Ovládání

O B S A H

1. Začínáme

1.1 Hlavní menu

1.2 Základní funkce IS BM

1.3 Činnosti

1.4 Procesy

1.4.1 Založení procesu

1.4.2 Prohlížení a vyhledávání informací

1.4.3 Pokračování v procesu

1.4.4 Modifikace struktury procesu a opravy

1.5 Operace (fyzická operace)

1.5.1 Kód po ukončení

2. Krok za krokem

2.1 Definice informační schopnosti

2.1.1 Diagram procesu

2.1.2 Otevřená období komponent

2.1.3 Volné karty

2.1.4 Objekty – nastavení

2.1.4.1 Nastavení – Souvislosti objektů

2.2 Poskytnutí informační schopnosti

2.2.1 Definice a stavba hlavního menu (výkazy, importy, napojení, procesy)

2.2.2 Personifikace a autorizace dat

2.2.3 Uživatelé, skupiny, práva

2.2.4 Stav systému

2.2.5 Předlohy výstupu

2.2.5.1 Využití předlohy

2.2.5.2 Metapředloha

2.2.5.3 Automatické užití předlohy

2.2.5.4 Výběry

2.2.5.5 Elektronický podpis

2.2.6 Výkazy

2.2.6.1 Sestavení výkazu

2.2.6.2 Definice výkazu

2.2.6.3 Proměnná dotazu

2.2.6.4 Definice listu výkazů

2.2.6.5 Šablona listů výkazů

2.2.6.6 Nastavení definice listu – užití přímé metody

2.2.6.7 Řádek definice listu výkazů

2.2.6.8 Sloupec definice listu výkazu

2.2.6.9 Příkaz „dyn“ v parametrech řádku nebo sloupce definice listu výkazů

2.2.6.10 Buňka definice listu

2.2.6.11 Formát buňky

2.2.6.12 Parametr (užívaný ve výkazech)

2.2.6.13 Parametr funkce výkazů

2.2.6.14 Atribut parametry ve výkazech

2.2.6.15 Výraz užívaný ve výkazech

2.2.6.16 Typ seznam hodnot užívaný ve výkazech

2.2.6.17 Vzorec užívaný ve výkazech

2.2.6.18 Funkce výkazů

2.2.6.19 Kód funkce výkazů

2.2.6.20 Nastavení definice listu pomocí vzoru listů výkazu

2.2.6.21 Zaokrouhlování ve výkazu

2.2.7 Obecné výběry

2.2.8 Nabídky

2.2.9 Importy

2.2.10 Balíčky

2.2.11 Prezentace artiklu, dokumentu

2.2.12 Dokumenty, předlohy, aplikace

2.2.13 Označování

2.2.14 Okno úloh

2.2.14.1 Nastavení stromu

3. Stáváme se odborníky

3.1 Volné karty – definice

3.2 Definice předlohy výstupu

3.2.1 Předlohy typu „sestava“ a „ostatní“

3.2.2 Předlohy typu „excel“

3.2.3 Předlohy typu „word“

3.2.4 Vzory výstupu

3.2.5 Profily spuštění

3.2.6 Logické tiskárny

3.2.7 Rychlý výstup (Excel, HTML)

3.3 Multipásová sestava

3.4 Uživatelské triggery

3.5 Doplňující vlastnosti formuláře

3.6 Funkce „automatické dokončování“

3.7 Doplňující položky menu objektů

3.8 Spojené dokumenty

3.8.1 Přehled o použití dokumentů

3.8.2 Dokumenty – verze

3.9 Funkce „Drag&Drop“

3.10 Informační panely

3.10.1 Materialized View

3.11 Parametry uživatele

3.12 Režim oprav

3.13 Nastavení programu BM

3.14 Nastavení sledování změn tabulek

3.15 Archivace

3.15.1 Popis archivací

3.15.2 Prohlížení archivu

3.16 Další možnost zadávání plnění úkolů

3.17 Odesílání e-mailů z BM s použitím objektu Outlooku

3.18 Sady vzdálených funkcí

Motto:

„Informační systém Bílý Motýl nemá chyby, vždy se jedná pouze o vlastnosti”.

Složka dokumentace OVLÁDÁNÍ, MENU, PRÁVA A VÝSTUPY je dokumentem vytvořeným ve společnosti BM Servis s.r.o. (tomu odpovídají vysvětlující poznámky a použité příklady). Jednotlivé hypertextové odkazy jsou zpracovávány tak, že v každé kapitole se snažíme mít hypertextový odkaz na určitý pojem vytvořen pouze jedenkrát (např. pokud je tedy v některé kapitole použit pojem „hlavní menu“ několikrát, je v textu vytvořen pouze jeden hypertextový odkaz na tento pojem). Toto opatření je proto, aby složky dokumentace nebyly „zahlceny“ odkazy do slovníku pojmů a uživatel si nekomplikoval čtení tím, že si stejný pojem spustí v jedné kapitole několikrát.

Pro seznámení se s každou složkou dokumentace se jako nejvhodnější způsob jeví elektronická podoba. Při čtení tištěné podoby uživatel musí mezi jednotlivými pojmy listovat, čímž částečně ztrácejí na efektu vytvořené hypertextové odkazy a uživatel se při listování a hledání pojmů „ztrácí“ a v některých případech je odkaz vytvořen na hesle, které nekoresponduje přesně s heslem ve slovníku pojmů, přičemž pojmově se jedná o shodná hesla, ale v textové podobě a listováním v dokumentaci toto uživatel nenajde. V elektronické podobě se uživatel pohodlně mezi jednotlivými hypertextovými odkazy přepíná a šipkou vrací zpět k původnímu heslu, což je jistě mnohem příjemnější a efektivnější způsob práce.

1. „Začínáme“

Tato úvodní kapitola by měla uživateli poskytnout přehled o základních vlastnostech informačního systému (dále jen IS) od prvního přihlášení se do systému přes jednotlivé funkční klávesy až k základnímu ovládání procesů. S informacemi obsaženými v této první kapitole přijde do styku každý běžný uživatel.

1.1 Hlavní menu

Práce s informačním systémem začíná pro uživatele přihlášením do systému, tzn. zadáním jména a vstupního hesla. Před prvním přihlášením je vstupní heslo uživateli předáno správcem systému. Původně je vygenerováno automaticky systémem (na základě zadaného jména a rodného čísla v činnosti „uživatelé programu“), správce může toto heslo samozřejmě následně změnit (praxe je taková, že správce pro jednotlivé uživatele vždy prvotní heslo mění, protože systém vygeneruje právě na základě zadaného rodného čísla ve většině případů těžko zapamatovatelnou kombinaci znaků). V případě, že by uživatel své změněné heslo nedopatřením zapomněl, může správce provést inicializaci hesla. Poté co se uživatel na základě hesla[1] přihlásí k IS, má k dispozici hlavní menu ve „svém“ jazyce, kde jsou pro něj dostupné činnosti na základě nastavených přístupových práv v oprávnění k činnostem.

Každý uživatel si pak následně může heslo změnit podle svých požadavků. V režimu přihlášení zadá své původní heslo a místo stisku OK si zvolí tlačítko „změnit heslo“. Následuje zadání nového uživatelského hesla. V případě, že uživatel toto své heslo zapomene, provede i v tomto případě správce inicializaci hesla.

Na základě těchto přístupových práv jsou tedy každému uživateli zpřístupněny jen odpovídající činnosti informačního systému a zároveň je možno do určité míry uživatelsky specifikovat vlastnosti některých funkcí (např. osobní maska, uspořádání dat na obrazovce, dostupnost událostí jednotlivých komponent, apod.).

IS BM je uživateli dostupný z pohledu Windows jako dvě úlohy (aplikace), přičemž první úloha představuje okno se systémem hlavního menu (aplikace menu) a druhou úlohu představuje okno (aplikace činnosti), ve kterém jsou uspořádána okna jednotlivých spuštěných činností IS BM. Případné spuštění a zobrazení diagramu procesu, spuštění slovníku dat, prohlížení dat jeho pohledem nebo jiné specifické funkce představují další úlohu (aplikaci Windows), kterou IS BM automaticky sám spouští. Pro uživatele tato vlastnost znamená, že na dolní liště PC má vždy zobrazenu ikonu s hlavním menu a ikonu, která představuje aktuálně spuštěnou činnost v IS BM. V případě spuštění např. diagramu procesu nebo slovníku dat se na dolní liště PC objeví ještě další ikona s odkazem právě na tyto spuštěné činnosti.

Zobrazení hlavního menu není nezbytně nutné, uživatel může IS ovládat i prostřednictvím činnosti Okno úloh (na základě jeho nastavení), pak by na dolní liště byla k dispozici jen ikona s aktuálně spuštěnou činností.

V případě, že uživatel potřebuje krátkodobě přerušit práci s informačním systémem, může využít možnosti kterou mu nabízí zablokování informačního systému a jeho opětovné odblokování pomocí vstupního hesla.

Hlavní menu se tedy skládá z jednotlivých skupin činností IS definovaných programovým kódem (např. marketing, účetnictví, obchod apod.) a položek menu, jejichž funkčnost vyplývá z uživatelských definičních dat (např. skupiny druhů procesů, uzly vývěsky apod.). Každou skupinu menu může uživatel „rozbalit“ (dvojklikem myši přímo na názvu skupiny a nebo stiskem znaménka plus před názvem skupiny) a tím má k dispozici činnosti této skupiny menu. Stiskem pravého tlačítka myši na každé skupině nebo na vlastní činnosti hlavního menu je možno vyvolat další funkční klávesy:

¨ vlastnosti (podrobně vysvětleno ve slovníku pojmů)

¨ kopírovat

¨ vrátit výchozí

¨ odstranit

¨ oprávnění k činnostem

¨ nastavení stromu

Jednotlivé činnosti uživatel spouští dvojklikem myši přímo na názvu činnosti nebo stiskem klávesy mezerník na názvu činnosti.

Z implicitního hlavního menu, dodávaného společně s IS („základní definice menu“) lze vytvořit „odvozená menu“. Uživatel má po přihlášení k informačnímu systému k dispozici to menu a v tom jazyce, v jakém stavu je měl při posledním odhlášení z informačního systému.

1.2 Základní funkce IS BM

Na úvod této kapitoly je vhodné zdůraznit, že všechny činnosti v informačním systému Bílý Motýl mají jednotné ovládání, tzn. že popis základního panelu nástrojů je shodný pro všechny činnosti (podrobný popis jednotlivých ikon panelu nástrojů je obsažen ve slovníku pojmů, v této dokumentaci je uveden pouze stručnější popis).

Ovládání informačního systému Bílý Motýl je plně kompatibilní se standardním ovládáním Windows, resp. Visual FoxPro. V případě, že uživatel nezná u některého prvku v IS jeho ovládání, bude postupovat stejně jako v kterékoliv jiné aplikaci Windows, tzn. umístěním kurzoru na tento prvek si nechá zobrazit informační text spojený s prvkem, použije dvojklik myši či pravý klik …, v podstatě lze využít standardní ovládací funkce Windows, které by každý uživatel PC měl již důvěrně znát.

Základní panel nástrojů:

¨ rychlé vyhledávání (klávesa Ctrl )

¨ třídící hledisko

¨ sestupné nebo vzestupné třídění formuláře

Ikony, určující způsob pohybu ve formuláři:

¨ přesun na první záznam

¨ přesun o jeden záznam zpět

¨ přesun o jeden záznam vpřed

¨ přesun na poslední záznam

¨ založení nového záznamu (klávesa F3) - vstup dat

¨ oprava daného záznamu (klávesa F4) – oprava dat

¨ zrušení daného záznamu (klávesa F8) – rušení dat

¨ vyhledávání v číselníku (klávesa F2, pravé tlačítko myši na „žluté“ položce)

¨ uložení daného záznamu (klávesa Ctrl W nebo Ctrl End, podobně funguje i klávesa ESC, po jejíž aktivaci následuje dotaz na ukončení činnosti)

¨ návrat zpět bez uložení provedených změn nebo bez zapsání daného záznamu

¨ tisk (klávesa Ctrl T) – zobrazí se nabídka předloh výstupu

¨ tabulka – režim úplného gridu, tj. zobrazují se pouze řádky.

¨ objekty – zobrazí se rámeček souvislostí objektů, kde je následně možno vyvolat k danému záznamu např. souvislost se zprávami nebo poštou apod.

¨ převzetí hodnoty (Ctrl Enter)

¨ ukončení dané činnosti

¨ vyvolání nápovědy

Základní panel nástrojů je tedy u všech činností stejný, jeho zobrazení však může být v daném okamžiku různé. Pokud si uživatel neumístí tento panel jinam (metodou uchopení panelu myší a přetáhnutí do levé, pravé či dolní části okna), zobrazuje se standardně pod horní lištou okna činnosti. V některých případech se stává, že uživatelé mají s umístěním panelu nástrojů problém (omylem si ho např. přetahují myší po okně apod.), pak je možno využít atributu v parametrech uživatelů „povolena změna pozice panelu nástrojů“. Pokud je tento atribut zatržen, uživatel má možnost si panel nástrojů přesouvat podle potřeby libovolně po okně, pokud zatržen není, panel nástrojů se uživateli zobrazuje standardně vždy pod horní lištou okna a nejde přesouvat.Vysvícené (čili aktivní; neaktivní ikony jsou zobrazeny šedivě) jsou pouze ty ikony a jejich funkce, které může uživatel v danou chvíli použít. Např. při zadávání nového záznamu je vysvícena ikona disketa (uložení), ale není přístupna ikona na opravu záznamu. U dalších popsaných používaných funkčních kláves je uživatele nutno upozornit, že ne všechny funkční klávesy jsou dostupné ve všech činnostech (stejně jako na panelu nástrojů nejsou vždy dostupné všechny ikony), vždy to vyplývá z kategorie činnosti a způsobu práce s ní:

¨ ESC – v případě prohlížení jakýchkoliv dat způsobí klávesa ESC zrušení tohoto prohlížení (pokud není v parametrech uživatele nastaveno jinak). V případě zápisu nebo opravy jakýchkoliv dat se systém po stisku klávesy ESC dotazuje „Zapsat data?“, v případě použití ESC při operaci v procesu se zaktivuje volba Nového procesu a možnost „Zapsat“ nebo „Zapsat a ukončit“.

¨ F10 – aktivace horní lišty (stiskem Enter je pak možno vyvolat nabídku menu volby, obecné apod.)

¨ Alt Q – nový dotaz s možností výběru vstupu definovaným na atributu „uchovat“.

¨ Ctrl + pravý klik myši – aktivace funkce automatického dokončování

¨ Ctrl + Home – používá se na textovém poli formuláře a vloží text do seznamu návrhů pro usnadnění dalšího vstupu. Nejprve se uživateli zobrazí dotaz: „Aktivovat funkci automatického dokončování pro pole „....“? Ano/Ne. Po volbě Ano se provede automatické vytvoření záznamu funkce automatického dokončování daného atributu pro daného uživatele s nastavením „naplnění seznamu návrhů“ na hodnotu Vstupem.

¨ Ctrl Q – zvolení nového výběru. Znovu se zobrazí záložka výběr s posledním nastaveným výběrem. Jednotlivé formuláře si pamatují hodnoty dvaceti naposledy zadaných výběrů od spuštění programu. Pomocí této klávesy je možno na výběrové záložce formuláře listovat mezi těmito zapamatovanými výběry.

¨ Ctrl O – činnosti související s označováním

¨ Ctrl D – vyvolání dokumentů (jen v objektech)

¨ Ctrl S – suma částek – uživateli se nabízí tabulka, kde je suma položek dané činnosti (jen v událostech)

¨ Ctrl T – vyvolání činnosti „Výstupy“ s předlohami výstupu (tzn. seznamu jednotlivých tiskových sestav dostupných v dané činnosti)

¨ Ctrl W - uložení záznamu (v panelu nástrojů ikona disketa)

¨ F6 – strom hlavního procesu (v událostech změny stavu peněz zastupuje klávesa F6 činnost přehled spárování)

¨ F7 – diagram procesu

¨ F9 – spuštění procesu nebo operace

¨ Page Down – potvrzení výběru (na základě zadaného výběru pak systém ukáže příslušné události v okně činnosti)

¨ Ctrl Page Up – posun záznamu na daném atributu směrem k začátku seznamu (tzn. pokud uživatel umístí kurzor např. na atribut komentář, po stisku Ctrl PgUp se posune o jeden záznam výše opět na atribut komentář)

¨ Ctrl Page Down – posun záznamu na daném atributu směrem ke konci seznamu (tzn. pokud uživatel umístí kurzor např. na atribut komentář, po stisku Ctrl PgDn se posune o jeden záznam níže opět na atribut komentář)

¨ Klávesa CTRL+SPACE (mezerník) na výběrové záložce formuláře na znakové položce vyvolává okno pro vstup delšího textu, tím je umožněno zadat delší text pro výběr v SQL dotazu v klauzuli LIKE.

¨ klávesa TAB – posun o další prvek na záznamu

¨ Shift TAB – posun zpět na předchozí prvek záznamu

Jakmile uživatel spouští proces, tak po zadání první operace v procesu se operace ukládá disketou nebo stiskem klávesy ESC. Při využití obou těchto možností se zobrazí okno „Nový proces“, kde je následující nabídka, tzn. systém automaticky pokládá tyto dotazy:

¨ Zapsat – zapíše se (uloží) daná operace a její stav je v tuto chvíli připravená a zahájená. Po zapsání této činnosti zůstane v okně činnosti stále zobrazena daná operace. Pro opuštění okna činnosti je možno použít klávesu ESC nebo křížek v pravém horním rohu daného okna a poté systém pokládá dotaz „Ukončit operaci?“ – Ano/Ne/Storno. Po potvrzení volby Ano je operace ukončena a automaticky se spouští další následující operace v procesu, po potvrzení volby Ne zůstává operace ve stavu připravená a zahájená. Storno provede pouze zrušení tohoto dotazu.

¨ Zapsat a ukončit – daná operace se zapíše a rovnou ukončí a zůstane ve stavu ukončená, tzn. že operace se uloží a rovnou ukončí, systém opustí dané okno činnosti a automaticky se spustí další následující operace (pokud je tak v diagramu procesu nastaveno; pokud není v diagramu připravena žádná další operace, systém se automaticky vrací do hlavního menu).

¨ Nezapisovat – daná operace se nezapíše, tzn. že zadání (její vyplnění) operace v okně činnosti se zruší.

¨ Storno – pouze se zruší tento dotaz v okně činnosti, zadání (vyplnění) operace zůstane zachováno.

¨ Opakovat vstup – zaškrtává se v případě, že uživatel zadává několik stejných druhů procesů za sebou (např. uživatel ví, že bude vystavovat několik faktur, čili spouštět stále stejný proces vystavení faktury). Tímto zatržením si zajistí, že po ukončení poslední operace prvního procesu automaticky nabíhá první operace dalšího, tj. nového procesu stejného druhu.

1.3 Činnosti

Než se budeme věnovat vlastnímu popisu nabídky informačního systému Bílý Motýl, pokusíme si vysvětlit logiku, podle které se veškeré činnosti v informačním systému dají rozdělit neboli kategorizovat. Uživateli se po přihlášení do systému zobrazí hlavní menu, kde má k dispozici velké množství činností, které si ještě podrobněji popíšeme, ale tyto činnosti je pro větší názornost (a podle způsobu práce s nimi) možno rozdělit do určitých kategorií:

¨ aktualizace – tj. činnosti, kde při realizaci procesů dochází ke změnám aktuálních hodnot (zadávání nového procesu nebo napojení se do procesu stávajícího)

¨ prohlížení událostí – tj. činnosti, které si uživatel může pouze prohlížet, není možné je editovat (procesy a operace)

¨ prohlížení AAA (aktér, artikl, alokace) – tj. činnosti, které je možno i aktualizovat – vstupovat, opravovat, prohlížet, rušit (např. umístění obchodu, artikly, adresář, sklady, pokladny, …)

¨ ostatní číselníky – stejně jako předchozí kategorii je možno je nejen prohlížet, ale i aktualizovat (např. státy, měny, PSČ, druhy procesů, druhy operací, …)

Činnosti představují funkce IS BM, které zajišťují zejména nastavení a naplnění informační schopnosti (aktualizace dat definičních i aplikačních) a následně její prezentaci (výstupy). K vybraným činnostem lze omezit dostupnost pro jednotlivé uživatele pomocí přístupových práv. Významnou část činností lze aktivovat formou spuštění listové položky hlavního menu, jiné lze aktivovat ovládacími prvky (menu, ikony, …) přímo z již jiných spuštěných činností.

Zřejmě nejčastěji přijde uživatel do styku s činnostmi typu „seznam“ (kromě aktualizace jsou obsaženy ve všech ostatních výše vyjmenovaných kategoriích), které zobrazují v okně činností data a informace formou seznamu ve struktuře dané zejména programovým kódem. Tyto činnosti jsou standardizované z hlediska ovládání, formy zobrazení i související funkčnosti.

Rozsah dat, který se uživateli zobrazí po spuštění takové činnosti je určen výběrem (tj. záložka výběr), který se aktivuje jako první. Uživatel je tedy po spuštění činnosti vyzván nejprve k definici výběru, který může být předplněn podle parametrů uživatele, podle souvislostí vyplývajících ze způsobu spuštění (např. z daného záznamu jiné činnosti) či podle výběru spojeného s položkou menu. Výběrovou záložku je možno pro uživatele ještě dále modifikovat, a to nastavením výběru záznamů u jednotlivých atributů.

V případě, že uživateli k určení rozsahu dat, která chce mít zobrazena, nestačí právě záložka výběr, je možno použít ještě obecný výběr, který se uživateli nabízí jako atribut ve tvaru překryvného seznamu na výběrové záložce.

Při zadávání výběru může uživatel využít všechny atributy, které mu výběr nabízí, takže pokud např. nezná přesný název adresáta a zná jméno pracovníka, který v dané firmě pracuje, tak může vyhledávat i podle jména pracovníka apod. Při jednoduchém hledání se např. zapíše pouze část názvu firmy a uloží se výběr nebo pouze počáteční písmeno apod. Zadaný výběr se potvrzuje klávesou PgDn nebo ikonou disketa z panelu nástrojů. Na výběrové záložce je možno využít i nastavení zobrazování ikon seznamu hodnot (možno pak vybírat z překryvného seznamu nabízených hodnot). Při složitějším výběru je možno hledané výrazy zapisovat do jednotlivých výběrových atributů těmito způsoby:

¨ % - nahrazuje jakýkoliv znak, tzn. uživatel hledá název firmy, o kterém neví, jak začíná, nicméně ví, že obsahuje slovo „stavební“. Pak do názvu firmy ve výběru zadá „%stavební“ a systém mu vyhledá všechny firmy, které na jakémkoliv místě ve svém názvu mají slovo stavební. Stejné je to i s jinými výběrovými atributy. Pokud tedy uživatel u některého výběrového atributu neví přesně, jakým způsobem je v systému zadán (pokud ví jistě, že firmu např. Compaq má v systému zadanou jako Compaq, není nutno před název firmy psát %, ale napíše rovnou začáteční písmena názvu firmy) je vhodné využít jako první výběrový znak právě % a za něj napsat výraz, který hledáme. I v případě, že uživatel rovnou napíše název firmy, systém přesto automaticky na konec tohoto zadaného slova přiřazuje znak % (uživatel ho tam tedy nepíše, ale systém si ho při vyhledávání přiřazuje sám)

¨ xx % - při vyhledávání podle přesně zadaného slova (tzn. je napsán hledaný výraz, mezera, procento). Tímto způsobem je pak při hledání např. výrazu „servis %“ zajištěno, že systém bude hledat opravdu jen a právě výrazy „servis“ a nikoliv i výrazy, které mají výraz „servis“ použitý kdekoliv ve svém názvu.

¨ _ - podtržítko nahrazuje právě jeden vybraný znak, např. uživatel má zadáno „diskuse“, ale i „diskuze“. Uživatel potřebuje najít jak výrazy s použitým „s“, tak i výrazy s použitým „z“, pak je výběr zapsán takto „disku_e“. Jinými slovy podtržítko nahrazuje na dané pozici jakýkoliv znak. Pokud se jako uživatel rozhodnu, že chci vybrat všechny firmy, které mají na 3. pozici v názvu písmeno A, tak zadám výběr takto: _ _ a %, tzn. první dvě místa cokoliv, na třetí pozici písmeno A a dál může něco být nebo nemusí.

¨ [] - hranaté závorky umožňují vybrat na zvolené pozici znak nebo množinu znaků, např. máme zapsáno kurz, ale i kurs. Chci vyhledat oba tyto výrazy, pak napíšu „kur[sz] a systém najde obě dvě varianty. Když bychom si tento výběr uvedli na příkladu čísel, pokud do závorek zadáme např. [56], systém bude hledat buď 5 nebo 6, pokud to bude zadáno [4-6], systém vyhledává 4 nebo 5 nebo 6.

¨ [^] - znaky uvedené v takové hranaté závorce znamenají, že systém má na zvolené pozici vyhledávat vše kromě uvedených, tzn. negace výběru. Např. pokud je zadáno [^4-6], systém na daném místě vyhledá znaky kromě 4 nebo 5 nebo 6.

Tyto výběrové možnosti je samozřejmě možno libovolně kombinovat, nutno však mít na zřeteli, že prostor pro zapsání výběrového výrazu je dán velikostí pole.

Na záložce výběr je pro uživatele navíc dostupný funkční přepínač „uchovat“, který způsobí, že výběr, který si uživatel právě nadefinoval bude uchován a při příštím spuštění dané činnosti a aktivaci záložky výběr bude takto automaticky předplněn. Po stisku pravého tlačítka myši lze definovat a zároveň používat již nadefinované „výběry vstupem“.

Již v dřívější části této dokumentace jsme se zmínili, že veškeré činnosti hlavního menu se spouštějí dvojklikem myši nebo stiskem klávesy mezerník přímo na názvu dané činnosti. Zároveň bylo i vysvětleno, že ve většině případů se uživateli nabízí nejprve záložka výběr. I další ovládání činností v jednotlivých oknech má určité standardy:

¨ pokud uživatel přesně neví, co který atribut ve výběru nebo v okně činnosti znamená, do určité míry mu toto objasní popis zobrazený v dolní části okna, tzv. message (kurzor musí být umístěn na daném atributu)

¨ v určitých případech daných způsobem aktivace činnosti je výzva k zadání výběru potlačena a výběr je fakticky dán programovým kódem. U některých činností je možno na základě nastavení v parametrech uživatele tento výběr vědomě potlačit.

¨ ve většině činností je k dispozici tučně zvýrazněný atribut, tzv. návěští (label). Po stisku pravého tlačítka myši na tomto atributu se uživateli zobrazí okno s nabídkou událostí a aktuálních hodnot, které jsou na daném atributu dostupné, např. v adresáři je tučně zvýrazněn Adresát – po stisku pravého tlačítka myši má uživatel k dispozici informace o událostech adresáta, aktuálních hodnotách, adresách, spojení apod. nebo v událostech skladové evidence je tučně zvýrazněn Artikl – po stisku pravého tlačítka myši má uživatel k dispozici informace o množství artiklu na skladech, ceníku artiklu apod. Mírně odlišně funguje label Téma v událostech vývěsky. Na tomto labelu nefunguje pravé tlačítko myši a tudíž nezobrazuje žádné další informace o tématu, ale po dvojkliku na tomto labelu se zobrazí události vývěsky pouze toho tématu, na kterém byl aktivován dvojklik. Po stisku tlačítka „návrat k předchozí“ (dolní část okna činnosti události vývěsky) se uživatel vrátí do původního zobrazení událostí vývěsky.

¨ na každé datumové položce se uživateli po stisku klávesy F2 nebo pravého tlačítka myši zobrazí kalendář.

¨ na každé numerické položce se uživateli po stisku klávesy F2 nebo pravého tlačítka myši zobrazí kalkulátor.

Vybraná data (po potvrzení výběru – ikona disketa nebo klávesa Page Down) se uživateli v každé činnosti nabízejí jako seznam v samostatném okně umístěném v okně činností IS BM.

Toto okno s vybranými daty obsahuje sdílené ovládací prvky - horní lištu obrazovky, panel nástrojů, případné zapnuté tooly (objektové vazby, uživatelsky definované nabídky, nabídka aktivních oken, okno úloh apod.).

Horní lišta obrazovky a panel nástrojů se uživateli standardně nabízí v každém okně nezávisle na spuštěných činnostech. Stejně jako v panelu nástrojů jsou pro uživatele vysvíceny pouze aktivní ikony v souvislosti s daným oknem, tak i v horní liště pod jejími jednotlivými nabídkami (volby, obecné apod.) má uživatel k dispozici pouze ty činnosti, které jsou pro danou činnost v okně aktivní, tzn. jsou uživateli dostupné, ostatní jsou šedivé a nepřístupné (resp. pokud pro danou činnost nemají smysl, nezobrazují se vůbec).

Případné zapnuté toolbary (tzn. okna s ikonami, tlačítky) se uživateli nabízejí jako:

¨ nabídka aktivních oken – zda se má nabídka aktivních oken uživateli zobrazovat či nikoliv se určí v parametrech uživatele zaškrtnutím parametru „zobrazovat nabídku aktivních oken“. Pokud je zaškrtnuto, znamená to, že se uživateli v okně činnosti zobrazuje okno s informacemi o právě aktivně spuštěných oknech. Stiskem jednotlivých tlačítek v tomto okně je možno tyto spuštěné činnosti rovnou aktivovat čili se mezi nimi přepínat.

¨ uživatelsky definovaná nabídka – zobrazuje se uživateli tehdy, pokud je aktivována (tzn. pod menu Obecné – Nabídky – je zaškrtnuta jedna nebo více vytvořených nabídek). Taková nabídka se pak nabízí v dolní části okna jako samostatné okno s přehledem činností, které jsou nadefinované v dané nabídce. Pod menu Obecné – Nabídky může uživatel zároveň aktivně využívat i činnost vazby míry plnění. Jako součást nabídek je možno využít i činnost okno úloh (po jeho aktivaci se spustí samostatné okno).

¨ objektové vazby

Pro činnosti, které jsou typu „událost“ (např. události obchodu, plateb, skladu apod.), obvykle platí, že v horní polovině okna činnosti je seznam jednotlivých záznamů a v dolní polovině jsou podrobnosti k právě aktuálnímu záznamu z horní poloviny okna, čili záznamu, na němž je umístěn kurzor. Pro činnosti, o nichž je možno říci, že nejsou typu událost (např. přehled procesů a operací, ale i přehled obchodovatelného nebo skladovaného artiklu apod.) obvykle platí, že v levé polovině okna činnosti je seznam jednotlivých záznamů a v pravé polovině jsou podrobnosti k právě aktuálnímu záznamu z levé poloviny okna, čili záznamu, na němž je umístěn kurzor. Z tohoto režimu zobrazení záznamů je možné se přepnout do režimu „databázového“, kdy jsou záznamy zobrazeny pouze řádkově (ikona tabulka v panelu nástrojů).

Kromě vlastních dat mohou být v okně činnosti zobrazeny informace o počtu vybraných (označených) záznamů na dolní liště a další ovládací prvky, např.: záložky na horním okraji okna či návěští (labely) atributů, pod kterými má uživatel k dispozici další příslušné údaje vztahující se k danému atributu.

Okno každé činnosti je v dolní části rozděleno do třech částí, které zleva doprava znamenají:

¨ levá část poskytuje uživateli informace o počtu vybraných záznamů. Dvojklikem levého tlačítka myši na tomto poli uživatel aktivuje funkci „znovu načíst“ (stejná činnosti jako pod menu Obecné). Klik na pravém tlačítku myši na tomto poli způsobí aktivaci menu Volby.

¨ prostřední část poskytuje uživateli informace o počtu označených záznamů. Dvojklikem levého tlačítka myši na tomto poli se uživateli zobrazí právě tyto označené záznamy. Opětovným dvojklikem se uživatel vrátí zpět do původního zobrazení. Klik na pravém tlačítku myši na tomto poli způsobí aktivaci menu Volby.

¨ pravá část poskytuje uživateli informace o použitém obecném výběru (pokud je nějaký použit). Dvojklikem levého tlačítka myši se uživateli zobrazí seznam všech nadefinovaných obecných výběrů dané činnosti. Uživatel si tímto způsobem může vybrat i jiný obecný výběr. Opětovným dvojklikem se uživatel vrátí zpět do původního zobrazení.

Způsob zobrazení a setřídění údajů na obrazovce je možno do určité míry ovlivnit i uživatelsky, a to nastavením třídění, pořadím a šířkou jednotlivých sloupců seznamu (způsob zobrazení a setřídění údajů v okně je možno uchovat nastavením v činnosti parametry formuláře). K nastavení třídění slouží uživateli ikona třídění v panelu nástrojů, pořadí a šířku jednotlivých sloupců seznamu si určí uživatel mechanicky – jednoduchou metodou systému Windows „táhni a drž“, čili je nutno si umístit kurzor na daný název sloupce a po stisku levého tlačítka myši ho pak přesunout na zvolené místo v seznamu. V případě potřeby nastavení šířky sloupců se postupuje tak, že ukazatel myši míří na pravý nebo levý okraj sloupce, kde se objeví malá černá šipka a pomocí stisku levého tlačítka myši a přetažení čáry na zvolené místo je upravena šířka sloupce. V menu Obecné v parametrech formuláře je možno toto změněné nastavení následně uchovat (stejně jako je zde možno uchovat i nastavené setřídění obrazovky). Pravý klik myši přímo na názvu vybraného sloupce provede setřídění podle tohoto atributu, tzn. je možno obrazovku třídit nezávisle na tom, jaké třídící hlediska nabízí uživateli panel nástrojů. Toto okamžité ruční setřídění se však ani po volbě „uchovat“ v parametrech formuláře neuchová.

V parametrech formuláře je možno pomocí atributu uchovávat pozice oken zaznamenávat pozice oken formulářů a rozlišení monitoru pro jednotlivé uživatele. Při následujícím spuštění daného formuláře je pak jeho okno zobrazeno v zaznamenané pozici. Způsob zaznamenávání pozice okna a rozlišení monitoru je dán nastavením atributů v parametrech uživatele a v parametrech daného formuláře.

V jednotlivých činnostech pod menu Obecné je možno nadefinovat i doplňující vlastnosti formuláře.

Do atributů formulářů, které jsou víceřádkového typu (např. poznámka, komentář, tzn. memo pole) je možno zapisovat i hypertextové odkazy na vybranou internetovou adresu (ve tvaru např. http://www.bm.cz). Tyto napsané odkazy jsou následně zvýrazněny modrým písmem a aktivují se stiskem klávesy CTRL+KLIK pravého tlačítka myši. Po jejich stisku dojde k vyvolání internetového prohlížeče s přechodem na odpovídající odkaz.

Zobrazenými záznamy (řádky) v seznamu je možno listovat s posunem kurzoru (ovládaným z klávesnice nebo myší) po záznamu, stránce nebo na začátek či konec seznamu (popsané ikony se šipkami v panelu nástrojů) nebo bez posunu kurzoru posuvníkem (ovládaným myší). Podle vlastností daného záznamu s kurzorem a jeho souvisejících vztahů jsou zobrazovány příslušné informace k nim (např. signalizace objektových vazeb v rámečku souvislostí či vazeb mírou plnění i obsah záznamů jimi vztažených, údaje na volné kartě, dokumenty apod.). Jinými slovy to znamená, že např. při listování záznamy (posunem kurzoru po nich) na vývěsce se uživateli zobrazují v pravé části okna atributy daného záznamu, případné zobrazené objektové vazby (znaménko plus v rámečku souvislostí) poskytují uživateli informace, zda s daným záznamem vývěsky není svázán např. dokument nebo zpráva apod. Stejné je to i s údaji volných karet, použitých např. u skladových karet. Při pohybu po jednotlivých skladových kartách se události v okně se zobrazenou volnou kartou (např. množství artiklu na skladu, rezervované množství apod.) automaticky mění podle aktuální skladové karty (tzn. uživatel se pohybuje kurzorem po jednotlivých skladových kartách a na základě toho se mu mění údaje v okně s volnou kartou).

Vybrané činnosti je navíc možno zobrazit v samostatném okně i ve stromovém vyjádření. Jedná se o zobrazení, kde jsou jednotlivé činnosti (nebo operace) pod sebou názorně navěšeny tak, jak spolu souvisí nebo jak byly časově zpracovávány. V činnosti adresář (nebo pod labelem adresát) je možno si spustit strom adresáta. V činnosti kompletní vývěska je možno si spustit strom vývěsky. Průběh procesu a jeho rozpracovanost je možno si zobrazit stromem hlavního procesu. U těchto výše vyjmenovaných činností je možnost zobrazit si strom činnosti umožněna implicitně programem, ostatní činnosti je v případě potřeby možno uspořádat do stromu, který si uživatel vydefinuje sám. Umožňuje mu to činnost obecné stromy, která je pro uživatele dostupná v hlavním menu v Informačním centru – Typy a řady.

Jak jsme se již výše zmínili, po spuštění většiny činností se nejprve aktivuje záložka výběr. Tímto výběrem je jako prvním zúžena množina zobrazovaných záznamů. Součástí tohoto výběru je i obecný výběr, který může ještě zúžit množinu dat, která se vybírají běžným způsobem. Pokud má uživatel k dispozici již zvolenou množinu dat, může využít další způsoby vyhledávání.

Všechna zobrazená data je možno nejen prohlížet, třídit, editovat, ale v případě potřeby i tisknout. Po stisku ikony tiskárna v panelu nástrojů nebo po stisku funkční klávesy Ctrl T se zobrazí dialog tisku a možnost výběru vhodné tiskové sestavy. Dále je zde možné specificky pro každou činnost například aktivovat funkce stiskem příslušné ikony na panelu nástrojů, například pro zmíněný výstup vybraných dat nebo pro opravu či zrušení záznamu, pro získání pomoci formou helpu, pro aktivaci panelu s objektovými vazbami nebo další funkce pro aktivaci souvisejících činností.

Po ukončení činnosti se IS BM dostane z hlediska ovládání do stavu, ve kterém byl před aktivací této činnosti (tedy např. zpět do hlavního menu nebo zpět do činnosti, ze které uživatel vyvolával další příslušné informace) anebo do stavu, ve kterém je automaticky spuštěna předdefinovaná následující činnost (např. při běhu procesu, kde je po ukončení dané operace nastaveno, že další operace se má spouštět automaticky).

Související činnosti se obvykle aktivují z menu horní lišty ( to je specifické pro každou činnost), z disponibilních toolů (např. dokumenty, vazby míry plnění nebo objektové vazby) nebo ovládacími ikonami (např. informace o adresátovi či artiklu na jejich tučném návěští).

Každá činnost, jejíž data jsou právě zobrazena, nabízí uživateli v horní liště v menu Volby a Obecné příslušné související činnosti. K dispozici (čili vysvíceny) jsou ty činnosti, které může uživatel použít právě v souvislosti s danou činností. V menu Jazyk má uživatel k dispozici:

¨ implementované jazyky, do kterých se lze přepnout z hlediska cizojazyčných dat (pouze v těch činnostech, které prezentují přeložitelná data),

¨ režim oprav, umožňující přeložit popisy položek do aktivního (zapnutého v hlavním menu) jazyka.

1.4 Procesy

Tato kapitola se již netýká ovládání jako takového, čili jak se chovají které činnosti a proč, ale ovládání konkrétní části informačního systému a to jsou procesy. V prvé řadě bychom si měli objasnit, co to v IS BM proces je. Proces je obrazem reálného světa vytvořeným posloupností operací, které jsou si obvykle věcně i časově blízké. Příkladem takového klasického procesu může být např. proces vystavení faktury. Skládá se z několika operací, které spolu souvisí a tudíž jsou pomocí diagramu procesu sestaveny do jednoho procesu (tzn. objednávka - dodání – DPH – platba). V IS BM jsou procesy, které jsou si podobné, modelovány druhem procesu.

Každý jednotlivý proces je tedy určitého druhu. Procesy stejného druhu mají řadu shodných vlastností, které jsou zachyceny v definici každého druhu. Jednotlivé druhy procesů se definují v činnosti druhy procesů. Právě na základě definice druhu procesu pak fyzický proces v okamžiku založení, tj. zápisu první události do jeho první operace, „dědí“ strukturu podle svého druhu procesu.

Fyzický proces je modelem jedinečného výskytu procesu v reálném světě. Představuje datovou strukturu zobrazenou pro uživatele například uzly a vazbami v diagramu nebo stromem procesu. Fyzický proces tedy představuje datovou strukturu předkládanou uživateli například uzly a vazbami v diagramu nebo stromem procesu, do které jsou uspořádaně ukládány údaje jednotlivých událostí z různých komponent.

1.4.1 Založení procesu

V okamžiku založení, tj. zápisu první události do jeho první operace, fyzický proces „dědí“ strukturu dle svého druhu procesu včetně pravidel pro datový tok ( automatizace vstupu dat ) a pro řídící tok ( stavy a aktivace uzlů ), dle kterých se pokračuje v zápisu dalších dat procesu, resp. v úpravě struktury procesu (pokud je v diagramu procesu nadefinováno, že po ukončení první operace procesu se má např. na pozadí automaticky spustit, vytvořit a ukončit následující operace, je po ukončení první operace v procesu toto zahájeno). Jednotlivé vytvořené fyzické procesy jsou uživateli k dispozici v hlavním menu v činnosti Procesy a operace – Procesy.

Zahájení procesu, tj. zápis události do první operace procesu, je možno provést dvojím způsobem:

1. samostatně – tzn. daný proces se spouští poprvé. Spustit vybraný proces je možno:

¨ výběrem ze skupinové položky hlavního menu Nový proces (u druhu procesu je definován název skupiny, pod kterým má uživatel tento proces ve skupině Nový proces hledat)

¨ po stisku klávesy F9 přímo na druhu procesu (menu Informační centrum – Typy a řady – Druhy procesů)

2. napojením v rámci již existujícího procesu - tzn. daný proces je uzlem jiného druhu procesu (tj. vnořený proces). Toto je možno provést:

¨ v činnosti Procesy (Procesy a operace – Procesy) vyhledáním existujícího procesu a spuštěním jeho stromu hlavního procesu (klávesa F6). V tomto stromu je pak možno vnořený proces spustit ručně, tj. stiskem pravého tlačítka myši na názvu vnořeného procesu a volbě „spustit operaci“. Tímto se aktivuje první operace vnořeného procesu.

¨ v činnosti Procesy (Procesy a operace – Procesy) vyhledáním existujícího procesu a stiskem záložky Operace procesu. Definice vnořeného procesu je napsána velkými písmeny a po stisku klávesy F9 na názvu vnořeného procesu se aktivuje jeho první operace.

¨ v činnosti Procesy (Procesy a operace – Procesy) vyhledáním existujícího procesu a spuštěním jeho diagramu procesu (klávesa F7). V diagramu je pak nutno umístit kurzor na uzel vnořeného procesu a v horní listě zvolit ikonu „spustit operaci – poprvé“. Aktivuje se první operace vnořeného procesu.

¨ nastavením výběru ve vlastnostech kopie činnosti operace – tzn. zkopírováním si činnosti operace, přesunutím si ji do vlastní vybrané skupiny v hlavním menu, v jejích vlastnostech změnit název a nastavit výběr (komponenta – procesy, operace – identifikace procesu, zobrazit – připravené – nezahájené). Po aktivaci takové činnosti se zobrazí přehled vnořených procesů, které mají připravenu první operaci a po stisku klávesy F9 na každém z nich se proces spustí, čili se aktivuje první operace procesu.

¨ napojení do již existujícího procesu je možno provést i referenčním procesem, dynamickým spojením nebo pomocí definice vyvolání.

Založením procesu je jeho první operace uvedena do stavu zahájena. V případě, že založený proces je uzlem v nadřazeném procesu, tak na základě uživatelského nastavení vazeb (tzn. po stisku pravého tlačítka myši na šipce mezi jednotlivými uzly) mohou být z hlediska těchto vazeb cílové uzly uvedeny do stavu připravena.

Založení procesů lze automatizovat aktivací uživatelské definice procesního importu ze skupinové položky hlavního menu IMPORT DO PROCESU na základě dat získaných importem.

Pro automatizaci vstupu dat jsou k dispozici různá uživatelská nastavení, tzn. že při zahájení procesu (jakýmkoliv výše popsaným způsobem) může uživatel využít možností předplnění jednotlivých atributů pro ulehčení své práce. K tomuto slouží především šablony a masky, popř. šablony spojené s importem dat. Pro automatizaci vstupu dat jsou dále k dispozici transformace, které určují způsob naplnění jednotlivých atributů z daného uzlu do atributů dalšího uzlu v rámci procesu. V rámci transformací lze u fyzických procesů využit i možnosti, kterou uživateli nabízí činnost korektor.

V okamžiku založení procesu je mu a všem jeho uzlům přiřazena jednotná identifikace, tzn. číslo procesu ve tvaru např. 2002-01-98000208. Tato uživatelská identifikace se skládá z následujích údajů:

¨ rok – podle data v první zapsané událost,

¨ IDÚ – podle identifikace datového úložiště, kde došlo k zahájení procesu

¨ pořadové číslo – podle nastavení číselné řady u druhu procesu

Číselná řada představuje evidenční knihu reálného světa, kde jsou doklady (v IS procesy) ukládány pod svými pořadovými čísly, které se jim přidělují z intervalu vymezeného touto číselnou řadou. Do jedné knihy může být současně zařazeno více druhů dokladů (procesů)[2]. Číselné řady se definují v činnosti Informační centrum – Typy a řady – Číselné řady. Při definování druhu procesu se pak každému druhu přiřazuje právě jedna číselná řada.

Číslování procesů odpovídá v IS BM i číslování dokladů, např. pokud máme proces faktury, který má přidělen určitou číselnou řadu, má vytištěný doklad faktura shodné číslo s touto číselnou řadou. Toto číslování je samozřejmě nutno náležitě definovat v příslušné předloze výstupu. Do jedné evidenční knihy je možno přiřadit více druhů procesů. U každé číselné řady se vstupují tyto atributy:

¨ řada – identifikace číselné řady (měla by např. souviset s komponentou, pro kterou je číselná řada tvořena – usnadňuje pak snadnější vyhledávání v přehledu číselných řad)

¨ popis – výstižný popis číselné řady

¨ začátek a konec intervalu – uživatel si z číselníku vybere začátek a konec intervalu pro danou číselnou řadu. Při výběru intervalu má uživatel k dispozici i činnost „volné intervaly“(pod menu Volby), která mu vypíše přehled dosud neobsazených, tj. volných intervalů. Číslo z tohoto intervalu se stává součástí identifikace procesu.

Zde je nutno uživatele upozornit na atribut „aktuální“, který je přístupný na záložce „číselné řady v letech“. Tento atribut poskytuje uživateli informaci o posledním použitém čísle ve fyzických procesech. Systém se chová tak, že při číslování procesů automaticky najde poslední použité číslo v přehledu fyzických procesů a vždy přidělí číslo o jedna vyšší.

Vyhledávání podle identifikace číselné řady je možné ve výběru v činnosti „druhy procesů”, kde je identifikace číselné řady dostupná i jako atribut přímo na oknech. V okně je identifikace číselné řady dostupná i v činnosti „procesy”, vyhledávat podle ní zde však nelze.

Všechna data procesů lze vyhledávat, prohlížet či opravovat . K navigaci strukturou procesu jsou určeny diagram procesu , strom procesu nebo záložky „Operace procesu“ v činnosti Procesy (menu Procesy a operace). Další informace o stavu jednotlivých operací v procesu uživateli poskytuje např. činnost „ průběh operací “.

1.4.2 Prohlížení a vyhledávání informací

Přehled všech dosud vytvořených procesů má uživatel k dispozici v činnosti Procesy (rovněž i v činnosti Operace, kde jsou k dispozici všechny jejich uzly) pod skupinovou položkou hlavního menu PROCESY A OPERACE, kde je do jisté míry patrná i struktura a stav procesu (v činnosti Procesy je možno na záložce „operace procesu“ vidět všechny operace, které jsou obsaženy v tomto procesu a na základě jejich barevného označení je možno rozpoznat i to, zda už jsou tyto operace zahájeny nebo ukončeny – ukončené operace jsou zvýrazněny černou barvou) nebo zda jsou tyto operace zatím ve stavu připravena (zvýraznění modrou barvou).

Po aktivaci činnosti Procesy (i Operace) se uživateli nabídne k nadefinování nejprve záložka Výběr, kde si může zadáním jednotlivých atributů zvolit následující zobrazenou množinu dat. Lze vybírat např. podle čísla procesu, druhu procesu, identifikace a názvu adresáta, data vzniku procesu apod.

Informace o struktuře a stavu procesu (resp. stavu jeho jednotlivých uzlů) jsou uživateli poskytovány pomocí diagramu procesu nebo stromu hlavního procesu. Diagram i strom procesu jsou k dispozici ve všech přehledech procesů, přehledu operací, ve všech událostech procesu a ve všech operacích procesu. Lze je aktivovat jako související činnost a jsou dostupné na funkční klávesu F7 (diagram procesu), F6 (strom hlavního procesu) nebo jako samostatná činnost pod menu Volby.

Ze stromu hlavního procesu či záložek operací v přehledu procesů lze zobrazit (aktivovat související činnost) události jednotlivých operací procesu a ve vlastnostech operace (menu Volby) informace o jejich stavu. Ze stromu procesu se jednotlivé operace spouští dvojklikem myši na dané operaci a nebo volbou „spustit operaci“ po stisku pravého tlačítka myši na dané operaci. Na záložce „operace procesu“ se jednotlivé operace spouští po stisku klávesy F9 nebo z menu Volby aktivací činnosti „spustit operaci“. Při aktivaci diagramu procesu je informace o stavu operace viditelná přímo na každém uzlu diagramu procesu (zatrženo připravena – zahájena – ukončena). Po aktivaci uzlu procesu (tzn. dvojklikem na daném uzlu nebo stiskem ikony „spustit operaci – již vytvořenou“) má pod menu Volby uživatel rovněž k dispozici činnost „vlastnosti operace“.

Po spuštění vlastností operace (z každé činnosti je toto možno různým způsobem – viz. popis v odstavci výše) se uživateli zobrazí tabulka s názvem procesu a dané operace a informace o jejím stavu, tzn. zda je připravena, zahájena, ukončena nebo předběžně ukončena. Je zde vidět datum zahájení i ukončení operace a adresát, kterého se daná operace týká. V dolní části obrazovky jsou k dispozici následující tlačítka:

¨ OK – potvrzení změny nebo zrušení stavu ukončena

¨ Diagram – možnost vyvolání diagramu procesu, ve kterém je obsažena daná operace

¨ Strom – možnost vyvolání stromu hlavního procesu, ve kterém je obsažena daná operace

¨ Zrušit stav ukončena – v případě potřeby je možno u ukončené operace zrušit stav ukončena

Ve vlastnostech operace může uživatel použít i záložku „operace v procesu“, kde má k dispozici přehled všech operací procesu, ve kterém je obsažena daná operace a zároveň stavy těchto operací.

V případě, že se uživatel v některém okamžiku provádění procesu „ztratí“, např. zkolabuje PC, systém ohlásí uživatelskou chybu a proces ukončí, uživatel provede nějaký nestandardní úkon a vrátí se zpět do hlavního menu apod., v takovém případě uživateli pomůže činnost průběh operací. Je možný dvojí způsob práce:

¨ zobrazit si přímo činnost „průběh operací“ – menu Procesy a operace – Průběh operací

¨ není nutno se snažit napojovat zpět do činnosti, ve které došlo k přerušení, stačí aktivovat jakoukoliv činnost (např. události některé komponenty nebo činnost Adresář), kde si pak uživatel pod menu Obecné najde činnost Průběh operací. Zobrazí se mu tabulka, kde má k dispozici přehled své dosud provedené práce, přičemž na poslední řádce jasně vidí, ve které operaci došlo k přerušení a v jakém stavu daná operace je. Dvojklikem na této operaci se do ní uživatel znovu automaticky napojí a může pokračovat dál v procesu. Průběh operací však není možno využít ve chvíli, kdy dojde k takové chybě, že uživatel je nucen opustit systém Bílý Motýl, po ukončení systému se totiž činnost průběh operací nuluje, tzn. funguje na systému od přihlášení do přihlášení.

V činnostech procesy, operace (menu Procesy a operace) nebo v událostech jednotlivých komponent je možno definovat výběr za druh procesu nebo za uživatelskou identifikaci procesu. V činnosti operace (seznam uzlů) je možno vybírat navíc podle stavu operace (uzlu). K vyhledání procesů podle jejich stavu je možno využít také semafor procesu nebo saldokontní hodnoty. Pokud je k uzlu typu operace připojena zpráva, lze ji přímo ze zprávy spustit, tj. zobrazit její události.

1.4.3 Pokračování v procesu

Pokračováním v procesu se rozumí zápis těch událostí do datové struktury procesu, které nebyly zapsány v okamžiku založení procesu. Pokračování v procesu může být aktivováno:

¨ automaticky po ukončení operace na základě uživatelského nastavení (tzn. že v diagramu procesu je nastaveno, že další uzel se automaticky spustí po ukončení uzlu předchozího),

¨ uživatelským rozhodnutím kdykoliv (uživatel se vědomě napojí do vybrané části již zahájeného procesu).

Automatické pokračování procesu je dáno uživatelským nastavením v diagramu procesu, resp. druhu procesu ve vlastnostech uzlů a vazeb mezi nimi. Automatické spuštění pokračování procesu, tj. automatické spuštění (případně spuštění na pozadí) činnosti pro vstup událostí do některé operace procesu, se aktivuje při ukončení operace (resp. při zahájení procesu, který je uzlem jiného (předcházejícího) procesu, nebo při ukončení jeho první operace s vlastností „ukončuje proces“) tímto algoritmem:

¨ na základě vyhodnocení vazeb mezi uzly a kódu po ukončení operace jsou dané uzly uvedeny do stavu připravena,

¨ uzel uvedený do stavu připravena, který má současně ve svých vlastnostech nastaveno spouštět automaticky (musí platit, že přihlášený uživatel má právo zápisu k danému druhu operace) nebo na pozadí (zde není nutné přístupové právo), se zaznamená do zásobníku operací,

¨ podle operací (uzlů) zapsaných do zásobníku operací se automaticky aktivují činnosti pro vstup událostí do jeho vyčerpání v pořadí daném metodou „zásobník“; uživatel má možnost v zásobníku pořadí spuštění ovlivnit, např. v případě vytváření dávkových operací se rovněž aktivně používá zásobník operací, tzn. uživatel spustí první dávkovou operaci a další se automaticky „předpřipraví“ do zásobníku operací a pak se uživateli automaticky nabízejí ke zpracování. Může však nastat situace, že uživatel potřebuje proces zpracování dávkových operací přerušit nebo úplně skončit, tzn. musí dosáhnout toho, aby se mu předpřipravené operace stále nenabízely ze zásobníku operací. V tomto případě si musí aktivovat činnost zásobník (menu Obecné) a po aktivaci tlačítka „pozastavit“ je práce přerušena, opětovným stiskem tohoto tlačítka uživatel opět pokračuje v práci. Pokud uživatel potřebuje naprosto vymazat naplněný zásobník operací, tzn. nechce v žádném případě dále zpracovávat zde připravené operace, aktivuje tlačítko „vyčistit“, čímž se celý obsah zásobníků vymaže.

Uživatelské rozhodnutí o pokračování v procesu spočívá:

¨ ve vyhledání odpovídajícího procesu a jeho uzlu, do kterého budou vstupovány události (přes připravený výběr nebo na základě činnosti procesy a operace, možnost vyhledání je i přes diagram či strom hlavního procesu)

¨ v aktivaci činnosti pro vstup událostí do odpovídající operace (aby bylo možno vstupovat události je možno operaci aktivovat stiskem klávesy F9 nebo volbou „spustit operaci“ v menu Volby)

Použití referenčního procesu umožní uživateli pokračování v procesu se současnou modifikací (změnou) jeho struktury připojením dalších druhů operací.

Pro případnou automatizaci pokračování v procesu je k dispozici i skupinová položka menu NAPOJENÍ DO PROCESU, jejíž listové položky jsou automaticky vytvářeny na základě uživatelských definic vyvolání. Při jejich aktivaci je uživatel vyzván k zadání čísla procesu a následně je automaticky spuštěna činnost pro vstup událostí do té operace zadaného procesu, která je uvedena v definici vyvolání.

Pokračováním v procesu je automaticky zajištěno naplněním atributů událostí, které souvisí s jejich zařazením do operace v procesu, i atributů v tabulkách souvisejících s vazbami operací i událostí v procesu. Pro automatizaci vstupu dat jsou dále k dispozici tyto uživatelsky definované nástroje:

¨ masky,

¨ šablony,

¨ transformace

¨ případně i importy dat a dávkové operace

1.4.4 Modifikace struktury procesu a opravy

Při založení lze strukturu fyzického procesu danou druhem procesu modifikovat (tzn. průběžně měnit) a to:

¨ automaticky na základě nastavení vlastností jeho uzlů a vazeb (tzn. vlastnosti uzlu + kód po ukončení operace) obvykle v souladu s datovým obsahem zejména odpovídajících událostí a souvisejících tabulek,

¨ na základě uživatelských rozhodnutí (např. vazby XOR).

Modifikací se rozumí změna diagramu procesu, tj. zejména zrušení či přidání uzlu nebo vazby mezi nimi, ale také změna jejich vlastností.

Automatická modifikace ve smyslu zrušení uzlu a s ním souvisejících vazeb vychází z uživatelských nastavení kódu po ukončení operace (např. v závislosti na datech, na dialogu s uživatelem, …) a výběrových vazeb XOR, tj. i v těchto okamžicích (ukončení operace, výběr cíle dle vazeb XOR) je aktivována automaticky. Podobně lze zrušit uzel procesu uživatelem přímo v jeho diagramu.

Automatická modifikace ve smyslu přidání uzlu (uzlů) a souvisejících vazeb vychází z uživatelských nastavení referenčních procesů, kterou aktivuje uživatel v činnosti prezentující události dané operace daného druhu z menu Obecné, ve kterém jsou jako položky uvedeny ty referenční procesy, které začínající shodným druhem operace. IS BM disponuje též funkcemi, které umožňují přidat uzel či vazbu přímo v jeho diagramu uživatelem.

Pro modifikaci struktury fyzického procesu jsou ve stromu procesu k dispozici funkce:

¨ kopírovat odkaz na proces - ve stromu hlavního procesu je možno u položky typu proces po stisku pravé myši aktivovat činnosti „kopírovat odkaz na proces“ (obdoba Windows příkazu Ctrl+C) a tento odkaz je možno k jinému procesu přiřadit (obdoba Windows příkazu Ctrl+V) opět po stisku pravého tlačítka myši na položce procesu, ke kterému chceme zkopírovaný odkaz přiřadit, a to volbou „napojit proces“, tzn. že k diagramu stávajícího procesu se přiřadí i tento napojený proces.

¨ osamostatnit proces – tato možnost vyřadí vybraný proces z daného nadřízeného procesu

Pro opravy dat jednotlivých fyzických procesů prostým přepisem platí, že zejména v událostech operací, které jsou ukončené, lze opravovat minimum atributů (např. poznámka, komentář apod., tzn. atributy, které jsou na bílém podkladu), většinu atributů již takto opravovat nelze (např. AAA, datum, numerické či kvalitativní údaje apod.). Podmínkou jsou přístupová práva zápisu pro daného uživatele.

Pro opravy údajů v událostech ukončených operací je k dispozici funkce storna procesu aktivovatelná z činnosti s přehledem procesů nebo ze stromu procesu, která daný proces označí za stornovaný a současně k němu vytvoří proces stornující. Stornující proces se vytváří automaticky a obsahuje události dle stornovaného procesu s opačným znaménkem u numerických atributů, které mohou být zdrojem pro aktualizaci hodnot. Toto platí pro události těch operací, jejichž druh má definované zrcadlové storno, ostatní události a operace jsou stornem zrušeny. Implicitní datum stornujících událostí odpovídá datu stornovaných událostí s tím, že uživatel má v okamžiku aktivace storna možnost zadat datum jiné.

Druhá forma opravy údajů v událostech ukončených operací je založena na funkci zrušení stavu „ukončena“ dané operace, která je aktivovatelná z menu VOLBY - vlastnosti operace za podmínky, že v daném procesu existuje neukončená operace (uzel) s uživatelsky nastavenou vlastností „ukončuje proces“ (tzn. ve vlastnostech této operace – po stisku pravého tlačítka myši – je zatrženo „ukončuje proces“). Aplikací této funkce na danou operaci (tzn. aktivovat danou operaci a ve vlastnostech operace použít tlačítko „zrušit stav ukončena“) dojde ke zrušení jejího stavu ukončena a nastavení stavu připravena při současném ovlivnění následujících operací, do kterých směřuje běžná vazba z dané operace (resp. následujících – řetězové chování), tak, že je obdobně změněn jejich stav a dále jsou v nich zrušeny události. Zrušit stav ukončena nelze u stornovaných či stornujícíh operací.

1.5 Operace (fyzická operace)

Fyzická operace je „složka“ fyzického procesu, ve které jsou uloženy události (resp. odkazy na ně) dané komponenty vzniklé v rámci daného procesu. Každá operace je určitého druhu a na základě nastavení atributů u druhu operace pak nabývá určitých vlastností i fyzická operace.

Operace jako uzel fyzického procesu nabývá dle uživatelského nastavení řízení provádění procesu (nastavení řídícího toku pro daný druh procesu) stavu ano/ne (volba Ano znamená zaškrtnuto a Ne prázdné okénko) u atributů „připravena“, „zahájena“, „ukončena“ a v případě vybraných komponent i u atributu „předběžně ukončena“. Stav operace (uzlu) je patrný z diagramu, přehledu procesů, přehledu operací a může tedy nabývat těchto hodnot:

¨ připravena - uvedení uzlu do stavu připravena může nastat dvojím způsobem. Připravené operace se mohou automaticky spouštět nebo mohou být uloženy do zásobníku operací. Zrušení stavu připravena (uzel operace) nastane ukončením operace. Zrušení stavu připravena (uzel proces) nastane zahájením procesu, tj. zahájením jeho první operace.

¨ zahájena - pokud se jedná o uzel typu operace, dostává se do stavu zahájena založením určité události (tzn. použitím volby „zapsat“ na operaci) a pokud se jedná o uzel typu proces, dostává se do stavu zahájen zahájením první operace v tomto uzlu. Zrušení stavu zahájena není uživatelskými nástroji možné.

¨ ukončena - operace je ukončena na základě rozhodnutí uživatele (volba „opravdu ukončit operaci“) nebo provedením operace na pozadí (viz. též ukončení uzlu, ukončení operace a ukončení procesu), uzel typu proces není nikdy ve stavu ukončen. Zrušení stavu ukončena u operace je možné vyvoláním funkce "Zrušit stav ukončena".

¨ předběžně ukončena - operace je ukončena předběžně, pokud má ve vlastnostech v diagramu procesu nastaveno „předběžné ukončení“.

¨ stav neuveden - uzel není uveden do stavu připravena ani není zahájen, tento stav je možný u cílových operací fyzických procesů. Stav neuveden (tzn. žádný stav) je i u procesu, který má svoji první operaci pouze ve stavu připravena – zahájena (tzn. jsou zapsány události, ale operace dosud není ukončena). Stav připraven tento proces dostane až ukončením této první operace.

Vstup událostí operace je buď zahájením nebo pokračováním procesu. Podle uživatelského nastavení automatizace vstupu dat do událostí jednotlivých operací (nastavení datového toku pro daný druh procesu) mohou být jejich atributy automatizovaně předplňovány (tzn. některé atributy je možno vstupovat transformací, jiné maskami operace). Pokud je realizováno předplnění s využitím míry plnění, pak je v menu Volby k dispozici funkce Aktivní míra plnění, jejíž aktivace zajistí, že nově vstoupená událost bude zahrnuta z hlediska vyhodnocení míry plnění k události, na níž byl kurzor v okamžiku aktivace vstupu nové události.

Pokud má daný uzel diagramu nastaveno ukončovat automaticky, je při zápisu událostí k uživateli vznesen dotaz, zda ukončit operaci. Pokud nemá, je operace ukončována rozhodnutím uživatele z menu Obecné (volba „ukončit operaci“).

1.5.1 Kód po ukončení

Kód pro ukončení operace slouží k řízení a modifikaci probíhajícího procesu zejména na základě informací v událostech operací procesu a uživatelských rozhodnutích, případně též na základě jiných informací v IS. Řízení procesu spočívá v:

¨ modifikaci jeho procesního diagramu

¨ uvedení operací do stavu připravena

¨ odstranění těch operací procesu, které ztratily vzhledem ke vstoupeným informacím smysl

¨ práci s volnými kartami (automatické naplnění, spuštění pro vstup, ...)

¨ validaci dat

¨ jiných aktivitách (výstupy: tisk, e-mail, ...)

Kód se uplatňuje v okamžiku pokusu o ukončení operace, přičemž může zabránit jejímu ukončení. Kód musí být zapsán ve zvláštním programovacím jazyce. Jednotlivé příklady zápisu kódu po ukončení operace jsou uvedeny ve zvláštní příloze k této dokumentaci.

V kódu po ukončení operace je navíc možno testovat, zda je nebo není operace ukončována předběžně a zároveň je možno určit, zda operace má nebo nemá být ukončena předběžně.

Pro druh operace v diagramu druhu procesu je možno kromě běžného kódu po ukončení operace zadávat statický kód druhu operace v druhu procesu. Aktivuje se zaškrtnutím tohoto atributu ve formuláři kódu po ukončení operace. Celkový kód prováděný po ukončení operace se sestavuje spojením:

¨ (statický kód druhu operace v druhu procesu) + (nestatický kód po ukončení operace, který je spojen s operací ve fyzickém procesu). Z toho vyplývá, že statický kód je prováděn vždy pro danou operaci v druhu procesu, i když byla operace ukončena a následně byl její stav ukončena zrušen. Na rozdíl od nestatického kódu, který je po ukončení operace pro danou operaci ve fyzickém procesu vymazán. Použití statického kódu je vhodné pro různé validace dat ukončované operace (např. musí být vyplněn selektor).

POZOR na nevhodný postup:

1. vznikl fyzický proces s operací, v jejímž kódu po ukončení je např. uvedeno DECLARE pocet=COUNT (.......)

2. implementátor upravil odpovídající druh procesu:

a) uvedl ve statickém kódu DECLARE pocet=COUNT (......)

b) zrušil v původním nestatickém kódu DECLARE pocet=COUNT (.....)

3. uživatel pokračuje ve fyzickém procesu a ukončuje operaci

4. kód po ukončení operace hlásí chybu dvojí deklarace proměnné pocet

2. „Krok za krokem“ (neboli „pokračujeme“)

Informační schopnost systému spočívá v tom, jakým způsobem je systém schopen odpovědět různé otázky. Informační schopnost vyplývá z datového modelu IS a je základním klíčem při rozhodování o pořízení daného IS v rámci výběrových řízení.

2.1 Definice informační schopnosti

Při definici informační schopnosti vycházíme z datového modelu IS, resp. z možnosti jeho uživatelského přizpůsobení při implementaci systému (např. jak zlepšit uspořádání operací do procesu, objektů do souvislostí, jak vhodně využít dávkové činnosti, informace volných karet, jakým způsobem zjistit na základě čeho byla zaplacena tato faktura apod.)

2.1.1 Diagram procesu

Diagram procesu je grafické vyjádření posloupnosti operací nebo procesů. Každý druh procesu má tedy svůj diagram, který se skládá z jednotlivých uzlů a vazeb mezi nimi. Každá vazba vyjadřuje vztah mezi zdrojovým (rámeček ze kterého vede šipka) a cílovým (rámeček do kterého vede šipka) uzlem a v diagramu procesu je vyjádřena šipkou. Uzlem procesu může být operace nebo proces. Každý diagram procesu má jednotné ovládání.

Při práci s diagramem procesu je důležité, zda uživatel pracuje s diagramem druhu procesu (tj. zdrojový diagram) nebo diagramem již vytvořeného fyzického procesu. Diagram druhu procesu je možno vyvolat:

¨ z činnosti „druhy procesů“ (menu Informační centrum – Typy a řady – Druhy procesů) po stisku klávesy F7 nebo z menu Volby. V tomto okamžiku se uživateli zobrazuje diagram druhu procesu.

¨ z činnosti „procesy“, „operace“ (menu Procesy a operace) po stisku klávesy F7 nebo z menu Volby. V tomto okamžiku se uživateli zobrazuje diagram již vytvořeného fyzického procesu. V případě, že uživatel chce vidět i diagram daného druhu procesu, aktivuje ikonu „diagram druhu procesu“ v panelu ovládání diagramu procesu.

¨ z událostí jednotlivých komponent – v tomto případě uživatel aktivuje diagram procesu pouze z menu Volby. V tomto okamžiku se uživateli zobrazuje rovněž diagram již vytvořeného fyzického procesu. V případě, že uživatel chce vidět i diagram daného druhu procesu, aktivuje ikonu „diagram druhu procesu“ v panelu ovládání diagramu procesu.

¨ aktivace diagramu procesu může být součástí i definice základní nabídky (menu Obecné – Nabídky – Základní)

Jak jsme se již výše zmínili, diagram se skládá z jednotlivých uzlů a vazeb mezi nimi. Pokud je uzlem diagramu procesu „proces“, je možno po stisku pravého tlačítka myši na uzlu vyvolat menu obsahující tyto položky:

¨ vlastnosti, tj. funkce pro nastavení specifického chování operace (procesu) v rámci daného procesu,

¨ odstranit, tj. funkce pro zrušení daného uzlu diagramu procesu; současně se odstraní vazby s uzlem související a také ty uzly, které by se pak staly nepropojenými s první operací.

Kromě položek vlastnosti a odstranit, obsahují uzly typu „operace“ ještě dále:

¨ kód po ukončení (pouze pro uzel typu operace) – možnost nastavení kódu po ukončení operace,

¨ vstupní maska operace (pouze pro uzel typu operace) – možnost definice vstupní masky operace pro automatizaci vstupu dat,

¨ maska operace v procesu (pouze pro uzel typu operace) – možnost definice masky operace platné pouze v daném druhu procesu

Mezi dvěmi (zdrojový a cílový) uzly diagramu lze definovat nejméně jednu vazbu. Pokud je některý z dvojice uzlů typu proces, lze definovat další vazby mezi nimi ve vlastnostech. Na každé vazbě v diagramu vyjádřené šipkou lze vyvolat menu obsahující tyto položky:

¨ vlastnosti, tj. funkce pro nastavení parametrů dané vazby,

¨ odstranit, tj. funkce pro zrušení dané vazby diagramu procesu; současně se odstraní uzly, které by se pak staly nepropojenými s první operací, a vazby s těmito uzly souvisejícími.

2.1.2 Otevřená období komponent

S jednotlivými komponentami úzce souvisí i činnost otevřená období komponent (menu Informační centrum - Typy a řady), která umožňuje uživateli nastavit období pro validaci dat v událostech.

U každé komponenty lze zadat (po stisku F3) datum od - do. Toto datum systém potom hlídá při zápisu událostí komponenty a při provádění storna. Jak již vyplývá z názvu této činnosti, je nutno si uvědomit, že uživatel zadává datum, kdy je možno komponentu pro zápis událostí nebo storna považovat za otevřenou, tzn. mimo toto zadané období je vlastně komponenta pro zápis nebo storno uzavřená. Pokud není pro komponentu definováno otevřené období, potom není povolen vstup událostí s datem mimo interval 1.1.1980 až 1.1.2100. Pozn.: Důsledkem toho je, že pro komponenty, ve kterých se mohou vyskytnout události s menším datem (spravovaný majetek, odepisovaný majetek, ....) je NUTNÉ definovat otevřené období komponenty.

Další možnosti této činnosti jsou:

¨ kontrolovat při stornu – možnost Ano/Ne. V případě zadání Ano systém kontroluje ještě nastavení tohoto atributu u druhu operace (záložka Další). Pokud je u otevřeného období komponenty nastaveno Ano a u druhu operace rovněž Ano (nebo není vůbec vyplněna záložka Další), storno procesu se neprovede, pokud by stornem vznikla inverzní událost s datem mimo otevřené období komponenty nebo pokud by stornem byla zrušena událost s datem mimo otevřené období komponenty.

¨ kontrolovat při rušení stavu ukončena - možnost Ano/Ne. V případě zadání Ano systém kontroluje ještě nastavení tohoto atributu u druhu operace (záložka Další). Pokud je u otevřeného období kompomenty nastaveno Ano a u druhu operace rovněž Ano (nebo není vůbec vyplněna záložka Další), zrušení stavu ukončena se neprovede, pokud by byla zrušena událost operace s datem mimo otevřené období komponenty.

2.1.3 Volné karty

Volná karta je nástroj, který umožňuje uživateli rozšířit množinu programátory definovaných atributů o další, uživatelsky definované atributy. Volnou kartu lze definovat ke každé entitě (tj. tabulce) na níž je postavena činnost typu seznam. Z některých činností lze kromě „vlastní“ volné karty aktivovat volné karty:

¨ adresáta

¨ artiklu

¨ operace

¨ procesu

¨ vazby objektů

¨ selektorů

Každá volná karta je určitého druhu a ke každému druhu volné karty je možno nadefinovat přístupová práva pro jednotlivé uživatele.

Volná karta představuje funkci IS BM, která v každé činnosti (ve které je to podporováno) umožňuje na základě zadaných uživatelských definic ke každému záznamu prezentovat další odpovídající údaje. Tyto údaje buď obsahují informace vypočtené (pomocí příkazu SELECT) z dat celého IS nebo údaje, které obsahují hodnotu atributů z nové tabulky s uživatelsky definovanou strukturou (tzn. atributy, které uživatel vstupuje).

Volnou kartu lze spustit rozhodnutím uživatele nebo automaticky. Uživatelské rozhodnutí je možno provést:

¨ z menu Obecné – uživatel si v tomto menu ručně spustí vybranou volnou kartu

¨ z doplňujících vlastností formuláře – kde je možno v definici těchto doplňujících vlastností zvolit funkční klávesu pro spuštění z menu

¨ v kódu po ukončení operace – lze nastavit dotaz, zda po ukončení operace se má aktivovat daná volná karta, uživatel si sám zvolí Ano či Ne.

Automatické rozhodnutí o spuštění volné karty může probíhat na základě:

¨ vlastní definice volné karty – zatržením atributu „vyvolat automaticky“ (při tomto nastavení se neuplatní přístupová práva k druhu volné karty)

¨ doplňujících vlastností formuláře (řídí se přístupovými právy k doplň. vlastnostem formuláře)

¨ kódu po ukončení operace

¨ definice druhu operace – v činnosti „druhy operací“ je nutno na záložce „další“ zatrhnout atribut „po ukončení vstup volné karty“

2.1.4 Objekty – nastavení

Objektová vazba umožňuje uživatelsky definovat vztah (předchůdce – následník nebo možno interpretovat i jako otec - syn) mezi dvěma objekty, tj. mezi dvěma záznamy ve „významných“ tabulkách IS (tj.: AAA, události, operace a jejich druhy, procesy a jejich druhy, dokumenty a příkaz k úhradě). Objektem mohou být pouze záznamy těch entit, které mají atribut jednoznačné časové identifikace. K vazbě objektů lze volnou kartou definovat další vlastnosti (atributy).

Existence objektové vazby je uživateli signalizována matematickými znaménky v rámečku souvislostí (tzn. při práci s objektovými vazbami je nutno mít tento rámeček zobrazen – panel nástrojů – ikona stromeček). Uživatel si může rámeček souvislostí přemístit (metodou „táhni a drž“) kdekoliv po okně, systém si toto umístění pamatuje a při jeho příštím spuštění ho zobrazí na tomto místě. Pokusíme se o vysvětlení na praktickém příkladu. Máme v okně činnosti zobrazenu přijatou zprávu a aktivován rámeček souvislostí. V něm, na ikoně vývěska je uvedeno znaménko plus nahoře, na ikoně dokumenty je uvedeno znaménko plus dole. Znamená to, že tato zpráva má objektovou vazbu na události vývěsky, která je k této zprávě ve vztahu předchůdce (otec) a zároveň má tato zpráva objektovou vazbu na dokument, který je k této zprávě ve vztahu následník (syn). Pokud bychom si tento příklad na základě těchto objektových vazeb uvedli do logické posloupnosti, vypadalo by to takto: vývěska – zprávy – dokumenty (otec – aktuální záznam – syn).

Vlastní vytvoření objektových vazeb je možno provést dvěmi způsoby, metodou přímou a metodou nepřímou. Na popisu konkrétního příkladu vytvoření objektové vazby mezi událostí vývěsky a zprávami si obě tyto metody vysvětlíme:

¨ přímo – je vytvořena událost vývěsky. Uživatel si z panelu nástrojů po stisku ikony stromeček aktivuje rámeček souvislostí. V něm si vybere ikonu „zprávy“ a klikne na ni. Zobrazí se mu okno činnosti zpráv, které je prázdné a na tlačítku vytvoření vazby je implicitně přepnuto na volbě „předcházejí“, tzn. původní událost (vývěska) je otec – předchůdce a nová událost (zprávy) je syn – následník. V případě potřeby vazby opačné, tz. původní událost (vývěska) bude syn a nová událost (zprávy) bude otec je nutno stisknout dané tlačítko a aktivovat polohu „následují“.

¨ nepřímo – jedná se o případ, kdy už je jak událost vývěsky, tak zprávy vytvořena, není mezi nimi zatím žádná spojitost a uživatel je tedy pomocí objektové vazby chce spojit (tzn. vytvořit odkaz jedné události na druhou). V takovém případě je postup následující: uživatel si spustí okno s činností vývěsky s výběrem na danou událost a zároveň okno s činností zprávy s výběrem na danou zprávu (tzn. má otevřená dvě okna činností s událostmi). V každém okně činnosti je kurzor umístěn vždy na daném záznamu, který chceme spojit. Aktivujeme činnost zpráv (tzn. horní lišta okna zpráv je modrá), stiskneme levé tlačítko myši na zeleném stromečku v levém dolním rohu okna činnosti zpráv a metodou „táhni a drž“ tento stromeček přesuneme kamkoliv do okna činnosti vývěska a zde ho pustíme. Zobrazí se nám dotazovací dialog, kdy opět pomocí - tentokrát zaškrtávátek, „následuje“ a „předchází“ vytvoříme potřebnou vazbu otec – syn nebo syn – otec. V případě potřeby je možno kdykoliv takto vytvořenou vazbu zrušit. Aktivujeme si okno činnosti s událostí, která byla připojena jako následník (syn), v našem případě zprávy, a po stisku klávesy F8 nebo ikony křížek v panelu nástrojů se systém dotazuje „opravdu zrušit vazbu na událost ......?“. Potvrzením volby Ano je vazba objektů zrušena.

Při vytváření objektových vazeb má uživatel kromě možnosti zvolit tlačítko „následuje“ a „předchází“ možnost využít ještě tyto tlačítka:

¨ nepřekrývat – překrývat – znamená, že pokud má uživatel zobrazena okna dvou činností, mezi kterými vytváří objektovou vazbu, tak při volbě nepřekrývat se při pohybu po těchto oknech vždy zobrazuje celé okno dané činnosti (tzn. aktivní okno je v danou chvíli vždy vidět celé a může překrývat právě neaktivní okno). Volba překrývat znamená, že při pohybu z jednoho okna činnosti na druhé je část okna jedné činnosti soustavně překryta částí okna druhé činnosti, čili jedno okno činnosti (kde je zatržena volba překrývat) stále překrývá okno druhé činnosti.

¨ nefixovat – fixovat – tato volba souvisí s pohybem po jednotlivých záznamech. Pokud máme opět zobrazena okna obou činností (např. znovu vývěska a zprávy), tak při volbě nefixovat se při pohybu po okně s činností vývěsky mění zároveň okno s činností zprávy, přesně podle toho, jakou má daná událost vývěsky vytvořenou objektovou vazbu na zprávy. Pokud je v okně činnosti zpráv přepnuto na volbu fixovat, znamená to, že i přesto, že se uživatel bude pohybovat po jednotlivých záznamech vývěsky, okno s činností zpráv se měnit nebude, zůstane zobrazena stále původní zpráva (tj. ta, na které bylo aktivováno fixovat).

Specifickou vazbou objektů jsou dokumenty, které kromě toho, že se příznak vazby zobrazuje v rámečku souvislostí ještě mají i své okno spojených dokumentů. Objektová vazba se technicky realizuje pomocí atributů s jednoznačnou časovou identifikací záznamu (record). Zpráva objektově připojená k vývěsce zpřístupní i záznam, který by podle práv přístupný nebyl.

2.1.4.1 Nastavení - Souvislosti objekt

Tato činnost je pro uživatele k dispozici v menu Systém - Nastavení - Souvislosti objekt. Nastavením této činnosti uživatel definuje způsob zobrazení rámečku souvislostí po stisku ikony objekty (ikonka se „stromečkem“) v panelu nástrojů. Rámeček souvislostí si metodou „táhni a drž“ může uživatel rozmístit na libovolné místo v okně. Po jeho zavření a opětovném spuštění si systém pamatuje poslední místo, kde byl umístěn a na tomto místě se rámeček souvislostí aktivuje. Možnost této definice má uživatel v činnosti menu „Systém“. Po její aktivaci se mu zobrazí tabulka s nabídkou všech objektů, které se mohou zobrazovat v rámečku souvislostí.

Příslušná znaménka plus nebo mínus v rámečku souvislostí poskytují uživateli informace o přítomnosti objektových vazeb. V levé části této tabulky má uživatel možnost změnit pořadí těchto objektů (stiskem malého čtverečku před názvem objektu pravým tlačítkem myši - po jeho stisku se zobrazí na čtverečku šipka - a jeho následným přetažením na jiné místo v seznamu).

U každého objektu v seznamu je možno z překryvného seznamu (v dolní části okna) vybrat tyto možnosti:

¨ zobrazit – tento objekt se bude po aktivaci rámečku souvislostí standardně nabízet v daném pořadí

¨ skrýt – tento objekt zůstává skrytý, tzn. po aktivaci rámečku souvislostí se standardně nezobrazí. V případě, že by uživatel potřeboval v některém okamžiku vidět v rámečku souvislostí i objekty, které mají příznak skrýt, zatrhne možnost „zobrazovat skryté“. Do té chvíle, dokud bude tato možnost zatržena, se budou v rámečku souvislostí nabízet i objekty, které mají příznak skrýt. Uživatel má však možnost vidět i objekty, které jsou skryté a přesto nemají zatrženo „zobrazovat skryté“. Po stisku pravého tlačítka myši v šedivém poli rámečku souvislostí se uživateli zobrazí i objekty, které mají příznak skryté. Opětovným stiskem pravého tlačítka myši se obnoví původní zobrazení.

¨ potlačit – tyto objekty se v rámečku souvislostí nebudou nabízet nikdy. V případě, že by je uživatel přesto chtěl vidět, musí příznak potlačit změnit na zobrazit nebo skrýt.

Nastavení – souvislosti objekt se vždy váže k danému uživateli a jeho přístupovému heslu (tedy, k tomu, který je právě aktuálně přihlášen do systému), tzn., že pro každého uživatele může být toto nastavení individuální a zcela podle jeho potřeb. Po stisku tlačítka OK se toto nastavení uloží.

2.2 Poskytnutí informační schopnosti

Poskytnutí informační schopnosti je způsob, jakým informační systém přijme požadavek od uživatele a jakým způsobem na to odpoví (např. systém umožní uživateli vytvořit a použít obecný výběr, tj. požadavek a po jeho zobrazení si uživatel nad tímto výběrem může použít např. klávesu Ctrl S – suma, tj. odpověď).

Informační schopnost je schopnost systému vyhovět informačním potřebám uživatele a je uživateli prezentována zejména pomocí vyprogramovaných základních oken, slovníku dat, volnými kartami, výkazy, sestavami apod.

2.2.1 Definice a stavba hlavního menu (výkazy, importy, napojení, procesy)

Jak jsme se již zmínili v úvodu této dokumentace, práci se systémem zahájí uživatel přihlášením do IS BM, tj. zadáním svého jména a hesla. Při prvním přihlášení do systému se mu zobrazí okno hlavního menu, které je tvořeno na základě základní definice menu.

Základní definici menu však není možno uživatelsky přizpůsobit (tzn. změnit pořadí činností, vytvořit nové skupiny, zkopírovat činnosti apod.). Každý uživatel má tedy možnost vytvořit si vlastní menu (může být společné i pro několik uživatelů). Toto provede spuštěním činnosti „otevřít menu“ (horní lišta hlavního menu – Menu – Otevřít menu) a ze základní definice menu si odvodí své vlastní menu, které si již může uživatelsky přizpůsobit. U každé své vytvořené definice menu si uživatel může po stisku pravého tlačítka myši nadefinovat jeho vlastnosti.

Po každém přihlášení do systému se však uživateli zobrazí vždy okno hlavního menu. To kromě ovládacích ikon ještě obsahuje i horní lištu, kde jsou soustředěny další činnosti, které souvisí s ovládáním hlavního menu. Hlavní menu se skládá ze skupin činností, tzn. že každou skupinu je ještě možno „rozbalit“ a pracovat s jednotlivými činnostmi v ní obsaženými. Na každé skupině i jednotlivých činnostech je možno po stisku pravého tlačítka myši vyvolat další volby.

Kromě menšiny uživatelsky definovaných skupin existuje ještě většina skupin programových, tedy těch, které jsou přímo součástí hlavního menu (např. Informační centrum, Procesy a operace, Obchod, Marketing, Platby apod.). Některé skupiny vznikají automaticky, tzn. bez přímého zásahu uživatele. V případě, že uživatel nadefinuje nový procesní import, bude tento automaticky vložen pod skupinu hlavního menu Import do procesu. Každá vytvořená definice vyvolání má vliv na zobrazení hlavního menu, automaticky se „zapisuje“ pod činnost hlavního menu Napojení do procesu. V případě nadefinování nového druhu procesu, který má nastaven „zobrazit v menu“ a nejedná se o skrytý proces, je tento automaticky uložen pod skupinu hlavního menu Nový proces. V případě, že je u druhu procesu určena i skupina procesů, je tento druh procesu vložen ještě do příslušné skupiny vytvořené pod skupinou Nový proces. Výkazy zadané v činnosti definice výkazů se pak automaticky zobrazují v menu Informační centrum – Výkazy – Výkazy ke spuštění, kde každý druh výkazu představuje skupinovou položku činností pod skupinou Výkazy ke spuštění.

Specifickými činnostmi hlavního menu jsou:

¨ aplikace[3]

¨ spustit při startu – pomocí vlastnosti činnosti „kopírovat“ si do této činnosti může uživatel vložit činnosti, které chce mít automaticky k dispozici po každém spuštění IS BM. Vybranou činnost si zkopíruje (pravé tlačítko myši na názvu dané činnosti), aktivuje si činnost spustit při startu a pomocí pravého tlačítka myši sem zkopírovanou činnost vloží. Může zde být vloženo i několik činností. Po spuštění IS BM se potom aktivují všechny najednou a uživatel se mezi nimi přepíná. V případě, že uživatel chce naopak sem zkopírovanou činnost zase zrušit, stiskne pravé tlačítko myši na názvu dané činnosti a na dotaz „odstranit ze spuštění při startu?“ zvolí možnost Ano.

¨ spuštění externího příkazu – zde se uživateli zobrazují příkazy, které si uživatel nadefinoval v činnosti externí příkazy (menu Informační systém – Typy a řady – Externí příkazy)

¨ významné uzly – jsou součástí činnosti Marketing – Vývěska. Významné uzly slouží pouze jako informativní činnost, v případě, že má uživatel vytvořeny uzly vývěsky, zobrazují se mu tyto uzly pod skupinou významné uzly. To, které uzly vývěsky se budou uživateli pod touto činností zobrazovat se určuje přímo v činnosti „uzly vývěsky“ (menu Marketing – Vývěska).

Pro snadnější orientaci uživatele si všechny významné pojmy týkající se hlavního menu shrneme. Po přihlášení do systému se uživateli zobrazí hlavní menu, které je postaveno na základě základní definice menu. V případě potřeby si uživatel může odvodit své vlastní menu. Každé menu obsahuje horní lištu, panel nástrojů, skupinové položky a jednotlivé činnosti. Po stisku pravého tlačítka myši na skupině nebo činnosti je možno vyvolat vlastnosti.

Podobné zákonitosti platí i u menu okna činností IS BM. Každá spuštěná činnost se uživateli zobrazí ve svém okně. Je možno mít naspouštěno několik činností najednou, aktivní může být vždy však pouze jedna. Každé okno činnosti obsahuje horní lištu a panel nástrojů. Na základě uživatelských nastavení může okno činnosti obsahovat i okno úloh a nabídku aktivních oken.

2.2.2 Personifikace a autorizace dat

Každý přihlášený uživatel má možnost si přizpůsobit některé funkce informačního systému podle svých požadavků formou určité personifikace IS, tj. nastavením svých:

¨ parametrů uživatele týkajících se celého IS (reakce na ESC, zobrazení volitelných informačních a ovládacích prvků, …),

¨ parametrů formuláře týkajících se dané obrazovky (třídění, uspořádání mřížky, …),

¨ osobních masek pro automatizaci vstupu dat v událostech,

¨ menu,

¨ jazyka,

¨ struktur objektů (ikon), které se zobrazují v panelu se signalizací vazeb objektů.

Významné aktualizace dat, tj. zejména vstup událostí, zahájení a ukončení operací, vstup a oprava dokumentů apod., jsou v informačním systému autorizovány. Tedy je u těchto záznamů uvedeno, který uživatel a kdy danou aktualizaci provedl (např. u dokumentu je vidět, zda daný uživatel provedl pouze čtení nebo i čtení a zápis, u operace je vidět, kdo ji zahájil a naopak, který uživatel ji ukončil apod.). Pro sledování dalších aktualizací (např. změny v adresáři, změny událostí apod.) je možno využít uživatelské triggery.

2.2.3 Uživatelé, skupiny, práva

Uživatel programu je každý nositel určitého práva (ne)přístupu k IS Bílý Motýl. Uživatelé se evidují v činnosti „uživatelé programu“ v menu SYSTÉM. V této činnosti se u každého uživatele uvádí v první řadě jeho jméno a vstupní heslo, kterým se pak uživatel identifikuje při přihlášení do programu. Exkluzivní uživatelé jsou "SPRÁVCE" a "SYSTÉM". Mezi další základní vlastnosti uživatele uváděné v činnosti „uživatelé programu“ a s nimi související funkčnost patří:

¨ jméno – tímto jménem se uživatel přihlašuje k IS, je prezentováno při zobrazení autorizace záznamů, je obvykle dostupné v položkách zahrnutých do předloh výstupů nad událostmi. Před naprosto prvním zadáním jména uživatele se ještě zadává rodné číslo uživatele, na jehož základě systém vygeneruje první vstupní heslo. Toto heslo si pak samozřejmě může podle svých potřeb změnit. V případě, že ho zapomene, provede správce u jeho jména inicializaci hesla, tzn. systém mu znovu přiřadí toto počáteční heslo a uživatel si ho pak může znovu změnit (v případě potřeby existuje možnost ukládat „hash“ hesla [4] uživatele).

¨ úplné jméno – lze je doplnit do předloh výstupů,

¨ e-mail – zde uvedená e-mailová adresa je využita jako adresa odesílatele při odesílání mailu z IS BM,

¨ počáteční heslo – heslo pro přihlášení k IS, které je uživateli automatizovaně přiděleno, on si je následně mění sám, případně má správce možnost opakovaného nastavení tohoto hesla inicializací hesla,

¨ jazyk – IS se prezentuje (je spuštěn) v tomto jazyce danému uživateli,

¨ práva správce – uživatel bude mít přidělena specifická práva správce,

¨ právo odblokování – uživatel bude mít právo provést odblokování IS po jeho zablokování jiným uživatelem na daném PC,

¨ aktivní uživatel – uživateli je umožněno se přihlásit k IS,

¨ povolena změna hesla – uživatel je oprávněn měnit své přístupové heslo,

¨ explicitní web menu – v případě aplikace web serveru a přístupu k IS daného uživatele pomocí internetového browseru bude mít uživatel přístup pomocí zde uvedené definice web menu,

¨ význam – význam obecné předkontace spojený s daným uživatelem.

Každý uživatel může být zařazen (provádí se jeho zatržením) do libovolného počtu skupin uživatelů, které jsou využity pro nastavení přístupových práv (činnost „uživatelé programu“, záložka „skupiny uživatelů“). Specifická je skupina „Každý uživatel systému“, která má implicitně vše dostupné a do které je každý uživatel automaticky zařazen při svém založení. Na záložce „skupiny uživatele“ je k dispozici pouze informace o aktuálních skupinách, do kterých je daný uživatel zařazen. Záložka „přístupy k věcem“ poskytuje informativní přehled o všech věcech s přístupem, které má daný uživatel dostupné. Zvýraznění modrou barvou znamená právo přístupu „čtení a zápis“, červené zvýraznění je právo přístupu pouze „čtení“.

IS umožňuje omezení své informační schopnosti a dostupnosti svých funkcí nastavením přístupových práv pro jednotlivé uživatele, resp. právě tyto jejich skupiny (z implementačního pohledu je mnohem smysluplnější definovat přístupová práva ke skupinám než k jednotlivým uživatelům).

Omezení dostupnosti funkcí IS se realizuje pomocí nastavení v činnosti „oprávnění k činnostem“ (menu SYSTÉM), kde je možné ke každé funkci (činnosti) zde uvedené definovat přístupové právo pro jednotlivé skupiny uživatelů až na úroveň editačních činností.

Omezení informační schopnosti IS se realizuje pomocí nastavení přístupových práv k věcem s přístupem (tj. datům). Přístupová práva je možno definovat vždy po aktivaci příslušné činnosti (přehled věcí s přístupem) stiskem klávesy Ctrl B nebo z menu Volby.

Věcí s přístupem se rozumí každý záznam v těch entitách IS, ke kterým je programovým kódem umožněno definovat přístupová práva. Mezi tyto entity patří:

¨ alokace (např.: sklad, pokladna, obchodní místo, …),

¨ druhy operací,

¨ druhy procesů (právo zápis = pouze právo zahájit proces),

¨ druhy informací:

- druhy dokumentů,

- druhy volných karet,

- druhy výkazů,

- druhy předloh výstupů,

- druhy šablon,

- druhy importů,

- druhy prvků Web

- druhy uzlů informačních panelů atd.

Právo přístupu nabývá některé z těchto hodnot: žádné, čtení nebo zápis. Následně je obvykle odpovídajícím způsobem chráněn i přístup k těm záznamům v různých entitách IS, kde je atributem věc s přístupem (tj. data). Přístupová práva věcí s přístupem (tzn. druhy procesů, druhy operací, ...) lze definovat přímo na uživatele nebo prostřednictvím skupiny uživatelů.

Uživatel (v případě definice přístupových práv by to měl být pouze „správce“) má k dispozici ještě i činnost „mapa přístupových práv“, která je určena pro usnadnění definování práv přístupu k druhům procesů, druhům operací, umístění komponent apod. Činnost se nachází v menu Informační centrum – Typy a řady – Mapa přístupových práv. Po její aktivaci jsou jednotlivá nadefinovaná práva zobrazena v mřížce, kde je možno je po stisku pravého tlačítka myši na vybraném právu měnit. Tuto činnost je rovněž možno vyvolat po stisku klávesy F5 při definování práv AAA, druhu procesů apod. po stisku klávesy Ctrl B. V tomto případě se zobrazí omezený počet práv odpovídajícího druhu.

Pro případ změn v zařazení uživatelů do skupin nebo změn vlastních přístupových práv (např. změnou práva z čtení na zápis u některé skupiny apod.) je k dispozici funkce pro přepočet práv. Tato funkce je dostupná v činnostech „uživatelé programu“ a „skupiny uživatelů“ v menu SYSTÉM pod menu Volby. V těchto činnostech má uživatel k dispozici pod menu Volby i činnost „aktualizace seznamu věcí“, která po přepočtu v těchto činnostech aktualizuje seznam věcí na záložce „přístupy k věcem“.

V případě potřeby automatizovaně přidělovat přístupová práva při zakládání vybraných druhů a umístění určité skupině uživatelů lze k tomuto účelu využít činnost „pravidla inicializací přístupových práv“.

2.2.4 Stav systému

Pod skupinovou položkou hlavního menu SYSTÉM má uživatel k dispozici řadu činností, které mu poskytují informace o aktuálním stavu systému v daný okamžik. Jsou to:

¨ přehled přihlášených – zobrazí se tabulka, která obsahuje přehled uživatelů, kteří jsou v daný okamžik přihlášeni k IS BM. U každého uživatele je navíc informace, v jaké se právě nachází činnosti a datum a čas jejího aktivování (užije správce, potřebuje-li si vyhradit databázi).

¨ rezervované zdroje systému – zobrazí se okno s tabulkou, které obsahuje informace o rezervovaném zdroji a uživateli, který si zdroj rezervoval, jeho důvodu a času rezervace. Do této činnosti není možno zapisovat přímo (tj. po stisku F3), je možno pouze v případě potřeby rezervace zrušit. Např. nastavením příkazu LOCK v dodatečných deklaracích definice listu výkazu systém umožňuje zamknout zdrojová data uvedených komponent. Jednotlivé rezervace se tedy do této činnosti zapisují nepřímo pomocí jiných činností. V současné době se automaticky zaznamenají rezervované zdroje při:

- výpočtu výkazů – zadaný příkaz LOCK UCE zabrání zápisu událostí účetnictví po dobu sestavení výkazu (to vede k zajištění integrity zobrazených informací ve výkazu) – doba výpočtu výkazu je tedy zaznamenána v rezervovaných zdrojích systému

- přepočtech hodnot – v případě, že uživatel potřebuje přepočítat hodnoty (statistické, aktuální, saldokontní, obratů) v menu Informační centrum – Statistika – Přepočet hodnot, systém po dobu přepočtu jednotlivých hodnot zaznamenává tento čas do rezervovaných zdrojů.

¨ přehled prováděných činností – zobrazí se okno, které na základě zadaného výběru obsahuje následující informace: den, čas, dobu trvání, jméno uživatele, identifikaci činnosti, název, identifikaci modulu a další. Uživatel má možnost vytvořit si na základě této činnosti přehled o tom co, kdy a kde jednotliví uživatelé v systému prováděli.

¨ přehled změn záznamů tabulek – na základě definice činnosti „nastavení sledování změn tabulek“ lze i zpětně dohledat, který uživatel a jakou změnu v dané tabulce provedl

2.2.5 Předlohy výstupu

Předlohy výstupu jsou definice, na základě kterých jsou realizovány výstupy v rámci činností IS BM. Tyto výstupy jsou vlastností téměř každé činnosti typu seznam (lze je vyvolat stiskem ikony “výstup”, volbou činnosti Tisk z menu Volby, stiskem klávesy Ctrl T nebo pomocí doplňujících vlastností formuláře, kódu po ukončení, klávesy F11 a F12). Předlohy výstupu a tím i výstupy mohou být podle nástroje pro jejich zobrazení typu:

¨ sestava – klasická tisková sestava

¨ Excel – sestava typu Excel (lze ji odeslat i e-mailem)

¨ ostatní – HTML sestavy (lze ji odeslat i e-mailem)

¨ Word – sestava typu dokumentu Word (lze ji odeslat i e-mailem)

Tisk na základě vytvořené předlohy výstupu uživatel využije kdekoliv, např. při:

¨ tisku operací,

¨ tisku procesů (tj. dokladů),

¨ tisku přehledu událostí, číselníků apod.

Každý výstup probíhá na základě vytvořené předlohy výstupu. Každá předloha se skládá ze své definice a vlastností předlohy. U předloh typu „sestava“ je možno při jejich definování využít i předdefinované vzory výstupu. Předlohy výstupu lze vložit do definice metapředlohy s řadou dalších definic, což se užije zejména u procesů a operací. U každé předlohy je možno nastavit reakci po její aktivaci uživatelem. Tato reakce je uživatelsky ovlivnitelná profilem spuštění, který je k dané předloze přiřazen, a který ovlivňuje chování předlohy po její aktivaci, tzn. zda má následovat přímo spuštění předlohy nebo rozhodnutí. Pro předlohy typu „sestava“,„excel“ a „word“ se v profilu určuje směrování výstupu (tiskárna/do souboru/prohlížení). Pro předlohy typu „sestava“ je při nasměrování předlohy výstupu na „prohlížení“ možno využít i atribut „v prohlížeči výstupů předloh“. Pro předlohy typu „sestava“ se navíc určuje, zda má při výstupu předlohy na tiskárnu předcházet dotaz na výběr tiskárny a pro předlohy typu „word“ se ještě nastavuje předplnění atributů „digitální podpis, příprava e-mail a ukládat jako dokument BM“. Uvedení logické tiskárny v předloze výstupu umožňuje definovat pro různá uživatelsky definovaná pracoviště (každé může zahrnovat několik fyzických počítačů) různé fyzické tiskárny.

2.2.5.1 Využití předlohy

Jednotlivé nadefinované předlohy výstupu využívá uživatel samozřejmě především při potřebě tisku vybraných dat. Činnost tisk uživatel aktivuje z panelu nástrojů (ikona tiskárna), výběrem příslušné činnosti z menu Volby nebo stiskem klávesy Ctrl T. Po spuštění tisku (jakýmkoliv z uvedených způsobů) se uživateli zobrazí samostatné okno „výstupy“. V tomto okně má uživatel přehled dosud nadefinovaných předloh výstupu. Pro ovládání tohoto okna má uživatel k dispozici panel nástrojů (tj. horní lišta), kde jsou následující možnosti ve formě ikon:

¨ spuštění výstupu – vlastní aktivace tisku vybrané předlohy výstupu

¨ oprava předlohy – u nové předlohy slouží tato činnost k výběru položek výstupu, u již nadefinované předlohy k opravě definice uspořádání položek

¨ výběry – uživatel si zde může nadefinovat výběr a jeho podmínku. Tento výběr mu slouží pro případ, že záložka výběr a možnosti ve vlastnostech předlohy (setřídění, doplnění, seskupování) nesplňují přesně jeho požadavky. Tímto výběrem si pak požadovaná výběrová kritéria může upřesnit. Při spuštění předlohy výstupu s tímto použitým výběrem pak IS BM provádí svůj SELECT, který vychází z činnosti (nad kterou probíhá tisk) a je upraven podle uživatelských definic ve vlastnostech předlohy (setřídění, seskupování, doplnění)

¨ nová předloha – pomocí této možnosti uživatel zadává novou předlohu výstupu. Atributy, které zde zadává jsou shodné s vlastnostmi předlohy, takže je zde nebudeme podrobně rozepisovat.

¨ kopie předlohy – uživatel má možnost na základě již nadefinované předlohy vytvořit kopii, kde si pouze zadá svůj nový název a samozřejmě má možnost si tuto kopii následně upravovat.

¨ vlastnosti předlohy

¨ zrušení – možnost zrušení vybrané předlohy výstupu

¨ zobrazovat skryté předlohy – po stisku této ikony uživatel bude mít k dispozici i ty předlohy výstupu, které mají ve svých vlastnostech zatržen příznak „skrytá“

¨ způsoby zobrazení okna předloh výstupu – možnost zvolení si způsobu, jak budou jednotlivé předlohy výstupu v okně výstupu uspořádány. Je možnost zvolit zobrazení: velké ikony, malé ikony, seznam, detaily a stromové zobrazení. Ve stromovém zobrazení je možno u předloh a metapředloh výstupu definovat skupiny předlohy a osobní skupiny předlohy výstupu

¨ nápověda – nápověda k činnosti

¨ nápověda – seznam položek k tisku – zobrazí se přehled atributů dané činnosti, které jsou dostupné při definování uspořádání položek výstupu

¨ konec činnosti – ukončení a zavření okna „výstupy“.

Kromě činností, které uživateli nabízí panel nástrojů (tj. horní lišta) okna výstupů má k dispozici ještě i činnosti, které se mu nabídnou po stisku pravého tlačítka myši kdekoliv ve volném (tzn. bílém) prostoru okna činnosti výstupy. Některé činnosti jsou shodné s činnostmi dostupnými v horní liště, ale navíc má uživatel k dispozici:

¨ přílohy k předloze

¨ export do balíčku

¨ překlad popisek – název předlohy

¨ metapředlohy

¨ skupiny procesů/předloh výstupu

¨ osobní skupina předlohy

¨ nastavení stromu

¨ export webovou službou

Vlastní zahájení tisku vybrané předlohy výstupu může uživatel provést těmito způsoby:

¨ dvojklikem levého tlačítka myši přímo na názvu vybrané předlohy výstupu

¨ stiskem ikony tiskárna v panelu nástrojů okna výstupů

¨ výběrem možnosti spustit předlohu po stisku pravého tlačítka myši na názvu předlohy

V případě, že není nastaveno jinak (v profilech předlohy nebo na záložce popis ve vlastnostech předlohy) zobrazí se uživateli dialogové okno tisku. Zde má uživatel možnost si zvolit rozsah tisku (všechny, aktuální, označené), jazyk, setřídění, zda předlohu tisknout nebo si data jen prohlédnout apod.

2.2.5.2 Metapředloha

Při každém výstupu v činnostech typu seznam probíhá tisk na základě vytvořené předlohy výstupu. U tisku procesů a operací je toto ještě podrobněji dopřesněno metapředlohou výstupu. Metapředloha je soubor, který obsahuje jednotlivé předlohy výstupu a zároveň se zde určuje jejich pořadí tisku, jejich profil, počet kopií apod.

Jak jsme se již zmínili, předlohy výstupu jsou uživateli dostupné ve většině činností IS BM. Při tisku běžných přehledů nebo číselníků není metapředloha pro uživatele nutností. V případě tisku operace nebo dokladu (obraz procesu) je nezbytné mít u každé předlohy ještě nadefinovanou i metapředlohu výstupu.

Při tisku operací se metapředloha výstupu zadává v diagramu procesu po stisku pravého tlačítka myši ve vlastnostech uzlu operace – atribut „po ukončení operace tisknout“ – a zde se z překryvného seznamu vybírá příslušná metapředloha, která obsahuje danou předlohu, která se pak bude po ukončení operace tisknout (podrobnější popis je uveden v následujícím odstavci).

Při tisku procesů se metapředloha zadává při definování procesu (Informační centrum – Typy a řady – Druhy procesů) a v diagramu procesu se pak vybírá ve vlastnostech uzlu po zatržení atributu „po ukončení operace tisknout doklad“.

Po aktivaci činnosti metapředlohy výstupu (z činnosti komponenty nebo po stisku pravého tlačítka myši kdekoliv v prostoru činnosti předlohy výstupu) má uživatel k dispozici tyto informace:

¨ záložka „Metapředlohy výstupu“ – identifikace a název metapředlohy a její druh (pomocí atributu druh jsou definována přístupová práva). U každé metapředlohy výstupu lze určit její skupinu (zařazení předloh výstupu a metapředloh do skupin lze pak využít při stromovém zobrazení v činnosti Výstupy). Atribut nabízet (volba Ano/Ne) určuje, zda se bude samotný název metapředlohy také nabízet v seznamu předloh výstupu.

¨ záložka „Předlohy v metapředloze“ – obsahuje jednotlivé předlohy výstupu zařazené pod danou metapředlohu. U každé předlohy se určuje pořadí, název, jazyk, profil, počet kopií atd. Důležitým atributem je „rozhodnutí“. V případě, že metapředloha obsahuje pouze jednu předlohu výstupu, uživatel zde ponechá volbu Ne, tzn. po aktivaci dané metapředlohy bude rovnou probíhat tisk dané předlohy výstupu na základě zadaného profilu. Pokud metapředloha obsahuje více předloh výstupu a uživatel si při vlastním tisku má z tohoto seznamu vybírat, musí mít tyto předlohy nastaveno default nepřipravena. V případě, že metapředloha obsahuje více předloh výstupu, z nichž jedna je ta implicitní, kterou uživatel tiskne např. v 90% případů, ale ostatní chce mít také k dispozici ve výběru, je možno u této implicitní nastavit default připravena a ostatní předlohy budou mít stále default nepřipravena. Při samotném tisku se v rozhodovacím okně (okno nese nadpis „předlohy vybrané k výstupu“) pak implicitní předloha nabízí k tisku automaticky, ale v případě potřeby je možno ji změnit za jakoukoliv sestavu z přehledu předloh tisku.

¨ záložky „Výskyt“ poskytují uživateli informační přehled o tom, kde jsou dané metapředlohy zastoupeny

Postup při definování metapředlohy výstupu z operace:

¨ uživatel v diagramu procesu vybere operaci, na níž chce nastavit, že po jejím ukončení se má tisknout vybraná předloha. Ve vlastnostech této operace (pravé tlačítko myši na uzlu operace) zatrhne „po ukončení operace tisk operace“. Z překryvného seznamu si zvolí vhodnou metapředlohu (v definici této metapředlohy je uvedena tisková předloha, která se po ukončení operace bude skutečně tisknout).

¨ vytvoření metapředlohy je možno trojím způsobem. V menu Informační centrum – Typy a řady – Druhy operací si uživatel vyhledá danou operaci a na atributu metapředloha stiskne F2 nebo pravé tlačítko myši. Uživatel má možnost si vybrat z již vytvořených metapředloh nebo si vytvořit metapředlohu novou. K ní pak přiřadit vhodnou tiskovou sestavu. Druhý způsob je přímo nad událostmi dané komponenty. Uživatel si vyvolá okno výstupu (menu volby Tisk nebo Ctrl T) a kdekoliv v prázdném prostoru tohoto okna po stisku pravého tlačítka myši zvolí možnost metapředlohy výstupu. Poslední způsob, jak může uživatel editovat či vytvářet předlohy je z menu Informační centrum – Typy a řady – Komponenty, kde v menu Volby je pro každou komponentu dostupná možnost metapředlohy výstupu.

¨ každá metapředloha může obsahovat „n“ tiskových předloh. Tyto předlohy jsou předlohy vytvořené „klasicky“ nad událostmi dané komponenty.

Postup při definování metapředlohy výstupu z procesu:

¨ v diagramu druhu procesu uživatel ve vlastnostech operace (té operace, jejíž události vstupují na tisk dokladu jako poslední) zatrhne atribut „po ukončení operace tisk dokladu“.

¨ v menu Informační centrum – Typy a řady – Druhy procesů u zvoleného druhu procesu nastaví po stisku F2 nebo pravého tlačítka myši metapředlohu výstupu. Může vybrat vhodnou z překryvného seznamu nebo si v případě potřeby vytvořit metapředlohu novou.

¨ jednotlivé tiskové předlohy, které si pak uživatel přiřazuje k metapředlohám se pro procesy vytvářejí v menu Procesy a operace – Procesy po aktivaci činnosti tisk (menu volby Tisk nebo Ctrl T). V této činnosti uživatel stiskne pravé tlačítko myši kdekoliv ve volném prostoru okna „výstupy“. Zvolí možnost metapředlohy a zadá si novou metapředlohu k níž přiřadí vybranou předlohu výstupu.

¨ u každé předlohy výstupu vytvořené v činnosti Procesy je nutno v jejích vlastnostech (vlastnosti předlohy si uživatel vyvolá pravým stiskem myši na názvu předlohy) nastavit ještě prezentaci. Prezentace jsou nástroj, kterým uživatel určuje, které události operací daného procesu budou pro uživatele k dispozici na předloze výstupu.

¨ jednotlivé prezentace se definují v menu Informační centrum – Typy a řady – Prezentace procesů.

2.2.5.3 Automatické užití předlohy

Jak vyplývá z předchozí kapitoly, je možno pomocí správného nastavení docílit automatického tisku předlohy. Automatický tisk lze nastavit:

¨ při ukončení operace – ta musí mít ve vlastnostech nadefinováno „po ukončení operace tisk operace“ a musí mít zvolenu metapředlohu výstupu, která obsahuje alespoň jednu předlohu výstupu. Pak se při ukončení operace uživateli automaticky nabízí dialogové okno tisku předlohy (není-li v parametrech nebo profilech nastaveno jinak)

¨ při tisku procesů – operace, jejíž záznamy vstupují na předlohu jako poslední musí mít ve vlastnostech nadefinováno „po ukončení operace tisk dokladu“, musí mít zvolenu metapředlohu výstupu, která obsahuje alespoň jednu předlohu výstupu (ta musí mít nastavena správně prezentaci procesu). Při ukončení této operace v procesu se uživateli automaticky nabízí dialogové okno s možností tisku daného dokladu (není-li v parametrech nebo profilech nastaveno jinak)

Kromě klasického spuštění tisku (tj. výběr ikony z panelu nástrojů, Ctrl T nebo pod menu Volby) existuje ještě možnost vyvolat tisk po spuštění vybrané funkční klávesy. Nejedná se o plně automatický tisk (ten vlastně probíhá bez zásahu uživatele až k dialogovému oknu tisku), nicméně tím, že po stisku funkční klávesy není uživatel nucen si vybírat se seznamu nadefinovaných předloh výstupu se o něm zmíníme. Jedná se o tyto možnosti:

¨ ve vlastnostech činnosti v hlavním menu je možno ve výběru nadefinovat metapředlohu dané činnosti. Potom při spuštění dané činnosti a stisku klávesy F12 dochází k tisku určené předlohy pro danou činnost.

¨ v činnosti „procesy“ (hlavní menu Procesy a operace – Procesy) lze u vybraného procesu vyvolat tisk po stisku klávesy F5 – výstup dokladu. Uživatel však musí tuto funkční klávesu použít na procesu, který má nadefinován tisk dokladu (tzn. zvolenou příslušnou metapředlohu).

¨ na operaci lze vyvolat tisk dokladu (tzn. metapředlohy, která je nadefinovaná ve vlastnostech operace po jejím ukončení) po stisku klávesy F11

2.2.5.3.1 Prohlížeč výstupů předloh

Po stisku ikony tiskárna (nebo Ctrl T) na vybrané předloze výstupu se uživateli zobrazí dialogové okno "zahájení výstupu podle předlohy". Uživatel si v současné době mohl zvolit směr tisku "na tiskárnu, do souboru nebo prohlížení". K volbě prohlížení má nyní k dispozici i možnost nemodálního prohlížení výstupů klasických předloh výstupu. Toto mu umožňuje nový atribut "v prohlížeči výstupů předloh".

Při jeho zatržení se uživateli následně zobrazí daná sestava ve formě náhledu před tiskem ve vlastním formuláři "prohlížeč výstupů předloh" s vlastní ovládací lištou. Pokud nechá uživatel tento formulář aktivní, tak při prohlížení jednotlivých klasických sestav se zatrženým atributem "v prohlížeči výstupů předloh" se všechny tyto sestavy zobrazují jako přehled právě v tomto formuláři, tzn. uživatel může mít např. vyfiltrován přehled vystavených faktur a vyvoláním tisku každé faktury se zatrženým atributem "v prohlížeči výstupů předloh" se do formuláře "prohlížeč výstupů předloh" naplní přehled všech těchto faktur.

Pomocí ikonek na ovládací liště (tlačítko první stránka/předchozí stránka/následující stránka/poslední stránka) se uživatel může v přehledu volně pohybovat, přičemž levá část formuláře zobrazuje přehled předloh výstupu a pravá část formuláře zobrazuje náhled dané předlohy.

Další tlačítko "zachovat/nezachovat poměr rozměrů výšky šířky stránky" funguje jako přepínač a umožňuje uživateli buď zachovat poměr rozměrů výšky a šířky dané předlohy výstupu nebo po jeho stisku roztažení předlohy výstupu do nastavené velikosti daného formuláře. Tím je ovšem porušen poměr rozměrů předlohy výstupu, tzn. že daná předloha výstupu je pro uživatele zvětšená, tj. čitelnější, ovšem bude zřejmě mnohem více zvětšena do šířky. Po stisku pravého tlačítka na tomto přepínači se automaticky upraví šířka formuláře, tzn. zarovná se přesně na velikost stránky.

Tlačítko tiskárna aktivuje tisk dané předlohy výstupu. Tlačítko dveře znamená totéž co ESC, tzn. opuštění a uzavření formuláře "prohlížeč výstupů předloh".

Pokud tedy zůstává tento formulář aktivní, tzn. uživatel ho během práce s IS BM nezavírá, ale např. pouze "uklízí" na dolní lištu PC, přehled jednotlivých zobrazených předloh výstupu narůstá a mohou zde být zobrazeny všechny předlohy, které uživatel použil během dne při práci s IS BM. V případě, že uživatel tento formulář ukončí, přehled předloh výstupu se vymaže a při dalším spuštění tohoto formuláře je opět prázdný.Tuto vlastnost předloh výstupu lze využívat pouze pro verze IS BM pod FoxPro 9 a vyšší.

Upozornění:

V některých případech nemusí zobrazená předloha výstupu plně odpovídat její vytištěné verzi. Program, který je využit ve formuláři na zobrazení předloh výstupu toto technicky neumožňuje (a není z autorské dílny firmy BM Servis), tzn. pouze ho pro tento formulář využíváme a u některých předloh může docházet ke zkreslení atributů (především atributů typu formát), tzn. že uživatel pak místo částky vidí hvězdičky/tečky nebo jsou chybně zobrazena pořadová čísla apod. V takovém případě doporučujeme, pokud je to technicky možné, aby si uživatel danou předlohu výstupu upravil (tzn. atributy typu formát zvětšil).

2.2.5.4 Výběry

Výběry má uživatel k dispozici po stisku příslušné ikony v panelu nástrojů nebo po stisku pravého tlačítka myši na názvu předlohy a zvolení možnosti „výběry“. Tyto výběry slouží uživateli pro případ, že záložka výběr a možnosti ve vlastnostech předlohy (setřídění, doplnění, seskupování) nesplňuje přesně jeho požadavky. Tímto výběrem si pak požadovaná výběrová kritéria může upřesnit. Při spuštění předlohy výstupu s tímto použitým výběrem (je nutno ho zvolit z překryvného seznamu v dialogovém okně tisku) pak IS BM provádí svůj SELECT, který vychází z činnosti (nad kterou probíhá tisk) a je upraven podle uživatelských definic ve vlastnostech předlohy (setřídění, seskupování, doplnění).

Při definování nového výběru uživatel zadavá na záložce „výběry“ název a vlastní komentář k danému výběru. Na druhé záložce „definice podmínky“ definuje jednotlivé atributy činnosti, které mají ve výběru vstupovat (jejich definice je shodná s definováním položek výstupu – pomocí šipek přesunout) a jejich podmínku (tzn. uživatel si zvolí příslušný výraz a nadefinuje jeho podmínku).

Po uložení (stisk ikony „disketa“) je výběr nadefinován a uložen v seznamu výběrů činnosti, které má uživatel k dispozici v panelu nástrojů činnosti výstupy. Při vyvolání tisku a zobrazení dialogového okna si může uživatel daný výběr vybrat z překryvného seznamu (atribut „podmínka“).

2.2.5.5 Elektronický podpis

Pro potřeby automatizovaného podpisu elektronickou značkou (zejména dokladů, a to i vystavených na pozadí) lze ukládat v IS BM systémové certifikáty. Systémové certifikáty se definují ve formuláři Informační centrum – Typy a řady – Systémové certifikáty. Uvádí se:

¨ identifikace systémového certifikátu - 6 znaků

¨ název certifikátu

¨ druh certifikátu

¨ soubor certifikátu - jméno souboru na disku s příponou PFX (exportovaný privátní klíč)

¨ poznámka

Ke každému syst. certifikátu je nutné uložit heslo, se kterým byl soubor certifikátu vytvořen (menu Volby – funkční klávesa F5). Toto heslo je bezpečně uloženo v databázi (zakryptované). Tato funkcionalita mimo jiné umožňuje nastavit v IS BM automatizované odesílání dokladů podepsaných elektronickou značkou.

Podepisování dokumentů probíhá interními rutinami BM.EXE, kterým je jedním z parametrů předána 'Identifikace systémového certifikátu'. V této chvíli je tímto způsobem vyřešeno podepisování dokumentů:

¨ PDF - Acrobat Reader - podepisování nástrojem PortableSigner (Open Source) http://portablesigner.sourceforge.net/

¨ XML - podle norem XML Signature Syntax and Processing (Second Edition) http://www.w3.org/TR/xmldsig-core/, XML Encryption Syntax and Processing http://www.w3.org/TR/xmlenc-core/ , Canonical XML http://www.w3.org/TR/xml-c14n, Exclusive XML Canonicalization http://www.w3.org/TR/xml-exc-c14n/ - podepisování nástrojem XML Security Library (Open Source)

¨ http://www.aleksey.com/xmlsec/index.html - tento způsob podepisování dokumentů se používá pro soubory ve formátu ISDOC = elektronická fakturace (nachází se ve fázi přípravy)

2.2.6 Výkazy

Výkazy je nazývána ta část IS BM, která zpřístupňuje uživateli informační schopnost IS BM formou, ve které je vlastní výstup prezentován pomocí sešitu tabulkového procesoru MS Excel, tj. výkazem. Jako zdrojová datová základna pro sestavení výkazu a naplnění jeho obsahu informacemi jsou disponibilní veškerá (ze všech tabulek) data IS BM v aktuálním stavu. Výkazy tedy rozumíme manažerskou část IS BM, která je určena k analýze dat (analytickému zpracování) a která zajišťuje poskytnutí informační schopnosti IS BM uživateli výstupy (výsledky jsou realizovány pomocí MS Excel).

Věcná struktura těchto výstupů a uspořádání poskytovaných informací v nich je vždy dáno uživatelským nastavením v definici každého z nich. Uživateli jsou všechny činnosti související s touto částí IS k dispozici v hlavním menu pod skupinovou položkou INFORMAČNÍ CENTRUM - VÝKAZY.

Tuto část IS lze rozdělit na dvě poloviny. První je „sestavení výkazu“ ve které je umožněno uživateli vypočítat obsah výkazu z aktuálních dat IS. Druhou tvoří definice výkazu.

2.2.6.1 Sestavení výkazu

Sestavením výkazu se rozumí automatický výpočet výsledných informací a jejich následná prezentace pomocí MS Excel podle definice výkazu ze zdrojových dat (tabulek IS BM), který je iniciován uživatelem spuštěním odpovídající činnosti INFORMAČNÍ CENTRUM – VÝKAZY – VÝKAZY KE SPUŠTĚNÍ nebo přímo ze seznamu definic výkazu.

Po volbě definice výkazu, tj. po spuštění položky menu, je uživatel v dialogovém okně vyzván k zadání zpřesňujících volitelných požadavků na prezentované informace - proměnných dotazu výkazu (např.: období, selektory apod.), jejichž hodnoty se použijí jako aktuální hodnoty parametrů při vlastním sestavení výkazu.

Následně se spustí MS Excel s aplikací šablony na jednotlivé listy a dle nastavení u ní se existující list výstupního souboru v MS Excel buď zruší nebo se jím sestavovaný list předplní (vhodná varianta například v případě definice grafů ve výstupním souboru).

Po té je zahájeno plnění jednotlivých buněk výkazu dle nastavení v definici listu, což má uživatel možnost pozorovat. Současně je informován v samostatném okně o procentu, do jaké míry je již výkaz sestaven, s možností přerušení (ESC) výpočtu s jeho následným předčasným ukončením.

Po ukončení sestavení výkazu je komunikace a „propojení“ IS BM a MS Excel ukončena, tj. oba systémy se stanou nezávislými z hlediska dalších aktivit uživatele.

Po rozhodnutí uživatele ukončit práci s daným výkazem v MS Excel má možnost jej uložit buď s cílem dalšího budoucího zpracování do souboru pod nově zadaným jménem (nedojde k přepsání při opakovaném sestavení výkazu) nebo pod svým jménem, což může umožnit případné předplnění dat, formátů a grafů při opakovaném sestavení výkazu.

2.2.6.2 Definice výkazu

Definice výkazů jsou členěny dle druhu výkazu, který se v případě existence výkazu daného druhu stává skupinovou položkou menu (INFORMAČNÍ CENTRUM - VÝKAZY – VÝKAZY KE SPUŠTĚNÍ – <DRUH VÝKAZU>), kde jsou definice výkazů dostupné pro sestavení výkazu s aktuálními daty těm uživatelům, kteří mají přístupové právo (čtení nebo zápis) k danému druhu výkazu.

Identifikátory tabulek IS BM, které patří do této části IS, začínají písmeny VK.

Definice výkazu je daná výčtem definic jednotlivých listů sešitu MS Excel s případným doplněním o inicializační parametry listu a parametry listu v daném výkazu a dále doplněním o nastavení možnosti zpřesnit požadavky uživatele na selekci a agregaci dat či uspořádání výsledků formou dotazu na konkrétní hodnoty proměnných dotazu výkazu, které jsou následně parametry listu, v okamžiku jeho sestavení.

Výkazy IS BM umožňují definovat i listy výkazu, které obsahují kontingenční tabulku Excel.

Definice listu výkazu je souborem pravidel, která definují způsob naplnění výsledných informací z jednotlivých tabulek IS BM (způsob selekce a agregace elementárních dat) a která dále definují způsob uspořádání výsledných informací do řádků, sloupců a buněk listu sešitu MS Excel s cílem jejich prezentace uživateli. Jedna definice listu může být užita v několika definicích výkazu.

Uspořádání dat prezentovaných listem MS Excel ovlivňuje dále šablona listů výkazů, která je též součástí definice listu. Současně definuje počáteční řádek a sloupec, se kterými koresponduje definice prvního řádku a sloupce v definici listu, a dále údaj, zda se při sestavování výkazu má nejprve existující list výstupního souboru (sešitu MS Excel) zrušit.

Dodatečné deklarace umožňují ovlivnit sestavení výkazu příkazem LOCK zamknout zdrojová data (zabránit zápisu událostí) uvedených komponent po dobu sestavení výkazu (zajištění integrity zobrazených hodnot) a dále umožňují formulovat podmínky, při jejichž nesplnění uvedený sloupec definice listu nebude zařazen do listu sestaveného výkazu.

Základem definice listu je nastavení vlastností jednotlivých buněk buď explicitně nebo implicitně dle řádků a sloupců. Explicitní definice buňky umožňuje její pojmenování výrazem, nastavení hodnot parametrů, její formátování a definování jejího obsahu buď výpočtem pomocí výrazů v syntaxi FoxPro, které mohou využívat parametry i funkce výkazů, nebo vzorcem v syntaxi MS Excel v anglickém jazyce nebo vyplývá (implicitní definice) z definice sloupce či řádku.

V případě, že není buňka, resp. některá její vlastnost, explicitně definována, uplatní se definice implicitní (zděděná), tj. definice řádku, je-li v ní daná vlastnost definována, nebo sloupce, pokud je v ní daná vlastnost definována a není definována v definici řádku, nebo listu, pokud je v ní daná vlastnost definována a není definována v definici řádku ani sloupce.

Definice řádku prezentovaná identifikátorem řádku umožňuje definovat pořadí a název řádku, nastavení hodnot parametrů, formát a obsah jeho buněk, zda má být ve výkazu skrytý. Definice sloupce je analogická, pouze pro definici obsahu neumožňuje variantu prázdný (nemá význam). V definici parametrů řádku či sloupce je možné jako první uvést příkaz dyn, který umožní z jedné definice dynamicky vygenerovat při sestavení výkazu tolik řádků (sloupců), kolik je vrátí prvků v jeho seznamu.

V IS BM jsou k dispozici dvě metody pro sestavení definice listu výkazu a to metoda přímá a metoda s použitím vzoru listů výkazu, který je též uživatelsky definovaný.

Přímá metoda může využívat v jednotlivých elementech (sloupec, řádek, buňka) definice listu přímo funkce výkazu k referenci do (vytěžení informací ze) zdrojových tabulek IS BM. Pro zajištění korespondence mezi definicí listu a budoucím listem MS Excel je ve fázi sestavení k dispozici navigační „List“, který zahrnuje uspořádání všech definovaných buněk.

Metoda s použitím vzoru listu výkazu využívá k referenci do zdrojových tabulek funkce výkazu zprostředkovaně přes výrazy vzoru (ukazatele), které jsou pomocí nich uživatelsky definovány. Tato logická vrstva (ukazatele) umožňuje a usnadňuje laickou definici výkazu. Současně je při použití této metody předdefinována základní struktura výkazu. Z takto uskutečněné definice listu pomocí vzoru vygeneruje IS BM standardní definici listu, která je následně k dispozici pouze pro prohlížení.

Nyní se vrátíme k jednotlivým částem definice výkazu a to jsou:

¨ druh výkazu – druh výkazu umožňuje definice výkazu členit do určitých skupin. Pro každý druh výkazu lze nastavit přístupová práva, kde čtení se rovná právo vidět a užít definici výkazu pro sestavení výkazu a zápis se rovná právo modifikovat (tj. opravovat) definici výkazu. Každý druh výkazu, pokud existuje alespoň jedna definice výkazu daného druhu, se stává skupinovou položkou hlavního menu zařazenou pod INFORMAČNÍ CENTRUM – VÝKAZY – VÝKAZY KE SPUŠTĚNÍ, pod kterou jsou uživatelům dostupné definice výkazu pro sestavení relevantních výkazů.

¨ dotaz výkazu – dotaz výkazu je uživatelské nastavení, na základě kterého je v okamžiku sestavení výkazu uživatel v dialogovém okně vyzván k zadání hodnot proměnných dotazu, ze kterých mohou být hodnoty jiných proměnných dotazu vypočteny. Proměnné dotazu jsou dostupné v definici listu či výkazu jako parametry, jejich hodnoty jako skutečné hodnoty parametrů při sestavení výkazu. Definice dotazu se skládá z názvu, pod kterým je dostupný v definici výkazu a který je uveden v nadpisu dialogového okna, designu vstupního formuláře (dialogového okna) a volného textu pro popis.

¨ výstupní soubor – definice souboru (do kterého bude sestaven výkaz) a jeho adresáře. Soubor lze definovat přímo (například trzby.xls) nebo výrazem (například s využitím parametrů 'urp'+[rok]+[mes]+'.xls'). Programový adresář je implicitní. Při opakovaném sestavení výkazu se nejprve načte již existující výstupní soubor výkazu a jeho listy jsou dle nastavení u šablony smazány nebo přepsány. Pokud je v názvu souboru výkazu obsažen adresář který neexistuje, IS BM jej před vytvořením výkazu založí.

¨ výraz názvu

¨ zamykat – příznak, zda zamykat listy výkazu

¨ heslo, pokud je výkaz definován jako uzamčený pro uživatele po sestavení

¨ zobrazovat seznam polí – překryvný seznam s možnostmi Ano/Ne – určuje zda se má ve výkazu zobrazovat seznam polí kontingenčních tabulek (pouze pro Excel 2007, v jiných verzích Excelu se neuplatňuje)

¨ popis výkazu - volný text pro poznámky

2.2.6.3 Proměnná dotazu

Proměnná dotazu je (podobně jako proměnná výběru) uživatelsky definovaná proměnná, která je parametrem použitelným v definici výkazu i jeho prvků a po nabytí hodnoty při sestavení výkazu. Použitelné typy proměnných jsou N, C, D a T.

V případě definice jejího naplnění vstupem je možné uvést její implicitní hodnotu výrazem a umístit ji v rámci designu vstupního formuláře. V případě definice jejího naplnění výpočtem je nutné uvést výpočtový výraz, ve kterém lze užít proměnné naplněné vstupem v syntaxi [promvst]. Proměnné jsou současně parametry výkazu s identifikátorem shodným s názvem proměnné.

2.2.6.4 Definice listu výkazů

Definice listu výkazů je soubor pravidel, podle kterých bude sestaven daný list při sestavení výkazu. V IS BM jsou k dispozici dvě metody pro uživatelské nastavení definice listu výkazů a to metoda přímá nebo metoda s použitím vzoru listů výkazu. Jedna definice listu přitom může být přiřazena do několika definic výkazu. Ve výkazech IS BM je možno definovat i listy, které obsahují kontingenční tabulky [5]. Pro účely této definice je činnost „Listy výkazů“ rozdělena do čtyř záložek, které si v dalším textu podrobně popíšeme:

¨ Listy výkazů – kde se vstupují základní informace o listu (společná záložka pro běžné i kontingenční typy listů)

¨ Běžný list – zde se vstupují atributy běžných typů listů výkazů

¨ Kontingenční list – zde se vstupují atributy kontingečních typů listů výkazů

¨ Pole kontingenčního výkazu – zde se vstupují vlastnosti jednotlivých polí vytvářené kontingenční tabulky

Záložka „Listy výkazů“:

- jedna definice listu může být přiřazena do několika definic výkazu. Definice listu výkazu obsahuje tyto atributy:

¨ identifikace a název listu

¨ šablona – identifikace šablony, která ovlivňuje uspořádání dat prezentovaných listem MS Excel. Současně definuje počáteční řádek a sloupec, se kterými koresponduje definice prvního řádku a sloupce v definici listu, a dále údaj, zda se při sestavování výkazu má nejprve existující list výstupního souboru (sešit MS Excel) zrušit. Obvykle se v rámci souboru šablony definuje grafika výkazu, pojmenované texty a buňky, jimž mohou být následně přiřazovány hodnoty v definici výkazu a následně při sestavení výkazu.

¨ vzor, pokud je list definován pomocí něj (následně funkční klávesa F7 nebo aktivace příslušné činnosti z menu Volby)

¨ typ listu – překryvný seznam s možnostmi výběru běžný/kontingenční

¨ parametry listu – jsou uživatelem definované parametry, které se užívají v definici výkazu, resp. listu, pro její usnadnění nebo s cílem zajištění určité variability obsahu výkazu dle požadavků uživatele při sestavení výkazu

¨ poznámka – vlastní poznámka k danému listu výkazu

Záložka „Běžný list“:

¨ implicitní název listu

¨ pohled – identifikace pohledu slovníku dat (v současné době nevyužívaný atribut)

¨ Where – doplněk dotazu Where pohledu slovníku dat (v současné době nevyužívaný atribut)

¨ předloha – identifikace předlohy pro výstup (v současné době nevyužívaný atribut)

¨ implicitní formát buněk – identifikace a název implicitního formátu buněk listu

¨ deklarace - dodatečné deklarace umožňují příkazem LOCK zamknout zdrojová data uvedených komponent (např. LOCK UCE zabrání zápisu událostí účetnictví po dobu sestavení výkazu, což vede na zajištění integrity zobrazených informací ve výkazu) a dále umožňují formulovat podmínky, při jejichž nesplnění nebude uvedený sloupec nebo řádek definice listu zařazen do listu sestaveného výkazu (např. $S(80) [rok]='2000' definuje, že sloupec s identifikací 80 v definici listu bude do výkazu při jeho sestavení zařazen pouze tehdy, je-li hodnota parametru rok dva tisíce; podobně pro řádek $R(80) [rok]='2000').

¨ kód – skript v jazyce Foxpro. Tento skript musí začínat slovem SCRIPT. Má-li funkce definované parametry, jsou tyto v programu skriptu dostupné jako proměnné identifikované _par_ + název parametru.

Funkce typu seznam musí vytvářet kurzor s aliasem _WORK, ostatní musí vracet požadovanou hodnotu příkazem RETURN.

Příklad skriptu :

SCRIPT

LOCAL _navrat

_navrat=tool.sql_dotaz([select sum(uc03ksvyk*(if ucrozvrh.uc01strana=1 then 1 else -1 endif)) from %%%.ucobrtab,%%%.ucrozvrh where uc01id like ?_p1 ]+;

[and uc03mesic=?_p2 and uc03rok=?_p3 and uc03druh=?_p4 and uc03faze=2 ]+;

[and oc01id='CZK' and ucobrtab.uc01id=ucrozvrh.uc01id],_par_ucet,_par_mesd,_par_rokd,_par_druh)

_navrat=_navrat+563

RETURN _navrat

V případě užití přímé metody pro nastavení definice listu (aktivace činnosti v menu Volby nebo klávesa F6) uživatel za pomoci navigačního listu definuje přímo jednotlivé sloupce, řádky a buňky definice listu.

V případě užití metody pro nastavení definice listu pomocí vzoru (aktivace činnosti v menu Volby nebo klávesa F7) uživatel definuje jednotlivé sloupce, řádky a buňky definice listu zprostředkovaně pomocí dříve připraveného vzoru listu s tím, že možnosti i složitost nastavení jsou oproti metodě přímé omezeny.

Záložka „Kontingenční list“:

Na této záložce se vstupuje atribut SQL, vztahující se ke kontingenčnímu typu listu výkazu. Tento textový atribut obsahuje SQL dotaz, který je zdrojem dat pro vytvářenou kontingenční tabulku. V SQL dotazu se mohou uplatnit proměnné listu výkazu uvedené v hranatých závorkách.

Záložka „Pole kontingenčního listu“:

- zde se vstupuje seznam polí vytvářené kontingenční tabulky. Pro každé pole se definuje:

¨ název pole - musí korespondovat s názvem atributu vytvářeným SQL dotazem (musí být exaktně totožný, tj. včetně diakritiky a velkých a malých písmen)

¨ pořadí – uvedené číslo vyjadřuje pořadí zpracování pole při vytváření kontingenční tabulky

¨ oblast - překryvný seznam s možnostmi Žádná/Filtr sestavy/Popisky sloupců/Popisky řádků/Hodnoty - určuje oblast kontingenční tabulky, ve které se má pole uplatnit

¨ určení oblasti výrazem - tento atribut je určen pro uvedení proměnné výkazu tak, aby při použití list v konkrétním výkazu bylo možné měnit umístění jednotlivých polí a uplatní se pouze v případě, že výraz představuje numerickou hodnotu v intervalu 1-5

¨ filtr sestavy - uplatní se pro pole v oblasti 'Filtr sestavy' a uplatní se pouze v případě, že hodnota výrazu odpovídá některé z hodnot pole v kontingenční tabulce

¨ výběr popisků - uplatní se pro pole v oblasti 'Filtr sestavy', 'Popisky sloupců' nebo 'Popisky řádků' - výraz musí obsahovat textový literál, který obsahuje výraz vyhodnocovaný v okamžiku vytváření kontingenční tabulky - tento výraz přitom obvykle pracuje s proměnnou _PIVOTITEM (objekt položky pole), nejčastěji s jeho vlastností _PIVOTITEM.VALUE

¨ zobrazení podpopisků - uplatní se pro pole v oblasti 'Popisky sloupců' nebo 'Popisky řádků' - výraz musí obsahovat textový literál, který obsahuje výraz vyhodnocovaný v okamžiku vytváření kontingenční tabulky - tento výraz přitom obvykle pracuje s proměnnou _PIVOTITEM (objekt položky pole) nejčastěji s jeho vlastností _PIVOTITEM.VALUE

¨ formát čísla - uplatní se pro pole v oblasti 'Hodnoty' (např. #,##0.00)

¨ skript - skript v jazyce FoxPro provedený po zpracování daného pole (kódu jsou přitom k dispozici objekty - v proměnné _PIVOTFIELD objekt pole kontingenční tabulky a v proměnné _PIVOTTABLE objekt kontingenční tabulky)

¨ poznámka – libovolný text k jednotlivým polím kont. listu

2.2.6.5 Šablona listů výkazů

Šablona listů výkazů tedy definuje soubor se šablonou pro list MS Excel, která se uplatní při sestavení výkazu, a jeho adresář (např.: template\Statvy.xlt). Implicitní je programový adresář. Na atributu „soubor šablony“ lze klávesou F2 vyvolat vstup, kterým se provede zápis kopie souboru šablony do databáze. Kopie obsahu souboru šablony je ukládána v databázi ve formátu ZIP a přitom se používá knihovna VFPCOMPRESSION.FLL, která je obvykle uložena v adresáři PRGS (při neexistenci knihovny VFPCOMPRESSION.FLL nejsou kopie souborů šablony ukládány). Kopie jednoho souboru se stejným názvem je v databázi uložena pouze jedenkrát a při změně názvu souboru je kopie souboru v databázi automaticky zrušena v případě, kdy se jedná o soubor, který není uveden jako příloha některé předlohy výstupu nebo jako soubor jiné šablony.

Ve formuláři se zobrazuje datum a čas kopie souboru, která je uložena v databázi. Při zápisu dat formuláře se porovnává tento datum a čas s datem a časem souboru, který uložen na disku a v případě, že se nerovnají (+- 2 vteřiny),

je nabídnuta možnost zápisu kopie obsahu souboru do databáze.

Při spuštění výkazu, je prováděna kontrola toho, zda všechny jeho šablony na disku existují a v případě, že neexistují jsou „vybaleny“ jejich kopie z databáze. Provádí se pouze kontrola existence souboru, vůbec se neporovnává datum a čas souboru (tj. nedochází k přepisu souboru na disku ani v případě, že je starší než jeho kopie v databázi).

Podmínkou pro tuto funkci je existence knihovny VFPCOMPRESSION.FLL, pokud není tato knihovna nainstalována, potom se při spuštění nebo opravě předlohy výstupu objeví hlášení „Výkaz obsahuje soubory šablon, které není možné vybalit, protože nemáte nainstalovanou knihovnu VFPCOMPRESSION.FLL“.

Při exportu definice výkazu do balíčku, jsou exportovány také jeho šablony včetně kopie obsahu souboru šablony.

Import balíčku nikdy nepřepisuje kopii souboru šablony v databázi a ani neprovádí její „vybalení“ do souboru na disku (to se provede až při prvním spuštění výkazu).

Knihovna VFPCOMPRESSION.FLL požaduje pro svou funkci ve Windows starších než Vista existenci souborů C:\WINDOWS\SYSTEM32\MSVCP71.DLL a C:\WINDOWS\SYSTEM32\MSVCR71.DLL.

Dále definuje počáteční řádek a sloupec, se kterými koresponduje definice prvního řádku a sloupce v definici listu, a údaj, zda se při sestavování výkazu má nejprve existující list zrušit.

Atributem šablony „vymazat list – Ano/Ne“ je možno nastavit, zda se má obsah listu výkazu v Excelu před jeho vytvářením vymazat, tzn. následný vytvořený výkaz bude přesně korespondovat s nadefinovanou šablonou (řádky, sloupce, velikost tabulky apod.).

Obvykle se v rámci souboru šablony definuje grafika výkazu, pojmenované texty a buňky, jimž mohou být následně přiřazovány hodnoty v definici výkazu a následně při sestavení výkazu.

IS BM předpokládá, že v šabloně je definováno:

¨ pojmenovaný text „autor“, který je pak automaticky při sestavení výkazu naplněn jménem přihlášeného uživatele,

¨ pojmenovaný text „nadpis“, který je pak automaticky při sestavení výkazu naplněn názvem listu (implicitně), pokud není název listu definován explicitně v atributu parametry, kde dostupný pod symbolem „nadpis_listu“ v atributu parametry pro naplnění skutečným obsahem,

¨ pojmenovaná buňka „nadpis_sloupce“, která pak definuje řádek, do kterého se budou automaticky při sestavení výkazu ukládat názvy sloupců (implicitně), pokud není název sloupce definován explicitně v atributu parametry, kde je dostupný pod symbolem „nadpis_sloupce“.

2.2.6.6 Nastavení definice listu – užití přímé metody

Jak je výše uvedeno, v případě užití přímé metody pro nastavení definice listu uživatel využívá navigační list. Tento list je okno, které se automaticky zobrazí společně s formulářem činnosti definice listu. Obsahuje a zobrazuje všechny definované buňky definice výkazu. Je určen pro navigaci v definici listu, tj. při kliknutí na danou buňku v navigačním listu je pod ním uživateli zobrazena definice této buňky včetně definice řádku, sloupce a parametrů listu.

2.2.6.7 Řádek definice listu výkazů

Řádek je elementem definice listu s prioritou nejvyšší po buňce, tj. může definovat její implicitní vlastnosti. Daný řádek definice listu je dostupný pomocí navigačního listu, pokud definice listu není založena pomocí vzoru listu je možné zde definovat jeho vlastnosti, případně zrušit či založit nový.

Jednomu řádku definice listu odpovídá jeden řádek výkazu, pokud je v atributu parametry řádku aplikován příkaz dyn, může to být více řádků výkazu.

Řádek definice listu výkazů prezentovaný identifikátorem řádku umožňuje definovat pořadí a název řádku, atribut parametry, implicitní formát a obsah jeho buněk výrazem, vzorcem nebo jako prázdný, případně zda má být řádek ve výkazu skrytý.

2.2.6.8 Sloupec definice listu výkazů

Sloupec je elementem definice listu s prioritou po řádku, tj. může definovat implicitní vlastnosti buňky, pokud nejsou definovány řádkem. Daný sloupec definice listu je dostupný pomocí navigačního listu, pokud definice listu není založena pomocí vzoru listu je možné zde definovat jeho vlastnosti, případně zrušit či založit nový.

Jednomu sloupci definice listu odpovídá jeden sloupec výkazu, pokud je v atributu parametry sloupce aplikován příkaz dyn, může to být více sloupců výkazu.

Sloupec definice listu výkazů prezentovaný identifikátorem sloupce umožňuje definovat pořadí a název sloupce, atribut parametry, implicitní formát a obsah jeho buněk výrazem nebo vzorcem, případně zda má být sloupec ve výkazu skrytý.

2.2.6.9 Příkaz „dyn“ v parametrech řádku nebo sloupce definice listu výkazů

V atributu parametry řádku či sloupce definice listu je možné na prvním řádku uvést příkaz dyn, který umožní z jedné definice řádku (sloupce) dynamicky vygenerovat při sestavení výkazu tolik řádků (sloupců), kolik funkce fce vrátí prvků v Seznamu.

Syntaxe příkazu s funkcí výkazu: DYN parv=fce(par1,par2,…,parn), kde:

parv – parametr, který postupně bude nabývat všech hodnot Seznamu vráceného funkcí

par1-parn – parametry, se kterými je funkce volána

fce – funkce výkazu, která vrací hodnotu typu Seznam obsahující všechny budoucí hodnoty parametru parv

Například:

Uvedení DYN adr=ADKAT000('BIMO%'), s využitím funkce výkazů ADKAT000 pro sestavení Seznamu, v atributu parametr jednoho řádku definice listu vygeneruje při sestavení výkazu tolik řádků, kolik prvků seznamu vrátí funkce ADKAT000 (zde například fce vrátí názvy všech adresátů v kategorii BIMO).

Syntaxe příkazu s funkcemi IS BM: DYN parv=SEZNAM(sez,typ,len,dec) nebo DYN parv=SEZNAMD1(d1,d2) nebo DYN parv=SEZNAMD2(m1,r1,m2,r2), kde:

sez – seznam hodnot oddělených středníkem

typ – typ hodnot v seznamu (C, N, D, T nebo M)

len – délka pro typ C a N

dec – počet desetin pro typ N

d1 – datum počátku (typ D)

d2 – datum konce (typ D)

m1 – měsíc počátku

r1 – rok počátku

m2 – měsíc konce

r2 – rok konce

SEZNAM je funkce IS BM, která postupně vrací hodnoty ze seznamu sez, např.: DYN selor=SEZNAM('112%;1135_[^5]%;2%',’C’) vygeneruje při sestavení výkazu tři řádky nebo DYN mes=SEZNAM(‘1;2;3;4;5;6;7;8;9;10;11;12’,’N’,2,0) vygeneruje při sestavení výkazu dvanáct řádků nebo DYN sel=SEZNAM(‘153%;123%;1456%’,’M’) vygeneruje při sestavení výkazu tři řádky.

SEZNAMD1 je funkce IS BM, která postupně vrací hodnoty ze seznamu datumů v intervalu od data d1 do data d2 po měsících, např.: DYN datum=SEZNAMD1({1.1.1990},{1.3.1990}) vrátí tyto datumy: 1.1.1990,1.2.1990 a 1.3.1990 a vygeneruje při sestavení výkazu tři řádky.

SEZNAMD2 je funkce IS BM, která postupně vrací hodnoty ze seznam datumů v textové formě „mm.rrrr“ od měsíce m1 a roku r1 do měsíce m2 a roku r2 po měsících, např.: DYN dat=SEZNAMD2(‘11’,’1990’,’02’,’1991’) vrátí tyto hodnoty: ’11.1990’, ’12.1990’, ’01.1991’ a ’02.1991’ a vygeneruje při sestavení výkazu čtyři řádky.

2.2.6.10 Buňka definice listu

Buňka je nejmenším elementem definice listu. Pokud není definována přímo, je definována implicitně řádkem či sloupcem definice listu, případně je definována pomocí vzoru listu. V definici listu je daná buňka dostupná pomocí navigačního listu.

Přímá definice buňky je umožněna, pokud byla vložena na odpovídajícím průsečíku řádku a sloupce v navigačním listu (menu VOLBY – Vložit buňku), což je současně možné jen tehdy, pokud definice listu není založena pomocí vzoru.

Přímá definice umožňuje definovat název buňky, který je následně použitelný ve vzorcích definujících jiné buňky, v atributu „param.“ přiřadit hodnoty parametrům, formát buňky a její obsah výrazem, vzorcem nebo jako prázdnou.

Lze využívat funkčnost makra $RS(...), které se používá ve statistických výkazech v buňkách typu vzorec[6]. Makro $RS(...) může vkládat do výsledného výrazu místo seznamu buněk Excelu jejich součet. Stane se tak v případě, že posledním znakem vzorce před makrem $RS(...) je znak '=' nebo '+' nebo '-'.

Příklad.:

K výrazu - =SUM($RS(mezisoucet)), který je vyhodnocen např. =SUM(C1,C5,C7,C11:C17,C20)

je ekvivalentní výraz - =$RS(mezisoucet), který je vyhodnocen např. =C1+C5+C7+SUM(C11:C17)+C20

2.2.6.11 Formát buňky

Formát buňky je pravidlo, které po aplikaci v definici listu pro danou buňku definuje, jak bude relevantní buňka výkazu formátována při sestavení výkazu. Formát umožňuje předdefinovat písmo, formát čísla a ohraničení buňky.

V případě, že je formát buňky uveden v definici listu, sloupce, řádku má implicitní charakter pro všechny obsažené buňky.

2.2.6.12 Parametr (užívaný ve výkazech)

Parametry užívané ve výkazech jsou uživatelem definované parametry, které se užívají v definici výkazu, resp. listu pro její usnadnění nebo s cílem zajištění určité variability obsahu výkazu dle požadavků uživatele při sestavení výkazu. Mohou být užívány jako skutečné parametry funkcí výkazu.

Parametr je některého z těchto typů: Numeric, Charakter, Date nebo Seznam hodnot. Každý parametr vystupuje pod svým identifikátorem. Nabytí hodnoty parametru je definováno některým ze způsobů uvedených v posloupnosti, jak nabývají hodnoty při sestavení výkazu:

¨ přiřazením v atributu parametry buňky, řádku nebo sloupce definice listu

¨ přiřazením v definici vzoru listu

¨ aplikací výrazu vzoru s definovanými parametry v definici listu pomocí vzoru

¨ přiřazením v atributu parametry definice listu v definici výkazu

¨ přiřazením v atributu parametry definice listu

¨ přiřazením v INI parametrech definice listu v definici výkazu

¨ proměnnou dotazu.

2.2.6.13 Parametr funkce výkazů

Parametr funkce výkazů je formální parametr, který se obvykle využije v kódu funkce pro zajištění jeho variability a tím i využití v několika variantách. V okamžiku volání funkce musí být uvedeny skutečné parametry, které se uplatní při výpočtu hodnoty funkce.

Parametry jsou některého z těchto typů: Numerický, Znakový, Datumový, Seznam hodnot nebo Makro.

V rámci definice formálního parametru funkce se uvádí: pořadí parametru ve skutečných parametrech při volání funkce, název parametru, typ parametru a v případě typu Seznam se dále uvádí relevantní atribut entity (tabulky datového modelu IS BM) a jeho délka.

2.2.6.14 Atribut parametry ve výkazech

Tento atribut typu memo je určen k uživatelské definici přiřazení hodnoty parametrům, přiřazení hodnoty pojmenovaným textům uvedených v šabloně ( nadpis listu, …), přiřazení názvu záložce listu nebo k uvedení komentáře.

K přiřazení hodnoty parametru nebo pojmenovanému textu nebo záložce je užíván výraz v syntaxi par/text/záložka=výraz, např.. nadpis_listu = _prvek.vk03nazev + ' ' +dtoc([datod]) + ' - ' + dtoc([datdo]) nebo nadpis_sloupce=[']+[mesrok] pro přiřazení hodnoty pojmenovanému textu nebo pro přiřazení názvu záložce listu zalozka_listu = ‘Tržby’ (implicitní název záložky je název listu), podobně pro přiřazení hodnoty parametru druhsh='SPO%;SPM%;SPS%;SNA%;OU%' nebo mesrok1=LEFT([mesrok],3)+STR(VAL(RIGHT([mesrok],4))-1) nebo s použitím příkazu DYN dyn seltv=SEZNAM ('1114%;1115%;13%;1A%;2%;3%') nebo dyn adr=ADKAT000('BIMO%'). Pokud je použit příkaz dyn, což je možné pouze v atributu parametry řádku nebo sloupce, musí být uveden na prvním řádku tohoto atributu.

Řádek uvedený znakem ‘*’ je interpretován jako komentář.

2.2.6.15 Výraz užívaný ve výkazech

Výrazem se zde rozumí výraz v syntaxi FoxPro s možností využití uživatelsky definovaných funkcí výkazu, parametrů, proměnné _prvek.cradr, která obsahuje aktuální číslo řádku při sestavení výkazu,a symbolů reprezentujících tyto atributy uvedených entit (tabulek) IS BM:

_prvek.vk06nazev - VKBUNKA.vk06nazev – název buňky,

_prvek.vk05nazev - VKRADEK.vk05nazev – název řádku,

_prvek.vk04nazev - VKSLOUP.vk04nazev – název sloupce,

_prvek.vk03nazev - VKLIST.vk03nazev – název listu.

Parametry se ve výrazu uvádějí svým identifikátorem uzavřeným do hranatých závorek.

Výraz lze užít k definici obsahu buněk i pojmenovaných textů, k nastavení hodnoty parametru, k definici názvu výstupního souboru výkazu, k definici výrazu vzoru.

Například výraz s funkcí výkazů ADKAT000('BIMO%') nebo s funkcí výkazů a parametry OBUDFIN([adr],[drart],[art],[alo],[datod],[datdo],[drop]) nebo výrazy konstantní 'Trzby PV' a '13%;14011%' nebo výraz s parametry a atributy entit IS BM a funkcí FoxPro _prvek.vk03nazev+' '+dtoc([datod])+' - '+dtoc([datdo]) nebo výraz s proměnnou (aktuální číslo řádku při sestavení výkazu) a parametrem _prvek.cradr+[radek_plus] apod.

2.2.6.16 Typ seznam hodnot užívaný ve výkazech

Typ seznam hodnot je skupina prvků seznamu oddělených středníkem uvozená a ukončená apostrofem, například: '112%;1135_[^5]%;2%'. Prvky seznamu mohou být typu N, C, D, T a M.

Tento typ je využíván zejména v příkazu DYN a také ve funkcích výkazu.

2.2.6.17 Vzorec užívaný ve výkazech

Vzorcem se zde rozumí vzorec MS Excel v anglickém jazyce (anglickém národním prostředí) užívaný v buňkách , řádcích a sloupcích definice listu nebo v buňce při nastavení definici listu pomocí vzoru.

Ve vzorci se referují jednotlivé řádky $R(n) a sloupce $S(n), kde n uvádí identifikátor definice řádku nebo sloupce. Odkaz $RL(n) nebo $SL(n) se použije pro referenci posledního řádku (sloupce) sestaveného výkazu, který byl vygenerován na základě příkazu dyn v atributu parametry řádku (sloupce) definice listu; pro referenci prvního se užije $R(n) nebo $S(n).

2.2.6.18 Funkce výkazů

Funkce výkazu jsou uživatelsky definovatelné funkce, které po svém volání při sestavení výkazu vracejí hodnotu některého z těchto typů: Numerická, Znaková, Datumová nebo Seznam hodnot.

Způsob výpočtu hodnoty je uživatelsky formulován pomocí programového kódu funkce. Variabilitu použití jedné funkce lze zajistit pomocí parametrů funkce, pak i při definici výrazu, ze kterého je volána daná funkce, se uvede funkce s parametry.

Součástí definice funkce výkazu je typ vracené hodnoty, template volání funkce (např.: [selor],[seltv],[selob]), tj. jak IS předplní volání funkce v sestavovaném výrazu po jejím výběru a přenesení (F2 – CTRL Enter) z jejich seznamu, programový kód a struktura parametrů funkce. Založení nové funkce výkazu uživatelem je autorizováno.

2.2.6.19 Kód funkce výkazů

Kód funkce výkazu je programový kód, ve kterém je napsána funkce výkazu obvykle s cílem získání hodnot, údajů či informací ze zdrojových dat (tabulky IS BM).

Vychází z jazyka FoxPro a jazyka SQL databázového serveru (jednoduché příkazy v syntaxi FOXPRO, příkazy IF a ENDIF a příkaz SET, který provádí SQL dotaz). Parametry funkce, pokud jsou v kódu použity, se uvádějí v syntaxi ?_par_ppp a v syntaxi &_par_ppp pro parametry typu Seznam hodnot nebo Makro, kde ppp je identifikátor parametru uvedený v jejich seznamu na záložce parametry funkce (například: selor).

Uvedení parametru typu Seznam hodnot je automaticky transformováno, například: Kód SET SELECT SUM(sp71prijem) FROM %%%.SPSTATIS WHERE _par_selor AND … bude transformován, pokud při volání funkce platí selor='112%;1135_[^5]%;2%' a v definici parametru [selor] je uveden atribut SPSTATIS. sp11idzak , takto SET SELECT SUM(sp71prijem) FROM %%%.SPSTATIS WHERE (SPSTATIS. sp11idzak LIKE ‘112%‘ OR SPSTATIS. sp11idzak LIKE ‘1135_[^5]%‘ OR SPSTATIS. sp11idzak LIKE ‘2%‘) and ….

Parametr typu Makro je v kódu nahrazen textovým řetězcem, který skutečný parametr obsahuje v okamžiku volání funkce výkazu.

2.2.6.20 Nastavení definice listu pomocí vzoru listů výkazu

Pokud uživatel definuje list výkazu pomocí metody s použitím vzoru listů, musí mít nadefinován i tento vzor. Vzor listů výkazů je uživatelsky připravená „šablona“, která uživateli usnadní nastavení definice listu. Každý vzor je opakovaně použitelný pro více listů, které jsou si svou strukturou a obsahem podobné, například přípravu všech definic listů účetních výkazů lze usnadnit jediným vzorem.

Příprava vzoru zahrnuje definici jeho identifikace, která se případně uvádí v definici listu, název, atribut parametry a případnou pevné uživatelem při aplikaci vzoru již neovlivnitelné nastavení prvních tří sloupců definice listu. Uvedené nastavení sloupce spočívá v uvedení jeho názvu (budoucí nadpis), definice obsahu výrazem, formátu a šířky. Příprava vzoru dále zahrnuje definici výrazů daného vzoru.

Nejnáročnější částí při definování vzoru listů výkazů je pravděpodobně definice výrazu vzoru. Výraz vzoru listu je definice „ukazatele“ (logického pojmu), který využívá uživatel při definici listu pomocí vzoru. Výraz vzoru listu je definován pořadím, popisem, tj.názvem, pod kterým je dostupný uživateli ve vzoru, a výrazem, kterým je mu přiřazen skutečný obsah (např. pomocí funkce výkazu).

Dále je možné pro každý výraz vzoru listu definovat až pět parametrů, na jejichž skutečnou hodnotu bude uživatel dotázán při aplikaci daného výrazu vzoru listu. Parametr se definuje identifikátorem, typem (C,N,D), délkou a návěštím, pod kterým se prezentuje uživateli ve vzoru.

Pro metodu definice listu výkazu pomocí metody s použitím vzoru listů je charakteristická řádková orientace jejího nastavení při pevném maximálním počtu sloupců výkazu, tj. maximálně tři pevně definované ve vzoru a maximálně devět definovaných zde.

Řádek je definován identifikátorem, pořadím, názvem, implicitním formátem jeho buněk a případně, zda ve výkazu bude skrytý. Pro každou ze zmíněných devíti buněk řádku může uživatel definovat název buňky, formát a způsob naplnění jejího obsahu (typ výpočtu) a to: žádný, vzorec (takto definované řádky se zobrazují v gridu šedě), výpočet anebo některý z výrazů daného vzoru, přičemž v tomto případě současně definuje hodnotu parametrů výrazu vzoru.

Pro každý sloupec je možné zde definovat jeho nadpis, implicitní formát a jeho šířku (-1 znamená skrytý). Pro list se zde definuje nadpis listu a název záložky.

Na základě těchto uživatelských nastavení je automaticky vygenerována definice listu výkazů.

2.2.6.21 Zaokrouhlování ve výkazu

Pro vytvoření výkazu, ve kterém mají být hodnoty zobrazovány zaokrouhleny na celá čísla, tisíce, milióny nebo miliardy je možné definovat proměnnou výkazu ZAOKROUHLI. Nabývá-li tato proměnná v okamžiku výpočtu výkazu hodnot 2 nebo 3 nebo 4 nebo 5, potom hodnoty, které mají ve svém sloupci nastavenu vlastnost Zaokrouhlovat=Ano nebudou zobrazovány v Excelu formátem buňky podle vlastnosti 'Formát čísel' , ale podle vlastnosti 'Formát zaokr.' (není-li vyplněn formátem #,##0) doplněným podle požadovaného zaokrouhlení.

V případě, že proměnná ZAOKROUHLI nabývá hodnotu:

2 - hodnoty budou zobrazovány zaokrouhlené na celá čísla - obvykle formátem #,##0

3 - hodnoty budou zobrazovány zaokrouhlené na tisíce - obvykle formátem #,##0,

4 - hodnoty budou zobrazovány zaokrouhlené na milióny - obvykle formátem #,##0,,

5 - hodnoty budou zobrazovány zaokrouhlené na miliardy - obvykle formátem #,##0,,,

Pokud se má způsob zaokrouhlování týkat všech listů výkazu, potom je vhodné definovat proměnnou ZAOKROUHLI v dotazu výkazu např.:

¨ Proměnná - ZAOKROUHLI

¨ Typ - Numerická

¨ Návěští - Zaokrouhlit

¨ Naplnění - Vstup

¨ Inicializace - 1

¨ Třída - Překryvný seznam - Ne,Koruny,Tisíce,Milióny

Pozn.:

Listy výkazů definovaných podle vzoru mohou obsahovat sloupce, které nemají být zobrazovány zaokrouhleně (např. čísla řádků účetní výsledovky, ....). Nastavení vlastnosti Zaokrouhlovat=Ne pro tyto sloupce je možné postupem:

1. zapamatujte si obsah vlastnost listu - Vzor

2. nastavte vlastnost listu Vzor = -

3. vyvolejte opravu listu klávesou F6

4. nastavte vlastnost daného sloupce Zaokrouhlovat=Ne

5. obnovte vlastnost listu - Vzor

2.2.7 Obecné výběry

Obecné výběry slouží uživateli jako rozšíření uživatelských možností ovládání systému. Standardní výběr umožňuje uživateli jednoduše definovat zejména ta výběrová kritéria, o kterých se v IS BM předpokládá, že jsou obvyklá a běžná. Definice se provádí vyplněním údajů na záložce výběr.V některých činnostech je uplatněn specifický algoritmus pro sestavení dotazu vycházející z hodnot některých vyplněných údajů standardního výběru (viz. statistika SQL – záložka Obecné).

Obecný výběr umožňuje uživateli navíc rozšířit standardní výběrová kritéria, a to na základě dat nebo jejich agregátů i mimo rámec datového modelu činnosti. Obecné výběry jsou tedy nástroj, který rozšiřuje možnosti standardního výběru a je uživatelsky definovatelný.

Obecné výběry je možno při práci s informačním systémem využít nebo sledovat jejich užití v těchto činnostech:

¨ na záložce Výběr – kromě standardních výběrových atributů má uživatel přímo na záložce výběr možnost zvolit si příslušný obecný výběr (zvolením obecného výběru v překryvném seznamu atributu „výběr“), tzn. že tento zvolený obecný výběr může doplňovat nebo zcela nahradit běžný výběr.

¨ pod menu Obecné – činnost Obecné výběry, kde má uživatel možnost si vybrat z nadefinovaných obecných výběrů a zároveň může definovat v případě potřeby obecný výběr nový

¨ v dolní části okna činnosti v jeho prostřední části, která poskytuje uživateli informace o použitém obecném výběru (pokud je nějaký použit). Dvojklikem levého tlačítka myši se uživateli zobrazí seznam všech nadefinovaných obecných výběrů dané činnosti. Uživatel si tímto způsobem může zvolit i jiný obecný výběr. Opětovným dvojklikem se uživatel vrátí zpět do původního zobrazení.

Nadefinované obecné výběry je možno importovat pomocí balíčku a je možno je tedy používat jako doplnění běžných výběrů (viz. odstavec výše) v každé činnosti (záložka výběr) nebo jako výběr vstupem, pokud se výběr definuje přímo jako vlastnost dané činnosti v menu (po stisku pravého tlačítka myši na činnosti) nebo po stisku pravého tlačítka myši na atributu „uchovat“ ve standardním výběru. Výběry je možno definovat v každé činnosti pod záložkou Obecné – Obecné výběry – Definovat obecné výběry. Uživateli se zobrazí okno činnosti „obecné výběry“, která obsahuje dvě záložky. Na první záložce se zadává:

¨ výběr – identifikace a název výběru

¨ příznak veřejného výběru – pokud není zatržen, obecný výběr má k dispozici pouze jeho autor (v přehledu definic tento výběr vidět je, ovšem v nabídce obecných výběrů se nezobrazuje)

¨ výraz – slouží k zadání výrazu, o který se rozšíří klausule WHERE příkazu SELECT dané činnosti oproti standardnímu výběru, a který definuje výběr (výrazy se zadávají ve formátu SQL a od uživatele se očekává částečná znalost datového modelu). Ve výrazu je možno rovněž zadat i programový kód v jazyce FoxPro, který zajistí sestavení daného výběru. Výraz musí být uvozen .post script[7] a takto nadefinovaný výběr následně při spuštění funguje tak, že se sestavuje dynamicky podle toho, co v daném okamžiku zvolí uživatel

¨ založil – jméno uživatele, který výběr založil a datum a čas založení

¨ komentář – v případě potřeby je zde si možno uvést vlastní poznámky nebo komentář

Následující obrázek uvádí již v praxi obecný výběr s použitím .post script ve výrazu. Současně je tím i detailně vysvětlena poznámka, že výběr dynamicky sestavuje uživatel až po jeho spuštění. Při aktivaci tohoto výběru se totiž uživateli zobrazí tento formulář, kde si teprve zatržením či vyplněním příslušných atributů určuje, která data chce mít vlastně následně dostupná.

Druhá záložka „proměnné výběru“ obsahuje přehled proměnných, které jsou použity ve výrazu na první záložce. Na ty proměnné s naplněním vstupem se informační systém uživatele „zeptá“ při uplatnění obecného výběru. U každé proměnné se definuje její pořadové číslo, název, typ, návěstí (tzn. tvar, jak se bude prezentovat v obecném výběru), v případě potřeby i naplnění, inicializace a třída. U vybrané proměnné je možno nastavit i reakci na klávesu F2. Po zadání definice obecného výběru je nutno aktivovat činnost „design vstupního formuláře“ (menu Volby nebo klávesa F6), který uživateli umožňuje upravit si okno dotazu obecného výběru tak, jak se pak bude při spuštění prezentovat uživateli.

2.2.8 Nabídky

Nabídky představují rozšířenou možnost pro uživatele, kdy lze nejčastěji používané činnosti (funkce) soustředit do vlastní nabídky (toolu), která se pak zobrazuje jako samostatné okno, které si může uživatel umístit na libovolné místo v okně činnosti. Je možno mít zobrazeno jednu nebo více nabídek zároveň, záleží to pouze na tom, kolik nabídek si uživatel v menu Obecné – Nabídky – zaškrtne (tím je aktivuje). Při práci s nabídkami může uživatel využít i možnosti sledovat vazby míry plnění.

V případě definování nové nabídky tedy uživatel postupuje následovně. Pod menu Obecné – Nabídky – zvolí možnost Definovat nabídky. Aktivuje tlačítko „vložit“ a stiskne Ano po dotazu „opravdu definovat novou nabídku?“. V prvním políčku se objeví název Nová nabídka, do druhého políčka vpravo uživatel napíše název své vytvářené nabídky a stiskne OK.

Jednotlivé činnosti a funkce do nabídky přiřadí tak, že si je vybere se seznamu nabízených a na každém zvoleném provede dvojklik levým tlačítkem myši (dojde k označení položky hvězdičkou a tím se automaticky stávají součástí dané nabídky). Nabídky (zobrazená okna) jsou součástí okna IS BM, tedy i jeho vlastností. Aktivní (tj. spustitelné) jsou pouze ty činnosti (funkce) nabídky, které jsou smysluplné pro aktivní činnost a pro aktivní záznam. U každé nabídky je možno zaškrtnutím příznaku „veřejná“ určit, zda nabídku bude mít k dispozici pouze autor nabídky a nebo i ostatní uživatelé a v případě potřeby je možno si jednotlivé položky z nabídky i přeložit (tlačítko „překlad“). Za zajímavost stojí i to, že je možno nabídce i jednotlivým činnostem přiřadit vlastní zvolené ikony. V takovém případě je nutno do kolonky Ikona zapsat název souboru, který obsahuje vybranou ikonu s příponou bmp. Uvedením znaku vlnovka ~ v textu názvu ikony znamená, že na odpovídající tlačítko bude přenesen text, který je zapsaný za vlnovkou. Atribut „dynamický“ má pro uživatele následující význam:

¨ pokud je vybráno ANO znamená to, že uživateli se v dané činnosti při aktivaci nabídky zobrazí v nabídce vždy jen činnosti, které jsou na daném okně činnosti dostupné. Např. pokud bude mít uživatel v nabídce vybráno např. činnost bankovní spojení a právě se bude nacházet v činnosti např. dokumenty, odkud tuto nabídku spustí, tak bankovní spojení v dokumentech není dostupné, tudíž v dané nabídce se činnost bankovní spojení v danou chvíli nabízet nebude

¨ pokud je vybráno NE jsou dostupné vždy všechny činnosti z nabídky, ty, které není možno vyvolat v dané činnosti jsou však nedostupné – šedivé

Pro každou položku nabídky je možno zvolit, zda se má uživateli nabízet samostatně jako činnost v menu Volby. Nadefinováním atributu „menu“ na hodnotu NE u jednotlivých položek nabídky si uživatel určuje, které položky nabídky chce pod menu Volby mít dostupné a které mohou zůstat potlačeny a nezobrazovat se. Hodnotu NE u atributu „menu“ mohou mít nastaveny také položky menu, které nejsou součástí žádné nabídky, ale jsou součástí programu BM a přitom se používají pouze minimálně (např. činnost pod menu Volby Odeslat do Outlooku apod.)

Příznak „křížek“ pro ukončení nabídky fakticky okno s nabídkou zavře, nabídka (v menu Obecné – Nabídky) však zůstává stále zaškrtnutá, tzn. že při dalším pokusu nabídku odškrtnout se znovu spustí. Při prvním spuštění se nabídka uživateli implicitně zobrazuje v dolní části okna, je možno si ji libovolně přesouvat kdekoliv po okně, její nové umístění je i po ukončení programu zachováno (tzn. pokud si uživatel okno s nabídkou přesune do pravého horní rohu okna, je při dalším spuštění činnosti, ze které se tato nabídka spouštěla, nabídka zobrazena v pravém horním rohu okna).

Přehled o jednotlivých událostech svázaných v IS BM mírou plnění uživateli poskytuje činnost vazby míry plnění.

2.2.9 Importy

Importem se rozumí schopnost informačního systému převzít data z jiného IS nebo programu (např. Excel). Oproti tomu naopak exporty data jinému IS nebo programu poskytují. Obě činnosti (import i export) tak podporují komunikaci IS BM s jinými systémy. Importy/exporty se aktivují v každé činnosti typu seznam z menu Obecné pomocí činnosti „Import/Export dat“ volbou ze seznamu definic, případně šablonou, v jejíž definici je import užit. V činnostech typu prohlížení seznamu záznamů (v událostech ne) je možno vytvořit definici jaká data a jak mají být importována, tj. definici zdroje dat (např. souborů – ODBC, DBF, TXT, XML, SOAP...) a definici pravidel transformace. Při definování jednotlivých definic importů se předpokládá určitá znalost datového modelu. Přístup k jednotlivým definicím importu lze chránit přístupovými právy podle druhu importu.

Při spuštění činnosti Import/export (dále jen import) z menu horní lišty Obecné se uživateli zobrazí okno „výběr importu/exportu“. V případě, že uživatel spouští import z činnosti typu seznam (např. přehled záznamů vývěsky, přehled adresátů apod.), nabízí se mu všechny nadefinované importy dané činnosti s výjimkou těch, které mají ve své definici nastaveno „nabízet – Ne“. V případě, že uživatel spouští import z událostí (např. obchodu, plateb apod.), musí tento import spouštět nad událostmi zahájených, ale dosud neukončených operací. V případě, že je operace ukončena, importy se v okně výběru importu nezobrazují.

Po zobrazení tohoto výběrového okna má uživatel možnost:

¨ aktivovat některý ze stávající nabídky nadefinovaných importů

¨ opravit již existující definici importu

¨ nadefinovat nový import

Při definici nového importu nebo při opravě již existujícího importu uživatel stiskne tlačítko „definovat“. Uživateli se následně zobrazí okno činnosti import, které obsahuje dvě záložky. První záložka („definice importu-exportu“) definuje základní vlastnosti importu a druhá záložka („proměnné importu-exportu“) definuje jednotlivé proměnné importu, které může uživatel vstupovat před zahájením importu, exportu nebo update dat a proměnné, které jsou odvozené ze vstupovaných hodnot.

Po definici obou těchto záložek (jejich podrobný popis, včetně příkladů, je uveden ve slovníku pojmů) uživatel definuje činnost konverze atributů. Pomocí činnosti konverze atributů uživatel v importu/exportu definuje odkud a kam se jednotlivé atributy importu/exportu mají zapsat. Činnost je pro uživatele dostupná na každé definici importu pod menu Volby nebo po stisku funkční klávesy F5.

Jako následující krok při definici importu by si uživatel měl upravit vlastní okno importu, které se uživateli zobrazí po jeho spuštění. To provede pomocí činnosti „design vstupního formuláře“, kterou má dostupnou pod menu Volby nebo po stisku funkční klávesy F6. Nejedná se o nic jiného než o rozmístění jednotlivých proměnných importu tak, jak se pak uživateli budou nabízet po vlastní aktivaci importu. Před zahájením importu má uživatel možnost si jednotlivá importovaná data ještě prohlédnout a případně pak i definici importu upravit a to pomocí činnosti „prohlížení importovaných dat“, kterou má uživatel dostupnou pod menu Volby nebo po stisku klávesy F7.

Po vlastním spuštění importu (tzn. výběr importu a potvrzení klávesou OK v okně „výběr importu/exportu) se uživateli zobrazí okno, kde právě vstupuje proměnné importu (to je okno jehož vhled si uživatel nadefinoval pomocí činnosti „design vstupního formuláře“), např. datum od – do, kategorie adresáta, selektory apod. Po jejich potvrzení klávesou OK proběhne konverze atributů a naimportovaná data jsou naplněna do jednotlivých událostí. V případě, že v definici importu nejsou uvedené proměnné, ale import je řešen pouze pomocí příkazu selekt, dojde po jeho aktivaci rovnou ke konverzi atributů a načtení dat do událostí.

Importy a exporty dat vytvořené u jednotlivých činností (tj. nad formuláři událostí jednotlivých komponent) je možné vyvolat i automaticky při běhu procesu:

¨ uvedením šablony používající import v diagramu procesu ve vlastnosti uzlu procesu "šablona prvého vstupu". Import se spustí při spuštění dané operace, pokud operace neobsahuje události.

¨ uvedením exportu v seznamu exportů na záložce "exporty" u popisu druhu operace. Export se spustí po ukončení dané operace.

Importy událostí komponent je možné používat i v procesních importech. Procesní import je nástroj pro spouštění importů událostí komponent s automatizovaným založením procesu, resp. založením událostí v operacích existujících procesů na základě importovaných dat. Přitom se mohou importovaná data automaticky rozpadat do událostí většího počtu operací. Procesní importy se definují v činnosti Informační centrum – Typy a řady – Procesní importy.

2.2.10 Balíčky

Balíček je prostředek přenosu vybraných definičních dat (tzn. jednotlivých definic) z jedné databáze do jiných databází, a to i u různých uživatelů. Balíčkem lze přenášet:

¨ druhy procesů

¨ předlohy výstupu

¨ metapředlohy výstupu

¨ definice volné karty

¨ definice výkazů

¨ obecné výběry

¨ uživatelské triggery

¨ šablony

¨ definice importů/exportů, procesních importů, doplňujících vlastností formuláře

Při přenosu definic balíčkem je nutno vědět, že bez ohledu na předchozí přenosy se stále dokola mohou přenášet pouze předlohy výstupu (tj. dojde k jejich přepsání), u ostatních přenosů se přenesou vždy jen první definice, další změny se nepřenášejí. Přenesou se pouze v případě, že se původní definice, kterou chceme přenést, zruší a pomocí balíčku se naimportuje znovu.

Balíčkem druhu procesu nelze přenášet současně nastavené volné karty operace , volné karty procesu a informace o nastavených parametrech operací.

Export do balíčku se provádí vždy v dané činnosti (např. Druhy procesů, Seznam předloh výstupu apod.) vyvoláním příslušné činnosti na horní liště v menu Volby („Export dat do balíčku“), kde uživatel určí soubor (jeho cestu), kam se balíček má uložit, jeho název (tj. popis) a které záznamy se mají exportovat (všechny vybrané, aktuální nebo označené). Ke každému vytvářenému balíčku je možno si připsat libovolnou poznámku. Cyklicky se vytváří soubory s příponou .BEX a .FPT (u předloh výstupu, kde se provádí export do balíčku přímo z okna činnosti výstupy se kromě souborů s příponou .bex a .fpt vytvoří ještě soubor s příponou .txt).

Pro vytvoření balíčků se implicitně nabízí programový adresář , uživatel má však samozřejmě možnost si nastavenou cestu změnit a zvolit si adresář podle svých potřeb. Ve formuláři zobrazeném při importu balíčku je k dispozici i tlačítko 'Uložit balíček jako ...'. Po jeho užití je uživatel vybírá soubor s příponou BEX, do kterého má být uložena kopie aktuálního balíčku. Může vybrat také již existující soubor balíčku, ke kterému má být aktuální soubor balíčku připojen.

Tato funkčnost souvisí se zavedením vzdálených funkcí BM, které umožňují předávat balíčky s nastavením BM prostřednictvím Internetu:

- pro předání balíčků uživatelům, jejichž systémy nedokážou z nějakého důvodu používat vzdálené funkce

- pro vytvoření balíčků nastavení BM předáváných obvykle na konci roku

Pozn.: Tuto funkčnost je možné použít také pro slučování balíčků vytvořených klasickým způsobem

Následný import balíčku se provádí v hlavním menu v činnosti SYSTÉM - Import balíčku. Po aktivaci této činnosti se uživateli jako první rovněž nabídne načtení balíčku z programového adresáře, uživatel si ale může určit libovolnou cestu, odkud a z jakého souboru se má provést import.

2.2.11 Prezentace artiklu, dokumentu

Prezentace artiklu nebo dokumentu umožňuje na artikl nebo dokument navázat propojené nebo vložené objekty vytvořené v některé z aplikací sady Office nebo v jakémkoliv jiném programu, který podporuje propojování a vkládání objektů.

Uživatel si v činnostech týkajících se artiklů (artikly skladu, artikly obchodu atd.) a dokumentů aktivuje menu Volby a v něm vyvolá příslušnou činnost týkající se „prezentace“. Uživateli se zobrazí samostatné okno, které je propojené s artikly nebo dokumenty. Např. můžeme mít oděvní firmu, která si ke každému atriklu obchodu vloží prezentaci (čili fotografii) každého jednotlivého kusu oděvu.

Propojení nebo vložení objektu se realizuje funkcí „vložit objekt“ nebo „vložit“ v horní liště obrazovky v menu Úpravy při aktivním okně prezentace artiklu. Při aktivaci funkce „ponechat“ v menu Volby nebude okno s prezentací artiklu automaticky uzavřeno při ukončení činnosti s přehledem artiklů nebo dokumentů.

2.2.12 Dokumenty, předlohy, aplikace

IS BM umožňuje kromě vlastních funkcí si k sobě „přitáhnout“ i funkčnost, kterou disponují externí programy případně i s jejich externě uloženými daty, tj. dokumenty v širším slova smyslu. Mezi použitelné programy patří především ty, které lze spustit s parametrem uvádějícím soubor s daty určenými pro zpracování daným programem, například MS Word, MS Excel, MS IE, MS Project, Sybase Power Designer, ale také T602, Quatro apod.

Uvedené a další užívané programy jsou uživatelsky definovatelné jako spouštěné aplikace (menu Marketing – Dokumenty – Spouštěné aplikace) s řadou vlastností, které definují způsob spuštění, způsob předávání dat a další parametry.

Dokumenty lze kategorizovat, tj. každý je určitého druhu, podle kterého jsou k němu nastavena přístupová práva. Přístup z hlediska zápisu lze dále omezit nastavením atributu „chráněný dokument“, takový dokument pak může opravovat pouze autor dokumentu. Při aktivaci dokumentu, ke kterému má aktuální uživatel právo zápis, ale který má v daném okamžiku otevřený pro zápis jiný uživatel, se zobrazuje v hlášení jméno tohoto jiného uživatele spolu s informací, že dokument je otevřen pouze pro čtení a případné změny nebudou zaznamenány. V případě, že má uživatel k dokumentu přístupové právo typu zápis, může pak i zpětně měnit druh dokumentu ve vlastnostech dokumentu.

IS BM dále umožňuje definovat předlohy dokumentů, které se uplatní při založení dokumentu. Ty mohou obsahovat konstantní údaje opakovatelně použitelné ve více dokumentech, jejich formátování, případná slučovací pole pro mailmerge (hromadnou korespondenci) apod. Obsah souboru, jehož struktura je daná programovým kódem IS BM, pro hromadnou korespondenci je automaticky naplňován při otevření dokumentu založeného na předloze s definovaným atributem „mailmerge“ pomocnými údaji (xxx, xxxxxxx, …) nebo skutečnými, zejména adresními údaji z událostí operace pošty spojené objektovou vazbou s dokumentem. Pro smysluplné využití této funkce je možné dokument spojit pouze s jedinou operací pošty.

Dokumenty jako objekty z hlediska objektových vazeb mohou být z jiného objektu vyvolány (zpřístupněny) nejen pomocí odpovídajícího toolu (tedy příslušným znaménkem plus v rámečku souvislostí), ale i v okně se spojenými dokumenty stiskem kláves CTRL D (podrobný popis je k dispozici v kapitole 3). Po stisku klávesy Ctrl D se tedy uživateli zobrazí rámeček „spojené dokumenty“. Zde má k dispozici dokumenty objektu, procesu, operace, adresáta a artiklu.

Ve stromech spojených dokumentů je nyní možné určit způsob popisu dokumentu ve stromu. Toto se provede nastaavením parametru BM Preferences->Skript_pro_popis_dokumentu, kterým se uvádí identifikace knihovny vkládaného kódu, jejíž kód bude spouštěn pro určení popisu dokumentu.

Tento skript musí vracet textovou hodnotu a v okamžiku jeho provádění má k dispozici informace o dokumentu v kurzoru _DOCS, který obsahuje mj.atributy:

SP26

SP26DATUM

SP26NAZEV

SP26INDEX

SP57ID

SP57TYPDOK

SP01ID

SP01PREDLO

SP26SOUBOR

SP26DISK

BW01UZIV

BW01JMENO

BW01JMENOT

SP44PRISTU

Kromě popisu dokumentu ve stromu je možné změnit také ikonu dokumentu vložením názvu souboru ikony do proměnné _NODE.ICON.

Př.:

Do Case

Case sp26disk<>1

Case Empty(Sys(2000,(sp26soubor)+''))

_node.Icon='hotovo'

Case Inlist(Upper(Justext(sp26soubor)),'BMP','ICO','JPG','GIF')

_node.Icon=sp26soubor

Endcase

Return Trans(sp26datum)+' '+Trim(sp26nazev)+Iif(sp26disk=1,' ('+Justfname(sp26soubor)+')','')

V případě potřeby vytvoření objektové vazby (např. navázání smlouvy na událost vývěsky) se využijí dokumenty objektu (aktivace spojených dokumentů Ctrl D a poté pravý klik myši na atributu Objekt). Dokumenty procesu a operace se napojují automaticky, pokud dokument vzniká jako součást (je nadefinovaný v diagramu procesu) procesu nebo operace. Pod dokumenty adresáta se nejčastěji ukládají dokumenty, které jsou přímo svázány s daným adresátem, např. smlouvy, ceníky adresáta apod. Pod složkou artikl jsou obsaženy události artiklu, který je aktuální na události, ze které si uživatel spojené dokumenty vyvolal.

Další složky, které jsou dostupné pod dokumenty adresáta jsou:

¨ kategorie adresáta – ukazuje se přehled kategorií, ve kterých je daný adresát zařazen

¨ procesy adresáta – ukazuje se strukturovaný přehled procesů, které byly založeny pro daného adresáta (roky – číselné řady – jednotlivé procesy)

¨ události adresáta – ukazují se události jednotlivých komponent, ve kterých je adresát uveden

Okno se spojenými dokumenty operace lze vyvolat též automaticky při ukončení operace, pokud je to uživatelsky uvedeno v jejím kódu po ukončení nebo pomocí doplňujících vlastností formuláře, nastane-li programová událost.

Vlastní dokument může být uložen zakódovaný v databázi IS BM nebo externě kdekoliv v počítačové síti. Společně s autorizovanými údaji o založení dokumentu (autor, datum a čas) jsou evidovány i údaje o jeho užívání (čtení/zápis) jednotlivými uživateli. V případě, že je to u dokumentu nastaveno (příznak „automatické ukládání revizí dokumentu“), je možno u každého dokumentu sledovat jeho revize. Revizí se rozumí kopie obsahu dokumentu zaznamenaná v čase.

Pro ucelenější přehled o práci s dokumenty je v menu Marketing – Dokumenty k dispozici činnost „přehled o použití dokumentů“.

2.2.13 Označování

Mezi další funkce, umožňující uživateli zvolit si určitou množinu dat, patří označování. Pokud je aktivní okno činnosti typu seznam s vyprogramovanou možností označování, nachází se označování pod menu Volby. Ruční označování je možné provést ve většině činností IS BM.

Jak napovídá předchozí odstavec, označování je možno provést dvojím způsobem:

¨ ručně – kliknutím myši do zaškrtávacího políčka dojde k označení aktuálního záznamu. Na dolní liště činnosti má pak uživatel k dispozici informaci o počtu označených záznamů.

¨ pomocí činnosti označování v menu Volby nebo stiskem klávesy Ctrl O. Uživateli se pak zobrazí následující nabídka:

¨ označení všech – označí se (tzn. zaškrtnou) všechny vybrané záznamy

¨ odznačení všech – odznačí se všechny v danou chvíli označené záznamy (i ty nevybrané)

¨ přehled označených / všech – při první aktivaci tohoto tlačítka se uživateli zobrazí přehled označených záznamů[8] [4], při dalším stisku se zobrazí přehled všech vybraných záznamů (funguje jako přepínač)

¨ počet označených záznamů – uživateli je poskytnuta informace o počtu aktuálně označených záznamů. Stejnou informaci má uživatel i na dolní liště okna činnosti.

¨ označování výrazem - vyvolá vstup pro zadání a uchování výrazů přihlášeného uživatele. Po uložení výrazu je možné vyvolat označení záznamů, které vyhovují zadané podmínce a zároveň se uplatňuje také aktuálně platný výběr výběrové záložky a případně aktuálně použitý obecný výběr (probíhá SELECT s uživatelem zadanými parametry). Funkce "Označování výrazem" se uplatňuje pouze ve formulářích objektů IS BM a není ji možné vyvolat z menu "označování", je-li v dané chvíli aktivní výběr s přehledem označených záznamů.

Označené záznamy je možno si nejen zobrazit (tj. přehled označených), ale i tisknout. V okamžiku spuštění předlohy výstupu má uživatel možnost vybrat si k tisku pouze označené záznamy.

V případě, že menu Volby daného formuláře obsahuje i podmenu Označování, potom se po stisku pravého tlačítka myši na zaškrtávacím políčku (tzn. tom políčku, které je u daného záznamu zatrženo jako označené) zobrazí menu, které odpovídá obsahu podmenu Označování (tzn. s možnostmi Označení všech, Odznačení všech, ...).

Kromě základní nabídky, která se uživateli nabízí po aktivaci činnosti označování (tzn. o(d)značení, přehled označených/všech, počet označených apod.) je pro některé činnosti v IS BM nabídka rozšířena, např. v adresáři označování podle kategorií, ve spuštěné neukončené operaci je možno hromadné zrušení označených záznamů apod.

V některých činnostech lze s označenými záznamy dále dávkově pracovat, např. platby na příkaz k úhradě, šablona hromadného vstupu do pošty na události podle označených adresátů, dávkové operace apod.

Označování je možné pouze nad těmi tabulkami IS BM, jejichž primární klíč nepřesahuje 20 znaků.

2.2.14 Okno úloh

Okno úloh představuje pro uživatele nástroj k usnadnění ovládání programu IS BM. K dispozici je v horní liště pod menu Obecné – Nabídky. Při aktivaci je okno úloh umístěné libovolně kdekoliv na obrazovce, uživatel si ho však může umístnit na vybrané místo a systém si při další aktivaci okna úloh již toto umístění pamatuje (platí pro verze Visual FoxPro 9.0). Na základě nastavení okna úloh se může při každém spuštění IS BM uživateli toto okno automaticky aktivovat samo a nebo je možno si ho ručně vyvolat.

Po stisku pravého tlačítka myši na horní liště činnosti „okno úloh“ má uživatel k dispozici menu s dvěmi atributy - „ukotvit“ a „skrýt“ (standardní tlačítko z ovládání FoxPro – ve verzi IS BM momentálně nefunkční).

Atribut „ukotvit“ je implicitně nastaven jako zatržený. Jeho význam spočívá v tom, že ať si uživatel okno úloh umístí kamkoliv na obrazovce (pravá strana, nad dolní lištu apod.), zůstává při aktivaci dalších činností a formulářů vždy na stejném místě (tzv. ukotveno) a aktivované činnosti nebo formuláře toto okno obtékají. V podstatě lze tuto vlastnost popsat i tak, že atribut „ukotvit“ způsobí, že okno úloh si pro sebe „přivlastní“ uživatelem vybrané místo na obrazovce a nemůže nastat problém, že by další spuštěná činnost nebo formulář toto okno překryly, tzn. vždy se pohodlně zobrazí vedle a uživatel tak má k dispozici všechny potřebné informace. Jinými slovy řečeno, atribut „ukotvit“ neznamená, že po jeho zatržení je okno úloh ukotveno, ale že okno úloh je ukotvitelné.

Okno úloh (musí být zatržen atribut „ukotvit“) lze pohodlně umístnit na obrazovce tzv. metodou „táhni a drž“. Uživatel stiskne levé tlačítko myši na horní modré liště okna úloh a přetáhne si okno úloh na vybrané místo na obrazovce. V tomto okamžiku může někdy nastat tzv. „technický problém“. V případě, že chce uživatel umístit a ukotvit (tzn. aby další formuláře a činnosti okno úloh obtékaly, nikoliv ho překrývaly) okno úloh např. v pravé části obrazovky jako samostatný sloupec, je vhodné postupovat takto: uchopit okno úloh (levá myš na horní liště) a lehkým plynulým švihem (mírně doprava nahoru, v podstatě takovým obloučkem) ho pustit na okraji pravé části obrazovky. V případě, že tento pohyb byl proveden správně, okno se samo automaticky usadí do pravé části obrazovky, tzn. vytvoří se sloupec okna úloh v pravé části obrazovky a horní lišta okna úloh bude těsně přiléhat k panelu nástrojů (tj. horní lišta) IS BM.

Technická poznámka:

V případě, že se takové umístění nezdaří na první pokus, nepropadejte panice a zkoušejte to znovu!:) Nesmíte se snažit okno úloh umístnit pomalu a detailně do vybraného místa (tzn. dojet myší až na zvolené místo a tam ho pomalu pustit, musí to být opravdu vedený lehký švih:). Stejný postup platí pro umístění okna kdekoliv jinde na obrazovce. Uchopit horní lištu a mírným švihem ho pustit na kraji zvolené části obrazovky.

Pro uživatele, kterým se nebude technicky dařit umístit okno úloh na zvolené místo na obrazovce je k dispozici činnost „přichycení okna úloh“. Tuto činnost mají k dispozici po stisku pravého tlačítka myši na položce stromů „Okna“ a „Menu BM“ (vlastní popis této činnosti je uveden dále v textu).

V okně úloh jsou zobrazena ovládací tlačítka, kterými se mění jeho obsah. Kromě základních tlačítek a s nimi spojenými zobrazovanými obsahy je možno definovat vlastní tlačítka pro zobrazení stránek informačních panelů. Uživatel si pro zobrazení stránek informačních panelů může definovat vlastní tlačítka. V nastavení programu BM lze v parametru OKNOULOH -> VLOZENEINFPANELY zadat seznam identifikací stránek informačních panelů oddělených čárkou. Popis a ikona takto definovaných tlačítek okna úloh přitom odpovídá názvům a ikonám uvedeným v popisu stránky informačního panelu. Jednotlivým uživatelům jsou zobrazovány tyto definovaná tlačítka pouze v případě, že k odpovídající stránce informačního panelu mají přístupové právo alespoň „Čtení“. Pravý klik myši na tlačítku pro zobrazení stránky informačního panelu způsobí znovunačtení stránky.

Zobrazení jednotlivých záložek (druh a velikost písma) a způsob ovládání těchto činností je volitelný vždy po stisku pravého tlačítka myši na názvu činnosti, např. na záložce „Menu BM“ po stisku pravého tlačítka myši na názvu jakékoliv komponenty má možnost změnit vzhled celého menu. Všechny tyto vlastnosti se nastavují v činnosti „Nastavení stromu“ (neplatí jen pro Okno úloh, pomocí tohoto nastavení je možno měnit i vzhled dalších stromů, např. hlavní menu, strom hlavního procesu, strom pracovníka, obecné stromy). Po stisku pravého tlačítka myši na názvu jakékoliv činnosti pod tlačítkem „Menu BM“ má uživatel k dispozici následující:

¨ otevřít menu (aktivace dané činnosti)

¨ zobrazovat skryté činnosti (uživateli se v menu zobrazí i činnosti, které mají ve vlastnostech uveden příznak „skryté“)

¨ nastavení stromu

¨ přichycení okna úloh – lze si vybrat možnost pro přichycení okna úloh v hlavním okně BM – možnosti jsou: vlevo, vpravo, nahoře, dole, nepřichyceno

Nastavení stromu a přichycení okna úloh má uživatel k dispozici i po stisku pravého tlačítka myši na jakékoliv činnosti pod tlačítkem „Okna“.

K dispozici jsou následující dvojice základních tlačítek (Okna – Menu BM, Dokumenty – Historie, Strom – Průběh). Jedná se o tlačítka, která spolu věcně souvisí, např. když uživatel bude přes tlačítko Menu BM aktivovat vybranou činnost, tak ta se zároveň ukáže jako aktivní po stisku tlačítka Okna. Stisk pravého tlačítka myši na každém z těchto tlačítek aktivuje možnost "obnovit", která způsobuje tzv. „znovunačtení“ činnosti. Jedná se o tyto tlačítka (tj. záložky):

¨ Okna – zobrazí se seznam názvu aktivních oken BM (tj. aktivně spuštěných činností). Uživatel se může mezi jednotlivými okny přepínat, tzn. klikem na název okna se mu na základní obrazovce zobrazí daná činnost. Zobrazuje se zde většina oken programu BM, např. i okna informačních panelů, digramů procesů, okno s předlohami výstupu atd.

¨ Menu BM – zobrazí se hlavní menu programu, ze kterého je možné aktivovat jednotlivé činnosti BM (aktivované činnosti se následně zobrazí pod záložkou Okna).

¨ Dokumenty – zobrazují se dokumenty, které se vztahují k aktivně spuštěné činnosti na základní obrazovce, tzn. má-li uživatel aktivovanou např. činnost adresář, tak po kliknutí na záložku Dokumenty se mu zobrazí dokumenty aktivního adresáta. Při přechodu na dalšího adresáta se obsah záložky Dokumenty nemění, teprve po dalším kliknutí přímo na tlačítko „Dokumenty“ je obsah záložky Dokumenty znovu načten.

¨ Historie - zobrazí se seznam dokumentů z posledních 7 týdnů, které uživatel naposledy otevřel v programu BM, seřazený podle data a času sestupně. Klik myši na názvu dokumentu způsobí jeho otevření. Opakovaný klik na tlačítko „Historie“ způsobí aktualizaci seznamu dokumentů (chování obdobné jako činnost „znovu načíst“).

¨ Strom – zobrazuje se strom hlavního procesu, který se vztahuje k aktivně spuštěné činnosti na základní obrazovce, tzn. má-li uživatel aktivovanou činnost např. události obchodu, tak po kliknutí na záložku Strom se zobrazí strom hlavního procesu vztahující se k právě aktivní události obchodu. Při přechodu na další událost se obsah záložky Strom nemění, teprve po dalším kliknutí přímo na tlačítko „Strom“ je obsah záložky Strom znovu načten.

¨ Průběh – uživateli se zobrazuje přehled dosud spuštěných procesů. Po rozbalení jejich názvu jsou k dispozici i jednotlivé operace procesu zobrazené ve stromové struktuře (jako strom hlavního procesu). Při zatržení příznaku „průběh procesů automaticky rozbalovat“ v Nastavení okna úloh se zobrazí seznam procesů, který už je automaticky rozbalen.

Následující záložky jsou zobrazeny jako tlačítka v řadě vedle sebe, jsou označena prvními písmeny z názvu:

¨ F - formulář – uživatelský popis – ve sloupcích pod sebou se zobrazí dvě vstupní textová pole, ve kterých uživatel vytváří vlastní uživatelský popis aktuálně zobrazeného formuláře. První textové pole „sdílený popis“ je dostupné všem uživatelům systému a údaje, které tam daný uživatel zapíše jsou dostupné všem uživatelům systému. Druhé textové pole „soukromý popis“ je dostupné pouze aktuálnímu uživateli systému. Vstupované popisy jsou ukládány na vývěsku s tématem, které je v činnosti „nastavení programu BM“ dáno parametrem OKNOULOH -> TEMAUZIVPOPISU (v případě, že tento parametr není nastaven nebo uvedené téma neexistuje, není možné zadávat uživatelské popisy). Uživatelé, kteří k tématu vývěsky uvedenému v parametru nemají právo přístupu „Zápis“, mohou obsah textového pole „sdílený zápis“ pouze číst. Obsah okna se mění při přepínání mezi formuláři a zároveň při této změně dochází k automatickému zápisu uživatelem zadaného popisu. Zápis změněného popisu je rovněž možno vyvolat opakovaným stiskem daného tlačítka („formulář – uživatelský popis“).

¨ O - operace – uživatelský popis – ve sloupcích pod sebou se zobrazí dvě vstupní textová pole, ve kterých uživatel vytváří vlastní uživatelský popis aktuálně zobrazeného formuláře. Pokud aktivní formulář na hlavní obrazovce není formulářem spuštěné operace, je tlačítko zobrazené jako nepovolené (tzn. šedivé a nedostupné).

První textové pole „sdílený popis“ je dostupné všem uživatelům systému a údaje, které tam daný uživatel zapíše jsou dostupné všem uživatelům systému. Druhé textové pole „soukromý popis“ je dostupné pouze aktuálnímu uživateli systému. Vstupované popisy jsou ukládány na vývěsku s tématem, které je v činnosti „nastavení programu BM“ dáno parametrem OKNOULOH -> TEMAUZIVPOPISU (v případě, že tento parametr není nastaven nebo uvedené téma neexistuje, není možné zadávat uživatelské popisy). Uživatelé, kteří k tématu vývěsky uvedenému v parametru nemají právo přístupu „Zápis“, mohou obsah textového pole „sdílený zápis“ pouze číst. Obsah okna se mění při přepínání mezi formuláři a zároveň při této změně dochází k automatickému zápisu uživatelem zadaného popisu. Zápis změněného popisu je rovněž možno vyvolat opakovaným stiskem daného tlačítka („operace – uživatelský popis“).

¨ OP - operace v procesu – uživatelský popis – ve sloupcích pod sebou se zobrazí dvě vstupní textová pole, ve kterých uživatel vytváří vlastní uživatelský popis aktuálně zobrazeného formuláře. Pokud aktivní formulář na hlavní obrazovce není formulářem spuštěné operace, je tlačítko zobrazené jako nepovolené (tzn. šedivé a nedostupné).

První textové pole „sdílený popis“ je dostupné všem uživatelům systému a údaje, které tam daný uživatel zapíše jsou dostupné všem uživatelům systému. Druhé textové pole „soukromý popis“ je dostupné pouze aktuálnímu uživateli systému. Vstupované popisy jsou ukládány na vývěsku s tématem, které je v činnosti „nastavení programu BM“ dáno parametrem OKNOULOH -> TEMAUZIVPOPISU (v případě, že tento parametr není nastaven nebo uvedené téma neexistuje, není možné zadávat uživatelské popisy). Uživatelé, kteří k tématu vývěsky uvedenému v parametru nemají právo přístupu „Zápis“, mohou obsah textového pole „sdílený zápis“ pouze číst. Obsah okna se mění při přepínání mezi formuláři a zároveň při této změně dochází k automatickému zápisu uživatelem zadaného popisu. Zápis změněného popisu je rovněž možno vyvolat opakovaným stiskem daného tlačítka („operace v procesu – uživatelský popis“).

¨ P - proces – uživatelský popis – ve sloupcích pod sebou se zobrazí dvě vstupní textová pole, ve kterých uživatel vytváří vlastní uživatelský popis aktuálně zobrazeného formuláře. Pokud aktivní formulář na hlavní obrazovce není formulářem spuštěné operace, je tlačítko zobrazené jako nepovolené (tzn. šedivé a nedostupné).

První textové pole „sdílený popis“ je dostupné všem uživatelům systému a údaje, které tam daný uživatel zapíše jsou dostupné všem uživatelům systému. Druhé textové pole „soukromý popis“ je dostupné pouze aktuálnímu uživateli systému. Vstupované popisy jsou ukládány na vývěsku s tématem, které je v činnosti „nastavení programu BM“ dáno parametrem OKNOULOH -> TEMAUZIVPOPISU (v případě, že tento parametr není nastaven nebo uvedené téma neexistuje, není možné zadávat uživatelské popisy). Uživatelé, kteří k tématu vývěsky uvedenému v parametru nemají právo přístupu „Zápis“, mohou obsah textového pole „sdílený zápis“ pouze číst. Obsah okna se mění při přepínání mezi formuláři a zároveň při této změně dochází k automatickému zápisu uživatelem zadaného popisu. Zápis změněného popisu je rovněž možno vyvolat opakovaným stiskem daného tlačítka („proces – uživatelský popis“).

¨ N - nápověda – zobrazí nápovědu BM k formuláři (činnosti), který je právě aktivní na hlavní obrazovce. Obsah okna se při přepínání mezi formuláři automaticky mění.

V tomto místě činnosti „okno úloh“ se mohou zobrazovat tlačítka s názvy informačních panelů, pokud je má uživatel správně nadefinovány. Poslední tlačítko, důležité pro chování činnosti „okno úloh“ je:

¨ Nastavení okna úloh – zde se definují parametry, které ovlivňují chování okna úloh. Tato nastavení jsou specifická pro každého uživatele. Jedná se o parametry, jejichž nastavením má uživatel přímo možnost ovlivnit chování okna úloh. Toto nastavení je specifické pro každého uživatele, tzn. každý uživatel může mít pod svým heslem okno úloh nastaveno zcela individuálně.

Jedná se o parametry, jejichž nastavením má uživatel přímo možnost ovlivnit chování okna úloh. Toto nastavení je specifické pro každého uživatele, tzn. každý uživatel může mít pod svým heslem okno úloh nastaveno zcela individuálně.

Jedná se o tyto parametry:

¨ otevírat okno úloh při spuštění programu – možnosti jsou:

- vždy – při každém spuštění IS BM se zároveň aktivuje i okno úloh

- pokud bylo otevřeno při ukončení programu – v případě, že okno úloh bylo otevřeno v okamžiku, kdy uživatel ukončil práci s IS BM, je při jeho spuštění automaticky otevřeno i okno úloh

- nikdy – okno úloh se neaktivuje (v případě potřeby má uživatel možnost si ho aktivovat – v menu Obecné – Nabídky – Okno úloh)

¨ přepínat do hlavního menu programu – tento parametr určuje chování v situaci, kdy uživatel v základním okně IS BM uzavře poslední aktivní formulář a přitom je otevřeno okno úloh. Možnosti jsou:

- vždy – při ukončení posledního aktivního formuláře se systém vždy automaticky přepne do okna hlavního menu a základní okno BM skryje

- když není aktivní úloha „Menu BM“ – v případě, že není aktivní úloha „Menu BM“, tak se systém automaticky přepne do hlavního menu. Pokud je tato úloha aktivní, systém ponechá zobrazenou úlohu „Menu BM“ a základní okno BM je rovněž aktivní

- nikdy – základní okno BM zůstává po ukončení posledního formuláře aktivní

¨ ukončení programu klávesou ALT+F4

¨ zobrazovat hlavní menu programu – v případě, že je tento atribut zatržený, tak se hlavní menu programu zobrazuje standardně, při spuštění některé činnosti z hlavního menu je pak uloženo na dolní liště PC. Pokud tento atribut nebude zatržený, tak se hlavní menu programu zobrazovat nebude a uživatel bude systém ovládat pouze pomocí tlačítka „Menu BM“ v okně úloh. Tento atribut úzce souvisí s nastavením předchozích třech parametrů, tzn. musí být nastaveny správně, aby byl tento atribut přístupný pro zatržení. Naopak, pokud je zatržený a uživatel ho odškrtne, dojde k automatickému nastavení atributů „otevírat okno úloh při spuštění programu na Vždy“, „přepínat do hlavního menu programu na Nikdy“ a „ukončení programu klávesou ALT+F4 na zatržené“. V případě, že má uživatel nastaveno hlavní menu nezobrazovat a přesto ho potřebuje náhle aktivovat, provede to pomocí činnosti „Hlavní menu“ pod menu Obecné (horní lišta formuláře). V případě, že aktivované hlavní menu chce uživatel opět „schovat“, provede toto pomocí tlačítka „skrýt menu“, které je dostupné v horní liště činnosti Hlavní menu pod menu Volby (tzn. atribut „zobrazovat hlavní menu programu“ je nezatržen). V případě, že je nastaveno nezobrazovat hlavní menu a uživatel si omylem ukončí okno úloh, tak se hlavní menu automaticky zpřístupní.

¨ používat zobrazení tlačítek – výběr z možností překryvného seznamu:

- textová tlačítka 1 – obsah okna úloh je zobrazován v pevné pozici, tak jak je nastaven pod tlačítkem „nastavit zobrazování úkolů“

- textová tlačítka 2 – obsah okna úloh je zobrazován dynamicky vždy pod daným tlačítkem v seznamu tlačítek

- ikony – obsah okna úloh je zobrazen jako horní lišta činnosti, kde každé jednotlivé tlačítko je představeno samostatnou ikonou

- překryvný seznam – v horní části činnosti okna úloh je k dispozici překryvný seznam s přehledem všech dostupných tlačítek a uživatel se pomocí tohoto překryvného seznamu mezi nimi přepíná

¨ tlačítko „nastavit zobrazování úkolů“ – po stisku tohoto tlačítka se zobrazí seznam všech možností, které uživateli poskytuje okno úloh a uživatel má možnost změnit pořadí jednotlivých nabízených možností, potlačit zobrazení tlačítka a určit pozici okna úloh pro zobrazení tlačítek ve variantě „textová tlačítka 1“

¨ seznam vlastních stránek IP – zde si uživatel může uvést seznam vlastních stránek informačních panelů, které mají být rovněž zobrazeny v okně úloh. Uživatel si pro zobrazení stránek informačních panelů může definovat vlastní tlačítka. V nastavení programu BM lze v parametru OKNOULOH -> VLOZENEINFPANELY zadat seznam identifikací stránek informačních panelů oddělených čárkou. Popis a ikona takto definovaných tlačítek okna úloh přitom odpovídá názvům a ikonám uvedeným v popisu stránky informačního panelu. Jednotlivým uživatelům jsou zobrazovány tyto definovaná tlačítka pouze v případě, že k odpovídající stránce informačního panelu mají přístupové právo alespoň „Čtení“. Pravý klik myši na tlačítku pro zobrazení stránky informačního panelu způsobí znovunačtení stránky.

¨ předplňovat adresáta v novém procesu – tento atribut umožňuje nastavit, že při spuštění nového procesu z okna úloh se předplní adresát zobrazený v aktuálním formuláři pro nově zakládané události v jeho první operaci. Adresát se však předplní pouze v případě, že úvodní druh operace daného druhu procesu má nastavenou vlastnost „vytvořit záložku při založení procesu“. Tento parametr je možno nastavit následovně:

- Ano – z formuláře Adresář – adresát se bude předplňovat pouze v případě, že jako aktuální formulář je spuštěn Adresář

- Ano – z formulářů událostí a Adresář – adresát se bude předplňovat pouze v případě, že jako aktuální formulář je spuštěn Adresář a nebo událost operace komponenty

- Ano – adresát se bude předplňovat vždy, pokud aktuálně spuštěný formulář obsahuje atribut adresát

- Ne – adresát se nebude nikdy předplňovat

¨ průběh procesů – automaticky rozbalovat složky – zatržení této možnost způsobí, že na záložce „Průběh procesů“ se uživateli jednotlivé procesy zobrazují již rozbalené, tzn. hlavička procesu (číslo a název procesu) a pod ní ve stromové struktuře její operace (jako „strom hlavního procesu“). Pokud tato možnost zatržena není, zobrazí se uživateli na záložce „Průběh procesů“ pouze hlavička procesu a tu si musí aktivně sám rozbalit.

¨ dotazovat při uzavírání okna úloh – při ukončení činnosti se při zaškrtnutí tohoto atributu systém dotazuje „Uzavřít okno úloh? Ano/Ne“. V případě, že není tento atribut zatržen, systém ukončí okno úloh automaticky bez dotazu.

Pozn.:

V seznamu stránek informačních panelů je možné před identifikací stránky uvádět znak ‘*‘. Tento znak znamená, že se jedná o příznak toho, že daná stránka je závislá na datech aktivního formuláře BM.

Takové stránky obvykle využívají parametr, které je jí předán v okamžiku jejího vyvolání.

Jedná se o parametr _P1, který obsahuje objekt s atributy odpovídající atributům aktuálního záznamu formuláře nebo hodnotu .F. (FALSE), pokud záznam není možné určit. Výskyt atributů v objektu _P1 je třeba při vytváření stránky IP ošetřit, protože např. atribut AD01ID (identifikace adresáta) se samozřejmě nevyskytuje ve všech formulářích BM. Máme-li např. stránku informačního panelu pro zobrazení informací o adresátovi, potom její poduzly mohou být definovány:

- Parametry - _P1.AD01ID

- WHERE – ADADSAT.AD01ID=?_P1

- Podmínka – TYPE(‘_P1.AD01ID‘)=‘C‘

Pro stránky informačního panelu, jejichž obsah je závislý na datech aktivního formuláře BM platí, že opakovaný klik na tlačítko v okně úloh v okamžiku, kdy je zobrazen v okně úloh jeho odpovídající obsah, způsobuje znovunačtení stránky.

2.2.14.1 Nastavení stromu

V činnostech, které využívají stromové zobrazení, jako je strom hlavního procesu, obecné stromy, strom pracovníka, hlavní menu a okno úloh má uživatel možnost nastavit si zobrazení a způsob ovládání. Toto provede stiskem pravého tlačítka myši na názvu činnosti a zvolí možnost „Nastavení stromu“. Zde jsou k dispozici následující atributy:

¨ font – výběr druhu písma, ve kterém bude daná činnost zobrazena (uživatele je v tomto případě nutno upozornit, aby si vybírali fonty, které zvládají zobrazení diakritiky, jinak pak zobrazení činnosti může vypadat tzv. jako „rozsypaný čaj“)

¨ velikost písma – tlačítkem nahoru nebo dolů si uživatel zvolí velikost daného písma

¨ kurzíva – při zatržení tohoto příznaku bude zvolený font písma ještě zvýrazněn kurzívou

¨ ‘+’ také ve vrcholových uzlech stromu – při standardním stromovém zobrazení činností mají vrcholové uzly před svým názvem ve většině případů ikonu a rozbalují se dvojklikem myši na názvu činnosti (nebo ikoně). Teprve další činnosti pod nimi mají před svým názvem znaménko ‘+’, což znamená, že je možno je ještě dále rozkliknout. Při zatržení tohoto atributu bude znaménko ‘+’ i před názvy vrcholových uzlů a klikem na něj se ihned rozbaluje nabídka činností pod ním.

¨ používat zjednodušené ovládání – při standardním ovládání se činnosti v menu aktivují dvojklikem levého tlačítka myši. Vysvětlíme si na příkladu hlavního menu. Uživatel si dvojklikem myši aktivuje činnost Marketing, ta zůstane rozbalená a dalším dvojklikem si aktivuje činnost Platby. Znamená to, že nyní má v hlavním menu rozbalenu nabídku dvou činností. V případě, že tuto nabídku chce zavřít, musí ji opětovným dvojklikem zase zavřít. Zatržení tohoto příznaku umožňuje uživateli změnit chování činností. Po kliku (jednom kliku levého tlačítka myši – nikoliv dvojkliku) na názvu činnosti se tato okamžitě rozbalí. Při kliku a rozbalení další činnosti se zároveň ihned první rozbalená činnost zase automaticky zavře. Vysvětlíme si opět na příkladu hlavního menu. Uživatel stiskem levého tlačítka myši aktivuje činnost Marketing, ta se ihned rozbalí, dalším stiskem levého tlačítka myši aktivuje činnost Platby. Ta se ihned rozbalí, ale zároveň se ihned automaticky zavře původní otevřená činnost Marketing.

Lehce odlišné chování jednotlivých menu může nastat v případě, že uživatel bude mít v této činnosti zároveň zatrženy atributy „‘+’ také ve vrcholových uzlech stromu“ a „ používat zjednodušené ovládání“. Pak skutečně i při ovládání menu funguje kombinace standardního a zjednodušeného ovládání menu. Při kliku na název činnosti se menu chová podle příznaku „používat zjednodušené ovládání“, tzn. menu se ovládá pouze stiskem levého tlačítka myši. Při kliku na znaménko ‘+’ u vrcholového uzlu se menu ovládá standardně. Opět si tuto situaci vysvětlíme na příkladu hlavního menu. Uživatel má samozřejmě zatrženy oba jmenované atributy. Při stisku levého tlačítka myši na názvu činnosti Marketing se rozbalí nabídka této činnosti. Po stisku znaménka ‘+’ u činnosti Platby se rovněž rozbalí nabídka této činnosti. Dalším stiskem levého tlačítka myši např. na názvu činnosti DHP se automaticky zavře nabídka činnosti Marketing (chová se podle zjednodušeného ovládání menu), ale nabídka činnosti Platby zůstane otevřená (chová se podle standardního ovládání menu).

3. „Stáváme se odborníky“

Tato kapitola obsahuje popisy činností, které jednak již byly částeně zmíněny v kapitole 2. a zde jsou více definičně rozvedeny a jednak i popisy dalších činností dostupných v IS BM, u kterých se při jejich definování předpokládá jistá uživatelská zdatnost a hlubší znalost IS BM.

3.1 Volné karty – definice

V každé činnosti, kde má uživatel pod menu Obecné dostupnou činnost Volné karty je možno definovat neomezený počet volných karet, přičemž údaje z těchto volných karet je možno sledovat současně v jednom okně, tzn. že v každém okně je možno mít zobrazen vybraný počet volných karet (tj. tolik, kolik si jich uživatel spustí). Každá volná karta se uživateli zobrazuje v samostatném okně. Tak jak se uživatel pohybuje po jednotlivých záznamech seznamu, tak se automaticky mění i údaje v okně volných karet.

V případě, že uživatel si nadefinoval volnou kartu, kde určité atributy při její aktivaci vstupuje (např. dodací lhůty, poznámky apod.) je nutno po její definici následně spustit činnost „generování tabulky“ v menu Volby (v případě, že nespustí generování tabulky, nebude daná volná karta fungovat). Pokud by systém při generování v některých případech hlásil chybové hlášení, je nutno stisknout klávesu F4 (nebo ikona „oprava“), pak uložit disketou a spustit generování znovu (provést jakoby fiktivní opravu). V případě generování tabulky dané volné karty systém (uvnitř své databáze) vytváří novou fyzickou tabulku, která kromě uživatelsky definovaných atributů obsahuje primární klíč, který je shodný se záznamem z výchozí tabulky a pomocí nějž jsou tyto tabulky propojeny. Jméno této nové fyzické tabulky (uživatelsky je v IS BM nedostupná) se skládá ze jména výchozí tabulky doplněného podtržítkem a jménem volné karty (např. v adresáři máme nadefinovanou volnou kartu „karta distributora“, která má identifikaci DI001. Tato vytvořená fyzická tabulka má tedy potom identifikaci ADADSAT_DI001). Pro uživatele je nutno umět si odvodit název dané tabulky, protože se pak na ní odvolává např. v případě, pokud by chtěl do tiskové sestavy dostat údaje z volné karty. Pak je v tiskové sestavě v doplnění nutno zadat právě název této tabulky a spojit je s tiskem pomocí primárního klíče.

Volné karty činností Procesy, Operace, Adresát a Artikl jsou dále dostupné i v činnostech zobrazujících události jednotlivých komponent (menu Obecné – Volné karty). V činnostech zobrazujících záznamy propojené pomocí objektové vazby je kromě volné karty Vazby objektů dostupná i volná karta objektu zobrazovaného v seznamu. U druhu operace lze definovat automatickou aktivaci volné karty procesu nebo operace při ukončení operace daného druhu (na záložce „další“ u druhu operace nebo u druhu procesu, menu Informační centrum – Typy a řady, atribut „po ukončení operace .....“), další automatickou práci s těmito volnými kartami lze definovat v kódu při ukončení operace.

Definice volné karty se skládá z definice její hlavičky, prezentovaných údajů (záložka „atributy volné struktury“) a volných pohledů (fakticky příkazů SELECT pro získání informace výpočtem z dat IS BM – záložka „volné pohledy“).V hlavičce se definuje:

¨ identifikace volné karty

¨ název volné karty

¨ správce – identifikace druhu implementačního rozšíření. Určuje právo uživatele ke správě (definování) volné karty. Vybírá se z překryvného seznamu a možnosti jsou: -, obecný druh dopl. vlast. formuláře, správce, systémový

¨ druh volné karty – vybírá se ze seznamu druhů volných karet, určuje právo uživatele pro přístup k datům volné karty. K tabulce volné karty je naprogramován trigger, který při změně druhu volné karty (v tabulce SPVOLST) provádí změnu druhu těch atributů volné karty (v tabulce SPVOLSTA), které mají uveden stejný druh jako původní druh volné karty.

¨ velikost – umožňuje změnit velikost okna volné karty (Ne, Horizontálně, Vertikálně, Oběma směry – horizontálně i vertikálně)

¨ posuvník – zda okno volné karty bude obsahovat posuvník. Pokud je volná karta menšího formátu, posuvník není zřejmě nutný, pokud obsahuje větší množství údajů, ale je omezena určitou velikostí, je vhodné zvolit aspoň horizontální posuvník, aby bylo možno se po jednotlivých atributech volné karty pohybovat. Možnosti jsou Žádný, Horizontální, Vertikální, Oba)

¨ autor – zobrazovat na volné kartě/nezobrazovat na volné kartě. Určuje, zda má být na volné kartě zobrazována informace o uživateli, který volnou kartu založil a datum jejího založení

¨ dynamický nadpis - výraz ve formátu FoxPro, který je vyhodnotitelný na úrovni formuláře, ze kterého je volná karta vyvolána a vrací textovou hodnotu. Např. volná karta v činnosti přehled uživatelů. Pokud je v dynamickém nadpisu zapsán výraz ve tvaru bwuzivat.bw01jmeno, tak při listování seznamem uživatelů se v okně volné karty bude dynamicky měnit jméno uživatele. Je možné uvádět výraz v jazyce FoxPro uvedený znakem ‘=’ – v tomto výrazu je možné získat hodnoty primárního klíče uvedením názvů atributů primárního klíče v hranatých závorkách.

¨ vyvolat automaticky - zda se bude aktivovat automaticky při spuštění činnosti

¨ znovu načítat – tento atribut způsobuje znovunačtení volné karty po zápisu dat na kartu. Volnou kartu je navíc možné „znovu načíst“ volbou z menu Obecné nebo po stisku funkční kláves F6.

¨ skript – definuje skript v jazyce FoxPro vyvolávaný v okamžiku zápisu volné karty. Pokud skript vrátí logickou hodnotu .F. (FALSE) není karta zapsána. Vyvolání skriptu se dá využít:

a/ k zápisu dalších informací na VK

např.: datum na VK je datem aktualizace VK

REPLACE bw01uziv1 WITH tool.uziv

REPLACE sp00datzap WITH DATETIME()

REPLACE bw01jmeno WITH tool.jmeno

b/ odeslání e-mailu před zápisem VK

¨ komentář – libovolná poznámka k volné kartě

¨ informace o tom, kdo a kdy volnou kartu založil

Vzhled volné karty je dán uživatelským designem (menu Volby nebo klávesa F6 – „design vstupního formuláře“), který určuje to, jak budou jednotlivé atributy volné karty rozmístěné v okně volné karty. Pokud to daná činnost umožňuje, lze vyvolat kteroukoliv volnou kartu po stisku menu Obecné a pak si příslušnou volnou kartu vybrat podle toho, zda se jedná o volnou kartu procesu, operace apod.

Na záložce „atributy volné struktury“ uživatel definuje:

¨ identifikaci (název) atributu,

¨ druh - vybírá se ze seznamu druhů volných karet, určuje právo uživatele pro přístup k datům volné karty

¨ typ, případně délku a počet desetinných míst (typ – znaková, numerická, datumová, časová, textová, multimediální – viz. popis níže)

¨ pořadí, v jakém bude aktualizován

¨ třída (textové pole, překryvný seznam, zaškrtávací pole)

¨ zobrazení - v jakém zobrazení či formátu se bude daný atribut při aktivaci okna volné karty zobrazovat, např. u překryvných seznamů se zde uvádí volby, které se uživateli budou nabízet při vyvolání tohoto překryvného seznamu, např. Ano,Ne nebo Příjem,Výdej apod., u numerických atributů zde může být zapsán formát jak se číslo má v okně volné karty zobrazovat, např. 99 999 999.99. Je možné uvádět libovolně dlouhý text. Pro třídu překryvný seznam a typ znakový je možné zadat SQL dotaz uvedený znaky *~. Dotaz musí vracet dva sloupce. První sloupec určuje text zobrazovaný v překryvném seznamu a druhý hodnotu předávanou na volnou kartu, např. SQL dotaz pro překryvný seznam se seznamem uživatelů *~select (if bw01aktiv=1 then '' else '* ' endif )+bw01jmeno,bw01uziv from %%%.bwuzivat where bw01uziv<>'$SYSTE' order by bw01aktiv desc,bw01jmeno

¨ návěští (tzn. popis, který se u daného atributu bude zobrazovat v okně volné karty)

¨ poznámka - vlastní poznámka k atributu,

¨ inicializace - pokud je zde uveden atribut, který je výpočtový, je nutno pro něj mít vytvořen vlastní volný pohled. Pokud je tedy uveden „název volného pohledu.alias jeho atributu" (např. POHCLK.pclk1), pak se jedná o údaj prezentující vypočtenou hodnotu (pomocí příkazu SELECT), v opačném případě se jedná o atribut nové tabulky, která se musí po každé aktualizaci své struktury generovat. V případě, že se jedná o atribut třídy zaškrtávací pole, při inicializaci 0 je volný, při zadané inicializaci 1 je při aktivaci okna volné karty již zaškrtnutý nebo při překryvném seznamu jsou atributy v překr. seznamu fiktivně očíslovány 1,2,3 atd., tzn. že při zobrazení Ano,Ne a nastavení inicializace na 1 se při aktivaci okna volné karty přednastaví překryvný seznam na hodnotu Ano. Atribut může obsahovat výraz uvedený znakem #např.: #tool.uziv pro inicializaci hodnoty volné karty identifikací aktuálního uživatele systému. Ve vlastnosti inicializace je možné uvádět text uvedený rovnítkem. Hodnota takové atributu není ukládána do dat volné karty a tento atribut není možné editovat. Za rovnítkem se uvádí výraz v jazyce FoxPro, jehož hodnota je zobrazována pro daný atribut ve volné kartě. Hodnota atributu ve volné kartě je přezobrazována při každé změně, kterou proveden uživatel vstupem libovolného atributu. Pro správné vyhodnocení je nutné, aby vstupované atributy uváděné ve výrazu měly pořadí menší než atribut, ve kterém je uvedena vypočtená hodnota. Za rovnítkem vlastnosti inicializace je možné zadat prefix SCRIPT – inicializace je potom provedena pomocí víceřádkového skriptu v jazyce FoxPro. Příklady:

a/ název adresáta zobrazovaného na volné kartě na základě identifikace adresáta (atribut IDADR) vstupované uživatelem:

=tool.sql_dotaz([select ad01adsat from %%%.adadsat where ad01id=?_p1],[idadr])

b/ součet dvou hodnot vstupovaných uživatelem

=[hodnota1]+[hodnota2]

c/ příklad řešení se skriptem

=SCRIPT

IF [hodnota1]>20

RETURN [hodnota2]

ELSE

RETURN [hodnota1]

ENDIF

¨ validace – je zde možno uvádět kód v jazyce FoxPro, který vrací hodnoty TRUE nebo FALSE signalizující validitu atributu. V tomto kódu je možné uvádět text ### (představuje daný atribut) nebo názvy jiných atributů volné karty ohraničené hranatými závorkami. Tyto texty představují hodnotu odpovídajícího atributu. Příklady:

a/ validace na nenulovou hodnotu

IF ###=0

WAIT WIND 'Částka nesmí být nulová' NOWAIT

RETURN .F.

ENDIF

b/ validace existence adresáta zadaného uživatelem na volnou kartu

IF EMPTY([adnazev])

* předpokládá se, že ADNAZEV je atribut volné karty inicializovaný podobně jako v příkladu 1a

* tento atribut bude v průběhu vstupu prázdný, pokud hodnota atributu identifikace adresáta (v příkladu 1x se jedná o atribut IDADR) neodpovídá existujícímu adresátovi

WAIT WIND 'Adresát musí být uveden' NOWAIT

RETURN .F.

ENDIF

¨ podmínka – umožňuje definovat logický výraz v jazyce FoxPro určující podmínku vstupu do daného atributu. Pokud podmínka obsahuje výraz .F. – je atribut zobrazen ve formátu pouze pro čtení

Ve vlastnostech atributů Zobrazení, Inicializace a Validace je možné používat makra. Základní makra jsou k dispozici v Návodech a balíčcích. Vlastní definování maker se provádí činností „definice maker“ z menu Volby formuláře volná karta. Řešení příkladů pomocí těchto maker:

1a/ fky_nazev_adresata([idadr])

2a/ valid_neprazdny('Částka nesmí být nulová')

2b/ valid_fky([adnazev],'Adresát musí být uveden')

V popisech Zobrazení, Inicializace a Validace jednotlivých atributů volné karty je možné uvádět identifikátory atributů primárního klíče tabulky, se kterou je volná karta spojena. Tyto identifikátory se uvádějí v hranatých závorkách. Např.: na volnou kartu adresáta zobrazit název adresáta v atributu inicializace - =tool.sql_dotaz([select ad01adsat from %%%.adadsat where ad01id=?_p1],[ad01id])

¨ p. oknu – přizpůsobení oknu – určuje, zda akceptovat změny velikosti atributu při změnách velikosti celého okna volné karty (Ne, Horizontálně, Vertikálně, Obojí)

¨ F2 - reakce - zda má být při vstupu údaje po stisku F2 aktivována zde uvedená činnost, tj. vstup do zvoleného číselníku.

Na záložce „atributy volné struktury" uživatel tedy definuje atributy, které po vyvolání příslušné volné karty vyplňuje, resp. prohlíží (ty mají údaj "inicializace" uveden názvem volného pohledu). Atributy volné karty jsou pak k dispozici v transformacích druhu procesu. Pokud je chceme použít jako výstupní atributy komponenty, tak v seznamu výstupních atributů komponenty (klávesa F5 v činnosti „Definice výrazu) nejsou zobrazeny. Do výrazů je nutno je zapsat po stisku klávesy F3 a před vlastní název výrazu je nutno připsat znak „~" (např. výraz ~data.divs je definován hodnotou atributu "divs" volné karty). Tento znak zaručí, že systém nebude daný výraz kontrolovat z hlediska syntaxe.

Atributy volné karty typu 'Multimediální' se používají:

1. s nevyplněnou vlastností 'Inicializace' - obrázek nebo videoklip je ukládán v tabulce volné karty

2. s vyplněnou vlastností 'Inicializace' výrazem uvedeným znakem '=' - obrázek není uložen v tabulce volné karty - na volné kartě je zobrazován obrázek ze souboru, jehož název je určen vyhodnocením výrazu této vlastnosti

3. s vyplněnou vlastností 'Inicializace' výrazem uvedeným znakem '=' a uvedeným textem AVI v popisu třídy atributu - videoklip není uložen v tabulce volné karty - na volné kartě je zobrazován videoklip ze souboru, jehož název je určen vyhodnocením výrazu této vlastnosti

Výraz vlastnosti 'Inicializace' je vyhodnocován dynamicky při přezobrazování volné karty, takže se při pohybu v záznamech formuláře, ke kterému je karta připojena, může docházet ke změně zobrazovaného obrázku resp. videoklipu. Multimediální atributy v vyplněnou vlastností 'Inicializace' mohou mít uveden ve vlastnosti 'Validace' kód v jazyce FoxPro, který má být prováděn při pravém kliku myší na obrázku resp. pravém okraji videoklipu.

K dispozici jsou makra, která usnadňují vytváření volných karet pro zobrazování multimédií, které jsou uloženy jako dokumenty BM připojené k objektům BM. Rozhodnutí o tom zda budou obrázky objektů ukládány v tabulce volné karty (ad 1.) nebo jako dokumenty BM (ad 2.) ovlivní implementaci. Obrázky objektů BM implementované způsobem ad 1. je možné prohlížet prostřednictvím volné karty a tisknout klasickou předlohou výstupu, další možnosti nejsou. Obrázky objektů BM implementované způsobem ad 2. (s využitím maker) je možné tisknout v předlohách výstupu typu Excel (tisk v klasické předloze výstupu je obtížný), použít s jinými nástroji Windows (např. publikovat na internetu), zahrnout do řízení procesu (např. při pořizování přijaté faktury přinutit uživatele připojit k procesu oskenovanou kopii přijaté faktury). Pro zobrazování dokumentů BM, které jsou svým charakterem obrázky resp.videoklipy, připojené k objektům BM, jsou připravena makra pro použití ve vlastnostech 'Inicializace' a 'Validace' multimediálních atributů volných karet.

Pro vlastnost 'Inicializace' makro - DOKUMENT_OBRAZEK_OBJEKTU.

Substitucí makra vznikne výraz, který vrací název souboru obsahujícího obrázek, který je uložen v dokumentu připojeného k objektu BM. Protože k objektu BM může být připojeno více dokumentů, z nichž pouze některé jsou obrázky, uvádí se parametrem tohoto makra, jakého druhu dokumentu a jakou předlohu dokumentu může mít připojený obrázek. Jediným parametrem makra je identifikátor obecné předkontace, které by měly mít uvedeny hodnoty:

- VK0001 - seznam druhů dokumentů

- VK0002 - seznam předloh výstupu

Na volné kartě je potom zobrazován obrázek uložený v prvním nalezeném připojeném dokumentu, který je druhu podle hodnoty VK0001 a má předlohu výstupu podle hodnoty VK0002. Dokument s obrázkem nebo videoklipem přitom může být uložen v databázi BM nebo uložený externě.

Pro vlastnost 'Validace' makro - DOKUMENT_OBRAZEK_RIGHTCLICK

Toto makro je možné použít pouze v případě, že je ve vlastnosti 'Inicializace' uvedeno volání makra DOKUMENT_OBRAZEK_OBJEKTU. Substitucí makra vznikne kód v jazyce FoxPro, který po pravém kliku klávesou myši na obrázku resp. pravém okraji videoklipu zobrazí menu:

1. v případě, že dokument není k objektu BM připojen:

1a) Založit dokument - obrázek

- volbou uživatel vybírá soubor obrázku s příponou podle hodnoty obecné předkontace VK0001 (identifikace této překontace je dána voláním makra DOKUMENT_OBRAZEK_OBJEKTU)

- následně vstupuje vlastnosti nově zakládaného dokumentu s předplněným názvem podle prvého parametru makra a s předplněným způsobem uložením dokumentu podle druhého parametru makra (0=předplňovat ukládání do databáze, 1=předplňovat externí uložení na disk), přitom vybírá druh dokumentu podle VK0001 a předlohu dokumentu podle VK0002 a odpovídající přípony

2. v případě, že je dokument k objektu BM připojen:

2a) Vyměnit dokument - obrázek

- volbou uživatel vybírá soubor obrázku s příponou podle předlohy daného dokumentu, kterým bude nahrazen obrázek uložený v dokumentu BM. Tato volba je podmíněna právem zápis pro uživatele k druhu daného dokumentu.

2b) Opravit dokument - obrázek

- volbou je vyvolána oprava dokumentu

2c) Uložit jako ...

- volba pro uložení kopie obrázku na disk

2d) Kopírovat

- provede kopii souboru do schránky Windows (obrázek je potom možné např. vložit do dokumentu Wordu, jako přílohu e-mailu, ...)

2e) Vlastnosti dokumentu

- volba pro prohlížení a opravy vlastností dokumentu BM

Pro vlastnost 'Inicializace' makro - EXTERNI_OBRAZEK

Makro se používá ve vlastnostech 'Inicializace' atributů typu 'Multimediální' volných karet. Substitucí makra vznikne výraz, který vrací název souboru obsahujícího obrázek resp. videoklip podle parametrů makra.

Parametry:

1. adresářová cesta k souboru

2. název souboru bez přípony

3. přípona souboru - může být uvedena souborová maska např. '*'

Makro je třeba uvádět s prefixem SCRIPT.

Příklad:

=script externi_obrazek('mediup\pict\',[sp60id],'*')

Pro vlastnost 'Validace' makro - EXTERNI_OBRAZEK_RIGHTCLICK

Makro se používá ve vlastnostech 'Validace' atributů typu 'Multimediální' volných karet. Toto makro se většinou používá při použití makra EXTERNI_OBRAZEK uvedeného ve vlastnosti 'Inicializace'.

Substitucí makra vznikne kód v jazyce FoxPro, který po pravém kliku klávesou myši na obrázku zobrazí menu:

1. Kopírovat - provede kopii souboru do schránky Windows (obrázek je potom možné např. vložit do dokumentu Wordu, jako přílohu e-mailu, ...)

Příklad:

externi_obrazek_rightclick()

Na záložce „atributy volné struktury“ tedy uživatel definuje atributy, které po vyvolání příslušné volné karty vyplňuje, resp. prohlíží (ty mají údaj "inicializace" uveden názvem volného pohledu). Atributy volné karty jsou pak k dispozici v transformacích druhu procesu. Pokud je chceme použít jako výstupní atributy komponenty, tak v seznamu výstupních atributů komponenty (klávesa F5 v činnosti „Definice výrazu) nejsou zobrazeny. Do výrazů je nutno je zapsat po stisku klávesy F3 a před vlastní název výrazu je nutno připsat znak „~“ (např. výraz ~data.divs je definován hodnotou atributu "divs" volné karty). Tento znak zaručí, že systém nebude daný výraz kontrolovat z hlediska syntaxe.

Záložka „volné pohledy“ umožňuje doplnit definici atributů volné struktury o SQL dotaz, kterým tyto atributy mají být plněny. Definice záložky „volného pohledu“ zahrnuje:

¨ pohled - identifikaci a název volného pohledu,

¨ návratové hodnoty, tj. výčet atributů klíče uvozených znaky $$$. a oddělených čárkou. Je to seznam výrazů (oddělených čárkami) ve formátu FoxPro vyhodnotitelných ve formuláři, ze kterého je volná karta vyvolána. Atribut uvozený $$$. je nahrazen názvem aliasem dočasné tabulky (tj. kurzoru) událostí odpovídající komponenty, ke kterému je volná karta připojena,

¨ formální parametry, tj. výčet atributů klíče uvozených znaky _ a oddělených čárkou. Je to seznam identifikátorů pod kterými budou tyto hodnoty vystupovat v SQL dotazu. Doporučuje se, aby název jednotlivých atributů byl uvozen podtržítkem.

¨ dotaz, tj. příkaz SELECT pro získání dat, ve kterém je možné využít formální parametry uvozené otazníkem (pro příklad se zadanou inicializací v atributech volné struktury obsahuje tento volný pohled atribut pclk1),

¨ poznámku – libovolný popis uživatele.

Z výše uvedeného vyplývá, že „návratové hodnoty“ vrací hodnotu daného atributu z daného formuláře na základě aktivního záznamu (např. pokud bude návratovou hodnotou atribut ad01id, tak systém v tuto chvíli vrátí identifikaci adresáta, na které je v danou chvíli v tabulce adresáře v přehledu jednotlivých záznamů umístěn kurzor). Formální parametry obsahují již konkrétní data atributu, který je v dotazu v příkazu SELECT uveden otazníkem (např. ?_ad01id). Jinými slovy, laicky řečeno, návratové hodnoty říkají systému „na co se má zeptat“, formální parametry poskytují již „určitou hodnotu“.

Záložka „užití volné karty“ sleduje využívání jednotlivých volných karet a tím usnadňuje rozhodování implementátora o tom, kterou volnou kartu ponechat a kterou je vhodné vyřadit. Užití volné karty, která je otevírána automaticky při spuštění formuláře zde zaznamenáno není. Zobrazuje se:

¨ kdo - jméno uživatele

¨ kdy poprvé - datum prvního použití volné karty uživatelem

¨ kdy naposledy - datum posledního použití volné karty uživatelem

¨ kolikrát - celkový počet použití volné karty uživatelem

Tyto informace se ukládají do tabulky SPVOLSTU s atributy:

¨ bw10nazev - část primárního klíče volné karty

¨ sp64nazev - část primárního klíče volné karty

¨ bw01uziv - kdo - identifikace uživatele

¨ spe6dat1 - kdy poprvé

¨ spe6dat2 - kdy naposledy

spe6pocet – kolikrát

3.2 Definice předlohy výstupu

V této kapitole se naopak budeme věnovat více popisu vlastní předlohy výstupu. Po aktivaci činnosti tisk má tedy uživatel v okně této činnosti přehled dosud nadefinovaných předloh výstupu. Po stisku pravého tlačítka myši na názvu předlohy má uživatel k dispozici tyto možnosti:

¨ spustit předlohu – aktivuje vlastní tisk

¨ opravit předlohu – uživatel má možnost si opravit vlastní definici předlohy

¨ vlastnosti předlohy – jednotlivé vlastnosti předlohy, které má uživatel k dispozici ve formě záložek, lze je vyvolat i samostatně (ikonou v panelu nástrojů) –

- obecné - na této záložce se určuje typ (sestava, Excel, ostatní) a druh předlohy. K druhu předlohy lze nadefinovat přístupová práva žádný přístup/čtení/zápis. Uživatel s právem přístupu čtení, který není správcem systému ani autorem předlohy ji může spustit, ale nemůže předlohu kopírovat, rušit, opravovat a nejsou mu dostupné ani vlastnosti předlohy. Je možné definovat druh předlohy, který není dostupný žádnému uživateli systému a na něj „odkládat“ předlohy, které není možné zrušit (na základě referenční integrity) nebo u kterých není jisté, zda bude třeba danou předlohu někdy v budoucnu použít. Pokračují atributy, zda je skrytá (pouze pro aktuálně přihlášeného uživatele) nebo skrytá všem (tato předloha je skrytá všem bez ohledu na privátní nastavení vlastnosti „skrytá“[9]. Příznak skrytá všem může nastavit pouze správce systému[10]). Příznak systémových předloh mají předlohy dodané společně s dodávkou systému a u těchto předloh není možno opravovat definici předlohy. Z překryvného seznamu nadefinovaných skupin procesu/předloh výstupu je možno vybrat skupinu ve které bude daná předloha zařazena. Aby bylo možno skupinu přiřadit k předloze výstupu, je nutno mít danou skupinu nadefinovanou v činnosti skupiny procesů a musí mít nastaveno hodnotu Ano v atributu „skupina předloh výstupu“. Jednotlivé skupiny předloh či osobní skupiny předloh výstupu se zobrazují v okně výstupy (po aktivaci ikony „tiskárna“ nebo stisku Ctrl T) v případě, že je zvolené zobrazení ve formě stromu. Po stisku pravého tlačítka myši na názvu skupiny má uživatel k dispozici následující možnosti:

- metapředlohy – vyvolání formuláře pro definování metapředloh

- skupiny procesů/předloh výstupu – vyvolání formuláře pro definování skupin

- nastavení stromu – vyvolání formuláře pro definování vlastností zobrazení stromu

V případě, že uživatel ve vlastnostech předlohy přiřadil vybrané předloze výstupu skupinu a zároveň danou předlohu zařadil v podmenu volby osobní skupina předlohy do jiné skupiny, bude tato předloha zobrazena ve stromu dvakrát, tzn. v obou skupinách.Jako další se zde může určit jazyk, v jakém se předloha bude prezentovat (daná předloha musí být samozřejmě definována vícejazyčně).

- popis - tato záložka obsahuje název předlohy a způsob setřídění atributů v ní, není-li na záložkce „setřídění“ definováno jinak. V případě potřeby je možno zatrhnout (dvojklikem myši) i pohyb (pohyb nastavený v předloze dokladů na události umožní zadat prezentaci procesu), tzn. ze kterých tabulek se ještě mají atributy v předloze nabízet. Zatržením příznaku tisk aktuálního by se tiskl vždy jen aktuální záznam (tzn. ten, na kterém je právě umístěn kurzor) a v případě zatržení pouze součtové údaje jsou ze sestavy při tisku vynechány jednotlivé záznamy a tisknou se pouze ty řádky, na kterých je v sestavě nadefinována suma (tj. součet, nejčastější použití je u předloh typu Excel a HTML – ostatní). U atributu kopie si uživatel určí pouze počet kopií při tisku a atribut výstupy procesů obsahuje překryvný seznam možností, jak může uživatel podle svých parametrů ovlivnit tisk předlohy. Reakce na aktivaci je uživatelsky ovlivnitelná profilem spuštění, který je k dané předloze přiřazen, a který ovlivňuje chování předlohy po její aktivaci.

- setřídění [11] - umožňuje uživateli nastavit si vlastní třídění, které na záložce popis není implicitně k dispozici. Při zaškrtnutí příznaku vlastní setřídění musí pak uživatel kliknout na ikonu „čtvereček“ v pravé části obrazovky a následně si atribut vybrat (tato možnost však vyžaduje jistou znalost datového modelu), též může užít atributy definované na záložce doplnění. Výraz setřídění lze zadat v syntaxi SQL (např. adadsat.ad01id) nebo v syntaxi FoxPro (např. *SPARTIKN_sp62artikl). V předloze dokladu lze definovat pouze setřídění událostí v rámci operace (setřídění dle operací je definováno v prezentaci procesu) a to jednotně pro všechny operace dané komponenty.

- seskupování - umožňuje nastavení vlastního seskupování atributů předlohy výstupu. Množina těchto atributů tisku může být uživatelsky nahrazena uvedenými atributy a výrazy, a to i z uživatelem připojených dalších tabulek na záložce doplnění. Druhá kolonka definuje „grupování“ (GROUP a HAVING) přímo na serveru. V seskupování se tedy uvádí informace potřebné pro vytvoření dotazu SQL s klauzulí GROUP BY. Při zaškrtnutém "Seskupování" se zde v poli "Atributy a výrazy příkazu SELECT" uvádí část sestaveného příkazu mezi SELECT a FROM. Jinými slovy umožňuje, aby příkaz SELECT při získání dat výstupu byl redefinován (oproti programovému kódu) s využitím klauzulí GROUP a HAVING, což je smysluplné tehdy, obsahuje-li předloha výstupu významné agregace. Ty se pak realizují na serveru, což bývá několikanásobně rychlejší (příklad zápisu je uveden ve slovníku pojmů).

V poli “Atributy a výrazy v příkazu SELECT” se uvádí například:

MTUDA.sp60id MTARTIKL_sp60id,MTUDA.sp61id MTARTIKL_sp61id,MTUDA.mt04id MTUDA_mt04id,SUM(MTUDA.mt02mnr*(if MTUDA.mt02pv=1 then 1 else -1 endif)) MTUDA_mt02mnr

V poli "Doplnění klausulí GROUP a HAVING" se uvádí odpovídají část dotazu, například:

MTUDA.sp60id,MTUDA.sp61id,MTUDA.mt04id

HAVING MTUDA_mt02mnr<>0

ORDER BY MTUDA.mt04id,MTUDA.sp61id,MTUDA.sp60id

- doplnění - umožňuje rozšířit předlohu výstupu o atributy, které se při jejím vytváření uživateli nenabízí přímo. Do kolonky „atributy“ se zadává seznam atributů nebo výrazů oddělených čárkou doplněných do dotazu ve tvaru „<alias tabulky>.<atribut>.<alias atributu>“. V příkazu SELECT se doplňuje do oblasti před FROM. Do kolonky „select-join“ se zadává seznam tabulek doplněných do dotazu SELECT mezi FROM a WHERE za deklaraci první tabulky dotazu nastavené programem. Pokud tento seznam nezačíná příkazem LEFT OUTER JOIN, musí začínat čárkou. Do kolonky „výběr“ se zadává doplnění příkazu SELECT v oblasti za WHERE, musí začínat „AND“ a je-li v dotazu obsažen logický operátor „OR“, musí být odpovídající část definice uzavřena do kulatých závorek.

Příklad: ( týká se jen části doplnění sestavy)

Nad Vývěskou (VYUDALOS) doplnění emailu spojení adresáta

Atributy: ADSPOJ.ad11email email

Select-join: ,%%%.ADSPOJ ADSPOJ

Výběr: AND VYUDALOS.ad01id=ADSPOJ.ad01id

Pozn.

V excelovské sestavě se pak k tomuto atributu dostanete například takto:

.EP xlsheet.cells[$(r),$(s9)].value=[']+sql_tisk.email

V html sestavě musíme použít Deklaraci: idemail;c(30);Email;sql_tisk.email a poté přidat atribut pomocí: $(idemail_USER_)

Sybase SQL Anywhere ve verzi 9 je citlivější na SQL dotazy obsahující na příkazu obsahující klauzuli LEFT OUTER JOIN, která musí být v jejím případě umísťována bezprostředně za tabulku, ke které je navazující tabulka připojována.

Např. SQL dotaz:

¨ select * from bm_servis.adadsat,bm_servis.spseob left outer join bm_servis.adspoj on adspoj.ad01id=adadsat.ad01id where spseob.sp10idzak=adadsat.sp10idzak,

který je funkční v nižších verzích Sybase SQL Anywhere, musí mít pro Sybase SQL Anywhere verze 9 tvar:

¨ select * from bm_servis.adadsat left outer join bm_servis.adspoj on adspoj.ad01id=adadsat.ad01id,bm_servis.spseob where spseob.sp10idzak=adadsat.sp10idzak

Řešením je možnost určení, kam má být která část uvedené definice do sestavovaného SQL dotazu zařazena. Toto uživatel provádí ve vlastnostech předlohy výstupu na záložce doplnění v atributu Select-join.

V atributu Select-join je možné uvádět definici jedné nebo několika subdefinic oddělených znakem '|' (svislá čára).

Syntaxe subdefinice je:

[#alias#] [tělo subdefinice]

Každá z těchto subdefinic určuje ve svém těle část SQL dotazu, která má být v sestavovaném SQL dotazu umístěna na různém místě podle uvedeného alias.

Příklad nastavení vlastnosti Select-join pro předlohu výstupu Události plateb:

#PLUDA# LEFT OUTER JOIN %%%.ADBUCTY UC99 ON UC99.AD01ID=PLUDA.AD01ID AND UC99.AD03CISBAN='99' |

#ADADSAT# LEFT OUTER JOIN %%%.ADSPOJ SP13 ON SP13.AD01ID=ADADSAT.AD01ID AND SP13.AD11CISSPO='13'

- deklarace – obsahuje:

- „dodatečné deklarace“ položek výstupu. V ní je možné doplnit výběr položek výstupu nabízený při definování nové předlohy o položky získané v doplnění, o položky typu konstanta či o položky dané výrazem sestaveným z nich a implicitně dostupných položek výstupu a o proměnné obecného výběru. Každý řádek v deklaraci definuje jeden nový výraz seznamu, má tvar (jeho jednotlivé části jsou oddělené středníky):

<identifikace>;<typ>;<návěští>;<výraz>

kde

<identifikace> je identifikátor doplněný textem "_USER_", pod kterým bude vystupovat v předlohách typu "Excel" a "Ostatní"

<typ> určuje typ výrazu. Je možné zadávat typy "N", "C", "D", "T", "L". Pro typy "N" a "C" musí být dále v závorkách uveden rozměr hodnoty výrazu

<návěští> určuje text zobrazený v seznamu při zakládání nové předlohy

<výraz> specifikuje výraz pro výpočet hodnoty

- skript před SQL dotazem – definuje se kód v jazyce FoxPro, který bude prováděn před provedením dotazu SQL. V okamžiku běhu skriptu je v proměnné _THIS odkaz na objekt řídící výstup předlohou výstupu.

- skript po SQL dotazu - je prováděn bezprostředně před výstupem, který nebude proveden v případě, že tento vrátí hodnotu .F. (FALSE).

Podrobný popis těchto atributů je uveden ve slovníku pojmů u atributu „záložka – deklarace“.

- info - výstupy lze aktivovat uživatelským rozhodnutím v rámci funkčnosti dané činnosti nebo automaticky na základě uživatelských definic v nastavení parametrů uzlu procesu při jeho ukončení nebo pomocí doplnění činnosti. Uvedení logické tiskárny v předloze výstupu umožňuje definovat pro různá uživatelsky definovaná pracoviště (každé může zahrnovat několik fyzických počítačů) různé fyzické tiskárny, na které bude výstup typu Sestava a Excel dle této předlohy směrován. Jako další tato záložka obsahuje informace o tom kdy a kým byla daná předloha vytvořena či změněna. Ke každé předloze výstupu si uživatel může uvést libovolně dlouhou poznámku.

¨ kopírovat definici předlohy – vytvoření kopie dané předlohy

¨ zrušit definici předlohy – zrušení definice předlohy

¨ výběry - uživatel si zde může nadefinovat výběr a jeho podmínku. Tento výběr mu slouží pro případ, že záložka výběr a možnosti ve vlastnostech předlohy (setřídění, doplnění, seskupování) nesplňují přesně jeho požadavky. Tímto výběrem si pak požadovaná výběrová kritéria může upřesnit. Při spuštění předlohy výstupu s tímto použitým výběrem pak IS BM provádí svůj SELECT, který vychází z činnosti (nad kterou probíhá tisk) a je upraven podle uživatelských definic ve vlastnostech předlohy (setřídění, seskupování, doplnění)

¨ export do balíčku

¨ překlad popisek – název předlohy

¨ export webovou službou

Poznámka:

Předlohy výstupů z procesů se od jiných předloh odlišují tím, že v seskupování, setřídění, doplnění nebo v deklaracích (tzn. na záložkách ve vlastnostech předlohy) je nutno specifikovat operaci. Nad kterou operací v procesu provádíme dotaz je určeno syntaxí |“název komponenty“|, oddělovač komponent je pak řetězec |||.

Např. v předloze výstupu „faktura“ ve vlastnostech předlohy na záložce „doplnění“ je rozšířená identifikace měrné jednotky zapsána takto:

¨ atributy - |OBC| SPMJN.sp58idmj

¨ select – join - |OBC|,%%%.SPMJN SPMJN

¨ výběr - |OBC| AND OBUDAL.sp24idmj=SPMJN.sp24idmj AND SPMJN.sp38id=?tool.jazyk

Tyto popsané údaje má tedy uživatel dostupné při stisku pravého tlačítka myši na názvu všech typů předloh (sestava, ostatní, excel, word).

Pro všechny typy předloh jsou k dispozici příkazy, které se mohou při tvorbě předloh použít a ty jsou popsány v Popisu jazyka generátoru sestav (vlastní pojem ve slovníku pojmů).

3.2.1 Předlohy typu „sestava“ a „ostatní“

Při definici nové předlohy uživatel stiskne příslušnou ikonu v panelu nástrojů a nadefinuje její vlastnosti (název, typ apod.). Kromě nadefinovaných vlastností je však předloha v tuto chvíli prázdná (tzn. neobsahuje dosud žádné atributy). Uživatel musí aktivovat ikonu „opravit předlohu“ (druhá v pořadí panelu nástrojů) nebo po stisku pravého tlačítka myši na názvu předlohy zvolit možnost „opravit předlohu“. Uživateli se zobrazí okno „výběr položek zahrnutých do nové předlohy“. Toto okno je v podstatě rozděleno na dvě části:

¨ v levé části je přehled všech dostupných položek výstupu

¨ pravá část je zatím prázdná. Do této části uživatel pomocí šipek přesouvá ty položky výstupu, které mají být obsaženy v dané předloze.

Podrobný popis okna „výběr položek výstupu zahrnutých do nové předlohy“ a jeho možnosti pro každou z typu předlohy je popsán ve slovníku pojmů.

Po přesunutí vhodných atributů předlohy do pravé části okna uživatel stiskne klávesu OK a na základě typu předlohy se mu otevře okno, kde definuje uspořádání položek výstupu. V případě, že uživatel přímo nedefinuje novou předlohu, ale pouze chce opravit uspořádání položek výstupu u již existující předlohy použije ikonu „opravit předlohu“ v panelu nástrojů (nebo po stisku pravého tlačítka myši na názvu předlohy možnost „opravit předlohu“). Jinými slovy, možnost „opravit předlohu“ při prvním spuštění předlohy slouží k nadefinování jednotlivých položek výstupu, při každém dalším spuštění slouží k vlastní opravě uspořádání položek výstupu. Při prvním spuštění předlohy a zvolení položek výstupu uživatel nemá k dispozici volbu tisku této předlohy (tzn. ikonka tiskárna je v panelu nástrojů nedostupná), teprve po nadefinování položek výstupu a jejich uspořádání se uživateli zpřístupní.

U předlohy typu sestava se uživateli zobrazí okno, kde mu k opravě předlohy (čili rozmístění položek výstupu tak, jak se budou uživateli zobrazovat při tisku) slouží generátor sestav FoxPro. Předlohy typu ostatní (tj. HTML) jsou tvořeny automaticky vygenerovaným pseudokódem, který má uživatel možnost opravovat (viz. Popis jazyka generátoru sestav). V činnosti nastavení BM je možno pro tyto předlohy určit adresář výstupního souboru (parametr Preferences-HTML_Output_Path), který se uplatí v případě, že v názvu souboru není uvedena absolutní adresářová cesta.

Ve verzích IS BM pod Visual FoxPro 9.0 je nutno pro práci s klasickými předlohami výstupu mít nainstalován program REPORTBUILDER.APP, který zajišťuje zobrazování formulářů pro vstup vlastností polí, pásů apod. v českém jazyce. Tento program je součástí návodu a balíčků (soubor.zip – adresář PRGS).

Při otevření klasické předlohy pro opravu nebo tisk provádí IS BM automaticky záměnu fontů 'Arial CE' , 'Courier New CE' a 'Times New Roman CE' za 'Arial-Středoevropský', 'Courier New-Středoevropský' a 'Times New Roman-Středoevropský', pokud jsou tedy v této předloze použity (tímto nastavením se zamezí tisku tzv. hyeroglifů).. Nastavením BM Printing->Potlac_FontCE=0 je možné tuto funkčnost potlačit (hlavní menu Systém – Nastavení programu BM).

3.2.2 Předlohy typu „excel“

Stejně jako u předloh typu „sestava“ nebo „word“ je nutno nejprve u nové sestavy typu „excel“ nadefinovat položky, které mají být v sestavě obsaženy. Po stisku ikony „opravit předlohu“ se uživateli nabízí okno „výběr položek zahrnutých do nové předlohy“. Přesunem položek z levé části okna do pravé si uživatel vybírá ty atributy, které mají být součástí nové definice sestavy typu „excel“. Po jejich nadefinování a stisku ok se mu nabízí okno s vlastní definicí předlohy. Po stisku ikony „oprava předlohy“ se mu stejné okno zobrazí už i u nadefinovaných předloh výstupu. V okně „výběr položek zahrnutých do nové předlohy“ se definuje i typ předlohy excel. Je možno definovat předlohy dvojího typu:

¨ deklarační – tento typ se předplňuje implicitně („excel typu1“) a definuje se pomocí Editoru deklaračních předloh výstupu do Excelu

¨ programový – aktivuje se, pokud uživatel zaškrtne atribut „excel typu2“. Je tvořen tzv. pseudokódem a upravuje se pomocí textového editoru FoxPro (viz. Popis jazyka generátoru sestav).

Pro možnost odesílání vytvořených dokumentů Excelu 2007 z IS BM e-mailem partnerům, kteří používají nižší verze Excelu byl v činnosti nastavení programu BM vytvořen parametr:

¨ Preferences -> Excel_Fileformat – slouží k určení formátu výstupního souboru Excelu vytvářeného předlohami výstupu typu Excel. Tento parametr může obsahovat jednu nebo více definic pro různé verze Excelu oddělených středníkem. Každá tato definice obsahuje číslo verze Excelu, po kterém za pomlčkou následuje číslo formátu souboru Excelu,

¨ např. Excel_Fileformat=12.0-56

Číslo verze Excelu je dostupné v aplikaci Excel v činnosti Nápověda – O aplikaci Microsoft Office Excel – tlačítko Systémové informace – Microsoft Office Excel – Souhrnné informace.

Pomocí aplikace MS Excel (je možno tak mít nastavenu přímo i předlohu výstupu) si uživatel může vytvářet kontingenční tabulky.

Editor deklaračních předloh výstupu do Excelu obsahuje tři záložky:

¨ list

¨ sloupce

¨ skript

Záložka „LIST“

¨ název listu – určuje název listu v Excelu, výraz v syntaxi FoxPro (obvykle textová konstanta) – „vlastní název“

¨ soubor – určuje výstupní soubor předlohy - uložení (tzn. cesta k souboru) je nadefinováno (Nastavení IS BM – Preferences Excel_Output_Path) a zde se uvádí přímo název souboru, např. prehled_faktur.xls nebo výraz v syntaxi FoxPro uvedený znakem '~' (vlnovka), který vrací textovou hodnotu, která určuje název výstupního souboru (tzn. že uživateli se pak do zvoleného adresáře ukládá vytvořená předloha Excel s názvem „výsledovka 01-2008, další soubor „výsledovka 02-2008“ apod.)

- není uvedena defaultní cesta pro výstupy Excelu – pak se soubor ukládá do adresáře IS BM

- je uvedena absolutní adresářová cesta

¨ šablona – určuje šablonu (přípona XLT), na základě které se založí list. Šablona je uložena v adresáři TEMPLATE v IS BM.

¨ R-Agregace – výraz v syntaxi FoxPro – řádková agregace – po sobě následující zpracovávané záznamy, pro které je hodnota vyhodnocení záznamu shodná, budou sloučeny do jednoho řádku vystupujícího do Excelu a přitom jsou načítány hodnoty ve sloupcích, ve kterých je definována hodnota

¨ třídění – před vlastním tiskem se data třídí podle zde uvedeného výrazu (v syntaxi FoxPro) - v 99% se výraz třídění rovná výrazu v R-Agregaci. Pokud chceme v R-Agregaci nebo v třídění použít ALIAS z doplnění, je nutno ho definovat v deklaraci (ve vlastnostech předlohy)

¨ podpis ř.1, ř.2 a ř.3 – při definování nové předlohy jsou tyto údaje předplněny, je možno je libovolně upravit. Jedná se o výrazy v syntaxi FoxPro, které jsou vloženy v řádcích na konec listu

¨ Textframe – výraz v syntaxi FoxPro – využíváme v případě, že údaje z podpisů nechceme mít na konci listu, ale např. nahoře v záhlaví listu (nadefinován textový rámec). Předpokládá se však, že se tento rámec vyskytuje v šabloně.

¨ 1. řádek – numerická hodnota – určuje první řádek výstupu na listu (kde se začínají tisknout data)

¨ 1. sloupec – numerická hodnota – určuje první sloupec výstupu na listu

¨ celková suma – překryvný seznam – Ano/Ne/Ano tučně/Ano kurzívou/Ano tučně+kurzívou – odpovídající hodnota způsobuje vytvoření závěrečného součtového řádku za všechny řádky listu v požadovaném formátu

¨ automatický formát – zaškrtnuté způsobí přizpůsobení šířky sloupců

¨ tisk na šířku – zaškrtnuté způsobí nastavení tisku na šířku

¨ rychlý výstup – zaškrtnuté urychluje výstup do Excelu – zde je problém s diakritikou, rychlý výstup je vhodný pouze pro sestavy, kde nejsou texty

¨ kontrola otevření – zaškrtnuté nedovolí opakovaný výstup předlohy Excel v situaci, kdy uživatel neuzavřel soubor v Excelu vytvořený posledním použitím stejné předlohy nebo jiné předlohy provádějící výstup do stejného souboru

¨ soubor neukládat – zaškrtnuté způsobí zrušení souboru na disku po jeho uzavření v Excelu. Zrušení souboru proběhne pouze v případě, že byl soubor v Excelu uzavřen před vlastním ukončením programu BM.

¨ tlačítko OK – uložení změn a ukončení formuláře

¨ tlačítko Storno – ukončení fomuláře bez uložení změn

¨ tlačítko Editor – vyvolá editor (FoxPro) se vstupem dané definice (pseudokód)

V definici předlohy výstupu Excel „typu 2“ lze použít příkaz:

.KONTROLA_OTEVŘENÍ,

který způsobí to, že předloha nedovolí opakovaný výstup do Excelu v situaci, kdy uživatel neuzavřel soubor v Excelu vytvořený posledním použitím stejné předlohy nebo jiné předlohy provádějící výstup do stejného souboru. Tento příkaz musí být uveden před příkazem .EXCEL_OTEVŘI.

Záložka „SLOUPEC“

¨ seznam sloupců – je možné je libovolně přesouvat

¨ nadpis – výraz v syntaxi FoxPro – obvykle textová konstanta (např.:„název adresáta“)

¨ název sloupce – text – je určen pro definování sloupců typu vzorec (např. pro jednotlivá čtvrtletí mohou být sloupce nazvány Q1, Q2 apod.)

¨ typ – překryvný seznam, který může nabývat hodnot:

- text – znakové a datumové položky (typu „char“)

- hodnota – numerické hodnoty (typu „numeric“)

- vzorec – výpočtové sloupce, kde se používají právě názvy sloupců (např. při názvech sloupců pro čtvrtletí Q1 až Q4, je zde pak uvedeno Q1+Q2+Q3+Q4)

¨ výraz obsahu – pro typy text nebo hodnota - výraz v syntaxi FoxPro, pro typ vzorec – text odpovídající výpočtovému výrazu v Excelu, ve kterém je mžné uvádět odkazy na sloupce pomocí názvů sloupců v hranatých závorkách

¨ formát – text – obvykle určuje formátování čísla (např. ##,###.00)

¨ šířka – numerická hodnota – nepovinný údaj – určuje pevnou šířku sloupce

¨ font – styl písma – vybírá se z překryvného seznamu

¨ ohraničení – výběr z překryvného seznamu – způsob ohraničení sloupce

¨ suma – pokud je v definici listu zaškrtnuta suma, automaticky se vysoučtuje i za sloupec. Pokud v definici listu suma není, možno ji zde zaškrtnout přímo pro daný sloupec.

¨ neopakovat – zaškrtnutí tohoto atributu určuje, že opakovaná hodnota ve sloupci nebude v následujících řádcích zobrazena

¨ zobrazit nuly – zaškrtnutí tohoto atributu zajišťuje, že i v případě, že vyhodnocením výrazu sloupce je zjištěna nulová hodnota, tak i tato se bude zobrazovat při tisku dané předlohy

¨ mezisoučet – výběr z překryvného seznamu stylů – odpovídající hodnota způsobuje vytvoření mezisoučtového řádku při změně hodnoty ve sloupci

¨ tučně – možnost tisku mezisoučtu se zvýrazněním tučně

¨ kurzívou – možnost tisku mezisoučtu kurzívou

¨ také pro 1 řádek – zaškrtnutí tohoto atributu způsobuje, že i v případě, že zdrojem pro mezisoučet je jediný řádek, bude tato hodnota zobrazena

¨ dynamický sloupec – maximální počet sloupců – numerická hodnota- je-li uvedena kladná hodnota, omezuje počet sloupců dynamického sloupce (např. hodnota 12)

¨ dynamický sloupec – S-Agregace – výraz v syntaxi FoxPro – sloupcová agregace, která se používá ve spojení s řádkovou agregací. Podle tohoto výrazu se při slučování řádků vytvářejí sloupce. Slučované řádky, pro které tento výraz nabývá shodnou hodnotu, jsou sečteny do tohoto sloupce s hodnotami vyhodnocení Výrazu obsahu, např. výraz MONTH($(OBUDAL_ob02datdod))

¨ výběr – výraz v syntaxi FoxPro – výraz musí nabývat logickou hodnotu – je-li výraz uveden a při zpracování řádku nabyde hodnotu nepravda (FALSE) – nebude hodnota do sloupce výstupního řádku vložena, resp. přičtena

¨ poznámka – libovolný text k danému sloupci

¨ tlačítko Nový – založení nového sloupce typu Text/Hodnota

¨ tlačítko Nový (vzorec) – založení nového sloupce typu Vzorec

¨ tlačítko Odstranit – zrušení sloupce

¨ tlačítko Kopie – vložení kopie aktuálního sloupce

Záložka „SCRIPT“

Při definování předlohy se skript zadává v jazyce FoxPro. Skript zpracovává různé události, které nastávají při vytváření výstupu.

Kód skriptu má k dispozici tyto proměnné:

_EVENT - identifikace události

_COLUMN_OBJECT.NAZEV_SLOUPCE - název sloupce při událostech týkajících se buňky

_COLUMN_OBJECT.VAL - hodnota vkládaná do buňky při událostech týkajících se buňky

_COLNO - číslo sloupce v Excelu při událostech týkajících se buňky

_ROWNO - číslo řádky v Excelu při událostech týkajících se buňky

Události před založením a po vytvoření listu:

BEFORE_LIST - Událost před založením listu

V této fázi vytváření výstupu může skript měnit obsah kurzoru SQL_TISK (na základě jeho obsahu následně vzniká výstup).

AFTER_LIST - Událost po vytvoření listu

V této fázi vytváření výstupu může skript upravit vzhled výsledného listu

Události týkající se buňky:

BEFORE_CELL - Událost před založením běžné buňky

Může měnit hodnotu proměnné _COLUMN_OBJECT.VAL, pokud skript vrátí logickou hodnotu .F. (FALSE), nebude žádná hodnota do buňky vložena.

AFTER_CELL - Událost po založení běžné buňky

Je určena pro formátování buňky

BEFORE_SUBTOTAL_CELL - Událost před založením buňky mezisoučtu

Pokud skript vrátí logickou hodnotu .F. (FALSE), nebude žádná hodnota do buňky vložena.

AFTER_SUBTOTAL_CELL - Událost po založením buňky mezisoučtu

Je určena pro formátování buňky

BEFORE_TOTAL_CELL - Událost před založením buňky závěrečného celkového součtu

Pokud skript vrátí logickou hodnotu .F. (FALSE), nebude žádná hodnota do buňky vložena.

AFTER_TOTAL_CELL - Událost po založení buňky závěrečného celkového součtu

Je určena pro formátování buňky

Pravý klik na textovém poli záložky 'Skript' vyvolává editor programů s předplněním vzoru skriptu, pokud byl pravý klik proveden na prázdném textovém poli.

Příklad:

#INCLUDE OLBEXC

* OLBEXC je knihovna obsahující konstanty Excelu - viz. Návody a Balíčky

DO CASE

CASE INLIST(_event,'AFTER_CELL','AFTER_SUBTOTAL_CELL','AFTER_TOTAL_CELL')

DO CASE

CASE LOWER(_column_object.nazev_sloupce)='jmeno_sloupce'

* vloží podmíněné formátování buňky - její hodnota bude zobrazena červeným textem, pokud je záporná

xlsheet.cells[_rowno,_colno].FormatConditions.Delete

xlsheet.cells[_rowno,_colno].FormatConditions.Add(xlCellValue, xlLess, "0")

xlsheet.cells[_rowno,_colno].FormatConditions(1).Font.ColorIndex = 3

ENDCASE

ENDCASE

3.2.3 Předlohy typu „word“

Stejně jako u předloh typu „sestava“ nebo „excel“ je nutno nejprve u nové sestavy typu „word“ nadefinovat položky, které mají být v sestavě obsaženy. Po stisku ikony „opravit předlohu“ se uživateli nabízí okno „výběr položek zahrnutých do nové předlohy“. Přesunem položek z levé části okna do pravé si uživatel vybírá ty atributy, které mají být součástí nové definice sestavy typu „word“. Po jejich nadefinování a stisku ok se mu nabízí okno s vlastní definicí předlohy. Po stisku ikony „oprava předlohy“ se mu stejné okno zobrazí už i u nadefinovaných předloh výstupu. Editor předloh výstupu do Wordu obsahuje 4 záložky, každou z nich si podrobněji popíšeme:

¨ hlavička

¨ skupiny

¨ elementy (elementy hlavička nebo elementy skupiny)

¨ e-mail

Program BM nekomunikuje při výstupu s předlohou výstupu typu „word“ s programem WORD přímo, ale prostřednictvím knihovny vkládaného kódu SYSDOC. Pro bezproblémovou funkčnost musí být nainstalována tato knihovna s datem aktualizace, které není starší než 1.1.2007 (existence knihovny a datum aktualizace je programem kontrolováno). Oddělená komunikace umožňuje připojení jiného textového editoru než jen WORDu.

Funkčnost výstupu předlohami typu „word“ byla testována pro verzi Word 2003, předpokládaná bezproblémová funkčnost je verze 2000 nebo vyšší.

Knihovna SYSDOC musí obsahovat definici třídy BM_CODE_SYSDOC, která obsahuje metody volané programem BM:

CREATEFILE - parametry _soubor,_template - zakládá a otevírá nový dokumentu Word s názvem _soubor, kopií ze souboru s názvem _template

DEFAULTBORDER_RESET - bez parametrů - nastavení vytváření tabulky s viditelným ohraničením

DEFAULTBORDER_NONE - bez parametrů - nastavení vytváření tabulky s neviditelným ohraničením

BOOKMARK_REPLACE_TABLE - parametry _zalozka,_radek,_hodnota1,_hodnota2,... - vloží do tabulky v záložce _záložka řádek s pořadovým číslem _radek s hodnotami sloupců _hodnota1,_hodnota2,...

BOOKMARK_TABLE_LINE_BOTTOM - parametry _zalozka,_radek,_border - vytvoří nebo zruší ohraničení tabulky v záložce _záložka pro řádek s pořadovým číslem _radek podle hodnoty _border (TRUE nebo FALSE)

BOOKMARK_REPLACE_TEXT - parametry _zalozka,_hodnota - nahradí text ve vytvářeném dokumentu označený záložkou _záložka textem _hodnota

PRINTPREVIEW - bez parametrů - vyvolá náhled aktuálně vytvářeného dokumentu

PRINTOUT - parametry _kopie,_tiskarna - vytiskne počet kopií aktuálně vytvářeného dokumentu na požadovanou tiskárnu

SAVE - bez parametrů - uloží aktuálně vytvářený dokumentu Wordu

DOCCLOSE - bez parametrů - uzavře aktuálně vytvářený dokument

A nyní se vrátíme k vlastnímu popisu Editoru definice předlohy typu „word“ a popíšeme si vlastnosti jednotlivých záložek:

Záložka „HLAVIČKA“

Na záložce „hlavička“ se definují vlastnosti týkající se výstupního souboru Wordu. Výstupní dokument Wordu je vytvářen podle template (vzoru), kterým je soubor ve formátu Word. Při výstupu předlohou výstupu je nejprve založen výstupní soubor Wordu, který je kopií tohoto template. Předpokladá se, že v template jsou obsaženy záložky, které odpovídají názvům uvedeným v předloze spolu s výrazy v jazyce FoxPro. Hodnoty zjištěné při výstupu předlouhou vyhodnocením výrazů jsou vkládány do výstupu podle záložek z template.

¨ soubor – nepovinný parametr – název výstupního souboru Wordu – výraz v jazyce FoxPro (‘soubor.doc’) nebo skript v jazyce FoxPro uvedený slovem SCRIPT.

.script

.....

..... (možná řada příkazů)

return ‘nazev.doc’ (např. nazev’+str(date())+’.doc’)

Není-li název souboru uveden, vytváří se dokument s náhodným jménem, který bude zrušen.

¨ šablona – nepovinný parametr - název souboru šablony (template) pro vytvoření souboru Wordu – výraz v jazyce FoxPro nebo skript v jazyce FoxPro uvedený slovem SCRIPT. Systémová šablona je uvozena ‘*’. Za znakem ‘*’ musí být uveden klíč dokumentu BM, který má být použit jako šablona (klíčem dokumentu je tabulka v SYSDOC). Přitom musí existovat dokument BM s daným klíčem (v činnosti „Marketing – Dokumenty - Dokument“), který musí mít nastavenu vlastnost „Duplikát“ (v této vlastnosti se uvádí název souboru na disku, kam má být ukládána kopie dokumentu. Doporučuje se ve vlastnosti „duplikát“ dokumentu BM uvádět jinou příponu souboru než DOC tak, aby se neumožnilo upravovat tento soubor na disku, např. TEMPLATE\FAKTURA.DOX).

Při výstupu předlohou program vyhledává dokument BM podle daného klíče. Podle názvu souboru uvedeného v jeho vlastnosti „duplikát“ vytváří kopii dokumentu BM do tohoto souboru v případě, že:

- tento soubor neexistuje,

- datum založení souboru je menší než poslední záznam o změně dokumentu BM zaznamenaným v jeho vlastnosti „užití dokumentu“

Vytvořená šablona mimo IS BM je pak zapsaná ve tvaru ‘template\nazev.doc’. V případě

použití skriptu je i zde nutný příkaz return jako v názvu soboru.

¨ opakovaná – zaškrtávací pole – jeho zaškrtnutí způsobí při tisku dané předlohy pro každý záznam SQL_TISK opakované vložení šablony do výstupu

¨ nová stránka – zaškrtávací pole – jeho zaškrtnutí ve spojení s polem „opakovaná“ způsobí při tisku předlohy vložení konce stránky před další vložení šablony do výstupu

¨ podmínka – nepovinný parametr – podmínka v jazyce FoxPro, kterou jsou filtrovány záznamy SQL_TISK (např. OBARTIKL_sp61id=’VYR’ – musí vracet TRUE nebo FALSE)

¨ heslo – nepovinný parametr – heslo uzamčení výstupního souboru Wordu pro provádění změn

¨ vícesouborový tisk – zaškrtávací políčko – zaškrtnuté způsobí při tisku vytváření samostatných dokumentů Word pro každý záznam SQL_TISK (tj. každý záznam v jiném souboru)

¨ úvodní skript – skript v jazyce FoxPro prováděný před zahájením výstupu – není-li skript vyplněn, potom se po pravém kliku ve vstupu tohoto atributu předplní vzor kódu pro zápis vytvořeného dokumentu jako dokumentu IS BM (pokud se předloha bude ukládat jako dokument v IS BM, je nutno mít úvodní skript nadefinován).

¨ závěrečný skript – skript v jazyce FoxPro prováděný po ukončení výstupu – není-li skript vyplněn, potom se po pravém kliku ve vstupu tohoto atributu předplní vzor kódu pro zastavení BM – čekání na uložení dokumentu

¨ poznámka – libovolná poznámka ohledně vlastností dané předlohy

¨ digitální podpis – překryvný seznam – Nikdy, Ano, Ne – určuje jak bude předplněno okno možností zobrazované před zahájením výstupu předlohy. Pokud má být dokument digitálně podepsán a uživatel ho digitálně nepodepíše, potom tento dokument nebude vytištěn ani odeslán e-mailem, bude uzavřen a zrušen.

¨ příprava e-mailu - překryvný seznam – Nikdy, Ano, Ne – určuje jak bude předplněno okno možností zobrazované před zahájením výstupu předlohy

¨ uložit jako dokument BM – překryvný seznam – Nikdy, Ano, Ne – určuje jak bude předplněno okno možností zobrazované před zahájením výstupu předlohy (nastavení Ano, resp. Ne, má smysl pouze v případě, že atribut Úvodní skript obsahuje odpovídající kód)

Vlastnosti „dig. podpis, příprava e-mailu a ukládat jako dokument BM“ se uplatňují v kombinaci s nastavením profilu spuštění předlohy, který je uveden ve vlastnostech předlohy výstupu.

Záložka „SKUPINY“

Na záložce „skupiny“ se definují skupiny elementů vkládaných do výstupu. Účelem rozdělení elementů do skupin je možnost vytváření tabulek ve Wordu definovaných na základě nezávislých SQL dotazů nebo zvýšení přehlednosti definice předlohy výstupu. Definují se tyto vlastnosti:

¨ seznam – seznam skupin definujících výstup

¨ název - název skupiny – neuplatňuje se při výstupu (zapsaný bez apostrofů)

¨ tabulka – tabulka vytvářená skupinou. Je-li uvedena (její název), potom je do výstupu vyplňována tabulka se sloupci vytvářenými na základě elementů skupiny. Předpokládá se, že v template je odpovídající tabulka Word označená značkou s názvem stejným jako je uvedený název tabulky. „Nová tabulka“- je uvedena vždy na konci předlohy. „Existující záložka“ – vytvoří prázdnou tabulku do existující záložky. „Existující tabulka“ – vytvoří již naformátovanou tabulku.

¨ od řádky – tento atribut je dostupný, pokud je vyplněn atribut „tabulka“ – určuje řádek, od kterého má být tabulka ve Wordu vyplňována

¨ Borders – zaškrtávací políčko – tento atribut je dostupný, pokud je vyplněn atribut „tabulka“ – zaškrtnutý určuje, že každý nový řádek tabulky má být ohraničen

¨ parametry – seznam výrazů v jazyce FoxPro – parametry pro SQL dotaz (uvozeno výrazem SQL_TISK. nebo _root_data.)

¨ SQL – SQL dotaz skupiny (odkazuje na parametry v syntaxi ?_p1 ..) nebo skript v jazyce FoxPro uvedený slovem SCRIPT (při použití parametrů musí obsahovat LPARAMETERS s odpovídajícím počtem formálních parametrů). Předpokládá se, že skript vytvoří kurzor s aliasem DATA

¨ skript – skript skupiny v jazyce FoxPro vyvolaný po naplnění skupiny podle definovaných elementů – může odkazovat objekty _wrd=řídící objekt Wordu, _this=řídící objekt skupiny

¨ podmínka - podmínka v jazyce FoxPro, kterou jsou filtrovány záznamy SQL_TISK nebo data SQL dotazu pro danou skupinu

¨ poznámka – libovolná poznámka ke skupině

Záložka „ELEMENTY“

Na záložce „elementy (hlavička, skupiny)“ se definují elementy aktuální skupiny ze záložky „skupina“. Jsou to tyto atributy:

¨ seznam – seznam elementů skupiny

¨ ID – identifikace elementu – v případě, že se jedná o element tabulky, představuje ID elementu výraz v syntaxi FoxPro vyplňovaný do sloupce tabulky. V případě, že se jedná o netabulkový element (na záložce „skupina“ je atribut tabulka prázdný), představuje ID elementu název záložky ze šablony.

¨ návěští – je dostupné, pokud je vyplněn atribut „tabulka“ na záložce skupiny. Je-li návěští uvedeno, název sloupce v tabulce se přepíše. Pokud uvedeno není, zůstává název sloupce stejný tak, jak je definován v šabloně.

¨ výraz – výraz v jazyce FoxPro – jeho hodnota bude vložena do tabulky, resp. do výstupního textu, náhradou za text označený v template záložkou, která odpovídá názvu ID (např. v template předlohy máme záložku „doklad“. Je vytvořena skupina záhlaví, jejíž elementem je právě záložka doklad a je uvedena jako element s ID doklad. Ve výrazu k tomuto elementu je zapsáno - SQL_TISK.SPPOHZDR_sp33cisdr+'-'+SQL_TISK.SPPOHZDR_sp33cisdpm+'-'+SQL_TISK.SPPOHZDR_sp33cisd – poté dojde k tomu, že na předloze je výraz doklad nahrazen číslem dokladu).

¨ překlad - nabízí se překryvný seznam s nabídkou jazyků nastavených v IS – pro každý výstupní jazyk předlohy je možné definovat samostatné definice vlastností „návěští“ a „výraz“.

¨ návěští – cizojazyčný překlad návěští podle zvoleného jazyka v překladu

¨ výraz – cizojazyčný výraz podle zvoleného jazyka v překladu (pokud je stejný s výše uvedeným atributem výraz, není nutné ho zde uvádět podruhé)

¨ formát – formátovací text vyhodnoceného výrazu – viz. funkce FoxPro TRANSFORM (např. u číselného výrazu je uveden formát 999 999.99)

¨ styl - formátovací text vyhodnoceného výrazu – viz. funkce FoxPro TRANSFORM (jedná se o nadefinovaný styl z Wordu)

¨ suma – zaškrtávací políčko – je dostupný, pokud je vyplněn atribut „tabulka“ skupiny – pokud je zaškrtnutý, tak se pro daný sloupec tabulky vytvoří sumární řádek

¨ poznámka – libovolná poznámka k elementu

Poznámka:

Atributy podmínky definované na záložkách 'Hlavicka' a 'Skupiny' umožňují komplexní výstup s vytvořením většího počtu tabulek v dokumentu bez využití SQL dotazu ve vlastnostech skupin (typické např. pro tisk dokladu procesu).

Např. tisk faktury - podmínky při zaškrtnutém 'Vícesouborový tisk':

Hlavička - SQL_TISK.sppohzdr_sp06idsubs='PLA'

Skupina - Záhlaví - sppohzdr_sp33cisdr+sppohzdr_sp33cisdpm+sppohzdr_sp33cisd= _root_data.sppohzdr_sp33cisdr+_root_data.sppohzdr_sp33cisdpm+_root_data.sppohzdr_sp33cisd

Skupina - Dodavatel - sppohzdr_sp06idsubs='OBC' and sppohzdr_sp33cisdr+sppohzdr_sp33cisdpm+sppohzdr_sp33cisd= _root_data.sppohzdr_sp33cisdr+_root_data.sppohzdr_sp33cisdpm+_root_data.sppohzdr_sp33cisd

Skupina - Odberatel - sppohzdr_sp06idsubs='OBC' and sppohzdr_sp33cisdr+sppohzdr_sp33cisdpm+sppohzdr_sp33cisd= _root_data.sppohzdr_sp33cisdr+_root_data.sppohzdr_sp33cisdpm+_root_data.sppohzdr_sp33cisd

Skupina - Dodací list (tabulka OBC) - sppohzdr_sp06idsubs='OBC' and sppohzdr_sp33cisdr+sppohzdr_sp33cisdpm+sppohzdr_sp33cisd= _root_data.sppohzdr_sp33cisdr+_root_data.sppohzdr_sp33cisdpm+_root_data.sppohzdr_sp33cisd

Skupina - Daňové údaje (tabulka DPH) - sppohzdr_sp06idsubs='DPH' and sppohzdr_sp33cisdr+sppohzdr_sp33cisdpm+sppohzdr_sp33cisd= _root_data.sppohzdr_sp33cisdr+_root_data.sppohzdr_sp33cisdpm+_root_data.sppohzdr_sp33cisd

Skupina - O platbě - sppohzdr_sp06idsubs='PLA' and sppohzdr_sp33cisdr+sppohzdr_sp33cisdpm+sppohzdr_sp33cisd= _root_data.sppohzdr_sp33cisdr+_root_data.sppohzdr_sp33cisdpm+_root_data.sppohzdr_sp33cisd

Ve výrazech podmínek se vyskytuje alias _ROOT_DATA, nejedná se o alias kurzoru, ale o objekt, který při zpracování obsahuje atributy s názvy a hodnotami odpovídajícím záznamu vybranému filtrem hlavičky (SQL_TISK.sppohzdr_sp06idsubs='PLA').

Výraz elementu netabulkové skupiny elementů může obsahovat volání příkazu CALCULATE jazyka FoxPro, přitom se bere v úvahu podmínka uvedená u skupiny.

Např.:

CALC SUM($(OBUDAL_dp02czazm))

Ve výrazech tisku je možné použít vlastnosti a metody řídícího objektu vytváření skupiny:

THIS.SP38ID - text - identifikace jazyka výstupu předlohy

THIS.VOLNY_TEXT - metoda s parametry _SP88ID,_DEFAULT - vyhledává volný text s identifikací _SP88ID v jazyce výstupu předlohy - není-li tento text definován vrací hodnotu _DEFAULT

Záložka „E-MAIL“

Na záložce „e-mail“ se definují parametry, které umožňují odeslat vytvořený dokument e-mailem. Definuje se:

¨ příjemce – e-mailová adresa příjemce – výraz v jazyce FoxPro nebo skript v jazyce FoxPro uvedený slovem SCRIPT (např. výraz ‘*’+sql_tisk.adadsat_ad01id vrátí jako hodnotu všechny e-mailové spojení daného adresáta) – nepovinný parametr

¨ předmět - předmět zprávy – výraz v jazyce FoxPro nebo skript v jazyce FoxPro uvedený slovem SCRIPT – povinný parametr, pokud má být e-mail odesílán (‘text’)

¨ název DOC – název, pod kterým bude dokument uveden v e-mailu jako příloha - výraz v jazyce FoxPro nebo skript v jazyce FoxPro uvedený slovem SCRIPT – nepovinný parametr

¨ další přílohy - seznam dalších příloh, které budou připojeny k e-mailu. Výraz v jazyce Foxpro nebo skript v jazyce Foxpro uvedený slovem SCRIPT – nepovinný parametr. Položky seznamu jsou odděleny středníkem ve tvaru (soubor na disku);(název přílohy), např. ‘C:\x.txt;nazev1;C:\y.txt;nazev2’ nebo ‘C:\x.txt;;C:\y.txt’. Při připojování dokumentů je ze strany uživatele vhodná určitá obezřetnost. Systém IS BM pracuje tak, že dokumenty připojené k emailu zároveň smaže z místa, kde byly dosud uloženy. Doporučujeme postupovat tak, že si uživatel vytvoří speciální adresář, kam si překopíruje dané dokumenty. Následně se tyto dokumenty připojí napevno k mailu a přitom na původním místě v PC uživatele zůstanou i nadále dostupné.

¨ text - text v e-mailu – text nebo skript v jazyce FoxPro uvedený slovem SCRIPT – nepovinný parametr. Pokud je v textu e-mailu text (ne skript), potom se na tento text aplikuje funkce TEXTMERGE jazyka FoxPro. Např.:

Dobrý den,

<<this.volny_text('UPOMIN')>>

S pozdravem <<tool.jmenot>>

¨ připravit e-mail z Wordu – e-mail bude připraven nebo odeslán přímo z Wordu – zaškrtávací políčko

¨ automaticky odeslat e-mail – e-mail bude odeslán bez možnosti úpravy uživatelem – zaškrtávací políčko

¨ důležitost - nastavení příznaku u e-mailu, důležitost malá/velká (pouze při odeslání z Wordu)

¨ uzavřít dokument pro/po odeslání e-mailu – dokument bude před nebo po odeslání e-mailu uzavřen (pro/po je podle toho, zda je dokument odesílám přímo z Word nebo ne) – zaškrtávací políčko

Poznámka pro e-mail odesílaný z Wordu:

¨ obsah vytvářeného dokumentu bude textem zprávy e-mailu

¨ text získaný podle vlastnosti Text bude vložen do Úvodu e-mailu

¨ je-li zaškrtnuto „automaticky odeslat e-mail“ a zároveň je zaškrtnuto „uzavřít dokument pro/po odeslání e-mailu“, je potom dokument po automatickém odeslání e-mailu uzavřen

Poznámka pro e-mail neodesílaný z Wordu:

¨ obsah vytvářeného dokumentu bude přílohou e-mailu

¨ text získaný podle vlastnosti Text bude textem zprávy

¨ je-li zaškrtnuto „uzavřít dokument pro/po odeslání e-mailu“ – dokument bude uzavřen a okamžitě připraven e-mail k odeslání, resp. e-mail odeslán podle nastavení v „automaticky odeslat e-mail“

¨ není-li zaškrtnuto „uzavřít dokument pro/po odeslání e-mailu“ – pak bude e-mail odesílán až po uzavření vytvářeného dokumentu uživatelem

***

_root_data.=ukazatel na aktuální pozici v SQL_TISK

RETURN

IF _this_parent.through_counter<=1 AND _this_parent.email_word

_this_parent.reopenfile(_root_data.sppohzdr_sp33cisdr+'-'+_root_data.sppohzdr_sp33cisd+'_body',_this_parent.template_value)

_this_parent.group_counter=0

ENDIF

*****

3.2.4 Vzory výstupu

Při výběru položek výstupu při definování nové předlohy výstupu si uživatel může zvolit i příslušný vzor výstupu. Pro vytváření nových předloh výstupu typu "Sestava" je možné použít předdefinované vzory. Pro použití této funkce je možné v souboru BW.INI předdefinovat až devět vzorů v sekci "Preferences" parametry "PRINT_TEMPLATEx", kde x je číslo vzoru 1 až 9. Uvádí se <název vzoru>[;<soubor vzoru>].

Není-li <soubor vzoru> uveden, předpokládá se, že vzor se nachází v podadresáři TEMPLATE adresáře programu pod jménem PTEMPx, kde x je číslo vzoru. Je-li <soubor vzoru> uveden musí být obsahovat jméno včetně přípony FRX. Je-li <soubor vzoru> vytvořen musí být spolu s ním v odpovídajícím adresáři soubor se stejným jménem s příponou FRT. Případné změny v souboru BW.INI se projeví při novém spuštění programu. Soubory vzoru je možné upravovat v okně činnosti „výstupy“ po pravém stisku tlačítka myši kdekoliv ve volném prostoru.

Soubor vzoru musí v pásu "Detail" obsahovat text s obsahem "Start_atr". Tento text určuje pozici, od které budou při vytváření nové sestavy vkládány vybrané položky a nebude do sestavy přenesen. Položka s obsahem 'LABEL' bude nahrazena názvem předlohy (nemusí být uvedena). Při vytváření nové předlohy typu "Sestava" může uživatel vybrat kromě položek zařazených do výstupu také vzor, podle kterého má být nová sestava vytvořena.

3.2.5 Profily spuštění

Jednotlivé profily se definují v činnosti „profily spuštění předloh“ v menu SYSTÉM a určuje se u nich zda má při odpovídajícím způsobu spuštění (dvojklikem na názvu předlohy nebo stiskem ikony) následovat přímo spuštění předlohy nebo rozhodnutí. Pro předlohy typu „sestava“ a „excel“ se v profilu určuje směrování výstupu (tiskárna/do souboru/prohlížení). Pro předlohy typu „sestava“ se navíc určuje, zda má při výstupu předlohy na tiskárnu předcházet dotaz na výběr tiskárny (zaškrtnuto nastavení tiskárny).

Pokud je tedy v profilu nastaveno u ikony „spuštění předlohy“, u sestavy „na tiskárnu“ a „nastavení tiskárny“ není zaškrtnuto, dochází v běhu procesu u operace, která má nadefinováno, že po jejím ukončení probíhá tisk dokladu, k automatickému tisku sestavy přímo na tiskárnu (tisková předloha je nastavena v metapředloze).

Jednotlivé profily spuštění předloh je možno nastavit jak u metapředlohy, tak přímo u předlohy výstupu. Pokud uživatel chce, aby se předloha chovala jinak po spuštění předlohy a jinak pokud se jedná o tisk dokladu (tzn. tisk předlohy v metapředloze), nastaví příslušné profily spuštění předloh jak u metapředlohy, tak přímo u vlastní předlohy.

Pro uživatele je dále k dispozici možnost definice profilu spuštění předlohy pro předlohy typu Word. Výběr zda na tiskárnu/do souboru/prohlížení je stejný jako u předloh typu sestava a Excel. Další možnosti pro předlohy typu Word je nastavení těchto atributů:

¨ Digitální podpis

¨ Příprava e-mailu

¨ Uložit jako dokument BM

Tyto nastavení velmi úzce souvisí s nastavením těchto atributů přímo v definici dané předlohy Word. Nastavení přímo v předloze přitom mají přednost před nastavením v profilu. Pokud je u těchto nastavení v předloze nastaveno NIKDY, tak ať už je v profilu nastaveno cokoliv, výsledkem je, že při spuštění okna „zahájení výstupu dle předlohy“ jsou všechny tyto tři možnost nezaškrtnuté a šedivé (tzn. není povoleno měnit).

Další nastavení u těchto atributů v předloze je možno Ano a Ne. V následující tabulce je popsáno předplnění atributů v okně „zahájení výstupu dle předlohy“ podle nastavení v předloze a profilu (platí směr zleva doprava).

Předloha | Profil | Okno „zahájení výstupu dle předlohy“
Ano | Volitelné | Povoleno měnit – zaškrtnuto
Ano | Volitelné Ano | Povoleno měnit – zaškrtnuto
Ano | Volitelné Ne | Povoleno měnit – nezaškrtnuto
Ano | Nevolitelné | Nepovoleno měnit – zaškrtnuto
Ano | Nevolitelné Ano | Nepovoleno měnit – zaškrtnuto
Ano | Nevolitelné Ne | Nepovoleno měnit – nezaškrtnuto
Ne | Volitelné | Povoleno měnit – nezaškrtnuto
Ne | Volitelné Ano | Povoleno měnit – zaškrtnuto
Ne | Volitelné Ne | Povoleno měnit – nezaškrtnuto
Ne | Nevolitelné | Nepovoleno měnit – nezaškrtnuto
Ne | Nevolitelné Ano | Nepovoleno měnit – zaškrtnuto
Ne | Nevolitelné Ne | Nepovoleno měnit – nezaškrtnuto

3.2.6 Logické tiskárny

Vlastnosti předlohy výstupu (záložka „info“) jsou doplněny o možnost určení "logické tiskárny". Logická tiskárna nepřímo určuje skutečnou fyzickou tiskárnu, na kterou má být proveden výstup. Logické tiskárny se definují v hlavním menu v činnosti SYSTÉM – Logické tiskárny spolu s dalšími souvisejícími objekty. Jsou to:

¨ logické tiskárny (1.)

¨ fyzické tiskárny (2.)

¨ pracoviště uživatelů BM (3.)

¨ počítače uživatelů BM (4.)

Logická tiskárna (1.) je propojena s pracovištěm uživatelů IS BM (3.) a v této vazbě je odkaz na fyzickou tiskárnu (3.). Pracoviště (3.) definuje množinu počítačů (4.), které mají z hlediska výstupu na tiskárnu shodné vlastnosti. Přidělení logické tiskárny předloze výstupu má význam při přímém výstupu na tiskárnu klasickou předlohou nebo předlohou typu Excel (nastavení v profilech výstupu).

Je-li logická tiskárna uvedena, potom při přímém výstupu předlohy IS BM před tiskem vyhledává podle systémové (Windows) identifikace počítače (4.) vazbou pracoviště (3.) na danou logickou tiskárnu (1.) konkrétní fyzickou tiskárnu (2.), na kterou má být proveden výstup. Je-li taková fyzická tiskárna nalezena, potom IS BM vloží do předlohy parametry nalezené tiskárny. Není-li nalezena, potom je před tiskem uživatel vyzván k výběru tiskárny, i když podle profilu měl být proveden přímý výstup bez dotazu na výstupní tiskárnu.

Fyzická tiskárna k logické tiskárně není nalezena v případě, že pro odpovídající pracoviště není definována vazba na odpovídající logickou tiskárnu nebo není-li fyzická tiskárna aktivní (vlastnost objektu fyzická tiskárna).

3.2.7 Rychlý výstup (Excel, HTML)

Doplňující vlastnost formuláře '* Rychlý výstup' umožňuje z aktuálního formuláře udělat jednorázový výstup do Excelu nebo HTML bez použití předlohy výstupu. Uživateli se po jeho aktivaci (menu Volby nebo ze základní nabídky) zobrazí okno „rychlý výstup“, které obsahuje dvě záložky. Záložku Atributy a záložku Popis pro „Definice IP“.

Na záložce Atributy si uživatel pomocí šipek umístěných ve středu okna vybere atributy, které chce mít na vytvářené sestavě k dispozici, pomocí posuvníků si může upravit jejich pořadí a v dolní části okna si poté zvolí, zda chce tuto jednorázovou sestavu vytisknout jako sesit aplikace Excel či ve formátu HTML. Tlačítko „DBF“ poskytuje uživatelům možnost exportovat jednorázovou sestavu do souboru DBF.

V případě, že by uživatel potřeboval do rychlého výstupu přidat i atribut, který není součástí aktuálního formuláře (tj. činnosti, ze které uživatel rychlý výstup aktivoval), je nutno tento atribut nejprve přidat jako další sloupec do formuláře, potom se teprve nabídne do výběru atributů do rychlého výstupu.

Další funkcí této doplňující vlastnosti je možnost založení nového uzlu v definicích informačních panelů podle vybraných atributů, které jsou použity ve formuláři (založí řádky, sloupce, elementy). Toto je možno provést po aktivaci záložky Popis pro „Definice IP“ a následném stisku tlačítka „Definice IP“ v dolní části okna. Tímto tlačítkem se aktivuje export do definice informačního panelu.

Funkce založení nového uzlu v definicích informačních panelů je povolena pouze uživatelům, kteří mají povolenu činnost 'Definice uzlů inf. panelů' a v ní povoleno vkládání.

Nově zakládaný IP-uzel je zakládán s prezentací 'BASE', která musí být definována.

3.3 Multipásová sestava

Jedná se o předlohu výstupu, která v sobě sdružuje informace z různých částí IS a umožňuje je uživateli vidět komplexně v jedné předloze výstupu. Uveďme si z praxe praktický příklad multipásové sestavy. Bude se vyskytovat v činnosti adresář a uživatel u každého adresáta bude mít k dispozici současně informace o jeho pohledávkách i jeho závazcích. Taková sestava pak bude obsahovat tři pásy – první pás s hlavičkou předlohy (tzn. základní info o adresátovi), druhý pás týkající se závazků a třetí pás týkající se pohledávek. Každý pás samozřejmě obsahuje části záhlaví, tělo a zápatí. Stejně tak může být např. v činnosti artikly skladu vytvořena sestava, která obsahuje informace o celkovém pohybu zboží (tzn. příjmy i výdaje).

V další části tohoto popisu si uvedeme konkrétní příklad vytvoření multipásové sestavy právě v činnosti adresář a bude se týkat závazků a pohledávek adresáta, tzn. u každého adresáta bude mít uživatel k dispozici informace o jeho závazcích a zároveň i o jeho pohledávkách.

obr. 2

Uživatel si běžným způsobem (popsaným v kapitole 2.2.5 a s ní souvisejícími) vytvoří hlavičku nové předlohy výstupu (název, typ, setřídění apod.) nebo v případě, že už má danou předlohu nadefinovánu si správně nadefinuje její vlastnosti.

Po stisku pravého tlačítka myši na názvu předlohy si uživatel aktivuje činnost „Vlastnosti předlohy“. Pro správné fungování multipásové předlohy výstupu je nutno nastavit atributy pod záložkami Doplnění (políčko Atributy) a Deklarace (políčko Skript po SQL dotazu) – viz. obrázky č.2 a č.3.

obr. 3

Do otevri_pluda

#INCLUDE DEFPDF

Procedure otevri_pluda

Local _sq,_filt

_filt=''

Select sql_tisk

Scan All

_filt=Iif(Empty(_filt),'',_filt+[,])+[']+adadsat_ad01id+[']

Endscan

TEXT TO _sql NOSHOW TEXTMERGE

SELECT sp33cisdr+'-'+sp33cisdpm+'-'+sp33cisd doklad,ad01id,pl02vs,pl02datpla,pl02datspl,pl02czm,pl02zalzm,oc01id,pl02crmnu FROM %%%.pluda WHERE ad01id in (<<EVL(_filt,['X'])>>) AND pl02pohzav=?_p1

ENDTEXT

If !bw_exec(.F.,_Sql,'sql_tisk_pludap',1) or !bw_exec(.F.,_Sql,'sql_tisk_pludaz',2)

Return .F.

Endif

Select sql_tisk_pludap

Index On ad01id+DTOS(pl02datpla) Tag ad01id

Select sql_tisk_pludaz

Index On ad01id+DTOS(pl02datpla) Tag ad01id

Select sql_tisk

Set Relation To adadsat_ad01id Into sql_tisk_pludaz,;

adadsat_ad01id Into sql_tisk_pludap

Replace All ma_zavazky With IIF(Eof('sql_tisk_pludaz'),0,1),;

ma_pohledavky With IIF(Eof('sql_tisk_pludap'),0,1)

Go Top

Vlastnosti předlohy uživatel uloží stiskem klávesy OK. Následně v panelu nástrojů formuláře Výstupy aktivuje činnost „Oprava předlohy“. V případě nově vytvářené předlohy si musí nejprve uživatel ve formuláři „výběr položek zahrnutých do nové předlohy“ zvolit atributy, které mají být zobrazeny na dané předloze výstupu. V případě, že se činnost „Oprava předlohy“ aktivuje z již vytvořené předlohy výstupu, zobrazí se rovnou formulář tiskové předlohy s již nadefinovanými atributy.

Uživateli se zobrazí vlastní definice jednotlivých atributů předlohy výstupu, přičemž předloha výstupu má definovány pouze pásy záhlaví stránky, tělo a zápatí stránky. Pro vytvoření multipásové sestavy však musí mít uživatel 3 pásy (resp. těla). První pás je hlavička dokladu, druhý pás jsou závazky adresáta a třetí pás jsou pohledávky adresáta (viz. obr. 4).

obr. 4

Jednotlivé pásy uživatel vytvoří pomocí nadefinování atributu Vlastnosti (Report Properties) a jeho jednotlivých záložek, který aktivuje po stisku pravého tlačítka myši ve volném prostoru předlohy výstupu (viz. obr. 5 – 7).

obr. 5

obr. 6

obr. 7

Po nadefinování jednotlivých pásů (v zobrazení předlohy výstupu těl) je nutno nastavit vlastnosti dalších atributů, tzn. vlastnosti pásů Záhlaví skupiny, vlastnosti pásů Tělo, vlastnosti součtových atributů, tzn. Pole (viz další obrázky 8 – 9). Vlastnosti se definují vždy po stisku pravé myši na daném atributu.

obr. 8

obr. 9

V tento okamžik má uživatel nadefinovanou „kostru“ předlohy výstupu, tzn. jednotlivé záhlaví, pásy a jejich vlastnosti. Pokračuje definováním jednotlivých atributů předlohy výstupu. Při vložení každého atributu je nutno si uvědomit jednak o jaký se jedná atribut a jednak o jaký se jedná pás, do kterého se vkládá (viz. obr. 10).

obr. 10

Po nadefinování jednotlivých atributů předlohy výstupu uživatel jistě bude vyžadovat i tisk určitých součtových údajů. Pak je nutno na daném součtovém atributu po stisku pravého tlačítka myši ve vlastnostech nastavit záložku Výpočty (viz. obr. 11).

obr. 11

Při definici jednotlivých atributů může uživatel využít možností, které mu poskytuje tzv. vícenásobný výběr. Jedná se o definici vlastností označených atributů najednou, tzn. nikoliv pro každý atribut definovat vlastnosti zvlášť, ale provést pomocí myši výběr (např. všech atributů v pásu tělo 3) a označit si příslušné atributy a po stisku pravého tlačítka a vyvolání Vlastností nastavit např. tyto vlastnosti (viz. obr. 12).

Na následujícím obrázku (obr. 13) má uživatel k dispozici pohled, jak vypadá konečná definice této multipásové sestavy. Jednotlivé obrázky v tomto popisu se týkají multipásové sestavy nad činností Adresář, kde uživatel chce mít k dispozici zároveň závazky i pohledávky adresáta. Pro uživatele je to pouze obecný návod jak postupovat při vytváření multipásových sestav, který je pro názornost popsán na konkrétním případu. Pro vytváření multipásové sestavy v jiné činnosti je samozřejmě nutné definice uzpůsobit konkrétní činnosti. To jistě vyžaduje jistou uživatelskou zdatnost, znalost atributů, výrazů FoxPro atd.[12]

obr. 12

obr. 13

3.4 Uživatelské triggery

Trigger je program uložený v databázi, který je spojený s některou tabulkou databáze. Je vyvoláván při změnách dané tabulky (lze zvolit zda v okamžiku vkládání, opravy či rušení záznamu). Nemá žádné parametry a je aktivován určitou změnou dat.

Jak již vyplývá z názvu činnosti, slouží tato činnost, uložená v hlavním menu v činnosti Systém, k tvorbě uživatelem definovaných triggerů. Ty mohou sloužit k různým uživatelem definovaným účelům:

¨ automatizace v aktualizaci dat (tzn. jedna uživatelská změna vyvolá řadu změn v tabulkách a záznamech) - např. uživatel má pohledávky a k nim vytvořené volné karty. Pak může být trigger napsán tak, že při změně stavu pohledávky se tato změna zapíše automaticky i do volné karty, která se k dané pohledávce vztahuje.

¨ signalizace změn dat – např. každá změna adresáře může vyvolat automatický zápis o změně a zapsat ho na vývěsku apod.

¨ autorizace změn dat – u každé změny je pak možno dohledat, kdo a kdy danou změnu provedl

Upozornění: Špatně zkonstruovaným triggerem si uživatel může způsobit neodstranitelné chyby v datech, proto je třeba tuto činnost používat s rozvahou a v každém případě by uživatel měl mít alespoň min. povědomí o programování a datovém modelu IS BM. Za nejschůdnější řešení lze v případě potřeby vytvoření triggeru považovat, aby se uživatel obrátil na svého implementátora.

V definici triggeru se uvádí:

¨ tabulka, ke které přísluší

¨ název volné karty, která se k tabulce vztahuje (pouze pokud se jedná o trigger volné karty)

¨ vlastní název triggeru

¨ pořadí triggeru (toto je ve skutečném triggeru v databázi zvětšeno o 50 tak, aby nedocházelo ke konfliktu s triggery BM)

¨ timming spuštění triggeru "before" (před) nebo "after" (po) událostí, která mění data tabulky (čili zda se data změní před zapsáním událostí či až po jejich zapsání)

¨ způsob, jakým má trigger aktualizovat záznamy v dané tabulce - "insert" (vkládání), "update" (oprava) nebo "delete" (rušení)

¨ kód triggeru – definice příkazu pomocí programovacího jazyka Sybase SQL Anywhere

Je-li uživatelský trigger definován, je třeba aktivovat příslušnou činnost v menu Volby „generovat triggery tabulky“ (žádný uživatel v případě generování nesmí být přítomný, tzn. „držet“ danou tabulku. Z praxe je ověřeno, že při generování triggerů je vhodné, pokud se všichni přihlášení uživatelé z IS BM odhlásí). V případě definičních dat lze uživatelský trigger vstoupit pomocí importu balíčku.

Příklad:

Typickým příkladem použití uživatelského triggeru je trigger tabulky "OBARTIKL" (obchodovatelný artikl), který při opravě technicko-věcného selektoru aktualizuje selektor odpovídajícího skladovaného artiklu (tabulka "MTARTIKL"). Kód pro událost "AFTER","UPDATE" může mít obsah:

if new_name.sp20idzak<>old_name.sp20idzak then

update %%%.mtartikl set sp20idzak=new_name.sp20idzak where

mtartikl.sp60id=new_name.sp60id and mtartikl.sp61id=new_name.sp61id and

sp20idzak<>new_name.sp20idzak;

end if;

Pozn.1: v kódu je při generování text %%% nahrazen identifikací uživatele (v daném případě BM_SERVIS)

Pozn.2: pro použití je třeba vytvořit obdobný trigger pro tabulku "MTARTIKL"

3.5 Doplňující vlastnosti formuláře

Formulářem je v tomto okamžiku pro uživatele každá činnost, která se uživateli prezentuje svým oknem. Doplňující vlastnosti formuláře uživatel definuje v menu Obecné. Doplňující vlastnosti formuláře je funkce, která umožňují uživateli přidat k danému formuláři (činnosti) uživatelský program (v kódu FoxPro), spuštění předlohy výstupu (činnosti, doklad, doklad hlavního procesu) nebo aktivaci volné karty (činnosti, procesu, operace). Doplň. vlastnost formuláře může být aktivována automaticky při spuštění dané činnosti nebo z menu Volby – způsob se definuje uživatelsky v její definici. Na základě druhu doplň. vlast. form. je řízeno přístupové právo jednotlivých uživatelů k dané funkci doplň. vlastnosti formuláře. Uplatnění doplň. vlastnosti formuláře událostí lze omezit jen na ty události, které jsou v daném uzlu procesu (druh procesu a druh operace, pořadí operace) ve stavu, který je uveden v definici doplň. vlastnosti formuláře (v praxi se obvykle využívá funkce doplň. vlastnosti formuláře např. na neukončené operace). V případě definice doplň. vlastností formuláře formou uživatelského programu (kód) lze k jeho sestavení použít knihovny vkládaného kódu. Tento kód je možno napsat tak, že ve zpracované činnosti může reagovat na tyto programové události: zahájení editace (po stisku F3), ukončení editace (jakýmkoliv způsobem – disketou nebo ESC ), ...

Doplňující vlastnosti formuláře tedy umožňují přidat k činnostem vlastní položky menu nebo automaticky vyvolat (při otevření formuláře) spuštění předlohy výstupu, volné karty , kódu Foxpro nebo umožňují přidat do mřížky formuláře nový sloupec. Definování doplň. vlastností formuláře patří k „nejodbornějším“ prvkům IS BM, některé provedené změny mohou vyvolat nevratné změny nebo dokonce ztrátu dat, tudíž vyžaduje dobrou znalost IS.

Při definování doplňujících vlastností formuláře uživatel zadává:

¨ činnost – předplní se automaticky číslo tabulky činnosti

¨ vlastnost – identifikace a název vlastnosti

¨ druh – právy k druhu je možné omezit automatické vyvolání druhu vlastnosti pro vybrané uživatele. Pro to, aby se akce vlastnosti provedla, musí mít aktuální uživatel k jejímu druhu právo alespoň "čtení". Uživatel s právem "zápis" může vytvářet doplňující vlastnosti daného druhu.

¨ kategorie – identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu

¨ menu – zařadit do menu - ano/ne

¨ řez písma položky menu – možnosti normální/kurzíva/tučné/tučná kurzíva – označení dané položky menu zvoleným stylem písma (při zvolení např. tučná kurzíva dojde v menu Volby k odlišení běžných činností od činností vyvolaných doplňující vlastností formuláře).

¨ klávesa - při doplnění menu formuláře je možné určit CTRL - klávesu pro vyvolání odpovídající funkce. Je možné zadat písmeno nebo funkční klávesu F1 až F12. Pro vytváření uživatelských nabídek (toolbarů) je vhodné uvádět pro ekvivalentní doplňující vlastnosti různých formulářů stejnou identifikaci.

¨ stat. podm. – statická podmínka zařazení do menu - vyhodnocuje se v okamžiku vytváření menu. Např.:

- v událostech vymáhání lze pomocí F6 spustit události plateb za statické podmínky, že charakter operace je běžná -thisform.komp_stav AND thisform._o_kompo_.sp07charak=1

- v uživatelích programu je viditelná činnost inicializace hesla jen pokud se jedná o uživatele správce - tool.spravce()

- dotaz na existenci souboru – FILE (‘nazev souboru’)

¨ dyn. podm. – dynamická podmínka zařazení do menu – vyhodnocuje se až v okamžiku, kdy je menu vytvořené. Např.:

- činnost Karta pracovníka může přes Volby spustit činnost Další informace. Dynamická podmínka ale říká, že to lze spustit jen pokud je kurzor umístěn na záložce Pracovní poměry – thisform._PF_activepage=thisform._PF_.p4.pageorder

- v činnosti Adresář lze spustit činnost Adresy, jen pokud stojím na příslušné záložce – thisform._PF_.activepage=thisform._PF_.p4.pageorder

- v činnosti Adresář lze spustit činnost předkontace adresáta jen pokud je kurzor umístěn na určitém adresátovi - !EOF(‘$$$’)

- v činnosti Adresář lze spustit cenové skupiny adresáta jen pokud je kurzor umístěn na určitém adresátovi - !EOF(‘$$$’)

¨ automaticky – ano/ne – akci specifikovanou doplňující vlastností formuláře je možné vyvolat automaticky při spuštění formuláře. Pro formuláře událostí komponent je možné omezit vyvolání této akce na vybrané operace.

¨ pořadí – pořadí provádění akce doplňující vlastnosti činnosti

¨ typ – může nabývat hodnot – spustit předlohu výstupu, spustit kód, spustit volnou kartu, doplnit mřížku formuláře, spustit kompilovaný kód.

- Pokud vlastnost určuje akci vyvolání metapředlohy výstupu je možné určit pro formuláře událostí komponent vyvolání metapředlohy výstupu dokladu procesu nebo dokladu nadřízeného procesu. V takovém případě není určení metapředlohy výstupu (MPV) povinné, vyvolá se metapředloha uvedená u odpovídajícího druhu procesu.

- Objekty vytvářené skriptem vyvolaným příkazem Foxpro EXECSCRIPT (typ spustit kód) po ukončení skriptu zanikají.

- Pokud vlastnost určuje akci vyvolání volné karty je možné určit pro formuláře událostí komponent vyvolání volné karty procesu, operace nebo volné karty adresáta. V takovém případě není určení volné karty povinné, vyvolá se volná karta odpovídajícího druhu operace resp. procesu (nebo adresáta – zde program nemůže provádět kontrolu, zda je možné pro daný formulář volnou kartu adresáta použít, tzn. je-li adresát obsažen na první záložce formuláře – musí ohlídat uživatel, jinak užití takto nadefinované DVF bude generovat chybu).

- Pokud vlastnost určuje akci doplnění mřížky formuláře je možné určit pro formuláře událostí komponent vyvolání doplnění mřížky.

- Kódem externích příkazů s typem „spustit kompilovaný kód“ je možné vytvářet objekty, které po provedení kódu nezanikají. Kód tohoto typu není prováděn příkazem Foxpro EXECSCRIPT, ale je zkompilován a následně spuštěn zkompilovaný program (soubor s příponou FXP). Takto je např. možno vytvořit formulář, který zůstane na obrazovce až do ukončení programu a je možné se přitom přepínat mezi ním a jinými běžnými formuláři BM. Další možné využití tohoto typu DVF je v souvislosti s připojováním metod k objektům formuláře (BINDEVENT) bez použití objektu BWSCRIPT.

Příklad:

* Výsledkem volání kódu je zobrazení formuláře na obrazovce

* Ale pouze pro typ externího příkazu 'Script Foxpro - kompilovaný' tento formulář bezprostředně po provedení kódu nezanikne

LOCAL _o

_o=CREATEOBJECT('xform')

_o.show

* metoda objektu TOOL - ADD_USER_WINDOW - uchovává odkaz na objekt _O v rámci atributů objektu TOOL

* jinak by objekt _O zanikl po ukončení kódu v každém případě

tool.add_user_window(_o)

define class xform as form

enddefine

Na záložce "omezení pro operace" se uvádí seznam operací v procesech, při jejichž spuštění se má požadovaná akce vykonat. Uvedení druhu procesu "-" znamená, že se akce vyvolá pro daný druh operace v libovolném druhu procesu. Kromě toho je možné určit podmínku, v jakém stavu "připravena","zahájena" nebo "ukončena" se daná operace musí nacházet.

Příklady praktického užití:

Doplňující vlastnost formuláře může definovat vyvolání programového kódu Foxpro. V textovém poli "kód" je možné zadat plnohodnotný program v jazyce Foxpro, který je možné snáze upravovat v editoru po stisku klávesy F5. Do kódu je automaticky přidán prvý řádek:

LPARAMETERS _this,

kterým je mu předán objekt formuláře, ze kterého byl vyvolán.

Do kódu je možné vkládat opakovaně použitelné části použitím klausule:

#INCLUDE <identifikace vkládaného kódu>.

Formulář pro vstup vkládaných kódů se vyvolává z formuláře doplňujících vlastností formuláře klávesou F6. Přístup k položkám vkládaných kódů je také chráněn jejich druhem a jejich kód je také možné upravovat v editoru po klávese F5. Ve vkládaném kódu může být uvedena klausule #INCLUDE, která do něho zařadí jiný vkládaný kód. Bylo vytvořeno i řešení podporující vytváření výstupu do HTML, které plně využívá výhod objektového programování. Sestává ze dvou základních "vkládaných kódů" (dále knihoven).

Knihovna SYSHTM definuje třídu, která slouží k vytváření obsahu HTML souboru.

Knihovna SYSPRC definuje třídu, pro usnadnění práce s operací v procesu.

To, jakým způsobem je možné jednoduše vytvářet přehledy zobrazované ve webovém prohlížeči je patrné v následujícím příkladu, který vytvoří přehled událostí obchodu v nadřízeném procesu k události.

LOCAL _o,_o2

* založíme objekt pro orientaci v procesech podle definice třídy v knihovně SYSPRC (viz.#INCLUDE na konci)

_o2=CREATEOBJECT('bm_code_sysprc',_this)

* založíme objekt pro vytváření souboru HTML podle definice třídy v knihovně SYSHTM (viz.#INCLUDE na konci)

_o=CREATEOBJECT('bm_code_syshtm')

* výstupní sestava bude mít titul 'Moje sestava'

_o.settitle('Moje sestava')

* vytvoříme hlavičku souboru HTML

_o.genheader

* do textu vložíme nadpis 'QUICK INFO'

_o.gentag_h2('QUICK INFO',.T.)

* budeme vytvoříme tabulku - tu je třeba inicializovat

_o.table_reset

* připravíme data pro naplnění tabulky

* metoda opendata vrací TRUE, když úspěšný dotaz vrátil alespoň jeden řádek

* všimněte si použití objektu _O2 při sestavování dotazu

IF _o.opendata([select obudal.ad01id,adadsat.ad01adsat,obudal.ob02dat,obudal.ob02datdod,]+;

[obudal.sp61id,obudal.sp60id,spartikn.sp62artikl,obudal.ob02mn,]+;

[obudal.ob02cj01c,obudal.dp02czazm,obudal.dp02cdpzm,obudal.dp02czarm,obudal.dp02cdprm,]+;

[obudal.oc01id,obudal.dp02sazba]+;

[ from %%%.obudal,%%%.spartikn,%%%.adadsat where ]+;

_o2.filter('OBUDAL',.T.)+;

[ and spartikn.sp61id=obudal.sp61id]+;

[ and spartikn.sp60id=obudal.sp60id]+;

[ and spartikn.sp38id=?tool.jazyk]+;

[ and adadsat.ad01id=obudal.ad01id])

* do prvého sloupce tabulky bude vkládán obsah podle výrazu "sp61id+'-'+sp60id" a bude mít nadpis "Artikl"

_o.table_addcol([sp61id+'-'+sp60id],'Artikl')

* podobně

_o.table_addcol([sp62artikl],'Název artiklu')

* podobně + navíc je určeno, že číslo má mít formát 20,2

_o.table_addcol([ob02mn],'Množství',20,2)

_o.table_addcol([ob02cj01c],'CJ',20,2)

* sloupce s cizí měnou má smysl vytvářet, pokud jsme neobchodovali v korunách

IF _o.getvalue([oc01id])<>'CZK'

_o.table_addcol([dp02czazm+dp02cdpzm],'Cena ZM',20,2)

_o.table_addcol([oc01id],'Měna')

ENDIF

* pro tento sloupec budeme chtít celkový součet

_o.table_addcol([dp02czarm],'Základ DPH',20,2,.t.)

_o.table_addcol([dp02sazba],'%')

_o.table_addcol([dp02cdprm],'DPH',20,2)

_o.table_addcol([dp02czarm+dp02cdprm],'Cena Kč',20,2,.t.)

* gentableheader - vytváří hlavičku tabulky s nadpisy sloupců v tomto případě navíc s jedním hlavičkovým řádkem

_o.gentableheader(" 'Obchod - '+dtoc(ob02dat)+' ['+ad01id+'] - '+alltrim(ad01adsat) ")

* gentable - vygeneruje tabulku s daty dotazu metody OPENDATA na základě definic sloupců (TABLE_ADDCOL)

_o.gentable

* gentablefooter - vygeneruje koncovou značku tabulky

_o.gentablefooter

ENDIF

* genfooter - vygeneruje koncové značky HTML dokumentu

_o.genfooter

* show - zobrazí dokument v interním HTML prohlížeči BM

* metoda LABEL objektu _O2 vrátí identifikaci procesu, kterou metoda SHOW zobrazí v nadpisu okna

_o.show(_o2.label(.T.))

* klausule #INCLUDE připojí knihovnu SYSHTM, která obsahuje deklaraci třídy objektu "bm_code_syshtm"

* knihovnu SYSPRC, která obsahuje deklaraci třídy objektu "bm_code_sysprc" není třeba připojovat (tu si připojuje SYSHTM)

#INCLUDE syshtm

Protože objekt "bm_code_syshtm" knihovny SYSHTM je zdrojem pro nezávislá řešení, umožňují principy objektového programování na jeho základě vytvořit vlastní objekt (např. "bm_code_usrhtm" v knihovně USRHTM), který překryje "bm_code_syshtm" v metodách a vlastnostech dotýkajících se formátování (vzhledu) výstupního HTML dokumentu. Jednotlivé doplň. vlastnosti formuláře IS BM při zapsání do kódu umožňují zpracování skriptů. Skript je programový kód vyvolaný na základě programové události.

Událost formuláře (viz. Pojem - Zpracování skriptů) GRID_HEADER_CLIK umožňuje implementačně definovat třídění sloupce po kliku na návěští sloupce v mřížce formuláře (např. v mřížce je identifikace artiklu a datum - po kliku na sloupec artiklu se požaduje setřídění artikl+datum).

Událost GRID_HEADER_CLIK vzniká při kliku na návěští sloupce mřížky ve formuláři a vyvolává skript připojený k formuláři doplňující vlastností formuláře voláním metody ADDSCRIPT.

Ve skriptu je možné odkazovat se na proměnné:

_objscript.recordsource - alias cursoru mřížky

_objscript.attribute - název atributu zobrazeného ve sloupci (včetně aliasu), na který uživatel kliknul

Kód skriptu by měl vrátit výraz v syntaxi jazyka Foxpro pro příkaz INDEX ON.

Příklad doplňující vlastnosti formuláře připojující skript pro událost GRID_HEADER_CLIK:

<pre>

LOCAL _kod

TEXT TO _kod NOSHOW

IF _objscript.recordsource='VRUDOPER' AND TYPE(_objscript.attribute)='C'

RETURN [UPPER(]+_objscript.attribute+[)+DTOS(NVL(vr02datum,{}))+LEFT(ad01adsat,50)]

ELSE

RETURN _objscript.attribute

ENDIF

ENDTEXT

_this.makroprikaz("this.addscript(CREATEOBJECT([bwscript],[GRID_HEADER_CLIK],[GRID_HEADER_CLIK],[],_p1))",_kod)

</pre>

Tato vlastnost pro uživatele představuje jakýsi nadstandard nad spuštěnou činností, např. pokud je nastaveno, že po ukončení operace se vždy aktivuje volná karta operace, je možno pomocí doplňujících vlastností formuláře pro vybrané uživatele nadefinovat, aby se jim tato volná karta neaktivovala, protože jejich práce se netýká. Další možností použití doplňující vlastnosti formuláře je nadefinovaný uživatelský program Quick info, např. nad událostmi plateb, který mu umožňuje získat veškeré informace o platbách v jednom okamžiku.

Jednotlivé formuláře činností IS BM nově umožňují zpracování skriptů. Jednotlivé definice nad formuláři (činnostmi) se pak aktivují z menu nebo automaticky (tzn. spuštění při startu formuláře).

Upozornění: Definice jednotlivých doplňujících vlastností formuláře není rozhodně vůbec triviální záležitostí a vyžaduje od uživatele nejen dobrou znalost datového modelu, ale i značné znalosti programovacího jazyka FoxPro. Podrobný popis definice doplňujících vlastností formuláře je uveden ve slovníku pojmů. Uživatel, který nemá potřebné znalosti, by měl jednotlivé definice vlastností formuláře používat s rozvahou, některé operace mohou nevratně způsobit ztrátu nebo zničení dat.

3.6 Funkce „automatické dokončování“

V informačním systému BM je možné nastavit funkci automatického dokončování při vstupu údajů formuláře podobně jako je možné pro Internet Explorer viz. http://support.microsoft.com/?kbid=217148.

Název „Funkce automatického dokončování“ vznikl podle českého překladu obdobného chování Internet Exploreru z anglického pojmu 'Automatic completion functionality', který překládá slovo 'completion' jako 'dokončování'. Podle slovníku slovo 'completion' znamená také 'vyplnění'.

Funkce automatického dokončování se nastavuje zvlášť pro každé pole formuláře, ve kterém je vstupován textový údaj. Některé funkce mohou být nastaveny shodně pro všechny uživatele, některé si nastaví každý uživatel podle svých potřeb. Aktivace této funkce se provádí nastavením definic činnosti parametry polí formulářů vyvolané po stisku pravého tlačítka myši, při kterém je zároveň podržena klávesa Ctrl (Ctrl+pravý klik myši).

Při aktivaci funkce automatického dokončování na vybraném atributu klávesou Ctrl+Home je pro dané pole automaticky vytvořen záznam pro daného uživatele s nastavením „naplnění seznamu návrhů“ na hodnotu Vstupem se systémovým dotazem „Aktivovat funkci automatického dokončování pro pole „....“? Ano/Ne“.

V praxi se postupuje následovně. Uživatel si zvolí formulář a atribut, kde chce tuto funkci automatického dokončování využít (např. ve výběrové záložce činnosti adresář na atributu název adresáta, v událostech obchodu na druhu artiklu, umístění apod.). Pak po stisku klávesy Ctrl a pravého tlačítka myši vyvolá formulář činnosti „parametry polí formulářů“.

Nejprve se mu zobrazí výběrová záložka, kde má předplněn název tabulky a identifikaci atributu, kde chce funkci automatického dokončování realizovat. Po potvrzení výběru pak uživatel definuje jednotlivé atributy.

ZÁLOŽKA „PARAMETRY“ (slouží k definování „funkce automatického dokončování“)

¨ činnost - identifikace činnosti (formuláře) – předplní se

¨ pole - identifikace pole formuláře – předplní se

¨ uživatel - identifikace uživatele systému – předplní se (je předplněno jménem přihlášeného uživatele, pokud je přihlášen správce, předplní se jméno SYSTÉM)

¨ funkce automatického dokončování - překryvný seznam – výběr Ano/Ne

¨ naplnění seznamu návrhů - překryvný seznam (viz. popis dále) - výběr

- Vstupem

- SQL dotazem

- Výčtem

- Skriptem

¨ SQL/Výčet/Skript – tento atribut slouží pro zapsání SQL dotazu pro atribut „naplnění seznamu návrhů“, kde je vybrána volba SQL dotazem, pro seznam hodnot atributu „naplnění seznamu návrhů“, kde je vybrána volba Výčtem nebo pro skript v jazyce Foxpro, který vytvoří seznam hodnot „naplnění seznamu návrhů“=skriptem

¨ počet řádků – v tomto atributu lze nastavit počet řádků zobrazovaných v seznamu návrhů funkce automatického dokončování. Udává se zde maximální počet zobrazovaných řádků, při užití funkce automatického dokončování může být počet řádků zobrazených v seznamu návrhů menší v závislosti na výšce okna aktuálního formuláře.

¨ výraz prefixu – text – výraz v jazyce Foxpro

¨ uplatní se znaků – uvádí se zde počet znaků vstupovaného pole, které se uplatní jako výběr pro naplnění seznamu návrhů (uvedená hodnota -1=všechny znaky)

¨ přenášet hodnotu – překryvný seznam Ano/Ne – při nastavení volby Ano se hodnota pole automaticky přenáší do vstupovaného pole při listování v aktivním seznamu návrhů (aktivní seznam návrhů si uživatel vyvolá např. po užití klávesy Ctrl+ ŠIPKA DOLŮ)

¨ poznámka - text - libovolný text

Takto definované parametry jsou specifické pro dané pole daného formuláře pro aktuálně přihlášeného uživatele systému. Správce systému má možnost aktivovat funkci automatického dokončování pro dané pole daného formuláře pro všechny uživatele systému založením parametrů pro uživatele SYSTÉM. Pokud jsou pro dané pole definovány parametry polí formulářů pro uživatele SYSTÉM a zároveň i pro konkrétního uživatele, potom se uplatňuje nastavení konkrétního uživatele (tj. aktuálně přihlášeného).

Při vstupu textového pole formuláře, pro které je aktivní funkce automatického dokončování, zobrazuje IS BM seznam návrhů na dokončení v překryvném seznamu. Pokud určitý návrh v seznamu odpovídá požadovaným kritériím pro dané pole, dvojklikněte na něj nebo jej vyberte pomocí klávesy ŠIPKA DOLŮ a potom stiskněte klávesu ENTER.

Přechod do seznamu návrhů z klávesnice s možností vybírat si přímo stiskem počátečních písmen textu jeho položek poskytuje uživateli kombinace kláves CTRL+ ŠIPKA DOLŮ. Uživatel se po její aktivaci přemístí kurzorem do seznamu návrhů, ve kterém je umožněn pohyb přímo stiskem počátečních písmen textu jednotlivých návrhů. Klávesu CTRL+ ŠIPKA DOLŮ je možno použít i v případě, že seznám návrhů není právě zobrazen.

Je-li potřeba ze seznamu návrhů na dokončení vymazat jednotlivé položky, je nutno umístit kurzor na požadovanou položku v seznamu návrhů a stisknout klávesu DELETE (při nastavení parametrů „naplnění seznamu návrhů – Vstupem“ a „přidávat do seznamu návrhů – Ano“). Seznam návrhů funkce automatického dokončování se automaticky zobrazí při vstupu jakéhokoliv znaku v daném poli.

Pokud má uživatel již seznam návrhů funkce automatického dokončování pro svoji potřebu naplněn, nastaví pak u parametru polí formulářů na atributu „přidávat do seznamu návrhů – Ne“. Pak mu stávající seznam návrhů zůstane zachován a další návrhy se již nebudou do seznamu přidávat.

Nechce-li uživatel na daném atributu již používat funkci automatického dokončování, nastaví na daném parametru NE u atributu funkce automatického dokončování.

Pokud je funkce automatického dokončování nastavena pro pole vyhledávací záložky formuláře a výběrem položky ze seznamu návrhů je vrácen text delší než je jeho kapacita, potom je pole automaticky přepnuto do stavu rozšířeného vyhledávání (klávesa CTRL+SPACE na výběrové záložce formuláře na znakové položce vyvolává okno pro vstup delšího textu, tím je umožněno zadat delší text pro formátovaný pro výběr v SQL dotazu v klauzuli LIKE).

Podle nastavení parametru pole formuláře „naplnění seznamu návrhů“ vytváří IS BM tento seznam návrhů:

¨ nastavení Vstupem - funkce automatického dokončování uchovává hodnoty zadávané v poli formuláře, jakou je například položka, kterou jste právě zadali po stisku klávesy Ctrl Home. V budoucnu pak může kontrolovat předchozí zadané položky a při zadávání nových položek zobrazovat návrhy.

Seznam návrhů se vytváří tímto způsobem zvlášť pro každého uživatele BM, např. na výběrové záložce činnosti adresář se v názvu adresáta mohou zobrazovat často hledané názvy adresátů v případě, že po zapsání názvu adresáta do výběrového pole uživatel stiskne klávesu Ctrl Home. Pokud tuto klávesu nestiskne, název tohoto adresáta se automaticky předplňovat nebude.

¨ nastavení SQL dotazem - seznam návrhů je naplněn na základě SQL dotazu, např. formulář Adresář může mít pro pole obchodního selektoru na výběrové záložce nastaven parametr SQL/Výčet:

SELECT SP10IDZAK FROM %%%.SPSEOB ORDER BY SP10IDZAK

¨ nastavení Výčtem - seznam návrhů je naplněn na základě textu uvedeného ve výčtu, např.

formulář Procesy může mít pro pole roku identifikace procesu na výběrové záložce nastaven parametr SQL/Výčet:

2001

2002

2003

2004

Při definování obsahu parametru SQL/Výčet je možné používat makra (viz. ukázky dále v textu). Definice maker se vyvolá po zapsání atributů parametrů polí formulářů po stisku klávesy F5 nebo aktivací činnosti z menu Volby. Je vhodné zejména u nastavování návrhů pro atributy, které se opakují v různých formulářích IS BM, aby na každém z nich nemusel uživatel zvlášť definovat parametry polí formulářů.

¨ nastavení Skriptem – seznam návrhů je naplněn vyvoláním kódu v jazyce Foxpro, např. formulář „Procesy“ může mít pro pole roku identifikace procesu na výběrové záložce nastaven parametr SQL/Výčet/Skript:

<pre>

LOCAL _i,_rt

_rt=''

FOR _i=2000 TO YEAR(DATE())

_rt=_rt+TRANS(_i)+CHR(13)

ENDFOR

RETURN _rt

</pre>

Naplnění seznamu návrhů tvořených SQL dotazem nebo Výčtem může být tvořeno jedním nebo dvěma sloupci,

¨ např. formulář Adresář může mít pro pole obchodního selektoru na výběrové záložce nastaven parametr SQL/Výčet:

SELECT SP10TEXT,SP10IDZAK FROM %%%.SPSEOB ORDER BY SP10TEXT,

což v praxi znamená, že uživatel do pole obchodního selektoru zapisuje jeho identifikaci a přitom se mu v seznamu návrhů zobrazují názvy obchodních selektorů.

¨ např. formulář Procesy může mít pro pole roku identifikace procesu na výběrové záložce nastaven parametr SQL/Výčet:

Rok 01|2001

Rok 02|2002

Rok 03|2003

Rok 04|2004

V tom případě jsou v seznamu návrhů zobrazovány texty obsažené v prvním sloupci a položky seznamu návrhů vybírány a vraceny podle druhého sloupce, převedeno do praxe .. uživatel si vybírá z návrhů Rok 01, Rok 02 apod., ale po výběru tohoto návrhu je do atributu předplněno 2001, 2002.

Výraz prefixu se obvykle používá ve spojení s nastavením „naplnění seznamu návrhů“ hodnotou SQL dotazem.

Výraz prefixu je vyhodnocován v okamžiku vytváření seznamu návrhů objektem daného pole formuláře, jeho hodnota filtruje položky vložené do seznamu návrhů. Typicky se tato možnost používá při implementaci funkce automatického dokončování pro pole formulářů, ve kterých se vstupuje artikl, např. obchodovatelný artikl:

Parametr SQL dotaz

SELECT SP62ARTIKL,OBARTIKL.SP61ID+OBARTIKL.SP60ID FROM %%%.OBARTIKL,%%%.SPARTIKN

WHERE SPARTIKN.SP61ID=OBARTIKL.SP61ID AND SPARTIKN.SP60ID=OBARTIKL.SP60ID AND

SPARTIKN.SP38ID=?TOOL.JAZYK AND SP00AKTUAL=1 ORDER BY SP62ARTIKL

Parametr Výraz prefixu

THIS.PARENT.SP61ID.VALUE

Podle SQL dotazu je ve druhý sloupec seznamu návrhů naplněn výrazem OBARTIKL.SP61ID+OBARTIKL.SP60ID.

Při vytváření seznamu návrhů je polem, ve kterém je vstupována identifikace artiklu, vyhodnocen výraz THIS.PARENT.SP61ID.VALUE

a tím je zjištěna hodnota identifikace druhu artiklu vstoupená uživatelem na stejné stránce fomuláře. Do seznamu návrhů jsou potom naplněny artikly daného druhu.

SQL dotaz je obvykle vyhodnocován pouze jednou, při prvním vytváření seznamu návrhů daného pole formuláře. V některých případech je vhodné omezit počet vrácených záznamů a SQL dotaz provádět při každé změně seznamu návrhů. V tom případě se výraz SQL dotazu uvádí znakem '*' a hodnota prefixu je v tomto výrazu prezentována parametrem ?_P1.

Jedná se např. o implementaci funkce automatického dokončování pro pole formulářů, ve kterých se vstupuje spojení adresátů:

Parametr SQL dotaz

*SELECT AD11JMENO,AD01ID+AD11CISSPO FROM %%%.ADSPOJ WHERE AD01ID=?_P1 AND TRIM(AD11JMENO)<>'' ORDER BY AD11JMENO

Parametr Výraz prefixu

THIS.PARENT.AD01ID.VALUE

Potlačení funkce automatického dokončování pro toto pole proveďte nastavením Funkce automatického dokončování - ne a zrušením záznamu, jinak by se při instalaci nové verze IS BM tento parametr opětovně založil.

Při definování obsahu parametru SQL/Výčet je možné používat makra. Příklady maker:

*

ID=SYS001

Název=SQL_spseob_XXX

select sp10text,left(sp10idzak,3) from %%%.spseob where sp10idzak like '___000000' and current date between isnull(sp10datum,current date) and isnull(sp10datumd,current date) order by sp10text

*

ID=SYS002

Název=SQL_mtskl

select mt04text,mt04id from %%%.mtskl order by mt04text

*

ID=SYS003

Název=SQL_spseob

select sp10text,sp10idzak from %%%.spseob where current date between isnull(sp10datum,current date) and isnull(sp10datumd,current date) order by sp10text

*

ID=SYS004

Název=SQL_obumist

SELECT ob05text,ob05id FROM OBUMIST order by OBUMIST.ob05text

*

ZÁLOŽKA „SKRIPTY POLE“ (definují se zde skripty v jazyce FoxPro daného pole formuláře)

Na této záložce nazvané 'Skripty pole' se definuje:

¨ typ skriptu - překryvný seznam - zatím je aplikován jediný typ skriptu 'Reakce na F2'

¨ skript - text - obsahuje kód v jazyce Foxpro

¨ poznámka

Pro uplatnění skriptů vzhledem k uživateli vedeném u skriptu platí totéž, co platí v tomto smyslu pro 'Funkce automatického dokončování':

¨ takto definované parametry jsou specifické pro dané pole daného formuláře pro aktuálně přihlášeného uživatele systému

¨ uživatel s právy správce systému má možnost aktivovat funkci automatického dokončování pro dané pole daného formuláře pro všechny uživatele systému založením parametrů pro uživatele SYSTÉM

¨ pokud je pro pole definováno Globální nastavení parametrů a zároveň nastavení parametrů uživatele, potom se uplatňuje nastavení uživatele

Skript typu 'Reakce na F2' se provádí na vstupním poli formuláře po stisku klávesy F2 resp. po pravém kliku myší.

Tomuto skriptu jsou předávány parametry (ve skriptu se neuvádí příkaz PARAMETER):

- _this - objekt, na kterém uživatel stiskl klávesu F2

- _thisform - objekt formuláře

Skript musí vracet hodnotu:

- .T. - TRUE - v případě, že skript proběhl a nemá být provedena funkce, která je pro 'Reakci na F2' naprogramována v BM.EXE

- .F. - FALSE - v případě, že skript neproběhl a má být provedena funkce, která je pro 'Reakci na F2' naprogramována v BM.EXE

Jediný společný skript je určen pro pole umístěná v mřížce a pro pole na stránce formuláře. Pokud nemá být skript proveden pro pole v mřížce, může být tato potřeba ošetřena na začátku skriptu např. kódem:

<pre>

IF UPPER(_this.parent.baseclass)='COLUMN'

RETURN .F.

ENDIF

</pre>

Příklad skriptu, který po pravém kliku myší na datu události obchodu v gridu vyvolá kalendář a potom zapíše do události vrácenou hodnotu:

<pre>

Local _ret

Do Case

Case !_thisform.komp_stav

* když se nejedná o spuštěnou operaci, provede se obvyklá akce po F2 naprogramovaná v BM.EXE

Return .F.

Case _thisform._o_kompo_.ukoncena

* když se jedná o ukončenou operaci, provede se obvyklá akce po F2 naprogramovaná v BM.EXE

Return .F.

Case _thisform._o_kompo_.sp07idtypd<>'PROCES'

* když se nejedná o operaci druhu procesu 'PROCES', provede se obvyklá akce po F2 naprogramovaná v BM.EXE

Return .F.

Case Upper(_this.Parent.BaseClass)<>'COLUMN'

* když se nejedná o pole v mřížce, provede se obvyklá akce po F2 naprogramovaná v BM.EXE

Return .F.

Endcase

If Val(Tool.get_prof('','CalendarXP','1',.T.))=1

Do bw_prika With [Do Form bw_gdate With _p1,.T. to _p2],_this.Value,_ret

Else

Do bw_prika With [Do Form bw_gdatx With _p1,.T. to _p2],_this.Value,_ret

Endif

If Type('_ret')$'TD' And _ret<>Nvl(_this.Value,{})

_this.Value=_ret

_thisform._pf_.p1.ob02datdod.Value=Max(_thisform._pf_.p1.ob02datdod.Value,_ret)

_thisform._pf_.p1.ob02dat.Refresh

If !_thisform._edit

_thisform.formakce('=')

Endif

Endif

* když skript nevrátí hodnotu .F. ('RETURN .T.' nemusí být uveden, protože skript, který nebyl ukončen příkazem RETURN, vždy vrací hodnotu .T.),

* tak se neprovede obvyklá akce po F2 naprogramovaná v BM.EXE

</pre>

Poznámka:

Při instalaci nové verze BM je automaticky vytvořen záznam globálního nastavení (tzn. uživatel SYSTÉM) pole „název adresáta“ na výběrové záložce formuláře Adresář s nastavením „naplnění seznamu návrhů – vstupem“. Toto nastavení je definováno jako ukázkové pro upozornění implementátorů na novou funkci automatického dokončování.

3.7 Doplňující položky menu objektů

Tato činnost poskytuje uživateli možnost implementačně doplnit definovatelné funkce pro menu, která jsou vyvolávána po stisku pravého tlačítka myši na uzlu představujícím objekt BM. Tuto možnost je vhodné využít zejména ve stromech zobrazovaných ve formulářích „spojené dokumenty“, „strom hlavního procesu“ a obdobných stromech formuláře „okno úloh“.

Uživatel má tuto činnost dostupnou v hlavním menu – Informační centrum – Typy a řady. Po aktivaci této činnosti má k dispozici přehled dosud nadefinovaných doplňujících položek menu objektů a zároveň má možnost definice nové položky. Při její definici vstupuje následující atributy:

¨ položka – identifikace a popis položky menu

¨ druh – výběr z překryvného seznamu druhů implementačních rozšíření. Na F2 možno nadefinovat nový druh, který se pak bude následně zobrazovat na výběr v překryvném seznamu. K jednotlivým druhům lze nadefinovat přístupová práva.

¨ objekt BM – výběr z překryvného seznamu objektů BM. Zde se určuje typ objektu BM (jeho uvedení není povinné), pro který se má doplňující položka menu uplatnit.

¨ pořadí – numerická hodnota – určuje pořadí zobrazení položky menu

¨ podmínka – podmínka zařazení položky menu – script v jazyce FoxPro. Je-li uvedena, musí obsahovat kód v jazyce FoxPro, který vrací logickou hodnotu .T. (TRUE) nebo .F. (FALSE)

¨ typ kódu – výběr z překryvného seznamu. Kompilovaný kód se použije v případě, že doplň. položka menu má spustit okno, které má zůstat otevřené, tzn. i při další práci s BM stále k dispozici. Nekompilovaný kód se naopak použije v případě, že spuštěná doplň. položka menu je k dispozici jen pro daný okamžik a pak se hned ukončuje.

¨ kód – kód v jazyce FoxPro vyvolaný při výběru položky menu

¨ poznámka – libovolný text

¨ aktualizace – datum a čas, kdy byla naposledy daná definice položky menu změněna – uplatňuje se zejména při importu balíčků

Doplňující položky menu jsou umisťovány na začátek standardního menu a uplatní se v případě, že 'Objekt BM' není určen nebo je totožný. O uplatnění doplňující položky menu může také rozhodnout kód Podmínky. Pro toto rozhodnutí má kód k dispozici předané parametry (v kódu se příkaz PARAMETERS resp. LPARAMETERS neuvádí):

_this - objekt - řídící objekt uzlu stromu, na kterém byl proveden pravý klik

_bw09typ1 - text - identifikace objektu BM

_bw09inst1 - jednoznačná časová identifikace objektu

Kromě toho jsou podle typu objektu BM k dispozici atributy objektu _this:

Pro typ objektu Adresář (AD) - _this.ad01id

Pro typ objektu Artikl (AR) - _this.sp61id,_this.sp60id

Pro typ objektu Proces (PR) - _this.sp33cisdr,_this.sp33cisdpm,_this.sp33cisd

Pro typ objektu Operace (OO) - _this.sp33cisdr,_this.sp33cisdpm,_this.sp33cisd,_this.sp06idsubs,_this.sp07idtyp,_this.sp33porad

Kód spouštěný po výběru položky menu má k dispozici parametry (v kódu se příkaz PARAMETERS resp. LPARAMETERS neuvádí):

_this - objekt - řídící objekt uzlu stromu, na kterém byl proveden pravý klik

_bw09typ1 - text - identifikace objektu BM

_bw09inst1 - jednoznačná časová identifikace objektu

_main_objekt - objekt - řídící objekt stromu

Kromě toho jsou podle typu objektu BM k dispozici atributy objektu _this. Může být spouštěný podle nastavení 'Typ kódu' v kompilovaném nebo nekompilovaném tvaru (kompilovaný tvar je určen pro případy, kdy kód vytváří nemodální objekty, např. nemodální formulář).

Parametr _main_objekt je předáván kódu pro případ, že je třeba po provedení kódu provést přezobrazení stromu, např. přezobrazení připojených dokumentů příkazem '_main_objekt.prezobraz_uzel(_this,.T.)'.

3.8 Spojené dokumenty

Přes vybraný objekt (vývěska, zprávy, události komponent) je možno spojit přes klávesu Ctrl D (nebo menu Volby – Dokumenty) jakýkoliv dokument. Vyvolání formuláře bylo zatím možné pouze z formulářů pro vstup objektů BM (události, artikly, adresát, ..). V IS BM je možné připojovat dokumenty i k záznamům tabulek, které nejsou objekty BM. Spojení s dokumentem čili existence vazby objekt - dokument se pak jako jiné objektové vazby ukazuje v rámečku souvislostí pomocí znaménka plus. Po stisku klávesy Ctrl D se uživateli zobrazí rámeček „spojené dokumenty“. Zde má k dispozici dokumenty objektu, procesu, operace, adresáta a artiklu. V případě potřeby vytvoření objektové vazby (např. navázání smlouvy na událost vývěsky) se využijí dokumenty objektu. Dokumenty procesu a operace se napojují automaticky, pokud dokument vzniká jako součást (je nadefinovaný v diagramu procesu) procesu nebo operace. Pod dokumenty adresáta se nejčastěji ukládají dokumenty, které jsou přímo svázány s daným adresátem, např. smlouvy, ceníky adresáta apod. Pod složkou artikl jsou obsaženy události artiklu, který je aktuální na události, ze které si uživatel spojené dokumenty vyvolal.

Další složky, které jsou dostupné pod dokumenty adresáta jsou:

¨ kategorie adresáta – ukazuje se přehled kategorií, ve kterých je daný adresát zařazen

¨ procesy adresáta – ukazuje se strukturovaný přehled procesů, které byly založeny pro daného adresáta.

¨ události adresáta – ukazují se události jednotlivých komponent, ve kterých je adresát uveden

Menu události adresáta a události artiklu se po spuštění činnosti spojené dokumenty zobrazuje zabalené (tzn. před jeho názvem je znaménko +) a napsané v závorkách. V tomto případě uživatel nedokáže rozpoznat, jestli adresát či artikl některé události obsahuje. Musí nabídku událostí nejprve rozbalit, tzn. kliknout na znaménko +. A pak se mu zobrazují pouze události komponent, ve kterých je adresát nebo artikl obsažen. Události jednotlivých komponent se v nabídce zobrazují podle druhu události, tzn. že např. v událostech změny stavu peněz může mít adresát uvedeno 12 událostí pohybu příjem do pokladny a 15 událostí pohybu úhrady předepsaných plateb. V případě, že uživatel nechá nabídku složky události adresáta nebo artiklu rozbalenou a takto ukončí činnost spojené dokumenty, tak při následujícím spuštění spojených dokumentů jsou tyto složky ve stavu rozbaleno.

Tyto menu se dají ovládat i pomocí myši:

¨ pravý klik na složce kategorie adresáta - vyvolání formuláře kategorií adresáta

¨ dvojí klik na konkrétní kategorii adresáta - vyvolání formuláře kategorií adresáta

¨ pravý klik na komponentě ve složce událostí - vyvolání formuláře odpovídajících událostí komponenty

¨ dvojí klik na druhu operace ve složce komponenty - vyvolání formuláře událostí komponenty (s předplněným výběrem daného druhu operace)

V případě potřeby vytvoření dokumentu uživatel postupuje následujícím způsobem. Kurzor umístí např. na dokumenty objektu (tzn. okno spojených dokumentů je aktivní) a po stisku pravého tlačítka myši se mu zobrazí volby:

¨ nový dokument – tuto možnost uživatel využije v případě, že vytváří úplně nový dokument. Při vytváření nového dokumentu musí nadefinovat jeho vlastnosti.

¨ načíst dokument – tuto možnost uživatel využije v případě, že již má dokument vytvořený, uložený mimo systém IS BM a chce tento dokument do systému přenést. Po aktivaci této činnosti uživatel určí cestu, odkud se má soubor načíst a pak už jen upřesní vlastnosti dokumentu (název, typ dokumentu a předlohy, příznak chráněného dokumentu). Je možno využít i možnosti externího uložení dokumentu. Po stisku OK je dokument načten a stává se součástí databáze IS BM (pokud nemá nadefinováno externí uložení).

¨ uložit obrázek v clipboardu – tato možnost umožňuje připojit jako dokument obrázek, který má uživatel uložen v clipboardu, tzn. na určitém obrázku mimo IS BM uživatel potvrdí volbu kopírovat (Ctrl C) a po aktivaci této činnosti je obrázek vložen jako dokument IS BM. Tato možnost je pro uživatele aktivní, je-li v hlavním menu programu obsažen program PCT_DLL.DLL. Obrázek je ukládán ve formátu JPEG.

IS BM umožňuje přenášet soubory tažením myší (metoda „táhni a drž“) do okna spojených dokumentů např. z okna průzkumníka Windows (tažením myší není možné připojovat přílohy e-mailu). Stejným způsobem je možné připojovat dokumenty k procesům nebo operacím ve formuláři Strom hlavního procesu a objektům, které mají zobrazený připojený dokument (obrázek) na volné kartě prostřednictvím atributu volné karty typu „multimediální“.

Po přetažení souboru do IS BM se pak systém chová standardně jako při klasickém vytváření dokumentu BM. Je nutno zadat jeho vlastnosti (tzn. název, druh dokumentu apod.). Pokud je v okamžiku uvolnění tlačítka myši stisknuta na klávesnici klávesa Shift, potom se ve vlastnostech připojovaného dokumentu automaticky nastaví zaškrtnuté „externí uložení“ na záložce „uložení dokumentu“.

Při založení dokumentu tažením myší je ukládána v IS BM informace o názvu načteného dokumentu (ukládá se do tabulky SPDOKFIL). Při opakovaném načtení dokumentu stejného názvu je pak systémem zobrazen dotaz podobného typu jako:

„Dokument „........název.........“ byl již do BM načten. Načtení provedl(a) – jméno a datum. Má být dokument opakovaně načten do BM (volba Ano) nebo má být připojen tento dříve načtený dokument? (volba Ne)?

Po stisknutí tlačítka ANO je původní načtený dokument přepsán úplně novým dokumentem, po stisknutí tlačítka NE není zakládán nový dokument a je pouze vytvořena objektová vazba mezi objektem BM a dokumentem, který byl již dříve načten. Při stisku klávesy Storno se neprovede žádná akce.

V případě, že má aktuální uživatel k dokumentu právo zápis a v okamžiku otevření daného dokumentu má tento dokument zároveň otevřen jiný uživatel, zobrazuje se mu v hlášení informace, že „dokument je otevřen pouze pro čtení, případné změny nebudou zaznamenány a jméno uživatele, který má otevřen daný dokument pro zápis“.

Ve stromech spojených dokumentů je nyní možné zvolit si tvar popisu dokumentu ve stromu. To se provádí pomocí nastavení parametru BM Preferences->Skript_pro_popis_dokumentu, kterým se uvádí identifikace knihovny vkládaného kódu, jejíž kód bude spouštěn pro určení popisu dokumentu.

3.8.1 Přehled o použití dokumentů

Jedná se o činnost, kterou má uživatel k dispozici v menu Marketing – Dokumenty. Poskytuje uživateli přehled o práci s jednotlivými dokumenty a zároveň slouží jako možnost ohlídání, zda některý z uživatelů nenahlédl omylem do citlivého dokumentu (při chybném nastavení přístupových práv k druhům dokumentů).

Uživatel má možnost si vyfiltrovat dokumenty za následující atributy:

¨ datum použití od – do

¨ za uživatele

¨ za způsob použití dokumentu (tzn. čtení, zápis)

¨ za název dokumentu

¨ za jeho druh, předlohu apod.

Další informace, které uživateli tato činnost poskytuje jsou tyto:

¨ zda je dokument uložen externě či je součástí databáze

¨ zda se jedná o dokument, který má příznak chráněný

¨ zda je nastaveno automatické ukládání revizí dokumentu

3.8.2 Dokumenty – verze

Jedná se o činnost, která je v případě nastavení dostupná na každém dokumentu a umožňuje sledování jednotlivých verzí. Verzí dokumentu rozumíme kopii obsahu daného dokumentu zaznamenanou v čase. Ve formuláři dokumenty je k tomuto účelu vytvořena záložka „verze dokumentu“. Zde se uživateli zobrazuje přehled jednotlivých verzí, a to těch dokumentů, které mají na záložce dokumenty zatržen příznak „automatické ukládání verzí“. Při zatržení tohoto příznaku vznikají verze daného dokumentu automaticky, ale v případě potřeby (pokud tento příznak zatržen není, ale uživatel by si rád uchoval průběh dokumentu v čase) je možno verzi vytvořit i manuálně a to volbou činnosti „uložit novou verzi dokumentu“ z menu Volby.

U každé verze se eviduje datum, čas jejího vzniku a uživatel, který ji založil. Nepotřebné verze je možné na záložce „verze dokumentu“ rušit. Verze je možné sledovat pouze pro dokumenty uložené v databázi, tzn. u dokumentů, které mají zatržen příznak „externí uložení“ verze sledovat nelze.

3.9 Funkce „Drap&Drop“

IS BM umožňuje uživateli využít funkci „Drag & Drop“ (tzn. Táhni a pusť) v těchto místech:

1. lze kopírovat záznamy formulářů, které obsahují záložky

2. lze kopírovat textové položky formulářů

3. lze kopírovat dokumenty

4. lze provést rychlý import dat vybraných řádků a sloupců Excelu

Tyto jednotlivé možnosti využití funkce „Drag & Drop“ si nyní podrobněji popíšeme.

3.9.1 Kopírování záznamů formulářů

Kopírování je možné provést z formulářů, které obsahují záložky. Provádí se tažením záložky (Drag) a jejím upuštěním (Drop) na záložku jiného formuláře. Přitom je ve formuláři, který přijímá data, zahájen vstup jednoho nebo několika nových záznamů, podle toho, zda bylo tažení záložky provedeno levým nebo pravým tlačítkem myši.

Při tažení levým tlačítkem myši se provádí kopírování aktuálního záznamu formuláře.

Při tažení pravým tlačítkem myši se provádí kopírování všech záznamů formuláře (maximálně však 10000 záznamů). Tato funkčnost se podobá doplňující vlastnosti formuláře 'Clipboard dat'.

Na rozdíl od doplňující vlastnosti formuláře 'Clipboard dat' je však možné tímto způsobem kopírovat data mezi různými formuláři (kopírují se pouze atributy, které jsou pro oba formuláře společné), např. je možné kopírovat tímto způsobem vybrané artikly do nově zakládaných událostí obchodu.

Kopírování je možné také mezi formuláři dvou různých aktuálně spuštěných BM.EXE. Tento způsob používání se však nedoporučuje, v současné době není zcela odladěno a při ukončování programu, že kterého byla kopírována data dochází k zahlcení systému a program nelze ukončit.

Tažením záložky formuláře je možné kopírovat data také do listu programu Excel (nebo jiného programu, který přijímá funkcí Drag&Drop data ve formátu CSV). Data jsou kopírována tak jak jsou zobrazená v mřížce formuláře. Kopíruje se jeden nebo několik záznamů, podle toho, zda bylo tažení záložky provedeno levým nebo pravým tlačítkem myši.

Při tažení levým tlačítkem myši se provádí kopírování aktuálního záznamu formuláře. Při tažení pravým tlačítkem myši se provádí kopírování všech záznamů formuláře. Pokud bylo do Excelu kopírováno více záznamů a v některém sloupci je uveden numerický údaj, potom je pro tyto sloupce doplněn součtový řádek.

3.9.2 Kopírování textových položek formulářů

Funkci „Drag“ (tj. táhnout text) je možné provést:

¨ z položek typu text nebo MEMO, přitom je možné text táhnout v rámci programu BM nebo do jiného programu Windows (Word, zpráva Outlooku, ...)

Funkci „Drop“ (tj. přijetí taženého textu) je možné provést:

¨ do položek typu MEMO (kromě tažení textu v rámci stejné položky typu MEMO)

¨ do položek typu text na výběrové záložce formuláře, přitom je možné přijímat text tažený v rámci programu BM nebo z jiného programu Windows (Word, zpráva Outlooku, ...)

3.9.3 Kopírování dokumentů

IS BM umožňuje kopírování dokumentů BM tažením myší (funkce Drag&Drop) ze stromů, ve kterých se vyskytují dokumenty, a to jsou:

- Spojené dokumenty

- Strom hlavního procesu

Dokument je tímto způsobem možné kopírovat:

¨ do jiných aplikací Windows (zpráva Outlooku, Explorer, ...)

¨ mezi různými stromy aktuálně spuštěného BM (v tomto případě je zobrazen dotaz, zda má být připojena kopie dokumentu nebo pouze odkaz na dokument)

3.9.4 Import dat vybraných řádků a sloupců Excelu

V IS BM je možno provést rychlý import dat vybraných řádků a sloupců aplikace Excel pomocí funkce „Drag“ (tažení). Dokončí se upuštěním („Drop“) tažené oblasti na vybranou záložku formuláře.

Následně se zobrazí formulář, který umožňuje uživateli data před importem upravit. Tento formulář obsahuje:

¨ mřížku, která obsahuje:

- sloupce, které odpovídají tažené oblasti – nadpisy sloupců jsou dány prvním řádkem tažené oblasti

- a navíc sloupce, které odpovídají atributům, které mohou být importovány aktuálním formulářem (v nadpisu sloupců jsou názvy atributů). Při pohybu v těchto sloupcích se zobrazuje na stavovém řádku popis atributu.

V nadpisech jednotlivých sloupců tažené oblasti může být uvedeno jejich ztotožnění s importovaným atributem. To se provede uvedením názvu atributu v nadpisu sloupce v kulatých závorkách (např. 'Druh artiklu (sp61id)' ).

V mřížce jsou sloupce, které se neuplatní při importu (tj. sloupce, které odpovídají tažené oblasti a přitom nebyly ztotožněny s některým importovaným atributem) zobrazeny na šedivém pozadí (tyto sloupce není možné editovat). Ostatní sloupce jsou zobrazeny na bílém pozadí, lze je editovat a pokud jsou vyplněné, tak se uplatní při importu.

Záznamy, které nemají být importovány, je možné v mřížce zrušit klikem na políčko zrušení záznamu.

¨ textové pole pro zadání skriptu v jazyce FoxPro

Skript je určen pro úpravu dat před jejich importem (např. 'REPLACE ALL ob02dat WITH {1.1.2010}' ). Skript může obsahovat procedury a cykly. Obsah skriptu se pamatuje v rámci aktuálního spuštění BM.EXE.

¨ tlačítko „Import“

Pomocí něj se provede import dat a ukončí formulář.

3.10 Informační panely

Informační panel je nástroj, který slouží k přehlednému zobrazení úkolů uživatele vyplývajících z informací uložených v systému. Obsah informačního panelu je volně definovatelný a je ho možné přizpůsobit individuálním potřebám jednotlivých uživatelů. Uživateli se mohou na jediné webové stránce zobrazovat jeho úkoly z různých oblastí IS a z této stránky potom může přímo vyvolávat potřebné funkce a činnosti aktivací hypertextového odkazu.

Informační panely se nacházejí v hlavním menu v činnosti Informační centrum. Po rozbalení tohoto menu má uživatel k dispozici tyto činnosti:

¨ Informační panely ke spuštění – přímo výběr jednotlivých nadefinovaných panelů ke spuštění

¨ Definice uzlů informačních panelů – vlastní definice jednotlivých informačních panelů

¨ Editor uzlů informačních panelů

¨ Druhy uzlů informačních panelů

¨ Prezentace stránek informačních panelů – definice vzhledu stránek informačního panelu

¨ Hypertextové odkazy – předdefinované hypertextové odkazy, které umožňují spouštění jiných uzlů s parametry nebo spouštění skriptů

Tato činnost se nachází v menu Informačním centrum – Informační panely.

Informační panel je nástroj, který slouží k přehlednému zobrazení úkolů uživatele vyplývajících z informací uložených v systému. Obsah informačního panelu je volně definovatelný a je ho možné přizpůsobit individuálním potřebám jednotlivých uživatelů. Uživateli se mohou na jediné webové stránce zobrazovat jeho úkoly z různých oblastí IS a z této stránky potom může přímo vyvolávat potřebné funkce a činnosti aktivací hypertextového odkazu. Po stisku ikonky „Zpět“ pravým tlačítkem myši se program automaticky přepne do hlavního okna programu.

Touto činností je možné definovat jeden nebo více informačních panelů. Na záložce Uzly a Další se popisují jednotlivé prvky informačních panelů.

Pro každý uzel se definuje:

¨ identifikace uzlu, která ho jednoznačně identifikuje

¨ název uzlu

¨ druh uzlu - definuje práva uživatelů

¨ prezentace - má význam pro uzel typu "Stránka panelu" - určuje HTML formátování

¨ ikona - má význam pro uzel typu "Stránka panelu" - určuje ikonu stránky

¨ typ – překryvný seznam - Informační panel / Stránka panelu / Prvek stránky

¨ adresa - má význam pro uzel typu "Stránka panelu" - přímá URL adresa vyvolaná při aktivaci stránky

¨ typ prvku - pro typ prvek stránky - určuje zda bude vytvářena tabulka nebo odkaz

¨ spojení - určuje datový zdroj, ze kterého budou SQL dotazem získávána data

¨ výraz názvu uzlu - je vyhodnocen při vytváření stránky panelu (výraz v syntaxi Foxpro)

¨ výraz třídění - pro uzel typu prvek stránky - určuje třídění dat získaných dotazem SQL (výraz v syntaxi Foxpro)

¨ SQL dotaz - pro uzel typu prvek stránky - SQL dotaz v syntaxi SQL Anywhere. Ve vlastnosti 'SQL dotaz' definice uzlu je možné vložit dva skripty provedené před a po provedení SQL dotazu. Oběma skriptům jsou přitom předávány parametry, se kterými je stránka vyvolána (_p1,_p2,...,_p14) a v proměnné _this je předán řídící objekt vytvářející stránku, skriptu před SQL dotazem je navíc předán v proměnné _OBJ_SQL objekt, který má ve svém atributu SQL obsažen text následně prováděného SQL dotazu (skript může tento text měnit). Provádí se uvedením slova #SCRIPT na začátku definice SQL dotazu (nesmí být před ním žádné mezery ani prázdné řádky). Za tímto slovem následuje kód skriptu v jazyce Foxpro vyvolaný bezprostředně před provedením SQL dotazu a za ním je na novém řádku slovo #ENDSCRIPT (nesmí být před ním žádné mezery). Pak následuje vlastní tvar SQL dotazu v syntaxi SQL. A potom může být uvedeno na samostatném řádku slovo #SCRIPT (nesmí být před ním žádné mezery), za kterým následuje kód v jazyce Foxpro vyvolaný po provedení SQL dotazu.

Př.:

<pre>

#SCRIPT

* vytvoří proměnnou TOOL.MOJE_PROMENNA a ta se potom použije v SQL dotazu

tool.addproperty('MOJE_PROMENNA','A%')

#ENDSCRIPT

select sp26,sp26datum,sp26nazev,bw01jmeno,sp26index,spdokobs.sp01id,sp01predlo,sp57typdok,spdokobs.sp57id,sp26koment,sp26disk,sp26soubor from %%%.spdokobs spdokobs,%%%.bwuzivat bwuzivat,%%%.sppredlo sppredlo,%%%.spdoktyp spdoktyp,%%%.sppristu sppristu where

spdokobs.sp57id=sppristu.sp44vec and
sppristu.sp44typ='tdo' and
sppristu.bw01uziv=?tool.uziv and

sppristu.sp44pristu>1 and

sp26nazev like ?TOOL.MOJE_PROMENNA and

spdokobs.bw01uziv=bwuzivat.bw01uziv and spdokobs.sp01id=sppredlo.sp01id and spdokobs.sp57id=spdoktyp.sp57id

#SCRIPT

* modifikuje data, která vrátil SQL dotaz v kurzoru DATA

select data

replace all sp26nazev with '* '+sp26nazev

#ENDSCRIPT

</pre>

Nebo:

<pre>

#SCRIPT

* doplní následně provedený SQL dotaz

_OBJ_SQL.SQL=_OBJ_SQL.SQL+" and sp26nazev like 'A%' "

#ENDSCRIPT

select sp26,sp26datum,sp26nazev,bw01jmeno,sp26index,spdokobs.sp01id,sp01predlo,sp57typdok,spdokobs.sp57id,sp26koment,sp26disk,sp26soubor from %%%.spdokobs spdokobs,%%%.bwuzivat bwuzivat,%%%.sppredlo sppredlo,%%%.spdoktyp spdoktyp,%%%.sppristu sppristu where

spdokobs.sp57id=sppristu.sp44vec and
sppristu.sp44typ='tdo' and
sppristu.bw01uziv=?tool.uziv and

sppristu.sp44pristu>1 and

spdokobs.bw01uziv=bwuzivat.bw01uziv and spdokobs.sp01id=sppredlo.sp01id and spdokobs.sp57id=spdoktyp.sp57id

#SCRIPT

* modifikuje data, která vrátil SQL dotaz v kurzoru DATA

select data

replace all sp26nazev with '* '+sp26nazev

#ENDSCRIPT

</pre>

Pozn.: V případě, že je potřeba použít pouze skript po SQL dotazu, potom je třeba definovat skript prováděný před SQL dotazem prázdný.

Např.:

<pre>

#SCRIPT

#ENDSCRIPT

select sp26,sp26datum,sp26nazev,bw01jmeno,sp26index,spdokobs.sp01id,sp01predlo,sp57typdok,spdokobs.sp57id,sp26koment,sp26disk,sp26soubor from %%%.spdokobs spdokobs,%%%.bwuzivat bwuzivat,%%%.sppredlo sppredlo,%%%.spdoktyp spdoktyp,%%%.sppristu sppristu where

spdokobs.sp57id=sppristu.sp44vec and
sppristu.sp44typ='tdo' and
sppristu.bw01uziv=?tool.uziv and

sppristu.sp44pristu>1 and

spdokobs.bw01uziv=bwuzivat.bw01uziv and spdokobs.sp01id=sppredlo.sp01id and spdokobs.sp57id=spdoktyp.sp57id

#SCRIPT

* modifikuje data, která vrátil SQL dotaz v kurzoru DATA

select data

replace all sp26nazev with '* '+sp26nazev

#ENDSCRIPT

</pre>

Na stránce informačního panelu je možné vytvářet odkazy, které způsobí vyvolání programu Windows (jiného než internetový prohlížeč) a v něm otevření souboru, který odpovídá celé zobrazené stránce (může to být více tabulek) nebo jednotlivé tabulce zobrazené na stránce. Funkčnost přenosu zobrazené tabulky do Wordu a Excelu je rozšířena o přímou možnost vytvoření dokumentu ve formátu Wordu resp. Excelu. Provádí se vložením kódu v jazyce Foxpro do atributu 'SQL dotaz' v definici uzlu informačního panelu. Tento kód vytvoří soubor v požadovaném formátu (případě, že je nastavena proměnná '_this.output_format') a jeho název vloží do proměnné '_this.rodic.output_file'.

V následujících popsaných příkladech se předpokládá, že na počítači je nainstalován Excel - a v případě použití pro WBM není jeho volání nějakým způsobem omezeno IIS-serverem.

Příklad 1. - klasický SQL dotaz

<pre>

#SCRIPT

#ENDSCRIPT

Select sp26,sp26datum,sp26nazev,bw01jmeno,sp26index,spdokobs.sp01id,sp01predlo,sp57typdok,spdokobs.sp57id,sp26koment,sp26disk,sp26soubor From %%%.spdokobs spdokobs,%%%.bwuzivat bwuzivat,%%%.sppredlo sppredlo,%%%.spdoktyp spdoktyp,%%%.sppristu sppristu Where

spdokobs.sp57id=sppristu.sp44vec And sppristu.sp44typ='TDO' And sppristu.bw01uziv=?Tool.uziv And

sppristu.sp44pristu>1 And

spdokobs.bw01uziv=bwuzivat.bw01uziv And spdokobs.sp01id=sppredlo.sp01id And spdokobs.sp57id=spdoktyp.sp57id

#SCRIPT

Local _txt,_xlapp,_xlwb,_xlsheet,_err

* Pokud má být vytvářen XLS, potom _this.output_format='XLS'

If Empty(_this.output_format) Or _this.output_format<>'XLS'

Return

Endif

If _this.web

* Výstup do Excelu pro WBM musí být uložen v adresáři -> _this.rodic.Path s příponou XLSX nebo XLS

_this.rodic.output_file=_this.rodic.Path+'tmp\'+Stuff(Sys(2015),1,1,'')+'.xlsx'

Else

* Výstup do Excelu pro BM.EXE bude uložen v libovolném pracovním souboru s příponou XLSX nebo XLS

_this.rodic.output_file=bw_param('TMP','.xlsx')

Endif

* _xlapp = OLE object Excelu

_xlapp=Createobject( "Excel.Application")

* _xlwb = objekt dokumentu Excelu

_xlwb=_xlapp.workbooks.Add

* _xlsheet = objekt listu Excelu

_xlsheet=_xlwb.worksheets[1]

Select Data

_i=0

Scan All

* _i obsahuje číslo řádku

_i=_i+1

* sp26datum do prvního sloupce

_xlsheet.cells[_i,1].Value=sp26datum

* sp26nazev do druhého sloupce

_xlsheet.cells[_i,2].Value=sp26nazev

* bw01jmeno do třetího sloupce

_xlsheet.cells[_i,3].Value=bw01jmeno

Endscan

_xlapp.displayalerts=.F.

* uložení dokumentu

_xlwb.SaveAs(_this.rodic.output_file)

_xlapp.displayalerts=.T.

* uzavření dokumentu

_xlwb.Close()

_xlsheet=.F.

_xlwb=.F.

_xlapp=.F.

#ENDSCRIPT

</pre>

Příklad 2. - programovaný SQL dotaz

<pre>

Local _txt,_xlapp,_xlwb,_xlsheet,_err

Local _sql

TEXT TO _sql Noshow

Select sp26,sp26datum,sp26nazev,bw01jmeno,sp26index,spdokobs.sp01id,sp01predlo,sp57typdok,spdokobs.sp57id,sp26koment,sp26disk,sp26soubor From %%%.spdokobs spdokobs,%%%.bwuzivat bwuzivat,%%%.sppredlo sppredlo,%%%.spdoktyp spdoktyp,%%%.sppristu sppristu Where

spdokobs.sp57id=sppristu.sp44vec And sppristu.sp44typ='TDO' And sppristu.bw01uziv=?Tool.uziv And

sppristu.sp44pristu>1 And

spdokobs.bw01uziv=bwuzivat.bw01uziv And spdokobs.sp01id=sppredlo.sp01id And spdokobs.sp57id=spdoktyp.sp57id

ENDTEXT

If !bw_exec(.F.,_sql,'Data')

Return

Endif

* Pokud má být vytvářen XLS, potom _this.output_format='XLS'

If Empty(_this.output_format) Or _this.output_format<>'XLS'

Return

Endif

If _this.web

* Výstup do Excelu pro WBM musí být uložen v adresáři -> _this.rodic.Path s příponou XLSX nebo XLS

_this.rodic.output_file=_this.rodic.Path+'tmp\'+Stuff(Sys(2015),1,1,'')+'.xlsx'

Else

* Výstup do Excelu pro BM.EXE bude uložen v libovolném pracovním souboru s příponou XLSX nebo XLS

_this.rodic.output_file=bw_param('TMP','.xlsx')

Endif

* _xlapp = OLE object Excelu

_xlapp=Createobject( "Excel.Application")

* _xlwb = objekt dokumentu Excelu

_xlwb=_xlapp.workbooks.Add

* _xlsheet = objekt listu Excelu

_xlsheet=_xlwb.worksheets[1]

Select Data

_i=0

Scan All

* _i obsahuje číslo řádku

_i=_i+1

* sp26datum do prvního sloupce

_xlsheet.cells[_i,1].Value=sp26datum

* sp26nazev do druhého sloupce

_xlsheet.cells[_i,2].Value=sp26nazev

* bw01jmeno do třetího sloupce

_xlsheet.cells[_i,3].Value=bw01jmeno

Endscan

_xlapp.displayalerts=.F.

* uložení dokumentu

_xlwb.SaveAs(_this.rodic.output_file)

_xlapp.displayalerts=.T.

* uzavření dokumentu

_xlwb.Close()

_xlsheet=.F.

_xlwb=.F.

_xlapp=.F.

</pre>

Při vytváření stránky informačního panelu je dostupná vlastnost řídícího objektu vytváření stránky OUTPUT_FORMAT, která má při vytváření běžné stránky zobrazované v internetovém prohlížeči hodnotu 'prázdný text' a při vytváření stránky určené pro zobrazení v programu Windows obsahuje hodnotu, kterou je tříznaková přípona souboru. Přitom platí, že je-li stránka vytvářena s nastavenou vlastností OUTPUT_FORMAT řídícího objektu, potom do vytvářených tabulek nejsou vkládány hypertextové odkazy, je potlačeno vytváření automatických hlaviček a patiček stránky a po vytvoření stránky je vyvolán program Windows podle uvedené přípony (hodnoty vlastnosti OUTPUT_FORMAT).

Do stránky informačního panelu je možné vkládat hypertextové odkazy, které zajistí vytvoření stránky s nastavenou vlastností řídícího objektu vytváření stránky OUTPUT_FORMAT třemi způsoby:

- v kódu patičky prezentace stránky

- ve vlastnosti POSTTEXT definice uzlu informačního panelu

- hypertextovým odkazem, který je součástí tabulky informačního panelu

K tomuto účelu slouží např. uživatelská knihovna vkládaného kódu USRPAN. S knihovnou USRPAN je možné zadat v kódu patičky prezentace stránky nebo ve vlastnosti POSTTEXT definice uzlu informačního panelu kód:

<pre>

#SCRIPT

Return zobrazit_v_excelu_a_wordu(_this)

#INCLUDE USRPAN

</pre>

Takto budou do stránky vloženy hypertexty, které převedou do programu Windows celou zobrazenou stránku (může to být více tabulek).

Při vytváření stránky určené pro zobrazení v programu Windows je pro úspěšné uplatnění stylů nutné, aby styly byly přímo obsaženy v souboru předaném programu Windows. Proto je třeba zasáhnou do popisu stylu v prezentaci stránky informačního panelu a v jeho kódu podmínit v případě, že je nastavena vlastnost OUTPUT_FORMAT řídícího objektu, vložení textu stylů do vytvářené stránky.

Např. s užitím knihovny USRPAN:

<pre>

#SCRIPT

Return vrat_styl(_this)

#INCLUDE USRPAN

</pre>

V některých případech je vhodné pro výstup stránky do programu Windows vyloučit některé sloupce tabulky, řádky tabulky,prvky stránek nebo celou jednotlivou tabulku zobrazenou na stránce (poslední platí pro hypertexty v kódu patičky prezentace stránky nebo ve vlastnosti POSTTEXT definice uzlu informačního panelu). V tom případě je možné uvádět ve vlastnosti Podmínka v definici takového sloupce, řádku, prvku stránky nebo podřízeného uzlu výraz 'EMPTY(this.output_format)'.

Pro uzel typu „Prvek stránky“ je možno nastavit tyto parametry typu prvku:

¨ „-„ – bude vytvořen seznam hypertextových odkazů s texty podle vyhodnocení výrazu uvedeného v parametru „výraz názvu“ – počet těchto odkazů odpovídá počtu záznamů vrácených SQL dotazem

¨ „tabulka“ – bude vytvořena tabulka podle popisu tabulky

¨ „odkazy s vyvoláním skriptu“ – bude vytvořen seznam hypertextových odkazů s texty podle vyhodnocení výrazu uvedeného v parametru „výraz názvu“ – počet těchto odkazů odpovídá počtu záznamů vrácených SQL dotazem

Při nastavení atributu „Typ prvku“ s jiným parametrem než „tabulka“ je nutno takový uzel zařadit pod jiný uzel (tzn. vytvořit poduzel uzlu) s nastavením parametru „Návěští – Odkaz na stránku“.

Stisk hypertextu vytvořeného pro uzel s typem prvku „-„ způsobí zobrazení stránky, která je sestavena podle definovaných vztahů s poduzly tohoto uzlu.

Pro uzel „Prvek stránky“ s parametrem „Odkazy s vyvoláním skriptu“ se na záložce Další definuje parametr SKRIPT, ve kterém se uvádí skript v jazyce Foxpro. Tento skript je vyhodnocován při vytváření stránky a vrací jiný skript v jazyce Foxpro, který bude aktivován při stisku odpovídajícího hypertextu a přitom je okno informačního panelu minimalizováno, pokud neprovedl skript při vytváření stránky nastavení _THIS.HREF_WEB=.T..

Pro uzel typu Prvek stránky - tabulka se definují sloupce a elementy sloupců tabulky. Na záložce Sloupce:

¨ sloupec - číslo - jednoznačně identifikuje sloupec - určuje pořadí sloupce

¨ návěští sloupce - určuje návěští sloupce ve vytvářené tabulce. Za znakem ‘~’ (vlnovka) je možno uvádět výraz v syntaxi FoxPro, který je vyhodnocován v okamžiku vytváření tabulky a zjištěná hodnota je vložena do vytvářené tabulky.

¨ HTML–atributy – atributy návěští sloupce následované výrazem v jazyce Foxpro oddělené klávesou Enter (např. TITLE=výraz v jazyce Foxpro)

¨ formát - určuje formát zobrazení hodnoty ve sloupci (např. 999 999 999.99). V tomto atributu je možno uvádět formáty času, zapsané v následujícím tvaru:

- @*TM - převádí numerickou hodnotu, která odpovídá počtu vteřin do tvaru MMM:SS

- @*TH - převádí numerickou hodnotu, která odpovídá počtu vteřin do tvaru HHH:MM

Oba tyto formáty je možno rovněž uvádět ve tvaru @Z*TM, resp. @Z*TH, kterými je do výstupu vkládán prázdný text v případě, že je formátovaný počet vteřin nulový (uvedené formáty nejsou součástí jazyka Visual Foxpro).

¨ podmínka – podmínka zařazení sloupce do tabulky (výraz v syntaxi FoxPro)

¨ výraz třídění – výraz třídění dat vrácený dotazem SQL (výraz v syntaxi FoxPro) – pro takto definovaný sloupec je ve výsledné HTML stránce návěští sloupce uvedeno ve tvaru hypertextového odkazu. Výraz třídění může být uveden znakem '*'. Tímto způsobem se definuje střídavé vzestupné a sestupné třídění při opakovaném stisku hypertextu návěští sloupce. Po stisku tohoto hypertextového odkazu je stránka přezobrazena setříděná podle hodnot získaných na základě výrazu třídění sloupce.

Poznámka:

Výraz třídění by měl reflektovat možnost výskytu hodnoty NULL v obsažených atributech (obvykle se to týká datumových atributů). Např. NVL(sp34datuko,DTOT({}))

¨ zarovnání ve sloupci - vpravo / na střed / vlevo

¨ součtový sloupec - na konci tabulky bude vytvořen součtový řádek se součtem v tomto sloupci (volba Ano/Ne)

Příklad definice HTML-atributů návěští sloupce:

TITLE='Setřízení tabulky podle data splatnosti pohledávky'

TARGET=iif(this.web,'_blank','_self')

Na záložce Řádky se definuje:

¨ Ř – číslo pásu/číslo řádku/návěští řádku - určuje návěští řádku ve vytvářené tabulce. Za znakem ‘~’ (vlnovka) je možno uvádět výraz v syntaxi FoxPro, který je vyhodnocován v okamžiku vytváření tabulky a zjištěná hodnota je vložena do vytvářené tabulky.

¨ podmínka – podmínka zařazení řádku do tabulky (výraz v syntaxi FoxPro)

¨ atributy elementu – atributy elementu řádku (TR) oddělené enterem

Záložka Další poskytuje uživateli možnost nastavit pro rozsáhlé tabulky zobrazované na stránkách informačního panelu stránkování:

¨ uzel – identifikátor a název uzlu

¨ prázdná, Ř. hlavičky, Ř. patičky – příznak, zda vytvářená tabulka může být prázdná (volba Ano/Ne) a počet řádků hlavičky a patičky

¨ sektor – pozice sektoru stránky ve tvaru písmeno+číslo – písmeno určuje pozici v ose X, číslo určuje pozici v ose Y + popis stylu tabulky rozvržení sektorů

¨ počet z. – volba, zda zobrazovat počet záznamů při uplatnění uzlu na stránce jako odkaz (možnosti Ano/Ne)

¨ stránkování – uvádí se číslo, které znamená, že po zadaném počtu záznamů se má stránkovat (hodnota nula znamená, že se stránkování neprovádí). V případě, že počet záznamů pro vytvoření tabulky nepřekročí zde uvedené číslo, potom se řádek s odkazy pro přechod na stránky tabulky nevytváří.

¨ odkazy – výběr z možností v překryvném seznamu (před tabulku/za tabulku/před i za tabulku) – určuje, kam má být umístěn řádek s odkazy pro přechod na jednotlivé stránky

¨ zahrnout – výběr z možností v překryvném seznamu (do tabulky/mimo tabulku) – určuje, jestli má být řádek s odkazy pro přechod na jednotlivé stránky umístěn jako součást tabulky nebo má být umístěn mimo tabulku

¨ tag – text - určuje grafické vlastnosti řádku s odkazy (např. TD STYLE="background:yellow; font-size:120%; text-align=center"), při umístění řádku s odkazy mimo tabulku jsou tagy TD a TH nahrazeny za tag DIV

¨ návěští - text - je určeno pro doplnění textu do řádku s odkazy (např.: <B>Stránky</B>). V textu návěští se může vyskytovat makro ###, které určuje umístění bloku s odkazy v textu návěští (např. 'Text před odkazy ### Text za odkazy' může zobrazit 'Text před odkazy 1 2 3 4 >>> Text za odkazy')

¨ refresh – v tomto atributu se udává čas (ve vteřinách), po jehož uplynutí má být stránka obnovena (příklad z praxe: ve skladu se skladníkovi automaticky aktualizuje stránka, na které se mu zobrazují skladové výdejky vytvářené na jiném pracovišti)

¨ pretext – text zobrazený na HTML před vyhodnocením uzlu

¨ posttext – text zobrazený na HTML po vyhodnocení uzlu

¨ skript – kód v jazyce FoxPro

¨ atributy elementu BODY - pro tvar definice platí stejná pravidla jako pro definování atributů elementů resp. sloupců, s těmito rozdíly:

a/ je možné použít vložení definice uložené v knihovnách vkládaného kódu klausulí #INCLUDE

b/ pokud je
prvním slovem definice slovo NODEFAULT, potom nebudou v elementu BODY atributy
'topmargin=0 id="bodyID" class = "dtBODY"', které jsou
jinak do elementu vkládány automaticky, např.: onLoad="return
relatedActions('ob11id','sp99','sp24idmj','ob02cj01c');"

¨ poznámka – libovolný komentář

V řádku s odkazy jsou odkazy na jednotlivé stránky představovány jejich pořadovými čísly a v případě, že byla data pro zobrazení tabulky setříděna příkazem FoxPro INDEX (tzn. že pro tabulku se uplatní Výraz třídění nebo ji uživatel setřídil klikem na návěští některého jejího sloupce), zobrazuje se při pohybu myší přes číslo stránky text (tooltip), který je vyhodnocením indexového výrazu pro první záznam zobrazovaný na stránce.

V řádku s odkazy je zobrazován seznam maximálně 21 odkazů na jednotlivé stránky tabulky. V případě, že v tomto seznamu není obsažena první stránka, potom řádek s odkazy obsahuje také odkaz s textem '<<<', který způsobuje přechod na stránku s pořadovým číslem (aktuálně_zobrazená_stránka - 20). V případě, že v seznamu odkazů není obsažena poslední stránka, potom řádek s odkazy obsahuje také odkaz s textem '>>>', který způsobuje přechod na stránku s pořadovým číslem (aktuálně_zobrazená_stránka + 20). Pokud tabulka obsahuje sloupce, které je možné třídit, potom je vždy po setřídění klikem na návěští sloupce zobrazována její první stránka.

Pro stránkovanou tabulku musí platit, že se identifikace uzlu informačního panelu, kterým je tabulka definována (včetně Alias - pokud se tabulka uplatňuje na stránce informačního panelu jako poduzel), vyskytne při vytváření stránky informačního panelu právě jednou.

Narozdíl od funkčnosti třídění nestránkované tabulky (klik na návěští sloupce – kde zároveň platí, že pokud je tabulka součástí skupiny tabulek, potom je setříděná tabulka zobrazena samostatně, tzn. není zobrazována stránka, ve které je tabulka obsažena, ale samostatná stránka tabulky), funguje třídění stránkované tabulky (klik na návěští sloupce) tak, že setříděná tabulka je zobrazována znovu jako součást skupiny tabulek. Stejné je chování při přechodu na jinou stránku tabulky, tzn. při přechodu na jinou stránku tabulky je zobrazována stránka informačního panelu, ve které je tabulka obsažena.

Poznámka: Této vlastnosti je možné využít i pro tabulky s možností třídění klikem na návěští sloupce, pro které platí pravidlo její jednoznačné identifikace ve vytvářené stránce informačního panelu a přitom pro tuto tabulku nemá smysl stránkovat. Stačí zadat do vlastnosti uzlu tabulky 'Stránkování' velkou hodnotu a potom bude po kliku na návěští sloupce zobrazována stránka informačního panelu, ve které je tabulka obsažena.

Záložka Sektory poskytuje uživateli možnost definovat pro každou stránku informačního panelu její rozčlenění na sektory. Sektory jsou ve výsledném HTML textu realizovány pomocí tabulky (dále jen tabulky rozvržení sektorů). Pro každý sektor se definuje:

¨ identifikace sektoru – je tvořena 2 znaky – označuje pozici sektoru stránky ve tvaru písmeno + číslo – písmeno určuje pozici v ose X, číslo určuje pozici v ose Y

¨ maximální počet sloupců sloučených do sektoru – číselná hodnota

¨ maximální počet řádků sloučených do sektoru – číselná hodnota

¨ popis sektoru – slovní popis sektoru (tento atribut se neuplatňuje ve výstupu)

¨ prázdný sektor – překryvný seznam Ano/Ne – určuje, zda má být sektor zobrazen i v případě, když je prázdný

¨ pretext – text vložený před buňku selektoru

¨ tag buňky – výraz, který definuje tag buňky vztaženého elementu

¨ posttext – text vložený za buňku sektoru

¨ poznámka – libovolný komentář k sektoru

Na záložce Poduzly uzlu se definují uzly připojené k danému uzlu. Typicky se k uzlům typu Informační panel připojují uzly typu 'Stránka panelu' a pod uzly typu 'Stránka panelu' uzly typu 'Prvek stránky'.

Uvádí se:

¨ uzel - identifikace uzlu

¨ pozice sektoru stránky ve tvaru písmeno + číslo

¨ pořadí - určuje pořadí zpracování uzlu (tj. také zobrazení výstupu uzlu na stránce)

¨ alias - umožňuje použít stejný uzel jako podřízený opakovaně

¨ název podřízeného uzlu - je-li uveden, potom je na stránce zobrazen tento text jako návěští (jinak je zobrazen text uvedený v definici uzlu)

¨ parametry – skutečné parametry použité v doplnění where poduzlu (předané do doplnění příkazu SQL uzlu, kde jsou pozičně reprezentované jako ?_p1, ?_p2 .... (maximální počet parametrů je 14))

¨ atributy - jsou doplňující atributy SQL dotazu podřízeného uzlu, které jsou vkládány do tohoto dotazu přímo za SELECT. Jsou-li uvedeny atributy, potom za posledním musí být uvedena čárka. Např. 'adadsat.ad01adsat, adspoj.ad11jmeno,' nebo 'TOP 200'

¨ from - je doplnění SQL dotazu podřízeného uzlu v jeho části za FROM

¨ where - je doplnění SQL dotazu podřízeného uzlu v jeho části za WHERE

¨ výraz třídění – výraz třídění dat vrácených dotazem SQL

¨ podmínka – podmínka zařazení poduzlu

Záložka Další obsahuje atributy, kde je možno se na nadefinované sektory odkazovat:

¨ sektor – pozice sektoru stránky ve tvaru písmeno + číslo

¨ popis stylu tabulky rozvržení sektorů (např. class=“dtTABLE“ cellspacing=“0“)

¨ alias - umožňuje použít stejný uzel jako podřízený opakovaně

¨ index - identifikátor pomocí kterého se je možné hypertextově odkazovat v XML dokumentech

¨ PRETEXT - text vložený před obsah vytvořený zpracováním uzlu

¨ POSTTEXT - text vložený za obsah vytvořený zpracováním uzlu

V atributech PRETEXT a POSTTEXT je možné uvádět kód v jazyce Foxpro. V tomto případě se uvádí na začátku textu slovo #SCRIPT. Tento kód musí vracet text, který je vložen do stránky.

Příklad vložení tabulky do sektoru:

¨ vlastnost Pretext sektoru -

<pre>

<table class="dtTABLE_papayawhip" cellspacing="0"><tr><th>Mám řešit úkoly</th></tr><td>

</pre>

¨ vlastnost Posttext sektoru -

<pre>

</tr></table></td>

</pre>

Na záložce Elementy sloupců se uvádí:

¨ sloupec - určuje sloupec umístění elementu (číslo pásu – řádku – sloupce)

¨ pořadí elementu

¨ break - Ano/Ne - za element vložení do sloupce může být vloženo odřádkování

¨ výraz - výraz v syntaxi Foxpro jehož vyhodnocená hodnota bude vložena do tabulky

¨ hypertext - s elementem bude spojen hypertextový odkaz

¨ jiný název – jiný název uzlu informačního panelu – za znakem ~ je možno zadat výraz (překrývá jiný název v hypertextu)

¨ parametry – skutečné parametry použité v doplnění where hypertextového odkazu (přebíjejí parametry uvedené v definici hypertextového odkazu)

¨ tučně - zobrazení elementu tučně

¨ kurzíva - zobrazení elementu kurzívou

¨ podtržené - zobrazení elementu podtrženě

¨ tag - jiný tag elementu - např. H2 - vloží <H2>[hodnota elementu]</H2>

¨ HTML–atributy – atributy elementu následované výrazem v jazyce Foxpro oddělené klávesou Enter (např. TITLE=výraz v jazyce Foxpro). Určené HTML-atributy vytvářeného elementu tabulky se uplatí pouze v případě, že:

- element má zaškrtnuto – Tučně nebo Kurzíva nebo Podtržené

- nebo je s elementem spojen hypertextový odkaz

- nebo má element uveden jiný tag (např. neutrální DIV)

¨ podmínka – podmínka zařazení elementu na stránku

Příklad definice HTML-atributů vytvářeného elementu tabulky:

TITLE='Kategorie adresáta:'+chr(13)+tool.sql_dotaz([select list(trim(ad08kateg),char(13)) from %%%.adkatads,%%%.adkat where adkatads.ad01id=?_p1 and adkat.ad08id=adkatads.ad08id],ad01id)

Uživatel má možnost doplnění elementu TR tabulky o další atributy. Na záložce Řádky je k tomuto účelu určena položka „Atributy elementu“. Dále uvedená pravidla se uplatňují také pro odpovídající nastavení návěští sloupce a elementu tabulky. V těchto položkách se uvádějí jednotlivé HTML – atributy elementu následované výrazem v jazyce Foxpro, oddělené klávesou Enter.

Př.: BGCOLOR=IIF(MOD(this.citac_radku,2)=1,'YELLOW','')

Pokud je hodnota vyhodnoceného výrazu prázdná, potom není atribut do elementu vkládán, jinak je hodnota atributu uvedena ohraničením apostrofy (pro uvedený příklad BGCOLOR="YELLOW").

Je-li název atributu uvedený znakem vlnovka, potom hodnota atributu není ohraničena apostrofy.

Např.: ~BGCOLOR=IIF(MOD(this.citac_radku,2)=1,'YELLOW','') -> BGCOLOR=YELLOW

Syntaxe ~= vkládá mezi atributy elementu přímo text bez jakéhokoliv formátování.

Např.: ~=IIF(MOD(this.citac_radku,2)=1,'BGCOLOR=YELLOW','') -> BGCOLOR=YELLOW

Stejné nastavení (tzn. položka „atributy elementů TR“) lze využít v činnosti Prezentace stránek panelů. V případě, že je uvedeno nastavení u jednotlivého řádku v definici uzlů inf. panelů a zároveň v prezentaci stránky, tak se poté uplatní obě tato nastavení.

Poznámka:

Součástí „návodů a balíčků“ je balíček obsahující definice uzlů informačního panelu, které vytvářejí stránky odpovídající hlavnímu menu programu (nebo jeho části). Z těchto stránek je možné spouštět činnosti BM stejně jako z hlavního menu programu.

3.10.1 Materialized View

Umožňuje prezentovat manažerské informace na informačních panelech novou metodou, která byla vyvinuta a v praxi nasazena pro vyhodnocování marketingových kampaní. Díky použité technologii MATERIALIZED VIEW se standardizovanou strukturou a navazujícího agregování GROUP BY CUBE se dosahuje okamžité odezvy.

Následující text nám uživatelským pohledem zpřístupní popis nové technologie MATERIALIZED VIEW, která byla zahrnuta do definice informačního panelu a umožňuje tím uživateli tzv. „multidimenzionální pohled“ na zobrazené informace.

V současné době je tato novinka zapracována v Informačním panelu – „Kampaně“, který uživateli poskytuje přehled jednak o počtu provedených kampaní, počtu oslovených zákazníků atd., ale zároveň i další pohled z jakého kraje či okresu byli, kolik mají zaměstnanců a další. Zpracování informačního panelu a jeho možnosti si nyní podrobněji popíšeme.

Po aktivaci informačního panelu se uživateli zobrazí následující výběrový formulář. Ten je postaven na výběru jednotlivých atributů, přičemž každý tento výběrový atribut přestavuje kategorii adresáta (předtím byl proveden import adresátů do systému IS BM a každému adresátovi podle obratu či počtu zaměstnanců a dalších výběrových kritérií byla přiřazena příslušná kategorie).

Do tohoto okamžiku se zatím výběr tváří a chová jako klasický běžný výběr, který uživatelé využívají při práci s IS BM již zcela standardně. Podstatná je poslední řádka ve výběru „Skupiny“. Právě její zvolení (analýza podmnožiny výběru) umožňuje uživateli výše zmíněný „multidimenzionální pohled“ (až 4 možné dimenze). Na obrázku je zvolen v řádku „Skupiny“ výběr pouze za Kampaň.

Po stisku tlačítka Vyhledat má uživatel pak dostupné následující informace:

Jednak příslušné údaje za jednotlivé kampaně, protože ve výběru byly zvoleny všechny kampaně a zároveň celkový skupinový pohled za kampaně dohromady.

Když si zvolíme ve výběru pouze určitou kampaň a více specifikujeme dimenze řádku Skupina, bude uživatel překvapen jak podrobně mohou být informace dostupné.

Takže při zadaném výběru za všechny kampaně, ale zároveň podle definice posledního řádku rozčleněné za kampaň, kraj a okres, viz. obrázek

jsou potom po stisku tlačítka „vyhledat“ informace následující:

Tlačítko „Celkem–detail“ funguje v podstatě jako přepínač. Při prvním zobrazení má uživatel dostupnou informaci celkem za zvolenou dimenzi (kritérium), při dalším stisku tohoto tlačítka se mu naopak rozbalí seznam s detailními informacemi. Při jeho dalším stisku se tento seznam zase sbalí. Takže podle zvoleného výběru má uživatel k dispozici informace celkem za jednotlivé kampaně, celkem za jednotlivé kraje a celkem i za jednotlivé okresy.

3.11 Parametry uživatele

Jedná se o činnost, která umožňuje každému uživateli nastavit si některé parametry podle jeho vlastních potřeb, tj. je součástí personifikace IS. Parametry lze nastavit nebo změnit v činnosti Systém - Parametry uživatele. Jedná se o tyto parametry:

¨ reakce na klávesu ESC při prohlížení - možnost nastavit si chování systému po stisku klávesy ESC v prohlížení jakékoliv činnosti. Pokud je nastaveno „zrušit prohlížení“, činnost se po stisku klávesy ESC automaticky ukončí, pokud je nastaveno „dotaz“, po stisku klávesy ESC se systém dotazuje „Ukončit prohlížení?Ano/Ne“, pokud je nastaveno „žádná reakce“, tak systém po stisku klávesy ESC nereaguje a činnost je nutno ukončit jiným způsobem (např. ikonou křížek).

¨ ukončovat textové pole psaním za poslední znak - při zatržení této možnosti kurzor po naplnění textového pole (např. zapsání 40-ti možných znaků v položce popis) automaticky přeskočí na další položku ve formuláři

¨ zobrazovat úplné století v datumových údajích - datum se potom zobrazuje ve tvaru DD.MM.RRRR, pokud by toto nebylo zatrženo, je rok zobrazen pouze dvěmi koncovými znaky (DD.MM.RR).

¨ zobrazovat grafický stavový řádek - při zatržení se uživateli zobrazuje řádek v dolním okraji okna, kde má např. možnost si přečíst message k dané položce.

¨ zobrazovat čas na stavovém řádku - na tomto stavovém řádku je pak v pravém dolním rohu okna k dispozici i čas.

¨ povolena změna pozice panelu nástrojů - pokud je tato možnost zatržena, je možno panel nástrojů přesouvat po okně, jinak zůstává standardně umístěn pod horní lištou okna.

¨ povoleno ukončení programu klávesou Alt + F4 - při zatržení je možno ukončit program, resp. hlavní menu, i po stisku klávesy Alt F4, jinak se program standardně ukončuje ikonou „křížek“.

¨ zobrazovat nabídku aktivních oken - uživateli se při zatržení této možnosti zobrazuje nabídka aktivních oken, což je seznam všech aktivně spuštěných činností.

¨ ikony – při zaškrtnutí této možnosti je pak nabídka aktivních oken zobrazována jako tlačítka s ikonami a při příštím spuštění programu se ukotví v dolní části obrazovky. Tuto možnost uživatel využije asi zejména, pokud si mřížku formuláře roztahuje do šířky a lišta s nabídkou aktivních oken mu pak zbytečně zabírá místo v pravé části obrazovky.

¨ stránka výběru po spuštění č. „Procesy“, „Operace“ - při zatržení této možnosti uživateli po aktivaci těchto dvou činností nejprve nabíhá záložka Výběr, kde si definuje, které údaje chce mít v okně k dispozici. V případě, že tato možnost zatržena není, aktivují se tyto činnosti podle posledního nastaveného výběru a to může být někdy i značně zdlouhavé. Zdlouhavému výběru je možno předejít tak, že uživatel si do výběru zadá napevno (možnost uchovat) č. nějakého procesu, tudíž po aktivaci činnosti procesy nebo operace se zobrazí tento proces, uživatel si sám přepne záložku výběr a vybere si data, která potřebuje.

¨ koeficient zobrazení - možnost zvětšit si nebo zmenšit si velikost formulářů (včetně velikosti písma atributů) podle vlastních potřeb. Standardně je nastaven koeficient 1, pokud se zadá např. 0,8, velikost formuláře na obrazovce se zmenší, pokud se zadá např. 1,2, velikost se naopak o něco zvětší.

¨ mřížka – nastavený koeficient mění na událostech velikost písma v mřížce. Nastavený koeficient u mřížky funguje pouze za předpokladu, že koeficient zobrazení je různý od hodnoty 1.

¨ zvýraznění řádku v mřížce – možnost nastavit si barevné zobrazení aktuální řádky v mřížkách formulářů. Možnosti způsobu zobrazení jsou:

- Ne – aktuální řádek v mřížkách nebude barevně zvýrazňován

- Ano – varianta 1 – aktuální řádek v mřížkách bude barevně zvýrazňován – při vstupu do buňky mřížky bude buňka vybarvena B/W (černé písmo na bílém podkladu) – při pohybu v mřížce pomocí klávesnice bude obsah buňky zčásti vybarven W/B (bílé písmo na modrém podkladu) – označení pro funkčnost klávesy Ctrl + C

- Ano – varianta 2 – aktuální řádek v mřížkách bude barevně zvýrazňován – při vstupu do buňky mřížky bude buňka vybarvena barvou zvýraznění – při pohybu v mřížce pomocí klávesnice bude obsah buňky zčásti vybarven W/B (bílé písmo na modrém podkladu) – označení pro funkčnost klávesy Ctrl + C

- Ano – varianta 3 - aktuální řádek v mřížkách bude barevně zvýrazňován – při vstupu do buňky mřížky bude buňka vybarvena barvou zvýraznění - při pohybu v mřížce pomocí klávesnice nebude obsah buňky automaticky označován pro funkčnost klávesy Ctrl + C

- (poznámka – možnost nastavení barevného zobrazování aktuální řádky v mřížkách formulářů je funkční pouze ve verzích BM pod Visual Foxpro verze 8.0 nebo vyšší).

¨ barva písma zvýraznění – barva zvýraznění písma v aktuálním řádku v mřížce

¨ barva pozadí zvýraznění – barva zvýraznění pozadí v aktuálním řádku v mřížce

¨ výstupy procesů - nejedná se o výstupy procesů jako takové, přesnější termín je nastavení způsobu tisku zvolených nebo předdefinovaných předloh výstupu nebo dokladů a toto nastavení se uplatní pouze tehdy, pokud je u dané předlohy výstupu na záložce „popis“ v atributu „výstupy procesů“ vybrána možnost „podle parametrů uživatele“. Možnosti tisku tedy jsou:

- rozhodnout - uživatel má možnost si zvolit, jestli chce tisknout na tiskárnu, do souboru nebo pouze předlohu prohlížet v okně

- prohlížet - předloha se automaticky zobrazí pouze k prohlížení v okně

- tisknout se zastavením - uživatel má v tomto případě k dispozici možnost zvolit si tiskárnu a počet kopií dané předlohy

- tisknout bez zastavení - daná předloha výstupu nebo doklad se automaticky tiskne bez zásahu uživatele

¨ E-mail - do této položky se zapíše e-mail uživatele, který se pak automaticky zobrazuje při posílání dokumentů nebo tiskových sestav pomocí elektronické pošty.

¨ aktuální datum uživatele - zapsáním data zde je možno krátkodobě změnit aktuální systémové datum, tzn. pokud uživatel potřebuje zadat např. větší množství událostí zpět k nějakému datu, změní si zde aktuální datum a systém bere jako aktuální datum toto datum zde nastavené. Pouze v případě storna nebere systém toto aktuální datum v potaz.

¨ uchovávat pozice oken – možnost nastavení zaznamenání pozice oken formulářů pro jednotlivé uživatele systému. Jedná se o překryvný seznam s možnostmi:

- Nikdy

- Ne

- Ano – automaticky vždy při uzavření okna

- Ano – při nastavení parametrů formuláře

¨ uchovávání pozice okna ve vztahu k rozlišení obrazovky – při uchovávání pozice okna formuláře je možno zaznamenávat i aktuální rozlišení monitoru uživatele. Možnosti nastavení jsou:

¨ přepočítávat pozice poměrem aktuálního rozlišení obrazovky – uživatel si uchová pozici okna formuláře (na svém PC) a při spuštění daného formuláře na jiném PC (tzn. s jiným rozlišením monitoru) systém automaticky přepočítává:

- umístění levého horní rohu okna v pixelech v ose X = [uložená pozice] * [uložené rozlišení v ose X] / [aktuální rozlišení v ose X]

- výška okna v pixelech = [uložená výška] * [uložené rozlišení v ose X] / [aktuální rozlišení v ose X]

- umístění levého horní rohu okna v pixelech v ose Y = [uložená pozice] * [uložené rozlišení v ose Y] / [aktuální rozlišení v ose Y]

- šířka okna v pixelech = [uložená šířka] * [uložené rozlišení v ose Y] / [aktuální rozlišení v ose Y]

- zvlášť pro různá rozlišení obrazovky

3.12 Režim oprav

Činnost režim oprav je pro uživatele dostupná v horní liště každé činnosti v menu Jazyk. Po aktivaci činnosti „režim oprav“ (tzn. jejím zatržení) je možno si přeložit nebo změnit název jakéhokoliv atributu dostupného na aktivním okně. Stiskem pravého tlačítka myši přímo na atributu se uživateli zpřístupní činnost „překlad textů“, kde si může libovolně změnit „návěští popisu“. Pokud bude chtít uživatel přeložit jednotlivé atributy do cizí řeči, je nutno si ještě před aktivací činnosti „režim oprav“ zvolit pod volbou Jazyk příslušný jazyk. Pokud si tedy uživatel bude chtít uzpůsobit popisy atributů v okně, je nutno před volbou „režim oprav“ zvolit jazyk CZE, v případě potřeby překladu popisu atributů do cizího jazyka je nutno zvolit příslušný cizí jazyk. Přeložená data se zobrazují pouze ta, jejichž název existuje v cizím jazyce. Přeložit lze:

¨ okna (názvy položek hlavního menu, nadpisy (labely) v oknech, obsahy překryvných seznamů a většina textů určených pro ovládání IS) – toto se provádí v činnosti Překlad textů v menu Systém.

¨ předlohy výstupů (tj. textová pole)

¨ data, u kterých je programovým kódem umožněno (určené číselníky, názvy účtů)

¨ nabídky

¨ hlavní menu

Při překladu textu prvku typu překryvný seznam pomocí režimu oprav je možné zatrhnout atribut „uložit přeložený text do BWSLOVPP“. Toto uložení následně v SQL dotazech umožňuje přístup k hodnotám, které jsou definované pro atributy zobrazované jako překryvný seznam.

3.13 Nastavení programu BM

Nastavení pro IS BM se původně ukládala v souboru BW.INI. V současné době se již nastavení pro IS BM ukládají přímo do dat (tabulka BWOPTION a BWOPTIOC) v činnosti „Nastavení programu BM“ (menu Systém).

Tato činnost poskytuje uživateli možnost definice jednotlivých nastavení potřebných pro IS BM. Význam nastavení včetně jejich popisu definují programátoři v Galaxii a při instalaci nové verze jsou nová nastavení programu BM do dat automaticky přidávána. Při doplňování nového nastavení do dat, které je aktuálně nastaveno také v souboru BW.INI je toto nastavení do této činnosti přidáno s hodnotou, která je nastavená v souboru BW.INI.

V přehledu definic nastavení programu BM jsou nastavení, která je možné definovat pouze v souboru BW.INI zobrazována v šedivých řádcích (jedná se o informace, které jsou pro program potřebné ještě před jeho vlastním připojením k databázovému serveru). Těmto nastavením zde není možné definovat žádnou hodnotu.

Nastavení, která je možná definovat v datech, jsou zobrazena v bílých řádcích a případné změny odpovídajících parametrů v souboru BW.INI nemají po instalaci nové verze žádný vliv na chod programu. Některá nastavení je možné definovat pouze lokálně pro datová úložiště nebo konkrétní počítače. Přitom v lokální definici hodnota datového úložiště „-„ znamená libovolné datové úložiště a hodnota počítač „-„ znamená libovolný počítač.

3.14 Nastavení sledování změn tabulek

Tato činnost umožňuje uživateli určit tabulky, jejichž změny záznamů mají být sledovány. Změny nadefinovaných tabulek je pak možno prohlížet v činnosti „přehled změn záznamů tabulek“ (menu Systém). Kromě změn v tabulkách umožňuje IS BM sledovat také změny záznamů na volných kartách.

Po aktivaci této činnosti uživatel definuje následující položky:

¨ tabulka - identifikace tabulky IS BM (výběr se seznamu tabulek obsažených v datovém modelu)

¨ VK – název volné karty, která je spojena s tabulkou. Při změně struktury volné karty nejsou automaticky přegenerovávány triggery pro sledování změn záznamů VK. Generovat triggery je možno z formuláře definování VK volbou „generovat triggery tabulky“ nebo z menu Volby tohoto formuláře vyvolat „nastavení sledování změn tabulek“ a „uživatelské triggery“.

¨ založení - Ano/Ne – zda bude zaznamenávána informace o založení záznamu do tabulky

¨ oprava - Ano/Ne – zda bude zaznamenávána informace o změně záznamu tabulky

¨ zrušení - Ano/Ne – zda bude zaznamenávána informace o zrušení záznamu tabulky

¨ podmínka - omezuje množinu sledovaných záznamů. Je to výraz v syntaxi Sybase SQL Anywhere - před jednotlivými atributy je třeba uvádět prefix $$$., který je v generovaných triggerech nahrazován textem new_name, resp. old_name

¨ atributy – výběr z překryvného seznamu - určuje způsob výběru atributů uvedených v následujícím atributu 'seznam atributů'. Je možno zvolit „všechny vyjmenované atributy“ nebo „všechny kromě vyjmenovaných atributů“

¨ seznam atributů - uvádí se přímo seznam atributů tabulky, jejichž hodnoty mají být, resp. nemají být sledovány (v návaznosti na to, co je uvedeno u atributu „atributy“)

¨ výraz popisu - výraz v syntaxi Sybase SQL Anywhere - před jednotlivými atributy je třeba uvádět prefix $$$., který je v generovaných triggerech nahrazován textem new_name resp. old_name

¨ aktivní - Ano/Ne - nastavení Ne je určeno pro pozastavení sledování změn (např. před hromadnou změnou dat pomocí ISQL)

¨ poznámka - libovolný text

Po vložení definic sledování změn je třeba vygenerovat triggery, které budou sledovat změny v určených tabulkách. Toto generování se provede aktivací příslušné činnosti z menu Volby:

¨ generovat triggery tabulky – pouze pro aktuální definici tabulky

¨ generovat všechny triggery - pro všechny definice tabulek

Jejich funkčnost je totožná s činností „uživatelské triggery“. Při generování triggerů je nutné, aby v daném okamžiku nepracoval s dotyčnými tabulkami jiný uživatel.

Příklady výrazu popisu:

Tabulka ADADSAT - $$$.ad01adsat

Tabulka ADADR - (select ad01adsat from %%%.ADADSAT where ad01id=$$$.ad01id)

Tabulka ADSPOJ - (select ad01adsat from %%%.ADADSAT where ad01id=$$$.ad01id)

Tabulka SPARTIKN (název artiklu) - $$$.sp62artikl

Tabulka OBARTIKL - (select sp62artikl from %%%.SPARTIKN where sp61id=$$$.sp61id and sp60id=$$$.sp60id and sp38id='CZE')

Tabulka MTARTIKL - (select sp62artikl from %%%.SPARTIKN where sp61id=$$$.sp61id and sp60id=$$$.sp60id and sp38id='CZE')

Omezení sledování změn tabulky obchodovatelného artiklu (OBARTIKL) výhradně pro druh artiklu 'ZBO' .

Podmínka = $$$.sp61id='ZBO'

Při sledování změn tabulky uživatelé programu (BWUZIVAT) je vhodné vyloučit ze sledování atributy BW01NAPOSL (Datum a čas posledního vyvolání systému - aktualizuje se při každém přihlášení uživatele) a SP38ID (Identifikace jazyka - může uživatel sám měnit). Pak je nastavení následující:

¨ Atributy = všechny kromě vyjmenovaných atributů

¨ Seznam atributů = bw01naposl,sp38id

3.15 Archivace

Nachází se v hlavním menu v činnosti Informační centrum – Utility. Jedná se o nástroj pro archivaci externích souborů, vlastní data BM jsou archivována společně s databází. Umožňuje tedy uživateli vytvořit si jednotlivé definice archivací, kde si určí, která data chce archivovat a jak často a kdy je chce archivovat. Archivují se především soubory template a banky (certifikáty apod.), programy, které vyžadují externí uložení (např. soubory jiných systémů) nebo externě ukládané dokumenty. Princip této archivace se dá jednoduše vyjádřit tak, že se v podstatě z externích souborů vytvoří data BM a ty se následně archivují standardním způsobem. Jednotlivé vytvořené archivace má uživatel kdykoliv k dispozici v archivu.

3.15.1 Popis archivací

Tato činnost se nachází v hlavním menu v činnosti Informační centrum – Utility – Archivace – Popis archivací.

Po aktivaci této činnosti se uživateli zobrazí aktivní záložka „Skupiny archivace“, kde jsou k dispozici již současné nadefinované archivace. Při prohlížení stávající archivace či při zakládání nové definice má uživatel k dispozici následující atributy:

¨ skupina – identifikace a název skupiny

¨ počítač – definice počítače, na kterém lze danou skupinu archivace aktivovat. V případě uvedení „pomlčky“ ji lze aktivovat z každého počítače, soubory archivace se vyskytují na síti a jsou dostupné všem. V případě lokálních souborů určených k archivaci je nutno určit počítač, ze kterého se bude daná archivace aktivovat, tzn. nelze ji pak aktivovat na jiném počítači.

¨ druh – jedná se o druh dokumentu. Druh dokumentu rovněž určuje přístupová práva k archivaci, tzn. archivaci smí aktivovat pouze ten, kdo má k danému druhu dokumentu právo zápis. Uživatel, který k danému druhu dokumentu nemá ani právo čtení, nevidí danou archivaci ani v prohlížení archivu.

¨ téma – téma vývěsky, pod kterým bude zapisován protokol o archivaci. Atributy téma, typ a text přímo souvisí s vývěskou, kam se zapisuje vytvořený protokol o archivaci. Výhodou tohoto zápisu na vývěsku je, že pak v datech lze pohodlně zjistit, kdy která archivace proběhla, což se hodí zejména pro případy, kdy se daná archivace spouští programově, tzn. že je nastaveno automatické spouštění archivace např. po 15 dnech. Podle údajů na vývěsce pak program dokáže analyzovat uplynulých 15 dní a automaticky spustí další naplánovanou archivaci.

¨ typ – typ události vývěsky, na kterou bude zapisován protokol o archivaci

¨ text – text události vývěsky

¨ adresář-A – adresář archivu, do kterého se ukládají archivní soubory (nepovinný údaj)

¨ adresář-* - kořenový adresář archivu. Jeho definice přímo souvisí s atributem adresář na záložce „Adresáře“. Uvedený adresář v tomto atributu následně nahrazuje * právě v atributu adresář, tzn. aby uživatel vždy nemusel vypisovat celou dlouhou cestu adresáře na každém atributu, zde uvede hlavní adresář a na záložce „Adresáře“ v atributu adresář je tento adresář nahrazen právě znakem *. Např. zde může být uveden adresář \\server\disk_k a na záložce „Adresáře“ v atributu adresář je potom uvedeno „*\bmsql\template“.

¨ aktivní – výběr z překryvného seznamu Ano/Ne – v případě potřeby vyřazení skupiny z archivace není nutno definici archivace rušit (i pro případ opětovné potřeby archivování), stačí pouze volbou Ne vyřadit z archivace

¨ nabízet – výběr z překryvného seznamu Ano/Ne – volba Ano znamená, že se daná definice archivace bude nabízet ke spuštění v hlavním menu (Inf. centrum – Utility – Archivace – Spuštění archivace) a pod menu Volby (připomenutí - pro uživatele je samozřejmě v nabídce ke spuštění v případě, že je nadefinovaná s druhem dokumentu, na který má uživatel právo zápisu)

¨ počet kopií – udává počet aktuálních kopií, který se má v přehledu archivu udržovat, tzn. je-li zde uvedeno např. 5 – v archivu se pak u dané archivace udržuje jedna hlavní archivace a 5 kopií (vždy 5 nejnovějších podle data, starší kopie se automaticky ruší). Vytváří se tzv. rozdílová archivace, tzn. že se archivují ta data, kde nastala změna. Pokud je zde v počtu kopií uvedeno číslo mínus jedna znamená to, že počet kopií je neomezen, neruší se žádná archivace

¨ poznámka – vlastní poznámka uživatele k definici archivace

Na druhé záložce „Adresáře“ se definuje, které adresáře se na uvedeném počítači mají archivovat. U každého adresáře jsou k dispozici tyto atributy:

¨ adresář – vlastní popis adresáře (tzn. včetně jeho přesné cesty). V případě síťových souborů může být část přesné cesty nahrazena znakem * (viz. atribut adresář-* na předchozí záložce). U popisu souboru je možno použít obrácené lomítko, což způsobí, že se pak v přehledu archivace ve stromu zobrazuje jako jeden adresář.

¨ popis ve stromu – popis, který se zobrazuje v přehledu archivace za atributem datum (popis není povinný údaj, lze ho doplnit i zpětně). Pokud se popis v tomto atributu zadá později, ve stromu se u daného adresáře projeví až po provedení další archivace.

¨ včetně podadresářů – možnosti Ano/ne – zda se mají archivovat i podadresáře daného souboru

¨ aktivní – možnosti Ano/Ne – volba Ano je jasná, volbu Ne uživatel použije v případě, že chce daný adresář vyloučit z archivace (a nechce ho rušit pro případ, že by ho časem opět do archivace chtěl zařadit).

¨ archivovat soubory – seznam souborů, které chce uživatel z daného adresáře archivovat uvedených v syntaxi *.název přípony souboru – oddělených čárkou (např. *dbf,*.fpt)

¨ nearchivovat soubory – stejný způsob zápisu jako u předchozího atributu s tím, že zde uživatel zadává pouze soubory, které nechce archivovat

¨ poznámka – vlastní komentář uživatele

Poslední záložkou této činnosti je záložka „Podskupiny“, která umožňuje uživateli do jedné velké skupiny sloučit několik malých.

Archivaci lze spustit z menu Volby (klávesa F9 – Spuštění archivu) a nebo z činnosti Utility – Archivace – Spuštění archivace. Po její aktivaci se uživateli zobrazí okno s nabídkou „Archivovat?“ – Ano/Ne a zároveň je u dotazu i informace o počtu archivovaných adresářů, počtu souborů a o celkové velikosti souborů.

Jednotlivé archivace lze spouštět programově a lze nastavit interval, po které době se mají automaticky provádět. Toto se provádí pomocí externího příkazu, který lze vyvolat voláním programu UTARCHIV s parametry:

1. identifikace skupiny archivu – povinný parametr

2. perioda – po kolika dnech se má archiv provádět (pokud na vývěsce existuje záznam mladší, archiv se provádět nebude) – nepovinný parametr

3. identifikace tématu vývěsky – nepovinný parametr – pokud je zde uveden, změní téma vývěsky uvedené v definici archivace

4. typ události - pokud je zde uvedeno, změní typ události uvedený v definici archivace

5. text – pokud je zde uveden, změní text uvedený u skupiny v definici archivace

6. doplnění adresáře archivu

7. počet kopií – pomocí předchozího a tohoto parametru lze nastavit automatickou dlouhodobou archivaci (pro potřeby archivace v letech, aby byl vidět průřez programem)

3.15.2 Prohlížení archivu

Tato činnost je pro uživatele dostupná v hlavním menu v komponentě Informační centrum – Utility – Archivace – Prohlížení archivu. Uživateli se zde přehledným způsobem zobrazují jednotlivé nadefinované archivace (definice archivace se provádí v činnosti Popis archivací).

Po aktivaci této činnosti je v levém sloupci (ve stromovém zobrazení) k dispozici přehled nadefinovaných skupin archivací z činnosti Popis archivací a v pravé části formuláře jsou k dispozici vlastní archivace. V pravé horní části je vždy hlavní verze souboru archivace a v pravé dolní části jeho kopie (archivace je typu rozdílová, tzn. nearchivuje se vždy vše v daných souborech, ale to co se změnilo či přibylo). Třídění jednotlivých sloupců v pravé části formuláře lze provádět po stisku levého tlačítka myši.

Po stisku pravého tlačítka myši na archivacích ve stromu (levý sloupec) lze provést (totéž lze provést i u souborů):

¨ kopírovat adresář (soubor) „.....“

¨ přejmenovat adresář (soubor) „.....“

¨ odstranit „.....“

U přejmenování souboru platí, že v případě, že uživatel změní např. název souboru a nadále chce archivovat soubor do stejného stromu, je nutno opravit nejprve definici a pak teprve název ve stromu. Pokud uživatel opraví název archivace přímo v její definici (popis archivací) a nikoliv zde ve stromu, tak se nový název zde neprojeví. Tento soubor archivace je pak vhodné ze stromu odstranit, přejmenovat a archivaci spustit znovu.

3.16 Další možnost zadávání plnění úkolů

Tato kapitola seznámí uživatele s jednou z možností zadávání plnění úkolů v projektovém řízení pomocí vytvořeného programu EVIVYK.EXE.

Základním předpokladem pro fungování tohoto programu je:

- IS BM obsahuje komponentu 'Projektové řízení'

- verze BM.EXE je s datem generování po 27.1.2010

EVIVYK.EXE je distribuován v souboru BM.ZIP (jeho adresář \BMSQL\EVIVYK).

Celý tento adresář by měl být umístěn v podadresáři adresáře uložení BM.EXE. Informace zobrazované programem EVIVYK.EXE je možné nastavit kódem 'knihovny vkládaného kódu' s identifikací EVIVYK. V každém případě je třeba tuto knihovnu založit a v jejím kódu nastavit atribut SP07IDTYPD.

Po spuštění tohoto programu (ať už výběrem a aktivací souboru evivyk.exe na určeném místě v PC nebo automatickým spuštěním po startu po přihlášení do IS BM) se uživateli jako první aktivuje přihlášení k tomuto programu, kde je předplněno jméno uživatele a uživatel zapíše pouze své heslo (heslo je totožné s heslem do IS BM).

Po přihlášení se uživateli zobrazí přehled projektových úkolů, ze kterých si uživatel zvolí ten, jehož se jeho plnění týká. Přitom zůstává na horní liště tohoto formuláře vysvícena možnost „Nové plnění úkolu“. Po výběru úkolu (dvojklik pravého tlačítka myši) uživatel zadává další atributy.

Stiskem ikonky „křížek“ v ovládací liště daného formuláře se tento program minimalizuje na dolní lištu počítače (ikonka bílé obálky) a je kdykoliv připraven k použití. Stačí pak pouze stiskem znovu aktivovat a zadat nové plnění úkolu.

Uživateli se po výběru projektového úkolu zobrazí následující formulář. Ten je konstantně umístěn v pravé dolní části obrazovky (velikost a místo umístění měnit nelze, pouze maximalizovat). Uživatel zde má v horní liště předplněn zvolený projektový úkol a dále je předplněn atribut datum aktuálním datem. Další údaje na druhém řádku formuláře jsou kromě data a času ikony:

¨ ikona hodiny – tj. časovač – měří čas daného úkolu, tzn. při výběru projektového úkolu a následném stisku ikonky časovač systém automaticky měří čas, který uživatel na daném úkolu strávil.

¨ popis úkolu – uživateli se po stisku této ikonky zobrazí popis, který je zapsán u zadání projektového úkolu

¨ odstranit plnění úkolu – tuto ikonku uživatel využije v okamžiku, kdy zjistí, že dané plnění nakonec vůbec nechce zapsat. Po stisku této ikonky je pak nutno ještě potvrdit tlačítko „odstranit plnění“.

Na dalším řádku se zadává krátký popis vztahující se k plnění projektového úkolu a v případě potřeby lze delší komentář zapsat v dalším atributu (viz. komentář). Další atribut, který se týká identifikace druhu plnění si uživatel vybere z překryvného seznamu. Implicitně je předplněna možnost „pracovní výkon“, další možnosti mohou být např.: „pracovní výkon – ukončení úkolu, změna stavu úkolu na připraven, čas strávený na cestě“ (nabídka těchto identifikací druhů plnění se mění v závislosti na druhu vybraného projektového úkolu).

Předchozí obrázek poskytuje uživateli pouze vzorovou možnost, jak může vypadat zadávání plnění projektových úkolů. Podle nastavení definice knihovny vkládaného kódu může uživatel při zadávání plnění ještě vstupovat např. obchodní selektor.

V případě, že si uživatel po aktivaci této činnosti vybral určitý projektový úkol a při jeho plnění zjistí, že by potřeboval daný projektový úkol změnit (např. při komunikaci se zákazníkem uživatel nejprve vybere projektový úkol typu „hotline“ a během hovoru může zjistit, že se bude jednat spíše o typ „servisní zásah“) lze projektový úkol pohodlně změnit. Toto se provede dvojklikem na modré liště s názvem projektového úkolu. Uživateli se zobrazí šedě zobrazený seznam dalších projektových úkolů daného druhu a stiskem pravého tlačítka myši na názvu tohoto úkolu je původní plnění přepsáno.

Po zadání všech atributů uživatel pak stiskne tlačítko „Zapsat plnění“ a potvrdí možnost „přepsat všechna Vaše plnění úkolů do BM“. Systém přepíše všechna zapsaná plnění do komponenty projektové řízení (nepřepíše pouze ty plnění s nevyplněným časem, když je čas u daného úkolu povinný).

Tímto způsobem tedy uživatel zadává jednotlivá plnění. Pro zadání dalšího plnění stiskne opět tlačítko „nové plnění úkolu“ a po vyplnění všech atributů tlačítko „zapsat plnění“, přičemž během plnění daného úkolu může opět změnit druh plnění (dvojklik na modré liště).

Může nastat situace, že se během doby, kdy má uživatel tento program aktivní např. změní určité zadání v knihovně vkládaného kódu a pak je nutno si tento aktivní formulář znovu obnovit. To se provede po stisku levého tlačítka myši na tlačítku „nové plnění úkolu“ pomocí Obnovit. Další z možností po stisku levého tlačítka myši je Konec aplikace.

Pro zkušenější uživatele nebo implementátory je v následující části popisu k dispozici příklad možnosti definice obsahu knihovny vkládaného kódu EVIVYK.

<pre>

* Provádí nastavení programu EVIVYK.EXE

* ve výrazech je možné pracovat s atributy:

* sp61id,sp60id,nk01verze,sp62artikl

* nk43,nk43idu,nk43porad,nk43stav,nk43datz,nk43datu,nk43text,nk43koment

* nk53id,nk53nazdru,pa13id,nk42id,nk44id,sp00datzap,sp10text

* atribut sp10text může nabývat hodnotu NULL

* atribut SP07IDTYPD - určuje druh procesu, který bude zakládán při přepisu plnění úkolů z pracovního souboru do komponenty plnění úkolů

* !!! toto je jediné povinné nastavení !!!

_this.sp07idtypd='HPXU01'

* atribut SP33CISDPM - určuje datové úložiště vzniklého procesu

_this.sp33cisdpm='01'

* atribut SQL_UKOLY_PLUS - doplňuje implicitní výběr úkolů pro založení nového plnění úkolu

_this.sql_ukoly_plus='nkukol.nk43stav in(2,3) and nkpredpr.nk01stav=4'

* atribut VYRAZ_STROM_PREDMET - mění implicitní zobrazení předmětu projektu ve stromu, ze kterého se vybírají úkoly pro založení nového plnění úkolu

_this.vyraz_strom_predmet='ALLTRIM(sp62artikl)'

* atribut VYRAZ_STROM_UKOL - mění implicitní zobrazení druhu úkolu ve stromu, ze kterého se vybírají úkoly pro založení nového plnění úkolu

TEXT TO _this.vyraz_strom_ukol noshow

ALLTRIM(nk53nazdru)+IIF((pa13id='T' AND nk53id <> 'IIS') or EMPTY(nk43text),'',' ['+allTRIM(nk43text)+']')

ENDTEXT

* atribut VYRAZ_STROM_ORDER - mění implicitní seřazení úkolů ve stromu, ze kterého se vybírají úkoly pro založení nového plnění úkolu

_this.vyraz_strom_order=[sp62artikl+IIF(pa13id='T','A','B')+nk53nazdru]

* atribut VYRAZ_NADPIS_CAPTION - mění implicitní zobrazení nadpisu plnění úkolu v seznamu rozpracovaných plnění úkolů

TEXT to _this.vyraz_nadpis_caption noshow

IIF(vykony.nk62datum=DATE(),'',

LEFT(TRANSFORM(vykony.nk62datum),IIF(YEAR(vykony.nk62datum)=YEAR(DATE()),6,20))+' ')+

TRIM(vykony.sp62artikl)+'; '+TRIM(vykony.nk53nazdru)+

IIF((vykony.pa13id='T' AND vykony.nk53id <> 'IIS') or EMPTY(vykony.nk43text),'',' ['+allTRIM(vykony.nk43text)+']')+

IIF(vykony.nk62hodin=0,'',' - '+thisform.trans_hodin(vykony.nk62hodin)+' hod.')

ENDTEXT

* atribut VYRAZ_NADPIS_ZMENA - mění implicitní zobrazení v menu úkolů zobrazovaném při změně druhu úkolu předmětu úkolu

TEXT to _this.vyraz_nadpis_zmena noshow

TRIM(sp62artikl)+'; '+TRIM(nk53nazdru)+IIF((pa13id='T' AND nk53id <> 'IIS') or EMPTY(nk43text),'',' ['+allTRIM(nk43text)+']')

ENDTEXT

* atribut VYRAZ_PODMINKA_TIMER - určuje logický výraz - je-li při založení nového plnění úkolu vyhodnocen TRUE, bude toto plnění založeno se spuštěným měřením času

_this.vyraz_podminka_timer=[sp60id='0001']

* metodou SPSEOB_ADD se stanoví to, zda bude s plněním úkolu vstupován obchodní selektor a jaké selektory se budou vstupovat

* např. pro plnění úkolů, jejichž název předmětu projektu začíná písmenem A, je povinný vstup obchodního selektoru začínajícího písmeny IPV0

_this.spseob_add([sp62artikl='A'],[sp10idzak like 'IPV0%'])

* a dále pro plnění úkolů, jejichž název předmětu projektu začíná písmenem E, je povinný vstup obchodního selektoru začínajícího písmenem E

_this.spseob_add([sp62artikl='E'],[sp10idzak like 'E%'])

* atribut TIMER_CLOSECONN.INTERVAL - uvádí čas v milisekundách, po jeho uplynutí je automaticky uzavřeno otevřené spojení s databází

_this.Timer_closeconn.interval=5000

</pre>

3.17 Odesílání e-mailů z BM s použitím objektu Outlooku

Nastavení programu BM (hlavní menu – Systém) MSMAPI->UseOutlook=1 způsobí to, že pro odesílání emailu z IS BM bude používán objekt Outlooku místo objektu vyvolaného z MSMAPI32.OCX.

Použití objektu Outlooku přináší následující výhody:

¨ při editaci mailu před jeho odesláním se používá plnohodnotný Word, tzn. že je možné např. používat tučné písmo, vkládat tabulky, vkládat obrázky, ...

¨ text mailu předplněný z BM může být ve formátu HTML (tj. může obsahovat např. logo firmy, tabulky, tučné písmo,...) - text mailu musí v tomto případě začínat tagem <pre><HTML></pre>

¨ Outlook dokáže takto vytvořené maily posílat do Datové schránky (pro tuto funkci je nutno v Outlooku nainstalovat potřebný plug-in)

¨ při automatickém odesílání mailu (bez možnosti opravy uživatelem) není třeba potvrzení uživatele o tom, že program BM je oprávněn odeslat mail

Při použití objektu Outlooku je možné také vyvolávat program BW_MAPI tak, že BM nečeká na ukončení úpravy mailu uživatelem BM_MAPI, který má nyní parametry:

lcrecipaddress,lcsubject,lcmessagetext,lcfiles,randomsend,sp38id

přitom parametr randomsend může mít hodnoty:

.T. nebo 0 - mail bude odeslán bez možnosti jeho úpravy

.F. nebo 1 - mail se nabídne k úpravě - program BM zastaví a čeká na ukončení úpravy mailu

2 - mail se nabídne k úpravě - program BM nezastaví a nečeká na ukončení úpravy mailu

V předlohách výstupu je možné použít příkaz:

.MAIL_SEND 2

Pro vložení firemního loga do mailu ve formátu HTML je třeba:

¨ soubor obrázku musí být v mailu uveden mezi přílohami dokumentu

¨ obrázek je v uveden v textu mailu v syntaxi cid:<název souboru bez cesty>, např. <pre>'<p><img width=218 height=80 src="cid:fi_logo.gif"></p>'</pre>

Dalším Nastavením programu BM MSMAPI->MailTemplate=<identifikace volného textu> (uplatní se pouze při nastavení MSMAPI->UseOutlook=1), je možné vytvářet vzhledově jednotné maily, které na svém konci obsahují např. logo firmy, kontaktní informace odesílatele mailu např. telefonní číslo, emailovou adresu, odkaz na webovou stránku, ...).

V tomto nastavení se uvádí <identifikace volného textu>. Volné texty se definují ve formuláři 'Volné texty' (INFORMAČNÍ CENTRUM -> TYPY A ŘADY -> Volné texty). Volný text použitý pro vytváření vzhledově jednotných mailů, by měl:

¨ být ve formátu HTML - tj. měl by začínat textem <pre><HTML></pre> a dále by měl obsahovat makro ##BODY##, které bude nahrazeno textem mailu

¨ v položce 'Kód' na záložce 'Další' - by měl obsahovat kód v jazyce Foxpro, který vrací upravený text (doplnění kontaktní informace odesílatele mailu např. jeho jméno, telefonní číslo, ...)

¨ v položce 'Přílohy mailu' na záložce 'Další' - je možné uvádět seznam souborů (obrázků), které budou doplněny do mailu jako přílohy - např. výsledný mail má obsahovat firemní logo (tj. ve volném textu je uvedeno

<pre>'<p><img width=218 height=80 src="cid:fi_logo.gif"></p>'</pre>), potom by měl být uveden soubor třeba 'bmps\fi_logo.gif'

Text mailu, který nahradí ve výsledném mailu makro ##BODY## musí obsahovat html-tagy pro odřádkování (BR).

Pro zjištění výsledného tvaru kostry mailu používá BM metodu 'tool.sptexty_vrat_text', která má parametry:

¨ _SP88ID - identifikace volného textu

¨ _SP38ID - jazyk volného textu (nepovinný)

Vrací upravený text v daném jazyce (pokud není takový text v jazyce definovaný, tak v jazyce uživatele). Text upraví spuštěním 'kódu' uvedeného u textu. 'Kódu' jsou předány parametry:

¨ _SP89OBSAH - text volného textu

¨ _DATA - objekt, který obsahuje všechny atributy volného textu - mj. atribut SP38ID (_DATA.SP38ID), ve kterém je jazyk textu (tj. _SP89OBSAH)

Příklad volného textu určeného pro vytváření vzhledově jednotných mailů.

'Text' volného textu např.:

<pre>

<html>

<body>

##BODY##

<br>

<span style='color:navy;'>S pozdravem</span><br>

<b><span style='color:navy;'><<tool.jmenot>></span><b><br>

<br>

<p><img width=218 height=80 src="cid:fi_logo.gif"></p>

<span style='color:navy;'>Naše firma s.r.o.</span><br>

<span style='color:navy;'>Uliční 1, 999 99 Kolobřehy</span><br>

<span style='color:navy;'>Tel.: +420 999 999 999 (sekretariát), <<alltrim(tool.sql_dotaz([select bw01telef from %%%.bwuzivat where bw01uziv=?tool.uziv]))>> (přímý)</span><br>

<span style='color:navy;'>Fax: +420 999 999 999</span><br>

<span style='color:navy;'>Skype: ???</span><br>

<span style='color:navy;'><a href="http://www.nasefirma.cz/">http://www.nasefirma.cz/</a></span>

<span style='color:navy;'>, </span><span
style='color:navy;'><a
href="http://nasefirma.inshop.cz/">http://nasefirma.inshop.cz/</a></span><br>

</body>

</html>

</pre>

'Kód' volného textu např.:

<pre>

Local _rt,_err

Try

_rt=Textmerge(_sp89obsah)

Catch To _err

_rt='<h1>'+_err.Message+'</h1>'+Chr(13)+Chr(10)+_sp89obsah

Endtry

Return _rt

</pre>

'Přílohy mailu' volného textu např.:

bmps\fi_logo.gif

3.18 Sady vzdálených funkcí

Tato činnost slouží ke sledování aktuálnosti verzí a legislativních nastavení u uživatelů, tzn. že u jednotlivých uživatelů lze porovnat jejich verzi vůči nejaktuálnější verzi Bílého Motýla a zjistit, jestli má uživatel aktuální všechny předlohy výstupu, doplňující vlastnosti formuláře, knihovny apod., čímž je plně zajištěno aktuální nastavení BM i u jednotlivých uživatelů. Činnost je pro uživatele dostupná v hlavním menu – Informační centrum – Algoritmy a parametry.

V činnosti „Sady vzdálených funkcí“ se definují vlastní definice kontroly jednotlivých činností, po jejichž spuštění právě dochází k porovnání verzí aktuálního nastavení BM a nastavení BM u uživatele.

U každé sady se na záložce „sady vzdálených funkcí“ definuje identifikace sady, její název a poznámka (tzn. bližší vysvětlení, k jaké kontrole tato sada slouží, co je jejím cílem apod.).

Uživatel si zde může pouze prohlédnout přehled nadefinovaných sad a vybranou následně aktivovat, jejich vlastní nastavení zde měnit nelze (to se provádí v činnostech Sady vzdálených funkcí – nastavení a Vzdálené funkce – nastavení).

Vedle atributu Poznámka má uživatel k dispozici dvě samostatná tlačítka:

¨ modrá tužka – (ne)zobrazovat kurzor v mřížce – v běžném nastavení platí, že pokud umístíme kurzor na vybraný řádek, tak tento řádek je zvýrazněn jinou barvou (právě aby bylo zřejmé, že je v tuto řádek aktivní). Pokud by toto zvýraznění řádku uživateli ovšem nevyhovovalo, lze stisknout právě toto tlačítko. Pak aktivní řádek není zvýrazněn žádnou barvou, pouze je u něj příznak malé černé šipky na začátku řádku.

¨ zelená šipka – toto tlačítko slouží ke spuštění vybrané sady vzdálených funkcí (možno aktivovat i pomocí klávesy F9). Po jeho aktivaci uživatel pouze určí datum, ke kterému tuto sadu aktivuje a stiskne tlačítko OK. Následně se uživateli zobrazí informační panel s protokolem, který je opticky rozdělen do dvou částí.

Menší levá část obsahuje sloupec s názvy jednotlivých sekcí, které daná sada obsahuje. Větší pravá část vždy zobrazuje info k té sekci, na které je umístěn kurzor. Jako první se po aktivaci dané sady kurzor umístí na hlavičku s názvem sady, která má v pravé části info k jednotlivým sekcím a ve sloupečku info je napsaná informace, které nesrovnalosti tam systém při kontrole objevil (tzn. může tam být napsáno „chyba“ – že je nutno některé údaje v sekci aktualizovat nebo hláška „nespuštěna“ – že tuto sekci uživatel ještě nikdy nenahrál apod.). Na dolní liště je info, kolik sekcí bylo OK, v jaké sekci bylo varování, chyby a kolik jich bylo ještě nespuštěno (viz. následující obrázek).

V případě, že uživatel umístí kurzor na řádek označený křížkem (na našem obr. např. „kontrola všech předloh výstupu“), zobrazí se mu v pravé části obrazovky podrobná informace.

Po stisku modře označených záznamů má uživatel dostupné ještě podrobnější informace, např. po stisku čísla verze se přesně dozví bližší údaje o tom, kdy a kým byla daná verze vytvořena, kdo je autor, jaký je typ předlohy apod. Po stisku modře označené informace „chyba“ se uživateli zobrazí nabídka možnosti nahrát si danou předlohu výstupu pomocí balíčku. Naprosto stejný postup je i u jiných druhů informací, např. těch, co se týkají legislativních konstant nebo daňových přiznání. Vždy pod modře označeným záznamem je buď podrobnější informace nebo možnost chybu napravit (nahrát balíčkem nebo informace o tom, kde si má jaké nastavení uživatel opravit).

Druhá záložka v této činnosti se jmenuje „automatické spouštění“ a uživatel zde má možnost si nadefinovat možnost automatického spouštění vybrané sady. Definují se následující atributy:

¨ skupina – identifikace skupiny uživatelů (v podstatě zde se vybírá, kdo bude mít právo danou sadu automaticky spouštět)

¨ spustit – výběr z překryvného seznamu. Možnosti jsou při startu BM, nespouštět, při startu programu

¨ perioda – pokaždé, jednou denně – uživatel, jednou denně – celá firma

¨ balíčky – opět výběr z překryvného seznamu. Možnosti jsou importovat, importovat na pozadí, importovat na pozadí s dotazem, neimportovat – spustit formulář

¨ po chybě – možnost nastavit spustit formulář vzdálených funkcí nebo nespustit formulář vzdálených funkcí

Pomocí kombinace těchto atributů lze nastavit např. že po prvním přihlášení daného uživatele do systému v daný den se má automaticky spustit daná sada vzdálených funkcí a pokud by systém zjistil nesrovnalosti ve verzích, může automaticky na pozadí naimportovat chybějící balíčky.

[1] V některých firmách potřebují využívat databázi uživatelů IS BM (tzn. jméno a heslo) zároveň i pro přihlašování do jiných programů (např. intranet, ...). BM volitelně ukládá do tabulky uživatelů systému (BWUZIVAT) při změně hesla uživatelem zadané heslo zakódované určenou hash funkcí. Před zakódováním hash funkcí se zadané heslo převede na malé znaky.

Hash funkce je transformace, která jako vstup přijímá řetězec znaků o libovolné délce a výsledkem je pak řetězec znaků s pevnou délkou, tzv. hash nebo také otisk. Hash funkce se často používají v kryptografii, kde se však na její kvalitu kladou další kritéria. Funkce je jednosměrná, je nemožné jednoznačně najít k otisku původní text.

Parametrem programu BM Preferencess->PasswordHashAlgorithm (v činnosti nastavení programu BM) se určuje použitá hash funkce pro zakódování hesla.

1 = SHA1 (a.k.a SHA160)

2 = SHA256

3 = SHA384

4 = SHA512 *Default

5 nebo 50= MD5

6 = RIPEMD128

7 = RIPEMD256

Hash se ukládá do atributu BW01HHASH tabulky BWUZIVAT v binárním nebo hexadecimálním tvaru (při nastavení Preferencess->PasswordHashHexa=1) a číslo hash funkce se zapisuje do atributu BW01HHASHT. Pro použití hash funkcí 1 až 7 je nutné, aby v adresáři programu BM byl nainstalován soubor VFPENCRYPTION.FLL a dále je nutno na každou stanici instalovat knihovny VC++ 8.0 runtime. Použití funkce 50 (MD5) nevyžaduje instalaci žádných externích prostředků.

Možnost ukládat hash hesla uživatele je pouze ve verzích BM pod Visual Foxpro 8.0 nebo vyšší.

[2] Například do knihy vystavených faktur (pohledávek) se budou zapisovat: vystavené faktury, vystavené dobropisy, vystavené zálohové listy.

[3] V současné době není s verzí IS BM dodáváno.

[4] V některých firmách potřebují využívat databázi uživatelů IS BM (tzn. jméno a heslo) zároveň i pro přihlašování do jiných programů (např. intranet, ...). BM volitelně ukládá do tabulky uživatelů systému (BWUZIVAT) při změně hesla uživatelem zadané heslo zakódované určenou hash funkcí. Před zakódováním hash funkcí se zadané heslo převede na malé znaky. Hash funkce je transformace, která jako vstup přijímá řetězec znaků o libovolné délce a výsledkem je pak řetězec znaků s pevnou délkou, tzv. hash nebo také otisk. Hash funkce se často používají v kryptografii, kde se však na její kvalitu kladou další kritéria. Funkce je jednosměrná, je nemožné jednoznačně najít k otisku původní text. Parametrem programu BM Preferencess->PasswordHashAlgorithm se určuje použitá hash funkce pro zakódování hesla.

[5] Uživatelský příklad definice kontingenční tabulky je k dispozici u pojmu „kontingenční tabulky“ (slovník pojmů). Je podrobně popsán příklad kontingenční tabulky, která využívá ke svému naplnění data z komponenty účetnictví z činnosti obratová tabulka.

[6] Tato změna byly vyvolána vlastností Excelu ve verzích 11 a nižších, podle které je možné v seznamu funkce SUM uvádět nejvýše 32 položek.

[7] V tuto chvíli je nutno upozornit implementátory, že při použití .post script ve výrazu obecného výběru nad určitou činností může nastat problém s předlohami výstupu nad touto činností. Jedná se o předlohy, které mají ve vlastnostech na záložce Seskupování vyplněny atributy SELECT, GROUP a HAVING. Tyto sestavy pak v kombinaci s takto vytvořeným výběrem nefungují, tzn. že není vhodné nad danou činností v sestavách aplikovat seskupování, pokud zároveň je v obecném výběru ve výrazu použit programový kód v jazyce FoxPro. Je velmi obtížné pak tyto sestavy a obecný výběr sladit dohromady, resp. pokud se na to implementátor nesoustředí již při jejich definování, je vlastně nemožné je potom sestavit.

[8] [4] Přehled označených záznamů vypne výběr, resp. zobrazí vždy přehled všech označených záznamů nezávisle na tom, jaký výběr je právě aktuálně zvolen. Přehled označených by uživatel mohl využívat i tak, že si zvolí řadu obecných výběrů, kde si v každém výběru označí vybrané záznamy a po stisku přehled označených se mu zobrazí kompletně všechny označené záznamy ze všech výběrů.

1/ Je možné měnit vlastnost systémová při nastavením parametru 'Povol_zmenit_priznak_syst_predlohy=1' v sekci 'Preferences' souboru BW.INI.

2/ U předlohy označené jako systémová je možné měnit její vlastnosti - druh předlohy, profil předlohy, skrytá, skrytá všem. Importem balíčku při přepisu existující předlohy (provádí se v případě, že datum a čas poslední změny původní předlohy je menší nebo roven datu poslední změny importované předlohy) se tyto informace zachovávají.

3/ Uživatel má s touto verzí přístupné vlastnosti předlohy i v případě, že se jedná o předlohu druhu, ke které má pouze právo čtení. V tomto případě nemá přístupné všechny záložky formuláře vlastností a může měnit pouze atribut 'skrytá'.

[10] [3] Funguje pouze vysloveně na heslo správce, nefunguje při přihlášení uživatele, který má „práva jako správce“.

[11] V tuto chvíli je nutno upozornit implementátory, že při definici seskupování (atributy SELECT, GROUP a HAVING) v předlohách výstupu nad určitou činností může nastat situace, že v kombinaci s použitým obecným výběrem nad danou činností nebudou tyto sestavy fungovat. A tato situace nastane v okamžiku, kdy implementátor ve výrazu obecného výběru použije programový kód FoxPro uvedený příkazem .post script. Je velmi obtížné pak tyto sestavy a obecný výběr sladit dohromady, resp. pokud se na to implementátor nesoustředí již při jejich definování, je vlastně nemožné je potom sestavit.

[12] Definice multipásových sestav je činnost vhodná pro skutečně pokročilé uživatele. Ostatní uživatelé se při potřebě definice takové sestavy mohou obrátit na svého implementátora.

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 18.09.2014


Slovník pojmů

SLOVNÍK POJMŮ představuje pro uživatele „základní příručku“ ke každé složce dokumentace informačního systému Bílý Motýl (např. procesy, ovládání apod.). Jednotlivá hesla ve slovníku jsou řazena abecedně a hypertextové odkazy jsou zpracovávány tak, že v každém popsaném hesle je hypertextový odkaz na určitý pojem vytvořen pouze jedenkrát (např. pokud je tedy pod heslem diagram procesu v popisu několikrát použito heslo proces, je v textu vytvořen pouze jeden hypertextový odkaz na heslo proces).

Toto opatření je proto, aby slovník pojmů nebyl „jeden souvislý“ hypertextový odkaz a uživatel se při jeho čtení zbytečně neztrácel a nespouštěl si stejné heslo několikrát.

Pro seznámení se se slovníkem pojmů se jako nejvhodnější způsob jeví elektronická podoba. V některých případech je odkaz vytvořen na hesle, které nekoresponduje přesně s heslem ve slovníku pojmů, přičemž pojmově se jedná o shodná hesla, ale v textové podobě a listováním v dokumentaci toto uživatel nenajde. V elektronické podobě se uživatel pohodlně mezi jednotlivými hypertextovými odkazy přepíná a šipkou vrací zpět k původnímu heslu, což je jistě mnohem příjemnější a efektivnější způsob práce.

Seznam pojmů

A

AAA

Aktér

Aktivní okno

Aktivovat

Aktualizace dat

Aktuální datum uživatele

Aktuální hodnota

Aktuální hodnoty sprav. majetku

Aktuální záznam

Algoritmy předplňování a validace artiklu

Algoritmy vymáhání

Algoritmy výpočtu protokolu

Alokace

Analytický účet

Analýza dat

Archivace

Artikl

Artikly výroby

Atribut

Atribut parametry ve výkazech

Automatické přihlášení do BM

Automatizace vstupu událostí

Autorizace

B

Balíček

Bankovní spojení

BM-funkce pro SQL

Buňka definice listu

BWLCL.INI

C

Cash flow

Cena celkem

Cena celkem upravená

Cena skladová

Ceník

Cenová období

Cenová skupina pro výpočet vzrůstového přírůstku

Cenové skupiny

Cílový uzel

Cizí klíč

Cizojazyčnost v předlohách výstupu

Č

Části dne obecného kalendáře

Činnost

Číselná řada procesů

Čistá mzda

D

Další informace k pracovnímu poměru

Další informace karty

Daň ze mzdy

Daňová zvýhodnění

Daňové přiznání DPH

Daňové tabulky souhrnné

Daňový doklad

Daňový odpis

Data uživatele (aplikační data)

Databáze

Databázový model

Datové úložiště

Datový model

Datový tok

Dávková zpracování

Dávky nemocenského pojištění

Definice listu výkazů

Definice maker

Definice mzdových položek

Definice uspořádání položek výstupu

Definice uzlů informačního panelu

Definice výkazu

Definice vyvolání

Definiční data

Definování typu kategorie adresáta

Deklarovaná menu

Design

Diagram procesu

Dialogové okno

Dialogové okno tisku předlohy výstupu

Dodatečné daňové přiznání

Doklad

Dokumentace IS

Dokumenty

Dokumenty - správa

Dokumenty – přehled o použití dokumentů

Dokumenty – verze

Dolní lišta

Doplněná okna

Doplnění mřížky formuláře

Doplnění výběrové záložky formuláře

Doplňující položky menu objektů

Doplňující vlastnosti formuláře

Dotaz výkazu

Drag & Drop (Táhni a pusť)

Druh artiklu

Druh dokumentu

Druh doplňující vlastnosti formuláře

Druh hodnoty

Druh operace

Druh procesu

Druh předlohy

Druh vazby

Druh vazby – bez výběru

Druh vazby – s výběrem

Druh volné karty

Druh výkazu

Druhy adresátů

Druhy objektů

Druhy uzlů informačních panelů

Duplicita

Dynamická spojení operací

Dynamický combobox

E

Editor uzlů informačních panelů

ELDP

Elektronická komunikace ve mzdách

Elektronické přiznání DPH

Elektronický podpis

Entita

EORI

EVIVYK - popis programu

Export

Export webovou službou

Externí příkazy

F

F2 reakce

Firewall

Formát buňky

Formulář

FTP server

Funkce automatického dokončování

Funkce IS

Funkce v EV verzi

Funkce v SQL databázi

Funkce výkazů

Fyzický proces

G

Generování úkolů zakázky

H

Harmonogram výroby (nový)

Hash heslo uživatele

Historie ceny

Historie karty a pracovního poměru

Hlavní kniha

Hlavní menu

Hlavní menu – horní lišta

Hlavní menu – panel nástrojů

Hlavní proces

Horní lišta

Hrubá mzda

HTTP

Hypertextové odkazy - informační panely

C

Charakter operace

Charakter operace – dávková, dávková unikátní

I

Identifikace procesu

Identifikátor

IDP (identifikace párování)

Ikony oken v programu BM

Implicitní web menu

Import

Import – konverze atributů

Import – záložka „definice importu/exportu

Import – záložka „proměnné importu/exportu

Individuální odpis

Informace stromu pro druh operace

Informační centrum (IC)

Informační panely

Informační schopnost

Informační systém (IS)

Informační technologie (IT)

Inicializace

Inicializace hesla

Interakce procesů

J

Jazyk

Jednoznačná časová identifikace

K

Kalendář

Kalendář FPD

Kalendáře směn výroby

Kalkulační jednice

Kalkulační vzorec

Kalkulátor

Karta odpisovaného majetku

Karta pracovníka

Karty pohledávek

Karty spravovaného majetku

Katastr nemovitostí

Katastrální mapa

Katastrální úřad

Katastrální území

Kategorie adresátů

Kategorie dokumentů

Kategorie spojení adresáta

Kategorie zvířat

Každý uživatel systému

Klasifikace objektu

Knihovny ELDP

Knihovny vkládaného kódu

Kód funkce výkazů

Kód po ukončení operace

Komentář

Komponenta

Komunikace s jinými systémy

Kontingenční tabulka

Kontrola dat před zápisem

Kontrola překlepů

Konvertor Winword

Konverze pro štítek

Korektor transformovaných dat

Krmný den

Kupní smlouva

Kurzor

L

Label (tučný nadpis – návěští atributu)

Label – Téma

Legislativní konstanty

List vlastnictví

Logické tiskárny

M

Mailmerge (hromadná korespondence)

Mapa přístupových práv

Mapy

Masky operace

Materialized View

Menu

Měsíční nezdanitelné položky

Message

Metapředloha výstupu

Mimořádný odpis

Minimální mzda

Míra plnění

Množství v MJ - pomocné

Množství v RMJ

Modální okno

Multiverze v IS BM

Mzda - její složení a formy

N

Nabídka aktivních oken

Nabídky

Napojení do procesu

Napojení ULR na atribut

Nápověda

Nastavení – Souvislosti objekt

Nastavení okna úloh

Nastavení programu BM

Nastavení stromu

Navazující dokument

Navigační list definice listu výkazů

Návrhář sestav FoxPro (Report Designer)

Nehmotný majetek

Nemovitost

Nepřítomnost

Nepřítomnost pro nemoc (do minulosti)

Nespolehlivý plátci

Neviditelné atributy

Nový proces

O

Obecná předkontace

Obecná předkontace v maskách

Obecná předkontace v transformacích a v šablonách

Obecné – v menu horní lišty

Obecné kalendáře

Obecné parametry

Obecné stromy

Obecný výběr

Objekt

Objektová vazba

Oblíbené skupiny uživatelů

Obratové hodnoty

Obraty skladu

Obrazovka uživatele

Odblokovač

Odesílání e-mailů z IS BM s použitím objektu Outlooku

Odpisovaný majetek

Odpisové skupiny

Odpisy

Odpisy a opravné položky pohledávek

Odvozená menu

Okno

Okno úloh

Opakovat vstup

Operace (druh operace)

Oprava dat

Opravné daňové přiznání

Opravné položky

Oprávnění k činnostem

Optimalizovaný výpočet mezd

Optimalizovaný výpočet mezd jednoho pracovníka

Osobní skupina předlohy výstupu

Osobní údaje

Ošetřovné

Otevřená období komponent

Otevření účetních knih

Ovládání diagramu procesu

Ovládání formulářů (mřížek)

Ovládání pomocí web browseru

Označování

Označování podle kategorií

Označování výrazem

P

Palety barev kategorií

Palety barev kategorií adresátů

Panel nástrojů

Panel nástrojů v okně činnosti výstupy

Parametr funkce výkazů

Parametry a číselníky

Parametry adresáře

Parametry formuláře

Parametry mezd

Parametry nemocenského pojištění

Parametry oceňování

Parametry odpisovaného majetku

Parametry operace komponenty

Parametry plateb

Parametry skladu zvířat

Parametry TPV

Parametry účetnictví

Parametry uživatele

Parametry výkazů

Parcelní číslo

PDA zařízení

PDF formát

Penalizace

Penzijní připojištění

Personalistika

Personifikace

Podvojnost

Pohled (slovníku dat)

Pohledávka

Pohyblivé složky mzdy

Položka výstupu dle předlohy

Pomocné slučování

Popis archivací

Popis jazyka generátoru sestav

Pořadí

Postupy vymáhání

Pozemky

Pracovní funkce

Pracovní místa

Pracovní poměr

Pracovní výkony

Pracovníci

Pravé tlačítko myši na činnosti hlavního menu

Pravidelné příjmy

Pravidla inicializací přístupových práv

Pravidla transformace

Prezentace artiklu, dokumentů

Prezentace procesů

Prezentace stránek informačního panelu

Primární klíč

Procedures & Functions

Proces

Procesní import

Procesy adresáta

Profily spuštění předlohy

Prognózování odpisů

Programový adresář

Prohlížení archivu

Projektové řízení

Projektové úkoly

Proměnná dotazu

Proměnné daňového přiznání

Propojené (vložené) objekty

Prostředí pohledu (slovníku dat)

Protokol mezd

Průběh operací

Prvek web

Přecenění Z/P v cizí měně koncem roku

Předkontace adresáta

Předloha dokumentu

Předloha výstupu

Předloha výstupu - proces

Předloha výstupu typu – Excel

Předloha výstupu typu – sestava a ostatní

Předloha výstupu typu – Word

Předmět projektu

Předměty zdanitelného plnění

Předplnění adresáta podle ARES

Předplnění bankovních účtů dle registru plátců DPH

Přehled nerozpočteného

Přehled přihlášených (SQL)

Přehled vstupů a výstupů výroby

Přehled změn záznamů tabulek

Překlad popisek

Překlad popisek - název předlohy

Překlad textů

Překryvný seznam

Přepočet hodnot

Přepočet obratové tabulky

Přepočet práv přístupu

Přepočet účetního saldokonta

Přihlášení

Přihlášení do informačního systému

Přihlášení k terminálu

Přihlášení uživatelé

Příjmy a náhrady

Příkaz „dyn“ v parametrech řádku nebo sloupce definice listu výkazů

Přílohy k předloze

Připojené okno

Příprava definice listu výkazů pomocí vzoru listu

Přístupová práva

Přístupová práva - alokace

Přístupová práva – druh informace

Přístupová práva – operace

Přístupová práva – proces

Přístupová práva k věcem s přístupem

Přístupové heslo

Přístupy k věcem

Půjčky, srážky, exekuce

Q

QUICK info

R

Referenční artikl výroby

Referenční integrita

Referenční měna

Referenční proces

Relační model

Replikace

Rezervace majetku

Rezervované zdroje systému

Režim oprav

Roční nezdanitelné položky

Roční zúčtování daně

Rovnoměrné odepisování

Rozlišení

Rozpočítávat množství

Rozvaha

Rušení dat

Rušení událostí komponent

Rychlý výstup

Ř

Řádek definice listu výkazů

Řídící tok

S

Sada vzdálených funkcí

Sady parametrů

Sady systémových konstant

Sady vzdálených funkcí - nastavení

SAI (Systém automatické identifikace)

SAI - Automatické ukončování dokladu

SAI - BMClientService

SAI - Čtečka čárového kódu

SAI - Doklad

SAI - Druhy etiket

SAI - Emulátor

SAI - Etiketa

SAI - Funkce CKCONV

SAI - Identifikátor reprezentující objekt reálného světa

SAI - Kódování čárového kódu

SAI - Objekt reálného světa

SAI - Předpis pohybu

SAI - Převod mezi buňkami

SAI - Snímání čárového kódu

SAI - Terminál

SAI - Tisk čárového kódu

SAI - Tiskárny pro potisk etiket

SAI - Vyskladňovací / naskladňovací cesta

SAI - Zdroj

Saldokontní hodnoty

Saldokonto

Selektor

Semafor procesu

Sériové číslo programu

Sestavení výkazu

Seznam

Seznam použitelných tool

Signalizace zprávy - úkolu

SKP

Skupina předlohy výstupu

Skupina uživatelů

Skupinová položka hlavního menu

Skupinový účet

Skupiny procesů/předloh výstupu

Skutečné pracovní místo

Sledování verzí impl. rozšíření

Sledování změn v záznamech tabulek IS BM

Sloupec definice listu výkazů

Slovník dat (SD)

Slučování adresátů

Směrná účtová osnova

SMTP

SOAP

Socialní pojištění

Sociální pojišťovny

Software - programový kód

Souhrnné hlášení

Specifická práva správce

Spojené dokumenty – Ctrl D

Spojení adresátů v událostech komponent

Spojení importů-exportů

Spouštěné aplikace

Spouštět

Správce

Spravovaný majetek

Spustit činnost

Spuštění archivace

SQL

Stáj (umístění)

Statická podmínka

Statistická hodnota

Stav operace (uzlu)

Stav programu BM uživatele

Storno

Stránka informačního panelu

Strom adresáta

Strom hlavního procesu

Strom pracovníka

Strom vývěsky

Substituce DPH

Superhrubá mzda

Syntetický účet

Systémový certifikát

Š

Šablona

Šablona listů výkazů

T

Technické zhodnocení

Technologické operace

Technologické postupy

Test mírou plnění

TIFF formát

Tisk zjednodušených dokladů

Toolbar

Tooltip

Transformace

Trigger, uživatelský trigger

Třída pohledu (slovníku dat)

Třídění

Turnus

Typ ceny

Typ prvku webu

Typ prvku webu: list - adresa

Typ prvku webu: list - slovník dat

Typ seznam hodnot užívaných ve výkazech

Typ zdanitelného plnění

Typové pracovní místo

Typy událostí komponent

Typy zdanitelného plnění

Ú

Účetní deník

Účetní období

Účetní odpis

Účetní případ

Účetní výkazy

Účetní zápis

Účetní závěrka

Účtová skupina

Účtový rozvrh

U

Událost

Události vymáhání

Uchovat

Uchovávat pozici oken

Ukončení činnosti

Ukončení operace

Ukončení procesu

Ukončení uzlu

Uložená procedura

ULR odkazy v tabulkách

Umístění

Update v importu/exportu

Uplatnění předmětů zdanitelného plnění

Uvedení uzlu do stavu připravena

Uzávěrka mezd

Uzavření účetních knih

Uzel procesu

Uzly vývěsky

Uživatel (informačního systému Bílý Motýl)

Uživatel (obchodní partner BM Servis s.r.o.)

Uživatelé programu

V

V prohlížeči výstupů předloh

Validace dat

Validace IČO

Variabilní symbol

Vazba objektů

Vazba uzlů procesu

Vazby míry plnění

Věc s přístupem

Věcné břemeno

Vlastnosti atributu v návrháři sestav

Vlastnosti činnosti, skupiny

Vlastnosti definice menu

Vlastnosti dokumentu

Vlastnosti hlavního menu

Vlastnosti operace

Vlastnosti předlohy

Vlastnosti uzlu diagramu procesu

Volby – z menu horní lišty

Volná karta - definice

Volná karta - užití volné karty

Volná karta – aktivace

Volná karta – atributy volné karty

Volná karta – volné pohledy

Volná karta adresáta

Volná karta artiklu

Volná karta operace

Volná karta procesu

Volná karta vazby objektů

Volné údaje

Vstup dat

Vstupní atributy komponenty

Výběr položek výstupu

Výběr vstupem

Výběrová řízení

Výčetky platidel

Vyhledávání

Výkaz zisků a ztrát (výsledovka)

Výkazy

Výkazy - zaokrouhlování

Vymáhání

Výměra pozemku

Výplatní lístek

Výpočet daňového přiznání

Výpočet KD

Vypočtená daňová přiznání

Výraz

Výraz obecného výběru

Výraz užívaný ve výkazech

Výraz vzoru listů výkazů

Výrobní linky a stroje

Výrobní úkoly

Výstupní atributy komponenty

Výstupní soubor výkazu

Výstupy

Výstupy procesů

Výstupy v rámci činností IS BM

Význam

Vzdálené funkce - nastavení

Vzdálený uživatel (informačního systému Bílý Motýl)

Vzor listů výkazů

Vzor výstupu

Vzorec užívaný ve výkazech

Vzrůstový přírůstek

Vztahy obchodovatelných artiklů k adresátům

Vztažené artikly

W

Web browser

Web menu

Webové rozhraní

Webové služby

Webový server

WI-FI

X

XML

XML dokumenty

Z

Zablokování IS

Zahraniční měna

Zakázky výroby

Základní definice menu

Záložka

Záložka – deklarace

Záložka – doplnění

Záložka – info

Záložka – na uzlu

Záložka – obecné

Záložka – popis

Záložka – seskupování

Záložka – setřídění

Záložka – Výběr

Zápočet krmných dnů

Zařazení do skupin uživatelů

Zásobník operací

Závazek

Zdaňovací období DPH

Zdravotní pojištění

Zdravotní pojišťovny

Zdrojový uzel

Změna stavu peněz

Změny spravovaného majetku

Zpracování skriptů

Zpráva

Zprávy databázového serveru

Zrcadlové storno

Zrušit stav ukončena

Zrychlené odepisování

Zvíře

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.10.2015


Pojem - AAA

Zkratka pro základní entity komponenty (Aktér, Artikl, Alokace), které modelují logické věci reálného světa. Mohou být propojeny na selektory, které se následně automatizovaně předplňují programovým kódem dle AAA v událostech komponent. Z hlediska objektových vazeb jsou objekty.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.01.2013


Pojem - Aktér

Pod pojmem aktér si můžeme představit adresáta nebo pracovníka. Základní adresát je vždy spojen s adresářem. Kromě adresáře je v různých komponentách spojen i s dalším údajem, např. v komponentě pošta je adresát spojen ještě s adresou, v komponentě platby s id bankovního spojení, v komponentě obchod s id spojení apod. V komponentě mzdy je aktérem pracovník, který je s adresářem spojen přes id adresáta. V případě, že by došlo k situaci, že stejného adresáta si uživatel do adresáře vloží několikrát (tomuto lze předejít aktivováním validace parametrech adresáře) je možno využít činnost slučování adresátů.

Aktér patří k základním entitám komponent, která je pro většinu komponent společná. V některých komponentách je základní entita doplněna dalším údajem (id bankovního spojení, id spojení, id adresy). Aktér je objektem z hlediska objektových vazeb.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 02.11.2007


Pojem - Aktivní okno

Jedná se o okno činnosti, která je v daný okamžik aktivní, tzn. horní lišta činnosti je zvýrazněná (tj. vysvícená) a pod menu Volby a Obecné se nabízejí činnosti, které jsou dostupné právě pro tuto činnost v okně.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 18.12.2012


Pojem - Aktivovat

Informační systém Bílý Motýl je aplikace Windows. Jako taková umožňuje uživateli mít otevřen libovolný počet oken s jednotlivými činnostmi a mezi těmito okny se podle potřeby přepínat. Každé přepnutí do vybraného okna způsobí, že okno se stane aktivním (čili horní lišta okna činnosti je zvýrazněna). Aktivovat tedy znamená vybrat si mezi již spuštěnými okny a vybrané okno uvést do aktivního stavu, nikoliv okno spustit.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 02.11.2007


Pojem - Aktualizace dat

Aktualizace dat znamená, že v určitém okamžiku dochází ke změně aktivních dat. Změny mohou být prováděny automaticky (přepisem šablonou, importem apod.) nebo ručně na základě potřeb uživatele. Aktualizace dat může probíhat v IS BM různými způsoby a to jsou:

¨ vstup dat

¨ oprava dat

¨ rušení dat

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 02.11.2007


Pojem - Aktuální datum uživatele

Tam, kde programový kód předplňuje datum, je v některých případech (zejména v událostech) systémové datum přepsáno tímto datem. Aktuální datum uživatele se definuje v činnosti Systém – Parametry uživatele a je součástí personifikace IS. Pokud si uživatel pro svoji potřebu změní systémové datum právě tímto aktuálním datem, je toto nastavené aktuální datum platné po dobu aktuálního přihlášení uživatele. Při dalším přihlášení je platným datem opět systémové datum uvedené v počítači.

Aktuální datum uživatele lze získat pomocí funkce: tool.currdate(), v případě výrazu užívaného v transformaci je nutné jej uvést dvěmi vlnovkami.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 24.06.2014


Pojem - Aktuální hodnota

Aktuální hodnoty daného druhu jsou dostupné ve všech komponentách a poskytují uživateli informace o aktuálním stavu v daném okamžiku. Jejich členění dle AAA je definováno u druhu hodnoty. Např. v komponentě sklad jsou to aktuální hodnoty skladu (množství v naturální jednotce, finanční hodnota - dle Alokace a Artiklu bez členění dle Aktéra), v komponentě obchod aktuální hodnoty obchodu (nakoupeno, tržby) apod.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Aktuální hodnoty sprav. majetku

Aktuální hodnoty poskytují uživateli přehled o jednotlivých hodnotách na kartách spravovaného majetku. Nejčastější aktuální hodnota, která se u sprav. majetku sleduje je jeho vyjádření ve finančním množství. Uživatel si výběrem může nadefinovat různý pohled na aktuální hodnoty, např. za umístění, adresáta apod.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 01.11.2012


Pojem - Aktuální záznam

Jedná se o záznam, na kterém je právě umístěn kurzor. Pokud se v terminologii IS BM uvede, že informace se vztahují k právě aktuálnímu záznamu, znamená to, že v jedné části okna činnosti je kurzor umístěn na daném záznamu (tím je záznam aktuální) a v druhé části okna činnosti se uživateli zobrazují informace právě k tomuto záznamu. Posunem kurzoru po jednotlivých záznamech se pak zároveň mění i informace k těmto záznamům.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 07.08.2008


Pojem - Algoritmy předplňování a validace artiklu

Činnost „druh artiklu“ obsahuje vlastnost "Algoritmus předplnění a validace". V překryvném seznamu je možné stanovit pro druh artiklu algoritmus, podle kterého bude předplněna identifikace artiklu při vstupu nového artiklu daného druhu a validován vstup nového artiklu. Funkčnost předplnění a validace identifikace artiklu je v tomto okamžiku realizovaná ve všech formulářích artiklů v výjimkou formulářů:

¨ artikly bibliografie

¨ artikly aukčního domu

¨ nemovitosti

¨ artikly mezd

Algoritmy se definují činností nazvanou "Algoritmy předplnění a validace artiklu", která se nachází v menu Informační centrum – Správa artiklu. V jejím formuláři se uvádí:

¨ název algoritmu

¨ kód předplnění - text - skript v jazyce Foxpro, který se uplatní při zakládání nového artiklu daného druhu pro předplnění jeho identifikace

¨ kód validace - text - skript v jazyce Foxpro, který se uplatní při zakládání nového artiklu daného druhu pro validaci jeho identifikace

¨ poznámka - libovolný text

V kódu předplnění jsou k dispozici proměnné:

_ALIAS - text - alias kurzoru formuláře, ve kterém je artikl vstupován

_SP61ID - text - druh artiklu, který je vstupován

Kód musí vracet hodnotu typu text, kterou bude předplněna identifikace artiklu

V kódu validace jsou k dispozici proměnné:

_ALIAS - text - alias kurzoru formuláře, ve kterém je artikl vstupován

_SP61ID - text - druh artiklu, který je vstupován

_SP60ID - text - identifikace artiklu, který je vstupován

Kód musí vracet logickou hodnotu .T. (TRUE) nebo .F. (FALSE)

V souvislosti s touto novou funkčností je k dispozici knihovna vkládaného kódu SYSAR1, která obsahuje mj. uživatelské funkce:

1. ID_ARTIKLU

Tato funkce vrací identifikaci nového artiklu podle užitých parametrů:

_ALIAS - text - alias kurzoru formuláře, ve kterém je artikl vstupován (užije se proměnná _ALIAS)

_PREFIX - text - proměnný text užitý na začátku identifikace artiklu (např. rok)

_CIFER - číslo - počet cifer pořadového čísla artiklu stejného druhu se stejným prefixem a postfixem - počet cifer+délka prefixu+délka postfixu nesmí být větší než 13

_POSTFIX - text - proměnný text užitý na konci identifikace artiklu - tento parametr není povinný

2. VALID_ARTIKLU

Tato funkce vrací identifikaci nového artiklu podle užitých parametrů:

_ALIAS - text - alias kurzoru formuláře, ve kterém je artikl vstupován (užije se proměnná _ALIAS)

_PREFIX - text - proměnný text musí být užitý na začátku identifikace artiklu (např. rok)

_CIFER - číslo - počet cifer pořadového čísla artiklu stejného druhu se stejným prefixem a postfixem - počet cifer+délka prefixu+délka postfixu nesmí být větší než 13

_POSTFIX - text - proměnný text musí být užitý na konci identifikace artiklu - tento parametr není povinný

Omezení:

Vzhledem k programovému řešení nemusí obě popsané funkce správně fungovat, pokud se budou v hodnotě prefixu, resp. postfixu vyskytovat náhražkové znaky (wildcards) používané podmínkou LIKE v SQL dotazech Sybase SQL Anywhere (_, %, [, ]) a ve funkci LIKE() Visual Foxpro ( * , ? ).

Příklady použití knihovny SYSAR1:

1. identifikace artiklu obsahuje rok+pořadové číslo artiklu na 5 cifer

Kód předplnění:

RETURN id_artiklu(_alias,TRANS(YEAR(DATE()))+'-',5)

#INCLUDE SYSAR1

Vrátí identifikaci nového artiklu např. 2005-00025

Kód validace:

RETURN valid_artiklu(_alias,TRANS(YEAR(DATE()))+'-',5)

#INCLUDE SYSAR1

Vrátí logickou hodnotu .T. v případě, že má identifikace artiklu odpovídající strukturu včetně hodnoty prefixu

2. identifikace artiklu obsahuje pořadové číslo artiklu na 7 cifer (bez prefixu a postfixu)

Kód předplnění:

RETURN id_artiklu(_alias,'',7)

#INCLUDE SYSAR1

Vrátí identifikaci nového artiklu např. 0000123

Kód validace:

RETURN valid_artiklu(_alias,'',7)

#INCLUDE SYSAR1

Vrátí logickou hodnotu .T. v případě, že má identifikace artiklu odpovídající strukturu

3. identifikace artiklu obsahuje rok a měsíc+pořadové číslo artiklu na 4 cifry

Kód předplnění:

RETURN id_artiklu(_alias,LEFT(DTOC(DATE(),1),6)+'-',4)

#INCLUDE SYSAR1

Vrátí identifikaci nového artiklu např. 200507-0101

Kód validace:

RETURN valid_artiklu(_alias,LEFT(DTOC(DATE(),1),6)+'-',4)

#INCLUDE SYSAR1

Vrátí logickou hodnotu .T. v případě, že má identifikace artiklu odpovídající strukturu včetně hodnoty prefixu

4. identifikace artiklu obsahuje rok + identifikaci datového úložiště+pořadové číslo artiklu na 5 cifer

Kód předplnění:

RETURN id_artiklu(_alias,TRANS(YEAR(DATE()))+'-'+RIGHT(tool.user,2)+'-',5)

#INCLUDE SYSAR1

Vrátí identifikaci nového artiklu např. 2005-01-40501.

Kód validace:

RETURN valid_artiklu(_alias,TRANS(YEAR(DATE()))+'-'+RIGHT(tool.user,2)+'-',5)

#INCLUDE SYSAR1

Vrátí logickou hodnotu .T. v případě, že má identifikace artiklu odpovídající strukturu včetně hodnoty prefixu

5. identifikace artiklu obsahuje pořadové číslo artiklu na 5 cifer + identifikaci datového úložiště

Kód předplnění:

RETURN id_artiklu(_alias,'',5,'/'+RIGHT(tool.user,2))

#INCLUDE SYSAR1

Vrátí identifikaci nového artiklu např. 00045/05

Kód validace:

RETURN valid_artiklu(_alias,'',5,'/'+RIGHT(tool.user,2))

#INCLUDE SYSAR1

Vrátí logickou hodnotu .T. v případě, že má identifikace artiklu odpovídající strukturu včetně hodnoty postfixu

6. identifikace artiklu obsahuje rok,měsíc a den+pořadové číslo artiklu na 4 cifry

Kód předplnění:

RETURN id_artiklu(_alias,DTOC(DATE(),1)+'-',4)

#INCLUDE SYSAR1

Vrátí identifikaci nového artiklu např. 20050713-0101

Kód validace:

RETURN valid_artiklu(_alias,DTOC(DATE(),1)+'-',4)

#INCLUDE SYSAR1

Vrátí logickou hodnotu .T. v případě, že má identifikace artiklu odpovídající strukturu včetně hodnoty prefixu

Doporučení:

Konstruovat názvy algoritmů tak, aby odpovídaly tvaru předplňované hodnoty např. pro příklady:

ad 1. RRRR-NNNNN

ad 2. NNNNNNN

ad 3. RRRRMM-NNNN

ad 4. RRRR-DU-NNNNN

ad 5. NNNNN/DU

ad 6. RRRRMMDD-NNNN

Zde je obsah knihovny SYSAR1 pro inspiraci v případech, kdy její funkčnost nebude dostatečná:

PROCEDURE id_artiklu

LPARAMETERS _alias,_prefix,_cifer,_postfix

LOCAL _sp61id,_sp60id1,_sp60id2,_mezer,_limit1,_limit2,_maska

* Následující komentáře jsou pro příklad skutečných parametrů _PREFIX=TRANS(YEAR(DATE()))+'-' a _CIFER=4

* Identifikace artiklu bude vypadat RRRR-NNNN, kde RRRR je rok a NNNN je pořadové číslo v roce

* v proměnné _ALIAS je aktuálně alias kurzoru do kterého jsou vstupována data

IF EMPTY(_postfix)

_postfix=''

ENDIF

SELECT (_alias)

_sp61id=sp61id

_mezer=LEN(sp60id)-LEN(_prefix)-_cifer-LEN(_postfix)

* limitní identifikace artiklu od RRRR-0000

_limit1=_prefix+REPLICATE('0',_cifer)+_postfix+SPACE(_mezer)

* limitní identifikace artiklu od RRRR-9999

_limit2=_prefix+REPLICATE('9',_cifer)+_postfix+SPACE(_mezer)

* maska vyloučí artikly např. RRRR-NNNNNN, ale ne RRRR-NNN nebo RRRR-NABC (to udělá uživatelská funkce jsou_tam_cifry)

_maska=_prefix+REPLICATE('?',_cifer)+_postfix+SPACE(_mezer)

* dotaz do kurzoru, protože mohou být vstoupeny artikly, které nejsou zatím zapsány na server

CALCULATE MAX(sp60id) TO _sp60id1 FOR sp61id=_sp61id AND BETWEEN(sp60id,_limit1,_limit2) AND ;

LIKEC(_maska,sp60id) AND jsou_tam_cifry(sp60id,_maska)

* maska vyloučí artikly např. RRRR-NNNNNN ale i RRRR-NABC

_maska=_prefix+REPLICATE('[0-9]',_cifer)+_postfix+SPACE(_mezer)

* dotaz na server do tabulky SPARTIKL, protože ne všechny artikly musí být aktuálně v kurzoru

_sp60id2=tool.sql_dotaz([select max(sp60id) from %%%.spartikl where sp61id=?_p1 and ]+;

[sp60id between ?_p2 and ?_p3 and sp60id like ?_p4],_sp61id,_limit1,_limit2,_maska)

IF _sp60id1<_sp60id2

* dotazem na server bylo zjištěno větší pořadové číslo

_sp60id1=_sp60id2

ENDIF

IF EMPTY(_sp60id1)

* jedná se o první artikl s prefixem daného roku

RETURN _prefix+REPLICATE('0',_cifer-1)+'1'+_postfix

ELSE

* vrací zvýšené pořadové číslo v roce

RETURN _prefix+PADL(LTRIM(STR(VAL(STUFF(_sp60id1,1,LEN(_prefix),''))+1)),_cifer,'0')+_postfix

ENDIF

PROCEDURE jsou_tam_cifry

LPARAMETERS _sp60id,_maska

* vrací TRUE pokud na pozicích všech otazníků v masce jsou cifry

LOCAL _i

FOR _i=1 TO MIN(LEN(_sp60id),LEN(_maska))

IF SUBSTR(_maska,_i,1)='?' AND !ISDIGIT(SUBSTR(_sp60id,_i,1))

RETURN .F.

ENDIF

ENDFOR

RETURN .T.

PROCEDURE valid_artiklu

LPARAMETERS _alias,_prefix,_cifer,_postfix

LOCAL _mezer,_maska,_sp60id

_sp60id=EVALUATE(_alias+'.sp60id')

IF EMPTY(_postfix)

_postfix=''

ENDIF

_mezer=LEN(_sp60id)-LEN(_prefix)-_cifer-LEN(_postfix)

_maska=_prefix+REPLICATE('?',_cifer)+_postfix+SPACE(_mezer)

RETURN LIKEC(_maska,_sp60id) AND jsou_tam_cifry(_sp60id,_maska)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 13.06.2014


Pojem - Algoritmy vymáhání

Tato činnost umožňuje uživateli nadefinovat, opravovat a rušit algoritmy, které se pak uplatňují při vytváření událostí vymáhání. U každého algoritmu se zadává:

¨ identifikace a název vymáhání

¨ % penále

¨ postup – výběr z číselníku postupů vymáhání

¨ libovolná poznámka

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 11.11.2013


Pojem - Algoritmy výpočtu protokolu

Pro uživatele je tato činnost dostupná v menu Mzdy – Definice. Přímo souvisí s optimalizovaným výpočtem mezd. Při tomto výpočtu se vytváří „protokol“, který obsahuje hlášení o nalezených chybách nebo jiných informacích, které byly zjištěny během výpočtu. Tuto činnost je možno (a doporučeno jako vhodné) nastavit pomocí balíčku dat. I v případě, že uživatel nebude mít tuto činnost nastavenu, proběhne výpočet mezd správně.

Činnost obsahuje dvě záložky:

¨ záložka Algoritmy

¨ záložka Užití algoritmu

Na záložce „algoritmy“ má uživatel k dispozici následující údaje:

¨ identifikaci a popis hlášení

¨ druh (např. systémový)

¨ typ (volba Zabudovaný, Skript před výpočtem, Skript po výpočtu)

¨ kód

¨ poznámku

¨ aktualizaci (datum a čas)

Je-li nastaveno, že je typ „Zabudovaný“, jedná se pak o hlášení pevně zabudované v kódu vlastního výpočtu výplatního lístku.

Je-li nastaveno, že je typ „Skript před výpočtem“, jedná se pak o hlášení uživatelské, ke kterému se váže kód uvedený v atributu „kód“. Tento skript se provede hned na začátku výpočtu výplatních lístků.

Je-li nastavené, že je typ „Skript po výpočtu“, jedná se rovněž o hlášení uživatelské, ke kterému se váže kód uvedený v atributu „kód“. Tento skript se provede až na konci výpočtu výplatních lístků.

Záložka „užití algoritmu“ obsahuje tyto údaje:

¨ provádět (volba Ano/Ne)

¨ skrytá (volba Ano/Ne)

¨ stupeň (volba Informace, Chyba zpracování)

¨ barva písma, barva pozadí

¨ priorita

¨ poznámka

V následujícím odstavci se blíže vrátíme k významu jednotlivých atributů:

¨ provádět – je-li položka protokolu nastavena na Ano, pak se test provede a zapíše do protokolu. Je-li nastavena na Ne, pak se test sice provede, ale do protokolu se jeho výsledek nezapíše. Uživatel pak ale tímto nemá žádnou informaci o tom, že se testem případný problém zachytil, tzn. že volbu Ne je vhodné použít jedině u testů, kde uživatel jejich výsledky opravdu sledovat nechce. Správné nastavení „provádět – Ano/Ne“ je tedy klíčovým nastavením v celé činnosti, protože jak jsme se zmínili výše, je možno některé testy zcela vyřadit.

¨ skrytá – je-li položka protokolu nastavena na skrytá Ano, pak se ve výsledném protokolu výpočtu nezobrazuje. Je-li nastavena na skrytá Ne, pak se ve výsledném protokolu zobrazuje. Zobrazování je možno vyfiltrovat na záložce výběr v protokolu. Jedná se o jemnější formu nastavení než u atributu provádět, protože tímto nastavením uživatel test zcela nevyřazuje, pouze řídí zobrazování jeho výsledku ve výběru protokolu.

¨ stupeň – tento atribut řídí chování samotného běhu výpočtu. Při položce, která má stupeň „informace“ dojde k zápisu do protokolu a výpočet běží dál. Pokud se provádí výpočet pro všechny pracovníky, dojde k zablokování výpočtu pro další přepočítávání. Při položce, která má stupeň „chyba“ dojde k zápisu do protokolu a výpočet u pracovníka, který byl tímto testem zachycen tímto okamžikem končí. Nedojde k zablokování výpočtu pro další přepočítávání. Výplatní lístky pak tímto nejsou kompletní, zachycený problém musí uživatel vyřešit a následně pustit znovu výpočet.

¨ barva písma a barva pozadí umožňuje hlášení uživatelsky barevně zvýraznit

¨ atribut priorita určuje třídění jednotlivých položek protokolu

Standardní nastavení algoritmu výpočtu protokolu mezd je „provádět – Ano“, „skrytá – Ne“ a „stupeň – Informace“.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 02.11.2007


Pojem - Alokace

Pod pojmem alokace (tj. umístění) je možno si představit sklad, stáje zvířat, pokladnu, středisko, distribuční kanál apod. Jedná se o určení umístění té které komponenty, tzn. že alokace komponenty skladu jsou skutečně jednotlivé sklady, alokace komponenty sklad zvířat jsou skutečně jednotlivé stáje zvířat, alokace komponenty změny stavu peněz je např. pokladna a účet, alokace komponenty obchod jsou jednotlivá obchodní střediska apod.

Alokace patří k základním entitám komponenty. K jednotlivým alokacím lze definovat přístupová práva. Alokace je objektem z hlediska objektových vazeb.

Identifikace alokace je možno zadat i v maskách operací. Pokud je v masce operace uvedena alokace, ke které nemá uživatel nadefinováno přístupové právo, nepodaří se mu tuto operaci zapsat. Problém může nastat tehdy, pokud je v masce operace u alokace uvedeno nevstupovat (např. programový kód přepíše - má vyšší prioritu v automatizaci vstupu - sklad uvedený v masce skladem, kde je k dispozici zadaný artikl).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Analytický účet

V knihách analytických účtů jsou vedeny podrobné systematické (nebo-li věcné) účetní zápisy. Vzniká-li informační potřeba podrobnějších záznamů o jednotlivých aktivech a pasivech, nákladech a výnosech, zavádí se k jednotlivým syntetickým účtům podrobnější záznamy na účtech analytických.

Označení analytického účtu se obvykle skládá z označení odpovídajícího syntetického účtu a několika dalších číslic (v IS BM až 6, takže celková délka identifikátoru účtu v účetním rozvrhu může být až 9 číslic).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.09.2008


Pojem - Analýza dat

Analýzou dat zde rozumíme činnost organizace, ve které usiluje o to, aby z jednotlivých elementárních údajů uložených v IS, resp. v jeho tabulkách, byly selekcí a agregací dle řady pravidel, která často reprezentují know-how organizace, získány informace, které lze obvykle uplatnit při rozhodování v řízení organizace.

Analýza dat je součástí té části IS, která bývá nazývána manažerská část IS. IS BM ji podporuje zejména svou částí nazývanou výkazy, ale i slovníkem dat nebo analytickými schopnostmi výstupů v jednotlivých činnostech.

IS BM tuto činnost dále podporuje i v rovině přípravy (předzpracování dat) možností automatizace agregace dat dle selektorů, období a druhů hodnot.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 02.11.2007


Pojem - Archivace

Tato činnost se nachází v hlavním menu v činnosti Informační centrum – Utility – Archivace. Umožňuje uživateli vytvořit si jednotlivé definice archivací, kde si uživatel určí která data chce archivovat a jak často a kdy je chce archivovat. Archivují se především soubory template a banky (certifikáty apod.) a programy, které vyžadují externí uložení (např. soubory jiných systémů) nebo externě ukládané dokumenty. Jednotlivé vytvořené archivace má uživatel kdykoliv k dispozici. Pod menu Archivace jsou tyto činnosti:

¨ Spuštění archivace

¨ Prohlížení archivu

¨ Popis archivací

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.10.2009


Pojem - Artikl

Pod pojmem artikl je možno si představit výrobky, zboží, služby, materiál apod. V některých komponentách je artikl evidován „výskytově“, tj. každý „kousek“ individuálně (např. spravovaný majetek, odepisovaný majetek, …), v některých komponentách pouze „druhově“, tj. v události se eviduje množství, které je různé od 1 (např. obchod), v některých je na uživateli, zda zvolí „výskytovou“ či „druhovou“ evidenci (sklad – dle výrobního čísla), v některých je nevyjádřený (změna stavu peněz – referenční měna).

Každý jednotlivý artikl je zařazen do určitého druhu artiklu (tj. škatulka), kde se určují vlastnosti, které pak artikly daného druhu přejímají. Identifikace artiklu se skládá z identifikace druhu artiklu a identifikace artiklu, v některých komponentách je dále v identifikaci „verze“, resp. „pořadí“ a případně čárový kód a externí identifikace. U všech druhů artiklů se kromě identifikace a názvu artiklu definují ještě další údaje, jako vztah k účetnictví, vztah ceny k DPH, charakter a typ zdanitelného plnění a zda se jedná o artikl skladovaný či neskladovaný.

V činnosti Druhy artiklů je důležitou záložkou „výskyt druhu artiklu”. Ta určuje, do jakých dalších komponent se má při zadávání v jedné komponentě ještě daný artikl automaticky zapsat. Automaticky toto funguje pouze při zadávání druhu artiklu v jednotlivých komponentách. Zde nelze míchat artikly principielně odlišné (viz. výskytová a datová evidence).

Artikl patří k základním entitám komponenty. Artikl je objektem z hlediska objektových vazeb.

Mnohdy platí, že artikly daného druhu jsou evidovány ve vztahu k dané alokaci, pak lze s úspěchem použít v masce či transformaci obecnou předkontaci pro předplnění alokace, dále jsou zprostředkovaně k dispozici přístupová práva k druhu artiklu (tj. dle alokace).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.04.2004


Pojem - Artikly výroby

Činnost artikly výroby soustřeďuje všechny artikly, které vystupují jako vstupy a výstupy výroby. Mezi typické artikly patří materiál, polotovary, výrobky a pracovní výkony.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.01.2008


Pojem - Atribut

Atribut je vlastnost, v rámci terminologie týkající se IS, určité entity. V obecném pohledu může být definován pomocí popisné entity, vazební entity nebo elementárním údajem (položka struktury tabulky).

V rámci této dokumentace se obvykle jedná o elementární údaj. Druhy atributů jsou dány možnostmi databáze Sybase SQL Anywhere, např.:

¨ C – např. adresát v komponentě obchod – atribut ad01id (výraz typu „charakter“, tj. znakový)

¨ N – např. množství v komponentě obchod – atribut ob02mn (výraz typu „numerický“, tj. číselný)

¨ D – např. datum v komponentě obchod – atribut ob02dat (výraz typu „datumový“)

¨ T – např. informace o datu a času zápisu události – atribut sp00datzap (výraz typu „time“, tj. časový)

¨ M – např. poznámka v komponentě obchod – atribut ob02koment (výraz typu „memo“, tj. volný text)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Atribut parametry ve výkazech

Tento atribut typu memo je určen k uživatelské definici přiřazení hodnoty parametrům, přiřazení hodnoty pojmenovaným textům uvedených v šabloně ( nadpis listu, …), přiřazení názvu záložce listu nebo k uvedení komentáře.

K přiřazení hodnoty parametru nebo pojmenovanému textu nebo záložce je užíván výraz v syntaxi par/text/záložka=výraz, např.. nadpis_listu = _prvek.vk03nazev + ' ' +dtoc([datod]) + ' - ' + dtoc([datdo]) nebo nadpis_sloupce=[']+[mesrok] pro přiřazení hodnoty pojmenovanému textu nebo pro přiřazení názvu záložce listu zalozka_listu = ‘Tržby’ (implicitní název záložky je název listu), podobně pro přiřazení hodnoty parametru druhsh='SPO%;SPM%;SPS%;SNA%;OU%' nebo mesrok1=LEFT([mesrok],3)+STR(VAL(RIGHT([mesrok],4))-1) nebo s použitím příkazu DYN dyn seltv=SEZNAM ('1114%;1115%;13%;1A%;2%;3%') nebo dyn adr=ADKAT000('BIMO%'). Pokud je použit příkaz dyn, což je možné pouze v atributu parametry řádku nebo sloupce, musí být uveden na prvním řádku tohoto atributu.

Řádek uvedený znakem ‘*’ je interpretován jako komentář.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Automatické přihlášení do BM

V programu BM lze v současnosti nastavit i automatické přihlašování uživatele do systému BM. V praxi to pak znamená, že jakmile se daný uživatel přihlásí ke svému PC, tak se mu naprosto bezobslužně zároveň aktivuje i program BM. Tuto vlastnost lze využít zejména v různých automatismech, např. po zapnutí serveru se aktivuje na tomto PC i systém BM, který zajišťuje různé automatické operace generované systémem (např. automatický tisk faktur po vystavení DL apod.).

Provádí se pomocí následujících parametrů, které je nutno zapsat v souboru bw.ini:

¨ AutoLogonPC = systémový název počítače, na kterém se má automatické přihlášení provádět

¨ AutoLogonPCUser = uživatelské jméno uživatele operačního systému, při jehož přihlášení na počítači specifikovaném v parametru AutoLogonPC se má automatické přihlášení provádět

¨ AutoLogonDSN = název ODBC připojení, které se má použít při automatickém přihlášení do IS BM, má význam v případě použití multiverze

¨ AutoLogonUser = uživatelské jméno uživatele v IS BM, které se použije pro automatické přihlášení do IS BM

¨ AutoLogonPsw = heslo uživatele přihlašujícího se automaticky do IS BM

V případě nutné potřeby a na přímé vyžádání implementátora je možno předat informaci o tom, jak zapsat heslo bw.ini tak, aby nebylo na první pohled čitelné (alternativně lze totiž zapsat heslo do parametru AutoLogonPsw jako sled číselných ASCII kódů znaků hesla oddělených čárkou).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 14.09.2012


Pojem - Automatizace vstupu událostí

Automatizace vstupu dat slouží k usnadnění vstupu do událostí. Vstup dat se může provádět ručně pomocí klávesy F3 a nebo právě automaticky, k čemuž slouží tyto nástroje:

¨ importy

¨ masky

¨ programový kód

¨ šablony

¨ transformace (míra plnění)

Při používání nástrojů určených pro automatizaci vstupu událostí je třeba vzít v úvahu priority uplatnění. Nejvyšší prioritu při předplňování dat má vždy programový kód, druhá v pořadí je explicitní definice v pravidle transformace, jako další se uplatní masky operace, pak implicitní definice v pravidle transformace a nakonec ostatní (např. šablona, import a ruční vstup dat).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.04.2004


Pojem - Autorizace

Poskytuje uživateli údaje o zápisu dané informace (entity) do informačního systému (např. události, operace, adresáta, artikl, selektor apod.). U každé takové informace je k dispozici datum a čas zápisu a uživatel, který tuto informaci zapsal.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 24.06.2014


Pojem - Balíček

Balíček je prostředek přenosu vybraných definičních dat (definic) z jednoho datového úložiště do jiných, a to i u různých uživatelů (nezávisle na replikacích). Balíčkem lze přenášet:

¨ druhy procesů (na rozdíl od následujících přenášených definic se nepřenáší pouze základní definice, ale celý komplex definic, např. diagram procesu a jeho vazby, masky operací, transformace mezi uzly, šablony procesu a tisková sestava, pokud je uvedena jako předloha výstupu u druhu operace)

¨ předlohy výstupu (včetně druhu předlohy)

¨ metapředlohy výstupu

¨ definice volné karty (včetně druhu VK)

¨ definice výkazů (upozornění: nepřenesou se funkce v definici použité)

¨ obecné výběry

¨ uživatelské triggery

¨ šablony (pouze v tom případě, pokud jsou uvedeny ve vlastnostech operace jako „šablona prvého vstupu“ a pokud je tento druh operace součástí druhu procesu, který se přenáší balíčkem) - (včetně druhu šablony)

¨ definice importů/exportů, procesních importů

¨ definice výkazů

Při přenosu definic balíčkem je nutno vědět, že bez ohledu na předchozí přenosy se stále dokola mohou přenášet pouze předlohy výstupu (tj. dojde k jejich přepsání), u ostatních přenosů se v pořádku přenesou vždy jen první definice, další změny se nepřenášejí. Přenesou se pouze v případě, že se přenášená definice smaže a pomocí balíčku se naimportuje znovu. Přenos pomocí balíčku je vhodné používat i v případech, že přenášený formulář (např. obecný výběr) obsahuje systémem automaticky generované primární klíče. V takovém případě tento formulář systém obvykle přenese tak, že se přenesené informace jeví v pořádku.

Balíčkem[1] nelze přenášet volné karty operace, volné karty procesu a informace o nastavených parametrech operací. Tam kde není dostupná možnost provést „balíček“ lze v některých činnostech využít příkaz Quick export do balíčku. Tento příkaz v podstatě funguje jako balíček, ale jenom pro první záložku dané činnosti. Sbalí veškeré informace první záložky, uloží je do balíčku a lze je tak přenést do jiné verze. Pokud má činnost více záložek a uživatel chce přenést informace ze všech, je nutno přenést klasickým balíčkem či využít jiné implementační možnosti.

Export do balíčku se provádí vždy v dané činnosti (např. Druhy procesů, Seznam předloh výstupu apod.) vyvoláním příslušné činnosti na horní liště v menu Volby („Export dat do balíčku“), kde uživatel určí soubor (jeho cestu), kam se balíček má uložit, jeho název (tj. popis) a které záznamy se mají exportovat (všechny vybrané, aktuální nebo označené). Ke každému vytvářenému balíčku je možno si připsat libovolnou poznámku. Cyklicky se vytváří soubory s příponou .BEX a .FPT (u předloh výstupu, kde se provádí export do balíčku přímo z okna činnosti výstupy se kromě souborů s příponou .bex a .fpt vytvoří ještě soubor s příponou .txt). Pro vytvoření balíčků se implicitně nabízí programový adresář, uživatel má však samozřejmě možnost si nastavenou cestu změnit a zvolit si adresář podle svých potřeb. Ve formuláři zobrazeném při importu balíčku je k dispozici i tlačítko 'Uložit balíček jako ...'. Po jeho užití je uživatel vybírá soubor s příponou BEX, do kterého má být uložena kopie aktuálního balíčku. Může vybrat také již existující soubor balíčku, ke kterému má být aktuální soubor balíčku připojen.

Tato funkčnost souvisí se zavedením vzdálených funkcí BM, které umožňují předávat balíčky s nastavením BM prostřednictvím Internetu:

- pro předání balíčků uživatelům, jejichž systémy nedokážou z nějakého důvodu používat vzdálené funkce

- pro vytvoření balíčků nastavení BM předáváných obvykle na konci roku

Pozn.: Tuto funkčnost je možné použít také pro slučování balíčků vytvořených klasickým způsobem

Následný import balíčku se provádí v hlavním menu v činnosti SYSTÉM - Import balíčku. Po aktivaci této činnosti se uživateli jako první rovněž nabídne načtení balíčku z programového adresáře, uživatel si ale může určit libovolnou cestu, odkud a z jakého souboru se má provést import.

[1] Pokud se zde jedná o definici procesu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 18.03.2015


Pojem - Bankovní spojení

Ke každému adresátu v IS je možno přiřadit nejméně jedno bankovní spojení. V případě potřeby je možno zvolené spojení označit jako implicitní (provádí se v adresáři na záložce „bankovní spojení“ pomocí tlačítka Impl. a pak se v přehledu bankovních spojení zobrazuje červeně). Takto zvolené bankovní spojení se pak na událostech jednotlivých operací automaticky zobrazuje u vybraného adresáta. Kromě standardních údajů jako číslo účtu, kód banky, pobočka, název a měna účtu je možno uvést IBAN, tj. mezinárodní bankovní číslo účtu a příznak „aktuální“. Tento příznak nabývá hodnoty Ano/Ne. Vstupuje se ve formulářích 'adresář' a 'bankovní spojení adresátů'. V mřížkách těchto formulářů jsou neaktuální bankovní spojení zobrazeny na šedivém podkladě.

V zahraničních bankách je obvyklé, že jsou na jednom účtu vedeny zůstatky více měn. Toto je možné nadefinovat na záložce „další měny účtu“. Na první záložce „bankovní spojení – pokladna“ se stále uvádí základní měna účtu. V události změny stavu peněz je možné vstupovat do položky Měna účtu v případě, že bankovní účet je typu 'účet' a má definované 'Další měny' .

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.01.2006


Pojem - BM-funkce pro SQL

V řadě uživatelských implementačních rozšířeních (doplnění výstupů, transformace, obecné výběry, volné karty, ...) opakovaně nastává situace, že uživatel potřebuje využít definičně složitou konstrukci pro získání hodnoty (např. nákladová cena z TPTECVVP k datu, výše opravné položky či úhrady k datu v platbě, hmotnost výrobku z VRUDOPMA, ...). V dnešní praxi se v BM obvykle řeší opakovaným sestavováním SELECTu v doplnění, kde však může nastat problém, že se mohou nadefinovat mírně odlišně (zaokrouhlování, ...) a pak je nutno řešit nekonzistence informací.

Činnost BM-funkce pro SQL (menu Informační centrum – Typy a řady - BM-funkce pro SQL) řeší právě tento problém.

Při jejím definování se zadává:

¨ BM-funkce - 12-ti znakový identifikátor

¨ název BM-funkce - popisuje funkci

¨ typ návratové hodnoty BM-funkce - překryvný seznam - Znaková, Numerická, Datumová, Časová

datum platnosti funkce od – datum. Tento parametr, který určuje datum, je rozhodující v okamžiku, kdy je definováno více BM-funkcí se stejnou identifikací. Podle nastaveného data platnosti je pak vyhodnocena jejich aktuálnost. Obvykle se uvádí konstanta NULL nebo CURRENT DATE (tj. v obou případech BM-funkce platná k aktuálnímu datu).

¨ SQL dotaz BM-funkce - text obsahující selekt v syntaxi Sybase SQL Anywhere

¨ testovací parametry - seznam parametrů (konstant) pro testování BM-funkce (parametry musí být definovány v syntaxi Foxpro)

¨ poznámka - libovolný text

¨ aktualizace – datum vytvoření. Při opravě funkce se tento atribut automaticky aktualizuje aktuálním datem a časem systému, který zajišťuje, že pro import balíčku je zachována poslední nejaktuálnější verze BM – funkce.

V implementačních rozšířeních IS BM se potom konkrétní BM-funkce odkazují v odpovídajících SQL dotazech voláním uložené procedury:

¨ bmfce_C - pro typ návratové hodnoty funkce Znaková

¨ bmfce_N - pro typ návratové hodnoty funkce Numerická

¨ bmfce_D - pro typ návratové hodnoty funkce Datumová

¨ bmfce_T - pro typ návratové hodnoty funkce Časová

v syntaxi např.:

bm_servis.bmfce_C([Identifikace BM-funkce],[platnost],[parametr1],[parametr2],...,[parametr9])

Nepovinné parametry [parametr1],[parametr2],...,[parametr9] jsou v SQL dotazu funkce reprezentovány pozičné proměnnými @p1,@p2,....,@p9.

Vytvořenou BM-funkci je možné testovat volbou „Testovat SQL výraz“ (klávesa F5 nebo aktivace činnosti v menu Volby) v případě, že jsou u ní nadefinovány „testovací parametry“. Uživatel by měl dodržet pravidlo, že každá funkce je tímto způsobem otestována, protože syntakticky chybně nadefinovaná funkce se neprojeví chybou SQL při použití v implementačních rozšířeních.

Exporty do balíčku jsou upraveny tak, že je-li v exportu obsažen záznam, který odkazuje v některém svém atributu na BM-funkci, potom je tato automatizovaně vložena do tohoto balíčku (tato funkčnost se neuplatňuje pro exporty ve starém formátu).

Př.:

BM-funkce vracející množství artiklu na všech skladech:

¨ identifikace BM-funkce - MT-AHNAT-ALL

¨ typ návratové hodnoty BM-funkce - Numerická

¨ SQL dotaz BM-funkce - SELECT SUM(mt02hodnot) FROM %%%.MTAH WHERE sp67id='NAT' AND sp61id=@p1 AND sp60id=@p2

¨ testovací parametry - 'ZBO',PADR('HOBLIK',13)

Použití této BM-funkce v doplnění tiskové předlohy výstupu obchodovatelného artiklu:

...., %%%.bmfce_N('MT-AHNAT-ALL',null,obartikl.sp61id,obartikl.sp60id) mnozstvi, ....

Použití této BM-funkce v obecném výběru obchodovatelného artiklu:

%%%.bmfce_N('MT-AHNAT-ALL',null,obartikl.sp61id,obartikl.sp60id)>1000

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 06.03.2007


Pojem - Buňka definice listu

Buňka je nejmenším elementem definice listu. Pokud není definována přímo, je definována implicitně řádkem či sloupcem definice listu, případně je definována pomocí vzoru listu. V definici listu je daná buňka dostupná pomocí navigačního listu.

Přímá definice buňky je umožněna, pokud na relevantním průsečíku řádku a sloupce v navigačním listu byla vložena (menu VOLBY – Vložit buňku), což je současně možné jen tehdy, pokud definice listu není založena pomocí vzoru.

Přímá definice umožňuje definovat název buňky, který je následně použitelný ve vzorcích definujících jiné buňky, v atributu „param.“ přiřadit hodnoty parametrům, formát buňky a její obsah výrazem, vzorcem nebo jako prázdnou.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - BWLCL.INI

BWLCL.INI je soubor, ve kterém jsou ukládány informace o naposledy přihlášeném uživateli programu a dále se v něm uchovávají informace o všech uživatelích, kteří se k programu historicky přihlásili. Tato informace se využívá pro naplnění seznamu uživatelů v překryvném seznamu při přihlašování uživatele k programu.

Doposud se tento soubor ukládal v adresáři C:\WINDOWS\SYSTEM. Protože se ve Windows Vista bere implicitně přístup do systémové složky jiným programem za nepovolený, změnil se adresář uložení tohoto souboru podle obsahu systémové proměnné APPDATA. Bude např. ve tvaru 'C:\Documents and Settings\jméno_uživatele.název_domény\Data aplikací\BM\'. Tato změna má za následek, že při prvním přihlášení jednotlivého uživatele Windows k BM bude seznam historicky přihlášených uživatelů prázdný.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 26.06.2008


Pojem - Cash flow

Cash flow nebo peněžní toky je rozdíl mezi běžnými příjmy a běžnými výdaji podniku za určité časové období. Cash-flow si firma musí pozorně plánovat a sledovat, jinak se může dostat do vážných finančních problémů, přestože je celková bilance firmy dobrá.

Cash-flow představuje jinými slovy ukazatel charakterizující přísun prostředků z podnikových operací, který vypovídá o likviditě a finanční situaci podniku. Je tokovým výkazem, tzn. vyjadřuje rozdíl mezi příjmy a výdaji peněžních prostředků a peněžních ekvivalentů v podniku za určité časové období. Je definován Vyhláškou č. 500/2002 Sb., hlava V.

V zásadě se cash-flow určuje:

¨ nepřímo -> zisk + odpisy - výnosy, které nepředstavují peněžní výdaj

¨ přímo -> výnosy, které představují peněžní příjem - účetní náklady, které představují zároveň peněžní výdaj

Věcný nedostatek cash-flow - nepostihuje plně všechny podnikové operace, které souvisí s příjmy nebo výdaji. V jednom období lze pouze změnit majetkovou strukturu (nákup materiálu apod.), která se neprojeví ve spotřebě, čili nákladech.

Cash-flow se oficiálně vykazuje podle české terminologie v Přehledu o peněžních tocích.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.09.2008


Pojem - Cena celkem

Cena celkem uvedená v událostech skladu zvířat informuje uživatele o celkové ceně daného pohybu. Její výpočet probíhá zadané množství x cena za MJ (v těchto výpočtech se přihlíží na zadaný typ ceny a vztah MJ k ceně – RMJ nebo MJ-pomocná).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.01.2008


Pojem - Cena celkem upravená

V komponentě skladu zvířat může v událostech nastat situace, že uživatel provede výdej určitého množství zvířat za průměrnou skladovou cenu. Následně však musí časově před tento výdajový pohyb předřadit příjmový pohyb. V tomto případě se však změnila skladová cena následného výdeje, který je již uzavřen, takže je nutné cenu upravit (cena celkem upravená se používá pouze v kombinaci s cenou skladovou).

Pokud tedy uživatel před určitý výdej (za určitou skladovou cenu) předřadí (změnou pořadí operací) příjem (tzn. skladová cena je v tuto chvíli změněná od původního výdeje), automaticky se na původní operaci výdeje tato cena upravená předplní touto novou cenou skladovou. Pokud je operace výdeje ve stavu připravena - zahájena, přepočte se automaticky cena upravená a rovněž se upraví i cena skladová za MJ. Pokud je operace výdeje již ukončena, cena za MJ zůstává beze změn, ale cena upravená se automaticky změní.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.10.2007


Pojem - Cena skladová

Tento pojem skladová cena je zde použit v kombinaci s událostmi komponenty sklad zvířat. Skladová cena je cena průměrná, uživatel ji v událostech nezadává, systém ji doplňuje automaticky sám. Skladová cena by se měla používat pouze v kombinaci s množstvím v referenční měrné jednotce. Její použití s MJ-pomocnou není implementačně správné.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.10.2007


Pojem - Ceník

Ceník je činnost IS BM prezentující seznam záznamů z odpovídající tabulky. Záznam v ceníku definuje cenu daného artiklu v dané cenové skupině a cenovém období za uvedenou měrnou jednotku v dané měně. Cena se zde může definovat těmito atributy:

¨ cena artiklu,

¨ cena ostatních nákladů,

¨ cena celkem jako součet předchozích,

¨ sleva vyjádřená procentem.

Uvedené atributy jsou specificky využívány v automatizaci vstupu dat do událostí jednotlivých komponent využívajících ceník.

Ceník je plněn vstupem dat na základě rozhodnutí uživatele nebo nástroji pro automatizaci tohoto vstupu dat, tj. přepočtem cen dané cenové skupiny či období nebo z událostí komponenty OBC s nastaveným atributem „aktualizovat ceník“ aktuálního cenového období podle odpovídajících atributů události OBC.

V případě, že je u artiklu nastaven atribut „Historie ceny“, je při každé změně (F4) některého atributu ceny v ceníku zaevidován původní stav s datem změny a ten je uživateli dostupný na záložce.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 18.01.2008


Pojem - Cenová období

Cenová období poskytují uživateli informaci o jednotlivých vytvořených cenových obdobích a datu jejich platnosti od – do. Každé cenové období může být přímo spojeno s cenovou skupinou. Při definování cenového období u jednotlivých skupin je hlídána platnost období od – do, tzn. že nemůže dojít k překryvu platnosti cenových období.

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Folvarská Kateř. - 22.10.2015


Pojem - Cenová skupina pro výpočet vzrůstového přírůstku

Tato cena se používá v komponentě sklad zvířat a souvisí s výpočtem vzrůstového přírůstku. Zadává se v činnosti parametry komp. sklad zvířat, souvisí s jednotlivými kategoriemi zvířat a používá se následně v událostech skladu zvířat. Jestliže uživatel požaduje u kategorie výpočet vzrůstového přírůstku, musí mít tato kategorie záznam v ceníku (třebaže ceníková cena bude nulová).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 11.10.2007


Pojem - Cenové skupiny

Předplnění cenové skupiny při vstupu události obchodu je možné podle adresáta nebo podle příjemce uvedeného na události. Převažující nastavení pro všechny události obchodu se provádí v činnosti Nastavení BM – menu Systém, v sekci obchod. Pro určení cenové skupiny podle příjemce je nastaveno ‚cen_skp_podle_adresata=0’ nebo ‚cen_skp_podle_adresata=1’, tj. pro určení cenové skupiny podle adresáta – default. Kromě toho je možné definovat toto nastavení různě pro vybrané druhy událostí komponenty obchod v parametrech operace komponenty obchod (menu Informační centrum – Typy a řady – Druhy operací – pod menu Volby činnost Parametry operace komponenty).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.04.2014


Pojem - Cílový uzel

Jedná se o uzel diagramu procesu (tento proces obsahuje více uzlů než jeden), do kterého směřuje vazba. Pak je možno konstatovat, že z pohledu vazby je vždy jeden uzel zdrojový a jeden uzel cílový. Fakticky v takovém diagramu je vždy pak právě jeden uzel, který je pouze zdrojový, a několik uzlů, které mohou být cílové i zdrojové, a alespoň jeden musí být jenom cílový (tzn. nevede z něj další vazba).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Cizí klíč

Cizí klíč (foreign key) je v prostředí relačních databází integritní omezení, které u referenční integrity databáze.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 24.06.2014


Pojem - Cizojazyčnost v předlohách výstupu

Všechny předlohy výstupu typu sestava mohou být implementovány jako vícejazyčné. Optimálnosti (tj. možnosti vše překládat v jednom místě IS) brání:

1. Nadpisy (labely) položek v sestavě standardně dostupných (připravených tvůrci) lze překládat pomocí činnosti „Překlad textů“. Problémy jsou následující:

¨ v sestavě je nadpis (label) identifikován v komentáři jakýmsi klíčem - ten ale nelze užít pro vyhledání v činnosti „Překlad textů“, takže je nereálné na sebe mapovat texty v návrhu sestavy a v překladu textů (zejména ty, co jsou často užívané v různých činnostech)

¨ náhled v návrhu sestavy zobrazuje vždy česky - nelze nic pohodlně ověřit, nutné vždy spustit prohlížení sestavy

2. Nadpisy (labely - texty) založené v předloze se nepromítnou do činnosti „Překlad textů“, podobně je tomu s údaji doplněnými ve vlastnostech předlohy. Z uvedeného vyplývá, že je nutné zvolit překlad přímo v předloze, kdy se v komentáři nadpisu (labelu) uvádí např.:

CZE-Popis artiklu

ENG-Description of Product

DEM-Artikel

3. Identifikováno nejednotné chování IS v překladu do cizího jazyka, např. text z PLA se nepřebere z jazyka neurčeného, pokud ve zvoleném jazyce není uveden, a tak se sestava poničí. Toto vede na problém, který je obtížné identifikovat implementátorem.

4. Položky předlohy dané výrazem (např. i konstantní text) nelze přeložit pomocí překladu přímo v předloze (viz. bod 2.), ale je nutné překlad opřít o podmínku dle výrazu this.sp38id, který obsahuje ID jazyka.

5. U měrných jednotek nelze překládat jejich ID, a tak je nutné v předlohách pro tisk doplnit cizojazyčný název nebo zkratku. V předlohách by měl být implicitně k dispozici údaj „zkratka měrné jednotky“ dle jazyka namísto ID měrné jednotky.

Otázkou zůstává, zda sestavy automatizovaně překládat nebo dělat samostatné cizojazyčné předlohy - zřejmě bude nutné se rozhodnout podle požadavků na strukturu a rozmístění údajů v sestavách.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Části dne obecného kalendáře

Části dne obecného kalendáře slouží uživateli pro nadefinování jednotlivých částí dne, které pak použije při definování nového kalendáře do Dnů v týdnu. Uživatel vstupuje:

¨ část dne – identifikace a název části dne (např. celý den)

¨ čas od – do (definice času, který se týká zvolené části dne, tzn. při části dne celý den je pak zadáno 00:00 až 23:59)

¨ předplňovat – Ano/Ne (pokud je zadáno Ano, tato část dne se pak automaticky předplňuje do Dnů v týdnu při založení nového kalendáře)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 24.06.2014


Pojem - Činnost

Činností se rozumí funkce (programový kód), resp. skupina funkcí, které mohou být aktivovány rozhodnutím uživatele (případně i zprostředkovaně). Činnosti jsou spuštěny v okně, které se nazývá formulář. Činností např. je:

¨ každá položka menu

¨ případně další samostatné funkce informačního systému (lišta, jiná menu, činnosti pod záložkou Volby)

Předmětem práv, která se definují v činnosti oprávnění k činnostem, jsou pouze některé činnosti.

Činnosti je možno z hlediska logického, a tím i z pohledu ovládání, rozdělit (neboli kategorizovat) takto:

1. položky základní definice menu:

¨ práce se seznamem záznamů

- vstup událostí

- prohlížení s případnou aktualizací

¨ nastavení parametrů

2. jiné (činnosti pod menu Volby, některé činnosti pod menu Obecné apod.)

Ke každé činnosti, která je součástí hlavního menu, je možno nadefinovat po stisku pravého tlačítka myši následující:

¨ vlastnosti

¨ kopírovat – umožňuje danou činnosti zkopírovat (obdoba příkazu Ctrl+C) a vložit (obdoba příkazu Ctrl+V) na jiné místo v hlavním menu, tzn. většinou pod jinou skupinu činností.

Např. uživatel si zkopíruje činnost Operace, vloží si ji pod svoji vybranou skupinu, tuto činnosti následně přejmenuje a nadefinuje pevný Výběr, tzn. že původně zkopírovaná činnost Operace bude uživateli nabízet např. přehled připravených dodacích listů, tzn. operace komponenty obchod.

¨ vrátit výchozí – pokud se jedná o činnost hlavního menu, u které uživatel změnil její vlastnosti (např. název, výběry apod.) je po aktivaci této možnosti činnost uvedena do původního stavu (tzn. provedené uživatelské změny jsou zrušeny)

¨ odstranit – tato volba je dostupná u činností, které uživatel v hlavním menu vytvořil kopírováním

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Číselná řada procesů

Představuje evidenční knihu reálného světa, kde jsou doklady (v IS procesy) ukládány pod svými pořadovými čísly, které se jim přidělují z intervalu vymezeného touto číselnou řadou. Do jedné knihy může být současně zařazeno více druhů dokladů (procesů)[1]. Číselné řady se definují v činnosti Informační centrum – Typy a řady – Číselné řady. Při definování druhu procesu se pak každému druhu přiřazuje právě jedna číselná řada.

Číslování procesů odpovídá v IS BM i číslování dokladů, např. pokud máme proces faktury, který má přidělen určitou číselnou řadu, má vytištěný doklad faktura shodné číslo s touto číselnou řadou. Toto číslování je samozřejmě nutno náležitě definovat v relevantní předloze výstupu. Do jedné evidenční knihy je možno přiřadit více druhů procesů. U každé číselné řady se vstupují tyto atributy:

¨ řada – identifikace číselné řady (měla by např. souviset s komponentou, pro kterou je číselná řada tvořena – usnadňuje pak snadnější vyhledávání v přehledu číselných řad)

¨ popis – výstižný popis číselné řady

¨ začátek a konec intervalu – uživatel si z číselníku vybere začátek a konec intervalu pro danou číselnou řadu. Při výběru intervalu má uživatel k dispozici i činnost „volné intervaly“(pod menu Volby), která mu vypíše přehled dosud neobsazených, tj. volných intervalů. Číslo z tohoto intervalu se stává součástí identifikace procesu.

Zde je nutno uživatele upozornit na atribut „aktuální“, který je přístupný na záložce „číselné řady v letech“. Tento atribut poskytuje uživateli informaci o posledním použitém čísle ve fyzických procesech. Systém se chová tak, že při číslování procesů automaticky najde poslední použité číslo v přehledu fyzických procesů a vždy přidělí číslo o jedna vyšší.

Vyhledávání podle identifikace číselné řady je možné ve výběru v činnosti „druhy procesů”, kde je identifikace číselné řady dostupná i jako atribut přímo na oknech. V okně je identifikace číselné řady dostupná i v činnosti „procesy”, vyhledávat podle ní zde však nelze.

[1] Například do knihy vystavených faktur (pohledávek) se budou zapisovat: vystavené faktury, vystavené dobropisy, vystavené zálohové listy.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.11.2007


Pojem - Čistá mzda

Čistá mzda = hrubá mzda – SP a ZP – záloha na daň z příjmu

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 29.02.2008


Pojem - Další informace k pracovnímu poměru

Jsou k dispozici na kartě pracovníka na záložce pracovní poměr po stisku klávesy F6 nebo volbou příslušné činnosti z menu Volby. Jsou zde atributy, které přímo vážou na pracovní poměr. Uživateli se nabízí tyto informace:

¨ o pracovním poměru – tj. datum zahájení, účast prac. poměru na nemocenském pojištění, denní vyměřovací základ, důvod ukončení prac. poměru

¨ o průměrech – hodinový, denní, měsíční – tyto údaje se po provedených uzávěrkách automaticky přepočítávají. Používají se např. při výpočtu peněz za denní dovolenou a nově např. pro nemocenské dávky platné od roku 2007.

¨ o dovolené – roční nárok, zůstatky, nová dovolená. Tyto údaje se po provedených uzávěrkách automaticky přepočítávají. Dovolená byla v současné době přepracována, nicméně „staré“ nastavení lze dále používat (pro implementaci nových dovolených je vytvořen samostatný uživatelský návod) – podrobnější popis položek je uveden níže

¨ volné datum a tři volná čísla – možno libovolně využít dle potřeb uživatele

Údaje týkající se dovolené:

¨ roční nárok na dovolenou – celkový nárok na dovolenou v daném roce

¨ zůstatek dovolené z minulého roku – využívá se ve mzdových listech

¨ převod dovolené do příštího roku – využívá se ve mzdových listech. Tento atribut nastaví vždy uzávěrka za 12/rok (během roku se jeho hodnota nemění)

¨ zůstatek staré dovolené – průběžný zůstatek dovolené z té části dovolené, která byla převedena z minulého roku

¨ zůstatek nové dovolené – průběžný zůstatek dovolené z té části dovolené, která vychází z nároku k 1.1. daného roku

Atributy „zůstatek staré dovolené“ a „zůstatek nové dovolené“ dohromady označují aktuální stav dovolené k datu poslední uzávěrky, tzn. pokud např. zpracováváme mzdy za 04/2008, je v těchto atributech hodnota stavu k 31.3.2008.

S výše uvedenými atributy dále pracuje uzávěrka mezd. Před vlastním provedením uzávěrky mezd (za měsíc prosinec) je nutno mít správně uvedeny roční nároky na dovolenou na následující rok.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 13.02.2008


Pojem - Další informace karty

Tato činnost je pro uživatele dostupná pod menu Volby z činnosti Karta pracovníka.

Atributy v této činnosti vznikly na základě mzdové reformy r. 2008 a na základě změn v evidenci nemocenských dávek v r. 2009. Organizacím s touto reformou vzniká povinnost sledovat výši maximální vyměřovacího základu na zdravotní a sociální pojištění a výši limitu penzijního a životního připojištění. Hodnoty, kterých tyto atributy mohou podle zákona dosahovat jsou uvedeny v legislativních konstantách.

Po každé provedené uzávěrce mezd se do těchto atributů přenesou částky těchto atributů z daného měsíce. V případě, že by např. během listopadové výplaty systém zjistil, že maximální hodnoty těchto atributů jsou již překročeny, bude toto hlášení (překročení limitu) zapsáno do protokolu výpočtu mezd.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 29.01.2009


Pojem - Daň ze mzdy

Plátce daně srazí zálohu na daň z příjmů fyzických osob ze závislé činnosti a funkčních požitků ze zdanitelné mzdy, kterou se rozumí úhrn všech příjmů od plátce, zúčtovaný nebo vyplacený poplatníkovi za kalendářní měsíc nebo za zdaňovací období snížený o:

¨ částky, které jsou od daně osvobozeny a

¨ zvýšený o částku odpovídající pojistnému na sociální zabezpečení a příspěvku na státní politiku zaměstnanosti a pojistnému na všeobecné zdravotní pojištění (dále jen "pojistné"), které je podle zvláštních právních předpisů ze zúčtovaných nebo vyplacených příjmů povinen platit zaměstnavatel sám za sebe, a u zaměstnance, na kterého se vztahuje povinné zahraniční pojištění stejného druhu, zvýšený o částku odpovídající příspěvkům zaměstnavatele na toto zahraniční pojištění

Základem daně (dílčím základem daně), tzv. superhrubá mzda, je příjem ze závislé činnosti a funkční požitky, snížené o sražené nebo zaměstnancem uhrazené částky pojistného na sociální a zdravotní zabezpečení a navýšený o částky na sociální a zdravotní pojištění, které zaměstnavatel zaplatí za zaměstnance. Daňová záloha u zaměstnavatele, u kterého zaměstnanec předložil Prohlášení pro uplatnění slev na dani se vypočte ze zdanitelné mzdy (dílčího základu daně), zaokrouhlené do 100 Kč na celé koruny nahoru a nad 100 Kč na celé stokoruny nahoru jako 15% z této částky.

Nárok na uplatnění slev na dani prokazuje poplatník podpisem Prohlášení k dani. Zaměstnavatel přihlédne k prokázaným slevám na dani, podepíše-li zaměstnanec Prohlášení do 30 dnů po vstupu do zaměstnání, a pak každý rok nejpozději do 15. února na příslušné zdaňovací období prohlášení k dani:

¨ jaké skutečnosti jsou u něj dány pro přiznání slev na dani

¨ že za stejné zdaňovací období i za stejný kalendářní měsíc zdaňovacího období neuplatňuje současně nárok na slevy na dani u jiného plátce daně

¨ že současně za stejné období kalendářního roku nepodepsal u jiného plátce daně Prohlášení

¨ že nárok na slevy na dani současně neuplatňuje jiný poplatník.

Daňové zvýhodnění na dítě

Odečítá daňové se zvýhodnění, které upravuje § 35c a § 35d zákona č. 586/1992 Sb. Daňové zvýhodnění se odečítá od vypočtené daně nebo měsíčně u zaměstnanců s podepsaným Prohlášením k dani od vypočtených záloh na daň z příjmů. Daňové zvýhodnění náleží poplatníkovi ve výši:

¨ 10 680 Kč ročně na každé vyživované dítě žijící s ním v domácnosti a

¨ 21 360 Kč ročně, jedná-li se o dítě, které je držitelem průkazu ZTP/P.

Daňový bonus lze uplatnit tehdy, jestliže má poplatník ve zdaňovacím období příjmy alespoň ve výši šestinásobku minimální mzdy, nebo při zdanění měsíční mzdy alespoň ve výši poloviny minimální mzdy. Zaměstnanci s podepsaným Prohlášením k dani se sníží v průběhu roku vypočtená záloha na daň o částku měsíčního daňového zvýhodnění, tj. o 1/12 ročního daňového zvýhodnění. Je-li vypočtená záloha nižší než částka měsíčního daňového zvýhodnění, vyplatí zaměstnavatel vzniklý rozdíl zaměstnanci jako měsíční daňový bonus. Poplatník má nárok na vyplacení daňového bonusu, činí-li jeho roční výše alespoň 50 Kč a maximálně jej lze uplatnit do výše 4 350 Kč měsíčně.

U druhého a dalšího souběžného zaměstnavatele, u kterého nelze souběžně předložit prohlášení, se daňová záloha zjistí tzv. srážkovou daní z dílčího základu daně (tj. z hrubé mzdy zvýšené o pojistné na sociální a zdravotní pojištění, které hradí zaměstnavatel a po zaokrouhlení na celé stovky Kč nahoru), - avšak daňová záloha musí činit 15 % ze zdanitelné mzdy. Prakticky to znamená, že jediný rozdíl oproti výpočtu mzdy s podepsaným Prohlášením se nepřihlíží k daňové slevě ani k daňovému bonusu. Tito zaměstnanci (poplatníci) jsou ze zákona povinni po skončení roku podat daňové přiznání, kde přiloží potvrzení o zdanitelných příjmech ze závislé činnosti a funkčních požitků a o sražených zálohách na daň za zdaňovací období od všech zaměstnavatelů v daném roce.

Zaměstnavatel, u kterého zaměstnanec nemá předloženo prohlášení a úhrn příjmů ze závislé činnosti a funkčních požitků podle § 6 odst. 1 písm. a) a písm. d) a odst. 10 zákona o daních z příjmů, resp. hrubý zdanitelný příjem (mzda snížená o případné sražené pojistné a po zaokrouhlení na celé Kč dolů) v měsíci nepřesáhne 5 000 Kč, sráží ze mzdy konečnou srážkovou daň zvláštní sazbou 15 %. Na zaměstnance zaměstnaného v organizačních složkách státu souběžně u dvou rozpočtových organizací je daňově nahlíženo, jako na zaměstnance pobírajícího mzdu od dvou samostatných plátců i když např. ve smyslu pracovněprávních předpisů bude mít jediného zaměstnavatele - stát. To znamená, že např. u první organizační složky bude mít prohlášení (daňová záloha běžným způsobem) a u druhé (bez prohlášení) se bude srážet srážková daň 15 % do 5 000 Kč měsíčně, a nebo z vyšších částek zálohy, jako u druhého plátce (15 %, ale ze superhrubé mzdy).

Vyplácí-li zaměstnavatel zaměstnanci mzdu za více kalendářních měsíců najednou, vypočítá zálohu na daň tak, jako kdyby prováděl výplatu v jednotlivých měsících, s přihlédnutím k uplatněným nezdanitelným částkám, tj. rozpočítá příjem zaměstnance na jednotlivé měsíce. Zpětně rozpočítat příjmy na jednotlivé měsíce není možné při výpočtu daně zvláštní sazbou.

Termíny pro odvod srážkové daně jsou do konce měsíce následujícího po měsíci, v němž byla (nebo měla být) daň sražena. Pro odvod sražených daňových záloh je stanoven jeden pevný termín, a to do 20. dne kalendářního měsíce, v němž povinnost srazit zálohy vznikla dle zákona č. 586/1992 Sb. §38h písm 9). Na situaci, kdy z technických důvodů zaměstnavatel odvod v tomto termínu nemůže stihnout nebo má jen příležitostné zaměstnance např. na dohodu o provedení práce, pamatuje zákon tím, že se souhlasem finančního úřadu lze odvod sražených záloh provést později, a to nejpozději do konce měsíce.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 07.03.2008


Pojem - Daňová zvýhodnění

Daňová zvýhodnění uživatel zadává v komponentě Mzdy, v činnosti Karta pracovníka na příslušné záložce. Tato záložka je platná od 1.1.2005 pro zadání zvýhodnění na děti a od 1.1.2006 pro zadání zvýhodnění i na ostatní položky. Důležité jsou tyto atributy:

¨ identifikace a název mzdové položky (např. daňové zvýhodnění na jedno dítě)

¨ druh – je předplněno daňové zvýhodnění

¨ druh mzdové položky – měsíční, roční, měsíční s bonusem, roční s bonusem

¨ druh - na poplatníka,na druhého z manželů,na částeč. inval. důchod,na plný inval. důchod,na průkaz ZTP/P,pro studenta,na dítě,na ZTP dítě (je důležitý zejména pro práci s obecně navrženými sestavami)

¨ částka – výše částky daň. zvýh.

¨ platnost od, platnost do

¨ tisknout – zda se tato mzdová položka bude tisknout na výplatním lístku

¨ druh události – výběr druhu události, který umožňuje provázání mzdové položky do plateb, účetnictví nebo statistiky

¨ technický selektor

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 01.02.2008


Pojem - Daňové přiznání DPH

Daňové přiznání k DPH je plátce DPH povinen podat do 25 dnů po skončení zdaňovacího období k DPH, a to na předepsaném tiskopise. Plátce musí až na stanovené výjimky podávat i negativní daňové přiznání, jestliže mu nevznikla v příslušném zdaňovacím období daňová povinnost. Vlastní daňová povinnost plátce je splatná ve stejné lhůtě v jaké je povinen podat daňové přiznání, tedy nejpozději do 25 dnů po skončení příslušného zdaňovacího období. Toto samozřejmě neplatí u dovezeného zboží, kde se splatnost daně řídí celními předpisy. IS BM umožňuje uživateli zpracovat vypočtená daňová přiznání i elektronicky. Podrobný popis k činnosti daňové přiznání je uveden v helpu dané činnosti a v dokumentaci DPH.

Pro vytvoření daňového přiznání DPH však nestačí mít jen správné definice včetně položek DP. Uživatel musí mít správně vyplněnu i volnou kartu „hlavička daňového přiznání“ (viz obr. 11) se všemi potřebnými údaji (menu Obecné – Volné karty – Hlavička daňového přiznání). Podle platného znění daného roku je k dispozici volná karta „hlavička daňového přiznání 2009“ a „hlavička daňového přiznání 2010“. Tato volná karta se používá i při výpočtu souhrnného hlášení.

Údaje zapsané na této volné kartě se pak při vytváření vlastního daňového přiznání (ať už v textové či elektronické podobě) automaticky přenášejí na první stránku daňového přiznání, kde jsou k dispozici veškeré nacionále o uživateli, proto je nutné mít zde veškeré atributy vyplněny opravdu správně a pečlivě.

Při podávání daňového přiznání k DPH v průběhu konkursu je plátce povinen za uplynulou část zdaňovacího období podat daňové přiznání ke dni předcházejícímu prohlášení konkurzu, a to do 30 dnů po prohlášení konkurzu. V průběhu konkurzu podává ve standardních lhůtách daňové přiznání správce konkurzní podstaty a poslední přiznání za úpadce podá ke dni zrušení konkurzu.

V případě sdružení podává daňové přiznání pověřený účastník sdružení, který ve svém daňovém přiznání uvádí v součtu svoji daňovou povinnost a povinnost za celé sdružení. Ostatní účastníci sdružení v daňovém přiznání uvádějí pouze zdanitelná plnění a daňovou povinnost ze své vlastní činnosti nebo podávají negativní daňové přiznání.

Osoba identifikovaná k dani je povinna podat daňové přiznání a zaplatit daň ve lhůtě do 25 dnů od skončení zdaňovacího období. Tato osoba nemusí podávat negativní daňové přiznání.

Plátci podle § 94 odst. 11 ZDPH, tj. osoby registrované k dani v jiném členském státě nebo zahraniční osoby povinné k dani, které nemají v tuzemsku provozovnu, mají povinnost podat daňové přiznání a zaplatit daň také ve lhůtě do 25 dnů od skončení zdaňovacího období a nemusí podávat negativní daňové přiznání.

V oddíle A tiskopisu daňového přiznání je plátce povinen do příslušných kolonek uvést především místně příslušného správce daně a daňové identifikační číslo ve struktuře platné od 1. 5. 2004. Dále je nutno křížkem označit typ podávaného přiznání, tj. zda se jedná o řádné, opravné nebo dodatečné přiznání. V případě dodatečného daňového přiznání je nutno v příslušné kolonce uvést den zjištění důvodů pro podání tohoto přiznání, jak vyplývá z § 41 odst. 1 zákona o správě daní a poplatků. V další části tohoto oddílu se uvede zdaňovací období (měsíc nebo čtvrtletí) včetně kalendářního roku. V příslušných kolonkách 1 až 4 je nutno uvést, zda podává přiznání plátce nebo jiná vyjmenovaná osoba. V návaznosti na to je třeba v dalších kolonkách uvést identifikaci osoby, která přiznání podává, včetně sídla nebo trvalého bydliště právnické osoby. V kolonce další údaje se uvedou dvě převažující ekonomické činnosti podle uskutečněných plnění za příslušné zdaňovací období.

V oddíle B tiskopisu daňového přiznání se uvádějí údaje rozhodné pro stanovení daňové povinnosti a uvádí se výpočet daně. Nedošlo-li k žádnému plnění, za které vznikla povinnost uplatnit daň na výstupu nebo nárok na odpočet daně, v části I. vyplní plátce křížek a další údaje již za toto zdaňovací období nevyplňuje. Další údaje rozhodné pro stanovení daňové povinnosti v celých Kč vyplní plátce podle daňové evidence vztahující se k příslušnému zdaňovacímu období. V dodatečném přiznání se uvádí pouze rozdíly od údajů, ze kterých byla stanovena předcházející daňová povinnost příslušného zdaňovacího období s výjimkou provádění opravy sazby daně a výše daně podle § 49 odst. 1 ZDPH, kde se postupuje způsobem stanoveným v uvedeném ustanovení zákona.

V oddílu C tiskopisu oprávněná osoba potvrzuje správnost, úplnost a pravdivost údajů uvedených v oddílu A a B tiskopisu daňového přiznání, za které nese plnou právní odpovědnost. Osoba identifikovaná k dani je povinna podat daňové přiznání do 25 dnů po skončení zdaňovacího období, ve kterém jí vznikla daňová povinnost. V této lhůtě je splatná daňová povinnost. Tato osoba postupuje při vyplňování přiznání přiměřeně jako plátce s tím, že vyplňuje pouze řádky, které se jí týkají, a to především údaje o pořízení zboží z jiného členského státu. Stejný tiskopis daňového přiznání použije také osoba, která není plátcem DPH ani osobou identifikovanou k dani v případě že ji vznikla povinnost přiznat a zaplatit daň nebo ji vznikl nárok na odpočet daně, jestliže pořídila nový dopravní prostředek z jiného členského státu nebo jestliže nový dopravní prostředek do jiného členského státu dodává. Daňový zástupce podává samostatně daňové přiznání k DPH za každou zastupovanou osobu v příslušném zdaňovacím období do 25 dnů po skončení kalendářního měsíce, ve kterém zastupované osobě vznikla povinnost přiznat a zaplatit daň. Částka daně musí být uvedena v české měně a je splatná ve lhůtě pro podání přiznání.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.03.2010


Pojem - Daňové tabulky souhrnné

Jedná se o činnost, kde jsou nadefinované jednotlivé daňové tabulky a jejich položky. Tato činnost je částečně naplněna s dodávkou systému. Příslušnou daňovou tabulku musí mít pak každý pracovník zadánu na Kartě pracovníka na záložce „osobní údaje“ v atributu „daňová tabulka“. Údaje těchto daňových tabulek je možno nahrát balíčkem.

Tento formulář obsahuje dvě záložky:

¨ hlavička – kde jsou k dispozici atributy identifikace, popis, druh (měsíční, roční) a komentář

¨ položky – u každé položky dané tabulky se uvádí platnost od, dolní a horní hranice, pevná část a sazba. Navíc se u každého řádku uvádí „typ vzniklé daně“ (výběr z překryvného seznamu – zálohová, srážková, roční zúčtování). Tento typu určuje mzdovou položku, která na jeho základě vzniká.

Upozornění:

V případě, že se údaje daňové tabulky v následujícím roce nemění, lze ponechat všechny záznamy tak, jak jsou uvedeny, např. máme-li zadány údaje s platností od 1.1.2006 a nenastala žádná změna, budou všechny tyto údaje platit i v roce 2007.

Pokud se údaje daňové tabulky v následujícím roce částečně nebo zcela změní, je nutné znovu vložit všechny položky tabulky s novou platností od, tedy i ty, které se nezměnily, např. pokud od 1.1.2008 bude platit nová daňová tabulka, je nutno ji k tomuto datu nadefinovat zcela znovu, neplatí, že řádky (položky s platností od 1.1.2007), kde změna nenastala, zůstávají i nadále platné. Program vyhledává vždy k dané identifikaci tabulky záznamy s platností od, která je nejblíže zpracovávanému období, na ostatní řádky tabulky (tzn. s jinou – menší platností od) nebere zřetel.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 31.01.2008


Pojem - Daňový doklad

Daňový doklad je pojem vyskytující se v zákoně o dani z přidané hodnoty a v zákoně o spotřebních daních, tento text se vztahuje pouze na daňový doklad dle zákona o dani z přidané hodnoty. Jedná se o externí účetní doklad vyhotovovaný plátcem DPH za každé zdanitelné plnění pro jiného plátce, výjimku tvoří pouze doklad o použití dle § 7 odst. 2 zákona o dani z přidané hodnoty. Popis daňového dokladu a jeho veškeré náležitosti jsou upraveny v § 12 zákona o dani z přidané hodnoty.

Plátce je povinen vyhotovit daňový doklad za každé zdanitelné plnění nejdříve dnem uskutečnění zdanitelného plnění a nejpozději do 15 dnů od tohoto dne, určité výjimky zákon však připouští. Doklad vystavený před uskutečněním zdanitelného plnění není daňovým dokladem, s výjimkou splátkového kalendáře.

Závazné náležitosti daňového dokladu vymezuje § 12 zákona o dani z přidané hodnoty. Běžný daňový doklad musí obsahovat:

¨ obchodní firmu, sídlo nebo místo podnikání, popř. bydliště nebo místo podnikání plátce, který uskutečňuje zdanitelné plnění,

¨ daňové identifikační číslo plátce, který uskutečňuje zdanitelné plnění,

¨ obchodní firmu, sídlo nebo místo podnikání, popř. bydliště nebo místo podnikání plátce, pro něhož se uskutečňuje zdanitelné plnění,

¨ daňové identifikační číslo plátce, pro něhož se uskutečňuje zdanitelné plnění,

¨ pořadové číslo dokladu,

¨ rozsah a předmět zdanitelného plnění,

¨ datum vystavení dokladu,

¨ datum uskutečnění zdanitelného plnění,

¨ výše ceny bez daně celkem (v české měně),

¨ základní nebo snížená sazba daně, případně sdělení, že se jedná o zdanitelné plnění osvobozené o povinnosti uplatnit daň na výstupu podle § 46 nebo 47 zákona o dani z přidané hodnoty,

¨ výši daně celkem zaokrouhlenou na desetihaléře nahoru, případně uvedenou i v haléřích (v české měně).

Protože je daňový doklad obvykle i účetním dokladem, musí samozřejmě mít i jeho náležitosti. Jsou-li součástí zdanitelného plnění uvedeného na daňovém dokladu plnění s různými sazbami daně, popř. osvobozené od daně, musí být na tomto dokladu uvedeny výše ceny bez daně celkem a výše daně celkem odděleně podle jednotlivých sazeb daně. Za správnost údajů uvedených na běžném daňovém dokladu odpovídá plátce, který uskutečnil zdanitelné plnění.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.09.2008


Pojem - Daňový odpis

Daňové odpisy jsou odpisy, jejichž výši a způsob uplatnění určuje zákon o daních z příjmů. Neuplatňují se do účetních nákladů, nýbrž se zohledňují při určování základu daně z příjmů.

Daňový odpis uživatel provede pomocí vytvořené události, která je součástí procesu "daňový odpis". Vlastní daňové odpisy u jednotlivých karet odpisovaného majetku má uživatel možnost prohlížet v činnosti odpisovaný majetek pod záložkou "daňový odpis".

U daňových odpisů lze zadat:

¨ způsob odpisování - jedná se o varianty dané Zákonem o dani z příjmu.

- neodpisovat

- rovnoměrně (nutno určit odpisovou skupinu)

- zrychleně (nutno určit odpisovou skupinu)

- rovn. NH (podle Zákona o dani z příjmu nutno určit počet měsíců odpisování a počet měsíců odpisování po provedení technického zhodnocení). Je povoleno pouze jedno technické zhodnocení měsíčně!

- individuální odpis (nutno určit odpisovou skupinu a vyplnit záložku Individuální odpis)

¨ měsíců – udává se u způsobu daň. odpisů rovn. nehmotného majetku

¨ odpisová skupina – výběr z číselníku odpisových skupin

¨ po TZ udává se u způsobu daň. odpisů rovn. NH

¨ vstup. cena – automaticky naplněna při pořízení daného odpisovaného majetku

¨ zůst. cena – dopočítává program automaticky (vstupní cena mínus suma provedených daňových odpisů konkrétního odpisovaného majetku)

¨ datum prvního TZ (+ odpisů) – datum je automaticky naplněn z provedeného pohybu prvního technického zhodnocení (tj. z události odpisovaného majetku) + atribut odpisů znamená, kolik již bylo provedeno celkem ročních daňových odpisů po prvním provedeném technickém zhodnocení

¨ datum posl. TZ (+ odpisů) - datum je automaticky naplněn z provedeného pohybu posledního zaznamenaného technického zhodnocení (tj. z události odpisovaného majetku) + atribut odpisů znamená, kolik již bylo provedeno celkem ročních daňových odpisů po dosud posledním provedeném technickém zhodnocení

¨ snížení odpisu % - o uvedené procento se snižuje vypočtený daňový odpis

¨ soubor majetku - majetek je hlavním předmětem souboru

- nadřízený artikl

- v případě potřeby vytvoření souboru majetku je nutno konkrétní kartu odpisovaného majetku určit jako hlavní majetek souboru (zaškrtnout daný atribut) a u karet, které jsou pak součástí tohoto souboru určit tuto kartu jako nadřízený artikl. Vytvoření souboru má však spíš pouze informační charakter (např. aby uživatel věděl, který majetek k čemu patří apod.), ale pro zpracování daňových odpisů to nemá význam[1].

Storno daňového odpisu se provede vystornováním daného procesu, pomocí kterého uživatel daňový odpis provedl.

Daňové odpisy jsou tedy:

¨ upraveny zákonem o dani z příjmu,

¨ firma při pořízení dlouhodobého majetku zvolí jednu ze dvou metod (rovnoměrné nebo zrychlené odepisování), zvolenou metodu musí dodržet do konce odepisování (v průběhu let odepisování změna není možná),

¨ zákon umožňuje odepisování přerušit a pokračovat až podle rozhodnutí podnikatele. Daňoví odborníci však přerušování nedoporučují, protože i když je firma např. ve ztrátě a započítáním odpisů si ztrátu ještě zvětší, v následujících sedmi letech si podnikatel může kdykoliv, když vykáže zisk, ztrátu odečíst a navíc ještě uplatnit řádné odpisy daného účetního období, čímž minimalizuje svou daňovou povinnost;

¨ v případě technického zhodnocení dlouhodobého majetku (přístavba, rekonstrukce, generální oprava stroje, zabudování klimatizace do auta apod. dražší než 40.000,- v jednom kalendářním roce) se zvyšuje hodnota dlouhodobého majetku a odpisy provádíte ze zvýšené ceny;

¨ v příloze zákona o dani z příjmu jsou jednotlivé druhy hmotného i nehmotného dlouhodobého majetku rozděleny do 6 odpisových skupin podle délky doby odepisování.

[1] Při provádění daňového odpisu systém zjistí odpisovou skupinu, která je uvedena na kartě majetku, který je hlavním předmětem souboru a podle jejího nastavení pak vytvoří daňové odpisy pro podřízené artikly daného souboru. Neodepisuje však soubor jako celek, ale stejně odepisuje každou kartu souboru položkově. Dosud není zatím ani vyřešeno, jak pak např. provést technické zhodnocení podřízené karty.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 11.12.2009


Pojem - Data uživatele (aplikační data)

Jedná se o tu část IS, která nikdy není součástí poskytovaného IS. Jsou vytvářena při provozu IS, jsou majetkem uživatele, uživateli je pomocí nich poskytována informační schopnost IS, tj. nesou pro uživatele významnou informační hodnotu. Poskytovaný IS definuje jejich strukturu pomocí definičních dat.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Databáze

Databáze (neboli Datová základna) je určitá uspořádaná množina informací (dat) uložená na paměťovém médiu. V širším smyslu jsou součástí databáze i softwarové prostředky, které umožňují manipulaci s uloženými daty a přístup k nim. Tento systém se v české odborné literatuře nazývá systém řízení báze dat (SŘBD). Běžně se označením databáze – v závislosti na kontextu – myslí jak uložená data, tak i software (SŘBD).

Mezi zcela nezbytné prvky IT infrastruktury IS BM patří databázový systém Sybase® SQL Anywhere ® . Databázový systém Sybase® SQL Anywhere® (dále jen SQL) se skládá z databázového serveru a s ním komunikujících klientů a případně je doplněn nástrojem pro replikaci SQL Remote.

Databázi si lze představit jako soubor dat, který slouží pro popis reálného světa (např. evidence školní knihovny, sklad chemikálií, evidence studentů). Entita je prvek reálného světa (např. člověk, stroj, vyučovaný předmět, město), který je popsán svými charakteristikami (vlastnostmi). Ty se většinou považují za atribut (např. jméno, příjmení, stav, plat, hmotnost).

Dalším důležitým pojmem je vazba mezi entitami. Jednotlivé entity odpovídající prvkům z reálného světa, mají mezi sebou určitý vztah. Např. každý člověk má právě jedny osobní údaje vedené na magistrátu, na oddělení občanských průkazů. To hovoříme o vazbě typu 1:1. Dalším typem je vazba 1:N, jíž bude odpovídat např. skutečnost, že jeden člověk může vlastnit více kreditních karet (ale jedna kreditní karta může být vlastněna pouze jedním člověkem). Posledním typem vazby je M:N. Zde není žádné omezení, příkladem by mohla být situace, že student na vysoké škole si může zapsat několik různých předmětů (ale jeden předmět může být zároveň zapsán více studenty).

V této době vzniká ještě jeden pojem, a to databázový model. V 70. letech se uvedené databázové modely ukázaly být nedostatečné (objevily se problémy s realizací a implementací vazby M:N), a proto vznikl relační model, který se stal standardem a používá se dodnes.

Databáze SQL obsahuje následující:

¨ Tables (tabulky) – vlastní data uložená v tabulkách (v podstatě se jedná o nevelké % z celkové velikosti databáze na disku)

¨ Views (pohledy) – případně Materialized Views – uspořádané pohledy na data

¨ Indexes (indexy) – zajišťující rychlejší přístupy k datům, ...

¨ Text Indexes

¨ Text Configuration Objects

¨ Triggers – textové triggery, které zajišťují sofistikované vyhledávání

¨ System Triggers – triggery zajišťující konzistenci databáze

¨ Procedures & Functions (procedury a funkce) – implementační využití. Funkce v podstatě vrací funkční hodnotu a procedury slouží k tomu, že buď vrací result (což je de facto tabulka o jednom nebo o několika záznamech) nebo jen vykonají určitou aktivitu (aktualizaci dat, odeslání mailu, ...)

¨ Events (události) – programový kód, který se aktivuje tím, že nastane určitá událost, např. nastane určitý časový okamžik nebo systémová událost. Události lze aktivovat:

- časem (Scheduled) – událost je spuštěna ve specifikovaný čas nebo v intervalu mezi dvěma časy

- manuálně (Manualy) – provedením příkazu Trigger EVENT

- událostí (Conditional) – událost je spuštěna když nastane systémová událost, např. když se soubor logu stane příliš velký

¨ Domains

¨ Sequence Generators

¨ Spatial Reference Systems

¨ External Environments

¨ Users

¨ Roles

¨ System Privileges

¨ Login Policies

¨ Login Mappings

¨ LDAP Servers

¨ SQL Remote Users

¨ MobiLink Users

¨ Publications

¨ SQL Remote Subscriptions

¨ Synchronization Subscriptions

¨ Synchronization Profiles

¨ Dbspaces

¨ Remote Servers

¨ Directory Access Servers

¨ External Logins

¨ Web Services

¨ Certificates

¨ Maintenance Plans

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 17.09.2015


Pojem - Databázový model

V této době vzniká ještě jeden pojem, a to databázový model. Ten byl zaveden zejména matematiky, jako prostředek pro popis databáze. Zpočátku se používaly modely dvojího typu: hierarchický (založen na modelování hierarchie mezi entitami se vztahy podřízenosti a nadřízenosti) a dále síťový (vychází z teorie grafů, uzly v grafu odpovídají entitám a orientované hrany definují vztahy mezi entitami).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.10.2007


Pojem - Datové úložiště

Datové úložiště je logické místo, které koresponduje s výskytem databáze (Sybase SQL Anywhere). Informační systém může mít data u uživatele uložena na jednom datovém úložišti nebo v několika datových úložištích. Mezi nimi pak obvykle probíhají replikace.

Pokud má tedy uživatel, u kterého je IS BM instalován, více poboček, může to v praxi vypadat např. následovně. Hlavní pobočka má číslo datového úložiště 01, ostatní pobočky mají čísla v pořadí 11, 21, 31 apod. (toto číslování je doporučeno z praxe – pro větší přehlednost práce s daty na jednotlivých datových úložištích a např. i pro případné provádění replikací). Definice datových úložišť je jednak závislá na instalaci programu, jednak je možno ji zadat v činnosti Informační centrum – Import/Export – Replikace – Datová úložiště (po stisku pravého tlačítka myši na názvu této činnosti je možno zadat „nové datové úložiště“).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.11.2007


Pojem - Datový model

Zde jím rozumíme fyzický datový model, který je dostupný v činnosti Systém a který popisuje strukturu datové základny konkrétního IS Bílý Motýl, na rozdíl od logického datového modelu, který je modelem reálného světa nezávislým na IS[1].

Fyzický datový model se skládá z definice tabulek (entit, někdy též nazývaných objekt), z definice jejich atributů a z definice souvislostí mezi tabulkami implementovanými jako relace ve vazbě na indexy. Ke zmíněným tabulkám mohou být definovány triggery.

Datový model využije uživatel při nastavení některých definičních dat.[2]

Typ |
C česky | binary(délka)
C | Char(délka)
M | Long varchar
MG | Long binary
D | Date
T | Timestamp
N, délka <3, (žádné desetiny nebo L) | Tinyint
N, délka <5, (žádné desetiny nebo L) | Smallint
N, délka <10, žádné desetiny | Integer
N | Numeric(délka, desetiny)

[1] Ideální DM představuje (modeluje) požadavky na informační schopnost budoucího IS, resp. na jeho nastavení. Těchto požadavků obvykle není dosaženo na 100 procent díky technickým omezením.

[2] Při nastavení některých definičních dat je mnohdy k dispozici v dané činnosti určitý subset DM.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 02.09.2008


Pojem - Datový tok

Datovým tokem se rozumí otázka vstupu atributů událostí (zejména automatizace) při běhu (provádění) fyzického procesu. Patří sem zejména předplňování dat a validace dat.

Mezi typické nástroje ovlivňující datový tok patří:

¨ importy dat

¨ kód po ukončení operace

¨ masky

¨ programový kód

¨ šablony

¨ transformace (míra plnění)

¨ vstup údajů z klávesnice

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Dávková zpracování

Pojmem dávková zpracování se rozumí práce s určitou množinou dat vedoucí ke změně nebo vzniku nových dat, např.:

¨ automatické párování bankovního výpisu na platby

¨ dávkové operace

¨ importy

¨ označování

¨ procesní importy

¨ spuštění označených operací na pozadí

¨ zrušení označených událostí v účetnictví po ESC

¨ …..

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Dávky nemocenského pojištění

Zákon o nemocenském pojištění (č. 54/1956 Sb.) stanoví, že dávky nemocenského pojištění jsou peněžité dávky:

¨ nemocenské,

¨ ošetřovné,

¨ vyrovnávací příspěvek v těhotenství a mateřství,

¨ peněžitá pomoc v mateřství.

Od 4. dne pracovní neschopnosti náleží zaměstnanci náhrada mzdy ve výši 60 % denního vyměřovacího základu, a to až do 30. pracovního dne pracovní neschopnosti (za první tři kalendářní dny nenáleží žádná náhrada mzdy dle § 192 ZP). Od 31. dne kalendářního dne pracovní neschopnosti do 60. kalendářního dne pracovní neschopnosti je nemocenská ve výši 66% denního vyměřovacího základu a 72 % denního vyměřovacího základu od 61. kalendářního dne pracovní neschopnosti. Náhrada mzdy se poskytuje za pracovní dny a svátky, za které jinak přísluší náhrada mzdy podle §115 odst. 3 zákoníku práce nebo se mu plat nekrátí podle §135 odst. 1 zákoníku práce. Výše nemocenského za kalendářní den se zaokrouhluje na celé koruny nahoru.

Nemocenské náleží zaměstnanci, který je uznán dočasně neschopným k výkonu svého dosavadního zaměstnání v činnosti, která je nemocensky pojištěna. Kdo vykonává několik činností zakládajících pojištění podle zákona o nemocenském pojištění, je pojištěn z každé z nich. Nemocenské se poskytuje za kalendářní dny a náleží zaměstnanci od 4. kalendářního dne pracovní neschopnosti do skončení pracovní neschopnosti nebo do uznání plné nebo částečné invalidity. Nemocenské se však poskytuje nejdéle po dobu jednoho roku od počátku pracovní neschopnosti.

Výše dávek se vypočítává z denního vyměřovacího základu, což je hrubý příjem (započitatelný příjem, který se zahrnuje do vyměřovacího základu pro stanovení pojistného na sociální zabezpečení) v rozhodném období vydělený počtem kalendářních dnů připadajících na rozhodné období. Rozhodným obdobím je období 12 kalendářních měsíců před kalendářním měsícem, ve kterém vznikla pracovní neschopnost.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 07.03.2008


Pojem - Definice listu výkazů

Definice listu výkazů je soubor pravidel, dle kterých bude sestaven daný list při sestavení výkazu. V IS BM jsou k dispozici dvě metody pro uživatelské nastavení definice listu výkazů a to metoda přímá nebo metoda s použitím vzoru listů výkazu. Jedna definice listu může být přiřazena do několika definic výkazu.

Ve výkazech IS BM je možno definovat i listy, které obsahují kontingenční tabulky [1]. Pro účely této definice je činnost „Listy výkazů“ rozdělena do čtyř záložek:

¨ Listy výkazů – kde se vstupují základní informace o listu (společná záložka pro běžné i kontingenční typy listů)

¨ Běžný list – zde se vstupují atributy běžných typů listů výkazů

¨ Kontingenční list – zde se vstupují atributy kontingečních typů listů výkazů

¨ Pole kontingenčního výkazu – zde se vstupují vlastnosti jednotlivých polí vytvářené kontingenční tabulky

Definice „běžného listu“ zahrnuje implicitní název listu, vzor, pokud je list definován pomocí něj, šablonu a implicitní formát buněk, atribut parametry, dodatečné deklarace a poznámku.

Dodatečné deklarace umožňují příkazem LOCK zamknout zdrojová data uvedených komponent (např. LOCK UCE zabrání zápisu událostí účetnictví po dobu sestavení výkazu, což vede na zajištění integrity zobrazených informací ve výkazu) a dále umožňují formulovat podmínky, při jejichž nesplnění nebude uvedený sloupec nebo řádek definice listu zařazen do listu sestaveného výkazu (např. $S(80) [rok]='2000' definuje, že sloupec s identifikací 80 v definici listu bude do výkazu při jeho sestavení zařazen pouze tehdy, je-li hodnota parametru rok dva tisíce; podobně pro řádek $R(80) [rok]='2000').

V případě užití přímé metody (klávesa F6) pro nastavení definice listu uživatel za pomoci navigačního listu definuje přímo jednotlivé sloupce, řádky a buňky definice listu.

V případě užití metody pro nastavení definice listu pomocí vzoru uživatel definuje jednotlivé sloupce, řádky a buňky definice listu zprostředkovaně pomocí dříve připraveného vzoru listu (klávesa F7) s tím, že možnosti i složitost nastavení jsou oproti metodě přímé omezeny.

Pro definici „kontingenčního listu“ výkazu je nutno mít precizně nadefinovány atributy na záložce „kontingenční list“ a „pole kontingenčního listu“ (viz. podrobný popis těchto atributů je uveden v helpu dané činnosti).

Upozornění pro uživatele:

V některých nastaveních u klientů může při opravě nebo spuštění listů výkazů nastat situace, že systém ohlásí chybovou hlášku typu: „Kód chyby OLE „číslo“. Třída není zaregistrována. Objekt OLE je ignorován. Po stisku OK potom následuje další chybová hláška typu „Neznámý člen MUJGRID“.

Systém upozorňuje, že v systému uživatele chybí knihovna, která je pro tento list výkazu nutná. Další postup pro odstranění této chybové hlášky je následující:

¨ z FTP firmy BM Servis je nutno stáhnout příslušnou knihovnu. Knihovna je v sekci ftp://bmftp@mail.bmservis.cz/Pro zakazniky/ISBM_neco_nechodi/GRID32.OCX

¨ aktivovat na PC příkazový řádek a jako správce do něj zapsat příkaz CMD

¨ aktivuje se černé příkazové okno a tam je nutno ručně vepsat příkaz pro registraci knihovny GRID32 „regsvr32 k:\bmsql\grid32.ocx“ (jméno disku se samozřejmě musí napsat takové, na jakém má uživatel nainstalován IS BM)

Tímto krokem se dá laicky říct, že dojde ke spojení výkazů s příslušnou knihovnou GRID32 a další práce s listy výkazů je již bez problémů.

[1] Uživatelský příklad definice kontingenční tabulky je k dispozici u pojmu „kontingenční tabulky“ (slovník pojmů). Je podrobně popsán příklad kontingenční tabulky, která využívá ke svému naplnění data z komponenty účetnictví z činnosti obratová tabulka.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 18.05.2015


Pojem - Definice maker

Pod pojmem makro rozumíme definici substituce, podle které se má v textu obsahujícím název makra (volání makra) nahradit toto volání výrazem uvedeným v definici makra. Makro může mít definováno parametry, podle jejichž hodnot, uvedených ve volání makra, má být výraz před substitucí upraven. Makra se využívají pro definování často opakovaných textů nebo pro překlad textů do uživatelsky srozumitelné formy.

Makra je možné používat:

¨ 1. v metapředlohách výstupu - vlastnosti Podmínka a Tiskárna na záložce Předlohy v metapředloze

¨ 2. v atributech Volné karty - vlastnosti Inicializace, Validace a Text popisující atributy třídy překryvný seznam, resp. zaškrtávací políčko

¨ 3. v Informačních panelech - vlastnosti SQL

¨ 4. v Obecných výběrech - proměnné výběru typu Makro

¨ 5. v Označování výrazem - výraz (používají stejná makra jako v obecných výběrech)

¨ 6. v Automatickém dokončování

Na první záložce formuláře definice makra se uvádí:

¨ identifikátor definice makra

¨ název makra - nesmí obsahovat mezeru

¨ typ - překryvný seznam - specifikuje typ hodnoty makra - uplatňuje se pro 2/ - typ logický se nabízí pro vlastnost Validace, ostatní typy pro vlastnosti Validace a Text popisující atributy třídy

¨ template - vzor skutečných parametrů makra, který bude předplněn při výběru makra uživatelem

¨ proměnné - překryvný seznam Ano/Ne - Ano = parametry jsou proměnné jazyka SQL nebo proměnné programového kódu, tzn. do výsledného textu zpracovaného makra má být přenesen jejich text bez transformace (používá se pro 2/ a 3/)

¨ výraz - výraz v jazyce SQL (pro 3/,4/ a 5/) nebo výraz v jazyce Foxpro (pro 1/ a 2/ kromě Validace) nebo kód v jazyce Foxpro (pro 2/ v atributu validace)

¨ from - doplnění SQL dotazu v části FROM (uplatňuje se pouze pro 5/)

¨ poznámka - libovolný text

Na záložce parametry makra se uvádí:

¨ pořadí parametru

¨ název parametru

¨ typ parametru - Znakový / Numerický / Datumový / Časový / Vložený text

¨ délka hodnoty parametru (pro typ parametru=Znakový / Numerický)

¨ počet desetinných míst (pro typ parametru=Numerický)

Při zpracování textu, ve kterém je obsaženo existující makro nahradí BM všechny výskyty tohoto makra v tomto textu upraveným výrazem definice makra. Ve výrazu definice makra přitom vyhledává parametry makra a nahrazuje je podle skutečných hodnot uvedených ve vyvolání makra. Parametry makra jsou ve výrazu makra uváděny ohraničené v hranatých závorkách a při úpravě výrazu makra jsou nahrazovány:

¨ konstantní hodnotou skutečného parametru ve formátu SQL (proměnné=Ne a Znakový / Numerický / Datumový / Časový)

¨ nebo hodnotou skutečného parametru bez transformace (proměnné=Ne a typ parametru=Vložený text)

¨ nebo textem skutečného parametru (proměnné=Ano)

Ve výrazech maker je možné uvádět text $$$, který bude nahrazen názvem databázové tabulky, jejíž obsah je odpovídajícím formulářem zobrazován.

Ve výrazu makra je možné uvádět jiná makra, ale přitom je třeba dbát, aby nedošlo k zacyklení tj., aby makro tímto způsobem přímo nebo nepřímo odkazovalo samo na sebe.

Příklady:

1. formulář - Adresát

1a) makro pro vyhledávání tuzemských adresátů

- název makra - Tuzemec

- template - neuveden

- výraz - ADADR.dp04tuzzah=1

- parametry - neuvedeny

1b) makro pro vyhledávání adresátů s textem v názvu

- název makra - Název_obsahuje

- template - '?'

- výraz - $$$.ad01adsat LIKE '%[OBSAHUJE]%'

- parametry - OBSAHUJE typ=Vložený text

Užití těchto maker např.:

NOT Tuzemec() AND Název_obsahuje('kopyto')

vytvoří část SQL dotazu

NOT ADADR.dp04tuzzah=1 AND ADADSAT.ad01adsat LIKE '%kopyto%'

2. formulář - Události obchodu

2a) makro pro vyhledání událostí s volitelným typem zdanitelného plnění

- název makra - Typ_ZDP

- template - '?'

- výraz - $$$.dp03id=[TZDP]

- parametry - TZDP typ=Znakový, Délka=3

2b) makro pro vyhledání událostí s typem zdanitelného plnění = základní sazba

- název makra - Typ_ZDP_základní

- template - neuveden

- výraz - Typ_ZDP('ZA1')

- parametry - neuvedeny

2c) makro pro vyhledání událostí s datem dodání v intervalu

- název makra - Dodání_od_do

- template - {1.1.2006},{31.12.2006}

- výraz - $$$.ob02datdod BETWEEN [D1] AND [D2]

- parametry - D1 typ=Datumový a D2 typ=Datumový

Užití těchto maker např. :

(Typ_ZDP('XX') OR Typ_ZDP_základní()) AND Dodání_od_do({2.5.2006},{8.12.2006})

vytvoří část SQL dotazu

(OBUDAL.dp03id='XX ' OR OBUDAL.dp03id='ZA1' ) AND OBUDAL.ob02datdod BETWEEN '2006/05/02' AND '2006/12/08'

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.11.2007


Pojem - Definice mzdových položek

Definice mzdových položek se provádí v činnosti Mzdy – Definice – Položky mezd. Vlastní nastavení mzdových položek má přímý vliv na výpočet mezd.

Nastavením definic položek mezd se ovlivňuje běh výpočtu hrubých mezd. Zejména vztah právě definované položky mezd k sociálnímu a zdravotnímu pojištění, ke čtvrtletním průměrům, ke kalendáři a jeho fondu pracovní doby, k druhu události mezd, atd. Na výplatním pásku pracovníka se položky tisknou v pořadí podle identifikace položky. Kombinací atributů Původ Kč/j a Výpočet Kč se nastaví chování mzdové položky.

Nastavení definice mzdových položek není rozhodně triviální záležitostí, proto se domníváme, že by toto měl dělat zkušený pracovník mezd v součinnosti s implementátorem.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.11.2007


Pojem - Definice uspořádání položek výstupu

Jedná se o okno, které se uživateli zobrazí v těchto případech:

¨ po nadefinování položek výstupu u nově založené předlohy výstupu

¨ po stisku ikony „opravit předlohu“ v panelu nástrojů u již nadefinované předlohy (tato předloha však nesmí mít ve vlastnostech zatržen příznak „systémová“ – taková předloha nemá možnost opravy dostupnou)

Při definici uspořádání položek výstupu u předlohy typu sestava má uživatel k dispozici příkazy a funkce, které mu poskytuje generátor sestav FoxPro (bližší popis uveden v pojmu „návrhář sestav FoxPro“). Okno činnosti typu sestava je rozděleno do tří částí – záhlaví, tělo, zápatí. Posunem po okně činnosti je možno jednotlivé položky výstupu uspořádávat, je možno je seskupovat, sumovat apod.

Při definici uspořádání položek výstupu u předlohy typu Excel, Word a ostatní (HTML) se uživateli zobrazí okno s automaticky vygenerovaným pseudokódem, který uživatel může samozřejmě podle potřeby upravovat. Tyto úpravy však vyžadují alespoň částečnou znalostí příkazů jazyka Excel, Word a HTML, proto není vhodné, aby je prováděl úplný začátečník.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.10.2013


Pojem - Definice uzlů informačního panelu

Tato činnost se nachází v menu Informačním centrum – Informační panely.

Informační panel je nástroj, který slouží k přehlednému zobrazení úkolů uživatele vyplývajících z informací uložených v systému. Obsah informačního panelu je volně definovatelný a je ho možné přizpůsobit individuálním potřebám jednotlivých uživatelů. Uživateli se mohou na jediné webové stránce zobrazovat jeho úkoly z různých oblastí IS a z této stránky potom může přímo vyvolávat potřebné funkce a činnosti aktivací hypertextového odkazu.

Touto činností je možné definovat jeden nebo více informačních panelů. Na záložce Uzly a Další se popisují jednotlivé prvky informačních panelů.

Pro každý uzel se definuje:

¨ identifikace uzlu, která ho jednoznačně identifikuje

¨ název uzlu

¨ druh uzlu - definuje práva uživatelů

¨ prezentace - má význam pro uzel typu "Stránka panelu" - určuje HTML formátování

¨ ikona - má význam pro uzel typu "Stránka panelu" - určuje ikonu stránky

¨ typ – překryvný seznam - Informační panel / Stránka panelu / Prvek stránky

¨ adresa - má význam pro uzel typu "Stránka panelu" - přímá URL adresa vyvolaná při aktivaci stránky

¨ typ prvku - pro typ prvek stránky - určuje zda bude vytvářena tabulka nebo odkaz

¨ spojení - určuje datový zdroj, ze kterého budou SQL dotazem získávána data

¨ výraz názvu uzlu - je vyhodnocen při vytváření stránky panelu (výraz v syntaxi Foxpro)

¨ výraz třídění - pro uzel typu prvek stránky - určuje třídění dat získaných dotazem SQL (výraz v syntaxi Foxpro)

¨ SQL dotaz - pro uzel typu prvek stránky - SQL dotaz v syntaxi SQL Anywhere. Ve vlastnosti 'SQL dotaz' definice uzlu je možné vložit dva skripty provedené před a po provedení SQL dotazu. Oběma skriptům jsou přitom předávány parametry, se kterými je stránka vyvolána (_p1,_p2,...,_p14) a v proměnné _this je předán řídící objekt vytvářející stránku, skriptu před SQL dotazem je navíc předán v proměnné _OBJ_SQL objekt, který má ve svém atributu SQL obsažen text následně prováděného SQL dotazu (skript může tento text měnit). Provádí se uvedením slova #SCRIPT na začátku definice SQL dotazu (nesmí být před ním žádné mezery ani prázdné řádky). Za tímto slovem následuje kód skriptu v jazyce Foxpro vyvolaný bezprostředně před provedením SQL dotazu a za ním je na novém řádku slovo #ENDSCRIPT (nesmí být před ním žádné mezery). Pak následuje vlastní tvar SQL dotazu v syntaxi SQL. A potom může být uvedeno na samostatném řádku slovo #SCRIPT (nesmí být před ním žádné mezery), za kterým následuje kód v jazyce Foxpro vyvolaný po provedení SQL dotazu.

Na stránce informačního panelu je možné vytvářet odkazy, které způsobí vyvolání programu Windows (jiného než internetový prohlížeč) a v něm otevření souboru, který odpovídá celé zobrazené stránce (může to být více tabulek) nebo jednotlivé tabulce zobrazené na stránce. Funkčnost přenosu zobrazené tabulky do Wordu a Excelu je rozšířena o přímou možnost vytvoření dokumentu ve formátu Wordu resp. Excelu. Provádí se vložením kódu v jazyce Foxpro do atributu 'SQL dotaz' v definici uzlu informačního panelu. Tento kód vytvoří soubor v požadovaném formátu (případě, že je nastavena proměnná '_this.output_format') a jeho název vloží do proměnné '_this.rodic.output_file'.

Při tvorbě definice informačních panelů lze použít technologii Materialized View. Ta umožňuje např. prezentovat manažerské informace na informačních panelech novou metodou, která byla vyvinuta a v praxi nasazena pro vyhodnocování marketingových kampaní. Díky použité technologii MATERIALIZED VIEW se standardizovanou strukturou a navazujícího agregování GROUP BY CUBE se dosahuje okamžité odezvy.

V následujících popsaných příkladech se předpokládá, že na počítači je nainstalován Excel - a v případě použití pro WBM není jeho volání nějakým způsobem omezeno IIS-serverem.

Příklad 1. - klasický SQL dotaz

<pre>

#SCRIPT

#ENDSCRIPT

Select sp26,sp26datum,sp26nazev,bw01jmeno,sp26index,spdokobs.sp01id,sp01predlo,sp57typdok,spdokobs.sp57id,sp26koment,sp26disk,sp26soubor From %%%.spdokobs spdokobs,%%%.bwuzivat bwuzivat,%%%.sppredlo sppredlo,%%%.spdoktyp spdoktyp,%%%.sppristu sppristu Where

spdokobs.sp57id=sppristu.sp44vec And sppristu.sp44typ='TDO' And sppristu.bw01uziv=?Tool.uziv And

sppristu.sp44pristu>1 And

spdokobs.bw01uziv=bwuzivat.bw01uziv And spdokobs.sp01id=sppredlo.sp01id And spdokobs.sp57id=spdoktyp.sp57id

#SCRIPT

Local _txt,_xlapp,_xlwb,_xlsheet,_err

* Pokud má být vytvářen XLS, potom _this.output_format='XLS'

If Empty(_this.output_format) Or _this.output_format<>'XLS'

Return

Endif

If _this.web

* Výstup do Excelu pro WBM musí být uložen v adresáři -> _this.rodic.Path s příponou XLSX nebo XLS

_this.rodic.output_file=_this.rodic.Path+'tmp\'+Stuff(Sys(2015),1,1,'')+'.xlsx'

Else

* Výstup do Excelu pro BM.EXE bude uložen v libovolném pracovním souboru s příponou XLSX nebo XLS

_this.rodic.output_file=bw_param('TMP','.xlsx')

Endif

* _xlapp = OLE object Excelu

_xlapp=Createobject( "Excel.Application")

* _xlwb = objekt dokumentu Excelu

_xlwb=_xlapp.workbooks.Add

* _xlsheet = objekt listu Excelu

_xlsheet=_xlwb.worksheets[1]

Select Data

_i=0

Scan All

* _i obsahuje číslo řádku

_i=_i+1

* sp26datum do prvního sloupce

_xlsheet.cells[_i,1].Value=sp26datum

* sp26nazev do druhého sloupce

_xlsheet.cells[_i,2].Value=sp26nazev

* bw01jmeno do třetího sloupce

_xlsheet.cells[_i,3].Value=bw01jmeno

Endscan

_xlapp.displayalerts=.F.

* uložení dokumentu

_xlwb.SaveAs(_this.rodic.output_file)

_xlapp.displayalerts=.T.

* uzavření dokumentu

_xlwb.Close()

_xlsheet=.F.

_xlwb=.F.

_xlapp=.F.

#ENDSCRIPT

</pre>

Příklad 2. - programovaný SQL dotaz

<pre>

Local _txt,_xlapp,_xlwb,_xlsheet,_err

Local _sql

TEXT TO _sql Noshow

Select sp26,sp26datum,sp26nazev,bw01jmeno,sp26index,spdokobs.sp01id,sp01predlo,sp57typdok,spdokobs.sp57id,sp26koment,sp26disk,sp26soubor From %%%.spdokobs spdokobs,%%%.bwuzivat bwuzivat,%%%.sppredlo sppredlo,%%%.spdoktyp spdoktyp,%%%.sppristu sppristu Where

spdokobs.sp57id=sppristu.sp44vec And sppristu.sp44typ='TDO' And sppristu.bw01uziv=?Tool.uziv And

sppristu.sp44pristu>1 And

spdokobs.bw01uziv=bwuzivat.bw01uziv And spdokobs.sp01id=sppredlo.sp01id And spdokobs.sp57id=spdoktyp.sp57id

ENDTEXT

If !bw_exec(.F.,_sql,'Data')

Return

Endif

* Pokud má být vytvářen XLS, potom _this.output_format='XLS'

If Empty(_this.output_format) Or _this.output_format<>'XLS'

Return

Endif

If _this.web

* Výstup do Excelu pro WBM musí být uložen v adresáři -> _this.rodic.Path s příponou XLSX nebo XLS

_this.rodic.output_file=_this.rodic.Path+'tmp\'+Stuff(Sys(2015),1,1,'')+'.xlsx'

Else

* Výstup do Excelu pro BM.EXE bude uložen v libovolném pracovním souboru s příponou XLSX nebo XLS

_this.rodic.output_file=bw_param('TMP','.xlsx')

Endif

* _xlapp = OLE object Excelu

_xlapp=Createobject( "Excel.Application")

* _xlwb = objekt dokumentu Excelu

_xlwb=_xlapp.workbooks.Add

* _xlsheet = objekt listu Excelu

_xlsheet=_xlwb.worksheets[1]

Select Data

_i=0

Scan All

* _i obsahuje číslo řádku

_i=_i+1

* sp26datum do prvního sloupce

_xlsheet.cells[_i,1].Value=sp26datum

* sp26nazev do druhého sloupce

_xlsheet.cells[_i,2].Value=sp26nazev

* bw01jmeno do třetího sloupce

_xlsheet.cells[_i,3].Value=bw01jmeno

Endscan

_xlapp.displayalerts=.F.

* uložení dokumentu

_xlwb.SaveAs(_this.rodic.output_file)

_xlapp.displayalerts=.T.

* uzavření dokumentu

_xlwb.Close()

_xlsheet=.F.

_xlwb=.F.

_xlapp=.F.

</pre>

Při vytváření stránky informačního panelu je dostupná vlastnost řídícího objektu vytváření stránky OUTPUT_FORMAT, která má při vytváření běžné stránky zobrazované v internetovém prohlížeči hodnotu 'prázdný text' a při vytváření stránky určené pro zobrazení v programu Windows obsahuje hodnotu, kterou je tříznaková přípona souboru. Přitom platí, že je-li stránka vytvářena s nastavenou vlastností OUTPUT_FORMAT řídícího objektu, potom do vytvářených tabulek nejsou vkládány hypertextové odkazy, je potlačeno vytváření automatických hlaviček a patiček stránky a po vytvoření stránky je vyvolán program Windows podle uvedené přípony (hodnoty vlastnosti OUTPUT_FORMAT).

Do stránky informačního panelu je možné vkládat hypertextové odkazy, které zajistí vytvoření stránky s nastavenou vlastností řídícího objektu vytváření stránky OUTPUT_FORMAT třemi způsoby:

- v kódu patičky prezentace stránky

- ve vlastnosti POSTTEXT definice uzlu informačního panelu

- hypertextovým odkazem, který je součástí tabulky informačního panelu

K tomuto účelu slouží např. uživatelská knihovna vkládaného kódu USRPAN. S knihovnou USRPAN je možné zadat v kódu patičky prezentace stránky nebo ve vlastnosti POSTTEXT definice uzlu informačního panelu kód:

<pre>

#SCRIPT

Return zobrazit_v_excelu_a_wordu(_this)

#INCLUDE USRPAN

</pre>

Takto budou do stránky vloženy hypertexty, které převedou do programu Windows celou zobrazenou stránku (může to být více tabulek).

Při vytváření stránky určené pro zobrazení v programu Windows je pro úspěšné uplatnění stylů nutné, aby styly byly přímo obsaženy v souboru předaném programu Windows. Proto je třeba zasáhnou do popisu stylu v prezentaci stránky informačního panelu a v jeho kódu podmínit v případě, že je nastavena vlastnost OUTPUT_FORMAT řídícího objektu, vložení textu stylů do vytvářené stránky.

Např. s užitím knihovny USRPAN:

<pre>

#SCRIPT

Return vrat_styl(_this)

#INCLUDE USRPAN

</pre>

V některých případech je vhodné pro výstup stránky do programu Windows vyloučit některé sloupce tabulky, řádky tabulky,prvky stránek nebo celou jednotlivou tabulku zobrazenou na stránce (poslední platí pro hypertexty v kódu patičky prezentace stránky nebo ve vlastnosti POSTTEXT definice uzlu informačního panelu). V tom případě je možné uvádět ve vlastnosti Podmínka v definici takového sloupce, řádku, prvku stránky nebo podřízeného uzlu výraz 'EMPTY(this.output_format)'.

Pro uzel typu „Prvek stránky“ je možno nastavit tyto parametry typu prvku:

¨ „-„ – bude vytvořen seznam hypertextových odkazů s texty podle vyhodnocení výrazu uvedeného v parametru „výraz názvu“ – počet těchto odkazů odpovídá počtu záznamů vrácených SQL dotazem

¨ „tabulka“ – bude vytvořena tabulka podle popisu tabulky

¨ „odkazy s vyvoláním skriptu“ – bude vytvořen seznam hypertextových odkazů s texty podle vyhodnocení výrazu uvedeného v parametru „výraz názvu“ – počet těchto odkazů odpovídá počtu záznamů vrácených SQL dotazem

Při nastavení atributu „Typ prvku“ s jiným parametrem než „tabulka“ je nutno takový uzel zařadit pod jiný uzel (tzn. vytvořit poduzel uzlu) s nastavením parametru „Návěští – Odkaz na stránku“.

Stisk hypertextu vytvořeného pro uzel s typem prvku „-„ způsobí zobrazení stránky, která je sestavena podle definovaných vztahů s poduzly tohoto uzlu.

Pro uzel „Prvek stránky“ s parametrem „Odkazy s vyvoláním skriptu“ se na záložce Další definuje parametr SKRIPT, ve kterém se uvádí skript v jazyce Foxpro. Tento skript je vyhodnocován při vytváření stránky a vrací jiný skript v jazyce Foxpro, který bude aktivován při stisku odpovídajícího hypertextu a přitom je okno informačního panelu minimalizováno, pokud neprovedl skript při vytváření stránky nastavení _THIS.HREF_WEB=.T..

Pro uzel typu Prvek stránky - tabulka se definují sloupce a elementy sloupců tabulky. Na záložce Sloupce:

¨ sloupec - číslo - jednoznačně identifikuje sloupec - určuje pořadí sloupce

¨ návěští sloupce - určuje návěští sloupce ve vytvářené tabulce. Za znakem ‘~’ (vlnovka) je možno uvádět výraz v syntaxi FoxPro, který je vyhodnocován v okamžiku vytváření tabulky a zjištěná hodnota je vložena do vytvářené tabulky.

¨ HTML–atributy – atributy návěští sloupce následované výrazem v jazyce Foxpro oddělené klávesou Enter (např. TITLE=výraz v jazyce Foxpro)

¨ formát - určuje formát zobrazení hodnoty ve sloupci (např. 999 999 999.99). V tomto atributu je možno uvádět formáty času, zapsané v následujícím tvaru:

- @*TM - převádí numerickou hodnotu, která odpovídá počtu vteřin do tvaru MMM:SS

- @*TH - převádí numerickou hodnotu, která odpovídá počtu vteřin do tvaru HHH:MM

Oba tyto formáty je možno rovněž uvádět ve tvaru @Z*TM, resp. @Z*TH, kterými je do výstupu vkládán prázdný text v případě, že je formátovaný počet vteřin nulový (uvedené formáty nejsou součástí jazyka Visual Foxpro).

¨ podmínka – podmínka zařazení sloupce do tabulky (výraz v syntaxi FoxPro)

¨ výraz třídění – výraz třídění dat vrácený dotazem SQL (výraz v syntaxi FoxPro) – pro takto definovaný sloupec je ve výsledné HTML stránce návěští sloupce uvedeno ve tvaru hypertextového odkazu. Výraz třídění může být uveden znakem '*'. Tímto způsobem se definuje střídavé vzestupné a sestupné třídění při opakovaném stisku hypertextu návěští sloupce. Po stisku tohoto hypertextového odkazu je stránka přezobrazena setříděná podle hodnot získaných na základě výrazu třídění sloupce.

Poznámka:

Výraz třídění by měl reflektovat možnost výskytu hodnoty NULL v obsažených atributech (obvykle se to týká datumových atributů). Např. NVL(sp34datuko,DTOT({}))

¨ zarovnání ve sloupci - vpravo / na střed / vlevo

¨ součtový sloupec - na konci tabulky bude vytvořen součtový řádek se součtem v tomto sloupci (volba Ano/Ne)

Příklad definice HTML-atributů návěští sloupce:

TITLE='Setřízení tabulky podle data splatnosti pohledávky'

TARGET=iif(this.web,'_blank','_self')

Na záložce Řádky se definuje:

¨ Ř – číslo pásu/číslo řádku/návěští řádku - určuje návěští řádku ve vytvářené tabulce. Za znakem ‘~’ (vlnovka) je možno uvádět výraz v syntaxi FoxPro, který je vyhodnocován v okamžiku vytváření tabulky a zjištěná hodnota je vložena do vytvářené tabulky.

¨ podmínka – podmínka zařazení řádku do tabulky (výraz v syntaxi FoxPro)

¨ atributy elementu – atributy elementu řádku (TR) oddělené enterem

Záložka Další poskytuje uživateli možnost nastavit pro rozsáhlé tabulky zobrazované na stránkách informačního panelu stránkování:

¨ uzel – identifikátor a název uzlu

¨ prázdná, Ř. hlavičky, Ř. patičky – příznak, zda vytvářená tabulka může být prázdná (volba Ano/Ne) a počet řádků hlavičky a patičky

¨ sektor – pozice sektoru stránky ve tvaru písmeno+číslo – písmeno určuje pozici v ose X, číslo určuje pozici v ose Y + popis stylu tabulky rozvržení sektorů

¨ počet z. – volba, zda zobrazovat počet záznamů při uplatnění uzlu na stránce jako odkaz (možnosti Ano/Ne)

¨ stránkování – uvádí se číslo, které znamená, že po zadaném počtu záznamů se má stránkovat (hodnota nula znamená, že se stránkování neprovádí). V případě, že počet záznamů pro vytvoření tabulky nepřekročí zde uvedené číslo, potom se řádek s odkazy pro přechod na stránky tabulky nevytváří.

¨ odkazy – výběr z možností v překryvném seznamu (před tabulku/za tabulku/před i za tabulku) – určuje, kam má být umístěn řádek s odkazy pro přechod na jednotlivé stránky

¨ zahrnout – výběr z možností v překryvném seznamu (do tabulky/mimo tabulku) – určuje, jestli má být řádek s odkazy pro přechod na jednotlivé stránky umístěn jako součást tabulky nebo má být umístěn mimo tabulku

¨ tag – text - určuje grafické vlastnosti řádku s odkazy (např. TD STYLE="background:yellow; font-size:120%; text-align=center"), při umístění řádku s odkazy mimo tabulku jsou tagy TD a TH nahrazeny za tag DIV

¨ návěští - text - je určeno pro doplnění textu do řádku s odkazy (např.: <B>Stránky</B>). V textu návěští se může vyskytovat makro ###, které určuje umístění bloku s odkazy v textu návěští (např. 'Text před odkazy ### Text za odkazy' může zobrazit 'Text před odkazy 1 2 3 4 >>> Text za odkazy')

¨ refresh – v tomto atributu se udává čas (ve vteřinách), po jehož uplynutí má být stránka obnovena (příklad z praxe: ve skladu se skladníkovi automaticky aktualizuje stránka, na které se mu zobrazují skladové výdejky vytvářené na jiném pracovišti)

¨ pretext – text zobrazený na HTML před vyhodnocením uzlu

¨ posttext – text zobrazený na HTML po vyhodnocení uzlu

¨ skript – kód v jazyce FoxPro

¨ atributy elementu BODY - pro tvar definice platí stejná pravidla jako pro definování atributů elementů resp. sloupců, s těmito rozdíly:

a/ je možné použít vložení definice uložené v knihovnách vkládaného kódu klausulí #INCLUDE

b/ pokud je
prvním slovem definice slovo NODEFAULT, potom nebudou v elementu BODY atributy
'topmargin=0 id="bodyID"
class = "dtBODY"',
které jsou jinak do elementu vkládány automaticky, např.: onLoad="return relatedActions('ob11id','sp99','sp24idmj','ob02cj01c');"

¨ poznámka – libovolný komentář

V řádku s odkazy jsou odkazy na jednotlivé stránky představovány jejich pořadovými čísly a v případě, že byla data pro zobrazení tabulky setříděna příkazem FoxPro INDEX (tzn. že pro tabulku se uplatní Výraz třídění nebo ji uživatel setřídil klikem na návěští některého jejího sloupce), zobrazuje se při pohybu myší přes číslo stránky text (tooltip), který je vyhodnocením indexového výrazu pro první záznam zobrazovaný na stránce.

V řádku s odkazy je zobrazován seznam maximálně 21 odkazů na jednotlivé stránky tabulky. V případě, že v tomto seznamu není obsažena první stránka, potom řádek s odkazy obsahuje také odkaz s textem '<<<', který způsobuje přechod na stránku s pořadovým číslem (aktuálně_zobrazená_stránka - 20). V případě, že v seznamu odkazů není obsažena poslední stránka, potom řádek s odkazy obsahuje také odkaz s textem '>>>', který způsobuje přechod na stránku s pořadovým číslem (aktuálně_zobrazená_stránka + 20). Pokud tabulka obsahuje sloupce, které je možné třídit, potom je vždy po setřídění klikem na návěští sloupce zobrazována její první stránka.

Pro stránkovanou tabulku musí platit, že se identifikace uzlu informačního panelu, kterým je tabulka definována (včetně Alias - pokud se tabulka uplatňuje na stránce informačního panelu jako poduzel), vyskytne při vytváření stránky informačního panelu právě jednou.

Narozdíl od funkčnosti třídění nestránkované tabulky (klik na návěští sloupce – kde zároveň platí, že pokud je tabulka součástí skupiny tabulek, potom je setříděná tabulka zobrazena samostatně, tzn. není zobrazována stránka, ve které je tabulka obsažena, ale samostatná stránka tabulky), funguje třídění stránkované tabulky (klik na návěští sloupce) tak, že setříděná tabulka je zobrazována znovu jako součást skupiny tabulek. Stejné je chování při přechodu na jinou stránku tabulky, tzn. při přechodu na jinou stránku tabulky je zobrazována stránka informačního panelu, ve které je tabulka obsažena.

Poznámka: Této vlastnosti je možné využít i pro tabulky s možností třídění klikem na návěští sloupce, pro které platí pravidlo její jednoznačné identifikace ve vytvářené stránce informačního panelu a přitom pro tuto tabulku nemá smysl stránkovat. Stačí zadat do vlastnosti uzlu tabulky 'Stránkování' velkou hodnotu a potom bude po kliku na návěští sloupce zobrazována stránka informačního panelu, ve které je tabulka obsažena.

Záložka Sektory poskytuje uživateli možnost definovat pro každou stránku informačního panelu její rozčlenění na sektory. Sektory jsou ve výsledném HTML textu realizovány pomocí tabulky (dále jen tabulky rozvržení sektorů). Pro každý sektor se definuje:

¨ identifikace sektoru – je tvořena 2 znaky – označuje pozici sektoru stránky ve tvaru písmeno + číslo – písmeno určuje pozici v ose X, číslo určuje pozici v ose Y

¨ maximální počet sloupců sloučených do sektoru – číselná hodnota

¨ maximální počet řádků sloučených do sektoru – číselná hodnota

¨ popis sektoru – slovní popis sektoru (tento atribut se neuplatňuje ve výstupu)

¨ prázdný sektor – překryvný seznam Ano/Ne – určuje, zda má být sektor zobrazen i v případě, když je prázdný

¨ pretext – text vložený před buňku selektoru

¨ tag buňky – výraz, který definuje tag buňky vztaženého elementu

¨ posttext – text vložený za buňku sektoru

¨ poznámka – libovolný komentář k sektoru

Na záložce Poduzly uzlu se definují uzly připojené k danému uzlu. Typicky se k uzlům typu Informační panel připojují uzly typu 'Stránka panelu' a pod uzly typu 'Stránka panelu' uzly typu 'Prvek stránky'.

Uvádí se:

¨ uzel - identifikace uzlu

¨ pozice sektoru stránky ve tvaru písmeno + číslo

¨ pořadí - určuje pořadí zpracování uzlu (tj. také zobrazení výstupu uzlu na stránce)

¨ alias - umožňuje použít stejný uzel jako podřízený opakovaně

¨ název podřízeného uzlu - je-li uveden, potom je na stránce zobrazen tento text jako návěští (jinak je zobrazen text uvedený v definici uzlu)

¨ parametry – skutečné parametry použité v doplnění where poduzlu (předané do doplnění příkazu SQL uzlu, kde jsou pozičně reprezentované jako ?_p1, ?_p2 .... (maximální počet parametrů je 14))

¨ atributy - jsou doplňující atributy SQL dotazu podřízeného uzlu, které jsou vkládány do tohoto dotazu přímo za SELECT. Jsou-li uvedeny atributy, potom za posledním musí být uvedena čárka. Např. 'adadsat.ad01adsat, adspoj.ad11jmeno,' nebo 'TOP 200'

¨ from - je doplnění SQL dotazu podřízeného uzlu v jeho části za FROM

¨ where - je doplnění SQL dotazu podřízeného uzlu v jeho části za WHERE

¨ výraz třídění – výraz třídění dat vrácených dotazem SQL

¨ podmínka – podmínka zařazení poduzlu

Záložka Další obsahuje atributy, kde je možno se na nadefinované sektory odkazovat:

¨ sektor – pozice sektoru stránky ve tvaru písmeno + číslo

¨ popis stylu tabulky rozvržení sektorů (např. class=“dtTABLE“ cellspacing=“0“)

¨ alias - umožňuje použít stejný uzel jako podřízený opakovaně

¨ index - identifikátor pomocí kterého se je možné hypertextově odkazovat v XML dokumentech

¨ PRETEXT - text vložený před obsah vytvořený zpracováním uzlu

¨ POSTTEXT - text vložený za obsah vytvořený zpracováním uzlu

V atributech PRETEXT a POSTTEXT je možné uvádět kód v jazyce Foxpro. V tomto případě se uvádí na začátku textu slovo #SCRIPT. Tento kód musí vracet text, který je vložen do stránky.

Příklad vložení tabulky do sektoru:

¨ vlastnost Pretext sektoru -

<pre>

<table class="dtTABLE_papayawhip" cellspacing="0"><tr><th>Mám řešit úkoly</th></tr><td>

</pre>

¨ vlastnost Posttext sektoru -

<pre>

</tr></table></td>

</pre>

Na záložce Elementy sloupců se uvádí:

¨ sloupec - určuje sloupec umístění elementu (číslo pásu – řádku – sloupce)

¨ pořadí elementu

¨ break - Ano/Ne - za element vložení do sloupce může být vloženo odřádkování

¨ výraz - výraz v syntaxi Foxpro jehož vyhodnocená hodnota bude vložena do tabulky

¨ hypertext - s elementem bude spojen hypertextový odkaz

¨ jiný název – jiný název uzlu informačního panelu – za znakem ~ je možno zadat výraz (překrývá jiný název v hypertextu)

¨ parametry – skutečné parametry použité v doplnění where hypertextového odkazu (přebíjejí parametry uvedené v definici hypertextového odkazu)

¨ tučně - zobrazení elementu tučně

¨ kurzíva - zobrazení elementu kurzívou

¨ podtržené - zobrazení elementu podtrženě

¨ tag - jiný tag elementu - např. H2 - vloží <H2>[hodnota elementu]</H2>

¨ HTML–atributy – atributy elementu následované výrazem v jazyce Foxpro oddělené klávesou Enter (např. TITLE=výraz v jazyce Foxpro). Určené HTML-atributy vytvářeného elementu tabulky se uplatí pouze v případě, že:

- element má zaškrtnuto – Tučně nebo Kurzíva nebo Podtržené

- nebo je s elementem spojen hypertextový odkaz

- nebo má element uveden jiný tag (např. neutrální DIV)

¨ podmínka – podmínka zařazení elementu na stránku

Příklad definice HTML-atributů vytvářeného elementu tabulky:

TITLE='Kategorie
adresáta:'+chr(13)+tool.sql_dotaz([select
list(trim(ad08kateg),char(13))
from %%%.adkatads,%%%.adkat
where adkatads.ad01id=?_p1 and adkat.ad08id=adkatads.ad08id],ad01id)

Uživatel má možnost doplnění elementu TR tabulky o další atributy. Na záložce Řádky je k tomuto účelu určena položka „Atributy elementu“. Dále uvedená pravidla se uplatňují také pro odpovídající nastavení návěští sloupce a elementu tabulky. V těchto položkách se uvádějí jednotlivé HTML – atributy elementu následované výrazem v jazyce Foxpro, oddělené klávesou Enter.

Př.: BGCOLOR=IIF(MOD(this.citac_radku,2)=1,'YELLOW','')

Pokud je hodnota vyhodnoceného výrazu prázdná, potom není atribut do elementu vkládán, jinak je hodnota atributu uvedena ohraničením apostrofy (pro uvedený příklad BGCOLOR="YELLOW").

Je-li název atributu uvedený znakem vlnovka, potom hodnota atributu není ohraničena apostrofy.

Např.: ~BGCOLOR=IIF(MOD(this.citac_radku,2)=1,'YELLOW','') -> BGCOLOR=YELLOW

Syntaxe ~= vkládá mezi atributy elementu přímo text bez jakéhokoliv formátování.

Např.: ~=IIF(MOD(this.citac_radku,2)=1,'BGCOLOR=YELLOW','') -> BGCOLOR=YELLOW

Stejné nastavení (tzn. položka „atributy elementů TR“) lze využít v činnosti Prezentace stránek panelů. V případě, že je uvedeno nastavení u jednotlivého řádku v definici uzlů inf. panelů a zároveň v prezentaci stránky, tak se poté uplatní obě tato nastavení.

Poznámka:

Součástí „návodů a balíčků“ je balíček obsahující definice uzlů informačního panelu, které vytvářejí stránky odpovídající hlavnímu menu programu (nebo jeho části). Z těchto stránek je možné spouštět činnosti BM stejně jako z hlavního menu programu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 18.09.2014


Pojem - Definice výkazu

Definicí výkazu zde rozumíme uživatelská nastavení, na základě kterých je sestaven výkaz z aktuálních dat (obvykle z dat uživatele) v okamžiku, kdy si toto sestavení uživatel vyvolá.

Součástí definice výkazu je druh výkazu, dotaz výkazu, výstupní soubor, do kterého bude výkaz sestavován, výraz názvu, heslo, pokud je výkaz definován jako uzamčený pro uživatele po sestavení, volný text pro poznámky a volba zda zobrazovat seznam polí (má význam v okamžiku, kdy uživatel využívá ve výkazech možností kontingenčních tabulek).

Nezbytnou součástí jsou definice listů výkazů přiřazených k dané definici výkazu s uvedením specifických vlastností každé definice listu v ní, tj. inicializační parametry a parametry definice listu a případný název listu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 20.02.2013


Pojem - Definice vyvolání

Je jedním z nástrojů jak uživatel realizuje napojení do procesu (do již vytvořeného procesu). Definuje se druh procesu (ten, který bude vytvořen a do kterého se tímto napojujeme) a druh operace (tzn. která operace v rámci tohoto napojení se má aktivovat), jinými slovy je možno říci, že druh operace je v tomto případě uzlem zvoleného druhu procesu. Pokud je tímto uzlem proces, tak se při definici vyvolání neuvádí komponenta.

Např. pokud se jedná o definici typu, kdy se z příjemek vytváří výdajový pokladní doklad, pak je v této definici uvedena identifikace procesu, do kterého se napojujeme a zároveň identifikace procesu, jehož první operace se bude vytvářet (bez předchozího uvedení komponenty).

Při vyvolání (spuštění) takové definice se uživateli objeví okno, kde zadá identifikaci procesu (tj. v tomto případě číslo vystavené příjemky) a následně se mu spustí první operace procesu zadaného v definici vyvolání u atributu Operace.

Tento způsob napojení se užívá tehdy, je-li známo číslo procesu, do kterého se napojujeme, tzn. na vytištěné příjemce je v každém případě uvedeno její číslo, které si pak uživatel, který se pomocí této definice napojuje, přečte a zadá jej do políčka „číslo procesu“. Druhým příkladem správného číslování dokladů může být definice vyvolání, kdy např. vystavujeme objednávku k dodavateli a po tomto dodavateli budeme požadovat, aby číslo naší objednávky uváděl na svých dodacích listech. Právě díky tomuto uvedenému číslu je pak možno se pomocí definice vyvolání napojit z objednávek do dodacích listů.

Každá vytvořená definice vyvolání má vliv na zobrazení hlavního menu, automaticky se „zapisuje“ pod činnost hlavního menu Napojení do procesu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Definiční data

Jedná se o tu část IS, která pouze ovlivňuje chování software. Tato data (metadata, tj. informace) pro uživatele nemají žádnou informační hodnotu (nedisponují informační schopností) a v omezené variantě je může obsahovat již poskytovaný IS. Je to například struktura databází, definice výstupů, druhy procesů a operací, metainformace, některé číselníky, definice výkazů, jejich listů, vzorů a funkcí, obecné výběry, volné karty, uživatelské triggery apod. Řada z nich je uživatelem modifikovatelná, některé v syntaxi Sybase SQL Anywhere, jiné v syntaxi Visual FoxPro:

¨ v pravidlech transformace – doplnění atributů syntaxe SQL - v poli "Atributy" je možné zadat atributy, které rozšíří nabídku atributů pro transformaci (zařadí se před FROM). V poli "Select-join" je možné doplnit dotaz o odkaz na další tabulky (zařadí se za FROM). V poli "Výběr" se zadávají doplňující podmínky odvislé od obsahu "Select-join" (zařadí se za WHERE) nebo mohou obsahovat případný ORDER. Atribut "Slučování" (Ano/Ne) určuje, zda má být výsledný pohled složen s definicí pohledu transformace dodaného s BM. Atribut "Fetchmemo" (Ano/Ne) by měl být nastaven na "Ano" v případě, že připojený atribut z další tabulky je charakteru text (memo).

¨ v pravidlech transformace - výrazy syntaxe Visual FoxPro

¨ volné karty – syntaxe Visual FoxPro, SQL (záložka atributy volné struktury - atribut inicializace - syntaxe FoxPro, záložka volné pohledy - syntaxe SQL)

¨ šablony – u proměných (inicializace,naplnění) FoxPro

¨ předlohy výstupu – při editování předlohy syntaxe Visual FoxPro, ve vlastnostech předlohy je syntaxe SQL

¨ obecné výběry – syntaxe SQL, při výpočtu jednotlivých proměnných obecného výběru je však syntaxe Visual FoxPro

¨ uživatelské triggery – syntaxe SQL

¨ masky operace a použití obecných předkontací – syntaxe Visual FoxPro

¨ kód po ukončení operace – syntaxe Visual FoxPro + je možno připojit objekt, který provede SQL dotaz

Pro nastavení definičních dat je v řadě případů potřebná znalost datového modelu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.11.2007


Pojem - Definování typu kategorie adresáta

Pro možnost použití palety barev a definice kategorií spojení adresáta byly rozšířeny vlastnosti kategorie adresáta o další atributy. Tyto atributy se nevstupují přímo ve formuláři „kategorie adresátů“, ale pomocí činnosti „definování typu kategorie adresáta“ (menu volby nebo klávesa F5) z tohoto formuláře.

Vzhledem k činnosti paleta barev byly rozšířeny vlastnosti kategorie adresáta o tyto atributy:

¨ typ - překryvný seznam Vstupovaná/Vypočítaná

¨ SQL - memo pole - SQL výraz pro typ Vypočítaná

Stanovení příslušnosti adresáta v kategorii podle typu:

¨ kategorie typu Vstupovaná - adresát patří do kategorie, pokud má u sebe uveden záznam o zařazení do kategorie platný k aktuálnímu datu

¨ kategorie typu Vypočítaná - adresát patří do kategorie, pokud vyhodnocení výrazu SQL vrátí hodnotu větší než 0. Tento výraz v syntaxi SQL Anywhere je vyhodnocován při zpracování SQL dotazu. Používají se v něm proměnné @ad01id (adresát), @ad11cispo (spojení adresáta), @bw01uziv (aktuálně přihlášený uživatel systému), @datum (datum vyhodnocení - obvykle aktuální datum systému). Vyhodnocením výrazu musí být numerická hodnota.

¨ testovat – provede test zadaného SQL dotazu (tzn. pro kategorie Vypočítané). Protože je výraz vyhodnocován uloženou procedurou až při zpracování SQL dotazu a není kompilován na straně klienta tak, jak je to v případě obecných výběrů, může chybně definovaný SQL výraz způsobovat to, že dotaz bude vracet žádný nebo menší počet záznamů než by měl bez nahlášení chyby. V atributu adresát se uvádí fiktivní číslo adresáta (v adresáři ale musí existovat), které má smysl pouze pro ověření daného SQL dotazu, na definici vypočítané kategorie jinak nemá žádný vliv.

Možné příklady SQL dotazů:

1. adresát je naším odběratelem

(select count() from %%%.obudal where ad01id=@ad01id and ob02privyd=4)

2. adresát je naším dodavatelem

(select count() from %%%.obudal where ad01id=@ad01id and ob02privyd=3)

3. adresát je naším odběratelem v posledním roce

(select count() from %%%.obudal where ad01id=@ad01id and ob02privyd=4 and ob02dat between @datum-365 and @datum)

4. adresát je naším dlužníkem

if exists(select * from %%%.pluda where ad01id=@ad01id and pl02pohzav=1 and pl02uhraze=0) then 1 else 0 endif

Pozn.: v příkladech 1,2 a 3 byl použita funkce COUNT, lépe pro efektivní zpracování dotazu by bylo užít způsob IF EXISTS(SELECT * ....

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 06.03.2009


Pojem - Deklarovaná menu

Deklarovaná menu je okno činnosti menu, které si uživatel spustí tím, že v horní liště hlavního menu pod volbou Menu aktivuje činnost otevřít menu. Tím se mu zobrazí okno „deklarovaná menu“, kde při prvním spuštění má k dispozici pouze základní definici menu, ze které si v případě potřeby může odvodit menu nová. V případě, že již má odvozeny nové definice menu, zobrazí se mu aktivací okna deklarovaná menu strom celého menu, kde se zobrazuje základní definice menu a menu od něj odvozená.

Není podmínkou odvozovat nové definice menu pouze na základě základní definice menu. Nové menu lze odvodit z jakékoliv definice menu (po stisku pravého tlačítka myši na názvu menu a volbě „odvodit menu“).

Celé okno deklarovaná menu se pak uživateli vizuálně jeví obdobně jako okno hlavního menu při zobrazení ikon způsobem strom činností. Zobrazení jednotlivých definic menu je rovněž v režimu „strom činností“, tzn. že každé definici menu, ze které byly odvozeny další definice menu, předchází znaménko plus. Po jeho stisku (levé tlačítko myši) se uživateli nabídnou odvozená menu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Design

V IS BM se heslo design používá ve spojení s návrhem vzhledu jednotlivých formulářů, kde je uživatelsky umožněno si právě tento vzhled navrhnout. Jedná se především o formuláře šablon, volných karet, obecných výběrů apod., kde uživatel po nadefinování jednotlivých položek určí design formuláře čili si vytvoří vlastní návrh rozmístění atributů v okně.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.11.2007


Pojem - Diagram procesu

Operace (i z různých komponent) spolu v reálném světě souvisí, a tak je i systém umožňuje řadit do procesu, který popisuje jejich posloupnost tak, jak v reálném světě probíhaly (u druhu procesu tak, jak se předpokládá, že budou probíhat).

V IS BM je tato posloupnost vyjádřena diagramem procesu, tzn. že každý druh procesu má svůj diagram (i v grafickém vyjádření), který se skládá z jednotlivých uzlů a vazeb mezi nimi. Vazba vyjadřuje vztah mezi zdrojovým a cílovým uzlem a v diagramu procesu je vyjádřena šipkou. Chování cílového uzlu souvisí s nastaveným způsobem jeho spuštění. Každý diagram procesu má jednotné ovládání.

Diagram procesu se je možno spustit z různých činností (např. druhů procesů, z fyzických procesů, z událostí jednotlivých komponent) vždy vyvoláním příslušné činnosti z menu Volby (v některých činnostech je možno i na klávesu F7). Po stisku pravého tlačítka myši na ploše okna diagramu se zobrazí menu, ve kterém je seznam oken včetně okna hlavního menu programu. Výběrem z tohoto seznamu se lze rychle přepnout do vybraného okna.

Uživatel, který nemá právo k činnosti „diagram procesu“ vyvolávané z formuláře „procesy“, nemá dostupnou možnost vyvolat diagram procesu z formulářů událostí operací komponent, ani ze stromu hlavního procesu.

V diagramu procesu lze definovat (analyzovat) řadu vlastností procesu, která v jiných zobrazeních procesu (strom, operace v procesu, ...) nejsou k dispozici.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 29.02.2012


Pojem - Dialogové okno

Jedná se o okno činnosti, kde je uživatel informačním systémem „vyzván ke spolupráci“, tzn. zaškrtnutím příslušné volby si volí pokračování v procesu, zadáním data od do (tj. období) si určuje výpočet výkazu, vyplňuje šablonu pro hromadný vstup pošty, zadává podmínky tisku apod. Jedná se tedy o okno činnosti, kde je nutná přímá účast uživatele, musí svým rozhodnutím a zadáním potřebných údajů určit další chování systému.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Dialogové okno tisku předlohy výstupu

Jedná se o okno tisku předlohy „zahájení výstupu podle předlohy“, které uživatel vyvolá aktivací tisku vybrané předlohy výstupu (dvojklikem myši nebo stiskem příslušné ikony v panelu nástrojů). Uživatel si může zvolit:

¨ počet kopií – předplní se počet, který má předloha uveden ve vlastnostech. V případě, že by chtěl uživatel tento počet změnit, musí odškrtnout příznak nastavení tisku, teprve pak je tento atribut dostupný.

¨ výstup – zda se má tisknout na tiskárnu, do souboru nebo zda chce data jenom prohlížet

¨ rozsah tisku – zda tisknout:

- všechny záznamy – tj. všechny vybrané

- aktuální záznam – tj. ten, na kterém je umístěn kurzor

- označené záznamy

- všechny možné – tiskne všechny záznamy, které má k dispozici daná tabulka bez ohledu na to, které záznamy má právě uživatel vybrané v daném okně (např. adresář´- uživatel má ve výběru zvolenu určitou kategorii. Při tisku všech možných ale systém pomine tento výběr a tisknul by kompletně celý adresář).

- pouze součtové údaje – pokud předloha obsahuje atributy, u kterých je nadefinovaná SUMA, vytiskne daná sestava pouze tyto atributy, ostatní vynechá.

- nastavení tisku – zaškrtnutí znamená, že po stisku OK se systém bude dotazovat na cestu na tiskárnu, při odškrtnutí tiskne rovnou na zvolenou implicitní tiskárnu

- opravovat – před tiskem se předloha uživateli zobrazí ve tvaru, kde má možnost některé vybrané atributy opravit

¨ jazyk – výběr jazyku předlohy (v případě cizího jazyku musí být ale položky výstupu do tohoto jazyku přeloženy)

¨ setřídění – způsob setřídění předlohy

¨ podmínka – zde má uživatel možnost si z překryvného seznamu vybrat nadefinovaný výběr (ikona v panelu nástrojů)

¨ log. výraz – souvisí s nadefinovaným výběrem. Pokud výběr obsahuje určitý logický výraz, tak při volbě daného výběru je tento logický výraz nahrazen daným atributem. Např. uživatel bude mít nadefinovám výběr za kategorii adresáta. V podmínce vybere tento výběr a log. výraz bude nahrazen atributem kategorie, kde ji uživatel přímo uvede. Pokud by zvolený výběr neobsahoval žádný logický výraz, je tento atribut nedostupný.

¨ text – libovolná poznámka

Po stisku tlačítka OK probíhá tisk podle nastaveného atributu výstup.

Na základě nastavení ve vlastnostech předlohy nebo profilech spuštění nemusí uživatel toto okno mít vůbec k dispozici, tzn. nezobrazuje se mu, tisk probíhá automaticky přímo bez účasti uživatele.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.09.2013


Pojem - Dodatečné daňové přiznání

Daňové přiznání, které z vlastní iniciativy předkládá daňový subjekt, zjistí-li po uplynutí řádné lhůty pro podání daňového přiznání, že jím podané řádné daňové přiznání bylo chybné. Zjistí-li daňový subjekt svou chybu ještě před uplynutím řádné lhůty pro podání daňového přiznání, může podat opravné daňové přiznání. Po zmeškání této lhůty musí podat dodatečné daňové přiznání.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Doklad

V reálném světě je doklad formulář, který obsahuje určité informace, obvykle autorizované a který je identifikovatelný určitým číslem.

Doklady v informačním systému Bílý Motýl se číslují na základě číselné řady. Číselná řada dokladů je vlastností (atributem) druhu procesu [1].

V IS Bílý Motýl se dokladem rozumí tiskový výstup definovaný v činnosti „procesy”. V definici takového tiskového výstupu (předlohy) se velmi často využívá prezentace procesů. U vybraných druhů procesů lze definovat implicitní metapředlohy pro výstup dokladu.

K používání automatizovaného tisku dokladů po zadání údajů pro doklad (tj. vlastně tisk obrazu procesu) je nutno dodržet následující kroky:

¨ u druhu procesu je nutno mít nadefinovanou metapředlohu výstupu

¨ předloha výstupu musí mít prezentaci uvedenou ve svých vlastnostech a zároveň musí být daná předloha uvedená v příslušné metapředloze

¨ v diagramu daného druhu procesu musí být nastaven příznak „po ukončení operace tisk dokladu”[2]

Podobně jako nastavení tisku dokladu z procesu, je možno nastavit i tisk jen z událostí jedné operace (tj. tisk zjednodušeného dokladu). Nastavení tohoto tisku se provádí v diagramu druhu procesu, kde se ve vlastnostech operace zatrhne příznak „po ukončení operace tisk operace” a příslušná metapředloha výstupu se vybere z překryvného seznamu. Tato metapředloha musí být vytvořena v činnosti s přehledem událostí dané komponenty, jinak se v tomto překryvném seznamu nenabízí a příslušná předloha musí být do této metapředlohy zařazena.

Obě tyto možnosti (tisk dokladu nad procesem, tisk po ukončení operace) jsou ukázkou tzv. automatického tisku, tzn. že nezávisle na uživateli se po ukončení operace automaticky tiskne doklad. Další metoda automatického tisku je definovatelná pomocí kódu po ukončení operace.

Při tomto nastavení je pak možno v procesech, operacích, událostech tisknout doklady poměrně rychle[3].

Ať už se jedná o tisk dokladů nebo o tisk zjednodušených dokladů je možno v případě potřeby využít cizojazyčnosti. Tisk cizojazyčných dokladů nese tyto problémy, které je nutno implementačně vyřešit. Plně automatizovaný tisk dokladů (tzn. vlastnost „tisknout bez zastavení“) je možný jen v jazyce definovaném u předlohy. Proces s možností dokladu ve více jazycích musí být nastaven tak, že o jazyce rozhodne obsluha. Alternativní varianty řešení jsou:

¨ míti tolik procesů, kolik chceme použít jazyků u dokladů

¨ v předloze ke každému atributu definovat podmíněný tisk dle jazyka stále uvedeného v adrese adresáta

¨ řešit v kódu po ukončení operace

[1] Zadává se v činnosti Informační centrum – Typy a řady – Druhy procesů – atribut „řada“.

[2] Provede se u operace v diagramu procesu po stisku pravého tlačítka myši a volbě vlastnosti.

[3] Doklady je pak zpětně možno tisknout v činnosti Procesy po stisku klávesy F5 a v událostech jednotlivých komponent po stisku klávesy F11. Tisk zjednodušeného dokladu je možný v činnosti Operace po stisku klávesy F5.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Dokumentace IS

Jedná se o tu část poskytovaného IS, která napomáhá uživateli seznámit se a naučit se užívat IS. Patří sem: popis IS, helpy, dokumentace implementace, dokumentace procesů a ovládání, novinky, wizardy, ale i samopopisné prvky - dokumentace implementace IS[1], datový model, message,....

[1] Dostupná v činnosti Informační centrum – Typy a řady – Druhy procesů pod menu Volby – činnost Generování a Prohlížení dokumentace.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.11.2007


Pojem - Dokumenty

Tato činnost se nachází v menu Marketing – Dokumenty – Dokument. Na základě zadaného výběru má uživatel k dispozici přehled dokumentů, které byly ve firmě vytvořeny. U každého dokumentu jsou k dispozici informace o jeho názvu, druhu, použité předloze a v případě externího uložení i cesta na soubor, kde je dokument uložen. Zároveň je možno zatržením příznaku „automatické ukládání verzí dokumentu“ sledovat i verze. U každého dokumentu je možno vytvořit i jeho duplikát, tj. soubor, který je uložen na pevném disku. Cestu na soubor, ve kterém má být daný dokument jako duplikát uložen, zadává uživatel v tomto atributu. Pro následnou práci s dokumentem pak platí, že změní-li uživatel dokument v IS BM, automaticky se mu stejně změní i duplikát na pevném disku. Opačný případ však nefunguje. Změní-li si uživatel duplikát na pevném disku, znamená to, že si soubor přepíše, jeho změny ale nebudou do dokumentu v IS BM přeneseny.

Dokumenty je možno aktivovat, tzn. zobrazit po stisku tlačítka „editovat dokument" nebo příslušnou činností z menu Volby. Jednotlivé záložky poskytují uživateli přehled o použití dokumentu, příslušnosti dokumentu k určité kategorii (po stisku F3 možno zařadit dokument k vybrané kategorii a datu) a jeho verzích. K jednotlivým dokumentům je možno pomocí vloženého objektu vytvořit prezentaci. V případě, že uživatel vytváří dokument pomocí vazby objektů, má k dispozici i činnost spojené dokumenty.

Obecný popis možností, které v IS BM skýtá práce s dokumenty je popsán v pojmu dokumenty – správa.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 24.07.2009


Pojem - Dokumenty - správa

IS Bílý Motýl® umožňuje správu dokumentů (Document Management), které lze prezentovat různými aplikacemi (MS Word, MS Excel, Akrobat Reader, MS Photoshop, MS Internet Explorer, Sybase Power Designer, …). Tyto dokumenty mohou být uloženy přímo v databázi nebo kdekoliv v dostupném informačním prostoru. Přístup k dokumentům je řízen přístupovými právy se sledováním způsobu užití dokumentů jednotlivými uživateli dle času. K dispozici je automatická tvorba duplikátu dokumentu na lokální disk a také automatické autorizované verzování těchto dokumentů při jejich změnách.

Jednotlivé dokumenty jsou objekty, takže je lze pohodlně připojovat k dalším objektům (například smlouvu k adresátovi, obraz primárního dokladu k účetnímu zápisu, technický výkres výrobku k technologickému postupu apod.) a z nich je rychle aktivovat (případně i automatizovaně), tj. dokument je po ruce právě v okamžiku, kdy jej potřebujete. Připojení dokumentů k procesům či jejich operacím (událostem) umožní i jejich automatické odesílání e-mailem.

Mezi možnosti automatické práce s dokumenty patří možnost zařadit výstup z dat (viz předlohy výstupu) prezentovaný v MS Word zcela automaticky jako dokument připojený k relevantnímu objektu (např. pracovní smlouvu k zaměstnanci). Dokumenty v MS Word, jako jsou například obchodní dopisy, lze též připojit k operaci pošty, kde jsou uvedeny adresy adresátů (příjemců zásilky) a další údaje, které lze v dokumentu automaticky aktualizovat pomocí funkcí hromadné korespondence.

Mezi zajímavé využití patří správa dokumentace systému řízení jakosti zejména ve vztahu k možnosti definovat schvalovací procesy.

Použitelné aplikace v IS Bílý Motýl® jsou uživatelsky definovatelné podobně jako předlohy sloužící k automatizaci tvorby standardizovaných dokumentů (např. smluv obchodních či pracovních, dopisů s možností aplikace hromadné korespondence, …).

Mezi další funkce patří možnost definovat schémata XML dokumentů včetně předloh XSLT pro definici formy výstupu. Tímto je umožněno v IS BM tvořit a spravovat poměrně rozsáhlé dokumentace, na nichž pracuje i několik autorů, s velkým množstvím vnitřních i vnějších vazeb při udržení trvalé integrity dokumentu. Tyto XML dokumenty lze následně pohodlně prohlížet internetovým browserem a to i v rámci informačních panelů IS Bílý Motýl®, kdy z těchto dokumentů lze přímo aktivovat i funkce IS Bílý Motýl®.

Do specifické skupiny dokumentů patří ty, které mají u své aplikace definovány akce, tj. celý život dokumentu je řízen dle přidělených akcí, které mohou dokument automaticky zakládat, aktualizovat, poskytovat vybraným uživatelům apod. O výsledku akcí je veden a archivován protokol. Mezi takového dokumenty patří i ty, kterými IS Bílý Motýl® komunikuje se státní správou (Evidenční list důchodového pojištění, Přihláška (odhláška) k nemocenskému pojištění, …), kde akce zajišťují vytvoření těchto dokumentů z dat při udržení integrity s předchozími dokumenty i s novými daty, dále akce zajišťují kompletní výměnu informací s IS státní správy včetně opravných chodů a samozřejmě jsou i tyto dokumenty trvale k dispozici kompetentním uživatelům.

K dalším vlastnostem dokumentů patří možnost opatřit je klíčovými slovy a pomocí nich a za pomoci wildcards vyhledávat rychle relevantní dokumenty.

Jak je patrné využití správy dokumentů v IS Bílý Motýl® je poměrně široké, ale mezi nejdůležitější vlastnosti správy dokumentů patří její plnohodnotné provázání na ostatní oblasti podnikání.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.11.2007


Pojem - Dokumenty – přehled o použití dokumentů

Jedná se o činnost, kterou má uživatel k dispozici v menu Marketing – Dokumenty. Poskytuje uživateli přehled o práci s jednotlivými dokumenty a zároveň slouží jako možnost ohlídání, zda některý z uživatelů nenahlédl omylem do citlivého dokumentu (při chybném nastavení přístupových práv k druhům dokumentů).

Uživatel má možnost si vyfiltrovat dokumenty za následující atributy:

¨ datum použití od – do

¨ za uživatele

¨ za způsob použití dokumentu (tzn. čtení, zápis)

¨ za název dokumentu

¨ za jeho druh, předlohu apod.

Další informace, které uživateli tato činnost poskytuje jsou tyto:

¨ zda je dokument uložen externě či je součástí databáze

¨ zda se jedná o dokument, který má příznak chráněný

¨ zda je nastaveno automatické ukládání revizí dokumentu

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.11.2007


Pojem - Dokumenty – verze

Jedná se o činnost, která je v případě nastavení dostupná na každém dokumentu a umožňuje sledování jednotlivých verzí. Verzí dokumentu rozumíme kopii obsahu daného dokumentu zaznamenanou v čase. Ve formuláři dokumenty je k tomuto účelu vytvořena záložka „verze dokumentu“. Zde se uživateli zobrazuje přehled jednotlivých verzí, a to těch dokumentů, které mají na záložce dokumenty zatržen příznak „automatické ukládání verzí“. Při zatržení tohoto příznaku vznikají verze daného dokumentu automaticky, ale v případě potřeby (pokud tento příznak zatržen není, ale uživatel by si rád uchoval průběh dokumentu v čase) je možno verzi vytvořit i manuálně a to volbou činnosti „uložit novou verzi dokumentu“ z menu Volby.

U každé verze se eviduje datum, čas jejího vzniku a uživatel, který ji založil. Nepotřebné verze je možné na záložce „verze dokumentu“ rušit. Verze je možné sledovat pouze pro dokumenty uložené v databázi, tzn. u dokumentů, které mají zatržen příznak „externí uložení“ verze sledovat nelze.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 19.07.2007


Pojem - Dolní lišta

Okno každé činnosti je v dolní části rozděleno do třech částí, které zleva doprava znamenají:

¨ levá část poskytuje uživateli informace o počtu vybraných záznamů. Dvojklikem levého tlačítka myši na tomto poli uživatel aktivuje funkci „znovu načíst“ (stejná činnosti jako pod menu Obecné)

¨ prostřední část poskytuje uživateli informace o počtu označených záznamů. Dvojklikem levého tlačítka myši na tomto poli se uživateli zobrazí právě tyto označené záznamy. Opětovným dvojklikem se uživatel vrátí zpět do původního zobrazení.

¨ pravá část poskytuje uživateli informace o použitém obecném výběru (pokud je nějaký použit). Dvojklikem levého tlačítka myši se uživateli zobrazí seznam všech nadefinovaných obecných výběrů dané činnosti. Uživatel si tímto způsobem může vybrat i jiný obecný výběr. Opětovným dvojklikem se uživatel vrátí zpět do původního zobrazení.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.11.2007


Pojem - Doplněná okna

Doplněná okna jsou součástí definice prostředí pohledu slovníku dat, která se uplatňuje pouze tehdy, je-li pohled aplikován v prvku web (přímo nebo zprostředkovaně, např. opět doplněným oknem jiného pohledu). V doplněných oknech se uvádí související pohledy.

Tato definice umožňuje z web browseru spustit pohledy uvedené v doplněných oknech s případným zde definovaným výběrem, klikem na první atribut v řádce nebo na atribut uvedený ve vlastnostech pohledu (Napojení ULR na atribut).

Součástí definice doplněného okna je:

¨ identifikace pohledu, který doplňujeme (související pohled),

¨ název doplněného pohledu, který zde lze modifikovat s cílem dosažení "přesnějšího" nadpisu při prohlížení web browserem,

¨ výběr, kterým se definuje podmnožina z vyhovujících záznamů (např. ZPUHR.zp02 = ZPUDA.zp02),

¨ přidané tabulky oddělené čárkou (např.: %%%.ZPUHR ZPUHR), které se obvykle užívají tehdy, pokud pohledy nejsou relačně propojené přímo (otec-syn), ale přes vazební entitu ,

¨ setřídění,

¨ relace otec, klíč v záznamech definovaných pohledem,

¨ relace syn, klíč v záznamech pohledu definovaného doplněným oknem.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.11.2007


Pojem - Doplnění mřížky formuláře

Pro rozšíření možností uživatelů při práci s IS BM je možné přidávat do mřížek formulářů vlastní sloupce. Vlastní sloupce do mřížky formuláře můžeme přidávat ze dvou důvodů:

1. chceme přidat sloupec, který je ve struktuře kurzoru dotazu (např. jméno kontaktní osoby ve formuláři adresáře)

2. chceme přidat sloupec, který není ve struktuře kurzoru dotazu (např. celková suma pohledávek adresáta ve formuláři adresáře) - pouze pro základní mřížku formuláře

Důvod ad.1. je řešen pomocí doplňujících vlastností formuláře a důvod ad. 2. je řešen pomocí obecných výběrů.

Ve formuláři "Doplnění mřížky formuláře" se definuje na první záložce:

¨ název doplnění - text

¨ poznámka

na druhé záložce „Sloupce“ popis jednotlivých sloupců doplnění -

¨ alias - text - alias kurzoru, který mřížka zobrazuje - pro základní mřížku nemusí být uveden - pro ostatní je možné zjistit volbou "Statistika SQL"

¨ návěští - text - bude zobrazen v záhlaví sloupce

¨ stavový řádek - text - text zobrazovaný na stavovém řádku obrazovky při vstupu na položku sloupce

¨ výraz - text - výraz v jazyce Foxpro - hodnota získaná jeho vyhodnocením bude zobrazována ve sloupci (ve výrazu je možné užít makro $$$, které je nahrazováno aliasem kurzoru mřížky). Pokud je ve výrazu uvedena funkce, musí být uvozena znakem vlnovka

¨ formát - text - formátovací výraz pro hodnotu výrazu

¨ pozice - číslo - určuje pozici sloupce v mřížce - není ovlivňována osobním nastavením mřížky uživatele, tj. sloupec je vždy zobrazen v dané pozici bez ohledu na tato nastavení

¨ pořadí - číslo - určuje pořadí sloupce v rámci stejné pozice

¨ šířka - číslo - šířka sloupce v pixelech

Pokud vyhodnocení výrazu sloupce není platná hodnota, není tento sloupec do mřížky zařazen (tj. neplatný výraz není považován za chybu). Výjimku tvoří výrazy uvedené znakem vlnovka - předpokládá se, že ve výrazu je uvedena funkce např. tool.sql_dotaz.

Příklady řešení:

Řešení přidání nového sloupce (jméno kontaktní osoby ve formuláři adresáře) do formuláře mřížky přes doplnění v doplňující vlastností formuláře -

¨ Odpovídající doplnění mřížky formuláře pak bude obsahovat tuto definici sloupce:

alias =

návěští = Osoba

stavový řádek = Jméno kontaktní osoby

výraz = $$$.ad11jmeno

formát =

pozice = 3

pořadí = 10

šířka = 80

Řešení přidání nového sloupce (celková suma pohledávek adresáta) do formuláře mřížky přes položku Atributy v obecném výběru -

¨ v obecném výběru pak bude zadáno následující:

atributy = (select sum(pluda.pl02czrmnu) from %%%.pluda where pluda.ad01id=adadsat.ad01id and pluda.pl02pohzav=1 and pluda.pl02uhraze=0) as dluh

výraz = dluh>0

¨ odpovídající doplnění mřížky formuláře bude obsahovat definici sloupce

alias =

návěští = Dluh

stavový řádek = Dluh adresáta

výraz = $$$.dluh

formát = 999 999 999.99

pozice = 2

pořadí = 10

šířka = 80

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 03.05.2013


Pojem - Doplnění výběrové záložky formuláře

Nadefinování „ikon seznamu hodnot“ se provádí v činnosti Doplnění výběrové záložky formuláře (hlavní menu – Informační centrum – Typy a řady) nebo z formuláře Doplňující vlastnosti formuláře stiskem klávesy F7.

Na záložce Výběr ve všech činnostech je možno vybrat si větší množinu dat jedním klikem. Pro tento účel jsou u takových výběrových atributů zobrazeny ikony zaškrtávacího políčka (černý čtvereček v pravém horním rohu daného atributu). Tento čtvereček se nazývá „ikona seznamu hodnot“. Po kliknutí myši (klik, pravý klik nebo dvojklik) na „ikonu seznamu hodnot“ (tzn. na čtvereček) se uživateli zobrazí okno se seznamem možných hodnot daného atributu, ve kterém si označí množinu hodnot atributu, kterou chce mít dostupnou.

Uvedeme si to nejlépe na konkrétním případu. Na záložce Výběr v činnosti Adresář je tato ikona dostupná např. na atributu Kategorie. Po kliku na čtvereček se uživateli zobrazí seznam všech nadefinovaných kategorií. Vlastní záložka Výběr umožňuje na atributu „kategorie“ výběr pouze jedné kategorie, pomocí této nové možnosti si může uživatel zvolit adresáty z různých kategorií, stačí dané kategorie v nabídnutém seznamu pouze zaškrtnout.

Použití „ikony seznamu hodnot“ u atributů na výběrové záložce formulářů je implementačně nastavitelné:

¨ je možné měnit definici „ikonu seznamu hodnot“, která byla dodána v programu BM.EXE

¨ je možné potlačit zobrazení „ikony seznamu hodnot“, která byla dodána v programu BM.EXE

¨ je možné vytvořit vlastní definici „ikony seznamu hodnot

Po kliknutí tlačítka myši (klik, pravý klik nebo dvojklik) na „ikonu seznamu hodnot“ na výběrové záložce se uživateli nabídne okno se seznamem možných hodnot atributu, ve kterém si označením vybírá množinu hodnot daného atributu. Platí, že když:

¨ si vybere (označí) jednu hodnotu, je tato hodnota přenesena do hodnoty atributu ve formuláři na výběrové záložce (podobně jako vrácení hodnoty po výběru z číselníku – F2)

¨ si vybere (označí) více hodnot, potom je hodnota atributu ve formuláři na výběrové záložce vynulována, tzn. atribut se stane nepřístupným (zašedlým) a „ikona seznamu hodnot“ změní svůj vzhled na „zaškrtnutá“. Při pohybu myší nad tímto nepřístupným atributem se poté zobrazuje nápověda (informační okénko), ve které je zobrazen seznam vybraných hodnot. Přímo ve formuláři se seznamem možných hodnot atributu je možné použít pravý klik myši, po kterém lze označit najednou všechny hodnoty nebo naopak zrušit označení všech hodnot.

Na první záložce „Doplnění výběrové záložky formuláře“ se definují tyto atributy:

¨ činnost – identifikace činnosti

¨ atribut – název výběrového atributu

¨ příznak aktivní/neaktivní – překryvný seznam – znamená zda se bude u daného atributu ikona seznamu hodnot vůbec zobrazovat. Pokud je nastaveno neaktivní, ikona se vůbec nenabízí.

¨ návěští – text, který určuje návěští okna se seznamem možných hodnot (uplatní se v případě, že atribut nemá uvedeno na výběrové záložce návěští a zároveň není uveden jeho překlad)

¨ původ – překryvný seznam – Systémová definice/Uživatelská definice – Systémové definice byly naprogramovány v BM.EXE, není je možné zrušit, lze u nich pouze měnit atributy „aktivní/neaktivní“, „původ“ a „poznámka“. Při instalaci nové verze BM se mohou změnit všechna nastavení systémové definice kromě atributů „aktivní/neaktivní“ a „poznámka“ nebo může být zrušena, pokud byla v nové verzi BM.EXE odstraněna. Pokud implementátor změní nastavení původu ze Systémová definice na Uživatelská definice, potom tato definice nebude po instalaci nové verze BM.EXE v žádném případě zrušena ani žádným způsobem měněna. V případě, že implementátor změní původ ze Systémová definice na Uživatelská definice a definici opraví a následně hned změní původ z Uživatelská definice na Systémová definice, potom se po ukončení formuláře „Doplnění výběrové záložky formuláře“ nastavení takové definice obnoví podle toho, jak je definována v BM.EXE (tj. přepíše jeho změny).

¨ typ zdroje – překryvný seznam – SQL/COMBOBOX/SEZNAM/SCRIPT – určuje význam obsahu atributu „zdroj“

¨ zdroj – zdroj pro vytvoření seznamu nabídky – tzn. víceřádkový text, který obsahuje definici, podle které se naplní seznam v okně možných hodnot

¨ ikona – určení místa, kde se u daného atributu bude zobrazovat ikona seznamu hodnot – překryvný seznam – Vlevo vedle atributu/Uvnitř atributu – při nastavení „Uvnitř atributu“ je ikona umístěna v pravém horním rohu atributu, při nastavení „Vlevo vedle atributu“ se zároveň ještě k tomu uplatňují varianty (možné způsoby zobrazení ikony), které jsou nastaveny v Parametrech uživatele

¨ vedle – určuje název atributu, vedle kterého má být ikona umístěna při nastavení Ikona = „vlevo vedle atributu“ (typickým příkladem je např. kategorie artiklu, tj. pro atribut SA05ID je vhodné umístit ikonu před překryvný seznam Je/Není/Byl/Nebyl tj. atribut SA05EXISTS) - uplatní se podle nastavení parametrů uživatele "Zobrazování ikon seznamů hodnot"

¨ Model SQL - víceřádkový text - obsahuje část SQL dotazu, která bude doplněna do výsledného SQL dotazu formuláře - text by měl obsahovat makro ###, které bude při sestavování SQL dotazu nahrazeno seznamem vybraných hodnot (např. „OBARTIKL.SP20IDZAK IN (###)“ ) - může obsahovat makro $$$, které bude nahrazeno názvem hlavní tabulky formuláře (např. pro formulář „Obchodovatelný artikl“ to může být „$$$.SP20IDZAK IN (###)“ )

¨ poznámka - víceřádkový text

Na záložce „Překlad návěští okna“ je možné definovat překlad návěští okna se seznamem možných hodnot v různých jazycích. Návěští okna se seznamem možných hodnot se uplatní:

¨ je-li uveden překlad návěští okna v jazyce uživatele, tak se uplatní tento text

¨ když má výběrový atribut uveden na výběrové záložce návěští, tak se uplatní text návěští výběrového atributu

¨ jinak se uplatní text uvedený v atributu Návěští

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 09.12.2010


Pojem - Doplňující položky menu objektů

Tato činnost poskytuje uživateli možnost implementačně doplnit definovatelné funkce pro menu, která jsou vyvolávána po stisku pravého tlačítka myši na uzlu představujícím objekt BM. Tuto možnost je vhodné využít zejména ve stromech zobrazovaných ve formulářích „spojené dokumenty“, „strom hlavního procesu“ a obdobných stromech formuláře „okno úloh“.

Uživatel má tuto činnost dostupnou v hlavním menu – Informační centrum – Typy a řady. Po aktivaci této činnosti má k dispozici přehled dosud nadefinovaných doplňujících položek menu objektů a zároveň má možnost definice nové položky. Při její definici vstupuje následující atributy:

¨ položka – identifikace a popis položky menu

¨ druh – výběr z překryvného seznamu druhů implementačních rozšíření. Na F2 možno nadefinovat nový druh, který se pak bude následně zobrazovat na výběr v překryvném seznamu. K jednotlivým druhům lze nadefinovat přístupová práva.

¨ objekt BM – výběr z překryvného seznamu objektů BM. Zde se určuje typ objektu BM (jeho uvedení není povinné), pro který se má doplňující položka menu uplatnit.

¨ pořadí – numerická hodnota – určuje pořadí zobrazení položky menu

¨ podmínka – podmínka zařazení položky menu – script v jazyce FoxPro. Je-li uvedena, musí obsahovat kód v jazyce FoxPro, který vrací logickou hodnotu .T. (TRUE) nebo .F. (FALSE)

¨ typ kódu – výběr z překryvného seznamu. Kompilovaný kód se použije v případě, že doplň. položka menu má spustit okno, které má zůstat otevřené, tzn. i při další práci s BM stále k dispozici. Nekompilovaný kód se naopak použije v případě, že spuštěná doplň. položka menu je k dispozici jen pro daný okamžik a pak se hned ukončuje.

¨ kód – kód v jazyce FoxPro vyvolaný při výběru položky menu

¨ poznámka – libovolný text

¨ aktualizace – datum a čas, kdy byla naposledy daná definice položky menu změněna – uplatňuje se zejména při importu balíčků

Doplňující položky menu jsou umisťovány na začátek standardního menu a uplatní se v případě, že 'Objekt BM' není určen nebo je totožný. O uplatnění doplňující položky menu může také rozhodnout kód Podmínky. Pro toto rozhodnutí má kód k dispozici předané parametry (v kódu se příkaz PARAMETERS resp. LPARAMETERS neuvádí):

_this - objekt - řídící objekt uzlu stromu, na kterém byl proveden pravý klik

_bw09typ1 - text - identifikace objektu BM

_bw09inst1 - jednoznačná časová identifikace objektu

Kromě toho jsou podle typu objektu BM k dispozici atributy objektu _this:

Pro typ objektu Adresář (AD) - _this.ad01id

Pro typ objektu Artikl (AR) - _this.sp61id,_this.sp60id

Pro typ objektu Proces (PR) - _this.sp33cisdr,_this.sp33cisdpm,_this.sp33cisd

Pro typ objektu Operace (OO) - _this.sp33cisdr,_this.sp33cisdpm,_this.sp33cisd,_this.sp06idsubs,_this.sp07idtyp,_this.sp33porad

Kód spouštěný po výběru položky menu má k dispozici parametry (v kódu se příkaz PARAMETERS resp. LPARAMETERS neuvádí):

_this - objekt - řídící objekt uzlu stromu, na kterém byl proveden pravý klik

_bw09typ1 - text - identifikace objektu BM

_bw09inst1 - jednoznačná časová identifikace objektu

_main_object - objekt - řídící objekt stromu

Kromě toho jsou podle typu objektu BM k dispozici atributy objektu _this. Může být spouštěný podle nastavení 'Typ kódu' v kompilovaném nebo nekompilovaném tvaru (kompilovaný tvar je určen pro případy, kdy kód vytváří nemodální objekty, např. nemodální formulář).

Parametr _main_object je předáván kódu pro případ, že je třeba po provedení kódu provést přezobrazení stromu, např. přezobrazení připojených dokumentů příkazem '_main_object.prezobraz_uzel(_this,.T.)'.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 11.08.2011


Pojem - Doplňující vlastnosti formuláře

Pod pojmem formulář je možno si představit každou aktuálně spuštěnou činnost zobrazenou v okně. U vybraných komponent jsou doplňující vlastnosti formuláře dostupné pod menu Obecné. Doplňující vlastnosti formuláře umožňují přidat k činnostem vlastní položky menu nebo automaticky vyvolat (při otevření formuláře) spuštění předlohy výstupu, volné karty nebo kódu Foxpro. Tato funkčnost se vztahuje pro verzi BM pro Foxpro 7.0 a vyšší. Činnost pro definování "Doplňujících vlastností formuláře" se vyvolává z menu formuláře "Obecné". Definování doplň. vlastností formuláře patří k „nejodbornějším“ prvkům IS BM, některé provedené změny mohou vyvolat nevratné změny nebo dokonce ztrátu dat, tudíž vyžaduje dobrou znalost IS.

Každá tato vlastnost tedy určuje akci:

1. vyvolání metapředlohy výstupu nebo

2. spuštění kódu v jazyce Foxpro nebo

3. vyvolání volné karty nebo

4. vytvoření položky menu s funkčností 1. nebo 2. nebo 3.

5. spuštění kompilovaného kódu (viz. popis help)

Pokud vlastnost určuje akci vyvolání metapředlohy výstupu je možné určit pro formuláře událostí komponent vyvolání metapředlohy výstupu dokladu procesu nebo dokladu nadřízeného procesu. V takovém případě není určení metapředlohy výstupu (MPV) povinné, vyvolá se metapředloha uvedená u odpovídajícího druhu procesu.

Pokud vlastnost určuje akci vyvolání volné karty je možné určit pro formuláře událostí komponent vyvolání volné karty procesu, operace nebo volné karty adresáta. V takovém případě není určení volné karty povinné, vyvolá se volná karta odpovídajícího druhu operace resp. procesu nebo adresáta (u volné karty adresáta je nutné, aby adresát byl obsažen na první záložce formuláře, pokud není, tak systém generuje při užití takové DVF chybu).

Pokud vlastnost určuje akci vyvolání doplnění mřížky je možné určit pro formuláře událostí komponent vyvolání doplnění.

Akci specifikovanou doplňující vlastností formuláře je možné vyvolat automaticky při spuštění formuláře. Pro formuláře událostí komponent je možné omezit vyvolání této akce na vybrané operace. Na záložce "Omezení pro operace" se uvádí seznam operací v procesech, při jejichž spuštění se má požadovaná akce vykonat. Uvedení druhu procesu "-" znamená, že se akce vyvolá pro daný druh operace v libovolném druhu procesu. Kromě toho je možné určit podmínku, v jakém stavu "připravena","zahájena" nebo "ukončena" se daná operace musí nacházet.

Uvedení některé operace v seznamu automaticky znamená, že se akce nebude provádět při vyvolání formuláře v režimu prohlížení událostí odpovídající komponenty. Při doplnění menu formuláře je možné určit CTRL - klávesu pro vyvolání odpovídající funkce. Je možné zadat písmeno nebo funkční klávesu F1 až F12. Pro vytváření uživatelských nabídek (toolbarů) je vhodné uvádět pro ekvivalentní doplňující vlastnosti různých formulářů stejnou identifikaci. Při definici doplňující vlastnosti lze využít statické i dynamické podmínky:

¨ stat. podm. – statická podmínka zařazení do menu - vyhodnocuje se v okamžiku vytváření menu. Např.:

- v událostech vymáhání lze pomocí F6 spustit události plateb za statické podmínky, že charakter operace je běžná -thisform.komp_stav AND thisform._o_kompo_.sp07charak=1

- v uživatelích programu je viditelná činnost inicializace hesla jen pokud se jedná o uživatele správce - tool.spravce()

- dotaz na existenci souboru – FILE (‘nazev souboru’)

¨ dyn. podm. – dynamická podmínka zařazení do menu – vyhodnocuje se až v okamžiku, kdy je menu vytvořené. Např.:

- činnost Karta pracovníka může přes Volby spustit činnost Další informace. Dynamická podmínka ale říká, že to lze spustit jen pokud je kurzor umístěn na záložce Pracovní poměry – thisform._PF_activepage=thisform._PF_.p4.pageorder

- v činnosti Adresář lze spustit činnost Adresy, jen pokud stojím na příslušné záložce – thisform._PF_.activepage=thisform._PF_.p4.pageorder

- v činnosti Adresář lze spustit činnost předkontace adresáta jen pokud je kurzor umístěn na určitém adresátovi - !EOF(‘$$$’)

- v činnosti Adresář lze spustit cenové skupiny adresáta jen pokud je kurzor umístěn na určitém adresátovi - !EOF(‘$$$’)

Druhem doplňující vlastnosti formuláře jsou dána přístupová práva. Pro to, aby se akce vlastnosti provedla, musí mít aktuální uživatel k jejímu druhu právo alespoň "čtení". Uživatel s právem "zápis" může vytvářet doplňující vlastnosti daného druhu.

Je možno nastavit zda má být daná vlastnost dostupná v menu (menu Volby), v případě potřeby k ní nadefinovat i funkční klávesu na kterou ji bude možno vyvolat a případně i určit, že v tomto menu bude zvýrazněna jiným druhem písma (tučné, kurzíva, tučná kurzíva).

Příklady praktického užití:

Právy k druhu je tedy možné omezit automatické vyvolání volné karty pouze pro vybrané uživatele. Účetnímu se automaticky zobrazí při účtování úhrady závazku faktura (výstup metapředlohy dokladu nadřízeného procesu), o které účtuje.

Doplňující vlastnost formuláře může definovat vyvolání programového kódu Foxpro. V textovém poli "kód" je možné zadat plnohodnotný program v jazyce Foxpro, který je možné snáze upravovat v editoru po stisku klávesy F5. Do kódu je automaticky přidán prvý řádek:

LPARAMETERS _this,

kterým je mu předán objekt formuláře, ze kterého byl vyvolán.

Do kódu je možné vkládat opakovaně použitelné části použitím klausule:

#INCLUDE <identifikace vkládaného kódu>.

Formulář pro vstup vkládaných kódů se vyvolává z formuláře doplňujících vlastností formuláře klávesou F6. Přístup k položkám vkládaných kódů je také chráněn jejich druhem a jejich kód je také možné upravovat v editoru po klávese F5. Ve vkládaném kódu může být uvedena klausule #INCLUDE, která do něho zařadí jiný vkládaný kód. Bylo vytvořeno i řešení podporující vytváření výstupu do HTML, které plně využívá výhod objektového programování. Sestává ze dvou základních "vkládaných kódů" (dále knihoven).

Knihovna SYSHTM definuje třídu, která slouží k vytváření obsahu HTML souboru.

Knihovna SYSPRC definuje třídu, pro usnadnění práce s operací v procesu.

To, jakým způsobem je možné jednoduše vytvářet přehledy zobrazované ve webovém prohlížeči je patrné v následujím příkladu, který vytvoří přehled událostí obchodu v nadřízeném procesu k události.

LOCAL _o,_o2

* založíme objekt pro orientaci v procesech podle definice třídy v knihovně SYSPRC (viz.#INCLUDE na konci)

_o2=CREATEOBJECT('bm_code_sysprc',_this)

* založíme objekt pro vytváření souboru HTML podle definice třídy v knihovně SYSHTM (viz.#INCLUDE na konci)

_o=CREATEOBJECT('bm_code_syshtm')

* výstupní sestava bude mít titul 'Moje sestava'

_o.settitle('Moje sestava')

* vytvoříme hlavičku souboru HTML

_o.genheader

* do textu vložíme nadpis 'QUICK INFO'

_o.gentag_h2('QUICK INFO',.T.)

* budeme vytvoříme tabulku - tu je třeba inicializovat

_o.table_reset

* připravíme data pro naplnění tabulky

* metoda opendata vrací TRUE, když úspěšný dotaz vrátil alespoň jeden řádek

* všimněte si použití objektu _O2 při sestavování dotazu

IF _o.opendata([select obudal.ad01id,adadsat.ad01adsat,obudal.ob02dat,obudal.ob02datdod,]+;

[obudal.sp61id,obudal.sp60id,spartikn.sp62artikl,obudal.ob02mn,]+;

[obudal.ob02cj01c,obudal.dp02czazm,obudal.dp02cdpzm,obudal.dp02czarm,obudal.dp02cdprm,]+;

[obudal.oc01id,obudal.dp02sazba]+;

[ from %%%.obudal,%%%.spartikn,%%%.adadsat where ]+;

_o2.filter('OBUDAL',.T.)+;

[ and spartikn.sp61id=obudal.sp61id]+;

[ and spartikn.sp60id=obudal.sp60id]+;

[ and spartikn.sp38id=?tool.jazyk]+;

[ and adadsat.ad01id=obudal.ad01id])

* do prvého sloupce tabulky bude vkládán obsah podle výrazu "sp61id+'-'+sp60id" a bude mít nadpis "Artikl"

_o.table_addcol([sp61id+'-'+sp60id],'Artikl')

* podobně

_o.table_addcol([sp62artikl],'Název artiklu')

* podobně + navíc je určeno, že číslo má mít formát 20,2

_o.table_addcol([ob02mn],'Množství',20,2)

_o.table_addcol([ob02cj01c],'CJ',20,2)

* sloupce s cizí měnou má smysl vytvářet, pokud jsme neobchodovali v korunách

IF _o.getvalue([oc01id])<>'CZK'

_o.table_addcol([dp02czazm+dp02cdpzm],'Cena ZM',20,2)

_o.table_addcol([oc01id],'Měna')

ENDIF

* pro tento sloupec budeme chtít celkový součet

_o.table_addcol([dp02czarm],'Základ DPH',20,2,.t.)

_o.table_addcol([dp02sazba],'%')

_o.table_addcol([dp02cdprm],'DPH',20,2)

_o.table_addcol([dp02czarm+dp02cdprm],'Cena Kč',20,2,.t.)

* gentableheader - vytváří hlavičku tabulky s nadpisy sloupců v tomto případě navíc s jedním hlavičkovým řádkem

_o.gentableheader(" 'Obchod - '+dtoc(ob02dat)+' ['+ad01id+'] - '+alltrim(ad01adsat) ")

* gentable - vygeneruje tabulku s daty dotazu metody OPENDATA na základě definic sloupců (TABLE_ADDCOL)

_o.gentable

* gentablefooter - vygeneruje koncovou značku tabulky

_o.gentablefooter

ENDIF

* genfooter - vygeneruje koncové značky HTML dokumentu

_o.genfooter

* show - zobrazí dokument v interním HTML prohlížeči BM

* metoda LABEL objektu _O2 vrátí identifikaci procesu, kterou metoda SHOW zobrazí v nadpisu okna

_o.show(_o2.label(.T.))

* klausule #INCLUDE připojí knihovnu SYSHTM, která obsahuje deklaraci třídy objektu "bm_code_syshtm"

* knihovnu SYSPRC, která obsahuje deklaraci třídy objektu "bm_code_sysprc" není třeba připojovat (tu si připojuje SYSHTM)

#INCLUDE syshtm

Protože objekt "bm_code_syshtm" knihovny SYSHTM je zdrojem pro nezávislá řešení, umožňují principy objektového programování na jeho základě vytvořit vlastní objekt (např. "bm_code_usrhtm" v knihovně USRHTM), který překryje "bm_code_syshtm" v metodách a vlastnostech dotýkajících se formátování (vzhledu) výstupního HTML dokumentu. Jednotlivé doplň. vlastnosti formuláře IS BM při zapsání do kódu umožňují zpracování skriptů. Skript je programový kód vyvolaný na základě programové události.

Událost formuláře (viz. Pojem - Zpracování skriptů) GRID_HEADER_CLIK umožňuje implementačně definovat třídění sloupce po kliku na návěští sloupce v mřížce formuláře (např. v mřížce je identifikace artiklu a datum - po kliku na sloupec artiklu se požaduje setřídění artikl+datum).

Událost GRID_HEADER_CLIK vzniká při kliku na návěští sloupce mřížky ve formuláři a vyvolává skript připojený k formuláři doplňující vlastností formuláře voláním metody ADDSCRIPT.

Ve skriptu je možné odkazovat se na proměnné:

_objscript.recordsource - alias cursoru mřížky

_objscript.attribute - název atributu zobrazeného ve sloupci (včetně aliasu), na který uživatel klikl

Kód skriptu by měl vrátit výraz v syntaxi jazyka Foxpro pro příkaz INDEX ON.

Příklad doplňující vlastnosti formuláře připojující skript pro událost GRID_HEADER_CLIK:

<pre>

LOCAL _kod

TEXT TO _kod NOSHOW

IF _objscript.recordsource='VRUDOPER' AND TYPE(_objscript.attribute)='C'

RETURN [UPPER(]+_objscript.attribute+[)+DTOS(NVL(vr02datum,{}))+LEFT(ad01adsat,50)]

ELSE

RETURN _objscript.attribute

ENDIF

ENDTEXT

_this.makroprikaz("this.addscript(CREATEOBJECT([bwscript],[GRID_HEADER_CLIK],[GRID_HEADER_CLIK],[],_p1))",_kod)

</pre>

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.02.2010


Pojem - Dotaz výkazu

Dotaz výkazu je uživatelské nastavení, na základě kterého je v okamžiku sestavení výkazu uživatel v dialogovém okně vyzván k zadání hodnot proměnných dotazu, ze kterých mohou být hodnoty jiných proměnných dotazu vypočteny.

Proměnné dotazu jsou dostupné v definici listu či výkazu jako parametry, jejich hodnoty jako skutečné hodnoty parametrů při sestavení výkazu.

Definice dotazu se skládá z názvu, pod kterým je dostupný v definici výkazu a který je uveden v nadpisu dialogového okna, designu vstupního formuláře (dialogového okna) a volného textu pro popis.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.11.2007


Pojem - Drag & Drop (Táhni a pusť)

IS BM umožňuje uživateli využít funkci „Drag & Drop“ (tzn. Táhni a pusť) v těchto místech:

1. lze kopírovat záznamy formulářů, které obsahují záložky

2. lze kopírovat textové položky formulářů

3. lze kopírovat dokumenty

4. lze provést rychlý import dat vybraných řádků a sloupců Excelu

Tyto jednotlivé možnosti využití funkce „Drag & Drop“ si nyní podrobněji popíšeme.

Kopírování záznamů formulářů

Kopírování je možné provést z formulářů, které obsahují záložky. Provádí se tažením záložky (Drag) a jejím upuštěním (Drop) na záložku jiného formuláře. Přitom je ve formuláři, který přijímá data, zahájen vstup jednoho nebo několika nových záznamů, podle toho, zda bylo tažení záložky provedeno levým nebo pravým tlačítkem myši.

Při tažení levým tlačítkem myši se provádí kopírování aktuálního záznamu formuláře.

Při tažení pravým tlačítkem myši se provádí kopírování všech záznamů formuláře (maximálně však 10000 záznamů). Tato funkčnost se podobá doplňující vlastnosti formuláře 'Clipboard dat'.

Na rozdíl od doplňující vlastnosti formuláře 'Clipboard dat' je však možné tímto způsobem kopírovat data mezi různými formuláři (kopírují se pouze atributy, které jsou pro oba formuláře společné), např. je možné kopírovat tímto způsobem vybrané artikly do nově zakládaných událostí obchodu.

Kopírování je možné také mezi formuláři dvou různých aktuálně spuštěných BM.EXE. Tento způsob používání se však nedoporučuje v případě, že kopírovaný formulář obsahuje systémem automaticky vygenerovaný primární klíč. V některých případech může dojít k tomu, že zkopírovaný formulář nepřevezme tento primární klíč a potom dochází k nesouladu dat. V takovém případě je vhodnější přenést daný formulář pomocí importu balíčku.

Tažením záložky formuláře je možné kopírovat data také do listu programu Excel (nebo jiného programu, který přijímá funkcí Drag&Drop data ve formátu CSV). Data jsou kopírována tak jak jsou zobrazená v mřížce formuláře. Kopíruje se jeden nebo několik záznamů, podle toho, zda bylo tažení záložky provedeno levým nebo pravým tlačítkem myši.

Při tažení levým tlačítkem myši se provádí kopírování aktuálního záznamu formuláře. Při tažení pravým tlačítkem myši se provádí kopírování všech záznamů formuláře. Pokud bylo do Excelu kopírováno více záznamů a v některém sloupci je uveden numerický údaj, potom je pro tyto sloupce doplněn součtový řádek.

Kopírování textových položek formulářů

Funkci „Drag“ (tj. táhnout text) je možné provést:

¨ z položek typu text nebo MEMO, přitom je možné text táhnout v rámci programu BM nebo do jiného programu Windows (Word, zpráva Outlooku, ...)

Funkci „Drop“ (tj. přijetí taženého textu) je možné provést:

¨ do položek typu MEMO (kromě tažení textu v rámci stejné položky typu MEMO)

¨ do položek typu text na výběrové záložce formuláře, přitom je možné přijímat text tažený v rámci programu BM nebo z jiného programu Windows (Word, zpráva Outlooku, ...)

Kopírování dokumentů

IS BM umožňuje kopírování dokumentů BM tažením myší (funkce Drag&Drop) ze stromů, ve kterých se vyskytují dokumenty, a to jsou:

- Spojené dokumenty

- Strom hlavního procesu

Dokument je tímto způsobem možné kopírovat:

¨ do jiných aplikací Windows (zpráva Outlooku, Explorer, ...)

¨ mezi různými stromy aktuálně spuštěného BM (v tomto případě je zobrazen dotaz, zda má být připojena kopie dokumentu nebo pouze odkaz na dokument)

Import dat vybraných řádků a sloupců Excelu

V IS BM je možno provést rychlý import dat vybraných řádků a sloupců aplikace Excel pomocí funkce „Drag“ (tažení). Dokončí se upuštěním („Drop“) tažené oblasti na vybranou záložku formuláře. Následně se zobrazí formulář, který umožňuje uživateli data před importem upravit. Tento formulář obsahuje:

¨ mřížku, která obsahuje:

- sloupce, které odpovídají tažené oblasti – nadpisy sloupců jsou dány prvním řádkem tažené oblasti

- a navíc sloupce, které odpovídají atributům, které mohou být importovány aktuálním formulářem (v nadpisu sloupců jsou názvy atributů). Při pohybu v těchto sloupcích se zobrazuje na stavovém řádku popis atributu.

V nadpisech jednotlivých sloupců tažené oblasti může být uvedeno jejich ztotožnění s importovaným atributem. To se provede uvedením názvu atributu v nadpisu sloupce v kulatých závorkách (např. 'Druh artiklu (sp61id)' ).

V mřížce jsou sloupce, které se neuplatní při importu (tj. sloupce, které odpovídají tažené oblasti a přitom nebyly ztotožněny s některým importovaným atributem) zobrazeny na šedivém pozadí (tyto sloupce není možné editovat). Ostatní sloupce jsou zobrazeny na bílém pozadí, lze je editovat a pokud jsou vyplněné, tak se uplatní při importu.

Záznamy, které nemají být importovány, je možné v mřížce zrušit klikem na políčko zrušení záznamu.

¨ textové pole pro zadání skriptu v jazyce FoxPro

Skript je určen pro úpravu dat před jejich importem (např. 'REPLACE ALL ob02dat WITH {1.1.2010}' ). Skript může obsahovat procedury a cykly. Obsah skriptu se pamatuje v rámci aktuálního spuštění BM.EXE.

¨ tlačítko „Import“

Pomocí něj se provede import dat a ukončí formulář.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 12.08.2014


Pojem - Druh artiklu

viz. artikl.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Druh dokumentu

Druh dokumentu umožňuje dokumenty členit do určitých skupin. Pro každý druh dokumentu (věc s přístupem) lze nastavit přístupová práva, kde čtení se rovná právo vidět a užít druh dokumentu a zápis se rovná právo modifikovat druh dokumentu. Při otevření dokumentu, ke kterému má aktuální uživatel právo zápis, ale který má v daném okamžiku otevřený pro zápis jiný uživatel, se zobrazuje hlášení s informacemi, že „dokument je otevřen pouze pro čtení, případné změny nebudou zaznamenány a k dispozici je i jméno uživatele, který má daný dokument právě otevřen“.

Jednotlivé nadefinované druhy dokumentů má uživatel k dispozici v hlavním menu v činnosti Marketing – Dokumenty – Druhy dokumentů.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.08.2009


Pojem - Druh doplňující vlastnosti formuláře

Na základě nadefinovaných druhů doplňujících vlastností formuláře jsou řízena přístupová práva jednotlivých uživatelů k dané funkci doplňující vlastnosti formuláře. Pro to, aby se funkce vlastnosti provedla, musí mít aktuální uživatel k jejímu druhu právo alespoň "čtení". Uživatel s právem "zápis" může vytvářet doplňující vlastnosti daného druhu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.11.2007


Pojem - Druh hodnoty

V rámci každé komponenty [1] lze uživatelsky definovat druhy hodnot, které informační systém bude automatizovaně aktualizovat. Druhem hodnoty[2] se rozumí např. stav skladu ve finančním vyjádření, stav skladu v naturálním vyjádření, finanční stav zásob za celý sklad apod. Tyto hodnoty se automatizovaně aktualizují na základě numerických údajů (atributů) událostí. V činnosti Druhy hodnot se definuje algoritmus zmíněné aktualizace a na záložce „výskyt hodnoty“ se definují druhy operací, jejichž události aktualizují danou hodnotu. U každého druhu operace se dále uvádí:

¨ druh hodnoty – identifikace a název druhu hodnoty

¨ +/-/PV – pokud je nastaveno +, hodnota se vždy přičítá, pokud je nastaveno – hodnota se vždy odečítá a u nastavení PV (dle příjmu či výdeje) platí, že pokud se jedná o příjem, hodnota se přičítá, pokud se jedná o výdej, hodnota se odečítá (příjmy jsou vždy liché, výdeje jsou vždy sudé – souvisí to se zobrazením atributů v překryvném seznamu)

¨ v procesu – pokud se jedná o hodnotu, kterou má význam sledovat pouze u vybraného druhu procesu, zadává se zde identifikace druhu hlavního procesu (zde je doporučeno opatrné chování, protože ze začátku implementace je těžké odhadnout v jakém hlavním procesu se to pak objeví)

Další možnosti algoritmu aktualizace jsou následující:

¨ volba numerického atributu události (výběr z překryvného seznamu vstupní hodnota, rozsah tohoto seznamu je daný programem)

¨ volba, zda obrat a statistickou hodnotu agregovat za den či měsíc uvedený v událostech ( v událostech obchodu se jako datum pro agregaci bere atribut datum dodání a ne první datum uvedené na události, v platbách je to datum splatnosti)

¨ volba agregace - za adresáta (nerozlišuje adresáta, obchodní selektor)

- za artikl (nerozlišuje artikl, technicko-věcný selektor)

- za umístění (nerozlišuje umístění, organizační selektor)

¨ volba podmínky při jejímž splnění dojde k aktualizaci hodnoty (překryvný seznam podmínka, koresponduje s relevantním atributem v události)

Druhy hodnot mohou být rozděleny do čtyř skupin z hlediska cílových entit (tj. souborů, kam se zapíší vypočtené hodnoty). Z tohoto pohledu může každý druh hodnoty aktualizovat libovolnou kombinaci těchto entit obsahujících vypočtené hodnoty:

¨ aktuální

¨ obrat (není implementováno pro všechny komponenty)

¨ saldokontní

¨ statistické

[1] Daný druh hodnoty lze aktualizovat pouze událostmi dané komponenty (kromě saldokontních hodnot).

[2] Druhy hodnot má uživatel k dispozici v činnosti Informační centrum – Typy a řady – Komponenty a u každé jednotlivé komponenty jsou druhy hodnot dostupné po stisku F7.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Druh operace

Druh operace je nositelem vlastností (definuje je) pro všechny operace daného druhu. Operace je seskupení plánovaných nebo uskutečněných událostí shodného druhu v časové i věcné blízkosti. Obsahem operace jsou tedy události jedné komponenty, operací může být např. příjem na sklad nebo dodací list. Jednotlivé řádky (položky) těchto operací jsou potom události. Z posloupností operací se skládá proces. Posloupností druhů operací se fakticky definuje druh procesu. Vlastnosti každého druhu operace se definují v činnosti Informační centrum – Typy a řady – Druhy operací.

Informace o každé fyzicky provedené operaci je možno tisknout. Tisk lze nastavit tak, že probíhá automaticky po ukončení operace[1] a to v případě potřeby i bez zásahu uživatele (viz. předlohy výstupu a tisk zjednodušených dokladů).

Na základě nadefinovaných druhů operací pak uživatelé vytvářejí fyzické operace v rámci procesů, jejichž přehled je k dispozici v činnosti Procesy a operace – Operace.

[1] Na vlastnostech operace v diagramu procesu se zvolí po ukončení tisk operace a zároveň se zvolí příslušná metapředloha.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.11.2007


Pojem - Druh procesu

V informačním systému BM jsou procesy, které jsou si podobné (blízké) modelovány pomocí druhu procesu. Procesy stejného druhu mají řadu shodných vlastností, které jsou v definici druhu zachyceny, např. transformace, masky,…apod. Nastavením těchto vlastností se rozhoduje o vlastnostech všech procesů daného druhu, které budou v informačním systému evidovány. Vlastnosti jednotlivých druhů procesů se definují v činnosti Informační centrum – Typy a řady – Druhy procesů a některé z vlastností se definují pouze v diagramu procesu. Ke každému druhu procesu je možno nadefinovat přístupová práva. Uživatel, který nemá právo k založení druhu procesu, nemůže proces tohoto druhu stornovat.

Informace o každém fyzicky provedeném procesu je možno tisknout (viz. předlohy výstupu a doklad).

Na základě definovaných druhů procesů pak uživatelé vytváří fyzické procesy, jejichž přehled je k dispozici v menu Procesy a operace – Procesy. Procesy se uživateli zobrazují v souvislosti s nadefinovanými přístupovými právy, tzn. pokud uživatel nemá k danému procesu právo, ani v tomto přehledu fyzických procesů ho pak nevidí.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 24.07.2009


Pojem - Druh předlohy

Druh předlohy se definuje v činnosti „seznam předloh výstupu“ (činnost SYSTÉM v hlavním menu) v atributu „druh“ (stiskem F2, pravým tlačítkem myši či volbou příslušné ikony z panelu nástrojů). K jednotlivým druhům předloh lze nadefinovat přístupové právo.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 24.07.2009


Pojem - Druh vazby

Jedná se o definici druhu vazby mezi zdrojovým a cílovým uzlem, které se zadávají při definování diagramu druhu procesu. Vazby různého druhu ovlivňují různým způsobem další vývoj daného procesu (řídí tok procesu), správněji cílového uzlu (např.: uvedení operace do stavu připravena, zrušení operací, ...). V kombinaci zdrojový a cílový uzel mohou nastat tyto možnosti dle typu uzlu:

¨ operace – operace

¨ operace – proces

¨ proces – proces

Vazby dle druhu (vliv na uvedení cílové operace do stavu připravena) lze rozdělit takto:

vazby bez výběru

- běžná

- samostatná

- pasivní

vazby s výběrem

- OR a OR opožděná

- XOR a XOR opožděná

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Druh vazby – bez výběru

Jedná se o tyto druhy vazeb:

¨ běžná – cílový uzel je uveden do stavu připravena, jsou –li ukončeny všechny zdrojové uzly, ze kterých vedou běžné vazby do cílového uzlu (simulace logického slučovacího AND z hlediska řídícího toku procesu)

¨ samostatná – cílový uzel je uveden do stavu připravena po ukončení zdrojového uzlu bez omezujících podmínek danými jinými vazbami. Tuto vazbu uživatel využije například při definování procesu, kdy z jedné operace vede vazba do několika operací a tyto operace se opětovně soustřeďují pouze do jedné operace. Potom u těchto operací bude nadefinovaná právě tato samostatná vazba a následující operace bude uvedena do stavu připravena, když bude ukončena alespoň jedna z několika předchozích operací (simulace logického slučovacího OR z hlediska řídícího toku procesu).

¨ pasivní - cílový uzel se do stavu připravena nedostane automaticky po ukončení zdrojového uzlu, je nutno jej ručně spustit nebo aktivovat v kódu po ukončení některé předchozí operace (nemá vliv na řídící tok procesu).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Druh vazby – s výběrem

Obvyklá aplikace výběrových vazeb nastává v případě, kdy po ukončení zdrojové operace je nutné rozhodnout o pokračování procesu (cílovém uzlu) z několika variant. Rozhodování provádí uživatel výběrem v zobrazeném okně. Jedná se o tyto vazby:

¨ výběrová (OR) - uživatel si vybere, které cílové uzly z těch, do kterých vede vazba OR (simulace logického větvení OR z hlediska řídícího toku procesu) budou ovlivněny jako vazbou běžnou.

¨ výběrová (XOR) - uživatel si vybere, který cílový uzel z těch, do kterých vede vazba XOR, (ostatní cílové uzly budou z diagramu odstraněny - simulace logického větvení XOR z hlediska řídícího toku procesu) bude ovlivněn jako vazbou běžnou.

Vazba typu OR nebo XOR by neměla následovat po operaci, která má nastaveno spouštět „na pozadí“, protože systém v tomto případě nedokáže automaticky aktivovat výběrové okno. Pak je nutno spustit znovu operaci, která proběhla na pozadí a teprve po stisku ESC se uživateli zobrazí výběrové okno, kde si vybere, kterou operací chce v procesu pokračovat. Z toho vyplývá, že pokud má operace nastaveno spouštět „na pozadí“, není vhodné používat po skončení této operace vazeb OR nebo XOR.

Pro obě tyto vazby (OR, XOR) platí, že jejich funkčnost se blíží funkčnosti kódu po ukončení operace - základní rozdíl je v tom, že u XOR rozhoduje o cestě pokračování procesu (řídícím toku) subjektivně pouze uživatel volbou, a to i později než v okamžiku ukončení zdrojové operace, zatímco v kódu se rozhoduje obvykle na základě dat v okamžiku ukončení zdrojové operace. Kód po ukončení operace lze kombinovat s vazbou XOR. Rozhodnutí o cestě pokračování v procesu se spouští:

¨ po ukončení operace, je-li nastaveno: ten kdo ukončuje operaci nebo skupina uživatelů, do které patří ten, kdo skutečně ukončuje

¨ klávesou ESC na již ukončené operaci (prohlížení událostí operace) v případě, že při ukončení operace nebylo rozhodnuto, za podmínky, že uživatel patří do skupiny uživatelů, pro kterou je nastaveno, že rozhoduje (je-li nastaveno „ten, kdo ukončuje operaci“, je jediný, kdo může takto rozhodnout).

Dosud nerozhodnuté operace lze zobrazit výběrem nad Operacemi s volbou „Nerozhodnuté“ (ty, které jsou v pravomoci uživatele rozhodnout ) nebo „Nerozhodnuté okolím“ (obsahuje i ty, jejichž rozhodnutí není v kompetenci uživatele, ale nezobrazí ty, které rozhoduje „ten, kdo ukončuje operaci“, pokud to byl jiný uživatel).

Pokud se má po rozhodnutí spustit pokračování procesu on-line, musí být následující operace nastavena spouštět „Automaticky“ nebo "Na pozadí". V každém případě přispěje tato vazba XOR k uvedení cílové operace do stavu „připravena“ až tímto rozhodnutím.

Upozornění (trooubleshoting):

1. Případné „Zrušení stavu ukončená“ operace (umístěné v procesu před rozhodnutím) již neobnoví automaticky ty větve procesu, které byly smazány, tj. i v takovémto případě je nutné již pokračovat zvolenou větví procesu. Nebo udělat storno procesu a začít znovu.

2. Je-li atribut vazby XOR uveden u vazby, u které je paralelní vazba (obě jsou mezi shodnými uzly procesu – tj. z jedné zdrojové operace do dvou různých cílových operací jednoho procesu), pak je nutné pro zajištění funkčnosti XOR je odlišit atributem „Rozlišení“ a zřejmě i pořadím.

3. Definovat 2 vazby XOR mezi 2 operacemi (např. s cílem užití rozdílné transformace dle volby uživatele) není možné.

¨ výběrová (OR) a (XOR) opožděná - význam OR a XOR je shodný jako u předchozích možností, navíc je zde varianta opožděná. Znamená to, že tato vazba (dotaz uživateli) se aktivuje až po dalším spuštění zdrojové operace (při ukončení se žádná vazba neaktivuje), jednoduše řečeno je její aktivace opožděna.

¨ rozhoduje - výběr skupiny uživatelů, která rozhoduje o volbě cílových uzlů (možno zadat pouze u výběrových vazeb). Při ukončení zdrojové operace je potom automaticky této skupině zasílána zpráva, proces (volba cílových uzlů) se v tomto okamžiku pozastaví. Ten, kdo rozhoduje, při přijetí zprávy v menu volby aktivuje činnost „spustit spojenou operaci“. Zobrazí se zdrojová operace, na kterou navazují cílové uzly, o kterých tento uživatel rozhoduje. Po stisku ESC se mu zobrazí na výběr právě tyto možné cílové uzly, uživatel si vybere ty, které budou v procesu následovat a standardně pokračuje v práci s procesem.

¨ opožděná signalizace zprávy - zde se nastavuje počet dnů o kolik má být opožděna zpráva spojená se zdrojovou operací. Např. určité operace (události) mohou mít mezi sebou časovou prodlevu - vystavení a potvrzení smlouvy apod. Tyto operace je možno zobrazit ze seznamu operací pokud se ve výběru zadá možnost, že se jedná o operace „připravené k rozhodnutí“.

Po rozšíření funkčnosti kódu po ukončení operace (zima 2001) pozbyly výběrové vazby na významu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 24.06.2014


Pojem - Druh volné karty

Tato činnost umožňuje uživateli aktualizovat, opravovat a rušit přehled (číselník) druhů volných karet. U každého druhu se eviduje jeho identifikace, název a jméno uživatele, který tento druh založil. Zařazení jednotlivých volných karet pod jednotlivé druhy určitě přispěje k lepší orientaci a k zjednodušení práce s volnými kartami.

Ke každému druhu volné karty je možno nadefinovat přístupová práva (příslušná činnost v menu Volby nebo klávesa Ctrl B).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 25.03.2008


Pojem - Druh výkazu

Druh výkazu umožňuje definice výkazu členit do určitých skupin. Pro každý druh výkazu (věc s přístupem) lze nastavit přístupová práva, kde čtení = právo vidět a užít definici výkazu pro sestavení výkazu a zápis = právo modifikovat definici výkazu (nejedná se o omezení práva k definici listu – ta se může z hlediska přístupu omezit pouze jako činnost).

Každý druh výkazu, pokud existuje alespoň jedna definice výkazu daného druhu, se stává skupinovou položkou hlavního menu zařazenou pod INFORMAČNÍ CENTRUM – VÝKAZY – VÝKAZY KE SPUŠTĚNÍ, pod kterou jsou uživatelům dostupné definice výkazu pro sestavení relevantních výkazů.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Druhy adresátů

Pro každého adresáta je možné definovat jeho druh, jehož prostřednictvím se definují přístupová práva uživatelů systému. Právo může nabývat hodnot Čtení, Zápis nebo Žádné. Toto právo se vztahuje k základním informacím o adresátovi, jeho adresám a adresním spojením a neomezuje možnost zadat adresáta v událostech komponent (např. při vytváření faktury, pokladního dokladu apod.). Práva k bankovním spojením adresáta se definují při nastavování práv přístupu zvlášť zaškrtnutím voleb - 'Ban.spojení - čtení' a 'Ban.spojení - žádné'.

Při aktivaci dané činnosti uživatel nejprve zadává identifikaci a název druhu adresátů, např. zaměstnanci (uživatel potřebuje mít zaměstnance uvedené v adresáři kvůli příkazům k úhradě apod.), ale zároveň nechce, aby osobní údaje zaměstnanců (adresa, bank. spojení) byly dostupné všem, kteří pracují s adresářem. K danému druhu adresátů pak definuje přístupová práva (menu Volby nebo pomocí klávesy Ctrl B).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 24.07.2009


Pojem - Druhy objektů

Přehled jednotlivých identifikátorů objektů tabulek, které obsahuje databáze IS BM.

TABULKA | ID_OBJEKTU | POZNÁMKA
ADADSAT | AD | Adresát
AUPOHL | PD | Pohledávka ke komitentovi aukčního domu
AUSMLOUV | DS | Smlouva o převzetí věci do aukčního domu
AUUDALOS | DU | Událost o věci v aukčním domě
AUVEC | AV | Věc aukčního domu
BIART | AB | Artikl bibliografie
BIKAH | BK | Katalog (bibliografie)
BINAB | BN | Nabídka (bibliografie)
BIUDAL | BI | Události bibliografie
DIDIAR | DI | Záznam diáře
DPUDA | DP | Událost DPH
EXARTIKL | AE | Vozidlo – komponenta expedice
EXUDAL | EX | Událost expedice
MTARTIKL | AM | Skladovaný artikl
MTUDA | MT | Událost skladu
MZKARTA | MZ | Pracovník
MZMZDY | MY | Mzda
MZPERART | AP | Artikly personalistiky
MZPERUDA | UP | Událost personalistiky
MZPRACFT | MQ | Pracovní místo typové (nepoužívat)
MZPRACFU | MP | Pracovní funkce – skutečné a typové
MZPRACPO | PP | Pracovní poměr
NKHODNP | NH | Hodnota parametru předmětu projektu
NKPREDPR | NK | Předmět projektu
NKSMLOUV | NS | Položka smlouvy
NKSMLPLN | NU | Událost plnění položky smlouvy
NKUKOL | NZ | Projektový úkol
NKUKOLP | NX | Plnění projektového úkolu
OBARTADR | OV | Vztah obchodovatelného artiklu a adresáta
OBARTIKL | AO | Obchodovatelný artikl
OBUDAL | OB | Událost obchodu
ODKARTA | AI | Karta odpisovaného majetku
ODUDAL | OD | Událost odpisovaného majetku
OKARTIKL | OX | Artikl obecné komponenty
OKUDALOS | OK | Událost obecné komponenty
PAALGOR | PA | Algoritmus
PLPRIU | PU | Příkaz k úhradě
PLUDA | PL | Událost plateb
POPOSTA | PO | Poštovní zásilka
SAUDAL | SA | Událost správy artiklu
SMMAJ | SN | Spravovaný majetek
SMREZER | RE | Rezervace
SMUDAL | SM | Událost spravovaného majetku
SPDOKOBS | DD | Dokument (obsah)
SPPRC | PR | Proces
SPPRCOD | OO | Operace procesu
SPSELUCE | US | Účetní selektor
SPSEOB | BS | Obchodní selektor
SPSEOR | GS | Organizační selektor
SPSETV | TS | Technicko – věcný selektor
SPTYP | SP | Druh procesu / operace
SZARTIKL | AZ | Kategorie zvířat
SZUDAL | SZ | Událost skladu zvířat
TPVYROB | AT | Artikl výroby
UCDENIK | UC | Účetní událost
VMUDA | VM | Událost vymáhání
VRUDMAT | V3 | Událost pohybu materiálu ve výrobě
VRUDOPER | V4 | Událost úkolu ve výrobě
VRUDOPMA | V3 | Vstup nebo výstup výrobního úkolu
VRUDVYR | V2 | Událost o zakázce výroby
VRVYR | V1 | Výrobní zakázka
VYUDALOS | VY | Událost vývěsky
ZAUDAL | ZA | Událost o záloze
ZPUDA | ZP | Událost změny stavu peněz – výpisy a příkazy

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 16.10.2015


Pojem - Druhy uzlů informačních panelů

V této činnosti uživatel definuje jednotlivé druhy informačních panelů. U každého druhu se zadává identifikace a jeho název. Po stisku Ctrl B nebo aktivací příslušné činnosti z menu Volby je možno ke každému druhu nadefinovat přístupová práva.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.09.2008


Pojem - Duplicita

Obecný význam pojmu duplicita je možno jinými slovy vysvětlit jako „zdvojení, dvojitost, dvojí provádění, dvojkolejnost ...“. Duplicita v IS BM tedy představuje situaci, že by se v systému objevoval více než jedenkrát zcela totožný obsah informací (např. dva adresáti se stejným identifikačním číslem apod.). Aby k takovým situacím nedocházelo, je možno v parametrech adresáře nastavit, které informace se budou z hlediska duplicity kontrolovat.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 23.01.2008


Pojem - Dynamická spojení operací

Je to nástroj, který umožňuje propojit nezávislé procesy (nezávisle zahájené, ale v určité fázi dochází k jejich interakci, tzn. mají společný uzel). Dynamické spojení je vytvořeno jako programový kód pro propojení:

¨ změny stavu peněz s platbou (Např. výpis z banky versus vystavená a přijatá faktura nebo také jejich úhrada pokladnou).

¨ vymáhání s platbou penalizační faktury (v praxi dosud neaplikováno)

Při definici jednotlivých dynamických spojení operací se uvádí:

¨ druh procesu, ve kterém se propojované procesy setkávají (např. proces PL-UP[1], který obsahuje operaci účetnictví, do které se jeden řádek transformuje z procesu platby předcházející PL-UP a druhý řádek z procesu výpisu z banky, který se dynamicky napojuje).

¨ druh operace tohoto druhu procesu, ve které se toto setkává

¨ transformace [2], která předplní data z operace dynamicky napojované

¨ rozlišení, pořadí – podobný význam jako u jiných vazeb v IS

Na záložce „aktivující operace“ se definuje seznam druhů operací, které se mohou dynamicky napojit do již zmíněného druhu operace (uvedeného na první záložce). U dynamického spojení ZSP – platby (zaúčtování platby) je to vždy druh operace z komponenty ZSP (změna stavu peněz). K bližšímu seznámení je vhodné nahlédnout do definic již existujících druhů procesů, které dynamické spojení operací využívají.

S dynamickou vazbou vždy souvisí určitá funkčnost komponenty, která je daná programovým kódem (např. ZSP – platby se aktivuje funkcí párování v komponentě změna stavu peněz).

[1] Vazba diagramu procesu, která vede do procesu PL-UP by měla být vždy pasivní a tento proces by měl mít nastaveno spouštět automaticky.

[2] Na pravý klik myši je možno zobrazit přehled transformací, k dispozici jsou pouze ty, jež mají zatržen příznak „ transformace dynamické vazby“.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Dynamický combobox

Volná karta může být nastavena tak, že se mění obsah překryvného seznamu (platí pro atributy třídy překryvný seznam) při změně hodnoty jiného atributu volné karty (tzn. že při změně hodnoty jednoho atributu překryvný seznam se podle toho automaticky změní i hodnota druhého atributu překryvný seznam).

Pro tuto možnost je třeba definovat:

1. pro atribut třídy překryvný seznam v atributu pro seznam hodnot kód, který zajistí naplnění překryvného seznamu

2. pro atribut, při jehož změně hodnoty má být provedena změna obsahu překryvného seznamu, nastavit validační funkci, kterou se nepřímo vyvolá kód změny překryvného seznamu.

K tomuto účelu se využívá metoda SET_ROWSOURCE atributu třídy překryvný seznam.

Tuto metodu je možné vyvolat výrazem v syntaxi:

_THIS.PARENT.SPF_[název atributu volné karty třídy překryvný seznam].SET_ROWSOURCE()

Např.:

Return _this.parent.spf_sp60id.set_rowsource()

Kód pro naplnění hodnot překryvného seznamu se obvykle uvádí pomocí makra a musí začínat textem *~SCRIPT. V kódu se vyskytují odkazy na atributy volné karty, které ovlivňují obsah překryvného seznamu - těmito odkazy jsou názvy atributů uvedené v hranatých závorkách a před levou závorkou je uveden znak podtržení (např. _[SP61ID]). Kód má dále k dispozici proměnné _THIS instance objektu třídy překryvný seznam, který je odvozen z objektu třídy COMBOBOX Visual Foxpro.

Příklad:

Volné karta, na které je vstupován artikl. Obsahuje atributy:

1. SP61ID - druh artiklu - C(3) - třída textové pole

2. SP60ID - artikl - C(13) - třída překryvný seznam

Požadavek - obsah překryvného seznamu (SP60ID) má odpovídat hodnotě druhu artiklu (SP61ID)

Nastavení vlastností atributů:

1. vlastnost Validace atributu SP61ID - RETURN _THIS.PARENT.SPF_SP60ID.SET_ROWSOURCE()

2. vlastnost Seznam hodnot pro překryvný seznam atributu SP60ID - COMBOBOX_SPARTIKL()

COMBOBOX_SPARTIKL je makro, s definovaný kódem:

<pre>

*~SCRIPT

Local _pc,_als,_li,_i

* _THIS obsahuje instanci objektu třídy překryvný seznam odvozené ze třídy COMBOBOX Visual Foxpro

Do Case

Case Empty(_[sp61id])

Return .F.

Case Type('_this.free_sp61id')<>'C'

* pokud objekt _THIS nemá vlastnost FREE_SP61ID, potom je mu tato vlastnost metodou ADDPROPERTY přidělena

* touto část kódu se půjde pouze jednou

* ve vlastnosti FREE_SP61ID se bude pamatovat, pro kterou hodnotu SP61ID je naplněn překryvný seznam

_this.AddProperty('free_sp61id',_[sp61id])

* vlastnosti COLUMNCOUNT a COLUMNWIDTHS jsou vizuální vlastnosti - toto nastavení, aby seznam lépe vypadal

_this.columncount=0

_this.ColumnWidths=''

Case _this.free_sp61id=_[sp61id]

* poslední zapamatovaná hodnota v FREE_SP61ID odpovídá aktuální hodnotě SP61ID na volné kartě

* obsah překryvného seznamu není proto třeba měnit

Return

Other

* uložení aktuální hodnotě SP61ID z volné karty do FREE_SP61ID

_this.free_sp61id=_[sp61id]

Endcase

* metoda Clear vymazává obsah překryvného seznamu

_this.Clear

_als=Select()

* SQL dotaz na zjištění názvů artiklů požadovaného druhu

If !bw_exec(.F.,[select sp60id,sp62artikl from %%%.spartikn where sp61id=?_p1 and sp38id='CZE'],'_art',_this.free_sp61id)

Select (_als)

Return

Endif

Select _art

* setřídění názvů česky

Set Collate To 'czech'

Index On sp62artikl Tag klic

Set Collate To 'machine'

_pc=0

_li=0

* v cyklu bude naplněn překryvný seznam

Scan All

_pc=_pc+1

* metoda ADDITEM přidává řádek překryvného seznamu

_this.AddItem(Trim(sp62artikl),_pc)

* pomocí vlastnosti LIST vkládá kód do druhého sloupce hodnotu identifikace artiklu

_this.List[_pc,2]=sp60id

if _this.value=sp60id

_li=_pc

endif

Endscan

_this.listindex=_li

Use In _art

Select (_als)

* kód funguje zároveň jako validační funkce

Return _pc>0

</pre>

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Editor uzlů informačních panelů

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.09.2008


Pojem - ELDP

Pojem ELDP představuje „registr evidenčních listů důchodového pojištění“. Od 1.1.2004 došlo k zásadní změně ve způsobu vedení ELDP.

Zákon o důchodovém pojištění č. 155/1995 Sb. ve znění pozdějších předpisů, je založen na pojistném principu. Podmínkou vzniku nároku na důchod je získání potřebné doby pojištění. Celková doba pojištění a výše vyměřovacího základu v rozhodném období ovlivňuje podstatným způsobem procentní výměru důchodu.

Orgány sociálního zabezpečení příslušné k rozhodování o dávkách důchodového pojištění, získávají údaje o dobách pojištění a o výši vyměřovacího základu jednotlivých pojištěnců výlučně z ELDP, které jsou od 1.1.2004 organizace povinny předávat do centrální evidence orgánů sociálního zabezpečení každoročně.

K vedení ELDP je nezbytná alespoň základní znalost ustanovení §§ 5, 8, 11 a 16 ve znění pozdějších předpisů a § 38 a 39 zák.č. 582/1991 Sb., ve znění platném od 1.1.2004.

Pro správné fungování je nutno mít v systému i aktuální knihovny ELDP.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.12.2013


Pojem - Elektronická komunikace ve mzdách

1. PVPOJ

Formulář PVPOJ lze podávat elektronicky. Jedná se o měsíční přehled o výši pojistného (jak za pracovníka, tak za organizaci).

K bezproblémovému chodu je nutno mít zajištěno:

¨ povolení od místní ČSSZ

¨ knihovny PVPOJA, PVPOJB, PVPOJF, CSSZBS, CSSZVO, XMLDOK, XMLDOM

¨ předlohu dokumentu PVPOJ - Přehled o výši pojistného (sada vzdálených funkcí tuto předloho nenahraje, použijte nastavení dle obrázku pvpoj_predloha.jpg)

¨ spouštěnou aplikaci PVPOJ - Přehled o výši pojistného (sada vzdálených funkcí tuto aplikaci nenahraje, nahrajte si balíček pvpoj-aplikace)

¨ v obecné předkontaci RELDP - RELDP1 je nutno zapsat variabilní symbol

¨ doplňující vlastnost formuláře nad Kartou pracovníka - "ELPOD1 - Elektronická podání" (zahrnuje podání ONZ, ELDP, ELDP extra, PVPOJ)

¨ externí příkazy:

ü Elektronická podání

ü Oznámení o nástupu do zam.

ü Evidenční list důch. pojištění 09

ü Evidenční list důch. poj. extra

ü Přehled o výši pojistného

¨ tiskovou sestavu k vygenerovanému dokumentu "Přehled o výši pojistného"

K nahrání potřebných knihoven, DVF a externích příkazů je možné využít Sadu vzdálených funkcí "Výpočet PVPOJ".

Povolení od ČSSZ se získá vyplněním formuláře "Oznámení o pověření k zajištění všech úkonů souvisejících s e-Podáním ČSSZ", na kterém se zaškrtnou všechny 4 možnosti. Tento formulář není součástí IS Bílý Motýl.

Balíčky a obrázky jsou pro implementátory dostupné na N:\_mzdy2013 a pro zákazníky na našem FTP Pro zakazniky/mzdy2013/pvpoj.

1.1 Spuštění PVPOJ

V činnosti Karta pracovníka je nutno kliknout na pracovníka „pomlčka“ (PVPOJ lze spustit pouze na tomto pracovníkovi). Následně si pod menu Volby aktivujte činnost Elektronická podání - PVPOJ. Tímto krokem vznikne dokument, který bude obsahovat údaje daného měsíce. Dokument můžete vytisknout a následně odeslat elektronicky.

2. NEMPRI

Formulář NEMPRI (Příloha k žádosti o) je možné podávat elektronicky.

K bezproblémovému chodu je nutno mít zajištěno:

¨ povolení od místní ČSSZ

¨ knihovny NEMPRI, NEMPRB, NEMPRF, NEMPRE, CSSZBS, CSSZED, CSSZVS, XMLDOM, XMLDOK

¨ předlohu dokumentu NEMPRI - Příloha k žádosti o (sada vzdálených funkcí tuto předlohu nenahraje, použijte nastavení dle obrázku nempri_predloha.jpg)

¨ spouštěnou aplikaci NEMPR - Příloha k žádosti o (sada vzdálených funkcí tuto aplikaci nenahraje, nahrajte si balíček nempri_aplikace)

¨ v obecné předkontaci RELDP - RELDP1 je nutno zapsat variabilní symbol

¨ doplňující vlastnost formuláře nad Nepřítomností pro nemoc - "NEMPRI - Příloha k žádosti o"

¨ tiskovou sestavu k vygenerovanému dokumentu "Příloha k žádosti o (elektron)"

Povolení od ČSSZ se získá vyplněním formuláře "Oznámení o pověření k zajištění všech úkonů souvisejících s e-Podáním ČSSZ", na kterém se zaškrtnou všechny 4 možnosti. Tento formulář není součástí IS Bílý Motýl.

K nahrání potřebných knihoven, DVF a externích příkazů je možné využít Sadu vzdálených funkcí "Výpočet NEMPRI"

Balíčky a obrázky jsou pro implementátory dostupné na N:\_mzdy2013 a pro zákazníky na našem FTP Pro zakazniky/mzdy2013/nempri.

2.1 Spuštění NEMPRI

Aktivujte činnost Nepřítomnost pro nemoc, klikněte na daného pracovníka nebo vyberte pracovníky pomocí označování a pod menu Volby spusťte činnost Příloha k žádosti o. Vznikne dokument, který bude obsahovat údaje o dané nepřítomnosti. Dokument můžete vytisknout a odeslat elektronicky.

Číslo legitimace (číslo potvrzení) nesmí obsahovat mezery.

3. Důchodové spoření PDSHL1

Jedná se o "Hlášení k záloze na pojistné na důchodové spoření za období ...“, elektronicky je to PDSHL1.

K bezproblémovému chodu je nutno mít zajištěno:

¨ číslo účastníka důchodového spoření zadejte do činnosti Karta pracovníka - Volby - Pracovníci v kategoriích - ke kategorii "Důchodové spoření - II. pilíř"(viz obr. duch_spor_cislo.jpg)

¨ nutno mít vyplněnou hlavičku DPH - činnost v komponentě DPH - Daňové přiznání – hlavička (viz dokument hlavicka_priklad.docx)

¨ tiskovou sestavu k vygenerovanému dokumentu "Důch. spoř. -záloha (PDSHL1)" nahrajete pomocí sady vzdálených funkcí "Nastavení mezd pro rok 2013"

Balíčky a obrázky jsou pro implementátory dostupné na N:\_mzdy2013 a pro zákazníky na našem FTP Pro zakazniky/mzdy2013/duch_sporeni.

3.1 Spuštění PDSHL1

Sestava se aktivuje v činnosti Prohlížení výplatních lístků a jmenuje se "Důch. spoř. -záloha (PDSHL1)". Sestava otevře elektronickou komunikaci (obdobně jako např. odesílání daňového přiznání DPH) a předplní požadované údaje.

Chcete-li dokument ukládat do IS Bílý Motýl, musíte si vytvořit předlohu ADISMZ, tj.:

¨ nahrát si balíček duch_spor_zaloha.bex

¨ předlohu dokumentu ADISMZ - ADIS MZDY (sada vzdálených funkcí tuto předlohu nenahraje, použijte nastavení dle obrázku duch_spor_predloha.jpg)

4. Důchodové spoření PDSVD1

Jedná se o "Vyúčtování pojistného na důchodové spoření ", elektronicky je to PDSVD1.

K bezproblémovému chodu je nutno mít zajištěno:

¨ číslo účastníka důchodového spoření je nutno zadat do činnosti Karta pracovníka - Volby - Pracovníci v kategoriích - ke kategorii "Důchodové spoření - II. pilíř" (viz obr. duch_spor_cislo.jpg)

¨ nutno mít vyplněnou hlavičku DPH - činnost v sekci DPH - Daňové přiznání – hlavička (viz dokument hlavicka_priklad.docx)

¨ tiskovou sestavu k vygenerovanému dokumentu "Důch. spoř.-vyúčt. (jen 2013)" nahrajete pomocí sady vzdálených funkcí.

Balíčky a obrázky jsou pro implementátory dostupné na N:\_mzdy2013 a pro zákazníky na našem FTP Pro zakazniky/mzdy2013/duch_sporeni.

4.1 Spuštění PDSVD1

Sestava se aktivuje v činnosti Prohlížení výplatních lístků a jmenuje se "Důch. spoř.-vyúčt. (jen 2013)". Sestava otevře elektronickou komunikaci (obdobně jako např. odesílání daňového přiznání DPH) a předplní požadované údaje. Zatím je nastavena na použití za rok 2013.

Chcete-li dokument ukládat do IS Bílý Motýl, musíte si vytvořit předlohu ADISMZ, tj.:

¨ nahrát balíček duch_spor_zaloha.bex

¨ předlohu dokumentu ADISMZ - ADIS MZDY (sada vzdálených funkcí toto nenahraje, použijte nastavení dle obrázku duch_spor_predloha.jpg)

5. B2B - komunikace s VZP (měsíční hlášení)

Jedná se o měsíční hlášení o zdravotním pojištění "Přehled o platbě zaměstnavatele" pomocí B2B rozhraní VZP ČR. Hlášení B2B pro VZP (Přehled o platbě zaměstnavatele) je možné podávat elektronicky.

K bezproblémovému chodu je nutno mít zajištěno:

¨ povolení od VZP

¨ knihovny B2BPLA, B2BPLB, B2BPLF, CSSZBS, CSSZED, CSSZVO, XMLDOM, XMLDOK

¨ předlohu dokumentu B2B kanál (sada vzdálených funkcí tuto předlohu nenahraje, použijte nastavení dle obrázku)

¨ spouštěnou aplikaci B2B - B2B kanál (sada vzdálených funkcí tuto aplikaci nenahraje, nahrajte si balíček b2b_aplikace)

¨ doplňující vlastnost formuláře nad Kartou pracovníka - "ELPOD1 - Elektronická podání" (zahrnuje podání ONZ, ELDP, ELDP extra, PVPOJ, B2B)

¨ externí příkazy:

ü Elektronická podání

ü Přehled o platbě pojistného

¨ tiskovou sestavu k vygenerovanému dokumentu "Přehled o platbě pojistného"

Balíčky a obrázky jsou pro implementátory dostupné na N:\_mzdy2013 a pro zákazníky na našem FTP Pro zakazniky/mzdy2013/pvpoj_nempri_b2b.

5.1 Spuštění B2B

V činnosti Karta pracovníka je nutno kliknout na pracovníka „pomlčka“ (lze aktivovat pouze na tomto pracovníkovi), pod menu Volby vyberte činnost Elektronická podání - B2B. Vznikne dokument, který bude obsahovat údaje daného měsíce. Dokument můžete vytisknout a odeslat elektronicky.

Registrace a obecné informace jsou dostupné na http://www.vzp.cz/e-komunikace/b2b-kanal/registrace-a-obecne-informace. Nutno je:

¨ vhodný elektronický certifikát pro autentizaci klienta a podpis zasílaného požadavku

¨ standardní připojení k internetu

¨ uzavření smlouvy (dodatku) pro využití služeb zabezpečené elektronické komunikace VZP -> vzory smluv

Pokud jste dosud neuzavřeli žádný dodatek/smlouvu o využívání zabezpečené elektronické komunikace – kontaktujte své územní pracoviště VZP, kde vám sdělí přesné podmínky uzavření dodatku/smlouvy (zda je nutná nebo není nutná osobní návštěva atd.). Při uzavření dodatku je třeba vždy požádat o aktivaci B2B služeb, tyto služby nejsou aktivovány automaticky.

6. B2B komunikace s VZP - Oznámení o pojištěncích

V současné době zatím navrženo řešení, zbývá ověřit, jakým způsobem s tím budou uživatelé pracovat.

Jedná se o formulář "Oznámení o pojištěncích zaměstnavatele B2B" - jde o hromadné předávání oznámení o pojištěncích do VZP ČR

K bezproblémovému chodu je nutno mít zajištěno:

¨ povolení od VZP

¨ knihovny B2BP2A, B2BP2B, B2BP2F, CSSZBS, CSSZED, CSSZVO, XMLDOM, XMLDOK

¨ předlohu dokumentu B2B kanál - změny prac. (sada vzdálených funkcí tuto předlohu nenahraje, použijte nastavení dle obrázku)

¨ spouštěnou aplikaci B2BOZ - B2B kanál - změny prac. (sada vzdálených funkcí tuto aplikaci nenahraje, nahrajte si balíček b2b_aplikace)

¨ doplňující vlastnost formuláře nad Kartou pracovníka - "ELPOD1 - Elektronická podání" (zahrnuje podání ONZ, ELDP, ELDP extra, PVPOJ, B2B, B2BOZ)

¨ externí příkazy:

ü Elektronická podání

ü Oznámení o pojištěncích (VZP)

¨ tiskovou sestavu k vygenerovanému dokumentu "Oznám. - změny"

Balíčky a obrázky jsou pro implementátory dostupné na N:\_mzdy2013 a pro zákazníky na našem FTP Pro zakazniky/mzdy2013/pvpoj_nempri_b2b.

6.1 Spuštění B2B komunikace s VZP

V činnosti Karta pracovníka vyberte pracovníky, označte je a pod menu Volby vyberte Elektronická podání variantu B2B změny. Zaškrtněte "Pro označené pracovníky". Vznikne dokument, který bude obsahovat oznámení o pracovnících, kteří jsou registrovaní u VZP. Dokument můžete vytisknout nebo odeslat elektronicky.

Registrace a obecné informace jsou dostupné na http://www.vzp.cz/e-komunikace/b2b-kanal/registrace-a-obecne-informace. Nutno je:

¨ vhodný elektronický certifikát pro autentizaci klienta a podpis zasílaného požadavku

¨ standardní připojení k internetu

¨ uzavření smlouvy (dodatku) pro využití služeb zabezpečené elektronické komunikace VZP -> vzory smluv

Pokud jste dosud neuzavřeli žádný dodatek/smlouvu o využívání zabezpečené elektronické komunikace - kontaktujte své územní pracoviště VZP, kde vám sdělí přesné podmínky uzavření dodatku/smlouvy (zda je nutná nebo není nutná osobní návštěva atd.). Při uzavření dodatku je třeba vždy požádat o aktivaci B2B služeb, tyto služby nejsou aktivovány automaticky.

7. DPZVD6 Vyúčtování daně

Jedná se o formulář elektronická sestava "DPZVD6 Vyúčtování daně" (zálohová daň). Je to sestava nad Prohlížením výplatních lístků.

Vlastní popis sloupců:

¨ počet zaměstnanců na první straně je podle existence položky L09000 (Příjem zdanitelný zálohově)

¨ do sloupce 06 na první straně se posílá součet položky L41000 za celé období

¨ do sloupce 06a na první straně se posílá součet položky L43000 za celé období

¨ do sloupce 1 a do sloupce 2 se posílá položka L11000 (daň zálohová)

¨ do sloupce 4 se posílá položka L41000 (vyrovnání přeplatku z ročního zúčtování).

¨ do sloupce 5 se posílá položka L43000 (vyrovnání bonusu z ročního zúčtování) + položka L10900 (měsíční daňový bonus)

¨ do sloupce 8 se posílá součet položek L41000 + L43000 + L10900.

¨ do sloupce 9 se posílají položky L11000 - L41000 - L43000 - L10900.

¨ do sloupce 11 (odvedeno) se posílají události ZSP - podle bankovního účtu a adresáta, který je uveden v Parametrech mezd. Zpracované mzdy se hradí vždy až začátkem dalšího měsíce. Toto je hlídaná informace, např. úhrada březnových mezd se hledá v událostech ZSP s datem od 1.4. do 30.4.

Žluté součtové položky jsou výpočtové, ale při změně ve formuláři se přepočítají automaticky samy. Sestavu lze stáhnout pomocí sady vzdálených funkcí.

2. DPSVD2 Vyúčtování daně (srážk.)

Jedná se o formulář Elektronická sestava "DPSVD2 Vyúčtování daně" (srážková daň). Je to sestava nad Prohlížením výplatních lístků.

Vlastní popis sloupců:

¨ do sloupce 1 a do sloupce 2 se posílá položka L21000 (daň srážková)

¨ do sloupce 10 (odvedeno) se posílají události ZSP - podle bankovního účtu a adresáta, který je uveden v Parametrech mezd. Zpracované mzdy se hradí vždy až začátkem dalšího měsíce. Toto je hlídaná informace, např. úhrada březnových mezd se hledá v událostech ZSP s datem od 1.4. do 30.4.

Žluté součtové položky jsou výpočtové, ale při změně ve formuláři se přepočítají automaticky samy. Sestavu lze stáhnout pomocí sady vzdálených funkcí.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 23.10.2014


Pojem - Elektronické přiznání DPH

Veškeré informace o podání elektronického přiznání DPH má uživatel k dispozici na daňovém portálu České daňové správy. V první řadě je nutno podotknout, že aplikace EPO (elektronické přiznání DPH) není aplikací BM, tzn. plně si za tuto aplikaci zodpovídá daňová správa a stejně tak se v čase samozřejmě mohou lehce měnit formuláře apod., které zde máme pro vaši potřebu k dispozici (tzn. tento návod na podání elektronického přiznání DPH se může v čase měnit od aktuálních www stránek daňové správy, podle toho, jak často tyto stránky daňová správa mění a aktualizuje)[1].

Informace o aplikaci elektronického podání DPH má uživatel k dispozici na stránce https://adisepo.mfcr.cz/adistc/adis/idpr_epo/epo2/uvod/vstup.faces.

Pro uživatele je tedy v IS BM k dispozici možnost zpracování vypočtených daňových přiznání elektronicky. Postup tohoto zpracování je následující:

¨ je nutno mít správně vyplněnu činnost „Daňové přiznání - hlavička“

¨ poté stiskem klávesy F5 nebo volbou činnosti z menu Volby uživatel provede výpočet daňového přiznání

¨ v činnosti „vypočtená daňová přiznání“ aktivuje předlohu výstupu ADIS 2013H

¨ po spuštění předlohy se uživateli zobrazí dialogové okno, kde v možnostech zaškrtne volbu „spustit ADIS“ – potvrdí stiskem OK a následně se mu na daňovém portálu České daňové správy otevře formulář pro „elektronické podání pro daňovou správu“ (může se stát, že se neotevře automaticky, ale spustí se uživateli na dolní lištu PC).

Při využití volby „uložit dokument do BM“ je nutno mít v aplikaci předlohy dokumentů nadefinovány příslušné předlohy dokumentů vztahující se k předlohám typu ADIS.

¨ pomocí tlačítka „Procházet“ si vybere soubor vypočteného daňového přiznání a stiskne tlačítko „Načíst“ (nebo ho lze automaticky načíst po stisku klávesy Ctrl V)

¨ po načtení vybraného souboru se uživateli následně zobrazí formulář „Informace o souboru s datovou zprávou“, kde má uživatel tyto možnosti:

- odeslání písemnosti

- úprava ve formuláři

- úplný opis k tisku

- protokol chyb

- načtení souboru

¨ automaticky se předplní formulář „Přiznání k dani z přidané hodnoty“. Uživatel si překliknutím může v klidu prohlédnout jednotlivé oddíly a kapitoly.

¨ po stisku tlačítka „úprava ve formuláři“ se mu zobrazí nabídka jednotlivých částí daňového přiznání

¨ opětovným stisknutím tlačítka „Další stránka“ si uživatel postupně projde všechny stránky daňového přiznání od Záhlaví, přes Oddíl I., Oddíl II. atd. až po Závěr, kde má možnost si prohlédnout protokol chyb, před odesláním si písemnosti uložit na vybrané místo na disku apod. Po přihlášení a stisku tlačítka „Odeslání písemnosti“ dojde k odeslání vytvořeného daňového přiznání DPH.

¨ zároveň má uživatel možnost si zvolit další akci podle svého uvážení, např. uložení k odeslání do Datové schránky, úplný opis k tisku apod.

V případě, že oprávněná osoba má certifikáty uloženy na svém PC, automaticky se předplní, jinak je nutno pomocí tlačítka „vybrat jiný certifikát“ vybrat ručně. Je vhodné vyplnit i příslušnou emailovou adresu, aby měl uživatel přehled v jakém stádiu zpracování se přiznání DPH nachází. Po vyplnění všech údajů pokračuje tlačítkem „Podat“. Tím dojde k odeslání daňového přiznání DPH, uživatel má možnost si uložit kopii na svém PC a i nadále má možnost sledovat stav zpracování daňového přiznání DPH.

Informace pro uživatele:

Po odeslání daňového přiznání následně obdržíte od daňové správy „potvrzení o podání písemnosti“. Zde postupujte podle popsaného připojeného návodu a pomocí tlačítka „uložit potvrzení“ si danou písemnost uložte na svém PC.

[1] Tímto vás prosíme o shovívavost pokud dojde k nějakým rozdílům, není v našich silách ohlídat všechny změny, které nastanou na stránkách daňové správy.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 23.02.2015


Pojem - Elektronický podpis

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.10.2009


Pojem - Entita

Entita je nástroj, pomocí kterého se v datovém modelu modelují objekty [1] reálného světa se shodnou strukturou vlastností (atributů). Ve fyzické interpretaci datového modelu jsou někdy nazývány tabulkami.

Některé entity IS BM jsou "středem" subsetu datového modelu, na kterém jsou postaveny činnosti typu "práce se seznamem záznamů" a dále některé z nich jsou definovány jako objekt.

[1] Objekty v IS BM se rozumí jen entity vybrané programátorem.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - EORI

Na záložce Další v činnosti Adresář je možno zadávat registrační a identifikační číslo hospodářských subjektů, tzv. číslo EORI (Economic Operators Registration and Identification number). EORI číslo musí být uváděno v celním prohlášení jako identifikátor subjektu a slouží jako společný identifikační údaj hospodářských subjektů a jiných osob při jejich kontaktu s celními orgány v celé Evropské unii.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.09.2009


Pojem - EVIVYK - popis programu

Tento dokument seznámí uživatele s jednou z možností zadávání plnění úkolů v projektovém řízení pomocí vytvořeného programu EVIVYK.EXE.

Základním předpokladem pro fungování tohoto programu je:

- IS BM obsahuje komponentu 'Projektové řízení'

- verze BM.EXE je s datem generování po 27.1.2010

EVIVYK.EXE je distribuován v souboru BM.ZIP (jeho adresář \BMSQL\EVIVYK).

Celý tento adresář by měl být umístěn v podadresáři adresáře uložení BM.EXE. Informace zobrazované programem EVIVYK.EXE je možné nastavit kódem 'knihovny vkládaného kódu' s identifikací EVIVYK. V každém případě je třeba tuto knihovnu založit a v jejím kódu nastavit atribut SP07IDTYPD.

Po spuštění tohoto programu (ať už výběrem a aktivací souboru evivyk.exe na určeném místě v PC nebo automatickým spuštěním po startu po přihlášení do IS BM) se uživateli jako první aktivuje přihlášení k tomuto programu, kde je předplněno jméno uživatele a uživatel zapíše pouze své heslo (heslo je totožné s heslem do IS BM).

Po přihlášení se uživateli zobrazí přehled projektových úkolů, ze kterých si uživatel zvolí ten, jehož se jeho plnění týká. Přitom zůstává na horní liště tohoto formuláře vysvícena možnost „Nové plnění úkolu“. Po výběru úkolu (dvojklik pravého tlačítka myši) uživatel zadává další atributy.

Stiskem ikonky „křížek“ v ovládací liště daného formuláře se tento program minimalizuje na dolní lištu počítače (ikonka bílé obálky) a je kdykoliv připraven k použití. Stačí pak pouze stiskem znovu aktivovat a zadat nové plnění úkolu.

Uživateli se po výběru projektového úkolu zobrazí následující formulář. Ten je konstantně umístěn v pravé dolní části obrazovky (velikost a místo umístění měnit nelze, pouze maximalizovat). Uživatel zde má v horní liště předplněn zvolený projektový úkol a dále je předplněn atribut datum aktuálním datem. Další údaje na druhém řádku formuláře jsou kromě data a času ikony:

¨ ikona hodiny – tj. časovač – měří čas daného úkolu, tzn. při výběru projektového úkolu a následném stisku ikonky časovač systém automaticky měří čas, který uživatel na daném úkolu strávil.

¨ popis úkolu – uživateli se po stisku této ikonky zobrazí popis, který je zapsán u zadání projektového úkolu

¨ odstranit plnění úkolu – tuto ikonku uživatel využije v okamžiku, kdy zjistí, že dané plnění nakonec vůbec nechce zapsat. Po stisku této ikonky je pak nutno ještě potvrdit tlačítko „odstranit plnění“.

Na dalším řádku se zadává krátký popis vztahující se k plnění projektového úkolu a v případě potřeby lze delší komentář zapsat v dalším atributu (viz. komentář). Další atribut, který se týká identifikace druhu plnění si uživatel vybere z překryvného seznamu. Implicitně je předplněna možnost „pracovní výkon“, další možnosti mohou být např.: „pracovní výkon – ukončení úkolu, změna stavu úkolu na připraven, čas strávený na cestě“ (nabídka těchto identifikací druhů plnění se mění v závislosti na druhu vybraného projektového úkolu).

Předchozí obrázek poskytuje uživateli pouze vzorovou možnost, jak může vypadat zadávání plnění projektových úkolů. Podle nastavení definice knihovny vkládaného kódu může uživatel při zadávání plnění ještě vstupovat např. obchodní selektor.

V případě, že si uživatel po aktivaci této činnosti vybral určitý projektový úkol a při jeho plnění zjistí, že by potřeboval daný projektový úkol změnit (např. při komunikaci se zákazníkem uživatel nejprve vybere projektový úkol typu „hotline“ a během hovoru může zjistit, že se bude jednat spíše o typ „servisní zásah“) lze projektový úkol pohodlně změnit. Toto se provede dvojklikem na modré liště s názvem projektového úkolu. Uživateli se zobrazí šedě zobrazený seznam dalších projektových úkolů daného druhu a stiskem pravého tlačítka myši na názvu tohoto úkolu je původní plnění přepsáno.

Po zadání všech atributů uživatel pak stiskne tlačítko „Zapsat plnění“ a potvrdí možnost „přepsat všechna Vaše plnění úkolů do BM“. Systém přepíše všechna zapsaná plnění do komponenty projektové řízení (nepřepíše pouze ty plnění s nevyplněným časem, když je čas u daného úkolu povinný).

Tímto způsobem tedy uživatel zadává jednotlivá plnění. Pro zadání dalšího plnění stiskne opět tlačítko „nové plnění úkolu“ a po vyplnění všech atributů tlačítko „zapsat plnění“, přičemž během plnění daného úkolu může opět změnit druh plnění (dvojklik na modré liště).

Může nastat situace, že se během doby, kdy má uživatel tento program aktivní např. změní určité zadání v knihovně vkládaného kódu a pak je nutno si tento aktivní formulář znovu obnovit. To se provede po stisku levého tlačítka myši na tlačítku „nové plnění úkolu“ pomocí Obnovit. Další z možností po stisku levého tlačítka myši je Konec aplikace.

Pro zkušenější uživatele nebo implementátory je v následující části popisu k dispozici příklad možnosti definice obsahu knihovny vkládaného kódu EVIVYK.

<pre>

* Provádí nastavení programu EVIVYK.EXE

* ve výrazech je možné pracovat s atributy:

* sp61id,sp60id,nk01verze,sp62artikl

* nk43,nk43idu,nk43porad,nk43stav,nk43datz,nk43datu,nk43text,nk43koment

* nk53id,nk53nazdru,pa13id,nk42id,nk44id,sp00datzap,sp10text

* atribut sp10text může nabývat hodnotu NULL

* atribut SP07IDTYPD - určuje druh procesu, který bude zakládán při přepisu plnění úkolů z pracovního souboru do komponenty plnění úkolů

* !!! toto je jediné povinné nastavení !!!

_this.sp07idtypd='HPXU01'

* atribut SP33CISDPM - určuje datové úložiště vzniklého procesu

_this.sp33cisdpm='01'

* atribut SQL_UKOLY_PLUS - doplňuje implicitní výběr úkolů pro založení nového plnění úkolu

_this.sql_ukoly_plus='nkukol.nk43stav in(2,3) and nkpredpr.nk01stav=4'

* atribut VYRAZ_STROM_PREDMET - mění implicitní zobrazení předmětu projektu ve stromu, ze kterého se vybírají úkoly pro založení nového plnění úkolu

_this.vyraz_strom_predmet='ALLTRIM(sp62artikl)'

* atribut VYRAZ_STROM_UKOL - mění implicitní zobrazení druhu úkolu ve stromu, ze kterého se vybírají úkoly pro založení nového plnění úkolu

TEXT TO _this.vyraz_strom_ukol noshow

ALLTRIM(nk53nazdru)+IIF((pa13id='T' AND nk53id <> 'IIS') or EMPTY(nk43text),'',' ['+allTRIM(nk43text)+']')

ENDTEXT

* atribut VYRAZ_STROM_ORDER - mění implicitní seřazení úkolů ve stromu, ze kterého se vybírají úkoly pro založení nového plnění úkolu

_this.vyraz_strom_order=[sp62artikl+IIF(pa13id='T','A','B')+nk53nazdru]

* atribut VYRAZ_NADPIS_CAPTION - mění implicitní zobrazení nadpisu plnění úkolu v seznamu rozpracovaných plnění úkolů

TEXT to _this.vyraz_nadpis_caption noshow

IIF(vykony.nk62datum=DATE(),'',

LEFT(TRANSFORM(vykony.nk62datum),IIF(YEAR(vykony.nk62datum)=YEAR(DATE()),6,20))+' ')+

TRIM(vykony.sp62artikl)+'; '+TRIM(vykony.nk53nazdru)+

IIF((vykony.pa13id='T' AND vykony.nk53id <> 'IIS') or EMPTY(vykony.nk43text),'',' ['+allTRIM(vykony.nk43text)+']')+

IIF(vykony.nk62hodin=0,'',' - '+thisform.trans_hodin(vykony.nk62hodin)+' hod.')

ENDTEXT

* atribut VYRAZ_NADPIS_ZMENA - mění implicitní zobrazení v menu úkolů zobrazovaném při změně druhu úkolu předmětu úkolu

TEXT to _this.vyraz_nadpis_zmena noshow

TRIM(sp62artikl)+'; '+TRIM(nk53nazdru)+IIF((pa13id='T' AND nk53id <> 'IIS') or EMPTY(nk43text),'',' ['+allTRIM(nk43text)+']')

ENDTEXT

* atribut VYRAZ_PODMINKA_TIMER - určuje logický výraz - je-li při založení nového plnění úkolu vyhodnocen TRUE, bude toto plnění založeno se spuštěným měřením času

_this.vyraz_podminka_timer=[sp60id='0001']

* metodou SPSEOB_ADD se stanoví to, zda bude s plněním úkolu vstupován obchodní selektor a jaké selektory se budou vstupovat

* např. pro plnění úkolů, jejichž název předmětu projektu začíná písmenem A, je povinný vstup obchodního selektoru začínajícího písmeny IPV0

_this.spseob_add([sp62artikl='A'],[sp10idzak like 'IPV0%'])

* a dále pro plnění úkolů, jejichž název předmětu projektu začíná písmenem E, je povinný vstup obchodního selektoru začínajícího písmenem E

_this.spseob_add([sp62artikl='E'],[sp10idzak like 'E%'])

* atribut TIMER_CLOSECONN.INTERVAL - uvádí čas v milisekundách, po jeho uplynutí je automaticky uzavřeno otevřené spojení s databází

_this.Timer_closeconn.interval=5000

</pre>

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.02.2012


Pojem - Export

Exportem se rozumí schopnost informačního systému poskytnout data jinému IS nebo programu (např. Excel). Exporty se aktivují v každé činnosti typu seznam z menu Obecné pomocí činnosti „Import/Export dat“ volbou ze seznamu definic. V činnostech typu prohlížení seznamu záznamů (v událostech ne) je možno vytvořit definici jaká data a jak mají být exportována a definici pravidel transformace. Při definování jednotlivých definic exportů se předpokládá určitá znalost datového modelu. Přístup k jednotlivým definicím exportu lze chránit přístupovými právy podle druhu exportu.

Definice jednotlivých záložek činnosti export je shodná s činností import, kde je uveden jejich podrobný popis. Odlišností je, že pro charakter definice typu Export je dostupná z menu Volby funkce "SELECT pro export". Po jejím vyvolání se zobrazí okno pro vstup dotazu SQL, který bude použit pro získání exportovaných dat (není-li dosud definován, předplní se dotaz odpovídající dotazu formuláře, ze kterého byla definice Importu/exportu vyvolána). V definice konverze bude výstup tohoto dotazu vystupovat jako tabulka s aliasem _EXP_.

Exporty dat vytvořené u jednotlivých činností (tj. nad formuláři událostí jednotlivých komponent) je možné vyvolat i automaticky při běhu procesu:

¨ uvedením exportu v seznamu exportů na záložce "exporty" u popisu druhu operace. Export se spustí po ukončení dané operace.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Export webovou službou

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 16.02.2012


Pojem - Externí příkazy

V komponentě Informační centrum – Typy a řady je pro uživatele k dispozici činnost externí příkazy. Zde je možno jednotlivé příkazy nadefinovat a v případě potřeby po stisku klávesy F9 spustit. Jinak se nadefinované externí příkazy zobrazují uživateli v hlavním menu v činnosti "spuštění externího příkazu". U každého externího příkazu se zadává:

¨ popis - tzn. název externího příkazu

¨ typ - může být Windows/Dos, FoxPro, Script Foxpro, Script Foxpro kompilovaný (podrobný popis v helpu činnosti)

¨ druh - identifikace druhu externího příkazu

¨ Ktg. – identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu

¨ skrytý - Ano/Ne - při nastavení Ano potlačuje zobrazování externího příkazu v hlavním menu programu

¨ pro vazbu – určen pro volání z vazby externího příkazu (volba Ano/Ne)

¨ programová identifikace - umožňuje vyvolávat externí příkazy ze skriptů - voláním programu SPCALEXT - např. _promenna=SPCALEXT('PRGID')

¨ příkaz - vlastní popis příkazu (definice cesty, souboru, název exe.souboru apod.) - platí pro příkazy typu Windows/Dos a FoxPro

¨ kód - víceřádkový popis kódu - platí pro příkaz typu Script Foxpro

Externím příkazem může být nově také skript v jazyce FoxPro.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 26.06.2008


Pojem - F2 reakce

Jedná se o atribut, který je možno popsat i jako výběrové pole, tzn. že po stisku klávesy F2 je na něm možno vyvolat adresář, číselníky, přehledy, definice apod. Stejně jako klávesa F2 funguje i stisk pravého tlačítka myši (viz. panel nástrojů).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Firewall

Firewall (čti fajrvol) je síťové zařízení , které slouží k řízení a zabezpečování síťového provozu mezi sítěmi s různou úrovní důvěryhodnosti a zabezpečení. Zjednodušeně se dá říct, že slouží jako kontrolní bod , který definuje pravidla pro komunikaci mezi sítěmi, které od sebe odděluje. Tato pravidla historicky vždy zahrnovala identifikaci zdroje a cíle dat (zdrojovou a cílovou IP adresu ) a zdrojový a cílový port , což je však pro dnešní firewally už poměrně nedostatečné – modernější firewally se opírají přinejmenším o informace o stavu spojení, znalost kontrolovaných protokolů a případně prvky IDS .

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2015


Pojem - Formát buňky

Formát buňky je pravidlo, které po aplikaci v definici listu pro danou buňku definuje, jak bude relevantní buňka výkazu formátována při sestavení výkazu. Formát umožňuje předdefinovat písmo, formát čísla a ohraničení buňky.

V případě, že je formát buňky uveden v definici listu, sloupce, řádku má implicitní charakter pro všechny obsažené buňky.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Formulář

Pod pojmem formulář je možno si představit každou činnost, která se uživateli prezentuje svým oknem. Proto i činnost parametry formuláře umožňuje každému uživateli nadefinovat si parametry vždy k dané činnosti zobrazené v danou chvíli v okně. V případě potřeby je možno si nadefinovat ještě doplňující vlastnosti formuláře.

Chování formulářů je podrobněji popsáno v činnosti ovládání formulářů.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.10.2005


Pojem - FTP server

FTP (anglicky File Transfer Protocol) je v informatice protokol aplikační vrstvy z rodiny TCP/IP. Je určen pro přenos souborů mezi počítači, na kterých mohou běžet rozdílné operační systémy (je platformě nezávislý). Jeho podpora je součástí webových prohlížečů nebo specializovaných programů.

FTP server poskytuje data pro ostatní počítače. Klient se k serveru připojí a může provádět různé operace (přenos dat atd.). Operace jsou řízeny sadou příkazů, které jsou definovány v rámci FTP protokolu, proto kdokoliv může vytvořit klienta pro jakékoliv prostředí nebo operační systém. Existuje mnoho programů pro FTP servery i klienty a mnoho je jich volně dostupných.

FTP běžně pracuje na dvou portech, 21 a 20 a běží výhradně přes TCP (Transmission Control Protocol). FTP server naslouchá na portu 21 na příchozí spojení z FTP klienta. Na tomto portu běží příkazy, které zachytává server. Na portu 20 se přenáší pouze data, nikoliv příkazy. Jakmile se začnou stahovat data, na příkazovém portu se nic nepřenáší. Při stahování velkých souborů přes připojení s firewallem může tento kvůli dlouhodobé nečinnosti zablokovat komunikaci na portu 21.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 06.03.2009


Pojem - Funkce automatického dokončování

V informačním systému BM je možné nastavit funkci automatického dokončování při vstupu údajů formuláře podobně jako je možné pro Internet Explorer viz. http://support.microsoft.com/?kbid=217148. Název „Funkce automatického dokončování“ vznikl podle českého překladu obdobného chování Internet Exploreru z anglického pojmu 'Automatic completion functionality', který překládá slovo 'completion' jako 'dokončování'. Podle slovníku slovo 'completion' znamená také 'vyplnění'.

Funkce automatického dokončování se nastavuje zvlášť pro každé pole formuláře, ve kterém je vstupován textový údaj. Některé funkce mohou být nastaveny shodně pro všechny uživatele, některé si nastaví každý uživatel podle svých potřeb. Aktivace této funkce se provádí nastavením definic činnosti parametry polí formulářů vyvolané po stisku pravého tlačítka myši, při kterém je zároveň podržena klávesa Ctrl (Ctrl+pravý klik myši).

Při aktivaci funkce automatického dokončování na vybraném atributu klávesou Ctrl+Home je pro dané pole automaticky vytvořen záznam pro daného uživatele s nastavením „naplnění seznamu návrhů“ na hodnotu Vstupem se systémovým dotazem „Aktivovat funkci automatického dokončování pro pole „....“? Ano/Ne“.

V praxi se postupuje následovně. Uživatel si zvolí formulář a atribut, kde chce tuto funkci automatického dokončování využít (např. ve výběrové záložce činnosti adresář na atributu název adresáta, v událostech obchodu na druhu artiklu, umístění apod.). Pak po stisku klávesy Ctrl a pravého tlačítka myši vyvolá formulář činnosti „parametry polí formulářů“.

Nejprve se mu zobrazí výběrová záložka, kde má předplněn název tabulky a identifikaci atributu, kde chce funkci automatického dokončování realizovat. Po potvrzení výběru pak uživatel definuje jednotlivé atributy.

ZÁLOŽKA „PARAMETRY“ (slouží k definování „funkce automatického dokončování“)

¨ činnost - identifikace činnosti (formuláře) – předplní se

¨ pole - identifikace pole formuláře – předplní se

¨ uživatel - identifikace uživatele systému – předplní se (je předplněno jménem přihlášeného uživatele, pokud je přihlášen správce, předplní se jméno SYSTÉM)

¨ funkce automatického dokončování - překryvný seznam – výběr Ano/Ne

¨ naplnění seznamu návrhů - překryvný seznam (viz. popis dále) - výběr

- Vstupem

- SQL dotazem

- Výčtem

- Skriptem

¨ SQL/Výčet/Skript – tento atribut slouží pro zapsání SQL dotazu pro atribut „naplnění seznamu návrhů“, kde je vybrána volba SQL dotazem, pro seznam hodnot atributu „naplnění seznamu návrhů“, kde je vybrána volba Výčtem nebo pro skript v jazyce Foxpro, který vytvoří seznam hodnot „naplnění seznamu návrhů“=skriptem

¨ počet řádků – v tomto atributu lze nastavit počet řádků zobrazovaných v seznamu návrhů funkce automatického dokončování. Udává se zde maximální počet zobrazovaných řádků, při užití funkce automatického dokončování může být počet řádků zobrazených v seznamu návrhů menší v závislosti na výšce okna aktuálního formuláře.

¨ výraz prefixu – text – výraz v jazyce Foxpro

¨ uplatní se znaků – uvádí se zde počet znaků vstupovaného pole, které se uplatní jako výběr pro naplnění seznamu návrhů (uvedená hodnota -1=všechny znaky)

¨ přenášet hodnotu – překryvný seznam Ano/Ne – při nastavení volby Ano se hodnota pole automaticky přenáší do vstupovaného pole při listování v aktivním seznamu návrhů (aktivní seznam návrhů si uživatel vyvolá např. po užití klávesy Ctrl+ ŠIPKA DOLŮ)

¨ poznámka - text - libovolný text

Takto definované parametry jsou specifické pro dané pole daného formuláře pro aktuálně přihlášeného uživatele systému. Správce systému má možnost aktivovat funkci automatického dokončování pro dané pole daného formuláře pro všechny uživatele systému založením parametrů pro uživatele SYSTÉM. Pokud jsou pro dané pole definovány parametry polí formulářů pro uživatele SYSTÉM a zároveň i pro konkrétního uživatele, potom se uplatňuje nastavení konkrétního uživatele (tj. aktuálně přihlášeného).

Při vstupu textového pole formuláře, pro které je aktivní funkce automatického dokončování, zobrazuje IS BM seznam návrhů na dokončení v překryvném seznamu. Pokud určitý návrh v seznamu odpovídá požadovaným kritériím pro dané pole, dvojklikněte na něj nebo jej vyberte pomocí klávesy ŠIPKA DOLŮ a potom stiskněte klávesu ENTER.

Přechod do seznamu návrhů z klávesnice s možností vybírat si přímo stiskem počátečních písmen textu jeho položek poskytuje uživateli kombinace kláves CTRL+ ŠIPKA DOLŮ. Uživatel se po její aktivaci přemístí kurzorem do seznamu návrhů, ve kterém je umožněn pohyb přímo stiskem počátečních písmen textu jednotlivých návrhů. Klávesu CTRL+ ŠIPKA DOLŮ je možno použít i v případě, že seznám návrhů není právě zobrazen.

Je-li potřeba ze seznamu návrhů na dokončení vymazat jednotlivé položky, je nutno umístit kurzor na požadovanou položku v seznamu návrhů a stisknout klávesu DELETE (při nastavení parametrů „naplnění seznamu návrhů – Vstupem“ a „přidávat do seznamu návrhů – Ano“). Seznam návrhů funkce automatického dokončování se automaticky zobrazí při vstupu jakéhokoliv znaku v daném poli.

Pokud má uživatel již seznam návrhů funkce automatického dokončování pro svoji potřebu naplněn, nastaví pak u parametru polí formulářů na atributu „přidávat do seznamu návrhů – Ne“. Pak mu stávající seznam návrhů zůstane zachován a další návrhy se již nebudou do seznamu přidávat.

Nechce-li uživatel na daném atributu již používat funkci automatického dokončování, nastaví na daném parametru NE u atributu funkce automatického dokončování.

Pokud je funkce automatického dokončování nastavena pro pole vyhledávací záložky formuláře a výběrem položky ze seznamu návrhů je vrácen text delší než je jeho kapacita, potom je pole automaticky přepnuto do stavu rozšířeného vyhledávání (klávesa CTRL+SPACE na výběrové záložce formuláře na znakové položce vyvolává okno pro vstup delšího textu, tím je umožněno zadat delší text pro formátovaný pro výběr v SQL dotazu v klauzuli LIKE).

Podle nastavení parametru pole formuláře „naplnění seznamu návrhů“ vytváří IS BM tento seznam návrhů:

¨ nastavení Vstupem - funkce automatického dokončování uchovává hodnoty zadávané v poli formuláře, jakou je například položka, kterou jste právě zadali po stisku klávesy Ctrl Home. V budoucnu pak může kontrolovat předchozí zadané položky a při zadávání nových položek zobrazovat návrhy.

Seznam návrhů se vytváří tímto způsobem zvlášť pro každého uživatele BM, např. na výběrové záložce činnosti adresář se v názvu adresáta mohou zobrazovat často hledané názvy adresátů v případě, že po zapsání názvu adresáta do výběrového pole uživatel stiskne klávesu Ctrl Home. Pokud tuto klávesu nestiskne, název tohoto adresáta se automaticky předplňovat nebude.

¨ nastavení SQL dotazem - seznam návrhů je naplněn na základě SQL dotazu, např. formulář Adresář může mít pro pole obchodního selektoru na výběrové záložce nastaven parametr SQL/Výčet:

SELECT SP10IDZAK FROM %%%.SPSEOB ORDER BY SP10IDZAK

¨ nastavení Výčtem - seznam návrhů je naplněn na základě textu uvedeného ve výčtu, např.

formulář Procesy může mít pro pole roku identifikace procesu na výběrové záložce nastaven parametr SQL/Výčet:

2001

2002

2003

2004

Při definování obsahu parametru SQL/Výčet je možné používat makra (viz. ukázky dále v textu). Definice maker se vyvolá po zapsání atributů parametrů polí formulářů po stisku klávesy F5 nebo aktivací činnosti z menu Volby. Je vhodné zejména u nastavování návrhů pro atributy, které se opakují v různých formulářích IS BM, aby na každém z nich nemusel uživatel zvlášť definovat parametry polí formulářů.

¨ nastavení Skriptem – seznam návrhů je naplněn vyvoláním kódu v jazyce Foxpro, např. formulář „Procesy“ může mít pro pole roku identifikace procesu na výběrové záložce nastaven parametr SQL/Výčet/Skript:

<pre>

LOCAL _i,_rt

_rt=''

FOR _i=2000 TO YEAR(DATE())

_rt=_rt+TRANS(_i)+CHR(13)

ENDFOR

RETURN _rt

</pre>

Naplnění seznamu návrhů tvořených SQL dotazem nebo Výčtem může být tvořeno jedním nebo dvěma sloupci,

¨ např. formulář Adresář může mít pro pole obchodního selektoru na výběrové záložce nastaven parametr SQL/Výčet:

SELECT SP10TEXT,SP10IDZAK FROM %%%.SPSEOB ORDER BY SP10TEXT,

což v praxi znamená, že uživatel do pole obchodního selektoru zapisuje jeho identifikaci a přitom se mu v seznamu návrhů zobrazují názvy obchodních selektorů.

¨ např. formulář Procesy může mít pro pole roku identifikace procesu na výběrové záložce nastaven parametr SQL/Výčet:

Rok 01|2001

Rok 02|2002

Rok 03|2003

Rok 04|2004

V tom případě jsou v seznamu návrhů zobrazovány texty obsažené v prvním sloupci a položky seznamu návrhů vybírány a vraceny podle druhého sloupce, převedeno do praxe .. uživatel si vybírá z návrhů Rok 01, Rok 02 apod., ale po výběru tohoto návrhu je do atributu předplněno 2001, 2002.

Výraz prefixu se obvykle používá ve spojení s nastavením „naplnění seznamu návrhů“ hodnotou SQL dotazem.

Výraz prefixu je vyhodnocován v okamžiku vytváření seznamu návrhů objektem daného pole formuláře, jeho hodnota filtruje položky vložené do seznamu návrhů. Typicky se tato možnost používá při implementaci funkce automatického dokončování pro pole formulářů, ve kterých se vstupuje artikl, např. obchodovatelný artikl:

Parametr SQL dotaz

SELECT SP62ARTIKL,OBARTIKL.SP61ID+OBARTIKL.SP60ID FROM %%%.OBARTIKL,%%%.SPARTIKN

WHERE SPARTIKN.SP61ID=OBARTIKL.SP61ID AND SPARTIKN.SP60ID=OBARTIKL.SP60ID AND

SPARTIKN.SP38ID=?TOOL.JAZYK AND SP00AKTUAL=1 ORDER BY SP62ARTIKL

Parametr Výraz prefixu

THIS.PARENT.SP61ID.VALUE

Podle SQL dotazu je ve druhý sloupec seznamu návrhů naplněn výrazem OBARTIKL.SP61ID+OBARTIKL.SP60ID.

Při vytváření seznamu návrhů je polem, ve kterém je vstupována identifikace artiklu, vyhodnocen výraz THIS.PARENT.SP61ID.VALUE

a tím je zjištěna hodnota identifikace druhu artiklu vstoupená uživatelem na stejné stránce fomuláře. Do seznamu návrhů jsou potom naplněny artikly daného druhu.

SQL dotaz je obvykle vyhodnocován pouze jednou, při prvním vytváření seznamu návrhů daného pole formuláře. V některých případech je vhodné omezit počet vrácených záznamů a SQL dotaz provádět při každé změně seznamu návrhů. V tom případě se výraz SQL dotazu uvádí znakem '*' a hodnota prefixu je v tomto výrazu prezentována parametrem ?_P1.

Jedná se např. o implementaci funkce automatického dokončování pro pole formulářů, ve kterých se vstupuje spojení adresátů:

Parametr SQL dotaz

*SELECT AD11JMENO,AD01ID+AD11CISSPO FROM %%%.ADSPOJ WHERE AD01ID=?_P1 AND TRIM(AD11JMENO)<>'' ORDER BY AD11JMENO

Parametr Výraz prefixu

THIS.PARENT.AD01ID.VALUE

Potlačení funkce automatického dokončování pro toto pole proveďte nastavením Funkce automatického dokončování - ne a zrušením záznamu, jinak by se při instalaci nové verze IS BM tento parametr opětovně založil.

Při definování obsahu parametru SQL/Výčet je možné používat makra. Příklady maker:

*

ID=SYS001

Název=SQL_spseob_XXX

select sp10text,left(sp10idzak,3) from %%%.spseob where sp10idzak like '___000000' and current date between isnull(sp10datum,current date) and isnull(sp10datumd,current date) order by sp10text

*

ID=SYS002

Název=SQL_mtskl

select mt04text,mt04id from %%%.mtskl order by mt04text

*

ID=SYS003

Název=SQL_spseob

select sp10text,sp10idzak from %%%.spseob where current date between isnull(sp10datum,current date) and isnull(sp10datumd,current date) order by sp10text

*

ID=SYS004

Název=SQL_obumist

SELECT ob05text,ob05id FROM OBUMIST order by OBUMIST.ob05text

*

ZÁLOŽKA „SKRIPTY POLE“ (definují se zde skripty v jazyce FoxPro daného pole formuláře)

Na této záložce nazvané 'Skripty pole' se definuje:

¨ typ skriptu - překryvný seznam - zatím je aplikován jediný typ skriptu 'Reakce na F2'

¨ skript - text - obsahuje kód v jazyce Foxpro

¨ poznámka

Pro uplatnění skriptů vzhledem k uživateli vedeném u skriptu platí totéž, co platí v tomto smyslu pro 'Funkce automatického dokončování':

¨ takto definované parametry jsou specifické pro dané pole daného formuláře pro aktuálně přihlášeného uživatele systému

¨ uživatel s právy správce systému má možnost aktivovat funkci automatického dokončování pro dané pole daného formuláře pro všechny uživatele systému založením parametrů pro uživatele SYSTÉM

¨ pokud je pro pole definováno Globální nastavení parametrů a zároveň nastavení parametrů uživatele, potom se uplatňuje nastavení uživatele

Skript typu 'Reakce na F2' se provádí na vstupním poli formuláře po stisku klávesy F2 resp. po pravém kliku myší.

Tomuto skriptu jsou předávány parametry (ve skriptu se neuvádí příkaz PARAMETER):

- _this - objekt, na kterém uživatel stiskl klávesu F2

- _thisform - objekt formuláře

Skript musí vracet hodnotu:

- .T. - TRUE - v případě, že skript proběhl a nemá být provedena funkce, která je pro 'Reakci na F2' naprogramována v BM.EXE

- .F. - FALSE - v případě, že skript neproběhl a má být provedena funkce, která je pro 'Reakci na F2' naprogramována v BM.EXE

Jediný společný skript je určen pro pole umístěná v mřížce a pro pole na stránce formuláře. Pokud nemá být skript proveden pro pole v mřížce, může být tato potřeba ošetřena na začátku skriptu např. kódem:

<pre>

IF UPPER(_this.parent.baseclass)='COLUMN'

RETURN .F.

ENDIF

</pre>

Příklad skriptu, který po pravém kliku myší na datu události obchodu v gridu vyvolá kalendář a potom zapíše do události vrácenou hodnotu:

<pre>

Local _ret

Do Case

Case !_thisform.komp_stav

* když se nejedná o spuštěnou operaci, provede se obvyklá akce po F2 naprogramovaná v BM.EXE

Return .F.

Case _thisform._o_kompo_.ukoncena

* když se jedná o ukončenou operaci, provede se obvyklá akce po F2 naprogramovaná v BM.EXE

Return .F.

Case _thisform._o_kompo_.sp07idtypd<>'PROCES'

* když se nejedná o operaci druhu procesu 'PROCES', provede se obvyklá akce po F2 naprogramovaná v BM.EXE

Return .F.

Case Upper(_this.Parent.BaseClass)<>'COLUMN'

* když se nejedná o pole v mřížce, provede se obvyklá akce po F2 naprogramovaná v BM.EXE

Return .F.

Endcase

If Val(Tool.get_prof('','CalendarXP','1',.T.))=1

Do bw_prika With [Do Form bw_gdate With _p1,.T. to _p2],_this.Value,_ret

Else

Do bw_prika With [Do Form bw_gdatx With _p1,.T. to _p2],_this.Value,_ret

Endif

If Type('_ret')$'TD' And _ret<>Nvl(_this.Value,{})

_this.Value=_ret

_thisform._pf_.p1.ob02datdod.Value=Max(_thisform._pf_.p1.ob02datdod.Value,_ret)

_thisform._pf_.p1.ob02dat.Refresh

If !_thisform._edit

_thisform.formakce('=')

Endif

Endif

* když skript nevrátí hodnotu .F. ('RETURN .T.' nemusí být uveden, protože skript, který nebyl ukončen příkazem RETURN, vždy vrací hodnotu .T.),

* tak se neprovede obvyklá akce po F2 naprogramovaná v BM.EXE

</pre>

Poznámka:

Při instalaci nové verze BM je automaticky vytvořen záznam globálního nastavení (tzn. uživatel SYSTÉM) pole „název adresáta“ na výběrové záložce formuláře Adresář s nastavením „naplnění seznamu návrhů – vstupem“. Toto nastavení je definováno jako ukázkové pro upozornění implementátorů na novou funkci automatického dokončování.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 01.03.2012


Pojem - Funkce IS

Funkce IS v BM jsou tvořeny:

¨ programovým kódem

¨ uživatelsky (šablona, obecný výběr, výkazy apod.)

¨ zprostředkovaně (spouštěné aplikace, externí příkazy apod.)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 11.10.2007


Pojem - Funkce v EV verzi

Jedná se o implementačně přidané funkce.

Funkce "bm_stringToStringLiteral"

Převádí vstupní řetězec na „string literal“, tzn. že uvnitř ošetří skupiny znaků, které vypadají jako řídící znaky (control characters) tak, aby nebyly interpretovány jako řídící znaky. Primárně je určena k tomu, že vracená funkční hodnota se může použít ke konstrukci příkazu pro "EXECUTE IMMEDIADE".

Vlastní obsah funkce:

ALTER FUNCTION "bm_servis"."bm_stringToStringLiteral"( IN @stringPar long varchar, IN @charProvisional char(1) default null)

//

//--------convert string (it is par example content of column or content of variable, etc.) to "string literal" (see help Sybase)

// the returned "string literal" you can use in construction of expression for EXECUTE IMMEDIADE

//--------převede znakový řetězec (tj. například obsah sloupce nebo obsah promenne, apod.) na "string literal" (viz help Sybase)

// vracený "string literal" se může použít v konstrukci příkazu pro "EXECUTE IMMEDIADE"

// Parameters:

// @stringPar - transformed input string / převáděný vstupní řetězec

// @charProvisional - use only if @stringPar contains char(0) and two \\, than insert as parameter some char whiche does not contain in @stringPar

// - použít jen, pokud vstupní parametr "@stringPar" obsahuje znak "char(0)" a také dvě zpětná lomítka, v takovém případě

// vložte jako parametr @charProvisional jakýkoliv znak, který není obsažen ve vstupním řetězci @stringPar

//

RETURNS LONG VARCHAR

DETERMINISTIC

BEGIN

DECLARE "@rt" LONG VARCHAR;

DECLARE @substrStart int;

DECLARE @hexaNumber char(2);

DECLARE @charProvisionalUsed tinyint;

//

if @stringPar is null then

return char(39)+char(39); -- ruturn two apostrophes '' (empty string literal)

end if;

set @rt=@stringPar;

//--- two backslashes (\\) replaces with provisional character, whiche will replace with four backslashes (\\\\) in the next time

if LOCATE(@rt,char(92)+char(92))>0 then

if @charProvisional is null then

set @charProvisional=char(0);

endif;

set @rt=replace(@rt,char(92)+char(92),@charProvisional);

set @charProvisionalUsed=1;

else

set @charProvisionalUsed=0;

end if;

//

set @rt=replace(@rt,char(39),char(39)+char(39)); -- one apostrophe (') replaces with two apostrophes ('')

//

set @rt=replace(@rt,char(92)+char(110),char(92)+char(92)+char(110)); -- substring (\n) replaces with (\\n), (\n) represents new line

//---- to each sequence \x[a-f0-9][a-f0-9] or \x[a-f0-9][a-f0-9](it means hexadecimal value)

// adds one slash on the start \\x[a-f0-9][a-f0-9], (case insensitive=use ASCII)

set @substrStart=LOCATE(@rt,char(92)+'x');

c1: WHILE @substrStart>0 LOOP

set @hexaNumber=SUBSTR(@rt,@substrStart+2,2);

if (ascii(LEFT(@hexaNumber,1)) between 48 and 57 or ASCII(LEFT(@hexaNumber,1)) between 97 and 105)

and (ascii(RIGHT(@hexaNumber,1)) between 48 and 57 or ASCII(RIGHT(@hexaNumber,1)) between 97 and 105) then

set @rt=SUBSTR(@rt,1,@substrStart)+char(92)+SUBSTR(@rt,@substrStart+1);

end if;

set @substrStart=LOCATE(@rt,char(92)+'x',@substrStart+2);

END LOOP c1;

// ---replaces provisional character (representing // from origin string) with four backslashes \\\\

if @charProvisionalUsed=1 then

set @rt=replace(@rt,@charProvisional,REPLICATE(char(92),4));

end if;

set @rt=char(39)+@rt+char(39); -- add apostrophe on the start and on the end

RETURN "@rt";

END

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 25.11.2014


Pojem - Funkce v SQL databázi

Některé funkce využívá přímo programový kód BM, dále jsou takové jako v EV verzi, ty jsou opakovatelné a užitečné v různých implementacích (jsou dostupné a definovány jsou přímo autory systému). Do databáze si je v případě potřeby může přidat i přímo implementátor.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 25.11.2014


Pojem - Funkce výkazů

Funkce výkazu jsou uživatelsky definovatelné funkce, které po svém volání při sestavení výkazu vracejí hodnotu některého z těchto typů: Numerická, Znaková, Datumová nebo Seznam hodnot.

Způsob výpočtu hodnoty je uživatelsky formulován pomocí programového kódu funkce. Variabilitu použití jedné funkce lze zajistit pomocí parametrů funkce, pak i při definici výrazu, ze kterého je volána daná funkce, se uvede funkce s parametry.

Součástí definice funkce výkazu je typ vracené hodnoty, template volání funkce (např.: [selor],[seltv],[selob]), tj. jak IS předplní volání funkce v sestavovaném výrazu po jejím výběru a přenesení (F2 – CTRL Enter) z jejich seznamu, programový kód a struktura parametrů funkce.

Založení nové funkce výkazu uživatelem je autorizováno.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 06.03.2007


Pojem - Fyzický proces

Je modelem jedinečného výskytu procesu v reálném světě, v informačním systému jej lze najít v činnosti Procesy a operace – Procesy, kde se uživateli zobrazuje přehled fyzických procesů, dále též viz. proces.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Generování úkolů zakázky

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.01.2008


Pojem - Harmonogram výroby (nový)

Nový harmonogram výroby (v popisu dále pouze „NHV“) slouží k naplánování výrobních úkolů na jednotlivých výrobních linkách (roštech). Po aktivaci této činnosti se uživateli nejprve zobrazí činnost „NHV“ s aktivní záložkou „Výběr“. Zde si nadefinuje data, která chce mít v harmonogramu k dispozici (tzn. číslo výroby, datum od – do, fáze, adresáta, druh linky, linku, operaci, ...). Důležitým atributem je „provádět změny – Ano/Ne“. Pokud je nastaveno Ano, může uživatel v harmonogramu realizovat posun úkolů, v případě, že je nastaveno Ne, změny v harmonogramu realizovat nemůže a harmonogram mu slouží pouze k prohlížení.

Po načtení záložky výběr se uživateli zobrazí dva formuláře. Menší formulář „NHV“ s informacemi o konkrétním výrobním úkolu (aktivní záložka Výrobní úkoly) a větší formulář s grafickým zobrazením výrobních úkolů („NHV“ – přehled). K dispozici jsou údaje o dnu, na které lince se výrobní úkol plní, na kolik směn a v jakém časovém rozpětí.

Jednotlivé sloupce ve formuláři „NHV“ (menší formulář) lze kdykoliv podle potřeby přesouvat (např. pro potřebu zvýšení přehlednosti v tiskových sestavách). Výrobní úkoly jsou řazeny v řádcích a jejich zbarvení určuje v jaké fázi zadávání se výrobní úkol nachází.

V případě, že výrobní úkol ještě nebyl zadán, je zbarven fialově. Úkoly, se kterými bylo manipulováno a které ještě nejsou zapsány jsou zbarveny šedě. Šedě jsou zbarveny i úkoly, které již byly zapsány, následně se s nimi znovu manipulovalo (např. přesouvání mezi výrobními linkami apod.) a tyto změny ještě nebyly zapsány.

Výrobní úkol si může uživatel zobrazit dvojím způsobem:

¨ překliknutím na záložku Popis, kde jsou konkrétní údaje k danému výrobnímu úkolu

¨ kliknutím na výrobní úkol přímo v „NHV – přehled“

Formulář „Nový harmonogram výroby – přehled“ poskytuje uživateli v horní liště následující informace:

¨ 1/1 (případně 1/2 ...n) – počet stran NHV, na jednu stranu připadá 70 řádků

¨ P – předchozí strana - pravý klik o pět záznamů (nikoliv stran) zpět

¨ N – následující strana – pravý klid o pět záznamů (nikoliv stran) vpřed

¨ O – označují se výrobní úkoly vhodné ke sloučení

¨ Z – krok zpět (vrátí poslední provedenou změnu v harmonogramu)

¨ U – uloží se změny provedené v harmonogramu

Sloupce odpovídají časovému úseku 30 nebo 60 minut výroby (časový úsek si uživatel nastaví na záložce Výběr). Časový harmonogram začíná s časem zahájení první směny. V prvním sloupci je zasán den a číslo výrobní linky, přičemž znak „#“ označuje delší směnu.

Zadávání výrobního úkolu uživatel provede v okně „Nový harmonogram výroby – přehled“. Vkládání výrobního úkolu provede uživatel přetažením z okna Nový harmonogram výroby ze záložky Výrobní úkol (lze vkládat pouze nezadané úkoly, tj. fialově zbarvené). Uživatel si označí daný výrobní úkol (kliknutím na něj), v dolní části okna se objeví ikona „ruky s nataženým ukazováčkem“ a metodou „táhni a drž“ (na ikonu ruky) přetáhne výrobní úkol na požadované místo. Po přetažení výrobního úkolu se ve formuláři „NHV – záložka Výrobní úkoly“ zbarví výrobní úkol šedě. Po uložení této procedury pomocí tlačítka „U“ změní zbarvení na bílou barvu a tímto je výrobní úkol zadán.

Při vkládání více různých výrobních úkolů se může každý zbarvit jinak, ale úkoly jedné výrobní zakázky mají vždy stejné zbarvení. Po vložení výrobních úkolů je nutno změny zapsat (pomocí klávesy F5 - Zapsat změny harmonogramu). Uložený výrobní úkol uživatel pozná podle toho, zda je název artiklu podtržen (podtržen = není uložen). Při ukončení harmonogramu bez uložení změn je uživatel systémem automaticky dotázán zda chce provedené změny uložit.

V praxi může nastat situace, že výrobní úkol přesahuje pracovní dobu linky. V takovém případě se systém při ukládání dotazuje, zda má výrobní úkol rozdělit. Po potvrzení volby „Ano“ se část přesahující čas denní výroby „odřízne“ a automaticky zařadí na začátek nejbližšího možného termínu stejné výrobní linky. Zbývající část výrobního úkolu se přesune na začátek další směny i v případě, že se na lince nachází již jiný výrobní úkol. Nastane tedy potom situace, že na jedné lince ve stejnou dobu bude více výrobních úkolů (tzn. zvětší se šířka řádka v přehledu NHV). Výrobní úkoly se v takové situaci řadí sestupně pod sebe podle času začátku výroby. Záleží zcela na uživateli, jestli některý výrobní úkol přesune na jiný termín. Pokud nastane situace, že se v harmonogramu výroby nachází více výrobních úkolů přesahujících pracovní dobu linky, je pak uživatel na každý z nich systém dotazován postupně.

V případě potřeby je pro uživatele k dispozici činnost, která mu umožňuje rozdělené výrobní úkoly opět spojit (využije ji i při nutnosti spojení vybraných výrobních úkolů). Tato činnost se nazývá slučování. Jaké výrobní úkoly lze sloučit uživatel zjistí dvojklikem myši na dané události. Na záložce Výrobní úkoly se pak následně ve sloupci Výroba č. označí červeně ty výrobní úkoly, které je možno s původním výrobním úkolem sloučen. Toto označení pomocí zbarvení funguje pouze v případě, že na záložce „výběr“ má uživatel použitu paletu „barvy dle artiklu“.

V případě, že uživatel nevyužívá palety barev, je možno provést slučování trojím způsobem:

¨ pomocí ikony v horní liště

¨ pomocí činnosti pod menu Volby „Označit výr. úkoly ke sloučení“

¨ ručním označením výrobních úkolů v NHV – záložka „výrobní úkoly“

Po zvolení výrobních úkolů ke sloučení uživatel aktivuje pod menu Volby činnost „Slučování výrobních úkolů“. Následuje systémový dotaz, zda uživatel chce slučovat výrobní úkoly i z různých směn. Toto je uživatelské rozhodnutí, v programu je implicitně nastavena volba NE. Po potvrzení OK se zobrazí okno „slučování“, ve kterém jsou k dispozici informace o slučovaných výrobních úkolech, č. zakázek, fázích, linkách operace, artiklu a umístění. V tento okamžik má uživatel možnost ještě proces slučování zrušit. Pokud ale potvrdí volbu ANO, jsou vybrané výrobní úkoly sloučeny. Pokud se slučují události z více výrobních linek, IS se dotazuje na každou zvlášť. Provedené změny se ihned graficky neprojeví, ale IS si je již pamatuje a nedovolí provést změny, které by zasahovaly do předchozích změn.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.01.2008


Pojem - Hash heslo uživatele

V některých firmách potřebují využívat databázi uživatelů IS BM (tzn. jméno a heslo) zároveň i pro přihlašování do jiných programů (např. intranet, ...). BM volitelně ukládá do tabulky uživatelů systému (BWUZIVAT) při změně hesla uživatelem zadané heslo zakódované určenou hash funkcí. Před zakódováním hash funkcí se zadané heslo převede na malé znaky.

Hash funkce je transformace, která jako vstup přijímá řetězec znaků o libovolné délce a výsledkem je pak řetězec znaků s pevnou délkou, tzv. hash nebo také otisk. Hash funkce se často používají v kryptografii, kde se však na její kvalitu kladou další kritéria. Funkce je jednosměrná, je nemožné jednoznačně najít k otisku původní text.

Hash se ukládá do atributu BW01HHASH tabulky BWUZIVAT v binárním nebo hexadecimálním tvaru (při nastavení Preferencess->PasswordHashHexa=1) a číslo hash funkce se zapisuje do atributu BW01HHASHT. Pro použití hash funkcí 1 až 7 je nutné, aby v adresáři programu BM byl nainstalován soubor VFPENCRYPTION.FLL a dále je nutno na každou stanici instalovat knihovny VC++ 8.0 runtime. Použití funkce 50 (MD5) nevyžaduje instalaci žádných externích prostředků.

Možnost ukládat hash hesla uživatele je pouze ve verzích BM pod Visual Foxpro 8.0 nebo vyšší.

Poznámka:

Parametrem programu BM Preferencess->PasswordHashAlgorithm (v činnosti nastavení programu BM) se určuje použitá hash funkce pro zakódování hesla.

1 = SHA1 (a.k.a SHA160)

2 = SHA256

3 = SHA384

4 = SHA512 *Default

5 nebo 50= MD5

6 = RIPEMD128

7 = RIPEMD256

V IS BM v nastavení programu je k dispozici funkce „bm_overeni_uzivatele_hash“. Ověřuje uživatele (tabulka BWUZIVAT) dle zadaného hesla pomocí HASHe (atribut bw01hhesh). Způsob "HASHování" a způsob uložení HASHe se nastavuje v SYSTÉM->Nastavení programu BM, Sekce: Preferences, Parametr: PasswordHashAlgorithm, PasswordHashHexa (tabulka BWOPTION).

Parametry:

¨ @uzivatel - identifikce uživatele (atribut bw01uziv) - implicitní, je-li délka <=6

¨ jméno uživatele (atribut bw01jmeno) - implicitní, je-li délka >6, popř. #J v parametru @zpusob

¨ @heslo - heslo uživatele

¨ @zpusob - určuje chování funkce, může obsahovat řídící znaky:

#J - parametr @uzivatel je jméno uživatele (atribut bw01jmeno)

#N - neprovádí se převod hesla na malá písmena (v IS BM jsou uložena hesla malými písmeny)

#M - při chybě zobrazení oznámení (MESSAGE <oznámení> TYPE WARNING TO CLIENT)

#R - při chybě chyba ODBC (RAISERROR <oznámení>)

#H:<způsob> - způsob "HASHování", není-li uvedeno, potom se řídí parametrem PasswordHashAlgorithm pro hodnoty: 1,2,5,50, kde <způsob> může mít hodnoty: MD5,SHA1,SHA1_FIPS,SHA256,SHA256_FIPS

#U:<způsob> - způsob uložení HASHe v IS BM, není-li uvedeno, potom se řídí parametrem PasswordHashHexa, kde <způsob> může mít hodnoty: B(binárně),H(hexadecimálně)

Návratové hodnoty:

¨ 1 - OK

¨ 0 - <oznámení>: Chybné heslo (RAISERROR 23000)

¨ -1 - <oznámení>: Uživatel nenalezen (RAISERROR 23001)

¨ -2 - <oznámení>: Uživatel nemá vygenerovaný HASH (RAISERROR 23002)

¨ -3 - <oznámení>: Nepodporovaný typ HASHe (Parametr PasswordHashAlgorithm) (RAISERROR 23003)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 24.11.2014


Pojem - Historie ceny

U každého artiklu lze nastavit, zda se u něj má evidovat historie ceny či nikoliv. Pokud je zatrženo, bude se u daného artiklu evidovat historie jednotlivých typů cen. Příznak „historie ceny“ je automaticky zatržen, pokud má druh daného artiklu zatržený atribut „předplňovat – evidovat historii ceny artiklu v činnosti Druhy artiklů Historie cen je zaznamenána, je-li provedena změna ceny v ceníku. Ke změně ceny může dojít dvojím způsobem:

¨ přímým přepsáním ceny v ceníku

¨ přepsáním ceny v událostech obchodu s tím, že na událostech obchodu je zaškrtnut atribut "aktualizovat cenu"

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 18.01.2008


Pojem - Historie karty a pracovního poměru

Tyto činnosti se nacházejí v menu Mzdy – Mzdy – Speciální činnosti. Poskytují uživateli přehled o historicky zadaných údajích na kartě pracovníka a údajích týkajících se prac. poměru. Uživatel má pak možnost si zvolit rok, měsíc a pracovníka, jehož údaje chce vidět. Tuto činnost zřejmě může využívat většina uživatelů ve chvíli, kdy potřebuje zjistit určité údaje o pracovníkovi týkající se minulosti (např. loňského roku apod.).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.11.2007


Pojem - Hlavní kniha

Hlavní kniha je účetní kniha, ve které jsou účetní záznamy uspořádané z věcného hlediska, tj. dle čísla účtu. V IS BM se tedy jedná o on-line zobrazení položek účetních zápisů na daný účet, případně na všechny (vybrané) účty s řazením položek účetních zápisů dle čísla účtu. Hlavní kniha je v IS BM primárně vedena pro každý použitý účet.

Uživatel má činnost Hlavní kniha pro jednotlivé účty vždy k dispozici na formulářích činností s agregovanými obraty účtu (např. Obratové tabulky, Konta) na vlastní záložce „Hlavní kniha“, která se zobrazí za daný účet a daný měsíc z obratových tabulek a nebo za daný účet od počátku roku z kont (vždy za zobrazený obrat na obou stranách). Obratová tabulka tedy obsahuje sumární stavy za jednotlivé analytické účty po měsících a selektorech, kdežto hlavní kniha obsahuje položkové údaje daného analytického účtu za konkrétní měsíc a selektor.

U každého účtu má uživatel v okně „Hlavní kniha“ nejprve přehled o agregovaných hodnotách za období, tj. o jeho počátečním stavu, obratech na straně MD, obratech na straně D a konečném stavu za zvolené období vyjádřené v Kč a zároveň jsou zobrazeny hodnoty obratů téhož účtu v hodnotách konkrétních použitých cizích měn. Následuje detailní seznam všech položek účetních zápisů na daný účet v daném období.

Jiný způsob, jak získat zobrazení hlavní knihy (a to i kompletní za všechny účty současně) z účetních zápisů, je volba odpovídajícího řazení a výběru přímo v činnosti Účetní deník s případnou agregací v předloze výstupu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.09.2008


Pojem - Hlavní menu

Po zadání vstupního hesla a přihlášení se do systému se uživateli vždy zobrazí hlavní menu. Hlavní menu může být tvořeno základní definicí menu nebo může být uživatelsky definováno (tzn. vytvořeno jako odvozené menu). Hlavní menu obsahuje skupiny a činnosti, které se každému uživateli po přihlášení do systému na základě jeho nastavených přístupových práv zobrazí, tzn. že vzhled hlavního menu může být pro každého uživatele různý. Po stisku pravého tlačítka myši na skupině nebo činnosti je možno vyvolat další možnosti, včetně vlastností dané činnosti.

Hlavní menu se z hlediska ovládání k uživateli chová jako běžné okno IS BM. Stejně se ovládá (tzn. lze je zvětšit, zmenšit na lištu apod.), obsahuje panel nástrojů i horní lištu. Uživatelsky změnit zobrazení a ovládání hlavního menu lze pomocí činnosti „nastavení stromu“. Tuto činnost uživatel aktivuje po stisku pravého tlačítka myši na názvu vrcholových činností nebo kdekoliv ve volném prostoru hlavního menu.

Jednotlivé činnosti hlavního menu lze přeložit do cizího jazyka. Nepoužívá se k tomu však tlačítko překlad ve vlastnostech činnosti hlavního menu, ale atribut jazyk v horní liště hlavního menu. V případě, že chce uživatel mít např. hlavní menu přeloženo do angličtiny, zatrhne si v horní liště příslušný jazyk a pak jednotlivé činnosti v atributu název ve vlastnostech přepíše. Pak se při přepnutí do cizího jazyka bude zobrazovat hlavní menu v daném jazyce, v případě zvolení češtiny bude hlavní menu česky.

Stejně jako na jednotlivých činnostech hlavního menu, lze i přímo v hlavním menu po stisku pravého tlačítka myši vyvolat vlastnosti hlavního menu. Tyto vlastnosti se však uživateli nabízí jen při zobrazení typu velké ikony, malé ikony a seznam. Při stisku pravého tlačítka myši při zobrazení detaily a strom činností se aktivují přímo vlastnosti aktivní činnosti, tj. té, na které je právě umístěn kurzor.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 03.06.2008


Pojem - Hlavní menu – horní lišta

Horní lišta okna hlavního menu obsahuje následující možnosti a s nimi související činnosti:

Volby:

¨ v případě, že má uživatel u některých činností nastavenu tzv. horkou klávesu pro spuštění (pravý klik na názvu činnosti – vlastnosti), zobrazují se tyto činnosti jako seznam pod menu Volby v hlavním menu

¨ aktivace pracovní plochy – v případě, že má uživatel aktivovanou některou z činností a okno má „shozeno“ na dolní liště PC a pracuje s oknem hlavního menu, tak po spuštění této činnosti se mu automaticky aktivuje daná činnost z dolní lišty PC.

¨ zablokovat systém BM – slouží k ochraně systému při přihlášení pod svým uživatelským heslem, resp. zabraňuje tomu, aby jiný uživatel zapsal do systému cokoliv pod „mým“ heslem.

¨ umístění okna menu programu – tato volba umožňuje zapamatování pozice okna hlavního menu individuálně pro každého uživatele systému. Při aktivaci této volby se zobrazí překryvný seznam, z něhož je možno zvolit:

- uchovat pro příští spuštění programu – okno hlavního menu se při příštím spuštění programu aktuálním uživatelem zobrazí ve stejné pozici a rozměrech, tak jako bylo při ukončení programu IS BM

- obnovit výchozí pro příští spuštění programu – okno hlavního menu se při příštím spuštění programu aktuálním uživatelem zobrazí v pozici a rozměrech tak, jak je určeno programem IS BM

¨ skrýt program – při aktivaci této volby se celý program IS BM (tzn. všechna spouštěná okna, hlavní menu apod.) skryjí na dolní lištu PC, kde je možno program IS BM znovu vyvolat stiskem ikonky „motýl“

¨ skrýt menu – po aktivaci této volby je skryto okno hlavního menu (tato volba je však dostupná pouze v případě nastavení atributu „zobrazovat hlavní menu“ v činnosti Okno úloh jako nezaškrtnuté)

¨ konec programu – ukončuje program (shodné s klávesou Ctrl F4).

Jazyk:

¨ výběr jazyka, kterým na uživatele bude systém „hovořit“ (jazyky, které se zde uživateli nabízejí se definují v Informačním centru – Společné číselníky – Jazyky systému).

Zobrazit:

¨ velké ikony – způsob zobrazení, kdy jednotlivé činnosti jsou zobrazeny vedle sebe a opticky zvýrazněny pomocí velkých ikon u každé činnosti (v tomto zobrazení je možno vkládat novou skupinu hlavního menu a změnit pořadí činností).

¨ malé ikony – jednotlivé činnosti jsou zobrazeny s malými ikonami u každé činnosti. Rozdíl mezi zobrazením malé ikony a seznam je ten, že při zobrazení malé ikony si uživatel může metodou „táhni a drž“ rozmístit činnosti libovolně po okně hlavního menu.

¨ seznam – jednotlivé činnosti jsou zobrazeny s malými ikonami u každé činnosti.

¨ detaily – přehled činností, které kromě malé ikony a názvu ještě u sebe mají vždy jednoduchý a stručný popis činnosti.

¨ strom činností – způsob zobrazení, kdy uživatel k pohybu po jednotlivých činnostech může využívat „rozbalovací znaménko plus“, tzn. pokud některá činnost má před názvem znaménko „plus“, znamená to, že obsahuje ještě další činnosti, které se dají z této činnosti aktivovat.

Menu:

¨ otevřít menu – uživateli se po aktivaci této činnosti zobrazí okno s „deklarovanými menu“, kde má možnost sledovat „strom“ všech dosud vytvořených menu a v případě potřeby si i vytvořit menu vlastní (odvozením z vybrané definice menu)

¨ uložit menu – uživatel má možnost aktivací této činnosti si uložit své vytvořené menu (nebo uložit jakékoliv provedené drobné změny, které si ve svém menu vytvořil)

Nápověda:

¨ obsahuje informace o aplikaci Bílý Motýl (verze, datum generování, uživatel apod.) a o obsahu nápovědy (zobrazuje se soubor s tématy nápovědy)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.12.2008


Pojem - Hlavní menu – panel nástrojů

Panel nástrojů hlavního menu obsahuje následující ikony:

¨ přejít do jiné složky – tato volba je aktivní jen při zobrazení typu velké ikony, malé ikony a seznam. Uživateli se zde ve formě překryvného seznamu ukazuje jeho pohyb v činnostech hlavního menu a výběrem určité činnosti v tomto překryvném seznamu má možnost ji rovnou aktivovat.

¨ úroveň výš – při stisku této ikony je uživatel vrácen o úroveň výš, tzn. do nadřazené činnosti (pokud se např. nachází v činnosti Typy a řady a použije tuto ikonu, systém ho vrátí na činnost Informační centrum). Tato volba je aktivní jen při zobrazení typu velké ikony, malé ikony a seznam.

¨ zobrazení ikon – ikony, pomocí kterých si uživatel může zvolit způsob zobrazení činností hlavního menu (velké ikony, malé ikony, seznam, detaily, strom činností).

¨ zobrazovat skryté činnosti – po stisku této ikony se uživateli v hlavním menu zobrazí i ty činnosti, které mají ve svých vlastnostech (po stisku pravého tlačítka myši) nastaven příznak „skrytá“.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Hlavní proces

Je to fyzický proces, který má oproti ostatním fyzickým procesům tyto vlastnosti:

¨ jsou k němu vztaženy saldokontní hodnoty procesu,

¨ jeho identifikace se předplňuje jako IDP v události účetnictví,

¨ jeho identifikace se předplňuje jako identifikace zálohy (záloha) v události záloh,

¨ lze jej užít v definici druhu hodnot, zda daný druh operace aktualizuje danou hodnotu v daném hlavním procesu,

¨ operace obsažené v hlavním procesu je možno vytisknout na dokladu pomocí prezentace procesů, pokud není zaškrtnutý atribut „operace z procesu“ (je-li zaškrtnutý tisknou se jen z daného procesu).

Hlavním se stal díky tomu, že byl založen některým z těchto způsobů:

¨ spuštěním z menu NOVÝ PROCES,

¨ napojením na zdrojový uzel v diagramu jiného předcházejícího procesu s vlastností „odvozené procesy budou hlavními procesy“, ovšem tato alternativa není z praxe příliš ověřena.

¨ „rozpůlením“ procesu. Po stisku pravého tlačítka myši ve stromu hlavního procesu na daném procesu se jedná o činnost „osamostatnit proces“, která vyřadí vybraný proces z daného nadřízeného procesu a tento osamostatněný proces se stává hlavním procesem a naopak.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.11.2007


Pojem - Horní lišta

Horní lišta je základem každé aktivované činnosti a pro uživatele je dostupná v horní části okna. Při aktivaci každé činnosti má uživatel v okně dostupný formulář činnosti, pak základní panel nástrojů a horní lištu. Zobrazení horní lišty je v každé činnosti stejné, tzn. neměnné. Horní lišta poskytuje uživateli následující položky:

¨ volby

¨ obecné

¨ jazyk

¨ soubor – činnosti, které je možno provádět se souborem (např. zavřít, uložit jako, náhled apod.)

¨ úpravy – činnosti, kterými je možno okna upravovat (např. vybrat vše, kopírovat, vložit, vymazat, vložit objekt apod.)

¨ okno – pod touto záložkou je k dispozici přehled všech aktivních oken, přičemž je možno se přepnout na další okno, vybrané okno je možno skrýt apod.

¨ nápověda – uživateli se po prvním spuštění připraví soubor pro nápovědu, kde má pak možnost hledat přímo v rejstříku nebo využít záložky najít, která najde všechny odkazy na zadaný řetězec

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.11.2007


Pojem - Hrubá mzda

Hrubá mzda = pevná složka mzdy + pohyblivá složka mzdy + náhrady mzdy

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 29.02.2008


Pojem - HTTP

HTTP (Hypertext Transfer Protocol) je internetový protokol určený pro výměnu hypertextových dokumentů ve formátu HTML. Používá obvykle port TCP/80, verze 1.1 protokolu je definována v RFC 2616. Tento protokol je spolu s elektronickou poštou tím nejvíce používaným a zasloužil se o obrovský rozmach internetu v posledních letech.

V současné době je používán i pro přenos dalších informací. Pomocí rozšíření MIME umí přenášet jakýkoli soubor (podobně jako XML pro tzv. webové služby (spouštění vzdálených aplikací) a pomocí aplikačních bran zpřístupňuje i další protokoly, jako je např. FTP nebo SMTP.HTTP používá jako některé další aplikace tzv. jednotný lokátor prostředků (URL, Uniform Resource Locator), který specifikuje jednoznačné umístění nějakého zdroje v Internetu.

Samotný protokol HTTP neumožňuje šifrování ani zabezpečení integrity dat. Pro zabezpečení HTTP se často používá TLS spojení nad TCP. Toto použití je označováno jako HTTPS.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2015


Pojem - Hypertextové odkazy - informační panely

Hypertextové odkazy se uplatňují při vytváření tabulek na stránce informačních panelů.

U každého odkazu se definuje:

¨ hypertext - jednoznačná textová identifikace

¨ název hypertextového odkazu

¨ typ - WEB / Interní BM

¨ kód - kód v jazyce Foxpro, který vrací pro typ WEB URL adresu, jinak vrací kód v jazyce Foxpro vyvolaný při aktivaci hypertextového odkazu na výstupní stránce informačního panelu

¨ uzel - odkaz na uzel informačního panelu - je-li uveden nemá význam uvádět 'kód'

¨ parametry - předané do doplnění příkazu SQL uzlu, kde jsou pozičně reprezentované jako ?_p1, ?_p2 .... (maximální počet parametrů je 14)

¨ atributy - jsou doplňující atributy SQL dotazu podřízeného uzlu, které jsou vkládány do tohoto dotazu přímo za SELECT. Jsou-li uvedeny atributy, potom za posledním musí být uvedena čárka. Např. 'adadsat.ad01adsat, adspoj.ad11jmeno,' nebo 'TOP 200'

¨ from - je doplnění SQL dotazu podřízeného uzlu v jeho části za FROM

¨ where - je doplnění SQL dotazu podřízeného uzlu v jeho části za WHERE

Na stránce informačního panelu je možné vytvářet odkazy, které způsobí vyvolání programu Windows (jiného než internetový prohlížeč) a v něm otevření souboru, který odpovídá celé zobrazené stránce (může to být více tabulek) nebo jednotlivé tabulce zobrazené na stránce.

Při vytváření stránky informačního panelu je dostupná vlastnost řídícího objektu vytváření stránky OUTPUT_FORMAT, která má při vytváření běžné stránky zobrazované v internetovém prohlížeči hodnotu 'prázdný text' a při vytváření stránky určené pro zobrazení v programu Windows obsahuje hodnotu, kterou je tříznaková přípona souboru. Přitom platí, že je-li stránka vytvářena s nastavenou vlastností OUTPUT_FORMAT řídícího objektu, potom do vytvářených tabulek nejsou vkládány hypertextové odkazy, je potlačeno vytváření automatických hlaviček a patiček stránky a po vytvoření stránky je vyvolán program Windows podle uvedené přípony (hodnoty vlastnosti OUTPUT_FORMAT).

Do stránky informačního panelu je možné vkládat hypertextové odkazy, které zajistí vytvoření stránky s nastavenou vlastností řídícího objektu vytváření stránky OUTPUT_FORMAT třemi způsoby:

- v kódu patičky prezentace stránky

- ve vlastnosti POSTTEXT definice uzlu informačního panelu

- hypertextovým odkazem, který je součástí tabulky informačního panelu

K tomuto účelu slouží např. uživatelská knihovna vkládaného kódu USRPAN.

Pro vložení hypertextu s nastavení vlastnosti OUTPUT_FORMAT řídícího objektu přímo do tabulky je třeba vytvořit zvláštní definici hypertextu informačních panelů, která obsahuje kód vracející text 'output_format=<přípona>', kde <přípona> je tříznaková přípona souboru (příklad kódu hypertextu RETURN 'output_format=XLS')

Tímto způsobem bude do stránky vložen hypertext, který převede do programu Windows danou tabulku.

Při vytváření stránky určené pro zobrazení v programu Windows je pro úspěšné uplatnění stylů nutné, aby styly byly přímo obsaženy v souboru předaném programu Windows.

Proto je třeba zasáhnou do popisu stylu v prezentaci stránky informačního panelu a v jeho kódu podmínit v případě, že je nastavena vlastnost OUTPUT_FORMAT řídícího objektu, vložení textu stylů do vytvářené stránky.

Např. s užitím knihovny USRPAN:

<pre>

#SCRIPT

Return vrat_styl(_this)

#INCLUDE USRPAN

</pre>

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 17.12.2008


Pojem - Charakter operace

Určuje, jakým způsobem se budou operace daného druhu vytvářet a co budou obsahovat. Zda se bude jednat pouze o odkazy na události v jiných operacích (dávková, dávková unikátní) nebo zda se bude jednat o nově vytvářené události (běžná).

Pokud je charakter operace běžná, jedná se o operace v praxi nejobvyklejší, ve kterých dochází ke vstupu nových dat, tj. k založení událostí, které mohou aktualizovat hodnoty dle definice druhů hodnot definovaných pro daný druh operace.

Pokud uživatel potřebuje, aby se do jednoho uzlu procesu transformovaly události z operací různých procesů (určité sloučení procesů -> interakce procesů), využije možností, které mu poskytují operace dávkového charakteru.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.11.2007


Pojem - Charakter operace – dávková, dávková unikátní

V operacích dávkového charakteru se shromažďují pouze odkazy na události jiných operací z různých fyzických procesů, tudíž tyto "odkazy" dávkové operace neaktualizují žádné hodnoty (u druhu operace s dávkovým charakterem je nemá smysl definovat) a ani do nich nelze transformovat data. Odkazy dávkovou operací na danou událost je možno používat opakovaně, pouze odkazy dávkovou unikátní nelze opakovaně použít k jedné a téže události (realizovat odkaz různými druhy dávkové unikátní operace nelze).

Např. firma zabývající se rozvozem materiálu. Celý den odváží stovky aut náklad (tzn. stovky vystavených dodacích listů). Za určité období je pak nutno shromáždit za vybraného adresáta všechny jeho dodací listy (odkazy na všechny tyto dodací listy se shromažďují právě v dávkové operaci) a odtud se v procesu transformují na fakturu apod.

Po spuštění dávkové operace není možno použít volbu F3 jako v běžných operacích, protože se nevstupují nová data, tzn., že uživatel si pod volbou Obecné vyvolá činnost „označit události pro dávku“, natáhne se mu přehled jednotlivých událostí, které si podle potřeby označí, stiskne klávesu ESC a teprve tehdy se tyto události transformují a pokračují podle nastaveného procesu.

Můžeme si uvést krátký příklad využití dávkových operací ve firmě BM Servis. Pokud má vystavená faktura konečného zákazníka, který je obsluhován distributorem, současně s touto operací se zapíše operace s nárokem na provizi distributorovi. Takovýchto nároků vznikne během měsíce celá řada. Na konci měsíce zašle distributor fakturu na provizi, kde jednotlivé řádky (položky) korespondují s jednotlivými nároky. Tato přijatá faktura je připojena pomocí procesu, který začíná dávkovou operací k jednotlivým nárokům vzniklých v různých procesech vystavených faktur.

Jedním z úskalí dávkových operací je IDP (identifikátor párování) v účetnictví, který se běžně předplňuje podle hlavního procesu, tak u dávkových operací, přes které jde účetní saldokonto, musí toto obsluha odřídit sama, resp. vyřešit toto speciálním nastavením transformace.

Např. ve zmíněném příkladu se IDP z nároku transformuje do poznámky každé události první operace přijaté faktury a odtud do jednotlivých položek účetní operace přijaté faktury.

Je-li dávková operace používaná na pozadí, pak je číslo procesu (včetně roku) vytvořeno automaticky, a to podle systémového data. Tak se ale může stát, že faktura vytvářená na pozadí z podkladu roku 2006 bude mít číslo procesu roku 2007. Pokud si uživatel přeje fakturovat do roku 2006, vznikne chyba (tento problém však lze implementačně řešit).

Není-li dávková operace používaná na pozadí, lze číslování vyřešit při zápisu dávkové operace pomocí "zaškrtávátka" datum vzniku procesu a zvolit si rok.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Identifikace procesu

Každý fyzický proces má kromě jednoznačné časové identifikace i své jednoznačné uživatelské číslo. Číslo procesu se skládá z roku / identifikace datového úložiště / pořadového čísla (tj. čísla odvozeného od nadefinované číselné řady pro daný rok a druh procesu).

Tímto identifikátorem jsou identifikovány všechny uzly daného procesu, tj. všechny operace i všechny uzly procesu, které představují jakési schránky, do kterých jsou ukládány fyzické procesy, jejichž druh je předepsán uzlem (schránkou).

Identifikace se přiděluje v okamžiku zápisu (založení) první operace procesu tak, že se převezme:

¨ rok z data uvedeného v události, přičemž v činnosti Nastavení programu BM lze určit, které datum je rozhodující (platí pro události komponent s více daty); v procesech, které začínají dávkovou operací, je možné rok operativně určit při zakládání procesu zaškrtnutím volby Vznik procesu k datu a zadáním data (nevyužitím této volby či založením procesu na pozadí je rok odvozen z aktuálního data). V procesech, které začínají operací bez události (ve většině případů proto, že je jejím ukončením aktivována do stavu připravena následující operace) je rok odvozen automaticky z aktuálního data.

¨ datové úložiště z identifikátoru datového úložiště, ke kterému je daný uživatel přihlášen,

¨ pořadové číslo z číselné řady přiřazené druhu procesu, a to první následující za nejvyšším již využitým číslem v dané řadě pro daný rok.

Identifikace procesu se též dále uplatňuje jako:

¨ IDP v účetnictví,

¨ v zálohách,

¨ v platbách (variabilní symbol).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 13.06.2008


Pojem - Identifikátor

Identifikátory (konstanty) v IS BM představují určité numerické nebo znakové označení atributů (např. identifikátor skladu, umístění, artiklu, kategorie apod.). V případě používání identifikátorů v uživatelských nastaveních (např. masky operace) je nutno uživatele upozornit na to, že identifikátory je NUTNO uvádět velkými písmeny (např. druh artiklu nesmí být v masce uveden jako „mat“, ale musí být zapsán ve tvaru „MAT“).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 25.03.2008


Pojem - IDP (identifikace párování)

Identifikace párování slouží pro saldokonto, záznamy v účetním deníku s touto shodnou identifikací párování (IDP) jsou součástí právě jednoho saldokontního případu; pokud je suma těchto záznamů na daném účtu nulová, pak se jedná o případ z hlediska saldokonta vyrovnaný (tj. ukončený)

IDP je primárně předplňováno podle čísla hlavního procesu. Uživatelsky je možno tuto identifikaci měnit, ale pro uživatele to pak znamená, že jakmile změní IDP (při zápisu události do účetního deníku), systém tím ztratí svoji velkou výhodu a to je automatismus a všechny další zákroky v systému, týkající se změněné IDP je nutno provádět ručně, proto pokud to není vysloveně nutné, identifikaci IDP uživateli měnit nedoporučujeme. Zcela vyhovujícím je IDP v případě závazků a pohledávek z dodavatelsko odběratelských vztahů.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.09.2008


Pojem - Ikony oken v programu BM

Při dodání IS BM jsou zároveň dodány i ikony, které prezentují okno hlavního menu a okno hlavního programu IS BM. Program ale zároveň umožňuje v případě potřeby tyto přednastavené ikony změnit:

¨ pro určení ikony okna hlavního menu programu je možné použít Nastavení programu BM v souboru BW.INI Preferences->BMMenuIcon=[soubor ikony]

¨ pro určení ikony hlavního okna programu je možné použít Nastavení programu BM v souboru BW.INI Preferences->BMIcon=[soubor ikony].

IS BM umožňuje definovat externí příkaz, jehož kód má být proveden bezprostředně po každém přihlášení uživatele k programu. Tímto způsobem je spouštěn externí příkaz s PID=STARTU v případě, že není nastaveno v BW.INI Preferences->StartupCode=0. Tuto možnost je možné použít mj. pro změnu vzhledu BM např. příkazem _screen.backcolor=RGB(192,255,192).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.11.2007


Pojem - Implicitní web menu

Jedná se o vlastnost uživatele IS Bílý Motýl, která definuje, jaký prvek web menu (typu: 1.menu) bude definovat strukturu jeho menu, pokud se uživatel přihlásí jako vzdálený uživatel.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Import

Importem se rozumí schopnost informačního systému převzít data z jiného informačního systému nebo programu (např. Excel), čímž vlastně IS BM podporuje komunikaci s jinými IS. Pro každou činnost typu prohlížení seznamu záznamů lze vytvořit definici jaká data a jak mají být importována, tj. definici zdroje dat (např. souborů – ODBC, DBF, TXT, XML, SOAP …) a definici pravidel transformace[1] zdrojových dat na cílová. Přístup k těmto definicím lze chránit přístupovými právy dle druhu importu.

Importy definované nad událostmi lze užít v definici procesního importu. Importy se aktivují z menu Obecné pomocí činnosti „Import/Export dat“ výběrem ze seznamu definic, případně šablonou, v jejíž definici je import užit.

Jako zajímavý se jeví import z vlastních dat (tj. z vlastního IS), čímž lze realizovat určitá dávková zpracování dat.

Uživatel při zakládání importu definuje dvě záložky – vlastní definici importu-exportu a proměnné importu-exportu. Po jejich definici aktivuje činnost konverze atributů a následně si nadefinuje design vstupního formuláře, čili jak se okno importu bude po spuštění jevit uživateli. Jako kontrolu správně nadefinovaného importu může uživatel využít činnosti pod menu Volby (nebo klávesa F7) „prohlížení importovaných dat“.

IS BM dovoluje definovat importy dat, které zpracovávají informace získané prostřednictvím webových služeb. Přitom používá protokol MS SOAP, který musí být na počítači instalován.

V kódu pro import spojení typu XBASE se spojení provádí pomocí COM objektu "MSSOAP.SoapClient" např.:

* deklarace proměnné pro objekt klienta

LOCAL _xsoap

* vytvoření objektu klienta

_xsoap = CREATEOBJECT("MSSOAP.SoapClient")

* inicializace klienta pro použití webové služby

_xsoap.MSSoapInit('http://isbm.bmservis.cz./Webpub/bmwssrv.WSDL', "bmwssrv", "bmwssrvSoapPort")

* deklarace proměnné pro uložení získané informace

LOCAL _buffer

* volání metody služby s parametry

_buffer=_xsoap.getdata('VY0001','UZIVATEL','HESLO',date(),date(),'','',.F.,.F.,.F.,.F.,.F.,.F.,.F.,.F.)

* převod dat předaných ve formátu XML do kurzoru s aliasem DATA

=XMLTOCURSOR(_buffer,'data',0)

[1] Nejedná se o pravidla transformace užívaná ve vazbě mezi uzly diagramu procesu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Import – konverze atributů

Pomocí činnosti konverze atributů uživatel v importu/exportu definuje odkud a kam se jednotlivé atributy importu/exportu mají zapsat. Činnost konverze atributů je pro uživatele dostupná na každé definici importu pod menu Volby nebo po stisku funkční klávesy F5. První záložka dané činnosti je „konverze řádku“, druhá záložka je „konverze atributů“. Z jednoho vstupního řádku může být transformováno žádný, jeden nebo více řádků. Na záložce „konverze řádku“ se definuje:

¨ podmínka – tento atribut rozhoduje o tom zda bude řádek použit. Přitom má pro Import nebo Update význam používat odkazy na atributy otevřených tabulek s aliasem DATA nebo případně další relačně propojené tabulky otevřené podle příkazů "Selekt" definice s druhem spojení XBASE. Pro Export má význam použití atributů s aliasem _EXP_. V atributu podmínka se mohou vyskytovat "proměnné importu" v hranatých závorkách.

¨ primární klíč exportu – tento atribut určuje výraz vyhodnocený při exportu nad cílovými daty. Pokud se v cílových datech vyskytuje záznam se stejnou hodnotou výrazu, potom není exportovaný řádek zapsán.

¨ klíč pro update – tento atribut se používá při update dat, když není nastavena vlastnost "Čas.id."(v definici importu). Obsahuje seznam výstupních atributů oddělených čárkou, které určují záznam, který má být aktualizován.

Na záložce „konverze atributů“ se definuje transformace dat jednotlivých atributů a zadává se:

¨ atribut - určuje výstupní atribut, jehož hodnota bude při importu/exportu/update naplněna vyhodnocením výrazu

¨ obecná platnost – tento atribut definuje na prvém řádku konverze, že daný výraz je platný pro všechny následující řádky, na kterých se potom nemusí uvádět.

¨ výraz - obsahuje výraz v jazyce Foxpro. Ve výrazu se mohou vyskytovat "proměnné importu" v hranatých závorkách. Hodnota získaná vyhodnocením výrazu musí být stejného typu jako "atribut", do kterého bude vložena.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Import – záložka „definice importu/exportu

Definují se zde základní vlastnosti importu a to jsou:

¨ identifikace importu/exportu/update dat - jednoznačně identifikuje v rámci činnosti

¨ název importu/exportu/update dat

¨ druh - druh importu/exportu/update dat – je k němu možno nadefinovat přístupová práva (právo zápis - uživatele má povoleno vytvářet, právo čtení - uživatel má právo spouštět)

¨ spojení - definuje spojení s externím zdrojem dat. Druh spojení může být:

- ODBC

- XBASE

- Text (nemá význam pro export)

¨ import/export/update dat - určuje charakter definice

¨ atribut nabízet - při nastavení Ne nebude import nabízen při vyvolání pro spuštění po volbě z menu Obecné (není aktuální nebo je vyvoláván jiným způsobem např. procesním importem)

¨ selekt - obsahuje definici pro zpřístupnění zdrojových dat importu/update nebo dat do kterých bude exportováno. Pro spojení druhu platí:

- ODBC - příkaz selekt se zapisuje v jazyce SQL, v definici se mohou vyskytovat "proměnné importu" v hranatých závorkách

- XBASE - příkazy se zapisují v jazyce Foxpro - otevírající tabulky musí otevřít tabulku nebo kurzor s aliasem DATA. V definici se mohou vyskytovat "proměnné importu" v hranatých závorkách. %S% v příkazech je nahrazeno obsahem atributu "Spojení OS" uvedeného ve spojení. V příkazech se mohou vyskytovat "proměnné importu" v hranatých závorkách. Je možné v atributu "Selekt" použít přímý kód Foxpro, ve kterém je možné použít všechny možnosti jazyka např. vytváření podprogramů, tříd objektů atd. Takto definovaný kód musí být uveden příkazem "SCRIPT" a může být ukončen příkazem "ENDSCRIPT". Po vyvolání je mu dostupný objekt importu v proměnné _THIS. V kódu je možné uvádět odkazy na knihovny vkládaného kódu (klauzule #INCLUDE).

- TEXT - definice importu z textového souboru

1. řádek název vstupního souboru včetně adresářové cesty (adresář může být definovám %S%)

2. řádek definuje typ textového souboru

a.) TXT [<point>] [<výběrová podmínka>] import z textového souboru s pevnou délkou věty

<point> - znak tečka nebo čárka určuje znak desetinné tečky v numerických hodnotách

<výběrová podmínka> - logický výraz pro výběr dat

b.) část příkazu APPEND FROM jazyka Foxpro

[[TYPE] [DELIMITED [WITH Delimiter | WITH BLANK | WITH TAB | WITH

CHARACTER Delimiter] | DIF | FW2 | MOD | PDOX | RPD |

SDF | SYLK | WK1 | WK3 | WKS | WR1 | WRK | CSV | XLS | XL5

[SHEET cSheetName] | XL8 [SHEET cSheetName]]] [AS nCodePage]

[FOR lExpression]

3. řádek definující strukturu souboru, který bude použit pro import dat

řádky uvedené znakem * jsou chápány jako komentáře

pro typ textového souboru ad a.)

<atribut> <typ>[<rozměr>] = <výraz>

pro typ textového souboru ad b.)

<atribut> <typ>[<rozměr>]

<atribut> - identifikátor atributu v konvencích Foxpro max.délka 10

<typ> - typ atributu (C - znakový atribut, D - datumový atribut, T - datum-časový atribut, N - numerický atribut, M - memo atribut (text))

<rozměr> - musí být uveden pro atributy typu C a N

uvádí se v kulatých závorkách např. C(16) nebo N(10) nebo N(20,4)

<výraz> - výraz v jazyce Foxpro, který je vyhodnocován pro řádek textového souboru. Řádek textového souboru je ve výrazu reprezentován textem ###

např. SUBSTR(###,10,5) nebo VAL(SUBSTR(###,14,4))

Příklady:

%s%\vstup.txt

TXT . TRIM(firma)<>'-'

firma C(40) = SUBSTR(###,15,40)

ico C(10) = SUBSTR(###,12,10)

obrat N(12,2) = VAL(SUBSTR(###,58,12))

nebo

%s%\vstup.xls

XL8 SHEET 'Seznam firem' FOR TRIM(firma)<>'-'

firma C(40)

ico C(10)

obrat N(12,2)

¨ příkazy - příkazy v jazyce Foxpro provedené po exportu dat (nevyužívá se pro import a update)

¨ init - určuje příkaz vyvolaný ještě před zahájením importu. Předpokládá se použití některých činností, které vracejí v pracovním souboru seznam označených záznamů jako třeba adresář. V okamžiku vyvolání příkazu, je v proměnné "_o.wrk2" uloženo jméno dosud neexistujícího souboru, který bude vytvořen příkazem. V okamžiku vyvolání kódu popsaného v atributu "Selekt" importu je toto jméno dostupné "this.wrk2". Takto definovaný import byl použit v aplikaci „nejmenované firmy“ a zde je vysvětlení jeho definice:

a.) Init obsahuje

DO FORM ad0137 WITH this.identif,'!',_o.wrk2,'',''

- znamená vyvolání formuláře "Adresář" před zahájením importu, tak aby zablokoval aktivaci formuláře, ze kterého je import vyvolán a vrátil v souboru

definovaného obsahem proměnné "_o.wrk2" označené adresáty

b.) obsah Selekt

*

select 0

create cursor data (ad01id c(6),sp61id c(3),sp60id c(13))

if !empty(this.wrk2);append from (this.wrk2)

do nkprcpre with this._thisform

*

- vytvoření kurzoru (kurzor=pracovní soubor, který je automaticky smazán po jeho uzavření) se strukturou identifikace adresáta a identifikace artiklu

- v případě, že údaj o názvu pracovního souboru není prázný doplní se do kurzoru

seznam označených adresátů (název může být prázdný, je-li kód vyvolán v okamžiku přípravy importu např. "Prohlížení importovaných dat" nebo "Předplnění hodnot")

- vyvolání programu "nkprcpre", který doplní do záznamů identifikaci artiklu a k tomu využije informace formuláře, do kterého je prováděn import (parametr this._thisform)

¨ Čas.id. - definuje výraz jehož hodnota bude vložena do jednoznačné časové identifikace objektu (má význam pouze při importu objektů). Jestliže při importu již existuje v tabulce záznam se stejnou časovou identifikací, potom není importován. Při update slouží tato definice jako výraz pro určení záznamu, který má být aktualizován.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Import – záložka „proměnné importu/exportu

Definují se zde proměnné, které může uživatel vstupovat před zahájením importu, exportu nebo update dat a proměnné, které jsou odvozené ze vstupovaných hodnot. Jednotlivé proměnné se definují stejným způsobem jako u obecných výběrů, šablon nebo volných karet. Za zmínku stojí atribut „naplnění“, který může nabývat těchto hodnot:

¨ vstup - hodnota proměnné je vstupována uživatelem

¨ výpočet - hodnota proměnné je odvozena podle hodnot proměnných definovaných s nižším pořadím. Hodnota proměnné je vyhodnocena na základě "Výrazu proměnné", který v sobě obsahuje odkazy na proměnné uvedené v hranatých závorkách. Používá se např. pro sestavení SQL dotazu s operátorem LIKE. Např.:

- proměnná v pořadí 10 je vstupována uživatelem, je znaková a má identifikátor FIRMA

- proměnná v pořadí 20 s identifikátorem FIRMA0 je vypočítavaná s hodnotou určenou výrazem TRIM([FIRMA])+'%'. Potom je možné v SQL dotazu zadat ..... ADADSAT.ad01adsat LIKE [FIRMA0] ...

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Individuální odpis

Tuto činnost (činnost Odpisovaný majetek – záložka Individuální odpis) lze využít pro výpočet mimořádného odpisu podle par. 30a Zákona o dani z příjmu ve znění platném od 20.7.2009.

K tomuto výpočtu je nutné dodržet několik zásad:

¨ u způsobu odpisování musí být zvolen „individuální odpis“

¨ musí být nastavena odpisová skupina (1 nebo 2)

¨ odpisovaný majetek musí být zařazen a uvedena jeho vstupní cena

Poté je možno výpočet individuálních odpisů provést:

¨ ručně – od data zařazení, případně zahájení daňového odpisu vyplnit po měsících jednotlivé částky odpisu. Při výpočtu ročních daňových odpisů šablona Daňový odpis kontroluje sumu měsíčních hodnot na hodnotu vstupní ceny. Nesoulad ohlásí a výpočet neprovede.

¨ automaticky – pomocí importu, který je součástí doplňující vlastnosti formuláře „Import individuálního odpisu“. Tento import se aktivuje stiskem příslušného tlačítka na základní nabídce (menu Obecné – Nabídky – Základní), následně automaticky předplní dané odpisy a uživatel pak tyto hodnoty zapíše (ikona disketa). Jak z výše uvedeného vyplývá, pro automatický výpočet je nutno mít v systému k dispozici import a danou doplňující vlastnost formuláře (obojí může být dodáno formou balíčku nebo se obraťte přímo na svého implementátora).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 11.12.2009


Pojem - Informace stromu pro druh operace

Jedná se o možnost zapsat si pomocí jednotlivých výrazů způsob zobrazení událostí ve stromu hlavního procesu. Tím, že si uživatel vytvoří tyto informace stromu pro druh operace, v podstatě určuje, jak se po vyvolání stromu hlavního procesu budou zobrazovat události operace po stisku pravého tlačítka myši na operaci.

Tuto činnost má uživatel dostupnou u druhu operace v menu Volby. Po stisku klávesy F3 jsou u druhu operací některých komponent tyto informace předdefinované, jinde je musí uživatel vytvořit sám.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 26.09.2007


Pojem - Informační centrum (IC)

Informační centrum je ta logická část IS, která je fakticky společná všem komponentám. Základní funkcí IC je zajistit a řídit komunikaci (výměnu informací) komponent, případně poskytovat informační schopnost (odpověď na otázky týkající se současně více komponent). Mezi nejvýznamnější prvky IC patří:

¨ definice druhů procesů a správa fyzických procesů

¨ statistické informace včetně selektorů a druhů hodnot,

¨ definice a správa výkazů

¨ správa globálních objektů typu AAA

¨ vazby objektů

¨ uživatelé, skupiny a jejich práva

¨ některé číselníky (MJ, jazyky, ceník, ...)

¨ slovník dat

¨ definice web

¨ ...

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Informační panely

Informační panel je nástroj, který slouží k přehlednému zobrazení úkolů uživatele vyplývajících z informací uložených v systému. Obsah informačního panelu je volně definovatelný a je ho možné přizpůsobit individuálním potřebám jednotlivých uživatelů. Uživateli se mohou na jediné webové stránce zobrazovat jeho úkoly z různých oblastí IS a z této stránky potom může přímo vyvolávat potřebné funkce a činnosti aktivací hypertextového odkazu.

Informační panely se nacházejí v hlavním menu v činnosti Informační centrum. Po rozbalení tohoto menu má uživatel k dispozici tyto činnosti:

¨ Informační panely ke spuštění – přímo výběr jednotlivých nadefinovaných panelů ke spuštění

¨ Definice uzlů informačních panelů – vlastní definice jednotlivých informačních panelů

¨ Editor uzlů informačních panelů

¨ Druhy uzlů informačních panelů

¨ Prezentace stránek informačních panelů – definice vzhledu stránek informačního panelu

¨ Hypertextové odkazy – předdefinované hypertextové odkazy, které umožňují spouštění jiných uzlů s parametry nebo spouštění skriptů

Po stisku ikonky „Zpět“ pravým tlačítkem myši se program automaticky přepne do hlavního okna programu.

Při tvorbě definice informačních panelů lze použít technologii Materialized View. Ta umožňuje např. prezentovat manažerské informace na informačních panelech novou metodou, která byla vyvinuta a v praxi nasazena pro vyhodnocování marketingových kampaní. Díky použité technologii MATERIALIZED VIEW se standardizovanou strukturou a navazujícího agregování GROUP BY CUBE se dosahuje okamžité odezvy.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 18.09.2014


Pojem - Informační schopnost

Informační schopností se rozumí schopnost IS odpovědět na otázky uživatele, tj. je vymezena množinou těchto zodpověditelných otázek. Informační schopnost vyplývá z datového modelu IS a je základním klíčem při rozhodování o pořízení daného IS v rámci výběrových řízení.

Informační schopnost je uživateli prezentována pomocí výstupů.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Informační systém (IS)

Pojmem informační systém rozumíme v obecné rovině soubor nehmotných věcí v elektronické podobě, který se skládá z aplikačního software (programový kód), definičních dat, dokumentace a aplikačních dat (na data uživ.). IS svou informační schopností podporuje činnost uživatele. V rámci této dokumentace se pojmem IS obvykle rozumí informační systém Bílý Motýl.

Poskytovaný IS neobsahuje aplikační data (data už.) a definiční data (def. data) obsahuje jen okrajově, tj. jedná se o IS připravený k zahájení implementace. Takovýto IS odpovídá systému, který je prvně instalován u uživatele po jeho pořízení nebo který je expedován z firmy BM Servis na distribučním médiu.

Po stránce logické architektury se IS skládá z informačního centra a komponent, a tomu odpovídá i uspořádání funkcí (činností) IS.

Po stránce určité kategorizace IS jej lze rozdělit na:

- manažerský IS (EIS, MIS, BI,...) - zaměřeno na analýzu dat

- transakční procesní operativní IS (ERP, SCM, CRM, ...) - zaměřeno na vstup dat a jejich přímé on-line využití

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Informační technologie (IT)

Pojmem informační technologie rozumíme soubor všech věcí, které slouží k podpoře podnikání informacemi. Zahrnuje: hardware a jeho propojení, komunikační a sdělovací prostředky, systémový a síťový software, informační systémy, vyškolený personál, ...

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Inicializace

Pojem inicializace je možno vysvětlit jako nastavení počátečních hodnot. V současné době je inicializace k dispozici pouze v komponentě odpisovaný majetek a měla by být dostupná pouze správci systému.

Inicializaci je nutno provést vždy před zahájením práce s komponentou odpisovaného majetku. Je provedena k datu, který uživatel zadá a od tohoto data je možno zadávat pohyby odpisovaného majetku a počítat měsíční odpisy (tzn. inicializací jsou zrušeny všechny dosud provedené pohyby a na kartách je vynulován atribut cena pořizovací, cena zůstatková a odepsáno v roce – např. uživatel měl zkušební provoz na seznámení uživatelů s komponentou, po jeho ukončení se provede inicializace a je možno provozovat systém „naostro“).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.10.2007


Pojem - Inicializace hesla

Tuto funkci využije správce systému v okamžiku, kdy si některý z uživatelů změní své přístupové heslo a pak se stane, že toto změněné heslo „zapomene“. Správce systému si aktivuje činnost „uživatelé programu“ (menu SYSTÉM), umístí kurzor na daného uživatele a z menu Volby aktivuje činnost „inicializace hesla“ (funkční klávesa F7). Na dotaz „opravdu si přejete inicializovat heslo uživatele xxx?“ zvolí možnost Ano a tím pádem je u tohoto uživatele znovu jako vstupní heslo platné to, které je uvedeno v atributu „počáteční heslo“ (v případě, že tam není uvedeno žádné, je nutno tam nějaké vstupní heslo zadat). Uživatel se následně tímto heslem přihlásí a poté si ho může v případě potřeby změnit.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 21.11.2007


Pojem - Interakce procesů

Jedná se o komunikaci procesů, jejich sdílení, vyměňování dat. Interakce má významný vliv na chování procesů, a tím i zprostředkovaně na jejich modelování. Příkladem interakce mohou být:

¨ dávkové operace

¨ dynamická spojení

¨ uzel typu proces

¨ vytvořená data - hodnota k alokaci, účetní saldo, zálohy, ...

¨ import z vlastních dat

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 21.11.2007


Pojem - Jazyk

Jedná se o určení jazyka, kterým „bude IS na uživatele hovořit“. Implicitně je nastaveno „neurčený“, v případě potřeby je možno si jazyk změnit. Volba jazyka systému se provádí v horní liště hlavního menu – záložka Jazyk. Definice jazyků, které mají být obsaženy v IS se provádí v činnosti Informační centrum – Selektory a číselníky – Jazyky systému. Pokud si uživatel změní jazyk systému, musí si názvy jednotlivých atributů do zvoleného jazyka přeložit. K tomuto účelu pak slouží činnost režim oprav, která je dostupná vždy v horní liště okna každé činnosti pod volbou Jazyk.

V případě, že si uživatel změní v hlavním menu volbu jazyka, je systémem aktivována funkce „znovu načíst“ s výběrem (WHERE v SELECT) na zvolený jazyk a pokud existující data nejsou do vybraného jazyku přeložena, nezobrazí se.

Informační systém BM je vytvořen v jazyce neurčeném, takže je možné si jej uživatelsky přizpůsobit do češtiny. Tímto způsobem lze uživatelsky rozšířit množinu prvků danou programovým kódem v překryvných seznamech.

Pro zvýšení kvality užívání IS v cizím jazyce je vhodné používat operativní systém a FoxPro ve stejném cizím jazyce.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 21.02.2008


Pojem - Jednoznačná časová identifikace

Každý záznam (událost, operace, proces apod.) v IS BM má svoji jednoznačnou časovou identifikaci. Znamená to, že u každého záznamu jsou dostupné informace o roku, měsíci, dnu, hodině, minutě a sekundě založení.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 21.11.2007


Pojem - Kalendář

Kalendář je možno vyvolat po stisku pravého tlačítka myši na každé datumové položce kdekoliv v systému. Uživateli se spustí okno, kde je zobrazen právě aktuální měsíc a aktuální datum (tzn. „dnešní“ datum) je šedivé a v červeném kroužku. Šipky zpět a vpřed umožňují uživateli listovat jednotlivými měsíci i několik let nazpět i dopředu. Dvojklik na vybraném datu způsobí jeho přenesení zpět do datumového atributu aktivní činnosti (tzn. do činnosti, z níž byl kalendář vyvolán).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Kalendář FPD

Uživatel má jednak k dispozici nabídku stávajících kalendářů a jednak má možnost si nový kalendář založit a vygenerovat si k němu příslušný fond pracovní doby (FPD). Kalendář slouží pro kontrolu počtu zadaných hodin, nehlídá práci ve svátek a přesčasy.

Pokud uživatel zadává nový kalendář, postupuje tímto způsobem. Pod záložkou kalendář založí nový kalendář (včetně denního úvazku). V případě, že organizace používá denní kalendáře (nastaví se v činnosti Parametry), uživatel určí typ denního kalendáře – Pravidelná pracovní doba. Typ „pravidelná pracovní doba“ znamená, že každý den má stejný počet hodin. Typ „zvlášť ke každému dni“ znamená, že jednotlivé dny mají různý počet hodin (nastavuje se ručně). Pro denní kalendáře je na záložce FPD – po dnech k dispozici nový atribut „typ dne“ (za atributem datum). Uživatel má možnost vybrat si z překryvného seznamu hodnoty: -, pracovní, sobota, neděle, svátek, nepracovní. Typ „nepracovní“ použije uživatel u dne, který není pracovním dnem pracovníka, ale není to ani sobota nebo neděle.

Při používání denních kalendářů existují tedy dvě možnosti:

¨ pravidelný kalendář – nemění se v něm úvazek jednotlivých dnů, tj. pracovní doba připadající na jeden den je vždy shodná, např. 8h

¨ nepravidelný kalendář – úvazek se určuje ke každému dni zvlášť, tzn. že pracovní doba připadající na jeden den může být jiná než v jiný den tohoto kalendáře

Ke každému kalendáři náleží atribut aktuální Ano/Ne. Toto se využije např. při zadávání pracovního poměru.

Používání denních kalendářů typu „ke každému dni zvlášť“ může mít několik logických úskalí:

¨ pokud u svých pracovníků používáte každý měsíc některé pravidelné příjmy (přes činnost Pravidelné příjmy), pak se k použití u pracovníka s tímto kalendářem nehodí možnosti „dopočíst do FPD dle hodin“ a „součet odpracovaných“. Může dojít k chybnému dopočtení počtu pracovních dnů.

¨ při uzávěrce mezd se předpokládá, že pracovník s tímto kalendářem nemá pravidelný kalendář a tím pádem se mu mění úvazek

¨ v Parametrech doporučujeme používat u atributu „způsob výpočtu denního průměru“ možnost „dle odpracovaných dnů“ a nikoliv „dle úvazku“ (je zde hlášení do Protokolu). Pokud přesto chcete používat v Parametrech „způsob výpočtu denního průměru“ s možností „dle úvazku“, pak pracovníci, kteří mají tento kalendář budou zpracováni tak, jako by bylo nastaveno „dle odpracovaných dnů“.

¨ je nutno nastavit správně význam dne, který je označen jako „svátek“. Svátky, které jsou propláceny mzdovou položkou „náhrada mzdy za svátek“ budou v případě nemoci propláceny mzdovou položkou „náhrada mzdy za nemoc“. Proto je nutné tyto dny mít správně v kalendáři označené jako svátky. Naopak svátky, které nejsou propláceny mzdovou položkou „náhrada mzdy za svátek“ (tzn. jsou to skutečně nepracovní dny daného pracovníka) nebudou v případě nemoci propláceny mzdovou položkou „náhrada mzdy za nemoc“. Proto je nutno mít tyto dny v kalendáři označené jako sobota, neděle nebo – nově – nepracovní. Označení „svátek“ platí tedy pouze pro ty dny, které připadají na pracovníkův placený den (tzn. pracuje nebo pobírá náhradu mzdy za svátek). Pro svátky je zaveden číselník „Číselník svátků“. Zde je možno si nastavit dny, které jsou svátky. Obsahuje datum svátku, jeho popis a komentář. Slouží ke generování denních kalendářů. Při generování denních kalendářů se poté program ptá, zda chcete označit pracovní dny jako svátky (podle číselníku svátků).

U jiných kalendářů než „zvlášť ke každému dni“ se spustí činnost "generuj FPD" (menu volby). Program poté spočítá FPD k danému kalendáři. Lze vygenerovat FPD:

¨ po měsících

¨ po dnech – možnost označit pracovní dny jako svátky

¨ s periodou po dnech - vygeneruje nový fond prac. doby po dnech pro zadané období podle zadané periody a hodin v periodě, tzn. zadává se období od – do, perioda střídání pracovních a nepracovních dnů a hodiny příslušející periodě. Perioda se uvádí pomocí znaků P(prac. den) a N (neprac. den), např. PPPPPNN – po 5-ti pracovních dnech následují 2 dny nepracovní. Hodiny se uvádí oddělené znakem /, používá se desetinná čárka (příklad: 8/8/12/12/7,5/7,5/0/0/0/). Perioda musí odpovídat Hodinám, tj. pro každý den v periodě musí být určen počet hodin. Na dotaz je zde možnost označit pracovní dny jako svátky (podle číselníku svátků).

¨ podle číselníků svátků – do již vygenerovaného denního kalendáře označí pracovní dny jako svátky

¨ veškerý FPD po dnech – možnost označit pracovní dny jako svátky

¨ veškerý FPD po měsících

Na FPD se při výpočtu mezd porovnává, zda má pracovník zadán plný počet hodin. Po zadání mzdových položek (dovolená, nemoc,...), lze podle FPD dopočítávat hodiny implicitní práce do plně odpracované doby v měsíci.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 07.11.2013


Pojem - Kalendáře směn výroby

Kalendáře v komponentě výroby definují použitelný čas (období plánovaného či očekávaného výrobního úkolu) dané linky a jsou využity zejména pro:

¨ automatické plánování (generování) výrobních úkolů

¨ zobrazení harmonogramu (s jeho následnou aplikací „ručního“ plánování)

Tato činnost tedy umožňuje uživateli definovat, opravovat, popřípadě i rušit jednotlivé kalendáře směn výroby. U každého kalendáře jsou k dispozici tyto informace:

¨ identifikace a název kalendáře

¨ úroveň – pro danou linku v daném období může být definováno libovolné množství kalendářů, podle kterých se v okamžiku aplikace kalendáře vyhodnotí její použitelný čas způsobem, kdy vyšší úroveň „přebíjí“ nižší úroveň (pokud se uživateli podaří chybně zadat, že jedna linka v jenom čase má platné 2 či více kalendářů se shodnou úrovní, je o tom uživatel informován při spuštění relevantních činností (přehled kalendářů, generování úkolů, ...) systémovou hláškou: „Kalendář nelze aplikovat“. Úroveň kalendáře je v okamžiku jeho vstupu (po stisku klávesy F3) automaticky předplněna hodnotou o 10 vyšší než dosud nejvyšší užitá úroveň (toto neplatí pro kalendáře výjimek).

¨ všeobecný kalendář – kalendář definovaný jako všeobecný je automaticky platný pro každou nově zařazenou linku

Specifická je aplikace kalendářů s identifikátorem, který je shodný s identifikátorem linky – tento kalendář se pak vytváří automaticky (pokud již neexistuje) s nastavenou nejvyšší úrovní při definici výjimek linky. Kalendář výjimek linky se zobrazuje modře (je nutno si dát pozor, aby nebyl založen kalendář s id jako linka, ale byl míněn na jiné použití). Tyto výjimky jsou dostupné i na záložce činnosti s přehledem linek.

Na záložce „Dny kalendáře“ se definují elementy kalendáře – jeho směny. K předplnění směn lze užít funkci, která je následně automaticky vygeneruje (menu Volby, činnost „předplnit směny“). V případě potřeby je k dispozici i funkce pro zrušení všech vybraných (na záložce dostupných) směn (menu Volby, činnost „zrušit zobrazené dny kalendáře“).

Na záložce „Přidělené linky“ se definuje, pro které linky a v kterém období je kalendář platný. Lze použít funkci z menu Volby („přidělit všechny linky ke kalendáři“), která nadefinuje všechny linky na „nekonečné“ období. V případě, že se jedná o všeobecný kalendář, je sem automaticky zařazena každá nově založená linka. V případě, že se jedná o kalendář výjimek (shodné identifikátory), není linka na záložce uváděna (platí implicitně).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 16.04.2008


Pojem - Kalkulační jednice

Kalkulační jednice definuje množství výrobku obsažené v jedné kalkulační jednici. Podle této nadefinované kalkulační jednice se v činnosti „přehled TP k datu rozpracované na KJ“ přepočítává množství vstupů a výstupů. Kalkulační jednice různá od množství „1“ se používá u artiklů výroby, kde se vyrábí množství v řádu tisíců.

Kalkulační jednice je tedy určitý výkon (výrobek, služba) vymezený měrnou jednotkou (ks, kg, m, hod, ... ) používaný jako elementární prvek kalkulace.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 24.01.2008


Pojem - Kalkulační vzorec

Tato činnost umožňuje uživateli nadefinovat si jednotlivé kalkulační vzorce nebo proměnné. Kalkulační vzorec se pak následně přiřazuje při definici referenčního artiklu a v podstatě určuje způsob ocenění. U každého kalkulačního vzorce se zadává:

¨ identifikace a název

¨ typ – může nabývat hodnot kalkulační vzorec nebo proměnná v kalkulačním vzorci. Kalkulační vzorec u referenčního artiklu vypovídá o tom, podle jakého vzorce se bude vypočítávat ocenění výstupu referenčního artiklu. Proměnná kalkulačního vzorce u vztaženého artiklu nebo u pracovních výkonů vypovídá o tom, jakým způsobem bude vstup zahrnut do výpočtu ocenění výstupu refer. artiklu dle kalkulačního vzorce.

Na záložce „výrazy kalkulačního vzorce“ se definují vlastní výrazy, podle kterých se pak počítá. U každého výrazu se zadává:

¨ platnost od – do

¨ linka – číslo výrobní linky (jen v případě, že přímo souvisí s výrazem daného kalkulačního vzorce)

¨ výraz

¨ poznámka

Výraz kalkulačního vzorce může vypadat např. takto:

([P1] + [P2] - [P3]) * 1,3 kde platí, že:

P1= vstupní materiál (vztažené artikly)

P2 = pracovní výkony

P3 = dále použitelný odpad

násobení 1,3 = režijní náklady

Kalkulační vzorec obsahuje:

+ přímý materiál

+ přímé mzdy

+ ostatní přímé náklady

+ výrobní (provozní) režie (např. odpisy strojů, energie atd.)

VLASTNÍ NÁKLADY VÝROBY

+ správní režie (např. řízení podniku jako celku, odpisy správních budov)

VLASTNÍ NÁKLADY VÝKONU

+ odbytové náklady (např. skladování, propagace, expedice)

ÚPLNÉ VLASTNÍ NÁKLADY VÝKONU

+ zisk (ztráta)

CENA VÝKONU

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 24.01.2008


Pojem - Kalkulátor

Je dostupný v každém okně pod menu Volby, po stisku klávesy Ctrl K nebo stisku pravého tlačítka myši na numerickém atributu. Uživateli se zobrazí kalkulátor, který je vzhledem velmi podobný klasické kalkulačce. Samozřejmě je možno provádět běžné početní úkony jako sčítat, odčítat, násobit, dělit. První aktivní pole zobrazuje zapsané číslice nebo výraz, druhé aktivní pole zobrazuje počet desetinných míst, na které se má výsledné číslo zaokrouhlovat.

Pomocí těchto tlačítek dochází k automatickému nakopírování vypočteného výsledku do schránky (tzv. clipboardu), tzn. je suplována funkce Ctrl+C (v událostech je pak možno na daném atributu stisknout pouze Ctrl+V a výsledek je automaticky přenesen). Jsou to tato tlačítka:

¨ Copy

¨ pravý klik na tlačítku ‘=’

¨ pravý klid na tlačítku ‘SUM’

¨ výpočet provedený klávesou Ctrl+Enter

Přes tlačítko Menu (nebo po stisku F2) je možno se přes kalkulátor napojit do aktivního okna a uživateli se zobrazí seznam výrazů, se kterými mu dané okno činnosti umožňuje počítat. Tyto výrazy může uživatel použít libovolně podle svých představ, tzn. může je sčítat, odčítat, násobit, dělit či po stisku tlačítka SUM nakonec získat jejich celkovou sumu. Na každém okně je nabídka těchto výrazů různá vzhledem k tomu, jaká data právě aktivní okno uživateli poskytuje. Vynulování řádku se provede pomocí tlačítka C nebo stiskem klávesy Ctrl W, tlačítko BS zastupuje klávesu Backspace. Po vybrání výrazu se tento výraz předplní do aktivního okna kalkulátoru – pak je nutno zvolit potřebný početní úkon (např. +, SUM nebo v případě = systém zobrazí částku tohoto výrazu, která odpovídá právě aktivnímu záznamu v okně, tedy tomu záznamu, na kterém je umístěn kurzor). Všechny použité početní úkony se uživateli zobrazují v překryvném seznamu aktivního okna kalkulátoru.

Kalkulátor si pamatuje počet desetin výpočtu a posledních 100 mezivýsledků v překryvném seznamu v rámci aktuálního spuštění BM. Do překryvného seznamu mezivýsledků je možné vkládat poznámky, přičemž za poznámku se považuje text uvedený znakem ‘*’. V překryvném seznamu mezivýsledků je možné odstranit záznam klávesou Ctrl+Delete.

V rámci aktuálního spuštění BM si kalkulátor pamatuje svoji pozici na obrazovce.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.05.2009


Pojem - Karta odpisovaného majetku

Tato činnost poskytuje uživateli možnost zakládat, aktualizovat a rušit jednotlivé karty investičního majetku. U jednotlivých karet investičního majetku se zadává:

¨ druh, identifikace a název odpisovaného majetku

¨ třída SKP

¨ datum zařazení – doplní se automaticky z první události typu příjem a zůstává neměnný bez ohledu na následující události stejného typu (není uživatelsky modifikovatelné, pouze pomocí událostí)

¨ datum vyřazení – doplní se automaticky z události typu výdej (není uživatelsky modifikovatelné, pouze pomocí událostí)

¨ dat. zaháj. UO – datum zahájení účetních odpisů – vyplní se automaticky shodně s datem zařazení. Toto datum je možno podle potřeb uživatele ručně změnit (posunout vpřed), např. pro odpisy sadu je nutné posunout datum odepisování zhruba až po třech letech od data zařazení.

¨ dat. zaháj. DO – datum zahájení daňových odpisů - vyplní se automaticky shodně s datem zařazení. Toto datum je možno podle potřeb uživatele ručně změnit (posunout vpřed).

¨ druh inv. maj. – výběr druhu investičního majetku z překryvného seznamu

¨ jednotlivé selektory

Za zmínku však stojí záložky "účetní" a "daňový" odpis, které jsou popsány v samostatném helpu. Pod záložkou daňový odpis si vysvětlíme položku "soubor majetku". Znamená to, ze určitý investiční majetek může být soustředěn do určitého souboru (např. počítač, monitor, tiskárna, kopírka apod.). Potom je nutno jeden investiční majetek určit jako hlavní předmět souboru a u ostatních potom zadat tento majetek jako nadřízený artikl. Ostatní investiční majetek v souboru se pak odepisuje podle stejné odpisové skupiny jako tento hlavní předmět.

Další činnosti, která má uživatel dostupné v menu "volby" jsou:

¨ události a karty artiklu - uživatel má k dispozici všechny potřebné údaje které se týkají odpisovaného majetku uvedeného na kartě. Jsou to:

- události odpisovaného majetku

- události spravovaného majetku

- rezervace majetku

- odpisovaný majetek

- spravovaný majetek

- prognózování odpisů

Další podstatné informace má uživatel k dispozici na záložkách „účetní odpis“ a „daňový odpis“, kde jsou údaje o počtu odpisů, jejich výši, vstupní a zůstatkové ceně apod.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Karta pracovníka

Tato činnost se nachází v hlavním menu v činnosti Mzdy a personalistika – Mzdy. Po spuštění této činnosti se jako první nabídne záložka výběr. Zde má uživatel na výběr z mnoha možností … může vyhledávat pracovníky podle osobního čísla, výplatního místa, podle kategorie apod. Pokud si uživatel chce přímo na prohlížení načíst všechny karty pracovníků, nebude výběrové pole vůbec zohledňovat a načte výběr prázdný.

Na kartě pracovníka má uživatel k dispozici osobní údaje o jednotlivých pracovnících (jméno, adresu, rodné číslo apod.) a údaje potřebné k evidenci mezd (pracovní poměr, srážky, půjčky, exekuce, daňová zvýhodnění apod.). Tyto informace má zároveň uživatel kompletně k dispozici i ve „stromu pracovníka“ (pod menu Volby).

Jednotlivé záložky v činnosti Karta pracovníka jsou následující:

¨ pracovníci

¨ osobní údaje

¨ volné údaje

¨ zdravotní pojišťovny

¨ sociální pojišťovny

¨ pracovní poměr

¨ měsíční nezdanitelné položky

¨ roční nezdanitelné položky

¨ daňová zvýhodnění

¨ půjčky, srážky, exekuce

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 03.06.2008


Pojem - Karty pohledávek

Komponenta odpisy a opravné položky pohledávek slouží pro tvorbu a evidenci daňových opravných položek, daňových odpisů pohledávek a navazujících účetních odpisů. Karty pohledávek uživatel vytváří nad činností „události plateb“ (hlavní menu – Platby).

Na záložce „Výběr“ podle následujícího obrázku zadat atributy a vybrat a označit platby. Následně aktivovat klávesu Ctrl K (nebo v menu Volby činnost Karty pohledávek), tím se aktivuje činnost „karty pohledávek“ a po stisku klávesy F3 (nebo ikony Nový záznam) dojde k částečnému předplnění karty pohledávky.

Do identifikace karty pohledávky se předplní variabilní symbol platby, dále je třeba vybrat tabulku, která určuje konkrétní způsoby vytváření opravných položek a datum, ke kterému se opravná položka zakládá.

Pole výše pohledávky udává hodnotu pohledávky v okamžiku založení karty. Tato je dále aktualizovaná událostmi komponenty (rozpouštění opravné položky při úhradě). Pro daňový odpis se uvádí procento ročního odpisu (10 %, 20%), tabulka pomlčka s druhem pohledávky odpis.

Procento odpisu pro účetní odepisování se uvádí na druhé záložce „stav pohledávek“. V přehledu karet pohledávek jsou šedě zobrazeny ty karty, kde došlo k úhradě pohledávky (i částečné). Na výběrové záložce lze takové karty najít nastavením „stav byl změněn“ v atributu stav změny.

Poznámka: V činnosti druhy artiklů by druh artiklu pro tuto činnost neměl mít nic zatrženo na záložce „výskyt artiklu“. V některých případech pak může nastat potíž při zapisování karty (chyba „data nebyla změněna“).

Tvorbu nebo rozpouštění opravných položek je třeba provést z nabídky Nový proces některým z následujících procesů:

¨ opravné položky a odpis pohledávek - tvorba

Pro tvorbu daňově uznatelných se používá šablona prvního vstupu - Daňové opravné položky a odpis pohledávek. Proces se spouští přes šablonu bez zaškrtávátka - používá se pro vytvoření odpisů a opravných položek k pohledávkám koncem roku (šablona pracuje pouze s aktuálními kartami). Zadává se datum, ke kterému se výpočet provádí. Proměnná „maximálně %“ – např. snížením na 50 % - při tvorbě dojde ke zkrácení nárokové hodnoty vytvářených opravných položek na polovinu. Toto snížení šablona nepoužije pro tvorbu daňových odpisů (10%, 20%), hodnota se vypočte ve 100% výši.

Výpočet všech druhů odpisů a opravných položek lze provádět opakovaně. Nový výpočet proběhne s ohledem na všechny dosud vytvořené záznamy a aktuální stav pohledávky k datu tvorby (práce s označenými).

¨ opravné položky a odpis pohledávek rozpuštění - úhrada

Proces se spouští přes šablonu Daňové opravné položky a odpis pohledávek s volbou Pouze rozpuštění odpisů a opravných položek (zaškrtnout) - používá se pro rozpouštění odpisů a opravných položek kdykoliv během roku po úhradě pohledávky (alespoň jednou před tvorbou nových opravných položek ke konci roku, jinak se rozpuštění provede při tvorbě nových při spuštění výše uvedeného procesu). Následuje zaúčtování do deníku po jednotlivých kartách. (Nespouštět rozpouštění v běžném roce před tvorbou předchozího roku.)

¨ opravné položky k pohledávkám rozpuštění + 100% odpis

Použít pro rozpuštění daňových opravných položek bez úhrady pohledávky (např. rozhodnutí soudu, neefektivní vymáhání, promlčení pohledávky). Použití šablony Neefektivně vymahatelné pohledávky – je třeba uvést datum splatnosti pohledávky do, dále datum, ke kterému je opravná položka rozpouštěna (datum události), částku do (výše pohledávky) a případně identifikaci adresáta (identifikaci adresáta je třeba si zjistit předem).

  1. Šablonou vytvoření opravné položky mínusem – označí kartu pohledávky neaktuální.
  2. Zaúčtování do výnosů po jednotlivých kartách.
  3. Odpis účetní ve výši 100% pohledávky a jeho zaúčtování.
  4. Pohledávky, které byly účetně odepsány, je takto třeba označit i v komponentě plateb. Nejlépe speciální operací komponenty změny stavu peněz „odpis“ (fiktivní označení pohledávky jako uhrazené), aby byly odepsané pohledávky vyjmuty z inventurních přehledů.

(Neaktuální karta k pohledávce – stav na kartě změní uživatelský trigger pouze operací „odnoo2“ Rozpuštění opravné položky bez úhrady.)

Šablona Nevymahatelné pohledávky - konkurz lze použít pro vytvoření opravné položky bez ohledu na datum splatnosti pohledávek (identifikaci adresáta je třeba si zjistit předem). Navazující kroky procesu je možné spouštět podle konkrétní situace jednotlivých pohledávek.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 23.01.2009


Pojem - Karty spravovaného majetku

Tato činnost představuje pro uživatele vlastní evidenci jednotlivých karet spravovaného majetku. Není nutno zvlášť popisovat všechny položky, které jsou přístupny na formuláři - jejich význam je většinou snadno odvoditelný od jejich názvu. Podrobněji se zastavíme pouze u těchto položek:

¨ identifikace druhu artiklu - spravovaný majetek je možno členit do několika druhů. Výhodou takového rozdělení je možnost evidence vlastní číselné řady pro každý z druhů spravovaného majetku. Znamená to tedy, že stejné číslo spravovaného majetku může být použito několikrát, pokud je tento majetek vždy jiného druhu (při vstupu nové karty spravovaného majetku s identifikací artiklu, která je již v BM zavedena, dochází automaticky k předplnění dalšího volného pořadového čísla pro danou identifikaci artiklu).

¨ mezi další údaje patří výrobní číslo, zaškrtávátko zda lze rezervovat (tzn. zda je možno daný sprav. majetek využívat pro rezervace), možnost zadání čárového kódu, třídy SKP, umístění, kam spravovaný majetek spadá a zodpovídá. Zde se uvádí jméno pracovníka, který je za daný spravovaný majetek zodpovědný (nenabízí se však pracovníci zadaní ve mzdách, ale nabízí se výběr pracovníků z adresáře, tzn. při zadávání jednotlivých pracovníků do položky zodpovídá je nutno mít tyto pracovníky uvedeny v adresáři).

¨ důležitým atributem u spravovaného majetku je stav (zařazen, vyřazen) a datum, kdy ke změně tohoto stavu došlo. Datum zařazení nebo vyřazení se na kartu spravovaného majetku automaticky dostává z příslušných událostí sprav. majetku. V okamžiku aktualizace (vložení, modifikace, zrušení) události sprav. majetku se aktualizují atributy na kartě spravovaného majetku s respektováním pořadí událostí dle jejich data. Následně vstupují v platnost omezení aktualizace dané karty (např. atribut změna stavu a změna ceny nelze po zápisu události již opravovat, u vyřazených artiklů již nelze měnit stav apod.).

Po zadání těchto údajů je možno u každého spravovaného majetku uvést jeho název v různých jazycích (viz. záložka "názvy artiklu") a prohlížet si další údaje o majetku, viz. záložka "další". Záložka aktuální hodnoty poskytuje uživateli přehled o aktuálních hodnotách dané karty spravovaného majetku, nejčastěji asi hodnota spravovaného majetku ve finančním vyjádření.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 01.11.2012


Pojem - Katastr nemovitostí

Katastr nemovitostí ČR (dále jen KN) vznikl ke dni 1. 1. 1993 na základě zákona číslo 344/92 Sb. o katastru nemovitostí České republiky (katastrální zákon). Jedná se o soubor údajů o nemovitostech v Čechách, na Moravě a ve Slezsku zahrnující jejich popis, soupis a geometrické a polohové určení. KN ČR je víceúčelový katastr, který neslouží jen pro daňové účely, ale i pro nemovitostech, avšak pouze o těch, které se nacházejí na území České republiky. Nenajdeme zde informace o nemovitostech, které sice patří občanům České republiky, ale nacházejí se v jiném státě, například na Slovensku.

V katastru nemovitostí se evidují pozemky, budovy, byty a nebytové prostory, rozestavěné budovy, byty a nebytové prostory a další stavby spojené se zemí pevným základem. Neevidují se tu však veškeré stavby, například zde nenajdeme podzemní stavby, rovněž tak nejsou evidovány stavby, které nejsou se zemí spojeny pevným základem (např. dřevěná kůlna bez základů) nebo které patří mezi tzv. drobné stavby (např. ptačí budka spojená se zemí pevným základem). Co se můžeme o nemovitosti dozvědět, pokud je předmětem evidence v katastru nemovitostí?:

¨ V katastru nemovitostí najdeme informace o tom, kde se vlastně nemovitost nachází - zjistíme její přesné geometrické a polohové určení a to, v jakém katastrálním území se nachází.

¨ Katastr nemovitostí nám poskytne základní informaci o druhu nemovitosti - nejenže zjistíme, zda se jedná o pozemek či o stavbu, ale u pozemků zjistíme i konkrétní druh. Pozemky se člení na ornou půdu, chmelnici, vinici, zahradu, ovocný sad, trvalý travní porost, lesní pozemek, vodní plochu, zastavěnou plochu a nádvoří a na ostatní plochy. Rovněž u staveb zjistíme jejich účel, například že jde o obytný dům nebo o hospodářskou budovu.

¨ V katastru nemovitostí jsou obsaženy veškeré číselné údaje o nemovitosti, tedy číslo pozemku, v případě budovy pak ještě její popisné a evidenční číslo.

¨ Zjistíme, jakou má pozemek evidovanou výměru.

¨ V praxi nejužívanější a nejpotřebnější informací je údaj o vlastníkovi nemovitosti, i ten se z katastru nemovitostí dá snadno zjistit. V případě, že by nemovitost měla více vlastníků, zjistíme nejen to, kdo nemovitost vlastní, ale i to, jaký je jeho spoluvlastnický podíl.

¨ Další pro život užitečnou informací je informace o tom, zda nemovitost není zatížena hypotečním právem, zda někdo nemá k nemovitosti předkupní právo nebo zda někdo nemá k nemovitosti právo odpovídající věcnému břemeni.

¨ V katastru nemovitostí jsou také obsaženy údaje o místním názvosloví a údaje o podrobných polohových bodových polích.

¨ Jak se můžeme informace o nemovitosti dozvědět? Katastr nemovitostí je veřejný soubor údajů a každý má právo, bez toho, aby prokazoval důvod, požadovat z něj informace. Ty lze získat buď tak, že přímo nahlédneme do katastru nemovitostí za přítomnosti pracovníka nebo si od něj vyžádáme ústní informace. Dále můžeme potřebné údaje získat výpisem, opisem nebo kopií, které případně mohou být ověřené. Každý má právo do katastru nemovitostí nahlížet a v případě potřeby si z něj pořizovat opisy, výpisy a náčrty. Obecně platí, že informace z katastru se poskytují za úplatu, bezplatně vám bude poskytnuta ústní informace a bude vám umožněno nahlédnutí do katastru.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Katastrální mapa

Podrobná polohopisná mapa velkého měřítka zobrazující nemovitosti a udržovaná ve stálém souladu se skutečným stavem v terénu. Tvoří soubor geodetických informací katastru nemovitostí.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Katastrální úřad

Orgán státní správy na úseku katastru nemovitostí s okresní působností podle zákona č. 359/1992 Sb. o orgánech zeměměřictví a katastru. Zejména vykonávají státní správu katastru nemovitostí ČR, správu zhušťovacích bodů a bodů podrobného polohového a výškového bodového pole, projednávají porušení pořádku na úseku katastru nemovitostí ČR, schvalují změny katastrálních hranic atd..

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.02.2008


Pojem - Katastrální území

Katastrální území (k. ú.) je v katastru nemovitostí společně evidovaný soubor nemovitostí“. Obdobná definice platí i na Slovensku. Existují také katastrální území nesouvislá (např. vesnice Kaliště byla součástí katastru České Budějovice 4 - venkov, ale územně se zbytkem tohoto katastru nijak nesousedí).

V rámci k. ú. jsou číslovány parcely v jedné nebo dvou souvislých číselných řadách a budovy v souvislé řadě čísel popisných a čísel evidenčních. V rámci České republiky mají katastrální území jedinečná pojmenování, která zpravidla vycházejí z názvu obce, osady nebo městské části. V mnoha případech se jejich názvy například rozlišujícími přívlastky od názvu správní jednotky (obce, městské části) odlišují. Katastrální území pokrývají celé území státu. Hranice a názvy katastrálních území určují místně příslušné katastrální úřady po projednání s obcemi nebo na jejich návrh.

Zjednodušeně řečeno je katastrální území technická jednotka, kterou tvoří místopisně uzavřený a v katastru společně evidovaný soubor nemovitostí.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.02.2008


Pojem - Kategorie adresátů

Tato činnost slouží k vedení evidence (vkládání, editace, rušení) jednotlivých kategorií adresátů, které se potom následně mohou přiřadit jednotlivým adresátům nebo kategoriím spojení. Výběrová záložka bere v potaz kategorie vstupované i vypočítané.

U každé kategorie se definuje:

¨ identifikace, název

¨ uplatnění – překryvný seznam s možností výběru – kategorie adresáta/kategorie spojení adresáta (znamená, zda definovaná kategorie bude novou kategorií pro adresáty nebo bude kategorií pro spojení adresátů)

¨ typ – vstupovaná/vypočítaná. Př.: SQL vypočítané kategorie „Dodací spojení“ podle realizovaných dodacích listů –

if exists (select * from %%%.obudal where ad01id=@ad01id and ad11cisspo=@ad11cisspo and sp07idtyp=’dodlis’) then 1 else 0 endif. Vstupovaná kategorie se vytváří přímo v této činnosti. Pro kategorii Vypočítanou je nutno nejprve nadefinovat SQL dotaz, což uživatel provede v činnosti „Definování typu kategorie adresáta“ (menu volby nebo pomocí klávesy F5). Zde se nadefinuje vypočítaná kategorie a k ní příslušný SQL dotaz.

¨ komentář – libovolný popis ke kategorii

Kategorii spojení adresáta je možno použít ve formuláři Druhy operací na záložce Spojení, kde se definuje přesný algoritmus předplňování spojení adresáta v událostech.

Přiřazení kategorie adresátům je možno si prohlédnout na záložce "adresáti v kategorii", kde si pomocí klávesy F3 může uživatel z adresáře vybrat adresáta, kterého chce následně zařadit do dané kategorie. U vybraného adresáta může zvolit i období (od -do) přítomnosti adresáta v kategorii. Toto období je pak možno využít při různém označování kategorií apod. U každého adresáta v kategorii je i adresa implicitního spojení.

Jednotlivým kategoriím je možno přiřadit i vybranou barvu, tj. záložka "barvy". Adresáti v takto označené kategorii pak budou v adresáři zobrazeni vybranou barvou. Takto je možno si označit např. neplatiče nebo naopak velmi významné klienty. V případě, že adresát je uveden v kategorii, která je zvýrazněna některou barvou a zároveň spadá do kategorie, která je uvedená v paletě barev a má rovněž určenu zvýrazňovací barvu, uplatní se barva, která je uvedena v paletě barev kategorií.

Programová podpora (vhodné pro implementátory):

Uložená funkce 'ADSPOJ je v kategorii'

– vybere ta spojení, která jsou v kategorii vstupované nebo vypočítané (uplatňuje se jako výběr nad tabulkou kategorie spojení). Samozřejmě, že vybere ta spojení k adresátům, ke kterým má daný uživatel přístup a kategorie je platná.

Vrací hodnotu 1 nebo 0 podle toho, zda spojení adresáta patří do požadované kategorie. Parametry:

ad08id - identifikace kategorie nebo %

ad08nazkat - název kategorie nebo %

ad01id - identifikace adresáta

ad11cisspo - spojení adresáta

bw01uziv - identifikace uživatele systému

datum - datum, ke kterému má být vyhodnocována příslušnost v kategorii

např.:

select * from %%%.adspoj where %%%."ADSPOJ je v kategorii"('DODSPO','%',ADSPOJ.ad01id,ADSPOJ.ad11cisspo,?tool.uziv,current date)=1

Uložená funkce 'ADADSAT je v kategorii'

- vybere adresáty (pro uživatele přístupné), kteří jsou v kategorii (vstupované nebo vypočítané) a nebo mají vstupovanou kategorii spojení. Parametry této funkce jsou shodné jako u výše popsané funkce ADSPOJ.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 06.03.2009


Pojem - Kategorie dokumentů

Tato činnost poskytuje uživateli přehled vytvořených kategorií dokumentů. Každý dokument BM je možno zařadit do různých kategorií. V této činnosti lze kategorie vytvářet, editovat či rušit. Zařazení dokumentu do kategorie se provádí ve formuláři činnosti „Dokumenty“ na záložce „Kategorie dokumentů“ nebo ve formuláři činnosti „Vlastnosti dokumentu“ na záložce „Kategorie“ (vlastnosti dokumentu se vyvolají pravým stiskem myši v okně spojených dokumentů).

U každé kategorie se definuje:

¨ identifikace a název kategorie

¨ složka – překryvný seznam s volbou Ano/Ne – při volbě Ano bude dokument zařazený do této kategorie k dispozici ve formuláři činnosti „Spojené dokumenty“ (Ctrl D) ve složce odpovídající názvu kategorie

¨ rozbalená – překryvný seznam s volbou Ano/Ne – při nastavení složka „Ano“ bude složka ve formuláři činnosti Spojené dokumenty rozbalená

¨ předchůdce – identifikátor kategorie, možný výběr z číselníku. Při nastavení složka „Ano“ a vyplněné identifikaci předchůdce je tímto určena nadsložka dané složky ve stromu ve formuláři činnosti „Spojené dokumenty (Ctrl D).

¨ poznámka

Spojené dokumenty (Ctrl D) x kategorie dokumentů

Dokumenty, které mají ve své definici nastaveno Složka – „Ano“, jsou pak ve formuláři činnosti Spojené dokumenty řazeny stromově podle jednotlivých kategorií. Je-li dokument zařazen do takové kategorie (složka – Ano), potom se ve stromu vytvoří adresářová struktura vyplývající ze vztahu kategorií (viz. atribut „předchůdce“).

Při zakládání nového dokumentu po pravém kliku na položce stromu, která odpovídá kategorii dokumentu, je u tohoto nově zakládaného dokumentu ve formuláři „vlastnosti dokumentu“ na záložce „kategorie“ předplněno zařazení do odpovídající kategorie. Při kopírování dokumentu se zařazení do kategorie nedědí.

Ve stromu se kromě dokumentů, které jsou přímo spojeny s objektem BM, zobrazují jako jejich poduzly také dokumenty, které jsou objektovou vazbou spojeny s dokumentem (následníci). Z podmenu NAVAZUJÍCÍ DOKUMENTY obsaženého v menu vyvolaném po pravém kliku na dokumentu je možno připojovat jeho nové následníky.

Příklad: K dokumentu charakteru smlouva je vhodné připojit dokumenty s jejími dodatky.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.11.2007


Pojem - Kategorie spojení adresáta

Kromě zařazování adresátů do kategorií je možno zařazovat do kategorií také jejich jednotlivá spojení. Zařazování spojení adresátů do kategorií se provádí v činnostech:

¨ adresář (záložka Kategorie spojení)

¨ spojení adresátů (záložka Kategorie spojení)

Kategorii spojení adresáta je možné použít ve formuláři „druhy operací“ na záložce „spojení“, kde se definuje přesný algoritmus předplňování spojení adresáta v událostech.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.11.2007


Pojem - Kategorie zvířat

Kategorie zvířat je skupina zvířat stejného druhu umístěná v různých stájích. O zařazení do kategorie rozhoduje obvykle biologický druh, pohlaví, věk a určení zvířete. Uživatel má k dispozici přehled jednotlivých nadefinovaných kategorií zvířat a jejich aktuální hodnoty. U každé kategorie je k dispozici:

¨ identifikace druhu a vlastní identifikace kategorie

¨ KD - zaškrtávátko, které určuje, zda se u dané kategorie mají počítat krmné dny. Pokud ano, je nutno ho zaškrtnou, pokud ne, je nutno ho nechat prázdné.

¨ název kategorie

¨ způsob vedení – překryvný seznam – kusově, obecně. U kategorie zvířat vedených kusově pak množství v kusech na události s uvedeným ID zvířete musí být vždy jedna.

¨ MJ - identifikátor referenční měrné jednotky, ve které se daná kategorie bude evidovat

¨ tech. sel. - identifikace technického selektoru, který je spojen s kategorií

¨ libovolná poznámka ke kategorii

V dolní části činnosti kategorie se uživateli zobrazují hodnoty, které si uživatel nadefinoval jako první tři parametry v činnosti "parametry komp. sklad zvířat".

Na záložce "aktuální hodnoty" má uživatel k dispozici informace o jednotlivých aktuálních hodnotách dané kategorie, tzn. nejčastěji jaké množství zvířat je v kterém umístění a to jak v naturálním, tak ve finančním vyjádření.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.11.2007


Pojem - Každý uživatel systému

Je to skupina uživatelů, do které je automaticky zařazen každý uživatel, v případě potřeby je možno ho kdykoliv vyřadit. Pokud jsou do systému zařazeny nové věci s přístupovým právem, má tato skupina automaticky právo zápisu. Podobně je tomu s novými činnostmi, které jsou zařazeny v rámci vývoje IS.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Klasifikace objektu

Klasifikace objektu je nástroj, kterým je možné sdělovat určitou obecnou vlastnost, která je společná různým objektům BM stejného druhu. Klasifikaci objektu je v současné době možné uvádět v událostech obchodu.

Pro vstup klasifikace objektu slouží činnost, která je vyvolávána klávesou F2. V této činnosti se definuje, kromě identifikátoru klasifikace a jejího názvu, sada obecných parametrů.

Na druhé záložce formuláře je pak možné vstupovat hodnoty obecných parametrů definovaných touto sadou. Tyto hodnoty jsou vztaženy ke klasifikaci a stávají se tímto společné pro všechny objekty, ve kterých je klasifikace uvedena.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.03.2004


Pojem - Knihovny ELDP

Knihovny ELDP uvádí u Průběhu pojištění 3 místný kód.

První znak se vyplňuje hodnotou:

1 - normální pracovní poměr u zaměstnavatele

A - dohoda o pracovní činnosti

Q - členové kolektivních orgánů právnické osoby

S - společník, jednatel, komandista, ředitel obecně prospěšné společnosti (toto zatím neumíme udělat)

T - dohoda o provedení práce

P - prokurista

Druhý znak se vyplňuje hodnotou:

P - příjmy po skončení výdělečné činnosti

D - důchodový věk

V - výjimka

+ - když to není P, D, V

Třetí znak se vyplňuje hodnotou:

S - statutární zástupce obchodní společnosti nebo družstva

+ - když to není S

Příklady kombinací:

1++,1+S, S++, SD+, Q+S, 1DS, Q++, ...

Pracovník může mít u sebe uvedenu kategorii (Na Kartě pracovníka - Volby - Pracovníci v kategoriích):

QCLEN - na první místo kódu nastaví znak Q,

STATUT - na třetí místo kódu nastaví znak S

Pokud používáte činnost Pracovníci v kategoriích, je nutno vždy vybrat nějaký účel. Kategorie se STEJNÝM účelem se považují za shodné a automaticky se jim předplňuje a zpětně opravuje platnost Do! V případě potřeby lze účel uživatelsky rozšířit cizojazyčností. V současnosti jsou možnosti: neurčeno, cizozemský nositel pojištění, trvalý pobyt v ČR, místo výkonu činnosti, studující, kategorie L, uchazeč o z., statut, Q člen, důchod. spoř.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.12.2013


Pojem - Knihovny vkládaného kódu

Jsou určeny pro definování opakovaného kódu programu doplň. vlastností formuláře a to tím způsobem, že přímo v doplň. vlastnostech formuláře se na programový kód knihovny odkazujeme klausulí #INCLUDE <identifikace knihovny>. V této chvíli jsou vytvořeny knihovny např. definující objekty pro výstup do HTML, importy-exporty dat, čtení dat z Excelu, ....

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.11.2007


Pojem - Kód funkce výkazů

Kód funkce výkazu je programový kód, ve kterém je uživatelsky napsána funkce výkazu, obvykle napsaný s cílem získání hodnot, údajů či informací ze zdrojových dat (tabulky IS BM).

Vychází z jazyka FoxPro a jazyka SQL databázového serveru (jednoduché příkazy v syntaxi FOXPRO, příkazy IF a ENDIF a příkaz SET, který provádí SQL dotaz). Parametry funkce, pokud jsou v kódu použity, se uvádějí v syntaxi ?_par_ppp a v syntaxi &_par_ppp pro parametry typu Seznam hodnot nebo Makro, kde ppp je identifikátor parametru uvedený v jejich seznamuna záložce parametry funkce (například: selor).

Uvedení parametru typu Seznam hodnot je automaticky transformováno, například: Kód SET SELECT SUM(sp71prijem) FROM %%%.SPSTATIS WHERE _par_selor AND … bude transformován, pokud při volání funkce platí selor='112%;1135_[^5]%;2%' a v definici parametru [selor] je uveden atribut SPSTATIS. sp11idzak , takto SET SELECT SUM(sp71prijem) FROM %%%.SPSTATIS WHERE (SPSTATIS. sp11idzak LIKE ‘112%‘ OR SPSTATIS. sp11idzak LIKE ‘1135_[^5]%‘ OR SPSTATIS. sp11idzak LIKE ‘2%‘) and ….

Parametr typu Makro je v kódu nahrazen textovým řetězcem, který skutečný parametr obsahuje v okamžiku volání funkce výkazu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.11.2007


Pojem - Kód po ukončení operace

Kód pro ukončení operace slouží k řízení a modifikaci probíhajícího procesu zejména na základě informací v událostech operací procesu a uživatelských rozhodnutích, případně též na základě jiných informací v IS. Řízení procesu spočívá v:

¨ modifikaci jeho procesního diagramu

¨ uvedení operací do stavu připravena

¨ odstranění těch operací procesu, které ztratily vzhledem ke vstoupeným informacím smysl

¨ práci s volnými kartami (automatické naplnění, spuštění pro vstup, ...)

¨ validaci dat

¨ jiných aktivitách (výstupy: tisk, e-mail, ...)

Kód se uplatňuje v okamžiku pokusu o ukončení operace, přičemž může zabránit jejímu ukončení. Kód musí být zapsán ve zvláštním programovacím jazyce. Jednotlivé příklady zápisu kódu po ukončení operace jsou uvedeny ve zvláštní příloze k této dokumentaci.

V kódu po ukončení operace je navíc možno testovat, zda je nebo není operace ukončována předběžně a zároveň je možno určit, zda operace má nebo nemá být ukončena předběžně.

Pro druh operace v diagramu druhu procesu je možno kromě běžného kódu po ukončení operace zadávat statický kód druhu operace v druhu procesu. Aktivuje se zaškrtnutím tohoto atributu ve formuláři kódu po ukončení operace. Celkový kód prováděný po ukončení operace se sestavuje spojením:

¨ (statický kód druhu operace v druhu procesu) + (nestatický kód po ukončení operace, který je spojen s operací ve fyzickém procesu). Z toho vyplývá, že statický kód je prováděn vždy pro danou operaci v druhu procesu, i když byla operace ukončena a následně byl její stav ukončena zrušen. Na rozdíl od nestatického kódu, který je po ukončení operace pro danou operaci ve fyzickém procesu vymazán. Použití statického kódu je vhodné pro různé validace dat ukončované operace (např. musí být vyplněn selektor).

POZOR na nevhodný postup:

1. vznikl fyzický proces s operací, v jejímž kódu po ukončení je např. uvedeno DECLARE pocet=COUNT (.......)

2. implementátor upravil odpovídající druh procesu:

a) uvedl ve statickém kódu DECLARE pocet=COUNT (......)

b) zrušil v původním nestatickém kódu DECLARE pocet=COUNT (.....)

3. uživatel pokračuje ve fyzickém procesu a ukončuje operaci

4. kód po ukončení operace hlásí chybu dvojí deklarace proměnné pocet

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.11.2007


Pojem - Komentář

Jedná se o tzv. memo pole, které je dostupné ve většině činností. Do pole komentář je možno napsat libovolně dlouhý text. Pohyb v textu komentáře je možný posuvníky po pravé straně a nebo je možno stiskem pravého tlačítka myši na tučně zvýrazněném atributu Komentář vyvolat vlastní okno komentáře. Jeho velikost si uživatel může upravit podle svých potřeb. Po stisku pravého tlačítka myši v okně komentáře má uživatel možnost změnit si i font písma v daném okně.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.11.2007


Pojem - Komponenta

Informační systém lze rozdělit na komponenty a informační centrum, které mimo jiné zajišťuje jejich komunikaci. Komponenta je tedy ucelená část informačního systému, kterou je možno provozovat i samostatně (s informačním centrem), a to samo o sobě již má určitý přínos pro uživatele. Každá komponenta v informačním systému Bílý Motýl má standardizovanou strukturu a může mít své:

¨ operace s druhy hodnot a šablony

¨ aktéry (adresáty)

¨ artikly

¨ alokace (umístění)

¨ činnosti

¨ vstupní atributy

¨ výstupní atributy

¨ ...

V současné době jsou k dispozici následující komponenty:

Ident. Název komponenty Zrcadlové storno záložka Další

DPH - daň z přidané hodnoty Ano

HPP - hodnoty předmětu projektu Ne

HPS - položky smluv Ne

HPU - plnění smlouvy Ne

HPX - plnění projektového úkolu Ne

HPZ - projektové úkoly Ne

MZD - události mezd Ano

MZP - personalistika Ano *

MZV - vstupní údaje ze systému Ano *

OBC - obchod Ano

ODP - odpisovaný majetek Ano

OKO - obecná komponenta Ano

PLA - platby Ano

POS - poštovní zásilka Ne

PZP - zprávy Ne

REZ - rezervace Ne

SKL - skladová evidence Ano

SMU - spravovaný majetek Ano

UCE - událost účetnictví Ano

VR1 - výroba – výrobní zakázka Ano

VR3 - výroba – vstupy a výstupy Ne

VR4 - výroba – výrobní úkoly Ne

VYM - vymáhání pohledávek Ano

VYV - obecná událost Ano *

ZAL - zálohy Ano

ZSP - změna stavu peněz Ano

Sloupec „zrcadlové storno“ poskytuje uživateli informaci o tom, zda daná komponenta má programově umožněno vytvářet zrcadlové storno či nikoliv. Zrcadlové storno znamená, že ke stornované události bude vytvořena událost inverzní (tj. opačná s mínusovými znaménky). U ostatních komponent je stornovaná událost zrušena. U komponent, které mají ve sloupečku „záložka Další“ zapsanou * platí, že tyto komponenty mají programově umožněno zrcadlové storno, ale implicitně se u nich neuplatňuje, tzn. že při stornu událostí těchto komponent jsou události zrušeny. Aby zde fungovalo zrcadlové storno, je nutno u druhu operací těchto komponent (Informační centrum – Typy a řady – Druhy operací) na záložce Další nastavit příznak zrcadlové storno na Ano.

S jednotlivými komponentami úzce souvisí i činnost otevřená období komponent (menu Informační centrum – Typy a řady), která umožňuje uživateli nastavit období pro validaci dat v událostech.

U každé komponenty lze zadat (po stisku F3) datum od – do. Toto datum systém potom hlídá při zápisu událostí komponenty a při provádění storna. Jak již vyplývá z názvu této činnosti, je nutno si uvědomit, že uživatel zadává datum, kdy je možno komponentu pro zápis událostí nebo storna považovat za otevřenou, tzn. mimo toto zadané období je vlastně komponenta pro zápis nebo storno uzavřená. Pokud uživatel u komponenty nezadá žádné datum od – do, je tato komponenta implicitně otevřená jak pro zápis, tak pro storno.

Pod menu Volby má uživatel k dispozici činnost metapředlohy výstupu, což mu umožňuje zobrazit si metapředlohy týkající se dané komponenty.

Např. při vytváření daňových přiznání – pokud je daňové přiznání vytvořeno např. k 31.3., tak uživatel pak jistě nechce, aby do tohoto období někdo zpětně vytvářel události DPH. U komponenty DPH tedy nastaví datum od 01.04., což znamená, že měsíc březen je pro zápis událostí nebo storno nepřístupný.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 26.06.2014


Pojem - Komunikace s jinými systémy

Informační systém umožňuje výměnu dat s okolními systémy zejména pomocí exportů a importů. Dále se jedná o:

¨ vytvoření souboru pro hromadnou korespondenci při spuštění dokumentu

¨ realizaci výstupů pomocí Excel nebo MSIE

¨ sestavení výkazů v MS Excel

¨ webové služby

¨ replikace

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.11.2007


Pojem - Kontingenční tabulka

Kontingenční tabulka je interaktivní tabulka, která rychle kombinuje a porovnává velká množství dat. Řádky a sloupce tabulky lze otáčet a zobrazit tak různé souhrny zdrojových dat. Kontingenční tabulka slouží k analýze souvisejících celkových hodnot, zejména chcete-li sumarizovat dlouhý seznam údajů a porovnávat více aspektů jednotlivých údajů, tzn. že jak kontingenční tabulka, tak i kontingenční graf vám umožní provádět informovaná rozhodnutí o důležitých datech v organizaci.

Kontingenční tabulka se užívá k přehledné vizualizaci vzájemného vztahu dvou statistických znaků. Řádky kontingenční tabulky odpovídají možným hodnotám prvního znaku, sloupce pak možným hodnotám druhého znaku. V příslušné buňce kontingenční tabulky je pak zařazen počet případů, kdy zároveň měl první znak hodnotu odpovídající příslušnému řádku a druhý znak hodnotu odpovídající příslušnému sloupci.

Kontingenční tabulka není přímo nástroj IS BM, pouze umožňuje data IS BM tímto způsobem zobrazit. Kontingenční tabulky jsou nástrojem aplikace MS Excel. Aby je bylo možno využívat v souvislosti se zobrazením množiny dat z IS BM, je nutno, aby pracovník implementace (nebo vývojového oddělení) připravil uživateli SELECT (nebo tak může být rovnou připravena v některých komponentách i předloha výstupu), který automaticky „vytáhne“ příslušná data z IS BM a poskytne je uživateli k zobrazení v MS Excel. Příkaz SELECT musí být sestaven tak, aby se odkazoval na data, která jsou spolu provázána a pak je možno kombinovat jejich zobrazení v kontingenční tabulce. V IS BM je možno kontingenční tabulky využívat při definici výkazů nebo informačních panelů.

Po aktivaci příkazu s tímto SELECTEM se uživateli zobrazí aplikace Excel, kde má k dispozici nejprve na výběr seznam polí, která má v tabulce k dispozici a jejich přetažením (systém „táhni a drž“) je umísťuje do vhodných polí, tzn. vytváří celkový filtr tabulky (stránková pole) a pak jednotlivé řádky, sloupce a množinu dat (viz. obrázek).

Pomocí jednotlivých ikon v panelu nástrojů týkajících se kontingenční tabulky má uživatel možnost nadefinovat si konečné zobrazení množiny dat, jsou to:

¨ formát kontingenční tabulky

¨ průvodce grafem

¨ skrýt detaily

¨ zobrazit detaily (např. celkový součet vybraného účtu za selektor a rok po stisku této ikony zobrazí detailní informace, tzn. např. po jednotlivých měsících, které tvoří celkový součet)

¨ aktualizovat data

¨ zahrnout skryté položky do celkových součtů

¨ vždy zobrazovat položky

¨ nastavení pole

¨ skrýt seznam polí

Upozornění, týkající se využití kontingenčních tabulek:

V případě, že databáze nepoužívá interní kódování textu v kódu 1250, potom se nebude v kontingenčních tabulkách správně zobrazovat diakritika. V tom případě může pomoci nastavení parametru BM: Preferences->ADODBcharset=cp1250, který určuje kódovou stránku, ve které mají být vraceny texty SQL dotazů zpracovávaných prostřednictvím ADO.

Příklad definice kontingenční tabulky, která čerpá data z obratové tabulky (komponenta účetnictví):

Typ listu - 'Kontingenční'

SQL -

<pre>

SELECT

left(ucobrtab.uc01id,1) "Třída",

trim(ucobrtab.uc01id)+' '+trim(uc04popuct) "Účet",

uc03rok Rok,

uc03mesic "Měsíc",

uc03mdr "Má dáti",

uc03dalr "Dal",

(uc03mdr-uc03dalr)*(if uc01strana=2 then -1 else 1 endif) Obrat,

sp10idzak OBS,

sp11idzak ORS,

sp20idzak TVS

FROM

%%%.ucobrtab ,%%%.ucrozvrh,%%%.ucrozvrn

WHERE

uc03faze=2 and uc03druh=1 and (uc03dalr<>0 or uc03mdr<>0)

and

ucrozvrh.uc01id=ucobrtab.uc01id

and

ucrozvrn.uc01id=ucobrtab.uc01id and ucrozvrn.sp38id=[jazyk]

and

sp11idzak like [sql_sp11idzak_like]

</pre>

V SQL dotazu je uvedená proměnná [sql_sp11idzak_like], která musí být deklarovaná v parametrech listu (viz.dále).

Pole kontingenčního listu:

Třída - Pořadí=10 - Oblast=Filtr sestavy - Určení oblasti
výrazem=[oblast_trida] - Filtr sestavy=[filtr_trida] - Výběr
popisků=[popisky_trida] - Zobrazení podpopisků=[rozbaleni_trida]

Rok - Pořadí=20 - Oblast=Filtr sestavy - Určení oblasti výrazem=[oblast_rok] - Filtr sestavy=[filtr_rok] - Výběr popisků=[popisky_rok] - Zobrazení podpopisků=[rozbaleni_rok]

Účet - Pořadí=30 - Oblast=Popisky řádků - Určení oblasti výrazem=[oblast_ucet] - Filtr sestavy=[filtr_ucet] - Výběr popisků=[popisky_ucet] - Zobrazení podpopisků=[rozbaleni_ucet]

ORS  - Pořadí=40 -
Oblast=Popisky řádků - Určení oblasti výrazem=[oblast_ors] - Filtr
sestavy=[filtr_ors] - Výběr popisků=[popisky_ors] - Zobrazení
podpopisků=[rozbaleni_ors]

Měsíc  - Pořadí= 50 -
Oblast=Popisky sloupců - Určení oblasti výrazem=[oblast_mesic] - Filtr
sestavy=[filtr_mesic] - Výběr popisků=[popisky_mesic] - Zobrazení
podpopisků=[rozbaleni_mesic]

Obrat - Pořadí=60 - Oblast=Hodnoty - Určení oblasti výrazem=[oblast_obrat] - Formát čísla=#,##0.00

TVS - Pořadí=70 - Oblast=Žádná - Určení oblasti výrazem=[oblast_tvs] - Filtr sestavy=[filtr_tvs] - Výběr popisků=[popisky_tvs] - Zobrazení podpopisků=[rozbaleni_tvs]

OBS - Pořadí=80 - Oblast=Žádná - Určení oblasti výrazem=[oblast_obs] - Filtr sestavy=[filtr_obs] - Výběr popisků=[popisky_obs] - Zobrazení podpopisků=[rozbaleni_obs]

Pozn.:

Pokud má být ve výrazech 'Výběr popisků' resp. 'Zobrazení podpopisků' uveden přímo výraz (místo např. [popisky_ors]), musí být tento výraz v definici pole uveden jako textový literál (např. [_pivotitem.value = 'ABC']).

V definici polí příkladu jsou použité proměnné listu a některé z nich musí být deklarovány v parametrech listu, jinak by byla při vytváření listu hlášena syntaktická chyba.

V parametrech listu proto musí být uvedeno:

jazyk=tool.jazyk

sql_sp11idzak_like='%'

popisky_trida=''

rozbaleni_trida=''

popisky_rok=''

rozbaleni_rok=''

popisky_ucet=''

rozbaleni_ucet=''

popisky_ors=''

rozbaleni_ors=''

popisky_mesic=''

rozbaleni_mesic=''

popisky_tvs=''

rozbaleni_tvs=''

popisky_obs=''

rozbaleni_obs=''

Aplikace příkladu listu ve výkazu:

Název listu ve výkazu - 'Zisk vloni'

Parametry listu ve výkazu:

filtr_trida='6'

filtr_rok=trans(year(date())-1)

Název listu ve výkazu - 'Zisk letos'

Parametry listu ve výkazu:

filtr_trida='6'

filtr_rok=trans(year(date()))

Název listu ve výkazu - 'Náklady vloni'

Parametry listu ve výkazu:

filtr_trida='5'

filtr_rok=trans(year(date())-1)

Název listu ve výkazu - 'Náklady letos'

Parametry listu ve výkazu:

filtr_trida='5'

filtr_rok=trans(year(date()))

Název listu ve výkazu - 'Zisk letos za středisko ABC'

Parametry listu ve výkazu:

filtr_trida='6'

filtr_rok=trans(year(date()))

popisky_ors=[_pivotitem.value = 'ABC']

Název listu ve výkazu - 'Zisk letos za středisko ABC - jinak - s fitrováním dat v SQL dotazu'

Parametry listu ve výkazu:

filtr_trida='6'

filtr_rok=trans(year(date()))

sql_sp11idzak_like='ABC%'

Název listu ve výkazu - 'Zisk letos - členění podle TVS'

Parametry listu ve výkazu:

filtr_trida='6'

filtr_rok=trans(year(date()))

oblast_ors=1

oblast_tvs=4

Název listu ve výkazu - 'Zisk letos - členění podle OBS'

Parametry listu ve výkazu:

filtr_trida='6'

filtr_rok=trans(year(date()))

oblast_ors=1

oblast_obs=4

Název listu ve výkazu - 'Zisk sumárně (rok ve sloupcích) - poslední čtyři roky'

Parametry listu ve výkazu:

filtr_trida='6'

oblast_rok=3

popisky_rok=[VAL(_pivotitem.value) > year(date())-4]

rozbaleni_rok=[.F.]

* rozbaleni_rok=[.F.] - rok bude mít podřízené popisky Měsíce a [.F.] (FALSE) způsobí to, že nebudou po vytvoření listu vidět (v Excelu 2007 se měsíce jednotlivých roků zobrazují jako podsložky - nebudou rozbalené)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 13.05.2009


Pojem - Kontrola dat před zápisem

Počínaje verzí BM 19.1.2004 je při zápisu dat prováděna závěrečná kontrola dat v jediném cyklu. Ve starších verzích byla tato kontrola na některých formulářích prováděna vícekrát.

Protože se tato funkce vyskytuje na všech formulářích BM, není možné udělat jejich kontrolu na 100%. Přestože je předpoklad, že to nebude nutné, nastavením "Zapis_Dat_Pocet_Cyklu=1" v sekci "Transient" je možné obnovit původní chování BM při jeho chybách vyplývajících z této programové změny bez nutnosti instalace opravené verze BM.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.11.2007


Pojem - Kontrola překlepů

Z okna pro vstup textu vyvolávaného na polích typu text (memo) klávesou F2 nebo pravým klikem na položce nebo jejím návěští je možné po pravém kliku nebo F2 vybrat nově také volbu Kontrola pravopisu. Uživateli se zobrazí formulář opravy pravopisu tak jak ho znají z používání programu Word.

Tato funkce vyžaduje na počítači instalovaný minimálně Word 2000 (ve starších verzích kontrola pravopisu není funkční).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 09.10.2007


Pojem - Konvertor Winword

Konvertor WINWORD lze v IS BM nadefinovat v činnosti Předlohy dokumentů na záložce Další.

Konvertor WINWORD je interní objekt BM, který je používán také při výstupu předlohou typu Word. Pro definici konverze může skript použít 'Definici pro konvertor WINWORD' uvedenou v předloze dokumentu. Ve formuláři 'Předlohy dokumentu' je možné spustit volbu z menu Volby - Editovat definici pro konvertor WINWORD (nebo funkční klávesa F7), kterou je vyvolán formulář pro vstup definice konverze stejný jako při definování předlohy výstupu typu Word.

Kromě použití konvertoru WINWORD je možné použít skript např. pro:

- načtení dat mailmerge po otevření dokumentu (prvním založení nebo každém otevření) - Word 2003 toto sám automaticky neprovádí

- vytvoření vlastního specifického mailmerge (mailmerge může být tímto způsobem použit bez nutnosti propojení s operací pošty)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 02.04.2010


Pojem - Konverze pro štítek

Tato činnost se nachází v hlavním menu v činnosti Adresář – Číselníky a parametry. Nadefinováním jednotlivých atributů konverze (tj. přeměna, změna, obrat) si uživatel určuje, jakým způsobem mají být naplněny informace tištěné na štítek z události poštovní zásilky, např. u právnické osoby chce mít uživatel oslovení, jméno a úplný název adresáta (Vážený pan, Jan Novák, firma xxx), ale u fyzické osoby mu stačí oslovení a jméno (Vážený pan, Jan Novák).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 03.03.2008


Pojem - Korektor transformovaných dat

Korektor je možné nadefinovat ke každému druhu procesu a úzce souvisí s formátem ISDOC. Korektor představuje definici kódu v jazyce FoxPro, který je spouštěn v rámci zpracování fyzického procesu v okamžiku po provedení všech transformací do operace těsně před tím, než jsou data předplněná transformací zobrazena uživateli ve formuláři operace. Korektor se definuje na druhu procesu (hlavní menu – Informační centrum – Typy a řady – Druhy procesů) na první záložce „Druhy procesů“. Obsahuje tyto atributy:

¨ korektor – identifikace a název korektoru

¨ druh – identifikace druhu implementačního rozšíření (pomocí tohoto druhu jsou řízena přístupová práva k danému korektoru). Použít tento korektor může uživatel, který má k danému druhu právo alespoň čtení.

¨ sada – identifikace a název sady systémových konstant

¨ kód – kód korektoru v jazyce FoxPro

¨ poznámka – vlastní poznámka uživatele

¨ datum a čas aktualizace

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 06.11.2009


Pojem - Krmný den

Den, ve kterém je dané zvíře ustájeno, tento den má ujednané ocenění s chovatelem. Toto ujednané a vyfakturované ocenění definuje zvýšení ceny zvířete. Obvyklá zkratka je KD a je to den, pro který je zvíře evidováno v informačním systému.

U kategorie (činnost „Kategorie zvířat“) se určuje, že se pro zvířata v dané kategorii mají počítat KD (zaškrtnutím atributu „KD“). Podle nastavení parametru „Započítávat stavy do KD“ (činnost „Parametry komp. sklad zvířat“) hodnotou „Počáteční stavy“ nebo „Konečné stavy“ se v IS počítají KD v den, kdy byla evidována událost. Tzn. je-li zadána hodnota „Počáteční stavy“ – potom se KD počítají pro zvířata, která v den události byla vyřazena (na počátku dne ještě byla ve stavech) a nepočítají se pro zvířata která byla v den události zařazena (na počátku dne ještě nebyla ve stavech). Obdobně pro hodnotu „Konečné stavy“ se KD počítají pro zvířata, která v den události byla zařazena a nepočítají se pro zvířata která byla v den události vyřazena.

První obrat pro zvolenou kategorii a umístění je určen prvním zápisem hodnoty „Množství v MJ pro výpočet KD“ (činnost „Parametry komp. sklad zvířat“ – obv. množství v naturálním vyjádření) do obratů. Od tohoto data se kontrolují stavy (počáteční/konečný) za všechny dny až do zadaného data vůči událostem, které mají shodné: datum, umístění, kategorii a druh operace má nastaven v činnosti Parametry operace komponenty „výpočet KD“. Není-li stav shodný, je vygenerován záznam operace s rozdílovým množstvím. Je-li ke kategorii přiřazena stejná cenová skupina (činnost „Kategorie zvířat“ – horní lišta „Volby“ – položka „Ceník artiklu“), jako je zadána v parametru „Cenová skupina pro výpočet vzrůst. přír.“ (činnost „Parametry komp. sklad zvířat“), je množství krmných dnů zároveň oceněno (tj. vyhodnocen vzrůstový přírůstek) dle ceny uvedené v ceníku.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.11.2007


Pojem - Kupní smlouva

Dvoustranný právní úkon, shodný projev vůle dvou smluvních stran, ze kterého jedné straně (prodávajícímu) vzniká povinnost předmět koupě odevzdat a druhé straně (kupujícímu) povinnost předmět koupě převzít a zaplatit za něj dohodnutou kupní cenu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.02.2008


Pojem - Kurzor

Je to dočasná tabulka vytvářená při běhu IS BM na stanici uživatele. Zpravidla obsahuje výstupy SQL dotazu. Ve formulářích se nepracuje přímo s databázovými tabulkami, ale právě s kurzory, tzn. že přístup je pomocí těchto kurzorů.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Label (tučný nadpis – návěští atributu)

V IS BM představuje label pro uživatele zdroj dalších okamžitých informací k aktuálnímu záznamu. Label je tučný nadpis, který je obsažen v okně vybraných činností. Po stisku pravého tlačítka myši na labelu se uživateli zobrazují další dostupné informace k aktuálnímu záznamu. Např. label v adresáři poskytuje informace o aktuálních hodnotách adresáta (tzn. jeho platbách, událostech skladu, obchodu, změnách stavu peněz), jeho adresách, bankovních spojeních, stromu adresáta apod. Label poskytuje uživateli ucelené informace o aktuálním záznamu v jeden okamžik.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Label – Téma

Výjimku tvoří label Téma v událostech vývěsky, který v sobě po stisku pravého tlačítka myši nenese žádné další informace, ale který po dvojkliku levého tlačítka myši vybere události toho tématu, na kterém byl aktivován dvojklik, tzn. že funguje jako rychlý výběr podle tématu. Zpátky do původního zobrazení všech vybraných událostí se uživatel dostane stiskem ikonky „návrat zpět“ v dolní části okna činnosti události vývěsky.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Legislativní konstanty

Tato činnost poskytuje uživateli přehled jednotlivých hodnot systémových konstant. Definice systémových konstant se provádí v činnosti „sady systémových konstant“. Tato činnost poskytuje uživateli už pouze výsledné hodnoty konstant.

Činnost „legislativní konstanty“ (menu Mzdy – Definice) obsahuje konstanty (údaje), které jsou limitující pro rozhodnutí o položení některého z dotazů při běhu činnosti optimalizovaný výpočet mezd. Tyto legislativní konstanty dostává 1x ročně uživatel od svého implementátora ve formě balíčku dat. Jsou to:

¨ výše minimální mzdy měsíční

¨ výše minimální mzdy hodinové

¨ limit placení sociálního pojištění

¨ plánovací kalendář se základní pracovní dobou

Kromě těchto údajů obsahuje tabulka legislativních konstant i údaje, které se týkají hodnot, které byly dříve uvedeny v parametrech. V současné době jsou do tabulky legislativních konstant přesunuty všechny parametry, jejichž hodnota se dá vyjádřit číslem.

Konstanta | Identifikace | Hodnota | Poznámka | Změny od 1.1.2009
Odvod SP zaměstnanec | mz27spzam | 8 |  | 0
Odvod SP organizace | mz27sporg | 26 |  | 0
Limit soc. poj. | mz27limsp | 400 |  | 2000
Sazba zdrav. poj. | mz27zpsazb | 13,5 |  |
Vym. základ ZP | mz27zpstat | 0 |  |
Min. mzda měsíční | mz27zpnepl | 8500 |  |
Min. mzda hodinová | mz27minhod | 50,60 |  |
Sazba (promile) | mz27zakpoj | 2 | Zákonné pojištění odpovědnosti |
Procento min. mzdy při invalidním důchodu | mz27inval | 50 | Práce s minimální mzdou |
Procento min. mzdy při část. invalidním důchodu | mz27cinval | 75 | Práce s minimální mzdou |
Limit odprac. dnů (průměrný výdělek) | mz27dnuodp | 21 |  |
Dolní limit vyplacení měs. daň. bonusu | mz27dzbol1 | 50 |  |
Horní limit vyplacení měs. daň. bonusu | mz27dzbol2 | 4350 |  |
Limit penz. a život. poji. | mz27penzli | 24000 |  |
Max. vym. základ pro SP | mz27vymz |  |  | 1 130 640
Limit hodin pro DPP | mz27limdpp | 150 | Dohoda o provedení práce |

V souvislosti se změnami v evidenci nemocenských dávek pro rok 2009 došlo k několika změnám ve stávajících konstantách (viz. tabulka) a zároveň byly zavedeny nové legislativní konstanty:

¨ trvání náhrady mzdy (kal.) - identifikace mz27nahrde - hodnota 14

¨ odvod důchodového pojištění zam. - identifikace mz27duczam - hodnota 6,5%

¨ odvod nemocenského pojištění zam. - identifikace mz27nemzam - hodnota 0%

¨ odvod na politiku nezaměstnanosti zam. - identifikace mz27stpzam - hodnota 0%

¨ odvod důchodového pojištění org. - identifikace mz27ducorg - hodnota 21,5%

¨ odvod nemocenského pojištění org. - identifikace mz27nemorg - hodnota 2,3%

¨ odvod na politiku nezaměstnanosti org. - identifikace mz27stporg - hodnota 1,2%

Vysvětlení:

Konstanta „trvání náhrady mzdy (kal.)“ byla zavedena pro účely náhrady mzdy. Náhrada mzdy se nyní poskytuje po dobu 14 kalendářních dnů podle pravidel, která jsou uvedena v činnosti „Parametry nemocenských dávek“. V r. 2009 je nutno zvlášť vyčíslovat „odvod na důchodové pojištění“, a proto se původní konstanty (odvod SP zaměstnanec a odvod SP organizace) rozdělily každá na tři samostatné, tzn. odvod důchodového pojištění, odvod nemocenského pojištění a odvod na politiku nezaměstnanosti (každá z těchto konstant je za zaměstnance a organizaci).

Poznámka ke konstantě „Limit hodin pro DPP“:

¨ Pokud konstanta nebude ve verzi definována, výpočet to nahlásí, ale bude pokračovat. Test dosažení limitu hodin pro DPP nebude proveden.

¨ Pokud konstanta bude definována, ale její hodnota nebude zadána, pak výpočet nebude pokračovat.

¨ Pokud konstanta bude definována i zadána, bude proveden test dosažení limitu hodin pro DPP.

Definici legislativních konstant lze využít např. i při stanovení výměry na dovolenou.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 03.12.2013


Pojem - List vlastnictví

Doklad evidence vlastnictví a věcných práv v katastru nemovitostí. Součást souboru popisných informací KN. Obsahuje jméno (název) vlastníka (spoluvlastníků), rodné číslo nebo číslo právnických osob, seznam nemovitostí, které vlastník (spoluvlastníci) v katastrálním území vlastní s uvedením jejich parcelních čísel, příp. evidenčních a údaje o právních vztazích k nemovitostem.

„Jeden z výstupů (sestava) souboru popisných informací katastru nemovitostí ČR, který obsahuje výčet nemovitých věcí evidovaných v katastru nemovitostí podle jejich vlastníků či spoluvlastníků a jiných oprávněných s údaji o právních vztazích k nemovitostem; běžně se užívá zkratka "LV“. Údaje v něm obsažené se dokládají stavební spořitelně originálem či úředně ověřenou kopií výpisu z katastru nemovitostí. Jedná se o veřejnou listinu, v níž se osvědčují údaje o nemovitostech zapsané v katastru nemovitostí. Za vyhotovení výpisu se platí správní poplatek."

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.02.2008


Pojem - Logické tiskárny

Vlastnosti předlohy výstupu (záložka Info) byly doplněny o možnost určení "Logické tiskárny". Logická tiskárna určuje nepřímo skutečnou fyzickou tiskárnu, na kterou má být proveden výstup. Logické tiskárny se definují v menu SYSTÉM spolu s dalšími souvisejícími objekty. Jsou to:

1. Logické tiskárny

2. Fyzické tiskárny

3. Pracoviště uživatelů BM

4. Počítače uživatelů BM

Logická tiskárna (1.) je propojena s pracovištěm (3.) a v této vazbě je odkaz na fyzickou tiskárnu (3.). Pracoviště (3.) definuje množinu počítačů (4.), které mají z hlediska výstupu na tiskárnu shodné vlastnosti. Přidělení logické tiskárny předloze výstupu má význam při přímém výstupu na tiskárnu klasickou předlohou nebo předlohou typu Excel.

Je-li uvedena, potom při přímém výstupu BM před tiskem vyhledává podle systémové (Windows) identifikace počítače (4.) vazbou pracoviště (3.) na danou logickou tiskárnu (1.) konkrétní fyzickou tiskárnu (2.), na kterou má být proveden výstup. Je-li taková fyzická tiskárna nalezena, potom BM vloží do předlohy parametry nalezené tiskárny. Není-li nalezena, potom je před tiskem uživatel vyzván k výběru tiskárny, i když podle profilu měl být proveden přímý výstup bez dotazu na výstupní tiskárnu.

Fyzická tiskárna k logické tiskárně není nalezena v případě, že pro odpovídající pracoviště není definována vazba na odpovídající logickou tiskárnu nebo není-li fyzická tiskárna aktivní (vlastnost objektu fyzická tiskárna).

Příklady logických tiskáren:

¨ výstup na hlavičkový papír

¨ výstup na běžný papír

¨ výstup na obálky

¨ výstup na etikety

¨ ....

Má-li skutečná tiskárna více příhradek pro vstup papíru, je pro ní možné definovat více fyzických tiskáren. Tato možnost se bohužel neuplatní při výstupu předlohou typu Excel.

Nastavení parametrů fyzické tiskárny se provádí v předhledu fyzických tiskáren klávesou F5, po které se zobrazí prázdná výstupní předloha, ve které se volbou menu "Soubor" -> "Vzhled stránky" určí parametry tiskárny. Tiskárny uvedené v metapředlohách jsou logické tiskárny. Metapředloha může změnit logickou tiskárnu definovanou v ní obsažené předloze. Při výstupu do Excel je v ní možné určit současný výstup na více různých logických tiskáren.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Mailmerge (hromadná korespondence)

Funkce mailmerge (v programu Word nazývána také jako hromadná korespondence) umožňuje rychle vytvářet různé dokumenty kombinací (sloučením) informací ze dvou různých souborů. Pro správný chod funkce mailmerge je nutno mít vytvořen hlavní dokument a připraven zdroj dat. Ve slovníku pojmů nebudeme popisovat chování hromadné korespondence ve Wordu, ale pokusíme se ve stručnosti popsat chování IS BM. Proto, aby mailmerge fungoval bez problemů je nutno mít zdroj dat (textový soubor), u předlohy dokumentu uvedenou cestu na tento zdrojový soubor a uvedenou příponu TXT. Při použití dané předlohy se tento zdrojový soubor vytvoří sám automaticky. V dané předloze je nutno mít nadefinována slučovací pole, která jsou pak právě při použití funkce mailmerge nahrazena konkrétními údaji. Praktické použití mailmerge je potom následující:

¨ uživatel si na základě předlohy dokumentu (ta má zatržen příznak mailmerge) vytvoří dokument

¨ po stisku pravého tlačítka myši na dokumentu vytvoří proces pošty, tzn. spojí dokument s událostí pošty, kde je právě uvedena informace o adresátu (nebo za pomoci hromadné šablony o adresátech)

¨ na poštovní události si pak uživatel vyvolá daný dokument (pomocí Ctrl D) a pomocí funkce programu Word hromadná korespondence „sloučit“ provede změnu slučovacích polí za konkrétní data adresátů uvedených v události pošty (v různých verzích programu Word může být použití „hromadné korespondence“ z hlediska ovládání uživatelem různé, nicméně princip této činnosti zůstává stejný).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.12.2007


Pojem - Mapa přístupových práv

Činnost se nachází v menu Informační centrum – Typy a řady – Mapa přístupových práv. Tuto činnost je rovněž možno vyvolat po stisku klávesy F5 při definování práv AAA, druhu procesů apod. V tomto případě se zobrazí omezený počet práv odpovídajícího druhu (tzn. pokud uživatel spustil mapu z činnosti druhy procesů, zobrazuje se mu mapa přístupových práv pouze k činnosti druhy procesů).

Po její aktivaci jsou jednotlivá nadefinovaná práva zobrazena v mřížce, kde se zobrazuje druh a název činnosti a sloupečky – zápis, čtení, žádné právo. Po stisku pravého tlačítka myši ve vybraném sloupečku (záleží na tom, jaké právo chceme přiřadit či naopak odebrat) se uživateli zobrazí okno s těmito možnostmi:

¨ aktuální přístupová práva skupiny – při pohybu po šipce je možno je změnit

¨ přidat skupinu uživatelů - na základě výběru skupiny a podle toho v jakém sloupečku uživatel stojí (zápis, čtení, žádné právo) se přiřadí vybrané právo dané skupině uživatelů

¨ přidat právo uživatele - na základě výběru uživatele a podle toho v jakém sloupečku uživatel stojí (zápis, čtení, žádné právo) se přiřadí právo vybranému uživateli.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.12.2007


Pojem - Mapy

Pomocí doplňující vlastnosti formuláře „Mapa“ lze z činnosti Adresář spustit internetovou aplikaci „mapy Google“. Tím má uživatel možnost vytvořit si trasu k vybranému uživateli a

zobrazit si ji i na mapě. V zobrazené mapě je vyznačena trasa s adresou aktuálního adresáta nebo trasa mezi adresami označených adresátů. Trasa je vyznačena v pořadí adres, ve kterém byli

adresáti označováni (v aplikaci „mapy Google“ lze pak pořadí adres případně změnit). Počet adres na trase je omezen na 25. Při vytváření trasy uživatel zadává startovní a cílovou adresu.

Zobrazení mapy předchází dotaz, ve kterém je možné pro zobrazení trasy určit startovní a cílovou adresu. V případě, že uživatel chce trasu vyznačit jako „kolečko“, tzn. od nás k zákazníkovi (nebo více zákazníkům) a znovu zpět do sídla firmy, zatrhne příznak „zahrnout cílovou adresu do trasy“ u atributu cílová adresa (pak je v podstatě vyznačena trasa od nás k zákazníkovi a zpět).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.08.2008


Pojem - Masky operace

Masky operace jsou jedním z nástrojů pro automatizaci vstupu dat (usnadnění) do událostí. Pomocí masky lze v rámci implementace "maskovat" vstupní atributy komponenty, tj. lze definovat zejména:

¨ předplňování vstupovaných údajů události konstantou, resp. konstantou s určitou závislostí na již vstoupených údajích (v případě používání identifikátorů (konstant) v uživatelských nastaveních je nutno uživatele upozornit na to, že identifikátory je NUTNO uvádět velkými písmeny, např. druh artiklu nesmí být v masce uveden jako „mat“, ale musí být zapsán ve tvaru „MAT“).

¨ omezení množiny vstupovaných údajů (atributů) události

Maska je vlastností druhu operace s případným přihlédnutím k druhu procesu, resp. k uživateli.

Všechny masky lze definovat při spuštění operace (i když neobsahuje události) z menu Obecné. Maska operace v procesu a vstupní maska operace se definují přímo v diagramu (druhu) procesu na vlastnostech operace[1]. Vstupní masku operace a masku operace v procesu je možno definovat i u druhu operace v příslušné činnosti pod menu Obecné (osobní masku je možno definovat pouze ZDE), tzn. daná operace je aktivována a pod menu Obecné má uživatel dostupné tyto masky. Při jejich změně v tomto okamžiku je pak nutné ještě aktivovat činnost „obnovení masky“ (rovněž menu Obecné). Při definování osobní masky je nutno dodržet zásadu, že nejlépe se definuje pod heslem toho uživatele, pro kterého je tato osobní maska vytvářena (tzn. do IS BM musí být provedeno přihlášení pod heslem tohoto uživatele), jinak je zápis do definice osobní masky možno zajistit volbou pamatovat (viz. popis dále). Osobní maska se definuje přímo ve spuštěné fyzické operaci pro kterou má být maska nastavena (menu Obecné – Masky – Osobní maska).

Při aplikaci masky může nastat i situace, kdy maska má nastavené odlišné hodnoty pro předplnění vstupovaných dat, než jaké jsou nadefinovány v transformaci. V tomto okamžiku systém uplatní nástroj s vyšší prioritou, a to jsou pravidla explicitně nastavená v transformaci. Jinak v případě nastavení všech masek jsou priority následující: osobní, maska operace v procesu, vstupní maska operace.

Po vyvolání činnosti pro definici masky operace se obecně postupuje stejně pro všechny typy masek. Stiskem F3 se zpřístupní formulář pro zadávání atributů v masce. Je možno zadat:

¨ atribut - překryvný seznam všech dostupných atributů, které může uživatel v maskách využít

¨ pořadí atributu

¨ inicializovat - uživatel má k dispozici volbu Ne, Konstantou, Výrazem. Volbu Ne uživatel použije v případě, že žádný atribut nechce přímo vstupovat (předplňuje se např. transformací), ale potřebuje

u něj nastavit např. reakci opakovat. Konstantu uživatel využije, pokud chce do masky zadat rovnou identifikaci atributu, např. identifikaci skladu, druh artiklu, číslo selektoru apod. Volbu Výrazem

uživatel použije tehdy, pokud atribut nechce vstupovat, ale určitým výrazem doplnit, vypočítat apod. Může si vybrat výraz z překryvného seznamu, pokud mu žádný v daný okamžik nevyhovuje, je možno

vytvořit nový.

¨ konstanta - v případě, že uživatel inicializuje konstantou, právě sem zapisuje její hodnotu (hodnota konstanty – identifikátoru musí být uvedena velkými písmeny, např. MAT)

¨ výraz - výběr výrazů z překryvného seznamu. Po stisku F2 a následném stisku F3 má uživatel možnost si nadefinovat výraz nový. Při vstupu událostí komponent byla doplněna možnost dynamicky

předplňovat nevyplněný atribut na základě informace uvedené v masce operace. Pro atribut v masce se zadává inicializovat konstantou nebo výrazem. Ve výrazu je uveden text v syntaxi ##V <výraz>.

Ve výrazu mohou být uvedeny znaky $$$, které budou nahrazeny odpovídajícími alias komponenty (použití dynamické inicializace v masce operace nemusí vždy fungovat, pokud ji přebíjí dynamická

inicializace atributu naprogramovaná ve formuláři. To nastává v případě, že programátorem naprogramovaná dynamická inicializace není umístěna bezprostředně před vstup atributu. Úplné dořešení

tohoto problému bude po dalším doplnění funkčnosti masek operací).

¨ validace - zde uživatel uvádí výraz, podle kterého se daný atribut bude kontrolovat. Např. uživatel může chtít kontrolovat, zda uživatel v atributu „datum splatnosti" uvádí správný datum (tzn. ve

správném tvaru, že se nepřepsal a omylem místo r. 2002 neuvádí např. pouze jen r. 02). Pak je u atributu datum splatnosti uvedena validace v následujícím tvaru: between(###,ctod('01/01/1900'),

ctod('01/01/2101'))

¨ chyb. hlášení - souvisí s uvedenou validací. Pokud validace u daného atributu zjistí nějakou nesrovnalost, může si tu uživatel nadefinovat chybové hlášení, které se pak při vstupu dané masky

zobrazí uživateli v okně činnosti. Např. právě při chybně vstoupeném datu splatnosti se objeví hlášení „chybný interval data splatnosti". Chybová hlášení si definuje uživatel sám podle svých vlastních potřeb.

¨ interní validace – překryvný seznam Zapnuta/Vypnuta - nastavení Vypnuta způsobí to, že při vstupu události nebude na daném atributu prováděna validace naprogramovaná BM.EXE

¨ interní předplňování - překryvný seznam Zapnuto/Vypnuto - nastavení Vypnuto způsobí to, že při vstupu události nebude daný atribut dynamicky předplňován tak, jak je naprogramován v BM.EXE

Pozn.: Nevhodné vypnutí interní validace může způsobovat chybné chování systému (např. pro datumové položky doporučujeme kombinovat vypnutí interní validace s validačním výrazem 'NOT EMPTY(###)' ). Na atributu Validace lze aplikovat klávesu F2, kterou se do něho předplní výraz validace atributu, tak jak byla naprogramována v BM.EXE.

¨ F2 reakce - v případě, že by uživatel chtěl při zadávání masky vstupovat i do určitých číselníků (např. adresář, seznam artiklu apod.) a případný atribut si přímo vybrat.

¨ nastavit 1. - při volbě Ano to znamená, že uživatel nastavil první vstupní údaj, což je údaj (atribut), který se bude uživatel při vytváření událostí daného druhu operace <> zadávat jako první, pokud

validace dat <> nepostaví kurzor již na předchozí . Pokud je tento údaj v událostech např. až třetí v pořadí, tak je vhodné zajistit, aby údaje před ním byly správně zadány (tj. zejména, aby byly schopné

úspěšně projít validací), např. je při vstupu první události operace v pořádku zadat a u těchto atributů nastavit v masce volbu „opakovat", pak bude při vstupu další události kurzor stát na třetím atributu.

¨ editovat - volba Ne znamená, že v události není možno tuto hodnotu editovat (atribut je šedý a nepřístupný), obvykle se užije po předplnění hodnoty maskou, transformací, nebo nemá v dané

události význam

¨ opakovat - volba Ano znamená, že tato hodnota (tento atribut) se při vstupu jednotlivých událostí v operaci vždy opakuje podle první události, je však v případě potřeby přístupná editaci

¨ pamatovat - pokud je v masce zadána konstanta, pak při prvním použití operace daného druhu od nastavení masky každým uživatelem se tato konstanta zapíše do jeho osobní masky. Pokud není v

masce zadána žádná konstanta, pouze je u atributu nastaveno pamatovat, tak uživatel při prvním vstupu události daného druhu operace tento údaj vyplní ručně a tento se pak rovněž zapíše do jeho

osobní masky operace, tzn., že při dalším spuštění daného druhu operace budou tyto údaje již předplněny z osobní masky. Pokud se časem zjistí, že nastavené údaje jsou chybné, je nutno je opravit přímo

v osobní masce (tzn. pod heslem daného uživatele).

V masce operace je v případě potřeby možno užít obecnou předkontaci.

[1] Vlastnosti operace se vyvolají stiskem pravého tlačítka myši na uzlu operace.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 01.11.2012


Pojem - Materialized View

Následující text nám uživatelským pohledem zpřístupní popis nové technologie MATERIALIZED VIEW, která byla zahrnuta do definice informačního panelu a umožňuje tím uživateli tzv. „multidimenzionální pohled“ na zobrazené informace.

V současné době je tato novinka zapracována v Informačním panelu – „Kampaně“, který uživateli poskytuje přehled jednak o počtu provedených kampaní, počtu oslovených zákazníků atd., ale zároveň i další pohled z jakého kraje či okresu byli, kolik mají zaměstnanců a další. Zpracování informačního panelu a jeho možnosti si nyní podrobněji popíšeme.

Po aktivaci informačního panelu se uživateli zobrazí následující výběrový formulář. Ten je postaven na výběru jednotlivých atributů, přičemž každý tento výběrový atribut přestavuje kategorii adresáta (předtím byl proveden import adresátů do systému IS BM a každému adresátovi podle obratu či počtu zaměstnanců a dalších výběrových kritérií byla přiřazena příslušná kategorie).

Do tohoto okamžiku se zatím výběr tváří a chová jako klasický běžný výběr, který uživatelé využívají při práci s IS BM již zcela standardně. Podstatná je poslední řádka ve výběru „Skupiny“. Právě její zvolení (analýza podmnožiny výběru) umožňuje uživateli výše zmíněný „multidimenzionální pohled“ (až 4 možné dimenze). Na obrázku je zvolen v řádku „Skupiny“ výběr pouze za Kampaň.

Po stisku tlačítka Vyhledat má uživatel pak dostupné následující informace:

Jednak příslušné údaje za jednotlivé kampaně, protože ve výběru byly zvoleny všechny kampaně a zároveň celkový skupinový pohled za kampaně dohromady.

Když si zvolíme ve výběru pouze určitou kampaň a více specifikujeme dimenze řádku Skupina, bude uživatel překvapen jak podrobně mohou být informace dostupné.

Takže při zadaném výběru za všechny kampaně, ale zároveň podle definice posledního řádku rozčleněné za kampaň, kraj a okres, viz. obrázek

jsou potom po stisku tlačítka „vyhledat“ informace následující:

Tlačítko „Celkem–detail“ funguje v podstatě jako přepínač. Při prvním zobrazení má uživatel dostupnou informaci celkem za zvolenou dimenzi (kritérium), při dalším stisku tohoto tlačítka se mu naopak rozbalí seznam s detailními informacemi. Při jeho dalším stisku se tento seznam zase sbalí. Takže podle zvoleného výběru má uživatel k dispozici informace celkem za jednotlivé kampaně, celkem za jednotlivé kraje a celkem i za jednotlivé okresy.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 18.09.2014


Pojem - Menu

Menu informačního systému Bílý Motýl vždy vychází ze základní definice menu, která je dodávána společně s dodávkou IS. Na základě základní definice menu je možno si podle potřeby odvodit menu nová, která se pak stávají pro daného uživatele nebo skupinu uživatelů hlavním menu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Měsíční nezdanitelné položky

Údaje, které se zadávaly na této záložce byly platné do prosince 2005. Jednalo se o částky, o které je možné snížit základ daně – v současné době nahrazeno na záložce daňová zvýhodnění.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 11.10.2007


Pojem - Message

Jedná se o krátkou poznámku k atributu (položce), která je v danou chvíli v okně aktivní (je na ní umístěn kurzor). Message se uživateli zobrazuje v levé dolní části okna (ve spodní liště).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.12.2007


Pojem - Metapředloha výstupu

Je objekt, který v sobě skrývá jednu nebo více skutečných předloh výstupu systému BM vytvořených pro jednotlivou činnost (formulář). V datovém modelu systému jsou objekty spojovány s předlohami výstupu právě pomocí objektu "metapředloha výstupu" (např. předloha výstupu pro doklad spojený s druhem procesu, doklad tištěný podle předlohy druhu operace v diagramu procesu ...).

Výstup podle předlohy výstupu zařazené v metapředloze výstupu může být podmíněný. Podmínka výstupu předlohou se vyhodnocuje v okamžiku tisku a je uváděna v definici metapředlohy v syntaxi jazyka Foxpro. Může obsahovat makra. Typickým příkladem makra může být zjištění národnosti aktéra, kterého se týká proces faktury. Odpovídající makro může v sobě použít funkce BM pro SQL dotaz a přitom použít proměnné _sp33cisdr, _sp33cisdpm, _sp33cisd, _sp06idsubs, _sp07idtyp a _sp33porad, které identifikují aktuálně vystupující operaci/proces.

Po aktivaci činnosti metapředlohy výstupu (z činnosti komponenty nebo po stisku pravého tlačítka myši kdekoliv v prostoru činnosti předlohy výstupu) má uživatel k dispozici tyto informace:

¨ záložka metapředlohy výstupu – identifikace a název metapředlohy a její druh (pomocí atributu druh jsou definována přístupová práva). U každé metapředlohy výstupu lze určit její skupinu (zařazení předloh výstupu a metapředloh do skupin lze pak využít při stromovém zobrazení v činnosti Výstupy). Atribut nabízet (volba Ano/Ne) určuje, zda se bude samotný název metapředlohy také nabízet v seznamu předloh výstupu.

¨ záložka předlohy v metapředloze – obsahuje jednotlivé předlohy výstupu zařazené pod danou metapředlohu. U každé předlohy se určuje pořadí, název, jazyk, profil, počet kopií atd. Důležitým atributem je „rozhodnutí“. V případě, že metapředloha obsahuje pouze jednu předlohu výstupu, uživatel zde ponechá volbu Ne, tzn. po aktivaci dané metapředlohy bude rovnou probíhat tisk dané předlohy výstupu na základě zadaného profilu. Pokud metapředloha obsahuje více předloh výstupu a uživatel si při vlastním tisku má z tohoto seznamu vybírat, musí mít tyto předlohy nastaveno default nepřipravena. V případě, že metapředloha obsahuje více předloh výstupu, z nichž jedna je ta implicitní, kterou uživatel tiskne např. v 90% případů, ale ostatní chce mít také k dispozici ve výběru, je možno u této implicitní nastavit default připravena a ostatní předlohy budou mít stále default nepřipravena. Při samotném tisku se v rozhodovacím okně pak implicitní předloha nabízí k tisku automaticky, ale v případě potřeby je možno ji změnit za jakoukoliv sestavu z přehledu předloh tisku.

¨ záložky výskyt poskytují uživateli informační přehled o tom, kde jsou dané metapředlohy zastoupeny

Předloha výstupu v metapředloze výstupu může být prováděna s některými jinými vlastnostmi než s těmi, které jsou uvedeny u dané předlohy (tzn. že pokud se liší nadefinované vlastnosti předlohy od vlastností, které jsou uvedeny v metapředloze, je metapředloha silnější nástroj a při tisku budou uplatněny její vlastnosti). Jedná se o:

1. výstupní jazyk

2. počet kopií

3. profil výstupu

4. navíc pro předlohu typu Excel může definovat výstup na určenou jednu nebo několik různých tiskáren (ve výrazech je možné používat makra)

Kromě toho může být vlastností předlohy výstupu v metapředloze určeno, že při výstupu metapředlohou uživatel rozhodne, která nebo které její předlohy mají být v danou chvíli užity.

Metapředlohu je také možné používat volitelně jako běžnou předlohu (tj. může být použita ze seznamu předloh výstupu činnosti). Metapředloha výstupu stejně jako předloha výstupu má určena přístupová práva druhem předlohy (stejná entita). Při výstupu metapředlohou se na práva přístupu v ní obsažené předlohy nepohlíží.

Seznam metapředloh je možné vyvolat v činnostech "Druhy procesů" a "Druhy operací" klávesou F2 při vstupu, v činnosti "Komponenty" z menu Volby a ze seznamu předloh výstupu činnosti výběrem z menu po pravém kliku myší.

Postup při definování metapředlohy výstupu z operace:

¨ uživatel v diagramu procesu vybere operaci, na níž chce nastavit, že po jejím ukončení se má tisknout vybraná předloha. Ve vlastnostech této operace (pravé tlačítko myši na uzlu operace) zatrhne „po ukončení operace tisk operace“. Z překryvného seznamu si zvolí vhodnou metapředlohu (v definici této metapředlohy je uvedena tisková předloha, která se po ukončení operace bude skutečně tisknout).

¨ vytvoření metapředlohy je možno trojím způsobem. V menu Informační centrum – Typy a řady – Druhy operací si uživatel vyhledá danou operaci a na atributu metapředloha stiskne F2 nebo pravé tlačítko myši. Uživatel má možnost si vybrat z již vytvořených metapředloh nebo si vytvořit metapředlohu novou. K ní pak přiřadit vhodnou tiskovou sestavu. Druhý způsob je přímo nad událostmi dané komponenty. Uživatel si vyvolá okno výstupu (menu volby Tisk nebo Ctrl T) a kdekoliv v prázdném prostoru tohoto okna po stisku pravého tlačítka myši zvolí možnost metapředlohy výstupu. Poslední způsob, jak může uživatel editovat či vytvářet předlohy je z menu Informační centrum – Typy a řady – Komponenty, kde v menu Volby je pro každou komponentu dostupná možnost metapředlohy výstupu.

¨ každá metapředloha může obsahovat „n“ tiskových předloh. Tyto předlohy jsou předlohy vytvořené „klasicky“ nad událostmi dané komponenty.

Postup při definování metapředlohy výstupu z procesu:

¨ v diagramu druhu procesu uživatel ve vlastnostech operace (té operace, jejíž události vstupují na tisk dokladu jako poslední) zatrhne atribut „po ukončení operace tisk dokladu“.

¨ v menu Informační centrum – Typy a řady – Druhy procesů u zvoleného druhu procesu nastaví po stisku F2 nebo pravého tlačítka myši metapředlohu výstupu. Může vybrat vhodnou z překryvného seznamu nebo si v případě potřeby vytvořit metapředlohu novou.

¨ jednotlivé tiskové předlohy, které si pak uživatel přiřazuje k metapředlohám se pro procesy vytvářejí v menu Procesy a operace – Procesy po aktivaci činnosti tisk (menu volby Tisk nebo Ctrl T). V této činnosti uživatel stiskne pravé tlačítko myši kdekoliv ve volném prostoru okna „výstupy“. Zvolí možnost metapředlohy a zadá si novou metapředlohu k níž přiřadí vybranou předlohu výstupu.

¨ u každé předlohy výstupu vytvořené v činnosti Procesy je nutno v jejích vlastnostech (vlastnosti předlohy si uživatel vyvolá pravým stiskem myši na názvu předlohy) nastavit ještě prezentaci. Prezentace jsou nástroj, kterým uživatel určuje, které události operací daného procesu budou pro uživatele k dispozici na předloze výstupu.

¨ jednotlivé prezentace se definují v menu Informační centrum – Typy a řady – Prezentace procesů.

Objekt KU_DATA (využívá se k kódu po ukončení operace) byl doplněn o metodu OP_PRINT_META, která provádí výstup metapředlohou.

Pro předlohu výstupu uvedenou v metapředloze je možné určit parametr, který je předloze předán při výstupu metapředlohou. Má význam pro předlohy typu Excel nebo HTML, ve kterých je parametr dostupný v proměnné 'this.param1'. Např. pro pokyn předloze typu Excel, že má být odeslána Mailem, uvedeme v parametru text 'MAIL' a v kódu předlohy zadáme:

.KDYŽ !EMPTY(this.param1) AND ALLTRIM(this.param1)='MAIL'

.EXCEL_CLOSE

.MAIL_RECIPADRESS .....

.MAIL_SUBJECT ......

.MAIL_MESSAGETEXT .....

.MAIL_SEND 1

.JINAK

.EXCEL_NEUKLÁDAT

.KONEC_KDYŽ

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.06.2009


Pojem - Mimořádný odpis

Pro výpočet účetních a daňových odpisů používá uživatel programové šablony „účetní odpis“ a „daňový odpis“. V případě, že uživatel potřebuje provést částečné vyřazení odpisovaného majetku a zároveň zachovat správnou funkčnost šablon účetních a daňových odpisů, musí použít typ „mimořádný odpis“ daňový i účetní.

Vysvětlíme si postup ohledně částečného vyřazení na konkrétním případu. Firma si pořídila např. traktor s kartáčem a dalším příslušenstvím. Dne 31.7.2004 byl zadán běžný příjem na částku 173 184,87 Kč. Poté následuje sled těchto událostí (výpočty zaokrouhleny směrem nahoru):

¨ účetní odpis k datu 31.12.2004 (173 184,87 / 72) * 5 = 12 030,-

¨ účetní odpis k datu 31.12.2005 (173 184,87 / 72) * 12 = 28 872,-

¨ účetní odpis k datu 31.12.2006 (173 184,87 / 72) * 12 = 28 872,-

¨ účetní odpis k datu 31.01.2007 (173 184,87 / 72) * 1 = 2 406,-

¨ účetní odpis k datu 28.02.2007 (173 184,87 / 72) * 2 = 4 812,-. Následně se odečtou již provedené účetní odpisy za rok 2007. V tento okamžik je částka 2 406,- (4812 – 2406) uplatněna v únoru.

¨ K DATU 09.03.2007 DOJDE K ČÁSTEČNÉMU VYŘAZENÍ (kartáče) Z KARTY TRAKTORU. V tomto okamžiku je nutno provést několik nestandardních záznamů:

- 09.03.2007 je nutno zadat běžný příjem zápornou částkou, tj. minus 39 747,90 (hodnota kartáče) – vyřazení části

- 09.03.2007 je nutno provést účetní odpis s typem události „mimořádný“ jako doodepsání vyřazené části kladnou částkou 22 631,-. Tento úkon provede uživatel ručním zápisem, bez pomoci šablony. Částku odpisu je nutné si vypočítat.

- 09.03.2007 je nutno provést účetní odpis s typem události „mimořádný“ jako vynulování odpisů z událostí, tj. minus 39 747,-, jinak se zůstatková cena vypočítává ze snížené pořizovací ceny mínus celkem dosud odepsáno (tj. z původní vyšší ceny) – chybná kladná až minusová hodnota zůstatkové ceny.

¨ standardní účetní odpis k datu 31.03.2007 se potom počítá jako odpis za měsíc 01/2007 (2 406,-) + odpis za měsíc 02/2007 (2 406,-) + odpis za měsíc 03/2007 (1 854,-). Celkový odpis má hodnotu 6 666,-. Následně se odečtou již provedené odpisy za rok 2007, takže odpis za 03/2007 je částka 1 854,- (6666 – 4812) – neodečítají se odpisy „mimořádné“.

Podobné kroky je nutno provést i pro daňové odpisy. Po vyřazení kartáče (operace vyřazení je jedna událost společná pro aktualizaci účetních i daňových cen) je nutno ručně provést záznam daňový odpis ve výši dosud uplatněných daňových odpisů vyřazené části majetku, který aktualizuje zůstatkovou cenu daňovou. Tento záznam je nutné odlišit od běžných záznamů daňových odpisů, proto bude zapsán s typem „mimořádný“.

Při použití odpisu typu „mimořádný“ je vhodné zkontrolovat sestavy nad odpisovaným majetkem, zda korektně filtrují události běžné a mimořádně a případně je upravit. V závislosti na parametrech odpis v měsíci vyřazení je poté nutno aktivovat účetní odpis – v případě, že majetek má nenulovou účetní zůstatkovou cenu v okamžiku vyřazení.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 23.03.2010


Pojem - Minimální mzda

Mzda (plat) pracovníka nesmí být nižší než minimální mzda. Do mzdy se pro tyto účely nezahrnuje mzda za práci přesčas, příplatek za práci ve ztíženém a zdraví škodlivém pracovním prostředí, za práci v noci a za práci ve svátek.

Při optimalizovaném výpočtu mezd je zobrazena tabulka s pracovníky, systém vznese dotaz „Hrubý příjem je menší než min. mzda. Doplnit položku pro vyrovnání do výše minimální mzdy? Pokud ano, doplní se položka, pokud ne, ponechá se vypočtený hrubý příjem.„ a výpočet se pak dokončí podle odpovědi na dotaz.

Testuje se měsíční min. mzda nebo hodinová min. mzda podle toho, jakým způsobem je pracovník odměňován (příslušný atribut na záložce pracovního poměru a rovněž na pracovní funkci). Pracovní funkce má u sebe informaci o tom, jak je pracovník odměňován (měsíčně nebo hodinově). Tento atribut slouží k předplnění atributu na záložce pracovní poměry – zadá se tam pracovní funkce a způsob odměňování se předplní (jako i atributy kalendář, stupnice, třída, …). Do mzdy se pro tyto účely nezahrnuje mzda za práci přesčas, příplatek za práci ve ztíženém a zdraví škodlivém pracovním prostředí, za práci v noci a za práci ve svátek.

Kalendáře fondu pracovní doby zůstávají beze změn. Hodinová mzda se upraví podle údajů v kalendáři uvedeném u pracovního místa. U měsíční mzdy dochází ke krácení minimální mzdy ve vztahu k odpracované době. Ke každému pracovníkovi se stanoví procentu krácení hodinové min. mzdy. Při výpočtu minimální mzdy se pracuje s mzdovými položkami, které mají zaškrtnuto „mzda pro účely srovnání s minimální mzdou“ a „odpracované hodiny pro účely srovnání s minimální mzdou“. Minimální mzda se vztahuje jen na některé zaměstnance, je to v závislosti na druhu pracovního poměru (např. na druh pracovního poměru dohoda se nevztahuje).

Algoritmus výpočtu min. mzdy je následující, systém zjistí:

¨ součet peněz u mzdových položek, které mají zaškrtnuto „částku zahrnout pro srovnání s min. mzdou“

¨ součet odpracovaných hodin u mzdových položek, které mají zaškrtnuto „hodiny zahrnout pro srovnání s min. mzdou“

¨ zda má pracovník hodinovou nebo měsíční mzdu

¨ věk a invaliditu zaměstnance a jeho hodinovou či měsíční mzdu krátí na několik procent

¨ dochází k úpravě hodinové minimální mzdy (nastaveno podle parametrů plánovacího kalendáře):

- pracuje-li prac. v 8h prac. době, je ponechána sazba 42,50 Kč (sazba platná pro r. 2005)

- pracuje-li prac. méně než 8h denně, je přepočítáno podle vzorce sazba=42,50 * (40/skut.hodiny*5). Sazba pak vyjde vyšší než 42,50

- pracuje-li více než 8h, je ponechána sazba 42,50

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 24.01.2008


Pojem - Míra plnění

Je nástroj související s vazbou uzlů procesu, který podporuje předplnění numerické hodnoty do událostí cílové operace na základě událostí zdrojové operace (správněji výstupních atributů komponenty) podle algoritmu zadaného v pravidlech transformace.

Pro fungování míry plnění je nutno v pravidlech transformací mezi oběma druhy operací, kde chceme míru plnění uplatnit, nastavit hodnotu výstupního atributu (ten je pro chod míry plnění podstatný). V pravidlech transformace se tento atribut nazývá cílová hodnota. Dále chování míry plnění ovlivňuje rozlišení vazby i rozlišení pravidla transformace.

Při ukončení operace, pokud je tak nastaveno u daného druhu operace, probíhá test mírou plnění.

Míru plnění je možno v datovém toku procesu využít i několikrát, např. ve zdrojové události je sledovaná hodnota nastavena na 100, tzn., že transformací se do událostí cílové operace prvotně vždy předplní hodnota 100, přičemž uživatel ji má možnost modifikovat, opraví ji např. na 30, tzn. že při opětovném spuštění této cílové operace transformace se uživateli již předplní pouze hodnotu 70 do nové (další) události.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.12.2007


Pojem - Množství v MJ - pomocné

Tento pojem souvisí s atributem „vztah ceny k MJ“ v událostech komponenty skladu zvířat. Vztah ceny k MJ může být „RMJ“ nebo „MJ-pomocné“. Určuje, ke které MJ se vztahuje cena za MJ (množství v RMJ nebo v MJ-pomocné).

V případě použití typu ceny skladové by mělo být implementačně zajištěno, že vztah ceny k MJ je nastaven: "RMJ", neboť skladová cena se vždy odvíjí k RMJ. Je-li přesto vztah ceny k MJ nastaven: "MJ-pomocná", potom je cena celkem spočtena jako cena skladová x množství v RMJ, cena za MJ je pak vypočtena jako cena celkem / množství v MJ-pomocné.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.10.2007


Pojem - Množství v RMJ

Druh hodnoty, který udává množství zvířat v referenční měrné jednotce (slouží pro výpočet jednotkové ceny skladové). Tento pojem souvisí s atributem „vztah ceny k MJ“ v událostech komponenty skladu zvířat. Vztah ceny k MJ může být „RMJ“ nebo „MJ-pomocné“. Určuje, ke které MJ se vztahuje cena za MJ (množství v RMJ nebo v MJ-pomocné).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.10.2007


Pojem - Modální okno

Modální okno je okno nebo dialogové okno vyžadující před přechodem k jinému formuláři nebo dialogovému oknu určitou akci uživatele. Typickým příkladem modálního okna v IS BM je např. okno, které si uživatel vyvolá po aktivaci vybrané předlohy výstupu (tzn. dvojklik na předloze výstupu). Toto okno pak zůstává na obrazovce a nelze se z něj přepnout do jiného okna. Uživatel musí provést určitou akci (stiskem tlačítka OK vyvolat tisk nebo prohlížení předlohy výstupu nebo stiskem klávesy ESC ukončit toto okno), aby bylo možno se přepnout do jiného okna. Jinými slovy modální okno v okamžiku aktivace pro sebe „sebere“ všechnu aktivitu FoxPro a další činnosti nelze provádět do okamžiku, kdy uživatel modální okno opustí.

Dalším příkladem modálního okna jsou dialogová okna vyvolávaná při importech/exportech, šablonách, maskách operací apod.

Poznámka – upozornění pro uživatele:

Po F2 reakci v modálních oknech nemusí vždy fungovat tlačítko „návrat hodnoty“ (panel nástrojů). Jedná se o danou vlastnost FoxPro, uživatel si v daný okamžik může pomoct ručním přenesením hodnoty zpět (Ctrl+Enter, tj. klávesová zkratka pro tlačítko „návrat hodnoty“).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 01.09.2008


Pojem - Multiverze v IS BM

Pro používání BM ve velkém počtu multiverzí, byla doplněna funkčnost programu usnadňující implementaci v oblastech:

1. podpora automatizovaného zakládání ODBC spojeních na stanicích

2. automatické spouštění odpovídající databáze na databázovém serveru v okamžiku zvolení multiverze

3. sdílení lokálních souborů ukládaných na stanicích všemi multiverzemi

K tomuto účelu jsou v souboru BW.INI umožněna tato nastavení:

1. Parametr EngineName v sekci Connection

EngineName=název serveru

Uplaňuje se při startu programu, způsobí automatické vytvoření ODBC spojení:

a.) Server name: název serveru

b.) Database name: odpovídá názvu spojení

c.) Network TCP/IP: Ano

d.) Buffer size: 4096

e.) Translator: Adaptive Server Anywhere 7.0 Translator - je-li nastaven parametr Connection->Translator=1

Souvisí dále s parametrem Connection->EngineVersion, který musí být nastaven na 7, pokud se nejedná o verzi databázového serveru 8.

2. Parametr EngineVersion v sekci Connection

EngineVersion=7

Uplatní se spolu s parametrem Connection->EngineName nebo Connection->DatabaseFile. Určuje verzi databázového serveru vytvářeného spojení resp. verzi serveru, na které má být automatizovaně spuštěna po zvolení multiverze odpovídající databáze.

3. Parametr Translator v sekci Connection

Translator=1

Uplatní se spolu s parametrem Connection->EngineName. Určuje, že vytvářené spojení má používat translator "Adaptive Server Anywhere 7.0 Translator"

4. Parametr DatabaseFile v sekci Connection

DatabaseFile=maska DB souboru

Způsobí při startu programu start databáze na databázovém serveru určeném parametrem Connection->EngineName.

V parametru se musí vyskytovat tři znaky #, které budou nahrazeny názvem spojení, po tomto nahrazení musí parametr odpovídat souboru DB včetně cesty na počítači, na kterém je spuštěn databázový server (např. C:\DATA\###\###.DB). Je-li server jiné verze než 8, musí být nastaven také parametr Connection->EngineVersion.

5. Parametr DBCPath v sekci Preferences

DBCPath=maska cesty

Definuje používání souborů s příponami DBC,DCX a DCT, které jsou potřebné pro práci BM a které jsou ukládány na lokální stanici.

Není-li parametr uveden, ukládají se tyto soubory v adresáři:

C:\[cesta programu]\[název spojení]

V parametru musí být jeden znak #, který je nahrazován pořadovým číslem současně spuštěného BM. Dále může být v parametru obsaženo makro $CURDIR$ , které je nahrazováno [cesta programu]

Např.:

DBCPath=C:$CURDIR$\DBC\#

Parametr se nesmí používat se současně nastaveným parametrem Preferences->DBCOpenShare.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 09.10.2007


Pojem - Mzda - její složení a formy

Mzda, plat = odměna za vykonanou práci. Její výše nemusí být zakotvena v pracovní smlouvě, ale může být stanovena v kolektivní smlouvě. Plat se řídí zákonem o platu a nařízením vlády, vztahuje se na zaměstnance rozpočtových a některých dalších organizací.
Mzda se řídí zákonem o mzdě a nařízením vlády, vztahuje se na zaměstnance zaměstnavatelů, kteří provozují podnikatelskou činnost.
Mzda musí odpovídat podmínkám stanoveným v zákoně. Základní podmínka je, že nesmí být nižší než minimální mzda stanovená nařízením vlády – musí vycházet z minimálních mzdových tarifů.

Mzdový tarif je hodinová nebo měsíční mzda v příslušném tarifovém stupni. Tarifní stupně jsou členěny podle míry složitosti odpovědnost a namáhavosti práce. V současné době jsou tři tarifní stupně (stejné pro dělníky i THP). V kolektivní smlouvě nebo vnitřních mzdových předpisech mohou být tarify podstatě vyšší. Mzdové předpisy neřeší otázku mzdových forem. Zaměstnavatel se může podle konkrétních podmínek rozhodnout pro mzdu časovou, úkolovou, smíšenou nebo podílovou.

Mzda se skládá z:
1. pevné složky mzdy – mzdový tarif
2. pohyblivé složky mzdy – motivuje k lepším výkonům – prémie, odměny, osobní ohodnocení

Formy mezd
1. časová mzda
ČM = počet odpracovaných hodin * hodinový mzdový tarif
Výhody – nemusí se vést evidence, lehký výpočet; Nevýhody – nepřihlíží k vyrobeným úkonům

2. úkolová mzda
ÚM = počet výkonů * mzda za 1 výkon (úkolová sazba)
Pro výpočet úkolové mzdy musí být stanoveny výkonové normy času nebo množství:
úkolová sazba (z VNM) = hodinový mzdový tarif / VNM
úkolová sazba (z VNČ) = hodinový mzdový tarif * VNČ / 60
Výhody – přihlíží k vyrobeným úkonům; Nevýhody – musí se vést evidence

3. podílová mzda (provize)
Nejčastěji se vyjadřuje procentem z tržby. Vztahuje se k prodeji zboží.

4. smíšená mzda
Kombinace úkolové a časové mzdy.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 29.02.2008


Pojem - Nabídka aktivních oken

Jedná se o další možnost poskytující uživateli informace o tom, které činnosti má právě spuštěny. Pokud má uživatel v parametrech uživatele zatrženo „zobrazovat nabídku aktivních oken“, automaticky se mu při spuštění jakékoliv činnosti v IS BM tato nabídka implicitně zobrazí v pravé části okna. Uživatel si tuto nabídku může podle potřeby přesouvat na jiné místo v okně (metoda „táhni a drž“), tato volba však není uchovávána, tudíž s dalším novým spuštěním IS BM se nabídka aktivních oken znovu zobrazí v pravé části okna.

Stiskem jednotlivých tlačítek si uživatel aktivuje vybrané činnosti v nabídce aktivních oken. V případě, že v některé z aktivních činností uživatel právě využívá klávesu F2, tj. vstup z číselníku (nebo ikonu lupa z panelu nástrojů), v nabídce aktivních oken v tomto okamžiku nelze přepínat mezi jednotlivými činnostmi. Zaškrtávátko „křížek“ pro ukončení činnosti nemá faktický význam, nabídka aktivních oken se sice v danou chvíli ukončí, nicméně se znovu automaticky aktivuje při přechodu na další spuštěné okno nebo při spuštění nové činnosti.

V případě, že uživatel používá možnost roztažení oken do šířky, zabírá pak nabídka aktivních oken zbytečně část šířky obrazovky, kterou by jinak uživatel mohl využít celou. Proto je možné zaškrtnout v parametrech uživatele spolu s volbou „zobrazovat nabídku aktivních oken“ i volbu „ikony“. V tomto případě je pak nabídka aktivních oken zobrazována jako tlačítka s ikonami a ukotví se při příštím spuštění programu v dolní části obrazovky.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 13.12.2007


Pojem - Nabídky

Nabídky představují rozšířenou možnost pro uživatele, kdy může nejčastěji používané činnosti soustředit do vlastní nabídky, která se pak zobrazuje jako samostatné okno činnosti, které si může uživatel umístit na libovolné místo. Je možno mít zobrazeno jednu nebo více nabídek zároveň, záleží pouze na tom, kolik nabídek si uživatel v menu Obecné – Nabídky – zaškrtne. Při práci s nabídkami může uživatel sledovat i vazby míry plnění. K dispozici pod menu nabídky má uživatel i činnost Okno úloh, která pro uživatele představuje další nástroj pro usnadnění ovládání programu BM.

V případě definování nové nabídky tedy uživatel postupuje následovně. Pod menu Obecné – Nabídky – zvolí možnost Definovat nabídky. Aktivuje tlačítko „vložit“ a stiskne Ano po dotazu „Opravdu definovat novou nabídku?“. V prvním poli se objeví název Nová nabídka, do druhého pole vedle uživatel napíše název své vytvářené nabídky a stiskne OK. Jednotlivé činnosti a funkce do nabídky přiřadí tak, že si je vybere se seznamu nabízených a na každém zvoleném provede dvojklik levým tlačítkem myši (dojde k označení položky hvězdičkou a tím se automaticky stává součástí dané nabídky). U každé nabídky je možno zaškrtnutím příznaku „veřejná“ určit, zda nabídku bude mít k dispozici pouze autor nabídky a nebo i ostatní uživatelé a v případě potřeby je možno si vybrané položky z nabídky i přeložit (tlačítko „překlad“), např. položky vytvořené programovým kódem (volné karty, obecné výběry). Atributy je možno přeložit i pomocí činnosti překlad popisek. Překlady pomocí činnosti překlad popisek mají vyšší prioritu než překlady v činnosti nabídky. Za zajímavost stojí i to, že je možno nabídce i jednotlivým činnostem přiřadit vlastní zvolené ikony, je nutno do kolonky Ikona zapsat název souboru, který obsahuje vybranou ikonu s příponou *.bmp. Uvedením znaku vlnovka ~ v textu názvu ikony znamená, že na odpovídající tlačítko bude přenesen text, který je zapsaný za vlnovkou. Atribut „dynamický“ má pro uživatele následující význam:

¨ pokud je vybráno ANO znamená to, že uživateli se v dané činnosti při aktivaci nabídky zobrazí v nabídce vždy jen činnosti, které jsou na dané činnosti dostupné (tzn. na činnosti, z které byla nabídka vyvolána). Pokud bude mít uživatel v nabídce vybráno např. činnost bankovní spojení a právě se bude nacházet v činnosti např. dokumenty, odkud tuto nabídku spustí, tak bankovní spojení v dokumentech není dostupné, tudíž v dané nabídce se činnost bankovní spojení v danou chvíli nabízet nebude

¨ pokud je vybráno NE jsou dostupné vždy všechny činnosti z nabídky, ty, které není možno v dané činnosti vyvolat jsou však nedostupné – šedivé.

Pro každou položku nabídky je možno zvolit, zda se má uživateli nabízet samostatně jako činnost v menu Volby. Nadefinováním atributu „menu“ na hodnotu NE u jednotlivých položek nabídky si uživatel určuje, které položky nabídky chce pod menu Volby mít dostupné a které mohou zůstat potlačeny a nezobrazovat se. Hodnotu NE u atributu „menu“ mohou mít nastaveny také položky menu, které nejsou součástí žádné nabídky, ale jsou součástí programu BM a přitom se používají pouze minimálně (např. činnost pod menu Volby Odeslat do Outlooku apod.)

Příznak „křížek“ pro ukončení nabídky fakticky okno s nabídkou zavře, nabídka (v menu Obecné – Nabídky) však zůstává stále zaškrtnutá, tzn. že při dalším pokusu nabídku odškrtnout se znovu spustí. Při prvním spuštění se nabídka uživateli implicitně zobrazuje v dolní části okna, je možno si ji libovolně přesouvat kdekoliv po okně, její nové umístění je i po ukončení programu zachováno (tzn. pokud si uživatel okno s nabídkou přesune do pravého horní rohu okna, je při dalším spuštění činnosti, ze které se tato nabídka spouštěla, nabídka zobrazena v pravém horním rohu okna).

Přehled o jednotlivých událostech svázaných v IS BM mírou plnění uživateli poskytuje činnost vazby míry plnění.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.07.2008


Pojem - Napojení do procesu

Napojením do procesu se rozumí situace, kdy je nutné k již existujícímu fyzickému procesu zadat (vstoupit) další události (resp. operace). Možnosti napojení jsou:

¨ přes definici vyvolání (činnost Napojení do procesu)

¨ prosté nalezení procesu (činnost Procesy) – obvykle výběrem a spuštěním operace ze záložky nebo rozhodnutím výběrové vazby

¨ přes výběry – tzn. uživatel má připravenu ve svém menu činnost, která obsahuje výběr např. připravených, dosud nezahájených operací, které uživatel následně podle potřeby spouští (work-flow).

¨ spuštění operace pomocí zprávy spojené s operací

¨ referenčním procesem – v tomto případě operace spuštěná pomocí referenčního procesu není definována u druhu procesu

¨ specifická napojení – např. párování ZSP na platby za pomoci dynamického spojení operací

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Napojení ULR na atribut

Jedná se o vlastnost pohledu (ve SD), která se uplatňuje pouze tehdy, je-li pohled aplikován v prvku web (přímo, zprostředkovaně doplněným oknem nebo ULR odkazem z jiného pohledu).

Tato definice umožňuje při prohlížení relevantních dat web browserem kliknutím na zde uvedený atribut zobrazit data definovaná připojeným oknem a pohledy uvedené v doplněných oknech.

Pokud není tato vlastnost explicitně definována, je implicitně přiřazena prvnímu atributu (zobrazovanému v řádce) při prohlížení web browserem.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Nápověda

Nápověda je standardní součástí každého okna IS BM. Je možno ji spustit po stisku funkční klávesy F1, z horní lišty nebo stiskem příslušné ikony z panelu nástrojů. Po spuštění nápovědy se uživateli v levém sloupci činnosti nápověda zobrazí následující nabídka:

¨ Bílý Motýl – menu program – po rozbalení této nabídky má uživatel k dispozici seznam všech činností tak, jak jsou k dispozici v hlavním menu. Pohybem po jednotlivých činnostech hlavního menu v levém sloupci se uživateli zároveň v pravém sloupci zobrazuje jejich popis.

¨ Datový model – po rozbalení této nabídky má uživatel k dispozici přehled všech tabulek IS BM, jejich datový model a popis jednotlivých atributů. Název tabulky je vždy zobrazen v levém sloupci, v pravém sloupci jsou dostupné všechny informace k dané tabulce.

¨ Novinky systému – obsahují krátký popis všech novinek systému k určitému datu.

¨ Další dokumentace – zde má uživatel k dispozici další vytvořené dokumentace k IS BM. Mezi jednotlivými dokumentacemi fungují hypertextové odkazy. Uživateli se nabízí dokumentace „Procesy v IS BM“, „Slovník pojmů“, „Specifikace systému“ a „Ovládání“.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Nastavení – Souvislosti objekt

Nastavením této činnosti uživatel definuje způsob zobrazení rámečku souvislostí po stisku ikony objekty (ikonka se „stromečkem“) v panelu nástrojů. Rámeček souvislostí si metodou „táhni a drž“ může uživatel rozmístit na libovolné místo v okně. Po jeho zavření a opětovném spuštění si systém pamatuje poslední místo, kde byl umístěn a na tomto místě se rámeček souvislostí aktivuje. Možnost této definice má uživatel v činnosti menu „Systém“. Po její aktivaci se mu zobrazí tabulka s nabídkou všech objektů, které se mohou zobrazovat v rámečku souvislostí. Příslušná znaménka plus nebo mínus v rámečku souvislostí poskytují uživateli informace o přítomnosti objektových vazeb. V levé části této tabulky má uživatel možnost změnit pořadí těchto objektů (stiskem malého čtverečku před názvem objektu pravým tlačítkem myši - po jeho stisku se zobrazí na čtverečku šipka - a jeho následným přetažením na jiné místo v seznamu).

U každého objektu v seznamu je možno z překryvného seznamu (v dolní části okna) vybrat tyto možnosti:

¨ zobrazit – tento objekt se bude po aktivaci rámečku souvislostí standardně nabízet v daném pořadí

¨ skrýt – tento objekt zůstává skrytý, tzn. po aktivaci rámečku souvislostí se standardně nezobrazí. V případě, že by uživatel potřeboval v některém okamžiku vidět v rámečku souvislostí i objekty, které mají příznak skrýt, zatrhne možnost „zobrazovat skryté“. Do té chvíle, dokud bude tato možnost zatržena, se budou v rámečku souvislostí nabízet i objekty, které mají příznak skrýt. Uživatel má však možnost vidět i objekty, které jsou skryté a přesto nemají zatrženo „zobrazovat skryté“. Po stisku pravého tlačítka myši v šedivém poli rámečku souvislostí se uživateli zobrazí i objekty, které mají příznak skryté. Opětovným stiskem pravého tlačítka myši se obnoví původní zobrazení.

¨ potlačit – tyto objekty se v rámečku souvislostí nebudou nabízet nikdy. V případě, že by je uživatel přesto chtěl vidět, musí příznak potlačit změnit na zobrazit nebo skrýt.

Nastavení – souvislosti objekt se vždy váže k danému uživateli a jeho přístupovému heslu (tedy, k tomu, který je právě aktuálně přihlášen do systému), tzn., že pro každého uživatele může být toto nastavení individuální a zcela podle jeho potřeb. Po stisku tlačítka OK se toto nastavení uloží.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 13.12.2007


Pojem - Nastavení okna úloh

Jedná se o parametry, jejichž nastavením má uživatel přímo možnost ovlivnit chování okna úloh. Toto nastavení je specifické pro každého uživatele, tzn. každý uživatel může mít pod svým heslem okno úloh nastaveno zcela individuálně.

Jedná se o tyto parametry:

¨ otevírat okno úloh při spuštění programu – možnosti jsou:

- vždy – při každém spuštění IS BM se zároveň aktivuje i okno úloh

- pokud bylo otevřeno při ukončení programu – v případě, že okno úloh bylo otevřeno v okamžiku, kdy uživatel ukončil práci s IS BM, je při jeho spuštění automaticky otevřeno i okno úloh

- nikdy – okno úloh se neaktivuje (v případě potřeby má uživatel možnost si ho aktivovat – v menu Obecné – Nabídky – Okno úloh)

¨ přepínat do hlavního menu programu – tento parametr určuje chování v situaci, kdy uživatel v základním okně IS BM uzavře poslední aktivní formulář a přitom je otevřeno okno úloh. Možnosti jsou:

- vždy – při ukončení posledního aktivního formuláře se systém vždy automaticky přepne do okna hlavního menu a základní okno BM skryje

- když není aktivní úloha „Menu BM“ – v případě, že není aktivní úloha „Menu BM“, tak se systém automaticky přepne do hlavního menu. Pokud je tato úloha aktivní, systém ponechá zobrazenou úlohu „Menu BM“ a základní okno BM je rovněž aktivní

- nikdy – základní okno BM zůstává po ukončení posledního formuláře aktivní

¨ ukončení programu klávesou ALT+F4

¨ zobrazovat hlavní menu programu – v případě, že je tento atribut zatržený, tak se hlavní menu programu zobrazuje standardně, při spuštění některé činnosti z hlavního menu je pak uloženo na dolní liště PC. Pokud tento atribut nebude zatržený, tak se hlavní menu programu zobrazovat nebude a uživatel bude systém ovládat pouze pomocí tlačítka „Menu BM“ v okně úloh. Tento atribut úzce souvisí s nastavením předchozích třech parametrů, tzn. musí být nastaveny správně, aby byl tento atribut přístupný pro zatržení. Naopak, pokud je zatržený a uživatel ho odškrtne, dojde k automatickému nastavení atributů „otevírat okno úloh při spuštění programu na Vždy“, „přepínat do hlavního menu programu na Nikdy“ a „ukončení programu klávesou ALT+F4 na zatržené“. V případě, že má uživatel nastaveno hlavní menu nezobrazovat a přesto ho potřebuje náhle aktivovat, provede to pomocí činnosti „Hlavní menu“ pod menu Obecné (horní lišta formuláře). V případě, že aktivované hlavní menu chce uživatel opět „schovat“, provede toto pomocí tlačítka „skrýt menu“, které je dostupné v horní liště činnosti Hlavní menu pod menu Volby (tzn. atribut „zobrazovat hlavní menu programu“ je nezatržen). V případě, že je nastaveno nezobrazovat hlavní menu a uživatel si omylem ukončí okno úloh, tak se hlavní menu automaticky zpřístupní.

¨ používat zobrazení tlačítek – výběr z možností překryvného seznamu:

- textová tlačítka 1 – obsah okna úloh je zobrazován v pevné pozici, tak jak je nastaven pod tlačítkem „nastavit zobrazování úkolů“

- textová tlačítka 2 – obsah okna úloh je zobrazován dynamicky vždy pod dané tlačítko v seznamu tlačítek

- ikony – obsah okna úloh je zobrazen jako horní lišta činnosti, kde každé jednotlivé tlačítko je představeno samostatnou ikonou

- překryvný seznam – v horní části činnosti okna úloh je k dispozici překryvný seznam s přehledem všech dostupných tlačítek a uživatel se pomocí tohoto překryvného seznamu mezi nimi přepíná

¨ tlačítko „nastavit zobrazování úkolů“ – po stisku tohoto tlačítka se zobrazí seznam všech možností, které uživateli poskytuje okno úloh a uživatel má možnost změnit pořadí jednotlivých nabízených možností, potlačit zobrazení tlačítka a určit pozici okna úloh pro zobrazení tlačítek ve variantě „textová tlačítka 1“

¨ seznam vlastních stránek IP – zde si uživatel může uvést seznam vlastních stránek informačních panelů, které mají být rovněž zobrazeny v okně úloh. Uživatel si pro zobrazení stránek informačních panelů může definovat vlastní tlačítka. V nastavení programu BM lze v parametru OKNOULOH -> VLOZENEINFPANELY zadat seznam identifikací stránek informačních panelů oddělených čárkou. Popis a ikona takto definovaných tlačítek okna úloh přitom odpovídá názvům a ikonám uvedeným v popisu stránky informačního panelu. Jednotlivým uživatelům jsou zobrazovány tyto definovaná tlačítka pouze v případě, že k odpovídající stránce informačního panelu mají přístupové právo alespoň „Čtení“. Pravý klik myši na tlačítku pro zobrazení stránky informačního panelu způsobí znovunačtení stránky.

¨ předplňovat adresáta v novém procesu – tento atribut umožňuje nastavit, že při spuštění nového procesu z okna úloh se předplní adresát zobrazený v aktuálním formuláři pro nově zakládané události v jeho první operaci. Adresát se však předplní pouze v případě, že úvodní druh operace daného druhu procesu má nastavenou vlastnost „vytvořit záložku při založení procesu“. Tento parametr je možno nastavit následovně:

- Ano – z formuláře Adresář – adresát se bude předplňovat pouze v případě, že jako aktuální formulář je spuštěn Adresář

- Ano – z formulářů událostí a Adresář – adresát se bude předplňovat pouze v případě, že jako aktuální formulář je spuštěn Adresář a nebo událost operace komponenty

- Ano – adresát se bude předplňovat vždy, pokud aktuálně spuštěný formulář obsahuje atribut adresát

- Ne – adresát se nebude nikdy předplňovat

¨ průběh procesů – automaticky rozbalovat složky – zatržení této možnost způsobí, že na záložce „Průběh procesů“ se uživateli jednotlivé procesy zobrazují již rozbalené, tzn. hlavička procesu (číslo a název procesu) a pod ní ve stromové struktuře její operace. Pokud tato možnost zatržena není, zobrazí se uživateli na záložce „Průběh procesů“ pouze hlavička procesu a tu si musí aktivně sám rozbalit.

¨ dotazovat při uzavírání okna úloh – při ukončení činnosti se při zaškrtnutí tohoto atributu systém dotazuje „Uzavřít okno úloh? Ano/Ne“. V případě, že není tento atribut zatržen, systém ukončí okno úloh automaticky bez dotazu.

Pozn.:

V seznamu stránek informačních panelů je možné před identifikací stránky uvádět znak ‘*‘. Tento znak znamená, že se jedná o příznak toho, že daná stránka je závislá na datech aktivního formuláře BM.

Takové stránky obvykle využívají parametr, které je jí předán v okamžiku jejího vyvolání.

Jedná se o parametr _P1, který obsahuje objekt s atributy odpovídající atributům aktuálního záznamu formuláře nebo hodnotu .F. (FALSE), pokud záznam není možné určit. Výskyt atributů v objektu _P1 je třeba při vytváření stránky IP ošetřit, protože např. atribut AD01ID (identifikace adresáta) se samozřejmě nevyskytuje ve všech formulářích BM. Máme-li např. stránku informačního panelu pro zobrazení informací o adresátovi, potom její poduzly mohou být definovány:

  • Parametry - _P1.AD01ID
  • WHERE – ADADSAT.AD01ID=?_P1
  • Podmínka – TYPE(‘_P1.AD01ID‘)=‘C‘

Pro stránky informačního panelu, jejichž obsah je závislý na datech aktivního formuláře BM platí, že opakovaný klik na tlačítko v okně úloh v okamžiku, kdy je zobrazen v okně úloh jeho odpovídající obsah, způsobuje znovunačtení stránky.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 07.05.2009


Pojem - Nastavení programu BM

Nastavení pro IS BM se původně vždy ukládala v souboru BW.INI. V současné době se již nastavení pro IS BM ukládají přímo do dat (tabulka BWOPTION a BWOPTIOC) v činnosti „Nastavení programu BM“ (menu Systém).

Tato činnost poskytuje uživateli možnost definice jednotlivých nastavení potřebných pro IS BM. Význam nastavení včetně jejich popisu definují programátoři v Galaxii a při instalaci nové verze jsou nová nastavení programu BM do dat automaticky přidávána. Při doplňování nového nastavení do dat, které je aktuálně nastaveno také v souboru BW.INI je toto nastavení do této činnosti přidáno s hodnotou, která je nastavená v souboru BW.INI.

V přehledu definic nastavení programu BM jsou nastavení, která je možné definovat pouze v souboru BW.INI zobrazována v šedivých řádcích (jedná se o informace, které jsou pro program potřebné ještě před jeho vlastním připojením k databázovému serveru). Těmto nastavením zde není možné definovat žádnou hodnotu.

Nastavení, která je možná definovat v datech, jsou zobrazena v bílých řádcích a případné změny odpovídajících parametrů v souboru BW.INI nemají po instalaci nové verze žádný vliv na chod programu. Některá nastavení je možné definovat pouze lokálně pro datová úložiště nebo konkrétní počítače. Přitom v lokální definici hodnota datového úložiště „-„ znamená libovolné datové úložiště a hodnota počítač „-„ znamená libovolný počítač.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 14.12.2007


Pojem - Nastavení stromu

V činnostech, které využívají stromové zobrazení, jako je strom hlavního procesu, obecné stromy, strom pracovníka, hlavní menu a okno úloh má uživatel možnost nastavit si zobrazení a způsob ovládání. Toto provede stiskem pravého tlačítka myši na názvu činnosti a zvolí možnost „Nastavení stromu“. Zde jsou k dispozici následující atributy:

¨ font – výběr druhu písma, ve kterém bude daná činnost zobrazena (uživatele je v tomto případě nutno upozornit, aby si vybírali fonty, které zvládají zobrazení diakritiky, jinak pak zobrazení činnosti může vypadat tzv. jako „rozsypaný čaj“)

¨ velikost písma – tlačítkem nahoru nebo dolů si uživatel zvolí velikost daného písma

¨ kurzíva – při zatržení tohoto příznaku bude zvolený font písma ještě zvýrazněn kurzívou

¨ ‘+’ také ve vrcholových uzlech stromu – při standardním stromovém zobrazení činností mají vrcholové uzly před svým názvem ve většině případů ikonu a rozbalují se dvojklikem myši na názvu činnosti (nebo ikoně). Teprve další činnosti pod nimi mají před svým názvem znaménko ‘+’, což znamená, že je možno je ještě dále rozkliknout. Při zatržení tohoto atributu bude znaménko ‘+’ i před názvy vrcholových uzlů a klikem na něj se ihned rozbaluje nabídka činností pod ním.

¨ používat zjednodušené ovládání – při standardním ovládání se činnosti v menu aktivují dvojklikem levého tlačítka myši. Vysvětlíme si na příkladu hlavního menu. Uživatel si dvojklikem myši aktivuje činnost Marketing, ta zůstane rozbalená a dalším dvojklikem si aktivuje činnost Platby. Znamená to, že nyní má v hlavním menu rozbalenu nabídku dvou činností. V případě, že tuto nabídku chce zavřít, musí ji opětovným dvojklikem zase zavřít. Zatržení tohoto příznaku umožňuje uživateli změnit chování činností. Po kliku (jednom kliku levého tlačítka myši – nikoliv dvojkliku) na názvu činnosti se tato okamžitě rozbalí. Při kliku a rozbalení další činnosti se zároveň ihned první rozbalená činnost zase automaticky zavře. Vysvětlíme si opět na příkladu hlavního menu. Uživatel stiskem levého tlačítka myši aktivuje činnost Marketing, ta se ihned rozbalí, dalším stiskem levého tlačítka myši aktivuje činnost Platby. Ta se ihned rozbalí, ale zároveň se ihned automaticky zavře původní otevřená činnost Marketing.

Lehce odlišné chování jednotlivých menu může nastat v případě, že uživatel bude mít v této činnosti zároveň zatrženy atributy „‘+’ také ve vrcholových uzlech stromu“ a „ používat zjednodušené ovládání“. Pak skutečně i při ovládání menu funguje kombinace standardního a zjednodušeného ovládání menu. Při kliku na název činnosti se menu chová podle příznaku „používat zjednodušené ovládání“, tzn. menu se ovládá pouze stiskem levého tlačítka myši. Při kliku na znaménko ‘+’ u vrcholového uzlu se menu ovládá standardně. Opět si tuto situaci vysvětlíme na příkladu hlavního menu. Uživatel má samozřejmě zatrženy oba jmenované atributy. Při stisku levého tlačítka myši na názvu činnosti Marketing se rozbalí nabídka této činnosti. Po stisku znaménka ‘+’ u činnosti Platby se rovněž rozbalí nabídka této činnosti. Dalším stiskem levého tlačítka myši např. na názvu činnosti DHP se automaticky zavře nabídka činnosti Marketing (chová se podle zjednodušeného ovládání menu), ale nabídka činnosti Platby zůstane otevřená (chová se podle standardního ovládání menu).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 03.06.2008


Pojem - Navazující dokument

Jedná se o dokumenty, které lze připojit k objektu BM po stisku pravého tlačítka myši pomocí volby:

¨ Nový dokument

¨ Načíst dokument

Menu „Navazující dokument“ je dostupné ve formuláři činnosti Strom hlavního procesu a Spojené dokumenty. Navazující dokument je pak zařazen ve stromové struktuře, tzn. je navěšen pod objektem, ke kterému byl připojen. Po stisku pravého tlačítka myši jsou dostupné klasické činnosti jako u dokumentů (tuto možnost uživatel využije např. při vytváření smluv a pod ně si navěsí jejich dodatky, tzn. smlouva je klasický dokument a dodatky smluv jsou navazující dokumenty).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 14.12.2007


Pojem - Navigační list definice listu výkazů

Tento list je v podstatě okno, které se automaticky zobrazí společně s formulářem činnosti definice listu. Obsahuje a zobrazuje všechny definované buňky definice výkazu. Je určen pro navigaci v definici listu, tj. při kliknutí na danou buňku v navigačním listu je pod ním uživateli zobrazena definice této buňky včetně definice řádku, sloupce a parametrů listu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 14.12.2007


Pojem - Návrhář sestav FoxPro (Report Designer)

Jedná se o činnost, kterou má uživatel dostupnou po aktivaci ikony „oprava“ v panelu nástrojů u předloh výstupu. Pokud tuto činnost spouští poprvé (poté co si nadefinoval atributy, které budou součástí výstupu – bližší popis u pojmu „výběr položek výstupu“), musí si nejprve provést správné rozmístění atributů ve formuláři, pokud tuto činnost spouští víckrát opakovaně, atributy jsou již rozmístěny a aktivace této činnosti slouží spíše pro opravu (přidání atributu, úprava formátování apod.).

V této činnosti uživatel provádí vlastní definici předlohy a způsob zobrazení jednotlivých atributů při vlastním tisku. Po aktivaci této činnosti má k dispozici klasickou ovládací horní lištu, vlastní formulář, který je rozdělen na záhlaví stránky, tělo a zápatí stránky a samostatné okno s ovládacími prvky sestavy.

Ovládací lišta obsahuje tuto nabídku:

¨ soubor – uložení, nastavení vzhledu stránky, náhled, tisk sestavy apod.

¨ úpravy – klasická nabídka možných úprav – vložit, kopírovat apod.

¨ sestava – možnost definice seskupování dat, proměnných, vlastností sestavy apod.

¨ okno – informace o současně otevřených jiných oknech

¨ nápověda – nápověda aplikace Microsoft Visual FoxPro

¨ formát – definice zarovnání, písma, stylu čáry apod.

Rozmístění atributů ve formuláři je dané názvy jednotlivých pásů. Ty atributy, které budou součástí hlavičky stránky uživatel přesune do pásu „záhlaví stránky“. Přesun atributů se provádí buď pomocí myši (tzv. „táhni a drž“) a nebo pomocí šipek na klávesnici. Atributy, které mají být zobrazeny vždy na konci stránky se přesunou do pásu „zápatí stránky“.

V případě, že existují atributy, které chce mít uživatel při tisku k dispozici za celou sestavu, umístí tyto atributy do pásu „souhrn“. Pokud není pás „souhrn“ k dispozici, uživatel si ho aktivuje sám (horní lišta nabídka Sestava – Volitelné pásy a zaškrtnout možnost „souhrn sestavy“ a zároveň si zvolit i jeho umístění - nová stránka, záhlaví stránky, zápatí stránky).

Atributy, které mají tvořit vlastní jádro sestavy je nutno rozmístit do pásu „tělo“.

Po stisku pravého tlačítka myši na každém pásu (tj. záhlaví, tělo, zápatí, souhrn) jsou k dispozici tyto možnosti:

¨ volitelné pásy – informace o vytvořených pásech v sestavě

¨ seskupování dat – pomocí skupinového výrazu lze vytvořit další pás (např. pokud u daného adresáta chce mít uživatel vytištěn všechny jeho definovaná spojení, tak potom skupinovým výrazem bude identifikace adresáta a v těle skupiny budou atributy týkající se vlastní adresy, tj. ulice, město apod.)

¨ vlastnosti – detailní informace k pásu sestavy

Podobné vlastnosti týkající se celé sestavy má uživatel k dispozici po pravém stisku tlačítka myši kdekoliv ve volném prostoru sestavy. Jsou to:

¨ vložit

¨ spustit sestavu

¨ náhled

¨ datové prostředí

¨ volitelné pásy

¨ seskupování dat

¨ proměnné

¨ vlastnosti

V každém formuláři, kde se definuje sestava má navíc uživatel k dispozici samostatné okno „ovládací prvky sestavy“, které obsahuje tyto ovládací ikony:

¨ vybrat objekt

¨ popisek – po jeho stisku a kliknutí kamkoliv do prostoru formuláře je možno vytvořit nový popisek

¨ vložit pole - po jeho stisku a kliknutí kamkoliv do prostoru formuláře je možno zadat nový atribut. Uživatel musí znát identifikaci proměnné nebo si ji může vybrat z nabídnutého seznamu dostupných proměnných.

¨ styl čáry – možnost zvolit si styl čáry

¨ možnost vložit do formuláře rámeček

¨ možnost vložit do formuláře rámeček s oblými rohy

¨ možnost vložit obrázek nebo vázaný prvek OLE

¨ zámek tlačítka – funguje jako zámek pro zvolenou ikonku, např. pokud bude uživatel chtít ve formuláři vytvářet větší množství čar a nechce neustále klikat na ikonku styl čáry, je možno na ni kliknout jednou a potom stisknout zámek tlačítka a poté může vytvářet jednu čáru za druhou bez opakované aktivace ikonky styl čáry

Na každém jednotlivém atributu lze vyvolat po stisku pravého tlačítka myši tyto možnosti:

¨ vyjmout – vybraný atribut se vyjme (v klasickém ovládání Windows Ctrl+X)

¨ kopírovat – zkopíruje se vybraný atribut (v klasickém ovládání Windows Ctrl+C)

¨ vložit – je aktivní, pokud předtím byla aktivována volba vyjmout nebo kopírovat (v klasickém ovládání Windows Ctrl+V)

¨ vlastnosti (properties) - jsou popsány podrobně v samostatném pojmu „vlastnosti atributu v návrháři sestav“

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.10.2013


Pojem - Nehmotný majetek

Zjednodušeně řečeno jde o:

¨ zřizovací výdaje,

¨ nehmotné výsledky výzkumu a vývoje,

¨ software,

¨ ocenitelná práva nebo

¨ jiný majetek podle zákona o účetnictví,

pokud zároveň platí, že:

¨ byl nabyt úplatně, přeměnou, darováním, zděděním nebo vytvořen vlastní činností

¨ jeho vstupní cena je vyšší než 60.000 Kč

¨ jeho doba použitelnosti je delší než rok

U nehmotného majetku, ke kterému má poplatník právo užívání na dobu určitou, se roční odpis stanoví jako podíl vstupní ceny a doby sjednané smlouvou. V ostatních případech se nehmotný majetek odpisuje rovnoměrně bez přerušení, a to audiovizuální dílo 18 měsíců, software a nehmotné výsledky výzkumu a vývoje 36 měsíců, zřizovací výdaje 60 měsíců a ostatní nehmotný majetek 72 měsíců. U nehmotného majetku, nabytého vkladem nebo přeměnou pokračuje nabyvatel v odpisování započatém původním vlastníkem za podmínky, že vkladatelem, zanikající nebo rozdělovanou obchodní společností nebo družstvem mohly být odpisy u tohoto nehmotného majetku uplatňovány

Odpisy se stanoví s přesností na celé měsíce, počínaje následujícím měsícem po dni, v němž byly splněny podmínky pro odpisování; přitom poplatník, který má právo užívání nehmotného majetku sjednané smlouvou na dobu určitou, má možnost stanovit odpisy s přesností na dny. Při zahájení (ukončení) odpisování v průběhu zdaňovacího období lze uplatnit odpisy pouze ve výši připadající na toto zdaňovací období v závislosti na použitém stanovení přesnosti odpisů. Odpisy se zaokrouhlují na celé koruny nahoru.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 11.09.2008


Pojem - Nemovitost

Pozemky a stavby spojené se zemí pevným základem, dále rovněž byty a nebytové prostory. Nemovitosti se evidují v katastru nemovitostí v rozsahu stanoveném zákonem. Nejjednodušeji by se dal pojem nemovitost definovat asi tak, že bychom si řekli, že nemovitost je všechno to, s čím nemůžeme hýbat, co se nemůže přesunout nebo přestěhovat. Je to tedy něco, co je pevně spojeno se zemí, nebo co zemí je.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Nepřítomnost

Nepřítomností rozumíme evidenci nepřítomnosti na pracovišti z důvodu nemoci, ošetřování člena rodiny, mateřské dovolené, rodičovské dovolené nebo jiné nemoci. Nepřítomnost v sobě eviduje nejméně jednu nemocenskou dávku (nemocenské je peněžitá dávka, která náleží zaměstnanci, který je podle zvláštního předpisu uznán dočasně neschopným k výkonu svého dosavadního zaměstnání).

Do výpočtu výplatních lístků vstupují údaje z činnosti „nepřítomnost pro nemoc“. Při uzávěrce mezd se aktualizuje atribut „kalendářních dnů pracovní neschopnosti“ a atribut „proplaceno dne“. Uzávěrka zasahuje rovněž do historie pracovních poměrů.

Pracovní poměr musí zakládat účast na nemocenském pojištění. Jednotlivé nepřítomnosti u pracovníka a jeho pracovního poměru se nesmějí překrývat. Dávku nelze vyplácet déle než trvala nemoc a jedním záznamem lze vyplácet pouze dávky v rámci jednoho měsíce. Systém umožňuje zadat nepřítomnost i do minulosti, tuto variantu by však uživatel měl používat pouze v krajní nouzi a v součinnosti se svým implementátorem.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Nepřítomnost pro nemoc (do minulosti)

Jako první u této činnosti je nutno napsat upozornění, že se v žádném případě nejedná o triviální činnost a zápis nemocenských dávek do minulosti je nutno používat s rozmyslem.

U nemocenské dávky zadávané do minulosti se vyplní všechny atributy stejně jako u běžné dávky, s tím rozdílem, že na záložce „dávky“ se pak správně vyplní datum „do výpočtu v“. Uvedeme si tyto údaje na zkušebním příkladu. Máme aktuální měsíc březen, leden a únor již jsou uzavřeny a přesto chceme zadat zpětně dávku, která se týká právě měsíce ledna. Pak dávku zadáme jako běžnou lednovou a do výpočtu uvedeme datum např. 1.3. nebo 31.3. Po spuštění optimalizovaného výpočtu pak v systému dojde k těmto akcím:

¨ v měsíci lednu, kam dávka logicky patří, vznikne nová položka nemocenské dávky

¨ do protokolu bude zapsáno, že je nutné danému pracovníkovi přepočítat průměry na nemocenskou, aby měl správné průměry u nemocí vzniklých v měsíci únoru a březnu

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 17.01.2008


Pojem - Nespolehlivý plátci

Od 1.4.2013 platí povinnost firem zveřejnit své platební účty v Registru DPH. Na základě jejich spolehlivosti (ve vztahu placení daní vůči státu) jsou následně vyhodnoceni jako spolehlivý nebo nespolehlivý plátci. Při vystavování příkazů k úhradě by pak uživatel neměl vystavit příkaz plátci, který je určen jako nespolehlivý. Pro tuto kontrolu je v systému IS BM připraveno několik činností (k dispozici jsou nad činnostmi Adresář a Příkazy k úhradě). Především se jedná o připravené doplňující vlastnosti formuláře, které si uživatel samostatně stáhne pomocí činnosti Sady vzdálených funkcí (Informační centrum – Algoritmy a parametry – Sady vzdálených funkcí – Různé – Systémové DPV). Jedná se o tyto vlastnosti:

¨ údaje o registraci k DPH adresáta

¨ kontrola spolehlivosti plátce DPH WS

¨ kontrola spolehlivosti plátce DPH

Následující kontroly spolehlivosti (pomocí webové služby) i údaje o registraci spouští uživatel ručně. Tato kontrola je definována na základě DIČ adresáta, tzn. že kontrolovaný adresát musí mít v adresáři uvedeno DIČ začínající na „CZ“. Uživatelům proto doporučujeme revizi zadaných DIČ v adresáři u jednotlivých adresátů. Jiná DIČ než začínající na „CZ“ tato kontrola nezahrnuje.

Pro snadnější spuštění je možno nastavit kontrolu spolehlivosti jako jednu z vlastností „základní“ nabídky (pokud toto nastavení nezvládne uživatel samostatně, musí se obrátit na svého implementátora). Lišta „základní“ nabídky potom může vypadat následovně:

V činnosti Příkazy k úhradě probíhá kontrola následujícím způsobem. Po aktivaci doplňující vlastnosti se nejprve zobrazí informace o čísle příkazu, následným kliknutím myši (kamkoliv na formuláři) se aktivuje kontrola všech položek příkazu. V případě, že jsou všechny položky (adresáti s DIČ začínajícím „CZ“) v pořádku, tj. jsou vyhodnoceni jako spolehlivý plátce a mají zveřejněný účet, zobrazí se informativní hláška „kontrola ukončena“. V případě, že kontrola zjistí nesoulad registrace a příkazu k úhradě (chybné DIČ nebo jiný bankovní účet na příkazu), informuje o tomto zjištění uživatele, např. takto:

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 12.04.2013


Pojem - Neviditelné atributy

Jedná se o jednotlivé atributy v událostech komponent, které jsou pro běžného uživatele neviditelné, čili nejsou standarně v událostech zobrazované, např. v událostech vývěsky se jedná o atributy časové identifikace, identifikace procesu apod. V datovém modelu jsou tyto atributy k dispozici, v okně události vývěsky pro uživatele k dispozici nejsou, přesto je o nich v programu veden záznam. V podstatě existují atributy tabulky (datového modelu), které jsou viditelné v databázi (pro uživatele dostupné) a neviditelné v databázi (uživateli nedostupné). Atributy z jiných tabulek je možno nejen zobrazovat, ale pokud je to umožněno, tak i opravovat.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 17.12.2007


Pojem - Nový proces

Jedná se o skupinovou položku menu, jejíž obsah (položky menu) je uživatelsky definován dle implementace skupin procesů a druhů procesů, které mají nastaveno "Zobrazit v menu" a nejedná se o skryté procesy. Pokud zmíněné druhy procesů mají uvedenu skupinu procesů, jsou zde v ní k dispozici, pokud nejsou přímo pod položkou menu "NOVÝ PROCES".

Uživatel má možnost zde zahajovat nové procesy, pokud k tomu má právo (definuje se u druhu procesu).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 17.12.2007


Pojem - Obecná předkontace

Obecná předkontace je činnost IS Bílý Motýl dostupná ve složce informační centrum, která umožňuje definovat obecné dvourozměrné tabulky a ty plnit definičními daty. U každé předkontace se definuje identifikace, název a druh, kterým je možné zároveň definovat přístupová práva k obecné předkontaci.

Vlastností obecné předkontace je dále možnost stanovit, že jedním rozměrem definované tabulky je ID adresáta. V tomto případě je obecná předkontace dostupná i z adresáře (menu Volby – činnost „předkontace adresáta“ nebo klávesa F7), kde se zobrazí všechny předkontace adresáta.

Oblasti možného využití obecné předkontace:

¨ obecné výběry,

¨ maska operace,

¨ šablony, transformace ve vazbě uzlů,

¨ výběry ve slovníku dat,

¨ výstupy,

¨ dle potřeby implementátora v těch místech IS, kde má možnost užít příkaz SELECT (např. sestavy, obecné výběry, …).

Výsledkem (vyhodnocením obecné předkontace) je hodnota přiřazená k významu. Syntaxe (způsob zápisu) použití má obvykle tvar: „#P <výraz1>;<výraz2>“ (výraz 1 je identifikace předkontace, výraz 2 je význam), kde <výraz x> je v daném okamžiku vyhodnotitelný výraz ve formátu FoxPro, např. (~#P 'FP-028';'IDU'+RIGHT(tool.user,2)).

Při použití numerických hodnot má tvar: ~~VAL(TOOL.HODNOTA_OBECNE_PREDKONTACE(‘ADDIPR’,data.ad01id1)), což je příklad, kdy k adresátovi uvedenému v příjemci (události obchodu) se obecnou předkontací ADDIPR přiřazuje hodnota provize.

Příklady:

1. Definuje tabulku (autorizovaný distributor - procento provize), která se užívá k automatizovanému výpočtu výše provize z prodeje v transformaci.

2. Definuje tabulku (autorizovaný distributor - kategorie adresátů, které spravuje), která se užívá k výběru dostupných údajů na webu o spravovaných zákaznících (platby, prodeje, konfigurace, ...).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 17.12.2007


Pojem - Obecná předkontace v maskách

V masce operace je možné využít obecnou předkontaci výrazem ve tvaru : „##P <výraz1>;<výraz2>[;default]“, kde <výraz1> je identifikace obecné předkontace a <výraz2> je význam v obecné předkontaci. Pokud obecná předkontace nemá k danému významu definovánu hodnotu, uplatní se implicitní default (tj. implicitní hodnota). Daná předkontace se vyhodnotí teprve v okamžiku vstupu na danou položku (atribut), a to pouze v případě, že neobsahuje (nebyl předplněn automatizací vstupu událostí) žádnou textovou hodnotu nebo že je uživateli nepřístupná.

Např. můžeme definovat dynamickou obecnou předkontaci adresáta určující jeho obvyklou obchodní smlouvu v operaci dodání identifikovanou např. „SMLOUV“, potom můžeme v masce operace příp. v masce operace v procesu použít u atributu „Obchodní smlouva“ definici ve tvaru: „##P ‘SMLOUV’;$$$.ad01id“ (znaky $$$ budou nahrazeny odpovídajícími alias). Pak je zřejmě dle atributu identifikace adresáta (ad01id) uvedeného v události předplněn atribut obchodní smlouva hodnotou obecné předkontace, která je předdefinována v obecné předkontaci s identifikací SMLOUV u významu, který se rovná identifikaci adresáta.

Podobně je možné např. určit jiného příjemce-dodavatele v události obchodu než je zadaný adresát, jiné než implicitní spojení apod.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 17.12.2007


Pojem - Obecná předkontace v transformacích a v šablonách

Při použití obecné předkontace v pravidle transformace mezi uzly procesů se ve výrazu uvádí tato definice:

... "~#P <výraz1>;<výraz2>[;default]“ ... kde <výraz1> je identifikace obecné předkontace a <výraz2> je význam v obecné předkontaci. Pokud obecná předkontace nemá k danému významu definovánu hodnotu, uplatní se implicitní default (tj. implicitní hodnota). Např.: výraz ~#P 'FP-028';'IDU'+RIGHT(tool.user,2)) vrátí hodnotu uvedenou v obecné předkontaci s identifikací FP-028 u významu, který vyplývá z identifikace datového úložiště (např.IDU11).

Hodnota daná výrazem s obecnou předkontací v transformaci v procesech se vyhodnocuje ještě před zápisem cílových událostí, takže je možné ji využít i v agregačním výrazu pravidla transformace. Agregační výraz pak má tuto syntaxi:

... „~DATA.v_<VstAtrKom>“ ..., kde <VstAtrKom>“ je některý vstupní atribut cílové události, jehož hodnota je definována pomocí obecné předkontace a podle kterého proběhne agregace.

Příklad transformace do účetnictví, kdy daný druh artiklu se dle skladu účtuje na různé účty. Pak jsou definovány obecné předkontace pro každý sklad (např. S-11 pro sklad číslo 11) s významem dle druhu artiklu a hodnotou odpovídající účtu z účetní osnovy. Výraz transformace pro předplnění účtu v cílové události komponenty účetnictví může mít následně tvar „~#P ‘S-‘+DATA.mt04id;’A-‘+DATA.sp61id“ (mt04id je identifikace skladu, sp61id je identifikace druhu artiklu). Agregační výraz dle čísla účtu "vypočteného" z obecné předkontace je v tomto případě : „~DATA.v_uc01id“ (uc01id je identifikace účtu účetnictví).

V šablonách je možné použít obecné předkontace pro předdefinování různých inicializačních hodnot (tím je míněn atribut inicializace v proměnných šablony). Dále je možné v šablonách tímto způsobem předdefinovat různé obsahy překryvných seznamů. V šablonách se neuvádí znak vlnovka.

Příklad inicializace překryvného seznam pro údaj odpovídající SPZ - „#P ‘SPZ’;’IDU’+RIGHT(tool.user,2)“ dle datového úložiště nebo „#P ‘SPZ’;tool.uziv“ dle uživatele.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 17.12.2007


Pojem - Obecné – v menu horní lišty

Jedná se o položku z horní lišty okna, která je v celém IS BM stejná pro všechny činnosti. Nabídka pod volbou Obecné se může měnit v závislosti na spuštěné činnosti, tzn. že nemusí být vždy přístupné (tj. vysvícené) nebo zobrazené všechny možnosti, které tato položka menu obsahuje. Jsou to:

¨ následující připravené operace – po aktivaci této možnosti se spustí, pokud existují, následující připravené operace (tato volba je obvykle dostupná u operací jednotlivých procesů)

¨ průběh operací

¨ zásobník operací

¨ činnosti hlavního menu – zobrazují se činnosti hlavního menu (a dvojklikem na nich je možno je rovnou aktivovat), které mají ve svých vlastnostech nadefinováno spouštění na funkční klávesu

¨ hledání (nahoru)

¨ parametry formuláře

¨ uchovat pozici okna formuláře

¨ doplňující vlastnosti formuláře

¨ oprávnění k činnosti

¨ najít (Ctrl F)

¨ hlavní menu – aktivuje se okno hlavního menu

¨ informace o aktualizaci – zobrazí se okno s údaji kdo, kdy a v jaký čas daný záznam aktualizoval

¨ export dat do balíčku (pouze, pokud činnost prezentuje přenositelné definice)

¨ znovu načíst – aktualizuje se daná činnost nebo záznam

¨ statistika SQL – činnost určená zejména implementátorům (informace o tom, jaký je použit select apod.)

¨ počet odkazů na záznam – informace o tom, kde všude je s daným záznamem (adresátem, artiklem apod.) pracováno (v které komponentě, události apod.), resp. informace o tom, kde všude je použit

¨ zablokovat systém BM

¨ import/Export dat

¨ nabídky (definovat, aktivovat) – možnost definice a užívání vytvořených nabídek

¨ obecné výběry (definovat, aktivovat)

¨ volné karty (definovat, aktivovat)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 16.05.2008


Pojem - Obecné kalendáře

Činnost Obecné kalendáře se nachází v Informačním centru, v podskupině Typy a řady. Uživatel může definovat kalendáře typu:

¨ denní kalendář

¨ týdenní kalendář

Tyto typy souvisí s uloženou funkcí databáze 'SPKALEN_platny_den', která slouží ke zjišťování platného data určeného kalendáře v SQL dotazech.

Pro typ 'Denní kalendář' musí být jednotlivé platné dny kalendáře vyjmenovány (záložka Jednotlivé dny kalendáře).

Pro typ 'Týdenní kalendář' je den považován za platný, pokud odpovídá určenému dne týdne daného kalendáře (záložka Dny v týdnu kalendáře).

Při definování nového kalendáře má uživatel k dispozici tři záložky:

¨ kalendáře

¨ dny v týdnu kalendáře

¨ jednotlivé dny kalendáře

Na záložce kalendáře zadá uživatel identifikaci, název a typ kalendáře. A pak podle toho, zda si zvolil typ denní nebo týdenní vyplňuje další záložky.

Záložka Dny v týdnu kalendáře obsahuje výčet dnů v týdnu, které mají pro daný kalendář význam. Uživatel zadává den, část dne (¨klávesou F2 se na tomto překryvném seznamu vyvolává formulář pro definování částí dne. Podstatnou informací části dne pro vyhodnocování funkcí 'SPKALEN_platny_den' je počáteční a konečná hodina - vyhodnocuje datum včetně času. Částí dne může být např. pracovní směna nebo celý den) a poznámku. Automatizovaně vstupovat jednotlivé dny kalendáře lze po stisku klávesy F5 pomocí funkce Předplnit kalendář.

Záložka Jednotlivé dny kalendáře obsahuje výčet jednotlivých dnů kalendáře. Pro typ kalendáře Denní musí být den na této záložce uveden jako platný, proto aby funkce 'SPKALEN_platny_den' vyhodnotila jí vyhodnocované datum jako platné. Kromě data se na této záložce uvádí část dne a stav dne Platný Ano/Ne. Automatizovaně vstupovat jednotlivé dny kalendáře lze po stisku klávesy F5 pomocí funkce Předplnit kalendář.

Platný den uvedený pro typ kalendáře Týdenní, který není dnem v týdnu uvedeným na záložce 'Dny v týdnu kalendáře' , je funkcí 'SPKALEN_platny_den' vyhodnocen jako platný.

Neplatný den uvedený pro typ kalendáře Týdenní, který je dnem v týdnu uvedeným na záložce 'Dny v týdnu kalendáře' , je funkcí 'SPKALEN_platny_den' vyhodnocen jako neplatný.

Funkce - SPKALEN_platny_den

Parametry: in @spd3id char(6),in @spd4datum timestamp,in @bw10nazev char(8),in @spd7id char(6)

@spd3id - identifikace kalendáře

@spd4datum - datum/datumčas - dotazované datum

@bw10nazev - entita, které se týká výjimka kalendáře

@spd7id - hodnota primárního klíče entity, které se týká výjimka kalendáře

Funkce vrací numerickou hodnotu (tinyint) :

0 - dotazované datum v určeném kalendáři je neplatné

1 - dotazované datum v určeném kalendáři je platné

Parametry @bw10nazev a @spd7id souvisí s používáním obecných kalendářů v komponentách IS BM, např. v komponentě Expedice, kde má smysl definovat kalendář pro trasu pro výpočet rozdělení dodacích listů na expediční příkazy.

Příklad : tuto trasu jezdíme v pondělí a ve čtvrtek a můžeme pro ní zadat výjimku na tento konkrétní den (i když je to středa, tak tuto trasu pojedeme) nebo výjimku i pro jiný den (i když je to čtvrtek, tak nepojedeme, protože je např. sněhová kalamita). V expedici se používají obecné kalendáře také ve spojení s tabulkou řidičů. Výjimky v kalendáři jsou ukládány ve společné entitě (SPKALENV).

Př.:

obecný výběr událostí vývěsky, které mají platné datum podle kalendáře 'K1'

bm_servis.SPKALEN_platny_den('K1 ',VYUDALOS.vy01datum,null,null)=1

Obecný kalendář používá tyto tabulky:

SPKALEN - Obecný kalendář

SPKALENT - Den v týdnu obecného kalendáře

SPKALEND - Den obecného kalendáře

SPKALENC - Část dne v obecném kalendáři

SPKALENV - Výjimka v obecném kalendáři

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 17.12.2007


Pojem - Obecné parametry

Tato činnost definuje parametry spojované s objekty IS BM (pomocí činnosti sady parametrů). U každého parametru se definuje nejprve záložka „obecné parametry“:

¨ identifikace a název

¨ druh – určuje práva přístupu k parametru

¨ číselník

¨ výraz – výraz zobrazení v mřížce

¨ perioda platnosti – inicializace data platnosti hodnoty parametru do – v měsících

Na záložce „elementární hodnoty“ se definuje:

¨ elementární hodnota – může být typu:

¨ datumová - 2 hodnoty - identifikace ##pa06dat1## a ##pa06dat2##

¨ numerická - 2 hodnoty - identifikace ##pa06num1## a ##pa06num2##

¨ textová - 1 hodnota - 60 znaků - identifikace ##pa06text1##

¨ seznam - 2 hodnoty - identifikace ##pa06cmb1## a ##pa06cmb2##

¨ adresát - 1 hodnota (včetně spojení adresáta a bankovního spojení) - identifikace ##ad01id## nebo ##ad01adsat##

¨ druh – určuje práva přístupu k elementární hodnotě

¨ texty uváděné v atributech elementární 'návěští' a 'stavový řádek' se uplatňují při vstupu hodnoty parametru ve formuláři.

¨ v atributu 'zobrazení' je vhodné pro elementární hodnoty typu seznam uvádět seznam hodnot oddělených čárkou.

¨ v atributu 'inicializace' se uvádí výraz v syntaxi SYBASE SQL Anywhere, který se uplatní při inicializaci parametru (např. pro datum - CURRENT DATE).

¨ výraz validace se uplatňuje při změně elementární hodnoty prováděné uživatelem (výraz musí být uveden ve formátu Foxpro).

V tomto výrazu je možné uvádět makro ###, které bude nahrazeno identifikátorem elementární hodnoty. Např. výrazy validace uvedené u elementární hodnoty pa06num1:

¨ ###>0

¨ pa06num1>0

mají stejný efekt.

Při konstrukci výrazu validace týkající se elementárních hodnot typu datum je třeba nezapomínat, že prázdné datum je v databázi ukládáno jako hodnota NULL. Bezpečný validační výraz respektující tuto skutečnost může být např.:

¨ !EMPTY(NVL(pa06dat1,{}))

¨ nebo NVL(pa06dat2,{})>NVL(pa06dat1,{})

Výraz uvedený na první záložce u popisu obecného parametru definuje výraz, jehož hodnota je zobrazovaná na mřížce při vstupu hodnoty parametru a při tisku. Výraz se uvádí v syntaxi Foxpro. Identifikátory jednotlivých elementárních hodnot parametru se ve výrazu uvádějí a ukončují znaky ## (proto, aby výraz fungoval při prohlížení dat i při tisku). Výsledkem vyhodnocení výrazu musí být hodnota legálního typu.

Např. správně:

¨ ##pa06num1##

¨ ##pa06num2##

¨ ##pa06dat1##

¨ dtoc(##pa06dat1##)+' - '+dtoc(##pa06dat1##)

¨ TRIM(##ad01adsat##)+' - '+dtoc(##pa06dat1##)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 17.12.2007


Pojem - Obecné stromy

Činnost „obecné stromy“ se nachází v hlavním menu v Informačním centru – Typy a řady. Umožňuje uživatelsky definovat vztahy mezi daty a následně tyto vztahy zobrazovat ve formě stromu (podobný formát jako např. strom hlavního procesu). Uživatelsky změnit zobrazení a ovládání obecného stromu lze pomocí činnosti „nastavení stromu“. Tuto činnost uživatel aktivuje po stisku pravého tlačítka myši na názvu činností v obecném stromu nebo kdekoliv ve volném prostoru obecného stromu.

Ve formuláři "Definice obecných stromů" se definují uzly stromů a vztahy mezi nimi. Na záložce "Uzly obecného stromu" se definují tyto atributy:

¨ identifikace uzlu - jednoznačně identifikuje uzel

¨ název uzlu - pro vrcholový uzel určuje název odpovídající položky hlavního menu a nadpis formuláře stromu

¨ druh uzlu - definuje práva přístupu

¨ ikona uzlu - určuje ikonu, která bude použita pro položky odvozené z definice uzlu

¨ volba vrcholový uzel Ano/Ne - pro vrcholové uzly je možné vyvolávat výsledný strom a objeví se také jako položky hlavního menu programu v menu VYVOLÁNÍ OBECNÉHO STROMU

¨ SQL dotaz - výstupem tohoto dotazu jsou určeny položky stromu vzniklé na základě dané definice

¨ výraz třídění - výraz v jazyce Foxpro - definuje setřídění dat

¨ výraz zobrazení - výraz v jazyce Foxpro - definuje text zobrazený ve stromu

¨ výraz hiearchie - výraz v jazyce Foxpro - určuje, že daná definice uzlu určuje hierarchické zobrazení

¨ maska hierarchie - text - rozpadá hodnotu vyhodnocenou výrazem hierachie do struktury stromu

¨ poznámka

Příklad uzlu definujícího hierarchické zobrazení obchodního selektoru, ve vlastnostech definice uzlu:

¨ SQL dotaz - SELECT sp10idzak,sp10text FROM %%%.SPSEOB WHERE sp10idzak like '____00000'

¨ výraz třídění - sp10text

¨ výraz zobrazení - sp10text

¨ výraz hiearchie - sp10idzak

¨ maska hierarchie – AABC (tj. záznamy, které mají prvé dva znaky v sp10idzak shodné se vyskytují na stejné úrovni menu)

Na záložce "Připojené uzly" se k odpovídající definici uzlu připojují uzly, jejichž definice jsou zpracovávány dynamicky pro jednotlivé položky výsledného stromu. Definují se tyto vlastnosti:

¨ identifikace připojeného uzlu

¨ alias - totožný uzel může být při použití aliasu připojen vícekrát

¨ pořadí připojeného uzlu

¨ skutečné parametry - seznam výrazů v jazyce Foxpro oddělených čárkou , ve kterých je možné použít odkazy na objekt _DATA, který obsahuje jako atributy aktuální položky výsledného stromu - maximální počet paramertů je 8

¨ doplnění WHERE - obsahuje fragment příkazu SQL, který bude doplněn k SQL dotazu při zpracování připojeného uzlu, je v něm možné použít odkaz na hodnoty výrazu "skutečných parametrů" uvedením výrazu ?_pX, X je pozice výrazu v seznamu skutečných parametrů

¨ výraz třídění - výraz v jazyce Foxpro - definuje setřídění dat - je-li uveden přebíjí odpovídající atribut v připojeném uzlu

Příklad napojení adresáře na uzel obchodního selektoru z předchozího příkazu:

¨ předpokládá se, že připojený uzel má ve vlastnosti "SQL dotaz" uvedeno - SELECT ad01id,ad01adsat FROM %%%.ADADSAT

¨ skutečné parametry - LEFT(_data.sp10idzak,4)+'%'

¨ doplnění WHERE - ADADSAT.sp10idzak LIKE ?_p1

Ke každé definici uzlu je možné připojit skript v jazyce Foxpro vyvolávaný při dvojím kliku na odpovídající položce výsledného stromu. Skript je možné definovat volbou F5 menu formuláře a je v něm možné používat odkazy na knihovny vkládaného kódu (např. výstup do HTML). V okamžiku vyvolání skriptu je dostupný objekt _DATA, který obsahuje jako atributy aktuální položky výsledného stromu. Např. pro spuštění adresáře se zobrazením odpovídajícího adresáta by bylo možné použít:

¨ tool.makroprikaz([do form AD0137 with '','',.F.,'A',_p1],_data.ad01id)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 03.06.2008


Pojem - Obecný výběr

Je to nástroj, který rozšiřuje možnosti standardního výběru a je uživatelsky definovatelný. Nadefinované obecné výběry je možno importovat pomocí balíčku a je možno je používat jako doplnění běžných výběrů v každé činnosti nebo jako pevný výběr, pokud se výběr definuje přímo jako vlastnost dané činnosti (po stisku pravého tlačítka myši na činnosti). Výběry je možno definovat v každé činnosti pod záložkou Obecné – Obecné výběry – Definovat obecné výběry.

U každého výběru uživatel zadává jeho název, příznak, zda se jedná o výběr veřejný a pak výraz, který je nejdůležitější součástí výběru. Ve výrazu se obecnému výběru určuje, jaké atributy a jejich hodnoty má vyhledat.

Na záložce „proměnné“ se definují jednotlivé proměnné obecného výběru. Jejich popisem se zde nemusíme podrobně zabývat (je popsáno v helpu), chovají se stejně jako proměnné šablony nebo volné karty. Ve většině obecných výběrů se ani proměnné nedefinují, obecný výběr je dostatečně definován zadaným výrazem, ale v některých případech je možno proměnné definovat, např. pokud se při aktivování obecného výběru má systém ještě dotázat na datum od – do.

Ve výrazu je možno zadat jakékoliv atributy, např.:

¨ SPPRC.sp33storno=2 - tento obecný výběr v činnosti Procesy vybere pouze procesy, které jsou stornované

¨ not ADADRI.ad05id like ‘CZ%’ - tento obecný výběr v činnosti adresář vybere pouze ty adresáty, kteří jsou zahraniční, tj. jsou cizinci

¨ EXISTS (SELECT ADSPOJI.ad12id FROM %%%.ADSPOJ ADSPOJI WHERE ADSPOJI.ad01id=ADADSAT.ad01id AND TRIM(ADSPOJI.ad12id)='EMAIL') - tento obecný výběr vybere pouze ty adresáty, kteří mají spojení typu e-mail

Typ proměnné výběru „makro“ slouží k definování vstupního textového pole pro sestavení podmínky výběru. Po vyvolání výběru má uživatel možnost vybírat předdefinovaná makra v menu po pravém kliku myší na tomto poli. Kromě výběru makra do sestavované podmínky má uživatel po pravém kliku myší na poli typu „makro“ možnost ukládat (odstraňovat) a následně vybírat vzory sestavených podmínek. Každý uživatel si takto může vytvářet své vlastní soubory vzorů sestavených podmínek (tabulka pro uložení těchto vzorů je sdílena s formulářem Označování výrazem). Makra připravuje pro uživatele implementátor systému položkou menu Volby – Definice maker formuláře pro definování obecných výběrů (použití obecných výběrů s proměnnými výběru typu makro je možné pouze ve verzích BM pod Visual Foxpro 8 nebo vyšší).

Na záložce „spojené předlohy výstupu“ si uživatel může nadefinovat, která předloha výstupu bude spojena s daným obecným výběrem. U této definice pak platí, že pokud je určitá předloha spojena s daným výběrem, funguje pouze za předpokladu, že je použit daný obecný výběr, nelze ji pak pustit samostatně.

Na záložce „užití výběru“ se sleduje využívání jednotlivých obecných výběrů. Tento přehled může sloužit i jako podklad pro implementátora při rozhodování o vyřazování nepoužívaných obecných výběrů. Zobrazuje se kdo (jméno uživatele), kdy poprvé (datum prvního použití výběru uživatelem), kdy naposledy (datum posledního použití výběru uživatelem) a kolikrát (celkový počet použití výběru uživatelem). Tyto informace se ukládají do tabulky SPVYBERU s atributy (sp27id - primárního klíč obecného výběru, bw01uziv - kdo - identifikace uživatele, spe6dat1 - kdy poprvé, spe6dat2 - kdy naposledy, spe6pocet – kolikrát). Hodnoty proměnných obecného výběru formuláře jsou dostupné v objektu: THISFORM.OBEC_VYBER.VAR, který obsahuje vlastnosti odpovídající názvům a hodnotám proměnných aktuálního obecného výběru, např. THISFORM.OBEC_VYBER.VAR.DATUM

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 25.09.2012


Pojem - Objekt

Objektem se z hlediska informačního systému Bílý Motýl rozumí záznamy v těch tabulkách (entitách), které jsou v programovém kódu definovány jako objekt. Následně je možné v činnostech určených pro přehled záznamů v těchto entitách využívat funkcí souvisejících s vazbou objektů. O přítomnosti objektové vazby uživatele informují i příslušná znaménka v rámečku souvislostí. Objektem mohou být pouze záznamy těch entit, které mají atribut jednoznačné časové identifikace.

Mimo rámec IS BM se objektem obvykle rozumí každá entita (tabulka) datového modelu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 18.12.2007


Pojem - Objektová vazba

Podrobný popis je uveden u pojmu „vazba objektů“.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 23.01.2008


Pojem - Oblíbené skupiny uživatelů

Tato činnost umožňuje uživateli nadefinovat oblíbené skupiny uživatelů, které využije při zasílání zpráv (odesílání zpráv více uživatelům najednou - pomocí šablony) nebo při zápisu do diáře ostatním pracovníkům. Při odesílání zprávy pouze jednomu uživateli tuto činnost nevyužije. V jedné skupině může mít např. pouze pracovníky obchodního oddělení, kterým posílá zprávy o obchodních jednáních, druhá skupina mohou být např. pracovníci systémové integrace apod. Využíváním oblíbených skupin si uživatel značně zjednoduší práci, protože nemusí jednotlivé pracovníky vybírat ze seznamu po jednom a nedojde tím k situaci, že by na někoho nechtěně zapomněl.

Uživatel v této činnosti zadává identifikaci a název skupiny. Po stisku záložky "uživatelé ve skupině" přiřazuje jednotlivé uživatele do aktuální skupiny. Výběr uživatelů do dané skupiny se provádí zatržením příznaku označení (tj. malé okénko před vlastním jménem uživatele).

Po nadefinování jednotlivých skupin (včetně přiřazení uživatelů do skupiny) má uživatel možnost prohlížet si záznamy v diáři vybrané skupiny uživatelů. Tento diář lze vyvolat stiskem klávesy F5 nebo výběrem činnosti z menu "volby".

Pokud si uživatel nenadefinuje žádnou oblíbenou skupinu uživatelů, nabízí se mu při zasílání zpráv nebo při zápisu do diáře seznam všech uživatelů systému, ze kterého si pak vybírá jednotlivé příjemce. Pokud má skupinu nadefinovanou, pak při odesílání zprávy pomocí šablony si v prvním překryvném seznamu tuto skupinu vybere.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 11.03.2008


Pojem - Obratové hodnoty

V případě hodnot – obraty se jedná o obratové tabulky. Pro tyto hodnoty je důležité, zda je, či není u daného druhu hodnoty při jejich definování zatržen příznak „den do hodnoty obratu“, tzn. zda se má počítat obrat denní nebo implicitní obrat měsíční. Obraty jsou k dispozici v komponentách účetnictví (kde to není závislé na definici druhu hodnoty, neboť účetnictví má jediný druh hodnoty "stav účtu" a ten je implicitní), sklad a změna stavu peněz a ukazují vždy počáteční stav k datu, příjmy, výdeje a konečný stav k datu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 18.12.2007


Pojem - Obraty skladu

Při práci s obratovou tabulkou skladu je nutno si uvědomit, jaké informace uživatel potřebuje mít k dispozici. Zobrazení potřebných údajů je přímo závislé na tom, jakým způsobem si uživatel nadefinuje záložku „výběr“. Jako u jiných výběrových záložek je možno si vybírat z několika atributů, na základě kterých se budou vybírat data. Kromě těch běžných jako je datum, druh hodnoty, adresát, artikl, sklad apod. je zde atribut, který má zásadní význam pro zobrazení dat. Tento atribut se nazývá „poslední obrat“ a dosahuje těchto hodnot:

¨ neurčeno – zobrazuje veškeré obraty nezávisle na období (tzn. není nutno zadávat žádné období od – do). Tuto hodnotu je vhodné využít např. při zobrazení hodnot za vybraný sklad, artikl nebo adresáta.

¨ zahrnout – hodnota zahrnout naopak úzce souvisí s obdobím od – do. Při použití hodnoty zahrnout je zároveň nutno zadat období OD – DO a systém pak zobrazí obraty za dané období s tím, že pokud u některého artiklu nenajde obrat v zadaném období OD – DO, zobrazí obrat s nejvyšším nižším datem

¨ pouze – hodnotu pouze má smysl používat nikoliv pro zjišťování obratů, ale pro zjištění konečných stavů s tím, že zároveň s touto hodnotou musí být uvedeno období DO (období OD zůstává nevyplněné).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 18.12.2007


Pojem - Obrazovka uživatele

Tato činnost je dostupná v činnosti „přehled přihlášených (SQL)“ (hlavní menu – Systém) pod menu Volby.

Činnost vyvolá formulář, ve kterém je periodicky (podle nastaveného parametru) zobrazován obsah obrazovky daného uživatele (obrazovka Windows ve formátu JPEG). Obrazovka se nezobrazuje pokud uživatel pracuje v režimu Terminal – Server. Pro správnou funkčnost této činnosti jsou nutná tyto nastavení:

¨ v adresáři BMSQL\PRGS musí být nahrán soubor JPGDLL.DLL

¨ je nutné k této činnosti nadefinovat právo přístupu některé skupině uživatelů (v činnosti oprávnění k činnostem)

¨ nastavit parametr programu BM SpySleepInterval

Interval periodického čtení je dán nastavením programu BM:

¨ Preferencess – SpySleepInterval – ten určuje periodu ve vteřinách v situaci, kdy není žádný požadavek na sejmutí obrazovky (resp. zjištění stavu)

¨ Preferencess – SpyRunInterval – ten určuje periodu ve vteřinách, na kterou se změní interval čtení záznamu v tabulce BWCONNEQ po dobu trvání požadavku na sejmutí obrazovky (resp. zjištění stavu)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 18.12.2007


Pojem - Odblokovač

Podrobný popis je uveden u pojmu „zrušit stav ukončena“.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 23.01.2008


Pojem - Odesílání e-mailů z IS BM s použitím objektu Outlooku

Nastavení programu BM (hlavní menu – Systém) MSMAPI->UseOutlook=1 způsobí to, že pro odesílání emailu z IS BM bude používán objekt Outlooku místo objektu vyvolaného z MSMAPI32.OCX.

Použití objektu Outlooku přináší následující výhody:

¨ při editaci mailu před jeho odesláním se používá plnohodnotný Word, tzn. že je možné např. používat tučné písmo, vkládat tabulky, vkládat obrázky, ...

¨ text mailu předplněný z BM může být ve formátu HTML (tj. může obsahovat např. logo firmy, tabulky, tučné písmo,...) - text mailu musí v tomto případě začínat tagem <pre><HTML></pre>

¨ Outlook dokáže takto vytvořené maily posílat do Datové schránky (pro tuto funkci je nutno v Outlooku nainstalovat potřebný plug-in)

¨ při automatickém odesílání mailu (bez možnosti opravy uživatelem) není třeba potvrzení uživatele o tom, že program BM je oprávněn odeslat mail

Při použití objektu Outlooku je možné také vyvolávat program BW_MAPI tak, že BM nečeká na ukončení úpravy mailu uživatelem BM_MAPI, který má nyní parametry:

lcrecipaddress,lcsubject,lcmessagetext,lcfiles,randomsend,sp38id

přitom parametr randomsend může mít hodnoty:

.T. nebo 0 - mail bude odeslán bez možnosti jeho úpravy

.F. nebo 1 - mail se nabídne k úpravě - program BM zastaví a čeká na ukončení úpravy mailu

2 - mail se nabídne k úpravě - program BM nezastaví a nečeká na ukončení úpravy mailu

V předlohách výstupu je možné použít příkaz:

.MAIL_SEND 2

Pro vložení firemního loga do mailu ve formátu HTML je třeba:

¨ soubor obrázku musí být v mailu uveden mezi přílohami dokumentu

¨ obrázek je v uveden v textu mailu v syntaxi cid:<název souboru bez cesty>, např. <pre>'<p><img width=218 height=80 src="cid:fi_logo.gif"></p>'</pre>

Dalším Nastavením programu BM MSMAPI->MailTemplate=<identifikace volného textu> (uplatní se pouze při nastavení MSMAPI->UseOutlook=1), je možné vytvářet vzhledově jednotné maily, které na svém konci obsahují např. logo firmy, kontaktní informace odesílatele mailu např. telefonní číslo, emailovou adresu, odkaz na webovou stránku, ...).

V tomto nastavení se uvádí <identifikace volného textu>. Volné texty se definují ve formuláři 'Volné texty' (INFORMAČNÍ CENTRUM -> TYPY A ŘADY -> Volné texty). Volný text použitý pro vytváření vzhledově jednotných mailů, by měl:

¨ být ve formátu HTML - tj. měl by začínat textem <pre><HTML></pre> a dále by měl obsahovat makro ##BODY##, které bude nahrazeno textem mailu

¨ v položce 'Kód' na záložce 'Další' - by měl obsahovat kód v jazyce Foxpro, který vrací upravený text (doplnění kontaktní informace odesílatele mailu např. jeho jméno, telefonní číslo, ...)

¨ v položce 'Přílohy mailu' na záložce 'Další' - je možné uvádět seznam souborů (obrázků), které budou doplněny do mailu jako přílohy - např. výsledný mail má obsahovat firemní logo (tj. ve volném textu je uvedeno

<pre>'<p><img width=218 height=80 src="cid:fi_logo.gif"></p>'</pre>), potom by měl být uveden soubor třeba 'bmps\fi_logo.gif'

Text mailu, který nahradí ve výsledném mailu makro ##BODY## musí obsahovat html-tagy pro odřádkování (BR).

Pro zjištění výsledného tvaru kostry mailu používá BM metodu 'tool.sptexty_vrat_text', která má parametry:

¨ _SP88ID - identifikace volného textu

¨ _SP38ID - jazyk volného textu (nepovinný)

Vrací upravený text v daném jazyce (pokud není takový text v jazyce definovaný, tak v jazyce uživatele). Text upraví spuštěním 'kódu' uvedeného u textu. 'Kódu' jsou předány parametry:

¨ _SP89OBSAH - text volného textu

¨ _DATA - objekt, který obsahuje všechny atributy volného textu - mj. atribut SP38ID (_DATA.SP38ID), ve kterém je jazyk textu (tj. _SP89OBSAH)

Příklad volného textu určeného pro vytváření vzhledově jednotných mailů.

'Text' volného textu např.:

<pre>

<html>

<body>

##BODY##

<br>

<span style='color:navy;'>S pozdravem</span><br>

<b><span style='color:navy;'><<tool.jmenot>></span><b><br>

<br>

<p><img width=218 height=80 src="cid:fi_logo.gif"></p>

<span style='color:navy;'>Naše firma s.r.o.</span><br>

<span style='color:navy;'>Uliční 1, 999 99 Kolobřehy</span><br>

<span style='color:navy;'>Tel.: +420 999 999 999 (sekretariát), <<alltrim(tool.sql_dotaz([select bw01telef from %%%.bwuzivat where bw01uziv=?tool.uziv]))>> (přímý)</span><br>

<span style='color:navy;'>Fax: +420 999 999 999</span><br>

<span style='color:navy;'>Skype: ???</span><br>

<span style='color:navy;'><a href="http://www.nasefirma.cz/">http://www.nasefirma.cz/</a></span>

<span style='color:navy;'>, </span><span style='color:navy;'><a href="http://nasefirma.inshop.cz/">http://nasefirma.inshop.cz/</a></span><br>

</body>

</html>

</pre>

'Kód' volného textu např.:

<pre>

Local _rt,_err

Try

_rt=Textmerge(_sp89obsah)

Catch To _err

_rt='<h1>'+_err.Message+'</h1>'+Chr(13)+Chr(10)+_sp89obsah

Endtry

Return _rt

</pre>

'Přílohy mailu' volného textu např.:

bmps\fi_logo.gif

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.02.2012


Pojem - Odpisovaný majetek

Komponenta je určena na podporu správy a evidence odepisovaných aktiv, kterými se zde rozumí odpisovaný majetek dle účetních i daňových odpisů a dále neuhrazené pohledávky, na které bylo možné uplatnit odpis nebo opravné položky.

Jako aktér je v odpisovaném majetku implementován adresát z IC. Jako artikl je implementován odpisovaný majetek (karta), který referuje třídu SKP, organizační a technicko věcný selektor. Artikl lze členit dle druhu investičního majetku (např.: hmotný investiční majetek, nehmotný investiční majetek, …). Atribut účetní selektor je dostupný jako výstupní atribut komponenty. Atribut datum zařazení a vyřazení je aktualizován nejnižším datem z relevantních událostí druhu příjem, resp. výdej.

Na záložce účetní odpis lze definovat parametry pro výpočet účetního odpisu (automatizovaný výpočet výše odpisů při volbě metody dle času, výkonu nebo dle daňových odpisů je podporován pomocí relevantní šablony). Atribut účetní pořizovací a zůstatková cena je aktualizován dle finanční částek z relevantních událostí se zatrženou aktualizací dané částky.

Na záložce daňový odpis lze definovat parametry (odpisová skupina, procento snížení odpisu) pro výpočet daňového odpisu (automatizovaný výpočet výše odpisů na konci roku při volbě rovnoměrně či zrychleně je podporován pomocí relevantní šablony). Atributy vstupní a zůstatková cena, datum prvního a posledního technického zhodnocení jsou aktualizovány dle relevantních událostí. Počet uplatněných odpisů z nezvýšené i ze zvýšené ceny je aktualizován šablonou s vyprogramovaným vstupem Daňový odpis. Atribut odhad počtu odpisů je aktualizován aktivací funkce Odhad doby odpisování v menu Volby. Na této záložce je možné definovat, že daný artikl je součástí společně odpisovaného souboru.

Podle par. 30a Zákona o dani z příjmu ve znění platném od 20.7.2009 lze záložku individuální odpis použít pro výpočet mimořádného odpisu.

Na další záložce lze definovat cizojazyčné názvy artiklu.

Mezi funkce dostupné v menu Volby v činnosti prezentující seznam artiklů patří funkce prezentace artiklu (dle artiklu v IC) a již uvedená funkce pro výpočet odhadu počtu odpisů. Na labelu Artikl jsou k dispozici relevantní údaje.

Odpisovaný majetek má dlouhodobou povahu - ve firmě má být používán déle než 1 rok. Jeho hodnota se tedy přenáší na nové výrobky postupně. Při používání se dlouhodobý majetek opotřebovává:

¨ morálně (dlouhodobý majetek zastarává, na trhu jsou modernější, výkonnější stroje, software, apod.),

¨ fyzicky (opotřebení součástek, koroze, poškození používáním apod.).

Odpisování je postupné přenášení vstupní ceny investičního majetku do nákladů firmy. Odpis je hodnota ročního opotřebení majetku. Odpisy mají pro firmu funkci:

¨ zdrojovou (odpisy jsou zdrojem pro budoucí nákup nového stroje za opotřebený),

¨ nákladovou (pouze prostřednictvím odpisů se hodnota majetku přenáší postupně do nákladů firmy. Firma nesmí dát do nákladů jednorázově vstupní cenu, tak jako to udělá u oběžného majetku).

Odpisy tedy rozlišujeme:

¨ daňové odpisy - upraveny zákonem o dani z příjmu,

¨ účetní odpisy - stanoví firma tak, aby objektivně vystihla míru opotřebení DM. Firma je může ztotožnit s odpisy daňovými.

Daňové odpisy lze počítat dvěma metodami:

¨ rovnoměrné odepisování,

¨ zrychlené odepisování.

Jednu z uvedených metod si firma u každého investičního majetku zvolí, ale pak ji musí dodržet po celou dobu odepisování.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 03.02.2010


Pojem - Odpisové skupiny

Nedílnou součástí zákona o daních z příjmů je příloha č. 1, kterou se hmotný majetek zatřiďuje do odpisových skupin 1 až 6. Odpisová skupina 6 byla zavedena poprvé pro období započaté v roce 2004. V letech 1993 až 2003 existovaly pouze odpisové skupiny 1 až 5. Každé odpisové skupině odpovídá doba odpisování. Zatřídění do příslušné odpisové skupiny se řídí kódem Standardní klasifikace produkce (SKP) nebo kódem Klasifikace stavebních děl CZ-CC.

Následující odpisové skupiny upravuje zákon o dani z příjmu a slouží pro výpočet daňových odpisů.

Odpis. skupina Doba odepisování Příklady

Odpis. skupina 1 3 roky -hovězí dobytek plemenný, kancelářské a školní potřeby plastové, kancelářské stroje, ruční mechanizované nářadí a nástroje

Odpis. skupina 2 5 let -koně, koberce, cisterny, čerpadla, transportní zařízení, prodejní automaty, traktory, stroje, letadla a kosmické lodě, kolotoče a pouťové atrakce, lešení, trolejbusy, nákladní auta apod.

Odpis. skupina 3 10 let -prefabrikované prostorové buňky z betonu, trezory, dekorativní sochy kovové, turbíny, výtahy, lodě, železniční lokomotivy, tramvaje, vozy metra, skleníky apod.

Odpis. skupina 4 20 let -domy a budovy ze dřeva a plastů, tribuny stadiónů ze dřeva a plastů, bazény ze dřeva a plastů, průmyslové komíny, vodovody a kanalizace apod.

Odpis. skupina 5 30 let -mosty, tunely, budovy, stavby, dráhy letišť, studny, dálnice, ulice, silnice, tribuny stadiónů kromě dřevěných a plastových atd.

Odpis. skupina 6 50 let -budovy hotelů, obchodních domů, muzea, školy atd.

 | Rovnoměrné | odepisování | Zrychlené | odepisování
Odpisová skupina | 1. rok | Další roky | 1. rok | Další roky
1 | 20% | 40% | 3 | 4
2 | 11% | 22,25% | 5 | 6
3 | 5,5% | 10,5% | 10 | 11
4 | 2,15% | 5,15% | 20 | 21
5 | 1,4% | 3,4% | 30 | 31
6 | 1,02% | 2,02% | 50 | 51

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 12.01.2009


Pojem - Odpisy

Odpisy jsou peněžním vyjádřením odpisů dlouhodobého majetku. Dlouhodobý majetek, tedy takové položky, jejichž vstupní (pořizovací) cena přesáhne stanovenou hranici (v roce 2008 Kč 40.000,00 pro dlouhodobý hmotný majetek a Kč 60.000,00 pro dlouhodobý nehmotný majetek – podnik však může rozhodnout o snížení této hranice), nelze uplatnit v nákladech v plné výši již v tom roce, v němž byly pořízeny. Odpis má právě vyjadřovat postupné opotřebovávání takového majetku v důsledku používání (fyzické opotřebení) či naopak v důsledku nepoužívání (morální opotřebení).

Rozlišujeme tzv. účetní odpisy a daňové odpisy. Účetní odpisy si stanovuje sama účetní jednotka (podnik) tak, aby co nejvíce vyjadřovaly skutečné opotřebení dlouhodobého majetku. Daňové odpisy stanovuje Zákon o daních z příjmů (586/1992 Sb. v platném znění) jako maximální možné částky, které lze uznat jako náklad (výdaj) na dosažení, zajištění a udržení příjmů („daňově uznatelný náklad“). Postup výpočtu daňových odpisů je v Zákoně o daních z příjmů přesně stanoven a prakticky neumožňuje žádné odchýlení od výpočtu.

Podle par. 30a Zákona o dani z příjmu ve znění platném od 20.7.2009 lze záložku individuální odpis použít pro výpočet mimořádného odpisu.

Správně by podnik měl účtovat o účetních odpisech a pro účely výpočtu daně z příjmů používat daňové odpisy. Jejich hodnoty se totiž mohou měnit. V praxi je však obvyklá situace (zvlášť u menších firem), že se používají jen daňové odpisy pro svou relativní jednoduchost (postup výpočtu – vzorec je dán Zákonem o daních z příjmů). Tento postup by však neměly používat auditované účetní jednotky. U účetních jednotek, které auditu nepodléhají, je možné vyšší přiblížení účetních a daňových odpisů.

Podnikatelé – fyzické osoby, kteří vedou daňovou evidenci (tj. dříve tzv. jednoduché účetnictví), mají povinnost používat pouze daňových odpisů.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 03.02.2010


Pojem - Odpisy a opravné položky pohledávek

Oblast pohledávek patří k jedné z nejdůležitějších při přípravě účetní závěrky. Struktura pohledávek je zpravidla velmi různorodá a je třeba zajistit jejich správné vykázání v účetní závěrce. Jako dlouhodobé se vykazují pouze takové pohledávky, jejichž lhůta splatnosti přesáhne období jednoho roku od data účetní závěrky. Ostatní pohledávky splatné do jednoho roku se vykazují jako krátkodobé i v případě, že nebyly uhrazeny ve lhůtě splatnosti (o těchto pohledávkám je nutné uvést informaci v příloze k účetní závěrce). Dále je nutné zajistit, aby se pohledávky, které nebyly uhrazeny ve lhůtě, nepromlčely, aby k nim bylo možné tvořit daňově účinné opravné položky. Z tohoto důvodu jsou důležité konfirmační dopisy, které zajistí odsouhlasení, a tedy uznání pohledávky (resp. závazku) protistranou.

Daňové účinný odpis pohledávek upravuje zákon o daních z příjmů. Pohledávky odepsané do nákladů na základě ustanovení tohoto zákona představují daňově uznatelný náklad. Jedná se jednak o jednorázový odpis, jednak o odpis postupný. Postupný odpis pohledávek byl umožněn účetním jednotkám již od roku 1995 u starých pohledávek vzniklých před rokem 1994 a dá se s jistotou předpokládat, že tyto pohledávky jsou dávno odepsané a v účetnictví se nevyskytují, takže o nich již neuvažujeme.

Daňově neúčinný odpis pohledávek provádí účetní jednotka na základě vlastního rozhodnutí u pohledávek, které zanikly nebo jsou promlčené, nesplňují podmínky pro daňový odpis, náklady na jejich vymáhání by přesáhly výtěžek, dlužník je např. dle sdělení příslušného orgánu (policie či soudu) neznámého pobytu, takže jejich úhrada je vysoce nepravděpodobná.

Korekce hodnoty pohledávek, u nichž je naděje na úhradu, případně které jsou soudně vymáhány, umožňují opravné položky. Tvorba opravných položek se účtuje na vrub nákladů a opravná položka se sníží, popřípadě zruší vyúčtováním ve prospěch nákladů, pokud inventarizace neprokáže opodstatněnost jejich výše (pohledávka je uhrazena, odepsána nebo vyřazena z účetnictví). Daňovou účinnost tvorby a zúčtování opravných položek upravuje zákon o rezervách v několika režimech. Pro rok 2006 přibyla nová možnost 100 % tvorby opravných položek u drobných pohledávek po lhůtě splatnosti více než 12 měsíců, jejichž hodnota za jedním dlužníkem nepřesahuje 30 000 Kč.

V případech, které nesplňují podmínky pro tvorbu daňově účinných opravných položek, avšak jedná se o pohledávky rizikové, by měla účetní jednotka tvořit účetní opravné položky. Ukládá jí to zákon o účetnictví, který uvádí, že při oceňování majetku a závazků v účetnictví se berou v úvahu rizika, ztráty a znehodnocení, které jsou známy ke dni sestavení účetní závěrky bez ohledu na to, zda je výsledkem hospodaření účetního období zisk nebo ztráta.

Je-li k pohledávce vytvořena 100 % opravná položka, je možné pohledávku vyřadit z účtu hlavní knihy a dále ji sledovat pouze na podrozvahových účtech. Pohledávky, které primárně zněly na cizí měnu, je nutné přepočítat kursem vyhlášeným Českou národní bankou k datu sestavení účetní závěrky. Kursový rozdíl se zaúčtuje podle povahy jako náklad (kursová ztráta) nebo výnos (kursový zisk). Jako dlouhodobé nebo krátkodobé pohledávky se vykazují v rozvaze i dohadné položky aktivní (pohledávky reálně existující, vztahující se ke sledovanému účetnímu období, avšak dokladem dosud nepotvrzené). Jejich kontrola je na samostatném kontrolním seznamu. Dlouhodobou pohledávkou je i odložená daňová pohledávka; oblast odložené daně je rovněž obsahem samostatného kontrolního seznamu.

Tato komponenta v IS BM je určena k evidenci neuhrazených pohledávek, na které je možné uplatnit odpis nebo opravné položky. Mezi nejvýznamnější atributy této komponenty patří kromě standardních odepsat procento z ceny pohledávky, finanční částka a výchozí cena a atribut, zda dochází ke změně stavu pohledávky. S komponentou Platby sdílí tato komponenta tabulku s vazbou karty odepisované pohledávky a události platby, na základě které byla založena.

Jako artikl je z hlediska odpisů a opravných položek pohledávek aplikována karta pohledávky, kterou lze založit pouze v činnosti s přehledem událostí PLA v menu Volby funkcí Karty pohledávek, přičemž její identifikace je předplněna dle druhu artiklu uvedeného v parametrech komponenty ODP a dle VS uvedeného v dané události pohledávky; současně je aktualizována vazební tabulka s událostí PLA.

Název artiklu je předplněn identifikací procesu události platby a datum aktuálním datem. Uživatelsky se definuje, zda se jedná o kartu s odpisem, pak se uvádí roční procento odpisu, či s opravnou položkou, pak se uvádí tabulka koeficientů, dle které bude relevantní šablona počítat výši opravné položky. Automaticky se doplní výše pohledávky dle atributu neuhrazeno v události PLA, která se následně aktualizuje (přepis) atributem výchozí cena z událostí ODP, které mají nastaven příznak Změna hodnoty pohledávky na Ano. Prezentované datum splatnosti je z relevantní události PLA.

Na první záložce Stav pohledávek se prezentují sumární údaje týkající se odpisů a opravných položek dané pohledávky, které se počítají z relevantních událostí ODP dle atributu finanční částka (procento a aktuální hodnota jsou dopočtené k počáteční hodnotě).

Na druhé záložce Změna pohledávky se prezentují události ODP týkající se dané karty pohledávky, jejichž operaci lze spustit z menu Volby; na šedém pozadí se prezentují ty, které mají nastaven atribut Změna hodnoty pohledávky na Ano.

Na třetí záložce Pohledávka se prezentují významné atributy z relevantní události PLA. Současně zde lze v menu Volby spustit operaci související s danou událostí PLA.

Mezi funkce dostupné v menu Volby v činnosti prezentující seznam artiklů (odepisovaných karet plateb) patří funkce prezentace artiklu (dle artiklu v IC) a funkce pro zrušení příznaku změna platby (tj. karta, na jejíž zdrojové události PLA došlo ke změně atributu dosud neuhrazeno, se bude po aplikaci této funkce chovat, jakoby ke změně atributu nedošlo). Na labelu Artikl jsou k dispozici relevantní údaje.

V případě, že se hodnota dosud neuhrazeno v události PLA nerovná hodnotě pohledávky na kartě, je zobrazována na šedém pozadí a je možné založit k dané události PLA novou kartu pohledávky. Shodně je tomu v případě nastavení atributu Změna hodnoty pohledávky na hodnotu Ano, pak se na šedém pozadí zobrazuje i tato událost.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.02.2008


Pojem - Odvozená menu

Odvozená menu jsou ta, kdy uživatel definici tohoto menu nevytvářel, ale odvodil z jiné vybrané definice menu a toto odvozené menu si pak pouze upravil podle svých vlastních požadavků. Po instalaci IS BM je k dispozici pouze základní definice menu, která je standardně dodávána se systémem. Z této definice by si uživatel měl odvodit své firemní menu (pak si může odvodit menu i pro jednotlivé uživatele), protože základní definice menu měnit nelze, tzn. že uživatel si ji nemůže přizpůsobit svým požadavkům (nelze změnit pořadí činností, kopírovat je apod.). Základní definice menu má příznak „systémová“ a slouží pouze k tomu účelu, aby na si na jejím základě mohl uživatel vytvořit své vlastní menu.

V případě vytváření nového menu uživatel postupuje následovně:

¨ v horní liště hlavního menu zvolí možnost Menu – Otevřít menu. Zobrazí se mu tabulka „deklarovaná menu“.

¨ uživatel umístí kurzor na to menu, z kterého si chce odvodit nové menu a stiskne pravé tlačítko myši a zvolí možnost „odvodit nové menu“. Odvozené menu dědí vlastnosti nadřízeného menu a uživatel má samozřejmě možnost si je podle svých potřeb upravit.

Po potvrzení této možnosti se mu zobrazí okno „vlastnosti definice menu“, kde určí právě vlastnosti tohoto nového odvozeného menu. Tyto vlastnosti definice menu nejsou spojené pouze s odvozenými menu, každé vytvořené menu má na okně „deklarovaná menu“ po stisku pravého tlačítka myši na názvu dostupné vlastnosti, které jsou shodné pro všechna menu.

Vytvořenou definici odvozeného menu může zrušit správce (nebo uživatel s právy správce) za předpokladu, že toto menu v daný okamžik nepoužívá žádný aktivní uživatel.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.02.2008


Pojem - Okno

V pojmech IS BM představuje okno pracovní plochu, která je pro všechny činnosti shodná. Činnosti se tedy uživateli prezentují svým oknem, které je možno nazývat formulář. Uživatel může mít v okně spuštěno jednu nebo více činností a podle potřeby si je může aktivovat. Každé okno v IS BM má společné tyto znaky:

¨ horní lištu okna

¨ základní panel nástrojů

¨ případné spuštěné tooly

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Okno úloh

Okno úloh představuje pro uživatele nástroj k usnadnění ovládání programu IS BM. K dispozici je v horní liště pod menu Obecné – Nabídky. Při aktivaci je okno úloh umístěné libovolně kdekoliv na obrazovce, uživatel si ho však může umístnit na vybraném místě a systém si při další aktivaci okna úloh již toto umístění pamatuje (platí pro verze Visual Foxpro 9.0). Na základě nastavení okna úloh se může při každém spuštění IS BM uživateli toto okno automaticky aktivovat samo a nebo je možno si ho ručně vyvolat.

Po stisku pravého tlačítka myši na horní liště činnosti „okno úloh“ má uživatel k dispozici menu s dvěmi atributy - „ukotvit“ a „skrýt“ (standardní tlačítko z ovládání Foxpro – ve verzi IS BM momentálně nefunkční).

Atribut „ukotvit“ je implicitně nastaven jako zatržený. Jeho význam spočívá v tom, že ať si uživatel okno úloh umístí kamkoliv na obrazovce (pravá strana, nad dolní lištu apod.), zůstává při aktivaci dalších činností a formulářů vždy na stejném místě (tzv. ukotveno) a aktivované činnosti nebo formuláře toto okno obtékají. V podstatě lze tuto vlastnost popsat i tak, že atribut „ukotvit“ způsobí, že okno úloh si pro sebe „přivlastní“ uživatelem vybrané místo na obrazovce a nemůže nastat problém, že by další spuštěná činnost nebo formulář toto okno překryly, tzn. vždy se pohodlně zobrazí vedle a uživatel tak má k dispozici všechny potřebné informace. Jinými slovy řečeno, atribut „ukotvit“ neznamená, že po jeho zatržení je okno úloh ukotveno, ale že okno úloh je ukotvitelné.

Okno úloh (musí být zatržen atribut „ukotvit“) lze pohodlně umístnit na obrazovce tzv. metodou „táhni a drž“. Uživatel stiskne levé tlačítko myši na horní modrém liště okna úloh a přetáhne si okno úloh na vybrané místo na obrazovce. V tomto okamžiku může někdy nastat mírný „technický problém“. V případě, že chce uživatel umístit a ukotvit (tzn. aby další formuláře a činnosti okno úloh obtékaly, nikoliv ho překrývaly) okno úloh např. v pravé části obrazovky jako samostatný sloupec, je vhodné postupovat takto: uchopit okno úloh (levá myš na horní liště) a lehkým plynulým švihem (mírně doprava nahoru, v podstatě takovým obloučkem) ho pustit na okraji pravé části obrazovky. V případě, že tento pohyb byl proveden správně, okno se samo automaticky usadí do pravé části obrazovky, tzn. vytvoří se sloupec okna úloh v pravé části obrazovky a horní lišta okna úloh bude těsně přiléhat k panelu nástrojů (tj. horní lišta) IS BM.

Technická poznámka:

V případě, že se takové umístění nezdaří na první pokus, nepropadejte panice a zkoušejte to znovu!:) Nesmíte se snažit okno úloh umístnit detailně do vybraného místo (tzn. dojet myší až na zvolené místo a tam ho pomalu pustit, musí to být opravdu vedený lehký švih:). Stejný postup platí pro umístění okna kdekoliv jinde na obrazovce. Uchopit horní lištu a mírným posunutím ho pustit na kraji zvolené části obrazovky.

Pro uživatele, kterým se nebude technicky dařit umístit okno úloh na zvolené místo na obrazovce je k dispozici činnost „přichycení okna úloh“. Tuto činnost mají k dispozici po stisku pravého tlačítka myši na položce stromů „Okna“ a „Menu BM“ (vlastní popis této činnosti je uveden dále v textu).

V okně úloh jsou zobrazena ovládací tlačítka, kterými se mění jeho obsah. Kromě základních tlačítek a s nimi spojenými zobrazovanými obsahy je možno definovat vlastní tlačítka pro zobrazení stránek informačních panelů. Uživatel si pro zobrazení stránek informačních panelů může definovat vlastní tlačítka. V nastavení programu BM lze v parametru OKNOULOH -> VLOZENEINFPANELY zadat seznam identifikací stránek informačních panelů oddělených čárkou. Popis a ikona takto definovaných tlačítek okna úloh přitom odpovídá názvům a ikonám uvedeným v popisu stránky informačního panelu. Jednotlivým uživatelům jsou zobrazovány tyto definovaná tlačítka pouze v případě, že k odpovídající stránce informačního panelu mají přístupové právo alespoň „Čtení“. Pravý klik myši na tlačítku pro zobrazení stránky informačního panelu způsobí znovunačtení stránky. Jednotlivé dostupné informační panely se uživateli pak zobrazují jako samostatné záložky okna úloh.

Zobrazení jednotlivých záložek (druh a velikost písma) a způsob ovládání těchto činností je volitelný vždy po stisku pravého tlačítka myši na názvu činnosti, např. na záložce „Menu BM“ po stisku pravého tlačítka myši na názvu jakékoliv komponenty má možnost změnit vzhled celého menu. Všechny tyto vlastnosti se nastavují v činnosti „Nastavení stromu“ (neplatí jen pro Okno úloh, pomocí tohoto nastavení je možno měnit i vzhled dalších stromů, např. hlavní menu, strom hlavního procesu, strom pracovníka, obecné stromy). Po stisku pravého tlačítka myši na názvu jakékoliv činnosti pod tlačítkem „Menu BM“ má uživatel k dispozici následující:

¨ otevřít menu (aktivace dané činnosti)

¨ zobrazovat skryté činnosti (uživateli se v menu zobrazí i činnosti, které mají ve vlastnostech uveden příznak „skryté“)

¨ nastavení stromu

¨ přichycení okna úloh – lze si vybrat možnost pro přichycení okna úloh v hlavním okně BM – možnosti jsou: vlevo, vpravo, nahoře, dole, nepřichyceno

Nastavení stromu a přichycení okna úloh má uživatel k dispozici i po stisku pravého tlačítka myši na jakékoliv činnosti pod tlačítkem „Okna“.

K dispozici jsou následující dvojice základních tlačítek (Okna – Menu BM, Dokumenty – Historie, Strom – Průběh). Jedná se o tlačítka, která spolu věcně souvisí, např. když uživatel bude přes tlačítko Menu BM aktivovat vybranou činnost, tak ta se zároveň ukáže jako aktivní po stisku tlačítka Okna. Stisk pravého tlačítka myši na každém z těchto tlačítek aktivuje možnost "obnovit", která způsobuje tzv. „znovunačtení“ činnosti. Jedná se o tyto tlačítka (tj. záložky):

¨ Okna – zobrazí se seznam názvu aktivních oken BM (tj. aktivně spuštěných činností). Uživatel se může mezi jednotlivými okny přepínat, tzn. klikem na název okna se mu na základní obrazovce zobrazí daná činnost. Zobrazuje se zde většina oken programu BM, např. i okna informačních panelů, digramů procesů, okno s předlohami výstupu atd.

¨ Menu BM – zobrazí se hlavní menu programu, ze kterého je možné aktivovat jednotlivé činnosti BM (aktivované činnosti se následně zobrazí pod záložkou Okna).

¨ Dokumenty – zobrazují se dokumenty, které se vztahují k aktivně spuštěné činnosti na základní obrazovce, tzn. má-li uživatel aktivovanou např. činnost adresář, tak po kliknutí na záložku Dokumenty se mu zobrazí dokumenty aktivního adresáta. Při přechodu na dalšího adresáta se obsah záložky Dokumenty nemění, teprve po dalším kliknutí přímo na tlačítko „Dokumenty“ je obsah záložky Dokumenty znovu načten.

¨ Historie - zobrazí se seznam dokumentů z posledních 7 týdnů, které uživatel naposledy otevřel v programu BM, seřazený podle data a času sestupně. Klik myši na názvu dokumentu způsobí jeho otevření. Opakovaný klik na tlačítko „Historie“ způsobí aktualizaci seznamu dokumentů (chování obdobné jako činnost „znovu načíst“).

¨ Strom – zobrazuje se strom hlavního procesu, který se vztahuje k aktivně spuštěné činnosti na základní obrazovce, tzn. má-li uživatel aktivovanou činnost např. události obchodu, tak po kliknutí na záložku Strom se zobrazí strom hlavního procesu vztahující se k právě aktivní události obchodu. Při přechodu na další událost se obsah záložky Strom nemění, teprve po dalším kliknutí přímo na tlačítko „Strom“ je obsah záložky Strom znovu načten.

¨ Průběh – uživateli se zobrazuje přehled dosud spuštěných procesů. Po rozbalení jejich názvu jsou k dispozici i jednotlivé operace procesu zobrazené ve stromové struktuře (jako strom hlavního procesu). Při zatržení příznaku „průběh procesů automaticky rozbalovat“ v Nastavení okna úloh se zobrazí seznam procesů, který už je automaticky rozbalen.

Následující záložky jsou zobrazeny jako tlačítka v řadě vedle sebe, jsou označena prvními písmeny z názvu:

¨ F - formulář – uživatelský popis – ve sloupcích pod sebou se zobrazí dvě vstupní textová pole, ve kterých uživatel vytváří vlastní uživatelský popis aktuálně zobrazeného formuláře. První textové pole „sdílený popis“ je dostupné všem uživatelům systému a údaje, které tam daný uživatel zapíše jsou dostupné všem uživatelům systému. Druhé textové pole „soukromý popis“ je dostupné pouze aktuálnímu uživateli systému. Vstupované popisy jsou ukládány na vývěsku s tématem, které je v činnosti „nastavení programu BM“ dáno parametrem OKNOULOH -> TEMAUZIVPOPISU (v případě, že tento parametr není nastaven nebo uvedené téma neexistuje, není možné zadávat uživatelské popisy). Uživatelé, kteří k tématu vývěsky uvedenému v parametru nemají právo přístupu „Zápis“, mohou obsah textového pole „sdílený zápis“ pouze číst. Obsah okna se mění při přepínání mezi formuláři a zároveň při této změně dochází k automatickému zápisu uživatelem zadaného popisu. Zápis změněného popisu je rovněž možno vyvolat opakovaným stiskem daného tlačítka („formulář – uživatelský popis“).

¨ O - operace – uživatelský popis – ve sloupcích pod sebou se zobrazí dvě vstupní textová pole, ve kterých uživatel vytváří vlastní uživatelský popis aktuálně zobrazeného formuláře. Pokud aktivní formulář na hlavní obrazovce není formulářem spuštěné operace, je tlačítko zobrazené jako nepovolené (tzn. šedivé a nedostupné).

První textové pole „sdílený popis“ je dostupné všem uživatelům systému a údaje, které tam daný uživatel zapíše jsou dostupné všem uživatelům systému. Druhé textové pole „soukromý popis“ je dostupné pouze aktuálnímu uživateli systému. Vstupované popisy jsou ukládány na vývěsku s tématem, které je v činnosti „nastavení programu BM“ dáno parametrem OKNOULOH -> TEMAUZIVPOPISU (v případě, že tento parametr není nastaven nebo uvedené téma neexistuje, není možné zadávat uživatelské popisy). Uživatelé, kteří k tématu vývěsky uvedenému v parametru nemají právo přístupu „Zápis“, mohou obsah textového pole „sdílený zápis“ pouze číst. Obsah okna se mění při přepínání mezi formuláři a zároveň při této změně dochází k automatickému zápisu uživatelem zadaného popisu. Zápis změněného popisu je rovněž možno vyvolat opakovaným stiskem daného tlačítka („operace – uživatelský popis“).

¨ OP - operace v procesu – uživatelský popis – ve sloupcích pod sebou se zobrazí dvě vstupní textová pole, ve kterých uživatel vytváří vlastní uživatelský popis aktuálně zobrazeného formuláře. Pokud aktivní formulář na hlavní obrazovce není formulářem spuštěné operace, je tlačítko zobrazené jako nepovolené (tzn. šedivé a nedostupné).

První textové pole „sdílený popis“ je dostupné všem uživatelům systému a údaje, které tam daný uživatel zapíše jsou dostupné všem uživatelům systému. Druhé textové pole „soukromý popis“ je dostupné pouze aktuálnímu uživateli systému. Vstupované popisy jsou ukládány na vývěsku s tématem, které je v činnosti „nastavení programu BM“ dáno parametrem OKNOULOH -> TEMAUZIVPOPISU (v případě, že tento parametr není nastaven nebo uvedené téma neexistuje, není možné zadávat uživatelské popisy). Uživatelé, kteří k tématu vývěsky uvedenému v parametru nemají právo přístupu „Zápis“, mohou obsah textového pole „sdílený zápis“ pouze číst. Obsah okna se mění při přepínání mezi formuláři a zároveň při této změně dochází k automatickému zápisu uživatelem zadaného popisu. Zápis změněného popisu je rovněž možno vyvolat opakovaným stiskem daného tlačítka („operace v procesu – uživatelský popis“).

¨ P - proces – uživatelský popis – ve sloupcích pod sebou se zobrazí dvě vstupní textová pole, ve kterých uživatel vytváří vlastní uživatelský popis aktuálně zobrazeného formuláře. Pokud aktivní formulář na hlavní obrazovce není formulářem spuštěné operace, je tlačítko zobrazené jako nepovolené (tzn. šedivé a nedostupné).

První textové pole „sdílený popis“ je dostupné všem uživatelům systému a údaje, které tam daný uživatel zapíše jsou dostupné všem uživatelům systému. Druhé textové pole „soukromý popis“ je dostupné pouze aktuálnímu uživateli systému. Vstupované popisy jsou ukládány na vývěsku s tématem, které je v činnosti „nastavení programu BM“ dáno parametrem OKNOULOH -> TEMAUZIVPOPISU (v případě, že tento parametr není nastaven nebo uvedené téma neexistuje, není možné zadávat uživatelské popisy). Uživatelé, kteří k tématu vývěsky uvedenému v parametru nemají právo přístupu „Zápis“, mohou obsah textového pole „sdílený zápis“ pouze číst. Obsah okna se mění při přepínání mezi formuláři a zároveň při této změně dochází k automatickému zápisu uživatelem zadaného popisu. Zápis změněného popisu je rovněž možno vyvolat opakovaným stiskem daného tlačítka („proces – uživatelský popis“).

¨ N - nápověda – zobrazí nápovědu BM k formuláři (činnosti), který je právě aktivní na hlavní obrazovce. Obsah okna se při přepínání mezi formuláři automaticky mění.

V tomto místě činnosti „okno úloh“ se mohou zobrazovat tlačítka s názvy informačních panelů, pokud je má uživatel správně nadefinovány. Poslední tlačítko, důležité pro chování činnosti „okno úloh“ je:

¨ Nastavení okna úloh – zde se definují parametry, které ovlivňují chování okna úloh. Tato nastavení jsou specifická pro každého uživatele.

Ve stromech zobrazovaných ve formulářích spojené dokumenty, strom hlavního procesu a obdobných stromech formuláře okno úloh je možno implementačně doplnit definovatelné funkce pro menu, která jsou vyvolávána po stisku pravého tlačítka myši na uzlu představujícím objekt BM. Toto implementační doplnění je možno nadefinovat v činnosti „doplňující položky menu objektů“.

Poznámka:

Vlastnost FoxPro v některých případech neumožňuje běžným kliknutím aktivovat minimalizovaná okna (v praxi to znamená, že uživatel fakticky musí z okna úloh „něco“ spustit a pak je možno se přepnout na minimalizované okno).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 29.02.2012


Pojem - Opakovat vstup

Jedná se o „zaškrtávací“ atribut, který má uživatel možnost využít jako usnadnění při vytváření procesů. Pokud uživatel zahajuje proces přímo z menu Nový proces a dopředu ví, že po ukončení daného procesu bude zahajovat další proces daného druhu (tzn. že bude například vytvářet jeden výdajový pokladní doklad za druhým), zaškrtne v okně ukončení první operace daného procesu tento atribut a po ukončení vstupu dat do daného procesu se automaticky spustí první operace dalšího procesu daného druhu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.01.2008


Pojem - Operace (druh operace)

Operace je základním stavebním kamenem v modelování procesu jako posloupnosti operací (činností, funkcí, business activity - viz BPM). Obsahuje události, které jsou si obvykle věcně i časově blízké.

Operace (druh operace) je jedním z možných uzlů v definici diagramu (druhu) procesu.

K druhu operace lze definovat přístupová práva. Informace o každé fyzicky provedené operaci je možno tisknout. Tisk lze nastavit tak, že probíhá automaticky po ukončení operace [1] a to v případě potřeby i bez zásahu uživatele (viz. předlohy výstupu). Každou fyzicky vytvořenou operaci i ostatní uzly má uživatel k dispozici v činnosti Procesy a operace – Operace.

Např. druh operace „SKLP – příjem na sklad“ je součástí definice několika druhů procesů. Takže pak existuje jeden druh operace „příjem na sklad“, ale fyzické operace jsou závislé na tom, v jakém procesu byl tento druh operace použit (např. nákup bez objednávky, PH-příjem, převod na sklad), a dále obsahují informaci co, kdy, kým a v jakém množství a ceně bylo na sklad přijato.

[1] Na vlastnostech operace v diagramu procesu se zvolí po ukončení tisk operace a zároveň se zvolí příslušná metapředloha.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 19.12.2007


Pojem - Oprava dat

Mezi nástroje opravy dat patří:

¨ storna

¨ zrušit stav ukončena

¨ přepsání existujících údajů, pokud to IS v dané situaci dovoluje (tzn. atribut je bílý a tudíž přístupný pro přepsání). K tomuto účelů může sloužit i vstup šablonou, která má povolenu hromadnou opravu

¨ uživatelské triggery

V IS BM je možno monitorovat provedené změny v tabulkách. Přehled provedených změn (i za jednotlivé uživatele) má uživatel k dispozici v činnosti Přehled změn záznamů tabulek (menu Systém). Před vlastním prohlížením je nutno nadefinovat nastavení sledování těchto změn (tzn. jaké změny, v kterých činnostech apod.).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 06.03.2009


Pojem - Opravné daňové přiznání

Daňové přiznání, které může daňový subjekt podat po odevzdání řádného daňového přiznání před uplynutím lhůty pro podání řádného daňového přiznání. Pro vyměřovací řízení se pak použije tohoto opravného přiznání a k přiznání předchozímu se nepřihlíží. Opravným daňovým přiznáním může daňový subjekt před uplynutím řádné lhůty nahradit předchozí chybné daňové přiznání, které finanční úřad "zahodí". Po zmeškání lhůty pro podání daňového přiznání je nutno chyby opravit dodatečným daňovým přiznáním.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Opravné položky

Opravnými položkami se vyjadřuje přechodné snížení hodnoty majetku za podmínek uvedených v následujícím § 55 vyhlášky:

§ 55 Postup tvorby a použití opravných položek:
- Opravné položky se vytvářejí pouze k účtům majetku v případech snížení ocenění majetku v účetnictví prokázaném na základě inventarizace majetku. Tyto opravné položky se vytvářejí jen v případech, kdy snížení ocenění majetku v účetnictví není trvalého charakteru nebo není snížení ocenění vyjádřeno jiným způsobem, například reálnou hodnotou. Při inventarizaci se posuzuje výše a odůvodněnost vytvořených opravných položek.
- Opravné položky lze vytvářet i v případech, kdy tak stanoví zákon č. 593/1992 Sb., o rezervách pro zjištění základu daně z příjmů, ve znění pozdějších předpisů.
- Tvorba opravných položek se účtuje na vrub nákladů a opravná položka se sníží, popřípadě zruší vyúčtováním ve prospěch nákladů, pokud inventarizace neprokáže opodstatněnost její výše.
- Opravné položky nesmí mít aktivní zůstatek a nelze je tvořit na zvýšení hodnoty majetku.

Opravné položky k pohledávkám se vytvářejí k pohledávkám za dlužníky v konkursním a vyrovnacím řízení a k nepromlčeným pohledávkám, které jsou zaúčtovány v účetnictví a jsou splatné po 31. 12.1994, a to ve výši stanovené zvláštním právním předpisem a popřípadě i ve výši přesahující zvláštním právním předpisem stanovenou tvorbu. Výše opravné položky, vytvářené podle zvláštního právního předpisu nebo nad jeho rámec, nesmí přesáhnout účetní hodnotu pohledávky na rozvahovém účtu, k níž je opravná položka tvořena. V případech, ve kterých bude opravná položka vytvořena ve výši 100 % hodnoty nepromlčené pohledávky, může být tato pohledávka odepsána a opravná položka k ní zrušena s výjimkou pohledávek za dlužníky v konkursním a vyrovnacím řízení. Takto odepsaná pohledávka se dále sleduje na podrozvahových účtech s výjimkou těch pohledávek, u kterých došlo k jejich zániku. Přijatá úhrada odepsané pohledávky se vyúčtuje jako výnos na příslušném účtu účtové skupiny 64 - Jiné provozní výnosy a zachytí se na podrozvahových účtech. Postup účtování opravných položek na vrub či ve prospěch příslušných účtů nákladů je uveden v Českém účetním standardu pro podnikatele č. 019 Náklady a výnosy. Při prodeji majetku se opravné položky, které se k němu váží, zruší vyúčtováním ve prospěch příslušného nákladového účtu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 20.03.2008


Pojem - Oprávnění k činnostem

Tato činnost slouží k přidělování oprávnění k provádění činností vybraným skupinám uživatelů nebo přímo jednotlivým uživatelům.

Přidělování práv k provádění jednotlivých činností se provádí následujícím způsobem. Uživateli se v levé části formuláře zobrazuje seznam funkčních činností a v pravé části je přehled nadefinovaných skupin uživatelů a jednotlivých uživatelů. U jednotlivých funkčních činností je navíc třeba rozlišovat, zda mají před názvem přítomnou "tečku" či nikoliv. Pokud je tam tečka, znamená to, že činnost se může dvojklikem ještě dále rozbalit. Uživatel si potom prochází jednotlivé činnosti a zatržením příznaku může přiřadit právo k provádění dané činnosti vybrané skupině nebo konkrétnímu uživateli. V případě, že není zatržena žádná skupina, mají oprávnění k dané funkční činnosti všichni uživatelé. Mezi jednotlivými funkčními činnostmi se uživatel pohybuje pomocí dvojitého stlačení levého tlačítka myši. Po dvojkliku se zobrazí všechny činnosti, které jsou navázány na danou činnost (stiskem ESC nebo ikony "zpět" se uživatel vrátí zpět do původní nabídky). Pokud je přehled skupin uživatelů zobrazen modrou barvou, znamená to, že k dané činnosti mají přístup všichni uživatelé. Pokud má přístup k činnosti zatržena pouze některá skupina, je naopak tato skupina zobrazena modře a ostatní skupiny bez přístupu jsou vysvíceny černě.

U jednotlivých činností, např. adresář, je možno přiřazovat oprávnění až na úroveň editačních činností, tzn. že uživatel pak např. nemá právo nového adresáta zařadit, nicméně číst v adresáři již vytvořené záznamy právo má. U které činnosti se rozsvítí záložka "editační činnosti", té je možno takto podrobně přiřazovat oprávnění (tzn. na úroveň čtení, zápisu, oprav apod.). Pomocí klávesy "návrat zpět" se uživatel vrací k činnosti vždy o úroveň výš.

Oprávnění k činnostem má právo definovat uživatel s „právy správce“. K dispozici má tyto možnosti:

¨ menu Systém – činnost Oprávnění k činnostem

¨ hlavní menu – pravý klik na názvu činnosti – volba Oprávnění k činnostem

¨ menu Obecné v horní liště libovolného formuláře – volba Oprávnění k činnostem

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.01.2008


Pojem - Optimalizovaný výpočet mezd

Pomocí činnosti „optimalizovaný výpočet mezd“ (menu Mzdy – Mzdy) se provádí výpočet výplatních lístků. Uživatel pak může zvolit konkrétní číslo pracovníka (napíše přímo jeho osobní číslo), skupinu pracovníků (napíše např. číslo jedna a systém pak vybere skupinu pracovníků, jejichž osobní číslo začíná na číslo 1) nebo všechny pracovníky (ponechá znak %).

Důležité momenty pro správné zpracování:

¨ nastavení parametrů

¨ definice mzdových položek

¨ zadání nepřítomností pro nemoc

¨ vytvořený kalendář pracovních dob

¨ správně zadané údaje na kartě pracovníka (tzn. nastavení zaškrtávátek a definičně přesné nastavení pravidelných příjmů)

Výpočet výplatních lístků jednotlivých pracovníků je možné provést ve zpracovávaném měsíci opakovaně. Výpočet provádí též řadu kontrol, jejichž výsledky jsou generovány do Protokolu. Záznamy vzniklé výpočtem výplatních lístků jsou podkladem pro komponentu MZD.

Pokud má pracovník v organizaci současně několik pracovních poměrů, systém mu připraví za každý pracovní poměr výplatní lístek s položkami příjmů, sociálního a zdravotního pojištění, základu daně a nemocenských dávek.

Na výplatním lístku z pracovního poměru označeného jako „určující“ systém navíc uplatní nezdanitelné položky, vypočítá daň za všechny příjmy, vypočítá čistý příjem, srážky a částku k výplatě.

Pokud má pracovník víc výplatních lístků a nemá ani jeden pracovní poměr s příznakem „určující“ nebo jich má víc, pak systém vybere za hlavní výplatní lístek kterýkoliv z vypočítaných a do „protokolu“ zapíše hlášku „pracovník nemá žádný pracovní poměr označen jako určující. Bude vybrán pracovní poměr, který je první v pořadí“.

Činnost pro každého pracovníka a jeho pracovní poměr postupně provede :

¨ přenos pravidelných příjmů z karty pracovníka

¨ kontrolu evidované doby

¨ výpočet hrubých příjmů

¨ výpočet sociálního pojištění hrazeného zaměstnancem

Je-li v parametrech mezd nastaven způsob výpočtu sociálního pojištění za organizaci „jednotlivě“, provede se výpočet sociálního pojištění hrazeného organizací (za jednoho zaměstnance):

¨ výpočet zdravotního pojištění hrazeného zaměstnancem a hrazeného organizací

¨ přenos nemocenských dávek z nepřítomnosti pro nemoc

Dále pro každého pracovníka a jeho pracovní poměr s příznakem určující = Ano systém provede :

¨ výpočet měsíční daně ze všech pracovních poměrů pracovníka

¨ výpočet čistého příjmu ze všech pracovních poměrů pracovníka

¨ výpočet srážek

¨ výpočet půjček

¨ výpočet k výplatě

Je-li v parametrech mezd nastaven způsob výpočtu sociálního pojištění za organizaci „souhrnně“, pak se po výpočtu příjmů posledního pracovníka provede výpočet základu a odvodu sociálního pojištění organizace v celkové částce za všechny pracovníky.

Při optimalizovaném výpočtu všech mezd se vypočtou mzdy všech pracovníků a všechny odvody za organizaci. Poté může nastat situace, kdy se určité údaje u jednotlivých pracovníků změní, pak uživatel spustí optimalizovaný výpočet mezd pouze daného pracovníka. Odvody se ovšem v tento okamžik nepřepočítají, tzn. že před finalizací mezd je nutno znovu ještě jednou spustit optimalizovaný výpočet všech, aby se znovu správně přepočítaly odvody za organizaci.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.01.2008


Pojem - Optimalizovaný výpočet mezd jednoho pracovníka

Pod menu Volby v činnosti Výplatní lístky je k dispozici činnost "Pomocný optimalizovaný výpočet JEDNOHO pracovníka". Tato činnost je výhodná zejména pro společnosti s vysokým počtem zaměstnanců, protože klasický Optimalizovaný výpočet bývá v některých případech příliš pomalý. Činnost je vhodná pro přepočet jednoho pracovníka, pokud je potřeba zjistit, jak bude vypadat jeho výplatní lístek a pokud si nejsme jisti, zda je u tohoto pracovníka vše zadáno správně.

Po kontrole pracovníka se MUSÍ spustit klasický Optimalizovaný výpočet pro všechny pracovníky nebo se ručně musí dorovnat zaokrouhlení odvodu sociálního pojištění.

POZOR - činnost "Pomocný optimalizovaný výpočet JEDNOHO pracovníka" neprovádí korekci zaokrouhlování na položce Odvod sociálního pojištění.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.07.2008


Pojem - Osobní skupina předlohy výstupu

Osobní skupina předlohy výstupu se nastavuje u každé jednotlivé předlohy výstupu po stisku pravého tlačítka myši na dané předloze. Pak má uživatel k dispozici podmenu „osobní skupina předlohy“ a zde zatrhne příslušnou skupinu. V případě, že by danou předlohu výstupu naopak chtěl vyřadit z podmenu „osobní skupina předlohy“, zatrhne volbu „žádná skupina“.

Aby se daná skupina nabízela jako volba v podmenu „osobní skupina předlohy“, je nutno mít tuto skupinu nadefinovanou v činnosti skupiny procesů a musí mít nastaveno hodnotu Ano v atributu „osobní skupina předlohy výstupu“.

Jednotlivé skupiny předloh či osobní skupiny předloh výstupu se zobrazují v okně výstupy (po aktivaci ikony „tiskárna“ nebo stisku Ctrl T) v případě, že je zvolené zobrazení ve formě stromu. Po stisku pravého tlačítka myši na názvu skupiny má uživatel k dispozici následující možnosti:

¨ metapředlohy – vyvolání formuláře pro definování metapředloh

¨ skupiny procesů/předloh výstupu – vyvolání formuláře pro definování skupin

¨ nastavení stromu – vyvolání formuláře pro definování vlastností zobrazení stromu

V případě, že uživatel ve vlastnostech předlohy přiřadil vybrané předloze výstupu skupinu a zároveň danou předlohu zařadil v podmenu volby osobní skupina předlohy do jiné skupiny, bude tato předloha zobrazena ve stromu dvakrát, tj. v obou skupinách.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 09.06.2009


Pojem - Osobní údaje

Jako první jsou na této záložce k dispozici atributy, které přímo souvisí s řízením běhu výpočtu mezd. Jedná se o:

¨ zdravotní pojištění – zvolená možnost z překryvného seznamu řídí způsob výpočtu zdravotního pojištění pracovníka

¨ podepsal prohlášení – tento atribut přímo řídí způsob výpočtu uplatnění zálohové daně

¨ lze srážet – tento atribut přímo řídí způsob výpočtu uplatnění srážkové daně

¨ provést roční zúčtování – pokud je zatrženo, provede se u tohoto pracovníka výpočet ročního zúčtování daně. Pokud zatrženo není, znamená to, že pracovník si přiznání daně provádí sám, mimo firmu.

Další údaje, které jsou zde k dispozici slouží částečně i jako podklad pro hlášení RELDP:

¨ rodné číslo

¨ číslo občanského průkazu

¨ rodné příjmení

¨ datum narození

¨ místo narození

¨ státní příslušnost

¨ stav – tzn. rodinný stav (možno vybrat z překryvného seznamu)

¨ počet dětí

¨ informace, zda se jedná či nejedná o pracovníka zdravotně postiženého

¨ muž/žena

¨ další příjmení – tzn. příjmení předcházející současnému příjmení

¨ v případě, že se jedná o pracujícího důchodce, tak informace o typu důchodu, od kdy ho pracovník pobírá a kolik Kč

Tyto vyplněné údaje mohou mít vliv na uživatelem nadefinované sestavy, které si vytvořil pro své interní účely, některé informace se uvádějí i na mzdovém listu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.06.2009


Pojem - Ošetřovné

Ošetřovné je peněžitou dávkou nemocenského pojištění, která náleží při splnění zákonem stanovených podmínek zaměstnanci (muži nebo ženě) účastnému nemocenského pojištění, který musel zůstat doma pro osobní překážku v práci spočívající v ošetřování jiného nemocného člena rodiny, jestliže zdravotní stav nemocného vyžaduje ošetřování jinou osobou. Ošetřovné náleží zaměstnanci, který nemůže pracovat, poněvadž musí:

¨ ošetřovat dítě mladší 10-ti let, které onemocnělo nebo se zranilo (v případě ošetřování dítěte mladšího 10-ti let se nevyžaduje, pokud takové dítě ošetřuje rodič, splnění podmínky společné domácnosti)

¨ pečovat o zdravé dítě mladší 10-ti let z toho důvodu, že:

- dětské výchovné zařízení, v jehož péči dítě jinak je, nebo škola, do které chodí, byly uzavřeny z nařízení příslušných orgánů,

- dítě nemůže být pro nařízenou karanténu v péči dětského výchovného zařízení nebo docházet do školy,

- osoba, která jinak o dítě pečuje, onemocněla, a proto nemůže o dítě pečovat.

Ani při péči o dítě mladší 10-ti let se nevyžaduje podmínka společné domácnosti, pečuje-li o dítě rodič. Pokud o dítě pečuje, či jej ošetřuje jiná osoba než rodič dítěte, pak se podmínka splnění podmínky společné domácnosti vyžaduje.

¨ ošetřovat jiného nemocného člena rodiny, jestliže jeho zdravotní stav vyžaduje nezbytně ošetřování jinou osobou (nezbytnost posuzuje lékař, který při vystavení tiskopisu žádosti přihlíží jak k závažnosti onemocnění, tak k věku nemocného).

¨ ošetřovat dítě, které je po rozvodu manželství svěřeno do střídané péče obou rodičů

Pro nárok na podporu při ošetřování člena rodiny ve věku do 10 let musí být splněna podmínka žití pojištěnce v domácnosti s ošetřovaným. Aby tato dávka byla poskytována osamělému pojištěnci po delší podpůrčí dobu (max. 16 kalendářních dnů), musí mít v trvalé péči alespoň jedno dítě ve věku do skončení povinné školní docházky. V případě, že zaměstnanec čerpá dovolenou na zotavenou a vzniknou důvody pro poskytování podpory při ošetřování člena rodiny, dovolená na zotavenou se mu z tohoto titulu přerušuje.

Doba poskytování podpory při ošetřování člena rodiny

Dle pracovněprávních předpisů jde o omluvenou nepřítomnost v práci. Četnost poskytování podpory při ošetřování člena rodiny není omezena. Při splnění stanovených podmínek, může být tato dávka poskytnuta i několikrát za měsíc. Podpora při ošetřování člena rodiny se poskytuje za kalendářní dny, nejvýše po dobu prvních devíti kalendářních dnů, pokud potřeba ošetřování v nich trvá. Tato doba se počítá vždy ode dne vzniku potřeby ošetřování.

Zaměstnanci, který má v trvalé péči alespoň jedno dítě ve věku do skončení povinné školní docházky a je jinak osamělý, se podpora při ošetřování člena rodiny poskytuje nejvýše po dobu prvních 16 kalendářních dnů, pokud potřeba ošetřování v nich trvá. Za osamělého zaměstnance se podle § 41 vyhlášky č. 143/1965 Sb., platném znění, pro tyto účely považuje zaměstnanec svobodný, ovdovělý, rozvedený nebo z jiných vážných důvodů osamělý (manžel vykonávající základní vojenskou službu, ve výkonu trestu odnětí svobody), který nežije s družkou (druhem). Oprávněné osoby se mohou během ošetřování jednou vystřídat. Změna druhu onemocnění (diagnózy) se nepovažuje za nový případ ošetřování. Jako nový případ potřeba ošetřování se posuzuje případ, kdy mezi dvěma onemocněními netrvá potřeba ošetřování alespoň jeden kalendářní den, nebo kdy jde o jiný důvod potřeby ošetřování, či péče. Jde-li o nový titul potřeby ošetřování, vzniká vždy nový nárok na dávku. O stejný případ ošetřování jde vždy, když potřeba ošetřování nepřetržitě trvá, a není rozhodné, zda v průběhu onemocnění došlo ke změně diagnózy. Obvykle jde o prodloužení stávající potřeby stanovené lékařem na kratší dobu, než po jakou onemocnění trvá. Ve stejném případě ošetřování (péče) náleží podpora jen jednou a jen jednomu oprávněnému.

Podpora při ošetřování člena rodiny nenáleží za dny ošetřování (péče), za něž náleží zaměstnanci započitatelný příjem s výjimkou příjmů, které mu náleží i za dobu ošetřování, aniž v této době vykonával zaměstnání. Podpora při ošetřování člena rodiny nenáleží zaměstnanci, který je sám současně uznán práce neschopným. Ošetřovné nenáleží, jestliže jiná fyzická osoba má z důvodu péče o toto dítě nárok na poskytování peněžité pomoci v mateřství nebo má nárok na rodičovský příspěvek; to neplatí, pokud tato jiná osoba onemocněla, utrpěla úraz, apod. Podpora při ošetřování člena rodiny nikdy nenáleží zaměstnancům, jestliže se jedná o:

¨ příslušníky

¨ zaměstnance vykonávající domácí práci,

¨ zaměstnance činné na základě dohody o pracovní činnosti,

¨ studenty a žáky,

¨ zaměstnance na nepravidelnou výpomoc,

¨ osoby samostatně výdělečně činné,

¨ dobrovolné pracovníky pečovatelské služby,

¨ odsouzení ve výkonu trestu odnětí svobody zařazení do práce a

¨ zahraniční zaměstnanci.

Výše podpory při ošetřování člena rodiny

Podpora při ošetřování člena rodiny se stanoví stejným způsobem jako nemocenské. Výše podpory za kalendářní den činí 69 % denního vyměřovacího základu od prvního dne podpory při ošetřování člena rodiny.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 07.03.2008


Pojem - Otevřená období komponent

S jednotlivými komponentami úzce souvisí i činnost otevřená období komponent (menu Informační centrum - Typy a řady), která umožňuje uživateli nastavit období pro validaci dat v událostech.

U každé komponenty lze zadat (po stisku F3) datum od - do. Toto datum systém potom hlídá při zápisu událostí komponenty a při provádění storna. Jak již vyplývá z názvu této činnosti, je nutno si uvědomit, že uživatel zadává datum, kdy je možno komponentu pro zápis událostí nebo storna považovat za otevřenou, tzn. mimo toto zadané období je vlastně komponenta pro zápis nebo storno uzavřená. Pokud není pro komponentu definováno otevřené období, potom není povolen vstup událostí s datem mimo interval 1.1.1980 až 1.1.2100. Pozn.: Důsledkem toho je, že pro komponenty, ve kterých se mohou vyskytnout události s menším datem (spravovaný majetek, odepisovaný majetek, ....) je NUTNÉ definovat otevřené období komponenty.

Další možnosti této činnosti jsou:

¨ kontrolovat při stornu – možnost Ano/Ne. V případě zadání Ano systém kontroluje ještě nastavení tohoto atributu u druhu operace (záložka Další). Pokud je u otevřeného období komponenty nastaveno Ano a u druhu operace rovněž Ano (nebo není vůbec vyplněna záložka Další), storno procesu se neprovede, pokud by stornem vznikla inverzní událost s datem mimo otevřené období komponenty nebo pokud by stornem byla zrušena událost s datem mimo otevřené období komponenty.

¨ kontrolovat při rušení stavu ukončena - možnost Ano/Ne. V případě zadání Ano systém kontroluje ještě nastavení tohoto atributu u druhu operace (záložka Další). Pokud je u otevřeného období kompomenty nastaveno Ano a u druhu operace rovněž Ano (nebo není vůbec vyplněna záložka Další), zrušení stavu ukončena se neprovede, pokud by byla zrušena událost operace s datem mimo otevřené období komponenty.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 21.12.2007


Pojem - Otevření účetních knih

Otevření účetních knih je činnost, která v souladu s ČÚS pro podnikatele č. 002, provede účetní zápisy, kterými otevře účty hlavní knihy.

Otevření účetních knih v IS BM spočívá v účetním zápisu, kde se nastaví zůstatky rozvahových účtů dle předchozího účetního období. Otevření lze opakovat libovolněkrát při současném zrušení předchozího provizorního otevření. Uzavření účetních knih spočívá v účetním zápisu, kde se zůstatky účtů automaticky převedou na účty třídy 7. Účetní zápisy otevírání a uzavírání účetních knih mají atribut „jiné párování“ nastaven na „Ano“. Tyto účetní zápisy lze sice uskutečnit ručním vstupem (nelze doporučit), ale mnohem účelnější a uživatelsky přítulnější je využití šablon.

Po aktivaci procesu „otevření účetních knih“ je uživateli k dispozici šablona pro otevření účetních knih (tato šablona se automaticky nabízí pouze při prvním spuštění procesu otevření účetních knih, při následných opravách je nutno si šablonu po stisku Ctrl F3 vyvolat ručně), která nabízí:

¨ Období – výběr účetního období, ke kterému se účetní knihy otevírají.

¨ Druh – výběr druhu informace (skutečnost/plán).

¨ Otevření z uzávěrky před. období – jedná se o atribut, který implicitně zůstává nastaven na NE. Protože na začátku dalšího účetního období obvykle dochází k tzv. provizornímu otevření účetních knih, ale uzavření ještě ve většině případů není provedeno, otevírají se účetní knihy bez souvislosti na účetní zápis uzavření předchozího období[1]. Teprve v okamžiku, kdy má uživatel všechny účetní náležitosti závěrky v pořádku a provede korektní uzavření účetních knih, uplatní otevření účetních knih ze závěrky předchozích období. Jinými slovy, položky účetního zápisu týkající se provizorního otevření účetních knih se zruší a provede se regulérní otevření účetních knih s tímto atributem nastaveným na hodnotu „ANO“.

¨ Respektovat selektory – tato volba vyplývá z toho, zda uživatel uvádí selektory na rozvahových účtech. Pokud ano, musí i zde být nastaveno ANO. V případě, že probíhá otevření účetních knih na základě předchozí uzávěrky, musí zde být uvedena stejná hodnota jako v závěrce (účetní zápisy uzavření účetních knih).

¨ Agregované zápisy na účty 7.. – volba zápisu na účty účtové třídy 7. k otevíraným účtům 1:1 nebo agregovaně.

¨ Měna – v případě, že uživatel vede některé účty i v cizí měně, tak ze Zákona o účetnictví pro něj vyplývá povinnost provést otevření účetních knih v těch měnách, ve kterých jsou účty vedeny. Potom pro tento atribut platí doporučení, že při otevření účetních knih ho uživatel nechá prázdný a systém automaticky provede otevření ve všech měnách.

Výběrem: období, druh „skutečnost“, otevření u uzávěrky „ne“, selektory „ne“, agregace „ano“ a měna umožní opakovaně provést provizorní otevření účetnictví. Zapsanou účetní operaci NEUKONČIT!!! , zvolit pouze možnost ZAPSAT. Operaci ukončit až po provedení řádné uzávěrky účetních knih.

V případě promítnutí změn zaúčtovaných do minulého období již po otevření je nutno znovu spustit již zapsanou operaci otevření účetních knih[2], označit všechny události (Volby označování), zrušit označené události, provést nový vstup šablonou (Ctrl F3), zapsat a neukončit.

Definitivní otevření účetních knih (po uzavření) se provede šablonou s volbou otevření z uzávěrky minulého období „ano“. Systém kontroluje existenci účetního zápisu (operace UCE – uzavření účetních knih) uzavření účetních knih, bez ní otevření neproběhne.

Pro otevření účtů podrozvahové evidence se používají stejné procesy jako pro běžné otevření účetních knih (tzn. Nový proces – Účetní zápisy – prvotní evidence) s tím rozdílem, že se nevyužívá možností šablony, ale nadefinovaného importu. Uživatel si aktivuje proces otevření účetních knih – zvolí menu Obecné – Import/Export dat a variantu „Otevření podrozvahových účtů“ požadovaného roku a měny. Při standardním provozu by mělo platit, že uživatelé spouští procesy pro otevření účtů 0 až 6 a další procesy pro otevření podrozvahových účtů – každý pouze jednou.

Systém umožňuje otevření účetních knih provést automaticky (tj. šablonou) pouze jednou ročně. V případě potřeby znovuotevření účetních knih je nutno původní operaci otevření odblokovat (storno neprovádět) a znovu zadat správně (v případě nejasností je toto nutno řešit ve spolupráci s pracovníky IT BM Servis s.r.o., kteří provedou ruční zásah do systému).

[1] tj. potřebné údaje jsou vypočteny z běžných účetních záznamů (událostí v činnosti Účetní deník) předchozího období

[2] V činnosti Procesy a Operace – Operace si uživatel najde operaci účetnictví druhu otevření účetních knih a tu aktivuje (po stisku klávesy F9).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.09.2008


Pojem - Ovládání diagramu procesu

Sestavení (korekce) diagramu procesu (i druhu procesu) se provádí pomocí těchto úkonů:

¨ vytvoření (odstranění) uzlu

¨ definice vlastností uzlu

¨ vytvoření (odstranění) vazby

¨ definice vlastností vazby

Při prvním spuštění diagramu druhu procesu se uživateli zobrazí okno, kde si vybere komponentu a operaci, která bude první operací v procesu (uzlem diagramu). Po stisku tlačítka vybrat se vytvoří uzel operace (rámeček s nadpisem - název[1] druhu uzlu) a zůstane zobrazen v okně. Další uzly uživatel do diagramu procesu vloží stiskem ikony „vložit nový prvek“ (v levém horním rohu okna) a následným stiskem levého tlačítka myši kdekoliv na okně se mu znovu zobrazí tabulka, kde si vybere komponentu a operaci (nebo proces), která vytvoří další uzel. Pokud uživatel nevkládá operaci, ale proces, je nutno si v okně „výběr typu operace/procesu“ zatrhnout volbu procesu.

Po pravém kliku myší na plochu okna diagramu se zobrazí menu, ve kterém je seznam oken včetně hlavního okna programu a výběrem z tohoto seznamu je možné rychle se přepnout do vybraného okna.

Automaticky se mu nabídne možnost vytvoření vazby s tím uzlem procesu, který byl "vysvícen". Uživatel tuto možnost mnohdy využije, pokud ji nechce využít, může možnost automatizovaného založení vazby stornovat. Rovněž má možnost definovat další vazby na jiné uzly. Toto provede po stisku druhé ikony v levém horním rohu okna „vytvořit vazbu“. Uživatel si kurzorem označí uzel, ze kterého chce vytvořit vazbu (horní lišta tohoto uzlu bude tedy modrá, nikoliv šedivá), klikne na ikonku „vytvořit vazbu“ a kurzorem klikne na uzel, do kterého má vazba vést. Znovu se mu nabídne klasická tabulka s možností zadání vlastností vazby. Vazba vyjadřuje vztah mezi zdrojovým a cílovým uzlem a v diagramu procesu je vyjádřena šipkou. Vlastnosti vazby (podrobný popis je k dispozici v dokumentaci Procesy v kapitole 2.2.2 Vazby operací) se zadávají po stisku pravého tlačítka myši na vazbě. Vlastnosti zdrojového a cílového uzle, které vazba spojuje se rovněž zadávají po stisku pravého tlačítka myši přímo na uzlu (podrobný popis vlastností uzlů je k dispozici v dokumentaci Procesy v kapitole 2.2.7 Diagram a sestavení druhu procesu).

Při volbě odstranit (po pravém kliku myší na daném prvku) – je zrušen daný uzel nebo vazba – systém se při zrušení dotazuje „opravdu zrušit prvek?“, současně se zruší vše následující co lze z hlediska daného prvku považovat za "listové", tj. je připojeno do diagramu pouze přes rušený prvek.

V případě, že uživatel pracuje s diagramem již fyzicky vytvořeného procesu, který může být různě modifikován a upraven, má k dispozici další následující funkce (tool v levém horním rohu):

¨ zobrazit zdrojový proces – uživateli se zobrazí diagram zdrojového procesu (pokud daný proces nebyl zahájen z menu NOVÝ PROCES, v tom případě tato ikona není vysvícena)

¨ vazby na jiné procesy – zobrazí se rámeček s přehledem vytvořených vazeb na jiné procesy, a to i vazby realizované pomocí dynamického spojení operací. Tento rámeček uživatel zavře opětovným stiskem této ikony.

¨ vlastnosti – zobrazí se vlastnosti právě aktivního uzlu (tzn. uzlu, který je vysvícen modře)

¨ zrušit – je zrušen aktivní (vysvícený) uzel nebo vazba – systém se při zrušení dotazuje „opravdu zrušit prvek?“, současně se zruší vše následující, co lze z hlediska daného prvku považovat za "listové", tj. je připojeno do diagramu pouze přes rušený prvek.

¨ spustit operaci – poprvé – v případě, že uživatel pokračuje v již existujícím fyzickém procesu přímo z diagramu, může daný uzel aktivovat touto ikonou

¨ spustit operaci – již vytvořenou – slouží k prohlížení již vytvořené operace nebo k modifikaci událostí v ní uložených

¨ diagram druhu procesu – zobrazí se diagram druhu daného procesu

Diagram stornovaného a stornujícího procesu se zobrazuje stejně jako diagram běžného fyzického procesu s tím rozdílem, že na hlavičce procesu je za číslem procesu a jeho názvem v závorce poznámka, zda se jedná o proces stornovaný nebo stornující. Stornovaný i stornující proces lze editovat (připojit nový prvek apod.), ale nedoporučujeme uživateli tuto možnost využívat, je chybou IS, že toto dovolí, uživatel si tímto krokem může narušit korektnost dat.

[1]Pro uzel typu proces je uvedeno id druhu procesu velkými písmeny, pro uzel typu operace je uvedeno id komponenty velkými písmeny a id druhu operace malými písmeny. Pokud je v jednom diagramu opakovaně použit shodný druh operace nebo procesu, je v nadpisu "rámečku" uvedena číslice uvádějící pořadí vyšší než 1.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.10.2013


Pojem - Ovládání formulářů (mřížek)

Způsob zobrazení a setřídění údajů na obrazovce je možno do určité míry ovlivnit i uživatelsky, a to nastavením třídění, pořadím a šířkou jednotlivých sloupců seznamu (způsob zobrazení a setřídění údajů v okně je možno uchovat nastavením v činnosti parametry formuláře). K nastavení třídění slouží uživateli ikona třídění v panelu nástrojů, pořadí a šířku jednotlivých sloupců seznamu si určí uživatel mechanicky – jednoduchou metodou systému Windows „táhni a drž“, čili je nutno si umístit kurzor na daný název sloupce a po stisku levého tlačítka myši ho pak přesunout na zvolené místo v seznamu. V případě potřeby nastavení šířky sloupců se postupuje tak, že ukazatel myši míří na pravý nebo levý okraj sloupce, kde se objeví malá černá šipka a pomocí stisku levého tlačítka myši a přetažení čáry na zvolené místo je upravena šířka sloupce. V menu Obecné v parametrech formuláře je možno toto změněné nastavení následně uchovat (stejně jako je zde možno uchovat i nastavené setřídění obrazovky). Pravý klik myši přímo na názvu vybraného sloupce provede setřídění podle tohoto atributu, tzn. je možno obrazovku třídit nezávisle na tom, jaké třídící hlediska nabízí uživateli panel nástrojů. Toto setřídění se však ani po volbě „uchovat“ v parametrech formuláře neuchová. Pro rozšíření možností uživatelů při práci s IS BM je možné přidávat do mřížek formulářů vlastní sloupce.

Nastavení Preferences řeší chování formulářů BM při přepínání mezi okny formulářů BM po návratu hodnoty z formuláře vyvolaného klávesou F2. Toto nastavení umožňuje pohodlněji řešit situace, kdy má formulář odesílající hodnotu nastavenu vlastnost „ponechat formulář po návratu hodnoty“ a zároveň je v okamžiku odeslání otevřena volná karta tohoto formuláře. Programové řešení emulací stisku kláves Ctrl+F1 v tomto případě přepíná na okno volné karty.

Do atributů formulářů, které jsou víceřádkového typu (např. poznámka, komentář apod.) je možno zapisovat i hyperlinkové odkazy na vybranou internetovou adresu (ve tvaru např. http://www.bm.cz). Tyto napsané odkazy jsou následně zvýrazněny modrým písmem a aktivují se stiskem klávesy CTRL+KLIK pravého tlačítka myši. Po jejich stisku dojde k vyvolání internetového prohlížeče s přechodem na odpovídající odkaz.

Chování mřížky na formuláři událostí komponent je možno ovlivnit i stiskem pravého tlačítka myši. Pokud uživatel stiskne pravé tlačítko myši na pravé liště sloupečku DATUM (tzn. objeví se černá čárka se šipkami jako kdybychom chtěli sloupeček posunout, místo toho na tomto místě stiskneme pravé tlačítko myši), poloha tohoto sloupce se jakoby uzamkne a při listování po sloupcích v mřížce zůstává vždy na prvním místě, ostatní sloupce se pohybují. Opětovným pravým klikem na pravé liště sloupečku DATUM se vrátí původní chování mřížky, tzn. při pohybu po jednotlivých sloupcích se posunují všechny.

Dvojklik přímo na modré liště názvu formuláře (v událostech) roztáhne formulář na celou stránku (poklepem se zase vrátí do původní velikosti). Stejnou funkčnost zajišťuje klávesová zkratka Ctrl F10. Roztažení formuláře souvisí i s tím, jakým způsobem má uživatel umístěnu nabídku aktivních oken. Pokud je umístěna standardně v pravé části obrazovky, formulář událostí je pak při roztažení do šířky o tuto část obrazovky „ochuzen“. V případě, že má uživatel nabídku aktivních oken zobrazenu jako ikony v dolní části obrazovky, formulář se roztáhne do plné šířky obrazovky. To jak si uživatel zobrazí nabídku aktivních oken se definuje v parametrech uživatele.

Systém umožňuje roztažení okna formuláře do šířky tak, že se přitom mění velikost hlavní mřížky formuláře do šířky a pokud je to vhodné, také šířka mřížek na ostatních záložkách. Tato funkčnost je zavedena ve formulářích:

¨ události komponent s výjimkou některých specializovaných komponent

¨ aktuálních hodnost komponent s výjimkou některých specializovaných komponent

¨ artiklů komponent s výjimkou některých specializovaných komponent

¨ obratů komponent

¨ adresář

¨ dokumenty

¨ účtový rozvrh

¨ účetní saldokonto

¨ obratové tabulky účetnictví

¨ konta účetnictví

¨ TP rozpracované k datu

¨ referenční artikly

¨ procesy

¨ operace

¨ druhy procesů

¨ druhy operací

S roztažením okna formuláře (podle potřeb uživatele) plně souvisí možnost uchovávat pozici okna formuláře. IS BM volitelně zaznamenává pozice oken formulářů pro jednotlivé uživatele systému tak, že při následujícím spuštění formuláře je jeho okno zobrazeno v poslední zaznamenané pozici. Takto je možno zaznamenávat pozice oken formulářů, pro které je možno použít volbu z menu Obecné – Parametry formuláře. Výjimku tvoří následující komponenty, kde tato možnost zatím není podporována:

¨ mzdy

¨ sklad zvířat

¨ pozemky

¨ aukční dům

¨ bibliografie

Způsob zaznamenávání pozice okna formuláře je pak dán nastavením atributů v činnosti „parametry uživatele“ a „parametry formuláře“. Výsledné chování IS BM z hlediska uchování pak vyplývá právě z nastavení obou těchto parametrů. V činnosti „parametry formuláře“ při nastavení atributu „uchovávat pozice oken“ = podle nastavení parametrů uživatele se pak systém chová podle nastavení atributu „uchovávat pozice oken“ v činnosti „parametry uživatele“.

Uchování pozice okna může probíhat automaticky vždy při uzavření daného okna formuláře nebo při nastavení parametrů formuláře a nebo je možno uložit pozici okna funkcí „uchovat pozici okna formuláře“ v menu Obecné.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 26.06.2008


Pojem - Ovládání pomocí web browseru

Po přihlášení na web server je vzdálený uživatel vyzván k zadání jména a hesla tak, jak jsou nastaveny v IS Bílý Motýl. Po zadání je lze odeslat <ENTER> nebo ikonou OK (RESET nuluje vyplněné údaje). Pokud je přihlášení v pořádku, zobrazí se vzdálenému uživateli jemu přidělené web menu (jedna položka web menu typu 1.menu). Menu se doporučuje ovládat intuitivně myší.

Upozornění: Pracujeme-li na webu, mějme na paměti základní funkci web browseru: "aktualizovat".

Ovládání prvku web typu "list - slovník dat" lze rozdělit do dvou částí (výběr - prohlížení):

¨ výběr dat, která budou zobrazena web browserem. Výběrem se rozumí omezení celkové dostupné množiny dat, tj. zpřesnění požadavku na zobrazená data vzdáleným uživatelem. Mezi jednotlivými atributy výběru obvykle platí "a zároveň" (AND), pokud není dokumentací prvku web upraveno jinak. Pokud se předpokládá zadané podmínky výběru používat i následně, je možné ztrhnout atribut "Uchovat" a podmínky se příště předplní. Možné typy atributů výběru:

¨ u atributů typu text (C) se obvykle vyplňují jen první znaky[1] ukončené znakem '%' (funkce LIKE '<zadaný řetězec znaků>%'), dokumentací daného prvku web může být definováno jiné vyhodnocení,

¨ u atributů typu číslo (N) nebývá z okna zřejmé, jak je vyhodnocováno, nutno užít dokumentaci daného prvku web, poměrně obvyklé je vyhodnocení operátorem => (rovno nebo větší než zadané číslo),

¨ u atributů typu datum (D) je vždy nutné nějaké datum vyplnit (nutno uvádět ve tvaru dd.mm.rrrr včetně teček), vyhodnocení je dáno dokumentací daného prvku web, jsou-li dvě data ve výběru, obvykle se jedná o uzavřený interval od-do.

Prohlížení (vybraných) dat v okně umožňuje kromě běžného rolování tyto funkce:

¨ změna třídění se provádí kliknutím na nadpis sloupce dle kterého je požadavek data setřídit, v případě změny třídění se třídí vždy všechny stránky vybraných dat,

¨ zobrazení následující (předcházející, první) stránky dat, která nejsou zobrazena v případě "dlouhého" seznamu vybraných dat, se provádí kliknutím na odpovídající text[2] (ten se zobrazuje jen v případě "dlouhého" seznamu) na konci (začátku) zobrazených dat, případné součty sloupců jsou za stránku dat - nikoliv za celý seznam,

¨ zobrazení souvisejících dat[3] s daným záznamem (řádkem) se provádí kliknutím na ty atributy řádku, které jsou podtržené.

Ovládání prvku web typu "list - adresa" je dáno autorem. Je-li autorem BM Servis s.r.o., pak obvykle platí:

¨ Výběr dat a prohlížení dat, která budou zobrazena web browserem, je analogické k typu "list-slovník dat".

Vstup dat má několik fází:

¨ vstupu dat se aktivuje kliknutím na relevantní text (vstup, připojení),

¨ vyplnění vstupního formuláře a odeslání <OK>,

¨ vstup dat je ukončen zprávou o tom, že data byla zapsána.

Přechod z jednoho prvku web do jiného nevyžaduje ukončení předchozího, ale je možné přímo spustit další prvek web. Též je možné užívat funkce web browseru: zpět, vpřed.

[1] Zde platí zásada zadávat jednotlivé znaky bez diakritiky.

[2] Následující záznamy, Předchozí záznamy, První záznam.

[3] Musí být definováno v pohledu SD - připojené okno, doplněná okna, ULR odkazy v tabulkách nebo relace 1:M.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Označování

Pokud je aktivní okno činnosti typu seznam s vyprogramovanou možností označování, nachází se označování pod menu Volby. Ruční označování je možné provést ve většině činností IS BM.

Jak napovídá předchozí odstavec, označování je možno provést dvojím způsobem:

¨ ručně – kliknutím myši do zaškrtávacího políčka dojde k označení aktuálního záznamu. Na dolní liště činnosti má pak uživatel k dispozici informaci o počtu označených záznamů.

¨ pomocí činnosti označování v menu Volby nebo stiskem klávesy Ctrl O. Uživateli se pak zobrazí následující nabídka:

¨ označení všech – označí se (tzn. zaškrtnou) všechny vybrané záznamy

¨ odznačení všech – odznačí se všechny v danou chvíli označené záznamy (i ty nevybrané)

¨ přehled označených / všech – při první aktivaci tohoto tlačítka se uživateli zobrazí přehled označených záznamů[1], při dalším stisku se zobrazí přehled všech vybraných záznamů (funguje jako přepínač)

¨ počet označených záznamů – uživateli je poskytnuta informace o počtu aktuálně označených záznamů. Stejnou informaci má uživatel i na dolní liště okna činnosti.

¨ označování výrazem

Označené záznamy je možno si nejen zobrazit (tj. přehled označených), ale i tisknout. V okamžiku spuštění předlohy výstupu má uživatel možnost vybrat si k tisku pouze označené záznamy.

V případě, že menu Volby daného formuláře obsahuje i podmenu Označování, potom se po stisku pravého tlačítka myši na zaškrtávacím políčku (tzn. tom políčku, které je u daného záznamu zatrženo jako označené) zobrazí menu, které odpovídá obsahu podmenu Označování (tzn. s možnostmi Označení všech, Odznačení všech, ...).

Kromě základní nabídky, která se uživateli nabízí po aktivaci činnosti označování (tzn. o(d)značení, přehled označených/všech, počet označených apod.) je pro některé činnosti v IS BM nabídka rozšířena, např. v adresáři označování podle kategorií, ve spuštěné neukončené operaci je možno hromadné zrušení označených záznamů apod.

V některých činnostech lze s označenými záznamy dále dávkově pracovat, např. platby na příkaz k úhradě, šablona hromadného vstupu do pošty na události podle označených adresátů, dávkové operace apod. Označování je možné pouze nad těmi tabulkami, jejichž primární klíč nepřesahuje 20 znaků.

[1] Přehled označených záznamů vypne výběr, resp. zobrazí vždy přehled všech označených záznamů nezávisle na tom, jaký výběr je právě aktuálně zvolen. Přehled označených by uživatel mohl využívat i tak, že si zvolí řadu obecných výběrů, kde si v každém výběru označí vybrané záznamy a po stisku přehled označených se mu zobrazí kompletně všechny označené záznamy ze všech výběrů.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.11.2009


Pojem - Označování podle kategorií

Tuto funkci uživatel využije při práci s adresářem v tom případě, že jednotlivé adresáty má zařazeny v kategoriích. Pak je možno tuto funkci využít např. při odesílání informačních mailů pouze pro vybranou kategorii (nebo více kategorií) adresátů, tzn. uživatel si na základě vybraných kategorií adresáty označí a tyto označené pak přenese do poštovní zásilky. Při aktivaci tohoto označování podle kategorií se uživateli jako první zobrazí okno, kde si jednotlivé kategorie vybere (přesune pomocí tlačítka se šipkou). V případě, že si vybere více kategorií, je nutno u těchto kategorií určit příznak „nebo“ a „a zároveň“, tzn. zda označovaní adresáti mají být v té a nebo v té kategorii a nebo jestli mají být zároveň v obou kategoriích. Poté stiskne tlačítko „vpřed“ v dolní části okna. V případě, že si uživatel u jednotlivých adresátů eviduje jejich časovou příslušnou v kategorii, využije na druhém okně volbu „zpracovat adresáty příslušné kategorie za období“. Pokud nezpracovává období u kategorií, nechá tuto volbu prázdnou a opět stiskne tlačítko „vpřed“. Další okno nabízí uživateli možnost zvolit si způsob označení, tzn. že se mají vybraní adresáti rovnou označit. V případě, že uživatel měl již před touto volbou nějaké adresáty označeny, může jim toto označení i zrušit. Pak uživatel znovu stiskne tlačítko „vpřed“. Poslední okno uživateli poskytne konečný přehled nadefinovaného označování. V případě, že uživatel s touto informací souhlasí, stiskne tlačítko „dokončit“. V posledním okně se uživateli zobrazí průvodce označováním, který mu poskytne informaci o konečném výsledku označování. Po stisku tlačítka OK je označování podle kategorií dokončeno a uživatel je vrácen zpět do adresáře, kde si pod volbou označování zvolí možnost „přehled označených“. V případě, že by chtěl některou informaci před dokončením označování ještě změnit, může využít tlačítka „zpět“.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 11.10.2007


Pojem - Označování výrazem

Je další způsob získávání informací z BM. Vyvolává je položkou menu "Volby - Označování - Označování výrazem". Funkce vyvolá vstup pro zadání a uchovávání výrazů přihlášeného uživatele. Po uložení výrazu je možné vyvolat označení záznamů, které vyhovují zadané podmínce a zároveň se uplatňuje také aktuálně platný výběr výběrové záložky a případně aktuálně použitý obecný výběr. Funkce "Označování výrazem" se uplatňuje pouze ve formulářích objektů BM a není ji možné vyvolat z menu "označování", je-li v dané chvíli aktivní výběr s přehledem označených záznamů.

Pro usnadnění zadávání dotazu může uživatel používat implementátorem systému předdefinovaná makra. Atributem makra je mimo jiné jeho druh, kterým je možné vyhradit jeho exkluzivní použití některým uživatelům systému, tzn. nadefinovat přístupová práva.

Každý formulář má svou vlastní množinu maker.V makru se definuje:

¨ název makra

¨ template tvar skutečných parametrů makra

¨ textové pole pro vstup části SQL dotazu za WHERE (výraz makra)

¨ textové pole pro vstup části SQL dotazu za FROM

¨ formální parametry makra

Při zadávání dotazu uvádí uživatel název makra se skutečnými parametry. Při jeho vyhodnocování dojde k nahrazení odpovídající části dotazu obsahem výrazu makra. Přitom jsou formální parametry makra nahrazeny parametry skutečnými. Makra pro označování výrazem obsahují ve výrazu makra výraz v syntaxi SQL jazyka serveru Sybase SQL Anywhere, který zpravidla vrací logickou hodnotu. Formální parametry makra se ve výrazu makra uvádějí v hranatých závorkách. Makra není možné vnořovat. Definovat makra je možné z formuláře "Označování výrazem" klávesou F5 nebo volbou činnosti z menu Volby. Při zadávání výrazu označování může uživatel vyvolat rychlou nápovědu klávesou F2 nebo pravým tlačítkem myši.

Označování výrazem je možné používat také ve formulářích spuštění operace komponenty. Praktické použití této možnosti je např. pro uperaci komponenty smluv, kdy je možné označovat různé položky

smlouvy v operaci podle různých hledisek a s takto označenými položkami provádět různé hromadné úkony (např. vložit do označených položek stejnou cenu pomocí doplňující vlastnosti formuláře).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 09.03.2007


Pojem - Palety barev kategorií

V hlavním menu v činnosti Informační centrum je k dispozici nabídka Správa artiklu. Aby uživatel mohl smysluplně využívat možností, které mu nabízí tato nabídka v souvislosti s kategoriemi a paletou barev, musí mít nadefinovány tyto činnosti:

¨ kategorie událostí správy artiklu – zde si uživatel nadefinuje jednotlivé kategorie, které by nad artikly (sám si následně určí jestli nad artikly skladu, obchodu apod.) chtěl sledovat

¨ palety barev kategorií – ke každé nadefinované kategorii je potom možno přiřadit barevnou paletu. Může být obarveno pouze pozadí dané kategorie nebo její písmo a nebo i obojí. Podle nastavené barevné palety se následně pak kategorie barevně zobrazují v činnosti kategorie událostí správy artiklu.

Na základě zvolení Palety na záložce Výběr je možno přehled artiklů zvýraznit i barevně. Pokud uživatel vybere z překryvného seznamu paletu a zaškrtávací políčko před zůstane prázdné, budou po zapsání Výběru zobrazeny všechny artikly (podle nastaveného Výběru) a ty, které spadají do kategorií dané palety (barva je přiřazena kategorii) budou vyznačeny barevně.

Pokud uživatel vybere z překryvného seznamu paletu a zaškrtne zároveň políčko před, budou po zapsání Výběru zobrazeny (v příslušné barvě) pouze ty artikly, které spadají do dané palety (resp. ty, které jsou nadefinovány v kategoriích dané palety).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 31.03.2014


Pojem - Palety barev kategorií adresátů

Nadefinování palety barev kategorií adresátů umožňuje zobrazovat adresáty v činnosti adresář v různých barvách v závislosti na jejich zařazení do kategorií. Např. uživatel si může vytvořit paletu barev, kterou nazve odběratelé. Pak v kategoriích může mít kategorie odběratelé do 100 tis.Kč, odběratelé do 200 tis.Kč. apod. Těmto kategoriím nadefinuje příslušné barvy a přiřadí je k paletě barev odběratelé. Při vstupu do adresáře se pak ve výběrové záložce kromě kategorie adresáta nabízí uživateli i možnost výběru za příslušnou paletu barev. Tzn. když si vybere paletu odběratelé, zobrazí se mu adresáti, kteří spadají do kategorií, které jsou obsažené v paletě odběratelé.

Při spuštění této činnosti uživatel zadává identifikaci a název palety barev. Ke každé paletě si může uvést svojí libovolně dlouhou poznámku. Výběrem skupiny se určuje uživatel palety barev. Důležitější je záložka kategorie v paletě, kde uživatel zadává:

¨ kategorie – identifikace kategorie adresáta (pokud ji nemá vytvořenu, je možno ji rovnou založit a přenést zpět do formuláře)

¨ priorita - určuje prioritu určení barvy v paletě barev v případě, že adresát odpovídá většímu počtu kategorií v paletě (např. 10, 20, 30 apod.)

¨ barva písma – tzn. jakou barvu písma budou mít adresáti v dané kategorii (nejčastěji se nechává standardní černá, tzn. že barva písma se neuvádí)

¨ barva pozadí – tzn. jakou barvu bude mít pozadí (tzn. řádek) na kterém je v adresáři uveden adresát, který spadá do této kategorie

V souvislosti s paletou barev byly rozšířeny vlastnosti kategorie adresáta o další atributy. Tyto atributy se nevstupují přímo ve formuláři „kategorie adresátů“, ale pomocí činnosti „definování typu kategorie adresáta“ (menu volby nebo klávesa F5) z tohoto formuláře.

Palety barev je možné exportovat do balíčku.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Panel nástrojů

Pod pojmem panel nástrojů je možno rozumět horní lištu každé činnosti (tj. formuláře) informačního systému Bílý Motýl.

Panel nástrojů je pro všechny činnosti stejný, jeho zobrazení (tzn. aktivace jednotlivých ikonek) může být v daném okamžiku různé. V každé činnosti jsou vysvíceny pouze ty ikony, které může uživatel použít, ty které jsou pro tuto chvíli nepřístupné jsou šedivé a není možné je aktivovat. Pokud si uživatel panel nástrojů nepřemístí jinam (klasické ovládání oken windows „uchop a táhni“), zobrazuje se standardně pod horní lištou okna. Jednotlivé ikony a jejich funkce si vysvětlíme podrobněji:

¨ Rychlé vyhledávání (klávesa Ctrl ) – např. v adresáři, po aktivaci tohoto políčka (tzn. Ctrl + šipka nahoru nebo kliknout do tohoto políčka myší), zapsání názvu adresáta a stisku Enter skočí kurzor právě na daného adresáta

¨ Třídící hledisko

– způsob setřídění formuláře v okně. Může být třídění např. podle identifikace, data, názvu apod. Zvolené třídící hledisko daného formuláře jde uchovat i natrvalo (viz. Parametry formuláře)

Sestupné nebo vzestupné třídění formuláře (implicitně je nastaveno vzestupné, pokud se tato položka zaškrtne, aktivuje se sestupné třídění, tzn. např. v rámci abecedy ve směru od Z do A, v rámci třídění podle částky, tedy podle numerického třídění, od částky nejvyšší po nejnižší).

¨ Ikony, určující způsob pohybu ve formuláři.

- přesun na první záznam

- přesun o jeden záznam zpět

- přesun o jeden záznam vpřed

- přesun na poslední záznam

Na těchto ikonách je zároveň dostupné i pravé tlačítko myši, které u první a čtvrté ikony způsobí posun o změnu primárního klíče (např. při setřídění událostí podle data systém automaticky přeskočí na nejbližší další datum) a u druhé a třetí ikony posun o stránku.

¨ Založení nového záznamu (klávesa F3) - vstup dat

¨ Oprava daného záznamu (klávesa F4) – oprava dat

¨ Zrušení daného záznamu (klávesa F8) – rušení dat

¨ Vyhledávání v číselníku (klávesa F2, pravé tlačítko myši na „žluté“ položce)

¨ Uložení daného záznamu (klávesa Ctrl W nebo Ctrl End, podobně funguje i klávesa ESC, po jejíž aktivaci následuje dotaz na ukončení činnosti)

¨ Návrat zpět bez uložení provedených změn nebo bez zapsání daného záznamu

¨ Tisk (klávesa Ctrl T) – zobrazí se nabídka předloh výstupu

¨ Tabulka – režim úplného gridu, tj. zobrazují se pouze řádky. Zpět do normálního zobrazení se uživatel dostane opětovným stiskem této ikony.

¨ Objekty – zobrazí se rámeček souvislostí objektů, kde je následně možno vyvolat k danému záznamu např. souvislost se zprávami nebo poštou apod.

¨ Převzetí hodnoty (Ctrl Enter) – po vyvolání číselníku a zvolení příslušného údaje se stiskem této ikony provede návrat této hodnoty do původního formuláře

¨ Ukončení dané činnosti

¨ Vyvolání nápovědy

Základní panel nástrojů je tedy u všech činností stejný, jeho zobrazení však může být v daném okamžiku různé. Pokud si uživatel neumístí tento panel jinam (metodou uchopení panelu myší a přetáhnutí do levé, pravé či dolní části okna), zobrazuje se standardně pod horní lištou okna činnosti. V některých případech se stává, že uživatelé mají s umístěním panelu nástrojů problém (omylem si ho např. přetahují myší po okně apod.), pak je možno využít atributu v parametrech uživatelů „povolena změna pozice panelu nástrojů“. Pokud je tento atribut zatržen, uživatel má možnost si panel nástrojů přesouvat podle potřeby libovolně po okně, pokud zatržen není, panel nástrojů se uživateli zobrazuje standardně vždy pod horní lištou okna a nejde přesouvat.Vysvíceny (čili aktivní; neaktivní ikony jsou zobrazeny šedivě) jsou pouze ty ikony a jejich funkce, které může uživatel v danou chvíli použít. Např. při zadávání nového záznamu je vysvícena ikona disketa (uložení), ale není přístupna ikona na opravu záznamu. U dalších popsaných používaných funkčních kláves je uživatele nutno upozornit, že ne všechny funkční klávesy jsou dostupné ve všech činnostech (stejně jako na panelu nástrojů nejsou vždy dostupné všechny ikony), vždy to vyplývá z kategorie činnosti a způsobu práce s ní:

¨ ESC – v případě prohlížení jakýchkoliv dat způsobí klávesa ESC zrušení tohoto prohlížení (pokud není v parametrech uživatele nastaveno jinak). V případě zápisu nebo opravy jakýchkoliv dat se systém po stisku klávesy ESC dotazuje „Zapsat data?“, v případě použití ESC při operaci v procesu se zaktivuje volba Nového procesu a možnost „Zapsat“ nebo „Zapsat a ukončit“.

¨ F10 – aktivace horní lišty (stiskem Enter je pak možno vyvolat nabídku menu volby, obecné apod.)

¨ Alt Q – nový dotaz s možností výběru vstupu definovaným na atributu „uchovat“.

¨ Ctrl + pravý klik myši – aktivace funkce automatického dokončování

¨ Ctrl + Home – nejprve se uživateli zobrazí dotaz: „Aktivovat funkci automatického dokončování pro pole „....“? Ano/Ne. Po volbě Ano se provede automatické vytvoření záznamu funkce automatického dokončování daného atributu pro daného uživatele s nastavením „naplnění seznamu návrhů“ na hodnotu Vstupem

¨ Ctrl Q – zvolení nového výběru. Znovu se zobrazí záložka výběr s posledním nastaveným výběrem.

¨ Ctrl O – činnosti související s označováním

¨ Ctrl D – vyvolání dokumentů (jen v objektech)

¨ Ctrl S – suma částek – uživateli se nabízí tabulka, kde je suma položek dané činnosti (jen v událostech)

¨ Ctrl T – vyvolání tabulky s předlohami výstupu (tzn. seznamu jednotlivých tiskových sestav)

¨ Ctrl W - uložení záznamu (v panelu nástrojů ikona disketa)

¨ F6 – strom hlavního procesu (v událostech změny stavu peněz zastupuje klávesa F6 činnost přehled spárování)

¨ F7 – diagram procesu

¨ F9 – spuštění procesu nebo operace

¨ Page Down – potvrzení výběru (na základě zadaného výběru pak systém ukáže příslušné události v okně činnosti)

¨ Ctrl Page Up – posun záznamu na daném atributu směrem k začátku seznamu (tzn. pokud uživatel umístí kurzor např. na atribut komentář, po stisku Ctrl PgUp se posune o jeden záznam výše opět na atribut komentář)

¨ Ctrl Page Down – posun záznamu na daném atributu směrem ke konci seznamu (tzn. pokud uživatel umístí kurzor např. na atribut komentář, po stisku Ctrl PgDn se posune o jeden záznam níže opět na atribut komentář)

¨ klávesa TAB – posun o další prvek na záznamu

¨ Shift TAB – posun zpět na předchozí prvek záznamu

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 21.07.2014


Pojem - Panel nástrojů v okně činnosti výstupy

Jedná se o panel nástrojů (horní lištu), který má uživatel k dispozici při vyvolání činnosti tisk a zobrazení okna výstupů. K dispozici má tyto možnosti:

¨ spuštění výstupu – vlastní aktivace tisku vybrané předlohy výstupu

¨ oprava předlohy – u nové předlohy slouží tato činnost k výběru položek výstupu, u již nadefinované předlohy k opravě definice uspořádání položek

¨ výběry – uživatel si zde může nadefinovat výběr a jeho podmínku. Tento výběr mu slouží pro případ, že záložka výběr a možnosti ve vlastnostech předlohy (setřídění, doplnění, seskupování) nesplňují přesně jeho požadavky. Tímto výběrem si pak požadovaná výběrová kritéria může upřesnit. Při spuštění předlohy výstupu s tímto použitým výběrem pak IS BM provádí svůj SELECT, který vychází z činnosti (nad kterou probíhá tisk) a je upraven podle uživatelských definic ve vlastnostech předlohy (setřídění, seskupování, doplnění)

¨ nová předloha – pomocí této možnosti uživatel zadává novou předlohu výstupu. Atributy, které zde zadává jsou shodné s vlastnostmi předlohy, takže je zde nebudeme podrobně rozepisovat.

¨ kopie předlohy – uživatel má možnost na základě již nadefinované předlohy vytvořit kopii, kde si pouze zadá svůj nový název a samozřejmě má možnost si tuto kopii následně upravovat.

¨ vlastnosti předlohy

¨ zrušení – možnost zrušení vybrané předlohy výstupu

¨ zobrazovat skryté předlohy – po stisku této ikony uživatel bude mít k dispozici i ty předlohy výstupu, které mají ve svých vlastnostech zatržen příznak „skrytá“

¨ způsoby zobrazení okna předloh výstupu – možnost zvolení si způsobu, jak budou jednotlivé předlohy výstupu v okně výstupu uspořádány. Je možnost zvolit zobrazení: velké ikony, malé ikony, seznam, detaily

¨ nápověda – nápověda k činnosti

¨ nápověda – seznam položek k tisku – zobrazí se přehled atributů dané činnosti, které jsou dostupné při definování uspořádání položek výstupu

¨ konec činnosti – ukončení a zavření okna „výstupy“.

Kromě činností, které uživateli nabízí panel nástrojů (tj. horní lišta) okna výstupů má k dispozici ještě i činnosti, které se mu nabídnou po stisku pravého tlačítka myši kdekoliv ve volném (tzn. bílém) prostoru okna činnosti výstupy. Některé činnosti jsou shodné s činnostmi dostupnými v horní liště, ale navíc má uživatel k dispozici:

¨ přílohy k předloze

¨ export do balíčku

¨ překlad popisek – název předlohy

¨ metapředlohy

¨ skupiny procesů/předloh výstupu

¨ osobní skupina předlohy

¨ nastavení stromu

¨ export webovou službou

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 16.02.2012


Pojem - Parametr funkce výkazů

Parametr funkce výkazů je formální parametr, který se obvykle využije v kódu funkce pro zajištění jeho variability a tím i využití v několika variantách. V okamžiku volání funkce musí být uvedeny skutečné parametry, které se uplatní při výpočtu hodnoty funkce.

Parametry jsou některého z těchto typů: Numerický, Znakový, Datumový, Seznam hodnot nebo Makro.

V rámci definice formálního parametru funkce se uvádí: pořadí parametru ve skutečných parametrech při volání funkce, název parametru, typ parametru a v případě typu Seznam se dále uvádí relevantní atribut entity (tabulky datového modelu IS BM) a jeho délka.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.08.2007


Pojem - Parametry a číselníky

Pro nastavení správného chování mezd má uživatel k dispozici celou řadu číselníků, z nichž některé dostává naplněny s dodávkou systému a některé doplní v součinnosti s implementátorem mezd. Jsou to např.:

¨ Daňové tabulky

¨ Kalendář

¨ Pracovní funkce

¨ Výplatní místa

¨ Zdravotní a sociální pojišťovny (oba druhy pojišťoven jsou zde uvedeny zároveň, jsou však odlišeny typem)

¨ Tarifní stupnice a třídy

¨ Druhy událostí

¨ Umístění mezd

Parametry jsou k dispozici v menu Mzdy – Mzdy – Parametry. Jednotlivé parametry ovlivňují jakým způsobem se bude chovat optimalizovaný výpočet mezd. Obsahují základní nastavení hodnot systému mzdové agendy a jsou rozděleny do tří záložek:

záložka Hodnoty

¨ poslední zpracované mzdy k datu – datum posledního výpočtu mezd

¨ uzamknutí – datum uzamčení výpočtu mezd. Je-li vyplněno, pak k tomuto datu již nelze provádět opravy a výpočty mezd pracovníků

¨ dorovnání min. mzda – mzdová položka, sloužící k dorovnání příjmu do minimální mzdy

¨ náhrada mzdy za nemoc – identifikace položky náhrady mzdy (slouží k výstupu mezd do plateb a účetnictví)

¨ min. roč. daňový bonus

¨ max. roč. daňový bonus

¨ kontrola příslušnosti

záložka Chování

¨ den výplaty (a zároveň kdy bude den výplaty, jestliže by měl připadat na sobotu nebo neděli)

¨ velká / malá organizace

¨ technický selektor na výpl. lístek odkud

¨ typ kalendáře (po měsících nebo po dnech)

¨ plánovací kalendář – určuje jeden z měsíčních kalendářů FPD jako plánovací kalendář, platný pro všechny zaměstnance. I když organizace používá denní kalendáře (viz. atribut výše), musí být tento plánovací kalendář vygenerován i ve variantě měsíční a to v případě, že organizace používá ve mzdách měsíční průměry ve mzdách (např. při výplatě odstupného).

¨ způsob výpočtu denního průměru

¨ způsob výpočtu SP

¨ způsob výpočtu nepřítomnosti pro nemoc

¨ sada

¨ velikost zkušeb. doby v měs.

záložka Adresáti

¨ adresát, spojení, účet, adresa, KS a VS pro odvod zálohové daně

¨ adresát, spojení, účet, adresa, KS a VS pro odvod daňového bonusu

¨ adresát, spojení, účet, adresa, KS a VS pro odvod srážkové daně

¨ adresát, spojení, účet, adresa, KS a VS pro odvod sociálního pojištění

¨ adresát, spojení, účet, adresa, KS a VS pro odvod zákonného pojištění odpovědnosti

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 07.05.2009


Pojem - Parametry adresáře

Jedná se o činnost, která uživateli umožňuje nastavit si parametry adresáře tak, jak to vyhovuje jeho potřebám nebo metodikám ve firmě. Činnost se nachází v menu Marketing – Adresář – Parametry a číselníky. Je možno zadat:

¨ validace duplicity IČO (v případě zadání adresáta se stejným IČO, který již v adresáři je, systém hlásí shodu)

¨ validace duplicity DIČ (v případě zadání adresáta se stejným DIČ, který již v adresáři je, systém hlásí shodu)

¨ validace duplicity telefonu (hlídání podle telefonního čísla)

¨ validace duplicity faxu (hlídání podle faxového čísla)

¨ validace duplicity RČ (hlídání podle rodného čísla)

¨ kontrola rodného čísla MOD11 (hlídání formátu rodného čísla, aby splňovalo kontrolu modulo 11)

¨ aktuální stát – uživatel zde zadá identifikaci státu, který se pak automaticky předplňuje v událostech, kde je jako atribut uveden

¨ české PSČ – jedná se o způsob použití formátovací masky pro vstup PSČ – pokud je zatrženo, bude se PSČ zapisovat automaticky ve tvaru tři čísla, mezera, dvě čísla

¨ implicitní adresát – identifikace adresáta, který se bude v událostech tvářit jako „JÁ“

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 09.12.2013


Pojem - Parametry formuláře

Jedná se o parametry, které se vždy vztahují k danému (tj. aktuálně) spuštěnému formuláři. Tyto parametry je možno nastavit na každém okně pod menu Obecné – Parametry formuláře. Je možno nastavit následující:

¨ reakce na klávesu ESCAPE při prohlížení - možnosti jsou stejné jako u parametrů uživatele, včetně toho, že je možno tyto možnosti ignorovat a zatrhnout rovnou možnost „podle parametrů uživatele“

¨ nastavení formuláře - tento atribut se týká možnosti uchování změn provedených ve formuláři. Je možno měnit jeho setřídění, po spuštění formuláře je nastaveno vždy nějaké implicitní třídění, které si může uživatel podle svých potřeb změnit a v případě potřeby i uchovat. Pokud si uživatel změní i vzhled tabulky (tj. mřížky) v okně, tzn. např. v tabulce „obchodovatelný artikl“ si přesune jednotlivé sloupečky tak, jak mu to vyhovuje, je možno si i tuto změnu uchovat. Možnosti nastavení formuláře tedy jsou:

- neukládat

- uchovat setřídění a nastavení mřížky

- uchovat setřídění

- uchovat nastavení mřížky

- zrušit uchované nastavení

¨ uchovávat pozice oken – tento atribut se týká možnosti zaznamenat pozice oken formulářů pro jednotlivé uživatele systému tak, že při následujícím spuštění daného formuláře je jeho okno zobrazeno v poslední zaznamenané pozici. Způsob zaznamenávání pozice okna formulářů je dán kombinací nastavení „parametrů uživatele“ a „parametrů daného formuláře“. Možnosti nastavení uchování pozice formuláře jsou následující:

- NE

- Ano – automaticky vždy při uzavření okna

- Ano – při nastavení parametrů formuláře

- podle nastavení parametrů uživatele

Výsledné chování IS BM z hlediska uchování pozice oken vyplývá z nastavení těchto obou parametrů. V činnosti „parametry formuláře“ při nastavení atributu „uchovávat pozice oken“ = podle nastavení parametrů uživatele se pak systém chová podle nastavení atributu „uchovávat pozice oken“ v činnosti „parametry uživatele“.

¨ ponechat formulář po návratu hodnoty - je vhodné zaškrtnout u činností typu číselníku (např. artikly skladu, obchodu, adresář) při zadávání operací o více událostech proto, aby uživatel nemusel u každé události na žlutém výběrovém poli (např. u artiklu) zadávat a potvrzovat výběr a pak přenést artikl na událost, tak při vstupu první události a tohoto atributu na číselníku např. právě zmiňovaných artiklů je vhodné zaškrtnout tento příznak a po stisku F2 se uživateli zobrazí rovnou číselník bez toho, aby musel potvrzovat nějaký výběr. Po ukončení práce s IS BM se tento příznak automaticky ruší, tzn., že při dalším přihlášení do systému je nutno si ho v případě potřeby na vybraném číselníku opětovně zaškrtnout.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Parametry mezd

Parametry jsou k dispozici v menu Mzdy – Mzdy – Parametry. Jednotlivé parametry ovlivňují jakým způsobem se bude chovat optimalizovaný výpočet mezd. Obsahují základní nastavení hodnot systému mzdové agendy a jsou rozděleny do tří záložek:

záložka Hodnoty

¨ poslední zpracované mzdy k datu – datum posledního výpočtu mezd

¨ uzamknutí – datum uzamčení výpočtu mezd. Je-li vyplněno, pak k tomuto datu již nelze provádět opravy a výpočty mezd pracovníků

¨ dorovnání min. mzda – mzdová položka, sloužící k dorovnání příjmu do minimální mzdy

¨ náhrada mzdy za nemoc – identifikace položky náhrady mzdy (slouží k výstupu mezd do plateb a účetnictví)

¨ min. roč. daňový bonus

¨ max. roč. daňový bonus

¨ kontrola příslušnosti

záložka Chování

¨ den výplaty (a zároveň kdy bude den výplaty, jestliže by měl připadat na sobotu nebo neděli)

¨ velká / malá organizace

¨ technický selektor na výpl. lístek odkud

¨ typ kalendáře (po měsících nebo po dnech)

¨ plánovací kalendář – určuje jeden z měsíčních kalendářů FPD jako plánovací kalendář, platný pro všechny zaměstnance. I když organizace používá denní kalendáře (viz. atribut výše), musí být tento plánovací kalendář vygenerován i ve variantě měsíční a to v případě, že organizace používá ve mzdách měsíční průměry ve mzdách (např. při výplatě odstupného).

¨ způsob výpočtu denního průměru

¨ způsob výpočtu SP

¨ způsob výpočtu nepřítomnosti pro nemoc

¨ sada

¨ velikost zkušeb. doby v měs.

¨ typ daňového subjektu – možnosti jsou Neurčeno, F-Fyzická osoba, P-právnická osoba, L-Plátcova pokladna. Pro formulář „Hlášení k záloze na pojistné na důchodové spoření“ je nutno vyplnit, kdo je plátcem pojistného.

Poznámka:

Daňovým subjektem je vždy fyzická nebo právnická osoba, nemůže jím být její organizační složka (např. závod, odštěpný závod, provozovna, dílna, prodejna apod.). Určitou výjimkou je však plátcova pokladna, která sice není daňovým subjektem, ale má stejná oprávnění a povinnosti jako plátce daně.

Plátcovou pokladnou je taková organizační složka, organizační jednotka plátce daně z příjmů fyzických osob ze závislé činnosti, v níž dochází k vybírání nebo srážení této daně nebo záloh na ni a kde jsou k tomu uloženy všechny potřebné doklady. Plátcovou pokladnou jsou rovněž pobočky či organizační jednotky banky nebo pojišťovny, v nichž dochází k vybírání nebo srážení srážkové daně z příjmů, pokud jsou u této pobočky nebo organizační jednotky banky (pojišťovny) k dispozici veškeré doklady nutné pro provedení řádné srážky daně a pro provedení kontroly této srážkové daně (převážně se bude jednat o srážkovou daň z úroků). Postavení plátcovy pokladny má tato organizační jednotka pouze v daném rozsahu, tj. pro účely daně z příjmů fyzických osob ze závislé činnosti a pro srážkovou daň z příjmů u bank a pojišťoven, pro ostatní daně, resp. pro ostatní části daně z příjmů, toto postavení neplatí.

Místně příslušným správcem daně je pro plátcovu pokladnu ten finanční úřad, v jehož obvodu se plátcova pokladna nachází (nikoliv tedy finanční úřad místně příslušný plátci).

záložka Adresáti

¨ adresát, spojení, účet, adresa, KS a VS pro odvod zálohové daně

¨ adresát, spojení, účet, adresa, KS a VS pro odvod daňového bonusu

¨ adresát, spojení, účet, adresa, KS a VS pro odvod srážkové daně

¨ adresát, spojení, účet, adresa, KS a VS pro odvod sociálního pojištění

¨ adresát, spojení, účet, adresa, KS a VS pro odvod zákonného pojištění odpovědnosti

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 03.12.2013


Pojem - Parametry nemocenského pojištění

Tyto parametry má uživatel k dispozici v menu Mzdy – Parametry – Parametry nemocenského pojištění. Slouží ke vstupu parametrů potřebných pro výpočet dávek nemocenského pojištění. Definice těchto parametrů je daná současnými zákony, tzn. hodnoty zde uvedené si uživatel nevymýšlí. Pokud by měl uživatel pocit, že nadefinovat si tyto parametry je tzv. „nad jeho síly“, svěří tuto činnost do rukou implementátorovi, který má na starost jeho firmu. Jsou to tyto parametry:

¨ algoritmus stanovení nem. dávky

¨ denní vyměřovací základ

¨ platnost algoritmu v období

V činnosti Parametry jsou k dispozici další dva atributy, které souvisí s výpočtem nemocenského pojištění. Na záložce „chování“ je to příznak zaškrtnutí, zda se jedná o velkou či malou organizaci a příznak plus nebo mínus u způsobu výpočtu nepřítomnosti pro nemoc (viz. popis dále).

Nastavení položek Mzdy – Parametry – Parametry nemocenského pojištění je v souladu s legislativou. Vzhledem ke složitosti dané problematiky posíláme uživatelům vždy balíček s nastavením těchto parametrů. V případě potřeby jejich úpravu provádí zkušený implementátor.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 23.01.2008


Pojem - Parametry oceňování

Parametry oceňování slouží pro definici parametrů, které jsou následně používány i při práci v jiných komponentách. Uživatel zadává tyto parametry:

¨ Referenční měna - zadává se kód měny - referenční měna slouží jako oceňovací jednotka.

¨ Kód implicitní banky - zadává se kód banky - zde je možnost nastavit implicitní banku uživatele. Tato položka není povinná. Je vhodné ji vyplnit v okamžiku, kdy uživatel nemá vyplněnou identifikaci centrální banky. Měna účtu s identifikací této implicitní banky pak slouží pro předplňování v událostech, tzn. že kurzový lístek by měl být veden v souvislosti s kurzy této banky. V podstatě lze říci, že platí, že v parametrech musí být prioritně uveden kurz centrální banky, kód implicitní banky zůstává prázdný. Pouze v případě, že uživatel nebude mít zadán kód centrální banky (z nějakého důvodu ji nechce používat), tak vyplní kód implicitní banky. Neměla by nastat situace, že ani jeden kód nebude vyplněn, protože poté dochází v událostech, kde je použita zahraniční měna k chybovým hlášením ohledně kurzového lístku (systém „nechápe“, ke které bance se má uvedená měna vztahovat).

¨ Kód centrální banky - zadává se kód banky - zde se nastaví centrální banka. Pokud je zadaná centrální banka, pozbývá smyslu zároveň zadávat i kód implicitní banky, v takovém případě je vhodné nechat tento atribut prázdný.

¨ Předplňovat kurz pouze je-li aktuální - pokud je tato volba zaškrtnuta, dojde u atributu kurz (na událostech obchodu) k předplnění hodnoty kurzu aktuálním kurzem (tzn. že v kurzovém lístku musí být kurz k aktuálnímu dni zařazen). Aktuálním kurzem se rozumí v případě komponenty platby kurz se stejným datem jako datum události na platbě (nikoliv datum splatnosti). V případě komponenty obchod se aktuálním kurzem rozumí kurz se stejným datem jako datum dodání na události obchodu. Pokud není zaškrtnuto, předplní se kurz vždy a to ten, který je jako poslední zadaný v kurzovém lístku (nezatrhává se např. v kombinaci s použitím činnosti operace s kurzem prvého dne, tzn. při používání pevných ročních nebo měsíčních kurzů).

¨ Pro dnešní datum pracovat s včerejším kurzem do ... h – zatržení respektuje ustanovení, že do uvedené hodiny a minuty lze vyhodnocovat částky v zahraničních měnách kurzem předchozího dne. Při vstupu událostí s aktuálním datem a zároveň s aktuálním časem počítače menším než uvedený čas v parametru systém tedy pak v událostech předplňuje kurz kurzem předchozího dne (v pondělí je to pátečním kurzem). Pozn.: někteří uživatelé zde uvádějí 15h, protože to je čas, kdy ČNB vydává oficiální denní kurzy, nicméně hodina a minuta zde uvedená zcela závisí na vnitropodnikových směrnicích uživatele.

¨ Automatická aktualizace kurzu - pokud je tato volba zaškrtnuta, zadá-li se na událostech kurz, je automaticky aktualizován v číselníku měn a kurzů (jen, pokud ještě pro daný den neexistuje). V případě, že je zaškrtnutý příznak „ pro dnešní datum pracovat s včerejším kurzem do 15:00 hodin“ a vstupují se události s aktuálním datem a zároveň s aktuálním časem počítače menším než 15h, je podle tohoto pravidla aktualizován kurz dané měny uložený v IS BM.

¨ Přepočet měn EMU - historický atribut. V současné době není jeho používání opodstatněné.

Pod menu volby má uživatel k dispozici činnost „Tabulka přechodů na měny“. Uživatel ji použije pouze v případě, že nastane situace přechodu na novou měnu (např. od 1.1.2009 na Slovensku přechod ze slovenských korun na měnu euro). V této činnosti v podstatě uživatel určuje novou referenční měnu, která se pak následně předplňuje jako referenční v událostech, ve kterých se pracuje s měnou (obchod, DPH, platby, změna stavu peněz, zálohy, účetnictví). Ve formuláři „Tabulka přechodů na měny“ se uvádí datum platnosti měny OD a identifikátor měny.

S případnou změnou referenční měny souvisí i nastavení platnosti měny (v činnosti Měny a kursy). U původní referenční měny (v našem případě u slovenských korun) je nutno nastavit platnost měny do, tzn. v této činnosti je nutno nastavit, že od 1.1.2009 je nová referenční měna EURO a v činnosti Měny a kurzy je nutno u slovenských korun nastavit platnost do 31.12.2007. V případě, že je u měny uvedeno období platnosti, nelze pak v událostech vstoupit měnu, jejíž datum nespadá do období platnosti měny.

Důležité upozornění:

Uvedené údaje o referenční měně se v činnosti Parametry oceňování ukládají do tabulky BWMEMOR s celou řadou dalších proměnných. Pro snadnější získání těchto údajů programovými prostředky je v IS BM objekt OCPARAM, nesoucí tyto údaje. S tímto parametrem lze dále uživatelsky pracovat např. v doplňujících vlastnostech formuláře či v předlohách výstupu.

V implementačních doplněních uváděných v jazyce FoxPro (např. právě doplňující vlastnosti formuláře) je vhodné uplatnit tuto konstrukci:

if type('ocparam')<>'O'

do ocparam

endif

která způsobí, že pokud neexistuje objekt ocparam, tak se spustí procedura ocparam a objekt se vytvoří

V předlohách výstupu lze uplatnit tuto konstrukci. Ve vlastnostech předlohy na záložce Deklarace v kolonce Script před SQL dotazem je nutno uvést:

if type('ocparam')<>'O'

do ocparam

endif

a následně ve vlastnostech předlohy na záložce Doplnění v atributech je nutno zapsat:

OBCENIK.oc01id=?ocparam.oc01id

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 09.10.2014


Pojem - Parametry odpisovaného majetku

Tuto činnost má uživatel k dispozici v hlavním menu – Odpisovaný majetek – Parametry odpisovaného majetku. Obsahuje následující atributy:

¨ datum inicializace – toto datum je s dodávkou programu naplněno. Datum inicializace je společné pro komponentu odpisovaný majetek a komponentu Odpisy a opravné položky pohledávek.

¨ datum účetního odpisu – toto datum vyplňuje systém automaticky podle dat, která najde v událostech odpisovaného majetku

¨ rok daňového odpisu - toto datum vyplňuje systém automaticky podle dat, která najde v událostech odpisovaného majetku

¨ neomezovat datum události – implicitně by tento atribut měl zůstat nezaškrtnutý, protože tím je zajištěno automatické hlídání dvou předchozích parametrů (např. nelze pak zařadit nový majetek před tato data). Ale v případě počátečního nastavení systému (tzn. potřeba naplnění dat) je vhodné si tento atribut zaškrtnout. Po dokončení počátečního nastavení jej opět odškrtnout.

¨ odpis v měsíci zařazení/ odpis v měsíci vyřazení – tento parametr se týká pouze účetních odpisů, kde v každé firmě mají svoji vnitropodnikovou směrnici, která určuje, zda se účetně odepisuje majetek v měsíci zařazení nebo v měsíci vyřazení (případně oboje). Nastavení těchto parametrů je platné pro všechny karty odpisovaného majetku. V případě, že uživatel pak na konkrétní kartě potřebuje tento způsob účetního odpisování změnit, nastaví se toto na konkrétní kartě – záložka „účetní odpis“.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 12.01.2009


Pojem - Parametry operace komponenty

Tyto parametry má uživatel k dispozici v činnosti Druhy operací (menu Informační centrum – Typy a řady – Druhy operací) jako možnost pod menu Volby. Parametry se v současné době vstupují zatím pouze u druhů operací komponent obchod a platby.

Jedná se o:

¨ automatické nastavení „stavu“ událostí v operaci daného druhu v případě, že po dané operaci následuje operace ze stejné komponenty (obvyklé použití v kombinaci s dávkovou operací, kde se nerespektuje míra plnění) a zároveň se zde nastavuje i „stav“ událostí v případě, že následující operace po dané operaci změnila stav (tzn. byla zrušena, stornována).

¨ předběžné ukončení – operace s tímto atributem je ukončena předběžně. Do vlastností uzlu diagramu s touto operací (atribut ukončit operaci) se však tato hodnota nepředplní, tj. je nutné ji definovat duplicitně.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Parametry plateb

Činnost Parametry plateb slouží k nastavení parametrů pro komponentu PLATBY:

¨ implicitní doba splatnosti pohledávky - zadává se zde počet dnů, po které trvá splatnost pohledávky. Je použit pro výpočet data splatnosti, tzn. že při zadání data na události platby se automaticky dopočte datum splatnosti (při potřebě nastavení individuálního data splatnosti pro vybrané adresáty lze využít činnost „předkontace adresáta“). Tato doba splatnosti pohledávky se vztahuje k datu zápisu platby (tzn. datum splatnosti je tvořeno způsobem: datum zápisu platby + zde uvedená implicitní doba splatnosti pohledávky).

¨ vzhledem k datu platby – možnosti Ano/Ne (implicitně nastaveno Ne). Tuto možnost uživatel využije v případě, že implicitní dobu splatnosti pohledávky chce vztahovat k datu zdanitelného plnění (tzn. tj. shodné s datem platby). Pak se datum splatnosti pohledávky tvoří způsobem: datum platby + zde uvedená implicitní doba splatnosti pohledávky. I toto nastavení lze uplatnit individuálně pro vybrané adresáty, viz. nastavení předkontace adresáta.

¨ implicitní doba splatnosti závazku - v případě potřeby je možno nastavit počet dnů, po které trvá splatnost závazku. Pokud uživatel tento parametr nechce využívat, nechá nastaveno číslo nula. Stejně jako u pohledávky, i zde platí, že doba splatnosti závazku se vztahuje k datu zápisu platby (tzn. datum splatnosti je tvořeno způsobem: datum zápisu platby + zde uvedená implicitní doba splatnosti závazku).

¨ vzhledem k datu platby - možnosti Ano/Ne (implicitně nastaveno Ne). Tuto možnost uživatel využije v případě, že implicitní dobu splatnosti závazku chce vztahovat k datu zdanitelného plnění (tzn. tj. shodné s datem platby). Pak se datum splatnosti závazku tvoří způsobem: datum platby + zde uvedená implicitní doba splatnosti závazku.

¨ 1.část variabilního symbolu - možnost nastavit si první čtyři znaky variabilního symbolu pohledávek (mohou být tvořeny kombinací čísel a znaků R – rok a znaků U – identifikace datového úložiště). Pak zde v tomto atributu může být kombinace RU (rok, úložiště – vždy poslední znak z tohoto atributu, je-li rok 2007 a identifikace úložiště je 01, pak první část var.symbolu bude 71) nebo RUU, RRUU apod. Variabilní symbol v IS BM je tvořen 10 znaky. První čtyři znaky jsou určeny tímto parametrem, dalších 6 znaků je automaticky generováno z čísla procesu. Pokud zde má uživatel nastaveno tento parametr jako např. RU, bude jeho generovaný VS pouze osmimístný.

Důležité upozornění:

Druhy procesů, které tvoří pohledávky, musí mít číselnou řadu menší než jeden milion, tzn. tvořenu 6 místy. Pokud si uživatel vytvoří číselnou řadu delší, může vzniknout problém ve VS v letech. V případě, že vygenerovaný variabilní symbol z plateb (6 znaků) by obsahoval na prvních místech číslice nula, jsou nuly automaticky mazány.

¨ validace variabilního symbolu - je možno zvolit Ne, Ano, Ano stejného adresáta, Podle parametrů plateb. Ne způsobí, že se variabilní symbol přijatých faktur vůbec kontrolovat nebude. Ano znamená, že systém nahlásí, pokud najde platbu se stejným variabilním symbolem. Ano stejného adresáta znamená, že systém nahlásí, že našel platbu se shodným variabilním symbolem, pokud se zároveň budou shodovat adresáti plateb. Podle parametrů plateb znamená, kontrola se bude provádět podle nastavení ekvivalentního parametru operace komponenty plateb (druhy operací, v menu Volby Parametry operace komponenty). Tato volba umožňuje nastavit chování BM při zápisu události (závazku) operace daného druhu z hlediska kontroly duplicity variabilního symbolu.

¨ nevalidované variabilní symboly - zde se uvádí seznam variabilních symbolů (oddělených čárkou), pro které se nebude provádět validace. Může se jednat např. o var. symboly různých převodů na účet apod.

Tyto údaje se v činnosti Parametry plateb ukládají do tabulky BWMEMOR s celou řadou dalších proměnných.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.10.2012


Pojem - Parametry skladu zvířat

Parametry ovlivňující chování komponenty skladu zvířat, tj.:

¨ 1. zobrazovaná hodnota (u kategorie) - nastavený druh hodnoty a výše hodnoty uvedeného druhu se pak zobrazuje na kartě kategorie zvířat jako 1. zobrazovaná hodnota

¨ 2. zobrazovaná hodnota (u kategorie) - nastavený druh hodnoty a výše hodnoty uvedeného druhu se pak zobrazuje na kartě kategorie zvířat jako 2. zobrazovaná hodnota

¨ 3. zobrazovaná hodnota (u kategorie) - nastavený druh hodnoty a výše hodnoty uvedeného druhu se pak zobrazuje na kartě kategorie zvířat jako 3. zobrazovaná hodnota

¨ cena skladová - nastavení druhu hodnoty, který představuje cenu skladovou. Cenu skladovou u jednotlivých kategorií si pak systém automaticky dopočítává z událostí a obratů skladu zvířat a v operacích výdeje, kde je nastaveno, že výdej bude za cenu skladovou, se pak tato cena automaticky předplňuje.

¨ množství v RMJ pro výpočet ceny skladové - druh hodnoty, který udává množství zvířat v referenční měrné jednotce (slouží pro výpočet jednotkové ceny skladové)

¨ množství v MJ pro výpočet KD - druh hodnoty, který udává množství zvířat v referenční měrné jednotce (slouží pro výpočet počtu krmných dnů u kategorií, které mají zaškrtnutý příznak KD)

¨ cenová skupina pro výpočet vzrůst. přír. - identifikace cenové skupiny, která je určena pro výpočet vzrůstového přírůstku. Jestliže požadujeme u kategorie výpočet vzrůstového přírustku, musí mít tato kategorie záznam v ceníku (třebaže ceníková cena bude nulová).

¨ započítávat stavy do KD - zápočet krmných dnů se provádí na základě počátečních nebo konečných stavů. V případě nastavení „počátečních stavů“ se v daný den do krmných dnů nezapočítávají naskladněná zvířata, ale započítávají se pouze v ten den vyskladněná a do příjmových operací se do atributu pořadí automaticky předplňuje 1. V případě nastavení „konečných stavů“ se v daný den do krmných dnů nezapočítávají vyskladněná (prodaná) zvířata, ale započítávají se pouze v ten den naskladněná a do výdajových operací se do atributu pořadí automaticky předplňuje 99999.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.11.2007


Pojem - Parametry TPV

Činnost parametry TPV představuje jednotlivé definice parametrů, které zajišťují správné předplňování atributů v činnostech TPV. Definuje se:

¨ cenová skupina – identifikace cenové skupiny (s touto cenovou skupinou jsou v ceníku uložena ocenění artiklů vstupujících do výroby)

¨ šablona – definice šablony, která se používá při generování jednokrokových technologických postupů

¨ hodin výk. normy – počet hodin, za které se uvádí výkonová norma

¨ obvyklé množství – definice množství, které se pak předplňuje při zadávání vztahů artiklů u výstupního (pilotního) artiklu

¨ pracovní náklady zahrnují – volba mzdové/mzdové s odvody – rozlišení zda celkové náklady zahrnují mzdové či osobní náklady

¨ předplňovat KV pro ref. artikl – identifikace kalkulačního vzorce předplňovaná pro výstupy v kusovníku (tabulky vztahů artiklu)

¨ předplňovat KV pro vztaž. artikl – identifikace proměnné kalkulačního vzorce předplňovaná v kusovníku (tabulky vztahů artiklu)

¨ předplňovat KV pro pracovní výkon – identifikace proměnné kalkulačního vzorce předplňovaná pro pracovní výkony v kusovníku (tabulky vztahů artiklu)

¨ směrování referenčního artiklu – předplňované směrování referenčního artiklu (vstup/výstup)

¨ využívat varianty operací – volba Ano/Ne – parametr, který dovoluje založit více referenčních artiklů se stejnou technologickou operací

¨ předplňovat číslo varianty – volba Ano/Ne – pokud je parametr nastaven na Ano, pak se při pořizování nového referenčního artiklu se stejnou technologickou operací předplní varianta o jedna větší než má největší varianta s touto operací

¨ vstupy a výstupy – definice inicializačního druhu operace pro nové technologické operace (v tomto druhu operace se definují algoritmy pro plnění aktuálních či statistických hodnot z událostí vstupů a výstupů)

¨ předplňovat min. ve směně – hodnota, která inicializuje atribut „Min.“ ve směně (při generování výrobních úkolů)

¨ vytěžovat linky – volba Ano/Ne – při volbě Ano se respektuje obsazení času linky jinými zakázkami (tj. nedochází k překryvu výrobních úkolů v harmonogramu výroby)

¨ kopírovat vždy vztažené artikly – volba Ano/Ne – při kopírováním operace referenčního artiklu zároveň vždy kopírovat všechny vztažené artikly varianty

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.01.2008


Pojem - Parametry účetnictví

Parametry účetnictví musí mít uživatel vyplněné před vlastním zahájením práce s komponentou účetnictví. Jedná se o parametry:

¨ povolit účtování do budoucna – při zaškrtnutí tohoto příznaku je povoleno v událostech účetního deníku zadat datum do budoucna. Pokud příznak povolen není a uživatel v událostech zadá datum do budoucna, systém upozorňuje: „datum události musí být menší nebo rovno dnešnímu datu“ a taková událost nejde zapsat

¨ povolit na účetním dokladu záznamy jednoho měsíce – při zatržení tohoto příznaku je hlídáno, aby při zápisu událostí do účetního deníku byly data aktuálního dokladu ve stejném měsíci. Pokud jsou události zapisovány s daty různých měsíců, systém upozorňuje: „události v rámci aktuálního dokladu nemají shodné datum zápisu“ a doklad nejde zapsat.

Informace o funkci šablon a importu v účetnictví:

¨ šablona otevření účetních knih otevírá účty třídy 0 až 4. Je nutno vytvořit pouze jeden doklad, tzn. že bude existovat pouze jeden proces otevření těchto účtů v každém účetním období

¨ šablona uzavření účetních knih uzavírá účty třídy 0 až 4. Je nutno vytvořit pouze jeden doklad, tzn. že bude existovat pouze jeden proces uzavření těchto účtů v každém účetním období

¨ import otevření či uzavření podrozvahových účtů otevírá či uzavírá účty třídy 75 až 79. Je nutno vytvořit pouze jeden doklad, tzn. že bude existovat pouze jeden proces pro otevření či uzavření těchto účtů v každém účetním období

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 02.09.2008


Pojem - Parametry uživatele

Jedná se o činnost, která umožňuje každému uživateli nastavit si některé parametry podle jeho vlastních potřeb, tj. je součástí personifikace IS. Parametry lze nastavit nebo změnit v činnosti Systém - Parametry uživatele. Jedná se o tyto parametry:

¨ reakce na klávesu ESC při prohlížení - možnost nastavit si chování systému po stisku klávesy ESC v prohlížení jakékoliv činnosti. Pokud je nastaveno „zrušit prohlížení“, činnost se po stisku klávesy ESC automaticky ukončí, pokud je nastaveno „dotaz“, po stisku klávesy ESC se systém dotazuje „Ukončit prohlížení?Ano/Ne“, pokud je nastaveno „žádná reakce“, tak systém po stisku klávesy ESC nereaguje a činnost je nutno ukončit jiným způsobem (např. ikonou křížek).

¨ ukončovat textové pole psaním za poslední znak - při zatržení této možnosti kurzor po naplnění textového pole (např. zapsání 40-ti možných znaků v položce popis) automaticky přeskočí na další položku ve formuláři

¨ zobrazovat úplné století v datumových údajích - datum se potom zobrazuje ve tvaru DD.MM.RRRR, pokud by toto nebylo zatrženo, je rok zobrazen pouze dvěmi koncovými znaky (DD.MM.RR).

¨ zobrazovat grafický stavový řádek - při zatržení se uživateli zobrazuje řádek v dolním okraji okna, kde má např. možnost si přečíst message k dané položce.

¨ zobrazovat čas na stavovém řádku - na tomto stavovém řádku je pak v pravém dolním rohu okna k dispozici i čas.

¨ povolena změna pozice panelu nástrojů - pokud je tato možnost zatržena, je možno panel nástrojů přesouvat po okně, jinak zůstává standardně umístěn pod horní lištou okna.

¨ povoleno ukončení programu klávesou Alt + F4 - při zatržení je možno ukončit program, resp. hlavní menu, i po stisku klávesy Alt F4, jinak se program standardně ukončuje ikonou „křížek“.

¨ zobrazovat nabídku aktivních oken - uživateli se při zatržení této možnosti zobrazuje nabídka aktivních oken, což je seznam všech aktivně spuštěných činností.

¨ ikony – při zaškrtnutí této možnosti je pak nabídka aktivních oken zobrazována jako tlačítka s ikonami a při příštím spuštění programu se ukotví v dolní části obrazovky. Tuto možnost uživatel využije asi zejména, pokud si mřížku formuláře roztahuje do šířky a lišta s nabídkou aktivních oken mu pak zbytečně zabírá místo v pravé části obrazovky.

¨ stránka výběru po spuštění č. „Procesy“, „Operace“ - při zatržení této možnosti uživateli po aktivaci těchto dvou činností nejprve nabíhá záložka Výběr, kde si definuje, které údaje chce mít v okně k dispozici. V případě, že tato možnost zatržena není, aktivují se tyto činnosti podle posledního nastaveného výběru a to může být někdy i značně zdlouhavé. Zdlouhavému výběru je možno předejít tak, že uživatel si do výběru zadá napevno (možnost uchovat) č. nějakého procesu, tudíž po aktivaci činnosti procesy nebo operace se zobrazí tento proces, uživatel si sám přepne záložku výběr a vybere si data, která potřebuje.

¨ uchovávat pozice oken – možnost nastavení zaznamenání pozice oken formulářů pro jednotlivé uživatele systému. Jedná se o překryvný seznam s možnostmi:

- Nikdy

- Ne

- Ano – automaticky vždy při uzavření okna

- Ano – při nastavení parametrů formuláře

¨ uchovávání pozice okna ve vztahu k rozlišení obrazovky – při uchovávání pozice okna formuláře je možno zaznamenávat i aktuální rozlišení monitoru uživatele. Možnosti nastavení jsou:

- přepočítávat pozice poměrem aktuálního rozlišení obrazovky – uživatel si uchová pozici okna formuláře (na svém PC) a při spuštění daného formuláře na jiném PC (tzn. s jiným rozlišením monitoru) systém automaticky přepočítává:

- umístění levého horní rohu okna v pixelech v ose X = [uložená pozice] * [uložené rozlišení v ose X] / [aktuální rozlišení v ose X]

- výška okna v pixelech = [uložená výška] * [uložené rozlišení v ose X] / [aktuální rozlišení v ose X]

- umístění levého horní rohu okna v pixelech v ose Y = [uložená pozice] * [uložené rozlišení v ose Y] / [aktuální rozlišení v ose Y]

- šířka okna v pixelech = [uložená šířka] * [uložené rozlišení v ose Y] / [aktuální rozlišení v ose Y]

- zvlášť pro různá rozlišení obrazovky

¨ koeficient zobrazení - možnost zvětšit si nebo zmenšit si velikost formulářů (včetně velikosti písma atributů) podle vlastních potřeb. Standardně je nastaven koeficient 1, pokud se zadá např. 0,8, velikost formuláře na obrazovce se zmenší, pokud se zadá např. 1,2, velikost se naopak o něco zvětší.

¨ mřížka – nastavený koeficient mění na událostech velikost písma v mřížce. Nastavený koeficient u mřížky funguje pouze za předpokladu, že koeficient zobrazení je různý od hodnoty 1.

¨ MDI formuláře – implicitní nastavení vlastností formulářů (MDI=vícedokladové rozhraní)

¨ zvýraznění řádku v mřížce – možnost nastavit si barevné zobrazení aktuální řádky v mřížkách formulářů. Možnosti způsobu zobrazení jsou:

- Ne – aktuální řádek v mřížkách nebude barevně zvýrazňován

- Ano – varianta 1 – aktuální řádek v mřížkách bude barevně zvýrazňován – při vstupu do buňky mřížky bude buňka vybarvena B/W (černé písmo na bílém podkladu) – při pohybu v mřížce pomocí klávesnice bude obsah buňky zčásti vybarven W/B (bílé písmo na modrém podkladu) – označení pro funkčnost klávesy Ctrl + C

- Ano – varianta 2 – aktuální řádek v mřížkách bude barevně zvýrazňován – při vstupu do buňky mřížky bude buňka vybarvena barvou zvýraznění – při pohybu v mřížce pomocí klávesnice bude obsah buňky zčásti vybarven W/B (bílé písmo na modrém podkladu) – označení pro funkčnost klávesy Ctrl + C

- Ano – varianta 3 - aktuální řádek v mřížkách bude barevně zvýrazňován – při vstupu do buňky mřížky bude buňka vybarvena barvou zvýraznění - při pohybu v mřížce pomocí klávesnice nebude obsah buňky automaticky označován pro funkčnost klávesy Ctrl + C

- (poznámka – možnost nastavení barevného zobrazování aktuální řádky v mřížkách formulářů je funkční pouze ve verzích BM pod Visual Foxpro verze 8.0 nebo vyšší).

¨ barva písma zvýraznění – barva zvýraznění písma v aktuálním řádku v mřížce

¨ barva pozadí zvýraznění – barva zvýraznění pozadí v aktuálním řádku v mřížce

¨ výstupy procesů - nejedná se o výstupy procesů jako takové, přesnější termín je nastavení způsobu tisku zvolených nebo předdefinovaných předloh výstupu nebo dokladů a toto nastavení se uplatní pouze tehdy, pokud je u dané předlohy výstupu na záložce „popis“ v atributu „výstupy procesů“ vybrána možnost „podle parametrů uživatele“. Možnosti tisku tedy jsou:

- rozhodnout - uživatel má možnost si zvolit, jestli chce tisknout na tiskárnu, do souboru nebo pouze předlohu prohlížet v okně

- prohlížet - předloha se automaticky zobrazí pouze k prohlížení v okně

- tisknout se zastavením - uživatel má v tomto případě k dispozici možnost zvolit si tiskárnu a počet kopií dané předlohy

- tisknout bez zastavení - daná předloha výstupu nebo doklad se automaticky tiskne bez zásahu uživatele

¨ E-mail - do této položky se zapíše e-mail uživatele, který se pak automaticky zobrazuje při posílání dokumentů nebo tiskových sestav pomocí elektronické pošty.

¨ aktuální datum uživatele - zapsáním data zde je možno krátkodobě změnit aktuální systémové datum, tzn. pokud uživatel potřebuje zadat např. větší množství událostí zpět k nějakému datu, změní si zde aktuální datum a systém bere jako aktuální datum toto datum zde nastavené. Pouze v případě storna nebere systém toto aktuální datum v potaz.

¨ zobrazování ikon seznamů hodnot – možnost určit si variantu zobrazování „ikony seznamu hodnot“ na výběrových záložkách jednotlivých formulářů při nastavení atributu „ikona – vlevo vedle atributu“. Možnosti jsou:

- varianta 1 – zobrazuje se čtvereček □ vlevo před atributem (při výběru více hodnot u atributu je to zaškrtnutý □)

- varianta 2 - zobrazuje se žlutý čtvereček □ vlevo před atributem (při výběru více hodnot u atributu je to zaškrtnutý žlutý □)

- varianta 3 - zobrazuje se malý čtvereček ▪ vlevo před atributem (při výběru více hodnot u atributu je to zaškrtnutý malý žlutý ▪ )

- varianta 4 - zobrazuje se malý čtvereček ▪ vlevo před atributem (při výběru více hodnot u atributu je to zaškrtnutý □)

- varianta 5 - zobrazuje se malý žlutý čtvereček ▪ vlevo před atributem (při výběru více hodnot u atributu je to zaškrtnutý žlutý □)

- varianta 6 - zobrazuje se malý čtvereček ▪ v pravém horním rohu atributu (při výběru více hodnot u atributu je to zaškrtnutý □ v pravém horním rohu)

- varianta 7 - zobrazuje se malý čtvereček ▪ v pravém horním rohu atributu (při výběru více hodnot u atributu je to zaškrtnutý □ v pravém horním rohu) + malý žlutý čtvereček ▪ před atributem typu překryvný seznam (po výběru více hodnot je to zaškrtnutý žlutý □)

- varianta 8 - zobrazuje se malý čtvereček ▪ v pravém horním rohu atributu (při výběru více hodnot u atributu je to zaškrtnutý □ v pravém horním rohu) + malý čtvereček ▪ před atributem typu překryvný seznam (po výběru více hodnot je to zaškrtnutý □)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 09.12.2010


Pojem - Parametry výkazů

Parametry užívané ve výkazech jsou uživatelem definované parametry, které se užívají v definici výkazu, resp. listu pro její usnadnění nebo s cílem zajištění určité variability obsahu výkazu dle požadavků uživatele při sestavení výkazu. Mohou být užívány jako skutečné parametry funkcí výkazu.

Parametr je některého z těchto typů: Numeric, Charakter, Date nebo Seznam hodnot.

Každý parametr vystupuje pod svým identifikátorem. Nabytí hodnoty parametru je

definováno některým ze způsobů uvedených v posloupnosti, jak nabývají hodnoty při sestavení výkazu:

¨ přiřazením v definici vzoru listu

¨ přiřazením v atributu parametry buňky, řádku nebo sloupce definice listu

¨ aplikací výrazu vzoru s definovanými parametry v definici listu pomocí vzoru

¨ přiřazením v atributu parametry definice listu v definici výkazu

¨ přiřazením v atributu parametry definice listu

¨ přiřazením v INI parametrech definice listu v definici výkazu

¨ proměnnou dotazu

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.08.2007


Pojem - Parcelní číslo

Číslo pozemku, pod kterým je pozemek veden v katastru nemovitostí.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.02.2008


Pojem - PDA zařízení

PDA (personal digital assistant - osobní digitální pomocník) či palmtop je malý kapesní počítač. Ten bývá ovládaný obvykle dotykovou obrazovkou a perem (které se nazývá stylus). Původně měly PDA za cíl především pomoci s organizováním času a kontaktů. Současné PDA jsou velmi výkonné a zvládají i přehrávání videa a velké množství dalších aplikací. Často se používají pro čtení ebooků.

Mezi nejčastěji používané operační systémy na PDA patří Windows Mobile, PalmOS a Symbian OS.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 07.07.2008


Pojem - PDF formát

U předloh výstupu typu „sestava“ lze použít při tisku formát PDF (po spuštění výstupu volba „do souboru“) nebo je možno ho použít jako přílohu e-mailu ve formátu PDF (zde je nastavení variabilní). Portable Document Format je univerzální formát dokumentů pro jejich bezproblémový přenos do různých operačních systémů bez závislosti na programovém vybavení. Jakýkoliv dokument lze přenést z libovolné aplikace při zachování přesného vzhledu a obsahu originálu. Lze je tisknout, posílat e-mailem, sdílet a ukládat na internetu nebo intranetu a zapisovat na CD.

Pro definici PDF formátu musí IS BM obsahovat:

¨ knihovnu SYSPDF (knihovna s funkcemi pro výstup tiskové předlohy typu Sestava do souboru ve formátu PDF – podrobný popis této knihovny je uveden v její poznámce) a knihovnu DEFPDF (knihovna určená pro uvedení v parametru BM Printing->Default_skript_po_SQL, která způsobí to, že tisk předlohami výstupu typu Sestava do souboru vytvoří PDF dokument a následně ho zobrazí v Acrobat Readeru. Pro svou funkci používá knihovnu SYSPDF)

¨ nastavení programu - v parametru programu BM 'Printing->Default_skript_po_SQL' je možné zadat identifikaci knihovny vkládaného kódu, jejíž kód má být prováděn pro všechny předlohy výstupu, které nemají vyplněnou vlastnost 'Skript po SQL dotazu'

- na záložce Deklarace vlastnost předlohy 'Skript po SQL dotazu'

¨ profil spuštění předloh - vytváření PDF dokumentu může být ovlivněno parametry uvedenými v proměnné _PARAMETR_PROFILU

Nastavení tisku ve formátu PDF není triviální záležitost, proto by ji méně zkušený uživatel měl definovat v součinnosti se svým implementátorem.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 24.10.2008


Pojem - Penalizace

Penalizace (z latinského poena – trest) ve svém původním významu znamená uložení peněžního trestu, vyměření pokuty apod.

Penále je sankce za zpožděnou platbu, nedodržení data splatnosti.

Nejčastěji se uplatňuje v případě opožděné platby daně. V případě nedodržení splatnosti se penále automaticky vypočítává jako příslušenství daně. Penále se vypočítává za každý den následující po data splatnosti až do dne platby. V případě nedodržení splatnosti penále se už další penále nevyměřuje (penále z penále).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.01.2013


Pojem - Penzijní připojištění

Penzijní připojištění se státním příspěvkem představuje v současné době jeden z finančních produktů, který zaměstnavatelé přednostně využívají při zavádění nebo doplňování motivačních firemních programů pro své zaměstnance. Zaměstnavatel může poukazovat příspěvek buď fixní částkou nebo procentem ze mzdy. Výše příspěvku není nijak omezena. Samozřejmě také platí určitá pravidla, která zaměstnavatele mimo jiné motivují k zavedení tohoto benefitu pro zaměstnance. Příspěvek zaměstnavatele na účet zaměstnance lze zahrnout do nákladů zaměstnavatele až do výše 3 % vyměřovacího základu pro pojistné na sociální a zdravotní zabezpečení zaměstnance a dále z příspěvků zaměstnavatel neplatí pojistné na zdravotní a sociální zabezpečení pokud tento příspěvek nepřekročí 5 % vyměřovacího základu pro pojistné na sociální a zdravotní zabezpečení. Pro zaměstnance má zaměstnavatelský příspěvek tu výhodu, že je do výše 5 % vyměřovacího základu pro pojistné na sociální a zdravotní zabezpečení osvobozen od daně z příjmů.

Pravidla pro používání penzijního a životního připojištění ve mzdách v IS BM:

¨ v činnosti Legislativní konstanty nastavit konstantu mz27penzli – Limit penzijního a životního pojištění – hodnota je 24.000,-

¨ v menu Definice – Položky mezd – Srážky je nutno zaškrtnout atribut „započítávat do limitu penzijního a životního pojištění“ u mzdové položky „Odvod pojištění firma“ (je vhodnější, pokud tuto definici srážek provede zkušený implementátor)

¨ je nutno přestat používat srážku typu „penzij. poj. s daňovým limitem“ (Karta pracovníka – záložka Srážky) – její platnost je do 31.12.2007

Systém následně automaticky provádí:

¨ nápočet limitovaného příspěvku (Karta pracovníka – menu Volby – činnost Další informace karty – atribut mz01pznapo)

¨ výpočet nahlásí případné překročení limitu (jeho hodnota je nastavena v legislativních konstantách) a je o tom vytvořen záznam v protokolu

¨ uzávěrka mezd nakopíruje stav nápočtu limitovaného příspěvku do Historie karty a aktualizuje Nápočet na kartě (Další informace karty). Aktualizace nápočtu proběhne tak, jak je částka zadána, tj. nikoliv v absolutní hodnotě

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 31.01.2008


Pojem - Personalistika

Neexistuje obecné použití této komponenty. Její využití je zcela závislé na potřebách organizace a na základě této analýzy nastaví její používání implementátor (např. je možné nastavit hodnoty požadavku na typová a skutečná pracovní místa, že obchodník má dostat každý druhý rok mobilní telefon, že má každý měsíc nárok na GO kupon, že 1x ročně musí projít školením apod.). Poté musí implementátor vytvořit příslušný druh procesu na evidování těchto nároků a potřeb (zároveň s tím i šablonu na vkládání těchto požadavků).

Komponenta personalistika nabízí tyto činnosti:

¨ událost personalistiky

¨ artikly personalistiky

¨ pracovní místa skutečná a typová

¨ hodnoty požadavku/vlastnost

¨ druhy požadavků a vlastností

¨ přehled volných údajů pracovníků

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 11.10.2007


Pojem - Personifikace

Každý přihlášený uživatel má možnost si přizpůsobit některé funkce IS dle svých požadavků formou určité personifikace IS, tj. nastavením svých:

¨ parametrů uživatele týkajících se celého IS (reakce na ESC, zobrazení volitelných informačních a ovládacích prvků, …),

¨ parametrů formuláře týkajících se daného okna (třídění, uspořádání mřížky, …),

¨ osobních masek pro automatizaci vstupu dat v událostech,

¨ menu,

¨ jazyk,

¨ strukturu objektů (ikon), které se zobrazují v panelu se signalizací vazeb objektů.

Významné aktualizace dat, tj. zejména vstup události, zahájení a ukončení operací, vstup a oprava dokumentu apod., jsou v IS autorizovány. Tedy je u těchto záznamů uvedeno, který uživatel a kdy danou aktualizaci provedl.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.08.2004


Pojem - Podvojnost

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 09.10.2013


Pojem - Pohled (slovníku dat)

Pohled je množina definic elementární položky slovníku dat, která umožňuje uživateli:

¨ získat uživatelem data (prohlížení, výstup) daná uvedenou množinou definic nezávisle na funkcích IS připravených poskytovatelem, k tomu uživatel definuje základní definice pohledu:

¨ datový submodel (prostředí pohledu), kterým definuje strukturu požadovaných dat,

¨ výběr, tj. podmínky (filtry), které musí požadovaná data splňovat, jeden výběr může obsahovat několik elementárních podmínek, jeden pohled může mít k dispozici několik výběrů,

¨ předlohu výstupu, tj. formu, jak se vybraná data dané struktury mají prezentovat, jeden pohled může mít k dispozici několik předloh výstupu,

¨ využít pohledu k definici položky web menu, přičemž pohled pak může kromě základní definice obsahovat definici:

¨ doplněných oken [1] (související pohledy), která lze vyvolat z web browseru klikem na první atribut nebo na atribut uvedený ve vlastnostech pohledu (Napojení ULR na atribut),

¨ ULR odkazů v tabulkách uvedených ve vlastnostech pohledu, ULR odkazy umožňují k libovolnému[2] atributu prezentovanému ve web browseru přiřadit vyvolání zde uvedeného souvisejícího atributu.

[1] Definují se v rámci prostředí pohledu.

[2] Mimo toho atributu, na který jsou napojeny doplněná okna

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Pohledávka

Pohledávka je právo věřitele požadovat určité plnění na dlužníkovi ze závazkového vztahu, např. kupní smlouvy. Splatnost pohledávky určuje většinou smlouva. Není-li pohledávka uhrazena ve lhůtě splatnosti, dostává se dlužník do prodlení.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.02.2008


Pojem - Pohyblivé složky mzdy

Zavádění a uplatňování pohyblivých složek mezd je zcela v pravomoci podniku. Jedná se zejména o: prémie, odměny, osobní ohodnocení, příplatky ke mzdě a podíly na hospodářském výsledku.

¨ prémie -
mohou se vyplácet v časové i úkolové mzdě, vyplácejí se za splnění předem stanovených úkolů, které jsou uvedeny v prémiových řádech. Jsou stanoveny procentem.

¨ odměny -
vyplácejí se za splnění mimořádných úkolů. Stanoví se pevnou částkou.

¨ osobní ohodnocení -
přihlíží se k dlouhodobým pracovním výsledkům. Výše osobního ohodnocení se stanovuje na delší dobu. Vyplácí se každý měsíc pevnou částkou. Týká se administrativních pracovníků.

¨ příplatky ke mzdě -
nejsou ze zákona povinné. Mohou být např. za vedení určitého počtu lidí, za práci na směnách.

¨ podíly na hospodářských výsledcích -
může podnik vyplácet, pokud dosahuje zisku.

Příplatky ze zákona povinné:
a) za práci přesčas, pokud zaměstnanec nečerpá náhradní volno
b) za práci ve svátek
c) za práce ve ztíženém a zdraví škodlivém prostředí
d) za práci v noci

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 29.02.2008


Pojem - Položka výstupu dle předlohy

Jedná se o jednotlivé atributy, které se uživateli nabízejí v okně činnosti „výběr položek zahrnutých do nové předlohy“ při definování položek nové předlohy výstupu. Pomocí šipek uživatel tyto atributy přesouvá do pravé části okna výběru položek výstupu a tím je zařazuje do právě vytvářené předlohy výstupu, kde je pak dále upravuje (tzn. definuje jejich uspořádání).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Pomocné slučování

Jedná se o nástroj, který umožňuje z více operací (zdrojových uzlů) sloučit data do jedné operace (cílového uzlu) pomocí transformace. Definuje se v agregačním výrazu pravidla transformace tímto výrazem ‘[##]’.

Při použití nastane:

¨ v první cílové události se budou agregovat numerické hodnoty ze zdrojových uzlů, někdy je nutné v pravidle pro některé atributy definovat výraz, který vždy vrací nulu, aby se nesčítali jablka a hrušky například díky implicitní definici v pravidle transformace,

¨ znakové atributy (C - charakter) první cílové události budou naplněny dle události, ze které vede vazba s pomocným slučováním, pokud nebudou potlačeny, tj. definice výrazu s prázdným řetězcem

¨ v cílové operaci se pomocným slučováním aktualizuje vždy pouze první událost (omezuje praktické použití), čemuž je případně nutné přizpůsobit pořadí vazeb a pravidel transformací

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Popis archivací

Tato činnost se nachází v hlavním menu v činnosti Informační centrum – Utility – Archivace – Popis archivací. Umožňuje uživateli vytvořit si jednotlivé definice archivací, kde si uživatel určí která data chce archivovat a jak často a kdy je chce archivovat. Archivují se především soubory template a banky (certifikáty apod.) a programy, které vyžadují externí uložení (např. soubory jiných systémů) nebo externě ukládané dokumenty.

Po aktivaci této činnosti se uživateli zobrazí aktivní záložka „Skupiny archivace“, kde jsou k dispozici již současné nadefinované archivace. Při prohlížení stávající archivace či při zakládání nové definice má uživatel k dispozici následující atributy:

¨ skupina – identifikace a název skupiny

¨ počítač – definice počítače, na kterém lze danou skupinu archivace aktivovat. V případě uvedení „pomlčky“ ji lze aktivovat z každého počítače, soubory archivace se vyskytují na síti a jsou dostupné všem. V případě lokálních souborů určených k archivaci je nutno určit počítač, ze kterého se bude daná archivace aktivovat, tzn. nelze ji pak aktivovat na jiném počítači.

¨ druh – jedná se o druh dokumentu. Druh dokumentu rovněž určuje přístupová práva k archivaci, tzn. archivaci smí aktivovat pouze ten, kdo má k danému druhu dokumentu právo zápis. Uživatel, který k danému druhu dokumentu nemá ani právo čtení, nevidí danou archivaci ani v prohlížení archivu.

¨ téma – téma vývěsky, pod kterým bude zapisován protokol o archivaci. Atributy téma, typ a text přímo souvisí s vývěskou, kam se zapisuje vytvořený protokol o archivaci. Výhodou tohoto zápisu na vývěsku je, že pak v datech lze pohodlně zjistit, kdy která archivace proběhla, což se hodí zejména pro případy, kdy se daná archivace spouští programově, tzn. že je nastaveno automatické spouštění archivace např. po 15 dnech. Podle údajů na vývěsce pak program dokáže analyzovat uplynulých 15 dní a automaticky spustí další naplánovanou archivaci.

¨ typ – typ události vývěsky, na kterou bude zapisován protokol o archivaci

¨ text – text události vývěsky

¨ adresář-A – adresář archivu, do kterého se ukládají archivní soubory (nepovinný údaj)

¨ adresář-* - kořenový adresář archivu. Jeho definice přímo souvisí s atributem adresář na záložce „Adresáře“. Uvedený adresář v tomto atributu následně nahrazuje * právě v atributu adresář, tzn. aby uživatel vždy nemusel vypisovat celou dlouhou cestu adresáře na každém atributu, zde uvede hlavní adresář a na záložce „Adresáře“ v atributu adresář je tento adresář nahrazen právě znakem *. Např. zde může být uveden adresář \\server\disk_k a na záložce „Adresáře“ v atributu adresář je potom uvedeno „*\bmsql\template“.

¨ aktivní – výběr z překryvného seznamu Ano/Ne – v případě potřeby vyřazení skupiny z archivace není nutno definici archivace rušit (i pro případ opětovné potřeby archivování), stačí pouze volbou Ne vyřadit z archivace

¨ nabízet – výběr z překryvného seznamu Ano/Ne – volba Ano znamená, že se daná definice archivace bude nabízet ke spuštění v hlavním menu (Inf. centrum – Utility – Archivace – Spuštění archivace) a pod menu Volby (připomenutí - pro uživatele je samozřejmě v nabídce ke spuštění v případě, že je nadefinovaná s druhem dokumentu, na který má uživatel právo zápisu)

¨ počet kopií – udává počet aktuálních kopií, který se má v přehledu archivu udržovat, tzn. je-li zde uvedeno např. 5 – v archivu se pak u dané archivace udržuje jedna hlavní archivace a 5 kopií (vždy 5 nejnovějších podle data, starší kopie se automaticky ruší). Vytváří se tzv. rozdílová archivace, tzn. že se archivují ta data, kde nastala změna. Pokud je zde v počtu kopií uvedeno číslo mínus jedna znamená to, že počet kopií je neomezen, neruší se žádná archivace

¨ poznámka – vlastní poznámka uživatele k definici archivace

Na druhé záložce „Adresáře“ se definuje, které adresáře se na uvedeném počítači mají archivovat. U každého adresáře jsou k dispozici tyto atributy:

¨ adresář – vlastní popis adresáře (tzn. včetně jeho přesné cesty). V případě síťových souborů může být část přesné cesty nahrazena znakem * (viz. atribut adresář-* na předchozí záložce). U popisu souboru je možno použít obrácené lomítko, což způsobí, že se pak v přehledu archivace ve stromu zobrazuje jako jeden adresář.

¨ popis ve stromu – popis, který se zobrazuje v přehledu archivace za atributem datum (popis není povinný údaj, lze ho doplnit i zpětně). Pokud se popis v tomto atributu zadá později, ve stromu se u daného adresáře projeví až po provedení další archivace.

¨ včetně podadresářů – možnosti Ano/ne – zda se mají archivovat i podadresáře daného souboru

¨ aktivní – možnosti Ano/Ne – volba Ano je jasná, volbu Ne uživatel použije v případě, že chce daný adresář vyloučit z archivace (a nechce ho rušit pro případ, že by ho časem opět do archivace chtěl zařadit).

¨ archivovat soubory – seznam souborů, které chce uživatel z daného adresáře archivovat uvedených v syntaxi *.název přípony souboru – oddělených čárkou (např. *dbf,*.fpt)

¨ nearchivovat soubory – stejný způsob zápisu jako u předchozího atributu s tím, že zde uživatel zadává pouze soubory, které nechce archivovat

¨ poznámka – vlastní komentář uživatele

Poslední záložkou této činnosti je záložka „Podskupiny“, která umožňuje uživateli do jedné velké skupiny sloučit několik malých.

Archivaci lze spustit z menu Volby (klávesa F9 – Spuštění archivu) a nebo z činnosti Utility – Archivace – Spuštění archivace. Po její aktivaci se uživateli zobrazí okno s nabídkou „Archivovat?“ – Ano/Ne a zároveň je u dotazu i informace o počtu archivovaných adresářů, počtu souborů a o celkové velikosti souborů.

Jednotlivé archivace lze spouštět programově a lze nastavit interval, po které době se mají automaticky provádět. Toto se provádí pomocí externího příkazu, který lze vyvolat voláním programu UTARCHIV s parametry:

1. identifikace skupiny archivu – povinný parametr

2. perioda – po kolika dnech se má archiv provádět (pokud na vývěsce existuje záznam mladší, archiv se provádět nebude) – nepovinný parametr

3. identifikace tématu vývěsky – nepovinný parametr – pokud je zde uveden, změní téma vývěsky uvedené v definici archivace

4. typ události - pokud je zde uvedeno, změní typ události uvedený v definici archivace

5. text – pokud je zde uveden, změní text uvedený u skupiny v definici archivace

6. doplnění adresáře archivu

7. počet kopií – pomocí předchozího a tohoto parametru lze nastavit automatickou dlouhodobou archivaci (pro potřeby archivace v letech, aby byl vidět průřez programem)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.10.2009


Pojem - Popis jazyka generátoru sestav

Popis jazyka generátoru sestav

Společné příkazy

Příkaz

Syntaxe

Popis

.KOMENTÁŘ

.KOMENTÁŘ

Popisný řádek

.DOKUD

.DOKUD [<seznam atributů>]

Cyklus se změnou pozice záznamu zpracovávaných dat.

Probíhá seznam příkazů až do nejbližšího příkazu ".KONEC" do té doby, dokud se nezmění alespoň jeden z atributů zadaných v seznamu.

.KONEC

.KONEC

Uzavírá seznam příkazů předcházejícího příkazu ".DOKUD".

.PŘIŘAĎ

.PŘIŘAĎ <proměnná>=<výraz>

Přiřazuje hodnotu proměnné, kterou zároveň tímto definuje.

Př.: .PŘIŘAĎ $(cislo)= $(cislo)+1

.KDYŽ

.KDYŽ <logický výraz>

Podmínka provedení následujících příkazů až do nejbližšího příkazu ".JINAK" nebo ".KONEC_KDYŽ".

Př.:

.KDYŽ $(x)=5

.PŘIŘAĎ $(cislo)= 1

.JINAK

.PŘIŘAĎ $(cislo)= 2

.KONEC_KDYŽ

.JINAK

.JINAK

Doplňuje příkaz ".KDYŽ", seznam následujících příkazů až do nejbližšího příkazu ".KONEC_KDYŽ" bude proveden při neplatnosti podmínky příkazu ".KDYŽ".

.KONEC_KDYŽ

.KONEC_KDYŽ

Ukončuje seznam prováděných příkazů za podmínky ".KDYŽ" (resp. ".JINAK")

.CYKLUS

.CYKLUS <logický výraz>

Seznam následujících příkazů až do nejbližšího příkazu ".KONEC_CYKLUS" bude prováděn do té doby, dokud platí podmínka uvedená v tomto příkazu.

Př.:

.PŘIŘAĎ $(i)=1

.CYKLUS $(i)<=10

Text $(i)

.PŘIŘAĎ $(i)= $(i)+1

.KONEC_CYKLUS

.KONEC_CYKLUS

.KONEC_CYKLUS

Ukončuje seznam prováděných příkazů v cyklu ".CYKLUS"

.DEKLARACE

.DEKLARACE <p>,<t>[,<l>[,<d>]],<v>

Deklarace proměnné, která mění svůj obsah při pohybu v datech (zejména pro použití v příkazu ".DOKUD").

<p> je název proměnné,

<t> je typ hodnoty proměnné (C,D,T,N,M)

<l> je délka hodnoty proměnné (pro typy C a N)

<d> je počet des.míst hodnoty proměnné (pro typ N)

<v> je výraz proměnné

Př.:

.DEKLARACE $(datum),D,SQL_TISK.datum

.DEKLARACE $(cislo),N,20,4,SQL_TISK.cislo

.DEKLARACE $(text),C,40,SQL_TISK.text

.CALL

.CALL <činnost>, <předloha>,<filtr>,<p1>,<p2>,<p3>

Vyvolá v průběhu výstupu jinou tiskovou předlohu.

Identifikaci předlohy a činnosti je možné zjistit ve vlastnostech předlohy na poslední záložce atribut ID:.

Např. pro identifikaci předlohy OB0101_W123456789, uvádí se příkaz .CALL ‘OB0101‘,‘W123456789‘,…..

Parametrem ‚filtr‘ může být výraz, který složí podmínku dotazu v textové formě jazyka SQL.

Parametry ‘p1‘,‘p2‘,‘p3‘ jsou volné parametry, které jsou k dispozici autorovi volané předlohy v syntaxi this.param1, this.param2 a this.param3. Jejich nejčastější využití je pro přenos názvu výstupního souboru nebo názvu výstupní záložky listu.

.SCRIPT

.SCRIPT

v předloze výstupu typu Excel a HTML je možné definovat skript v jazyce FOXPRO.

Skript musí být uveden příkazem ".SCRIPT" a ukončen příkazem ".ENDSCRIPT". Musí být uveden vždy na začátku řádku (na začátku řádku nesmí být žádný příkaz TAB apod., pak je funkčnost narušena).

V okamžiku běhu skriptu je v proměnné _THIS odkaz na objekt řídící výstup předlohou.

Kód skriptu musí vracet logickou hodnotu.

V případě, že vrátí logickou hodnotu FALSE, zpracování výstupu ukončeno bude přerušeno.

.ENDSCRIPT

.ENDSCRIPT

Viz. SCRIPT

Metoda load_my_adress

this.load_my_adress

Metodu je možné vyvolávat ve skriptu předlohy výstupu.

Potom jsou pro výstup dostupné v objektu ADM1.AD atributy odpovídající vlastní adrese nastavené v adresáři:

ADM1.AD.ad01id, ADM1.AD.ad01adsat,

ADM1.AD.ad01unodpo, ADM1.AD.ad01adsat2, ADM1.AD.ad01ico, ADM1.AD.ad01dico,ADM1.AD.ad01koment,ADM1.AD.sp10idzak, ADM1.AD.ad01klic,

ADM1.AD.ad01rc, ADM1.AD.ad01ksymb,

ADM1.AD.ad01pladph, ADM1.AD.ad01zakljm, ADM1.AD.ad01spolec, ADM1.AD.ad01volne1, ADM1.AD.ad01volne2, ADM1.AD.ad01volne3, ADM1.AD.ad02cisads, ADM1.AD.ad58id,

ADM1.AD.ad13nsc, ADM1.AD.ad11jmeno,

ADM1.AD.ad11cislo, ADM1.AD.ad11fax,

ADM1.AD.ad11mobil, ADM1.AD.ad11email, ADM1.AD.ad11cisost, ADM1.AD.ad11pozn,

ADM1.AD.ad02ulice, ADM1.AD.ad13psc,

ADM1.AD.ad02mesto, ADM1.AD.ad05stat,

ADM1.AD.ad05nazeva, ADM1.AD.ad58naztyp, ADM1.AD.bw01jmeno, ADM1.AD.sp10text,

ADM1.AD.ad02ulice3, ADM1.AD.ad13psc3,

ADM1.AD.ad02mesto3, ADM1.AD.ad05id3,

ADM1.AD.ad05stat3

Vlastnost předlohy výstupu SKRIPT

Vlastnost předlohy výstupu SKRIPT se definuje na záložce "Deklarace" a je v ní možné definovat kód v jazyce Foxpro, který má bude prováděn před provedením dotazu SQL.

V okamžiku běhu skriptu je v proměnné _THIS odkaz na objekt řídící výstup předlohou výstupu.

Např.:

LOCAL _o

* přidání vlastnosti TEMP_DATUM1 do objektu _THIS inicializovanou aktuálním datem

_this.addproperty('temp_datum1',date())

* třída BM_CODE_SYSDIA definuje objekt pro dialog

_o=CREATEOBJECT('bm_code_sysdia')

* inicializace objektu třídy BM_CODE_SYSDIA

_o.start(_this,'Datum')

* bude vstup do vlastnosti TEMP_DATUM1 objektu _THIS

_o.addtextbox('temp_datum1')

* metoda READ zahajuje vstup formuláře a vrací FALSE při uživatelově stisku ESC

RETURN _o.read()

#INCLUDE sysdia

V předloze výstupu je potom možné odkazovat na vstoupenou proměnnou jako THIS.TEMP_DATUM1.

Odkaz v doplnění SQL dotazu ve vlastnostech předlohy však není tímto způsobem možný.

Proto jinak např.:

LOCAL _o

* vstupní informace bude uložena v objektu TOOL, ale mohla již být definována předchozím spuštěním předlohy

DO CASE

CASE TYPE('tool.temp_datum1')='U'

* dosud není vlastnost TEMP_DATUM1 objektu TOOL definována

* přidání vlastnosti TEMP_DATUM1 do objektu TOOL inicializovanou aktuálním datem

tool.addproperty('temp_datum1',date())

CASE TYPE('tool.temp_datum1')<>'D'

* vlastnost TEMP_DATUM1 je definována, ale není typu datum

tool.temp_datum1=DATE()

ENDCASE

_o=CREATEOBJECT('bm_code_sysdia')

_o.start(tool,'Datum')

* bude vstup do vlastnosti TEMP_DATUM1 objektu TOOL

_o.addtextbox('temp_datum1')

RETURN _o.read()

#INCLUDE sysdia

V předloze výstupu je potom možné odkazovat na vstoupenou proměnnou jako TOOL.TEMP_DATUM1.

V doplnění SQL dotazu ve vlastnostech předlohy bude možné odkazovat v otazníkové konvenci např.:

tabulka.datum>=?tool.temp_datum1

Příklad použití příkazu .CALL

Příklad použití příkazu .CALL v komponentě „Projektové řízení“ – výstup do Excel výběrového řízení, kdy na jednom listu budou parametry dodávky a na druhém technická specifikace předmětu projektu.

Předloha nad událostmi obchodu operace „Výběrové řízení“ na začátku vyvolá předlohu činnosti „Předmět projektu“, která vytvoří soubor Excelu s obsahem technické specifikace daného předmětu. Tento soubor potom předloha obchodu použije jako vzor pro vytvoření nového souboru Excel pro každého účastníka výběrového řízení.

V předloze činnosti „Předmět projektu“ je v kódu po vytvoření užita sekvence:

.KDYŽ this.extern

.CLOSE_EXCEL

.KONEC_KDYŽ

a

.KDYŽ this.extern

.EXCEL_OTEVŘI this.param1, 'template\vykazy.xlt'

.PŘIŘAĎ $(list)=this.param2

.JINAK

.EXCEL_OTEVŘI 'C:\TMP\KARTAP.XLS', 'template\vykazy.xlt'

.PŘIŘAĎ $(list)="Karta předmětu"

.KONEC_KDYŽ

.EXCEL_NOVÝ_LIST $(list)

Parametr this.extern nabývá logickou hodnotu TRUE v případě, že byla předloha vyvolána příkazem .CALL

V souvislosti s použitím šablony používané novými výkazy jsou dále pro doplnění hlavičky výkazu použity příkazy:

.EP xlsheet.Shapes('nadpis').textframe.Characters.Text='Karta předmětu'

.EP xlsheet.Shapes('nadpis').textframe.autosize=.T.

.EP xlsheet.Shapes('autor').textframe.Characters.Text=ALLTRIM(tool.jmeno)+

' '+TTOC(DATETIME())

.EP xlsheet.Shapes('autor').textframe.autosize=.T.

Výstup do EXCELU

Příkaz

Syntaxe

Popis

.EXCEL

.EXCEL

Popisuje, že definice je určena k výstupu do EXCELU.

Musí být uveden na prvním řádku definice.

.EXCEL_NEUKLÁDAT

.EXCEL_NEUKLÁDAT

Soubor bude po ukončení prohlížení v EXCELU zrušen.

.EXCEL_OTEVŘI

.EXCEL_OTEVŘI <soubor>,<template>

Otevře soubor uvedený v příkazu kopií ze souboru "template". Uvedené parametry jsou výrazy, vyhodnocované při zpracování předlohy (tj. názvy mohou být odvozeny z dat)

Př.:

.EXCEL_OTEVŘI "VYSTUP.XLS","C:\ZDROJ.XLS"

Je-li v parametru „template“ uvedena šablona Excelu (přípona XLT), potom výstupní soubor není přepsán, ale listy vytvářené příkazem EXCEL_LIST budou vytvářeny podle dané šablony.

.EXCEL_LIST

.EXCEL_LIST <název>

Přepne na zpracování listu uvedeného v parametru.

Není-li list v aktuálním otevřeném souboru EXCELU obsažen, je založen nový list.

Př.:

.PŘIŘAĎ $(list)='Název listu'

.EXCEL_LIST $(list)

nebo

.EXCEL_LIST 'Název listu'

.EXCEL_NOVÝ_LIST

.EXCEL_NOVÝ_LIST <název>

Vytvoří nový list podle zadaného parametru. Funguje stejně jako příkaz EXCEL_LIST, s tím rozdílem, že pokud list s daným jménem existuje, bude před vytvořením nového listu zrušen (vhodné pro odstranění formátování předchozího výstupu)

.EXCEL_CLEAR_SHEET

.EXCEL_CLEAR_SHEET

Vymaže obsah aktuálního listu.

.EXCEL_VYHLEDEJ

.EXCEL_VYHLEDEJ <výraz>

Vyhledá v datech záznam odpovídající výrazu (např. pro účel odvození jména výstupního XLS souboru podle variabilního symbolu při tisku faktury)

.EXCEL_NÁVRAT_UKAZATELE

.EXCEL_NÁVRAT_UKAZATELE

Návrat na záznam pře provedením posledního příkazu ".EXCEL_VYHLEDEJ".

.EXCEL_STRANA

.EXCEL_STRANA <výraz>

Po dokončení výstupu do EXCELU bude na danou pozici vloženo odstránkování.

Je vhodnější než přímým příkazem EXCELU z důvodu rychlosti.

.EXCEL_PŘÍKAZ

.EXCEL_PŘÍKAZ <příkaz>

Provede vedený příkaz.

.EP

.EP <příkaz>

Ekvivalent příkazu ".EXCEL_PŘÍKAZ"

Metoda EX_COLUMN

…this.ex_column(5)..

Metoda vrací znakovou identifikaci sloupce např.:

xlsheet.Columns('A:'+this.ex_column($(se))).autofit

Metoda EX_CELL

…this.ex_cell(5,3)..

Metoda vrací znakovou identifikaci buňky např.:

xlsheet.range(this.ex_cell(4,$(r)+1)).SELECT

Metoda EX_RANGE

this.ex_range(5,3,7,4)

Metoda vrací znakovou identifikaci oblasti např.:

xlsheet.range(this.ex_range(1,$(r),$(se),$(r))).WrapText = .T.

Výstup do EXCELU pracuje s objekty XLAPP (odpovídá objektu Application), XLWB (odpovídá objektu Workbook) a XLSHEET (odpovídá objektu Worksheet). Příkazem v předloze ".EXCEL_PŘÍKAZ" je možné volat metody, číst a měnit vlastnosti těchto objektů.

Tabulka příkladů práce s objekty EXCELU

Příklad | Popis
.prirad $(row)=xlsheet.range('r_start').row | Zjištění řádku pojmenované buňky listu.
.prirad $(col)=xlsheet.range('c_start'). Column | Zjištění sloupce pojmenované buňky listu.
.EP xlsheet.range('součet').value=$(a)+$(b) | Vložení hodnoty do pojmenované buňky listu.
.EP xlsheet.cells[$(row),$(col)].value=$(a)+$(b) | Vložení hodnoty do buňky v pozicích $(row) a $(col).
.EP xlsheet.range('A'+ LTRIM(STR($(row)))+':'+CHR(ASC('A')-1+$(col_posledni))+LTRIM(STR($(row)))).Borders(1).LineStyle = 1 | Levé ohraničení buněk od prvního sloupce do sloupce jehož číslo je uloženo v proměnné $(col_posledni) tenkou čarou. Parametr Borders : 1 = levý, 2 = pravý, 3 = horní, 4 = dolní
.EP xlsheet.range('A'+LTRIM(STR($(r)))+ ':'+CHR(ASC('A')-1+$(col_posledni))+LTRIM(STR($(r)))).Borders(3).Weight = 3 | Určení ohraničení buněk od prvního sloupce do sloupce jehož číslo je uloženo v proměnné $(col_posledni) tlustou čarou
.prirad $(pom)='=SUM(R['+LTRIM(STR($(r_od)-$(r)))+']C:R[-1]C)' .EP xlsheet.cells[$(r),$(c_pokladna)].FormulaR1C1=$(pom) .EP xlsheet.cells[$(r),$(c_banka)].FormulaR1C1=$(pom) | Relativní adresování R1C1 pro sumu řádků ve sloupci.
.EP xlsheet.cells[$(row),$(col)].Formula='=A1+A2' | Definování výpočtové buňky v přímém adresování
.EP xlsheet.rows($(row)).hidden=.T. | Skrytí řádky
.EP xlsheet.Columns($(col)).hidden=.T. | Skrytí sloupce
.EP xlsheet.range('c_datum').columnWidth=200 | Změna šířky sloupce pojmenované buňky
.EP xlsheet.range('A1').columnWidth=100 | Změna šířky sloupce 1
.EP xlsheet.range("A"+LTRIM(STR($(r)))).RowHeight=20 | Změna výšky řádky.
.EP xlsheet.range("A1").SELECT | Nastavení na buňku A1 (např. po ukončení výstupu)
.EP xlsheet.cells[$(row),$(col)].font.bold=.T. | Nastavení tučného textu v buňce (podobně "italic").
.EP xlsheet.Shapes("nodberatel").textframe.Characters.Text='Abnehmer' | Změna textu pojmenovaného textframe v listu.
.EP xlsheet.range("A1:A10").copy .EP xlsheet.range("A"+LTRIM(STR($(row)))).SELECT .EP xlsheet.Paste | Kopírování oblasti A1:A10 do oblasti podle proměnné $(row).
.EP xlsheet.range("A"+LTRIM(STR($(r)))+":A"+LTRIM(STR($(r)+1))).EntireRow.Insert | Vsunutí dvou řádků
.EP xlsheet.range("A"+LTRIM(STR($(r2)))).EntireRow.delete | Odstranění řádky
.EP xlsheet.cells[$(row),$(col)].NumberFormat='##0' | Definování numerického formátu buňky.
.EP xlsheet.cells[$(r),$(c)].NumberFormat='#,##0.00 "'+ALLTRIM($(OBUDAL_oc01id2))+'"' | Definování numerického formátu buňky s měnou.
.EP xlsheet.HPageBreaks.Add(xlsheet.Range("A"+LTRIM(STR($(r))))) | Vložení odstránkování (lépe je z důvodu rychlosti použít ".excel_strana $(r)")
.EP xlsheet.Protect(, .T., .T., .T.) | Zablokování listu pro opravy
.EP xlsheet.UnProtect | Odblokování listu pro opravy
.prirad $(list_vse)='Peněžní deník' .prirad $(list_den)='Denní součty' . . .excel_list $(list_den) .prirad $(pom)=[=']+$(list_vse)+['!] .prirad $(i)=$(od) .cyklus $(i)<=$(do) .EP xlsheet.cells[$(rd),$(i)].value=$(pom)+CHR(ASC('A')-1+$(i))+LTRIM(STR($(r))) .prirad $(i)=$(i)+1 .konec_cyklus .excel_list $(list_vse) | Příklad převodu součtových hodnot z listu na list.
.komentar deklarace pole použité v prostředí FOXPRO .EP LOCAL ARRAY _var1[50] .prirad $(c_pokladna)=xlsheet.range('c_pokladna').column .prirad $(c_banka)=xlsheet.range('c_banka').column .komentar vynulování obsahu pole .EP _var1=0 .DOKUD $(UCDENIK_sp33cisdr),$(UCDENIK_sp33cisdpm),$(UCDENIK_sp33cisd) .komentar naplnění obsahu pole podle účetního dokladu .prirad $(castka)=$(UCDENIK_uc02castka)*IIF($(UCDENIK_uc02strana)=1,1,-1) .když SUBSTR($(UCDENIK_uc01id),1,3)='211' .EP _var1[$(c_pokladna)]=_var1[$(c_pokladna)]+$(castka) .konec_když .když SUBSTR($(UCDENIK_uc01id),1,3)='221' .EP _var1[$(c_banka)]=_var1[$(c_banka)]+$(castka) .konec_když . .KONEC .prirad $(i)=$(od) .cyklus $(i)<=$(do) .když _var1[$(i)]<>0 .EP xlsheet.cells[$(r),$(i)].value=_var1[$(i)] .konec_kdyz .prirad $(i)=$(i)+1 .konec_cyklus | Příklad použití pole v souvislosti s příkazem ".CYKLUS"
.EP xlsheet.range("D2").SELECT .EP XLapp.ActiveWindow.FreezePanes=.T. | Od buňky D2 výše jsou zmrazeny posuvy těchto řádků a sloupců
.EP xlsheet.range(“A1”).WrapText=.T. | V buňce A1 je zalamován text
.EP xlsheet.PageSetup.Orientation=2 | Orientace výstupu pro tisk
.EP Xlapp.ActiveWindow.WindowState=2 | Maximalizuje okno dokumentu
.EP xlsheet.range(“A1:C2”).MergeCells=.T | Sloučení buňek A1 až C2
.EP xlsheet.range[2,8].HorizontalAlignment=3 | Zarovnání textu na střed
.EP xlsheet.Columns(“E:E“).EntireColumn.Autofit | Sloupec E bude mít dynamickou šířku
.EP xlsheet.cells[2,2].value=IIF(TYPE(‘this.otec.obec_vyber.p[1]’)=’D’,this.otec.obec_vyber.p[1],{}) | Do buňky B2 je vložena hodnota prvního parametru z obecného výběru formuláře, současně je provedena i kontrola na typ

Výstup do HTML

Příkaz | Syntaxe | Popis
.HTML | .HTML soubor | Definuje název výstupního souboru. Např.: .HTML C:\KTL\KATALOG.HTM
.OTEVŘI | .OTEVŘI [<název>] | Otevře výstup do HTML souboru. Není-li parametr uveden, otevře opakovaně soubor uvedený v příkazu ".HTML". Při uvedeném parametru je případný existující soubor přepsán. Např.: .OTEVŘI "C:\KTL\"+ALLTRIM(OBARTIKL_sp60id)+'.HTM'
.OTEVŘI_ZNOVU | .OTEVŘI_ZNOVU <název> | Otevře opakovaně soubor, tj. výstupy budou zapisovány za konec tohoto existujícího souboru.

MAIL výstupu předloh

Příkazy pro Mail výstupních dokumentů se uplatňují při výstupu do Excel (typ 2) a výstupu do HTML. Technické podmínky – instalovaná pošta kompatibilní s MS MAPI a nainstalován prvek AktiveX MSMAPI32.OCX. Mail je odeslán příkazem MAIL_SEND, při výstupu do HTML okamžitě, je-li výstupní soubor uzavřen příkazem UZAVŘI , při výstupu do EXCEL okamžitě, je-li výstupní soubor uzavřen příkazem EXCEL_CLOSE, jinak po ukončení práce uživatele se souborem v EXCELU. Po úspěšném odeslání MAIL je původní výstupní soubor zrušen. Byl-li v průběhu výstupu do HTML odeslán alespoň jeden mail, nebude browser spuštěn po ukončení výstupní předlohy.

Příkaz

Syntaxe

Popis

.MAIL_RECIPADRESS

MAIL_RECIPADRESS ‘adresa(y)’

Určuje adresu příjemce je možné zadávat seznam adres oddělených středníkem např. ‘a.@telecom.cz; b.@telecom.cz;‘

Nebo je možné určit atribut ve výstupním souboru (uvedený znakem ‘*‘), který odpovídá identifikaci adresáta např. ‘*OBUDAL_ad01id‘. V tom případě bude MAIL odeslán na všechny e-mailové adresy adresátů obsažených ve výstupu.

Nebo je možné určit identifikaci adresáta (uvedenou znakem ‘*‘), kterému má být mail odeslán

např. ‘*‘+SQL_TISK.OBUDAL_ad01id. V tom případě bude MAIL odeslán na všechny e-mailové adresy daného adresáta.

.MAIL_SUBJECT

MAIL_SUBJECT ‘text‘

Předmět zprávy např. ‘Faktura za dodání‘

.MAIL_MESSAGETEXT

MAIL_MESSAGETEXT ‘text‘

Popisná část zprávy např. ‘Fakturujeme Vám ‘+SQL_TISK.OBUDAL_ob02text+CHR(13)+‘Těšíme se na další spolupráci‘+CHR(13)+‘Fakturoval:‘+tool.jmeno

.MAIL_FILE

MAIL_FILE ‘soubor‘

Nastavení souboru spojeného s mailem na jiný než je soubor vytvářený předlohou. Při uvedení prázdného řetězce nebude s mailem spojen žádný soubor.

.MAIL_BM_FILE

MAIL_BM_FILE cid[,typ]

Nastavení souboru spojeného s mailem na soubor(y) uložený v BM. Při neuvedení parametru TYP se předpokládá, že v parametru CID je uvedena jednoznačná časová identifikace dokumentu. Uvedený parametr TYP znamená výstup dokumentů spojených s objektem typu daného tímto parametrem (může být ‘%‘).

Při použití tohoto příkazu je třeba použít příkaz MAIL_SEND s parametrem 2 nebo 3.

Dále viz. Příklad

.MAIL_SEND

MAIL_SEND 0/1/2/3

Odeslání mailu s uvedeným parametrem 0 nebo 2 bez možnosti jeho dotvoření v editoru. Při užití parametru 1 nebo 3 bude mail možné dotvořit v editoru mailu.

Užití parametru 2 nebo 3 způsobí, že spojený soubor nebude po odeslání zrušen.

V souvislosti s odesíláním je možné nastavit jméno profilu v souboru BW.INI nebo lokálně v BWLCL.INI parametrem ‚mail_profile‘ v sekci ‚Preferences‘ např.:

mail_profile=Nastavení MS Exchange

.EXCEL_CLOSE

EXCEL_CLOSE

Doplňující příkaz pro EXCEL určený pro použití s MAIL. Při jeho uvedení bude po vytvoření soubor v EXCEL uzavřen a MAIL bude možné přímo odeslat.

.UZAVŘI

UZAVŘI

Doplňující příkaz pro výstup do HTML určený pro použití s MAIL. Při jeho uvedení bude po vytvoření výstupní soubor uzavřen a MAIL bude možné přímo odeslat.

Příklad

.HTML temp.htm

.MAIL_FILE ''

.MAIL_BM_FILE sql_tisk.vy01,‘%‘

.MAIL_RECIPADRESS '*'+$(Vyudalos_ad01id)

.MAIL_SUBJECT $(Vyudalos_vy01text)

.MAIL_MESSAGETEXT $(Vyudalos_vy01koment)

.MAIL_SEND 3

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.02.2014


Pojem - Pořadí

Tento atribut se vyskytuje v událostech komponenty skladu zvířat. Předplňuje se automaticky číslem 100 a každé následující je o sto vyšší. Výjimku tvoří operace zápočet krmných dnů, kde se pořadí předplňuje podle nastavených parametrů (činnost parametry komp. skladu zvířat - parametr "započítávat stavy do KD"). Zápočet krmných dnů se provádí na základě počátečních nebo konečných stavů. V případě nastavení „počátečních stavů“ se v daný den do krmných dnů nezapočítávají naskladněná zvířata, ale započítávají se pouze v ten den vyskladněná a do příjmových operací se do atributu pořadí automaticky předplňuje 1. V případě nastavení „konečných stavů“ se v daný den do krmných dnů nezapočítávají vyskladněná (prodaná) zvířata, ale započítávají se pouze v ten den naskladněná a do výdajových operací se do atributu pořadí automaticky předplňuje 99999.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 06.03.2008


Pojem - Postupy vymáhání

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.01.2013


Pojem - Pozemky

Užití komponenty „pozemky“ se předpokládá v souvislosti se správou a evidencí jednotlivých nemovitostí (např. pozemků) či celků z nich vytvářených. Základní vlastností této komponenty je schopnost využití dat evidovaných Českým úřadem zeměměřickým a katastrálním s možností dalšího uživatelského zpracování. U každé nemovitosti potom sledujeme kde leží, komu patří a další informace s ní související (tj. podíly, řízení, jiné právní vztahy, vlastnické listy, správní celky apod.).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 17.03.2008


Pojem - Pracovní funkce

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 01.02.2008


Pojem - Pracovní místa

Jedná se o číselník pracovních míst skutečných a typových (přehled podle nadefinované záložky Výběr) a nadefinovaných pracovních funkcí k jednotlivým pracovním místům. Každá organizace může mít nadefinováno několik typových pracovních míst (např. obchodník, manager, technik apod.). Na základě těchto typových míst pak vznikají konkrétní skutečná pracovní místa. A ke každému pracovnímu místu lze nadefinovat k němu se vztahující pracovní funkce.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 01.02.2008


Pojem - Pracovní poměr

Tato záložka je svojí důležitostí pro pracovníka klíčová. Zadává se zde seznam pracovních poměrů pracovníka u organizace. K dispozici jsou tyto atributy:

¨ číslo p.p. – číslo prac. poměru a jeho druh (na výběr z překryvného seznamu)

¨ prac. funkce – identifikace pracovní funkce (seznam pracovních funkcí by si měla každá organizace uživatelsky nadefinovat)

¨ kalendář – identifikace kalendáře, který je platný pro daného pracovníka, je nedílnou součásti pracovního poměru a ve výpočtu mezd má zásadní vliv (např. pro výpočet FPD, minimální mzdy apod.). Při vytváření nového kalendáře se definuje jeho identifikace, název a počet hodin za den. Pak je nutno každému kalendáři v číselníku vygenerovat fond pracovní doby ve dnech nebo v měsících (menu Volby) – podle nastavení atributu „typ kalendáře“ v činnosti Parametry – záložka Chování.

¨ stupnice – identifikace tarifní stupnice. V číselníku se u každé stupnice evidují i jednotlivé tarifní třídy

¨ třída – identifikace tarifní třídy

¨ určující – možná volba Ano/Ne. Pokud má uživatel více pracovních poměrů, musí mít jeden určený jako určující.

¨ vznik p.p. – datum zahájení daného pracovního poměru

¨ typ mzdy – volbou typu mzdy se v podstatě určuje způsob odměňování (měsíční, hodinová apod.). Typ mzdy byl vyvinut pro účely hlídání překročení minimální mzdy. Je nastaven na kartě pracovníka (záložka pracovní poměry) a předplňuje se podle uvedené pracovní funkce.

¨ skončení p.p. – datum ukončení pracovního poměru

¨ zkušeb. lhůta – datum ukončení zkušební lhůty pracovníka u daného prac. poměru

Na této záložce má uživatel pod menu Volby k dispozici další důležité atributy, které je nutno u pracovníka evidovat . Jsou dostupné v činnosti:

¨ pravidelné příjmy (funkční klávesa F5)

¨ další informace (funkční klávesa F6)

¨ další informace karty (ke sledování limitu vyměřovacího základu SP, limitu vyměřovacího základu ZP, limitu penzijního a životního připojištění)

Pro snadnější zadání a zamezení opomenutí některých údajů u pracovníka je možné po zadání a uložení pracovního poměru využít možnost, kterou uživateli nabízí činnost Cyklus při vstupu nového pracovníka (menu Volby nebo funkční klávesa F7). Po aktivaci této činnosti se uživateli postupně zobrazující všechny činnosti, které je nutné v této souvislosti vyplnit.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 31.01.2008


Pojem - Pracovní výkony

Pracovní výkony se definují na záložce v činnosti přehled referenčních artiklů. Na ní se definují pracovní výkony nutné k výrobě referenčního artiklu. Atribut „profese“ odkazuje do komponenty mezd, přiřazuje pracovnímu výkonu pracovní místo, které je ohodnoceno hodinovou mzdou. Další důležitý atribut je atribut „čas“, který eviduje čas potřebný k provedení pracovního výkonu. Konstantní čas trvání pracovního výkonu se používá v případě, že se jedná o pracovní výkon nezávislý na počtu vyráběných výrobků. Čas podle délky kroku je vypočítáván v závislosti na počtu vyráběných výrobků podle tabulky vztahů pracovních výkonů. Atribut „procento kroku“ (proc.kr.) definuje podíl času, který věnuje uvedená profese danému kroku pracovního výkonu (např. pokud se pracovník v určitý čas věnuje zároveň práci na více výrobních linkách)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.01.2008


Pojem - Pracovníci

Tato záložka obsahuje základní informace o pracovníkovi, tzn. jeho osobní číslo, externí identifikaci (možno využít v případě potřeby i jako druhé osobní číslo), jméno, příjmení, adresu, která zajišťuje spojení s adresářem a zařazení pracovníka k příslušnému výplatnímu místu.

Protože každý pracovník je ve mzdách evidován pouze pod svým osobním číslem, ale pro spojení s okolním světem, např. pro účely vytvoření příkazu k úhradě v platbách, je nutné ho mít zaevidováno přímo v činnosti adresář. Proto je zde na této záložce vidět jeho osobní číslo, ale zároveň i identifikační číslo, pod kterým je zařazen v centrálním adresáři. U každého pracovníka v adresáři se evidují základní údaje (např. jeho jméno, adresa, bankovní účet apod.)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 07.05.2009


Pojem - Pravé tlačítko myši na činnosti hlavního menu

Po každém stisku pravého tlačítka myši na některé z činností hlavního menu se uživateli zobrazí následující nabídka:

¨ vlastnosti činnosti

¨ kopírovat – umožňuje činnost zkopírovat (funguje jako používaný příkaz Ctrl+C) a vložit ji pod jinou, zvolenou skupinu (funguje jako používaný příkaz Ctrl+V). Uživatel tedy klikne pravou myší na názvu činnosti, zvolí možnost zkopírovat, pak se kurzorem přemístí na vybranou skupinu, klikne na jejím názvu pravou myší a zvolí možnost „vložit činnost .....“

¨ vrátit výchozí – pokud si uživatel změní název nebo vlastnosti dané činnosti a pak zjistí, že tato změna byla chybná a chtěl by vrátit zpátky původní název, zvolí tuto možnost.

¨ odstranit – činnost je odstraněna. Tato volba je ovšem vysvícena jen u nově vytvořených činností (kopírováním), standardní činnosti obsažené v dodávce IS BM (tzn. v základní definici menu) odstranit nelze.

Jako je možno na vlastnostech činnosti nadefinovat funkční klávesu, po jejímž stisku se bude daná činnost aktivovat, je možno vybranou činnost pomocí volby kopírovat vložit pod činnost hlavního menu „spustit při startu“, čímž je zajištěno, že tato činnost se bude automaticky aktivovat při každém spuštění IS BM.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Pravidelné příjmy

Jsou k dispozici na kartě pracovníka na záložce pracovní poměr po stisku klávesy F5 nebo volbou příslušné činnosti z menu Volby.

Na úvod se uživateli zobrazují údaje z karty pracovníka, tzn. osobní číslo, jméno a identifikace pracovního poměru. Další údaje se již vstupují:

¨ jednoznačná identifikace mzdové položky (jak jsme se již zmínili výše, tyto příjmy a náhrady by měl definovat implementátor nebo zkušený mzdový pracovník)

¨ popis – přetáhne se současně s identifikací mzdové položky

¨ hodiny – způsob dopočtu hodin na výplatním lístku. Na výběr z překryvného seznamu jsou tyto možnosti:

- nevyplňovat – po přenosu pravidelných příjmů do výplatního lístku se atribut hodiny nevyplní. Na výplatní lístek se pak přenese přesně tolik Kč, kolik je zde vyplněno. Atribut hodiny na výplatním lístku bude 0.

- dopočíst do FPD dle hodin – hodiny na výplatním lístku se pak počítají jako hodiny FPD ve zpracovávaném měsíci mínus součet hodin mzdových položek s doplňujícím údajem („hodiny jsou součástí FPD – Ano“) mínus součet hodin nepřítomností mínus součet hodin neplaceného volna mínus součet hodin ve kterých pracovní poměr ve zpracovávaném měsíci netrval. Dny na výplatním lístku jsou pak výsledkem poměru hodin na výplatním lístku a pracovního úvazku (úvazek je součástí kalendáře pracovníka a tento je součástí pracovního poměru). Odečítané mzdové položky byly zadány do výplatního lístku ručně nebo pomocí úkolových lístků.

- součet odpracovaných dle hodin – hodiny se vypočte jako suma těch mzdových položek, které mají v doplňujících údajích zadáno „hodiny započítávat pro nárok na pohyblivou složku měsíční – Ano“. Použije se např. při pravidelné měsíční pohyblivé složce, jejíž výše je závislá na počtu odpracovaných hodin při výkonu určitých prací. Dny na výplatním lístku jsou pak výsledkem poměru hodin na výplatním lístku a pracovního úvazku (úvazek je součástí kalendáře pracovníka a tento je součástí pracovního poměru).

- dopočíst do FPD odděleně ve dnech a v hodinách – hodiny se zjistí s ohledem na FPD (stejný postup výpočtu jako u možnosti „dopočíst FPD dle hodin“). Dny se pak samostatně zjistí s ohledem na FPD (stejný postup výpočtu jako u možnosti „dopočíst FPD dle dnů“). Dny a hodiny pak tedy spolu vůbec nemusí korespondovat. Používá se hlavně v případech, kdy na výplatní lístek vstupují položky jako paragraf (nebo dovolená půl dne), které mají pak specifický způsob zápisu, např. 0dnů, 2,5 hodiny apod.

- součet odpracovaných odděleně ve dnech a v hodinách – stejný výpočet jako při možnosti „součet odpracovaných dle hodin“, ale hodiny a dny se počítají samostatně, nikoliv podle úvazku.

- dopočíst do FPD dle dnů – stejný výpočet jako při možnosti „dopočíst do FPD dle hodin“, ale výpočet se zajímá pouze o dny a hodiny se pak spočítají jako dny * úvazek.

¨ Kč/j – množství Kč za jednotku

¨ indiv. koef. – umožňuje nadefinovat konkrétní koeficient pro konkrétního pracovníka u dané položky mzdy (např. chci pracovníkovi dlouhodobě nastavit prémie 50%. Potom je zde v tomto koeficientu nastaveno 0,5 a platí to právě na konkrétní položku mzdy a konkrétního pracovníka). V případě, že je uveden tento individuální koeficient, má při výpočtu mzdových položek přednost před atributem „koeficient“ v dolní části formuláře.

¨ od data – do data – datum zahájení a datum ukončení platnosti položky

¨ koeficient, výpočet Kč a dopl. údaj jsou informace, které se sem jako informace automaticky natáhnou při zadání identifikace mzdové položky

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 25.11.2008


Pojem - Pravidla inicializací přístupových práv

Tato činnost slouží k zpřehlednění a zjednodušení definice přístupových práv u jednotlivých druhů (např. druh volné karty, druh procesu, druh artiklu, druh předlohy výstupu apod.). V současné době platí, že při nainstalování IS BM je vše povoleno všem a správce systému pak postupně jednotlivé činnosti uživatelům zakazuje. Pomocí nastavení pravidel inicializací přístupových práv je možno toto nastavení změnit.

Při zakládání nového druhu v IS BM se nejprve vyhledává pravidlo, které:

¨ má stejnou identifikaci jako je identifikace nového druhu

¨ pokud není takové pravidlo nalezeno, vyhledává se první takové s nejvyšší prioritou, jehož identifikace je ‘jako‘ identifikace nového druhu, tj. vyhovuje podmínce logického výrazu Sybase SQL Anywhere – identifikace_nového_druhu LIKE identifikace_pravidla

Pokud není pro nový druh žádné pravidlo inicializace přístupových práv nalezeno, bude přiděleno přístupové právo „Zápis“ skupině uživatelů „Každý uživatel systému“.

U každého pravidla se definuje:

¨ identifikace pravidla – šestiznaková identifikace

¨ název pravidla

¨ typ pravidla – překryvný seznam, kde je možno vybrat:

¨ každý uživatel zápis – bude přiděleno přístupové právo „Zápis“ každému uživateli ve skupině „Každý uživatel systému“

¨ každý uživatel čtení – bude přiděleno přístupové právo „Čtení“ každému uživateli ve skupině „Každý uživatel systému“

¨ každý uživatel žádná práva – nebudou přidělena práva přístupu pro žádnou skupinu uživatelů

¨ kopie práva – budou přidělena stejná práva, jako jsou aktuálně nastavena pro dané pravidlo (pravidlu se nastavují práva po stisku Ctrl B). Znamená to, že pro vytvořené pravidlo XXX zadáme po stisku Ctrl B přístupová práva. Pak jakékoliv jiné pravidlo založené nově v systému s identifikací XXX má stejná práva.

¨ priorita – možnost vyhledávání pravidel s nejvyšší prioritou (priorita 1 je vyšší než priorita 2)

¨ uplatnění – text – uvádí se zde seznam typů práv, pro které se má pravidlo uplatnit (viz. níže)

¨ poznámka – libovolný text

Příklad implementace s využitím atributu „uplatnění“:

Do IS BM mají přístup uživatelé, kteří mají v systému významně omezená práva, tj. nejsou členy skupiny $KAZDY, ale jsou členy skupiny EXTERN. Tito uživatelé by měli mít možnost tisku faktur a sestav skladových pohybů. Pro takovou potřebu přístupových práv definujeme pravidlo následovně:

¨ identifikace pravidla = '______'

¨ typ pravidla = kopie práva

¨ priorita = 999

¨ uplatnění = 'TSK,TUO,TUP,OBC,DPH,PLA'

K tomuto pravidlu definujeme přístupová práva pro skupiny uživatelů:

$KAZDY = zápis

EXTERN = čtení

Potom při založení nového skladu, umístění obchodu, umístění plateb nebo nové operace obchodu, DPH a plateb budou automaticky přidělena práva skupinám uživatelů:

$KAZDY = zápis

EXTERN = čtení

UPOZORNĚNÍ:

Při každé nové instalaci IS BM se automaticky vytvářejí pravidla:

‘SYSTEM’ – typ Každý uživatel čtení

‘HIDDEN‘ – typ Každý uživatel žádná práva

‘-‘ - typ Každý uživatel zápis

Tato pravidla není vhodné rušit (další instalací IS BM se znovu vytvoří), ale je možné měnit jejich typ. Změna typu pravidla ‘-’ se nedoporučuje, protože se jedná o identifikaci nově doplňovaných druhů v IS BM a může nastat situace, kdy po instalaci nové verze BM budou s nimi spojená data pro uživatele nedostupná.

Při definování pravidla se záměrem uplatnění „nový druh je jako pravidlo“ je třeba si uvědomit, že se při jeho vyhodnocování uplatňují všechny znaky včetně mezer (např. pravidlo s identifikací ‘%‘ vyhoví všem identifikacím druhů, které mají první libovolný znak následovaný pěti mezerami).

U pravidel s identifikací typu „Každý uživatel žádná práva“ může nastat situace, že po importu balíčků implementačních rozšíření, ve kterých jsou obsaženy jejich druhy, jsou pak tyto implementační rozšíření pro implementátora neviditelná.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 29.02.2012


Pojem - Pravidla transformace

Pravidla transformace jsou algoritmy datového toku, na základě kterých se události zdrojového uzlu přeměňují v události uzlu cílového (přesněji - na základě kterých se vstupní atributy cílové komponenty předplňují zejména[1] dle výstupních atributů zdrojové komponenty). Pravidla transformace se vyvolávají po stisku klávesy F5 přímo na transformaci (nebo volbou činnosti z menu Volby) nebo je možno je přímo vyvolat po stisku pravého tlačítka myši na názvu transformace při definování vazby uzlů procesu. Každá transformace musí mít uvedeno alespoň jedno pravidlo, což si musí ohlídat implementátor.

Pro definici pravidel transformace vždy bez výjimky platí, že z jedné události zdrojové lze transformací vytvořit maximálně jednu událost cílovou.

Např. pokud bude uživatel pomocí transformace chtít vytvořit z jedné události vývěsky pět zpráv, které pošle spolupracovníkům, je nutno mít nadefinováno pět pravidel transformace (po jednom pro každou ze zpráv), při účtování musí být jedno pravidlo transformace pro stranu Má Dáti a druhé pravidlo pro stranu Dal.

První část (nad čarou) pravidel transformace obsahuje tyto údaje:

¨ pořadové číslo - právě číslo pravidla transformace a vedle je informace kdo a kdy transformaci založil, definuje pořadí, v jakém se pravidla uplatní a tím i pořadí cílových událostí (významné např. pro pomocné slučování)

¨ rozlišení - slouží k rozlišení pravidel se stejnou cílovou hodnotou, ale obvykle v různém významu (tj. při aplikaci pravidel s různým rozlišením nedochází k tomu, že se jejich cílové částky sčítají při vykrytí míry plnění, ale naopak vykrývají se každé zvlášť - např. při účtování na obě strany: strana MD - rozlišení 0, strana D - rozlišení 1), podobný vliv na míru plnění má i rozlišení vazby uzlů

¨ agregační výraz - výraz slučování, tzn. že události se shodnou výstupní hodnotou tohoto výrazu budou do cílové události sloučeny (z několika zdrojových bude jedna cílová), specifické je pomocné slučování (výraz "[##]") a využití obecné předkontace

¨ výběr - logický výraz - dané pravidlo transformace se uplatní pouze pro ty zdrojové události, pro které má výraz výstupní hodnotu „pravda“, tzn., že daný výraz platí. Jako doporučení z praxe je možno uvést, že do výběru v pravidlech transformace je vhodné striktně zadávat pouze ty výrazy, které platí pouze pro dané pravidlo, aby nedocházelo k duplikaci se zadaným filtrem transformace, který je společný pro všechna pravidla u dané transformace.

¨ zdrojová hodnota - hodnota (numerický atribut), která je přenášena ze zdroje (tj. z událostí operace, ze které se tato transformace provádí). Zdrojová hodnota je současně algoritmus pro výpočet cílové hodnoty mírou plnění v případě, že je takto jednoduchý. V případě, že tato hodnota není definována, je nutné algoritmus pro výpočet cílové hodnoty mírou plnění definovat přímo u vstupního atributu komponenty, který je definován jako cílová hodnota, obvykle výrazem.

¨ cílová hodnota - hodnota (numerický atribut), která řídí míru plnění pro toto pravidlo (např. lze nadefinovat, že celková cena se má převést na hodnotu částka – v míře plnění). V případě, že chceme, aby se v transformaci mezi uzly uplatnila míra plnění, musí být cílová hodnota zadána povinně.

Druhá část (pod čarou) pravidel transformace je značně variantní a odvíjí se od toho, která komponenta je zdrojová pro danou transformaci (definují ji vstupní atributy komponenty). V této části je možno definovat algoritmus předplnění (automatizace vstupu) uvedených vstupních atributů dvěma způsoby, a to tak, že uživatel může zadávat konstantní hodnoty nebo výraz.

Konstantní hodnoty uživatel zadává, pokud nechává políčko u atributů volné (nezaškrtnuté). Potom jsou sloupce vedle atributů vysvíceny bíle a konstantní hodnota se přímo vepíše, např. v popisu může být uvedeno, že se jedná o „příjem na sklad“ nebo zde může být uvedena hodnota selektorů, které se vždy týkají pouze této transformace.

Pokud políčko před atributem zaškrtneme, předchozí bílé pole se změní na žluté a uživatel může potřebný výraz vybrat z překryvného seznamu nebo má možnost si ho po stisku F2 nadefinovat.

Též je možno využít (nebo zabránit využití) implicitní definice předplnění vstupních atributů komponenty pravidlem transformace, ale to je možné pouze u těch atributů, které jsou současně v událostech zdrojové i cílové komponenty nebo je to poznámka. Pokud uživatel některý vstupní atribut nechce pravidlem transformace předplňovat, a to ani implicitně, musí k němu nadefinovat předplnění prázdným výrazem nebo nulou[2].

[1] Dále lze k předplnění využít konstant, obecných předkontací, ...

[2] Pozor u některých atributů – může prázdný výraz být „přebit“ programovým kódem.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.04.2004


Pojem - Prezentace artiklu, dokumentů

Uživatel si v činnostech týkajících se artiklů (artikly skladu, artikly obchodu atd.) a dokumentů aktivuje menu Volby a v něm vyvolá příslušnou činnost týkající se „prezentace“. Uživateli se zobrazí samostatné okno, které je propojené s artikly nebo dokumenty. Např. můžeme mít oděvní firmu, která si ke každému artiklu obchodu vloží prezentaci (čili fotografii) každého jednotlivého kusu oděvu.

Propojení nebo vložení objektu se realizuje funkcí „vložit objekt“ nebo „vložit“ v horní liště obrazovky v menu Úpravy při aktivním okně prezentace artiklu. Při aktivaci funkce „ponechat“ v menu Volby nebude okno s prezentací artiklu automaticky uzavřeno při ukončení činnosti s přehledem artiklů nebo dokumentů.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 18.09.2012


Pojem - Prezentace procesů

Definuje, z jakých druhů operací a v jakém pořadí dle druhů operací mohou být pro tisk (výstup na základě předlohy výstupu - proces) získávány informace.

Tato definice se provádí v činnosti „prezentace procesů”[1]. Uvádí se název prezentace a na záložce „prezentované operace” se k prezentaci přiřadí druh operace. K prezentaci se přiřazují ty druhy operací z procesů, jejichž události chceme tisknout na dokladu [2]. Je poměrně obvyklé, že se každá prezentace implementuje ve vztahu k jednomu druhu procesu (či k několika "příbuzným" druhům procesu)[3] s následným využitím v několika předlohách výstupu - proces.

Důležitým atributem je „pořadí”[4], které určuje, v jakém pořadí (sledu) druhů operací jejich události na doklad při tisku vystupují. Poslední dva atributy, které má uživatel dostupné v pravé dolní části okna a má možnost je zaškrtnout jsou:

¨ referenční – znamená, že určité atributy událostí druhu operace, u které je tento atribut zaškrtnutý, jsou pak při tisku dostupné i v ostatních druzích operací v dané prezentaci (toto „zaškrtávátko“ však z praxe není ověřeno, navíc je zde podezření, že by se určitým způsobem mohl zpomalit i vlastní tisk)

¨ operace z procesu – pokud je tento atribut zatržen, je v tisku k dispozici operace daného druhu jen z toho fyzického procesu, ze kterého je spuštěn výstup. Pokud tento atribut zatržen není, v tisku jsou k dispozici operace daného druhu z celého hlavního procesu.

Nadefinované prezentace procesů se pak přiřazují k jednotlivým předlohám výstupu - proces[5]. Prezentaci procesů lze zadat pouze v případě, že předloha výstupu má zaškrtnutý (zvýrazněný tečkou) pohyb v událostech, jinak je položka prezentace nedostupná (tzn. šedivá).

V případě, že se změní diagram (druhu) procesu přidáním uzlu (operace), z něhož se požaduje tisk dokladu, musí se tato změna promítnout i do relevantních prezentací procesu, jinak nebude možno doklad vytisknout (atributy událostí nové operace nebudou dostupné v předloze).

[1] Menu Informační centrum – Typy a řady.

[2] O tomto dokladu je možno říci, že představuje obraz procesu.

[3] Podle mínění implementátora, zda upřednostnil jeden velmi variabilní proces nebo několik procesů pro sourodou problematiku.

[4] Zapisuje se ve tvaru 10, 20, 30, … atd.

[5] Stiskem pravé myši na předloze výstupu (dokladů) se vyvolá činnost vlastnosti, kde se pod záložkou „popis“ z překryvného seznamu vybere příslušná prezentace. Nejprve se musí zaškrtnout pohyb v událostech procesu, aby se zpřístupnilo.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.04.2004


Pojem - Prezentace stránek informačního panelu

Tato činnosti je určena pro nastavení stylů pro zobrazení stránky informačního panelu. Definuje se :

¨ popis stylu stránky - HTML text, který definuje styly

¨ kód hlavičky – umožňuje nastavit přizpůsobení vzhledu hlavičky informačního panelu. Tento kód (v jazyce Foxpro) musí vracet textovou hodnotu. Text vrácený kódem hlavičky je ve výsledném obsahu HTML souboru uložen za koncový tag HEAD.

¨ kód patičky - umožňuje nastavit přizpůsobení vzhledu patičky informačního panelu. Tento kód (v jazyce Foxpro) musí vracet textovou hodnotu. Text vrácený kódem patičky je vložen na konec HTML souboru a musí obsahovat koncový tag BODY.

Na stránce informačního panelu je možné vytvářet odkazy, které způsobí vyvolání programu Windows (jiného než internetový prohlížeč) a v něm otevření souboru, který odpovídá celé zobrazené stránce (může to být více tabulek) nebo jednotlivé tabulce zobrazené na stránce. Při vytváření stránky informačního panelu je dostupná vlastnost řídícího objektu vytváření stránky OUTPUT_FORMAT, která má při vytváření běžné stránky zobrazované v internetovém prohlížeči hodnotu 'prázdný text' a při vytváření stránky určené pro zobrazení v programu Windows obsahuje hodnotu, kterou je tříznaková přípona souboru. Přitom platí, že je-li stránka vytvářena s nastavenou vlastností OUTPUT_FORMAT řídícího objektu, potom do vytvářených tabulek nejsou vkládány hypertextové odkazy, je potlačeno vytváření automatických hlaviček a patiček stránky a po vytvoření stránky je vyvolán program Windows podle uvedené přípony (hodnoty vlastnosti OUTPUT_FORMAT).

Do stránky informačního panelu je možné vkládat hypertextové odkazy, které zajistí vytvoření stránky s nastavenou vlastností řídícího objektu vytváření stránky OUTPUT_FORMAT třemi způsoby:

- v kódu patičky prezentace stránky

- ve vlastnosti POSTTEXT definice uzlu informačního panelu

- hypertextovým odkazem, který je součástí tabulky informačního panelu

K tomuto účelu slouží např. uživatelská knihovna vkládaného kódu USRPAN. S knihovnou USRPAN je možné zadat v kódu patičky prezentace stránky nebo ve vlastnosti POSTTEXT definice uzlu informačního panelu kód:

<pre>

#SCRIPT

Return zobrazit_v_excelu_a_wordu(_this)

#INCLUDE USRPAN

</pre>

Takto budou do stránky vloženy hypertexty, které převedou do programu Windows celou zobrazenou stránku (může to být více tabulek).

Při vytváření stránky určené pro zobrazení v programu Windows je pro úspěšné uplatnění stylů nutné, aby styly byly přímo obsaženy v souboru předaném programu Windows. Proto je třeba zasáhnou do popisu stylu v prezentaci stránky informačního panelu a v jeho kódu podmínit v případě, že je nastavena vlastnost OUTPUT_FORMAT řídícího objektu, vložení textu stylů do vytvářené stránky.

Např. s užitím knihovny USRPAN:

<pre>

#SCRIPT

Return vrat_styl(_this)

#INCLUDE USRPAN

</pre>

V některých případech je vhodné pro výstup stránky do programu Windows vyloučit některé sloupce tabulky, řádky tabulky,prvky stránek nebo celou jednotlivou tabulku zobrazenou na stránce (poslední platí pro hypertexty v kódu patičky prezentace stránky nebo ve vlastnosti POSTTEXT definice uzlu informačního panelu). V tom případě je možné uvádět ve vlastnosti Podmínka v definici takového sloupce, řádku, prvku stránky nebo podřízeného uzlu výraz 'EMPTY(this.output_format)'.

¨ popis stylu prvku stránky - kód v jazyce Foxpro, který vrací text doplňující formát prvku

¨ atributy elementů TR – zde se uvádějí jednotlivé HTML atributy elementu následované výrazem v jazyce Foxpro oddělené klávesou Enter, např. BGCOLOR=IIF(MOD(this.citac_radku,2)=1,'YELLOW','') – stejné nastavení je možno uvádět také u jednotlivých řádků v činnosti definice uzlů inf. panelů. V případě, že je uvedeno nastavení u jednotlivého řádku v definici uzlů inf. panelů a rovněž zde v prezentaci stránek panelů, potom se uplatní obě tato nastavení.

¨ poznámka

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 17.12.2008


Pojem - Primární klíč

Primární klíč je pole nebo kombinace polí, jednoznačně identifikující každý záznam v databázové tabulce. Žádné pole, které je součástí primárního klíče, nesmí obsahovat hodnotu NULL. Každá tabulka má mít definovaný právě jeden primární klíč (entitní integrita).

Primární klíč má dvě základní vlastnosti: jedinečnost v rámci tabulky a nenulovou hodnotu. Databázový systém by měl být navržen a udržován tak, aby se primární klíč založeného záznamu nikdy nemusel měnit.

Typickým příkladem primárního klíče je rodné číslo v seznamu osob, identifikační číslo v seznamu podniků apod. Pokud u záznamu neexistuje žádný přirozený primární klíč, nebo je takový primární klíč příliš složitý, používá se jako primární klíč číslo, které záznamu přidělí automaticky sama databáze. Takové číslo může být pořadové číslo nebo náhodné číslo.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.10.2007


Pojem - Procedures & Functions

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 25.11.2014


Pojem - Proces

Proces je v IS modelem reálného světa vytvořeným posloupností operací, které jsou si obvykle věcně i časově blízké, tj. procesně spolu souvisí. Každý fyzický proces je určitého druhu, podle kterého má přiřazeny výchozí vlastnosti. Na základě definovaných druhů procesů pak uživatelé vytváří fyzické procesy, jejichž přehled je k dispozici v menu Procesy a operace – Procesy.

Přístupy k jednotlivým fyzickým procesům je možno omezit přístupovými právy, podle toho, jak jsou práva nadefinována u jednotlivých druhů procesů. Informace o každém fyzicky provedeném procesu je možno tisknout (viz. předlohy výstupu), případně zobrazit v několika režimech: diagram, strom a činnost s přehledem procesů Specifické vlastnosti má hlavní proces.

Uživatel, který nemá právo k činnosti „diagram procesu“ vyvolávané z formuláře „procesy“, nemá dostupnou možnost vyvolat diagram procesu z formulářů událostí operací komponent ani ze stromu hlavního procesu.

Fyzický proces je objektem.

Proces je také jedním z možných uzlů, který se používá při sestavování definice diagramu (druhu) procesu, resp. je zobrazován v diagramu fyzického procesu. IS disponuje nástroji pro modelování a řízení datového i řídícího toku.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 06.03.2009


Pojem - Procesní import

Procesní import je nástroj pro spouštění importů událostí komponent s automatizovaným založením procesu, resp. založením událostí v operacích existujících procesů na základě importovaných dat. Přitom se mohou importovaná data automaticky rozpadat do událostí většího počtu operací. Jedná se tedy o import dat, při kterém dochází k založení celé řady nových fyzických procesů, resp. k napojení (spuštění, naplnění událostmi) operace do celé řady různých fyzických procesů, čímž se řadí mezi dávková zpracování dat. Procesní importy se definují v činnosti Informační centrum – Typy a řady – Procesní importy. U každého procesního importu se nastavují tyto atributy:

¨ název a druh daného procesního importu (k druhu importu je možno nastavit přístupová práva, právem zápis má uživatel povoleno import vytvářet, právem čtení má právo ho spouštět)

¨ proces – identifikace druhu procesu, kterého se procesní import týká, tzn. který bude procesním importem založen nebo se na něj napojujeme

¨ operace – identifikace komponenty a druhu uzlu (u většiny způsobů založení se zde zadává identifikace uzlu typu proces, pouze u způsobu založení typu „existující proces s EI“ se zde zadává uzel typu operace), který se procesním importem spouští. Číslo za uzlem (operací) určuje pořadí operace stejného druhu, tzn. že ve většině případů zde bude číslo 1, pouze pokud by stejný druh operace byl v daném procesu použit několikrát, je nutno tímto pořadím určit, který se má spouštět.

¨ I-E – definice importu pro import dat do událostí operace dané komponenty

¨ založení – způsob, jakým má být výše uvedený proces vytvořen

a.) nový proces – procesní import založí naprosto nový proces (s identifikací podle číselné řady druhu procesu), jako kdyby se zakládal z menu NOVÝ PROCES

b.) nový proces podle záložky – předpokládá se existence jediného aktuálního fyzického uzlu (typu proces) se záložkou s adresátem (který se do ní dostal při založení procesu). Do tohoto uzlu se napojí nově zakládaný proces importem a vyhledá tento uzel (napojovací bod) dle id adresáta, tj. id na záložce = id adresáta současně "vypočtené" z importovaných dat. Pokud takovýto uzel neexistuje, IS nahlásí před rozběhnutím procesního importu zprávu, že neexistuje potřebná záložka adresáta a import nespustí. V případě spouštění se nově vzniklý proces ukládá do zmíněného uzlu se záložkou.

c.) nový proces - napojení – procesní import vytvoří nový proces s napojením do výše uvedeného procesu, dle výrazů - rok, IDU, číslo, pořadí zadaných na záložce výrazy je vyhledán uzel (napojovací bod), do kterého je nový proces napojen. Mezi všemi procesy odpovídajícího hlavního procesu je tedy vyhledán ten, který ve svém diagramu obsahuje uzel typu proces s druhem procesu procesního importu a v něm založí nový proces. Identifikátory procesu se pro tento způsob založení automaticky stávají součástí rozpadu událostí do operací.

d.) nový proces s EI (externí identifikací) – předpokládá se implementace cizího IS se shodným číslováním procesů jako v IS BM (tj. určitá simulace replikací), pak je takovýmto importem založen nový proces (jako způsob založení z menu Nový proces), ale jeho identifikace je převzata z importovaných dat (a to z výrazů, které jsou definovány na záložce výrazy). Pozor - v číslování procesů mohou nastat nesrovnalosti v číselných řadách (díry), pokud je připouští externí data a definice importu.

e.) existující proces s EI (externí identifikací) – v tomto případě nedochází k založení nového procesu (oproti všem předchozím případům), ale pouze k zápisu událostí do některé neukončené operace již existujícího procesu, tzn. systém vyhledá proces s identifikátory podle importovaných dat (vyhodnocením výrazů na záložce výrazy) a v něm neukončenou operaci druhu uvedeného v definici procesního importu a do této operace importu události.

f.) nový proces – možné napojení – kombinace způsobu založení „nový proces s EI“ a „nový proces – napojení“. V případě takto nastaveného procesního importu systém nejprve zkoumá, zda existuje proces s neukončenou operací do kterého by se zapsal, pokud takový nenajde, vytvoří se nový proces s napojením do výše uvedeného procesu.

spustit operaci na pozadí – zde uvedenou hodnotou je pro daný proces naplněn atribut

¨ spouštět (ve vlastnostech uzlu), tj. úvodní operace importu bude probíhat na pozadí

¨ zobrazit v menu – daný procesní import se nabízí v hlavním menu v činnosti Import do procesu (odtud je možno procesní import aktivovat)

¨ CID - tento atribut je určen pouze k využití programovým kódem, který formuluje implementátor, např. v doplňujících vlastnostech formuláře, v informačních panelech apod. V použitých činnostech musí být zapsán v tomto tvaru:

do spcallpi with ‘CID’

Tím je nadefinována hlavička procesního importu. Na záložce „výrazy“ se definují jednotlivé výrazy, které systém při provádění procesního importu používá:

¨ rozpad – dle tohoto klíče dojde k rozpadu cizích (tj. zdrojových) dat na jednotlivé procesy v IS BM (nemá smysl u založení typu "existující proces s EI"), současně dochází k automatickému rozpadu (ve variantách typu "napojení")

¨ jednoznačná identifikace – identifikace podle které se při opakovaném spuštění procesního importu rozlišují „cizí“ data na již importovaná a na data, která budou importována (v případě storna procesu založeného procesním importem se tento stále chová jako již importovaný. Pokud jej chceme znovu importovat, je nutno pozměnit definici této jednoznačné identifikace – změněný atribut musí být zapsán v uvozovkách). Jednoznačná identifikace tedy zcela jednoznačně identifikuje skupinu záznamů importovaných dat odpovídajících jediné fyzické operaci v IS BM. V přehledu fyzických operací se zobrazuje na úvodní záložce s návěštím „externí ID“. Užití výrazu jednoznačné identifikace zabraňuje opakovanému importu stejných dat. Výraz se automaticky stává součástí klíče rozpadu událostí do operací. Největší možná délka externí identifikace je 20 znaků.

¨ výrazy (rok, IDÚ, číslo, pořadí) – používají se při napojení do procesu pomocí EI a "napojení", definují napojovací bod - identifikaci procesu (operace) pro napojení (tzn. při napojení k již existujícímu procesu).

¨ rok – výraz pro určení roku identifikace procesu. Je povinný pro způsob založení procesního importu c.), d.), e.) a f.)

¨ IDÚ – výraz pro určení identifikace datového úložiště identifikace procesu. Je povinný pro způsob založení procesního importu c.), d.), e.) a f.)

¨ číslo – výraz pro určení čísla procesu identifikace procesu. Je povinný pro způsob založení procesního importu c.), d.), e.) a f.)

¨ pořadí – výraz pro určení pořadí operace identifikace procesu. Jediný numerický – obvykle 1. Je povinný pro způsob založení procesního importu c.), d.), e.) a f.)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 25.09.2012


Pojem - Procesy adresáta

Strukturovaný přehled procesů adresáta má uživatel k dispozici v činnosti Spojené dokumenty. Po rozkliknutí nabídky Procesy adresáta se uživateli zobrazují procesy seřazené do tří úrovní:

¨ jednotlivé roky – seznam složek let, kdy se procesy pro daného adresáta vytvářely. Po jeho rozkliknutí jsou k dispozici:

¨ číselné řady – jednotlivé použité druhy procesů podle nadefinovaných číselných řad (např. pohledávky, závazky apod.). Po jejich rozkliknutí se zobrazuje:

¨ seznam složek fyzických procesů, ve kterém jsou obsaženy procesy odpovídající roku a druhu procesu s číselnou řadou, které jsou uvedeny v nadřazených složkách. Jednotlivé procesy jsou popsány tímto způsobem: číslo procesu, druh procesu, popis procesu, jméno zakladatele procesu a datum a čas založení procesu. Po rozkliknutí položky stromu daného procesu se uživateli zobrazí klasický strom hlavního procesu, tak jak mu je již znám z jiných činností. Po stisku pravého tlačítka myši však nemá k dispozici všechny volby, které jsou k dispozici ve stromu hlavního procesu, ale pouze upravenou nabídku, která je v dané činnosti možná:

§ navazující dokument

§ diagram procesu

§ proces

§ nastavení stromu

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 02.02.2009


Pojem - Profily spuštění předlohy

Jednotlivé profily se definují v činnosti „profily spuštění předloh“ v menu SYSTÉM a určuje se u nich zda má při odpovídajícím způsobu spuštění (dvojklikem na názvu předlohy nebo stiskem ikony) následovat přímo spuštění předlohy nebo rozhodnutí. Kromě identifikace a názvu profilu je dostupný ještě atribut „parametr“, který ovlivňuje vytváření dokumentů ve formátu PDF. Zapsané parametry mohou být oddělené Ctrl F nebo středníkem.

Jedná se o:

PDF=0 - výstup do PDF nemá být prováděn - default PDF=1

GHOSTSCRIPT=0 - nebude používán Ghostscript, ale PDF tiskárna - default GHOSTSCRIPT=1

PRINTER=název tiskárny - jiný název použité tiskárny než default - default při GHOSTSCRIPT=1 je to PRINTER=GENERIC POSTSCRIPT PRINTER a při GHOSTSCRIPT=0 je to PRINTER=PRINT2PDF

PRINTERFILE=název výstupního dokumentu PDF tiskárny (při GHOSTSCRIPT=0) - default PRINTERFILE=C:\TMP\SOUBOR.PDF

PRINTRESOLUTION=600 - rozlišení PDF dokumentu v pixelech při GHOSTSCRIPT=1 (při GHOSTSCRIPT=1) - default PRINTRESOLUTION=300

GSFOLDER=kořenový adresář, ve kterém je nainstalován Ghostscript (při GHOSTSCRIPT=1) - default GSFOLDER=C:\Program Files\GS a GSFOLDER=C:\GS

EMAIL=0 - nebude odeslán email, i když je Subject uveden - default EMAIL=0

DROPPDF=0 - dokument PDF nebude po odeslání emailu zrušen - default DROPPDF=1

VIEWPDF=0 - nebude spouštěn Acrobat Reader pro prohlížení dokumentu ani v případě, že není odesílán email - VIEWPDF=1

AUTOINSTALLPATH=jiný adresář pro automatickou instalaci Ghostscriptu a postscriptové tiskárny (při GHOSTSCRIPT=1) - default AUTOINSTALLPATH=AUTOINSTALL

Parametr AUTOINSTALLPATH naznačuje, že může být při tisku automatizovaně prováděna instalace Ghostscriptu a postscriptové tiskárny, pokud nejsou na počítači uživatele nalezeny. Pro tuto instalaci je třeba vytvořit adresář podle tohoto parametru s podadresáři GHOSTSCRIPT a PSDRIVERS a do nich umístit jejich instalační EXE. Při nastavení AUTOINSTALLPATH=NO není automatická instalace prováděna.

Pokud je tedy v profilu nastaveno u ikony „spuštění předlohy“, u sestavy „na tiskárnu“ a „nastavení tiskárny“ není zaškrtnuto, dochází v běhu procesu u operace, která má nadefinováno, že po jejím ukončení probíhá tisk dokladu, k automatickému tisku sestavy přímo na tiskárnu (tisková předloha je nastavena v metapředloze).

Jednotlivé profily spuštění předloh je možno nastavit jak u metapředlohy, tak přímo u předlohy výstupu. Pokud uživatel chce, aby se předloha chovala jinak po spuštění předlohy a jinak pokud se jedná o tisk dokladu (tzn. tisk předlohy v metapředloze), nastaví příslušné profily spuštění předloh jak u metapředlohy, tak přímo u vlastní předlohy.

Pro uživatele je dále k dispozici možnost definice profilu spuštění předlohy pro předlohy typu Word. Výběr zda na tiskárnu/do souboru/prohlížení je stejný jako u předloh typu sestava a Excel. Další možnosti pro předlohy typu Word je nastavení těchto atributů:

¨ Digitální podpis

¨ Příprava e-mailu

¨ Uložit jako dokument BM

Tyto nastavení velmi úzce souvisí s nastavením těchto atributů přímo v definici dané předlohy Word. Nastavení přímo v předloze přitom mají přednost před nastavením v profilu. Pokud je u těchto nastavení v předloze nastaveno NIKDY, tak ať už je v profilu nastaveno cokoliv, výsledkem je, že při spuštění okna „zahájení výstupu dle předlohy“ jsou všechny tyto tři možnost nezaškrtnuté a šedivé (tzn. není povoleno měnit).

Další nastavení u těchto atributů v předloze je možno ANO a NE. V následující tabulce je popsáno předplnění atributů v okně „zahájení výstupu dle předlohy“ podle nastavení v předloze a profilu (při uplatnění nastavení platí směr zleva doprava).

Předloha | Profil | Okno „zahájení výstupu dle předlohy“
Ano | Volitelné | Povoleno měnit – zaškrtnuto
Ano | Volitelné Ano | Povoleno měnit – zaškrtnuto
Ano | Volitelné Ne | Povoleno měnit – nezaškrtnuto
Ano | Nevolitelné | Nepovoleno měnit – zaškrtnuto
Ano | Nevolitelné Ano | Nepovoleno měnit – zaškrtnuto
Ano | Nevolitelné Ne | Nepovoleno měnit – nezaškrtnuto
Ne | Volitelné | Povoleno měnit – nezaškrtnuto
Ne | Volitelné Ano | Povoleno měnit – zaškrtnuto
Ne | Volitelné Ne | Povoleno měnit – nezaškrtnuto
Ne | Nevolitelné | Nepovoleno měnit – nezaškrtnuto
Ne | Nevolitelné Ano | Nepovoleno měnit – zaškrtnuto
Ne | Nevolitelné Ne | Nepovoleno měnit – nezaškrtnuto

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 21.06.2010


Pojem - Prognózování odpisů

Tato činnost se nachází v hlavním menu – Odpisovaný majetek – Prognózování odpisů. Po aktivaci této činnosti se uživateli nejprve zobrazí záložka „Výběr“, kde si vybere období (tj. nadefinované účetní období v komponentě účetnictví), za které chce prognózu odpisů spočítat a případně i konkrétní kartu odpisovaného majetku. Prognóza poskytuje uživateli informace v jaké výši budou odpisy za zvolené období pokud se nezmění způsob odepisování. Tyto informace jsou přínosem v případě velkých firemních investic, aby měl podnik představu o svých nákladech na odpisy. Prognózování odpisů představuje pro uživatele nástroj, který mu poměrně přesně spočítá odpisy příštích let.

Tato činnost tedy uživateli poskytuje informace o vypočtených odpisech příštích let, tzn. odpisech za zbytek letošního roku a odpisech dalších let (podle období uvedeného na záložce „Výběr“). V podstatě tedy ukazuje finanční údaje týkající se hodnoty odpisů za vybrané i předchozí období.

Po nadefinování záložky „Výběr“ proběhne výpočet prognózy a uživatel má k nahlédnutí formulář, kde jsou ke každé řádce zvoleného období k dispozici následující atributy:

¨ období – název období (jedná se o účetní období, které uživatel definuje v komponentě Účetnictví – Speciální činnosti – Účetní období)

¨ artikl – identifikace druhu artiklu a identifikace artiklu

¨ název artiklu – název odpisovaného majetku (z karty)

¨ účetní odpis – částka účetního odpisu, která se ještě v daném období odepíše a dosud není odepsána

¨ pořiz. cena – hodnota z karty odpisovaného majetku

¨ zůst. cena – částka, která se očekává jako zůstatková cena na konci daného období (tzn. pořizovací cena mínus všechny uskutečněné a prognózované odpisy)

¨ daňový odpis – částka daňového odpisu, která se ještě v daném období odepíše a dosud není odepsána

¨ vstup. cena – hodnota z karty odpisovaného majetku

¨ zůst. cena – částka, která se očekává jako zůstatková cena na konci daného období (tzn. pořizovací cena mínus všechny uskutečněné a prognózované odpisy)

¨ počet odpisů – počet daňových odpisů, které se uplatnily (buď v události odepisování nebo v prognóze předchozích let) v předchozích účetních obdobích

¨ počet odp. ze zv. ceny – počet daňových odpisů po posledním technickém zhodnocení, které se uplatnily v předchozích účetních obdobích (buď v událostech nebo v prognóze)

Na následujícím obrázku si konkrétně vysvětlíme atributy počet odpisů a počet odp. ze zv. ceny. Karta odpisovaného majetku byla zařazena v r. 2006, tzn. že účetní období 2010 v prognóze správně uvádí, že počet odpisů je 4 (tzn. rok 2006, rok 2007, rok 2008, rok 2009). Aktuální účetní období (tzn. rok 2010) se nezapočítává. Obdobné je to s počty odpisů po provedeném technickém zhodnocení. Na naší ukázkové kartě bylo první technické zhodnocení provedeno v roce 2009, tzn. že období 2010 správně uvádí počet odpisů ze zvýšené ceny 1 (tj. v roce 2009).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 12.01.2009


Pojem - Programový adresář

Je to implicitní adresář IS BM, který se uživateli nabízí jako prvotní např. při vytváření exportu do balíčku nebo při externím uložení vytvořeného dokumentu apod. Jakékoliv automatické uložení informací nebo naopak jejich načtení probíhá z programového adresáře.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.10.2007


Pojem - Prohlížení archivu

Tato činnost je pro uživatele dostupná v hlavním menu v komponentě Informační centrum – Utility – Archivace – Prohlížení archivu. Uživateli se zde přehledným způsobem zobrazují jednotlivé nadefinované archivace (definice archivace se provádí v činnosti Popis archivací).

Po aktivaci této činnosti je v levém sloupci (ve stromovém zobrazení) k dispozici přehled nadefinovaných skupin archivací z činnosti Popis archivací a v pravé části formuláře jsou k dispozici vlastní archivace. V pravé horní části je vždy hlavní verze souboru archivace a v pravé dolní části jeho kopie (archivace je typu rozdílová, tzn. nearchivuje se vždy vše v daných souborech, ale to co se změnilo či přibylo). Třídění jednotlivých sloupců v pravé části formuláře lze provádět po stisku levého tlačítka myši.

Po stisku pravého tlačítka myši na archivacích ve stromu (levý sloupec) lze provést (totéž lze provést i u souborů):

¨ kopírovat adresář (soubor) „.....“

¨ přejmenovat adresář (soubor) „.....“

¨ odstranit „.....“

U přejmenování souboru platí, že v případě, že uživatel změní např. název souboru a nadále chce archivovat soubor do stejného stromu, je nutno opravit nejprve definici a pak teprve název ve stromu. Pokud uživatel opraví název archivace přímo v její definici (popis archivací) a nikoliv zde ve stromu, tak se nový název zde neprojeví. Tento soubor archivace je pak vhodné ze stromu odstranit, přejmenovat a archivaci spustit znovu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 29.10.2009


Pojem - Projektové řízení

V této oblasti se podpora IS Bílý Motýl® zaměřuje na definici projektu, na plánování projektových úkolů s řízením kapacit, na sledování a řízení plnění projektových úkolů a to vždy ve vztahu k cíli projektu a samozřejmě v procesních vztazích k ostatním oblastem, například k prodeji a nákupu, odměňování, výrobě, expedici, ale také třeba i ke správě majetku apod. Mezi nejdůležitější podmínky pro úspěšnost projektu patří jasná a srozumitelná komunikace o všem (co s projektem souvisí) všech zúčastněných: manažer projektu, členové projektového týmu, zákazník, jiná oddělení organizace, ...

Řízením projektu (projektem, někdy též zakázkou) rozumíme tedy takové manažerské činnosti, které jsou jedinečné s termínem zahájení a ukončení, využívají zdrojů vlastních i externích v součinnosti s ostatními činnostmi organizace a mají cíl definovaný specifikací parametrů předmětu projektu, rozpočtem nákladů a časovým plánem realizace. Mezi nejvýznamnější vlastnosti kromě obvyklých patří definice parametrů předmětu projektu a plná integrace projektového řízení s ostatními činnostmi organizace.

Přesná definice parametrů umožňuje automatizovaně porovnávat cíle různých projektů mezi sebou s následným převzetím zkušeností. Dále je pohodlné realizovat automatizovaně výběrová řízení na subdodávky s přesným zněním parametrů.

Integrace projektového řízení s IS Bílý Motýl® umožňuje automatizovaně realizovat (jednorázově i periodicky) plnění závazků a předpis pohledávek vyplývajících ze smluvních vztahů s projektem souvisejícím, a to i v závislosti na jiných informacích v IS uložených.

Všechny tyto části projektového řízení jsou provázány na další oblasti informační podpory společnosti zejména po stránce procesní, ale také z hlediska dokumentů, zpráv, manažerských informací apod.

Kromě informační podpory poskytované pro řízení „pravých“ projektů je možné tyto nástroje IS Bílý Motýl® použít i na sledování ostatních úkolů nebo na řízení kontinuálních činností nebo na poskytování služeb. V takové situaci například při řízení ostatních úkolů se nemusíme zabývat komplexním popisem předmětu projektu pomocí mnoha parametrů, ale vystačíme s krátkým textem, lze vyřadit plánování kapacit či nákladů a pouze sledovat pracovní výkon související s plněním úkolu, plnění termínů a dosažený výsledek.

Podobně lze redukovat komplexní projektové pojetí v případě poskytování služeb formou drobných zakázek, kdy předmět projektu může reprezentovat zákazníka, spravované zařízení apod., takže není nutné jej opakovaně specifikovat. Pro danou službu či jinou trvale opakovanou aktivitu může být definován jediný trvalý úkol, ke kterému se přiřazují všechna plnění v čase s vazbou na další oblasti informační podpory.

Přístup k celé oblasti projektů je řízen přístupovými právy, takže někdo si může projekty (či s jednotlivými parametry) prohlížet, jiný je může definovat. Podobně někdo smí zakládat a plánovat projektové úkoly, jiní je smí plnit ale jen určitými druhy plnění. Někteří uživatelé nemají žádný přístup.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 18.01.2008


Pojem - Projektové úkoly

Definice cíle projektu nám popisuje, CO má být výsledkem realizace daného projektu, tak projektové úkoly nám umožňují plánovat a řídit, JAK, s KÝM, KDY a za KOLIK tohoto cíle dosáhnout. Projektové úkoly fakticky představují uspořádanou posloupnost jednotlivých kroků, kterými se plánuje cesta neboli postup směřující k dosažení cíle projektu.

IS Bílý Motýl® umožňuje tyto kroky uspořádat do logicky navazující posloupnosti vyjádřené formou diagramu, ve které lze z hlediska řízení termínů definovat paralelní průběh některých kroků, fixovat termín pro zahájení nebo pro ukončení každého kroku a nastavit časový posun mezi jednotlivými projektovými úkoly, čímž lze vymodelovat libovolnou posloupnost projektových kroků v čase schopnou automatizovaného přeplánování.

Vytvoření projektových úkolů a jejich uspořádání (naplánování projektu) lze automatizovat aplikací generického projektu, kdy jsou projektové kroky a jejich posloupnost automaticky vygenerovány, tj. jsou odvozeny od jiného již existujícího projektového plánu s možností dalších změn. Současně je k dispozici automatizované přeplánování projektových úkolů pro případ změn, přičemž je respektována disponibilní kapacita jednotlivých zdrojů (řešitelů) dle jejich kalendáře. V případě přeplánování, ale i v případě jiných změn (např. změna plánovaných nákladů) projektového úkolu, je k dispozici historie těchto změn.

Mezi nejdůležitější údaje při plánování času na projektu patří datum začátku a konce (trvání) projektového úkolu a druh úkolu mimo jiné definující možné (povolené) zadavatele a řešitele, zda se jedná o milník, implicitní nastavení zpráv manažerům projektu a možné druhy odváděných prací (plnění). Dále sem patří tyto údaje - konkrétní zadavatel úkolu, tj. obvykle osoba kompetentní měnit daný naplánovaný úkol, konkrétní řešitel úkolu, který je oprávněn k danému úkolu evidovat jeho plnění, popis úkolu a adresát, kterého se daný úkol týká (například zakázka pro něj). Lze též aplikovat skupinové řešitele.

Klíčovým údajem pro řízení je stav projektového úkolu (plánovaný, připravený, zahájený, …, ukončený) a procento plnění. Tyto údaje jsou automaticky aktualizovány ze záznamů o dílčím plnění projektového úkolu. Za účelem automatizované kontroly nad projektem je možné definovat zprávy, které se automaticky odešlou vedoucímu projektu při změně zahájení nebo ukončení projektového úkolu anebo v případě ukončení takového projektového úkolu, který mění stav celého projektu. K dispozici je též možnost nastavit si zprávy s připomínáním v uvedeném termínu, ať již pro řešitele nebo manažera úkolu, ale i jiným účastníkům.

K dosažení maximální orientace v projektových úkolech dle jednotlivých řešitelů je určen harmonogram (grafické vyjádření s detailem v samostatném okně – viz obrázek), kde lze pohodlně „tažením myši“ úkoly přeplánovat.

V případě, že je projektové řízení z IS Bílý Motýl® aplikováno na podporu aktivit, jako je poskytování „drobných“ služeb nebo realizace „drobných“ zakázek nebo jako jsou kontinuální činnosti (prodej, marketing, správa majetku, …), pak je projektový úkol definován jen jednoduše - obvykle jediný, bez časového omezení a se skupinovým řešitelem, což umožní pohodlný záznam plnění (odvádění práce) celé řadě řešitelů. Má-li projekt naplánovánu posloupnost kroků (časový plán - projektové úkoly), umožňuje IS Bílý Motýl® evidovat uskutečněná plnění (např. odvedené pracovní výkony) ke každému úkolu dle jednotlivých řešitelů. Tím je k dispozici úplný přehled o objemu prací včetně údajů kdy, kým a jak byly uskutečněny, mnohdy ve vazbě na jiné aktivity společnosti formou procesů.

Každý záznam o plnění referuje odpovídající projektový úkol, který je aktualizován procentem přírůstku plnění, sumarizuje uvedený objem času k uvedenému řešiteli a je určitého druhu, což umožňuje nejen určité členění, ale také aplikaci takových plnění, které automaticky změní stav projektového úkolu.

Technika dynamických transformací společně s procesním uspořádáním umožní uživateli automatizované založení nového projektového úkolu dle dosaženého výsledku na realizovaném projektovém úkolu, což umožní dynamicky řídit další postup projektu dle vývoje situace. Tj. na základě dosaženého mezivýsledku projektu (zakázky, obchodního případu, poskytování služby či jiné aktivity) je automaticky naplánován další krok postupu (projektový úkol).

Přehled plnění projektů lze prezentovat harmonogramem, ale také celou řadou hodnotících výstupů včetně pohodlných analýz na informačních panelech. Informační panely s aplikací webserveru umožňují také pohodlné řízení projektů na firemním intranetu včetně pohodlného odvádění práce jednotlivými řešiteli přímo do IS, kteří zde mají stále na očích své dosud nesplněné úkoly.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 17.01.2008


Pojem - Proměnná dotazu

Proměnná dotazu je (podobně jako proměnná výběru) uživatelsky definovaná proměnná, která je parametrem použitelným v definici výkazu i jeho prvků a po nabytí hodnoty při sestavení výkazu. Použitelné typy proměnných jsou N, C, D a T.

V případě definice jejího naplnění vstupem je možné uvést její implicitní hodnotu výrazem a umístit ji v rámci designu vstupního formuláře.

V případě definice jejího naplnění výpočtem je nutné uvést výpočtový výraz, ve kterém lze užít proměnné naplněné vstupem v syntaxi [promvst].

Proměnné jsou současně parametry výkazu s identifikátorem shodným s názvem proměnné.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Proměnné daňového přiznání

Proměnné daňového přiznání má uživatel k dispozici v činnosti „daňová přiznání“ po stisku klávesy F7 nebo aktivaci činnosti „Proměnné daňového přiznání“ pod menu Volby. Uživatel musí mít kurzor umístněn na definici daňového přiznání, které počítal, tzn. na tom řádku s definicí, na kterém aktivoval výpočet daňového přiznání.

Po aktivaci této činnosti se mu nejprve nabídne záložka „výběr“, kde si jako období zvolí příslušný rok a po uložení výběru (ikona „disketa“) se mu zobrazí proměnné daňového přiznání.

Do proměnných daňového přiznání je nutno zadat pro každou novou verzi daňového přiznání alespoň jednou hodnotu zálohového koeficientu „1“, v případě potřeby krácení příslušnou hodnotu zálohového koeficientu vždy pro konkrétní rok. Význam dalších proměnných je uveden v poznámce daného daňového přiznání – jedná se o ručně zadávané hodnoty do konkrétních řádků daňového přiznání. Pokud má uživatel k dispozici platné definice daňového přiznání, správně vyplněné atributy na volné kartě a proměnné daňového přiznání, může přistoupit k vlastnímu výpočtu daňového přiznání.

Pokud nejsou proměnné pro vypočítávané období definovány, dochází automaticky ke kopírování proměnných daňového přiznání a jejich nastavení na nulovou hodnotu. Tu je následně nutno uživatelsky opravit.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 12.02.2015


Pojem - Propojené (vložené) objekty

Jedná se o objekty, které uživatel do IS BM vložil pomocí činnosti prezentace. Po spuštění činnosti „vložit objekt“ (horní lišta – činnost Úpravy) má uživatel možnost si zvolit, zda chce vložit objekt nový či již vytvořený ze souboru. V případě nového objektu je nutno určit typ souboru.

V případě vkládání objektu ze souboru je nutno určit cestu, odkud se má vložit (pro vyhledání daného souboru možno využít i tlačítka procházet). V případě zaškrtnutí „propojit“ bude vložený objekt propojen ze souborem, takže změny provedené v souboru se automaticky projeví i v tomto vloženém objektu.

U obou možností vložení objektu může uživatel využít zaškrtávátko „zobrazit jako ikonu“, které způsobí, že vkládaný objekt se bude v okně prezentace zobrazovat jako ikona (je možno ji změnit tlačítkem „změnit ikonu“) a po dvojkliku myši na této ikoně se zobrazí celý obrázek (tzn. vložený objekt) v samostatném okně v plné velikosti.

Pod horní lištou – menu Úpravy má uživatel k dispozici další činnosti, které může použít při práci s vloženými objekty, tj. kopírovat, vyjmout, vymazat apod.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Prostředí pohledu (slovníku dat)

Skupina definic pohledu dat, která definuje zejména datový submodel IS pro daný pohled. Součástí je též definice doplněných oken, která se uplatňuje pouze při užití pohledu na webu.

Poznámka: Relace 1:M (výchozí entita : následná entita), které umožňují takto vztažená data prezentovat na webu pod připojeným oknem, se v praxi neosvědčila jako plně vhodná.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Protokol mezd

Činnost „protokol“ má uživatel k dispozici v menu Mzdy – Mzdy – Protokol strukturovaný. K dispozici jsou strukturované protokoly, které se automaticky vytvářejí při výpočtu mezd, při uzávěrce mezd a při přepočtu průměrů, tzn. že během jednoho měsíce může mít uživatel i několik protokolů. V této činnosti si je může uchovávat nebo v případě potřeby i rušit. U každého protokolu jsou k dispozici tyto údaje:

¨ typ hlavičky – tzn. čeho se daný protokol týká (výpočtu mzdy, uzávěrky, přepočtu průměrů, přepočtu pro nepřítomnosti)

¨ pořadové číslo protokolu

¨ období – které období daný protokol představuje

¨ poslední zpracované mzdy k datu – informace o datu posledního zpracování mezd

Vlastní položky protokolu si lze prohlédnout po stisku funkční klávesy F6 nebo volbou činnosti „položky protokolu“ pod menu Volby. Položky je možno zobrazit celkově za organizaci nebo např. pouze za konkrétního pracovníka. Obsahují určité nesrovnalosti nebo chybová hlášení např. typu: Pracovník nemá pro zpracovávané období na Kartě určenu žádnou zdravotní pojišťovnu. Bylo to zjištěno na položce I11000.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 31.01.2008


Pojem - Průběh operací

Průběh operací (zobrazuje uzly typu operace i uzly typu proces, pokud jsou ve stavu připravena) je činnost, kde uživatel má k dispozici přehled těch uzlů, u kterých došlo od okamžiku jeho přihlášení do IS a jeho přičiněním ke změně jejich stavu, prohlížení uzlů zde zachyceno není. Průběh operací je v každé činnosti v IS dostupný v menu Obecné. Uživatel má k dispozici tyto údaje:

¨ datum

¨ identifikace operace

¨ název druhu

¨ stav (tzn. připravena, zahájena, ukončena apod.)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Prvek web

Prvkem web v rámci IS Bílý Motýl se rozumí položka web menu zobrazovaného pomocí internetového browseru vzdálenému uživateli. Prvky web se uživatelsky definují v činnosti Definice Web menu ve skupině SYSTÉM. Každý prvek web je určitého druhu, pomocí kterého jsou standardně zajištěna přístupová práva. Prvky web lze rozdělit do několika typů, které jim přiřazují základní vlastnosti.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Přecenění Z/P v cizí měně koncem roku

Přecenění plateb kurzem ke konci roku uživatel provede procesem Kursový rozdíl platby – uzávěrka (v hlavním menu činnost Nový proces – Úhrady a jiné změny stavu peněz).

Před vlastním spuštěním tohoto procesu je nutno nastavit kurz k 31.12. daného roku u všech přeceňovaných měn (v hlavním menu Informační centrum – Oceňování - Měny a kursy).

Proces je možné spouštět opakovaně, systém vybere vždy zatím nepřeceněné závazky/ pohledávky. Z toho vyplývá skutečnost, že přecenění je vhodné provést co nejdříve po ukončení roku a po provedení inventury závazků a pohledávek. Doporučujeme přecenit závazky/pohledávky vždy před úhradou.

Samotné načtení přeceňovaných plateb se spouští přes doplňující vlastnost formuláře „Update podle kursu“ (pod menu Volby). Nedoporučujeme povolit duplicitu variabilních symbolů plateb. V případě duplicity je třeba rozlišit variabilní symboly plateb pouze pro přecenění a poté opravit zpět na původní.

obr. 1

Vytvořené události pouze zapsat (tzn. po volbě zapsání dat – disketou nebo po stisku ESC – zvolit možnost ZAPSAT) a dále pracovat obdobně jako při automatickém párování výpisu z běžného účtu – F6, F6, Esc, potvrdit zapsání změn. Po ukončení události přecenění následuje zaúčtování hodnoty přecenění.

V případě, že uživatel nastaví v atributu „Povolit duplicitu – ANO“, nesmí využívat možnosti automatického párování (F6 – F6), je nutno VŽDY PÁROVAT RUČNĚ, tzn. F6 – F5.

obr. 2

Důležitá poznámka pro implementátory (specifická vlastnost systému):

Při běžném chování událostí ZSP platí, že „credit“ kladně v událostech ZSP hodnotu pohledávky snižuje (tzn. peníze plus, pohledávka mínus). Při použití doplňující vlastnosti "Update dle kursu" pro přecenění Z/P koncem roku se vytvoří událost ZSP „credit“ (pro pohledávku) a zvýšení hodnoty pohledávky v CZK z titulu zvýšení kursu zapíše kladnou hodnotu v CZK (nula ZM), i když by na události ZSP logicky správně měla být hodnota „credit - mínus". Hodnota „dosud neuhrazeno v RM“ na záložce Plateb je ovšem vždy správně. Správně není pouze znaménko na události ZSP, kterou vypočítal systém jako kurzový rozdíl koncem roku. Tato specifická vlastnost se uživateli nemusí nikdy projevit, problém nastává pouze v případech konkrétních implementačních nastavení pro uživatele, tzn. sestava „platby k datu“ na míru uživateli, volná karta či doplňující vlastnost formuláře.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.01.2010


Pojem - Předkontace adresáta

V případě, že definice obecné předkontace (Informační centrum - Typy a řady) má zatržen atribut "předkontace adresáta", je v takovém případě obecná předkontace dostupná i z adresáře. Předkontaci adresáta lze vyvolat volbou příslušné činnosti z menu Volby nebo po stisku klávesy F7. Nejčastěji definovanou předkontací adresáta je individuální nastavení splatnosti pohledávky.

V případě, že v obecných předkontacích je vytvořena i obecná předkontace typu BMSPL2, pro niž platí, že datum splatnosti pohledávky se vztahuje k datu zdanitelného plnění, tak se uživateli zobrazuje následující nabídka:

¨ splatnost je vzhledem k DZP – tuto možnost uživatel využije v případě, že implicitní dobu splatnosti pohledávky chce vztahovat k datu zdanitelného plnění (tzn. tj. shodné s datem platby). Pak se datum splatnosti pohledávky tvoří způsobem: datum platby + uvedená individuální implicitní doba splatnosti pohledávky. V případě, že datum splatnosti chce uživatel takto využívat, musí v tomto atributu mít uveden text začínající malým nebo velkým písmenem A (např. Ano).

¨ splatnost pohledávky – individuální počet dní splatnosti pohledávky daného adresáta

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.12.2009


Pojem - Předloha dokumentu

Tato činnost umožňuje uživateli nadefinovat, pomocí jakého externího programu bude zpracován dokument dané předlohy a dále umožňuje předdefinovat obsah tohoto dokumentu (tuto možnost využije uživatel např. při zpracování smluv, zápisech z porad, zasílání jednotných obchodních informací apod.). K dispozici jsou následující údaje:

¨ předloha - identifikace a název předlohy

¨ druh dokumentu – identifikace druhu předlohy. K druhu předlohy je možno nadefinovat přístupová práva a tím je vlastně nadefinováno i přístupové právo k předloze, která má u sebe uveden daný druh předlohy. Přístupové právo může nabývat hodnot čtení a zápis. V činnosti „dokumenty“ nebo při vytváření dokumentu po stisku Ctrl D na událostech se pak práva k předlohám uplatňují takto:

¨ uživatel může založit nový dokument s předlohou výstupu, ke které má přístupové právo čtení nebo zápis

¨ přístup k existujícím dokumentům je řízen právy spojenými s druhem daného dokumentu (tj. uživatel může číst nebo opravovat dokumenty vytvořenými na základě předloh dokumentů, ke kterém nemá právo přístupu čtení ani zápis)

¨ aplikace - identifikace a název spouštěného programu (např. Word, Excel ...)

¨ blokování - příznak blokování dokumentu předlohy proti opravě. Ostatní uživatelé mohou na základě této předlohy vytvářet dokumenty, ale nesmí opravovat tuto vytvořenou předlohu.

¨ prázdná předloha - příznak nevytvoření implicitní předlohy a současně i blokování proti opravě. Tzn., že i když je zde nějaká předloha nadefinovaná, při zatržení tohoto příznaku se bude vždy spouštět prázdná předloha.

¨ mailmerge - příznak vytváření mailmerge. Jedná se o funkci, pomocí které je možno vytvořit řadu podobných dokumentů (např. dopisy), lišících se pouze v několika výrazech (adresa, oslovení ...). Potom stačí mít dva dokumenty, hlavní dokument se standardním (neměnným) textem a datový soubor obsahující údaje, které se budou měnit (databáze adres). Po vyvolání předlohy s příznakem mailmerge v aplikaci Word je pak postup následující - uživatel použije činnost Wordu "hromadná korespondence" a potvrdí příkazy "sloučit" (2x). Potom může mít několik dopisů s naprosto shodným textem, ale rozdílnou adresou příjemce.

¨ cesta pro soubor mailmerge, soubor mailmerge, přípona souboru mailmerge - vlastní definice mailmerge. Pokud nejsou tyto parametry u jednotlivých předloh nadefinovány, hlásí systém chybu a nedovolí danou předlohu zapsat.

¨ komentář - komentář, který detailně popisuje význam předlohy

¨ aktuální – zda je daná předloha aktuální (tzn. používaná) nebo je zde pouze historicky

¨ založil - jméno uživatele, který předlohu vytvořil

¨ datum, čas - datum a čas vytvoření dané předlohy

Na záložce „další“ je možno definovat:

¨ Skript – text v jazyce Foxpro spouštěný bezprostředně po otevření dokumentu, resp. předlohy dokumentu externím programem (tzn. je-li předloha dokumentu vytvořena na základě aplikace Word, spustí se tento skript po aktivaci dokumentu vytvořeném na základě této předlohy v okamžiku spuštění aplikace Word). Příklady skriptu jsou popsány ve slovníku pojmů.

Kód skriptu v jazyce Foxpro je vyvolán s parametry:

- _this - objekt - řídící objekt BM, který otevírá dokument

- _sp26 - jednoznačná časová identifikace dokumentu BM resp. předlohy dokumentu

- _predloha - logická hodnota nabývající hodnotu .T. (TRUE), pokud je opravována předloha dokumentu

- _workfile - název pracovního souboru, ve kterém je opravován dokument resp. předloha dokumentu

- _poprve - logická hodnota nabývající hodnotu .T. (TRUE) při první opravě dokumentu

¨ definice pro konvertor Winword - text

Na záložce „užití dokumentu“ jsou k dispozici údaje, který uživatel danou předlohu kdy užil a za jakým účelem (čtení, zápis apod.).

Příklady skriptu:

Příklad skriptu s použitím konvertoru WINWORD - skript při prvním otevření dokumentu předplní tento dokument textem charakteru e-mail.

Vlastnost Skript obsahuje:

<pre>

LOCAL _o,_sql

IF !_poprve OR _predloha

* konverze nebude provedena, pokud je otevírána předloha nebo se nejedná o první otevření dokumentu

RETURN

ENDIF

* proměnná _SQL bude obsahovat sql dotaz pro zjištení hodnot z události vývěsky spojené s dokumentem

* všimněte si použití parametru _SP26

TEXT TO _sql TEXTMERGE NOSHOW

select first vyudalos.*,adspoj.ad11email,adadsat.ad01adsat

from

%%%.bwobject,%%%.vyudalos,%%%.adadsat,%%%.adspoj

where

bwobject.bw09inst2='<<_SP26>>' and

bwobject.bw09typ2='DD' and

bwobject.bw09typ1='VY' and

vyudalos.vy01=bwobject.bw09inst1 and

adadsat.ad01id=vyudalos.ad01id and

adspoj.ad01id=vyudalos.ad01id and

adspoj.ad11cisspo=vyudalos.ad11cisspo

ENDTEXT

* konvertor používá data kurzoru SQL_TISK

IF !bw_exec(.F.,_sql,'sql_tisk')

RETURN

ENDIF

* volání uložené procedury BW_OWRD vrací instanci objektu konvertoru WINWORD

_o=bw_owrd()

* metoda ADDPROPERTY přidává v instanci objektu vlastnost WORKFILE s názvem pracovního souboru dokumentu tak,

* aby konvertor vytvořil soubor s tímto názvem (viz. definice konverze)

_o.addproperty('workfile',_workfile)

* TOOL.OLEOBJ[2] obsahuje při aktuálním spuštění skriptu odkaz na objekt aplikace Wordu

* dokument ve Wordu musí být uzavřen - konvertor ho znovu otevře resp. vytvoří s jiným obsahem (pokud je v definici konverze určena předloha)

tool.oleobj[2].activedocument.close

* metoda GET_DEFKONV řídícího objektu otevření dokumentu vrátí obsah definice pro konvertor uvedený u předlohy dokumentu

* metoda GO objektu konvertoru spouští konverzi - druhý parametr .T. musí být uveden (určuje, že se nejedná o konverzi podle předlohy výstupu)

_o.go(_this.get_defkonv(),.T.)

</pre>

- vlastnost Definice pro konvertor WINWORD obsahuje (všimněte si nastavení .FILE this.workfile)

.WINWORD 1.0

* SPRÁVCE 16.03.2007 15:26:11

.FILE this.workfile

.FILEFORMAT 1

.TEMPLATE 'K:\BMSQL\template\email.dox'

.EMAIL_ADDRESS

ad11email

.ENDEMAIL_ADDRESS

.EMAIL_SUBJECT

vy01text

.ENDEMAIL_SUBJECT

.EMAIL_WORD

.EMAIL_IMPORTANCE 1

.BWPRINTD_BW04WRDEMA

.GROUP

.TABLETYPE 3

.FROM 1

.BORDERS

.ELEMENT body

.EXPR vy01koment

.COMMENT

Komentář, který detailně popisuje událost. - M(10,0)

.ENDCOMMENT

.ELEMENT BWUZIVAT_bw01jmeno

.LABEL "Zapsal"

.EXPR tool.jmenot

.COMMENT

Jméno uživatele systému - C(17,0)

.ENDCOMMENT

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 02.04.2010


Pojem - Předloha výstupu

Předlohy výstupu jsou definice, na základě kterých jsou realizovány výstupy v rámci činností IS BM. Tyto výstupy jsou vlastností téměř každé činnosti typu seznam (lze je vyvolat stiskem ikony “výstup”, volbou činnosti Tisk z menu Volby, stiskem klávesy Ctrl T nebo pomocí doplňujících vlastností formuláře, kódu po ukončení, klávesy F11 a F12). Předlohy výstupu a tím i výstupy mohou být podle nástroje pro jejich zobrazení typu:

¨ sestava – klasická tisková sestava (lze i ve formátu PDF nebo TIFF)

¨ Excel – sestava typu Excel (lze ji odeslat i e-mailem)

¨ ostatní – HTML sestavy (lze ji odeslat i e-mailem)

¨ Word – sestava typu dokumentu Word (lze ji odeslat i e-mailem)

Tisk na základě vytvořené předlohy výstupu uživatel využije kdekoliv, např. při:

¨ tisku operací,

¨ tisku procesů (tj. dokladů),

¨ tisku přehledu událostí, číselníků apod.

Každý výstup probíhá na základě vytvořené předlohy výstupu. Každá předloha se skládá ze své definice a vlastností předlohy. U předloh typu „sestava“ je možno při jejich definování využít i předdefinované vzory výstupu. Předlohy výstupu lze vložit do definice metapředlohy s řadou dalších definic, což se užije zejména u procesů a operací. U každé předlohy je možno nastavit reakci po její aktivaci uživatelem. Tato reakce je uživatelsky ovlivnitelná profilem spuštění, který je k dané předloze přiřazen, a který ovlivňuje chování předlohy po její aktivaci, tzn. zda má následovat přímo spuštění předlohy nebo rozhodnutí. Pro předlohy typu „sestava“,„excel“ a „word“ se v profilu určuje směrování výstupu (tiskárna/do souboru/prohlížení). V předlohách výstupu typu „sestava“ je při směrování výstupu do „prohlížení“ možno využít i atribut „v prohlížeči výstupů předloh“, který uživateli umožnuje nemodální prohlížení předloh výstupů. Pro předlohy typu „sestava“ se navíc určuje, zda má při výstupu předlohy na tiskárnu předcházet dotaz na výběr tiskárny a pro předlohy typu „word“ se ještě nastavuje předplnění atributů „digitální podpis, příprava e-mail a ukládat jako dokument BM“. Uvedení logické tiskárny v předloze výstupu umožňuje definovat pro různá uživatelsky definovaná pracoviště (každé může zahrnovat několik fyzických počítačů) různé fyzické tiskárny.

Předlohy výstupu je možno řadit do uživatelsky vytvořených skupin, zároveň může uživatel mít nadefinovánu i osobní skupinu předlohy výstupu.

V rámci výstupů lze realizovat i určité „neočekávané“ akce, např. odeslat e-mail. Druh předlohy umožňuje definovat přístupová práva k výstupům, což má význam zejména proto, že pomocí doplnění lze do každého výstupu doplnit i citlivé informace.

Hodnoty zadané v obecném výběru je možné definovat v předloze výstupu výrazem:

this.otec.obec_vyber.p[<pořadí>], kde pořadí je pořadové číslo proměnné výběru.

Aby předloha fungovala také bez obecného výběru, je vhodné otestovat typ hodnoty výrazu např.: pro hodnotu obecného výběru typu datum:

IIF(TYPE('this.otec.obec_vyber.p[1]')='D',this.otec.obec_vyber.p[1],{})

Hodnoty proměnných zadaných v obecném výběru lze využít v předlohách výstupu v záložce doplnění. Hodnota proměnné obecného výběru se musí uvést otazníkem, viz. příklad:

(SELECT ISNULL(SUM(OBUDAL.dp02czarm),0) FROM %%%.OBUDAL OBUDAL WHERE

ADADSAT.ad01id=OBUDAL.ad01id AND OBUDAL.ob02dat between '2000/1/1' and

'2000/12/31' AND OBUDAL.sp07idtyp LIKE 'dod%' AND OBUDAL.sp11idzak LIKE

?thisform.obec_vyber.p[2])trzba[1]

Předlohy výstupu lze koncipovat i cizojazyčně a to i pro několik jazyků současně.

[1] Doplňuje sestavu nad adresářem o atribut trzba obsahující sumu tržeb adresáta (události operací začínajících znaky ‘dod’) za rok 2000, a to za organizační selektor (resp. jeho začátek), který je zadán uživatelem do proměnné obecného výběru.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 09.07.2013


Pojem - Předloha výstupu - proces

Tyto předlohy se od ostatních odlišují tím, že jsou postaveny na základě prezentace procesu a používají se pro tisk dokladů. Předlohy lze využít pro výstup i v jiných činnostech (např. z událostí), než do které přísluší (jsou vlastností činnosti Procesy a operace – Procesy).

U každého druhu procesu lze definovat tuto implicitní předlohu, podle které se proces (jeho operace) bude prezentovat v tištěné podobě. U druhu procesu se udává pouze název metapředlohy výstupu (výběr z překryvného seznamu), vlastní definice těchto předloh se provádí v činnosti Procesy a operace – Procesy. V případě potřeby je možno v definici metapředlohy uvést více předloh výstupu, z nichž při vlastním "běhu" procesu si uživatel v okamžiku tisku zvolí z těchto předdefinovaných předloh.

V diagramu daného druhu procesu se u určité operace v jejích vlastnostech definuje tisk dokladu, který je možno zajistit i bez zásahu obsluhy[1].

Po spuštění vlastností předlohy výstupu se na záložce „popis” uvede příslušná prezentace. Pro tisk dokladu je nutno, aby data pro tisk byla správně setříděna. Setřídění je možno provést takto:

¨ při vlastní editaci předlohy[2] tím, že se správně vytvoří skupiny (seskupení dat). Pokud předloha obsahuje více skupin, za které je setříděna, měla by první skupina být setříděna za identifikaci dokladu (rok, číslo, IDÚ). Implicitní setřídění operací jednotlivých komponent určuje nadefinovaná prezentace.

¨ ve vlastnostech předlohy na záložce „setřídění” je možno zadat pouze vlastní setřídění událostí jednotlivých operací (např. [OBC]obudal.sp61id+obudal.sp60id – setřídí události operací z komponenty obchod dle artiklu).

¨ pro tisk atributů mimo pořadí operací (např. datum splatnosti v hlavičce faktury) je k dispozici funkce bw_tiskh (např. bw_tiskh(‘PLA’,’atribut pro tisk’)).

[1] Tato vlastnost se nastavuje přímo u dané předlohy. Po stisku pravého tlačítka myši si uživatel vyvolá vlastnosti předlohy a zvolí atribut „tisknout bez zastavení“. Po ukončení operace, která má nadefinovánu takovou implicitní předlohu probíhá tedy rovnou tisk na implicitní tiskárnu.

[2] Editace předlohy se provede po stisku pravého tlačítka myši (činnost opravit předlohu) nebo po stisku druhé ikony zleva (oprava předlohy) na obrazovce předloh výstupu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.04.2004


Pojem - Předloha výstupu typu – Excel

Stejně jako u předloh typu „sestava“ nebo „word“ je nutno nejprve u nové sestavy typu „excel“ nadefinovat položky, které mají být v sestavě obsaženy. Po stisku ikony „opravit předlohu“ se uživateli nabízí okno „výběr položek zahrnutých do nové předlohy“. Přesunem položek z levé části okna do pravé si uživatel vybírá ty atributy, které mají být součástí nové definice sestavy typu „excel“. Po jejich nadefinování a stisku ok se mu nabízí okno s vlastní definicí předlohy. Po stisku ikony „oprava předlohy“ se mu stejné okno zobrazí už i u nadefinovaných předloh výstupu. V okně „výběr položek zahrnutých do nové předlohy“ se definuje i typ předlohy excel. Je možno definovat předlohy dvojího typu:

¨ deklarační – tento typ se předplňuje implicitně („excel typu1“) a definuje se pomocí Editoru deklaračních předloh výstupu do Excelu

¨ programový – aktivuje se, pokud uživatel zaškrtne atribut „excel typu2“. Je tvořen tzv. pseudokódem a upravuje se pomocí textového editoru Foxpro (viz. Popis jazyka generátoru sestav).

Pro možnost odesílání vytvořených dokumentů Excelu 2007 z IS BM e-mailem partnerům, kteří používají nižší verze Excelu byl v činnosti nastavení programu BM vytvořen parametr:

¨ Preferences -> Excel_Fileformat – slouží k určení formátu výstupního souboru Excelu vytvářeného předlohami výstupu typu Excel. Tento parametr může obsahovat jednu nebo více definic pro různé verze Excelu oddělených středníkem. Každá tato definice obsahuje číslo verze Excelu, po kterém za pomlčkou následuje číslo formátu souboru Excelu,

např. Excel_Fileformat=12.0-56

Číslo verze Excelu je dostupné v aplikaci Excel v činnosti Nápověda – O aplikaci Microsoft Office Excel – tlačítko Systémové informace – Microsoft Office Excel – Souhrnné informace.

Editor deklaračních předloh výstupu do Excelu obsahuje tři záložky:

¨ list

¨ sloupce

¨ skript

Záložka „LIST“

¨ název listu – určuje název listu v Excelu, výraz v syntaxi Foxpro (obvykle textová konstanta) – „vlastní název“

¨ soubor – určuje výstupní soubor předlohy - uložení (tzn. cesta k souboru) je nadefinováno (Nastavení IS BM – Preferences Excel_Output_Path) a zde se uvádí přímo název souboru, např. prehled_faktur.xls nebo výraz v syntaxi FoxPro uvedený znakem '~' (vlnovka), který vrací textovou hodnotu, která určuje název výstupního souboru (tzn. že uživateli se pak do zvoleného adresáře ukládá vytvořená předloha Excel s názvem „výsledovka 01-2008, další soubor „výsledovka 02-2008“ apod.)

- není uvedena defaultní cesta pro výstupy Excelu – pak se soubor ukládá do adresáře IS BM

- je uvedena absolutní adresářová cesta

¨ šablona – určuje šablonu (přípona XLT), na základě které se založí list. Šablona je uložena v adresáři TEMPLATE v IS BM.

¨ R-Agregace – výraz v syntaxi Foxpro – řádková agregace – po sobě následující zpracovávané záznamy, pro které je hodnota vyhodnocení záznamu shodná, budou sloučeny do jednoho řádku vystupujícího do Excelu a přitom jsou načítány hodnoty ve sloupcích, ve kterých je definována hodnota

¨ třídění – před vlastním tiskem se data třídí podle zde uvedeného výrazu (v syntaxi Foxpro) - v 99% se výraz třídění rovná výrazu v R-Agregaci. Pokud chceme v R-Agregaci nebo v třídění použít ALIAS z doplnění, je nutno ho definovat v deklaraci (ve vlastnostech předlohy)

¨ podpis ř.1, ř.2 a ř.3 – při definování nové předlohy jsou tyto údaje předplněny, je možno je libovolně upravit. Jedná se o výrazy v syntaxi Foxpro, které jsou vloženy v řádcích na konec listu

¨ Textframe – výraz v syntaxi Foxpro – využíváme v případě, že údaje z podpisů nechceme mít na konci listu, ale např. nahoře v záhlaví listu (nadefinován textový rámec). Předpokládá se však, že se tento rámec vyskytuje v šabloně.

¨ 1. řádek – numerická hodnota – určuje první řádek výstupu na listu (kde se začínají tisknout data)

¨ 1. sloupec – numerická hodnota – určuje první sloupec výstupu na listu

¨ celková suma – překryvný seznam – Ano/Ne/Ano tučně/Ano kurzívou/Ano tučně+kurzívou – odpovídající hodnota způsobuje vytvoření závěrečného součtového řádku za všechny řádky listu v požadovaném formátu

¨ automatický formát – zaškrtnuté způsobí přizpůsobení šířky sloupců

¨ tisk na šířku – zaškrtnuté způsobí nastavení tisku na šířku

¨ rychlý výstup – zaškrtnuté urychluje výstup do Excelu – zde je problém s diakritikou, rychlý výstup je vhodný pouze pro sestavy, kde nejsou texty

¨ kontrola otevření – zaškrtnuté nedovolí opakovaný výstup předlohy Excel v situaci, kdy uživatel neuzavřel soubor v Excelu vytvořený posledním použitím stejné předlohy nebo jiné předlohy provádějící výstup do stejného souboru

¨ soubor neukládat – zaškrtnuté způsobí zrušení souboru na disku po jeho uzavření v Excelu. Zrušení souboru proběhne pouze v případě, že byl soubor v Excelu uzavřen před vlastním ukončením programu BM.

¨ tlačítko OK – uložení změn a ukončení formuláře

¨ tlačítko Storno – ukončení fomuláře bez uložení změn

¨ tlačítko Editor – vyvolá editor (Foxpro) se vstupem dané definice (pseudokód)

V definici předlohy výstupu Excel „typu 2“ lze použít příkaz:

.KONTROLA_OTEVŘENÍ,

který způsobí to, že předloha nedovolí opakovaný výstup do Excelu v situaci, kdy uživatel neuzavřel soubor v Excelu vytvořený posledním použitím stejné předlohy nebo jiné předlohy provádějící výstup do stejného souboru. Tento příkaz musí být uveden před příkazem .EXCEL_OTEVŘI.

Záložka „SLOUPEC“

¨ seznam sloupců – je možné je libovolně přesouvat

¨ nadpis – výraz v syntaxi Foxpro – obvykle textová konstanta (např.:„název adresáta“)

¨ název sloupce – text – je určen pro definování sloupců typu vzorec (např. pro jednotlivá čtvrtletí mohou být sloupce nazvány Q1, Q2 apod.)

¨ typ – překryvný seznam, který může nabývat hodnot:

- text – znakové a datumové položky (typu „char“)

- hodnota – numerické hodnoty (typu „numeric“)

- vzorec – výpočtové sloupce, kde se používají právě názvy sloupců (např. při názvech sloupců pro čtvrtletí Q1 až Q4, je zde pak uvedeno Q1+Q2+Q3+Q4)

¨ výraz obsahu – pro typy text nebo hodnota - výraz v syntaxi Foxpro, pro typ vzorec – text odpovídající výpočtovému výrazu v Excelu, ve kterém je mžné uvádět odkazy na sloupce pomocí názvů sloupců v hranatých závorkách

¨ formát – text – obvykle určuje formátování čísla (např. ##,###.00)

¨ šířka – numerická hodnota – nepovinný údaj – určuje pevnou šířku sloupce

¨ font – styl písma – vybírá se z překryvného seznamu

¨ ohraničení – výběr z překryvného seznamu – způsob ohraničení sloupce

¨ suma – pokud je v definici listu zaškrtnuta suma, automaticky se vysoučtuje i za sloupec. Pokud v definici listu suma není, možno ji zde zaškrtnout přímo pro daný sloupec.

¨ neopakovat – zaškrtnutí tohoto atributu určuje, že opakovaná hodnota ve sloupci nebude v následujících řádcích zobrazena

¨ zobrazit nuly – zaškrtnutí tohoto atributu zajišťuje, že i v případě, že vyhodnocením výrazu sloupce je zjištěna nulová hodnota, tak i tato se bude zobrazovat při tisku dané předlohy

¨ mezisoučet – výběr z překryvného seznamu stylů – odpovídající hodnota způsobuje vytvoření mezisoučtového řádku při změně hodnoty ve sloupci

¨ tučně – možnost tisku mezisoučtu se zvýrazněním tučně

¨ kurzívou – možnost tisku mezisoučtu kurzívou

¨ také pro 1 řádek – zaškrtnutí tohoto atributu způsobuje, že i v případě, že zdrojem pro mezisoučet je jediný řádek, bude tato hodnota zobrazena

¨ dynamický sloupec – maximální počet sloupců – numerická hodnota- je-li uvedena kladná hodnota, omezuje počet sloupců dynamického sloupce (např. hodnota 12)

¨ dynamický sloupec – S-Agregace – výraz v syntaxi Foxpro – sloupcová agregace, která se používá ve spojení s řádkovou agregací. Podle tohoto výrazu se při slučování řádků vytvářejí sloupce. Slučované řádky, pro které tento výraz nabývá shodnou hodnotu, jsou sečteny do tohoto sloupce s hodnotami vyhodnocení Výrazu obsahu, např. výraz MONTH($(OBUDAL_ob02datdod))

¨ výběr – výraz v syntaxi Foxpro – výraz musí nabývat logickou hodnotu – je-li výraz uveden a při zpracování řádku nabyde hodnotu nepravda (FALSE) – nebude hodnota do sloupce výstupního řádku vložena, resp. přičtena

¨ poznámka – libovolný text k danému sloupci

¨ tlačítko Nový – založení nového sloupce typu Text/Hodnota

¨ tlačítko Nový (vzorec) – založení nového sloupce typu Vzorec

¨ tlačítko Odstranit – zrušení sloupce

¨ tlačítko Kopie – vložení kopie aktuálního sloupce

Záložka „SCRIPT“

Při definování předlohy se skript zadává v jazyce Foxpro. Skript zpracovává různé události, které nastávají při vytváření výstupu.

Kód skriptu má k dispozici tyto proměnné:

_EVENT - identifikace události

_COLUMN_OBJECT.NAZEV_SLOUPCE - název sloupce při událostech týkajících se buňky

_COLUMN_OBJECT.VAL - hodnota vkládaná do buňky při událostech týkajících se buňky

_COLNO - číslo sloupce v Excelu při událostech týkajících se buňky

_ROWNO - číslo řádky v Excelu při událostech týkajících se buňky

Události před založením a po vytvoření listu:

BEFORE_LIST - Událost před založením listu

V této fázi vytváření výstupu může skript měnit obsah kurzoru SQL_TISK (na základě jeho obsahu následně vzniká výstup).

AFTER_LIST - Událost po vytvoření listu

V této fázi vytváření výstupu může skript upravit vzhled výsledného listu

Události týkající se buňky:

BEFORE_CELL - Událost před založením běžné buňky

Může měnit hodnotu proměnné _COLUMN_OBJECT.VAL, pokud skript vrátí logickou hodnotu .F. (FALSE), nebude žádná hodnota do buňky vložena.

AFTER_CELL - Událost po založení běžné buňky

Je určena pro formátování buňky

BEFORE_SUBTOTAL_CELL - Událost před založením buňky mezisoučtu

Pokud skript vrátí logickou hodnotu .F. (FALSE), nebude žádná hodnota do buňky vložena.

AFTER_SUBTOTAL_CELL - Událost po založením buňky mezisoučtu

Je určena pro formátování buňky

BEFORE_TOTAL_CELL - Událost před založením buňky závěrečného celkového součtu

Pokud skript vrátí logickou hodnotu .F. (FALSE), nebude žádná hodnota do buňky vložena.

AFTER_TOTAL_CELL - Událost po založení buňky závěrečného celkového součtu

Je určena pro formátování buňky

Pravý klik na textovém poli záložky 'Skript' vyvolává editor programů s předplněním vzoru skriptu, pokud byl pravý klik proveden na prázdném textovém poli.

Příklad:

#INCLUDE OLBEXC

* OLBEXC je knihovna obsahující konstanty Excelu - viz. Návody a Balíčky

DO CASE

CASE INLIST(_event,'AFTER_CELL','AFTER_SUBTOTAL_CELL','AFTER_TOTAL_CELL')

DO CASE

CASE LOWER(_column_object.nazev_sloupce)='jmeno_sloupce'

* vloží podmíněné formátování buňky - její hodnota bude zobrazena červeným textem, pokud je záporná

xlsheet.cells[_rowno,_colno].FormatConditions.Delete

xlsheet.cells[_rowno,_colno].FormatConditions.Add(xlCellValue, xlLess, "0")

xlsheet.cells[_rowno,_colno].FormatConditions(1).Font.ColorIndex = 3

ENDCASE

ENDCASE

V předloze výstupu typu Excel a HTML je možné definovat skript v jazyce FOXPRO. Skript musí být uveden příkazem ".SCRIPT" a ukončen příkazem ".ENDSCRIPT". Musí být uveden vždy na začátku řádku (na začátku řádku nesmí být žádný příkaz TAB nebo jiný znak apod., pak je funkčnost narušena).

.script

.endscript

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 14.09.2012


Pojem - Předloha výstupu typu – sestava a ostatní

Při definici nové předlohy uživatel stiskne příslušnou ikonu v panelu nástrojů a nadefinuje její vlastnosti (název, typ apod.). Kromě nadefinovaných vlastností je však předloha v tuto chvíli prázdná (tzn. neobsahuje dosud žádné atributy). Předlohy výstupu typu sestava je možno tisknout i ve formátu PDF.

Uživatel musí aktivovat ikonu „opravit předlohu“ (druhá v pořadí panelu nástrojů) nebo po stisku pravého tlačítka myši na názvu předlohy zvolit možnost „opravit předlohu“. Uživateli se zobrazí okno „výběr položek zahrnutých do nové předlohy“. Toto okno je v podstatě rozděleno na dvě části:

¨ v levé části je přehled všech dostupných položek výstupu

¨ pravá část je zatím prázdná. Do této části uživatel pomocí šipek přesouvá ty položky výstupu, které mají být obsaženy v dané předloze.

Podrobný popis okna „výběr položek výstupu zahrnutých do nové předlohy“ a jeho možnosti pro každou z typu předlohy je popsán ve slovníku pojmů.

Po přesunutí vhodných atributů předlohy do pravé části okna uživatel stiskne klávesu OK a na základě typu předlohy se mu otevře okno, kde definuje uspořádání položek výstupu. V případě, že uživatel přímo nedefinuje novou předlohu, ale pouze chce opravit uspořádání položek výstupu u již existující předlohy použije ikonu „opravit předlohu“ v panelu nástrojů (nebo po stisku pravého tlačítka myši na názvu předlohy možnost „opravit předlohu“). Jinými slovy, možnost „opravit předlohu“ při prvním spuštění předlohy slouží k nadefinování jednotlivých položek výstupu, při každém dalším spuštění slouží k vlastní opravě uspořádání položek výstupu. Při prvním spuštění předlohy a zvolení položek výstupu uživatel nemá k dispozici volbu tisku této předlohy (tzn. ikonka tiskárna je v panelu nástrojů nedostupná), teprve po nadefinování položek výstupu a jejich uspořádání se uživateli zpřístupní.

U předlohy typu sestava se uživateli zobrazí okno, kde mu k opravě předlohy (čili rozmístění položek výstupu tak, jak se budou uživateli zobrazovat při tisku) slouží generátor sestav FoxPro. Předlohy typu ostatní (tj. HTML) jsou tvořeny automaticky vygenerovaným pseudokódem, který má uživatel možnost opravovat (viz. Popis jazyka generátoru sestav). V činnosti nastavení BM je možno pro tyto předlohy určit adresář výstupního souboru (parametr Preferences-HTML_Output_Path), který se uplatí v případě, že v názvu souboru není uvedena absolutní adresářová cesta.

Ve verzích IS BM pod Visual Foxpro 9.0 je nutno pro práci s klasickými předlohami výstupu mít nainstalován program REPORTBUILDER.APP, který zajišťuje zobrazování formulářů pro vstup vlastností polí, pásů apod. v českém jazyce. Tento program je součástí návodu a balíčků (soubor.zip – adresář PRGS).

Při otevření klasické předlohy pro opravu nebo tisk provádí IS BM automaticky záměnu fontů 'Arial CE' , 'Courier New CE' a 'Times New Roman CE' za 'Arial-Středoevropský', 'Courier New-Středoevropský' a 'Times New Roman-Středoevropský', pokud jsou tedy v této předloze použity. Nastavením BM Printing->Potlac_FontCE=0 je možné tuto funkčnost potlačit (hlavní menu Systém – Nastavení programu BM).

Poznámka:

V předloze výstupu typu Excel a HTML je možné definovat skript v jazyce FOXPRO. Skript musí být uveden příkazem ".SCRIPT" a ukončen příkazem ".ENDSCRIPT". Musí být uveden vždy na začátku řádku (na začátku řádku nesmí být žádný příkaz TAB nebo jiný znak apod., pak je funkčnost narušena).

.script

.endscript

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 14.09.2012


Pojem - Předloha výstupu typu – Word

Stejně jako u předloh typu „sestava“ nebo „excel“ je nutno nejprve u nové sestavy typu „word“ nadefinovat položky, které mají být v sestavě obsaženy. Po stisku ikony „opravit předlohu“ se uživateli nabízí okno „výběr položek zahrnutých do nové předlohy“. Přesunem položek z levé části okna do pravé si uživatel vybírá ty atributy, které mají být součástí nové definice sestavy typu „word“. Po jejich nadefinování a stisku ok se mu nabízí okno s vlastní definicí předlohy. Po stisku ikony „oprava předlohy“ se mu stejné okno zobrazí už i u nadefinovaných předloh výstupu. Editor předloh výstupu do Wordu obsahuje 4 záložky, každou z nich si podrobněji popíšeme:

¨ hlavička

¨ skupiny

¨ elementy – hlavička

¨ e-mail

Program BM nekomunikuje při výstupu s předlohou výstupu typu „word“ s programem WORD přímo, ale prostřednictvím knihovny vkládaného kódu SYSDOC. Pro bezproblémovou funkčnost musí být nainstalována tato knihovna s datem aktualizace, které není starší než 1.1.2007 (existence knihovny a datum aktualizace je programem kontrolováno). Oddělená komunikace umožňuje připojení jiného textového editoru než jen WORDu.

Funkčnost výstupu předlohami typu „word“ byla testována pro verzi Word 2003, předpokládaná bezproblémová funkčnost je verze 2000 nebo vyšší.

Knihovna SYSDOC musí obsahovat definici třídy BM_CODE_SYSDOC, která obsahuje metody volané programem BM:

CREATEFILE - parametry _soubor,_template - zakládá a otevírá nový dokumentu Word s názvem _soubor, kopií ze souboru s názvem _template

DEFAULTBORDER_RESET - bez parametrů - nastavení vytváření tabulky s viditelným ohraničením

DEFAULTBORDER_NONE - bez parametrů - nastavení vytváření tabulky s neviditelným ohraničením

BOOKMARK_REPLACE_TABLE - parametry _zalozka,_radek,_hodnota1,_hodnota2,... - vloží do tabulky v záložce _záložka řádek s pořadovým číslem _radek s hodnotami sloupců _hodnota1,_hodnota2,...

BOOKMARK_TABLE_LINE_BOTTOM - parametry _zalozka,_radek,_border - vytvoří nebo zruší ohraničení tabulky v záložce _záložka pro řádek s pořadovým číslem _radek podle hodnoty _border (TRUE nebo FALSE)

BOOKMARK_REPLACE_TEXT - parametry _zalozka,_hodnota - nahradí text ve vytvářeném dokumentu označený záložkou _záložka textem _hodnota

PRINTPREVIEW - bez parametrů - vyvolá náhled aktuálně vytvářeného dokumentu

PRINTOUT - parametry _kopie,_tiskarna - vytiskne počet kopií aktuálně vytvářeného dokumentu na požadovanou tiskárnu

SAVE - bez parametrů - uloží aktuálně vytvářený dokumentu Wordu

DOCCLOSE - bez parametrů - uzavře aktuálně vytvářený dokument

A nyní se vrátíme k vlastnímu popisu Editoru definice předlohy typu „word“ a popíšeme si vlastnosti jednotlivých záložek:

Záložka „HLAVIČKA“

Na záložce „hlavička“ se definují vlastnosti týkající se výstupního souboru Wordu. Výstupní dokument Wordu je vytvářen podle template (vzoru), kterým je soubor ve formátu Word. Při výstupu předlohou výstupu je nejprve založen výstupní soubor Wordu, který je kopií tohoto template. Předpokladá se, že v template jsou obsaženy záložky, které odpovídají názvům uvedeným v předloze spolu s výrazy v jazyce Foxpro. Hodnoty zjištěné při výstupu předlouhou vyhodnocením výrazů jsou vkládány do výstupu podle záložek z template.

¨ soubor – nepovinný parametr – název výstupního souboru Wordu – výraz v jazyce Foxpro (‘soubor.doc’) nebo skript v jazyce Foxpro uvedený slovem SCRIPT.

.script

.....

..... (možná řada příkazů)

return ‘nazev.doc’ (např. nazev’+str(date())+’.doc’)

Není-li název souboru uveden, vytváří se dokument s náhodným jménem, který bude zrušen.

¨ šablona – nepovinný parametr - název souboru šablony (template) pro vytvoření souboru Wordu – výraz v jazyce Foxpro nebo skript v jazyce Foxpro uvedený slovem SCRIPT. Systémová šablona je uvozena ‘*’. Za znakem ‘*’ musí být uveden klíč dokumentu BM, který má být použit jako šablona (klíčem dokumentu je tabulka v SYSDOC). Přitom musí existovat dokument BM s daným klíčem (v činnosti „Marketing – Dokumenty - Dokument“), který musí mít nastavenu vlastnost „Duplikát“ (v této vlastnosti se uvádí název souboru na disku, kam má být ukládána kopie dokumentu. Doporučuje se ve vlastnosti „duplikát“ dokumentu BM uvádět jinou příponu souboru než DOC tak, aby se neumožnilo upravovat tento soubor na disku, např. TEMPLATE\FAKTURA.DOX).

Při výstupu předlohou program vyhledává dokument BM podle daného klíče. Podle názvu souboru uvedeného v jeho vlastnosti „duplikát“ vytváří kopii dokumentu BM do tohoto souboru v případě, že:

- tento soubor neexistuje,

- datum založení souboru je menší než poslední záznam o změně dokumentu BM zaznamenaným v jeho vlastnosti „užití dokumentu“

Vytvořená šablona mimo IS BM je pak zapsaná ve tvaru ‘template\nazev.doc’. V případě

použití skriptu je i zde nutný příkaz return jako v názvu soboru.

¨ opakovaná – zaškrtávací pole – jeho zaškrtnutí způsobí při tisku dané předlohy pro každý záznam SQL_TISK opakované vložení šablony do výstupu

¨ nová stránka – zaškrtávací pole – jeho zaškrtnutí ve spojení s polem „opakovaná“ způsobí při tisku předlohy vložení konce stránky před další vložení šablony do výstupu

¨ podmínka – nepovinný parametr – podmínka v jazyce Foxpro, kterou jsou filtrovány záznamy SQL_TISK (např. OBARTIKL_sp61id=’VYR’ – musí vracet TRUE nebo FALSE)

¨ heslo – nepovinný parametr – heslo uzamčení výstupního souboru Wordu pro provádění změn

¨ vícesouborový tisk – zaškrtávací políčko – zaškrtnuté způsobí při tisku vytváření samostatných dokumentů Word pro každý záznam SQL_TISK (tj. každý záznam v jiném souboru)

¨ úvodní skript – skript v jazyce Foxpro prováděný před zahájením výstupu – není-li skript vyplněn, potom se po pravém kliku ve vstupu tohoto atributu předplní vzor kódu pro zápis vytvořeného dokumentu jako dokumentu IS BM (pokud se předloha bude ukládat jako dokument v IS BM, je nutno mít úvodní skript nadefinován).

¨ závěrečný skript – skript v jazyce Foxpro prováděný po ukončení výstupu – není-li skript vyplněn, potom se po pravém kliku ve vstupu tohoto atributu předplní vzor kódu pro zastavení BM – čekání na uložení dokumentu

¨ poznámka – libovolná poznámka ohledně vlastností dané předlohy

¨ digitální podpis – překryvný seznam – Nikdy, Ano, Ne – určuje jak bude předplněno okno možností zobrazované před zahájením výstupu předlohy. Pokud má být dokument digitálně podepsán a uživatel ho digitálně nepodepíše, potom tento dokument nebude vytištěn ani odeslán e-mailem, bude uzavřen a zrušen.

¨ příprava e-mailu - překryvný seznam – Nikdy, Ano, Ne – určuje jak bude předplněno okno možností zobrazované před zahájením výstupu předlohy

¨ uložit jako dokument BM – překryvný seznam – Nikdy, Ano, Ne – určuje jak bude předplněno okno možností zobrazované před zahájením výstupu předlohy (nastavení Ano, resp. Ne, má smysl pouze v případě, že atribut Úvodní skript obsahuje odpovídající kód)

Vlastnosti „dig. podpis, příprava e-mailu a ukládat jako dokument BM“ se uplatňují v kombinaci s nastavením profilu spuštění předlohy, který je uveden ve vlastnostech předlohy výstupu.

Záložka „SKUPINY“

Na záložce „skupiny“ se definují skupiny elementů vkládaných do výstupu. Účelem rozdělení elementů do skupin je možnost vytváření tabulek ve Wordu definovaných na základě nezávislých SQL dotazů nebo zvýšení přehlednosti definice předlohy výstupu. Definují se tyto vlastnosti:

¨ seznam – seznam skupin definujících výstup

¨ název - název skupiny – neuplatňuje se při výstupu (zapsaný bez apostrofů)

¨ tabulka – tabulka vytvářená skupinou. Je-li uvedena (její název), potom je do výstupu vyplňována tabulka se sloupci vytvářenými na základě elementů skupiny. Předpokládá se, že v template je odpovídající tabulka Word označená značkou s názvem stejným jako je uvedený název tabulky. „Nová tabulka“- je uvedena vždy na konci předlohy. „Existující záložka“ – vytvoří prázdnou tabulku do existující záložky. „Existující tabulka“ – vytvoří již naformátovanou tabulku.

¨ od řádky – tento atribut je dostupný, pokud je vyplněn atribut „tabulka“ – určuje řádek, od kterého má být tabulka ve Wordu vyplňována

¨ Borders – zaškrtávací políčko – tento atribut je dostupný, pokud je vyplněn atribut „tabulka“ – zaškrtnutý určuje, že každý nový řádek tabulky má být ohraničen

¨ parametry – seznam výrazů v jazyce Foxpro – parametry pro SQL dotaz (uvozeno výrazem SQL_TISK. nebo _root_data.)

¨ SQL – SQL dotaz skupiny (odkazuje na parametry v syntaxi ?_p1 ..) nebo skript v jazyce Foxpro uvedený slovem SCRIPT (při použití parametrů musí obsahovat LPARAMETERS s odpovídajícím počtem formálních parametrů). Předpokládá se, že skript vytvoří kurzor s aliasem DATA

¨ skript – skript skupiny v jazyce Foxpro vyvolaný po naplnění skupiny podle definovaných elementů – může odkazovat objekty _wrd=řídící objekt Wordu, _this=řídící objekt skupiny

¨ podmínka - podmínka v jazyce Foxpro, kterou jsou filtrovány záznamy SQL_TISK nebo data SQL dotazu pro danou skupinu

¨ poznámka – libovolná poznámka ke skupině

Záložka „ELEMENTY - HLAVIČKA“

Na záložce „elementy – hlavička“ se definují elementy aktuální skupiny ze záložky „skupina“. Jsou to tyto atributy:

¨ seznam – seznam elementů skupiny

¨ ID – identifikace elementu – v případě, že se jedná o element tabulky, představuje ID elementu výraz v syntaxi Foxpro vyplňovaný do sloupce tabulky. V případě, že se jedná o netabulkový element (na záložce „skupina“ je atribut tabulka prázdný), představuje ID elementu název záložky ze šablony.

¨ návěští – je dostupné, pokud je vyplněn atribut „tabulka“ na záložce skupiny. Je-li návěští uvedeno, název sloupce v tabulce se přepíše. Pokud uvedeno není, zůstává název sloupce stejný tak, jak je definován v šabloně.

¨ výraz – výraz v jazyce Foxpro – jeho hodnota bude vložena do tabulky, resp. do výstupního textu, náhradou za text označený v template záložkou, která odpovídá názvu ID (např. v template předlohy máme záložku „doklad“. Je vytvořena skupina záhlaví, jejíž elementem je právě záložka doklad a je uvedena jako element s ID doklad. Ve výrazu k tomuto elementu je zapsáno - SQL_TISK.SPPOHZDR_sp33cisdr+'-'+SQL_TISK.SPPOHZDR_sp33cisdpm+'-'+SQL_TISK.SPPOHZDR_sp33cisd – poté dojde k tomu, že na předloze je výraz doklad nahrazen číslem dokladu).

¨ překlad - nabízí se překryvný seznam s nabídkou jazyků nastavených v IS – pro každý výstupní jazyk předlohy je možné definovat samostatné definice vlastností „návěští“ a „výraz“.

¨ návěští – cizojazyčný překlad návěští podle zvoleného jazyka v překladu

¨ výraz – cizojazyčný výraz podle zvoleného jazyka v překladu (pokud je stejný s výše uvedeným atributem výraz, není nutné ho zde uvádět podruhé)

¨ formát – formátovací text vyhodnoceného výrazu – viz. funkce Foxpro TRANSFORM (např. u číselného výrazu je uveden formát 999 999.99)

¨ styl - formátovací text vyhodnoceného výrazu – viz. funkce Foxpro TRANSFORM (jedná se o nadefinovaný styl z Wordu)

¨ suma – zaškrtávací políčko – je dostupný, pokud je vyplněn atribut „tabulka“ skupiny – pokud je zaškrtnutý, tak se pro daný sloupec tabulky vytvoří sumární řádek

¨ poznámka – libovolná poznámka k elementu

Poznámka:

Atributy podmínky definované na záložkách 'Hlavicka' a 'Skupiny' umožňují komplexní výstup s vytvořením většího počtu tabulek v dokumentu bez využití SQL dotazu ve vlastnostech skupin (typické např. pro tisk dokladu procesu).

Např. tisk faktury - podmínky při zaškrtnutém 'Vícesouborový tisk':

Hlavička - SQL_TISK.sppohzdr_sp06idsubs='PLA'

Skupina - Záhlaví - sppohzdr_sp33cisdr+sppohzdr_sp33cisdpm+sppohzdr_sp33cisd= _root_data.sppohzdr_sp33cisdr+_root_data.sppohzdr_sp33cisdpm+_root_data.sppohzdr_sp33cisd

Skupina - Dodavatel - sppohzdr_sp06idsubs='OBC' and sppohzdr_sp33cisdr+sppohzdr_sp33cisdpm+sppohzdr_sp33cisd= _root_data.sppohzdr_sp33cisdr+_root_data.sppohzdr_sp33cisdpm+_root_data.sppohzdr_sp33cisd

Skupina - Odberatel - sppohzdr_sp06idsubs='OBC' and sppohzdr_sp33cisdr+sppohzdr_sp33cisdpm+sppohzdr_sp33cisd= _root_data.sppohzdr_sp33cisdr+_root_data.sppohzdr_sp33cisdpm+_root_data.sppohzdr_sp33cisd

Skupina - Dodací list (tabulka OBC) - sppohzdr_sp06idsubs='OBC' and sppohzdr_sp33cisdr+sppohzdr_sp33cisdpm+sppohzdr_sp33cisd= _root_data.sppohzdr_sp33cisdr+_root_data.sppohzdr_sp33cisdpm+_root_data.sppohzdr_sp33cisd

Skupina - Daňové údaje (tabulka DPH) - sppohzdr_sp06idsubs='DPH' and sppohzdr_sp33cisdr+sppohzdr_sp33cisdpm+sppohzdr_sp33cisd= _root_data.sppohzdr_sp33cisdr+_root_data.sppohzdr_sp33cisdpm+_root_data.sppohzdr_sp33cisd

Skupina - O platbě - sppohzdr_sp06idsubs='PLA' and sppohzdr_sp33cisdr+sppohzdr_sp33cisdpm+sppohzdr_sp33cisd= _root_data.sppohzdr_sp33cisdr+_root_data.sppohzdr_sp33cisdpm+_root_data.sppohzdr_sp33cisd

Ve výrazech podmínek se vyskytuje alias _ROOT_DATA, nejedná se o alias kurzoru, ale o objekt, který při zpracování obsahuje atributy s názvy a hodnotami odpovídajícím záznamu vybranému filtrem hlavičky (SQL_TISK.sppohzdr_sp06idsubs='PLA').

Výraz elementu netabulkové skupiny elementů může obsahovat volání příkazu CALCULATE jazyka Foxpro, přitom se bere v úvahu podmínka uvedená u skupiny.

Např.:

CALC SUM($(OBUDAL_dp02czazm))

Ve výrazech tisku je možné použít vlastnosti a metody řídícího objektu vytváření skupiny:

THIS.SP38ID - text - identifikace jazyka výstupu předlohy

THIS.VOLNY_TEXT - metoda s parametry _SP88ID,_DEFAULT - vyhledává volný text s identifikací _SP88ID v jazyce výstupu předlohy - není-li tento text definován vrací hodnotu _DEFAULT

Záložka „E-MAIL“

Na záložce „e-mail“ se definují parametry, které umožňují odeslat vytvořený dokument e-mailem. Definuje se:

¨ příjemce – e-mailová adresa příjemce – výraz v jazyce Foxpro nebo skript v jazyce Foxpro uvedený slovem SCRIPT (např. výraz ‘*’+sql_tisk.adadsat_ad01id vrátí jako hodnotu všechny e-mailové spojení daného adresáta) – nepovinný parametr

¨ předmět - předmět zprávy – výraz v jazyce Foxpro nebo skript v jazyce Foxpro uvedený slovem SCRIPT – povinný parametr, pokud má být e-mail odesílán (‘text’)

¨ název DOC – název, pod kterým bude dokument uveden v e-mailu jako příloha - výraz v jazyce Foxpro nebo skript v jazyce Foxpro uvedený slovem SCRIPT – nepovinný parametr

¨ další přílohy - seznam dalších příloh, které budou připojeny k e-mailu. Výraz v jazyce Foxpro nebo skript v jazyce Foxpro uvedený slovem SCRIPT – nepovinný parametr. Položky seznamu jsou odděleny středníkem ve tvaru (soubor na disku);(název přílohy), např. ‘C:\x.txt;nazev1;C:\y.txt;nazev2’ nebo ‘C:\x.txt;;C:\y.txt’. Při připojování dokumentů je ze strany uživatele vhodná určitá obezřetnost. Systém IS BM pracuje tak, že dokumenty připojené k emailu zároveň smaže z místa, kde byly dosud uloženy. Doporučujeme postupovat tak, že si uživatel vytvoří speciální adresář, kam si překopíruje dané dokumenty. Potom se tyto dokumenty připojí napevno k mailu a přitom na původním místě v PC uživatele zůstanou i nadále dostupné.

¨ text - text v e-mailu – text nebo skript v jazyce Foxpro uvedený slovem SCRIPT – nepovinný parametr. Pokud je v textu e-mailu text (ne skript), potom se na tento text aplikuje funkce TEXTMERGE jazyka Foxpro. Např.:

Dobrý den,

<<this.volny_text('UPOMIN')>>

S pozdravem <<tool.jmenot>>

¨ připravit e-mail z Wordu – e-mail bude připraven nebo odeslán přímo z Wordu – zaškrtávací políčko

¨ automaticky odeslat e-mail – e-mail bude odeslán bez možnosti úpravy uživatelem – zaškrtávací políčko

¨ důležitost - nastavení příznaku u e-mailu, důležitost malá/velká (pouze při odeslání z Wordu)

¨ uzavřít dokument pro/po odeslání e-mailu – dokument bude před nebo po odeslání e-mailu uzavřen (pro/po je podle toho, zda je dokument odesílám přímo z Word nebo ne) – zaškrtávací políčko

Poznámka pro e-mail odesílaný z Wordu:

¨ obsah vytvářeného dokumentu bude textem zprávy e-mailu

¨ text získaný podle vlastnosti Text bude vložen do Úvodu e-mailu

¨ je-li zaškrtnuto „automaticky odeslat e-mail“ a zároveň je zaškrtnuto „uzavřít dokument pro/po odeslání e-mailu“, je potom dokument po automatickém odeslání e-mailu uzavřen

Poznámka pro e-mail neodesílaný z Wordu:

¨ obsah vytvářeného dokumentu bude přílohou e-mailu

¨ text získaný podle vlastnosti Text bude textem zprávy

¨ je-li zaškrtnuto „uzavřít dokument pro/po odeslání e-mailu“ – dokument bude uzavřen a okamžitě připraven e-mail k odeslání, resp. e-mail odeslán podle nastavení v „automaticky odeslat e-mail“

¨ není-li zaškrtnuto „uzavřít dokument pro/po odeslání e-mailu“ – pak bude e-mail odesílán až po uzavření vytvářeného dokumentu uživatelem

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 13.05.2013


Pojem - Předmět projektu

Jádrem každého projektu je definice předmětu projektu, který je výsledkem uskutečnění projektu, tj. to proč se projekt zakládá a realizuje. Může se jednat o hmotné předměty projektu, jako je například stavba, prototyp stroje, kniha, nová chemická sloučenina, ale také prodávané auto,…, anebo o nehmotné předměty projektu, jako je například urbanistická studie, technická dokumentace, analýza informačních potřeb, definice plánu realizace zakázky atd.

V případě, že je projektové řízení z IS Bílý Motýl® aplikováno na podporu „neprojektových“ aktivit, jako je poskytování „drobných“ služeb nebo realizace „drobných“ zakázek nebo jako jsou kontinuální činnosti (prodej, marketing, správa majetku, …), pak je jako předmět projektu definován opakovaný výkon dané aktivity.

V IS Bílý Motýl® lze cíl projektu popsat několika způsoby. Mezi nejstručnější bude zcela jistě patřit popis volným textem. Pokud se k projektu vztahuje řada dokumentů, může být vhodné předmět projektu popsat připojením těchto dokumentů (text, tabulky, foto, video, ….) objektovou vazbou. V situaci, kdy se opakovaně realizuje poměrně velké množství „podobných“ projektů, je nejvhodnější cíl projektu popsat sadou parametrů.

Parametry a jejich struktura jsou uživatelsky definovatelné, což umožní popsat jakýkoliv projekt. Aplikace parametrů vám umožní pohodlně vybírat projekty, ve kterých je daný parametr evidován nebo ve kterých nabývá určité hodnoty.

Nastavení parametrů obvykle probíhá automatizovaně „děděním“ v určité míře (dvojče, bratr, bratranec) od jiného věcně blízkého projektu při inicializaci předmětu projektu, kdy je založen i odpovídající proces, ve kterém obvykle navazuje plánování úkolů (čas a kapacity), ale také další operace (např. sklad, mzdy, fakturace, nákup, expedice, výrobní zakázka, …) dle vašich firemních procesů.

Kromě výše zmíněného detailního popisu předmětu projektu je součástí jeho definice identifikace včetně verze, externí a pracovní identifikace, čárový kód, vedoucí projektu, alokace řídící přístupová práva, prezentace definující způsob zobrazení parametrů, obchodní a technicko věcný selektor umožňující referovat projekt z ostatních aktivit. Dále je zde k dispozici stav projektu (např. uvažovaný, schválený, zamítnutý, odložený, připravený, zahájený, před dokončením, předaný, hotový, …), který je automaticky aktualizován dle plnění projektu či dle rozhodnutí kompetentních osob.

Konkrétní popis jednotlivých atributů v činnosti Předmět projektu je uveden v helpu dané činnosti.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 14.04.2014


Pojem - Předměty zdanitelného plnění

V této činnosti má uživatel samostatně k nahlédnutí číselník jednotlivých předmětů zdanitelného plnění a ke každému předmětu i přehled jeho uplatnění. Předměty i uplatnění zdanitelného plnění jsou nedílnou součástí definice vlastních typů zdanitelného plnění, které pak vstupují do událostí DPH a jsou podkladem pro vytvoření daňového přiznání DPH.

Předměty lze uživatelsky doplnit pouze na základě pokynů správce IS BM v souvislosti se změnami zákona o DPH, případně změnami formuláře daňového přiznání.

Podle zákona o DPH (235/2004 Sb.) je předmětem daně:

¨ dodání zboží nebo převod nemovitosti anebo přechod nemovitosti v dražbě za úplatu osobou povinnou k dani v rámci uskutečňování ekonomické činnosti, s místem plnění v tuzemsku,

¨ poskytnutí služby za úplatu osobou povinnou k dani v rámci uskutečňování ekonomické činnosti, s místem plnění v tuzemsku,

¨ pořízení zboží z jiného členského státu Evropské unie za úplatu, uskutečněné v tuzemsku osobou povinnou k dani v rámci uskutečňování ekonomické činnosti nebo právnickou osobou, která nebyla založena nebo zřízena za účelem podnikání, a pořízení nového dopravního prostředku z jiného členského státu za úplatu osobou, která není osobou povinnou k dani,

¨ dovoz zboží s místem plnění v tuzemsku.

Plnění, která jsou předmětem daně, jsou zdanitelnými plněními, pokud nejsou osvobozena od daně.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 23.03.2010


Pojem - Předplnění adresáta podle ARES

Doplňující vlastnost formuláře „Předplnění adresáta podle ARES“ slouží uživateli k automatickému vyplnění údajů o adresátovi pomocí webové služby Ministerstva financí ČR. Po

zadání názvu nebo IČO se uživateli předplní kompletní adresa adresáta a popř. i informativní hlášení, že je daný adresát z nějakého důvodu (např. konkurz, vyrovnání) uveden v registru

Centrální evidence úpadců.

Definice uzlu informačního panelu ADARES je určena pro zobrazení informací o adresátovi pomocí webové služby Ministerstva financí ČR v činnosti Okno úloh. Po instalaci tohoto

balíčku je nutno doplnit v Nastavení BM OKNOULOH-> VLOZENEINFPANELY do seznamu identifikací IP identifikaci této stránky uvedenou znakem ‘*’ (tj. *ADARES). Po stisku tlačítka „Adresát v ARES“ v činnosti Okno úloh se pak uživateli zobrazují následující informace.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.08.2008


Pojem - Předplnění bankovních účtů dle registru plátců DPH

Jedná se o doplňující vlastnost formuláře dostupnou v činnosti Adresář. Slouží k vyplnění údajů o bance a účtu do bankovních spojení adresáta pomocí webové služby „Registr plátců DPH“, kde je adresát identifikován přes DIČ.

Způsob použití je určen obecnou předkontací (v menu Informační centrum->Typy a řady->Obecné předkontace). Jednotlivé atributy jsou:

¨ předkontace - BINDBU

¨ význam:

BINBU1 - kdy použít službu

= 0 ... nikdy

= 1 ... při zadáváni bankovního spojení

= 2 ... při zadáváni bankovního spojení, po založení adresáta

= 3 ... při zadáváni bankovního spojení, po založení adresáta pomocí doplňující vlastnosti BINDIC (Implicitní)

BINBU2 - přezobrazovat seznam adresátů (pouze po založení adresáta)

= 0 ... Ne (Implicitní)

= 1 ... Ano

BINBU3 - nastavit Ano do atributu Plátce DPH (pouze po založení adresáta)

= 0 ... Ne

= 1 ... Ano (Implicitní)

BINBU4 - nastavit bankovní spojení jako implicitní (pouze po založení adresáta)

= 0 ... Ne

= 1 ... Ano (Implicitní)

Při zadávání nového bankovního spojení (F3) - pokud se jedná o "Účet" (ne "Pokladna") a je zadán v kódu banky znak *, potom se předplní kód banky, předčíslí a číslo účtu dle rejstříku plátců DPH (jestliže již toto spojení v IS BM neexistuje). Má-li adresát více než 1 účet, je vygenerována nabídka (menu), kde uživatel může požadovaný účet vybrat.

Při zadávání nového adresáta se po jeho zadání naplní všechny účty adresáta dle registru plátců DPH pro banky evidované v IS BM.

¨ je-li alespoň 1 účet:

- BINBU3 = 1 nastaví se atribut plátce DPH na hodnotu Ano

- BINBU4 = 1 je-li právě jeden účet - nastaví se jako implicitní, je-li více účtů, je vygenerována nabídka (menu), kde uživatel může požadovaný účet vybrat jako implicitní

¨ je-li BINBU2 = 1, potom dojde k přezobrazení seznamu adresátů (právě zadaný adresát nemusí být vidět, neodpovídá-li zadání na výběrové záložce)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 16.10.2014


Pojem - Přehled nerozpočteného

Tato činnost podle nastaveného kritéria na záložce „výběr“ (nejčastěji číslo linky, artikl a období od – do) poskytuje uživateli přehled nerozpočteného artiklu. Jedná se o artikl, který má na kartě (činnost „artikly výroby“ – komponenta TPV) v atributu „rozp.mn.“ (rozpočítávat množství) uvedenu hodnotu Ano. Tímto příznakem se označuje artikl (materiál), jehož množství na realizovaných vstupech výrobních úkolů se rozpočítává podle skutečně spotřebovaného množství artiklu za období.

Rozpočet artiklu se provádí po stisku klávesy F9 nebo volbou činnosti „rozpočet množství“ z menu Volby.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.01.2008


Pojem - Přehled přihlášených (SQL)

Tato činnost poskytuje přehled přihlášených uživatelů. K dispozici jsou tyto informace:

¨ identifikace (čísla spojení, která uživatelům přidělil databázový server)

¨ jméno uživatele

¨ činnost (název probíhající činnosti)

¨ čas (datum a čas poslední aktivity uživatele)

¨ název počítače

¨ multiverze (číslo multiverze přihlášeného uživatele)

Další vlastností, kterou tato činnost uživateli poskytuje, je možnost sledování počtu přihlášených uživatelů na základě zakoupených licencí. Chování této vlastnosti přímo závisí na nastavení parametru „Preferencess ->Licence_prodluzovat“ v činnosti „Nastavení programu BM“. Podle počtu zakoupených licencí je uživateli vygenerováno sériové číslo programu, které je mu dodáno s programem.

Pokud počet současně přihlášených uživatelů překročí licenci provozovatele BM na počet současně přihlášených:

¨ při nastavení parametru“Licence_prodluzovat=1“ – se uživateli zobrazí dotaz: „Po Vašem vstupu do BM bude k BM přihlášeno „nn“ uživatelů a tím bude licence Vaší firmy pro používání

BM překročena o „nn“ současně přihlášených uživatelů. Vaše odpověď ANO Vám umožní vstup do programu a bude považována za objednání dalších licencí BM.

¨ při nastavení parametru“Licence_prodluzovat=0“ – tento dotaz zobrazen nebude a uživateli není vstup do BM povolen.

V horní liště z menu Volby lze vyvolat tyto činnosti:

¨ obrazovka uživatele – vyvolá formulář, ve kterém je periodicky zobrazován obsah obrazovky daného uživatele

¨ stav programu BM uživatele – vyvolá formulář, ve kterém je periodicky zobrazován stav programu BM daného uživatele

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 19.12.2007


Pojem - Přehled vstupů a výstupů výroby

Na základě nadefinovaných údajů na záložce „parametry“ (druh artiklu, artikl, technologický postup, množství a datum zahájení výroby) má uživatel k dispozici přehled vstupů a výstupů, které se týkají daného artiklu v souvislosti s daným technologickým postupem a zadaným množstvím.

Jedná se ale o okamžitý přehled vstupů a výstupů, tzn. po ukončení činnosti nejsou tyto data v této činnosti nijak ukládána. V podstatě tato činnost poskytuje uživateli možnost vytvořit si přehled vstupů a výstupů, jak by vypadal, kdyby chtěl realizovat zakázku uvedenou v parametrech. Tento okamžitý přehled mu pak může sloužit např. jako předběžné rozhodnutí, zda danou zakázku může v nejbližší době realizovat.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.01.2008


Pojem - Přehled změn záznamů tabulek

Činnost má uživatel k dispozici v menu Systém. Poskytuje uživateli přehled změn, které byly provedeny ve vybraných tabulkách. Které změny se budou sledovat a v jakých tabulkách přímo souvisí s nastavením definic v činnosti „nastavení sledování změn tabulek“.

Pro snadnější vyhledávání změněných záznamů tabulek je po aktivaci této činnosti k dispozici výběrová záložka.

Uživatel má k dispozici tyto atributy:

¨ tabulka - identifikace tabulky IS BM

¨ popis - předplněný podle výrazu popisu v definici - je ho možné upravovat

¨ změna - může dosahovat hodnot založení/oprava/zrušení

¨ klíč - text odpovídající primárnímu klíči záznamu

¨ uživatel - jméno uživatele (pro změny provedené mimo IS BM uživatel SYSTÉM)

¨ datum a čas změny

¨ poznámka - libovolný text

Na záložce „atributy“ jsou zaznamenány změny jednotlivých atributů v tabulkách. Změna typu „založení“ nezaznamenává vstoupené atributy. Změna typu „oprava“ zaznamenává původní a nové hodnoty změněných atributů. Změna typu „zrušení“ zaznamenává původní hodnoty atributů zrušeného záznamu s výjimkou prázdných textových atributů (C resp.char) a poznámka (M resp. long varchar).

Po spuštění formulářů, které pracují s tabulkou uvedenou v činnosti „nastavení sledování změn tabulek“ je možné pro aktuální záznam vyvolat formulář „přehled změn záznamů tabulek“ (činnost v menu Obecné - Přehled změn záznamu). Přitom se automaticky odpovídajícím způsobem předplní výběrová záložka.

Při implementaci IS BM s použitím replikací je třeba řešit problém identifikace uživatele, který provedl změnu. Změny dat prováděné triggery totiž nejsou replikovány, protože se předpokládá, že totožný trigger bude spuštěn na vzdáleném počítači při synchronizaci dat prováděné replikačním agentem. Replikační agent však nemůže identifikovat uživatele IS BM, který provedl změnu. Proto záznamy o změnách dat, které byly provedeny na vzdáleném datovém úložišti mají uvedeného uživatele SYSTÉM.

Pro následné doplnění uživatele, který skutečně provedl změnu je k dispozici uložená procedura:

'BWUPDRC prepis bw01uziv'

kterou je možné vyvolávat událostním triggerem v syntaxi:

CALL bm_servis."BWUPDRC prepis bw01uziv"().

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 03.08.2006


Pojem - Překlad popisek

Ve formulářích pro definování implementačních rozšíření (volné karty, obecné výběry, importy/exporty dat, šablony, výkazy, metapředlohy výstupu) lze pod menu Volby vyvolat činnost „překlad popisu“. Překlad názvů předloh výstupu se provádí volbou „překlad popisek“ z okna Výstupy po stisku pravého tlačítka myši na názvu předlohy.

Činnost „překlad popisek“ je možno vyvolat z menu Volby aktivací příslušné činnosti nebo pomocí klávesy Ctrl P. Popiskou se rozumí návěští vstupovaných, resp. zobrazovaných atributů, text stavového řádku, text zaškrtávacího políčka, seznam hodnot překryvného seznamu, název implementačního rozšíření.

Při zaškrtnutí atributu režim oprav lze činnost překlad popisu vyvolat i po stisku pravého tlačítka myši na daném atributu, překryvném seznamu apod. Při překladu textu prvku typu překryvný seznam je možné zatrhnout atribut „uložit přeložený text do BWSLOVPP“. Toto uložení následně v SQL dotazech umožňuje přístup k hodnotám, které jsou definované pro atributy zobrazované jako překryvný seznam.

Překlady názvů implementačních rozšíření se provádějí samostatnými funkcemi menu Volby:

¨ překlad popisek – název volné karty

¨ překlad popisek – název obecného výběru

¨ překlad popisek – název šablony

¨ překlad popisek – název importu/exportu

¨ překlad popisek – název metapředlohy

¨ překlad popisek – název výkazu

Aktivací této činnosti je vyvolán formulář, ve kterém se vstupuje:

¨ jazyk

¨ typ textu – určuje co je textem překládáno – Návěští/Stavový řádek/Text pro zaškrtávací políčko nebo překryvný seznam/Chybové hlášení

¨ text – přeložený text

¨ poznámka – libovolný text

Přeložené názvy se uplatňují při práci s IS BM v cizím jazyce, a to:

¨ v menu Obecné – tyto překlady mají vyšší prioritu než překlady v „definování nabídek“ (platí pro volné karty a obecné výběry)

¨ v překryvných seznamech obecných výběrů na výběrových záložkách formulářů

¨ ve výběrech pro spuštění (šablony a import/export dat)

Přeložené texty popisek formulářů jsou ukládány mimo SQL databázi implementace IS BM nebo v databázi implementace IS BM. O tomto uložení rozhoduje nastavení programu BM – Preferences – Slovnik_SQL (menu Systém – Nastavení programu BM). Při nastavení Preferences – Slovnik_SQL na:

¨ 0 – (implicitni). Přeložené texty jsou ukládány v souborech SLOVNIK\SLOV_XXX.DBF a SLOVNIK\SLOV_XXX.FPT a SLOVNIK\SLOV_XXX.CDX, kde XXX je identifikace jazyka

¨ 1 – přeložené texty jsou ukládány do tabulky BWSLOVNI v SQL databázi

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 16.02.2012


Pojem - Překlad popisek - název předlohy

Překlad názvů předloh výstupu se provádí volbou „překlad popisek“ z okna Výstupy po stisku pravého tlačítka myši na názvu předlohy.

Aktivací této činnosti je vyvolán formulář, ve kterém se vstupuje:

¨ jazyk

¨ typ textu – určuje co je textem překládáno – Návěští/Stavový řádek/Text pro zaškrtávací políčko nebo překryvný seznam/Chybové hlášení

¨ text – přeložený text

¨ poznámka – libovolný text

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 16.02.2012


Pojem - Překlad textů

Překlad vybraných textů položek menu je možné provádět v činnosti Nabídky pomocí tlačítka „Překlad“. Uživatel si aktivuje menu Obecné – Nabídky – Definovat nabídky a na položkách, které mu v danou chvíli činnost nabízí může využít tlačítko „Překlad“. Po jeho aktivaci zadává návěští popisu a poznámku popisu.

Do jakého jazyka bude uživatel vybraný text překládat je určeno tím, jaký jazyk je aktivován (zatržen) v hlavním menu pod volbou Jazyk.

Vybrané údaje IS BM (atributy, hodnoty překryvných seznamů apod.) je možno překládat i pomocí činnosti režim oprav. Po jejím zatržení (menu Jazyk v horní liště) se pak po stisku pravého tlačítka myši zobrazí možnost překladu popisu v daném jazyce (v tom, který je právě aktivní). Návěští popisu definuje překládané hodnoty, poznámka popisu slouží pouze jako informační popis k překladu. Při překladu textu prvku typu překryvný seznam je možné zatrhnout atribut „uložit přeložený text do BWSLOVPP“. Toto uložení následně v SQL dotazech umožňuje přístup k hodnotám, které jsou definované pro atributy zobrazované jako překryvný seznam.

Pro zvýšení kvality užívání IS v cizím jazyce je vhodné používat operativní systém a FoxPro ve stejném cizím jazyce.

Společnost BM Servis s.r.o. nabízí svým zákazníkům možnost objednat si kompletní překlad do angličtiny, němčiny, případně do jiného jazyka. Nicméně i tak zůstane několik málo výrazů, které budou jenom česky.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 02.03.2009


Pojem - Překryvný seznam

Jedná se o výběrové pole s již programově definovanou nabídkou možností k výběru. Tuto nabídku není možno uživatelsky rozšiřovat, je možno ji pouze pomocí překladu textů přejmenovat podle svých vlastních potřeb. Překryvné seznamy jsou použité především na výběrových záložkách, při definování vlastností artiklů apod.

Jak jsme již zmínili výše, nabídku překryvných seznamů je možno přejmenovat podle vlastních potřeb pomocí překladu textů (resp.po stisku pravého tlačítka myši po zatržení atributu režim oprav). Tuto definici je možno provést dvojím způsobem:

¨ prostým výčtem – hodnota vybrané položky je daná jejím pořadím v přeloženém textu v atributu návěští popisu (např. Vše,Uvažovaný,Zamítnutý,Odložený,Schválený,Rozpracovaný,Ukončený)

¨ výčtem s uvedením hodnot – hodnota vybrané položky je daná numerickou hodnotou, která je v seznamu (atribut návěští popisu) uvedena bezprostředně za danou položkou (např. Vše,1,Uvažovaný,2,Zamítnutý,3,Odložený,4,Schválený,5,Rozpracovaný,6,Ukončený,7). Použití překladu obsahu překryvného seznamu způsobem „výčtem s uvedením hodnot“ zároveň umožňuje vyloučit z překryvného seznamu hodnoty, které v dané implementaci nemají smysl (např. Vše,1,Uvažovaný,2,Schválený,5,Ukončený,7). Při definici hodnot překryvného seznamu touto metodou musí platit:

- celkový počet položek seznamu je sudý (tzn. každý popis musí mít zároveň svoji numerickou hodnotu)

- na sudých pozicích seznamu jsou uvedena celá čísla (např. Vše,1,Uvažovaný,2 ....)

- alespoň jeden text (tj. návěští popisu) na liché pozici v seznamu není celé číslo (např. text ‘1,2,3,4’ není považován za obsah definovaný výčtem s uvedením hodnot)

- nesmí existovat hodnota překryvného seznamu, která by se opakovala (např. text ‘Vše,1,Schválený,5,Uvažovaný,1‘ není považován za obsah definovaný výčtem s uvedením hodnot)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 21.02.2008


Pojem - Přepočet hodnot

V rámci každé komponenty [1] lze uživatelsky definovat druhy hodnot, které informační systém bude automatizovaně aktualizovat. Druhem hodnoty[2] se rozumí např. stav skladu ve finančním vyjádření, stav skladu v naturálním vyjádření, finanční stav zásob za celý sklad apod. Tyto hodnoty se automatizovaně aktualizují na základě numerických údajů (atributů) událostí.

Druhy hodnot mohou být rozděleny do čtyř skupin z hlediska cílových entit (tj. souborů, kam se zapíší vypočtené hodnoty). Z tohoto pohledu může každý druh hodnoty aktualizovat libovolnou kombinaci těchto entit obsahujících vypočtené hodnoty:

¨ aktuální

¨ obrat (není implementováno pro všechny komponenty)

¨ saldokontní

¨ statistické

Činnost přepočet hodnot slouží uživateli k přepočtu právě těchto druhů hodnot (v případě, že se změní pravidla nastavení u některého druhu operace, např. uživatel bude chtít sledovat jiné aktuální hodnoty nebo v případě nesrovnalostí na obratech skladu je možno spustit přepočet hodnot obratů). Činnost Přepočet hodnot má uživatel k dispozici v menu Informační centrum – Statistika, selektory – Přepočet hodnot. Po spuštění této činnosti si uživatel zvolí ze seznamu komponent, jejichž hodnoty chce přepočítat a zároveň si zvolí (zatrhne) druhy hodnot, které chce přepočítat. Dobu přepočtu jednotlivých hodnot systém zaznamenává do tabulky rezervovaných zdrojů.

[1] Daný druh hodnoty lze aktualizovat pouze událostmi dané komponenty (kromě saldokontních hodnot).

[2] Druhy hodnot má uživatel k dispozici v činnosti Informační centrum – Typy a řady – Komponenty a u každé jednotlivé komponenty jsou druhy hodnot dostupné po stisku F7.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Přepočet obratové tabulky

Přepočet obratové tabulky má uživatel k dispozici v hlavním menu - Účetnictví - Speciální činnosti. Přepočet obratové tabulky slouží k aktualizaci hodnot v obratové tabulce. Během účetního období může uživatel provést v komponentě účetnictví změny v nastavení a pak se někdy hodnoty v obratové tabulce mohou jevit jako „zavádějící“. V takovém případě je vhodné aktivovat přepočet obratové tabulky, nejčastějším důvodem je:

¨ změna strany účtu v účtovém rozvrhu

¨ změna sledování obratů za jednotlivé selektory v účtovém rozvrhu

¨ změna hodnoty atributu „obrat v ZM“

Po spuštění této činnosti je uživatel dotázán na účetní období, za který chce provádět přepočet, ten si vybere z překryvného seznamu a pak je systémem ještě znovu položen dotaz, zda opravdu provést přepočet. Po potvrzení volby Ano je proveden přepočet obratové tabulky. Přepočet obratové tabulky blokuje pro ostatní uživatele možnost účetních zápisů po dobu přepočtu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.09.2008


Pojem - Přepočet práv přístupu

Činnost přepočet práv přístupu je pro uživatele dostupná v menu SYSTÉM v činnosti uživatelé programu a skupiny uživatelů v menu Volby. Přepočet práv přístupu slouží k tomu, aby se nastavená práva správně zaznamenala a při práci jednotlivých uživatelů s IS BM uplatňovala. Při nastavování přístupových práv k funkcím je nutno spustit přepočet práv přístupu pouze v případě, že uživatel zadal do systému novou skupinu nebo nového uživatele (nebo změnil jeho zařazení do jiné skupiny), při vlastním definování přístupových práv v činnosti „oprávnění k činnostem“ pro jednotlivé skupiny není nutno přepočet spouštět.

V případě, že uživatel definuje přístupová práva přes mapu přístupových práv, je nutno pustit přepočet vždy.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Přepočet účetního saldokonta

Přepočet účetního saldokonta má uživatel k dispozici v hlavním menu - Účetnictví - Speciální činnosti. Přepočet účetního saldokonta slouží k aktualizaci saldokontních hodnot. Uživatel tuto činnost aktivuje v případě, že:

¨ během účetního období označí uživatel nesaldokontní účet v účtovém rozvrhu jako saldokontní (anebo naopak) - pak je nutné hodnoty tohoto účtu znovu přepočítat.

¨ zjistil nejasnosti v saldokontu za konkrétní IDP nebo účet a tzv. si s nimi neví rady

Po spuštění této činnosti má uživatel možnost zvolit si pro přepočet konkrétní IDP nebo účet. V případě, že ponechá nabídnutý výběr prázdný, přepočítává se saldokonto u všech účtů i IDP najednou.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.09.2008


Pojem - Přihlášení

Tento pojem zastřešuje možné způsoby přihlašování. Přihlášení znamená, že uživatel je vyzván k určité součinosti, tzn. k zadání jména, hesla, otisku prstů apod. Po tomto zadání následuje přihlášení, kdy je vyhodnoceno, zda zadané údaje jsou správné a uživatel je přihlášen. Běžné je přihlášení k informačnímu systému, k terminálu, ale uživatel se může, pokud to tak má nastaveno, tímto způsobem přihlašovat i např. k aplikaci pošty nebo do zaheslovaných dokumentů apod.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 31.07.2015


Pojem - Přihlášení do informačního systému

Přihlášení do IS BM uživatel provede dvojklikem na ikoně BM, pokud systém spouští z plochy PC, jinak aktivováním souboru bm.exe v adresáři BMSQL. Uživateli se zobrazí okno „přihlášení uživatele“, kde při prvním přihlášení do kolonky uživatel zapíše své jméno (ve stejném tvaru jako je jeho jméno zadáno v činnosti „uživatelé programu“ – toto mu sdělí správce systému) a do druhé kolonky heslo napíše své vstupní heslo. Po stisku tlačítka OK nebo klávesy Enter proběhne přihlášení uživatele do systému. Při každém dalším přihlášení je již jeho jméno předplněno, zapíše vždy jen přístupové heslo. Systém uchovává informace o historicky přihlášených uživatelích, pouze při prvním přihlášení jednotlivého uživatele k BM je tento seznam prázdný (viz. BWLCL.INI).

Po prvním přihlášení do IS BM je možno provést změnu hesla. Uživatel si zadá své současné platné heslo, potom klikne na tlačítko Změna hesla. Tam dvakrát (atribut nové heslo a kontrola hesla) zadá nové přihlašovací heslo a stiskne OK. V případě, že by své nově zadané heslo náhodou zapomněl, může správce BM provést inicializaci hesla.

V případě, že se jedná o přihlášení do multiverze BM, je zobrazení pro uživatele poněkud odlišné. Po spuštění IS BM (stiskem ikony nebo souboru bm.exe) se uživateli zobrazí okno „ výběr datového zdroje“, kde se mu nabízí jednotlivé verze IS BM, kde si uživatel vybere příslušný zdroj (tj. verzi IS BM) a stiskne tlačítko OK. Následně se mu spustí okno „přihlášení uživatele“, které je stejné jako při běžném přihlášení. I změna hesla je potom shodná s výše uvedeným popisem.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 31.07.2015


Pojem - Přihlášení k terminálu

Pro přihlášení k terminálu platí stejná pravidla jako pro klasické přihlášení do informačního systému. Uživatel musí zadat (nelze vybírat z překryvného seznamu) své jméno a přihlašovací heslo. Funguje stejné heslo jako pro přihlášení do IS BM. V případě, že se jedná o úplně vůbec první přihlášení k terminálu a uživatel si dosud nezměnil původní (námi dodané) heslo do IS BM, může se stát, že heslo z IS BM nebude fungovat. Potom je nutno provést změnu přihlašovacího hesla do IS BM, proto aby se zaktualizovalo hash heslo uživatele.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 31.07.2015


Pojem - Přihlášení uživatelé

Přihlášení uživatelé do informačního systému Bílý Motýl jsou ti, kteří se přihlásili pomocí svého jména a vstupního hesla. Mohou pracovat v některé z činností IS BM nebo mohou mít pouze hlavní menu IS BM „shozeno“ na dolní liště PC. Každého přihlášeného uživatele systém eviduje a poskytuje o něm přehled v činnosti „přehled přihlášených“ (menu SYSTÉM).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Příjmy a náhrady

Činnost Příjmy a náhrady je součástí sekce DEFINICE (komponenta Mzdy). Jedná se o činnost, ve které je možné nastavit jednotlivé mzdové položky, které během výpočtu vytvoří hrubou část mezd.

Význam jednotlivých položek je následující:

¨ identifikace - jednoznačná identifikace mzdové položky

¨ příjem - popis mzdové položky

¨ původ Kč/j - původ Kč za jednotku. Může nabývat těchto hodnot:

¨ zadaná částka - do Kč / j se přenese hodnota uvedená u příjmu, nebo u pravidelného příjmu na kartě pracovníka. Hodnota na kartě má přednost před hodnotou uvedenou u příjmu!!! Např. při zadávání klasické měsíční mzdy se do Kč/j neuvede nic, protože se to uvede u každého pracovníka zvlášť (na jeho kartě). Tato možnost se použije též u prémií a odměn.

¨ dle tarifu prac. - do Kč / j se po zadání ke konkrétnímu pracovníkovi přenese jeho sazba uvedená v jeho tarifní třídě (tato tarifní třída odpovídá jeho tarifní stupnici).

¨ úkolová dle tar. prac. - příjem s touto hodnotou musí mít vyplněnou volbu úkolová - tarifní. V této volbě se zadá kombinace tarifní stupnice a tarifní třídy a hodnota Kč/j. Tato hodnota Kč/j není shodná s hodinovou mzdou uvedenou v číselníku tarifních stupnic a jejich tříd. Např. daný pracovník má přidělenu tarifní stupnici A a tarifní třídu 5 s hodinovou mzdou 56,- Kč. U mzdové položky je ve volbě úkolová - tarifní pro stupnici A a tarifní třídu 5 uvedena hodnota Kč/j 70,- Kč. Při použití takové mzdové položky (která má tedy uveden původ Kč/j - úkolová dle tarifu pracovníka) bude program automaticky počítat s hodnotou 70,- Kč/j.

¨ vyšší ze zadaná částka - tarif pracovníka - porovná se hodnota Kč/j a tarif pracovníka

¨ vyšší ze zadaná částka - úkolová dle tar. prac. - porovná se hodnota Kč/j a tarif pracovníka. V tomto případě se tarif pracovníka zadává přímo v této činnosti pomocí volby Úkolová-tarifní.

¨ hod.průměr - do Kč / j se přenese hodnota uvedená na kartě pracovníka, tj. hodinový průměr. Tento původ Kč/j se využije např. při zadávání dovolené hodinově, paragrafu, ......

¨ den.průměr - do Kč / j se přenese hodnota uvedená na kartě pracovníka, tj. denní průměr. Tento původ Kč/j se využije např. při zadávání denní dovolené, .....

¨ měs.průměr - do Kč / j se přenese hodnota uvedená na kartě pracovníka, tj. měsíční průměr.

¨ vzorce - vzorec pro zjištění položky Kč/j

- vzorec pro zjištění položky koeficient - vzorec pro koeficient se bude používat až ve výpočtu, pro zjištění skutečného koeficientu. Vzorec pro koeficient může záviset na pracovníkovi, na jeho pracovním poměru, na mzdové položce v aktuálním měsíci apod. Pokud je z hlediska obsahu vzorce možné ho v činnosti Příjmy a náhrady vyčíslit, pak se přímo v této činnosti zapíše, jinak zůstane na hodnotě 1 a vzorec se uplatní až později. Uplatňuje se při výpočtu v kombinaci s použitím mzdové položky v Pravidelných příjmech. Může být zapsán i výrazem ve tvaru FoxPro (tzn. vytvořen select např. že když pracovník nepřekročí určitou výši vyrobených zmetků, tak má nárok na 20% prémií apod.).

¨ Kč / j - korun za jednotku (např. výkonu, hodin, ....)

¨ koeficient - koeficient, jímž se násobí Kč/j

¨ výpočet Kč - způsob výpočtu celkové částky Kč (výběr z možností). Ač to u této položky není uvedeno (kvůli nedostatku místa) je každá tato možnost při výpočtu mzdy násobena koeficientem.

¨ dopl. údaje - jednoznačná identifikace doplňující položky mezd

¨ vyplatit v penězích - zda vyplácet částku (v Kč) v hotovosti

¨ tisknout - zda se položka má tisknout na výplatním lístku

¨ povoleny nulové dny – zaškrtnutím je povoleno uvést počet dnů 0 (u příjmové položky, která vznikla pomocí pravidelných příjmů je nutná možnost zápisu odlišných hodin a odlišných dnů)

¨ povoleny nulové hodiny – zaškrtnutím je povoleno uvést počet hodin 0

¨ komentář - bližší popis k dané mzdové položce

¨ platnost položky od data do data (datum zahájení a datum ukončení platnosti položky)

¨ druh události – identifikace druhu účetní události (výběr z číselníku)

¨ technický selektor – možnost výběru z číselníku technicko-věcných selektorů

Pokud se jedná o úkolovou - tarifní mzdovou položku, je nutno na záložce "úkolová - tarifní" zadat další údaje, které se týkají právě této položky. Zadává se tarifní stupnice, třída a Kč/j (viz. příklady vyplnění uvedené výše v popisu).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 25.11.2008


Pojem - Příkaz „dyn“ v parametrech řádku nebo sloupce definice listu výkazů

V atributu parametry řádku či sloupce definice listu je možné na prvním řádku uvést příkaz dyn, který umožní z jedné definice řádku (sloupce) dynamicky vygenerovat při sestavení výkazu tolik řádků (sloupců), kolik funkce fce vrátí prvků v Seznamu.

Syntaxe příkazu s funkcí výkazu: DYN parv=fce(par1,par2,…,parn), kde:

¨ parv – parametr, který postupně bude nabývat všech hodnot Seznamu vráceného funkcí

¨ par1-parn – parametry, se kterými je funkce volána

¨ fce – funkce výkazu, která vrací hodnotu typu Seznam obsahující všechny budoucí hodnoty parametru parv

Například:

Uvedení DYN adr=ADKAT000('BIMO%'), s využitím funkce výkazů ADKAT000 pro sestavení Seznamu, v atributu parametr jednoho řádku definice listu vygeneruje při sestavení výkazu tolik řádků, kolik prvků seznamu vrátí funkce ADKAT000 (zde například fce vrátí názvy všech adresátů v kategorii BIMO).

Syntaxe příkazu s funkcemi IS BM: DYN parv=SEZNAM(sez,typ,len,dec) nebo DYN parv=SEZNAMD1(d1,d2) nebo DYN parv=SEZNAMD2(m1,r1,m2,r2), kde:

¨ sez – seznam hodnot oddělených středníkem

¨ typ – typ hodnot v seznamu (C, N, D, T nebo M)

¨ len – délka pro typ C a N

¨ dec – počet desetin pro typ N

¨ d1 – datum počátku (typ D)

¨ d2 – datum konce (typ D)

¨ m1 – měsíc počátku

¨ r1 – rok počátku

¨ m2 – měsíc konce

¨ r2 – rok konce

SEZNAM je funkce IS BM, která postupně vrací hodnoty ze seznamu sez, např.: DYN selor=SEZNAM('112%;1135_[^5]%;2%',’C’) vygeneruje při sestavení výkazu tři řádky nebo DYN mes=SEZNAM(‘1;2;3;4;5;6;7;8;9;10;11;12’,’N’,2,0) vygeneruje při sestavení výkazu dvanáct řádků nebo DYN sel=SEZNAM(‘153%;123%;1456%’,’M’) vygeneruje při sestavení výkazu tři řádky.

SEZNAMD1 je funkce IS BM, která postupně vrací hodnoty ze seznamu datumů v intervalu od data d1 do data d2 po měsících, např.: DYN datum=SEZNAMD1({1.1.1990},{1.3.1990}) vrátí tyto datumy: 1.1.1990,1.2.1990 a 1.3.1990 a vygeneruje při sestavení výkazu tři řádky.

SEZNAMD2 je funkce IS BM, která postupně vrací hodnoty ze seznam datumů v textové formě „mm.rrrr“ od měsíce m1 a roku r1 do měsíce m2 a roku r2 po měsících, např.: DYN dat=SEZNAMD2(‘11’,’1990’,’02’,’1991’) vrátí tyto hodnoty: ’11.1990’, ’12.1990’, ’01.1991’ a ’02.1991’ a vygeneruje při sestavení výkazu čtyři řádky.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Přílohy k předloze

Zde je možno definovat nebo prohlížet přehled příloh, které jsou připojeny k dané předloze. Nadefinované předlohy výstupu se poté automaticky s předlohou načítají i při exportu předlohy do balíčku.

Přílohou k předloze výstupu se rozumí externí soubor uložený na disku, který je nutný pro její správnou funkčnost. Přílohou k předloze výstupu může být např. soubor:

¨ template pro předlohu výstupu typu Excel (soubory s příponou XLT, XLTX, XLS, XLSX)

¨ obrázek použitý v klasické předloze výstupu (např. firemní logo)

Přílohy k předloze výstupu má uživatel k dispozici po stisku pravého tlačítka myši na předloze pod volbou „přílohy k předloze“. Zde si může prohlížet již nadefinované přílohy (k jedné předloze je možné definovat i větší počet příloh) či vkládat novou přílohu. Při zakládání nové předlohy uživatel stiskne ikonku „Nová“ a zadá:

¨ jméno souboru (doporučuje se uvádět jméno souboru s relativní cestou)

¨ poznámku

Při potřebě zrušení některé přílohy stačí umístit kurzor na název přílohy v horní části formuláře a poté stisknout ikonku „Odstranit“.

Kopie obsahu souboru přílohy je ukládána v databázi ve formátu ZIP a přitom se používá knihovna VFPCOMPRESSION.FLL, která je obvykle uložena v adresáři PRGS (bez existence knihovny VFPCOMPRESSION.FLL není možné přílohy definovat). Kopie jednoho souboru se stejným názvem je v databázi uložena pouze jedenkrát a při rušení záznamu o příloze k předloze výstupu je kopie souboru v databázi automaticky zrušena v případě, že se jedná o soubor, který není uveden jako příloha žádné jiné předlohy výstupu a také se nejedná o soubor uvedený u některé Šablony listů výkazů.

Ve formuláři pro definování příloh se zobrazuje datum a čas kopie souboru, která je uložena v databázi. Při zápisu dat formuláře se porovnává tento datum a čas s datem a časem souboru, který uložen na disku a v případě, že se nerovnají (+- 2 vteřiny), je nabídnuta možnost zápisu kopie obsahu souboru do databáze. Při otevírání formuláře pro definování příloh se porovnají datum a čas kopie souboru a datum a čas souboru jednotlivých příloh, a jestliže se pro některou z nich nerovnají (+- 2 vteřiny), pak je formulář otevřen s aktivním tlačítkem OK.

V seznamu příloh funguje dvojí klik v seznamu příloh, kterým je vyvolán podle přípony souboru program (např. Excel), který otevírá soubor přílohy uložený na disku.

Při spuštění nebo opravě předlohy výstupu, je prováděna kontrola, jestli všechny její přílohy na disku existují a v případě, že neexistují jsou „vybaleny“ jejich kopie z databáze. Provádí se pouze kontrola existence souboru, vůbec se neporovnává datum a čas souboru (tj. nedochází k přepisu souboru na disku ani v případě, že je starší než jeho kopie v databázi). Podmínkou pro tuto funkci je existence knihovny VFPCOMPRESSION.FLL, pokud není tato knihovna nainstalována, potom se při spuštění nebo opravě předlohy výstupu objeví hlášení „Sestava obsahuje přílohy, které není možné vybalit, protože nemáte nainstalovanou knihovnu VFPCOMPRESSION.FLL“.

Po ukončení opravy předlohy výstupu typu Excel, Word nebo Ostatní je analyzována její definice (i když nebyla definice změněna) a v případě, že v ní byly zjištěny odkazy na soubory existující na disku, které by měly být uvedené jako přílohy dané předlohy, potom je automaticky vyvolán formulář pro definování příloh, ve kterém jsou tyto nové přílohy připravené k zápisu.

Při exportu předlohy výstupu do balíčku, jsou exportovány také její přílohy včetně kopie obsahu souboru přílohy. Import balíčku nikdy nepřepisuje existující kopii souboru přílohy v databázi a ani neprovádí její „vybalení“ do souboru na disku (to se provede až při prvním spuštění nebo první opravě předlohy výstupu nebo po dvojím kliku v seznamu příloh).

Knihovna VFPCOMPRESSION.FLL požaduje pro svou funkci ve Windows starších než Vista existenci souborů C:\WINDOWS\SYSTEM32\MSVCP71.DLL a C:\WINDOWS\SYSTEM32\MSVCR71.DLL.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 16.02.2012


Pojem - Připojené okno

Je forma zobrazení dat při jejich prohlížení pohledem slovníku dat, kdy data nejsou zobrazena jen v řádcích[1] dle databázových záznamů výchozí tabulky, ale ke každému řádku je k dispozici okno, kde mohou být prezentovány všechny atributy (údaje) řádku.

Při použití pohledu na webu je definice připojeného okna podmínkou pro možnost zobrazení doplněných oken, ULR odkazů v tabulkách, ...apod.

[1] Všechny atributy záznamu obvykle nelze shlédnout na obrazovce bez rolování

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Příprava definice listu výkazů pomocí vzoru listu

Pro tuto metodu definice listu je charakteristická řádková orientace jejího nastavení při pevném maximálním počtu sloupců výkazu, tj. maximálně tři pevně definované ve vzoru a maximálně devět zde definovaných.

Řádek je definován identifikátorem, pořadím, názvem, implicitním formátem jeho buněk a případně, zda ve výkazu bude skrytý. Pro každou ze zmíněných devíti buněk řádku může uživatel definovat název buňky, formát a způsob naplnění jejího obsahu (typ výpočtu) a to: žádný, vzorec (takto definované řádky se zobrazují v gridu šedě), výpočet anebo některý z výrazů daného vzoru, přičemž v tomto případě současně definuje hodnotu parametrů výrazu vzoru.

Pro každý sloupec je možné zde definovat jeho nadpis, implicitní formát a jeho šířku (-1 znamená skrytý). Pro list se zde definuje nadpis listu a název záložky.

Na základě těchto uživatelských nastavení je automaticky vygenerována definice listu výkazů.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Přístupová práva

Jedná se o informace, k jakým funkcím (činnostem) a kterým datům (věc s přístupem) má daný uživatel přístupové právo. Dle těchto informací IS poskytuje své funkce a data uživatelům.

Na začátku je nutno upozornit, že před vlastním zahájením práce s přístupovými právy je v informačním systému „všechno povoleno všem” (přesněji je to povoleno skupině "každý uživatel systému"), tzn. že postup nastavení práv je vybrané činnosti a data jednotlivým uživatelům zakazovat. Toto se nevztahuje na činnosti, které jsou primárně přístupné pouze SPRÁVCI.

Do systému se jako prvotní zadávají jednotliví uživatelé programu, kteří se pak následně zařazují do různých skupin uživatelů, tzn., že právo (k čemukoliv) se nastavuje pro celou skupinu uživatelů. Součástí systému je vždy skupina „každý uživatel systému”, do které je automaticky zařazen každý uživatel (v případě potřeby jej z této skupiny lze vyřadit), který je evidován v systému. Nastavené právo pro skupinu je implicitní pro uživatele do skupiny zařazené, pokud je nutno pro některého uživatele nastavit právo odlišné oproti skupině, je toto právo explicitní.

Aby byla efektivita práce co nejvyšší, je vhodné zvolit tento pracovní postup:

¨ v menu SYSTÉM v činnosti „skupiny uživatelů” si uživatel založí jednotlivé skupiny uživatelů, které si sestaví podle jakéhosi vnitrofiremního uspořádání (např. organizačního řádu). Při vytváření skupin uživatelů je možno doporučit sestavovat jednotlivé skupiny uživatelů podle toho, jaký je jejich klíčový úkol, čímž je pak vyřešen i problém při výměně pracovníka, změně pracovní náplně apod.

¨ v menu SYSTÉM v činnosti „uživatelé programu” uživatel zadá jednotlivé pracovníky, kteří budou s informačním systémem nějakým způsobem pracovat. U každého pracovníka se zadává jméno a rodné číslo[1], podle kterého systém automaticky vygeneruje vstupní heslo pro první vstup do systému. Na záložce „skupiny uživatelů” pak uživatel u každého jednotlivého zapsaného uživatele zatrhne skupinu, do které tento uživatel náleží.

Uživatel (v případě definice přístupových práv v činnosti „oprávnění k činnostem“ je to pouze „správce“) má k dispozici ještě i činnost „mapa přístupových práv“, která je určena pro usnadnění definování práv přístupu k druhům procesů, druhům operací, umístění komponent apod. Při změně nastavení přístupových práv je nutno spustit činnost přepočet práv přístupu. Definování přístupových práv může uživateli značně ulehčit i využití činnosti pravidla inicializací přístupových práv.

Na základě objektu s přístupem i způsobu definování je možno přístupová práva rozdělit na dvě základní skupiny:

¨ přístupová práva k funkcím

¨ přístupová práva k věcem s přístupem (tj. k datům)

[1] Pokud se rodné číslo nezadá (tzn. jeho vstup se zruší klávesou ESC), uživatel má pak možnost zadat identifikaci uživatele ručně, jinak po vstupu rodného čísla je vygenerována automaticky.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Přístupová práva - alokace

Nastavením práv k alokacím se rozumí práva k jednotlivým umístěním, tzn. ke skladům, k pokladnám, k účtům apod. Právo nabývá některé z těchto variant:

¨ - - události, aktuální hodnoty, obraty, alokace – nejsou k dispozici,

¨ čtení - je možno prohlížet vytvořené události jednotlivých alokací, aktuální hodnoty, obraty apod., není možno provádět jakékoliv změny,

¨ zápis - události jednotlivých alokací je možno zapsat, prohlížet, editovat

Práva k alokacím se nastavují vždy přímo v dané činnosti po stisku klávesy Ctrl B nebo z menu volby činností „přístupová práva”. Postup definování je shodný s popisem uvedeným v kapitole přístupová práva k věcem s přístupem.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Přístupová práva – druh informace

Nastavením práv k druhům informací se rozumí práva k jednotlivým druhům dokumentům, druhům výkazů, druhům volných karet, druhům importů, druhům šablon, druhům dokumentů, druhům prvků WEB, druhům doplň. vlastnostem formuláře a druhům adresátů. Právo nabývá některé z těchto variant:

¨ - - uživateli se druhy informací vůbec nezobrazují

¨ čtení - uživatel si může druhy informací prohlížet a číst (např. přečíst si daný dokument, spustit prohlížení volné karty apod.), ale nemůže je vytvářet ani opravovat

¨ zápis - uživatel může dané druhy informací opravovat, ale i zadávat nové (tzn. vytvořit novou šablonu, založit nový dokument, vytvořit nový výkaz apod.).

Práva k druhům informací se nastavují vždy přímo v dané činnosti po stisku klávesy Ctrl B nebo z menu volby činností „přístupová práva”. Postup definování je shodný s popisem uvedeným v kapitole přístupová práva k věcem s přístupem.

Přístupová práva k funkcím

Jedná se o funkce (činnosti), které jsou dostupné v činnosti Oprávnění k činnostem, a tu má možnost editovat pouze správce (v popisu budeme dále používat oslovení uživatel), pokud vybranému uživateli nebyla přiřazena práva jako správci.

V této činnosti uživatel tedy nastavuje přístupová práva k vybraným činnostem POUZE pro jednotlivé skupiny uživatelů. Uživateli se zobrazí okno, které obsahuje přehled všech činností z hlavního menu a zároveň přehled skupin uživatelů.

Každou činnost mají implicitně přístupnou všechny skupiny, pak je přehled skupin uživatelů v pravé části okna zobrazen v modré barvě, explicitně však u většiny činností mají přístup pouze vybrané skupiny uživatelů a ty jsou nejen zobrazeny modře (ostatní skupiny černě), ale ještě jsou „zaškrtnuty”. Při vytváření práv k jednotlivým činnostem tedy uživatel postupuje od činnosti k činnosti a zaškrtnutím příslušné skupiny uživatelů ji k této činnosti přiřazuje právo. Vrácení se na činnosti hlavního menu se nebo na činnosti o úroveň výš se provádí pomocí tlačítka „zpět“. U některých činností je možno nastavit přístupové právo až na úroveň editačních činností, tzn. že pokud je to u dané činnosti možné, je přístupná záložka „editační činnosti”, kdy je možno pro jednotlivé skupiny nastavit, zda mají právo vkládat, opravovat, rušit apod. V případě, že daná skupina nemá k některým činnostem přístupové právo, pak se uživatelům této skupiny[1] tyto činnosti po přihlášení se do systému vůbec nenabízejí v činnostech hlavního menu.

Je důležité si uvědomit, že některé činnosti lze spustit z různých míst IS, ale právo stačí nastavit pouze jedenkrát.

[1] Pokud současně nejsou zařazeni do skupiny, která právo má, pak by se jim nabízely.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 02.09.2008


Pojem - Přístupová práva – operace

Nastavením přístupových práv k operacím se rozumí práva k jednotlivým nadefinovaným druhům operací, které mohou nabývat těchto hodnot:

¨ - - uživatel nemá žádné právo k operaci (nevidí události jednotlivých operací, nemá možnost operaci ani spustit, ani editovat),

¨ čtení - je možno prohlížet vytvořené události jednotlivých operací, aktuální hodnoty, není možno provádět jakékoliv změny ani spustit operaci.

¨ zápis - události jednotlivých operací je možno zapsat, prohlížet, editovat, je možno operaci spustit, prohlížet i editovat

¨ zakázáno opravovat - pokud je tato možnost zatržena, není již možno ukončenou operaci opravovat (atributy událostí, které lze opravovat i po ukončení operace, např. poznámka, komentář jsou opravě dostupné)

¨ zakázáno ukončit operaci - pokud je tato možnost zatržena, je možno operaci spustit, opravovat, prohlížet i zapsat, není však možno ji ukončit. Toto nastavení má smysl, pokud se na vytvoření operace podílí více uživatelů, tzn. že jeden uživatel ji zahájí a druhý po kontrole schválí a ukončí.

U operací, které běží na pozadí platí, že i uživatel, který k operaci nemá jinak žádné právo nebo pouze právo čtení, dostává v tomto případě přechodné právo zápisu.

Tato práva se nastavují v menu Informační centrum – Typy a řady – Druhy operací po stisku klávesy Ctrl B nebo zvolením příslušné činnosti z menu Volby. Postup definování je shodný s popisem uvedeným v kapitole přístupová práva k věcem s přístupem.

Nefunguje teď v účetnictví - dostupné i události ze zakázaných operací.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.03.2006


Pojem - Přístupová práva – proces

Nastavením přístupových práv k procesům se rozumí práva k jednotlivým nadefinovaným druhům procesů. Tyto práva se vztahují pouze k možnosti zahájení procesu, vytvořené procesy jsou pak přístupovými právy chráněny i v činnosti Procesy (Procesy a operace – Procesy). Tyto práva mohou nabývat těchto hodnot:

¨ - - uživatel nemá právo zahájit proces

¨ čtení - uživatel nemá právo zahájit proces

¨ zápis - je možno zahájit proces (právo zápis znamená právo pouze zahájit proces, ostatní nastavení jako prohlížení a editace vyplývá z nastavení práv k jednotlivým operacím. Jedná se o to, aby např. pracovnice obchodu nezahájila omylem proces skladového výdeje, do kterého má právo se pouze v operaci „dodání“ napojit, nemá právo tento proces zahájit).

¨ zakázáno opravovat – tato volba nemá v nastavení příst. práv k procesům smysl (měla by fungovat tak, že zamezí opravovat diagram procesu daného druhu, ale z praxe je ověřeno, že tomu tak není)

Tato práva se nastavují v menu Informační centrum – Typy a řady – Druhy procesů po stisku klávesy Ctrl B nebo zvolením příslušné činnosti z menu Volby. Postup definování je shodný s popisem uvedeným v kapitole přístupová práva k věcem s přístupem.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.03.2006


Pojem - Přístupová práva k věcem s přístupem

Přístupová práva k datům (věc s přístupem) nejsou primární činností správce, může je definovat kterýkoliv z uživatelů, pokud nemá v činnosti „oprávnění k činnostem“ zakázány přístupová práva k jednotlivým datům (tzn. pokud má uživatel např. přístupové právo k umístění obchodu nebo skladům, tzn. má zde dostupnou a vysvícenou ikonu pro vstup nového záznamu (tj. F3), má u této činnosti i právo definovat přístupová práva po stisku Ctrl B). Přístupová práva je možno definovat vždy po aktivaci příslušné činnosti (přehled věcí s přístupem) stiskem klávesy Ctrl B nebo z menu Volby.

Práva k datům se tedy nastavují vždy přímo v dané činnosti po stisku klávesy Ctrl B nebo z menu volby činností „přístupová práva”. Uživatel může pro nastavení přístupových práv využít i činnost mapa přístupových práv. Zobrazuje se vždy přehled všech datových činností (alokace, operace, proces apod.) se zobrazením aktuálního přístupu jednotlivých pracovníků. V první řadě je nutno změnit právo přístupu pro skupinu „každý uživatel systému” z práva zápis např. na čtení nebo žádné (-). Ve chvíli, kdy je upraven přístup pro skupinu „každý uživatel systému”, je všem ostatním skupinám právo k dané činnosti odepřeno. V tuto chvíli pak stačí vybrané skupině přiřadit k činnosti právo zápis. V případě, že vybraná skupina nemá právo k dané činnosti, je možno ho po stisku klávesy F3 nebo příslušné ikony (vložení nového záznamu) změnit.

Uživateli se zobrazuje přehled všech dosud nadefinovaných procesů a operací. Na záložce „práva“ je v pravé části formuláře přehled skupin uživatelů nebo jednotlivých uživatelů, kteří mají práva k danému procesu, tzn. že při definování přístupových práv je možno nadefinovat přístupové právo buď celé skupině uživatelů nebo jen vybraným uživatelům. (přístupová práva se definují po stisku klávesy F3 nebo po volbě ikony „vložení nového záznamu“).

Po stisku záložky "aktuální práva" se zobrazí přehled uživatelů, kteří mají v danou chvíli přístupové právo k danému procesu nebo operaci.

Takto se obecně nastavují přístupová práva k datům, která je možno rozdělit na práva k:

¨ alokacím

¨ operacím

¨ procesům

¨ druhům informací

Implementační poznámky:

Odlišně se zobrazují práva v objektových vazbách. Uživateli se v rámečku souvislostí zobrazí, že např. k dané události vývěsky je připojen dokument, který je synem dané události, nicméně, pokud uživatel k daným druhům dokumentů nemá přístupové právo, vidí sice v rámečku souvislostí plus (tedy příznak, že nějaký dokument svázaný objektovou vazbou existuje), daný dokument se mu však nezobrazí (pokud není připojen objektem typu zpráva). Objektově připojená zpráva totiž zpřístupní i záznamy, ke kterým by uživatel podle definice přístupových práv neměl přístup.

Další odlišností je, že události operací účetnictví nejsou nastavenými přístupovými právy hlídané, tzn. neuplatní se právo nastavené u druhu operace účetnictví. Jinými slovy, i v případě, že uživatel nemá k dané operaci účetnictví nastaveno žádné právo, události této operace se mu zobrazí.

Ve vazbách míry plnění není rovněž hlídán přístup podle druhu účetní operace, tzn. uživateli se zobrazí události operace účetnictví spojené s aktivní událostí pomocí objektové vazby, přestože k ní nemá žádné právo.

Při rozsáhlejším doplnění ve vlastnostech předlohy výstupu by implementátor měl vzít v úvahu přístupová práva k věcem, která má uživatel nastaveny, tzn. měl by dát pozor, aby uživateli doplněním v předloze výstupu nezpřístupnil údaje, která by měl mít na základě přístupových práv zakázány.

Jednotlivá nastavená práva k alokacím (např. sklady) se projeví zároveň jako práva (nebo „nepráva“) k obratům, tzn. pokud uživatel nemá přístupové právo k danému skladu, obraty tohoto skladu nebude mít k dispozici.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 07.03.2007


Pojem - Přístupové heslo

Jedná se o heslo, kterým se uživatel identifikuje a přihlašuje do informačního systému. Pro první spuštění informačního systému má uživatel přidělené heslo, které mu systém při zařazování uživatele do systému na základě kombinace jména a rodného čísla automaticky vygeneroval. Toto heslo má uživatel samozřejmě možnost si změnit. V případě, že by své změněné heslo zapomněl, provede správce inicializaci hesla, uživatel se bude do systému moci přihlásit zase původním (automaticky vygenerovaným) heslem, které si pak může opětovně změnit.

Při přihlašování do informačního systému si uživatel vybírá z překryvného seznamu uživatelů, pokud se v tomto seznamu jeho jméno nenabízí, je možno ho přímo zadat – klasicky vypsat (v tomto seznamu se nabízí jména těch uživatelů, kteří se do IS BM na tomto PC již přihlásili). Zapsáno by mělo být ve stejném tvaru, jako je uživatel uveden v činnosti „uživatelé programu“ (menu Systém – Uživatelé programu). Při příštím spuštění informačního systému se jeho jméno již nabízí v překryvném seznamu uživatelů.

Pokud si uživatel přeje změnit své současné vstupní heslo, při přihlášení zadá běžným způsobem své jméno a současné heslo a místo tlačítka OK zvolí tlačítko „změna hesla“, kde do kolonky „nové heslo“ zadá své nové zvolené heslo a pro kontrolu toto heslo zadá ještě jednou do kolonky „kontrola hesla“. Poté stiskne tlačítko OK nebo klávesu Enter a běžným způsobem se přihlásí do systému.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Přístupy k věcem

Jedná se o záložku s informacemi o přístupových právech k věcem s přístupem, která je dostupná v činnosti uživatelé programu a skupiny uživatelů. Informace na této záložce jsou naplněny automaticky podle nastavených přístupových práv, dojde-li však ke změně (např. vybranému uživateli je zpřístupněn nový druh operace nebo nový sklad apod.) je nutno spustit činnost „aktualizace seznamu věcí“ v menu Volby. Důležité jsou zde tři hlavní atributy:

¨ typ práva přístupu (atribut sp44typ)

¨ přistupovaná věc (sp44vec)

¨ popis přistupované věci (sp85nazpra)

V případě, že se jedná o přístupy k procesům, je první sloupec typ práva vždy prázdný a ve druhém sloupci je identifikace druhu procesu, kterého se přístupové právo týká. Pokud se jedná o operace, je v prvním sloupci vždy identifikace komponenty a ve druhém sloupci identifikace druhu operace. U přístupů k věcem (tj. umístěním apod.) jsou k dispozici tyto typy přístupů:

' ' | práva přístupu k procesům
DPH | práva přístupu k operacím DPH
MZV | práva přístupu k operacím mezd
OBC | práva přístupu k operacím obchodu
ODP | práva přístupu k operacím odpisovaného majetku
OKO | práva přístupu k operacím obecné komponenty
PLA | práva přístupu k operacím plateb
POS | práva přístupu k operacím pošty
SAB | právapřístupu k druhům šablon
SKL | práva přístupu k operacím skladu
SMU | práva přístupu k operacím spravovaného majetku
TDO | přístupy k typům dokumentů
TDV | právo přístupu k dopl. vlast. činnosti
TEP | právo přístupu k druhu externích příkazů
TIM | právo přístupu k druhu importu
TMZ TMC TMA | práva přístupu k umístění mezd právo přístupu k makrům přístup ke kategoriím pracovníků
TNK | právo přístupu k druhu parametru
TNZ TNA | právo přístupu ke zdroji proj. úkolu práva přístupu k zadání úkolů řešitele
TOK TOS | právo přístupu k umístění obecné komponenty právo přístupu k druhům stromů
TPR | právo přístupu k předloze výstupu
TPU TPA TSE TSA | právo přístupu k účtu/pokladně právo přístupu k druhu parametrů právo přístupu k umístění selektoru právo přístupu ke kategorii správy artiklu
TSK | právo přístupu ke skladům
TSM | právo přístupu k umístění spravovaného majetku
TUD | právo přístupu k umístění DPH
TUO | právo přístupu k umístění obchodu
TUP | právo přístupu k umístění plateb
TVK | právo přístupu k druhu výkazu
TVL | právo přístupu k výrobní lince
TVS | práva přístupu k druhům volných karet
TWD | právo přístupu k druhu prvku WEB
TZA | právo přístupu k umístění záloh
UCE | práva přístupu k operacím účetnictví
VR1 | práva přístupu k operacím výroby - výrobní zakázka
VR3 | práva přístupu k operacím výroby - vstupy a výstupy
VR4 | práva přístupu k operacím výroby - výrobní úkoly
VYM | práva přístupu k operacím vymáhání
VYV | práva přístupu k operacím vývěsky
ZAL | práva přístupu k operacím záloh
ZSP | práva přístupu k operacím změny stavu peněz

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 19.12.2014


Pojem - Půjčky, srážky, exekuce

Informace o půjčkách, srážkách a exekucích se evidují v komponentě Mzdy, na příslušných záložkách v činnosti Karta pracovníka.

Na záložku půjčky doporučujeme zadávat pohledávky, které mají nepřednostní fixní charakter a u kterých se splácí jedna pevná částka každý měsíc. Při uzávěrce mezd dojde o odečtení provedené splátky půjčky od zůstatku půjčky. Datum doručení soudního rozhodnutí je povinné.

Na záložku srážky doporučujeme zadávat pouze nepohledávky, např. srážku typu „vše na účet“. Datum doručení rozhodnutí je v tomto případě nepovinný. Na záložce srážky je možné zadat příspěvek zaměstnavatele na penzijní připojištění (tj. srážka, která má v definici uvedeno Srážet – procento ze základu SP) a zároveň odvod samotného zaměstnance na penzijní připojištění (tj. jako běžnou srážku).

Na záložku exekuce doporučujeme zadávat pohledávky přednostní či nepředností, s fixní měsíční splátkou či pohyblivou splátkou typu „tolik, kolik lze“. Datum doručení soudního rozhodnutí je povinný. Při uzávěrce mezd dojde k odečtení provedené splátky exekuce od zůstatku exekuce. Od zůstatku se odečte pouze taková částka, která byla skutečně sražena. Při tvorbě mzdových položek typu exekuce pečlivě volte první znak identifikace této mzdové položky. Podle identifikace se ve většině implementací třídí záznamy na výplatním lístku.

Ať už se jedná o půjčku, srážku či exekuci na záložce se u každé z nich zadávají tyto shodné údaje:

¨ identifikace mzdové položky (složitější nastavování, které by měl provádět pouze zkušený uživatel nebo implementátor)

¨ částka – celková exekuční částka

¨ zůstatek – exekuční částka k doplacení, její výši snižuje uzávěrka

¨ srážet – měsíční srážená exekuční částka (např. částka výživného)

¨ nedoplatek – slouží jenom pro účely výživného (jeho výši zvyšuje a snižuje uzávěrka)

¨ adresát – příjemce peněžních částek

¨ bankovní údaje příjemce

¨ typ – bankovní údaj (speciální bank.styk se spořitelnou)

¨ doručení – datum doručení exekučního rozhodnutí

¨ platnost záznamu od - do

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 31.01.2008


Pojem - QUICK info

Jedná se o vlastnost, kterou si uživatel může aktivovat pod menu Volby nebo jako ikonu v liště Nabídky (podle individuálního nastavení v implementaci uživatele). Vlastnost QUICK info poskytuje uživateli podrobný přehled o aktuálně spuštěných údajích na obrazovce, např. má-li uživatel aktuálně spuštěnou např. operaci účetnictví, má po aktivaci QUICK info k dispozici podrobný přehled o dané operaci, ale i o operacích, které jí předcházely. Všechny zobrazené informace lze zároveň i aktivovat.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.08.2008


Pojem - Referenční artikl výroby

Referenční artikl v podstatě slučuje definované artikly výroby a technologické operace do jednoho logického celku. Uživatel má k dispozici informaci, že právě touto technologickou operací (v dané variantě) je vyráběn tento artikl. Referenční artikly představují již zcela konkrétní případy výroby, kde určitý artikl lze vyrábět více technologickými operacemi a na druhou stranu určitou technologickou operací lze vyrábět více artiklů. U každého referenčního artiklu se definují následující atributy:

¨ identifikace technologické operace – výběr z číselníku

¨ varianta technologické operace (TO) – odlišuje referenční artikly se stejnou technologickou operací z pohledu vstupů (vztažené artikly) referenčního artiklu (např. výroba desky stolu – technologická operace „barvení desky namáčením“ – stejná technologická operace, ale jednou ve variantě M – modrá barva desky a podruhé ve variantě Z – žlutá barva desky)

¨ identifikace referenčního artiklu – referenční artikl vztahující se k dané technologické operaci (ve většině případů je to výstupní artikl dané technologické operace), např. u výše zmíněné TO „barvení desky namáčením“ je uveden artikl „natřený plech“

¨ druh linky – je daný příslušnou technologickou operací

¨ linka – implicitní linka pro daný referenční artikl. Je-li implicitní linka zadána, její hodnota při plánování výroby (tj. při generování výrobních úkolů) „přebije“ implicitní linku uvedenou u daného druhu linky.

¨ výkon. norma – počet kalkulačních jednic, vyrobených za jednotku času (uvedenou v parametrech TPV)

¨ opakování – hodnota, která vyjadřuje počet opakování jednoho výrobního úkolu (ovlivňuje jen čas trvání výrobního úkolu)

¨ normohodin – doba vyjádřená v jednotce času (uvedenou v parametrech TPV) na vyrobení jedné kalkulační jednice

¨ plus – připočítávaný konstantní čas délky kroku (výrobního úkolu) v minutách

¨ výkon. norma celkem – hodnota výkonové normy celkem (přepočtena podle výkon. norma * opakování)

¨ normohodin celkem – hodnota normohodin celkem (přepočtena podle normohodin * opakování)

¨ KV – kalkulační vzorec + identifikace proměnné kalkulačního vzorce – KV u referenčního artiklu definuje vzorec, podle kterého se počítá ocenění výstupu referenčního artiklu. Proměnná kalkulačního vzorce u vztaženého artiklu nebo u pracovních výkonů sděluje způsob, jakým bude vstup zahrnut do výpočtu ocenění výstupu referenčního artiklu podle daného KV.

¨ úložiště – identifikace skladového úložiště. Na základě svých výrobních potřeb si firmy definují své skladové prostory, tj. skladová úložiště. Nejčastěji jsou skladová úložiště shodná s počtem skladů. U daného referenčního artiklu definuje úložiště místo, kam se ukládá výstup referenčního artiklu. Typicky je shodné s úložištěm na artiklu výroby, který je výstupem referenčního artiklu. U vztažených artiklů definuje úložiště místo, odkud se vztažené artikly spotřebovávají. Typicky je shodné s úložištěm na artiklu výroby, který je vztaženým artiklem referenčního artiklu.

¨ směr – vstup (materiál) / výstup (meziprodukt, odpad) – u referenčního a vztaženého artiklu tato hodnota sděluje, zda se jedná o vstup nebo výstup výrobního úkolu. U výroby ve většině případů platí, že referenční artikly jsou výstupy a vztažené artikly vstupy (až na případné výjimky, např. odpad). Opačná situace je u „zpracovatelské“ výroby, kde referenční artikl je vstupem a vztažený artikl je výstupem výrobního úkolu.

¨ měřená položka – volba Ano/Ne. Označuje vstup nebo výstup, který je měřitelný. V případě volby Ano bude u tohoto artiklu možno při výrobě zjistit jeho množství na vstupu/výstupu (pomocný parametr pro identifikaci vstupů a výstupů, jejichž hodnoty ve výrobě je možné zjišťovat nějakým technologickým zařízením, např. automatická čtečka vyrobeného množství).

¨ jednotková cena – ceníková cena artiklu za měrnou jednotku v oceňovací jednotce

¨ minimální množství – definuje minimální množství pro vstup artiklu do následující operace, typicky používané při proudové výrobě. Tato hodnota má smysl jen u artiklů, jejichž „směr“ je vstup.

Následující záložky poskytují uživateli zpřesňující informace vztahující se k definici referenčních artiklů. Důležitá záložka je:

¨ záložka Vztažené artikly

¨ záložka Pracovní výkony

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.01.2008


Pojem - Referenční integrita

Referenční integrita je nástroj databázového stroje, který pomáhá udržovat vztahy v relačně propojených databázových tabulkách. Referenční integrita se definuje cizím klíčem, a to pro dvojici tabulek, nebo nad jednou tabulkou, která obsahuje na sobě závislá data (například stromové struktury). Tabulka, v niž je pravidlo uvedeno, se nazývá podřízená tabulka (používá se také anglický termín slave). Tabulka, jejíž jméno je v omezení uvedeno je nadřízená tabulka (master). Pravidlo referenční integrity vyžaduje, aby každý záznam použitý v podřízené tabulce existoval v nadřízené tabulce. To znamená, že každý záznam musí v cizím klíči obsahovat hodnoty odpovídající primárními klíči v nadřízené tabulce, nebo null.

Referenční integrita se projevuje při:

¨ při přidání záznamu do podřízené tabulky se kontroluje, zda stejná hodnota klíče existuje v nadřízené tabulce – porušení pravidla vyvolá chybu

¨ při mazání nebo úpravě záznamů v nadřízené tabulce se kontroluje, zda v podřízené tabulce není záznam se stejnou hodnotou klíče – porušení pravidla může vyvolat chybu nebo úpravu dat v podřízené tabulky v souladu s definovanými akcemi.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.10.2007


Pojem - Referenční měna

Referenční měna (RM) je při aplikaci informačního systému v České republice CZK. V této měně se vede účetnictví a ve všech činnostech, kde se objevuje zahraniční měna je uváděn kurz vůči této měně. Identifikace referenční měny se nastavuje v činnosti Parametry oceňování (Informační centrum – Oceňování).

Poznámka:

Uvedené údaje o referenční měně se v činnosti Parametry oceňování ukládají do tabulky BWMEMOR s celou řadou dalších proměnných. Pro snadnější získání těchto údajů programovými prostředky je v IS BM objekt OCPARAM, nesoucí tyto údaje (detailní info viz. parametry oceňování).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.10.2012


Pojem - Referenční proces

Je to druh procesu se standardní strukturou (první "referenční" operace a jeden nebo více uzlů následujících), který představuje nástroj, pomocí kterého je možné modifikovat strukturu (diagram) již existujících fyzických procesů připojením dalších uzlů. Množina fyzických procesů, do kterých je možné se napojit pomocí daného referenčního procesu, je definována tím, že obsahují zahájenou operaci, jejíž druh se shoduje s druhem "referenční" operace daného referenčního procesu. K této operaci fyzického procesu se pomocí referenčního procesu mohou připojit uzly referenčního procesu následující po "referenční" operaci v jeho diagramu.

Připojení nových uzlů k fyzickému procesu pomocí referenčního procesu se aktivuje ze spuštěné operace[1] z menu Obecné, které referenční procesy rozšiřují o další položky. K této operaci je pak možno uzly referenčního procesu připojit opakovaně několikrát.

Např. budeme mít operaci účetní zápis. K této operaci vytvoříme referenční proces opravný účetní zápis. Referenční proces se dá využít např. i u fakturace, kdy budeme mít možnost ke každé zadané faktuře vytvořit dobropis.

[1] Její typ musí být shodný s typem "referenční" operace některého referenčního procesu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Relační model

Relační databázový model sdružuje data do tzv. relací (tabulek), které obsahují n-tice (řádky). Tabulky (relace) tvoří základ relační databáze. Tabulka je struktura záznamů s pevně stanovenými položkami (sloupci - atributy). Každý sloupec má definován jednoznačný název, typ a rozsah, neboli doménu. Záznam se stává n-ticí (řádkem) tabulky. Pokud jsou v různých tabulkách sloupce stejného typu, pak tyto sloupce mohou vytvářet vazby mezi jednotlivými tabulkami. Tabulky se poté naplňují vlastním obsahem - konkrétními daty.

Kolekce více tabulek, jejich funkčních vztahů, indexů a dalších součástí tvoří relační databázi. Relační model přináší celou řadu výhod, zejména mnohdy přirozenou reprezentaci zpracovávaných dat, možnost snadného definování a zpracování vazeb apod.

Relační model klade velký důraz na zachování integrity dat. Zavádí pojmy referenční integrita, cizí klíč, primární klíč, normální tvar apod. S relačními databázemi je úzce spojen pojem SQL (Structured Query Language), neboli strukturovaný dotazovací jazyk. Jeho základní model je obecně použitelný pro většinu relačních databází.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.03.2009


Pojem - Replikace

Technika umožňující výměnu dat mezi několika datovými úložišti pomocí Sybase SQL Remot Control. Definice entit a jejich záznamů, které mají být předmětem výměny, se provádí v činnosti Informační centrum – Import/Export – Replikace.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Rezervace majetku

Činnost rezervace majetku je dostupná v menu činnosti spravovaný majetek. Uživatel může jednak prohlížet doposud vytvořené rezervace a jednak samozřejmě zakládat rezervace nové. U každé vytvářené rezervace se zadávají údaje o začátku a konci rezervace (tj. datum a čas od - do), rezervovaném majetku, je možno zadat i pro koho (tzn. jméno konkrétního uživatele), kategorii, popis a komentář. To jsou základní údaje, které uživatel vstupuje při vytváření nové rezervace.

Při vytváření rezervací může nastat situace, kdy dojde k časovému překryvu jednotlivých záznamů. Už při vytváření takového záznamu systém hlásí, že došlo k překryvu záznamů a u dané události se objeví výstražný žlutý trojúhelník s vykřičníkem. Při zápisu této události systém nahlásí "kolizi záznamů" a je zcela v kompetenci uživatele, zda kolizi odstraní či nikoliv.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.10.2013


Pojem - Rezervované zdroje systému

Uživatel má k dispozici tabulku, která obsahuje informace o rezervovaném zdroji a uživateli, který si zdroj rezervoval, jeho důvodu a času rezervace. Tuto činnost má uživatel k dispozici pod skupinovou položkou hlavního menu SYSTÉM. Jednotlivé zobrazené rezervace, které se zobrazují uživateli se do této činnosti zapisují nepřímo pomocí jiných činností:

¨ výkazy

¨ přepočet hodnot

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Režim oprav

Činnost režim oprav je pro uživatele dostupná v horní liště každé činnosti v menu Jazyk. Po aktivaci činnosti „režim oprav“ (tzn. jejím zatržení) je možno si přeložit nebo změnit název jakéhokoliv atributu dostupného na aktivním okně. Stiskem pravého tlačítka myši přímo na atributu se uživateli zpřístupní činnost „překlad textů“, kde si může libovolně změnit „návěští popisu“. Pokud bude chtít uživatel přeložit jednotlivé atributy do cizí řeči, je nutno si ještě před aktivací činnosti „režim oprav“ zvolit pod volbou Jazyk příslušný jazyk. Pokud si tedy uživatel bude chtít uzpůsobit popisy atributů v okně, je nutno před volbou „režim oprav“ zvolit jazyk CZE, v případě potřeby překladu popisu atributů do cizího jazyka je nutno zvolit příslušný cizí jazyk. Přeložená data se zobrazují pouze ta, jejichž název existuje v cizím jazyce. Přeložit lze:

¨ okna (názvy položek hlavního menu, nadpisy (labely) v oknech, obsahy překryvných seznamů a většina textů určených pro ovládání IS) – toto se provádí v činnosti Překlad textů v menu Systém.

¨ předlohy výstupů (tj. textová pole)

¨ data, u kterých je programovým kódem umožněno (určené číselníky, názvy účtů)

¨ nabídky

¨ hlavní menu

Při překladu textu prvku typu překryvný seznam pomocí režimu oprav je možné zatrhnout atribut „uložit přeložený text do BWSLOVPP“. Toto uložení následně v SQL dotazech umožňuje přístup k hodnotám, které jsou definované pro atributy zobrazované jako překryvný seznam.

Zaškrtnutí způsobí uložení textu do tabulky BWSLOVPP. Tato tabulka má atributy:

- bw57idt - jednoznačná identifikace textu - je zobrazena ve formuláři překladu textu prvku typu překryvný seznam

- sp38id - identifikace jazyka

- bwa7id - numerická - odpovídá hodnotě atributu typu překryvný seznam

- bwa7text - textová - text přidělený hodnotě atributu překladem

Např. pro hodnotu atributu 'úkon vymáhání'. Přeložený text:

Upom.,1,Penále,2,Soud,3,Exek.,4,Tr. ozn.,5,Ost.,6,NEVYM.,7,Výzva,8,Telef.,9,Odlož.,10,Mail,30,Telef.2,31

vznikne v tabulce BWSLOVPP 12 záznamů:

bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=1, bwa7text=Upom.

bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=2, bwa7text=Penále

bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=3, bwa7text=Soud

bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=4, bwa7text=Exek.

bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=5, bwa7text=Tr. ozn.

bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=6, bwa7text=Ost.

bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=7, bwa7text=NEVYM.

bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=8, bwa7text=Výzva.

bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=9, bwa7text=Telef.

bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=10, bwa7text=Odlož.

bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=30, bwa7text=Mail

bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=31, bwa7text=Telef.2

V SQL dotazu je potom možné tabulku použít:

(select bwa7text from %%%.bwslovpp where bwslovpp.bw57idt='_RZU14KD54'
and bwslovpp.sp38id='CZE' and
bwslovpp.bwa7id=PLUDA.pl02ukonvy) ukon_text

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 02.03.2009


Pojem - Roční nezdanitelné položky

Informace o nadefinovaných ročních nezdanitelných položkách se evidují v komponentě Mzdy, na záložce Roční pol. v činnosti Karta pracovníka.

Na této záložce se evidují údaje, které jsou potřebné k provedení ročního zúčtování daně. Mzdová účetní je může vyplňovat postupně během roku. Údaje se do výpočtu zahrnou až v okamžiku, kdy je příznak „provést roční zúčtování“ (na záložce Osobní údaje) nastaven na Ano.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.10.2007


Pojem - Roční zúčtování daně

Tato činnost (Mzdy a personalistika – Mzdy) se spouští v systému jednou ročně, obvykle při zpracování únorových mezd.

Činnost provede roční zúčtování daně z příjmu fyzických osob, tj. vypočte základ ročního zúčtování, vyrovnání přeplatku na dani a dorovná daňový bonus.

Údaje a nastavení k tomu potřebná jsou :

¨ Na kartě pracovníka – atribut podepsal prohlášení nastaven na Ano, atribut Provést roční zúčtování nastaven na Ano, doplnit roční nezdanitelné položky

¨ Na výplatním lístku – u pracovníků, kteří část roku pracovali u jiné firmy zadat údaje poskytnuté cizím zaměstnavatelem - mzdové položky Loňský příjem (příjem od jiného zaměstnavatele za uplynulý rok), Loňský odvod (odvod zdravotního a sociálního pojištění, které za pracovníka odvedl zaměstnavatel za uplynulý rok), Loňská daň, Loňský nárok, Loňská sleva a Loňský bonus Všechno jsou to položky typu Odvod. Musí být nadefinovány v činnosti Definice – Položky mezd – Odvody.

Ve výběru činnosti Roční zúčtování daně se nastavuje:

¨ číslo pracovníka (pokud není vyplněno, automaticky se berou všichni)

¨ zaškrtávátko „přepočítat“ reguluje, zda se má spustit výpočet nebo zda chcete údaje pouze prohlížet

¨ po spuštění výpočtu se ke každému pracovníkovi (dle nastavení ve výběru) předplní dva řádky s datem. Jsou to řádky L40000 – Základ ročního zúčtování a L41000 – Vyrovnání přeplatku na dani. Tyto řádky se stanou součástí výplatního lístku (zda se budou tisknout se reguluje zaškrtnutím „Tisknout“ v činnosti Definice – Položky mezd – Odvody). Od zúčtování r.2005 se nově může objevit položka L43000 – Vyrovnání ročního daňového bonusu (položky L40000, L41000, L43000 musí být nadefinovány v činnosti Definice – Položky mezd – Odvody).

¨ Tento přepočet může uživatel spouštět několikrát

Je-li vyrovnání přeplatku na dani větší než 50,- Kč, pak se vyplatí, tzn. přičte se k čisté mzdě. Je-li vyrovnání přeplatku na dani menší než 0,- Kč (nedoplatek), pak se v ročním zúčtování uvažuje jako 0,- Kč a situace se srovná další měsíc jako doplatek daně.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 25.02.2011


Pojem - Rovnoměrné odepisování

Rovnoměrné odpisy jsou jednou z metod daňových odpisů a jejich výpočet upravuje zákon o dani z příjmu. K výpočtu se využívá vzorec, do nějž se doplní potřebné údaje o vstupní ceně DM a sazba z tabulky, podle toho, do které odpisové skupiny je zařazen konkrétní odpisovaný dlouhodobý majetek a kterým rokem je odpisování prováděno. Jiné sazby jsou v prvním roce odepisování a jiné v ostatních letech odepisování. V případě technického zhodnocení se využije sazba z posledního sloupce tabulky pro zvýšenou vstupní cenu.

Vzorec pro výpočet:

vstupní cena*sazba z tabulky

roční odpis = _________________________

100

Roční odpisová sazba

odpis.skupina v prvním v dalších pro

roce letech zvýšenou

odepisování vstupní cenu

1 20 40 33,3

1a 14,2 28,6 25

2 11 22,25 20

3 5,5 10,5 10

4 2,15 5,15 5,0

5 1,4 3,4 3,4

6 1,02 2,02 2

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 12.01.2009


Pojem - Rozlišení

Rozlišení je atribut, který se používá při definování pravidel transformace i pro definování vazeb mezi jednotlivými uzly diagramu procesu. V obou případech se jedná o vliv rozlišení na způsob výpočtu cílové hodnoty dle míry plnění. Cílová hodnota se vyhodnocuje agregovaně za všechna pravidla transformace vedoucí z jednoho zdrojového uzlu i do několika (pokud operace cílového uzlu patří do jedné komponenty) cílových uzlů, pokud mají shodný cílový atribut a shodné rozlišení, jehož klíč se skládá z rozlišení vazby a rozlišení pravidla.

V pravidlech transformace slouží k rozlišení pravidel se stejnou cílovou hodnotou, ale obvykle v různém významu (tj., aby nedocházelo k tomu, že se tyto cílové částky budou sčítat při vykrytí míry plnění, ale naopak, aby se evidovaly zvlášť - např. při účtování na obě strany: strana MD - rozlišení 0, strana D - rozlišení 1).

V diagramu procesu má vazba mezi uzly např. následující význam: pokud se z jedné operace komponenty obchod vytváří dvě transformace do operací komponenty platby, tak by mohlo dojít k tomu, že se tato transformace provede pouze jednou u první operace a ostatní se provádět nebudou. Pokud se ale tyto operace rozliší jednotlivými symboly A, B, C, tak přestože se jedná o transformaci do více operací stejné komponenty, systém ji díky uvedenému rozlišení provede třikrát. Toto rozlišení má význam i z hlediska míry plnění, kdy se při transformaci do více operací míra plnění implicitně sčítá, při nastaveném rozlišení k součtu míry plnění nedochází.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Rozpočítávat množství

Tento atribut označuje materiál, jehož množství na realizovaných vstupech výrobních úkolů se rozpočítává podle skutečně spotřebovaného množství artiklu za období (rozpočítávání se provádí nad činností „přehled nerozpočteného“ v komponentě Výroba, kde se rozpočítávají vstupy dle období, linky, artiklu a výrobního čísla)

Můžeme si uvést teoretický příklad: výrobní podnik má 3 zakázky na výrobu montovaných stolků. Tyto stolky je nutno nalakovat. Na každý stolek je určena normovaná spotřeba laku. Nicméně po realizaci těchto tří zakázek se spočítá skutečná spotřeba laku a ta se následně rozpočítá (váženým průměrem) ke každé ze tří zakázek (normovaná spotřeba první zakázky je 2kg, druhé zakázky 5kg a třetí zakázky 10kg, což je celkem 17kg). Po realizaci těchto zakázek bylo ale zjištěno, že skutečně se spotřebovalo 34kg laku. Po provedení rozpočtu je u první zakázky uvedeno 4kg laku, u druhé zakázky 10kg a u třetí zakázky 20kg laku.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.01.2008


Pojem - Rozvaha

Rozvaha je výkaz o majetku podniku (aktiva) a zdrojích jeho financování (pasiva) k určitému datu. Definice rozvahy je standardní součástí dodávky IS BM.

Aktiva jsou formy majetku, formy bohatství a soubor hospodářských prostředků vyjádřených v penězích (uvádějí se na levé straně rozvahy tvaru T). Pasiva jsou zdroje financování majetku (aktiv), kapitálové zdroje (uvádějí se na pravé straně rozvahy tvaru T).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 24.01.2008


Pojem - Rušení dat

Obecně je možno provádět rušení dat ručním způsobem nebo pomocí programu. Ruční rušení dat se provádí:

¨ pomocí klávesy „zrušení“ v panelu nástrojů nebo volbou příslušné činnosti z menu Volby (možná i klávesová zkratka F8). Platí ovšem pravidlo, že smazat jdou pouze záznamy, které neodkazují na žádný další záznam, např. pokud má adresát vytvořenu v událostech plateb platbu, není možno takového adresáta z adresáře zrušit. K zjištění počtu záznamů slouží činnost „počet odkazů na záznam“ na záložce Obecné. I při běžném rušení by si měl uživatel vždy dobře rozmyslet, zda chce daný záznam zrušit a co všechno se s daným záznamem ještě zruší, např. při zrušení adresáta se zruší zároveň i všechny jeho adresy apod.

¨ pomocí storna - zruší neukončené operace stornovaného procesu.

Rušení pomocí programu je možno provést pomocí doplňujících vlastností formuláře, uživatelských triggerů nebo pomocí speciálního externího programu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Rušení událostí komponent

Při rušení události libovolné komponenty, ze které byla transformována data (může nastat po odblokování operace) se systém zachová podle nastavení parametru "Delete_Transformed_Event" v sekci "Preferenced" nastavení BM :

0 - není povoleno

1 - je povoleno

2 - rozhodne uživatel

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 28.01.2004


Pojem - Rychlý výstup

Doplňující vlastnost formuláře '* Rychlý výstup' umožňuje z aktuálního formuláře udělat jednorázový výstup do Excelu nebo HTML bez použití předlohy výstupu. Uživateli se po jeho aktivaci (menu Volby nebo ze základní nabídky) zobrazí okno „rychlý výstup“, které obsahuje dvě záložky. Záložku Atributy a záložku Popis pro „Definice IP“.

Na záložce Atributy si uživatel pomocí šipek umístěných ve středu okna vybere atributy, které chce mít na vytvářené sestavě k dispozici, pomocí posuvníků si může upravit jejich pořadí a v dolní části okna si poté zvolí, zda chce tuto jednorázovou sestavu vytisknout jako sesit aplikace Excel či ve formátu HTML. Tlačítko „DBF“ poskytuje uživatelům možnost exportovat jednorázovou sestavu do souboru DBF.

V případě, že by uživatel potřeboval do rychlého výstupu přidat i atribut, který není součástí aktuálního formuláře (tj. činnosti, ze které uživatel rychlý výstup aktivoval), je nutno tento atribut nejprve přidat jako další sloupec do formuláře, potom se teprve nabídne do výběru atributů do rychlého výstupu.

Další funkcí této doplňující vlastnosti je možnost založení nového uzlu v definicích informačních panelů podle vybraných atributů, které jsou použity ve formuláři (založí řádky, sloupce, elementy). Toto je možno provést po aktivaci záložky Popis pro „Definice IP“ a následném stisku tlačítka „Definice IP“ v dolní části okna. Tímto tlačítkem se aktivuje export do definice informačního panelu.

Funkce založení nového uzlu v definicích informačních panelů je povolena pouze uživatelům, kteří mají povolenu činnost 'Definice uzlů inf. panelů' a v ní povoleno vkládání.

Nově zakládaný IP-uzel je zakládán s prezentací 'BASE', která musí být definována.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 03.05.2013


Pojem - Řádek definice listu výkazů

Řádek je elementem definice listu s prioritou nejvyšší po buňce, tj. může definovat její implicitní vlastnosti. Daný řádek definice listu je dostupný pomocí navigačního listu, pokud definice listu není založena pomocí vzoru listu je možné zde definovat jeho vlastnosti, případně zrušit či založit nový.

Jednomu řádku definice listu odpovídá jeden řádek výkazu, pokud je v atributu parametry řádku aplikován příkaz dyn, může to být více řádků výkazu.

Řádek definice listu výkazů prezentovaný identifikátorem řádku umožňuje definovat pořadí a název řádku, atribut parametry, implicitní formát a obsah jeho buněk výrazem, vzorcem nebo jako prázdný, případně zda má být řádek ve výkazu skrytý.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Řídící tok

Řídícím tokem se rozumí rozhodování při běhu (provádění) fyzického procesu ve smyslu, co bude (může) následovat na základě aktuálního stavu procesu (tj. stavu všech definičních i aplikačních dat souvisejících s procesem, ale i jiných dat přímo nesouvisejících) a případného dialogu s uživatelem. Mezi typická rozhodování patří volba, který uzel procesu bude:

¨ automaticky spuštěn,

¨ uveden do stavu připravena,

¨ ukončen,

¨ z diagramu odstraněn, protože se stal nadbytečným.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Sada vzdálených funkcí

Činnost má uživatel dostupnou v hlavním menu v komponentě informační centrum v činnosti algoritmy a číselníky.

Tato činnost slouží ke sledování aktuálnosti verzí a legislativních nastavení u uživatelů, tzn. že u jednotlivých uživatelů lze porovnat jejich verzi vůči nejaktuálnější verzi Bílého Motýla a zjistit, jestli má uživatel aktuální všechny sestavy, doplňující vlastnosti formuláře, knihovny apod., čímž je plně zajištěno aktuální nastavení BM i u jednotlivých uživatelů.

V činnosti „Sady vzdálených funkcí“ se definují vlastní definice kontroly jednotlivých činností, po jejichž spuštění právě dochází k porovnání verzí aktuálního nastavení BM a nastavení BM u uživatele.

U každé sady se na záložce „sady vzdálených funkcí“ definuje identifikace sady, její název a poznámka (tzn. bližší vysvětlení, k jaké kontrole tato sada slouží, co je jejím cílem apod.).

Uživatel si zde může pouze prohlédnout přehled nadefinovaných sad a vybranou následně aktivovat, jejich vlastní nastavení zde měnit nelze (to se provádí v činnostech Sady vzdálených funkcí – nastavení a Vzdálené funkce – nastavení).

Vedle atributu Poznámka má uživatel k dispozici dvě samostatná tlačítka:

¨ modrá tužka – (ne)zobrazovat kurzor v mřížce – v běžném nastavení platí, že pokud umístíme kurzor na vybraný řádek, tak tento řádek je zvýrazněn jinou barvou (právě aby bylo zřejmé, že je v tuto řádek aktivní). Pokud by toto zvýraznění řádku uživateli ovšem nevyhovovalo, lze stisknout právě toto tlačítko. Pak aktivní řádek není zvýrazněn žádnou barvou, pouze je něj příznak malé černé šipky na začátku řádku.

¨ zelená šipka – toto tlačítko slouží ke spuštění vybrané sady vzdálených funkcí (možno využít i klávesu F9). Po jeho aktivaci uživatel pouze určí datum, ke kterému tuto sadu aktivuje a stiskne tlačítko OK. Následně se uživateli zobrazí informační panel s protokolem, který je opticky rozdělen do dvou částí.

Menší levá část obsahuje sloupec s názvy jednotlivých sekcí, které daná sada obsahuje. Větší pravá část vždy zobrazuje info k té sekci, na které je umístěn kurzor. Jako první se po aktivaci dané sady kurzor umístí na hlavičku s názvem sady, která má v pravé části info k jednotlivým sekcím a ve sloupečku info je napsaná informace, které nesrovnalosti tam systém při kontrole objevil (tzn. může tam být napsáno „chyba“ – že je nutno některé údaje v sekci aktualizovat nebo hláška „nespuštěna“ – že tuto sekci uživatel ještě nikdy nenahrál apod.). Na dolní liště je info, kolik sekcí bylo OK, v jaké sekci bylo varování, chyby a kolik jich bylo ještě nespuštěno (viz. následující obrázek).

V případě, že uživatel umístí kurzor na řádek označený křížkem (na našem obr. např. „kontrola všech předloh výstupu“), zobrazí se mu v pravé části obrazovky podrobná informace.

Po stisku modře označených záznamů má uživatel dostupné ještě podrobnější informace, např. po stisku čísla verze se přesně dozví bližší údaje o tom, kdy a kým byla daná verze vytvořena, kdo je autor, jaký je typ předlohy apod. Po stisku modře označené informace „chyba“ se uživateli zobrazí nabídka možnosti nahrát si danou předlohu výstupu pomocí balíčku. Naprosto stejný postup je i u jiných druhů informací, např. těch, co se týkají legislativních konstant nebo daňových přiznání. Vždy pod modře označeným záznamem je buď podrobnější informace nebo možnost chybu napravit (nahrát balíčkem nebo informace o tom, kde si má jaké nastavení uživatel opravit).

Druhá záložka v této činnosti se jmenuje „automatické spouštění“ a uživatel zde má možnost si nadefinovat možnost automatického spouštění vybrané sady. Definují se následující atributy:

¨ skupina – identifikace skupiny uživatelů (v podstatě zde se vybírá, kdo bude mít právo danou sadu automaticky spouštět)

¨ spustit – výběr z překryvného seznamu. Možnosti jsou při startu BM, nespouštět, při startu programu

¨ perioda – pokaždé, jednou denně – uživatel, jednou denně – celá firma

¨ balíčky – opět výběr z překryvného seznamu. Možnosti jsou importovat, importovat na pozadí, importovat na pozadí s dotazem, neimportovat – spustit formulář

¨ po chybě – možnost nastavit spustit formulář vzdálených funkcí nebo nespustit formulář vzdálených funkcí

Pomocí kombinace těchto atributů lze nastavit např. že po prvním přihlášení daného uživatele do systému v daný den se má automaticky spustit daná sada vzdálených funkcí a pokud by systém zjistil nesrovnalosti ve verzích, může automaticky na pozadí naimportovat chybějící balíčky.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 26.09.2012


Pojem - Sady parametrů

Evidují se zde volné údaje definované podle vlastních potřeb každého uživatele. Nachází se pod menu Obecné – Hodnoty parametrů objektu – Sady parametrů. Nadefinovat jednotlivé sady je uživatelsky náročnější, takže by to měl provádět buď zkušený uživatel a nebo implementátor. Sady parametrů je možné využít ve všech komponentách IS BM, např. v obchodu v činnosti „vztahy obchodovatelných artiklů k adresátům“ nebo i pro účely personalistiky apod. Můžeme tuto činnost definovat i tak, že v podstatě kopíruje možnosti, které uživateli poskytují Volné karty, jen v obecnější míře pojetí.

U každé sady parametrů se na záložce „Sady parametrů“ definuje:

¨ identifikace sady

¨ identifikace komponenty – dodává ji systém automaticky. Deklaruje nad jakým objektem je sada vytvořena.

¨ název sady

¨ příznak, zda je aktuální či nikoliv

¨ libovolnou poznámku

Poznámka:

Při použití sady parametrů v komponentě personalistika je v případě potřeby možno u každého pracovníka evidovat další osobní údaje (o dětech, o studiu, školeních apod.). Tato činnost je dostupná v menu Volby. K dispozici jsou čtyři volné texty, volné datum a volné číslo. U každého osobního údaje je navíc možno nastavit jeho platnost od – do.

Na záložce „parametry v sadě“ se definuje:

¨ identifikátor parametru (definovaný v číselníku obecných parametrů)

¨ pořadí parametru

výskyt parametru – ten může nabývat hodnot:

¨ 1:1 - pro každý objekt musí existovat právě jeden tento parametr. Je povinný.

¨ 0:1 - pro každý objekt může existovat žádný nebo právě jeden tento parametr

¨ 1:M - pro každý objekt musí existovat alespoň jeden nebo více těchto parametrů

¨ 0:M - pro každý objekt může existovat žádný nebo více těchto parametrů

Při zařazení nového parametru do sady s výskytem 1:1 nebo 1:M je automaticky ke všem objektům daného druhu připojen záznam o hodnotě parametru s inicializací jeho elementárních hodnot.

Automatické připojení se neprovádí:

¨ pro objekty, které jsou událostmi komponent

¨ pro objekty, ve kterých je sada přímo uvedena (např. pracovní funkce ve personalistice) - automaticky se připojují pouze parametry odpovídající sady

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 09.02.2007


Pojem - Sady systémových konstant

Činnost „sady systémových konstant“ slouží pro definování a uchování hodnot konstant potřebných pro funkce programu IS BM. Je dostupná v hlavním menu programu v činnosti Informační centrum – Algoritmy a parametry. Tato činnost obsahuje záložku sady a záložku konstanty.

Sady konstant je možné exportovat do balíčku (menu Obecné – export dat do balíčku). Přitom je do balíčku exportována jak definice sady konstant, tak i její hodnoty. Při importu balíčku dojde k přepisu dříve zadaných definic konstant resp. jejich hodnot podle u nich uvedeného data a času aktualizace. V IS BM jsou nyní k dispozici nadefinované legislativní konstanty.

Na záložce „Sady“ se definuje:

¨ identifikace sady konstant - 6 znaků

¨ název sady konstant

¨ druh sady konstant - určuje přístupová práva pro definování sady

¨ verze - numerická 8,3 - pro určení aktuálnosti sady - uvádí se obvykle rok a měsíc např. 2006.030 v březnu roku 2006

¨ aktualizace - datum a čas aktualizace záznamu

¨ poznámka

Na záložce „Konstanty“ se definuje struktura sady konstant a zadávají se tyto atributy:

¨ identifikace konstanty - 10 znaků

¨ název konstanty

¨ druh konstanty - určuje přístupová práva uživatele pro nastavení hodnoty konstanty

¨ typ konstanty - překryvný seznam - Text / Číslo / Datum

¨ pořadí zobrazení konstanty při zadávání hodnot sady konstant

¨ délka - pro typ Text / Číslo

¨ desetiny - pro typ Číslo

¨ poznámka

¨ platnost od – do – uvedení platnosti konstanty. Tato možnost je vhodná i pro uživatele mezd a legislativní konstanty, kde se dá tímto ukončit platnost legislativní konstantě, která pro současný výpočet mezd ztratila smysl.

¨ specifická – volba Ano/Ne – označuje konstantu jež je specifická pro různé subjekty. Konstanty s nastavením specifická na hodnotu ANO jsou v mřížce zobrazené na světle modrém podkladu. Hodnoty konstant, které mají nastaveno specifická ANO, nebudou při exportu do balíčku vyvolaném v tomto formuláři do něj zahrnuty.

¨ aktualizace - datum a čas aktualizace záznamu

Po stisku klávesy F9 nebo aktivací činnosti v menu Volby lze vyvolat činnost Hodnoty sady konstant. Tato činnost je pro uživatele dostupná i z hlavního menu (Informační centrum – Algoritmy a parametry – Hodnoty konstant), kde se zobrazují všechny uživateli dostupné sady konstant. Pomocí nastavení výběru na výběrové záložce je možné vybírat hodnoty konstant k různému datu platnosti. Definuje se:

¨ konstanta - překryvný seznam naplněný seznamem konstant definovaných pro danou sadu

¨ datum platnosti od

¨ hodnota konstanty podle typu vybrané konstanty

¨ popis

¨ poznámka

¨ aktualizace - datum a čas aktualizace záznamu

Pro použití hodnot konstant v SQL dotazech je možné použít uložené procedury:

Procedura 'PASYSVAL hodnota - text' - zjišťuje hodnotu textové konstanty

Parametry:

¨ identifikace sady systémových konstant

¨ identifikace konstanty

¨ datum, ke kterému se vybere platná konstanta - nepovinný parametr - není-li uveden vybírá se podle aktuálního data

Procedura vrací textovou hodnotu, není-li konstanta k datu nalezena vrací NULL.

Procedura 'PASYSVAL hodnota - cislo' - zjišťuje hodnotu číselné konstanty

Parametry:

¨ identifikace sady systémových konstant

¨ identifikace konstanty

¨ datum, ke kterému se vybere platná konstanta - nepovinný parametr - není-li uveden vybírá se podle aktuálního data

Procedura vrací numerickou hodnotu, není-li konstanta k datu nalezena vrací NULL.

Procedura 'PASYSVAL hodnota - datum' - zjišťuje hodnotu datumové konstanty

Parametry:

¨ identifikace sady systémových konstant

¨ identifikace konstanty

¨ datum, ke kterému se vybere platná konstanta - nepovinný parametr - není-li uveden vybírá se podle aktuálního data

Procedura vrací datumovou hodnotu, není-li konstanta k datu nalezena vrací NULL.

Příklad:

... WHERE .... AND TABULKA.cislo=%%%."PASYSVAL hodnota - cislo"('SADA','konstanta7',current date-30) AND ....

Pro použití hodnot konstant ve skriptech v jazyce Foxpro je možné použít objekt inicializovaný programem PA0119OB a jeho metody:

Metoda LOAD_DATA

Parametry:

¨ identifikace sady systémových konstant

¨ datum, ke kterému se vyberou platné konstanty - nepovinný parametr - není-li uveden vybírá se podle aktuálního data

Metoda vytvoří v objektu atributy se identifikacemi a hodnotami konstant určené sady. Vrací logickou hodnotu .T. (TRUE) v případě, že byly hodnoty všech definovaných konstant naplněny do atributů objektu, jinak zobrazí chybové hlášení a vrátí hodnotu .F. (FALSE). Vlastnost objektu PARAM_VERZE je metodou nastavena na číslo verze sady (používá se pro zjištění aktuálnosti sady).

Příklad:

LOCAL _o

_o=PA0119OB()

IF NOT _o.load_data('MZDLEG',DATE())

RETURN

ENDIF

IF _o.param_verze<2006.010

DO bw_hlase WITH '!','NAČTENÍ SADY','Sada konstant MZDLEG není aktuální.'+CHR(13)+;

'Importuje aktuální balíček s touto sadou.'

RETURN

ENDIF

? 'Odvod SP zaměstnanec=',_o.mz27spzam

? 'Odvod SP organizace =',_o.mz27sporg

Metoda GET_VALUE

Parametry:

¨ identifikace sady systémových konstant

¨ identifikace konstanty

¨ datum, ke kterému se vybere platná konstanta - nepovinný parametr - není-li uveden vybírá se podle aktuálního data

Vrací hodnotu určené konstanty z určené sady systémových konstant k datu. Není-li konstanta nalezena vrátí hodnotu .F. (FALSE).

Příklad:

? hodnota_mz27spzam()

PROCEDURE hodnota_mz27spzam

LOCAL _o

_o=PA0119OB()

RETURN _o.get_value('MZDLEG','mz27spzam',DATE())

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.11.2012


Pojem - Sady vzdálených funkcí - nastavení

Tato činnost úzce souvisí s činností Vzdálené funkce – nastavení. Je dostupná v hlavním menu – Informační centrum – Algoritmy a parametry – Nastavení vzdálených funkcí.

V činnosti Vzdálené funkce – nastavení se jednotlivé funkce nadefinují a v této činnosti se následně zvolené funkce sestaví do příslušných sad. Tato činnost a činnost Vzdál. funkce - nastavení rozhodně není běžnou uživatelskou činností. Může být dodána nadefinována přímo s dodávkou IS BM nebo by její definici měl provádět pouze velmi zkušený implementátor.

Takto nadefinované sady má potom teprve možnost využít uživatel, a to v činnosti Sady vzdálených funkcí.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 26.09.2012


Pojem - SAI (Systém automatické identifikace)

Systémy automatické identifikace (SAI) umožňují propojení označených objektů reálného světa s jejich obrazy v informačním systému v reálném čase.

SAI týkající se firmy BM Servis je založeno na těchto principech:

¨ jednotná data IS BM

¨ webové služby Sybase SQL Anywhere

¨ BMClientService – software (server), který zajišťuje komunikaci mezi aplikací UClient provozovanou na terminálech (tedy uživatelem) a webovými službami (tedy daty IS BM)

¨ terminály (nainstalován klient) komunikující se serverem (BMClientService) pomocí sítě WI-FI

¨ označování objektů reálného světa čárovým kódem

SAI firmy BM se obvykle využívá v oblasti:

¨ skladu

¨ výroby

Systémy automatické identifikace dat využívají různé technologie záznamu, přenosu a identifikace informací. Mezi jednu z nejpoužívanějších technologií patří čárové kódy. Využití technologie čárových kódů výrazným způsobem usnadňuje evidenci materiálu a zboží na skladě. Ke čtení čárových kódů lze použít různých snímacích zařízení: scannery, terminály apod.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.10.2015


Pojem - SAI - Automatické ukončování dokladu

Jednou z možností chování terminálu, kterou si uživatel může nastavit je volba „automatické ukončování dokladu“ na volné kartě Terminál. Pokud je tato možnost aktivována (tj. zatržena), tak terminál po načtení čárového kódu balení nebo artiklu vytvoří samostatný proces. Pokud tato volba aktivní není, tak nedochází k ukončení dokladu po každém načtení čárového kódu, ale uživatel si může doklad samostatně ukončit ve chvíli, kdy má načteny všechny čárové kódy z předchůdce, tj. z předpisu pohybu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.08.2015


Pojem - SAI - BMClientService

Jedná se o software (server), který zajišťuje komunikaci mezi aplikací UClient provozovanou na terminálech (tedy uživatelem) a webovými službami (tedy daty IS BM). Tento software je na PC (nebo přímo v databázi) nainstalován přímo jako služba, ve Správci služeb je nutné nastavit její automatické spouštění při startu PC (nebo databáze).

S tímto serverem komunikují aplikace UClient na jednotlivých terminálech a rovněž i emulátor.

Obvykle je nainstalován ve složce „C:\Program Files (x86)\Eprin\BMClientService“.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.10.2015


Pojem - SAI - Čtečka čárového kódu

Čtečka čárového kódu je zařízení, pomocí kterého lze přečíst/snímat čárový kód (např. z etikety). Obvykle je čtečka součástí nějakého zařízení, ke kterému je připojena. V případě SAI je čtečka součástí terminálu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.10.2015


Pojem - SAI - Doklad

Dokladem se rozumí operace, která se do IS BM zaznamenává načtením čárového kódu (tzn. načtením kódu z etikety).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.10.2015


Pojem - SAI - Druhy etiket

Etikety a pásky lze rozlišovat na:

¨ archové etikety a štítky - jsou tištěny na formát A4. Bílé papírové etikety s ochranným okrajem jsou určené pro inkoustové a laserové tiskárny a kopírky.

¨ kotoučové etikety - etikety navinuté v kotoučích, které jsou vhodné pro termotransferový tisk.

¨ samolepící etikety - s amolepící etikety a štítky jsou v provedení polyexact nebo papír a jsou vhodné pro termotransferové tiskárny.

¨ pásky – se vyznačují obzvláště vysokou mechanickou odolností tisku a velmi dobrým přenosem barviva na bázi vosk – pryskyřice. Zajišťují výbornou kvalitu tisku na hladké i lehce strukturované papíry, na PE a PET materiály.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.10.2015


Pojem - SAI - Emulátor

Emulátor terminálu je speciální aplikace, která v grafickém uživatelském prostředí (Windows) vytváří okno, uvnitř kterého je emulován terminál. Emulovat doslova znamená schopnost napodobovat jeden systém jiným. Emulátor terminálu (anglicky „terminal emulator“) je program, který v SAI BM emuluje terminál (fakticky jen provoz aplikace „UClient“) uvnitř pokročilejšího zařízení nebo prostředí.

V praxi to pak znamená, že uživatel může mít tento emulátor nainstalován jako aplikaci přímo ve svém PC a ta mu umožňuje ruční ovládání terminálu a zpracování čárových kódů.

Jedná se o program „UClientAppPC.exe“ obvykle instalovaný do složky "C:\Program Files (x86)\Eprin\UClientAppPC\ ".

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.10.2015


Pojem - SAI - Etiketa

Etiketa je v SAI nositelem vytištěného čárového kódu. Nejpoužívanějším materiálem pro výrobu etiket je papír nebo různé druhy fólií (samolepící nebo nesamolepící) v kombinaci s vhodným druhem lepidla.

Etiketa je obvykle pevně spojena (nalepena) s objektem reálného světa, který se čárovým kódem na etiketě stává automaticky identifikovatelný.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.10.2015


Pojem - SAI - Funkce CKCONV

Jedná se o funkci IS BM, která převádí hodnotu identifikátoru reprezentujícího objekt reálného světa na hodnotu v daném kódování ČK, kterou je následně možné vytisknout fontem čárového kódu. Její použití pro určitá kódování je nezbytné.

Pro funkci se v IS BM uvádí 2 parametry:

¨ převáděný řetězec (identifikátor reprezentující objekt reálného světa)

¨ identifikace typu převodu (kódování ČK pro tisk daným fontem), možné varianty:

- ’ 128’ - code 128, font CODE128

- ’ 128JK’ - code 128, font CODE128JK

- ’ 128JKF’ - code 128, font CODE128JKF

- ‘INT‘ - interleaved 2 of 5, font IntHrP... a IntP...

- ‘IDA‘ - interleaved 2 of 5, font IDAutomation

- neuvedeno - interleaved 2 of 5, font neznámý

V SAI BM se často používá typ převodu „128JK“ s následným použitím fontu „Code 128 JK“. Další typy převodů se využívají například v expedici balíků přes přepravní společnosti (Česká pošta, Geis, PPL,…).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.10.2015


Pojem - SAI - Identifikátor reprezentující objekt reálného světa

V SAI je sledovanému objektu z reálného světa přidělen jednoznačný identifikátor. Jeho hodnota, tedy číslo nebo textový řetězec, lze vytisknout formou čárového kódu ve zvoleném kódování.

Pokud je tento identifikátor nerozlučně připojen k objektu reálného světa (obvykle je vytištěn formou čárového kódu na etiketu, která je přilepena na objekt reálného světa), dojde k jeho jednoznačnému propojení s informačním systémem BM a lze řídit či sledovat jeho pohyb.

V datech IS BM může být tento identifikátor primárně zakládán na různých místech. V řadě případů je pro toto vhodný atribut „Výrobní číslo“ v událostech obchodu (přijatý dodací list, odvádění výroby) nebo specifická volná karta nebo specifické hodnoty parametrů objektu. Pro skupinové objekty (např. skladovaný artikl, obchodovatelný artikl, …) lze použít odpovídající atribut „Čárový kód“ na kartě. V některých případech lze použít přirozené klíče z tabulek IS BM.

Založení (generování) tohoto identifikátoru se obvykle provádí specifickou funkcí, která je v některých aplikacích aktivována obsluhou, v jiných automaticky (třeba jako součást tisku). V některých případech je možné tento identifikátor převzít od dodavatele, pak je obvykle do IS BM importován.

V případě, že sledování objektu reálného světa se týká skladu, pak je tento identifikátor ukládám do atributu „VČ“.

Při nasazení SAI je rozhodnutí o těchto identifikátorech v BM (struktura, ukládání, generování, kódování, tisk, …) naprosto zásadní.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.10.2015


Pojem - SAI - Kódování čárového kódu

V datech IS BM jsou ukládány identifikátory reprezentující objekt reálného světa (objektem v IS BM mohou být pouze záznamy tabulek, které mají atribut jednoznačné časové identifikace). Jejich hodnoty se tisknou formou čárového kódu na etikety. Identifikátor se na čárový kód převádí obvykle v okamžiku tisku nastaveným fontem a případným předřazeným kódováním.

V aplikacích SAI BM jsme v praxi prověřili kódování “code 128“ a „3z9“, což nevylučuje možnost použití i jiných způsobů kódování, pokud to je vhodné. Při rozhodování o způsobu kódování je nutné brát v úvahu, zda použité zařízení pro čtení čárového kódu (terminál) umí dané kódování načíst, a také to, zda jsou volně k dispozici odpovídající fonty pro tisk.

Při kódování „3z9“ lze rovnou tisknout identifikátor reprezentující objekt reálného světa formou čárového kódu bez dalších úprav (např. pomocí volně dostupného fontu „IDAutomationHC39M“). Na druhou stranu díky absenci kontrolního čísla v tomto kódování čtečka nedokáže identifikovat chybné načtení (např. částečné poškození vytištěného kódu), tedy bude do zpracování (webové služby) zaslán chybný kód (ten bude obvykle odmítnut ze strany IS BM a na display se objeví chybové hlášení).

Při kódování “code 128“ je nutné před tiskem identifikátor reprezentující objekt reálného světa upravit, fakticky ho převést do kódování “code 128“ a doplnit řídící znaky, k čemuž se použije funkce IS BM „ckconv“. Teprve pak jej lze vytisknout, například fontem „Code 128 JK“.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.10.2015


Pojem - SAI - Objekt reálného světa

Jedná se o konkrétní fyzický výskyt objektu v reálném světě, který je (má být) v SAI sledován potřebným způsobem a který je v IS nějakým způsobem identifikován.

Může se jednat o výrobek s daným výrobním číslem, o artikl, o paletu s materiály pro danou zakázku, o doklad, …. , tedy konkrétnost i skupina.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.10.2015


Pojem - SAI - Předpis pohybu

Pro některé procesy (resp. některé typy dokladu), které jsou zaznamenávány pomocí terminálu platí, že musejí mít nejprve specifikaci co a v jakém množství se má načíst, případně jaké konkrétní balení. Systém potom následně kontroluje, zda doklad odpovídá tomuto předpisu.

Konkrétně se jedná o volbu „vykrývat předchůdce pouze jednou operací“, která je nastavena na volné kartě Terminál. Pokud má předchůdce dokladu např. tři události a je zatržena tato možnost, tak systém kontroluje, že daný doklad bude vytvořen také jako jedna operace s třemi událostmi.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.08.2015


Pojem - SAI - Převod mezi buňkami

Převod mezi buňkami je obvykle realizován jedinou operací, kde jedna událost je výdejem ze zdrojové buňku a druhá je příjmem na cílovou buňku, přičemž se v terminálu načítá jen cílová buňka, protože zdrojová buňka je automatizovaně dopočtena dle čárového kódu balení. Obsluha terminálu je vždy vyzvána k zadání množství cílové buňky.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.10.2015


Pojem - SAI - Snímání čárového kódu

Úkolem snímačů je rychle a bezchybně přečíst čárový kód a předat jeho obsah hostiteli. Tím může být běžný počítač, pokladna anebo jakékoliv zařízení podporující některé ze standardních průmyslových rozhraní. Připojení snímače k hostiteli může být realizováno kabelem anebo bezdrátově.

Z hlediska principu snímání dělíme snímače na laserové a digitální. Laserové snímače využívají technologie čtení jedním nebo více paprsky emitovanými laserovými diodami a jsou schopné číst čárové kódy i z větších vzdáleností. Princip digitálních snímačů je stejný jako u digitálních fotoaparátů: kód se vyfotí a obrázek je poté integrovaným dekodérem dekódován.

V systému SAI BM je obvykle snímačem čárového kódu terminál vybavený čtečkou, který využívá síť WI-FI.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.10.2015


Pojem - SAI - Terminál

Jako terminál se v informatice označuje jednoduché elektronické nebo elektro-mechanické zařízení sloužící pro komunikaci uživatele s počítačem. Může mít formu malého PC, přenosného zařízení s laserovou čtečkou nebo může být jenom nasimulován na klasickém PC, tj. emulátor.

V případě SAI v BM se používají terminály firmy Motorola vybavené laserovou čtečkou, a to tyto typy MC3090 nebo MC9190, případně i další se shodným operačním systémem. V SAI BM terminál zajišťuje komunikaci s uživatelem pomocí aplikace UClient, kde si uživatel volí potřebné funkce a snímá čárové kódy.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.10.2015


Pojem - SAI - Tisk čárového kódu

Aby bylo uskutečněno propojení mezi objektem reálného světa a identifikátorem, který ho reprezentuje v datech IS BM, musí se potisknout etiketa čárovým kódem interpretujícím hodnotu identifikátoru ve zvoleném kódování.

Někdy se též čárový kód tiskne z IS BM nejen na etikety, ale také v jiných výstupech (např. doklady, přehledové sestavy atd.), pokud je vhodné ho pak načítat z takového nosiče. Jedná o výstup z IS BM na základě odpovídající předlohy.

V technické rovině se při zavádění SAI BM volí typ tiskárny pro tisk etiket, související materiál (termotransferové pásky), typ a velikost etiket.

V logické rovině se volí způsob kódování (způsob převedení hodnoty identifikátoru objektu reálného světa na čárový kód). V závislosti na něm, na uložení identifikátorů a na velikosti etiket se definují předlohy výstupů určené pro potisk etiket. V závislosti na integraci SAI do procesů IS BM se definují metapředlohy a jejich případná aktivace při ukončení operace.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.10.2015


Pojem - SAI - Tiskárny pro potisk etiket

Jednotlivé etikety mohou být různého druhu (tj. velikosti, odolnosti apod.) a zároveň je lze i různě tisknout, resp. existuje několik způsobů potisku etiket. Tiskárny využívají technologie Thermo Transfer (TT) - tisk přes barvicí pásku (papírové etikety, PE etikety) nebo Direct Thermal (DT) - přímý tisk na teplocitlivý materiál (termo-etikety). Způsob se odvíjí od zvolené tiskárny:

¨ Jehličková tiskárna / Maticový tisk

Jehličkové tiskárny tisknou pomocí matice drobných jehliček přes barvící pásku na různé typy materiálů. Díky nižšímu rozlišení tisku, není tento tisk vhodný pro všechny kódy. Tisk je vhodný zejména pro velké kódy s nízkou hustotou kódu.

¨ Inkoustový tisk

Inkoustové tiskárny tisknou pomocí tiskové hlavy která rozprašuje inkoust pomocí sady trysek. Výhodou tohoto tisku je možnost tisknout na různé materiály, případně přímo na označované předměty.

¨ Laserový tisk

Tento tisk je vhodný pouze na omezené materiály kvůli rozměrům tiskárny a pak také materiál musí dobře snášet vyšší teploty při zapékání toneru a musí být dostatečně ohebný, aby prošel mechanikou tiskárny. Samotný tisk je pak velmi přesný - tzn. s čitelností kódů nebývá problém.

¨ Tepelný tisk

Tepelný tisk se dělí na tzv. přímý termální (Direct Thermal) a termotransferový (Thermal Transfer).

- Přímý termální tisk (Direct Thermal) - je starší metoda vyvinutá pro potřeby faxů. Spočívá v tisku na chemicky speciálně upravený papír. Tisk se tak skládá z jednotlivých řádků složených z teček. Náklady na tisk jsou minimální - pouze papír. Dosahuje dobrého rozlišení i kvality kódu. Nevýhoda je, že papír je stále chemicky aktivní, tzn. že stářím nebo UV zářením může dojít k poškození tisku.

- Termotransferový tisk (Thermal Transfer)

Tiskne podobně jako přímý termální tisk, ale místo chemicky upraveného papíru je zde tisková páska vyrobená z odolného polyesteru s nanesenou vrstvou inkoustu. Výhodou je trvanlivý a přesný tisk čárového kódu. Nevýhodou je pouze to, že barvící páska a potiskovaný materiál musí být vzájemně kompatibilní.

K průmyslovým tiskárnám čárového kódu lze objednat buď jako příslušenství nebo jako jejich součást např. odlepovačky etiket, řezačky potiskovaného materiálu, navíječe kotoučů etiket, nalepovací zařízení atd. V SAI BM obvykle preferujeme termotransferový tisk.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.10.2015


Pojem - SAI - Vyskladňovací / naskladňovací cesta

Je to trasa, po které se pohybuje skladník ve skladu s cílem optimálně vyskladnit či naskladnit artikly dané operace (obvykle dáno předpisem).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.08.2015


Pojem - SAI - Zdroj

Pro definování (určení) zdroje je naprosto nezbytné, aby v systému existoval předchůdce neboli předpis pohybu.

Zdrojem může být:

¨ čárový kód artiklu – každý skladovaný artikl má u sebe evidován jednoznačný čárový kód

¨ čárový kód balení – zde je obvykle definováno prvotní množství balení. Čárový kód balení se musí určitým způsobem v systému založit, obvykle na základě nějaké události obchodu a je určen např. atributem „obozvc“ nebo je vytvořen na základě nadefinovaných parametrů obchodu

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.10.2015


Pojem - Saldokontní hodnoty

Saldokontní hodnota je vypočtena agregací z několika hodnot (a to i různého druhu i z různých komponent) daného fyzického procesu. Na rozdíl od ostatních hodnot je saldokontní hodnota vztažena k jedinému konkrétnímu hlavnímu procesu. Pokud v procesu existují nenulové saldokontní hodnoty, lze tento proces z určitého pohledu považovat za nedokončený (viz též ukončení procesu). Druhy saldokontních hodnot je možno uvést při výběru v těchto činnostech:

¨ Procesy a operace – Nedokončené procesy

¨ Procesy a operace – Procesy (zde je nutno upozornit, že atribut umístění je bílý a tudíž přístupný vyplnění bez pomoci číselníku proto, že nemá implementován nadtyp v informačním centru, např. podobně jako artikl)

¨ Procesy a operace - Operace

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Saldokonto

V IS BM lze pomocí funkcionality saldokonta sledovat a řídit související účetní případy, které jsou reprezentované řadou dokladů, aby se udržela kontrola nad všemi saldokontně nevyrovnanými účetními zápisy. Základními nástroji saldokonta v IS BM jsou:

¨ Nastavení příznaku saldokontní „Ano“ u daného účtu v účtovém rozvrhu. Jako saldokontní lze nastavit libovolný účet rozvrhu, tj. nejen účty zachycující dodavatelsko–odběratelské vztahy, ale také např. účty třídy 1 (111, 112, 122 apod.).

¨ IDP uváděná v položkách účetních zápisů zajistí, že se položky se shodnou IDP stávají součástí souvisejících účetních případů (tj. jednoho saldokontně sledovaného celku). IDP je primárně předplňována identifikací hlavního procesu. Uživatelsky je možno tuto IDP změnit. Pokud to není vysloveně nutné, tak IDP uživateli měnit nedoporučujeme (ruční změnou IDP uživatel ztratí výhodu automatického spárování a pak si musí v celém saldokontním případu IDP hlídat ručně).

¨ Atribut „jiné párování“ v účetních zápisech nastaven na „Ano“ zajistí, že daná položka účetního zápisu se do saldokonta nezahrnuje, tj. velmi výjimečné použití.

¨ Činnosti určené k analýze neukončených saldokontních případů (účetní saldokonto a účetní saldokonto do data).

¨ Atribut „saldokontně neuzavřené“ na výběrové záložce činnosti Účetní deník (jeho zatržení zajistí, že se uživateli zobrazí jen saldokontně nevyrovnané účetní zápisy).

Účetní saldokonto v IS BM je vedeno vždy v referenční měně, tzn. v CZK. Účetní saldokonto sleduje, zda jsou vyrovnané strany Má dáti a Dal u saldokontních účtů jednotlivých účetních zápisů (dle IDP). Jedinou výchozí podmínkou pro správnou evidenci účetního saldokonta je prvotní úprava účtového rozvrhu. Uživatel si u jednotlivých účtů musí nastavit, zda jsou či nejsou saldokontní.

„Nerozlučná“ dvojice pro sledování účetního saldokonta (zde míněno ve smyslu dodavatelsko-odběratelských vztahů) je IDP a adresát. Neměla by nastat situace, že ke konkrétní IDP jsou navázáni dva různí adresáti.

Do účetního saldokonta se vždy zahrnují položky účetních zápisů na účtu, který má v účtovém rozvrhu nastaven příznak saldokontní „ANO“ a událost účetnictví má u atributu Jiné párování příznak „NE“. Účetní saldokonto lze do určité míry analyzovat i v činnosti Účetním deník, a to pomocí atributu „saldokontně neuzavřené“ ze záložky Výběr. Poté je nutno položku účetního zápisu uvést do režimu oprav (tj. po stisku klávesy F9 – Spustit operaci) a po stisku klávesy F2 na identifikaci párování (IDP) u saldokontního účtu dané položky účetního zápisu má uživatel k dispozici přesnou hodnotu a skladbu saldokonta dané IDP. V jednodušší formě, ale rychleji lze tuto informaci získat na záložce Saldokonto.

Zcela výjimečně mohou uživatelé použít činnost přepočet účetního saldokonta (menu účetnictví – speciální činnosti) a to v případech, kdy během účetního období nesaldokontní účet označí v účtovém rozvrhu jako saldokontní - pak je nutné hodnoty tohoto účtu znovu přepočítat. Optimální je ovšem provést nastavení příznaku „saldokontní účet – ANO“ před použitím daného účtu. Provedení přepočtu saldokonta však nezajišťuje automatické doplnění IDP číslem hlavního procesu – přepočet do prázdných IDP v účetních zápisech saldokontních účtů automaticky naplní pouze „pomlčku“.

Činnost saldokonto má uživatel k dispozici v hlavním menu – účetnictví – saldokonto nebo saldokonto do data. Z důvodu větší variability možností nastavení záložky Výběr je výhodnější používat činnost „saldokonto do data“.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.09.2008


Pojem - Selektor

Všechny události jsou založeny na tom, že někdo – někde – s něčím změnil stav světa. Někdo je v IS BM obvykle adresát (aktér), kterého ve statistickém pojetí lze reprezentovat obchodním selektorem. Někde je v IS BM obvykle umístění (alokace), které realizujeme podle komponenty, např. skladem, pokladnou apod., a které lze ve statistickém pojetí reprezentovat organizačním selektorem (u organizačního selektoru je možno definovat i umístění, u kterého lze nastavit přístupová práva). Něco je IS BM obvykle artikl, který realizujeme rovněž podle komponenty, např. skladovaným artiklem, obchodovatelným artiklem, penězi, sazbou DPH apod., a který lze ve statistickém pojetí reprezentovat technicko – věcným selektorem.

Vzhledem k tomu, že každý selektor se vztahuje k jednomu A (aktér, alokace, artikl) je u každého aktéra v adresáři uveden jeho obchodní selektor, u každého artiklu je uveden jeho technicko – věcný selektor a u každého umístění je v IS BM uveden organizační selektor. Při vytváření jednotlivých událostí a zadávání těchto atributů (AAA) se s nimi současně programovým kódem předplňují i zadané selektory.

K agregaci za selektory dochází při výpočtu statistických hodnot. Dle selektorů lze vybírat statistické hodnoty, události různých komponent, záznamy entit typu AAA i definovat údaje výkazů .

Ve formulářích jednotlivých selektorů jsou kromě identifikace a názvu selektoru dostupné i datumové atributy „platnost od“ a „platnost do“. Při zadávání událostí komponent pak není povolen vstup události se selektorem, jehož platnost neodpovídá datu uvedenému na události. Na výběrové záložce selektorů je pak na základě platnosti upraven i výběr.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 20.07.2007


Pojem - Semafor procesu

Je hodnota, která může signalizovat stav ukončenosti procesu z určitého pohledu daného implementačním záměrem. Jeho hodnotu aktualizuje ukončení těch operací, které to mají nastaveno ve vlastnostech operace daného druhu v diagramu procesu.

Proces se následně jeví jako ukončený z hlediska semaforu v případě, když je jeho hodnota nulová, tj. dle implementačního záměru, když jsou ukončeny všechny operace (zahájen uzel typu proces), u kterých je nastavena kladná nebo záporná hodnota aktualizující semafor. Pokud ve vlastnostech uzlu typu proces není nastavena žádná hodnota semaforu procesu, tzn. atribut semafor procesu je prázdný, systém pak tyto procesy z hlediska aktualizace semaforů nebere v potaz a považuje je za ukončené. Uzel typu proces se přičte/odečte jen první a aktualizuje hodnotu semaforu při zahájení.

Zjištění stavu ukončenosti procesu z hlediska jeho semaforu je možno využít při prohlížení fyzických procesů (činnost Procesy), kde uživatel ve výběru zaškrtne atribut „procesy s aktivním semaforem“.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Sériové číslo programu

Každý uživatel IS BM má ve smlouvě uveden zakoupený počet licencí a počet uživatelů. Na základě této licenční smlouvy je mu vygenerována verze, která je mu odeslána každým rokem v prosinci společně s předávacím protokolem. Od roku 2008 používají programy IS BM nové registrační klíče, ve kterých je zakódováno omezení maximálního možného počtu přihlášených uživatelů. Součástí dodávky verze je proto kromě CD s exe souborem a předávacího protokolu také vytištěný list obsahující tyto nové registrační klíče.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 19.12.2007


Pojem - Sestavení výkazu

Sestavením výkazu se rozumí automatizované naplnění sešitu MS Excel (komunikace) informacemi dle definice výkazu v IS BM.

Sestavení výkazu dle dané definice si uživatel vyvolá z hlavního menu INFORMAČNÍ CENTRUM – VÝKAZY – VÝKAZY KE SPUŠTĚNÍ – DRUH VÝKAZU nebo přímo ze seznamu definic výkazu. Po zadání proměnných dotazu se na sestavení jednotlivých listů dle jejich definice aplikuje šablona listu výkazů a dle nastavení v ní se buď list předplní daty již existujícího výstupního souboru nebo naopak se existující výstupní soubor zruší a nově založí.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Seznam

Pod pojmem seznam v IS BM rozumíme přehled určitých záznamů (např. události, přehled procesů, operací, záznamy vývěsky apod.). Při práci se seznamem záznamů je možno aktivně používat ikony z panelu nástrojů určené pro pohyb ve formuláři nebo využít posuvníku či šipek, které jsou umístě v pravé části seznamu záznamů. Při prohlížení seznamu záznamů je rovněž možno použít šipek na klávesnici, kdy se potom uživatel pohybuje po jednotlivých záznamech. Právě aktivní záznam v seznamu určuje přítomnost kurzoru, tzn. na kterém záznamu je umístěn kurzor, ten je právě aktivní. Toto byly činnosti, které uživateli umožňují pohyb v seznamu záznamů. V případě hledání určitého záznamu může uživatel využít možností, které mu poskytuje vyhledávání.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Seznam použitelných tool

Lze je použít především v tiscích, ale i ve výrazech (např.: obecných předkontacích). Jejich tvar je následující:

¨ tool.jmeno - jméno uživatele

¨ tool.jmenol - úplné jméno uživatele

¨ tool.uziv - identifikace uživatele

¨ tool.user - identifikace verze (číslo dodávané tvůrci IS ve formátu XXXXX-XX, přičemž poslední dvě čísla jsou identifikace datového úložiště)

¨ tool.bw01email - email uživatele

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.04.2004


Pojem - Signalizace zprávy - úkolu

U každé zprávy (činnost Marketing – Zprávy) se uživateli zobrazuje datum a čas zápisu, datum přijetí a zpracování zprávy, krátký text a komentář ke zprávě. Důležitou položkou ve zprávách je datum signalizace, pomocí kterého má uživatel možnost určovat datum, který den se daná zpráva objeví mezi aktuálními.

Důležitou roli v činnosti zprávy hraje i atribut připomenutí a čas. Pokud je zvoleno připomenutí „Ne“, zpráva se bude uživateli nabízet pouze v této činnosti jako aktuální nepřijatá zpráva (podle zvoleného data signalizace). Pokud je zvoleno „Ano“, tak podle nastaveného data a času se zpráva uživateli zobrazí jako samostatné okno informačního panelu (určení takto spuštěné stránky se provádí nastavením parametru BM, činnost Systém – Nastavení programu BM – Zpravy-pripomenuti_stranka, ve kterém se uvádí identifikace stránky informačního panelu, více o tomto v Návodech a balíčcích.) Zpráva je takto připomínána příjemci v případě, že:

¨ má nastaveno připomenutí „Ano“

¨ zpráva nebyla dosud zpracována

¨ datum a čas připomenutí je menší než aktuální systémové datum a čas

¨ BM v daném okamžiku nemá aktivní modální okno (tj. okno, ze kterého se nelze přepnout. Např. okno s určitým systémovým dotazem, kde je nutno zvolit odpověď Ano/Ne).

IS BM skenuje požadavky připomenutí zpráv (v okně Signalizace zpráv je to volba Skenovat zprávy) ve volitelném intervalu podle parametru BM Zpravy-pripomenuti_timeout (implicitně je nastaveno 5 minut). V případě, že je v okamžiku skenování aktivní modální okno, odloží skenování podle parametru BM Zpravy-pripomenuti_timeout_odlozeni (implicitně je nastaveno 1 minuta). Okamžik, kdy je zpráva uživateli jako samostatné okno informačního panelu připomenuta nastává:

¨ 15 vteřin po přihlášení uživatele do BM u těch zpráv, jejichž datum a čas připomenutí je v tomto okamžiku menší než aktuální systémové datum a čas

¨ u zpráv, které vznikly po spuštění programu na stejném počítači nebo jiném počítači zadané jiným uživatelem systému s maximálním zpožděním podle parametru Zpravy-pripomenuti_timeout

¨ je-li v okamžiku, kdy by mělo být zobrazeno okno s připomenutím aktivní modální okno, potom je připomenutí odloženo podle parametru Zpravy-Pripomenuti_timeout_odlozeni

¨ pokud se na zprávu nevztahuje žádná z předchozích možností, je připomenutí provedeno v určený čas

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 29.01.2014


Pojem - SKP

Hierarchicky uspořádané třídění produkce (zboží, prací výrobní povahy, služeb atd.) zavedené Českým statistickým úřadem. Klasifikace SKP je vypracována na bázi evropského standardu CPA (Classification of Product by Activity) a nahradila dosavadní klasifikace JKPOV, JKVZLVH, JKV, JKPVP a JKSO.

Klasifikace CPA byla vytvořena z oddílů Harmonizovaného systému resp. Kombinované nomenklatury (HS/CN), využívané v zahraničním obchodě pro celní účely, přičemž základ klasifikace tvoří odvětvová klasifikace NACE. Na rozdíl od HS/CN klasifikace CPA obsahuje i zboží a služby, které nejsou předmětem dovozu nebo vývozu a je vhodná pro různé ekonomické rozbory a analýzy.

Český statistický úřad podle § 19 odst. 2 zákona č. 89/1995 Sb., o státní statistické službě, ve znění pozdějších předpisů, zavádí Klasifikaci produkce (dále jen „CZ-CPA“). Sdělení navazuje na nařízení Evropského parlamentu a Rady (ES) č. 451/2008 ze dne 23. dubna 2008, kterým se zavádí nová statistická klasifikace produkce podle činností (CPA) a ruší nařízení Rady (EHS) č. 3696/93. Tento přímo použitelný předpis Evropských společenství zrušil zpětně s účinností od 1. ledna 2008 nařízení Rady (EHS) č. 3696/93, na základě kterého byla zavedena dosavadní Standardní klasifikace produkce (SKP), a stanovil použitelnost nové statistické klasifikace od 1. ledna 2008.

Klasifikace produkce (CZ-CPA), která zohledňuje technologický rozvoj a strukturální změny v hospodářství, nahrazuje Standardní klasifikaci produkce (SKP), vydanou sdělením Českého statistického úřadu č. 589/2002 Sb. ze dne 5. prosince 2002. Klasifikace včetně vysvětlivek a převodníku bude v tištěné podobě k dispozici v odboru informačních služeb Českého statistického úřadu, v elektronické podobě bude k dispozici rovněž na internetových stránkách úřadu na adrese www.czso.cz.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.01.2009


Pojem - Skupina předlohy výstupu

Skupina předlohy výstupu se nastavuje u každé jednotlivé předlohy výstupu ve vlastnostech předlohy. Aby bylo možno skupinu přiřadit k předloze výstupu, je nutno mít danou skupinu nadefinovanou v činnosti skupiny procesů a musí mít nastaveno hodnotu Ano v atributu „skupina předloh výstupu“.

Jednotlivé skupiny předloh či osobní skupiny předloh výstupu se zobrazují v okně výstupy (po aktivaci ikony „tiskárna“ nebo stisku Ctrl T) v případě, že je zvolené zobrazení ve formě stromu. Po stisku pravého tlačítka myši na názvu skupiny má uživatel k dispozici následující možnosti:

¨ metapředlohy – vyvolání formuláře pro definování metapředloh

¨ skupiny procesů/předloh výstupu – vyvolání formuláře pro definování skupin

¨ nastavení stromu – vyvolání formuláře pro definování vlastností zobrazení stromu

V případě, že uživatel ve vlastnostech předlohy přiřadil vybrané předloze výstupu skupinu a zároveň danou předlohu zařadil v podmenu volby osobní skupina předlohy do jiné skupiny, bude tato předloha zobrazena ve stromu dvakrát, tj. v obou skupinách.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 09.06.2009


Pojem - Skupina uživatelů

Skupina uživatelů je[1] soubor několika (alespoň jednoho) uživatelů a je nositelem určitého práva (ne)přístupu k IS. Skupiny uživatelů se definují v menu SYSTÉM v činnosti Skupiny uživatelů. Současně jsou pro uživatele k dispozici v činnosti „uživatelé programu“, záložka Skupiny uživatelů. Exkluzivní postavení má skupina "Každý uživatel systému". Jednotlivé nadefinované skupiny se využívají při definici přístupových práv k funkcím. Uživatel má kromě nadefinovaných skupin v okně činnosti k dispozici ještě záložku s přehledem uživatelů, pak jednotlivých uživatelů ve skupině a záložku o přístupech dané skupiny k věcem.

[1] Definici by bylo možné vést (resp. skupinu tak implementovat) i tímto směrem: Skupina uživatelů je element IS, který koresponduje s právě jedním klíčovým úkolem, který patří do kompetencí organizace. K tomuto klíčovému úkolu se přiřazují pracovníci (v IS uživatelé) a lze jej využít pro snadnější definici a správu přístupu uživatelů k funkcím a věcem s přístupem.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Skupinová položka hlavního menu

Jedná se o skupiny vytvořené v hlavním menu. Většina vytvořených skupin je již součástí základní definice menu, ale v případě potřeby si uživatel může zakládat skupiny další.

Každá skupina v hlavním menu obsahuje příslušné činnosti a stejně jako u činnosti, je možno i u skupiny po stisku pravého tlačítka myši nastavit následující:

¨ vlastnosti – název, poznámka, funkční klávesa, kterou lze skupinu aktivovat, atribut „skrytá“

¨ kopírovat – umožňuje danou skupinu zkopírovat (obdoba příkazu Ctrl+C) a vložit (obdoba příkazu Ctrl+V) na jiné místo v hlavním menu, tzn. většinou pod jinou skupinu činností čili vytvořit jakousi podskupinu.

¨ vrátit výchozí – pokud se jedná o skupinu z hlavního menu, u které uživatel změnil její vlastnosti (např. název, poznámku apod.), je po aktivaci této možnosti skupina uvedena do původního stavu (tzn. provedené uživatelské změny jsou zrušeny)

¨ odstranit – tato volba je dostupná u uživatelsky založených skupin

¨ vložit skupinu – možnost vytvořit u dané skupiny další skupinu (tzn. podskupinu)

¨ vložit činnost „xxxxxx“ – tato volba je vysvícena v případě, že uživatel po stisku pravého tlačítka myši zkopíroval určitou činnost, kterou chce přesunout právě pod danou skupinu. Po zkopírování činnosti a stisku pravého tlačítka myši na názvu skupiny se zobrazí právě možnost vložení zkopírované činnosti pod tuto skupinu.

¨ změnit pořadí činností – uživatel si může určit pořadí činností v dané skupině. Jednoduchým přesunem činností pomocí posuvníku je možno činnosti ve skupině libovolně přesouvat.

Novou skupinu je možno založit po stisku pravého tlačítka myši kdekoliv ve volném prostoru hlavního menu pomocí činnosti „vložit skupinu“. Možnost vytvoření nové skupiny přímo souvisí se způsobem zobrazení hlavního menu. V případě, že je hlavní menu zobrazeno způsobem „strom činností“, není možno vytvořit novou skupinu na úrovni hlavního menu. Nově vytvořená skupina se vždy vloží jako podskupina k právě aktivní skupině (tzn. té skupině, na které právě stojí kurzor). V případě jakéhokoliv jiného zobrazení hlavního menu (např. velké ikony, malé ikony apod.) se po stisku pravého tlačítka myši ve volném prostoru hlavního menu vytvoří nová skupina na úrovni hlavního menu. Uživateli se při zakládání nové skupiny nabídne okno, kde má možnost nadefinovat si název[1] skupiny (implicitně se předplňuje Nová skupina), poznámku, funkční klávesu a atribut skrytá. Atribut skrytá uživatel použije u skupiny, kterou již nechce používat, ale zároveň ji nechce ani trvale zrušit, tudíž u této skupiny zatrhne atribut „skrytá“ a skupina tedy bude stále existovat, ale nebude se zobrazovat v hlavním menu. V případě, že si uživatel potřebuje zobrazit skryté skupiny, spustí si ikonu „zobrazovat skryté činnosti“ v panelu nástrojů hlavního menu.

Kromě menšího množství uživatelsky definovaných skupin existuje ještě většina skupin programových, tedy těch, které jsou přímo součástí hlavního menu (např. Informační centrum, Procesy a operace, Obchod, Marketing, Platby apod.). Některé skupiny jsou tvořeny automaticky, tzn. bez přímého zásahu uživatele. V případě, že uživatel nadefinuje nový procesní import, bude tento automaticky vložen pod skupinu hlavního menu Import do procesu. V případě, že uživatel nadefinuje novou definici vyvolání, bude tato automaticky vložena pod skupinu hlavního menu Napojení do procesu. V případě nadefinování nového druhu procesu je tento automaticky uložen pod skupinu hlavního menu Nový proces. V případě, že je u druhu procesu určena i skupina procesů, je tento druh procesu vložen ještě do příslušné skupiny vytvořené pod skupinou Nový proces.

[1] Název skupiny je vhodné psát velkými písmeny, aby byla docílena shoda se zobrazením ostatních skupin v hlavním menu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Skupinový účet

Trojmístné vyjádření čísla účtu, kde na poslední třetí pozici je nula. Obvykle se na tyto účty neúčtuje, slouží pouze pro zjednodušené účetnictví.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.09.2008


Pojem - Skupiny procesů/předloh výstupu

Skupiny procesů/předloh výstupu jsou nástroj (škatulka), který k sobě umožňuje přiřadit (shluknout) druhy procesů obvykle blízkých vlastností z pohledu uživatele. U každé skupiny se zadává její identifikace a název.

Možnost definice skupin slouží uživatelům pro organizaci menu, které se mu nabízí po spuštění činnosti Nový proces. Zde se uživatelům nabízí všechny nadefinované procesy nezařazené do skupiny. Protože by mohla nastat situace, kdy by se časem toto menu příliš naplnilo a stalo se nepřehledné, je vhodnější např. procesy dle jednotlivých komponent nebo dle organizační struktury sdružit do určité skupiny. Při spuštění činnosti Nový proces se pak budou uživatelům nabízet nejprve skupiny procesů, ze kterých si dvojklikem nebo stiskem klávesy Enter vybraný proces spustí.

Kromě možnosti nadefinování skupin procesů slouží tato činnost k definici skupin předloh výstupu a k definici osobní skupiny předlohy výstupu. V této činnosti se pouze definují a určují jejich vlastnosti, jejich použití je při definici metapředloh výstupu a ve vlastnostech předloh výstupu. Význam těchto skupin spočívá v tom, že jednotlivé předlohy výstupu je možno zařazovat a třídit podle zvolených skupin, navíc pak každý uživatel může mít ještě i osobní skupinu předloh výstupu.

U každé nadefinované skupiny lze pak volbou Ano/Ne z překryvného seznamu nastavit její uplatnění:

¨ skupina procesu – použití pro procesy (Ano/Ne)

¨ skupina předloh výstupu – použití pro předlohy výstupu ve vlastnostech předlohy (Ano/Ne)

¨ osobní skupina předlohy výstupu – použití pro určení osobní skupiny předlohy výstupu (Ano/Ne)

Skupiny procesů se definují pouze v činnosti Druhy procesů - atribut skupina po stisku klávesy F2, ikony výběr nebo stisku pravého tlačítka myši přímo na atributu. Se zařazením procesů do jednotlivých skupin částečně souvisí i nastavení atributu „použití“ u druhu procesu. Pokud je nastaveno zobrazovat v menu, druh procesu se zobrazuje v činnosti Nový proces a je možno ho kdykoliv zařadit do zvolené skupiny, pokud je zde nastaveno nezobrazovat v menu, v činnosti Nový proces se pak tento druh procesu vůbec nevyskytuje a není smysluplné ho zařadit do skupiny. Možnost nezobrazovat využije uživatel zejména pokud definuje složitější proces, který se skládá nejen z operací, ale i z dalších procesů. Potom u vrcholného procesu zadá možnost zobrazit v menu a u procesů, které jsou součástí tohoto vrcholného procesu nastaví nezobrazovat v menu. Ty se pak spouští buď automaticky nebo napojením do procesu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 16.02.2012


Pojem - Skutečné pracovní místo

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 01.02.2008


Pojem - Sledování verzí impl. rozšíření

V IS BM je pro uživatele k dispozici informace, která mu umožňuje velmi pohodlně sledovat verze implementačních rozšíření. V podstatě se jedná o to, že u vybraných činností má uživatel k dispozici informaci o čísle vytvořené verze a dalších změnách, které se u dané činnosti udály. Je zde vždy info o čísle verze, posledním datu její aktualizace a identifikace uživatele, který změnu provedl.

Sledování verzí implementačních rozšíření je možno v těchto činnostech:

¨ sady systémových konstant

¨ předlohy výstupu

¨ knihovny vkládaného kódu

¨ doplňující vlastnosti formuláře

¨ externí příkazy

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 02.11.2012


Pojem - Sledování změn v záznamech tabulek IS BM

Činnost je pro uživatele dostupná v menu Systém. Umožňuje uživateli určit tabulky, jejichž změny záznamů mají být sledovány. Změny nadefinovaných tabulek je pak možno prohlížet v činnosti „přehled změn záznamů tabulek“ (menu Systém).

Po aktivaci této činnosti uživatel definuje následující položky:

¨ tabulka - identifikace tabulky IS BM (výběr se seznamu tabulek obsažených v datovém modelu)

¨ VK – název volné karty. IS BM umožňuje sledovat změny záznamů na volných kartách. Při změně struktury volné karty nejsou automaticky přegenerovávány triggery pro sledování změn záznamů VK. Generovat triggery je možno z formuláře definování VK volbou „generovat triggery tabulky“ nebo z menu Volby tohoto formuláře vyvolat „nastavení sledování změn tabulek“ a „uživatelské triggery“.

¨ založení - Ano/Ne – zda bude zaznamenávána informace o založení záznamu do tabulky

¨ oprava - Ano/Ne – zda bude zaznamenávána informace o změně záznamu tabulky

¨ zrušení - Ano/Ne – zda bude zaznamenávána informace o zrušení záznamu tabulky

¨ podmínka - omezuje množinu sledovaných záznamů. Je to výraz v syntaxi Sybase SQL Anywhere - před jednotlivými atributy je třeba uvádět prefix $$$., který je v generovaných triggerech nahrazován textem new_name, resp. old_name

¨ atributy – výběr z překryvného seznamu - určuje způsob výběru atributů uvedených v následujícím atributu 'seznam atributů'. Je možno zvolit „všechny vyjmenované atributy“ nebo „všechny kromě vyjmenovaných atributů“

¨ seznam atributů - uvádí se přímo seznam atributů tabulky, jejichž hodnoty mají být, resp. nemají být sledovány (v návaznosti na to, co je uvedeno u atributu „atributy“)

¨ výraz popisu - výraz v syntaxi Sybase SQL Anywhere - před jednotlivými atributy je třeba uvádět prefix $$$., který je v generovaných triggerech nahrazován textem new_name resp. old_name

¨ aktivní - Ano/Ne - nastavení Ne je určeno pro pozastavení sledování změn (např. před hromadnou změnou dat pomocí ISQL)

¨ poznámka - libovolný text

Po vložení definic sledování změn je třeba vygenerovat triggery, které budou sledovat změny v určených tabulkách. Toto generování se provede aktivací příslušné činnosti z menu Volby:

¨ generovat triggery tabulky – pouze pro aktuální definici tabulky

¨ generovat všechny triggery - pro všechny definice tabulek

Jejich funkčnost je totožná s činností „uživatelské triggery“. Při generování triggerů je nutné, aby v daném okamžiku nepracoval s dotčenými tabulkami jiný uživatel.

Příklady výrazu popisu:

Tabulka ADADSAT - $$$.ad01adsat

Tabulka ADADR - (select ad01adsat from %%%.ADADSAT where ad01id=$$$.ad01id)

Tabulka ADSPOJ - (select ad01adsat from %%%.ADADSAT where ad01id=$$$.ad01id)

Tabulka SPARTIKN (název artiklu) - $$$.sp62artikl

Tabulka OBARTIKL - (select sp62artikl from %%%.SPARTIKN where sp61id=$$$.sp61id and sp60id=$$$.sp60id and sp38id='CZE')

Tabulka MTARTIKL - (select sp62artikl from %%%.SPARTIKN where sp61id=$$$.sp61id and sp60id=$$$.sp60id and sp38id='CZE')

Omezení sledování změn tabulky obchodovatelného artiklu (OBARTIKL) výhradně pro druh artiklu 'ZBO' .

Podmínka = $$$.sp61id='ZBO'

Při sledování změn tabulky uživatelé programu (BWUZIVAT) je vhodné vyloučit ze sledování atributy BW01NAPOSL (Datum a čas posledního vyvolání systému - aktualizuje se při každém přihlášení uživatele) a SP38ID (Identifikace jazyka - může uživatel sám měnit). Pak je nastavení následující:

¨ Atributy = Všechny kromě vyjmenovaných atributů

¨ Seznam atributů = bw01naposl,sp38id

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 14.11.2007


Pojem - Sloupec definice listu výkazů

Sloupec je elementem definice listu s prioritou po řádku, tj. může definovat implicitní vlastnosti buňky, pokud nejsou definovány řádkem. Daný sloupec definice listu je dostupný pomocí navigačního listu, pokud definice listu není založena pomocí vzoru listu je možné zde definovat jeho vlastnosti, případně zrušit či založit nový.

Jednomu sloupci definice listu odpovídá jeden sloupec výkazu, pokud je v atributu parametry sloupce aplikován příkaz dyn, může to být více sloupců výkazu.

Sloupec definice listu výkazů prezentovaný identifikátorem sloupce umožňuje definovat pořadí a název sloupce, atribut parametry, implicitní formát a obsah jeho buněk výrazem nebo vzorcem, případně zda má být sloupec ve výkazu skrytý.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Slovník dat (SD)

SD je nástroj (funkce) informačního systému Bílý Motýl, který uživateli umožňuje definovat pohledy na data (struktura - datový submodel, výběr - vymezení podmnožiny, předloha výstupu - forma zobrazení) nezávisle na funkcích IS připravených poskytovatelem. Pohledy se kategorizují do tříd, což umožní jejich zpřehlednění, ale i dědění vlastností.

V IS jej lze najít ve skupině SYSTÉM.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Slučování adresátů

Jedná se o činnost, která umožňuje uživateli sloučit adresáty, kteří jsou totožní a kteří byli omylem do systému zadáni víckrát (zřejmě nebyla v parametrech adresáře nastavena validace na IČO a DIČ). Při slučování adresátů se postupuje takto:

¨ v adresáři jsou k dispozici obecné výběry „duplicitní IČO, duplicitní DIČ a duplicitní název“, pomocí těchto výběrů naleznete adresáty, které chcete sloučit (tzn. systém vyhledá ty adresáty, kteří mají shodné IČO, DIČ nebo název)

¨ v adresáři je volná karta „počet událostí“, která zjistí počet událostí k určenému adresátovi, pokud tedy chcete některého adresáta smazat (například proto, že je duplicitní), můžete tak učinit v případě, že nemá žádné vytvořené události

¨ spojení adresátů, kteří mají již nějaké události (Adresář -> Číselníky a parametry -> Duplicita adresátů -> F3), je potřeba vložit původního a aktuálního adresáta, tj. adresáta v jehož událostech bude změněn adresát na nového (aktuálního), po vyplnění obou adresátů zapsat

¨ v případě, že není vyplněna záložka „spojení adresáta“, jsou spojení z původního adresáta přidána do spojení aktuálního adresáta, v opačném případě je třeba vyplnit spojení na původního adresáta a aktuálního adresáta, které se mají sloučit (definuje se, která spojení původního adresáta odpovídají spojením aktuálního adresáta)

¨ záložka „bankovní spojení“ funguje obdobně, jako záložka „spojení“, tj. v případě, že ji nevyplníte je bankovní spojení původního adresáta přidáno k bankovním spojením adresáta aktuálního, pokud je přidávané bankovní spojení identické, pak je automaticky spárováno s původním

¨ po vyplnění formuláře „duplicita adresátů“ použijte v menu Volby činnost „zaměnit vazby na původního“, tím jsou události původního adresáta převedeny na aktuálního adresáta, tudíž ho můžete smazat (je měněn odkaz na původního adresáta podle záložky "adresát", na jeho spojení podle záložky "spojení", na jeho bankovní spojení podle záložky "bankovní spojení" všude tam, kde se tyto vyskytují jako cizí klíče, např. v událostech komponent. Navíc jsou kopírovány objektové vazby původního adresáta k aktuálnímu adresátovi)

¨ pokud chcete u adresáta sloučit spojení, existuje v menu Volby ve spojeních adresáta činnost „slučování spojení adresáta“, která toto umožňuje (pozn. pokud nemáte dosud spojení zapsáno v nové struktuře, je třeba nastavit správně typy spojení a použít činnost „konverze spojení do nové struktury“)

Poznámky:

Události záloh, které jsou vyúčtované, zůstanou přiřazeny k původnímu adresátovi. Proto je potřeba u těchto událostí zrušit ( nejdřív odblokovat) operaci vyúčtování, provést toto sloučení a znovu vyúčtovat.

Nedefinovaná spojení původního adresáta na záložce "spojení adresáta" způsobí, že tato spojení budou zkopírována ke spojením aktuálního adresáta (včetně adres). Přitom se informace o tom, že tato nově založená spojení aktuálního adresáta jsou totožná s odpovídajícími spojeními původního adresáta zapíše do dat tak, že se po provedení funkce začnou objevovat na záložce "spojení", jako kdyby je uživatel zadal ručně. To umožňuje tuto funkci spouštět opakovaně.

Nadefinovaná bankovní spojení původního adresáta na záložce "bankovní spojení" fungují obdobně jako nadefinovaná spojení původního adresáta na záložce "spojení adresáta" s tím rozdílem, že bankovní spojení původního adresáta není k aktuálnímu adresátovi přidáváno v případě, že u něho již existuje bankovní spojení se stejným kódem banky, prefixem účtu, číslem bankovního účtu a specifickým symbolem.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.01.2006


Pojem - Směrná účtová osnova

V ČR je Směrná účtová osnova dána legislativou a představuje seznam účtových skupin, které musí účetní jednotka respektovat. Na základě této účtové osnovy vytváří účetní jednotky účtový rozvrh.

Určuje uspořádání a označení účtových tříd, popř. účtových skupin nebo i syntetických účtů pro účtování, je dána legislativou (Vyhláškou č. 500/2002 Sb.). Na základě této účtové osnovy si účetní jednotky sestavují svůj účtový rozvrh, tj. mají povinnost v něm zachovat strukturu danou jejich směrnou účtovou osnovou. Směrná účtová osnova není v IS BM přímo evidována, nicméně je možné si odpovídající právní předpis připojit jako dokument.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.09.2008


Pojem - SMTP

Simple Mail Transfer Protocol (zkratka SMTP) je internetový protokol určený pro přenos zpráv elektronické pošty (e-mailů ) mezi přepravci elektronické pošty (MTA). Protokol zajišťuje doručení pošty pomocí přímého spojení mezi odesílatelem a adresátem; zpráva je doručena do tzv. poštovní schránky adresáta, ke které potom může uživatel kdykoli (off-line) přistupovat (vybírat zprávy) pomocí protokolů POP3 nebo IMAP . Jedná se o jednu z nejstarších aplikací, původní norma RFC 821 byla vydána v roce 1982 (v roce 2001 ji nahradila novější RFC 2821 ). SMTP funguje nad protokolem TCP , používá port TCP/25.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2015


Pojem - SOAP

SOAP (původně Simple Object Access Protocol) je protokolem pro výměnu zpráv založených na XML přes síť, hlavně pomocí HTTP. Formát SOAP tvoří základní vrstvu komunikace mezi webovými službami a poskytuje prostředí pro tvorbu složitější komunikace. Existuje několik různých druhů šablon pro komunikaci na protokolu SOAP. Nejznámější z nich je RPC šablona, kde jeden z účastníků komunikace je klient a na druhé straně je server. Server ihned odpovídá na požadavky klienta.

HTTP i SMTP se dají použít jako aplikační vrstva pro protokol SOAP. Ale HTTP dosáhl daleko většího použití. Je to především proto, že HTTP je prakticky základ pro dnešní firewall. To je hlavní výhoda oproti jiným distribuovaným protokolům, jako je například DCOM, které jsou většinou na firewallu zakázány.

XML formát byl zvolen jako standard pro přenos SOAP zpráv pro jeho rozšířenost a dostupnost vývojových nástrojů nabízených jako opensource nebo freeware a tedy volně k používání.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2015


Pojem - Socialní pojištění

Částka, kterou zaměstnanec odvádí České správě sociálního zabezpečení. Celkem tento odvod činí 8% z hrubé mzdy. Skládá se z pojistného na důchodové pojištění, nemocenského pojištění a příspěvku na státní politiku zaměstnanosti.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 29.02.2008


Pojem - Sociální pojišťovny

Tato záložka poskytuje přehled o sociálních pojišťovnách daného pracovníka (obdobně jako se na kartě zadává u pracovníka Zdravotní pojišťovna). Z praxe je možné, aby v organizaci pracovali lidé s různými sociálními pojišťovnami. Implicitně platí, že pokud nemá pracovník v této činnosti uvedenu žádnou sociální pojišťovnu, použije se automaticky adresa pojišťovny, která je uvedena v činnosti Parametry. U pracovníka je možno zadat v případě potřeby i cizí sociální pojišťovnu (pak je nutno zadat i měnu, v které se budou výše odvodů evidovat).

Číselník zdravotní pojišťovny byl přejmenován na zdravotní a sociální pojišťovny. Jsou zde oba druhy pojišťoven zároveň, pouze odlišeny typem.

V souvislosti s vytvořením sociálních pojišťoven došlo k vytvoření nového atributu „způsob výpočtu sociálního pojištění“ jednotlivě nebo souhrnně (činnost Parametry, záložka Chování).

U způsobu výpočtu „jednotlivě“ dochází k těmto zaokrouhlením. Pro každou skupinu pracovníků se stejnou sociální pojišťovnou uvedenou na kartě pracovníka vznikne položka I31000 s adresátem podle sociální pojišťovny. Rozdíl součtu těchto I31000 a odvodu vypočítaného ze součtu I30000 je zapsán na adresáta podle sociální pojišťovny.

U způsobu výpočtu „souhrnně“ dochází k těmto zaokrouhlením. Za každou sociální pojišťovnu dojde k výpočtu položky I31000 ze součtu I30000. Rozdíl součtu těchto I31000 o odvodu vypočítaného z celkového součtu I30000 se zapíše s adresátem dle činnosti Parametry.

Pro skupinu pracovníků, která nemá na kartě uvedenu žádnou sociální pojišťovnu vznikne položka I31000 s adresátem dle nastavení v činnosti Parametry. Rozdíl součtu těchto I31000 a odvodu vypočítaného ze součtu I30000 se zapíše s adresátem dle činnosti Parametry.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 25.04.2008


Pojem - Software - programový kód

Jedná se o tu část poskytovaného IS, která se nazývá programový kód (resp. sada instrukcí), a která zajišťuje funkcionalitu IS. Úzce souvisí s definičními daty, která řídí (korigují) jeho funkcionalitu. Uživatel programový kód poskytnutého IS nemůže modifikovat, nicméně některá definiční data se svým charakterem blíží programovému kódu, resp. jej doplňují.

Po stránce logické je programový kód (funkce) IS uspořádán do činností. Po stránce technické jej lze rozdělit takto:

¨ programy databázového serveru: uložené procedury a triggery v syntaxi Sybase SQL Anywhere

¨ programy klienta: .exe v syntaxi Visual FoxPro

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Souhrnné hlášení

Plátce je povinen podat souhrnné hlášení, pokud uskutečnil dodání zboží do jiného členského státu osobě registrované k dani v jiném členském státu; přemístil obchodní majetek do jiného členského státu; dodal zboží kupujícímu při zjednodušeném postupu v třístranném obchodu podle §17, pokud je plátce prostřední osobou v tomto obchodu nebo poskytnul službu s místem plnění v jiném členském státě podle §9 odst. 1, s výjimkou služeb osvobozených od daně, pokud je povinen přiznat a zaplatit daň příjemce služby (ve znění platného zákona).

Souhrnné hlášení se podává formou datové zprávy, která je opatřena uznávaným elektronickým podpisem, nebo která je odeslána prostřednictvím datové schránky, vždy ve formátu, struktuře a s údaji stanovenými správcem daně. Údaje o hodnotě dodaného zboží nebo poskytnuté služby se uvádějí v české měně.[1]

Uživatel si souhrnné hlášení vytvoří následujícím způsobem:

¨ v činnosti události DPH si na výběrové záložce zvolí období od – do

¨ v obecném výběru platném pro dané období vybere „souhrnné hlášení“

¨ v činnosti Daňová přiznání je nutno mít vyplněnu volnou kartu „Hlavička daňového přiznání“ (menu Obecné – Volné karty)

Po načtení těchto příslušných událostí vyvolá předlohy výstupu (v panelu nástrojů ikona tiskárna nebo pod menu Volby Ctrl T). Zde má uživatel k dispozici předlohu výstupu „Souhrnné hlášení VIES“ a „Souhrnné hlášení VIES 2010“ (nutno si vybrat předlohu v platném znění pro daný rok, viz. dokument legislativně závislá nastavení).

Po aktivaci dané předlohy se spustí portál EPO (aplikace daňové správy), kde lze zkontrolovat a především VYTISKNOUT souhrnné hlášení. Další způsob zpracování souhrnného hlášení je shodný s elektronickým podáním přiznání DPH (viz. kapitola 5.4). Aplikace EPO je vytvořena přehledně a intuitivně vede uživatele kterou činnost má právě provést.

[1] Tzn. že souhrnné hlášení lze podle zákona od r. 2010 podat pouze elektronickým způsobem.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.03.2010


Pojem - Specifická práva správce

Správce je specifický uživatel IS BM a jako takovému jsou mu přiřazena i určitá specifická práva (tyto práva jsou dostupná i uživateli, který má v činnosti „uživatelé programu“ zatržen příznak „práva správce“). Jsou to:

¨ oprávnění k činnostem - po prvním přihlášení do systému má kromě činností, které jsou přístupné všem (skupina každý uživatel systému, do které je automaticky zařazen), primárně přístupnou činnost „oprávnění k činnostem“ (činnost Systém – Oprávnění k činnostem). Tuto činnost sice ve svém menu mohou mít přístupnou i ostatní uživatelé systému (pokud ji nemají právě od správce v oprávnění k činnostem zakázánu), dokonce ji poté mohou i aktivovat, nicméně provádět jakékoliv změny a nastavení v této činnosti je možno VŽDY pouze pod heslem správce (nebo pod heslem uživatele, který má nastaven „práva jako správce“).

¨ inicializace hesla – v případě, že některý z uživatelů zapomene své změněné přístupové heslo, může mu správce pomocí činnosti inicializace hesla obnovit heslo původní.

¨ příznak „skrytá všem“ v předlohách výstupu – na záložce Obecné ve vlastnostech předlohy výstupu je pro správce dostupný atribut „skrytá všem“. Využije ho zejména u předloh, u kterých nechce, aby se zobrazovaly v základní nabídce. Taková předloha se pak nezobrazuje žádnému uživateli. V případě potřeby zobrazení takové předlohy je toto možno docílit pomocí ikony „skryté“.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Spojené dokumenty – Ctrl D

Přes vybraný objekt (vývěska, zprávy, události komponent) je možno spojit přes klávesu Ctrl D (nebo menu Volby – Dokumenty) jakýkoliv dokument. Vyvolání formuláře bylo zatím možné pouze z formulářů pro vstup objektů BM (události, artikly, adresát, ..). V IS BM je možné připojovat dokumenty i k záznamům tabulek, které nejsou objekty BM. Spojení s dokumentem čili existence vazby objekt - dokument se pak jako jiné objektové vazby ukazuje v rámečku souvislostí pomocí znaménka plus. Po stisku klávesy Ctrl D se uživateli zobrazí rámeček „spojené dokumenty“. Zde má k dispozici dokumenty objektu, procesu, operace, adresáta a artiklu. V případě potřeby vytvoření objektové vazby (např. navázání smlouvy na událost vývěsky) se využijí dokumenty objektu. Dokumenty procesu a operace se napojují automaticky, pokud dokument vzniká jako součást (je nadefinovaný v diagramu procesu) procesu nebo operace. Pod dokumenty adresáta se nejčastěji ukládají dokumenty, které jsou přímo svázány s daným adresátem, např. smlouvy, ceníky adresáta apod. Pod složkou artikl jsou obsaženy události artiklu, který je aktuální na události, ze které si uživatel spojené dokumenty vyvolal.

Další složky, které jsou dostupné pod dokumenty adresáta jsou:

¨ kategorie adresáta – ukazuje se přehled kategorií, ve kterých je daný adresát zařazen

¨ procesy adresáta – ukazuje se strukturovaný přehled procesů, které byly založeny pro daného adresáta.

¨ události adresáta – ukazují se události jednotlivých komponent, ve kterých je adresát uveden

Menu události adresáta a události artiklu se po spuštění činnosti spojené dokumenty zobrazuje zabalené (tzn. před jeho názvem je znaménko +) a napsané v závorkách. V tomto případě uživatel nedokáže rozpoznat, jestli adresát či artikl některé události obsahuje. Musí nabídku událostí nejprve rozbalit, tzn. kliknout na znaménko +. A pak se mu zobrazují pouze události komponent, ve kterých je adresát nebo artikl obsažen. Události jednotlivých komponent se v nabídce zobrazují podle druhu události, tzn. že např. v událostech změny stavu peněz může mít adresát uvedeno 12 událostí pohybu příjem do pokladny a 15 událostí pohybu úhrady předepsaných plateb. V případě, že uživatel nechá nabídku složky události adresáta nebo artiklu rozbalenou a takto ukončí činnost spojené dokumenty, tak při následujícím spuštění spojených dokumentů jsou tyto složky ve stavu rozbaleno.

Tato menu se dají ovládat i pomocí myši:

¨ pravý klik na složce kategorie adresáta - vyvolání formuláře kategorií adresáta

¨ dvojí klik na konkrétní kategorii adresáta - vyvolání formuláře kategorií adresáta

¨ pravý klik na komponentě ve složce událostí - vyvolání formuláře odpovídajících událostí komponenty

¨ dvojí klik na druhu operace ve složce komponenty - vyvolání formuláře událostí komponenty (s předplněným výběrem daného druhu operace)

V případě potřeby vytvoření dokumentu uživatel postupuje následujícím způsobem. Kurzor umístí např. na dokumenty objektu (tzn. okno spojených dokumentů je aktivní) a po stisku pravého tlačítka myši se mu zobrazí volby:

¨ nový dokument – tuto možnost uživatel využije v případě, že vytváří úplně nový dokument. Při vytváření nového dokumentu musí nadefinovat jeho vlastnosti.

¨ načíst dokument – tuto možnost uživatel využije v případě, že již má dokument vytvořený, uložený mimo systém IS BM a chce tento dokument do systému přenést. Po aktivaci této činnosti uživatel určí cestu, odkud se má soubor načíst a pak už jen upřesní vlastnosti dokumentu (název, typ dokumentu a předlohy, příznak chráněného dokumentu). Je možno využít i možnosti externího uložení dokumentu. Po stisku OK je dokument načten a stává se součástí databáze IS BM (pokud nemá nadefinováno externí uložení).

¨ uložit obrázek v clipboardu – tato možnost umožňuje připojit jako dokument obrázek, který má uživatel uložen v clipboardu, tzn. na určitém obrázku mimo IS BM uživatel potvrdí volbu kopírovat (Ctrl C) a po aktivaci této činnosti je obrázek vložen jako dokument IS BM. Tato možnost je pro uživatele aktivní, je-li v hlavním menu programu obsažen program PCT_DLL.DLL. Obrázek je ukládán ve formátu JPEG.

IS BM umožňuje přenášet soubory tažením myší (metoda „táhni a drž“) do okna spojených dokumentů např. z okna průzkumníka Windows (tažením myší není možné připojovat přílohy e-mailu). Stejným způsobem je možné připojovat dokumenty k procesům nebo operacím ve formuláři Strom hlavního procesu a objektům, které mají zobrazený připojený dokument (obrázek) na volné kartě prostřednictvím atributu volné karty typu „multimediální“.

Po přetažení souboru do IS BM se pak systém chová standardně jako při klasickém vytváření dokumentu BM. Je nutno zadat jeho vlastnosti (tzn. název, druh dokumentu apod.). Pokud je v okamžiku uvolnění tlačítka myši stisknuta na klávesnici klávesa Shift, potom se ve vlastnostech připojovaného dokumentu automaticky nastaví zaškrtnuté „externí uložení“ na záložce „uložení dokumentu“.

Při založení dokumentu tažením myší je ukládána v IS BM informace o názvu načteného dokumentu (ukládá se do tabulky SPDOKFIL). Při opakovaném načtení dokumentu stejného názvu je pak systémem zobrazen dotaz podobného typu jako:

„Dokument „........název.........“ byl již do BM načten. Načtení provedl(a) – jméno a datum. Má být dokument opakovaně načten do BM (volba Ano) nebo má být připojen tento dříve načtený dokument? (volba Ne)?

Po stisknutí tlačítka ANO je původní načtený dokument přepsán úplně novým dokumentem, po stisknutí tlačítka NE není zakládán nový dokument a je pouze vytvořena objektová vazba mezi objektem BM a dokumentem, který byl již dříve načten. Při stisku klávesy Storno se neprovede žádná akce.

Ve stromech spojených dokumentů je nyní možné zvolit si tvar popisu dokumentu ve stromu. To se provádí pomocí nastavení parametru BM Preferences->Skript_pro_popis_dokumentu, kterým se uvádí identifikace knihovny vkládaného kódu, jejíž kód bude spouštěn pro určení popisu dokumentu. Tento skript musí vracet textovou hodnotu a v okamžiku jeho provádění má k dispozici informace o dokumentu v kurzoru _DOCS, který obsahuje mj.atributy:

SP26

SP26DATUM

SP26NAZEV

SP26INDEX

SP57ID

SP57TYPDOK

SP01ID

SP01PREDLO

SP26SOUBOR

SP26DISK

BW01UZIV

BW01JMENO

BW01JMENOT

SP44PRISTU

Kromě popisu dokumentu ve stromu je možné změnit také ikonu dokumentu vložením názvu souboru ikony do proměnné _NODE.ICON.

Př.:

Do Case

Case sp26disk<>1

Case Empty(Sys(2000,(sp26soubor)+''))

_node.Icon='hotovo'

Case Inlist(Upper(Justext(sp26soubor)),'BMP','ICO','JPG','GIF')

_node.Icon=sp26soubor

Endcase

Return Trans(sp26datum)+' '+Trim(sp26nazev)+Iif(sp26disk=1,' ('+Justfname(sp26soubor)+')','')

Pokud uživatel u daného dokumentu sleduje revize, ukazují se pod názvem dokumentu ve stromovém zobrazení (tzn. po stisku znaménka +) i revize daného dokumentu. Dvojklikem je možno danou revizi otevřít. Po stisku pravého tlačítka myši na názvu revize dokumentu je možno revizi otevřít nebo zrušit. Přehled těchto revizí pod každým dokumentem se aktualizuje po aktivaci možnosti obnovit přehled revizí (viz. popis níže).

V případě, že uživatel už má několik dokumentů vytvořených a chce s dokumentem dále pracovat, vyvolá si stejně jako při založení přes klávesu Ctrl D okno „spojené dokumenty“ a umístí kurzor na vybraný název dokumentu. Po stisku pravého tlačítka myši na názvu dokumentu má uživatel k dispozici tyto možnosti:

¨ otevřít dokument – aktivuje spuštění dokumentu (stejného efektu lze dosáhnout dvojklikem levého tlačítka myši na názvu dokumentu).

¨ založit proces pošty – umožňuje vytvořit proces poštovní zásilky (nebo poštovní zásilky + zápis události na vývěsku), ke které je automaticky dokument připojen a po spojení s událostí pošty je možno využít vlastností mailmerge, tj. předplnění adresy adresáta z události pošty do dokumentu.

¨ založit proces e-mail – obdoba procesu pošty s tím rozdílem, že dokument se neposílá klasickou poštou, ale emailem. Uživateli se přesto zobrazí klasická operace pošty a po aktivaci činnosti „odeslat e-mail“ (menu Volby) se dokument odešle adresátovi z poštovní zásilky emailem. Podmínkou tohoto procesu je, že adresát musí mít v adresáři (ve spojeních) uvedeno e-mailové spojení (tzn. e-mailovou adresu).

¨ kopírovat dokument – umožňuje vytvořit kopii dokumentu. Kopii může uživatel vložit ke stejné události jako je kopírovaný dokument nebo může kopii dokumentu připojit k úplně jiné události. Na takové události uživatel vyvolá klávesou Ctrl D okno spojeného dokumentu a pravým tlačítkem myši např. na dokumentech objektu si vyvolá možnost „vložit dokument ..(jeho název).......“.

¨ uložit jako – možnost externího uložení dokumentu.

¨ uložit novou verzi dokumentu

¨ odeslat dokument – pokud je dokument spojen s událostí vývěsky, kde je uveden adresát, který má uvedeno emailové spojení, předplní se okno e-mailové pošty touto adresou s vloženým dokumentem. V případě, že není uveden adresát nebo nevlastní e-mailové spojení, otevře se e-mailová pošta s vloženým dokumentem, ale atribut KOMU zůstává prázdný.

¨ zrušit spojení s dokumentem – tato činnost ruší objektovou vazbu na událost, z které byl dokument vyvolán, tzn. událost nemá dále žádnou vazbu na tento dokument. Touto akcí je však zrušena pouze vazba, pokud by uživatel potřeboval zrušit dokument jako takový, je nutno si aktivovat činnost „dokumenty“ (menu Marketing – Dokumenty – Dokument), zde si příslušný dokument najít a pomocí klávesy F8 nebo ikony křížek tento dokument odstranit.

¨ kopírovat odkaz na dokument – v případě potřeby je možno vytvořit u vybrané události pouze odkaz na dokument, není nutno tento dokument přímo s událostí svazovat. Např. je vytvořen dokument adresáta „smlouva“ a uživatel na některé události vývěsky potřebuje vytvořit odkaz na tuto smlouvu. Potom na dokumentu smlouva aktivuje činnost kopírovat odkaz na dokument, přepne se na události vývěsky, vyvolá spojené dokumenty (Ctrl D) a po stisku pravého tlačítka myši na dokumentech objektu aktivuje možnost „spojit s dokumentem ..(jeho název).......“.

¨ prezentace dokumentu – možnost vytvoření prezentace (neboli optického náhledu) dokumentu.

¨ volné karty dokumentu

¨ volné karty vazby objektů

¨ obnovit přehled verzí – po aktivaci této možnosti se obnoví přehled verzí, který je součástí každého vytvořeného dokumentu o další uloženou kopii

¨ navazující dokument – zde je možno pomocí objektové vazby připojovat k danému dokumentu jeho následníky (možnost Nový dokument, Načíst dokument). Vytvořený následník se pak automaticky zařadí pod vlastní název dokumentu.

¨ vlastnosti dokumentu

Ve stromech zobrazovaných ve formulářích spojené dokumenty, strom hlavního procesu a obdobných stromech formuláře okno úloh je možno implementačně doplnit definovatelné funkce pro menu, která jsou vyvolávána po stisku pravého tlačítka myši na uzlu představujícím objekt BM. Toto implementační doplnění je možno nadefinovat v činnosti „doplňující položky menu objektů“.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.06.2014


Pojem - Spojení adresátů v událostech komponent

Možnost nadefinování rozdílného čísla spojení adresáta v událostech operací různých komponent je v IS BM dostupná v činnosti Druhy operací pod záložkou „Spojení“.

Na této záložce se definuje jakým způsobem program určuje číslo spojení adresáta při vstupu nové události daného druhu operace. Zadává se:

¨ spojení – 1.adresáta/2.adresáta (překryvný seznam) – určuje, kterého adresáta v události se daná definice spojení týká (zadat hodnotu „2.adresáta“ má smysl pouze pro operace komponenty obchod,

jejíž události obsahují dva adresáty)

¨ subjekt – textová hodnota – uvádí se identifikátor typu subjektu spojení adresáta – bude předplňováno spojení daného typu subjektu

¨ kategorie – textová hodnota – uvádí se kategorie spojení adresáta – bude předplňováno spojení, které je k datu události zařazeno do uvedené kategorie (lze zadat i vypočítávanou kategorii)

¨ použít impl. – Ano/Ne (překryvný seznam) – určuje pravidlo, zda se má použít implicitní spojení adresáta v případě, že pro něj neexistuje spojení daného typu subjektu

¨ proces – textová hodnota – uvádí se identifikátor druhu procesu – umožňuje definovat různé způsoby předplnění spojení adresáta pro danou operaci v případě, že je použitá v různých druzích procesů

¨ kód – textová hodnota – kód v jazyce FoxPro vyvolávaný pro určení spojení adresáta. V okamžiku vyvolání jsou pro kód dostupné proměnné _THIS (instance objektu formuláře ve kterém je prováděn

vstup), _AD01ID (identifikace adresáta pro kterého má být spojení předplněno) a _SPF2CSSP (odpovídá zadávané vlastnosti „spojení“ – nabývá hodnota 1 nebo 2) – kód by měl vracet textovou hodnotu

¨ poznámka – libovolný text

Postup programu při zjišťování předplňovaného čísla spojení adresáta je následující:

  1. je vyhledána definice pro určení spojení pro daný druh operace v odpovídajícím druhu procesu – není-li taková definice nalezena, vyhledává se definice pro daný druh operace s uvedeným druhem procesu ‘-’
  2. není-li ani jedna taková definice nalezena, předplní se spojení uvedené jako implicitní pro daného adresáta
  3. je-li uveden atribut „kód“ a v průběhu zpracování je vyplněn textovou hodnotou, spojení adresáta bude předplněno touto hodnotou
  4. je-li uveden atribut „subjekt“ (tzn. jeho identifikace není ‘-’), vyhledává se nejmenší spojení vstupovaného adresáta které má u sebe uvedený typ subjektu spojení. Je-li takové spojení nalezeno, potom je spojení v události předplněno jeho identifikací.
  5. je-li uvedena kategorie spojení adresáta – vyhledává se nejmenší spojení vstupovaného adresáta, které je k datu události zařazeno do uvedené kategorie (lze zadat i vypočítávanou kategorii) – je-li takové nalezeno, potom je spojení v události předplněno jeho identifikací
  6. v závislosti na nastavení atributu „použít impl.“ se předplní spojení uvedené jako implicitní pro daného adresáta. Pokud nemá adresát uveden implicitní spojení, nepředplní se nic.

Poznámka:

Pokud se uplatní kombinace definice „subjekt=’-’” a “použít impl.=Ne, tak se žádné číslo spojení adresáta nepředplní, tj. uživatel je nucen určit spojení adresáta ručně.

Příklad kódu:

RETURN tool.sql_dotaz([select min(adspoj.ad11cisspo) from %%%.adspoj,adadsat where adspoj.ad01id=?_p1 and adadsat.ad01id=adspoj.ad01id and adspoj.ad02cisadr=adadsat.ad02cisads],_ad01id)

Předplní nejnižší číslo spojení, které obsahuje adresu uvedenou u adresáta na záložce 'Obchodní rejstřík' (nepřehlédněte část SQL dotazu adspoj.AD02CISADR=adadsat.AD02CISADS)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 09.10.2007


Pojem - Spojení importů-exportů

Spojení importů-exportů definuje uložení zdrojových dat pro import/export/update dat. Při jeho definici se vstupují následující atributy:

¨ identifikace a název spojení

¨ druh spojení – ODBC, XBASE (uložení databáze v souboru)

¨ spojení OS – v případě druhu spojení XBASE se zde uvádí cesta na adresář, kde je uložen daný soubor. V případě druhu spojení ODBC se zde uvádí název ODBC spojení.

¨ uživatel, heslo – v případě druhu spojení XBASE se neuvádí, v případě druhu spojení ODBC se zde uvádí jméno a heslo k dané databázi ODBC.

¨ k. stránka – kódová stránka znakové sady, která slouží pro import typu TEXT. Protože každý textový soubor může být vytvořen v jiné znakové sadě, je nutno pomocí této kódové stránky importovaný soubor sladit se zdrojovým, aby import textového souboru nenatáhl tzv. „paznaky“. Znakové sady jsou dané, např. pro aplikaci DOS platí, že znaková sada Latin2 má kód 852, Kamenických mají kód 895, pro aplikaci Windows platí, že Windows evropské mají kód 1252, Windows české mají kód 1250 apod.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Spouštěné aplikace

Tato činnost umožňuje definovat způsob vyvolávání externích programů (aplikací), které se pak používají při definování předloh dokumentů. V následujícím textu si vysvětlíme jednotlivé zadávané položky společně s konkrétním příkladem. Pro názornost budeme u každé položky v závorce uvádět hodnotu, jako kdybychom vytvářeli např. aplikaci Wordu:

¨ aplikace - identifikace spouštěného programu (WORD)

¨ název - název spouštěného programu (WORD)

¨ zabudované OLE - způsob volání pro aplikace Word/Excel (Word 7.0)

¨ typ spuštění a přípona - způsob volání + přípona zvolené aplikace (zabudované OLE + DOC). Příponu souboru lze nadefinovat až na 15 znaků, např. DOCX, XLSX, ISDOCX apod. Mimo jiné je tím uživateli umožněno vložit tažením myši do IS BM i dokumenty, které mají příponu delší než 3 znaky (DOC, XLS apod.). Jednotlivé způsoby volání jsou - Windows DDE, DOS, Windows OLE, zabudované OLE, Windows CALL, Windows podle přípony . Následující popis nám přiblíží vyplnění jednotlivých položek při různých způsobech volání:

______________________________________________________________

Pouze pro aplikace Windows volané způsobem zabudované OLE a Windows podle přípony:

¨ další údaje se uvádět nemusí, pro aplikace Windows volané způsobem "zabudované OLE" je naprosto dostačující určit způsob volání a příponu.

Pouze pro aplikace Windows volané způsobem DDE:

¨ zpráva DDE - zpráva DDE

¨ aplikace - aplikace DDE

¨ položka - položka DDE. Potřebné údaje pro tyto tři položky uživatel získá při použití Registračního souboru pro aplikace Windows (RegEdit), který je standardní součástí Windows.

Pouze pro aplikace Windows volané způsobem OLE:

¨ třída OLE - umožňuje definovat u dokumentu jinou než implicitní třídu OLE, která je uvedena v Asociaci daného typu souboru. Je uvedena v RegEdit.

Pouze pro aplikace DOS a aplikace Windows volané způsobem CALL:

¨ volání - volání programu - příkazový řádek. Pro spouštění aplikací pro DOS pod Windows je nejlépe vytvořit si pro každou aplikaci PIF soubor (viz dokumentace Windows) a jméno PIF souboru uvést do této položky. Druhým možným řešením je uvést přímo cestu k aplikaci.

Pouze pro aplikace Windows volané způsobem CALL:

¨ dle WIN.INI - volání programu dle definice aplikace v souboru WIN.INI v sekci EMBEDDING (použije se v případě nemožnosti spuštění aplikace dle zadání v atributu Volání)

______________________________________________________________

¨ parametry volání - způsob otevření aplikace a jejím umístění do okna:

- aktivní a normální velikost

- aktivní a minimalizovat

- aktivní a maximalizovat

- neaktivní a normální velikost

- neaktivní a minimalizován

¨ info o otevření – tento atribut určuje chování BM po otevření dokumentu. Může nabývat hodnot:

- Ano s potvrzením – po otevření dokumentu bude zároveň otevíráno okno, které uživatel pak musí uzavřít (klávesou ESC, tlačítkem OK nebo ikonou uzavření okna)

- Ano bez potvrzení - po otevření dokumentu bude zároveň otevíráno okno, které uživatel pak musí uzavřít (klávesou ESC, tlačítkem OK nebo ikonou uzavření okna) – v případě, že uživatel okno neuzavře, automaticky se po 5 vteřinách zavře samo

- Ne – po otevření dokumentu nebude zobrazeno žádné okno

Tento atribut je implicitně nastaven na hodnotu „Ano s potvrzením“. Tuto hodnotu je nutno ponechat pro aplikace, které neblokují jimi otevřené soubory. V jejich případě platí, že kdyby systém BM po otevření dokumentu zároveň nezastavil, tak potom by se BM soubor dokumentu bezprostředně zrušil a aplikace by nemohla prezentovat daný dokument. Těmito aplikacemi mohou být programy např. pro zobrazení obrázků, internet explorer (soubory s příponami HTM, XML, ...).

¨ prázdný - pokud soubor ještě neexistuje, vytvoří prázdný soubor

¨ čekej na ukončení - po předání dokumentu je zobrazeno hlášení, po jehož odklepnutí je dokument uložen. Slouží pro práci s dokumenty aplikací, které nedokáží systému sdělit, že s daným dokumentem pracují a systém tedy nemůže zjistit, kdy byl daný dokument uvolněn pro uložení (např. CorelDraw).

Do specifické skupiny dokumentů patří ty, které mají u své aplikace definovány akce (záložka Akce), tj. celý život dokumentu je řízen dle přidělených akcí, které mohou dokument automaticky zakládat, aktualizovat, poskytovat vybraným uživatelům apod. O výsledku akcí je veden a archivován protokol (záložka Protokol v činnosti Dokumenty). Mezi takového dokumenty patří i ty, kterými IS Bílý Motýl® komunikuje se státní správou (Evidenční list důchodového pojištění, Přihláška (odhláška) k nemocenskému pojištění, …), kde akce zajišťují vytvoření těchto dokumentů z dat při udržení integrity s předchozími dokumenty i s novými daty, dále akce zajišťují kompletní výměnu informací s IS státní správy včetně opravných chodů a samozřejmě jsou i tyto dokumenty trvale k dispozici kompetentním uživatelům.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 29.10.2009


Pojem - Spouštět

Tento atribut uzlu v rámci daného procesu umožňuje uživateli vybrat si některou z variant, jakým způsobem je možno nastavit chování cílového uzlu, pokud je uveden do stavu připravena, resp. je v zásobníku operací. Varianty spouštění jsou:

¨ automaticky – po ukončení zdrojových uzlů se automaticky spustí cílový uzel (přesněji: je-li cílový uzel uveden do stavu připravena nebo je v zásobníku operací, tak tento atribut definuje, že se automaticky spustí, pokud uživatel k němu má příslušná práva). V tomto případě je nutné si uvědomit funkčnost druhu vazby uvedeného mezi cílovým a zdrojovým uzlem v diagramu procesu.

¨ na pozadí – po ukončení zdrojových uzlů (přesněji: je-li cílový uzel uveden do stavu připravena nebo je v zásobníku operací) běží cílový uzel na pozadí, tj. uživateli se pouze zobrazuje informativní hláška o identifikaci a názvu operace, která běží na pozadí. U operací, které běží na pozadí platí, že i uživatel, který k operaci nemá právo zápisu, dostává v tomto případě přechodné právo. Na pozadí lze též spustit označené operace dávkově i na základě rozhodnutí uživatele, třebaže to není v diagramu tak definováno (v činnosti Operace pod menu Volby činnost „spustit označené operace“). Po ukončení operace, která běží na pozadí by neměla následovat vazba typu OR nebo XOR, protože systém v tomto případě nedokáže automaticky aktivovat výběrové okno. Pak je nutno spustit znovu operaci, která proběhla na pozadí a teprve po stisku ESC se uživateli zobrazí výběrové okno, kde si vybere, kterou operací chce v procesu pokračovat. Z toho vyplývá, že pokud má operace nastaveno spouštět „na pozadí“, není vhodné používat po skončení této operace vazeb OR nebo XOR.

¨ nespouštět – cílový uzel se po ukončení zdrojových uzlů (přesněji: je-li cílový uzel uveden do stavu připravena nebo je v zásobníku operací) automaticky (ani na pozadí) nespustí a uživatel si jej pak musí spustit ručně (z diagramu, ze stromu hlavního procesu, z připravené nabídky operací apod.). Tato varianta má význam u procesů s čekáním na odezvu (např. na dodávku po objednávce).

¨ nespouštět a zobrazit průběh operací – cílový uzel se po ukončení zdrojových uzlů (přesněji: je-li cílový uzel uveden do stavu připravena nebo je v zásobníku operací) automaticky (ani na pozadí) nespustí, ale uživateli se v okně zobrazí tabulka „průběh operací“ (zobrazen je seznam všech připravených uzlů, tj. včetně zásobníku operací, daného dne všemi uživateli bez ohledu na to, jak jsou nastavena přístupová práva k jednotlivým operacím), kde má uživatel možnost si zvolit operaci, kterou chce spustit (tato varianta je mírně nepřehledná, protože se zobrazuje přehled všech operací a uživatel si tu svoji operaci, která je ve stavu připravena musí v tomto přehledu vyhledat). Tato varianta klade tedy vysokou náročnost na uživatele, tudíž je možná lepší ji v praxi příliš nevyužívat a modelovat tuto situaci dotazem přes kód po ukončení operace.

Možnosti „spouštět“ se nastavují ve vlastnostech jednotlivých uzlů v diagramu procesu, implicitní hodnoty se nastavují u druhu operace a druhu procesu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Správce

Správce je specifický uživatel informačního systému, který je definován programovým kódem a ne uživatelsky a jako takový má i svá vlastní specifická práva.

V případě, že to vyžaduje praxe, je možno přiřadit vybranému uživateli stejná práva jako správci (činnost Uživatelé programu - atribut Práva správce). Z tohoto pohledu je po logické stránce správce fakticky "skrytá" skupina uživatelů.

Stejně jako ostatní uživatele je možno i správce zařadit do vybrané skupiny uživatelů, a tím řídit jeho přístupová práva k věcem s přístupem.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Spravovaný majetek

Komponenta „spravovaný majetek“ je určena pro evidenci a správu spravovaného majetku, obvykle i inventarizovaného, různého druhu. Na každé kartě spravovaného majetku je evidován právě jeho jeden výskyt jednoznačně identifikovatelný v IS BM i v reálném světě, tj. jedná se o druhovou evidenci, kde je významnějším údajem stav oproti množství. Komponenta eviduje ve svých událostech též veškeré změny stavu, odpovědnosti i alokace, ale také případné servisní zásahy apod.

Mezi významné tabulky komponenty kromě standardizovaných patří cizojazyčné názvy spravovaného majetku. Artikl spravovaného majetku je sdílen s komponentou rezervace majetku.

Z pohledu této komponenty lze za spravovaný majetek prohlásit vše, co je potřebné mít pod kontrolou a co je tedy nutné inventarizovat. Mezi základní nástroje této evidence patří:

¨ přiřazení odpovědnosti konkrétní osoby (zaměstnance, obecně adresáta) k dané kartě majetku po určité období,

¨ přiřazení karty k určitému umístění (kancelář, dílna, budova, …), ve které se provádí inventarizace,

¨ sledování nákladů (cen) souvisejících s údržbou či zlepšením daného předmětu,

¨ sledování úkonů souvisejících se správou daného předmětu (např. výměna pneumatik na autě, vymalování kanceláře apod.).

Po stránce technické je možné k inventarizaci využít čárového kódu či jiné metody automatické identifikace. Samozřejmě lze také tisknout inventurní seznamy dle zodpovědných osob, umístění apod. Pod menu Spravovaný majetek má uživatel k dispozici následující činnosti:

¨ změny spravovaného majetku

¨ aktuální hodnoty sprav. majetku

¨ rezervace majetku

¨ spravovaný majetek

¨ umístění spravovaného majetku

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 01.11.2012


Pojem - Spustit činnost

Pod pojmem spustit činnost rozumíme prvotní spuštění činnosti, tzn. dvojklikem levého tlačítka myši z hlavního menu, zvolením příslušné činnosti z menu Volby apod. Na rozdíl od pojmu aktivovat, který umožňuje uvádět do aktivního stavu již spuštěné činnosti, znamená pojem spustit činnost její skutečné prvotní spuštění.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Spuštění archivace

V této činnosti jsou ke spuštění k dispozici jednotlivé nadefinované archivace, které ve své definici mají na záložce Skupiny archivace v atributu nabízet uvedeno Ano a zároveň jsou nadefinovány s druhem dokumentu, ke kterému má daný uživatel právo zápis. Jednotlivé archivace se mohou aktivovat z této činnosti (tzn. z hlavního menu) a nebo přímo z činnosti Popis archivací z menu Volby (stiskem klávesy F9).

Po aktivaci dané archivace následuje systémový dotaz, zda uživatel chce opravdu archivovat (Ano/Ne) s informacemi o počtu archivovaných adresářů a souborů a jejich velikosti.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.10.2009


Pojem - SQL

SQL je standardizovaný dotazovací jazyk používaný pro práci s daty v relačních databázích. SQL je zkratka anglických slov Structured Query Language (strukturovaný dotazovací jazyk).

V 70. letech 20. století probíhal ve firmě IBM výzkum relačních databází. Bylo nutné vytvořit sadu příkazů pro ovládání těchto databází. Vznikl tak jazyk SEQUEL (Structured English Query Language). Cílem bylo vytvořit jazyk, ve kterém by se příkazy tvořily syntakticky co nejblíže přirozenému jazyku (angličtině). K vývoji jazyka se přidaly další firmy. V r. 1979 uvedla na trh firma Relational Software, Inc. (dnešní Oracle Corporation) svoji relační databázovou platformu Oracle Database. IBM uvedla v roce Relační databáze byly stále významnější, a bylo nutné jejich jazyk standardizovat. Americký institut ANSI původně chtěl vydat jako standard zcela nový jazyk RDL. SQL se však prosadil jako de facto standard a ANSI založil nový standard na tomto jazyku. Tento standard bývá označován jako SQL-86 podle roku, kdy byl přijat. V dalších letech se ukázalo, že SQL-86 obsahuje některé nedostatky a naopak v něm nejsou obsaženy některé důležité prvky týkající se hlavně integrity databáze. V roce 1992 byl proto přijat nový standard SQL-92 (někdy se uvádí jen SQL2). Zatím nejnovějším standardem je SQL3 (SQL-99), který reaguje na potřeby nejmodernějších databází s objektovými prvky. Standardy podporuje prakticky každá relační databáze, ale obvykle nejsou implementovány vždy všechny požadavky normy. A naopak, každá z nich obsahuje prvky a konstrukce, které nejsou ve standardech obsaženy. Přenositelnost SQL dotazů mezi jednotlivými databázemi je proto omezená.

Poznámka k jazyku SQL:

Historie jazyka SQL spadá do 70. a 80. let. První standard byl přijat v roce 1986 (označován jako SQL86). Časem se však projevily některé nedostatky. Opravená verze je z roku 1992 a je označována jako SQL92. Ten je v oblasti relačních databází standardem dodnes. Jazyk v sobě zahrnuje nástroje pro tvorbu databází (tabulek) a dále nástroje na manipulaci s daty (vkládání dat, aktualizace, mazání a vyhledávání informací).

SQL patří mezi tzv. deklarativní programovací jazyky, což v praxi znamená, že kód jazyka SQL nepíšeme v žádném samostatném programu (jako by tomu bylo např. u jazyka C nebo Pascal), ale vkládáme jej do jiného programovacího jazyka, který je již procedurální. Se samotným jazykem SQL můžeme pracovat pouze v případě, že se terminálem připojíme na SQL server a na příkazový řádek bychom zadávali přímo příkazy jazyka SQL.

SQL se skládá z několika částí. Některé části jsou určeny pro administrátory a návrháře databázových systémů, jiné pak pro koncové uživatele a programátory. První částí jazyka SQL je jazyk DDL - Data Definition Language. Jedná se o jazyk pro vytváření databázových schémat a katalogů. Způsob ukládání tabulek definuje jazyk SDL - Storage Definition Language. Třetí částí pro návrháře a správce je jazykVDL - View Definition Language, určující vytváření pohledů (pohled si lze představit jako virtuální tabulku složenou z různých jiných tabulek). Poslední částí, je jazyk DML - Data Manipulation Language, který obsahuje základní příkazy INSERT, UPDATE, DELETE a nejpoužívanější příkaz SELECT. S jazykem DML pracují nejvíce koncoví uživatelé a programátoři databázových aplikací.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 25.11.2014


Pojem - Stáj (umístění)

Identifikace umístění zvířete. Je fakticky reprezentována chovatelem (výkrmcem) nezávisle na tom, kde si zvíře chovatel fyzicky umístí.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.10.2007


Pojem - Statická podmínka

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Statistická hodnota

Je-li daný druh hodnoty definován jako statistický (tzn. statistika – ANO), pak dochází k výpočtu statistických hodnot. Statistické hodnoty jsou k dispozici v činnosti Informační centrum – Statistika – Statistické hodnoty.

Hodnotou se zde rozumí čtveřice agregovaných údajů daného druhu (počáteční stav, příjem, výdej, konečný stav) dle data a selektorů. Aktualizace se provádí dle údajů v událostech daného druhu operace na základě definic u druhu (statistické) hodnoty. Pokud zde není zatržen příznak „den do statistické hodnoty“, data se zde zobrazují s datem prvního dne v daném měsíci.

Tyto hodnoty jsou mimo jiné významným elementem pro definici výkazu.

Příkladem statistické hodnoty může být např. sledování spotřeby a výnosů ve firmě.

V přehledu statistických hodnot jsou k dispozici společně hodnoty, které byly vypočteny z událostí různých komponent na základě algoritmů uvedených u druhu hodnoty.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Stav operace (uzlu)

Stav operace (uzlu) je základní vlastností fyzického uzlu pro jeho uplatnění z hlediska work-flow. Stav cílového uzlu může být definován:

¨ stavem zdrojových uzlů a druhem souvisejících vazeb

¨ kódem po ukončení jiných operací procesu

¨ vlastním obsahem a rozhodnutím uživatele o jeho ukončení

Uzel typu proces má jediný stav, uzel typu operace jeden nebo dva. Stav operace (uzlu) je patrný z diagramu, přehledu procesů, přehledu operací a může nabývat těchto hodnot:

¨ připravena – uvedení uzlu do stavu připravena může nastat dvojím způsobem. Připravené operace se mohou automaticky spouštět nebo mohou být uloženy do zásobníku operací. Zrušení stavu připravena (uzel operace) nastane ukončením operace. Zrušení stavu připravena (uzel proces) nastane zahájením procesu, tj. zahájením jeho první operace.

¨ zahájena – pokud se jedná o uzel typu operace, dostává se do stavu zahájena založením určité události (tzn. použitím volby „zapsat“ na operaci) a pokud se jedná o uzel typu proces, dostává se do stavu zahájen zahájením první operace v tomto uzlu. Zrušení stavu zahájena není uživatelskými nástroji možné.

¨ ukončena – operace je ukončena na základě rozhodnutí uživatele (volba „opravdu ukončit operaci“) nebo provedením operace na pozadí (viz. též ukončení uzlu, ukončení operace a ukončení procesu), uzel typu proces není nikdy ve stavu ukončen. Zrušení stavu ukončena u operace je možné vyvoláním funkce "Zrušit stav ukončena".

¨ předběžně ukončena - operace je ukončena předběžně, pokud má ve vlastnostech v diagramu procesu nastaveno „předběžné ukončení“.

¨ stav neuveden - uzel není uveden do stavu připravena ani není zahájen, tento stav je možný u cílových operací fyzických procesů. Stav neuveden (tzn. žádný stav) je i u procesu, který má svoji první operaci pouze ve stavu připravena – zahájena (tzn. jsou zapsány události, ale operace dosud není ukončena). Stav připraven tento proces dostane až ukončením této první operace.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Stav programu BM uživatele

Tato činnost je dostupná v činnosti „přehled přihlášených (SQL)“ (hlavní menu – Systém) pod menu Volby.

Činnost vyvolá formulář, ve kterém je periodicky (podle nastaveného parametru) zobrazován stav programu daného uživatele. Pro správnou funkčnost této činnosti jsou nutná tyto nastavení:

¨ vytvořit externí příkaz s PID=STATUS (nebo ho nainstalovat z návodů a balíčků)

¨ nastavit parametr programu BM SpySleepInterval

Interval periodického čtení je dán nastavením programu BM:

¨ Preferencess – SpySleepInterval – ten určuje periodu ve vteřinách v situaci, kdy není žádný požadavek na sejmutí obrazovky (resp. zjištění stavu)

¨ Preferencess – SpyRunInterval – ten určuje periodu ve vteřinách, na kterou se změní interval čtení záznamu v tabulce BWCONNEQ po dobu trvání požadavku na sejmutí obrazovky (resp. zjištění stavu)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 26.07.2007


Pojem - Storno

Je jedním z nástrojů opravy dat fyzických procesů, který opravu téměř plně dokumentuje i autorizuje. Ke stornovanému procesu storno vždy vytvoří proces stornující na stejné číselné řadě a ve stejné struktuře operací jako má stornovaný proces. Stornovaný proces lze poznat:

¨ v přehledu procesů je vedle názvu procesu uveden příznak „stornovaný“

¨ v diagramu procesu je vedle názvu procesu v závorce uvedeno „stornovaný“

¨ ve stromu hlavního procesu má tento proces před svou identifikací červený znak a v závorce uvedeno velké písmeno S – (S)

Diagram stornovaného procesu lze modifikovat, což je možno považovat za chybu IS, z hlediska udržení korektnosti dat toto není vhodné, tzn. nedoporučujeme uživateli korigovat diagram stornovaného procesu.

Storno stornovaného (stornujícího) procesu není možné.

Stornující proces lze poznat:

¨ v přehledu procesů je vedle názvu procesu uveden příznak „stornující“

¨ v diagramu procesu je vedle názvu procesu v závorce uvedeno „stornující“

¨ ve stromu hlavního procesu má tento proces před svou identifikací červený znak a v závorce uvedeno malé písmeno S – (s)

Rovněž diagram stornujícího procesu lze modifikovat, což je možno považovat za chybu IS, z hlediska udržení korektnosti dat toto není vhodné, tzn. nedoporučujeme uživateli korigovat diagram stornujícího procesu.

Ke stornovaným ukončeným operacím storno vytvoří stornující operace s inverzními[1] (tj. opačnými) událostmi a neukončené operace stornovaného procesu zruší. Operace komponent pošta, vývěska a zprávy ve stornovaném procesu ruší vždy (na jejich stavu nezáleží), k vytvoření inverzních operací dochází pouze v případě, že mají nastaveno zrcadlové storno (činnost druhy operací – záložka Další).

Storno procesu se provádí v činnosti Procesy a operace – Procesy, kde si uživatel daný proces vyhledá, z menu Volby nebo ze stromu hlavního procesu po stisku pravého tlačítka myši. U storna je důležité vědět, že vybraný proces je nutno začít stornovat od jednotlivých podprocesů. Pokud by uživatel nevystornoval nejprve podřízené procesy (podprocesy), systém podává informativní hlášení typu: „Proces není možné stornovat, protože obsahuje odkazy na nestornované procesy“.

Např. máme-li proces vystavená faktura (č.1), který obsahuje operace dodání a procesy DPH (č.2) a plateb (č.3), je nutno nejprve vystornovat proces plateb (č.3), pak proces DPH (č.2) a nakonec vlastní proces vystavené faktury (č.1), přičemž ke všem procesům bude vytvořen proces stornující a k operaci dodání bude vytvořena inverzní operace.

Stejně se systém chová, pokud uživatel stornuje proces, kde je použita dynamická vazba (např. ZSP - platby). I tento proces se naprosto v pořádku vystornuje, přičemž dynamická vazba je tímto zrušena (tzn. dojde k odpárování platby apod.). V případě, že se stornuje proces, kde má druh operace nastaven určité parametry operace komponenty, tak i v tomto případě se storno chová naprosto korektně (vrátí stav).

Např. pokud máme proces, kde po objednávce následuje dodací list a jeho ukončením dostávají události na objednávce stav „vykrytá“, tak po stornu tohoto dodacího listu se události objednávky vrátí zpět do stavu „nevykrytá“.

Pokud má uživatel vyhledán proces, který potřebuje stornovat, aktivuje z menu Volby činnost Storno procesu. Jako další se zobrazuje následující:

¨ informativní tabulka, jaký proces bude stornován, včetně informace, která operace bude zrušena, a která bude mít vytvořenu inverzní operaci. Uživatel má volbu OK – Storno. Po potvrzení volby OK následuje:

¨ zápis stornujícího procesu – popis procesu, komentář ke stornu a atribut „vzniknou události operací s datem“. Uživatel zvolí možnost Zapsat, zobrazí se mu ještě jedno upozorňující hlášení typu „Opravdu stornovat proces ….“?. Po potvrzení volby Ano je daný proces vystornován (získává příznak stornovaný) a je vytvořen nový proces stornující. U stornované či stornující operace není možno zrušit stav ukončena.

Při stornování jednotlivých fyzických procesů jsou stornující procesy (tzn. jejich operace a události) zapsány s aktuálním systémovým datem (u storna není možno využít atribut „aktuální datum uživatele“ z parametrů uživatele). Stornující procesy nelze zapsat s datem původních událostí. Pokud by uživatel potřeboval stornovat proces s jiným datem než aktuálním systémovým, využije možnosti, které mu nabízí atribut „vzniknou události operací s datem“, který při vlastním provádění storna zaškrtne, tím se mu zpřístupní políčko pro zadání nového data a události stornujících operací jsou pak zapsány s tímto datem. Jediný problém může nastat v případě, kdyby uživatel zadal datum, které spadá do uzavřeného období komponenty, jejíž operace je součástí stornovaného procesu, pak systém včas (než cokoliv zapíše) hlásí: „Operaci … (dané číslo) není možné stornovat, protože by vznikl zápis do neotevřeného období komponenty“. Tuto možnost se změnou data storna by měl využívat pouze zkušený uživatel a ještě i s vědomím účetní, protože může dojít k „rozhození“ invetury k datu (tj. operativní evidence versus účetnictví). Možnost využívat tuto změnu datumu lze potlačit pomocí parametru „Storno_k_datu=0“, který potlačuje možnost vyplnit toto datum (hlavní menu – Systém – Nastavení programu BM – sekce Procesy – parametr Storno_k_datu).

V případě storna procesu založeného procesním importem se tento stále chová jako již importovaný. Pokud jej chceme znovu importovat, je nutno pozměnit definici jednoznačné identifikace procesního importu.

Stornování procesu je vázáno na přístupová práva, která se řídí následujícími pravidly:

¨ uživatel, který nemá právo k založení druhu procesu, nemůže proces tohoto druhu stornovat

¨ uživatel, který nemá právo k činnosti „storno procesu“ vyvolávané z formuláře „procesy“, nemůže provádět zrušení stavu ukončena žádné operace (z formuláře „vlastnosti operace), ani mu není umožněno stornovat proces ve „stromu hlavního procesu“

¨ uživatel, který nemá právo k činnosti „diagram procesu“ vyvolávané z formuláře „procesy“, nemá dostupnou možnost vyvolat diagram procesu z formulářů událostí operací komponent ani ze stromu hlavního procesu

¨ uživatel, který nemá právo k činnosti „strom hlavního procesu“ vyvolávané z formuláře „procesy“, nemá dostupnou možnost vyvolat strom hlavního procesu z formulářů událostí operací komponent

[1] Opačné znaménko (u těch atributů, které jsou použitelné v algoritmu pro výpočet hodnot)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 01.11.2012


Pojem - Stránka informačního panelu

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 13.02.2009


Pojem - Strom adresáta

Jedná se o činnost, která uživateli umožňuje sestavit si informace o adresátovi přehledně ve stromovém vyjádření. Tuto činnost má uživatel k dispozici v hlavním menu v činnosti adresář pod menu Volby nebo po stisku klávesy F5. Dále ji má dostupnou na každém labelu „adresát“ (tzn. po stisku pravého tlačítka myši na tučně zvýrazněném atributu adresář).

Po aktivaci této činnosti se uživateli otevře nové okno s činností strom adresáta. Uživateli se zobrazuje název adresáta a pod ním jsou navěšeny jednotlivé adresy adresáta (stiskem znaménka + se adresa rozbalí). V dolní části okna této činnosti má uživatel ještě k dispozici menu „vývěska a dokumenty“. Po kliknutí myši na tomto menu se uživateli zpřístupní znaménko + a po jeho rozbalení má k dispozici události vývěsky (dvojklikem na názvu se menu rozbalí ihned), které byly vytvořeny s tímto adresátem a dokumenty, které se týkají tohoto adresáta.

Po stisku pravého tlačítka myši kdekoliv v prostoru okna této činnosti má uživatel k dispozici tyto možnosti:

¨ obnovit – při jakékoliv změně v adresáři se touto činností aktualizuje strom adresáta

¨ následníci – vývěska – vyvolá se okno činnosti události vývěsky, které jsou k dané události ve vztahu následník (tzn. syn)

¨ následníci – dokumenty – vyvolá se okno činnosti dokumenty, které jsou k dané události připojeny pomocí objektových vazeb (tzn. přes Ctrl D)

¨ spojení adresáta – zobrazí se okno činnosti s přehledem nadefinovaných spojení adresáta

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Strom hlavního procesu

Strom hlavního procesu je další ze způsobů zobrazení rozpracovanosti procesu. Diagram procesu poskytuje uživateli grafické zobrazení, strom hlavního procesu je jakési schéma struktury fyzického procesu. Strom hlavního procesu zobrazuje všechny uzly i několika hlavních procesů od uzlu, který je pouze zdrojový. Uživatelsky změnit zobrazení a ovládání hlavního menu lze pomocí činnosti „nastavení stromu“. Tuto činnost uživatel aktivuje po stisku pravého tlačítka myši na názvu činností ve stromu hlavního procesu nebo kdekoliv ve volném prostoru stromu hlavního procesu.

Strom hlavního procesu je možno aktivovat po stisku tlačítka F6 nebo volbou příslušné činnosti z menu Volby. Zobrazuje všechny uzly, přičemž u každého uzlu je díky značce před názvem částečně viditelný i jeho stav (červená barva – zatím se s operací nepracovalo, žlutá barva - operace připravena, zelená barva – připravena a zahájena, křížek - operace ukončena). Každý uzel ve stromu procesu má po stisku pravého tlačítka myši dostupné své vlastnosti. Tyto vlastnosti jsou odlišné na základě toho, zda se jedná o uzel typu operace nebo o uzel typu proces.

Uživatel, který nemá právo k činnosti „strom hlavního procesu“ vyvolávané z formuláře „procesy“, nemá dostupnou možnost vyvolat strom hlavního procesu z formulářů událostí operací komponent.

Na záložce Další v činnosti „Druhy operací“ je možno nastavit, které uzly (tj. operace) se budou ve stromu hlavního procesu zobrazovat. Ve většině případů bude zřejmě nastaveno Ano, volba Ne se typicky použije pro druhy operací, které se definují v diagramu procesu pouze pro umožnění odblokování operace.

U každého uzlu ve stromu hlavního procesu se zobrazuje informace, kdo operaci zahájil a ukončil. Může nabývat stavu:

¨ operace byla zahájena a nebyla dosud ukončena (tvar: jméno uživatele, datum a čas zahájení)

¨ operace byla zahájena a ukončena stejným uživatelem v jednom dni (tvar: jméno uživatele, datum a čas zahájení – čas ukončení)

¨ operace byla zahájena ukončena stejným uživatelem v jiném dni (tvar: jméno uživatele, datum a čas zahájení, datum a čas ukončení)

¨ operace byla zahájena a ukončena jiným uživatelem v jednom dni (tvar: jméno uživatele, datum a čas zahájení, čas ukončení, jméno uživatele)

¨ operace byla zahájena a ukončena jiným uživatelem v jiném dni (tvar: jméno uživatele, datum a čas zahájení, datum a čas ukončení, jméno uživatele)

Pod uzlem (operace, proces) stromu hlavního procesu je možno vidět vše co je s uzlem spojeno:

¨ napojené dokumenty k procesu nebo operaci. Pro uzly ve stromu hlavního procesu se uplatňuje totožná funkčnost jako ve formuláři „Spojené dokumenty“ (tj. mj. stejné menu po pravém kliku klávesu myši, možnost připojovat navazující dokumenty, zobrazení zařazení dokumentu do kategorie jako složky stromu, apod.). Při přenášením souboru tažením myší do stromu hlavního procesu je možné dokument připojit také k jinému objektu BM, než jsou objekty procesů resp. operací.

¨ zprávy - pod uzlem operace nebo procesu má uživatel možnost vidět zprávy, které byly o operaci odeslány (pravý klik na operaci „odeslat zprávu o operaci“). Jednotliví aktuální uživatelé vidí pouze ty zprávy, jichž jsou sami autory nebo příjemci. Po pravém kliku myši přímo na řádku zprávy ve stromu je možno vyvolat činnost „zobrazit zprávu“. Po její aktivaci se spustí formulář s danou událostí zprávy. Zobrazované zprávy však můžou být vytvořeny už přímo při vytváření událostí operace (pod menu Volby na událostech komponent je možnost „odeslat zprávu o operaci“). Operace, ke kterým je současně vytvořena zpráva je pak možné vyhledávat ve formuláři operací se zaškrtnutou možností „zobrazit=spojené se zprávami“.

¨ volné karty – zobrazují se volné karty definované u odpovídajících druhů procesů a operací. Na uzlu představujícím volnou kartu je možné dvojklikem spustit formulář volné karty, ovšem pouze na prohlížení, udané hodnoty není možno nijak měnit.

Pokud se jedná o uzel typu operace, jsou po stisku pravého tlačítka myši dostupné tyto možnosti:

¨ obnovit - po stisku tohoto tlačítka se aktualizují (obnoví) změny provedené v mezičase (stejné jako činnost „znovu načíst")

¨ navazující dokument – možnost pomocí volby (Nový dokument, Načíst dokument) připojit dokument k danému objektu

¨ diagram procesu - zobrazí se diagram daného hlavního procesu (stejné jako klávesa F7 nebo příslušná činnost pod menu Volby)

¨ proces – aktivuje se výběrová záložka činnosti „procesy“

¨ stornovat proces - umožňuje stornovat proces, jehož součástí daná operace je. Avšak i zde platí zásada, že procesy je nutno stornovat postupně - od posledního po ten první.

¨ spustit operaci - aktivuje se daný uzel typu operace. Pokud ještě nebyla tato operace spuštěna, je tímto spuštěna poprvé, pokud již byla zahájena, uživatel má možnost si ji po aktivaci této možnosti prohlédnout (stejné jako klávesa F9 nebo příslušná činnost pod menu Volby)

¨ odeslat zprávu o operaci - umožňuje odeslat zprávu k dané operaci. Je možno vybrat jednoho nebo více příjemců zprávy, připsat krátký text a po stisku OK je zpráva odeslána. Tato zpráva se pak zobrazuje ve stromu hlavního procesu napojená pod danou operací. Dostupná je autorovi zprávy a jejím příjemcům. Zprávu k operaci je možno vytvořit v jednotlivých událostech komponent, kde pod menu Volby má uživatel možnost "Odeslat zprávu o operaci". V případě, že uživatel umístí ve stromu kurzor na řádek s danou zprávou, má po pravém tlačítku myši k dispozici volbu "zobrazit zprávu".

¨ události operace - výběrem této možnosti se zobrazí krátký popis událostí dané operace. Na takto zobrazených událostech je možno po stisku pravého tlačítka zvolit: obnovit, diagram procesu, spustit operaci, míra plnění - předchůdci a míra plnění - následníci (zobrazují se události různých komponent, z kterých byla událost odvozena, resp. které vyvolala, a na nich je zase možné vyvolat předchůdce a následníky podle míry plnění), vlastnosti operace.

¨ vlastnosti operace - uživatel má k dispozici přehled nejaktuálnějších informací o operaci - název, druh, její stav apod.

Pokud se jedná o uzel typu proces, jsou po stisku pravého tlačítka myši dostupné tyto možnosti:

¨ obnovit - po stisku tohoto tlačítka se aktualizují (obnoví) změny provedené v mezičase (stejné jako činnost „znovu načíst")

¨ navazující dokument – možnost pomocí volby (Nový dokument, Načíst dokument) připojit dokument k danému objektu

¨ diagram procesu - zobrazí se diagram daného hlavního procesu (stejné jako klávesa F7 nebo příslušná činnost pod menu Volby)

¨ proces - aktivuje se výběrová záložka činnosti „procesy“

¨ stornovat proces

¨ kopírovat odkaz na proces - ve stromu hlavního procesu je možno u položky typu proces po stisku pravé myši aktivovat činnosti „kopírovat odkaz na proces" (obdoba Windows příkazu Ctrl+C) a tento odkaz je možno k jinému procesu přiřadit (obdoba Windows příkazu Ctrl+V) opět po stisku pravého tlačítka myši na položce procesu, ke kterému chceme zkopírovaný odkaz přiřadit, a to volbou „napojit proces", tzn. že k diagramu stávajícího procesu se přiřadí i tento napojený proces.

¨ osamostatnit proces - tato možnost vyřadí vybraný proces z daného nadřízeného procesu. Tato možnost se zobrazuje pouze u podřízených procesů.

Uzly stromu hlavního procesu, které jsou poduzly uzlu představujícího proces v hlavním procesu (ikona dopravní značky zákaz vjezdu do jednosměrné ulice nebo stop), jsou ve formuláři stromu doplňovány dynamicky v okamžiku rozbalení uzlu představujícího proces. Tím je umožněna dostatečně rychlá odezva při zobrazování stromů rozsáhlých procesů.

Při nastavení vlastnosti BM StromHP-dynamicke rozbalovani=0 je strom hlavního procesu kompletně naplněn při startu formuláře stromu (ovšem za cenu pomalejší odezvy jeho zobrazení).

Ve stromech zobrazovaných ve formulářích spojené dokumenty, strom hlavního procesu a obdobných stromech formuláře okno úloh je možno implementačně doplnit definovatelné funkce pro menu, která jsou vyvolávána po stisku pravého tlačítka myši na uzlu představujícím objekt BM. Toto implementační doplnění je možno nadefinovat v činnosti „doplňující položky menu objektů“.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.04.2009


Pojem - Strom pracovníka

Tuto činnost uživatel aktivuje nad Kartou pracovníka (pod menu Volby). Jedná se o stromové zobrazení údajů, které jsou v IS BM u každého pracovníka k dispozici (např. údaje z karty pracovníka, údaje o zdravotní pojišťovně, srážkách, půjčkách, exekucích apod.). Po stisku pravého tlačítka myši v hlavičce stromu (tj. na jménu pracovníka) si uživatel aktivuje činnost „nastavení stromu“, kdy si může mírně změnit zobrazení a vybrat způsob ovládání daného stromu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 03.06.2008


Pojem - Strom vývěsky

Tato činnost umožňuje uživateli zobrazit si události vývěsky (včetně vytvořených objektových vazeb) v přehledném stromovém vyjádření. Činnost strom vývěsky má uživatel k dispozici v hlavním menu v činnosti Marketing – Kompletní vývěska po stisku klávesy F5 nebo pod menu Volby.

Po aktivaci této činnosti se uživateli zobrazí samostatné okno, jehož velikost si může libovolně upravit (metoda „táhni a drž“). Zobrazují se události vytvořené k dané události jako předchůdci a zároveň se zobrazují události vytvořené k dané události jako následníci. Dvojklikem na každé události si uživatel danou událost spustí v samostatném okně. Na každé události je možno po stisku pravého tlačítka myši vyvolat tyto možnosti:

¨ obnovit – stejné jako znovu načíst. V případě změny některé události se tímto načte strom vývěsky v obnovené verzi

¨ editovat událost – v novém okně událostí vývěsky se zobrazí daná událost a uživatel ji může opravit

¨ následníci – vývěska – uživateli se v novém okně zobrazí události, které jsou k dané události pomocí objektových vazeb vytvořeny ve vztahu předchůdce – následník (neboli otec – syn)

¨ následníci – dokumenty – v případě, že je k události vývěsky připojen dokument (přes spojené dokumenty), zobrazí se v samostatném okně

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 31.03.2010


Pojem - Substituce DPH

Nastavení uvedená na této záložce se uplatňují při vstupu událostí obchodu. Při vstupu nové události způsobí přeplnění jiného TZP než je uvedeno u artiklu , a to podle TZP a klasifikace uvedené u artiklu obchodu příznaku plátce DPH a typu místa plnění uvedeného u vstupovaného adresáta.

V substituci se uvádí:

¨ identifikace TZP

¨ typ místa

¨ odpočet/nápočet

¨ příznak plátce DPH adresáta

¨ klasifikace artiklu obchodu

¨ datum platnosti od

¨ datum platnosti do

Př.:
- je vstupována událost obchodu - prodej pro adresáta s typem místa EU, který je plátcem DPH a artiklem, který má u sebe uvedenu klasifikací Z (zboží) a typ zdanitelného plnění ZA1
- pro TZP ZA1 je definovaná substituce (OSV,EU,Nápočet,Plátce DPH=Ano,Z)
- potom na události obchodu bude předplněn TZP OSV

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 09.10.2007


Pojem - Superhrubá mzda

Superhrubá mzda je rozšířený základ daně o sociální a zdravotní pojistné placené zaměstnancem i zaměstnavatelem (jedná se vlastně o hrubou mzdu zaměstnance + sociální a zdravotní pojištění placené zaměstnavatelem za zaměstnance, jde tedy o celkové náklady zaměstnavatele na zaměstnance).

Superhrubá mzda je tedy hrubá + odvod SP a ZP za firmu (bez odečtu SP zaměstnance a ZP zaměstnance). Odvod SP za firmu je 26% ze základu SP. Odvod ZP za firmu je 2/3 ze 13,5% ze základu ZP, tj. 9%.

Současný výpočet 2007

Příjem zdanitelný zálohově - součet jednotlivých příjmů, jejichž mzdová položka má v doplňujících údajích nastaveno Zdanitelný příjem - Ano

Základ zálohové daně – sníží se o odvod SP za zaměstnance a odvod ZP za zaměstnance. Základ daně se zaokrouhlí na celé Kč nahoru (v zákoně není uvedeno).

Daň zálohová ze základu dle daňové tabulky. Z toho se pak odečtou měsíční slevy na dani.

Výpočet nový 2008

Příjem zdanitelný zálohově - součet jednotlivých příjmů, jejichž mzdová položka má v doplňujících údajích nastaveno Zdanitelný příjem – Ano. Zákazníci si musí zkontrolovat toto zaškrtávátko. Superhrubá mzda jako příjem zdanitelný zálohově + odvod SP za firmu + odvod ZP za firmu. Daň zálohová ze základu dle daňové tabulky. Z toho se pak odečtou měsíční slevy na dani.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 29.02.2008


Pojem - Syntetický účet

V IS BM si účetní jednotky definují syntetické účty v souladu se směrnou účtovou osnovou tak, aby představovaly základní strukturu pro zachycení všech skutečností (na globální, resp. sumární úrovni), které jsou předmětem účetnictví; v rámci zvyklostí (s přihlédnutím k právním předpisům) se obvykle jedná o účty vyjádřené třímístným číslem; k syntetickým účtům se váže řada legislativních ujednání.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.09.2008


Pojem - Systémový certifikát

Pro potřeby automatizovaného podpisu elektronickou značkou (zejména dokladů, a to i vystavených na pozadí) lze ukládat v IS BM systémové certifikáty. Systémové certifikáty se definují ve formuláři Informační centrum – Typy a řady – Systémové certifikáty. Uvádí se:

¨ identifikace systémového certifikátu - 6 znaků

¨ název certifikátu

¨ druh certifikátu

¨ soubor certifikátu - jméno souboru na disku s příponou PFX (exportovaný privátní klíč)

¨ poznámka

Ke každému systémovému certifikátu je nutné uložit heslo, se kterým byl soubor certifikátu vytvořen (menu Volby – funkční klávesa F5). Toto heslo je bezpečně uloženo v databázi (zakryptované). Tato funkcionalita mimo jiné umožňuje nastavit v IS BM automatizované odesílání dokladů podepsaných elektronickou značkou.

Podepisování dokumentů probíhá interními rutinami BM.EXE, kterým je jedním z parametrů předána 'Identifikace systémového certifikátu'. V této chvíli je tímto způsobem vyřešeno podepisování dokumentů:

¨ PDF - Acrobat Reader - podepisování nástrojem PortableSigner (Open Source) http://portablesigner.sourceforge.net/

¨ XML - podle norem XML Signature Syntax and Processing (Second Edition) http://www.w3.org/TR/xmldsig-core/, XML Encryption Syntax and Processing http://www.w3.org/TR/xmlenc-core/ , Canonical XML http://www.w3.org/TR/xml-c14n, Exclusive XML Canonicalization http://www.w3.org/TR/xml-exc-c14n/ - podepisování nástrojem XML Security Library (Open Source)

¨ http://www.aleksey.com/xmlsec/index.html - tento způsob podepisování dokumentů se používá pro soubory ve formátu ISDOC = elektronická fakturace (nachází se ve fázi přípravy)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 02.11.2012


Pojem - Šablona

Šablona je nástroj, který umožňuje automatizaci vstupu událostí (resp. usnadnění tohoto vstupu). Usnadnění obvykle spočívá v tom, že na základě vstupu několika málo údajů (případně i pomocí importu dat nebo i programového kódu) IS vygeneruje celou řadu událostí. Pro definici okna pro zadání "mála" údajů uživatelem při použití šablony je k dispozici uživatelský design (menu Volby v definici šablony).

Šablony se ve většině případů definují v činnosti Informační centrum – Typy a řady – Komponenty[1] a zde po stisku klávesy F5 nebo vyvoláním příslušné činnosti z menu Volby. Uživateli se nabízí přehled a možnost definice šablony pro danou komponentu. Zobrazí se mu tedy přehled šablon dané komponenty.

U každé šablony se zadává:

¨ její název

¨ druh (k druhu šablony je možno nadefinovat přístupová práva)

¨ import (jsou-li data získána importem)

¨ způsob vstupu šablony, pokud je pro danou komponentu připraven nějaký vstup programovým kódem (např. kopie operace, kopie události apod.)

¨ hromadná oprava – umožňuje definovat hromadnou opravu aktuálně zobrazených záznamů. Je-li tento atribut nastaven na hodnotu "Ano", jedná se o šablonu, která nebude vkládat nové záznamy, ale opravovat existující záznamy vstoupenou nebo konstantní hodnotou v atributech události podle definice šablony. Typickým případem může být například změna adresáta ve všech událostech operace. Při změně hodnoty atributu záznamu nedochází k "vynulování" logicky souvisejících atributů a tím k jejich následnému přepočtu. Tuto vlastnost musí šablona respektovat, tzn. při přepisování atributu, který je svázán při zápisu klávesou F3 s jiným atributem (např. artikl a jeho selektor) je nutno při použití hromadné opravy v šabloně uvést obě tyto proměnné - artikl, který se bude vstupovat a zároveň selektor, ten však jako nulový, tzn. s pomlčkou. Při zápisu šablony (ikona disketa) se pak tento jakoby nulový selektor přepíše správnou hodnotou (tedy tou hodnotou, která je svázána s daným artiklem). Hromadnou opravu je možno provádět pouze v neukončených operacích.

¨ příznak, zda šablona je veřejná (tzn. přístupná i ostatním uživatelům) nebo zda šablona zůstane přístupná pouze pro toho uživatele, který ji definuje

Na záložce proměnné šablony se definují jednotlivé proměnné (podrobnější popis v helpu), které bude uživatel při aktivaci šablony vstupovat nebo budou vypočteny z již vstoupených proměnných. Tyto proměnné lze následně využít v definici pravidel šablony. U každé proměnné je nutné/možné určit typ, velikost, návěstí, naplnění (je-li uveden výpočet, uvádí se v sousedním poli výpočtový výraz), inicializaci proměnné, třídu u numerických proměnných a reakci na F2 (umožňuje "zažlutit" pole vstupované proměnné nabídkou číselníku, kterou zde poskytuje programový kód). U těchto proměnných je důležitým údajem i pořadí, které určuje v jakém pořadí budou při aktivaci šablony vstupovat.

Pokud má uživatel nadefinovánu hlavičku šablony a její proměnné, musí nadefinovat pravidla šablony (v menu Volby nebo po stisku klávesy F5), tj. jak má šablona předplnit atributy události. Vždy platí, že jedno pravidlo šablony předplní jednu událost. Ke každému pravidlu šablony je možno definovat podmínku zařazení řádku do výstupu šablony. Uvádí se logický výraz v syntaxi Foxpro, ve kterém je možné použít proměnné šablony uvedené v hranatých závorkách.

Pokud je šablona plněna importem, není nutno pravidla šablony definovat, neboť import údaje nastavené u šablony nebere v potaz, řídí se pouze svými nastaveními. Pokud se jedná o vstup šablony programovým kódem, tak rovněž platí, že jedno pravidlo šablony předplní jednu událost, přičemž každá jednotlivá položka se může vyskytovat v různých pravidlech (např. atribut částka může být v šabloně komponenty účetnictví v jednom pravidle na straně Má dáti a stejný atribut částka je v druhém pravidle na straně Dal). Pravidla šablony se definují podobně jako masky operace (pozor na "schované" pokračování seznamu atributů). U položek (atributů události), které chceme automatizovaně předplnit daným pravidlem šablony uživatel nastaví název proměnné, ty položky (atributy události), které nechce šablonou předplnit nechá prázdné a u těch, kde se má předplnit implicitní hodnota (konstanta), tuto hodnotu rovnou zapíše. Volba kopírovat se používá v případě, pokud je vstup šablony „kopie operace“ čili aby systém přesně věděl, které atributy ze zadané operace chce uživatel pomocí šablony kopírovat. U těchto atributů, které se mají zkopírovat z již vytvořené operace se zvolí právě možnost kopírovat.

Jako poslední zbývá definovat design vstupního formuláře (v menu Volby nebo po stisku klávesy F6), kde se pouze jednotlivé proměnné šablony s naplněním "vstup" rozmístí v okně tak, jak budou při aktivaci šablony zobrazeny v okně.

Šablona se aktivuje stiskem CTRL F3 v neukončené operaci nebo automaticky při spuštění operace v rámci procesu, v jehož diagramu je ve vlastnostech daného druhu operace uvedena jako šablona prvého vstupu. Pokud je definována šablona prvého vstupu ve vlastnostech uzlu, pro který je současně definována automatizace vstupu pomocí transformace, tak se šablona neuplatní.

Použití šablony lze chránit přístupovým právem přiřazeným k druhu šablony. Určité nároky na funkčnost šablony nelze řešit uživatelsky a tak je k dispozici několik programátorsky připravených vstupů šablony.

Příkladem použití šablony může být např. zápis operace do komponenty pošta. Jedná se o jeden dokument, který se posílá více adresátům. V tu chvíli obsluha zvolí správnou šablonu (ta má v hlavičce nastaven vstup adresář, což je autory připravený programový kód), vybere z adresáře příslušné adresáty, pak do šablony doplní zbývající údaje (jako kategorie pošty, cena zásilky apod.), šablonu potvrdí (stiskem OK) a ta následně přepíše události do pošty (událostí bude tolik, kolik bylo v šabloně vybráno adresátů z adresáře).

[1] Definovat šablonu lze rovněž i ve spuštěné operaci přímo při jejím spuštění po stisku Ctrl F3 na tlačítku „Definovat“.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 25.06.2008


Pojem - Šablona listů výkazů

Šablona listů výkazů definuje soubor se šablonou pro list MS Excel, která se uplatní při sestavení výkazu, a jeho adresář (např.: template\Statvy.xlt). Implicitní je programový adresář.

Na atributu „soubor šablony“ lze klávesou F2 vyvolat vstup, kterým se provede zápis kopie souboru šablony do databáze. Kopie obsahu souboru šablony je ukládána v databázi ve formátu ZIP a přitom se používá knihovna VFPCOMPRESSION.FLL, která je obvykle uložena v adresáři PRGS (při neexistenci knihovny VFPCOMPRESSION.FLL nejsou kopie souborů šablony ukládány). Kopie jednoho souboru se stejným názvem je v databázi uložena pouze jedenkrát a při změně názvu souboru je kopie souboru v databázi automaticky zrušena v případě, kdy se jedná o soubor, který není uveden jako příloha některé předlohy výstupu nebo jako soubor jiné šablony.

Ve formuláři se zobrazuje datum a čas kopie souboru, která je uložena v databázi. Při zápisu dat formuláře se porovnává tento datum a čas s datem a časem souboru, který uložen na disku a v případě, že se nerovnají (+- 2 vteřiny),

je nabídnuta možnost zápisu kopie obsahu souboru do databáze.

Při spuštění výkazu, je prováděna kontrola toho, zda všechny jeho šablony na disku existují a v případě, že neexistují jsou „vybaleny“ jejich kopie z databáze. Provádí se pouze kontrola existence souboru, vůbec se neporovnává datum a čas souboru (tj. nedochází k přepisu souboru na disku ani v případě, že je starší než jeho kopie v databázi).

Podmínkou pro tuto funkci je existence knihovny VFPCOMPRESSION.FLL, pokud není tato knihovna nainstalována, potom se při spuštění nebo opravě předlohy výstupu objeví hlášení „Výkaz obsahuje soubory šablon, které není možné vybalit, protože nemáte nainstalovanou knihovnu VFPCOMPRESSION.FLL“.

Při exportu definice výkazu do balíčku, jsou exportovány také jeho šablony včetně kopie obsahu souboru šablony.

Import balíčku nikdy nepřepisuje kopii souboru šablony v databázi a ani neprovádí její „vybalení“ do souboru na disku (to se provede až při prvním spuštění výkazu).

Knihovna VFPCOMPRESSION.FLL požaduje pro svou funkci ve Windows starších než Vista existenci souborů C:\WINDOWS\SYSTEM32\MSVCP71.DLL a C:\WINDOWS\SYSTEM32\MSVCR71.DLL.

Dále definuje počáteční řádek a sloupec, se kterými koresponduje definice prvního řádku a sloupce v definici listu, a údaj, zda se při sestavování výkazu má nejprve existující list zrušit.

Atributem šablony „vymazat list – Ano/Ne“ je možno nastavit, zda se má obsah listu výkazu v Excelu před jeho vytvářením vymazat, tzn. následný vytvořený výkaz bude přesně korespondovat s nadefinovanou šablonou (řádky, sloupce, velikost tabulky apod.).

Obvykle se v rámci souboru šablony definuje grafika výkazu, pojmenované texty a buňky, jimž mohou být následně přiřazovány hodnoty v definici výkazu a následně při sestavení výkazu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 17.02.2012


Pojem - Technické zhodnocení

Technické zhodnocení je akt, kterým dochází ke zvyšování hodnoty, např. odepisovaného majetku. Paragraf 33 Zákona o dani z příjmu vymezuje technické zhodnocení jako dokončené nástavby, přístavby a stavební úpravy, modernizace a rekonstrukce. Technickým zhodnocením se pro účely tohoto zákona rozumí vždy výdaje na dokončené nástavby, přístavby a stavební úpravy, rekonstrukce a modernizace majetku.

Rekonstrukcí se pro účely tohoto zákona rozumí zásahy do majetku, které mají za následek změnu jeho účelu nebo technických parametrů. Modernizací se pro účely tohoto zákona rozumí rozšíření vybavenosti nebo použitelnosti majetku. Technickým zhodnocením jsou také výdaje na dokončené nástavby, přístavby a stavební úpravy, rekonstrukce a modernizace majetku, pokud je hradí budoucí nájemce na cizím hmotném majetku v průběhu jeho pořizování za podmínky, že se stane nájemcem tohoto hmotného majetku nebo jeho části, a vlastník tohoto hmotného majetku nezahrne výdaje vynaložené budoucím nájemcem do vstupní ceny.

Technické zhodnocení nehmotného majetku (viz. §32a Zákona o dani z příjmu) zvyšuje vstupní cenu nehmotného majetku; přitom za technické zhodnocení se považují výdaje na ukončené rozšíření vybavenosti nebo použitelnosti nehmotného majetku anebo zásahy, které mají za následek změnu účelu nehmotného majetku, pokud po ukončení u jednotlivého nehmotného majetku převýší částku 40 000 Kč. Za technické zhodnocení se považují i uvedené výdaje nepřesahující stanovenou částku, pokud je poplatník na základě svého rozhodnutí neuplatní jako výdaj (náklad) podle § 24. Poplatník pokračuje v odpisování nehmotného majetku ze zvýšené vstupní ceny snížené o již uplatněné odpisy od měsíce následujícího po měsíci, v němž bylo technické zhodnocení ukončeno, a to rovnoměrně bez přerušení po zbývající dobu odpisování[1], nejméně však

a) audiovizuální díla po dobu 9 měsíců,
b) software a nehmotné výsledky výzkumu a vývoje po dobu 18 měsíců,
c) nehmotný majetek, je-li právo užívání sjednáno na dobu určitou, do konce doby sjednané smlouvou,
d) ostatní nehmotný majetek po dobu 36 měsíců.

Technické zhodnocení ukončené na již odepsaném nehmotném majetku se odpisuje samostatně po dobu uvedenou v písmenech a), b) a d). Při prodloužení doby užívání práva sjednaného smlouvou na dobu určitou, zvýší poplatník o hodnotu technického zhodnocení vstupní cenu a pokračuje v odpisování nehmotného majetku ze zvýšené vstupní ceny snížené o již uplatněné odpisy od měsíce následujícího po měsíci, v němž bylo právo užívání prodlouženo, a to rovnoměrně bez přerušení do konce doby nově sjednaného práva užívání.

[1] U nehmotného majetku, ke kterému má poplatník právo užívání na dobu určitou, se roční odpis stanoví jako podíl vstupní ceny a doby sjednané smlouvou. V ostatních případech se nehmotný majetek odpisuje rovnoměrně bez přerušení, a to audiovizuální dílo 18 měsíců, software a nehmotné výsledky výzkumu a vývoje 36 měsíců, zřizovací výdaje 60 měsíců a ostatní nehmotný majetek 72 měsíců.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 11.09.2008


Pojem - Technologické operace

Činnost technologické operace a činnost artikly výroby jsou základním podkladem pro definici technologických postupů. Aby je bylo možno co nejefektivněji nadefinovat, je nutno správně zadat technologické operace, kde každá jedna operace představuje činnost ve výrobním postupu pro finalizaci výrobku (polotovaru) nebo skupiny výrobků (polotovarů). Různé technologické postupy pak mohou obsahovat stejné technologické operace. U každé operace se definuje:

¨ identifikace a název operace

¨ tabulka – identifikace tabulky vztahů artiklů. Tabulka přiřazená technologické operaci definuje vztahy mezi artikly, které jsou vstupem a výstupem technologické operace.

¨ druh linky – druh výrobní linky přiřazený technologické operaci – definuje, na jakém místě (lince) ve výrobě se bude operace provádět

¨ barva – zvolení barvy jakou se bude daná technologická operace zobrazovat v harmonogramu výroby

¨ technický selektor

¨ vstupy a výstupy – identifikace druhu operace ve kterém se definují algoritmy pro plnění aktuálních či statistických hodnot z událostí vstupů a výstupů

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.01.2008


Pojem - Technologické postupy

Tato činnost poskytuje uživateli přehled nadefinovaných technologických postupů. Technologický postup je přesné vyjádření posloupností úkonů (tj. jednotlivých operací) nutných k finalizaci výstupu technologického postupu. U každého technologického postupu se definuje:

¨ identifikace a název – identifikace je ve většině případů odvozena od skupiny artiklů, které jsou pro tento postup pilotním artiklem

¨ datum platnosti od – do – určení platnosti technologického postupu. Toto datum platnosti se uplatňuje ve výběru technologického postupu při generování v činnosti „TP k datu rozpracované na KJ“.

¨ platný – volba platnosti TP (Ano/Ne)

¨ pilotní – zda se jedná o pilotní TP pro určení ceny vstupu/výstupu podle TP k datu (při volbě Ano v podstatě určuje TP pro určení ceny výrobku v případě, že se výrobek vyskytuje jako pilotní artikl ve více technologických postupech)

¨ šablona – identifikace šablony procesu TP (definuje druh procesu, který vznikne a napojí se na proces výrobní zakázky v případě, že podobný druh procesu již v diagramu procesu výrobní zakázky není)

¨ komentář – libovolný popis

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.01.2008


Pojem - Test mírou plnění

V případě, že při běhu procesu dochází k ukončení operace, jejíž události vznikly předplněním na základě pravidel transformace, tak provádí systém test naplnění míry plnění, tj. porovná údaje před transformací a po transformaci (uživatel mohl pozměnit předplněné údaje) .

Způsob, zda má být uživatel informován o výsledku testu, se definuje v činnosti Druhy procesů a Druhy operací. Nejvyšší prioritu pro nastavení testu míry plnění má hodnota, která je nastavena u druhu operace, tzn. že pokud je u druhu operace nastaveno test mírou plnění NE a u druhu procesu ANO, systém bude za prioritní brát hodnotu NE.

Nastavení hodnoty testu míry plnění u druhu procesu má význam pouze tehdy, pokud je u druhů operací v něm obsažených nastaven test míry plnění „podle procesu”. Jinak vždy platí nastavení u druhu operace.

Test míry plnění je pak schopen pracovat tak, že kontroluje např. vykrývání objednávek, úhrady plateb apod. Lze nastavit tyto varianty:

¨ ano – u operací daného druhu se bude provádět test mírou plnění a při ukončení operace je uživatel na nesrovnalosti upozorněn implicitním[1] informativním hlášením: „Transformace nebyly naplněny. Přesto ukončit operaci?“.

¨ ne – test mírou plnění se provádět nebude a uživatel v případě nesrovnalosti nebude informován.

¨ podle procesu – tato varianta je dostupná pouze v činnosti druhy operací, tzn. že u operací daného druhu se bude (ne)provádět test mírou plnění podle hodnoty, která je uvedena u druhu procesu, jehož je tento druh operace uzlem.

¨ rozhodne kód po ukončení – o tom, zda se bude test mírou plnění provádět, rozhodují definice, které jsou zapsány v kódu po ukončení u daného druhu operace v diagramu procesu (je-li v něm uvedena proměnná #MP#, uživatel není upozorněn na nesrovnalost implicitním informativním hlášením).

Test mírou plnění však může probíhat ještě i nezávisle na hodnotě nastavené u druhu operace. V případě, že uživatel bude potřebovat přidat událost (např. rozúčtování, další artikl apod.) na operaci, která nemá nastaven test mírou plnění, bude zobrazován dotaz typu „Transformace nebyly naplněny. Přesto ukončit operaci?“. Tomuto dotazu je možno předejít tím, že u takovéto operace se v menu Volby zaktivuje pro současnou chvíli činnost „aktivní míra plnění“. Tím bude operace v pořádku ukončena a tento dotaz se zobrazovat nebude.

V kódu po ukončení operace mohou být použity konstanty a funkce:

#MP# | Konstanta obsahuje informaci (logickou hodnotu), jak události dané operace naplňují definované míry plnění (true = nenaplňuje)
ASK3 | Dotaz k uživateli – tvar ANO/NE/STORNO Funkce s jedním parametrem typu text. Vrací textovou hodnotu ‚A‘ nebo ‚N‘ nebo ‚Z‘

Příklad použití konstanty #MP# a funkce ASK3:

DECLARE dotaz

IF #MP#

SET dotaz=ASK3('Je dodání ukončeno ?')

IF dotaz='N'

ACTIVATE PARENT

ELSE

IF dotaz='Z' THEN CANCEL

ENDIF

ENDIF

Příklad souvisí s možností nastavení parametru druhu operace „test mírou plnění“ na hodnotu „Rozhodne kód po ukončení operace“, který způsobí to, že po ukončení operace s nenaplněnou mírou plnění nebude zobrazen obvyklé informativní hlášení „Transformace nebyly naplněny. Přesto ukončit operaci?“ ale dotaz "Je dodání ukončeno ?". Případně je možné definovat, že kód po ukončení nedovolí ukončit operaci bez naplnění míry plnění.

[1] V kódu po ukončení operace lze definovat explicitně.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.04.2004


Pojem - TIFF formát

U předloh výstupu typu „sestava“ lze použít při tisku formát TIFF (po spuštění výstupu volba „do souboru“) nebo je možno ho použít jako přílohu e-mailu ve formátu TIFF (zde je nastavení variabilní). Formát TIFF (Tagged-Image File Format) se používá k přenosu obrazových souborů mezi různými aplikacemi a platformami. TIFF je typickým představitelem bitmapového formátu, tj. grafická informace je v něm vyjádřena formou matice obrazových bodů - pixelů, přičemž u každého pixelu je udána informace o jeho barvě. Největší výhodou uvedeného typu formátů je schopnost věrné reprezentace "přirozeného" obrazu (sejmutého například skenerem či digitálním fotoaparátem). Dalšími výhodami jsou robustnost (nehrozí ztráta informací při přenosu do jiného prostředí) a poměrně snadné zpracování při výstupu.

Pro definici PDF a TIFF formátu musí IS BM obsahovat:

¨ knihovnu SYSPDF (knihovna s funkcemi pro výstup tiskové předlohy typu Sestava do souboru ve formátu PDF a TIFF – podrobný popis této knihovny je uveden v její poznámce) a knihovnu DEFPDF (knihovna určená pro uvedení v parametru BM Printing->Default_skript_po_SQL, která způsobí to, že tisk předlohami výstupu typu Sestava do souboru vytvoří PDF a TIFF dokument a následně ho zobrazí v Acrobat Readeru. Pro svou funkci používá knihovnu SYSPDF)

¨ nastavení programu - v parametru programu BM 'Printing->Default_skript_po_SQL' je možné zadat identifikaci knihovny vkládaného kódu, jejíž kód má být prováděn pro všechny předlohy výstupu, které nemají vyplněnou vlastnost 'Skript po SQL dotazu'

- na záložce Deklarace vlastnost předlohy 'Skript po SQL dotazu'

¨ profil spuštění předloh - vytváření PDF dokumentu může být ovlivněno parametry uvedenými v proměnné _PARAMETR_PROFILU

Nastavení tisku ve formátu PDF a TIFF není triviální záležitost, proto by ji méně zkušený uživatel měl definovat v součinnosti se svým implementátorem.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 24.10.2008


Pojem - Tisk zjednodušených dokladů

Jedná se o výstup informací z událostí „té jedné určité” operace. Tento tisk (předloha výstupu) není k dispozici nad procesy (jako předlohy dokladů), ale jsou to běžné předlohy výstupu, které jsou vytvořeny v činnostech s přehledem událostí jednotlivých komponent, kde se tyto zjednodušené doklady také tisknou po vyvolání činnosti tisk a zvolení příslušné předlohy výstupu. Každá předloha výstupu musí být součástí určité metapředlohy.

Též lze automatizovat tisk těchto výstupů při běhu procesu a to pomocí nastavení určité předlohy ve vlastnostech uzlu (operace) v daném diagramu procesu. Pak dojde k automatickému spuštění výstupu při ukončení dané operace.

U těchto předloh výstupu se při tisku doporučuje třídění podle identifikace procesu, čímž se předejde smíchání a rozházení událostí.

Příkladem zjednodušených dokladů je např. tisk výdejky, příjemky, příjmového nebo výdajového pokladního dokladu apod.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.04.2004


Pojem - Toolbar

Je to sada nástrojů, která v sobě obsahuje řadu dalších metod a vlastností, které ovlivňují chod systému a ovládání formulářů. Příkladem toolbaru jsou:

¨ zobrazení aktivních oken

¨ nabídky

¨ rámeček souvislostí

¨ vazby míry plnění apod.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.01.2013


Pojem - Tooltip

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.10.2009


Pojem - Transformace

Transformace obecně definuje, jak se z dat ve zdrojovém uzlu mají předplnit data do cílového uzlu, tj. je základním nástrojem modelování datového toku. Transformace se skládá z definice základních údajů a definice pravidel (nejméně jedno pravidlo musí být vždy uvedeno). Transformace se definuje přímo[1] při vytváření vazby uzlů v diagramu procesu po stisku tlačítka „vstup transformací” (vztahuje[2] se k dvojici komponenta zdrojové operace – komponenta cílové operace). U každé transformace se vstupují následující atributy:

¨ transformace - vlastní název transformace (měl by vyjadřovat co transformace provádí, např. nákup za hotové, prodej za hotové, ZS - příjem, převod na BÚ apod.)

¨ filtr transformace - globální filtr pro zdrojové události, který se uplatní pro všechny pravidla uvedené transformace (např. u transformace „změna stavu - příjem" může být uveden filtr „nenulová úhrada")

¨ rozpad na procesy - má význam jen tehdy, je-li cílový uzel typu proces. Jedná se o definici výrazu (klíče) ze vstupních atributů komponenty, podle kterého se mají cílové události rozdělit (odvozené z událostí se shodným klíčem do jedné operace) do prvních operací samostatných procesů, např. dle adresáta. Pokud např. vytvoříme větší množství položek penalizačních faktur, budeme je pak zcela určitě chtít roztřídit podle jednotlivých adresátů. Jiným příkladem jsou např. nepárované položky výpisu apod.

¨ popis rozpadu – určuje text zobrazovaný v zásobníku operací v seznamu operací. Ve výrazu je možné použít rutinu BM pro SQL-dotaz (např. pro přenos názvu adresáta "~tool.sql_dotaz([select ad01adsat from %%%.adadsat where ad01id=?_p1,Data.ad01id]") pro zobrazení informací, které nejsou součástí dotazu transformace.

¨ doplnění pohledu - umožňuje rozšířit množinu výstupních atributů komponenty o další uživatelsky definované. Je důležité si uvědomit, že tento výpočet probíhá samostatně pro každou událost zdrojové operace, takže pokud je následně v pravidle transformace aplikován agregační výraz, bude doplněná numerická hodnota sčítána. To někdy není žádané a lze tomu zabránit definicí výběru v pravidle, např. RECNO ('DATA')=1

¨ prog. transformace - dodávaná nadstavba (programový kód) pro specifické případy požadavků na transformaci. Je součástí IS BM a uplatňuje se u transformací, kde nestačí základní ani doplněné atributy.

¨ právo následující operace podle umístění - pokud je tento atribut u transformace zaškrtnutý, znamená to, že při ukončení operace (zdrojového uzlu) má uživatel možnost si vybrat (definovat) alokaci pro cílový uzel (např. může určit umístění skladu apod. - podle komponenty, jejíž operace je nadefinována jako cílový uzel v transformaci). Pokud uživatel ke zvolenému umístění (alokaci) nemá (musí mít alespoň právo čtení, aby je mohl uvést) nadefinováno přístupové právo, následující uzel se nespustí, třebaže má ve vlastnostech spouštět automaticky.

¨ transformace dynamické vazby - pokud je daná transformace užita v dynamické vazbě, je nutno zaškrtnout tento příznak. Tuto transformaci není možno užít v nedynamické vazbě, resp. tato možnost není dosud zdárně ověřena z praxe.

¨ aktivovat následující operaci podle filtru transformace – zaškrtnuté způsobuje, že následující operace je aktivována (převedena do stavu připravena) pouze v případě, že existuje událost ukončované operace vyhovující filtru transformace. Z toho vyplývá, že toto nastavení má smysl pouze v případě, když je nastavena vlastnost transformace „filtr transformace“. Pro vyhodnocení podmínky se používá v případě tohoto nastavení kurzor aktuálně ukončované operace, je nutné, aby v ní byly užity pouze atributy tohoto kurzoru (nesmí v ní být použity atributy doplnění transformace).

¨ poznámka - popis užití transformace

Záložka „obecné předkontace“ poskytuje uživateli možnost nadefinovat si obecné předkontace, které jsou svázány s danou transformací a lze je využít při definování vazby (zobrazují se zde jako překryvný seznam u atributu předkontace) mezi zdrojovým a cílovým uzlem v diagramu procesu.

Záložka „výskyt transformace v typech procesů“ poskytuje uživateli pouze informativní přehled o tom, v jakých druzích procesů (a mezi jakými uzly těchto druhů procesů) je daná transformace použita[3].

Transformace jsou společné pro druhy procesu i fyzické procesy. V diagramu fyzického procesu lze transformaci mezi uzly zaměnit za jinou, ale pak se transformace uplatní pouze tehdy, pokud zdrojová operace[4] není ukončena nebo pokud je cílový uzel typu operace.

[1] Z jiného místa IS není jejich definice dostupná, krom speciálních případů (dynamická spojení operací).

[2] V zobrazeném seznamu jsou k dispozici transformace mezi dvojicí komponent.

[3] Zobrazují se i skryté procesy.

[4] Pokud je zdrojový uzel proces, pak se uplatní pouze tehdy, není-li ukončena ani jedna operace, ze které se transformuje.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.02.2012


Pojem - Trigger, uživatelský trigger

Nástroj databázového serveru spojený s danou tabulkou (entitou) databáze, který na základě změny (aktualizace) záznamu v ní může automatizovaně aktualizovat data jiných tabulek (např. po založení skladu trigger automaticky založí i jednu skladovou buňku "-"). Obsahem triggeru je definice, která data a za jakých podmínek a jak se mají aktualizovat.

Triggery jsou součástí programového kódu poskytnutého IS, ale je možnost definovat i uživatelské triggery[1] k jednotlivým tabulkám, resp. k souvisejícím volným kartám. Implementace uživatelského triggeru patří k "nejodbornějším" prvkům implementace, tj. vyžaduje dobrou znalost IS i jeho dané implementace.

Popis uživatelského triggeru uložený v databázi má strukturu:

<hlavička>

BEGIN

<kód>

END;

V definici uživatelského triggeru v BM se uvádí kód bez uvedení BEGIN a END.

V kódu triggerů je možné se odkazovat na atributy záznamu, který jej aktivoval:

¨ při INSERT - new_name - alias záznamu, který vstupuje do tabulky

¨ při UPDATE - old_name - alias záznamu, který obsahuje hodnoty před změnou

- new_name - alias záznamu, který obsahuje změněné hodnoty

¨ při DELETE - old_name - alias záznamu, který je rušen z tabulky

Případné změny dat provedené triggerem jsou obsaženy ve stejné transakci jako změna, která ho vyvolala, proto by neměl obsahovat příkaz "COMMIT".

[1] Položka menu ....

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Třída pohledu (slovníku dat)

Je nástroj slovníku dat pro uspořádání pohledů do skupin. V rámci třídy lze uplatnit například funkci kopie pohledu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Třídění

Je jedním z uživatelských nástrojů způsobu zobrazení vybraných dat. Třídění je možno používat ve dvou případech:

¨ setřídění formulářů

¨ setřídění předloh výstupu

Při třídění formulářů se používá především činností, které uživateli poskytuje hlavní panel nástrojů, tzn., že uživatel má možnost si zvolit atribut, podle kterého bude daný formulář setříděn a v případě potřeby si toto setřídění může i trvale uchovat (viz. parametry formuláře). Setřídit atributy ve formuláři je možno i tímto způsobem – uživatel stiskne pravé tlačítko myši na názvu sloupce a jednotlivé záznamy jsou pak setříděny na základě tohoto sloupce.

Třídění v předlohách výstupu je možno provádět dvojím způsobem:

¨ výběr atributu třídění při zahájení výstupu, tzn. při aktivaci předlohy výstupu (ještě před odesláním předlohy výstupu do tisku)

¨ nastavením vlastního setřídění – to se provádí ve vlastnostech předlohy výstupu. Uživatel si určí vlastní atribut, podle kterého bude daná předloha výstupu setříděna.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Turnus

Skupina zvířat jedné kategorie, která obvykle „vstoupila“ do výkrmu v jeden časový okamžik (tj. 1 až 3 dny) u jednoho chovatele (tj. jedna stáj) a kterou lze samostatně ekonomicky hodnotit.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Typ ceny

Pojem typ ceny úzce souvisí s událostmi komponenty skladu zvířat. Typ ceny může být skladová a nebo zadaná. V případě ceny skladové uživatel vůbec nevstupuje atribut cena za MJ, neboť je doplněn automaticky, podle průměrné skladové ceny. V případě ceny zadané uživatel určuje cenu za MJ samostatně.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.10.2007


Pojem - Typ prvku webu

Typ prvku webu definuje základní vlastnosti každému prvku webu. Existují tyto typy:

¨ definující nelistové úrovně položek menu (jsou typu: 1.menu nebo 2.menu),

¨ definující listovou úroveň položky menu pomocí ULR adresy (jsou typu: list - adresa):

¨ do adresáře umístěného na adrese http://isbm.bmservis.cz/bm, kde jsou umístěny ASP soubory (např.: /bm/vyveska.asp pro vývěsku), vytvořené programátory BM Servis,

¨ do libovolného místa sítě internet (např.: http://www.justice.cz/cgi-bin/sqw1250.cgi/or/l_hled.sqw pro obchodní rejstřík),

¨ definující listovou úroveň položky menu pomocí odkazu na pohled (plus výběr a předloha výstupu) ve slovníku dat, který je připraven uživatelsky (jsou typu: list - slovník dat).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Typ prvku webu: list - adresa

Je to položka web menu, která po vyvolání přepojí vzdáleného uživatele na internetovou adresu, která je součástí definice prvku web tohoto typu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Typ prvku webu: list - slovník dat

Je to položka web menu, která po vyvolání dodá vzdálenému uživateli informace, jejichž struktura je definována pomocí slovníku dat. V rámci definice prvku webu tohoto typu se uvádí:

¨ název pohledu ze slovníku dat, který definuje zejména strukturu zobrazovaných dat (povinné),

¨ název výběru, který definuje množinu zobrazovaných dat (povinné),

¨ název předlohy výstupu, který definuje zejména formu zobrazení (nepovinné).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Typ seznam hodnot užívaných ve výkazech

Typ seznam hodnot je skupina prvků seznamu oddělených středníkem uvozená a ukončená apostrofem, například: '112%;1135_[^5]%;2%'. Prvky seznamu mohou být typu N, C, D, T a M.

Tento typ je využíván zejména v příkazu DYN a také ve funkcích výkazu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Typ zdanitelného plnění

Tuto činnost má uživatel k dispozici v hlavním menu – DPH – Typ zdanitelného plnění. Číselník typů zdanitelného plnění dostává uživatel naplněný společně s dodávkou informačního systému. V případě legislativních změn si následně uživatel změny v sazbách apod. musí provést ručně.

Jednotlivé nastavené definice typů zdanitelného plnění uživatel využívá při automatizaci vstupu dat událostí OBC[1] a DPH programovým kódem.

Po aktivaci této činnosti má uživatel k dispozici přehled nadefinovaných typů zdanitelného plnění a aktivní záložku „Typy zdanitelného plnění“. Atributy na této záložce jsou:

¨ typ zdanitelného plnění – jednoznačná identifikace typu zdanitelného plnění[2]

¨ název – zpřesňující název typu zdanitelného plnění

¨ zdan. plnění – výběr možností zdanitelného plnění z překryvného seznamu. Možnosti jsou: nepodléhá dani, osvobozeno pro koeficient, snížená, základní, dočasné použití, finanční pronájem, osvobozeno, osvobozeno-třístranný obchod

¨ pro vývoz – historický atribut. Uvedené konkrétní možnosti na jednotlivých typech zdanitelných plnění sloužily pro definice daňového přiznání do 1.5.2004. Pro následující verze DPH se již nevyužívají.

¨ účel daně – historický atribut. Pro verzi DPH od 1.5.2004 se již nevyužívá.

Záložka „Sazby DPH“ obsahuje konkrétní sazby DPH k jednotlivým typům zdanitelného plnění.

¨ typ místa – výběr z překryvného seznamu tuzemsko/zahraničí/EU

¨ platnost od – počátek období platnosti dané sazby

¨ sazba DPH – vstup – procento sazby DPH na vstupu (odpočet)

¨ účet – vstup – syntetika účtu z účtové osnovy (historický atribut z verze do r. 2004). Od verze DPH k 1.5.2004 lze požadované analytické účty nadefinovat v činnosti Uplatnění předmětů zdanitelného plnění.

¨ sazba DPH – výstup – procento sazby DPH na výstupu (nápočet)

¨ účet – výstup – syntetika účtu z účtové osnovy (historický atribut z verze do r. 2004). Od verze DPH k 1.5.2004 lze požadované analytické účty nadefinovat v činnosti Uplatnění předmětů zdanitelného plnění.

¨ zaokrouhlení na řád, nahoru od cifry – řád zaokrouhlení a od které cifry nahoru (oba atributy se uplatní při zaokrouhlení částky DPH). V implementacích doporučujeme nastavit zaokrouhlování na 0,01 nahoru od cifry 1.

¨ tech. sel. – v případě potřeby detailního rozlišení možno uvést identifikaci technicko-věcného selektoru

Na záložce „uplatnění předmětů“ jsou k dispozici varianty zdanitelného plnění konkrétní sazby. Ke každému uplatnění je zadáno kdy a za jakých podmínek se toto uplatnění bude realizovat. U každého uplatnění se navíc eviduje jeho platnost od - do a ta uplatnění, která jsou již mimo dobu platnosti, se uživateli zobrazují šedivě. Při vstupu událostí obchodu se pak na základě kombinace: typ, místo plnění a plátce či neplátce nabízí odpovídající možnosti uplatnění předmětů.

Důležitými atributy na této záložce je uvedení čísla paragrafu a v poznámce uvedení přesného popisu, do kterého řádku daňového přiznání daný paragraf vstupuje (tzn. hodnotu jakého řádku daňového přiznání ovlivňuje). Pro platné znění daňového přiznání od vzoru č. 15 a dále je nutno mít v atributu poznámka řádek uveden ve tvaru „=ř. xy“.

Čísla paragrafů uvedená v této činnosti slouží jako vodítko, nejedná se o plný a přesný výčet paragrafů z hlediska Zákona od DPH.

Záložka „Uplatnění předmětů“ slouží v této činnosti spíše pro hrubou informaci uživatele. Vlastní definici a prohlížení jednotlivých uplatnění je vhodnější provádět přímo v dané činnosti (vlastní popis činnosti a jednotlivých atributů je uveden v pojmu Uplatnění předmětů zdanitelného plnění).

Na záložce „Substituce TZP“ lze k typu zdanitelného plnění definovat pravidlo (i více pravidel), které předplní na událost obchodu zde definovaný typ zdanitelného plnění, který je odlišný od typu uvedeného na kartě obchodovatelného artiklu.

Příklad:

¨ je vstupována událost obchodu - prodej pro adresáta s typem místa EU, který je plátcem DPH a s artiklem, který má u sebe uvedenu klasifikací Z (zboží) a typ zdanitelného plnění ZA1

¨ pro TZP ZA1 je definovaná substituce (OSV, EU, Nápočet, Plátce DPH=Ano, Z)

¨ potom na události obchodu bude pro takového adresáta automaticky předplněn typ zdanitelného plnění OSV

[1] Pro přesnější představu uživatele: číselník typů zdanitelného plnění je vyplněn v komponentě DPH v příslušné činnosti, avšak při běhu procesu uživatel jako první zadává např. událost obchodu a zde tento číselník rovněž automaticky využívá a pak pomocí transformací dojde k jeho předplnění i v komponentě DPH.

[2] Bez dopřesnění se svým implementátorem nedoporučujeme tyto identifikátory měnit

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 23.03.2010


Pojem - Typové pracovní místo

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 01.02.2008


Pojem - Typy událostí komponent

Tuto činnost má uživatel k dispozici v hlavním menu – Informační centrum – Typy a řady – Typy událostí komponent.

Tato činnost umožňuje členit operace jednotlivých komponent (v současnosti pouze komponenty „obecná událost“, tzn. vývěska) podle nadefinovaných typů událostí komponenty. Typ události pak uživatel uvádí při zadávání operace komponenty (tzn. při zadávání událostí komponenty vývěska se z překryvného seznamu vybírá i typ události). V této činnosti má uživatel přehled jednotlivých typů událostí a jejich použitelnosti v jednotlivých operacích. K druhům operací lze i v této činnosti přiřazovat jednotlivé typy, v rámci lepší přehlednosti ale doporučujeme uživateli toto definovat přímo v činnosti druhy operací.

Uveďme si příklad možného použití této činnosti:

¨ uživatel má nadefinovaný druh operace komponenty obecná událost (tj. vývěska), která se jmenuje „obchodní případ“

¨ tento druh operace může být pak následně členěn na různé typy – např. telefonát, odeslání informací e-mailem, osobní návštěva apod.

Nejprve je nutno nadefinovat typy událostí komponent. Zde se zadává:

¨ identifikace typu

¨ název typu

Na záložce „použitelnost typu pro druhy operací“ se definuje, jaký typ je platný pro kterou operaci. K druhu operace může být přidělen žádný nebo několik typů událostí. Definuje se:

¨ operace – identifikace komponenty, identifikace druhu operace a její název

¨ počáteční – možnost Ano/Ne – volba Ano určuje typ události předplněný při vstupu nové události

¨ poznámka

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 30.07.2008


Pojem - Typy zdanitelného plnění

Jedná se o číselník typů zdanitelného plnění a dalších činností s ním souvisejících, který se v celém informačním systému používá při práci s DPH. Tento číselník dodáváme naplněný tak, aby odpovídal stávající legislativě. Činnost je rozdělena čtyřmi záložkami (typy zdanitelného plnění, sazby DPH, uplatnění předmětů, substituce TZP).

V systému se u každého artiklu eviduje typ plnění DPH, který je pro artikl platný. V událostech DPH je pak tento typ zdanitelného plnění uváděn jako implicitní (s možností změny). Každý typ zdanitelného plnění, resp. jeho sazby, je navíc spojen s určitým technicko-věcným selektorem, což umožňuje využít modul statistika.

Každý „typ zdanitelného plnění“ obsahuje informace o jeho identifikaci, názvu, zdanitelném plnění (např. bez daně, snížená sazba, osvobozené plnění apod.) a možnostech při vývozu do zahraničí.

Druhou záložkou jsou „sazby DPH“, přičemž každá sazba se vztahuje k právě aktuálnímu typu zdanitelného plnění. Uživatel při jejich zadávání vstupuje tyto údaje:

¨ typ místa - tuzemsko, zahraničí, Evropská Unie apod.

¨ platnost od - od kterého data je daná sazba platná

¨ sazba DPH - vstup - sazba při nákupu (sazba se vždy vztahuje k typu místa, takže bude rozdíl mezi tuzemskem a zahraničním)

¨ účet - vstup - zadaný analytický účet je dostupný jako výstupní atribut komponenty v transformaci do účetnictví. Systém hledá, jaká je zde nadefinována sazba DPH a podle sazby a tohoto nadefinovaného účtu proběhne zaúčtování.

¨ sazba DPH - výstup - sazba při prodeji (sazba se vždy vztahuje k typu místa, takže bude rozdíl mezi tuzemskem a zahraničním)

¨ účet - výstup - zadaný analytický účet je dostupný jako výstupní atribut komponenty v transformaci do účetnictví. Systém hledá, jaká je zde nadefinována sazba DPH a podle sazby a tohoto nadefinovaného účtu proběhne zaúčtování.

¨ zaokrouhlení na řád - výběr na jaký řád se mají výsledné částky daně zaokrouhlovat

¨ nahoru od cifry - ještě souvisí se zaokrouhlováním (od jakého čísla se má zaokrouhlovat nahoru či-li výše)

¨ tech. sel. - předplňuje se při vstupu události s touto sazbou. Při zadávání technického selektoru se pak pomocí komponenty statistika dají zjistit takové údaje jako např. prodej bez daně, prodej do zahraniční s daní - bez daně apod.

Na záložce „uplatnění předmětů“ má uživatel k dispozici varianty zdanitelného plnění konkrétní sazby. Ke každému uplatnění se zadává kdy a za jakých podmínek se toto uplatnění uplatní. U každého uplatnění se navíc eviduje jeho platnost od do a ty uplatnění, která jsou již neplatná, se uživateli zobrazují šedivě. Při vstupu událostí obchodu se pak na základě kombinace – typ a místo plnění a plátce či neplátce předplní odpovídající uplatnění předmětů.

Na záložce „substituce TZP“ se ke každému typu zdanitelného plnění definuje pravidlo, které umožní uplatnit uvedenou sazbu než je sazba definovaná na obchodovatelném artiklu.

Př.: - je vstupována událost obchodu - prodej pro adresáta s typem místa EU, který je plátcem DPH a artiklem, který má u sebe uvedenu klasifikací Z (zboží) a typ zdanitelného plnění ZA1

- pro TZP ZA1 je definovaná substituce (OSV, EU, Nápočet, Plátce DPH=Ano, Z)

- potom na události obchodu bude předplněn TZP OSV

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 09.10.2007


Pojem - Účetní deník

Činnost IS BM „Účetní deník“ umožňuje uživateli prohlížení neagregovaných účetních zápisů a to s výběrem jejich libovolné podmnožiny, s volbou třídění a s libovolnou formou zobrazení (tisku) pomocí předloh výstupu. Jednou z možností pohledu na účetní zápisy je samozřejmě účetní kniha „účetní deník“, kde jsou účetní zápisy uspořádány z hlediska časového (chronologicky) a prokazují zaúčtování všech účetních případů v účetním období.

Jednotlivé účetní zápisy v účetním deníku vznikají buď prostřednictvím procesů a nebo pomocí obecného účetního zápisu (s případnou pomocí šablon). Jinými slovy lze toto vysvětlit tak, že někde v operativní evidenci v systému (např. komponenta obchod nebo sklad) je vytvořen prvotní doklad (např. vystavená faktura nebo výdej ze skladu) a na základě procesu a v něm nadefinovaných transformací dojde k účetnímu zápisu tohoto účetního případu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.09.2008


Pojem - Účetní období

Účetní období je přesně definováno Zákonem o účetnictví.

Účetní období je období, k jehož konci se sestavuje účetní závěrka. Období trvá obvykle 12 měsíců, přičemž se může shodovat s kalendářním rokem anebo ne (pak se jedná o hospodářský rok). Jiná délka účetního období se uplatní např. při přechodu z kalendářního roku na hospodářský a naopak, při založení společnosti a v dalších případech dle Zákona o účetnictví. IS BM umožňuje zápisy pouze do definovaných (neuzavřených) účetních období, to se uplatní i při automatickém výpočtu měsíčních odpisů, při výběrech v obratové tabulce či při uzavírání a otevírání účetních knih. S účetním obdobím úzce souvisí účetní závěrka.

Uživatel má činnost účetní období k dispozici v hlavním menu – Účetnictví – Speciální činnosti. Při definování účetního období vstupuje následující atributy:

¨ identifikace a název období

¨ rok od – měsíc od

¨ rok do – měsíc do

Atributy „otevřeno“ a „uzavřeno“ jsou plně uživatelsky modifikovatelné (mají však vliv na další činnosti účetnictví) , tzn. jejich zatržení není prováděno automaticky systémem. V případě otevření účetních knih je vhodné, aby si uživatel u daného (otevíraného) období zatrhnul atribut „otevřeno“, stejně tak to platí i pro uzavření účetních knih. Po jejich uzavření je vhodné, aby si uživatel u daného (uzavíraného) období zatrhnul atribut „uzavřeno“. Pro uživatele je tedy vhodné, aby zatržení těchto atributů provedl vždy po otevření nebo uzavření úč. knih a aby stav těchto atributů odpovídal skutečnému stavu účetnictví, neboť tyto atributy mají vliv na:

¨ nabídku účetního období v nabídce šablony při otevírání nebo uzavírání účetních knih

¨ účetní období při vytváření účetních zápisů (událostí účetního deníku)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.09.2008


Pojem - Účetní odpis

Povinnost provádění účetních odpisů vyplývá ze zákona o účetnictví. Účetní odpisy jsou uplatněny podle skutečné doby používání dlouhodobého majetku. Mají přesně vystihnout míru opotřebení dlouhodobého majetku. Podnik si může zvolit vlastní účetní odpisy (vnitropodnikové směrnice), ale při vyplňování daňového přiznání musí dbát na to, že může uplatnit pro zjištění základu daně z příjmu jen výši daňových odpisů. Obvykle se používají tyto metody ke stanovení účetních odpisů:

¨ časové – vychází z doby použitelnosti majetku. Podnik si sám stanoví upotřebitelnost dlouhodobého majetku. Určí se tedy doba, po kterou chceme majetek v podniku využívat. Doba nemusí odpovídat době odpisu podle §30 zákona o dani z příjmu. Odpisová sazba v % se vypočítá jako 100/doba životnosti.

¨ výkonové – jsou odvozeny z množství výkonů, které podnik předpokládá získat prostřednictvím daného majetku. Při této metodě dělíme vstupní cenu výkonem majetku. Výkonem majetku může být např. počet vyrobených ks výrobků nebo počet ujetých km apod.

¨ dle daňových odpisů – na základě vnitřních směrnic podniku

Účetní odpisy se počítají z pořizovací ceny, ve které je majetek oceněn v účetnictví. Odepisuje se jen do výše této ceny. Odpisy se účtují zpravidla měsíčně a zaokrouhlení výše odpisu je na celé koruny nahoru. Po sečtení každoročně provedených odpisů zjistíme tzv. oprávky. Oprávky představují sumu provedených odpisů u konkrétního majetku a jejich odečtením od pořizovací ceny zjistíme zůstatkovou cenu.

Záložka „Účetní odpis“ v činnosti Odpisovaný majetek poskytuje uživateli následující údaje:

¨ způsob odpisování - neodpisovat (tato volba je plně na rozhodnutí firmy)

- dle času (nutno uvést plánovaný celoživotní výkon odp. majetku v měsících)

- dle výkonu (nutno uvést plánovaný celoživotní výkon odp. majetku v měsících + roční výkon + MJ)

- dle daň. odp. – daňové odpisy se provádí 1x ročně, účetní odpisy lze měsíčně, ale jejich měsíční částka je odpovídající část daňového nároku. Poslední měsíc v účetním období je nutno provést nejprve roční daňový odpis a pak teprve účetní odpis za poslední měsíc v účetním období, program automaticky vyrovnává případný rozdíl.

- dle ČÚS 708 rovnoměrně – jedná se o způsob odepisování dlouhodobého majetku pro některé vybrané účetní jednotky, které vedou účetnictví podle Vyhlášky č. 410/2009 Sb.

¨ pořizovací cena – je automaticky naplněna z pohybu (události) pořízení odpisovaného majetku

¨ zůst. cena – je automaticky dopočítávána (pořizovací cena mínus suma dosud provedených odpisů u konkrétní karty odpisovaného majetku)

¨ plán. celož. výkon – uvádí se u účetních odpisů prováděných podle času a podle výkonu

¨ roč. výkon – uvádí se u účetních odpisů prováděných podle výkonu

¨ MJ - uvádí se u účetních odpisů prováděných podle výkonu

¨ snížení odpisu % - o uvedené procento se snižuje vypočtený účetní odpis

¨ odpis v měs. zař. – možnosti jsou Podle parametrů odp. majetku, Odepisovat, Neodepisovat. Standardně uživatel použije Podle parametrů odp. majetku, změní je pouze v případě, že pro konkrétní kartu, případně „druh“ karet chce použít jiný způsob než je uveden v Parametrech, které jsou společné pro účetní odpis všech karet.

¨ odpis v měs. vyř. – stejné jako předchozí atribut

V případě volby způsobu odepisování „dle ČÚS“ jsou potom pro uživatele dostupné ještě následující atributy:

¨ procento – určuje výši zbytkové hodnoty odpisovaného majetku. Majetek se odepisuje tak dlouho, dokud není dosaženo této hodnoty.

¨ měsíc/rok od – do – určuje období začátku a konce odepisování

Účetní odpis se provádí pomocí programovatelné šablony „účetní odpisy“. Uživatel v hlavním menu aktivuje činnost Nový proces – Odpisovaný a spravovaný majetek – proces „Dl. MO – účetní odpis měs.“.

Šablona účetních odpisů pracuje s pořizovací cenou k datu, tj. lze např. do budoucnosti zadat technické zhodnocení. Při výpočtu "účetních odpisů" šablonou je možné vybrat umístění, za které se má udělat odpis, (tj. je možné odepsat najednou skupinu majetku vymezenou jednotným umístěním) nebo vypočítat odpisy pro veškerý majetek přístupný (zápis) danému uživateli. Po stisku tlačítka OK jsou předplněny jednotlivé řádky s měsíčními účetními odpisy za karty odpisovaného majetku dle zvolené varianty.

Při opravách dat je nutno dát pozor na výpočet již vyřazených karet – šablony s kartami s příznakem „vyřazeno“ nepočítají.

Po stisku tlačítka OK jsou předplněny jednotlivé řádky s měsíčními účetními odpisy. Uživatel tyto pohyby (jednotlivé události odpisovaného majetku) zapíše (ikona disketa nebo klávesa ESC – následně volba Zapsat a ukončit). Poté se uživateli zobrazí možnost zaúčtování jednotlivých pohybů (událostí) účetního odpisu[1].

V případě, že uživatel potřebuje provést částečné vyřazení odpisovaného majetku a zároveň zachovat správnou funkčnost šablony účetních odpisů, musí použít typ „mimořádný odpis“ účetní (implicitně je předplněno typ běžný) [2] . Ten spouští nezávisle na měsíčních odpisech speciálním procesem ODVC01 DI.MO - částečné vyřazení.

[1] U každého uživatele to na základě jeho analytický účtů může být mírně odlišné, přesto obecné účtování účetních odpisů je ve stylu 551(MD)/07., 08. (Dal)

[2] Bližší popis k mimořádnému odpisu je uveden ve slovníku pojmů – pojem mimořádný odpis (vysvětleno i na konkrétním případu).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.01.2013


Pojem - Účetní případ

V IS BM jsou účetní případy podchycovány účetním zápisem. Účetním případem je každá skutečnost, která je předmětem účetnictví dle zákona 563/1991 Sb. Některé účetní případy spolu mohou úzce souviset, např. saldokontně (někdy je společně nazýváme saldokontní případ).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.09.2008


Pojem - Účetní výkazy

Výkazy má uživatel k dispozici v hlavním menu v činnosti Informační centrum – Výkazy – Výkazy ke spuštění – Účetní. S nákupem IS BM jsou standardně distribuovány tyto výkazy:

¨ Rozvaha v plném rozsahu

¨ Rozvaha ve zjednodušeném rozsahu

¨ Výkaz zisku a ztráty v plném rozsahu

¨ Výkaz zisku a ztráty ve zjednodušeném rozsahu

¨ roční výkaz Cash flow (u výkazu cash flow je nutno podotknout, že sestavení tohoto výkazu vyžaduje od uživatele detailnější evidenci v účetním deníku, případně v operativních evidencích)

Rozvaha je sestava aktiv a pasiv (porovnání majetku a zdrojů jeho financování k určitému datu) a podle zákona o účetnictví je povinnou součástí účetní závěrky.

Výkaz zisku a ztráty (někdy zkráceně Výsledovka) ukazuje, jakého hospodářského výsledku společnost dosáhla za sledované a minulé období. Výkaz zisku a ztráty je podle zákona o účetnictví povinnou součástí účetní závěrky.

Forma výkazu zisku a ztráty je v ČR upravena, používá se buď ve zkrácené nebo plné verzi. Zájemce z ní získá základní přehled o hospodaření společnosti, velikosti tržeb, nákladů v základním členění (materiálové, mzdové, odpisy…) a výši zisku či ztráty.

Výkaz o peněžních tocích neboli výkaz cash flow je součástí přílohy k účetní závěrce sestavované v plném rozsahu. Z hlediska potřeb podrobného zhodnocení finanční situace podniku a úrovně finančního řízení za dané období mají rozvaha i výkaz zisků a ztrát určitá omezení, a proto podniky sestavují cash flow jako součást přílohy k účetní závěrce.

Po volbě definice výkazu, tj. po spuštění vybraného výkazu z menu (Informační centrum – Výkazy – Výkazy ke spuštění – Účetní), je uživatel v dialogovém okně vyzván k zadání zpřesňujících volitelných požadavků, které ovlivňují informace zobrazené na výkazu, tzv. proměnných dotazu výkazu (např.: období – měsíc a rok od a měsíc a rok do, selektory, zaokrouhlení apod.), jejichž hodnoty se použijí jako aktuální hodnoty parametrů při vlastním sestavení výkazu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.09.2008


Pojem - Účetní zápis

V IS BM představuje zápis (záznam) do účetních knih tu část účetního dokladu, která vyjadřuje jeho reprezentaci formou účtů účtového rozvrhu; v terminologii IS BM se jedná o operaci komponenty účetnictví a její události.

Účetní zápis se do IS BM realizuje zápisem událostí v operaci komponenty účetnictví. Účetní zápis se v IS BM skládá z libovolného počtu položek se shodným číslem procesu (číslování dokladů). Tento zápis je ze strany IS kontrolován, takže musí splňovat tyto podmínky:

¨ podvojnost;

¨ platnost účtu;

¨ platnost selektorů;

¨ existující účetní období a otevřené období komponenty účetnictví;

¨ jednotnost data (pomocí uživatelského nastavení v transformaci je obvykle zajištěno, že v rámci jednoho dokladu při vytváření událostí účetního zápisu zůstává datum shodné. V některých případech je však nutné umožnit v rámci jednoho dokladu různé datum událostí. Toto se zajistí pomocí parametru účetnictví „povolit na účetním dokladu záznamy jednoho měsíce“.);

¨ budoucno – implicitně není povoleno účtování do budoucna. Toto je možné pouze v případě, že je v parametrech účetnictví nastaveno „povolit účtování do budoucna“. Zápis plánu do budoucna je povolen nezávisle na tomto parametru;

¨ jednotnost atributů „skutečnost – plán“ a atributů „otevření – běžné – uzavření“ (doporučujeme toto zajistit správným nastavením vstupní masky operace), tzn. pro každý druh operace v masce tento atribut správně nastavit pomocí konstanty a nastavit příznak editovat „ne“.

Účetní zápis se realizuje buď automatizovaně na základě již zaznamenaných údajů popisujících účetní případ (tj. v rámci procesu) nebo přímo (tj. obecný účetní zápis apod.).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.09.2008


Pojem - Účetní závěrka

Účetní závěrka je ze strany IS BM podporována těmito nástroji:

¨ výkazy

¨ uzavřením a otevřením účetních knih

¨ dokumenty (výroční zpráva, příloha), operace vývěsky „odeslání“ pro zveřejnění

¨ Mezinárodními standardy

Cílem účetní závěrky je poskytnout informace o finanční pozici, výkonnosti a změnách ve finanční pozici účetní jednotky, které jsou užitečné širokému okruhu uživatelů při tvorbě ekonomických rozhodnutí.

Mezi hlavní finanční výkazy účetní závěrky patří:

¨ Rozvaha (podává přehled o finanční pozici podniku)

¨ Výkaz zisku a ztráty (podává přehled o finanční výkonnosti podniku)

¨ Přehled o peněžních tocích (cash flow)

Účetní závěrka v podstatě představuje soubor výkazů, které se vystavují za dané účetní období k rozvahovému dni (rozvahový den je poslední den účetního období). Účetní závěrka může být:

¨ řádná (v rozvahový den) – dochází k uzavření účetních knih

¨ mimořádná (likvidace, zrušení konkurzem)

¨ mezitímní (na základě insolvenčního zákona) – není prováděna k rozvahovému dni, nejsou při ní uzavírány účetní knihy

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.09.2008


Pojem - Účtová skupina

Vyhláška č. 500/2002 Sb. definuje v příloze č. 4 Směrnou účtovou osnovu, která obsahuje čísla a názvy účtových skupin, které musí účetní jednotka respektovat. Příslušnost k účtové skupině identifikují první dvě číslice v obvykle trojmístném čísle účtu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 20.06.2008


Pojem - Účtový rozvrh

Je sestaven na základě Směrné účtové osnovy, představuje seznam všech účtů (syntetických i analytických) potřebných k zaúčtování všech účetních případů a k sestavení účetní závěrky v dané účetní jednotce, přičemž některé účty mohou být určeny pro vnitropodnikový pohled (analytické členění účtů), v IS BM může dále zahrnovat účty podrozvahové.

Účtový rozvrh je při dodávce informační systému z větší části naplněný. Každý uživatel si může účtový rozvrh (zejména jeho analytickou část) upravit podle vlastních firemních zvyklostí. U každého účtu se zadává jeho jednoznačná identifikace, název, strana (Má dáti nebo Dal, podle toho, zda je účet aktivní či pasivní), saldokontní (možnosti jsou Ano/Ne) a zda sledovat obrat v zahraniční měně (možnosti jsou Ano/Ne). Dalším atributem s možnou volbou Ano/Ne je „povinná částka v ZM“. Pro účty s nastavením tohoto atributu na Ano nelze zadat událost účetního deníku s daným účtem s nulovou částkou v zahraniční měně.

Při provádění určitého procesu, kde uživatel použije saldokontní účet, systém provádí kontrolu na účtový rozvrh a zjistí, jestli částka na události je plusová a tudíž hodnotu saldokonta zvyšuje nebo je minusová a hodnotu saldokonta snižuje. Aktuální hodnoty saldokonta jsou k dispozici u každého saldokontního účtu.

Jako další se nabízí atributy, které určují, zda se selektor uvedený na události účetnictví daného účtu promítá do obratové tabulky. Jsou to:

¨ sledovat obrat obchodního selektoru Ano/Ne

¨ sledovat obrat organizačního selektoru Ano/Ne

¨ sledovat obrat technicko-věcného selektoru Ano/Ne

Nejvhodnější se jeví používat sledování obratu za organizační selektor (v podstatě umožňuje sledovat obraty za střediska), sledování obratů za ostatní selektory by značným způsobem rozšiřovalo (a tím znepřehlednilo) hodnoty obratové tabulky. Přesto v případě, že uživatel provede jakoukoliv změnu v nastavení tohoto sledování obratů, je nutno provést přepočet obratové tabulky účetnictví.

Další vlastností, kterou je možnost nastavit pro každý účet účtového rozvrhu je:

¨ povinnost uvádět obchodní selektor v událostech účetnictví pro účet – volba Ano/Ne

¨ povinnost uvádět organizační selektor v událostech účetnictví pro účet – volba Ano/Ne

¨ povinnost uvádět technicko-věcný selektor v událostech účetnictví pro účet – volba Ano/Ne

Pokud je pro daný účet nastavena povinnost uvádět selektor v událostech účetnictví, pak při vytváření událostí účetnictví nebude možné zapsat událost s hodnotou selektoru neurčeno (‘-’).

U každého účtu je navíc možno nastavit datum jeho platnosti od - do. Pokud je toto datum u účtu nastaveno, je možno s tímto účtem aktivně pracovat pouze v tomto uvedeném období. Je možno využívat tento účet při přípravě předkontací, ale účtování je systémem kontrolováno na nastavené období platnosti. Pokud není nastavena žádná platnost účtu, není jeho používání samozřejmě ničím omezeno.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 17.02.2012


Pojem - Událost

V informačním systému BM je reprezentantem změny stavu věcí v reálném světě. Mezi její základní vlastnosti patří:

¨ časový okamžik, kdy tato změna nastala (v IS obvykle datum)

¨ výčet logických věcí, kterých se týká (aktér, artikl, alokace)

¨ míra změny (numerické hodnoty, např. částka, množství)

¨ atributy autorizace

¨ jiné zpřesňující údaje obvykle různé podle komponent.

Význam uvedených vlastností (resp. atributů) je různý dle komponent i dle implementačního záměru.

Události, které jsou si věcně i časově blízké mohou být v IS BM seskupovány do operací. Dle definic souvisejících s druhem informace události aktualizují hodnoty (obraty atd.).

Události patří mezi základní entity každé komponenty, obvykle jsou to objekty. Jejich vstup je řešen vstupem (naplněním) operací v rámci procesů včetně užití nástrojů pro automatizaci vstupu. Přístup k nim je řízen dle práv uživatele k druhům operací a k alokacím.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Události vymáhání

Události vymáhání zobrazují uživateli procesně navstupované události, nelze je vstupovat samostatně.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.01.2013


Pojem - Uchovat

Na záložce výběr je pro uživatele dostupný funkční přepínač „uchovat“, který způsobí to, že výběr, který si uživatel právě nadefinoval bude uchován a při příštím spuštění dané činnosti bude automaticky takto předplněn. Na atributu „uchovat“ je navíc možno po stisku pravého tlačítka myši vyvolat:

¨ výběr s novým vstupem

¨ zrušit uchovaný výběr – automaticky zruší nastavený výběr, tzn. všechny atributy ve výběrové záložce jsou prázdné

¨ definovat výběry vstupem – zde se jednotlivé dostupné výběry vstupem definují

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 12.02.2014


Pojem - Uchovávat pozici oken

Tento atribut je součástí činnosti „parametry formuláře“ a „parametry uživatele“ a týká se možnosti zaznamenat pozice oken formulářů pro jednotlivé uživatele systému tak, že při následujícím spuštění daného formuláře je jeho okno zobrazeno v poslední zaznamenané pozici. Způsob zaznamenávání pozice okna formulářů je dán právě kombinací nastavení atributů v obou těchto činnostech.

Ve formuláři Parametry uživatele se v této souvislosti uvádí parametr „uchovávat pozice oken“ s těmito možnostmi:

¨ Nikdy

¨ Ne

¨ Ano - automaticky vždy při uzavření okna

¨ Ano - při nastavení parametrů formuláře

¨ a parametr „uchovávání pozice okna ve vztahu k rozlišení obrazovky“ – při uchovávání pozice okna formuláře je možno zaznamenávat i aktuální rozlišení monitoru uživatele. Možnosti nastavení jsou:

- přepočítávat pozice poměrem aktuálního rozlišení obrazovky – uživatel si uchová pozici okna formuláře (na svém PC) a při spuštění daného formuláře na jiném PC (tzn. s jiným rozlišením monitoru) systém automaticky přepočítává:

- umístění levého horní rohu okna v pixelech v ose X = [uložená pozice] * [uložené rozlišení v ose X] / [aktuální rozlišení v ose X]

- výška okna v pixelech = [uložená výška] * [uložené rozlišení v ose X] / [aktuální rozlišení v ose X]

- umístění levého horní rohu okna v pixelech v ose Y = [uložená pozice] * [uložené rozlišení v ose Y] / [aktuální rozlišení v ose Y]

- šířka okna v pixelech = [uložená šířka] * [uložené rozlišení v ose Y] / [aktuální rozlišení v ose Y]

- zvlášť pro různá rozlišení obrazovky

Ve formuláři Parametry formuláře se v této souvislosti uvádí parametr „uchovávat pozice oken“ s těmito možnostmi:

¨ Ne

¨ Ano - automaticky vždy při uzavření okna (dále varianta 1)

¨ Ano - při nastavení parametrů formuláře (dále varianta 2)

¨ Podle nastavení parametrů uživatele

Výsledné chování IS BM z hlediska uchování pozice oken vyplývá z nastavení těchto parametrů. V činnosti „parametry formuláře“ při nastavení atributu „uchovávat pozice oken“ = podle nastavení parametrů uživatele se pak systém chová podle nastavení atributů „uchovávat pozice oken“ a „uchovávání pozice okna ve vztahu k rozlišení obrazovky“ v činnosti „parametry uživatele.

Automatické uchování pozice okna probíhá vždy při uzavření daného okna formuláře nebo při nastavení parametrů formuláře nebo při ukládání pozice okna funkcí „uchovat pozici okna formuláře“ v menu Obecné.

Funkci v menu Obecné – Uchovat pozici okna formuláře – je možné použít v případě, že:

¨ atribut „uchovávat pozice oken“ v činnosti parametry uživatele je různý od možnosti „Nikdy“

¨ dané okno formuláře není maximalizované

¨ dané okno formuláře není minimalizované

¨ pozice daného okna není ukládána automaticky

K obnovení uchované pozice okna při spuštění formuláře dochází, pokud to vyplývá z obou parametrů nastavení parametrů formuláře (varianta 1 a 2) a přitom platí:

¨ atribut „uchovávat pozice oken“ v činnosti parametry uživatele je různý od možnosti „Nikdy“

¨ obnovovaná pozice okna je taková, že umístění levého horního rohu okna v pixelech v ose X je v intervalu mínus 10 pixelů až šířka nadřízeného okna v pixelech mínus 50 pixelů

¨ obnovovaná pozice okna je taková, že umístění levého horního rohu okna v pixelech v ose Y je v intervalu mínus 10 pixelů až výška nadřízeného okna v pixelech mínus 50 pixelů

Výška okna formuláře se obnovuje pouze v případě, že je možné libovolně měnit výšku jeho okna až do výšky nadřazeného okna. Šířka okna formuláře se obnovuje pouze v případě, že je možné libovolně měnit šířku jeho okna až do šířky nadřazeného okna.

Automatické uchování pozice okna neproběhne v případě, že:

¨ atribut „uchovávat pozice oken“ v činnosti parametry uživatele se rovná Nikdy

¨ uzavírané okno je maximalizované

¨ uzavírané okno je minimalizované

¨ umístění levého horního rohu okna v pixelech v ose X není v intervalu mínus 10 pixelů až šířka nadřízeného okna v pixelech mínus 50 pixelů

¨ umístění levého horního rohu okna v pixelech v ose Y není v intervalu mínus 10 pixelů až výška nadřízeného okna v pixelech mínus 50 pixelů

Pozice okna se obvykle uchovává jedinečná pro daný formulář s výjimkou:

¨ formuláře spuštěné operace komponenty – zde se ukládají pozice zvlášť pro každý druh operace

¨ formuláře Stromu hlavního procesu – zde se ukládají pozice zvlášť pro každý druh hlavního procesu

¨ formuláře Spojených dokumentů – zde se ukládají pozice zvlášť pro každý druh objektu, ke kterému jsou dokumenty připojeny

¨ formuláře Volné karty – zde se ukládají pozice zvlášť pro každou volnou kartu

¨ formuláře Obecného stromu – zde se ukládají pozice zvlášť pro každý obecný strom

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 21.04.2008


Pojem - Ukončení činnosti

Ukončení činnosti je možno v IS BM provést několika způsoby:

¨ příslušnou ikonou v panelu nástrojů

¨ klávesou ESC

¨ volbou „konec“ na záložce Volby

¨ křížkem v pravém horním rohu

¨ klávesou Alt F4 (při zatrženém příznaku „povolit ukončit“ v parametrech uživatele)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 09.10.2007


Pojem - Ukončení operace

Způsob ukončení operace se nastavuje ve vlastnostech uzlu v diagramu procesu. Každou fyzickou operaci je tedy možno ukončit těmito způsoby:

¨ automaticky ukončit – po zapsání událostí dané operace a následném stisku klávesy ESC se systém automaticky dotazuje „ukončit operaci“. Pokud je daná operace první operací v uzlu typu proces, po zapsání událostí se z nabídky může vybrat volba „Zapsat a ukončit“.

¨ automaticky neukončovat – po stisku klávesy ESC systém opustí formulář operace bez dotazu na ukončení operace a přestože uživatel zvolí „Zapsat a ukončit“ v případě první operace procesu, operace se automaticky neukončí. Ukončit operaci je pak možné z menu Obecné volbou činnosti „Ukončit operaci“. V tomto případě je nutno uživatele upozornit, že po opětovném spuštění automaticky neukončené operace a následném stisku klávesy ESC se systém nedotazuje, zda „opravdu ukončit operaci“. V tomto případě je chování systému mírně nestandardní, nicméně operaci je možno ukončit pouze volbou Ukončit operaci z menu Obecné. Problém při tomto způsobu ukončování je pouze u operací, které mají nastaveno spouštět na pozadí. Tyto operace se totiž ukončí i přesto, že je zde nastaveno automaticky neukončovat.

¨ automaticky ukončit předběžně – tento způsob ukončení je ve své podstatě shodný s prvním, pouze s tím rozdílem, že daná operace nabude stav, že byla ukončena předběžně. V kódu po ukončení operace je navíc možno testovat, zda je nebo není operace ukončována předběžně a zároveň je možno určit, zda operace má nebo nemá být ukončena předběžně.

V menu Procesy a operace – Operace, kde jsou k dispozici všechny uzly (operací i procesů), je možno zhlédnout přehled všech fyzických operací i s jejich aktuálními stavy (pokud uživatel ve výběru zadá komponentu „procesy“ má možnost vidět stavy uzlů typu proces). Stavy jednotlivých operací jsou k dispozici rovněž i v diagramu procesu, kde u každého uzlu typu operace je zaškrtávátkem určeno, v jakém stavu uzel typu operace v dané chvíli je. Strom hlavního procesu stav uzlu signalizuje pomocí příznaku (nebo-li značky) před názvem operace (svíti-li červená, je operace připravena, svítí-li zelená, je operace zahájena, je-li u operace křížek, je ukončena) nebo si stav operace může uživatel zjistit ve vlastnostech operace – po stisku pravého tlačítka myši.

Operace se automaticky ukončuje rovněž v případě, že ve vlastnostech operace v diagramu procesu má nadefinováno spuštění na pozadí.

Ukončení operace je okamžikem, kdy:

¨ vazby z ní vedoucí mohou uvést cílové uzly do stavu připravena (viz. též ukončení uzlu),

¨ je spuštěn kód po ukončení operace, který může modifikovat diagram procesu, validovat data operace, ...

¨ je spuštěn případný tisk (zjednodušeného) dokladu

¨ probíhá případný test mírou plnění

¨ je aktualizována hodnota semaforu.

Ukončit operaci může vždy jen uživatel nebo skupina uživatelů, kteří mají k danému druhu operace nadefinováno příslušné přístupové právo.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Ukončení procesu

Každý fyzický proces lze považovat za ukončený z několika hledisek dle implementačního záměru:

¨ saldokonto – tato možnost přímo souvisí s druhem nadefinovaných saldokontních hodnot, které se vždy vztahují k hlavnímu procesu. Pokud v hlavním (fyzickém) procesu existují nenulové saldokontní hodnoty, lze tento proces z určitého pohledu považovat za nedokončený. Pokud jsou saldokontní hodnoty procesu nulové, je možno považovat proces z hlediska saldokonta za ukončený. Využívá se ve výběrech uzlů (činnost Operace) a ve výběrech procesů (činnost Nedokončené procesy).

¨ obsahuje operaci "ukončuje proces" – pokud je v diagramu procesu nadefinován uzel typu operace s vlastností „ukončuje proces“ a tento uzel je při běhu procesu skutečně ukončen, je rovněž celý proces považován za ukončený (viz. též ukončení uzlu). Využívá se v činnostech uvedení do stavu připravena, vazba uzlů (zdrojový uzel je proces).

¨ semafor - proces se z tohoto hlediska jeví jako ukončený v případě, když je hodnota semaforu rovna nule, tj. když jsou ukončeny všechny operace, u kterých je nastavena kladná nebo záporná aktualizační hodnota semaforu. Pokud ve vlastnostech uzlu typu proces není nastavena žádná hodnota semaforu procesu, tzn. atribut uzlu semafor procesu je prázdný, systém pak tyto procesy z hlediska aktualizace semaforů nebere v potaz a považuje je za ukončené, uzel typu proces se přičte/odečte jen první a aktualizuje hodnotu semaforu při zahájení). Využívá se ve výběrech procesů (činnost Procesy - procesy s aktivním semaforem).

¨ obecný výběr – v definici obecného výběru si uživatel může zadat, že pokud proces dosahuje určité hodnoty (zadáno výrazem), lze ho z hlediska tohoto obecného výběru považovat za ukončený.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Ukončení uzlu

Pojem ukončení uzlu má význam pouze z hlediska vlivu na řídící tok procesu, tj. kdy ukončení zdrojového uzlu diagramu procesu ovlivňuje stav cílových uzlů (přispívá k uvedení do stavu připravena).

Uzel typu operace je považován za ukončený vždy, je-li operace ve stavu ukončena. Pokud je ve stavu ukončena předběžně, je považována z tohoto hlediska za ukončenou pouze tehdy, nemá-li cílový uzel nastaveno "po nepředběžném ukončení předchozích operací".

Aby uzel typu proces mohl být považován z hlediska dané vazby za ukončený, musí být ukončena operace, která je v dané vazbě definována jako zdrojová. V případě, že je v této vazbě nastaveno "po ukončení procesu", musí dále obsahovat ukončenou operaci s vlastností "ukončuje proces". Zde je důležité si uvědomit, že proces není ve stavu ukončený.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Uložená procedura

Nástroj databázového serveru nesoucí programový kód pro aktualizaci dat (např. přepočet aktuálních hodnot), který se aktivuje:

¨ na základě uživatelského rozhodnutí, tj. spuštěním určité funkce IS

¨ vyvoláním z triggeru

Je vždy součástí programového kódu poskytnutého IS.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - ULR odkazy v tabulkách

Jedná se o vlastnost pohledu (ve SD), která se uplatňuje pouze tehdy, je-li pohled aplikován v prvku web (přímo, zprostředkovaně doplněným oknem nebo ULR odkazem z jiného pohledu).

Definice se skládá z:

¨ identifikace pohledu, na který je odkazováno,

¨ identifikace atributu, kliknutím na nějž se uvedený pohled spustí (spouštěcí atribut),

¨ definice relace (výběru) do dat odkazovaného pohledu.

Tato definice umožňuje při prohlížení relevantních dat web browserem zobrazit data definovaná zde uvedeným pohledem kliknutím na zde uvedený atribut.

Příklad:

09HIMQ-ad01adsat-ad01id[1]=ad01id, uvedený ULR odkaz umožní spustit kliknutím na atribut názvu adresáta (ad01adsat) pohled s identifikací 09HIMQ (v tomto případě adresář) s výběrem těch dat, která splňují podmínku, že ID adresáta (ad01id) v odkazovaném pohledu se rovná IS adresáta, který je v záznamu (nemusí být zobrazen, ale musí být v prostředí pohledu), na který se kliká.

POZOR: spouštěcím atributem nesmí být atribut Napojení na ULR, resp. implicitní.

[1] Atribut entity v pohledu 09HIMQ

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Umístění

viz. pojem alokace

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.10.2007


Pojem - Update v importu/exportu

Update v importu/exportu umožňuje hromadně měnit některá již zapsaná data u činností typu seznam (např. u vybraných adresátů hromadně změnit jejich kategorii) nebo v událostech jednotlivých operací (události by se měli nacházet v dosud neukončených operacích, např. hromadná změna data nebo selektoru apod.).

Definice importu/exportu byla tedy pro uživatele rozšířena o možnost typ „update“. Pro tento typ se definuje v činnosti "konverze atributů" parametr "klíč pro Update". Takto definovaný import/export/update nepřidává ani neexportuje záznamy, nýbrž mění obsah dat aktuálně zobrazených záznamů a přitom mezi zobrazenými záznamy vyhledává ty, které mají stejnou hodnotu v atributech uvedených v seznamu "klíč pro Update". Pokud je prováděn update na první záložce formuláře (tj. dané činnosti), potom jsou změněné záznamy v hlavní mřížce formuláře zobrazeny se šedivým podkladem. Bezprostředně po update nejsou data ještě zapsána, zápis provádí uživatel běžným způsobem jako by změny dat provedl sám (tj. disketou nebo volbou "Ano" po ESC).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Uplatnění předmětů zdanitelného plnění

V této činnosti má uživatel samostatně k nahlédnutí číselník jednotlivých uplatnění předmětů zdanitelného plnění (viz obr. 23). Uplatnění předmětů zdanitelného plnění jsou nedílnou součástí definice vlastních typů zdanitelného plnění, které pak vstupují v událostech DPH a jsou podkladem pro vytvoření daňového přiznání DPH.

Pro uplatnění předmětů a jejich uživatelské úpravy platí následující pokyny:

¨ uplatnění, která mají v atributu poznámka uvedeno konkrétní číslo řádku lze uživatelsky doplnit pouze na základě pokynů správce IS BM v souvislosti se změnami zákona o DPH, případně definice daňového přiznání

¨ uplatnění, která mají v atributu poznámka uvedeno „pro obchod“ lze libovolně uživatelsky modifikovat (tj. ta, která nikdy nevstupují do daňového přiznání)

Po aktivaci této činnosti (hlavní menu – DPH – Uplatnění předmětů zdanitelného plnění) se uživateli jako první nabídne nejprve záložka „výběr“, kde si může podle jednotlivých výběrových atributů zvolit množinu dat, kterou chce mít následně k dispozici. Vybírat lze např. podle: paragrafu, předmětu, typu zdan. plnění, typu místa, platnosti atd.

Pro ještě podrobnější vyhledávání má uživatel k dispozici i možnosti, které mu nabízí obecný výběr:

¨ dle řádku v poznámce – uživatel má možnost vyhledávat podle přesného čísla řádku DPH přiznání, které má uvedeno u jednotlivých uplatnění v atributu „poznámka“

¨ poznámka – uživatel má možnost vyhledávat podle komentáře, který má uveden u jednotlivých uplatnění v atributu „poznámka“ (doporučení - „%text“ nebo „%číslo“)

Po potvrzení záložky „výběr“ se uživateli nabídne číselník, kde má k dispozici následující atributy:

¨ paragraf – číslo paragrafu. Paragraf je uváděn jako jedna z teoretických možností, nejde o kompletní výčet paragrafů příslušného plnění.

¨ předmět – identifikace předmětu zdanitelného plnění, výběr z překryvného seznamu. Počet uvedených předmětů je ovlivněn příslušným zněním zákona o DPH a verzí konkrétního přiznání k dani z přidané hodnoty.

¨ typ místa – tuzemsko/zahraničí/EU

¨ plátce DPH – příznak plátce DPH – Ano/Ne/Nerozhoduje/Neurčeno

¨ O/N – zda se dané uplatnění týká odpočtu či nápočtu

¨ typ zd.pl. – identifikace a název typu zdanitelného plnění

¨ účet – platný účet z účetní osnovy minimálně na úrovni syntetiky účtu. Analytické účty je třeba doplnit dle konkrétního účetního rozvrhu jednotlivých uživatelů.

¨ tech. sel. – identifikace technického selektoru

¨ klasif.art. – identifikace klasifikace objektu artiklu

¨ platnost od – do – datum platnosti od a datum platnosti do daného uplatnění

¨ poznámka – přesný popis uplatnění. Je zde uvedeno číslo řádku přiznání DPH, do kterého se právě toto uplatnění = konkrétní kombinace jednotlivých atributů – započte, samozřejmě v závislosti na vzorech tiskopisu Přiznání k dani z přidané hodnoty. Z toho vyplývá, že se jedná v podstatě o nejdůležitější informaci pro korektní zadávání daňových dokladů.

Důležitými atributy na je uvedení čísla paragrafu a v poznámce uvedení přesného popisu, do kterého řádku daňového přiznání daný paragraf vstupuje (tzn. hodnotu jakého řádku daňového přiznání ovlivňuje). Pro platné znění daňového přiznání od vzoru č. 15 a dále je nutno mít v atributu poznámka řádek uveden ve tvaru „=ř. xy“.

Čísla paragrafů uvedená v této činnosti slouží jako vodítko, nejedná se o plný a přesný výčet paragrafů z hlediska Zákona od DPH.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 23.03.2010


Pojem - Uvedení uzlu do stavu připravena

Uzel diagramu procesu je uveden do stavu připravena:

1. Vlivem běžných a samostatných vazeb operací do daného uzlu směřujících takto:

¨ běžná – cílový uzel je uveden do stavu připravena, jsou –li ukončeny všechny zdrojové uzly, ze kterých vedou běžné vazby do cílové operace (simulace logického slučovacího AND z hlediska řídícího toku procesu)

¨ samostatná – cílový uzel je uveden do stavu připravena po ukončení zdrojového uzlu bez omezujících podmínek danými jinými vazbami (simulace logického slučovacího OR z hlediska řídícího toku procesu).

¨ výběrová – stejný vliv jako běžná

V případě vazby proces-proces je cílový uzel uveden do připravena prvním zdrojovým procesem.

Pokud je více zdrojových uzlů, které se ukončují předběžně, a následující cílový uzel má ve vlastnostech nastaveno „spouštět po nepředběžném ukončení předchozích operací“ tak se spustí (resp. je uvedena do stavu připravena a uložena do zásobníku) tehdy, pokud je „konečně“ ukončen alespoň jeden z daných zdrojových uzlů (tj. logický AND daný běžnými vazbami se neuplatní).

2. Definicí "ACTIVATE..." v kódu po ukončení operace

3. Spuštěním činnosti "zrušit stav ukončena".

Připravené uzly jsou ukládány do zásobníku operací, odkud jsou automaticky spuštěny, pokud je u operace nastaveno spouštět "automaticky" a uživatel má k dané operaci přístupové právo nebo je u operace nastaveno spouštět "na pozadí".

Pořadí ukládání do zásobníku je ovlivňováno pořadím vazby uzlů diagramu procesu.

Připravené uzly jsou obvyklým nástrojem pro řízení work-flow, ať již prostým výběrem v činnosti Operace nebo definicí položky uživatelského menu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.04.2004


Pojem - Uzávěrka mezd

Tato činnost (a její help) je v podstatě společná pro několik činností z komponenty mzdy. Jedná se o:

¨ uzávěrku mezd, která se aktivuje z hlavního menu Mzdy – Mzdy – Uzávěrka mezd a její podrobný popis je uveden níže

a další činnosti, které se aktivují z menu Mzdy – Speciální činnosti a v podstatě provedou pouze vždy přepočty, které se vztahují k názvu dané činnosti. Jedná se o tyto činnosti:

¨ zákonné pojištění odpovědnosti

¨ přepočet průměrů (hodinový, denní, měsíční)

¨ zjištění pravděpodobného průměru

Přepočet průměrů provede současně i uzávěrka mezd, tzn. že není nutné tuto činnost pouštět samostatně, pokud máme v plánu pustit uzávěrku mezd. Výpočet zákonného pojištění odpovědnosti a zjištění pravděpodobného průměru je však nutno aktivovat jako tuto samostatnou činnost, uzávěrka mezd s těmito údaji nepracuje.

Uzávěrku lze provést pouze v případě, že od posledního výpočtu mezd nebyla provedena žádná změna. Uzávěrka mezd pak definitivně zablokuje údaje daného měsíce pro vkládání dalších údajů. Po jejich uzavření není možné do nich znovu zasahovat, měnit jejich položky a nechat je znovu počítat. Záznamy mezd uzavřeného měsíce nelze tedy vkládat, opravovat ani rušit.

Nejschůdnější variantou je uzavírat mzdy až po jejich vyplacení, nejlépe až před výpočtem mezd za následující období. Uzávěrku mezd má uživatel k dispozici v hlavním menu mzdy – mzdy – uzávěrka mezd. Po aktivaci této činnosti se systém dotazuje „Opravdu chcete spustit uzávěrku mezd za měsíc … a rok ……? Možnosti jsou Ano – Ne. Některé akce provádí uzávěrka každý měsíc, některé pouze jestliže končí čtvrtletí.

Uzávěrka měsíčně provádí tyto akce :

¨ odečtení zůstatku dovolené

¨ pro všechny nemocenské dávky, které měly nastaveno Proplatit = Ano se nastaví Proplaceno dne a Proplatit se nastaví na Ne

¨ snížení zůstatku půjčky o uhrazenou částku

¨ aktualizaci data posledního zpracování mezd

¨ zápis do Historie karty

¨ zápis do Historie pracovního poměru

- jedná se o stav atributů „zůstatek staré dovolené“ a „zůstatek nové dovolené“ k prvnímu dni uzavíraného měsíce, tj. před započtením čerpání dovolené v uzavíraném měsíci, např. údaj pro měsíc a rok 03/2007 udává stav dovolených k 1.3.2007)

- aktualizace atributů „zůstatek staré dovolené“ a „zůstatek nové dovolené“ podle počtu dní, které byly v uzavíraném měsíci čerpány

Uzávěrka čtvrtletně provádí (pouze pro každého pracovníka a jeho pracovní poměr, který ke konci čtvrtletí trvá) :

¨ výpočet průměrného výdělku - hodinový, denní a měsíční průměr

Uzávěrka za měsíc PROSINEC aktualizuje tyto atributy:

¨ do atributu „převod dovolené do příštího roku“ se zapíše součet „zůstatku staré dovolené! a „zůstatek nové dovolené“ k datu 31.12.

¨ do atributu „zůstatek staré dovolené“ se zapíše tentýž součet „zůstatku staré dovolené“ a „zůstatku nové dovolené“ k datu 31.12.

¨ do atributu „zůstatek nové dovolené“ se zapíše počet dní, který je uveden v atributu „roční nárok na dovolenou“, tzn. že před provedením uzávěrky za prosinec je nutno mít v pořádku roční nároky na dovolenou na následující rok.

V případě nesrovnalostí zapíše uzávěrka tyto údaje do protokolu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 06.05.2009


Pojem - Uzavření účetních knih

Uzavření účetních knih je činnost, která v souladu s ČÚS pro podnikatele č. 002, provede účetní zápisy, kterými uzavře účty hlavní knihy.

Uzavření účetních knih v IS BM úzce souvisí s účetní závěrkou. Při provádění účetní závěrky dojde k uzavření účtů podle zákonem dané předkontace. Ke dni uzavření účetních knih systém spočítal určitý konečný zůstatek účtů.

Při závěrce systém tyto zůstatky vynuluje a zaúčtuje podle nastavených předkontací v šabloně. Závěrka vyčíslí zisk nebo ztrátu a následně je zaúčtuje. Při závěrce se obraty účtů (v obratové tabulce) načítají do zvláštního 13-tého měsíce, tzn., že obraty 12-tého měsíce nijak neovlivní. Běžně se závěrka provádí k 31.12., ale je možno, že uživatel ji bude potřebovat provést i během roku (např. konkurz nebo likvidace firmy).

Pro uzavření účetních knih slouží proces v nabídce Nový proces – Účetní zápisy – Prvotní evidence – Uzavření účetních knih. Tento proces se případně použije i pro uzavření podrozvahové evidence.

Po aktivaci procesu „uzavření účetních knih“ se nabídne šablona (Ctrl F3), která nabízí obdobné možnosti jako otevření účetních knih, tj. období, druhu, možnost výběru otevření účtů po jednotlivých účetních selektorech či kumulaci bez ohledu na selektory a dále volbu zápisu na účty účtové třídy 7. k uzavíraným účtům 1:1 nebo agregovaně. Měnu lze vypsat a nadále se tato měna nabízí při opakovaném využití této šablony. V případě potřeby uzávěrky účtů i v cizích měnách je možné uzavírat účty po jednotlivých měnách nebo za všechny měny najednou (nevyplnění nabídky Měna).

Pro uzavření účtů podrozvahové evidence se používají stejné procesy jako pro běžné uzavření účetních knih (tzn. Nový proces – Účetní zápisy – prvotní evidence) s tím rozdílem, že se nevyužívá možností šablony, ale nadefinovaného importu. Uživatel si aktivuje proces uzavření účetních knih – zvolí menu Obecné – Import/Export dat a variantu „Uzavření podrozvahových účtů“ požadovaného roku a měny. Při standardním provozu by mělo platit, že uživatelé spouští procesy pro uzavření účtů 0 až 6 a další procesy pro uzavření podrozvahových účtů – každý pouze jednou.

Systém umožňuje uzavření účetních knih provést automaticky pomocí šablony pouze jednou za účetní období. V případě potřeby opakovaného uzavření účetních knih je nutno původní operaci uzavření odblokovat (storno neprovádět) a znovu zadat správně (v případě nejasností je toto nutno řešit ve spolupráci s pracovníky IT BM Servis s.r.o., kteří provedou ruční zásah do systému).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.09.2008


Pojem - Uzel procesu

Jedná se o každé okénko (rámeček, „chlíveček“), které je zobrazeno v diagramu procesu a k němuž je vztažena minimálně jedna vazba. Na základě vazby se může jednat o cílový nebo o zdrojový uzel. Chování cílového uzlu souvisí s nastaveným způsobem jeho spuštění.

Uzly fyzického procesu jsou založeny v okamžiku zápisu událostí jeho první operace. Přehled všech uzlů fyzického procesu je k dispozici v činnosti Procesy a operace - Operace (správně by se měla jmenovat „přehled uzlů“). Uzly procesu má uživatel k dispozici pokud ve výběru zadá jako komponentu procesy.

Uzly diagramu druhu procesu lze rozdělit na uzly reprezentované druhem operace a uzly reprezentované druhem procesu. Uzly diagramu fyzického procesu lze rozdělit na uzly - operace a uzly, které představují jakési schránky, do kterých jsou ukládány fyzické procesy, jejichž druh je předepsán uzlem (schránkou).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.04.2004


Pojem - Uzly vývěsky

Tato činnost slouží k usnadnění přístupu k vybraným záznamům vývěsky. Uživatel ji má k dispozici v menu Marketing – Vývěska –Uzly vývěsky. V okně významných uzlů je možno zobrazovat pouze ty záznamy, které byly vytvořeny pomocí objektových vazeb, neboť se zde využívá vzájemně vytvořené vazby otec – syn. Do okna významných uzlů se přenese vybraný záznam typu otec, po jeho aktivaci se však zobrazí všechny jeho záznamy typu „syn“. Mezi významné uzly vývěsky se dají přesunout pouze záznamy vývěsky typu „otec“ (neboli předchůdce), nikoliv záznamy vytvořené pomocí objektové vazby typu „syn“ (čili následník). Pokud má tedy uživatel např. nějaký obchodní případ, je vhodné si vytvořit záznam na vývěsce s názvem např. obchodní případ a pomocí objektových vazeb k němu pak vytvářet další vznikající záznamy (tj. události obchodního případu). Výhodou uzlů vývěsky pak je, že po aktivaci daného uzlu „obchodní případ“ se všechny záznamy typu „syn“ zobrazí najednou, tzn. uživatel je má všechny v danou chvíli k dispozici. V případě, že by tyto záznamy neměl sjednocené pomocí uzlu vývěsky, musel by je jednotlivě vyhledávat na kompletní vývěsce.

Při prvním spuštění uzlů vývěsky se uživateli zobrazí prázdné okno této činnosti. Záznam vývěsky typu „otec“, který chce uživatel přesunout do uzlů vývěsky si nejprve vyhledá v činnosti kompletní vývěska (menu Marketing – Vývěska – Kompletní vývěska). Tento záznam musí být aktivní, tzn. je na něm umístěn kurzor, zároveň má uživatel otevřeno i okno uzlů vývěsky. Pak na kompletní vývěsce uchopí (levé tlačítko myši a držet) ikonu stromeček v levém dolním rohu okna činnosti kompletní vývěska a přetáhne tento stromeček do okna činnosti uzly vývěsky, kde tuto ikonu pustí. Tím se do okna činnosti přenese odkaz na daný záznam z kompletní vývěsky a po jeho aktivaci v uzlech vývěsky se mu zobrazí právě záznamy typu „syn“ k němu vytvořené.

V případě, že uživatel už má některé uzly vývěsky vytvořeny, po aktivaci této činnosti se mu zobrazí okno, kde jsou uzly vývěsky zobrazeny ve formě „ikon“ s popisem.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Uživatel (informačního systému Bílý Motýl)

Uživatel je nositel určitého práva (ne)přístupu k IS. Uživatelé se definují v činnosti "Uživatelé programu". Exkluzivní uživatelé jsou "SPRÁVCE" a "SYSTÉM".

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Uživatel (obchodní partner BM Servis s.r.o.)

Uživatel (ve smyslu obchodní partner) je ta právnická či fyzická osoba, která uzavřela s firmou BM Servis s.r.o. smlouvu o poskytování IS (obvykle IS Bílý Motýl).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.10.2007


Pojem - Uživatelé programu

Uživatelé programu je činnost IS BM, kde jsou k dispozici všichni uživatelé programu, tj. aktivní i neaktivní, a kde jsou zároveň k dispozici informace o skupinách uživatelů, skupině uživatele a přístupech k věcem. Je dostupná v menu SYSTÉM – činnost „uživatelé programu“.

Při aktivaci této činnosti se uživateli nejprve zobrazí výběrová záložka.

Zadání nového uživatele do IS BM se provádí po stisku F3 nebo příslušné ikony pro vstup nového záznamu v panelu nástrojů. Poté je správce (nového uživatele by měl zařazovat správce systému) vyzván k zadání rodného čísla nového uživatele. Po jeho zadání systém automaticky vygeneruje identifikaci uživatele (kombinace písmen a číslic) a tuto identifikaci zároveň předplní i do atributu „počáteční heslo“. V případě, že správce nemá rodné číslo uživatele k dispozici, může výzvu k zadání rodného čísla ignorovat, tzn. klávesou ESC zrušit a systém rovnou přeskočí kurzorem do atributu identifikace uživatele, který si v tomto případě správce vyplní sám. Další atributy, které se při vstupu nového uživatele zadávají jsou:

¨ jméno – tímto jménem se uživatel přihlašuje k IS, je prezentováno při zobrazení autorizace záznamů, je obvykle dostupné v položkách zahrnutých do předloh výstupů nad událostmi,

¨ úplné jméno – lze je doplnit do předloh výstupů,

¨ počáteční heslo – heslo pro přihlášení k IS, které je uživateli automatizovaně přiděleno, on si je následně změní sám, případně má správce možnost opakovaného nastavení tohoto hesla inicializací hesla (v případě potřeby je možno nastavením příslušného parametru evidovat hash heslo uživatele),

¨ e-mail – zde uvedená e-mailová adresa je využita jako adresa odesílatele při odesílání mailu z IS BM,

¨ telefon – telefonní spojení na uživatele,

¨ jazyk – IS se prezentuje (je spuštěn) v tomto jazyce danému uživateli,

¨ práva správce – uživatel bude mít přidělena specifická práva správce,

¨ právo odblokování – uživatel bude mít právo provést odblokování IS po jeho zablokování jiným uživatelem na daném PC,

¨ aktivní uživatel – uživateli je umožněno se přihlásit k IS,

¨ povolena změna hesla – uživatel je oprávněn měnit své přístupové heslo,

¨ explicitní web menu – v případě aplikace web serveru a přístupu k IS daného uživatele pomocí internetového browseru bude mít uživatel přístup pomocí zde uvedené definice web menu,

¨ význam – význam obecné předkontace spojený s daným uživatelem.

Po stisku záložky "skupiny uživatelů" má správce k dispozici tabulku, ve které je zobrazen seznam všech skupin a je zaškrtnuta skupina, ve které je zařazen aktuálně zobrazený uživatel.

¨ Skupina - má význam pro definování přístupových práv k jednotlivým činnostem. Každý uživatel musí být zařazen do některé skupiny uživatelů. Do stejné skupiny může být zařazeno více uživatelů, což pak znamená, že mají stejná práva při používání programu (např. skupina každý uživatel systému).

¨ Název skupiny - stručný a výstižný název skupiny

Po stisku záložky „skupiny uživatele“ je k dispozici pouze přehled těch skupin, ve kterých je daný uživatel zařazen. Záložka „přístupy k věcem“ poskytuje přehled činností, ke kterým má daný uživatel právo a jeho typ (čtení, zápis).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 02.08.2007


Pojem - V prohlížeči výstupů předloh

Po stisku ikony tiskárna na vybrané předloze výstupu se uživateli zobrazí dialogové okno „zahájení výstupu podle předlohy“. Uživatel si v současné době mohl zvolit směr tisku „na tiskárnu, do souboru nebo prohlížení“. K volbě prohlížení má nyní k dispozici i možnost nemodálního prohlížení výstupů klasických předloh výstupu. Toto mu umožňuje nový atribut „v prohlížeči výstupů předloh“.

Při jeho zatržení se uživateli následně zobrazí daná sestava ve formě náhledu před tiskem ve vlastním formuláři „prohlížeč výstupů předloh“ s vlastní ovládací lištou. Pokud nechá uživatel tento formulář aktivní, tak při prohlížení jednotlivých klasických sestav se zatrženým atributem „v prohlížeči výstupů předloh“ se všechny tyto sestavy zobrazují jako přehled právě v tomto formuláři, tzn. uživatel může mít např. vyfiltrován přehled vystavených faktur a vyvoláním tisku každé faktury se zatrženým atributem „v prohlížeči výstupů předloh“ se do formuláře „prohlížeč výstupů předloh“ naplní přehled všech těchto faktur.

Pomocí ikonek na ovládací liště (tlačítko první stránka/předchozí stránka/následující stránka/poslední stránka) se uživatel může v přehledu volně pohybovat, přičemž levá část formuláře zobrazuje přehled předloh výstupu a pravá část formuláře zobrazuje náhled dané předlohy.

Další tlačítko „zachovat/nezachovat poměr rozměrů výšky šířky stránky“ funguje jako přepínač a umožňuje uživateli buď zachovat poměr rozměrů výšky a šířky dané předlohy výstupu nebo po jeho stisku roztažení předlohy výstupu do nastavené velikosti daného formuláře. Tím je ovšem porušen poměr rozměrů předlohy výstupu, tzn. že daná předloha výstupu je pro uživatele zvětšená, tj. čitelnější, ovšem bude zřejmě mnohem více zvětšena do šířky. Po stisku pravého tlačítka na tomto přepínači se automaticky upraví šířka formuláře, tzn. zarovná se přesně na velikost stránky.

Tlačítko „tiskárna“ aktivuje tisk dané předlohy výstupu. Tlačítko „dveře“ znamená totéž co ESC, tzn. opuštění a uzavření formuláře „prohlížeč výstupů předloh“.

Pokud tedy zůstává tento formulář aktivní, tzn. uživatel ho během práce s IS BM nezavírá, ale např. pouze „uklízí“ na dolní lištu PC, přehled jednotlivých zobrazených předloh výstupu narůstá a mohou zde být zobrazeny všechny předlohy, které uživatel použil během dne při práci s IS BM. V případě, že uživatel tento formulář ukončí, přehled předloh výstupu se vymaže a při dalším spuštění tohoto formuláře je opět prázdný.

Tuto vlastnost předloh výstupu lze využívat pouze pro verze IS BM pod FoxPro 9 a vyšší.

Upozornění:

V některých případech nemusí zobrazená předloha výstupu plně odpovídat její vytištěné verzi. Program, který je využit ve formuláři na zobrazení předloh výstupu toto technicky neumožňuje (a není z autorské dílny firmy BM Servis), tzn. pouze ho pro tento formulář využíváme a u některých předloh může docházet ke zkreslení atributů (především atributů typu formát), tzn. že uživatel pak místo částky vidí hvězdičky/tečky nebo jsou chybně zobrazena pořadová čísla apod. V takovém případě doporučujeme, pokud je to technicky možné, aby si uživatel danou předlohu výstupu upravil (tzn. atributy typu formát zvětšil).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 06.02.2009


Pojem - Validace dat

Validací dat se rozumí kontrola dat zejména při jejich vstupu z hlediska logiky, případně i z hlediska syntaxe (např. datum "__.__.____"). Validace je definována těmito nástroji:

¨ programový kód

¨ parametry uživatelsky nastavitelné v relevantních činnostech

¨ kód po ukončení operace

Validace se provádí v těchto okamžicích:

¨ při vyplnění údaje

¨ při zápisu záznamu

¨ při ukončení operace

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Validace IČO

V parametrech adresáře (adresář – číselníky a parametry) je možno zatrhnout možnost kontroly zadávaných adresátů podle IČO, tzn. validace IČO. V případě, že uživatel zadává nového adresáta s IČO, které již v adresáři existuje nebo změnil IČO dříve založeného adresáta na IČO, které již v adresáři existuje, je zobrazen formulář s hlášením: „IČO …… bylo již užito pro adresáta ….. „. Po stisku tlačítka OK systém povolí vstup adresáta se zadaným duplicitním IČO. Po stisku tlačítka Storno systém nutí uživatele IČO změnit. V případě potřeby je možno při stisku tlačítka OK zaškrtnou volbu „Vypnout kontrolu duplicitního IČO pro toto spuštění formuláře“, která způsobí potlačení kontroly duplicitního IČO pro právě aktuálně spuštění formulář „Adresář“ (využije se při importu dat do adresáře).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 03.10.2005


Pojem - Variabilní symbol

Variabilní symbol (VS) je jedním z určujících atributů týkajících se událostí plateb. U přijatých faktur (závazky) je variabilní symbol v podstatě „opsán“ z došlé faktury, u vystavených faktur (pohledávky) se na základě nastavení IS BM tvoří automaticky. Variabilní symbol v IS BM je tvořen 10 znaky. První čtyři znaky jsou určeny z parametrů plateb (atribut „1.část variabilního symbolu“), dalších 6 znaků je automaticky generováno z čísla procesu.

V atributu „1.část variabilního symbolu“ je tedy možno nastavit si první čtyři znaky variabilního symbolu pohledávek. Mohou být tvořeny kombinací čísel a znaků, kdy R=rok a U=identifikace datového úložiště. Pak zde v tomto atributu může být kombinace RU (rok, úložiště – vždy poslední znak z tohoto atributu, tzn. je-li rok 2007 a identifikace úložiště je 01, pak první část var.symbolu bude 71) nebo RUU, RRUU apod. Pokud zde má uživatel nastaveno tento parametr jako např. RU, bude jeho generovaný VS pouze osmimístný.

Důležité upozornění:

Druhy procesů, které tvoří pohledávky, musí mít číselnou řadu menší než jeden milion, tzn. tvořenu 6 místy. Pokud si uživatel vytvoří číselnou řadu delší, může vzniknout problém ve VS v letech. V případě, že vygenerovaný variabilní symbol z plateb (6 znaků) by obsahoval na prvních místech číslice nula, jsou nuly automaticky mazány.

Další atributy z parametrů plateb, které se týkají nastavení variabilního symbolu jsou:

¨ „validace variabilního symbolu“ - je možno zvolit Ne, Ano, Ano stejného adresáta, Podle parametrů plateb. Ne způsobí, že se variabilní symbol přijatých faktur vůbec kontrolovat nebude. Ano znamená, že systém nahlásí, pokud najde platbu se stejným variabilním symbolem. Ano stejného adresáta znamená, že systém nahlásí, že našel platbu se shodným variabilním symbolem, pokud se zároveň budou shodovat adresáti plateb. Podle parametrů plateb znamená, že kontrola se bude provádět podle nastavení ekvivalentního parametru operace komponenty plateb (druhy operací, v menu Volby Parametry operace komponenty). Tato volba umožňuje nastavit chování BM při zápisu události (závazku) operace daného druhu z hlediska kontroly duplicity variabilního symbolu.

¨ „nevalidované variabilní symboly“ - zde se uvádí seznam variabilních symbolů (oddělených čárkou), pro které se nebude provádět validace. Může se jednat např. o var. symboly různých převodů na účet apod.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 18.01.2008


Pojem - Vazba objektů

Definuje vztah mezi dvěma objekty. Objekty se rozumí např. vývěska, zprávy, dokumenty, události obchodu, události plateb, adresář apod. Určuje, který objekt bude považován za předchůdce (čili otce) a který za následníka (čili syna). K vazbě objektů lze volnou kartou definovat další atributy.

Vazba objektů je v systému vyjádřena znaménkem plus v rámečku souvislostí objektů, který se vyvolává vždy po stisku ikony „stromeček“ ze základního panelu nástrojů.

Existence objektové vazby je uživateli signalizována matematickými znaménky v rámečku souvislostí (tzn. při práci s objektovými vazbami je nutno mít tento rámeček zobrazen – panel nástrojů – ikona stromeček). Pokusíme se o vysvětlení na praktickém příkladu. Máme v okně činnosti zobrazenu přijatou zprávu a aktivován rámeček souvislostí. V něm, na ikoně vývěska je uvedeno znaménko plus nahoře, na ikoně dokumenty je uvedeno znaménko plus dole. Znamená to, že tato zpráva má objektovou vazbu na události vývěsky, která je k této zprávě ve vztahu předchůdce (otec) a zároveň má tato zpráva objektovou vazbu na dokument, který je k této zprávě ve vztahu následník (syn). Pokud bychom si tento příklad na základě těchto objektových vazeb uvedli do logické posloupnosti, vypadalo by to takto: vývěska – zprávy – dokumenty (otec – aktuální záznam – syn).

Vlastní vytvoření objektových vazeb je možno provést dvěmi způsoby, metodou přímou a metodou nepřímou. Na popisu konkrétního příkladu vytvoření objektové vazby mezi událostí vývěsky a zprávami si obě tyto metody vysvětlíme:

¨ přímo – je vytvořena událost vývěsky. Uživatel si z panelu nástrojů po stisku ikony stromeček aktivuje rámeček souvislostí. V něm si vybere ikonu „zprávy“ a klikne na ni. Zobrazí se mu okno činnosti zpráv, které je prázdné a na tlačítku vytvoření vazby je implicitně přepnuto na volbě „následují“ (tím by se původní událost vývěsky připojila k této zprávě jako syn). Ve většině případů ovšem uživatel chce vytvářet vazbu opačnou, tzn. původní událost (vývěska) má být otec – předchůdce a nová událost (zprávy) má být syn – následník. V tomto případě je nutno tlačítko s volbou „následují“ stiskem levého tlačítka myši přepnout do polohy „předcházejí“ a teprve pak aktivovat vstup (klávesa F3 nebo ikona pro vstup nového záznamu na panelu nástrojů) nového záznamu (v našem případě zprávy).

¨ nepřímo – jedná se o případ, kdy už je jak událost vývěsky, tak zprávy vytvořena, není mezi nimi zatím žádná spojitost a uživatel je tedy pomocí objektové vazby chce spojit (tzn. vytvořit odkaz jedné události na druhou). V takovém případě je postup následující: uživatel si spustí okno s činností vývěsky s výběrem na danou událost a zároveň okno s činností zprávy s výběrem na danou zprávu (tzn. má otevřená dvě okna činností s událostmi). V každém okně činnosti je kurzor umístěn vždy na daném záznamu, který chceme spojit. Aktivujeme činnost zpráv (tzn. horní lišta okna zpráv je modrá), stiskneme levé tlačítko myši na zeleném stromečku v levém dolním rohu okna činnosti zpráv a metodou „táhni a drž“ tento stromeček přesuneme kamkoliv do okna činnosti vývěska a zde ho pustíme. Zobrazí se nám dotazovací dialog, kdy opět pomocí - tentokrát zaškrtávátek, „následují“ a „předcházejí“ vytvoříme potřebnou vazbu otec – syn nebo syn – otec. V případě potřeby je možno kdykoliv takto vytvořenou vazbu zrušit. Aktivujeme si okno činnosti s událostí, která byla připojena jako následník (syn), v našem případě zprávy, a po stisku klávesy F8 nebo ikony křížek v panelu nástrojů se systém dotazuje „opravdu zrušit vazbu na událost ......?“. Potvrzením volby Ano je vazba objektů zrušena.

Při vytváření objektových vazeb má uživatel kromě možnosti zvolit tlačítko „následují“ a „předcházejí“ možnost využít ještě tyto tlačítka:

¨ nepřekrývat – překrývat – znamená, že pokud má uživatel zobrazena okna dvou činností, mezi kterými vytváří objektovou vazbu, tak při volbě nepřekrývat se při pohybu po těchto oknech vždy zobrazuje celé okno dané činnosti (tzn. aktivní okno je v danou chvíli vždy vidět celé a může překrývat právě neaktivní okno). Volba překrývat znamená, že při pohybu z jednoho okna činnosti na druhé je část okna jedné činnosti soustavně překryta částí okna druhé činnosti, čili jedno okno činnosti (kde je zatržena volba překrývat) stále překrývá okno druhé činnosti.

¨ nefixovat – fixovat – tato volba souvisí s pohybem po jednotlivých záznamech. Pokud máme opět zobrazena okna obou činností (např. znovu vývěska a zprávy), tak při volbě nefixovat se při pohybu po okně s činností vývěsky mění zároveň okno s činností zprávy, přesně podle toho, jakou má daná událost vývěsky vytvořenou objektovou vazbu na zprávy. Pokud je v okně činnosti zpráv přepnuto na volbu fixovat, znamená to, že i přesto, že se uživatel bude pohybovat po jednotlivých záznamech vývěsky, okno s činností zpráv se měnit nebude, zůstane zobrazena stále původní zpráva (tj. ta, na které bylo aktivováno fixovat).

Specifickou vazbou objektů jsou dokumenty, které kromě toho, že se příznak vazby zobrazuje v rámečku souvislostí ještě mají i své vlastní okno spojených dokumentů.

Objektová vazba se technicky realizuje pomocí atributů s jednoznačnou časovou identifikací záznamu (record) a druhů objektů. Zpráva objektově připojená k vývěsce zpřístupní i záznam, který by podle práv přístupný nebyl.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 14.10.2015


Pojem - Vazba uzlů procesu

Definuje vztah mezi dvěma uzly procesu. Určuje, který uzel je zdrojový a který je cílový. Vazba je v diagramu (druhu) procesu vyjádřená "šipkou". V případě, že je cílový uzel proces, může "šipka" obsahovat několik vazeb.

Před vlastním vysvětlením možností, které se nabízejí ve vlastnostech, je nutno se zmínit o principu vazeb. Každá operace může nabývat tří stavů: připravena, zahájena, ukončena. Obecně platí, že do stavu připravena se může dostat několik operací najednou, bez předchozího ukončení operace může být zahájena pouze první operace v procesu, ostatní operace je možno zahájit a následně ukončit vždy až po ukončení operace předchozí.

Významné vlastnosti vazby (vlastnosti vazby se nastavují po stisku pravého tlačítka myši na dané vazbě) z hlediska řídícího toku procesu jsou dány druhem vazby a z hlediska datového toku transformací. Další vlastnosti jsou:

¨ definice zdrojové operace (jen je-li zdrojový uzel typu proces)

¨ příznak "po ukončení procesu" (jen je-li zdrojový uzel typu proces, viz. též ukončení uzlu a ukončení procesu)

¨ pořadí vazby má význam, pokud z daného zdrojového uzlu vede více vazeb do cílových, a vliv na zápis (pořadí) cílového uzlu do zásobníku operací

¨ definice cílové operace (jen je-li cílový uzel typu proces)

¨ transformace - pokud je tento příznak zatržen, uživatel pomocí položky „vstup transformací“ zadá transformaci (vybere ji ze seznamu nebo založí novou – tlačítko „vstup transformací“), která se vztahuje k operacím, mezi kterými je daná vazba. Seznam transformací v překryvném seznamu se vždy vztahuje k zdrojovému a cílovému uzlu (tzn. pokud bude zdrojový uzel operace komponenty obchod a cílový uzel bude operace komponenty DPH, budou se v překryvném seznamu zobrazovat všechny transformace související s komponentou obchod a DPH).

¨ rozlišení ovlivňuje chování míry plnění

¨ vazba – z hlediska toho, jakých hodnot může nabývat definice druhu vazby mezi uzly (běžná, samostatná, pasivní, výběrová (OR), výběrová (XOR)) je možno tyto vazby rozdělit do dvou skupin:

- vazby bez výběru

- vazby s výběrem

¨ předkontace – výběr obecné předkontace z překryvného seznamu. Předkontace, které se zde nabízejí, jsou definovány u dané transformace na příslušné záložce

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.02.2012


Pojem - Vazby míry plnění

Vazba míry plnění vzniká mezi dvěmi událostmi, z nichž následující vznikla na základě transformace a tyto události operací mezi sebou přenesly alespoň jeden atribut z první operace, tzn. aby vznikla vazba míry plnění musí z první operace do druhé operace být pomocí transformace přenesen alespoň jeden atribut (např. datum, adresát, druh artiklu apod.). Vazbu míry plnění tedy není možno vytvořit ručně jako např. objektovou vazbu, její vznik závisí na nastavené transformaci mezi jednotlivými operacemi v procesu.

Jedná se o činnost, která je pro uživatele dostupná z menu Obecné – Nabídky. Po spuštění (nejedná se o klasické spuštění, ale spíše zaškrtnutí) této činnosti se uživateli zobrazí okno míra plnění. Při prvním spuštění se standardně zobrazuje v levé horní části okna činnosti, uživatel si ho však může přemístit kdekoliv po okně činnosti. V případě, že aktivní činnost ukončí a okno míry plnění bude ve chvíli ukončení činnosti stále otevřené, jeho změněné umístění na obrazovce zůstane v takovém případě zachováno, tzn. při dalším spuštění činnosti se zobrazí na tomto místě. V případě, že si uživatel okno s mírou plnění přemístí jinam, ale před vlastním ukončení činnosti okno míry plnění zavře (ikona křížek), umístění se neuchová a při dalším spuštění vazeb míry plnění se okno této činnosti bude znovu zobrazovat v levém horním rohu okna činnosti. Zobrazení činností v okně míry plnění do jisté míry souvisí s nastavením rámečku souvislostí. Uživateli se zobrazují pouze ty činnosti, které mají v nastavení souvislostí – objekt přiřazeno „zobrazit“. Činnosti s příznakem „skryté“ zůstávají skryté i zde. Po stisku pravého tlačítka myši kdekoliv v šedém prostoru okna míry plnění se zobrazí i skryté, opětovným stiskem pravého tlačítka myši se skryté nezobrazují.

Stejně jako v rámečku souvislostí je přítomnost vazby míry plnění u jednotlivých činností signalizována znaménkem plus. Zobrazení po stisku znaménka plus u jednotlivých činností se však řídí přístupovými právy daného uživatele. Jinými slovy, uživatel může ikonu s činností operace plateb v okně míry plnění vidět, je zobrazeno znaménko plus, uživatel však po aktivaci této ikony jednotlivé událostí neuvidí, neboť nemá přístupové právo k operaci plateb. Při zobrazení vazeb míry plnění se uplatňují přístupová práva k umístění (tj. alokacím) a druhům operací (kromě operace komponenty účetnictví, která přístup podle druhu operace nehlídá). Uživatel tedy v okně míry plnění pomocí signalizace znaménka plus vidí, které události kterých komponent jsou svázány vazbou míry plnění, aktivovat si však může pouze ty, ke kterým má přístupové právo. Aktivace jednotlivých událostí se provede stiskem příslušné ikony v okně míry plnění.

Případné zrušení vazeb míry plnění se provede stiskem klávesy F8 (nebo ikonka „křížek“ v horní liště).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 03.11.2011


Pojem - Věc s přístupem

Věc s přístupem je záznam v těch entitách IS, k jejichž záznamům je umožněno programovým kódem definovat přístupová práva. Následně je umožněno programovým kódem chránit přístup k nim dle nastavených práv, a to obvykle i přístup v jiných entitách, pokud se tam vyskytují jako cizí klíč.

Například: K věci s přístupem "sklad číslo 11" nebude mít uživatel A nastavené žádné právo, pak nebude mít právo ani k událostem, které se týkají tohoto skladu.

Přehled věcí s přístupem je dostupný na záložce v činnosti Uživatelé (věci přístupné uživateli) a také v činností Skupiny uživatelů (věci přístupné skupině).

Typ (druh) věci s přístupem je určitý ukazatel (využívaný v programovém kódu) na entitu IS, k jejímž záznamům je umožněno programovým kódem definovat přístupová práva (např. typ TDO představuje Přístupy k typům dokumentů).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.04.2004


Pojem - Věcné břemeno

Podstatou věcného břemene je zatížení vlastníka nemovité věci tím, že je tento vlastník omezen ve výkonu svého vlastnického práva tím, že je povinen něco trpět (např. chůzi souseda po vašem pozemku), něčeho se zdržet (např. povinnost vlastníka zdržet se výstavby plotu nad určitou výšku) nebo něco konat (např. poskytnutí určitých peněžitých nebo naturálních dávek). Toto omezení působí buď ve prospěch vlastníka jiné nemovitosti, nebo ve prospěch určité konkrétní osoby.

Věcná břemena patří mezi tzv. věcná práva. Znamená to, že práva a povinnosti, která jsou obsahem věcného břemene, jsou nejen spojena s vlastnictvím nemovité věci, ale přecházejí i na každého nového nabyvatele této věci. Každý vlastník nemovité věci zatížené věcným břemenem je povinen toto břemeno trpět.
Z občanského zákoníku dále vyplývá, že věcným břenem je možné zatížit pouze věci nemovité (tj. pozemky a stavby spojené se zemí pevným základem a dále byty či nebytové prostory). Věcným břemenem ale nelze omezit vlastníka movité stavby (např. dřevěná kůlna bez základů, plechová garáž, skleník apod.) a vlastníka movité věci vůbec.
Věcné břemeno musí mít opakující se charakter, musí být využíváno nepřetržitě nebo vícekrát v pravidelných intervalech. Jako věcné břemeno nelze sjednat předkupní právo, nájem ani omezení nakládat s nemovitostí (např. podmínečný prodej). Věcným břemenem lze zatížit nemovitost pouze jako celek. Předmětem práva odpovídajícímu věcnému břemeni však nemusí být celá zatížená nemovitost, ale může to být i její část (např. část pozemku).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Vlastnosti činnosti, skupiny

Vlastnosti činnosti má uživatel dostupné na každé činnosti nebo skupinové položce hlavního menu po stisku pravého tlačítka myši na názvu dané činnosti. Zobrazí se mu okno s názvem „vlastnosti prvku menu“, kde má k dispozici tři záložky:

¨ obecné – uživatel má k dispozici atributy název činnosti a poznámku (lze je editovat), možnost zvolit si funkční klávesu, po jejímž stisku se daná činnost aktivuje a možnost zaškrtnout atribut „skrytá“. Tento atribut uživatel použije u činností, které sice má přístupné v hlavním menu, ale on sám s touto činností nepracuje a nepotřebuje ji tedy vždy vidět zobrazenou po aktivaci hlavního menu. V případě, že by potřeboval pak vidět i ty činnosti, které mají příznak skrytá, aktivuje z horní lišty hlavního menu ikonu „zobrazovat skryté činnosti“. Atribut Typ má pro uživatele pouze informativní charakter, protože se jedná o implicitně nastavenou hodnotu, kterou uživatel nemá možnost editovat. V případě potřeby si uživatel může změnit i ikonu, kterou je daná činnost uvozena v hlavním menu (tlačítko „změnit ikonu“), je nutno však mít k dispozici jiný soubor s příponou *.bmp. U činností, které uživatel převzal z nadřazené definice menu (a své vlastní menu si vytvořil na základě odvození menu z této definice) je zatržen příznak „odvozené“. Uživatel zde má k dispozici i atribut „klíč“, který se automaticky naplní po stisku pravého tlačítka myši v daném atributu. Předplněnou identifikaci lze poté dále využít např. v definicích doplňujících vlastností formuláře apod. (ve smyslu, že daná DVF se má spustit právě s činností, která má tuto identifikaci).

¨ výběr – možnost nastavení si výběru pro danou činnost. Tento výběr se aktivuje po spuštění této činnosti a uživateli umožňuje zvolit si velmi pohodlným způsobem potřebnou množinu dat, aniž by pak uživatel musel po spuštění této činnosti definovat svoje požadavky na záložce výběr (např. pokud si uživatel např. zkopíruje činnost Operace, tuto činnost si vloží pod vybranou skupinu, změní si název této činnosti na „připravené dodací listy“, tak je možno právě do toho výběru nadefinovat, že činnost „připravené dodací listy“ má zobrazovat operace obchodu „dod – xxx“, které jsou připravené – nezahájené). Uživatel má tedy k dispozici:

¨ nový výběr[1] (tj. definice úplně nového výběru) – uživatel si zvolí název nového výběru a poté ho definuje pod tlačítkem nastavení výběru

¨ nastavení výběru (tj. možnost úpravy nového nebo stávajícího výběru) - uživatel si vybírá atributy, kterých se má výběr týkat a nastavuje k nim hodnoty, jichž mají dosahovat (např. rok, druh procesu, druh operace apod.). Při definování výběru je možno použít i obecný výběr a vybranou metapředlohu tisku (resp. předlohu výstupu obsaženou v dané metapředloze). Tuto předlohu výstupu je potom možno vyvolat přímo z formuláře (tj. okna) činnosti spuštěné z hlavního menu po stisku klávesy F12.

¨ zrušit výběr

¨ překlad – tato záložka neslouží pro vlastní překlad do cizího jazyka, ale spíše pouze pro zpřesnění popisu pojmu v daném jazyce. Pokud chce uživatel mít hlavní menu např. anglicky, je nutno zvolit v horní liště hlavního menu jazyk angličtina, na záložce obecné ve vlastnostech činnosti přepsat český název do angličtiny a pak se při aktivaci anglického jazyka bude zobrazovat hlavní menu anglicky.

Jak jsme se tedy již výše zmínili, uživatelsky definované položky menu se překládají přepisem na záložce obecné ve vlastnostech v daném jazyce (nikoliv záložkou překlad). Je-li uživatelská položka zařazena při zapnutí určitého jazyka, stává se tento název současně názvem v jazyce neurčeném, kde je možno jej následně i opravit. Přeložit je možno jenom položky základního menu, nikoliv položky uživatelsky odvozené.

[1] Při definování nového výběru je tedy nutno nejprve aktivovat tlačítko Nový výběr, zde zadat název nového výběru a poté aktivovat tlačítko „Nastavení výběru“, kde je možno teprve určit potřebné atributy a jejich hodnoty.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 26.04.2013


Pojem - Vlastnosti definice menu

Vlastnosti definice menu má uživatel dostupné po stisku pravého tlačítky myši v okně „deklarovaná menu“. Tyto vlastnosti jsou shodné pro všechna menu (základní, odvozené). Obsahují následující možnosti:

¨ název – název menu

¨ povoleno měnit obsah menu – pokud je zaškrtnuto, uživatel má možnost vytvářet nové skupiny, kopírovat činnosti, měnit názvy činností apod. Pokud není zaškrtnuto, není možno měnit obsah menu.

¨ povoleno aktivovat menu – znamená, že pokud si z hlavního menu přes volbu Menu – Otevřít menu uživatel otevře „deklarovaná menu“ a vybere si některé z přehledu menu, tak to, které má zatržen tento příznak může spustit, tzn. dvojklikem ho aktivovat.

¨ povoleno zrušit definici menu – pokud je tento příznak zatržen (což standardně nebývá) je možno tuto vytvořenou definici menu zrušit.

¨ soukromé menu – při zatržení této možnosti se definice menu „zablokuje“ pouze pro svého vlastníka, nelze ji zrušit jiným uživatelem a změny v obsahu (a rušit) smí provádět pouze vlastník tohoto menu.

¨ příznak systémové má pouze základní definice menu

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 09.01.2008


Pojem - Vlastnosti dokumentu

Při vytváření nového dokumentu musí nadefinovat jeho vlastnosti, tzn. na záložce „obecné“ určí název, typ dokumentu a předlohu dokumentu. K jednotlivým typům dokumentů je možno definovat přístupová práva. V případě, že uživatel má k danému druhu dokumentu přístupové právo zápis, je možno ve vlastnostech dokumentu druh dokumentu změnit. Při zatrženém příznaku chráněný dokument nebudou případné změny provedené v dokumentu jinými uživateli zaznamenány (aby nedošlo k omylu, při aktivaci tohoto dokumentu systém uživateli dovolí do dokumentu zapisovat nebo opravovat, ale při uložení nebudou tyto změny zaznamenány). Dokument pak smí opravovat (tzn. zapisovat do něj) pouze autor dokumentu.

Záložka „kategorie“ umožňuje daný dokument do vybrané kategorie zařadit pomocí atributu Nová a pak výběrem z překryvného seznamu nadefinovaných kategorií ji přiřadit dokumentu. Lze zadat i platnost od – do příslušnosti dokumentu ke kategorii. Zároveň poskytuje uživateli přehled o tom, v jakých kategoriích je daný dokument již zařazen. V případě potřeby je možno dokument z kategorie vyřadit pomocí atributu „odstranit“. V této činnosti se jednotlivé kategorie dokumentů nedefinují, pouze je možno vybírat z překryvného seznamu (definují se v činnosti Marketing – Dokumenty – Kategorie dokumentů).

Záložka „užití dokumentu“ ve chvíli založení uživateli žádné informace neposkytne, ale při další práci s dokumentem je zde zaznamenán každý pohyb, který byl s dokumentem proveden, tzn. datum, čas od – do, jméno uživatele a akce, kterou s dokumentem provedl (čtení, zápis).

Záložka „uložení dokumentu“ umožňuje uživateli:

¨ externí uložení - v případě normálního uložení je vytvořený dokument součástí databáze IS BM, při zatržení příznaku externí musí uživatel vytvořit odkaz (tzn. určit cestu a název souboru, ve kterém bude dokument uložen mimo IS BM) a při jeho aktivaci systém přes určenou cestu dokument vyvolá.

¨ soubor – cesta pro externí uložení dokumentu

¨ duplikát – IS BM umožňuje uživateli vytvořit si při tvorbě dokumentu rovnou jeho duplikát, který je uložen na pevném disku. Cestu na soubor, ve kterém má být daný dokument jako duplikát uložen, zadává uživatel v tomto atributu. Pro následnou práci s dokumentem pak platí, že změní-li uživatel dokument v IS BM, automaticky se mu stejně změní i duplikát na pevném disku. Opačný případ však nefunguje. Změní-li si uživatel duplikát na pevném disku, znamená to, že si soubor přepíše, jeho změny nebudou do dokumentu v IS BM přeneseny.

¨ automatické ukládání verzí dokumentu

Po vyplnění všech potřebných údajů na jednotlivých záložkách a konečném stisku OK je nový dokument vytvořen.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.11.2009


Pojem - Vlastnosti hlavního menu

Po stisku pravého tlačítka myši lze vyvolat vlastnosti hlavního menu. Tyto vlastnosti se však uživateli nabízí jen při zobrazení typu velké ikony, malé ikony a seznam. Při stisku pravého tlačítka myši při zobrazení detaily a strom činností se aktivují přímo vlastnosti aktivní činnosti, tj. té, na které je právě umístěn kurzor. Takže při výše vyjmenovaném zobrazení při stisku pravého tlačítka myši kdekoliv ve volném prostoru okna hlavního menu se uživateli zobrazí následující možnosti, které jsou vlastnostmi hlavního menu:

¨ způsoby zobrazení – aktuální způsob zobrazení je zatržen.

¨ vložit skupinu – po této volně se uživateli nabídne dialogové okno, kde si může vložit novou skupinu (zvolit si název podle svých představ), případně ji přiřadit i funkční klávesu, po které se bude aktivovat.

¨ vložit činnost – tato volba není běžně vysvícená, dostupná je pouze v případě, pokud uživatel na některé vybrané činnosti hlavního menu po stisku pravého tlačítka myši zvolí možnost kopírovat, tak pak bude zde tato možnost vložit činnost vysvícena s tím, že systém bude už rovnou nabízet vložení té dané zkopírované činnosti.

¨ změnit pořadí činností – po aktivaci této volby se uživateli nabídne tabulka, kde pomocí posuvníku po levé straně okna má možnost ovlivnit pořadí jednotlivých činností v hlavním menu

¨ rovnat automaticky – tato volba je implicitně zatržena. V případě vložení nové skupiny nebo činnosti budou tyto vloženy systémem na konec, tzn. na první volné místo v seznamu činností hlavního menu. Pouze v případě, že by si uživatel chtěl při zobrazení typu malé ikony činnosti rozmístit podle své potřeby libovolně po okně, je nutno tuto volbu odškrtnout.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.11.2007


Pojem - Vlastnosti operace

Vlastnosti operace mohou být dvojího druhu:

¨ vlastnosti operace, které se nastavují v diagramu procesu u uzlu typu operace (po stisku pravého tlačítka myši)

¨ vlastnosti operace, které je možno vyvolat po stisku pravého tlačítka myši na operaci ve stromu hlavního procesu nebo jsou dostupné na každé události pod menu Volby. Tyto vlastnosti poskytují uživateli informace o tom, kdo a kdy operaci založil, v jakém je stavu a zároveň (pokud je to přístupovými právy umožněno) má uživatel možnost v případě potřeby využít tlačítko „zrušit stav ukončena“.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 20.05.2015


Pojem - Vlastnosti předlohy

Vlastnosti předlohy si uživatel vyvolá stiskem pravého tlačítka myši na názvu předlohy nebo pomocí příslušné ikony v panelu nástrojů předloh. Zobrazí se mu okno „vlastnosti předlohy“, kde má k dispozici následující záložky:

¨ obecné – obecné informace o předloze

¨ popis – název předlohy, setřídění, počet kopií apod.

¨ setřídění

¨ seskupování

¨ doplnění

¨ deklarace

¨ info

¨ verze

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 02.11.2012


Pojem - Vlastnosti uzlu diagramu procesu

Nyní si podrobně popíšeme možnosti, které má uživatel k dispozici pod atributem vlastnosti. Pokud se jedná o uzel typu operace, uživatel vstupuje tyto údaje:

¨ zadání, zda operaci spouštět automaticky, na pozadí nebo nespouštět

¨ po nepředběžném ukončení předchozích operací - tento příznak slouží zatím pro operace skladové evidence, kde je možno provádět předběžné a konečné ocenění. Pokud je ocenění předběžné, je vhodné u následující operace v procesu zatrhnout právě tento příznak, neboť pak operace nebude pokračovat a "počká" až do té doby než u předchozí operace bude ocenění konečné. Je to výhodné zejména v případě, kdy po operaci skladové evidence (např. příjem či výdej) s předběžným oceněním následuje zaúčtování pohybu. Aby nedošlo k zaúčtování předběžného pohybu, je k dispozici právě tento příznak, který tuto alternativu umožňuje a hlídá.

¨ aktualizuje hodnotu semaforu procesu - nejprve je třeba zdůraznit, že tato hodnota není povinná, pokud uživatel nepotřebuje u daného procesu sledovat zda je z hlediska "procesního salda" ukončen, tuto hodnotu nezadává. Pokud toto sleduje, tak u první operace v procesu, ze které se provádí transformace se uvádí kladná hodnota, u operací, které následují hodnota záporná. Uvedeme si toto na příkladu - první operací v procesu je událost vývěsky, na kterou přes transformaci navazují dvě zprávy. Potom u operace vývěsky je zadána hodnota 2, u každé z operací zprávy je zadána hodnota -1. Hodnota -1 uvedená u každé této operace se přičítá k vstupní operaci v okamžiku, kdy je tato operace ukončena. Vyrovnaný semafor je tedy v tom případě, pokud je výsledná hodnota nulová.

¨ vytvořit záložku na operaci při založení procesu - tento atribut způsobí to, že na fyzicky vytvořených operacích (v činnosti „operace") je pak na obrazovce dostupný i adresát, který je zastoupen na operaci (jedná se o adresáta z první události), je-li na uzlu typu proces nevytvoří záložku na všech prvních operacích.

¨ zadání šablony prvého vstupu - pokud se operace vstupuje přes šablonu, zadá zde uživatel název šablony (např. pokud se operace týká zprávy, která se posílá několika uživatelům atd.)

¨ po ukončení operace tisk dokladu – pokud je zaškrtnuto, tiskne se po ukončení této operace doklad podle toho, jak je nadefinován u druhu procesu v atributu metapředloha

¨ po ukončení operace tisk operace - výběr metapředlohy (metapředloha s tiskem po ukončení operace musí být nadefinována v tisku v událostech té komponenty, ze které se tiskne)

¨ oprávnění ukončit operaci - výběr jména uživatele nebo skupiny uživatelů, kteří mají oprávnění operaci ukončit. V případě standardního nastavení práv je vhodné zde ponechat implicitní nastavení „každý s právem ukončit operaci“, v případě potřeby lze samozřejmě určit konkrétní skupinu uživatelů nebo přímo jen konkrétního uživatele. To znamená, že danou operaci pak skutečně bude moct do stavu ukončena dovést pouze určený uživatel nebo skupina uživatelů, ostatní uživatelé či skupiny danou operaci nikdy neukončí. (Nastavení tohoto oprávnění však vždy nemusí fungovat v případě, že je spouštění operace nastaveno na pozadí – pak se operace automaticky ukončí i přesto, že k ní daný uživatel nemá nastaveno toto oprávnění ukončit).

¨ ukončuje proces - tento příznak uživatel zatrhne především v operacích, které jsou poslední operací určitého podprocesu, který je součástí daného hlavního procesu a na které navazuje další operace nebo podproces.

Pokud se jedná o uzel typu proces (tedy vlastně podproces), který je součástí hlavního procesu, po aktivaci činnosti vlastnosti jsou k dispozici tyto údaje:

¨ spouštět automaticky, na pozadí nebo nespouštět

¨ po nepředběžném ukončení předchozích operací - tento příznak slouží zatím pro operace skladové evidence, kde je možno provádět předběžné a konečné ocenění. Pokud je ocenění předběžné, je vhodné u následující operace v procesu zatrhnout právě tento příznak, neboť pak operace nebude pokračovat a "počká" až do té doby než u předchozí operace bude ocenění konečné. Je to výhodné zejména v případě, kdy po operaci skladové evidence (např. příjem či výdej) s předběžným oceněním následuje zaúčtování pohybu. Aby nedošlo k zaúčtování předběžného pohybu, je k dispozici právě tento příznak, který tuto alternativu umožňuje a hlídá.

¨ aktualizuje hodnotu semaforu procesu - hodnota uvedená zde má stejné vlastnosti jako kdyby se jednalo o operaci, akorát je nutno si uvědomit, že hodnota uvedená u operace, na kterou navazuje podproces, platí pouze ve vztahu operace - podproces, není aktuální pro operace, které jsou součástí daného podprocesu. Hodnota -1, která je uvedená u podprocesu se přičítá k vstupní operaci v okamžiku provedení podprocesu.

¨ vytvořit záložku na operaci při založení procesu - tato funkce se využije především při tvorbě dávkových procesů, např. je možno určitý čas pro daného adresáta vytvářet nové a nové dodací listy a pak je všechny najednou vyfakturovat. Je nutno vytvořit proces o jedné operaci "dodání", která bude mít zatržen tento příznak. Na základě tohoto procesu se pak aktivuje operace, např. o několika událostech a druhý den je opět nutno vystavit danému adresátu dodací list. Uživatel tedy aktivuje činnost "operace", vybere si operace, které jsou spojeny se záložkou, příslušný přehled si setřídí podle názvu adresáta, zvolí si příslušného adresáta a z menu volby nebo stiskem příslušné funkční klávesy znovu spustí operaci a vkládá další události. Takovým způsobem může k jakémukoliv adresátovi vkládat stále další a události, aniž by musel stále pouštět nový proces.

¨ odvozené procesy budou hlavními procesy - tento příznak zatrhne uživatel u procesů, které jsou součástí určitého hlavního procesu, ale uživatel přesto potřebuje znát saldokontní hodnoty pouze za tento daný proces

¨ datové úložiště zahajující operaci/proces – v případě nutnosti odlišení procesu, který má být zapsán s jiným datovým úložištěm (nepříliš používaný atribut)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 20.05.2015


Pojem - Volby – z menu horní lišty

Pod touto položkou menu jsou pro uživatele ve většině případů dostupné činnosti, které jsou jako ikony dostupné na panelu nástrojů a kromě toho i další činnosti, které slouží k ovládání formuláře. Obecně platí, že neví-li uživatel, co všechno mu aktivně spuštěná činnost nabízí za možnosti, měl by si aktivovat položku menu Volby. Stejně jako u položky Obecné i zde platí, že ne vždy jsou vysvíceny a dostupné všechny možnosti, záleží na činnosti, z které je položka menu Volby aktivována. Obsahuje:

¨ nový dotaz s novým vstupem – je dostupný pouze pokud činnost disponuje záložkou výběr. Aktivuje znovu záložku výběr (kde je možno si nadefinovat nový výběr) včetně výběrů, které jsou nadefinovány u možnosti uchovat.

¨ vkládání – dostupné pouze je-li uživateli povoleno, resp. není-li aktualizace pouze automatická. Umožňuje vložení nového záznamu.

¨ oprava – dostupná pouze je-li uživateli povoleno, resp. není-li aktualizace pouze automatická. Umožňuje editaci stávajícího záznamu.

¨ strom vývěsky – poskytuje uživateli informaci ve formě stromového vyjádření (podobně jako strom hlavního procesu) o komunikaci se záznamem na vývěsce.

¨ zrušení – dostupné pouze je-li uživateli povoleno, resp. není-li aktualizace pouze automatická)

¨ spustit operaci – aktivuje danou operaci procesu

¨ tisk dokladu

¨ tisk určené předlohy – dostupný je pouze v případě, že ve vlastnostech činnosti v hlavním menu (pravé tlačítko myši) je nadefinován výběr, který obsahuje i příslušnou tiskovou předlohu

¨ dokumenty - pouze, pokud se jedná o objekt IS BM, tzn. dokument je svázán se záznamem pomocí objektové vazby

¨ vstup šablonou – aktivace vstupu šablonou

¨ kalkulátor

¨ označování (není implementováno vždy)

¨ prezentace (pouze v dokumentech a artiklech)

¨ nový dotaz – dostupné pouze, pokud činnost disponuje záložkou výběr

¨ tisk

¨ komunikace nad záznamem – uživateli se zobrazí tabulka, kde jsou informace o tom, kdo záznam vytvořil, případně, komu k němu poslal zprávu, jestli ji ten dotyčný přijal apod.

¨ dávkové operace události

¨ informace o adresátovi – stejná možnost, jakou uživateli poskytuje tučný label adresát v okně činnosti. Má možnost si takto zobrazit všechny potřebné informace o daném adresátovi.

¨ vývěsky – jiná možnost jak vyvolat vývěsky otců, synů apod.

¨ diagram procesu

¨ strom hlavního procesu

¨ vlastnosti operace

¨ štítek adresáta – poskytuje uživateli rychlou informaci o adresátovi (tzn. adresa, kontaktní osoba apod.)

¨ odeslat do Outlooku – umožňuje vybraný záznam odeslat do elektronické pošty. Je nutno zvolit vhodnou transformaci a adresáta, komu tento záznam chci poslat, případně je možno ho poslat i sám sobě.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Volná karta - definice

Volná karta je nástroj, který umožňuje uživateli rozšířit množinu programátory definovaných atributů těch entit, ke kterým existuje činnost určená k prohlížení záznamů dané entity, o další uživatelsky definované atributy. Rozlišujeme několik volných karet, které mají významnější postavení než ostatní, a to:

¨ adresáta

¨ artiklu

¨ operace

¨ procesu

¨ vazby objektů

¨ selektorů

Pojem volná karta užíváme pro její definici i pro okno se zobrazením jejího obsahu. U každé definice volné karty se kromě její identifikace a názvu vstupují další údaje uvedené na jednotlivých záložkách. Toto je pro všechny volné karty shodné. Jedná se o záložku „atributy volné struktury“ a záložku „volné pohledy“.

Aktivovat volnou kartu je možno na základě uživatelského rozhodnutí nebo automaticky.

IS BM umožňuje sledovat změny záznamů na volných kartách (po nastavení v činnosti „nastavení sledování změn tabulek“). Při změně struktury volné karty nejsou automaticky přegenerovávány triggery pro sledování změn záznamů VK. Generovat triggery je možno z formuláře definování VK volbou „generovat triggery tabulky“ nebo z menu Volby tohoto formuláře vyvolat „nastavení sledování změn tabulek“ a „uživatelské triggery“.

Definice volné karty se skládá z definice její hlavičky, prezentovaných údajů (záložka „atributy volné karty") a volných pohledů (fakticky příkazů SELECT pro získání informace výpočtem z dat IS BM - záložka „volné pohledy").V hlavičce „karty“ se definuje:

¨ identifikace volné karty

¨ název volné karty

¨ správce – identifikace druhu implementačního rozšíření. Určuje právo uživatele ke správě (definování) volné karty. Vybírá se z překryvného seznamu a možnosti jsou: -, obecný druh dopl. vlast. formuláře, správce, systémový

¨ druh volné karty – vybírá se ze seznamu druhů volných karet, určuje právo uživatele pro přístup k datům volné karty. K tabulce volné karty je naprogramován trigger, který při změně druhu volné karty (v tabulce SPVOLST) provádí změnu druhu těch atributů volné karty (v tabulce SPVOLSTA), které mají uveden stejný druh jako původní druh volné karty.

¨ velikost – umožňuje změnit velikost okna volné karty (Ne, Horizontálně, Vertikálně, Oběma směry – horizontálně i vertikálně)

¨ posuvník – zda okno volné karty bude obsahovat posuvník. Pokud je volná karta menšího formátu, posuvník není zřejmě nutný, pokud obsahuje větší množství údajů, ale je omezena určitou velikostí, je vhodné zvolit aspoň horizontální posuvník, aby bylo možno se po jednotlivých atributech volné karty pohybovat. Možnosti jsou Žádný, Horizontální, Vertikální, Oba)

¨ autor – zobrazovat na volné kartě/nezobrazovat na volné kartě. Určuje, zda má být na volné kartě zobrazována informace o uživateli, který volnou kartu založil a datum jejího založení

¨ dynamický nadpis - výraz ve formátu FoxPro, který je vyhodnotitelný na úrovni formuláře, ze kterého je volná karta vyvolána a vrací textovou hodnotu. Např. volná karta v činnosti přehled uživatelů. Pokud je v dynamickém nadpisu zapsán výraz ve tvaru bwuzivat.bw01jmeno, tak při listování seznamem uživatelů se v okně volné karty bude dynamicky měnit jméno uživatele. Je možné uvádět výraz v jazyce Foxpro uvedený znakem ‘=’ – v tomto výrazu je možné získat hodnoty primárního klíče uvedením názvů atributů primárního klíče v hranatých závorkách.

¨ vyvolat automaticky - zda se bude aktivovat automaticky při spuštění činnosti

¨ znovu načítat – tento atribut způsobuje znovunačtení volné karty po zápisu dat na kartu. Volnou kartu je navíc možné „znovu načíst“ volbou z menu Obecné nebo po stisku funkční kláves F6.

¨ skript – definuje skript v jazyce Foxpro vyvolávaný v okamžiku zápisu volné karty. Pokud skript vrátí logickou hodnotu .F. (FALSE) není karta zapsána. Vyvolání skriptu se dá využít:

a/ k zápisu dalších informací na VK

např.: datum na VK je datem aktualizace VK

REPLACE bw01uziv1 WITH tool.uziv

REPLACE sp00datzap WITH DATETIME()

REPLACE bw01jmeno WITH tool.jmeno

b/ odeslání e-mailu před zápisem VK

¨ komentář – libovolná poznámka k volné kartě

¨ informace o tom, kdo a kdy volnou kartu založil

Vzhled volné karty je dán uživatelským designem (menu Volby nebo klávesa F6 - „design vstupního formuláře"), který určuje to, jak budou jednotlivé atributy volné karty rozmístěné v okně volné karty. Pokud to daná činnost umožňuje, lze vyvolat kteroukoliv volnou kartu po stisku menu Obecné a pak si příslušnou volnou kartu vybrat podle toho, zda se jedná o volnou kartu procesu, operace apod.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 26.03.2008


Pojem - Volná karta - užití volné karty

Záložka „užití volné karty“ sleduje využívání jednotlivých volných karet a tím usnadňuje rozhodování implementátora o tom, kterou volnou kartu ponechat a kterou je vhodné vyřadit. Užití volné karty, která je otevírána automaticky při spuštění formuláře zde zaznamenáno není. Zobrazuje se:

¨ kdo - jméno uživatele

¨ kdy poprvé - datum prvního použití volné karty uživatelem

¨ kdy naposledy - datum posledního použití volné karty uživatelem

¨ kolikrát - celkový počet použití volné karty uživatelem

Tyto informace se ukládají do tabulky SPVOLSTU s atributy:

¨ bw10nazev - část primárního klíče volné karty

¨ sp64nazev - část primárního klíče volné karty

¨ bw01uziv - kdo - identifikace uživatele

¨ spe6dat1 - kdy poprvé

¨ spe6dat2 - kdy naposledy

¨ spe6pocet – kolikrát

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.10.2007


Pojem - Volná karta – aktivace

Volnou kartu lze spustit rozhodnutím uživatele nebo automaticky. Uživatelské rozhodnutí je možno provést:

¨ z menu Obecné – uživatel si v tomto menu ručně spustí vybranou volnou kartu

¨ z doplňujících vlastností formuláře – kde je možno v definici těchto doplňujících vlastností zvolit funkční klávesu pro spuštění z menu

¨ v kódu po ukončení operace – lze nastavit dotaz, zda po ukončení operace se má aktivovat daná volná karta, uživatel si sám zvolí Ano či Ne.

Automatické rozhodnutí o spuštění volné karty může probíhat na základě:

¨ vlastní definice volné karty – zatržením atributu „vyvolat automaticky“ (při tomto nastavení se neuplatní přístupová práva k druhu volné karty)

¨ doplňujících vlastností formuláře (řídí se přístupovými právy k doplň. vlastnostem formuláře)

¨ kódu po ukončení operace

¨ definice druhu operace – v činnosti „druhy operací“ je nutno na záložce „další“ zatrhnout atribut „po ukončení vstup volné karty“

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Volná karta – atributy volné karty

Jedná se o záložku při definování volné karty, kde uživatel zadává jednotlivé atributy, které se budou při aktivaci volné karty uživateli nabízet. Jedná se o:

¨ identifikaci (název) atributu,

¨ druh - vybírá se ze seznamu druhů volných karet, určuje právo uživatele pro přístup k datům volné karty

¨ typ, případně délku a počet desetinných míst (typ – znaková, numerická, datumová, časová, textová, multimediální – viz. popis níže)

¨ pořadí, v jakém bude aktualizován

¨ třída (textové pole, překryvný seznam, zaškrtávací pole). Pro atributy typu překryvný seznam je možno nastavit dynamický combobox.

¨ zobrazení - v jakém zobrazení či formátu se bude daný atribut při aktivaci okna volné karty zobrazovat, např. u překryvných seznamů se zde uvádí volby, které se uživateli budou nabízet při vyvolání tohoto překryvného seznamu, např. Ano,Ne nebo Příjem,Výdej apod., u numerických atributů zde může být zapsán formát jak se číslo má v okně volné karty zobrazovat, např. 99 999 999.99. Je možné uvádět libovolně dlouhý text. Pro třídu překryvný seznam a typ znakový je možné zadat SQL dotaz uvedený znaky *~. Dotaz musí vracet dva sloupce. První sloupec určuje text zobrazovaný v překryvném seznamu a druhý hodnotu předávanou na volnou kartu, např. SQL dotaz pro překryvný seznam se seznamem uživatelů *~select (if bw01aktiv=1 then '' else '* ' endif )+bw01jmeno,bw01uziv from %%%.bwuzivat where bw01uziv<>'$SYSTE' order by bw01aktiv desc,bw01jmeno

¨ návěští (tzn. popis, který se u daného atributu bude zobrazovat v okně volné karty)

¨ poznámka - vlastní poznámka k atributu,

¨ inicializace - pokud je zde uveden atribut, který je výpočtový, je nutno pro něj mít vytvořen vlastní volný pohled. Pokud je tedy uveden „název volného pohledu.alias jeho atributu" (např. POHCLK.pclk1), pak se jedná o údaj prezentující vypočtenou hodnotu (pomocí příkazu SELECT), v opačném případě se jedná o atribut nové tabulky, která se musí po každé aktualizaci své struktury generovat. V případě, že se jedná o atribut třídy zaškrtávací pole, při inicializaci 0 je volný, při zadané inicializaci 1 je při aktivaci okna volné karty již zaškrtnutý nebo při překryvném seznamu jsou atributy v překr. seznamu fiktivně očíslovány 1,2,3 atd., tzn. že při zobrazení Ano,Ne a nastavení inicializace na 1 se při aktivaci okna volné karty přednastaví překryvný seznam na hodnotu Ano. Atribut může obsahovat výraz uvedený znakem #např.: #tool.uziv pro inicializaci hodnoty volné karty identifikací aktuálního uživatele systému. Ve vlastnosti inicializace je možné uvádět text uvedený rovnítkem. Hodnota takové atributu není ukládána do dat volné karty a tento atribut není možné editovat. Za rovnítkem se uvádí výraz v jazyce Foxpro, jehož hodnota je zobrazována pro daný atribut ve volné kartě. Hodnota atributu ve volné kartě je přezobrazována při každé změně, kterou proveden uživatel vstupem libovolného atributu. Pro správné vyhodnocení je nutné, aby vstupované atributy uváděné ve výrazu měly pořadí menší než atribut, ve kterém je uvedena vypočtená hodnota. Za rovnítkem vlastnosti inicializace je možné zadat prefix SCRIPT – inicializace je potom provedena pomocí víceřádkového skriptu v jazyce Foxpro. Příklady:

a/ název adresáta zobrazovaného na volné kartě na základě identifikace adresáta (atribut IDADR) vstupované uživatelem:

=tool.sql_dotaz([select ad01adsat from %%%.adadsat where ad01id=?_p1],[idadr])

b/ součet dvou hodnot vstupovaných uživatelem

=[hodnota1]+[hodnota2]

c/ příklad řešení se skriptem

=SCRIPT

IF [hodnota1]>20

RETURN [hodnota2]

ELSE

RETURN [hodnota1]

ENDIF

¨ validace – je zde možno uvádět kód v jazyce Foxpro, který vrací hodnoty TRUE nebo FALSE signalizující validitu atributu. V tomto kódu je možné uvádět text ### (představuje daný atribut) nebo názvy jiných atributů volné karty ohraničené hranatými závorkami. Tyto texty představují hodnotu odpovídajícího atributu. Příklady:

a/ validace na nenulovou hodnotu

IF ###=0

WAIT WIND 'Částka nesmí být nulová' NOWAIT

RETURN .F.

ENDIF

b/ validace existence adresáta zadaného uživatelem na volnou kartu

IF EMPTY([adnazev])

* předpokládá se, že ADNAZEV je atribut volné karty inicializovaný podobně jako v příkladu 1a

* tento atribut bude v průběhu vstupu prázdný, pokud hodnota atributu identifikace adresáta (v příkladu 1x se jedná o atribut IDADR) neodpovídá existujícímu adresátovi

WAIT WIND 'Adresát musí být uveden' NOWAIT

RETURN .F.

ENDIF

¨ podmínka – umožňuje definovat logický výraz v jazyce FoxPro určující podmínku vstupu do daného atributu. Pokud podmínka obsahuje výraz .F. – je atribut zobrazen ve formátu pouze pro čtení

Ve vlastnostech atributů Zobrazení, Inicializace a Validace je možné používat makra. Základní makra jsou k dispozici v Návodech a balíčcích. Vlastní definování maker se provádí činností „definice maker“ z menu Volby formuláře volná karta. Řešení příkladů pomocí těchto maker:

1a/ fky_nazev_adresata([idadr])

2a/ valid_neprazdny('Částka nesmí být nulová')

2b/ valid_fky([adnazev],'Adresát musí být uveden')

V popisech Zobrazení, Inicializace a Validace jednotlivých atributů volné karty je možné uvádět identifikátory atributů primárního klíče tabulky, se kterou je volná karta spojena. Tyto identifikátory se uvádějí v hranatých závorkách. Např.: na volnou kartu adresáta zobrazit název adresáta v atributu inicializace - =tool.sql_dotaz([select ad01adsat from %%%.adadsat where ad01id=?_p1],[ad01id])

¨ p. oknu – přizpůsobení oknu – určuje, zda akceptovat změny velikosti atributu při změnách velikosti celého okna volné karty (Ne, Horizontálně, Vertikálně, Obojí)

¨ F2 - reakce - zda má být při vstupu údaje po stisku F2 aktivována zde uvedená činnost, tj. vstup do zvoleného číselníku.

Na záložce „atributy volné struktury" uživatel tedy definuje atributy, které po vyvolání příslušné volné karty vyplňuje, resp. prohlíží (ty mají údaj "inicializace" uveden názvem volného pohledu). Atributy volné karty jsou pak k dispozici v transformacích druhu procesu. Pokud je chceme použít jako výstupní atributy komponenty, tak v seznamu výstupních atributů komponenty (klávesa F5 v činnosti „Definice výrazu) nejsou zobrazeny. Do výrazů je nutno je zapsat po stisku klávesy F3 a před vlastní název výrazu je nutno připsat znak „~" (např. výraz ~data.divs je definován hodnotou atributu "divs" volné karty). Tento znak zaručí, že systém nebude daný výraz kontrolovat z hlediska syntaxe.

Atributy volné karty typu 'Multimediální' se používají:

1. s nevyplněnou vlastností 'Inicializace' - obrázek nebo videoklip je ukládán v tabulce volné karty

2. s vyplněnou vlastností 'Inicializace' výrazem uvedeným znakem '=' - obrázek není uložen v tabulce volné karty - na volné kartě je zobrazován obrázek ze souboru, jehož název je určen vyhodnocením výrazu této vlastnosti

3. s vyplněnou vlastností 'Inicializace' výrazem uvedeným znakem '=' a uvedeným textem AVI v popisu třídy atributu - videoklip není uložen v tabulce volné karty - na volné kartě je zobrazován videoklip ze souboru, jehož název je určen vyhodnocením výrazu této vlastnosti

Výraz vlastnosti 'Inicializace' je vyhodnocován dynamicky při přezobrazování volné karty, takže se při pohybu v záznamech formuláře, ke kterému je karta připojena, může docházet ke změně zobrazovaného obrázku resp. videoklipu. Multimediální atributy v vyplněnou vlastností 'Inicializace' mohou mít uveden ve vlastnosti 'Validace' kód v jazyce Foxpro, který má být prováděn při pravém kliku myší na obrázku resp. pravém okraji videoklipu.

K dispozici jsou makra, která usnadňují vytváření volných karet pro zobrazování multimédií, které jsou uloženy jako dokumenty BM připojené k objektům BM. Rozhodnutí o tom zda budou obrázky objektů ukládány v tabulce volné karty (ad 1.) nebo jako dokumenty BM (ad 2.) ovlivní implementaci. Obrázky objektů BM implementované způsobem ad 1. je možné prohlížet prostřednictvím volné karty a tisknout klasickou předlohou výstupu, další možnosti nejsou. Obrázky objektů BM implementované způsobem ad 2. (s využitím maker) je možné tisknout v předlohách výstupu typu Excel (tisk v klasické předloze výstupu je obtížný), použít s jinými nástroji Windows (např. publikovat na internetu), zahrnout do řízení procesu (např. při pořizování přijaté faktury přinutit uživatele připojit k procesu oskenovanou kopii přijaté faktury). Pro zobrazování dokumentů BM, které jsou svým charakterem obrázky resp.videoklipy, připojené k objektům BM, jsou připravena makra pro použití ve vlastnostech 'Inicializace' a 'Validace' multimediálních atributů volných karet.

Pro vlastnost 'Inicializace' makro - DOKUMENT_OBRAZEK_OBJEKTU.

Substitucí makra vznikne výraz, který vrací název souboru obsahujícího obrázek, který je uložen v dokumentu připojeného k objektu BM. Protože k objektu BM může být připojeno více dokumentů, z nichž pouze některé jsou obrázky, uvádí se parametrem tohoto makra, jakého druhu dokumentu a jakou předlohu dokumentu může mít připojený obrázek. Jediným parametrem makra je identifikátor obecné předkontace, které by měly mít uvedeny hodnoty:

- VK0001 - seznam druhů dokumentů

- VK0002 - seznam předloh výstupu

Na volné kartě je potom zobrazován obrázek uložený v prvním nalezeném připojeném dokumentu, který je druhu podle hodnoty VK0001 a má předlohu výstupu podle hodnoty VK0002. Dokument s obrázkem nebo videoklipem přitom může být uložen v databázi BM nebo uložený externě.

Pro vlastnost 'Validace' makro - DOKUMENT_OBRAZEK_RIGHTCLICK

Toto makro je možné použít pouze v případě, že je ve vlastnosti 'Inicializace' uvedeno volání makra DOKUMENT_OBRAZEK_OBJEKTU. Substitucí makra vznikne kód v jazyce Foxpro, který po pravém kliku klávesou myši na obrázku resp. pravém okraji videoklipu zobrazí menu:

1. v případě, že dokument není k objektu BM připojen:

1a) Založit dokument - obrázek

- volbou uživatel vybírá soubor obrázku s příponou podle hodnoty obecné předkontace VK0001 (identifikace této překontace je dána voláním makra DOKUMENT_OBRAZEK_OBJEKTU)

- následně vstupuje vlastnosti nově zakládaného dokumentu s předplněným názvem podle prvého parametru makra a s předplněným způsobem uložením dokumentu podle druhého parametru makra (0=předplňovat ukládání do databáze, 1=předplňovat externí uložení na disk), přitom vybírá druh dokumentu podle VK0001 a předlohu dokumentu podle VK0002 a odpovídající přípony

2. v případě, že je dokument k objektu BM připojen:

2a) Vyměnit dokument - obrázek

- volbou uživatel vybírá soubor obrázku s příponou podle předlohy daného dokumentu, kterým bude nahrazen obrázek uložený v dokumentu BM. Tato volba je podmíněna právem zápis pro uživatele k druhu daného dokumentu.

2b) Opravit dokument - obrázek

- volbou je vyvolána oprava dokumentu

2c) Uložit jako ...

- volba pro uložení kopie obrázku na disk

2d) Kopírovat

- provede kopii souboru do schránky Windows (obrázek je potom možné např. vložit do dokumentu Wordu, jako přílohu e-mailu, ...)

2e) Vlastnosti dokumentu

- volba pro prohlížení a opravy vlastností dokumentu BM

Pro vlastnost 'Inicializace' makro - EXTERNI_OBRAZEK

Makro se používá ve vlastnostech 'Inicializace' atributů typu 'Multimediální' volných karet. Substitucí makra vznikne výraz, který vrací název souboru obsahujícího obrázek resp. videoklip podle parametrů makra.

Parametry:

1. adresářová cesta k souboru

2. název souboru bez přípony

3. přípona souboru - může být uvedena souborová maska např. '*'

Makro je třeba uvádět s prefixem SCRIPT.

Příklad:

=script externi_obrazek('mediup\pict\',[sp60id],'*')

Pro vlastnost 'Validace' makro - EXTERNI_OBRAZEK_RIGHTCLICK

Makro se používá ve vlastnostech 'Validace' atributů typu 'Multimediální' volných karet. Toto makro se většinou používá při použití makra EXTERNI_OBRAZEK uvedeného ve vlastnosti 'Inicializace'.

Substitucí makra vznikne kód v jazyce Foxpro, který po pravém kliku klávesou myši na obrázku zobrazí menu:

1. Kopírovat - provede kopii souboru do schránky Windows (obrázek je potom možné např. vložit do dokumentu Wordu, jako přílohu e-mailu, ...)

Příklad:

externi_obrazek_rightclick()

Příklady:

1. Procesy

Karta - FOTO

Název volné karty - Foto dokladu procesu

Velikost - Oběma směry horizontálně i vertikálně

Posuvník - Oba horizontální i vertikální

Autor - Nezobrazovat na volné kartě

Atribut - PICT

Typ - Multimediální

Inicializace - =dokument_obrazek_objektu('VKIM01')

Validace - dokument_obrazek_rightclick([sp33cisdr]+'-'+[sp33cisdpm]+'-'+[sp33cisd] , 0)

Přizpůsobení oknu - Ne

Šířka - 700

Výška - 1000

2. Operace

Karta - FOTO

Název volné karty - Foto dokladu operace

Velikost - Oběma směry horizontálně i vertikálně

Posuvník - Oba horizontální i vertikální

Autor - Nezobrazovat na volné kartě

Atribut - PICT

Typ - Multimediální

Inicializace - =dokument_obrazek_objektu('VKIM02')

validace - dokument_obrazek_rightclick('['+trim(iif(empty([sp06idsubs]),[sp07idtyp],lower([sp06idsubs]+'-'+[sp07idtyp])))+'] '+[sp33cisdr]+'-'+[sp33cisdpm]+'-'+[sp33cisd] , 0)

Přizpůsobení oknu - Ne

Šířka - 700

Výška - 1000

3. Artikl (SP)

Karta - FOTO

Název volné karty - Foto artiklu

Velikost - Oběma směry horizontálně i vertikálně

Posuvník - Žádný

Autor - Nezobrazovat na volné kartě

Atribut - PICT

Typ - Multimediální

Inicializace - =dokument_obrazek_objektu('VKIM03')

Validace - dokument_obrazek_rightclick([sp61id]+'-'+[sp60id] , 0)

Přizpůsobení oknu - Obojí

Šířka - není podstatná

Výška - není podstatná

Na záložce „atributy volné struktury“ uživatel tedy definuje atributy, které po vyvolání příslušné volné karty vyplňuje, resp. prohlíží (ty mají údaj "inicializace" uveden názvem volného pohledu). Atributy volné karty jsou pak k dispozici v transformacích druhu procesu. Pokud je chceme použít jako výstupní atributy komponenty, tak v seznamu výstupních atributů komponenty (klávesa F5 v činnosti „Definice výrazu) nejsou zobrazeny. Do výrazů je nutno je zapsat po stisku klávesy F3 a před vlastní název výrazu je nutno připsat znak „~“ (např. výraz ~data.divs je definován hodnotou atributu "divs" volné karty). Tento znak zaručí, že systém nebude daný výraz kontrolovat z hlediska syntaxe.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 26.03.2008


Pojem - Volná karta – volné pohledy

Jedná se o záložku při definování volné karty a tato záložka obsahuje příkazy SELECT pro získání informací výpočtem z dat IS BM, jinými slovy záložka „volné pohledy“ umožňuje doplnit definici atributů volné struktury o SQL dotaz, kterým tyto atributy mají být plněny. Definuje se zde:

¨ pohled - identifikaci a název volného pohledu,

¨ návratové hodnoty - tj. výčet atributů klíče uvozených znaky $$$. a oddělených čárkou. Je to seznam výrazů (oddělených čárkami) ve formátu FoxPro vyhodnotitelných ve formuláři, ze kterého je volná karta vyvolána. Atribut uvozený $$$. je nahrazen názvem aliasem dočasné tabulky (tj. kurzoru) událostí odpovídající komponenty, ke kterému je volná karta připojena,

¨ formální parametry - tj. výčet atributů klíče uvozených znaky _ a oddělených čárkou. Je to seznam identifikátorů pod kterými budou tyto hodnoty vystupovat v SQL dotazu. Doporučuje se, aby název jednotlivých atributů byl uvozen podtržítkem.

¨ dotaz - tj. příkaz SELECT pro získání dat, ve kterém je možné využít formální parametry uvozené otazníkem (pro příklad se zadanou inicializací v atributech volné struktury obsahuje tento volný pohled atribut pclk1),

¨ poznámka - libovolný popis uživatele.

Z výše uvedeného vyplývá, že „návratové hodnoty“ vrací hodnotu daného atributu z daného formuláře na základě aktivního záznamu (např. pokud bude návratovou hodnotou atribut ad01id, tak systém v tuto chvíli vrátí identifikaci adresáta, na které je v danou chvíli v tabulce adresáře v přehledu jednotlivých záznamů umístěn kurzor). Formální parametry obsahují již konkrétní data atributu, který je v dotazu v příkazu SELECT uveden otazníkem (např. ?_ad01id). Jinými slovy, laicky řečeno, návratové hodnoty říkají systému „na co se má zeptat“, formální parametry poskytují již získanou „určitou hodnotu“.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Volná karta adresáta

Volná karta adresáta je dostupná (definice i prohlížení) nejen v činnosti adresář v menu Obecné – Volné karty – Definovat volné karty, ale ve většině činností, které zobrazují seznam záznamů, ve kterých je adresát uveden (události, ...), jako VOLNÉ KARTY ADRESÁTA. Volná karta adresáta umožňuje sledovat údaje, které jsou jinak v IS současně v jednom okně obtížně dostupné, např. je možno u každého distributora vést jeho vlastní kartu, tzn. např. sledovat hodnotu prodaného software apod.

Příklad:

Pohledávky (Volná karta Adresáře)

Atributy:

POHCELKEM N(13,2) text Inicializace: POHCLK.pclk1

…

Volné pohledy:

Pohled: POHCLK Celkové pohledávky kategorie 1

Návratové hodnoty: $$$.ad01id

Formální parametry: _ad01id

Dotaz:

SELECT ISNULL(SUM(PLUDA.pl02crmnu),0) pclk1

FROM %%%.PLUDA PLUDA

WHERE PLUDA.ad01id=?_ad01id AND

PLUDA.pl02pohzav=1 AND

PLUDA.pl02kateg=1 AND

PLUDA.pl02uhraze=0

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Volná karta artiklu

Volná karta artiklu je dostupná (definice i prohlížení) nejen v činnosti Informační centrum –Typy a řady - Artikl v menu Obecné – Volné karty – Definovat volné karty, ale ve většině činností, které zobrazují seznam záznamů, ve kterých je artikl uveden (události, ...), jako VOLNÉ KARTY ARTIKLU (SP).

Současně lze definovat volné karty artiklu v každé činnosti s přehledem artiklů (tzn. obchodovatelný artikl, skladovaný artikl apod.) v menu Obecné – Volné karty – Definovat volné karty. Ty jsou ale dostupné vždy jen v činnosti, kde byly definovány.

Volná karta artiklu umožňuje uživateli sledovat informace o artiklu.

Příklad:

Informace o artiklu – sklad (Volná karta artiklu)

Atributy:

SKLNAT0 N(12,2) text Inicializace: SKLNAT.nat

SKLREZ0 N(12,2) text Inicializace: SKLREZ.rez

SKLDSP0 N(12,2) text Inicializace: SKLNAT.nat-SKLREZ.rez

Volné pohledy:

Pohled1: SKLNAT Skladováno v naturální jednotce

Návratové hodnoty: $$$.sp61id, $$$.sp60id

Formální parametry: _sp61id, _sp60id

Dotaz:

SELECT ISNULL(SUM(MTAH.mt02hodnot),0) nat

FROM %%%.MTAH MTAH

WHERE ?_sp61id=MTAH.sp61id AND

?_sp60id=MTAH.sp60id AND

MTAH.sp67id LIKE 'NAT%'

Pohled2: SKLREZ Rezervováno na skladě

Návratové hodnoty: $$$.sp61id, $$$.sp60id

Formální parametry: _sp61id, _sp60id

Dotaz:

SELECT ISNULL(SUM(MTAH.mt02hodnot),0) rez

FROM %%%.MTAH MTAH

WHERE ?_sp61id=MTAH.sp61id AND

?_sp60id=MTAH.sp60id AND

MTAH.sp67id LIKE 'ODB%'

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Volná karta operace

Volná karta operace je dostupná (definice i prohlížení) nejen v činnosti Operace v menu Obecné – Volné karty – Definovat volné karty, ale ve většině činností, které zobrazují seznam záznamů, ve kterých je operace uvedena (události, ...), jako VOLNÉ KARTY OPERACE.

Volnou kartu operace, která se definuje u Druhu operace na záložce Další, lze automaticky „spustit“ , pokud je nastaven atribut „ po ukončení vstup volné karty operace“. Atributy této VK rozšiřují množinu výstupních atributů komponenty pro transformace, které jsou uvedeny ve vazbách, kde je daný druh operace zdrojovým uzlem.

Volnou kartu procesu je možno vyvolat při běhu procesu i ručně, a to volbou příslušné činnosti v menu Obecné. Na základě definic v kódu po ukončení operace lze s volnou kartou operace pracovat (spustit, naplnit, ...) i automatizovaně.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Volná karta procesu

Volná karta procesu je dostupná (definice i prohlížení) nejen v činnosti Procesy v menu Obecné – Volné karty – Definovat volné karty, ale ve většině činností, které zobrazují seznam záznamů, ve kterých je proces uveden (operace, ...), jako VOLNÉ KARTY PROCESU.

Volná karta procesu umožňuje uživateli sledovat údaje (atributy procesu), jejichž struktura je definována uživatelsky, tj. ty, které nejsou běžně dostupné v událostech operací daného procesu nebo které chce mít po ruce jako kompletní informace k procesu (volná karta u procesu je kdykoliv dostupná z menu Obecné v činnosti Procesy a operace – Procesy, z fyzických operací i jednotlivých událostí).

Výjimečné postavení má volná karta procesu, která se definuje u druhu procesu (činnost Informační centrum – Typy a řada) na záložce „Další“. Po stisku záložky další je tedy možno pomocí klávesy F3 definovat volnou kartu. Atributy této volné karty jsou k dispozici v transformacích druhu procesu. Pokud je chceme použít jako výstupní atributy komponenty, tak v seznamu výstupních atributů komponenty (klávesa F5 v činnosti Definice výrazu) nejsou zobrazeny. Do výrazů je nutno je zapsat po stisku klávesy F3 a před vlastní název výrazu je nutno připsat znak „~“ (např. výraz ~data.divs je definován hodnotou atributu „divs“ volné karty). Tento znak zaručí, že systém nebude daný výraz kontrolovat z hlediska syntaxe.

Automatické spouštění volné karty procesu (uvedené u druhu procesu) je možno nadefinovat v činnosti Druhy operací (na záložce „Další“ je to atribut „po ukončení vstup volné karty procesu“). V kódu po ukončení operace lze definovat automatické spuštění volné karty procesu nebo její automatické naplnění.

Příklad (DIFAKT je název volné karty) automatického vyplnění volné karty procesu bez zásahu obsluhy:

DECLARE OBJECT difakt

SET difakt=CREATE('KU_DATA')

difakt.SET_PROCESS()

difakt.FC_OPEN('difakt')

difakt.FC_PUT('naprij',nazprij)

difakt.FC_SAVE()

Volnou kartu procesu je možno vyvolat při běhu procesu i ručně, a to volbou příslušné činnosti v menu Obecné.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Volná karta vazby objektů

Volná karta vazby objektů je dostupná (definice i prohlížení) ve většině činností, kde byla použita objektová vazba (tzn. je k dispozici ikona „souvislosti objektů“), jako VOLNÁ KARTA VAZBY OBJEKTŮ.

Volnou kartu vazby objektů je možno definovat v případě, že byla mezi objekty vytvořena vazba pomocí rámečku souvislostí. Tzn. když budeme mít například událost vývěsky, která je přes rámeček souvislostí svázána s dokumenty (tzn. v rámečku souvislostí je u dokumentu znaménko + v pozici syna) je možno pod menu Obecné definovat volnou kartu vazby objektů. Tato možnost není v praxi zřejmě příliš využívána, ale je možno nadefinovat např. volnou kartu, která bude vyjadřovat význam vztahu adresátů apod. V IS BM je možné vytvářet jakékoliv vazby objektů, tudíž i definice volných karet je závislá na aktuálních potřebách uživatele.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Volné údaje

Na této záložce je vhodné evidovat údaje o pracovníkovi, které nás zajímají a které nám neumožňují sledovat jiné záložky, např. údaje o dosaženém vzdělání, o provedených školeních apod. Jsou to uživatelsky nastavitelné údaje a pro jejich správné fungování je třeba mít nadefinovány sady parametrů a jejich strukturu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 11.10.2007


Pojem - Vstup dat

Jedná se o primární pořízení aplikačních i definičních dat IS uživatelem, které může být v informačním systému Bílý Motýl realizováno pomocí klávesy F3 nebo importem. Pro vstup událostí jsou dále k dispozici nástroje automatického vstupu událostí.

Pořízená data je obvykle možné opravovat.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Vstupní atributy komponenty

Je to množina atributů události dané komponenty daná programovým kódem, ke kterým lze v rámci pravidla transformace definovat algoritmus jejich předplnění. Definují strukturu okna pro definici pravidla transformace.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Výběr položek výstupu

Jedná se o okno, které má uživatel k dispozici při definování položek výstupu u nově vytvářené předlohy výstupu po vyvolání možnosti „opravit předlohu“ (výběrem z panelu nástrojů nebo po stisku pravého tlačítka myši na názvu předlohy). V levé části okna má uživatel k dispozici seznam dostupných:

¨ programátorsky definovaných položek:

¨ programátorsky zvolených atributů z tabulek datového prostředí

¨ programátorsky zvolených atributů běžného (tj. standardního) výběru (tyto atributy jsou uvozeny *)

¨ uživatelsky definované položky v deklaraci

Položky definované v doplnění, ale neuvedené v deklaraci, zde nejsou, ale lze je následně v definici jejich uspořádání definovat a uplatnit:

¨ u typu předlohy sestava výběrem z datového prostředí

¨ u typu předlohy Excel a HTML s pomocí příkazu DEKLARACE

V případě předlohy dokladu je seznam položek výstupu rozdělen na základní informace a dále dle komponent na základě prezentace, tzn. že uživatel si zvolí vybranou komponentu a pak teprve určuje položky výstupu, které mají z dané komponenty být obsaženy v předloze výstupu (nenabízejí se položky týkající se běžného výběru).

Pro typ předlohy sestava je navíc k dispozici vzor výstupu. Typ předlohy Excel je možné vytvořit ve tvaru druhého typu (programovaná varianta). K tomu je určeno zaškrtávátko "Excel typu2" (jiné by se používat nemělo). Dále se na tomto formuláři pro tento typ předlohy uplatňuje zaškrtávátko "mezisoučet", které definuje sloupce, za které budou prováděny mezisoučty. Výsledkem je předloha, která je naformátovaná a obsahuje libovolný počet mezisoučtů. Pro předlohu typu ostatní (tj. HTML) je k dispozici možnost „spojit se sloupcem“, kde v překryvném seznamu má uživatel možnost si vybrat z položek výstupu který sloupec chce spojit s kterým. Výsledkem je potom předloha, kde budou vybrané položky výstupu spojeny v jednou sloupci.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.07.2013


Pojem - Výběr vstupem

Nadefinované obecné výběry jsou shodné s výběry definovanými ve vlastnostech činnosti (pravý klik myši na činnosti v hlavním menu). Výběry vstupem jsou uživateli dostupné v případě, že činnost, ze které se tento výběr spouští má uživatel dostupnou v hlavním menu (tzn. pokud bude mít uživatel v hlavním menu nedostupnou komponentu obchod a její události – a na těchto událostech bude definován tento výběr vstupem, tak při spuštění např. událostí obchodu daného adresáta se mu tento výběr vstupem zobrazovat nebude). Přístup k „výběru vstupem“, tj. zda se uživateli zobrazí na pravý klik myši na atributu „uchovat“ je možný dvojím způsobem podle nastavení atributu „veřejný přístup“ při definici výběru. Tento atribut může dosahovat těchto stavů:

¨ ANO - přístup je dán zařazením aktuálního uživatele do některé ze skupiny uživatelů spojených s výběrem (tedy do skupiny, která má přístup k danému výběru). Přidělovat práva skupin uživatelů má nejen vlastník výběru, ale i správce systému a každý uživatel s právy správce (zároveň mají možnost nastavovat atribut „veřejný přístup“.) V konečném důsledku to znamená, že výběr se nemusí na atributu „uchovat“ zobrazovat ani samotnému vlastníku výběru.

¨ NE - přístup k výběru je výhradní pouze pro vlastníka výběru. Ve formuláři pro definování výběrů vstupem se výběr s takto nastaveným atributem zobrazí pouze jeho vlastníkovi, správci systému a uživateli s právy správce (při neveřejném přístupu není možno definovat pro skupiny uživatelů práva k výběru).

Samotné nastavení parametrů výběru (po stisku klávesy F5) je dovoleno všem uživatelům. Nově založený výběr vstupem automaticky získává aktuální nastavení atributů výběrové záložky ve stavu po posledním zápisu výběru na záložce výběr (např. uživatel si aktivuje činnost kompletní vývěska, na záložce výběr si vyplní atributy zapsal, datum události a text – aktivuje si pravou myší atribut uchovat a bude si chtít nadefinovat nový výběr vstupem). V tom případě po stisku F5 definice nového výběru budou automaticky v definici tohoto výběru již předplněny atributy zapsal, datum události a text.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 14.09.2007


Pojem - Výběrová řízení

Výběrové řízení je možno vysvětlit jako proces, který firma zahájí, několikrát zopakuje a na konci by měl být viditelný výsledek, např. provádí-li firma výběrové řízení na nový firemní IS tak nejprve zanalyzuje požadavky, osloví vytipované dodavatele s nabídkou, poté s nimi provede jednání, nabídky IS apod. a na konci si zvolí jednoho dodavatele se kterým sepíše smlouvu o dodávce.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.10.2007


Pojem - Výčetky platidel

Tato činnost se nachází v menu Mzdy – Mzdy. Využije ji nejspíš pouze ten uživatel, který vyplácí své mzdy nikoliv převodem na účet pracovníka, ale v hotovosti. Činnost mu usnadní spočítat výčetku platidel pro výplatu každého pracovníka. Obsahuje tři možnosti:

¨ číselník platidel – nadefinovaný číselník jednotlivých platidel

¨ jednotlivé výčetky platidel – přehled za vybrané pracovníky

¨ sumární výčetka platidel za výplatní místo – celkový přehled výčetky platidel za zvolené výplatní místo

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 11.10.2007


Pojem - Vyhledávání

Po spuštění většiny činností se nejprve aktivuje záložka výběr. Tímto výběrem je jako prvním zúžena množina zobrazovaných záznamů. Tuto množinu může ještě dále vyfiltrovat i obecný výběr. Pokud má uživatel k dispozici již zvolenou množinu dat, může využít další způsoby vyhledávání.

¨ pomocí indexu – tzn. vyhledávání, které uživateli poskytuje panel nástrojů. Nejprve je nutno si zkontrolovat, podle jakého atributu jsou záznamy setříděny, protože není možno mít např. v adresáři setříděny záznamy podle identifikace adresáta a vyhledávat název adresáta. Vyhledávání a setřídění záznamů musí být vždy v souladu. Tzn. pokud uživatel bude např. hledat ve zvolené množině konkrétní název adresáta, bude mít třídění nastaveno podle názvu adresáta a do vyhledávacího pole napíše název adresáta – není nutno psát celý název, stačí první písmeno z názvu nebo část slova, systém podle toho pak vyhledává záznamy, které odpovídají tomuto zadanému vyhledávání. Je zde možno zadávat vyhledávání s diakritikou i bez ní.

¨ fultextové – tzn. pomocí klávesy Ctrl F, kde zapíše vyhledávané slovo a kurzor po jeho vyhledání automaticky skočí na záznam, který hledané slovo obsahuje (při tomto vyhledávání se hledaná slova zapisují s diakritikou).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Výkaz zisků a ztrát (výsledovka)

Výkaz zisku a ztráty (někdy zkráceně výsledovka) ukazuje, jakého hospodářského výsledku společnost dosáhla za sledované a minulé období. Výkaz zisku a ztrát je podle zákona o účetnictví povinnou součástí účetní závěrky. Forma výkazu zisku a ztráty je v ČR upravena, používá se buď ve zkrácené nebo plné verzi. Zájemce z ní získá základní přehled o hospodaření společnosti, velikosti tržeb, nákladů v základním členění (materiálové, mzdové, odpisy…) a výši zisku. Pro získání detailnějšího přehledu o hospodaření společnosti je vhodné si prostudovat i výroční zprávu a přílohu k účetní závěrce, kde bývají uvedeny další doplňující informace.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.02.2008


Pojem - Výkazy

Výkazy je nazývána manažerská část IS BM, která je určena k analýze dat (analytickému zpracování) a která zajišťuje poskytnutí informační schopnosti IS BM uživateli výstupy, ve kterých je vlastní prezentace výsledků realizována pomocí sešitu tabulkového procesoru MS Excel a pro které je jako zdrojová datová základna k dispozici celý datový model IS BM (všechny tabulky IS). Výkazy IS BM při své definici umožňují i využití kontingenčních tabulek MS Excel (ověřeno ve verzi MS Excel 2007 – zřejmě jsou funkční i ve starších verzích aplikace MS Excel – zde ale není možno dokonale ověřit).

Věcná struktura těchto výstupu a uspořádání poskytovaných informací v nich je vždy dáno uživatelským nastavením v definici každého z nich.

Uživateli jsou všechny činnosti související s touto částí IS k dispozici v hlavním menu pod skupinovou položkou INFORMAČNÍ CENTRUM - VÝKAZY.

Nastavením příkazu LOCK v dodatečných deklaracích definice listu výkazu systém umožňuje zamknout zdrojová data. Tento zadaný příkaz pak zabrání zápisu událostí komponenty účetnictví po dobu sestavení (výpočtu) výkazu. Doba výpočtu výkazu je zaznamenána v rezervovaných zdrojích systému.

Pro bezproblémový chod jednotlivých výkazů je nutno nadefinovat:

¨ definice výkazu

¨ listy výkazu

¨ formát buňky

¨ funkce výkazů

¨ šablony listů výkazu

¨ vzory listů

¨ dotazy výkazů

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 13.05.2009


Pojem - Výkazy - zaokrouhlování

Pro vytvoření výkazu, ve kterém mají být hodnoty zobrazovány zaokrouhlené na celá čísla, tisíce, milióny nebo miliardy je možné definovat proměnnou výkazu ZAOKROUHLI.

Nabývá-li tato proměnná v okamžiku výpočtu výkazu hodnot 2 nebo 3 nebo 4 nebo 5, potom hodnoty, které mají ve svém sloupci nastavenu vlastnost Zaokrouhlovat=Ano nebudou zobrazovány v Excelu formátem buňky podle vlastnosti 'Formát čísel' , ale podle vlastnosti 'Formát zaokr.' (není-li vyplněn formátem #,##0) doplněným podle požadovaného zaokrouhlení.

V případě, že proměnná ZAOKROUHLI nabývá hodnotu:

2 - hodnoty budou zobrazovány zaokrouhlené na celá čísla - obvykle formátem #,##0

3 - hodnoty budou zobrazovány zaokrouhlené na tisíce - obvykle formátem #,##0,

4 - hodnoty budou zobrazovány zaokrouhlené na milióny - obvykle formátem #,##0,,

5 - hodnoty budou zobrazovány zaokrouhlené na miliardy - obvykle formátem #,##0,,,

Pokud se má způsob zaokrouhlování týkat všech listů výkazu, potom je vhodné definovat proměnnou ZAOKROUHLI v dotazu výkazu např.:

¨ Proměnná - ZAOKROUHLI

¨ Typ - Numerická

¨ Návěští - Zaokrouhlit

¨ Naplnění - Vstup

¨ Inicializace - 1

¨ Třída - Překryvný seznam - Ne,Koruny,Tisíce,Milióny

Pozn.:

Listy výkazů definovaných podle vzoru mohou obsahovat sloupce, které nemají být zobrazovány zaokrouhleně (např. čísla řádků účetní výsledovky, ....). Nastavení vlastnosti Zaokrouhlovat=Ne pro tyto sloupce je možné postupem:

1. zapamatujte si obsah vlastnost listu - Vzor

2. nastavte vlastnost listu Vzor = -

3. vyvolejte opravu listu klávesou F6

4. nastavte vlastnost daného sloupce Zaokrouhlovat=Ne

5. obnovte vlastnost listu - Vzor

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 06.03.2007


Pojem - Vymáhání

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.01.2013


Pojem - Výměra pozemku

Plocha pozemku zobrazeného v katastrální mapě jako parcela, tj. plocha vztažená k vodorovné zobrazovací rovině této mapy; zaokrouhluje se na celé metry čtvereční.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Výplatní lístek

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 12.04.2006


Pojem - Výpočet daňového přiznání

Výpočet daňového přiznání uživatel provede v činnosti „daňová přiznání“ po stisku klávesy F5 nebo aktivací činnosti „Výpočet DP“ pod menu Volby. Uživatel musí mít kurzor umístněn na definici daňového přiznání, které chce počítat, tzn. když chce uživatel spočítat běžné daňové přiznání, musí tzv. „stát“ na řádku DANPR6 – Daňové přiznání po 1.1.2009.

Po aktivaci této činnosti se mu zobrazí dialogové okno, kde je předplněn rok a měsíc za který se má daňové přiznání vypočítat. Tyto údaje samozřejmě může uživatel editovat. Po jejich zapsání (pomocí ikony „disketa“ v panelu nástrojů) dojde k vlastnímu výpočtu daňového přiznání.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 23.03.2010


Pojem - Výpočet KD

Výpočet krmných dnů probíhá na základě následujícího algoritmu. Systém z obratů skladu zvířat vybere záznamy (podle data, umístění, kategorie, počátečního/konečného stavu) s nižším datem, než je zadané datum na šabloně výpočtu krmných dnů, pro ty kategorie zvířat, které mají zaškrtnutý příznak KD. Z obratů systém bere tyto hodnoty:

¨ množství (tj. počet krmných dnů) – určené parametrem „množství v MJ pro výpočet KD“ (činnost Parametry komp. sklad zvířat)

¨ podle nastavení parametru „započítávat stavy do KD“ (činnost Parametry komp. sklad zvířat) hodnota počáteční nebo konečný stav

První obrat pro zvolenou kategorii a umístění je určen prvním zápisem hodnoty „množství v MJ pro výpočet KD“ do obratů. Od tohoto data se kontrolují stavy (počáteční/konečný) za všechny dny až do zadaného data vůči událostem, které mají shodné: datum, umístění, kategorii a druh operace má nastaven v činnosti Parametry operace komponenty „výpočet KD“. Není-li stav shodný, je vygenerován záznam operace s rozdílovým množstvím. Je-li ke kategorii přiřazena stejná cenová skupina, jako je zadána v parametru „cenová skupina pro výpočet vzrůst. přír. (činnost Parametry komp. sklad zvířat), je množství krmných dnů zároveň oceněno (tj. vyhodnocen vzrůstový přírůstek) dle ceny uvedené v ceníku.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 18.06.2014


Pojem - Vypočtená daňová přiznání

Vypočtená daňová přiznání má uživatel rovněž k dispozici v činnosti „daňová přiznání“ po stisku klávesy F6 nebo aktivaci činnosti „Vypočtená daňová přiznání“ pod menu Volby. Uživatel musí mít kurzor umístněn na definici daňového přiznání, které počítal, tzn. na tom řádku s definicí, na kterém aktivoval výpočet daňového přiznání.

Po aktivaci činnosti „vypočtená daňová přiznání“ se mu zobrazí daná činnost s aktivní záložkou „výběr“, kde si uživatel určí za jaké období chce mít vypočtené přiznání k dispozici:

¨ rok – definice roku

¨ měsíc/kvartál – možnost zvolit si období daného roku. V případě měsíců se zadávají ve tvaru 01, 02, ....11, 12. V případě, že si uživatel jako období zvolí kvartál – musí být zadán ve tvaru Q1, Q2, Q3 a Q4.

Uživatel výběr uloží (pomocí ikony „disketa“ v panelu nástrojů) a zobrazí se mu přehled jednotlivých řádek daňového přiznání za vybrané období (viz obr. 13). Zde si pak může jednotlivé řádky prohlédnout, v případě nesrovnalostí pak ještě doladit, znovu spočítat a následně si vybrané daňové přiznání vytisknout.

K tomu uživatel využije předloh výstupu pod ikonou „tiskárna“ v panelu nástrojů. K dispozici má předlohu výstupu pro daňové přiznání vytvořenou pro MS Excel „Daňové přiznání – vzor č. ...“ (dle platného znění – viz. dokument legislativně závislá nastavení). Tím jak se v čase tiskopisy pro podání daňového přiznání mění, tak se mění i předlohy výstupu (tzn. např. pro rok 2010 je vzor výstupu č. 16). Proto je zde k dispozici několik čísel vzorů daňového přiznání, aktuální tiskopis daňového přiznání má vždy to nejvyšší číslo. Přiznání k dani z přidané hodnoty lze podávat takto běžnou cestou (tzn. vytisknout předlohu a odeslat) nebo elektronickým způsobem[1].

Pro podání daňového přiznání elektronickou cestou je k dispozici předloha výstupu ADIS 2009 (pro rok 2010 je to předloha výstupu ADIS 2010. Vždy se jedná o aktuální předlohu k danému roku).

[1] Pro ověření správnosti dat doporučujeme uživateli vždy načíst daný soubor do aplikace EPO (elektronické podání) i v případě, že daň. přiznání nebude podávat elektronicky. Uživatel je po načtení souboru upozorněn na případné chyby, které si má opravit.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 23.03.2010


Pojem - Výraz

Výrazem se zde rozumí uživatelsky definovaný výraz, který se využívá v transformacích, resp. v jejich pravidlech. Výrazy jsou selektovány dle komponenty (z pohledu vazby zdrojové) a dle druhu (C, N, D, ...).

Výrazy se formulují za použití funkcí FoxPro a výstupních atributů komponenty. Při použití jiných prvků pro definici výrazu je nutno jej uvést vlnovkou (~), pak není prováděna kontrola jejich syntaxe v okamžiku jeho definování, v okamžiku provádění programu je však syntaxe kontrolována. V případě chyby je uživateli systémem nahlášena. Jsou-li uvedeny ~ dvě, není výraz kontrolován z hlediska syntaxe ani v okamžiku definice, ani v okamžiku provádění programu. V tomto případě systém nehlásí žádnou chybu, ale padá. Například ve výrazech lze užít níže uvedené prvky v dané syntaxi:

¨ VK ~data.cspr+’-’+data.naprij - předplní atributem volné karty cspr (číslo procesu), pomlčku a atributem volné karty naprij (název příjemce)

¨ saldokontní hodnoty ~~this.saldo([typ],[druh hodnoty],[druh artiklu],[artikl]) - vrací hodnotu za daný druh saldokontní hodnoty a artikl

¨ atributy doplněné pohledem ~data.sp33extcis - příklad, kdy je připojen atribut externí číslo procesu

¨ pomocné slučování [##] - tento výraz se užívá v atributu agregace v pravidlech transformace

¨ obecná předkontace

- do numerického atributu - ~~VAL(TOOL.HODNOTA_OBECNE_PREDKONTACE_PREDKONTACE(‘ADDIPR’,data.ad01id1)) - předplní dle příjemce hodnotu provize

- do atributu typu C - „#P <výraz1>;<výraz2>“ (výraz 1 je identifikace předkontace, výraz 2 je význam), kde <výraz x> je v daném okamžiku vyhodnotitelný výraz ve formátu FoxPro, např. (~#P 'FP-028';'IDU'+RIGHT(tool.user,2)).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Výraz obecného výběru

Výraz obecného výběru rozšiřuje klausuli WHERE příkazu SELECT dané činnosti oproti standardnímu výběru. Po stisku klávesy F2 nebo pravého tlačítka myši ve žlutém výrazovém poli se zobrazí aktuální datové prostřední pohledu, kde jako hlavní je uvedena tabulka (ta, z jejíž činnosti se obecný výběr spouští) a její atributy a vazby na další tabulky, které jsou s hlavní tabulkou svázané. V případě potřeby je možno činnost rozšířit a vytvořit novou vazbu.

Ve výrazu se dají použít proměnné obecného výběru, musí však být uvedeny v hranatých závorkách. Pokud je zapsaný výraz příliš dlouhý a je obtížné se v něm takto orientovat, může uživatel využít možnosti, kterou mu nabízí atribut „výraz“. Po stisku pravého tlačítka myši na tomto atributu se uživateli zobrazí okno, kde vidí výraz celý a může si ho zde pohodlně prohlížet, případně i editovat.

Ve výrazu je možno rovněž zadat i programový kód v jazyce FoxPro, který zajistí sestavení daného výběru. Výraz musí být uvozen .post script a takto nadefinovaný výběr následně při spuštění funguje tak, že se sestavuje dynamicky podle toho, co v daném okamžiku zvolí uživatel.

V tuto chvíli je nutno upozornit implementátory, že při použití .post script ve výrazu obecného výběru nad určitou činností může nastat problém s předlohami výstupu nad touto činností. Jedná se o předlohy, které mají ve vlastnostech na záložce Seskupování vyplněny atributy SELECT, GROUP a HAVING. Tyto sestavy pak v kombinaci s takto vytvořeným výběrem nefungují, tzn. že není vhodné nad danou činností v sestavách aplikovat seskupování, pokud zároveň je v obecném výběru ve výrazu použit programový kód v jazyce FoxPro. Je velmi obtížné pak tyto sestavy a obecný výběr sladit dohromady, resp. pokud se na to implementátor nesoustředí již při jejich definování, je vlastně nemožné je potom sestavit.

Příklad napsaného výrazu za použití scriptu nad obecnými výběry v činnosti adresář:

.post_script

LOCAL _SQL,_pom

DO pridej_kategorie WITH _this,<jektg1>,<ktg11>,<ktg12>,<ktgdn1>,<ktgod1>,<ktgkd1>,<ktgnep1>

DO pridej_kategorie WITH _this,<jektg2>,<ktg21>,<ktg22>,<ktgdn2>,<ktgod2>,<ktgkd2>,<ktgnep2>

if <jepldph>=1

_this.add_sql_plus('adadsat.ad01pladph='+ltrim(str(<pldph>)))

endif

if <jezal>=1

text to _sql noshow textmerge

exists(select * from %%%.bwupdrc where bwupdrc.bw10nazev='ADADSAT ' and bwupdrc.sp64nazev=space(8) and

bwupdrc.bw92key=adadsat.ad01id+space(44) and

bwupdrc.bw92datum >= <<uprav_cas(<zaldatum>)>> and

bwupdrc.bw92zmena=1)

endtext

_this.add_sql_plus(_SQL)

text to _sql noshow textmerge

(select max(bwupdrc.bw92datum)
from %%%.bwupdrc where bwupdrc.bw10nazev='ADADSAT '
and bwupdrc.sp64nazev=space(8) and

bwupdrc.bw92key=adadsat.ad01id+space(44) and

bwupdrc.bw92datum >= <<uprav_cas(<zaldatum>)>> and

bwupdrc.bw92zmena=1) bw92datum_zal

endtext

_this.add_attr_plus(_SQL)

endif

if <dupnaz>=1

text to _sql noshow textmerge

exists(select * from %%%.adadsat ad2

where

ad2.ad01adsat=adadsat.ad01adsat and

ad2.ad01id<>adadsat.ad01id) and

not adadsat.ad01adsat like '%Zakladni skola%' and

not adadsat.ad01adsat like '%gymnasium%' and

not adadsat.ad01adsat like '%materska skola%' and

not adadsat.ad01adsat like '%Městská knihovna%' and

not adadsat.ad01adsat like '%obchodni akademie%' and

not adadsat.ad01adsat like '%Středisko služeb školám%'

endtext

_this.add_sql_plus(_SQL)

endif

if <dupnazi>=1

text to _sql noshow textmerge

exists(select * from %%%.adadsat ad2

where

ad2.ad01adsat=adadsat.ad01adsat and

ad2.ad01id<>adadsat.ad01id and

(ad2.ad01id like '07%' or adadsat.ad01id like '07%')

) and

not adadsat.ad01adsat like '%Zakladni skola%' and

not adadsat.ad01adsat like '%gymnasium%' and

not adadsat.ad01adsat like '%materska skola%' and

not adadsat.ad01adsat like '%Městská knihovna%' and

not adadsat.ad01adsat like '%obchodni akademie%' and

not adadsat.ad01adsat like '%Středisko služeb školám%'

endtext

_this.add_sql_plus(_SQL)

endif

if <jespo>=1

_pom=iif(<spovyb>=7,'ad11adsat',iif(<spovyb>=1,'ad11jmeno',iif(<spovyb>=2,'ad11jmenop',iif(<spovyb>=3,'ad11cislo',iif(<spovyb>=4,'ad11mobil',iif(<spovyb>=5,'ad11fax',iif(<spovyb>=6,'ad11email',iif(<spovyb>=8,'ad57id','ad11jmeno'))))))))

if <spoimpl>=1

text to _sql noshow textmerge

adspoji.<<_pom>> like '<<trim(<spotxt>)+'%'>>'

endtext

else

text to _sql noshow textmerge

exists(select * from %%%.adspoj ad56 where

ad56.ad01id=adadsat.ad01id and

ad56.<<_pom>>

like '<<trim(<spotxt>)+'%'>>')

endtext

endif

_this.add_sql_plus(_SQL)

endif

if <jespo2>=1

_pom=iif(<spovyb2>=7,'ad11adsat',iif(<spovyb2>=1,'ad11jmeno',iif(<spovyb2>=2,'ad11jmenop',iif(<spovyb2>=3,'ad11cislo',iif(<spovyb2>=4,'ad11mobil',iif(<spovyb2>=5,'ad11fax',iif(<spovyb2>=6,'ad11email',iif(<spovyb2>=8,'ad57id','ad11jmeno'))))))))

if <spoimpl2>=1

text to _sql noshow textmerge

adspoji.<<_pom>> like '<<trim(<spotxt2>)+'%'>>'

endtext

else

text to _sql noshow textmerge

exists(select * from %%%.adspoj ad56 where

ad56.ad01id=adadsat.ad01id and

ad56.<<_pom>>

like '<<trim(<spotxt2>)+'%'>>')

endtext

endif

_this.add_sql_plus(_SQL)

endif

if <jeduv>=1

_this.add_sql_plus([exists(select * from %%%.adadsat_kkf where adadsat_kkf.ad01id=adadsat.ad01id and adadsat_kkf.sp11idzak like ']+trim(<duvors>)+'%'+[' and trim(adadsat_kkf.sp11idzak)<>'')])

endif

IF <jepart>=1

DO CASE

CASE <part>=1

_pom='VIP '

CASE <part>=2

_pom='DUL '

CASE <part>=3

_pom='PAR '

OTHER

_pom=''

ENDCASE

TEXT to _sql noshow textmerge

EXISTS(select * from %%%.nkpredpr,%%%.nkinipre where nkpredpr.ad01id=adadsat.ad01id and

nkpredpr.nk01stav=4 and nkpredpr.sp61id='VIP' and

nkinipre.sp61id=nkpredpr.sp61id and

nkinipre.sp60id=nkpredpr.sp60id and

nkinipre.nk01verze=nkpredpr.nk01verze and

nkinipre.sp60id2 like '<<_pom>>%'

ENDTEXT

IF !EMPTY(<partum>)

_sql=_sql+[ and nkpredpr.nk06id like ']+trim(<partum>)+[%']

ENDIF

_sql=_sql+')'

_this.add_sql_plus(IIF(<partnot>=1,'not ','')+_SQL)

ENDIF

IF <jeinshop>=1

TEXT to _sql noshow textmerge

exists(select * from %%%.adadsat_inshop where adadsat_inshop.ad01id=adadsat.ad01id and

adadsat_inshop.kkfdat<[inshopdat] )

ENDTEXT

_this.add_sql_plus(IIF(<inshopnot>=1,'not ','')+_SQL)

ENDIF

IF <jeobc>=1

if <obcaskola>=0

TEXT to _sql noshow textmerge

adadsat.ad01id in (select obudal.ad01id from %%%.obudal where obudal.ob02dat between [obcod] and [obcdo] and

obudal.sp20idzak like '<<trim(<OBCTVS>)+'%'>>' and obudal.sp10idzak like '<<trim(<OBCOBS>)+'%'>>' and obudal.sp11idzak like '<<trim(<OBCORG>)+'%'>>' and

not obudal.sp07idtyp in ('obvybr','vobjti')

)

ENDTEXT

else

TEXT to _sql noshow textmerge

not adadsat.ad01id in (select obudal.ad01id from %%%.obudal where obudal.ob02dat between [obcod] and [obcdo] and

obudal.sp20idzak like '<<trim(<OBCTVS>)+'%'>>' and obudal.sp10idzak like '<<trim(<OBCOBS>)+'%'>>' and obudal.sp11idzak like '<<trim(<OBCORG>)+'%'>>' and

not obudal.sp07idtyp in ('obvybr','vobjti'))

and

<<iif(<obcpos>=0,'','(')>>

exists(select * from %%%.obudal,%%%.adspoj xxspoj where obudal.ob02dat between [obcod] and [obcdo] and

obudal.sp20idzak like '<<trim(<OBCTVS>)+'%'>>' and obudal.sp10idzak like '<<trim(<OBCOBS>)+'%'>>' and obudal.sp11idzak like '<<trim(<OBCORG>)+'%'>>' and

not obudal.sp07idtyp in ('obvybr','vobjti') and

xxspoj.ad01id2=obudal.ad01id and xxspoj.ad01id=adadsat.ad01id)

ENDTEXT

endif

do case

case <obcpos>=0

case <obcaskola>=0

_SQL='( '+_SQL+ ' or adadsat.ad01id in (select poposta.ad01id from %%%.poposta where poposta.po01datza between [obcod] and [obcdo]) )'

other

TEXT to _sql noshow textmerge

<<_sql>>

or

exists(select * from %%%.poposta,%%%.adspoj xxspoj where

poposta.po01datza between [obcod] and [obcdo] and

xxspoj.ad01id2=poposta.ad01id and xxspoj.ad01id=adadsat.ad01id)

)

ENDTEXT

endcase

IF <obcnot>=1

_SQL='not ('+_SQL+')'

ENDIF

_this.add_sql_plus(_SQL)

ENDIF

IF <jerecvyt>=1

TEXT to _sql noshow

exists(select * from %%%.mtuda,%%%.spprc LEFT OUTER JOIN %%%.spprc_popvydej VK ON

VK.sp33cisdr=spprc.sp33cisdr and VK.sp33cisdpm=spprc.sp33cisdpm and VK.sp33cisd=spprc.sp33cisd

and VK.druvyd='SKV100'

where

mtuda.ad01id=adadsat.ad01id and

mtuda.mt02dat between [recvytod] and [recvytdo] and

(mtuda.sp11idzak like 'MR0[12]%' OR

ISNULL(VK.orgs,'') like 'MR0[12]%' ) and

mtuda.sp33cisdr=spprc.sp33cisdr and

mtuda.sp33cisdpm=spprc.sp33cisdpm and

mtuda.sp33cisd=spprc.sp33cisd and

spprc.sp33storno=1

ENDTEXT

IF !EMPTY(<recvytsel>) or !EMPTY(<recvytobs>) or !EMPTY(<recvytorg>)

* _sql=_sql+[ and mtuda.sp20idzak like ']+left(trim(<recvytsel>)+'%',9)+[']+[ and mtuda.sp10idzak like ']+left(trim(<recvytobs>)+'%',9)+[']+[ and mtuda.sp11idzak like ']+left(trim(<recvytorg>)+'%',9)+[']

_sql=_sql+[ and mtuda.sp20idzak like ']+left(trim(<recvytsel>)+'%',9)+[']+[ and mtuda.sp10idzak like ']+left(trim(<recvytobs>)+'%',9)+[']+[ and (mtuda.sp11idzak like ']+left(trim(<recvytorg>)+'%',9)+[' OR ISNULL(VK.orgs,'') like '] +left(trim(<recvytorg>)+'%',9)+[')]

ENDIF

_sql=_sql+[)]

IF <recvytnot>=1

_SQL='not '+_SQL

ENDIF

_this.add_sql_plus(_SQL)

ENDIF

IF <jeclanek>=1

TEXT to _sql noshow

exists(select * from %%%.vyudalos where

vyudalos.ad01id=adadsat.ad01id and

vyudalos.vy01datum between [clanekod] and [clanekdo] and

vyudalos.sp07idtyp='recen '

ENDTEXT

IF !EMPTY(<claneksel>) or !EMPTY(<clanekobs>) or !EMPTY(<clanekorg>)

_sql=_sql+[ and vyudalos.sp20idzak like ']+left(trim(<claneksel>)+'%',9)+[']+[ and vyudalos.sp10idzak like ']+left(trim(<clanekobs>)+'%',9)+[']+[ and vyudalos.sp11idzak like ']+left(trim(<clanekorg>)+'%',9)+[']

ENDIF

_sql=_sql+[)]

IF <claneknot>=1

_SQL='not '+_SQL

ENDIF

_this.add_sql_plus(_SQL)

ENDIF

IF <jepos>=1

_SQL='adadsat.ad01id in (select poposta.ad01id from %%%.poposta where poposta.po01datza between [posod] and [posdo]'+;

iif(empty(<postvs>),'',[ and poposta.sp20idzak like ']+trim(<postvs>)+'%'+['])+;

iif(empty(<posobs>),'',[ and poposta.sp10idzak like ']+trim(<posobs>)+'%'+['])+;

iif(empty(<posors>),'',[ and poposta.sp11idzak like ']+trim(<posors>)+'%'+['])+[)]

IF <posnot>=1

_SQL='not '+_SQL

ENDIF

_this.add_sql_plus(_SQL)

ENDIF

IF <jeobj>=1

TEXT to _sql noshow textmerge

exists(select * from %%%.obudal OBUDAL10 where OBUDAL10.ob02privyd in (1,4) and

OBUDAL10.ad01id=adadsat.ad01id and OBUDAL10.ob02dat between [objod] and [objdo] and OBUDAL10.sp07idtyp<>'rezdod'

and

obudal10.sp20idzak like '<<trim(<objtvs>)+'%'>>' and obudal10.sp10idzak like '<<trim(<objobs>)+'%'>>' and obudal10.sp11idzak like '<<trim(<objorg>)+'%'>>'

)

ENDTEXT

IF <objnot>=1

_SQL='not '+_SQL

ENDIF

_this.add_sql_plus(_SQL)

ENDIF

IF !EMPTY(<poztxt>)

TEXT to _sql noshow textmerge

exists(select * from %%%.adadsat_poznamka where adadsat_poznamka.ad01id=adadsat.ad01id and

adadsat_poznamka.text like '%<<trim(<poztxt>)+'%'>>' )

ENDTEXT

_this.add_sql_plus(_SQL)

ENDIF

IF <jexad>=1

DO CASE

CASE <xad>=1

TEXT to _sql noshow textmerge

adadri.dp04tuzzah<>1 and

adadri.ad05id='CZ '

ENDTEXT

CASE <xad>=2

TEXT to _sql noshow textmerge

exists(select * from %%%.adadr ax where ax.ad01id=adadsat.ad01id and ax.dp04tuzzah<>2 and

not ax.ad05id

in

('AT ','BE ','CY ','DE ','DK ','ES ','FI ','FR ','GB ','GR ','HU ','IE ','IS ','IT ','LT ','LU ','MT ','NL ','PL ','PT ','SE ','SI ','SK ','LO ','EST','RO ','BG ','CZ '))

ENDTEXT

*SMI 25.1.2012 vyhozeno 'LI '

CASE <xad>=3

TEXT to _sql noshow textmerge

exists(select * from %%%.adadr ax where ax.ad01id=adadsat.ad01id and ax.dp04tuzzah<>3 and

ax.ad05id

in

('AT ','BE ','CY ','DE ','DK ','ES ','FI ','FR ','GB ','GR ','HU ','IE ','IS ','IT ','LT ','LU ','MT ','NL ','PL ','PT ','SE ','SI ','SK ','LO ','EST','RO ','BG '))

ENDTEXT

*SMI 25.1.2012 vyhozeno 'LI '

ENDCASE

_this.add_sql_plus(_SQL)

ENDIF

IF <jead05id>=1

TEXT to _sql noshow textmerge

ADADRI.ad05id like '<<alltrim(<ad05id>)+'%'>>'

ENDTEXT

IF <ad05idne>=1

_SQL='not '+_SQL

ENDIF

_this.add_sql_plus(_SQL)

ENDIF

IF <jenes>=1

TEXT to _sql noshow textmerge

NOT ADADSAT.ad01adsat2 LIKE'%'+TRIM(ADADSAT.ad01adsat)+'%'

ENDTEXT

_this.add_sql_plus(_SQL)

ENDIF

IF <jeodpn>=1

TEXT to _sql noshow textmerge

ADADSAT.ad01unodpo=<<trans(int(<odpn>))>>

ENDTEXT

_this.add_sql_plus(_SQL)

ENDIF

IF <jesml>=1

TEXT to _sql noshow textmerge

exists(select * from %%%.nksmlouv where nksmlouv.ad01id=adadsat.ad01id and nksmlouv.nk56id like '<<trim(<smlnk56id>)+'%'>>' and

nksmlouv.nk27datum between [smlod] and [smldo])

ENDTEXT

IF <smlnot>=1

_SQL='not '+_SQL

ENDIF

_this.add_sql_plus(_SQL)

ENDIF

IF !EMPTY(<usrjmeno>)

TEXT to _sql noshow textmerge

BWUZIVAT.bw01jmeno LIKE '<<trim(<usrjmeno>)+'%'>>'

ENDTEXT

_this.add_sql_plus(_SQL)

ENDIF

if <dotazfo>=1 and !empty(_this.sql_plus)

do oznafo with _this,_thisform

endif

IF <tim>=1 and <timod> >0

TEXT to _sql noshow textmerge

ISNULL((select vk.pcbaltim from %%%.adadsat_knihkup VK where vk.ad01id=adadsat.ad01id) ,0) BETWEEN [timod] and [timdo]

ENDTEXT

* exists(select * from %%%.adadsat_knihkup VK where vk.ad01id=adadsat.ad01id and vk.pcbaltim between [timod] and [timdo])

_this.add_sql_plus(_SQL)

ENDIF

PROCEDURE pridej_kategorie

LPARAMETERS _this,_je,_k1,_k2,_dn,_dt,_k_datu,_not

LOCAL _SQL

IF _je<>1

RETURN

ENDIF

_SQL=IIF(_not=1,'not ','')+[exists(select ad08id from %%%.adkatads ads where ads.ad01id=adadsat.ad01id ]

IF EMPTY(_k1)

_k1=_k2

_k2=''

ENDIF

DO CASE

CASE EMPTY(_k1)

CASE !EMPTY(_k2)

     _SQL=_SQL+[and
(ads.ad08id like ']+TRIM(_k1)+[%' or
ads.ad08id like ']+TRIM(_k2)+[%')]

OTHER

_SQL=_SQL+[and ads.ad08id like ']+TRIM(_k1)+[%']

ENDCASE

IF !EMPTY(_dt)

_SQL=_SQL+[and ads.ad07datod>=]+uprav_datum(_dt)+' '

ENDIF

Do CASE

CASE _dn=2

     _SQL=_SQL+[and
]+uprav_datum(evl(_k_datu,_dt))+[
between isnull(ads.ad07datod,current date) AND isnull(ads.ad07datdo,current date)]

CASE _dn=3

     _SQL=_SQL+[and
not ]+uprav_datum(evl(_k_datu,_dt))+[
between isnull(ads.ad07datod,current date) AND isnull(ads.ad07datdo,current date)]

ENDCASE

_this.add_sql_plus(_SQL+[)] )

PROCEDURE uprav_datum

LPARAM _d

RETURN [']+TRANS(YEAR(_d))+'/'+TRANS(MONTH(_d))+'/'+TRANS(DAY(_d))+[']

PROCEDURE uprav_cas

LPARAM _d

RETURN [']+TRANS(YEAR(_d))+'/'+TRANS(MONTH(_d))+'/'+TRANS(DAY(_d))+;

' '+TRANS(hour(_d))+':'+TRANS(minute(_d))+':'+TRANS(sec(_d))+[']

Procedure oznafo

Lparameters _this,_thisform

LOCAL _o,_bw51

IF TYPE('_thisform.work_select')<>'C'

_bw51=sys(2015)

_thisform.addproperty('work_select',_bw51)

ELSE

_bw51=_thisform.work_select

ENDIF

_o=createobject('vyber')

_o.start(_bw51,_this.sql_plus,iif(empty(_this.attr_plus),'',[,]+_this.attr_plus),_thisform)

_this.sql_plus=[exists(select * from bm_servis.bwoznac
oz where oz.bw51=']+_thisform.work_select+['
and adadsat.ad01=oz.bw51ob)]

_this.attr_plus=''

_thisform.print_template_data=.T.

define class vyber as konektor_objekt

datasession=2

smer='FO'

procedure start

lparameters _bw51,_sql,_atr,_thisform

local _loc

use bwsql!SY0111_bwoznac alias bwoznac

=requery()

go bott

_loc=bw_lock('L','Fbwoznac')

delete all for bw51=_bw51

do bw_lock with 'U',_loc

_loc=bw_lock('L','Fbwoznac')

do case

case !this.pripoj()

return

case !bw_exec(this.con,strtran([select ad01]+_atr+[ from %%%.adadsat,%%%.adspoj adspoji,%%%.adadr adadri where adspoji.ad01id=adadsat.ad01id and ]+;

     [adspoji.ad11cisspo=adadsat.ad11cisspo
and adadri.ad01id=adspoji.ad01id and adadri.ad02cisadr=adspoji.ad02cisadr and
]+_sql,;

'?thisform.','?_p1.',1,10000,1),'vyber',_thisform)

return

endcase

_loc=bw_lock('L','Fbwoznac')

select vyber

scan all

select bwoznac

append blank

replace bw01uziv with tool.uziv,;

bw51 with _bw51,;

bw51ob with vyber.ad01

endscan

use in vyber

do bw_lock with 'U',_loc

use in bwoznac

enddefine

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 26.09.2012


Pojem - Výraz užívaný ve výkazech

Výrazem se zde rozumí výraz v syntaxi FoxPro s možností využití uživatelsky definovaných funkcí výkazu, parametrů, proměnné _prvek.cradr, která obsahuje aktuální číslo řádku při sestavení výkazu,a symbolů reprezentujících tyto atributy uvedenýchentit (tabulek) IS BM:

_prvek.vk06nazev - VKBUNKA.vk06nazev – název buňky,

_prvek.vk05nazev - VKRADEK.vk05nazev – název řádku,

_prvek.vk04nazev - VKSLOUP.vk04nazev – název sloupce,

_prvek.vk03nazev - VKLIST.vk03nazev – název listu.

Parametry se ve výrazu uvádějí svým identifikátorem uzavřeným do hranatých závorek.

Výraz lze užít k definici obsahu buněk i pojmenovaných textů, k nastavení hodnoty parametru, k definici názvu výstupního souboru výkazu, k definici výrazu vzoru.

Například výraz s funkcí výkazů ADKAT000('BIMO%') nebo s funkcí výkazů a parametry OBUDFIN([adr],[drart],[art],[alo],[datod],[datdo],[drop]) nebo výrazy konstantní 'Trzby PV' a '13%;14011%' nebo výraz s parametry a atributy entit IS BM a funkcí Foxpro _prvek.vk03nazev+' '+dtoc([datod])+' - '+dtoc([datdo]) nebo výraz s proměnnou (aktuální číslo řádku při sestavení výkazu) a parametrem _prvek.cradr+[radek_plus] apod.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Výraz vzoru listů výkazů

Výraz vzoru listu je definice „ukazatele“ (logického pojmu), který využívá uživatel při definici listu pomocí vzoru. Výraz vzoru listu je definován pořadím, popisem, tj.názvem, pod kterým je dostupný uživateli ve vzoru, a výrazem, kterým je mu přiřazen skutečný obsah (např. pomocí funkce výkazu).

Dále je možné pro každý výraz vzoru listu definovat až pět parametrů, na jejichž skutečnou hodnotu bude uživatel dotázán při aplikaci daného výrazu vzoru listu. Parametr se definuje identifikátorem, typem (C,N,D), délkou a návěštím, pod kterým se prezentuje uživateli ve vzoru.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 18.06.2014


Pojem - Výrobní linky a stroje

Tato činnost poskytuje uživateli přehled nadefinovaných výrobních linek (jsou zvýrazněny modrou barvou) a jednotlivých strojů. Ke každé lince nebo stroji je možno nadefinovat přístupová práva (menu Volby nebo Ctrl B). Údaje této činnosti jsou pro uživatele k dispozici na následujících záložkách:

¨ výrobní linky a stroje – identifikace a název výrobní linky, druh linky a určení, zda se jedná o linku nebo stroj

¨ stroje výrobní linky – ke každé výrobní lince se zde přiřazují stroje, které se na lince vyskytují. Každý stroj na lince má uveden datum platnosti zařazení na linku. Poslední stroj linky určuje, jaký se předplní stroj do výstupu ve vstupech a výstupech výrobního úkolu.

¨ obsluha – ke každé výrobní lince nebo stroji se přiřazují konkrétní pracovníci. Tímto dojde k vyplnění hodnoty osobního čísla „OSC“ na vstupech výrobních úkolů (pracovní výkony) podle profese nadefinované v pracovních výkonech referenčního artiklu, který je předmětem daného výrobního úkolu

¨ výjimky v kalendáři – definují se výjimky v kalendáři pro konkrétní výrobní linku

¨ přidělené kalendáře – informace o kalendáři přiřazeném dané výrobní lince (vlastní definice kalendářů se provádí v komponentě Výroba – Kalendáře směn výroby)

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.01.2008


Pojem - Výrobní úkoly

Tato činnost představuje přehled dílčích výrobních úkolů k jednotlivým zakázkám. Struktura poskytovaných informací je závislá na tom, jaké kritérium si uživatel zvolí na záložce „výběr“.

Přehled výrobních úkolů se tvoří automaticky a to po spuštění generování úkolů zakázky, tzn. že výrobní úkoly jsou dílčí kroky vedoucí k realizaci výrobní zakázky. Tyto kroky jsou definovány jako technologické operace v technologickém postupu, jehož pilotním artiklem je artikl z výrobní zakázky.

Každý výrobní úkol poskytuje uživateli tyto základní a pro něj specifické informace:

¨ identifikaci procesu

¨ příznak, zda se jedná o aktuální výrobní úkol – Ano/Ne – jedná o další možnost, jak třídit výrobní úkoly. Normované výrobní úkoly mají vždy příznak aktuální NE, plánované se stávají neaktuálními po přesunutí do očekávaných, očekávané se stávají neaktuálními po přesunutí do realizovaných.

¨ fáze výrobního úkolu - plánované (typicky vygenerované dle TPV a tudíž rovnající se hodnotami hodnotám normovaným, nastávají ale i situace, kdy je nutno změnit hodnoty předplněné z TPV, např. změnit artikl nebo množství na vstupu)

- očekávané (výrobní úkoly se typicky přesouvají z fáze plánované do fáze očekávané tehdy, když jsou výrobní úkoly naplánovány z hlediska času, tj. výrobní úkol je naplánován v harmonogramu výroby a je definována materiálová i pracovní náročnost)

- realizované – označuje již hotové výrobní úkoly s hodnotami u stupů a výstupů odpovídající realitě

- normované – vstupy a výstupy podle TPV, slouží jen pro porovnání

¨ VČ – výrobní číslo sjednocuje výrobní úkoly náležející stejné výrobní zakázce

¨ skupina výrobního úkolu – představuje časové uspořádání výrobních úkolů (technologických operací) dle technologického postupu. Jedná se o tříznakový atribut nabývající hodnot 001, 002, ... (u normovaných výrobních úkolů 701, 702, ...). Pokud je výstup výrobního úkolu vstupem následujícího výrobního úkolu, je na záložce „následující skupiny úkolů“ přehled následujících výrobních úkolů.

¨ pořadové číslo výrobního úkolu (6-ti znakový atribut) – označuje podmnožinu skupiny výrobního úkolu (např. jeden výrobní úkol bude trvat 3 dny, výroba funguje na 3 směny a pracuje se na 2 výrobních linkách. Potom bude existovat 18 výrobních úkolů se stejným výrobním číslem, stejnou skupinou výrobního úkolu, ale budou se lišit právě pořadovým číslem – 000001, 000002, ...

¨ směna – označuje v jaké směně se bude výrobní úkol dělat

¨ datum zahájení a ukončení – určuje časové naplánování (realizaci) výrobního úkolu, mění se podle naplánování výrobního úkolu v harmonogramu výroby

¨ délka trvání – čas potřebný na realizaci výrobního úkolu

¨ linka – definice, na jaké lince bude výrobní úkol prováděn

¨ artikl – jedná se o výstup výrobního úkolu (referenční artikl technologické operace výrobního úkolu)

¨ operace – jedná se o technologickou operaci z technologického postupu, kterou je realizován výrobní úkol

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.01.2008


Pojem - Výstupní atributy komponenty

Je to množina atributů, které jsou k dispozici pro tvorbu výrazů využitelných v transformacích, pro něž je daná komponenta zdrojová. Současně jsou tyto atributy přímo k dispozici v kódu po ukončení operace.

Tato základní množina atributů je dána primárně programovým kódem, dále ji lze rozšířit pomocí atributu „doplnění pohledu“ v transformaci, případně atributy volné karty operace či procesu definované na záložce „Další“ (činnost Informační centrum – Typy a řady – Druhy procesů, Druhy operací). Základní množinu výstupních atributů si může uživatel zobrazit po stisku klávesy F5 z činnosti Definice výrazů, kterou si vyvolal při definování pravidel transformace.

Doplněné atributy nelze užít v míře plnění, ale ani v určitých atributech (např. množství skladu), pokud se nevypne test mírou plnění u druhu operace (uzlu). Podobně je tomu tak i s atributy z volné karty, resp. salda.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Výstupní soubor výkazu

Definice souboru, do kterého bude sestaven výkaz, a jeho adresáře. Soubor lze definovat přímo (například trzby.xls) nebo výrazem (například s využitím parametrů 'urp'+[rok]+[mes]+'.xls'). Programový adresář je implicitní.

Při opakovaném sestavení výkazu se nejprve načte již existující výstupní soubor výkazu a jeho listy jsou dle nastavení u šablony smazány nebo přepsány.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Výstupy

Výstupem se rozumí některá z následujících forem poskytnutí informační schopnosti IS uživateli:

¨ okno (činnosti) - určeno pouze k prohlížení, rozsah informační schopnosti výstupu ovlivňuje implementace jen minimálně, je dána programovým kódem (blíže viz dokumentace ovládání)

¨ jiné - určeno k dalšímu zpracování (tisk, graf, uložení na www, poslat e-mail, ...), rozsah informační schopnosti výstupu je v podstatné míře definována v rámci implementace

¨ výstupy v rámci činností IS - výchozí rozsah informační schopnosti výstupu je dán programovým kódem (fakticky určitým subsetem datového modelu IS vymezeným pro tuto činnost), ale v rámci implementace jej lze rozšířit. Seznam vycházející z jediné "nejsilnější" entity činnosti. Dle nástroje pro zobrazení:

- sestava

- Excel

- HTML (MSIE)

Dle způsobu definice výchozího subsetu datového modelu:

- doklady (subset DM kromě programového kódu je definován prezentací procesu)

- ostatní /asi nějak nazvat/ (pouze programový kód)

¨ výkazy - celý rozsah informační schopnosti výstupu definován při implementaci. Nevychází z jediné "nejsilnější" entity, ale z celé řady uživatelsky definovaných subsetů.

¨ slovník dat (viz dokumentace web) - celý rozsah informační schopnosti výstupu (pohledu - pojem) definován při implementaci. Každý pohled vychází z jediné "nejsilnější" entity, uživatelsky definované.

Z hlediska přístupu k IS BM pomocí MSIE se tato kategorizace výstupů neuplatní.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 08.04.2004


Pojem - Výstupy procesů

Jedná se o atribut dostupný u předloh výstupu v jejích vlastnostech na záložce popis. Nejedná se o výstupy procesů jako takové, přesnější termín je nastavení způsobu tisku zvolených nebo předdefinovaných předloh výstupu nebo dokladů. Každý výstup procesu , tzn. doklad, musí mít uvedenu metapředlohu a prezentaci. Možnosti tisku tedy jsou:

¨ podle parametrů uživatele – v úvahu se tedy bude brát varianta, kterou má každý uživatel nastavenou ve svých parametrech uživatele

¨ rozhodnout – uživatel má možnost si zvolit, jestli chce tisknout na tiskárnu, do souboru nebo pouze předlohu prohlížet v okně, tzn. vždy se mu zobrazí dialogové okno tisku

¨ prohlížet – předloha se automaticky zobrazí pouze k prohlížení v samostatném okně

¨ tisknout se zastavením – uživateli se zobrazí dialogové okno, kde má v tomto případě možnost zvolit si tiskárnu a počet kopií dané předlohy

¨ tisknout bez zastavení – daná předloha výstupu nebo doklad se automaticky tiskne bez zásahu uživatele

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Výstupy v rámci činností IS BM

Jednotlivé nadefinované předlohy výstupu využívá uživatel samozřejmě především při potřebě tisku vybraných dat. Činnost tisk uživatel aktivuje z panelu nástrojů (ikona tiskárna), výběrem příslušné činnosti z menu Volby nebo stiskem klávesy Ctrl T. Po spuštění tisku (jakýmkoliv z uvedených způsobů) se uživateli zobrazí samostatné okno „výstupy“. V tomto okně má uživatel přehled dosud nadefinovaných předloh výstupu. Pro ovládání tohoto okna má uživatel k dispozici panel nástrojů (tj. horní lišta), kde jsou následující možnosti ve formě ikon:

¨ spuštění výstupu – vlastní aktivace tisku vybrané předlohy výstupu

¨ oprava předlohy – u nové předlohy slouží tato činnost k výběru položek výstupu, u již nadefinované předlohy k opravě definice uspořádání položek

¨ výběry – uživatel si zde může nadefinovat výběr a jeho podmínku. Tento výběr mu slouží pro případ, že záložka výběr a možnosti ve vlastnostech předlohy (setřídění, doplnění, seskupování) nesplňují přesně jeho požadavky. Tímto výběrem si pak požadovaná výběrová kritéria může upřesnit. Při spuštění předlohy výstupu s tímto použitým výběrem pak IS BM provádí svůj SELECT, který vychází z činnosti (nad kterou probíhá tisk) a je upraven podle uživatelských definic ve vlastnostech předlohy (setřídění, seskupování, doplnění)

¨ nová předloha – pomocí této možnosti uživatel zadává novou předlohu výstupu. Atributy, které zde zadává jsou shodné s vlastnostmi předlohy, takže je zde nebudeme podrobně rozepisovat.

¨ kopie předlohy – uživatel má možnost na základě již nadefinované předlohy vytvořit kopii, kde si pouze zadá svůj nový název a samozřejmě má možnost si tuto kopii následně upravovat.

¨ vlastnosti předlohy

¨ zrušení – možnost zrušení vybrané předlohy výstupu

¨ zobrazovat skryté předlohy – po stisku této ikony uživatel bude mít k dispozici i ty předlohy výstupu, které mají ve svých vlastnostech zatržen příznak „skrytá“

¨ způsoby zobrazení okna předloh výstupu – možnost zvolení si způsobu, jak budou jednotlivé předlohy výstupu v okně výstupu uspořádány. Je možnost zvolit zobrazení: velké ikony, malé ikony, seznam, detaily a zobrazení ve formě stromu. Při zobrazení ve formě stromu lze využít i činnosti „nastavení stromu“. Při zobrazení ve formě seznamu jsou metapředlohy umístěny podle názvu na začátek, oproti tomu při řazení ve formě stromu jsou jednotlivé poduzly stromu zobrazeny podle názvu pod sebou (bez ohledu na to, jestli se jedná o metapředlohu či předlohu výstupu). Při zobrazení ve formě stromu se při uzavírání okna předloh výstupu ukládá pro každého uživatele informace, které složky stromu byly rozbalené, takže při následujícím otevření tohoto okna stejným uživatelem jsou ve stejném stavu, tzn. stejně rozbalené jako při předchozím ukončení činnosti.

¨ nápověda – nápověda k činnosti

¨ nápověda – seznam položek k tisku – zobrazí se přehled atributů dané činnosti, které jsou dostupné při definování uspořádání položek výstupu

¨ konec činnosti – ukončení a zavření okna „výstupy“.

Kromě činností, které uživateli nabízí panel nástrojů (tj. horní lišta) okna výstupů má k dispozici ještě i činnosti, které se mu nabídnou po stisku pravého tlačítka myši kdekoliv ve volném (tzn. bílém) prostoru okna činnosti výstupy. Některé činnosti jsou shodné s činnostmi dostupnými v horní liště, ale navíc má uživatel k dispozici:

¨ balíčky

¨ metapředlohy

¨ vzory výstupu

¨ překlad popisek

¨ skupiny procesů/předloh výstupu

¨ osobní skupina předlohy

¨ nastavení stromu

Vlastní zahájení tisku vybrané předlohy výstupu může uživatel provést těmito způsoby:

¨ dvojklikem levého tlačítka myši přímo na názvu vybrané předlohy výstupu

¨ stiskem ikony tiskárna v panelu nástrojů okna výstupů

¨ výběrem možnosti spustit předlohu po stisku pravého tlačítka myši na názvu předlohy

V případě, že není nastaveno jinak (v profilech předlohy nebo na záložce popis ve vlastnostech předlohy) zobrazí se uživateli dialogové okno tisku. Zde má uživatel možnost si zvolit rozsah tisku (všechny, aktuální, označené), jazyk, setřídění, zda předlohu tisknout nebo si data jen prohlédnout apod.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.02.2010


Pojem - Význam

Význam je atribut uživatele, který lze užít různým způsobem dle potřeb implementátora pomocí obecné předkontace (např. číslo adresáta).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Vzdálené funkce - nastavení

Tato činnost úzce souvisí s činností Sady vzdálených funkcí – nastavení. Je dostupná v hlavním menu – Informační centrum – Algoritmy a parametry – Nastavení vzdálených funkcí.

V této činnosti se jednotlivé funkce nadefinují a v činnosti Sady vzdál. funkcí – nastavení se potom příslušné funkce sestaví do příslušných sad. Tato činnost a činnost Sady vzdál. funkcí rozhodně není běžnou uživatelskou činností. Může být dodána nadefinována přímo s dodávkou IS BM nebo by její definici měl provádět pouze velmi zkušený implementátor.

Takto nadefinované sady má potom teprve možnost využít uživatel, a to v činnosti Sady vzdálených funkcí.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 26.09.2012


Pojem - Vzdálený uživatel (informačního systému Bílý Motýl)

Vzdálený uživatel je ten z uživatelů, který v daném okamžiku komunikuje s IS (web serverem firmy BM Servis s.r.o. - http://isbm.bmservis.cz/bm) za pomoci web browseru.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Vzor listů výkazů

Vzor listů výkazů je uživatelsky připravená „šablona“, která uživateli usnadní nastavení definice listu. Každý vzor je opakovaně použitelný pro více listů, které jsou si svou strukturou a obsahem podobné, například přípravu všech definic listů účetních výkazů lze usnadnit jediným vzorem.

Příprava vzoru zahrnuje definici jeho identifikace, která se případně uvádí v definici listu, název, atribut parametry a případnou pevné uživatelem při aplikaci vzoru již neovlivnitelné nastavení prvních tří sloupců definice listu. Uvedené nastavení sloupce spočívá v uvedení jeho názvu (budoucí nadpis), definice obsahu výrazem, formátu a šířky. Příprava vzoru dále zahrnuje definici výrazů daného vzoru.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Vzor výstupu

Pro vytváření nových předloh výstupu typu "Sestava" je možné použít předdefinované vzory. Pro použití této funkce je možné v souboru BW.INI předdefinovat až devět vzorů v sekci "Preferences" parametry "PRINT_TEMPLATEx", kde x je číslo vzoru 1 až 9. Uvádí se <název vzoru>[;<soubor vzoru>].

Není-li <soubor vzoru> uveden předpokládá se, že vzor se nachází v podadresáři TEMPLATE adresáře programu pod jménem PTEMPx, kde x je číslo vzoru. Je-li <soubor vzoru> uveden musí být obsahovat jméno včetně přípony FRX. Je-li <soubor vzoru> vytvořen musí být spolu s ním v odpovídajícím adresáři soubor se stejným jménem s příponou FRT. Případné změny v souboru BW.INI se projeví při novém spuštění programu. Soubory vzoru je možné upravovat v okně činnosti „výstupy“ po pravém stisku tlačítka myši kdekoliv ve volném prostoru.

Soubor vzoru musí v pásu "Detail" obsahovat text s obsahem "Start_atr". Tento text určuje pozici, od které budou při vytváření nové sestavy vkládány vybrané položky a nebude do sestavy přenesen. Položka s obsahem 'LABEL' bude nahrazena názvem předlohy (nemusí být uvedena). Při vytváření nové předlohy typu "Sestava" může uživatel vybrat kromě položek zařazených do výstupu také vzor, podle kterého má být nová sestava vytvořena.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Vzorec užívaný ve výkazech

Vzorcem se zde rozumí vzorec MS Excel v anglickém jazyce (anglickém národním prostředí) užívaný v buňkách, řádcích a sloupcích definice listu nebo v buňce při nastavení definici listu pomocí vzoru.

Ve vzorci se referují jednotlivé řádky $R(n) a sloupce $S(n), kde n uvádí identifikátor definice řádku nebo sloupce. Odkaz $RL(n) nebo $SL(n) se použije pro referenci posledního řádku (sloupce) sestaveného výkazu, který byl vygenerován na základě příkazu dyn v atributu parametry řádku (sloupce) definice listu; pro referenci prvního se užije $R(n) nebo $S(n).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Vzrůstový přírůstek

Vzrůstový přírůstek se vykazuje za uvedenou kategorii zvířat v umístění. Je-li ke kategorii přiřazena stejná cenová skupina, jako je zadána v parametru „cenová skupina pro výpočet vzrůst. přír. (činnost Parametry komp. sklad zvířat), je množství krmných dnů zároveň oceněno (tj. je vyhodnocen vzrůstový přírůstek) dle ceny uvedené v ceníku, tzn. že vzrůstový přírůstek je částka, kterou jsou zvířata oceňována za jeden krmný den.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.10.2007


Pojem - Vztahy obchodovatelných artiklů k adresátům

Činnost „vztahy obchodovatelných artiklů k adresátům“ umožňuje uživateli nadefinovat si u každého jednotlivého adresáta informace k danému obchodovatelnému artiklu. Především to, jak je ve vztahu k danému adresátovi artikl identifikován (identifikace, název, objednací číslo apod.).

Příkladem použití může být situace, kdy uživatel má zadány obchodovatelné artikly s určitou identifikací a názvem a jeho dodavatel pro vybrané artikly chce používat např. jiný název nebo jiné objednací číslo.

U každého vztahu se zadávají tyto základní údaje:

¨ sada – identifikace sady, která vztah definuje

¨ priorita – hodnota od 1 do 10, přičemž čím nižší číslo, tím je priorita větší

¨ artikl – identifikace obchodovatelného artiklu

¨ adresát – identifikace adresáta, jehož se nadefinovaný vztah týká

¨ údaje k artiklu, které mají být odlišné (objednací číslo, název, čárový kód, volný údaj)

¨ časová platnost vztahu od – do

¨ poznámka

Další vlastnosti vztahu, které tady nejsou nabízeny, je možno popsat obecnými parametry pomocí činnosti sady parametrů.

Vztah obchodovatelného artiklu k adresátovi je objektem, tzn. je možné využívat objektové vazby a připojovat k němu jiné objekty (např. dokumenty, události vývěsky apod.).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 01.02.2007


Pojem - Vztažené artikly

Vztažené artikly se definují na záložce v činnosti přehled referenčních artiklů. Na ní se definují vztažené artikly k referenčnímu artiklu (např. výroba desky stolu – referenční artikl je modrá deska, vztažený artikl je barva a plech). Na jakém druhu linky se ve výrobě použije vztažený artikl určuje atribut „dr.stroje“ (má dopad na naplánování výrobních úkolů). Další atributy jsou významem totožné s atributy na záložce Referenční artikly. Pomocí klávesy F6 lze aktivovat formulář kusovníku, kde se zadávají vztahy mezi vstupy a výstupy referenčního artiklu (jedná se v podstatě o tabulku vztahů artiklu pro danou operaci a referenční artikl).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.01.2008


Pojem - Web browser

Program, který zpřístupňuje dostupné informace na síti Internet, tj. i informace z web serveru firmy BM Servis s.r.o. (http://isbm.bmservis.cz/bm). Při ověřování přístupu k datům IS Bílý Motýl byl užíván jako web browser MS Internet Explorer verze 5 (viz též Ovládání pomocí web browseru).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Web menu

Nabídka "programu", která je k dispozici vzdálenému uživateli web serveru firmy BM Servis s.r.o. (http://isbm.bmservis.cz/bm) zobrazovaná web browserem. Tato nabídka se skládá z prvků web definovaných v činnosti Definice Web menu ve skupině SYSTÉM, ke kterým má vzdálený uživatel právo přístupu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Webové rozhraní

Webovým rozhraním označujeme prostředí, pomocí kterého se vstupuje do libovolného systému (např. mail, Outlook, webový Bílý Motýl apod.). Je v něm umožněno nejen čtení, ale i vkládání nebo rušení dat (tzn. neslouží pouze jako webová prezentace). Vstup do libovolného systému se děje výhradně a pouze přes webové prohlížeče (např. Explorer, Mozilla, Firefox, Safari, ....).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 07.07.2008


Pojem - Webové služby

Webové služby jsou základním stavebním blokem pro implementaci distribuovaného zpracování na Internetu. Vytváří standard pro integraci aplikací prostřednictvím internetu. Předpokládá se, že budoucnost aplikací je v jejich komunikaci s různými zdroji informací internetu pomocí Webových služeb. Bílý Motýl ve verzi pro Runtime Foxpro 7.0 (a vyšší) samozřejmě podporuje webové služby. Webová služba je reprezentována firewallů pro příchozí zprávy. Mechanismus tunelování tedy funguje tak, že se například SOAP zpráva zabalí do již známého protokolu (HTTP, SMTP, MQseries), kterému XML. V IS BM se používá parametr PARAMS, tj. dokument XML, který specifikuje všechny parametry. Tento XML dokument je zakódovaný do BASE64.

Protokoly SOAP a WSDL jsou oba provedeny v syntaxi jazyka XML , který je navržen tak, aby byl snadno strojově zpracovatelný. Protokol SOAP (způsob komunikace) i WSDL (popis komunikace a možností) byly navrženy tak, aby byly co nejméně závislé na zvolené verzi standardu XML (formát zpráv komunikace). Oba protokoly jsou zavázány dodržet příslušné standardy WSDL (SOAP ) a zvolený standard XML.

IS BM umožňuje ve svých implementacích:

¨ zpracovávat informace externích webových služeb

¨ publikovat vlastní webové služby

V IS BM se webové služby definují takto:

¨ jedna hlavní typu DISH – specifikuje určitou skupinu webových služeb, které mají jednotný charakter (tzn. patří k sobě)

¨ všechny ostatní jsou typu SASOAP – začínající stejně jako ta hlavní. Každá z těchto podřízených obsahuje SQL příkaz

Definice webových služeb se v IS BM provádí buď přímo v databázi (pomocí jazyka SQL) nebo pomocí definic informačního panelu. Definice pomocí informačního panelu má své výhody (může usnadnit testování definované webové služby), ale i své nevýhody (definice má svá nutná specifika, která musí uživatel znát).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.04.2015


Pojem - Webový server

Pojmem webový server se rozumí:

¨ počítač, který je odpovědný za vyřizování požadavků HTTP od klientů (nejčastěji webových prohlížečů). Vyřízením požadavků se rozumí odeslání cíle specifikovaného URL (typicky webová stránka, ale též statický text, obrázek či jiný soubor). Webové stránky jsou obvykle dokumenty v jazyku HTML.

¨ počítačový program

Jednotlivé webové servery se mohou v různých jednotlivostech značně lišit. Přesto mají několik společných vlastností. Každý webový server je připojen k počítačové síti a přijímá požadavky ve tvaru HTTP. Tyto požadavky vyřizuje a počítači, který požadavek vznesl, vrací odpověď. Odpověď obvykle představuje nějaký HTML dokument. Může to být ale i dokument v jiném formátu – text, obrázek apod. Odpověď serveru je opět ve tvaru HTTP, je uvozena hlavičkou obsahující stavový kód, za níž následuje samotný obsah. Stavový kód odpovědi udává, zda byl požadavek vyřízen v pořádku, či zda došlo k nějakým obtížím. Obvykle server nějakým způsobem protokoluje přijímané požadavky a taktéž zaznamenává případné chyby. To pomáhá správci webového serveru vytvářet statistiky a podle typu a množství požadavků optimalizovat obsah, způsob uložení i způsob prezentace požadovaných dat.

Webový server (program) má téměř vždy nějaké možnosti konfigurace – stanovení kořenového adresáře, z něhož je přístupný obsah poskytovaný on-line, a dále konfigurace pro každý jeho podadresář individuálně, například jaký soubor zpracovat implicitně, obsahuje-li URL pouze daný adresář nebo v jaké časové zóně se nachází či jaké podporuje jazyky a přípony souborů. Podporuje-li webserver dynamický obsah, je součástí i nastavení představitelů skriptovacích jazyků, jež tento obsah zpracovávají. Služeb webového serveru nejčastěji využívají uživatelé internetu prostřednictvím webových prohlížečů.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2015


Pojem - WI-FI

Wi-Fi (nebo také Wi-fi, WiFi, Wifi, wi-fi, wifi) je v informatice označení pro několik standardů IEEE 802.11 popisujících bezdrátovou komunikaci v počítačových sítích (téžWireless LAN, WLAN). Samotný název WiFi vytvořilo Wireless Ethernet Compatibility Aliance. Tato technologie využívá tak zvaného „bezlicenčního frekvenčního pásma“ proto je ideální pro budování levné, ale výkonné sítě bez nutnosti pokládky kabelů. Název původně neměl znamenat nic, ale časem se z něj stala slovní hříčka wireless fidelity (bezdrátová věrnost) analogicky k Hi-Fi (high fidelity – vysoká věrnost).

Původním cílem Wi-Fi sítí bylo zajišťovat vzájemné bezdrátové propojení přenosných zařízení a dále jejich připojování na lokální (např. firemní) sítě LAN. S postupem času začala být využívána i k bezdrátovému připojení do sítě Internet v rámci rozsáhlejších lokalit a tzv. hotspotů. Wi-Fi zařízení jsou dnes prakticky ve všech přenosných počítačích a i v některých mobilních telefonech. Úspěch Wi-Fi přineslo využívání bezlicenčního pásma, což má negativní důsledky ve formě silného zarušení příslušného frekvenčního spektra a dále častých bezpečnostních incidentů. Následníkem Wi-Fi by měla být bezdrátová technologie WiMAX, která se zaměřuje na zlepšení přenosu signálu na větší vzdálenosti.

Wi-Fi zajišťuje komunikaci na spojové vrstvě, zbytek je záležitost vyšších protokolů (na rozdíl od Bluetooth, který sám o sobě zajišťuje nejrůznější služby). Typicky se proto přenášejí zapouzdřené ethernetové rámce. Pro bezdrátovou komunikaci na sdíleném médiu (šíření elektromagnetického pole prostorem) je používán protokol CSMA/CA (Ethernet používá na vodičích CSMA/CD).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 02.09.2015


Pojem - XML

Extensible Markup Language (zkráceně XML, česky rozšiřitelný značkovací jazyk) je obecný značkovací jazyk. Je zjednodušenou podobou staršího jazyka SGML. Umožňuje snadné vytváření konkrétních značkovacích jazyků (tzv. aplikací) pro různé účely a různé typy dat. Zpracování XML je podporováno řadou nástrojů a programovacích jazyků.

Jazyk je určen především pro výměnu dat mezi aplikacemi, pro publikování dokumentů a fungování webových služeb, u kterých popisuje strukturu z hlediska věcného obsahu jednotlivých částí, nezabývá se vzhledem. Prezentace dokumentu (vzhled) může být definována pomocí kaskádových stylů. Další možností zpracování je transformace do jiného typu dokumentu, nebo do jiné aplikace XML. Není vhodné zasílat dokumenty ve tvaru, který vyžaduje pro zpracování speciální software konkrétní firmy, jako je např. formát DOC, XLS apod. Je používána celá řada operačních a informačních systémů a není možné předpokládat, že každý uživatel vlastní příslušný software. Vznikla tak potřeba vytvořit nějaký jednoduchý otevřený formát, který není úzce svázán s nějakou platformou nebo proprietární technologií. Tím může být právě XML, který je založen na jednoduchém textu a je zpracovatelný (v případě potřeby) libovolným textovým editorem. Jako znaková sada se implicitně používá ISO 10646 (také Unicode). V XML proto můžeme vytvářet dokumenty, které obsahují texty v mnoha jazycích najednou – můžeme přepínat mezi různými jazyky v jednom dokumentu. Současně je přípustné i jiné libovolné kódování (např. windows-1250, iso-8859-2), musí však být v každém dokumentu přesně určeno. Odpadají tak problémy s konverzí z jednoho kódování do druhého.

Při používání XML dokumentu potřebujeme také dokument zobrazit. XML samo o sobě žádné prostředky pro definici vzhledu nenabízí. Existuje ale několik stylových jazyků, které umožňují definovat, jak se mají jednotlivé elementy zobrazit. Souboru pravidel nebo příkazů, které definují, jak se dokument převede do jiného formátu, se říká styl. Jeden vytvořený styl můžeme aplikovat na mnoho dokumentů stejného typu, stejně tak můžeme na jeden dokument aplikovat několik různých stylů. Výsledkem může být např. PostScriptový soubor, HTML kód nebo XML s obsahem původního dokumentu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2015


Pojem - XML dokumenty

XML je zkratka anglického eXtensible Markup Language, tedy doslova přeloženo "rozšiřitelný značkovací jazyk". A co to znamená?

¨ Extensible - rozšiřitelný

Při objasňování koncepce XML se často jako příklad uvádí HTML. Tento příklad je však vhodný spíše pro popis vzhledu XML zdrojového programu, než pro popis jeho vlastností a využití. HTML zná pravděpodobně téměř každý a ví, že jde o sadu zvolených "tagů" - tedy značek, které umožňují formátování textového dokumentu. V HTML je tedy význam jednotlivých značek přesně určen a jejich počet je omezen. Naproti tomu standard XML pouze popisuje jak má XML dokument vypadat po stránce syntaktické, avšak nepřiřazuje žádným značkám konkrétní obsah. Na autorovi samotném pak záleží, jakou úlohu danému tagu přiřadí a jak bude daný XML dokument zpracován.

V XML tedy nejsou informace členěny pomocí tagů do skupin podle jejich požadovaného vzhledu, ale podle logického uspořádání dokumentu. Takový přístup pak nabízí daleko větší možnosti při zpracování dat než HTML a navíc dává možnost širšího uplatnění XML jako formátu pro ukládání dat.

¨ Markup - značkovací

XML navazuje na mnohem starší standard pro vytváření "značkovaných" dokumentů - SGML. Tato norma však byla pro reálné použití zbytečně složitá a stejně tak složitá byla její implementace. Proto byl na základě SGML navržen nový standard, který zachovává většinu z výhod SGML (tedy hlavně jeho univerzálnost), ale značně zjednodušuje vytváření a posléze zpracování takových dokumentů - XML. XML dokument je tudíž také platným SGML dokumentem.

¨ Language - jazyk

Velmi významnou vlastností XML je, že jde o formát, který lze prohlížet i editovat v libovolném editoru - jde tedy o tzv. "human readable" formát.

Pravidla pro psaní XML jsou jednoduchá:

¨ obsah tagu (element) musí začínat startovním tagem ve tvaru <jmeno_tagu>

¨ konec elementu je vyznačen koncovým tagem </jmeno_tagu>, který je povinný!

¨ před ukončením elementu musí být ukončeny všechny jeho vnitřní elementy - každý element tedy musí mít koncový tag uvnitř stejného elementu jako počáteční

¨ prázdný tag vyznačíme <jmeno_tagu/>

¨ počáteční tag může obsahovat atributy v podobě <jmeno_tagu atr1="aaa" atr2="abc">

¨ znaky, které jsou součástí textu a mají speciální význam (např. <), musí být escapnuty

¨ nejvyšší element v hierarchii elementů je nazýván "root element" a smí být pouze jeden

Kromě těchto pravidel by měl správný XML dokument obsahovat také "hlavičku", která popisuje verzi XML standardu, kterou daný dokument používá, popř. některé další údaje:

<?xml version="1.0" ?>

Pokusný XML dokument:

<?xml version="1.0" encoding="iso-8859-2" ?>

<dokument>

  <nadpis level="1">Můj zkušební dokument</nadpis>

  <kapitola number="1">

    <nadpis level="2">První kapitola</nadpis>

    <odstavec>Tak tohle je můj první XML dokument

    (tedy není, ale jako by byl).</odstavec>

    <odstavec>A tohle je další odstavec. Trocha

    matematiky: 2&lt;5.</odstavec>

    <obrazek soubor="/home/beda/muj_obrazek.png"/>

  </kapitola>

</dokument>

Standard XML byl vytvořen, aby poskytl standardní formát pro zpracování dat a splňoval následující kritéria (mimo jiné):

¨ je "human readable" - je ho tedy možno číst a upravovat v libovolném textovém editoru

¨ je rozšiřitelný - umožňuje vytvářet vlastní formáty

¨ má jednoduchou syntaxi

¨ implementace parserů a dalších nástrojů na jeho zpracování je snadná (alespoň ve srovnání se SGML)

XML umožňuje vývojářům vytvářet poměrně snadno vlastní formáty od něj odvozené, protože poskytuje standardní nástroje pro jejich zpracování. Na standard XML je nabaleno velké množství dalších standardů, které umožňují jednoduše a účinně provádět kontrolu dokumentů, jejich vzájemné převody apod. XML formátem lze popsat takřka jakákoli data a je ho tedy možno využít jako obecný formát pro mnoho aplikací různého druhu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 29.01.2008


Pojem - Zablokování IS

Pokud uživatel potřebuje krátkodobě přerušit práci se systémem a přitom chce mít chráněný přístup do IS BM, využije možnosti, kterou mu nabízí právě zablokování systému. Zablokování systému je činnost hlavního menu, dostupná pod menu Volby.

Uživateli se zobrazí okno, kde je zadáno uživatelské jméno a heslo je prázdné. V takovém stavu uživatel systém nechá (čili systém je od této chvíle zablokován pro daného uživatele) do okamžiku, než chce blokování zrušit a to provede zadáním uživatelského hesla.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 14.04.2004


Pojem - Zahraniční měna

Zahraniční měna (ZM) je jakákoliv měna, která se liší od měny referenční. V této měně může být veden účet či pokladna a dále se může objevovat v událostech souvisejících s nákupem, prodejem atd. Obvykle je uváděn kurz mezi touto měnou a referenční měnou.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 18.01.2008


Pojem - Zakázky výroby

Tato činnost poskytuje uživateli přehled výrobních zakázek. Struktura přehledu zakázek je závislá na tom, jak si uživatel nadefinuje záložku „Výběr“. Každá výrobní zakázka představuje událost v procesu výrobních zakázek. Pro výrobní zakázky je v IS BM speciální komponenta VR1 – „Výroba – výrobní zakázka“, operace výrobních zakázek pak tedy náleží této komponentě.

Záložka „výrobní úkoly“ obsahuje přehled všech existujících výrobních úkolů s výrobním číslem zakázky výroby.

Záložka „ekonomika“ obsahuje přehled hodnot vypočtených ze vstupů a výstupů výrobních úkolů (normovaných, plánovaných, očekávaných a realizovaných) zvolené výrobní zakázky. Náklady jsou vypočítané ze vstupů, výnosy z výstupů.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 22.01.2008


Pojem - Základní definice menu

Základní definice menu je uživateli standardně dodávána s instalací IS BM. Základní definici menu nelze uživatelsky přizpůsobovat (tzn. nelze přidávat skupinu, měnit pořadí, kopírovat činnosti apod.), slouží pouze k tomu účelu, aby na si na jejím základě mohl uživatel vytvořit své vlastní odvozené menu.

Základní definici menu lze vyvolat z hlavního menu volbou Menu – Otevřít menu. Uživateli se zobrazí okno „deklarovaná menu“, kde jako první v seznamu se zobrazuje právě základní definice menu. Toto menu lze aktivovat dvojklikem levého tlačítka myši. Při prvním přihlášení do systému má uživatel vždy nastavenu v hlavním menu právě základní definici menu (pozná se to podle toho, že v okně hlavního menu není na dolní liště uveden žádný název menu). V základní definici menu by však uživatel pracovat neměl (hlavně i z toho důvodu, že ji nelze uživatelsky upravovat), měl by mít vytvořeno své vlastní menu a s tímto pracovat (pak se v dolní liště okna hlavního menu zobrazuje přímo název menu daného uživatele). Jednotlivé vytvořené definice menu mohou být vytvořeny pro jednotlivé uživatele, ale i pro celé skupiny uživatelů, záleží na struktuře organizace. Při stisku pravého tlačítka myši na činnosti nebo skupinové položce základní definice menu má uživatel k dispozici tyto možnosti:

¨ vlastnosti – ty jsou však v základní definici menu nepřístupné. Základní definice menu má příznak systémová, nelze tudíž měnit její vlastnosti

¨ odvodit nové menu – uživatel si může na základě definice menu odvodit své vlastní, které dědí vlastnosti a původní nastavení menu, z kterého je odvození vyvoláno

¨ odstranit – u základní definice menu rovněž nepřístupné

¨ aktivovat menu – funguje stejně jako dvojklik levého tlačítka myši na názvu menu

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 28.07.2009


Pojem - Záložka

Jedná se o ovládací prvek, který je dostupný na většině činností , minimálně na většině činností je dostupná záložka „výběr“. Některé činnosti obsahují více záložek, mezi kterými se uživatel může přepínat a zobrazovat si tak jejich informace, např. činnost události obchodu má záložku „události obchodu“ (základní informace – datum, umístění, artikl, množství, cena), „další informace“ (daňové údaje), „účetnictví“ (zda byla událost obchodu zaúčtována) a standardní záložku „výběr“.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 26.09.2012


Pojem - Záložka – deklarace

Tato záložka ve vlastnostech předlohy výstupu obsahuje následující vlastnosti:

¨ textovou vlastnost předlohy „dodatečné deklarace“. V ní je možné doplnit výběr položek výstupu nabízený při definování nové předlohy o položky získané v doplnění, o položky typu konstanta či o položky dané výrazem sestaveným z nich a implicitně dostupných položek výstupu a o proměnné obecného výběru. Každý řádek v deklaraci definuje jednu novou položku výstupu a má tvar (jeho jednotlivé části jsou odděleny středníky):

<identifikace>;<typ>;<návěští>;<výraz>

kde

<identifikace> je identifikátor (automaticky IS doplněný textem "_USER_"), pod kterým bude vystupovat v předlohách typu "Excel" a "Ostatní"

<typ> určuje typ výrazu. Je možné zadávat typy "N", "C", "D", "T", "L". Pro typy "N" a "C" musí být dále v závorkách uveden rozměr hodnoty výrazu

<návěští> určuje text zobrazený v seznamu při zakládání nové předlohy

<výraz> specifikuje výraz pro výpočet hodnoty

Např.:

KS ; N(12,2) ; Konečný stav ; SQL_tisk.mtobrat_mt14pstav+SQL_tisk.mtobrat_mt14prijem-SQL_tisk.mtobrat_mt14vydej

Pozn.:

1/ ve výrazu je možné používat atributy vyplývající z doplnění pohledu (v sestavách typu HTML je to nutnost, není to nutnost v případě použití příkazu .deklarace)

2/ v předlohách typu "Excel" nebo "Ostatní" vystupují doplněné výrazy ve své symbolické podobě, tzn. že případná oprava tvaru výrazu v dodatečných deklaracích se promítá do výsledku předlohy

3/ pro předlohy typu Excel2 (předlohy typu Excel2 jsou nastaveny implicitně[1], uživateli se zobrazují v dolní části obrazovky při výběru atributů do nově vytvořené sestavy) je možné definovat výpočtové sloupce tak ,že se jako výraz uvede text vzorce Excelu

Např.:

Součet ; N(7,4) ; Součet ; '=RC(-2)+RC(-1)'

Ve sloupci v Excelu potom vzniknou v daném sloupci výpočtové buňky se součtem buněk v sousedních dvou sloupcích zleva ve stejném řádku.

¨ skript před SQL dotazem – definuje se kód v jazyce Foxpro, který bude prováděn před provedením dotazu SQL. V okamžiku běhu skriptu je v proměnné _THIS odkaz na objekt řídící výstup předlohou výstupu. Např.:

<pre>

LOCAL _o

* přidání vlastnosti TEMP_DATUM1 do objektu _THIS inicializovanou aktuálním datem

_this.addproperty('temp_datum1',date())

* třída BM_CODE_SYSDIA definuje objekt pro dialog

_o=CREATEOBJECT('bm_code_sysdia')

* inicializace objektu třídy BM_CODE_SYSDIA

_o.start(_this,'Datum')

* bude vstup do vlastnosti TEMP_DATUM1 objektu _THIS

_o.addtextbox('temp_datum1')

* metoda READ zahajuje vstup formuláře a vrací FALSE při uživatelově stisku ESC

RETURN _o.read()

#INCLUDE sysdia

</pre>

V předloze výstupu je potom možné odkazovat na vstoupenou proměnnou jako THIS.TEMP_DATUM1.

Odkaz v doplnění SQL dotazu ve vlastnostech předlohy však není tímto způsobem možný.

Proto jinak např.:

<pre>

LOCAL _o

* vstupní informace bude uložena v objektu TOOL, ale mohla již být definována předchozím spuštěním předlohy

DO CASE

CASE TYPE('tool.temp_datum1')='U'

* dosud není vlastnost TEMP_DATUM1 objektu TOOL definována

* přidání vlastnosti TEMP_DATUM1 do objektu TOOL inicializovanou aktuálním datem

tool.addproperty('temp_datum1',date())

CASE TYPE('tool.temp_datum1')<>'D'

* vlastnost TEMP_DATUM1 je definována, ale není typu datum

tool.temp_datum1=DATE()

ENDCASE

_o=CREATEOBJECT('bm_code_sysdia')

_o.start(tool,'Datum')

* bude vstup do vlastnosti TEMP_DATUM1 objektu TOOL

_o.addtextbox('temp_datum1')

RETURN _o.read()

#INCLUDE sysdia

</pre>

V předloze výstupu je potom možné odkazovat na vstoupenou proměnnou jako TOOL.TEMP_DATUM1. V doplnění SQL dotazu ve vlastnostech předlohy bude možné odkazovat v otazníkové konvenci např.:

tabulka.datum>=?tool.temp_datum1

¨ skript po SQL dotazu - je prováděn bezprostředně před výstupem, který nebude proveden v případě, že tento vrátí hodnotu .F. (FALSE).

Skriptu jsou předány tyto parametry:

_THIS - řídící objekt výstupu

_THISFORM - objekt formuláře pro který je prováděn výstup

_FRX - jméno souboru s definicí výstupu FRX

_AKCE - text PRINT, TOFILE, PREVIEW nebo EDIT podle toho, jaká činnost je s předlohou prováděna

_PROMPT - .T. nebo .F. podle toho, zda uživatel zaškrtnul Nastavení tiskárny

_PARAMETR_PROFILU - text uvedený v atributu „Parametr“ v činnosti profily předlohy, resp. metapředlohy

_TYP - numerická hodnota 1 pro předlohu typu Sestava nebo 2 pro předlohu typu Excel nebo 3 pro předlohu typu Ostatní nebo 4 pro předlohu typu Word

V parametru programu BM 'Printing->Default_skript_po_SQL' je možné zadat identifikaci Knihovny vkládaného kódu, jejíž kód má být prováděn pro všechny předlohy výstupu, které nemají vyplněnou vlastnost 'Skript po SQL dotazu'. Skript je prováděn vždy při výstupu předlohou nebo její opravě (proto by měl brát ohled na obsah parametru _AKCE) a může provádět např. :

- modifikaci dat, která jsou součástí výstupu

- vytvoření jiného formátu výstupu (PDF,....)

Pro výstup předlohami typu výstupu jsou v Návodech a balíčcích k dispozici knihovny pro výstup do dokumentu ve formátu PDF.

Knihovna SYSPDF - knihovna s funkcemi pro výstup tiskové předlohy typu Sestava do souboru ve formátu PDF. Tato knihovna podporuje dva způsoby vytvoření PDF dokumentu:

1/ využití nástroje Ghostscript

2/ výstup prostřednictvím PDF tiskárny

Knihovna SYSPDF se používá ve spojení s kódem uvedeným v předloze výstupu ve vlastnosti 'Skript po SQL dotazu'.

Např.:

IF _akce<>'TOFILE' OR _typ<>1

RETURN .T.

ELSE

RETURN print2pdf(_this,'',_frx,_parametr_profilu)=0

ENDIF

#INCLUDE SYSPDF

Pozn.: proměnné _AKCE, _FRX, _THIS, _TYP a _PARAMETR_PROFILU jsou proměnné, které předává BM tomuto kódu při jeho volání.

V příkladu je uvedena jedna možnost volání výstupu do PDF touto knihovnou, a to volání programu PRINT2PDF, který má parametry:

_RIDIC - objekt - řídící objekt tisku BM

_OUTFILE - text - název vytvářeného výstupního souboru PDF - je-li prázdný, potom bude jeho název TEMP1.PDF nebo TEMP2.PDF nebo TEMP3.PDF ... (první vytvořitelný - který nemá právě otevřený Acrobat Reader) v temporary adresáři

_FRX - text - název souboru definice výstupu Foxpro (přípona FRX) - obvykle se používá ten, který je předaný řídícím objektem tisku BM

_PARAMETR_PROFILU - text - parametr profilu výstupu - obvykle se používá ten, který je předaný řídícím objektem tisku BM, tj. ten, který má u sebe uveden profil předlohy resp. metapředlohy výstupu

_RECIPADDRESS - text - emailová adresa

_SUBJECT - text - předmět emailu - není-li prázdný a přitom není dáno parametry profilu jinak, potom bude vytvářen email, jehož bude vytvořený PDF dokument přílohou

_MESSAGETEXT - text - obsah emailu

Program vrací numerickou hodnotu:

0 - PDF dokument nebyl vytvářen

1 - PDF dokument byl vytvořen resp. PDF dokument byl vytvořen a odeslán emailem

17 - chyba - Programu Print2PDF nebyly předány parametry

18 - chyba - V adresáři "xxx" nebyl nalezen žádný program pro spuštění instalace

19 - chyba - Tiskárna "xxx" není na Vašem počítači nainstalovaná

20 - chyba - Ghostscript není na Vašem počítači nainstalován

21 - chyba - Pro spuštění Ghostscriptu není v adresáři "xxx" nalezen program "GSWIN32C.EXE"

24 - chyba - Soubor "xxx" nebyl příkazem REPORT FORM TO PRINTER vytvořen

25 - chyba - Soubor "xxx" nebyl příkazem REPORT FORM TO FILE vytvořen

26 - chyba - Ghostscript nevytvořil soubor "xxx"

27 - chyba - Uživatel neodeslal email

Druhou možností je možné pracovat ve skriptu 'Skript po SQL dotazu' přímo s objektem třídy BM_CODE_SYSPDF pro výstup do PDF definovaném v knihovně SYSPDF, resp. jiným implementátorem vytvořeným objektem jiné knihovny odvozeným z třídy objektu BM_CODE_SYSPDF. Např. ekvivalentní kód předchozímu příkladu:

Local lopdf

IF _akce<>'TOFILE' OR _typ<>1

RETURN .T.

ENDIF

lopdf = Createobject("bm_code_syspdf")

lopdf.ridic=_this

lopdf.parametr_profilu=_parametr_profilu

lopdf.recipaddress='*PLUDA_AD01ID'

lopdf.subject='Faktura '+sql_tisk.sp33cisdr+'-'+sql_tisk.sp33cisd

lopdf.messagetext='Zaplaťte nebo ... !!!'+chr(13)+chr(13)+tool.jmenot

lopdf.creport= _frx

* Metoda MAIN objektu třídy BM_CODE_SYSPDF vytváří dokument PDF a vrací numerickou hodnotu (0,1,17 ...)

Return lopdf.Main()

#INCLUDE SYSPDF

Knihovna DEFPDF - knihovna určená pro uvedení v parametru BM Printing->Default_skript_po_SQL, která způsobí to, že tisk předlohami výstupu typu Sestava do souboru vytvoří PDF dokument a následně ho zobrazí v Acrobat Readeru. Pro svou funkci používá knihovnu SYSPDF.

[1] Jiné se nedoporučují, nejsou již užívány.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 26.09.2012


Pojem - Záložka – doplnění

Tato záložka umožňuje rozšířit předlohu výstupu o atributy, které se při jejím vytváření uživateli nenabízí přímo. Do kolonky „atributy“ se zadává seznam atributů nebo výrazů oddělených čárkou doplněných do dotazu ve tvaru „<alias tabulky>.<atribut>.<alias atributu>“. V příkazu SELECT se doplňuje do oblasti před FROM. Do kolonky „select-join“ se zadává seznam tabulek doplněných do dotazu SELECT mezi FROM a WHERE za deklaraci první tabulky dotazu nastavené programem. Pokud tento seznam nezačíná příkazem LEFT OUTER JOIN, musí začínat čárkou. Do kolonky „výběr“ se zadává doplnění příkazu SELECT v oblasti za WHERE, musí začínat „AND“ a je-li v dotazu obsažen logický operátor „OR“, musí být odpovídající část definice uzavřena do kulatých závorek.

Příklad:

Nad vývěskou (VYUDALOS) - doplnění emailu spojení adresáta (namnoží záznamy dle počtu spojení adresáta):

Atributy: ADSPOJ.ad11email email

Select-join: ,%%%.ADSPOJ ADSPOJ

Výběr: AND VYUDALOS.ad01id=ADSPOJ.ad01id

Pozn.

V excelovské sestavě se pak k tomuto atributu dostanete například takto:

.EP xlsheet.cells[$(r),$(s9)].value=[']+sql_tisk.email

V html sestavě musíme použít Deklaraci: idemail;c(30);Email;sql_tisk.email a poté přidat atribut pomocí: $(idemail_USER_). SQL_TISK je tabulka ve které se program pohybuje v okamžiku tisku. Je vytvořena na základě doplnění a SQL dotazu a jsou zde všechny atributy tisku.

Proměnné zadané v obecném výběru je možné zobrazit v předloze výstupu výrazem:

this.otec.obec_vyber.p[<pořadí>],

kde pořadí je pořadové číslo proměnné výběru. Aby předloha fungovala také bez obecného výběru, je vhodné otestovat typ hodnoty výrazu např.: pro hodnotu obecného výběru typu datum:

IIF(TYPE('this.otec.obec_vyber.p[1]')='D',this.otec.obec_vyber.p[1],{})

Sybase SQL Anywhere ve verzi 9 je citlivější na SQL dotazy obsahující na příkazu obsahující klauzuli LEFT OUTER JOIN, která musí být v jejím případě umísťována bezprostředně za tabulku, ke které je navazující tabulka připojována.

Např. SQL dotaz:

¨ select * from bm_servis.adadsat,bm_servis.spseob left outer join bm_servis.adspoj on adspoj.ad01id=adadsat.ad01id where spseob.sp10idzak=adadsat.sp10idzak,

který je funkční v nižších verzích Sybase SQL Anywhere, musí mít pro Sybase SQL Anywhere verze 9 tvar:

¨ select * from bm_servis.adadsat left outer join bm_servis.adspoj on adspoj.ad01id=adadsat.ad01id,bm_servis.spseob where spseob.sp10idzak=adadsat.sp10idzak

Řešením je možnost určení, kam má být která část uvedené definice do sestavovaného SQL dotazu zařazena. Toto uživatel provádí ve vlastnostech předlohy výstupu na záložce doplnění v

atributu Select-join. V atributu Select-join je možné uvádět definici jedné nebo několika subdefinic oddělených znakem '|' (svislá čára).

Syntaxe subdefinice je:

[#alias#] [tělo subdefinice]

Každá z těchto subdefinic určuje ve svém těle část SQL dotazu, která má být v sestavovaném SQL dotazu umístěna na různém místě podle uvedeného alias.

Příklad nastavení vlastnosti Select-join pro předlohu výstupu Události plateb:

#PLUDA# LEFT OUTER JOIN %%%.ADBUCTY UC99 ON UC99.AD01ID=PLUDA.AD01ID AND UC99.AD03CISBAN='99' |

#ADADSAT# LEFT OUTER JOIN %%%.ADSPOJ SP13 ON SP13.AD01ID=ADADSAT.AD01ID AND SP13.AD11CISSPO='13'

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 26.09.2012


Pojem - Záložka – info

Uvedení logické tiskárny v předloze výstupu umožňuje definovat pro různá uživatelsky definovaná pracoviště (každé může zahrnovat několik fyzických počítačů) různé fyzické tiskárny, na které bude výstup typu Sestava a Excel dle této předlohy směrován. Jako další tato záložka obsahuje informace o tom kdy a kým byla daná předloha vytvořena či změněna a uživatel má možnost uvést si u dané předlohy libovolně dlouhou poznámku.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 26.09.2012


Pojem - Záložka – na uzlu

Ve vlastnostech uzlu v diagramu procesu je možno zaškrtnout atribut „vytvořit záložku na operaci při založení procesu“. Tento atribut způsobí to, že při založení daného fyzického procesu, kdy se vytváří i všechny jeho uzly (nemají stav ani neobsahují data - události či procesy), bude do těchto uzlů s touto definicí (tj. vytvořit záložku) zaznamenán adresát z první události operace, která proces zahajuje.

Pak ve vytvořených uzlech (v činnosti „operace“ - fakticky přehled uzlů) je v okně dostupný i adresát v záložce, tj. je možné podle něj i vybírat.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Záložka – obecné

Na této záložce se určuje typ (sestava, Excel, ostatní) a druh předlohy. K druhu předlohy lze nadefinovat přístupová práva žádný přístup/čtení/zápis. Uživatel s právem přístupu čtení, který není správcem systému ani autorem předlohy ji může spustit, ale nemůže předlohu kopírovat, rušit, opravovat a nejsou mu dostupné ani vlastnosti předlohy.

Uživatel má k dispozici i informaci o čísle verze dané předlohy výstupu. Další podrobnější informace týkající se verze jsou soustředěny pod vlastní záložkou verze.

Dalším dostupným atributem je vlastní název dané předlohy.

Je možné definovat druh předlohy, který není dostupný žádnému uživateli systému a na něj „odkládat“ předlohy, které není možné zrušit (na základě referenční integrity) nebo u kterých není jisté, zda bude třeba danou předlohu někdy v budoucnu použít.

Atribut skupina umožňuje určit skupinu, do které bude daná sestava zařazena. Definice skupin sestav a jejich zobrazení se následně využije ve stromovém zobrazení činnosti výstupy.

Jako další se zde může určit jazyk, v jakém se předloha bude prezentovat (daná předloha musí být samozřejmě definována vícejazyčně).

Pokračují atributy, zda je skrytá (pouze pro daného uživatele) nebo skrytá všem (tato předloha je skrytá všem bez ohledu na privátní nastavení vlastnosti „skrytá“. Příznak skrytá všem může nastavit pouze správce systému). Příznak systémových předloh mají předlohy dodané společně s dodávkou systému a u těchto předloh není možno opravovat definici předlohy. V případě potřeby je možno u předlohy změnit i ikonu, která se zobrazuje vedle názvu předlohy. Stačí kliknout na tlačítko „změnit ikonu“ a vybrat si příslušný soubor (přípona *.ico).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 02.11.2012


Pojem - Záložka – popis

Tato záložka obsahuje název předlohy a způsob setřídění atributů v ní, není-li na záložce „setřídění“ definováno jinak. V případě potřeby je možno zatrhnout (dvojklikem myši) i pohyb (pohyb nastavený v předloze dokladů na události umožní zadat prezentaci procesu), tzn. ze kterých tabulek se ještě mají atributy v předloze nabízet.

Zatržením příznaku tisk aktuálního by se tiskl vždy jen aktuální záznam (tzn. ten, na kterém je právě umístěn kurzor) a v případě zatržení pouze součtové údaje jsou ze sestavy při tisku vynechány jednotlivé záznamy a tisknout se pouze ty řádky, na kterých je v sestavě nadefinována suma (tj. součet, nejčastější použití je u předloh typu Excel a HTML – ostatní). U atributu kopie si uživatel určí pouze počet kopií při tisku a atribut výstupy procesů obsahuje překryvný seznam možností, jak může uživatel podle svých parametrů ovlivnit tisk předlohy.

Výstupy lze aktivovat uživatelským rozhodnutím v rámci funkčnosti dané činnosti nebo automaticky na základě uživatelských definic v nastavení parametrů uzlu procesu při jeho ukončení nebo pomocí doplnění činnosti. Reakce na aktivaci je uživatelska ovlivnitelná profilem spuštění, který je k dané předloze přiřazen, a který ovlivňuje chování předlohy po její aktivaci.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 26.09.2012


Pojem - Záložka – seskupování

Tato záložka umožňuje nastavení vlastního seskupování předlohy výstupu. Množina těchto atributů tisku může být uživatelsky nahrazena uvedenými atributy a výrazy, a to i z uživatelem připojených dalších tabulek na záložce doplnění. Druhá kolonka definuje „grupování“ (GROUP a HAVING) přímo na serveru. V seskupování se tedy uvádí informace potřebné pro vytvoření dotazu SQL s klauzulí GROUP BY. Při zaškrtnutém "Seskupování" se zde v poli "Atributy a výrazy příkazu SELECT" uvádí část sestaveného příkazu mezi SELECT a FROM. Jinými slovy umožňuje, aby příkaz SELECT při získání dat výstupu byl redefinován (oproti programovému kódu) s využitím klauzulí CROUP a HAVING, což je smysluplné tehdy, obsahuje-li předloha výstupu významné agregace. Ty se pak realizují na serveru, což bývá několikanásobně rychlejší.

Např.:

MTUDA.sp60id,MTARTIKL_sp60id,MTUDA.sp61id MTARTIKL_sp61id,MTUDA.mt04id MTUDA_mt04id,SUM(MTUDA.mt02mnr*(if MTUDA.mt02pv=1 then 1 else -1 endif)) MTUDA_mt02mnr

V poli "Doplnění klausulí" GROUP a HAVING" se uvádí odpovídají část dotazu.

Např.:

MTUDA.sp60id,MTUDA.sp61id,MTUDA.mt04id

HAVING MTUDA_mt02mnr<>0

ORDER BY MTUDA.mt04id,MTUDA.sp61id,MTUDA.sp60id

V tuto chvíli je nutno upozornit implementátory, že při definici seskupování (atributy SELECT, GROUP a HAVING) v předlohách výstupu nad určitou činností může nastat situace, že v kombinaci s použitým obecným výběrem nad danou činností nebudou tyto sestavy fungovat. A tato situace nastane v okamžiku, kdy implementátor ve výrazu obecného výběru použije programový kód FoxPro uvedený příkazem .post script. Je velmi obtížné pak tyto sestavy a obecný výběr sladit dohromady, resp. pokud se na to implementátor nesoustředí již při jejich definování, je vlastně nemožné je potom sestavit.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 26.09.2012


Pojem - Záložka – setřídění

Tato záložka umožňuje uživateli nastavit si vlastní třídění, které na záložce popis není implicitně k dispozici. Při zaškrtnutí příznaku vlastní setřídění musí pak uživatel kliknout na čtvereček v pravé části obrazovky a následně si atribut vybrat (tato možnost však vyžaduje jistou znalost datového modelu), též může užít atributy definované na záložce doplnění. Výraz setřídění lze zadat v syntaxi SQL (např. adadsat.ad01id) nebo v syntaxi FoxPro (např. *SPARTIKN_sp62artikl). V předloze dokladu lze definovat pouze setřídění událostí v rámci operace (setřídění dle operací je definováno v prezentaci procesu) a to jednotně pro všechny operace dané komponenty.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Záložka – Výběr

Na většině oken činností se při jejich aktivaci uživateli zobrazí jako první právě záložka „výběr“. Ta slouží k tomu, aby si uživatel zúžil nabídku všech dostupných informací, které mu může následující činnost poskytnout. Právě proto, že uživatele většinou zajímají pouze určité informace nebo v určitém období apod. je vhodné si možný výběr takto „ořezat“. Výběr se ukládá ikonou „disketa“ v panelu nástrojů nebo funkční klávesou Ctrl PgDn. V určitých případech daných způsoben aktivace činnosti je výzva k výběru potlačena a výběr je fakticky dán programovým kódem. Ve vybraných činnostech je možno záložku výběr potlačit, je to dáno způsobem nastavení v parametrech uživatele.

Zejména při definici složitějších výběrů (např. v událostech) uživatel využije možnosti, kterou mu nabízí klávesa CTRL + Q. Při jejím stisku se mu zobrazují hodnoty, které ve formulářích zadával ve dvaceti naposledy zadaných výběrech po spuštění programu. Klávesou CTRL + Q je pak možno na výběrové záložce formulářů listovat mezi těmito zapamatovanými výběry.

Při složitějším výběru je možno hledané výrazy zapisovat do jednotlivých výběrových atributů těmito způsoby:

¨ % - nahrazuje jakýkoliv znak, tzn. uživatel hledá název firmy, o kterém neví, jak začíná, nicméně ví, že obsahuje slovo „stavební“. Pak do názvu firmy ve výběru zadá %stavební a systém mu vyhledá všechny firmy, které na jakémkoliv místě ve svém názvu mají slovo stavební. Stejné je to i s jinými výběrovými atributy. Pokud tedy uživatel u některého výběrového atributu neví přesně, jakým způsobem je v systému zadán (pokud ví jistě, že firmu např. Compaq má v systému zadanou jako Compaq, není nutno před název firmy psát %, ale napíše rovnou začáteční písmena názvu firmy) je vhodné využít jako první výběrový znak právě % a za něj napsat výraz, který hledáme. I v případě, že uživatel rovnou napíše název firmy, systém přesto automaticky na konec tohoto zadaného slova přiřazuje znak % (uživatel ho tam tedy nepíše, ale systém si ho při vyhledávání přiřazuje sám)

¨ xx % - při vyhledávání podle přesně zadaného slova (tzn. je napsán hledaný výraz, mezera, procento). Tímto způsobem je pak při hledání např. výrazu „servis %“ zajištěno, že systém bude hledat opravdu jen a právě výrazy „servis“ a nikoliv i výrazy, které mají výraz „servis“ použitý kdekoliv ve svém názvu.

¨ _ - podtržítko nahrazuje právě jeden vybraný znak, např. uživatel má zadáno „diskuse“, ale i „diskuze“. Uživatel potřebuje najít jak výrazy s použitým „s“, tak i výrazy s použitým „z“, pak je výběr zapsán takto „disku_e“. Jinými slovy podtržítko nahrazuje na dané pozici jakýkoliv znak. Pokud se jako uživatel rozhodnu, že chci vybrat všechny firmy, které mají na 3. pozici v názvu písmeno A, tak zadám výběr takto: _ _ a %, tzn. první dvě místa cokoliv, na třetí pozici písmeno A a dál může něco být nebo nemusí.

¨ [] - hranaté závorky umožňují vybrat na zvolené pozici znak nebo množinu znaků, např. máme zapsáno kurz, ale i kurs. Chci vyhledat oba tyto výrazy, pak napíšu „kur[sz] a systém najde obě dvě varianty. Když bychom si tento výběr uvedli na příkladu čísel, pokud do závorek zadáme např. [56], systém bude hledat buď 5 nebo 6, pokud to bude zadáno [4-6], systém vyhledává 4 nebo 5 nebo 6.

¨ [^] - znaky uvedené v takové hranaté závorce znamenají, že systém má na zvolené pozici vyhledávat vše kromě uvedených, tzn. negace výběru. Např. pokud je zadáno [^4-6], systém na daném místě vyhledá znaky kromě 4 nebo 5 nebo 6.

Tyto výběrové možnosti je samozřejmě možno libovolně kombinovat. Klávesa CTRL+SPACE (mezerník) na výběrové záložce formuláře na znakové položce vyvolává okno pro vstup delšího textu, tím je umožněno zadat delší text pro výběr v SQL dotazu v klauzuli LIKE. Na záložce výběr je pro uživatele navíc dostupný funkční přepínač „uchovat“, který způsobí to, že výběr, který si uživatel právě nadefinoval bude uchován a při příštím spuštění dané činnosti a aktivaci záložky výběr bude takto automaticky předplněn.

Na záložce Výběr ve všech činnostech je možno vybrat si větší množinu dat jedním klikem. Pro tento účel jsou u takových výběrových atributů zobrazeny ikony zaškrtávacího políčka (černý čtvereček v pravém horním rohu daného atributu). Tento čtvereček se nazývá „ikona seznamu hodnot“. Po kliknutí myši (klik, pravý klik nebo dvojklik) na „ikonu seznamu hodnot“ (tzn. na čtvereček) se uživateli zobrazí okno se seznamem možných hodnot daného atributu, ve kterém si označí množinu hodnot atributu, kterou chce mít dostupnou.

Nadefinování „ikon seznamu hodnot“ se provádí v činnosti Doplnění výběrové záložky formuláře (hlavní menu – Informační centrum – Typy a řady) nebo z formuláře Doplňující vlastnosti formuláře stiskem klávesy F7.

Uvedeme si možnost definice nejlépe na konkrétním případu. Na záložce Výběr v činnosti Adresář je tato ikona dostupná např. na atributu Kategorie. Po kliku na čtvereček se uživateli zobrazí seznam všech nadefinovaných kategorií. Vlastní záložka Výběr umožňuje na atributu „kategorie“ výběr pouze jedné kategorie, pomocí této nové možnosti si může uživatel zvolit adresáty z různých kategorií, stačí dané kategorie v nabídnutém seznamu pouze zaškrtnout.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 09.12.2010


Pojem - Zápočet krmných dnů

Zápočet krmných dnů se provádí na základě počátečních nebo konečných stavů podle toho, jak je uživatelem nastaveno v parametrech skladu zvířat. V případě nastavení „počátečních stavů“ se v daný den do krmných dnů nezapočítávají naskladněná zvířata, ale započítávají se pouze v ten den vyskladněná a do příjmových operací se do atributu pořadí automaticky předplňuje 1. V případě nastavení „konečných stavů“ se v daný den do krmných dnů nezapočítávají vyskladněná (prodaná) zvířata, ale započítávají se pouze v ten den naskladněná a do výdajových operací se do atributu pořadí automaticky předplňuje 99999.

Pro zápočet krmných dnů je k dispozici program "SZUDAL krmne dny" využitelný v definici importu, kde uživatel pouze zadá datum, kategorii a umístění a program automaticky naplní operaci událostmi, které podle nastavených parametrů náleží do zápočtu krmných dnů.

Výpočet krmných dnů probíhá na základě následujícího algoritmu. Systém z obratů skladu zvířat vybere záznamy (podle data, umístění, kategorie, počátečního/konečného stavu) s nižším datem, než je zadané datum na šabloně výpočtu krmných dnů, pro ty kategorie zvířat, které mají zaškrtnutý příznak KD. Z obratů systém bere tyto hodnoty:

¨ množství (tj. počet krmných dnů) – určené parametrem „množství v MJ pro výpočet KD“ (činnost Parametry komp. sklad zvířat)

¨ podle nastavení parametru „započítávat stavy do KD“ (činnost Parametry komp. sklad zvířat) hodnota počáteční nebo konečný stav

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.10.2007


Pojem - Zařazení do skupin uživatelů

Tato činnost poskytuje uživateli přehled jak o jednotlivých aktivních uživatelích, tak o nadefinovaných skupinách.

U každého uživatele je k dispozici přehled jeho zařazení ve skupinách. Jednak je tato skupina viditelná jako zaškrtnutá v pravé části formuláře a jednak je u každého uživatele k dispozici po rozbalení jeho menu (tj. znaménko plus před jménem uživatele).

Stejný princip platí i u přehledu skupin. V pravé části formuláře jsou zaškrtnuti ti uživatelé, kteří patří do dané skupiny a zároveň je jejich přehled k dispozici po rozbalení menu skupiny (tj. znaménko plus před názvem skupiny).

Přiřazovat uživatelům skupiny lze dvojím způsobem:

¨ v levé části formuláře budu mít kurzor umístěn na jménu uživatele a v pravé části zaškrtnu skupinu (tím je do ní tento uživatel zařazen)

¨ nebo pravou myší na jménu uživatele zvolím volbu „Kopírovat ...xxxxx ....“? poté kliknu pravou myší na názvu skupiny, kam chci uživatele zařadit a aktivuji volbu „Vložit ... xxxxx ...“

Uživatelé a skupiny uživatelů jsou tímto uloženy v jediné společné tabulce (BWUZIVAT). To umožňuje kromě definování zařazení uživatelů do skupin také definování vztahů mezi skupinami uživatelů. Hierarchická struktura skupin uživatelů má pak vliv na definování přístupových práv. Uvedeme si příklad:

¨ v systému je definovaná skupina uživatelů „vedení“ a skupiny „obchodní ředitel“ a „ředitel výroby“, které jsou obě zařazené do skupiny „vedení“ (stejný postup vytváření hierarchické struktury jako u uživatelů. Pravá myš na skupině „obchodní ředitel“ a volba „kopírovat“, pak pravá myš na skupině „vedení“ a volba „vložit“). Potom uživatel zařazený do skupiny „obchodní ředitel“ je nepřímo zařazen i do skupiny „vedení“ a vztahují se k němu všechna přístupová práva definovaná pro skupinu „vedení“.

Uživatele je možné zařadit do skupiny uživatelů, která je zároveň uživatelem systému. V takovém případě pak zařazený uživatel vlastní pouze ta přístupová práva, která jsou přímo udělena uživateli, který v tomto vztahu vystupuje jako skupina uživatelů.

Poznámka pro implementátory:

Při instalaci nové verze BM dochází ke sloučení obsahu tabulek BWOBDOR a BWUZIVAT, přitom nejsou přenášeny ty skupiny uživatelů, které mají stejnou identifikaci jako některý uživatel. Proto by měl správce systému před instalací nové verze změnit jejich identifikace (není nutno měnit pouze identifikaci skupiny uživatelů $SPRAV, tu instalace automaticky změní na SPRAVC).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 28.07.2009


Pojem - Zásobník operací

Zásobník operací slouží jako úschovna operací určených k automatickému spuštění, tj. těch, které jsou ve stavu připravena, spouštějí se automaticky nebo na pozadí, je mezi nimi vazba běžná a rozlišeny jsou pouze zadaným pořadím ve vazbě uzlů.

Když si představíme zásobník jako jednotlivé přihrádky, tak do první (tj. nejspodnější) přihrádky se uloží operace, která má být podle pořadí spuštěna jako poslední a v poslední (té nejvyšší) přihrádce je uložena operace, která má být podle nastaveného pořadí spuštěna jako první. Zásobník pak tedy v praxi funguje tak, že jednotlivé operace postupně automaticky spouští od nejvyšší po nejnižší přihrádku, tj. metoda LIFO.

Pokud je pořadí všech vazeb ze zdrojového uzlu stejné (např. implicitních 10), pak neexistuje žádné pravidlo, v jakém pořadí se cílové uzly spustí, resp. uloží do zásobníku.

Operace, které jsou v zásobníku operací se současně zobrazují i v průběhu operací.

V případě, že uživatel potřebuje přerušit práci se zásobníkem, aktivuje tlačítko „pozastavit“, jeho opětovným stiskem opět pokračuje v práci. Pokud uživatel potřebuje naprosto vymazat naplněný zásobník operací, tzn. nechce v žádném případě dále zpracovávat zde připravené operace, aktivuje tlačítko „vyčistit“, čímž se celý připravený obsah zásobníku vymaže.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 28.07.2009


Pojem - Závazek

Pod pojmem závazek (přesněji závazkový vztah) chápeme takový typ občanskoprávního vztahu, na základě něhož je jeden z účastníků takového vztahu (dlužník) povinen druhému účastníku (věřiteli) poskytnout určitou, zpravidla majetkovou hodnotu, tj. plnění. Druhý účastník - věřitel - je pak oprávněn takové plnění od dlužníka požadovat. Na straně dlužníka je plnění označováno jako dluh, na straně věřitele je plnění označováno jako pohledávka.

Vzhledem k tomu, že v právním postavení dlužníka i v právním postavení věřitele v rámci téhož závazku může vystupovat více osob fyzických i právnických, používá se pro označení dlužníka či skupiny dlužníků povinných k témuž plnění ze závazku pojem strana dlužnická, pro označení více věřitelů ve shodném postavení v rámci téhož závazku pojem strana věřitelská.

Základní dvojice práv a povinností, tj. dluhu a pohledávky bývá doplněna dvojicí práv a povinností další, tj. povinností poskytnout druhé straně součinnost k řádnému plnění (např. povinnost věřitele řádně a včas nabídnuté plnění od dlužníka převzít), a právem dlužníka tuto součinnost od věřitele požadovat.

S výjimkou zcela jednoduchých závazků jsou obě (všechny) strany závazkového vztahu v pozici současně dlužníka a věřitele (např. prodávající u kupní smlouvy má povinnost vydat předmět koupě kupujícímu a současně má právo na zaplacení kupní ceny).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.02.2008


Pojem - Zdaňovací období DPH

Zdaňovací období pro účely DPH jsou vymezena v § 99 ZDPH. Zdaňovacím obdobím plátce DPH je kalendářní čtvrtletí, pokud jeho obrat za předcházející kalendářní rok nedosáhl 10 000 000 Kč. Pokud obrat plátce za předcházející kalendářní rok dosáhl 10 000 000 Kč, je jeho zdaňovacím obdobím kalendářní měsíc.

Plátce, jehož obrat přesáhl částku 2 000 000 Kč za předcházející kalendářní rok, má možnost zvolit si dobrovolně jako zdaňovací období kalendářní měsíc. Stejně může postupovat i osoba povinná k dani, která podnikala v uplynulém kalendářním roce a přesáhla uvedenou částku při podání přihlášky k registraci. Zdaňovací období plátce ve sdružení se stanoví ze součtu obratu dosaženého všemi účastníky v rámci sdružení a obratu plátce dosaženého mimo sdružení.

Při přeměně společnosti fúzí (Transformace) se zdaňovací období zúčastněných společností nebo družstev stanoví ze součtu jejich obratů. Při rozdělení společnosti se pro stanovení zdaňovacího období každé nástupnické společnosti obrat zanikající společnosti nebo družstva rozdělí v poměru, v jakém na ně bylo převedeno jmění ze zanikající společnosti nebo družstva. Při převodu jmění na společníka se zdaňovací období stanoví z obratu společnosti, která se zrušuje bez likvidace, a obratu společníka.

V případě stanovení zdaňovacího období nově zaregistrovaného plátce se vychází z předpokládaného ročního obratu. Prvním zdaňovacím obdobím plátce po registraci je nadále kalendářní měsíc nebo kalendářní čtvrtletí, v němž se stal plátcem.

Změnu zdaňovacího období je plátce oprávněn provést nejdříve od počátku následujícího kalendářního roku. Plátce je povinen oznámit změnu zdaňovacího období správci daně nejpozději do 31. ledna příslušného kalendářního roku.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.02.2008


Pojem - Zdravotní pojištění

Částka, kterou zaměstnanec odvádí ze mzdy zdravotní pojišťovně. Jedná se o částku 4,5% z hrubé mzdy.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 29.02.2008


Pojem - Zdravotní pojišťovny

Tato záložka poskytuje přehled o zdravotních pojišťovnách daného pracovníka. Eviduje se:

¨ zdravotní pojišťovna – tj. kód pojišťovny a číslo pod kterým je daná pojišťovna zařazena v adresáři IS BM (toto číslo se automaticky natáhne z karty pojišťovny)

¨ číslo pojištěnce – zadává se pouze v případě, že je odlišné od rodného čísla pracovníka

¨ datum zahájení platnosti položky

¨ datum ukončení platnosti položky

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 11.10.2007


Pojem - Zdrojový uzel

Jedná se o uzel diagramu procesu ze kterého směřuje vazba. Pak je možno konstatovat, že z pohledu vazby je vždy jeden uzel zdrojový a jeden uzel cílový. Fakticky v takovém diagramu je vždy pak právě jeden uzel, který je pouze zdrojový, a několik uzlů, které mohou být cílové i zdrojové, a alespoň jeden musí být jenom cílový (tzn. nevede z něj další vazba).

Je-li to proces, tak se ve vazbě dále definuje zdrojová operace a ukončuje proces (viz. ukončení uzlu).

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Změna stavu peněz

Užití této komponenty se předpokládá v souvislosti se správou a evidencí finančních prostředků dle jednotlivých alokací a měn, tj. například pokladní a bankovní evidence, a dále v souvislosti s uhrazováním plateb (evidovaných v komponentě PLA – platby).

Mezi významné tabulky komponenty kromě standardizovaných patří definice komunikace s bankou a tabulka (přehled spárování) sdílená s komponentou PLA se záznamy o vztahu události PLA a události ZSP s významem: výše uhrazené částky v ZM z dané platby zde uvedenou částkou v ZM z dané změny (příjem/výdej) stavu peněz. Mezi dvěmi událostmi PLA a ZSP může být několik těchto vazeb.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 18.12.2007


Pojem - Změny spravovaného majetku

Uživatel má k dispozici události týkající se spravovaného majetku, např. jeho příjem, výdej, přeřazení, předání do opravy apod. Jednotlivé události jsou zapsány pomocí vytvoření příslušného procesu, tzn. není možno jednotlivé události vkládat ručně po stisku F3, ale vždy až po aktivaci příslušného procesu.

Atributy dostupné v této činnosti jsou:

¨ údaje o procesu – rok/IDÚ/číslo/identifikace operace

¨ datum události

¨ popis změny stavu - zařazen, vyřazen, neučeno apod.

¨ stručný popis události

¨ adresát, kterého se událost týká

¨ artikl - identifikace a název artiklu

¨ umístění spravovaného majetku

¨ atributy změny odpovědnosti, změny umístění - Ano, Ne (dochází-li např. k přeřazení sprav. majetku, určuje se, zda s jeho přeřazením za něj odpovídá jiný pracovník, či zda bylo přeřazeno na jiné umístění - do jiné kanceláře apod.)

¨ změna ceny - Ne, Nová cena, Přírůstek - zda současně se stavem události dochází ke změně ceny artiklu. Při zařazení se zcela jistě zadává nová cena artiklu, při různých opravách apod. může dojít k jejímu přírůstku apod.

¨ komentář k události

¨ jednotlivé selektory

Na záložce „aktuální stav artiklu“ jsou podrobné informace o stavu artiklu k aktuálnímu datu. K dispozici je název artiklu, čárový kód, stav artiklu (tzn. zařazen, vyřazen, neurčeno), jeho umístění. V případě vyřazení je zde kompletní informace nejen o datu vyřazení, ale zároveň i o datu, kdy byl majetek zařazen a za jakou cenu.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 01.11.2012


Pojem - Zpracování skriptů

Jednotlivé doplň. vlastnosti formuláře IS BM při zapsání do kódu umožňují zpracování skriptů. Skript je programový kód vyvolaný na základě programové události.

V současné verzi IS BM jsou definovány tyto události:

1. zahájení editace - EDIT_START

2. ukončení editace - EDIT_END

3. úspěšný zápis dat - UPDATE_COMPLETED

4. aktivace formuláře (přepnutí z jiného formuláře) - FORM_ACTIVATE

5. deaktivace formuláře (přepnutí na jiný formulář) - FORM_DEACTIVATE

6. ukončení formuláře - FORM_DESTROY

Skripty jsou připojovány k danému formuláři jeho metodou ADDSCRIPT.

Syntaxe:

objekt_formulare.addscript(objekt_skriptu)

objekt_formulare - je objekt formuláře, ke kterému má být skript připojen

objekt_skriptu - je objekt, který bude spouštět daný skript

Metoda vrací odkaz na objekt skriptu (objekt_skriptu).

K formuláři může být pro stejnou událost připojeno několik různých skriptů, jejichž objekty musí splňovat tyto podmínky pro rozhraní jejich komunikace s formulářem:

1. vlastnost SCRIPTID - jednoznačná identifikace skriptu - pokud je v okamžiku připojování skriptu metodou ADDSCRIPT již k formuláři připojen skript se stejnou identintifikací, potom je tento dříve připojený skript od formuláře odpojen.

2. metoda SCRIPTENABLED - rozhoduje o tom, že skript bude proveden

Parametry:

_this - objekt formuláře, ze kterého je metoda vyvolána

_typ - identifikace události formuláře (EDIT_START nebo EDIT_END ....)

Návratová hodnota:

logická hodnota - udává, zda je možné skript vyvolat

3. metoda SCRIPTEVENT - spouští skript

Parametry:

_this - objekt formuláře, ze kterého je metoda vyvolána

_typ - identifikace události formuláře (EDIT_START nebo EDIT_END ....)

V IS BM je předdefinována třída objektů BWSCRIPT, která splňuje podmínky rozhraní pro komunikaci objektu skriptu s formulářem. Třída objektů BWSCRIPT definuje tyto vlastnosti a metody:

1. vlastnost SCRIPTID - viz. rozhraní

2. vlastnost SCRIPTTYPE - obsahuje seznam identifikací událostí formuláře oddělených čárkou, pro které se má skript uplatnit (např. EDIT_START)

3. vlastnost SCRIPTACTIVE - logická hodnota - FALSE určuje, že skript nemá být aktivován i když nastala událost podle SCRIPTTYPE

4. vlastnost SCRIPTCOMMAND - textová hodnota - je-li naplněna, určuje příkaz, kterým bude skriptem proveden

5. vlastnost SCRIPTCODE - textová hodnota - není-li vlastnost SCRIPTCOMMAND naplněna, musí obsahovat víceřádkový programový kód prováděný skriptem

6. metoda SCRIPTENABLED - viz. rozhraní

Parametry:

_this - objekt formuláře, ze kterého je metoda vyvolána

_typ - identifikace události formuláře (EDIT_START nebo EDIT_END ....)

Návratová hodnota:

logická hodnota - udává, zda je možné skript vyvolat

Rozhoduje o tom, že skript bude proveden podle předaného parametru _typ a vlastností SCRIPTTYPE a SCRIPTACTIVE

7. metoda SCRIPTEVENT - viz. rozhraní

Parametry:

_this - objekt formuláře, ze kterého je metoda vyvolána

_typ - identifikace události formuláře (EDIT_START nebo EDIT_END ....)

Spouští skript, je-li naplněna vlastnost SCRIPTCOMMAND bude proveden příkaz v ní uvedený (může použít proměnné _this a _typ), není-li naplněna vlastnost SCRIPTCOMMAND provádí se víceřádkový programový kód obsažený v SCRIPTCODE doplněný o "LPARAMETERS _this,_typ,_objscript".

Tomuto kódu je předáváno v parametrech:

_this - objekt formuláře

_typ - identifikace události formuláře

_objscript - objekt skriptu

Objekt třídy BWSCRIPT je možné vytvářet s parametry, které inicializují jeho vlastnosti.

Např.:

_o=createobject("BWSCRIPT",_scriptid,_scripttype,_scriptcommand,_scriptcode)

Příklad použití v praxi:

Firma používá jako způsob prodeje svým distributorům komisní prodej. Zboží v komisi u každého jednotlivého distributora je evidováno v IS BM na zvláštním skladě. Při vyúčtování prodeje z komise doposud využívala ručního zadávání programovou šablonu "Převod mezi sklady" událostí skladu. Připravuje zavedení automatizovaného zpravování vyúčtování hlášení o prodejích z komise předávaných od distributorů pomocí textových souborů. Řešení tohoto požadavku je pomocí "doplňující vlastnosti" formuláře "Převod mezi sklady" typu program, spouštěný z menu formuláře. Tento program zpracuje vybraný textový soubor a podle jeho obsahu aktualizuje zobrazená data. Přitom vytvoří protokol o zpracování ve formátu HTML, ve kterém jsou informace o načtených datech s případným popisem rozporů v evidenci distributora a firmy.

Program dále zařídí, že tento protokol stejně jako textový soubor od distributora, bude uložen jako připojený dokument k procesu, který operaci skladového výdeje z komise zahajuje. To je možné udělat teprve po zápisu událostí výdeje ze skladu, protože v okamžiku běhu programu doplňující vlastnosti proces neexistuje a nemusí ani podle rozhodnutí obsluhy vzniknout. Proto připojí k formuláři výdeje ze skladu skript aktivovaný událostí tohoto formuláře UPDATE_COMPLETED. Tento skript vloží do dat odpovídající dokumenty a propojí je s procesem datovou objektovou vazbou.

Část kódu programu doplňující vlastnosti formuláře, která zajišťuje vytvoření skriptu:

<pre>

* nalezení formuláře skladového výdeje, ke kterému má být skript připojen

FOR _i=1 TO _SCREEN.FORMCOUNT

_otec=_SCREEN.FORMS[_i]

* ve vlastnosti identif je jednoznačná časová identifikace formuláře

* ve vlastnosti otec formuláře "Převod mezi sklady" je jednoznačná časová identifikace formuláře,

* do kterého mají být převedena data - objekt běžícího programového kódu obsahuje

* ve své vlastnosti _this odkaz na tento formulář

IF TYPE('_otec.identif')='C' AND _otec.identif==THIS._this.otec

* časové identifikace s shodují - formulář byl nalezen

EXIT

ENDIF

ENDFOR

IF _i>_SCREEN.FORMCOUNT

* fomulář události skladového výdeje nebyl nalezen

RETURN

ENDIF

* připojení skriptu pro založení dokumentu - textový soubor od distributora

* po provedení cyklu je v proměnné _otec odkaz na objekt formuláře skladového výdeje

* metoda makroprikaz je vyvolána v tomto objektu - provede příkaz uvedený jako parametr

* tj. založí objekt třídy BWSCRIPT a připojí ho do seznamu svých skriptů

* objekt skriptu má jednoznačnou identifikaci V1 a skript jím definovaný bude spouštěn

* při události formuláře UPDATE_COMPLETED

_o=_otec.makroprikaz("RETURN this.addscript(createobject([bwscript],[V1],[UPDATE_COMPLETED]))")

* metoda addscript vrací odkaz na připojený objekt skriptu

* proto by měl být v proměnné _o odkaz na objekt skriptu

IF VARTYPE(_o)<>'O'

RETURN

ENDIF

* pro založení dokumentu bude v kódu použit objekt, který vrací program SP0103DP

* následující kód nastaví vlastnosti tohoto objektu tak, aby bylo možné před založením dokumentu

* doplnit pouze časovou identifikaci procesu

_o2=sp0103dp()

* druh dokumentu

_o2._sp57id='DOK001'

* předloha dokumentu

_o2._sp01id="NOTEPA"

* poznámka k dokumentu

_o2._sp26koment='Vytvořeno při automatizovaném zpracování komise'

* soubor ukládaný do dat - proměnnou _soubor_zdroj naplnil program mimo ukázku

_o2._sp26soubor=_soubor_zdroj

* popis dokumentu - proměnnou _ad01adsat naplnil program mimo ukázku

_o2._sp26nazev='Z - Nahláška - '+_ad01adsat

* do objektu skriptu přidáme vlastnost dokument a do ní odkaz na objekt pro vytvoření dokumentu

_o.ADDPROPERTY('dokument',_o2)

* pozn.: _o2 odkazuje na stejný objekt jako _o.dokument

* vytvoření kódu skriptu

_script=''

* následující příkaz Foxpro TEXT vloží do proměnné _script vše až po ENDTEXT

* v nezměněném tvaru včetně odřádkování

TEXT TO _script NOSHOW

* toto je kód skriptu

* bude proveden až v okamžiku události UPDATE_COMPLETED formuláře skladového výdeje

* v době běhu skriptu se tento nachází v datové seanci formuláře skladového výdeje

* k tomuto kódu přidá objekt skriptu řádek "LPARAMETERS _this,_typ,_objscript"

LOCAL _sp33

* zjištění časové identifikace odpovídajícího procesu

_sp33=tool.sql_dotaz([select sp33 from %%%.spprc where sp33cisdr=?_p1 AND sp33cisdpm=?_p2 AND sp33cisd=?_p3],;

MTUDA.sp33cisdr,MTUDA.sp33cisdpm,MTUDA.sp33cisd)

IF !EMPTY(_sp33)

* objekt skriptu předal při vyvolání kódu skriptu v parametru _objscript odkaz na sebe

* v připojené vlastnosti "dokument" objektu skriptu se náchází objekt pro založení dokumentu

* vyvoláním jeho metody GO je založen dokument s odkazem na datový

* objekt typu proces (PR) s časovou identifikací podle proměnné _sp33

* úspěšné založení dokumentu zároveň deaktivuje objekt skriptu

_objscript.scriptactive=!_objscript.dokument.go('PR',_sp33)

ENDIF

ENDTEXT

* naplnění vlastnosti kód skriptu objektu skriptu

_o.scriptcode=_script

* připojení skriptu pro založení dokumentu - protokol o zpracování

* liší se od části pro založení dokumentu textový soubor od distributora:

* 1/ typ objektu skriptu je V2

* 2/ nastavením vlastností objektu pro vytvoření dokumentu

_o=_otec.makroprikaz("RETURN this.addscript(createobject([bwscript],[V2],[UPDATE_COMPLETED]))")

IF VARTYPE(_o)<>'O'

RETURN

ENDIF

_o2=sp0103dp()

_o2._sp57id='DOK001'

_o2._sp01id='HTML'

_o2._sp26koment='Vytvořeno při automatizovaném zpracování komise'

_o2._sp26soubor=_soubor_protokol

_o2._sp26nazev='V - Nahláška - '+_ad01adsat

* naplnění vlastnosti kód skriptu objektu skriptu

* kód skriptu je stejný, protože vše podstatné je ve vlastnostech objektu pro založení dokumentu

_o.ADDPROPERTY('dokument',_o2)

_o.scriptcode=_script

</pre>

Metoda LOAD_MY_ADRESS vytváří pro předlohu výstupu objekt ADM1.AD, ze kterého je možné ve výstupu zobrazit vlastní adresu adresáře.

Metodu je možné vyvolávat ve skriptu předlohy výstupu např.: this.load_my_adress

Potom jsou pro výstup dostupné v objektu ADM1.AD atributy odpovídající vlastní adrese nastavené v adresáři:

ADM1.AD.ad01id, ADM1.AD.ad01adsat,

ADM1.AD.ad01unodpo, ADM1.AD.ad01adsat2, ADM1.AD.ad01ico, ADM1.AD.ad01dico,ADM1.AD.ad01koment,ADM1.AD.sp10idzak, ADM1.AD.ad01klic,

ADM1.AD.ad01rc, ADM1.AD.ad01ksymb,

ADM1.AD.ad01pladph, ADM1.AD.ad01zakljm, ADM1.AD.ad01spolec, ADM1.AD.ad01volne1, ADM1.AD.ad01volne2, ADM1.AD.ad01volne3, ADM1.AD.ad02cisads, ADM1.AD.ad58id,

ADM1.AD.ad13nsc, ADM1.AD.ad11jmeno,

ADM1.AD.ad11cislo, ADM1.AD.ad11fax,

ADM1.AD.ad11mobil, ADM1.AD.ad11email, ADM1.AD.ad11cisost, ADM1.AD.ad11pozn,

ADM1.AD.ad02ulice, ADM1.AD.ad13psc,

ADM1.AD.ad02mesto, ADM1.AD.ad05stat,

ADM1.AD.ad05nazeva, ADM1.AD.ad58naztyp, ADM1.AD.bw01jmeno, ADM1.AD.sp10text,

ADM1.AD.ad02ulice3, ADM1.AD.ad13psc3,

ADM1.AD.ad02mesto3, ADM1.AD.ad05id3,

ADM1.AD.ad05stat3

Událost formuláře GRID_HEADER_CLIK umožňuje implementačně definovat třídění sloupce po kliku na návěští sloupce v mřížce formuláře (např. v mřížce je identifikace artiklu a datum - po kliku na sloupec artiklu se požaduje setřídění artikl + datum).

Událost GRID_HEADER_CLIK vzniká při kliku na návěští sloupce mřížky ve formuláři a vyvolává skript připojený k formuláři doplňující vlastností formuláře voláním metody ADDSCRIPT.

Ve skriptu je možné odkazovat se na proměnné:

_objscript.recordsource - alias cursoru mřížky

_objscript.attribute - název atributu zobrazeného ve sloupci (včetně aliasu), na který uživatel klikl

Kód skriptu by měl vrátit výraz v syntaxi jazyka Foxpro pro příkaz INDEX ON.

Příklad doplňující vlastnosti formuláře připojující skript pro událost GRID_HEADER_CLIK:

<pre>

LOCAL _kod

TEXT TO _kod NOSHOW

IF _objscript.recordsource='VRUDOPER' AND TYPE(_objscript.attribute)='C'

RETURN [UPPER(]+_objscript.attribute+[)+DTOS(NVL(vr02datum,{}))+LEFT(ad01adsat,50)]

ELSE

RETURN _objscript.attribute

ENDIF

ENDTEXT

_this.makroprikaz("this.addscript(CREATEOBJECT([bwscript],[GRID_HEADER_CLIK],[GRID_HEADER_CLIK],[],_p1))",_kod)

</pre>

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 16.11.2007


Pojem - Zpráva

Zpráva je v informačním systému jeden z možných způsobů signalizace. Zprávu je možno odeslat několika způsoby:

¨ v činnosti Marketing – Zprávy je možno po stisku F3 poslat zprávu vybranému uživateli. Pokud chceme poslat stejnou zprávu více uživatelům využijeme možností, která nám nabízí šablona (Ctrl F3).

¨ lze využít objektových vazeb a zprávu připojit ke zvolenému objektu. Např. máme událost vývěsky, ke které chceme poslat zprávu. V tom případě si uživatel vyvolá rámeček „souvislostí objektů“ (ikona stromeček), stiskne příslušné okénko zpráv a rovněž po stisku F3 nebo Ctrl F3 zadá zprávu, která však je objektově svázána s událostí vývěsky, což pak znamená, že z této přijaté zprávy má uživatel možnost si přes rámeček souvislostí vyvolat danou událost vývěsky

¨ při validaci vstupu u druhu operace – u každé zde zadávané hodnoty (resp. pro případ, že dojde k jejímu překročení) je možno nadefinovat text a uživatele, komu má být zpráva zaslána

¨ z událostí dané operace – pod menu Volby má uživatel k dispozici činnost „odeslat zprávu“. V tomto případě se však nejedná o objektovou vazbu, tzn., že příjemce této zprávy si nemůže dané události vyvolat přes rámeček „souvislostí objektů“, nýbrž si v dané zprávě z menu Volby musí vyvolat činnost „spustit spojenou operaci“. Tuto zprávu má pak uživatel možnost vidět i ve stromu hlavního procesu u operace, z jejíchž událostí byla zpráva odeslána.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.03.2008


Pojem - Zprávy databázového serveru

Činnost „zprávy databázového serveru“ je k dispozici v menu Systém. Po její aktivaci se zobrazí formulář a v něm seznam zpráv databázového serveru. Zprávy se v seznamu doplňují každých 5 vteřin (podobný seznam zpráv je možné vidět v programech SQL Central nebo DBConsole) a jsou zobrazovány pro verze databázového serveru 8 nebo vyšší. K dispozici jsou např. zprávy týkající se procedur, triggerů, spouštěných databází a jejich případných chyb atd.

Tato činnost používá volání programu BWSRVMES. Tento program má následující parametry:

_form_caption - text - nadpis okna formuláře

_cmdfree_caption - text - popis volného tlačítka formuláře

_cmdfree_script - text - skript v jazyce Foxpro vyvolaný po stisku volného tlačítka

_interval - číslo - interval aktualizace seznamu zpráv databázového serveru - uplatní se, pokud se větší než 3

_filtr - text - je-li uveden budou zobrazeny pouze zprávy začínající daným textem

Pozn.: je-li program BWSRVMES volán v externím příkazu, doplňující vlastnosti formuláře apod. ..., musí se jednat o kompilovaný kód.

Např.:

<pre>

LOCAL _kod_foxpro

* v proměnné _kod_foxpro bude kód volného tlačítka formuláře

TEXT TO _kod_foxpro NOSHOW

* kód skriptu nejdříve odstartuje událostní trigger "Prepocet FIFO"

tool.sqlcall(.F.,'TRIGGER EVENT "Prepocet FIFO"')

* a potom znepřístupní volné tlačítko formuláře

_thisform.cmdfree.enabled=.F.

ENDTEXT

* fomulář bude mít nadpis 'FIFO'

* volné tlačítko bude mít popis 'Přepočet FIFO'

* po jeho stisku bude vyvolán skript uvedený v proměnné _kod_foxpro

* frekvence aktualizace seznamu zpráv databázového serveru bude 3 vteřiny

DO bwsrvmes WITH 'FIFO','Přepočet FIFO',_kod_foxpro,3

</pre>

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.05.2009


Pojem - Zrcadlové storno

Zrcadlové storno znamená, že ke stornované události bude vytvořena událost inverzní (tj. opačná s minusovými znaménky). U ostatních komponent, které nemají umožněno zrcadlové storno je stornovaná událost zrušena. U komponent vývěska (VYV), personalistika (MZP) a vstupní údaje ze systému (MZV) platí, že přesto, že tyto komponenty mají programově umožněno zrcadlové storno se u nich implicitně neuplatňuje, tzn. že při stornu událostí těchto komponent jsou události zrušeny. Aby zde fungovalo zrcadlové storno, je nutno u druhu operací těchto komponent (Informační centrum – Typy a řady – Druhy operací) na záložce Další nastavit příznak zrcadlové storno na Ano.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 28.07.2009


Pojem - Zrušit stav ukončena

Jedná se o jeden ze způsobů opravy stávajících dat. Je zřejmé, že pokud je operace uvedena do stavu ukončena, není přístupná jakýmkoliv opravám (kromě popisu, poznámky, selektorů apod.). Je tedy nutno zrušit stav ukončena, pokud nechceme uplatnit storno.

Uživatel, který nemá právo k činnosti „storno procesu“ vyvolávané z činnosti „procesy“, nemůže provádět zrušení stavu ukončena žádné operace (z formuláře „vlastnosti operace), ani mu není umožněno stornovat proces ve „stromu hlavního procesu“. Zrušit stav ukončena nelze u stornované ani stornující operace.

K tomuto účelu nám právě slouží tato činnost, která je dostupná ve vlastnostech operace (menu Volby). Aby tato činnost byla ve vlastnostech operace dostupná, je nutné při definování diagramu procesu připojit operaci, která má ve vlastnostech zatrhnut atribut „ukončuje proces“ a není ukončená (typicky je v implementacích IS BM nazývána jako „odblokovač“).

Například: Je možné zařadit ještě fiktivní operaci jiné komponenty a nastavit tento atribut až u ní. Může se jednat např. o operaci komponenty vývěska, kterou si nazveme „odblokovač“ - ta se nikdy nezahajuje (je-li připojena pasivní vazbou), u této operace zatrhnout tento příznak „ukončuje proces“ a pak mají všechny operace daného diagramu v případě potřeby trvale dostupnou funkci "Zrušit stav ukončená".

Aplikací této funkce na danou operaci (tzn. aktivovat danou operaci a ve vlastnostech operace použít tlačítko „zrušit stav ukončena“) dojde ke zrušení jejího stavu ukončena a nastavení stavu připravena při současném ovlivnění následujících operací, do kterých směřuje běžná vazba z dané operace (resp. následujících – řetězové chování), tak, že je obdobně změněn jejich stav a dále jsou v nich zrušeny události.

V činnosti druhy operací na záložce Další je možno nastavit atribut „zobrazovat ve stromu procesu“. Jedná se o nastavení, zda daný druh operace má být zobrazen ve stromu hlavního procesu. Ve většině případů zřejmě bude nastaveno Ano, možnost Ne se využije především u operací, které se vkládají do diagramu procesu pouze pro umožnění odblokování operace.

Pokud se jedná o fyzický proces, který má již všechny operace ukončeny a uživatel potřebuje opravit údaje na událostech první operace v procesu, měl by postupovat velmi obezřetně, protože zrušením stavu ukončena u první operace se automaticky zruší i stavy ukončena u operací následujících nebo může využít možnost, která je popsána v dokumentaci Procesy – kapitola Tipy a triky.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 01.11.2012


Pojem - Zrychlené odepisování

Zrychlené odepisování je jednou z metod výpočtu daňových odpisů a je upraveno zákonem o dani z příjmu. Jinak se vypočítává odpis v prvním roce odepisování a jinak v dalších letech. K výpočtu musíme znát vstupní cenu, v dalších letech zůstatkovou cenu (vstupní cena mínus provedené odpisy) a koeficienty z daňové tabulky, které vybereme podle zařazení konkrétního odepisovaného dlouhodobého majetku do jedné z odpisových skupin.

Vzorce pro výpočet v prvním roce a v následujících letech:

vstupní cena

odpis v 1. roce = _____________________

koeficient z tabulky

2*zůstatková cena

odpis v dalších letech = _____________________

koeficient z tabulky - n

Tabulka:

Koeficient pro zrychlené odepisování

odpis.skupina v prvním v dalších pro

roce letech zvýšenou

odepisování odepisování zůstat. cenu

1 3 4 3

1a 4 5 4

2 5 6 5

3 10 11 10

4 20 21 20

5 30 31 30

6 50 51 50

n ... počet let, po které se již dlouhodobý majetek odepisoval,

zůstatková cena = vstupní cena - oprávky,

oprávky jsou součtem doposud provedených odpisů,

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 26.03.2008


Pojem - Zvíře

Chovaný jedinec odlišitelný od ostatních jedinců svým identifikačním číslem. Je umístěn v některé stáji, během svého života může být řazen do různých kategorií. Evidence zvířat se týká komponenty sklad zvířat.

Užití této komponenty se předpokládá právě v souvislosti se správou a evidencí zvířat zejména základního stáda dle kategorií a dle jednotlivého umístění (tzn. stáje, pastviny apod.) zejména ve vazbě na účetnictví. Zvířata jsou evidována v naturálním množství i ve více jednotkách a ve finančním vyjádření (ocenění). Kromě tohoto je u kategorie možno sledovat pohyby zvířat (např. zařazení, nákup, prodej, přeřazení, úhyn, krádež apod.). Komponenta umožňuje automatizovaný výpočet krmných dnů a u vybraných kategorií se počítá i vzrůstový přírůstek.

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 11.10.2007


Poznámky ke specifikaci IS Bílý Motýl

Specifikace IS Bílý Motýl®

1.1 Úvod

Tato specifikace definuje základní garantované parametry informační schopnosti, funkčnosti a dostupnosti IS Bílý Motýl® v okamžiku jeho pořízení. Fakticky se jedná o software, který zajišťuje vygenerování datových struktur (tabulky a jejich atributy) IS BM, a o software, který zajišťuje funkce pro jejich naplnění a zpřístupnění.

Detailní parametry informační schopnosti aktuální verze IS Bílý Motýl® jsou přesně definovány jejím fyzickým datovým modelem, který si uživatel instalací IS zpřístupní v hlavním menu.

IS Bílý Motýl® je koncipován jako integrovaný firemní informační systém určený zejména na podporu manažerského a procesního řízení nezávisle na odvětví.

Je vhodný zejména pro takové organizace, které mají zájem o získání nebo udržení konkurenčních výhod za pomoci informační podpory podnikání, což je podloženo zejména jeho úrovní parametrizace informační schopnosti, automatizace vstupu dat a forem prezentace informační schopnosti dle skutečných požadavků uživatele, které se mohou v čase významně měnit.

Mezi klíčové vlastnosti IS Bílý Motýl® patří:

¨ použitá architektura logiky informační schopnosti (dekompozice IS) s informačním centrem a zejména se standardizovanými komponentami,

¨ standardizace prezenční vrstvy IS Bílý Motýl®, tj. uživatelské rozhraní,

¨ využití řady standardů z oblasti infrastruktury informačních technologií.

1.2 Logická architektura IS Bílý Motýl®

Logická architektura IS Bílý Motýl® vychází z níže uvedené kategorizace entit a následné standardizace jejich vlastností dle kategorie. Kategorizace a standardizace entit umožňuje v plné míře využít metodu dekompozice IS (tj. jeho entit a následně i ve fyzickém provedení relevantních tabulek) do jednotlivých komponent standardní struktury komunikujících mezi sebou pouze pomocí informačního centra, kde jsou tyto komunikace uživatelsky nastavitelné.

Tato architektura umožňuje nejen dosažení níže uvedené informační schopnosti a funkčnosti IS, ale i její další rozvoj, a to obvykle pouze pomocí uživatelských definičních dat.

1.2.1 Kategorizace entit

Entity IS Bílý Motýl® jsou primárně rozděleny do dvou skupin (kategorizovány). Do první skupiny řadíme entity reprezentující objekty zájmu sledování (základní informace) a do druhé skupiny řadíme entity reprezentující atributy objektů zájmu sledování včetně jejich vzájemných vztahů.

1.2.1.1 Objekty zájmu sledování

Objekty zájmu sledování jsou ty objekty (entity) reálného světa, jejichž model v IS (informační schopnost IS) má pro uživatele takový význam, že je důvodem k pořízení IS.

Základní hierarchie entit zájmu sledování je patrná z obrázku. V první úrovni jsou objekty zájmu rozděleny do základních kategorií: Logická věc, Proces, Kontejner a Událost.

Logickou věcí rozumíme určitý element stavu reálného světa. Složení všech elementů představuje reálný svět v daném okamžiku, tj. v daném stavu. V IS jsou logické věci významnými objekty zájmu sledování, které definují model reálného světa v daném okamžiku, případně včetně vývoje v čase. Obvykle se k jejich popisu v IS užívá celá řada tabulek. Z hlediska další kategorizace dělíme logické věci v IS Bílý Motýl® do tří skupin: Aktér, Alokace a Artikl.

Procesem rozumíme posloupnost operací, které jsou si obvykle věcně (týkají se souvisejících logických věcí) i časově blízké (jejich provádění v čase je vzájemně závislé, tj. procesně spolu souvisí) a které obsahují události, jejichž uskutečněním dochází ke změně stavu (vlastností) logických věcí. V IS Bílý Motýl® je krom vlastního fyzického procesu díky jeho rozsáhlé datové struktuře i jeho šablona (pravidla) řídící jeho průběh vyjádřená druhem procesu.

Kontejnerem rozumíme nástroje reálného světa, které umožňují či usnadňují uložení souvisejících informací k sobě do „jedné složky“. V IS Bílý Motýl® je to například možnost uspořádat do jedné operace několik událostí, na jeden doklad několik operací, apod.

Událostí rozumíme okamžik, ve kterém nastane naplnění určitých kritérií způsobem, který vede na změnu stavu či vlastností některé logické věci. V IS se sledují jen ty události, které jsou významné z hlediska informačních potřeb uživatele.

1.2.1.2 Atributy objektů zájmu sledování

Vlastnosti objektů zájmu sledování jsou rozděleny též do několika kategorií, a to zejména na přímé elementární atributy, deskripce objektů a vazby objektů.

Elementární atributy představují elementární údaje, které jsou přímo součástí informační schopnosti objektu zájmu sledování, tj. jsou s ním v jediné entitě. Deskripce představují opakovanou skupinu atributů vztaženou k danému (jedinému) objektu zájmu sledování umístěnou v samostatné popisné entitě. Vazby objektů představují skupinu atributů (případně se opakující) vztaženou k několika objektům zájmu sledování umístěnou v samostatné vazební entitě.

Mezi vlastnosti objektů zájmu sledování patří do určité míry též atributy umožňující jejich členění či agregaci, a to zejména druhy objektů, selektory a kategorie umístěné v samostatné entitě. Jedná se o vlastnost, která uvádí, že daný objekt zájmu sledování (trvale) patří do daného kontejneru.

Druhy objektů představují kategorizační prvek, ke kterému je vztaženo (ve smyslu: jsou daného druhu) několik výskytů objektů zájmu sledování jedné entity. Výskyty objektů často přejímají vlastnosti svého druhu v okamžiku svého vzniku či po celou dobu své existence. Procesy, operace, artikl apod. jsou vždy určitého druhu.

Selektory představují kategorizační prvek IS, který obvykle reprezentuje skupinu logických věcí zejména v manažerské části IS BM (kontejner na logické věci). K obchodnímu selektoru se vztahují aktéři, k organizačnímu alokace a k technicko věcnému artikly.

Kategorie jsou specifickým prvkem členění uplatněným na některé objekty zájmu sledování.

1.2.1.3 Ostatní entity

Mezi ostatní entity patří elementární číselníky a definiční data definující algoritmy pro jednotlivé funkce IS.

1.2.2 Dekompozice IS

Uvedená důsledně uplatněná standardizace entit umožňuje IS Bílý Motýl®, resp. jeho tabulky, rozdělit (dekomponovat) na komponenty, přičemž každá podporuje určitou relativně samostatnou oblast informačních potřeb uživatele, a na informační centrum obsahující globální objekty, které dokáže řídit komunikaci komponent i zajistit další společné funkce celého IS Bílý Motýl®.

V IS Bílý Motýl® mezi nejvýznamnější globální objekty informačního centra patří procesy, kontejnery (operace, selektory, prezentace procesu, …), jejich atributy a související definiční data. Do informačního centra jsou umístěny i další objekty (globální objekty), které jsou následně sdíleny jednotlivými komponentami.

Mezi nejvýznamnější objekty komponent obvykle patří událost a logické věci (aktér, alokace a artikl), jejich atributy a související definiční data.

1.2.2.1 Standardizace komponent

Všechny komponenty IS Bílý Motýl® mají standardní strukturu uspořádání základních entit včetně jejich vztahů, což vychází a je umožněno kategorizací entit. Struktura komponenty se základními objekty zájmu sledování (logické věci a událost) je uvedena na obrázku.

Mezi nejvýznamnější atributy, které vyjadřují stav logických věcí (objektů zájmu sledování), patří hodnoty daného druhu (uživatelsky definovaného). Tyto hodnoty umístěné ve vazební entitě jsou vztaženy ke všem logickým věcem, které jsou v dané komponentě aplikovány.

Událost komponent eviduje sledovanou změnu reálného světa k uvedenému datu, která se obvykle týká v ní uvedených logických věcí (aktér, artikl, alokace). Dle uživatelsky nastaveného způsobu aktualizace hodnoty daného druhu událostmi daného druhu operace a dle vlastních atributů události (logické věci, datum a numerické atributy) jsou hodnoty vztažené k logickým věcem automaticky aktualizovány.

Událost (kromě výjimek některých komponent) je při svém vzniku zařazena do kontejneru operace, která je určitého druhu a patří do určitého procesu. Události různých komponent lze uživatelsky propojit objektovou vazbou nebo automaticky v procesu mírou plnění.

Každá standardizovaná entita komponenty má vlastnosti, které jsou pro danou kategorii entit společné ve všech komponentách, a dále vlastnosti, které jsou specifické pro každou komponentu (včetně popisných či vazebních entit).

1.2.2.2 Informační centrum

Informační centrum IS Bílý Motýl® z hlediska entit obsahuje globální objekty zájmu sledování, tj. ty entity, které jsou sdíleny více komponentami, jinými slovy, které jsou relacemi propojeny s entitami různých komponent, což je někdy nazýváno komunikací komponent.

Některé entity (např. procesy, operace, …) podporují operativní transakční část IS a další entity (např. selektory, statistické hodnoty, výkazy, …) podporují část manažerskou.

Informační centrum je v IS Bílý Motýl® navrženo s důsledným přihlédnutím ke kategorizaci entit a standardizaci jejich vlastností. Klíčové entity informačního centra, které jsou uvedené na zjednodušeném obrázku, a jejich význam je popsán níže.

1.2.2.2.1 Operace

Entita operativní části IS operace je kontejner, do kterého se „ukládají“ události jedné komponenty, které spolu úzce souvisí, obvykle časově i věcně. Každá operace je určitého druhu (patří do kontejneru druh operace), který jí definuje určité vlastnosti. Například jsou to přístupová práva uživatelů, která se interpretují pro všechny operace daného druhu a události těchto operací, nebo způsob aktualizace hodnot komponenty týkajících se AAA (resp. statistických hodnot týkajících se selektorů) uvedených v událostech operací daného druhu.

Druh operace, operace a její události jsou vždy vztaženy k jediné komponentě, které zajišťují napojení do procesu v IC a tím i na jiné komponenty.

Operace je současně uzlem procesu, který dle průběhu procesu nabývá některých z těchto stavů: připravená, zahájená nebo ukončená, na kterých je postaveno řízení work-flow v IS BM.

1.2.2.2.2 Proces

Entita operativní části IS proces je objektem zájmu sledování s rozsáhlými vztahy k dalším objektům sledování, které fakticky obsahuje (zejména operace) a které popisují vývoj procesu v čase i kvalitě. Současně je klíčovou entitou operativní části IS BM, která umožňuje související informace náležitě uspořádat.

V rámci procesu jsou operace uspořádány do posloupnosti pomocí vazeb, které zajišťují jejich komunikaci a řízení procesu z hlediska jeho postupu (automatická signalizace work-flow) i z hlediska automatizace vstupu dat (transformace, míra plnění, …).

Proces je vždy určitého druhu, dle kterého v okamžiku založení dědí vlastnosti definující jeho předpokládaný průběh, které se následně modifikují dle skutečného průběhu proces v reálném světě, který je v IS modelován.

1.2.2.2.3 Statistické hodnoty, selektory, výkazy

Podobně, jako jsou hodnoty komponenty automaticky aktualizovány při zápisu události, je tomu i s hodnotami statistickými, které jsou evidovány v jediné (vazební) entitě informačního centra v manažerské části IS.

Statistické hodnoty jsou vztaženy k selektorům a datu, které se automaticky odvozují z odpovídajících atributů události, a k druhu hodnoty, který definuje jejich sémantiku i způsob jejich aktualizace.

IS BM disponuje třemi druhy selektorů (každý umístěn v samostatné entitě) zastupujících skupinu logických věcí. Sounáležitost logické věci se selektorem (obchodní s aktéry, organizační s alokacemi, technicko věcný s artikly) lze v IS nastavit a využít pro automatizaci jejich uvedení při vstupu událostí a tím i pro aktualizaci statistických hodnot. U každého selektoru je navíc možno nastavit jeho platnost od – do. U organizačního selektoru se navíc eviduje umístění (lze definovat přístupová práva), tzn. že pokud je událost uvedena s organizačním selektorem, na jehož umístění nemá uživatel právo čtení nebo zápis, není mu událost zobrazena.

Entita manažerské části IS výkaz i související entity jsou definiční data, která umožňují uživateli prezentovat informace složené z elementární informační schopnosti jednotlivých entit všech komponent i informačního centra. Významným datovým zdrojem jsou statistické hodnoty.

1.2.2.2.4 Další globální objekty IC

Mezi globální objekty IC patří další entity, které jsou sdíleny komponentami. Jsou to například ty, které souvisí se zajištěním dostupnosti IS (uživatel, věc s přístupem a práva uživatelů k ní, jazyk, předlohy výstupu, …) , které vyjadřují vazby mezi objekty zájmu sledování (objektové vazby, míra plnění, …), dále to jsou dokumenty, adresář, měna, ceník a další, ale také kontejnery a definiční data (struktura volných karet, procesní importy, transformace, …). Pro definování a uchování hodnot konstant potřebných pro funkce programu BM (např. legislativní konstanty mezd) je k dispozici činnost 'Sady systémových konstant'.

1.2.3 Zbývající prvky logické stavby IS

Informační schopnost IS BM vyplývající z výše uvedené logické architektury IS je uživatelsky přizpůsobitelná (procesní pojetí ze své podstaty vytváří orientaci na uživatelsky definovanou informační schopnost) dle konkrétních potřeb a požadavků nejen uživatelským naplněním entit a přiřazením sémantiky informacím v nich, ale i rozšířením vlastností objektů zájmu sledování (i dalších entit) pomocí uživatelsky definovatelných atributů volných karet.

Podobně je pro dostupnost informační schopnosti v IS BM celá řada nástrojů, které uživatelsky podpoří konkrétní požadavky na ní, například: volba jazyka, uživatelské doplnění příkazů SELECT v různých situacích, uživatelské položky menu, …

1.3 Dostupnost funkcí a dat v rámci IS BM

Data IS BM a z nich složené informace jsou dostupné uživatelům pomocí funkcí (tj. činností IS BM uspořádaných do systému menu), které zajišťují jejich aktualizaci či prezentaci uživateli. V určitých situacích je možný přístup pomocí informačních panelů, které umožňují zcela uživatelsky definované poskládání funkcí a dat.

Alternativou pro přístup k datům je přímý přístup k nim pomocí nástrojů databázového serveru Sybase SQL Anywhere nebo přístup pomocí internetového browseru. Tyto alternativy nejsou předmětem této specifikace.

Vlastnosti vybraných funkcí IS a dostupnost informační schopnosti IS jsou v řadě situací parametrizovatelné pro konkrétního uživatele. Z tohoto důvodu se každý musí před využitím IS nejprve identifikovat a přihlásit pomocí hesla, což je využito též pro následnou autorizaci některých významných změn dat. V případě krátkodobého opuštění IS má uživatel možnost zablokování IS a jeho opětovného odblokování pomocí hesla.

Dle nastavení přístupových práv je každému uživateli zpřístupněna jen odpovídající informační schopnost IS a funkce pro její dostupnost.

Vlastnosti některých funkcí IS (např. osobní maska, uspořádání dat na obrazovce, …) lze do určité míry uživatelsky specifikovat pro každého uživatele odlišně (personifikovat).

IS BM je uživateli dostupný z pohledu Windows jako dvě úlohy (aplikace), přičemž první představuje okno se systémem hlavního menu (aplikace menu) a druhou představuje okno (aplikace činnosti), ve kterém jsou uspořádána okna jednotlivých spuštěných činností IS BM. Případné zobrazení diagramu procesu, spuštění slovníku dat, prohlížení dat jeho pohledem nebo jiné specifické funkce představují další úlohu (aplikaci Windows).

1.3.1 Systém menu

Systém menu slouží k zajištění dostupnosti funkcí IS BM uživatelům. Po té, co se uživatel přihlásí k IS, má v okně „menu“ v rozsahu daném přístupovými právy k dispozici hlavní menu ve „svém“ jazyce, které se může prezentovat v několika různých formách (seznam, malé nebo velké ikony, …) a kde si volí požadované funkce (činnosti) IS BM.

Hlavní menu se skládá ze skupinových položek a položek „listových“ typu činnost. Kromě položek menu, pod kterými jsou dostupné funkce (činnosti) IS definované programovým kódem, jsou zde k dispozici i takové položky menu, jejichž funkčnost vyplývá z uživatelských definičních dat (dle druhů procesů a jejich skupin, dle definic výkazů a jejich druhů, dle definic procesních importů, dle definic vyvolání – napojení do procesu, dle významných uzlů vývěsky, dle definic externích příkazů).

Z implicitního hlavního menu „Základní definice menu“ lze odvodit podřízená menu. Ta dědí vlastnosti nadřízeného a dále je lze dle konkrétních potřeb konkrétních uživatelů specificky upravit těmito způsoby:

¨ změna názvu položky (změna ikony) menu, pod kterým se uživateli prezentuje,

¨ skrytí položky menu, takže se implicitně nezobrazuje,

¨ vytvoření nové položky kopií z existující,

¨ „zjemnění“ funkčnosti položky menu přiřazením výběru dat (např. připravené operace), který se automaticky předplní do standardního výběru, nebo určením předlohy výstupu,

¨ nastavení možnosti spuštění položky menu funkční klávesou,

¨ nastavení možnosti spuštění položky menu při startu IS BM po každém spuštění či jednou denně.

Uživatel má po přihlášení k IS k dispozici to menu a v tom jazyce, v jakém je měl při posledním odhlášení se z IS. Ikonu hlavního menu a ikonu hlavního okna programu BM lze v případě potřeby uživatelsky změnit (souvisí s nastavením příslušného parametru v souboru BW.INI). Pomocí nastavení atributu „umístění okna menu programu“ (pod menu Volby) je možno nastavit si zapamatování pozice okna hlavního menu individuálně pro každého uživatele systému. Provádí se z menu Volby okna hlavního menu programu volbou 'Umístění okna menu programu'.

Kromě hlavního menu má uživatel v jednotlivých činnostech IS k dispozici další systémy menu i jiné ovládací prvky, pomocí kterých má zpřístupněny funkce, které jsou relevantní k jím vykonávané činnosti či k prezentovaným informacím.

1.3.2 Činnosti

Činnosti reprezentují funkce IS BM, které zajišťují zejména nastavení a naplnění informační schopnosti (aktualizace dat definičních i aplikačních) a následně její prezentaci (výstupy). K vybraným činnostem lze omezit dostupnost pro jednotlivé uživatele pomocí přístupových práv.

Významnou část činností lze aktivovat formou spuštění listové položky hlavního menu, jiné lze aktivovat ovládacími prvky (menu, ikony, …) přímo z již spuštěných jiných činností.

1.3.2.1 Činnost typu „seznam“

Zřejmě nejpočetnější a nejvýznamnější podmnožinu všech činností IS BM tvoří činnosti typu „seznam“, které prezentují (zobrazují) na obrazovce okno s daty a informacemi formou seznamu ve struktuře dané zejména programovým kódem. Tyto činnosti jsou standardizované z hlediska ovládání, formy zobrazení i související funkčnosti.

Každá takováto činnost je postavena na „svém“ datovém modelu, který je podmnožinou (subsetem) datového modelu IS BM a který vychází vždy z jedné entity (tabulky), která je též někdy označována za hvězdu subsetu. To znamená, že každá činnost je primárně určena pro zajištění dostupnosti dat právě z této a souvisejících tabulek.

Struktura datového modelu činnosti je vymezena programovým kódem, přičemž rozsah prezentovaných dat (záznamů tabulek DM) je dále vymezen pro uživatele v daném okamžiku standardním výběrem, obecným výběrem, přístupovými právy a případnou volbou přehledu pouze označených záznamů. Tyto skutečnosti jsou využity k sestavení příkazu SELECT pro získání dat z databázového serveru pro zpracování klientem. Skutečné znění tohoto příkazu přesně definující množinu zobrazených dat je uživateli dostupné v menu Obecné pod položkou Statistika SQL.

Z hlediska funkčnosti je pro tyto činnosti typický postup jejího využití vyjádřený na obrázku.

Aktivace činnosti se uskuteční spuštěním z listové položky hlavního menu nebo spuštěním z některého ovládacího prvku, kterým se aktivují činnosti související s již aktivovanou činností, resp. prezentovaným záznamem a jeho vlastnostmi v ní.

Po aktivaci činnosti je uživatel vyzván k definici výběru, který může být předplněn dle parametrů uživatele, dle souvislostí vyplývajících ze způsobu spuštění (např. z daného záznamu jiné činnosti) či dle výběru spojeného s položkou menu. V určitých případech daných způsobem aktivace činnosti je výzva k výběru potlačena a výběr je fakticky dán programovým kódem.

Standardní výběr umožňuje uživateli jednoduše definovat zejména ta výběrová kritéria, o kterých se v IS BM předpokládá, že jsou obvyklá a běžná. Definice se provádí vyplněním údajů na záložce výběr. Pro kritéria uplatněná na znakové proměnné lze užít wilcards dle možností klausule LIKE v jazyce databázového serveru. V některých činnostech je uplatněn specifický algoritmus pro sestavení dotazu vycházející z hodnot některých vyplněných údajů standardního výběru (viz Statistika SQL). Jednotlivé formuláře si pamatují hodnoty dvaceti naposledy zadaných výběrů po spuštění programu. Klávesou CTRL+Q je možné na výběrové záložce těchto formulářů listovat mezi zapamatovanými výběry.

Obecný výběr umožňuje uživateli rozšířit standardní výběrová kritéria, a to na základě dat nebo jejich agregátů i mimo rámec datového modelu činnosti. V rámci definice obecného výběru, která je připojena operátorem AND do klausule WHERE daného příkazu SELECT, lze definovat i proměnné, kterým uživatel při jeho aplikaci přiřadí hodnotu, která se uplatní v aktuálním dotazu (viz Statistika SQL). Proměnné v obecném výběru mohou být i typu makro (platí pro verze Visual Foxpro 8 a vyšší). K dispozici je nástroj, který usnadňuje rozhodování při vyřazování nepoužívaných obecných výběrů (sledování užití obecného výběru).

Vybraná data se v každé této činnosti prezentují formou seznamu v samostatném okně umístěném v okně činností IS BM, které obsahuje jimi sdílené ovládací prvky: panel nástrojů, horní lištu s menu, případné zapnuté tooly (objektové vazby, uživatelsky definované nabídky, nabídka aktivních oken, okno úloh …).

Pro činnosti, jejichž datový model je založen na entitě typu událost, obvykle platí, že v horní polovině okna činnosti je seznam jednotlivých záznamů a v dolní polovině jsou podrobnosti záznamu, na němž je umístěn kurzor. Pro činnosti, jejichž datový model není založen na entitě typu událost, obvykle platí, že v levé polovině okna činnosti je seznam jednotlivých záznamů a v pravé polovině jsou podrobnosti záznamu, na němž je umístěn kurzor. Z tohoto režimu zobrazení záznamů je možné se přepnout do režimu „databázového“, kdy jsou záznamy zobrazeny pouze řádkově. Kromě vlastních dat mohou být v okně činnosti zobrazeny informace o počtu vybraných (označených) záznamů na dolním okraji, další ovládací prvky: např.: záložky na horním okraji okna či tučné nadpisy (labely) údajů, pod kterými jsou k dispozici další relevantní data.

Způsob zobrazení je dále možné do určité míry ovlivnit uživatelsky, a to nastavením třídění, pořadí a šířky jednotlivých sloupců seznamu, zapnutím určitých signalizačních toolů i obsahu souvisejících dat, zapnutím volné karty. Další možnosti chování a vzhledu formulářů mohou být ovlivněny personifikací činnosti parametry uživatele. Nastavením parametrů uživatele a parametrů formuláře je možno zaznamenat pozice oken formulářů pro jednotlivé uživatele systému tak, že při opětovné aktivaci daného formuláře je jeho okno zobrazeno v zaznamenané pozici. Zároveň je možno uchovávat i rozlišení monitoru daného uživatele.

Zobrazenými záznamy (řádky) v seznamu je možno listovat s posunem kurzoru (ovládané z klávesnice nebo myší) po záznamu, stránce nebo na začátek či konec seznamu nebo bez posunu kurzoru posuvníkem (ovládané myší). Dle vlastností záznamu s kurzorem a jeho relačních vztahů jsou zobrazovány relevantní informace (např. signalizace objektových vazeb či vazeb mírou plnění i obsah záznamů jimi vztažených, údaje na volné kartě, apod.) k nim. Pro vyhledání specifických záznamů je možné užít vyhledání pomocí indexu nebo fultextové.

Dále je zde možné specificky pro každou činnost například aktivovat funkce ikonou na panelu nástrojů například pro výstup vybraných dat nebo pro opravu či zrušení záznamu s kurzorem, pro získání pomoci formou helpu, pro aktivaci panelu s objektovými vazbami, nebo další funkce pro aktivaci souvisejících činností a to i v případném vztahu k záznamu s kurzorem.

Pro každé pole formuláře, ve kterém je vstupován textový údaj (i na výběrových záložkách) lze nastavit funkci automatického dokončování. Aktivace této funkce se provádí nastavením definic činnosti parametry polí formulářů vyvolané po stisku pravého tlačítka myši, při kterém je zároveň podržena klávesa Ctrl (Ctrl+pravý klik myši). Přechod do seznamu návrhů z klávesnice s možností vybírat si přímo stiskem počátečních písmen textu jeho položek poskytuje uživateli kombinace kláves CTRL+ ŠIPKA DOLŮ.

Při aktivaci funkce automatického dokončování na vybraném atributu klávesou Ctrl+Home je pro dané pole formuláře automaticky vytvořen záznam pro daného uživatele s nastavením „naplnění seznamu návrhů“ na hodnotu Vstupem, další možnosti naplnění jsou SQL dotazem, výčtem nebo skriptem.

Nadefinované parametry jsou specifické pro dané pole daného formuláře pro aktuálně přihlášeného uživatele systému. Správce systému má možnost aktivovat funkci automatického dokončování pro dané pole daného formuláře pro všechny uživatele systému založením parametrů pro uživatele SYSTÉM. Při vstupu textového pole formuláře, pro které je aktivní funkce automatického dokončování, zobrazuje IS BM seznam návrhů na dokončení v překryvném seznamu.

Do atributů formulářů, které jsou víceřádkového typu (např. poznámka, komentář apod.) je možno zapisovat i hyperlinkové odkazy na vybranou internetovou adresu (ve tvaru např. http://www.bm.cz). Tyto napsané odkazy jsou následně zvýrazněny modrým písmem a aktivují se stiskem klávesy CTRL+KLIK pravého tlačítka myši. Po jejich stisku dojde k vyvolání internetového prohlížeče s přechodem na odpovídající odkaz.

Související činnosti se obvykle aktivují z menu horní lišty (specifické pro každou činnost), z disponibilních toolů (např. dokumenty, vazby míry plnění nebo objektové, strom činnost) nebo ovládacími ikonami (např. informace o adresátovi či artiklu na jejich tučném labelu).

Do základní množiny funkcí (každá činnost může být vybavena řadou dalších specifických funkcí) horní lišty aktivních ve většině činností patří zejména v menu Volby:

¨ Odeslat do Outlooku (pouze, pokud se jedná o objekt IS BM),

¨ Nový dotaz s novým vstupem (pouze, pokud činnost disponuje záložkou výběr),

¨ Vkládání (pouze, je-li uživateli povoleno, resp. není-li aktualizace pouze automatická),

¨ Oprava (pouze, je-li uživateli povoleno, resp. není-li aktualizace pouze automatická),

¨ Rušení (pouze, je-li uživateli povoleno, resp. není-li aktualizace pouze automatická),

¨ Tisk určené předlohy (pouze, pokud činnost disponuje záložkou výběr),

¨ Dokumenty (pouze, pokud se jedná o objekt IS BM),

¨ Kalkulátor,

¨ Označování (není implementováno vždy),

¨ Nový dotaz (pouze, pokud činnost disponuje záložkou výběr),

¨ Tisk,

¨ Konec,

v menu Obecné:

¨ Průběh operací,

¨ Zásobník operací,

¨ Činnosti hlavního menu,

¨ Hledání (nahoru),

¨ Parametry formuláře,

¨ Doplňující vlastnosti formuláře,

¨ Oprávnění k činnostem (pouze pro uživatele s právy správce)

¨ Najít (hledání dolu),

¨ Hlavní menu,

¨ Export dat do balíčku (pouze, pokud činnost prezentuje přenositelné definice),

¨ Znovu načíst,

¨ Statistika SQL,

¨ Počet odkazů na záznam,

¨ Zablokovat systém BM,

¨ Import/Export dat,

¨ Nabídky (definovat, aktivovat),

¨ Obecné Výběry (definovat, aktivovat),

¨ Volné karty (definovat, aktivovat),

¨ Hodnoty parametrů objektu (definovat, aktivovat),

a v menu Jazyk:

¨ Implementované jazyky, do kterých se lze přepnout z hlediska cizojazyčných dat (pouze v těch činnostech, které prezentují přeložitelná data),

¨ Režim oprav, umožňující přeložit labely položek do aktivního (zapnutého v hlavním menu) jazyka.

1.3.2.1.1 Volná karta

Volná karta představuje v menu Obecné funkci IS BM, která v každé činnosti typu seznam umožňuje na základě uživatelských definic ke každému záznamu prezentovat další relevantní údaje, a to buď údaje obsahující informace vypočtené (SELECT) z dat celého IS nebo údaje obsahující hodnotu atributů z nové tabulky s uživatelsky definovanou strukturou.

V rámci jedné činnosti lze definovat více volných karet, přičemž je možné v nich definované údaje prezentovat současně na jedné obrazovce, každou volnou kartu v samostatném okně. Vzhled okna a rozmístění údajů v něm je uživatelsky definovatelné. Údaje v okně volné karty se aktualizují při každém pohybu v seznamu záznamů prezentovaných výchozí činností. Volná karta je určitého druhu, dle kterého je řízen přístup k údajům na volné kartě.

Pokud je v rámci definice volné karty definována nová tabulka, pak její záznamy obsahují kromě svých uživatelsky definovaných atributů primární klíč, který je shodný se záznamem z výchozí (hvězdy subsetu činnosti) tabulky a pomocí kterého jsou propojeny vazbou s kardinalitou 1:0. Jméno nové tabulky se skládá ze jména výchozí tabulky doplněného podtržítkem a jménem volné karty.

Volné karty činností Procesy, Operace, Adresát a Artikl jsou dále dostupné i v činnostech zobrazujících události jednotlivých komponent. V činnostech zobrazujících záznamy propojené pomocí objektové vazby je kromě volné karty vazby objektů dostupná i volná karta objektu zobrazovaného v seznamu. U druhu operace lze definovat automatickou aktivaci volné karty procesu nebo operace při ukončení operace daného druhu, další automatickou práci s těmito volnými kartami lze definovat v kódu při ukončení operace. Ve stromu hlavního procesu se zobrazují volné karty definované u odpovídajících druhů procesů a operací. Na uzlu představujícím volnou kartu je možné dvojklikem spustit formulář volné karty, ovšem pouze na prohlížení, dané hodnoty není možno nijak měnit. Z formulářů, na kterých se vyskytuje některý ze selektorů, je možné vyvolávat jeho volné karty z menu Obecné (volná karta selektorů).

K dispozici je nástroj, který usnadňuje rozhodování při vyřazování nepoužívaných volných karet (sledování užití volné karty). Užití volné karty, která je otevírána automaticky při spuštění formuláře zaznamenáváno není. Nadefinováním v činnosti „nastavení sledování změn tabulek“ je možno sledovat provedené změny záznamů na volných kartách.

Definice volné karty se skládá z definice její hlavičky, prezentovaných údajů a volných pohledů (fakticky příkazů SELECT pro získání informace výpočtem z dat IS BM).

V hlavičce se definuje identifikátor a název volné karty, druh, zda se bude aktivovat automaticky při spuštění činnosti a design formuláře (okna, ve kterém se její údaje budou prezentovat).

Definice volného pohledu zahrnuje:

¨ identifikaci a název,

¨ návratové hodnoty, tj. výčet atributů klíče uvozených znaky $$$. a oddělených čárkou,

¨ formální parametry, tj. výčet atributů klíče uvozených znaky _ a oddělených čárkou,

¨ dotaz, tj. příkaz SELECT pro získání dat, ve kterém je možné využít formální parametry uvozené otazníkem,

¨ poznámku.

Definice prezentovaných údajů (atributy volné karty) zahrnuje:

¨ identifikaci (název) atributu,

¨ pořadí, v jakém bude aktualizován,

¨ typ, případně délku a počet desetinných míst,

¨ třída (textové pole, překryvný seznam, zaškrtávací pole .. pro atributy typu překryvný seznam lze nastavit dynamický combobox)

¨ zobrazení,

¨ návěští,

¨ poznámka,

¨ inicializace, pokud je uveden „název volného pohledu“.“alias jeho atributu“, pak se jedná o údaj prezentující vypočtenou hodnotu, v opačném případě o atribut nové tabulky, která se musí po každé aktualizaci své struktury generovat. Hodnota atributu uvedeného rovnítkem není ukládána do dat volné karty a tento atribut není možné editovat,

¨ zda je údaj povinný, tj. v okamžiku vstupu bude validováno, zda je vyplněn (vrací hodnoty TRUE nebo FALSE signalizující validitu atributu),

¨ podmínka – umožňuje definovat logický výraz v jazyce Foxpro určující podmínku vstupu do daného atributu

¨ P.oknu (přizpůsobení oknu) – možnost určení případné změny velikosti atributu při změnách velikosti okna volné karty

¨ zda má být při vstupu údaje po stisku F2 aktivována uvedená činnost.

Ve vlastnostech atributů Zobrazení, Inicializace a Validace lze používat makra. V popisech těchto atributů je možno uvádět identifikátory (v hranatých závorkách) atributů primárního klíče tabulky, se kterou je volná karta spojena.

Na volné kartě je možné zobrazovat obrázky nebo videoklipy. Jsou definována makra, která usnadňují vytváření volných karet pro zobrazování multimédií, které jsou uloženy jako dokumenty BM připojené k objektům BM. Dokument s obrázkem nebo videoklipem může být uložen v databázi BM nebo uložený externě.

1.3.2.2 Aktualizace dat

Aktualizací dat zde rozumíme funkce IS BM pro primární pořízení aplikačních i definičních dat a jejich opravu včetně rušení uživatelem.

Vstup dat může být v IS BM realizován pomocí klávesnice nebo importem (např. z jiného IS, z technologického zařízení, …) v rámci jednotlivých činností, a to přímo (klávesa F3, případně CTRL F3) u těch činností, jimiž obsluhovaná data nejsou pořizována automatickým odvozením z jiných pořízených dat ani nejsou pořizována pouze s podmínkou určitých souvislostí (např. v rámci operace procesu). Mezi nástroje pro automatické odvození dat patří triggery přiřazené k jednotlivým tabulkám, které jsou uživateli k nahlédnutí v činnosti prezentující datový model. IS BM umožňuje definovat též uživatelské triggery k jednotlivým tabulkám včetně tabulek volných karet. V případě definičních dat je možný jejich vstup importem balíčku.

Definice importu (exportu) dat umožňuje uživatelsky nastavit IS BM schopnost převzít (předat) data z jiného IS nebo SW na základě definice zdroje dat (např. ODBC, DBF, TXT, …) a definice konverze řádků a jejich atributů ze zdrojových dat na cílová data IS BM.

Importy definované v činnostech prezentujících události lze užít v definici procesního importu. Pro usnadnění vstupu událostí jsou k dispozici další nástroje (modelování datového toku) automatického vstupu událostí (masky, šablony, …). Data první operace procesu se vstupují po spuštění relevantní položky menu skupinové položky NOVÝ PROCES nebo IMPORT DO PROCESU.

Pořízená data je možné opravovat nebo rušit. Prosté přepsání (klávesa F4) nebo zrušení (klávesa F8) existujících údajů IS dovoluje ve svých činnostech pouze za podmínky, že nebude narušena referenční integrita IS, že se nejedná o změnu v uzavřeném období nebo v ukončené operaci (některé atributy jsou výjimkou, např. poznámka). Pro opravy a rušení dat událostí v rámci procesů se uplatňuje storno, tj. vytvoření stornujícího dokladu s opačnými hodnotami nebo zrušení událostí a fyzických uzlů a označení stávajícího za stornovaný.

1.3.2.3 Prezentace informační schopnosti - výstupy

Způsoby sestavení a prezentace informační schopnosti IS uživateli lze rozdělit na dvě skupiny. V první skupině informační schopnost vyplývá z datového modelu a programového kódu činností (obvykle položky hlavního menu) a v druhé skupině je celý rozsah informační schopnosti výstupu definován uživatelským nastavením při implementaci.

Do první skupiny patří:

¨ Prezentace informací na obrazovce programovým kódem dané činnosti dle výběru uživatele, kde rozsah dat a strukturu zobrazení ovlivňují implementační rozhodnutí jen minimálně (volná karta, třídění, pořadí sloupců, výběry vstupem, sémantika a label atributů, …). Součástí této prezentace je i možnost aktivovat další související funkce IS, tedy i možnost spustit předlohu výstupu.

¨ Prezentace informací souvisejících a vybraných danou činností některým z těchto typů výstupu: sestava Visual FoxPro, MS Excel, MS Word nebo MS IE. V případě typu výstupu MS Excel, MS Word nebo MS IE jej lze spojit s automatickým odesláním e-mailu pomocí programu nastaveného pro e-mail ve vlastnostech Internetu. Struktura a datový obsah výstupu je uživatelsky definován v předloze výstupu, přičemž vychází z atributů tisku datového modelu dané činnosti s možností jejich uživatelského rozšíření.

¨ Prezentace informací souvisejících s daným procesem (dokladů) některým typem výstupu z uvedených v předchozím bodě. Struktura a datový obsah výstupu je uživatelsky definován, přičemž vychází z atributů tisku každé činnosti prezentující události těch komponent, jejichž druhy operace jsou uvedeny v prezentaci procesu dané předlohy výstupu.

Do druhé skupiny patří:

¨ Prezentace informací pomocí výkazu v MS Excel, jehož struktura i datový obsah je plně definován uživatelsky v rámci implementace. Každá buňka výkazu může mít svůj datový model, který je subsetem datového modelu IS BM.

¨ Prezentace informací pomocí pohledu ve slovníku dat, jehož struktura i datový obsah je plně definován uživatelsky v rámci implementace. Každý pohled má definován svůj datový subset. Definice těchto pohledů lze užít i pro prezentaci informační schopnosti na webu pomocí www serveru dostupnou pomocí internetového browseru.

1.3.2.3.1 Výstupy na základě předlohy výstupu

Výstupy na základě uživatelsky definovaných předloh jsou aplikovány v jednotlivých činnostech typu „seznam“, při prezentaci dokladů a případně i ve slovníku dat.

Předloha výstupu je soubor definic, které upravují výchozí datový model prezentovaných dat a které definují, jakým způsobem budou prezentovány informace vycházející z nich.

Datový model činnosti (procesu v případě dokladů) je východiskem pro dostupné atributy tisku v relevantních předlohách výstupu. Množina těchto atributů tisku může být v doplnění definice předlohy uživatelsky rozšířena o další atributy a to i z uživatelem připojených dalších tabulek nebo atributy „vypočtené“ příkazem SELECT. Alternativní přístup získání dat s využitím jejich „grupování“ (GROUP a HAVING) přímo na serveru je možné nastavit na záložce „Seskupování“ ve vlastnostech předlohy výstupu. Podobně je možné definovat uživatelské setřídění prezentovaných dat a to i dle vypočtených informací.

Rozsah dat prezentovaných výstupem může být oproti rozsahu danému výběrem v činnosti omezen klausulí WHERE (v poli „Výběr“ v doplnění předlohy) nebo podmínkovým výrazem ve vlastní definici předlohy nebo aplikací podmínky v okamžiku sestavení výstupu.

Součástí definice předlohy výstupu je její přiřazení k určitému druhu předlohy, ke kterému lze nastavit přístupová práva a ta jsou následně aplikována na dostupnost předloh daného druhu uživateli.

Uvedení logické tiskárny v předloze výstupu umožňuje definovat pro různá uživatelsky definovaná pracoviště (každé může zahrnovat několik fyzických počítačů) různé fyzické tiskárny, na které bude výstup typu Sestava, Excel, Word a HTML dle této předlohy směrován. Předlohy výstupu typu Sestava umožňují i tisk ve formátu PDF.

Výstupy lze aktivovat uživatelským rozhodnutím v rámci funkčnosti dané činnosti nebo automaticky na základě uživatelských definic v nastavení parametrů uzlu procesu při jeho ukončení nebo pomocí doplnění činnosti. Způsob aktivace je uživatelsky ovlivnitelný profilem spuštění, který je k dané předloze přiřazen.

Kromě aktivace výstupu na základě předlohy je možné aktivovat výstup pomocí metapředlohy, která je definována odkazy na relevantní předlohy výstupu a specifikovanými parametry pro ně zvyšující variantnost užití předloh zejména při jejich automatické aplikaci v procesech. Pro automatizaci tisku dokladů z procesů je metapředloha nezbytností.

Vlastní sestavení definice předlohy výstupu může být usnadněna, resp. standardizována využitím uživatelsky definovaného vzoru předlohy.

1.3.3 Informační panely

Informační panel je nástroj, který slouží k přehlednému zobrazení údajů vyplývajících z informací uložených v systému (např. stav plateb ke dni, připravené objednávky, ...). Obsah informačního panelu je tedy volně definovatelný a je ho možné přizpůsobit individuálním potřebám jednotlivých uživatelů. Přístupová práva k informačnímu panelu jsou řešena přes druh prvku. Uživateli se mohou na jediné webové stránce zobrazovat informace z různých oblastí IS a z této stránky potom může přímo vyvolávat potřebné funkce a činnosti aktivací hypertextového odkazu (např. z celkové částky neuhrazeno je možno vyvolat detailní přehled neuhrazených plateb, z názvu adresáta lze vyvolat činnost adresář apod.)

V hlavním menu programu jsou k dispozici tyto činnosti týkající se informačních panelů:

¨ informační panely ke spuštění – přímo výběr jednotlivých nadefinovaných panelů ke spuštění

¨ definice uzlů informačního panelu – vlastní definice jednotlivých informačních panelů

¨ prezentace stránek informačních panelů – definice vzhledu stránek informačního panelu

¨ hypertextové odkazy – předdefinované hypertextové odkazy, které umožňují spouštění jiných uzlů s parametry nebo spouštění skriptů

Informační panel se obvykle skládá z jednotlivých stránek, které jsou prezentovány ikonou v horní liště formuláře. Mezi nimi je možno se pohodlně přepínat. Technicky je informační panel řešen jako HTML stránka, kterou je možno využít i na WEB serveru. Pro rozsáhlé tabulky zobrazované na stránkách informačního panelu lze na záložce Další nadefinovat stránkování.

Vlastní definice informačních panelů se tedy provádí v činnosti definice uzlů informačního panelu, kde základním stavebním prvkem je uzel, u kterého se definuje:

¨ identifikace uzlu – jednoznačná identifikace

¨ název uzlu

¨ druh uzlu - definuje práva uživatelů

¨ prezentace - má význam pro uzel typu "Stránka panelu" - určuje HTML formátování

¨ ikona - má význam pro uzel typu "Stránka panelu" - určuje ikonu stránky

¨ typ - Informační panel / Stránka panelu / Prvek stránky

¨ adresa - má význam pro uzel typu "Stránka panelu" - přímá URL adresa vyvolaná při aktivaci stránky

¨ typ prvku - pro typ prvek stránky - určuje zda bude vytvářena tabulka nebo odkaz

¨ spojení - určuje datový zdroj, ze kterého budou SQL dotazem získávána data

¨ výraz názvu uzlu - je vyhodnocen při vytváření stránky panelu (výraz v syntaxi Foxpro)

¨ výraz třídění - pro uzel typu prvek stránky - určuje třídění dat získaných dotazem SQL (výraz v syntaxi Foxpro)

¨ SQL dotaz - pro uzel typu prvek stránky - SQL dotaz v syntaxi SQL Anywhere

¨ PRETEXT - text vložený před obsah vytvořený zpracováním uzlu

¨ POSTTEXT - text vložený za obsah vytvořený zpracováním uzlu

¨ poznámka

Záložka Sektory poskytuje uživateli možnost definovat pro každou stránku informačního panelu její rozčlenění na sektory. Sektory jsou ve výsledném HTML textu realizovány pomocí tabulky (v tabulkách se uplatňují hypertextové odkazy). Na záložce Poduzly uzlu se definují uzly připojené k danému uzlu. Typicky se k uzlům typu Informační panel připojují uzly typu 'Stránka panelu' a pod uzly typu 'Stránka panelu' uzly typu 'Prvek stránky'. Záložky Pásy, Řádky, Sloupce, Elementy a Buňky umožňují definovat vzhled a rozvržení informačního panelu.

Pro údržbu již existujících stránek informačních panelů je k dispozici činnost Editor uzlů informačních panelů.

Proměnné v informačním panelu mohou být i typu makro (platí pro verze Visual Foxpro 8 a vyšší).

Na stránce informačního panelu je možné vytvářet odkazy, které způsobí vyvolání programu Windows (jiného než internetový prohlížeč) a v něm otevření souboru, který odpovídá celé zobrazené stránce (může to být více tabulek) nebo jednotlivé tabulce zobrazené na stránce. Při vytváření stránky informačního panelu je dostupná vlastnost řídícího objektu vytváření stránky OUTPUT_FORMAT, která má při vytváření běžné stránky zobrazované v internetovém prohlížeči hodnotu 'prázdný text' a při vytváření stránky určené pro zobrazení v programu Windows obsahuje hodnotu, kterou je tříznaková přípona souboru. Do stránky informačního panelu je možné vkládat hypertextové odkazy, které zajistí vytvoření stránky s nastavenou vlastností řídícího objektu vytváření stránky OUTPUT_FORMAT třemi způsoby:

- v kódu patičky prezentace stránky

- ve vlastnosti POSTTEXT definice uzlu informačního panelu

- hypertextovým odkazem, který je součástí tabulky informačního panelu

1.3.4 Uživatel a skupiny uživatelů

Uživatel programu je každý nositel určitého práva (ne)přístupu k IS Bílý Motýl v něm evidovaný. Ti s přístupem se identifikují při přihlášení se k IS. Exkluzivní uživatelé jsou "SPRÁVCE" a "SYSTÉM". Základní vlastnosti uživatele a s nimi související funkčnost:

¨ jméno – tímto jménem se uživatel přihlašuje k IS, je prezentováno při zobrazení autorizace záznamů, je obvykle dostupné v položkách zahrnutých do předloh výstupů nad událostmi,

¨ úplné jméno – lze je doplnit do předloh výstupů,

¨ e-mail – zde uvedená e-mailová adresa je využita jako adresa odesílatele při odesílání mailu z IS BM,

¨ počáteční heslo – heslo pro přihlášení k IS, které je uživateli automatizovaně přiděleno, on si je následně mění sám, případně má správce možnost opakovaného nastavení tohoto hesla inicializací hesla (pomocí nastavení parametru lze evidovat hash heslo uživatele),

¨ jazyk – IS se prezentuje (je spuštěn) v tomto jazyce danému uživateli,

¨ práva správce – uživatel bude mít přidělena specifická práva správce,

¨ právo odblokování – uživatel bude mít právo provést odblokování IS po jeho zablokování jiným uživatelem na daném PC,

¨ aktivní uživatel – uživateli je umožněno se přihlásit k IS,

¨ změna hesla – uživatel je oprávněn měnit své heslo,

¨ web menu – v případě aplikace web serveru a přístupu k IS daného uživatele pomocí internetového browseru bude mít uživatel přístup pomocí zde uvedené definice web menu,

¨ význam – význam obecné předkontace spojený s daným uživatelem.

Každý uživatel může být zařazen do libovolného počtu skupin uživatelů, které jsou využity pro nastavení přístupových práv. Kromě definování zařazení uživatelů do skupin lze definovat vztahy mezi skupinami uživatelů.

Specifická je skupina „Každý uživatel systému“, která má implicitně vše dostupné a do které je každý uživatel automaticky zařazen při svém založení. Implicitní nastavení přístupových práv lze změnit pomocí činnosti pravidla inicializací přístupových práv.

1.3.5 Přístupová práva

IS umožňuje omezení své informační schopnosti a dostupnosti svých funkcí nastavením přístupových práv pro jednotlivé uživatele, resp. jejich skupiny.

Omezení dostupnosti funkcí IS se realizuje pomocí nastavení v příslušné činnosti, kde je možné ke každé funkci (činnosti) zde uvedené definovat přístupové právo pro jednotlivé skupiny uživatelů.

Omezení informační schopnosti IS se realizuje pomocí nastavení přístupových práv k věcem s přístupem. Věcí s přístupem se rozumí každý záznam v těch entitách IS, ke kterým je programovým kódem umožněno definovat přístupová práva. Mezi tyto entity patří:

¨ alokace (např.: sklad, pokladna, obchodní místo, organizační selektor…),

¨ druhy operací,

¨ druhy procesů (právo zápis=pouze právo zahájit proces),

¨ druhy dokumentů,

¨ druhy volných karet,

¨ druhy výkazů,

¨ druhy předloh výstupů,

¨ druhy šablon,

¨ druhy importů,

¨ druhy prvků Web,

¨ druhy adresátů,

¨ druhy obecných předkontací,

¨ druhy uzlů informačního panelu.

Právo přístupu nabývá některé z těchto hodnot: žádné, čtení nebo zápis. Následně je obvykle relevantním způsobem chráněn i přístup k těm záznamům v různých entitách IS, kde je atributem věc s přístupem. Tato práva lze definovat přímo na uživatele nebo prostřednictvím skupiny uživatelů.

Pro případ změn v zařazení uživatelů do skupin je k dispozici funkce pro přepočet práv.

1.3.6 Personifikace a autorizace dat

Každý přihlášený uživatel má možnost si přizpůsobit některé funkce IS dle svých požadavků formou určité personifikace IS, tj. nastavením svých:

¨ parametrů uživatele týkajících se celého IS (reakce na ESC, zobrazení volitelných informačních a ovládacích prvků, zobrazení nabídky aktivních oken…),

¨ parametrů formuláře týkajících se dané obrazovky (třídění, uspořádání mřížky, koeficient zobrazení a mřížky, zvýraznění řádku, barva písma, barva pozadí …),

¨ osobních masek pro automatizaci vstupu dat v událostech,

¨ menu,

¨ jazyka,

¨ struktury objektů (ikon), které se zobrazují v panelu se signalizací vazeb objektů.

Významné aktualizace dat, tj. zejména vstup události, zahájení a ukončení operací, vstup a oprava dokumentu apod., jsou v IS autorizovány. Tedy je u těchto záznamů uvedeno, který uživatel a kdy danou aktualizaci provedl.

1.3.7 Jazyk

IS BM je konstruován tak, aby jej bylo možno užívat v různých jazycích, a to i současně. Uživatelsky lze definovat jak aplikované jazyky tak znění textových výrazů v nich. Vlastnosti IS zajišťující tuto funkčnost jsou řešeny ve třech rovinách: ovládání, výstupy a data.

V rovině ovládání jsou přeložitelné názvy položek hlavního menu, nadpisy (label) na obrazovkách, obsahy překryvných seznamů a většina dalších textů určených pro ovládání IS a orientaci v něm. Dle jazyka uživatele pro něj IS automaticky zvolí texty ovládání.

V rovině elementárních dat jsou přeložitelné tyto číselníky: Název a kód měrných jednotek, názvy artiklů (skladovaný, obchodovaný, spravovaný, předmět projektu, …) a názvy účtů. Dle jazyka uživatele IS automaticky prezentuje data na obrazovce v něm.

V rovině výstupů jsou přeložitelná textová pole. Dle jazyka uživatele IS automaticky zvolí jazyk pro výstup a tím nejen texty ale i data v odpovídajícím jazyce. Uživatel má možnost před uskutečněním výstupu zvolit i jiný jazyk než „svůj“.

V případě aplikace operačního systému i SW klienta v cizím jazyce bude v něm i znění systémových zpráv.

1.3.8 Slovník dat

Slovník dat je nástroj (funkce) IS Bílý Motýl, který uživateli umožňuje definovat uživatelské pohledy na data (struktura - datový submodel, výběr - vymezení podmnožiny, předloha výstupu - forma zobrazení) nezávisle na funkcích IS připravených na úrovni programového kódu jednotlivých činností (tedy i na přístupových právech). Pohledy se kategorizují do tříd, což umožní jejich prezentaci dle tříd a dědění jejich vlastností.V IS BM je slovník dat listovou položkou menu ve skupině SYSTÉM.

V rámci uživatelské definice pohledu slovníku dat uživatel definuje:

¨ datový submodel (datové prostředí pohledu), kterým definuje strukturu požadovaných dat, výběrem požadovaných tabulek a jejich relačním propojením,

¨ výběr, tj. podmínky (filtry), které musí požadovaná data splňovat, jeden výběr může obsahovat několik elementárních podmínek, jeden pohled může mít k dispozici několik výběrů, ze kterých si uživatel při aktivaci pohledu jeden zvolí,

¨ připojené okno, které definuje uživatelské rozmístění dat na obrazovce odlišně oproti implicitnímu generovanému pohledem automaticky,

¨ předlohu výstupu, tj. formu, jak se vybraná data dané struktury mají prezentovat, jeden pohled může mít k dispozici několik předloh výstupu podobně jako činnosti prezentující seznam dat.

Pohled lze dále využít k definici položky web menu, pak může kromě základní definice obsahovat:

¨ definici doplněných oken (související pohledy), kterou lze vyvolat z web browseru klikem na první atribut nebo na atribut uvedený ve vlastnostech pohledu (Napojení ULR na atribut),

¨ definici ULR odkazů v tabulkách (vlastnosti pohledu), které umožňují k libovolnému prezentovanému atributu přiřadit vyvolání zde uvedeného souvisejícího pohledu.

1.3.9 Dokumentace

Pro zvýšení a usnadnění dostupnosti a pochopení funkcí a dat IS BM je jednotlivým uživatelům různé úrovně k dispozici řada relevantních prvků dokumentace prvků, které lze zjednodušeně rozdělit do tří prolínajících se úrovní: dokumentace pro pokročilé uživatele (správce IS, implementátor), běžné uživatele, dokumentace okamžitého stavu IS.

Dokumentace pro pokročilé uživatele se skládá z:

¨ popisu datového modelu, který je prezentován (položka hlavního menu Datový model) seznamem všech tabulek, jejich atributů a indexů, vzájemných relací a definic jejich triggerů, tj. zveřejňuje úplnou informační schopnost IS BM,

¨ této specifikace definující významné vlastnosti IS BM z hlediska jeho konstrukce,

¨ popisu využití procesů v IS BM,

¨ slovníku pojmů,

¨ on line helpu, zejména jeho prvků zaměřených na konstrukci IS BM (atributy tisku apod.),

¨ popisu implementovaných definičních dat přímo v IS.

Dokumentace pro běžné uživatele se skládá z:

¨ základní informace o systému Bílý Motýl,

¨ ovládání IS BM,

¨ on line helpu, zejména jeho prvků zaměřených na ovládání IS BM,

¨ samopopisných prvků IS BM (labely, poznámky k atributům, …),

¨ popisů a metodik vytvořených uživatelem pro užívání IS BM,

¨ popisu implementovaných definičních dat přímo v IS.

Dokumentace popisující stav systému IS BM se skládá z těchto činností:

¨ přehled přihlášených,

¨ přehled prováděných činností,

¨ rezervované zdroje systému,

¨ další data IS (např. stav jednotlivých uzlů procesů, autorizace záznamů apod.).

1.4 Specifikace informačního centra IS BM

Informační centrum je vždy součástí rozsahu poskytnuté licence k IS Bílý Motýl. Obsahuje zejména ty tabulky, které jsou sdíleny několika komponentami. Mezi ně patří zejména tabulky související s definicí a podporou procesů, agregovanými informacemi a jejich prezentací v manažerské části IS BM, objektovými vazbami, dokumenty, oceňováním, adresářem a artiklem apod.

1.4.1 Procesy

Ve své operativní části je IS BM orientován procesně, tj. umožňuje na základě uživatelských definic uspořádat data jednotlivých komponent související s jednotlivými operacemi, které uživatel vykonává, do datového modelu (tabulek IS BM), který odpovídá struktuře procesu.

Definice druhu procesu (šablona definující předpokládaný obvyklý průběh procesu) sestavená uživatelsky se skládá z posloupnosti uzlů reprezentovaných druhy operací nebo „zapouzdřenými“ druhy procesů a vztahů mezi jednotlivými uzly.

Na základě druhu procesu jsou v hlavním menu pod skupinovou položkou NOVÝ PROCES uživatelem zakládány a zahajovány jednotlivé fyzické procesy, které popisují jednotlivé evidované skutečné procesy. Pokračování v zahájeném procesu je možné obvykle několika způsoby.

Struktura dat procesu se uživateli prezentuje v činnosti „Procesy“ typu seznam na záložkách nebo formou stromu či diagramu procesu.

1.4.1.1 Fyzické procesy a jejich řízení

Fyzický proces představuje datovou strukturu prezentovanou uživateli například uzly a vazbami v diagramu nebo stromem procesu, do které jsou uspořádaně ukládány údaje jednotlivých událostí z různých komponent s procesem souvisejících v rámci jeho operací.

V okamžiku založení, tj. zápisu první události do jeho první operace, fyzický proces „dědí“ strukturu dle svého druhu procesu včetně pravidel pro datový tok (automatizace vstupu dat) a pro řídící tok (stavy a aktivace uzlů), dle kterých se pokračuje v zápisu dalších dat procesu, resp. v úpravě struktury procesu.

Data procesu lze vyhledávat, prohlížet či opravovat. K navigaci strukturou procesu jsou určeny: diagram procesu, strom procesu nebo záložky v činnosti „Procesy“.

1.4.1.1.1 Založení procesu

Proces lze zahájit, tj. zapsat záznam události do jeho první operace, buď napojením v rámci již existujícího procesu, ve kterém je daný proces uzlem, nebo samostatně.

V případě, že se jedná o samostatné založení procesu, je to umožněno pod skupinovou položkou menu NOVÝ PROCES, pokud je u daného druhu procesu nastaveno použití jako položka menu, nebo odpovídající volbou v činnosti se seznamem druhů procesu. Pro automatizaci vstupu dat jsou k dispozici uživatelská nastavení (šablony s případným importem dat a masky).

V případě, že se jedná o napojení, je to umožněno několika způsoby (např. pomocí definice vyvolání, spuštěním uzlu ze záložky v činnosti „Procesy“ nebo v činnosti „Operace“ nebo ve specializované uživatelské položce hlavního menu nebo ze stromu či diagramu procesu, referenčním procesem, dynamickým spojením, apod.). Pro automatizaci vstupu dat jsou dále k dispozici transformace.

V okamžiku založení procesu je mu a všem jeho uzlům přiřazena uživatelská identifikace:

¨ rok – dle data v první zapsané události

¨ IDÚ – dle identifikace datového úložiště, kde došlo k zahájení procesu

¨ pořadové číslo – dle nastavení číselné řady u druhu procesu.

Založením procesu je jeho první operace uvedena do stavu zahájena. V případě, že založený proces je uzlem v nadřazeném procesu, mohou být dle uživatelského nastavení vazeb z něj vedoucích uvedeny cílové uzly z hlediska těchto vazeb do stavu připravena.

Založení procesů lze automatizovat aktivací uživatelské definice procesního importu ze skupinové položky hlavního menu IMPORT DO PROCESU na základě dat získaných importem.

1.4.1.1.2 Prohlížení a vyhledávání informací

Přehled všech založených procesů je dispozici v činnosti Procesy (také v činnosti Operace, kde jsou k dispozici všechny jejich uzly) pod skupinovou položkou hlavního menu PROCESY a OPERACE, kde je do určité míry přímo patrná i struktura a stav procesu.

Struktura a stav procesu (resp. stav jeho jednotlivých uzlů) jsou prezentovány uživateli v diagramech procesu nebo ve stromu procesu, které jsou k dispozici (lze je aktivovat jako související činnost) ve všech událostech procesu a ve všech operacích procesu. Z diagramu i stromu procesu či záložek činností s přehledem procesů lze zobrazit (aktivovat související činnost) události jednotlivých operací procesu a z nich dále ve vlastnostech operace informace o jejím stavu. Podobně je možné aktivovat činnosti pro vstup událostí do jednotlivých neukončených uzlů procesu.

V činnostech se seznamem procesů, operací nebo událostí lze definovat výběr za druh procesu nebo za uživatelskou identifikaci procesu. V seznamu operací (uzlů) lze vybírat dle stavu operace (uzlu). K vyhledání procesů dle jejich stavu je možno využít též semafor procesu nebo saldokontní hodnoty.

Pokud je k uzlu typu operace připojena zpráva, lze ji přímo ze zprávy spustit, tj. zobrazit její události.

1.4.1.1.3 Pokračování v procesu

Pokračováním v procesu se rozumí zápis těch událostí do jeho datové struktury, které nebyly zapsány v okamžiku založení procesu. Pokračování v procesu může být aktivováno automaticky po ukončení operace na základě uživatelského nastavení nebo uživatelským rozhodnutím kdykoliv.

Automatické pokračování procesu je dáno uživatelským nastavením v diagramu procesu, resp. druhu procesu ve vlastnostech uzlů a vazeb mezi nimi, které ovlivňují zejména řídící tok. Automatické spuštění pokračování procesu, tj. automatické spuštění (případně spuštění na pozadí) činnosti pro vstup událostí do některé operace procesu, se aktivuje při ukončení operace (resp. při zahájení procesu, který je uzlem jiného (předcházejícího) procesu, nebo při ukončení jeho první operace s vlastností „ukončuje proces“) tímto algoritmem:

¨ dle vyhodnocení vazeb a kódu po ukončení operací jsou referované uzly uvedeny do stavu připravena,

¨ uzel uvedený do stavu připravena, který má současně ve svých vlastnostech nastaveno spouštět automaticky (současná podmínka práva zápisu k danému druhu operace pro přihlášeného uživatele) nebo na pozadí, se zaznamená do zásobníku operací,

¨ dle operací (uzlů) zapsaných do zásobníku operací se automaticky aktivují činnosti pro vstup událostí do jeho vyčerpání v pořadí daném metodou „zásobník“; uživatel má možnost v zásobníku pořadí spuštění ovlivnit.

Uživatelské rozhodnutí o pokračování v procesu spočívá ve vyhledání odpovídajícího procesu a jeho uzlu, do kterého budou vstupovány události, a aktivace činnosti pro vstup událostí do odpovídající operace. Aplikace referenčního procesu umožní pokračování procesu se současnou modifikací jeho struktury připojením dalších druhů operací.

Pro případnou automatizaci pokračování v procesu je k dispozici skupinová položka menu NAPOJENÍ DO PROCESU, jejíž listové položky jsou automaticky vytvářeny dle uživatelských definic vyvolání. Při jejich spuštění je uživatel vyzván k zadání čísla procesu a následně je automaticky spuštěna činnost pro vstup událostí do té operace zadaného procesu, která je uvedena v definici vyvolání.

Pokračováním v procesu je automaticky zajištěno naplnění atributů událostí, které souvisí s jejich zařazením do operace v procesu, i atributů v tabulkách souvisejících s vazbami operací i událostí v procesu. Dále jsou k dispozici pro automatizaci vstupu dat do událostí tyto uživatelsky definované nástroje: masky, šablony a transformace, případně i importy dat.

1.4.1.1.4 Modifikace struktury procesu a opravy

Strukturu fyzického procesu při jeho založení danou druhem procesu lze modifikovat a to automaticky na základě nastavení vlastností jeho uzlů a vazeb obvykle v korelaci s datovým obsahem zejména relevantních událostí a souvisejících tabulek nebo na základě uživatelských rozhodnutí. Modifikací se rozumí změna diagramu procesu, tj. zejména zrušení či přidání uzlu nebo vazby mezi nimi, ale také změna jejich vlastností.

Automatická modifikace ve smyslu zrušení uzlu a s ním souvisejících vazeb vychází z uživatelských nastavení kódu po ukončení operace (např. v závislosti na datech, na dialogu s uživatelem, …) a výběrových vazeb XOR, tj. i v těchto okamžicích (ukončení operace, výběr cíle dle vazeb XOR) je aktivována automaticky. Podobně lze zrušit uzel procesu uživatelem přímo v jeho diagramu.

Automatická modifikace ve smyslu přidání uzlu (uzlů) a souvisejících vazeb vychází z uživatelských nastavení referenčních procesů, kterou aktivuje uživatel v činnosti prezentující události dané operace daného druhu z menu Obecné, ve kterém jsou jako položky uvedeny ty referenční procesy, které začínající shodným druhem operace. IS BM disponuje též funkcemi, které umožňují přidat uzel či vazbu přímo v jeho diagramu uživatelem.

Pro modifikaci struktury fyzického procesu jsou ve stromu procesu k dispozici funkce:

¨ osamostatnění procesu – uživatelem zvolený uzel procesu typu proces se aplikací této funkce stane nezávislým na svém původním (předcházejícím) procesu,

¨ kopírovat odkaz na proces * napojit proces – aplikace této dvojice funkcí umožňuje uživateli zvolený (kopírovat odkaz) proces napojit do struktury jiného procesu, který pro kopírovaný bude předcházejícím.

Pro opravy dat jednotlivých fyzických procesů prostým přepisem platí, že zejména v událostech operací, které jsou ukončené, lze opravovat minimum atributů (např. poznámka, selektory apod.), většinu atributů již takto opravovat nelze (např. AAA, datum, numerické či kvalitativní údaje apod.). Podmínkou jsou přístupová práva zápisu pro daného uživatele.

Pro opravy údajů v událostech ukončených operací je k dispozici funkce storna procesu aktivovatelná z činnosti s přehledem procesů nebo ze stromu procesu, která daný proces označí za stornovaný a současně k němu vytvoří stornující proces. Funkce storna je ošetřena přístupovými právy.

Stornující proces se vytváří automaticky a obsahuje události dle stornovaného procesu s opačným znaménkem u numerických atributů, které mohou být zdrojem pro aktualizaci hodnot. Toto platí pro události těch operací, jejichž druh má definované zrcadlové storno, ostatní události a operace jsou zrušeny. Implicitní datum stornujících událostí odpovídá datu stornovaných událostí s tím, že uživatel má v okamžiku aktivace storna možnost zadat datum jiné.

Druhá forma opravy údajů v událostech ukončených operací je založena na funkci zrušení stavu „ukončena“ dané operace, která je aktivovatelná z menu VOLBY - vlastnosti operace za podmínky, že v daném procesu existuje neukončená operace (uzel) s uživatelsky nastavenou vlastností ukončuje proces.

Aplikací této funkce na danou operaci dojde ke zrušení jejího stavu ukončena a nastavení stavu připravena při současném ovlivnění následujících operací, do kterých směřuje běžná vazba z dané operace (resp. následujících – řetězové chování), tak, že je obdobně změněn jejich stav a dále jsou v nich zrušeny události.

1.4.1.1.5 Operace (fyzická operace)

Fyzická operace je „složka“ fyzického procesu, ve které jsou uloženy události (resp. odkazy na ně) dané komponenty vzniklé v rámci daného procesu.

Operace jako uzel fyzického procesu nabývá dle uživatelského nastavení řízení provádění procesu (nastavení řídícího toku pro daný druh procesu) stavu ano/ne u atributů „připravena“, „zahájena“, „ukončena“ a v případě vybraných komponent i u atributu „předběžně ukončena“.

Vstup událostí operace je buď zahájením nebo pokračováním procesu. Dle uživatelského nastavení automatizace vstupu dat do událostí jednotlivých operací (nastavení datového toku pro daný druh procesu) mohou být jejich atributy automatizovaně předplňovány. Pokud je realizováno předplnění s využitím míry plnění, pak je v menu Volby k dispozici funkce Aktivní míra plnění, jejíž aktivace zajistí, že nově vstoupená událost bude zahrnuta z hlediska vyhodnocení míry plnění k události, na níž byl kurzor v okamžiku aktivace vstupu nové události.

Pokud má relevantní uzel diagramu nastaveno ukončovat automaticky, je při zápisu událostí k uživateli vznesen dotaz, zda ukončit operaci. Pokud nemá, je operace ukončována rozhodnutím uživatele z menu Obecné.

1.4.1.2 Druh procesu

Druh procesu představuje jakousi šablonu vyjádřenou uživatelsky definovaným uspořádáním druhů operací a „zapouzdřených“ druhů procesů jako uzlů grafu (diagramu) a dále vztahů mezi nimi, které definují způsob změny stavů jednotlivých uzlů a související posloupnost jejich provádění (řídící tok – work-flow) a způsob automatizace vstupu dat do událostí jednotlivých operací (datový tok).

K druhu procesu jsou definována práva týkající se možnosti zahájení procesů daného druhu. Na základě definice číselné řady u druhu procesu jsou fyzické procesy následně pořadově číslovány v rámci roku první jeho události a datového úložiště.

Dle definice druhu procesu je odvozena struktura každého fyzického procesu daného druhu při jeho zahájení. Tato struktura je uživatelsky dále modifikovatelná, například: vložení nového uzlu, zrušení stávajícího uzlu, změna vlastností uzlu, změna definice řídícího či datového toku.

1.4.1.2.1 Druh operace

Druh operace je základním stavebním kamenem definice druhu procesu, kde představuje „listový“ uzel. Vlastnosti druhu operace i vlastnosti druhu operace v procesu (uzlu procesu) následně dědí operace fyzické (skutečné) ve fyzickém procesu.

Druhy operací jsou uživatelsky definovány dle jednotlivých komponent. Rozlišují se druhy operací běžné, dávkové a dávkové unikátní. Obsahem operací, jejichž druh je definován jako běžný, jsou události dané komponenty, a obsahem operací, jejichž druh je definován jako dávkový, jsou odkazy na již evidované události dané komponenty. V případě dávkové unikátní se jedná o jediný odkaz.

K druhu operace lze definovat přístupová práva, která se uplatní i na události obsažené ve fyzických operacích daného druhu. V rámci definice druhu operace lze dále definovat algoritmus aktualizace hodnot komponenty, možnost automatické aktivace volné karty operace či procesu po ukončení operace daného druhu, způsob chování při stornu dané operace, možnost zobrazování ve stromu hlavního procesu, spojení adresátů v událostech komponent, validaci vstupu založenou na výši aktuálních hodnot a spojenou s případnou zprávou, masku operace pro předplňování údajů při vstupu událostí, strukturu informací zobrazovaných z událostí ve stromu procesu a případné další specifické vlastnosti druhu operace v dané komponentě.

Je-li daný druh operace užitý jako uzel v diagramu druhu procesu, jsou mu uživatelsky přiřazeny další vlastnosti, například způsob spuštění (automaticky, na pozadí, …), maska operace v procesu, výstup, který bude automaticky spuštěn, …

1.4.1.2.2 Diagram druhu procesu

Diagram druhu procesu je grafické vyjádření jeho struktury obsahující definice řídícího i datového toku. Diagram je uživatelsky definován posloupností jednotlivých uzlů, reprezentovaných druhy operací nebo druhy procesů, a vazeb mezi nimi.

Na každém uzlu diagramu lze vyvolat menu obsahující tyto položky:

¨ vlastnosti, tj. funkce pro nastavení specifického chování operace v rámci daného procesu,

¨ odstranit, tj. funkce pro zrušení daného uzlu diagramu procesu; současně se odstraní vazby s uzlem související a také ty uzly, které by se pak staly nepropojenými s první operací.

A na uzlech typu operace toto menu dále obsahuje:

¨ kód po ukončení (pouze pro uzel typu operace) – možnost nastavení kódu po ukončení operace,

¨ vstupní maska operace (pouze pro uzel typu operace) – možnost definice vstupní masky operace pro automatizaci vstupu dat,

¨ maska operace v procesu (pouze pro uzel typu operace) – možnost definice masky operace platné pouze v daném druhu procesu.

¨ Ve vlastnostech uzlu procesu lze uživatelsky definovat:

¨ způsob spuštění uzlu, tj. způsob aktivace činnosti pro vstup událostí do jeho operace,

¨ zda bude uzel automaticky spuštěn jen po nepředběžném ukončení předchozích operací,

¨ zda a jak bude aktualizována hodnota semaforu procesu při ukončení operace (resp. při zahájení procesu, je-li uzlem proces),

¨ zda bude vytvořena záložka na tento uzel při založení procesu, tj. zda bude do něj zaznamenán adresát z první události procesu,

a ve vlastnostech uzlu typu proces lze uživatelsky dále definovat:

¨ zda odvozené procesy budou hlavními procesy,

a ve vlastnostech uzlu typu operace lze uživatelsky dále definovat:

¨ zda má být zde uvedená šablona automaticky uplatněna při prvním vstupu událostí do této operace, tj. při aktivaci činnosti pro vstup událostí dané komponenty do dané operace, pokud do ní dosud nebyly zapsány žádné události,

¨ zda bude po ukončení operace automaticky aktivována činnost pro tisk dokladu podle zde uvedené metapředlohy z dat událostí tohoto procesu na základě prezentace procesu,

¨ zda bude po ukončení operace automaticky aktivována činnost pro tisk výstupu podle zde uvedené předlohy z dat událostí této operace,

¨ explicitní oprávnění ukončit operaci zde uvedenou skupinu uživatelů,

¨ způsob ukončení operace, tj. automaticky ukončit, automaticky neukončovat nebo automaticky ukončit předběžně,

¨ zda operace ukončuje proces.

Mezi dvěma (zdrojový a cílový) uzly diagramu lze definovat nejméně jednu vazbu. Pokud je některý z dvojice uzlů typu proces lze definovat další vazby mezi nimi ve vlastnostech. Na každé vazbě v diagramu vyjádřené šipkou lze vyvolat menu obsahující tyto položky:

¨ vlastnosti, tj. funkce pro nastavení parametrů dané vazby,

¨ odstranit, tj. funkce pro zrušení dané vazby diagramu procesu; současně se odstraní uzly, které by se pak staly nepropojenými s první operací, a vazby s těmito uzly souvisejícími.

Ve vlastnostech každé vazby mezi zdrojovým a cílovým uzlem lze uživatelsky definovat:

¨ pořadí vazby, v jakém bude vyhodnocována,

¨ zda bude uplatněna transformace pro automatizaci vstupu dat do událostí cílového uzlu,

¨ která transformace bude uplatněna ze seznamu transformací uplatnitelných mezi dvojicí komponent daných komponentou zdrojového a cílového uzlu,

¨ jaké bude rozlišení pro vyhodnocení míry plnění,

¨ druh vazby, který různým způsobem ovlivňuje řídí tok procesu (stav cílového uzlu) a případně i strukturu fyzického procesu a způsob spuštění cílového uzlu.

¨ v případě výběrového druhu vazby, kdo (skupina uživatelů nebo ten, kdo ukončí operaci) bude rozhodovat o pokračování,

¨ zda bude ukončena signalizace

¨ zda bude uplatněna obecná předkontace – v překryvném seznamu se nabízejí obecné předkontace, které jsou určeny pro danou transformaci

a v případě, že je cílový uzel typu proces, je možné dále uživatelsky definovat ve vlastnostech každé vazby:

¨ číslo vazby mezi zdrojovým a cílovým uzlem,

¨ uzel v cílovém uzlu (procesu), který bude cílovou operací; pokud je jako uzel v cílovém procesu definován opět proces, bude cílová operace jeho první operace,

a v případě, že je zdrojový uzel typu proces, je možné dále uživatelsky definovat ve vlastnostech každé vazby:

¨ číslo vazby mezi zdrojovým a cílovým uzlem,

¨ uzel ve zdrojovém uzlu (procesu), který bude zdrojovou operací,

¨ zda dojde k vyhodnocení vlivu vazby na cílový uzel po zahájení procesu nebo až po ukončení jeho operace s nastavenou vlastností ukončuje proces.

1.4.1.3 Modelování řídícího toku

Řídícím tokem procesu se rozumí rozhodování při běhu (provádění) fyzického procesu ve smyslu, co bude následovat (jak může proces pokračovat) na základě aktuálního stavu procesu (tj. stavu všech definičních i aplikačních dat souvisejících s procesem, ale případně i jiných dat) a případného dialogu s uživatelem. Základními prvky řízení procesu je změna stavu jednotlivých uzlů a jejich automatická aktivace (spouštění), případně i modifikace struktury procesu.

Řídící tok je na dané struktuře (diagramu) procesu implementován pomocí vlastností uzlů a vazeb mezi uzly procesu a kódu po ukončení operace s přihlédnutím k přístupovým právům.

Druh vazby mezi uzly ovlivňuje automatické nastavení stavu cílového uzlu takto:

¨ pokud do cílového uzlu směřuje jediná běžná (výběrové vazby se z hlediska vlivu na stav cílového uzlu chovají jako vazby běžné) nebo alespoň jedna samostatná vazba, bude cílový uzel uveden automaticky do stavu „připraven“ v případě zdrojového uzlu typu operace ukončením operace nebo v případě zdrojového uzlu typu proces zahájením procesu (pokud je ve vazbě zatrženo „po ukončení procesu“, pak až ukončením některé jeho operace s nastaveným atributem uzlu „Ukončuje proces“),

¨ pokud do cílového uzlu směřuje několik běžných vazeb, bude cílový uzel uveden automaticky do stavu „připraven“ v okamžiku, kdy samostatné působení každé vazby by vedlo na uvedení cílového uzlu do stavu „připraven“.

Kromě automatického nastavení stavu uzlů „připraven“ pomocí vazeb je možné jej nastavit pomocí kódu po ukončení operace na základě dat nebo na základě rozhodnutí uživatele.

Ukončení uzlu typu operace lze ovlivnit v jeho vlastnostech nastavením, kdo má právo ukončit operaci, a nastavením způsobu ukončení (automaticky ukončit, automaticky neukončit, automaticky ukončit předběžně – pouze pro ty komponenty, které to umožňují).

Stavy uzlů, které se kromě uvedené automatizace nastavují zápisem dat relevantních dat (zejména události a operace) a souvisejícím rozhodováním uživatele, lze z hlediska automatizace využít pro definici uživatelských položek hlavního menu nebo pro automatické spuštění připravených uzlů.

Uzly uvedené do stavu „připraven“, pokud mají ve svých vlastnostech nastaveno spouštět automaticky nebo na pozadí, jsou zařazeny do zásobníku operací dle pořadí vazby a z něj automaticky spouštěny.

1.4.1.4 Modelování datového toku v procesech IS BM

Datovým tokem v souvislosti s procesy IS BM se rozumí vstup dat událostí a zejména související automatizace (předplnění atributů) v rámci struktury fyzického procesu. Modelováním datového toku se rozumí nastavení pravidel pro vstup událostí v rámci procesu (druhu procesu, resp. fyzického procesu).

Mezi nástroje IS BM ovlivňující datový tok procesu kromě přímého vstupu dat z klávesnice a importu dat, patří uživatelsky definovatelné nástroje pro jeho automatizaci, tj. šablony, masky operace a transformace, ale také uživatelem neovlivnitelný programový kód specifický pro každou komponentu.

Z hlediska priorit uplatnění nástroje pro automatizaci vstupu v případě jejich současné uživatelské implementace obvykle platí, že nejvyšší prioritu má programový kód, dále explicitní definice v pravidle transformace, masky operace, implicitní definice v pravidle transformace a nakonec ostatní (např. šablona, import a ruční vstup dat).

1.4.1.4.1 Šablona

Šablona je nástroj IS BM, který umožňuje na základě uživatelského vstupu několika proměnných (případně i na základě definice importu dat nebo programového kódu vstupů šablony pro každou komponentu specifických) automatizovaně vygenerovat několik událostí (předplnit jejich atributy). Alternativou je užití šablony na hromadnou změnu hodnoty atributu všech událostí neukončené operace.

Šablona, jejíž definice se skládá z hlavičky, proměnných a pravidel, je určena na generování událostí právě té komponenty, do které patří. Každé pravidlo šablony generuje jednu událost, což nemusí platit v případě využití importu nebo vstupu v její definici. V rámci definice šablony se definuje:

¨ název a druh, jehož přístupová práva řídí možnost aplikace šablony přihlášeným uživatelem,

¨ import, pokud budou data generována z dat zpřístupněných definicí importu,

¨ programátorsky připravený vstup šablony, pokud budou data generována dle jeho programového kódu (kopie operace a kopie události je k dispozici ve všech komponentách),

¨ zda se jedná o hromadnou opravu atributu všech již zapsaných událostí operace, ze které je aktivována, nebo vstup nových dat (událostí),

¨ příznak, zda šablona je veřejná (tzn. přístupná i ostatním uživatelům) nebo zda šablona zůstane přístupná pouze pro toho uživatele, který ji definuje,

¨ vzhled okna, ve kterém je při aplikaci šablony uživatel vyzván k zadání proměnných, je uživatelsky definován pomocí funkce uživatelský design v menu Volby,

¨ na záložce proměnné šablony seznam proměnných (pořadí, typ, velikost, návěští, způsob naplnění – vstup/výpočet, inicializační hodnota, …) použitých v pravidlech; pro definici výrazu inicializační hodnoty lze užít obecnou předkontaci,

¨ pravidla šablony (v případě šablony využívající definici importu dat se neuplatní) v menu Volby, ve kterých se pro jednotlivé vstupní atributy události definuje předplnění uvedenou konstantou nebo proměnnou anebo kopírováním, je-li uplatněn vstup šablony kopie operace.

Pokud je ve vlastnostech uzlu v diagramu procesu uvedena šablona prvého vstupu je v okamžiku spuštění neukončené relevantní operace automaticky aktivována.

1.4.1.4.2 Vstupní maska operace

Vstupní maska operace umožňuje pro uživatelem zvolené vstupní atributy události daného druhu operace uživatelsky definovat jejich oproti programovému kódu nové vlastnosti:

¨ inicializace při vstupu konstantou nebo výrazem (s možností využití tabulky obecné předkontace) komponenty,

¨ validace logickým výrazem v syntaxi FoxPro, ve kterém ### symbolizuje vstoupenou hodnotu odpovídajícího atributu a $$$ symbolizuje identifikaci tabulky události dané komponenty, s uvedením volného textu jako chybového hlášení,

¨ reakce na F2, tj. spuštění některé ze zde dostupných činností IS BM,

¨ zda má být daný atribut vstupován (na něj umístěn kurzor) jako první (pokud mu budou dle programového kódu předcházet atributy, které nevyhoví validaci, bude kurzor umístěn na ně),

¨ zda bude uživateli umožněna editace,

¨ zda bude hodnota atributu opakována dle předchozí události dané operace,

¨ zda se uvedená konstanta či první uživatelem uvedená hodnota atributu zapíše do osobní masky uživatele.

Vstupní masku operace lze definovat ve třech úrovních (seřazeno od nejnižší priority uplatnění), tj. maska druhu operace (lze definovat v menu Volby v činnosti s přehledem druhů operací nebo na uzlu diagramu procesu, kde je daný druh operace využit), maska druhu operace platná pro daný druh procesu (na uzlu diagramu procesu daného druhu, kde je daný druh operace využit), osobní maska operace platná pro přihlášeného uživatele.

Všechny úrovně masky operace lze definovat v okamžiku vstupu událostí dané operace v menu Obecné s případným obnovením masky pro aktuální aplikaci.

1.4.1.4.3 Transformace a její pravidla, míra plnění

Transformace představuje definiční data, na jejichž základě se automaticky generují události cílového uzlu vazby (v okamžiku jeho spuštění, pokud cílový uzel není reprezentován ukončenou operací) vycházeje z událostí zdrojového uzlu vazby.

Transformace je vztažena ke komponentě zdrojového uzlu, pro kterou jsou programátorsky definovány výstupní atributy komponenty, a ke komponentě cílového uzlu, pro kterou jsou programátorsky definovány vstupní atributy komponenty.

Transformace umožňuje uživatelsky definovat, kolik událostí, za jakých podmínek a s jak předplněnými vstupními atributy se má vygenerovat z každé události zdrojového uzlu. Definice, která může využívat výrazy komponenty, se skládá z vlastní transformace a z nejméně jednoho jejího pravidla.

Činnost prezentující (s možností aktualizace) seznam transformací pro dvojici zdrojové a cílové komponenty je aktivována z vlastností vazby v diagramu procesu. Na záložce „obecné předkontace“ je možno definovat obecné předkontace, které se mohou využívat v souvislosti s danou transformací. Tyto předkontace se následně zobrazují jako překryvný seznam ve vlastnostech vazby mezi zdrojovým a cílovým uzlem v diagramu procesu. Na záložce „výskyt ..“ jsou k dispozici druhy procesů, ve kterých je daná transformace uplatněna, a v menu Volby lze aktivovat jejich diagram. V menu Volby je k dispozici funkce pro kopii operace a funkce pro aktivaci činnosti s přehledem pravidel dané operace včetně jejich aktualizace.

Mezi významné atributy transformace patří:

¨ automaticky naplněné atributy: jednoznačná časová identifikace, zdrojová a cílová komponenta vyplývající z komponent zdrojové a cílové operace vazby v diagramu procesu, ke které je transformace definována, a autorizační údaje,

¨ vlastní název transformace,

¨ filtr transformace definovaný výrazem komponenty typu L s významem: pouze na ty události zdrojového uzlu, pro které uvedený výraz nabude logické hodnoty .T., budou aplikována pravidla transformace,

¨ rozpad na procesy definovaný výrazem komponenty typu C s významem: pokud je cílový uzel typu proces, bude pro každou hodnotu uvedeného výrazu založen samostatný fyzický proces, do kterého budou transformována data jen z relevantních (shoda výrazu) událostí,

¨ popis rozpadu definovaný výrazem komponenty typu C se předplní do popisu procesu založeného na základě rozpadu,

¨ doplnění pohledu, které umožňuje rozšířit množinu programátorsky připravených výstupních atributů komponenty o další uživatelsky definované formou uživatelského rozšíření relevantního SQL dotazu, kde $$$ symbolizuje alias tabulky zdrojových událostí a %%% symbolizuje alias databáze; výrazy využívající ve své definici doplněné atributy musí být uvedeny znakem ~,

¨ program transformace, který pomocí programového kódu IS BM umožňuje řešit specifické nároky na transformaci, pokud je pro danou zdrojovou a cílovou komponentu k dispozici,

¨ právo následující operace podle umístění, které umožňuje uživateli při ukončení operace zdrojového uzlu závazně uvést alokaci pro předplnění události cílového uzlu,

¨ transformace dynamické vazby, která umožní použití transformace (pouze) v dynamických vazbách,

¨ aktivovat následující operaci podle filtru transformace, což způsobí, že následující operace je aktivována (tzn. převedena do stavu připravena) pouze v případě, že existuje událost ukončované operace vyhovující filtru transformace.

Na základě nastavení pravidla transformace lze z jedné události zdrojového uzlu (přesněji ze záznamu tabulky naplněné relevantním příkazem SELECT) vygenerovat obvykle jednu událost cílového uzlu.

V případě, že výraz výběru pravidla nabude hodnoty F nebo je míra plnění již naplněna, nebude vygenerována ani jedna cílová událost. Pokud jsou uživatelem modifikovány implicitní předplněné hodnoty nebo numerické hodnoty užité ve výrazu předplňování při aktivní míře plnění, lze z jedné zdrojové události vygenerovat několik událostí výstupních.

Pravidlo transformace se skládá ze základních údajů ve své hlavičce a z definice předplnění vstupních atributů cílové události dané komponenty. V činnosti s přehledem pravidel dané transformace je v menu Volby k dispozici funkce s přehledem výstupních atributů zdrojové komponenty.

Mezi významné atributy pravidla transformace patří:

¨ autorizační údaje,

¨ pořadové číslo, které definuje, v jakém pořadí bude pravidlo transformace uplatněno a tím i pořadí cílových událostí,

¨ rozlišení, které zajistí, že pravidla transformací se shodným rozlišením a shodnou cílovou hodnotou budou z hlediska předplňování mírou plnění vyhodnocována společně,

¨ agregační výraz definovaný výrazem komponenty typu C s významem: pokud nabývá pro několik vstupních záznamů (událostí) shodné hodnoty bude z nich generována jediná výstupní událost, ve které budou hodnoty numerických atributů (těch, které jsou disponibilní v definici druhu hodnoty jako vstupní hodnota) sečteny a atributy ostatních typů předplněny z první vstupní události; specifické je užití výrazu [##] pro pomocné slučování, kdy je agregováno do první události cílové operace, a využití obecné předkontace pro předplnění vstupního atributu, dle jehož hodnoty lze agregovat výrazem, ve kterém je daný atribut uvozen takto: ~data.v_ .

¨ výběr definovaný výrazem komponenty typu L s významem: pouze na ty události zdrojového uzlu, pro které uvedený výraz nabude logické hodnoty .T., bude aplikováno dané pravidlo transformace; výraz je vyhodnocován včetně atributů získaných v doplnění pohledu,

¨ zdrojová hodnota, která definuje numerickým výstupním atributem zdrojové události fakticky výraz, dle kterého bude předplňována cílová hodnota na základě míry plnění; pokud je definován výraz přímo v definici předplnění cílového atributu uvedeného jako cílová hodnota, pak má vyšší prioritu a uplatní se,

¨ cílová hodnota, která definuje numerický atribut cílové události, který bude určen pro řízení předplňování na základě míry plnění

V definici předplnění jednotlivých vstupních atributů cílové události dané komponenty lze uplatnit:

¨ uvedenou konstantu,

¨ uvedený výraz komponenty shodného typu s typem vstupního atributu; pokud jsou v jeho definici uvedeny další prvky kromě implicitních výstupních atributů, konstant a funkcí FoxPro, je nutné jej uvést znakem ~, pak nebude validována jeho syntaxe,

¨ kopii ze zdrojového atributu, což je implicitní předplnění, které se uplatní pro atributy, jejichž identifikátor je ve zdrojové i cílové události shodný, a pro poznámku,

¨ míru plnění, která na základě definovaného atributu cílové hodnoty a výrazu jeho předplňování jej předplní hodnotou získanou jako rozdíl vyhodnocení uvedeného výrazu a již zapsaných hodnot do relevantních atributů cílových událostí při aktivní míře plnění se shodným rozlišením vazby a pravidla; předplnění mírou plnění se v některých případech přiměřeně uplatní i na numerické atributy nedefinované jako cílová hodnota.

Informaci o propojení zdrojové a cílové události pomocí míry plnění zaznamená IS BM do vazební entity, kde se současně uvádí komponenta zdroje i cíle, rozlišení vazby i pravidla. Při ukončení operace probíhá test na „vyrovnanost“ z hlediska míry plnění, je-li to nastaveno u daného druhu operace, a v případě „nevyrovnanosti“, je o tom uživatel upozorněn formou hlášení.

1.4.1.5 Související definice

1.4.1.5.1 Procesní import

Procesní import je uživatelská definice dávkového zpracování, která umožňuje na základě importovaných dat automatizovaně zakládat nové procesy nebo pokračovat v procesech již založených.

Činnost s přehledem definic procesních importů umístěná v hlavním menu ve skupinové položce INFORMAČNÍ CENTRUM prezentuje na záložce výrazy, které ovlivňují chování procesní importu. V menu Volby jsou k dispozici funkce pro aktivaci procesního importu, prohlížení importovaných dat, zobrazení konverze atributů relevantního importu dat a zobrazení diagramu relevantního druhu procesu. Tyto definice lze exportovat do balíčku.

Mezi významné atributy definice procesního importu patří:

¨ název, který se případně stane položkou hlavního menu pod skupinovou položkou IMPORT DO PROCESU,

¨ druh daného procesního importu, dle kterého se řídí práva procesní import aktivovat,

¨ proces, tj. identifikace druhu procesu, kterého se procesní import týká,

¨ operace, tj. identifikace uzlu daného procesu, který se procesním importem spouští,

¨ I-E, tj. definice importu dat do událostí uvedené operace, kterým budou získána data,

¨ založení, tj. způsob, jakým má být výše uvedený proces vytvořen:

¨ nový proces definuje, že procesní import založí nový samostatný proces,

¨ nový proces podle záložky definuje, že procesní import založí nový proces a ten vloží do již existujícího uzlu typu proces, pro který platí, že adresát jeho záložky je shodný s adresátem konvertovaným ze zdrojových dat; pokud takovýto uzel neexistuje, IS BM o tom podá informaci a import není aktivován,

¨ nový proces - napojení definuje, že procesní import založí nový proces a ten vloží dle výrazů pro rok, IDÚ, číslo procesu a pořadí uvedených na záložce okna činnosti s přehledem procesních importů do již existujícího procesu dané identifikace a to do uzlu výše uvedeného,

¨ nový proces s EI definuje, že procesní import založí nový samostatný proces, který převezme identifikaci z výrazů uvedených na záložce,

¨ existující proces s EI definuje, že procesní import zapíše události do dané operace již existujícího procesu, který identifikuje dle výrazů pro rok, IDÚ, číslo procesu a pořadí uvedených na záložce okna činnosti s přehledem procesních importů,

¨ spustit operaci na pozadí, je-li zatržen bude uzel, do kterého je importováno, nastaven na spustit na pozadí,

¨ zobrazit v menu, je-li zatržen stane se tato definice položkou skupinové položky hlavního menu IMPORT DO PROCESU,

¨ CID, který je určen pouze k využití programovým kódem IS BM,

a dále na záložce „výrazy“:

¨ rozpad definuje výraz, pro který platí, že zdrojová data s jeho shodnou hodnotou budou importována do jedné operace společně; současně dochází k automatickému rozpadu ve variantách založení procesu typu "napojení",

¨ jednoznačná identifikace definuje výraz, který je importem považován za identifikátor jedinečného klíče (referenční integrita) zdrojových dat, což způsobuje, že do IS BM je za danou hodnotu tohoto výrazu importováno pouze jedenkrát; při pokusu o opakovaný import je uživatel upozorněn na chybu s dotazem zda pokračovat s odmítnutím duplicitních dat,

¨ výrazy rok, IDÚ, číslo a pořadí se používají pro identifikaci existujícího procesu při napojení k němu, případně při založení nového procese s EI.

1.4.1.5.2 Definice vyvolání

Definice vyvolání je uživatelská definice, která umožňuje na základě zadání uživatelské identifikace fyzického procesu v něm pokračovat automatickým spuštěním činnosti pro vstup událostí v operaci, která je uvedena v definici.

V menu Volby činnosti prezentující seznam těchto definic ji lze aktivovat. Mezi významné atributy definice vyvolání patří:

¨ identifikace a název, pod kterým je dostupná pro aktivaci v hlavním menu pod skupinovou položkou NAPOJENÍ DO PROCESU,

¨ proces, tj. druh procesu, do kterého se má realizovat napojení,

¨ operace, tj. identifikace uzlu uvedeného druhu procesu (tj. komponenta, druh operace a pořadí v diagramu; je-li uzlem proces, uvádí se jen druh procesu jako druh operace), pro který bude aktivována činnost vstupu událostí.

1.4.1.5.3 Dynamická spojení operací

Dynamické spojení (dynamická vazba) operací je programový kód a s ním související uživatelská definice, na jejímž základě lze z jednoho procesu ovlivnit druhý proces ve smyslu řídícího i datového toku.

Typickým představitelem je ovlivnění procesu obsahujícího operaci komponenty PLA operací komponenty ZSP po spárování jejich událostí, v okamžiku ukončení operace ZSP nebo následné změny spárování.

Uživatelská část definice dynamického spojení ZSP-PLA obsahuje:

¨ druh procesu, fakticky uzlu, který bude uveden do stavu připraven v těch procesech, ve kterých je událost PLA spárovaná s událostí aktivující operace ZSP,

¨ druh operace, fakticky identifikace uzlu (typ operace komponenty UCE) výše uvedeného procesu, který bude cílem této dynamické vazby i zde uvedené transformace a pro který bude spuštěna činnost pro vstup událostí,

¨ transformace, dle které budou předplněna data do cílové operace,

¨ rozlišení vazby, které bude využito při předplnění cílových událostí dle míry plnění,

¨ pořadí transformací, které definuje, v jakém pořadí bude pravidlo transformace uplatněno a tím i pořadí cílových událostí,

¨ seznam (na záložce Aktivující operace) operací, při jejichž ukončení dojde k vyhodnocení dané dynamické vazby.

Činnosti s přehledem dynamických vazeb i jejich definice pro případné další dvojice komponent jsou obdobné.

1.4.1.5.4 Prezentace procesu

Prezentace procesu je uživatelská definice určená na podporu prezentace informací souvisejících s daným procesem v předlohách výstupu v činnosti s přehledem procesů.

Její uvedení ve vlastnostech předlohy výstupu (s definovaným pohybem v událostech) zpřístupní jako atributy tisku současně i atributy tisku všech činností, které prezentují události operací, jejichž druh je uveden v definici prezentace.

Kromě identifikace a názvu, pod kterým je dostupná v předloze výstupu, se v činnosti s přehledem prezentací procesu na záložce definují druhy operací, jejichž události budou následně dostupné pro výstup.

Současně se definuje pořadí, v jakém budou následně události ve výstupu seřazeny, a zda do výstupu budou vybrány události pouze z operací procesu (který patří do množiny procesů vybraných pro výstup) nebo z operací celého hlavního procesu (implicitní varianta).

1.4.1.5.5 Saldokontní hodnoty procesu

Saldokontní hodnota procesu je tabulka informačního centra IS BM obsahující kromě identifikace hlavního procesu a druhu saldokontní hodnoty (součástí tabulky může být i adresát, artikl a alokace) numerickou hodnotu, která je aktualizována zápisem událostí v operacích patřících do daného procesu, je-li to pro daný druh operace a procesu nastaveno.

Druhy saldokontních hodnot se definují v činnosti, kterou lze aktivovat z činnosti s přehledem druhů hodnot každé komponenty. Je-li daný druh hodnoty komponenty definován jako saldokontní, pak se zde v jeho definici uvádí i druh saldokontní hodnoty a následně jsou i relevantní saldokontní hodnoty procesů aktualizovány dle zde uvedených pravidel.

IS BM obsahuje ve svém hlavním menu listovou činnost Nedokončené procesy, která prezentuje seznam nenulových (tj. fakticky existujících) saldokontních hodnot procesů dle výběru uživatele. Na záložce jsou k dispozici operace hlavního procesu s možností je v menu Volby spustit. Z menu Volby lze též aktivovat diagram procesu a strom hlavního procesu. Dále je zde k dispozici funkce, která aktivuje činnost prezentující skladbu saldokontní hodnoty, tj. vybrané informace z událostí různých komponent, které se podílejí na dané saldokontní hodnotě procesu.

1.4.2 Objektové vazby

Objektová vazba umožňuje uživatelsky definovat vztah (předchůdce – následník) mezi dvěma objekty, tj. mezi dvěma záznamy ve „významných“ tabulkách IS (tj.: AAA, události, operace a jejich druhy, procesy a jejich druhy, dokumenty a příkaz k úhradě). K vazbě objektů lze volnou kartou definovat další vlastnosti (atributy).

Existence objektové vazby mezi objektem, na kterém je umístěn kurzor, a dalším objektem je uživateli signalizována, pokud má zapnut (ikona stromeček v panelu nástrojů) příslušný panel a v něm nastaveno zobrazení signalizace vazeb k objektům z odpovídající tabulky. Z panelu lze přímo aktivovat činnost, která zobrazí seznam objektů (tj. i jejich atributů) daného druhu připojených touto vazbou.

Vzhled okna této činnosti koresponduje s oknem vlastní činnosti pro zobrazení seznamu předchůdců či následníků a je doplněn údaji o záznamu (objektu), ze kterého byla činnost aktivována, a ovládacím tlačítkem, kterým lze přepnout mezi zobrazením předchůdců nebo následníků, a tlačítkem, kterým lze zobrazené záznamy zafixovat, tj. při posunu kurzoru ve výchozí činnosti nedojde k aktualizaci tohoto okna.

K propojení záznamů (objektů) objektovou vazbou lze užít přímý vstup v okně se zobrazením objektově svázaných záznamů, přičemž dojde k založení nového záznamu předchůdce či následníka. Již existující objekty lze provázat pomocí ikony „stromečku“ v okně činností s přehledem těch záznamů, které jsou objekty.

Objektová vazba se technicky realizuje pomocí atributů s jednoznačnou časovou identifikací záznamu (record).

1.4.3 Dokumenty

IS BM umožňuje kromě vlastních funkcí si k sobě „přitáhnout“ i funkčnost, kterou disponují externí programy případně i s jejich externě uloženými daty, tj. dokumenty v širším slova smyslu. Mezi použitelné programy patří především ty, které lze spustit s parametrem uvádějícím soubor s daty určenými pro zpracování daným programem, například MS Word, MS Excel, MS IE, MS Project, Sybase Power Designer, ale také T602, Quatro apod.

Uvedené a další užívané programy jsou uživatelsky definovatelné jako spouštěné aplikace s řadou vlastností, které definují způsob spuštění, způsob předávání dat a další parametry. U spouštěných aplikací lze též definovat akce, které se mají provést nad dokumentem.

Každý dokument je určitého druhu, dle kterého jsou k němu nastavena přístupová práva. Přístup z hlediska zápisu lze dále omezit nastavením atributu „chráněný dokument“, pak jej může modifikovat pouze autor.

IS BM dále umožňuje definovat předlohy dokumentů, které se uplatní při založení dokumentu. Ty mohou obsahovat konstantní údaje opakovatelně použitelné ve více dokumentech, jejich formátování, případná slučovací pole pro hromadnou korespondenci, skript apod. Obsah souboru, jehož struktura je daná programovým kódem IS BM, pro hromadnou korespondenci je automaticky naplňován při otevření dokumentu založeného na předloze s definovaným atributem „mailmerge“ pomocnými údaji (xxx, xxxxxxx, …) nebo skutečnými zejména adresními údaji z událostí operace pošty spojené objektovou vazbou s dokumentem. Pro smysluplné využití této funkce je možné dokument spojit pouze s jedinou operací pošty.

Dokumenty lze kategorizovat, tzn. každý dokument je možno přiřadit do jedné nebo více kategorií dokumentů. Jednotlivé kategorie dokumentů mezi sebou mohou mít nastavenu vazbu předchůdce – následník. Způsob nadefinování kategorie dokumentů ovlivňuje zobrazování dokumentů v okně činnosti Spojené dokumenty, tzn. zda bude vytvořena adresářová struktura či nikoliv.

Dokumenty jako objekty z hlediska objektových vazeb mohou být z jiného objektu vyvolány (zpřístupněny) nejen pomocí odpovídajícího toolu, ale i v okně se spojenými dokumenty stiskem kláves CTRL D (v případě, že daný objekt je událost jsou zde dostupné i dokumenty operace, procesu a adresáta), čímž se zpřístupní i řada funkcí aplikovatelných na každý dokument, např. odeslání dokumentu e-mailem, kopírování dokumentu, uložení dokumentu na disk, spuštění volné karty, spuštění libovolné operace připojené objektovou vazbou k němu, založení procesu s operací pošty s připojením dokumentu objektovou vazbou k ní, apod. Okno se spojenými dokumenty operace lze vyvolat též automaticky při ukončení operace, pokud je to uživatelsky uvedeno v jejím kódu po ukončení. V případě, že v hlavním menu programu je obsažen program PCT_DLL.DLL, je možno v okně spojených dokumentů vložit obrázek v clipboardu. Tento obrázek je pak následně ukládán ve formátu JPEG.

IS BM umožňuje přenášet soubory tažením myší (metoda „táhni a drž“) do okna spojených dokumentů např. z okna průzkumníka Windows. Stejným způsobem je možné připojovat dokumenty k procesům nebo operacím ve formuláři činnosti strom hlavního procesu a objektům, které mají zobrazený připojený dokument (obrázek) na volné kartě prostřednictvím atributu volné karty typu „multimediální“. Po přetažení souboru do IS BM se pak systém chová standardně jako při klasickém vytváření dokumentu BM.

Vlastní dokument může být uložen zakódovaný v databázi IS BM nebo externě kdekoliv v počítačové síti. Společně s autorizovanými údaji o založení dokumentu jsou evidovány i údaje o jeho užívání (čtení/zápis) jednotlivými uživateli.

V menu Volby činnosti prezentují seznam dokumentů je k dispozici funkce prezentace dokumentu umožňující aktivovat okno a v něm prezentovat propojené nebo vložené objekty vytvořené v některé z aplikací sady Office nebo v jakémkoli jiném programu, který podporuje propojování a vkládání objektů, s daným artiklem. Propojení či vložení objektu se realizuje funkcí vložit objekt nebo vložit jinak v menu Úpravy při aktivním okně prezentace dokumentu. Při aktivaci funkce ponechat v menu Volby, nebude okno s prezentací dokumentu automaticky uzavřeno při ukončení činnosti s přehledem dokumentů.

U každého dokumentu je v případě nastavení dostupná činnost, která umožňuje sledování jednotlivých verzí (tj. kopií obsahu daného dokumentu zaznamenanou v čase). U každé verze se eviduje datum, čas jejího vzniku a uživatel, který ji založil. Nepotřebné verze je možné na záložce „verze dokumentu“ rušit. Verze je možné sledovat pouze pro dokumenty uložené v databázi, tzn. u dokumentů, které mají zatržen příznak „externí uložení“ verze sledovat nelze.

1.4.3.1 Spouštěné aplikace

Spouštěné aplikace jsou uživatelsky definované programy s řadou vlastností, které definují způsob spuštění dokumentu, způsob předávání dat a další parametry.

Záložka „akce“ poskytuje uživateli možnost nadefinovat si jednotlivé akce, které se mají provést nad dokumentem (příkladem využití může být např. nadefinovaná akce RELDP, kterou pak pro odeslání příslušného dokumentu využívá mzdový systém).

U každé akce se definuje interní identifikace a název akce a zároveň se automaticky předplňuje identifikace a název spouštěného programu (tj. aplikace). Na záložce akce je k dispozici řada vlastností, které definují chování akce (např. stavový řádek, charakter, kód akce, kód podmínky akce a info o otevření, která určuje chování BM po otevření dokumentu). Dalším údajem jsou informace o identifikaci kategorie doplňující vlastnosti formuláře (nebo knihovny vkládaného kódu) a o identifikaci druhu doplňující vlastnosti formuláře (ke druhu se vážou přístupová práva).

1.4.4 Agregované informace (manažerské řízení)

Pro získání informací z elementárních dat disponuje IS BM řadou funkcí. V operativní části IS jsou to především výstupy, volné karty s hodnotou atributů definovanou pohledem, ale také zobrazení sumarizovaných hodnot událostí stiskem CTRL S. V analytické části IS jsou to statistické hodnoty dle selektorů a výkazy.

1.4.4.1 Statistické hodnoty

Statistickou hodnotou se v IS BM rozumí čtveřice (počáteční stav, příjem, výdej, konečný stav) agregovaných údajů dle druhu hodnoty, data a tří selektorů (obchodní, organizační a technicko – věcný). Druhy hodnot i selektorů jsou uživatelsky definovatelné.

Statistická hodnota se automaticky aktualizuje dle hodnot atributů události jejím zápisem do IS v rámci operace na základě jednoduchého algoritmu aktualizace uvedeného v definici druhu hodnoty pro daný druh operace, pokud je druh hodnoty definován jako statistický. Součástí definice algoritmu aktualizace druhu hodnoty je rozhodnutí, zda se statistická hodnota agreguje v rámci dne či měsíce.

V činnosti s přehledem statistických hodnot jsou společně k dispozici hodnoty, které byly vypočteny dle událostí různých komponent. Tyto hodnoty jsou mimo jiné významným elementem zdrojové datové základny pro sestavení výkazu.

Po případné změně definice druhu hodnoty je k dispozici funkce pro přepočtení statistických, ale i aktuálních a saldokontních hodnot včetně obratů.

1.4.4.2 Selektory

Selektor je uživatelem definovaný identifikátor skupiny logických věcí (objektů reálného světa), pro které chce mít v IS možnost sledovat je a vyhodnocovat je jako celek. To je mu následně umožněno uvedením selektorů v událostech odpovídajících komponent a v následně odvozených statistických hodnotách.

IS BM disponuje třemi skupinami (tj. tři úhly sledování a vyhodnocování) selektorů: Obchodní selektor, organizační selektor a technicko – věcný selektor. Dále umožňuje definovat u jednotlivých logických věcí (Aktér, Alokace, Artikl) jejich vztah k selektoru, takže obvykle lze přiřadit Aktéry k obchodnímu selektoru, Alokace k organizačnímu selektoru a Artikly k technicko – věcnému selektoru. Na základě těchto vztahů IS BM všechny tři selektory v rámci automatizace vstupu dat událostí předplňuje. U organizačního selektoru se navíc eviduje umístění (lze definovat přístupová práva), tzn. že pokud je událost uvedena s organizačním selektorem, na jehož umístění nemá uživatel právo čtení nebo zápis, není mu událost zobrazena.

K agregaci hodnot dle selektorů uvedených v události dochází při aktualizaci statistických hodnot. V událostech účetnictví mohou selektory naplňovat i obratové hodnoty. Dle selektorů lze vybírat statistické hodnoty, události různých komponent, záznamy tabulek typu AAA i definovat obsah či uspořádání výkazů.

Selektory jsou z hlediska objektových vazeb objektem.

1.4.4.3 Výkazy

Výkazy je nazývána ta část IS BM, která zpřístupňuje uživateli informační schopnost IS BM formou, ve které je vlastní výstup prezentován pomocí sešitu tabulkového procesoru MS Excel, tj. výkazem. Jako zdrojová datová základna pro sestavení výkazu a naplnění jeho obsahu informacemi jsou disponibilní veškerá (ze všech tabulek) data IS BM v aktuálním stavu.

Tuto část IS lze rozdělit na dvě poloviny. První je „sestavení výkazu“ ve které je umožněno uživateli vypočítat obsah výkazu z aktuálních dat IS na základě definic výkazu, které tvoří druhou. Logika a význam obsahu informací ve výkazu i jejich uspořádání v rámci sešitu Excel jsou dány jen a pouze uživatelským nastavením v definici výkazu.

Definice výkazů jsou členěny dle druhu výkazu, který se v případě existence výkazu daného druhu stává skupinovou položkou menu (INFORMAČNÍ CENTRUM - VÝKAZY – VÝKAZY KE SPUŠTĚNÍ – <DRUH VÝKAZU>), kde jsou definice výkazů dostupné pro sestavení výkazu s aktuálními daty těm uživatelům, kteří mají přístupové právo (čtení nebo zápis) k danému druhu výkazu.

Identifikátory tabulek IS BM, které patří do této části IS, začínají písmeny VK.

1.4.4.3.1 Sestavení výkazu

Sestavením výkazu se rozumí automatický výpočet výsledných informací a jejich následná prezentace pomocí MS Excel dle definice výkazu ze zdrojových dat (tabulek IS BM), který je iniciován uživatelem spuštěním odpovídající činnosti v hlavním menu INFORMAČNÍ CENTRUM – VÝKAZY – VÝKAZY KE SPUŠTĚNÍ nebo přímo ze seznamu definic výkazu.

Po volbě definice výkazu, tj. po spuštění položky menu, je uživatel v dialogovém okně vyzván k zadání zpřesňujících volitelných požadavků na prezentované informace - proměnných dotazu výkazu (např.: období, selektory apod.), jejichž hodnoty se použijí jako aktuální hodnoty parametrů při vlastním sestavení výkazu.

Následně se spustí MS Excel s aplikací šablony na jednotlivé listy a dle nastavení u ní se existující list výstupního souboru v MS Excel buď zruší nebo se jím sestavovaný list předplní (vhodná varianta například v případě definice grafů ve výstupním souboru).

Poté je zahájeno plnění jednotlivých buněk výkazu dle nastavení v definici listu, což má uživatel možnost pozorovat. Současně je informován v samostatném okně o procentu, do jaké míry je již výkaz sestaven, s možností přerušení (ESC) výpočtu s jeho následným předčasným ukončením.

Po ukončení sestavení výkazu je komunikace a „propojení“ IS BM a MS Excel ukončena, tj. oba systémy se stanou nezávislými z hlediska dalších aktivit uživatele.

Po rozhodnutí uživatele ukončit práci s daným výkazem v MS Excel má možnost jej uložit buď s cílem dalšího budoucího zpracování do souboru pod nově zadaným jménem (nedojde k přepsání při opakovaném sestavení výkazu) nebo pod svým jménem, což může umožnit případné předplnění dat, formátů a grafů při opakovaném sestavení výkazu.

1.4.4.3.2 Definice výkazu

Definice výkazu je daná výčtem definic jednotlivých listů sešitu MS Excel s případným doplněním o inicializační parametry listu a parametry listu v daném výkazu a dále doplněním o nastavení možnosti zpřesnit požadavky uživatele na selekci a agregaci dat či uspořádání výsledků formou dotazu na konkrétní hodnoty proměnných dotazu výkazu, které jsou následně parametry listu, v okamžiku jeho sestavení.

Definice listu výkazu je souborem pravidel, která definují způsob naplnění výsledných informací z jednotlivých tabulek IS BM (způsob selekce a agregace elementárních dat) a která dále definují způsob uspořádání výsledných informací do řádků, sloupců a buněk listu sešitu MS Excel s cílem jejich prezentace uživateli. Jedna definice listu může být užita v několika definicích výkazu.

Uspořádání dat prezentovaných listem MS Excel ovlivňuje dále šablona listů výkazů, která je též součástí definice listu. Současně definuje počáteční řádek a sloupec, se kterými koresponduje definice prvního řádku a sloupce v definici listu, a dále údaj, zda se při sestavování výkazu má nejprve existující list výstupního souboru (sešitu MS Excel) zrušit.

Dodatečné deklarace umožňují ovlivnit sestavení výkazu příkazem LOCK zamknout zdrojová data (zabránit zápisu událostí) uvedených komponent po dobu sestavení výkazu (zajištění integrity zobrazených hodnot) a dále umožňují formulovat podmínky, při jejichž nesplnění uvedený sloupec definice listu nebude zařazen do listu sestaveného výkazu.

Základem definice listu je nastavení vlastností jednotlivých buněk buď explicitně nebo implicitně dle řádků a sloupců. Explicitní definice buňky umožňuje její pojmenování výrazem, nastavení hodnot parametrů, její formátování a definování jejího obsahu buď výpočtem pomocí výrazů v syntaxi FoxPro, které mohou využívat parametry i funkce výkazů, nebo vzorcem v syntaxi MS Excel v anglickém jazyce nebo vyplývá (implicitní definice) z definice sloupce či řádku.

V případě, že není buňka, resp. některá její vlastnost, explicitně definována, uplatní se definice implicitní (zděděná), tj. definice řádku, je-li v ní daná vlastnost definována, nebo sloupce, pokud je v ní daná vlastnost definována a není definována v definici řádku, nebo listu, pokud je v ní daná vlastnost definována a není definována v definici řádku ani sloupce.

Definice řádku prezentovaná identifikátorem řádku umožňuje definovat pořadí a název řádku, nastavení hodnot parametrů, formát a obsah jeho buněk, zda má být ve výkazu skrytý. Definice sloupce je analogická, pouze pro definici obsahu neumožňuje variantu prázdný (nemá význam). V definici parametrů řádku či sloupce je možné jako první uvést příkaz dyn, který umožní z jedné definice dynamicky vygenerovat při sestavení výkazu tolik řádků (sloupců), kolik se vrátí prvků v jeho seznamu.

Pro vytvoření výkazu, ve kterém mají být hodnoty zobrazovány zaokrouhlené na celá čísla, tisíce, milióny nebo miliardy je možné definovat proměnnou výkazu ZAOKROUHLI.

V IS BM jsou k dispozici dvě metody pro sestavení definice listu výkazu a to metoda přímá a metoda s použitím vzoru listů výkazu, který je též uživatelsky definovaný.

Přímá metoda může využívat v jednotlivých elementech (sloupec, řádek, buňka) definice listu přímo funkce výkazu k referenci do (vytěžení informací ze) zdrojových tabulek IS BM. Pro zajištění korespondence mezi definicí listu a budoucím listem MS Excel je ve fázi sestavení k dispozici navigační „List“, který zahrnuje uspořádání všech definovaných buněk.

Metoda s použitím vzoru listu výkazu využívá k referenci do zdrojových tabulek funkce výkazu zprostředkovaně přes výrazy vzoru (ukazatele), které jsou pomocí nich uživatelsky definovány. Tato logická vrstva (ukazatele) umožňuje a usnadňuje laickou definici výkazu. Současně je při použití této metody předdefinována základní struktura výkazu. Z takto uskutečněné definice listu pomocí vzoru vygeneruje IS BM standardní definici listu, která je následně k dispozici pouze pro prohlížení.

1.4.4.3.3 Nástroje pro usnadnění definice listu

Parametry výkazů jsou uživatelsky definovatelné parametry, které se užívají v různých částech definice výkazu, resp. listu pro její usnadnění nebo s cílem zajištění určité variability obsahu výkazu dle požadavků uživatele při jeho sestavení. Hodnota parametrů je definována uživatelem nebo je vypočtena z dat IS BM pomocí funkcí výkazu.

Funkce výkazu jsou uživatelsky definovatelné funkce, které na základě hodnot parametrů, se kterými jsou volány v okamžiku sestavení výkazu, a na základě uživatelsky definovaného programového kódu vrátí hodnotu, kterou vypočtou obvykle ze zdrojových dat IS BM. Založení nové funkce výkazu uživatelem je autorizováno.

1.4.5 Jiné objekty informačního centra

1.4.5.1 AAA - Logické věci

1.4.5.1.1 Adresát

Adresátem je kdokoliv, s kým se v rámci činnosti uživatele systému vstoupí nebo je možno vstoupit v jednání. Jeho vlastnosti jsou uloženy v několika tabulkách informačního centra. Adresát je aktérem v událostech většiny komponent, které relevantní tabulky sdílí.

Mezi vlastnosti adresáta patří:

¨ identifikační číslo z číselné řady dle datového úložiště,

¨ IČ a DIČ, název a úplný název (memo),

¨ druh adresáta (prostřednictvím druhu se definují přístupová práva k základním informacím o adresátovi, jeho adresám a adresním spojením typu zápis, čtení nebo žádné. Nastavené právo neomezuje možnost zadání adresáta v událostech komponent),

¨ obchodní selektor,

¨ údaje o zápisu do obchodního rejstříku,

¨ komentář (memo) a implicitní obchodní selektor,

¨ implicitní měna pro obchodní transakce, zda je plátcem DPH, konstantní symbol, …

¨ zda je aktuální,

¨ adresy, kontaktní spojení, bankovní spojení,

¨ kategorie, do kterých může být zařazen na určité období, a dle kterých je lze vybírat a označovat pro dávková zpracování (tisk štítků, vstup pomocí šablonou, …),

¨ obecné předkontace a cenové skupiny, do kterých je zařazen.

Činnost prezentující seznam adresátů kromě základního okna zobrazuje na záložkách adresy, spojení adresáta, bankovní spojení, kategorie, další informace a údaje obchodního rejstříku. V menu Volby jsou k dispozici funkce pro:

¨ aktivaci činností prezentujících obecné předkontace a cenové skupiny adresáta,

¨ aktivaci činností prezentujících adresy, spojení, bankovní spojení a kategorie adresáta,

¨ označování dle kategorií,

¨ odeslání hromadného e-mailu vybraným adresátům,

¨ označení sebe,

¨ změnu implicitního spojení (při aktivní relevantní záložce),

¨ změnu implicitního bankovního spojení (při aktivní relevantní záložce).

Události komponenty POS, komponenty VYV a spojení adresáta jsou dostupné z ikon v dolní části okna. V okamžiku vstupu adresáta se současně vstupuje adresa a implicitní spojení.

V souvislosti s adresářem disponuje IS BM těmito činnostmi (položky hlavního menu):

¨ Kategorie adresátů, která prezentuje seznam kategorií, do kterých mohou být adresáti po určité období zařazeni, a jejich vlastnosti;

¨ Kategorie spojení adresátů, která prezentuje seznam kategorií, do kterých mohou být spojení adresátů po určité období zařazeni;

¨ Informace k adresátům:

¨ Spojení adresátů, která prezentuje seznam spojení adresátů dle výběru,

¨ Adresy adresátů, která prezentuje seznam adres adresátů dle výběru, mezi významné atributy adresy patří: město s PSČ dle číselníku měst, stát dle číselníku států, ulice s popisným číslem, byt a typ místa, který se uplatní v automatizaci vstupu událostí OBC, a komentář,

¨ Kategorie adresátů, která prezentuje seznam zařazení adresátů do kategorií dle výběru,

¨ Bankovní spojení adresátů, která prezentuje seznam bankovních spojení adresátů dle výběru,

¨ Číselníky a parametry:

¨ Města, která prezentuje seznam měst uživatelsky evidovaných v IS BM; mezi vlastnosti každého města patří: město, PSČ, národní směrové číslo státu (UTO) pro telefonní spojení, stát z číselníku států; klíčem je jednoznačná časová identifikace,

¨ Státy, která prezentuje seznam států uživatelsky evidovaných v IS BM; mezi vlastnosti každého státu patří: identifikace a název, oficiální název, název v cizí řeči a v angličtině, směrové číslo státu pro telefonní spojení,

¨ Oslovení, která prezentuje seznam oslovení uživatelsky evidovaných v IS BM,

¨ Parametry adresáře, ve které lze nastavit implicitní adresát (fakticky označení sebe) a stát (předplňuje se při vstupu adresáta), způsob validace na duplicitu adresátů při jejich vstupu a zda se má PSČ zobrazovat v české konvenci,

¨ Číselná řada adresátů, ve které se definuje interval uživatelských čísel adresátů automaticky IS BM jim přidělovaným dle jednotlivých datových úložišť; intervaly dle DÚ jsou disjunktní,

¨ Typy subjektů spojení, která prezentuje seznam typů subjektů spojení adresátů; ke každému lze na záložce Druhy parametrů přiřadit druhy parametrů s pořadím, ve kterém se prezentují k danému spojení, a s možností nastavení inicializace (budou se pak prezentovat i s prázdnou hodnotou),

¨ Druhy parametrů spojení, která prezentuje seznam druhů parametrů spojení adresáta.

Kategorie adresátů

Každý adresát může být zařazen do několika kategorií na uvedené období, což lze významně uplatnit ve výběrech a obecných výběrech řady činností, importech dat, pro označení adresátů v činnosti s jejich přehledem a v řadě dalších implementačních situací.

V činnosti prezentující seznam kategorií je na záložce seznam adresátů do kategorie zařazených včetně zobrazení implicitního spojení. Na druhé záložce lze definovat barvu, v jaké se budou zobrazovat adresáti v činnosti s jejich seznamem, pokud jsou platně zařazeni do dané kategorie k systémovému datu. Barvu lze nastavit různě pro každou skupinu uživatelů. Z labelu Kategorie lze aktivovat činnost prezentující seznam adresátů s předplněným výběrem danou kategorií, shodný význam má ikona v dolní části okna či funkce v menu Volby, kde je též k dispozici funkce pro aktivaci činnosti prezentující seznam zařazení adresátů do kategorií s předplněnou kategorií. Na labelu Adresát i v menu Volby lze aktivovat činnosti pro prezentaci údajů souvisejících s adresátem.

Aktivace funkce Označování podle kategorií v menu Volby činnosti s přehledem adresátů spustí průvodce označováním, který uživatele vede těmito kroky:

¨ krok: Výběr kategorií pro označování (rušení označování) adresátů, kde se volí požadované kategorie uspořádané do logického výrazu operátory AND a OR,

¨ krok: Období příslušnosti do kategorie, kde se udává období, ve kterém jsou zařazeni do zadaných kategorií, případně s podmínkou nepřerušení v zadaném období,

¨ krok: Označovat nebo rušit označení, kde se volí zda označovat s případným zrušením dřívějších označení adresátů či rušit označení (ne)vyhovujícím adresátům,

¨ krok: Zahájit označování (rušení označování) adresátů, s volbou (ne)ukončení průvodce.

S označenými adresáty (nejen dle kategorií) lze dávkově pracovat v řadě činností IS BM, např. výstupy, šablony apod.

Aktivace funkce Definování typu kategorie adresáta v menu Volby činnosti s přehledem kategorií adresátů umožňuje definici zobrazování adresátů v mřížce adresáře v různých barvách v závislosti na jejich zařazení do kategorií. Uživatel musí stanovit příslušnost adresáta k jedné nebo více kategoriím. Kategorie může být typu Vstupovaná nebo Vypočítaná. Vlastní definice barev se provede v činnosti Palety barev kategorií adresátů. Pro každou paletu barev se definují v ní obsažené kategorie. Na výběrové záložce formuláře Adresář je k dispozici atribut Paleta, podle níž jsou adresáti v mřížce vybarvováni barvou kategorií, které má paleta u sebe uvedeny.

Bankovní spojení adresátů

Každý adresát může mít evidováno několik bankovních spojení adresáta, která definují jeho bankovní účty, případně pokladny (zejména vlastní). Identifikátorem spojení je adresát a pořadové číslo bankovního spojení, které IS BM automatizovaně předplňuje. Atribut „aktuální“ nabývající hodnoty Ano/Ne umožňuje pohodlně sledovat stav bankovních účtů. Účty označené jako neaktuální jsou zobrazeny na šedivém podkladu.

Bankovní spojení daného adresáta jsou dostupná (základní atributy) na relevantní záložce činnosti prezentující seznam adresátů. V činnosti hlavního menu bankovní spojení adresátů jsou dostupná bankovní spojení všech adresátů, tato činnost s předplněným výběrem za daného adresáta patří mezi činnosti prezentující relevantní data adresáta aktivací z labelu adresát.

Pomocí atributu druh adresáta lze k bankovním spojením adresáta nadefinovat přístupová práva (čtení, žádné).

Mezi významné atributy bankovního spojení dále patří:

¨ typ bankovního spojení, tj. Účet nebo Pokladna,

¨ kód banky z číselníku bank,

¨ adresát včetně adresy reprezentující banku z číselníku bank (pouze se prezentuje),

¨ pobočka, tj. název pobočky banky, kde je veden účet,

¨ prefix a číslo bankovního účtu (je validováno dle nastavení u banky),

¨ specifický symbol,

¨ měna účtu, v případě pokladny nemá význam,

¨ název účtu.

Implicitní bankovní spojení adresáta se využívá v automatizaci vstupu událostí komponent.

Spojení adresátů

Každý adresát může mít evidováno několik spojení adresáta, která obsahují kontaktní a případně další uživatelsky definované údaje, přičemž jedno ze spojení je určeno jako implicitní. Identifikátorem spojení je adresát a pořadové číslo spojení, které IS BM automatizovaně předplňuje. IS BM obsahuje možnost předplňování rozdílného čísla spojení adresáta v událostech operací různých komponent.

Spojení daného adresáta jsou dostupná (základní atributy) na relevantní záložce činnosti prezentující seznam adresátů. V činnosti hlavního menu spojení adresátů jsou dostupná spojení všech adresátů, tato činnost s předplněným výběrem za daného adresáta patří mezi činnosti prezentující relevantní data adresáta aktivací z labelu adresát.

Mezi významné programátorsky definované atributy spojení dále patří:

¨ subjekt, tj. identifikátor typu spojení, se kterým je spojena uživatelská definice parametrů spojení daného typu,

¨ adresát, který umožňuje v rámci spojení daného adresáta odkázat na dalšího adresáta v IS již evidovaného,

a dále atributy, na které lze uživatelsky mapovat elementární prvky struktury druhu parametru: jméno a jméno určené pro tisk na štítek, funkce, oslovení z číselníku oslovení, adresa ze seznamu adres daného adresáta, telefon, mobil, fax, e-mail, jiné. Jednotlivá spojení adresátů je možno zařadit do kategorií.

Na záložce Parametry činnosti s prezentací seznamu spojení jsou k dispozici hodnoty parametrů spojení (fakticky uživatelsky definované atributy) v čase (datum od do), přičemž ty neplatné se zobrazují na šedém pozadí. V případě, že je pro daný druh parametru v rámci subjektu spojení definováno inicializovat, je zde uveden i s prázdnou hodnotou. Parametr je jednoznačně identifikován adresátem, spojením adresáta, druhem parametru a uživatelsky přiděleným pořadím (IS BM je předplňuje).

Parametry a jejich hodnoty, jejichž druh parametru (elementární prvek jeho struktury) je mapován na programátorsky definované atributy spojení adresáta, se zde pouze prezentují. Modifikují se přímo na první záložce, přičemž zde je automaticky původní hodnotě ukončena platnost (datum do naplněn aktuálním datem) a založena nová platná hodnota parametru. Atributy tisku jsou platné parametry a v případě událostí platné k datu události.

Druh parametru spojení adresáta

Druh parametru spojení adresáta uživatelsky definuje parametr (fakticky atribut), který může být součástí struktury atributů spojení adresáta, a který uživatel naplní hodnotou. Mezi atributy druhu parametru patří:

¨ identifikátor a název,

¨ formát, jak se hodnota parametru bude prezentovat v gridu, v syntaxi FoxPro s možností uvést atributy parametrů uvozené a ukončení znaky ##,

¨ zda je unikátní pro adresáta, s čímž souvisí validace,

¨ zda je unikátní pro spojení adresáta, s čímž souvisí validace,

¨ a na záložce Definice struktury maximálně sedm různých (různý atribut hodnota) elementárních prvků struktury druhu parametru:

¨ hodnota (textová 1, textová 2, numerická 1, numerická 2, datumová 1, datumová 2, adresa), kde adresa definuje strukturu parametru dle atributů v tabulce adres adresáta,

¨ odpovídá, možnost mapovat uživatelský druh parametru na SW atribut spojení adresáta, pak bude aktualizován automaticky změnou atributu spojení s automatickou evidencí historie změn,

¨ návěští, kterým bude uvozen v přehledu parametrů (záložka činnosti spojení adresáta),

¨ stavový řádek (status bar), tj. text zobrazovaný v dolní části okna, pokud kurzor myši je umístěn na poli daného atributu,

¨ validace logickým výrazem v syntaxi FoxPro s použitím atributů aktuálně otevřeného datového modelu,

¨ délka,

¨ desetiny numerického atributu.

1.4.5.1.2 Artikl, druh artiklu, SKP

Artikl je ta logická věc, která je obvykle předmětem dané události, tj. uskutečnění události mění jeho kvalitu nebo kvantitu. IS BM umožňuje artikly dle druhu artiklu členit do skupin. Součástí IC je také číselník SKP, ze kterého jsou v některých komponentách přiřazovány artiklu třídy SKP.

Součástí definice druhu je krom identifikace a názvu možnost nastavení implicitních vlastností pro relevantní artikly v jednotlivých komponentách (zejména OBC, SKL), například: vztah k účetnictví, vztah ceny k DPH, charakter (skladovaný/neskladovaný), typ zdanitelného plnění, zda evidovat historii ceny. Atribut „algoritmus předplnění a validace identifikace nového artiklu“ v definici druhu umožňuje rovněž stanovit pro druh artiklu algoritmus, podle kterého je předplněna identifikace při vstupu nového artiklu daného druhu a zároveň je validován vstup nového artiklu. Nastavení barvy písma a barvy pozadí umožňuje barevně rozlišit artikly jednotlivých druhů.

Na záložce Výskyt artiklu v činnosti prezentující seznam druhů artiklu lze pro daný artikl zatržením definovat, do kterých komponent se má „replikovat“ v okamžiku zařazení, kde může nabývat dalších pro danou komponentu specifických vlastností. Hodnoty atributů artiklu v jednotlivých komponentách specifikované v bw.ini se při „replikaci“ automaticky uplatní (tj. artikly jsou zapsány v jednotlivých komponentách s těmito hodnotami).

V informačním centru IS BM je artikl identifikován druhem artiklu a identifikátorem a má tyto vlastnosti platné i v komponentách:

¨ název

¨ příznak, zda evidovat historii ceny, který se uplatní v automatizaci vstupu událostí OBC,

¨ názvy v aplikovaných jazycích definované na první záložce,

¨ vztah měrných jednotek definovaný na druhé záložce vyjadřuje přepočet množství z jedné do druhé MJ, vztahů může být definováno několik.

V činnosti prezentující seznam artiklů lze v menu Volby aktivovat funkci:

¨ prezentace artiklu umožňující aktivovat okno a v něm prezentovat propojené nebo vložené objekty vytvořené v některé z aplikací sady Office, nebo v jakémkoli jiném programu, který podporuje propojování a vkládání objektů, s daným artiklem; propojení či vložení objektu se realizuje funkcí vložit objekt nebo vložit jinak v menu Úpravy při aktivním okně prezentace artiklu; při aktivaci funkce ponechat v menu Volby, nebude okno s prezentací artiklu automaticky uzavřeno při ukončení činnosti s přehledem artiklů,

¨ dokumenty artiklu, prezentující seznam dokumentů objektově spojených s artiklem včetně prezentace dokumentu,

¨ ceník artiklu v různých měnách, cenových skupinách a obdobích (viz kapitola oceňování),

¨ pro získání informací z různých komponent souvisejících s daným artiklem; tu lze získat i na labelu Artikl.

Artikl IC není objektem. Další vlastnosti artiklu jsou specifické dle komponent včetně možnosti rozšíření identifikace.

1.4.5.2 Oceňování

1.4.5.2.1 Banky, měny a kurzy

IS BM disponuje tabulkou, ve které záznamy korespondují s jednotlivými bankami. Mezi její významné atributy patří kód banky, SWIFT a parametr, zda a jak číslo účtu v dané bance kontrolovat na modulo 11 a případná vazba na adresáta. Kód banky se uvádí v jednotlivých bankovních spojeních adresátů jako součást identifikace bankovního účtu. Bankovní spojení adresátů je atributem událostí některých komponent, například platby, ZSP, …

IS BM disponuje v informačním centru tabulkou, ve které záznamy korespondují s jednotlivými měnami. Mezi její významné atributy patří kód a název měny, znak, zaokrouhlování (uplatňuje se při automatizaci vstupu do událostí, např. plateb) a nejmenší jednotka měny. Na záložce je dle banky a data evidován kurz (střed, nákup a prodej) a množství oceňovací jednotky v kurzu vůči referenční měně. Záložka „další měny“ umožňuje vedení dalších měn účtu, přičemž na první záložce se eviduje základní (tj. referenční) měna účtu. Referenční měna (RM) je ta, ve které jsou vedeny veškeré evidence, některé komponenty evidují finance současně i v jiné měně, tj. v zahraniční měně (ZM), případně v měně účtu (MÚ). Měny a kurzy se uplatní při automatizaci vstupu událostí těch komponent, kde se evidují finance v ZM i RM.

Parametry oceňování definují:

¨ referenční měnu,

¨ implicitní banku,

¨ centrální banku,

¨ předplňovat kurz pouze je-li aktuální; tj. zda v rámci automatizace vstupu dat události komponenty předplnit kurz automaticky (na základě měny a data v ní) dle jeho relevantní hodnoty střed v IC vždy nebo jen za určitých podmínek,

¨ zatržení způsobí, že se předplní pouze tehdy, pokud se datum události shoduje s datem uvedeným v kurzu dané měny v informačním centru,

¨ nezatržení způsobí, že se předplní vždy, resp. pokud v IC existuje a to ten s nejbližším nižším datem od data události,

¨ pro dnešní datum pracovat s včerejším kurzem do ... h – zatržení respektuje ustanovení, že do uvedené hodiny a minuty lze vyhodnocovat částky v zahraničních měnách kurzem předchozího dne. Při vstupu událostí s aktuálním datem a zároveň s aktuálním časem počítače menším než uvedený čas v parametru systém tedy pak v událostech předplňuje kurz kurzem předchozího dne (v pondělí je to pátečním kurzem).

¨ automatická aktualizace kurzu; tj. zda kurz uživatelem uvedený v události (tj. pro danou měnu k datu události) se automaticky zapíše i do kurzu v informačním centru (s datem a měnou události a kódem centrální banky) v okamžiku prvního zápisu události (případně při změně data či měny v ní), pokud tento kurz již v IC neexistuje; zatržení způsobí aktualizaci. V případě, že je zatržen příznak „ pro dnešní datum do 15.hodin pracovat s včerejším kurzem“ a vstupují se události s aktuálním datem a zároveň s aktuálním časem počítače menším než 15h, je podle tohoto pravidla aktualizován kurz dané měny uložený v IS BM.

Algoritmus automatické aktualizace kurzu i automatizace předplnění kurzu v událostech daného druhu operace je dále ovlivněn případným nastavením kurzu prvého dne pro daný druh operace. V případě nastavení kurzu prvého dne bude v událostech dané operace předplňován pouze kurz z IC evidovaný k prvému dni měsíce události, resp. k prvému dni prvního nižšího měsíce od měsíce události. Podobně bude na základě uživatelem uvedeného kurzu v události aktualizován kurz v IC k prvému dni měsíce události.

V případě, že ze zákona dojde ke změně referenční měny (např. přechod na euro), je toto řešeno pomocí činnosti Tabulka přechodu na měny (menu Volby).

1.4.5.2.2 Ceník

Ceník je činnost IS BM prezentující seznam záznamů z relevantní tabulky. Záznam v ceníku definuje cenu daného artiklu v dané cenové skupině a cenovém období za uvedenou měrnou jednotku v dané měně. Cena se zde může definovat těmito atributy:

¨ cena artiklu,

¨ cena ostatních nákladů,

¨ cena celkem jako součet předchozích,

¨ sleva vyjádřená procentem.

Uvedené atributy jsou specificky využívány v automatizaci vstupu dat do událostí jednotlivých komponent využívajících ceník.

Ceník je plněn vstupem dat na základě rozhodnutí uživatele nebo nástroji pro automatizaci tohoto vstupu dat, tj. přepočtem cen dané cenové skupiny či období nebo z událostí komponenty OBC s nastaveným atributem „aktualizovat ceník“ aktuálního cenového období dle relevantních atributů události OBC.

V případě, že je u artiklu nastaven atribut „Historie ceny“, je při každé změně (F4) některého atributu ceny v ceníku zaevidován původní stav s datem změny a ten je uživateli dostupný na záložce.

1.4.5.2.3 Cenová skupina

Cenová skupina je činnost IS BM prezentující seznam záznamů z relevantní tabulky. Je určena na podporu správy ceníků a pro automatizaci v oblasti předplnění cen artiklů či souvisejících výpočtů.

Kromě identifikace a názvu obsahuje atributy typ a zda se jedná o implicitní cenovou skupinu (implicitní cenová skupina typu prodejní a nákupní se uplatní v automatizaci vstupu událostí OBC).

Na záložce Cenová období se prezentují a definují cenová období s počátečním a koncovým datem jeho platnosti. Při definování cenových období je zároveň kontrolována jeho platnost, tzn. že nemůže vzniknout překryv cenových skupin.

Na záložce AAA v cenové skupině – obchod lze definovat, že daná cenová skupina se bude automaticky uplatňovat v událostech OBC jako implicitní pro zde uvedené adresáty a jejich spojení na artikly se zde uvedenou maskou pro jejich technicko věcný selektor, pokud v ceníku existuje cena v dané cenové skupině. Atributy obchodní smlouva a výběr dle obchodní smlouvy zajistí, že relevantní cena se v události OBC automaticky předplní jen, je-li v ní uvedena. Atribut umístění zajistí, že relevantní cena se v události OBC automaticky předplní jen, je-li v ní uvedeno. Zde uvedená sleva se předplní v události OBC při aplikaci dané cenové skupiny, pokud v ceníku uvedená sleva nabývá hodnoty nula. V případě, že adresát je v několika cenových skupinách, pak se do události OBC předplní ta cenová skupina, u které je zde uvedena priorita s nižším číslem.

Činnost cenové skupiny umožňuje automatizovaně aktualizovat ceník pomocí funkce Přepočet cen artiklu v menu Volby. Aktualizace spočívá v automatizovaném vygenerování nových záznamů ceníku nebo aktualizaci již existujících pro danou cenovou skupinu a cenové období pro maskou (wilcards) zadané artikly z již existujících relevantních záznamů v ceníku. Automatizace je dána definicí vzorce sestaveného z odkazů na cenové skupiny a z aritmetických operací pro každý numerický atribut ceníku.

V předloze výstupu je k dispozici pohyb v cenových obdobích a v AAA.

1.4.5.3 Obecné předkontace, volné texty a konstanty

Obecné předkontace jsou uživatelsky definovaná data v činnosti IS Bílý Motýl dostupné ve skupinové položce hlavního menu informační centrum, která jsou uspořádána do tabulky s dvěma klíči, tj.: identifikace obecné předkontace, význam hodnoty a vlastní hodnota. U každé obecné předkontace se uvádí druh obecné předkontace, který určuje přístupová práva uživatelů.

Jako vlastnost obecné předkontace je dále možnost stanovit, že jedním klíčem (význam) je identifikace adresáta. V tomto případě je obecná předkontace dostupná i z adresáře.

Mezi oblasti možného využití obecné předkontace patří například maska operace, šablony, výrazy pravidel transformací a dále ty funkce IS BM, ve kterých je alespoň částečná možnost uživatelsky aplikovat příkaz SELECT.

Výsledkem (vyhodnocením obecné předkontace) je hodnota přiřazená k jejímu významu. Syntaxe použití má obvykle tvar: „#P <výraz1>;<výraz2>“, kde výraz 1 (identifikace obecné předkontace) a výraz 2 (význam), jsou v daném okamžiku vyhodnotitelné textové výrazy ve formátu FoxPro.

Volné texty jsou uživatelsky definovatelné texty typu memo, které mají svůj identifikátor, název a možnost znění v cizích jazycích. Jsou užívány v různých komponentách, např. událost PLA, nebo ve funkcích IS BM, ve kterých je umožněno alespoň částečně uživatelsky aplikovat příkaz SELECT.

Konstanty jsou uživatelsky definovatelné konstanty (hodnoty atributu) typu charakter, které mají svůj identifikátor (identifikátor musí být uveden velkými písmeny), název a vlastní hodnotu, která může být různá dle jednotlivých datových úložišť. Jsou užívány ve funkcích IS BM, ve kterých je umožněno alespoň částečně uživatelsky aplikovat příkaz SELECT.

1.5 Specifikace komponent IS BM

Informační systém Bílý Motýl® disponuje níže uvedenými komponentami standardizované struktury. Každá komponenta je do určité míry předurčena na informační podporu určitých aktivit (funkční oblasti) uživatele (o tom kterých se fakticky rozhoduje při sestavení plánu implementace) a již i její samostatný provoz spolu s informačním centrem IS BM poskytuje smysluplnou informační schopnost.

Seznam aktuálně poskytnutých uvedený v licenční smlouvě je součástí vymezení rozsahu licence.

ID | Název komponenty
DPH | Daň z přidané hodnoty
EXP | Expedice
HPP | Hodnoty předmětu projektu
HPS | Položky smluv
HPU | Plnění smlouvy
HPX | Plnění projektového úkolu
HPZ | Projektové úkoly
MZD | Události mezd
MZV | Vstupní údaje ze systému
OBC | Obchod
ODP | Odpisovaný majetek
OKO | Obecná komponenta
PLA | Platby
POS | Poštovní zásilka
PZM | Události o nemovitostech
PZP | Zprávy
REZ | Rezervace
SKL | Skladová evidence
SKZ | Sklad zvířat
SMU | Spravovaný majetek
UCE | Událost účetnictví
VR1 | Výroba – výrobní zakázka
VR3 | Výroba - vstupy a výstupy
VR4 | Výroba – výrobní úkoly
VYM | Vymáhání pohledávek
VYV | Obecná událost
ZAL | Zálohy
ZSP | Změna stavu peněz

1.5.1 Vlastnosti standardizované komponenty

Plnohodnotná standardizovaná komponenta disponuje tabulkami s AAA a jejich vztahy, tj. hodnoty a události, které nesou nejvýznamnější část informační schopnosti pro uživatele. Skutečná komponenta obsahuje smysluplnou podmnožinu uvedených základních tabulek včetně činností (funkcí) pro prezentaci a pro aktualizaci dat v nich, dále obsahuje řadu tabulek pro danou komponentu specifických k zajištění její funkčnosti.

Pro každou komponentu lze dále v informačním centru definovat její druhy operací, druhy hodnot, šablony vstupu a výrazy použitelné v transformacích ve vazbách z dané komponenty. Z hlediska objektových vazeb jsou AAA a události obvykle objekty s jednoznačnou časovou identifikací.

AAA představuje zkratku pro základní entity (tabulky) standardizovaných komponent (Aktér, Artikl, Alokace), které modelují logické věci sledované části reálného světa.

Vystupují jako cizí klíč v událostech komponent a dle uživatelských nastavení pro daný druh operace jsou k nim vztaženy hodnoty daného druhu. Logické věci mohou obsahovat selektor, který se následně využije při automatizaci vstupu událostí, tj. předplní se.

1.5.1.1 Aktér

Aktérem je ta logická věc, která je obvykle „hybnou silou“ dané události. V IS BM je aktér obvykle reprezentován adresátem z IC, který je dostupný téměř ve všech komponentách, tj. jedná se o jednu tabulku informačního centra jimi sdílenou.

Adresát je v událostech různých komponent doprovázen i dalšími zpřesňujícími údaji, např. v komponentě pošta či obchod identifikátorem spojení, v komponentě platby identifikátorem bankovního spojení apod.

Je-li v některých obrazovkách uveden label „Adresát“ tučně, pak na něm lze vyvolat menu, ze kterého lze spustit činnosti pro zobrazení údajů, které s daným adresátem souvisí (relevantní údaje).

V událostech jsou k dispozici volné karty jejich adresáta.

1.5.1.2 Alokace

Alokace je ta logická věc, která reprezentuje umístění (prostor), ve kterém obvykle daná událost nastala, resp. který se dané události významně týkal. V IS BM je alokace obvykle reprezentována šestimístným identifikátorem, který je unikátní v rámci každé komponenty, tj. každá komponenta má svou tabulku se svými alokacemi, případnou závislost lze řešit v implementaci pomocí uživatelských triggerů.

Alokace je v událostech některých komponent doprovázena i dalšími zpřesňujícími údaji, např. v komponentě sklad identifikátorem skladové buňky.

Mezi obvyklé vlastnosti alokace kromě vlastností společných pro AAA (hodnoty, události, VK, objekty…) též patří:

¨ identifikátor a název,

¨ implicitní organizační selektor,

¨ možnost definovat přístupová práva, která se následně týkají i událostí na dané alokaci,

¨ adresát, na jehož adrese je alokace umístěna (jen ve vybraných komponentách).

Další vlastnosti alokace jsou specifické dle komponent.

1.5.1.3 Artikl

Artikl komponenty odvozený z artiklu IC je ta logická věc, která je obvykle předmětem dané události, tj. uskutečnění události mění jeho kvalitu nebo kvantitu.

V některých komponentách je artikl evidován „výskytově“ (tj. individuálně každý „kousek“, např. SMU), kde je pak významnou vlastností stav artiklu. V jiných komponentách pouze „druhově“ (tj. v celkovém množství, např. OBC), kde je pak významnou vlastností množství artiklu.

Artikl je v událostech různých komponent doprovázen i dalšími zpřesňujícími údaji včetně rozšíření identifikátoru, např. v komponentě SMU pořadím shodného artiklu apod.

Je-li na některých obrazovkách činností uveden label „Artikl“ tučně, pak na něm lze vyvolat menu, ze kterého lze spustit činnosti pro zobrazení údajů, které s daným artiklem souvisí.

Mezi vlastnosti artiklu specifické dle komponent může patřit:

¨ případné rozšíření uživatelské identifikace oproti IC,

¨ implicitní technicko věcný selektor,

¨ implicitní měrná jednotka,

¨ čárový kód, externí id (jen ve vybraných komponentách).

Další vlastnosti jsou specifické dle komponent.

1.5.1.4 Hodnoty

Součástí každé plnohodnotné standardizované komponenty je tabulka, která obsahuje numerickou hodnotu určitého druhu týkající se daného aktéra, alokace a artiklu. Tyto hodnoty jsou automaticky aktualizovány v okamžiku aktualizace dat události komponenty. Kromě tabulky aktuálních hodnot vyjadřujících okamžitou hodnotu je ve vybraných komponentách k dispozici i tabulka s hodnotou obratu, tj. hodnotou vztaženou k datu (denně či měsíčně).

Druhy těchto hodnot (informační centrum) jsou uživatelsky definovatelné, přičemž součástí jejich definice je i algoritmus aktualizace hodnot. V rámci definice druhu hodnoty je možné nastavit i aktualizaci tabulky se statistickými a tabulky se saldokontními hodnotami, které jsou komponentami sdíleny v informačním centru. Definice umožňuje pro každý druh hodnoty nastavit:

¨ identifikátor a název druhu hodnoty,

¨ vstupní hodnota, tj. atribut události, jehož hodnota je zdrojem pro aktualizaci hodnoty daného druhu,

¨ které tabulky s hodnotami se mají aktualizovat (aktuální, obratová, saldokontní, statistická),

¨ druh saldokontní hodnoty (pouze pokud je nastavena aktualizace relevantní tabulky),

¨ míru rozlišení hodnoty dle AAA, tj. zda za aktéra, alokaci či artikl agregovat (nerozlišovat); pokud se nerozlišuje jsou hodnoty zapsány s identifikátorem “-“,

¨ podmínka vyjádřená hodnotou určitého atributu události (pak bude hodnota aktualizována pouze těmi událostmi, ve kterých je podmínka splněna, tj. shoduje se hodnota atributu), uplatněno pouze u vybraných komponent,

¨ seznam druhů operací, jejichž události budou aktualizovat daný druh hodnoty, se způsobem aktualizace (sčítání, odečítání či dle atributu příjem/výdej) a možností omezení na umístění druhu operace do určitého druhu procesu.

Přehled aktuálních (obratových) hodnot je obvykle dostupný v komponentě jako samostatná činnost s respektováním přístupových práv k alokaci. Po případné změně definice druhu hodnoty je k dispozici funkce pro přepočtení statistických, ale i aktuálních a saldokontních hodnot včetně obratů dle zvolených komponent s případnou rezervací zdrojů (tj. do tabulek událostí přepočítávaných komponent nelze zapisovat).

1.5.1.5 Událost

Událost v IS BM reprezentuje (modeluje) změnu stavu věcí v reálném světě. Změnou lze rozumět zejména změnu množství, hodnoty či kvality. Mezi její obvyklé vlastnosti do určité míry uplatněné v každé komponentě patří:

¨ časový okamžik (obvykle datum), kdy tato změna nastala,

¨ výčet logických věcí (aktér, artikl, alokace), jejichž vlastností se tato změna dotýká,

¨ míra (numerické hodnoty, např. částka, množství, …) nebo kvalita (zařazen, vyřazen,..) změny,

¨ selektory,

¨ druh, pořadí v procesu a komponenta operace, v rámci které událost nastala (je evidována),

¨ číselná identifikace procesu, v rámci kterého událost nastala (je evidována),

¨ atributy autorizace (uživatel, datum a čas zápisu),

¨ jiné zpřesňující údaje včetně popisu obvykle různé dle komponent.

Přesný význam uvedených vlastností (resp. atributů) je různý dle komponent a dle implementačního záměru.

Události, které jsou si věcně i časově blízké, mohou být v IS BM seskupovány do operací a dle definic druhů hodnot souvisejících s druhem operace aktualizují hodnoty (aktuální, obraty, statistické, saldokontní). Události mohou vstupovat do objektových vazeb.

Obrazovka činnosti s přehledem seznamu událostí má v horní polovině jejich seznam a v dolní atributy události s kurzorem, na záložkách jsou obvykle další relevantní informace. Na labelu adresáta a artiklu lze aktivovat menu s relevantními údaji. Tato činnost má dvě varianty, první obvykle aktivovaná z hlavního menu umožňuje prezentaci všech událostí, druhá aktivovaná spuštěním operace prezentuje události jedné operace s možností aktualizace dat událostí v neukončených operacích. Související funkce mohou být různé v každé variantě.

Vstup událostí je řešen v rámci procesů vstupem (naplněním) operací včetně užití nástrojů pro automatizaci vstupu. Datum je validován intervalem uvedeným v činnosti Otevřená období komponent. Pro vstup událostí s datem mimo interval 1.1.1980 až 1.1.2100 je nutno definovat otevřené období komponent. Kontrolní atributy umožňují nastavit chování událostí operací komponent při stornu a při rušení stavu ukončena.

Atributy prezentované překryvným seznamem se předplňují hodnotou 1. Přístup k událostem je obvykle řízen dle práv uživatele k druhům operací a k alokacím.

Kalkulátor aktivovaný z přehledu událostí má k dispozici (tlačítko Menu) hodnoty numerických atributů události. Z menu na horní liště činností spravujících data události je oproti většině ostatních činností dále možné z menu Volby:

¨ spustit operaci, do které událost patří,

¨ tisknout doklad,

¨ vstup šablonou (pouze pokud se jedná o zobrazení událostí v rámci neukončené operace),

¨ označit záznamy,

¨ zobrazit sumu,

¨ aktivní míra plnění (v okamžiku předplnění událostí transformací),

¨ zobrazit dávkové operace události,

¨ zobrazit strom i diagram procesu, do kterého událost patří,

¨ zobrazit vlastnosti operace,

a z menu Obecné:

¨ odeslat zprávu (pouze pokud se jedná o zobrazení události v rámci operace),

¨ ukončit operaci (pouze pokud se jedná o zobrazení událostí v rámci neukončené operace),

¨ zdroje operace (pouze pokud se jedná o zobrazení události v rámci operace),

¨ následující připravené operace,

¨ saldokonto procesu,

¨ masky operace (pouze pokud se jedná o zobrazení událostí v rámci neukončené operace),

¨ import/export dat (pouze pokud se jedná o zobrazení událostí v rámci neukončené operace),

¨ činnosti hlavního menu, tj. možnost zde aktivovat ty položky hlavního menu, které mají definovánu aktivaci funkčním klíčem,

¨ Volné karty objektu (tj. události), procesu, operace, adresáta a artiklu,

¨ referenční procesy (pouze pokud se jedná o zobrazení události v rámci operace).

Další funkce jsou specifické dle komponent.

1.5.2 Komponenta DPH

Užití této komponenty se předpokládá v souvislosti s vystavováním daňových dokladů a s přípravou daňového přiznání k dani z přidané hodnoty. Obvyklé je využití ve spojení s komponentou OBC, jejíž událost referuje tabulku typů zdanitelného plnění. Ta spolu s tabulkou pro definice a přehled daňových přiznání patří mezi významné tabulky této komponenty.

1.5.2.1 DPH - Definiční data komponenty

1.5.2.1.1 Standardní definice

Pro aktualizaci hodnot komponenty je možné využít tyto atributy její události:

¨ 1,

¨ Základ DPH v ZM,

¨ DPH v ZM,

¨ Základ DPH v RM,

¨ DPH v RM,

¨ DPH v RM (zaokr.).

bez aplikace podmínky. Komponenta má definováno zrcadlové storno, šablony komponenty nedisponují speciálními vyprogramovanými vstupy šablony. Události lze aplikovat pouze v rámci operace.

1.5.2.1.2 Typ zdanitelného plnění

Nastavení atributů tohoto typu se uplatní při automatizaci vstupu dat událostí OBC a DPH programovým kódem a při sestavení definice daňového přiznání (výkazů této komponenty, například Přiznání k dani z přidané hodnoty za …). Každý typ je definován jednoznačným identifikátorem, názvem a dále obsahuje:

¨ Kategorii plnění pro tuzemsko, např.: Nepodléhá dani, Snížená, …,

¨ Kategorii plnění pro vývoz (zahraničí), např.: Vývoz zboží, Vývoz služeb, Mezinárodní přeprava, …,

¨ Účel daně, např.: Vrácení, …,

¨ Pro každý typ zdanitelného plnění je možné dále definovat sazby v závislosti na typu místa (tuzemsko, zahraničí, …) a počátku období platnosti:

¨ procento sazby DPH na vstupu (odpočet) a relevantní číslo účtu z účetnictví (je dostupné jako výstupní atribut komponenty v transformaci),

¨ procento sazby DPH na výstupu (nápočet) a relevantní číslo účtu z účetnictví (je dostupné jako výstupní atribut komponenty v transformaci),

¨ řád zaokrouhlení a od které cifry nahoru (uplatní se při zaokrouhlení částky DPH).

Na záložce „uplatnění předmětů“ jsou k dispozici varianty zdanitelného plnění konkrétní sazby. Ke každému uplatnění se zadává kdy a za jakých podmínek se toto uplatnění bude realizovat. U každého uplatnění se navíc eviduje jeho platnost od - do a ty uplatnění, která jsou již mimo dobu platnosti, se uživateli zobrazují šedivě. Při vstupu událostí obchodu se pak na základě kombinace: typ, místo plnění a plátce či neplátce předplní odpovídající uplatnění předmětů. Na záložce „substituce TZP“ se ke každému typu zdanitelného plnění definuje pravidlo, které umožní uplatnit zde uvedenou sazbu než je sazba definovaná na obchodovatelném artiklu.

Definice typů zdanitelného plnění lze tisknout s případným pohybem v sazbách.

1.5.2.1.3 Daňová přiznání

Definice daňového přiznání, kterých může být v IS několik, se skládá z identifikace, názvu a kategorie (běžná, opravné hlášení, ostatní) událostí, které se v něm uplatní. Na záložce se dále definuje obsah (název řádku, paragraf, označení řádku, základ, daň na vstupu a výstupu) a pořadí jednotlivých řádků přiznání odkazem a výběrem odpovídajících událostí DPH nebo výrazem z proměnných a již vypočtených řádků (k dispozici jsou i řádky pomocné, které se netisknou).

Proměnné se definují v menu Volby, kde se též aktivuje činnost pro výpočet přiznání za zvolené období a činnost pro zpřístupnění vypočtených přiznání. Pokud nejsou proměnné pro vypočítávané období definovány, dochází automaticky ke kopírování proměnných daňového přiznání s hodnotami podle předchozího období.

Definice daňového přiznání lze exportovat pomocí balíčku. K dispozici je i možnost odeslat vypočtené daňové přiznání elektronickou cestou a jeho zpracování přímo na daňovém portálu České daňové správy. Uživatel má všechny informace o elektronickém podání daňového přiznání k dispozici na http://adisepo.mfcr.cz/.

1.5.2.2 DPH - Logické věci komponenty

Jako aktér je aplikován adresát z informačního centra společně se spojením adresáta. Atribut adresy adresáta typ místa ovlivňuje automatizaci vstupu událostí OBC a DPH, podobně příznak plátce DPH události OBC.

Jako alokace je aplikováno umístění DPH, jehož atributem je adresát a jeho spojení, dále organizační selektor.

Artikl v této komponentě není aplikován a ve statistických hodnotách je rozlišováno dle TV selektoru.

1.5.2.3 DPH - Událost

Události je možné členit dle potřeb zejména dle druhu operace, dle atributu „Odpočet/ Nápočet“ a dle atributu „Běžná, opravné hlášení, ....“. Dále mezi nejvýznamnější atributy patří údaje o základu daně a výši daně v RM i ZM. Programový kód zajišťuje tato předplnění atributů:

¨ datum aktuálním datem,

¨ spojení adresáta jeho implicitním spojením,

¨ typ místa dle relevantního atributu adresáta,

¨ kurz dle pravidel oceňování,

¨ procentní sazba daně dle typu místa, odpočet/nápočet a data z relevantního atributu uvedeného typu zdanitelného plnění,

¨ DPH v ZM dle základu v ZM a procentní sazby DPH (zaokrouhleně na 2 desetinná místa v případě, že ZM není shodná s RM),

¨ základ v RM dle základu v ZM a kurzu,

¨ DPH v RM dle základu v RM a procentní sazby DPH,

¨ DPH v RM (zaokr.) dle DPH v RM a v případě zatržení zaokrouhlovat zaokrouhleně dle atributů u daného typu zdanitelného plnění a daného typu místa zdanitelného plnění pro dané období,

¨ technicko věcný selektor selektorem uvedeným u relevantního typu a místa zdanitelného plnění.

Na záložce jsou k dispozici relevantní (dle míry plnění) události účetnictví. Události DPH jsou zdrojovými daty pro sestavení přiznání k dani z přidané hodnoty.

1.5.2.4 DPH - Jiné

Výpočet daňového přiznání se aktivuje z následně pro výpočet uplatněné definice přiznání a shodně je tomu s funkcí pro prezentaci daňového přiznání za zvolený rok a měsíc či kvartál. Činnost s přehledem řádků daňového přiznání vypočtených dle relevantní definice zobrazuje všechny řádky, které nejsou definovány jako pomocné, vybraného přiznání. Uživatelsky definovaná předloha výstupu umožňuje výstup daňového přiznání v podobě odpovídající oficiálnímu formuláři.

Ve výstupních atributech komponenty jsou kromě údajů události zejména atributy typu zdanitelného plnění.

1.5.3 Komponenta MZD (na výstupu)

Komponenta MZD zajišťuje souhru s dalšími komponentami na výstupu mzdové agendy. Jedná se zejména o souhru s komponentou plateb a s komponentou účetnictví. Mzdový systém může využívat akce dokumentů, např. pro odeslání RELDP.

1.5.3.1 MZD – Definiční data komponenty

1.5.3.1.1 Standardní definice

Pro aktualizaci hodnot komponenty je možné využít tyto atributy její události:

¨ 1,

¨ Částka

s aplikací podmínky pomocí atributu Typ mzdové události. Datum zpracovaných mezd je relevantní datum pro aktualizaci statistických hodnot. Události lze aplikovat pouze v rámci operace.

Komponenta má umožněno zrcadlové storno, šablony komponenty disponují několika speciálními vyprogramovanými vstupy šablony pro souhrnný nebo podrobný výstup údajů ze mzdových lístků v závislosti na nastavení druhu události.

Jsou to tyto šablony:

Mzdy podrobně - UC i PL – MZ0048

Šablona zapisuje údaje vzniklé výpočtem výplatních lístků podrobně, tj. každého pracovníka zvlášť a každou mzdovou položku zvlášť. Zapisuje údaje potřebné do účetnictví (mají označení UC) i do plateb (mají označení PL).

Odvod sociálního pojištění organizace se zapisuje jednou částkou. Část UC vůbec nezapisuje selektory. Část PL kopíruje obchodní, organizační a technický selektor dle stavu na výplatních lístcích.

Mzdy - souhrn PL – MZ0082

Šablona zapisuje údaje vzniklé výpočtem výplatních lístků souhrnně, tj. za všechny pracovníky dohromady. Součtování mzdových položek se řídí identifikací druhu události, který je každé mzdové položce přiřazen v menu DEFINICE. Zapisuje POUZE údaje potřebné do plateb (mají označení PL).

Odvod sociálního pojištění organizace se zapisuje jednou částkou. Obchodní selektor, organizační selektor a TV selektor se vyplní hodnotou „-„. Šablona plní kolonku účet účetní osnovy údajem dle druhu události.

Mzdy - UC podrobně – MZ0084

Šablona zapisuje údaje vzniklé výpočtem výplatních lístků podrobně, tj. každého pracovníka zvlášť a každou mzdovou položku zvlášť. Zapisuje POUZE údaje potřebné do účetnictví (mají označení UC). Odvod sociálního pojištění organizace se zapisuje jednou částkou.

Šablona nezapisuje selektory.

Mzdy souhrn - UC – MZ0085

Šablona zapisuje údaje vzniklé výpočtem výplatních lístků souhrnně, tj. za všechny pracovníky dohromady. Součtování mzdových položek se řídí identifikací druhu události, který je každé mzdové položce přiřazen v menu DEFINICE. Zapisuje POUZE údaje potřebné do účetnictví (mají označení UC). Odvod sociálního pojištění organizace se zapisuje jednou částkou.

Obchodní selektor, organizační selektor a TV selektor se vyplní hodnotou „-„.

Mzdy podrobně – ST – MZ0087

Šablona zapisuje údaje vzniklé výpočtem výplatních lístků podrobně, tj. každého pracovníka zvlášť a každou mzdovou položku zvlášť. Zapisuje POUZE údaje potřebné do statistiky(mají označení ST). Šablona rozpočítává položky dle poměru trojice selektorů u příjmů daného pracovníka.

Šablona zapisuje všechny selektory. Slouží k zaznamenání statistických údajů. Aplikuje se na samostatnou operaci. Odvod sociálního pojištění organizace se zde rozpočítává na jednotlivé pracovníky dle poměru základů sociálního pojištění za pracovníka.

Mzdy – UC s org. selektorem – MZ0089

Šablona zapisuje údaje vzniklé výpočtem výplatních lístků podrobně, tj. každého pracovníka zvlášť a každou mzdovou položku zvlášť. Zapisuje POUZE údaje potřebné do účetnictví (mají označení UC). Odvod sociálního pojištění organizace se zapisuje jednou částkou.

Šablona zapisuje organizační selektor dle karty pracovníka. (Tím se liší od šablony MZ0084). Šablona nerozpočítává žádné údaje dle trojice selektorů.

Mzdy – UC podrobně + SP rozděleně – MZ0090

Mzdy - podrobně OST – MZ0096

Šablona zapisuje údaje vzniklé výpočtem výplatních lístků podrobně, tj. za každého pracovníka zvlášť a za každou mzdovou položku zvlášť. Zapisuje POUZE údaje ostatní (mají označení OST) a na Druzích událostí mají nastaveno Ostatní „Ano“. Šablona zapisuje pouze stranu Dal.

Šablona nezapisuje selektory. Pokud zapisuje mzdovou položku typu srážky, vezme adresáta z Karty pracovníka.

Mzdy – UC podrobně a částečně rozděleně – MZ0103

Šablona zapisuje údaje vzniklé výpočtem výplatních lístků podrobně, tj. každého pracovníka zvlášť a každou mzdovou položku zvlášť. Zapisuje POUZE údaje potřebné do účetnictví (mají označení UC). Šablona zapisuje stranu MD i Dal. Šablona zapisuje selektory.

Mzdové položky typu „příjmy a náhrady“ šablona zapisuje tak, jak je uvedeno na výplatním lístku i s příslušnými selektory.

Mzdové položky – hrubý příjem, odvod SP organizace, odvod ZP organizace – se rozpočítávají dle poměru trojice selektorů u příjmů daného pracovníka. Šablona zapisuje všechny selektory.

Mzdové položky ostatních typů šablona zapisuje tak, jak je uvedeno na výplatním lístku.

Tato šablona je tedy kombinací šablon MZ0087 a MZ0084.

1.5.3.1.2 Druhy událostí

Nastavení atributů tohoto typu se uplatní při automatizaci vstupu dat událostí MZD vyprogramovanými vstupy šablony.

Každý typ je definován jednoznačným identifikátorem, názvem a dále obsahuje:

¨ Příznaky typu mzdové události

¨ Atributy účet, strana a vlastnost

Definice druhů událostí lze tisknout s případným pohybem v účtu, straně a vlastnosti. Vlastnost je obsažena též na kartě pracovníka.

1.5.3.2 MZD – Logické věci komponenty

Jako aktér je implementován pracovník, který referuje organizační a může referovat technicko-věcný selektor. Bližší údaje o pracovníkovi zaznamenává Karta pracovníka, která je popsána v komponentě MZX.

Jako alokace je aplikováno umístění mezd.

Jako artikl je implementována mzdová položka, která může referovat technicko-věcný selektor.

1.5.3.3 MZD – Událost

Události lze dělit především dle druhu události (UC/ST/PL/OST) a dalších atributů.

Mezi nejvýznamnější atributy krom standardních patří datum zpracovaných mezd, identifikace mzdové položky, pracovník a jeho pracovní poměr, adresát a jeho spojení, adresa, účet, konstantní symbol a variabilní symbol, dále pak částka a poznámka. Vzhledem k velkým objemům dat se doporučuje využívat šablony pro vstup událostí komponenty.

1.5.4 Komponenta MZV (na vstupu)

Komponenta MZV se uplatňuje na vstupu mzdové agendy. Komponentu lze využít jako úkolové lístky, ke sledování docházky, atd.

Mezi významné tabulky komponenty MZV kromě standardizovaných patří Karta pracovníka (pracovník je zde z hlediska logické stavby IS BM aktérem) obsahující údaje logicky se vztahující ke konkrétním pracovníkům. Dále pak tabulky mzdových položek, které ovlivňují údaje v dalších atributech komponenty MZV.

1.5.4.1 MZV – Definiční data komponenty

1.5.4.1.1 Standardní definice

Pro aktualizaci hodnot komponenty je možné využít tyto atributy její události:

¨ 1

bez aplikace podmínky. Události lze aplikovat pouze v rámci operace.

Komponenta má umožněno zrcadlové storno, šablony komponenty nedisponují speciálním vyprogramovaným vstupem šablony.

1.5.4.2 MZV – Logické věci komponenty

Jako aktér je implementován pracovník, který svým pracovním poměrem referuje organizační a může referovat technicko-věcný selektor.

Jako alokace je aplikováno umístění mezd společné s komponentou MZD.

Jako artikl je implementován artikl mezd společný s komponentou MZD.

1.5.4.3 MZV – Událost (úkolové listy - vstup)

Mezi nejvýznamnější atributy kromě standardních patří identifikace adresáta, pro kterého pracovník pracuje, pracovník a jeho pracovní poměr, identifikace mzdové položky, atributy zachycující délku trvání práce (od, do, dnů, hodin, minut, výkon, délka přestávky, částka).

Události tohoto typu se po vstupu mohou stát součástí výpočtu mezd nebo mohou sloužit pro sledování docházky.

1.5.5 Komponenta MZX

Komponenta MZX je skrytou komponentou a popisuje celou řadu činností, se kterými mzdová agenda pracuje.

Mezi významné tabulky komponenty MZX kromě standardizovaných patří Karta pracovníka obsahující údaje logicky se vztahující ke konkrétním pracovníkům. Dále pak tabulky mzdových položek, které ovlivňují vlastní výpočet mzdy a tabulka výplatních lístků.

1.5.5.1 MZX - Definiční data komponenty

1.5.5.1.1 Standardní definice

Komponenta MZX nemá hodnoty komponenty. Nemá umožněno zrcadlové storno a nelze v ní používat šablony.

1.5.5.1.2 Inicializace

Inicializací je nastaven datum poslední uzávěrky mezd v okamžiku uvedení sytému do provozu.

1.5.5.2 Karta pracovníka

Karta pracovníka je jednou ze základních činností komponenty. Ovlivňuje též komponenty MZV a MZD. Obsahuje údaje o jednotlivých pracovnících a údaje vztahující se k jejich pracovním poměrům.

K jednotlivým pracovníkům jsou zde zaznamenány mimo jiné především tyto informace :

¨ některé osobní údaje – jméno a příjmení, rodné číslo, rodné jméno, …

¨ vazba na adresář

¨ příslušnost k výplatnímu místu

¨ příslušnost ke zdravotní pojišťovně

¨ vztah ke zdravotnímu pojištění, k daním, k ročnímu zúčtování

¨ uplatňované nezdanitelné položky (měsíční i roční)

¨ uplatňované pravidelné srážky

¨ uplatňované pravidelné půjčky

Ke každému pracovnímu poměru pracovníka jsou zde zaznamenány mimo jiné tyto informace:

¨ druh pracovního poměru, pracovní funkce, pracovní kalendář, tarifní stupnice a tarifní třída, zkušební lhůta

¨ organizační a technicko-věcný selektor

¨ účast pracovního poměru na nemocenském pojištění

¨ denní vyměřovací základ

¨ hodinový, denní a měsíční průměr

¨ trvání pracovního poměru, důvod ukončení

¨ stav dovolené – aktuální, k počátku roku, nárok

¨ pravidelné příjmy, které jsou vypláceny na pracovním poměru každý měsíc

¨ charakter pracovníka v pracovním poměru (má souvislost s druhy událostí a ovlivňuje komponentu MZD)

1.5.5.3 Definice položek mezd

Nastavením definic položek mezd se ovlivňuje běh výpočtu hrubých mezd. Zejména vztah právě definované položky mezd k sociálnímu a zdravotnímu pojištění, ke čtvrtletním průměrům, ke kalendáři a jeho fondu pracovní doby, k druhu události mezd … .

Na výplatním pásku pracovníka se položky tisknou v pořadí podle identifikace položky.

Kombinací atributů Původ Kč/j a Výpočet Kč se nastaví chování mzdové položky. Pro správnou funkci celé komponenty MZX je toto nastavení stěžejní.

1.5.5.3.1 Doplňující údaje k příjmům

Jedná se o nastavení doplňujících položek k příjmům, jako jsou např. prémie, osobní ohodnocení, dovolená apod. U každého doplňujícího údaje se zadávají tyto parametry:

¨ hodiny jsou součástí FPD

¨ Kč zahrnout do HP

¨ Kč zahrnout do průměru

¨ hodiny zahrnout do průměru

¨ dny zahrnout do průměru

¨ dny odečíst od vyměřovacího základu pro nemocenské pojištění

¨ hodiny započítávat pro nárok na pohyblivou měsíční složku

¨ základ sociálního pojištění

¨ základ pro zdravotní pojištění

¨ zdanitelný příjem

¨ dovolená

¨ celoroční charakter

¨ půlroční charakter

1.5.5.4 Parametry

Parametry obsahují základní nastavení konstant systému mzdové agendy.

Jsou to tyto údaje :

¨ poslední zpracované mzdy k datu

¨ datum uzamknutí výpočtu mezd (je-li vyplněno, pak k tomuto datu nelze provádět opravy a výpočet mezd pracovníků)

¨ sazba sociálního pojištění zaměstnance

¨ sazba sociálního pojištění organizace

¨ sazba zdravotního pojištění

¨ vyměřovací základ zdravotního pojištění

¨ minimální vyměřovací základ zdravotního pojištění

¨ limit srážkové daně

¨ sazba srážkové daně

¨ maximální denní vyměřovací základ - plná částka (platné pouze do 31.12.2003)

¨ maximální denní vyměřovací základ - 60 % částka (platné pouze do 31.12.2003)

¨ nemocenské za první tři dny (%)(platné pouze do 31.12.2003)

¨ nemocenské za den (%)(platné pouze do 31.12.2003)

¨ velká / malá organizace

¨ adresát, spojení, účet, adresa, KS a VS pro odvod zálohové daně

¨ adresát, spojení, účet, adresa, KS a VS pro odvod srážkové daně

¨ adresát, spojení, účet, adresa, KS a VS pro odvod sociálního pojištění

¨ nastavení termínu vyplácení mezd

¨ způsob práce s technicko-věcným selektorem

¨ výběr používaného pracovního kalendáře – do měsících nebo po dnech

¨ způsob výpočtu denního průměru

¨ způsob výpočtu sociálního pojištění za organizaci

¨ způsob výpočtu nepřítomnosti pro nemoc

1.5.5.5 Parametry nemocenských dávek

¨ Slouží ke vstupu parametrů potřebných pro výpočet dávek nemocenského pojištění. (platné pouze do 31.12.2003)

1.5.5.6 Parametry nemocenského pojištění

¨ Platné od 1.1.2004 s možností zpětného nastavení i pro předchozí roky.

¨ Soubor tří činností sloužících k nastavení parametrů potřebných pro výpočet dávek nemocenského pojištění.

1.5.5.7 Číselníky

Komponenty MZX obsahuje celou řadu číselníků a podpůrných tabulek.

Jsou to :

¨ Daňové tabulky

¨ Kalendář

¨ Pracovní funkce

¨ Výplatní místa

¨ Zdravotní pojišťovny

¨ Tarifní stupnice a třídy

¨ Druhy událostí

¨ Umístění mezd

1.5.5.8 Výčetka platidel

Systém výčetky platidel se využívá pro výplaty v hotovosti. Jeho součástí je číselník platných platidel - bankovek a mincí. Systém pracuje s výčetkou jednotlivců a s výčetkou souhrnnou.

1.5.5.9 Nepřítomnost pro nemoc

Činnost umožňuje prohlížení a údržbu seznamu nepřítomností pro nemoc. Evidují se zde nepřítomnosti pracovníků na pracovišti z důvodu nemoci, ošetřování člena rodiny, mateřské dovolené nebo jiných nepřítomností.

Na druhé záložce činnosti se uvádějí konkrétní nemocenské dávky, které se v případě velké organizace i vyplácejí a v případě malé organizace pouze evidují co do počtu pracovních dnů.

Výpočet bere v úvahu nastavení údajů v parametrech nemocenských dávek. Na první záložce můžeme nastavit krácení základu pro výpočet nemoci. Na druhé záložce činnosti můžeme nastavit krácení jednotlivých částí vypočtené dávky. K takto vypočtené dávce lze zobrazit i její podrobné složení.

Při uzávěrce mezd se aktualizuje atribut Kalendářních dnů pracovní neschopnosti a atribut Proplaceno dne.

1.5.5.10 Výplatní lístky a jejich výpočet

Výpočet výplatních lístků jednotlivých pracovníků je možné provést ve zpracovávaném měsíci opakovaně. Uplatňuje se zde kontrola na uzamčení mezd, které je nastavené v Parametrech. Je-li výpočet pro daný měsíc již uzavřen, pak je nutné uzamčení odblokovat. Vlastní výpočet toto uzamčení sám nastavuje pokaždé, když počítám výplatní lístky pro všechny pracovníky. Výpočet provádí též řadu kontrol, jejichž výsledky jsou generovány do Strukturovaného protokolu. Záznamy vzniklé výpočtem výplatních lístků jsou podkladem pro komponentu MZD.

Pokud má pracovník v organizaci současně několik pracovních poměrů, systém mu připraví za každý pracovní poměr výplatní lístek s položkami příjmů, sociálního a zdravotního pojištění, základu daně a nemocenských dávek. U vybraných položek typu odvod a dodatečný odvod se předplňuje adresát, bankovní účet, KS a VS.

Na výplatním lístku z pracovního poměru označeného jako určující systém navíc uplatní nezdanitelné položky, vypočítá daň za všechny příjmy, vypočítá čistý příjem, srážky a částku k výplatě.

Činnost pro každého pracovníka a jeho pracovní poměr postupně provede :

¨ přenos pravidelných příjmů z karty pracovníka

¨ kontrolu evidované doby

¨ výpočet hrubých příjmů

¨ výpočet sociálního pojištění hrazeného zaměstnancem

Je-li v parametrech mezd nastaven způsob výpočtu sociálního pojištění za organizaci „jednotlivě“, provede se výpočet sociálního pojištění hrazeného organizací (za jednoho zaměstnance), výpočet zdravotního pojištění hrazeného zaměstnancem a hrazeného organizací, přenos nemocenských dávek z nepřítomnosti pro nemoc

Dále pro každého pracovníka a jeho pracovní poměr s příznakem určující = Ano program provede :

¨ výpočet měsíční daně ze všech pracovních poměrů pracovníka

¨ výpočet čistého příjmu ze všech pracovních poměrů pracovníka

¨ výpočet srážek

¨ výpočet půjček

¨ výpočet k výplatě

Je-li v parametrech mezd nastaven způsob výpočtu sociálního pojištění za organizaci „souhrnně“, pak se po výpočtu příjmů posledního pracovníka provede výpočet základu a odvodu sociálního pojištění organizace v celkové částce za všechny pracovníky.

Přes menu Volby je možno spustit „optimalizovaný výpočet“.

1.5.5.11 Uzávěrka mezd

Uzávěrka mezd definitivně zablokuje údaje daného měsíce pro vkládání dalších údajů. Mzdy je tedy lépe uzavírat až po jejich vyplacení, nejlépe až před výpočtem mezd za následující období.

Některé akce provádí uzávěrka každý měsíc, některé pouze jestliže končí čtvrtletí.

Uzávěrka měsíčně provádí :

¨ odečtení zůstatku dovolené

¨ pro všechny nemocenské dávky, které měly nastaveno Proplatit = Ano se nastaví Proplaceno dne a Proplatit se nastaví na Ne

¨ snížení zůstatku půjčky o uhrazenou částku

¨ aktualizaci data posledního zpracování mezd

¨ zápis do Historie karty a do Historie pracovního poměru

¨ výpočet průměru na nemocenské dávky

Uzávěrka čtvrtletně provádí (pouze pro každého pracovníka a jeho pracovní poměr, který ke konci čtvrtletí trvá) :

¨ výpočet průměrného výdělku - hodinový, denní a měsíční průměr

1.5.5.12 Roční zúčtování daně

Činnost provede roční zúčtování daně z příjmu fyzických osob, tj. vypočte základ ročního zúčtování a Vyrovnání přeplatku na dani.

Údaje a nastavení k tomu potřebná jsou :

¨ Na kartě pracovníka – atribut podepsal prohlášení nastaven na Ano, atribut Provést roční zúčtování nastaven na Ano, nezdanitelné položky roční

¨ Na výplatním lístku – mzdové položky Loňský příjem (příjem od jiného zaměstnavatele za uplynulý rok), Loňský odvod (odvod zdravotního a sociálního pojištění, které pracovník odvedl u jiného zaměstnavatele za uplynulý rok).

¨ Roční daňová tabulka

1.5.5.13 MZX – Logické věci komponenty

Komponenta MZX není plnohodnotnou komponentou a proto u ní nehovoříme o aktéru, alokaci a artiklu.

1.5.5.14 MZX – Událost

Komponenta MZX není plnohodnotnou komponentou a proto u ní nehovoříme o událostech.

1.5.6 Komponenta OBC

Užití této komponenty se předpokládá v souvislosti s obchodními vztahy s adresáty týkajícími se plánovaného, předpokládaného či uskutečněného prodeje nebo nákupu určitého artiklu v daném množství za určitou cenu v daném termínu. Množství lze vyjádřit v libovolné měrné jednotce, cenu v libovolné měně a artikl identifikací čárového kódu.

Mezi významné tabulky komponenty kromě standardizovaných patří katalog zboží a vazba adresátů na cenové skupiny využívané pro automatizaci vstupu událostí této komponenty. Dále má tato komponenta významné vztahy s komponentou DPH na úrovni sdílení typů DPH a na úrovni struktury numerických atributů událostí a s ceníkem z informačního centra.

1.5.6.1 OBC - Definiční data komponenty

1.5.6.1.1 Standardní definice

Pro aktualizaci hodnot komponenty je možné využít tyto atributy její události:

¨ 1,

¨ Množství,

¨ Mn. ref.,

¨ Celkem bez daně artikl,

¨ Celkem bez daně ostatní,

¨ Základ DPH v ZM,

¨ DPH v ZM,

¨ Základ DPH v RM,

¨ DPH v RM,

¨ Spojená cena.

s aplikací podmínky pomocí atributu Vztah k účetnictví. Datum dodání je relevantní datum pro aktualizaci statistických hodnot.

Komponenta má definováno zrcadlové storno, šablony komponenty disponují několika speciálními vyprogramovanými vstupy šablony například pro aplikaci katalogu, vytvoření objednávky k dodavateli z požadavků, hromadný vstup artiklu apod. Události lze aplikovat pouze v rámci operace, jejíž druh může mít tyto parametry:

¨ změna stavu při vstupu následující (v procesu) události obchodu a nový stav,

¨ změna stavu při zrušení následující (v procesu) události obchodu a nový stav,

¨ zda ukončovat operaci předběžně,

¨ poznámka.

1.5.6.1.2 Ostatní

V činnosti Parametry se uživatelsky definuje typ zdanitelného plnění neplátce DPH, který se předplní při vstupu událostí s adresátem, který má nastaven atribut DPH na hodnotu Ne, a atribut události PO/VO/PDL/VDL nabývá hodnoty 2 nebo 3.

Pokud se dle událostí této komponenty odvozuje rok v identifikaci procesu, odvozuje se implicitně dle data události obchodu, což lze změnit nastavením v souboru BW.INI v sekci [Komponenta_OBC] 'datum2=1', aby se odvozoval z data dodání.

V činnosti Propojení operací skladu lze definovat druh hlavního procesu a v něm obsažený druh operace SKL a druh operace OBC. Ve fyzických procesech uvedeného druhu bude při přepočtu hodnot OBC do atributu události OBC „Spojená cena“ v operacích uvedeného druhu zapsána cena korespondující s cenou skladovou z operací SKL uvedeného druhu.

V činnosti Výrazy označování je umožněno definovat výrazy ve FoxPro nebo v SQL, jejichž logická hodnota se uplatní při jejich aplikaci v činnosti Označování-obchod pro označení událostí OBC.

Katalog zboží umožňuje uživateli uskupit v něm několik artiklů včetně informace o množství, alokaci obchodu, cenové skupině a pořadí. Definice této struktury artiklů lze využít v automatizaci vstupu událostí OBC pomocí šablony vstupu užívající vyprogramovaný vstup šablony „Výstup katalogu“.

Pro podporu zpracování celního sazebníku jsou k dispozici činnosti Celní sazebník a Sazby celního sazebníku. V činnosti Obchodovatelný artikl je možné zadávat u každého artiklu položku celního sazebníku a zároveň je možno podle této položky vybírat i na výběrové záložce.

1.5.6.2 OBC - Logické věci komponenty

Jako aktér je implementován adresát z IC společně se spojením adresáta, který je dále doprovázen druhým adresátem (např. ve významu příjemce).

Jako alokace je aplikováno umístění – distribuční kanál, které referuje:

¨ adresáta a jeho spojení,

¨ organizační selektor,

¨ případně i účetní selektor dostupný ve výstupních atributech komponenty.

Jako artikl je implementován obchodovatelný artikl, který je reprezentován druhem a identifikací artiklu. Obchodovatelný artikl nese kromě atributů artiklu v IC zejména: identifikaci čárovým kódem, třídu SKP, referenční měrnou jednotku, implicitní typ DPH, identifikaci a název položky celního sazebníku, TV selektor a účetní selektor dostupný ve výstupních atributech komponenty, informaci, zda v událostech týkajících se ho bude povolena nulová cena, a na první záložce několik volných údajů. Na záložkách jsou k dispozici relevantní údaje z ceníku včetně historie cen, názvy artiklu v cizích jazycích dle artiklu v IC, vztah měrných jednotek dle artiklu v IC a aktuální hodnoty.

Mezi funkce dostupné v menu Volby v činnosti prezentující seznam obchodovatelných artiklů patří:

¨ prezentace artiklu umožňující prezentovat propojené nebo vložené objekty vytvořené v některé z aplikací sady Office, nebo v jakémkoli jiném programu, který podporuje propojování a vkládání objektů, s daným artiklem,

¨ dokumenty artiklu umožňující zobrazit seznam dokumentů propojených objektovou vazbou s daným artiklem.

V tiskové předloze je k dispozici pohyb v aktuálních hodnotách, ceníku a historii ceny.

1.5.6.3 OBC – Událost

Události je možné členit na různé druhy pohledávek a závazků atributem události PO/VO/PDL/VDL nebo dle vztahu k účetnictví či dle stavu události. Mezi nejvýznamnější atributy krom standardních patří datum dodání, čárový kód a referenční i aplikovaná měrná jednotka artiklu, typ a související údaje zdanitelného plnění DPH dle komponenty DPH, měna a její kurz, identifikace a název klasifikace objektu, množství v referenční i aplikované měrné jednotce a cena za jednotku před a po uplatnění procentuální slevy v měně ceníku, základ a DPH v ZM i RM, spojenou cenu.

Programový kód zajišťuje tato předplnění atributů:

¨ datum aktuálním datem,

¨ datum dodání předchozím datem,

¨ spojení adresáta jeho aktuálním spojením,

¨ adresát (příjemce) předchozím adresátem a jeho aktuálním spojením,

¨ identifikace artiklu a jeho druhu artiklem dle čárového kódu,

¨ typ DPH dle artiklu, resp. dle parametrů OBC, pokud je adresát neplátce a atribut události PO/VO/PDL/VDL nabývá hodnoty 2 nebo 3,

¨ typ místa zdanitelného plnění dle typu místa v adrese adresáta referované jeho uvedeným spojením,

¨ aktuální měrná jednotka referenční MJ uvedenou u obchodovatelného artiklu,

¨ aktuální měna měnou uvedenou u adresáta,

¨ kurz dle pravidel pro oceňování,

¨ vztah k účetnictví dle relevantního atributu obchodovatelného údaje,

¨ množství v referenční MJ artiklu dle množství v aktuální MJ a vztahu MJ uvedeného na kartě artiklu, resp. hodnotou množství v aktuální MJ, pokud vztah neexistuje,

a ve vztahu k ceníku se předplňuje:

¨ cenová skupina implicitní cenovou skupinou pro nákup (atribut PO/VO/PDL/VDL nabývá hodnoty 2 nebo 3) či prodej (ostatní hodnoty atributu PO/VO/PDL/VDL) nebo dle specifik adresáta uvedených u cenových skupin na záložce AAA v cenové skupině (v bw.ini lze nastavit, že adresátem je míněn příjemce),

¨ měnu ceny za jednotku aktuální měnou události, pokud existuje v ceníku cena v dané měně pro předplněnou cenovou skupinu, v opačném případě měnou referenční,

¨ MJ ceny za jednotku aktuální MJ události, pokud existuje v ceníku cena v uvedené měně pro danou MJ, v opačném případě referenční MJ,

¨ cenu za jednotku dle ceníku (předplněná cenová skupina, platné cenové období ve vztahu k datu dodání, MJ a měna) celkem (artikl + ostatní náklady),

¨ sleva v procentech dle ceníku podobně jako cena za jednotku,

¨ cena za jednotku (artikl + ostatní náklady) po slevě vypočtená odečtením slevy z ceny za jednotku uvedená v měně ceny za jednotku,

¨ cena bez daně po slevě (v měně ceny za jednotku) za artikl vynásobením ceny za jednotku artiklu v ceníku s dopočtem slevy události a množství v MJ ceny za jednotku,

¨ cena bez daně po slevě (v měně ceny za jednotku) za ostatní náklady vynásobením ceny za jednotku ostatních nákladů v ceníku s dopočtem slevy události a množství v MJ ceny za jednotku; resp. částkou, o kterou uživatel snížil cenu bez daně po slevě za artikl předplněnou IS,

¨ spojená cena není předplňována při vstupu události OBC, ale může být plněna při přepočtu hodnot komponenty, je-li tak definováno v činnosti Propojení operací skladu,

¨ procentní sazba daně z přidané hodnoty dle typu místa, odpočet/nápočet (atribut PO/VO/PDL/VDL) a data z relevantního atributu uvedeného typu zdanitelného plnění v komponentě DPH,

a celkové sumární finanční údaje se předplňují při volbě cena bez DPH takto:

¨ základ DPH v ZM součtem ceny po slevě za artikl a ostatní náklady, pokud je cena za jednotku v ZM, v opačném případě z RM a kurzu,

¨ základ DPH v RM součtem ceny po slevě za artikl a ostatní náklady, pokud je cena za jednotku v RM, v opačném případě ze ZM a kurzu,

¨ DPH v ZM (RM) výpočtem ze základu DPH v ZM (RM) dle posledního (tj. platného) procenta daně pro daný typ a místo zdanitelného plnění DPH,

a při volbě cena včetně DPH takto:

¨ částka DPH v ZM výpočtem dle posledního (tj. platného) procenta daně pro daný typ a místo zdanitelného plnění DPH z ceny po slevě za artikl a ostatní náklady, pokud je cena za jednotku v ZM, v opačném případě z RM a kurzu,

¨ základ DPH v ZM dle uvedené částky DPH v ZM tak, aby součet základu a částky DPH se rovnal ceně za artikl a ostatní náklady, pokud je cena za jednotku v ZM, v opačném případě z RM a kurzu,

¨ částka DPH v RM výpočtem dle posledního (tj. platného) procenta daně pro daný typ a místo zdanitelného plnění DPH z ceny po slevě za artikl a ostatní náklady, pokud je cena za jednotku v RM, v opačném případě ze ZM a kurzu,

¨ základ DPH v RM dle uvedené částky DPH v RM tak, aby součet základu a částky DPH se rovnal ceně za artikl a ostatní náklady, pokud je cena za jednotku v RM, v opačném případě ze ZM a kurzu.

V případě zatržení atributu aktualizovat ceník je zápis události následován aktualizací (nový záznam nebo modifikace původního, pokud již existuje) relevantního (předplněná cenová skupina, datum dodání implikuje období, měna a MJ ceníkové ceny za jednotku) záznamu v ceníku.

Údaje události OBC jsou rozmístěny na dvou záložkách. Na další záložce jsou k dispozici relevantní (dle míry plnění) události účetnictví.

Pro každou událost operace obchodu se uchovává její pořadové číslo v operaci (lze ho opravovat). Po aktivaci zapsané operace obchodu jsou její události zobrazené podle tohoto pořadí (pokud není určeno jiné setřídění). Atribut pořadí události v operaci obchodu je možno použít také v předlohách výstupu

V menu Volby je kromě standardních dostupná funkce pro označení událostí OBC, která splňují zde uživatelem uvedená kritéria, která mohou využívat definic výrazů označování.

V případě aktivace činnosti s přehledem událostí neukončené operace je zde k dispozici dále funkce pro hromadnou změnu slevy a pro zrušení označených událostí v rámci událostí operace.

V předlohách výstupu není definován pohyb; je zde k dispozici řada atributů adresáta a obchodovatelného artiklu.

1.5.7 Komponenta ODP

Komponenta je určena na podporu správy a evidence odepisovaných aktiv, kterými se zde rozumí odepisovaný majetek dle účetních i daňových odpisů a dále neuhrazené pohledávky, na které bylo možné uplatnit odpis nebo opravné položky.

V IS jsou funkce této komponenty rozděleny do dvou částí dle druhu odepisovaných aktiv. První je reprezentovaná skupinovou položkou základního menu ODEPISOVANÝ MAJETEK a druhá skupinovou položkou základního menu ODPISY A OPRAV.POL. POHLEDÁVEK.

Mezi významné tabulky kromě standardních patří tabulka:

¨ koeficientů a její koeficienty obsahující procenta v závislosti na počtu měsíců pro výpočet (šablonou) výše odpisu či opravné položky k pohledávce uváděná na kartě pohledávky,

¨ odpisových skupin obsahující sazby a koeficienty pro výpočet (šablonou) výše daňového odpisu investičního majetku,

¨ realizovaných výkonů daným investičním majetkem (artiklem – strojem, …) pro výpočet (šablonou) účetního odpisu při odepisování dle výkonu,

¨ s prognózou odpisů, aktualizovaná po aktivaci relevantní činnosti.

S komponentou PLA sdílí tabulku s vazbou karty odepisované pohledávky a události PLA, na základě které byla založena.

1.5.7.1 ODP – Definiční data komponenty

1.5.7.1.1 Standardní definice

Pro aktualizaci hodnot komponenty je možné využít tyto atributy její události:

¨ 1,

¨ Částka,

¨ Finanční částka nesnížená.

bez aplikace podmínky. Události lze aplikovat pouze v rámci operace. Komponenta má definováno zrcadlové storno a šablony komponenty disponují speciálním vyprogramovaným vstupem šablony:

¨ účetní odpis,

¨ daňový odpis,

¨ daňový odpis pohledávek,

¨ import událostí odpisů.

1.5.7.1.2 Parametry

¨ Druh artiklu – bude předplňován při zakládání karty pohledávek.

¨ Odpis v měsíci zařazení – (ne)bude šablonou pro účetní odpis počítán i za měsíc zařazení.

¨ Odpis v měsíci vyřazení – (ne)bude šablonou pro účetní odpis počítán i za měsíc zařazení.

¨ Neomezovat datum události – v případě zatržení nebude při vstupu událostí prováděna kontrola data na měsíc a rok inicializace.

Dále jsou v parametrech prezentovány významné údaje komponenty (datum inicializace, rok daňového a účetního odepisování).

1.5.7.1.3 Tabulka odpisových skupin

V IS BM lze definovat odpisové skupiny a k nim sazby pro rovnoměrný, resp. koeficienty pro zrychlený, odpis v prvním roce, dalších letech a pro odpis ze zvýšené ceny. Tyto sazby v závislosti na způsobu odepisování, odpisové skupině a již uskutečněných odpisech daného odepisovaného majetku využije šablona pro automatizovaný výpočet událostí ODP s účetními či daňovými odpisy.

1.5.7.1.4 Tabulka koeficientů pro odpis a opravné položky pohledávek

V IS BM lze definovat několik tabulek koeficientů, které uživatel přiřazuje jednotlivým kartám pohledávek v okamžiku jejich založení s případnou jejich záměnou následně. Tabulka definuje vztah mezi počtem měsíců po splatnosti události PLA a procentem vyjadřující výši opravné položky. Dle počtu měsíců po splatnosti události PLA, ke které se pomocí šablony automatizovaně počítá výše opravné položky (odpisu), se zde použije uvedené procento.

1.5.7.2 ODP - Logické věci komponenty

Jako aktér je implementován adresát z IC. Alokace není aplikována.

Jako artikl je z hlediska odepisovaného majetku implementován odepisovaný majetek (karta), který referuje třídu SKP, organizační a technicko věcný selektor. Artikl lze členit dle druhu investičního majetku (např.: Hmotný investiční majetek, Nehmotný investiční majetek, …). Atribut účetní selektor je dostupný jako výstupní atribut komponenty. Atribut datum zařazení a vyřazení je aktualizován nejnižším datem z relevantních událostí druhu příjem, resp. výdej.

Na záložce účetní odpis lze definovat parametry pro výpočet účetního odpisu (automatizovaný výpočet výše odpisů při volbě metody dle času, výkonu nebo dle daňových odpisů je podporován pomocí relevantní šablony). Atribut účetní pořizovací a zůstatková cena je aktualizován dle finanční částek z relevantních událostí se zatrženou aktualizací dané částky.

Na záložce daňový odpis lze definovat parametry (odpisová skupina, procento snížení odpisu) pro výpočet daňového odpisu (automatizovaný výpočet výše odpisů na konci roku při volbě rovnoměrně či zrychleně je podporován pomocí relevantní šablony). Atributy vstupní a zůstatková cena, datum prvního a posledního technického zhodnocení jsou aktualizovány dle relevantních událostí. Počet uplatněných odpisů z nezvýšené i ze zvýšené ceny je aktualizován šablonou s vyprogramovaným vstupem Daňový odpis. Atribut odhad počtu odpisů je aktualizován aktivací funkce Odhad doby odpisování v menu Volby. Na této záložce je možné definovat, že daný artikl je součástí společně odepisovaného souboru.

Na další záložce lze definovat cizojazyčné názvy artiklu.

Mezi funkce dostupné v menu Volby v činnosti prezentující seznam artiklů patří funkce prezentace artiklu (dle artiklu v IC) a již uvedená funkce pro výpočet odhadu počtu odpisů. Na labelu Artikl jsou k dispozici relevantní údaje.

Jako artikl je z hlediska odpisů a opravných položek pohledávek aplikována karta pohledávky, kterou lze založit pouze v činnosti s přehledem událostí PLA v menu Volby funkcí Karty pohledávek, přičemž její identifikace je předplněna dle druhu artiklu uvedeného v parametrech komponenty ODP a dle VS uvedeného v dané události pohledávky; současně je aktualizována vazební tabulka s událostí PLA. Název artiklu je předplněn identifikací procesu události platby a datum aktuálním datem. Uživatelsky se definuje, zda se jedná o kartu s odpisem, pak se uvádí roční procento odpisu, či s opravnou položkou, pak se uvádí tabulka koeficientů, dle které bude relevantní šablona počítat výši opravné položky. Automaticky se doplní výše pohledávky dle atributu neuhrazeno v události PLA, která se následně aktualizuje (přepis) atributem výchozí cena z událostí ODP, které mají nastaven příznak Změna hodnoty pohledávky na Ano. Prezentované datum splatnosti je z relevantní události PLA.

Na první záložce Stav pohledávek se prezentují sumární údaje týkající se odpisů a opravných položek dané pohledávky, které se počítají z relevantních událostí ODP dle atributu finanční částka (procento a aktuální hodnota jsou dopočtené k počáteční hodnotě).

Na druhé záložce Změna pohledávky se prezentují události ODP týkající se dané karty pohledávky, jejichž operaci lze spustit z menu Volby; na šedém pozadí se prezentují ty, které mají nastaven atribut Změna hodnoty pohledávky na Ano.

Na třetí záložce Pohledávka se prezentují významné atributy z relevantní události PLA. Současně zde lze v menu Volby spustit operaci související s danou událostí PLA.

Mezi funkce dostupné v menu Volby v činnosti prezentující seznam artiklů (odepisovaných karet plateb) patří funkce prezentace artiklu (dle artiklu v IC) a funkce pro zrušení příznaku změna platby (tj. karta, na jejíž zdrojové události PLA došlo ke změně atributu dosud neuhrazeno, se bude po aplikaci této funkce chovat, jakoby ke změně atributu nedošlo). Na labelu Artikl jsou k dispozici relevantní údaje.

V případě, že se hodnota dosud neuhrazeno v události PLA nerovná hodnotě pohledávky na kartě, je zobrazována na šedém pozadí a je možné založit k dané události PLA novou kartu pohledávky. Shodně je tomu v případě nastavení atributu Změna hodnoty pohledávky na hodnotu Ano, pak se na šedém pozadí zobrazuje i tato událost.

Artikly komponenty ODP nejsou objektem z hlediska objektových vazeb.

1.5.7.3 ODP – Událost

Události lze dělit především na události týkající se investičního majetku nebo odepisovaných pohledávek (pohledávek s opravnou položkou), dle toho se též mění struktura vstupovaných atributů, dále dle druhu (Příjem, Výdej, Účetní odpis, Daňový odpis, Technické zhodnocení, Účetní odpis pohledávky, Daňový odpis pohledávky, …) a dalších atributů.

1.5.7.3.1 ODP – Událost (investiční majetek)

Mezi nejvýznamnější atributy kromě standardních patří charakter výdeje, částka a částka nesnížená (pouze, je-li druh události odpis) a definice, které ceny na kartě artiklu budou aktualizovány (upravuje cenu).

Programový kód zajišťuje tato předplnění atributů:

¨ datum aktuálním datem,

¨ finanční částku dle částky nesnížené snížením o procento uvedené v parametrech pro výpočet daňového odpisu na odpovídající kartě odepisovaného majetku, pokud se jedná o druh události účetní nebo daňový odpis.

¨ finanční částku dle účetní zůstatkovou cenou, pokud se jedná o druh události výdej.

Dle druhu události a zatržených atributů aktualizace jsou v okamžiku aktualizace události přepočteny ceny na kartě odepisovaného majetku (z událostí druhu Příjem nebo Technické zhodnocení přičtením a z ostatních odečtením) finanční částkou z událostí, resp. finanční částkou nesníženou v případě odpisů.

Mezi nástroje pro automatizaci vstupu událostí patří šablony, které využívají buď uživatelsky definovaný import dat nebo vyprogramovaný vstup:

¨ účetní odpis, který pro karty odepisovaného majetku s nastavením účetních odpisů „dle daňových“ předplní události ODP (druh Účetní odpis) s datem prvního měsíce, ve kterém nejsou události účetních odpisů zaznamenány; výše odpisu je vypočtena dle sazeb (resp. koeficientů) dané odpisové skupiny jako jedna dvanáctina předpokládaného ročního daňového odpisu (resp. ve výši skutečného v případě, že jsou události daňového odpisu již zapsány);

¨ daňový odpis, který dle atributů pro daňový odpis na kartě odepisovaného majetku předplní události ODP (druh Daňový odpis) s datem posledního dne prvního roku od roku inicializace, ve kterém dosud nejsou události daňového odpisu.

V činnosti s přehledem událostí ODP spuštěné operace je v menu Volby k dispozici funkce pro zrušení označených událostí.

1.5.7.3.2 ODP – Událost (odpis a opravné položky pohledávek)

Mezi nejvýznamnější atributy kromě standardních patří odepsat procento z ceny pohledávky, finanční částka a výchozí cena (základ výpočtu odpisu pohledávky) a atribut, zda dochází ke změně stavu pohledávky.

Programový kód zajišťuje předplnění data aktuálním datem. Mezi nástroje pro automatizaci vstupu událostí patří šablony, které využívají buď uživatelsky definovaný import dat nebo vyprogramovaný vstup daňový odpis pohledávek, který při:

¨ nezatrženém atributu Pouze rozpuštění odpisů a opravných položek k uvedenému datu vypočte pro aktuální karty pohledávek tabulky koeficientů (resp. procenta odpisu na kartě) z relevantních plateb nárok na daňový odpis, resp. opravnou položku, při respektování již zapsaných událostí ODP a předplní jimi nové události ODP (druh Daňová opravná položka); v případě, že je maximální procento sníženo ze 100 procent bude výše vytvářených opravných položek snížena na uvedené procento (daňové odpisy se vypočtou vždy v plné výši); v případě, že v okamžiku aktivace této šablony jsou v IS BM karty pohledávek splňující kritéria (nastala úhrada) pro rozpuštění odpisů či opravných položek, jsou současně šablonou generovány i události ODP reprezentující rozpuštění,

¨ zatrženém atributu Pouze rozpuštění odpisů a opravných položek k uvedenému datu vypočte pro aktuální karty pohledávek dle úhrad relevantních událostí PLA a vytvořených odpisů či opravných položek částky pro rozpuštění a jimi předplní generované události PLA s atributem Změna hodnoty pohledávky nastaveným na Ano a atributem Výchozí cena naplněným hodnotou atributu Dosud neuhrazeno z události PLA.

Dle druhu události a dle nastavení atributu Změna hodnoty pohledávky jsou v okamžiku aktualizace události přepočteny tyto atributy na kartě pohledávky:

¨ výše pohledávky je přepsána výchozí cenou relevantní události s nejvyšším datem a nastavenou změnou pohledávky,

¨ k daňovému stavu po snížení je přičtena hodnota finanční částka z událostí druhu Daňová opravná položka,

¨ k účetnímu stavu po snížení je přičtena hodnota finanční částka z událostí druhu Účetní opravná položka.

V činnosti prezentující seznam těchto událostí ODP se na šedém pozadí prezentují ty, které mají nastaven atribut Změna hodnoty pohledávky na Ano.

1.5.7.4 ODP – Jiné

Komponenta ODP disponuje činností určenou k prognózování výše odpisů do data uvedeného ve výběru.

Funkce inicializace spravovaného majetku dostupná v hlavním menu zaznamená datum inicializace, dle kterého je validováno datum v událostech (musí být vyšší).

1.5.8 Komponenta OKO

Užití této komponenty se předpokládá v souvislosti se specifickou problematikou daného uživatele, která není řešena ostatními komponentami, mnohdy jako dočasné řešení. Rozsah funkcí této komponenty poměrně koresponduje s vlastnostmi standardizované komponenty.

1.5.8.1 OKO - Definiční data komponenty

1.5.8.1.1 Standardní definice

Pro aktualizaci hodnot komponenty je možné využít tyto atributy její události:

¨ 1,

¨ Množství,

¨ Celková cena.

s aplikací podmínky pomocí atributu Vztah ke statistice. Komponenta má definováno zrcadlové storno, šablony komponenty disponují speciálním vyprogramovaným vstupem šablony s možností přenesení označených adresátů. Události lze aplikovat pouze v rámci operace, jejíž druh nemá parametry.

1.5.8.2 OKO - Logické věci komponenty

Jako aktér je implementován adresát z IC.

Jako alokace je aplikováno umístění obecné komponenty, které referuje organizační selektor a případně i účetní selektor dostupný ve výstupních atributech komponenty.

Jako artikl je implementován artikl obecné komponenty, který je reprezentován druhem a identifikací artiklu. Tento artikl nese kromě atributů artiklu v IC zejména: měrnou jednotku, cenu, TV selektor a účetní selektor dostupný ve výstupních atributech komponenty a na první záložce několik volných údajů. Na záložkách jsou k dispozici názvy artiklu v cizích jazycích dle artiklu v IC a aktuální hodnoty dle alokace a artiklu. Tento artikl není objektem.

Mezi funkce dostupné v menu Volby v činnosti prezentující seznam artiklů patří funkce artiklu v IC, tj. prezentace artiklu a dokumenty artiklu.

V tiskové předloze je k dispozici pohyb v aktuálních hodnotách a cizojazyčných názvech.

1.5.8.3 OKO – Událost

Události je možné členit zejména na příjmy a výdeje nebo dle vztahu ke statistice. Mezi nejvýznamnější atributy kromě standardních patří množství a cena. Programový kód zajišťuje předplnění data aktuálním datem.

Na záložce činnosti s přehledem událostí OKO jsou k dispozici relevantní informace týkající se saldokontních hodnot, do kterých daná událost přispěla.

V menu Obecné je k dispozici funkce Informace o aktualizaci, pomocí které lze zobrazit seznam (kdo a kdy) realizovaných modifikací atributů dané události.

V tiskové předloze je k dispozici pohyb v saldu.

1.5.9 Komponenta PLA

Užití této komponenty se předpokládá v souvislosti se správou a evidencí očekávaných i realizovaných plateb dle jednotlivých adresátů, měn a dalších klíčů.

Mezi významné tabulky komponenty kromě standardizovaných patří příkazy k úhradě a jejich položky. S dalšími komponentami (kromě tabulek IC) jsou sdíleny tyto tabulky:

¨ s komponentou ZSP vazba událostí (přehled spárování) – informuje o vztahu události PLA a ZSP (M:N), že daná událost platby je hrazená danou změnou (příjem/výdej) stavu peněz; na základě zápisu do této tabulky jsou aktualizovány atributy události platby související s úhradou,

¨ s komponentou ZSP tabulka vlastních účtů/pokladen a souvisejících definic komunikace s bankou,

¨ s komponentou VYM vazba událostí – informuje o vztahu události PLA a VYM (1:M), že daná událost platby je vymáhána danou událostí vymáhání pohledávek,

¨ s komponentou ODP vazba události na odpovídající kartu odepisovaného aktiva – informuje, že na danou platbu byl uplatněn odpis nebo opravná položka a pro účely této evidence založena zde uvedená karta odepisovaného majetku.

1.5.9.1 PLA - Definiční data komponenty

1.5.9.1.1 Standardní definice

Pro aktualizaci hodnot komponenty je možné využít tyto atributy její události:

¨ 1,

¨ částka v ZM,

¨ záloha v ZM,

¨ částka v RM (nezaok.)

¨ částka v ZM (nezaok.)

¨ částka v RM,

¨ záloha v RM,

¨ dosud uhrazeno,

¨ kurzový rozdíl – KPP<KÚ (je-li kurz platby menší než úhrady),

¨ kurzový rozdíl – KPP>KÚ (je-li kurz platby větší než úhrady).

s aplikací podmínky pomocí atributu Kategorie předepsané platby. Datum splatnosti je relevantní datum pro aktualizaci statistických hodnot.

Komponenta má definováno zrcadlové storno, šablony komponenty nedisponují speciálním vyprogramovaným vstupem šablony. Události lze aplikovat pouze v rámci operace, jejíž druh může mít tyto parametry:

¨ změna kategorie při vstupu následující (v procesu) události platby a nová kategorie,

¨ změna kategorie při zrušení následující (v procesu) události platby a nová kategorie,

¨ zda ukončovat operaci předběžně,

¨ poznámka.

1.5.9.1.2 Parametry

Parametry ovlivňují chování SW při vstupu událostí plateb, tj.:

¨ implicitní doba splatnosti pohledávky od aktuálního data, pokud se neuplatní doba splatnosti adresáta,

¨ implicitní doba splatnosti závazku od aktuálního data,

¨ 1.část variabilního symbolu, tj. max. 4 znaky z toho 2 odvozené z datového úložiště (U) a 2 z roku (R) v čísle procesu zahrnujícího platbu; zde uvedená písmena U a R odkazují zprava na relevantní identifikátory. Variabilní symbol v IS BM je tvořen 10 znaky. První čtyři znaky jsou určeny tímto parametrem, dalších 6 znaků je automaticky generováno z čísla procesu,

¨ validace variabilního symbolu (Ne, Ano, Ano stejného adresáta) – zda bude validována duplicita variabilního symbolu, tj. bude k uživateli vznesen informační dotaz, zda s duplicitou souhlasí,

¨ nevalidované variabilní symboly – pokud je nastavena validace variabilního symbolu, tak zde uvedené symboly (oddělené čárkou) nebudou validovány.

Sestavení příkazu k úhradě ovlivňuje parametr …. druhu operace této komponenty.

1.5.9.2 PLA - Logické věci komponenty

Jako aktér je implementován adresát z IC společně se spojením adresáta a s bankovním spojením adresáta (dle něj se zobrazují údaje o jeho bankovním účtu v činnosti s přehledem událostí plateb).

Jako alokace je aplikováno umístění platby, které referuje:

¨ adresáta a jeho spojení,

¨ organizační selektor.

Artikl tato komponenta neobsahuje.

1.5.9.3 PLA – Událost

Události je možné členit na pohledávky a závazky nebo dle kategorie. Mezi nejvýznamnější atributy kromě standardních patří datum splatnosti, banka/pokladna z komponenty ZSP, konstantní a variabilní symbol, numerické údaje platby včetně kurzu, standardizovaný text, algoritmus vymáhání, úkon a datum aktuálně očekávaného vymáhání dle postupu.

Programový kód zajišťuje tato předplnění atributů:

¨ datum aktuálním datem,

¨ datum splatnosti se předplní (není-li vyplněn) po vyplnění adresáta dle parametrů komponenty nebo dle splatnosti specifické pro daného adresáta uvedené v obecné předkontaci adresáta BMSPLA, kde je jako význam uveden identifikátor adresáta a jako hodnota doba splatnosti ve dnech,

¨ VS z prefixu dle parametrů a dále z čísla procesu (6 znaků zprava bez levých nul), není-li před zápisem události platby číslo procesu dosud přiděleno, pak zde uvedená * bude při zápisu nahrazena variabilním symbolem sestaveným dle uvedené konstrukce,

¨ měna dle měny uvedené u adresáta,

¨ konstantní symbol dle symbolu uvedeného u adresáta,

¨ kurz dle pravidel oceňování (střed),

¨ množství oceňovací jednotky v kurzu dle měny,

¨ účet je aktualizován po účtování dle první události účetnictví zapsané na základě míry plnění,

¨ ZM zaokrouhlená dle zaokrouhlení u měny,

¨ RM i RM zaokrouhlená dle kurzu a zaokrouhlené ZM v případě, že RM<>ZM,

¨ RM i RM zaokrouhlená dle odpovídajících údajů v ZM v případě, že RM=ZM,

¨ při zápisu události se aktualizuje atribut:

¨ dosud neuhrazeno v RM i ZM odečtením zálohy od zaokrouhlených částek,

¨ úkon a datum prvního očekávaného vymáhání dle postupu vymáhání vyplývajícího z uvedeného algoritmu vymáhání; tyto atributy jsou následně aktualizovány zápisem událostí VYM vztažené k dané události PLA dle postupu vymáhání,

¨ při spárování v komponentě ZSP se aktualizují relevantní atributy (neuhrazeno RM a ZM, dosud uhrazeno v RM, kurzové rozdíly, stav uhrazená) takto:

¨ neuhrazeno ZM – odečte se hodnota uhrazené částky z dané platby danou změnou ZSP v ZM platby uvedená ve spárování (vpravo),

¨ uhrazeno (RM) – přičte se hodnota částky z výpisu uhrazující danou platbu v ZM uvedená ve spárování (vlevo) nad danou událostí ZSP vynásobená kurzem ze ZSP

¨ kurzový rozdíl 1 (kurz platby[1] < kurz úhrady, tj. ZSP) – pokud je výsledek „od uhrazující (ze spárování) násobené kurzem ZSP se odečte uhrazená (ze spárování) násobená kurzem platby“ kladný,

¨ kurzový rozdíl 2 (kurz platby > kurz úhrady, tj. ZSP) – pokud je výsledek „od uhrazující (ze spárování) násobené kurzem ZSP se odečte uhrazená (ze spárování) násobená kurzem platby“ záporný násobený –1,

¨ neuhrazeno RM – aktualizuje se tak, aby stále platila tato rovnost: částka v RM zaokrouhlená - záloha v RM - uhrazeno RM+KR1-KR2=neuhrazeno v RM,

¨ v okamžiku dosažení dosud neuhrazeno=0, se označí platba jako uhrazená.

Na záložkách jsou k dispozici relevantní (dle záznamů ve vazební entitě přehled spárování) události ZSP (úhrad), relevantní (dle míry plnění) události účetnictví, relevantní (dle vazební entity) položky vymáhání a položky relevantních příkazů k úhradě.

V menu Volby je kromě standardních dostupná funkce pro změnu bankovního spojení ve všech vybraných a zobrazených událostech daného adresáta a funkce pro zobrazení relevantní karty pohledávek s odpisy či opravnými položkami, resp. pro její založení.

Označení událostí plateb v činnosti s jejich přehledem aktivované z operace komponenty vymáhání využije funkce komponenty VYM pro automatizaci vstupu svých událostí a současného naplnění vazby PLA-VYM.

1.5.9.4 PLA – Jiné

Příkazy k úhradě jsou číslovány v rámci roku a datového úložiště pořadovým číslem a obsahují identifikaci bankovního účtu (vlastní účty), jehož přístupovými právy se řídí i přístup k příkazům k úhradě (hlavičce příkazu). V menu Volby jsou funkce pro uzavření příkazu, pak jej ani jeho položky nelze upravovat, pro export příkazu k úhradě, tj. vytvoření souboru dle definice komunikace s bankou nastavené pro daný bankovní účet, a pro zrušení uzavření příkazu.

Položky příkazu k úhradě, tj. fakticky vazby na platby, se prezentují na záložce, kde je možné změnit přikázanou částku v ZM platby oproti částce automaticky předplněné z relevantní události platby.

Zařazení platby na příkaz a automatické stanovení výše částky na příkaz se realizuje aktivací činnosti s přehledem plateb z daného příkazu z menu Volby s následným uživatelským výběrem a označením plateb. Po ukončení činnosti s přehledem plateb se z označených automaticky odvodí (předplní) položky příkazu při respektování těchto pravidel:

¨ jedná se o kladný závazek nebo zápornou pohledávku,

¨ platba není uhrazená,

¨ je-li již vystaven příkaz na část platby, předplní se jen dosud nepřikázaná část platby,

¨ je-li již část platby uhrazena, předplní se jen dosud neuhrazená část platby,

¨ je-li již část platby uhrazena a část přikázaná, předplní se dosud neuhrazeno v ZM mínus vyšší částka ze sumy úhrad a příkazů,

¨ platby z neukončených operací lze zařadit pouze tehdy, je-li to nastaveno v parametrech u druhu operace

V definici předlohy příkazu je pro sumu částky z řádků příkazů do jeho hlavičky k dispozici funkce bw_tisks. V položkách zahrnovaných do předlohy je k dispozici řada atributů platby a bankovního spojení adresáta včetně specifického symbolu.

1.5.10 Komponenta POS

Užití této komponenty se předpokládá zejména v souvislosti se správou a evidencí přijatých a odeslaných poštovních zásilek (dopisů, balíků, …) adresátům ve vztahu ke kompetentním pracovníkům dle různých kategorií obsahu s vyčíslením ceny.

Mezi významné tabulky komponenty kromě standardizovaných patří tabulka:

¨ kategorií pošty,

¨ kategorie zásilky, související poštovní služby a jejich ceny,

¨ aktuálního štítku adresy při odeslání,

¨ odeslaných e-mailů.

Těsné vztahy má tato komponenta s dokumenty, které vychází z předlohy s mailmerge, neboť její událost je zdrojem dat souboru MailMerge.

1.5.10.1 POS – Definiční data komponenty

1.5.10.1.1 Standardní definice

Pro aktualizaci hodnot komponenty je možné využít tyto atributy její události:

¨ 1,

¨ Cena zásilky,

¨ Hmotnost zásilky,

¨ Cena obsahu,

¨ F. cena.

bez aplikace podmínky. Komponenta nemá umožněno zrcadlové storno, šablony komponenty disponují speciálním vyprogramovaným vstupem šablony Adresář pro výběr a označení adresátů (resp. pro kopii adresátů z událostí spojených s dokumentem, ze kterého byla aktivována funkce pro založení procesu začínajícího operací komponenty POS) pro hromadný vstup událostí POS. Události lze aplikovat pouze v rámci operace, jejíž druh nemá parametry.

1.5.10.1.2 Další definice

Komponenta obsahuje řadu definičních dat souvisejících s kategorizací pošty a zásilek včetně automatizovaného stanovení ceny. Součástí definice kategorie pošty je implicitní kategorie zásilky a dvou doplňkových služeb. Součástí definice kategorie zásilky je spojená doplňková služba a ceník dané kategorie zásilky, kde lze cenu zásilky definovat jako složenou ze dvou rozlišení HMOTN a CENAS v závislosti na intervalu hmotnosti (dle rozlišení do) pro každé uvedené rozlišení. Cena doplňkové služby se definuje základní výší s možností další periodické částky dle výše hmotnosti, udané či skutečné ceny. Uvedené definice cen se uplatní pro stanovení ceny zásilky.

Kategorie zásilky a doplňkové služby lze exportovat do balíčku.

1.5.10.2 POS - Logické věci komponenty

Jako aktér je implementován adresát z IC společně se spojením adresáta.

Jako alokace je z hlediska aktuálních a statistických hodnot (nikoliv z hlediska přístupových práv) aplikována kategorie pošty referující související implicitní kategorii zásilky a doplňkové služby.

Artikl není aplikován.

1.5.10.3 POS – Událost

Události je možné členit zejména dle druhu pošty (přijatá, odeslaná, …) a dle kategorie pošty či zásilky. Mezi nejvýznamnější atributy krom standardních patří atributy vyřizuje (kompetentní uživatel), pořadí v rámci dne, identifikace kategorie zásilky a doplňkových služeb, hmotnost, cena a hodnota obsahu, cena zásilky, údaje adresy při odeslání.

Programový kód zajišťuje tato předplnění atributů:

¨ datum aktuálním datem,

¨ spojení adresáta implicitním spojením adresáta, případně spojením typu e-mail, pokud se jedná o vstup události aktivovaný založením procesu e-mail z okna dokumentů spojených s událostí obsahují adresáta se spojením typu e-mail,

¨ vyřizuje přihlášeným uživatelem,

¨ pořadí pořadovým číslem v rámci dne v okamžiku zápisu události,

¨ kategorie zásilky implicitní hodnotou z kategorie pošty,

¨ doplňkové služby dle implicitních hodnot v kategorii pošty,

¨ cena součtem ceny zásilky dané hmotnosti (součet za rozlišení HMOTN a CENAS), související doplňkové služby a v události uvedených doplňkových služeb,

¨ nepřepisovat vypočtenou cenu se zaškrtne v okamžiku zápisu události, pak případná oprava definic či atributů utvářejících cenu zásilky nebude již tuto cenu předplňovat

¨ text názvem kategorie pošty, pokud není uživatelem vyplněn

a adresní údaje na záložce předplní:

¨ oslovení oslovením dle uvedeného spojení adresáta,

¨ druhý řádek adresy jménem dle uvedeného spojení adresáta,

¨ třetí řádek adresy názvem adresáta,

¨ ulice, město a stát dle relevantních atributů adresy referované uvedeným spojením adresáta.

Na záložce činnosti s přehledem událostí POS lze modifikovat předplněné adresní údaje; v případě zatržení atributu uchovat změny štítku nebudou následné změny v adresáři z hlediska této události automaticky reflektovány. Údaje na těchto záložkách jsou v okamžiku aktivace dokumentu s definovaným mailmerge a objektově spojeným s operací pošty kopírovány do souboru MailMerge. Identifikace procesu (ve tvaru 9999-99-99999999) odpovídá v souboru mailMerge atributu „ČJ krátké“.

V seznamu se druh pošty zobrazuje barevně (došlá červeně, odeslaná modře). Na labelu kategorie lze aktivovat činnost se seznamem událostí poštu dané kategorie; shodně je tomu v činnosti s přehledem kategorií pošty.

V menu Volby je k dispozici funkce:

¨ Odeslání pošty, která změní druh pošty „K odeslání“ na „Odeslaná“,

¨ Vyřizuje, která umožní změnu atributu vyřizuje i v ukončené operaci (jediný, který se ukončením blokuje),

¨ Odeslat e-mail, která umožní z události odeslat e-mail, pokud uvedené spojení adresáta je typu e-mail; následně se aktivuje okno prezentující, jak e-mail bude odeslán (předplněna adresa a předmět, text možno doplnit).

V menu Obecné je k dispozici funkce Informace o aktualizaci, pomocí které lze zobrazit seznam (kdo a kdy) realizovaných modifikací atributů dané události.

1.5.10.4 POS – Jiné

Z okna spojených dokumentů lze aktivovat založení procesu pošty (proces e-mail), tj. těch druhů procesů, které začínají druhem operace z komponenty POS. Následně se aktivuje činnost pro vstup událostí v odpovídající operaci POS, do které jsou kopírováni adresáti za použití šablony s vyprogramovaným vstupem Adresář ze všech událostí spojených objektovou vazbou s dokumentem. V případě volby proces e-mail je do události POS předplněno první nalezené spojení typu e-mail, pokud je adresát má, pokud ne je o tom uživatel informován. Současně je dokument automaticky spojen objektovou vazbou s operací POS v okamžiku jejího založení.

1.5.11 Komponenta PZM

Užití této komponenty se předpokládá v souvislosti se správou a evidencí jednotlivých nemovitostí (např. pozemků) či celků z nich vytvářených. Základní vlastností této komponenty je schopnost využití dat evidovaných Českým úřadem zeměměřickým a katastrálním s možností dalšího uživatelského zpracování. U každé nemovitosti potom sledujeme kde leží, komu patří a další informace s ní související (tj. podíly, řízení, jiné právní vztahy apod.).

1.5.11.1 PZM – Definiční data komponenty

1.5.11.1.1 Standardní definice

Pro aktualizaci hodnot komponenty je možné využít tyto atributy její události:

¨ 1,

bez podmínky s možností míry rozlišení za adresáta a artikl.

Komponenta nemá definováno zrcadlové storno, šablony komponenty disponují speciálním vyprogramovaným vstupem šablony „hromadný vstup nemovitostí“. Události lze aplikovat pouze v rámci operace.

1.5.11.1.2 Parametry

Parametry ovlivňující chování komponenty pozemky:

¨ sada – tj. identifikace sady parametrů z oblasti AAA. Obecné parametry této sady je možné aktualizovat a prezentovat na záložce „parametry“ v činnosti s přehledem nemovitostí.

¨ operace zápisu událostí na pozadí – identifikuje operaci do které import dat z Českého úřadu zeměměřického a katastrálního zaznamená události reflektující změny. Uživatel zde uvádí identifikaci a číslo operace (číslo operace se pak mění automaticky po každém provedeném importu o jedno výš).

1.5.11.2 PZM – Logické věci komponenty

Jako aktér je implementován adresát z IC společně se spojením adresáta. Jako alokace je aplikováno umístění na nemovitosti, které referuje:

¨ organizační selektor.

Ke každému umístění lze nadefinovat přístupová práva, čímž se nepřímo určí přístupová práva i pro druhy událostí o nemovitostech. Každý druh události je totiž svázán s určitým umístěním a pokud uživatel nemá přístupové právo na umístění uvedené na druhu události, nemá právo ani k druhu události o nemovitostech.

Jako artikl je implementována nemovitost, která je reprezentována druhem a identifikací. Nemovitost navíc nese informace o těchto atributech: katastr, list vlastnictví, vyšší celek, budova, typ, zdroj evidence, určení výměry, způsob využití. Na záložkách v činnosti nemovitosti jsou k dispozici relevantní údaje: další, BDP (bonitní díl parcely), parametry, podíly, ochrana, řízení, jiné právní vztahy (JPV) a stavy.

Mezi funkce dostupné v menu Volby v činnosti prezentující nemovitosti patří:

¨ prezentace artiklu umožňující pro danou nemovitost prezentovat propojené nebo vložené objekty vytvořené v některé z aplikací sady Office, nebo v jakémkoli jiném programu, který podporuje propojování a vkládání objektů,

¨ dokumenty umožňující zobrazit seznam dokumentů propojených objektovou vazbou s danou nemovitostí.

V tiskové předloze je k dispozici pohyb podle:

¨ hodnoty parametrů,

¨ JPV k tíži,

¨ JPV ku prospěchu,

¨ podílů,

¨ stavu nemovitostí,

¨ způsobu ochrany,

¨ řízení.

1.5.11.3 PZM – Událost

Události je možné členit podle stavu na vznik, ukončení nebo zrušení. Mezi nejvýznamnější atributy kromě standardních patří druh události. Programový kód zajišťuje pouze předplnění data aktuálním datem.

Ostatní atributy na události jsou:

¨ popis – vlastní popis události

¨ adresát – identifikace adresáta

¨ nemovitost – druh a identifikace nemovitosti

¨ druh události

¨ změna stavu

¨ hodnota

¨ poznámka

Jednotlivé události uživatel vstupuje pouze procesně. Změnu stavu nemovitosti (tzn. změna druhu události např. na vlastní nemovitost, hospodaříme apod.) provede uživatel pro tento účel speciálně vytvořeným druhem procesu. Ostatní naplnění událostí se provádí pomocí importu dat z Českého úřadu zeměměřického a katastrálního.

1.5.11.4 PZM – Jiné

1.5.11.4.1 Import z Českého úřadu zeměměřického a katastrálního

Import dat z Katastrálního úřadu naplní příslušné číselníky (tzn. nemovitosti a s nimi související) daty s tím, že zároveň provádí automatickou aktualizaci adresáře. Pokud tedy adresát uvedený na importované události v adresáři ještě neexistuje, je tam zápisem importovaných dat automaticky zapsán.

Import dat je řešen doplňující vlastností formuláře s připravenou specializovanou knihovnou vkládaného kódu. Je spojen s činností „Události o nemovitostech“. Struktura importovaných dat je popsaná v dokumentu Struktura výměnného formátu IS KN.

Při importu je pro každý záznam tabulky OPSUB (oprávněný subjekt) vytvořen adresát v tabulce BM ADADSAT, který je pro vztah k odpovídajícímu OPSUB označen v atributu „klíč“ (ad01klic) identifikací OPSUB. Tento adresát potom vystupuje ve všech záznamech tabulek BM, kterým odpovídá v importovaných datech záznam tabulky OPSUB.

Záznamy v tabulkách BM, pro které jsou definovány v importovaných záznamech atributy STAV_DAT a PRIZNAK_KONTEXTU vyjadřující stav záznamu (např. „zrušen“, „opraven“ ….), jsou při importu označovány odpovídajícím cizím klíčem tabulky BM „Stavy dat“. Tzn. při aktualizaci dat novým kompletním importem nebo změnovým importem nejsou zrušené záznamy v evidenci Českého úřadu zeměměřického a katastrálního v datech BM fyzicky rušeny, ale jsou označovány atributem tabulky BM „Stavy dat“.

Při importu mohou vznikat události o nemovitostech, na základě definic uvedených v tabulkách BM „Stavy nemovitostí“ a „Transformace změn – nemovitost“. Tyto události signalizují změny dat způsobené importem a mohou také měnit stavy nemovitostí.

1.5.11.4.2 Listy vlastnictví

Listy vlastnictví jsou úzce provázány se subjekty a nemovitostmi. Každý list vlastnictví nese informace o svém identifikačním čísle a případně čísle řízení vzniku či řízení zániku. Každý list vlastnictví je vztažen k určitému subjektu (záložka „podíly“) a s každým listem vlastnictví je svázána jedna nebo více nemovitostí (záložka „nemovitosti“). U každého listu vlastnictví se navíc mohou evidovat i jiné právní vztahy.

1.5.11.4.3 Oprávněné subjekty

Jedná se o přehled adresátů nebo institucí, se kterými bylo jednáno o řízení vzniku či řízení zániku. Každý subjekt je provázán na adresář z IC, kde má svoje vlastní identifikační číslo.

1.5.11.4.4 Katastry nemovitostí

Uživatel má k dispozici přehled katastrů, kde u každého katastru je informace o jeho identifikaci a názvu, identifikace obce (tzn. správního celku) a datum platnosti katastru od – do.

1.5.12 Komponenta PZP

Užití této komponenty se předpokládá zejména v souvislosti s přijímáním a odesíláním zpráv mezi uživateli IS BM v jeho rámci. Se zprávou může být objektovou vazbou spojen libovolný objekt IS BM, který je zprávou příjemci zpřístupněn i tehdy, pokud by k němu neměl přístupové právo. Zprávu lze též odeslat z událostí prezentovaných v rámci operace a naopak ze zprávy spustit danou operaci.

V některých situacích IS BM generuje zprávy automaticky, aby upozornil kompetentní uživatele (např. na změnu stavu projektu, stav operace apod.)

Mezi významné tabulky komponenty kromě standardizovaných patří tabulka skupin uživatelů, kterou využívá šablona určená pro hromadné odesílání zpráv.

1.5.12.1 PZP – Definiční data komponenty

1.5.12.1.1 Standardní definice

Pro aktualizaci hodnot komponenty je možné využít hodnotu 1 bez aplikace podmínky. Komponenta nemá umožněno zrcadlové storno, šablony komponenty disponují speciálním vyprogramovaným vstupem šablony Uživatelé pro hromadné odesílání zpráv definovaným skupinám uživatelů. Události lze aplikovat i mimo rámec operace. Logické věci nejsou aplikovány.

1.5.12.2 PZP – Událost

Události je možné členit zejména na došlé a odeslané dle přihlášeného uživatele nebo dle stavu zpracování (nepřijaté, přijaté a zpracované). Mezi nejvýznamnější atributy patří zapsal (uživatel - odesílatel), přijal (uživatel – příjemce), datum a čas odeslání, přijetí a zpracování, datum signalizace, text a komentář.

Programový kód zajišťuje tato předplnění atributů:

¨ zapsal a přijal přihlášeným uživatelem,

¨ datum signalizace aktuálním datem,

¨ text uživatelem, pokud není vyplněn,

¨ datum a čas odeslání systémový datem a časem v okamžiku zápisu bez možnosti ovlivnění uživatelem v IS BM,

¨ datum a čas přijetí systémový datem a časem v okamžiku zápisu přijetí bez možnosti ovlivnění uživatelem v IS BM,

¨ datum a čas zpracování systémový datem a časem v okamžiku zápisu přijetí bez možnosti ovlivnění uživatelem v IS BM.

IS BM umožňuje nastavení signalizace zpráv (tj. datum a čas připomenutí zprávy jejímu příjemci). Připomenutí je provedeno spuštěním stránky informačního panelu v samostatném okně pro každou připomínanou zprávu v rámci hlavního okna programu.

V činnosti prezentující seznam zpráv se zobrazují pouze ty, ve kterých je daný uživatel odesílatel nebo příjemce. Dále se dle stavu zprávy prezentuje její datum:

¨ červeně (vykřičník) – nepřijatá,

¨ modře (křížek) – přijatá nezpracovaná,

¨ zeleně (plus) – zpracovaná,

¨ hnědě (pomlčka) – nenastal termín její signalizace,

¨ na šedém pozadí – spojená s operací.

V menu Volby jsou k dispozici funkce pro přijetí a zpracování došlé zprávy (mění její stav) a pro spuštění spojené operace. Funkci pro zrušení záznamu lze aplikovat pouze na odeslané zprávy, které příjemce dosud nepřijal.

Při vstupu šablonou lze uplatnit uživatelsky definované „Oblíbené skupiny uživatelů“ včetně přiřazení (označením) jednotlivých uživatelů k ní, které se zde nabídnou k výběru kromě implicitní skupiny všech uživatelů. Pro vybrané uživatele šablona vygeneruje zprávu.

1.5.13 Komponenta REZ

Komponenta je určena k vedení diářů sdílených prostředků (artiklů spravovaného majetku), u kterých to uživatel v komponentě SMU definoval, a k rezervaci prostředků v nich pro využití jednotlivými uživateli.

Kromě vlastní tabulky událostí disponuje vlastní tabulkou kategorií diáře.

1.5.13.1 REZ – Definiční data komponenty

1.5.13.1.1 Standardní definice

Pro aktualizaci hodnot komponenty je možné využít hodnoty 1 bez aplikace podmínky a bez aplikace logických věcí. Komponenta nemá umožněno zrcadlové storno, šablony komponenty disponují speciálním vyprogramovaným vstupem šablony Spravovaný majetek pro výběr a označení karet (artiklu) spravovaného majetku s nastaveným atributem možnosti rezervace pro hromadný vstup událostí REZ. Události lze aplikovat i mimo rámec operace.

1.5.13.2 REZ - Logické věci komponenty

Třebaže komponenta z hlediska hodnot komponenty nemá definovány logické věci, v události jako aktér vystupuje adresát z IC, jako artikl spravovaný majetek, který lze rezervovat, z komponenty SMU, dle jehož umístění je řízen přístup k událostem REZ. V případě, že jsou události REZ prezentovány činností zobrazující události spuštěné operace, není přístup k nim omezen přístupovými právy.

1.5.13.3 REZ – Událost

Události SMU je možné členit zejména dle kategorie, která (relevantní tabulka) je sdílena s diáři pracovníků IS BM, a dále dle dalších atributů. Mezi významné atributy dále patří datum a čas počátku a konce rezervace, uživatel, pro kterého je rezervováno, popis, komentář a selektory. Programový kód zajišťuje tato předplnění atributů:

¨ začátek aktuálním datem v čase 00:00:00,

¨ konec začátkem,

¨ uživatele, pro kterého je rezervováno, přihlášeným uživatelem.

Údaj začátku a konce rezervace je při vyplnění artiklu i při zápisu události porovnán s ostatními událostmi REZ daného artiklu a v případě překryvu (začátek a konec tvoří uzavřený interval) je o tom uživatel informován. Pokud překryv zapíše, budou se tyto události prezentovat červeně a ikonou s vykřičníkem.

V činnosti prezentující seznam událostí REZ je přístup k událostem řízen přístupovými právy k alokaci spravovaného majetku uvedeného na kartě spravovaného artiklu. V případě, že jsou události REZ prezentovány činností zobrazující události spuštěné operace, není přístup k nim omezen přístupovými právy.

Atributy události lze modifikovat i v uzavřené operaci. Na labelu Adresát a Artikl jsou k dispozici relevantní údaje. V menu Obecné je k dispozici funkce Informace o aktualizaci, pomocí které lze zobrazit seznam (kdo a kdy) realizovaných modifikací atributů dané události.

1.5.14 Komponenta SKL

Užití této komponenty se předpokládá v souvislosti se správou a evidencí skladovaných artiklů (zboží, surovin, materiálů či jiných i fiktivních zásob) dle jednotlivých skladů a jejich buněk. Evidenci lze aplikovat druhově, tj. artiklu v IS odpovídá několik jeho výskytů (množství) v reálném světě, nebo kusově, tj. artiklu v IS odpovídá jeden výskyt v reálném světě. Artikl je evidován v naturálním množství v několika měrných jednotkách a ve finančním vyjádření (ocenění). Pro oceňování lze užít metodu průměrných cen, FIFO nebo pevných cen dle ceníku. V událostech lze aplikovat čárový kód pro automatizaci jejich vstupu.

Mezi významné tabulky komponenty kromě standardizovaných patří tabulka:

¨ skladových buněk a artiklů v nich,

¨ množství artiklu (základní druhy hodnot – nepředběžné ocenění) ve skladech, resp. skladových buňkách, tj. fakticky specifický pohled do tabulky aktuálních hodnot,

¨ provázaných příjmů a výdajů pro stanovení ceny výdeje metodou FIFO,

¨ výrobních čísel (šarží) artiklů a související obratové tabulky.

Ve vztahu k dalším komponentám váže na technickou přípravu výroby, kde může být sklad aplikován jako úložiště TPV. Ostatní vztahy jsou realizovány pomocí IC.

1.5.14.1 SKL - Definiční data komponenty

1.5.14.1.1 Standardní definice

Pro aktualizaci hodnot komponenty je možné využít tyto atributy její události:

¨ 1,

¨ Množství,

¨ Množství v RMJ (referenční měrné jednotce),

¨ Celkem (celková cena za celé množství události).

s aplikací podmínky pomocí atributu Vztah k účetnictví a s možností definovat hodnotu jako obrat za sklad. Komponenta má definováno zrcadlové storno, šablony komponenty disponují několika speciálními vyprogramovanými vstupy šablony, například pro hromadný vstup artiklu (označeného), pro vše skladované, apod. Události lze aplikovat pouze v rámci operace, kterou je možné ukončovat předběžně.

1.5.14.1.2 Základní druhy hodnot

Zde se definuje význam některých uživatelsky definovaných druhů hodnot z hlediska skladové evidence, která se jimi následně řídí v algoritmech a v prezentaci dat. Jedná se o přiřazení druhu hodnoty k těmto základním druhům hodnoty:

¨ Množství na skladě ve finančním vyjádření,

¨ Množství na skladě v naturálním vyjádření,

¨ Rezervované množství na skladě (naturální vyjádření),

¨ Množství na skladě ve finančním vyjádření – předběžné ocenění,

¨ Množství na skladě v naturálním vyjádření – předběžné ocenění,

¨ Rezervované množství na skladě – předběžné ocenění (naturální vyjádření).

1.5.14.2 SKL - Logické věci komponenty

Jako aktér je implementován adresát z IC společně se spojením adresáta.

Jako alokace je aplikován sklad, který referuje adresáta a jeho spojení, organizační selektor a případně i účetní selektor dostupný ve výstupních atributech komponenty, a jeho skladová buňka. Součástí definice skladu je volba algoritmu pro předplňování ceny událostí výdejů ze skladu a definice jednotlivých buněk v něm. Buňka je definována: identifikátorem, názvem, kódem pro automatickou identifikaci, polohou (x, y, z) a volným textem. V definici předloh výstupu činnosti s přehledem skladů lze užít pohyb ve skladových buňkách.

Jako artikl je implementován artikl skladu, který je reprezentován druhem a identifikací artiklu. Artikl skladu nese kromě atributů artiklu v IC zejména: identifikaci čárovým kódem, třídu SKP, referenční měrnou jednotku, vztah k účetnictví, TV selektor a účetní selektor dostupný ve výstupních atributech komponenty, informaci, zda je aktuální a zda v událostech týkajících se ho bude povolena nulová cena. Na záložkách v činnosti s přehledem artiklu (karet) jsou k dispozici relevantní údaje: názvy artiklu v cizích jazycích dle artiklu v IC, vztah měrných jednotek dle artiklu v IC, informace o množství (základní druhy hodnot – nepředběžné ocenění) dle skladů a jejich buněk a informace o stavu aktuálních hodnot.

Mezi funkce dostupné v menu Volby v činnosti prezentující seznam artiklů skladu patří:

¨ prezentace artiklu umožňující pro daný artikl prezentovat propojené nebo vložené objekty vytvořené v některé z aplikací sady Office, nebo v jakémkoli jiném programu, který podporuje propojování a vkládání objektů,

¨ dokumenty artiklu umožňující zobrazit seznam dokumentů propojených objektovou vazbou s daným artiklem.

V tiskové předloze je k dispozici pohyb v aktuálních hodnotách, množství na skladech a v názvech artiklu v cizích jazycích. V běžném výběru je k dispozici volba nenulového množství na skladě.

Artikly definované kromě základní identifikace i výrobním číslem (šarží) mají kromě základní výše uvedené karty založenu další kartu s výrobním číslem (kusová evidence artiklu), jejichž seznam se prezentuje samostatnou činností s údajem o datu prvního příjmu a aktuálním množství (druh hodnoty přiřazený Množství na skladě v naturálním vyjádření). Podobně obraty těchto artiklů kusově (v šarži) evidovaných se prezentují samostatnou činností.

1.5.14.3 SKL – Událost

Události je možné členit zejména na příjmy a výdeje nebo dle vztahu k účetnictví. Mezi nejvýznamnější atributy kromě standardních patří atribut, zda se jedná o konečné ocenění, čárový kód, skladová buňka, výrobní číslo, aplikovaná i referenční měrná jednotka artiklu a množství v nich vyjádřené, cena za jednotku a celkem.

Programový kód zajišťuje tato předplnění atributů:

¨ datum aktuálním datem,

¨ spojení adresáta jeho aktuálním spojením,

¨ identifikace artiklu a jeho druhu artiklem dle čárového kódu,

¨ sklad a buňka v případě výdeje skladem a buňkou, kde je uvedený artikl umístěn (dle základních hodnot), pokud to není v BW.INI nastaveno jinak,

¨ aktuální i referenční měrná jednotka události dle referenční MJ z karty artiklu,

¨ množství v referenční MJ dle množství v aktuální MJ (resp. obráceně) za pomoci vztahu MJ na kartě artiklu,

¨ cena za jednotku v aktuální MJ,

¨ při příjmu (nebo výdeji se záporným množstvím) podílem ceny celkem a aktuálního množství, pokud ji uživatel neuvedl,

¨ při výdeji (nebo příjmu se záporným množstvím) podílem ceny celkem a aktuálního množství,

¨ cena za jednotku v referenční MJ,

¨ při příjmu (nebo výdeji se záporným množstvím) podílem ceny celkem a referenčního množství, pokud ji uživatel neuvedl,

¨ při výdeji (nebo příjmu se záporným množství) podílem ceny celkem a referenčního množství,

¨ cena celkem,

¨ při příjmu (nebo výdeji se záporným množstvím) z ceny za jednotku referenční nebo aktuální, pokud některou uživatel uvedl, vynásobené odpovídajícím množstvím,

¨ při výdeji (nebo příjmu se záporným množstvím) dle nastavení skladu:

¨ na FIFO se předplní cena vypočtená z událostí relevantních příjmů následně poznamenaných do vazební tabulky,

¨ na vážený průměr se předplní cena vypočtená ze základních druhů aktuálních hodnot jako podíl množství na skladě ve finančním vyjádření a množství na skladě v naturálním vyjádření násobený množstvím z události výdeje; v souboru BW.INI v sekci [Sklad] lze nastavit parametr CenaVC=1, aby se pak v případě událostí s uvedeným VČ vzaly do výpočtu pouze aktuální hodnoty týkající se daného VČ.

V okamžiku události s výdejem (záporným příjmem) IS BM kontroluje, zda uvedené množství je k dispozici na uvedeném skladě, buňce a výrobním čísle. V případně, že je artikl rezervován (nenulový základní druh hodnoty – rezervované množství na skladě), pak se při jeho výdeji (záporném příjmu) v rámci operace, jejíž druh nemá definovánu aktualizaci uvedené základní hodnoty skladu (rezervované množství na skladě), v okamžiku zápisu události zobrazí okno informující o rezervacích s volbou storna či zápisu.

Při zápisu události s uvedeným VČ se současně aktualizuje (založí nový a naplní datem události, pokud se jedná o první příjem, a modifikuje hodnotu aktuálního množství, pokud událost daného druhu operace aktualizuje základní druh hodnoty „Množství na skladě v naturálním vyjádření“ nezávisle na nastavení – aktuální, obrat, statistická) záznam v tabulce artikly s výrobním číslem. Přístup ke kartám artiklu s VČ je dán právy přístupu k odpovídajícímu skladu. Relevantním způsobem se aktualizuje i tabulka obratů skladu s VČ.

V případě skladu nastaveného na FIFO se při zápisu události výdeje (záporného příjmu) automaticky vyberou a „spárují“ odpovídající (první dle data nespárované) příjmy na daný sklad a informace o tom včetně spárovaného množství a ceny za jednotku se zapíší do tabulky s přehledem provázaných příjmů a výdajů metodou FIFO.

V případě výdeje ze skladu nastaveného na FIFO je při výdeji ze skladu automaticky aplikováno ocenění předběžné, pokud operace příjmu není ukončena, a současně aktualizovány druhy hodnot relevantní s předběžnými základními druhy hodnot.

Na záložkách činnosti s přehledem událostí SKL jsou k dispozici relevantní (dle záznamů ve vazební tabulce s přehledem provázaných příjmů a výdajů metodou FIFO) události skladových příjmů (z události příjmu) a výdejů (z události výdejů) s uvedením vázaného množství v referenční MJ a ceny za referenční MJ a na další záložce relevantní (dle míry plnění) události účtování.

V menu Volby je k dispozici funkce pro prezentaci uvedeného artiklu a pro nastavení konečného ocenění v dané události.

1.5.14.4 SKL – Jiné

Aktuální hodnoty skladu definované s rozlišením adresáta se nezobrazují na záložce v činnosti s přehledem artiklů.

1.5.15 Komponenta SKZ

Užití této komponenty se předpokládá v souvislosti se správou a evidencí zvířat zejména základního stáda dle kategorií a dle jednotlivého umístění (tzn. stáje, pastviny apod.) zejména ve vazbě na účetnictví. Zvířata jsou evidována v naturálním množství i ve více jednotkách a ve finančním vyjádření (ocenění). Kromě tohoto je u kategorie možno sledovat pohyby zvířat (např. zařazení, nákup, prodej, přeřazení, úhyn, krádež apod.). Komponenta umožňuje automatizovaný výpočet krmných dnů a u vybraných kategorií se počítá i vzrůstový přírůstek.

1.5.15.1 SKZ – Definiční data komponenty

1.5.15.1.1 Standardní definice

Pro aktualizaci hodnot komponenty je možné využít tyto atributy její události:

¨ 1,

¨ množství v RMJ,

¨ množství v MJ – pomocné,

¨ cena celkem,

¨ cena celkem upravená.

Komponenta má definováno zrcadlové storno. Události lze aplikovat pouze v rámci operace, jejíž druh může mít tyto parametry:

¨ běžná – mají nastaveno všechny standardní operace jako příjem, výdej, prodej apod.,

¨ výpočet KD – nutno nastavit v parametrech operace, která provádí zápočet krmných dnů,

¨ převod – příjem, převod - výdej – nastavuje se v parametrech operací, které provádějí převod zvířat z kategorie do kategorie (nebo umístění – umístění) proto, aby bylo v pořádku zachováno ocenění (tzn. při převodu je nutno brát skladovou cenu z původního stáda) a to i tehdy, je-li původní cena následně upravená

1.5.15.1.2 Parametry

Parametry ovlivňující chování komponenty skladu zvířat, tj.:

¨ 1. zobrazovaná hodnota (u kategorie) – nastavený druh hodnoty a výše hodnoty uvedeného druhu se pak zobrazuje na kartě kategorie zvířat jako 1. zobrazovaná hodnota

¨ 2. zobrazovaná hodnota (u kategorie) – nastavený druh hodnoty a výše hodnoty uvedeného druhu se pak zobrazuje na kartě kategorie zvířat jako 2. zobrazovaná hodnota

¨ 3. zobrazovaná hodnota (u kategorie) – nastavený druh hodnoty a výše hodnoty uvedeného druhu se pak zobrazuje na kartě kategorie zvířat jako 3. zobrazovaná hodnota

¨ cena skladová – nastavení druhu hodnoty, který představuje cenu skladovou. Cenu skladovou u jednotlivých kategorií si pak systém automaticky dopočítává z událostí a obratů skladu zvířat a v operacích výdeje, kde je nastaveno, že výdej bude za cenu skladovou se pak tato cena automaticky předplňuje.

¨ množství v RMJ pro výpočet ceny skladové – druh hodnoty, který udává množství zvířat v referenční měrné jednotce (slouží pro výpočet jednotkové ceny skladové).

¨ množství v MJ pro výpočet KD – druh hodnoty, který udává množství zvířat v referenční měrné jednotce (slouží pro výpočet počtu krmných dnů u kategorií, které mají zaškrtnutý příznak KD)

¨ cenová skupina pro výpočet vzrůst. přír. – identifikace cenové skupiny, která je určena pro výpočet vzrůstového přírůstku. Jestliže požadujeme u kategorie výpočet vzrůstového přírůstku, musí mít tato kategorie záznam v ceníku (třebaže ceníková cena bude nulová).

¨ započítávat stavy do KD – zápočet krmných dnů se provádí na základě počátečních nebo konečných stavů. V případě nastavení „počátečních stavů“ se v daný den do krmných dnů nezapočítávají naskladněná zvířata, ale započítávají se pouze v ten den vyskladněná a do příjmových operací se do atributu pořadí automaticky předplňuje 1. V případě nastavení „konečných stavů“ se v daný den do krmných dnů nezapočítávají vyskladněná (prodaná) zvířata, ale započítávají se pouze v ten den naskladněná a do výdajových operací se do atributu pořadí automaticky předplňuje 99999.

1.5.15.2 SKZ – Logické věci komponenty

Jako aktér je implementován adresát z IC společně se spojením adresáta. Jako alokace je aplikováno umístění skladu zvířat, které referuje adresáta a jeho spojení. Jako artikl je implementována kategorie zvířat, která je reprezentována druhem artiklu a identifikací kategorie a případně identifikace zvířete (tento atribut je povinnost uvádět v událostech v případě kategorií vedených kusově). Kategorie nese kromě atributů artiklu v IC zejména: příznak, zda se u ní počítají krmné dny, způsob vedení (obecně/kusově), referenční měrnou jednotku, TV a účetní selektor. Dále se zde zobrazují tři aktuální hodnoty definované v parametrech skladu zvířat. Na záložkách jsou k dispozici relevantní údaje o aktuálních hodnotách k dané kategorii a dle jednotlivých umístění.

Mezi funkce dostupné v menu Volby v činnosti prezentující seznam kategorií skladu zvířat patří:

¨ prezentace kategorie umožňující pro danou kategorii prezentovat propojené nebo vložené objekty vytvořené v některé z aplikací sady Office, nebo v jakémkoli jiném programu, který podporuje propojování a vkládání objektů,

¨ dokumenty kategorie umožňující zobrazit seznam dokumentů propojených objektovou vazbou s danou kategorií.

V tiskové předloze je k dispozici pohyb v aktuálních hodnotách a jednotlivých umístěních.

Obraty jednotlivých kategorií podle druhů hodnot se prezentují samostatnou činností.

1.5.15.3 SKZ - Událost

Události je možné členit na příjmy a výdeje. Mezi nejvýznamnější atributy kromě standardních patří cena (skladová nebo zadaná), množství v referenční měrné jednotce, cena za jednotku a cena upravená.

Programový kód zajišťuje předplnění těchto atributů:

¨ datum aktuálním datem,

¨ pořadí – předplňuje se automaticky číslem 100 a každé následující je o sto vyšší. Výjimku tvoří operace zápočet krmných dnů, kde se pořadí předplňuje podle nastavených parametrů,

¨ typ ceny – cena skladová se vztahem k RMJ nebo cena zadaná

¨ identifikátor měrné jednotky – na základě nastavené MJ u kategorie zvířat,

¨ cena za MJ – pokud se jedná o výdej, automaticky se předplňuje cenou skladovou k datu události,

¨ cena upravená – tato cena se naplňuje automaticky cenou skladovou,

¨ cena upravená celkem – platí totéž co u ceny upravené.

Je-li zapsána událost, jejíž datum či pořadí ji na časové ose nezařadí jako poslední a současně ji následují výdeje a zároveň mění jednotkovou cenu, je automaticky v následných výdajích relevantním způsobem dopočtena cena upravená (v neukončených operacích i cena za MJ).

Je-li změněna cena upravená v události výdeje v druhu operace s nastaveným parametrem operace komponenty typ operace na „převod – výdej“, je relevantním způsobem nastavena cena upravená i v událostech příjmu (dle míry plnění). Tyto změny upravené ceny se provádějí i v ukončených operacích.

Pokud tedy uživatel před určitý výdej (za určitou skladovou cenu) předřadí (změnou pořadí operací) příjem (tzn. skladová cena je v tuto chvíli změněná od původního výdeje), automaticky se na původní operaci výdeje tato cena upravená předplní touto novou cenou skladovou. Pokud je operace výdeje ve stavu připravena – zahájena, přepočte se automaticky cena upravená a rovněž se upraví i cena skladová za MJ. Pokud je operace výdeje již ukončena, cena za MJ zůstává beze změn, ale cena upravená se automaticky změní.

1.5.15.4 SKZ – Jiné

Pro zápočet krmných dnů je k dispozici program "SZUDAL krmne dny" využitelný v definici importu, kde uživatel pouze zadá datum, kategorii a umístění a program automaticky naplní operaci událostmi, které podle nastavených parametrů náleží do zápočtu krmných dnů.

Výpočet krmných dnů probíhá na základě následujícího algoritmu. Systém z obratů skladu zvířat vybere záznamy (podle data, umístění, kategorie, počátečního/konečného stavu) s nižším datem, než je zadané datum na šabloně výpočtu krmných dnů, pro ty kategorie zvířat, které mají zaškrtnutý příznak KD. Z obratů systém bere tyto hodnoty:

¨ množství (tj. počet krmných dnů) – určené parametrem „množství v MJ pro výpočet KD“ (činnost Parametry komp. sklad zvířat)

¨ podle nastavení parametru „započítávat stavy do KD“ (činnost Parametry komp. sklad zvířat) hodnota počáteční nebo konečný stav

První obrat pro zvolenou kategorii a umístění je určen prvním zápisem hodnoty „množství v MJ pro výpočet KD“ do obratů. Od tohoto data se kontrolují stavy (počáteční/konečný) za všechny dny až do zadaného data vůči událostem, které mají shodné: datum, umístění, kategorii a druh operace má nastaven v činnosti Parametry operace komponenty „výpočet KD“. Není-li stav shodný, je vygenerován záznam operace s rozdílovým množstvím. Je-li ke kategorii přiřazena stejná cenová skupina, jako je zadána v parametru „cenová skupina pro výpočet vzrůst. přír. (činnost Parametry komp. sklad zvířat), je množství krmných dnů zároveň oceněno (tj. vyhodnocen vzrůstový přírůstek) dle ceny uvedené v ceníku.

1.5.16 Komponenta SMU

Komponenta SMU je určena pro evidenci a správu spravovaného majetku, obvykle i inventarizovaného, různého druhu. Na každé kartě spravovaného majetku je evidován právě jeho jeden výskyt jednoznačně identifikovatelný v IS BM i v reálném světě, tj. jedná se o druhovou evidenci, kde je významnějším údajem stav oproti množství. Komponenta eviduje ve svých událostech též veškeré změny stavu, odpovědnosti i alokace, ale také případné servisní zásahy apod.

Mezi významné tabulky komponenty kromě standardizovaných patří cizojazyčné názvy spravovaného majetku. Artikl spravovaného majetku je sdílen s komponentou rezervace majetku.

1.5.16.1 SMU – Definiční data komponenty

1.5.16.1.1 Standardní definice

Pro aktualizaci hodnot komponenty je možné využít tyto atributy její události:

¨ 1,

¨ Cena.

bez aplikace podmínky. Komponenta má definováno zrcadlové storno, šablony komponenty disponují speciálním vyprogramovaným vstupem šablony Spravovaný majetek pro výběr a označení karet (artiklu) spravovaného majetku pro hromadný vstup událostí SMU. Události lze aplikovat pouze v rámci operace.

1.5.16.2 SMU - Logické věci komponenty

Jako aktér je implementován adresát z IC společně se spojením adresáta.

Jako alokace je aplikováno umístění spravovaného majetku, které referuje organizační selektor. Aktuální umístění každého spravovaného artiklu je evidováno na jeho kartě, přičemž jeho změna je realizována událostí SMU.

Jako artikl je implementován artikl spravovaného majetku, který je reprezentován druhem, identifikací artiklu a pořadím. Artikl skladu nese kromě atributů artiklu v IC zejména: čárový kód, třídu SKP, výrobní číslo, organizační selektor, TV selektor a účetní selektor dostupný ve výstupních atributech komponenty, informaci, zda jej lze rezervovat v komponentě REZ, a atributy aktualizované událostí:

¨ zodpovídá adresátem z poslední události s atributem změna odpovědnosti nastaveným na Ano,

¨ umístění umístěním z poslední události s atributem změna umístění nastaveným na Ano,

¨ stav změnou stavu uvedenou v poslední události se změnou stavu (implicitní stav při založení karty je nezařazen),

¨ datum zařazení první událostí s atributem změna stavu nastaveným na zařazen,

¨ cena zařazení dle událostí s atributem změna stavu nastaveným na zařazen a atributem změna ceny nastaveným na Nová cena (přepsání ceny) nebo na Přírůstek ceny (přičtení),

¨ datum vyřazení událostí s atributem změna stavu nastaveným na vyřazen,

¨ cena vyřazení událostí s atributem změna stavu nastaveným na vyřazen a atributem změna ceny nastaveným na Nová cena (přepsání ceny) nebo na Přírůstek ceny (přičtení).

Na první záložce v činnosti s přehledem spravovaného majetku (artiklu SMU) je k dispozici poznámka (memo), na druhé aktuální hodnoty a na další jeho cizojazyčné názvy. Mezi funkce dostupné v menu Volby v činnosti prezentující seznam artiklů patří funkce artiklu v IC, tj. prezentace artiklu a dokumenty artiklu. Založení karty je autorizováno a přístup k nim je řízen dle přístupových práv k umístění spravovaného majetku uvedeného na kartě.

1.5.16.3 SMU – Událost

Události jsou určeny k aktualizaci uvedených údajů na kartě spravovaného majetku (artiklu). Je možné členit zejména dle změny stavu artiklu, změny odpovědnosti, změny umístění a dle dalších atributů. Mezi významné atributy dále patří datum změny, adresát (odpovědnost), cena, selektory a poznámka.

Programový kód zajišťuje tato předplnění atributů:

¨ datum aktuálním datem,

¨ pořadí hodnotou 1,

¨ změna umístění a odpovědnosti hodnotou Ne,

¨ cenu hodnotou zařazení na kartě v případě události vyřazení s novou cenou.

V okamžiku aktualizace (vložení, modifikace, zrušení) události SMU se aktualizují atributy na kartě spravovaného majetku s respektováním pořadí událostí dle jejich data. Následně vstupují v platnost omezení aktualizace dané karty (např. atribut změna stavu a změna ceny nelze po zápisu události již opravovat, u vyřazených artiklů již nelze měnit stav apod.).

Na záložce činnosti prezentující seznam událostí SMU jsou k dispozici údaje daného spravovaného artiklu. Na labelu Adresář a Artikl jsou k dispozici relevantní údaje.

1.5.17 Komponenta UCE

Komponenta UCE je určena pro vedení účetnictví. Má zčásti charakter manažerského systému, takže standardní hodnoty komponent jsou nahrazeny specifickými obratovými tabulkami. Podobně je tomu s logickými věcmi, které zde nejsou aplikovány.

Mezi významné tabulky komponenty kromě standardizovaných patří:

¨ účetní osnova a cizojazyčné názvy účtů,

¨ účetní období,

¨ saldokontní hodnoty,

¨ saldokonto do data (dle uživatelem zadaného data se obsah aktualizuje po zápisu výběru),

¨ měsíční obraty.

Vzhledem k obvyklosti významných vazeb událostí řady komponent na účetnictví je v jejich činnostech prezentujících seznam událostí záložka, na které jsou k dispozici relevantní (dle míry plnění) události komponenty UCE.

1.5.17.1 UCE - Definiční data komponenty

1.5.17.1.1 Standardní definice

Pro aktualizaci hodnot komponenty je možné využít tyto atributy její události:

¨ 1,

¨ částka,

¨ částka v ZM.

bez aplikace podmínky. Hodnotu nelze definovat jako obrat. Činnost pro prohlížení aktuálních hodnot není k dispozici.

Komponenta má definováno zrcadlové storno, šablony komponenty disponují speciálním vyprogramovaným vstupem šablony pro otevření a uzavření účetních knih. Události lze aplikovat pouze v rámci operace, jejíž druh nemá parametry.

1.5.17.1.2 Účtový rozvrh

IS BM umožňuje definovat účtový rozvrh, ve kterém se identifikace účtu skládá ze tří povinných znaků a z dalších šesti volitelných. Názvy účtů lze uvádět v různých jazycích. K dispozici je komentář (memo). Další atributy ovlivňují související algoritmy:

¨ strana; je-li nastaveno MD, počítá IS BM konečný stav (KS) v obratové tabulce: PS+MD-Dal; je-li nastaveno Dal, počítá IS BM konečný stav (KS) v obratové tabulce: PS-MD+Dal,

¨ saldokontní; je-li nastaveno Ano, pak je v události dostupný (resp. automaticky plněn) identifikátor párování s následnou aktualizací saldokontních hodnot,

¨ obrat v ZM; je-li nastaven na Ano, pak se aktualizuje obratová tabulka nejen referenční měnou, ale i uvedenou zahraniční měnou v události UCE,

¨ obrat obchodního selektoru, obrat organizačního selektoru, obrat tech.-věcného selektoru – je-li nastaveny Ano, aktualizuje se obratová tabulka se selektory (hodnota selektoru uvedeného na události účetnictví na daném účtu se promítá do obratové tabulky). Při změně nastavení těchto obratů je nutno provést přepočet obratové tabulky účetnictví.

¨ povinnost uvádět obchodní, organizační a tech.-věcný selektor v událostech účetnictví – je-li nastaveno Ano, nelze zapsat událost účetnictví s hodnotou daného selektoru neurčeno (‘-’)

¨ interval platnosti; zápis události na daný účet s datem mimo tento interval IS BM nepovolí.

Z labelu Účet či menu Volby lze aktivovat menu s nabídkou informací souvisejících s daným účtem (účetní deník, saldo, obraty, …). Zápis nového účtu je autorizován.

1.5.17.1.3 Parametry a účetní období

V parametrech účetnictví je možné nastavit možnost účtování do budoucna, které implicitně není umožněno.

IS BM umožňuje definovat účetní období intervalem začínajícím měsícem a rokem počátku a končícím měsícem a rokem konce účetního období. Takto definované období je klíčem v obratové tabulce, přičemž se odvozuje z data události, které nesmí být mimo definovaná období.

Do období, které má zde nastaven stav uzavřeno, nelze zapsat událost. Období, které má zde nastaven stav otevřeno, se nenabízí v šabloně pro otevření účetních knih.

1.5.17.2 UCE – Událost

Události představují položky účetního deníku, které je možné členit zejména dle fáze účetního období (otevření, uzavření účetních knih, běžná), dle druhu (skutečnost, plán) a dle dalších atributů. Mezi významné atributy dále patří: datum účetního případu, adresát, jiné párování, účetní strana, částka, částka v ZM a měna, identifikátor párování saldokonta a organizační selektor.

Programový kód zajišťuje tato předplnění atributů:

¨ datum aktuálním datem,

¨ text názvem druhu operace, pokud není vyplněn,

¨ fáze stavem běžná,

¨ adresát neuvedeným adresátem „-“,

¨ jiné spárování hodnotou Ne,

¨ zahraniční měna měnou referenční,

¨ částka v ZM částkou v RM, je-li ZM shodná s RM, v opačném případě nulou,

¨ IDP kódem složeným z identifikace daného procesu (rok, datové úložiště a pořadové číslo), pokud se jedná o saldokontní účet, v opačném případě atribut IDP není přístupný; pokud v okamžiku zápisu není vyplněn, doplní jej IS automaticky při zápisu,

¨ organizační selektor neuvedeným „-“.

V okamžiku před zápisem události je operace validována, zda souhlasí suma částek v RM na straně MD a Dal, zda je ve všech událostech shodné datum a zda jsou ve shodné fázi. V případě nesouhlasu nelze takovou operaci ukončit.

V okamžiku zápisu události se aktualizuje tabulka obratů v RM a v případě, že se jedná o účet, který nese příznak cizí měny, aktualizuje se i záznam v zahraniční měně. Pokud se jedná o účet, který nese příznak, že je saldokontní, a pokud je současně atribut události jiné párování nastaven na Ne, pak se při zápisu takové události aktualizuje tabulka účetních saldokontních hodnot. V případě aplikace šablony pro otevření účetních knih uživatel volí:

¨ ze seznamu neotevřených účetních období, které chce otevřít,

¨ zda se účetní knihy otevřou z uzávěrky předchozího období nebo z obratů jednotlivých účtů (pracovní provizorní otevření),

¨ zda se budou v událostech otevření uvádět organizační selektory nebo nebudou a současně bude součtováno za všechny do jedné události,

¨ zda události otevření s účty třídy 7 budou agregovány dle účtu do jediné nebo ne,

¨ které měny a druhu účetních událostí se otevření týká.

Následně je předplněna operace událostmi UCE, které nastaví počáteční stavy jednotlivých účtů proti účtu 701 buď dle obratů z předchozího uzavření nebo dle jeho simulace. Pokud již existují v daném období relevantní události otevření je uživatel vyzván k jejich zrušení a opakování otevření.

V případě aplikace šablony pro uzavření účetních knih účetních knih uživatel volí:

¨ ze seznamu neuzavřených účetních období, které chce uzavřít,

¨ zda se budou v událostech uzavření uvádět organizační selektory nebo nebudou a současně bude součtováno za všechny do jedné události,

¨ zda události uzavření s účty třídy 7 budou agregovány dle účtu do jediné události nebo ne,

¨ které měny a druhu účetních událostí se uzavření týká.

Následně je předplněna operace událostmi UCE, které nastaví nulové konečné stavy jednotlivých účtů proti účtu 702 a 710 dle konečných stavů v uzavíraném období.

Na první záložce jsou k dispozici všechny události dané operace (dokladu) a na druhé záložce jsou k dispozici události, které s danou událostí souvisí z hlediska saldokonta, tj. mají shodné IDP, a ze kterých lze spustit relevantní operaci.

V menu Volby, je-li aktivována z činnosti se seznamem událostí UCE v rámci spuštěné neukončené operace, je k dispozici funkce pro zrušení označených událostí. Na labelu Učet a Adresát jsou k dispozici relevantní informace. V běžném výběru zatržení atributu „saldokontně neuzavřené“ znamená, že jsou vybrány pouze ty události, pro které platí, že účetní saldokontní hodnota se shodným identifikátorem IDP je různá od nuly.

V událostech účetnictví neukončených operací je možno rozúčtovat události účetního deníku na více událostí bez nutnosti přepisovat původní hodnotu v Kč. Rozúčtování uživatel aktivuje volbou příslušné činnosti z menu Volby.

V předlohách výstupu je definován pohyb v položkách dokladu, tj. v událostech účetní operace.

1.5.17.3 UCE – Jiné

1.5.17.3.1 Účetní saldokonto

IS BM umožňuje saldokontní párování položek (událostí UCE) na základě uvedení IDP (identifikátoru párování, který IS předplňuje identifikací procesu) v nich při nastavení jejich atributu jiné párování na hodnotu Ne.

Takové aktualizují tabulku účetního saldokonta, kde jsou k dispozici dle identifikátoru účtu a IDP aktuální nenulové saldokontní hodnoty. Pro aktualizaci tabulky účetního saldokonta po změně strany účtu v účetním rozvrhu je v hlavním menu k dispozici činnost Přepočet účetního saldokonta.

V činnosti prezentující seznam saldokontních hodnot jsou na záložce skladba saldokonta k dispozici události UCE s odpovídajícím IDP, které zde lze modifikovat (párovat), podobně zde lze nastavit příznak jiné párování. Na labelu Účet a Adresát lze aktivovat činnosti pro prezentaci relevantních událostí. V menu Volby jsou dále k dispozici funkce pro aktivaci těchto činností:

¨ spuštění operace, do které daná událost skladby salda patří,

¨ zobrazení diagramu procesu, do kterého daná událost skladby salda patří,

¨ zobrazení stromu procesu, do kterého daná událost skladby salda patří,

¨ zobrazení všech událostí skladby salda (shodné IDP) pomocí činnosti Účetní deník.

V předlohách výstupu je definován pohyb v deníku (účetní události skladby salda).

Činnost Účetní saldokonto do data umožňuje prezentovat stav salda k datu uživatelem uvedenému ve výběru, které je vypočteno po zápisu běžného výběru. V ostatních vlastnostech je tato činnost obdobná jako činnost Účetní saldokonto.

1.5.17.3.2 Obratová tabulka a konta

V okamžiku zápisu událostí UCE je aktualizována tabulka s obraty v členění dle těchto atributů události (resp. z ní odvozených): měsíce a roku, účetního období, účtu, fáze a druhu účetní události, měny a organizačního selektoru. Dle měny je aktualizováno pouze tehdy, je-li tak daný účet definován v účetním rozvrhu. Každý záznam obsahuje počáteční stav (PS), obraty na straně Má dáti, obraty na straně DAL a konečný stav vypočtený dle definice daného účtu. Pro aktualizaci obratové tabulky po změně strany účtu v účetním rozvrhu je v hlavním menu k dispozici činnost Přepočet obratové tabulky.

V běžném výběru činnosti prezentující tato data lze zvolit, zda se při zobrazení mají dopočítat i záznamy, které mají nulový obrat. Data prezentující otevření a uzavření účetních knih se zobrazují v šedém pozadí. Na labelu Účet lze aktivovat činnosti pro prezentaci relevantních událostí a v menu volby součet stran.

V činnosti prezentující seznam obratů jsou na záložce hlavní kniha k dispozici relevantní události UCE tvořící uvedený obrat s možností v menu Volby aktivovat funkci pro výpočet sumy stran nebo pro spuštění operace, do které daná událost patří.

V předlohách výstupu je definován pohyb v deníku (účetní události hlavní knihy).

Činnosti Obratová tabulka se selektory, Konta a Konta se selektory jsou další pohledy (např. zahrnuto členění dle organizačního selektoru) na tabulku s obraty s funkcemi blízkými činnosti Obratová tabulka.

1.5.18 Komponenta VYM

Komponenta VYM je určena na podporu úkonů souvisejících s vymáháním pohledávek po splatnosti, např. upomínání, penalizace, soudní vymáhání, exekuce apod., které mohou být primárně evidovány jako událost komponenty PLA.

Mezi významné tabulky komponenty VYM kromě standardizovaných patří algoritmus vymáhání (uváděný též v události PLA) referující postup vymáhání s tabulkou úkonů vymáhání dle počtu dnů po splatnosti. Tyto tabulky podporují automatizaci generování událostí VYM z událostí PLA.

Vztah událostí VYM vygenerovaných (funkcí IS BM) z události PLA je evidován ve vazební tabulce sdílené s komponentou PLA.

1.5.18.1 VYM – Definiční data komponenty

1.5.18.1.1 Standardní definice

Pro aktualizaci hodnot komponenty je možné využít tyto atributy její události:

¨ 1,

¨ Částka v ZM (penále).

bez aplikace podmínky. Komponenta má umožněno zrcadlové storno, šablony komponenty nedisponují speciálním vyprogramovaným vstupem šablony. Události lze aplikovat pouze v rámci operace, jejíž druh nemá parametry.

1.5.18.1.2 Definice algoritmu vymáhání

Algoritmus vymáhání (uváděný v události PLA) definuje implicitní denní procento penále a postup vymáhání, který dále definuje úkon vymáhání v závislosti na počtu dnů po splatnosti (události PLA) a související text (z IC) s případnou změnou procenta penále.

Postup vymáhání se uplatní při využití funkce pro automatické generování událostí VYM z označených událostí PLA při zvolení varianty generování Podle dat (dnů) nebo (textů).

Při volbě varianty podle dnů IS BM nalezne v postupu vymáhání odpovídající (záznam splňující podmínku „zadané datum - datum splatnosti => dny“ s nejnižším hodnotou dnů) úkon vymáhání.

Při volbě varianty podle textů IS BM nalezne v postupu vymáhání první neuskutečněný (neexistuje relevantní událost VYM) úkon vymáhání. Jsou-li uskutečněny všechny, opakuje poslední.

V obou uvedených variantách je odpovídající událost VYM vygenerována pouze v případě, že dosud vygenerována nebyla. Pro stanovení procenta penalizace se agreguje procento uvedené v algoritmu a změny procenta uvedené dle dnů v postupu vymáhání. Do generované události VYM se přenáší text z postupu vymáhání.

Postup vymáhání se neuplatní při automatickém generování událostí VYM při zvolení varianty generování Upomínky nebo Penále. V tomto případě se penále počítá pouze dle údaje uvedeného u algoritmu vymáhání.

1.5.18.2 VYM - Logické věci komponenty

Jako aktér je aplikován aktér z IC a jeho spojení. Alokace a artikl nejsou aplikovány.

1.5.18.3 VYM – Událost

Události je možné členit dle druhu úkonu vymáhání (upomínka, penále, …) a dle dalších atributů. Mezi nejvýznamnější atributy kromě standardních patří datum pro kalendář vymáhání (ke kterému se vymáhá), vymáhaná částka a její měna, počet dnů, částka v ZM (penále) a standardizovaný volný text z IC.

Programový kód zajišťuje buď automatizované vygenerování událostí VYM pomocí funkce Události plateb v menu Volby z označených událostí PLA se současným propojením události PLA a VYM ve vazební tabulce nebo tato předplnění atributů:

¨ datum události a datum pro kalendář vymáhání aktuálním datem,

¨ měna měnou uvedenou u adresáta.

V případě generování událostí VYM z označených plateb definuje uživatel:

¨ datum, ke kterému se vymáhá, tj. ke kterému se počítají dny po splatnosti, resp. dny od poslední penalizace,

¨ variantu automatizace, která v případě:

¨ Upomínky – vygeneruje události VYM s úkonem Upomínka, nezávisle na postupu vymáhání,

¨ Penále – vygeneruje události VYM s úkonem Penalizace, nezávisle na postupu vymáhání; pro výpočet penále bude užito procento penalizace z algoritmu,

¨ Podle dat (dny) – vygeneruje události VYM dle postupu vymáhání a dnů po splatnosti (postup versus událost PLA),

¨ Podle dat (texty) - vygeneruje události VYM dle posloupnosti úkonů v postupu vymáhání,

¨ omezení výší vypočteného penále – události VYM (úkon penále), ve kterých by vypočtené penále nepřesáhlo uvedené omezení se nevygenerují,

¨ text – text ze seznamu volných textů (IC), který bude do událostí VYM vložen v případě varianty generování Upomínky nebo Penále, v ostatních případech je vložen text z postupu vymáhání dle dnů po splatnosti.

Následně jsou ve vygenerovaných událostech předplněny atributy:

¨ datum vzniku události aktuálním datem,

¨ datum, ke kterému je vymáháno, datem zadaným ve funkci pro generování událostí VYM,

¨ popis, adresát a měna dle relevantních údajů události PLA,

¨ základní částka hodnotou dosud neuhrazeno v ZM v platbě,

¨ dny počtem dnů od posledního vymáhání typu penalizace nebo od poslední částečné úhrady v případě události vymáhání, v ostatních případech dny po splatnosti,

¨ částka v ZM (pouze v případě penále, jinak nula) sumou částek vypočtených za jednotlivé intervaly, kde počátek je datum splatnosti, konec je datum zadané při generování, zlomové body jsou data úhrady a data vypočtená dle dnů po splatnosti uvedená v postupu vymáhání definujících změnu procenta penále, od které jsou odečteny již evidovaná penále (události VYM s úkonem penále) v uvedeném období; v intervalu je částka násobkem „neuhrazeno v ZM v období intervalu“, „délka intervalu ve dnech“ a „procento penále platné v období intervalu/100“.

V okamžiku aktualizace událostí VYM jsou aktualizovány odpovídající atributy platby dle dnů postupu vymáhání.

Na záložce činnosti prezentující události VYM jsou k dispozici atributy relevantní události PLA, pokud byla propojena, a tu pak lze z menu Volby spustit. Na labelu Adresát jsou k dispozici relevantní údaje.

1.5.19 Komponenta VYV

Užití této komponenty se předpokládá v souvislosti s obecným zaznamenáním informace, například sdílené autorizované poznámky v čase vztažené k adresátovi s přístupem řízeným přístupovými právy k tématu.

1.5.19.1 VYV - Definiční data komponenty

1.5.19.1.1 Standardní definice

Pro aktualizaci hodnot komponenty je možné využít hodnoty 1 bez aplikace podmínky. Komponenta nemá umožněno zrcadlové storno, šablony komponenty disponují speciálním vyprogramovaným vstupem šablony s možností přenesení označených adresátů. Události je možné aplikovat i mimo rámec operace, v takovém případě se jako téma uvádí druh operace. Druh operace nemá parametry.

1.5.19.1.2 Významné uzly vývěsky

Definice významných uzlů (tj. událostí) umožňuje uživatelsky do skupinové položky menu VÝZNAMNÉ UZLY vložit listové položky definované v činnosti Uzly vývěsky (za použití ikony pro vytváření objektových vazeb mezi objekty).

Spuštěním těchto listových položek menu se aktivuje činnost prezentující seznam připojených objektů (událostí VYV) jako následník k relevantnímu uzlu vývěsky.

1.5.19.2 VYV - Logické věci komponenty

Jako aktér je aplikován adresát z informačního centra společně.

Téma ztotožněné s druhem operace, tj. dle něj jsou řízena přístupová práva k událostem, je z hlediska aktuálních hodnot alokací.

Artikl není aplikován.

1.5.19.3 VYV - Událost

Události je možné členit na různé druhy dle tématu, tj. dle druhu operace. Mezi významné atributy kromě standardních patří atribut „blokování“, který zajistí, že nikdo kromě autora události ji nemůže modifikovat, a to ani poznámku, a zdroj informace ze seznamu uživatelů.

Programový kód zajišťuje tato předplnění atributů:

¨ téma tématem, na kterém je kurzor, pokud se jedná o vstup mimo operaci, v opačném případě druhem operace,

¨ adresáta neuvedeným adresátem, tj. „-“,

¨ číslo spojení adresáta implicitním spojením,

¨ datum aktuálním datem,

¨ text názvem tématu, pokud není text uveden uživatelem,

¨ zdroj informace přihlášeným uživatelem.

V okně s činností prezentující události VYV jsou k dispozici ikony pro aktivaci a deaktivaci zobrazení následníků či předchůdců dle objektových vazeb, událostí daného tématu (též pravý klik na label Téma) či adresáta (automatické rozšíření běžného výběru), pokud se nejedná o zobrazení událostí dané operace.

V menu Volby je k dispozici funkce Štítek adresáta, která prezentuje jeho aktuální adresní údaje, a funkce pro zobrazení stromu vývěsky, tj. objektově propojených událostí vývěsky.

V menu Obecné je k dispozici funkce Informace o aktualizaci, pomocí které lze zobrazit seznam (kdo a kdy) realizovaných modifikací atributů dané události.

1.5.19.4 VYV - Jiné

Transformace do VYV předplní do atributu zdroj informace autora zdrojové události, třebaže to není explicitně definováno v pravidle.

V případě volby funkce Nový dokument v okně spojených dokumentů IS BM předplní typ dokumentu dle posledního takto založeného dokumentu k danému tématu daným uživatelem.

1.5.20 Komponenta ZAL

Užití této komponenty se předpokládá v souvislosti se správou a evidencí poskytnutých i přijatých finančních záloh, tj. s úhradou (přijetím či poskytnutím) zálohy a vyúčtováním zálohy.

Mezi významné tabulky komponenty kromě standardizovaných patří karta zálohy dostupná v položce menu Přehled záloh, kde jsou uvedeny údaje o jednotlivých úhradách a vyúčtováních dané zálohy (na záložkách) i tyto sumární údaje:

¨ Částka v MÚ – suma všech úhrad (tj. suma odpovídajícího atributu všech událostí s charakterem „úhrada“ obsahujících identifikaci dané karty) vyjádřená v měně úhrady zálohy, tj. v měně, ve které jsou úhrady a vyúčtování související s danou kartou záloh vzájemně vyhodnocovány.

¨ Zbývá vyúčtovat - obsahuje rozdíl předchozího atributu a sumy všech vyúčtování (tj. sumy atributu Částka v MÚ všech událostí s charakterem „vyúčtování“ obsahujících identifikaci dané karty). V případě, že tento atribut karty má hodnotu nula, je taková karta zálohy považována za vyúčtovanou (v opačném případě za nevyúčtovanou, která se zobrazuje modře).

Každá karta zálohy je identifikována adresátem, identifikátorem zálohy, měnou úhrady a typem zálohy (přijatá/poskytnutá), dle těchto atributů v jednotlivých událostech je karta zálohy automaticky (programovým kódem) aktualizována.

Dále mezi významné tabulky komponenty patří vazební entita evidující vztah mezi událostí úhrady a související událostí vyúčtování a hodnotu, která byla vyúčtována v MÚ. Tato tabulka je automaticky plněna programovým kódem při zápisu události vyúčtování na základě aplikace metody FIFO. Dle této tabulky jsou zobrazovány záznamy na záložkách událostí záloh.

1.5.20.1 ZAL - Definiční data komponenty

1.5.20.1.1 Standardní definice

Pro aktualizaci hodnot komponenty je možné využít tyto atributy její události:

¨ 1,

¨ částka v ZM,

¨ částka v RM,

¨ kurzový rozdíl,

¨ částka v MÚ,

¨ zbývá vyúčtovat.

s případnou aplikací podmínky: úhrady nebo vyúčtování. Hodnotu nelze definovat jako obrat.

Komponenta má definováno zrcadlové storno, šablony komponenty nedisponují speciálním vyprogramovaným vstupem šablony. Události lze aplikovat pouze v rámci operace, jejíž druh nemá parametry.

1.5.20.2 ZAL - Logické věci komponenty

Jako aktér je implementován aktér z IC společně se spojením adresáta. Jako alokace je aplikováno umístění záloh, jehož atributem je organizační selektor. Z hlediska aktuálních hodnot se měna úhrady (MÚ) chová jako artikl (pokud je nastaveno „Nerozlišuje artikl“ musí být v číselníku měn uvedena měna s identifikátorem “-“).

1.5.20.3 ZAL – Událost

Události je možné členit na zálohy přijaté nebo poskytnuté a na úhrady nebo vyúčtování. Programový kód zajišťuje tato předplnění atributů:

¨ id zálohy dle id hlavního procesu,

¨ kurz dle kurzovního lístku a parametrů oceňování,

¨ částku v RM dle kurzu,

¨ měnu úhrady zahraniční měnou.

Událost této komponenty aktualizuje kromě uživatelsky nastavených aktuálních hodnot i údaje na referované kartě záloh (včetně založení a zrušení karty) na základě programového kódu takto:

¨ Pokud se jedná o zápis události charakteru „úhrada“, přičte se hodnota atributu události „Částka v MÚ“ do atributu „Částka v MÚ“ i do atributu „Zbývá vyúčtovat“ karty se shodnou identifikací. Pokud taková karta neexistuje, je automaticky založena. Současně je tato hodnota zapsána i do atributu „Dosud nevyúčtováno“ dané události.

¨ Pokud se jedná o zápis události charakteru „úhrada“, odečte se hodnota atributu události „Částka v MÚ“ z atributu „Zbývá vyúčtovat“ karty se shodnou identifikací. Pokud taková karta neexistuje, není možné vyúčtování zapsat. Současně se vyhledají nevyúčtované (jejich atribut „Dosud nevyúčtováno“ >0) události úhrad se shodnou identifikací a v pořadí daném metodou FIFO se v nich sníží hodnota atributu „Dosud nevyúčtováno“ (automatické párování) až do celkové výše atributu „Částka v MÚ“ události vyúčtování. Události úhrad referované danou událostí vyúčtování se zaznamenají do vazební tabulky včetně výše v MÚ, ve které vyúčtování dané úhrady daným vyúčtováním proběhlo. V případě, že se MÚ liší od RM, je současně do události vyúčtování vypočten kurzový rozdíl oproti událostem úhrad.

Tu událost úhrady, která byla alespoň částečně vyúčtována, nelze již z hlediska relevantních hodnot (id, RM a MÚ) aktualizovat.

V seznamu událostí záloh se zobrazují modře nevyúčtované zálohy (atribut „Dosud nevyúčtováno“ >0). Na záložkách jsou k dispozici relevantní (dle záznamů ve vazební entitě) události úhrad nebo vyúčtování záloh.

Předlohy výstupu umožňují definovat pohyb v souvisejících úhradách/vyúčtováních.

1.5.20.4 ZAL - Jiné

S touto komponentou může souviset atribut „záloha“ v události platby, pokud je tomu tak uživatelsky nastaveno v relevantních druzích procesů.

1.5.21 Komponenta ZSP

Užití této komponenty se předpokládá v souvislosti se správou a evidencí finančních prostředků dle jednotlivých alokací a měn, tj. například pokladní a bankovní evidence, a dále v souvislosti s uhrazováním plateb (evidovaných v komponentě PLA – platby).

Mezi významné tabulky komponenty kromě standardizovaných patří definice komunikace s bankou a tabulka (přehled spárování) sdílená s komponentou PLA se záznamy o vztahu události PLA a události ZSP s významem: výše uhrazené částky v ZM z dané platby zde uvedenou částkou v ZM z dané změny (příjem/výdej) stavu peněz. Mezi dvěmi událostmi PLA a ZSP může být několik těchto vazeb.

1.5.21.1 ZSP – Definiční data komponenty

1.5.21.1.1 Standardní definice

Pro aktualizaci hodnot komponenty je možné využít tyto atributy události ZSP:

¨ 1,

¨ částka v ZM,

¨ částka v RM,

¨ částka v MÚ.

bez aplikací podmínky. Hodnotu lze definovat jako obrat.

Komponenta má definováno zrcadlové storno, šablony komponenty disponují speciálním vyprogramovaným vstupem šablony pro hromadný vstup z plateb a pro přijetí výpisu z banky (tj. načtení souboru z bankovního systému). Události lze aplikovat pouze v rámci operace, jejíž druh nemá parametry.

1.5.21.1.2 Definice komunikace s bankou

Definice komunikace s bankou umožňuje uživatelsky definovat soubor a jeho strukturu, ze kterého budou importována data (transformována do struktur IS BM) týkající se změn stavu peněz na daném účtu po využití šablony pro přijetí výpisu z banky při automatizaci vstupu událostí operace ZSP.

Podobně umožňuje uživatelsky definovat soubor a jeho strukturu, do kterého budou exportována data (transformována ze struktur IS BM) týkající se příkazu k úhradě.

Tyto definice lze pomocí balíčku přenášet mezi nezávislými implementacemi IS BM.

Funkce související s komunikací s bankou ovlivňují i nastavení v souboru BW.INI v sekci [KomunikaceBanka], a to:

¨ DataExport=adresář; definuje adresář, do kterého se budou exportovat soubory s příkazy k úhradě,

¨ DataImport= adresář; definuje adresář, ve kterém bude soubor reprezentující bankovní výpis, ze kterého se budou šablonou importovat události ZSP,

¨ CisloUctu=Ano; definuje, že v rámci importu výpisu z banky se v IS BM vyhledá adresát, jehož účet (prefix účtu, číslo účtu, identifikace banky a specifický symbol) se shoduje s účtem importovaným, a ten se předplní do události ZSP.

1.5.21.2 ZSP – Logické věci komponenty

Jako aktér je implementován adresát z IC společně se spojením adresáta a s bankovním spojením adresáta.

Jako alokace je aplikováno umístění změny stavu peněz (tj. například pokladna, bankovní účet, fiktivní účet, …). Alokace (účty/pokladny) referuje:

¨ některé z bankovních spojení adresáta, na kterého byla aplikována funkce „Označení sebe“ naposledy před definicí alokace, alokace dědí vlastnosti bankovního spojení adresáta (účet nebo pokladna, kód a adresát banky, číslo účtu, měna, …),

¨ účet v účetní osnově, který bude k dispozici jako výstupní atribut komponenty v transformacích,

¨ definici komunikace s bankou,

¨ organizační selektor.

Činnost prezentující seznam účtů a pokladen umožňuje na záložce k dané alokaci zobrazit stav aktuálních hodnot.

Z hlediska aktuálních hodnot se měna účtu uvedená v události (MÚ) chová jako artikl (pokud je nastaveno „Nerozlišuje artikl“ musí být v číselníku měn uvedena měna s identifikátorem “-“).

1.5.21.3 ZSP – Událost

Události je možné členit zejména na credity či debety a na párované nebo nepárované. Pro párované je k dispozici funkce, která zajistí jejich automatické zařazení do přehledu spárování. Programový kód zajišťuje tato předplnění atributů:

¨ měnu částky v ZM měnou uvedenou u alokace (účtu/pokladny), resp. relevantního bankovního spojení,

¨ kurz dle kurzovního lístku a parametrů oceňování,

¨ částku v RM dle kurzu v události a částky v ZM,

¨ měnu účtu dle měny uvedené u alokace, je-li to bankovní účet, nebo dle měny dané události, je-li to pokladna,

¨ částku v MÚ (měně účtu), pokud je měna účtu shodná s měnou události nebo s RM,

¨ obchodní a organizační selektor,

¨ banka a číslo účtu adresáta dle jeho bankovního spojení, pokud dosud nejsou vyplněny, a opačně adresát a jeho spojení dle banky, čísla účtu a specifického symbolu, pokud jsou již vyplněny,

¨ pořadí položky na výpisu dle pořadí vstupu události do operace (uživatel nemá právo modifikovat),

¨ atribut „Částka byla spárovaná s platbami“, pokud se jedná o nepárovanou položku.

Po zápisu změn spárování dochází k aktualizaci:

¨ adresáta adresátem z platby,

¨ atributu „Částka v ZM spojená se všemi platbami“ přičtením uhrazující hodnoty v ZM ze spárování,

¨ atributu „Částka byla spárovaná s platbami“, pokud suma částky všech spárování v ZM je shodná s částkou v ZM v události ZSP.

Na záložkách jsou k dispozici relevantní (dle záznamů ve vazební entitě s přehledem spárování) události plateb a relevantní (dle míry plnění) události účtování.

V seznamu událostí ZSP se zobrazují červeně ty, u kterých ve vazbě mírou plnění do událostí komponenty UCE není žádný záznam a současně není uživatelsky nastaven atribut zaúčtováno.

V seznamu událostí ZSP se zobrazují modře ty, u kterých ve vazbě mírou plnění do událostí komponenty UCE existuje alespoň jeden záznam, ale suma hodnot v těchto záznamech událostí UCE se nerovná hodnotě částky v RM události ZSP.

1.5.21.3.1 Přehled spárování

K nejvýznamnějším funkcím činnosti prezentující seznam událostí ZSP kromě standardních patří funkce přehled spárování aktivovaná z menu Volby, která umožňuje události ZSP spárovat s událostmi plateb, resp. spárování prohlížet. Po aktivaci této funkce (činnosti) se zobrazí okno se seznamem událostí z operace ZSP, na jejíž události je kurzor, a to pouze těch, které mají atribut párovat nastaven na Ano.

V případě, že některá událost ZSP je již spárována s událostmi plateb, tak se k ní tyto platby zobrazují v dolní části okna včetně údaje jaká hodnota platby v ZM byla uhrazena (vpravo) zde uvedenou uhrazující hodnotou (vlevo) z události ZSP v ZM. Zde opět v menu Volby jsou k dispozici funkce pro uskutečnění párování:

¨ párování plateb: tímto je aktivována činnost s přehledem plateb a v ní uživatelem vybrané a označené platby se následně automatizovaně spárují s tou událostí změny stavu peněz, na které zde stál kurzor v okamžiku aktivace párování plateb,

¨ párování na platby: uživatel je vyzván k zadání kritérií (mezi uživatelsky volitelná kritéria patří shoda variabilního symbolu, čísla účtu a částky v událostech PLA a ZSP, IS BM dále jako kritérium uplatní shodu měny) pro automatický výběr plateb ke spárování a k volbě, zda automaticky párovat pouze událost ZSP s kurzorem (v tom případě „zaškrtne“ atribut aktualizovat všechny) nebo všechny zobrazené; dle zadaných parametrů IS BM provede automatizované spárování.

Po uplatnění některé z funkcí pro párování se v dolní části okna s přehledem spárování zobrazí spárované platby. K jedné události ZSP zde může být spárováno několik plateb. Automatizované párování je omezeno ze strany události ZSP částkou v ZM a ze strany platby neuhrazenou částkou v ZM, které nepřekročí.

Dále jsou v menu Volby funkce pro:

¨ spuštění operace platby, na které je v dolní části obrazovky kurzor,

¨ zrušení párování (F8) s tou platbou, na které je v dolní části obrazovky kurzor,

¨ změna výše uhrazené či uhrazující částky spárování (F4) s tou platbou, na které je v dolní části obrazovky kurzor.

V případě, že došlo ke změnám v párování (nové, oprava párované částky), je daný záznam automaticky označen; v případě zrušení párování označuje uživatel. Dle označených záznamů dochází při ukončení činnosti přehled spárování k aktualizaci vazebního souboru (událost PLA – ZSP a přehledem spárování) a k aktualizaci relevantních údajů platby i události ZSP.

1.5.21.4 ZSP – Jiné

Po ukončení operace ZSP obsahující spárované události s platbou se aktivuje (resp. uvede do stavu připravena) cílový uzel definovaný v dynamickém spojení operací vazbou: ZSP - platby zaúčtování platby. Podobně dochází k aktivaci tohoto uzlu po každé změně ve spárování v již ukončené operaci ZSP.

1.6 Správa IS BM

Správa IS BM kromě nastavování logiky IS (zejména definiční data uvedená v předchozích kapitolách a uživatelské triggery) spočívá též v instalaci a nastavení konfiguračních dat mimo databázi, aktualizaci definic pomocí balíčků, archivaci, replikaci dat a optimalizaci relevantního SW (např. Windows, MS Excel, Sybase SQL Anywhere, poštovní server), HW a přenosových sítí, tj. v nastavení produktů třetích stran.

1.6.1 Produkty třetích stran

Provozování IS Bílý Motýl vyžaduje určité prostředí (IT infrastrukturu), přičemž některé prvky tohoto prostředí jsou zcela nezbytné, jiné jsou potřebné pro určitou funkcionalitu a další jsou volitelně aplikovatelné. K těmto produktům je licence pořizována ze strany koncového uživatele (zákazníka) za podmínek, které stanoví příslušný výrobce či distributor.

Mezi zcela nezbytné prvky IT infrastruktury patří databázový systém Sybase® SQL Anywhere®, operační systém stanic na bázi MS Windows, operační systém serveru na bázi Windows Server anebo LINUX. V operačních systémech je pro dosažení určité funkcionality nutné jejich nastavení (například MS Windows nastavení v registrech).

Pro prezentaci výkazů je potřebný MS Excel, pro prezentaci výstupů ve formátu .doc je potřebný MS Word, pro automatizované odesílání e-mailů MS Outlook, pro zajištění replikací je nezbytný SQL Remote a případné další produkty mnohdy i specifické pro daného koncového uživatele.

Při realizaci přístupu k IS BM z prostředí Internetu internetovým browserem je nezbytný MS Internet Information Server.

S každou aktuální verzí IS BM musí být provozovány relevantní verze produktů třetích stran.

1.6.1.1 Databázový systém

Databázový systém Sybase® SQL Anywhere® (dále jen SQL) se skládá z databázového serveru a s ním komunikujících klientů a případně je doplněn nástrojem pro replikaci SQL Remote. Licence (tj. oprávnění k užívání) se poskytuje na základě a za podmínek licenční smlouvy, kterou akceptujete při instalaci těchto produktů a kterou tím uzavíráte se společností Sybase Inc.

Zde si uveďme určitý zjednodušený výtah z této smlouvy, který z právního hlediska má jen orientační informativní charakter na rozdíl od licenční smlouvy.

Licence SQL se poskytuje vždy k serveru pro jediný operační systému (Windows nebo Linux), který spravuje databázi, a k zařízením (klientům), která komunikují v síti se serverem.

Za zařízení (klienta) se považuje každé specifické, identifikovatelné a unikátní vstupně / výstupní zařízení (obvykle PC, ale také PDA, čtečka čárového kódu, inteligentní stroj, snímač či měřidlo, …) schopné přímo nebo nepřímo komunikovat se serverem. V případě multiplexu, za který lze například považovat přístup pomocí vzdálené plochy apod., se započítává do počtu klientů každé koncové zařízení.

Licence SQL může být pořízena ve dvou variantách, a to na procesor (CPU) anebo na jednotlivá zařízení (klienty, dále Seat).

V případě licence na CPU máte oprávnění užívat SQL server na jediném HW serveru s jediným procesorem, se kterým komunikuje po síti neomezený počet zařízení, včetně neomezeného počtu internetových uživatelů.

V případě licence na Seat máte oprávnění užívat SQL server, se kterým komunikuje po síti nakoupený počet klientů (zařízení). Nakoupený počet klientů jste také oprávněni instalovat na odpovídající počet stanic.

Ve vztahu k IS BM za podmínky, že není realizován přístup z prostředí Internetu, lze z licenční smlouvy pravděpodobně dovodit, že maximální počet potřebných zařízení (klientů), a tedy i zařízení schopných užívat server, bude roven vyššímu číslu z těchto:

a) počet instalací klienta SQL nebo

b) rozsah licence k IS BM – uplatní se jen tehdy, je-li využit multiplex (např. vzdálená plocha),

Je-li realizován přístup z prostředí Internetu, je vhodnější pořízení CPU licence. Jedná-li se ovšem o identifikovatelné přístupy splňující definici zařízení dle licenční smlouvy, pak lze předpokládat, že by pravděpodobně byla použitelná licence i na seat, kde by se maximální počet potřebných zařízení (klientů) a tedy i zařízení schopných užívat server rovnal nejvyššímu číslu z těchto:

a) počet instalací klienta SQL nebo

b) rozsah licence k IS BM, je-li využit multiplex (např. vzdálená plocha) a počet instalovaných klientů je menší než rozsah licence k IS BM, nebo

c) počet aktivních uživatelů v tabulce uživatel (činnost Uživatelé programu v IS BM ).

1.7 Použité zkratky

AAA – aktér, alokace, artikl (logické věci - základní tabulky komponenty)

DIČ – daňové identifikační číslo plátce DPH

DPH – daň z přidané hodnoty; stejnojmenná komponenta

EI – externí identifikace

FIFO – metoda oceňování zásob

HW – hardware

IČ – identifikační číslo organizace

ID - identifikace

IDP – identifikátor párování salda v účetnictví

IDÚ – identifikace datového úložiště

IS – informační systém

IS BM – informační systém Bílý Motýl

MD – strana Má dáti v účetnictví

MÚ – měna účtu

MJ – měrná jednotka

OBC – komponenta Obchod

OS – operační systém

RM – referenční měna

RMJ – referenční měrná jednotka

SKP – standardní klasifikace produkce

SQL – system query language

SW – software

VČ – výrobní číslo

VS – variabilní symbol platby

ZM – zahraniční měna

1.8 Obsah

Specifikace IS Bílý Motýl®. 1

1.1 Úvod. 1

1.2 Logická architektura IS Bílý Motýl®. 1

1.2.1 Kategorizace entit 1

1.2.1.1 Objekty zájmu sledování 1

1.2.1.2 Atributy objektů zájmu sledování 2

1.2.1.3 Ostatní entity. 3

1.2.2 Dekompozice IS. 3

1.2.2.1 Standardizace komponent 3

1.2.2.2 Informační centrum.. 4

1.2.2.2.1 Operace. 5

1.2.2.2.2 Proces. 5

1.2.2.2.3 Statistické hodnoty, selektory, výkazy. 5

1.2.2.2.4 Další globální objekty IC.. 6

1.2.3 Zbývající prvky logické stavby IS. 6

1.3 Dostupnost funkcí a dat v rámci IS BM... 6

1.3.1 Systém menu. 6

1.3.2 Činnosti 7

1.3.2.1 Činnost typu „seznam“. 7

1.3.2.1.1 Volná karta. 11

1.3.2.2 Aktualizace dat 12

1.3.2.3 Prezentace informační schopnosti - výstupy. 13

1.3.2.3.1 Výstupy na základě předlohy výstupu. 13

1.3.3 Informační panely. 14

1.3.4 Uživatel a skupiny uživatelů. 15

1.3.5 Přístupová práva. 16

1.3.6 Personifikace a autorizace dat 16

1.3.7 Jazyk. 17

1.3.8 Slovník dat 17

1.3.9 Dokumentace. 18

1.4 Specifikace informačního centra IS BM... 18

1.4.1 Procesy. 18

1.4.1.1 Fyzické procesy a jejich řízení 19

1.4.1.1.1 Založení procesu. 19

1.4.1.1.2 Prohlížení a vyhledávání informací 19

1.4.1.1.3 Pokračování v procesu. 20

1.4.1.1.4 Modifikace struktury procesu a opravy. 20

1.4.1.1.5 Operace (fyzická operace) 21

1.4.1.2 Druh procesu. 22

1.4.1.2.1 Druh operace. 22

1.4.1.2.2 Diagram druhu procesu. 22

1.4.1.3 Modelování řídícího toku. 24

1.4.1.4 Modelování datového toku v procesech IS BM... 24

1.4.1.4.1 Šablona. 25

1.4.1.4.2 Vstupní maska operace. 25

1.4.1.4.3 Transformace a její pravidla, míra plnění 26

1.4.1.5 Související definice. 28

1.4.1.5.1 Procesní import 28

1.4.1.5.2 Definice vyvolání 29

1.4.1.5.3 Dynamická spojení operací 29

1.4.1.5.4 Prezentace procesu. 30

1.4.1.5.5 Saldokontní hodnoty procesu. 30

1.4.2 Objektové vazby. 30

1.4.3 Dokumenty. 31

1.4.3.1 Spouštěné aplikace. 32

1.4.4 Agregované informace (manažerské řízení) 32

1.4.4.1 Statistické hodnoty. 32

1.4.4.2 Selektory. 33

1.4.4.3 Výkazy. 33

1.4.4.3.1 Sestavení výkazu. 33

1.4.4.3.2 Definice výkazu. 34

1.4.4.3.3 Nástroje pro usnadnění definice listu. 35

1.4.5 Jiné objekty informačního centra. 36

1.4.5.1 AAA - Logické věci 36

1.4.5.1.1 Adresát 36

1.4.5.1.2 Artikl, druh artiklu, SKP. 39

1.4.5.2 Oceňování 40

1.4.5.2.1 Banky, měny a kurzy. 40

1.4.5.2.2 Ceník. 41

1.4.5.2.3 Cenová skupina. 42

1.4.5.3 Obecné předkontace, volné texty a konstanty. 42

1.5 Specifikace komponent IS BM... 43

1.5.1 Vlastnosti standardizované komponenty. 44

1.5.1.1 Aktér 44

1.5.1.2 Alokace. 44

1.5.1.3 Artikl 44

1.5.1.4 Hodnoty. 45

1.5.1.5 Událost 46

1.5.2 Komponenta DPH.. 47

1.5.2.1 DPH - Definiční data komponenty. 47

1.5.2.1.1 Standardní definice. 47

1.5.2.1.2 Typ zdanitelného plnění 47

1.5.2.1.3 Daňová přiznání 48

1.5.2.2 DPH - Logické věci komponenty. 48

1.5.2.3 DPH - Událost 48

1.5.2.4 DPH - Jiné. 49

1.5.3 Komponenta MZD (na výstupu) 49

1.5.3.1 MZD – Definiční data komponenty. 49

1.5.3.1.1 Standardní definice. 49

1.5.3.1.2 Druhy událostí 51

1.5.3.2 MZD – Logické věci komponenty. 51

1.5.3.3 MZD – Událost 51

1.5.4 Komponenta MZV (na vstupu) 51

1.5.4.1 MZV – Definiční data komponenty. 51

1.5.4.1.1 Standardní definice. 51

1.5.4.2 MZV – Logické věci komponenty. 52

1.5.4.3 MZV – Událost (úkolové listy - vstup) 52

1.5.5 Komponenta MZX.. 52

1.5.5.1 MZX - Definiční data komponenty. 52

1.5.5.1.1 Standardní definice. 52

1.5.5.1.2 Inicializace. 52

1.5.5.2 Karta pracovníka. 52

1.5.5.3 Definice položek mezd. 53

1.5.5.3.1 Doplňující údaje k příjmům.. 53

1.5.5.4 Parametry. 53

1.5.5.5 Parametry nemocenských dávek. 54

1.5.5.6 Parametry nemocenského pojištění 54

1.5.5.7 Číselníky. 54

1.5.5.8 Výčetka platidel 54

1.5.5.9 Nepřítomnost pro nemoc. 54

1.5.5.10 Výplatní lístky a jejich výpočet 55

1.5.5.11 Uzávěrka mezd. 56

1.5.5.12 Roční zúčtování daně. 56

1.5.5.13 MZX – Logické věci komponenty. 56

1.5.5.14 MZX – Událost 56

1.5.6 Komponenta OBC.. 56

1.5.6.1 OBC - Definiční data komponenty. 57

1.5.6.1.1 Standardní definice. 57

1.5.6.1.2 Ostatní 57

1.5.6.2 OBC - Logické věci komponenty. 58

1.5.6.3 OBC – Událost 58

1.5.7 Komponenta ODP. 60

1.5.7.1 ODP – Definiční data komponenty. 60

1.5.7.1.1 Standardní definice. 60

1.5.7.1.2 Parametry. 60

1.5.7.1.3 Tabulka odpisových skupin. 61

1.5.7.1.4 Tabulka koeficientů pro odpis a opravné položky pohledávek. 61

1.5.7.2 ODP - Logické věci komponenty. 61

1.5.7.3 ODP – Událost 62

1.5.7.3.1 ODP – Událost (investiční majetek) 62

1.5.7.3.2 ODP – Událost (odpis a opravné položky pohledávek) 63

1.5.7.4 ODP – Jiné. 64

1.5.8 Komponenta OKO.. 64

1.5.8.1 OKO - Definiční data komponenty. 64

1.5.8.1.1 Standardní definice. 64

1.5.8.2 OKO - Logické věci komponenty. 64

1.5.8.3 OKO – Událost 64

1.5.9 Komponenta PLA.. 65

1.5.9.1 PLA - Definiční data komponenty. 65

1.5.9.1.1 Standardní definice. 65

1.5.9.1.2 Parametry. 65

1.5.9.2 PLA - Logické věci komponenty. 66

1.5.9.3 PLA – Událost 66

1.5.9.4 PLA – Jiné. 67

1.5.10 Komponenta POS. 68

1.5.10.1 POS – Definiční data komponenty. 68

1.5.10.1.1 Standardní definice. 68

1.5.10.1.2 Další definice. 68

1.5.10.2 POS - Logické věci komponenty. 69

1.5.10.3 POS – Událost 69

1.5.10.4 POS – Jiné. 70

1.5.11 Komponenta PZM... 70

1.5.11.1 PZM – Definiční data komponenty. 70

1.5.11.1.1 Standardní definice. 70

1.5.11.1.2 Parametry. 70

1.5.11.2 PZM – Logické věci komponenty. 70

1.5.11.3 PZM – Událost 71

1.5.11.4 PZM – Jiné. 71

1.5.11.4.1 Import z Českého úřadu zeměměřického a katastrálního. 71

1.5.11.4.2 Listy vlastnictví 72

1.5.11.4.3 Oprávněné subjekty. 72

1.5.11.4.4 Katastry nemovitostí 72

1.5.12 Komponenta PZP. 72

1.5.12.1 PZP – Definiční data komponenty. 72

1.5.12.1.1 Standardní definice. 72

1.5.12.2 PZP – Událost 73

1.5.13 Komponenta REZ.. 73

1.5.13.1 REZ – Definiční data komponenty. 73

1.5.13.1.1 Standardní definice. 73

1.5.13.2 REZ - Logické věci komponenty. 74

1.5.13.3 REZ – Událost 74

1.5.14 Komponenta SKL.. 74

1.5.14.1 SKL - Definiční data komponenty. 75

1.5.14.1.1 Standardní definice. 75

1.5.14.1.2 Základní druhy hodnot 75

1.5.14.2 SKL - Logické věci komponenty. 75

1.5.14.3 SKL – Událost 76

1.5.14.4 SKL – Jiné. 77

1.5.15 Komponenta SKZ.. 77

1.5.15.1 SKZ – Definiční data komponenty. 77

1.5.15.1.1 Standardní definice. 77

1.5.15.1.2 Parametry. 78

1.5.15.2 SKZ – Logické věci komponenty. 78

1.5.15.3 SKZ - Událost 79

1.5.15.4 SKZ – Jiné. 79

1.5.16 Komponenta SMU.. 80

1.5.16.1 SMU – Definiční data komponenty. 80

1.5.16.1.1 Standardní definice. 80

1.5.16.2 SMU - Logické věci komponenty. 80

1.5.16.3 SMU – Událost 81

1.5.17 Komponenta UCE.. 81

1.5.17.1 UCE - Definiční data komponenty. 81

1.5.17.1.1 Standardní definice. 81

1.5.17.1.2 Účtový rozvrh. 82

1.5.17.1.3 Parametry a účetní období 82

1.5.17.2 UCE – Událost 82

1.5.17.3 UCE – Jiné. 84

1.5.17.3.1 Účetní saldokonto. 84

1.5.17.3.2 Obratová tabulka a konta. 84

1.5.18 Komponenta VYM... 85

1.5.18.1 VYM – Definiční data komponenty. 85

1.5.18.1.1 Standardní definice. 85

1.5.18.1.2 Definice algoritmu vymáhání 85

1.5.18.2 VYM - Logické věci komponenty. 85

1.5.18.3 VYM – Událost 85

1.5.19 Komponenta VYV.. 86

1.5.19.1 VYV - Definiční data komponenty. 87

1.5.19.1.1 Standardní definice. 87

1.5.19.1.2 Významné uzly vývěsky. 87

1.5.19.2 VYV - Logické věci komponenty. 87

1.5.19.3 VYV - Událost 87

1.5.19.4 VYV - Jiné. 87

1.5.20 Komponenta ZAL.. 88

1.5.20.1 ZAL - Definiční data komponenty. 88

1.5.20.1.1 Standardní definice. 88

1.5.20.2 ZAL - Logické věci komponenty. 88

1.5.20.3 ZAL – Událost 88

1.5.20.4 ZAL - Jiné. 89

1.5.21 Komponenta ZSP. 89

1.5.21.1 ZSP – Definiční data komponenty. 89

1.5.21.1.1 Standardní definice. 89

1.5.21.1.2 Definice komunikace s bankou. 90

1.5.21.2 ZSP – Logické věci komponenty. 90

1.5.21.3 ZSP – Událost 90

1.5.21.3.1 Přehled spárování 91

1.5.21.4 ZSP – Jiné. 92

1.6 Správa IS BM... 92

1.6.1 Produkty třetích stran. 92

1.6.1.1 Databázový systém.. 93

1.7 Použité zkratky. 93

1.8 Obsah. 94

V Českých Budějovicích dne . . . . . . . . . . . | V . . . . . . . . . . . . . . . . dne . . . . . . . . . . .
Autor | Nabyvatel

[1] Tímto je míněn faktický kurz, který vyplývá z hodnot uvedených ve spárování, nikoliv kurz uvedený v událostech.


Procesy

O B S A H

Procesy v IS Bílý Motýl®. 1

1. Co je to proces?.. 1

2. Druh procesu.. 2

2.1 Základní vlastnosti druhu procesu. 2

2.2 Související vlastnosti druhu procesu. 3

2.3 Modelování řídícího a datového toku. 14

3. Fyzické procesy a jejich řízení 17

3.1 Založení procesu (tj. spuštění) 17

3.2 Prohlížení a vyhledávání informací 17

3.3 Pokračování v procesu. 18

3.4 Opravy. 18

4. Tipy a triky.. 18

Procesy v IS Bílý Motýl®

Motto:

„Informační systém Bílý Motýl nemá chyby, vždy se jedná pouze o vlastnosti”.

Z hlediska informačního systému Bílý Motýl se jedná o celou oblast operativního řízení, tj. transakční část IS, s tím, že vlastnosti jednotlivých komponent nejsou popsány uceleně, ale jen v rozsahu nutném pro popis chování procesů.

Složka dokumentace PROCESY V IS BÍLÝ MOTÝL je interním dokumentem společnosti BM Servis s.r.o. (tomu odpovídají vysvětlující poznámky a použité příklady). Jednotlivé hypertextové odkazy jsou zpracovávány tak, že v každé kapitole je hypertextový odkaz na určitý pojem vytvořen pouze jedenkrát (např. pokud je tedy v kapitole 2.2.1 Druh operace několikrát použit pojem „druh operace“, je v textu vytvořen pouze jeden hypertextový odkaz na tento pojem). Toto opatření je proto, aby složky dokumentace nebyly „zahlceny“ odkazy do slovníku pojmů a uživatel si nekomplikoval čtení tím, že si stejný pojem spustí několikrát.

Pro seznámení se s každou složkou dokumentace se jako nejvhodnější způsob jeví elektronická podoba. Při čtení tištěné podoby uživatel musí mezi jednotlivými pojmy listovat, čímž částečně ztrácejí na efektu vytvořené hypertextové odkazy a uživatel se při listování a hledání pojmů „ztrácí“ a v některých případech je odkaz vytvořen na hesle, které nekoresponduje přesně s heslem ve slovníku pojmů, přičemž pojmově se jedná o shodná hesla, ale v textové podobě a listováním v dokumentaci toto uživatel nenajde. V elektronické podobě se uživatel pohodlně mezi jednotlivými hypertextovými odkazy přepíná a šipkou vrací zpět k původnímu heslu, což je jistě mnohem příjemnější a efektivnější způsob práce.

1. Co je to proces?

Proces v reálném světě je posloupnost určitých změn stavu reálného světa. Obvykle tyto změny mají kauzální (příčinnou) souvislost. Příkladem procesu v reálném světě může být např. výroba nábytku. Ze dřeva se hrubým opracováním stává surovina, která se vysoustruhuje, ohobluje apod., tím se změní v polotovar se kterým se dále pracuje (např. natře se barvou, moří se, lakuje apod.) a který se po těchto úpravách mění ve finální výrobek. Dalším procesem v reálném světě je např. stárnutí (ať už třeba materiálu nebo živého organismu).

Zatímco první proces (výroba nábytku) lze a může být i zajímavé zachytit (modelovat) v informačním systému, druhý proces z reálného světa (stárnutí) většina informačních systémů modelovat neumí (v podstatě ho naprosto ignorují).

Jako zajímavé řešení se jeví určité procesy reálného světa, které jsou si podobné (resp. blízké), modelovat a pro tento účel je zaveden pojem druh procesu. Jedním z cílů modelování je sestavení BPM (podrobnější informace se nacházejí v dokumentaci „úvodní informace k informačnímu systému Bílý Motýl”, kapitola BPM). Jiným z cílů modelování je dosažení standardizace chování procesu tak, aby bylo možno reálný proces podpořit informačním systémem. Rozpracování tohoto cíle je v podstatě work-flow (podrobnější informace se nacházejí v dokumentaci „úvodní informace k informačnímu systému Bílý Motýl”, kapitola work-flow).

V informačním systému Bílý Motýl jsou procesy, které jsou si podobné (blízké) modelovány druhem procesu. Procesy stejného druhu mají řadu shodných vlastností, které jsou v definici druhu zachyceny, např. shodná počáteční operace v diagramu procesu, transformace, masky, … apod.

Fyzický proces je tedy model jednoho konkrétního procesu v reálném světě, který má vlastnosti dané druhem procesu. Tento proces nese v IS určitou informační schopnost, která pak zajímá uživatele.

2. Druh procesu

Jak jsme si již zmínili v předešlé kapitole, pomocí druhu procesu jsou v informačním systému Bílý Motýl modelovány procesy, které jsou si podobné (blízké). Nastavením jeho vlastností se rozhoduje o vlastnostech všech procesů daného druhu, které budou v informačním systému evidovány. Vlastnosti lze rozdělit na:

¨ základní

¨ související

2.1 Základní vlastnosti druhu procesu

Každý druh procesu u sebe eviduje určité vlastnosti, které se mu přiřazují při jeho sestavování nebo editaci (Informační centrum – Typy a řady – Druhy procesů). Jsou to:

¨ druh procesu - jednoznačná identifikace procesu a jeho stručný (ale výstižný) název

¨ řada - identifikátor číselné řady procesu a název intervalu číselné řady. Při zahájení procesu ještě není číslo procesu definováno, systém procesu přiřadí číslo teprve až po ukončení první operace v procesu. Číslo procesu se pak skládá z roku/identifikace datového úložiště/pořadového čísla (tj. čísla odvozeného od nadefinované číselné řady pro daný proces)

¨ skupina - identifikace skupiny procesu. Skupiny procesů se definují pouze v této činnosti po stisku klávesy F2 nebo ikony výběr. Možnost definice skupin slouží uživatelům pro zjednodušení menu, které se mu nabízí po spuštění činnosti "nový proces". Zde se uživatelům nabízely všechny dosud spuštěné procesy. Protože by mohla nastat situace, kdy by se časem toto menu příliš naplnilo, je vhodnější např. procesy jednotlivých komponent sdružit do určité skupiny. Při spuštění činnosti "nový proces" se pak budou uživatelům nabízet nejprve skupiny procesů, ze kterých si dvojklikem nebo stiskem klávesy Enter vybraný proces spustí.

¨ korektor - korektor je možné nadefinovat ke každému druhu procesu a úzce souvisí s formátem ISDOC. Korektor představuje definici kódu v jazyce FoxPro, který je spouštěn v rámci zpracování fyzického procesu v okamžiku po provedení všech transformací do operace těsně před tím, než jsou data předplněná transformací zobrazena uživateli ve formuláři operace.

¨ metapředloha - pokud je daný proces spojen s tiskem určitého dokladu (např. faktura, příkaz k úhradě, prodej za hotové), je nutno v této položce uvést název metapředlohy tiskové sestavy (u druhu operace v diagramu procesu, kde se pak má tato metapředloha tisknout, je ve vlastnostech uzlu operace nutno zaškrtnout „po ukončení operace tisk dokladu“).

¨ implicitně spouštět:

- automaticky - zatržením tohoto příznaku se jednotlivé operace v procesu budou ukončovat a zahajovat automaticky. Pokud tento příznak zatržen nebude, musí uživatel každou operaci v procesu ukončit vyvoláním činnosti z menu "volby". Teprve po "ručním" ukončení operace může být následující operace zahájena.

- na pozadí - většinou se tento příznak nastavuje u tzv. procesů v procesu (tj. podprocesů). Znamená to, že tento podproces pak probíhá v rámci procesu na pozadí - uživatel jeho vlastní průběh nevidí. Např. při procesu prodej, může vyskladnění a jeho zaúčtování běžet na pozadí. Uživatel pak vstupuje objednávku, na pozadí proběhne vyskladnění, jeho zaúčtování a vstupuje se zase až při vytváření faktury.

- nespouštět - tento příznak uživatel rovněž využije nejvíce u podprocesů, např. u procesu prodej, který se bude skládat ze samostatných procesů faktura a výpis z banky. Protože mezi fakturací a výpisem z banky je určitá časová prodleva, uživatel počká, až přijde výpis z banky a potom ručním spuštěním podprocesu výpis z banky dokončí celý proces prodej.

¨ použití:

- zobrazovat v menu - pokud je zadána tato možnost, název procesu se zobrazuje v menu (tj. přehledu všech dosud vytvořených procesů). Pokud uživatel zadá nezobrazovat v menu, proces se v přehledu procesů nezobrazuje. Tuto možnost využije uživatel zejména pokud definuje složitější proces, který se skládá nejen z operací, ale i z dalších procesů. Potom tuto možnost zadá pouze u vrcholného procesu a u procesů, které jsou součástí tohoto vrcholného procesu, tuto možnost zadávat nebude.

- nezobrazovat v menu - zadá se u procesů, které uživatel nechce mít v hlavní nabídce

- referenční proces - jedná se o proces (o jedné nebo více operacích), který je možno napojit na jakoukoliv jinou operaci, která se používá v ostatních procesech. Z této operace je pak možno referenční proces spustit opakovaně několikrát. Např. budeme mít operaci účetní zápis. K této operaci vytvoříme referenční proces opravný účetní zápis. Potom si v přehledu operací najdeme právě operace účetní zápis, přes strom hlavního procesu je znovu spustíme a potom se v menu Obecné nabízí možnost napojení opravného účetního zápisu. Systém pak ještě pokládá kontrolní dotaz, zda opravdu chceme opravný účetní zápis napojit na danou operaci. Takovým způsobem lze v podstatě opravit jakýkoliv účetní zápis a to i opakovaně. Referenční proces se dá využít např. i u fakturace, kdy budeme mít možnost ke každé zadané faktuře vytvořit dobropis.

¨ test mírou plnění - možnost vybrat z překryvného seznamu, zda se při ukončení operace daného druhu procesu má informovat uživatel, že očekávané události nenastaly v plné míře (tzn. výsledek testu mírou plnění je negativní).

¨ skrytý druh procesu - tuto možnost uživatel využije např. u procesu, který v současné době již není aktuální nebo se přestal používat v praxi

¨ poznámka - není povinný údaj. Jedná se o krátkou poznámku k procesu, např. možnosti jeho využití nebo naopak případy, ve kterých není vhodné tento proces používat.

V činnosti Druhy procesů za zmínku ještě určitě stojí záložka „Další“, která umožňuje uživateli:

¨ nadefinovat si volnou kartu, která se vztahuje k danému procesu, tj. ze které lze transformovat (její atributy lze užít jako výstupní atributy komponenty), případně ji automaticky vyvolat při ukončení určité operace (po ukončení vstup volné karty procesu)

¨ nastavit si volbu „opakovat vstup“, což znamená, že volba „předplňovat-opakovat vstup“ před zápisem událostí první operace při spuštění procesu z menu Nový proces bude předplněna (viz. ovládání).

¨ výraz popisu procesu - výraz pro předplnění popisu procesu podle operace zahajující proces

¨ výraz externí identifikace procesu - výraz pro předplnění externí identifikace procesu podle operace zahajující proces

¨ výraz poznámky procesu – výraz nebo skript v jazyce Foxpro, na základě jehož vyhodnocení je předplňován text komentáře nově zakládaného procesu. Skript je možno definovat po stisku pravého tlačítka myši na daném atributu a jeho text musí být uveden slovem SCRIPT (stejné platí pro „výraz popisu procesu“ a „výraz externí identifikace procesu“). V kódu skriptu je možno se odkazovat na tyto proměnné:

- _THIS - řídící objekt operace (např. pro využití jeho atributů _THIS.SP33CISDRO, _THIS.SP33CISDPO, _THIS.SP33CISDO ...)

- _ALIAS - alias kurzoru, ve kterém se nacházejí informace pro vytvoření popisu

¨ založil - informace o uživateli, který proces založil + datum a čas jeho založení

Přiklad:

<pre>

SCRIPT

LOCAL _sp33text

_sp33text=tool.sql_dotaz([select sp33text from %%%.spprc where sp33cisdr=?_p1 and sp33cisdpm=?_p2 and sp33cisd=?_p3],;

_this.sp33cisdro, _this.sp33cisdpo, _this.sp33cisdo)

RETURN _sp33text

</pre>

Na formuláři se jako další uživateli nabízí záložka "Výskyt procesu". Zobrazí se tabulka, ve které je zapsán název druhu procesu, ve kterém se aktuální proces vyskytuje. V případě potřeby je možno i u tohoto procesu zobrazit jeho diagram (menu Volby nebo klávesa F7).

Před vysvětlením záložky "Hodnoty procesu" (týká se saldokontních hodnot) je nutno si nejprve ujasnit pojem HLAVNÍ PROCES. Nejlépe si tento pojem vysvětlíme na konkrétním případu. Např. proces "prodej" se skládá z několika operací a podprocesů (výdejka, faktura ....), které v případě potřeby mohou běžet i jako samostatné hlavní procesy. Proces "prodej" je ale v tuto chvíli "hlavním procesem". Pod záložkou hodnoty procesu uživatel zadává druhy hodnot (vztahující se k operacím, které jsou součástí daného procesu), které vytváří saldokontní hodnoty. Neboli u tohoto hlavního procesu definuje, které operace vytváří které saldokontní hodnoty. V tuto chvíli je však nutné, aby si uživatel uvědomil, že tyto hodnoty jsou nadefinovány pouze pro hlavní proces (např. prodej). V případě, že se hlavní proces skládá z podprocesů (např. výdejka, faktura, výpis z banky ...), které jsou schopny fungovat i samostatně, se tyto hodnoty k nim v tuto chvíli nevztahují. Nadefinované saldokontní hodnoty skutečně platí právě jen tehdy, pokud je spuštěn právě hlavní proces. Pokud uživatel potřebuje znát saldokontní údaje samostatně i za jednotlivé podprocesy, musí saldokontní hodnoty nadefinovat u každého podprocesu zvlášť (uživatel si v přehledu druhu procesů najde vybraný podproces a přepnutím se na záložku "hodnoty procesu" nadefinuje potřebné údaje). U každé hodnoty se vyplňuje název komponenty, druh operace, druh hodnoty a příznak, zda je v tu chvíli jisté, že se jedná čistě o příjem (+), výdej (-) nebo to může být kombinace obou (PV) a systém pak sám podle dalších příznaků rozlišuje, zda se jedná právě o příjem nebo o výdej. Např. jednou se může podle druhu operace jednat o příjemku, jindy stejná operace může být výdejka, proto je nutné nastavení příznaku PV.

Nastavení saldokontních hodnot u hlavního procesu v této činnosti je výhodné z hlediska jejich definování. Uživatel má na výběr hodnoty u operací všech komponent, tzn. že si na jednom místě nadefinuje vše, co v daném procesu chce sledovat. Zde nadefinované hodnoty se pak nadále zobrazují pouze na záložce „hodnoty procesu“ v činnosti Druhy operací (jinými slovy, v této činnosti si uživatel saldokontní hodnoty pouze nadefinuje, k prohlížení je ale pak má k dispozici jinde).

Záložka „Popisné info“ formuláře 'Druhy procesů' umožňuje definovat několik záznamů popisné informace spojené s druhem procesu:

¨ Význam - identifikátor významu položky obecné předkontace - součást primárního klíče

¨ Volný text - identifikátor volného textu

¨ Kód - kód v jazyce Foxpro

¨ Datum 1 - datum

¨ Datum 2 - datum

¨ Text 1 - text

¨ Text 2 - text

¨ Num1 - číslo

¨ Num2 - číslo

¨ Poznámka

Knihovna SYSPDF, která se používá při tisku dokladů procesů do souborů PDF a ISDOC, používá 'Popisné informace' uvedené u tištěného druhu procesu pro sestavení emailu. Používá 'Popisné informace' s těmito významy:

EMAIL1 - určení Příjemce zprávy

EMAIL2 - určení Předmětu zprávy

EMAIL3 - určení Textu zprávy

Příklad popisné informace významu EMAIL3:

'Volný text' definuje text:

<pre>

Fakturujeme Vám:<br>

Faktura číslo: <<spprc_sp33cisdr>>-<<spprc_sp33cisdpm>>-<<spprc_sp33cisd>><br>

VS: <b><i><<alltrim(pluda_pl02vs)>></i></b><br>

Cena: <b><<alltrim(trans(pluda_pl02czm,'999 999 999.99'))>></b><br>

<br>

<br>

<h5>Seznam dodaného zboží:</h5>

<br>

##TABLE##

<br>

</pre>

'Kód' obsahuje kód v jazyce Foxpro:

<pre>

* Knihovna SYSPDF volá tento kód s parametry:

* _THIS = objekt, který provádí výstup do PDF

* _RIDIC = řídící objekt tisku

* _SP89OBSAH = text Volného textu

* _DATA = objekt s atributu záznamu 'Popisné informace' mj. _DATA.SPH1DAT1, _DATA.SPH1DAT2, _DATA.SPH1TEXT1, _DATA.SPH1TEXT2, _DATA.SPH1NUM1, _DATA.SPH1NUM2

*

Local _rt,_err,_chb,_txt

Select sql_tisk

Locate All For sppohzdr_sp06idsubs='PLA'

If !Found()

Return _sp89obsah

Endif

Try

_rt=Textmerge(_sp89obsah)

_chb=.F.

Catch To _err

_rt=_err.Message+Chr(13)+Chr(10)+_sp89obsah

_chb=.T.

Endtry

If _chb

Return _rt

Endif

_txt='<table border cellspacing="0" ><tr><th>Popis zboží</th><th>Množství</th></tr>'

Select sql_tisk

Scan All For sppohzdr_sp06idsubs='OBC'

_txt=_txt+'<tr><td>'+Alltrim(obudal_ob02text)+'</td><td style="text-align:right">'+Trans(obudal_ob02mn)+'</td></tr>'

Endscan

_txt=_txt+'</table>'

Go Top In sql_tisk

Return Strtran(_rt,'##TABLE##',_txt,1,1,1)

</pre>

V každé komponentě, se kterou uživatel pracuje v rámci procesu, si volbou příslušné činnosti z menu "volby" může vyvolat tzv. "strom hlavního procesu". Uživateli se na obrazovce objeví celá definice procesu a navíc vždy je jednotlivými značkami vyznačeno místo, na kterém se uživatel v rámci procesu nachází. Tato činnost uživateli umožňuje snadnou a rychlou orientaci při práci s procesy.

Při definování nového procesu je nutno k tomuto procesu přiřadit přístupová práva (tj. činnost "přístupy k procesům a operacím"). Definováním přístupových práv k jednotlivým procesům se např. zamezí tomu, aby se fakturantce zbytečně nezobrazovaly procesy týkající se vývěsky nebo mezd a naopak, aby např. pracovník skladu neměl možnost prohlížet procesy týkající se plateb apod. Každému uživateli se tedy budou zobrazovat pouze jemu přístupné procesy (tzn. definice procesů), což jistě povede k zjednodušení práce s vlastními procesy (v činnosti Procesy a operace – Procesy).

Protože v této činnosti uživatel vlastně definuje pouze název, číselnou řadu a vlastnosti procesu, samotné složení procesu musí nadefinovat v činnosti "diagram procesu". V této činnosti nastaví posloupnost jednotlivých operací nebo procesů a vazby mezi nimi. Podrobnější vysvětlení najde uživatel v helpu činnosti "diagram procesu".

Po nastavení přístupových práv a nadefinování diagramu (neboli složení) procesu je možno vybraný proces spustit. Spuštění procesu se provádí právě v této činnosti, a to funkční klávesou F9 nebo přímo volbou této činnosti z menu "volby".

Pro účely implementace má uživatel k dispozici činnost "generování dokumentace" (menu Volby), kde systém sám vytvoří dokumentaci, která obsahuje dosud vytvořené procesy, jejich operace, použité transformace a druhy hodnot. Pomocí činnosti "prohlížení dokumentace" může uživatel všechny tyto vygenerované údaje prohlížet, popřípadě si je i vytisknout.

V případě potřeby má uživatel možnost vytvořit si kopii druhu procesu (příslušná činnost v menu Volby), čímž si může zefektivnit tvorbu nových druhů procesu.

Na základě definovaných druhů procesů pak uživatelé vytváří fyzické procesy, jejichž přehled je k dispozici v menu Procesy a operace – Procesy.

2.2 Související vlastnosti druhu procesu

2.2.1 Druh operace

Druh operace je nositelem vlastností (definuje je) pro všechny operace daného druhu. Operace je seskupení plánovaných nebo uskutečněných událostí shodného druhu v časové i věcné blízkosti. Obsahem operace jsou tedy události jedné komponenty, operací může být např. příjem na sklad nebo dodací list. Jednotlivé řádky (položky) těchto operací jsou potom události. Z posloupností operací se skládá proces. Posloupností druhů operací se fakticky definuje druh procesu.

Druh operace [1] se definuje pomocí následujících údajů:

¨ komponenta - identifikace a název komponenty, ke které se operace vztahuje (do které patří).

¨ druh operace - identifikace a vlastní název operace. Pro druh operace platí stejné upozornění, jaké je uvedeno u druhu procesu. Identifikace a název druhu operace by se měly tvořit s ohledem na další možnosti vyhledávání a třídění.

¨ charakter - pokud je charakter operace běžná, jedná se o standardní druh operace, který se bude pravděpodobně v systému vyskytovat nejčastěji (aktualizuje statistiky, transformuje data). Pokud uživatel potřebuje, aby se do jednoho procesu transformovaly operace z několika procesů, využije možností, které mu poskytují operace dávkového charakteru. Protože v operacích dávkového charakteru se shromažďují pouze odkazy na jiné operace, neaktualizují tyto dávkové operace statistiky a nelze do nich transformovat data.

Dávkové operace je možno používat opakovaně, ale do dávkové unikátní nelze opakovaně vložit operaci stejného druhu. Použití dávkových operací si nejsnadněji vysvětlíme na konkrétním případě. Dejme tomu, že máme např. firmu zabývající se rozvozem písku. Celý den odváží stovky aut náklad písku. Za určité období je pak nutno shromáždit za vybraného adresáta všechny jeho dodací listy (odkazy na všechny tyto dodací listy se shromažďují právě v dávkové operaci) a odtud se v procesu transformují na fakturu apod.

Je-li dávková operace používaná na pozadí, pak je číslo procesu (včetně roku) vytvořeno automaticky, a to podle systémového data. Takto se může stát, že faktura vytvářená na pozadí z podkladu roku 2006 bude mít číslo procesu roku 2007. Pokud si uživatel přeje fakturovat do roku 2006, vznikne chyba (tento problém však lze implementačně řešit).

Není-li dávková operace používaná na pozadí, lze číslování vyřešit při zápisu dávkové operace pomocí "zaškrtávátka" datum vzniku procesu a zvolit si rok.

¨ MP dávkové operace - způsob vyhodnocení míry plnění při transformaci z dávkové operace - možnosti jsou "z události" (tj. označená událost - případně její numerické atributy) nebo "z vazby na událost" (tj. událost dávkové operace). Tento atribut má význam pouze pro dávkové operace.

¨ korektor - korektor představuje definici kódu v jazyce FoxPro, který je spouštěn v rámci zpracování fyzického procesu v okamžiku po provedení všech transformací do operace těsně před tím, než jsou data předplněná transformací zobrazena uživateli ve formuláři operace (např. může být použito v případě transformace obchod – sklad, kdy máme jednu operaci obchodu, která se podle množství skladových buněk rozpadne na příslušný počet operací skladu)

¨ metapředloha - výběr metapředlohy výstupu pro tisk operace (např. skladová příjemka apod.)

¨ implicitně spouštět - může být nastaveno - automaticky - v průběhu procesu se bude operace spouštět automaticky (tj. po ukončení předchozí operace se tato automaticky spustí)

- na pozadí - operace bude probíhat na pozadí - uživatel ji nevidí, ani ji nemá možnost ovlivnit (např. zaúčtování, výdej ze skladu apod.). Na pozadí je možno provést i tu operaci, ke které nemá uživatel přístupová práva.

- nespouštět - operace se nebude spouštět automaticky, uživatel ji musí aktivovat ručně. Tato volba se používá u operací v procesech, kde je mezi operacemi určitá časová prodleva (např. odeslaná faktura a příjem výpisu z banky). Operace odeslaná faktura se provede, ale následující operace výpis z banky se nespustí. Uživatel vlastně musí počkat, až skutečně přijde výpis z banky, potom ručně spustí operaci výpis z banky a celý proces dokončí.

¨ řada operace - zadává se zde identifikace číselné řady operace

¨ test mírou plnění - možnost vybrat z překryvného seznamu, zda se po ukončení operace daného druhu má informovat uživatel o negativním výsledku testu mírou plnění

¨ skrytý druh operace - tento příznak uživatel využije u operací, se kterými se již nepracuje proto, aby se dále nezobrazovaly v aktuální nabídce druhů operací

¨ založil - informace datu, čase a uživateli, který druh operace založil

¨ poznámka - libovolná poznámka k operaci (např. v jakých procesech je vhodné ji použít apod.)

Další činnosti, které jsou uživateli dostupné v činnosti Druhy operací na jednotlivých záložkách:

¨ záložka Další -

Po stisku klávesy F3 na záložce Další je možno zadat identifikaci a název volné karty (její atributy lze užít jako výstupní atributy komponenty). Uživatel má možnost u druhu operace nastavit tyto příznaky:

¨ po ukončení vstup volné karty procesu - tato volba se uplatní tehdy, pokud je u druhu procesu, jehož je daný druh operace součástí nastavena na záložce „další" volná karta, tak se po ukončení daného druhu operace spustí tato volná karta.

¨ po ukončení vstup volné karty operace - v případě, že je u druhu operace nadefinována volná karta a je uvedena na této záložce „další" v činnosti Druhy operací, tak se po ukončení daného druhu operace uživateli spustí právě tato nastavená volná karta.

¨ ukončení operace bez událostí - volba Ano/Ne, zda povolit ukončit daný druh operace i bez toho, že by obsahoval události

¨ operaci na pozadí vždy ukončovat automaticky - volba Ano/Ne, operace se bude na pozadí vždy ukončovat automaticky bez ohledu na to, co má nastaveno ve vlastnostech operace v diagramu procesu

¨ zrcadlové storno - volba Ano znamená, že při stornu vznikají inverzní (tj. opačné) operace a události, volba Ne znamená, že při stornu jsou operace i události zrušeny i pro ukončené operace

¨ kontrolovat při stornu – volba Ano znamená, že při stornu procesu systém kontroluje, zda otevřené období komponenty tohoto druhu operace má nastaveno kontrolovat při stornu Ano. Pokud je u otevřeného období komponenty nastaveno Ano a u druhu operace rovněž Ano (nebo není vůbec vyplněna záložka Další), storno procesu se neprovede, pokud by stornem vznikla inverzní událost s datem mimo otevřené období komponenty nebo pokud by stornem byla zrušena událost s datem mimo otevřené období komponenty.

¨ kontrolovat při rušení stavu ukon. – volba Ano znamená, že při rušení tohoto druhu operace systém kontroluje, zda otevřené období komponenty má nastaveno kontrolovat při rušení stavu ukončena Ano. Pokud je u otevřeného období komponenty nastaveno Ano a u druhu operace rovněž Ano (nebo není vůbec vyplněna záložka Další), zrušení stavu ukončena se neprovede, pokud by byla zrušena událost operace s datem mimo otevřené období komponenty. Dále platí, že rušení záznamu události komponenty klávesou F8 nebo rušení označených událostí v neukončené operaci nedovolí zrušit událost, která je mimo otevřené období komponenty. Stejně tak není povoleno změnit datum události, která byla uložena s datem, které je v daném okamžiku mimo otevřené období komponenty.

¨ zobrazovat ve stromu procesu – volba Ano/Ne. Možnost nastavení, zda druh operace má být zobrazen ve stromu hlavního procesu. Ve většině případů zřejmě bude nastaveno Ano, možnost Ne se využije především u operací, které se vkládají do diagramu procesu pouze pro umožnění odblokování operace.

¨ záložka Typy –

Tato záložka umožňuje uživateli členit daný druh operace ještě podle jednotlivých typů událostí komponent. Zde je možné jednak si typy přiřazené k operaci prohlížet a jednak je možno daný typ k operaci přiřadit.

¨ záložka Výskyt operace -

Údaje v této záložce poskytují uživateli informaci o tom, v jakém procesu (-ech) se daná operace vyskytuje.

¨ záložka Hodnoty operace -

Aktuální hodnoty se nevztahují k saldokontu, ale k ostatním hodnotám, které má smysl u dané operace evidovat a sledovat neboli jsou to hodnoty, které jsou operací aktualizovány. Např. operace bankovní výpis aktualizuje hodnotu stav financí na účtu nebo operace výdej ze skladu aktualizuje hodnotu množství materiálu na skladě apod. U každého druhu hodnoty se eviduje její název a způsob výpočtu. Podle druhu hodnoty systém sám předplňuje způsob výpočtu, přičemž "+" je příjem, "-" je výdej a "PV" je příjem/výdej. Např. u hodnoty stav financí na účtu musí být zadán způsob "PV", protože tato hodnota je aktualizována jak příjmy (výpisy z banky), tak i výdaji (příkazy k úhradě). U každé hodnoty je navíc možno zadat podmínku, v jakém procesu se daná hodnota má vyvolat. Pokud je zadána "-", tak se tato hodnota uplatňuje vždy, pokud je zadána přímo identifikace procesu, tak pouze v tomto procesu.

¨ záložka Spojení –

Tato záložka poskytuje uživateli možnost předplňování rozdílného čísla spojení adresáta v událostech operací různých komponent. Na této záložce se definuje jakým způsobem program určuje číslo spojení adresáta při vstupu nové události daného druhu operace. Zadává se:

- spojení – 1.adresáta/2.adresáta (překryvný seznam) – určuje, kterého adresáta v události se daná definice spojení týká (zadat hodnotu „2.adresáta“ má smysl pouze pro operace komponenty obchod,

jejíž události obsahují dva adresáty)

- subjekt – textová hodnota – uvádí se identifikátor typu subjektu spojení adresáta – bude předplňováno spojení daného typu subjektu

- použít impl. – Ano/Ne (překryvný seznam) – určuje pravidlo, zda se má použít implicitní spojení adresáta v případě, že pro něj neexistuje spojení daného typu subjektu

- proces – textová hodnota – uvádí se identifikátor druhu procesu – umožňuje definovat různé způsoby předplnění spojení adresáta pro danou operaci v případě, že je použitá v různých druzích procesů

- kód – textová hodnota – kód v jazyce FoxPro vyvolávaný pro určení spojení adresáta. V okamžiku vyvolání jsou pro kód dostupné proměnné _THIS (instance objektu formuláře ve kterém je prováděn

vstup), _AD01ID (identifikace adresáta pro kterého má být spojení předplněno) a _SPF2CSSP (odpovídá zadávané vlastnosti „spojení“ – nabývá hodnota 1 nebo 2) – kód by měl vracet textovou hodnotu

- poznámka – libovolný text

Postup programu IS BM při zjišťování předplňovaného čísla spojení adresáta je popsán ve slovníku pojmů (pojem „Spojení adresátů v událostech komponent“).

¨ záložka Validace -

Pod touto záložkou má uživatel možnost u jednotlivých druhů operací a s nimi souvisejících druhů hodnot nastavit takové údaje, které pak systém při jejich vstupu (při vstupu operací) ověřuje neboli validuje. Všechny zde nastavené údaje by se měli nějakým způsobem vztahovat k adresátovi. Může se jednat např. o druh operace "objednání odběratelem", kde je potom možno nastavit takové údaje, že pokud má u nás uživatel závazky v té a té výši, nebude jeho objednávka akceptována. Hodnota "než" představuje hodnotu varování, kdy při zápisu operace systém uživatele upozorní, že určitá částka je vyšší, nicméně mu dovolí tuto operaci zapsat. Hodnota "a než" představuje hodnotu zákazu vstupu a systém po jejím překročení vůbec nedovolí zapsat tuto operaci. Nastavené validace vstupu a jejich hodnoty jsou shodné pro všechny adresáty. Pokud uživatel potřebuje rozlišit jednotlivé hodnoty individuálně pro každého adresáta, využije tuto možnost, kterou mu nabízí činnost "kredity adresátů" (menu Volby), kde si pro každého adresáta může nastavit individuální hodnoty.

¨ záložka Info -

Na této záložce je možné definovat několik záznamů popisné informace spojené s druhem operace:

- Význam - identifikátor významu položky obecné předkontace - součást primárního klíče

- Volný text - identifikátor volného textu

- Kód - kód v jazyce Foxpro

- Datum 1 - datum

- Datum 2 - datum

- Text 1 - text

- Text 2 - text

- Num1 - číslo

- Num2 - číslo

- Poznámka

¨ záložka Uživatelé -

Zobrazuje se přehled uživatelů systému a jejich přístupová práva k dané operaci (čtení, zápis ...). Pro každého uživatele je možno po vyvolání této činnosti v menu Volby nastavit "osobní masku operace". Toto se využije především v takových případech, kdy několik uživatelů pracuje s jednou operací a přitom pro každého z nich jsou v této operaci prioritní jiné údaje. Pokud by neexistovala možnost vytvoření osobní masky operace, musela by se tato operace definovat několikrát pro každého uživatele zvlášť.

¨ záložka Výběr -

Jednotlivé položky slouží k tomu, aby si uživatel nadefinoval výběr podle svých současných potřeb a nezobrazoval si zbytečně mnoho informací, které v danou chvíli nepotřebuje.

Informace o každé fyzicky provedené operaci nebo procesu je možno tisknout. Tisk lze nastavit tak, že probíhá automaticky po ukončení operace [2]. Jeho opakované vyvolání je možno provést několika způsoby:

- v činnosti Operace funguje výstup operace po stisku klávesy F5 nebo volbou příslušné činnosti z menu Volby (jedná o tisk předlohy, která je nadefinována v diagramu procesu ve vlastnostech uzlu operace, např. skladová výdejka, objednávka, dodací list)

- v činnosti Procesy funguje výstup dokladu po stisku klávesy F5 nebo volbou příslušné činnosti z menu Volby (jedná se o tisk dokladu nad celým procesem, viz. prezentace procesů)

- v událostech jednotlivých komponent lze tisk operace nebo dokladu provést po stisku klávesy F11 nebo volbou příslušné činnosti z menu Volby

- v činnosti procesy a v událostech jednotlivých komponent je ještě možno vyvolat tisk klasickým způsobem, čili stiskem příslušné ikony (nebo volbou Ctrl T), která aktivuje přehled tiskových výstupů, kde si uživatel může příslušnou tiskovou sestavu zvolit

Na základě nadefinovaných druhů operací pak uživatelé vytvářejí fyzické operace v rámci

procesů, jejichž přehled je k dispozici v činnosti Procesy a operace – Operace.

Události jednotlivých vytvořených operací pak mají uživatelé dostupné v jednotlivých komponentách. V komponentě obchod jsou přístupné události obchodu (objednávka, nabídka, dodací list), v komponentě sklad zase události skladu (příjemka, výdejka) apod.

2.2.1.1 Masky operace

Události operace daného druhu mohou při vstupu v procesu již mít některé atributy předplněny, tj. jedná se o jeden z nástrojů předplňování událostí (automatizace vstupu). Toto předplnění vybraných atributů je možno definovat mimo jiné maskou operace. Při definování druhu operace je možno nastavit vstupní masku operace[3]. Kromě vstupní masky operace ještě existuje maska operace v procesu a osobní maska. Všechny masky jsou v podstatě jakési šablony[4], podle kterých se údaje událostí spouštěných operací předplní. Mezi maskami existuje určité pravidlo nadřazenosti. Nejvyšší prioritu má osobní maska operace, jako druhá v pořadí se uplatňuje maska operace v procesu a co se týče priority, je poslední maskou vstupní maska.

Při běhu procesu je nutno si dát pozor na priority, a to nejen mezi jednotlivými maskami, ale i v případě, že první operace v procesu může být předplňována transformací z nadřazeného procesu a přitom má např. nadefinovánu vlastní masku operace v procesu. V tuto chvíli může dojít ke kolizi transformace a masky operace, kdy větší prioritu a tudíž přednost má vždy explicitní pravidlo transformace.

Ke kolizi může dojít i s chováním programu, kdy je automatizace vstupu jeho součástí, což je implementačně mnohdy neodstranitelné.

Lze konstatovat, že masky je možno v procesech využívat různými způsoby:

¨ každý sklad, pokladna, účet apod. (tedy každá alokace) je ve většině případů aktualizována svými procesy (alokace = číselná řada). Od tohoto se dá odvodit a nastavit maska pro jednotlivé procesy a při běhu procesu se pak masky předplňují na základě tohoto nastavení.

¨ z praxe je typické, že v masce operace v procesu se uvádějí klíčové atributy událostí (VDL, PO, VO) a u těchto atributů se nastavuje hodnota „nevstupovat“.

¨ u některých údajů, které nás na událostech v dané implementaci vůbec nezajímají (např. čárový kód, výrobní číslo, skladová buňka apod.) se vždy nastavuje hodnota „nevstupovat“.

2.2.1.2 Jiné vlastnosti druhu operace

Jedná se o vlastnosti, které nejsou k dispozici na záložkách v činnosti Druhy operací, ale přesto s touto činností souvisí.

¨ Informace stromu pro druh operace – tato činnost je dostupná v menu Volby (činnost Druhy operací). Její nastavení souvisí s tím, jak se budou u jednotlivých fyzických operací daného druhu ve stromu hlavního procesu (klávesa F6) zobrazovat události operace. Tyto zobrazené události uživatel vyvolává po stisku pravého tlačítka myši na operaci ve stromu. Volbou „obnovit” (rovněž po stisku pravého tlačítka myši) se strom hlavního procesu vrátí do původní podoby.

U druhů operací některých komponent je informace stromu předdefinována programovým kódem, tzn. že události operace se ve stromu hlavního procesu zobrazují automaticky i přesto, že jednotlivé druhy těchto operací nemají informace stromu pro druh operace zde nadefinovány.

Při jejich definici se postupuje takto:

- na příslušném druhu operace si uživatel vyvolá činnost „informace stromu pro druh operace”

- po stisku F3 a následném definování si zvolí atributy, které se pak budou zobrazovat po vyvolání činnosti „události operace”

V případě, že tyto informace stromu uživatel u jednotlivých druhů operací nenadefinuje (pokud se tedy nejedná o operace, které mají tyto informace stromu implicitně předdefinovány), tak po stisku pravého tlačítka myši ve stromu hlavního procesu na názvu operace se mu možnost vyvolat si události operace vůbec nenabídne.

¨ Parametry operace komponenty – tato činnost je dostupná v menu Volby (činnost Druhy operací). Tyto parametry se v současné době vstupují zatím pouze u druhů operací komponent obchod a platby. Jedná se o:

- automatické nastavení „stavu“ událostí v operaci daného druhu v případě, že po dané operaci následuje operace ze stejné komponenty (obvyklé použití v kombinaci s dávkovou operací, kde se nerespektuje míra plnění) a zároveň se zde nastavuje i „stav“ událostí v případě, že následující operace po dané operaci změnila stav (tzn. byla zrušena, stornována).

- předběžné ukončení – operace s tímto atributem je ukončena předběžně. Do vlastností uzlu diagramu s touto operací (atribut ukončit operaci) se však tato hodnota nepředplní, tj. je nutné ji definovat duplicitně.

Řada dalších významných vlastností je druhu operace přiřazena teprve při jejím použití jako uzlu v diagramu procesu.

2.2.2 Vazby operací

Vazba vyjadřuje vztah mezi zdrojovým a cílovým uzlem a v diagramu procesu je vyjádřena šipkou.

Každá vazba má své vlastnosti[5], jedním úkolem je umožnit uživateli nadefinovat způsob přeměny dat událostí zdrojového uzlu v uzel cílový. Tuto přeměnu nazýváme transformací. Způsob definice transformací si ještě podrobněji vysvětlíme v další části dokumentace (zejména modelování datového toku). Na základě nadefinované transformace pak dochází např. k přeměně výdejky na fakturu apod.

Druhým úkolem je přispět k definici, jak se mají operace spouštět ( modelování řídícího toku).

Pokud tedy uživatel definuje „vlastnosti“ vazby, kdy zdrojovým uzlem je operace nebo proces a cílovým uzlem je operace (tzn. vazby uzlů operace – operace, operace – proces), jedná se o tyto údaje:

¨ identifikace vazby – vazba vyjádřená „šipkou“ může obsahovat několik faktických vazeb, pokud cílem je uzel typu proces, pak se jedná se o identifikace vazeb, které jsou obsaženy v dané „šipce“, obvykle (vždy) do různé operace cílového procesu. V případě typu vazby operace – operace není možno zadat další vazby (tzn. že ve vazbě bude uvedeno číslo 1). Pokud uživatel potřebuje aplikovat dvě a více následných vazeb, zvolí příslušné číslo a každou z nových vazeb samostatně nadefinuje.

¨ pořadí – jedná se o číslo, které vyjadřuje pořadí vazby v jakém se bude vyhodnocovat. Pokud se jedná o vazbu z jednoho uzlu do druhého, je většinou uvedeno implicitní číslo 10. Pokud do uzlu vstupují transformace z více uzlů, využije se právě tato možnost nastavení pořadí. Toto pořadí pak určí v jakém sledu se budou transformovaná data z několika uzlů do tohoto uzlu ukládat. Tento atribut má význam:

- pro aplikaci masky OPAKOVAT (např. datum dle první události operace)

- pro aplikaci „pomocného slučování“, které se realizuje vždy jen do první události cílové operace

¨ po ukončení procesu – tento atribut je k dispozici pouze u vazeb uzlů proces – proces. Pokud je zaškrtnutý, tak předchozí zdrojový uzel musí obsahovat alespoň jednu ukončenou operaci s atributem „ukončuje proces“.

¨ operace zdrojového uzlu – je možno ho vstupovat pouze v případě, že se jedná o vazby uzlů proces – proces.

¨ operace cílového uzlu – je možno je vstupovat pouze v případě, že se jedná o vazby uzlů operace – proces nebo proces – proces. U vazby operace – operace se toto pole nevstupuje. Uživateli se nabízí překryvný seznam všech operací cílového uzlu proces (tzn. všechny operace procesu, který je určen jako cílový uzel. Pokud je v překryvném seznamu v nabídce opět proces, tak se jako cílový uzel bere první operace tohoto procesu). Pokud se ručně připojí vazba proces – proces do již existujícího fyzického procesu, tak se již automaticky neuplatní transformace, ani neproběhne aktivace operace do stavu připravena.

¨ transformace - pokud je tento příznak zatržen, uživatel pomocí položky „vstup transformací“ zadá transformaci (vybere ji ze seznamu nebo založí novou – tlačítko „vstup transformací“), která se vztahuje k operacím, mezi kterými je daná vazba. Seznam transformací v překryvném seznamu se vždy vztahuje k zdrojovému a cílovému uzlu (tzn. pokud bude zdrojový uzel operace komponenty obchod a cílový uzel bude operace komponenty DPH, budou se v překryvném seznamu zobrazovat všechny transformace související s komponentou obchod a DPH).

¨ rozlišení - pokud se např. z jedné operace komponenty obchod vytváří dvě transformace do operací komponenty platby, tak by mohlo dojít k tomu, že se tato transformace provede pouze jednou u první operace a ostatní se provádět nebudou. Pokud se ale tyto operace rozliší jednotlivými symboly A, B, C, tak přestože se jedná o transformaci do více operací stejné komponenty, systém ji díky uvedenému rozlišení provede třikrát. Toto rozlišení má význam i z hlediska míry plnění, kdy se při transformaci do více operací míra plnění implicitně sčítá, při nastaveném rozlišení k součtu míry plnění nedochází.

¨ vazba – z hlediska toho, jakých hodnot může nabývat definice druhu vazby mezi uzly (běžná, samostatná, pasivní, výběrová (OR), výběrová (XOR)) je možno tyto vazby rozdělit do dvou skupin:

- vazby bez výběru

- vazby s výběrem

¨ předkontace – výběr obecné předkontace z překryvného seznamu. Předkontace, které se zde nabízejí, jsou definovány u dané transformace na příslušné záložce

2.2.3 Transformace

Již výše jsme se zmínili, že transformace definuje, jak se z dat (atributů událostí) ve zdrojovém uzlu mají předplnit data do cílového uzlu. Transformace se skládá z definice základních údajů a definice pravidel (nejméně jedno pravidlo musí být vždy uvedeno). Transformace se definuje přímo při vytváření vazby mezi uzly po stisku tlačítka „vstup transformací” (vztahuje se k dvojici komponenta zdrojové operace – komponenta cílové operace). U každé transformace se vstupují následující atributy:

¨ transformace - vlastní název transformace (měl by vyjadřovat co transf. provádí, např. nákup za hotové, prodej za hotové, ZS – příjem, převod na BÚ apod.)

¨ filtr transformace – globální filtr, který se uplatní pro všechny pravidla uvedené transformace (např. u transformace „změna stavu – příjem” může být uveden filtr „nenulová úhrada”)[6]

¨ rozpad na procesy – má význam jen tehdy, je-li cílový uzel typu proces. Jedná se o definici výrazu, podle kterého se mají vytvořené události rozdělit do samostatných procesů, např. to bude asi adresát. Pokud např. vytvoříme větší množství položek penalizačních faktur, budeme je pak zcela určitě chtít roztřídit podle jednotlivých adresátů.

¨ popis rozpadu - určuje text zobrazovaný v zásobníku operací v seznamu operací. Ve výrazu je možné použít rutinu BM pro SQL-dotaz (např. pro přenos názvu adresáta "~tool.sql_dotaz([select ad01adsat from %%%.adadsat where ad01id=?_p1,Data.ad01id]") pro zobrazení informací, které nejsou součástí dotazu transformace.

¨ doplnění pohledu – umožňuje rozšířit množinu výstupních atributů komponenty o další uživatelsky definované

¨ prog. transformace – dodávaná nadstavba. Je součástí IS BM a uplatňuje se u transformací, kde nestačí základní atributy a je nutné využít tuto naprogramovanou nadstavbu.

¨ právo následující operace podle umístění – pokud je tento atribut u transformace zaškrnutý, znamená to, že při ukončení uzlu procesu má uživatel možnost si vybrat umístění pro uzel další (např. může určit umístění skladu apod. – podle komponenty, jejíž operace je nadefinována jako jeden z uzlů v transformaci). Tento atribut v podstatě koresponduje s možností, kterou uživateli nabízí maska operace s tím rozdílem, že tento atribut je možno použít pouze pro nastavení alokací (tzn. identifikace skladu, pokladny, účtu apod.) Pokud uživatel ke zvolenému umístění (alokaci) nemá nadefinováno přístupové právo, následující uzel se nespustí.

¨ transformace dynamické vazby – pokud je daná transformace užita v dynamické vazbě, je nutno zaškrtnout tento příznak. Transformace dynamické vazby by se neměla užívat v normální (tedy nedynamické) vazbě (není ověřeno z praxe).

¨ aktivovat následující operaci podle filtru transformace - zaškrtnuté způsobuje, že následující operace je aktivována (převedena do stavu připravena) pouze v případě, že existuje událost ukončované operace vyhovující filtru transformace. Z toho vyplývá, že toto nastavení má smysl pouze v případě, když je nastavena vlastnost transformace „filtr transformace“. Pro vyhodnocení podmínky se používá v případě tohoto nastavení kurzor aktuálně ukončované operace, je nutné, aby v ní byly užity pouze atributy tohoto kurzoru (nesmí v ní být použity atributy doplnění transformace).

¨ poznámka – popis užití transformace

Záložka „obecné předkontace“ poskytuje uživateli možnost nadefinovat si obecné předkontace, které jsou svázány s danou transformací a lze je využít při definování vazby (zobrazují se zde jako překryvný seznam u atributu předkontace) mezi zdrojovým a cílovým uzlem v diagramu procesu.

Záložka „výskyt transformace v typech procesů" poskytuje uživateli pouze informativní přehled o tom, v jakých druzích procesů (a mezi jakými uzly těchto druhů procesů) je daná transformace použita.

Transformace jsou společné pro druhy procesu i fyzické procesy. V diagramu fyzického procesu lze transformaci mezi uzly zaměnit za jinou, ale pak se transformace uplatní pouze tehdy, pokud zdrojová operace není ukončena nebo pokud je cílový uzel typu operace.

2.2.4 Pravidla transformace

Každá transformace musí mít uvedeno alespoň jedno pravidlo. Pravidla transformace jsou v podstatě algoritmy, na základě kterých se události jednoho uzlu přeměňují v události uzlu druhého. Pravidla transformace se vyvolávají po stisku klávesy F5 přímo na transformaci (nebo volbou činnosti z menu Volby) nebo je možno je přímo vyvolat po stisku pravého tlačítka myši na názvu transformace při definování vazby mezi uzly procesu.

První pravidlo, které bez výjimky platí pro definici pravidel transformace je, že z jedné události zdrojové lze transformací vytvořit maximálně jednu událost cílovou. Např. pokud bude uživatel pomocí transformace chtít vytvořit z jedné události vývěsky pět zpráv, které pošle spolupracovníkům, je nutno mít nadefinováno pět řádek transformace (po jedné pro každou ze zpráv), při účtování musí být jeden řádek transformace pro stranu MáDáti a druhý řádek pro stranu Dal nebo při fakturaci musí být jeden řádek transformace pro DPH s 5% a druhý řádek pro DPH s 22%.

První část (nad čarou) pravidel transformace obsahuje tyto údaje:

¨ pořadové číslo - právě číslo pravidla transformace a vedle je informace kdo a kdy transformaci založil

¨ rozlišení - slouží k rozlišení hodnot se stejným atributem, ale jiným významem (aby nedocházelo k tomu, že se pak tyto částky budou sčítat při vykrytí míry plnění, ale evidovat zvlášť - např. strana MD - rozlišení 0, strana D - rozlišení 1)

¨ agregační výraz - výraz slučování, tzn. které transformované události mají být sloučeny (z několika zdrojových bude jedna cílová)

¨ výběr - logický výraz - toto pravidlo transformace se uplatní pro ty záznamy, pro které má vstupní hodnotu „pravda“, tzn., že daný výraz platí. Jako doporučení z praxe je možno uvést, že do výběru v pravidlech transformace je vhodné striktně zadávat pouze ty výrazy, které platí pro dané pravidlo, aby nedocházelo ke kolizi se zadaným filtrem transformace, který je společný pro všechna pravidla u dané transformace.

¨ zdrojová hodnota - hodnota, která je přenášena ze zdroje (tj. z operace, ze které se tato transformace provádí). Zdrojová hodnota je vstupní výraz pro míru plnění v případě, že je takto jednoduchý.

¨ cílová hodnota - hodnota, která má být tímto pravidlem dosažena (např. lze nadefinovat, že celková cena se má převést na hodnotu částka – v míře plnění). V případě, že chceme, aby se v transformaci mezi uzly uplatnila míra plnění, musí být cílová hodnota zadána povinně.

Druhá část (pod čarou) pravidel transformace je značně variantní a odvíjí se od toho, která komponenta je zdrojová pro danou transformaci. Tuto část je možno definovat dvěma způsoby, a to tak, že uživatel může zadávat konstantní hodnoty nebo výraz.

Konstantní hodnoty uživatel zadává pokud nechává políčko u atributů volné (nezaškrtnuté). Potom jsou sloupce vedle atributů vysvíceny bíle a konstantní hodnota se přímo vepíše, např. v popisu může být uvedeno, že se jedná o „příjem na sklad“ nebo zde může být uvedena hodnota selektorů, které se vždy týkají pouze této transformace.

Pokud políčko před atributem zaškrtneme, předchozí bílé pole je žluté a uživatel může potřebný výraz vybrat z překryvného seznamu nebo má možnost si ho po stisku F2 nadefinovat. Je možno využít automatické předplnění atributů, které jsou v událostech zdrojové i cílové komponenty nebo je to poznámka. Pokud uživatel některou položku v druhé části nechce předplňovat, a to ani automaticky, musí k ní nadefinovat předplnění prázdným výrazem nebo nulou[7].

2.2.5 Doklad(y)

V reálném světě je doklad formulář, který obsahuje určité informace, obvykle autorizované a který je identifikovatelný určitým číslem.

Doklady v informačním systému Bílý Motýl se číslují na základě číselné řady. Číselná řada dokladů je vlastností (atributem) druhu procesu [8].

V IS Bílý Motýl se dokladem rozumí tiskový výstup definovaný v činnosti „procesy”. V definici takového tiskového výstupu (předlohy) se velmi často využívá prezentace procesů. U vybraných druhů procesů lze definovat implicitní předlohy pro výstup dokladu.

Implicitní předlohy výstupu k procesům se přiřazují ve většině případů v diagramu druhu procesu.

K používání automatizovaného tisku dokladů po zadání údajů pro doklad (tj. vlastně tisk obrazu procesu) je nutno dodržet následující tři kroky:

¨ předloha výstupu musí mít prezentaci uvedenou ve svých vlastnostech

¨ u druhu procesu musí být uvedena metapředloha výstupu

¨ v diagramu daného druhu procesu musí být nastaven příznak „po ukončení operace tisk dokladu”[9]

Podobně jako nastavení tisku dokladu z procesu, je možno nastavit i tisk jen z událostí jedné operace (tj. tisk zjednodušeného dokladu). Nastavení tohoto tisku se provádí v diagramu druhu procesu, kde se ve vlastnostech operace zatrhne příznak „po ukončení operace tisk operace” a příslušná předloha výstupu se vybere z překryvného seznamu. Tato předloha musí být vytvořena současně se svou metapředlohou v činnosti Tisk (Ctrl T) s přehledem událostí dané komponenty, jinak se v tomto překryvném seznamu nenabízí.

Obě tyto možnosti (tisk dokladu nad procesem, tisk po ukončení operace) jsou ukázkou tzv. automatického tisku, tzn. že nezávisle na uživateli se po ukončení operace automaticky tiskne doklad. Další metoda automatického tisku je definovatelná pomocí kódu po ukončení operace.

Při tomto nastavení je pak možno v procesech, operacích, událostech tisknout doklady poměrně rychle[10].

Ať už se jedná o tisk dokladů nebo o tisk zjednodušených dokladů je možno v případě potřeby využít cizojazyčnosti. Tisk cizojazyčných dokladů nese tyto problémy, které je nutno implementačně vyřešit. Plně automatizovaný tisk dokladů (tzn. vlastnost „tisknout bez zastavení“) je možný jen v jazyce definovaném u předlohy. Proces s možností dokladu ve více jazycích musí být nastaven tak, že o jazyce rozhodne obsluha. Alternativní varianty řešení jsou:

¨ míti tolik procesů, kolik chceme použít jazyků u dokladů

¨ v předloze ke každému atributu definovat podmíněný tisk dle jazyka stále uvedeného v adrese adresáta

¨ řešit v kódu po ukončení operace

2.2.6 Přístupová práva

Jedná se o informace, k jakým funkcím a kterým datům (věc s přístupem) má daný uživatel přístupové právo. Dle těchto informací IS poskytuje své funkce a data uživatelům.

Vliv přístupových práv na procesy a související informace:

¨ nový proces – jedná o činnost menu, kde jsou k dispozici procesy ke spuštění. Uživateli se nabízí všechny procesy, tzn. i ty, ke kterým nemá přístupové právo, ale může je pouze vidět, při pokusu o jejich spuštění systém hlásí „nemáte právo vytvářet proces“.

¨ operace, ke které uživatel nemá nadefinované přístupové právo se automaticky nespustí, systém hlásí „nemáte právo vytvářet operaci“, pouze v případě, že ve vlastnostech operace je nastaveno spouštět na pozadí, tak uživatel dostává pouze přechodné právo zápisu

¨ nelze vstoupit událost k alokaci bez práva (nelze ani prohlížet události) – tzn. uživatel nemůže vytvořit událost např. příjmu na sklad, když k tomuto skladu nemá přístupové právo zápis. Pokud má přístupové právo čtení může si prohlížet události, pokud nemá žádné přístupové právo, nemůže ani vstoupit událost ani si prohlížet události dané alokace.

¨ volná karta se nespustí – pokud uživatel nemá nastaveno přístupové právo k dané volné kartě, tak třebaže je u druhu operace nadefinováno, že po jejím ukončení se má spustit volná karta, v tomto případě se nespustí.

2.2.7 Diagram a sestavení druhu procesu

Diagram procesu je v podstatě grafické vyjádření druhu procesu včetně definice řídícího i datového toku. Velká část definičních parametrů druhu procesu (i fyzického procesu) se definuje pouze v diagramu, který je tedy nejdůležitější částí definice druhu procesu. Kromě diagramu druhu procesu má svůj diagram i každý fyzický proces, pro něj je v okamžiku zápisu jeho první operace[11] vytvořena kopie diagramu dle daného druhu procesu, tj. od tohoto okamžiku je možné všechny uzly daného procesu nalézt v činnosti Procesy a operace – Procesy, Operace. V činnosti Procesy je vidět přehled procesů, v činnosti Operace se zobrazuje přehled operací i jejich stav (tzn. zahájená, připravená apod.)

Diagram druhu procesu se definuje v činnosti Informační centrum – Typy a řady – Druhy operací po stisku klávesy F7 nebo volbou příslušné činnosti z menu volby s využitím ovládání.

Před začátkem definování druhu procesu je vhodné mít nadefinovány druhy operací (uzly), které se budou v procesu vyskytovat. Před ukončením komplexní definice diagramu procesu doporučujeme provést opakovanou, alespoň optickou, kontrolu vlastností všech uzlů i vazeb, neboť zejména ve složitých diagramech mohlo dojít k přeskočení některého uzlu nebo vazby.

Diagram procesu se skládá z jednotlivých uzlů a vazeb mezi nimi. U každého uzlu (tzn. uzlu typu „operace“ i uzlu typu „proces“), ze kterých uživatel skládá diagram procesu lze pravým klikem myši vyvolat menu:

¨ vlastnosti

¨ kód po ukončení (pouze uzel typu operace) – uživatel zde má možnost zadávat, aktualizovat nebo rušit vytvořený kód po ukončení operace. V diagramu druhu procesu je u operace vidět celý nadefinovaný kód, ve fyzických procesech je kód po ukončení operace jen do jejího ukončení, pak se smaže.

¨ odstranit – tento atribut se využije v případě, pokud chceme některý uzel diagramu procesu zrušit, současně se odstraní vazby s uzlem související a také ty uzly, pro které je rušený uzel jediným zdrojovým uzlem

¨ vstupní maska operace (pouze uzel typu operace) – možnost definice nebo opravy vstupní masky operace

¨ maska operace v procesu (pouze uzel typu operace) – rovněž možnost definice nebo opravy masky operace v procesu

Pokud se jedná o uzel typu „proces“, uživatel ve vlastnostech dále zadává tyto atributy:

¨ spouštět – definuje některou z variant, jak bude spuštěn. Uživatel si zde vybere příslušnou variantu z překryvného seznamu.

¨ po nepředběžném ukončení předchozích operací – taková operace, třebaže je uvedena do stavu připravena, se automaticky spustí pouze tehdy, je-li aspoň jeden ze zdrojových uzlů ovlivňující (druhem vazby) stav tohoto „podprocesu“ ukončen a to nepředběžně. Jedná se o další podmínku (kromě stavu - připravená), která musí být splněna, aby došlo k automatickému spuštění operace. Operace se pak automaticky spustí v okamžiku nepředběžného ukončení alespoň jednoho ze zdrojových uzlů. Můžeme si ho vysvětlit např. na operacích skladové evidence, kde je možno provádět předběžné a konečné ocenění. Pokud je ocenění předběžné, je vhodné u následující operace v procesu zatrhnout právě tento příznak, neboť pak operace nebude pokračovat a „počká“ až do té doby než u předchozí operace bude ocenění konečné. Je to výhodné zejména v případě, kdy po operaci skladové evidence (např. příjem či výdej) s předběžným oceněním následuje zaúčtování pohybu. Aby nedošlo k zaúčtování předběžného pohybu, je k dispozici právě tento příznak, který tuto alternativu umožňuje a hlídá.

¨ aktualizuje hodnotu semaforu procesu - definuje změnu hodnoty semaforu, která se uplatní při ukončení této operace, což má význam pouze tehdy, je-li ukončení procesu řízeno semaforem. Je-li na uzlu proces, aktualizuje se zahájením první operace a násobí se počtem fyzických procesů v uzlu. Uvedeme si toto na příkladu - první operací v procesu je událost vývěsky, na kterou přes transformaci navazují dvě zprávy. Potom u operace vývěsky je zadána hodnota 2, u každé z operací zprávy je zadána hodnota -1. Hodnota -1 uvedená u každé této operace se přičítá k vstupní operaci v okamžiku, kdy je tato operace ukončena. Vyrovnaný semafor je tedy v tom případě, pokud je výsledná hodnota nulová. Pokud tato hodnota není nulová, je možno v činnosti „procesy“ vyhledávat procesy i podle hodnoty, zda je u nich aktivní semafor.

¨ vytvořit záložku na operaci při založení procesu – tento atribut způsobí to, že na fyzicky vytvořených operacích a procesech (v činnosti „operace“, „procesy“) je pak na formuláři dostupný i atribut adresát, který je zastoupen na operaci (jedná se o adresáta z první události), je-li na uzlu typu proces nevytvoří záložku na všech prvních operacích.

¨ odvozené procesy budou hlavními procesy – pokud chceme u procesu, který je uzlem jiného procesu, tedy je vlastně podprocesem jiného procesu, aby byl hlavním procesem, musí být tento příznak zatržen.

¨ datové úložiště zahajující operaci/proces – v současné době se nepoužívá, tento atribut byl připraven speciálně pro firmu Kámen a písek.

Pokud se jedná o uzel typu operace , uživatel kromě atributů shodných s uzlem typu „proces“ (tj. spouštět, po nepředběžném ukončení předchozích operací, vytvořit záložku na operaci při založení procesu) ve vlastnostech ještě dále zadává tyto atributy:

¨ šablona prvého vstupu - pokud se operace vstupuje přes šablonu, zadá zde uživatel název šablony, která se automaticky aktivuje při spuštění operace (např. odpisy, kde je využit vstup šablony nebo pokud se operace týká zprávy, která se posílá několika uživatelům atd.). Pokud je definována šablona prvého vstupu ve vlastnostech uzlu, pro který je současně definována automatizace vstupu pomocí transformace, tak se šablona neuplatní.

¨ po ukončení operace tisk dokladu – po ukončení operace se (automaticky) bude tisknout doklad podle předdefinované metapředlohy, resp. s výběrem z předdefinovaných metapředloh

¨ po ukončení operace tisk operace - po zaškrtnutí se definuje předloha výstupu (resp. metapředloha výstupu obsahující danou předlohu) pro tisk zjednodušeného dokladu

¨ oprávnění ukončit operaci - výběr skupiny uživatelů, která má oprávnění operaci ukončit.

¨ ukončení operace – tato činnost poskytuje uživateli výběr možností způsobů, jak lze operaci ukončit:

- automaticky ukončit

- automaticky neukončovat

- automaticky ukončit předběžně

¨ ukončuje proces - tento příznak uživatel zatrhne především v operacích, které jsou "poslední" operací určitého procesu. Pokud ve fyzickém procesu budou všechny operace s tímto příznakem již ukončeny, pak všechny ostatní operace daného procesu již nemají přístupnou funkci "Zrušit stav ukončena" ve vlastnostech operace.

Z praxe: Někdy je vhodné napojit (pasivní vazbou bez transformace) na tuto poslední operaci ještě fiktivní operaci (vlastnost nespouštět) například komponenty vývěska, kterou si nazveme např. odblokovač - ta se nikdy nezahajuje, u této operace zatrhnout tento příznak „ukončuje proces“ a pak mají v podstatě všechny operace v případě potřeby trvale dostupnou funkci "Zrušit stav ukončená" .

Způsob chování jednotlivých uzlů v procesu ovlivňují i vazby, které jsou mezi jednotlivými uzly.

Po stisku pravého tlačítka myši na ploše okna diagramu se zobrazí menu, ve kterém je seznam oken včetně okna hlavního menu programu. Výběrem z tohoto seznamu se lze rychle přepnout do vybraného okna.

2.2.8 Dokumentace

V činnosti druhy procesů [12] umožňuje informační systém uživateli vygenerovat si dokumentaci k implementaci. Při aktivaci této činnosti systém pokládá dotaz: „Opravdu vytvořit dokumentaci implementace systému?”. Po jejím vygenerování má uživatel tuto dokumentaci dostupnou v činnosti prohlížení dokumentace (pod menu Volby).

Po aktivaci činnosti prohlížení dokumentace má uživatel k dispozici přehled jednotlivých druhů procesů, u každého procesu přehled jeho operací, vazeb a transformací. Dokumentace je vytvořena ve formátu HTML.

2.3 Modelování řídícího a datového toku

2.3.1 „Struktura“ procesu

Uspořádání (posloupnost) aktivit (funkcí, operací, uzlů) je každému fyzickému procesu dáno do vínku diagramem daného druhu procesu, přičemž na základě reality může dojít k odchylkám od této struktury. Pro korektní zachycení odchylek jsou k dispozici následující funkce:

¨ zrušení nepotřebného uzlu fyzického procesu (uživateli se tím zvýší přehlednost diagramu). Nepotřebný uzel je možno zrušit:

- ručně – záleží vždy na rozhodnutí uživatele, ruší se většinou uzly, u kterých se při implementaci předpokládalo, že budou potřeba. Nepotřebný uzel se zruší v diagramu procesu stiskem pravého tlačítka myši na daném uzlu a výběrem možnosti „odstranit“. Společně s daným uzlem se zruší i vazby, které do něj (z něj) vedly.

- kódem po ukončení – v definici kódu po ukončení je možno nastavit kdy a za jaké podmínky se daný uzel má zrušit

- výběrovou vazbou XOR – tato vazba umožňuje uživateli zvolit si pokračování procesu, přičemž nepotřebné (tedy nezvolené) vazby jsou automaticky zrušeny

¨ připojení nového uzlu do fyzického procesu. K tomu je možno využít:

- ruční připojení v diagramu – tzn. uživatel si spustí diagram daného procesu a způsobem, který je popsán v ovládání diagramu procesu vloží nový uzel a vytvoří k němu příslušnou vazbu.

- ruční připojení ve stromu hlavního procesu – ve stromu hlavního procesu je možno u položky typu proces po stisku pravé myši aktivovat činnosti „kopírovat odkaz na proces“ (obdoba Windows příkazu Ctrl+C) a tento odkaz je možno k jinému procesu přiřadit (obdoba Windows příkazu Ctrl+V) opět po stisku pravého tlačítka myši na položce procesu, ke kterému chceme zkopírovaný odkaz přiřadit, a to volbou „napojit proces“, tzn. že k diagramu stávajícího procesu se v podstatě přiřadí i tento napojený proces.

Pokud bychom chtěli použít příklad z praxe, je možné toto využít např. v případě, kdy je dodatečně k vybrané objednávce třeba napojit příslušnou fakturu.

- referenčním procesem

¨ „rozpůlení“ procesu. Po stisku pravého tlačítka myši ve stromu hlavního procesu na daném procesu se jedná o možnost „osamostatnit proces“, která v podstatě vyřadí vybraný proces z daného nadřízeného procesu.

Významný vliv na chování procesů, a tím i zprostředkovaně na jejich modelování má také jejich interakce. V dané struktuře procesu se dále uplatňuje řídící i datový tok.

2.3.2 Modelování řídícího toku

Řídícím tokem procesu se rozumí rozhodování při běhu (provádění) fyzického procesu ve smyslu, co bude (může) následovat na základě aktuálního stavu procesu (tj. stavu všech definičních i aplikačních dat souvisejících s procesem, ale i jiných dat přímo nesouvisejících) a případného dialogu s uživatelem. Mezi typická rozhodování patří volba, který uzel procesu bude:

¨ automaticky spuštěn

¨ uveden do stavu připravena

¨ ukončen

¨ z diagramu odstraněn, protože se stal nadbytečným

Řídící tok je na dané struktuře (diagramu) procesu dále implementován pomocí:

¨ stavu (nejčastěji stav připravená) jednotlivých uzlů

¨ kódu po ukončení (uvede operaci do stavu připravena)

Stavy uzlů lze využít pro:

¨ definici uživatelských položek menu signalizujících, které operace (obvykle stav připravené) by měl uživatel vykonat (work-flow)

¨ automatické spuštění připravených operací

Po stránce logické diagram procesu umožňuje tyto logické vazby[13] mezi uzly, z hlediska cílového uzlu [14]:

¨ „základní“ – do cílového uzlu směřuje jediná vazba druhu běžná nebo samostatná

¨ slučovací AND – do cílového uzlu směřuje několik vazeb druhu běžná (výběrové vazby se z hlediska vlivu na stav cílového uzlu chovají stejně jako vazby běžné)

¨ slučovací OR – do cílového uzlu směřuje několik vazeb druhu samostatná (vazba pasivní žádným způsobem neovlivňuje řídící tok, slouží pouze pro datový tok, resp. umožňuje provést transformaci dat)

a z hlediska zdrojového uzlu:

¨ „základní“

¨ větvení OR – vazba OR

¨ větvení XOR – vazba XOR

¨ větvení AND – vazba běžná a samostatná

Tam, kde se nevystačí s modelovacím nástrojem daným druhy vazeb, nastupuje méně přehledný a implementačně složitější nástroj kód po ukončení operace, který z hlediska řídícího toku umožňuje implementovat uvedení uzlu do stavu připravená dle dat či rozhodnutí uživatele.

Poznámka: S kódem po ukončení operace je nutno pracovat velmi opatrně, protože jeho použití může mít sice velký krátkodobý efekt, nicméně z dlouhodobého hlediska může být jeho použití (zejména údržba implementace) poněkud složitější. Uvedeme-li si příklad z praxe, můžeme použít drogovou závislost. Po použití drogy je organismus „nastartován“ k vyššímu výkonu, ale tento výkon je pouze krátkodobý, z dlouhodobějšího pohledu organismus používáním drogy v podstatě odumírá.

O spouštění operací (uzlů) se rozhoduje takto:

¨ vyhledání a spuštění – tzn. uživatel si příslušnou operaci vyhledá například v činnosti Procesy a operace – Operace a klávesou F9 nebo aktivací příslušné činnosti z menu Volby operaci spustí (může jít o první spuštění operace nebo může jít o prohlížení již vytvořené operace)

¨ položka menu (work-flow) – při implementaci je možno pro uživatele vytvořit uživatelská menu, kde má jako položku menu připraveny vhodné operace ke spuštění (například činnost Operace byla zkopírována a pro uživatele byl nadefinován potřebný výběr[15], který se aktivuje při spuštění dané činnosti)

¨ automaticky – ve spuštěném procesu je daný uzel ve stavu připravena a současně má definováno ve vlastnostech spouštět automaticky. Pokud je ve stavu připravena několik uzlů současně, řídí automatické spuštění pořadí, které je nastavené u těchto uzlů.

Z praxe může nastat příklad, že po ukončení zdrojové operace jsou k automatickému spuštění připraveny např. tři uzly (pořadí 10, 20, 30), přičemž na uzel 10 jsou navázány ještě další tři uzly. Systém se potom chová následovně. Po ukončení zdrojového uzlu se automaticky spustí uzel s pořadím 10, přičemž uzly s pořadím 20 a 30 jsou uloženy do zásobníku operací. Jako následující se spustí operace, které jsou navázány na uzel 10 a po jejich ukončení je ze zásobníku automaticky spuštěn nejprve uzel s pořadím 20 a následně uzel s pořadím 30.

2.3.3 Modelování datového toku (možnosti vstupů dat)

Datovým tokem se rozumí otázka vstupu atributů událostí (zejména automatizace) při běhu (provádění) fyzického procesu. Patří sem zejména předplňování a validace dat. Datový tok tedy definuje způsob předání dat následujícím operacím. Mezi typické nástroje ovlivňující datový tok patří:

¨ importy dat

¨ kód po ukončení operace

¨ masky

¨ programový kód

¨ šablony

¨ transformace

¨ vstup údajů z klávesnice

Příkladem ideálního modelu datového toku je proces, jehož všechny operace jsou spouštěny na pozadí a který je zahájen pomocí procesního importu.

3. Fyzické procesy a jejich řízení

Fyzický proces je model výskytu jedinečného procesu z reálného světa, v informačním systému ho lze najít v činnosti Procesy a operace – Procesy.

3.1 Založení procesu (tj. spuštění)

Každý fyzický proces je určitého druhu a spustit ho lze těmito způsoby:

¨ z činnosti Nový proces – vybraný proces se aktivuje dvojklikem levého tlačítka myši

¨ z činnosti Informační centrum – Typy a řady – Druhy procesů – vybraný proces lze spustit po stisku klávesy F9 nebo výběrem příslušné činnosti z menu Volby

¨ napojením (spuštěním) z již vytvořeného fyzického procesu – toto spuštění je možné v činnosti Procesy, kde je proces možno aktivovat ze záložky „operace v procesu“ (po stisku F9[16]) nebo ze stromu hlavního procesu

3.2 Prohlížení a vyhledávání informací

Přehled všech vytvořených procesů má uživatel k dispozici v činnosti Procesy a operace – Procesy po načtení záložky Výběr. Na této záložce je možno množinu zobrazených dat určit pomocí atributů např. číslo procesu, druh procesu, identifikace adresáta, datum vzniku procesu apod. Po načtení záložky Výběr se uživateli zobrazí vlastní činnost Procesy, kde ale v podstatě vidí pouze hlavičku vytvořeného fyzického procesu.

Stav procesu, čili rozpracovanost jednotlivých uzlů, uživatel může zjistit takto:

¨ vyvoláním stromu hlavního procesu, kde má graficky zobrazen stav jednotlivých uzlů v procesu

¨ v menu Procesy a operace – Operace[17] si uživatel zvolí výběr, kde do položky komponenta zadá „procesy“ a do druhu operace zadá „identifikaci procesu“. Pak se mu zobrazí hlavička daného procesu a na pravé straně obrazovky má vidět stavy jednotlivých uzlů procesu.

¨ aktivací diagramu procesu

K určitému zjištění stavu procesu slouží v informačním systému Bílý Motýl i činnost průběh operací. Nezobrazuje však proces jako celek, ale jedná se o tabulku, kde má uživatel k dispozici přehled aktuálně vytvořených operací (uzlů) v daném procesu a jejich stavy.

Při běhu procesu, tedy při zpracovávání jednotlivých uzlů, je možno k uzlu typu operace připojit i zprávu. Zprávu k operaci je v podstatě možno připojit dvojím způsobem:

¨ v činnosti Informační centrum – Typy a řady – Druhy operací je záložka validace vstupu. Zde je možno nadefinovat komu (kterému uživateli – výběr z překryvného seznamu) a jaká zpráva se má poslat při dosažení nadefinovaných hodnot.

¨ při vytváření událostí operace je možno si před ukončením operace v menu Obecné zvolit činnost „odeslat zprávu“.

K zjištění stavu ukončenosti procesu je možno využít informací, které nám poskytuje semafor procesu i saldokontní hodnoty.

K zjištění stavu jednotlivých operací procesu lze též použít vlastnosti operace.

Vyhledání a prohlížení informací o procesu lze mnohdy využít pro pokračování ve vstupu dat do daného procesu.

3.3 Pokračování v procesu

Pokud již byl proces spuštěn, tzn.že nejméně jeden zdrojový uzel procesu byl zahájen, běží proces podle nastaveného diagramu procesu daného druhu. V diagramu procesu je možno u vybraných uzlů (tam kde je to vhodné a potřebné) nadefinovat jejich spouštění na pozadí, čímž je běh procesu značně urychlen a uživatelsky zpříjemněn.

Pokud je proces v určitém okamžiku zastaven (např. byla vytvořena objednávka a čeká se na dodací list nebo byla vystavena faktura a čeká se na přijetí výpisu z banky), tak v tomto okamžiku v podstatě nedochází k automatickému pokračování procesu a je nutno se nějakým způsobem napojit a pokračovat. K tomuto účelu uživatel využije některou variantu napojení do procesu.

3.4 Opravy

Pro opravy jednotlivých fyzických procesů má uživatel k dispozici tyto nástroje:

¨ storna

¨ zrušit stav ukončena

¨ přepsání existujících údajů, pokud to informační systém v dané situaci dovoluje

4. Tipy a triky

1. Pořadí vazeb – maska operace (opakovat) – v případě, že do jednoho uzlu (cílového) typu operace vede více stejných vazeb (např. všechny vazby běžné) z uzlů zdrojových, je možno k předplňování atributů do cílového uzlu využít masku operace. Pokud se u prvního uzlu nastaví pořadí např. 10 a ostatní uzly vedoucí do daného cílového uzlu budou mít pořadí např. 20, 30, 40 atd., a v masce operace u daného cílového uzlu bude např. u atributu datum nastaveno opakovat, bude se do cílového uzlu předplňovat datum z uzlu, který má pořadí 10 a toto datum se bude opakovat, tzn. že vstup uzlů s pořadím 20, 30, 40 toto datum již nijak neovlivní. Tímto způsobem je v některých případech možno zajistit správný vstup atributů z jednotlivých uzlů a nemusí to být pouze datum, ten zde byl uveden jako konkrétní příklad, může se jednat i o jiné atributy (záleží na konkrétních potřebách implementace).

2. Někdy je vhodné napojit (pasivní vazbou bez transformace) na poslední operaci (uzel) diagramu procesu ještě fiktivní operaci (vlastnost nespouštět) například komponenty vývěska, kterou si nazveme např. odblokovač - ta se nikdy nezahajuje, u této operace zatrhnout příznak „ukončuje proces“ a pak mají v podstatě všechny operace v případě potřeby trvale dostupnou funkci "Zrušit stav ukončená" (ve vlastnostech operace v menu Volby).

3. Při "odblokování" (tj. ve vlastnostech operace atribut „zrušit stav ukončena“) - pokud chceme opravit jen některou z prvních operací, nastavíme vazby z ní vedoucí na pasivní a tak nedojde ke zrušení cílových uzlů.

4. Při provádění storna – protože storno se provádí tak, že jednotlivé procesy se vlastně stornují postupně (od podřízených až k hlavnímu) a může nastat situace, že chceme sice vystornovat část hlavního procesu, nicméně třeba proces dodání, který je součástí tohoto hlavního procesu stornovat nechceme (chceme ho naopak zachovat), využijeme pro tuto eventualitu možností, které nám nabízí strom hlavního procesu. Vybraný proces dodání tedy „osamostatníme“ (levé tlačítko myši), zbylý hlavní proces vystornujeme a osamostatněný proces dodání můžeme znovu do tohoto procesu napojit.

5. Pokud máme vytvořený nějaký fyzický proces a chceme ho vystornovat bez vytvoření stornujícího procesu, je možné využít možnosti, kdy jednotlivé operace fyzického procesu otevřeme, vynulujeme (tzn. zrušíme jejich události), uzavřeme je tedy v podstatě prázdné a systém potom při provádění storna nevytváří stornující proces, ale tyto prázdné operace zruší a na hlavičce původního fyzického procesu je poznámka o tom, že je stornován.

[1] Činnost se nachází v menu Informační centrum – Typy a řady – Druhy operací.

[2] Na vlastnostech operace v diagramu procesu se zvolí po ukončení tisk operace a zároveň se zvolí příslušná tisková sestava.

[3] Klávesou F6 nebo volbou činnosti „vstupní maska operace“ z menu Volby.

[4] Tím nejsou míněny šablony dle slovníku pojmů.

[5] Stiskem pravého tlačítka myši na vazbě (čili šipce) má uživatel možnost zadávat, upravovat nebo rušit vlastnosti vazby.

[6] Mnohdy koresponduje s řídícím tokem modelovaným v kódu po ukončení.

[7] Pozor u některých atributů – může prázdný výraz být „přebit“ programovým kódem.

[8] Zadává se v činnosti Informační centrum – Typy a řady – Druhy procesů – atribut „řada“.

[9] Provede se u operace v diagramu procesu po stisku pravého tlačítka myši a volbě vlastnosti.

[10] Doklady je pak zpětně možno tisknout v činnosti Procesy po stisku klávesy F5 a v událostech jednotlivých komponent po stisku klávesy F11. Tisk zjednodušeného dokladu je možný v činnosti Operace po stisku klávesy F5.

[11] Operace se zapisuje v okamžiku zápisu události.

[12] Menu Informační centrum – Typy a řady.

[13] Mezi zdrojovým a cílovým uzlem diagramu nemusí být z hlediska řídícího toku definována žádná vazba, tj. tehdy je-li implementována vazba pasivní.

[14] uvedeno zjednodušeně

[15] Mnohdy obecný výběr.

[16] V této činnosti a na této záložce je nutno si uvědomit, že pokud se jedná o proces (identifikace velkými písmeny), tak se po stisku klávesy F9 vždy spouští nový proces, není zde možno klávesu F9 používat k prohlížení vytvořeného procesu.

[17] Fakticky v této položce menu nejsou operace, ale uzly.

© 1996-2013 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 07.10.2013


Marketing

O B S A H

1. Adresář.. 2

1.1 Adresář. 2

1.2 Kategorie adresátů. 14

1.3 Informace k adresátům... 15

1.3.1 Spojení adresátů. 15

1.3.2 Adresy adresátů. 16

1.3.3 Zařazení adresátů do kategorií 16

1.3.4 Bankovní spojení adresátů. 17

1.4 Číselníky a parametry. 18

1.4.1 Města. 18

1.4.2 Okresy. 18

1.4.3 Kraje. 18

1.4.4 Státy. 18

1.4.5 Oslovení 19

1.4.6 Typ spojení 19

1.4.7 Parametry adresáře. 19

1.4.8 Číselná řada adresátů. 20

1.4.9 Typy subjektů spojení 20

1.4.10 Druhy parametrů spojení 21

1.4.11 Duplicita adresátů. 21

1.4.12 Druhy adresátů. 22

1.4.13 Palety barev kategorií adresátů. 23

1.4.14 Konverze pro štítek v události pošty. 24

2. Vývěska.. 24

2.1 Kompletní vývěska. 24

2.2 Aktuální hodnoty vývěsky. 27

2.3 Významné uzly. 27

2.4 Uzly vývěsky. 28

3. Zprávy.. 29

3.1 Zprávy. 29

3.2 Oblíbené skupiny uživatelů. 32

3.3 Objekty Outlooku. 33

3.4 Deklarace Outlooku. 33

4. Dokumenty.. 34

4.1 Dokument. 34

4.2 Přehled o použití dokumentů. 39

4.3 Druhy dokumentů. 39

4.4 Kategorie dokumentů. 40

4.5 Předlohy dokumentů. 40

4.6 Spouštěné aplikace. 42

4.7 Konfigurace XML dokumentů. 43

5. Pošta.. 43

5.1 Pošta. 43

5.2 Aktuální hodnoty pošty. 46

5.3 Kategorie pošty. 46

5.4 Kategorie zásilky. 47

5.5 Doplňkové služby. 47

5.6 Uzavření dnešního dne. 47

5.7 Číselné řady kategorií zásilek. 47

6. Diář.. 48

6.1 Diář. 48

6.2 Kategorie diáře. 49

Obecně lze říci, že komponenta Marketing v sobě sdružuje činnosti, které zajišťují veškerou agendu firmy pro její kontakt s okolním světem (např. evidence adresátů a jejich veškerých potřebných údajů, evidence došlé a odeslané pošty, evidence přijatých a odeslaných dokumentů, evidence událostí týkajících se firmy, přijaté a odeslané zprávy, diář apod.). Uživatel má všechny tyto podstatné informace shrnuty do jednoho souvislého bloku a to je právě komponenta Marketing. Její jednotlivé činnosti si v následujícím textu popíšeme podrobněji.

1.Adresář

1.1 Adresář

Tato činnost se nachází v hlavním menu v komponentě Marketing – Adresář – Adresář a umožňuje prohlížet a aktualizovat vlastní adresář, tzn., že uživatel má k dispozici veškeré údaje o adresátech, jeho adresách, spojeních a zařazení adresáta v kategoriích. Každého adresáta je navíc možno přiřadit určitému druhu a k druhu adresátů je pak možno nadefinovat přístupová práva (viz. činnost druhy adresátů – adresář – číselníky a parametry).

Obr. 1

Po aktivaci činnosti adresář se uživateli vždy nejprve nabídne záložka Výběr (viz. popis dále) a teprve po jejím načtení má k dispozici celou řadu záložek, kde jsou umístěny jednotlivé detailní údaje k danému adresátovi. Jednotlivé záložky si v následujících odstavcích popíšeme podrobněji.

Na první záložce „Adresát“ (obr. 1) jsou k dispozici tyto atributy:

¨ adresát – identifikace a název ... Při zařazení nového adresáta je systémem automaticky předplněno číslo adresáta podle nadefinované číselné řady adresátů (o jedno vyšší než je poslední použité číslo adresáta). V případě, že v mezičase zařazování vložil jiný uživatel dalšího nového adresáta, je číslo adresáta automaticky změněno na další volné číslo v číselné řadě adresátů.

¨ IČO, DIČ

¨ implicitní adresa - identifikace

¨ konverze pro štítek události pošty

¨ vlastní adresa (pro správné fungování událostí DPH je zde nutno mít uvedeno u každého adresáta velmi přesně zda se jedná o adresáta tuzemsko/zahraničí/EU)

¨ identifikace spojení

¨ identifikátor typu subjektu pro spojení adresáta

¨ jméno, telefon, mobil, e-mail apod.

¨ obchodní selektor

¨ druh adresáta (na základě druhu adresáta lze definovat přístupová práva, tzn. adresáty si uživatel rozdělí do několika druhů a ke každému druhu pak nadefinuje přístupová práva. Druhy adresátů se definují v činnosti Číselníky a parametry)

Při vkládání adresáta může uživatel využít možnosti, kterou mu poskytuje doplňující vlastnost formuláře „předplnění adresáta podle ARES“. Po zadání názvu nebo IČO se uživateli předplní kompletní adresa adresáta a popř. i informativní hlášení, že je daný adresát z nějakého důvodu (např. konkurz, vyrovnání) uveden v registru Centrální evidence úpadců.

Další zajímavou vlastností adresáře je, že pokud uživatel potřebuje, lze si pomocí doplňující vlastnosti formuláře „Mapy“ zobrazit na mapě trasu k vybranému uživateli nebo více vybraným uživatelům najednou.

Na záložce „Adresy“ (obr. 2) má uživatel k dispozici jednotlivé adresy, které náleží uživateli. Každá adresa je následně spojena s určitým spojením adresáta (na záložce Spojení se u jednotlivých spojení zadává číslo adresy, která se spojením přímo souvisí).

Obr. 2

Na záložce „Spojení“ (obr. 3) má uživatel k dispozici tlačítko "Impl", kterým určuje, které spojení adresáta je implicitní, tedy to, které je pak následně zobrazováno na první záložce Adresát a které se automaticky předplňuje v událostech adresáta. Implicitní spojení je zobrazeno červeně. Při potřebě změny spojení je nutno umístit kurzor na zvolené spojení a stisknout tlačítko Impl.

Kromě základních údajů ke spojení (jméno, adresa, telefon, email, www stránky apod.) je k dispozici i atribut „alias“. Tento atribut představuje způsob zobrazení názvu adresáta v událostech ostatních komponent. Ve formuláři událostí komponent platby, sklad, obchod, zálohy, pošta, změna stavu peněz, vymáhání, vývěska a expedice se v atributu odpovídajícímu názvu adresáta zobrazuje jeho název v tomto složení – „název adresáta+město z adresy+kontaktní osoba ze spojení adresáta“. Je-li vyplněn atribut ALIAS, tj. forma, jak má být v událostech uveden název adresáta, zobrazuje se v událostech takto.

Obr. 3

Stejným způsobem lze nadefinovat implicitní bankovní spojení. Na záložce „Bankovní spojení“ (obr. 4) se stiskne tlačítko „Impl“ a implicitní bankovní spojení je zvýrazněno červeně. Bankovní spojení, která nejsou aktuální se zobrazí šedivě. Na záložce Bankovní spojení se evidují bankovní účty daného adresáta. V případě, že adresát má několik bankovních spojení, je vhodné si označit jedno bankovní spojení jako implicitní.

Mezi důležité informace, které jsou dostupné na záložce „bankovní spojení“ patří informace zda se jedná o účet či pokladnu, údaje o příslušné bance (adresa, číslo účtu, IBAN, měna a název účtu a zda je povolen na účtu debet).

Obr. 4

Záložka Kategorie (obr. 5) slouží k evidenci příslušnosti adresáta do kategorie. Při zakládání se vybírá kategorie, do které bude příslušet a zároveň je možno zadat datum zařazení (automaticky se předplňuje aktuálním datem). V případě vyřazení adresáta z kategorie se zadá i datum vyřazení. Každý adresát může být zařazen do několika kategorií. Při vlastní definici kategorie je možno vytvářet kategorie vstupované nebo vypočítané. Kategorie vypočítané je nutno zvlášť nadefinovat po stisku klávesy F5 pomocí činnosti „Definování typu kategorie adresáta“.

Tlačítko vpravo dole na formuláři představuje činnost „zařazení adresátů do kategorií“. Po jeho aktivaci se uživateli zobrazí detailní přehled kategorií daného adresáta a časové údaje (zařazení, vyřazení) k dané kategorii.

Na základě kategorie adresáta je v adresáři možno i jednotlivé adresáty označovat (viz. dále popis činnosti „Označování“).

Obr. 5

Záložka Kategorie spojení (obr. 6) poskytuje uživateli možnost zařazení spojení adresátů do kategorií. Uživatel vybere spojení adresáta, které chce zařadit do kategorie a zároveň určí i příslušnou kategorii. Do atributu zařazení se automaticky předplní aktuální datum.

Kategorie spojení lze využít např. v případě, že uživatel má u každého adresáta určenu jednu konkrétní osobu pro zasílání informací. Pak si např. vytvoří kategorii spojení INFO a do této kategorie vždy zařadí spojení, které se týká dané osoby.

Obr. 6

U každého adresáta má uživatel k dispozici 40 znaků pro zadání názvu adresáta. Pokud má adresát název delší, je možno využít na záložce "Další " (obr. 7) atributu "úplný název adresáta".

Obr. 7

Pokud uživatel chce, aby se mu se změnou (opravou) názvu adresáta automaticky změnil i úplný název adresáta, musí mít na záložce "další informace" zadáno u atributu "odpovídá názvu" hodnotu ANO. Jako další na této záložce je možno zadat:

¨ měna - pro každého adresáta je možno určit jeho implicitní měnu, tzn. měnu, která se bude automaticky předplňovat na událostech komponent v souvislosti s tímto adresátem

¨ EORI - registrační a identifikační číslo hospodářských subjektů (Economic Operators Registration and Identification number). EORI číslo musí být uváděno v celním prohlášení jako identifikátor subjektu a slouží jako společný identifikační údaj hospodářských subjektů a jiných osob při jejich kontaktu s celními orgány v celé Evropské unii.

¨ klíč – možnost zadání libovolného výrazu v případě velmi specifických rozlišení adresátů (v současné době není zřejmě již příliš využívaný atribut)

¨ rodné číslo – v případě potřeby možno uvést rodné číslo adresáta (využije se spíše u fyzických osob)

¨ konstantní symbol – předplňuje se pak v souvislosti s tímto adresátem v událostech plateb

¨ DPH – příznak plátce DPH (pro správné fungování procesů DPH je nutné mít u každého adresáta vyplněn právě příznak DPH a na první záložce místo, tzn. tuzemsko/zahraničí/EU)

¨ stav – aktuální/neaktuální

¨ komentář

Pro obchodní údaje nebo tisky na fakturách jsou určeny atributy na záložce „obchodní rejstřík“ (obr. 8).

Obr. 8

Podle nastavení filtru na záložce "výběr" (obr. 9) může uživatel ovlivnit množinu zobrazených záznamů v adresáři. Na výběr je několik třídících hledisek, navíc po stisku příznaku "uchovat" se nadefinované výběry uchovají a po dalším spuštění činnosti adresář se bude k potvrzení nabízet tento nastavený výběr.

Obr. 9

Kromě klasických vyhledávacích atributů (např. název, IČO, jméno, město apod.) má uživatel k dispozici i:

¨ kategorie – výběr adresátů dané kategorie (vstupovaná nebo vypočítaná kategorie platná k datu) nebo adresátů, pro které existuje spojení zařazené do odpovídající vstupované kategorie

¨ druh adresáta – pro každého adresáta je možné definovat jeho druh, jehož prostřednictvím se definují přístupová práva uživatelů k jeho informacím (adresa, bankovní spojení – viz. činnost druhy adresátů)

¨ paleta – umožňuje zobrazovat adresáty v mřížce (na formuláři adresář) v různých barvách v závislosti na jejich zařazení do kategorií

Uživatel např. bude mít vytvořenu paletu barev nazvanou odběratelé. Při definování hodnot do záložky výběr se systém potom chová následovně. Do názvu adresáta zadá písmeno „B“ a v překryvném seznamu zvolí paletu odběratelé. Pak systém vybere všechny adresáty, jejichž název začíná písmenem „B“ bez ohledu na to, jaká je zvolena paleta a ti z nich, kteří splňují podmínky definované v paletě odběratelé jsou označeni příslušnou barvou. V případě, že uživatel na výběrové záložce před atributem paleta označí zaškrtávací políčko, vybírá systém adresáty, jejichž název začíná písmenem „B“ a zároveň splňují podmínky definované v paletě odběratelé. V menu Volby je pak k dispozici funkce 'Legenda palety barev', která zobrazí okno s přehledem barev aktuálně zvolené palety, tzn. že pak uživatel snadno pozná, která kategorie v paletě má přiřazenu kterou barvu.

Na záložce výběr, ale samozřejmě i kdekoliv na jiných atributech v činnosti marketing lze využít možností, kterou uživateli nabízí činnost „automatické dokončování“.

V atributech na záložce výběr (možná ale nejčastěji na názvu adresáta) je možno využít při vyhledávání i různých matematických znaků, např.:

¨ % - nahrazuje jakýkoliv znak, tzn. uživatel hledá název firmy, o kterém neví, jak začíná, nicméně ví, že obsahuje slovo „stavební“. Pak do názvu firmy ve výběru zadá „%stavební“ a systém mu vyhledá všechny firmy, které na jakémkoliv místě ve svém názvu mají slovo stavební. Stejné je to i s jinými výběrovými atributy. Pokud tedy uživatel u některého výběrového atributu neví přesně, jakým způsobem je v systému zadán (pokud ví jistě, že firmu např. Compaq má v systému zadanou jako Compaq, není nutno před název firmy psát %, ale napíše rovnou začáteční písmena názvu firmy) je vhodné využít jako první výběrový znak právě % a za něj napsat výraz, který hledáme. I v případě, že uživatel rovnou napíše název firmy, systém přesto automaticky na konec tohoto zadaného slova přiřazuje znak % (uživatel ho tam tedy nepíše, ale systém si ho při vyhledávání přiřazuje sám)

¨ xx % - při vyhledávání podle přesně zadaného slova (tzn. je napsán hledaný výraz, mezera, procento). Tímto způsobem je pak při hledání např. výrazu „servis %“ zajištěno, že systém bude hledat opravdu jen a právě výrazy „servis“ a nikoliv i výrazy, které mají výraz „servis“ použitý kdekoliv ve svém názvu.

¨ _ - podtržítko nahrazuje právě jeden vybraný znak, např. uživatel má zadáno „diskuse“, ale i „diskuze“. Uživatel potřebuje najít jak výrazy s použitým „s“, tak i výrazy s použitým „z“, pak je výběr zapsán takto „disku_e“. Jinými slovy podtržítko nahrazuje na dané pozici jakýkoliv znak. Pokud se jako uživatel rozhodnu, že chci vybrat všechny firmy, které mají na 3. pozici v názvu písmeno A, tak zadám výběr takto: _ _ a %, tzn. první dvě místa cokoliv, na třetí pozici písmeno A a dál může něco být nebo nemusí.

¨ [] - hranaté závorky umožňují vybrat na zvolené pozici znak nebo množinu znaků, např. máme zapsáno kurz, ale i kurs. Chci vyhledat oba tyto výrazy, pak napíšu „kur[sz] a systém najde obě dvě varianty. Když bychom si tento výběr uvedli na příkladu čísel, pokud do závorek zadáme např. [56], systém bude hledat buď 5 nebo 6, pokud to bude zadáno [4-6], systém vyhledává 4 nebo 5 nebo 6.

¨ [^] - znaky uvedené v takové hranaté závorce znamenají, že systém má na zvolené pozici vyhledávat vše kromě uvedených, tzn. negace výběru. Např. pokud je zadáno [^4-6], systém na daném místě vyhledá znaky kromě 4 nebo 5 nebo 6.

Tyto výběrové možnosti je samozřejmě možno libovolně kombinovat, nutno však mít na zřeteli, že prostor pro zapsání výběrového výrazu je dán velikostí pole.

U činnosti adresář stojí za samostatnou poznámku položka adresát, která je na obrazovce zvýrazněna tučně. Po jejím stisku "tlačítkem myši" se zobrazí (obr. 10) následující nabídka, ze které má uživatel možnost si přímo vyvolat:

¨ události adresáta (např. události obchodu, skladu, plateb, ...)

¨ aktuální hodnoty adresáta

¨ obratové hodnoty adresáta

¨ adresář

¨ adresy adresátů

¨ spojení adresátů

¨ bankovní spojení

¨ cenové skupiny adresátů

¨ předkontace adresáta

¨ strom adresáta

¨ vztahy k obchodním artiklům

Obr. 10

Každou z těchto činností je možno po stisku tlačítka myši aktivovat. Některé z těchto činností si uživatel může vyvolat i po stisku příslušné ikony, která se nabízí v levém dolním rohu.

Další činnosti poskytují uživateli jednotlivé záložky v horní liště. Pod menu Volby jsou pro uživatele k dispozici činnosti, které mu činnost adresář umožňuje v daný okamžik využívat, např.:

¨ předkontace adresáta –

Předkontaci adresáta lze vyvolat volbou příslušné činnosti z menu Volby nebo po stisku klávesy F7. Nejčastější definovanou předkontací adresáta je individuální nastavení splatnosti pohledávky. V případě, že v obecných předkontacích je vytvořena i obecná předkontace typu BMSPL2, pro niž platí, že datum splatnosti pohledávky se vztahuje k datu zdanitelného plnění, tak se uživateli zobrazuje následující nabídka:

¨ splatnost je vzhledem k DZP – tuto možnost uživatel využije v případě, že implicitní dobu splatnosti pohledávky chce vztahovat k datu zdanitelného plnění (tzn. tj. shodné s datem platby). Pak se datum splatnosti pohledávky tvoří způsobem: datum platby + uvedená individuální implicitní doba splatnosti pohledávky. V případě, že datum splatnosti chce uživatel takto využívat, musí v tomto atributu mít uveden text začínající malým nebo velkým písmenem A (např. Ano).

¨ splatnost pohledávky – individuální počet dní splatnosti pohledávky daného adresáta

¨ cenové skupiny –

Tato činnost poskytuje uživateli přehled o nadefinovaných cenových skupinách daného adresáta a slouží pro předplnění cenových skupin adresáta v událostech obchodu. Aktivuje se z činnosti adresář po stisku klávesy F9 nebo spuštěním příslušné činnosti z menu Volby. K dispozici jsou tyto údaje:

¨ identifikace adresáta (je předplněna)

¨ číslo spojení adresáta

¨ skupina – cenová skupina

¨ OS – v případě, že to uživatel využívá, tak číslo obchodní smlouvy

¨ umístění – umístění obchodu (výběr z číselníku)

¨ artikl – zadaná maska technicko-věcného selektoru (může být zadán konkrétní, jeho část nebo vybrány všechny)

¨ % slevy

¨ výběr podle OS – volba Ano/Ne – souvisí s vyplněním atributu OS – pokud ho uživatel uvádí a následně chce cenovou skupinu s touto slevou uplatnit pro adresáta pouze u této smlouvy, ponechá volbu Ano

¨ priorita – implicitně předplněna hodnotou 5. V případě, že adresát je uveden v několika cenových skupinách, pak se do události obchodu předplní ta cenová skupina, které je zde uvedena priorita s nižším číslem.

¨ strom adresáta –

Jedná se o činnost, která uživateli umožňuje sestavit si informace o adresátovi přehledně ve stromovém vyjádření. Tuto činnost má uživatel k dispozici v hlavním menu v činnosti adresář pod menu Volby nebo po stisku klávesy F5. Dále ji má dostupnou na každém labelu „adresát“ (tzn. po stisku pravého tlačítka myši na tučně zvýrazněném atributu adresář).

Po aktivaci této činnosti se uživateli otevře nové okno s činností strom adresáta. Uživateli se zobrazuje název adresáta a pod ním jsou navěšeny jednotlivé adresy adresáta (stiskem znaménka + se adresa rozbalí). V dolní části okna této činnosti má uživatel ještě k dispozici menu „vývěska a dokumenty“. Po kliknutí myši na tomto menu se uživateli zpřístupní znaménko + a po jeho rozbalení má k dispozici události vývěsky (dvojklikem na názvu se menu rozbalí ihned), které byly vytvořeny s tímto adresátem a dokumenty, které se týkají tohoto adresáta. Po stisku pravého tlačítka myši kdekoliv v prostoru okna této činnosti má uživatel k dispozici tyto možnosti:

¨ obnovit – při jakékoliv změně v adresáři se touto činností aktualizuje strom adresáta

¨ následníci – vývěska – vyvolá se okno činnosti události vývěsky, které jsou k dané události ve vztahu následník (tzn. syn)

¨ následníci – dokumenty – vyvolá se okno činnosti dokumenty, které jsou k dané události připojeny jako objekty pomocí objektových vazeb (tzn. přes Ctrl D)

¨ spojení adresáta – zobrazí se okno činnosti s přehledem nadefinovaných spojení adresáta

¨ označování –

Činnost označování si uživatel aktivuje v menu Volby nebo stiskem klávesy Ctrl O. Zobrazí se mu pak následující nabídka:

¨ označení všech – označí se (tzn. zaškrtnou) všechny vybrané záznamy

¨ odznačení všech – odznačí se všechny v danou chvíli označené záznamy (i ty nevybrané)

¨ přehled označených / všech – při první aktivaci tohoto tlačítka se uživateli zobrazí přehled označených záznamů[1], při dalším stisku se zobrazí přehled všech vybraných záznamů (funguje jako přepínač)

¨ počet označených záznamů – uživateli je poskytnuta informace o počtu aktuálně označených záznamů. Stejnou informaci má uživatel i na dolní liště okna činnosti.

¨ označování výrazem

Pod menu Obecné zkušenější uživatel může využít i činnosti Volné karty adresáta a Volné karty selektorů.

1.2 Kategorie adresátů

Činnost uživatel aktivuje v hlavním menu – Marketing – Adresář – Kategorie adresátů. Tato činnost slouží k vedení evidence (vkládání, editace, rušení) jednotlivých kategorií adresátů, které se potom následně mohou přiřadit jednotlivým adresátům nebo kategoriím spojení.

Po aktivaci této činnosti má uživatel k dispozici nejprve záložku „výběr“, kde je nutno specifikovat množinu vybíraných dat. Pokud uživatel chce vidět všechny nadefinované kategorie, nechá výběrovou záložku prázdnou, pouze potvrdí tento prázdný výběr. Vybírat lze podle identifikace kategorie, názvu, uplatnění (zda se jedná o kategorii adresáta nebo o kategorii spojení adresáta) a typu (kategorie vstupované či vypočítané).

Po potvrzení záložky „výběr“ má uživatel k dispozici následující formulář (obr. 11).

Obr. 11

U každé kategorie se definuje:

¨ identifikace a název kategorie

¨ uplatnění – překryvný seznam s možností výběru – kategorie adresáta/kategorie spojení adresáta (znamená, zda definovaná kategorie bude novou kategorií pro adresáty nebo bude kategorií pro spojení adresátů)

¨ typ – vstupovaná/vypočítaná. Př.: SQL vypočítané kategorie „Dodací spojení“ podle realizovaných dodacích listů –

if exists (select * from %%%.obudal where ad01id=@ad01id and ad11cisspo=@ad11cisspo and sp07idtyp=’dodlis’) then 1 else 0 endif. Vstupovaná kategorie se vytváří přímo v této činnosti. Pro kategorii Vypočítanou je nutno nejprve nadefinovat SQL dotaz, což uživatel provede v činnosti „Definování typu kategorie adresáta“ (menu volby nebo pomocí klávesy F5). Zde se nadefinuje vypočítaná kategorie a k ní příslušný SQL dotaz.

¨ komentář – libovolný popis ke kategorii

Kategorii spojení adresáta je možno použít ve formuláři Druhy operací na záložce Spojení, kde se definuje přesný algoritmus předplňování spojení adresáta v událostech.

Přiřazení kategorie adresátům je možno si prohlédnout na záložce "adresáti v kategorii", kde si pomocí klávesy F3 může uživatel z adresáře vybrat adresáta, kterého chce následně zařadit do dané kategorie. U vybraného adresáta může zvolit i období (od -do) přítomnosti adresáta v kategorii. Toto období je pak možno využít při různém označování kategorií apod. U každého adresáta v kategorii je i adresa implicitního spojení.

Jednotlivým kategoriím je možno přiřadit i vybranou barvu, tj. záložka "barvy". Adresáti v takto označené kategorii pak budou v adresáři zobrazeni vybranou barvou. Takto je možno si označit např. neplatiče nebo naopak velmi významné klienty. V případě, že adresát je uveden v kategorii, která je zvýrazněna některou barvou a zároveň spadá do kategorie, která je uvedená v paletě barev a má rovněž určenu zvýrazňovací barvu, uplatní se barva, která je uvedena v paletě barev kategorií.

1.3 Informace k adresátům

1.3.1 Spojení adresátů

Tato činnost je pro uživatele dostupná v hlavním menu – Marketing – Adresář – Informace k adresátům – Spojení adresátů. Jako první se po aktivaci činnosti uživateli nabídne záložka „výběr“, kde si může vyplnit jednotlivé atributy podle kterých chce konkrétní spojení vyhledat.

Po potvrzení záložky „výběr“ se uživateli nabídne formulář spojení adresátů, kde je implicitně jako aktivní první záložka „spojení adresáta“, kde jsou k dispozici následující informace:

¨ číslo adresáta a číslo spojení adresáta

¨ typ subjektu

¨ adresát spojení subjektu adresáta (ve většině případů se uvádí pouze „-„)

¨ kontaktní osoba včetně její funkce a možného oslovení

¨ číslo adresy adresáta

¨ mobil, fax, email apod.

¨ alias – název adresáta pro zobrazení jeho názvu v událostech ostatních komponent (ve formuláři událostí komponent platby, sklad, obchod, zálohy, pošta, změna stavu peněz, vymáhání, vývěska a expedice se v atributu odpovídajícímu názvu adresáta zobrazuje jeho název v tomto složení – „název adresáta+město z adresy+kontaktní osoba ze spojení adresáta“. Je-li vyplněn atribut ALIAS, tj. forma, jak má být v událostech uveden název adresáta, zobrazuje se v událostech tento).

¨ komentář ke spojení

Na záložce Kategorie spojení se definuje, do které kategorie je dané spojení případně zařazeno. Při zařazování spojení do kategorie uživatel zadává identifikaci kategorie a datum zařazení (předplňuje se aktuální datum). Kategorie spojení adresáta je informace, která je viditelná i v činnosti Adresář (záložka Kategorie spojení). Atribut „kategorie“ na záložce Výběr vybírá pouze spojení zařazená do kategorií s uplatněním „kategorie spojení adresáta“ (definuje se v činnosti Kategorie adresátů), v potaz bere platné kategorie spojení vstupované a vypočítané.

Na záložce Výběr v událostech komponent platby, sklad, obchod, zálohy, pošta, změna stavu peněz a vymáhání je možno vybírat i podle spojení adresáta. Spojení adresáta je k dispozici i v událostech komponenty vývěska.

Vyvolání přehledu událostí adresáta po pravém kliku na návěští adresáta předplňuje na výběrovou záložku spojení adresáta, pokud není nastaven v 'Nastavení BM' parametr 'Vyber_spojeni_adresata=0' v sekci 'Komponenta-XXX', kde XXX odpovídá identifikaci komponenty.

U každého spojení je důležitá i záložka „parametry“, kde jsou k dispozici jednotlivé parametry a jejich hodnoty. Ty vychází z toho, jak jsou nadefinované typy parametrů u typu subjektu spojení. U každého parametru se eviduje jeho platnost od - do, což uživateli umožňuje sledovat jednotlivé parametry v čase. Neplatný parametr je zobrazen šedivě.

Pod menu Volby má uživatel k dispozici činnost "Export do Outlooku", která umožňuje exportovat zobrazená spojení adresátů do adresáře Outlooku. Opakovaný export aktualizuje již dříve exportovaná spojení (tato činnost je pro uživatele dostupná, pokud je nadefinována příslušná doplňující vlastnost formuláře).

1.3.2 Adresy adresátů

Tato činnost je pro uživatele dostupná v hlavním menu – Marketing – Adresář – Informace k adresátům – Adresy adresátů. Jako první je opět k dispozici záložka „výběr“, kde si uživatel může určit množinu dat, kterou chce mít následně k dispozici (např. adresy pouze konkrétního adresáta či za konkrétní město, PSČ apod.).

Tato činnost poskytuje uživateli přehled o všech dosud zapsaných adresách daného adresáta. Jedná se pouze o informativní přehled, měnit implicitní spojení zde nelze.

Na základě toho, jak jsou nastaveny parametry v typech subjektů spojení, je možno jednotlivé adresy adresáta sledovat i v čase, tzn. jsou zde zaznamenány všechny adresy adresáta, a ty, které již nejsou platné jsou zvýrazněny šedivě.

1.3.3 Zařazení adresátů do kategorií

Tato činnost je pro uživatele dostupná v hlavním menu – Marketing – Adresář – Informace k adresátům – Zařazení adresátů do kategorií. Jako první se uživateli nabízí k vyplnění záložka „výběr“, kde jsou k dispozici pouze dva výběrové atributy (lze vybírat podle identifikace adresáta nebo identifikace kategorie).

Tato činnost slouží k vedení evidence jednotlivých kategorií, které jsou přiřazeny k adresátům, resp. jedná se pouze o přehled adresátů, kteří jsou ve vybraných kategoriích zařazeni (v této činnosti nelze adresáty do kategorie zařazovat). Pokud uživatel neupřesní údaje na záložce „výběr“[2] má k dispozici přehled kategorií a zároveň všech adresátů, kteří jsou do dané kategorie zařazeni. U každé kategorie se eviduje:

¨ adresát – identifikace adresáta, který je v kategorii zařazen

¨ kategorie - identifikace kategorie

¨ platnost kategorie od – do – datum platnosti adresáta v kategorii

¨ komentář

1.3.4 Bankovní spojení adresátů

Tato činnost je pro uživatele dostupná v hlavním menu – Marketing – Adresář – Informace k adresátům – Bankovní spojení adresátů. Na první aktivní záložce „výběr“ si uživatel může nadefinovat množinu dat, kterou chce mít následně k dispozici. Lze vybírat podle identifikace adresáta, hledat konkrétní účet, měnu apod.

Ke každému adresátovi v IS je možno přiřadit nejméně jedno bankovní spojení. V případě potřeby je možno zvolené spojení označit jako implicitní (provádí se v adresáři na záložce „bankovní spojení" pomocí tlačítka Impl. nebo z menu Volby pomocí klávesy Ctrl B a pak se v přehledu bankovních spojení zobrazuje červeně). Takto zvolené bankovní spojení se pak na událostech jednotlivých operací implicitně zobrazuje u vybraného adresáta.

Po načtení záložky výběr má uživatel k dispozici následující údaje, které může prohlížet, opravovat a rušit a zároveň může zadat i nový údaj. V takovém případě vstupuje tyto položky:

¨ adresáta, jehož bankovní spojení se zakládá (výběr z adresáře)

¨ účet – identifikátor na bankovní spojení adresáta (automaticky se při vstupu nového bank.spojení čísluje)

¨ typ - zda se jedná o účet či pokladnu

¨ údaje - pokud se jedná o účet, zadávají se údaje týkající se banky (tj. kód banky, adresa, pobočka, číslo účtu a specifický symbol). Kód banky uživatel vybírá z číselníku bank, kde by u každého kódu měla být vyplněna i adresa. Po výběru kódu banky se automaticky předplní i adresa.

¨ aktuální – tento atribut nabývá hodnoty Ano/Ne. Vstupuje se ve formulářích 'Adresář' a 'Bankovní spojení adresátů'. V mřížkách těchto formulářů jsou neaktuální bankovní spojení zobrazeny na šedivém podkladě. V této činnosti je možno na výběrové záložce vybírat spojení podle této vlastnosti.

¨ IBAN – mezinárodní bankovní číslo účtu

¨ měna - kód a název oceňovací jednotky

¨ debet – příznak možnosti debetu v pokladně. V případě zaškrtnutí tohoto atributu se stav pokladny (resp. aktuální hodnota uvedená v činnosti „základní druhy hodnot“) nekontroluje. V případě nezaškrtnutého atributu se při zadání debetu pokladny kontroluje stav poklady. Pokud se zadáním debetu dosáhne záporných hodnot v pokladně, program zobrazí chybové hlášení a není možno tuto událost zapsat.

¨ název účtu

¨ komentář

V zahraničních bankách je obvyklé, že jsou na jednom účtu vedeny zůstatky více měn. Toto je možné nadefinovat na záložce „další měny účtu“. Na první záložce „bankovní spojení – pokladna“ se stále uvádí základní měna účtu. V události změny stavu peněz je možné vstupovat do položky Měna účtu v případě, že bankovní účet je typu 'účet' a má definované 'Další měny'.

1.4 Číselníky a parametry

Jedná se o činnost dostupnou v hlavním menu – Marketing – Adresář – Číselníky a parametry. Poskytuje uživateli přehled všech následujících číselníků, které se zde v těchto činnostech definují, případně opravují či ruší a pracuje se s nimi v dalších činnostech týkajících se adresáře.

1.4.1 Města

Po aktivaci této činnosti se uživateli jako první aktivuje záložka „výběr“, kde si může vydefinovat množinu měst, kterou chce mít k dispozici a to např. podle PSČ (či jeho prvních číslic), názvu města, okresu či státu. Pokud chce uživatel vidět číselník měst kompletní, ve výběru nezadá žádný atribut a načte (ikona disketa) výběr prázdný.

Zobrazí se mu přehled měst, kde u každého města jsou na pravé straně formuláře k dispozici tyto atributy:

¨ PSČ

¨ číslo obce

¨ město

¨ UTO

¨ okres

¨ stát

¨ postavení obce

1.4.2 Okresy

Uživateli má po aktivaci této činnosti k dispozici přehled jednotlivých nadefinovaných okresů. Uživatel může v případě potřeby zadat nový okres, či opravovat či rušit stávající. U každého okresu je informace o identifikaci a názvu okresu a kraji. V případě dalšího individuálního identifikačního členění lze využít atribut jiná identifikace.

1.4.3 Kraje

Stejný typ číselníku jako předchozí okresy. Po jeho aktivaci se zobrazí přehled nadefinovaných krajů, kde u každého kraje je info o jeho identifikaci a názvu, případně opět možnost zadat si jinou identifikaci.

1.4.4 Státy

Stejný typ číselníku jako předchozí okresy. Po jeho aktivaci se zobrazí přehled nadefinovaných států. U každého státu jsou k dispozici tyto atributy:

¨ identifikace a název státu

¨ oficiální název

¨ název v cizí řeči

¨ název v angl.

¨ SČZ (směrové číslo státu pro telefonní spojení)

1.4.5 Oslovení

V této činnosti uživatel definuje (případně opravuje či ruší) číselník oslovení, který lze následně využít na záložce „spojení“ v činnosti Adresář.

1.4.6 Typ spojení

Jedná se o historický číselník, který v současných verzích nemá uplatnění. Tyto jednotlivé typy spojení jsou nahrazeny číselníkem druhů parametrů spojení, který uživatel využívá při definici typů subjektů.

1.4.7 Parametry adresáře

V této činnosti má uživatel k dispozici jednotlivé parametry, jejichž nastavení následně ovlivňuje chování vybraných atributů v činnosti Adresář. Jednotlivé parametry si podrobněji popíšeme:

¨ validace duplicity IČO - je-li zatrženo, proběhne po zadání IČO kontrola duplicity. V případě, že uživatel vstoupil nového adresáta s IČO, které již v adresáři existuje nebo změnil IČO dříve založeného adresáta na IČO, které již v adresáři existuje, je zobrazen formulář s hlášením: „IČO …… bylo již užito pro adresáta ….. „. Po stisku tlačítka OK systém povolí vstup adresáta se zadaným duplicitním IČO. Po stisku tlačítka Storno systém nutí uživatele IČO změnit. V případě potřeby je možno při stisku tlačítka OK zaškrtnou volbu „Vypnout kontrolu duplicitního IČO pro toto spuštění formuláře“, která způsobí potlačení kontroly duplicitního IČO pro právě aktuálně spuštění formulář „Adresář“ (využije se např. při importu dat do adresáře).

¨ validace duplicity telefonu - je-li zatrženo, proběhne po zadání telefonního čísla kontrola duplicity. Případná duplicita je systémem nahlášena. Za duplicitní jsou považována shodná tel. čísla ve stejném státě a stejném UTO. Ze seznamu telefonních čísel (u jedné adresy) systém vždy kontroluje jenom první.

¨ validace duplicity faxu - je-li zatrženo, proběhne po zadání faxového čísla kontrola duplicity. Případná duplicita je systémem nahlášena. Za duplicitní jsou považována shodná fax. čísla ve stejném státě a stejném UTO. Ze seznamu faxových čísel (u jedné adresy) systém vždy kontroluje jenom první.

¨ validace duplicity rodného čísla - je-li zatrženo, proběhne po zadání rodného čísla adresáta kontrola duplicity. V případě, že systém najde stejné rodné číslo u jiného adresáta, upozorní uživatele informativní hláškou, že rodné číslo je již užito u "název" adresáta.

¨ kontrola rodného čísla MOD11 - je-li zatrženo, tak při vkládání rodného čísla adresáta probíhá kontrola rodného čísla podle Modulo11, tzn. zda je rodné číslo zapsáno ve správném tvaru (tato kontrola v podstatě zajistí, že není možné vložit rodné číslo v chybném formátu)

¨ aktuální stát - identifikace aktuálního státu. Aktuální stát se předplňuje při vkládání nových měst v číselníku měst. Spolu s identifikací aktuálního státu se z číselníku předplňuje i jeho název.

¨ české PSČ - pokud je tato volba zatržena, je při zadávání PSČ nutno vyplňovat PSČ ve formě obvyklé v ČR (např. 370 01).

¨ implicitní adresát - identifikace implicitního adresáta. Tento parametr v podstatě splňuje funkci činnosti "označení sama sebe" (tzn. v činnostech, kde se pak vyskytuje adresát typu „já“ se automaticky předplňuje vaše adresa).

1.4.8 Číselná řada adresátů

Tato činnost slouží k zajištění jednoznačnosti čísel adresátů na jednotlivých pracovních místech. U každého pracovního místa (např. dvě odloučená pracoviště jedné firmy) má uživatel možnost určit si interval čísel, ve kterém může zadávat nové adresáty. Nemůže potom nastat situace, že na jednotlivých odloučených pracovištích bude více adresátů se stejným číslem (v současné době toto zřejmě není příliš často používaná činnost).

1.4.9 Typy subjektů spojení

Jedná se o typy subjektů spojení, které se pak využívají při práci s adresářem, např. při zadávání nového adresáta a jeho spojení. U každého subjektu se zadává typ a jeho název. Typem může být např. adresa nebo určité obchodní spojení pro distribuci informací apod. Jednotlivé typy subjektů spojení lze využívat i při definici spojení adresátů v událostech komponent (např. jiný typ spojení adresáta v platbách při fakturaci, jiný typ spojení adresáta v poštovních událostech pro adresu, na kterou se odesílá pošt. zásilka apod.).

U každého typu subjektu jsou ovšem důležité parametry, které uživatel zadává na záložce "druhy parametrů". Vstupuje následující údaje:

¨ druh - identifikace spojení (např. adresa, mobil, email, telefon apod.)

¨ název spojení

¨ pořadí

¨ inicializovat - ve většině případů je zadáno Ne a uživatel si jednotlivé parametry u spojení adresátů vstupuje ručně. V případě, že se zde zadá Ano, je parametr ve spojení adresátů vytvořen automaticky, např. pokud zadáme inicializovat Ano u parametru email, tak bude v parametrech spojení adresátů vytvořen parametr email, jehož hodnota bude samozřejmě prázdná (uživatel zde bude muset emailovou adresu dopsat), ale parametr pro zadání správné hodnoty již bude připraven.

Po zadání typu subjektů a jeho parametrů uživatel aktivuje činnost "naplnění parametrů spojení" (menu Volby). Ta naplní jednotlivé parametry ke všem adresátům v adresáři, kteří mají v adrese uveden daný typ subjektu a u parametrů nastaveno inicializovat „Ano“.

Jednotlivé zadané parametry u typu subjektu se u každého adresáta rovněž evidují v čase, tzn. pokud dojde např. ke změně adresy nebo telefonního čísla, bude k dispozici jak nový parametr, tak i ten starý, jako nefunkční označen šedivou barvou.

1.4.10 Druhy parametrů spojení

Jedná se o druhy parametrů, které uživatel zadává při definici typů subjektů na záložce „druhy parametrů“. U každého parametru se definuje:

¨ druh a název parametru

¨ ikona parametru daného druhu ve stromu (možnost výběru z číselníku ikon)

¨ formát zobrazení v gridu a ve stromu (např. u druhu parametru adresa může vypadat takto: „trim(##ad02mesto##)+iif(empty(##ad02ulice##),'',', '+##ad02ulice##)“)

¨ unikátní pro adresáta

¨ unikátní pro spojení

Pro každý druh spojení se navíc zadává i jeho definice struktury, záložka "definice struktury". Definují se následující atributy:

¨ hodnota – identifikace druhu elementární hodnoty

¨ odpovídá – kterému odpovídá atributu spojení

¨ návěští

¨ stavový řád

¨ validace

¨ délka

¨ desetiny

1.4.11 Duplicita adresátů

Pod pojmem duplicita si můžeme představit jakési zdvojení, tzn. že duplicita adresátů nastane, pokud je daný adresát v systému přítomen dvakrát. Duplicitě adresátů lze částečně zabránit nastavením validace IČO nebo rodného čísla (v činnosti parametry adresáře), tzn. že systém pak při vkládání hlásí, že adresáta s tímto IČO či rodným číslem již v systému má.

Z hlediska udržení správnosti dat bude u této činnosti zřejmě vhodnější, pokud bude přístupná pouze správci systému nebo uživatelům s právy správce či zvoleným uživatelům, kteří mají tuto činnost povolenu v „oprávnění k činnostem“.

Na záložce "Adresát" formuláře "Duplicita adresátů" se uvádí:

1. původní adresát (tj. adresát, jehož chceme v systému zrušit, ale je nejprve nutno převést všechny vazby na nového adresáta. Dokud nejsou převedeny všechny vazby, nelze adresáta zrušit.)

2. aktuální adresát (tj. adresát, jehož údaje chceme i nadále v systému zachovat)

Záložka "Spojení" definuje, která spojení původního adresáta odpovídají spojením aktuálního adresáta. Záložka "Bankovní spojení" definuje, která bankovní spojení původního adresáta odpovídají bankovním spojením aktuálního adresáta.

Po nastavení dat popisující duplicitu adresátů je možné z menu "Volby" vyvolat funkci "Zaměnit vazby na původního". Tato funkce převede datové vazby směrované na původního adresáta aktuálnímu adresátovi tak, aby bylo možné následně původního adresáta běžným způsobem zrušit. Je měněn odkaz na původního adresáta podle záložky "Adresát", na jeho spojení podle záložky "Spojení", na jeho bankovní spojení podle záložky "Bankovní spojení" všude tam, kde se tyto vyskytují jako cizí klíče (např. v událostech komponent). Navíc jsou kopírovány objektové vazby původního adresáta k aktuálnímu adresátovi.

Záměna adresátů v událostech komponenty zálohy není provedena, pokud pro původního adresáta existuje událost typu "vyúčtování" zálohy. V tomto případě je třeba odpovídající operace odblokovat a události vyúčtování smazat a po provedení funkce "Zaměnit vazby na původního" opakovaně tyto události vytvořit pro aktuálního adresáta. Nedefinovaná spojení původního adresáta na záložce "Spojení" způsobí, že tato spojení budou zkopírována ke spojením aktuálního adresáta (včetně adres). Přitom informace o tom, že tato nově založená spojení aktuálního adresáta jsou totožná s odpovídajícími spojeními původního adresáta se zapíše do dat tak, že se po provedení funkce začnou objevovat na záložce "Spojení", jako kdyby je uživatel zadal ručně. To umožňuje tuto funkci spouštět opakovaně.

Nedefinovaná bankovní spojení původního adresáta na záložce "Bankovní spojení" fungují obdobně jako nedefinovaná spojení původního adresáta na záložce "Spojení" s tím rozdílem, že bankovní spojení původního adresáta není k aktuálnímu adresátovi přidáváno v případě, že u něho již existuje bankovní spojení se stejným kódem banky, prefixem účtu, číslem bankovního účtu a specifickým symbolem.

1.4.12 Druhy adresátů

Pro každého adresáta je možné definovat jeho druh, jehož prostřednictvím se definují přístupová práva uživatelů systému k daným adresátům. Druh adresáta se definuje v činnosti Adresát hned na první záložce „Adresát“ (druh adresáta se nachází vedle atributu obchodní selektor a lze ho vybrat z překryvného seznamu).

Při aktivaci dané činnosti uživatel nejprve zadává identifikaci a název druhu adresátů, např. zaměstnanci (uživatel potřebuje mít zaměstnance uvedené v adresáři kvůli příkazům k úhradě apod.), ale zároveň nechce, aby osobní údaje zaměstnanců (adresa, bank. spojení) byly dostupné všem, kteří pracují s adresářem. K danému druhu adresátů pak definuje přístupová práva (menu Volby nebo klávesa Ctrl B).

Po aktivaci činnosti přístupová práva lze tedy definovat práva k druhům adresátů. Právo může nabývat hodnot Čtení, Zápis nebo Žádné. Toto právo se vztahuje k základním informacím o adresátovi, jeho adresám a adresním spojením a neomezuje možnost zadat adresáta v událostech komponent (např. při vytváření faktury, pokladního dokladu apod.). Práva k bankovním spojením adresáta se definují při nastavování práv přístupu zvlášť zaškrtnutím voleb - 'Ban.spojení - čtení' a 'Ban.spojení - žádné'.

Příklady možného nastavení, např.:

Nastavení práva k druhu adresáta = Zápis

Volba 'Ban.spojení - čtení' = Zaškrtnutá

Uživatel může měnit základní informace o adresátovi, přidávat adresy a adresní spojení adresáta, ale bankovní spojení adresáta může pouze číst.

Nastavení práva k druhu adresáta = Zápis

Volba 'Ban.spojení - žádné' = Zaškrtnutá

Uživatel může měnit základní informace o adresátovi, přidávat adresy a adresní spojení adresáta, ale bankovní spojení adresáta nevidí, ani nesmí nové bankovní spojení přidávat.

Nastavení práva k druhu adresáta = Čtení

Volba 'Ban.spojení - čtení' = Nezaškrtnutá

Volba 'Ban.spojení - žádné' = Nezaškrtnutá

Uživatel nemůže měnit základní informace o adresátovi, nemůže přidávat ani měnit adresy a adresní spojení adresáta, ale bankovní spojení adresáta může měnit i přidávat.

1.4.13 Palety barev kategorií adresátů

Nadefinování palety barev kategorií adresátů umožňuje zobrazovat adresáty v činnosti adresář v různých barvách v závislosti na jejich zařazení do kategorií. Např. uživatel si může vytvořit paletu barev, kterou nazve odběratelé. Pak v kategoriích může mít kategorie odběratelé do 100 tis.Kč, odběratelé do 200 tis.Kč. apod. Těmto kategoriím nadefinuje příslušné barvy a přiřadí je k paletě barev odběratelé. Při vstupu do adresáře se pak ve výběrové záložce kromě kategorie adresáta nabízí uživateli i možnost výběru za příslušnou paletu barev, tzn. když si vybere paletu odběratelé, zobrazí se mu adresáti, kteří spadají do kategorií, které jsou obsažené v paletě odběratelé.

Při spuštění této činnosti uživatel zadává identifikaci a název palety barev. Ke každé paletě si může uvést svojí libovolně dlouhou poznámku. Výběrem skupiny se určuje uživatel palety barev (tj. přístupová práva). Důležitější je záložka „kategorie v paletě“, kde uživatel zadává:

¨ kategorie – identifikace kategorie adresáta (pokud ji nemá vytvořenu, je možno ji rovnou založit a přenést zpět do formuláře)

¨ priorita - určuje prioritu určení barvy v paletě barev v případě, že adresát odpovídá většímu počtu kategorií v paletě (např. 10, 20, 30 apod.)

¨ barva písma – tzn. jakou barvu písma budou mít adresáti v dané kategorii (nejčastěji se nechává standardní černá, tzn. že barva písma se neuvádí)

¨ barva pozadí – tzn. jakou barvu bude mít pozadí (tzn. řádek) na kterém je v adresáři uveden adresát, který spadá do této kategorie

V souvislosti s paletou barev byly rozšířeny vlastnosti kategorie adresáta o další atributy. Tyto atributy se nevstupují přímo ve formuláři „kategorie adresátů“, ale pomocí činnosti „definování typu kategorie adresáta“ (menu volby nebo klávesa F5) z tohoto formuláře.

Palety barev je možné exportovat do balíčku.

1.4.14 Konverze pro štítek v události pošty

Nastavení jednotlivých atributů konverze (tj. přeměna, obrat) pro štítek se určuje, jakým způsobem mají být naplněny informace tištěné na štítek z události poštovní zásilky, např. u právnické osoby chce mít uživatel oslovení, jméno a úplný název adresáta (Vážený pan, Jan Novák, firma xxx), ale u fyzické osoby mu stačí oslovení a jméno (Vážený pan, Jan Novák). V této činnosti se jednotlivé konverze na poštovní štítek definují a k adresátovi se následně pak přiřazují v činnosti Adresář na záložce Adresát (hned vedle atributu číslo adresy adresáta, konverzi je možno vybrat z překryvného seznamu).

Každá definice konverze pro štítek v události pošty obsahuje tyto atributy:

¨ identifikace definice konverze

¨ název definice konverze

¨ výraz konverze 1.řádku štítku - výraz v jazyce Foxpro - není-li uveden, předplní se prázdný text

¨ výraz konverze 2.řádku štítku - výraz v jazyce Foxpro - není-li uveden, předplní se jméno pro štítek resp. jméno uvedené ve spojení

¨ výraz konverze 3.řádku štítku - výraz v jazyce Foxpro - není-li uveden, předplní se název firmy adresáta

¨ poznámka

2.Vývěska

2.1 Kompletní vývěska

Činnost Kompletní vývěska se nachází v hlavním menu v komponentě Marketing – Vývěska.

Před vlastním spuštěním činnosti vývěska má uživatel možnost nadefinovat si záložku Výběr (obr. 12), čímž si určí množinu dat, se kterou chce nadále pracovat. Z následujícího obrázku je zřejmé, podle jakých atributů lze výběr konkretizovat. Uživatel si může vyfiltrovat události vývěska např. podle data, podle uživatele, který událost zapsal, podle adresáta, tématu nebo lze vyhledávat i podle textu. V případě, že uživateli nevyhovují jednotlivé výběrové atributy, lze na záložce Výběr využít i obecný výběr.

Obr. 12

Základní informací vývěsky je "událost vývěsky", což je datovaný záznam o nějaké (pro firmu) významné události. Záznamy se ukládají do pomyslných "škatulek", jimiž jsou témata. Strukturu a počet témat definuje uživatel tak, aby co nejlépe popisovala jeho činnost. Pokud je událost vývěsky součástí operace, která běží v nějakém procesu, automaticky se jako téma předplňuje identifikace dané operace. Když je událost vývěsky zapisována samostatně, identifikace operace se jako téma vybírá ručně.

Událost vývěsky se může týkat některého adresáta z adresáře, který je součástí informačního systému. V tomto případě je název "adresát" poněkud nepřesný, neboť mu není záznam určen, pouze je o něm veden.

Při zadání události vývěsky tedy uživatel zadává (obr. 13):

¨ téma – výběr z číselníku (tj. druhu operací). K jednotlivým druhům operací lze nastavit přístupová práva

¨ adresát a jeho spojení – výběr z adresáře

¨ datum – předplňuje se aktuální datum

¨ text – krátký popis události

¨ příznak blokování – takto zaškrtnutá událost je blokována pro případ editování – povoleno pouze uživateli, který událost zapsal

¨ komentář – libovolný komentář k události

¨ typ události komponenty – výběr z číselníku nadefinovaných typů událostí komponenty. Činnost typy událostí komponent umožňuje členit operace jednotlivých komponent (v současnosti pouze komponenty „obecná událost“, tzn. vývěska) podle nadefinovaných typů událostí komponenty. Typ události pak uživatel uvádí při zadávání operace komponenty (tzn. při zadávání událostí komponenty vývěska se z překryvného seznamu vybírá i typ události). V této činnosti má uživatel přehled jednotlivých typů událostí a jejich použitelnosti v jednotlivých operacích. K druhům operací lze i v této činnosti přiřazovat jednotlivé typy, v rámci lepší přehlednosti ale doporučujeme uživateli toto definovat přímo v činnosti druhy operací.

¨ zdroj informace – je uveden uživatel, který je zdrojem uvedené informace zapsané v události

¨ selektory

¨ zapsal – automaticky je předplněno jméno uživatele, který událost zadává

Obr. 13

K jednotlivým událostem vývěsky lze vytvářet souvislosti, což pak uživateli umožňuje vyvolat si událost vývěsky i z jiných činností (např. ze zpráv, z diáře, z dokumentů, z adresáře....).

Pod tučným atributem Téma je po stisku pravého tlačítka myši na daném atributu možno vyvolat setřídění a výběr událostí pouze daného tématu. Tzn. ve výběru si uživatel zvolí určité datum od – do a načte si události. Zobrazí se mu události různých témat v daném období. Uživatel zjistí, že by se mu líbilo si v daném období zobrazit pouze události daného tématu. Tím pádem není nutné jít zpět na záložku Výběr a tam definovat ještě dané téma, ale stačí na události, která toto téma obsahuje stisknout pravé tlačítko myši na atributu Téma a systém provede tento výběr za vás. Pro návrat do předchozích událostí vývěsky a opuštění pouze vybraného tématu stačí v dolní liště stisknout tlačítko „Návrat k předchozí“.

Pod tučným atributem Adresát je po stisku pravého tlačítka myši na daném atributu možno vyvolat další činnosti a události týkající se daného adresáta.

Pod menu Volby (nebo po stisku klávesy Ctrl U) má uživatel k dispozici činnost „Komunikace nad záznamem“, jejíž pomocí může sledovat, kterému uživateli byla na základě dané události vývěsky odeslána zpráva a její stav.

Pod menu Volby nebo stiskem klávesy F5 uživatel aktivuje činnost „strom vývěsky“. Jedná se v podstatě o obdobný princip vyjádření událostí jako je ve stromu hlavního procesu. Je vidět základní událost, ze které byl strom spuštěn a k ní předcházející a navazující události vývěsky. Po aktivaci této činnosti se uživateli zobrazí samostatné okno, jehož velikost si může libovolně upravit (metoda „táhni a drž“). Zobrazují se události vytvořené k dané události jako předchůdci a zároveň se zobrazují události vytvořené k dané události jako následníci. Dvojklikem na každé události si uživatel danou událost spustí v samostatném okně. Na každé události je možno po stisku pravého tlačítka myši vyvolat tyto možnosti:

¨ obnovit – stejné jako znovu načíst. V případě změny některé události se tímto načte strom vývěsky v obnovené verzi

¨ editovat událost – v novém okně událostí vývěsky se zobrazí daná událost a uživatel ji může opravit

¨ následníci – vývěska – uživateli se v novém okně zobrazí události, které jsou k dané události pomocí objektových vazeb vytvořeny ve vztahu předchůdce – následník (neboli otec – syn)

¨ následníci – dokumenty – v případě, že je k události vývěsky připojen dokument (přes spojené dokumenty), zobrazí se v samostatném okně

Po stisku Ctrl D nebo výběrem činnosti Dokumenty v menu Volby se uživateli zobrazí okno se spojenými dokumenty.

Po stisku ikonky „tiskárna“ v panelu nástrojů nebo výběrem činnosti z menu Volby (Ctrl T) jsou k dispozici následující předlohy výstupu:

¨ mail s dokumenty (objekty) – jeho aktivace způsobí, že z dané události vývěsky se text a komentář předplní do mailu a dokument, který je připojen přes Ctrl D jako objekt je automaticky připojen jako příloha mailu. Toto samozřejmě předpokládá, že adresát na události musí mít ve svých spojeních uvedenu emailovou adresu.

¨ přehled událostí dle data – klasická sestava, kde má uživatel přehled jednotlivých událostí vývěska a k nim vždy kompletní informace (adresát, datum, text, komentář, kdo zapsal atd.).

2.2 Aktuální hodnoty vývěsky

Po aktivaci této činnosti (hlavní menu – Marketing – Vývěska) se uživateli nabídne k vyplnění nejprve záložka Výběr. Zde si může zvolit konkrétní druh hodnoty, adresáta či druh operace.

Využití činnosti aktuální hodnoty komponenty v případě vývěsky nebude asi příliš časté, mohou sloužit spíše pro potřeby evidence určitých sumárních údajů, např. možnost sledování odesílané korespondence, doporučených dopisů apod.

2.3 Významné uzly

Tato činnost (hlavní menu – Vývěska – Významné uzly) není definiční činností, tzn. nabízí uživateli pouze přehled významných uzlů, které si předtím nadefinoval v činnosti „uzly vývěsky“. Uživatel pak má k dispozici stromové menu, kde po rozbalení této činnosti má k dispozici všechny události, které si nadefinoval právě v činnosti „uzly vývěsky“.

2.4 Uzly vývěsky

Tuto činnost má uživatel k dispozici v hlavním menu v činnosti Marketing – Vývěska – Uzly vývěsky.

Tato činnost slouží k usnadnění přístupu k vybraným záznamům vývěsky, resp. uživatel má možnost pomocí vytváření souvislostí definovat uzly vývěsky, které v podstatě zastávají roli "oblíbeného otce" událostí.

Při prvním spuštění uzlů vývěsky se uživateli zobrazí prázdné okno této činnosti. Záznam vývěsky typu „otec“, který chce uživatel přesunout do uzlů vývěsky si nejprve vyhledá v činnosti kompletní vývěska (menu Marketing – Vývěska – Kompletní vývěska). Tento záznam musí být aktivní, tzn. je na něm umístěn kurzor, zároveň má uživatel otevřeno i okno uzlů vývěsky. Na kompletní vývěsce si tedy uživatel zvolí událost, která má být uzlem vývěsky, tzn. takovou událost, která je pomocí souvislostí spojena s mnoha dalšími událostmi, a ke které se uživatel častěji vrací (např. obchodník připravuje významnou firemní akci, takže má vytvořenu událost AKCE, pod níž „věší“ všechny s ní spojené záznamy, tzn. pozvánky, přihlášky apod.). Takže AKCE bude právě ta událost, kterou si vloží do uzlů vývěsky.

Další postup je následující:

¨ na obrazovce má tedy uživatel spuštěnu činnost kompletní vývěska a zároveň činnost uzly vývěsky. Pomocí stisku ikony "strom" v činnosti kompletní vývěska a jejím přenesením do činnosti uzly vývěsky se vytvoří z dané události uzel vývěsky. Přenesení události se provádí způsobem běžným u aplikací windows, tj. "táhni a drž".

¨ u každého uzlu má uživatel po stisku pravého tlačítka myši možnost definovat jeho vlastnosti

¨ kliknutím tlačítka myši (levého) na zvoleném uzlu vývěsky se uživateli zobrazí události vývěsky spojené právě s tímto uzlem

V případě, že uživatel už má některé uzly vývěsky vytvořeny, po aktivaci této činnosti se mu zobrazí okno, kde jsou uzly vývěsky zobrazeny ve formě „ikon“ s popisem.

V okně významných uzlů je možno zobrazovat pouze ty záznamy, které byly vytvořeny pomocí objektových vazeb, neboť se zde aktivně využívá vzájemně vytvořené vazby otec – syn. Do okna významných uzlů se přenese vybraný záznam typu otec, po jeho aktivaci se však zobrazí všechny jeho záznamy typu „syn“. Mezi významné uzly vývěsky se dají přesunout pouze záznamy vývěsky typu „otec“ (neboli předchůdce), nikoliv záznamy vytvořené pomocí objektové vazby typu „syn“ (čili následník). Pokud má tedy uživatel např. nějaký obchodní případ, je vhodné si vytvořit záznam na vývěsce s názvem např. obchodní případ a pomocí objektových vazeb k němu pak vytvářet další vznikající záznamy (tj. události obchodního případu). Výhodou uzlů vývěsky pak je, že po aktivaci daného uzlu „obchodní případ“ se všechny záznamy typu „syn“ zobrazí najednou, tzn. uživatel je má všechny v danou chvíli k dispozici. V případě, že by tyto záznamy neměl sjednocené pomocí uzlu vývěsky, musel by je jednotlivě vyhledávat na kompletní vývěsce.

3.Zprávy

3.1 Zprávy

Tuto činnost má uživatel k dispozici v hlavním menu – Marketing – Zprávy. Po její aktivaci se uživateli nejprve nabídne k dispozici záložka Výběr, kde pomocí nadefinování jednotlivých atributů si může zvolit následující množinu dat. Záložka Výběr (obr. 14) poskytuje uživateli tyto možnosti:

Obr. 14

Uživatel si může zvolit zprávy za určité období, v určitém stavu (došlé, odeslané, všechny), s určitým příznakem (nepřijaté, přijaté, zpracované) a zvolit si i uživatele, který dané zprávy zapsal či naopak přijal. Zprávy lze vyhledávat i podle jednotlivých selektorů. V případě, že by uživateli nestačili nabídnuté výběrové atributy, lze pak využít možností, které mu nabízí obecný výběr. Po načtení záložky Výběr má uživatel k dispozici vybranou množinu dat, resp. zpráv.

Zprávy je možno zadávat jednotlivě (po stisku F3 nebo pomocí ikonky Nový záznam) a nebo je možno zadat zprávu naráz více uživatelům pomocí vytvořené šablony a nadefinované činnosti Oblíbené skupiny uživatelů po stisku Ctrl F3.

U každé zprávy se uživateli zobrazuje (obr. 15):

¨ jméno uživatele, kdo zprávu zapsal a datum a čas zápisu

¨ jméno uživatele, kdo zprávu přijal a datum a čas přijetí zprávy

¨ datum signalizace určuje datum, který den se daná zpráva objeví mezi aktuálními (tímto způsobem si uživatel může zapisovat zprávy na které nechce zapomenout, i do budoucna a tyto zprávy do budoucna např. posílat i jiným uživatelům).

¨ zpracování – datum a čas zpracování zprávy uživatelem, kterému byla zpráva adresována

¨ připomenutí a čas – viz. popis níže

¨ text – krátký popis zprávy

¨ komentář – podrobnější komentář k dané zprávě

Obr. 15

Důležitou roli v činnosti zprávy hraje i atribut připomenutí a čas. Pokud je zvoleno připomenutí „Ne“, zpráva se bude uživateli nabízet pouze v této činnosti jako aktuální nepřijatá zpráva (podle zvoleného data signalizace). Pokud je zvoleno „Ano“, tak podle nastaveného data a času (atribut „čas“) se zpráva uživateli zobrazí jako samostatné okno informačního panelu (určení takto spuštěné stránky se provádí nastavením parametru BM, činnost Systém – Nastavení programu BM – Zpravy-pripomenuti_stranka, ve kterém se uvádí identifikace stránky informačního panelu, více o tomto v Návodech a balíčcích.) Zpráva je takto připomínána příjemci v případě, že:

¨ má nastaveno připomenutí „Ano“

¨ zpráva nebyla dosud zpracována

¨ datum a čas připomenutí je menší než aktuální systémové datum a čas

¨ BM v daném okamžiku nemá aktivní modální okno (tj. okno, ze kterého se nelze přepnout, např. okno s určitým systémovým dotazem, kde je nutno zvolit odpověď Ano/Ne).

Okamžik, kdy je zpráva uživateli jako samostatné okno informačního panelu připomenuta nastává:

¨ 15 vteřin po přihlášení uživatele do BM u těch zpráv, jejichž datum a čas připomenutí je v tomto okamžiku menší než aktuální systémové datum a čas

¨ u zpráv, které vznikly po spuštění programu na stejném počítači nebo jiném počítači zadané jiným uživatelem systému s maximálním zpožděním podle parametru Zpravy-pripomenuti_timeout (implicitně nastaveno 5 minut)

¨ je-li v okamžiku, kdy by mělo být zobrazeno okno s připomenutím aktivní modální okno, potom je připomenutí odloženo podle parametru Zpravy-Pripomenuti_timeout_odlozeni

¨ pokud se na zprávu nevztahuje žádná z předchozích možností, je připomenutí provedeno v určený čas

Následující obrázek poskytuje uživateli přehled jak vypadá následovně takto vytvořené připomenutí. Po přihlášení se do systému po uplynutí příslušné doby automaticky naskočí uživateli k dispozici tento formulář:

Jednotlivé zprávy (resp. položka datum signalizace v mřížce) jsou v této činnosti barevně odlišeny a zároveň mají i různé příznaky ve sloupečku "stav zpracování", takže potom vypadají následovně:

¨ červená - jedná se o aktuální zprávu, stav zpracování je " ! " a obálka u data zápisu zprávy je žlutá a zavřená

¨ modrá - jedná se o přijatou zprávu, stav zpracování je " # " a obálka u data zápisu zprávy je bílá a otevřená

¨ zelená - jedná o zpracovanou zprávu, stav zpracování je " + " a obálka u data zápisu zprávy je bílá se šipkou

¨ hnědá - jedná se o zprávu zaslanou do budoucna, stav zpracování je " - " a obálka u data zápisu zprávy je žlutá a zavřená

Pro uživatele existuje několik variant, jakým způsobem lze přijmout zprávu:

¨ dvojklikem myši přímo na sloupečku "signalizace" nebo "stav zpracování zprávy" (nejsnadnější a zároveň nejrychlejší metoda)

¨ klávesou F6 (klávesa F7 u zpracování zprávy)

¨ výběrem funkce "přijetí zprávy" přímo z menu Volby

¨ tlačítkem „přijetí zprávy“ a tlačítkem „potvrzení zprávy“ v dolní liště formuláře zprávy

Systém se následně po jakékoliv výše uvedené akci dotazuje: "Skutečně přijímáte zprávu ..... ? Ano/Ne". Po potvrzení volby Ano se položka "přijetí" vyplní aktuálním datem a stav zpracování zprávy má příznak "#" (modrá barva). Stejným způsobem je pak možno zprávu přijatou změnit na zprávu zpracovanou. Po potvrzení volby Ano se položka "zpracování" vyplní aktuálním datem a stav zpracování zprávy má příznak "+" (zelená barva).

3.2 Oblíbené skupiny uživatelů

Tuto činnost má uživatel k dispozici v hlavním menu v činnosti Marketing – Zprávy – Oblíbené skupiny uživatelů.

Tato činnost umožňuje uživateli nadefinovat oblíbené skupiny uživatelů, které využije při zasílání zpráv (odesílání zpráv více uživatelům najednou - pomocí šablony) nebo při zápisu do diáře ostatním pracovníkům. Při odesílání zprávy pouze jednomu uživateli tuto činnost nevyužije. V jedné skupině může mít např. pouze pracovníky obchodního oddělení, kterým posílá zprávy o obchodních jednáních, druhá skupina mohou být např. pracovníci systémové integrace apod. Využíváním oblíbených skupin si uživatel značně zjednoduší práci, protože nemusí jednotlivé pracovníky vybírat ze seznamu po jednom a nedojde tím k situaci, že by na někoho nechtěně zapomněl.

Uživatel v této činnosti zadává identifikaci a název skupiny. Po stisku záložky "uživatelé ve skupině" přiřazuje jednotlivé uživatele do aktuální skupiny. Výběr uživatelů do dané skupiny se provádí zatržením příznaku označení (tj. malé okénko před vlastním jménem uživatele).

Po nadefinování jednotlivých skupin (včetně přiřazení uživatelů do skupiny) má uživatel možnost prohlížet si záznamy v diáři vybrané skupiny uživatelů. Tento diář lze vyvolat stiskem klávesy F5 nebo výběrem činnosti z menu "volby".

Pokud si uživatel nenadefinuje žádnou oblíbenou skupinu uživatelů, nabízí se mu při zasílání zpráv nebo při zápisu do diáře pomocí šablony seznam všech uživatelů systému, ze kterého si pak vybírá jednotlivé příjemce. Pokud má skupinu nadefinovanou, pak při odesílání zprávy pomocí šablony si v prvním překryvném seznamu tuto skupinu vybere.

Po stisku ikonky „tiskárna“ v panelu nástrojů nebo aktivaci činnosti Tisk v menu Volby má uživatel k dispozici předlohu výstupu „Přehled zpráv“. Jedná se o klasickou sestavu, kde má uživatel přehledně pod sebou zobrazen přehled jednotlivých zpráv a veškeré info k nim.

Následující činnosti popsané v kapitole 3.3 a 3.4 se v současné době příliš nevyužívají a jejich případně nastavení není triviální záležitost, tzn. je vhodné spíše pro zkušenějšího uživatele či implementátora.

3.3 Objekty Outlooku

Tato činnost umožňuje zpracovávat data zapsaná v Outlooku v IS BM.

3.4 Deklarace Outlooku

Činnost umožňuje nastavení definic mezi Outlookem a činnostmi v IS BM. K jejímu správnému fungování je nutno nadefinovat:

Druh objektu Outlooku

Tato činnost umožňuje definovat jednotlivé druhy objektu Outlooku. U každého druhu se zadává:

¨ identifikace a název druhu objektu

¨ seznam složek Outlooku (oddělených středníkem), ve kterých se daný objekt nachází (např. doručená pošta, deník apod.)

¨ text pro návěští (data, předmětu, poznámky) – text pro návěští (data, předmětu, poznámky) v prezentaci v IS BM

¨ výraz vlastnosti (data, předmětu, poznámky) – výraz vlastnosti (data, předmětu, poznámky) objektu Outlooku pro prezentaci v BM

¨ poznámka – vlastní komentář

Konverze adresy do Outlooku

V této činnosti se definují jednotlivé konverze (tj. přeměna, obrat) adresy z IS BM do aplikace Outlook. Zadává se:

¨ identifikace a název konverze adresy příjemce v Outlooku

¨ BM – identifikace objektu IS BM (výběr z překryvného seznamu)

¨ typ – typ určení adresy příjemce v Outlooku (výběr z překryvného seznamu)

¨ výraz konverze

¨ poznámka

Transformace BM -> Outlook

V této činnosti se definují jednotlivé transformace mezi objekty IS BM a aplikací Outlook a k nim výrazy pro transformaci. U každé transformace se zadává:

¨ identifikace a název transformace

¨ BM – identifikace objektu IS BM (výběr z překryvného seznamu)

¨ druh objektu (výběr z číselníku)

¨ konverze (výběr z číselníku)

¨ poznámka

Záložka „výrazy pro transformaci“ obsahuje definici jednotlivých výrazů dané transformace, kterou by měl provádět pouze zkušený uživatel nebo implementátor.

4.Dokumenty

Tato činnost v sobě sdružuje činnosti týkající se jednak vlastního vytvoření, editace a prohlížení jednotlivých dokumentů, jejich druhů a kategorií, ale týkající se např. i vlastních definic předloh výstupu a spouštěných aplikací. Postupně si jednotlivé činnosti podrobněji popíšeme.

4.1 Dokument

Tuto činnost má uživatel k dispozici v hlavním menu – Marketing – Dokumenty – Dokument. Po její aktivaci se uživateli nejprve zobrazí aktivní záložka Výběr (obr. 16), kde si může definovat následující množinu dat, kterou chce mít k dispozici.

Obr. 16

Uživatel si může vybírat podle následujících atributů:

¨ dokument – vyhledávání podle názvu nebo části názvu dokumentu

¨ klíč – pokud je u dokumentu nadefinován i klíč (je součástí XML dokumentů)

¨ datum od – do

¨ obsah poznámky – pokud poznámka u dokumentu obsahuje určité klíčové slovo nebo výraz, lze vyhledávat dokument i podle něj

¨ druh dokumentu, kategorie, předloha, adresát – to vše jsou další z možností podle kterých lze dokument vyhledávat

¨ zapsané – lze vyhledávat i podle jména uživatele, který dokument vytvořil

V případě, že by uživateli nevyhovoval ani jeden z těchto výběrových atributů, lze využít ještě možností, které mu nabízí obecný výběr, kde je možno si nadefinovat vlastní výběrové hledisko.

Po načtení zadaného výběru má uživatel k dispozici následující formulář (obr. 17), kde je implicitní záložka „Dokumenty“:

Obr. 17

U každého dokumentu jsou k dispozici následující informace:

¨ název dokumentu

¨ druh dokumentu – identifikace dokumentu. Ke každému druhu dokumentu lze nastavit přístupová práva. Vytvářet nový dokument má uživatel možnost pouze s druhem dokumentu, ke kterému má právo zápis. V případě, že má aktuální uživatel k dokumentu právo zápis a v okamžiku otevření daného dokumentu má tento dokument zároveň otevřen jiný uživatel, zobrazuje se mu v systémovém hlášení informace, že „dokument je otevřen pouze pro čtení, případné změny nebudou zaznamenány a zároveň má k dispozici i jméno uživatele, který má otevřen daný dokument pro zápis“.

¨ předloha – identifikace předlohy. Každá předloha dokumentu je spojena i s druhem dokumentu. K druhu dokumentu lze definovat přístupová práva, čímž jsou zároveň definována přístupová práva i k dané předloze. Uživatel má možnost používat předlohu (tzn. i vytvářet na jejím základě nový dokument), k jejímuž druhu má právo přístupu čtení nebo zápis.

¨ klíč - pokud se jedná o předlohu typu XML, zadává se u dokumentu i klíč

¨ externí uložení - v případě potřeby externího uložení dokumentu. Uživatel po zaškrtnutí tohoto atributu pak udává cestu a název souboru, ve kterém je dokument externě uložen

¨ chráněný dokument - takový dokument pak může opravovat pouze autor dokumentu. Ostatním uživatelům se při otevření tohoto dokumentu zobrazí hlášení, že dokument jen určen pouze pro čtení a případné změny nebudou zaznamenány.

¨ automatické ukládání revizí - umožňuje u dokumentu ukládat i jeho revize. Prázdný atribut za umožňuje uživateli nastavit interval autom. ukládání revizí v čase (v hodinách a minutách)

¨ soubor - název souboru, ve kterém je dokument uložen (při externím uložení)

¨ duplikát - název souboru, do kterého je po změně automaticky ukládán duplikát dokumentu

¨ poznámka – libovolný text k danému dokumentu

Dokumenty je možno aktivovat, tzn. zobrazit po stisku tlačítka „editace dokumentu" nebo příslušnou činností z menu Volby.

Další záložky poskytují uživateli následující informace:

¨ záložka „Kategorie dokumentu“ - přehled o příslušnosti dokumentu k určité kategorii (po stisku F3 možno zařadit dokument k vybrané kategorii a datu) – viz. podrobnější popis v kapitole 4.4

¨ záložka „Použití dokumentu“ – přehled o tom kdy a jaký uživatel dokument použil a jaké změny s dokumentem provedl (tzn. zda se jednalo pouze o čtení či čtení a zápis)

¨ záložka „Verze dokumentu“ – přehled o jednotlivých vytvořených verzích dokumentu (sledují se pouze v případě, že je u dokumentu zatrženo „automatické verze dokumentu“). Poskytuje přehled uživatelů, kteří verzi vytvořili a datum verze.

¨ záložka „Protokol“ – přehled jednotlivých akcí dokumentu. Akce dokumentu se definují v činnosti Spouštěné aplikace na záložce Akce). U dokumentů, které byly vytvořeny pomocí předlohy dokumentu, která má u sebe nadefinovanou spouštěnou aplikaci i s akcí lze pak akce dokumentu vidět po stisku klávesy F7 (nebo menu Volby Akce dokumentu).

Po stisku ikonky „tiskárna“ nebo aktivaci činnosti Tisk (i Ctrl T) z menu Volby má uživatel k dispozici předlohu výstupu typu Excel „přehled dokumentů“. Jedná se v podstatě pouze o kompletní info k dokumentům (tzn. kdo vytvořil, datum, druh, předloha atd.).

K jednotlivým dokumentům je možno pomocí vloženého objektu vytvořit prezentaci. V případě, že uživatel vytváří dokument pomocí vazby objektů, má k dispozici i činnost spojené dokumenty.

Tato činnost tedy umožňuje uživateli vytvářet nové dokumenty (tzn. založit je přímo zde v této činnosti) a zároveň mu poskytuje přehled jednotlivých vytvořených dokumentů. Tyto dokumenty jsou tedy vloženy do IS BM přímo v této činnosti nebo jsou vytvořeny pomocí souvislostí, tzn. že např. k události vývěsky „obchodní jednání“ je připojen pomocí souvislostí dokument uzavřené „kupní smlouvy“ nebo k události vývěsky „pozvánka na školení“ je připojen dokument „pozvánka“ apod. Dokumenty vytvořené pomocí souvislostí jsou v událostech ostatních komponent dostupné jako spojené dokumenty vždy po stisku Ctrl D (nebo menu Volby – Dokumenty). Uživateli se zobrazí samostatné okno spojených dokumentů.

Spojení s dokumentem čili existence vazby objekt - dokument se pak jako jiné objektové vazby ukazuje v rámečku souvislostí pomocí znaménka plus. Po stisku klávesy Ctrl D se tedy uživateli zobrazí rámeček „spojené dokumenty“. Zde má k dispozici dokumenty objektu, procesu, operace, adresáta a artiklu. V případě potřeby vytvoření objektové vazby (např. navázání smlouvy na událost vývěsky) se využijí dokumenty objektu. Dokumenty procesu a operace se napojují automaticky, pokud dokument vzniká jako součást (je nadefinovaný v diagramu procesu) procesu nebo operace. Pod dokumenty adresáta se nejčastěji ukládají dokumenty, které jsou přímo svázány s daným adresátem, např. smlouvy, ceníky adresáta apod. Pod složkou artikl jsou obsaženy události artiklu, který je aktuální na události, ze které si uživatel spojené dokumenty vyvolal.

Další složky, které jsou dostupné pod dokumenty adresáta jsou:

¨ kategorie adresáta – ukazuje se přehled kategorií, ve kterých je daný adresát zařazen

¨ procesy adresáta – ukazuje se strukturovaný přehled procesů, které byly založeny pro daného adresáta.

¨ události adresáta – ukazují se události jednotlivých komponent, ve kterých je adresát uveden

Tato menu se dají ovládat i pomocí myši:

¨ pravý klik na složce kategorie adresáta - vyvolání formuláře kategorií adresáta

¨ dvojí klik na konkrétní kategorii adresáta - vyvolání formuláře kategorií adresáta

¨ pravý klik na komponentě ve složce událostí - vyvolání formuláře odpovídajících událostí komponenty

¨ dvojí klik na druhu operace ve složce komponenty - vyvolání formuláře událostí komponenty (s předplněným výběrem daného druhu operace)

V případě potřeby vytvoření dokumentu uživatel postupuje následujícím způsobem. Kurzor umístí např. na dokumenty objektu (tzn. okno spojených dokumentů je aktivní) a po stisku pravého tlačítka myši se mu zobrazí volby:

¨ nový dokument – tuto možnost uživatel využije v případě, že vytváří úplně nový dokument. Při vytváření nového dokumentu musí nadefinovat jeho vlastnosti.

¨ načíst dokument – tuto možnost uživatel využije v případě, že již má dokument vytvořený, uložený mimo systém IS BM a chce tento dokument do systému přenést. Po aktivaci této činnosti uživatel určí cestu, odkud se má soubor načíst a pak už jen upřesní vlastnosti dokumentu (název, typ dokumentu a předlohy, příznak chráněného dokumentu). Je možno využít i možnosti externího uložení dokumentu. Po stisku OK je dokument načten a stává se součástí databáze IS BM (pokud nemá nadefinováno externí uložení).

¨ uložit obrázek v clipboardu – tato možnost umožňuje připojit jako dokument obrázek, který má uživatel uložen v clipboardu, tzn. na určitém obrázku mimo IS BM uživatel potvrdí volbu kopírovat (Ctrl C) a po aktivaci této činnosti je obrázek vložen jako dokument IS BM. Tato možnost je pro uživatele aktivní, je-li v hlavním menu programu obsažen program PCT_DLL.DLL. Obrázek je ukládán ve formátu JPEG.

IS BM umožňuje přenášet soubory tažením myší (metoda „táhni a drž“) do okna spojených dokumentů např. z okna průzkumníka Windows (tažením myší není možné připojovat přílohy e-mailu). Stejným způsobem je možné připojovat dokumenty k procesům nebo operacím ve formuláři Strom hlavního procesu a objektům, které mají zobrazený připojený dokument (obrázek) na volné kartě prostřednictvím atributu volné karty typu „multimediální“.

Po přetažení souboru do IS BM se pak systém chová standardně jako při klasickém vytváření dokumentu BM. Je nutno zadat jeho vlastnosti (tzn. název, druh dokumentu apod.). Pokud je v okamžiku uvolnění tlačítka myši stisknuta na klávesnici klávesa Shift, potom se ve vlastnostech připojovaného dokumentu automaticky nastaví zaškrtnuté „externí uložení“ na záložce „uložení dokumentu“.

Při založení dokumentu tažením myší je ukládána v IS BM informace o názvu načteného dokumentu. Při opakovaném načtení dokumentu stejného názvu je pak systémem zobrazen dotaz podobného typu jako:

„Dokument „........název.........“ byl již do BM načten. Načtení provedl(a) – jméno a datum. Má být dokument opakovaně načten do BM (volba Ano) nebo má být připojen tento dříve načtený dokument? (volba Ne)?

Po stisknutí tlačítka ANO je původní načtený dokument přepsán úplně novým dokumentem, po stisknutí tlačítka NE není zakládán nový dokument a je pouze vytvořena objektová vazba mezi objektem BM a dokumentem, který byl již dříve načten. Při stisku klávesy Storno se neprovede žádná akce.

Pokud uživatel u daného dokumentu sleduje revize, ukazují se pod názvem dokumentu ve stromovém zobrazení (tzn. po stisku znaménka +) i revize daného dokumentu. Dvojklikem je možno danou revizi otevřít. Po stisku pravého tlačítka myši na názvu revize dokumentu je možno revizi otevřít nebo zrušit.

V případě, že uživatel již má několik dokumentů vytvořených a chce s dokumentem dále pracovat, vyvolá si stejně jako při založení přes klávesu Ctrl D okno „spojené dokumenty“ a umístí kurzor na vybraný název dokumentu. Po stisku pravého tlačítka myši na názvu dokumentu má uživatel k dispozici tyto možnosti:

¨ otevřít dokument – aktivuje spuštění dokumentu (stejného efektu lze dosáhnout dvojklikem levého tlačítka myši na názvu dokumentu).

¨ založit proces pošty – umožňuje vytvořit proces poštovní zásilky (nebo poštovní zásilky + zápis události na vývěsku), ke které je automaticky dokument připojen a po spojení s událostí pošty je možno využít vlastností mailmerge, tj. předplnění adresy adresáta z události pošty do dokumentu.

¨ založit proces e-mail – obdoba procesu pošty s tím rozdílem, že dokument se neposílá klasickou poštou, ale emailem. Uživateli se přesto zobrazí klasická operace pošty a po aktivaci činnosti „odeslat e-mail“ (menu Volby) se dokument odešle adresátovi z poštovní zásilky emailem. Podmínkou tohoto procesu je, že adresát musí mít v adresáři (ve spojeních) uvedeno e-mailové spojení (tzn. e-mailovou adresu).

¨ kopírovat dokument – umožňuje vytvořit kopii dokumentu. Kopii může uživatel vložit ke stejné události jako je kopírovaný dokument nebo může kopii dokumentu připojit k úplně jiné události. Na takové události uživatel vyvolá klávesou Ctrl D okno spojeného dokumentu a pravým tlačítkem myši např. na dokumentech objektu si vyvolá možnost „vložit dokument ..(jeho název).......“.

¨ uložit jako – možnost externího uložení dokumentu

¨ uložit novou verzi dokumentu

¨ odeslat dokument – pokud je dokument spojen s událostí vývěsky, kde je uveden adresát, který má uvedeno emailové spojení, předplní se okno e-mailové pošty touto adresou s vloženým dokumentem. V případě, že není uveden adresát nebo nevlastní e-mailové spojení, otevře se e-mailová pošta s vloženým dokumentem, ale atribut KOMU zůstává prázdný.

¨ zrušit spojení s dokumentem – tato činnost ruší objektovou vazbu na událost, z které byl dokument vyvolán, tzn. událost nemá dále žádnou vazbu na tento dokument. Touto akcí je však zrušena pouze vazba, pokud by uživatel potřeboval zrušit dokument jako takový, je nutno si aktivovat činnost „dokumenty“ (menu Marketing – Dokumenty – Dokument), zde si příslušný dokument najít a pomocí klávesy F8 nebo ikony křížek tento dokument odstranit.

¨ kopírovat odkaz na dokument – v případě potřeby je možno vytvořit u vybrané události pouze odkaz na dokument, není nutno tento dokument přímo s událostí svazovat. Např. je vytvořen dokument adresáta „smlouva“ a uživatel na některé události vývěsky potřebuje vytvořit odkaz na tuto smlouvu. Potom na dokumentu smlouva aktivuje činnost kopírovat odkaz na dokument, přepne se na události vývěsky, vyvolá spojené dokumenty (Ctrl D) a po stisku pravého tlačítka myši na dokumentech objektu aktivuje možnost „spojit s dokumentem ..(jeho název).......“.

¨ prezentace dokumentu – možnost vytvoření prezentace (neboli optického náhledu) dokumentu.

¨ volné karty dokumentu

¨ volné karty vazby objektů

¨ obnovit přehled verzí – po aktivaci této možnosti se obnoví přehled verzí, který je součástí každého vytvořeného dokumentu o další uloženou kopii

¨ navazující dokument – zde je možno pomocí objektové vazby připojovat k danému dokumentu jeho následníky (možnost Nový dokument, Načíst dokument). Vytvořený následník se pak automaticky zařadí pod vlastní název dokumentu.

¨ vlastnosti dokumentu

4.2 Přehled o použití dokumentů

Tuto činnost má uživatel k dispozici v hlavním menu – Marketing – Dokumenty – Přehled o použití dokumentů.

Jako první se uživateli zobrazí záložka „výběr“, kde má možnost si vyfiltrovat informace, které potřebuje sledovat (např. použití dokumentu v období, tzn. kdo ho četl, kdo zapisoval apod.). Tato činnost poskytuje uživateli přehled o práci s jednotlivými dokumenty a zároveň slouží jako možnost ohlídání, zda některý z uživatelů nenahlédl omylem do citlivého dokumentu (např. při chybném nastavení přístupových práv k druhům dokumentů).

Uživatel u každého dokumentu může sledovat následující atributy:

¨ datum použití od - do

¨ jméno uživatele

¨ způsob použití dokumentu (tzn. čtení, čtení a zápis)

¨ název dokumentu

¨ jeho druh, předlohu apod.

¨ zda je dokument uložen externě či je součástí databáze

¨ zda se jedná o dokument, který má příznak chráněný

¨ zda je nastaveno automatické ukládání revizí dokumentu

¨ poznámka k dokumentu

¨ jméno uživatele, kdo dokument založil

Pomocí tlačítka „editace dokumentu“ nebo klávesou F6 (případně volbou činnosti z menu Volby) je možno dokument aktivovat. Na záložce „verze dokumentu“ je možno sledovat jednotlivé revize dokumentu (tzn. který uživatel a v jakém datu s dokumentem pracoval apod.)

4.3 Druhy dokumentů

Tuto činnost má uživatel k dispozici v hlavním menu – Marketing – Dokumenty – Druhy dokumentů.

Po aktivaci této činnosti se uživateli zobrazí přehled dosud nadefinovaných druhů dokumentů. Uživatel může založit nový druh dokumentu, případně opravovat nebo rušit stávající druh. U každého druhu dokumentu se eviduje:

¨ druh – identifikace a název druhu dokumentu. Ke každému druhu dokumentu lze nadefinovat přístupová práva (menu Volby nebo klávesa Ctrl B), což se následně využívá při práci v činnosti „dokumenty“ – uživatel nemůže založit dokument s druhem, ke kterému nemá přístupové právo zápis, nemůže do něj zapisovat, má ho přístupný pouze pro čtení. Pokud nemá k druhu dokumentu právo ani čtení, ani zápis, dokument takového druhu pro něj pak vůbec není dostupný.

¨ příznak aktuální

¨ poznámka

4.4 Kategorie dokumentů

Tuto činnost má uživatel k dispozici v hlavním menu – Marketing – Dokumenty – Kategorie dokumentů a poskytuje uživateli přehled vytvořených kategorií dokumentů. Každý dokument BM je možno zařadit do různých kategorií. V této činnosti lze kategorie vytvářet, editovat či rušit. Zařazení dokumentu do kategorie se provádí ve formuláři činnosti „Dokumenty“ na záložce „Kategorie dokumentů“ nebo ve formuláři činnosti „Vlastnosti dokumentu“ na záložce „Kategorie“ (vlastnosti dokumentu se vyvolají stiskem pravého tlačítka myši v okně spojených dokumentů – Ctrl D).

U každé kategorie se definuje:

¨ identifikace a název kategorie

¨ složka – překryvný seznam s volbou Ano/Ne – při volbě Ano bude dokument zařazený do této kategorie k dispozici ve formuláři činnosti „Spojené dokumenty“ (Ctrl D) ve složce odpovídající názvu kategorie

¨ rozbalená – překryvný seznam s volbou Ano/Ne – při nastavení složka „Ano“ bude složka ve formuláři činnosti Spojené dokumenty implicitně rozbalená

¨ předchůdce – identifikátor kategorie, možný výběr z číselníku. Při nastavení složka „Ano“ a vyplněné identifikaci předchůdce je tímto určena tzv. nadsložka dané složky ve stromu ve formuláři činnosti „Spojené dokumenty (Ctrl D), tzn. uživatel si v podstatě tímto způsobem může vytvořit několik úrovní kategorií dokumentů.

¨ poznámka – libovolná poznámka uživatele k dané kategorii

Dokumenty, které mají ve své definici nastaveno Složka – „Ano“, jsou pak ve formuláři činnosti Spojené dokumenty řazeny stromově podle jednotlivých kategorií. Je-li dokument zařazen do takové kategorie (složka – Ano), potom se ve stromu vytvoří adresářová struktura vyplývající ze vztahu kategorií (viz. atribut „předchůdce“), tzn. že ve stromu Spojené dokumenty bude viditelný název předchůdce a pod ním budou seřazeny všechny dokumenty kategorie, které ho mají ve své definici uvedeného.

Při zakládání nového dokumentu po pravém kliku na položce stromu, která odpovídá kategorii dokumentu, je u tohoto nově zakládaného dokumentu ve formuláři „vlastnosti dokumentu“ na záložce „kategorie“ předplněno zařazení do odpovídající kategorie. Při kopírování dokumentu se zařazení do kategorie nedědí.

4.5 Předlohy dokumentů

Tuto činnost má uživatel k dispozici v hlavním menu – Marketing – Dokumenty – Předlohy dokumentu (obr. 18) a umožňuje uživateli nadefinovat jednotlivé předlohy dokumentů, které pak bude využívat při vlastní práci s dokumenty.

Obr. 18

Na záložce „předlohy dokumentu“ jsou k dispozici následující údaje:

¨ předloha - identifikace a název předlohy

¨ druh dokumentu – identifikace druhu předlohy. K druhu předlohy lze nadefinovat přístupová práva a tím je vlastně nadefinováno i přístupové právo k předloze, která má u sebe uveden daný druh předlohy. Přístupové právo může nabývat hodnot čtení a zápis. V činnosti „dokumenty“ nebo při vytváření dokumentu po stisku Ctrl D na událostech se pak práva k předlohám uplatňují takto:

- uživatel může založit nový dokument s předlohou výstupu, ke které má přístupové právo čtení nebo zápis

- přístup k existujícím dokumentům je řízen právy spojenými s druhem daného dokumentu (tj. uživatel může číst nebo opravovat dokumenty vytvořené na základě předloh dokumentů, ke kterým nemá právo přístupu čtení ani zápis, ale má právo přístupu k druhu dokumentu uvedeným u dané předlohy)

¨ aplikace - identifikace a název spouštěného programu (např. Word, Excel ...) – výběr z číselníku nadefinovaných aplikací

¨ blokování - příznak blokování dokumentu předlohy proti opravě. Ostatní uživatelé mohou na základě této předlohy vytvářet dokumenty, ale nesmí opravovat tuto vytvořenou definici předlohy.

¨ prázdná předloha - příznak nevytvoření implicitní předlohy a současně i blokování proti opravě. Tzn., že i když je zde nějaká definice předlohy vytvořena, při zatržení tohoto příznaku se bude vždy spouštět prázdná předloha.

¨ mailmerge - příznak vytváření mailmerge. Jedná se o funkci, pomocí které je možno vytvořit řadu podobných dokumentů (např. dopisy), lišících se pouze v několika výrazech (adresa, oslovení ...). Potom stačí mít dva dokumenty, hlavní dokument se standardním (neměnným) textem a datový soubor obsahující údaje, které se budou měnit (databáze adres). Po vyvolání předlohy s příznakem mailmerge v aplikaci Word je pak postup následující - uživatel použije činnost Wordu "hromadná korespondence" a potvrdí jednotlivé nabízené příkazy (možno si na hromadnou korespondenci ve Wordu vytvořit i příslušné makro). Potom může mít několik dopisů s naprosto shodným textem, ale rozdílnou adresou příjemce. Mailmerge dokumentu BM připojeného k operaci pošty obsahuje také atribut 'ČJ krátké', jehož hodnotou je text odpovídající identifikaci procesu (9999-99-99999999).

¨ cesta pro soubor mailmerge, soubor mailmerge, přípona souboru mailmerge - vlastní definice mailmerge. Pokud nejsou tyto parametry u jednotlivých předloh nadefinovány, nahlásí systém chybu a nedovolí danou předlohu zapsat (typicky bývá jako soubor mailmerge uvedeno BMSERVIS s příponou TXT a cesta je C:\TMP).

¨ aktuální - zda je daná předloha aktuální (tzn. používaná) nebo je zde pouze z historických důvodů (např. v současné době se již nevyužívá, ale nelze ji smazat, protože na základě ní jsou vytvořené určité dokumenty, které i nadále chceme používat).

¨ komentář - komentář, který detailně popisuje význam předlohy

¨ založil - jméno uživatele, který předlohu vytvořil + datum a čas vytvoření dané předlohy

Stiskem tlačítka „editace dokumentu“ nebo klávesou F6 (případně aktivací činnosti z menu Volby) se spustí daná předloha dokumentu.

Na záložce „Další“ je možno definovat:

¨ Skript – text v jazyce Foxpro spouštěný bezprostředně po otevření dokumentu, resp. předlohy dokumentu externím programem (tzn. je-li předloha dokumentu vytvořena na základě aplikace Word, spustí se tento skript po aktivaci dokumentu vytvořeném na základě této předlohy v okamžiku spuštění aplikace Word). Příklady skriptu jsou popsány ve slovníku pojmů.

¨ definice pro konvertor Winword – text (viz. daný pojem ve slovníku pojmů)

Na záložce „Užití dokumentu“ jsou k dispozici údaje, který uživatel danou předlohu kdy užil a za jakým účelem (kdo, kdy a zda čtení nebo zápis apod.).

4.6 Spouštěné aplikace

Tuto činnost má uživatel k dispozici v hlavním menu – Marketing – Dokumenty – Spouštěné aplikace a umožňuje uživateli definovat způsob vyvolávání externích programů (aplikací), které se pak používají při definování předloh dokumentů. V následujícím textu si vysvětlíme jednotlivé zadávané položky společně s konkrétním příkladem. Pro názornost budeme u každé položky v závorce uvádět hodnotu, jako kdybychom vytvářeli např. aplikaci Wordu:

¨ aplikace - identifikace spouštěného programu (WORD)

¨ název - název spouštěného programu (WORD)

¨ zabudované OLE - způsob volání pro aplikace Word/Excel (Word 7.0)

¨ typ spuštění a přípona - způsob volání + přípona zvolené aplikace (zabudované OLE + DOC). Příponu souboru lze nadefinovat až na 15 znaků, např. DOCX, XLSX, ISDOCX apod. Mimo jiné je tím uživateli umožněno vložit tažením myši do IS BM i dokumenty, které mají příponu delší než 3 znaky (DOCX, XLSX apod.). Jednotlivé způsoby volání jsou - Windows DDE, DOS, Windows OLE, zabudované OLE, Windows CALL, Windows podle přípony. Různé způsoby volání jsou popsány u spouštěných aplikací ve slovníku pojmů.

¨ parametry volání - způsob otevření aplikace a jejím umístění do okna:

- aktivní a normální velikost

- aktivní a minimalizovat

- aktivní a maximalizovat

- neaktivní a normální velikost

- neaktivní a minimalizován

¨ info o otevření – tento atribut určuje chování BM po otevření dokumentu. Může nabývat hodnot:

- Ano s potvrzením – po otevření dokumentu bude zároveň otevíráno okno, které uživatel pak musí uzavřít (klávesou ESC, tlačítkem OK nebo ikonou uzavření okna)

- Ano bez potvrzení - po otevření dokumentu bude zároveň otevíráno okno, které uživatel pak musí uzavřít (klávesou ESC, tlačítkem OK nebo ikonou uzavření okna) – v případě, že uživatel okno neuzavře, automaticky se po 5 vteřinách zavře samo

- Ne – po otevření dokumentu nebude zobrazeno žádné okno

Tento atribut je implicitně nastaven na hodnotu „Ano s potvrzením“. Tuto hodnotu je nutno ponechat pro aplikace, které neblokují jimi otevřené soubory. V jejich případě platí, že kdyby systém BM po otevření dokumentu zároveň nezastavil, tak potom by se BM soubor dokumentu bezprostředně zrušil a aplikace by nemohla prezentovat daný dokument. Těmito aplikacemi mohou být programy např. pro zobrazení obrázků, internet explorer (soubory s příponami HTM, XML, ...).

¨ prázdný - pokud soubor ještě neexistuje, vytvoří prázdný soubor

¨ čekej na ukončení - po předání dokumentu je zobrazeno hlášení, po jehož odklepnutí je dokument uložen. Slouží pro práci s dokumenty aplikací, které nedokáží systému sdělit, že s daným dokumentem pracují a systém tedy nemůže zjistit, kdy byl daný dokument uvolněn pro uložení (např. CorelDraw).

Do specifické skupiny dokumentů patří ty, které mají u své aplikace definovány akce (záložka Akce), tj. celý život dokumentu je řízen dle přidělených akcí, které mohou dokument automaticky zakládat, aktualizovat, poskytovat vybraným uživatelům apod. O výsledku akcí je veden a archivován protokol (záložka Protokol v činnosti Dokumenty). Mezi takového dokumenty patří i ty, kterými IS Bílý Motýl komunikuje se státní správou (Evidenční list důchodového pojištění, Přihláška (odhláška) k nemocenskému pojištění, …), kde akce zajišťují vytvoření těchto dokumentů z dat při udržení integrity s předchozími dokumenty i s novými daty, dále akce zajišťují kompletní výměnu informací s IS státní správy včetně opravných chodů a samozřejmě jsou i tyto dokumenty trvale k dispozici kompetentním uživatelům.

4.7 Konfigurace XML dokumentů

XML je zkratka anglického eXtensible Markup Language, tedy doslova přeloženo "rozšiřitelný značkovací jazyk". A co to znamená?

¨ Extensible - rozšiřitelný

Při objasňování koncepce XML se často jako příklad uvádí HTML. Tento příklad je však vhodný spíše pro popis vzhledu XML zdrojového programu, než pro popis jeho vlastností a využití. HTML zná pravděpodobně téměř každý a ví, že jde o sadu zvolených "tagů" - tedy značek, které umožňují formátování textového dokumentu. V HTML je tedy význam jednotlivých značek přesně určen a jejich počet je omezen. Naproti tomu standard XML pouze popisuje jak má XML dokument vypadat po stránce syntaktické, avšak nepřiřazuje žádným značkám konkrétní obsah. Na autorovi samotném pak záleží, jakou úlohu danému tagu přiřadí a jak bude daný XML dokument zpracován.

V XML tedy nejsou informace členěny pomocí tagů do skupin podle jejich požadovaného vzhledu, ale podle logického uspořádání dokumentu . Takový přístup pak nabízí daleko větší možnosti při zpracování dat než HTML a navíc dává možnost širšího uplatnění XML jako formátu pro ukládání dat.

¨ Markup - značkovací

XML navazuje na mnohem starší standard pro vytváření "značkovaných" dokumentů - SGML. Tato norma však byla pro reálné použití zbytečně složitá a stejně tak složitá byla její implementace. Proto byl na základě SGML navržen nový standard, který zachovává většinu z výhod SGML (tedy hlavně jeho univerzálnost), ale značně zjednodušuje vytváření a posléze zpracování takových dokumentů - XML. XML dokument je tudíž také platným SGML dokumentem.

¨ Language - jazyk

Velmi významnou vlastností XML je, že jde o formát, který lze prohlížet i editovat v libovolném editoru - jde tedy o tzv. "human readable" formát.

Pravidla pro psaní XML jsou jednoduchá:

¨ obsah tagu (element) musí začínat startovním tagem ve tvaru <jmeno_tagu>

¨ konec elementu je vyznačen koncovým tagem </jmeno_tagu>, který je povinný!

¨ před ukončením elementu musí být ukončeny všechny jeho vnitřní elementy - každý element tedy musí mít koncový tag uvnitř stejného elementu jako počáteční

¨ prázdný tag vyznačíme <jmeno_tagu/>

¨ počáteční tag může obsahovat atributy v podobě <jmeno_tagu atr1="aaa" atr2="abc">

¨ znaky, které jsou součástí textu a mají speciální význam (např. <), musí být escapnuty

¨ nejvyšší element v hierarchii elementů je nazýván "root element" a smí být pouze jeden

Kromě těchto pravidel by měl správný XML dokument obsahovat také "hlavičku", která popisuje verzi XML standardu, kterou daný dokument používá, popř. některé další údaje:

<?xml version="1.0" ?>

Pokusný XML dokument:

<?xml version="1.0" encoding="iso-8859-2" ?>

<dokument>

  <nadpis level="1">Můj zkušební dokument</nadpis>

  <kapitola number="1">

    <nadpis level="2">První kapitola</nadpis>

    <odstavec>Tak tohle je můj první XML dokument

    (tedy není, ale jako by byl).</odstavec>

    <odstavec>A tohle je další odstavec. Trocha

    matematiky: 2&lt;5.</odstavec>

    <obrazek soubor="/home/beda/muj_obrazek.png"/>

  </kapitola>

</dokument>

Standard XML byl vytvořen, aby poskytl standardní formát pro zpracování dat a splňoval následující kritéria (mimo jiné):

¨ je "human readable" - je ho tedy možno číst a upravovat v libovolném textovém editoru

¨ je rozšiřitelný - umožňuje vytvářet vlastní formáty

¨ má jednoduchou syntaxi

¨ implementace parserů a dalších nástrojů na jeho zpracování je snadná (alespoň ve srovnání se SGML)

XML umožňuje vývojářům vytvářet poměrně snadno vlastní formáty od něj odvozené, protože poskytuje standardní nástroje pro jejich zpracování. Na standard XML je nabaleno velké množství dalších standardů, které umožňují jednoduše a účinně provádět kontrolu dokumentů, jejich vzájemné převody apod. XML formátem lze popsat takřka jakákoli data a je ho tedy možno využít jako obecný formát pro mnoho aplikací různého druhu.

5.Pošta

Komponenta pošta je nástroj podporující komunikaci firmy s okolím a administrativní činnost firmy. Eviduje došlou a odeslanou poštu, kterou lze podle obsahu a charakteru zásilky kategorizovat. Každá zásilka je svázána s určitým adresátem. Pokud byly zásilky vytvořeny jako dokumenty, je jejich obsah neustále k dispozici (jako dokument vytvořený pomocí Ctrl D).

5.1 Pošta

Tuto činnost má uživatel k dispozici v hlavním menu – Marketing – Pošta – Pošta.

Po aktivaci této činnosti se uživateli nejprve zobrazí záložka „výběr“, kde si eliminuje, které údaje ho zajímají (obr. 19) a které chce vidět (např. jestli poštu došlou nebo odeslanou, v určitý datum, za určitého adresáta, podle zvoleného selektoru apod.).

Obr. 19

Poštovní zásilky se v systému tvoří pomocí nastavených procesů a transformací, tzn. ve vlastní činnosti pošta nelze události pošty vkládat pouze pomocí klávesy F3, ale pro vložení jak došlé, tak i odeslané pošty je nutno aktivovat příslušný proces k tomuto účelu vytvořený. Teprve po aktivaci daného procesu má uživatel k dispozici klávesu F3 (nebo ikonku Nový záznam v panelu nástrojů) a zadává tyto atributy (obr. 20):

Obr. 20

U každé poštovní zásilky je rozlišeno:

¨ na základě nadefinovaného procesu je uvedeno číslo procesu (ve tvaru rok – identifikace datového úložiště a vlastní číslo procesu podle nadefinované číselné řady) a identifikace druhu operace

¨ datum vytvoření poštovní události

¨ druh – zda se jedná o poštu došlou, odeslanou či uloženou v zásobníku (tzn. připravenou k odeslání)

¨ adresát – příjemce či odesílatel dané poštovní události

¨ vyřizuje – identifikace uživatele, který má danou poštovní událost na starosti

¨ kategorie – identifikace kategorie pošty (výběr z číselníku nadefinovaných kategorií). V případě, že je v číselníku kategorií pošty nadefinována u každé kategorie i kategorie zásilky, cena zásilky a doplňková služba, předplní se následující atributy „zásilka“ automaticky s vyplněním kategorie pošty.

¨ zásilka – kategorie zásilky a doplňkové služby

¨ hmotnost – hmotnost poštovní zásilky (pokud má smysl ji evidovat)

¨ hodnota – uvedená hodnota zásilky v Kč

¨ cena obsahu – skutečná hodnota obsahu zásilky v Kč

¨ cena – cena zásilky, platba přepravní společnosti (zaškrtnutý příznak cena způsobí, že uvedená cena nebude přepisována nově vypočtenou hodnotou, např. při změně kategorie poštovní události, která má u sebe uvedenou jinou cenu – ale uživatel nechce tuto cenu, chce si ponechat původní zadanou cenu zásilky)

¨ F. cena – cena zásilky uvedená na odeslané faktuře

¨ text – krátký popis poštovní události

¨ komentář – komentář k poštovní události

¨ selektory

¨ zapsal – jméno uživatele, který poštovní událost zapsal a datum

Přehled událostí pošty se zobrazuje barevně (odeslaná – modře, došlá – červeně).

U každé události pošty, která má uvedeného adresáta, je možno si po stisku příslušné záložky "adresa" zobrazit štítek, který je možno modifikovat a následně i tisknout. V případě zatržení příznaku „uchovat změny štítku“ nebudou následné změny v adresáři z hlediska této události automaticky reflektovány (tzn. adresát má uvedenu v adresáři svou adresu, na tu mu je odeslána příslušná poštovní zásilka. Po čase adresát adresu změní, ale v případě, že by nebylo zaškrtnuto „uchovat změny štítku“, tak by se současně s adresářem změnila adresa i zde na štítku a uživatel by po čase nevěděl, na jakou původní adresu vlastně poštovní zásilka odešla).

Za samostatnou poznámku stojí tučně zvýrazněný atribut adresát. Po jeho stisku pravým "tlačítkem myši" se zobrazí nabídka činností vztahující se vždy k danému adresátovi, ze které má uživatel možnost si přímo vyvolat např. události adresáta v obchodu, ve skladu, bankovní spojení adresáta, cenové skupiny apod.

Po stisku F9 nebo pomocí příslušné činnosti pod menu Volby se aktivuje činnosti „odeslání pošty“. Její spuštění u zobrazených událostí pošty změní příznak z "k odeslání" na "odeslaná" a současně je aktuálním systémovým datem naplněn atribut datum odeslání (tento atribut je dostupný pouze formou implementačních rozšíření, např. volná karta, předlohy výstupu, ...). Údaje na těchto záložkách jsou v okamžiku aktivace dokumentu s definovaným mailmerge a objektově spojeným s operací pošty kopírovány do souboru mailmerge.

Po stisku ikonky „tiskárna“ nebo aktivací činnosti Tisk v menu Volby má uživatel k dispozici následující předlohy výstupu:

¨ Doporučené zásilky – přehled – klasická sestava, která zobrazuje přehled doporučených zásilek vytvořený speciálně pro podání na poštovních přepážkách (tzn. na poště pak u jednotlivých zásilek doplní podací číslo a případně cenu)

¨ Evidenční lístek poštovného – pouze souhrnný přehled k zobrazeným poštovním událostem, tzn. jejich počet, druh, celková cena.

5.2 Aktuální hodnoty pošty

Tuto činnost má uživatel k dispozici v hlavním menu – Marketing – Pošta – Aktuální hodnoty pošty.

V případě, že má uživatel nadefinovány aktuální hodnoty pošty, dokáže zde správně zvoleným výběrem získat jejich hodnotu, a to za druh hodnoty, kategorii a adresáta. Definici aktuálních hodnot pošty uživatel využije např. při sledování hodnot zásilek, při sledování doporučené pošty apod. Je možné, že definici aktuálních hodnot pošty nevyužijí všichni uživatelé, souvisí to plně se zaměřením a specifikací dané firmy a tokem poštovním zásilek vně firmy a potřebě jejich sledování.

5.3 Kategorie pošty

Tuto činnost má uživatel k dispozici v hlavním menu – Marketing – Pošta – Kategorie pošty.

Tato činnost umožňuje definovat jednotlivé kategorie pošty, které se rozlišují u poštovních zásilek. Uživatel má k dispozici přehled dosud vytvořených kategorií (např. obchodní informace, záloha, upomínka, reklama, pozvánka apod.). Tento přehled může aktualizovat, opravovat a rušit. U každé kategorie je k dispozici:

¨ identifikace a název kategorie pošty

¨ kategorie zásilky - identifikace kategorie zásilky (může být např. obyčejné psaní, doporučené, cenné psaní, balík apod.)

¨ doplňková služba - identifikace doplňkové služby spojené s kategorií pošty

¨ doplňková služba - identifikace doplňkové služby spojené s kategorií pošty

¨ klasifikace – identifikace klasifikace objektu

¨ sada – identifikace sady parametrů

¨ komentář - libovolný popis

V případě vyplnění těchto atributů potom při vstupu událostí pošty dojde při zadání této kategorie k automatickému vyplnění těchto atributů na události právě podle tohoto zadání.

5.4 Kategorie zásilky

Tuto činnost má uživatel k dispozici v hlavním menu – Marketing – Pošta – Pošta.

Jedná se o definici jednotlivých kategorií zásilky pošty, kde u každé zásilky eviduje:

¨ identifikaci a název kategorie zásilky

¨ název (strom) – název kategorie zásilky pro strom

¨ řada – identifikátor číselné řady zásilek

¨ aktuální – Ano/Ne – určení, zda kategorie zásilky je aktuální nebo již časově zastaralá. Podle tohoto příznaku je možno i zadávat atribut na záložce „výběr“.

¨ spojená doplňková služba

5.5 Doplňkové služby

Tuto činnost má uživatel k dispozici v hlavním menu – Marketing – Pošta – Doplňkové služby. Tato činnost poskytuje uživateli možnost vedení evidence doplňkových služeb použitelných při posílání zásilky a jejich cenové ohodnocení.

5.6 Uzavření dnešního dne

Po aktivaci této činnosti je uživatel dotázán: „Přejete si provést uzavření dnešního dne pro odesílání poštovních zásilek k dnešnímu datu?“ – volba Ano/Ne. Po volbě Ano dojde k uzavření komponenty pošta (jak pro přijaté, tak pro odeslané zásilky) k dnešnímu dni. Zároveň se do činnosti otevřená období komponent automaticky zapíše ke komponentě pošta do atributu „vstup datum od“ datum následujícího dne.

Tato činnost byla v roce 2002 částečně nahrazena ekvivalentní činností otevřená období komponent.

5.7 Číselné řady kategorií zásilek

Tuto činnost má uživatel k dispozici v hlavním menu – Marketing – Pošta – Číselné řady kategorií zásilek. Tato činnost umožňuje uživateli evidovat si jednotlivé číselné řady kategorií zásilek. U každé řady se definuje:

¨ identifikace a název řady

¨ od – do – číselný interval řady

6.Diář

Činnost Diář jedna z činností komponenty Marketing. Obsahuje v sobě činnosti týkající se přímo diáře, tzn. spíše zápisů v diáři a kategorií diáře.

6.1 Diář

Činnost Diář se nachází v hlavním menu v činnosti Marketing – Diář – Diář. Umožňuje uživateli vést záznamy týkající se jeho vlastního diáře nebo má možnost prohlížet si a zapisovat záznamy do diáře svých spolupracovníků (v případě potřeby může i jiný uživatel zapsat záznam do jeho diáře).

Podle nastavení filtru na záložce "Výběr" (obr. 21) může uživatel ovlivnit zobrazení záznamů v diáři. Na výběr je několik třídících hledisek, navíc po stisku příznaku "uchovat" se nadefinované výběry uchovají a po dalším spuštění činnosti diář se záznamy diáře budou zobrazovat právě podle tohoto nastaveného výběru. Mezi důležité atributy této záložky patří především výběr majitele diáře nebo výběr skupiny uživatelů, kategorie diáře, příznak zda se jedná o soukromý či veřejný záznam a je možný i výběr konkrétního dne zápisu v diáři.

Obr. 21

Mezi základní údaje, které uživatel při zápisu do diáře (obr. 22) vyplňuje patří např. datum a čas od - do, kategorie, text a příznak, zda se jedná o událost pracovní či soukromou. Při zápisu záznamů do diáře může dojít k časovému překryvu jednotlivých záznamů. V tomto případě systém uživatele upozorňuje, že došlo k překryvu jednotlivých záznamů. Je pak zcela na vůli uživatele, zda tento záznam zapíše i s případnou kolizí či nikoliv. Zda se mají u daného zápisu do diáře sledovat i kolize, je dáno kategorií diáře – u té se při její definici nastavuje atribut „kolize – Ano/Ne“. Pokud ho přesto zapíše, je u tohoto záznamu zobrazena výstražná značka upozorňující na překryv.

Uživatel má možnost zápisu do diáře ostatním pracovníkům. Tato možnost je ovlivněna nadefinovanými přístupovými právy. Zápisem do diáře vytvořeným na základě vstupu pomocí šablony je pak možno provést zápis do diáře více pracovníkům (k tomu lze využít nadefinované oblíbené skupiny uživatelů, viz. zprávy).

Obr. 22

Jednotlivé zápisy v diáři jsou od sebe barevně odlišeny. Možnosti barev jsou:

¨ černá - jedná se o běžný zápis do vlastního diáře

¨ červená - v případě, že u daného záznamu došlo k překryvu s jiným záznamem

¨ modrá - zápis do diáře jinému uživateli nebo zápis ve vlastním diáři, který mi zapsal jiný uživatel

¨ zelená - zápis do vlastního diáře s příznakem soukromé

6.2 Kategorie diáře

Tato činnost se nachází v hlavním menu – Marketing – Diář – Kategorie diáře a umožňuje definovat kategorie, podle kterých je možno rozlišovat a zaznamenávat zprávy nebo záznamy v diáři. U každé kategorie se vyplňují tyto údaje:

¨ identifikace a název kategorie

¨ kolize – Ano/Ne – příznak, zda vyhodnocovat kolize (jednak při běžném zápisu záznamů do diáře a jednak při použití v rezervaci spravovaného majetku – pro obě tyto činnosti jsou kategorie diáře společné)

[1] Přehled označených záznamů vypne výběr, resp. zobrazí vždy přehled všech označených záznamů nezávisle na tom, jaký výběr je právě aktuálně zvolen. Přehled označených by uživatel mohl využívat i tak, že si zvolí řadu obecných výběrů, kde si v každém výběru označí vybrané záznamy a po stisku přehled označených se mu zobrazí kompletně všechny označené záznamy ze všech výběrů.

[2] Výběrová záložka bere v potaz pouze kategorie vstupované bez ohledu na jejich platnost.

© 1996-2013 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 16.10.2013


Dokumentace DPH

O B S A H

1. Úvod a základní pojmy

2. Umístění DPH

3. Typ zdanitelného plnění

4. Události DPH

4.1 Atributy

4.2 Záložka Výběr

4.3 Předlohy výstupu

4.4 Souhrnné hlášení

4.5 Výpis z evidence pro daňové účely

4.6 Institut ručení

5. Daňová přiznání

5.1 Proměnné daňového přiznání

5.2 Výpočet daňového přiznání

5.3 Vypočtená daňová přiznání

5.4 Elektronické přiznání DPH

6. Předměty zdanitelného plnění

7. Uplatnění předmětů zdanitelného plnění

8. Daňové přiznání - hlavička

1. Úvod a základní pojmy

Tato dokumentace se zaměřuje na podporu evidence daňových dokladů a s ní spojených úkonů (tj. daňové přiznání DPH, dodatečné daňové hlášení apod.) pomocí IS Bílý Motýl®, přičemž je zde kladen důraz na komponentu „DPH“.

Komponentu DPH uživatelé využijí především v souvislosti s vystavováním daňových dokladů a s přípravou daňového přiznání k dani z přidané hodnoty. Velmi časté je využití komponenty DPH ve spojení s komponentou OBC (obchod), jejíž události předcházejí událostem DPH a předplňují tabulku typů zdanitelného plnění.

K pochopení následujícího návodu je vhodná znalost dokumentace „ovládání“ (především kapitoly 1.1, 1.2 a 1.3), znalost Zákona o dani z přidané hodnoty (235/2004 Sb.) a Zákona o dani z příjmů (586/1992 Sb.). Pro větší názornost si zde zopakujeme některé pojmy ze slovníku pojmů:

- daň - platební povinnost do veřejného rozpočtu, kterou stát stanoví zákonem;

- daňová evidence (dle zákona o daních z příjmů) - zajišťuje zjištění základu daně z příjmů a obsahuje údaje o příjmech a výdajích (v členění potřebném pro zjištění základu daně) a majetku a závazcích;

- daňové identifikační číslo (DIČ) - číslo, které přidělí daňovému subjektu správce daně při registraci. Toto číslo je daňový subjekt povinen uvádět ve všech případech při styku se správcem daně a dále, pokud tak stanoví zákon;

- dodatečné daňové přiznání - daňové přiznání, které z vlastní iniciativy předkládá daňový subjekt, zjistí-li po uplynutí řádné lhůty pro podání daňového přiznání, že jím podané řádné daňové přiznání bylo chybné. Zjistí-li daňový subjekt svou chybu ještě před uplynutím řádné lhůty pro podání daňového přiznání, může podat opravné daňové přiznání. Po zmeškání této lhůty musí podat dodatečné daňové přiznání;

- opravné daňové přiznání - daňové přiznání, které může daňový subjekt podat po odevzdání řádného daňového přiznání před uplynutím lhůty pro podání řádného daňového přiznání. Pro vyměřovací řízení se pak použije opravného přiznání a k přiznání předchozímu se nepřihlíží. Opravným daňovým přiznáním může daňový subjekt před uplynutím řádné lhůty nahradit předchozí chybné daňové přiznání, které finanční úřad "zahodí". Po zmeškání lhůty pro podání daňového přiznání je nutno chyby opravit dodatečným daňovým přiznáním;

- řádné daňové přiznání - daňové přiznání k DPH je plátce DPH povinen předložit do 25 dnů po skončení zdaňovacího období k DPH. Plátce musí předkládat i negativní daňové přiznání, a to i v případě, že mu nevznikla v příslušném zdaňovacím období daňová povinnost.

- souhrnné hlášení – plátce je povinen podat souhrnné hlášení, pokud uskutečnil dodání zboží do jiného členského státu osobě registrované k dani v jiném členském státu; přemístil obchodní majetek do jiného členského státu; dodal zboží kupujícímu při zjednodušeném postupu v třístranném obchodu podle §17, pokud je plátce prostřední osobou v tomto obchodu nebo poskytnul službu s místem plnění v jiném členském státě podle §9 odst. 1, s výjimkou služeb osvobozených od daně, pokud je povinen přiznat a zaplatit daň příjemce služby.

- výpis z evidence pro účely daně z přidané hodnoty podle § 92a zákona o DPH - výpis DPHEVD je povinen předložit plátce, který v daném zdaňovacím období uskutečnil zdanitelné plnění v režimu přenesení daňové povinnosti (platí pro zákonem vyjmenované komodity a služby) a obdobně plátce, pro kterého bylo uvedené zdanitelné plnění v tuzemsku uskutečněno. Režim platí pro dodání uskutečněná mezi plátci v tuzemsku. Uvedené výpisy musí plátce odběratel i dodavatel předložit ve lhůtě pro podání daňového přiznání k DPH za dané zdaňovací období a to elektronicky;

- ZDPH – Zákon o dani z přidané hodnoty.

2. Umístění DPH

Tuto činnost má uživatel k dispozici v hlavním menu – DHP – Umístění DPH. Nadefinování jednotlivých umístění poskytuje uživateli možnost rozlišení firemních toků DPH (např. podle jednotlivých oddělení, středisek, poboček firmy apod.). Ke každému umístění je možno nadefinovat i přístupová práva (menu Volby nebo klávesová zkratka Ctrl B), která se následně projevují i v událostech DPH, kde je dané umístěno použito.

Příklad:

Uživatel bude mít např. střediska „prodej 01“ a „prodej 02“ a ke každému nadefinována správná přístupová práva. Pak uživatel, který má nadefinováno přístupové právo alespoň čtení ke středisku „prodej 01“ v událostech DPH nebude mít přístupné události, které se týkají střediska „prodej 02“ (k tomuto středisku nemá žádné přístupové právo) a naopak.

U každého umístění DPH se definují tyto atributy:

¨ umístění – identifikace umístění a jeho název

¨ adresát – identifikace adresáta vztahujícího se k danému umístění (po vyplnění identifikace adresáta – výběr z adresáře – se automaticky doplní celá jeho adresa)

¨ organizační selektor – zde se uvádí organizační selektor, který se vztahuje k danému umístění

3. Typ zdanitelného plnění

Tuto činnost má uživatel k dispozici v hlavním menu – DPH – Typ zdanitelného plnění. Číselník typů zdanitelného plnění dostává uživatel naplněný společně s dodávkou informačního systému. V případě legislativních změn si následně uživatel změny v sazbách apod. musí provést ručně.

Jednotlivé nastavené definice typů zdanitelného plnění uživatel využívá při automatizaci vstupu dat událostí OBC [1] a DPH programovým kódem.

Po aktivaci této činnosti má uživatel k dispozici přehled nadefinovaných typů zdanitelného plnění a aktivní záložku „Typy zdanitelného plnění“ (viz. obr. 1). Atributy na této záložce jsou:

¨ typ zdanitelného plnění – jednoznačná identifikace typu zdanitelného plnění [2]

¨ název – zpřesňující název typu zdanitelného plnění

¨ zdan. plnění – výběr možností zdanitelného plnění z překryvného seznamu. Možnosti jsou: nepodléhá dani, osvobozeno pro koeficient, snížená, základní, dočasné použití (historický atribut), finanční pronájem (historický atribut), osvobozeno, osvobozeno-třístranný obchod, snížená 2

¨ pro vývoz – historický atribut. Uvedené konkrétní možnosti na jednotlivých typech zdanitelných plnění sloužily pro definice daňového přiznání do 1.5.2004. Pro následující verze DPH se již nevyužívají.

¨ účel daně – historický atribut. Pro verzi DPH od 1.5.2004 se již nevyužívá.

Obr. 1

Záložka „Sazby DPH“ (viz obr. 2) obsahuje konkrétní sazby DPH k jednotlivým typům zdanitelného plnění.

¨ typ místa – výběr z překryvného seznamu tuzemsko/zahraničí/EU

¨ platnost od – počátek období platnosti dané sazby

¨ sazba DPH – vstup – procento sazby DPH na vstupu (odpočet)

¨ účet – vstup – syntetika účtu z účtové osnovy (historický atribut z verze do r. 2004). Od verze DPH k 1.5.2004 lze požadované analytické účty nadefinovat v činnosti Uplatnění předmětů zdanitelného plnění.

¨ sazba DPH – výstup – procento sazby DPH na výstupu (nápočet)

¨ účet – výstup – syntetika účtu z účtové osnovy (historický atribut z verze do r. 2004). Od verze DPH k 1.5.2004 lze požadované analytické účty nadefinovat v činnosti Uplatnění předmětů zdanitelného plnění.

¨ zaokrouhlení na řád, nahoru od cifry – řád zaokrouhlení a od které cifry nahoru (oba atributy se uplatní při zaokrouhlení částky DPH). V implementacích doporučujeme nastavit zaokrouhlování na 0,01 nahoru od cifry 1.

¨ tech. sel. – v případě potřeby detailního rozlišení možno uvést identifikaci technicko-věcného selektoru

Obr. 2

Na záložce „uplatnění předmětů“ (viz obr. 3) jsou k dispozici varianty zdanitelného plnění konkrétní sazby. Ke každému uplatnění je zadáno kdy a za jakých podmínek se toto uplatnění bude realizovat. U každého uplatnění se navíc eviduje jeho platnost od - do a ta uplatnění, která jsou již mimo dobu platnosti, se uživateli zobrazují šedivě. Při vstupu událostí obchodu se pak na základě kombinace: typ, místo plnění a plátce či neplátce nabízí odpovídající možnosti uplatnění předmětů.

Důležitými atributy na této záložce je uvedení čísla paragrafu a v poznámce uvedení přesného popisu, do kterého řádku daňového přiznání daný paragraf vstupuje (tzn. hodnotu jakého řádku daňového přiznání ovlivňuje). Pro platné znění daňového přiznání od vzoru č. 15 a dále je nutno mít v atributu poznámka řádek uveden ve tvaru „=ř. xy“.

Čísla paragrafů uvedená v této činnosti slouží jako vodítko, nejedná se o plný a přesný výčet paragrafů z hlediska Zákona od DPH.

Obr. 3

Záložka „Uplatnění předmětů“ slouží v této činnosti spíše pro hrubou informaci uživatele. Vlastní definici a prohlížení jednotlivých uplatnění je vhodnější provádět přímo v dané činnosti (vlastní popis činnosti a jednotlivých atributů je uveden v kapitole 7. Uplatnění předmětů zdanitelného plnění).

Na záložce „Substituce TZP“ (viz obr. 4) lze k typu zdanitelného plnění definovat pravidlo (i více pravidel), které předplní na událost obchodu zde definovaný typ zdanitelného plnění, který je odlišný od typu uvedeného na kartě obchodovatelného artiklu.

Příklad:

¨ je vstupována událost obchodu - prodej pro adresáta s typem místa EU, který je plátcem DPH a s artiklem, který má u sebe uvedenu klasifikací Z (zboží) a typ zdanitelného plnění ZA1

¨ pro TZP ZA1 je definovaná substituce (OSV, EU, Nápočet, Plátce DPH=Ano, Z)

¨ potom na události obchodu bude pro takového adresáta automaticky předplněn typ zdanitelného plnění OSV

Obr. 4

4. Události DPH

Jednotlivé události DPH (tj. daňové doklady) vznikají prostřednictvím procesů . Jinými slovy lze toto vysvětlit tak, že někde v operativní evidenci v systému (např. komponenta obchod nebo zálohy) je vytvořen prvotní doklad (např. vystavená faktura nebo vystavený zálohový list) a na základě procesu a v něm nadefinovaných transformací dojde k zápisu do událostí DPH.

Tato činnost poskytuje uživateli přehled jednotlivých provedených záznamů (tj. událostí) do daňové evidence. Tyto události se v této činnosti pouze zobrazují, tzn. jsou k dispozici pro prohlížení, nelze je zde vytvářet. Vytvoření jednotlivých událostí se provádí procesním způsobem, tzn. každý druh události (odpočet, nápočet apod.) je součástí určitého druhu procesu, který uživatel aktivuje. Ve většině případů tedy vznikají události DPH napojením do jiného druhu procesu (např. viz obr. 5, kde operace „DPH – nápočet“ je součástí procesu OBVF01 – Faktura odeslaná tuzemsko) nebo referenčním procesem (např. dobropis, apod.).

Pokusíme se tedy o krátké shrnutí možností vzniku daňových dokladů (událostí DPH):

¨ vznikají na základě procesů realizovaných nákupů a prodejů (včetně dobropisů a záloh), ale i jiných událostí, které podléhají této dani

¨ je možný i přímý vstup

Na základě zadaného obchodovatelného artiklu se automaticky přiřadí typ zdanitelného plnění a dle dalších parametrů adresáta a obchodu (např. místo plnění apod.) je daný obchod z hlediska daně z přidané hodnoty automatizovaně vypořádán.

Obr. 5

Samostatný zápis (výše zmíněný přímý vstup) do událostí DPH lze provést procesem „DPH dle uživatele a zaúčtování“, který má uživatel k dispozici v hlavním menu – Nový proces – Účetní zápisy – prvotní evidence. Tento proces obsahuje dvě operace. Obecnou operaci DPH a na ni je napojená operace „obecný účetní zápis“.

Pro automatizované vytváření daňových dokladů (událostí DPH) procesním způsobem, tzn. na základě vzniku prvotních dokladů v jiné komponentě (nejčastěji je to obchod) je nutné mít správně nadefinovány vstupní údaje, tzn. už v prvotní evidenci (např. událost obchodu) musí být správně uveden typ zdanitelného plnění, typ místa, způsob uplatnění a předmět. Pomocí transformací, které jsou nastaveny v procesech jsou pak tyto údaje automaticky předplněny v daňových dokladech (událostech DPH). Aby však bylo zajištěno co nejvíce automatizované naplnění těchto údajů i v dokladech prvotní evidence, je z hlediska DPH nutno zajistit následující body:

¨ u jednotlivých adresátů v činnosti adresář (hlavní menu – Marketing – Adresář) je nutno mít správně na první záložce vyplněn typ místa a na záložce Další vyplněn příznak plátce DPH (možnosti jsou Ano/Ne) a měnu – oceňovací jednotku, tzn. měnu ve které budeme s daným adresátem obchodovat - viz obr. 6 a 7

¨ u obchodovatelného artiklu (hlavní menu – Obchod – Obchodovatelný artikl) je nutno mít nadefinovanou identifikaci typu zdanitelného plnění, případně klasifikaci artiklu a kód předmětu plnění.

¨ dle možnosti nadefinovat substituce

Obr.6

Obr.7

4.1 Atributy

Jednotlivé atributy této činnosti má uživatel k dispozici na záložce „Událost“. V tento okamžik je má uživatel k dispozici pouze pro prohlížení (viz obr. 8). Jednotlivé atributy si popíšeme v souvislosti s možností vytváření daňových dokladů (tzn. událostí DPH).

V případě takto hromadně zobrazených daňových dokladů (viz obr. 8) je možno aktivní daňový doklad (tzn. ten, na kterém je umístěn kurzor) aktivovat po stisku klávesy F9.

Pod menu Volby má uživatel k dispozici další možnosti:

¨ Diagram procesu – uživateli se zobrazí diagram konkrétního fyzického procesu, jehož je daná událost DPH součástí

¨ Strom hlavního procesu – uživateli se zobrazí strom hlavního procesu, kde kurzor zůstane umístněn v místě dané operace DPH

¨ Vlastnosti operace – konkrétní informace o události (tj. operaci) DPH – v jakém se nachází stavu (připravena, zahájena, ...), kdo s operací pracoval apod.

Obr. 8

Další popis se týká konkrétních atributů činnosti události DPH:

¨ číslo operace - na základě číselné řady a druhu daného procesu jsou předplněny atributy týkající se procesu (číslo, identifikace operace, pořadí, název)

¨ odpočet/nápočet – předplněno na základě masky operace v procesu

¨ datum – předplněn datem z předchozí operace (v případě ručního vstupu operace DPH, tzn. pokud operace DPH zahajuje proces, se předplní aktuálním datem)

¨ druh události – běžná, dodatečné hlášení, ostatní ... – předplněno na základě masky operace v procesu, případně výběr ručně

¨ popis – vlastní popis události

¨ adresát – výběr adresáta z adresáře – v případě, že je operace součástí procesu, předplní se na základě transformace adresát z předchozí operace

¨ umístění – umístění DPH (k jednotlivým umístěním je možno nadefinovat přístupová práva. Pokud je na události DPH uvedeno umístění, na které nemá uživatel právo ani čtení, nemá danou událost DPH k dispozici).

¨ typ zd. pl. – předplněn pomocí transformace (nejčastěji na základě předchozí operace obchodu a tam je zadán na základě typu zdan. plnění uvedeného artiklu) a zároveň s typem zdanitelného plnění se automaticky přenese typ místa, způsob uplatnění a předmět (s výjimkou samovyměření daně v režimech reverse charge). Pokud není operace DPH součástí žádného procesu, ale vstupuje se zde samostatně, uživatel si ručně vybere typ zdan. plnění a ostatní atributy.

¨ PID – pomocná identifikace záznamu DPH – identifikace DPH ze zálohy. Přiřazuje se buď automaticky nebo ručně události DPH, která následuje po úhradě zálohy. Slouží pro automatické vyčíslení již zdaněné hodnoty DPH z titulu zálohy v navazujících dokladech jejího vyúčtování, případně její následnou kontrolu z pohledu DPH.

¨ měna – automaticky předplněna pomocí transformace (předplňuje se na základě měny uvedené na záložce „další“ u adresáta uvedeného na události)

¨ základ DPH v ZM – celková částka základu DPH v zahraniční měně

¨ DPH v ZM – celková částka DPH v zahraniční měně

¨ základ DPH v RM – celková částka základu DPH v referenční měně

¨ DPH v RM – celková částka DPH v referenční měně

¨ DPH v RM (zaokr.) – celková částka DPH v referenční měně zaokrouhlená

¨ selektory – identifikace selektorů, které se na událost DPH zapisují automaticky (obchodní selektor na základě selektoru, který má u sebe uveden adresát události, organizační selektor na základě selektoru uvedeného u umístění DHP a technicko-věcný selektor na základě selektoru, který je uveden na kartě obchodovatelného artiklu v předchozí události obchodu)

¨ zapsal – kdo a kdy danou událost zapsal (datum, čas, jméno uživatele)

Po stisku pravého tlačítka myši na tučném atributu „Adresát“ si uživatel může vyvolat další potřebné informace vztahující se k adresátovi dané události, např. události daného adresáta v jednotlivých komponentách, aktuální hodnoty adresáta, obratové hodnoty a další podrobné údaje z adresáře (tj. adresa, spojení, cenové skupiny, ...).

Po stisku pravého tlačítka myši na tučném atributu „PID“ má uživatel následující možnosti:

¨ přehled záloh – aktivuje se činnost přehled záloh s předplněnou výběrovou záložkou (podle PID je předplněno číslo zálohy a identifikace adresáta). Uživatel má k dispozici údaje o záloze – celková částka, kolik je uhrazeno, kolik zbývá uhradit apod.

¨ události o zálohách – aktivuje se činnost události záloh, kde je na základě PID zobrazena událost dané zálohy

¨ události DPH – uživateli se aktivuje daná událost DPH

Uživatel jistě využije i kombinaci kláves Ctrl S – Suma stran. Poskytuje uživateli přehled sumárních částek zobrazených událostí (či konkrétní události). Uživatel má k dispozici dva sloupce hodnot – nápočet a odpočet a v každém info o částce základu DPH, částce DPH a celkové částce (tzn. základ DPH + DPH) a to jak v referenční, tak i v zahraniční měně (pokud je na události použita, pokud ne, jsou hodnoty v obou měnách shodné) a případný rozdíl mezi hodnotami odpočtu a nápočtu.

Po stisku klávesy Ctrl D má uživatel k dispozici dokumenty, které souvisejí s danou událostí DPH, např. při zpracovávání došlé pošty může daná pracovnice nascanovat přijatou fakturu do systému a uživatel pak při kontrole událostí DPH (v případě, že bude mít nějaké nejasnosti nebo si jen chce ověřit prvotní doklad) má po stisku Ctrl D tento doklad ihned k dispozici.

Protože události DPH jsou velmi citlivé informace firmy (obzvlášť s ohledem na daňové přiznání), je nutné mít jednak správně nastavena přístupová práva a zároveň je nutno mít možnost i zpětně sledovat provedené změny či opravy. Toto uživateli umožňuje nadefinování v činnosti „sledování změn v záznamech tabulek IS BM“ (viz. daný pojem ve slovníku pojmů).

Opravy záznamů v událostech DPH lze provádět:

¨ Běžným přepisem jednotlivých atributů (pouze dokud není operace ukončena. V případě ukončené operace lze opravit pouze atribut „popis“ a „způsob odpočtu daně“.).

¨ Pomocí odblokovače (viz. pojem „ zrušit stav ukončena “ ve slovníku pojmů).

¨ Provedením storna daného daňového dokladu (viz. pojem „ storno “ ve slovníku pojmů).

4.2 Záložka Výběr

Záložka „výběr“ se uživateli nabízí jako první po spuštění činnosti „události DPH“. Z jednotlivých atributů je zřejmé k čemu slouží a proto zkušenému uživateli jistě nedá práci nadefinovat si výběr tak, aby měl k dispozici přehled událostí DPH, které potřebuje. Záložka „výběr“ je v podstatě rozdělena do tří částí. Horní řádek umožňuje uživateli využít při výběru číselné řady, identifikaci či konkrétní číslo procesu nebo operace. Výběr možno upřesnit ještě zadáním data událostí od – do.

Pravá část umožňuje vyhledávání podle jednotlivých částek od – do ve zvolených atributech.

Levá část obsahuje atributy, které se detailně týkají událostí DPH, tzn. uživatel může vyhledávat podle typu místa, typu zdanitelného plnění, zdanitelného plnění, předmětu zdanitelného plnění, adresáta, umístění, měny apod. Je zde k dispozici i atribut „událost“, kde je implicitně předplněno „všechna“. Pro konkrétní vyhledávání událostí DPH je vhodné si tento atribut upřesnit, např. pro kontrolu běžného daňového přiznání pracovat pouze s událostmi typu „běžná“, naopak pro kontrolu dodatečného daňového přiznání pracovat pouze s událostmi typu „dodatečné přiznání“. Pozornost je vhodné věnovat událostem typu „ostatní“.

Na atributu výběr má uživatel kromě standardního běžného výběru ještě možnost využít i obecný výběr:

¨ přiznání plný a krácený nárok – zobrazí se pouze ty události, které mají v atributu způsob uplatnění odpočtu daně uvedeno číslo 1 (=100%) nebo 3 (=kráceno)

¨ souhrnné hlášení r. 2013 – zobrazí se události, které jsou podkladem pro Souhrnné hlášení za příslušné období

¨ výpis z evid. DPHEVD – dodavatel – zobrazí se události, které jsou podkladem pro DPHEVD za příslušné období

¨ výpis z evid. DPHEVD – odběratel – zobrazí se události, které jsou podkladem pro DPHEVD za příslušné období

Obr. 9

4.3 Předlohy výstupu

¨ Daňový doklad - záloha přijatá – slouží pro tisk daňového dokladu po úhradě zálohového listu

¨ Evidence dle par. 44 (IR) – formulář dle doporučení MF, který lze použít jako detailní přílohu k DPH přiznání, v případě opravy výše daně u pohledávek za dlužníky v insolvenčním řízení

¨ Přehled DD s DIČ – s výběrem nápočet nebo odpočet uvádí podrobný přehled daňových dokladů se sumou za tuzemsko, zahraničí a EU, splňuje požadavky záznamní povinnosti

¨ Přehled DD2 – s výběrem nápočet nebo odpočet, běžná událost uvádí sumární přehled daňových dokladů za místa, typy a předměty zdanitelných plnění – lze využít pro kontrolu daňových dokladů na daňové přiznání (viz. dokument legislativně závislá nastavení)

¨ Souhrnné hlášení VIES - H 2013– s výběrem Souhrnné hlášení (r. 2013) slouží pro vytvoření souhrnného hlášení pro elektronické podání ve formátu a struktuře požadované správcem daně

¨ Výpis z evidence-dod.-od2013 – s výběrem výpis z evid. DPHEVD – dodavatel slouží pro vytvoření výpisu pro elektronické podání ve formátu a struktuře požadované správcem daně

¨ Výpis z evidence-odb.-od2013 – s výběrem výpis z evid. DPHEVD – odběratel slouží pro vytvoření výpisu pro elektronické podání ve formátu a struktuře požadované správcem daně

4.4 Souhrnné hlášení

Plátce je povinen podat souhrnné hlášení, pokud uskutečnil dodání zboží do jiného členského státu osobě registrované k dani v jiném členském státu; přemístil obchodní majetek do jiného členského státu; dodal zboží kupujícímu při zjednodušeném postupu v třístranném obchodu podle §17, pokud je plátce prostřední osobou v tomto obchodu nebo poskytnul službu s místem plnění v jiném členském státě podle §9 odst. 1, s výjimkou služeb osvobozených od daně, pokud je povinen přiznat a zaplatit daň příjemce služby (ve znění platného zákona).

Souhrnné hlášení se podává formou datové zprávy, která je opatřena uznávaným elektronickým podpisem , nebo která je odeslána prostřednictvím datové schránky, vždy ve formátu, struktuře a s údaji stanovenými správcem daně. Údaje o hodnotě dodaného zboží nebo poskytnuté služby se uvádějí v české měně. [3]

Uživatel si souhrnné hlášení vytvoří následujícím způsobem:

¨ v činnosti události DPH si na výběrové záložce zvolí období od – do

¨ v obecném výběru platném pro dané období vybere „souhrnné hlášení“

¨ v komponentě DPH je nutno mít vyplněnu činnost „Daňové přiznání - hlavička“

Po načtení těchto příslušných událostí vyvolá předlohy výstupu (v panelu nástrojů ikona tiskárna nebo pod menu Volby Ctrl T). Zde má uživatel k dispozici předlohu výstupu „Souhrnné hlášení VIES“ a „Souhrnné hlášení VIES 2010“ (nutno si vybrat předlohu v platném znění pro daný rok, viz. dokument legislativně závislá nastavení).

Po aktivaci dané předlohy se spustí portál EPO (aplikace daňové správy), kde lze zkontrolovat a především VYTISKNOUT souhrnné hlášení. Další způsob zpracování souhrnného hlášení je shodný s elektronickým podáním přiznání DPH (viz. kapitola 5.4). Aplikace EPO je vytvořena přehledně a intuitivně vede uživatele kterou činnost má právě provést.

4.5 Výpis z evidence pro daňové účely

Plátce, který uskutečnil nebo pro kterého bylo uskutečněno zdanitelné plnění v režimu přenesení daňové povinnosti podle par. 92a (ve znění platného zákona), je povinen předložit správci daně ve lhůtě pro podání daňového přiznání výpis z evidence pro daňové účely (DPHEVD).

Výpis DPHEVD se podává formou datové zprávy, která je opatřena uznávaným elektronickým podpisem nebo která je odeslána prostřednictvím datové schránky, vždy ve formátu, struktuře a s údaji stanovenými správcem daně. Údaje se uvádějí v české měně.

Uživatel si výpis DPHEVD vytvoří následujícím způsobem:

¨ v činnosti události DPH si na výběrové záložce zvolí období od – do

¨ v obecném výběru platném pro dané období vybere „Výpis z evid. DPHEVD - odběratel“ nebo „Výpis z evid. DPHEVD – dodavatel“

¨ v komponentě DPH je nutno mít vyplněnu činnost „Daňové přiznání - hlavička“

Po načtení těchto příslušných událostí uživatel vyvolá předlohy výstupu (v panelu nástrojů ikona tiskárna nebo pod menu Volby Ctrl T). Zde má uživatel k dispozici předlohu výstupu „Výpis z evidence-dodavatel“ a „Výpis z evidence-odběratel“ (nutno si vybrat předlohu v platném znění pro daný rok, viz. dokument legislativně závislá nastavení).

Po aktivaci dané předlohy se spustí portál EPO (aplikace daňové správy), kde lze zkontrolovat a především VYTISKNOUT výpis DPHEVD. Další způsob zpracování DPHEVD je shodný s elektronickým podáním přiznání DPH (viz. kapitola 5.4). Aplikace EPO je vytvořena přehledně a intuitivně, vede uživatele, kterou činnost má právě provést.

4.6 Institut ručení

S účinností od 1. 4. 2011 byl zaveden v ZDPH institut ručení za nezaplacenou daň z přidané hodnoty (§ 109), který byl následně rozšířen o další skutkové podstaty ručení, a to s účinností od 1. 1. 2012, resp. od 1. 1. 2013. Jedním důvodem použití aplikace ručení je situace, kdy je v okamžiku uskutečnění daného plnění o poskytovateli zveřejněno způsobem umožňujícím dálkový přístup, že je nespolehlivým plátcem. Dalším důvodem ručení příjemce zdanitelného plnění je také, pokud je úplata za plnění poskytnuta zcela nebo zčásti bezhotovostním převodem na jiný účet než účet poskytovatele zdanitelného plnění, který je správcem daně zveřejněn způsobem umožňujícím dálkový přístup (s doplněním účinným od 1.1.2014).

Pohodlnější kontrolu této oblasti ručení umožní uživatelům následující nástroje:

¨ doplňující vlastnost formuláře nad adresátem „Údaje o registraci k DPH adresáta“ (záložka Volby, případně na liště v základní nabídce „URA“).

¨ doplňující vlastnost formuláře nad adresátem „Kontrola spolehlivosti plátce DPH WS“ (záložka Volby)

¨ doplňující vlastnost formuláře nad příkazy k úhradě „Kontrola spolehlivosti plátce DPH“ (záložka Volby, případně na liště v základní nabídce „URA“).

Jednotlivé kontroly spolehlivosti se spouští ručně. Kontrola je postavena na DIČ adresáta, tj. kontrolovaný adresát má v adresáři uvedeno DIČ ve struktuře „CZ………“. Jiná DIČ kontrola nezahrnuje (ujistěte se, že máte DIČ v adresáři v IS BM ve správném formátu).

Na příkazu k úhradě kontrola probíhá následujícím způsobem. Po spuštění doplňující vlastnosti se nejprve zobrazí informace o č. příkazu, kliknutím (kamkoliv) se aktivuje kontrola veškerých položek příkazu. V případě, že jsou všechny položky (pouze adresátů s DIČ začínajícím na CZ) v pořádku, tj. spolehlivý plátce a zveřejněný účet, zobrazí se informace „Kontrola ukončena“.

V případě, že kontrola zjistí nesoulad registrace a příkazu (např. chybné DIČ v adresáři, jiný BÚ na příkazu), oznámí vždy a uvede také hodnotu přikazovaného závazku v CZK (informace pro vyhodnocení, zda nedošlo k překročení limitu). Kontrola dále zobrazuje upozornění, že je na příkazu k úhradě zadán pro tuzemského adresáta účet vedený v zahraničí (IBAN nezačíná na CZ). Např. viz. obrázek:

5. Daňová přiznání

Daňové přiznání k DPH je plátce DPH povinen elektronicky podat do 25 dnů po skončení zdaňovacího období k DPH (detailní popis je uveden v kapitole 5.4). Plátce musí až na stanovené výjimky podávat i negativní daňové přiznání, jestliže mu nevznikla v příslušném zdaňovacím období daňová povinnost. Vlastní daňová povinnost plátce je splatná ve stejné lhůtě v jaké je povinen podat daňové přiznání, tedy nejpozději do 25 dnů po skončení příslušného zdaňovacího období.

Činnost daňová přiznání uživatel aktivuje z hlavního menu – DPH – Daňová přiznání. Jako první se uživateli nabídne záložka „výběr“, kde si může určit přesnou definici a název, které přiznání bude chtít mít k dispozici nebo které události má daňové přiznání reflektovat. Pro uživatele ale bude zřejmě na této záložce nejvíc používaný atribut „platnost“. Uživatel si na základě platnosti může zvolit jaké definice daňového přiznání chce mít následně k dispozici:

¨ platná i neplatná – zobrazí se všechny definice bez ohledu na platnost

¨ platná dnes - definice platné k aktuálnímu datu

¨ platná minulý měsíc – definice platné k aktuálnímu datu v minulém měsíci

Po potvrzení záložky „výběr“ se mu jako aktivní zobrazí záložka „Daňová přiznání“ (viz obr. 10), kde má uživatel k dispozici definice běžných a dodatečných daňových přiznání s uvedenými daty platnosti (právě tato uvedená data platnosti hrají svoji roli ve výběrové záložce).

Obr. 10

Jednotlivé definice daňového přiznání uživatel nevytváří sám, dostává je od firmy BM Servis s.r.o. jako součást verze. Případné změny v definicích jsou pak nejčastěji řešeny zasíláním balíčku (nebo pomocí sady vzdálených funkcí ) s novou či opravenou stávající definicí. Součástí jednotlivých definic jsou i „položky DP“, které má uživatel dostupné na další záložce a které nedoporučujeme měnit.

Pro vytvoření daňového přiznání DPH však nestačí mít jen správné definice včetně položek DP. Uživatel musí mít správně vyplněnu „hlavičku daňového přiznání“ (viz obr. 11) se všemi potřebnými údaji (menu DPH - činnost Hlavička daňového přiznání). Tato činnost se používá i při výpočtu souhrnného hlášení.

Údaje zapsané v této činnosti se pak při vytváření vlastního daňového přiznání (ať už v textové či elektronické podobě) automaticky přenášejí na první stránku daňového přiznání, kde jsou k dispozici veškeré nacionále o uživateli, proto je nutné mít zde veškeré atributy vyplněny opravdu správně a pečlivě.

Obr. 11

5.1 Proměnné daňového přiznání

Proměnné daňového přiznání má uživatel rovněž k dispozici v činnosti „daňová přiznání“ po stisku klávesy F7 nebo aktivaci činnosti „Proměnné daňového přiznání“ pod menu Volby. Uživatel musí mít kurzor umístněn na definici daňového přiznání, které počítal, tzn. na tom řádku s definicí, na kterém aktivoval výpočet daňového přiznání.

Po aktivaci této činnosti se mu nejprve nabídne záložka „výběr“, kde si jako období zvolí příslušný rok a po uložení výběru (ikona „disketa“) se mu zobrazí proměnné daňového přiznání.

Do proměnných daňového přiznání je nutno zadat pro každou novou verzi daňového přiznání alespoň jednou hodnotu zálohového koeficientu „100“, v případě potřeby krácení příslušnou hodnotu zálohového koeficientu vždy pro konkrétní rok. Význam dalších proměnných je uveden v poznámce daného daňového přiznání – jedná se o ručně zadávané hodnoty do konkrétních řádků daňového přiznání.

Pokud má uživatel k dispozici platné definice daňového přiznání, správně zadanou hlavičku daňového přiznání a proměnné daňového přiznání, může přistoupit k vlastnímu výpočtu daňového přiznání.

5.2 Výpočet daňového přiznání

Výpočet daňového přiznání uživatel provede v činnosti „daňová přiznání“ po stisku klávesy F5 nebo aktivací činnosti „Výpočet DP“ pod menu Volby. Uživatel musí mít kurzor umístněn na definici daňového přiznání, které chce počítat, tzn. když chce uživatel spočítat běžné daňové přiznání, musí tzv. „stát“ na řádku DANP12 – Daňové přiznání po 1.1.2015.

Po aktivaci této činnosti se mu zobrazí dialogové okno, kde je předplněn rok a měsíc za který se má daňové přiznání vypočítat. Tyto údaje samozřejmě může uživatel editovat. Po jejich zapsání (pomocí ikony „disketa“ v panelu nástrojů) dojde k vlastnímu výpočtu daňového přiznání.

Obr. 12

5.3 Vypočtená daňová přiznání

Vypočtená daňová přiznání má uživatel rovněž k dispozici v činnosti „daňová přiznání“ po stisku klávesy F6 nebo aktivaci činnosti „Vypočtená daňová přiznání“ pod menu Volby. Uživatel musí mít kurzor umístněn na definici daňového přiznání, které počítal, tzn. na tom řádku s definicí, na kterém aktivoval výpočet daňového přiznání.

Po aktivaci činnosti „vypočtená daňová přiznání“ se mu zobrazí daná činnost s aktivní záložkou „výběr“, kde si uživatel určí za jaké období chce mít vypočtené přiznání k dispozici:

¨ rok – definice roku

¨ měsíc/kvartál – možnost zvolit si období daného roku. V případě měsíců se zadávají ve tvaru 01, 02, ....11, 12. V případě, že si uživatel jako období zvolí kvartál – musí být zadán ve tvaru Q1, Q2, Q3 a Q4.

Uživatel výběr uloží (pomocí ikony „disketa“ v panelu nástrojů) a zobrazí se mu přehled jednotlivých řádek daňového přiznání za vybrané období (viz obr. 13). Zde si pak může jednotlivé řádky prohlédnout a následně si vybrané daňové přiznání vytisknout. Od roku 2015 pouze v aplikaci EPO, a to v souvislosti s novelou ZDPH, která ukládá plátcům povinnost podávat vyjmenovaná podání pouze elektronicky (mimo jiné daňové přiznání, dodatečné daňové přiznání a hlášení, a to včetně jejich příloh).

K tomu uživatel využije předlohu výstupu pod ikonou „tiskárna“ v panelu nástrojů, která slouží současně pro elektronické podání daňového přiznání. Sestava je samozřejmě dle potřeb aktualizována, pro rok 2015 je platná předloha výstupu ADIS 2013 H.

Uživatel může získat rychlý přehled pro účely prvotní kontroly DPH přiznání, aniž by bylo nutné vstupovat na portál DS. Použije pro to předlohu Podklad k DPH přiznání (vz.19), která v podstatě zobrazuje oddíl „C“ přiznání.

Předlohy výstupu s čísly vzoru do č. 18 lze použít v historickém kontextu zobrazovaných dat.

Obr.13

5.4 Elektronické přiznání DPH

Veškeré informace o podání elektronického přiznání DPH má uživatel k dispozici na daňovém portálu České daňové správy. V první řadě je nutno podotknout, že aplikace EPO (elektronické přiznání DPH) není aplikací BM, tzn. plně si za tuto aplikaci zodpovídá daňová správa a stejně tak se v čase samozřejmě mohou lehce měnit formuláře apod., které zde máme pro vaši potřebu k dispozici (tzn. tento návod na podání elektronického přiznání DPH se může v čase měnit od aktuálních www stránek daňové správy, podle toho, jak často tyto stránky daňová správa mění a aktualizuje) [4] .

Informace o aplikaci elektronického podání DPH má uživatel k dispozici na stránce https://adisepo.mfcr.cz/adistc/adis/idpr_epo/epo2/uvod/vstup.faces .

Pro uživatele je tedy v IS BM k dispozici možnost zpracování vypočtených daňových přiznání elektronicky. Postup tohoto zpracování je následující:

¨ je nutno mít správně vyplněnu činnost „Daňové přiznání - hlavička“

¨ poté stiskem klávesy F5 nebo volbou činnosti z menu Volby uživatel provede výpočet daňového přiznání

¨ v činnosti „vypočtená daňová přiznání“ aktivuje předlohu výstupu ADIS 2013H

¨ po spuštění předlohy se uživateli zobrazí dialogové okno (viz obr. 14), kde v možnostech zaškrtne volbu „spustit ADIS“ – potvrdí stiskem OK a následně se mu na daňovém portálu České daňové správy otevře formulář pro „elektronické podání pro daňovou správu“ (může se stát, že se neotevře automaticky, ale spustí se uživateli na dolní lištu PC).

Obr. 14

Při využití volby „uložit dokument do BM“ je nutno mít v aplikaci předlohy dokumentů nadefinovány příslušné předlohy dokumentů vztahující se k předlohám typu ADIS.

Obr. 15

¨ pomocí tlačítka „Procházet“ (viz obr. 15) si vybere soubor vypočteného daňového přiznání a stiskne tlačítko „Načíst“ (nebo ho lze automaticky načíst po stisku klávesy Ctrl V)

¨ po načtení vybraného souboru se uživateli následně zobrazí formulář „Informace o souboru s datovou zprávou“ (viz obr. 17), kde má uživatel tyto možnosti:

- odeslání písemnosti

- úprava ve formuláři

- úplný opis k tisku

- protokol chyb

- načtení souboru

Obr. 16

¨ automaticky se předplní formulář „Přiznání k dani z přidané hodnoty“. Uživatel si překliknutím může v klidu prohlédnout jednotlivé oddíly a kapitoly.

¨ po stisku tlačítka „úprava ve formuláři“ se mu zobrazí nabídka jednotlivých částí daňového přiznání

Obr. 17

¨ opětovným stisknutím tlačítka „Další stránka“ si uživatel postupně projde všechny stránky daňového přiznání od Záhlaví, přes Oddíl I., Oddíl II. atd. až po Závěr, kde má možnost si prohlédnout protokol chyb, před odesláním si písemnosti uložit na vybrané místo na disku apod. Po přihlášení a stisku tlačítka „Odeslání písemnosti“ dojde k odeslání vytvořeného daňového přiznání DPH.

¨ zároveň má uživatel možnost si zvolit další akci podle svého uvážení, např. uložení k odeslání do Datové schránky, úplný opis k tisku apod.

V případě, že oprávněná osoba má certifikáty uloženy na svém PC, automaticky se předplní, jinak je nutno pomocí tlačítka „vybrat jiný certifikát“ vybrat ručně. Je vhodné vyplnit i příslušnou emailovou adresu, aby měl uživatel přehled v jakém stádiu zpracování se přiznání DPH nachází. Po vyplnění všech údajů pokračuje tlačítkem „Podat“. Tím dojde k odeslání daňového přiznání DPH, uživatel má možnost si uložit kopii na svém PC a i nadále má možnost sledovat stav zpracování daňového přiznání DPH.

Informace pro uživatele:

Po odeslání daňového přiznání následně obdržíte od daňové správy „potvrzení o podání písemnosti“. Zde postupujte podle popsaného připojeného návodu a pomocí tlačítka „uložit potvrzení“ si danou písemnost uložte na svém PC.

6. Předměty zdanitelného plnění

V této činnosti má uživatel samostatně k nahlédnutí číselník jednotlivých předmětů zdanitelného plnění a ke každému předmětu i přehled jeho uplatnění (viz obr. 19). Předměty i uplatnění zdanitelného plnění jsou nedílnou součástí definice vlastních typů zdanitelného plnění, které pak vstupují do událostí DPH a jsou podkladem pro vytvoření daňového přiznání DPH.

Předměty lze uživatelsky doplnit pouze na základě pokynů správce IS BM v souvislosti se změnami zákona o DPH, případně změnami formuláře daňového přiznání.

Podle zákona o DPH (235/2004 Sb.) je předmětem daně:

¨ dodání zboží nebo převod nemovitosti anebo přechod nemovitosti v dražbě za úplatu osobou povinnou k dani v rámci uskutečňování ekonomické činnosti, s místem plnění v tuzemsku,

¨ poskytnutí služby za úplatu osobou povinnou k dani v rámci uskutečňování ekonomické činnosti, s místem plnění v tuzemsku,

¨ pořízení zboží z jiného členského státu Evropské unie za úplatu, uskutečněné v tuzemsku osobou povinnou k dani v rámci uskutečňování ekonomické činnosti nebo právnickou osobou, která nebyla založena nebo zřízena za účelem podnikání, a pořízení nového dopravního prostředku z jiného členského státu za úplatu osobou, která není osobou povinnou k dani,

¨ dovoz zboží s místem plnění v tuzemsku.

Plnění, která jsou předmětem daně, jsou zdanitelnými plněními, pokud nejsou osvobozena od daně.

Obr. 18

7. Uplatnění předmětů zdanitelného plnění

V této činnosti má uživatel samostatně k nahlédnutí číselník jednotlivých uplatnění předmětů zdanitelného plnění (viz obr. 20). Uplatnění předmětů zdanitelného plnění jsou nedílnou součástí definice vlastních typů zdanitelného plnění, které pak vstupují v událostech DPH a jsou podkladem pro vytvoření daňového přiznání DPH.

Pro uplatnění předmětů a jejich uživatelské úpravy platí následující pokyny:

¨ uplatnění, která mají v atributu poznámka uvedeno konkrétní číslo řádku lze uživatelsky doplnit pouze na základě pokynů správce IS BM v souvislosti se změnami zákona o DPH, případně definice daňového přiznání

¨ uplatnění, která mají v atributu poznámka uvedeno „pro obchod“ lze libovolně uživatelsky modifikovat (tj. ta, která nikdy nevstupují do daňového přiznání)

Po aktivaci této činnosti (hlavní menu – DPH – Uplatnění předmětů zdanitelného plnění) se uživateli jako první nabídne nejprve záložka „výběr“ (obr. 19), kde si může podle následujících výběrových atributů zvolit množinu dat, kterou chce mít následně k dispozici. Vybírat lze podle:

¨ paragrafu

¨ předmětu

¨ typu zdanitelného plnění

¨ typu místa

¨ příznaku, zda se jedná o odpočet či nápočet (nebo obojí)

¨ účtu z účetní osnovy

¨ technického selektoru

¨ platnosti – tento atribut lze ještě blíže specifikovat podle těchto podmínek:

¨ platné i neplatné – tj. všechna uplatnění z hlediska platnosti

¨ platné dnes – uživateli se zobrazí všechna uplatnění, jejichž období platnosti od – do je aktuální pro dnešní datum

¨ neplatné dnes - uživateli se zobrazí všechna uplatnění, jejichž období platnosti od – do je neaktuální pro dnešní datum

¨ platné k datu - uživateli se zobrazí všechna uplatnění, jejichž období platnosti od – do je aktuální pro zadané datum

¨ neplatné k datu - uživateli se zobrazí všechna uplatnění, jejichž období platnosti od – do je neaktuální pro zadané datum

Obr. 19

Pro ještě podrobnější vyhledávání má uživatel k dispozici i možnosti, které mu nabízí obecný výběr:

¨ dle řádku v poznámce – uživatel má možnost vyhledávat podle přesného čísla řádku DPH přiznání, které má uvedeno u jednotlivých uplatnění v atributu „poznámka“

¨ poznámka – uživatel má možnost vyhledávat podle komentáře, který má uveden u jednotlivých uplatnění v atributu „poznámka“ (doporučení - „%text“ nebo „%číslo“)

Po potvrzení záložky „výběr“ se uživateli nabídne následující číselník (viz obr. 20), kde má k dispozici následující atributy:

¨ paragraf – číslo paragrafu. Paragraf je uváděn jako jedna z teoretických možností, nejde o kompletní výčet paragrafů příslušného plnění.

¨ předmět – identifikace předmětu zdanitelného plnění, výběr z překryvného seznamu. Počet uvedených předmětů je ovlivněn příslušným zněním zákona o DPH a verzí konkrétního přiznání k dani z přidané hodnoty.

¨ typ místa – tuzemsko/zahraničí/EU

¨ plátce DPH – příznak plátce DPH – Ano/Ne/Nerozhoduje/Neurčeno

¨ O/N – zda se dané uplatnění týká odpočtu či nápočtu

¨ typ zd.pl. – identifikace a název typu zdanitelného plnění

¨ účet – platný účet z účetní osnovy minimálně na úrovni syntetiky účtu. Analytické účty je třeba doplnit dle konkrétního účetního rozvrhu jednotlivých uživatelů.

¨ tech. sel. – identifikace technického selektoru

¨ klasif.art. – identifikace klasifikace objektu artiklu

¨ platnost od – do – datum platnosti od a datum platnosti do daného uplatnění

¨ poznámka – přesný popis uplatnění. Je zde uvedeno číslo řádku přiznání DPH, do kterého se právě toto uplatnění = konkrétní kombinace jednotlivých atributů – započte, samozřejmě v závislosti na vzorech formuláře Přiznání k dani z přidané hodnoty. Z toho vyplývá, že se jedná v podstatě o nejdůležitější informaci pro korektní zadávání daňových dokladů.

Ke každému uplatnění je zadáno kdy a za jakých podmínek se toto uplatnění bude realizovat. U každého uplatnění se navíc eviduje jeho platnost od - do a ta uplatnění, která jsou již mimo dobu platnosti, se uživateli zobrazují šedivě. Při vstupu událostí obchodu se pak na základě kombinace: typ, místo plnění a plátce či neplátce nabízí odpovídající možnosti uplatnění předmětů.

Důležitými atributy na této záložce je uvedení čísla paragrafu a v poznámce uvedení přesného popisu, do kterého řádku daňového přiznání daný paragraf vstupuje (tzn. hodnotu jakého řádku daňového přiznání ovlivňuje). Pro platné znění daňového přiznání od vzoru č. 15 a dále je nutno mít v atributu poznámka řádek uveden ve tvaru „=ř. xy“.

Čísla paragrafů uvedená v této činnosti slouží jako vodítko, nejedná se o plný a přesný výčet paragrafů z hlediska Zákona od DPH.

Obr. 20

Podrobný přehled jednotlivých nadefinovaných uplatnění a s nimi spojených předmětů, paragrafů, typů místa a příznaku plátce DPH uživateli poskytuje také předloha výstupu „Přehled uplatnění předmětů ZP“. Tuto předlohu výstupu uživatel vyvolá po aktivaci ikony „tiskárna“ v panelu nástrojů nebo po stisku klávesy Ctrl T.

8. Daňové přiznání – hlavička

Činnost Daňové přiznání – hlavička je jedna ze zásadních činností nutných pro podání daňového přiznání, a to jak elektronickou cestou, tak i pro tisk „historické“ excelovské sestavy daňového přiznání. Jedná se o soubor atributů, které musí být vyplněny. Při jejich špatném zadání pak systém při podání daň. přiznání hlásí chyby a nesrovnalosti. Tuto činnost uživatel vyplní pouze jednou a zapíše, zadané údaje zde zůstávají stále k dispozici. V případě, že dojde k určité legislativní změně a je nutno zadávat ještě další atribut, je do této činnosti programátorsky zapracován tak, aby si ho zde mohl uživatel zadat (např. pro daň v r. 2013 byl nový atribut „územní pracoviště“).

[1] Pro přesnější představu uživatele: číselník typů zdanitelného plnění je vyplněn v komponentě DPH v příslušné činnosti, avšak při běhu procesu uživatel jako první zadává např. událost obchodu a zde tento číselník rovněž automaticky využívá a pak pomocí transformací dojde k jeho předplnění i v komponentě DPH.

[2] Bez dopřesnění se svým implementátorem nedoporučujeme tyto identifikátory měnit

[3] Tzn. že souhrnné hlášení lze podle zákona od r. 2010 podat pouze elektronickým způsobem.

[4] Tímto vás prosíme o shovívavost pokud dojde k nějakým rozdílům, není v našich silách ohlídat všechny změny, které nastanou na stránkách daňové správy.

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 05.03.2015


Dokumentace mzdy (ovládání)

MZDY

1. Karta pracovníka 2

1.1 Jednotlivé záložky karty 2

1.2 Další informace k pracovnímu poměru 6

1.3 Pravidelné příjmy 6

1.4 Sady parametrů a další osobní údaje, vztahy k osobám 7

2. Zadávání výplatního lístku 8

2.1 Ruční zadávání 8

2.2 Pravidelné příjmy 9

2.3 Úkolové listy 9

2.4 Import 9

3. Zadávání nepřítomností 9

3.1 Parametry nemocenského pojištění 9

3.2 Vlastní zadávání 10

4. Výpočet výplatního lístku 11

4.1 Zablokování výpočtu (resp. odblokování uzamčení pořizování a výpočtu) 12

4.2 Minimální mzda 13

4.3 Zdravotní a sociální pojištění, doplatek 14

4.4 Algoritmy výpočtu protokolu mezd 15

4.4.1 Algoritmy 15

4.4.2 Užití algoritmu 16

5. Pomocné výpočty 16

6. Odeslání mezd do systému – události mezd 17

6.1 Nastavení 17

6.2 Provedení 17

7. Roční zúčtování daně 17

7.1 Algoritmus ročního zúčtování 18

8. Uzávěrka mezd 19

9. Definice mzdových položek 19

9.1 Příjmy a náhrady 19

10. Odvody na ZP a SP 21

11. Parametry a číselníky 21

12. Personalistika 22

13. Další funkce mezd 22

13.1 Výčetky platidel 22

13.2 Historie karty a pracovního poměru 22

13.3 Výplata záloh 23

13.4 Penzijní a životní pojištění 23

14. Návod 23

1. Karta pracovníka

Tato činnost se nachází v hlavním menu v činnosti Mzdy a personalistika – Mzdy. Po spuštění činnosti se jako první nabídne záložka výběr. Zde má uživatel na výběr z mnoha možností … může vyhledávat pracovníky podle osobního čísla, výplatního místa, podle kategorie apod. Pokud si uživatel chce přímo na prohlížení načíst všechny karty pracovníků, nebude výběrové pole vůbec zohledňovat a načte výběr prázdný.

Na kartě pracovníka má uživatel k dispozici osobní údaje o jednotlivých pracovnících (jméno, adresu, rodné číslo apod.) a údaje potřebné k evidenci mezd (pracovní poměr, srážky, půjčky, exekuce, daňová zvýhodnění apod.).

1.1 Jednotlivé záložky karty

V následujících kapitolách si podrobněji popíšeme jednotlivé záložky činnosti karta. Údaje uvedené u každého pracovníka je pak možno vidět i v činnosti Info k pracovníkovi (menu Mzdy – Mzdy).

1.1.1 Pracovníci

Tato záložka obsahuje základní informace o pracovníkovi, tzn. jeho osobní číslo, externí identifikátor (v případě potřeby je možno tento atribut využít i jako druhé osobní číslo), jméno, příjmení, adresu, která zajišťuje spojení s adresářem a zařazení pracovníka k příslušnému výplatnímu místu.

Protože každý pracovník je ve mzdách evidován pouze pod svým osobním číslem, ale pro spojení s okolním světem, např. pro účely vytvoření příkazu k úhradě v platbách, je nutné ho mít zaevidováno přímo v činnosti adresář. Proto je zde na této záložce vidět jeho osobní číslo, ale zároveň i identifikační číslo, pod kterým je zařazen v centrálním adresáři. U každého pracovníka v adresáři se evidují základní údaje (např. jeho jméno, adresa, bankovní účet apod.) Jednotlivý popis činností adresáře je uveden v helpu této činnosti.

1.1.2 Osobní údaje

Jako první jsou na této záložce k dispozici atributy, které přímo souvisí s řízením běhu výpočtu mezd. Jedná se o:

¨ zdravotní pojištění – zvolená možnost z překryvného seznamu řídí způsob výpočtu zdravotního pojištění pracovníka

¨ daňová tabulka – uvede se zde způsob, jakým bude pracovníkova mzda zdaněna. Daňová tabulka neruší povinnost správně nastavit atributy podepsal prohlášení a lze srážet (viz níže).

¨ podepsal prohlášení – tento atribut přímo řídí způsob výpočtu uplatnění zálohové daně

¨ lze srážet – tento atribut přímo řídí způsob výpočtu uplatnění srážkové daně

¨ provést roční zúčtování – pokud je zatrženo, provede se u tohoto pracovníka výpočet ročního zúčtování daně. Pokud zatrženo není, znamená to, že pracovník si přiznání daně provádí sám, mimo firmu. Podrobný popis k ročnímu zúčtování je k dispozici v kapitole 7.

Další údaje, které jsou zde k dispozici slouží částečně i jako podklad pro hlášení RELDP:

¨ rodné číslo

¨ číslo občanského průkazu

¨ rodné příjmení

¨ datum narození

¨ místo narození

¨ státní příslušnost

¨ stav – tzn. rodinný stav (možno vybrat z překryvného seznamu)

¨ počet dětí

¨ informace, zda se jedná či nejedná o pracovníka zdravotně postiženého

¨ muž/žena

¨ další příjmení – tzn. příjmení předcházející současnému příjmení

¨ v případě, že se jedná o pracujícího důchodce, tak informace o typu důchodu, od kdy ho pracovník pobírá a kolik Kč

Tyto vyplněné údaje mohou mít vliv na uživatelem nadefinované sestavy, které si vytvořil pro své interní účely, některé informace se uvádějí i na mzdovém listu.

1.1.2.1 Daňové tabulky souhrnné

Jedná se o činnosti v menu Mzdy - Definice – Daňové tabulky souhrnné. Nastavení je možno provést ručně nebo pomocí balíčku (DANOVE_TABULKY.BEX), který můžeme uživatelům dodat. Vlastní hodnoty u daňových tabulek se definují na záložce „Položky“. Jednotlivé daňové tabulky a jejich položky jsou:

Podepsal prohlášení - DPM001

Od | Do | Pevná | % | Typ daně
0 | 999999999999 | 0 | 15 | zálohová

Nepodepsal prohlášení kombinovaná - DKM001

Od | Do | Pevná | % | Typ daně
0 | 6750 | 0 | 15 | Srážková
6751 | 999999999999 | 1012 | 15 | Zálohová

Pozn.: Částka 6750 je příjem 5000 + pojistné zaměstnavatele 450+1300. Pevná částka 1012 ve druhé řádce vznikla jako 15% z částky 6750.

Pozn. : Tato tabulka je vhodná pro Dohodu o pracovní činnosti. Naopak NENÍ vhodná pro dohodu o provedení práce.

Daňová tabulka pro cizince - DNC001

Od | Do | Pevná | % | Typ daně
0 | 999999999999 | 0 | 15 | srážková

Nepodepsal prohlášení - DNM001

Od | Do | Pevná | % | Typ daně
0 | 999999999999 | 0 | 15 | zálohová

Podepsal roční - DPR001

Od | Do | Pevná | % | Typ daně
0 | 999999999999 | 0 | 15 | roční vyúčtování

Nepodepsal prohlášení kombinovaná - DKM002

Od | Do | Pevná | % | Typ daně
0 | 5000 | 0 | 15 | Srážková
5001 | 999999999999 | 750 | 15 | Zálohová

Pozn. : Tato tabulka je vhodná pro Dohodu o provedení práce. Pozn.: Pevná částka 750 ve druhé řádce vznikla jako 15% z částky 5000.

1.1.3 Volné údaje

Na této záložce je vhodné evidovat údaje o pracovníkovi, které nás zajímají a které nám neumožňují sledovat jiné záložky, např. údaje o dosaženém vzdělání, o provedených školeních apod. Jsou to uživatelsky nastavitelné údaje a pro jejich správné fungování je třeba mít nadefinovány sady parametrů a jejich strukturu (menu Obecné – Hodnoty parametrů objektu - Sady parametrů, kapitola 1.4).

1.1.4 Zdravotní pojišťovny

Tato záložka poskytuje přehled o zdravotních pojišťovnách daného pracovníka. Eviduje se:

¨ zdravotní pojišťovna – tj. kód pojišťovny a číslo pod kterým je daná pojišťovna zařazena v adresáři IS BM (toto číslo se automaticky natáhne z karty pojišťovny)

¨ číslo pojištěnce – zadává se pouze v případě, že je odlišné od rodného čísla pracovníka

¨ datum zahájení platnosti položky

¨ datum ukončení platnosti položky

1.1.5 Sociální pojišťovny

Tato záložka poskytuje přehled o sociálních pojišťovnách daného pracovníka (obdobně jako se na kartě zadává u pracovníka Zdravotní pojišťovna). Z praxe je možné, aby v organizaci pracovali lidé s různými sociálními pojišťovnami. Implicitně platí, že pokud nemá pracovník v této činnosti uvedenu žádnou sociální pojišťovnu, použije se automaticky adresa pojišťovny, která je uvedena v činnosti Parametry.

Číselník zdravotní pojišťovny byl přejmenován na zdravotní a sociální pojišťovny. Jsou zde oba druhy pojišťoven zároveň, pouze odlišeny typem. Jedná se v podstatě o číselník zdravotních a sociálních pojišťoven, ze kterého si pak uživatel podle svých potřeb vybírá. U každé pojišťovny se zadává:

¨ identifikace a typ (zdravotní/sociální)

¨ měna – kód měny – pracovníci mohou mít u sebe uvedenu i cizí sociální pojišťovnu, např. pokud je někdo zaměstnancem firmy, která sídlí v Německu. Potom je zřejmé, že platby do této pojišťovny budou uvedeny v jiné měně než CZK, kterou bude mít uvedeno většina uživatelů.

¨ odvod SP zaměstnanec (%) – procento odvodu cizí sociální pojišťovny za zaměstnance. U tuzemských pojišťoven zůstává uvedeno 0,00, protože % odvodu je uvedeno v legislativních konstantách.

¨ odvod SP organizace (%) – procento odvodu cizí sociální pojišťovny za organizaci (viz. bod výše)

¨ max. vyměřovací základ pro SP – maximální výše (tzv. strop) odvodu soc. pojištění – nutno uvést v měně sociální pojišťovny

¨ typ limitu – měsíční, roční

¨ údaje k pojišťovně – adresa, spojení, účet apod.

V souvislosti s vytvořením sociálních pojišťoven došlo k vytvoření nového atributu „způsob výpočtu sociálního pojištění“ jednotlivě nebo souhrnně (činnost Parametry, záložka Chování).

U způsobu výpočtu „jednotlivě“ dochází k těmto zaokrouhlením. Pro každou skupinu pracovníků se stejnou sociální pojišťovnou uvedenou na kartě pracovníka vznikne položka I31000 s adresátem podle sociální pojišťovny. Rozdíl součtu těchto I31000 a odvodu vypočítaného ze součtu I30000 je zapsán na adresáta podle sociální pojišťovny.

Následující možnost způsobu výpočtu „souhrnně“ se od 1.1.2008 nepoužívá (za každou sociální pojišťovnu dojde k výpočtu položky I31000 ze součtu I30000. Rozdíl součtu těchto I31000 o odvodu vypočítaného z celkového součtu I30000 se zapíše s adresátem dle činnosti Parametry).

Pro skupinu pracovníků, která nemá na kartě uvedenu žádnou sociální pojišťovnu vznikne položka I31000 s adresátem dle nastavení v činnosti Parametry. Rozdíl součtu těchto I31000 a odvodu vypočítaného ze součtu I30000 se zapíše s adresátem dle činnosti Parametry.

1.1.6 Pracovní poměry

Tato záložka je svojí důležitostí pro pracovníka klíčová. Zadává se zde seznam pracovních poměrů pracovníka u organizace. K dispozici jsou tyto atributy:

¨ číslo p.p. – číslo prac. poměru a jeho druh (na výběr z překryvného seznamu)

¨ prac. funkce – identifikace pracovní funkce (seznam pracovních funkcí by si měla každá organizace uživatelsky nadefinovat)

¨ kalendář – identifikace kalendáře, který je platný pro daného pracovníka, je nedílnou součásti pracovního poměru a ve výpočtu mezd má zásadní vliv (např. pro výpočet FPD, minimální mzdy apod.). Při vytváření nového kalendáře se definuje jeho identifikace, název a počet hodin za den. Pak je nutno každému kalendáři v číselníku vygenerovat fond pracovní doby ve dnech nebo v měsících (menu Volby) – podle nastavení atributu „typ kalendáře“ v činnosti Parametry – záložka Chování.

¨ stupnice – identifikace tarifní stupnice. V číselníku se u každé stupnice evidují i jednotlivé tarifní třídy

¨ třída – identifikace tarifní třídyvznik p.p. – datum zahájení daného pracovního poměru

¨ určující – možná volba Ano/Ne. Pokud má uživatel více pracovních poměrů, musí mít jeden určený jako určující.

¨ typ mzdy – volbou typu mzdy se v podstatě určuje způsob odměňování (měsíční, hodinová apod.). Typ mzdy byl vyvinut pro účely hlídání překročení minimální mzdy. Je nastaven na kartě pracovníka (záložka pracovní poměry) a předplňuje se podle uvedené pracovní funkce.

¨ skončení p.p. – datum ukončení pracovního poměru

¨ zkušeb. lhůta – datum ukončení zkušební lhůty pracovníka u daného prac. poměru

¨ v případě potřeby možnost zadání organizačního a technicko-věcného selektoru

¨ alias – název pracovníka v pracovním poměru

Na této záložce má uživatel pod menu Volby k dispozici další důležité atributy, které je nutno u pracovníka evidovat . Jsou dostupné v činnosti:

¨ pravidelné příjmy (funkční klávesa F5) – viz. kapitola 1.3

¨ další informace (funkční klávesa F6) – viz. kapitola 1.2

Pro snadnější zadání a zamezení opomenutí některých údajů u pracovníka je možné po zadání a uložení pracovního poměru využít možnost, kterou uživateli nabízí činnost Cyklus při vstupu nového pracovníka (menu Volby nebo funkční klávesa F7). Po aktivaci této činnosti se uživateli postupně zobrazující všechny činnosti, které je nutné v této souvislosti vyplnit.

1.1.7 Měsíční nezdanitelné položky

Údaje, které se zadávaly na této záložce byly platné do prosince 2005. Jednalo se o částky, o které je možné snížit základ daně – v současné době nahrazeno na záložce daňová zvýhodnění.

1.1.8 Roční položky

Na této záložce se evidují údaje, které jsou potřebné k provedení ročního zúčtování daně. Mzdová účetní je může vyplňovat postupně během roku. Údaje se do výpočtu zahrnou až v okamžiku, kdy je příznak „provést roční zúčtování“ nastaven na Ano (záložka osobní údaje).

V této činnosti je zároveň možno zadávat v souvislosti s ročním zúčtováním daně i údaje od předchozího zaměstnavatele (mzdové položky L30000 - Loňský příjem, L31000 - Loňský odvod, L32000 - Loňská daň a L35000 - Loňský daňový bonus).

Postup pro roční zúčtování je uveden v samostatné kapitole 7.

1.1.9 Daňová zvýh.a slevy

Tato záložka je platná od 1.1.2005 pro zadání zvýhodnění na děti a od 1.1.2006 pro zadání zvýhodnění i na ostatní položky. Důležité jsou tyto atributy:

¨ identifikace (identifikace, popis a druh daň. zvýhodnění + osoby. Daň. zvýh. může být charakteru měsíční, měsíční s bonusem, roční a roční s bonusem. U každého daň. zvýhodnění se dále uvádí částka a příznak, zda se má tisknout tato hodnota na výplatním lístku)

¨ datum signalizace – signalizuje datum do kdy je možno dané daňové zvýhodnění uplatňovat (např. odpočet na dítě nebo na studenta). Výpočet mezd pak toto datum zachytí a v případě potřeby upozorní, že uživatel by měl změnit datum platnosti.

¨ platnost od – platnost do – určení data platnosti položky. Toto datum se uplatňuje pouze v okamžiku zápisu dané položky na kartu pracovníka.

1.1.10 Půjčky, srážky, exekuce

Na záložku půjčky doporučujeme zadávat pohledávky, které mají nepřednostní fixní charakter a u kterých se splácí jedna pevná částka každý měsíc. Při uzávěrce mezd dojde o odečtení provedené splátky půjčky od zůstatku půjčky. Datum doručení soudního rozhodnutí je povinné.

Na záložku srážky doporučujeme zadávat pouze nepohledávky, např. srážku typu „vše na účet“. Datum doručení rozhodnutí je v tomto případě nepovinný.

Na záložku exekuce doporučujeme zadávat pohledávky přednostní či nepředností, s fixní měsíční splátkou či pohyblivou splátkou typu „tolik, kolik lze“. Datum doručení soudního rozhodnutí je povinný. Při uzávěrce mezd dojde k odečtení provedené splátky exekuce od zůstatku exekuce. Od zůstatku se odečte pouze taková částka, která byla skutečně sražena. Při tvorbě mzdových položek typu exekuce pečlivě volte první znak identifikace této mzdové položky. Podle identifikace se ve většině implementací třídí záznamy na výplatním lístku.

Ať už se jedná o půjčku, srážku či exekuci na záložce se u každé z nich zadávají tyto shodné údaje:

¨ identifikace – poměrně složité nadefinování, které by měl dělat pouze zkušený uživatel nebo přímo implementátor. Definuje se zde vlastní identifikace, její popis, druh, poddruh, výše Kč, způsob srážení, priorita (1-pohledávky, 2-srážky na vlastní účet, 3-pohl.výživné), způsob uplatnění exekuční pohl. a zda se položka bude či nebude tisknout na výplatním lístku.

¨ kolik Kč srážet, pořadí srážky

¨ identifikace adresáta a jeho bankovního spojení

¨ variabilní symbol

¨ datum doručení soudního rozhodnutí

¨ od data – do data

1.2 Další informace k pracovnímu poměru

Jsou k dispozici na kartě pracovníka na záložce pracovní poměr po stisku klávesy F6 nebo volbou příslušné činnosti z menu Volby. Uživateli se nabízí tyto informace o:

¨ pracovním poměru – tj. datum zahájení, účast prac. poměru na nemocenském pojištění, denní vyměřovací základ, důvod ukončení prac. poměru

¨ vztah k pojistnému na sociální zabezpečení – žádný/vše/důchod. Možnost vybrat si z překryvného seznamu je z toho důvodu, že u některých skupin pracovníků se odvádí pouze důchodové pojištění. Odvod nemocenského pojištění a odvod na politiku nezaměstnanosti se neprovádí. Implicitně je však v tomto atributu nastavena možnost „Vše“. Pokud je na konkrétní mzdové položce uvedeno, že se z ní počítá sociální pojištění, tak pak na její další chování mají vliv možnosti nastavené zde:

- žádný – odvod sociálního pojištění bude nulový

- vše – odvod sociálního pojištění se provede podle všech tří složek (důchodové pojištění, nemocenské pojištění a příspěvek na státní politiku zaměstnanosti)

- důchod – odvod sociálního pojištění se provede pouze podle důchodového pojištění

¨ vztahu k pojistnému na sociální zabezpečení – může nabývat hodnot „žádný, vše, důchod“. Implicitně je nastaven tento atribut na hodnotu „Vše“, u některých skupin pracovníků se však odvádí pouze důchodové pojištění (nikoliv nemocenské poj. a odvod na politiku nezaměstnanosti)

¨ průměrech – hodinový, denní, měsíční – tyto údaje se po provedených uzávěrkách automaticky přepočítávají. Používají se např. při výpočtu peněz za denní dovolenou a nově např. pro nemocenské dávky platné od roku 2007.

¨ dovolené – roční nárok, zůstatky, nová dovolená. Tyto údaje se po provedených uzávěrkách automaticky přepočítávají. Dovolená byla v současné době přepracována, viz. samostatný návod, nicméně „staré“ nastavení lze dále používat.

¨ volné datum a tři volná čísla – možno libovolně využít dle potřeb uživatele

1.3 Pravidelné příjmy

Jsou k dispozici na kartě pracovníka na záložce pracovní poměr po stisku klávesy F5 nebo volbou příslušné činnosti z menu Volby. Na úvod se uživateli zobrazují údaje z karty pracovníka, tzn. osobní číslo, jméno a identifikace pracovního poměru. Další údaje se již vstupují:

¨ jednoznačná identifikace mzdové položky (jak jsme se již zmínili výše, tyto příjmy a náhrady by měl definovat implementátor nebo zkušený mzdový pracovník)

¨ popis – přetáhne se současně s identifikací mzdové položky

¨ hodiny – způsob dopočtu hodin na výplatním lístku. Na výběr z překryvného seznamu jsou tyto možnosti:

- nevyplňovat – po přenosu pravidelných příjmů do výplatního lístku se atribut hodiny nevyplní. Na výplatní lístek se pak přenese přesně tolik Kč, kolik je zde vyplněno. Atribut hodiny na výplatním lístku bude 0.

- dopočíst do FPD dle hodin – hodiny na výplatním lístku se pak počítají jako hodiny FPD ve zpracovávaném měsíci mínus součet hodin mzdových položek s doplňujícím údajem („hodiny jsou součástí FPD – Ano“) mínus součet hodin nepřítomností mínus součet hodin neplaceného volna mínus součet hodin ve kterých pracovní poměr ve zpracovávaném měsíci netrval. Dny na výplatním lístku jsou pak výsledkem poměru hodin na výplatním lístku a pracovního úvazku (úvazek je součástí kalendáře pracovníka a tento je součástí pracovního poměru). Odečítané mzdové položky byly zadány do výplatního lístku ručně nebo pomocí úkolových lístků.

- součet odpracovaných dle hodin – hodiny se vypočte jako suma těch mzdových položek, které mají v doplňujících údajích zadáno „hodiny započítávat pro nárok na pohyblivou složku měsíční – Ano“. Použije se např. při pravidelné měsíční pohyblivé složce, jejíž výše je závislá na počtu odpracovaných hodin při výkonu určitých prací. Dny na výplatním lístku jsou pak výsledkem poměru hodin na výplatním lístku a pracovního úvazku (úvazek je součástí kalendáře pracovníka a tento je součástí pracovního poměru).

- dopočíst do FPD odděleně ve dnech a v hodinách – hodiny se zjistí s ohledem na FPD (stejný postup výpočtu jako u možnosti „dopočíst FPD dle hodin“). Dny se pak samostatně zjistí s ohledem na FPD (stejný postup výpočtu jako u možnosti „dopočíst FPD dle dnů“). Dny a hodiny pak tedy spolu vůbec nemusí korespondovat. Používá se hlavně v případech, kdy na výplatní lístek vstupují položky jako paragraf (nebo dovolená půl dne), které mají pak specifický způsob zápisu, např. 0dnů, 2,5 hodiny apod.

- součet odpracovaných odděleně ve dnech a v hodinách – stejný výpočet jako při možnosti „součet odpracovaných dle hodin“, ale hodiny a dny se počítají samostatně, nikoliv podle úvazku.

- dopočíst do FPD dle dnů – stejný výpočet jako při možnosti „dopočíst do FPD dle hodin“, ale výpočet se zajímá pouze o dny a hodiny se pak spočítají jako dny * úvazek.

- suma svátků – používá se pouze u organizací s denním kalendářem. Z kalendáře se do hodin a dnů na výplatním lístku vyplní součet údajů, které se vážou k typu dne svátek. Úzce souvisí s dalším nastavením položky „náhrada mzdy“ v činnosti Příjmy a náhrady. V každém případě je nutné, aby pracovník, který bude mít nastavenu tuto možnost výpočtu hodin měl v kalendáři označen jako svátky pouze dny, které jsou jeho pracovními (tzn. např. pracovník v turnusech bude mít prac. týden út – so a např. na pátek připadá svátek, pak je nutné, aby út až so byly označeny jako pracovní dni). Používá se pouze u denních kalendářů, jestliže bude mít pracovník měsíční kalendář, pak se zapíše do protokolu chybové hlášení PRAVI6 a dny a hodiny položky zůstanou nulové.

¨ Kč/j – množství Kč za jednotku

¨ indiv. koef. – umožňuje nadefinovat konkrétní koeficient pro konkrétního pracovníka u dané položky mzdy (např. chci pracovníkovi dlouhodobě nastavit prémie 50%. Potom je zde v tomto koeficientu nastaveno 0,5 a platí to právě na konkrétní položku mzdy a konkrétního pracovníka). V případě, že je uveden tento individuální koeficient, má při výpočtu mzdových položek přednost před atributem „koeficient“ v dolní části formuláře.

¨ od data – do data – datum zahájení a datum ukončení platnosti položky

¨ koeficient, výpočet Kč a dopl. údaj jsou informace, které se sem jako informace automaticky natáhnou při zadání identifikace mzdové položky

1.4 Sady parametrů a další osobní údaje, vztahy k osobám

Sady parametrů slouží především pro účely personalistiky. Evidují se zde volné údaje definované podle vlastních potřeb každé organizace. Jak je zmíněno již výše, nachází se pod menu Obecné – Hodnoty parametrů objektu – Sady parametrů. Nadefinovat jednotlivé sady je uživatelsky náročnější, takže by to měl provádět buď zkušený uživatel a nebo implementátor.

V případě potřeby je možno u každého pracovníka evidovat další osobní údaje (o dětech, o studiu, školeních apod.). Tato činnost je dostupná v menu Volby. K dispozici jsou čtyři volné texty, volné datum a volné číslo. U každého osobního údaje je navíc možno nastavit jeho platnost od – do.

1.4.1 Vztahy k osobám

Každý pracovník, který má nadefinovaná daňová zvýhodnění musí mít v této souvislosti nastaveny i vztahy k osobám. Tato činnost je dostupná z menu Volby. Uživatel na první záložce „vztahy pracovníků k osobám“ definuje:

¨ číslo a jméno pracovníka

¨ osoba – identifikace osoby, které se vztah týká

¨ rodné číslo osoby

¨ vztah mezi pracovníkem a osobou – výběr z překryvného seznamu (např. manžel, manželka, dítě, sourozenec, příbuzný apod.)

Význam jednotlivých nadefinovaných vztahů se definuje na další záložce „významy vztahu“. Význam může nabývat hodnot daňové zvýhodnění a vyživovaná osoba. Pro příklad: pokud má pracovník uvedeno dítě v daňových zvýhodněních, musí zde mít ve vztazích nastaven vztah dítě s významem daňové zvýhodnění. Pokud firma zároveň provádí exekuce, musí mít pracovník ve vztazích nastaven vztah dítě s významem vyživovaná osoba. Tzn. že v praxi je to pak tak, že je uveden jeden vztah dítě s dvěma významy.

1.4.2 Menu Volby v činnosti Karta pracovníka

Stručný popis důležitých činností, které jsou pro uživatele dostupné v menu Volby z činnosti Karta pracovníka. Některé činnosti se uživateli zpřístupní pouze pokud je aktivní záložka Pracovní poměry:

¨ pravidelné příjmy – F5 – popis v kapitole 1.3

¨ další informace – F6 – jsou nedílnou součástí informací o pracovním poměru, mají vliv na výpočet mzdy

¨ cyklus při vstupu nového pracovníka – F7 – automaticky se jedna po druhé spouští činnosti, které by měly být zadány při zařazení nového pracovníka

¨ volné údaje pracovníků – F9 – souvisí se záložkou volné údaje na Kartě pracovníka. Jsou to uživatelem definované údaje, které chce o pracovníkovi sledovat (např. dosažené vzdělání, řidičský průkaz, školení apod.)

¨ Ctrl D – dokumenty – možnost spojit kartu pracovníka např. s pracovní smlouvou (viz. samostatný popis v helpu „spojené dokumenty“)

¨ charakter pracovníka v p. p. – souvisí s událostmi mezd a s činností druhy událostí. Slouží k výstupu mezd do okolního systému, např. do plateb (příkazy k úhradě) nebo do účetnictví

¨ další informace – dílčí – kvůli přístupovým právům (vytvořeno speciálně na žádost společnosti Moeller)

¨ další informace karty – atributy v této činnosti vznikly na základě mzdové reformy r. 2008. Organizacím s touto reformou vzniká povinnost sledovat u každého pracovníka výši maximální vyměřovacího základu na zdravotní a sociální pojištění a výši limitu penzijního a životního připojištění. Hodnoty, kterých tyto atributy mohou podle zákona dosahovat jsou uvedeny v legislativních konstantách. V případě, že uživatel má na kartě uvedenu cizí sociální pojišťovnu, je zde odvedená částka napočítávána v měně uvedené u cizí pojišťovny. Po každé provedené uzávěrce mezd se do těchto atributů přenesou částky těchto atributů z daného měsíce. V případě, že by např. během listopadové výplaty systém zjistil, že maximální hodnoty těchto atributů jsou již překročeny, bude toto hlášení (překročení limitu) zapsáno do protokolu výpočtu mezd.

¨ evidenční list důchodového pojištění – státní výkaz – vytvořen na základě legislativy (od ing. Filipa samostatný návod + help)

¨ informace o pracovníkovi – rychlá vazba na údaje o mzdě daného pracovníka

¨ nastavení zkušební doby – atribut „zkušební doby“ se opět nastaví v souladu s údaji uvedenými v Parametrech (samostatný návod)

¨ obecné parametry – úzce souvisí s volnými údaji pracovníka (samostatný návod)

¨ osobní údaje – používají jen organizace, které nevyužívají volné údaje

¨ pracovníci v kategoriích – vytvořeno pro účely RELDP a registru pojištěnců

¨ přehled volných údajů pracovníků – souvisí s činností volné údaje pracovníků

¨ registr pojištěnců – viz. evidenční listy, státní výkaz

¨ sady parametrů – popis v kapitole 1.4

¨ vztahy k osobám – popis v kapitole 1.4.1

¨ ZP – hromadné oznámení zaměstnavatele – souvisí s evidenčními listy, státní výkaz

2. Zadávání výplatního lístku

Zadávání výplatního lístku je možno provádět těmito způsoby:

¨ jednotlivě zadávat každý výplatní lístek pro každého pracovníka (Mzdy a personalistika – Mzdy – Výplatní lístek)

¨ hromadně zadávat pracovníky najednou (Mzdy a personalistika – Mzdy – Všechny výpl. lístky – zadávání)

¨ pomocí procesního zadávání úkolových lístků

2.1 Ruční zadávání

Uživatel si aktivuje činnost Výplatní lístek, vybere si ve výběru pracovníka, pracovní poměr a období, za které chce zadávat mzdy. Pak pomocí klávesy F3 nebo příslušné ikony vkládá jednotlivé řádky výplatního lístku. U každého řádku se definuje:

¨ mzdová položka

¨ kombinace odměňování za mzdovou položku – období od-do, počet dnů nebo hodiny

¨ na základě definice mzdové položky se předplní způsob výpočtu

¨ v penězích – pokud je zaškrtnuto, bude tato částka vyplacena hotově (nevyplácet se zaškrtává např. u peněžního daru)

¨ tisknout – pokud je zaškrtnuto, objevuje se tato položka na výplatním lístku, pokud zaškrtnuto není, netiskne se (např. u pojistného hrazeného zaměstnavatelem)

2.2 Pravidelné příjmy

Jedná se o příjmy, které se pak při výpočtu mezd automaticky doplní na výplatní lístek. Tyto pravidelné příjmy uživatel zadává na kartě pracovníka, na záložce „pracovní poměr“ po stisku klávesy F5 nebo po volbě příslušné činnosti z menu Volby. U těchto pravidelných příjmů se při výpočtu mezd kontroluje zároveň jejich platnost (tzn. pravidelné příjmy s jiným obdobím platnosti než je aktuální datum se na výplatní lístek nenačtou).

2.3 Úkolové listy

Jedná se o specifické použití výpočtu výplatního lístku. Je řešeno procesním způsobem, tzn. že na zadávání jednotlivých úkolových lístků (zřejmě pak zadávají mistři nebo vedoucí pracovníci) musí být v systému nadefinován vlastní druh procesu a při jejich zadávání se používají speciální typy mzdových položek.

Na zadávání úkolových lístků je vytvořen speciální druh procesu (Nový proces – procesy mezd – úkolové listy), kde se po jeho spuštění aktivuje formulář ve Foxpro (nadefinovaný přesně podle specifických požadavků společnosti Moeller) a po jeho vyplnění se tyto údaje zobrazují v této činnosti, tzn. že tato činnost v podstatě slouží pouze k prohlížení procesně zadaných úkolových listů.

2.4 Import

Údaje na výplatní lístky je možno natáhnout i pomocí naimportovaných dat. V takovém případě samozřejmě musí být nadefinován příslušný import, který údaje do mezd natahuje z externího zdroje dat (např. srážky za stravenky apod.).

3. Zadávání nepřítomností

Nepřítomností rozumíme evidenci nepřítomnosti na pracovišti z důvodu nemoci, ošetřování člena rodiny, ošetřování osamělou osobou, mateřské dovolené, rodičovské dovolené nebo jiné nemoci. Nepřítomnost v sobě eviduje nejméně jednu nemocenskou dávku. Podle legislativy platné pro r. 2009 se prvních 14 dní nemoci eviduje jako „náhrada mzdy“ a její výše je zaměstnanci vyplácena zaměstnavatelem, nemoc pokračující i po 14 dnech se eviduje jako nemocenská dávka a je vyplácena správou sociálního zabezpečení.

Do výpočtu výplatních lístků vstupují údaje z činnosti „nepřítomnost pro nemoc“. Při uzávěrce mezd se aktualizuje atribut „kalendářních dnů pracovní neschopnosti“ a atribut „proplaceno dne“. Uzávěrka zasahuje rovněž do historie pracovních poměrů.

Pracovní poměr musí zakládat účast na nemocenském pojištění. Jednotlivé nepřítomnosti u pracovníka a jeho pracovního poměru se nesmějí překrývat. Dávku nelze vyplácet déle než trvala nemoc a jedním záznamem lze vyplácet pouze dávky v rámci jednoho měsíce. Systém umožňuje zadat nepřítomnost i do minulosti, tuto variantu by však uživatel měl používat pouze v krajní nouzi (viz. kapitola 3.2.2).

3.1 Parametry nemocenského pojištění

Tyto parametry má uživatel k dispozici v menu Mzdy – Parametry – Parametry nemocenského pojištění. Slouží ke vstupu parametrů potřebných pro výpočet dávek nemocenského pojištění. Definice těchto parametrů je daná současnými zákony, tzn. hodnoty zde uvedené si uživatel nevymýšlí. Pokud by měl uživatel pocit, že nadefinovat si tyto parametry je tzv. „nad jeho síly“, svěří tuto činnost do rukou svému implementátorovi. Jsou to tyto parametry:

¨ algoritmus stanovení nem. dávky

¨ denní vyměřovací základ

¨ platnost algoritmu v období

V činnosti Parametry jsou k dispozici další dva atributy, které souvisí s výpočtem nemocenského pojištění. Na záložce „chování“ je to příznak zaškrtnutí, zda se jedná o velkou či malou organizaci a příznak plus nebo mínus u způsobu výpočtu nepřítomnosti pro nemoc (viz. popis dále).

Nastavení položek Mzdy – Parametry – Parametry nemocenského pojištění je v souladu s legislativou. Vzhledem ke složitosti dané problematiky posíláme uživatelům vždy balíček s nastavením těchto parametrů. V případě potřeby jejich úpravu provádí zkušený implementátor (navíc k této problematice je vytvořen samostatný návod).

3.2 Vlastní zadávání

Při zadávání nepřítomností platí několik následujících pravidel:

¨ před zahájením vkládání nepřítomností daného měsíce je nutno mít provedenu uzávěrku za předchozí měsíc, jinak nebudou aktuální denní vyměřovací základy, které systém automaticky nabízí

¨ pokud pracovní neschopnost vznikla ve stejném měsíce jako pracovní poměr pracovníka, systém na tuto skutečnost upozorní

¨ je-li nemoc zadávána zpětně, tzn. do minulosti, předplní se denní vyměřovací základ z historie pracovních poměrů

¨ nemocenská dávka se vypočítá podle tabulek uvedených v parametrech

3.2.1 Běžné zadání

Činnost „nepřítomnost pro nemoc“ (v hlavním menu mzdy a personalistika – mzdy) umožňuje zadávání, prohlížení a údržbu přehledu nepřítomností. Evidují se zde nepřítomnosti pracovníků na pracovišti z důvodu nemoci, ošetřování člena rodiny, mateřské dovolené nebo jiné nepřítomnosti. Při zadávání nepřítomnosti vstupuje uživatel tyto základní údaje:

¨ osobní číslo, na základě jehož se předplní i jméno pracovníka

¨ číslo jeho pracovního poměru

¨ důvod nepřítomnosti (nemoc, ošetřování, vyrovnávací příspěvek, mateřská dovolená, jiná nepřítomnost, rodičovská dovolená, ošetřování osamělou osobou apod.) – výběr z překryvného seznamu. I při zadávání důvodu „ošetřování osamělou osobou“ vytvoří výpočet výplatních lístků mzdové položky jako u běžného ošetřování (N20000 a N21000). Zadáním údajů v této činnosti typu „nemoc“ od r. 2009 automaticky vznikne na výplatním lístku mzdová položka náhrada mzdy (její definice se zadává v parametrech nemocenských dávek).

¨ typ nemoci – zadává se pouze pokud je důvod nepřítomnosti nemoc (pak je nutno určit zda se jedná o „Karanténu“ či nikoliv z důvodu, že u Karantény se proplácejí i první tři dny nemoci).

¨ od – do – datum od kdy do kdy je pracovník nepřítomen (systém pak automaticky spočítá kolik je to kalendářních dnů a automaticky rozdělí dávku na „náhradu mzdy“ a „nemocenskou dávku“, tj. pokračování nemoci i po 14 dnech nepřítomnosti)

¨ základ – systém předplní hodnotu denního vyměřovacího základu. Základ se předplňuje podle údajů uvedených na kartě pracovníka. Uživatel pak při zadávání rozhoduje, zda předplněný základ odpovídá skutečnosti, tj. zda byly ve výplatním lístku zohledněny všechny skutečnosti, které jsou zásadní pro výpočet základu. Pokud předplněný základ neodpovídá skutečnosti, uživatel buď opustí zadávání nemocenské dávky a nebo ručně opraví výši základu

¨ krátit o % - o uvedené % se krátí základ nemocenské dávky (např. z důvodu porušení léčebného režimu pacienta)

Ve většině případů není žádoucí, aby byla nepřítomnost zadána tak, že se na jednom pracovním poměru u jednoho pracovníka nemoci překrývají. Může však nastat situace, že uživatel bude potřebovat takovýto překryv přesto zadat. Po zadání nepřítomnosti pro nemoc s datem, který se překrývá s datem již jiné zadané nepřítomnosti systém hlásí:

"Zadaná nepřítomnost se překrývá s jinou !!!! Skutečně chcete zapsat údaje PŘES jinou nepřítomnost ?“ Volba Ano/Ne.

Pokud uživatel odpoví Ano, systém dovolí zapsat záznam nepřítomnosti, který se překrývá s jinou již dříve zapsanou nepřítomností. Pokud uživatel odpoví Ne, pak systém záznam nedovolí zapsat dokud ho uživatel neopraví na datum, které se s jinou nepřítomností nepřekrývá. Implicitně je nastavena odpověď Ne.

Na druhé záložce „dávky“ se uvádějí konkrétní nemocenské dávky, které jsou v případě prvních 14 kalendářních dnů nemoci vypláceny organizací a v každém případě se evidují co do počtu pracovních dnů a následného hlášení nepřítomnosti správě sociálního zabezpečení. Výpočet bere v úvahu nastavení údajů v parametrech nemocenských dávek. Při uzávěrce mezd se aktualizuje atribut „kalendářních dnů pracovní neschopnosti“ a atribut „proplaceno dne“. K dispozici jsou tyto údaje:

¨ datum, kdy se poskytuje nemocenská dávka (od – do se předplní automaticky podle zadané nepřítomnosti na předchozí záložce)

¨ dnů kalendářních, dnů pracovních – rovněž se předplňuje automaticky, uživatel tyto údaje může podle potřeby opravit, např. když pracovník byl nemocen jiný počet dnů, ale k tomu ještě i několik hodin. Po takové ruční opravě těchto údajů je vhodné zaškrtnout atribut nepřepočítávat, tzn. aby systém opět údaje neopravil podle zadaných hodnot, ale ponechal hodnoty, které zadal uživatel.

¨ výše nemocenské dávky – doplní se automaticky. Pokud ji chce uživatel z nějakého důvodu upravit, změní ji a zaškrtne příznak nepřepočítávat, aby tuto dávku systém znovu automaticky nepřepsal

¨ nepřepoč. – lze použít v případě, že systém automaticky předplní určitou výši dávky, ale uživatel chce mít tuto hodnotu jinou, pak si ji opraví a zatrhne nepřepočítávat, aby mu ji systém při dalším výpočtu mezd znovu neopravil

¨ krátit o % - o uvedené % se krátí základ nemocenské dávky (např. z důvodu porušení léčebného režimu pacienta)

¨ do výpočtu v – období, ve kterém bude dávka zahrnuta do výpočtu. U většiny dávek zůstane tento atribut prázdný, zadává se pouze v případě, že chceme nemocenskou dávku zadat zpětně, tj. do měsíce, který již byl uzavřen

¨ proplatit v nejbližším výplatním termínu (ano/ne)

¨ proplaceno dne – doplní se sem pak automaticky datum, kdy byla dávka proplacena (po měsíční uzávěrce)

Na záložce dávky je možné klávesou F6 nebo aktivací příslušné činnosti z menu Volby spustit činnost „Složení dávky“. Jedná se o podrobný přehled složení dávky za kalendářní měsíc, tzn. částí, ze kterých při výpočtu vznikala. Tento přehled o podrobném složení nemocenské dávky vzniká postupně během jejího výpočtu.

3.2.2 Zadání nepřítomnosti do minulosti

Jako první u této činnosti je nutno napsat upozornění, že se rozhodně nejedná o triviální činnost a zápis nemocenských dávek do minulosti je nutno používat s rozmyslem.

U nemocenské dávky zadávané do minulosti se vyplní všechny atributy stejně jako u běžné dávky, s tím rozdílem, že na záložce „dávky“ se pak správně vyplní datum „do výpočtu v“. Uvedeme si tyto údaje na zkušebním příkladu. Máme aktuální měsíc březen, leden a únor již jsou uzavřeny a přesto chceme zadat zpětně dávku, která se týká právě měsíce ledna. Pak dávku zadám jako běžnou lednovou a do výpočtu uvedu datum např. 1.3. nebo 31.3. Po spuštění optimalizovaného výpočtu pak v systému dojde k těmto akcím:

¨ v měsíci lednu, kam dávka logicky patří, vznikne nová položka nemocenské dávky

¨ do protokolu bude zapsáno, že je nutné danému pracovníkovi přepočítat průměry na nemocenskou, aby měl správné průměry u nemocí vzniklých v měsíci únoru a březnu

4. Výpočet výplatního lístku

Výpočet výplatních lístků se provede pomocí činnosti „optimalizovaný výpočet mezd“ (menu Mzdy – Mzdy). Uživatel pak může zvolit konkrétní číslo pracovníka (napíše přímo jeho osobní číslo), skupinu pracovníků (napíše např. číslo jedna a systém pak vybere skupinu pracovníků, jejichž osobní číslo začíná na číslo 1) nebo všechny pracovníky (ponechá znak %).

Důležité momenty pro správné zpracování:

¨ nastavení parametrů

¨ definice mzdových položek

¨ zadání nepřítomností pro nemoc

¨ vytvořený kalendář pracovních dob

¨ správně zadané údaje na kartě pracovníka (tzn. nastavení zaškrtávátek a definičně přesné nastavení pravidelných příjmů)

Výpočet výplatních lístků jednotlivých pracovníků je možné provést ve zpracovávaném měsíci opakovaně. Výpočet provádí též řadu kontrol, jejichž výsledky jsou generovány do Protokolu. Záznamy vzniklé výpočtem výplatních lístků jsou podkladem pro komponentu MZD.

Pokud má pracovník v organizaci současně několik pracovních poměrů, systém mu připraví za každý pracovní poměr výplatní lístek s položkami příjmů, sociálního a zdravotního pojištění, základu daně a nemocenských dávek.

Na výplatním lístku z pracovního poměru označeného jako „určující“ systém navíc uplatní nezdanitelné položky, daňová zvýhodnění, vypočítá daň za všechny příjmy, vypočítá čistý příjem, srážky a částku k výplatě.

Pokud má pracovník víc výplatních lístků a nemá ani jeden pracovní poměr s příznakem „určující“ nebo jich má víc, pak systém vybere za hlavní výplatní lístek kterýkoliv z vypočítaných a do „protokolu“ zapíše hlášku „pracovník nemá žádný pracovní poměr označen jako určující. Bude vybrán pracovní poměr, který je první v pořadí“.

Činnost pro každého pracovníka a jeho pracovní poměr postupně provede :

¨ přenos pravidelných příjmů z karty pracovníka

¨ kontrolu evidované doby

¨ výpočet hrubých příjmů

¨ výpočet sociálního pojištění hrazeného zaměstnancem -

je-li v parametrech mezd nastaven způsob výpočtu sociálního pojištění za organizaci „jednotlivě“, provede se výpočet sociálního pojištění hrazeného organizací - za jednoho zaměstnance (je-li nastaven souhrnně, systém nahlásí chybu)

¨ výpočet zdravotního pojištění hrazeného zaměstnancem a hrazeného organizací

¨ přenos nemocenských dávek z nepřítomnosti pro nemoc

Dále pro každého pracovníka a jeho pracovní poměr s příznakem určující = Ano systém provede :

¨ výpočet měsíční daně ze všech pracovních poměrů pracovníka

¨ výpočet čistého příjmu ze všech pracovních poměrů pracovníka

¨ výpočet srážek

¨ výpočet půjček

¨ výpočet k výplatě

Při optimalizovaném výpočtu všech mezd se vypočtou mzdy všech pracovníků a všechny odvody za organizaci. Poté může nastat situace, kdy se určité údaje u jednotlivých pracovníků změní, pak uživatel spustí optimalizovaný výpočet mezd pouze daného pracovníka. Odvody se ovšem v tento okamžik nepřepočítají, tzn. že před finalizací mezd je nutno znovu ještě jednou spustit optimalizovaný výpočet všech, aby se znovu správně přepočítaly odvody za organizaci.

4.1 Zablokování výpočtu (resp. odblokování uzamčení pořizování a výpočtu)

Prvotním cílem této činnosti je zamezit opravám hrubých mezd, pokud již byly vypočteny čisté mzdy. Možnost tohoto zablokování zároveň zasahuje do činností parametry, optimalizovaný výpočet mezd, výplatní lístky a výplatní lístky – zadávání.

Doporučené kroky při zadávání mezd jsou:

¨ kompletní zadání hrubých mezd

¨ spuštění optimalizovaného výpočtu všech pracovníků. Tím dojde k zamknutí (zablokování) pořizování hrubých mezd a spuštění výpočtu.

¨ v případě potřeby návratu k hrubým mzdám je možno je odemknout činností „odblokování uzamčení pořizování a výpočtu“ (menu Mzdy – Mzdy)

¨ pak provést potřebné úpravy v hrubých mzdách

¨ opět spustit výpočet mezd a tím zároveň opět dojde k jeho zablokování

Projevující se vliv této činnosti v ostatních činnostech mezd:

¨ parametry – v činnosti je parametr „uzamčení“, který obsahuje datum, ke kterému jsou opravy a výpočet mezd uzamčeny. Je-li datum vyplněné, pak jsou výplatní lístky a jejich výpočet právě k tomuto datu zablokovány (uzamčeny). Je-li datum prázdné, pak jsou výplatní lístky a jejich výpočet odblokovány a přístupny k potřebným opravám.

¨ výplatní lístky, výplatní lístky – zadávání – možnost vkládání, opravy a rušení záznamů na výplatních lístcích závisí právě na výše uvedeném parametru „uzamčení“. Zároveň je nutno zdůraznit, že vkládání, oprava a rušení záznamů závisí rovněž na datu poslední uzávěrky.

¨ optimalizovaný výpočet mezd – spuštění této činnosti je přímo závislé na parametru „uzamčení“. Je-li datum uzamčení nastaveno na měsíc, který je právě zpracováván, nelze pak tuto činnost spustit a je nutné datum uzamčení odblokovat. Pokud dojde ke spuštění optimalizovaného výpočtu a je prováděn výpočet za VŠECHNY pracovníky, kód výpočtu automaticky nastaví parametr uzamčení a tím dojde k zablokování oprav a opětovného výpočtu. Pokud dojde ke spuštění optimalizovaného výpočtu a je prováděn pouze pro jednoho pracovníka nebo skupinu pracovníků, kód výpočtu parametr uzamčení nenastavuje a nedojde k žádnému zablokování.

¨ odblokování uzamčení pořizování a výpočtu – tato činnost umožňuje uživateli odblokovat parametr uzamčení. Po spuštění odblokování je pak parametr uzamčení nastaven na prázdné datum. Odblokování uzamčení je rovněž možno provést smazáním data uzamčení v činnosti parametry.

4.2 Minimální mzda

Při optimalizovaném výpočtu mezd je zobrazena tabulka s pracovníky, systém vznese dotaz „Hrubý příjem je menší než min. mzda. Doplnit položku pro vyrovnání do výše minimální mzdy? Pokud ano, doplní se položka, pokud ne, ponechá se vypočtený hrubý příjem.„ a výpočet se pak dokončí podle odpovědi na dotaz.

Testuje se měsíční min. mzda nebo hodinová min. mzda podle toho, jakým způsobem je pracovník odměňován (příslušný atribut na záložce pracovního poměru a rovněž na pracovní funkci). Pracovní funkce má u sebe informaci o tom, jak je pracovník odměňován (měsíčně nebo hodinově). Tento atribut slouží k předplnění atributu na záložce pracovní poměry – zadá se tam pracovní funkce a způsob odměňování se předplní (jako i atributy kalendář, stupnice, třída, …). Do mzdy se pro tyto účely nezahrnuje mzda za práci přesčas, příplatek za práci ve ztíženém a zdraví škodlivém pracovním prostředí, za práci v noci a za práci ve svátek.

Kalendáře fondu pracovní doby zůstávají beze změn. Hodinová mzda se upraví podle údajů v kalendáři uvedeném u pracovního místa. U měsíční mzdy dochází ke krácení minimální mzdy ve vztahu k odpracované době. Ke každému pracovníkovi se stanoví procento krácení hodinové min. mzdy. Při výpočtu minimální mzdy se pracuje s mzdovými položkami, které mají zaškrtnuto „mzda pro účely srovnání s minimální mzdou“ a „odpracované hodiny pro účely srovnání s minimální mzdou“. Minimální mzda se vztahuje jen na některé zaměstnance, je to v závislosti na druhu pracovního poměru (např. na druh pracovního poměru dohoda se nevztahuje).

Algoritmus výpočtu min. mzdy je následující, systém zjistí:

¨ součet peněz u mzdových položek, které mají zaškrtnuto „částku zahrnout pro srovnání s min. mzdou“

¨ součet odpracovaných hodin u mzdových položek, které mají zaškrtnuto „hodiny zahrnout pro srovnání s min. mzdou“

¨ zda má pracovník hodinovou nebo měsíční mzdu

¨ věk a invaliditu zaměstnance a jeho hodinovou či měsíční mzdu krátí na několik procent

¨ dochází k úpravě hodinové minimální mzdy (nastaveno podle parametrů plánovacího kalendáře): - pracuje-li prac. v 8h prac. době, je ponechána sazba 42,50 Kč (sazba platná pro r. 2005) - pracuje-li prac. méně než 8h denně, je přepočítáno podle vzorce sazba=42,50 * (40/skut.hodiny*5). Sazba pak vyjde vyšší než 42,50

- pracuje-li více než 8h, je ponechána sazba 42,50

4.3 Zdravotní a sociální pojištění, doplatek

Při běhu optimalizovaného výpočtu mezd je nutné několikrát uživatelsky rozhodnout o dalším postupu výpočtu mzdy u konkrétního pracovníka, např.:

¨ rozhodnout o doplatku mzdy do výše minimální mzdy

¨ rozhodnout o způsobu výpočtu zdravotního pojištění ze mzdy, která je menší než vyměřovací základ zdravotního pojištění

¨ rozhodnout o způsobu odvedení sociální pojištění ze mzdy, která je příliš malá

Tyto jednotlivé dotazy se sdružují do jedné tabulky (legislativní konstanty), která je zobrazena uprostřed běhu výpočtu a pomocí níž bude na dotazy odpovězeno.

Jednotlivé dotazy, které jsou pak při běhu výpočtu systémem pokládány jsou nadefinovány v činnosti „dotazy při běhu výpočtu“ (menu Mzdy – Definice). Tato činnost zachycuje přehled typů dotazů. Udává se identifikace dotazu, popis, priorita a komentář. Text uvedený v položce popis je právě ten text, který se uživateli zobrazí v dotazovací tabulce při běhu výpočtu. Text by tedy měl být dostatečně jasný a srozumitelný, aby uživatel podle toho měl možnost správně rozhodnout o dalším postupu výpočtu. Priorita umožňuje třídění údajů v dotazovací tabulce.

K této činnosti by měl mít přístup pouze pověřený pracovník (např. implementátor nebo správce).

Dotazovací tabulka se při běhu optimalizovaného výpočtu mezd zobrazí pouze jednou. Obsahuje souhrn pracovníků, kteří spadají do sféry jednoho nebo několika definovaných dotazů. Údaje v ní je možno třídit rovněž podle priority. Na každý z uvedených záznamů je nutno odpovědět. Poté se opět rozeběhne výpočet mezd a pracovníci, ke kterým byl položen dotaz se dopočtou podle rozhodnutí uživatele. V případě, že žádný pracovník není zachycen do sítě předdefinovaných dotazů, tabulka se během výpočtu vůbec nezobrazí.

V případě, že uživatel zvolí doplatit do výše minimální mzdy, tak není nutné dávat odvod na zdravotní pojištění za předpokladu, že typ mzdy, který je nastaven jako doplatek do min. mzdy má u sebe nastaven, že je součástí základu na zdravotní pojištění.

4.3.1 Legislativní konstanty

Tato činnost poskytuje uživateli přehled jednotlivých hodnot systémových konstant. Definice systémových konstant se provádí v činnosti „sady systémových konstant “. Tato činnost poskytuje uživateli už pouze výsledné hodnoty konstant.

Činnost „ legislativní konstanty “ (menu Mzdy – Definice) obsahuje konstanty (údaje), které jsou limitující pro rozhodnutí o položení některého z dotazů při běhu činnosti optimalizovaný výpočet mezd . Tyto legislativní konstanty dostává 1x ročně uživatel od svého implementátora ve formě balíčku dat. Jsou to:

¨ výše minimální mzdy měsíční

¨ výše minimální mzdy hodinové

¨ limit placení sociálního pojištění

¨ plánovací kalendář se základní pracovní dobou

Kromě těchto údajů obsahuje tabulka legislativních konstant i údaje, které se týkají hodnot, které byly dříve uvedeny v parametrech . V současné době jsou do tabulky legislativních konstant přesunuty všechny parametry, jejichž hodnota se dá vyjádřit číslem.

Konstanta | Identifikace | Hodnota | Poznámka | Změny od 1.1.2009
Odvod SP zaměstnanec | mz27spzam | 8 |  | 0
Odvod SP organizace | mz27sporg | 26 |  | 0
Limit soc. poj. | mz27limsp | 400 |  | 2000
Sazba zdrav. poj. | mz27zpsazb | 13,5 |  |
Vym. základ ZP | mz27zpstat | 0 |  |
Min. mzda měsíční | mz27zpnepl | 8000 |  |
Min. mzda hodinová | mz27minhod | 48,10 |  |
Sazba (promile) | mz27zakpoj | 2 | Zákonné pojištění odpovědnosti |
Procento min. mzdy při invalidním důchodu | mz27inval | 50 | Práce s minimální mzdou |
Procento min. mzdy při část. invalidním důchodu | mz27cinval | 75 | Práce s minimální mzdou |
Limit odprac. dnů (průměrný výdělek) | mz27dnuodp | 21 |  |
Dolní limit vyplacení měs. daň. bonusu | mz27dzbol1 | 50 |  |
Horní limit vyplacení měs. daň. bonusu | mz27dzbol2 | 4350 |  |
Limit penz. a život. poji. | mz27penzli | 24000 |  |
Max. vym. základ pro SP | mz27vymz |  |  | 1 130 640
Limit hodin pro DPP | mz27limdpp | 150 | Dohoda o provedení práce |

V souvislosti se změnami v evidenci nemocenských dávek pro rok 2009 došlo k několika změnám ve stávajících konstantách (viz. tabulka) a zároveň byly zavedeny nové legislativní konstanty:

¨ trvání náhrady mzdy (kal.) - identifikace mz27nahrde - hodnota 14

¨ odvod důchodového pojištění zam. - identifikace mz27duczam - hodnota 6,5%

¨ odvod nemocenského pojištění zam. - identifikace mz27nemzam - hodnota 0%

¨ odvod na politiku nezaměstnanosti zam. - identifikace mz27stpzam - hodnota 0%

¨ odvod důchodového pojištění org. - identifikace mz27ducorg - hodnota 21,5%

¨ odvod nemocenského pojištění org. - identifikace mz27nemorg - hodnota 2,3%

¨ odvod na politiku nezaměstnanosti org. - identifikace mz27stporg - hodnota 1,2%

Vysvětlení:

Konstanta „trvání náhrady mzdy (kal.)“ byla zavedena pro účely náhrady mzdy. Náhrada mzdy se nyní poskytuje po dobu 14 kalendářních dnů podle pravidel, která jsou uvedena v činnosti „Parametry nemocenských dávek“. V r. 2009 je nutno zvlášť vyčíslovat „odvod na důchodové pojištění“, a proto se původní konstanty (odvod SP zaměstnanec a odvod SP organizace) rozdělily každá na tři samostatné, tzn. odvod důchodového pojištění, odvod nemocenského pojištění a odvod na politiku nezaměstnanosti (každá z těchto konstant je za zaměstnance a organizaci).

Poznámka ke konstantě „Limit hodin pro DPP“:

¨ Pokud konstanta nebude ve verzi definována, výpočet to nahlásí, ale bude pokračovat. Test dosažení limitu hodin pro DPP nebude proveden.

¨ Pokud konstanta bude definována, ale její hodnota nebude zadána, pak výpočet nebude pokračovat.

¨ Pokud konstanta bude definována i zadána, bude proveden test dosažení limitu hodin pro DPP.

Definici legislativních konstant lze využít např. i při stanovení výměry na dovolenou. V souvislosti s novými legislativními změnami mohou přibývat automaticky i další legislativní konstanty.

4.4 Algoritmy výpočtu protokolu mezd

Pro uživatele je tato činnost dostupná v menu Mzdy – Definice. Přímo souvisí s optimalizovaným výpočtem mezd. Při tomto výpočtu se vytváří „protokol“, který obsahuje hlášení o nalezených chybách nebo jiných informacích, které byly zjištěny během výpočtu. Tuto činnost je možno (a doporučeno jako vhodné) nastavit pomocí balíčku dat. I v případě, že uživatel nebude mít tuto činnosti nastavenu, proběhne výpočet mezd správně.

Činnost obsahuje dvě záložky:

¨ záložka Algoritmy

¨ záložka Užití algoritmu

4.4.1 Algoritmy

Na této záložce má uživatel k dispozici následující údaje:

¨ identifikaci a popis hlášení

¨ druh (např. systémový)

¨ typ (volba Zabudovaný, Skript před výpočtem, Skript po výpočtu)

¨ kód

¨ poznámku

¨ aktualizaci (datum a čas)

Je-li nastaveno, že je typ „Zabudovaný“, jedná se pak o hlášení pevně zabudované v kódu vlastního výpočtu výplatního lístku.

Je-li nastaveno, že je typ „Skript před výpočtem“, jedná se pak o hlášení uživatelské, ke kterému se váže kód uvedený v atributu „kód“. Tento skript se provede hned na začátku výpočtu výplatních lístků.

Je-li nastavené, že je typ „Skript po výpočtu“, jedná se rovněž o hlášení uživatelské, ke kterému se váže kód uvedený v atributu „kód“. Tento skript se provede až na konci výpočtu výplatních lístků.

4.4.2 Užití algoritmu

Druhá záložka v činnosti „algoritmy výpočtu protokolu“ obsahuje tyto údaje:

¨ provádět (volba Ano/Ne)

¨ skrytá (volba Ano/Ne)

¨ stupeň (volba Informace, Chyba zpracování)

¨ barva písma, barva pozadí

¨ priorita

¨ poznámka

V následujícím odstavci se blíže vrátíme k významu jednotlivých atributů:

¨ provádět – je-li položka protokolu nastavena na Ano, pak se test provede a zapíše do protokolu. Je-li nastavena na Ne, pak se test sice provede, ale do protokolu se jeho výsledek nezapíše. Uživatel pak ale tímto nemá žádnou informaci o tom, že se testem případný problém zachytil, tzn. že volbu Ne je vhodné použít jedině u testů, kde uživatel jejich výsledky opravdu sledovat nechce. Správné nastavení „provádět – Ano/Ne“ je tedy klíčovým nastavením v celé činnosti, protože jak jsme se zmínili výše, je možno některé testy zcela vyřadit.

¨ skrytá – je-li položka protokolu nastavena na skrytá Ano, pak se ve výsledném protokolu výpočtu nezobrazuje. Je-li nastavena na skrytá Ne, pak se ve výsledném protokolu zobrazuje. Zobrazování je možno vyfiltrovat na záložce výběr v protokolu. Jedná se o jemnější formu nastavení než u atributu provádět, protože tímto nastavením uživatel test zcela nevyřazuje, pouze řídí zobrazování jeho výsledku ve výběru protokolu.

¨ stupeň – tento atribut řídí chování samotného běhu výpočtu. Při položce, která má stupeň „informace“ dojde k zápisu do protokolu a výpočet běží dál. Pokud se provádí výpočet pro všechny pracovníky, dojde k zablokování výpočtu pro další přepočítávání. Při položce, která má stupeň „chyba“ dojde k zápisu do protokolu a výpočet u pracovníka, který byl tímto testem zachycen tímto okamžikem končí. Nedojde k zablokování výpočtu pro další přepočítávání. Výplatní lístky pak tímto nejsou kompletní, zachycený problém musí uživatel vyřešit a následně pustit znovu výpočet.

¨ barva písma a barva pozadí umožňuje hlášení uživatelsky barevně zvýraznit

¨ atribut priorita určuje třídění jednotlivých položek protokolu

Standardní nastavení algoritmu výpočtu protokolu mezd je „provádět – Ano“, „skrytá – Ne“ a „stupeň – Informace“.

5. Pomocné výpočty

Automaticky tyto činnosti vykonává standardně uzávěrka mezd. Jejich přepočet se pouští v případě, že došlo k nějakému nestandardnímu zásahu do mezd. Jsou k dispozici v menu Mzdy – Speciální činnosti:

¨ přepočet průměru h., d. a m. (tj. hodinový, denní a měsíční)

¨ přepočet průměru h., d. a m. (pravděpodobný průměr)

¨ přepočet průměru na nemoc. dávku

¨ výpočet zákonného pojištění odpovědnosti organizace

Tento výpočet se v ideálním případě vůbec neprovádí, je vhodné, aby ho měl přístupný (práva) jen pověřený pracovník. Nestandardní zásah může vzniknout vlivem nesprávného zadání prvotních údajů nebo skrytou chybou programu.

6. Odeslání mezd do systému – události mezd

K odeslání mezd do systému se používá nadefinovaných druhů událostí. Jedná se o procesní způsob zpracování, tzn. že činnost události se naplní událostmi automaticky (pokud se tak nestane automaticky, je nutno pomocí Ctrl F3 aktivovat příslušnou šablonu), nikoliv ručně po stisku F3. Uživatel si v menu Nový proces – Mzdy zvolí proces, který chce aktivovat a po jeho zapsání je zároveň aktivována i činnost události mezd.

6.1 Nastavení

Pro využití možnosti odeslat výsledky mezd procesně do ostatních částí systému je nutno mít přesně nadefinované druhy událostí. Tato činnost se nachází v menu Mzdy – Definice – Druh události. Definuje se:

¨ identifikace události

¨ popis (např. odvod zdravotního pojištění, odvod zálohové daně, mzdové náklady apod.)

¨ do účetnictví, do plateb, do statistiky, ostatní – ve všech těchto případech je možno v překryvném seznamu volit z těchto možností:

- Ano

- Ne

- Ano v absolutní hodnotě – přenese se kladné číslo

- Ano s obráceným znaménkem – využije se např. u nemocenských dávek

K dispozici je zde i atribut „Procento uplatnění“ a Vlastnost (např. rozlišení společník nebo zaměstnanec). Tyto atributy jsou pro uživatele k dispozici např. vzhledem k nové evidenci nemocenských dávek. Prvních 14 dní nemoci uživatel platí zaměstnanci tzv. „náhradu mzdy“. Polovinu této částky má zaměstnavatel možnost si ze zákona odečítat. Proto je nutné v této činnosti na záložce „Účty a strany“ tento druh události správně nastavit a toto mu umožňují následující atributy:

¨ platné pro účetnictví

¨ platné pro platby

¨ platné pro statistiku

¨ platné pro ostatní

Jejich hodnoty jsou Ano, Ne, Neurčeno. Jestliže je nastaveno Ano, pak se příslušný účet a strana uplatní při spuštění šablony (události mezd vznikají pomocí naprogramovaných šablon). Pokud je nastaveno Ne nebo Neurčeno, pak šablona s takovým záznamem účtu a strany nepracuje.

6.2 Provedení

Vlastní provedení, tzn. odeslání mezd do systému, je v systému IS Bílý Motýl řešeno pomocí procesu. Při aktivaci tohoto procesu (v činnosti Nový proces) se spustí naprogramovaná šablona, která právě používá nadefinované druhy událostí a vytvoří na základě těchto definic jednotlivé vstupy mezd do systému (např. do plateb, účetnictví apod.). K dispozici jsou následující naprogramované šablony:

¨ Mzdy podrobně - UC i PL – MZ0048

Šablona zapisuje údaje vzniklé výpočtem výplatních lístků podrobně, tj. každého pracovníka zvlášť a každou mzdovou položku zvlášť. Zapisuje údaje potřebné do účetnictví (mají označení UC) i do plateb (mají označení PL). Část UC vůbec nezapisuje selektory. Část PL kopíruje obchodní, organizační a technický selektor dle stavu na výplatních lístcích.

¨ Mzdy - souhrn PL – MZ0082

Šablona zapisuje údaje vzniklé výpočtem výplatních lístků souhrnně, tj. za všechny pracovníky dohromady (za bankovní údaje a mzdovou položku). Součtování mzdových položek se řídí identifikací druhu události, který je každé mzdové položce přiřazen v menu DEFINICE. Zapisuje POUZE údaje potřebné do plateb (mají označení PL). Obchodní selektor, organizační selektor a TV selektor se vyplní hodnotou „-„. Šablona plní kolonku účet účetní osnovy údajem dle druhu události.

¨ Mzdy - UC podrobně – MZ0084

Šablona zapisuje údaje vzniklé výpočtem výplatních lístků podrobně, tj. každého pracovníka zvlášť a každou mzdovou položku zvlášť. Zapisuje POUZE údaje potřebné do účetnictví (mají označení UC). Šablona nezapisuje selektory.

¨ Mzdy souhrn - UC – MZ0085

Šablona zapisuje údaje vzniklé výpočtem výplatních lístků souhrnně, tj. za všechny pracovníky dohromady. Součtování mzdových položek se řídí identifikací druhu události, který je každé mzdové položce přiřazen v menu DEFINICE. Zapisuje POUZE údaje potřebné do účetnictví (mají označení UC). Obchodní selektor, organizační selektor a TV selektor se vyplní hodnotou „-„.

¨ Mzdy podrobně – ST – MZ0087

Šablona zapisuje údaje vzniklé výpočtem výplatních lístků podrobně, tj. každého pracovníka zvlášť a každou mzdovou položku zvlášť. Zapisuje POUZE údaje potřebné do statistiky (mají označení ST). Šablona rozpočítává položky dle poměru trojice selektorů u příjmů daného pracovníka. Šablona zapisuje všechny selektory. Slouží k zaznamenání statistických údajů. Aplikuje se na samostatnou operaci.

¨ Mzdy – UC s org. selektorem – MZ0089

Šablona zapisuje údaje vzniklé výpočtem výplatních lístků podrobně, tj. každého pracovníka zvlášť a každou mzdovou položku zvlášť. Zapisuje POUZE údaje potřebné do účetnictví (mají označení UC). Šablona zapisuje organizační selektor dle karty pracovníka (tím se liší od šablony MZ0084). Šablona nerozpočítává žádné údaje dle trojice selektorů.

¨ Mzdy – UC podrobně + SP rozděleně – MZ0090

¨ Mzdy - podrobně OST – MZ0096

Šablona zapisuje údaje vzniklé výpočtem výplatních lístků podrobně, tj. za každého pracovníka zvlášť a za každou mzdovou položku zvlášť. Zapisuje POUZE údaje ostatní (mají označení OST) a na Druzích událostí mají nastaveno Ostatní „Ano“. Šablona zapisuje pouze stranu Dal. Šablona nezapisuje selektory. Pokud zapisuje mzdovou položku typu srážky, vezme adresáta z Karty pracovníka.

¨ Mzdy – UC podrobně a částečně rozděleně – MZ0103

Šablona zapisuje údaje vzniklé výpočtem výplatních lístků podrobně, tj. každého pracovníka zvlášť a každou mzdovou položku zvlášť. Zapisuje POUZE údaje potřebné do účetnictví (mají označení UC). Šablona zapisuje stranu MD i Dal. Šablona zapisuje selektory. Mzdové položky typu „příjmy a náhrady“ šablona zapisuje tak, jak je uvedeno na výplatním lístku i s příslušnými selektory. Mzdové položky – hrubý příjem, odvod SP organizace, odvod ZP organizace – se rozpočítávají dle poměru trojice selektorů u příjmů daného pracovníka. Šablona zapisuje všechny selektory. Mzdové položky ostatních typů šablona zapisuje tak, jak je uvedeno na výplatním lístku. Tato šablona je tedy kombinací šablon MZ0087 a MZ0084.

¨ Šablona „MZDY - UC podrobně s org. sel z lístků“ (MZ0168)

Šablona je stejná jako MZ0084. Zapisuje organizační selektor dle údajů na výplatním lístku. Pouze v případě kolize kvůli stejnému druhu události zapíše organizační selektor z karty pracovníka. Pozn.: Pro kontrolu údajů směřujících do účetnictví je možné využít tiskové sestavy „Účetnictví podrobně III“ nebo „Kontrola účetnictví“ (spouští se z událostí mezd).

¨ Šablona „Mzdy - podrobně OST“ (MZ0096)

Šablona zapisuje údaje z mezd podrobně, tj. za každého pracovníka zvlášť a za každou mzdovou položku zvlášť. Zapisuje POUZE údaje ostatní (mají označení OST) a na Druzích událostí mají nastaveno Ostatní „Ano“. Šablona zapisuje pouze stranu Dal. Šablona nezapisuje selektory. Pokud zapisuje mzdovou položku typu srážky, bere se adresát z Karty pracovníka.

7. Roční zúčtování daně

Tato činnost (Mzdy a personalistika – Mzdy) se spouští v systému jednou ročně, obvykle při zpracování únorových mezd. Činnost provede roční zúčtování daně z příjmu fyzických osob, tj. vypočte základ ročního zúčtování, vyrovnání přeplatku na dani a dorovná daňový bonus.

Údaje a nastavení k tomu potřebná jsou :

¨ Roční daňová tabulka

Zkontrolujte si nastavení Roční daňové tabulky. Naleznete ji v činnosti DEFINICE – Daňové tabulky souhrnné. Má identifikaci DPR001 - Podepsal, roční (druh roční).

Položky nastavte takto :

Platnost od | Od | Do | Pevná část | Sazba % | Typ vzniklé daně
1.1.2008 | 0 | 99 999 999 | 0 | 15 | Roční zúčtování

¨ Karta pracovníka

Na Kartě pracovníka - Osobní údaje – zaškrtněte „Provést roč. zúčt.“ - u těch pracovníků, kterým budete vytvářet roční zúčtování.

¨ Roční položky

Karta pracovníka má záložku Roční položky. Zde se definují: :

¨ roční nezdanitelné položky

¨ daňová zvýhodnění typu roční nebo roční s bonusem

¨ položky od jiného zaměstnavatele (loňský příjem, loňský odvod, loňská daň, loňský daňový bonus)

Roční nezdanitelné položky daně jsou např.:

KOZP | životní kapitálové připojištění
KOPP | penzijní připojištění (zadává se jen částka uznatelná jako odpočet od základu daně)
KO09 | služební auto pro soukromé účely (dodanění)
KO10 | odpočet pro dárce krve (dva tisíce Kč za každý odběr krve)
KO12 | dary (zadává se pouze částka uznatelných darů pro odpočet od základu daně)
KO13 | úroky z úvěrů
KOOD | Členské příspěvky člena odborové organizace
KOZK | Úhrady za zkoušky ověřující výsledky dalšího vzdělávání

Doporučené identifikace daňových zvýhodnění typu roční nebo roční s bonusem jsou:

Na poplatníka | JJR021
Na manželku | JJR022
Na manželku ZTP | JJR023
Na částečnou invaliditu | JJR024
Na plnou invaliditu | JJR025
Držitel průkazu ZTP/P | JJR026
Na studium | JJR027
Na dítě | JJR01
Na ZTP dítě | JJR11

Pozn.: Karta pracovníka má též záložku Daňová zvýhodnění, ale zadávají se do ní pouze Daňová zvýhodnění, která NEJSOU typu roční nebo roční s bonusem.

Identifikace položek od jiného zaměstnavatele jsou:

Loňský příjem | L30000
Loňský odvod | L31000
Loňská daň | L32000
Loňský bonus | L35000

U položky L35000 se nejedná o nároky, ale o skutečně vyplacené bonusy od jiného zaměstnavatele. Pro zpracování ročního zúčtování za rok 2008 zadejte do položky platnost 1.1.2008 až 31.12.2008. Do výplatního lístku se položky ze záložky Roční položky dostanou automaticky při výpočtu ročního zúčtování.

Nastavení atributů minimální a maximální roční daňový bonus se provádí v činnosti Parametry (samozřejmě se jedná o nastavení na hodnoty platné pro rok, za který provádíte roční zúčtování).

Ve výběru činnosti Roční zúčtování daně se nastavuje:

¨ číslo pracovníka (pokud není vyplněno, automaticky se berou všichni)

¨ zaškrtávátko „přepočítat“ reguluje, zda se má spustit výpočet nebo zda chcete údaje pouze prohlížet

¨ po spuštění výpočtu se ke každému pracovníkovi (dle nastavení ve výběru) předplní tři řádky s datem. Jsou to řádky L40000 – Základ ročního zúčtování a L41000 – Vyrovnání přeplatku na dani a položka L43000 – Vyrovnání ročního daňového bonusu (položky L40000, L41000, L43000 musí být nadefinovány v činnosti Definice – Položky mezd – Odvody).. Tyto řádky se stanou součástí výplatního lístku (zda se budou tisknout se reguluje zaškrtnutím „Tisknout“ v činnosti Definice – Položky mezd – Odvody).

¨ Tento přepočet může uživatel spouštět několikrát

Je-li vyrovnání přeplatku na dani větší než 50,- Kč, pak se vyplatí, tzn. přičte se k čisté mzdě. Je-li vyrovnání přeplatku na dani menší než 0,- Kč (nedoplatek), pak se v ročním zúčtování uvažuje jako 0,- Kč a situace se srovná další měsíc jako doplatek daně.

7.1 Algoritmus ročního zúčtování

¨ základ ročního zúčtování se vypočte jakou součet všech zálohově zdanitelných příjmů aktuálního pracovníka za uplynulý rok. Přičtou se odvody zdravotního a sociálního pojištění aktuálního pracovníka za uplynulý rok, které za pracovníka odvedla organizace. Odečtou se nezdanitelné měsíční položky aktuálního pracovníka za uplynulý rok. K základu se přičte Loňský příjem a přičte se Loňský odvod. Loňský příjem je příjem od jiného zaměstnavatele za uplynulý rok. Loňský odvod je odvod zdravotního a sociálního pojištění, který jiný zaměstnavatel odvedl za pracovníka za uplynulý rok.

¨ sčítají se základy aktuálního pracovníka za všechny jeho pracovní poměry, tj. základ ročního zúčtování daně = příjmy zdanitelné zálohově + odvody SP organizace + odvody ZP organizace – nezdanitelné položky měsíční + loňský příjem + loňský odvod – nezdanitelné položky roční

¨ vypočtený základ se pak zaokrouhlí na celé stokoruny směrem dolů

¨ daň se vypočte podle roční daňové tabulky

¨ maximální daňové zvýhodnění na děti se skládá z nároku na daňové zvýhodnění od stávajícího zaměstnavatele a z nároku na daňové zvýhodnění od minulého zaměstnavatele (mzdová položka L33000)

¨ porovnáním maximálního daňového zvýhodnění na děti a daně vypočtené dle roční daňové tabulky se určí roční sleva na dani

¨ daň po slevě = daň podle roční daňové tabulky – roční sleva na dani

¨ přeplatek na dani se vypočte jako součet zálohových daní + loňská daň – (daň dle roční daňové tabulky – roční sleva na dani). Tato hodnota se zapíše do mzdové položky L41000

¨ roční daňový bonus se určí jako maximální daňové zvýhodnění na děti mínus roční sleva na dani

¨ vyplacené měsíční daňové bonusy a měsíční daňové bonusy vyplacené od minulého zaměstnavatele (mzdová položka L35000) se sečtou

¨ rozdíl na daňovém bonusu se určí jako roční daňový bonus mínus součet vyplacených měsíčních daňových bonusů. Na rozdíl na daňovém bonusu má nárok pouze ten zaměstnanec, který dosáhl příjmu alespoň ve výši šestinásobku minimální mzdy. Tato hodnota se zapíše do mzdové položky L43000.

¨ vyrovnání přeplatku na dani se určí kompenzací přeplatku na dani a rozdílu na daňovém bonusu

8. Uzávěrka mezd

Tato činnost (a její help) je v podstatě společná pro několik činností z komponenty mzdy. Jedná se o:

¨ uzávěrku mezd, která se aktivuje z hlavního menu Mzdy – Mzdy – Uzávěrka mezd a její podrobný popis je uveden níže

a další činnosti, které se aktivují z menu Mzdy – Speciální činnosti a v podstatě provedou pouze vždy přepočty, které se vztahují k názvu dané činnosti. Jedná se o tyto činnosti:

¨ zákonné pojištění odpovědnosti

¨ přepočet průměrů (hodinový, denní, měsíční)

¨ zjištění pravděpodobného průměru

Přepočet průměrů provede současně i uzávěrka mezd, tzn. že není nutné tuto činnost pouštět samostatně, pokud máme v plánu pustit uzávěrku mezd. Výpočet zákonného pojištění odpovědnosti a zjištění pravděpodobného průměru je však nutno aktivovat jako tuto samostatnou činnost, uzávěrka mezd s těmito údaji nepracuje.

Uzávěrku lze provést pouze v případě, že od posledního výpočtu mezd nebyla provedena žádná změna. Uzávěrka mezd pak definitivně zablokuje údaje daného měsíce pro vkládání dalších údajů. Po jejich uzavření není možné do nich znovu zasahovat, měnit jejich položky a nechat je znovu počítat. Záznamy mezd uzavřeného měsíce nelze tedy vkládat, opravovat ani rušit.

Nejschůdnější variantou je uzavírat mzdy až po jejich vyplacení, nejlépe až před výpočtem mezd za následující období. Uzávěrku mezd má uživatel k dispozici v hlavním menu mzdy – mzdy – uzávěrka mezd. Po aktivaci této činnosti se systém dotazuje „Opravdu chcete spustit uzávěrku mezd za měsíc … a rok ……? Možnosti jsou Ano – Ne. Některé akce provádí uzávěrka každý měsíc, některé pouze jestliže končí čtvrtletí.

Uzávěrka měsíčně provádí tyto akce :

¨ odečtení zůstatku dovolené

¨ pro všechny nemocenské dávky , které měly nastaveno Proplatit = Ano se nastaví Proplaceno dne a Proplatit se nastaví na Ne

¨ snížení zůstatku půjčky o uhrazenou částku

¨ aktualizaci data posledního zpracování mezd

¨ zápis do Historie karty

¨ zápis do Historie pracovního poměru

- jedná se o stav atributů „zůstatek staré dovolené“ a „zůstatek nové dovolené“ k prvnímu dni uzavíraného měsíce, tj. před započtením čerpání dovolené v uzavíraném měsíci, např. údaj pro měsíc a rok 03/2007 udává stav dovolených k 1.3.2007)

- aktualizace atributů „zůstatek staré dovolené“ a „zůstatek nové dovolené“ podle počtu dní, které byly v uzavíraném měsíci čerpány

¨ kontrola limitu pro SP, ZP a penzijního pojištění

Uzávěrka čtvrtletně provádí (pouze pro každého pracovníka a jeho pracovní poměr, který ke konci čtvrtletí trvá) :

¨ výpočet průměrného výdělku - hodinový, denní a měsíční průměr

¨ výpočet průměru na nemocenské dávky

Uzávěrka za měsíc PROSINEC aktualizuje tyto atributy:

¨ do atributu „převod dovolené do příštího roku“ se zapíše součet „zůstatku staré dovolené! a „zůstatek nové dovolené“ k datu 31.12.

¨ do atributu „zůstatek staré dovolené“ se zapíše tentýž součet „zůstatku staré dovolené“ a „zůstatku nové dovolené“ k datu 31.12.

¨ do atributu „zůstatek nové dovolené“ se zapíše počet dní, který je uveden v atributu „roční nárok na dovolenou“, tzn. že před provedením uzávěrky za prosinec je nutno mít v pořádku roční nároky na dovolenou na následující rok.

V případě nesrovnalostí zapíše uzávěrka tyto údaje do protokolu .

9. Definice mzdových položek

Definice mzdových položek se provádí v činnosti Mzdy – Definice – Položky mezd. Vlastní nastavení mzdových položek má přímý vliv na výpočet mezd.

Nastavením definic položek mezd se ovlivňuje běh výpočtu hrubých mezd. Zejména vztah právě definované položky mezd k sociálnímu a zdravotnímu pojištění, ke čtvrtletním průměrům, ke kalendáři a jeho fondu pracovní doby, k druhu události mezd, atd. Na výplatním pásku pracovníka se položky tisknou v pořadí podle identifikace položky. Kombinací atributů Původ Kč/j a Výpočet Kč se nastaví chování mzdové položky.

Nastavení definice mzdových položek není rozhodně triviální záležitostí, proto se domníváme, že by toto měl dělat zkušený pracovník mezd v součinnosti s implementátorem.

9.1 Příjmy a náhrady

Činnost Příjmy a náhrady je součástí sekce DEFINICE. Jedná se o činnost, ve které je možné nastavit jednotlivé mzdové položky, které během výpočtu vytvoří hrubou část mezd. Při aktivaci této činnosti má uživatel nejprve dostupnou záložku Výběr, kde si může vyfiltrovat údaje, které chce mít následně k dispozici.

Dostupné atributy :

¨ Identifikace

¨ Popis

¨ Komentář

¨ Platnost od data

¨ Platnost do data

¨ Technicko-věcný selektor

¨ Tlačítko Úkolová-tarifní

¨ Vzorce - vzorec pro zjištění položky Kč/j

- vzorec pro zjištění položky koeficient - vzorec pro koeficient se bude používat až ve výpočtu, pro zjištění skutečného koeficientu. Vzorec pro koeficient může záviset na pracovníkovi, na jeho pracovním poměru, na mzdové položce v aktuálním měsíci apod. Pokud je z hlediska obsahu vzorce možné ho v činnosti Příjmy a náhrady vyčíslit, pak se přímo v této činnosti zapíše, jinak zůstane na hodnotě 1 a vzorec se uplatní až později. Uplatňuje se při výpočtu v kombinaci s použitím mzdové položky v Pravidelných příjmech. Může být zapsán i výrazem ve tvaru FoxPro (tzn. vytvořen select např. že když pracovník nepřekročí určitou výši vyrobených zmetků, tak má nárok na 20% prémií apod.).

¨ Původ Kč/j – pomocí tohoto atributu se určí způsob, kterým se při použití ve výplatních lístcích (činnost Prohlížení výplatních lístků) nastaví atribut Kč/j tj. částka za jednotku času. Možnosti jsou :

- Zadaná částka – do atributu Kč/j se přímo vepíše částka, nebo se tam předplní pomocí činnosti Pravidelné příjmy na Kartě pracovníka. Použije se např. u prémií, měsíční mzdy, …

- Dle tarifu pracovníka – do atributu Kč/j se předplní údaj z Karty pracovníka – tarifní třídy – hodinová mzda. Použije se např. u Základní mzdy časové (dle tarifu)

- Úkolová dle tar. prac. - do atributu Kč/j se předplní údaj z tlačítka Úkolová-tarifní – podle stupnice a třídy, která pracovníkovi náleží. Použije se např. u Základní mzdy úkolové tarifní.

- Vyšší ze zadaná částka – tarif prac. – do atributu Kč/j se nastaví částka podle principu Zadaná částka nebo podle principu Dle tarifu pracovníka, podle toho, která je větší

- Vyšší ze zadaná částka – úkolová dle tar. prac. - do atributu Kč/j se nastaví částka podle principu Zadaná částka nebo podle principu Úkolová dle tar. prac., podle toho, která je větší

- Hod. průměr - do atributu Kč/j se nastaví hodnota hodinového průměru, která je uvedena na Kartě pracovníka. Použije se např. u Dovolené.

- Den. průměr - do atributu Kč/j se nastaví hodnota denního průměru, která je uvedena na Kartě pracovníka. Použije se např. u Dovolené.

- Měs. průměr - do atributu Kč/j se nastaví hodnota měsíčního průměru, která je uvedena na Kartě pracovníka.

- Dle artiklu mezd – používá se pouze v činnosti Úkolové lístky, atribut Kč/j je přeplněn na základě artiklu, který je použitý na události.

- Vzorcem – používá se spolu s atributem Vzorec, atribut Kč/j se předplní podle údaje uvedeného v atributu Vzorec

¨ Koeficient (koeficientem se vynásobí částka na atributu Kč/j) při použití ve výplatních lístcích

¨ Výpočet Kč- pomocí tohoto atributu se určí způsob, kterým se při použití ve výplatních lístcích (činnost Prohlížení výplatních lístků) nastaví atribut Kč tj. celková částka na mzdové položce. Ve všech následujících případech může dojít k ovlivnění atributem koeficient.Možnosti jsou :

- Kč/j – celková částka na mzdové položce bude totožná s atributem Kč/j

- Dnů * Kč/j - celková částka na mzdové položce vznikne vynásobením počtu odpracovaných dnů atributem Kč/j

- Dnů/ Dnů FPD v období x Kč/j – celková částka na mzdové položce vznikne úpravou podle fondu pracovní doby a to ve dnech a vynásobením atributem Kč/j

- Hodin * Kč/j - celková částka na mzdové položce vznikne vynásobením počtu odpracovaných hodin atributem Kč/j

- Hodin/ hodin FPD v období x Kč/j - celková částka na mzdové položce vznikne úpravou podle fondu pracovní doby a to v hodinách a vynásobením atributem Kč/j

- Výkon * Kč/j - celková částka na mzdové položce vznikne vynásobením atributu Výkon atributem Kč/j

¨ Doplňující údaje – vazba na sadu doplňujících údajů, které řídí chování mzdové položky např. vůči daním, zdravotnímu pojištění, …

¨ Vyplatit v penězích – mzdová položka bude započtena do výplatního lístku v penězích nikoliv jako nepeněžní plnění

¨ Tisknout – mzdová položka se bude tisknout na výplatním lístku

¨ Povoleny nulové dny – mzdová položka může mít na výplatním lístku nulové dny

¨ Povoleny nulové hodiny – mzdová položka může mít na výplatním lístku nulové hodiny

¨ platnost mzdové položky od data – do data

¨ druh události

¨ technický selektor

¨ ciz. název – cizojazyčný název mzdové položky

10. Odvody na ZP a SP

Tuto činnost má uživatel k dispozici v menu Mzdy – Mzdy (zároveň má uživatel možnost tyto údaje vidět i na sestavách nad činností „prohlížení výplatních lístků“) Obsahuje tři činnosti:

¨ sumář odvodů zdrav. poj. – uživatel si zvolí výběr za měsíc, rok a zdravotní pojišťovnu a má pak k dispozici údaje jakou výši zdravotního pojištění organizace zdravotní pojišťovně odvedla (přesněji počet pracovníků, základ zdrav.poj., zdrav.poj. za organizaci a zdrav.poj. za pracovníky)

¨ odvody zdrav.poj. – lidi – přehled jednotlivých odvodů zdravotního pojištění za pracovníky

¨ odvody soc.poj. dle lidí – přehled jednotlivých odvodů sociálního pojištění za pracovníky

11. Parametry a číselníky

Pro nastavení správného chování mezd má uživatel k dispozici celou řadu číselníků, z nichž některé dostává naplněny s dodávkou systému a některé doplní v součinnosti s implementátorem mezd. Jsou to např.:

¨ Daňové tabulky

¨ Kalendář

¨ Pracovní funkce

¨ Výplatní místa

¨ Zdravotní a sociální pojišťovny (oba druhy pojišťoven jsou zde uvedeny zároveň, jsou však odlišeny typem)

¨ Tarifní stupnice a třídy

¨ Druhy událostí

¨ Umístění mezd

Parametry jsou k dispozici v menu Mzdy – Mzdy – Parametry. Jednotlivé parametry ovlivňují jakým způsobem se bude chovat optimalizovaný výpočet mezd. Obsahují základní nastavení hodnot systému mzdové agendy a jsou rozděleny do tří záložek:

záložka Hodnoty

¨ poslední zpracované mzdy k datu – datum posledního výpočtu mezd

¨ uzamknutí – datum uzamčení výpočtu mezd. Je-li vyplněno, pak k tomuto datu již nelze provádět opravy a výpočty mezd pracovníků

¨ dorovnání min. mzda – mzdová položka, sloužící k dorovnání příjmu do minimální mzdy

¨ náhrada mzdy za nemoc – definice mzdové položky, která slouží k výpočtu „náhrady“ za nemoc (k výstupu mezd do plateb a účetnictví)

¨ min. roč. daňový bonus

¨ max. roč. daňový bonus

¨ kontrola příslušnosti

záložka Chování

¨ den výplaty (a zároveň kdy bude den výplaty, jestliže by měl připadat na sobotu nebo neděli)

¨ velká / malá organizace

¨ technický selektor na výpl. lístek odkud

¨ typ kalendáře (po měsících nebo po dnech)

¨ plánovací kalendář – určuje jeden z měsíčních kalendářů FPD jako plánovací kalendář, platný pro všechny zaměstnance. I když organizace používá denní kalendáře (viz. atribut výše), musí být tento plánovací kalendář vygenerován i ve variantě měsíční a to v případě, že organizace používá ve mzdách měsíční průměry ve mzdách (např. při výplatě odstupného).

¨ způsob výpočtu denního průměru

¨ způsob výpočtu SP

¨ uplatňovat slevy na sociálním pojištění

¨ způsob výpočtu nepřítomnosti pro nemoc

¨ sada

¨ velikost zkušeb. doby v měs.

záložka Adresáti

¨ adresát, spojení, účet, adresa, KS a VS pro odvod zálohové daně

¨ adresát, spojení, účet, adresa, KS a VS pro odvod daňového bonusu

¨ adresát, spojení, účet, adresa, KS a VS pro odvod srážkové daně

¨ adresát, spojení, účet, adresa, KS a VS pro odvod sociálního pojištění

12. Personalistika

¨ událost personalistiky

¨ artikly personalistiky

¨ pracovní místa skutečná a typová

¨ hodnoty požadavku/vlastnost

¨ druhy požadavků a vlastností

¨ přehled volných údajů pracovníků

Neexistuje obecné použití této komponenty. Její využití je zcela závislé na potřebách organizace a na základě této analýzy nastaví její používání implementátor (např. je možné nastavit hodnoty požadavku na typová a skutečná pracovní místa, že obchodník má dostat každý druhý rok mobilní telefon, že má každý měsíc nárok na GO kupon, že 1x ročně musí projít školením apod.). Poté musí implementátor vytvořit příslušný druh procesu na evidování těchto nároků a potřeb (zároveň s tím i šablonu na vkládání těchto požadavků).

13. Další funkce mezd

Jedná se o funkce, které nejsou plně využívány u všech uživatelů, záleží na každé organizaci, kterou z těchto funkcí využije.

13.1 Výčetky platidel

Tato činnost se nachází v menu Mzdy – Mzdy. Využije ji nejspíš pouze ten uživatel, který vyplácí své mzdy nikoliv převodem na účet pracovníka, ale v hotovosti. Činnost mu usnadní spočítat výčetku platidel pro výplatu každého pracovníka. Obsahuje tři možnosti:

¨ číselník platidel – nadefinovaný číselník jednotlivých platidel

¨ jednotlivé výčetky platidel – přehled za vybrané pracovníky

¨ sumární výčetka platidel za výplatní místo – celkový přehled výčetky platidel za zvolené výplatní místo

13.2 Historie karty a pracovního poměru

Tyto činnosti se nacházejí v menu Mzdy – Mzdy – Speciální činnosti. Poskytují uživateli přehled o historicky zadaných údajích na kartě pracovníka a údajích týkajících se prac. poměru. Uživatel má pak možnost si zvolit rok, měsíc a pracovníka, jehož údaje chce vidět. Tuto činnost zřejmě může využívat většina uživatelů ve chvíli, kdy potřebuje zjistit určité údaje o pracovníkovi týkající se minulosti (např. loňského roku apod.)

13.3 Výplata záloh

V tomto případě se zřejmě jedná o zastaralou funkci systému, neboť u žádného uživatele není v současné době aktivně užívána. Nachází se v menu Mzdy – Mzdy.

13.4 Penzijní a životní pojištění

Změnou v legislativě mezd od r. 2008 došlo k některým změnám v případě používání odvodů na penzijní a životní pojištění pracovníků. Nejlepším řešením pro uživatele je, pokud všechny tyto činnosti nastaví ve spolupráci se svým implementátorem, přesto zde uvedeme několik základních pravidel, které by měly být v této souvislosti dodrženy:

¨ v činnosti „legislativní konstanty“ je nutno nastavit konstantu „limit penzijního a životního pojištění“ (hodnota je 24000,-)

¨ v činnosti Karta pracovníka pod menu Volby je k dispozici činnost „další informace karty“, kde je k dispozici atribut „nápočet limitovaného příspěvku“

¨ případné překročení limitu (z legisl. konstant) je při výpočtu mezd hlášeno v Protokolu

¨ uzávěrka nakopíruje stav „nápočtu limitovaného příspěvku“ do Historie karty a zároveň aktualizuje „nápočet“ na Kartě (v činnosti Další informace karty). Aktualizace nápočtu proběhne tak, jak je částka zadána, tzn. nikoliv v absolutní hodnotě

¨ v menu Definice – Položky mezd – Srážky je nutno u mzdové položky „odvod připojištění firma“ zatrhnout příznak „započítávat do limitu penzijního a životního pojištění“

14. Návod

Tato činnost obsahuje stručný popis základních kroků a je určena pro mzdovou účetní:

¨ Základní číselníky jsou v činnosti MZDY - DEFINICE. Jsou zde informace o mzdových položkách. Činnost Příjmy a náhrady nastavuje chování hrubých příjmů. Je nutné zkontrolovat i nastavení účtů do účetnictví. Další volby se zaměřují na ostatní mzdové položky výplatního lístku, jsou to takové, které vzniknou po provedení optimalizovaného výpočtu. O jejich správné nastavení se postará implementátor

¨ Datum posledního zpracování mezd, tj. poslední provedená uzávěrka je v činnosti Parametry (záložka Hodnoty).

¨ V činnosti Karta pracovníka se zadávají údaje k pracovnímu poměru pracovníka, tj. např. pravidelné příjmy, měsíční a roční nezdanitelné položky, půjčky a srážky, … . Pravidelné příjmy jsou např. přímá mzda, pravidelné prémie, … .

¨ V činnostech MZDY – Prohlížení výplatních lístků, Výplatní lístky – zadávání, Výplatní lístky se zadávají údaje – hrubé příjmy k výplatnímu lístku jednotlivce. Údaje z činnosti pravidelné příjmy se sem automaticky vloží při spuštění MZDY - Optimalizovaného výpočtu mezd.

¨ Spustíte-li činnost MZDY – Optimalizovaný výpočet mezd pro všechny pracovníky najednou (%), pak jsou vypočtené výplatní lístky kompletní. Ovšem je možné též spouštět MZDY – Optimalizovaný výpočet mezd pouze pro jednoho pracovníka nebo pro omezenou skupinu pracovníků (000010, 01%). Pak výsledné výplatní lístky nejsou kompletní. Položka Odvod sociálního pojištění za organizaci nebude správná. Tento odvod se totiž počítá ze souhrnných údajů za celou firmu. Před konečnou finalizací mezd je tedy nutné spustit znovu činnost Optimalizovaný výpočet mezd pro všechny pracovníky.

¨ Pokud je u nějakého pracovníka zadána složitější mzda, nebo se použije mzdová položka, která dosud nebyla použita, je výhodné spouštět nejprve činnost MZDY – Optimalizovaný výpočet mezd (za jednoho pracovníka) pro zjištění případných chyb.

¨ Nemoci, Ošetřování člena rodiny a Mateřská a rodičovská dovolená se vkládá v činnosti Nepřítomnost pro nemoc. Údaje z této činnosti se automaticky přetáhnou do výplatního lístku spuštěním činnosti MZDY – Optimalizovaný výpočet mezd.

¨ Zálohy se zadávají jako srážky. Vyplácí se pomocí činnosti Výplata záloh.

¨ Činnost Jednotlivé výčetky platidel vypočítá výčetky platidel pro jednotlivé sáčky. Musí se zatrhnout okénko přepočítat. Zároveň se vypočítá i sumární výčetka platidel za jednotlivá výplatní místa. Tato činnost se ale dnes již téměř nepoužívá, pracovníci si obvykle nechávají posílat mzdu na bankovní účet.

¨ PŘED uzávěrkou se provede odeslání údajů z mezd do systému (účetnictví a platby). Provede se to pomocí PROCESU.

¨ Po vyplacení mezd se spustí Uzávěrka mezd. Ta odečte dny dovolené, zaeviduje proplacení nemocí, čtvrtletně přepočte průměry na dovolenou, do voleb Historie karty a Historie pracovního poměru zapíše údaje za zpracovávaný měsíc.

© 1996-2013 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 13.02.2013


Odpisovaný majetek

O B S A H

1. Úvod a základní pojmy

2. Odpisové skupiny a sazby

3. Karty odpisovaného majetku

3.1 Odpisovaný majetek – atributy

3.2 Účetní odpis

3.3 Daňový odpis

3.4 Individuální odpis

3.5 Záložka „Výběr“

3.6 Předlohy výstupu

4. Změny odpisovaného majetku

4.1 Atributy

4.2 Záložka „Výběr“

4.3 Předlohy výstupu

5. Prognózování odpisů

6. Evidence výkonů

7. Parametry odpisovaného majetku

1. Úvod a základní pojmy

Tato dokumentace se zaměřuje na podporu evidence odpisovaného majetku a s ní spojených úkonů (tj. pořízení, odpisy, technické zhodnocení, vyřazení apod.) pomocí IS Bílý Motýl®, přičemž je zde kladen důraz na komponentu „Odpisovaný majetek“.

K pochopení následujícího návodu je vhodná znalost dokumentace „ovládání“ (především kapitoly 1.1, 1.2 a 1.3), znalost Zákona o dani z příjmů (586/1992 Sb.) a znalost Zákona o účetnictví (563/1991 Sb.) včetně prováděcí vyhlášky k podvojnému účetnictví (500/2002). Pro větší názornost si zde zopakujeme některé pojmy ze slovníku pojmů:

- Daňové odpisy – jejich výši a způsob uplatnění určuje zákon o daních z příjmů. Neuplatňují se do účetních nákladů, nýbrž se zohledňují při určování základu daně z příjmů;

- Odpisování – týká se hmotného (kromě zásob) a nehmotného (kromě pohledávek) investičního majetku. Tento majetek se během doby užívání opotřebovává, a proto ho odepisujeme do výdajů formou odpisů. Úkolem odpisu je tedy ukázat jak majetek používáním snižuje svoji hodnotu;
- Vstupní cena = pořizovací cena, reprodukční cena nebo vlastní náklady;
- Technické zhodnocení - technickým zhodnocením se rozumí výdaje na rekonstrukci a modernizaci majetku. Technické zhodnocení je vlastně investicí do již existujícího majetku a zvyšuje vstupní cenu;

- Odpisy – představují peněžní vyjádření opotřebení hmotného i nehmotného investičního majetku;

- Oprávky – jsou kumulovaný souhrn provedených odpisů;

- Účetní odpisy – o jejich výši a způsobu uplatňování rozhoduje v rámci účetních pravidel podnik. Účetní odpisy jsou nákladem podniku, pro účely zjištění základu daně z příjmů je však nutné použít odpisy daňové, popř. upravit zjištěný výsledek hospodaření o rozdíl účetních a daňových odpisů.

Odpisy vyjadřují opotřebení majetku (amortizaci) vyjádřené v Kč za určité období. Uznáváme dva druhy opotřebení a to fyzické, které je způsobeno používáním a morální, které vzniká zastaráním majetku. Účetní jednotka sleduje dva druhy odpisů: účetní a daňové. Oba typy se používají pouze pro dlouhodobý majetek (hmotný i nehmotný), který odepisujeme do výše vstupní nebo zvýšené vstupní ceny, a to rovnoměrně nebo zrychleně (metoda zvolená na počátku se pak musí dodržet po celou dobu odepisování).

Účetní odpisy slouží k přehledu o skutečné výši hodnoty majetku a jeho opotřebení v důsledku užívání nebo zaostávání po technické stránce. Pravidla účetních odpisů upravuje zákon č. 563/1991 Sb. o účetnictví.

Daňové odpisy jsou dány zákonem č. 586/1992 Sb. o dani z příjmů (§26 - §33) a slouží ke stanovení daně z příjmů.

Odpisy provádí vlastník či osoba oprávněná hospodařit s majetkem státu či nájemce (odpisy technického zhodnocení dlouhodobého majetku a/nebo odpisy najatého podniku, pokud je písemný souhlas vlastníka s odpisováním).

Mezi dlouhodobý hmotný odpisovaný majetek patří:

¨ samostatné movité věci a/nebo soubory movitých věcí, jejichž vstupní cena je vyšší než 40.000,- Kč a předpokládaná doba užívání delší než jeden rok (pokud účetní jednotka nestanoví jinak)

¨ stavby

¨ pěstitelské celky trvalých porostů s dobou plodnosti déle než 3 roky

¨ základní stádo a tažná zvířata

¨ jiný dlouhodobý hmotný majetek

Mezi dlouhodobý nehmotný odpisovaný (vstupní cena vyšší než 60.000,-Kč) majetek patří:

¨ zřizovací výdaje

¨ nehmotné výsledky výzkumu a vývoje

¨ software

¨ ocenitelná práva

¨ ostatní dlouhodobý nehmotný majetek

2. Odpisové skupiny a sazby

Před zahájením odepisování je nutno určit, do které odpisové skupiny majetek patří. Majetek je zákonem rozdělen do odpisových skupin. Pro rok 2008 zákon určuje 6 odpisových skupin. Dlouhodobý hmotný majetek je začleněn do odpisových skupiny podle životnosti. Konkrétní rozdělení do skupin určuje Příloha č. 1 k zákonu č. 586/1992 Sb. Nelze-li majetek podle této přílohy zařadit, potom automaticky patří do druhé odpisové skupiny. Dobu odpisu upravuje §30 zákona. Doba odpisování tedy závisí na tom, do které odpisové skupiny majetek patří.

Číselník odpisových skupin a jejich sazeb je s pořízením informačního systému Bílý Motýl dodáván naplněný. Na případné legislativní změny v sazbách apod. je uživatel upozorněn a tyto změny si následně ručně zaznamená do tohoto číselníku.

Tuto činnost má uživatel k dispozici v hlavním menu – Odpisovaný majetek – Odpisové skupiny. Po aktivaci této činnosti má uživatel k dispozici záložku odpisové skupiny, kde jsou uvedeny jednotlivé odpisové skupiny v letech. U každé skupiny je uvedena její identifikace a platnost s datem od – do. Pod záložkou Výběr může uživatel pak následně vyhledávat podle této identifikace a na základě atributu „platnost“ lze pak výběr ještě blíže specifikovat. Uživatel si může vybrat z těchto možností:

¨ platné i neplatné – tj. všechny odp. skupiny z hlediska platnosti

¨ platné dnes – uživateli se zobrazí všechny odp. skupiny, jejichž období platnosti od – do je aktuální pro dnešní datum

¨ neplatné dnes - uživateli se zobrazí všechny odp. skupiny, jejichž období platnosti od – do je neaktuální pro dnešní datum

¨ platné k datu - uživateli se zobrazí všechny odp. skupiny, jejichž období platnosti od – do je aktuální pro zadané datum, tzn. uživatel si může najít ty odp. skupiny, které byly platné např. k 1.1.2005

¨ neplatné k datu - uživateli se zobrazí všechny odp. skupiny, jejichž období platnosti od – do je neaktuální pro zadané datum

Další informace, které má uživatel k dispozici jsou na záložce „Sazby a koeficienty“. Zde jsou ke každé odpisové skupině uvedeny její sazby a koeficienty s datem platnosti od, tzn. jeden řádek sazeb a koeficientů může u dané skupiny mít platnost např. od 01.01.2003 a druhý řádek pak může být např. s platností od 01.01.2008 (viz. obr. 1). Jinými slovy, u každé odpisové skupiny je možno mít nadefinováno několik řádek s různými sazbami a koeficienty rozlišených různým datem platnosti.

obr. 1

Atribut „sazby pro rovnoměrný odpis“ poskytuje uživateli přehled o sazbách odpisů při rovnoměrném způsobu odepisování v prvním roce, v dalších letech a pro odpis ze zvýšené ceny. Výpočet rovnoměrných odpisů upravuje §31 zákona o dani z příjmu odst. a). Zákon určuje sazby pro výpočet odpisu. Tyto sazby jsou vyjádřeny procentem. Odlišná odpisová sazba je v prvním roce odepisování a v dalších letech. Sazba pro zvýšenou vstupní cenu se používá v případě, že u majetku v průběhu jeho užívání bylo provedeno technické zhodnocení.

Atribut „koeficienty pro zrychlený odpis“ poskytuje uživateli přehled o sazbách odpisů při zrychleném způsobu odepisování v prvním roce, v dalších letech a pro odpis ze zvýšené ceny. Výpočet zrychlených odpisů upravuje §32 zákona o dani z příjmu. Zákon určuje koeficienty pro výpočet odpisu. Koeficient pro 1 rok odpisu odpovídá době odepisování.

Daňové odpisy lze v prvním roce odpisování navýšit o 10, 15 nebo 20% (viz. atribut „procento“ na obr. 1). Zvýšení odpisu v prvním roce odepisování je možné v těchto výších:

¨ 10% - pro poplatníka, který je prvním vlastníkem majetku, který je zatříděn v odpisových skupinách 1 až 3,

¨ 15% - pro poplatníka, který je prvním vlastníkem zařízení pro čištění a úpravu vody, třídícího a úpravárenského zařízení na zhodnocení druhotných surovin,

¨ 20% - pro poplatníka, který je prvním vlastníkem stroje pro zemědělství a lesnictví (jen pro poplatníka s převážně zemědělskou a lesní výrobou).

Po stisku ikonky „tiskárna“ nebo po aktivaci činnosti „Tisk“ z menu Volby má uživatel k dispozici následující předlohu výstupu:

¨ Platné k datu (ve výběru) – klasická sestava, jejíž funkčnost je podmíněna zadáním data platnosti ve výběru[1]. Sestava poskytuje uživateli informace o odpisové skupině, sazbách pro rovnoměrný odpis, koeficientech pro zrychlený odpis a platnosti odpisové skupiny od – do.

3. Karty odpisovaného majetku

Tuto činnost má uživatel k dispozici v hlavním menu – komponenta Odpisovaný majetek – činnost Odpisovaný majetek. Poskytuje uživateli přehled jednotlivých nadefinovaných karet odpisovaného majetku. Uživatel při založení (po stisku klávesy F3 nebo stisku ikony „nový záznam“) karty zadává základní evidenční údaje k majetku jako je např. název, způsob výpočtu odpisů, zařazení do odpisové skupiny apod. Další atributy na kartě majetku jsou v podstatě vypočítávané, tzn. jsou vázané na pohyby (události) majetku jako je pořízení, technické zhodnocení, účetní odpisy, daňové odpisy, prodej apod. V dalších kapitolách si podrobně vysvětlíme atributy na jednotlivých stěžejních záložkách této činnosti.

Uživatel má navíc k dispozici záložku „Názvy artiklu“ (poskytuje uživateli možnost evidovat názvy majetku v různých zvolených jazycích) a záložku „Kategorie artiklu“ (možnost rozčlenit si karty odpisovaného majetku do jednotlivých kategorií, kde u každé kategorie se eviduje název, platnost, popis apod. U každé kategorie lze pak navíc nadefinovat i paletu barev.).

3.1 Odpisovaný majetek - atributy

První záložka v činnosti Odpisovaný majetek obsahuje základní evidenční údaje o majetku (viz obr. 2). Uživatel při zakládání karty odpisovaného majetku vstupuje následující atributy:

¨ Druh artiklu – výběr z číselníku.

¨ Identifikace artiklu – vlastní definiční číslo odpisovaného majetku.

¨ Název artiklu

¨ Třída SKP

¨ Datum zařazení – nevstupuje se při zakládání nové karty odpisovaného majetku, ale je automaticky naplněn z pohybu pořízení odpisovaného majetku (událost procesu Dl.MO – zařazení).

¨ Datum vyřazení - nevstupuje se při zakládání nové karty odpisovaného majetku, ale je automaticky naplněn z pohybu vyřazení odpisovaného majetku (událost procesu Dl.MO – vyřazení).

¨ Dat. zaháj. UO – datum zahájení účetních odpisů – vyplní se automaticky shodně s datem zařazení. Toto datum je možno podle potřeb uživatele ručně změnit (posunout vpřed). Uživatel má pomocí těchto atributů (dat. zaháj. UO a dat. zaháj. DO) možnost individuálního zahájení účetních a daňových odpisů odlišně od data zařazení (příklad použití – pro pěstitelské celky trvalých porostů, které nedosáhly plodonosného stáří – např. pro odpisy sadu je nutné posunout datum odepisování zhruba až po třech letech od data zařazení).

¨ Dat. zaháj. DO – datum zahájení daňových odpisů - vyplní se automaticky shodně s datem zařazení. Toto datum je možno podle potřeb uživatele ručně změnit (posunout vpřed).

¨ Druh inv. maj. – možnost výběru z překryvného seznamu (hmotný dlouhodobý majetek, nehmotný dlouhodobý majetek, drobný hmotný dlouhodobý majetek, drobný nehmotný dlouhodobý majetek).

¨ Umístění - odkazuje (po stisku F2 nebo ikony lupa či pravého tlačítka myši) do stávajícího číselníku "umístění spravovaného majetku", ke kterému lze nadefinovat přístupová práva. Při prohlížení karet investičního majetku má daný uživatel k dispozici jen ty karty, ke kterým má alespoň právo čtení; při založení (F3) či opravě (F4) karty lze uvést jen ta umístění, ke kterým má daný uživatel přístup "zápis".

¨ Tech. sel. – technicko věcný selektor. Uživatel ho u daného odpisovaného majetku zadává v případě, že chce např. sledovat náklady (míněno provedené odpisy) na konkrétní odpisovaný majetek, např. náklady za konkrétní auto.

¨ Org. sel. – organizační selektor. Uživatel ho u daného odpisovaného majetku zadává v případě, že chce např. sledovat náklady (míněno provedené odpisy) za umístění, např. náklady za jednotlivé stroje na střediska apod. V případě, že je zde uveden organizační selektor (tzn. konkrétní umístění – středisko podniku), jdou celkové náklady na odpisy na vrub danému středisku. V případě, že uživatel potřebuje náklady na odpisy daného odp. majetku rozpočítat na více středisek, použije u daného odp. majetku volnou kartu „procento odpisů na střediska“, kde uvede příslušné údaje pro rozpočítání nákladů na odpisy (menu Obecné – Volné karty).

¨ Účet. sel. – účetní selektor. V IS BM je zvykem účtovat pohyby majetku na základě druhu artiklu a připravených předkontací. V případě, že by uživatel měl potřebu účtovat pohyby každé jednotlivé karty samostatně, je zde tato možnost k dispozici.

¨ Komentář – možnost zapsání libovolné poznámky ke kartě odpisovaného majetku.

obr. 2

Po stisku pravého tlačítka myši na tučném atributu „Artikl“ má uživatel k dispozici tyto činnosti (informace se vždy vztahují k aktuálnímu odpisovanému majetku). Ne každá nabídka činností má pro každý artikl (v našem případě kartu odp.maj.) v daném okamžiku smysl (např. nedokončené procesy nebo TP k datu rozpracované na KJ). Činnosti, které uživatel při práci s kartou odpisovaného majetku využije jsou:

¨ artikly (výskyt daného odp. majetku v ostatních komponentách)

¨ události artiklu (pohyb daného odp. majetku v ostatních komponentách)

¨ aktuální hodnoty artiklu

¨ obratové hodnoty artiklu

¨ množství artiklu na skladech

¨ dokumenty artiklu

¨ prezentace artiklu

¨ ceník artiklu

Po stisku ikonky „tiskárna“ nebo po aktivaci činnosti „Tisk“ z menu Volby má uživatel k dispozici následující předlohy výstupu:

¨ Invent. přehled daň. + tech. zhod. – jedná se o klasickou sestavu, kde má uživatel přehled jednotlivých karet odpisovaného majetku. U každé karty jsou následující atributy: inventurní číslo, název, datum zařazení a datum vyřazení, vstupní cena daňová, zůstatková cena daňová, hodnota daňového odpisu, hodnota technického zhodnocení, odpisová skupina, účetní selektor a celkem roky odepisování daného majetku.

¨ Inventura ke dni – se součtem – sestava typu Excel. Po jejím spuštění uživatel zadává datum, ke kterému chce mít inventuru vyčíslenu (Stav ke dni: .....). Následně se spustí aplikace Excel a uživatel má u každé karty k dispozici identifikaci, název, datum zařazení, datum posledního provedeného technického zhodnocení + celkovou sumu technických zhodnocení, pořizovací cenu účetní a daňovou, sumu účetních a daňových odpisů, hodnotu účetního a daňového odpisu v daném období a účetní a daňovou zůstatkovou cenu.

¨ Karta IMO ke dni – klasická sestava, která umožňuje uživateli zjistit stav na dané kartě k zadanému dni. Po jejím spuštění uživatel zadává datum, ke kterému chce mít údaje na kartě zobrazeny (Stav ke dni: .....). U každé karty jsou pak k danému dni k dispozici základní informace (identifikace, název apod.) a veškeré údaje k daňovým a účetním odpisům.

¨ Stručný inventurní přehled – jedná se o klasickou sestavu, která poskytuje uživateli ke každé kartě odpisovaného majetku veškeré potřebné informace + celkem za všechny karty na sestavě i sumu daňových a účetních odpisů.

¨ Stručný přehled s cenou – jedná se o klasickou sestavu, která poskytuje uživateli ke každé kartě odpisovaného majetku základní informace (identifikace, název apod.) a hodnotu pořizovací ceny (účetní i daňové) a hodnotu zůstatkové ceny (účetní i daňové).

3.2 Účetní odpis

Povinnost provádění účetních odpisů vyplývá ze zákona o účetnictví. Účetní odpisy jsou uplatněny podle skutečné doby používání dlouhodobého majetku. Mají přesně vystihnout míru opotřebení dlouhodobého majetku. Podnik si může zvolit vlastní účetní odpisy (vnitropodnikové směrnice), ale při vyplňování daňového přiznání musí dbát na to, že může uplatnit pro zjištění základu daně z příjmu jen výši daňových odpisů. Obvykle se používají tyto metody ke stanovení účetních odpisů:

¨ časové – vychází z doby použitelnosti majetku. Podnik si sám stanoví upotřebitelnost dlouhodobého majetku. Určí se tedy doba, po kterou chceme majetek v podniku využívat. Doba nemusí odpovídat době odpisu podle §30 zákona o dani z příjmu. Odpisová sazba v % se vypočítá jako 100/doba životnosti.

¨ výkonové – jsou odvozeny z množství výkonů, které podnik předpokládá získat prostřednictvím daného majetku. Při této metodě dělíme vstupní cenu výkonem majetku. Výkonem majetku může být např. počet vyrobených ks výrobků nebo počet ujetých km apod.

¨ dle daňových odpisů – na základě vnitřních směrnic podniku

Účetní odpisy se počítají z pořizovací ceny, ve které je majetek oceněn v účetnictví. Odepisuje se jen do výše této ceny. Odpisy se účtují měsíčně a zaokrouhlení výše odpisu je na celé koruny nahoru. Po sečtení každoročně provedených odpisů zjistíme tzv. oprávky. Oprávky představují sumu provedených odpisů u konkrétního majetku a jejich odečtením od pořizovací ceny zjistíme zůstatkovou cenu.

Záložka „Účetní odpis“ v činnosti Odpisovaný majetek poskytuje uživateli následující údaje (viz obr. 3):

¨ způsob odpisování - neodpisovat (tato volba je plně na rozhodnutí firmy)

- dle času (nutno uvést plánovaný celoživotní výkon odp. majetku v měsících)

- dle výkonu (nutno uvést plánovaný celoživotní výkon odp. majetku v měsících + roční výkon + MJ)

- dle daň. odp. – daňové odpisy se provádí 1x ročně, účetní odpisy lze měsíčně, ale jejich měsíční částka je odpovídající část daňového nároku. Poslední měsíc v účetním období je nutno provést nejprve roční daňový odpis a pak teprve účetní odpis za poslední měsíc v účetním období, program automaticky vyrovnává případný rozdíl.

- dle ČÚS 708 rovnoměrně – jedná se o způsob odepisování dlouhodobého majetku pro některé vybrané účetní jednotky, které vedou účetnictví podle Vyhlášky č. 410/2009 Sb.

¨ pořizovací cena – je automaticky naplněna z pohybu (události) pořízení odpisovaného majetku

¨ zůst. cena – je automaticky dopočítávána (pořizovací cena mínus suma dosud provedených odpisů u konkrétní karty odpisovaného majetku)

¨ plán. celož. výkon – uvádí se u účetních odpisů prováděných podle času a podle výkonu

¨ roč. výkon – uvádí se u účetních odpisů prováděných podle výkonu

¨ MJ - uvádí se u účetních odpisů prováděných podle výkonu

¨ snížení odpisu % - o uvedené procento se snižuje vypočtený účetní odpis

¨ odpis v měs. zař. – možnosti jsou Podle parametrů odp. majetku, Odepisovat, Neodepisovat. Standardně uživatel použije Podle parametrů odp. majetku, změní je pouze v případě, že pro konkrétní kartu, případně „druh“ karet chce použít jiný způsob než je uveden v Parametrech, které jsou společné pro účetní odpis všech karet.

¨ odpis v měs. vyř. – stejné jako předchozí atribut

V případě volby způsobu odepisování „dle ČÚS“ jsou potom pro uživatele dostupné ještě následující atributy:

¨ procento – určuje výši zbytkové hodnoty odpisovaného majetku. Majetek se odepisuje tak dlouho, dokud není dosaženo této hodnoty.

¨ měsíc/rok od – do – určuje období začátku a konce odepisování

obr.3

Účetní odpis se provádí pomocí programovatelné šablony „účetní odpisy“. Uživatel v hlavním menu aktivuje činnost Nový proces – Odpisovaný a spravovaný majetek – proces „Dl. MO – účetní odpis měs.“. Na následujícím obrázku (viz obr. 4) je pro uživatele k dispozici viditelný formulář, který se mu automaticky spustí po aktivaci daného procesu a zároveň se předplní i období za které má být účetní odpis proveden (následující měsíc po posledním měsíci provedení účetních odpisů).

Šablona účetních odpisů pracuje s pořizovací cenou k datu, tj. lze např. do budoucnosti zadat technické zhodnocení.

Na následujícím obrázku (viz obr. 4) je pro uživatele k dispozici viditelný formulář, který se mu automaticky spustí po aktivaci daného procesu a zároveň se předplní i období za které má být účetní odpis proveden (následující měsíc po posledním měsíci provedení účetních odpisů).

Při výpočtu "účetních odpisů" šablonou je možné vybrat umístění, za které se má udělat odpis, (tj. je možné odepsat najednou skupinu majetku vymezenou jednotným umístěním) nebo vypočítat odpisy pro veškerý majetek přístupný (zápis) danému uživateli. Po stisku tlačítka OK jsou předplněny jednotlivé řádky s měsíčními účetními odpisy za karty odpisovaného majetku dle zvolené varianty.

Při opravách dat je nutno dát pozor na výpočet již vyřazených karet – šablony s kartami s příznakem „vyřazeno“ nepočítají.

obr. 4

Po stisku tlačítka OK jsou předplněny jednotlivé řádky s měsíčními účetními odpisy za všechny karty odpisovaného majetku.

Uživatel tyto pohyby (jednotlivé události odpisovaného majetku) zapíše (ikona disketa nebo klávesa ESC – následně volba Zapsat a ukončit). Poté se uživateli zobrazí možnost zaúčtování jednotlivých pohybů (událostí) účetního odpisu[2].

V případě, že uživatel potřebuje provést částečné vyřazení odpisovaného majetku a zároveň zachovat správnou funkčnost šablony účetních odpisů, musí použít typ „mimořádný odpis“ účetní (implicitně je předplněno typ běžný) [3] . Ten spouští nezávisle na měsíčních odpisech speciálním procesem ODVC01 DI.MO - částečné vyřazení (podrobný popis v kapitole 4. Změny odpisovaného majetku).

3.3 Daňový odpis

Daňové odpisy se používají pro účely výpočtu daňového základu podniku pro daň z příjmů. Způsob výpočtu je tedy upraven zákonem o dani z příjmů (§26 - §32a Zákona č. 586/1992 Sb. o daních z příjmů[4]). Daňové odpisy se počítají zpravidla na konci účetního období. Daňový odpis se počítá z pořizovací ceny majetku a odepisuje se do výše pořizovací ceny. Zaokrouhlení výše odpisu je na celé koruny nahoru (tj. nikoliv matematicky. Tzn., že i kdyby výše odpisu byla 7 500,01 Kč, odpis se zaokrouhlí na 7 501Kč.).

Hodnota daňových odpisů je zákonem povolenou maximální výší odpisů, které lze uplatnit jako daňově uznatelnou položku při výpočtu základu daně z příjmů.

Problematiku daňových odpisů je možno rozčlenit do několika etap.

¨ Kdy se odepisuje?

Odepisovat lze pouze majetek, který firma vlastní a má jej evidovaný v majetku ke konci kalendářního roku (příp. ke konci hospodářského roku). Musí být tedy zařazený do používání na účtech 02x, 01x k 31.12. roku.

Odepisovat lze i technické zhodnocení pronajatého hmotného majetku, je-li hrazeno nájemcem, není-li o výdaje na technické zhodnocení zvýšena vstupní cena majetku u vlastníka a dá-li k tomu pronajímatel písemný souhlas (§28, odst. 3).

U majetku, který firma v průběhu roku prodala, ale měla jej v evidenci k 1.1. roku kalendářního (příp. 1. dni měsíce roku hospodářského), může uplatnit ½ ročního odpisu. Majetek, který je pořízen v průběhu roku a k 31.12. roku je vyřazen z evidence, nelze odepisovat vůbec (obdobně pro hospodářský rok). Daňový odpis se vypočítá jako roční nárok.

¨ Z čeho se odepisuje?

Odepisuje se vždy z pořizovací ceny (ta je v zákoně o dani z příjmů definována v § 29). V zásadě se dá říci, že se jedná o cenu, za kterou byl majetek pořízen. Technické zhodnocení v 1. roce odepisování majetku se stává součástí vstupní ceny, je tedy nutné ji o něj zvýšit. Toto neplatí pro nemovité kulturní památky, kde má technické zhodnocení vlastní režim.

¨ Jak se odepisuje?

V prvním roce odepisování zatřídí poplatník hmotný majetek do odpisových skupin uvedených v příloze č. 1 k zákonu o dani z příjmů. Nelze-li majetek podle této přílohy zařadit, potom automaticky patří do 2. odpisové skupiny. Odepisuje se rovnoměrně (§ 31) nebo zrychleně (§ 32)[5]. Způsob odepisování si volí každý sám a tento způsob nelze dále měnit. V případě, že byl majetek špatně zatříděn, je nutné ho přeřadit do jiné odpisové skupiny a daňové odpisy přepočítat od počátku daňového odepisování. Pokud se změna týká více zdaňovacích období a změna zatřídění majetku znamená změnu daňové povinnosti, je potřeba podat dodatečné daňové přiznání.

Způsob odepisování je tedy:

¨ rovnoměrně – výpočet rovnoměrných odpisů upravuje § 31 zákona o dani z příjmů odst. a). Zákon určuje sazby pro výpočet odpisu. Tyto sazby jsou vyjádřeny procentem.

1. rok vstupní cena * sazba v 1. roce

100

další roky vstupní cena * sazba v dalších letech

100

¨ zrychleně – výpočet zrychlených odpisů upravuje § 32 zákona o dani z příjmů. Zákon určuje koeficienty pro výpočet odpisu.

1. rok vstupní cena

koeficient v 1. roce

další roky 2 * zůstatková cena

koeficient v dalších letech – počet již odpisovaných let

Záložka „Daňový odpis“ v činnosti Odpisovaný majetek poskytuje uživateli následující údaje (viz obr. 5):

¨ způsob odpisování - jedná se o varianty dané Zákonem o dani z příjmu.

- neodpisovat

- rovnoměrně (nutno určit odpisovou skupinu)

- zrychleně (nutno určit odpisovou skupinu)

- rovn. NH (podle Zákona o dani z příjmu nutno určit počet měsíců

odpisování a počet měsíců odpisování po provedení technického zhodnocení). Je povoleno pouze jedno technické zhodnocení měsíčně!

- individuální odpis (nutno určit odpisovou skupinu a vyplnit záložku Individuální odpis)

¨ měsíců – udává se u způsobu daň. odpisů rovn. NH

¨ odpisová skupina – výběr z číselníku odpisových skupin

¨ po TZ udává se u způsobu daň. odpisů rovn. NH

¨ vstup. cena – automaticky naplněna při pořízení daného odpisovaného majetku

¨ zůst. cena – dopočítává program automaticky (vstupní cena mínus suma provedených daňových odpisů konkrétního odpisovaného majetku)

¨ datum prvního TZ (+ odpisů) – datum je automaticky naplněn z provedeného pohybu prvního technického zhodnocení (tj. z události odpisovaného majetku) + atribut odpisů znamená, kolik již bylo provedeno celkem ročních daňových odpisů po prvním provedeném technickém zhodnocení

¨ datum posl. TZ (+ odpisů) - datum je automaticky naplněn z provedeného pohybu posledního zaznamenaného technického zhodnocení (tj. z události odpisovaného majetku) + atribut odpisů znamená, kolik již bylo provedeno celkem ročních daňových odpisů po dosud posledním provedeném technickém zhodnocení

¨ snížení odpisu % - o uvedené procento se snižuje vypočtený daňový odpis

¨ soubor majetku - majetek je hlavním předmětem souboru

- nadřízený artikl

- v případě potřeby vytvoření souboru majetku je nutno konkrétní kartu odpisovaného majetku určit jako hlavní majetek souboru (zaškrtnout daný atribut) a u karet, které jsou pak součástí tohoto souboru určit tut kartu jako nadřízený artikl. Vytvoření souboru má však spíš pouze informační charakter (např. aby uživatel věděl, který majetek k čemu patří apod.), ale pro zpracování daňových odpisů to nemá smysl[6].

obr. 5

Daňový odpis se provádí pomocí programovatelné šablony „daňové odpisy“. Uživatel v hlavním menu aktivuje činnost Nový proces – Odpisovaný a spravovaný majetek – proces „Dl. MO – daňový odpis roční.“. Na následujícím obrázku (viz obr. 6) je pro uživatele k dispozici viditelný formulář, který se mu automaticky spustí po aktivaci daného procesu a zároveň se předplní i období za které má být daňový odpis proveden (následující rok po posledním roce provedení daňových odpisů).

Šablona daňových odpisů pracuje s pořizovací cenou k datu pouze pro variantu rovnoměrně nehmotný majetek. Při opravách dat pozor na výpočet již vyřazených karet – šablony s kartami s příznakem „vyřazeno“ se nepočítají.

Pro zahájení odepisování karty šablona pracuje podle následujícího pravidla: jestliže se datum zařazení = datu zahájení daňových odpisů, pak zahájí odpis v souladu se Zákonem o daních z příjmu v měsíci zařazení, či měsíci následujícím (rovnoměrně NM). Jestliže bude datum (měsíc) zařazení a datum (měsíc) zahájení daňových odpisů rozdílné, tak použije Datum zahájení DO. Pro správnou funkčnost šablony je nezbytné dodržet podmínku: existuje pouze jedno technické zhodnocení měsíčně u karet se způsobem odpisování Rovnoměrně NM!

Při výpočtu "daňových odpisů" šablonou je možné vybrat umístění, za které se má udělat odpis, (tj. je možné odepsat najednou skupinu majetku vymezenou jednotným umístěním) nebo vypočítat odpisy pro veškerý majetek přístupný (zápis) danému uživateli. Po stisku tlačítka OK jsou předplněny jednotlivé řádky s daňovými odpisy za karty odpisovaného majetku dle zvolené varianty k poslednímu dni daného účetního období (kalendářní rok, hospodářský rok).

Uživatelé spouští nový proces nezávislý na ročním odpisu, tj. speciální proces ODVC01 DI.MO - částečné vyřazení (podrobný popis v kapitole 4. Změny odpisovaného majetku).

V případě, že uživatel účetní odpisy vytváří podle metody „účetní podle daňových“, tak platí pravidlo, že poslední měsíc v účetním období je nutno provést nejprve roční daňový odpis a pak teprve účetní odpis za poslední měsíc v účetním období, program následně automaticky vyrovnává případný rozdíl.

obr. 6

Po stisku tlačítka OK jsou předplněny jednotlivé řádky s daňovými odpisy k poslednímu dni daného roku.

Uživatel tyto pohyby (jednotlivé události odpisovaného majetku) zapíše (ikona disketa nebo klávesa ESC – následně volba Zapsat a ukončit). Tím je proces daňového odpisu ukončen[7].

V případě, že uživatel potřebuje provést částečné vyřazení odpisovaného majetku a zároveň zachovat správnou funkčnost šablony daňových odpisů, musí použít typ „mimořádný odpis“ daňový (implicitně je předplněno typ běžný) [8] .

3.4 Individuální odpis

Tuto činnost (činnost Odpisovaný majetek – záložka Individuální odpis) lze využít pro výpočet mimořádného odpisu podle par. 30a Zákona o dani z příjmu ve znění platném od 20.7.2009. K tomuto výpočtu je nutné dodržet několik zásad:

¨ u způsobu odpisování musí být zvolen „individuální odpis“

¨ musí být nastavena odpisová skupina (1 nebo 2)

¨ odpisovaný majetek musí být zařazen a uvedena jeho vstupní cena

Poté je možno výpočet individuálních odpisů provést:

¨ ručně – od data zařazení, případně zahájení daňového odpisu vyplnit po měsících jednotlivé částky odpisu. Při výpočtu ročních daňových odpisů šablona Daňový odpis kontroluje sumu měsíčních hodnot na hodnotu vstupní ceny. Nesoulad ohlásí a výpočet neprovede.

¨ automaticky – pomocí importu, který je součástí doplňující vlastnosti formuláře „Import individuálního odpisu“. Tento import se aktivuje stiskem příslušného tlačítka na základní nabídce (menu Obecné – Nabídky – Základní), následně automaticky předplní dané odpisy a uživatel pak tyto hodnoty zapíše (ikona disketa). Jak z výše uvedeného vyplývá, pro automatický výpočet je nutno mít v systému k dispozici import a danou doplňující vlastnost formuláře (obojí může být dodáno formou balíčku nebo se obraťte přímo na svého implementátora).

obr. 7

3.5 Záložka „Výběr“

Po aktivaci činnosti „odpisovaný majetek“ má uživatel nejprve k dispozici záložku „Výběr“ (viz obr. 8), kde si může podle svých potřeb vyfiltrovat potřebnou množinu dat. Je možno vybírat podle následujících atributů:

¨ druh artiklu, identifikace artiklu, název artiklu – možno využít všechny tři atributy najednou nebo každý z nich (nebo jeho část, např. část názvu) samostatně. Pod pojmem artikl jsou samozřejmě míněny jednotlivé karty odpisovaného majetku.

¨ všechny – zobrazí se všechny karty odpisovaného majetku

¨ jen hlavní předměty souboru – zobrazí se karty odpisovaného majetku, které mají na záložce „daňový odpis“ zatržen atribut „majetek je hlavním předmětem souboru“

¨ jen podřízené předměty - zobrazí se karty odpisovaného majetku, které mají na záložce „daňový odpis“ vyplněn nadřízený artikl (tzn. proto, že mají nadefinován nadřízený artikl jsou automaticky podřízené)

¨ jen samostatné předměty - zobrazí se karty odpisovaného majetku, které na záložce „daňový odpis“ nemají uveden žádný nadřízený artikl, ani nejsou hlavním předmětem souboru

¨ hlavní a podřízené předměty - zobrazí se karty odpisovaného majetku, které mají na záložce „daňový odpis“ zatrženo „majetek je hlavním předmětem souboru“ a nebo mají uveden nadřízený artikl (tato možnost je proto, aby si uživatel mohl kompletně zobrazit celý vytvořený soubor majetku – tzn. hlavní majetek souboru a jeho podřízené artikly)

¨ po pravé straně záložky „výběr“ lze kombinovat výběr za všechny/vyřazené/nevyřazené karty zároveň i k datu. Uživatel si pak může tyto karty ještě blíže vyfiltrovat určením data zařazení nebo vyřazení od – do.

¨ vybírat karty odpisovaného majetku lze i podle zůstatkové ceny

¨ další zaškrtávací atributy se týkají provádění účetních a daňových odpisů. Levý sloupeček se týká možností týkajících se účetních odpisů (účetně neodpis., dle času, dle výkonu, dle daňových odpisů), pravý sloupeček je určen pro daňové odpisy (daňově neodpisovaný, rovnoměrný odpis, zrychlený odpis, rovnoměrný odpis – NM, individuální odpis).

¨ další možnosti výběru jsou podle odpisové skupiny, umístění, jednotlivých selektorů nebo třídy SKP

¨ kategorie artiklu – zde jsou možnosti hledání majetku: Je, Není, Byl, Nebyl, tzn. „je“=k dnešnímu datu je v kategorii, „není“=k dnešnímu datu není v kategorii, „byl“=není v kategorii, ale byl, „nebyl“=není a nikdy nebyl v kategorii

Vzhledem k tomu, že u každé kategorie karty odpisovaného majetku lze nastavit období platnosti, lze podle tohoto období i vyfiltrovat výběr. Kategorie je možno vybírat podle těchto kritérií:

¨ platné i neplatné – tj. všechny kategorie z hlediska platnosti

¨ platné dnes – uživateli se zobrazí všechny kategorie, jejichž období platnosti od – do je aktuální pro dnešní datum

¨ neplatné dnes - uživateli se zobrazí všechny kategorie, jejichž období platnosti od – do je neaktuální pro dnešní datum

¨ platné k datu - uživateli se zobrazí všechny kategorie, jejichž období platnosti od – do je aktuální pro zadané datum, tzn. uživatel si může najít ty kategorie, které byly platné např. k 1.1.2005

¨ neplatné k datu - uživateli se zobrazí všechny kategorie, jejichž období platnosti od – do je neaktuální pro zadané datum

¨ v případě, že uživatel u jednotlivých karet využije nastavení palety barev u kategorie artiklu, lze vyhledávat i podle palety barev

¨ vyhledávat lze i podle uživatele, který majetek do systému zapsal a podle Výběru (v případě, že má uživatel nadefinován nějaký vlastní Obecný výběr)

obr. 8

3.6 Předlohy výstupu

Po stisku ikonky „tiskárna“ nebo po aktivaci činnosti „Tisk“ z menu Volby má uživatel k dispozici následující předlohy výstupu:

¨ Invent. přehled daň.+tech.zhod – klasická sestava, kde má uživatel k dispozici základní údaje o majetku (číslo, název, datum zařazení, datum vyřazení), daňových odpisech (vstupní cena daňová, zůstatková cena daňová, hodnota daň. odpisu), provedeném technickém zhodnocení. Kromě toho má informaci o celkových letech odepisování majetku, jeho odpisové skupině a příslušném účetním selektoru.

¨ Inventura ke dni – se součtem – sestava typu Excel, kde uživatel jako první po její aktivaci zadává datum, ke kterému má být inventura vytvořena. Uživatel má následně k dispozici inventurní soupis, kde jsou základní údaje o majetku, datum posledního technického zhodnocení + celkem suma TZ, účetní a daňová pořizovací cena, suma účetních a daňových odpisů k danému dni, účetní a daň. odpis v období a výše zůstatkové ceny účetní a daňové.

¨ Karta IMO ke dni – klasická sestava, po jejíž aktivaci uživatel zadává nejprve datum, ke kterému chce mít následující informace k dispozici. Tato sestava poskytuje komplexní informace o dané kartě, tzn. identifikaci, název, datum zařazení a veškeré údaje k účetním a daňovým odpisům.

¨ Stručný inventurní přehled – klasická sestava, která uživateli poskytuje komplexní informace potřebné pro inventurní přehledy majetku (tzn. datu zařazení, případně i vyřazení, ceně vstupní, ceně zůstatkové, počtu odpisů, způsobu odepisování, organizačním selektoru, veškerých údajích ohledně provedených účetních a daňových odpisů).

¨ Stručný přehled s cenou – klasická sestava, která poskytuje pouze základní údaje o kartě majetku, tzn. identifikaci, názvu, org. selektoru, pořizovací ceně účetní a daňové a zůstatkové ceně účetní a daňové + celkový součet za uvedené ceny.

4. Změny odpisovaného majetku (tj. události)

Tato činnost poskytuje uživateli přehled jednotlivých provedených pohybů (tj. událostí) odpisovaného majetku. Tyto pohyby se v této činnosti pouze zobrazují, tzn. jsou k dispozici pro prohlížení, nelze je zde vytvářet. Vytvoření jednotlivých pohybů se provádí procesním způsobem, tzn. každý druh pohybu (příjem, výdej apod.) má svůj druh procesu, který musí uživatel aktivovat (v hlavním menu – Nový proces – Odpisovaný a spravovaný majetek) a ten mu umožňuje pohodlným způsobem zadat jednotlivé pohyby.

Tuto činnost má uživatel dostupnou v hlavním menu v činnosti Odpisovaný majetek – Změny odpisovaného majetku. Po aktivaci činnosti se uživateli nejprve nabídne záložka „Výběr“ (viz popis níže), kde si vyfiltruje množinu dat, která ho zajímá k prohlížení.

Při prohlížení událostí IMO (tj. změny odepisovaného majetku) daný uživatel vidí jen události týkající se těch karet, ke kterým má alespoň právo čtení; zápis (oprava) změn lze provést jen k těm kartám, k jejichž umístění má daný uživatel nastaveno právo zápisu.

4.1 Atributy

Jednotlivé atributy této činnosti má uživatel k dispozici na záložce „Událost“. V tento okamžik je má uživatel k dispozici pouze pro prohlížení (viz obr. 9). Jednotlivé atributy si popíšeme v souvislosti s možností vytvářených pohybů odpisovaného majetku (tzn. událostí).

Způsob provádění účetních a daňových odpisů jsme si již popsali (kapitola 3.2 a 3.3). Jako další je možno vytvářet pohyby (události) typu příjem a výdej. K tomuto účelu má uživatel k dispozici připravené procesy v hlavním menu – Nový proces – Odpisovaný a spravovaný majetek

obr. 9

Dl. MO – zařazení

Tento proces uživateli slouží pro zařazení odpisovaného majetku (např. při jeho nákupu) nebo pro provedení pohybu (události) technického zhodnocení. Po spuštění tohoto procesu uživatel vstupuje následující atributy:

¨ na základě číselné řady a druhu daného procesu jsou předplněny atributy týkající se procesu (číslo, identifikace operace, pořadí, název)

¨ datum – předplňuje se aktuální datum (možno ho přepsat)

¨ druh – může nabývat hodnot příjem nebo technické zhodnocení[9] (výběr z překryvného seznamu). Lze zadávat i vícekrát hodnotu příjem pro jednu kartu.

¨ popis pohybu – např. nákup, pořízení apod.

¨ adresát

¨ artikl – výběr z číselníku karet odpisovaného majetku

¨ částka – tato částka je při pořízení majetku následně automaticky zapsána do karty odpisovaného majetku jako pořizovací cena. Při provádění technického zhodnocení je na kartě odpisovaného majetku o částku technického zhodnocení pořizovací cena navýšena (i cena zůstatková).

¨ atributy „upravuje cenu“ – jsou na základě druhu procesu automaticky nastaveny pomocí masky operace

Po zadání všech potřebných atributů je nutno daný pohyb zapsat (klávesa ESC nebo ikona „disketa“). Uživatel pak zvolí možnost „Zapsat a ukončit“ a automaticky je mu k dispozici možnost zaúčtování daného pohybu (události)[10].

V praxi může nastat i situace, že uživatel potřebuje zařadit kartu odpisovaného majetku, která má již částečně provedeny odpisy v jiném informačním systému. Pak existují dvě možnosti řešení:

¨ v případě, že to jiný informační systém dovoluje, je proveden import, při němž se historická data dané karty pak natáhnou do IS BM pomocí importu zcela automaticky

¨ v případě, že import není technicky možný, je nutno historická data dané karty vložit do systému ručně a to následujícím způsobem:

- nelze zařadit žádnou kartu před datum inicializace

- v parametrech odpisovaného majetku zaškrtnout „neomezovat datum události“

- založit druhy artiklů pro odpisovaný majetek

- definovat obecné předkontace pro zaúčtování dokladů

- zadat nové karty – vyplnit způsob daňového a účetního odepisování. Pro účetní odpis dle času zadat i plánovaný celoživotní výkon v měsících. Pro daňový odpis je nutno zadat odpisovou skupinu a způsob odepisování.

- zařadit majetek, tj. událost příjmu s pořizovací cenou procesem DI.MO – Prvotní nastavení – ceny (je možno provést hromadně podle data zařazení do číselných řad po letech)

- procesem DI.MO – Prvotní nastavení – odpisy zadat informace o daňových odpisech a technickém zhodnocení.

- účetní odpisy se ručně (bez šablony) nastaví pomocí procesu DI.MO – Účetní odpis měs., aktualizovat pouze zůstatkovou cenu účetní ve výši dosud odepsáno.

- po kontrole vstupních údajů opětovně v parametrech zaškrtnout „neomezovat datum události“

Dl. MO - vyřazení

Tento proces uživateli slouží pro vyřazení odpisovaného majetku (např. prodej, likvidace apod.). Po spuštění tohoto procesu uživatel vstupuje následující atributy:

¨ na základě číselné řady a druhu daného procesu jsou předplněny atributy týkající se procesu (číslo, identifikace operace, pořadí, název)

¨ datum – předplňuje se aktuální datum (možno ho přepsat)

¨ druh – je předplněno výdej a v dalším atributu se určuje způsob výdeje (prodej, likvidace, škoda, dar) – na výběr je z překryvného seznamu. Pokud účel výdeje není ani jedna z uvedených možností, uživatel nechá předplněnou „pomlčku“ a účel výdeje zapíše do popisu pohybu (události)

¨ popis – bližší popis čeho se výdej týká

¨ adresát

¨ typ – pro vyřazení může nabývat hodnotu běžný. Pouze v případě, že uživatel potřebuje provést částečné vyřazení odepisovaného majetku a zároveň zachovat správnou funkčnost šablon účetních a daňových odpisů, musí použít typ „mimořádný“ pro odpis daňový i účetní (typ mimořádný odpis je podrobně vysvětlen ve Slovníku pojmů).

¨ částka – automaticky předplněna z karty majetku zůstatková cena

¨ atributy „upravuje cenu“ – jsou na základě druhu procesu automaticky nastaveny pomocí masky operace

Po zadání všech potřebných atributů je nutno daný pohyb zapsat (klávesa ESC nebo ikona „disketa“). Uživatel pak zvolí možnost „Zapsat a ukončit“ a automaticky je mu k dispozici možnost zaúčtování daného pohybu (události)[11].

Pro mimořádný odpis platí: Uživatel proces Dl. MO - částečné vyřazení zahájí z nabídky Nový proces skupina Odepisovaný a spravovaný majetek. Po spuštění operace odvcm1 komponenty ODP se uživateli nabídne k vyplnění šablona, kde je třeba určit druh artiklu, artikl, datum události a hodnotu vyřazované části. Šablona spočítá % odepsání účetní i daňové k okamžiku výpočtu a předplní 4 události: 1x vyřazení (= minusový příjem), 2x účetní odpis, 1x daňový odpis. Poté následuje zaúčtování částečného vyřazení, kde předkontace nabízí pouze syntetické účty používané pro samostatné movité věci a soubory.

V případě, že firma používá variantu účetních odpisů dle daňových, nelze použít vypočtenou hodnotu účetního odpisu "doodepsání do 100%", je třeba ji vypočítat a ručně opravit (tj. korektní je pouze před 1. účetním odpisem v účetním období).

Při použití odpisu typu „mimořádný“ je vhodné zkontrolovat sestavy nad odpisovaným majetkem, zda korektně filtrují události běžné a mimořádně a případně je upravit. V závislosti na parametrech odpis v měsíci vyřazení je poté nutno aktivovat účetní odpis – v případě, že majetek má nenulovou účetní zůstatkovou cenu v okamžiku vyřazení.

Konkrétní příklad mimořádného odpisu:

V případě, že uživatel potřebuje provést částečné vyřazení odepisovaného majetku a zároveň zachovat správnou funkčnost šablon účetních a daňových odpisů, musí použít typ „mimořádný odpis“ daňový i účetní. Vysvětlíme si postup ohledně částečného vyřazení na konkrétním případu. Firma si pořídila např. traktor s kartáčem a dalším příslušenstvím. Dne 31.7.2004 byl zadán běžný příjem na částku 173 184,87 Kč. Poté následuje sled těchto událostí (výpočty zaokrouhleny směrem nahoru):

¨ účetní odpis k datu 31.12.2004 (173 184,87 / 72) * 5 = 12 030,-

¨ účetní odpis k datu 31.12.2005 (173 184,87 / 72) * 12 = 28 872,-

¨ účetní odpis k datu 31.12.2006 (173 184,87 / 72) * 12 = 28 872,-

¨ účetní odpis k datu 31.01.2007 (173 184,87 / 72) * 1 = 2 406,-

¨ účetní odpis k datu 28.02.2007 (173 184,87 / 72) * 2 = 4 812,-. Následně se odečtou již provedené účetní odpisy za rok 2007. V tento okamžik je částka 2 406,- (4812 – 2406) uplatněna v únoru.

¨ K DATU 09.03.2007 DOJDE K ČÁSTEČNÉMU VYŘAZENÍ (kartáče) Z KARTY TRAKTORU. V tomto okamžiku je nutno provést několik nestandardních záznamů:

- 09.03.2007 je nutno zadat běžný příjem zápornou částkou, tj. minus 39 747,90 (hodnota kartáče) – vyřazení části

- 09.03.2007 je nutno provést účetní odpis s typem události „mimořádný“ jako doodepsání vyřazené části kladnou částkou 22 631,-. Tento úkon provede uživatel ručním zápisem, bez pomoci šablony. Částku odpisu je nutné si vypočítat.

- 09.03.2007 je nutno provést účetní odpis s typem události „mimořádný“ jako vynulování odpisů z událostí, tj. minus 39 747,-, jinak se zůstatková cena vypočítává ze snížené pořizovací ceny mínus celkem dosud odepsáno (tj. z původní vyšší ceny) – chybná kladná až minusová hodnota zůstatkové ceny.

¨ standardní účetní odpis k datu 31.03.2007 se potom počítá jako odpis za měsíc 01/2007 (2 406,-) + odpis za měsíc 02/2007 (2 406,-) + odpis za měsíc 03/2007 (1 854,-). Celkový odpis má hodnotu 6 666,-. Následně se odečtou již provedené odpisy za rok 2007, takže odpis za 01-03/2007 je částka 1 854,- (6666 – 4812) – neodečítají se odpisy „mimořádné“.

Podobné kroky je nutno provést i pro daňové odpisy. Po vyřazení kartáče (operace vyřazení je jedna událost společná pro aktualizaci účetních i daňových cen) je nutno ručně provést záznam daňový odpis ve výši dosud uplatněných daňových odpisů vyřazené části majetku, který aktualizuje zůstatkovou cenu daňovou. Tento záznam je nutné odlišit od běžných záznamů daňových odpisů, proto bude zapsán s typem „mimořádný“.

Jak jsme se již zmínili v kapitole 3.1. má uživatel po stisku pravého tlačítka myši na tučném atributu „Artikl“ k dispozici řadu činností, které mu mohou přinést podrobnější informace o daném majetku.

Podobně si uživatel může vyvolat po stisku pravého tlačítka myši na tučném atributu „Adresát“ další potřebné informace vztahující se k adresátovi.

Uživatel jistě využije i kombinaci kláves Ctrl S – Suma stran. Poskytuje uživateli přehled sumárních částek nad zobrazenými pohyby (událostmi) majetku. Je vysoučtovaná suma účetních odpisů, suma daňových odpisů a celkem suma všech zobrazených pohybů (událostí).

Po stisku klávesy Ctrl D má uživatel k dispozici dokumenty, které souvisejí s daným pohybem (událostí) majetku, např. při zpracovávání došlé pošty může daná pracovnice nascanovat přijatou fakturu do systému a uživatel, který na základě faktury přijímá nový majetek (v případě, že bude mít nějaké nejasnosti nebo si jen chce ověřit prvotní doklad) má po stisku Ctrl D tento doklad ihned k dispozici. Tyto dokumenty uživatel nevyužívá v okamžiku vytváření daného pohybu majetku, neboť to je má tzv. „v ruce“, ale jsou připraveny pro budoucí použití, např. při zpětné kontrole dokladů, při opravě chyb, zjištění nesrovnalostí apod.

Opravy záznamů provedených pohybů (tzn. jednotlivých událostí) lze provádět:

¨ Běžným přepisem jednotlivých atributů (pouze dokud není operace ukončena. V případě ukončené operace lze opravit pouze atribut „popis“.).

¨ Pomocí odblokovače (viz. pojem „zrušit stav ukončena“ ve slovníku pojmů).

¨ Provedením storna daného pohybu (viz. pojem „storno“ ve slovníku pojmů).

Na záložce „Poznámka“ (viz obr. 10) má uživatel k dispozici komentář k výpočtu daného pohybu (tzn. jak byla událost na dané řádce vypočítána). Z poznámky je zřejmé, jak odpis systém počítal a jakým způsobem a z jakých hodnot jej spočítal.

obr. 10

4.2 Záložka „Výběr“

Záložka „Výběr“ umožňuje uživateli vyfiltrovat si následující zobrazené pohyby majetku (tj. události) podle vlastních zvolených kritérií. Tato záložka se uživateli automaticky aktivuje po spuštění činnosti Změny odpisovaného majetku (hlavní menu – Odpisovaný majetek). Uživatel si může vybírat podle těchto atributů (viz obr. 11):

¨ proces – umožňuje uživateli vyhledávat daný pohyb podle čísla dokladu

¨ datum od – do – možnost určení časového období

¨ druh – výběr jakého druhu se mají pohyby týkat (např. příjem, výdej, účet. odpis, daň. odpis apod.)

¨ umístění – jakého umístění se mají pohyby týkat (uživatel si může vybrat umístění, ke kterému má právo alespoň čtení)

¨ popis – možno vyhledávat i podle popisu (např. když uživatel bude vědět, že v popisu daného pohybu např. zadal slovo „notebook“, tak když při vyhledává zadá do tohoto atributu výraz „%notebook“, tak se mu zobrazí všechny pohyby, které mají kdekoliv v popisu uvedeno notebook).

¨ adresát – možnost vyhledávání podle konkrétního adresáta

¨ stav – v případě potřeby hledání podle stavu procesu, tzn. uživatel může hledat i stornované či stornující doklady

¨ artikl – vyhledávání podle identifikace artiklu (tzn. podle inventárního čísla odpisovaného majetku)

¨ název artiklu – možnost vyhledávání i podle názvu majetku

¨ typ – ve většině provedených pohybů je uveden typ běžný, pouze v případě, že uživatel provedl částečné vyřazení, tak použil typ mimořádný odpis – tímto výběrem tento částečný odpis může snadno vyhledat

¨ selektory – možnost vyhledávání podle konkrétních selektorů

¨ zapsal – hledání podle jména uživatele, který daný doklad (událost) vytvořil

obr. 11

4.3 Předlohy výstupu

Po stisku ikonky „tiskárna“ nebo po aktivaci činnosti „Tisk“ z menu Volby má uživatel k dispozici následující předlohy výstupu:

¨ Doklad o pohybu IMO – klasická sestava, která obsahuje informace o čísle dokladu (tj. v podstatě číslo procesu, kterým byl daný pohyb proveden), identifikaci a názvu majetku, datu pohybu, druhu pohybu (zařazení, vyřazení, odpis apod.) a částce.

¨ Doklad o zařazení IMO – klasická sestava, která uživateli poskytuje všechny informace potřebné k evidenci zařazení majetku (tzn. majetek, způsob účetních odpisů + pořizovací cenu, způsob daňových odpisů, odp. skupinu + vstupní cenu, datum zařazení a částku).

¨ Doklad o vyřazení IMO – klasická sestava, která uživateli poskytuje všechny informace potřebné k evidenci vyřazení majetku (tzn. majetek, způsob účetních odpisů + pořizovací cenu, způsob daňových odpisů + vstupní cenu, datum vyřazení a částku). Při použití odpisu typu „mimořádný“ je vhodné zkontrolovat sestavy, zda korektně filtrují události běžné a mimořádné a případně je upravit.

¨ Odpisy daňové v roce dle OSK – klasická sestava, která poskytuje uživateli přehled celkových daňových odpisů v letech sumarizovaný za odpisovou skupinu, tzn. rok, odpisová skupina, celkem vstupní cena za skupinu a rok a celková částka daňových odpisů za skupinu a rok.

¨ Odpisy účetní v roce za druh ART – klasická sestava, která poskytuje uživateli přehled celkových účetních odpisů v letech sumarizovaný za druh artiklu, tzn. rok, druh artiklu, celkem vstupní cena za druh artiklu a rok a celková částka účetních odpisů za rok a druh artiklu

¨ Odpisy účetní v roce dle OSK – klasická sestava, která poskytuje uživateli přehled celkových účetních odpisů v letech sumarizovaný za odpisovou skupinu, tzn. rok, odpisová skupina, celkem vstupní cena za skupinu a rok a celková částka účetních odpisů za skupinu a rok.

¨ Události se součty za artikl – klasická sestava, poskytující uživateli u každého artiklu (tj. u každého odpisovaného majetku) přehled provedených pohybů (zařazení, techn. zhodnocení, úč. odpis, daň. odpis apod.), jejich datum a částku s mezisoučty za každý artikl a celkem za sestavu.[12]

5. Prognózování odpisů

Tato činnost se nachází v hlavním menu – Odpisovaný majetek – Prognózování odpisů. Po aktivaci této činnosti se uživateli nejprve zobrazí záložka „Výběr“, kde si vybere období (tj. nadefinované účetní období v komponentě účetnictví), za které chce prognózu odpisů spočítat. Při výpočtu prognózy odpisů je možné vybrat umístění, za které se má udělat prognóza odpisu, (tj. je možné odepsat najednou skupinu majetku vymezenou jednotným umístěním) nebo vypočítat prognózu odpisů pro veškerý majetek přístupný (čtení nebo zápis) danému uživateli.

Prognóza poskytuje uživateli informace v jaké výši budou odpisy za zvolené období pokud se nezmění způsob odepisování. Tyto informace jsou přínosem v případě velkých firemních investic, aby měl podnik představu o svých nákladech na odpisy. Prognózování odpisů představuje pro uživatele nástroj, který mu poměrně přesně spočítá odpisy příštích let.

Tato činnost tedy uživateli poskytuje informace o vypočtených odpisech příštích let, tzn. odpisech za zbytek letošního roku a odpisech dalších let (podle období uvedeného na záložce „Výběr“).

Po nadefinování záložky „Výběr“ proběhne výpočet prognózy a uživatel má k nahlédnutí formulář (viz obr. 12), kde jsou ke každé řádce zvoleného období k dispozici následující atributy:

¨ období – název období (jedná se o účetní období, které uživatel definuje v komponentě Účetnictví – Speciální činnosti – Účetní období)

¨ artikl – identifikace druhu artiklu a identifikace artiklu

¨ umístění – identifikace umístění

¨ název artiklu – název odpisovaného majetku (z karty)

¨ účetní odpis – částka účetního odpisu, na kterou je v daném období nárok a dosud není v událostech tohoto období zapsána, tj. celkový nárok je již snížen o hodnotu účetního odpisu realizovaného v daném období

¨ pořiz. cena – hodnota z karty odpisovaného majetku

¨ zůst. cena – částka, která se očekává jako zůstatková cena na konci daného období (tzn. pořizovací cena mínus všechny uskutečněné a prognózované odpisy)

¨ daňový odpis – částka daňového odpisu, na kterou je v daném období nárok a dosud není v událostech tohoto období zapsána, tj. celkový nárok je již snížen o hodnotu daňového odpisu realizovaného v daném období

¨ vstup. cena – hodnota z karty odpisovaného majetku

¨ zůst. cena – částka, která se očekává jako zůstatková cena na konci daného období (tzn. pořizovací cena mínus všechny uskutečněné a prognózované odpisy)

¨ počet odpisů – počet daňových odpisů, které se uplatnily (buď v události odepisování nebo v prognóze předchozích let) v předchozích účetních obdobích

¨ počet odp. ze zv. ceny – počet daňových odpisů po posledním technickém zhodnocení, které se uplatnily v předchozích účetních obdobích (buď v událostech nebo v prognóze)

Na obr. 12 si konkrétně vysvětlíme atributy počet odpisů a počet odp. ze zv. ceny. Karta odpisovaného majetku byla zařazena v r. 2006, tzn. že účetní období 2010 v prognóze správně uvádí, že počet odpisů je 4 (tzn. rok 2006, rok 2007, rok 2008, rok 2009). Aktuální účetní období (tzn. rok 2010) se nezapočítává. Obdobné je to s počty odpisů po provedeném technickém zhodnocení. Na naší ukázkové kartě bylo první technické zhodnocení provedeno v roce 2009, tzn. že období 2010 správně uvádí počet odpisů ze zvýšené ceny 1 (tj. v roce 2009).

obr. 12

Po stisku ikonky „tiskárna“ nebo po aktivaci činnosti „Tisk“ z menu Volby má uživatel k dispozici následující předlohy výstupu:

¨ Odpisovaný majetek H – sestava typu Excel, která u každého artiklu poskytuje informace o pořizovací a zůstatkové ceně účetní, vstupní a zůstatkové ceně daňové a o částce účetních a daňových odpisů. U účetních a daňových odpisů je vždy k dispozici suma za dané období a celková částka za sestavu. Tato sestava umí pracovat nejen s účetním obdobím zadaným jako rok, ale i s účetním obdobím, které je zadáno jako hospodářský rok, tzn. jeho identifikace není rok, ale např. H08, H09 apod. (hospodářský rok může být např. období od 1.4. do 31.3.).

¨ Odpis. maj. – měsíčně – sestava typu Excel, která v podstatě poskytuje uživateli stručný přehled týkající se účetních odpisů (tzn. údaje o artiklu, PC účetní, ZC účetní, plánovaný roční účetní odpis, částku měs. odpisu – i po jednotlivých měsících v daném období a informaci o období od – do).

¨ Odpis. maj. – rok H – sestava typu Excel. Poskytuje uživateli komplexní informace o pohybech na kartě, tzn. uživatel má k dispozici základní údaje o kartě majetku, PC účetní, ZC účetní, VC daňové, ZC daňové, výši daňových a účetních odpisů, počtu odpisů a počtu odpisů ze zvýšené ceny. Tato sestava umí pracovat nejen s účetním obdobím zadaným jako rok, ale i s účetním obdobím, které je zadáno jako hospodářský rok, tzn. jeho identifikace není rok, ale např. H08, H09 apod. (hospodářský rok může být např. období od 1.4. do 31.3.).

¨ Odpis. maj. ORGSEL dle karet – sestava typu Excel, která u každé karty poskytuje informaci o čísle, názvu, organizačním selektoru, PC účetní, ZC účetní, plánovaném ročním účetním odpisu, měsíčním odpisu + zaokrouhleném měs. odp. K tomu jsou účetní odpisy rozpočítané za uvedené období. Tato sestava umí pracovat i s údaji na volné kartě „procento odpisu na střediska“ (tuto volnou kartu má uživatel k dispozici v činnosti Odpisovaný majetek – menu Obecné – Volné karty). Tato sestava není vhodná pro použití v případě, že se účetní odpisy nedělají podle daňových.

¨ Odpis. maj. ORGSEL dle středis – sestava typu Excel, která uživateli poskytuje stejné informace jako výše popsaná sestava s tím rozdílem, že tato sestava je setříděna podle jednotlivých organizačních selektorů a za každý organizační selektor provádí mezisoučet. Stejně jako předchozí sestava i tato umí pracovat s údaji na volné kartě „procento odpisu na střediska“ (tuto volnou kartu má uživatel k dispozici v činnosti Odpisovaný majetek – menu Obecné – Volné karty). Tato sestava není vhodná pro použití v případě, že se účetní odpisy nedělají podle daňových.

6. Evidence výkonů

Tato činnost se nachází v hlavním menu – Odpisovaný majetek – Evidence výkonů. V případě, že se firma rozhodla u některého odpisovaného majetku provádět účetní odpisy výkonové, je zde nutno u daného odpisovaného majetku jeho jednotlivé výkony evidovat. Evidence výkonů se může provádět denní (tzn. každý den je zapsaný výkon daného majetku) nebo za zvolené období (týden, měsíc apod.) s tím, že se pak uvádí počáteční datum zvoleného období. U každého výkonu se eviduje:

¨ artikl – identifikace druh artiklu a artiklu

¨ datum, kdy byl evidovaný výkon proveden

¨ MJ – měrná jednotka výkonu (km, strojové hodiny apod.)

¨ výkon – hodnota výkonu

¨ text – poznámka k provedenému výkonu

¨ zapsal – jméno uživatele, kdo výkon zadal

Pod záložkou Výběr má uživatel možnost nadefinovat si podle zvolených atributů (datum od – do, konkrétní artikl, měrná jednotka apod.) následně zobrazenou množinu dat.

7. Parametry odpisovaného majetku

Tuto činnost má uživatel k dispozici v hlavním menu – Odpisovaný majetek – Parametry odpisovaného majetku. Obsahuje následující atributy:

obr. 13

¨ datum inicializace – toto datum je s dodávkou programu naplněno[13]. Datum inicializace je společné pro komponentu odpisovaný majetek a komponentu Odpisy a opravné položky pohledávek.

¨ datum účetního odpisu – toto datum vyplňuje systém automaticky podle dat, která najde v událostech odpisovaného majetku

¨ rok daňového odpisu - toto datum vyplňuje systém automaticky podle dat, která najde v událostech odpisovaného majetku

¨ neomezovat datum události – implicitně by tento atribut měl zůstat nezaškrtnutý, protože tím je zajištěno automatické hlídání dvou předchozích parametrů (např. nelze pak zařadit nový majetek před tato data). Ale v případě počátečního nastavení systému (tzn. potřeba naplnění dat) je vhodné si tento atribut zaškrtnout. Po dokončení počátečního nastavení jej opět odškrtnout.

¨ odpis v měsíci zařazení/ odpis v měsíci vyřazení – tento parametr se týká pouze účetních odpisů, kde v každé firmě mají svoji vnitropodnikovou směrnici, která určuje, zda se účetně odepisuje majetek v měsíci zařazení nebo v měsíci vyřazení (případně oboje). Nastavení těchto parametrů je platné pro všechny karty odpisovaného majetku. V případě, že uživatel pak na konkrétní kartě potřebuje tento způsob účetního odpisování změnit, nastaví se toto na konkrétní kartě – záložka „účetní odpis“.

[1] Pokud není datum platnosti zadáno, sestava se nezobrazuje správně.

[2] U každého uživatele to na základě jeho analytický účtů může být mírně odlišné, přesto obecné účtování účetních odpisů je ve stylu 551(MD)/07., 08. (Dal)

[3] Bližší popis k mimořádnému odpisu je uveden ve slovníku pojmů – pojem mimořádný odpis (vysvětleno i na konkrétním případu).

[4] Ve znění platném pro r. 2008

[5] Ve znění platném pro r. 2008

[6] Při provádění daňového odpisu systém zjistí odpisovou skupinu, která je uvedena na kartě majetku, který je hlavním předmětem souboru a podle jejího nastavení pak vytvoří daňové odpisy pro podřízené artikly daného souboru. Neodepisuje však soubor jako celek, ale stejně odepisuje každou kartu souboru položkově. Dosud není zatím ani vyřešeno, jak pak např. provést technické zhodnocení podřízené karty.

[7] Daňové odpisy se neúčtují.

[8] Bližší popis k mimořádnému odpisu je uveden ve slovníku pojmů – pojem mimořádný odpis (vysvětleno i na konkrétním případu).

[9] Technické zhodnocení je pojem, který neupravuje žádná právní norma upravující soukromoprávní vztahy (jako je obchodní či občanský zákoník). Je to pojem používaný pouze pro daňové a účetní účely.

Na technické zhodnocení lze pohlížet jak z hlediska účetního, tak i z hlediska daňového. Zákon o daních z příjmů v § 33 definuje technické zhodnocení jako výdaje na dokončené nástavby, přístavby a stavební úpravy, rekonstrukce a modernizace majetku, pokud převýšily u jednotlivého majetku v úhrnu ve zdaňovacím období částku 40 000 Kč. Technickým zhodnocením jsou i uvedené výdaje nepřesahující stanovenou částku, pokud je poplatník na základě svého rozhodnutí neuplatní jako výdaj (náklad) na dosažení, zajištění a udržení příjmů.

[10] Účtování pohybu typu zařazení nebo techn. zhodnocení je nastaveno jako 01., 02. (MD)/04. (Dal).

[11] Účtování pohybu typu vyřazení je nastaveno jako 07., 08. (MD)/01., 02. (Dal).

[12] Pokud uživatelé nebudou mít žádným způsobem definovanou záložku Výběr, může tato sestava poskytovat chaotické informace, resp. sčítat částku zařazení a např. účetního odpisu je v praxi nesmyslné. Ovšem v případě, že si záložku

Výběr vyfiltruje např. pouze za druh pohybu účetní odpis, může mít pak k dispozici velmi praktické a potřebné informace o částce účetních odpisů za jednotlivé karty odpisovaného majetku a celkem za firmu.

[13] Ve většině případů toto předplnění nevadí, ovšem v případě, že uživatel potřebuje zařadit kartu majetku ještě před datum inicializace, je možno toto považovat za chybnou vlastnost IS BM. Implementátor pak musí servisním zásahem toto datum obejít, aby bylo možno majetek zařadit před toto datum.

© 1996-2013 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 11.10.2013


Platby a úhrady

Platby a úhrady

OBSAH

1. Příkaz k úhradě

1.1 Hlavička příkazu k úhradě

1.2 Platby na příkazu

1.3 Uzavření příkazu

2. Události plateb

2.1 Záložka „změny stavu peněz“

2.2 Záložka „položky příkazu k úhradě“

2.3 Záložka „účetnictví“

2.4 Evidence kurzových rozdílů

3. Výpisy z banky

3.1 Ruční zadávání

3.2 Elektronické přijetí výpisu z banky

3.3 Párování plateb

3.4 Přehled spárování

3.5 Události změny stavu peněz

3.6 Odpárování

3.7 Příklady spárování

4. Přecenění závazků a pohledávek v cizí měně

1. Příkaz k úhradě

K pochopení následujícího návodu je vhodná znalost dokumentace „ovládání“. Pro větší názornost si vysvětlíme nejčastěji používané zkratky v tomto dokumentu:

¨ RM – referenční měna – při aplikaci informačního systému v České republice je to CZK. V této měně se vede účetnictví a ve všech činnostech, kde se objevuje zahraniční měna je uváděn kurz vůči této měně. Identifikace referenční měny se nastavuje v činnosti Parametry oceňování (Informační centrum – Oceňování).

¨ ZM – zahraniční měna – jakákoliv měna, která se liší od měny referenční. V této měně může být veden účet či pokladna a dále se může objevovat v událostech souvisejících s nákupem, prodejem, .... Obvykle je uváděn kurz mezi touto měnou a referenční měnou.

¨ ZSP – změna stavu peněz – evidence hotovostních (tj. pokladen) i bezhotovostních (tj. bankovních účtů) pohybů.

¨ VS – variabilní symbol – identifikace platby, která slouží pro úhradu.

1.1 Hlavička příkazu k úhradě

Činnost příkazy k úhradě je dostupná v hlavním menu v činnosti Platby. Po aktivaci této činnosti se uživateli nejprve zobrazí záložka „výběr“. Její atributy uživatel využije v případě, že hledá konkrétní, již vytvořený, příkaz k úhradě. Je možno hledat podle čísla příkazu, podle data vystavení od – do apod. Nadefinovaný výběr je nutno načíst (ikona „disketa“ nebo klávesa PgDn).

Pokud uživatel bude definovat nový příkaz k úhradě, záložku „výběr“ nechává prázdnou a ukončí ji ikonou „šipka zpět“ (pak se mu zobrazí čistý formulář) nebo ikonou „disketa“ (jsou zobrazeny všechny dosud vystavené příkazy k úhradě). Nový příkaz k úhradě uživatel zadává po stisku klávesy F3 nebo ikony „vložení nového záznamu“. Definuje se:

¨ pořadové číslo – automaticky se předplní o jedno vyšší než číslo posledního příkazu (doporučujeme nepřepisovat)

¨ datum vystavení, které je následně považováno za den, kdy má banka zrealizovat úhrady – předplní se aktuální datum

¨ popis příkazu – vlastní popis uživatele

¨ bankovní účet – výběr bankovního účtu, ze kterého bude příkaz k úhradě proveden

Příkaz pak uložit – ikona „disketa“

Tímto krokem má uživatel vytvořenu hlavičku příkazu k úhradě (příklad viz. následující obrázek). Nyní je nutno na příkaz vložit platby, které mají být uhrazeny.

obr.1

1.2 Platby na příkazu

Jednotlivé platby k úhradě se na příkaz přiřadí pomocí klávesy F9 nebo volbou činnosti „události plateb“ pod menu Volby. Po aktivaci této činnosti se uživateli nabídne záložka „výběr“ událostí plateb. Zde je naprosto nejvhodnější způsob nechat tento výběr prázdný (v některých případech je vhodné zadat rok) a v atributu výběr zvolit „nepřikázané závazky“. Tento obecný výběr zajistí, že uživateli se zobrazí dosud neuhrazené závazky, které ještě nejsou součástí žádného vystaveného příkazu k úhradě (viz. obrázek). V některých verzích se tento výběr jmenuje „nepřikázané závazky bez *“, jeho funkčnost však zůstává shodná.

Takto nadefinovaný výběr je pak nutno uložit (ikona „disketa“ nebo klávesa „PgDn“).

obr. 2

Zobrazí se přehled dosud neuhrazených závazků. Uživatel si tento přehled může setřídit (např. podle data splatnosti) a pak je nutné jednotlivé závazky, které chce přenést na příkaz k úhradě označit („zaškrtnutím“ čtverečku označení záznamu).

obr.3

Po jejich označení stiskne klávesu ESC a tyto označené závazky se přenesou na příkaz k úhradě a jsou k dispozici pod záložkou „položky příkazu k úhradě“. Na příkaz k úhradě se přenáší částka závazku „dosud neuhrazeno“. V případě, že je na danou platbu vystaven další částečný příkaz k úhradě, je částka „dosud neuhrazeno“ automaticky snížena o hodnotu příkazu k úhradě (a ta se přenese na příkaz k úhradě). Stiskem ikony „disketa“ se přenesené závazky uloží.

Příklad:

Uživatel má v únoru přijatý závazek ve výši 150 000,- Kč. V březnu vystaví příkaz k úhradě na 100 000,- Kč. Kdyby uživatel v tento okamžik vystavoval příkaz k úhradě, výše částky dosud neuhrazeno, která se mu přenese na příkaz k úhradě je 50 000,- Kč.

Může nastat i další situace: např. 1.4. vystaví uživatel příkaz k úhradě a ze zbývajících 50 000,- Kč dosud nehrazeno částečně uhradí 30 000,- Kč. Při dalším vystavení příkazu k úhradě na daný závazek dne 4.4. se mu správně přenese částka k úhradě 20 000,- Kč.

V případě kombinace hotovostních úhrad, zápočtů a příkazů k úhradě na jednom závazku je nutné vytvořit fiktivní příkazy k úhradě na hotovostní a nepeněžní úhrady faktury (tj.závazku). Stejné pravidlo platí i pro kombinaci zápočtu a příkazu k úhradě a hotovostní úhrady a příkazu k úhradě[1].

obr. 4

V levé části obrazovky je k dispozici přehled všech závazků k úhradě, v pravé části jsou vždy informace k aktuálnímu závazku (tzn. tomu, na kterém je umístěn kurzor). V případě potřeby je samozřejmě možno částku na příkazu změnit (např. pouze částečná úhrada platby), pak je nutno ručně opravit atribut „částka na příkazu“.

Příkazy v úhradě je možno vystavovat i v cizí měně, pak u každé platby bude skutečně vyčíslena hodnota v cizí měně a identifikátor měny (např. EUR).

Pro ideální zpracovaní příkazu elektronickou formou doporučujeme s ohledem na některé bankovní software, aby každý příkaz k úhradě byl vystaven v jednotné měně (tzn. nekombinovat na jednom příkazu platby v CZK a EUR).

Při zobrazení záložky „příkazy k úhradě“ se uživateli znovu zobrazí hlavička příkazu k úhradě, po jejím znovunačtení (volby Obecné – Znovu načíst) se doplní i celková částka PÚ.

obr. 5

Takto vystavený příkaz k úhradě je možno vytisknout (volba předlohy výstupu po stisku ikonky „tiskárna“ – předloha „hromadný příkaz k úhradě“ nebo „příkaz k úhradě – individuální“) nebo po stisku klávesy F5 provést „export příkazu k úhradě“ (v případě, že uživatel používá elektronický platební styk).

1.3 Uzavření příkazu

Po celkové kontrole vystaveného příkazu k úhradě a zejména po jeho odeslání do banky je vhodné tento příkaz uzamknout (klávesa F6 nebo činnost „uzavřít příkaz“ pod menu Volby). Uzavření příkazu znemožní editaci příkazu (tzn. nikdo již nemůže opravovat data, která byla odeslána do banky). V případě, že se příkaz uzavřel a je ještě před odesláním do banky, a je nutno provést určitou změnu, je možno ho znovu otevřít (pod menu Volby aktivovat činnost „zrušit uzavření příkazu“), provést opravu a znovu uzavřít.

2. Události plateb

Tato činnost je pro uživatele dostupná v hlavním menu pod činností Platby. Protože s událostmi plateb uživatel pracuje jak při vystavování příkazu k úhradě, tak i při párování plateb s výpisem z banky (též je lze hradit pokladnou, zápočtem, srážkou ze mzdy apod., a to i částečně), krátce se u této činnosti zastavíme a vysvětlíme si základní atributy, které se této problematiky přímo týkají.

Při aktivaci činnosti „události plateb“ se uživateli nejprve zobrazí záložka „výběr“. Zde je vhodné si množinu prohlížených dat určitým způsobem rozlišit. Je možno si vybrat např. jen závazky nebo pohledávky, s příznakem uhrazené/neuhrazené, s určitým datem splatnosti, konkrétním číslem variabilního symbolu apod. Jednotlivé atributy je samozřejmě možné různě kombinovat (např. zaškrtnout pohledávky, příznak neuhrazené, s datem splatnosti do .....). Nadefinovaný výběr je vždy nutno uložit (ikona „disketa“), viz. dokumentace „ovládání“.

Na následujícím obrázku si vysvětlíme stěžejní atributy, které jsou podstatné jak pro vystavování příkazu k úhradě, tak i při párování plateb s výpisem z banky a uživatel by jim měl rozumnět.

Formulář událostí plateb je rozdělen na dvě části. Horní část je přehled jednotlivých hlaviček plateb (na našem obrázku je pouze jedna vybraná platba), v dolní části jsou vždy informace k platbě, na které je umístěn kurzor.

Obrázek poskytuje ukázku vystavené pohledávky v EUR, přičemž celková částka pohledávky činí 1159,- EUR a částečnou úhradou již bylo uhrazeno 15 250,- Kč, takže zbývá uhradit 659,- EUR (záloha v souvislosti s touto pohledávkou nebyla aplikována).

Vysvětlivky k obrázku:

1. – identifikace bankovního účtu

2. – částka k úhradě v zahraniční měně (zaokrouhlená)

3. – dosud neuhrazeno (v zahraniční měně)

4. – dosud uhrazeno (v referenční měně)

obr. 6

Jak je zmíněno ve vysvětlivkách k obrázku, stěžejními atributy jsou:

¨ B.úč/pok.– identifikace vlastního bankovního spojení nebo pokladny – při vystavování závazků nebo pohledávek se jedná o povinný atribut, který musí být uveden. Uvedený účet se v případě pohledávky obvykle zobrazí na vytištěném dokladu, kde odběratele informuje, kam nám má zaplatit, v případě závazku se uplatní při vystavení příkazu k úhradě, tj. jedná se o účet, ze kterého budeme závazek hradit.

¨ Částka v zahraniční měně (zaokrouhlená) – jedná se o částku k úhradě, tzn. že tato částka se přenese na příkaz k úhradě v případě závazku a v případě pohledávky je to částka, která se bude párovat na částku z výpisu z banky. Doporučujeme zaokrouhlení využívat pouze u závazků, a to v případě že dodavatel částku zaokrouhlil (může se stát, že přijatá faktura je na částku např. 1125,86Kč, ale je zaokrouhlená na 1126,-Kč). Zaokrouhlovat pohledávky nemá při používání elektronického platebního styku smysl.

¨ Dosud neuhrazeno (v zahraniční měně) – v případě, že je platba vystavena pouze v Kč (tj. referenční měně), je i tato částka v Kč. Představuje částku, která je v daném okamžiku z celkové částky platby stále neuhrazena (hodnota tohoto atributu je snižována každou úhradou, tj. i v případě částečných úhrad). Zřejmě nejdůležitější údaj z pohledu úhrad, neboť pro řádně uhrazenou platbu platí, ze je zde hodnota 0.

Dosud uhrazeno – tento atribut se zobrazuje uživateli pouze v referenční měně. Představuje hodnotu, která byla z celkové částky platby dosud uhrazena.

V případě, že je při párování s výpisem z banky uhrazena kompletně celá částka platby, automaticky dojde k zaškrtnutí atributu „uhrazená“ (vedle čísla procesu).

Formulář událostí plateb poskytuje uživateli další informace o platbě, které má uživatel dostupné pod jednotlivými záložkami (viz. popis dále). Každá z těchto záložek opticky rozdělí formulář na dvě části. Ve vrchní části je vždy informace o dané platbě. Ve spodní části je vždy informace o platbě týkající se problematiky dané záložky.

2.1 Záložka „změny stavu peněz“

Tato záložka poskytuje uživateli informace o tom, jak byla daná platba uhrazována na výpisu z banky, tzn. jaká hodnota platby byla s danou fakturou spárována (položka bankovního výpisu, pokladní doklad, zápočet apod.).

V horní části formuláře má uživatel informace o platbě tak, jak je evidována v událostech plateb (na našem obrázku vidíme, že se jedná o pohledávku vystavenou 29.3.2007 a částka k úhradě je 5 853,- EUR). Ve spodní část formuláře jsou informace o platbě tak, jak je evidována na výpisu z banky (na našem obrázku vidíme, že se jedná o výpis č. 00790001 ze dne 29.3.2007 a skutečně uhrazená částka byla 5 852,84 EUR, což činí 176 170,48 Kč). Částka v zahraniční měně je přepočtena na částku v referenční měně kurzem uvedeným na výpisu z banky.

Stiskem klávesy F9 lze spustit danou operaci úhrady (změny stavu peněz).

obr. 7

2.2 Záložka „položky příkazu k úhradě“

Tato záložka poskytuje uživateli informace o tom, jakým způsobem byl na danou platbu vystaven příkaz (příkazy) k úhradě.

V horní části formuláře má uživatel informace o platbě tak, jak je evidována v událostech plateb (z obrázku je vidět, že se jedná o závazek přijatý 29.3.2007 se splatností 2.4.2007 na částku 19 992,- Kč.). Spodní část formuláře poskytuje uživateli informace o vystaveném příkazu k úhradě na celou částku (číslo příkazu je 000001 ze dne 29.3.2007 na částku 19 992,-).

obr. 8

2.3 Záložka „účetnictví“

Tato záložka poskytuje uživateli informace o tom, jak byla daná platba (předpis i následné úhrady) zaúčtována v komponentě účetnictví.

V horní části formuláře má uživatel informace o platbě tak, jak je evidována v událostech plateb (jedná se o naši platbu popsanou na obrázku v kapitole 2.1). Částka k úhradě v ZM byla 5853,- EUR (tj. 175 000,- Kč), skutečně bylo uhrazeno 5852,84 EUR (tj. 176 170,48 Kč), takže je vidět i správně zaúčtovaný kurzový rozdíl ve výši 1170,48 Kč.

Stiskem klávesy F9 lze spustit danou operaci účetnictví (předpis nebo úhradu platby).

obr. 9

2.4 Evidence kurzových rozdílů

Kurzovým rozdílem rozumíme částky, které vznikají jako rozdíl mezi vystavenou platbou v zahraniční měně a její úhradou v zahraniční měně. U každé platby jsou tyto kurzové rozdíly viditelné jednak na záložce „účetnictví“ a jednak přímo v událostech platby (v případě, že uživatel posune kurzor dále po jednotlivých atributech v horní části formuláře, vidí zde kurzový rozdíl přesně vyčíslený – vysumovaný za všechny úhrady v případě částečných úhrad).

obr. 10

Do atributu KPP<KÚ – tj. kurz předepsané platby je menší než kurz data úhrady, se zapíše částka u pohledávky v případě, že se jedná o kurzový zisk a částka u závazku v případě, že se jedná o kurzovou ztrátu.

Do atributu KPP>KÚ – tj. kurz předepsané platby je větší než kurz data úhrady, se zapíše částka u pohledávky v případě, že se jedná o kurzovou ztrátu a částka u závazku v případě, že se jedná o kurzový zisk.

Tyto údaje se využívají pro automatizované účtování kurzových rozdílů.

3. Výpisy z banky

Následující popis se v kapitole 3.1 a 3.2 bude lišit, postup párování a další náležitosti výpisu z banky (od kapitoly 3.3) je stejný jak pro ruční zadávání příkazu, tak i pro elektronické přijetí výpisu z banky. V případě, že uživatel používá elektronický platební styk s bankou (jak pro příkazy, tak pro výpisy), automaticky předpokládáme, že ovládá daný bankovní software.

3.1 Ruční zadávání

Uživatel si aktivuje činnost „Výpis z BÚ“ (menu Nový proces – Úhrady a jiné změny stavu peněz). Otevře se mu prázdný formulář výpisu z banky. Po stisku klávesy F3 definuje jednotlivé atributy výpisu:

¨ credit/debet – vybrat správný příznak (credit +, debet -)

¨ datum – předplní se aktuální datum

¨ párované – Ano/Ne (příznak, zda se jedná o párovanou či nepárovanou úhradu, např. nepárované úhrady jsou poplatky, úroky apod.). V případě, že si uživatel v daný okamžik není jistý, zda se jedná o úhradu párovanou nebo nepárovanou, je vhodné ji zapsat jako nepárovanou a po dopřesnění úhrady to pak změnit a tuto úhradu dopárovat.

¨ bankovní účet – vybrat správný bankovní účet, jehož se výpis z banky týká

¨ adresát – identifikace adresáta na úhradě ve výpisu (zde ponecháme uživateli možnost volby – může zde vybrat adresáta podle úhrady na výpisu nebo je zde možno ponechat i pomlčku). U párovaných plateb se po spárování pomlčkový adresát automaticky přepíšem adresátem z platby. U nepárovaných plateb pak zůstává pomlčka.

¨ měna – určit měnu, v jaké je úhrada realizována

¨ kurz – v případě zahraniční měny uvést kurz (v závislosti na vnitřní účetní směrnici)

¨ částka v ZM – napsat částku úhrady. Je to částka, která se uplatňuje v automatickém párování. V případě úhrady v CZK napsat i sem částku CZK, po stisku klávesy Enter se automaticky přenese do atributu částka v RM. V případě cizí měny napsat do tohoto atributu částku v cizí měně, do atributu částka v RM se automaticky dopočte přepočtená částka na CZK dle uvedeného kurzu. Částka v ZM se může lišit od částky v MÚ.

¨ částka v MÚ – částka v měně účtu – částka úhrady v měně, která je definovaná jako měna bankovního účtu. Je to hodnota o kterou se sníží (zvýší) stav účtu (aktuální hodnota) uvedený v dané události. Může nastat situace, že na účet přijde částka v jiné měně než v jaké je účet veden.

¨ VS – variabilní symbol úhrady (povinný údaj u párovaných úhrad). Důležitý atribut pro správné spárování úhrady s platbou. Vyplňovat ho přesně a správně dle výpisu.

Tímto má uživatel zadánu jednu řádku výpisu z banky. Další řádky zadává opět po stisku F3. Po zadání všech řádek výpisu je nutno výpis zapsat – ikona „disketa“ – pak volba ZAPSAT. Při zadávání delšího výpisu z banky je vhodné si údaje průběžně ukládat, tj. stiskem ikony „disketa“, zvolit volbu „ZAPSAT“ a znovu pokračovat F3 v zadávání, aby se zabránila případné ztrátě dat po havárii HW. Po zadání všech znovu zápis dat – ikona „disketa“.

Pro usnadnění dalšího vyhledávání můžeme uživatelům doporučit, že jakmile zvolí ikonu „disketa“ a nabídne se jim na výběr volba ZAPSAT, je vhodné si před stiskem této volby zapsat do externího čísla procesu číslo výpisu. Toto číslo pak uživatel může využít při vyhledávání v událostech ZSP.

3.2 Elektronické přijetí výpisu z banky

V této kapitole si popíšeme způsob elektronického přijetí výpisu z banky. Zde se může pro jednotlivé uživatele popis mírně lišit na zakládě toho, jaký používají bankovní software, nejčastější způsob zpracování je takový:

¨ v hlavní menu – Nový proces – Úhrady a jiné změny stavu peněz – Výpis z BÚ

¨ po aktivaci činnosti provést Ctrl F3 a vybrat šablonu „přijetí“

¨ do kolonky jméno souboru je nutno vybrat cestu k souboru (vybrat cestu k souboru, kde je výpis uložen)

¨ po stisku OK se automaticky načtou jednotlivé řádky výpisu z banky

¨ uživatel po stisku ikony „disketa“ zvolí pouze ZAPSAT, aby mohl s událostmi výpisu dále pracovat

obr. 11

Důležité pokyny pro výpis z banky (ruční nebo elektronické zpracování):

Před vlastním zahájením párováním úhrad na platby je nutné zkontrolovat sumy (tzn. zda nám souhlasí zadané credity a debety s výpisem) – toto se provede po stisku klávesy Ctrl S.

V případě, že si uživatel v daný okamžik není jistý, zda se jedná o úhradu párovanou nebo nepárovanou, je vhodné ji zapsat jako nepárovanou (tzn. Párov.: NE) a po dopřesnění úhrady (identifikaci položky výpisu) to pak změnit na párovanou a tuto úhradu dopárovat.

Tímto je výpis z banky zadán, odkontrolován a uložen v IS BM. V tomto okamžiku (formulář výpisu z banky zůstává aktivní) lze přistoupit k párování plateb.

3.3 Párování plateb

Párování plateb se provádí ve formuláři výpisu z banky po stisku klávesy F6. Zobrazí se formulář „přehled spárování“, kde se znovu stiskne klávesa F6 pro automatické párování. V tento okamžik se uživateli zobrazí nabídka, kde může určit, podle jakých atributů bude párování probíhat. Nejčastější variantou (a ta se také objeví předplněna) je párování dle variabilního symbolu a částky (tuto nabídku ikonou „disketa“ zapsat). Dvojí stisknutí klávesy F6 je tzv. automatické párování.

obr. 12

V případě, že částka úhrady na výpisu souhlasí s částkou platby (v událostech plateb) a variabilní symbol na výpisu souhlasí s variabilním symbolem platby (v událostech plateb) je tato úhrada automaticky spárována. Spárované úhrady se zároveň označí (tzn. jsou zatrženy).

Tím má uživatel daný názorný přehled o tom, která úhrada je spárovaná. V tento okamžik je možné znovu stisknout klávesu F6 a vyvolat automatické párování s tím, že se párování zvolí pouze dle variabilního symbolu (např. v případě částečných úhrad apod. nikdy nedošlo ke spárování dle částky a současně dle VS). Tuto volbu znovu zapsat ikonou „disketa“. Spárují a označí se další automaticky spárované úhrady, což je patrné v přehledu spárování.

Úhrady, které zůstanou neoznačené (tj. nezatržené) dosud nejsou spárovány a ty je nutno dopárovat ručně. To se provede po stisku klávesy F5 v přehledu spárování. Uživateli se zobrazí záložka „výběr“ formuláře události plateb (viz. popis v kapitole 2). Zde je nutno danou platbu k úhradě ručně vyhledat (např. pokud nesouhlasí částka, ani variabilní symbol, tak hledat podle adresáta, poznámky apod.). Tento výběr zapsat (ikona disketa), vyhledat příslušnou platbu a označit ji (tzn. zaškrtnout). Po stisku klávesy ESC se automaticky přenese do formuláře přehled spárování a úhrada se označí jako spárovaná.

Tímto způsobem se postupuje tak dlouho, dokud všechny úhrady (uvedené v bankovním výpisu jako „párované = Ano“) nejsou spárované s příslušnými platbami (podrobný popis formuláře spárování je v následující kapitole).

Po spárování úhrad se stiskne klávesa ESC. Následuje dotaz „Opravdu zapsat změny?“ – nutno zvolit ANO. Teprve tímto krokem je výpis z účtu spárován na platby.

Systém uživatele v tento okamžik vrátí do formuláře výpisu z banky, odkud vlastně párování plateb aktivoval.

Párování není nezbytně nutné dělat celá najednou, např. v situaci, kdy pro identifikaci určité položky výpisu je nutná konzultace s pravděpodobným plátcem. Pak se zde popsaný postup párování opakuje než jsou všechny úhrady s příznakem „párované = Ano“ spárovány s platbami.

3.3.1 Zaúčtování úhrad

Uživatel zvolí ve formuláři se zadaným výpisem činnost „ukončit operaci“ pod menu Obecné. Po jejím ukončení se automaticky spustí operace zaúčtování a k zaúčtování se postupně nabízí každá úhrada. Uživateli se zobrazí událost účetnictví s předplněnými údaji o úhradě, uživatel stiskne klávesu ESC – zvolí možnost Zapsat a ukončit – operace zaúčtování dané úhrady se automaticky zapíše a ukončí a rovnou se aktivuje operace zaúčtování další úhrady. Tímto způsobem se takto postupně zaúčtuje kompletně celý výpis z banky. Následně lze doporučit kontrolu, že i v účetním deníku na bankovním účtu korespondují obraty s výpisem.

Implementátor IS BM nastaví, aby se zaúčtování jednotlivých typů úhrad předplňovalo na správné účty. Případné rozdíly mezi platbou a úhradou vyčíslené v CZK budou zaúčtovány jako rozdíly ze zaokrouhlení, rozdíly mezi platbou a úhradou v cizí měně budou vyčísleny jako kurzové rozdíly.

Uživateli lze doporučit, aby nastavení systému (za spolupráce se svým implementátorem) pro účtování bankovního výpisu bylo vyladěno způsobem, kdy je možné výpis účtovat zcela automaticky.

V případě, že nastane okamžik, kdy během účtování nastane kolize (havárie PC, spadne síť apod.) se postupuje takto:

¨ uživatel si v událostech ZSP vyhledá daný výpis, aktivuje ho stiskem klávesy F9

¨ po stisku F6 zkontroluje, že všechny úhrady jsou spárovány

¨ v menu Obecné ve formuláři výpisu z banky se aktivuje činnost „následující připravené operace“ – systém automaticky spustí k zaúčtování ty úhrady, které dosud nebyly zaúčtovány

3.4 Přehled spárování

V této kapitole si podrobně popíšeme formulář přehled spárování. Tak jak je viditelné na obrázku je tento formulář opticky rozdělen na dvě části. Horní část poskytuje uživateli údaje z banky, tzn. to co je přeneseno z výpisu z banky. Ve spodní části formuláře jsou údaje z událostí plateb, tzn. údaje o platbě, která je s danou úhradou (s tou, na které je v horní části umístěn kurzor) spárována.

obr. 13

Spodní řádek představuje částky k úhradě:

¨ částka k úhradě – tj. částka úhrady převzatá z výpisu z banky (tu nikdy neopravovat, je to skutečně částka, která je uvedena na výpisu, tedy ta, kterou uživatel konkrétně dostal nebo zaplatil. Na bankovním výpisu je to atribut „částka v ZM“.)

¨ částka v ZM platby – tj. částka, která se nám v událostech platby přepíše do atributu „dosud uhrazeno“. Tuto částku musí uživatel v některých případech revidovat (v případě zaokrouhlení nebo kurzových rozdílů je nutno ji opravit na hodnotu částky v ZM – řádek týkající se plateb). Je nutno ji opravit z toho důvodu, že na událostech platby je nutno mít přesně uhrazenu celkovou částku (i několika úhradami), protože dokud atribut „dosud neuhrazeno“ na platbě nebude mít nulovou hodnotu, systém tuto platbu nebere jako uhrazenou.

3.5 Události změny stavu peněz

Jednotlivé výpisy z banky má uživatel k dispozici pod menu „události změny stavu peněz“ (hlavní menu – změna stavu peněz). Kromě jiného jsou v událostech změny stavu peněz k dispozici i údaje o událostech pokladny (příjmy, výdeje) či fiktivních úhrad. V této kapitole se ovšem budeme věnovat pouze problematice výpisů z banky.

Po aktivaci činnosti „události změny stavu peněz“ se uživateli nejprve zobrazí záložka „výběr“. Zde si podle data, čísla dokladu, čísla externího dokladu (tj. výpisu), bankovního účtu nebo částky vyhledá příslušný výpis (nebo jen konkrétní úhradu). Výběr je nutno načíst (ikona „disketa“). Následně je možné spustit operaci ZSP (tj. celý výpis) klávesou F9 a případně pokračovat v párování či v něm provádět korekce (viz. kapitola odpárování).

Zobrazí se mu jednotlivé události daného výpisu. Pozornému uživateli jistě neunikne, že jsou zde i okamžiky, kdy jednotlivé události mají odlišnou barvu zobrazení.

obr. 14

Možnosti jsou:

¨ červená barva – znamená událost ZSP, která není dosud zaúčtovaná

¨ modrá barva (u párovaných úhrad) – je zaúčtovaná, systém však signalizuje případný problém (odlišná částka v účetnictví, ZSP a platbách)

¨ černá barva – vše OK

¨ modrá barva (u nepárovaných úhrad) – událost ZSP je zaúčtovaná, vše OK

Na záložce „platby“ má uživatel k dispozici informace o tom, s kterou platbou byla daná úhrada spárována. V horní části formuláře jsou údaje o úhradě, ve spodní části jsou údaje o platbě. Stiskem klávesy F9 lze spustit danou operaci platby (události plateb).

Na záložce „účetnictví“ má uživatel k dispozici informace o tom, jak byla daná úhrada zaúčtována. V horní části formuláře jsou údaje o úhradě, ve spodní části jsou údaje z komponenty účetnictví. Stiskem klávesy F9 lze spustit danou operaci účetnictví.

3.6 Odpárování

V případě potřeby je možno již spárované úhrady odpárovat. Není to triviální záležitost, takže by uživatel měl postupovat velmi obezřetně, případně požádat o spolupráci svého implementátora.

V událostech změny stavu peněz je nutno vyhledat danou úhradu, kterou chceme odpárovat. Stiskem klávesy F9 aktivovat výpis, na kterém se tato úhrada nachází.

Po stisku klávesy F6 se uživateli zobrazí přehled spárování. Zde je nutno označit danou úhradu, tzn. v horní části formuláře umístit kurzor na řádek s danou částkou a tento řádek zaškrtnout. Ve spodní části formuláře umístit kurzor na řádek platby, která je s touto úhradou spojena. Stisknout ikonu „červený křížek“ (zrušit záznam) v horní liště formuláře. Systém se dotazuje „Opravdu zrušit ...?“ – potvrdit volbu ANO. Poté stisknout klávesu ESC a po dotazu „Přejete si zapsat změny?“ znovu zvolit ANO. Teprve tímto okamžikem je daná úhrada odpárována.

Automaticky se aktivuje inverzní událost účetnictví s nabídkou odúčtování úhrady. Na řádek účtu banky je nutno doplnit identifikaci adresáta (může být i pomlčka) a na řádek účtu závazků nebo pohledávek je nutno doplnit datum. Poté stiskem ikony „disketa“ tyto údaje zapsat (zaúčtovat) a po stisku ESC účetní operaci ukončit. Následně je možné provést nové spárování úhrady, u které bylo párování zrušeno.

3.7 Příklady spárování

obr. 15

Částka platby je 5 853,- EUR, odběratel mi však z nějakých důvodů zaplatil pouze 5 852,84 EUR. V dolním řádku tedy skutečně musí být částka k úhradě 5852,84 EUR (to je skutečná částka úhrady) a částku v ZM platby musí uživatel opravit na 5 853,- EUR (aby částka na platbě dosud neuhrazeno byla nula). Rozdíl (tj. 0,16 EUR bude přepočten na RM a vyčíslen jako kurzový rozdíl).

obr. 16

Částka platby je 25 823,- Kč. Odběratel však provedl částečnou úhradu a zaplatil mi pouze 15 000,- Kč. V dolním řádku tedy skutečně musí být částka k úhradě 15 000,- Kč (to je skutečná částka úhrady) a částku v ZM platby musí uživatel opravit na 15 000,- Kč.

obr. 17

Faktura byla vystavena na částku 2 372,- EUR. Odběratel tuto fakturu ovšem nehradí v EUR, ale zaplatil mi ji v CZK, v celkové výši 71 000,- Kč.

V dolním řádku tedy skutečně musí být částka k úhradě 71 000,- Kč (to je skutečná částka úhrady) a částku v ZM platby musí uživatel přepsat na 2 372,- EUR.

obr. 18

Tento obrázek představuje bezproblémovou kombinaci úhrady. Závazek byl přijat ve výši 19 992,- a úhrada byla rovněž na částku 19 992,-, takže ideálně proběhlo spárování dle částky a VS.

obr. 19

Přijatý závazek je ve výši 1 234,11 EUR. Částka úhrady je 1 234,11 EUR, takže nenastává žádný problém, úhrada je spárována a platba uhrazena do nuly.

obr. 20

Platba je vystavena na 25 823,-Kč, z toho je již částečně uhrazeno 15 000,-Kč, takže zbývá uhradit 10 823,-Kč. Úhrada je přijata ve výši 10 823,- Kč. V dolním řádku tedy skutečně musí být částka k úhradě 10 823,- Kč (to je skutečná částka úhrady) a částku v ZM platby musí být skutečných 10 823,-Kč a tím je platba uhrazena do nuly.

obr. 21

Tato úhrada přišla v celkové výši 3 115,- EUR a uživatel s ní uhradí tři platby od daného odběratele. Částka úhrady však nesouhlasí s celkovou částkou plateb, tzn. že jedna z plateb bude hrazena pouze částečně. Při párování je vhodné postupovat tak, že uživatel s úhradou spáruje ty platby, které jsou hrazeny v plné výši (tzn. vybrat v událostech plateb, označit a ESC přenést zpět do formuláře spárování) a teprve poté samostatně páruje úhradu té platby, která je hrazena pouze částečně.

Částka k úhradě je dopočtena automaticky (tzn. celková částka úhrady z výpisu minus suma v plné výši hrazených plateb).

Na našem obrázku je viditelné, že platby ve výši 1 250,- EUR a 1 365,- EUR jsou uhrazeny v plné výši, z platby ve výši 860,- EUR je uhrazeno částečně pouze 500,- EUR.

4. Návod na přecenění závazků a pohledávek v cizí měně

Přecenění plateb kurzem ke konci roku uživatel provede procesem Kursový rozdíl platby – uzávěrka (v hlavním menu činnost Nový proces – Úhrady a jiné změny stavu peněz).

Před vlastním spuštěním tohoto procesu je nutno nastavit kurz k 31.12. daného roku u všech přeceňovaných měn (v hlavním menu Informační centrum – Oceňování - Měny a kursy).

Proces je možné spouštět opakovaně, systém vybere vždy zatím nepřeceněné závazky/ pohledávky. Z toho vyplývá skutečnost, že přecenění je vhodné provést co nejdříve po ukončení roku a po provedení inventury závazků a pohledávek. Doporučujeme přecenit závazky/pohledávky vždy před úhradou. Samotné načtení přeceňovaných plateb se spouští přes doplňující vlastnost formuláře „Update podle kursu“ (pod menu Volby). Nedoporučujeme povolit duplicitu variabilních symbolů plateb. V případě duplicity je třeba rozlišit variabilní symboly plateb pouze pro přecenění a poté opravit zpět na původní.

obr. 22

Vytvořené události pouze zapsat (tzn. po volbě zapsání dat – disketou nebo po stisku ESC – zvolit možnost ZAPSAT) a dále pracovat obdobně jako při automatickém párování výpisu z běžného účtu – F6, F6, Esc, potvrdit zapsání změn. Po ukončení události přecenění následuje zaúčtování hodnoty přecenění.

V případě, že uživatel nastaví v atributu „Povolit duplicitu – ANO“, nesmí využívat možnosti automatického párování (F6 – F6), je nutno VŽDY PÁROVAT RUČNĚ, tzn. F6 – F5.

obr. 23

[1] V případě, že si uživatel nevytvoří fiktivní příkaz k úhradě a zbývající část dosud neuhrazeno hradí např. dvěma částečnými úhradami, je nutno si částku na příkazu k úhradě vědomě přepsat.

© 1996-2013 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 04.10.2013


Dokumentace účetnictví

OBSAH

OBSAH-- 1

Účetnictví 2

1. Obecné principy. 3

2. Účtový rozvrh. 4

3. Účetní doklady, zápisy a účetní knihy. 6

3.1 Účetní deník. 8

3.2 Obratová tabulka (se selektory) 14

3.2.1 Konta (se selektory) 16

3.3 Hlavní kniha. 17

4. Saldokonto. 18

5. Číslování dokladů (zápisů) 22

6. Výkazy. 23

6.1 Definice výkazů. 24

7. Selektory. 24

8. Otevření a uzavření účetních knih. 26

9. Speciální činnosti 29

9.1 Přepočet obratové tabulky. 29

9.2 Přepočet účetního saldokonta. 29

9.3 Parametry účetnictví 29

9.4 Účetní období 30

10. Závěrka. 31

10.1 Mezinárodní standardy. 32

11. Další 32

11.1 Přechod na nový rok. 32

11.2 Příklady účtování 33

Účetnictví

Tato dokumentace se zaměřuje na podporu vedení účetnictví pomocí IS Bílý Motýl®, přičemž je zde kladen důraz na komponentu „Účetnictví“. K pochopení následujícího návodu je vhodná znalost dokumentace „ovládání“ (především kapitoly 1.1, 1.2 a 1.3) a samozřejmě znalost Zákona o účetnictví (563/1991 Sb.) včetně předpisů prováděcích a platných účetních standardů. Pro větší názornost si zde zopakujeme některé pojmy ze slovníku pojmů:

- Analytický účet – účetní jednotky si definují k syntetickým účtům účty analytické, které podrobněji z hlediska věcného (systematického) člení účty syntetické. Označení analytického účtu se obvykle skládá z označení odpovídajícího syntetického účtu a několika dalších číslic (v IS BM až 6, takže celková délka identifikátoru účtu v účetním rozvrhu může být až 9 číslic);

- Cash flow – v IS BM výkaz cash flow – podle české terminologie Přehled o peněžních tocích. Vyjadřuje rozdíl mezi příjmy a výdaji peněžních prostředků a peněžních ekvivalentů v podniku za určité časové období [1] ;

- Dal – výrazem dal (D) je označována pravá strana syntetického účtu;

- IDP – identifikace párování (pro saldokonto), tj. záznamy v účetním deníku se shodnou IDP jsou součástí právě jednoho saldokontního případu; pokud je zůstatek těchto záznamů na daném účtu nulový, pak se jedná o případ z hlediska saldokonta vyrovnaný (tj. ukončený);

- Konečný zůstatek – stav účtu na konci účetního období. Konečný zůstatek aktivních účtů (MD v atributu „strana“ v účtovém rozvrhu) se vypočítává jako počáteční zůstatek období + obrat MD v období – obrat D za v období. Konečný zůstatek pasivních účtů (D v atributu „strana“ v účtovém rozvrhu) se vypočítává jako počáteční zůstatek období + obrat D v období – obrat MD v období;

- MD – výrazem má dáti (MD) je označována levá strana syntetického účtu;

- Obrat účtu – představuje číselné vyjádření celkového pohybu aktiv a pasiv, popřípadě nákladů a výnosů za určité období, který je evidován na daném účtu;

- Počáteční zůstatek – výchozí stav účtu na počátku určitého období, např. na počátku účetního období. Počáteční zůstatek na počátku účetního období je nastaven na základě provedení otevření účetních knih. Počáteční zůstatek v rámci měsíce je tvořen konečným zůstatkem předchozího měsíce;

- RM – referenční měna – při aplikaci informačního systému BM v České republice je to CZK. V této měně se vede účetnictví a ve všech činnostech, kde se objevuje zahraniční měna je obvykle uváděn kurz vůči této referenční měně. Identifikace referenční měny se nastavuje v činnosti Parametry oceňování (Informační centrum – Oceňování);

- Saldokonto – je pomocná účetní kniha nebo obecně analytická evidence pohledávek a závazků – obsahuje jednotlivé účty pro každého dodavatele a odběratele – nedoplatky lze využít pro porovnání s komponentou plateb při inventuře. Činnost účetní saldokonto lze v IS BM využít i pro další účty, jejichž zůstatek podlehá inventarizaci a analytická evidence doloží nenulový rozdíl mezi součtem částek zapsaných na straně MD a na straně Dal – např. účty třídy 1 (111, 112, 121, ...);

- Skupinový účet – trojmístné vyjádření čísla účtu, kde na poslední třetí pozici je nula. Obvykle se na tyto účty neúčtuje, slouží pouze pro zjednodušené účetnictví;

- Směrná účtová osnova – určuje uspořádání a označení účtových tříd, popř. účtových skupin nebo i syntetických účtů pro účtování, je dána legislativou[2]. Na základě této účtové osnovy si účetní jednotky sestavují svůj účtový rozvrh, tj. mají povinnost v něm zachovat strukturu danou jejich směrnou účtovou osnovou. Směrná účtová osnova není v IS BM přímo evidována, nicméně je možné si odpovídající právní předpis připojit jako dokument;

- Syntetický účet – v IS BM si účetní jednotky definují syntetické účty v souladu se směrnou účtovou osnovou tak, aby představovaly základní strukturu pro zachycení všech skutečností (na globální, resp. sumární úrovni), které jsou předmětem účetnictví; v rámci zvyklostí (s přihlédnutím k právním předpisům) se obvykle jedná o účty vyjádřené třímístným číslem; k syntetickým účtům se váže řada legislativních ujednání;

- Třída – představuje základní členění účtů, fakticky dle první pozice čísla účtu v účtovém rozvrhu;

- Účetní doklad – je definován Zákonem o účetnictví, vnitřním předpisem lze specifikovat, které údaje v IS BM a za jakých podmínek reprezentují účetní doklad;

- Účetní případ – v IS BM jsou účetní případy podchycovány účetním zápisem. Účetním případem je každá skutečnost, která je předmětem účetnictví dle zákona 563/1991 Sb. Některé účetní případy spolu mohou úzce souviset, např. saldokontně (v následném textu je někdy společně nazýváme saldokontní případ);

- Účetní zápis – v IS BM představuje zápis (záznam) do účetních knih tu část účetního dokladu, která vyjadřuje jeho reprezentaci formou účtů účtového rozvrhu; v terminologii IS BM se jedná o operaci komponenty účetnictví a její události;

- Účtová skupina – představuje jemnější členění účtů než třída, fakticky dle prvních dvou pozic čísla účtu;

- Účtový rozvrh – je sestaven na základě Směrné účtové osnovy, představuje seznam všech účtů (syntetických i analytických) potřebných k zaúčtování všech účetních případů a k sestavení účetní závěrky v dané účetní jednotce, přičemž některé účty mohou být určeny pro vnitropodnikový pohled (analytické členění účtů), v IS BM může dále zahrnovat účty podrozvahové;

- ZM – zahraniční měna – jakákoliv měna, která se liší od měny referenční. Ve většině komponent[3] je uváděn kurz mezi touto měnou a referenční měnou.

1. Obecné principy

Následující body poskytnou uživateli stručný přehled (detailněji je rozvedeno v odpovídajících kapitolách) obecných principů komponenty účetnictví a podpory vedení účetnictví v informačním systému Bílý Motýl:

¨ zajištění podvojnosti – systém hlídá rovnost stran MD a D každého účetního zápisu a zároveň je kontrolována existence a platnost účtů, kterým je účetní případ reprezentován

¨ po provedení účetní závěrky se data (účetní zápisy) neodsouvají, uživatel má data minulých účetních období stále k dispozici

¨ účetní období (ale i ukončený měsíc) lze uzavřít, tzn. je zajištěno, že nelze provést účetní zápis do již uzavřeného období

¨ účetní zápisy lze vytvářet přímým vstupem nebo je automaticky zaznamenat na základě operativních evidencí

¨ účtový rozvrh je definován uživatelsky – k jeho sestavení lze využít různé směrné účtové osnovy; k dispozici i podrozvahové účty, analytika až na 6 míst

¨ je zajištěno jednoznačné číslování účetních zápisů (případně i dokladů)

¨ automatizovaně aktualizované saldokonto je k dispozici on-line

¨ je umožněno použít i cizí měny v těch účetních případech, kdy je to potřebné

¨ lze zadokumentovat veškeré opravy v účetních zápisech[4]

¨ možnost plánování na všech účtech i vnitropodnikově

¨ pomocí výběrových záložek lze vybrat požadované podmnožiny informací (viz. pojem Záložka – výběr)

2. Účtový rozvrh

Účtový rozvrh je při implementaci IS BM obvykle naplněn podle našich vzorů (resp. připravených rozvrhů dle odpovídající Směrné účtové osnovy)[5]. Každý uživatel si může účtový rozvrh (zejména jeho analytickou část) upravit podle vlastních firemních zvyklostí (individuální nadefinování účtů v účtovém rozvrhu dle směrné účtové osnovy je dáno vnitřní účetní směrnicí každého konkrétního uživatele IS BM).

Korektní struktura syntetických účtů a navazujících analytických účtů je předpokladem pro splnění požadavku daného zákonem o účetnictví, a tím je zaúčtování všech účetních případů a sestavení účetní uzávěrky. Minimální struktura účtů účtového rozvrhu musí být trojmístná (2místa skupinový účet doplněný nulou).

Naprostá většina uživatelů eviduje účtový rozvrh členěný minimálně podle syntetických účtů, tzn. nikoliv skupinový účet 310, ale pevně daný účet 311 – Odběratelé. Za účelem detailnějšího vnitropodnikového pohledu mají uživatelé možnost vést až 6-ti místnou analytiku. Pro další vnitropodnikové členění mají k dispozici i selektory.

Před vlastní aktivací činnosti účtový rozvrh má nejprve uživatel k dispozici záložku Výběr. Ta mu poskytuje možnost vyfiltrovat si množinu dále zobrazených dat (účtů účtového rozvrhu). Může vyhledávat konkrétní účet (nebo jen část účtu), stranu a zda má být účet s příznakem saldokontní či nikoliv. Vzhledem k tomu, že u každého účtu lze nastavit období platnosti, lze podle tohoto období i vyfiltrovat výběr. Účty je možno vybírat podle těchto kritérií:

¨ Platné i neplatné – tj. všechny účty z hlediska platnosti

¨ Platné dnes – uživateli se zobrazí všechny účty, jejichž období platnosti od – do je pro dnešní datum aktuální[6]

¨ Neplatné dnes - uživateli se zobrazí všechny účty, jejichž období platnosti od – do je pro dnešní datum neaktuální

¨ Platné k datu - uživateli se zobrazí všechny účty, jejichž období platnosti od – do je aktuální pro zadané datum, tzn. uživatel si může najít účty, které byly platné např. k 1.1.2003

¨ Neplatné k datu – uživateli se zobrazí všechny účty, jejichž období platnosti od – do je neaktuální pro zadané datum

Po načtení výběru a zobrazení konkrétních účtů má uživatel u každého účtu k dispozici následující řadu jeho vlastností – atributů (viz. obr.1):

¨ Účet – identifikace účtu (povinně musí být identifikace účtu 3místná, max. lze zadat 9míst) – první tři místa zajišťují syntetické členění účtu, další místa jsou určena pro analytické členění.

¨ Text – název účtu (na záložce cizojazyčné je možno uvést název účtu i v cizím jazyce).

¨ Strana – MD/D – zda je daný účet aktivní či pasivní neboli na jaké straně se eviduje zůstatek účtu.

¨ Saldokontní – Ano/Ne – v případě volby Ano bude systém automaticky u daného účtu sledovat, zda je vyrovnané saldokonto. Při účetním zápisu systém automaticky předplní IDP číslem hlavního procesu (pro účty s nastavením „saldokontní ANO“ v účtovém rozvrhu) a tím daná řádka (položka) účetního zápisu vstupuje do saldokonta. Po stisku myši na tučném atributu účet – aktuální hodnoty saldokonta – má uživatel k dispozici účetní případy (fakticky účetní zápisy reprezentující účetní případy), které jsou z hlediska saldokonta nevyrovnané.

¨ Obrat v ZM - Ano/Ne. V případech, kdy podle zákona o účetnictví existuje povinnost použít v účetnictví současně i cizí měnu (např. u pohledávek a závazků, podílů na obchodních společnostech, cenných papírů a derivátů, cenin, ...), lze toto uživatelsky nastavit tímto příznakem účtu. Následně jsou v obratové tabulce a kontech k dispozici i kumulované údaje v cizí měně.

¨ Povinná částka v ZM – Ano/Ne. Pro účty s nastavením tohoto atributu na Ano nelze zadat událost účetního deníku s daným účtem s nulovou částkou v zahraniční měně.

obr. 1

Další atributy, které má uživatel k dispozici určují, zda se selektor uvedený na události účetnictví daného účtu (účetním zápisu) má promítat do obratové tabulky. Jsou to:

¨ sledovat obrat obchodního selektoru Ano/Ne

¨ sledovat obrat organizačního selektoru Ano/Ne

¨ sledovat obrat technicko-věcného selektoru Ano/Ne

Pro každý účet účtového rozvrhu (druhý sloupec možností u atributu obrat) lze nastavit:

¨ povinnost uvádět obchodní selektor v událostech účetnictví (účetních zápisech) – volba Ano/Ne

¨ povinnost uvádět organizační selektor v událostech účetnictví (účetních zápisech) – volba Ano/Ne

¨ povinnost uvádět technicko-věcný selektor v událostech účetnictví (účetních zápisech) – volba Ano/Ne

Pokud je pro daný účet nastavena povinnost uvádět selektor v událostech účetnictví, pak při vytváření účetních zápisů nebude možné zapsat událost s hodnotou selektoru neurčeno (‘-’).

U každého účtu je možno definovat datum jeho platnosti od - do. Pokud je toto datum u účtu nastaveno, je možno na tento účet zaúčtovat pouze v tomto uvedeném období. Je možno využívat tento účet při přípravě předkontací, ale účetní zápis je systémem kontrolován na nastavené období platnosti. Pokud není nastavena žádná platnost účtu, je platný bez omezení. V případě, že uživatel v účetním zápisu použije účet, který je mimo období platnosti, systém uživatele informuje: „Datum události se musí nacházet v období platnosti účtu a účetního období“.

¨ komentář – tento atribut může uživatel využít pro zadání metodiky, kdy daný účet použít pro zachycení účetního případu

V případě, že uživatel zařadí do účtového rozvrhu nový účet, doporučujeme ověřit jeho uplatnění v definici výkazů, a to zejména tehdy, pokud standardní výkazy dodávané BM Servisem byly v dané implementaci specificky upraveny podle analytického členění účtů daného uživatele.

Účtový rozvrh však může uživateli poskytovat i další související informace, které nejsou na první pohled okamžitě k dispozici. Po stisku pravého tlačítka myši na tučném atributu „Účet“ má uživatel k dispozici činnosti (informace se vždy vztahují k aktuálnímu účtu):

¨ účetní deník (fakticky účetní zápisy týkající se tohoto účtu)

¨ účetní saldokonto

¨ účtový rozvrh

¨ obratová tabulka

¨ obratová tabulka se selektory

¨ konta

¨ konta se selektory

Záložka „cizojazyčné“ poskytuje uživateli možnost přeložit si názvy účtů do vybraných cizích jazyků. Uživatel si vybírá jazyk a do atributu text pak napíše název účtu právě ve zvoleném cizím jazyce. To lze následně využít při ovládání IS v cizím jazyce nebo ve výstupech.

Pokud si chcete účtový rozvrh vytisknout, jsou k dispozici základní předlohy výstupu typu Excel, které obsahují následující informace:

¨ účtový rozvrh – obsahuje atributy identifikace účtu, popis účtu a stranu

¨ účtový rozvrh – podrobný – obsahuje atributy identifikace účtu, popis účtu, strana, příznak saldokonta, obrat v ZM a komentář

V případě potřeby doplnění sestav o další atributy nebo vytvoření další nové sestavy lze toto nastavit v rámci implementace.

3. Účetní doklady, zápisy a účetní knihy

Skutečnosti, které jsou předmětem účetnictví, tj. účetní případy, jsou zachycovány pomocí účetních dokladů, na jejichž základě jsou realizovány účetní zápisy v IS Bílý Motýl. Účetní zápis se do IS BM realizuje zápisem událostí v operaci komponenty účetnictví. Účetní zápis se v IS BM skládá z libovolného počtu položek[7] se shodným číslem procesu (viz. kapitola číslování dokladů). Tento zápis je ze strany IS kontrolován, takže musí splňovat tyto podmínky:

¨ podvojnost [8];

¨ platnost účtu;

¨ platnost selektorů;

¨ existující účetní období a otevřené období komponenty účetnictví;

¨ jednotnost data (pomocí uživatelského nastavení v transformaci je obvykle zajištěno, že v rámci jednoho dokladu při vytváření událostí účetního zápisu zůstává datum shodné. V některých případech je však nutné umožnit v rámci jednoho dokladu různé datum událostí[9]. Toto se zajistí pomocí parametru účetnictví „povolit na účetním dokladu záznamy jednoho měsíce“.);

¨ budoucno – implicitně není povoleno účtování do budoucna. Toto je možné pouze v případě, že je v parametrech účetnictví nastaveno „povolit účtování do budoucna“. Zápis plánu do budoucna je povolen nezávisle na tomto parametru;

¨ jednotnost atributů „skutečnost – plán“ a atributů „otevření – běžné – uzavření“ (doporučujeme toto zajistit správným nastavením vstupní masky operace), tzn. pro každý druh operace v masce tento atribut správně nastavit pomocí konstanty a nastavit příznak editovat „ne“.

Účetní zápis se realizuje buď automatizovaně na základě již zaznamenaných údajů popisujících účetní případ[10] nebo přímo. Každá položka účetního zápisu, který se promítá současně do všech účetních knih, má tuto strukturu:

¨ Číslo operace v procesu – jednoznačné číslo účetního zápisu složené z roku-identifikace datového úložiště-čísla operace (podrobnější popis číslování dokladů je popsán v kapitole 5.).

¨ Identifikace a název druhu operace – ke každému druhu operace lze nastavit přístupová práva, tzn. že při prohlížení v účetním deníku má uživatel k dispozici ty účetní zápisy, které jsou vytvořeny na základě druhu operace, ke které má uživatel přístupové právo alespoň čtení. Pro vytváření jednotlivých účetních zápisů je nutno mít k druhu operace právo zápis.

¨ Datum – datum účetního případu. Tento atribut úzce souvisí s nastavením účetního období a nastavením činnosti otevřená období komponent. V případě nesrovnalostí systém uživatele upozorňuje těmito hláškami:

- „Datum události musí být menší nebo rovno dnešnímu datu“ – kontrolní hláška, která se objeví ihned po přechodu na další atribut. Upozorňuje uživatele, že v činnosti otevřená období komponent má chybně vyplněn atribut „vstup datum od – do“ nebo že účtuje do budoucna.

- „Pokus o zápis do nedefinovaného účetního období“ – kontrolní hláška, která se objeví při zápisu události. Upozorňuje uživatele, že v činnosti účetní období nemá nadefinované období pro dané datum (systém toto hlásí např. v případě, že uživatel zadává účetní případ s lednovým datem roku 2008 a přitom nemá v činnosti účetní období nadefinován řádek s rokem 2008).

- „Pokus o zápis do uzavřeného účetního období“ - kontrolní hláška, která se objeví při zápisu události. Upozorňuje uživatele, že v činnosti účetní období má období, kam spadá daný datum na události, již uzavřeno.

- „Nesouhlasí suma na straně MD a D“ – kontrolní hláška, která se objeví při zápisu události. V tomto případě tak úplně nesouvisí se sumou stran, ale s datem na události. Upozorňuje uživatele, že v události má např. několik řádek, kde je různé datum události (tato situace může nastat při různých zpětných opravách apod.).

¨ Druh události – atribut označující fázi události v účetním období. Může nabývat hodnot běžná/otevření/uzavření (tj. otevření a uzavření účetních knih), což se následně užije ve výběrech při prohlížení účetních zápisů, v definici výkazů, v hlavní knize, ....

¨ Druh události 2.část – skutečnost/plán – význam je zřejmý z možných variant, tj. plánování se provádí obdobně jako záznam skutečnosti. Hodnota plán se využívá pro vytvoření účetních zápisů s plánovanými hodnotami, které potom následně uživatel porovnává na skutečnost (např. ve výkazech, při provádění finančních analýz, při přípravě plánů do budoucna apod. – bez ohledu na atribut „povolit účtování do budoucna“ v parametrech účetnictví).

¨ Text – vlastní popis účetní události, např. vymezení obsahu účetního případu, ...

¨ Účet – identifikace účtu – účet musí existovat v účtovém rozvrhu a musí být v období platnosti, jinak systém hlásí: „Datum události se musí nacházet v období platnosti účtu a účetního období“.

¨ Obch.s. – identifikace obchodního selektoru – umožňuje uživateli rozlišení účetních událostí na základě obchodního pohledu (např. obchodních zakázek apod.). U obchodního selektoru se eviduje jeho platnost od – do, tzn. v účetním zápisu nelze použít selektor, který je mimo období platnosti.

¨ Org.s. – identifikace organizačního selektoru – umožňuje uživateli rozlišení účetních událostí na základě rozdělení organizace (např. za jednotlivá střediska, úseky, provozy apod.). U organizačního selektoru se eviduje jeho platnost od – do, tzn. v účetním zápisu nelze použít selektor, který je mimo období platnosti. Ke každému organizačnímu selektoru je možno prostřednictvím atributu „umístění“ nastavit pro jednotlivé uživatele přístupová práva, tzn. uživatel s právem přístupu zápis může daný selektor vstupovat v účetním zápisu, uživatel s právem čtení má účetní zápisy s tímto selektorem k dispozici pro prohlížení.

¨ Tech.s. – identifikace technicko-věcného selektoru – umožňuje uživateli rozlišení účetních událostí z hlediska technicko – věcného (např. za jednotlivá auta nebo majetek apod.). U technicko-věcného selektoru se eviduje jeho platnost od – do, tzn. v účetním zápisu nelze použít selektor, který je mimo období platnosti.

¨ Jiné párování – jedná se o příznak saldokontního párování, implicitně je nastaveno NE, protože účetní saldokonto je automaticky hlídáno pomocí IDP. Tento atribut s hodnotou ANO má smysl především u otevření a uzavření účetních knih a při provádění importů či různých oprav (na těchto záznamech uživatel nechce u saldokontních účtů sledovat saldokonto), tj. výjimečné nastavení ANO.

¨ Strana – výběr strany účtu MD/Dal.

¨ Částka – finanční částka v referenční měně, tj. v Kč (maximálně je 999 999 999 999 999,99).

¨ Kód oceňovací jednotky ZM, tj. kód cizí měny, je-li uváděna.

¨ ZM - částka v zahraniční měně.

¨ IDP – identifikace párování – předplňuje se automaticky na základě čísla hlavního procesu. Tuto identifikaci lze uživatelsky měnit, nicméně to pak předpokládá, že veškerá další práce v řízení salda (opravy i standardní práce) je ze strany uživatele ruční. Nicméně uživateli nedoporučujeme IDP měnit u závazků a pohledávek z dodavatelsko odběratelských vztahů, takto automaticky předplněná IDP je obvykle zcela dostačují a umožňuje pohodlné sledování saldokonta napříč těmito procesy. Ke každému IDP (po stisku klávesy F2) je k dispozici aktuální hodnota saldokonta.

¨ Identifikace adresáta, např. účastník účetního případu.

¨ Údaje o tom, kdo danou položku účetního zápisu zapsal dle přihlášeného uživatele. Tento atribut je ze strany IS BM doplněn automaticky identifikací přihlášeného uživatele, který tuto položku zapsal[11].

¨ Kdy zapsal – datum a čas, kdy byl zahájen zápis dané události (položky zápisu).

Pokud je v uvedených atributech uživatelem uvedeno vše, co předepisuje Zákon o účetnictví pro účetní doklad, pak lze takovýto účetní zápis považovat za účetní doklad, případně je možné za účetní doklad považovat tento zápis společně s dalšími údaji (záznamy) evidovanými v daném procesu[12], který zachycuje účetní případ.

Volbou odpovídajícího řazení položek účetních zápisů s případným výběrem je prezentována odpovídající účetní kniha, kterou je obvykle možné i vytisknout pomocí odpovídající předlohy výstupu. Jedná s zejména o účetní deník a o hlavní knihu, ale jsou k dispozici (či jsou v rámci implementace IS nastaveny) další způsoby prezentace účetních zápisů.

3.1 Účetní deník

Činnost IS BM „Účetní deník“ umožňuje uživateli prohlížení neagregovaných účetních zápisů a to s výběrem jejich libovolné podmnožiny, s volbou třídění a s libovolnou formou zobrazení (tisku) pomocí předloh výstupu. Jednou z možností pohledu na účetní zápisy je samozřejmě účetní kniha „účetní deník“, kde jsou účetní zápisy uspořádány z hlediska časového (chronologicky) a prokazují zaúčtování všech účetních případů v účetním období.

Jednotlivé účetní zápisy v účetním deníku vznikají buď prostřednictvím procesů a nebo pomocí obecného účetního zápisu (s případnou pomocí šablon). Jinými slovy lze toto vysvětlit tak, že někde v operativní evidenci v systému (např. komponenta obchod nebo sklad) je vytvořen prvotní doklad (např. vystavená faktura nebo výdej ze skladu) a na základě procesu a v něm nadefinovaných transformací dojde k účetnímu zápisu tohoto účetního případu. Z obrázku (č.2) je zřejmé jak může vypadat diagram procesu vystavení faktury. Uživatel v operaci komponenty OBC (obchod) uvádí, co bylo předmětem prodeje a za jakých podmínek – po jejím ukončení se aktivuje operace komponenty DPH a po jejím ukončení se aktivuje operace komponenty PLA (platby). Údaje ze všech těchto komponent operativní evidence se následně transformují do událostí v operaci komponenty UCE (účetnictví), tj. na účetní zápis. Toto je řízeno nadefinovanými transformacemi v diagramu procesu (viz. obrázek 2 – zatržené vazby mezi uzly, kde je nadefinovaná transformace). Údaje do účetnictví jdou tedy ze tří různých komponent a poskytují tak uživateli komplexní informaci o daném účetním případu.

obr. 2

Na dalším obrázku (č.3) má uživatel k dispozici příklad toho, jak vypadají události (účetní záznamy) komponenty účetnictví vytvořené na základě tohoto diagramu procesu. Z komponenty OBC je odvozena „částka fa bez DPH“ (strana D, účet 604). Z komponenty DPH je odvozena „výše DHP“ (strana D, účet 34322) a z komponenty PLA je odvozena „částka k úhradě“ (strana MD, účet 311).

obr. 3

V diagramu procesu lze nadefinovat i to, že události operace účetnictví se automaticky zaúčtují na pozadí. Jedná se např. o standardní vystavení skladové výdejky, kdy v transformaci procesu skladového výdeje je nadefinován způsob účtování (vytvořeny předkontace) a pak v okamžiku, kdy pracovník skladu ukončí operaci skladového výdeje se na pozadí automaticky tento výdej i zaúčtuje.

Jednotlivé zápisy účetního případu musí na základě Zákona o účetnictví obsahovat tyto náležitosti:

¨ Účtování probíhá na různé souvztažné účty (souvztažnými účty rozumíme dva, případně i více, účtů, kterým je zachycen účetní případ. Tyto účty musí odpovídat obsahu účetního případu, tj. musí být vybrány tak, aby zápis na ně měl smysl a věrně zachycoval skutečnost, ke které došlo a kterou je nutno zaúčtovat). Věcná správnost účetního zápisu spočívá právě ve volbě správných souvztažných účtů.

¨ Částky, které se zaúčtují na těchto různých účtech a na jejich různých stranách, musí být shodné (obrat MD se musí rovnat obratu D).

Po aktivaci činnosti účetní deník (hlavní menu – Účetnictví – Účetní deník) má uživatel k dispozici nejprve záložku výběr. Zde si pomocí nabízených atributů může vyfiltrovat požadovanou množinu dat. Při definici záložky výběr je vždy pro uživatele podstatné si uvědomit, kterou informaci od systému požaduje, např. zda výběr účetních zápisů za vybrané období nebo pouze zápisy na určitý účet nebo adresáta nebo kombinaci několika výběrových atributů – období od – do, účet, adresát, částka, IDP apod. Navíc je zde k dispozici výběr za identifikaci organizačního selektoru[13]. V případě, že uživatel by rád viděl souhrnnější pohled na události (účetní zápisy) z pohledu obchodních zakázek (nebo jiného obchodního pohledu), využije k tomuto účelu výběr za obchodní selektor. Z pohledu technicko věcného (např. za jednotlivá auta nebo majetek apod., tak jak to má každý podnik individuálně zavedeno) je uživateli k dispozici technicko – věcný selektor. Následně zobrazené účetní případy jsou vytvořeny na základně určitého druhu operace v procesu. Aby měl uživatel vyfiltrované záznamy k dispozici, musí mít k dané operaci přístupové právo alespoň čtení.

obr. 4

Po stisku pravého tlačítka myši na tučném atributu „Účet“ má uživatel k dispozici tyto činnosti (informace se vždy vztahují k aktuálnímu účtu):

¨ účetní deník (fakticky účetní zápisy týkající se tohoto účtu)

¨ účetní saldokonto

¨ účtový rozvrh

¨ obratová tabulka

¨ obratová tabulka se selektory

¨ konta

¨ konta se selektory

Podobně další potřebné informace vztahující se k adresátovi si uživatel může vyvolat po stisku pravého tlačítka myši na tučném atributu „Adresát“.

Uživatel jistě využije i kombinaci kláves Ctrl S – Suma stran. Poskytuje uživateli přehled sumárních částek na straně Má dáti a Dal ze zobrazených položek (účetních zápisů). Tak uživatel ihned vidí, zda-li je zachováno pravidlo podvojnosti či nikoliv. V případě, že uživatel klávesu Ctrl S při vytváření účetního případu nevyužije, nemusí se obávat, kontrola podvojnosti probíhá při zápisu účetního případu automaticky.

Po stisku klávesy Ctrl D má uživatel k dispozici dokumenty, které souvisejí s daným účetním případem, např. při zpracovávání došlé pošty může daná pracovnice nascanovat přijatou fakturu do systému a účetní pak při zaúčtování přijaté faktury (v případě, že bude mít nějaké nejasnosti nebo si jen chce ověřit prvotní doklad) má po stisku Ctrl D tento doklad ihned k dispozici. Tyto dokumenty uživatel nevyužívá v okamžiku zpracovávání daného účetního případu, neboť to je má tzv. „v ruce“, ale jsou připraveny pro budoucí použití, např. při zpětné kontrole dokladů, při opravě chyb, zjištění nesrovnalostí apod.

Další možnost, jak sledovat celý účetní případ a jeho prvotní doklady poskytuje uživateli doplňující vlastnost formuláře QUICK info (viz. daný pojem ve slovníku pojmů).

Protože v účetním deníku jsou obsaženy velmi citlivé informace firmy, je nutné mít jednak správně nastavena přístupová práva a zároveň je nutno mít možnost i zpětně sledovat provedené změny či opravy. Toto uživateli umožňuje nadefinování v činnosti „sledování změn v záznamech tabulek IS BM“ (viz. daný pojem ve slovníku pojmů).

Opravy záznamů v účetním deníku lze provádět:

¨ Běžným přepisem jednotlivých atributů (pouze dokud není operace ukončena. V případě ukončené operace lze opravit pouze atribut „text“.).

¨ Pomocí odblokovače (viz. pojem „zrušit stav ukončena“ ve slovníku pojmů).

¨ Provedením storna účetního případu (viz. pojem „storno“ ve slovníku pojmů).

Význam atributů zobrazovaných v činnosti Účetní deník (viz. obr. 4) byl popsán v předchozí kapitole. Činnost účetní deník obsahuje ještě další záložky:

¨ Záložka „Protiúčty“ – poskytuje uživateli komplexní přehled o celém účetním zápisu (viz. další obrázek). Na našem ukázkovém výběru máme výběr vybírající jen účet 311 (tzn. k dispozici jsou pohyby účtu 311 a veškerých analytik). Aktivní událost (položka účetního zápisu, na které je umístěn kurzor a řádka je barevně zvýrazněna) je ze dne 12.02.2008 na částku 809,00. Záložka „Protiúčty“ poskytuje uživateli přehled o tom, jak vypadá celý účetní zápis, tj. zachycení celého účetního případu. Podobný přehled, jaký má uživatel dostupný na záložce „Protiúčty“, má možnost si zobrazit po stisku klávesy F9 (nebo menu Volby – Spustit operaci) na dané události pod záložkou „Deník“.

obr. 5

¨ Záložka „Saldokonto“ – poskytuje uživateli přehled o skladbě saldokonta daného účtu a IDP (tzn. zda jsou vyrovnané obraty MD a D). Zde si může uživatel informace pouze prohlížet, případné opravy IDP lze provádět pouze v „režimu oprav“, tzn. uživatel musí mít aktivovanou operaci se skladbou saldokonta (to provede spuštěním dané operace – klávesa F9). První obrázek (obr. 6) poskytuje uživateli příklad, kdy je saldokonto účtu 3111 s IDP 20080100170001 nevyrovnané, na druhém obrázku (obr. 7) už jsou hodnoty saldokonta vyrovnané (tzn. došlo k úhradě platby a strany MD a D se nyní rovnají).

obr. 6

obr. 7

Po stisku ikony „tiskárna“ (panel nástrojů v horní liště) má uživatel k dispozici tyto nadefinované předlohy výstupu:

¨ Účetní doklad (košilky) – klasická sestava, která uživateli poskytuje přehled o tom, jak je účetní zápis zaúčtován, tzn. informace o účtu, částce, straně, za jaké středisko (tj. organizační selektor) a kdo a kdy daný účetní zápis provedl

¨ UD2 (účetní doklad) – klasická sestava představující účetní zápis v řádcích, velmi stručný přehled o zaúčtování, tzn. datum, účet, strana, č. procesu, druh operace, popis události a identifikace obchodního selektoru – na konci sestavy součtový řádek strany MD a D za daný účetní zápis.

¨ Hlavní kniha – sestava typu Excel. Poskytuje uživateli přehled (na základě zadaného výběru – všechny účty, pouze účty určité třídy, konkrétní analytický účet apod.) o daném účtu – tzn. počáteční stav, obraty stran MD a D (u každého obratu je navíc k dispozici datum účetního případu a číslo procesu) a konečný zůstatek daného účtu.

¨ Hodnocení zakázek položkově – ve výběru (záložka Výběr) si uživatel zadá identifikaci obchodního selektoru, jehož výsledky ho zajímají. Tato sestava mu pak poskytuje přehled o výsledcích dané zakázky (selektoru), tzn. jednotlivé zápisy na účty, stranu, částku, mezisoučty za účty a celkem součet za zakázku.

V případě potřeby doplnění sestav o další atributy nebo vytvoření další nové sestavy lze toto nastavit v rámci implementace.

3.2 Obratová tabulka (se selektory)

Činnost „obratová tabulka“ má uživatel k dispozici v hlavním menu – Účetnictví – Obratová tabulka (Obratová tabulka se selektory). Zde má k dispozici veškeré údaje o jednotlivých účtech, přičemž se jedná o údaje on-line agregované ze všech uskutečněných účetních zápisů. U každého účtu je navíc k dispozici i informace o straně účtu (MD, D) uvedené u daného účtu v účtovém rozvrhu.

Obratová tabulka se selektory se vytváří pro účty, které mají v účtovém rozvrhu zatržen příznak „sledovat obrat po selektorech“. Uživatelé mohou použít činnost přepočet obratové tabulky (menu účetnictví – speciální činnosti) a to v případech, kdy během účetního období účet dodatečně označí v účtovém rozvrhu příznakem „sledovat obrat po selektorech“. Ke každému organizačnímu selektoru je možno prostřednictvím atributu „umístění“ nastavit pro jednotlivé uživatele přístupová práva, tzn. že uživatel nevidí údaje o jednotlivých účtech s daným organizačním selektorem, pokud k němu nemá alespoň právo čtení.

Po aktivaci činnosti obratová tabulka (nebo obratová tabulka se selektory) se uživateli jako první aktivuje záložka výběr, kde si definicí jednotlivých atributů zvolí následnou množinu zobrazených dat. Na výběr má z těchto atributů:

¨ druh informace – skutečnost/plán

¨ fáze události v účetním období – neurčeno/běžná/otevření/uzavření. V případě, že chce uživatel mít k dispozici všechny pohyby, zvolí možnost „neurčeno“. V takovém případě se zároveň s prvním měsícem období zobrazuje jako další řádek i otevření účetních knih a s posledním měsícem období se zobrazuje jako další řádek i uzavření účetních knih. Při volbě „běžná“ jsou k dispozici pouze záznamy měsíců ve zvoleném období, tj. korektně se zobrazují obraty účtů běžného období.

¨ účetní období – při použití hospodářského roku obrat. tabulka zobrazuje i více měsíců dle definice účetního období ve speciálních činnostech (např. 01/2007 – 03/2008)

¨ rok, měsíc od – do – týká se kalendářního roku

¨ účet

¨ měna

¨ v činnosti obratová tabulka se selektory je možnost výběru za jednotlivé selektory

¨ zobrazit – na výběr jsou možnosti „vše“ a nebo pouze účty s „nenulovým obratem“

¨ možnost volby obecného výběru

Po zadání výběrových atributů a uložení výběru se uživateli zobrazí následující formulář:

obr. 8

Na našem ukázkovém příkladu (obr. 8) máme záložku výběr vyfiltrovanou za rok 2004 a účet 311. Ke každému aktivnímu řádku (tj. ten, na kterém má uživatel umístěn kurzor) jsou konkrétní informace ve spodní části formuláře.

U každého účtu jsou za jednotlivé měsíce ve zvoleném roce k dispozici údaje o počátečním a konečném stavu a obratech na straně Má dáti a Dal za skutečnost nebo plán. K dispozici je navíc i informace o straně účtu (MD, D) uvedené u daného účtu v účtovém rozvrhu[14].

Na záložce Hlavní kniha jsou k dispozici odpovídající účetní zápisy (události UCE), které se týkají daného řádku obratové tabulky (tj. účtu, měsíce, ...), tzn. tvoří výše zobrazený obrat, selektor.

Po stisku pravého tlačítka myši na tučném atributu „Účet“ má uživatel k dispozici činnosti (informace se vždy vztahují k aktuálnímu účtu):

¨ účetní deník (fakticky účetní zápisy týkající se tohoto účtu)

¨ účetní saldokonto

¨ účtový rozvrh

¨ obratová tabulka

¨ obratová tabulka se selektory

¨ konta

¨ konta se selektory

Pokud bude uživatel využívat obratovou tabulku k prohlížení a tisku hlavní knihy, má vždy k dispozici aktuální stavy jednotlivých obratů.

Po stisku ikony „tiskárna“ (panel nástrojů v horní liště) má uživatel k dispozici tyto nadefinované předlohy výstupu:

¨ Obratová předvaha – sestava typu Excel poskytuje uživateli informace o počátečním a konečném stavu účtu a obratech strany MD a D, přičemž se provádějí mezisoučty za syntetický účet a celkem za třídu

¨ Hlavní kniha – doporučujeme vyfiltrovat (zadat na záložce Výběr) konkrétní syntetický účet – v sestavě typu Excel má pak uživatel k dispozici jednotlivé listy za analytické účty, kde jsou k dispozici atributy – rok, měsíc, účet, měna, datum, druh operace, MD, D, popis události a ident. a název adresáta – a zároveň je k dispozici suma obratů po měsících a suma celkem. Při tisku této sestavy má uživatel navíc k dispozici ještě jeden list, kde má k dispozici informace o nenulových obratech za všechny analytické účty. V případě velkého objemu dat však doporučujeme tisk hlavní knihy raději nad činností účetní deník.

¨ Hlavní kniha (1 list) - doporučujeme vyfiltrovat (zadat na záložce Výběr) konkrétní syntetický účet – v sestavě typu Excel má pak uživatel k dispozici pouze jeden list s přehledem jednotlivých analytických účtů, kde jsou k dispozici atributy –datum, č. dokladu, MD, D, popis, org.sel., ident. a název adresáta, zapsáno, IDP – a zároveň je k dispozici suma obratů po měsících a suma celkem.

V případě potřeby doplnění sestav o další atributy nebo vytvoření další nové sestavy lze toto nastavit v rámci implementace.

3.2.1 Konta (se selektory)

Konta má uživatel k dispozici v hlavním menu – Účetnictví – Konta (Konta se selektory). Podobně jako v činnosti Obratová tabulka má uživatel po aktivaci této činnosti nejprve k dispozici záložku Výběr. Na základě jejího vyplnění má následně k dispozici veškeré informace o konečném stavu účtu ke konci vybraného období za jednotlivé selektory. Počáteční stav je hodnota k prvnímu dni účetního období, tj. dle otevření účetních knih. Obraty (MD, D) uvádějí vždy sumární obrat od počátku roku do konce uvedeného měsíce. U každého účtu je k dispozici i informace o straně účtu (MD, D) uvedené u daného účtu v účtovém rozvrhu.

Na záložce hlavní kniha jsou k dispozici odpovídající účetní zápisy (události UCE), které se týkají daného konta, tj. (účtu, měsíce, ...), které tvoří výše zobrazený obrat. Po stisku pravého tlačítka myši na tučném atributu „Účet“ má uživatel k dispozici podrobnější informace vztahující se k aktuálnímu účtu.

Ke každému organizačnímu selektoru je možno prostřednictvím atributu „umístění“ nastavit pro jednotlivé uživatele přístupová práva, tzn. že uživatel nevidí údaje o jednotlivých účtech s daným organizačním selektorem, pokud k němu nemá alespoň právo čtení.

Po stisku ikony „tiskárna“ (panel nástrojů v horní liště) má uživatel k dispozici tyto nadefinované předlohy výstupu:

¨ Konta – tato předloha výstupu (typu sestava) poskytuje uživateli informace o jednotlivých účtech, počátečním stavu, obratech MD a D a konečném stavu, přičemž se provádí součet za účtovou třídu.

¨ Konta se součty na SÚ (syntet. účet) – předloha typu sestava se stejnými atributy jako výše uvedená s tím rozdílem, že součty se neprovádějí za účtovou třídu, ale za jednotlivé syntetické účty.

V případě potřeby doplnění sestav o další atributy nebo vytvoření další nové sestavy lze toto nastavit v rámci implementace.

3.3 Hlavní kniha

Hlavní kniha je účetní kniha, ve které jsou účetní záznamy uspořádané z věcného hlediska, tj. dle čísla účtu. V IS BM se tedy jedná o on-line zobrazení položek účetních zápisů na daný účet, případně na všechny (vybrané) účty s řazením položek účetních zápisů dle čísla účtu. Hlavní kniha je v IS BM primárně vedena pro každý použitý účet[15].

Uživatel má činnost Hlavní kniha pro jednotlivé účty vždy k dispozici na formulářích činností s agregovanými obraty účtu (např. Obratové tabulky, Konta) na vlastní záložce „Hlavní kniha“, která se zobrazí za daný účet a daný měsíc z obratových tabulek a nebo za daný účet od počátku roku z kont (vždy za zobrazený obrat na obou stranách). Obratová tabulka tedy obsahuje sumární stavy za jednotlivé analytické účty po měsících a selektorech, kdežto hlavní kniha obsahuje položkové údaje daného analytického účtu za konkrétní měsíc a selektor.

U každého účtu má uživatel v okně „Hlavní kniha“ nejprve přehled o agregovaných hodnotách za období, tj. o jeho počátečním stavu, obratech na straně MD, obratech na straně D a konečném stavu za zvolené období vyjádřené v Kč a zároveň jsou zobrazeny hodnoty obratů téhož účtu v hodnotách konkrétních použitých cizích měn[16]. Následuje detailní seznam všech položek účetních zápisů na daný účet v daném období.

Po stisku pravého tlačítka myši na tučném atributu „Účet“ má uživatel k dispozici činnosti (informace se vždy vztahují k aktuálnímu účtu):

¨ účetní deník (fakticky účetní zápisy týkající se tohoto účtu)

¨ účetní saldokonto

¨ účtový rozvrh

¨ obratová tabulka

¨ obratová tabulka se selektory

¨ konta

¨ konta se selektory

Po stisku klávesy F9 na vybraném řádku Hlavní knihy daného účtu se uživateli zobrazí konkrétní účetní zápis (operace UCE), jehož součástí je daný řádek Hlavní knihy. Po stisku ikonky „tiskárna“ nebo klávesy Ctrl T má uživatel k dispozici tiskovou sestavu Hlavní kniha (pouze v činnosti Obratová tabulka – viz. popis v kapitole 3.2).

Jiný způsob, jak získat zobrazení hlavní knihy (a to i kompletní za všechny účty současně) z účetních zápisů, je volba odpovídajícího řazení a výběru přímo v činnosti Účetní deník s případnou agregací v předloze výstupu (viz. popis v kapitole 3.1).

Na našem ukázkovém příkladu (obr. 9) máme záložku výběr vyfiltrovanou za rok 2004 a účet 311 je v obratové tabulce aktivní řádek (je na něm umístěn kurzor) s obratem na účtu 311 za osmý měsíc roku 2004. Záložka Hlavní kniha pak uživateli poskytuje všechny pohyby (položky účetních zápisů) účtu 311 v osmém měsíci roku 2004. Po stisku klávesy F9 (nebo menu Volby – „Spustit operaci“) se uživateli aktivuje celý účetní zápis[17] reprezentující účetní doklad, tak, jak byl zaúčtován v účetním deníku.

obr. 9

4. Saldokonto

V IS BM lze pomocí funkcionality saldokonta sledovat a řídit související účetní případy, které jsou reprezentované řadou dokladů, aby se udržela kontrola nad všemi saldokontně nevyrovnanými účetními zápisy. Základními nástroji saldokonta v IS BM jsou:

¨ Nastavení příznaku saldokontní „Ano“ u daného účtu v účtovém rozvrhu. Jako saldokontní lze nastavit libovolný účet rozvrhu, tj. nejen účty zachycující dodavatelsko–odběratelské vztahy, ale také např. účty třídy 1 (111, 112, 122 apod.).

¨ IDP uváděná v položkách účetních zápisů zajistí, že se položky se shodnou IDP stávají součástí souvisejících účetních případů (tj. jednoho saldokontně sledovaného celku). IDP je primárně předplňována identifikací hlavního procesu. Uživatelsky je možno tuto IDP změnit. Pokud to není vysloveně nutné, tak IDP uživateli měnit nedoporučujeme (ruční změnou IDP uživatel ztratí výhodu automatického spárování a pak si musí v celém saldokontním případu IDP hlídat ručně).

¨ Atribut „jiné párování“ v účetních zápisech nastaven na „Ano“ zajistí, že daná položka účetního zápisu se do saldokonta nezahrnuje, tj. velmi výjimečné použití.

¨ Činnosti určené k analýze neukončených saldokontních případů (účetní saldokonto a účetní saldokonto do data).

¨ Atribut „saldokontně neuzavřené“ na výběrové záložce činnosti Účetní deník (jeho zatržení zajistí, že se uživateli zobrazí jen saldokontně nevyrovnané účetní zápisy).

Účetní saldokonto v IS BM je vedeno vždy v referenční měně, tzn. v CZK. Účetní saldokonto sleduje, zda jsou vyrovnané strany Má dáti a Dal u saldokontních účtů jednotlivých účetních zápisů (dle IDP). Jedinou výchozí podmínkou pro správnou evidenci účetního saldokonta je prvotní úprava účtového rozvrhu. Uživatel si u jednotlivých účtů musí nastavit, zda jsou či nejsou saldokontní.

„Nerozlučná“ dvojice pro sledování účetního saldokonta (zde míněno ve smyslu dodavatelsko-odběratelských vztahů) je IDP a adresát. Neměla by nastat situace, že ke konkrétní IDP jsou navázáni dva různí adresáti.

Do účetního saldokonta se vždy zahrnují položky účetních zápisů na účtu, který má v účtovém rozvrhu nastaven příznak saldokontní „ANO“ a událost účetnictví má u atributu Jiné párování příznak „NE“. Účetní saldokonto lze do určité míry analyzovat i v činnosti Účetním deník, a to pomocí atributu „saldokontně neuzavřené“ ze záložky Výběr. Poté je nutno položku účetního zápisu uvést do režimu oprav (tj. po stisku klávesy F9 – Spustit operaci) a po stisku klávesy F2 na identifikaci párování (IDP) u saldokontního účtu dané položky účetního zápisu má uživatel k dispozici přesnou hodnotu a skladbu saldokonta dané IDP. V jednodušší formě, ale rychleji lze tuto informaci získat na záložce Saldokonto.

Zcela výjimečně mohou uživatelé použít činnost přepočet účetního saldokonta (menu účetnictví – speciální činnosti) a to v případech, kdy během účetního období nesaldokontní účet označí v účtovém rozvrhu jako saldokontní - pak je nutné hodnoty tohoto účtu znovu přepočítat. Optimální je ovšem provést nastavení příznaku „saldokontní účet – ANO“ před použitím daného účtu. Provedení přepočtu saldokonta však nezajišťuje automatické doplnění IDP číslem hlavního procesu – přepočet do prázdných IDP v účetních zápisech saldokontních účtů automaticky naplní pouze „pomlčku“.

Činnost saldokonto má uživatel k dispozici v hlavním menu – účetnictví – saldokonto nebo saldokonto do data. Z důvodu větší variability možností nastavení záložky Výběr je výhodnější používat činnost „saldokonto do data“. Jako první se uživateli po její aktivaci nabídnou k zadání atributy na záložce Výběr. Uživatel může vybírat podle konkrétní IDP a čísla účtu s tím, že je možno určit „datum do“, tzn. k dispozici je pak stav saldokonta pro inventarizaci. Na výběrové záložce lze vybírat informace pro konkrétního adresáta, a to při použití obecného výběru „Saldokonto adresáta“. Pokud je pro danou IDP saldokonto vyrovnané, v této činnosti se vůbec nenabízí, tj. zobrazují se pouze IDP, která mají saldokonto nevyrovnané. Informace o (ne)vyrovnaném saldokontu je samozřejmě stále k dispozici v činnosti Účetní deník u každého zápisu na saldokontní účet na záložce Saldokonto.

Třetí obrazovka na následujícím obrázku představuje konkrétní nevyrovnané saldokonto pro IDP (20080100175016). Obecně činnost „účetní saldokonto do data“ poskytuje uživateli přehled neukončených (nevyrovnaných) účetních případů z hlediska saldokonta. Na záložce „saldokonto“ má uživatel k dispozici následující údaje:

¨ IDP – identifikace párování – jak jsme se již zmínili v účetním deníku, je IDP primárně předplňována podle čísla hlavního procesu. Uživatelsky je možno tuto IDP měnit, ale pro uživatele to pak znamená, že jakmile změní IDP (při zápisu události do účetního deníku), systém tím ztratí svoji velkou výhodu (automatické párování a veškeré další párování v systému, týkající se změněné IDP je nutno provádět ručně), proto pokud to není vysloveně nutné, IDP uživateli měnit nedoporučujeme. Zcela vyhovujícím je standardní IDP v případě závazků a pohledávek vyplývajících z dodavatelsko odběratelských vztahů.

¨ Účet – saldokontní účet, s nímž je daná IDP spojena. Po stisku pravého tlačítka myši na tučném atributu „Účet“ má uživatel k dispozici (informace se vždy vztahují k aktuálnímu účtu):

§ účetní deník

§ účetní saldokonto

§ účtový rozvrh

§ obratová tabulka

§ obratová tabulka se selektory

§ konta

§ konta se selektory

¨ Hodnota saldokonta – vyjadřující výši nevyrovnanosti daného saldokontního případu (IDP).

Záložka „skladba saldokonta“ poskytuje uživateli přehled účetních záznamů, které se svojí hodnotou podílejí na zůstatku (hodnotě) saldokonta daného účtu a IDP. Po stisku klávesy F9 se uživateli zobrazí celý konkrétní účetní zápis (operace UCE), kde lze v případě potřeby opravovat identifikaci párování (IDP). Jedním z požadavků na úpravu IDP je např. více nezávislých úhrad záloh poskytnutých (tj. více procesů), na které navazuje pouze jedna faktura přijatá (vyúčtování). V případě činností „Účetní saldokonto“ lze IDP opravit přímo na záložce Skladba saldokonta.

Následující obrázek (č. 10) poskytuje uživateli přehled o tom, jak je důležité mít všechny údaje, které se týkají saldokonta správně zadány. V účtovém rozvrhu je nutno mít daný účet označen jako saldokontní (první z trojice obrázků). Při vytvoření položky účetního zápisu s účtem, který je označen jako saldokontní, se automaticky na základě čísla hlavního procesu předplní IDP a zároveň je nutno mít atribut „jiné párování“ nastaven na hodnotu NE (viz. druhý obrázek v trojici). Třetí obrázek pak poskytuje uživateli přehled, jak je možno pohodlně sledovat, zda je saldokonto vyrovnané či nikoliv. Záložka „saldokonto“ mu poskytuje informaci o IDP, účtu a hodnotě, která dosud není vyrovnána. Druhá záložka „skladba saldokonta“ poskytuje informaci o položkách účetních zápisů, které jsou součástí daného saldokontního případu (IDP). Konkrétněji vysvětleno je ze „skladby saldokonta“ zřejmé, že byla vystavena faktura na částku 132 566,- (účet 311, strana MD). Poté následovaly tři úhrady ve výši 45 000,-, 45 000,- a 40 000,- (účet 311, strana D). Každou z těchto úhrad (účetní zápis – operace komponenty UCE) je možno po stisku klávesy F9 aktivovat a prohlédnout si. Jednoduchým výpočtem MD – D vychází, že hodnota (zůstatek) dosud nevyrovnaného saldokonta s IDP 20080100175016 je částka 2 566,-.

obr. 10

V činnosti „účetní saldokonto do data“ má uživatel po stisku ikony „tiskárna“ (panel nástrojů v horní liště) k dispozici následující nadefinované předlohy výstupu (všechny typu Excel). Před vlastním spuštěním jednotlivých předloh výstupu doporučujeme uživateli si určitým způsobem vyfiltrovat záložku Výběr (za konkrétního adresáta[18], za konkrétní účet nebo IDP apod.), vždy podle toho, jaká konkrétní informace uživatele zajímá.

¨ Saldokonto adresátů k datu dle IDP – přehled položek účetních zápisů všech saldokontních případů řazený dle adresáta, čísla účtu, IDP, data a částky s mezisoučtem za IDP + účet + adresát a mezisoučtem za účet + adresát. Jedná se tedy o inventarizační výstup řazený primárně dle adresáta. Lze doporučit výběr za účet.

¨ Saldokonto adresátů k datu dle účtu – přehled položek účetních zápisů všech saldokontních případů řazený dle účtu, adresáta, IDP, data a částky. Podobná sestava jako výše uvedená, s tím rozdílem, že není primárně setříděna podle adresáta, ale podle čísla účtu a k němu se vztahují zobrazené atributy.

¨ Saldokonto k datu dle IDP - přehled položek účetních zápisů všech saldokontních případů řazený dle účtu, IDP, adresáta, data a částky. Jednotlivé atributy jsou vyfiltrovány podle čísla účtu, čísla IDP a adresáta. Mezisoučty jsou vždy za jednotlivé IDP a pak celkem za daného adresáta + účet + syntetický účet.

V případě potřeby doplnění sestav o další atributy nebo vytvoření další nové sestavy lze toto nastavit v rámci implementace.

5. Číslování dokladů (zápisů)

Číslování účetních zápisů (případně i účetních dokladů) probíhá v informačním systému zcela automaticky na základě nadefinovaných číselných řad. Každý druh procesu (nebo věcně podobné druhy procesů) má svoji číselnou řadu, např. jedna řada může být pro vystavené tuzemské faktury různým druhem procesu, další řada může být pro vystavené zahraniční faktury různým druhem procesu apod. Číslo dokladu se skládá z identifikace roku, identifikace datového úložiště a vlastního čísla dle nadefinované číselné řady u druhu procesu (podrobné vysvětlení je uvedeno ve Slovníku pojmů u pojmu „identifikace procesu“).

Operace účetnictví (účetní zápis) je ve většině případů součástí konkrétního procesu, tzv. proces završuje. Jednotlivé události operace účetnictví tudíž přejímají číslování druhu procesu. Vlastní číselnou řadu mají pouze operace účetnictví, které nejsou součástí žádného druhu procesu (tzn. nevznikly na základě operativní evidence), tj. obvykle obecný účetní zápis a operace otevření a uzavření účetních knih. Číslování dokladů v účetnictví tedy probíhá na základě operativní evidence (v operativě systému zahájené procesy) a nebo dle vlastní číselné řady.

Na následujícím obrázku (č. 11) je k dispozici pohled na vytvořený proces prodeje, tzn. vystavení odeslané faktury. Je zřejmé, že všechny operace v daném procesu (obchod, dph, platby, účetnictví apod.) mají shodné číslo.

Pro uživatele je toto výhodné z toho důvodu, že během práce s informačním systémem složení číselných řad bez problémů navnímá a pak při hledání v účetním deníku už ví, že operace zaúčtování odeslané faktury začíná např. číslováním 001 (tzn. všechny položky v činnosti Účetní deník, které se týkají zaúčtování odeslané faktury začínají 001), operace přijaté faktury 002 apod.

obr. 11

6. Výkazy

Výkazy má uživatel k dispozici v hlavním menu v činnosti Informační centrum – Výkazy – Výkazy ke spuštění – Účetní. S nákupem IS BM jsou standardně distribuovány tyto výkazy[19]:

¨ Rozvaha v plném rozsahu

¨ Rozvaha ve zjednodušeném rozsahu

¨ Výkaz zisku a ztráty v plném rozsahu

¨ Výkaz zisku a ztráty ve zjednodušeném rozsahu

¨ roční výkaz Cash flow (u výkazu cash flow je nutno podotknout, že sestavení tohoto výkazu vyžaduje od uživatele detailnější evidenci v účetním deníku, případně v operativních evidencích)

Rozvaha je sestava aktiv a pasiv (porovnání majetku a zdrojů jeho financování k určitému datu) a podle zákona o účetnictví je povinnou součástí účetní závěrky.

Výkaz zisku a ztráty (někdy zkráceně Výsledovka) ukazuje, jakého hospodářského výsledku společnost dosáhla za sledované a minulé období. Výkaz zisku a ztráty je podle zákona o účetnictví povinnou součástí účetní závěrky.

Forma výkazu zisku a ztráty je v ČR upravena, používá se buď ve zkrácené nebo plné verzi. Zájemce z ní získá základní přehled o hospodaření společnosti, velikosti tržeb, nákladů v základním členění (materiálové, mzdové, odpisy…) a výši zisku či ztráty.

Výkaz o peněžních tocích neboli výkaz cash flow je součástí přílohy k účetní závěrce sestavované v plném rozsahu. Z hlediska potřeb podrobného zhodnocení finanční situace podniku a úrovně finančního řízení za dané období mají rozvaha i výkaz zisků a ztrát určitá omezení, a proto podniky sestavují cash flow jako součást přílohy k účetní závěrce.

Po volbě definice výkazu, tj. po spuštění vybraného výkazu z menu (Informační centrum – Výkazy – Výkazy ke spuštění – Účetní), je uživatel v dialogovém okně vyzván k zadání zpřesňujících volitelných požadavků, které ovlivňují informace zobrazené na výkazu, tzv. proměnných dotazu výkazu (např.: období – měsíc a rok od a měsíc a rok do, selektory, zaokrouhlení apod.), jejichž hodnoty se použijí jako aktuální hodnoty parametrů při vlastním sestavení výkazu.

Po zadání údajů do tohoto dialogového okna se následně spustí MS Excel s aplikací šablony na jednotlivé listy. Následně je zahájeno vyplňování jednotlivých buněk výkazu (na základě nastavení v definici listu). Sestavování výkazu je pro uživatele viditelné. Po ukončení sestavení výkazu dochází k ukončení komunikace IS BM s aplikací MS Excel. Během výpočtu výkazu může být nastaveno, že ostatní uživatelé nesmí provádět účetní zápisy, aby bylo dosaženo korektních výsledků (ve Slovníku pojmů pojem „Rezervované zdroje systému“).

Po rozhodnutí uživatele ukončit práci s daným výkazem v MS Excel má na výběr možnost:

¨ uložení výkazu pod nově zadaným jménem (s cílem dalšího budoucího zpracování do souboru) – zde však nedochází k přepsání při opakovaném sestavení výkazu

¨ uložení výkazu pod svým (jeho) jménem, což umožňuje případné předplnění dat, formátů a grafů při opakovaném sestavení výkazu

6.1 Definice výkazů

Jak je patrné z předchozí kapitoly, jsou definice výkazů, tj. forma výkazů (vzhled, grafická úprava) a obsah výkazů (struktura a hodnoty údajů) uživatelsky dostupné, takže změny v nich si můžete nastavit samostatně nebo i formou importu balíčku z BM Servis s.r.o.

V rámci těchto definic lze definovat i zcela nové výkazy (např. v souladu s mezinárodními standardy nebo pro interní účely apod.). Účetní výkazy jsou obvykle koncipovány jako výkazy dle vzoru, což umožní i uživateli bez IT odbornosti jejich modifikace. V rámci definice výkazu se nastavují práva uživatelů jej užívat.

Detailnější informace o výkazech a jejich definování lze získat v dokumentaci Ovládání (kapitola 2.2.6) nebo ve Slovníku pojmů (jedná se např. o tyto pojmy: výkazy, definice výkazu, listy výkazu, vzory listů, funkce výkazů, šablony listů výkazu, ...).

7. Selektory

Selektory v IS BM představují nástroj k vnitrofiremnímu členění informací, a tedy i položek účetních zápisů, dle Vašich zvyklostí, např. dle středisek, pracovních míst, zakázek, projektů, okruhu výrobků, služeb či materiálů apod.

Informační systém BM disponuje třemi druhy selektorů – obchodním, organizačním a technicko-věcným. Vzhledem k provázanosti selektorů s celým systémem (obchodní selektor je svázán s adresátem, organizační s umístěními a technicko-věcný s artikly) a na základě provázání operativní evidence s účetnictvím[20] je možno z velké části zautomatizovat předplňování selektorů do jednotlivých položek účetních zápisů.

Význam selektorů v účetnictví lze vyložit následujícím způsobem:

¨ pomocí obchodního selektoru se např. zjišťuje efektivnost, tzn. náklady a výnosy za jednotlivé obchodní zakázky, segmenty trhu, projekty, ....

¨ protože většina firem má určitou organizační strukturu, tak právě organizační selektor umožňuje zjišťovat výsledky za jednotlivá střediska, dílny, pracoviště, ...

¨ technicko-věcný selektor umožňuje nahlížet na evidované skutečnosti z pohledu věcného, a to i v jiné struktuře, než je účetní rozvrh odvozený ze Směrné účtové osnovy

U každého selektoru lze nastavit jeho platnost od – do, tzn. v položkách účetního zápisu s datem mimo tento interval jej nelze užít. U organizačního selektoru se navíc eviduje umístění (lze definovat přístupová práva), tzn. že pokud je položka účetního zápisu (událost účetnictví) uvedena s organizačním selektorem, na jehož umístění nemá uživatel právo čtení nebo zápis, není mu tato položka zobrazena. Stejně tak to platí v činnosti Obratová tabulka se selektory a Konta se selektory. Uživatel nevidí obraty účtu se selektorem, ke kterému nemá alespoň právo čtení. Uživatel pak může na základě selektorů vyhledávat v účetních zápisech nebo si lze připravit různé výkazy, kde budou vyhodnoceny např. tržby za střediska, za okruhy výrobků apod.

Následující obrázek (č. 12) poskytuje uživateli názornou ukázku, jak pak může vypadat položka účetního zápisu (v našem případě se jedná o účtování pohledávky), kde se na základě správného nastavení údajů v operativní evidenci (tj. transformace a uvedení selektorů v jednotlivých činnostech - adresář, artikl, umístění) automaticky předplnily jednotlivé selektory. Z obrázku vyplývá, že obchodní selektor je reprezentován konkrétní obchodní zakázkou (Rozvoj), organizační selektor vypovídá, že tuto obchodní zakázku zajišťovalo „středisko ČB“ a technicko-věcný selektor uživateli sděluje, že se jednalo o tržbu, která se týká „dámské konfekce – luxus“.

obr. 12

Další možnost prezentace informací poskytuje uživateli činnost Obecné stromy (v hlavním menu Informační centrum – Obecné stromy – Vyvolání obecného stromu). Po nadefinování struktury obecného stromu si lze, jak ukazuje obrázek (č.13) níže, velmi názorně prohlédnout strukturu organizačního selektoru ve firmě.

obr. 13

V případě, že ve firmě nebudou využity pro vnitropodnikové členění selektory, ale pouze vytvořená šestimístná analytika účtu, tak je možno i toto analytické členění po nadefinování (v obecných stromech) prezentovat obdobným způsobem.

8. Otevření a uzavření účetních knih

Otevření účetních knih se provádí:

¨ při zahájení práce s komponentou účetnictví

¨ po provedení účetní závěrky

Pro otevření účetních knih slouží proces v nabídce Nový proces – Účetní zápisy – Prvotní evidence – Otevření účetních knih. Tento proces se případně použije i pro otevření podrozvahové evidence.

Otevření účetních knih spočívá v účetním zápisu, kde se nastaví zůstatky rozvahových účtů dle předchozího účetního období. Otevření lze opakovat libovolněkrát při současném zrušení předchozího provizorního otevření. Uzavření účetních knih spočívá v účetním zápisu, kde se zůstatky účtů automaticky převedou na účty třídy 7. Účetní zápisy otevírání a uzavírání účetních knih mají atribut „jiné párování“ nastaven na „Ano“[21]. Tyto účetní zápisy lze sice uskutečnit ručním vstupem (nelze doporučit), ale mnohem účelnější a uživatelsky přítulnější je využití šablon.

Po aktivaci procesu „otevření účetních knih“ je uživateli k dispozici šablona (viz. obr. 14) pro otevření účetních knih (tato šablona se automaticky nabízí pouze při prvním spuštění procesu otevření účetních knih[22], při následných opravách[23] je nutno si šablonu po stisku Ctrl F3 vyvolat ručně), která nabízí:

¨ Období – výběr účetního období, ke kterému se účetní knihy otevírají.

¨ Druh – výběr druhu informace (skutečnost/plán).

¨ Otevření z uzávěrky před. období – jedná se o atribut, který implicitně zůstává nastaven na NE. Protože na začátku dalšího účetního období obvykle dochází k tzv. provizornímu otevření účetních knih, ale uzavření ještě ve většině případů není provedeno, otevírají se účetní knihy bez souvislosti na účetní zápis uzavření předchozího období[24]. Teprve v okamžiku, kdy má uživatel všechny účetní náležitosti závěrky v pořádku a provede korektní uzavření účetních knih, uplatní otevření účetních knih ze závěrky předchozích období. Jinými slovy, položky účetního zápisu týkající se provizorního otevření účetních knih se zruší a provede se regulérní otevření účetních knih s tímto atributem nastaveným na hodnotu „ANO“.

¨ Respektovat selektory – tato volba vyplývá z toho, zda uživatel uvádí selektory na rozvahových účtech. Pokud ano, musí i zde být nastaveno ANO. V případě, že probíhá otevření účetních knih na základě předchozí uzávěrky, musí zde být uvedena stejná hodnota jako v závěrce (účetní zápisy uzavření účetních knih).

¨ Agregované zápisy na účty 7.. – volba zápisu na účty účtové třídy 7. k otevíraným účtům 1:1 nebo agregovaně.

¨ Měna – v případě, že uživatel vede některé účty i v cizí měně, tak ze Zákona o účetnictví pro něj vyplývá povinnost provést otevření účetních knih v těch měnách, ve kterých jsou účty vedeny. Potom pro tento atribut platí doporučení, že při otevření účetních knih ho uživatel nechá prázdný a systém automaticky provede otevření ve všech měnách.

obr. 14

Výběrem: období, druh „skutečnost“, otevření u uzávěrky „ne“, selektory „ne“, agregace „ano“ a měna umožní opakovaně provést provizorní otevření účetnictví. Zapsanou účetní operaci NEUKONČIT!!! , zvolit pouze možnost ZAPSAT. Operaci ukončit až po provedení řádné uzávěrky účetních knih (v praxi to znamená, že uživatel provede řádnou účetní uzávěrku a původní provizorní události operace otevření se vyruší a pomocí šablony se provede nové korektní otevření účetních knih a v šabloně se v atributu „otevření z uzávěrky před. období“ vybere možnost ANO).

V případě promítnutí změn zaúčtovaných do minulého období již po otevření je nutno znovu spustit již zapsanou operaci otevření účetních knih[25], označit všechny události (Volby označování), zrušit označené události, provést nový vstup šablonou (Ctrl F3), zapsat a neukončit.

Definitivní otevření účetních knih (po uzavření) se provede šablonou s volbou otevření z uzávěrky minulého období „ano“. Systém kontroluje existenci účetního zápisu (operace UCE – uzavření účetních knih) uzavření účetních knih, bez ní otevření neproběhne.

Pro otevření účtů podrozvahové evidence se používají stejné procesy jako pro běžné otevření účetních knih (tzn. Nový proces – Účetní zápisy – prvotní evidence) s tím rozdílem, že se nevyužívá možností šablony, ale nadefinovaného importu. Uživatel si aktivuje proces otevření účetních knih – zvolí menu Obecné – Import/Export dat a variantu „Otevření podrozvahových účtů“ požadovaného roku a měny. Při standardním provozu by mělo platit, že uživatelé spouští procesy pro otevření účtů 0 až 6 a další procesy pro otevření podrozvahových účtů – každý pouze jednou.

Systém umožňuje otevření účetních knih provést automaticky (tj. šablonou) pouze jednou ročně. V případě potřeby znovuotevření účetních knih je nutno původní operaci otevření odblokovat (storno neprovádět) a znovu zadat správně (v případě nejasností je toto nutno řešit ve spolupráci s pracovníky IT BM Servis s.r.o., kteří provedou ruční zásah do systému).

Uzavření účetních knih úzce souvisí s účetní závěrkou. Při provádění účetní závěrky dojde k uzavření účtů podle zákonem dané předkontace. Ke dni uzavření účetních knih systém spočítal určitý konečný zůstatek účtů.

Při závěrce systém tyto zůstatky vynuluje a zaúčtuje podle nastavených předkontací v šabloně. Závěrka vyčíslí zisk nebo ztrátu a následně je zaúčtuje. Při závěrce se obraty účtů (v obratové tabulce) načítají do zvláštního 13-tého měsíce, tzn., že obraty 12-tého měsíce nijak neovlivní. Běžně se závěrka provádí k 31.12., ale je možno, že uživatel ji bude potřebovat provést i během roku (např. konkurz nebo likvidace firmy).

Pro uzavření účetních knih slouží proces v nabídce Nový proces – Účetní zápisy – Prvotní evidence – Uzavření účetních knih. Tento proces se případně použije i pro uzavření podrozvahové evidence.

Po aktivaci procesu „uzavření účetních knih“ se nabídne šablona (Ctrl F3 – viz. obr. 15), která nabízí obdobné možnosti jako otevření účetních knih, tj. období, druhu, možnost výběru otevření účtů po jednotlivých účetních selektorech či kumulaci bez ohledu na selektory a dále volbu zápisu na účty účtové třídy 7. k uzavíraným účtům 1:1 nebo agregovaně. Měnu lze vypsat a nadále se tato měna nabízí při opakovaném využití této šablony. V případě potřeby uzávěrky účtů i v cizích měnách je možné uzavírat účty po jednotlivých měnách nebo za všechny měny najednou (nevyplnění nabídky Měna).

obr. 15

Pro uzavření účtů podrozvahové evidence se používají stejné procesy jako pro běžné uzavření účetních knih (tzn. Nový proces – Účetní zápisy – prvotní evidence) s tím rozdílem, že se nevyužívá možností šablony, ale nadefinovaného importu. Uživatel si aktivuje proces uzavření účetních knih – zvolí menu Obecné – Import/Export dat a variantu „Uzavření podrozvahových účtů“ požadovaného roku a měny. Při standardním provozu by mělo platit, že uživatelé spouští procesy pro uzavření účtů 0 až 6 a další procesy pro uzavření podrozvahových účtů – každý pouze jednou.

Systém umožňuje uzavření účetních knih provést automaticky pomocí šablony pouze jednou za účetní období. V případě potřeby opakovaného uzavření účetních knih je nutno původní operaci uzavření odblokovat (storno neprovádět) a znovu zadat správně (v případě nejasností je toto nutno řešit ve spolupráci s pracovníky IT BM Servis s.r.o., kteří provedou ruční zásah do systému).

Šablony pro otevření či uzavření účetních knih standardně pracují se syntetickými účty 701, 702, 710 a 431.

9. Speciální činnosti

Jedná se o činnosti, které ovlivňují nastavení a chování celé komponenty účetnictví. Uživatel je má k dispozici v hlavním menu v činnosti Účetnictví - Speciální činnosti.

9.1 Přepočet obratové tabulky

Přepočet obratové tabulky má uživatel k dispozici v hlavním menu - Účetnictví - Speciální činnosti. Přepočet obratové tabulky slouží k aktualizaci hodnot v obratové tabulce. Během účetního období může uživatel provést v komponentě účetnictví změny v nastavení a pak se někdy hodnoty v obratové tabulce mohou jevit jako „zavádějící“. V takovém případě je vhodné aktivovat přepočet obratové tabulky, nejčastějším důvodem je:

¨ změna strany účtu v účtovém rozvrhu

¨ změna sledování obratů za jednotlivé selektory v účtovém rozvrhu

¨ změna hodnoty atributu „obrat v ZM“

Po spuštění této činnosti je uživatel dotázán na účetní období, za který chce provádět přepočet, ten si vybere z překryvného seznamu a pak je systémem ještě znovu položen dotaz, zda opravdu provést přepočet. Po potvrzení volby Ano je proveden přepočet obratové tabulky. Přepočet obratové tabulky blokuje pro ostatní uživatele možnost účetních zápisů po dobu přepočtu.

9.2 Přepočet účetního saldokonta

Přepočet účetního saldokonta má uživatel k dispozici v hlavním menu - Účetnictví - Speciální činnosti. Přepočet účetního saldokonta slouží k aktualizaci saldokontních hodnot. Uživatel tuto činnost aktivuje v případě, že:

¨ během účetního období označí uživatel nesaldokontní účet v účtovém rozvrhu jako saldokontní (anebo naopak) - pak je nutné hodnoty tohoto účtu znovu přepočítat.

¨ zjistil nejasnosti v saldokontu za konkrétní IDP nebo účet a tzv. si s nimi neví rady

Po spuštění této činnosti má uživatel možnost zvolit si pro přepočet konkrétní IDP nebo účet. V případě, že ponechá nabídnutý výběr prázdný, přepočítává se saldokonto u všech účtů i IDP najednou.

9.3 Parametry účetnictví

Tuto činnost má uživatel k dispozici v hlavním menu – Účetnictví – Speciální činnosti. Obsahuje následující atributy:

obr. 16

¨ Povolit účtování do budoucna – při zaškrtnutí tohoto příznaku je povoleno uskutečnit účetní zápisy s datem do budoucna. Pokud tento příznak není zatržen a uživatel zadá datum do budoucna, systém v souladu se stávajícím zákonem o účetnictví upozorňuje: „datum události musí být menší nebo rovno dnešnímu datu“ a nedovolí zapsat.

¨ Povolit na účetním dokladu záznamy jednoho měsíce – při zatržení tohoto příznaku je hlídáno, aby při zápisu položek jednoho účetního zápisu (jedné operace UCE) do činnosti Účetní deník byla data všech položek ve stejném měsíci. Pokud jsou položky zapisovány s daty různých měsíců, systém upozorňuje: „události v rámci aktuálního dokladu nemají shodné datum zápisu“ a nepovolí zápis.

9.4 Účetní období

Účetní období je přesně definováno Zákonem o účetnictví. V této kapitole si uvedeme některé ze základních charakteristik.

Účetní období je období, k jehož konci se sestavuje účetní závěrka. Období trvá obvykle 12 měsíců, přičemž se může shodovat s kalendářním rokem anebo ne (pak se jedná o hospodářský rok). Jiná délka účetního období se uplatní např. při přechodu z kalendářního roku na hospodářský a naopak, při založení společnosti a v dalších případech dle Zákona o účetnictví. IS BM umožňuje zápisy pouze do definovaných (neuzavřených) účetních období, to se uplatní i při automatickém výpočtu měsíčních odpisů, při výběrech v obratové tabulce či při uzavírání a otevírání účetních knih. S účetním obdobím úzce souvisí účetní závěrka (viz. následující kapitola).

Uživatel má činnost účetní období k dispozici v hlavním menu – Účetnictví – Speciální činnosti. Při definování účetního období (viz. obr. 17) vstupuje následující atributy:

¨ identifikace a název období

¨ rok od – měsíc od

¨ rok do – měsíc do

Atributy „otevřeno“ a „uzavřeno“ jsou plně uživatelsky modifikovatelné (mají však vliv na další činnosti účetnictví) , tzn. jejich zatržení není prováděno automaticky systémem. V případě otevření účetních knih je vhodné, aby si uživatel u daného (otevíraného) období zatrhnul atribut „otevřeno“, stejně tak to platí i pro uzavření účetních knih. Po jejich uzavření je vhodné, aby si uživatel u daného (uzavíraného) období zatrhnul atribut „uzavřeno“. Pro uživatele je tedy vhodné, aby zatržení těchto atributů provedl vždy po otevření nebo uzavření úč. knih a aby stav těchto atributů odpovídal skutečnému stavu účetnictví, neboť tyto atributy mají vliv na:

¨ nabídku účetního období v nabídce šablony při otevírání nebo uzavírání účetních knih[26]

¨ účetní období při vytváření účetních zápisů (událostí účetního deníku) – viz. popis dále

obr. 17

V případě, že systém v souvislosti s účetním obdobím při účetním zápisu (událostí komponenty UCE) zjistí nesrovnalosti, je uživatel upozorněn informativním hlášením:

¨ „Pokus o zápis do nedefinovaného účetního období“ – kontrolní hláška, která se objeví při účetním zápisu. Upozorňuje uživatele, že nemá nadefinované období pro dané datum (systém toto hlásí např. v případě, že uživatel zadává účetní případ s lednovým datem roku 2008 a přitom nemá v činnosti účetní období nadefinován řádek s rokem 2008).

¨ „Pokus o zápis do uzavřeného účetního období“ - kontrolní hláška, která se objeví při účetním zápisu (událost UCE). Upozorňuje uživatele, že účetní období, kam spadá daný datum na události, je již uzavřeno.

10. Závěrka

Účetní závěrka je ze strany IS BM podporována těmito nástroji:

¨ výkazy (viz. kapitola 6)

¨ uzavřením a otevřením účetních knih (viz. kapitola 8)

¨ dokumenty (výroční zpráva, příloha), operace vývěsky „odeslání“ pro zveřejnění

¨ Mezinárodními standardy

Cílem účetní závěrky je poskytnout informace o finanční pozici, výkonnosti a změnách ve finanční pozici účetní jednotky, které jsou užitečné širokému okruhu uživatelů při tvorbě ekonomických rozhodnutí.

Mezi hlavní finanční výkazy účetní závěrky patří:

¨ Rozvaha (podává přehled o finanční pozici podniku)

¨ Výkaz zisku a ztráty (podává přehled o finanční výkonnosti podniku)

¨ Přehled o peněžních tocích (cash flow)

Účetní závěrka v podstatě představuje soubor výkazů, které se vystavují za dané účetní období k rozvahovému dni (rozvahový den je poslední den účetního období). Účetní závěrka může být:

¨ řádná (v rozvahový den) – dochází k uzavření účetních knih

¨ mimořádná (likvidace, zrušení konkurzem)

¨ mezitímní (na základě insolvenčního zákona) – není prováděna k rozvahovému dni, nejsou při ní uzavírány účetní knihy

10.1 Mezinárodní standardy

Konsolidované účetní závěrky musí sestavovat v souladu s mezinárodními standardy finančního výkaznictví (IFRS) všechny společnosti s veřejně obchodovanými cennými papíry registrované na území Evropské unie. Pro české společnosti s veřejně obchodovanými cennými papíry to znamená vést účetnictví dvakrát – podle české národní legislativy a zároveň i podle mezinárodních účetních standardů IFRS. IFRS je věrné zobrazení ekonomické skutečnosti podniku a zároveň je to systém s naprosto odlišným charakterem než české národní standardy. Podle IFRS si každá firma definuje vlastní účtovou osnovu, vytvoří si vlastní výkazy a účetní je povinen zvolit takový účetní postup, který vede k tomu, že se ekonomická skutečnost zobrazí pravdivě a věrně.

11. Další

Jak jsme si již zmínili v kapitole 3.1 Účetní deník vznikají jednotlivé účetní zápisy ve většině případů prostřednictvím procesů, tzn. na základě prvotní evidence (tzn. účtuje se např. úhrada pohledávky, nákup zboží na sklad apod.). Z toho vyplývá, že někde v systému (komponenta obchod, sklad apod.) uživatel zahájením daného procesu vytvoří prvotní doklady a operace účetnictví prostřednictvím účetních zápisů tento proces zakončí.

V některých případech nastává situace, kdy operace účetnictví není vytvářena na základě žádných prvotních dokladů, tzn. existuje samostatně a zahajuje daný proces[27]. Jedná se zejména o tyto procesy, které má uživatel k dispozici v hlavním menu – Nový proces – Účetní zápisy – Prvotní evidence:

¨ Účetní doklad – obecný

¨ Účetní doklad – otevření knih (viz. kapitola 8)

¨ Účetní doklad – uzavření knih (viz. kapitola 8)

Obecný účetní zápis je jistě pojem, který je uživatelům pracujícím s komponentou účetnictví důvěrně znám. Vytvoří ho pomocí procesu „Účetní doklad – obecný“ (hlavní menu – Nový proces – Účetní zápisy – Prvotní evidence). Po stisku klávesy F3 (nebo ikony Vložení nového záznamu či aktivní šablony) uživatel zadává jednotlivé atributy, přičemž platí stejná pravidla jako při procesním zpracování účetních zápisů, tzn. je hlídáno datum, období, platnost účtu a selektorů, podvojnost apod.

11.1 Přechod na nový rok

Tato kapitola poskytuje uživateli přehled o tom, které kroky by měl udělat v komponentě účetnictví IS BM při přechodu na nový kalendářní rok:

¨ kontrolu nastavení období v činnosti „otevřená období komponent“ (v hlavním menu Informační centrum – Typy a řady);

¨ založit nové účetní období, tzn. v činnosti „účetní období“ založit nový řádek (v hlavním menu Účetnictví – Speciální činnosti) – toto se dělá na zlomu kalendářního roku pouze tehdy, pokud současně končí účetní období[28];

¨ v případě že nastanou změny v účtovém rozvrhu provést ukončení platnosti či naopak nastavit platnost účtů (v hlavním menu Účetnictví – Účtový rozvrh);

¨ tento bod se týká pouze uživatelů, kteří zahájili práci s IS BM v průběhu předchozího roku – je nutno zkontrolovat nastavení začátku číselných řad od ...., 1 – při zahájení práce s IS BM v průběhu předchozího roku jsou totiž začátky číselných řad mnohdy nastaveny odlišně od 1 (v hlavním menu Informační centrum – Typy a řady);

¨ kontrolu platnosti selektorů.

11.2 Příklady účtování

Následující příklady účtování (účetních zápisů) poskytují uživateli příklad zaúčtování závazku a pohledávky a zároveň i zaúčtování i úhrad těchto plateb, které proběhlo v cizí měně, tzn. že zaúčtováním úhrady došlo i ke vzniku kurzových rozdílů (rozdílný kurz EUR v době vystavení platby a v době úhrady platby).

účtování o závazku

obr. 18

úhrada závazku

obr. 19

účtování o pohledávce

obr. 20

úhrada pohledávky

obr. 21

¨ [1] Je definován Vyhláškou č. 500/2002 Sb., hlava V.

[2] Např. vyhláškou 500/2002 Sb. pro účetní jednotky, které jsou podnikateli účtujícími v soustavě podvojného účetnictví.

[3] zrovna v účetnictví uváděn není

[4] nutno mít správně nadefinovaná přístupová práva

[5] V případě zájmu uživatele lze doplnit přímo do IS i Směrnou účtovou osnovu. Na její účty však nelze účtovat, slouží pouze jako vzor.

[6] Alternativní definice: uživateli se zobrazí všechny účty, pro které platí, že dnešní datum je v intervalu platnosti

[7] Tj. záznamů, přesněji událostí komponenty účetnictví.

[8] Ta je kontrolována v okamžiku ukončení operace a v okamžiku uzavření formuláře (i v neukončené situaci). Teoreticky by mohla nastat situace, kdy je formulář s nedokončeným účetním zápisem ukončen nestandardně (např. havárie), což by mohlo vést na nepodvojnost zápisu, tj. je nutné provádět určitou kontrolu, např. že jsou všechny účetní operace ukončené apod.

[9] Platí v rámci jednoho dokladu a jednoho měsíce.

[10] Tj. v rámci procesu, např. v IS BM je v operativní evidenci zaznamenán výdej materiálu ze skladu do spotřeby, na který navazuje účetní zápis.

[11] V souladu s vnitřním předpisem definujícím oprávnění, povinnosti a odpovědnosti osob ve vztahu k připojování podpisového záznamu (identifikačního záznamu) jej lze zřejmě považovat za průkazný podpisový záznam (podobně je tomu s dalšími účetními záznamy), samozřejmě za předpokladu, že je IS BM nastaven v souladu s tímto vnitřním předpisem.

[12] Včetně údajů uložených na volných kartách.

[13] Ten v konečném efektu umožňuje evidenci účetnictví za více podniků najednou, čímž umožňuje i provedení konsolidované účetní uzávěrky.

[14] Určuje způsob výpočtu konečného stavu (stranu konečného stavu).

[15] V rámci implementace mohou být definovány výstupy, které zajistí určitou agregaci, např. za syntetický účet apod.

[16] Při neurčení atributu měna na záložce Výběr.

[17] Odpovídající operace komponenty Účetnictví.

[18] Není vhodné tisknout následující sestavy za všechny adresáty najednou, může tím dojít k znepřehlednění poskytnutých informací.

[19] Tyto výkazy mohou být v rámci implementace IS BM doplněny dalšími výkazy (obvykle specifickými pro Vaši společnost)a dle Vašich informačních potřeb.

[20] Provázání operativní evidence s účetnictvím je řešeno pomocí transformací v diagramech procesů a vhodné definice selektorů v činnostech adresář, artikl, umístění.

[21] Aby tyto účetní zápisy neaktualizovaly hodnotu saldokonta.

[22] viz. pojem šablona – atribut šablona prvého vstupu

[23] Systém šablonu automaticky nabízí pouze při první aktivaci procesu otevření úč. knih. V případě znovuotevření je nutno tuto operaci otevření znovu aktivovat (a předtím odblokovat) a pomocí ručního vyvolání šablony (Ctrl F3) ji znovu zadat správně.

[24] tj. potřebné údaje jsou vypočteny z běžných účetních záznamů (událostí v činnosti Účetní deník) předchozího období

[25] V činnosti Procesy a Operace – Operace si uživatel najde operaci účetnictví druhu otevření účetních knih a tu aktivuje (po stisku klávesy F9).

[26] V případě, že uživatel u účetního období 2006 zatrhne příznak uzavřeno, automaticky se mu v šabloně otevření účetních knih nabízí účetní období 2007. Stejný princip platí i pro uzavírání účetních knih.

[27] Jedná se o proces složený pouze z jedné operace účetnictví.

[28] Před zahájením účetního období se toto musí udělat vždy.

© 1996-2013 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 10.10.2013


Skladová evidence

O B S A H

O B S A H.. 1

1. Úvod a základní pojmy. 3

2. Možnosti nastavení (příprava k provozu) 4

2.1.Skladované artikly. 4

2.1.1 Identifikace a popis (název, šarže-expirace, čarový kod) 4

2.1.2 MJ (hmotnost) 6

2.1.3 Kategorizace. 7

2.1.4 Specifické vlastnosti (VK, parametry, dokumenty, ..) 8

2.2 Fyzické uspořádání skladových prostor. 9

2.2.1 Sklady. 9

2.2.2 Buňky. 9

2.3 Logické uspořádání (konsignační sklady – viz Agrospol) 9

2.4 Zvolení systému oceňování 10

2.4.1 Vážený průměr 12

2.4.2 FIFO.. 12

2.4.3 Pevné ceny. 12

2.4.4 Bez oceňování 12

2.5 Předběžné oceňování (systém, vztah k ukončení operace, …) 12

2.6 Druhy pohybů. 12

2.6.1 Info o procesech, operacích, druhu hodnot i základní druhy hodnot 12

2.6.2 Přípravné a kontrolní 12

2.6.2.1 Rezervace. 12

2.6.2.2 Avíza (bez aktualizace skladových hodnot) 12

2.6.2.3 Inventura. 12

2.6.3 Pohyby aktualizující stav. 12

2.6.3.1 Příjem.. 12

2.6.3.2 Výdej 12

2.6.3.3 Převod. 12

2.6.3.4 Přecenění 12

2.6.3.5 Dodatečné pořizovací náklady. 12

2.7 Získávání informací a výstupy. 12

2.7.1 Stav a obraty. 12

2.7.2 Nízkoobrátkové. 12

3. Popis funkcí IS BM pro sklad. 12

3.1 Událost skladové evidence. 12

3.1.1 FIFO – příjem.. 16

3.1.2 FIFO - výdej 16

3.1.3 Účetnictví 16

3.1.4 Záložka „Výběr“. 17

3.1.5 Předlohy výstupu. 18

3.2 Aktuální hodnoty skladu. 18

3.2.1 Záložka „Výběr“. 20

3.3 Množství artiklu na skladech. 21

3.3.1 Záložka „Výběr“. 23

3.3.2 Předlohy výstupu. 23

3.4 Obraty skladu. 23

3.4.1 Záložka „Výběr“. 25

3.4.2 Předlohy výstupu. 26

3.5 Obraty skladu – VČ. 26

3.5.1 Záložka „Výběr“. 28

3.5.2 Předlohy výstupu. 28

3.6 Artikly skladu. 29

3.6.1 Názvy skl. artiklu v jazycích. 31

3.6.2 Přepočet MJ skl. art. 32

3.6.3 Množství 32

3.6.4 Aktuální hodnoty. 33

3.6.5 Kategorie. 34

3.6.6 Záložka „Výběr“. 35

3.6.7 Předlohy výstupu. 36

3.7 Artikly skladu – VČ. 37

3.7.1 Záložka „Výběr“. 38

3.8 Sklady. 39

3.8.1 Buňky. 40

3.8.2 Záložka „Výběr“. 40

3.8.3 Předloha výstupu. 41

3.9 Základní druhy hodnot 41

3.10 Přehled buněk skladu. 42

3.10.1 Záložka „Výběr“. 43

3.11 Nastavení programu BM... 44

1. Úvod a základní pojmy

Tato dokumentace se zaměřuje na podporu evidence skladovaného majetku a s ní spojených úkonů (tj. příjem, výdej, převod, práce s čárovými kódy apod.) pomocí IS Bílý Motýl®, přičemž je zde kladen důraz na komponentu „Sklad“.

K pochopení následujícího návodu je vhodná znalost dokumentace „ovládání“ (především kapitoly 1.1, 1.2 a 1.3), kde je podrobně vysvětleno ovládání formulářů a základní chování systému. Pro větší názornost si zde zopakujeme některé pojmy ze slovníku pojmů:

¨ ČK – kód automatické identifikace, který je naprosto jednoznačný pro každý artikl

¨ MJ – identifikace měrné jednotky

¨ metoda FIFO (first in-first out) - první do skladu, první ze skladu, tzn. dodávka daného druhu artiklu, která byla naskladněna jako první v určité ceně se zároveň v dané ceně jako první vydává

¨ množství NAT – množství vyjádřeno v naturálním vyjádření (tzn. v kusech, v metrech apod.)

¨ množství FIN – množství, které je vyjádřeno finančně, tzn. v Kč

¨ ref. MJ – referenční (základní, výchozí) měrná jednotka je ta jednotka, která je uvedena v číselníku u artiklu. V ní se artikl eviduje, na základě ní se provádějí přepočty MJ apod.

¨ vážený průměr - cena se zjistí jako aritmetický průměr z pořizovacích cen všech dodávek - nový průměr se zjišťuje po každém novém přírůstku určitého druhu materiálu do skladu

¨ VČ – výrobní číslo. Může být vedeno samostatně pro každý artikl (např. pomocí čtečky čárových kódů může mít každý artikl svoji etiketu, tj. VČ) nebo může být výrobní číslo vedeno jako šarže výrobků a pak může mít vícero artiklů shodné VČ.

Komponenta „skladová evidence“ je určena pro všechny firmy, které chtějí sledovat stav svých zásob a pohyb na skladových kartách. Komponentu „skladová evidence“ může uživatel samozřejmě používat samostatně, ale její význam výrazně roste společně s používáním komponenty "Obchod“, „Platby“ a „Účetnictví“.

Protože celý systém IS Bílý Motýl je postaven procesně, musí mít uživatel nadefinovány druhy procesů a druhy operací pro využívání komponenty skladová evidence a to jak v případě, že by jí využíval samostatně, tak v kombinaci s ostatními komponentami. Každý druh procesu nebo operace navíc ještě musí mít svá specifická nastavení (přístupová práva, základní druhy hodnot, masky, transformace apod.).

Procesy mohou být nastavené tak, že např. nákup zboží do firmy může začínat přijetím dodacího listu, který se následně automaticky přetransformuje do skladové příjemky nebo naopak může být první operací skladová příjemka, kterou zadá skladník při příjmu zboží na sklad a ta se automaticky přetransformuje do dodacího listu. Toto nastavení procesů a jejich posloupností je vždy záležitostí prvotní analýzy v dané firmě a jsou poté nastaveny přesně podle potřeb a reálného stavu dané firmy (včetně toho, že některé operace mohou probíhat na pozadí, tzn. absolutně samostatně bez nutného zásahu uživatele).

Příjmy a výdeje na sklad se nemusí provádět pouze klasickým způsobem, tj. vlastním zadáním údajů do PC, ale mohou běžet automaticky např. pomocí čtečky čárového kódu. V případě, že firma používá systém čteček a etiket (či štítků) na zboží (v IS BM je toto zajištěno pomocí atributu čárový kód a výrobní číslo), potom načtení příslušného kódu čtečkou způsobí automatický zápis příjmu na sklad. Uživatel se při příjmech a výdejích zboží pomocí čtečky v podstatě ani nepřiblíží k PC, přesto všechny tyto příjmové a výdajové pohyby jsou pečlivě zaznamenány v událostech skladové evidence. Pomocí čtečky pak lze velmi pohodlně dělat např. i inventurní soupisky.

Kromě klasického příjmu či výdeje na sklad je možno provádět převody mezi sklady, inventarizační soupisky apod. Uživatel má kdykoliv k dispozici přehled o pohybech zboží na skladu, může si vyfiltrovat pohyby pouze týkající se např. určitého dodavatele, určitého skladu, pouze za daný artikl, za vybrané období apod. Neustále má k dispozici informace o aktuálním stavu zboží na skladě, a to jak v naturálním, tak i ve finančním vyjádření.

Další možností, kterou skladová evidence uživateli umožňuje je např. možnost nastavit si minimální množství zboží na skladě a pokud skladové zásoby klesnou pod toto nastavené množství, je o tom uživatel neprodleně informován. Takových informací, které může systém automaticky hlídat je samozřejmě mnohem víc, záleží vždy na konkrétních potřebách daného uživatele.

Na základě obratových tabulek a u nich dostupných předloh výstupu lze pohodlně zjistit pohyb zboží na skladě za vybrané období.

Veškeré pohyby na skladě jsou vedeny v hlavní měně systému (Kč) bez ohledu na to, že např. v komponentě „obchod“ byly nakoupeny v jiné měně (např. EUR). Přepočet se provádí dle kurzu měny platného pro dané období. Systém umožňuje provést dodatečné opravy kurzů a provést přepočet cen všech pohybů na skladech.

2. Možnosti nastavení (příprava k provozu)

2.1.Skladované artikly

V IS BM v hlavním menu, v komponentě Informační centrum je činnost Správa artiklu. Tato komponenta soustřeďuje v systému veškeré činnosti, které určitým způsobem souvisejí s artiklem a na něj navazujícími činnostmi. Uživatel má k dispozici:

¨ události správy artiklu

¨ druhy artiklů

¨ artikl

¨ kategorie událostí správy artiklu

¨ palety barev kategorií

¨ legenda palety barev

¨ algoritmy předplnění a validace artiklu

Události správy artiklu poskytují uživateli přehled o pohybech artiklu, které přímo souvisí s činnostmi v komponentě správa artiklu, tzn. např. přiřazení kategorie, změna data platnosti apod., neukazuje tedy vlastní pohyby skladovaného artiklu, ty jsou k dispozici v komponentě Sklad – Událost skladové evidence.

Druhy artiklů slouží k vlastní definici druhů artiklu a nastavení jejich chování v systému (např. předplnění vztahu k účetnictví, předplnění vztahu ceny k DPH apod.). Důležitou záložkou v této činnosti je „výskyt druhu artiklu“, kde se definuje výskyt artiklu při jeho založení, tzn. pokud má artikl zatrženo obchodovatelný artikl a skladovaný artikl, znamená to, že při jeho založení je zároveň automaticky zapsán do artiklů skladu a obchodovatelného artiklu.

Pod činností Artikl je přehled všech artiklů, které byly založeny v systému IS BM. U každého artiklu je informace o jeho identifikaci, cizojazyčném názvu, vztahu měrných jednotek a příslušnosti ke kategorii.

Činnost Kategorie událostí správy artiklu uživateli slouží pro zadávání a editaci jednotlivých kategorií artiklu. Můžeme si uvést konkrétní příklad použití kategorie a palety barev na uživateli, který se zabývá vydáváním knih.

Palety barev kategorií poskytují uživateli velmi zajímavý nástroj, jak si zpřehlednit práci s artikly. Tato činnost poskytuje uživateli možnost nadefinovat si jednotlivé palety barev pro vybrané kategorie (jinými slovy je definice palety určením způsobu vybarvení artiklu dané kategorie). U každé palety barev je nutno zadat:

¨ identifikaci a název palety

¨ skupina – výběr skupiny uživatelů nebo přímo konkrétního uživatele, který má k dané paletě přístup

Vlastní definice palety barev pro jednotlivé kategorie se provádí na záložce „kategorie v paletě“. Zde se u každé barevné palety (např. obchod – platný artikl, sklad – platný artikl apod.) eviduje kategorie události správy artiklu (i s informací o prioritě a barvě písma a pozadí). Pokud nastane okamžik, že některé kategorie budou disjunktní (tzn. prolíná se několik kategorií naráz), uplatní se ta s nejvyšší prioritou.

Využití dalších činností pod menu Správa artiklu bude konkrétněji vysvětleno v další verzi této dokumentace.

2.1.1 Identifikace a popis (název, šarže-expirace, čarový kód)

Každý artikl musí mít u sebe uvedenu svoji jednoznačnou identifikaci. Tou je v případě IS BM definice druhu artiklu, čísla artiklu a jeho názvu. Podle těchto atributů lze v systému artikl kdykoliv vyhledat.

¨ druh artiklu – jak jsme zmínili v předchozí kapitole, mohou už zároveň s druhem artiklu být nastaveny určité vlastnosti nově definovaného artiklu (např. vztah k účetnictví apod.). Druh artiklu je povinný atribut.

¨ identifikace artiklu – povinný a neměnný atribut. Při zakládání nových artiklů je vhodné si vytvořit určitý systém, nezakládat artikly nahodile. V předimplementační analýze je vhodné si řádně promyslet vlastní definici tvorby identifikace artiklu, tzn. z čeho se daný identifikátor bude skládat ... může jít např. o kombinaci písmen a čísel, z nichž každé má vlastní význam, např. může být vytvořen identifikátor typu RE150755.5N2, který symbolizuje, že se jedná o řezivo o rozměrech 150 * 75 v délce 5,5 m, je nesušené a poslední číslo 2 na konci identifikátoru značí druh řeziva (např. smrk, borovice aj.). Toto je samozřejmě jen příklad možné tvorby identifikátorů. U každého druhu artiklu se taková identifikace může tvořit jinak a lze implementačně nastavit, aby se při zařazování daného druhu artiklu identifikátor zcela či částečně automaticky předplnil.

Pro zachování jednoznačné struktury tvorby identifikátorů artiklů je vhodné uspořádání artiklů do stromu. To již patří mezi náročnější implementační činnosti, je nutno mít nadefinován artikl druhu DEF, na jehož volné kartě se potom definují všechny příslušné další atributy a jejich definice. Nové artikly je pak možno rovnou zakládat i pomocí tohoto stromu, čímž je zajištěno, že bude zachována vytvořená struktura artiklů. Jak může vypadat takové uspořádání artiklů do stromu si názorně ukážeme na následujícím obrázku.

¨ název artiklu – je povinný údaj, ale je možno ho opravovat. I zde platí pravidlo, že vlastnímu zápisu názvu artiklu by měla předcházet předimplementační analýza. Pokud jsou názvy vytvářeny logicky a systematicky, ulehčuje to potom uživateli další práci s artiklem v systému, např. při různých vyhledáváních, zadávání v událostech apod.

Jako další identifikátor slouží atribut čarový kód, který lze implementačně využít různými způsoby. Může zde být uvedeno číslo čarového kódu, jiný uživatel tento atribut může využít jako číslo pro sledování šarže výrobků, pro sledování jejich expirace (tj. doba trvanlivosti) apod. Pomocí nadefinování doplňujících vlastností formuláře lze implementačně dosáhnout toho, že při definici nového artiklu se automaticky toto číslo naplní právě číslem šarže nebo datem expirace. Pokud uživatel využívá u artiklu čarový kód, je pro usnadnění a urychlení práce s pohybem artiklu rozumné používat zároveň i čtečky čarového kódu.

Další podrobnější údaje o daném artiklu lze uvádět na volné kartě, jejich nadefinování plně závisí na konkrétních potřebách uživatele.

2.1.2 MJ (hmotnost)

Měrná jednotka, ve které se primárně vede evidence daného artiklu je označena jako referenční měrná jednotka (jinak řečeno základní, výchozí jednotka). Při zařazování nového artiklu se uživatel rozhoduje, v jaké referenční měrné jednotce bude artikl veden (atribut MJ na kartě artiklu). Měrná jednotka může být předdefinována i na základě uživatelského nastavení [1] , tzn. že může být nastaveno např. že s daným druhem artiklu se vždy předplní daná MJ. V této zvolené referenční měrné jednotce bude uživatel rovněž zjišťovat informace o stavu artiklu (aktuální hodnoty, množství artiklu na skladě, obraty apod.).

Číselník měrných jednotek je uživatelsky definován. Vůči referenční měrné jednotce je možno na záložce „přepočet MJ“ na kartě artiklu nastavit vztahy k dalším měrným jednotkám. Můžeme tedy mít artikl, jehož referenční měrná jednotka jsou kusy, ale v přepočtu měrných jednotek je uveden vztah kusy – balení a pak např. balení – paleta, takže potom může uživatel naprosto samozřejmě přijmout nebo vystavit dodací list, kde u daného artiklu bude množství 3 palety a systém toto množství automaticky přepočítá na kusy (tím má uživatel i podrobnou informaci, kolik kusů daného artiklu je na jedné paletě). Zároveň je tímto způsobem možno snadnou cestou získat celkovou hmotnost dodávky (pokud je uveden i přepočet kolik kg má jedna paleta), která se potom uvádí např. na dodacích listech.

Pokud nastane uživatelská potřeba informace o množství artiklu ve více různých MJ, jsou v IS BM připraveny dvě různé metody řešení:

¨ uživatelské zadání množství ve dvou MJ v každém skladovém pohybu

¨ automatické vyjádření množství v dalších MJ právě na základě výše popsaného vztahu měrných jednotek

2.1.2.1 Uživatelské zadání množství ve 2 různých MJ

Při zadávání skladového pohybu lze kromě hodnoty v referenční MJ (RMJ) zadat naturální množství také v další libovolně zvolené MJ. Pokud je nadefinován vztah mezi uvedenou MJ a RMJ (přepočet MJ), pak se při zadávání skladové události na základě tohoto přepočtu automaticky předplní množství i v druhé MJ, ale uživatel sám rozhodne, jaká množství budou nakonec zadána v obou MJ.

V případě, že uživatel potřebuje zjistit informace o naturálním množství artiklu v nereferenční MJ (např. o celkovém stavu na skladě, obratech apod.), vypočítá se toto množství pomocí příslušných implementačních nastavení z jednotlivých pohybů a tato informace se předá uživateli, např. pomocí nadefinovaných předloh výstupu, doplňujících vlastností formuláře, tooltipů, volných karet apod.

Uživatelské zadání MJ se uplatní u artiklů jako jsou např. uzeniny, kdy každé balení (kus) má jinou hmotnost a uživatel zároveň potřebuje evidovat jak počet kusů, tak i hmotnost v kg. Podobným případem je i situace, kdy se u daného artiklu eviduje množství v paletách i v kusech, ale zároveň na každé paletě je jiné množství kusů.

V případě uživatelského zadání dvou MJ lze skladové události vytvářet i bez zadaného pevného vztahu MJ (tzn. není nastaven žádný přepočet), ale takové zadávání klade mnohem větší nároky na uživatele, obzvlášť při zadávání dat při složitějším implementačním nastavení.

2.1.2.2 Automatické vyjádření množství v různých MJ

Automatické vyjádření množství v různých MJ je založeno především na definici přesného a trvalého vztahu mezi RMJ a libovolným množstvím MJ. Při zadávání skladového pohybu lze zadat množství v MJ odlišné od RMJ, přičemž množství v RMJ se na základě zadaných vztahů mezi MJ automaticky dopočte. Počet MJ, které mohou mít nadefinován vztah k RMJ není nijak omezen.

Stejně jako v případě uživatelského zadání různých MJ, i zde platí, že v případě, kdy uživatel potřebuje zjistit informace o naturálním množství artiklu v nereferenční MJ (např. o celkovém stavu na skladě, obratech apod.), vypočítá se toto množství pomocí příslušných implementačních nastavení z jednotlivých pohybů a tato informace se předá uživateli, např. pomocí nadefinovaných předloh výstupu, doplňujících vlastností formuláře, tooltipů, volných karet apod.

Automatické vyjádření množství v různých MJ lze uplatnit u artiklů, kde je vztah mezi dvěma nadefinovanými MJ neměnný, tzn. že artikl, který je evidován např. v kusech se dodává vždy ve stejném počtu kusů v balení, paletě apod. a má vždy stejnou hmotnost v kilogramech.

Vyjádření hmotnosti při použití evidence dvou různých MJ ve skladových pohybech lze provést dvojím způsobem. První, jednodušší, způsob je ten, že hmotnost je zároveň druhou MJ uvedenou na události, tzn. RMJ jsou např. kusy a druhá MJ jsou právě kilogramy. Potom je v předlohách výstupu snadné přímo uvést počet kilogramů.

Druhý způsob zjištění hmotnosti je potom pomocí implementačních nastavení a je to u událostí, kde jsou sice uvedeny dvě různé MJ, ale ani jedna není hmotnost, pouze je k RMJ nastaven přepočet i na kilogramy. Laicky vyjádřeno to znamená, že systém sice o vztahu RMJ a MJ, která vyjadřuje hmotnost ví, v daném okamžiku zadávání skladové události ji však nemá přímo k dispozici. Potom se musí hmotnost dopočítat. Lze to implementačně řešit přes volné karty či nastavení výpočtu přímo v předlohách výstupu apod.

2.1.3 Kategorizace

Jednotlivé artikly lze kategorizovat, resp. zařazovat do skupin, podle nichž je možno vybírat a které se mohou vzájemně překrývat. Využití této alternativy poskytuje uživateli činnost kategorie událostí správy artiklu. Tyto kategorie si uživatel nadefinuje pod menu Informační centrum – Správa artiklu. Ke každé kategorii lze přiřadit příslušnou barevnou paletu. Abychom si tuto možnost přiblížili na konkrétním případu, lze si tímto způsobem např. rozdělit artikly podle obratu nebo si takto označit naopak artikly, které jsou více problematické. Na našem vzorovém obrázku je konkrétní příklad rozdělení kategorií podle prodejnosti artiklu, uživatel je firma zabývající se tiskem a prodejem knih.

Jak je dobře viditelné výše může mít každá kategorie nejen svoji barevnou paletu, ale i svoji platnost. Podle těchto parametrů lze pak vyhledávat na záložkách výběr v komponentě sklad.

Jednotlivé pohyby artiklu, který má nadefinované kategorie, lze potom sledovat v událostech správy artiklu. Zjednodušeně řečeno fungují události správy artiklu na způsob nástěnky o artiklu, vše co se s daným artiklem v systému děje je zde zaznamenáno. Jednotlivé události se v této činnosti zakládají neprocesně.

2.1.4 Specifické vlastnosti (VK, parametry, dokumenty, ..)

Každý artikl může mít u sebe nadefinováno množství dalších specifických vlastností. Jednou z možností definice těchto vlastností jsou volné karty. Nachází se pod menu Obecné nad činností Artikly skladu. Uživatel si zde může nadefinovat další atributy, které chce evidovat u artiklu a které mu neposkytuje činnost artikly skladu, např. různé poznámky, specifické dodací podmínky, atypický způsob balení aj., možností je opravdu nepočítaně.

Ke každému artiklu je možno přiřadit dokument, např. kupní smlouvu, technický výkres apod. Tuto možnost má uživatel dostupnou po stisku klávesy Ctrl D na daném artiklu. U každého artiklu je navíc možno evidovat i jeho fotografii nebo třeba návrh obalu apod. Tato funkčnost je zastoupena činností prezentace artiklu.

Pod menu Obecné má uživatel k dispozici ještě činnost, která se nazývá Hodnoty parametrů objektu. Tato činnost již patří mezi implementačně náročnější, nicméně její správné nadefinování dokáže splnit i ty nejnáročnější evidenční potřeby jednotlivých uživatelů. U každého artiklu je díky této činnosti možno evidovat v podstatě nekonečné množství atributů. Můžeme si tyto hodnoty parametrů lépe přiblížit na konkrétním příkladu. Existuje uživatel, který se zabývá výrobou plechových obalů, např. víček na přesnídávky, džemy, kečupy apod., tzn. že pro svoji výrobu nutně nakupuje plech a u tohoto artiklu potřebuje sledovat velké množství jednotlivých atributů. Na následujícím obrázku je velmi dobře znázorněné, jakým způsobem mohou být pak hodnoty parametrů objektu nadefinovány.

2.2 Fyzické uspořádání skladových prostor

Představuje reálné možnosti uspořádání skladových prostor. V IS Bílý Motýl se skladové prostory mohou dělit na jednotlivé sklady a ty se ještě mohou členit podle jednotlivých buněk.

2.2.1 Sklady

Tato činnost umožňuje uživateli nadefinovat si a vést přehled jeho úložného prostoru, který má smysl evidovat. Každý uživatel může vést neomezený počet skladů. Pokud nevede více skladů, musí zde být uveden minimálně jeden fiktivní sklad, který má význam fyzického skladu firmy (může to být i záznam uvedený pomlčkou). V případě potřeby je možno sklad rozdělit na tzv. skladové buňky.

Pomocí atributu umístění lze ke každému skladu nastavit přístupová práva. Kromě nadefinovaných přístupových práv se u každého skladu se eviduje několik stěžejních informací (jeho identifikace a název, adresa vlastníka skladu a především zvolená metoda způsobu oceňování skladu).

V jednotlivých událostech skladové evidence se následně při skladových pohybech vždy uvádí identifikace skladu (uživatel může provést skladový pohyb pouze ve skladu, ke kterému má přístupové právo „zápis“) a případná identifikace sklad. buňky (pokud je daný sklad členěn i na buňky). Pokud má uživatel k danému skladu přístupové právo pouze „čtení“, může si skladové události pouze prohlížet, nelze je vytvářet ani evidovat.

U každého skladu lze sledovat množství jednotlivých artiklů na skladě (vlastní činnost pod menu Sklady – Množství artiklu na skladech). Další informaci o aktuálním množství artiklu na skladě má uživatel přímo na kartě artiklu – záložka Aktuální hodnoty. V případě, že uživatel má členění skladu i na skladové buňky, tak v obou těchto činnostech je k dispozici informace nejen za sklad, ale i za jednotlivé skladové buňky.

2.2.2 Buňky

Každý nadefinovaný sklad je možno v případě potřeby členit na skladové buňky. Členění skladových buněk v podstatě představuje jakýsi „trojrozměrný“ pohled na rozdělení skladu. V IS BM je to řešeno pomocí pohledu osa X, Y, Z.

Definovat skladové buňky je možno samozřejmě pouze u skladů, ke kterým má uživatel přístupové právo zápis.

Podle nadefinovaných buněk lze následně provádět i veškeré skladové události, např. příjem, výdej, převod apod.

V případě, že uživatel má skladovou evidenci vedenou ve vícero skladech a mezi jednotlivými sklady i převádí zboží, tak lze přímo i nastavit, zda při převodu mezi sklady má systém pracovat i s buňkami. Pokud v činnosti nastavení programu BM v sekci Sklad bude mít uveden tento parametr,

¨ BunkyVeFormulariPrevod=0, systém při převodu mezi sklady nebude s buňkami vůbec pracovat.

2.3 Logické uspořádání (konsignační sklady)

Konsignační sklad je fyzický sklad materiálu, polotovarů nebo dokončených výrobků. Na rozdíl od běžného skladu se formálně liší tím, že obsah skladu - zboží uskladněné v konsignačním skladu, je ve vlastnictví dodavatele. Odběratel je obvykle na základě smlouvy povinen skladovat konsignační zboží odděleně od ostatního vlastního zboží, které má ve své vlastní skladové evidenci (majetku).

Konsignační sklad může vzniknout pouze za předpokladu spolupráce dvou obchodních partnerů, kdy jeden plní roli dodavatele a druhý odběratele, kterému "silnější" partner - dodavatel poskytuje na své náklady skladovou zásobu umístěnou ve vlastních prostorách odběratele. Skladová zásoba je pak odběratelem dle jeho potřeb průběžně odčerpávána a je jím uhrazována v závislosti na odběrech ze skladu. Naproti tomu dodavatel obvykle konsignační sklad svého odběratele podle potřeb dozásobuje.

Odběratel ze svého konsignačního skladu odebírá zboží pro vlastní potřebu (prodej, potřeby výroby, servis apod.) a je obvykle povinen dodavateli v pravidelných intervalech reportovat odebrané zboží. Na základě reportů pak dodavatel vystavuje vůči odběrateli faktury.

V IS BM lze konsignační sklad nastavit v podstatě pouze daným logickým uspořádáním, tzn. uživatel sice bude mít regulérně určitý fyzický prostor, nicméně pomocí nastavení procesů v IS BM lze tento sklad vést v případě potřeby jako konsignační.

2.4 Zvolení systému oceňování

Každá firma si při svém podnikání musí zvolit způsob oceňování skladů a skladových zásob. Na základě tohoto zvoleného oceňování potom následně o skladových pohybech i účtuje. České právní předpisy o účetnictví připouštějí tyto metody:

¨ cena se zjišťuje výpočtem váženého aritmetického průměru

¨ metodu FIFO

Účetní jednotka se může samostatně a svobodně rozhodnout pro ten způsob oceňování materiálu při výdeji, který považuje za nejefektivnější ve svých podmínkách. Zvolený způsob ocenění musí být stanoven vnitřní organizační normou (směrnicí, pokynem apod.) a nesmí se měnit v průběhu účetního období. Způsob ocenění lze tedy měnit jen s účinností od prvého dne následujícího účetního období.

Uplatnění jednotlivých metod ocenění zásob při jejich vyskladnění může mít vliv na hodnotu mnoha ukazatelů o činnosti účetní jednotky, protože může ovlivnit výši hrubého zisku, výši daně z příjmů a výši čistého (disponibilního) zisku. Proto není povoleno používání metody LIFO (první do skladu, poslední ze skladu).

2.4.1 Vážený průměr

Cena se zjišťuje výpočtem váženého aritmetického průměru z cen materiálu při jeho pořízení. Cena podle váženého aritmetického průměru je trvale přepočítávána při každém pohybu.

U váženého průměru je nutno zajistit, že skladové výdeje jsou zadávány až poté, co jsou provedeny skladové příjmy, jinak se může průměrná skladová cena chybně rozhodit. Aby se tomuto předešlo, lze tuto situaci řešit implementačně tak, že firma bude mít sklad fyzický (tj. skutečný) a sklad účetní (tj. fiktivní). Ve fyzickém skladu je nutno znát přesné množství artiklu v daném okamžiku, proto se skladové události provádějí podle skutečnosti tak jak v reálném světě běží, do účetního skladu se naopak zadávají ve správném pořadí (tzn. nejprve příjmy, potom navazující výdeje).

2.4.2 FIFO

Jako cena vyskladněného materiálu se použije skladová cena nejstaršího skladovaného materiálu, tzn. z nejstaršího nákupu. Tato metoda je označovaná jako metoda FIFO. FIFO je zkratkové označení plného anglického vyjádření principu metody – first in, first out (první dovnitř, první ven).

Informační systém BM pracuje s FIFO tak, že při výdeji ze skladu najde systém nejstarší nevykrytý

příjem na sklad a s ním výdej spáruje. Implicitní spárování probíhá při zápisu události, kdy dochází k automatickému přepočtu FIFO.

V IS BM lze implementačně nastavit, aby k tomuto párování automaticky nedocházelo. Může to být proto, že uživatel využívá při příjmech i ocenění předběžné. Pomocí parametru „Neparovat_FIFO“ (viz. popis níže), lze nastavit, že přepočet FIFO se nespustí automaticky, ale musí ho ručně aktivovat uživatel. Následně dojde k tomu, že systém ocení příjmy, tím se u příjmu oceněných předběžně změní ocenění na konečné, příznak u operací se změní z předběžně ukončeno na ukončeno a prováže se FIFO.

Při metodě FIFO má smysl používat předběžné ocenění pouze v tom případě, pokud je nějakým komplexním způsobem (implementačně) zajištěno ukončení konečné. Teprve až po konečném ukončení se aktivuje operace účetnictví.

Parametr ovlivňující chování FIFO v IS BM je k dispozici v menu Systém – Nastavení programu BM – sekce Sklad:

¨ parametr Neparovat_FIFO

Neparovat_FIFO=1

Při nastavení Neparovat_FIFO=1 se neprovádí párování FIFO při vstupu události skladové evidence. Předpokládá se, že párování bude provedeno jiným způsobem.

2.4.3 Pevné ceny

Skladové ceny se stanovují pevně na celý rok. Ve skladové evidenci se pak pracuje pouze s touto pevnou cenou. Rozdíly mezi cenami ve skladu a cenami při fakturaci se účtují jako cenové odchylky. Pevná cena se nastavuje v ceníku u jednotlivých artiklů a pomocí masky operace a transformace je implementačně zajištěno, že do dat (tzn. skladových událostí) vstupuje u daného artiklu pouze tato pevná cena. Při přechodu do nového roku uživatel v případě potřeby u artiklu stanoví novou pevnou cenu na další rok a stávající zásoby daného artiklu se přecení.

2.4.4 Bez oceňování

IS BM neumožňuje v pravém slova smyslu vést skladovou evidenci bez oceňování, tzn. v nulových cenách. Proto se tato uživatelská potřeba řeší nejjednodušším způsobem tak, že veškeré pohyby skladu jsou oceněny hodnotou jedna (implementačně nastaveno).

I zde je vhodné nastavení tzv. fyzického a účetního skladu. Veškeré skladové pohyby jsou realizovány s cenou jedna, následně se tyto pohyby přenášejí do skladu účetního a až tam jsou podle následné fakturace oceněny podle skutečných cen.

Další implementační nastavení může být takové, že uživatel si definuje fiktivní sklad, kterým řídí obchodní aktivity. Výdeje tohoto skladu se poté časem ocení, tím se aktivuje operace účetnictví a teprve pak následuje vlastní výdej z fyzického skladu, který se už ovšem neúčtuje.

2.5 Předběžné oceňování (systém, vztah k ukončení operace, …)

K pochopení následující problematiky se pokusíme si vysvětlit podrobnější chování systému v souvislosti se skladovou evidencí. Každý pohyb ve skladu probíhá na základě nadefinovaného druhu operace. Druh operace může aktualizovat určitou hodnotu (např. stav skladu ve finančním vyjádření, materiál na skladě apod.). Každá z operací má v diagramu procesu nastaven způsob ukončení.

Každý skladový pohyb je možno ocenit. Ocenění může být konečné nebo předběžné. Definuje se přímo při vytváření skladového pohybu na atributu „ocenění“. Ve většině případů asi uživatelé pracují s oceněním konečným, tzn. cena příjmu nebo výdeje je v daný okamžik známa.

Může ale z praxe nastat situace, že zboží uživateli (tj. majiteli) sice dorazilo na sklad, nicméně ještě není známá přesná skladová cena tohoto příjmu. Nicméně zákazník si chce dané zboží koupit, tzn. zboží je nutno vydat ze skladu a vystavit prodejní doklad (prodejní cena je známa). Tato situace přesně demonstruje okamžik, kdy je vhodné a účelné použít právě předběžné oceňování.

K tomuto je však nutno podotknout, že předběžné oceňování slouží spíš jako vyřešení momentální situace s neznámou skladovou cenou, nefunguje zároveň jako rezervace artiklu na skladě. Ve chvíli, kdy si uživatel dopřesní skladové ceny, je nutno události s předběžným oceněním vyhledat, upravit ceny a ocenění změnit na konečné. Vyhledávat předběžné oceněné skladové pohyby pohodlně umožňuje výběr nad skladovými událostmi i nad fyzickými operacemi.

2.6 Druhy pohybů

2.6.1 Info o procesech, operacích, druhu hodnot i základní druhy hodnot

Již v předchozí kapitole jsme si lehce nastínili, jak pracuje IS BM. Každý skladový pohyb musí být proveden na základě nadefinovaného druhu operace a každá operace je zároveň součástí druhu procesu. Může se jednat o proces o pouze jedné operaci, např. výdej artiklu do spotřeby a nebo se může jednat o nadefinovaný druh procesu prodeje, kde operace skladového výdeje je konečnou operací tohoto procesu.

Způsob zahájení a způsob ukončení operace skladového pohybu je dán její definicí ve vlastnostech daného uzlu v diagramu procesu. Operaci je možno zahájit ručně, tzn. aktivním spuštěním operace uživatelem, např. právě v okamžiku, kdy je sklad první operací v procesu nebo automaticky, tzn. že operace skladové evidence se automaticky spustí po ukončení předchozí operace.

Operaci je možno ukončit těmito způsoby:

¨ automaticky ukončit – po zapsání událostí dané operace a následném stisku klávesy ESC

¨ automaticky neukončovat – po stisku klávesy ESC systém opustí formulář operace bez dotazu na ukončení operace

¨ automaticky ukončit předběžně – tento způsob ukončení je ve své podstatě shodný s prvním, pouze s tím rozdílem, že daná operace nabude stav, že byla ukončena předběžně

¨ operace se automaticky ukončuje rovněž v případě, že ve vlastnostech operace v diagramu procesu má nadefinováno spuštění na pozadí

V menu Procesy a operace – Operace, kde jsou k dispozici všechny uzly (operací i procesů), je možno zhlédnout přehled všech fyzických operací i s jejich aktuálními stavy. Stavy jednotlivých operací jsou k dispozici rovněž i v diagramu procesu, kde u každého uzlu typu operace je zaškrtávátkem určeno, v jakém stavu uzel typu operace v dané chvíli je. Strom hlavního procesu stav uzlu signalizuje pomocí příznaku (nebo-li značky) před názvem operace (svíti-li červená, je operace připravena, svítí-li zelená, je operace zahájena, je-li u operace křížek, je ukončena) nebo si stav operace může uživatel zjistit ve vlastnostech operace – po stisku pravého tlačítka myši.

Spustit nebo ukončit operaci může vždy jen uživatel nebo skupina uživatelů , kteří mají k danému druhu operace nadefinováno příslušné přístupové právo .

Podrobnější popis ohledně diagramu procesu, druhu procesu, druhu operace, spuštění a ukončení operace je součástí dokumentace Procesy, je dostupný i jako jednotlivé pojmy ve Slovníku pojmů a v helpech nebo v dokumentaci Ovládání.

U každého druhu operace (Informační centrum – Typy a řady - Druhy operací) lze nastavit základní druh hodnoty, která se bude prováděním daného druhu operace aktualizovat. Toto se nastaví na záložce Hodnoty operace. Druhem hodnoty se rozumí např. stav skladu ve finančním vyjádření, stav skladu v naturálním vyjádření, finanční stav zásob za celý sklad apod. Tyto hodnoty se automatizovaně aktualizují na základě numerických údajů ( atributů ) událostí . Uvádí se:

¨ druh hodnoty – identifikace a název druhu hodnoty

¨ +/-/PV – pokud je nastaveno +, hodnota se vždy přičítá, pokud je nastaveno – hodnota se vždy odečítá a u nastavení PV (dle příjmu či výdeje) platí, že pokud se jedná o příjem, hodnota se přičítá, pokud se jedná o výdej, hodnota se odečítá

¨ v procesu – pokud se jedná o hodnotu, kterou má význam sledovat pouze u vybraného druhu procesu , zadává se zde identifikace druhu hlavního procesu

V rámci každé komponenty lze sledovat i tzv. aktuální hodnoty. Definici těchto hodnot má uživatel dostupnou v činnosti Komponenty (Informační centrum – Typy a řady – Komponenty) po stisku klávesy F7. Jsou to hodnoty v naturálním a finančním vyjádření, které chce uživatel nad komponentou sledovat (např. aktuální stav materiálu na skladě nebo stav peněz na účtu). Zadávají se tyto údaje:

¨ druh - identifikace druhu a název druhu hodnoty

¨ vstupní hodnota - vstupní hodnotou může být množství nebo celková cena. Pokud daná hodnota nesleduje ani množství, ani celkovou cenu, zadává se 1.

¨ aktualizuje - může být aktuální, statistická, saldokontní nebo obrat. Při zadání aktuální tento druh hodnoty aktualizuje celkový stav druhu hodnoty v celé komponentě. Při zadání statistická, aktualizuje statistickou hodnotu, která je plněna dávkově. Zadáním saldokonta se aktualizují saldokontní hodnoty. Hodnotu obrat lze definovat pouze ke zjištění obratů skladu a změny stavu peněz. Hodnoty, které se týkají obratů sledují logické věci za určité období. U obratu a statistické hodnoty je možno určit, jakým způsobem se bude tato hodnota při přepočtu počítat. Pokud uživatel u některé statistické hodnoty (např. průběh prodeje) potřebuje znát její podrobnější evidenci, zatrhne příznak "den do statistické hodnoty". Evidence statistických hodnot je pak provedena po jednotlivých dnech. Pokud tato možnost není zatržena, probíhá evidence statistických hodnot po měsících, systém počítá vždy s prvním dnem v měsíci, za který danou hodnotu sesumuje. Na stejném principu funguje i obrat s příznakem "den do hodnoty obratu".

¨ druh saldokontní hodnoty - jedná se pouze o hodnoty, které sledují saldokonto. U každého druhu hodnoty se pak definuje komponenta a operace, které se hodnota týká a výpočet. Pak např. druh hodnoty "množství vydané ze skladu" u procesu výdejka má následující složení:

- operace výdejka - druh hodnoty je množství vydané ze skladu a výpočet je "+"

- operace dodání - druh hodnoty je množství vydané ze skladu a výpočet je "-"

¨ podmínka - umožňuje zadat, za jaké podmínky se tento druh hodnoty má počítat. Pokud uživatel nechce vstupovat žádnou podmínku, vybere v překryvném seznamu "hvězdičku".

2.6.2 Přípravné a kontrolní

Jak z názvu kapitoly vyplývá, jedná se o operace, které mají pro uživatele spíš informativní charakter, nedochází k vlastní změně aktuálního stavu artiklu.

2.6.2.1 Rezervace

Činnost rezervace umožňuje uživateli zarezervovat si určitý artikl ve zvoleném množství. Zarezervované množství je však pro uživatele pouze informativní údaj, nemění stav artiklu na skladě.

Zarezervování se provede příslušným skladovým procesem, kde uživatel zvolí adresáta, druh artiklu a artikl a jeho množství. Následný údaj o zarezervovaném množství má uživatel u artiklu k dispozici v činnosti:

¨ Množství artiklu na skladech – atribut zarezervováno

¨ Aktuální hodnoty – pohyb s informací o zarezervovaném množství daného artiklu

¨ na kartě Artiklu (činnost Artikly skladu) – záložka Množství nebo na volné kartě Informace o artiklu - sklad nad touto činností

Pokud následně při výdeji (prodeji) daného artiklu uživatel vydává množství, které je zarezervováno, zobrazí se uživateli informativní hláška jaké množství a pro jakého adresáta je momentálně rezervováno.

Jak je zmíněno výše, tato hláška má pouze informativní charakter, pokud bude uživatel i přesto operaci výdeje chtít ukončit, lze to bez problémů.

Zároveň je možno v případě potřeby aktivovat i proces na odrezervování daného artiklu. Platí stejný postup jako pro rezervaci. Spustit vybraný proces, zadat adresáta, artikl a množství.

2.6.2.2 Avíza (bez aktualizace skladových hodnot)

V tomto případě se jedná o různá informativní hlášení, která jsou uživateli o artiklu poskytována. Samozřejmě vždy záleží na konkrétní implementaci a potřebách uživatele, jaké údaje chce u artiklu sledovat, ale ve většině případů se jedná minimálně o sledování optimálního a minimálního množství. V činnosti Artikly skladu je na volné kartě artiklu možno nadefinovat právě minimální a optimální množství artiklu, měrnou jednotku objednávky, typicky objednávané množství apod.

Pokud se aktuální množství artiklu dostane pod hodnoty nadefinovaného množství, tak po přihlášení do systému se uživateli zobrazí hlášení s tím, že daný artikl nedosahuje požadovaného nadefinovaného množství a bylo by vhodné provést objednávku daného artiklu.

2.6.2.3 Inventura

Inventuru (čili kontrolu mezi evidovaným a skutečným množstvím) lze v IS BM provádět ručně nebo pokud má uživatel implementováno, i pomocí čtečky čárového kódu. V každém případě je v činnosti Artikly skladu připravena předloha výstupu, po jejíž aktivaci má uživatel k dispozici stav evidovaného artiklu. V případě ruční inventury se následně skutečné (neboli fyzické) množství dopisuje, v případě možnosti využití čtečky se skutečný stav skladu načte a je v této předloze výstupu k dispozici. Uživatel následně zjistí inventurní rozdíly a pro správné dorovnání stavu skladu musí následně pustit proces Inventura – manko nebo Inventura – přebytek a vyčíslené rozdíly zaznamenat i do IS.

2.6.3 Pohyby aktualizující stav

Jedná se o pohyby, po jejichž provedení se vždy změní stav artiklu na skladě, tzn. tyto pohyby nadefinovaným způsobem aktualizují aktuální hodnoty artiklu. V každém skladovém pohybu lze určit ocenění konečné/předběžné, ke skladu lze zvolit i skladovou buňku (pokud má uživatel implementováno) a pohyby je možno provádět ve dvou různých měrných jednotkách.

2.6.3.1 Příjem

Příjem na sklad se provede pomocí příslušného druhu procesu (nákup, příjem z výroby, převod apod.) a po zadání adresáta, artiklu a množství jsou u daného artiklu aktualizovány aktuální hodnoty a množství artiklu na skladě (pokud má daná příjmová operace tyto hodnoty nadefinovány).

V rámci implementace může probíhat příjem u každého uživatele mírně odlišným způsobem na základě firemních zvyklostí. Někde je operace příjmu na sklad první v daném druhu procesu, jinde navazuje na přijatou fakturu apod.

Na obrázku je viditelné, které atributy se vyskytují při příjmu na sklad. Je možno zvolit i příjem ve dvou měrných jednotkách. Skladová cena se při příjmu zadává ve většině případů z prvotního dokladu, na základě kterého příjem uživatel zadává. Lze naimplementovat i pevné skladové ceny.

2.6.3.2 Výdej

Stejně jako příjem, tak i výdej musí v IS BM probíhat na základě příslušného druhu procesu (výdej/prodej, výdej do spotřeby, převod na jiný sklad apod.) a po zadání adresáta, artiklu a množství jsou u daného artiklu aktualizovány aktuální hodnoty a množství artiklu na skladě (pokud má daná výdajová operace tyto hodnoty nadefinovány).

I operaci výdeje lze v rámci implementace provádět rozdílným způsobem. U některého uživatele operace výdeje zahajuje proces, poté následuje např. dodací list a faktura, jinde to může být naimplementováno tak, že nejprve se vystaví dodací list a faktura a teprve poté proběhne konečný výdej ze skladu.

Atributy, které při výdeji ze skladu uživatel vstupuje jsou naprosto shodné jako při příjmové operaci (tedy viz. předchozí obrázek).

Aby správně probíhal výpočet skladové ceny při jakémkoliv skladovém pohybu, musí být splněny následující podmínky:

¨ k odpovídajícímu druhu operace musí být připojeny druhy hodnot, které jsou definované činností „základní druhy hodnot“ jako hodnoty aktualizující množství artiklu na skladě ve finančním a naturálním vyjádření

¨ musí se jednat o výdej ze skladu – tj. událost charakteru výdej s uvedeným kladným množstvím artiklu nebo událost charakteru příjem s uvedeným záporným množstvím artiklu

Výpočet probíhá metodou „vážený průměr“ nebo „FIFO“ podle nastavení odpovídající vlastnosti skladu uvedeného v události, tzn. že skladová cena je atribut, který se uživateli předplňuje při výdeji automaticky, není uživatelsky modifikovatelný.

2.6.3.3 Převod

Proces převodu uživatel využije v okamžiku, že potřebuje daný artikl převést na jiný sklad a nebo i v případě, že v rámci stejného skladu potřebuje artikl převést u jedné buňky na jinou.

Po aktivaci daného procesu je nutno nejprve zadat atributy operace výdeje ze skladu. Po jejím ukončení se automaticky předplní operace příjmu na sklad, kde uživatel zadá jinou identifikaci skladu či skladové buňky.

2.7 Získávání informací a výstupy

V každé činnosti menu Sklad má uživatel k dispozici příslušné předlohy výstupu, které se vztahují k dané činnosti. Implementačně lze samozřejmě vytvořit další předlohy výstupu dle přání a požadavků uživatele.

Činnosti, které poskytují uživateli přehled o množství artiklu na skladě jsou:

¨ aktuální hodnoty skladu

¨ množství artiklu na skladech

V případě potřeby ještě jiných informačních přehledů a stavu a množství artiklů lze např. využít možností, které poskytují informační panely apod.

2.7.1 Stav a obraty

Jak jsme již zmínili výše, stav artiklu lze zjistit v činnosti „aktuální hodnoty skladu“. Po aktivaci této činnosti uživatel zadává především druh hodnoty, jejíž stav zjišťuje (ve většině případů buď NAT – naturální vyjádření stavu artiklu nebo FIN – finanční vyjádření stavu artiklu), adresáta, artikl (druh, id), sklad, selektory a paletu. Výběrové možnosti může podle potřeby libovolně kombinovat, takže si může sám vytvořit různé přehledy aktuálních hodnot skladu (např. podle vybraného adresáta nebo za daný artikl nebo za sklad apod.).

Stejnou možnost kombinovat si na základě výběrové záložky poskytuje uživateli i činnost „množství artiklu na skladech“. Zde už z názvu vyplývá, že poskytovaná informace o stavu se týká množství, tzn. stavu v naturálním vyjádření, tj. kolik kusů, metrů, kg apod. uživatel daného artiklu na skladě má. Ve výběrové záložce může vybrat artikl (druh, id), sklad, selektory, paletu. A IS BM po potvrzení výběru poskytuje u každého artiklu informace o množství, rezervovaném množství a celkové ceně.

Činnost „obraty skladu“ poskytuje uživateli přehled o pohybu artiklu na skladě za vybrané období. Na záložce výběr má uživatel k dispozici atributy datum od – do, poslední obrat (neurčeno, zahrnout, pouze), druh hodnoty, adresát, artikl (druh, id), sklad, selektory a paleta. Může využít jednu, dvě nebo kombinaci několika výběrových atributů. U každého zobrazeného obratu má následně uživatel informaci o počátečním stavu, příjmu, výdeji a konečném stavu.

2.7.2 Nízkoobrátkové

Jedná se o artikly, jejichž obraty na skladě jsou velmi malé nebo někdy i nulové. V případě, že by uživatel potřeboval informativní přehled těchto artiklů, je možné toto zajistit implementačně buď příslušnou předlohou výstupu přímo nad obraty skladu a nebo např. nadefinováním vlastního informačního panelu, který uživateli poskytne tyto informace (implementační záležitost).

3. Popis funkcí IS BM pro sklad (menu Sklad)

3.1 Událost skladové evidence

Po aktivaci této činnosti a následném potvrzení záložky výběr se zobrazují události skladové evidence, které jsou vždy součástí určitého procesu, tzn., že události do této činnosti lze zařazovat pouze procesně, není možno je zde vkládat samostatně. Formulář poskytuje uživateli k dispozici značné množství informací, z nichž většina je díky procesnímu plnění opravě nepřístupná a má pouze informativní charakter. Jednotlivé atributy jsou:

¨ rok, datové úložiště, pořadové číslo procesu, identifikátor druhu operace, pořadí stejného druhu operace v jednom procesu, pořadí události v operaci – jednoznačná číselná definice skladové operace

¨ popis operace – zda se jedná o příjem či výdej

¨ datum – datum pohybu

¨ ocenění - oceňování na událostech může mít atribut konečné a předběžné. Možnost "konečné" uživatel použije v případě, že např. při příjmu nebo výdeji artiklu ze skladu zná přesnou a konečnou cenu artiklu, a to v případě, ať oceňuje metodou FIFO nebo metodou váženého průměru. Pokud uživateli není cena artiklu při příjmu nebo výdeji dosud známa, vybere u této události v položce ocenění možnost "předběžné".

¨ adresát – identifikace, spojení a název adresáta, jehož se daný pohyb týká

¨ ČK – čárový kód (kód automatické identifikace). Je daný pro každý artikl.

¨ artikl – druh, identifikace a název artiklu, jehož se pohyb týká

¨ sklad – identifikace umístění skladové evidence, případná identifikace umístění buňky

¨ směr procesu – může nabývat hodnot např. materiál, výrobek, služba apod. Tento atribut může sloužit k definici dalšího chování procesu, např. k nadefinování dalších navazujících operací, např. můžeme přijímat na sklad určitý artikl, který zároveň budeme zařazovat do odpisovaného majetku, tzn. že po příjmu na sklad se automaticky aktivuje operace odpisovaného majetku.

¨ VČ – identifikace výrobního čísla. Výrobní číslo může být samostatné pro každý artikl nebo i pro určitou skupinu artiklů (v případě uskladněného PC bude výrobní číslo vztaženo přímo ke konkrétnímu artiklu a bude pro něj jedinečné, v jiném případě může být výrobní číslo vztaženo např. třeba pro určitou šarži, tzn. že všechny artikly v dané šarži (např. množství vyrobené ten den na stejné lince), budou mít stejnou identifikaci výrobního čísla).

¨ Množství – množství artiklu

¨ Cena za MJ – skladová cena artiklu za uvedenou měrnou jednotku

¨ Množství v RMJ – množství v referenční měrné jednotce

¨ Cena za RMJ – skladová cena artiklu za uvedenou měrnou jednotku (pokud uživatel u daného artiklu nepoužívá možnost přepočtu MJ, jsou atributy množství a množství v RMJ shodné a rovněž shodné jsou atributy cena za MJ a cena za RMJ. Pokud používá přepočet měrných jednotek, jsou tyto atributy rozdílné).

¨ Celkem – celková cena (množství v RMJ krát cena za RMJ)

¨ Selektory – identifikace o jednotlivých selektorech (obchodní, technicko-věcný a organizační)

¨ Zapsal – jméno uživatele, kdo operaci zapsal a datum a čas zápisu

Pod menu Volby nebo po stisku Ctrl S je možno vyvolat funkci celkové sumy. Uživateli se zobrazí tabulka s vyčíslenými vybranými údaji, tj. celkem příjem, celkem výdej a rozdíl.

Po stisku klávesy F9 (nebo pod menu Volby „spustit operaci“) si uživatel aktivuje přímo danou operaci skladové evidence.

Pod menu Volby nebo po stisku klávesy Ctrl P je možno aktivovat činnost Prezentace artiklu. Uživateli se následně zobrazí samostatné okno, které je propojené s artikly. Např. můžeme mít oděvní firmu, která si ke každému artiklu vloží prezentaci (čili fotografii) každého jednotlivého kusu oděvu.

Propojení nebo vložení objektu se realizuje funkcí „vložit objekt“ nebo „vložit“ v horní liště obrazovky v menu Úpravy při aktivním okně prezentace artiklu. Při aktivaci funkce „ponechat“ v menu Volby nebude okno s prezentací artiklu automaticky uzavřeno při ukončení činnosti s přehledem artiklů nebo dokumentů.

Další činností, kterou je možno aktivovat pod menu Volby (nebo po stisku klávesy Ctrl O) je činnost Označování. Uživateli se pak zobrazí následující nabídka:

¨ označení všech – označí se (tzn. zaškrtnou) všechny vybrané záznamy

¨ odznačení všech – odznačí se všechny v danou chvíli označené záznamy (i ty nevybrané)

¨ přehled označených / všech – při první aktivaci tohoto tlačítka se uživateli zobrazí přehled označených záznamů, při dalším stisku se zobrazí naopak přehled všech vybraných záznamů (funguje jako přepínač)

¨ počet označených záznamů – uživateli je poskytnuta informace o počtu aktuálně označených záznamů. Stejnou informaci má uživatel i na dolní liště okna činnosti.

¨ označování výrazem

Označené záznamy je možno si nejen zobrazit (tj. přehled označených), ale i tisknout. V okamžiku spuštění předlohy výstupu má uživatel možnost vybrat si k tisku pouze označené záznamy. V případě, že menu Volby daného formuláře obsahuje i podmenu Označování, potom se po stisku pravého tlačítka myši na zaškrtávacím políčku (tzn. tom políčku, které je u daného záznamu zatrženo jako označené) zobrazí menu, které odpovídá obsahu podmenu Označování (tzn. s možnostmi Označení všech, Odznačení všech, ...).

Pod menu Obecné má uživatel k dispozici i činnost Volné karty, která mu poskytuje podrobnější informace k dané činnosti. Jsou nadefinované tyto druhy volných karet:

¨ volná karta procesu - foto dokladu procesu – po aktivaci této volné karty se uživateli zobrazí prázdný formulář, kde po stisku pravého tlačítka myši může načíst vybraný dokument či obrázek. Ten je potom dostupný vždy po vyvolání této volné karty u daného procesu a zároveň je jako připojený dokument Procesu dostupný pod Ctrl D (spojené dokumenty)

- informace o skladu (výdej) – po aktivaci této volné karty uživatel získá informaci, zda daný artikl uvedený v tomto procesu LZE VYDAT či NELZE VYDAT ze skladu

¨ volná karta adresáta - poznámka – vztahuje se přímo k adresátovi události a uživatel si na ní může uvést jakoukoliv poznámku k danému adresátovi (tuto volnou kartu a tím i poznámku k adresátovi má uživatel dostupnou i v dalších činnostech komponenty sklad, ale třeba i přímo v adresáři a dalších činnostech IS BM).

¨ volná karta artiklu - informace o artiklu – sklad – po aktivaci této volné karty má uživatel k dispozici základní informace o uvedeném artiklu, tzn. jeho skladované množství, případné rezervované množství, disponibilní množství, měrnou jednotku a název artiklu. V případě, že by daný artikl měl uživatel uložen na vícero skladech, informace o množství na této volné kartě jsou uvedené celkem za všechny sklady.

3.1.1 FIFO – příjem

Pokud má uživatel nastaveno oceňování skladu metodou FIFO (first in – first out), má pod touto záložkou dostupné příjmy daného artiklu. Po stisku klávesy F9 si lze spustit přímo aktuální příjem. Při oceňování skladu metodou FIFO se jako první vyskladňují artikly, které byly také první nakoupeny.

3.1.2 FIFO - výdej

Stejné jako u předchozí kapitoly, ale týkající se pouze výdejů. Pokud má uživatel nastaveno oceňování skladu metodou FIFO (first in – first out), má pod touto záložkou dostupné výdeje daného artiklu. Po stisku klávesy F9 si lze spustit přímo aktuální výdej.

3.1.3 Účetnictví

Po aktivaci této záložky se uživateli zobrazí informace o tom, jakým způsobem byl daný skladový pohyb zaúčtován (např. datum zaúčtování, číslo účtu, částka apod.). Po stisku klávesy F9 je možno si aktivovat danou účetní operaci.

3.1.4 Záložka „Výběr“

Po aktivaci činnosti „události skladové evidence“ má uživatel jako první k dispozici záložku Výběr. Zde si nadefinováním příslušného výběru zvolí data, která chce mít následně zobrazena. Na žlutých výběrových polích je vždy možný výběr hodnot z číselníku. Pokud nechá uživatel výběr prázdný (tzn. nebudou zvoleny žádné výběrové atributy) bude mít k dispozici všechny události skladové evidence. Výběrové atributy jsou následující:

¨ rok, identifikace datového úložiště, číslo procesu od – do

¨ druh operace

¨ druh procesu

¨ datum od – do

¨ zaškrtnutím lze zvolit, zda se má jednat o události příjmu – výdeje – či obojího

¨ možno vybírat události i podle popisu

¨ zaškrtnutím lze zvolit, zda se má jednat o události s oceněním konečné – předběžné – či obojí

¨ je možno si vybrat i události podle vztahu k účetnictví (výběr z překryvného seznamu) či podle stavu procesu (-, nestornovaný, stornovaný, stornující)

Další výběrové atributy se nacházejí v pravé části formuláře Výběr a jsou to:

¨ adresát - identifikace, spojení, název adresáta a možné je i vyhledávání podle kategorie adresáta

¨ artikl – možné vyhledávání podle druhu artiklu, jeho identifikace nebo názvu

¨ možnost vybírat podle výrobního čísla nebo čárového kódu

¨ sklad – události si lze vyfiltrovat i za zvolený sklad, buňku a měrnou jednotku

¨ lze si zvolit události i jednotlivých selektorů (obchodní, organizační a technicko-věcný)

¨ vyhledávat události lze i podle účetního selektoru

¨ zapsal – lze si zvolit události i podle toho, kdo je vytvořil

¨ žádný speciální obecný výběr zde není definován (v případě jeho potřeby je možno ho zde nadefinovat)

3.1.5 Předlohy výstupu

Po stisku ikonky „tiskárna“ nebo po aktivaci činnosti „Tisk“ z menu Volby má uživatel k dispozici následující předlohy výstupu:

¨ Dodací list – klasická sestava, která obsahuje informace o dodavateli a příjemci (+ veškeré náležitosti jejich adres včetně IČ), názvu artiklu, množství a měrné jednotce. K tomu jsou zde informace typu vydal, přijal, podpis a datum vystavení dokladu.

¨ Přehled pohybů se součtem – klasická sestava před jejímž spuštění je vhodné si na záložce výběr zvolit buď jen příjmy či jen výdeje (sestava je potom pro uživatele přehlednější). Poskytuje uživateli informace o čísle vystaveného dokladu, množství a celkové sumě.

¨ Příjemka – klasická sestava, která obsahuje informace o dodavateli a příjemci (+ veškeré náležitosti jejich adres včetně IČ), čísle dokladu, identifikaci a názvu artiklu, jeho množství a měrné jednotce, ceně za jednotku a ceně bez DPH. Na konci příjemky je součtový řádek cena celkem bez daně za příjemku. K dispozici jsou samozřejmě i údaje typu přijal, místo a datum.

¨ Výdejka – klasická sestava, která obsahuje informace o dodavateli a příjemci (+ veškeré náležitosti jejich adres včetně IČ), čísle dokladu, identifikaci a názvu artiklu, jeho množství a měrné jednotce, ceně za jednotku a ceně bez DPH. Na konci výdejky je součtový řádek cena celkem bez daně za výdejku. K dispozici jsou samozřejmě i údaje typu vydal, přijal, místo a datum.

¨ Inventura skladu za období – sestava typu excel, kde už z názvu vyplývá, že je vhodné si na záložce výběr zvolit období od – do. Sestava je setříděna za jednotlivé artikly a u každého artiklu má uživatel k dispozici informace o čísle dokladu, datu pohybu, druhu a identifikaci artiklu, skladu, počátečním stavu, příjmu, výdeji a konečném stavu. Za daný artikl je vždy k dispozici ještě součtový řádek.

3.2 Aktuální hodnoty skladu

Jedná se o hodnoty, které vyjadřují určitý aktuální stav (k dnešnímu datu) na skladě. Může se jednat o finanční či naturální vyjádření stavu skladu nebo o informaci o stavu materiálu na skladě. Každá aktuální hodnota se může vztahovat k jednomu nebo všem adresátům, záleží na tom, jaký výběr si uživatel při spuštění této činnosti nastaví. Definice sledovaných aktuálních hodnot se provádí v činnosti Informační centrum – Komponenty – Druhy hodnot.

Na základě těchto druhů hodnot a jejich používání v jednotlivých procesech je pak uživatel v podstatě schopen zjistit jakoukoliv potřebnou informaci o stavu skladu.

Po zadání záložky výběr má uživatel k dispozici tyto informace:

¨ druh hodnoty – identifikace a název druhu hodnoty

¨ adresát- zobrazení identifikace a názvu adresáta, kterého se hodnota týká (po stisku pravého tlačítka na tučném atributu adresát má uživatel k dispozici další údaje a informace týkající se daného adresáta)

¨ artikl – druh artiklu, jeho identifikace a název (po stisku pravého tlačítka na tučném atributu artikl má uživatel k dispozici další údaje a informace týkající se daného artiklu)

¨ sklad – identifikace skladu, na němž je artikl, ke kterému se vztahuje vybraná hodnota, případná identifikace buňky a vlastní název skladu

¨ obchodní, organizační a technicko-věcný selektor

¨ vlastní hodnota

Po stisku klávesy Ctrl S má uživatel možnost nechat si vyčíslit celkovou sumu zobrazených aktuálních hodnot. V takovém případě je však vhodné si výběr na záložce „výběr“ vždy vyfiltrovat za jednu hodnotu (aby nedocházelo k tomu, že se budou např. nesmyslně sčítat hodnoty NAT a FIN).

Po stisku klávesy F6 nebo příslušnou volbou činnosti pod menu Volby si lze aktivovat „události správy artiklu“. Jedná se o události těch artiklů, které v číselníku u sebe mají nadefinovanou určitou kategorii a uživatel pak má tyto události kompletně k dispozici na jednom místě.

Pod menu Obecné má uživatel k dispozici i činnost Volné karty, která mu poskytuje podrobnější informace k dané činnosti. Jsou nadefinované tyto druhy volných karet:

¨ volná karta adresáta - poznámka – vztahuje se přímo k adresátovi události a uživatel si na ní může uvést jakoukoliv poznámku k danému adresátovi (tuto volnou kartu a tím i poznámku k adresátovi má uživatel dostupnou i v dalších činnostech komponenty sklad, ale třeba i přímo v adresáři a dalších činnostech IS BM).

¨ volná karta artiklu - informace o artiklu – sklad – po aktivaci této volné karty má uživatel k dispozici základní informace o uvedeném artiklu, tzn. jeho skladované množství, případné rezervované množství, disponibilní množství, měrnou jednotku a název artiklu. V případě, že by daný artikl měl uživatel uložen na vícero skladech, informace o množství na této volné kartě jsou uvedené celkem za všechny sklady.

3.2.1 Záložka „Výběr“

Po aktivaci činnosti „aktuální hodnoty skladu“ se uživateli nejprve zobrazí záložka „výběr“, kde má možnost si pomocí zadání jednotlivých výběrových atributů vyfiltrovat potřebnou množinu dat. Na žlutých výběrových polích je vždy možný výběr hodnot z číselníku. Výběrová kritéria jsou následující:

¨ druh hodnoty – výběr druhu hodnoty, jejíž pohyby budou následně zobrazeny

¨ adresát – identifikace, název a v případě potřeby možno vybírat i podle kategorie adresáta

¨ artikl – druh artiklu, identifikace a název – uživatel může využít jeden z těchto výběrových atributů či kombinaci všech

¨ sklad – výběr skladu, jehož se mají hodnoty týkat, případně výběr i podle identifikace skladové buňky a názvu skladu

¨ možnost výběru i podle jednotlivých selektorů (obchodní, organizační a technicko-věcný)

¨ paleta - v případě, že uživatel u jednotlivých karet artiklu využívá nastavení palety barev u kategorie artiklu, lze vyhledávat i podle palety barev

3.3 Množství artiklu na skladech

Po nadefinování záložky Výběr se uživateli zobrazí následující formulář, kde u každého artiklu má k dispozici následující informace:

¨ druh artiklu, jeho identifikace a název (po stisku pravého tlačítka myši na tučném atributu artikl má uživatel k dispozici další údaje a informace o daném artiklu)

¨ sklad – identifikace skladu, skladové buňky (pokud uživatel u skladů dále nečlení evidenci na sklad. buňky, je zde uvedena pomlčka) a název skladu

¨ množství – celkové množství daného artiklu na daném skladu v naturálním vyjádření

¨ rezervováno – případné rezervované množství daného artiklu na daném skladu

¨ celková cena - celkové množství daného artiklu na daném skladu ve finančním vyjádření

Po stisku klávesy F6 nebo příslušnou volbou činnosti pod menu Volby si lze aktivovat „události správy artiklu“. Jedná se o události těch artiklů, které v číselníku u sebe mají nadefinovanou určitou kategorii a uživatel pak má tyto události kompletně k dispozici na jednom místě.

Co se týká nastavení např. optimálního množství artiklu na skladě, tzn. uživatel si u vybraných artiklů hlídá stav, pod který nechce, aby se skladové zásoby dostaly, lze využít dalších možností, které mu systém nabízí. Lze si nadefinovat volnou kartu, kde bude uvedeno optimální množství a v případě, že stav daného artiklu klesne na skladě pod toto množství, bude na to uživatel upozorněn zprávou, kterou mu systém automaticky zobrazí po jeho přihlášení do systému.

Pod menu Obecné má uživatel k dispozici i činnost Volné karty, která mu poskytuje podrobnější informace k dané činnosti. Jsou nadefinované tyto druhy volných karet:

¨ volná karta adresáta - poznámka – vztahuje se přímo k adresátovi události a uživatel si na ní může uvést jakoukoliv poznámku k danému adresátovi (tuto volnou kartu a tím i poznámku k adresátovi má uživatel dostupnou i v dalších činnostech komponenty sklad, ale třeba i přímo v adresáři a dalších činnostech IS BM).

¨ volná karta artiklu - informace o artiklu – sklad – po aktivaci této volné karty má uživatel k dispozici základní informace o uvedeném artiklu, tzn. jeho skladované množství, případné rezervované množství, disponibilní množství, měrnou jednotku a název artiklu. V případě, že by daný artikl měl uživatel uložen na vícero skladech, informace o množství na této volné kartě jsou uvedené celkem za všechny sklady.

3.3.1 Záložka „Výběr“

Po aktivaci této činnosti se uživateli nejprve zobrazí záložka Výběr, kde si zadáním příslušných hodnot vybere množinu dat, kterou potřebuje vidět. Pokud nechá výběrové atributy prázdné, uvidí množství na skladech za všechny artikly na všech skladech. Na žlutých výběrových polích je vždy možný výběr hodnot z číselníku. Vybírat lze z těchto atributů:

¨ artikl – možnost zadání druh artiklu, jeho identifikace a názvu

¨ sklad – lze si zvolit konkrétní sklad (resp. jeho identifikaci), identifikaci skladové buňky (pokud uživatel u jednotlivých skladů rozlišuje ještě i skladové buňky) nebo je možno si vybrat přímo podle názvu skladu

¨ selektory – výběr podle organizačního či technicko-věcného selektoru

¨ paleta - v případě, že uživatel u jednotlivých karet artiklu využívá nastavení palety barev u kategorie artiklu, lze vyhledávat i podle palety barev

3.3.2 Předlohy výstupu

Po stisku ikonky „tiskárna“ nebo po aktivaci činnosti „Tisk“ z menu Volby má uživatel k dispozici následující předlohy výstupu:

¨ Množství na skladě + suma – klasická, velmi jednoduchá sestava pouze se základními informacemi. Obsahuje druh artiklu, jeho identifikaci, název a množství + celkové množství za sestavu.

3.4 Obraty skladu

Po zadání příslušných údajů na záložce Výběr se uživateli následně zobrazí vlastní činnost „Obraty skladu“, kde má k dispozici údaje jakoby opticky rozčleněné do tří částí. První část je řádkový přehled jednotlivých obratů, v dolní části formuláře jsou pak detailní informace k aktivnímu (tj. ten, na jehož řádce je umístěn kurzor) obratu rozdělené na pravou a levou část. Levá část (přesněji spíš levý sloupeček) obsahuje tyto informace:

¨ datum obratu a druh hodnoty

¨ adresát – pokud je obrat vztažen ke konkrétnímu adresátovi, je zde k dispozici jeho identifikace a název (po stisku pravého tlačítka myši na tučném atributu adresát má uživatel k dispozici další informace a události daného adresáta)

¨ artikl – druh artiklu, jeho identifikace, název a měrná jednotka, v níž je obrat zobrazen (po stisku pravého tlačítka myši na tučném atributu artikl má uživatel k dispozici další informace a události daného artiklu)

¨ sklad – identifikace a název skladu

¨ případné selektory, pokud jsou u obratu uvedeny

V pravé části (tj. v pravém sloupečku) jsou již samotné hodnoty daného obratu. Hodnota počátečního stavu, hodnota příjmu, hodnota výdeje a hodnota konečného stavu.

Po stisku klávesy F6 nebo příslušnou volbou činnosti pod menu Volby si lze aktivovat „události správy artiklu“. Jedná se o události těch artiklů, které v číselníku u sebe mají nadefinovanou určitou kategorii a uživatel pak má tyto události kompletně k dispozici na jednom místě.

Pod menu Obecné má uživatel k dispozici i činnost Volné karty, která mu poskytuje podrobnější informace k dané činnosti. Jsou nadefinované tyto druhy volných karet:

¨ volná karta adresáta - poznámka – vztahuje se přímo k adresátovi události a uživatel si na ní může uvést jakoukoliv poznámku k danému adresátovi (tuto volnou kartu a tím i poznámku k adresátovi má uživatel dostupnou i v dalších činnostech komponenty sklad, ale třeba i přímo v adresáři a dalších činnostech IS BM).

¨ volná karta artiklu - informace o artiklu – sklad – po aktivaci této volné karty má uživatel k dispozici základní informace o uvedeném artiklu, tzn. jeho skladované množství, případné rezervované množství, disponibilní množství, měrnou jednotku a název artiklu. V případě, že by daný artikl měl uživatel uložen na vícero skladech, informace o množství na této volné kartě jsou uvedené celkem za všechny sklady.

3.4.1 Záložka „Výběr“

Záložka Výběr se uživateli zobrazí jako první po aktivaci činnosti Obraty skladu. Na žlutých výběrových polích je vždy možný výběr hodnot z číselníku. Při výběru lze využít těchto atributů:

¨ datum od – do – možnost časového ohraničení vybraných dat

¨ poslední obrat - atribut, který má zásadní význam pro zobrazení dat a z nabídky překryvného seznamu lze zvolit tyto hodnoty:

- neurčeno - zobrazuje veškeré obraty nezávisle na období (tzn. není nutno zadávat žádné období od - do). Tuto hodnotu je vhodné využít např. při zobrazení hodnot za vybraný sklad, artikl nebo adresáta.

- zahrnout - hodnota zahrnout naopak úzce souvisí s obdobím od - do. Při použití hodnoty zahrnout je zároveň nutno zadat období OD - DO a systém pak zobrazí obraty za dané období s tím, že pokud u některého artiklu nenajde obrat v zadaném období OD - DO, zobrazí obrat s nejvyšším nižším datem

- pouze – hodnotu pouze má smysl používat nikoliv pro zjišťování obratů, ale pro zjištění konečných stavů s tím, že zároveň s touto hodnotou musí být uvedeno období DO (období OD zůstává nevyplněné).

¨ druh hodnoty – výběr z číselníku nadefinovaných druhů hodnot. Nejčastěji se využívají hodnoty

NAT (množství obratů v naturálním vyjádření) nebo FIN (množství obratů ve finančním vyjádření). Pokud nechá uživatel tento atribut prázdný, zobrazí se mu množství obratů jak v NAT, tak i ve FIN.

¨ adresát – možnost výběru obratů pouze za zvoleného adresáta. Lze vyhledávat podle jeho identifikace, názvu nebo příslušnosti v kategorii.

¨ artikl – možnost výběru obratů pouze za zvolený artikl. Lze vyhledávat podle druhu artiklu, jeho identifikace nebo názvu.

¨ sklad – výběr skladu, jehož obraty budou zobrazeny

¨ paleta - v případě, že uživatel u jednotlivých karet artiklu využívá nastavení palety barev u kategorie artiklu, lze vyhledávat i podle palety barev

¨ selektory – možnost výběru podle zvoleného selektoru

¨ výběr - běžný

- nenulové množství (na základě tohoto výběru se zobrazí pouze artikly, které mají nějakou hodnotu obratu, tzn. jejich počáteční stav + příjem – výdej se nerovná hodnotě nula)

- pouze (historický obecný výběr. Tento výběr je nyní plně nahrazen možností „pouze“ ve výběrovém artiklu poslední obrat)

3.4.2 Předlohy výstupu

Po stisku ikonky „tiskárna“ nebo po aktivaci činnosti „Tisk“ z menu Volby má uživatel k dispozici následující předlohy výstupu. Všechny předlohy výstupu nad touto činností jsou do značné míry vždy ovlivněny uživatelským výběrem na záložce Výběr:

¨ Inventura k datu – sestava typu Excel, která uživateli poskytuje informace o druhu artiklu, identifikaci a jeho názvu, referenční měrné jednotce, množství, ocenění (cena celkem) a ceně za MJ

¨ Inventura nad obraty – klasická sestava, která uživateli poskytuje souhrnné informace za daný sklad. K dispozici je údaj o druhu artiklu, identifikaci a názvu, jeho množství v NAT (naturální vyjádření) a FIN (finanční vyjádření), ceně za MJ a měrné jednotce

¨ Inventura nad obraty XLS – sestava typu Excel, která uživateli v podstatě nahrazuje inventurní protokol. K dispozici má údaje o druhu artiklu, jeho identifikaci a názvu a MJ. Dále uživatel vidí konečný stav v NAT, konečný stav FIN, konečný stav FYZ (což znamená fyzický stav. Do této kolonky uživatel napíše skutečné zjištěné množství daného artiklu na skladě). V políčku Rozdíl pak systém sám automaticky dopočítá rozdíl mezi množstvím NAT (které je uvedeno v systému) a množstvím, které bylo skutečně fyzicky zjištěno.

¨ Přehled za období – sestava typu Excel, před jejíž aktivací je vhodné si na záložce Výběr určit sklad a období od – do. Následně má uživatel k dispozici informace o druhu artiklu, jeho identifikaci a názvu a ke každému artiklu i jednotlivé stavy, tzn. počáteční stav NAT, počáteční stav FIN, příjmy v NAT, příjmy ve FIN, výdeje v NAT, výdeje ve FIN, konečný stav NAT a konečný stav FIN. Celkem za sestavu je potom k dispozici ve FIN počáteční stav, příjmy, výdeje a konečný stav.

3.5 Obraty skladu – VČ

Po zadání příslušných údajů na záložce Výběr se uživateli následně zobrazí vlastní činnost „Obraty skladu - VČ“, kde má k dispozici následující informace:

¨ VČ – identifikace výrobního čísla

¨ artikl – druh artiklu, jeho identifikace a název (na tučném atributu artikl jsou k dispozici další údaje a informace k danému artiklu)

¨ sklad – identifikace skladu

¨ druh hodnoty – identifikace hodnoty, jejíž výše je následně zobrazena

¨ datum – datum obratu (z událostí skladu)

¨ vlastní hodnota obratu – vždy zobrazená v příslušné kolonce podle toho, jakého pohybu se obrat týkal – počáteční stav, příjem, výdej nebo konečný stav

Po stisku klávesy F6 nebo příslušnou volbou činnosti pod menu Volby si lze aktivovat „události správy artiklu“. Jedná se o události těch artiklů, které v číselníku u sebe mají nadefinovanou určitou kategorii a uživatel pak má tyto události kompletně k dispozici na jednom místě.

Pod menu Obecné má uživatel k dispozici i činnost Volné karty, která mu poskytuje podrobnější informace k dané činnosti. Jsou nadefinované tyto druhy volných karet:

¨ volná karta adresáta - poznámka – vztahuje se přímo k adresátovi události a uživatel si na ní může uvést jakoukoliv poznámku k danému adresátovi (tuto volnou kartu a tím i poznámku k adresátovi má uživatel dostupnou i v dalších činnostech komponenty sklad, ale třeba i přímo v adresáři a dalších činnostech IS BM).

¨ volná karta artiklu - informace o artiklu – sklad – po aktivaci této volné karty má uživatel k dispozici základní informace o uvedeném artiklu, tzn. jeho skladované množství, případné rezervované množství, disponibilní množství, měrnou jednotku a název artiklu. V případě, že by daný artikl měl uživatel uložen na vícero skladech, informace o množství na této volné kartě jsou uvedené celkem za všechny sklady.

3.5.1 Záložka „Výběr“

Po aktivaci činnosti „obraty skladu – VČ“ se uživateli zobrazí jako první záložka Výběr, kde si může nadefinovat množinu dat podle následujících atributů (na žlutých výběrových polích je vždy možný výběr hodnot z číselníku):

¨ VČ – obraty pouze za konkrétní výrobní číslo (jak jsme se již zmínili, může to být jednoznačné výrobní číslo ke každému artiklu nebo může výrobní číslo zastupovat např. celou vyrobenou šarži daného artiklu)

¨ datum od – do

¨ artikl – možný výběr podle druhu artiklu či identifikace artiklu

¨ sklad – výběr obratů artiklů s VČ pouze za konkrétní sklad

¨ druh hodnoty – stejné jako u klasických obratů skladu. Výběr hodnoty NAT (naturální vyjádření množství) nebo FIN (finanční vyjádření množství). Pokud si uživatel ve výběru jednu z nich nezadá, systém ukáže obraty artiklů s VČ jak v NAT, tak i ve FIN.

¨ poslední obrat - atribut, který má zásadní význam pro zobrazení dat a z nabídky překryvného seznamu lze zvolit tyto hodnoty:

- neurčeno - zobrazuje veškeré obraty nezávisle na období (tzn. není nutno zadávat žádné období od - do). Tuto hodnotu je vhodné využít např. při zobrazení hodnot za vybraný sklad, artikl nebo adresáta.

- pouze – zobrazí se pouze poslední pohyb daného artiklu s VČ

¨ paleta - v případě, že uživatel u jednotlivých karet artiklu využívá nastavení palety barev u kategorie artiklu, lze vyhledávat i podle palety barev

3.5.2 Předlohy výstupu

Po stisku ikonky „tiskárna“ nebo po aktivaci činnosti „Tisk“ z menu Volby má uživatel k dispozici následující předlohy výstupu:

¨ Inventura nad obraty SKL s VČ – klasická sestava, která je prioritně seskupena podle jednotlivých skladů. U každého skladu je pak informace o druhu artiklu, identifikaci a názvu a jeho výrobním čísle (tj. čárový kód). U každého takto zobrazeného artiklu je k dispozici konečný stav jeho množství v naturálním i finančním vyjádření, cena za MJ a vlastní měrná jednotka. Na konci sestavy je pro uživatele k dispozici i celkový součet za sklad.

3.6 Artikly skladu

Po spuštění činnosti má uživatel nejprve možnost zvolit si nadefinováním výběru zobrazení artiklu. Při vkládání, opravě nebo prohlížení artiklu se vstupují tyto údaje:

¨ artikl - identifikace druhu artiklu. Lze vybrat ze seznamu druhů artiklu klávesou F2 (po stisku pravého tlačítka myši na tučném atributu artikl jsou k dispozici další informace a události k danému artiklu).

¨ identifikace artiklu (identifikace druhu artiklu a artiklu jsou povinné údaje)

¨ název artiklu - název artiklu

¨ ČK - pokud se používá při práci čtečka, zadává se zde čárový kód artiklu, tzn. že čárový kód na událostech obchodu a skladu se vstupuje právě proto, aby se podle něj automaticky předplnil artikl, např. právě při použití čtečky čárového kódu. Pro rozšiřující identifikátor artiklu (např. šarži) je určen na událostech obchodu a skladu atribut výrobní číslo.

¨ MJ - identifikátor měrné jednotky (jedná se o MJ, v níž se daný artikl skladuje, přijímá, vydává apod.), tzn. je to referenční měrná jednotka

¨ třída SKP - identifikace třídy standardní klasifikace produkce. Pokud uživatel nechce zadávat, vybírá možnost neurčeno.

¨ vztah k účetnictví - jaký vztah k účetnictví zaujímá daný artikl. Může to být materiál, zboží, výrobek atd. - uživatel má možnost si vybrat z překryvného seznamu, který je v případě potřeby ještě možno rozšířit.

¨ technicko-věcný selektor - identifikátor technicko - věcného selektoru. V postatě určuje, jaké činnosti v organizaci se daný artikl týká.

¨ účetní selektor - zadává se zde přímo hodnota účtu, na který se daný artikl (resp. pohyby s daným artiklem) účtuje

¨ stav - může být aktuální či neaktuální. Ve většině případů bude určitě aktuální, v případě, že uživatel nechce artikl již používat a on nelze zrušit, protože již byl použit v událostech, nastaví u něj právě příznak neaktuální (pak je vhodné si ve výběrové záložce vybírat pouze aktuální artikly).

¨ povolena nulová cena - tento artikl je možno v událostech vstupovat s nulovou cenou, jinak musí být cena vždy uvedena.

¨ libovolná poznámka k artiklu

Po stisku klávesy F6 nebo příslušnou volbou činnosti pod menu Volby si lze aktivovat „události správy artiklu“. Jedná se o události těch artiklů, které v číselníku u sebe mají nadefinovanou určitou kategorii a uživatel pak má tyto události kompletně k dispozici na jednom místě.

Pod menu Volby nebo po stisku klávesy Ctrl P je možno aktivovat činnost Prezentace artiklu. Uživateli se následně zobrazí samostatné okno, které je propojené s artikly. Např. můžeme mít oděvní firmu, která si ke každému artiklu vloží prezentaci (čili fotografii) každého jednotlivého kusu oděvu.

Propojení nebo vložení objektu se realizuje funkcí „vložit objekt“ nebo „vložit“ v horní liště obrazovky v menu Úpravy při aktivním okně prezentace artiklu. Při aktivaci funkce „ponechat“ v menu Volby nebude okno s prezentací artiklu automaticky uzavřeno při ukončení činnosti s přehledem artiklů nebo dokumentů.

Další činností, kterou je možno aktivovat pod menu Volby (nebo po stisku klávesy Ctrl O) je činnost Označování. Uživateli se pak zobrazí následující nabídka:

¨ označení všech – označí se (tzn. zaškrtnou) všechny vybrané záznamy

¨ odznačení všech – odznačí se všechny v danou chvíli označené záznamy (i ty nevybrané)

¨ přehled označených / všech – při první aktivaci tohoto tlačítka se uživateli zobrazí přehled označených záznamů, při dalším stisku se zobrazí naopak přehled všech vybraných záznamů (funguje jako přepínač)

¨ počet označených záznamů – uživateli je poskytnuta informace o počtu aktuálně označených záznamů. Stejnou informaci má uživatel i na dolní liště okna činnosti.

¨ označování výrazem

Označené záznamy je možno si nejen zobrazit (tj. přehled označených), ale i tisknout. V okamžiku spuštění předlohy výstupu má uživatel možnost vybrat si k tisku pouze označené záznamy. V případě, že menu Volby daného formuláře obsahuje i podmenu Označování, potom se po stisku pravého tlačítka myši na zaškrtávacím políčku (tzn. tom políčku, které je u daného záznamu zatrženo jako označené) zobrazí menu, které odpovídá obsahu podmenu Označování (tzn. s možnostmi Označení všech, Odznačení všech, ...).

Pod menu Obecné má uživatel k dispozici i činnost Volné karty, která mu poskytuje podrobnější informace k dané činnosti. Jsou nadefinované tyto druhy volných karet:

¨ volná karta artiklu - informace o artiklu – sklad – po aktivaci této volné karty má uživatel k dispozici základní informace o uvedeném artiklu, tzn. jeho skladované množství, případné rezervované množství, disponibilní množství, měrnou jednotku a název artiklu. V případě, že by daný artikl měl uživatel uložen na vícero skladech, informace o množství na této volné kartě jsou uvedené celkem za všechny sklady.

3.6.1 Názvy skl. artiklu v jazycích

U každého artiklu je možno evidovat jeho název v různých, uživatelsky zvolených, jazycích. Definuje se vždy identifikace jazyka a název artiklu v daném jazyce. Tuto cizojazyčnost je poté možno využívat např. i v tiscích apod. Možnost výběru jazyků je dána tím, jaké jazyky má uživatel nadefinované v činnosti „jazyky systému“ (menu Informační centrum – Jazyky systému).

3.6.2 Přepočet MJ skl. art.

Na této záložce uživatel definuje vztah jednotlivých měrných jednotek u daného artiklu. Může být uvedeno více možných vztahů, přepočty kusy na kg nebo metry apod. I tyto nadefinované údaje lze využívat v předlohách výstupu, např. na dodacím listu (pokud je u artiklu uveden přepočet kus – kilogram, lze např. zjistit celkovou hmotnost artiklů na dodacím listě).

Vysvětlíme si tuto činnost a její zadávání na konkrétním případě. Např. budeme mít artikl, který má tyto vztahy měrných jednotek: 10 kusů se rovná balení a zároveň 10 balení se rovná paleta a paleta se rovná 55 kg. Potom bude zadání následovné:

MJ – bal = 10 ks

MJ – pal = 10 bal

MJ – pal = 155 kg

Všechny uvedené měrné jednotky musí mít uživatel nadefinovány v činnosti „měrné jednotky“ (menu Informační centrum – Jazyky systému).

3.6.3 Množství

Tato záložka poskytuje uživateli přehled o množství daného artiklu na jednotlivých skladech. K dispozici jsou informace o skladu, množství artiklu, případném rezervovaném množství, celkové ceně a ceně za měrnou jednotku. V horní části má vždy uživatel názorné info ke kterému artiklu se tyto informace vztahují.

3.6.4 Aktuální hodnoty

Tato záložka poskytuje uživateli přehled jednotlivých nadefinovaných druhů hodnot. Ke každé komponentě (menu Informační centrum – Typy a řady – Komponenty) lze po stisku klávesy F7 nadefinovat druhy hodnot. Pokud jsou tyto hodnoty nadefinovány a zároveň nastaveny v činnosti „základní druhy hodnot“ (v menu Sklad), tak se na této záložce zobrazují jejich aktuální hodnoty. Uživatel má k dispozici informaci o skladu, druhu hodnoty a její výši, např. sklad XX, druh hodnoty NAT, hodnota 41 a další řádek je např. sklad XX, druh hodnoty FIN a hodnota 20 024,43, tzn. že na skladu XX je daného artiklu 41 ks v celkové výši 20 024,43 Kč.

3.6.5 Kategorie

V této činnosti má uživatel možnost si nadefinovat jednotlivé kategorie, které by mohl využít při práci s jednotlivými artikly. Jsou vhodné zejména k rozlišení různých hledisek třídění artiklů. U každé kategorie je navíc možno nadefinovat i barvu písma a pozadí. Kategorie (přesněji Paleta) skladovaný artikl obarví (viz. následující obrázek).

Definují se zde tyto atributy:

¨ kategorie – výběr z číselníku kategorií (možnost si i nadefinovat novou)

¨ platnost – platnost artiklu v kategorii od – do

¨ adresát – výběr z číselníku (po stisku pravého tlačítka myši na tučném atributu adresát jsou k dispozici další informace k adresátovi)

¨ popis – vlastní popis kategorie a případná poznámka

3.6.6 Záložka „Výběr“

Po aktivaci činnosti „artikly skladu“ má uživatel nejprve k dispozici záložku „Výběr“, kde si může podle svých potřeb vyfiltrovat potřebnou množinu dat. Na žlutých výběrových polích je vždy možný výběr hodnot z číselníku. Je možno vybírat podle následujících atributů:

¨ druh artiklu, identifikace artiklu, název artiklu – možno využít všechny tři atributy najednou nebo každý z nich samostatně. Lze hledat podle čísla artiklu, či části jeho názvu (vyhledávání pomocí %) apod.

¨ MJ – možnost hledání artiklů pouze zadané měrné jednotky

¨ stav – možnost vše/aktuální/neaktuální. Tuto volbu využije uživatel u těch artiklů, kde si tento atribut (aktuální/neaktuální) aktivně vyplňuje. Z praxe se spíše asi využije vyplnit atribut neaktuální, zejména u karet artiklu, které již nejsou aktivní, nicméně uživatel je nechce rušit, tudíž jim zadá příznak neaktuální a právě pomocí této možnosti ve výběru si pak může zvolit pouze ty aktuální.

¨ směr procesu – možnost výběru směru procesu, souvisí pak s následnými možnostmi zaúčtování. Lze si zvolit neurčeno, zboží, materiál, výrobek, službu, HIM, NHIM, DRM, neúčetní a výdaje.

¨ množství – možnost si zvolit vše, nenulové, nulové

¨ technický selektor – identifikátor technicko-věcného selektoru, možnost výběru z číselníku

¨ účetní selektor – možnost zvolit si přímo číslo účtu, na který se pohyby s daným artiklem účtují

¨ kategorie – pokud má uživatel u jednotlivých karet artiklů vytvořeny kategorie, je zde možno vybírat i podle těchto kategorií. Možnosti jsou „Je“ (k dnešnímu datu je v kategorii), „Není“ (k dnešnímu datu není v kategorii), „Byl“ (aktuálně v kategorii není, ale byl), „Nebyl“ (není a nikdy nebyl v kategorii)

¨ v případě volby „Je“ a „Byl“ je poté možno si z číselníku zvolit příslušnou kategorii (možno vybrat z číselníku její identifikaci nebo lze do dalšího políčka napsat přímo její název)

Vzhledem k tomu, že u každé kategorie karty skladovaného artiklu lze nastavit období platnosti, lze podle tohoto období i vyfiltrovat výběr. Kategorie je možno vybírat podle těchto kritérií:

¨ platné i neplatné – tj. všechny kategorie z hlediska platnosti

¨ platné dnes – uživateli se zobrazí všechny kategorie, jejichž období platnosti od – do je aktuální pro dnešní datum

¨ neplatné dnes - uživateli se zobrazí všechny kategorie, jejichž období platnosti od – do je neaktuální pro dnešní datum

¨ platné k datu - uživateli se zobrazí všechny kategorie, jejichž období platnosti od – do je aktuální pro zadané datum, tzn. uživatel si může najít ty kategorie, které byly platné např. k 1.1.2005

¨ neplatné k datu - uživateli se zobrazí všechny kategorie, jejichž období platnosti od – do je neaktuální pro zadané datum

¨ v případě, že uživatel u jednotlivých karet využije nastavení palety barev u kategorie artiklu, lze vyhledávat i podle palety barev

¨ vyhledávat lze i podle uživatele, který majetek do systému Zapsal a podle Výběru (v případě, že má uživatel nadefinován nějaký vlastní Obecný výběr). K dispozici je výběr:

- běžný

- bezobrátkové artikly (po jeho aktivaci uživatel nejprve zadává období od – do a následně

mu systém zobrazí artikly, které v daném období neměly v událostech skladu žádný pohyb)

- nenulové množství (historický artibut. Plně nahrazen možností „nenulové“ ve výběrovém atributu množství)

3.6.7 Předlohy výstupu

Po stisku ikonky „tiskárna“ nebo po aktivaci činnosti „Tisk“ z menu Volby má uživatel k dispozici následující předlohy výstupu:

¨ Přehled artiklů – sestava typu Excel, kde má uživatel k dispozici přehled jednotlivých artiklů (závisí na zvoleném výběru na záložce „výběr“). Sestava obsahuje informace o druhu artiklu, jeho identifikaci a názvu, měrné jednotce, množství, ceně za referenční MJ a cenu celkem (tzn. množství krát cena za MJ) a zároveň cenu celkem za sestavu.

3.7 Artikly skladu – VČ

Po aktivaci této činnosti má uživatel k dispozici číselník artiklů skladu, u kterých je navíc k dispozici i informace o jejich výrobním čísle. Výrobní číslo může být samostatně pro každý artikl nebo i pro určitou skupinu artiklů (v případě uskladněného PC bude výrobní číslo vztaženo přímo ke konkrétnímu artiklu a bude pro něj jedinečné, v jiném případě může být výrobní číslo vztaženo např. třeba pro určitou šarži, tzn. že všechny artikly v dané šarži, např. množství vyrobené ten den na stejné lince, budou mít stejnou identifikaci výrobního čísla). U každého artiklu v tomto číselníku se definuje:

¨ artikl – druh, identifikace a název artiklu (po stisku pravého tlačítka myši na tučném atributu artikl jsou k dispozici další informace a události k danému artiklu)

¨ VČ – identifikace výrobního čísla. Výrobní číslo může být samostatně pro každý artikl nebo i pro určitou skupinu artiklů (v případě uskladněného PC bude výrobní číslo vztaženo přímo ke konkrétnímu artiklu a bude pro něj jedinečné, v jiném případě může být výrobní číslo vztaženo např. třeba pro určitou šarži, tzn. že všechny artikly v dané šarži, např. množství vyrobené ten den na stejné lince, budou mít stejnou identifikaci výrobního čísla).

¨ ČK – čárový kód (kód automatické identifikace). Je daný pro každý artikl. Zatímco výrobní číslo může být společné pro určité množství artiklů, čárový kód je pro každý artikl jedinečný.

¨ TVS – identifikace technicko – věcného selektoru

¨ sklad – identifikace skladu, na kterém se nachází daný artikl

¨ 1. příjem – datum prvního příjmu na sklad

¨ množství v RMJ – referenční množství artiklu, které se nachází na skladě

¨ datum – datum zápisu první události daného artiklu (může být shodné s datem 1. příjmu, ale může být i rozdílné, např. datum 1. příjmu může být 9.9., ale událost příjmu obsluha zapsala do PC až 11.9., takže u takového artiklu bude datum 1. příjmu 9.9., ale datum 11.9.)

¨ poznámka – libovolná poznámka k danému artiklu

Po stisku klávesy F6 nebo příslušnou volbou činnosti pod menu Volby si lze aktivovat „události správy artiklu“. Jedná se o události těch artiklů, které v číselníku u sebe mají nadefinovanou určitou kategorii a uživatel pak má tyto události kompletně k dispozici na jednom místě.

Pod menu Volby má uživatel k dispozici i činnost „Doplnit artikly s VČ“. Po její aktivaci systém pokládá dotaz „Opravdu doplnit artikly s výrobním číslem?“. Po potvrzení volby Ano systém projde příjmové události skladové evidence, které u sebe mají uvedeno VČ a které zároveň nejsou nadefinovány v této činnosti a založí do této činnosti novou kartu artiklu s VČ.

Pod menu Obecné má uživatel k dispozici i činnost Volné karty, která mu poskytuje podrobnější informace k dané činnosti. Jsou nadefinované tyto druhy volných karet:

¨ volná karta artiklu - informace o artiklu – sklad – po aktivaci této volné karty má uživatel k dispozici základní informace o uvedeném artiklu, tzn. jeho skladované množství, případné rezervované množství, disponibilní množství, měrnou jednotku a název artiklu. V případě, že by daný artikl měl uživatel uložen na vícero skladech, informace o množství na této volné kartě jsou uvedené celkem za všechny sklady.

3.7.1 Záložka „Výběr“

Po aktivaci činnosti „artikly skladu - VČ“ má uživatel nejprve k dispozici záložku „Výběr“, kde si může podle svých potřeb vyfiltrovat potřebnou množinu dat. Na žlutých výběrových polích je vždy možný výběr hodnot z číselníku. Je možno vybírat podle následujících atributů:

¨ druh artiklu, identifikace artiklu, název artiklu – možno využít všechny tři atributy najednou nebo každý z nich samostatně. Lze hledat podle čísla artiklu, či části jeho názvu (vyhledávání pomocí %) apod.

¨ výrobní číslo

¨ čárový kód

¨ sklad – možnost vybrat z číselníku skladů

¨ TVS – technicko – věcný selektor (možno vybrat z číselníku)

¨ množství – možnost definovat si množinu zobrazených artiklů podle jejich stavu na skladě – lze vidět vše nebo pouze nulové či nenulové množství

¨ v případě, že uživatel u jednotlivých karet využije nastavení palety barev u kategorie artiklu, lze vyhledávat i podle palety barev

3.8 Sklady

Po zadání příslušných údajů na záložce Výběr se uživateli aktivuje činnost Sklady, kde má k dispozici tyto údaje:

¨ sklad – identifikace a název skladu (ke každému skladu je možno nadefinovat přístupová práva)

¨ oceňování – zvolený způsob oceňování skladu. Možnosti jsou:

- vážený průměr - cena se zjistí jako aritmetický průměr z pořizovacích cen všech dodávek - nový průměr se zjišťuje po každém novém přírůstku určitého druhu materiálu do skladu

- metoda FIFO (first in-first out) - první do skladu, první ze skladu, tzn. ta dodávka daného druhu artiklu, která byla naskladněna jako první v určité ceně se zároveň v dané ceně jako první vydává

¨ adresát – adresát, ke kterému se sklad vztahuje (na tučném atributu adresát má uživatel po stisku pravého tlačítka myši k dispozici další informace a události daného adresáta)

¨ org. sel. – organizační selektor daného skladu (každý organizační selektor má své umístění a k tomu lze nadefinovat přístupová práva)

¨ účet. sel. – účetní selektor daného skladu (resp. číslo účtu z účetní osnovy, které se váže k danému skladu)

Ke každému skladu je možno nadefinovat přístupová práva. To se provede pomocí klávesy Ctrl B nebo volbou činnosti Přístupová práva pod menu Volby. Ke každému skladu lze pak přiřadit přístupové právo čtení nebo zápis buď skupině uživatelů nebo přímo i jednotlivým uživatelům.

Pod menu Obecné má uživatel k dispozici i činnost Volné karty, která mu poskytuje podrobnější informace k dané činnosti. Jsou nadefinované tyto druhy volných karet:

¨ volná karta adresáta - poznámka – vztahuje se přímo k adresátovi události a uživatel si na ní může uvést jakoukoliv poznámku k danému adresátovi (tuto volnou kartu a tím i poznámku k adresátovi má uživatel dostupnou i v dalších činnostech komponenty sklad, ale třeba i přímo v adresáři a dalších činnostech IS BM).

3.8.1 Buňky

Skladové buňky lze nadefinovat u každého skladu a jsou jednou z možností, jak si rozčlenit sklad na ještě menší části. V případě, že má uživatel nadefinován u příslušného skladu skladové buňky, lze veškeré pohyby skladu (činnost události skladu) a příslušné výběry zároveň členit nejen na sklad, ale i podle jednotlivých buněk (např. činnost aktuální hodnoty skladu a množství artiklu na skladech je rozčleněna až na sklad. buňky).

Každý sklad tedy může být rozdělen na úložný prostor (buňky). Nadefinované buňky jsou k dispozici na této záložce a zároveň jako samostatná činnost, kterou si může uživatel vyvolat pod menu Volby nebo po stisku klávesy F5. Každá buňka přísluší určitému skladu a uvádí se tyto atributy:

¨ buňka - identifikace skladové buňky a název skladové buňky. Identifikátor skladové buňky může být zadán strukturovaně (řada, regál, patro).

¨ čárový kód - kód automatické identifikace (např. pro automatické zakladače).

¨ umístění buňky osa X, Y, Z - možnost ještě více rozčlenit umístění v buňce (osa X-Y-Z může fungovat jako trojrozměrné zobrazení)

¨ volný text – záleží zcela na možnostech a potřebách daného zákazníka, jak tento atribut využije (může být použit např. jako další rozlišující prvek rozmístění buněk)

3.8.2 Záložka „Výběr“

Tato záložka se uživateli zobrazí jako první při aktivaci činnosti Sklady. Na žlutých výběrových polích je vždy možný výběr hodnot z číselníku. Může zde vybírat z těchto atributů:

¨ sklad - identifikace a název skladu

¨ adresát

¨ typ – možnost výběru podle zvoleného způsobu oceňování – výběr z překryvného seznamu Vše, Vážený průměr, FIFO

¨ org. sel – identifikace organizačního selektoru

¨ účet. sel. – možnost výběru i podle účetního selektoru (resp. příslušného čísla účtu z účtové osnovy)

3.8.3 Předloha výstupu

Po stisku ikonky „tiskárna“ nebo po aktivaci činnosti „Tisk“ z menu Volby má uživatel k dispozici následující předlohy výstupu:

¨ Přehled skladů – klasická sestava, která uživateli poskytuje základní informaci o skladech, které jsou nadefinované v systému IS BM. U každého skladu je k dispozici jeho identifikace, název, způsob oceňování, adresát a organizační a účetní selektor.

3.9 Základní druhy hodnot

Po aktivaci této činnosti se uživateli zobrazí tabulka s jednotlivými základními druhy hodnot, které se vztahují ke skladové evidenci.

Při zadávání hodnot si uživatel příslušné aktuální hodnoty vybírá z číselníku pomocí klávesy F2, stiskem ikony s lupou a nebo stiskem pravého tlačítka myši přímo na žlutém výběrovém políčku.

Jednotlivé druhy hodnot (nadefinované v činnosti Informační centrum - Komponenty) se přiřazují k těmto základním druhům hodnot:

¨ množství na skladě ve finančním vyjádření

¨ množství na skladě v naturálním vyjádření

¨ rezervované množství na skladě

¨ množství na skladě ve finančním vyjádření - předběžné ocenění

¨ množství na skladě v naturálním vyjádření - předběžné ocenění

¨ rezervované množství na skladě - předběžné ocenění

3.10 Přehled buněk skladu

Po zadání příslušných údajů na záložce Výběr se uživateli aktivuje vlastní činnost Přehled buněk skladu. Informace, které má uživatel u každé buňky k dispozici jsou následující:

¨ sklad – identifikace skladu, na němž se buňka nachází

¨ buňka – identifikace buňky

¨ název – vlastní název buňky

¨ čárový kód – případný kód automatické identifikace

¨ umístění buňky osy X, Y, Z – pokud je definované

¨ volný text

Na druhé záložce „Hodnoty“ jsou k dispozici u každé buňky hodnoty a artikl (druh artiklu, identifikace a název), kterého se daná hodnota týká.

3.10.1 Záložka „Výběr“

Po aktivaci činnosti Přehled buněk skladu se uživateli nejprve zobrazí tato záložka, kde si může nadefinovat tyto výběrové atributy (na žlutých výběrových polích je vždy možný výběr hodnot z číselníku):

¨ sklad – identifikace skladu (možný výběr z číselníku)

¨ buňka – identifikace a název buňky

¨ CK – čárový kód

¨ druh hodnoty – možný výběr druhu hodnoty

¨ stav buněk – lze vybrat množství nenulové, nulové a vše

3.11 Nastavení programu BM

¨ parametr Vyber_spojeni_adresata (v sekci Komponenta – SKL)

Vyber_spojeni_adresata=0

Způsobí, že při vyvolání přehledu událostí komponenty po prvém kliku na návěští adresáta nebude na výběrové záložce předplněno spojení adresáta, je-li to možné. Chování systému z hlediska spojení adresáta je pak tímto ovlivněno takto:

- při nastavení 0 po stisku pravého tlačítka myši na tučném atributu Adresát není předplněno číslo spojení

- při nastavení 1 je po stisku pravého tlačítka myši na tučném atributu Adresát předplněno číslo spojení adresáta z dané události

¨ parametr Cena_vydej (v sekci Sklad)

Cena_vydej=1

Při nastavení Cena_vydej=0 se cena celkem u záporného příjmu počítá jako množství * cena z artiklu skladu. Záporný příjem se chová jako výdej (kusy mínus).

Při nastavení Cena_vydej=1 se cena celkem u záporného příjmu počítá jako množství * cena za jednotku.Nechceme tedy u zapisování výdeje používat údaje z artiklu skladu. Nutným předpokladem je, že je nějakým způsobem vyplněná cena za jednotku (např. transformací nebo maskou).

Na kladný příjem, kladný výdej a záporný výdej nemá toto nastavení vliv.

¨ parametr CenaVC (v sekci Sklad)

CenaVC=1

Při nastavení CenaVC=1 je potom použita průměrná cena příjmů a výdejů artiklů na stejný sklad se stejným výrobním číslem.

Při nastavení CenaVC=0 (default) je potom použita průměrná cena příjmů a výdejů artiklů na stejný sklad s libovolným výrobním číslem.

¨ parametr Neparovat_FIFO (v sekci Sklad)

Neparovat_FIFO=1

Při nastavení Neparovat_FIFO=1 se neprovádí párování FIFO při vstupu události skladové evidence. Předpokládá se, že párování bude provedeno jiným způsobem.

¨ parametr Nepredplnuj (v sekci Sklad)

Nepredplnuj=1

Při zadání skladového výdeje se nepředplňuje sklad, na kterém se odpovídající artikl nachází.

¨ parametr BunkyVeFormulariPrevod (v sekci Sklad)

BunkyVeFormulariPrevod=0

Nastavení způsobí to, že se ve formuláři 'Převod mezi sklady' nebude pracovat s buňkami.

[1] Doplňující vlastnost formuláře

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 09.06.2015


Bílý Motýl

Bílý Motýl

Popis

Informační systém Bílý Motýl je koncipován jako moderní komplexní a integrovaný IS na podporu procesního a manažerského řízení v takových organizacích, které mají zájem díky informační podpoře svých aktivit získat konkurenční výhody, a to ať již úsporou nákladů či odlišením se od ostatních konkurentů zejména v komplexní kvalitě.

Viz.také

NOVÝ PROCES | IMPORT DO PROCESU | NAPOJENÍ DO PROCESU | PROCESY A OPERACE | INFORMAČNÍ CENTRUM | MARKETING | ÚČETNICTVÍ | OBCHOD | EXPEDICE | SPRAVOVANÝ MAJETEK | DPH | ODPISOVANÝ MAJETEK | PLATBY | ZÁLOHY | SKLAD | ZMĚNA STAVU PENĚZ | ODPISY A OPRAV.POL. POHLEDÁVEK | MZDY A PERSONALISTIKA | TECHNICKÁ PŘÍPRAVA VÝROBY | OBECNÁ KOMPONENTA | SYSTÉM | VÝROBA | SPUŠTĚNÍ EXTERNÍHO PŘÍKAZU | PROJEKTOVÉ ŘÍZENÍ | SKLAD ZVÍŘAT | POZEMKY

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


NOVÝ PROCES

Popis

Jedná se o skupinovou položku menu, jejíž obsah (položky menu) je uživatelsky definován dle implementace skupin procesů a druhů procesů, které mají nastaveno "Zobrazit v menu" a nejedná se o skryté procesy. Pokud zmíněné druhy procesů mají uvedenu skupinu procesů, jsou zde v ní k dispozici, pokud nejsou přímo pod položkou menu "NOVÝ PROCES".

Uživatel má možnost zde zahajovat nové procesy, pokud k tomu má právo (definuje se u druhu procesu).

Datový model

  • SPTYP Druh procesu/operace
    • SPPRISTU Přístupové právo uživatele k věci
    • SPTYPFOL Skupina procesů / předloh pro zobrazení v menu
    • SPTYPOD Druh operace v druhu procesu (alias SPTYPOD3)
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU3)

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


IMPORT DO PROCESU

Popis

Tato činnost umožňuje uživateli přímo spustit vybraný procesní import. Jednotlivé procesní importy uživatel definuje v činnosti "procesní import" v menu Informační centrum - Typy a řady.

Datový model

  • SPIMPP Procesní import
    • SPIMPD Druh importu
      • SPPRISTU Přístupové právo uživatele k věci

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


NAPOJENÍ DO PROCESU

Popis

Napojením do procesu se rozumí situace, kdy je nutné k již existujícímu fyzickému procesu zadat (vstoupit) další události (resp. operace). Možnosti napojení jsou:

¨ přes definici vyvolání (činnost Napojení do procesu)

¨ prosté nalezení procesu (činnost Procesy) - obvykle výběrem a spuštěním operace ze záložky nebo rozhodnutím výběrové vazby

¨ přes výběry - tzn. uživatel má připravenu ve svém menu činnost, která obsahuje výběr např. připravených, dosud nezahájených operací, které uživatel následně podle potřeby spouští (work-flow).

¨ spuštění operace pomocí zprávy spojené s operací

¨ referenčním procesem - v tomto případě operace spuštěná pomocí referenčního procesu není definována u druhu procesu

¨ specifická napojení - např. párování ZSP na platby za pomoci dynamického spojení operací

Datový model

  • SPTYPGO Vyvolání operace z hlavního procesu
    • SPPRISTU Přístupové právo uživatele k věci

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PROCESY A OPERACE

Popis

Jedná se pouze o hlavní menu, které v sobě sdružuje ostatní činnosti, které se týkají fyzických procesů a operací.

Viz.také

Procesy | Operace | Průběh operací | Nedokončené procesy


Procesy

Popis

Tato činnost poskytuje uživateli přehled o všech dosud zahájených (tj. spuštěných) procesech v informačním systému. Jako první je vhodné aktivovat si záložku „výběr“ (pokud uživatel nemá nastaveno její automatické spouštění v parametrech uživatele) a určit si množství zobrazených dat pomocí výběrových atributů (např. podle čísla procesu, druhu procesu, adresáta procesu, data vzniku aj.).

Uživatel má na první záložce "proces" k dispozici informace o číslu procesu, jeho stavu (stornovaný, nestornovaný), adresátu procesu, názvu, popisu, externím čísle, číselné řadě procesu a kdo proces založil. Adresátem procesu je adresát, který je uveden v úvodní operaci procesu (pozn. do operace se zapisuje, když je v uzlu procesu nastaveno „vytvořit záložku při založení procesu“).

Zajímavou položkou na záložce procesy je "aktuální hodnota semaforu procesu". Jedná se o položku, která uživateli svojí aktuální hodnotou sděluje, zda je proces z hlediska "procesního salda" ukončen. Pokud se jedná o (z nějakého důvodu) neukončený proces, je tato položka naplněna hodnotou jedna. Aby nedošlo k nějakému nedorozumění, tento proces se jeví jako neukončený proto, že některá operace v něm není dokončena (např. nedošlo k potvrzení zprávy nebo nebyla vytvořena událost vývěsky apod.). Hodnoty semaforu v procesu totiž nesledují saldokonto jako takové, ale spíše "procesní saldo", tzn. zda všechny operace a nastavené transformace v procesu proběhly tak, jak je definováno v diagramu procesu.

Kromě záložky "výběr", kterou uživatel využívá podle svých momentálních potřeb, má k dispozici ještě záložku "operace v procesu" a "operace hlavního procesu". Operace v procesu poskytují uživateli přehled všech operací, které se v daném procesu vyskytují. Operace procesu poskytují uživateli přehled operací, které předcházejí spuštění daného procesu (tzn. všech operací, jenž jsou součástí hlavního procesu). Např. u procesu výdejka může být zdrojovou operací přijatá objednávka. Důležitou záložkou je "saldokontní hodnoty procesu", která uživateli nabízí přehled všech hodnot daného procesu, které se týkají saldokonta. Druhy hodnot, které se mají v saldokontu v procesu vyskytovat se definují v činnosti druhy procesů "saldokontní hodnoty procesu".

Uživatel si může vyvoláním příslušné činnosti z menu "volby" spustit strom hlavního procesu (klávesa F6) a diagram procesu (klávesa F7). Rozdíl mezi těmito činnostmi je jednak ten, že diagram procesu zobrazuje proces graficky, ale i ten, že pokud se proces skládá i z podprocesů, činnost diagram procesu ukáže pouze diagram procesu (pokud bude aktuální proces procesem hlavním, ukáže se diagram celého procesu). Činnost strom hlavního procesu zobrazí vždy posloupnost celého hlavního procesu, ať už se tato činnost vyvolává z podprocesu nebo rovnou hlavního procesu.

Uživatel, který nemá právo k činnosti „diagram procesu“ vyvolávané z formuláře „procesy“, nemá dostupnou možnost vyvolat diagram procesu z formulářů událostí operací komponent ani ze stromu hlavního procesu.

Uživatel, který nemá právo k činnosti „strom hlavního procesu“ vyvolávané z formuláře „procesy“, nemá dostupnou možnost vyvolat strom hlavního procesu z formulářů událostí operací komponent.

V případě potřeby si uživatel přímo ze stromu či diagramu procesu může vybranou operaci spustit. Na záložce "operace procesu" si uživatel vybranou operaci může aktivovat po stisku klávesy F9. Barevně jsou od sebe odlišeny operace připravené (modré) a operace zahájené a ukončené (černé).

U jednotlivých procesů má uživatel možnost provést storno. Při stornování procesů je nutno si uvědomit, jestli se daný proces skládá pouze z operací nebo i z dalších procesů. Pokud se proces skládá pouze z operací, je možno ho okamžitě vystornovat. Pokud se však jedná o proces složený ještě z dalších procesů (v tuto chvíli jsou to spíš podprocesy), je nutno nejdříve vystornovat jednotlivé podprocesy a potom teprve hlavní proces. Pokud nebudou tzv. podprocesy vystornovány, systém hlásí chybu:"Proces není možné vystornovat, protože obsahuje odkazy na nestornované procesy". Při provádění storna uživatel tedy využije i činnost strom hlavního procesu, která mu poskytuje nejrychlejší způsob zjištění složení procesu. Při vlastním provádění storna se uživateli na obrazovce objeví nejprve hlášení o stornu procesu. Po stisku tlačítka OK se vytváří hlavička nového procesu o stornu procesu. Po stisku tlačítka ZAPSAT se objeví ještě poslední kontrolní hlášení: "Opravdu stornovat proces?" Ano/Ne. Po potvrzení volby Ano je daný proces vystornován a do stavu procesu se předplní hodnota "stornovaný". Zároveň je k danému stornovanému procesu vytvořen proces stornující.

Datový model

  • SPPRC Proces
    • SPPRISTU Přístupové právo uživatele k věci
    • SPPRCOD Operace procesu (alias SPPRCODX)
      • ADADSAT Adresát
    • SPPRC Proces (alias SPPRC2)
    • SPTYP Druh procesu/operace
      • SPCISDOK Číselná řada
    • BWUZIVAT Uživatel systému (alias BWUZIVA8)

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Výstup dokladu |
F6 | Strom hlavního procesu | Zobrazení hlavního stromu procesu-operace
F7 | Diagram procesu | Zobrazení diagramu procesu
F9 | Spustit operaci | Spuštění zobrazené operace
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Storno procesu | Storno aktuálně zobrazeného procesu
- | Výstup operace |
- | Skladba saldokontní hodnoty | Přehled skladby saldokontní hodnoty procesu
- | Průběh operací | Zobrazení přehledu změn stavu operací
F2 | Adresář | Přehled adresátů
F2 | Artikl | Seznam artiklu
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy procesů | Přehled druhů procesů
F2 | Druhy saldokontních hodnot | Druhy saldokontních hodnot procesu

    Formulář

    Formulář činnosti - Adresář
Mřížka [Seznam procesů]
Listovací rámeček
Stránka #1 Proces
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
Proces | Identifikátor druhu procesu
Název druhu procesu | Název druhu procesu
Popis | Popis procesu
Ext.č. | Externí číslo procesu
Stav | Stav procesu - Nestornovaný,Stornovaný,Stornující
Adresát | Identifikace adresáta
 | Název adresáta
Řada | Identifikátor číselné řady procesů
 | Název intervalu číselné řady procesů
Aktuální hodnota semaforu procesu | Aktuální hodnota semaforu procesu
Založil | Jméno uživatele systému
 | Datum zahájení procesu
Poznámka | Komentář k procesu
Stránka #2 Operace procesu
Mřížka [Operace dokladu]
Stránka #3 Operace hlavního procesu
Mřížka [Operace hlavního procesu]
Stránka #4 Saldokontní hodnoty procesu
Mřížka [Saldokontní hodnoty procesu]
 | Identifikace druhu saldokontní hodnoty procesu
 | Název druhu saldokontní hodnoty procesu
Hodnota | Saldokontní hodnota v procesu
Adresát | Identifikace adresáta
 | Název adresáta
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Umístění | Umístění
Skrytá | Skrytá saldokontní hodnota
Stránka #5 Výběr
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh procesu | Identifikátor druhu procesu
Adresát | Identifikace adresáta
 | Název adresáta
Popis | Popis procesu
Externí číslo | Externí číslo procesu
Datum vzniku od | Datum zahájení procesu
do | Datum vzniku procesu
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
Zapsané | Identifikace uživatele systému
Procesy s aktivním semaforem | Zobrazit procesy jejichž hodnota semaforu není nulová
Vybrat procesy spojené se zprávami | Vybrat záznamy bez ohledu na zprávy,s došlou zprávou,s odeslanou zprávou,s oběma druhy zpráv
Signalizace od | Datum signalizace zprávy od
Nepřijaté | Zobrazit nepřijaté zprávy
Přijaté | Zobrazit přijaté zprávy
Zpracované | Zobrazit zpracované zprávy
Druh saldokontní hodnoty | Identifikace druhu saldokontní hodnoty procesu
Adresát | Identifikace adresáta
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Umístění | Umístění
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Seznam procesů] činnosti - Adresář

    Mřížka [Seznam procesů] činnosti - Adresář
Označování | Označení záznamu
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh procesu | Identifikátor druhu procesu
Popis | Popis procesu
Externí číslo | Externí číslo procesu
Řada | Identifikátor číselné řady procesů
Popis | Název intervalu číselné řady procesů
Uživatel | Jméno uživatele systému
Vznik procesu | Datum zahájení procesu
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
Adresát | Identifikace adresáta
Název adresáta | Název adresáta

    Mřížka [Operace dokladu] činnosti - Adresář

    Mřížka [Operace dokladu] činnosti - Adresář
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Komponenta | Identifikace komponenty
Druh operace | Identifikátor druhu operace
 | Název druhu procesu
Zahájení operace | Datum zahájení operace
Ukončení operace | Datum ukončení operace
Referenční identifikace | Referenční identifikace operace

    Mřížka [Operace hlavního procesu] činnosti - Adresář

    Mřížka [Operace hlavního procesu] činnosti - Adresář
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Komponenta | Identifikace komponenty
Druh | Identifikátor druhu operace
Název druhu operace | Název druhu operace
Zahájení operace | Datum zahájení operace
Uživatel | Jméno uživatele systému

    Mřížka [Saldokontní hodnoty procesu] činnosti - Adresář

    Mřížka [Saldokontní hodnoty procesu] činnosti - Adresář
Druh | Identifikace druhu saldokontní hodnoty procesu
Adresát | Identifikace adresáta
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Umístění | Umístění
Hodnota procesu | Saldokontní hodnota v procesu

    Atributy tisku

    Základní údaje
Rok | Rok v identifikaci procesu | SPPRC_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | SPPRC_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | SPPRC_sp33cisd | C(8)
Druh procesu | Identifikátor druhu procesu | SPPRC_sp07idtypd | C(6)
Popis | Popis procesu | SPPRC_sp33text | C(30)
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující | Výpočet | C(12)
Externí číslo | Externí číslo procesu | SPPRC_sp33extcis | C(15)
Poznámka | Komentář k procesu | SPPRC_sp33koment | M
Rok | Rok řady čísla procesu - předcházejícího procesu | SPPRC_sp33cisdro | C(4)
IDÚ | Identifikace datového úložiště v čísle procesu - předcházejícího procesu | SPPRC_sp33cisdpo | C(2)
Číslo procesu | Číslo procesu - předcházejícího procesu | SPPRC_sp33cisdo | C(8)
Druh procesu | Identifikátor druhu procesu - předcházejícího procesu | SPPRC_sp07idtypo | C(6)
Popis | Popis procesu | SPPRC2_sp33text | C(30)

    Při pohybu v Událost procesu
Rok | Rok v identifikaci procesu | SPPOHZDR_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | SPPOHZDR_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | SPPOHZDR_sp33cisd | C(8)
Druh operace | Identifikátor druhu operace | SPPOHZDR_sp07idtyp | C(6)
Komponenta | Identifikace komponenty | SPPOHZDR_sp06idsubs | C(3)
Pořadí | Pořadí stejného druhu operace v jednom procesu | SPPOHZDR_sp33porad | N(2)
Název druhu operace | Název druhu procesu | SPPOHZDR_sp07text | C(30)
Referenční identifikace | Referenční identifikace operace | SPPOHZDR_sp34frefid | C(40)
Operace připravena | Operace je připravena ke spuštění | Výpočet | C(3)
Zahájena | Operace zahájena | Výpočet | C(3)
Zahájení operace | Datum zahájení operace | SPPOHZDR_sp34datzac | T
Ukončena | Operace ukončena | Výpočet | C(3)
Ukončení operace | Datum ukončení operace | SPPOHZDR_sp34datkon | T

    Viz.také

    Výstup dokladu | Strom hlavního procesu | Diagram procesu | Spustit operaci | OZNAČOVÁNÍ | Storno procesu | Výstup operace | Skladba saldokontní hodnoty | Průběh operací | Adresář | Artikl | Druhy artiklů | Druhy procesů | Druhy saldokontních hodnot


Operace

Popis

Uživateli se zobrazuje přehled fyzických operací, které byly dosud v rámci procesů spuštěny. Uživatel má možnost si pomocí definice záložky "výběr" zvolit, které operace bude mít na obrazovce zobrazeny. U každé operace se navíc zobrazuje příznak, zda je připravena, zahájena, ukončena nebo předběžně ukončena. Mezi časté filtry může patřit zobrazení nedokončených operací, tzn., že operace je připravena, zahájena, ale není dosud ukončena.

Po načtení záložky „výběr“ má uživatel k dispozici základní informace týkající se vybraných operací. U každé operace je k dispozici její číslo, adresát operace, popis, externí číslo, případně externí identifikace a hlavně časové údaje (typu datum-čas-uživatel) o zahájení a ukončení operace.

Záložka "operace hlavního procesu" poskytuje uživateli informace o všech operacích procesu, jehož je daná fyzická operace součástí. Navíc barevným odlišením je možno rozlišit operace připravené (modré) nebo zahájené či ukončené (černé).

Záložka "saldokontní hodnoty procesu" podává uživateli informaci o tom, v jakém stavu jsou určité druhy saldokontních hodnot navázané na konkrétní proces, např. výši neuhrazeného závazku, množství materiálu na skladě apod. Pod menu Volby má uživatel navíc možnost aktivovat činnost "skladba saldokontní hodnoty", kde se mu podrobně zobrazuje z jakých údajů je daná saldokontní hodnota složena.

Na záložce "fyzická operace" má uživatel pod menu Volby k dispozici tyto činnosti:

¨ výstup operace (klávesa F5)

¨ strom hlavního procesu - lze ho vyvolat z každé operace, zobrazuje v jaké části procesu se uživatel právě nachází, která operace již byla ukončena, kterou je třeba zahájit apod. (klávesa F6)

¨ diagram procesu - grafické zobrazení složení procesu. Uživatel vidí nejenom skladbu procesu, ale má možnost podívat se i na vlastnosti operací a na jednotlivé transformace mezi nimi (klávesa F7).

¨ spustit operaci - touto činností je možno zahájit připravenou operaci nebo opakovaně spustit operaci již zahájenou či ukončenou (klávesa F9).

¨ spustit označené operace - označené operace se po aktivaci této činnosti přetáhnou do zásobníku (menu Obecné), kde se první operace spouští na pozadí a další spouští uživatel. Pokud se jedná o operace již ukončené a uživatel pouze potřebuje vytisknout doklad, běží tyto operace zcela automaticky a pouze se tisknou příslušné doklady.

Datový model

  • SPPRCOD Operace procesu
    • SPTYP Druh procesu/operace
      • SPPRISTU Přístupové právo uživatele k věci
    • BWUZIVAT Uživatel systému
    • BWUZIVAT Uživatel systému (alias BWUZIVA3)
    • SPPRCODE Externí primární označení operace
    • SPPRC Proces
      • SPTYP Druh procesu/operace (alias SPTYP4)
    • ADADSAT Adresát

    • Formulář

    Formulář činnosti - Dávkové operace události
Mřížka [Fyzické operace]
Listovací rámeček
Stránka #1 Fyzická operace
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
 | Identifikace komponenty
 | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Název druhu operace
 | Datum změny stavu operace
Externí ID | Externí identifikace operace
Neaktuální | Příznak neaktuální operace
Zahájení | Datum zahájení operace
 | Jméno uživatele systému
Ukončení | Datum ukončení operace
 | Jméno uživatele systému
Připravena | Operace je připravena ke spuštění
Zahájena | Operace zahájena
Ukončena | Operace ukončena
Předb.ukon. | Operace ukončena předběžně
Proces | Identifikátor druhu procesu
Název druhu procesu | Název druhu procesu
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
Popis | Popis procesu
Ext.č. | Externí číslo procesu
 | Datum zahájení procesu
Referenční identifikace | Referenční identifikace operace
Adresát | Identifikace adresáta
Umístění | Umístění
 | Název adresáta
Stránka #2 Operace hlavního procesu
Mřížka [Operace hlavního procesu]
Stránka #3 Saldokontní hodnoty procesu
Mřížka [Saldokontní hodnoty procesu]
 | Identifikace druhu saldokontní hodnoty procesu
 | Název druhu saldokontní hodnoty procesu
Hodnota | Saldokontní hodnota v procesu
Adresát | Identifikace adresáta
 | Název adresáta
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Umístění | Umístění
Skrytá | Skrytá saldokontní hodnota
Stránka #4 Výběr
Komponenta | Identifikace komponenty
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Zobrazit | Zobrazit operace
 | Zobrazit všechny nebo aktuální nebo neaktuální operace
 | Identifikace uživatele systému
Druh procesu | Identifikátor druhu procesu
Ext.č. | Externí číslo procesu
Popis | Popis procesu
Vznik procesu | Datum zahájení procesu
 | Datum vzniku procesu
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
Zapsané | Identifikace uživatele systému
Řada oper. | Identifikace řady operace
Umístění | Umístění
Číslo op. | Číslo operace
Adresát oper. | Identifikace adresáta
 | Název adresáta
Změna stavu | Datum a čas změny stavu operace
 | Datum a čas aktivity operace do
 | Došlé, odeslané, všechny
Signalizace od | Datum signalizace zprávy od
Nepřijaté | Zobrazit nepřijaté zprávy
Přijaté | Zobrazit přijaté zprávy
Zpracované | Zobrazit zpracované zprávy
Druh saldokontní hodnoty | Identifikace druhu saldokontní hodnoty procesu
Adresát | Identifikace adresáta
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Umístění | Umístění
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Fyzické operace] činnosti - Dávkové operace události

    Mřížka [Fyzické operace] činnosti - Dávkové operace události
Označování | Označení záznamu
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Komponenta | Identifikace komponenty
Druh | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
Název druhu operace | Název druhu procesu
Zahájení operace | Datum zahájení operace
Uživatel | Jméno uživatele systému
Ukončení operace | Datum ukončení operace
Uživatel | Jméno uživatele systému
Připravena | Operace je připravena ke spuštění
Ukončena | Operace ukončena
Vznik procesu | Datum zahájení procesu
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Umístění | Umístění
Číslo op. | Číslo operace
Změna stavu | Datum změny stavu operace
Externí číslo procesu | Externí číslo procesu
Popis procesu | Popis procesu

    Mřížka [Operace hlavního procesu] činnosti - Dávkové operace události

    Mřížka [Operace hlavního procesu] činnosti - Dávkové operace události
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Komponenta | Identifikace komponenty
Druh | Identifikátor druhu operace
Název druhu operace | Název druhu operace
Zahájení operace | Datum zahájení operace
Uživatel | Jméno uživatele systému

    Mřížka [Saldokontní hodnoty procesu] činnosti - Dávkové operace události

    Mřížka [Saldokontní hodnoty procesu] činnosti - Dávkové operace události
Druh | Identifikace druhu saldokontní hodnoty procesu
Adresát | Identifikace adresáta
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Umístění | Umístění
Hodnota procesu | Saldokontní hodnota v procesu

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Výstup operace |
F6 | Strom hlavního procesu | Zobrazení hlavního stromu procesu-operace
F7 | Diagram procesu | Zobrazení diagramu procesu
F9 | Spustit operaci | Spuštění zobrazené operace
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Průběh operací | Zobrazení přehledu změn stavu operací
- | Skladba saldokontní hodnoty | Přehled skladby saldokontní hodnoty procesu
- | Spustit označené operace | Spustit označené operace
- | Události označených operací | Zobrazit události označených operací
F2 | Adresář | Přehled adresátů
F2 | Artikl | Seznam artiklu
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Druhy saldokontních hodnot | Druhy saldokontních hodnot procesu

    Atributy tisku

    Základní údaje
Rok | Rok v identifikaci procesu | SPPRCOD_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | SPPRCOD_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | SPPRCOD_sp33cisd | C(8)
Druh operace | Identifikátor druhu operace | SPPRCOD_sp07idtyp | C(6)
Komponenta | Identifikace komponenty | SPPRCOD_sp06idsubs | C(3)
Pořadí | Pořadí stejného druhu operace v jednom procesu | SPPRCOD_sp33porad | N(2)
Název druhu operace | Název druhu operace | SPTYP_sp07text | C(30)
Druh procesu | Identifikátor druhu procesu | SPPRC_sp07idtypd | C(6)
Vznik procesu | Datum zahájení procesu | SPPRC_sp33datum | T
Popis | Popis procesu | SPPRC_sp33text | C(30)
Externí číslo | Externí číslo procesu | SPPRC_sp33extcis | C(15)
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující | Výpočet | C(12)
Poznámka | Komentář k procesu | SPPRC_sp33koment | M
Název druhu procesu | Název druhu procesu | SPTYP4_sp07text | C(30)
Kořenová operace procesu | Kořenová operace procesu | SPPRCOD_sp34main | N(1)
Zahájení operace | Datum zahájení operace | SPPRCOD_sp34datzac | T
Ukončení operace | Datum ukončení operace | SPPRCOD_sp34datkon | T
Uživatel | Jméno uživatele systému | BWUZIVA3_bw01jmeno | C(30)
Změna stavu | Datum změny stavu operace | SPPRCOD_sp34datzms | T
Operace připravena | Operace je připravena ke spuštění | Výpočet | C(3)
Zahájena | Operace zahájena | Výpočet | C(3)
Ukončena | Operace ukončena | Výpočet | C(3)
Předb.ukon. | Operace ukončena předběžně | Výpočet | C(3)
Umístění | Umístění | SPPRCOD_sp34umiste | C(6)
Právo násl. podle | Typ práva přístupu | SPPRCOD_sp44typ | C(3)
Skupina | Identifikace skupiny uživatelů | SPPRCOD_bw05ident | C(6)
MPV | Identifikace metapředlohy výstupu | SPPRCOD_bw81id | C(6)
Adresát | Identifikace adresáta | SPPRCOD_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)

    Viz.také

    Výstup operace | Strom hlavního procesu | Diagram procesu | Spustit operaci | OZNAČOVÁNÍ | Průběh operací | Skladba saldokontní hodnoty | Spustit označené operace | Události označených operací | Adresář | Artikl | Druhy artiklů | Druhy operací | Druhy procesů | Druhy saldokontních hodnot | Dávkové operace události | Spojené dokumenty


Průběh operací

Popis

Průběh operací (zobrazuje uzly typu operace i uzly typu proces, pokud jsou ve stavu připravena) je činnost, kde uživatel má k dispozici přehled těch uzlů, u kterých došlo od okamžiku jeho přihlášení do IS a jeho přičiněním ke změně jejich stavu, prohlížení uzlů zde zachyceno není. Průběh operací je v každé činnosti v IS dostupný v menu Obecné. Uživatel má k dispozici tyto údaje:

¨ datum

¨ identifikace operace

¨ název druhu

¨ stav (tzn. připravena, zahájena, ukončena apod.)

Formulář

Formulář činnosti - Strom hlavního procesu
Mřížka [Průběh operací]

Mřížka [Průběh operací] činnosti - Strom hlavního procesu

Mřížka [Průběh operací] činnosti - Strom hlavního procesu
Datum | Datum vzniku zápisu
Operace | Identifikace operace
Název druhu | Název druhu operace
Stav | Stav operace

Vyvolávané činnosti

K. | Činnost | Popis
F6 | Strom hlavního procesu | Zobrazení hlavního stromu procesu-operace
F7 | Diagram procesu | Zobrazení diagramu procesu
F9 | Spustit operaci | Spuštění zobrazené operace

Viz.také

Strom hlavního procesu | Diagram procesu | Spustit operaci


Nedokončené procesy

Popis

Uživateli se zobrazují jednotlivé procesy, které nemají vyrovnané saldokonto k určitému druhu hodnoty.

Může se rovněž stát, že druh hodnoty v procesu je vyrovnán a přesto je proces zařazen mezi neukončené procesy. Tato situace může nastat tehdy, pokud u jednotlivých hodnot jednoho procesu nesouhlasí položky jako adresát, artikl nebo umístění.

Pokud se stane, že uživatel omylem u saldokontní hodnoty procesu zadá chybného adresáta a proces se proto řadí mezi nedokončené, je možno provést ruční potvrzení hodnot v procesu (uživatel si v podstatě odsouhlasí, že adresát je chybný) a v procesu se vyrovná saldokonto a systém ho odstraní z nedokončených procesů. Odsouhlasení "chybné" hodnoty uživatel provede tak, že u takovéto hodnoty daného procesu zatrhne příznak "skrytá".

U každého nedokončeného procesu je možno po stisku odpovídající záložky zobrazit přehled operací procesu.

Datový model

  • SPPRCSAL Saldokontní hodnota procesu
    • SPPRC Proces
      • SPTYP Druh procesu/operace
        • SPPRISTU Přístupové právo uživatele k věci
      • BWUZIVAT Uživatel systému
    • SPSTATDS Druh saldokontní hodnoty procesu
    • ADADSAT Adresát
    • SPARTIKN Název artiklu

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Skladba saldokontní hodnoty | Přehled skladby saldokontní hodnoty procesu
F6 | Strom hlavního procesu | Zobrazení hlavního stromu procesu-operace
F7 | Diagram procesu | Zobrazení diagramu procesu
F9 | Spustit operaci | Spuštění zobrazené operace
F2 | Adresář | Přehled adresátů
F2 | Artikl | Seznam artiklu
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy procesů | Přehled druhů procesů
F2 | Druhy saldokontních hodnot | Druhy saldokontních hodnot procesu

    Formulář

    Formulář činnosti - Druhy procesů
Mřížka [Nedokončené procesy]
Listovací rámeček
Stránka #1 Nedokončené procesy
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
 | Identifikátor druhu procesu
 | Stav procesu - Nestornovaný,Stornovaný,Stornující
 | Popis procesu
Ext.č. | Externí číslo procesu
 | Komentář k procesu
 | Jméno uživatele systému
 | Datum zahájení procesu
 | Identifikace druhu saldokontní hodnoty procesu
 | Název druhu saldokontní hodnoty procesu
Skrytá | Skrytá saldokontní hodnota
Hodnota | Saldokontní hodnota v procesu
Adresát | Identifikace adresáta
 | Název adresáta
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Umístění | Umístění
Stránka #2 Operace procesu
Mřížka [Operace dokladu]
Stránka #3 Výběr
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
 | Identifikátor druhu procesu
 | Popis procesu
Ext.č. | Externí číslo procesu
Vznik | Datum zahájení procesu
do | Datum vzniku procesu
Uživatel | Identifikace uživatele systému
Druh | Identifikace druhu saldokontní hodnoty procesu
Adresát | Identifikace adresáta
 | Název adresáta
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Umístění | Umístění
 | Zobrazit skryté,neskryté nebo všechny saldokontní hodnoty procesu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Nedokončené procesy] činnosti - Druhy procesů

    Mřížka [Nedokončené procesy] činnosti - Druhy procesů
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh procesu | Identifikátor druhu procesu
Popis | Popis procesu
Vznik procesu | Datum zahájení procesu
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
Druh | Identifikace druhu saldokontní hodnoty procesu
Adresát | Identifikace adresáta
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Umístění | Umístění

    Mřížka [Operace dokladu] činnosti - Druhy procesů

    Mřížka [Operace dokladu] činnosti - Druhy procesů
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Komponenta | Identifikace komponenty
Druh operace | Identifikátor druhu operace
 | Název druhu procesu
Zahájení operace | Datum zahájení operace
Ukončení operace | Datum ukončení operace
Referenční identifikace | Referenční identifikace operace

    Atributy tisku

    Základní údaje
Rok | Rok v identifikaci procesu | SPPRC_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | SPPRC_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | SPPRC_sp33cisd | C(8)
Druh procesu | Identifikátor druhu procesu | SPPRC_sp07idtypd | C(6)
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující | Výpočet | C(12)
Popis | Popis procesu | SPPRC_sp33text | C(30)
Externí číslo | Externí číslo procesu | SPPRC_sp33extcis | C(15)
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Vznik procesu | Datum zahájení procesu | SPPRC_sp33datum | T
Poznámka | Komentář k procesu | SPPRC_sp33koment | M
Skrytá saldokontní hodnota | Skrytá saldokontní hodnota | Výpočet | C(3)
Druh | Identifikace druhu saldokontní hodnoty procesu | SPPRCSAL_sp69id | C(6)
Název druhu | Název druhu saldokontní hodnoty procesu | SPSTATDS_sp69drusal | C(40)
Adresát | Identifikace adresáta | SPPRCSAL_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Druh artiklu | Identifikace druhu artiklu | SPPRCSAL_sp61id | C(3)
Artikl | Identifikace artiklu | SPPRCSAL_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Umístění | Umístění | SPPRCSAL_sp74id | C(6)
Hodnota procesu | Saldokontní hodnota v procesu | SPPRCSAL_sp74hodnot | N(20,4)

    Viz.také

    Skladba saldokontní hodnoty | Strom hlavního procesu | Diagram procesu | Spustit operaci | Adresář | Artikl | Druhy artiklů | Druhy procesů | Druhy saldokontních hodnot


INFORMAČNÍ CENTRUM

Popis

Toto menu zahrnuje veškeré komponenty, které slouží jako určitý zdroj informací, a které uživatel využívá při práci se všemi komponentami informačního systému BM. Jsou to:

¨ selektory a číselníky

¨ typy a řady

¨ import/export

¨ statistika

Viz.také

TYPY A ŘADY | SPRÁVA ARTIKLU | SELEKTORY A ČÍSELNÍKY | IMPORT / EXPORT | STATISTIKA | OCEŇOVÁNÍ | VÝKAZY | ALGORITMY A PARAMETRY | INFORMAČNÍ PANELY | OBECNÉ STROMY | APLIKACE | UTILITY


TYPY A ŘADY

Popis

Tato činnost v sobě sdružuje činnosti, které přímo souvisí se zadáváním, aktualizací a údržbou jednotlivých činností, a které se využívají při vlastní práci v informačním systému BM. Každá z těchto činností je dále vysvětlena v samostatném helpu.

Viz.také

Druhy procesů | Druhy operací | Typy událostí komponent | Komponenty | Otevřená období komponent | Číselné řady | Korektory transformovaných dat | Druhy volných karet | Definice vyvolání | Prezentace procesů | DYNAMICKÁ SPOJENÍ OPERACÍ | Volné texty | Konstanty | Procesní importy | Obecné předkontace | Externí příkazy | Doplňující vlastnosti formuláře | Doplňující položky menu objektů | Knihovny vkládaného kódu | Mapa přístupových práv | Obecné kalendáře | BM-funkce pro SQL | Pravidla inicializací přístupových práv | Parametry polí formulářů | Systémové certifikáty


Druhy procesů

Popis

V informačním systému BM jsou procesy, které jsou si podobné (blízké) modelovány druhem procesu. Procesy stejného druhu mají řadu shodných vlastností, které jsou v definici druhu zachyceny, např. transformace, masky,…apod. Nastavením těchto vlastností se rozhoduje o vlastnostech všech procesů daného druhu, které budou v informačním systému evidovány.

V této činnosti má uživatel k dispozici veškeré informace o již nadefinovaných procesech a navíc má možnost si v případě potřeby založit proces nový. K dispozici jsou tyto údaje:

¨ druh procesu - jednoznačná identifikace procesu a jeho stručný (ale výstižný) název

¨ řada - identifikátor číselné řady procesu a název intervalu číselné řady. Při zahájení procesu ještě není číslo procesu definováno, systém procesu přiřadí číslo teprve až po ukončení první operace v procesu. Číslo procesu se pak skládá z roku/identifikace datového úložiště/pořadového čísla (tj. čísla odvozeného od nadefinované číselné řady pro daný proces)

¨ skupina - identifikace skupiny procesu. Skupiny procesů se definují pouze v této činnosti po stisku klávesy F2 nebo ikony výběr. Možnost definice skupin slouží uživatelům pro zjednodušení menu, které se mu nabízí po spuštění činnosti "nový proces". Zde se uživatelům nabízely všechny dosud spuštěné procesy. Protože by mohla nastat situace, kdy by se časem toto menu příliš naplnilo, je vhodnější např. procesy jednotlivých komponent sdružit do určité skupiny. Při spuštění činnosti "nový proces" se pak budou uživatelům nabízet nejprve skupiny procesů, ze kterých si dvojklikem nebo stiskem klávesy Enter vybraný proces spustí.

¨ korektor - korektor je možné nadefinovat ke každému druhu procesu a úzce souvisí s formátem ISDOC. Korektor představuje definici kódu v jazyce FoxPro, který je spouštěn v rámci zpracování fyzického procesu v okamžiku po provedení všech transformací do operace těsně před tím, než jsou data předplněná transformací zobrazena uživateli ve formuláři operace.

¨ metapředloha - pokud je daný proces spojen s tiskem určitého dokladu (např. faktura, příkaz k úhradě, prodej za hotové), je nutno v této položce uvést název metapředlohy tiskové sestavy (u druhu operace v diagramu procesu, kde se pak má tato metapředloha tisknout, je ve vlastnostech uzlu operace nutno zaškrtnout „po ukončení operace tisk dokladu“).

¨ implicitně spouštět:

- automaticky - zatržením tohoto příznaku se jednotlivé operace v procesu budou ukončovat a zahajovat automaticky. Pokud tento příznak zatržen nebude, musí uživatel každou operaci v procesu ukončit vyvoláním činnosti z menu "volby". Teprve po "ručním" ukončení operace může být následující operace zahájena.

- na pozadí - většinou se tento příznak nastavuje u tzv. procesů v procesu (tj. podprocesů). Znamená to, že tento podproces pak probíhá v rámci procesu na pozadí - uživatel jeho vlastní průběh nevidí. Např. při procesu prodej, může vyskladnění a jeho zaúčtování běžet na pozadí. Uživatel pak vstupuje objednávku, na pozadí proběhne vyskladnění, jeho zaúčtování a vstupuje se zase až při vytváření faktury.

- nespouštět - tento příznak uživatel rovněž využije nejvíce u podprocesů, např. u procesu prodej, který se bude skládat ze samostatných procesů faktura a výpis z banky. Protože mezi fakturací a výpisem z banky je určitá časová prodleva, uživatel počká, až přijde výpis z banky a potom ručním spuštěním podprocesu výpis z banky dokončí celý proces prodej.

¨ použití

- zobrazovat v menu - pokud je zadána tato možnost, název procesu se zobrazuje v menu (tj. přehledu všech dosud vytvořených procesů). Pokud uživatel zadá nezobrazovat v menu, proces se v přehledu procesů nezobrazuje. Tuto možnost využije uživatel zejména pokud definuje složitější proces, který se skládá nejen z operací, ale i z dalších procesů. Potom tuto možnost zadá pouze u vrcholného procesu a u procesů, které jsou součástí tohoto vrcholného procesu, tuto možnost zadávat nebude.

- nezobrazovat v menu - zadá se u procesů, které uživatel nechce mít v hlavní nabídce

- referenční proces - jedná se o proces (o jedné nebo více operacích), který je možno napojit na jakoukoliv jinou operaci, která se používá v ostatních procesech. Z této operace je pak možno referenční proces spustit opakovaně několikrát. Např. budeme mít operaci účetní zápis. K této operaci vytvoříme referenční proces opravný účetní zápis. Potom si v přehledu operací najdeme právě operace účetní zápis, přes strom hlavního procesu je znovu spustíme a potom se v menu Obecné nabízí možnost napojení opravného účetního zápisu. Systém pak ještě pokládá kontrolní dotaz, zda opravdu chceme opravný účetní zápis napojit na danou operaci. Takovým způsobem lze v podstatě opravit jakýkoliv účetní zápis a to i opakovaně. Referenční proces se dá využít např. i u fakturace, kdy budeme mít možnost ke každé zadané faktuře vytvořit dobropis.

¨ test mírou plnění - možnost vybrat z překryvného seznamu, zda se při ukončení operace daného druhu procesu má informovat uživatel, že očekávané události nenastaly v plné míře (tzn. výsledek testu mírou plnění je negativní).

¨ skrytý druh procesu - tuto možnost uživatel využije např. u procesu, který v současné době již není aktuální nebo se přestal používat v praxi

¨ založil - informace o uživateli, který proces založil + datum a čas jeho založení

¨ poznámka - není povinný údaj. Jedná se o krátkou poznámku k procesu, např. možnosti jeho využití nebo naopak případy, ve kterých není vhodné tento proces používat.

V činnosti Druhy procesů má uživatel k dispozici celou řadu záložek, které obsahují doplňující informace k druhu procesu. Na záložce „Další"se definuje:

¨ karta – možnost nadefinovat si volnou kartu, která se vztahuje k danému procesu, tj. ze které lze transformovat (její atributy lze užít jako výstupní atributy komponenty), případně ji automaticky vyvolat při ukončení určité operace (po ukončení vstup volné karty procesu)

¨ nastavení volby „předplňovat - opakovat vstup", což znamená, že volba „opakovat vstup" před zápisem událostí první operace při spuštění procesu z menu Nový proces bude implicitně zaškrtnuta.

¨ výraz popisu procesu - výraz pro předplnění popisu procesu podle operace zahajující proces

¨ výraz externí identifikace procesu - výraz pro předplnění externí identifikace procesu podle operace zahajující proces

¨ výraz poznámky procesu – výraz nebo skript v jazyce Foxpro, na základě jehož vyhodnocení je předplňován text komentáře nově zakládaného procesu. Skript je možno definovat po stisku pravého tlačítka myši na daném atributu a jeho text musí být uveden slovem SCRIPT (stejné platí pro „výraz popisu procesu“ a „výraz externí identifikace procesu“). V kódu skriptu je možno se odkazovat na tyto proměnné:

- _THIS - řídící objekt operace (např. pro využití jeho atributů _THIS.SP33CISDRO, _THIS.SP33CISDPO, _THIS.SP33CISDO ...)

- _ALIAS - alias kurzoru, ve kterém se nacházejí informace pro vytvoření popisu

Přiklad:

<pre>

SCRIPT

LOCAL _sp33text

_sp33text=tool.sql_dotaz([select sp33text from %%%.spprc where sp33cisdr=?_p1 and sp33cisdpm=?_p2 and sp33cisd=?_p3],;

_this.sp33cisdro, _this.sp33cisdpo, _this.sp33cisdo)

RETURN _sp33text

</pre>

Na formuláři se jako další uživateli nabízí záložka "výskyt procesu". Zobrazí se tabulka, ve které je zapsán název druhu procesu, ve kterém se aktuální proces vyskytuje. V případě potřeby je možno i u tohoto procesu zobrazit jeho diagram (menu Volby nebo klávesa F7).

Před vysvětlením záložky "hodnoty procesu" (týká se saldokontních hodnot) je nutno si nejprve ujasnit pojem HLAVNÍ PROCES. Nejlépe si tento pojem vysvětlíme na konkrétním případu. Např. proces "prodej" se skládá z několika operací a podprocesů (výdejka, faktura ....), které v případě potřeby mohou běžet i jako samostatné hlavní procesy. Proces "prodej" je ale v tuto chvíli "hlavním procesem". Pod záložkou hodnoty procesu uživatel zadává druhy hodnot (vztahující se k operacím, které jsou součástí daného procesu), které vytváří saldokontní hodnoty. Neboli u tohoto hlavního procesu definuje, které operace vytváří které saldokontní hodnoty. V tuto chvíli je však nutné, aby si uživatel uvědomil, že tyto hodnoty jsou nadefinovány pouze pro hlavní proces (např. prodej). V případě, že se hlavní proces skládá z podprocesů (např. výdejka, faktura, výpis z banky ...), které jsou schopny fungovat i samostatně, se tyto hodnoty k nim v tuto chvíli nevztahují. Nadefinované saldokontní hodnoty skutečně platí právě jen tehdy, pokud je spuštěn právě hlavní proces. Pokud uživatel potřebuje znát saldokontní údaje samostatně i za jednotlivé podprocesy, musí saldokontní hodnoty nadefinovat u každého podprocesu zvlášť (uživatel si v přehledu druhu procesů najde vybraný podproces a přepnutím se na záložku "hodnoty procesu" nadefinuje potřebné údaje). U každé hodnoty se vyplňuje název komponenty, druh operace, druh hodnoty a příznak, zda je v tu chvíli jisté, že se jedná čistě o příjem (+), výdej (-) nebo to může být kombinace obou (PV) a systém pak sám podle dalších příznaků rozlišuje, zda se jedná právě o příjem nebo o výdej. Např. jednou se může podle druhu operace jednat o příjemku, jindy stejná operace může být výdejka, proto je nutné nastavení příznaku PV.

Nastavení saldokontních hodnot u hlavního procesu v této činnosti je výhodné z hlediska jejich definování. Uživatel má na výběr hodnoty u operací všech komponent, tzn. že si na jednom místě nadefinuje vše, co v daném procesu chce sledovat. Zde nadefinované hodnoty se pak nadále zobrazují pouze na záložce „hodnoty procesu“ v činnosti Druhy operací (jinými slovy, v této činnosti si uživatel saldokontní hodnoty pouze nadefinuje, k prohlížení je ale pak má k dispozici jinde).

Záložka „Popisné info“ umožňuje definovat několik záznamů popisné informace spojené s druhem procesu:

¨ Význam - identifikátor významu položky obecné předkontace - součást primárního klíče

¨ Volný text - identifikátor volného textu

¨ Kód - kód v jazyce Foxpro

¨ Datum 1 - datum

¨ Datum 2 - datum

¨ Text 1 - text

¨ Text 2 - text

¨ Num1 - číslo

¨ Num2 - číslo

¨ Poznámka

Knihovna SYSPDF, která se používá při tisku dokladů procesů do souborů PDF a ISDOC, používá 'Popisné informace' uvedené u tištěného druhu procesu pro sestavení emailu. Používá 'Popisné informace' s těmito významy:

EMAIL1 - určení Příjemce zprávy

EMAIL2 - určení Předmětu zprávy

EMAIL3 - určení Textu zprávy

Příklad popisné informace významu EMAIL3:

'Volný text' definuje text:

<pre>

Fakturujeme Vám:<br>

Faktura číslo: <<spprc_sp33cisdr>>-<<spprc_sp33cisdpm>>-<<spprc_sp33cisd>><br>

VS: <b><i><<alltrim(pluda_pl02vs)>></i></b><br>

Cena: <b><<alltrim(trans(pluda_pl02czm,'999 999 999.99'))>></b><br>

<br>

<br>

<h5>Seznam dodaného zboží:</h5>

<br>

##TABLE##

<br>

</pre>

'Kód' obsahuje kód v jazyce Foxpro:

<pre>

* Knihovna SYSPDF volá tento kód s parametry:

* _THIS = objekt, který provádí výstup do PDF

* _RIDIC = řídící objekt tisku

* _SP89OBSAH = text Volného textu

* _DATA = objekt s atributu záznamu 'Popisné informace' mj. _DATA.SPH0DAT1, _DATA.SPH0DAT2, _DATA.SPH0TEXT1, _DATA.SPH0TEXT2, _DATA.SPH0NUM1, _DATA.SPH0NUM2

*

Local _rt,_err,_chb,_txt

Select sql_tisk

Locate All For sppohzdr_sp06idsubs='PLA'

If !Found()

Return _sp89obsah

Endif

Try

_rt=Textmerge(_sp89obsah)

_chb=.F.

Catch To _err

_rt=_err.Message+Chr(13)+Chr(10)+_sp89obsah

_chb=.T.

Endtry

If _chb

Return _rt

Endif

_txt='<table border cellspacing="0" ><tr><th>Popis zboží</th><th>Množství</th></tr>'

Select sql_tisk

Scan All For sppohzdr_sp06idsubs='OBC'

_txt=_txt+'<tr><td>'+Alltrim(obudal_ob02text)+'</td><td style="text-align:right">'+Trans(obudal_ob02mn)+'</td></tr>'

Endscan

_txt=_txt+'</table>'

Go Top In sql_tisk

Return Strtran(_rt,'##TABLE##',_txt,1,1,1)

</pre>

V každé komponentě, se kterou uživatel pracuje v rámci procesu, si volbou příslušné činnosti z menu "volby" může vyvolat tzv. "strom hlavního procesu". Uživateli se na obrazovce objeví celá definice procesu a navíc vždy je jednotlivými značkami vyznačeno místo, na kterém se uživatel v rámci procesu nachází. Tato činnost uživateli umožňuje snadnou a rychlou orientaci při práci s procesy.

Při definování nového procesu je nutno k tomuto procesu přiřadit přístupová práva (tj. činnost "přístupy k procesům a operacím"). Definováním přístupových práv k jednotlivým procesům se např. zamezí tomu, aby se fakturantce zbytečně nezobrazovaly procesy týkající se vývěsky nebo mezd a naopak, aby např. pracovník skladu neměl možnost prohlížet procesy týkající se plateb apod. Každému uživateli se tedy budou zobrazovat pouze jemu přístupné procesy (tzn. definice procesů), což jistě povede k zjednodušení práce s vlastními procesy (v činnosti Procesy a operace – Procesy). Uživatel, který nemá právo k založení druhu procesu, nemůže proces tohoto druhu stornovat.

Protože v této činnosti uživatel vlastně definuje pouze název, číselnou řadu a vlastnosti procesu, samotné složení procesu musí nadefinovat v činnosti "diagram procesu". V této činnosti nastaví posloupnost jednotlivých operací nebo procesů a vazby mezi nimi. Podrobnější vysvětlení najde uživatel v helpu činnosti "diagram procesu".

Po nastavení přístupových práv a nadefinování diagramu (neboli složení) procesu je možno vybraný proces spustit. Spuštění procesu se provádí právě v této činnosti, a to funkční klávesou F9 nebo přímo volbou této činnosti z menu "volby". V případě potřeby (např. pouze drobných odlišností v definici) může uživatel využít pod menu Volby i možnosti vytvoření Kopie druhu procesu.

Pro účely implementace má uživatel k dispozici činnost "generování dokumentace" (menu Volby), kde systém sám vytvoří dokumentaci, která obsahuje dosud vytvořené procesy, jejich operace, použité transformace a druhy hodnot. Pomocí činnosti "prohlížení dokumentace" může uživatel všechny tyto vygenerované údaje prohlížet, popřípadě si je i vytisknout.

Datový model

  • SPTYP Druh procesu/operace
    • SPCISDOK Číselná řada
    • BWUZIVAT Uživatel systému
    • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)

    • Vyvolávané činnosti

    K. | Činnost | Popis
F7 | Diagram procesu | Zobrazení diagramu procesu
F9 | Spuštění procesu | Spuštění procesu
^B | Přístupy k procesům a operacím | Definování přístupu k druhům procesů a druhům operací
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Generování dokumentace | Generování dokumentace implementace systému
- | Prohlížení dokumentace | Prohlížení vygenerované dokumentace k implementaci systému
- | Kopie druhu procesu | Vytvoření kopie aktuálního druhu procesu
- | Překlad názvu umístění nebo druhu | Překlad názvu umístění nebo druhu
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Korektory transformovaných dat | Korektory transformovaných dat
F2 | Metapředlohy výstupu | Metapředlohy výstupu
F2 | Skupiny procesů / předloh výstupu | Seznam skupin procesů / předloh výstupu
F2 | Volná karta | Seznam volných karet tabulky
F2 | Číselné řady platných procesů | Číselník číselných řad

    Formulář

    Formulář činnosti - Korektory transformovaných dat
Mřížka [Typy procesů]
Listovací rámeček
Stránka #1 Druhy procesů
Druh | Identifikátor druhu procesu
 | Název druhu procesu
Řada | Identifikátor číselné řady procesů
 | Název intervalu číselné řady procesů
Skupina | Identifikace skupiny procesů
Korektor | Identifikace korektoru transformovaných dat
Metapředloha | Identifikace metapředlohy výstupu
Implicitně spouštět | Způsob spuštění činnosti po ukončení předchozí činnosti
Použití | Zobrazovat v menu nebo se jedná o referenční proces
Test mírou plnění | Test míry plnění při ukončení operace
Skrytý druh procesu | Druh procesu/operace běžně nezobrazovaný
Poznámka | Komentář k druhu procesu
Stránka #2 Další
Karta | Název volné karty
 | Popis volné karty
Předplňovat - opakovat vstup | Předplňovat - opakovat vstup při startu procesu
Výraz popisu procesu | Výraz nebo skript v jazyce Foxpro (uvedený slovem SCRIPT) pro předplnění popisu procesu podle operace zahajující proces
Výraz externí identifikace procesu | Výraz nebo skript v jazyce Foxpro (uvedený slovem SCRIPT) pro předplnění externí identifikace procesu podle operace zahajující proces
Výraz poznámky procesu | Výraz nebo skript v jazyce Foxpro (uvedený slovem SCRIPT) pro předplnění poznámky procesu podle operace zahajující proces
Založil | Jméno uživatele systému
 | Datum založení
Stránka #3 Výskyt procesu
Mřížka [Výskyt procesu]
 | Komentář k druhu procesu
Stránka #4 Hodnoty procesu
Mřížka [Hodnoty procesu]
Komponenta | Identifikace komponenty
Druh operace | Identifikátor druhu operace
Druh hodnoty | Identifikace druhu hodnoty
 | Název druhu hodnoty
+/-/PV | Výpočet +=příjem, -=výdej, PV=podle atributu vyjadřující příjmovou/výdajovou událost (pokud existuje pro komponentu)
Stránka #5 Popisné info
Mřížka [Popisné info]
Význam | Identifikace významu položky obecné předkontace
Popis významu | Popis významu položky obecné předkontace
Volný text | Identifikace textu
Popis | Popis textu
Skript | Kód v jazyce Foxpro
Datum 1 | Datum 1
Datum 2 | Datum 2
Text 1 | Text 1
Text 2 | Text 2
Num 1 | Num 1
Num 2 | Num 2
Poznámka | Poznámka
Stránka #6 Výběr druhů procesů
Druh procesu | Identifikátor druhu procesu
Název druhu | Název druhu procesu
Řada | Identifikátor číselné řady procesů
Skupina | Identifikace skupiny procesů
 | Zobrazit druhy procesů vybraného charakteru
 | Zobrazit skryté, neskryté nebo všechny druhy procesů
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Typy procesů] činnosti - Korektory transformovaných dat

    Mřížka [Typy procesů] činnosti - Korektory transformovaných dat
Označování | Označení záznamu
Druh | Identifikátor druhu procesu
Název druhu procesu | Název druhu procesu
Řada | Identifikátor číselné řady procesů
Popis číselné řady | Název intervalu číselné řady procesů
Zobrazovat v menu,Nezobrazovat v menu,Referenční proces | Zobrazovat v menu nebo se jedná o referenční proces
Skrytý druh procesu | Druh procesu/operace běžně nezobrazovaný
Implicitně spouštět | Způsob spuštění činnosti po ukončení předchozí činnosti

    Mřížka [Výskyt procesu] činnosti - Korektory transformovaných dat

    Mřížka [Výskyt procesu] činnosti - Korektory transformovaných dat
Druh procesu | Identifikátor druhu procesu
Název druhu procesu | Název druhu procesu

    Mřížka [Hodnoty procesu] činnosti - Korektory transformovaných dat

    Mřížka [Hodnoty procesu] činnosti - Korektory transformovaných dat
Komponenta | Identifikace komponenty
Druh operace | Identifikátor druhu operace
Druh hodnoty | Identifikace druhu hodnoty
+/-/PV | Výpočet +=příjem, -=výdej, PV=podle atributu vyjadřující příjmovou/výdajovou událost (pokud existuje pro komponentu)
Druh | Identifikace druhu saldokontní hodnoty procesu

    Mřížka [Popisné info] činnosti - Korektory transformovaných dat

    Mřížka [Popisné info] činnosti - Korektory transformovaných dat
Význam | Identifikace významu položky obecné předkontace
Popis významu | Popis významu položky obecné předkontace
Text | Identifikace textu
Popis | Popis textu

    Atributy tisku

    Základní údaje
Druh | Identifikátor druhu procesu | SPTYP_sp07idtyp | C(6)
Řada | Identifikátor číselné řady procesů | SPTYP_sp08idcisd | C(8)
Název druhu procesu | Název druhu procesu | SPTYP_sp07text | C(30)
Poznámka | Komentář k druhu procesu | SPTYP_sp07koment | M
Skupina | Identifikace skupiny procesů | SPTYP_sp79id | C(6)
MPV | Identifikace metapředlohy výstupu | SPTYP_bw81id | C(6)
Zobrazovat v menu,Nezobrazovat v menu,Referenční proces | Zobrazovat v menu nebo se jedná o referenční proces | Výpočet | C(3)
Skrytý druh operace | Druh procesu/operace běžně nezobrazovaný | Výpočet | C(3)
Uživatel | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Uživatel (úplné jméno) | Úplné jméno uživatele systému | BWUZIVAT_bw01jmenot | C(25)

    Viz.také

    Diagram procesu | Spuštění procesu | Přístupy k procesům a operacím | OZNAČOVÁNÍ | Generování dokumentace | Prohlížení dokumentace | Kopie druhu procesu | Překlad názvu umístění nebo druhu | Druhy hodnot | Korektory transformovaných dat | Metapředlohy výstupu | Skupiny procesů / předloh výstupu | Volná karta | Číselné řady | Definice importu/exportu | Výběr předlohy


Druhy operací

Popis

Tato činnost umožňuje uživateli prohlížet a zároveň definovat jednotlivé druhy operací. Ke každému druhu operace je možno nadefinovat přístupová práva. U každé operace jsou k dispozici tyto údaje:

¨ komponenta - identifikace a název komponenty, ke které se operace vztahuje

¨ druh operace - identifikace a vlastní název operace

¨ charakter - pokud je charakter operace běžná, jedná se o standardní druh operace, který se bude pravděpodobně v systému vyskytovat nejčastěji (aktualizuje statistiky, transformuje data). Pokud uživatel potřebuje, aby se do jednoho procesu transformovaly operace z několika procesů, využije možností, které mu poskytují operace dávkového charakteru. Protože v operacích dávkového charakteru se shromažďují pouze odkazy na jiné operace, neaktualizují tyto dávkové operace statistiky a nelze do nich transformovat data.

Dávkové operace je možno používat opakovaně, ale do dávkové unikátní nelze opakovaně vložit operaci stejného druhu. Použití dávkových operací si nejsnadněji vysvětlíme na konkrétním případě. Dejme tomu, že máme např. firmu zabývající se rozvozem písku. Celý den odváží stovky aut náklad písku. Za určité období je pak nutno shromáždit za vybraného adresáta všechny jeho dodací listy (odkazy na všechny tyto dodací listy se shromažďují právě v dávkové operaci) a odtud se v procesu transformují na fakturu apod.

Je-li dávková operace používaná na pozadí, pak je číslo procesu (včetně roku) vytvořeno automaticky, a to podle systémového data. Takto se může stát, že faktura vytvářená na pozadí z podkladu roku 2006 bude mít číslo procesu roku 2007. Pokud si uživatel přeje fakturovat do roku 2006, vznikne chyba (tento problém však lze implementačně řešit).

Není-li dávková operace používaná na pozadí, lze číslování vyřešit při zápisu dávkové operace pomocí "zaškrtávátka" datum vzniku procesu a zvolit si rok.

¨ MP dávkové operace - způsob vyhodnocení míry plnění při transformaci z dávkové operace - možnosti jsou "z události" (tj. označená událost - případně její numerické atributy) nebo "z vazby na událost" (tj. událost dávkové operace). Tento atribut má význam pouze pro dávkové operace.

¨ korektor - korektor představuje definici kódu v jazyce FoxPro, který je spouštěn v rámci zpracování fyzického procesu v okamžiku po provedení všech transformací do operace těsně před tím, než jsou data předplněná transformací zobrazena uživateli ve formuláři operace (např. může být použito v případě transformace obchod – sklad, kdy máme jednu operaci obchodu, která se podle množství skladových buněk rozpadne na příslušný počet operací skladu)

¨ metapředloha - výběr metapředlohy výstupu pro tisk operace (např. skladová příjemka apod.)

¨ implicitně spouštět - může být nastaveno - automaticky - v průběhu procesu se bude operace spouštět automaticky (tj. po ukončení předchozí operace se tato automaticky spustí)

- na pozadí - operace bude probíhat na pozadí - uživatel ji nevidí, ani ji nemá možnost ovlivnit (např. zaúčtování, výdej ze skladu apod.). Na pozadí je možno provést i tu operaci, ke které nemá uživatel přístupová práva.

- nespouštět - operace se nebude spouštět automaticky, uživatel ji musí aktivovat ručně. Tato volba se používá u operací v procesech, kde je mezi operacemi určitá časová prodleva (např. odeslaná faktura a příjem výpisu z banky). Operace odeslaná faktura se provede, ale následující operace výpis z banky se nespustí. Uživatel vlastně musí počkat, až skutečně přijde výpis z banky, potom ručně spustí operaci výpis z banky a celý proces dokončí.

¨ řada operace - zadává se zde identifikace číselné řady operace

¨ test mírou plnění - možnost vybrat z překryvného seznamu, zda se po ukončení operace daného druhu má informovat uživatel o negativním výsledku testu mírou plnění

¨ skrytý druh operace - tento příznak uživatel využije u operací, se kterými se již nepracuje proto, aby se dále nezobrazovaly v aktuální nabídce druhů operací

¨ založil - informace datu, čase a uživateli, který druh operace založil

¨ poznámka - libovolná poznámka k operaci (např. v jakých procesech je vhodné ji použít apod.)

V další části tohoto popisu uživateli podrobněji přiblížíme jednotlivé záložky, které má v činnosti druhy operací k dispozici:

¨ záložka Další -

Po stisku klávesy F3 na záložce Další je možno zadat identifikaci a název volné karty (její atributy lze užít jako výstupní atributy komponenty). Uživatel má možnost u druhu operace nastavit tyto příznaky:

¨ po ukončení vstup volné karty procesu - tato volba se uplatní tehdy, pokud je u druhu procesu, jehož je daný druh operace součástí nastavena na záložce „další" volná karta, tak se po ukončení daného druhu operace spustí tato volná karta.

¨ po ukončení vstup volné karty operace - v případě, že je u druhu operace nadefinována volná karta a je uvedena na této záložce „další" v činnosti Druhy operací, tak se po ukončení daného druhu operace uživateli spustí právě tato nastavená volná karta.

¨ ukončení operace bez událostí - volba Ano/Ne, zda povolit ukončit daný druh operace i bez toho, že by obsahoval události

¨ operaci na pozadí vždy ukončovat automaticky - volba Ano/Ne, operace se bude na pozadí vždy ukončovat automaticky bez ohledu na to, co má nastaveno ve vlastnostech operace v diagramu procesu

¨ zrcadlové storno - volba Ano znamená, že při stornu vznikají inverzní (tj. opačné) operace a události, volba Ne znamená, že při stornu jsou operace i události zrušeny i pro ukončené operace

¨ kontrolovat při stornu – volba Ano znamená, že při stornu procesu systém kontroluje, zda otevřené období komponenty tohoto druhu operace má nastaveno kontrolovat při stornu Ano. Pokud je u otevřeného období komponenty nastaveno Ano a u druhu operace rovněž Ano (nebo není vůbec vyplněna záložka Další), storno procesu se neprovede, pokud by stornem vznikla inverzní událost s datem mimo otevřené období komponenty nebo pokud by stornem byla zrušena událost s datem mimo otevřené období komponenty.

¨ kontrolovat při rušení stavu ukon. – volba Ano znamená, že při rušení tohoto druhu operace systém kontroluje, zda otevřené období komponenty má nastaveno kontrolovat při rušení stavu ukončena Ano. Pokud je u otevřeného období komponenty nastaveno Ano a u druhu operace rovněž Ano (nebo není vůbec vyplněna záložka Další), zrušení stavu ukončena se neprovede, pokud by byla zrušena událost operace s datem mimo otevřené období komponenty. Dále platí, že rušení záznamu události komponenty klávesou F8 nebo rušení označených událostí v neukončené operaci nedovolí zrušit událost, která je mimo otevřené období komponenty. Stejně tak není povoleno změnit datum události, která byla uložena s datem, které je v daném okamžiku mimo otevřené období komponenty.

¨ zobrazovat ve stromu procesu – volba Ano/Ne. Možnost nastavení, zda druh operace má být zobrazen ve stromu hlavního procesu. Ve většině případů zřejmě bude nastaveno Ano, možnost Ne se využije především u operací, které se vkládají do diagramu procesu pouze pro umožnění odblokování operace.

¨ záložka Typy –

Tato záložka poskytuje uživateli jednak přehled a jednak rovnou i možnost přiřadit dané operaci jednotlivé typy událostí komponent. V současnosti je toto možné pouze pro operace komponenty „obecná událost“ (tj. vývěska).

¨ záložka Výskyt operace -

Údaje v této záložce poskytují uživateli informaci o tom, v jakém procesu (-ech) se daná operace vyskytuje.

¨ záložka Hodnoty operace -

Pod záložkou hodnoty operace se definují hodnoty, které má smysl u dané operace evidovat a sledovat neboli jsou to hodnoty, které jsou danou operací aktualizovány. Např. operace bankovní výpis aktualizuje hodnotu stav financí na účtu nebo operace výdej ze skladu aktualizuje hodnotu množství materiálu na skladě apod. U každého druhu hodnoty se eviduje její název a způsob výpočtu. Podle druhu hodnoty systém sám předplňuje způsob výpočtu, přičemž "+" je příjem, "-" je výdej a "PV" je příjem/výdej. Např. u hodnoty stav financí na účtu musí být zadán způsob "PV", protože tato hodnota je aktualizována jak příjmy (výpisy z banky), tak i výdaji (příkazy k úhradě). Nastavení tohoto atributu rozhoduje o tom, jak se hodnota na operaci bude chovat v obratech skladu. Pokud je zde nastaveno „+“, tak i kdyby uživatel na dané fyzické operaci změnil příznak pohybu na výdej, tak v obratové tabulce bude hodnota operace vždy na straně příjmu. Pouze v případě, že je zde na druhu operace nastaveno „PV“, tak se uplatní příjem nebo výdej podle toho, co je uvedeno na fyzické operaci. V případě nastavení „PV“ platí ještě jedno pravidlo: minusový příjem na fyzické operaci se v obratech skladu chová jako výdej a minusový výdej se v obratech skladu chová naopak jako příjem.

U každé hodnoty je navíc možno zadat podmínku, v jakém procesu se daná hodnota má vyvolat. Pokud je zadána "-", tak se tato hodnota uplatňuje vždy, pokud je zadána přímo identifikace procesu, tak pouze v tomto procesu.

V případě, že je zde uvedena konkrétní identifikace procesu, tak se daný druh hodnoty v odpovídající operaci vyhodnocuje:

¨ aktuální hodnota – daná operace se vyskytuje přímo v procesu daného druhu

¨ statistická hodnota – daná operace se vyskytuje přímo v procesu daného druhu

¨ hodnota obratu – daná operace se vyskytuje přímo v procesu daného druhu

¨ saldokontní hodnota – daná operace se vyskytuje v hlavním procesu daného druhu

¨ záložka Spojení –

Tato záložka poskytuje uživateli možnost předplňování rozdílného čísla spojení adresáta v událostech operací různých komponent. Na této záložce se definuje jakým způsobem program určuje číslo spojení adresáta při vstupu nové události daného druhu operace. Zadává se:

- spojení – 1.adresáta/2.adresáta (překryvný seznam) – určuje, kterého adresáta v události se daná definice spojení týká (zadat hodnotu „2.adresáta“ má smysl pouze pro operace komponenty obchod,

jejíž události obsahují dva adresáty)

- subjekt – textová hodnota – uvádí se identifikátor typu subjektu spojení adresáta – bude předplňováno spojení daného typu subjektu

- kategorie – textová hodnota – uvádí se kategorie spojení adresáta – bude předplňováno spojení, které je k datu události zařazeno do uvedené kategorie (lze zadat i vypočítávanou kategorii)

- použít impl. – Ano/Ne (překryvný seznam) – určuje pravidlo, zda se má použít implicitní spojení adresáta v případě, že pro něj neexistuje spojení daného typu subjektu

- proces – textová hodnota – uvádí se identifikátor druhu procesu – umožňuje definovat různé způsoby předplnění spojení adresáta pro danou operaci v případě, že je použitá v různých druzích procesů

- kód – textová hodnota – kód v jazyce FoxPro vyvolávaný pro určení spojení adresáta. V okamžiku vyvolání jsou pro kód dostupné proměnné _THIS (instance objektu formuláře ve kterém je prováděn

vstup), _AD01ID (identifikace adresáta pro kterého má být spojení předplněno) a _SPF2CSSP (odpovídá zadávané vlastnosti „spojení“ – nabývá hodnota 1 nebo 2) – kód by měl vracet textovou hodnotu

- poznámka – libovolný text

Postup programu IS BM při zjišťování předplňovaného čísla spojení adresáta je popsán ve slovníku pojmů (pojem „Spojení adresátů v událostech komponent“).

¨ záložka Validace -

Pod touto záložkou má uživatel možnost u jednotlivých druhů operací a s nimi souvisejících druhů hodnot nastavit takové údaje, které pak systém při jejich vstupu (při vstupu operací) ověřuje neboli validuje. Všechny zde nastavené údaje by se měli nějakým způsobem vztahovat k adresátovi. Může se jednat např. o druh operace "objednání odběratelem", kde je potom možno nastavit takové údaje, že pokud má u nás uživatel závazky v té a té výši, nebude jeho objednávka akceptována. Hodnota "než" představuje hodnotu varování, kdy při zápisu operace systém uživatele upozorní, že určitá částka je vyšší, nicméně mu dovolí tuto operaci zapsat. Hodnota "a než" představuje hodnotu zákazu vstupu a systém po jejím překročení vůbec nedovolí zapsat tuto operaci. Nastavené validace vstupu a jejich hodnoty jsou shodné pro všechny adresáty. Pokud uživatel potřebuje rozlišit jednotlivé hodnoty individuálně pro každého adresáta, využije tuto možnost, kterou mu nabízí činnost "kredity adresátů" (menu Volby), kde si pro každého adresáta může nastavit individuální hodnoty.

¨ záložka Info -

Na této záložce je možné definovat několik záznamů popisné informace spojené s druhem operace:

- Význam - identifikátor významu položky obecné předkontace - součást primárního klíče

- Volný text - identifikátor volného textu

- Kód - kód v jazyce Foxpro

- Datum 1 - datum

- Datum 2 - datum

- Text 1 - text

- Text 2 - text

- Num1 - číslo

- Num2 - číslo

- Poznámka

¨ záložka Uživatelé -

Zobrazuje se přehled uživatelů systému a jejich přístupová práva k dané operaci (čtení, zápis ...). Pro každého uživatele je možno po vyvolání této činnosti v menu Volby nastavit "osobní masku operace". Toto se využije především v takových případech, kdy několik uživatelů pracuje s jednou operací a přitom pro každého z nich jsou v této operaci prioritní jiné údaje. Pokud by neexistovala možnost vytvoření osobní masky operace, musela by se tato operace definovat několikrát pro každého uživatele zvlášť.

¨ záložka Výběr -

Jednotlivé položky slouží k tomu, aby si uživatel nadefinoval výběr podle svých současných potřeb a nezobrazoval si zbytečně mnoho informací, které v danou chvíli nepotřebuje.

Datový model

  • SPTYP Druh procesu/operace
    • BWUZIVAT Uživatel systému

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Kredity adresátů | Kredity adresátů pro druhy hodnot
F6 | Vstupní maska operace | Definování vstupní masky operace
F7 | Diagram procesu | Zobrazení diagramu procesu
F9 | Spuštění procesu | Spuštění procesu
^B | Přístupy k procesům a operacím | Definování přístupu k druhům procesů a druhům operací
^M | Maska operace v procesu | Definování vstupní masky operace
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Parametry operace komponenty | Parametry operace komponenty
- | Osobní maska operace | Definování vstupní masky operace
- | Inf. stromu pro druh operace | Zobrazené informace ve stromu pro operaci
- | Překlad názvu umístění nebo druhu | Překlad názvu umístění nebo druhu
F2 | Definice importu/exportu | Definice importu nebo exportu dat
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Komponenty | Číselník komponent
F2 | Metapředlohy výstupu | Metapředlohy výstupu
F2 | Typy subjektů spojení | Typy subjektů spojení
F2 | Typy událostí komponent | Typy událostí komponent
F2 | Volná karta | Seznam volných karet tabulky
F2 | Číselné řady | Číselník číselných řad

    Formulář

    Formulář činnosti - Typy událostí komponent
Mřížka [Druh operace]
Listovací rámeček
Stránka #1 Druhy operací
Komponenta | Identifikace komponenty
Druh | Identifikátor druhu operace
 | Název druhu operace
 | Název komponenty
Charakter | Charakter operace - běžná, dávková, dávková unikátní
MP dávkové operace | Míra plnění při transformaci z dávk.operace propojuje událost nebo vazbu dávk.operace
Metapředloha | Identifikace metapředlohy výstupu
Implicitně spouštět | Způsob spuštění činnosti po ukončení předchozí činnosti
Test mírou plnění | Test míry plnění při ukončení operace
Skrytý druh operace | Druh procesu/operace běžně nezobrazovaný
Řada operace | Identifikace řady operace
Založil | Jméno uživatele systému
 | Datum založení
Poznámka | Komentář k druhu procesu
Stránka #2 Další
Karta | Název volné karty
 | Popis volné karty
Po ukončení vstup volné karty procesu | Po ukončení vstup volné karty procesu
Po ukončení vstup volné karty operace | Po ukončení vstup volné karty operace
Ukončení operace bez událostí | Povolit ukončení operace bez událostí
Operaci na pozadí vždy ukončovat automaticky | Operaci spuštěnou na pozadí ukončit automaticky bez ohledu na nastavení v diagramu
Zrcadlové storno | Zrcadlové storno ANO=při stornu vznikají inverzní operace a události, NE=při stornu jsou operace a události zrušeny i pro ukončené operace
Kontrolovat při stornu | Validovat otevřené období komponenty při stornu procesu
Kontrolovat při rušení stavu ukon. | Validovat otevřené období komponenty při rušení stavu ukončena
Zobrazovat ve stromu procesu | Zobrazovat ve stromu hlavního procesu Ano/Ne
Stránka #3 Typy
Mřížka [Použitelné typy]
Typ | Identifikátor typu události komponenty
Název typu | Název typu události komponenty
Počáteční | Počáteční typ pro druh operace
Poznámka | Poznámka
Stránka #4 Výskyt operace
Mřížka [Výskyt operace v procesech]
 | Komentář k druhu procesu
Stránka #5 Hodnoty operace
Mřížka [Hodnoty operace]
Druh hodnoty | Identifikace druhu hodnoty
 | Název druhu hodnoty
+/-/PV | Výpočet +=příjem, -=výdej, PV=podle atributu vyjadřující příjmovou/výdajovou událost (pokud existuje pro komponentu)
V procesu | Druh hodnoty se uplatní pouze pro druh hlavního procesu
 | Název druhu procesu
Stránka #6 Spojení
Mřížka [Spojení]
Spojení | Pořadové číslo spojení v události operace
Subjekt | Identifikátor typu subjektu pro spojení adresáta
Název typu subjektu | Název typu subjektu pro spojení adresáta
Kategorie | Identifikace kategorie adresáta.
Název kategorie | Text vystihující charakter kategorie
Použít impl. | Použít implicitní spojení adresáta v případě, že pro něj neexistuje spojení daného typu subjektu
Proces | Identifikátor druhu procesu
Název druhu procesu | Název druhu procesu
Kód | Script v jazyce Foxpro vyvolávaný pro určení spojení
Poznámka | Poznámka
Stránka #7 Validace
Mřížka [Validace vstupu operace]
 | Identifikace komponenty - přijemce transformovaných dat
Druh hodnoty | Identifikace druhu hodnoty
 | Název druhu hodnoty
je | Aktuální hodnota je větší nebo menší než uvedená hodnota
než | Mezní porovnávaná hodnota pro varování
a než | Mezní porovnávaná hodnota pro zákaz vstupu
Odeslat zprávu | Odeslat zprávu uživateli systému
 | Identifikace uživatele systému
Text odeslané zprávy | Text odeslané zprávy
Stránka #8 Info
Mřížka [Popisné info]
Význam | Identifikace významu položky obecné předkontace
Popis významu | Popis významu položky obecné předkontace
Volný text | Identifikace textu
Popis | Popis textu
Skript | Kód v jazyce Foxpro
Datum 1 | Datum 1
Datum 2 | Datum 2
Text 1 | Text 1
Text 2 | Text 2
Num 1 | Num 1
Num 2 | Num 2
Poznámka | Poznámka
Stránka #9 Uživatelé
Mřížka [Uživatelé]
Stránka #10 Výběr
Komponenta | Identifikace komponenty
Druh operace | Identifikátor druhu operace
Název druhu | Název druhu operace
 | Zobrazit skryté, neskryté nebo všechny druhy operací
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Druh operace] činnosti - Typy událostí komponent

    Mřížka [Druh operace] činnosti - Typy událostí komponent
Komponenta | Identifikace komponenty
Druh | Identifikátor druhu operace
Název druhu operace | Název druhu procesu
Skrytý druh operace | Druh procesu/operace běžně nezobrazovaný
Implicitně spouštět | Způsob spuštění činnosti po ukončení předchozí činnosti
Charakter | Charakter operace - běžná, dávková, dávková unikátní
MP dávkové operace | Míra plnění při transformaci z dávk.operace propojuje událost nebo vazbu dávk.operace
Test mírou plnění | Test míry plnění při ukončení operace

    Mřížka [Použitelné typy] činnosti - Typy událostí komponent

    Mřížka [Použitelné typy] činnosti - Typy událostí komponent
Typ | Identifikátor typu události komponenty
Název typu | Název typu události komponenty
Počáteční | Počáteční typ pro druh operace

    Mřížka [Výskyt operace v procesech] činnosti - Typy událostí komponent

    Mřížka [Výskyt operace v procesech] činnosti - Typy událostí komponent
Druh procesu | Identifikátor druhu procesu
Název druhu procesu | Název druhu procesu

    Mřížka [Hodnoty operace] činnosti - Typy událostí komponent

    Mřížka [Hodnoty operace] činnosti - Typy událostí komponent
Druh hodnoty | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
+/-/PV | Výpočet +=příjem, -=výdej, PV=podle atributu vyjadřující příjmovou/výdajovou událost (pokud existuje pro komponentu)
V procesu | Druh hodnoty se uplatní pouze pro druh hlavního procesu
Název druhu procesu | Název druhu procesu

    Mřížka [Spojení] činnosti - Typy událostí komponent

    Mřížka [Spojení] činnosti - Typy událostí komponent
Spojení | Pořadové číslo spojení v události operace
Subjekt | Identifikátor typu subjektu pro spojení adresáta
Název typu subjektu | Název typu subjektu pro spojení adresáta
Proces | Identifikátor druhu procesu
Název druhu procesu | Název druhu procesu

    Mřížka [Validace vstupu operace] činnosti - Typy událostí komponent

    Mřížka [Validace vstupu operace] činnosti - Typy událostí komponent
Komponenta | Identifikace komponenty
Druh | Identifikace druhu hodnoty
je | Aktuální hodnota je větší nebo menší než uvedená hodnota
než | Mezní porovnávaná hodnota pro varování
a než | Mezní porovnávaná hodnota pro zákaz vstupu

    Mřížka [Popisné info] činnosti - Typy událostí komponent

    Mřížka [Popisné info] činnosti - Typy událostí komponent
Význam | Identifikace významu položky obecné předkontace
Popis významu | Popis významu položky obecné předkontace
Text | Identifikace textu
Popis | Popis textu

    Mřížka [Uživatelé] činnosti - Typy událostí komponent

    Mřížka [Uživatelé] činnosti - Typy událostí komponent
Uživatel | Jméno uživatele systému
Přístup | Právo přístupu - Žádné,Čtení,Zápis

    Atributy tisku

    Základní údaje
Druh | Identifikátor druhu operace | SPTYP_sp07idtyp | C(6)
Komponenta | Identifikace komponenty | SPTYP_sp06idsubs | C(3)
Název druhu operace | Název druhu operace | SPTYP_sp07text | C(30)
Charakter | Charakter operace - běžná, dávková, dávková unikátní | Výpočet | C(16)
MP dávkové operace | Míra plnění při transformaci z dávk.operace propojuje událost nebo vazbu dávk.operace | Výpočet | C(18)
Poznámka | Komentář k druhu procesu | SPTYP_sp07koment | M
Uživatel | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Uživatel (úplné jméno) | Úplné jméno uživatele systému | BWUZIVAT_bw01jmenot | C(25)
Datum založení | Datum založení | SPTYP_sp07datzal | T
Ident. | Identifikace uživatele systému | BWUZIVA3_bw01uziv | C(6)
Uživatel | Jméno uživatele systému | BWUZIVA3_bw01jmeno | C(30)
Uživatel (úplné jméno) | Úplné jméno uživatele systému | BWUZIVA3_bw01jmenot | C(25)
Název typu subjektu | Název typu subjektu pro spojení adresáta | ADTYPSUB_ad58naztyp | C(40)
Název kategorie | Text vystihující charakter kategorie | ADKAT_ad08kateg | C(40)
Název druhu procesu | Název druhu procesu | SPTYP4_sp07text | C(30)

    Při pohybu v Uživatelé
    Právo přístupu Právo přístupu - Žádné,Čtení,Zápis Výpočet C(5)

    Při pohybu v Určení typu subjektu spojení
Spojení | Pořadové číslo spojení v události operace | Výpočet | C(10)
Typ | Identifikátor typu subjektu pro spojení adresáta | SPTYPSUB_ad58id | C(6)
Kategorie | Identifikace kategorie adresáta. | SPTYPSUB_ad08id | C(6)
Použít impl. | Použít implicitní spojení adresáta v případě, že pro něj neexistuje spojení daného typu subjektu | Výpočet | C(3)
Druh procesu | Identifikátor druhu procesu | SPTYPSUB_sp07idtypd | C(6)
Kód | Script v jazyce Foxpro vyvolávaný pro určení spojení | SPTYPSUB_spf2kod | M
Poznámka | Poznámka | SPTYPSUB_spf2koment | M

    Viz.také

    Kredity adresátů | Diagram procesu | Spuštění procesu | Přístupy k procesům a operacím | OZNAČOVÁNÍ | Parametry operace komponenty | Vstupní maska operace | Inf. stromu pro druh operace | Překlad názvu umístění nebo druhu | Definice importu/exportu | Druhy hodnot | Druhy procesů | Kategorie adresátů | Komponenty | Metapředlohy výstupu | Typy subjektů spojení | Typy událostí komponent | Volná karta | Číselné řady | Doplňující vlastnosti formuláře


Typy událostí komponent

Popis

Tato činnost umožňuje členit operace jednotlivých komponent (v současnosti pouze komponenty „obecná událost“, tzn. vývěska) podle nadefinovaných typů událostí komponenty. Typ události pak uživatel uvádí při zadávání operace komponenty (tzn. při zadávání událostí komponenty vývěska se z překryvného seznamu vybírá i typ události). V této činnosti má uživatel přehled jednotlivých typů událostí a jejich použitelnosti v jednotlivých operacích. K druhům operací lze i v této činnosti přiřazovat jednotlivé typy, v rámci lepší přehlednosti ale doporučujeme uživateli toto definovat přímo v činnosti druhy operací.

Uveďme si příklad možného použití této činnosti:

¨ uživatel má nadefinovaný druh operace komponenty obecná událost (tj. vývěska), která se jmenuje „obchodní případ“

¨ tento druh operace může být pak následně členěn na různé typy – např. telefonát, odeslání informací e-mailem, osobní návštěva apod.

Nejprve je nutno nadefinovat typy událostí komponent. Zde se zadává:

¨ identifikace typu

¨ název typu

Na záložce „použitelnost typu pro druhy operací“ se definuje, jaký typ je platný pro kterou operaci. K druhu operace může být přidělen žádný nebo několik typů událostí. Definuje se:

¨ operace – identifikace komponenty, identifikace druhu operace a její název

¨ počáteční – možnost Ano/Ne – volba Ano určuje typ události předplněný při vstupu nové události

¨ poznámka

Datový model

  • SPTYPUD Typ události komponenty

    • Formulář

    Formulář činnosti - Komponenty
Mřížka [Typy událostí]
Typ | Identifikátor typu události komponenty
Název typu | Název typu události komponenty
Listovací rámeček
Stránka #1 Typy událostí
Poznámka | Poznámka
Stránka #2 Použitelnost typu pro druhy operací
Mřížka [Použitelnost pro druhy operací]
Komp. | Identifikace komponenty
Operace | Identifikátor druhu operace
 | Název druhu procesu
Počáteční | Počáteční typ pro druh operace
Poznámka | Poznámka

    Mřížka [Typy událostí] činnosti - Komponenty

    Mřížka [Typy událostí] činnosti - Komponenty
Typ | Identifikátor typu události komponenty
Název typu | Název typu události komponenty

    Mřížka [Použitelnost pro druhy operací] činnosti - Komponenty

    Mřížka [Použitelnost pro druhy operací] činnosti - Komponenty
Komp. | Identifikace komponenty
Operace | Identifikátor druhu operace
Název druhu operace | Název druhu operace
Počáteční | Počáteční typ pro druh operace

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druhy operací | Přehled druhů operací
F2 | Komponenty | Číselník komponent

    Atributy tisku

    Základní údaje
Typ | Identifikátor typu události komponenty | SPTYPUD_spf8id | C(6)
Název typu | Název typu události komponenty | SPTYPUD_spf8naztyp | C(40)
Poznámka | Poznámka | SPTYPUD_spf8koment | M
Název druhu operace | Název druhu procesu | SPTYP_sp07text | C(30)

    Při pohybu v Použitelnost typu pro druhy operací
Operace | Identifikátor druhu operace | SPTYPUDV_sp07idtyp | C(6)
Komponenta | Identifikace komponenty | SPTYPUDV_sp06idsubs | C(3)
Počáteční | Počáteční typ pro druh operace | Výpočet | C(3)
Poznámka | Poznámka | SPTYPUDV_spf9koment | M

    Viz.také

    Druhy operací | Komponenty


Komponenty

Popis

Komponenta je ucelená část informačního systému, kterou je možno provozovat i samostatně (s informačním centrem), a to samo o sobě již má určitý přínos pro uživatele. Každá komponenta v informačním systému Bílý Motýl má standardizovanou strukturu a může mít své:

¨ operace s druhy hodnot a šablony

¨ aktéry (adresáty)

¨ artikly

¨ alokace (umístění)

¨ činnosti

¨ vstupní atributy

¨ výstupní atributy

¨ ...

Sloupec „zrcadlové storno“ poskytuje uživateli informaci o tom, zda daná komponenta má programově umožněno vytvářet zrcadlové storno či nikoliv. Zrcadlové storno znamená, že ke stornované události bude vytvořena událost inverzní (tj. opačná s mínusovými znaménky). U ostatních komponent je stornovaná událost zrušena. U komponent, které mají ve sloupečku „záložka Další“ zapsanou * platí, že tyto komponenty mají programově umožněno zrcadlové storno, ale implicitně se u nich neuplatňuje, tzn. že při stornu událostí těchto komponent jsou události zrušeny. Aby zde fungovalo zrcadlové storno, je nutno u druhu operací těchto komponent (Informační centrum - Typy a řady - Druhy operací) na záložce Další nastavit příznak zrcadlové storno na Ano. S jednotlivými komponentami úzce souvisí i činnost otevřená období komponent (menu Informační centrum - Typy a řady), která umožňuje uživateli nastavit období pro validaci dat v událostech.

U každé komponenty lze zadat (po stisku F3) datum od - do. Toto datum systém potom hlídá při zápisu událostí komponenty a při provádění storna. Jak již vyplývá z názvu této činnosti, je nutno si uvědomit, že uživatel zadává datum, kdy je možno komponentu pro zápis událostí nebo storna považovat za otevřenou, tzn. mimo toto zadané období je vlastně komponenta pro zápis nebo storno uzavřená. Pokud uživatel u komponenty nezadá žádné datum od - do, je tato komponenta implicitně otevřená jak pro zápis, tak pro storno.

Formulář

Formulář činnosti - VÝRAZY KOMPONENTY
Mřížka [Komponenty]

Mřížka [Komponenty] činnosti - VÝRAZY KOMPONENTY

Mřížka [Komponenty] činnosti - VÝRAZY KOMPONENTY
Komponenta | Identifikace komponenty
Název komponenty | Název komponenty
Zrcadlové storno | Zrcadlové storno ANO=při stornu vznikají inverzní operace a události, NE=při stornu jsou operace a události zrušeny i pro ukončené operace

Vyvolávané činnosti

K. | Činnost | Popis
F5 | Šablony | Definování vstupních šablon komponent
F7 | Druhy hodnot | Seznam druhů statistických informací
F9 | Zobrazené informace ve stromu | Informace o události komponenty zobrazené ve stromu
- | Metapředlohy výstupu | Metapředlohy výstupu
- | VÝRAZY KOMPONENTY | Výrazy komponenty pro transformace v procesech

Atributy tisku

Základní údaje
Subsystém | SPSUBSYS.sp06idsubs | C(3)
Název subsystému | SPSUBSYS.sp06text | C(30)

Viz.také

Šablony | Druhy hodnot | Zobrazené informace ve stromu | Metapředlohy výstupu | VÝRAZY KOMPONENTY


Otevřená období komponent

Popis

S jednotlivými komponentami úzce souvisí i činnost otevřená období komponent (menu Informační centrum - Typy a řady), která umožňuje uživateli nastavit období pro validaci dat v událostech.

U každé komponenty lze zadat (po stisku F3) datum od - do. Toto datum systém potom hlídá při zápisu událostí komponenty a při provádění storna. Jak již vyplývá z názvu této činnosti, je nutno si uvědomit, že uživatel zadává datum, kdy je možno komponentu pro zápis událostí nebo storna považovat za otevřenou, tzn. mimo toto zadané období je vlastně komponenta pro zápis nebo storno uzavřená. Pokud není pro komponentu definováno otevřené období, potom není povolen vstup událostí s datem mimo interval 1.1.1980 až 1.1.2100. Pozn.: Důsledkem toho je, že pro komponenty, ve kterých se mohou vyskytnout události s menším datem (spravovaný majetek, odepisovaný majetek, ....) je NUTNÉ definovat otevřené období komponenty.

Další možnosti této činnosti jsou:

¨ kontrolovat při stornu – možnost Ano/Ne. V případě zadání Ano systém kontroluje ještě nastavení tohoto atributu u druhu operace (záložka Další). Pokud je u otevřeného období komponenty nastaveno Ano a u druhu operace rovněž Ano (nebo není vůbec vyplněna záložka Další), storno procesu se neprovede, pokud by stornem vznikla inverzní událost s datem mimo otevřené období komponenty nebo pokud by stornem byla zrušena událost s datem mimo otevřené období komponenty.

¨ kontrolovat při rušení stavu ukončena - možnost Ano/Ne. V případě zadání Ano systém kontroluje ještě nastavení tohoto atributu u druhu operace (záložka Další). Pokud je u otevřeného období kompomenty nastaveno Ano a u druhu operace rovněž Ano (nebo není vůbec vyplněna záložka Další), zrušení stavu ukončena se neprovede, pokud by byla zrušena událost operace s datem mimo otevřené období komponenty.

Datový model

  • SPKOMPUZ Uzavřené období komponenty

    • Formulář

    Formulář činnosti - VÝRAZY KOMPONENTY
Mřížka [Otevřené období]
Komponenta | Identifikace komponenty
Název komponenty | Název komponenty
Vstup datum od | Povolené období pro vstup od
do | Povolené období pro vstup do
Kontrolovat při stornu | Validovat otevřené období komponenty při stornu procesu
Kontrolovat při rušení stavu ukončena | Validovat otevřené období komponenty při rušení stavu ukončena

    Mřížka [Otevřené období] činnosti - VÝRAZY KOMPONENTY

    Mřížka [Otevřené období] činnosti - VÝRAZY KOMPONENTY
Komponenta | Identifikace komponenty
Název komponenty | Název komponenty
od | Povolené období pro vstup od
do | Povolené období pro vstup do
Kontrolovat při stornu | Validovat otevřené období komponenty při stornu procesu
Kontrolovat při rušení stavu ukončena | Validovat otevřené období komponenty při rušení stavu ukončena

    Atributy tisku

    Základní údaje
Komponenta | Identifikace komponenty | SPKOMPUZ_sp06idsubs | C(3)
Vstup datum od | Povolené období pro vstup od | SPKOMPUZ_sp04datvod | D
do | Povolené období pro vstup do | SPKOMPUZ_sp04datvdo | D
Kontrolovat při stornu | Validovat otevřené období komponenty při stornu procesu | Výpočet | C(3)
Kontrolovat při rušení stavu ukončena | Validovat otevřené období komponenty při rušení stavu ukončena | Výpočet | C(3)


Číselné řady

Popis

Představuje evidenční knihu reálného světa, kde jsou doklady (v IS procesy) ukládány pod svými pořadovými čísly, které se jim přidělují z intervalu vymezeného touto číselnou řadou. Do jedné knihy může být současně zařazeno více druhů dokladů (procesů). Číselné řady se definují v činnosti Informační centrum - Typy a řady - Číselné řady. Při definování druhu procesu se pak každému druhu přiřazuje právě jedna číselná řada.

Číslování procesů odpovídá v IS BM i číslování dokladů, např. pokud máme proces faktury, který má přidělen určitou číselnou řadu, má vytištěný doklad faktura shodné číslo s touto číselnou řadou. Toto číslování je samozřejmě nutno náležitě definovat v relevantní předloze výstupu. Do jedné evidenční knihy je možno přiřadit více druhů procesů. U každé číselné řady se vstupují tyto atributy:

¨ řada - identifikace číselné řady (měla by např. souviset s komponentou, pro kterou je číselná řada tvořena - usnadňuje pak snadnější vyhledávání v přehledu číselných řad)

¨ popis - výstižný popis číselné řady

¨ začátek a konec intervalu - uživatel si z číselníku vybere začátek a konec intervalu pro danou číselnou řadu. Při výběru intervalu má uživatel k dispozici i činnost „volné intervaly“(pod menu Volby), která mu vypíše přehled dosud neobsazených, tj. volných intervalů. Číslo z tohoto intervalu se stává součástí identifikace procesu.

Zde je nutno uživatele upozornit na atribut „aktuální“, který je přístupný na záložce „číselné řady v letech“. Tento atribut poskytuje uživateli informaci o posledním použitém čísle ve fyzických procesech. Systém se chová tak, že při číslování procesů vždy najde poslední použité číslo v přehledu fyzických procesů a přidělí číslo o jedna větší.

Vyhledávání podle identifikace číselné řady je možné ve výběru v činnosti „druhy procesů”, kde je identifikace číselné řady dostupná i jako atribut přímo na oknech. V okně je identifikace číselné řady dostupná i v činnosti „procesy”, vyhledávat podle ní zde však nelze.

Datový model

  • SPCISDOK Číselná řada

    • Vyvolávané činnosti

    K. | Činnost | Popis
- | Volné intervaly | Zjištění volných intervalů v číselných řadách
F2 | Komponenty | Číselník komponent
F2 | Konec intervalu | Zjištění volných intervalů v číselných řadách

    Formulář

    Formulář činnosti - Volné intervaly
Mřížka [Číselné řady]
Řada | Identifikátor číselné řady procesů
Popis | Název intervalu číselné řady procesů
Listovací rámeček
Stránka #1 Číselné řady
Začátek | Začátek intervalu číselné řady procesů
Konec | Konec intervalu číselné řady procesů
Poznámka | Poznámka k číselné řadě
Stránka #2 Číselné řady v letech
Mřížka [Číselné řady v letech]
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Aktuální | Aktuální číslo procesu
Zbývá | Zbývající počet procesů
Využití | Procento využití číselné řady
Stránka #3 Výskyt v procesech
Mřížka [Druhy procesů]
 | Komentář k druhu procesu
Stránka #4 Výběr
Řada | Identifikátor číselné řady procesů
Popis | Název intervalu číselné řady procesů
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Číselné řady] činnosti - Volné intervaly

    Mřížka [Číselné řady] činnosti - Volné intervaly
Řada | Identifikátor číselné řady procesů
Popis | Název intervalu číselné řady procesů
Začátek | Začátek intervalu číselné řady procesů
Konec | Konec intervalu číselné řady procesů

    Mřížka [Číselné řady v letech] činnosti - Volné intervaly

    Mřížka [Číselné řady v letech] činnosti - Volné intervaly
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Aktuální | Aktuální číslo procesu
Zbývá | Zbývající počet procesů
Využití | Procento využití číselné řady

    Mřížka [Druhy procesů] činnosti - Volné intervaly

    Mřížka [Druhy procesů] činnosti - Volné intervaly
Druh procesu | Identifikátor druhu procesu
Název druhu procesu | Název druhu procesu

    Atributy tisku

    Základní údaje
Řada | Identifikátor číselné řady procesů | SPCISDOK_sp08idcisd | C(8)
Popis | Název intervalu číselné řady procesů | SPCISDOK_sp08text | C(30)
Začátek | Začátek intervalu číselné řady procesů | SPCISDOK_sp08intzac | N(8)
Konec | Konec intervalu číselné řady procesů | SPCISDOK_sp08intkon | N(8)
Poznámka | Poznámka k číselné řadě | SPCISDOK_sp08koment | M
Rok | Rok v identifikaci procesu | SPCISDOX_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | SPCISDOX_sp33cisdpm | C(2)
Aktuální | Aktuální číslo procesu | SPCISDOX_sp33cisd | C(8)

    Při pohybu v Druhy procesů
Druh procesu | Identifikátor druhu procesu | SPTYP_sp07idtyp | C(6)
Název druhu procesu | Název druhu procesu | SPTYP_sp07text | C(30)
Poznámka | Komentář k druhu procesu | SPTYP_sp07koment | M

    Viz.také

    Komponenty | Volné intervaly


Korektory transformovaných dat

Popis

Korektor je možné nadefinovat ke každému druhu procesu a úzce souvisí s formátem ISDOC. Korektor představuje definici kódu v jazyce FoxPro, který je spouštěn v rámci zpracování fyzického procesu v okamžiku po provedení všech transformací do operace těsně před tím, než jsou data předplněná transformací zobrazena uživateli ve formuláři operace. Korektor se definuje na druhu procesu (hlavní menu – Informační centrum – Typy a řady – Druhy procesů) na první záložce „Druhy procesů“. Obsahuje tyto atributy:

¨ korektor – identifikace a název korektoru

¨ druh – identifikace druhu implementačního rozšíření (pomocí tohoto druhu jsou řízena přístupová práva k danému korektoru). Použít tento korektor může uživatel, který má k danému druhu právo alespoň čtení.

¨ sada – identifikace a název sady systémových konstant

¨ kód – kód korektoru v jazyce FoxPro

¨ poznámka – vlastní poznámka uživatele

¨ datum a čas aktualizace

Datový model

  • SPKOREK Korektor transformovaných dat
    • PASYSSAD Sada systémových konstat
    • SPCINDVT Druh implementačního rozšíření
      • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Knihovny vkládaného kódu
Mřížka [Korektory]
Korektor | Identifikace korektoru transformovaných dat
Název korektoru | Název korektoru transformovaných dat
Druh | Identifikace druhu implemetačního rozšíření
Název druhu | Název druhu implemetačního rozšíření
Sada | Identifikace sady systémových konstant
Název sady | Název sady systémových konstant
Kód | Kód kortektoru v jazyce Foxpro (Lparameters _this,_thisform,_alias,_params ...)
Poznámka | Poznámka
Aktualizace | Datum aktualizace

    Mřížka [Korektory] činnosti - Knihovny vkládaného kódu

    Mřížka [Korektory] činnosti - Knihovny vkládaného kódu
Korektor | Identifikace korektoru transformovaných dat
Název korektoru | Název korektoru transformovaných dat
Sada | Identifikace sady systémových konstant
Název sady | Název sady systémových konstant
Druh | Identifikace druhu implemetačního rozšíření
Název druhu | Název druhu implemetačního rozšíření

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Editovat kód vlastnosti | Editovat kód vlastnosti
F6 | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností
F9 | Hodnoty sady konstant | Hodnoty sady systémových konstant
- | Kontrolní kompilace | Kontrolní kompilace
F2 | Druhy implementačních rozšíření | Druhy implementačních rozšíření
F2 | Sady systémových konstat | Sady systémových konstat

    Atributy tisku

    Základní údaje
Korektor | Identifikace korektoru transformovaných dat | SPKOREK_spg2id | C(6)
Sada | Identifikace sady systémových konstant | SPKOREK_pa17id | C(6)
Název sady | Název sady systémových konstant | PASYSSAD_pa17nazsad | C(40)
Druh | Identifikace druhu implemetačního rozšíření | SPKOREK_spa6id | C(6)
Název druhu | Název druhu implemetačního rozšíření | SPCINDVT_spa6nazdru | C(40)
Název korektoru | Název korektoru transformovaných dat | SPKOREK_spg2nazkor | C(40)
Kód | Kód kortektoru v jazyce Foxpro (Lparameters _this,_thisform,_alias,_params ...) | SPKOREK_spg2kod | M
Poznámka | Poznámka | SPKOREK_spg2koment | M

    Viz.také

    Editovat kód vlastnosti | Knihovny vkládaného kódu | Hodnoty sady konstant | Kontrolní kompilace | Druhy implementačních rozšíření | Sady systémových konstat


Druhy volných karet

Popis

Tato činnost umožňuje uživateli aktualizovat, opravovat a rušit přehled (číselník) druhů volných karet. U každého druhu se eviduje jeho identifikace, název a jméno uživatele, který tento druh založil. Zařazení jednotlivých volných karet pod jednotlivé druhy určitě přispěje k lepší orientaci a k zjednodušení práce s volnými kartami.

Ke každému druhu volné karty je možno nadefinovat přístupová práva (příslušná činnost v menu Volby nebo klávesa Ctrl B).

Datový model

  • SPVOLSTT Druh volné karty
    • SPPRISTU Přístupové právo uživatele k věci
    • BWUZIVAT Uživatel systému (alias BWUZIVA1)

    • Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci

    Formulář

    Formulář činnosti - Volná karta
Mřížka [Druhy volných struktur]
Druh | Druh volné karty - pro přístup uživatele
 | Název druhu volné karty
Založil | Jméno uživatele systému
 | Datum založení druhu volné karty
Komentář | Popis druhu volné karty

    Mřížka [Druhy volných struktur] činnosti - Volná karta

    Mřížka [Druhy volných struktur] činnosti - Volná karta
Druh | Druh volné karty - pro přístup uživatele
Název druhu volné karty | Název druhu volné karty

    Atributy tisku

    Základní údaje
Druh | Druh volné karty - pro přístup uživatele | SPVOLSTT_sp66id | C(6)
Název druhu volné karty | Název druhu volné karty | SPVOLSTT_sp66druhst | C(40)
Komentář | Popis druhu volné karty | SPVOLSTT_sp66koment | M
Založil | Jméno uživatele systému | BWUZIVA1_bw01jmeno | C(30)
Vznik | Datum založení druhu volné karty | SPVOLSTT_sp66datum | T

    Viz.také

    Přístupová práva | Volná karta


Definice vyvolání

Popis

Definice vyvolání je činnost, která se nejčastěji používá u procesů, kde nastává určitá komunikace s nějakým externím zdrojem nebo je-li mezi operacemi určitá časová prodleva. Klasickou ukázkou je proces výpisu z banky, kde se určitou dobu čeká než do společnosti dorazí výpis z banky a teprve potom může dojít ke spárování s vystavenými fakturami (tj. platbami).

A právě proto, aby se uživatel napojil do správného procesu, je nutno nadefinovat "definici vyvolání". Definice vyvolání tedy řečeno zjednodušeně určuje, která operace z které komponenty se má napojit do procesu.

U každé definice se zadává její identifikace a název (např. přijetí výpisu z banky), identifikace procesu, kterého se definice týká (v našem případě tedy výpis) a identifikace komponenty a operace, která se bude do tohoto procesu napojovat (je to operace, která se týká úhrady faktury).

Po zařazení "definice vyvolání" uživatel spustí činnost "vyvolání operace" , kde je předplněn rok a identifikace datového úložiště. Číslo procesu zadává uživatel sám. Toto číslo procesu může nahrazovat i variabilní symbol.

Datový model

  • SPTYPGO Vyvolání operace z hlavního procesu
    • SPTYP Druh procesu/operace
    • SPTYPOD Druh operace v druhu procesu
      • SPTYP Druh procesu/operace (alias SPTYP2)
        • SPPRISTU Přístupové právo uživatele k věci
    • BWUZIVAT Uživatel systému

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Vyvolání operace | Vyvolání operace z hlavního procesu
F2 | Druhy procesů | Přehled druhů procesů
F2 | Komponenty | Číselník komponent

    Formulář

    Formulář činnosti - Druhy procesů
Mřížka [Vyvolání operace]
Identifikace | Identifikace vyvolání
Název | Název vyvolání
Proces | Identifikátor druhu procesu
 | Název druhu procesu
 | Identifikace komponenty
Operace | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Název druhu procesu
Založil | Jméno uživatele systému
 | Datum založení

    Mřížka [Vyvolání operace] činnosti - Druhy procesů

    Mřížka [Vyvolání operace] činnosti - Druhy procesů
Identifikace | Identifikace vyvolání
Název | Název vyvolání
Druh procesu | Identifikátor druhu procesu
Komponenta | Identifikace komponenty
Druh operace | Identifikátor druhu operace

    Atributy tisku

    Základní údaje
Identifikace | Identifikace vyvolání | SPTYPGO_sp72id | C(6)
Název | Název vyvolání | SPTYPGO_sp72nazev | C(40)
Druh procesu | Identifikátor druhu procesu | SPTYPGO_sp07idtypd | C(6)
Název druhu procesu | Název druhu procesu | SPTYP_sp07text | C(30)
Komponenta | Identifikace komponenty | SPTYPGO_sp06idsubs | C(3)
Druh operace | Identifikátor druhu operace | SPTYPGO_sp07idtyp | C(6)
Název druhu operace | Název druhu procesu | SPTYP2_sp07text | C(30)
Pořadí | Pořadí stejného druhu operace v jednom procesu | SPTYPGO_sp33porad | N(2)
Datum založení | Datum založení | SPTYPGO_sp72datum | T

    Viz.také

    Vyvolání operace | Druhy procesů | Komponenty


Prezentace procesů

Popis

Definuje, z jakých druhů operací a v jakém pořadí dle druhů operací mohou být pro tisk (výstup na základě předlohy výstupu - proces) získávány informace. Je uživateli dostupná v hlavním menu ve skupině Informační centrum – Typy a řady.

Tato definice se provádí v činnosti „prezentace procesů”. Uvádí se název prezentace a na záložce „prezentované operace” se k prezentaci přiřadí druh operace. K prezentaci se přiřazují ty druhy operací z procesů, jejichž události chceme tisknout na dokladu. Je poměrně obvyklé, že se každá prezentace implementuje ve vztahu k jednomu druhu procesu (či k několika "příbuzným" druhům procesu) s následným využitím v několika předlohách výstupu - proces.

Důležitým atributem je „pořadí”, které určuje, v jakém pořadí (sledu) druhů operací jejich události na doklad při tisku vystupují. Poslední dva atributy, které má uživatel dostupné v pravé dolní části okna a má možnost je zaškrtnout jsou:

¨ referenční - znamená, že určité atributy událostí druhu operace, u které je tento atribut zaškrtnutý, jsou pak při tisku dostupné i v ostatních druzích operací v dané prezentaci (toto „zaškrtávátko“ však z praxe není ověřeno, navíc je zde podezření, že by se určitým způsobem mohl zpomalit i vlastní tisk)

¨ operace z procesu - pokud je tento atribut zatržen, je v tisku k dispozici operace daného druhu jen z toho fyzického procesu, ze kterého je spuštěn výstup. Pokud tento atribut zatržen není, v tisku jsou k dispozici operace daného druhu z celého hlavního procesu.

Nadefinované prezentace procesů se pak přiřazují k jednotlivým předlohám výstupu - proces. Prezentaci procesů lze zadat pouze v případě, že předloha výstupu má zaškrtnutý (zvýrazněný tečkou) pohyb v událostech, jinak je položka prezentace nedostupná (tzn. šedivá).

V případě, že se změní diagram (druhu) procesu přidáním uzlu (operace), z něhož se požaduje tisk dokladu, musí se tato změna promítnout i do relevantních prezentací procesu, jinak nebude možno doklad vytisknout (atributy událostí nové operace nebudou dostupné v předloze), tzn. uzel (operace), který byl přidán do diagramu musí být vložen do příslušné prezentace se správným pořadovým číslem.

Datový model

  • SPPREZ Prezentace procesu
    • BWUZIVAT Uživatel systému

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druhy operací | Přehled druhů operací
F2 | Komponenty | Číselník komponent

    Formulář

    Formulář činnosti - Druhy operací
Mřížka [Prezentace procesů]
Prezentace | Identifikátor prezentace procesu
 | Název prezentace procesu
Listovací rámeček
Stránka #1 Prezentace
Založil | Jméno uživatele systému
 | Datum založení
Poznámka | Poznámka k prezentaci procesu
Stránka #2 Prezentované operace
Mřížka [Prezentované operace]
Komponenta | Identifikace komponenty
 | Název komponenty
Druh operace | Identifikátor druhu operace
 | Název druhu operace
Pořadí | Pořadí operace v prezentaci
Referenční | Referenční číslo operace je považováno za identifikaci dokladu
Operace z procesu | Prezentovat operaci přímo obsaženou v procesu

    Mřížka [Prezentace procesů] činnosti - Druhy operací

    Mřížka [Prezentace procesů] činnosti - Druhy operací
Prezentace | Identifikátor prezentace procesu
Název prezentace procesu | Název prezentace procesu

    Mřížka [Prezentované operace] činnosti - Druhy operací

    Mřížka [Prezentované operace] činnosti - Druhy operací
Komponenta | Identifikace komponenty
Druh operace | Identifikátor druhu operace
Název druhu operace | Název druhu operace

    Atributy tisku

    Základní údaje
Prezentace | Identifikátor prezentace procesu | SPPREZ_sp77id | C(6)
Název prezentace procesu | Název prezentace procesu | SPPREZ_sp77prezen | C(40)
Poznámka | Poznámka k prezentaci procesu | SPPREZ_sp77koment | M
Datum založení | Datum založení | SPPREZ_sp77datzal | T
Uživatel | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Prezentace | Identifikátor prezentace procesu | SPPREZPL_sp77id | C(6)
Komponenta | Identifikace komponenty | SPPREZPL_sp06idsubs | C(3)
Druh operace | Identifikátor druhu operace | SPPREZPL_sp07idtyp | C(6)
Pořadí | Pořadí operace v prezentaci | SPPREZPL_sp78poradi | N(5)
Operace z procesu | Prezentovat operaci přímo obsaženou v procesu | Výpočet | C(3)

    Viz.také

    Druhy operací | Komponenty


DYNAMICKÁ SPOJENÍ OPERACÍ

Popis

Je to nástroj, který umožňuje propojit nezávislé procesy (nezávisle zahájené, ale v určité fázi dochází k jejich interakci, tzn. mají společný uzel). Dynamické spojení je vytvořeno jako programový kód pro propojení:

¨ změny stavu peněz s platbou (Např. výpis z banky versus vystavená a přijatá faktura nebo také jejich úhrada pokladnou).

¨ vymáhání s platbou penalizační faktury (v praxi dosud neaplikováno)

Při definici jednotlivých dynamických spojení operací se uvádí:

¨ druh procesu, ve kterém se propojované procesy setkávají (např. proces PL-UP, který obsahuje operaci účetnictví, do které se jeden řádek transformuje z procesu platby předcházející PL-UP a druhý řádek z procesu výpisu z banky, který se dynamicky napojuje).

¨ druh operace tohoto druhu procesu, ve které se toto setkává

¨ transformace, která předplní data z operace dynamicky napojované

¨ rozlišení, pořadí - podobný význam jako u jiných vazeb v IS

Na záložce „aktivující operace“ se definuje seznam druhů operací, které se mohou dynamicky napojit do již zmíněného druhu operace (uvedeného na první záložce). U dynamického spojení ZSP - platby (zaúčtování platby) je to vždy druh operace z komponenty ZSP (změna stavu peněz). K bližšímu seznámení je vhodné nahlédnout do definic již existujících druhů procesů, které dynamické spojení operací využívají.

S dynamickou vazbou vždy souvisí určitá funkčnost komponenty, která je daná programovým kódem (např. ZSP - platby se aktivuje funkcí párování v komponentě změna stavu peněz).

Viz.také

ZSP - platby zaúčtování platby


ZSP - platby zaúčtování platby

Popis

Nastavení dynamického spojení operací, kde je umožněno automatické zaúčtování platby.

Datový model

  • SPTYPDSP Dynamické spojení operací
    • SPTYP Druh procesu/operace
    • SPTYPOD Druh operace v druhu procesu
      • SPTYP Druh procesu/operace (alias SPTYP2)

    • Formulář

    Formulář činnosti - Obecné předkontace
Mřížka [Dynamická spojení operací]
Druh procesu | Identifikátor druhu procesu
 | Název druhu procesu
 | Identifikace komponenty
Druh operace | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Název druhu procesu
Transformace | Tranformace mezi operacemi
Rozlišení vazby | Rozlišení vazby pro transformaci
Pořadí transf. | Pořadí transformace
Předkontace | Identifikace obecné předkontace
Listovací rámeček
Stránka #1 Dynamická spojení
Poznámka | Poznámka k dynamickému spojení operací
Stránka #2 Aktivující operace
Mřížka [Aktivující operace]
 | Identifikace komponenty
Druh operace | Identifikátor druhu operace
 | Název druhu operace

    Mřížka [Dynamická spojení operací] činnosti - Obecné předkontace

    Mřížka [Dynamická spojení operací] činnosti - Obecné předkontace
Druh procesu | Identifikátor druhu procesu
Název druhu procesu | Název druhu procesu

    Mřížka [Aktivující operace] činnosti - Obecné předkontace

    Mřížka [Aktivující operace] činnosti - Obecné předkontace
Operace | Identifikátor druhu operace
Komp. | Identifikace komponenty
Název druhu operace | Název druhu operace

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druhy operací | Přehled druhů operací
F2 | Komponenty | Číselník komponent
F2 | Obecné předkontace | Seznam obecných předkontací
F2 | Transformace | Přehled definovaných transfromací mezi komponentami

    Viz.také

    Druhy operací | Komponenty | Obecné předkontace | Transformace


Volné texty

Popis

Jedná se o uživatelsky volně definovatelné texty, které může uživatel využít v činnostech, které mají dostupný atribut TEXT a navíc i v činnostech, kde se uživatelsky modifikuje nebo nastavuje příkaz SELECT (např. doplňující vlastnosti formuláře, triggery, doplnění transformace, texty upomínek pro události vymáhání, importy - exporty apod.).

Výhodou tohoto nastavení pak je, že uživatel neopravuje použitý volný text v těchto činnostech, ale vždy na tomto místě a oprava textu se do těchto činností následně automaticky promítne.

Datový model

  • SPTEXTY Volný text k události
    • SPTEXTYN Obsah volného textu
    • SPSETV Technicko-věcný selektor

    • Formulář

    Formulář činnosti - ZSP - platby zaúčtování platby
Mřížka [Volné texty]
Listovací rámeček
Stránka #1 Volné texty
Text | Identifikace textu
 | Popis textu
Obsah textu | Obsah textu
Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Název technicko-věcného selektoru.
Poznámka | Poznámka
Stránka #2 Další
Kód | Kód v jazyce Foxpro volaný metodou TOOL.SPTEXTY_vrat_text
Přílohy mailu | Seznam souborů (obrázků) doplněných jako příhlohy mailu
Stránka #3 Texty v jazycích
Mřížka [Texty v jazycích]
Jazyk | Identifikace jazyka
Obsah textu | Obsah textu
Stránka #4 Výběr
Text | Identifikace textu
Popis | Popis textu
Tech. sel. | Identifikátor technicko-věcného selektoru.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Volné texty] činnosti - ZSP - platby zaúčtování platby

    Mřížka [Volné texty] činnosti - ZSP - platby zaúčtování platby
Text | Identifikace textu
Popis | Popis textu

    Mřížka [Texty v jazycích] činnosti - ZSP - platby zaúčtování platby

    Mřížka [Texty v jazycích] činnosti - ZSP - platby zaúčtování platby
Text | Identifikace textu
Jazyk | Identifikace jazyka

    Atributy tisku

    Základní údaje
Text | Identifikace textu | SPTEXTY_sp88id | C(6)
Popis | Popis textu | SPTEXTY_sp88text | C(40)
Obsah textu | Obsah textu | SPTEXTYN_sp89obsah | M
Tech. sel. | Identifikátor technicko-věcného selektoru. | SPTEXTY_sp20idzak | C(9)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(60)
Poznámka | Poznámka | SPTEXTY_sp88koment | M

    Při pohybu v Texty v jazycích
Jazyk | Identifikace jazyka | SPTEXTYN2_sp38id | C(3)
Obsah textu | Obsah textu | SPTEXTYN2_sp89obsah | M


Konstanty

Popis

Při aktivaci této činnosti má uživatel nejprve k dispozici záložku „Výběr“, kde může definovat množinu následujících zobrazených údajů.

Jedná se o uživatelsky volně definovatelné konstanty, které může uživatel využít v činnostech, kde se uživatelsky modifikuje nebo nastavuje příkaz SELECT (např. doplňující vlastnosti formuláře, triggery, doplnění transformace, importy - exporty apod.).

Výhodou tohoto nastavení pak je, že uživatel neopravuje použitou definici konstanty v těchto jednotlivých činnostech, ale vždy na tomto místě a oprava konstanty se do těchto činností následně automaticky promítne.

Datový model

  • SPKONST Konstanty transformací a šablon

    • Formulář

    Formulář činnosti - ZSP - platby zaúčtování platby
Mřížka [Konstanty]
Listovací rámeček
Stránka #1 Konstanty
Konstanta | Identifikace konstanty
IDÚ | Identifikace datového úložiště
 | Název konstanty
Hodnota | Hodnota konstanty
Poznámka | Poznámka ke konstantě
Stránka #2 Výběr
Konstanta | Identifikace konstanty
IDÚ | Identifikace datového úložiště číselné řady procesu
Název konstanty | Název konstanty
Hodnota | Hodnota konstanty
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Konstanty] činnosti - ZSP - platby zaúčtování platby

    Mřížka [Konstanty] činnosti - ZSP - platby zaúčtování platby
Konstanta | Identifikace konstanty
Název konstanty | Název konstanty
Hodnota | Hodnota konstanty

    Atributy tisku

    Základní údaje
Konstanta | Identifikace konstanty | SPKONST_sp73id | C(10)
IDÚ | Identifikace datového úložiště číselné řady procesu | SPKONST_sp33cisdpm | C(2)
Název konstanty | Název konstanty | SPKONST_sp73nazkon | C(40)
Hodnota | Hodnota konstanty | SPKONST_sp73hodnot | C(40)
Poznámka | Poznámka ke konstantě | SPKONST_sp73koment | M


Procesní importy

Popis

Procesní import je nástroj pro spouštění importů událostí komponent s automatizovaným založením procesu, resp. založením událostí v operacích existujících procesů na základě importovaných dat. Přitom se mohou importovaná data automaticky rozpadat do událostí většího počtu operací. Jedná se tedy o import dat, při kterém dochází k založení celé řady nových fyzických procesů, resp. k napojení (spuštění, naplnění událostmi) operace do celé řady různých fyzických procesů, čímž se řadí mezi dávková zpracování dat. U každého procesního importu se nastavují tyto atributy:

¨ název a druh daného procesního importu (k druhu importu je možno nastavit přístupová práva, právem zápis má uživatel povoleno import vytvářet, právem čtení má právo ho spouštět)

¨ proces - identifikace druhu procesu, kterého se procesní import týká, tzn. který bude procesním importem založen nebo se na něj napojujeme

¨ operace - identifikace komponenty a druhu uzlu (u většiny způsobů založení se zde zadává identifikace uzlu typu proces, pouze u způsobu založení typu „existující proces s EI“ se zde zadává uzel typu operace), který se procesním importem spouští. Číslo za uzlem (operací) určuje pořadí operace stejného druhu, tzn. že ve většině případů zde bude číslo 1, pouze pokud by stejný druh operace byl v daném procesu použit několikrát, je nutno tímto pořadím určit, který se má spouštět.

¨ I-E - definice importu pro import dat do událostí operace dané komponenty

¨ založení - způsob, jakým má být výše uvedený proces vytvořen

a.) nový proces - procesní import založí naprosto nový proces (s identifikací podle číselné řady druhu procesu), jako kdyby se zakládal z menu NOVÝ PROCES

b.) nový proces podle záložky - předpokládá se existence jediného aktuálního fyzického uzlu (typu proces) se záložkou s adresátem (který se do ní dostal při založení procesu). Do tohoto uzlu se napojí nově zakládaný proces importem a vyhledá tento uzel (napojovací bod) dle id adresáta, tj. id na záložce = id adresáta současně "vypočtené" z importovaných dat. Pokud takovýto uzel neexistuje, IS nahlásí před rozběhnutím procesního importu zprávu, že neexistuje potřebná záložka adresáta a import nespustí. V případě spouštění se nově vzniklý proces ukládá do zmíněného uzlu se záložkou.

c.) nový proces - napojení - procesní import vytvoří nový proces s napojením do výše uvedeného procesu, dle výrazů - rok, IDU, číslo, pořadí zadaných na záložce výrazy je vyhledán uzel (napojovací bod), do kterého je nový proces napojen. Mezi všemi procesy odpovídajícího hlavního procesu je tedy vyhledán ten, který ve svém diagramu obsahuje uzel typu proces s druhem procesu procesního importu a v něm založí nový proces. Identifikátory procesu se pro tento způsob založení automaticky stávají součástí rozpadu událostí do operací.

d.) nový proces s EI (externí identifikací) - předpokládá se implementace cizího IS se shodným číslováním procesů jako v IS BM (tj. určitá simulace replikací), pak je takovýmto importem založen nový proces (jako způsob založení z menu Nový proces), ale jeho identifikace je převzata z importovaných dat (a to z výrazů, které jsou definovány na záložce výrazy). Pozor - v číslování procesů mohou nastat nesrovnalosti v číselných řadách (díry), pokud je připouští externí data a definice importu.

e.) existující proces s EI (externí identifikací) - v tomto případě nedochází k založení nového procesu (oproti všem předchozím případům), ale pouze k zápisu událostí do některé neukončené operace již existujícího procesu, tzn. systém vyhledá proces s identifikátory podle importovaných dat (vyhodnocením výrazů na záložce výrazy) a v něm neukončenou operaci druhu uvedeného v definici procesního importu a do této operace importu události.

f.) nový proces - možné napojení - kombinace způsobu založení „nový proces s EI“ a „nový proces - napojení“. V případě takto nastaveného procesního importu systém nejprve zkoumá, zda existuje proces s neukončenou operací do kterého by se zapsal, pokud takový nenajde, vytvoří se nový proces s napojením do výše uvedeného procesu.

¨ spustit operaci na pozadí - zde uvedenou hodnotou je pro daný proces naplněn atribut spouštět (ve vlastnostech uzlu), tj. úvodní operace importu bude probíhat na pozadí

¨ zobrazit v menu - daný procesní import se nabízí v hlavním menu v činnosti Import do procesu (odtud je možno procesní import aktivovat)

¨ CID - tento atribut je určen pouze k využití programovým kódem, který formuluje implementátor, např. v doplňujících vlastnostech formuláře, v informačních panelech apod. V použitých činnostech musí být zapsán v tomto tvaru:

do spcallpi with ‘CID’

Tím je nadefinována hlavička procesního importu. Na záložce „výrazy“ se definují jednotlivé výrazy, které systém při provádění procesního importu používá:

¨ rozpad - dle tohoto klíče dojde k rozpadu cizích (tj. zdrojových) dat na jednotlivé procesy v IS BM (nemá smysl u založení typu "existující proces s EI"), současně dochází k automatickému rozpadu (ve variantách typu "napojení")

¨ jednoznačná identifikace - identifikace podle které se při opakovaném spuštění procesního importu rozlišují „cizí“ data na již importovaná a na data, která budou importována (v případě storna procesu založeného procesním importem se tento stále chová jako již importovaný. Pokud jej chceme znovu importovat, je nutno pozměnit definici této jednoznačné identifikace - změněný atribut musí být zapsán v uvozovkách). Jednoznačná identifikace tedy zcela jednoznačně identifikuje skupinu záznamů importovaných dat odpovídajících jediné fyzické operaci v IS BM. V přehledu fyzických operací se zobrazuje na úvodní záložce s návěštím „externí ID“. Užití výrazu jednoznačné identifikace zabraňuje opakovanému importu stejných dat. Výraz se automaticky stává součástí klíče rozpadu událostí do operací. Největší možná délka externí identifikace je 20 znaků.

¨ výrazy (rok, IDÚ, číslo, pořadí) - používají se při napojení do procesu pomocí EI a "napojení", definují napojovací bod - identifikaci procesu (operace) pro napojení (tzn. při napojení k již existujícímu procesu).

¨ rok - výraz pro určení roku identifikace procesu. Je povinný pro způsob založení procesního importu c.), d.), e.) a f.)

¨ IDÚ - výraz pro určení identifikace datového úložiště identifikace procesu. Je povinný pro způsob založení procesního importu c.), d.), e.) a f.)

¨ číslo - výraz pro určení čísla procesu identifikace procesu. Je povinný pro způsob založení procesního importu c.), d.), e.) a f.)

¨ pořadí - výraz pro určení pořadí operace identifikace procesu. Jediný numerický - obvykle 1. Je povinný pro způsob založení procesního importu c.), d.), e.) a f.)

Datový model

  • SPIMPP Procesní import
    • SPTYPOD Druh operace v druhu procesu
    • SPIMP Definice importu/exportu
    • SPIMPD Druh importu
      • SPPRISTU Přístupové právo uživatele k věci
    • BWUZIVAT Uživatel systému
    • SPTYP Druh procesu/operace
    • SPTYP Druh procesu/operace (alias SPTYP2)

    • Formulář

    Formulář činnosti - Diagram procesu
Mřížka [Procesní importy]
Název | Název procesního importu
Listovací rámeček
Stránka #1 Procesní importy
Druh | Identifikace druhu importu-exportu
 | Název druhu importu-exportu
Proces | Identifikátor druhu procesu
 | Název druhu procesu
 | Identifikace komponenty
Operace | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Název druhu operace
I-E | Identifikace importu-exportu
 | Název importu-exportu
Založení | Způsob založení operace
Spustit operaci na pozadí | Spustit operaci na pozadí
Zobrazit v menu | Zobrazit procesní import v menu
CID | Identifikace importu pro volání prostředky BM
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Poznámka | Poznámka
Stránka #2 Výrazy
Rozpad | Výraz rozpadu na procesy
Jedn.id. | Výraz jednoznačné identifikace operace
Rok | Výraz identifikace roku pro napojení do procesu
IDÚ | Výraz identifikace IDÚ pro napojení do procesu
Číslo | Výraz identifikace čísla procesu pro napojení do procesu
Pořadí | Výraz identifikace pořadí pro napojení do procesu

    Mřížka [Procesní importy] činnosti - Diagram procesu

    Mřížka [Procesní importy] činnosti - Diagram procesu
Název | Název procesního importu
Proces | Identifikátor druhu procesu
Operace | Identifikátor druhu operace
Komponenta | Identifikace komponenty

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Konverze atributů | Definování konverzí atributů
F7 | Prohlížení importovaných dat | Prohlížení importovaných-exportovaných dat
F9 | Spustit procesní import | Spustit procesní import
- | Diagram procesu | Zobrazení diagramu procesu
F2 | Definice importu/exportu | Definice importu nebo exportu dat
F2 | Druhy importů-exportů | Seznam druhů importů-exportů
F2 | Druhy procesů | Přehled druhů procesů
F2 | Výraz | Tvorba výrazu tvůrcem výrazů

    Viz.také

    Konverze atributů | Prohlížení importovaných dat | Spustit procesní import | Diagram procesu | Definice importu/exportu | Druhy importů-exportů | Druhy procesů | Výraz


Obecné předkontace

Popis

Při aktivaci této činnosti má uživatel nejprve k dispozici záložku „Výběr“, kde může definovat množinu následujících zobrazených údajů.

Obecná předkontace je činnost IS Bílý Motýl dostupná ve složce informační centrum, která umožňuje definovat obecné dvourozměrné tabulky a ty plnit definičními daty.

Vlastností obecné předkontace je dále možnost stanovit, že jedním rozměrem definované tabulky je ID adresáta. V tomto případě je obecná předkontace dostupná i z adresáře (menu Volby - činnost „předkontace adresáta“ nebo klávesa F7), kde se zobrazí všechny předkontace adresáta.

Oblasti možného využití obecné předkontace:

¨ obecné výběry,

¨ maska operace,

¨ šablony, transformace ve vazbě uzlů,

¨ výběry ve slovníku dat,

¨ výstupy,

¨ dle potřeby implementátora v těch místech IS, kde má možnost užít příkaz SELECT (např. sestavy, obecné výběry, …).

Výsledkem (vyhodnocením obecné předkontace) je hodnota přiřazená k významu. Syntaxe (způsob zápisu) použití má obvykle tvar: „#P <výraz1>;<výraz2>“ (výraz 1 je identifikace předkontace, výraz 2 je význam), kde <výraz x> je v daném okamžiku vyhodnotitelný výraz ve formátu FoxPro, např. (~#P 'FP-028';'IDU'+RIGHT(tool.user,2)).

Na formuláři obecné předkontace se u každé předkontace na záložce „obecné předkontace“ definuje její identifikace a název. U každé obecné předkontace se uvádí i její druh, který určuje přístupová práva uživatelů (žádné/čtení/zápis). Zaškrtávátko „předkontace adresáta“ určuje ty předkontace, které jsou spojeny s adresátem. Na záložce „položky obecné předkontace“ se definují atributy význam a hodnota.

Datový model

  • SPPREDK Obecná předkontace
    • SPPREDKD Druh obecné předkontace
      • SPPRISTU Přístupové právo uživatele k věci

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druh obecné předkontace | Druh obecné předkontace
F2 | Komponenty | Číselník komponent
F2 | Významy položek předkontací | Seznam významů položek obecných předkontací

    Formulář

    Formulář činnosti - Druh obecné předkontace
Mřížka [Obecné předkontace]
Předkontace | Identifikace obecné předkontace
 | Název obecné předkontace
Listovací rámeček
Stránka #1 Obecné předkontace
Druh | Identifikátor druhu obecné předkontace
Předkontace adresáta | Předkontace spojená s adresátem
Poznámka | Poznámka k obecné předkontaci
Stránka #2 Položky obecné předkontace
Mřížka [Položky obecné překontace]
Význam | Identifikace významu položky obecné předkontace
Platnost od | Datum platnosti položky obecné předkontace od
 | Popis významu položky obecné předkontace
Hodnota | Hodnota položky překontace
Poznámka | Poznámka k položce předkontace
Stránka #3 Výběr
Předkontace | Identifikace obecné předkontace
Název předkontace | Název obecné předkontace
Druh | Identifikátor druhu obecné předkontace
Předkontace adresáta | Předkontace spojená s adresátem
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Obecné předkontace] činnosti - Druh obecné předkontace

    Mřížka [Obecné předkontace] činnosti - Druh obecné předkontace
Předkontace | Identifikace obecné předkontace
Název předkontace | Název obecné předkontace
Druh | Identifikátor druhu obecné předkontace
Název druhu | Název druhu obecné předkontace

    Mřížka [Položky obecné překontace] činnosti - Druh obecné předkontace

    Mřížka [Položky obecné překontace] činnosti - Druh obecné předkontace
Význam | Identifikace významu položky obecné předkontace
Platnost od | Datum platnosti položky obecné předkontace od
Hodnota | Hodnota položky překontace
Popis významu | Popis významu položky obecné předkontace

    Atributy tisku

    Základní údaje
Předkontace | Identifikace obecné předkontace | SPPREDK_sp19id | C(6)
Název předkontace | Název obecné předkontace | SPPREDK_sp19nazpre | C(40)
Druh | Identifikátor druhu obecné předkontace | SPPREDK_spe1id | C(6)
Název druhu | Název druhu obecné předkontace | SPPREDKD_spe1nazdru | C(40)
Předkontace adresáta | Předkontace spojená s adresátem | Výpočet | C(3)
Poznámka | Poznámka k obecné předkontaci | SPPREDK_sp19koment | M
Popis významu | Popis významu položky obecné předkontace | SPPREDKV_sp47nazvyz | C(40)
Poznámka | Poznámka k významu položky obecné předkontace | SPPREDKV_sp47koment | M

    Při pohybu v Položky předkontace
Význam | Identifikace významu položky obecné předkontace | SPPREDKP_sp47id | C(6)
Platnost od | Datum platnosti položky obecné předkontace od | SPPREDKP_sp23datpla | D
Hodnota | Hodnota položky překontace | SPPREDKP_sp23hodnot | M
Poznámka | Poznámka k položce předkontace | SPPREDKP_sp23koment | M

    Viz.také

    Druh obecné předkontace | Komponenty | Významy položek předkontací


Externí příkazy

Popis

Po aktivaci činnosti se jako první zobrazí uživateli záložka „výběr“, kde si může zvolit, které externí příkazy chce mít k dispozici. Může nechat výběr prázdný a zapsat a poté má k dispozici všechny nadefinované externí příkazy nebo si může zvolit různá výběrová hlediska (např. dle popisu, druhu, kategorie, typu, PID apod.).

Umožňuje nadefinovat externí příkazy, které pak uživatel může aktivovat z hlavního menu z činnosti "spuštění externího příkazu". U každého externího příkazu se zadává:

¨ popis - tzn. název externího příkazu

¨ verze – číslo verze, datum její aktualizace a identifikace uživatele, který změnu provedl

¨ druh - identifikace druhu externího příkazu

¨ Ktg. – identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu

¨ typ - může být Windows/Dos, FoxPro, Script Foxpro, Script Foxpro kompilovaný. Kódem externích příkazů s typem „Script Foxpro kompilovaný“ je možné vytvářet objekty, které po provedení kódu nezanikají. Objekty vytvářené typem „Script Foxpro“ vyvolaným příkazem Foxpro EXECSCRIPT po ukončení skriptu zanikají. Typ externího příkazu „Script Foxpro kompilovaný“ není prováděn příkazem Foxpro EXECSCRIPT, ale je zkompilován a následně je spuštěn zkompilovaný program (tj. soubor s příponou FXP). Tímto způsobem je možné udělat např. formulář, který zůstane na obrazovce až do ukočení programu a je možné se přitom přepínat mezi ním a jinými běžnými formuláři BM.

¨ skrytý - Ano/Ne - při nastavení Ano potlačuje zobrazování externího příkazu v hlavním menu programu

¨ pro vazbu – Ano/Ne – zda je určen pro volání z vazby externího příkazu

¨ programová identifikace - umožňuje vyvolávat externí příkazy ze skriptů - voláním programu SPCALEXT - např. _promenna=SPCALEXT('PRGID')

¨ příkaz - vlastní popis příkazu (definice cesty, souboru, název exe.souboru apod.) - platí pro příkazy typu Windows/Dos a FoxPro

¨ kód - víceřádkový popis kódu - platí pro příkaz typu Script Foxpro a Script Foxpro kompilovaný.

Externím příkazem může být také skript v jazyce FoxPro.

Příklad:

* Výsledkem volání kódu je zobrazení formuláře na obrazovce

* Ale pouze pro typ externího příkazu 'Script Foxpro - kompilovaný' tento formulář bezprostředně po provedení kódu nezanikne

LOCAL _o

_o=CREATEOBJECT('xform')

_o.show

* metoda objektu TOOL - ADD_USER_WINDOW - uchovává odkaz na objekt _O v rámci atributů objektu TOOL

* jinak by objekt _O zanikl po ukončení kódu v každém případě

tool.add_user_window(_o)

define class xform as form

enddefine

Na záložce Popis verzí příkazu má uživatel k nahlédnutí všechny změny, které se týkají daného externího příkazu.

Datový model

  • SPEXTPR Externí příkaz
    • SPEXTPRD Druh externího příkazu
      • SPPRISTU Přístupové právo uživatele k věci
    • BWUZIVAT Uživatel systému
    • SPCINDVK Kategorie doplňující vlastnost formuláře/knihovny vkládaného kódu

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Editovat kód vlastnosti | Editovat kód vlastnosti
F6 | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností
F9 | Spustit externí příkaz | Spustit externí příkaz
- | Kontrolní kompilace | Kontrolní kompilace
F2 | Druhy externích příkazů | Seznam druhů externích příkazů
F2 | Externí příkazy | Seznam externích příkazů
F2 | Kategorie doplňující vlastnosti/knihovny | Kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu

    Formulář

    Formulář činnosti - Kategorie doplňující vlastnosti/knihovny
Mřížka [Externí příkazy]
Popis | Popis externího příkazu
Listovací rámeček
Stránka #1 Externí příkazy
Verze | Verze externího příkazu
Změnil | Jméno uživatele systému, který změnil záznam
Aktualizace | Datum aktualizace
Druh | Identifikace druhu externího příkazu
Ktg. | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
Typ | Typ externího příkazu
Skrytý | Skrytý externí příkaz nezobrazovaný v menu
Pro vazbu | Určen pro volání z vazby externího příkazu Ano/Ne
PID | Identifikace pro programové volání
Příkaz | Externí příkaz
Kód | Kód scriptu externího příkazu
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Poznámka | Poznámka k externímu příkazu
Stránka #2 Vazby externího příkazu
Mřížka [Vazby externího příkazu]
Popis | Jednoznačná časová identifikace externího příkazu ve vazbě
Pořadí | Pořadí v nabídce
Druh | Identifikace druhu externího příkazu
Poznámka | Poznámka
Stránka #3 Popis verzí příkazu
Mřížka [Popis verzí příkazu]
Verze | Verze externího příkazu
Aktualizace | Datum aktualizace
Popis | Popis verze
Dne | Datum záznamu o verzi
Popsal | Jméno uživatele systému, který změnil záznam
Stránka #4 Výběr
Popis | Popis externího příkazu
Druh | Identifikace druhu externího příkazu
Kategorie | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
Typ | Typ externího příkazu
Skrytý | Skrytý externí příkaz nezobrazovaný v menu
Pro vazbu | Určen pro volání z vazby externího příkazu Ano/Ne
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Externí příkazy] činnosti - Kategorie doplňující vlastnosti/knihovny

    Mřížka [Externí příkazy] činnosti - Kategorie doplňující vlastnosti/knihovny
Popis | Popis externího příkazu
Typ | Typ externího příkazu
Druh | Identifikace druhu externího příkazu
Název druhu | Název druhu externího příkazu
Příkaz | Externí příkaz
Verze | Verze externího příkazu
Aktualizace | Datum aktualizace

    Mřížka [Vazby externího příkazu] činnosti - Kategorie doplňující vlastnosti/knihovny

    Mřížka [Vazby externího příkazu] činnosti - Kategorie doplňující vlastnosti/knihovny
Pořadí | Pořadí v nabídce
Popis | Popis externího příkazu

    Mřížka [Popis verzí příkazu] činnosti - Kategorie doplňující vlastnosti/knihovny

    Mřížka [Popis verzí příkazu] činnosti - Kategorie doplňující vlastnosti/knihovny
Verze | Verze externího příkazu
Dne | Datum záznamu o verzi
Popsal | Jméno uživatele systému, který změnil záznam

    Atributy tisku

    Základní údaje
Popis | Popis externího příkazu | SPEXTPR_sp48popis | C(40)
Typ | Typ externího příkazu | Výpočet | C(27)
Druh | Identifikace druhu externího příkazu | SPEXTPR_sp49id | C(6)
Název druhu | Název druhu externího příkazu | SPEXTPRD_sp49nazdru | C(40)
Kategorie | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu | SPEXTPR_spc1id | C(6)
Název kategorie | Název kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu | SPCINDVK_spc1nazkat | C(40)
Skrytý | Skrytý externí příkaz nezobrazovaný v menu | Výpočet | C(3)
Pro vazbu | Určen pro volání z vazby externího příkazu Ano/Ne | Výpočet | C(3)
PID | Identifikace pro programové volání | SPEXTPR_sp48prgid | C(6)
Příkaz | Externí příkaz | SPEXTPR_sp48prikaz | C(80)
Kód | Kód scriptu externího příkazu | SPEXTPR_sp48kod | M
Poznámka | Poznámka k externímu příkazu | SPEXTPR_sp48koment | M
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | SPEXTPR_sp00datzap | T
Aktualizace | Datum aktualizace | SPEXTPR_sp00datakt | T
Změnil | Jméno uživatele systému, který změnil záznam | SPEXTPR_sp00jmeakt | C(40)
Popis | Popis externího příkazu | SPEXTPR2_sp48popis | C(40)

    Při pohybu v Vazby externího příkazu
Poznámka | Poznámka | SPEXTPRV_spd8koment | M
Pořadí | Pořadí v nabídce | SPEXTPRV_spd8porad | N(3)

    Při pohybu v Popis verzí
Verze | Verze externího příkazu | SPEXVPR_sp48verze | N(6,3)
Popis | Popis verze | SPEXVPR_spg5koment | M
Dne | Datum záznamu o verzi | SPEXVPR_spg5dne | D
Popsal | Jméno uživatele systému, který změnil záznam | SPEXVPR_sp00jmeakt | C(40)

    Viz.také

    Editovat kód vlastnosti | Knihovny vkládaného kódu | Spustit externí příkaz | Kontrolní kompilace | Druhy externích příkazů | Kategorie doplňující vlastnosti/knihovny


Doplňující vlastnosti formuláře

Popis

Pod pojmem formulář je možno si představit každou aktuálně spuštěnou činnost zobrazenou v okně. U vybraných komponent jsou doplňující vlastnosti formuláře dostupné pod menu Obecné. Doplňující vlastnosti formuláře umožňují přidat k činnostem vlastní položky menu nebo automaticky vyvolat (při otevření formuláře) spuštění předlohy výstupu, volné karty , kódu Foxpro nebo umožňují přidat do mřížky formuláře nový sloupec. Definování doplň. vlastností formuláře patří k „nejodbornějším“ prvkům IS BM, některé provedené změny mohou vyvolat nevratné změny nebo dokonce ztrátu dat, tudíž vyžaduje dobrou znalost IS.

Při definování doplňujících vlastností formuláře uživatel zadává:

¨ činnost – předplní se automaticky číslo tabulky činnosti

¨ vlastnost – identifikace a název vlastnosti

¨ verze – číslo verze, datum její aktualizace a identifikace uživatele, který změnu provedl

¨ druh – právy k druhu je možné omezit automatické vyvolání druhu vlastnosti pro vybrané uživatele. Pro to, aby se akce vlastnosti provedla, musí mít aktuální uživatel k jejímu druhu právo alespoň "čtení". Uživatel s právem "zápis" může vytvářet doplňující vlastnosti daného druhu.

¨ kategorie – identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu

¨ menu – zařadit do menu - ano/ne

¨ řez písma položky menu – možnosti normální/kurzíva/tučné/tučná kurzíva – označení dané položky menu zvoleným stylem písma (při zvolení např. tučná kurzíva dojde v menu Volby k odlišení běžných činností od činností vyvolaných doplňující vlastností formuláře)

¨ klávesa - při doplnění menu formuláře je možné určit CTRL - klávesu pro vyvolání odpovídající funkce. Je možné zadat písmeno nebo funkční klávesu F1 až F12. Pro vytváření uživatelských nabídek (toolbarů) je vhodné uvádět pro ekvivalentní doplňující vlastnosti různých formulářů stejnou identifikaci.

¨ stat. podm. – statická podmínka zařazení do menu - vyhodnocuje se v okamžiku vytváření menu. Např.:

- v událostech vymáhání lze pomocí F6 spustit události plateb za statické podmínky, že charakter operace je běžná -thisform.komp_stav AND thisform._o_kompo_.sp07charak=1

- v uživatelích programu je viditelná činnost inicializace hesla jen pokud se jedná o uživatele správce - tool.spravce()

- dotaz na existenci souboru – FILE (‘nazev souboru’)

¨ dyn. podm. – dynamická podmínka zařazení do menu – vyhodnocuje se až v okamžiku, kdy je menu vytvořené. Např.:

- činnost Karta pracovníka může přes Volby spustit činnost Další informace. Dynamická podmínka ale říká, že to lze spustit jen pokud je kurzor umístěn na záložce Pracovní poměry – thisform._PF_activepage=thisform._PF_.p4.pageorder

- v činnosti Adresář lze spustit činnost Adresy, jen pokud stojím na příslušné záložce – thisform._PF_.activepage=thisform._PF_.p4.pageorder

- v činnosti Adresář lze spustit činnost předkontace adresáta jen pokud je kurzor umístěn na určitém adresátovi - !EOF(‘$$$’)

- v činnosti Adresář lze spustit cenové skupiny adresáta jen pokud je kurzor umístěn na určitém adresátovi - !EOF(‘$$$’)

¨ automaticky – ano/ne – akci specifikovanou doplňující vlastností formuláře je možné vyvolat automaticky při spuštění formuláře. Pro formuláře událostí komponent je možné omezit vyvolání této akce na vybrané operace.

¨ pořadí – pořadí provádění akce doplňující vlastnosti činnosti

¨ typ – může nabývat hodnot – spustit předlohu výstupu, spustit kód, spustit volnou kartu, doplnit mřížku formuláře, spustit kompilovaný kód.

- Pokud vlastnost určuje akci vyvolání metapředlohy výstupu je možné určit pro formuláře událostí komponent vyvolání metapředlohy výstupu dokladu procesu nebo dokladu nadřízeného procesu. V takovém případě není určení metapředlohy výstupu (MPV) povinné, vyvolá se metapředloha uvedená u odpovídajícího druhu procesu.

- Objekty vytvářené skriptem vyvolaným příkazem Foxpro EXECSCRIPT (typ spustit kód) po ukončení skriptu zanikají.

- Pokud vlastnost určuje akci vyvolání volné karty je možné určit pro formuláře událostí komponent vyvolání volné karty procesu, operace nebo volné karty adresáta. V takovém případě není určení volné karty povinné, vyvolá se volná karta odpovídajícího druhu operace resp. procesu (nebo adresáta – zde program nemůže provádět kontrolu, zda je možné pro daný formulář volnou kartu adresáta použít, tzn. je-li adresát obsažen na první záložce formuláře – musí ohlídat uživatel, jinak užití takto nadefinované DVF bude generovat chybu).

- Pokud vlastnost určuje akci doplnění mřížky formuláře je možné určit pro formuláře událostí komponent vyvolání doplnění mřížky.

- Kódem externích příkazů s typem „spustit kompilovaný kód“ je možné vytvářet objekty, které po provedení kódu nezanikají. Kód tohoto typu není prováděn příkazem Foxpro EXECSCRIPT, ale je zkompilován a následně spuštěn zkompilovaný program (soubor s příponou FXP). Takto je např. možno vytvořit formulář, který zůstane na obrazovce až do ukončení programu a je možné se přitom přepínat mezi ním a jinými běžnými formuláři BM. Další možné využití tohoto typu DVF je v souvislosti s připojováním metod k objektům formuláře (BINDEVENT) bez použití objektu BWSCRIPT.

Příklad:

* Výsledkem volání kódu je zobrazení formuláře na obrazovce

* Ale pouze pro typ externího příkazu 'Script Foxpro - kompilovaný' tento formulář bezprostředně po provedení kódu nezanikne

LOCAL _o

_o=CREATEOBJECT('xform')

_o.show

* metoda objektu TOOL - ADD_USER_WINDOW - uchovává odkaz na objekt _O v rámci atributů objektu TOOL

* jinak by objekt _O zanikl po ukončení kódu v každém případě

tool.add_user_window(_o)

define class xform as form

enddefine

Na záložce "omezení pro operace" se uvádí seznam operací v procesech, při jejichž spuštění se má požadovaná akce vykonat. Uvedení druhu procesu "-" znamená, že se akce vyvolá pro daný druh operace v libovolném druhu procesu. Kromě toho je možné určit podmínku, v jakém stavu "připravena","zahájena" nebo "ukončena" se daná operace musí nacházet.

Na záložce „popis verzí vlastnosti“ je k dispozici informace o založení verze DVF (datum, číslo, kdo ji založil) a dalších případných změnách.

Příklady praktického užití:

Doplňující vlastnost formuláře může definovat vyvolání programového kódu Foxpro. V textovém poli "kód" je možné zadat plnohodnotný program v jazyce Foxpro, který je možné snáze upravovat v editoru po stisku klávesy F5. Do kódu je automaticky přidán prvý řádek:

LPARAMETERS _this,

kterým je mu předán objekt formuláře, ze kterého byl vyvolán.

Do kódu je možné vkládat opakovaně použitelné části použitím klausule:

#INCLUDE <identifikace vkládaného kódu>.

Formulář pro vstup vkládaných kódů se vyvolává z formuláře doplňujících vlastností formuláře klávesou F6. Přístup k položkám vkládaných kódů je také chráněn jejich druhem a jejich kód je také možné upravovat v editoru po klávese F5. Ve vkládaném kódu může být uvedena klausule #INCLUDE, která do něho zařadí jiný vkládaný kód. Bylo vytvořeno i řešení podporující vytváření výstupu do HTML, které plně využívá výhod objektového programování. Sestává ze dvou základních "vkládaných kódů" (dále knihoven).

Knihovna SYSHTM definuje třídu, která slouží k vytváření obsahu HTML souboru.

Knihovna SYSPRC definuje třídu, pro usnadnění práce s operací v procesu.

To, jakým způsobem je možné jednoduše vytvářet přehledy zobrazované ve webovém prohlížeči je patrné v následujícím příkladu, který vytvoří přehled událostí obchodu v nadřízeném procesu k události.

LOCAL _o,_o2

* založíme objekt pro orientaci v procesech podle definice třídy v knihovně SYSPRC (viz.#INCLUDE na konci)

_o2=CREATEOBJECT('bm_code_sysprc',_this)

* založíme objekt pro vytváření souboru HTML podle definice třídy v knihovně SYSHTM (viz.#INCLUDE na konci)

_o=CREATEOBJECT('bm_code_syshtm')

* výstupní sestava bude mít titul 'Moje sestava'

_o.settitle('Moje sestava')

* vytvoříme hlavičku souboru HTML

_o.genheader

* do textu vložíme nadpis 'QUICK INFO'

_o.gentag_h2('QUICK INFO',.T.)

* budeme vytvoříme tabulku - tu je třeba inicializovat

_o.table_reset

* připravíme data pro naplnění tabulky

* metoda opendata vrací TRUE, když úspěšný dotaz vrátil alespoň jeden řádek

* všimněte si použití objektu _O2 při sestavování dotazu

IF _o.opendata([select obudal.ad01id,adadsat.ad01adsat,obudal.ob02dat,obudal.ob02datdod,]+;

[obudal.sp61id,obudal.sp60id,spartikn.sp62artikl,obudal.ob02mn,]+;

[obudal.ob02cj01c,obudal.dp02czazm,obudal.dp02cdpzm,obudal.dp02czarm,obudal.dp02cdprm,]+;

[obudal.oc01id,obudal.dp02sazba]+;

[ from %%%.obudal,%%%.spartikn,%%%.adadsat where ]+;

_o2.filter('OBUDAL',.T.)+;

[ and spartikn.sp61id=obudal.sp61id]+;

[ and spartikn.sp60id=obudal.sp60id]+;

[ and spartikn.sp38id=?tool.jazyk

]+;

[ and adadsat.ad01id=obudal.ad01id])

* do prvého sloupce tabulky bude vkládán obsah podle výrazu "sp61id+'-'+sp60id" a bude mít nadpis "Artikl"

_o.table_addcol([sp61id+'-'+sp60id],'Artikl')

* podobně

_o.table_addcol([sp62artikl],'Název artiklu')

* podobně + navíc je určeno, že číslo má mít formát 20,2

_o.table_addcol([ob02mn],'Množství',20,2)

_o.table_addcol([ob02cj01c],'CJ',20,2)

* sloupce s cizí měnou má smysl vytvářet, pokud jsme neobchodovali v korunách

IF _o.getvalue([oc01id])<>'CZK'

_o.table_addcol([dp02czazm+dp02cdpzm],'Cena ZM',20,2)

_o.table_addcol([oc01id],'Měna')

ENDIF

* pro tento sloupec budeme chtít celkový součet

_o.table_addcol([dp02czarm],'Základ DPH',20,2,.t.)

_o.table_addcol([dp02sazba],'%')

_o.table_addcol([dp02cdprm],'DPH',20,2)

_o.table_addcol([dp02czarm+dp02cdprm],'Cena Kč',20,2,.t.)

* gentableheader - vytváří hlavičku tabulky s nadpisy sloupců v tomto případě navíc s jedním hlavičkovým řádkem

_o.gentableheader(" 'Obchod - '+dtoc(ob02dat)+' ['+ad01id+'] - '+alltrim(ad01adsat) ")

* gentable - vygeneruje tabulku s daty dotazu metody OPENDATA na základě definic sloupců (TABLE_ADDCOL)

_o.gentable

* gentablefooter - vygeneruje koncovou značku tabulky

_o.gentablefooter

ENDIF

* genfooter - vygeneruje koncové značky HTML dokumentu

_o.genfooter

* show - zobrazí dokument v interním HTML prohlížeči BM

* metoda LABEL objektu _O2 vrátí identifikaci procesu, kterou metoda SHOW zobrazí v nadpisu okna

_o.show(_o2.label(.T.))

* klausule #INCLUDE připojí knihovnu SYSHTM, která obsahuje deklaraci třídy objektu "bm_code_syshtm"

* knihovnu SYSPRC, která obsahuje deklaraci třídy objektu "bm_code_sysprc" není třeba připojovat (tu si připojuje SYSHTM)

#INCLUDE syshtm

Protože objekt "bm_code_syshtm" knihovny SYSHTM je zdrojem pro nezávislá řešení, umožňují principy objektového programování na jeho základě vytvořit vlastní objekt (např. "bm_code_usrhtm" v knihovně USRHTM), který překryje "bm_code_syshtm" v metodách a vlastnostech dotýkajících se formátování (vzhledu) výstupního HTML dokumentu. Jednotlivé doplň. vlastnosti formuláře IS BM při zapsání do kódu umožňují zpracování skriptů. Skript je programový kód vyvolaný na základě programové události.

Událost formuláře (viz. Pojem - Zpracování skriptů) GRID_HEADER_CLIK umožňuje implementačně definovat třídění sloupce po kliku na návěští sloupce v mřížce formuláře (např. v mřížce je identifikace artiklu a datum - po kliku na sloupec artiklu se požaduje setřídění artikl+datum).

Událost GRID_HEADER_CLIK vzniká při kliku na návěští sloupce mřížky ve formuláři a vyvolává skript připojený k formuláři doplňující vlastností formuláře voláním metody ADDSCRIPT.

Ve skriptu je možné odkazovat se na proměnné:

_objscript.recordsource - alias cursoru mřížky

_objscript.attribute - název atributu zobrazeného ve sloupci (včetně aliasu), na který uživatel kliknul

Kód skriptu by měl vrátit výraz v syntaxi jazyka Foxpro pro příkaz INDEX ON.

Příklad doplňující vlastnosti formuláře připojující skript pro událost GRID_HEADER_CLIK:

<pre>

LOCAL _kod

TEXT TO _kod NOSHOW

IF _objscript.recordsource='VRUDOPER' AND TYPE(_objscript.attribute)='C'

RETURN [UPPER(]+_objscript.attribute+[)+DTOS(NVL(vr02datum,{}))+LEFT(ad01adsat,50)]

ELSE

RETURN _objscript.attribute

ENDIF

ENDTEXT

_this.makroprikaz("this.addscript(CREATEOBJECT([bwscript],[GRID_HEADER_CLIK],[GRID_HEADER_CLIK],[],_p1))",_kod)

</pre>

Datový model

  • SPCINDV Doplňující vlastnost formuláře
    • BWPRINS Metapředloha výstupu
    • SPVOLST Volná karta
    • SPCINDVT Druh implementačního rozšíření
      • SPPRISTU Přístupové právo uživatele k věci
    • SPCINDVK Kategorie doplňující vlastnost formuláře/knihovny vkládaného kódu

    • Formulář

    Formulář činnosti - Doplnění mřížky formuláře
Mřížka [Doplňující vlastnosti formuláře]
Činnost | Identifikace činnosti
Název činnosti | Název činnosti
Vlastnost | Identifikace doplňující vlastnosti činnosti
Název | Název doplňující vlastnosti činnosti
Listovací rámeček
Stránka #1 Doplňující vlastnosti formuláře
Verze | Verze doplňující vlastnosti formuláře
Aktualizace | Datum aktualizace
Změnil | Jméno uživatele systému, který změnil záznam
Druh | Identifikace druhu implemetačního rozšíření
Kategorie | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
Menu | Zařadit do menu
 | Řez písma položky menu - Normální/Kurzíva/Tučné/Tučná kurzíva
Klávesa | CTRL-klávesa pro spuštění z menu
Stat.podm. | Statická podmínka zařazení do menu
Dyn.podm. | Dynamická podmínka zařazení do menu
Automaticky | Vyvolat akci automaticky při spuštění
Pořadí | Pořadí provádění akce doplňující vlastnosti činnosti
Typ | Typ provené akce
Určení metapředlohy | Určení metapředlohy
MPV | Identifikace metapředlohy výstupu
Název metapředlohy | Název metapředlohy výstupu
Určení volné karty | Určení volné karty
Karta | Název volné karty
Popis | Popis volné karty
Doplnění | Identifikace doplnění mřížky formuláře
Kód | Kód provedený akcí vlastnosti činnosti v jazyce Foxpro
Poznámka | Poznámka
Stránka #2 Omezení pro operace
Mřížka [Omezení pro operace]
Proces | Identifikátor druhu procesu
 | Název druhu procesu
Komp. | Identifikace komponenty
Operace | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Název druhu operace
Stav operace připravena | Podle stavu operace připravena
Stav operace zahájena | Podle stavu operace zahájena
Stav operace ukončena | Podle stavu operace ukončena
Poznámka | Poznámka
Stránka #3 Popis verzí vlastnosti
Mřížka [Popis verzí vlastnosti]
Verze | Verze doplňující vlastnosti formuláře
Aktualizace | Datum aktualizace
Popis | Popis verze
Dne | Datum záznamu o verzi
Popsal | Jméno uživatele systému, který změnil záznam
Stránka #4 Výběr
Činnost | Identifikace činnosti
Vlastnost | Identifikace doplňující vlastnosti činnosti
Název | Název doplňující vlastnosti činnosti
Druh | Identifikace druhu implemetačního rozšíření
Kategorie | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Doplňující vlastnosti formuláře] činnosti - Doplnění mřížky formuláře

    Mřížka [Doplňující vlastnosti formuláře] činnosti - Doplnění mřížky formuláře
Označování | Označení záznamu
Činnost | Identifikace činnosti
Vlastnost | Identifikace doplňující vlastnosti činnosti
Název | Název doplňující vlastnosti činnosti
Název činnosti | Název činnosti
Druh | Identifikace druhu implemetačního rozšíření
Název druhu | Název druhu implemetačního rozšíření
Kategorie | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
Název kategorie | Název kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
Verze | Verze doplňující vlastnosti formuláře
Aktualizace | Datum aktualizace

    Mřížka [Omezení pro operace] činnosti - Doplnění mřížky formuláře

    Mřížka [Omezení pro operace] činnosti - Doplnění mřížky formuláře
Operace | Identifikátor druhu operace
Název druhu operace | Název druhu operace
Proces | Identifikátor druhu procesu
Název druhu procesu | Název druhu procesu

    Mřížka [Popis verzí vlastnosti] činnosti - Doplnění mřížky formuláře

    Mřížka [Popis verzí vlastnosti] činnosti - Doplnění mřížky formuláře
Verze | Verze doplňující vlastnosti formuláře
Dne | Datum záznamu o verzi
Popsal | Jméno uživatele systému, který změnil záznam

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Editovat kód vlastnosti | Editovat kód vlastnosti
F6 | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností
- | Kontrolní kompilace | Kontrolní kompilace
- | Doplnění mřížky formuláře | Doplnění mřížky formuláře
F2 | Druhy implementačních rozšíření | Druhy implementačních rozšíření
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Kategorie doplňující vlastnosti/knihovny | Kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
F2 | Komponenty | Číselník komponent
F2 | Metapředlohy výstupu | Metapředlohy výstupu
F2 | Volná karta | Seznam volných karet tabulky

    Atributy tisku

    Základní údaje
Činnost | Identifikace činnosti | SPCINDV_bw02krok | C(6)
Vlastnost | Identifikace doplňující vlastnosti činnosti | SPCINDV_spa7id | C(6)
Název | Název doplňující vlastnosti činnosti | SPCINDV_spa7nazvla | C(40)
Druh | Identifikace druhu implemetačního rozšíření | SPCINDV_spa6id | C(6)
Název druhu | Název druhu implemetačního rozšíření | SPCINDVT_spa6nazdru | C(40)
Kategorie | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu | SPCINDV_spc1id | C(6)
Název kategorie | Název kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu | SPCINDVK_spc1nazkat | C(40)
Menu | Zařadit do menu | Výpočet | C(3)
Klávesa | CTRL-klávesa pro spuštění z menu | SPCINDV_spa7klaves | C(3)
Stat.podm. | Statická podmínka zařazení do menu | SPCINDV_spa7menusp | M
Dyn.podm. | Dynamická podmínka zařazení do menu | SPCINDV_spa7menudp | M
Automaticky | Vyvolat akci automaticky při spuštění | Výpočet | C(3)
Pořadí | Pořadí provádění akce doplňující vlastnosti činnosti | SPCINDV_spa7porad | N(3)
Typ | Typ provené akce | Výpočet | C(24)
Určení metapředlohy | Určení metapředlohy | Výpočet | C(26)
MPV | Identifikace metapředlohy výstupu | SPCINDV_bw81id | C(6)
Název metapředlohy | Název metapředlohy výstupu | BWPRINS_bw81skupre | C(40)
Určení volné karty | Určení volné karty | Výpočet | C(19)
Karta | Název volné karty | SPCINDV_sp64nazev | C(8)
Popis | Popis volné karty | SPVOLST_sp64volstr | C(40)
Doplnění | Popis doplnění mřížky formuláře | SPGRID_spe4nazdop | C(40)
Kód | Kód provedený akcí vlastnosti činnosti v jazyce Foxpro | SPCINDV_spa7kod | M
Aktualizace | Datum aktualizace | SPCINDV_sp00datakt | T
Změnil | Jméno uživatele systému, který změnil záznam | SPCINDV_sp00jmeakt | C(40)
Poznámka | Poznámka | SPCINDV_spa7koment | M
Název druhu procesu | Název druhu procesu | SPTYP2_sp07text | C(30)
Název druhu operace | Název druhu operace | SPTYP_sp07text | C(30)

    Při pohybu v Omezení pro operace
Proces | Identifikátor druhu procesu | SPCINDVD_sp07idtypd | C(6)
Operace | Identifikátor druhu operace | SPCINDVD_sp07idtyp | C(6)
Komponenta | Identifikace komponenty | SPCINDVD_sp06idsubs | C(3)
Pořadí | Pořadí stejného druhu operace v jednom procesu | SPCINDVD_sp33porad | N(2)
Stav operace připravena | Podle stavu operace připravena | Výpočet | C(12)
Stav operace zahájena | Podle stavu operace zahájena | Výpočet | C(11)
Stav operace ukončena | Podle stavu operace ukončena | Výpočet | C(11)
Poznámka | Poznámka | SPCINDVD_spa5koment | M

    Při pohybu v Popis verzí
Verze | Verze doplňující vlastnosti formuláře | SPCIVDV_spa7verze | N(6,3)
Dne | Datum záznamu o verzi | SPCIVDV_spg4dne | D
Popsal | Jméno uživatele systému, který změnil záznam | SPCIVDV_sp00jmeakt | C(40)
Popis | Popis verze | SPCIVDV_spg4koment | M

    Viz.také

    Editovat kód vlastnosti | Knihovny vkládaného kódu | Kontrolní kompilace | Doplnění mřížky formuláře | Druhy implementačních rozšíření | Druhy operací | Druhy procesů | Kategorie doplňující vlastnosti/knihovny | Komponenty | Metapředlohy výstupu | Volná karta


Doplňující položky menu objektů

Popis

Tato činnost poskytuje uživateli možnost implementačně doplnit definovatelné funkce pro menu, která jsou vyvolávána po stisku pravého tlačítka myši na uzlu představujícím objekt BM. Tuto možnost je vhodné využít zejména ve stromech zobrazovaných ve formulářích „spojené dokumenty“, „strom hlavního procesu“ a obdobných stromech formuláře „okno úloh“.

Uživatel má tuto činnost dostupnou v hlavním menu – Informační centrum – Typy a řady. Po aktivaci této činnosti má k dispozici přehled dosud nadefinovaných doplňujících položek menu objektů a zároveň má možnost definice nové položky. Při její definici vstupuje následující atributy:

¨ položka – identifikace a popis položky menu

¨ druh – výběr z překryvného seznamu druhů implementačních rozšíření. Na F2 možno nadefinovat nový druh, který se pak bude následně zobrazovat na výběr v překryvném seznamu. K jednotlivým druhům lze nadefinovat přístupová práva.

¨ objekt BM – výběr z překryvného seznamu objektů BM. Zde se určuje typ objektu BM (jeho uvedení není povinné), pro který se má doplňující položka menu uplatnit.

¨ pořadí – numerická hodnota – určuje pořadí zobrazení položky menu

¨ podmínka – podmínka zařazení položky menu – script v jazyce FoxPro. Je-li uvedena, musí obsahovat kód v jazyce FoxPro, který vrací logickou hodnotu .T. (TRUE) nebo .F. (FALSE)

¨ typ kódu – výběr z překryvného seznamu. Kompilovaný kód se použije v případě, že doplň. položka menu má spustit okno, které má zůstat otevřené, tzn. i při další práci s BM stále k dispozici. Nekompilovaný kód se naopak použije v případě, že spuštěná doplň. položka menu je k dispozici jen pro daný okamžik a pak se hned ukončuje.

¨ kód – kód v jazyce FoxPro vyvolaný při výběru položky menu

¨ poznámka – libovolný text

¨ aktualizace – datum a čas, kdy byla naposledy daná definice položky menu změněna – uplatňuje se zejména při importu balíčků

Doplňující položky menu jsou umisťovány na začátek standardního menu a uplatní se v případě, že 'Objekt BM' není určen nebo je totožný.

O uplatnění doplňující položky menu může také rozhodnout kód Podmínky. Pro toto rozhodnutí má kód k dispozici předané parametry (v kódu se příkaz PARAMETERS resp. LPARAMETERS neuvádí):

_this - objekt - řídící objekt uzlu stromu, na kterém byl proveden pravý klik

_bw09typ1 - text - identifikace objektu BM

_bw09inst1 - jednoznačná časová identifikace objektu

Kromě toho jsou podle typu objektu BM k dispozici atributy objektu _this:

Pro typ objektu Adresář (AD) - _this.ad01id

Pro typ objektu Artikl (AR) - _this.sp61id,_this.sp60id

Pro typ objektu Proces (PR) - _this.sp33cisdr,_this.sp33cisdpm,_this.sp33cisd

Pro typ objektu Operace (OO) - _this.sp33cisdr,_this.sp33cisdpm,_this.sp33cisd,_this.sp06idsubs,_this.sp07idtyp,_this.sp33porad

Kód spouštěný po výběru položky menu má k dispozici parametry (v kódu se příkaz PARAMETERS resp. LPARAMETERS neuvádí):

_this - objekt - řídící objekt uzlu stromu, na kterém byl proveden pravý klik

_bw09typ1 - text - identifikace objektu BM

_bw09inst1 - jednoznačná časová identifikace objektu

_main_object - objekt - řídící objekt stromu

Kromě toho jsou podle typu objektu BM k dispozici atributy objektu _this. Může být spouštěný podle nastavení 'Typ kódu' v kompilovaném nebo nekompilovaném tvaru (kompilovaný tvar je určen pro případy, kdy kód vytváří nemodální objekty, např. nemodální formulář).

Parametr _main_object je předáván kódu pro případ, že je třeba po provedení kódu provést přezobrazení stromu, např. přezobrazení připojených dokumentů příkazem '_main_object.prezobraz_uzel(_this,.T.)'.

Datový model

  • SPCINDO Doplňující položka menu objektu
    • SPCINDVT Druh implementačního rozšíření
      • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Knihovny vkládaného kódu
Mřížka [Doplňující vlastnosti objektů v menu]
Položka | Identifikace doplňující položky menu objektu
Název | Název položky menu
Druh | Identifikace druhu implemetačního rozšíření
Objekt BM | Identifikace objektu BM
Pořadí | Pořadí položky menu
Podmínka | Podmínka zařazení položky menu - script v jazyce Foxpro
Typ kódu | Způsob spuštění kódu - kompilovaný/nekompilovaný kód
Kód | Kód v jazyce Foxpro vyvolaný při výběru položky menu
Poznámka | Poznámka
Aktualizace | Datum aktualizace

    Mřížka [Doplňující vlastnosti objektů v menu] činnosti - Knihovny vkládaného kódu

    Mřížka [Doplňující vlastnosti objektů v menu] činnosti - Knihovny vkládaného kódu
Položka | Identifikace doplňující položky menu objektu
Název | Název položky menu
Objekt BM | Identifikace objektu BM
Druh | Identifikace druhu implemetačního rozšíření
Pořadí | Pořadí položky menu
Aktualizace | Datum aktualizace

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Editovat kód vlastnosti | Editovat kód vlastnosti
F6 | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností
- | Kontrolní kompilace | Kontrolní kompilace
F2 | Druhy implementačních rozšíření | Druhy implementačních rozšíření

    Atributy tisku

    Základní údaje
Položka | Identifikace doplňující položky menu objektu | SPCINDO_spg0id | C(6)
Druh | Identifikace druhu implemetačního rozšíření | SPCINDO_spa6id | C(6)
Identifikace objektu BM | Identifikace objektu BM | SPCINDO_bw55objec | C(2)
Pořadí | Pořadí položky menu | SPCINDO_spg0porad | N(3)
Název | Název položky menu | SPCINDO_spg0prompt | M
Podmínka | Podmínka zařazení položky menu - script v jazyce Foxpro | SPCINDO_spg0when | M
Typ kódu | Způsob spuštění kódu - kompilovaný/nekompilovaný kód | Výpočet | C(17)
Kód | Kód v jazyce Foxpro vyvolaný při výběru položky menu | SPCINDO_spg0kod | M
Poznámka | Poznámka | SPCINDO_spg0koment | M

    Viz.také

    Editovat kód vlastnosti | Knihovny vkládaného kódu | Kontrolní kompilace | Druhy implementačních rozšíření


Knihovny vkládaného kódu

Popis

Jsou určeny pro definování opakovaného kódu programu doplň. vlastností formuláře a to tím způsobem, že přímo v doplň. vlastnostech formuláře se na programový kód knihovny odkazujeme klausulí #INCLUDE <identifikace knihovny>. V této chvíli jsou vytvořeny knihovny např. definující objekty pro výstup do HTML, importy-exporty dat, čtení dat z Excelu, apod.

Na záložce Popis verzí knihovny má uživatel informaci, kdy byla daná knihovna vytvořena, případně jaké změny v ní byly provedeny.

Datový model

  • SPCINDVI Knihovna vkládaného kódu prováděného akcí doplnění vlastnosti činnosti
    • SPCINDVT Druh implementačního rozšíření
      • SPPRISTU Přístupové právo uživatele k věci
    • SPCINDVK Kategorie doplňující vlastnost formuláře/knihovny vkládaného kódu

    • Formulář

    Formulář činnosti - Kategorie doplňující vlastnosti/knihovny
Mřížka [Knihovny]
Listovací rámeček
Stránka #1 Knihovny
Knihovna | Identifikace vkládaného kódu
Popis knihovny | Popis knihovny vkládaného kódu
Verze | Verze knihovny vkládaného kódu
Aktualizace | Datum aktualizace
Změnil | Jméno uživatele systému, který změnil záznam
Druh | Identifikace druhu implemetačního rozšíření
Kategorie | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
Kód | Obsah knihovny vkládaného kódu
Poznámka | Poznámka
Stránka #2 Popis verzí knihovny
Mřížka [Popis verzí knihovny]
Verze | Verze knihovny vkládaného kódu
Aktualizace | Datum aktualizace
Popis | Popis verze
Dne | Datum záznamu o verzi
Popsal | Jméno uživatele systému, který změnil záznam
Stránka #3 Výběr
Knihovna | Identifikace vkládaného kódu
Popis knihovny | Popis knihovny vkládaného kódu
Druh | Identifikace druhu implemetačního rozšíření
Kategorie | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Knihovny] činnosti - Kategorie doplňující vlastnosti/knihovny

    Mřížka [Knihovny] činnosti - Kategorie doplňující vlastnosti/knihovny
Označování | Označení záznamu
Knihovna | Identifikace vkládaného kódu
Popis knihovny | Popis knihovny vkládaného kódu
Druh | Identifikace druhu implemetačního rozšíření
Název druhu | Název druhu implemetačního rozšíření
Kategorie | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
Název kategorie | Název kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
Verze | Verze knihovny vkládaného kódu
Aktualizace | Datum aktualizace

    Mřížka [Popis verzí knihovny] činnosti - Kategorie doplňující vlastnosti/knihovny

    Mřížka [Popis verzí knihovny] činnosti - Kategorie doplňující vlastnosti/knihovny
Verze | Verze knihovny vkládaného kódu
Dne | Datum záznamu o verzi
Popsal | Jméno uživatele systému, který změnil záznam

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Editovat kód vlastnosti | Editovat kód vlastnosti
- | Kontrolní kompilace | Kontrolní kompilace
F2 | Druhy implementačních rozšíření | Druhy implementačních rozšíření
F2 | Kategorie doplňující vlastnosti/knihovny | Kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu

    Atributy tisku

    Základní údaje
Knihovna | Identifikace vkládaného kódu | SPCINDVI_spa8id | C(6)
Popis knihovny | Popis knihovny vkládaného kódu | SPCINDVI_spa8popkod | C(40)
Druh | Identifikace druhu implemetačního rozšíření | SPCINDVI_spa6id | C(6)
Název druhu | Název druhu implemetačního rozšíření | SPCINDVT_spa6nazdru | C(40)
Kategorie | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu | SPCINDVI_spc1id | C(6)
Název kategorie | Název kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu | SPCINDVK_spc1nazkat | C(40)
Kód | Obsah knihovny vkládaného kódu | SPCINDVI_spa8kod | M
Aktualizace | Datum aktualizace | SPCINDVI_sp00datakt | T
Změnil | Jméno uživatele systému, který změnil záznam | SPCINDVI_sp00jmeakt | C(40)
Poznámka | Poznámka | SPCINDVI_spa8koment | M

    Při pohybu v Popis verzí
Verze | Verze knihovny vkládaného kódu | SPCIVDVI_spa8verze | N(6,3)
Dne | Datum záznamu o verzi | SPCIVDVI_spg3dne | D
Popsal | Jméno uživatele systému, který změnil záznam | SPCIVDVI_sp00jmeakt | C(40)
Popis | Popis verze | SPCIVDVI_spg3koment | M

    Viz.také

    Editovat kód vlastnosti | Kontrolní kompilace | Druhy implementačních rozšíření | Kategorie doplňující vlastnosti/knihovny


Mapa přístupových práv

Popis

Činnost se nachází v menu Informační centrum - Typy a řady - Mapa přístupových práv. Tuto činnost je rovněž možno vyvolat po stisku klávesy F5 při definování práv AAA, druhu procesů apod. V tomto případě se zobrazí omezený počet práv odpovídajícího druhu (tzn. pokud uživatel spustil mapu z činnosti druhy procesů, zobrazuje se mu mapa přístupových práv pouze k činnosti druhy procesů).

Po aktivaci činnosti jsou jednotlivá nadefinovaná práva zobrazena v mřížce, kde se zobrazuje druh a název činnosti a sloupečky - zápis, čtení, žádné právo. Po stisku pravého tlačítka myši ve vybraném sloupečku (záleží na tom, jaké právo chceme přiřadit či naopak odebrat) se uživateli zobrazí okno s těmito možnostmi:

¨ aktuální přístupová práva skupiny - při pohybu po šipce je možno je změnit

¨ přidat skupinu uživatelů - na základě výběru skupiny a podle toho v jakém sloupečku uživatel stojí (zápis, čtení, žádné právo) se přiřadí vybrané právo dané skupině uživatelů

¨ přidat právo uživatele - na základě výběru uživatele a podle toho v jakém sloupečku uživatel stojí (zápis, čtení, žádné právo) se přiřadí právo vybranému uživateli.

Po ukončení této činnosti je uživatel vyzván k provedení přepočtu práv přístupu.

Datový model

  • BWOVAZBA Zařazení uživatele to skupiny uživatelů

    • Formulář

    Formulář činnosti - Kategorie doplňující vlastnosti/knihovny
    Seznam komponent


Obecné kalendáře

Popis

Činnost Obecné kalendáře se nachází v Informačním centru, v podskupině Typy a řady. Uživatel může definovat kalendáře typu:

¨ denní kalendář

¨ týdenní kalendář

Tyto typy souvisí s uloženou funkcí databáze 'SPKALEN_platny_den', která slouží ke zjišťování platného data určeného kalendáře v SQL dotazech. Pro typ 'Denní kalendář' musí být jednotlivé platné dny kalendáře vyjmenovány (záložka Jednotlivé dny kalendáře). Pro typ 'Týdenní kalendář' je den považován za platný, pokud odpovídá určenému dne týdne daného kalendáře (záložka Dny v týdnu kalendáře).

Při definování nového kalendáře má uživatel k dispozici tři záložky:

¨ kalendáře

¨ dny v týdnu kalendáře

¨ jednotlivé dny kalendáře

Na záložce kalendáře zadá uživatel identifikaci, název a typ kalendáře. A pak podle toho, zda si zvolil typ denní nebo týdenní vyplňuje další záložky.

Záložka Dny v týdnu kalendáře obsahuje výčet dnů v týdnu, které mají pro daný kalendář význam. Uživatel zadává den, část dne (¨klávesou F2 se na tomto překryvném seznamu vyvolává formulář pro definování částí dne. Podstatnou informací části dne pro vyhodnocování funkcí 'SPKALEN_platny_den' je počáteční a konečná hodina - vyhodnocuje datum včetně času. Částí dne může být např. pracovní směna nebo celý den) a poznámku.

Záložka Jednotlivé dny kalendáře obsahuje výčet jednotlivých dnů kalendáře. Pro typ kalendáře Denní musí být den na této záložce uveden jako platný, proto aby funkce 'SPKALEN_platny_den' vyhodnotila jí vyhodnocované datum jako platné. Kromě datumu se na této záložce uvádí část dne a stav dne Platný Ano/Ne. Automatizovaně vstupovat jednotlivé dny kalendáře lze po stisku klávesy F5 pomocí funkce Předplnit kalendář.

Platný den uvedený pro typ kalendáře Týdenní, který není dnem v týdnu uvedeným na záložce 'Dny v týdnu kalendáře' , je funkcí 'SPKALEN_platny_den' vyhodnocen jako platný.

Neplatný den uvedený pro typ kalendáře Týdenní, který je dnem v týdnu uvedeným na záložce 'Dny v týdnu kalendáře' , je funkcí 'SPKALEN_platny_den' vyhodnocen jako neplatný.

Funkce - SPKALEN_platny_den

Parametry: in @spd3id char(6),in @spd4datum timestamp,in @bw10nazev char(8),in @spd7id char(6)

@spd3id - identifikace kalendáře

@spd4datum - datum/datumčas - dotazované datum

@bw10nazev - entita, které se týká výjimka kalendáře

@spd7id - hodnota primárního klíče entity, které se týká výjimka kalendáře

Funkce vrací numerickou hodnotu (tinyint) :

0 - dotazované datum v určeném kalendáři je neplatné

1 - dotazované datum v určeném kalendáři je platné

Parametry @bw10nazev a @spd7id souvisí s používáním obecných kalendářů v komponentách IS BM, např. v komponentě Expedice, kde má smysl definovat kalendář pro trasu pro výpočet rozdělení dodacích listů na expediční příkazy.

Příklad : tuto trasu jezdíme v pondělí a ve čtvrtek a můžeme zadat pro ní výjimku tento konkrétní den, i když je to středa tuto trasu pojedeme nebo výjimku pro jiný den, i když je to čtvrtek nepojedeme, protože je sněhová kalamita. V expedici se používají obecné kalendáře také ve spojení s tabulkou řidičů.

Výjimky v kalendáři jsou ukládány ve společné entitě (SPKALENV).

Př.:

obecný výběr událostí vývěsky, které mají platné datum podle kalendáře 'K1'

bm_servis.SPKALEN_platny_den('K1 ',VYUDALOS.vy01datum,null,null)=1

Obecný kalendář používá tyto tabulky:

SPKALEN - Obecný kalendář

SPKALENT - Den v týdnu obecného kalendáře

SPKALEND - Den obecného kalendáře

SPKALENC - Část dne v obecném kalendáři

SPKALENV - Výjimka v obecném kalendáři

Datový model

  • SPKALEN Obecný kalendář

    • Formulář

    Formulář činnosti - Předplnit kalendář
Mřížka [Kalendáře]
Kalendář | Identifikace kalendáře
Název kalendáře | Název kalendáře
Typ | Pro vyhodnocení platnosti dne musí být uveden - Denní kalendář - den v týdnu, Týdenní kalendář - jednotlivý platný den
Listovací rámeček
Stránka #1 Kalendáře
Poznámka | Poznámka
Stránka #2 Dny v týdnu kalendáře
Mřížka [Dny v týdnu kalendáře]
Den | Den v týdnu
Čas od | Čas od
Čas do | Čas do
Část dne | Identifikace části dne
Poznámka | Poznámka
Stránka #3 Jednotlivé dny kalendáře
Mřížka [Jednotlivé dny kalendáře]
Datum | Datum
Čas od | Čas od
Čas do | Čas do
Část dne | Identifikace části dne
Platný | Platný den kalendáře Ano/Ne
Poznámka | Poznámka
Stránka #4 Výběr
Kalendář | Identifikace kalendáře
Název kalendáře | Název kalendáře
Typ | Pro vyhodnocení platnosti dne musí být uveden - Denní kalendář - den v týdnu, Týdenní kalendář - jednotlivý platný den
Datum | Datum
 | Datum do
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 | Platnost nebo neplatnost k datu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Kalendáře] činnosti - Předplnit kalendář

    Mřížka [Kalendáře] činnosti - Předplnit kalendář
Kalendář | Identifikace kalendáře
Název kalendáře | Název kalendáře

    Mřížka [Dny v týdnu kalendáře] činnosti - Předplnit kalendář

    Mřížka [Dny v týdnu kalendáře] činnosti - Předplnit kalendář
Den | Den v týdnu
Název části dne | Název části dne
Čas od | Čas od
Čas do | Čas do

    Mřížka [Jednotlivé dny kalendáře] činnosti - Předplnit kalendář

    Mřížka [Jednotlivé dny kalendáře] činnosti - Předplnit kalendář
Datum | Datum
Název části dne | Název části dne
Čas od | Čas od
Čas do | Čas do

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Předplnit kalendář |
F2 | Části dne obecného kalendáře | Části dne obecného kalendáře

    Atributy tisku

    Základní údaje
Kalendář | Identifikace kalendáře | SPKALEN_spd3id | C(6)
Název kalendáře | Název kalendáře | SPKALEN_spd3nazkal | C(40)
Typ | Pro vyhodnocení platnosti dne musí být uveden - Denní kalendář - den v týdnu, Týdenní kalendář - jednotlivý platný den | Výpočet | C(16)
Poznámka | Poznámka | SPKALEN_spd3koment | M
Platí k datu | Příznak platnosti k aktuálnímu dni podle kalendáře | spd3plati | N(1)
Název části dne | Název části dne | SPKALENC_spd5nazcas | C(40)
Čas od | Čas od | SPKALENC_spd5casod | C(5)
Čas do | Čas do | SPKALENC_spd5casdo | C(5)
Poznámka | Poznámka | SPKALENC_spd5koment | M
Název části dne | Název části dne | SPKALENC2_spd5nazcas | C(40)
Čas od | Čas od | SPKALENC2_spd5casod | C(5)
Čas do | Čas do | SPKALENC2_spd5casdo | C(5)
Poznámka | Poznámka | SPKALENC2_spd5koment | M

    Při pohybu v Dny v roce kalendáře
Datum | Datum | SPKALEND_spd4datum | D
Část dne | Identifikace části dne | SPKALEND_spd5id | C(6)
Platný | Platný den kalendáře Ano/Ne | Výpočet | C(3)
Poznámka | Poznámka | SPKALEND_spd4koment | M

    Při pohybu v Dny v týdnu kalendáře
Část dne | Identifikace části dne | SPKALENT_spd5id | C(6)
Den | Den v týdnu | Výpočet | C(7)
Poznámka | Poznámka | SPKALENT_spd6koment | M

    Viz.také

    Předplnit kalendář | Části dne obecného kalendáře


BM-funkce pro SQL

Popis

V řadě uživatelských implementačních rozšířeních (doplnění výstupů, transformace, obecné výběry, volné karty, ...) opakovaně nastává situace, že uživatel potřebuje využít definičně složitou konstrukci pro získání hodnoty (např. nákladová cena z TPTECVVP k datu, výše opravné položky či úhrady k datu v platbě, hmotnost výrobku z VRUDOPMA, ...). V dnešní praxi se v BM obvykle řeší opakovaným sestavováním SELECTu v doplnění, kde však může nastat problém, že se mohou nadefinovat mírně odlišně (zaokrouhlování, ...) a pak je nutno řešit nekonzistence informací.

Činnost BM-funkce pro SQL (menu Informační centrum – Typy a řady - BM-funkce pro SQL) řeší právě tento problém. Při jejím definování se zadává:

¨ BM-funkce - 12-ti znakový identifikátor

¨ název BM-funkce - popisuje funkci

¨ typ návratové hodnoty BM-funkce - překryvný seznam - Znaková, Numerická, Datumová, Časová

datum platnosti funkce od – datum. Tento parametr, který určuje datum, je rozhodující v okamžiku, kdy je definováno více BM-funkcí se stejnou identifikací. Podle nastaveného data platnosti je pak vyhodnocena jejich aktuálnost. Obvykle se uvádí konstanta NULL nebo CURRENT DATE (tj. v obou případech BM-funkce platná k aktuálnímu datu).

¨ SQL dotaz BM-funkce - text obsahující selekt v syntaxi Sybase SQL Anywhere

¨ testovací parametry - seznam parametrů (konstant) pro testování BM-funkce (parametry musí být definovány v syntaxi Foxpro)

¨ poznámka - libovolný text

¨ aktualizace – datum vytvoření. Při opravě funkce se tento atribut automaticky aktualizuje aktuálním datem a časem systému, který zajišťuje, že pro import balíčku je zachována poslední nejaktuálnější verze BM – funkce.

V implementačních rozšířeních IS BM se potom konkrétní BM-funkce odkazují v odpovídajících SQL dotazech voláním uložené procedury:

¨ bmfce_C - pro typ návratové hodnoty funkce Znaková

¨ bmfce_N - pro typ návratové hodnoty funkce Numerická

¨ bmfce_D - pro typ návratové hodnoty funkce Datumová

¨ bmfce_T - pro typ návratové hodnoty funkce Časová

v syntaxi např.:

bm_servis.bmfce_C([Identifikace BM-funkce],[platnost],[parametr1],[parametr2],...,[parametr9])

Nepovinné parametry [parametr1],[parametr2],...,[parametr9] jsou v SQL dotazu funkce reprezentovány pozičné proměnnými @p1,@p2,....,@p9.

Vytvořenou BM-funkci je možné testovat volbou „Testovat SQL výraz“ (klávesa F5 nebo aktivace činnosti v menu Volby) v případě, že jsou u ní nadefinovány „testovací parametry“. Uživatel by měl dodržet pravidlo, že každá funkce je tímto způsobem otestována, protože syntakticky chybně nadefinovaná funkce se neprojeví chybou SQL při použití v implementačních rozšířeních.

Exporty do balíčku jsou upraveny tak, že je-li v exportu obsažen záznam, který odkazuje v některém svém atributu na BM-funkci, potom je tato automatizovaně vložena do tohoto balíčku (tato funkčnost se neuplatňuje pro exporty ve starém formátu).

Př.:

BM-funkce vracející množství artiklu na všech skladech:

¨ identifikace BM-funkce - MT-AHNAT-ALL

¨ typ návratové hodnoty BM-funkce - Numerická

¨ SQL dotaz BM-funkce - SELECT SUM(mt02hodnot) FROM %%%.MTAH WHERE sp67id='NAT' AND sp61id=@p1 AND sp60id=@p2

¨ testovací parametry - 'ZBO',PADR('HOBLIK',13)

Použití této BM-funkce v doplnění tiskové předlohy výstupu obchodovatelného artiklu:

...., %%%.bmfce_N('MT-AHNAT-ALL',null,obartikl.sp61id,obartikl.sp60id) mnozstvi, ....

Použití této BM-funkce v obecném výběru obchodovatelného artiklu:

%%%.bmfce_N('MT-AHNAT-ALL',null,obartikl.sp61id,obartikl.sp60id)>1000

Datový model

  • SPSQLFCE BM funkce pro implementační rozšíření ISBM

    • Formulář

    Formulář činnosti - Testovat SQL výraz
Mřížka [BM-funkce]
Listovací rámeček
Stránka #1 BM-funkce
BM-funkce | Identifikace BM-funkce
Název BM-funkce | Název BM-funkce
Typ | Typ návratové hodnoty BM-funkce
Platnost | Datum platnost BM-funkce od
do | Datum platnost BM-funkce do
SQL | SQL dotaz, ve kterém jsou parametry pozičně reprezentovány proměnnými @p1,@p2,...,@p9
Test par. | Testovací parametry - zadává se seznam konstant s syntaxi Sybase
Aktualizace | Datum aktualizace
Poznámka | Poznámka
Stránka #2 Výběr
BM-funkce | Identifikace BM-funkce
Název BM-funkce | Název BM-funkce
Typ | Typ návratové hodnoty BM-funkce
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 | Platnost nebo neplatnost k datu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [BM-funkce] činnosti - Testovat SQL výraz

    Mřížka [BM-funkce] činnosti - Testovat SQL výraz
BM-funkce | Identifikace BM-funkce
Název BM-funkce | Název BM-funkce
Typ | Typ návratové hodnoty BM-funkce
Platnost | Datum platnost BM-funkce od
do | Datum platnost BM-funkce do

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Testovat SQL výraz |

    Atributy tisku

    Základní údaje
BM-funkce | Identifikace BM-funkce | SPSQLFCE_spe2id | C(12)
Název BM-funkce | Název BM-funkce | SPSQLFCE_spe2nazfce | C(40)
Typ | Typ návratové hodnoty BM-funkce | Výpočet | C(9)
Platnost | Datum platnost BM-funkce od | SPSQLFCE_spe2datod | D
do | Datum platnost BM-funkce do | spe2datdo | D
SQL | SQL dotaz, ve kterém jsou parametry pozičně reprezentovány proměnnými @p1,@p2,...,@p9 | SPSQLFCE_spe2sql | M
Test par. | Testovací parametry - zadává se seznam konstant s syntaxi Sybase | SPSQLFCE_spe2zkupar | M
Aktualizace | Datum aktualizace | SPSQLFCE_sp00datakt | T
Poznámka | Poznámka | SPSQLFCE_spe2koment | M

    Viz.také

    Testovat SQL výraz


Pravidla inicializací přístupových práv

Popis

Tato činnost slouží k zpřehlednění a zjednodušení definice přístupových práv u jednotlivých druhů (např. druh volné karty, druh procesu, druh artiklu, druh předlohy výstupu apod.). V současné době platí, že při nainstalování IS BM je vše povoleno všem a správce systému pak postupně jednotlivé činnosti uživatelům zakazuje. Pomocí nastavení pravidel inicializací přístupových práv je možno toto nastavení změnit.

Při zakládání nového druhu v IS BM se nejprve vyhledává pravidlo, které:

¨ má stejnou identifikaci jako je identifikace nového druhu

¨ pokud není takové pravidlo nalezeno, vyhledává se první takové s nejvyšší prioritou, jehož identifikace je ‘jako‘ identifikace nového druhu, tj. vyhovuje podmínce logického výrazu Sybase SQL Anywhere – identifikace_nového_druhu LIKE identifikace_pravidla

Pokud není pro nový druh žádné pravidlo inicializace přístupových práv nalezeno, bude přiděleno přístupové právo „Zápis“ skupině uživatelů „Každý uživatel systému“.

U každého pravidla se definuje:

¨ identifikace pravidla – šestiznaková identifikace

¨ název pravidla

¨ typ pravidla – překryvný seznam, kde je možno vybrat:

¨ každý uživatel zápis – bude přiděleno přístupové právo „Zápis“ každému uživateli ve skupině „Každý uživatel systému“

¨ každý uživatel čtení – bude přiděleno přístupové právo „Čtení“ každému uživateli ve skupině „Každý uživatel systému“

¨ každý uživatel žádná práva – nebudou přidělena práva přístupu pro žádnou skupinu uživatelů

¨ kopie práva – budou přidělena stejná práva, jako jsou aktuálně nastavena pro dané pravidlo (pravidlu se nastavují práva po stisku Ctrl B). Znamená to, že pro vytvořené pravidlo XXX zadáme po stisku Ctrl B přístupová práva. Pak jakékoliv jiné pravidlo založené nově v systému s identifikací XXX má stejná práva.

¨ priorita – možnost vyhledávání pravidel s nejvyšší prioritou (priorita 1 je vyšší než priorita 2)

¨ uplatnění – text – uvádí se zde seznam typů práv, pro které se má pravidlo uplatnit (viz. níže)

¨ poznámka – libovolný text

Příklad implementace s využitím atributu „uplatnění“:

Do IS BM mají přístup uživatelé, kteří mají v systému významně omezená práva, tj. nejsou členy skupiny $KAZDY, ale jsou členy skupiny EXTERN. Tito uživatelé by měli mít možnost tisku faktur a sestav skladových pohybů. Pro takovou potřebu přístupových práv definujeme pravidlo následovně:

¨ identifikace pravidla = '______'

¨ typ pravidla = kopie práva

¨ priorita = 999

¨ uplatnění = 'TSK,TUO,TUP,OBC,DPH,PLA'

K tomuto pravidlu definujeme přístupová práva pro skupiny uživatelů:

$KAZDY = zápis

EXTERN = čtení

Potom při založení nového skladu, umístění obchodu, umístění plateb nebo nové operace obchodu, DPH a plateb budou automaticky přidělena práva skupinám uživatelů:

$KAZDY = zápis

EXTERN = čtení

UPOZORNĚNÍ:

Při každé nové instalaci IS BM se automaticky vytvářejí pravidla:

‘SYSTEM’ – typ Každý uživatel čtení

‘HIDDEN‘ – typ Každý uživatel žádná práva

‘-‘ - typ Každý uživatel zápis

Tato pravidla není vhodné rušit (další instalací IS BM se znovu vytvoří), ale je možné měnit jejich typ. Změna typu pravidla ‘-’ se nedoporučuje, protože se jedná o identifikaci nově doplňovaných druhů v IS BM a může nastat situace, kdy po instalaci nové verze BM budou s nimi spojená data pro uživatele nedostupná.

Při definování pravidla se záměrem uplatnění „nový druh je jako pravidlo“ je třeba si uvědomit, že se při jeho vyhodnocování uplatňují všechny znaky včetně mezer (např. pravidlo s identifikací ‘%‘ vyhoví všem identifikacím druhů, které mají první libovolný znak následovaný pěti mezerami).

U pravidel s identifikací typu „Každý uživatel žádná práva“ může nastat situace, že po importu balíčků implementačních rozšíření, ve kterých jsou obsaženy jejich druhy, jsou pak tyto implementační rozšíření pro implementátora neviditelná.

Příklady pravidel:

- 'SYSTEM' - typ Každý uživatel čtení

- 'HIDDEN' - typ Každý uživatel žádná práva

- 'OBECNY' - typ Každý uživatel zápis

- 'OBECNE' - typ Každý uživatel zápis

- 'OBECNA' - typ Každý uživatel zápis

- 'VEREJ' - typ Každý uživatel zápis

- 'Z_____' - typ Každý uživatel zápis - priorita 10

- 'C_____' - typ Každý uživatel čtení - priorita 10

- '______' - typ Kopie práv - priorita 999

Datový model

  • SPPRISTI Pravidlo inicializace přístupových práv při vstupu nového druhu

    • Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Pravidla]
Pravidlo | Identifikace pravidla inicializace přístupových práv při vstupu nového druhu
Popis pravidla | Popis pravidla inicializace přístupových práv při vstupu nového druhu
Typ | Typ pravidla
Priorita | Priorita aplikace pravidla
Poznámka | Poznámka

    Mřížka [Pravidla] činnosti - Přístupová práva

    Mřížka [Pravidla] činnosti - Přístupová práva
Priorita | Priorita aplikace pravidla
Pravidlo | Identifikace pravidla inicializace přístupových práv při vstupu nového druhu
Popis pravidla | Popis pravidla inicializace přístupových práv při vstupu nového druhu
Typ | Typ pravidla

    Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci

    Atributy tisku

    Základní údaje
Pravidlo | Identifikace pravidla inicializace přístupových práv při vstupu nového druhu | SPPRISTI_spe9id | C(6)
Popis pravidla | Popis pravidla inicializace přístupových práv při vstupu nového druhu | SPPRISTI_spe9nazpra | C(40)
Typ | Typ pravidla | Výpočet | C(26)
Priorita | Priorita aplikace pravidla | SPPRISTI_spe9prior | N(3)
Poznámka | Poznámka | SPPRISTI_spe9koment | M

    Viz.také

    Přístupová práva


Parametry polí formulářů

Popis

Uživatel si zvolí formulář a atribut, kde chce funkci automatického dokončování využít (např. ve výběrové záložce činnosti adresář na atributu název adresáta, v událostech obchodu na druhu artiklu, umístění apod.). Pak po stisku klávesy Ctrl a pravého tlačítka myši vyvolá formulář činnosti „parametry polí formulářů“.

Při aktivaci funkce automatického dokončování na vybraném atributu klávesou Ctrl+Home je pro dané pole automaticky vytvořen záznam pro daného uživatele s nastavením „naplnění seznamu návrhů“ na hodnotu Vstupem se systémovým dotazem „Aktivovat funkci automatického dokončování pro pole „....“? Ano/Ne“.

Nejprve se mu zobrazí výběrová záložka, kde má předplněn název tabulky a identifikaci atributu, kde chce funkci automatického dokončování realizovat. Po potvrzení výběru pak uživatel definuje jednotlivé atributy.

ZÁLOŽKA „PARAMETRY“ (slouží k definování „funkce automatického dokončování“)

¨ činnost - identifikace činnosti (formuláře) – předplní se

¨ pole - identifikace pole formuláře – předplní se

¨ uživatel - identifikace uživatele systému – předplní se (je předplněno jménem přihlášeného uživatele, pokud je přihlášen správce, předplní se jméno SYSTÉM)

¨ funkce automatického dokončování - překryvný seznam – výběr Ano/Ne

¨ naplnění seznamu návrhů - překryvný seznam (viz. popis dále) - výběr

- Vstupem

- SQL dotazem

- Výčtem

- Skriptem

¨ SQL/Výčet/Skript – tento atribut slouží pro zapsání SQL dotazu pro atribut „naplnění seznamu návrhů“, kde je vybrána volba SQL dotazem, pro seznam hodnot atributu „naplnění seznamu návrhů“, kde je vybrána volba Výčtem nebo pro skript v jazyce Foxpro, který vytvoří seznam hodnot „naplnění seznamu návrhů“=skriptem

¨ počet řádků – v tomto atributu lze nastavit počet řádků zobrazovaných v seznamu návrhů funkce automatického dokončování. Udává se zde maximální počet zobrazovaných řádků, při užití funkce automatického dokončování může být počet řádků zobrazených v seznamu návrhů menší v závislosti na výšce okna aktuálního formuláře.

¨ výraz prefixu – text – výraz v jazyce Foxpro

¨ uplatní se znaků – uvádí se zde počet znaků vstupovaného pole, které se uplatní jako výběr pro naplnění seznamu návrhů (uvedená hodnota -1=všechny znaky)

¨ přenášet hodnotu – překryvný seznam Ano/Ne – při nastavení volby Ano se hodnota pole automaticky přenáší do vstupovaného pole při listování v aktivním seznamu návrhů (aktivní seznam návrhů si uživatel vyvolá např. po užití klávesy Ctrl+ ŠIPKA DOLŮ)

¨ poznámka - text - libovolný text

Takto definované parametry jsou specifické pro dané pole daného formuláře pro aktuálně přihlášeného uživatele systému. Správce systému má možnost aktivovat funkci automatického dokončování pro dané pole daného formuláře pro všechny uživatele systému založením parametrů pro uživatele SYSTÉM. Pokud jsou pro dané pole definovány parametry polí formulářů pro uživatele SYSTÉM a zároveň i pro konkrétního uživatele, potom se uplatňuje nastavení konkrétního uživatele (tj. aktuálně přihlášeného).

Při vstupu textového pole formuláře, pro které je aktivní funkce automatického dokončování, zobrazuje IS BM seznam návrhů na dokončení v překryvném seznamu. Pokud určitý návrh v seznamu odpovídá požadovaným kritériím pro dané pole, dvojklikněte na něj nebo jej vyberte pomocí klávesy ŠIPKA DOLŮ a potom stiskněte klávesu ENTER.

Přechod do seznamu návrhů z klávesnice s možností vybírat si přímo stiskem počátečních písmen textu jeho položek poskytuje uživateli kombinace kláves CTRL+ ŠIPKA DOLŮ. Uživatel se po její aktivaci přemístí kurzorem do seznamu návrhů, ve kterém je umožněn pohyb přímo stiskem počátečních písmen textu jednotlivých návrhů. Klávesu CTRL+ ŠIPKA DOLŮ je možno použít i v případě, že seznám návrhů není právě zobrazen.

Je-li potřeba ze seznamu návrhů na dokončení vymazat jednotlivé položky, je nutno umístit kurzor na požadovanou položku v seznamu návrhů a stisknout klávesu DELETE (při nastavení parametrů „naplnění seznamu návrhů – Vstupem“ a „přidávat do seznamu návrhů – Ano“). Seznam návrhů funkce automatického dokončování se automaticky zobrazí při vstupu jakéhokoliv znaku v daném poli.

Pokud má uživatel již seznam návrhů funkce automatického dokončování pro svoji potřebu naplněn, nastaví pak u parametru polí formulářů na atributu „přidávat do seznamu návrhů – Ne“. Pak mu stávající seznam návrhů zůstane zachován a další návrhy se již nebudou do seznamu přidávat.

Nechce-li uživatel na daném atributu již používat funkci automatického dokončování, nastaví na daném parametru NE u atributu funkce automatického dokončování.

Pokud je funkce automatického dokončování nastavena pro pole vyhledávací záložky formuláře a výběrem položky ze seznamu návrhů je vrácen text delší než je jeho kapacita, potom je pole automaticky přepnuto do stavu rozšířeného vyhledávání (klávesa CTRL+SPACE na výběrové záložce formuláře na znakové položce vyvolává okno pro vstup delšího textu, tím je umožněno zadat delší text pro formátovaný pro výběr v SQL dotazu v klauzuli LIKE).

Podle nastavení parametru pole formuláře „naplnění seznamu návrhů“ vytváří IS BM tento seznam návrhů:

¨ nastavení Vstupem - funkce automatického dokončování uchovává hodnoty zadávané v poli formuláře, jakou je například položka, kterou jste právě zadali po stisku klávesy Ctrl Home. V budoucnu pak může kontrolovat předchozí zadané položky a při zadávání nových položek zobrazovat návrhy.

Seznam návrhů se vytváří tímto způsobem zvlášť pro každého uživatele BM, např. na výběrové záložce činnosti adresář se v názvu adresáta mohou zobrazovat často hledané názvy adresátů v případě, že po zapsání názvu adresáta do výběrového pole uživatel stiskne klávesu Ctrl Home. Pokud tuto klávesu nestiskne, název tohoto adresáta se automaticky předplňovat nebude.

¨ nastavení SQL dotazem - seznam návrhů je naplněn na základě SQL dotazu, např. formulář Adresář může mít pro pole obchodního selektoru na výběrové záložce nastaven parametr SQL/Výčet:

SELECT SP10IDZAK FROM %%%.SPSEOB ORDER BY SP10IDZAK

¨ nastavení Výčtem - seznam návrhů je naplněn na základě textu uvedeného ve výčtu, např.

formulář Procesy může mít pro pole roku identifikace procesu na výběrové záložce nastaven parametr SQL/Výčet:

2001

2002

2003

2004

Při definování obsahu parametru SQL/Výčet je možné používat makra (viz. ukázky dále v textu). Definice maker se vyvolá po zapsání atributů parametrů polí formulářů po stisku klávesy F5 nebo aktivací činnosti z menu Volby. Je vhodné zejména u nastavování návrhů pro atributy, které se opakují v různých formulářích IS BM, aby na každém z nich nemusel uživatel zvlášť definovat parametry polí formulářů.

¨ nastavení Skriptem – seznam návrhů je naplněn vyvoláním kódu v jazyce Foxpro, např. formulář „Procesy“ může mít pro pole roku identifikace procesu na výběrové záložce nastaven parametr SQL/Výčet/Skript:

<pre>

LOCAL _i,_rt

_rt=''

FOR _i=2000 TO YEAR(DATE())

_rt=_rt+TRANS(_i)+CHR(13)

ENDFOR

RETURN _rt

</pre>

Naplnění seznamu návrhů tvořených SQL dotazem nebo Výčtem může být tvořeno jedním nebo dvěma sloupci,

¨ např. formulář Adresář může mít pro pole obchodního selektoru na výběrové záložce nastaven parametr SQL/Výčet:

SELECT SP10TEXT,SP10IDZAK FROM %%%.SPSEOB ORDER BY SP10TEXT,

což v praxi znamená, že uživatel do pole obchodního selektoru zapisuje jeho identifikaci a přitom se mu v seznamu návrhů zobrazují názvy obchodních selektorů.

¨ např. formulář Procesy může mít pro pole roku identifikace procesu na výběrové záložce nastaven parametr SQL/Výčet:

Rok 01|2001

Rok 02|2002

Rok 03|2003

Rok 04|2004

V tom případě jsou v seznamu návrhů zobrazovány texty obsažené v prvním sloupci a položky seznamu návrhů vybírány a vraceny podle druhého sloupce, převedeno do praxe .. uživatel si vybírá z návrhů Rok 01, Rok 02 apod., ale po výběru tohoto návrhu je do atributu předplněno 2001, 2002.

Výraz prefixu se obvykle používá ve spojení s nastavením „naplnění seznamu návrhů“ hodnotou SQL dotazem.

Výraz prefixu je vyhodnocován v okamžiku vytváření seznamu návrhů objektem daného pole formuláře, jeho hodnota filtruje položky vložené do seznamu návrhů. Typicky se tato možnost používá při implementaci funkce automatického dokončování pro pole formulářů, ve kterých se vstupuje artikl, např. obchodovatelný artikl:

Parametr SQL dotaz

SELECT SP62ARTIKL,OBARTIKL.SP61ID+OBARTIKL.SP60ID FROM %%%.OBARTIKL,%%%.SPARTIKN

WHERE SPARTIKN.SP61ID=OBARTIKL.SP61ID AND SPARTIKN.SP60ID=OBARTIKL.SP60ID AND

SPARTIKN.SP38ID=?TOOL.JAZYK AND SP00AKTUAL=1 ORDER BY SP62ARTIKL

Parametr Výraz prefixu

THIS.PARENT.SP61ID.VALUE

Podle SQL dotazu je ve druhý sloupec seznamu návrhů naplněn výrazem OBARTIKL.SP61ID+OBARTIKL.SP60ID.

Při vytváření seznamu návrhů je polem, ve kterém je vstupována identifikace artiklu, vyhodnocen výraz THIS.PARENT.SP61ID.VALUE

a tím je zjištěna hodnota identifikace druhu artiklu vstoupená uživatelem na stejné stránce fomuláře. Do seznamu návrhů jsou potom naplněny artikly daného druhu.

SQL dotaz je obvykle vyhodnocován pouze jednou, při prvním vytváření seznamu návrhů daného pole formuláře. V některých případech je vhodné omezit počet vrácených záznamů a SQL dotaz provádět při každé změně seznamu návrhů. V tom případě se výraz SQL dotazu uvádí znakem '*' a hodnota prefixu je v tomto výrazu prezentována parametrem ?_P1.

Jedná se např. o implementaci funkce automatického dokončování pro pole formulářů, ve kterých se vstupuje spojení adresátů:

Parametr SQL dotaz

*SELECT AD11JMENO,AD01ID+AD11CISSPO FROM %%%.ADSPOJ WHERE AD01ID=?_P1 AND TRIM(AD11JMENO)<>'' ORDER BY AD11JMENO

Parametr Výraz prefixu

THIS.PARENT.AD01ID.VALUE

Potlačení funkce automatického dokončování pro toto pole proveďte nastavením Funkce automatického dokončování - ne a zrušením záznamu, jinak by se při instalaci nové verze IS BM tento parametr opětovně založil.

Při definování obsahu parametru SQL/Výčet je možné používat makra. Příklady maker:

*

ID=SYS001

Název=SQL_spseob_XXX

select sp10text,left(sp10idzak,3) from %%%.spseob where sp10idzak like '___000000' and current date between isnull(sp10datum,current date) and isnull(sp10datumd,current date) order by sp10text

*

ID=SYS002

Název=SQL_mtskl

select mt04text,mt04id from %%%.mtskl order by mt04text

*

ID=SYS003

Název=SQL_spseob

select sp10text,sp10idzak from %%%.spseob where current date between isnull(sp10datum,current date) and isnull(sp10datumd,current date) order by sp10text

*

ID=SYS004

Název=SQL_obumist

SELECT ob05text,ob05id FROM OBUMIST order by OBUMIST.ob05text

*

ZÁLOŽKA „SKRIPTY POLE“ (definují se zde skripty v jazyce FoxPro daného pole formuláře)

Na této záložce nazvané 'Skripty pole' se definuje:

¨ typ skriptu - překryvný seznam - zatím je aplikován jediný typ skriptu 'Reakce na F2'

¨ skript - text - obsahuje kód v jazyce Foxpro

¨ poznámka

Pro uplatnění skriptů vzhledem k uživateli vedeném u skriptu platí totéž, co platí v tomto smyslu pro 'Funkce automatického dokončování':

¨ takto definované parametry jsou specifické pro dané pole daného formuláře pro aktuálně přihlášeného uživatele systému

¨ uživatel s právy správce systému má možnost aktivovat funkci automatického dokončování pro dané pole daného formuláře pro všechny uživatele systému založením parametrů pro uživatele SYSTÉM

¨ pokud je pro pole definováno Globální nastavení parametrů a zároveň nastavení parametrů uživatele, potom se uplatňuje nastavení uživatele

Skript typu 'Reakce na F2' se provádí na vstupním poli formuláře po stisku klávesy F2 resp. po pravém kliku myší.

Tomuto skriptu jsou předávány parametry (ve skriptu se neuvádí příkaz PARAMETER):

- _this - objekt, na kterém uživatel stiskl klávesu F2

- _thisform - objekt formuláře

Skript musí vracet hodnotu:

- .T. - TRUE - v případě, že skript proběhl a nemá být provedena funkce, která je pro 'Reakci na F2' naprogramována v BM.EXE

- .F. - FALSE - v případě, že skript neproběhl a má být provedena funkce, která je pro 'Reakci na F2' naprogramována v BM.EXE

Jediný společný skript je určen pro pole umístěná v mřížce a pro pole na stránce formuláře. Pokud nemá být skript proveden pro pole v mřížce, může být tato potřeba ošetřena na začátku skriptu např. kódem:

<pre>

IF UPPER(_this.parent.baseclass)='COLUMN'

RETURN .F.

ENDIF

</pre>

Příklad skriptu, který po pravém kliku myší na datu události obchodu v gridu vyvolá kalendář a potom zapíše do události vrácenou hodnotu:

<pre>

Local _ret

Do Case

Case !_thisform.komp_stav

* když se nejedná o spuštěnou operaci, provede se obvyklá akce po F2 naprogramovaná v BM.EXE

Return .F.

Case _thisform._o_kompo_.ukoncena

* když se jedná o ukončenou operaci, provede se obvyklá akce po F2 naprogramovaná v BM.EXE

Return .F.

Case _thisform._o_kompo_.sp07idtypd<>'PROCES'

* když se nejedná o operaci druhu procesu 'PROCES', provede se obvyklá akce po F2 naprogramovaná v BM.EXE

Return .F.

Case Upper(_this.Parent.BaseClass)<>'COLUMN'

* když se nejedná o pole v mřížce, provede se obvyklá akce po F2 naprogramovaná v BM.EXE

Return .F.

Endcase

If Val(Tool.get_prof('','CalendarXP','1',.T.))=1

Do bw_prika With [Do Form bw_gdate With _p1,.T. to _p2],_this.Value,_ret

Else

Do bw_prika With [Do Form bw_gdatx With _p1,.T. to _p2],_this.Value,_ret

Endif

If Type('_ret')$'TD' And _ret<>Nvl(_this.Value,{})

_this.Value=_ret

_thisform._pf_.p1.ob02datdod.Value=Max(_thisform._pf_.p1.ob02datdod.Value,_ret)

_thisform._pf_.p1.ob02dat.Refresh

If !_thisform._edit

_thisform.formakce('=')

Endif

Endif

* když skript nevrátí hodnotu .F. ('RETURN .T.' nemusí být uveden, protože skript, který nebyl ukončen příkazem RETURN, vždy vrací hodnotu .T.),

* tak se neprovede obvyklá akce po F2 naprogramovaná v BM.EXE

</pre>

Datový model

  • BWFLDPAR Parametry pole formuláře
    • BWUZIVAT Uživatel systému

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Definice maker | Definice maker
F2 | Výběr makra | Výběr makra

    Formulář

    Formulář činnosti - Výběr makra
Mřížka [Parametry]
Činnost | Identifikace činnosti
Název činnosti | Název činnosti
Pole | Pole formuláře
Uživatel | Identifikace uživatele systému
Listovací rámeček
Stránka #1 Parametry
Funkce automatického dokončování | Aktivní funkce automatického dokončování Ano/Ne
Naplnění seznamu návrhů | Naplnění seznamu návrhů
SQL/Výčet/Skript | SQL dotaz pro vytvoření seznamu návrhů / Výčet obsahu návrhu / Skript v jazyce Foxpro
Výraz prefixu | Výraz prefixu hodnoty v seznamu návrhů
Uplatní se znaků | Počet znaků vstupovaného pole, které se uplatní jako výběr pro naplnění seznamu návrhů (-1=všechny)
Přenášet hodnotu | Přenášení hodnoty do vstupovaného pole při listování v aktivním seznamu návrhů (aktivním např. po užití klávesy CTRL+ŠIPKA_DOLŮ)
Poznámka | Poznámka
Stránka #2 Výběr
Činnost | Identifikace činnosti
Pole | Pole formuláře
Uživatel | Identifikace uživatele systému
Funkce automatického dokončování | Aktivní funkce automatického dokončování Ano/Ne
Naplnění seznamu návrhů | Naplnění seznamu návrhů
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Parametry] činnosti - Výběr makra

    Mřížka [Parametry] činnosti - Výběr makra
Činnost | Identifikace činnosti
Pole | Pole formuláře
Uživatel | Identifikace uživatele systému
Jméno uživatele | Jméno uživatele systému
Funkce automatického dokončování | Aktivní funkce automatického dokončování Ano/Ne
Naplnění seznamu návrhů | Naplnění seznamu návrhů

    Atributy tisku

    Základní údaje
Činnost | Identifikace činnosti | BWFLDPAR_bw02krok | C(6)
Pole | Pole formuláře | BWFLDPAR_bwa2nazev | C(30)
Uživatel | Identifikace uživatele systému | BWFLDPAR_bw01uziv | C(6)
Funkce automatického dokončování | Aktivní funkce automatického dokončování Ano/Ne | Výpočet | C(3)
Naplnění seznamu návrhů | Naplnění seznamu návrhů | Výpočet | C(11)
SQL/Výčet/Skript | SQL dotaz pro vytvoření seznamu návrhů / Výčet obsahu návrhu / Skript v jazyce Foxpro | BWFLDPAR_bwa2acmpsq | M
Výraz prefixu | Výraz prefixu hodnoty v seznamu návrhů | BWFLDPAR_bwa2acmppx | M
Uplatní se znaků | Počet znaků vstupovaného pole, které se uplatní jako výběr pro naplnění seznamu návrhů (-1=všechny) | BWFLDPAR_bwa2chrcnt | N(3)
Přenášet hodnotu | Přenášení hodnoty do vstupovaného pole při listování v aktivním seznamu návrhů (aktivním např. po užití klávesy CTRL+ŠIPKA_DOLŮ) | Výpočet | C(3)
Poznámka | Poznámka | BWFLDPAR_bwa2koment | M

    Viz.také

    Definice maker | Výběr makra


Systémové certifikáty

Popis

Pro potřeby digitálního podpisu lze ukládat v BM systémové certifikáty. Systémové certifikáty se definují ve formuláři činnosti Systémové certifikáty (v hlavním menu Informační centrum – Typy a řady). Definuje se:

¨ Identifikace systémového certifikátu - 6 znaků

¨ Název certifikátu

¨ Druh certifikátu – k druhu certifikátu lze definovat přístupová práva

¨ Soubor certifikátu - jméno souboru na disku s příponou PFX (exportovaný privátní klíč)

¨ Poznámka

Ke každému systémovému certifikátu je nutné uložit heslo, se kterým byl soubor certifikátu (PFX) vytvořen.

Provádí se v menu Volby -> Definovat heslo nebo pomocí klávesy F5 („definovat heslo“). Toto heslo je uloženo v databázi zakryptované (tj. zašifrované).

Podepisování dokumentů probíhá interními rutinami BM.EXE, kterým je jedním z parametrů předána 'Identifikace systémového certifikátu'.

V současnosti je tímto způsobem vyřešeno podepisování dokumentů:

¨ PDF - Acrobat Reader - podepisování nástrojem PortableSigner (Open Source) http://portablesigner.sourceforge.net/

¨ XML - podle norem XML Signature Syntax and Processing (Second Edition) http://www.w3.org/TR/xmldsig-core/, XML Encryption Syntax and Processing http://www.w3.org/TR/xmlenc-core/ , Canonical XML http://www.w3.org/TR/xml-c14n, Exclusive XML Canonicalization http://www.w3.org/TR/xml-exc-c14n/ - podepisování nástrojem XML Security Library (Open Source) http://www.aleksey.com/xmlsec/index.html - tento způsob podepisování dokumentů se používá pro soubory ve formátu ISDOC (tj. elektronická fakturace)

Datový model

  • SPCERT Systémové certifikáty
    • SPPREDKD Druh obecné předkontace
      • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Vybrat soubor dokumentu
Mřížka [Systémové certifikáty]
Certifikát | Identifikátor certifikátu
Název certifikátu | Název certifikátu
Druh | Identifikátor druhu obecné předkontace
Název druhu | Název druhu obecné předkontace
Soubor | Soubor certifikátu
Poznámka | Poznámka

    Mřížka [Systémové certifikáty] činnosti - Vybrat soubor dokumentu

    Mřížka [Systémové certifikáty] činnosti - Vybrat soubor dokumentu
Certifikát | Identifikátor certifikátu
Název certifikátu | Název certifikátu
Druh | Identifikátor druhu obecné předkontace
Název druhu | Název druhu obecné předkontace

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Definovat heslo | Definovat heslo
F2 | Druh obecné předkontace | Druh obecné předkontace
F2 | Vybrat soubor dokumentu | Vybrat soubor dokumentu

    Atributy tisku

    Základní údaje
Certifikát | Identifikátor certifikátu | SPCERT_spg1id | C(6)
Název certifikátu | Název certifikátu | SPCERT_spg1nazev | C(40)
Druh | Identifikátor druhu obecné předkontace | SPCERT_spe1id | C(6)
Název druhu | Název druhu obecné předkontace | SPPREDKD_spe1nazdru | C(40)
Soubor | Soubor certifikátu | SPCERT_spg1soubor | M
Poznámka | Poznámka | SPCERT_spg1koment | M

    Viz.také

    Definovat heslo | Druh obecné předkontace | Vybrat soubor dokumentu


SPRÁVA ARTIKLU

Popis

Správa artiklu je kompomenta, která se nachází v hlavním menu pod menu Informační centrum. Umožňuje evidovat veškeré artikly IS, které jsou členěny podle druhu artiklu a je možno je zařazovat i do kategorií artiklu. V této složce jsou obsaženy tyto činnosti:

¨ události správy artiklu

¨ druhy artiklu

¨ artikl

¨ kategorie událostí správy artiklu

¨ palety barev kategorií

¨ legenda palety barev

¨ algoritmy předplnění a validace artiklu

Viz.také

Události správy artiklu | Druhy artiklů | Artikl | Kategorie událostí správy artiklu | Palety barev kategorií | Legenda palety barev | Algoritmy předplnění a validace artiklu


Události správy artiklu

Popis

Jednotlivé události správy artiklu může uživatel vstupovat jak procesně, tak samostatně mimo proces (obdobně jako události vývěsky). Události správy artiklu slouží především k zařazování artiklů do jednotlivých kategorií.

Při zadávání událostí správy artiklu uživatel vstupuje:

¨ datum

¨ popis události

¨ druh artiklu a artikl – výběr z číselníku

¨ kategorii

¨ platnost artiklu v kategorii od (případně i do)

¨ adresáta, kterého se událost artiklu týká

¨ poznámku

¨ jednotlivé selektory

Datový model

  • SAUDAL Událost správy artiklu
    • SPPRCOD Operace procesu
      • SPTYP Druh procesu/operace
      • SPPRC Proces
    • SPARTIKL Artikl
      • SPARTIKN Název artiklu
    • SAKATEG Kategorie události správy artiklu
      • SPPRISTU Přístupové právo uživatele k věci
    • ADSPOJ Spojení adresáta
      • ADADSAT Adresát
    • BWUZIVAT Uživatel systému

    • Formulář

    Formulář činnosti - OZNAČOVÁNÍ
Mřížka [Události]
Listovací rámeček
Stránka #1 Události
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
 | Pořadí stejného druhu operace v jednom procesu
Druh | Identifikátor druhu operace
 | Název druhu operace
Datum | Datum události
Popis | Popis události
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Kategorie | Identifikace kategorie události správy artiklu
Platnost | Datum platnosti od
Platnost do | Datum platnosti do
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
Poznámka | Poznámka
Selektory | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Založil | Jméno uživatele systému
Datum a čas zápisu | Datum a čas zápisu záznamu události
Stránka #2 Výběr
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
 | Pořadové číslo procesu
Druh operace | Identifikátor druhu operace
Druh procesu | Identifikátor druhu procesu
Datum | Datum události
 | Datum události do
Popis | Popis události
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Kategorie | Identifikace kategorie události správy artiklu
Název kategorie | Název kategorie události správy artiklu
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 | Platnost nebo neplatnost k datu
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
 | Identifikace kategorie adresáta.
Selektory | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Zapsané | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Události] činnosti - OZNAČOVÁNÍ

    Mřížka [Události] činnosti - OZNAČOVÁNÍ
Označování | Označení záznamu
Datum | Datum události
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Kategorie | Identifikace kategorie události správy artiklu
Název kategorie | Název kategorie události správy artiklu
Platnost od | Datum platnosti od
Platnost do | Datum platnosti do
Popis | Popis události
Název adresáta | Název adresáta

    Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
- | INFORMACE O ARTIKLU | Přehled informací o artiklu
F2 | Adresář | Přehled adresátů
F2 | Artikl | Seznam artiklu
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Kategorie událostí správy artiklu | Přehled kategorií událostí správy artiklu
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Atributy tisku

    Základní údaje
Datum | Datum události | SAUDAL_sa02dat | D
Popis | Popis události | SAUDAL_sa02text | C(40)
Druh artiklu | Identifikace druhu artiklu | SAUDAL_sp61id | C(3)
Artikl | Identifikace artiklu | SAUDAL_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Kategorie | Identifikace kategorie události správy artiklu | SAUDAL_sa05id | C(6)
Název kategorie | Název kategorie události správy artiklu | SAKATEG_sa05nazkat | C(40)
Platnost od | Datum platnosti od | SAUDAL_sa02platod | D
Adresát | Identifikace adresáta | SAUDAL_ad01id | C(6)
Platnost do | Datum platnosti do | SAUDAL_sa02platdo | D
Spojení | Číslo spojení adresáta. | SAUDAL_ad11cisspo | C(2)
Adresát | Název adresáta | ADADSAT_ad01adsat | C(100)
Poznámka | Poznámka | SAUDAL_sa02koment | M
Datum a čas zápisu | Datum a čas zápisu záznamu události | SAUDAL_sp00datzap | T
Obch. sel. | Identifikátor obchodního selektoru | SAUDAL_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | SAUDAL_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | SAUDAL_sp20idzak | C(9)
Rok | Rok v identifikaci procesu | SAUDAL_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | SAUDAL_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | SAUDAL_sp33cisd | C(8)
Název druhu operace | Název druhu procesu | SPTYP_sp07text | C(30)
Druh operace | Identifikátor druhu operace | SAUDAL_sp07idtyp | C(6)

    Viz.také

    OZNAČOVÁNÍ | Prezentace artiklu | INFORMACE O ARTIKLU | Adresář | Artikl | Druhy artiklů | Kategorie adresátů | Kategorie událostí správy artiklu | Obchodní selektor | Organizační selektor | Spojení adresátů | Technicko-věcný selektor


Druhy artiklů

Popis

Uživateli se zobrazuje přehled (neboli číselník) druhů artiklů, který může aktualizovat, opravovat nebo rušit.

Druhy artiklů v podstatě suplují funkci číselníku materiálových skupin. Umožňují vést neomezený počet druhů artiklů (např. spravovaný majetek, zásoby, materiál na skladě ...) a v podstatě potom každý tento druh artiklu má svojí vlastní číselnou řadu (jednoznačnou identifikaci) neboli druhy artiklů umožňují veškerý artikl, který má firma k dispozici, rozdělit do několika druhů, aby nedocházelo k tomu, že se všechen artikl bude číslovat pouze na základě jedné číselné řady. U každého artiklu je možno nadefinovat určité údaje, které se pak při jeho zařazování budou takto automaticky předplňovat (např. vztah k účetnictví, vztah ceny k DPH, charakter, typ zdanitelného plnění apod.).

U každého druhu artiklu je možno dále nastavit:

¨ algoritmus předplnění a validace

¨ barva písma – barva písma řádku v mřížce

¨ barva pozadí – barva pozadí řádku v mřížce

Pro uživatele může v souvislosti s historií ceny artiklu být zajímavý ještě atribut "předplňovat - evidovat historii ceny artiklu". Zaškrtnutím tohoto atributu uživatel dosáhne toho, že při zadávání artiklu (Informační centrum - Typy a řady - Artikly) se mu atribut "historie ceny" zapíše automaticky u artiklu daného druhu jako zaškrtnutý. Poté např. i v ceníku artiklu může sledovat u daného artiklu historii ceny.

V činnosti druhy artiklů má navíc uživatel k dispozici záložku "výskyt druhu artiklu". K dispozici jsou tyto údaje:

¨ skladovaný artikl

¨ artikly personalistiky

¨ předmět projektu

¨ obchodovatelný artikl

¨ artikl obecné komponenty

¨ spravovaný majetek

V podstatě se jedná o to, aby při zařazení nového artiklu do určitého druhu bylo možno určit, zda se tento artikl má zařadit pouze do skladovaného nebo zároveň i do obchodovatelného artiklu. Do jakých artiklů současně se právě určí zatržením příznaku v tabulce pod záložkou "výskyt druhu artiklu".

Datový model

  • SPARTIKD Druh artiklu
    • DPZPT Typ zdanitelného plnění
    • BWRGBCOL Hodnota RGB barvy
    • BWRGBCOL Hodnota RGB barvy (alias BWRGBCOL2)

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Algoritmy předplnění a validace artiklu | Algoritmy předplnění a validace identifikace nového artiklu
F2 | Barvy RGB |
F2 | Klasifikace objektů | Klasifikace objektů
F2 | Typ zdanitelného plnění | Číselník typů zdanitelného plnění

    Formulář

    Formulář činnosti - Algoritmy předplnění a validace artiklu
Mřížka [Druhy artiklu]
Druh | Identifikace druhu artiklu
Název druhu artiklu | Název druhu artiklu
Listovací rámeček
Stránka #1 Druhy artiklů
Předplňovat vztah k účetnictví | Vztah k účetnictví - zboží, materiál, výrobek, služba ...
Předplňovat vztah ceny k DPH | Vztah ceny artiklu k DPH - cena bez DPH,cena včetně DPH, cena včetně DPH z rozdílu nákladů a konečné ceny
Předplňovat charakter | Charakter artiklu - skladovaný, neskladovaný
Předplňovat typ zdanitelného plnění | Identifikace typu zdanitelného plnění
 | Název typu zdanitelného plnění
Předplňovat klasifikaci artiklu | Identifikace klasifikace objektu artiklu
Algoritmus předplnění a validace | Algoritmus předplnění a validace identifikace nového artiklu
B.písma | Barva písma řádku v mřížce
B.pozadí | Barva pozadí řádku v mřížce
Předplňovat - evidovat historii ceny artiklu | Předplňovat - evidovat historii ceny artiklu
Stránka #2 Poznámka
Komentář | Komentář ke druhu artiklu
Stránka #3 Výskyt druhu artiklu
Mřížka [Výskyt druhu artiklu]

    Mřížka [Druhy artiklu] činnosti - Algoritmy předplnění a validace artiklu

    Mřížka [Druhy artiklu] činnosti - Algoritmy předplnění a validace artiklu
Druh | Identifikace druhu artiklu
Název druhu artiklu | Název druhu artiklu

    Mřížka [Výskyt druhu artiklu] činnosti - Algoritmy předplnění a validace artiklu

    Mřížka [Výskyt druhu artiklu] činnosti - Algoritmy předplnění a validace artiklu
Označování | Označení záznamu
Název tabulky | Název tabulky

    Atributy tisku

    Základní údaje
Druh artiklu | Identifikace druhu artiklu | SPARTIKD_sp61id | C(3)
Název druhu artiklu | Název druhu artiklu | SPARTIKD_sp61nazdru | C(40)
Komentář | Komentář ke druhu artiklu | SPARTIKD_sp61koment | M
Předplňovat vztah k účetnictví | Vztah k účetnictví - zboží, materiál, výrobek, služba ... | Výpočet | C(8)
Předplňovat vztah ceny k DPH | Vztah ceny artiklu k DPH - cena bez DPH,cena včetně DPH, cena včetně DPH z rozdílu nákladů a konečné ceny | Výpočet | C(23)
Předplňovat charakter | Charakter artiklu - skladovaný, neskladovaný | Výpočet | C(12)
Předplňovat typ zdanitelného plnění | Identifikace typu zdanitelného plnění | SPARTIKD_dp03id | C(3)
Název | Název typu zdanitelného plnění | DPZPT_dp03text | C(40)
Předplňovat klasifikaci artiklu | Identifikace klasifikace objektu artiklu | SPARTIKD_pa13idart | C(12)
Název klasifikace objektu | Název klasifikace objektu | PAOBJDRU_pa13nazdru | C(40)
Algoritmus | Název algoritmu | SPARTALG_spe3nazalg | C(40)

    Viz.také

    Algoritmy předplnění a validace artiklu | Barvy RGB | Klasifikace objektů | Typ zdanitelného plnění


Artikl

Popis

Tato činnost poskytuje uživateli přehled všech dosud nadefinovaných a do systému vložených artiklů. Je to v podstatě jakoby číselník veškerých artiklů všech druhů, který může uživatel zakládat, opravovat a rušit. U každého artiklu se eviduje jeho druh, jednoznačné identifikační číslo a jeho název. Navíc je možno u každého artiklu nastavit, zda se u něj má evidovat historie ceny či nikoliv. Pokud je zatrženo, bude se u daného artiklu evidovat historie jednotlivých typů cen. Příznak „historie ceny“ je automaticky zatržen, pokud má druh daného artiklu zatržený atribut „předplňovat – evidovat historii ceny artiklu v činnosti Druhy artiklů Historie cen je zaznamenána, je-li provedena změna ceny v ceníku. Ke změně ceny může dojít dvojím způsobem:

¨ přímým přepsáním ceny v ceníku

¨ přepsáním ceny v událostech obchodu s tím, že na událostech obchodu je zaškrtnut atribut "aktualizovat cenu"

Záložka "názvy artiklu" umožňuje uživateli překlad názvů artiklu do cizí řeči.

Záložka "vztah měrných jednotek artiklu" umožňuje uživateli nadefinovat jaké jsou vztahy mezi jednotlivými jednotkami, pokud u některého artiklu je třeba evidence ve dvou měrných jednotkách. Např. určitý artikl se může prodávat v kusech, ale nakupuje se pouze v celých baleních. Pak je nutno nadefinovat vztah, kolik kusů obsahuje jedno balení.

Záložka „kategorie artiklu“ umožňuje každému artiklu přiřadit jednotlivé nadefinované kategorie událostí správy artiklu. Artikl je evidován v kategorii pokud poslední událost s datem události do dnešního dne včetně má uvedenu platnost od – do v intervalu, do kterého spadá dotazované datum (poslední událost je ta, která má nejvyšší datum události a v případě dvou událostí se stejným datem je to ta, která má nejvyšší datum a čas zápisu události). Z toho vyplývá, že:

¨ příslušnost artiklu v kategorii je možno plánovat do budoucna

¨ pokud existuje více událostí se stejnou kategorií pro stejný artikl nenaplánované do budoucnosti, uplatňuje se pro stanovení příslušnosti artiklu do kategorie právě a pouze poslední událost z nich na časové ose (určené datem události a datem a časem zápisu události)

Událost s kategorií, která má nastavenu platnost od – do, ovlivňuje výběry artiklů. Na výběrových záložkách formulářů artiklů se uvádí:

¨ příslušnost artiklu v dané kategorii – překryvný seznam – Je / Není / Byl / Nebyl (tj. Je=k dnešnímu datu je v kategorii, Není=k dnešnímu datu není v kategorii, Byl=není v kategorii, ale byl, Nebyl=není a nikdy v kategorii nebyl). Dále se zadává identifikátor a název kategorie

¨ platnost – překryvný seznam – Platné i neplatné / Platné dnes / Neplatné dnes / Platné k datu / Neplatné k datu. Následující atribut „datum“ je spojen s platností Platné k datu a Neplatné k datu. Za platný artikl je považován takový, pro který neexistuje žádná událost s kategorií určující platnost a poslední událost o libovolné kategorii určující platnost nenaplánovaná do budoucnosti má uvedenou platnost od – do, do které spadá odpovídající datum.

Na základě zvolení Palety na záložce Výběr je možno přehled artiklů zvýraznit i barevně. Pokud uživatel vybere z překryvného seznamu paletu a zaškrtávací políčko před zůstane prázdné, budou po zapsání Výběru zobrazeny všechny artikly (podle nastaveného Výběru) a ty, které spadají do kategorií dané palety (barva je přiřazena kategorii) budou vyznačeny barevně.

Pokud uživatel vybere z překryvného seznamu paletu a zaškrtne zároveň políčko před, budou po zapsání Výběru zobrazeny (v příslušné barvě) pouze ty artikly, které spadají do dané palety (resp. ty, které jsou nadefinovány v kategoriích dané palety).

Menu Volby formulářů artiklů bylo doplněno o vyvolání formuláře Události správy artiklu (ve většině případů klávesa F6 nebo pokud byla tato klávesa již obsazena, tak přímou aktivací této činnosti z menu Volby). Pod menu Volby má uživatel dostupnou i činnost prezentace artiklu (možnost vložení k artiklu např. foto apod.). Pod menu Obecné má uživatel k dispozici možnost definovat si a spouštět již nadefinované Volné karty a Volné karty artiklu.

Datový model

  • SPARTIKL Artikl
    • SPARTIKD Druh artiklu
    • SPARTIKN Název artiklu

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Ceník artiklu | Ceník obchodovatelných artiklů
F6 | Události správy artiklu |
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
- | Dokumenty artiklu | Dokumenty artiklu
- | INFORMACE O ARTIKLU | Přehled informací o artiklu
- | Legenda palety barev |
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Kategorie událostí správy artiklu | Přehled kategorií událostí správy artiklu
F2 | Měrné jednotky | Číselník měrných jednotek
F2 | Palety barev kategorií | Palety barev kategorií

    Formulář

     | Formulář činnosti - Legenda palety barev
 | Mřížka [Všeobecný artikl]
 |  | Identifikace druhu artiklu
 |  | Název druhu artiklu
 | Artikl | Identifikace artiklu
 | Název artiklu | Název artiklu
 | Listovací rámeček
 | Stránka #1 Artikl
 | Historie ceny | Evidovat historii ceny artiklu
 | Stránka #2 Názvy artiklu
 | Mřížka [Názvy artiklu v jazycích]
 | Jazyk | Identifikace jazyka
 | Název artiklu | Název artiklu
 | Stránka #3 Vztah měrných jednotek artiklu
 | Mřížka [Vztah měrných jednotek artiklu]
 | MJ | Identifikátor měrné jednotky
 |  | Název měrné jednotky
 | := | Vztah měrných jednotek
 | MJ | Identifikátor měrné jednotky
 |  | Název měrné jednotky
 | Stránka #4 Kategorie artiklu
 | Mřížka [Kategorie artiklu]
 |  | Kategorie
Identifikace kategorie události správy artiklu |  |  | Platnost
Datum platnosti od |  |  | Platnost do
Datum platnosti do |  |  | Popis
Popis události |  |  | Poznámka
Poznámka |  |  | Zapsal
Jméno uživatele systému |  |  | Datum a čas zápisu
Datum a čas zápisu záznamu události
 | Stránka #5 Výběr
 | Druh | Identifikace druhu artiklu
 | Artikl | Identifikace artiklu
 | Název artiklu | Název artiklu
 | Vztah ke kategorii | Vztah ke kategorii - Je=K dnešnímu datu je v kategorii, Není=K dnešnímu datu není v kategorii, Byl=Není v kategorii, ale byl, Nebyl=Není a nikdy nebyl v kategorii,Bude=Bude v kategorii
 | Kategorie | Identifikace kategorie události správy artiklu
 | Název kategorie | Název kategorie události správy artiklu
 | Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 |  | Platnost nebo neplatnost k datu
 | Paleta | Vybrat záznamy všech kategorií v paletě
 |  | Identifikace palety barev
 | Výběr | Určení výběru
 | Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Všeobecný artikl] činnosti - Legenda palety barev

    Mřížka [Všeobecný artikl] činnosti - Legenda palety barev
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu

    Mřížka [Názvy artiklu v jazycích] činnosti - Legenda palety barev

    Mřížka [Názvy artiklu v jazycích] činnosti - Legenda palety barev
Jazyk | Identifikace jazyka
Název artiklu | Název artiklu

    Mřížka [Vztah měrných jednotek artiklu] činnosti - Legenda palety barev

    Mřížka [Vztah měrných jednotek artiklu] činnosti - Legenda palety barev
MJ | Identifikátor měrné jednotky
Název měrné jednotky | Název měrné jednotky
:= | Vztah měrných jednotek
MJ | Identifikátor měrné jednotky
Název měrné jednotky | Název měrné jednotky

    Mřížka [Kategorie artiklu] činnosti - Legenda palety barev

    Mřížka [Kategorie artiklu] činnosti - Legenda palety barev
Kategorie | Identifikace kategorie události správy artiklu
Název kategorie | Název kategorie události správy artiklu
Platnost od | Datum platnosti od
Platnost do | Datum platnosti do

    Atributy tisku

    Základní údaje
Druh artiklu | Identifikace druhu artiklu | SPARTIKL_sp61id | C(3)
Název druhu artiklu | Název druhu artiklu | SPARTIKD_sp61nazdru | C(40)
Artikl | Identifikace artiklu | SPARTIKL_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Název kategorie | Název kategorie události správy artiklu | SAKATEG_sa05nazkat | C(40)
Zapsal | Jméno uživatele systému | BWUZIVASA_bw01jmeno | C(30)

    Při pohybu v Kategorie artiklu
Datum | Datum události | SAUDAL_sa02dat | D
Popis | Popis události | SAUDAL_sa02text | C(40)
Kategorie | Identifikace kategorie události správy artiklu | SAUDAL_sa05id | C(6)
Platnost od | Datum platnosti od | SAUDAL_sa02platod | D
Platnost do | Datum platnosti do | SAUDAL_sa02platdo | D
Adresát | Identifikace adresáta | SAUDAL_ad01id | C(6)
Spojení | Číslo spojení adresáta. | SAUDAL_ad11cisspo | C(2)
Obch. sel. | Identifikátor obchodního selektoru | SAUDAL_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | SAUDAL_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | SAUDAL_sp20idzak | C(9)
Poznámka | Poznámka | SAUDAL_sa02koment | M
Datum a čas zápisu | Datum a čas zápisu záznamu události | SAUDAL_sp00datzap | T

    Viz.také

    Ceník artiklu | Události správy artiklu | Prezentace artiklu | Dokumenty artiklu | INFORMACE O ARTIKLU | Legenda palety barev | Druhy artiklů | Kategorie událostí správy artiklu | Měrné jednotky | Palety barev kategorií


Kategorie událostí správy artiklu

Popis

Tato činnost slouží uživateli pro definici kategorií událostí správy artiklu (např. platnost, zájem, artikl je užíván apod.). U každé kategorie se definuje:

¨ identifikace a název kategorie

¨ platnost – výběr Ano/Ne

¨ typ – Vstupovaná/Vypočítávaná

¨ barva písma

¨ barva pozadí

¨ poznámka

Na záložce „palety barev“ se zadává:

¨ identifikace palety barvy

¨ priorita – ovlivňuje výběr barvy pro danou paletu v případě, že se stejná paleta vyskytuje ve více kategoriích (1 je vyšší priorita než 2)

¨ barva písma

¨ barva pozadí

Na záložce „určení platnosti“ (platnost se určuje „zaškrtnutím“ daného druhu artiklu) se zaškrtávají tabulky artiklu, jichž se platnost týká (např. pro případ sledování, zda je na skladě minimální množství artiklu pro reklamace, ale jako skladovaný artikl se již neprodává, stačí platnost této kategorie definovat pouze pro obchodovatelný artikl).

Datový model

  • SAKATEG Kategorie události správy artiklu
    • SPPRISTU Přístupové právo uživatele k věci
    • BWRGBCOL Hodnota RGB barvy (alias BWRGBCOL3)
    • BWRGBCOL Hodnota RGB barvy (alias BWRGBCOL4)

    • Formulář

    Formulář činnosti - Palety barev kategorií
Mřížka [Kategorie událostí správy artiklu]
Kategorie | Identifikace kategorie události správy artiklu
Název kategorie | Název kategorie události správy artiklu
Listovací rámeček
Stránka #1 Kategorie
Platnost | Určuje platnost artiklu Ano/Ne
Typ | Typ kategorie - Vstupovaná / Vypočítaná
B.písma | Identifikace barvy RGB
B.pozadí | Identifikace barvy RGB
Poznámka | Poznámka
Stránka #2 Palety barev
Mřížka [Palety barev]
Paleta | Identifikace palety barev
Název palety | Název palety barev
Priorita | Priorita barvy
B.písma | Barva písma řádku v mřížce
B.pozadí | Barva pozadí řádku v mřížce
Stránka #3 Určení platnosti
Mřížka [Výskyt druhu artiklu]
Stránka #4 Výběr
Kategorie | Identifikace kategorie události správy artiklu
Název kategorie | Název kategorie události správy artiklu
Typ | Typ kategorie - Vstupovaná / Vypočítaná
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Kategorie událostí správy artiklu] činnosti - Palety barev kategorií

    Mřížka [Kategorie událostí správy artiklu] činnosti - Palety barev kategorií
Kategorie | Identifikace kategorie události správy artiklu
Název kategorie | Název kategorie události správy artiklu

    Mřížka [Palety barev] činnosti - Palety barev kategorií

    Mřížka [Palety barev] činnosti - Palety barev kategorií
Priorita | Priorita barvy
Název palety | Název palety barev

    Mřížka [Výskyt druhu artiklu] činnosti - Palety barev kategorií

    Mřížka [Výskyt druhu artiklu] činnosti - Palety barev kategorií
Označování | Označení záznamu
Název tabulky | Název tabulky

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Definování typu kategorie správy artiklu |
^B | Přístupová práva | Definování práv přístupu k věci
- | Palety barev kategorií | Palety barev kategorií
F2 | Barvy RGB |
F2 | Palety barev kategorií | Palety barev kategorií

    Atributy tisku

    Základní údaje
Kategorie | Identifikace kategorie události správy artiklu | SAKATEG_sa05id | C(6)
Název kategorie | Název kategorie události správy artiklu | SAKATEG_sa05nazkat | C(40)
Platnost | Určuje platnost artiklu Ano/Ne | Výpočet | C(3)
Typ | Typ kategorie - Vstupovaná / Vypočítaná | Výpočet | C(10)
SQL | Výraz v SQL vyhodnocovaný dotazem vracející numerickou hodnotu (0=není v kategoriii) použivá ID artiklu @sp61id,@sp60id | SAKATEG_sa05sql | M
Poznámka | Poznámka | SAKATEG_sa05koment | M
Barva | Identifikace barvy RGB | SAKATEG_bw95id | C(6)
Popis | Popis barvy RGB | BWRGBCOL3_bw95popbar | C(40)
Barva | Identifikace barvy RGB | SAKATEG_bw95id2 | C(6)
Popis | Popis barvy RGB | BWRGBCOL4_bw95popbar | C(40)
Název palety | Název palety barev | SAPALETA_sa08nazpal | C(40)
Popis | Popis barvy RGB | BWRGBCOL_bw95popbar | C(40)
Popis | Popis barvy RGB | BWRGBCOL2_bw95popbar | C(40)

    Při pohybu v Palety barev
Paleta | Identifikace palety barev | SAPALKAT_sa08id | C(6)
B.písma | Barva písma řádku v mřížce | SAPALKAT_bw95id | C(6)
B.pozadí | Barva pozadí řádku v mřížce | SAPALKAT_bw95id2 | C(6)
Priorita | Priorita barvy | SAPALKAT_sa06prior | N(3)

    Viz.také

    Definování typu kategorie správy artiklu | Přístupová práva | Barvy RGB | Palety barev kategorií


Palety barev kategorií

Popis

Tato činnost poskytuje uživateli možnost nadefinovat si jednotlivé palety barev pro vybrané kategorie (jinými slovy je definice palety určením způsobu vybarvení artiklu dané kategorie). U každé palety barev je nutno zadat:

¨ identifikaci a název palety

¨ skupina – výběr skupiny uživatelů nebo přímo konkrétního uživatele, který má k dané paletě přístup

Vlastní definice palety barev pro jednotlivé kategorie se provádí na záložce „kategorie v paletě“. Zde se u každé barevné palety (např. obchod – platný artikl, sklad – platný artikl apod.) eviduje kategorie události správy artiklu (i s informací o prioritě a barvě písma a pozadí). Pokud nastane okamžik, že některé kategorie budou disjunktní (tzn. prolíná se několik kategorií naráz), uplatní se ta s nejvyšší prioritou.

Datový model

  • SAPALETA Paleta barev kategorií artiklu

    • Formulář

    Formulář činnosti - Kategorie událostí správy artiklu
Mřížka [Palety barev kategorií]
Paleta | Identifikace palety barev
Název palety | Název palety barev
Listovací rámeček
Stránka #1 Palety barev kategorií
Skupina | Identifikace skupiny uživatelů
Poznámka | Poznámka
Stránka #2 Kategorie v paletě
Mřížka [Kategorie v paletě]
Kategorie | Identifikace kategorie události správy artiklu
Název kategorie | Název kategorie události správy artiklu
Priorita | Priorita barvy
B.písma | Identifikace barvy RGB
B.pozadí | Identifikace barvy RGB

    Mřížka [Palety barev kategorií] činnosti - Kategorie událostí správy artiklu

    Mřížka [Palety barev kategorií] činnosti - Kategorie událostí správy artiklu
Paleta | Identifikace palety barev
Název palety | Název palety barev

    Mřížka [Kategorie v paletě] činnosti - Kategorie událostí správy artiklu

    Mřížka [Kategorie v paletě] činnosti - Kategorie událostí správy artiklu
Priorita | Priorita barvy
Název kategorie | Název kategorie události správy artiklu

    Vyvolávané činnosti

    K. | Činnost | Popis
- | Kategorie událostí správy artiklu | Přehled kategorií událostí správy artiklu
F2 | Barvy RGB |
F2 | Kategorie událostí správy artiklu | Přehled kategorií událostí správy artiklu
F2 | Skupiny uživatelů | Definování skupin uživatelů

    Atributy tisku

    Základní údaje
Paleta | Identifikace palety barev | SAPALETA_sa08id | C(6)
Název palety | Název palety barev | SAPALETA_sa08nazpal | C(40)
Skupina | Identifikace skupiny uživatelů | SAPALETA_bw05ident | C(6)
Název skupiny uživatelů | Název skupiny uživatelů | BWODBOR_bw05popis | C(30)
Poznámka | Poznámka | SAPALETA_sa08koment | M
Název kategorie | Název kategorie události správy artiklu | SAKATEG_sa05nazkat | C(40)
Popis | Popis barvy RGB | BWRGBCOL_bw95popbar | C(40)
Popis | Popis barvy RGB | BWRGBCOL2_bw95popbar | C(40)

    Při pohybu v Palety barev
Kategorie | Identifikace kategorie události správy artiklu | SAPALKAT_sa05id | C(6)
Priorita | Priorita barvy | SAPALKAT_sa06prior | N(3)
Barva | Identifikace barvy RGB | SAPALKAT_bw95id | C(6)
Barva | Identifikace barvy RGB | SAPALKAT_bw95id2 | C(6)

    Viz.také

    Barvy RGB | Kategorie událostí správy artiklu | Skupiny uživatelů | Legenda palety barev


Legenda palety barev

Popis

Tato činnost poskytuje uživateli pouze informativní přehled o tom, jaká priorita a kategorie byla u dané palety barev použita (tzn. která kategorie danou paletu barev využívala). Palety barev jsou dostupné v překryvném seznamu.

Vyvolávané činnosti

K. | Činnost | Popis
- | Palety barev kategorií | Palety barev kategorií
- | Kategorie událostí správy artiklu | Přehled kategorií událostí správy artiklu

Formulář

Formulář činnosti - Kategorie událostí správy artiklu
Paleta Identifikace palety barev
Mřížka [Kategorie v paletě]

Mřížka [Kategorie v paletě] činnosti - Kategorie událostí správy artiklu

Mřížka [Kategorie v paletě] činnosti - Kategorie událostí správy artiklu
Priorita | Priorita barvy
Název kategorie | Název kategorie události správy artiklu

Viz.také

Palety barev kategorií | Kategorie událostí správy artiklu


Algoritmy předplnění a validace artiklu

Popis

Algoritmy se definují činností nazvanou "Algoritmy předplnění a validace artiklu", která se nachází v menu Informační centrum – Správa artiklu. V jejím formuláři se uvádí:

¨ název algoritmu

¨ kód předplnění - text - skript v jazyce Foxpro, který se uplatní při zakládání nového artiklu daného druhu pro předplnění jeho identifikace

¨ kód validace - text - skript v jazyce Foxpro, který se uplatní při zakládání nového artiklu daného druhu pro validaci jeho identifikace

¨ poznámka - libovolný text

V kódu předplnění jsou k dispozici proměnné:

_ALIAS - text - alias kurzoru formuláře, ve kterém je artikl vstupován

_SP61ID - text - druh artiklu, který je vstupován

Kód musí vracet hodnotu typu text, kterou bude předplněna identifikace artiklu

V kódu validace jsou k dispozici proměnné:

_ALIAS - text - alias kurzoru formuláře, ve kterém je artikl vstupován

_SP61ID - text - druh artiklu, který je vstupován

_SP60ID - text - identifikace artiklu, který je vstupován

Kód musí vracet logickou hodnotu .T. (TRUE) nebo .F. (FALSE)

V souvislosti s touto novou funkčností je k dispozici knihovna vkládaného kódu SYSAR1, která obsahuje mj. uživatelské funkce:

1. ID_ARTIKLU

Tato funkce vrací identifikaci nového artiklu podle užitých parametrů:

_ALIAS - text - alias kurzoru formuláře, ve kterém je artikl vstupován (užije se proměnná _ALIAS)

_PREFIX - text - proměnný text užitý na začátku identifikace artiklu (např. rok)

_CIFER - číslo - počet cifer pořadového čísla artiklu stejného druhu se stejným prefixem a postfixem - počet cifer+délka prefixu+délka postfixu nesmí být větší než 13

_POSTFIX - text - proměnný text užitý na konci identifikace artiklu - tento parametr není povinný

2. VALID_ARTIKLU

Tato funkce vrací identifikaci nového artiklu podle užitých parametrů:

_ALIAS - text - alias kurzoru formuláře, ve kterém je artikl vstupován (užije se proměnná _ALIAS)

_PREFIX - text - proměnný text musí být užitý na začátku identifikace artiklu (např. rok)

_CIFER - číslo - počet cifer pořadového čísla artiklu stejného druhu se stejným prefixem a postfixem - počet cifer+délka prefixu+délka postfixu nesmí být větší než 13

_POSTFIX - text - proměnný text musí být užitý na konci identifikace artiklu - tento parametr není povinný

Omezení:

Vzhledem k programovému řešení nemusí obě popsané funkce správně fungovat, pokud se budou v hodnotě prefixu, resp. postfixu vyskytovat náhražkové znaky (wildcards) používané podmínkou LIKE v SQL dotazech Sybase SQL Anywhere (_, %, [, ]) a ve funkci LIKE() Visual Foxpro ( * , ? ).

Příklady použití knihovny SYSAR1 jsou podrobněji popsány ve slovníku pojmů.

Datový model

  • SPARTALG Algoritmus předplnění a validace artiklu

    • Formulář

    Formulář činnosti - Editovat kód vlastnosti
Mřížka [Algoritmus předplnění identifikace nového artiklu]
Algoritmus | Název algoritmu
Předplnění | Kód algoritmu předplnění v jazyce Foxpro
Validace | Kód algoritmu validace v jazyce Foxpro
Poznámka | Poznámka

    Mřížka [Algoritmus předplnění identifikace nového artiklu] činnosti - Editovat kód vlastnosti

    Mřížka [Algoritmus předplnění identifikace nového artiklu] činnosti - Editovat kód vlastnosti
    Algoritmus Název algoritmu

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Editovat kód vlastnosti | Editovat kód vlastnosti
F6 | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností
- | Kontrolní kompilace | Kontrolní kompilace

    Atributy tisku

    Základní údaje
Algoritmus | Název algoritmu | SPARTALG_spe3nazalg | C(40)
Předplnění | Kód algoritmu předplnění v jazyce Foxpro | SPARTALG_spe3kod | M
Validace | Kód algoritmu validace v jazyce Foxpro | SPARTALG_spe3kodval | M
Poznámka | Poznámka | SPARTALG_spe3koment | M

    Viz.také

    Editovat kód vlastnosti | Knihovny vkládaného kódu | Kontrolní kompilace


SELEKTORY A ČÍSELNÍKY

Popis

Tato činnost v sobě sdružuje číselníky (tj. přehledy, seznamy), které uživatel využívá při práci se systémem. Má možnost je zadávat, aktualizovat a rušit. Každá z těchto činností je dále vysvětlena v samostatném helpu.

Viz.také

Měrné jednotky | Obchodní selektor | Organizační selektor | Technicko-věcný selektor | Třídy SKP | Jazyky systému


Měrné jednotky

Popis

Uživatel má k dispozici číselník měrných jednotek. Obsahuje informace o měrné jednotce, resp. její identifikaci a vlastním názvu měrné jednotky.

Pokud uživatel bude u artiklu využívat evidenci ve více měrných jednotkách, má po stisku záložky "vztah měrných jednotek" možnost nadefinovat vazby mezi nimi, tzn., že může nadefinovat např. vztah, že 1 balení = 20 kusů.

V případě, že uživatel bude v informačním systému BM využívat možnost cizojazyčnosti, může si po stisku záložky "měrná jednotka v jazycích" nadefinovat vlastní názvy měrných jednotek v jednotlivých vybraných jazycích.

Datový model

  • SPMJ Měrná jednotka
    • SPMJN Měrná jednotka v jazyce

    • Formulář

    Formulář činnosti - Editovat kód vlastnosti
Mřížka [Měrné jednotky]
Měrná jednotka | Identifikátor měrné jednotky
 | Název měrné jednotky
Listovací rámeček
Stránka #1 Měrné jednotky
Rozšířená identifikace | Rozšířená identifikace měrné jednotky
Poznámka | Poznámka
Stránka #2 Vztah měrných jednotek
Mřížka [Vztah měrných jednotek]
:= | Vztah měrných jednotek
 | Identifikátor měrné jednotky
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
 | Název měrné jednotky
Stránka #3 Měrná jednotka v jazycích
Mřížka [Měrná jednotka v jazycích]
 | Identifikace jazyka
Název měrné jednotky | Název měrné jednotky
Rozšířená identifikace | Rozšířená identifikace měrné jednotky

    Mřížka [Měrné jednotky] činnosti - Editovat kód vlastnosti

    Mřížka [Měrné jednotky] činnosti - Editovat kód vlastnosti
MJ | Identifikátor měrné jednotky
Název měrné jednotky | Název měrné jednotky

    Mřížka [Vztah měrných jednotek] činnosti - Editovat kód vlastnosti

    Mřížka [Vztah měrných jednotek] činnosti - Editovat kód vlastnosti
MJ | Identifikátor měrné jednotky
:= | Vztah měrných jednotek
MJ | Identifikátor měrné jednotky
Název měrné jednotky | Název měrné jednotky
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu

    Mřížka [Měrná jednotka v jazycích] činnosti - Editovat kód vlastnosti

    Mřížka [Měrná jednotka v jazycích] činnosti - Editovat kód vlastnosti
Jazyk | Identifikace jazyka
Název měrné jednotky | Název měrné jednotky

    Atributy tisku

    Základní údaje
MJ | Identifikátor měrné jednotky | SPMJ_sp24idmj | C(3)
Poznámka | Poznámka | SPMJ_sp24koment | M
Název měrné jednotky | Název měrné jednotky | SPMJN_sp58mjnaz | C(40)
Rozšířená identifikace | Rozšířená identifikace měrné jednotky | SPMJN_sp58idmj | C(20)

    Při pohybu v Měrné jednotky v jazycích
Jazyk | Identifikace jazyka | SPMJN2_sp38id | C(3)
Název měrné jednotky | Název měrné jednotky | SPMJN2_sp58mjnaz | C(40)
Rozšířená identifikace | Rozšířená identifikace měrné jednotky | SPMJN2_sp58idmj | C(20)


Obchodní selektor

Popis

Se selektory uživatel pracuje tehdy, potřebuje-li členit informace z několika pohledů. Všechny selektory se vzájemně prolínají celým systémem, umožňují tedy uživateli tzv. "trojí pohled na reálný svět".

Obchodní selektor umožňuje uživateli sledovat obchodní hledisko (např. sledování % slevy u určitých skupin výrobků atd.). Uživatel si pak na základě těchto informací může vytvořit pohled, jak by měl dále obchodovat. Jako první se uživateli při aktivaci této činnosti zobrazí záložka „výběr“. Zde má uživatel možnost pomocí vybraných atributů ovlivnit rozsah zobrazovaných dat. Pokud uživatel chce, aby tato činnost fungovala tak, že se při její aktivaci nebude zobrazovat výběrová záložka, ale rovnou se načtou všechny selektory, provede se toto nastavením Selektory – OBC_vyber na hodnotu 0 (menu Systém – Nastavení programu BM).

V této činnosti má uživatel možnost prohlížet si již definované selektory a zároveň zařazovat nové. V tomto případě pak zadává následující:

¨ identifikátor - identifikátor obchodního selektoru (identifikátor obchodního selektoru musí být uveden)

¨ název - název obchodního selektoru (název obchodního selektoru musí být uveden)

¨ platnost od - do

¨ analytika - číslo analytického účtu. Není to povinný údaj, zadává se pouze v případě, že uživatel chce, aby existovala určitá vazba - daný selektor a účetnictví.

¨ poznámka - libovolná poznámka k obchodnímu selektoru

Při zadávání událostí komponent pak není povolen vstup události se selektorem, jehož platnost neodpovídá datu uvedenému na události. Na výběrové záložce selektorů je pak na základě platnosti upraven i výběr. Je možno vybrat selektory: platné i neplatné, platné dnes, neplatné dnes, platné k datu, neplatné k datu. U každého selektoru může uživatel definovat i selektory podřízené. Můžeme si uvést i teoretický příklad, že uživatel bude mít např. obchodní selektor "OBCHOD". Podřízenými selektory potom mohou být např. "obchod s knihami", "obchod s kosmetikou" a "obchod s počítači".

Datový model

  • SPSEOB Obchodní selektor

    • Formulář

    Formulář činnosti - Editovat kód vlastnosti
Mřížka [Obchodní selektor]
Selektor | Identifikátor obchodního selektoru
Název | Název obchodního selektoru
Listovací rámeček
Stránka #1 Obchodní selektor
Platnost od | Datum platnosti selektoru od
Platnost do | Datum platnosti selektoru do
Analytika | Analytika obchodního selektoru
Poznámka | Poznámka k obchodnímu selektoru
Stránka #2 Výběr
Obch. sel. | Identifikátor obchodního selektoru
Název | Název obchodního selektoru
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 | Platnost nebo neplatnost k datu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Obchodní selektor] činnosti - Editovat kód vlastnosti

    Mřížka [Obchodní selektor] činnosti - Editovat kód vlastnosti
Selektor | Identifikátor obchodního selektoru
Název obchodního selektoru | Název obchodního selektoru
Platnost od | Datum platnosti selektoru od
Platnost do | Datum platnosti selektoru do
Analytika obchodního selektoru | Analytika obchodního selektoru

    Atributy tisku

    Základní údaje
Selektor | Identifikátor obchodního selektoru | SPSEOB_sp10idzak | C(9)
Název obchodního selektoru | Název obchodního selektoru | SPSEOB_sp10text | C(60)
Platnost od | Datum platnosti selektoru od | SPSEOB_sp10datum | D
Platnost do | Datum platnosti selektoru do | SPSEOB_sp10datumd | D
Analytika obchodního selektoru | Analytika obchodního selektoru | SPSEOB_sp10analyt | C(9)
Poznámka | Poznámka k obchodnímu selektoru | SPSEOB_sp10koment | M


Organizační selektor

Popis

Se selektory uživatel pracuje tehdy, potřebuje-li členit informace z několika různých pohledů. Všechny selektory se vzájemně prolínají celým systémem, umožňují tedy uživateli tzv. "trojí pohled na reálný svět".

Organizační selektor umožňuje sledovat členění v závislosti na nadefinované příslušnosti a odpovědnosti (např. v investičním majetku se to může týkat budov a staveb nebo strojů a zařízení). Jako první se uživateli při aktivaci této činnosti zobrazí záložka „výběr“. Zde má uživatel možnost pomocí vybraných atributů ovlivnit rozsah zobrazovaných dat. Pokud uživatel chce, aby tato činnost fungovala tak, že se při její aktivaci nebude zobrazovat výběrová záložka, ale rovnou se načtou všechny selektory, provede se toto nastavením Selektory – ORG_vyber na hodnotu 0 (menu Systém – Nastavení programu BM).

V této činnosti má uživatel možnost prohlížet si již definované selektory a zároveň zařazovat nové. V tomto případě pak zadává následující:

¨ identifikátor - identifikátor organizačního selektoru (identifikátor selektoru musí být uveden)

¨ název - název organizačního selektoru (název selektoru musí být uveden)

¨ umístění – identifikace umístění selektoru. K umístění lze definovat přístupová práva. Přístupová práva nadefinovaná u org. selektoru se následně uplatňují v činnosti účetní deník (uživatel nevidí události účetnictví se selektorem, ke kterému nemá alespoň právo čtení), obratová tabulka se selektory a konta se selektory (nutno mít k zadanému selektoru alespoň právo čtení, jinak záznamy daného účtu s tímto selektorem nejsou pro uživatele dostupné). Umístění u organizačního selektoru v podstatě mírně supluje to, že komponenta účetnictví nemá vlastní umístění jako např. obchod nebo sklady.

¨ platnost od - do

¨ analytika - číslo analytického účtu. Není to povinný údaj, zadává se pouze v případě, že uživatel chce, aby existovala určitá vazba - daný selektor a účetnictví.

¨ poznámka - libovolná poznámka k organizačnímu selektoru

Při zadávání událostí komponent pak není povolen vstup události se selektorem, jehož platnost neodpovídá datu uvedenému na události. Na výběrové záložce selektorů je pak na základě platnosti upraven i výběr. Je možno vybrat selektory: platné i neplatné, platné dnes, neplatné dnes, platné k datu, neplatné k datu.

U každého selektoru může uživatel definovat i selektory podřízené.

Datový model

  • SPSEOR Organizační selektor
    • SPSEUMIS Umístění selektoru

    • Formulář

    Formulář činnosti - Umístění selektorů
Mřížka [Organizační selektor]
Selektor | Identifikátor organizačního selektoru.
Název | Název organizačního selektoru
Listovací rámeček
Stránka #1 Organizační selektor
Umístění | Identifikace umístění selektoru
Název umístění | Název umístění selektoru
Platnost od | Datum platnosti selektoru od
Platnost do | Datum platnosti selektoru do
Analytika | Analytika organizačního selektoru
Poznámka | Poznámka k organizačnímu selektoru
Stránka #2 Výběr
Org. sel. | Identifikátor organizačního selektoru.
Název | Název organizačního selektoru
Umístění | Identifikace umístění selektoru
Název umístění | Název umístění selektoru
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 | Platnost nebo neplatnost k datu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Organizační selektor] činnosti - Umístění selektorů

    Mřížka [Organizační selektor] činnosti - Umístění selektorů
Selektor | Identifikátor organizačního selektoru.
Název organizačního selektoru | Název organizačního selektoru
Platnost od | Datum platnosti selektoru od
Platnost do | Datum platnosti selektoru do
Analytika organizačního selektoru | Analytika organizačního selektoru
Umístění | Identifikace umístění selektoru
Název umístění | Název umístění selektoru

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Umístění selektorů | Umístění selektorů

    Atributy tisku

    Základní údaje
Selektor | Identifikátor organizačního selektoru. | SPSEOR_sp11idzak | C(9)
Název organizačního selektoru | Název organizačního selektoru | SPSEOR_sp11text | C(60)
Umístění | Identifikace umístění selektoru | SPSEOR_spf3id | C(6)
Název umístění | Název umístění selektoru | SPSEUMIS_spf3nazumi | C(40)
Platnost od | Datum platnosti selektoru od | SPSEOR_sp11datum | D
Platnost do | Datum platnosti selektoru do | SPSEOR_sp11datumd | D
Analytika organizačního selektoru | Analytika organizačního selektoru | SPSEOR_sp11analyt | C(9)
Poznámka k organizačnímu selektoru | Poznámka k organizačnímu selektoru | SPSEOR_sp11koment | M

    Viz.také

    Umístění selektorů


Technicko-věcný selektor

Popis

Se selektory uživatel pracuje tehdy, potřebuje-li členit informace z několika pohledů. Všechny selektory se vzájemně prolínají celým systémem, umožňují tedy uživateli tzv. "trojí pohled na reálný svět".

Technicko věcný selektor slouží pro vytvoření určitých hledisek možného členění, umožňuje např. členit skladové zásoby nebo investiční majetek do skupin. Jako první se uživateli při aktivaci této činnosti zobrazí záložka „výběr“. Zde má uživatel možnost pomocí vybraných atributů ovlivnit rozsah zobrazovaných dat. Pokud uživatel chce, aby tato činnost fungovala tak, že se při její aktivaci nebude zobrazovat výběrová záložka, ale rovnou se načtou všechny selektory, provede se toto nastavením Selektory – TVS_vyber na hodnotu 0 (menu Systém – Nastavení programu BM).

V této činnosti má uživatel možnost prohlížet si již definované selektory a zároveň zařazovat nové. V tomto případě pak zadává následující:

¨ identifikátor - identifikátor tech.-věcného selektoru (identifikátor selektoru musí být uveden)

¨ název - název tech.-věcného selektoru (název selektoru musí být uveden)

¨ platnost od - do

¨ analytika - číslo analytického účtu. Není to povinný údaj, zadává se pouze v případě, že uživatel chce, aby existovala určitá vazba - daný selektor a účetnictví.

¨ poznámka - libovolná poznámka k tech.-věcného selektoru

Při zadávání událostí komponent pak není povolen vstup události se selektorem, jehož platnost neodpovídá datu uvedenému na události. Na výběrové záložce selektorů je pak na základě platnosti upraven i výběr. Je možno vybrat selektory: platné i neplatné, platné dnes, neplatné dnes, platné k datu, neplatné k datu.

U každého selektoru může uživatel definovat i selektory podřízené.

Datový model

  • SPSETV Technicko-věcný selektor

    • Formulář

    Formulář činnosti - Umístění selektorů
Mřížka [Technicko-věcný selektor]
Selektor | Identifikátor technicko-věcného selektoru.
Název | Název technicko-věcného selektoru.
Listovací rámeček
Stránka #1 Technicko-věcný selektor
Platnost od | Datum platnosti selektoru od
Platnost do | Datum platnosti selektoru do
Analytika | Analytika technicko-věcného selektoru
Poznámka | Poznámka k technicko-věcnému selektoru
Stránka #2 Výběr
Tech. sel. | Identifikátor technicko-věcného selektoru.
Název | Název technicko-věcného selektoru.
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 | Platnost nebo neplatnost k datu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Technicko-věcný selektor] činnosti - Umístění selektorů

    Mřížka [Technicko-věcný selektor] činnosti - Umístění selektorů
Selektor | Identifikátor technicko-věcného selektoru.
Název technicko-věcného selektoru | Název technicko-věcného selektoru.
Platnost od | Datum platnosti selektoru od
Platnost do | Datum platnosti selektoru do
Analytika technicko-věcného selektoru | Analytika technicko-věcného selektoru

    Atributy tisku

    Základní údaje
Selektor | Identifikátor technicko-věcného selektoru. | SPSETV_sp20idzak | C(9)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(60)
Platnost od | Datum platnosti selektoru od | SPSETV_sp20datum | D
Platnost do | Datum platnosti selektoru do | SPSETV_sp20datumd | D
Analytika technicko-věcného selektoru | Analytika technicko-věcného selektoru | SPSETV_sp20analyt | C(9)
Poznámka k technicko-věcnému selektoru | Poznámka k technicko-věcnému selektoru | SPSETV_sp20koment | M


Třídy SKP

Popis

Uživatel má možnost zadat identifikaci kódu klasifikace CZ-CPA (dřívější třídy SKP), popis klasifikace a odpisovou skupinu. Definování kódů standardní klasifikace produkce se odvozuje od zákona a uživatel by při jejich zadávání měl k tomuto zákonu přihlížet.

Datový model

  • SPSKP SKP

    • Formulář

    Formulář činnosti - Umístění selektorů
Mřížka [Třídy Standardní klasifikace produkce]
Třída SKP | Identifikace třídy Standardní klasifikace produkce.
 | Název kategorie Standardní klasifikace produkce.
Poznámka | Poznámka ke kategorii Standardní klasifikaci produkce.

    Mřížka [Třídy Standardní klasifikace produkce] činnosti - Umístění selektorů

    Mřížka [Třídy Standardní klasifikace produkce] činnosti - Umístění selektorů
Třída SKP | Identifikace třídy Standardní klasifikace produkce.
Název třídy Standardní klasifikace produkce | Název kategorie Standardní klasifikace produkce.
Poznámka | Poznámka ke kategorii Standardní klasifikaci produkce.

    Atributy tisku

    Základní údaje
Třída SKP | Identifikace třídy Standardní klasifikace produkce. | SPSKP_sp17idskp | C(8)
Název třídy Standardní klasifikace produkce | Název kategorie Standardní klasifikace produkce. | SPSKP_sp17text | C(70)
Poznámka | Poznámka ke kategorii Standardní klasifikaci produkce. | SPSKP_sp17pozn | C(40)


Jazyky systému

Popis

Tato činnost umožňuje uživateli evidovat jazyky, které chce používat v systému. Pokud tedy bude uživatel v systému potřebovat používat i jiný jazyk, tak po spuštění hlavního menu uživatel tento cizí jazyk zatrhne pod položkou menu "jazyky". Standardně je zatržena možnost neurčeno, pokud si uživatel bude chtít vytvářet vlastní menu, tzn., že si některé činnosti bude chtít přejmenovat (jinak česky) zatrhne češtinu, pokud bude chtít používat cizojazyčné názvy činností, zatrhne příslušný cizí jazyk. Po vybrání příslušného jazyka potom u každé činnosti v hlavním menu po stisku pravého tlačítka myši funguje volba vlastnosti, kde si pod záložkou překlad uživatel uvede cizojazyčný název. Tímto způsobem si uživatel upraví názvy činností, které se zobrazují v hlavním menu.

Uživatel však má možnost si takto upravit i jednotlivé obrazovky, resp. jednotlivé názvy atributů. U každé spuštěné činnosti má vedle menu volby k dispozici menu jazyk. Pokud má v hlavním menu uživatel zatržen nějaký vybraný cizí jazyk, zatrhne v této činnosti možnost "režim oprav" a potom má po stisku pravého tlačítka myši na kterémkoliv názvu položky na obrazovce možnost si tento název přeložit do vybrané cizí řeči. U některých číselníků (např. obchodovatelný artikl) je k dispozici i vlastní záložka pro cizojazyčný překlad.

Datový model

  • SPJAZYK Jazyk

    • Formulář

    Formulář činnosti - Umístění selektorů
Mřížka [Jazyky]
Jazyk | Identifikace jazyka
Název jazyka | Název jazyka

    Mřížka [Jazyky] činnosti - Umístění selektorů

    Mřížka [Jazyky] činnosti - Umístění selektorů
Jazyk | Identifikace jazyka
Název jazyka | Název jazyka

    Atributy tisku

    Základní údaje
Jazyk | Identifikace jazyka | SPJAZYK_sp38id | C(3)
Název jazyka | Název jazyka | SPJAZYK_sp38jazyk | C(40)


IMPORT / EXPORT

Popis

Importem se rozumí schopnost informačního systému převzít data z jiného informačního systému nebo programu (např. Excel), čímž vlastně IS BM podporuje komunikaci s jinými IS. Pro každou činnost typu prohlížení seznamu záznamů lze vytvořit definici jaká data a jak mají být importována, tj. definici zdroje dat (např. souborů - ODBC, DBF, TXT, XML, SOAP …) a definici pravidel transformace zdrojových dat na cílová. Přístup k těmto definicím lze chránit přístupovými právy dle druhu importu.

Importy definované nad událostmi lze užít v definici procesního importu. Importy se aktivují z menu Obecné pomocí činnosti „Import/Export dat“ výběrem ze seznamu definic, případně šablonou, v jejíž definici je import užit.

Jako zajímavý se jeví import z vlastních dat (tj. z vlastního IS), čímž lze realizovat určitá dávková zpracování dat.

Uživatel při zakládání importu definuje dvě záložky - vlastní definici importu-exportu a proměnné importu-exportu. Po jejich definici aktivuje činnost konverze atributů a následně si nadefinuje design vstupního formuláře, čili jak se okno importu bude po spuštění jevit uživateli. Jako kontrolu správně nadefinovaného importu může uživatel využít činnosti pod menu Volby (nebo klávesa F7) „prohlížení importovaných dat“.

IS BM dovoluje definovat importy dat, které zpracovávají informace získané prostřednictvím webových služeb. Přitom používá protokol MS SOAP, který musí být na počítači instalován.

V kódu pro import spojení typu XBASE se spojení provádí pomocí COM objektu "MSSOAP.SoapClient" např.:

* deklarace proměnné pro objekt klienta

LOCAL _xsoap

* vytvoření objektu klienta

_xsoap = CREATEOBJECT("MSSOAP.SoapClient")

* inicializace klienta pro použití webové služby

_xsoap.MSSoapInit('http://isbm.bmservis.cz./Webpub/bmwssrv.WSDL', "bmwssrv", "bmwssrvSoapPort")

* deklarace proměnné pro uložení získané informace

LOCAL _buffer

* volání metody služby s parametry

_buffer=_xsoap.getdata('VY0001','UZIVATEL','HESLO',date(),date(),'','',.F.,.F.,.F.,.F.,.F.,.F.,.F.,.F.)

* převod dat předaných ve formátu XML do kurzoru s aliasem DATA

=XMLTOCURSOR(_buffer,'data',0)

Exportem se rozumí schopnost informačního systému poskytnout data jinému IS nebo programu (např. Excel). Exporty se aktivují v každé činnosti typu seznam z menu Obecné pomocí činnosti „Import/Export dat“ volbou ze seznamu definic. V činnostech typu prohlížení seznamu záznamů (v událostech ne) je možno vytvořit definici jaká data a jak mají být exportována a definici pravidel transformace. Při definování jednotlivých definic exportů se předpokládá určitá znalost datového modelu. Přístup k jednotlivým definicím exportu lze chránit přístupovými právy podle druhu exportu.

Definice jednotlivých záložek činnosti export je shodná s činností import, kde je uveden jejich podrobný popis. Odlišností je, že pro charakter definice typu Export je dostupná z menu Volby funkce "SELECT pro export". Po jejím vyvolání se zobrazí okno pro vstup dotazu SQL, který bude použit pro získání exportovaných dat (není-li dosud definován, předplní se dotaz odpovídající dotazu formuláře, ze kterého byla definice Importu/exportu vyvolána). V definice konverze bude výstup tohoto dotazu vystupovat jako tabulka s aliasem _EXP_.

Exporty dat vytvořené u jednotlivých činností (tj. nad formuláři událostí jednotlivých komponent) je možné vyvolat i automaticky při běhu procesu:

¨ uvedením exportu v seznamu exportů na záložce "exporty" u popisu druhu operace. Export se spustí po ukončení dané operace.

Viz.také

REPLIKACE | IMPORT | KONFIGURACE WEBOVÝCH SLUŽEB


REPLIKACE

Popis

Replikace dat je sdílení dat mezi vzdálenými databázemi. Replikace provádí srovnávání dat mezi jednotlivými datovými úložišti, na základě definice replikace. Replikace přímo podporuje nástroj Sybase SQL Anywhere, v IS Bílý Motýl je pak pouze nabídnuta podpora pro snadnou definici replikace. Replikace jsou možné pouze mezi jednotlivými databázemi SQL Anywhere, navíc všechny databáze účastnící se replikací musí mít použit transakční log (Transaction log). Bez aktivního transakčního logu bude fungovat replikace pouze jednosměrně, v případě spojení dvou databází bez transakčního logu vůbec.

IS Bílý Motýl podporuje pouze hierarchické propojení datových úložišť, kdy na vrcholu stromu stojí konsolidovaná databáze (Consolidated database), která vždy obsahuje všechny tabulky, které v IS vzniknou. Dalšími prvky stromu jsou pak jedna nebo více vzdálených databází (Remote database), které mohou obsahovat volitelné tabulky. Vztahy mezi jednotlivými místy popisují publikace (Publications), které jsou částí definice replikace. Databáze spolu komunikují prostřednictvím speciálních uživatelů, publikátora (Publisher) a vzdáleného uživatele (Remote user). Publikátor, spojený (Subscription) s určitou publikací připraví data pro replikaci a odešle je zvoleným způsobem. Druhá databáze je pak prostřednictvím vzdáleného uživatele přijme a zpracuje.

SQL Anywhere nabízí několik způsobů komunikace mezi jednotlivými databázemi:

1. FILE systém - Komunikace prostřednictvím sdílených souborů.

2. MAPI systém - Používá The Message Application Programming Interface (MAPI) užívaný řadou e-mail systémů, příkladem může být Microsoft Mail.

3. VIM systém - Používá The Vendor Independent Messaging systém (VIM), který je používán systémy Lotus cc:Mail a Lotus Notes.

4. SMTP systém - The Simple Mail Transfer Protocol (SMTP) je používám nástroji pro e-mail komunikaci prostřednictvím Internetu.

IS Bílý Motýl nabízí nástroj pro definici jednotlivých datových úložišť, jejich vlastností, hierarchické struktury a vztahů mezi jednotlivými úložišti. V IS je každé datové úložiště definováno jednoznačným číslem, od 00 do 99. Toto číslo je definováno číslem licence, a je určeno při prvním spuštění systému. Později není možné tuto definici měnit!

Viz.také

Datová uložiště | Export DU do balíčku | Konfigurace SMTP | Seznam replikovaných procesů | Publikace | Replikace aktuálních hodnot


Datová uložiště

Popis

Pro správnou funkci replikace je nutné, pomocí Sybase Central, definovat v jednotlivých databázích následující údaje:

1. Založení uživatele publikátora, který musí mít následující jméno: "user_XX", kde "XX" je identifikace datového úložiště. Pokud konsolidovaná databáze bude mít identifikaci "00", pak musí existovat uživatel "user_00", typu publikátor.

2. Založení vzdáleného uživatele, který musí mít následující jméno: "user_YY", kde "YY" je identifikace datového úložiště, se kterým chceme komunikovat, nebo-li to druhé se kterým bude probíhat replikace. Pokud tedy bude mít vzdálená databáze číslo "10", pak musí pro správnou funkci replikace existovat uživatel "user_10", typu vzdálený uživatel. U těchto uživatelů je nutné nastavit způsob komunikace.

Vytvořená datová úložiště pak uživatel navěsí do struktury databáze, přičemž jedno z nich je nadřízené a jedno podřízené. U podřízených si uživatel spustí činnost vlastnosti vazby (pravá myš) a vybere si příslušné tabulky, které se mají replikovat.

Pokud máme uvedené údaje nastaveny, můžeme prostřednictvím IS vygenerovat publikaci. Podle jednotlivých identifikací datových úložišť mají tyto publikace názvy "pub_YY", kde "YY" je identifikace datového úložiště se kterým budeme provádět synchronizaci. Tyto publikace musíme vygenerovat na jednotlivých datových úložištích, neboť se generují přímo do dané databáze, která s datovým úložištěm úzce souvisí.

Samotná replikace se může spouštět několika způsoby:

1. Manuálně – spouštění podle potřeby, je vhodné například pro synchronizaci dat mezi některou "pevnou" databází a přenosným počítačem.

2. Automaticky v zadaném intervalu.

3. Automaticky ve vybraném pevném čase.

Formulář

Formulář činnosti - Generování publikace
Strom

Viz.také

Generování publikace


Export DU do balíčku

Popis

Uživatel má k dispozici možnost nadefinovat si identifikaci a název exportu datového úložiště do balíčku.

Datový model

  • IEUZEL Datové úložiště

    • Formulář

    Formulář činnosti - Generování publikace
Mřížka [Export DU do balíčku]
Identifikace | Identifikace datového úložiště
Název | Název datového úložiště
Komentář | Popis pracovního místa

    Mřížka [Export DU do balíčku] činnosti - Generování publikace

    Mřížka [Export DU do balíčku] činnosti - Generování publikace
Identifikace | Identifikace datového úložiště
Název | Název datového úložiště


Konfigurace SMTP

Popis

Simple Mail Transfer Protocol zkráceně SMTP je internetový protokol určený pro přenos zpráv elektronické pošty (e-mailů) mezi stanicemi. Protokol zajišťuje doručení pošty pomocí přímého spojení mezi odesílatelem a adresátem; zpráva je doručena do tzv. poštovní schránky adresáta, ke které potom může uživatel kdykoli (off-line) přistupovat (vybírat zprávy) pomocí protokolů POP3 nebo IMAP. Jedná se o jednu z nejstarších aplikací, původní norma RFC 821 byla vydána v roce 1982 (v roce 2001 ji nahradila novější RFC 2821). SMTP funguje nad protokolem TCP, používá port TCP/25.

Datový model

  • IESMTP Nastavení SMTP pro replikace

    • Formulář

    Formulář činnosti - Generování publikace
Adresa | E-mailová adresa
smtp_host | Identifikace počítače, na kterém běží SMTP server
pop3_host | Identifikace počítače, na kterém běží POP host obvykle = smtp_host
pop3_userid | Identifikace uživatele pro odesílání a příjem pošty
pop3_password | Heslo uživatele pro odesílání a příjem pošty


Seznam replikovaných procesů

Popis

Tato činnost poskytuje uživateli přehled o nadefinovaných procesech, které se budou při replikacích přenášet. U každého procesu se nastavuje:

¨ publikace – výběr z číselníku publikací

¨ druh procesu – identifikátor druhu procesu (výběr z číselníku)

¨ IDÚ procesu – replikovat pouze proces s tímto zadaným IDÚ (tj. identifikace datového úložiště)

¨ IDÚ nadř. procesu – replikovat pouze proces, kterému předchází proces s tímto zadaným IDÚ

¨ podmínka – doplňující podmínka pro proces

¨ libovolná poznámka

Na záložku „O událostech“ se nadefinováním replikovaného procesu automaticky přenesou operace a podprocesy daného procesu.

Datový model

  • IERPRC Replikovaný proces mezi DÚ
    • SPTYP Druh procesu/operace (alias SPTYP2)
    • IEPUB Publikace

    • Formulář

    Formulář činnosti - Publikace
Mřížka [Replikované procesy]
Publikace | Identifikace publikace
 | Platí výhradně pro DÚ
Název publikace | Název publikace
Druh procesu | Identifikátor druhu procesu
 | Název druhu procesu
Listovací rámeček
Stránka #1 Replikované procesy
IDÚ procesu | Replikovat pouze proces s IDÚ
IDÚ nadř.procesu | Replikovat pouze proces, kterému předchází proces s IDÚ
Podmínka | Doplňující podmínka pro proces
Poznámka | Poznámka
Stránka #2 O událostech
Mřížka [O událostech]
Komp. | Identifikace komponenty
Operace | Identifikátor druhu operace
 | Název druhu operace
Replikovat | Replikovat události operace Ano/Ne
Poznámka | Poznámka

    Mřížka [Replikované procesy] činnosti - Publikace

    Mřížka [Replikované procesy] činnosti - Publikace
Publikace | Identifikace publikace
DÚ | Platí výhradně pro DÚ
Druh procesu | Identifikátor druhu procesu
Název druhu procesu | Název druhu procesu
Název publikace | Název publikace

    Mřížka [O událostech] činnosti - Publikace

    Mřížka [O událostech] činnosti - Publikace
Komp. | Identifikace komponenty
Operace | Identifikátor druhu operace
Název druhu operace | Název druhu operace

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Doplnit nadřízené procesy | Doplnit nadřízené procesy - podle druhu operací
F6 | Doplnit nadřízené procesy 2 | Doplnit nadřízené procesy - podle fyzických operací
F7 | Diagram procesu | Zobrazení diagramu procesu
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Komponenty | Číselník komponent
F2 | Publikace | Seznam publikací

    Atributy tisku

    Základní údaje
Publikace | Identifikace publikace | IERPRC_ie16id | C(6)
DÚ | Platí výhradně pro DÚ | IERPRC_ie13idu2 | C(2)
Název publikace | Název publikace | IEPUB_ie16nazpub | C(40)
Druh procesu | Identifikátor druhu procesu | IERPRC_sp07idtypd | C(6)
Název druhu procesu | Název druhu procesu | SPTYP2_sp07text | C(30)
Poznámka | Poznámka | IERPRC_ie13koment | M
IDÚ procesu | Replikovat pouze proces s IDÚ | IERPRC_ie13ridu1 | C(30)
IDÚ nadř.procesu | Replikovat pouze proces, kterému předchází proces s IDÚ | IERPRC_ie13ridu2 | C(30)
Podmínka | Doplňující podmínka pro proces | IERPRC_ie13podmin | M
Název druhu operace | Název druhu operace | SPTYP_sp07text | C(30)

    Při pohybu v O událostech
Operace | Identifikátor druhu operace | IERUDA_sp07idtyp | C(6)
Komponenta | Identifikace komponenty | IERUDA_sp06idsubs | C(3)
Replikovat | Replikovat události operace Ano/Ne | Výpočet | C(3)
Poznámka | Poznámka | IERUDA_ie14koment | M

    Viz.také

    Doplnit nadřízené procesy | Doplnit nadřízené procesy 2 | Diagram procesu | Druhy operací | Druhy procesů | Komponenty | Publikace


Publikace

Popis

Publikace představují v IS BM v podstatě množinu dat (tabulek), která se bude replikacemi přenášet. U každé publikace se definuje:

¨ identifikace a název publikace

¨ nadřízené DÚ – doplňující podmínky pro nadřízené datové úložiště

¨ podle popisu procesů – replikace podle popisu procesů pro nadřízené datové úložiště (volba Ano/Ne)

¨ replikovat statistiky – replikovat tabulky statistik z nadřízeného datového úložiště (volba Ano/Ne). Při volbě Ano jsou replikovány záznamy v tabulkách aktuálních hodnot, účetní obratové tabulky a statistické hodnoty. Vhodné využití této možnosti je při plné replikaci na notebook – odstraňuje potřebu provádění přepočtu aktuálních hodnot, hodnot obratů a statistických hodnot po vyextrahování distribuované databáze. Pro řešení s částečnými replikacemi je vhodnější použít „replikace aktuálních hodnot“. Důvodem správného rozhodnutí, zda replikovat statistické hodnoty Ano/Ne, je způsob jejich přepočtu, při kterém jsou původní záznamy ve statistice vymazány a vznikají nové záznamy s přepočtenými hodnotami. Tím může vzniknout problém s velkým objemem dat, který je třeba replikovat, zejména při replikaci prováděné pomocí internetu. (Při zadání „replikovat statistiky – Ano“ na nadřízeném DÚ a „Ne“ na „podřízeném DÚ“ je nutno po vyextrahování databáze pro podřízené DÚ generovat publikaci Sybase.

¨ podřízené DÚ – doplňující podmínky pro podřízené datové úložiště

¨ podle popisu procesů - replikace podle popisu procesů pro podřízené datové úložiště (volba Ano/Ne)

¨ replikovat statistiky - replikovat tabulky statistik z podřízeného datového úložiště (volba Ano/Ne)

¨ všechny tabulky – volba Ano/Ne zda replikovat všechny tabulky

Na záložce „činnosti ve vztahu k replikaci“ se k dané publikaci nastaví činnosti (identifikace) a potvrdí se volba Ano/Ne zda replikovat.

Datový model

  • IEPUB Publikace

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Vlastnosti vazby | Vlastnosti vazby
F6 | Vlastnosti vazby - činnosti | Vlastnosti vazby - činnosti

    Formulář

    Formulář činnosti - Vlastnosti vazby - činnosti
Mřížka [Publikace]
Publikace | Identifikace publikace
Název publikace | Název publikace
Listovací rámeček
Stránka #1 Publikace
Nadřízené DÚ | Doplňující podmínky pro nadřízené DÚ
Podřízené DÚ | Doplňující podmínky pro podřízené DÚ
Podle popisu procesů | Replikace podle popisu procesů pro nadřízené DÚ
Podle popisu procesů | Replikace podle popisu procesů pro podřízené DÚ
Replikovat statistiky | Replikovat tabulky statistik z nadřízeného DÚ
Replikovat statistiky | Replikovat tabulky statistik z podřízeného DÚ
Všechny tabulky | Replikovat všechny tabulky
 | Poznámka
Stránka #2 Činnosti ve vztahu k replikaci
Mřížka [Č]
Činnost | Identifikace činnosti
 | Název činnosti
Replikovat | Replikovat činnost
Poznámka | Poznámka

    Mřížka [Publikace] činnosti - Vlastnosti vazby - činnosti

    Mřížka [Publikace] činnosti - Vlastnosti vazby - činnosti
Publikace | Identifikace publikace
Název publikace | Název publikace

    Mřížka [Č] činnosti - Vlastnosti vazby - činnosti

    Mřížka [Č] činnosti - Vlastnosti vazby - činnosti
Činnost | Identifikace činnosti
Činnost | Název činnosti
Replikovat | Replikovat činnost

    Viz.také

    Vlastnosti vazby | Vlastnosti vazby - činnosti


Replikace aktuálních hodnot

Popis

Pro řešení s částečnými replikacemi je vhodnější použít „replikace aktuálních hodnot“, kdy z názvu vyplývá, že se replikují pouze aktuální hodnoty (odpadá tím problém se statistickými a obratovými hodnotami).

V popisu publikace pro replikace je totiž možné nastavit pro nadřízené a podřízené DÚ vlastnosti „replikovat statistiky“ s hodnotami Ano/Ne. Při volbě Ano jsou replikovány záznamy v tabulkách aktuálních hodnot, účetní obratové tabulky a statistické hodnoty. Vhodné využití této možnosti je při plné replikaci na notebook – odstraňuje potřebu provádění přepočtu aktuálních hodnot, hodnot obratů a statistických hodnot po vyextrahování distribuované databáze. Důvodem správného rozhodnutí, zda replikovat statistické hodnoty Ano/Ne, je způsob jejich přepočtu, při kterém jsou původní záznamy ve statistice vymazány a vznikají nové záznamy s přepočtenými hodnotami. Tím může vzniknout problém s velkým objemem dat, který je třeba replikovat, zejména při replikaci prováděné pomocí internetu.

Datový model

  • IERAH Replikovat aktuální hodnoty komponenty
    • IEUZEL Datové úložiště

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Komponenty | Číselník komponent

    Formulář

    Formulář činnosti - Komponenty
Mřížka [Replikované AH pro komponenty]
 | Název datového úložiště
DÚ | Identifikace datového úložiště
Komponenta | Identifikace komponenty
Název komponenty | Název komponenty
Listovací rámeček
Stránka #1 Komponenty a DÚ
Poznámka | Poznámka
Stránka #2 Replikovaná úložiště
Mřížka [Replikovaná úložiště]
Umístění | Umístění
Replikovat | Replikovat AH umístění
Poznámka | Poznámka

    Mřížka [Replikované AH pro komponenty] činnosti - Komponenty

    Mřížka [Replikované AH pro komponenty] činnosti - Komponenty
DÚ | Identifikace datového úložiště
Název DÚ | Název datového úložiště
Komponenta | Identifikace komponenty
Název komponenty | Název komponenty

    Mřížka [Replikovaná úložiště] činnosti - Komponenty

    Mřížka [Replikovaná úložiště] činnosti - Komponenty
Umístění | Umístění
Replikovat | Replikovat AH umístění

    Viz.také

    Komponenty


IMPORT

Popis

Souhrn činností importu.

Viz.také

Převodní tabulka | Doplnění spojení k adresátům


Převodní tabulka

Popis

Umožňuje definovat převody hodnot pro importy. U každého převodu se zadává:

¨ entita - tabulka, které se převod týká

¨ původní - stará hodnota, která se má konvertovat

¨ nová - nová hodnota

¨ poznámka – libovolný komentář uživatele

Datový model

  • IEKONV Konverzní tabulka

    • Vyvolávané činnosti

    K. | Činnost | Popis
- | Export převodní tabulky |
- | Import převodní tabulky |

    Formulář

    Formulář činnosti - Import převodní tabulky
Mřížka [Konverze]
Entita | Název entity
Původní | Původní hodnota
Nová | Nová hodnota
Poznámka | Poznámka

    Mřížka [Konverze] činnosti - Import převodní tabulky

    Mřížka [Konverze] činnosti - Import převodní tabulky
Entita | Název entity
Původní | Původní hodnota
Nová | Nová hodnota
Poznámka | Poznámka

    Atributy tisku

    Základní údaje
Entita | Název entity | IEKONV_ie03ent | C(10)
Původní | Původní hodnota | IEKONV_ie05puv | C(15)
Nová | Nová hodnota | IEKONV_ie05nova | C(15)
Poznámka | Poznámka | IEKONV_ie05kom | C(40)

    Viz.také

    Export převodní tabulky | Import převodní tabulky


Doplnění spojení k adresátům

Popis

Po aktivaci této činnosti se systém dotazuje: “Opravdu chcete provést doplnění spojení k adresátům, kteří žádné nemají?“. Po potvrzení volby Ano systém provede doplnění implicitních spojení ke všem adresátům, kteří toto spojení dosud nemají.


KONFIGURACE WEBOVÝCH SLUŽEB

Popis

Webové služby jsou základním stavebním blokem pro implementaci distribuovaného zpracování na Internetu. Vytváří standard pro integraci aplikací prostřednictvím internetu. Předpokládá se, že budoucnost aplikací je v jejich komunikaci s různými zdroji informací internetu pomocí Webových služeb. Bílý Motýl ve verzi pro Runtime Foxpro 7.0 podporuje Webové služby.

IS BM dovoluje na internetu publikovat vlastní „webové služby“. Předpokladem je provozovat vlastní „web server“, kde musí být nainstalovány tyto aplikace:

  1. MS SOAP
  2. runtime Foxpro 7.0
  3. COM objekt BMWSSRV
  4. webová služba BMWSSRV.WSDL

Pro správné nastavení webových služeb je nutno správně nadefinovat uživatele webových služeb a vlastní definici webových služeb.

Viz.také

Webové služby | Uživatelé webových služeb


Webové služby

Popis

Webové služby jsou základním stavebním blokem pro implementaci distribuovaného zpracování na Internetu. Vytváří standard pro integraci aplikací prostřednictvím internetu. Předpokládá se, že budoucnost aplikací je v jejich komunikaci s různými zdroji informací internetu pomocí Webových služeb. Bílý Motýl ve verzi pro Runtime Foxpro 7.0 podporuje Webové služby.

IS BM dovoluje na internetu publikovat vlastní „webové služby“. Předpokladem je provozovat vlastní „web server“, kde musí být nainstalovány tyto aplikace:

  1. MS SOAP
  2. runtime Foxpro 7.0
  3. COM objekt BMWSSRV
  4. webová služba BMWSSRV.WSDL

COM objekt BMWSSRV je součástí IS BM. Svou metodou GETDATA odesílá klientovi informace získané z dat BM pomocí SQL dotazu. Jaký dotaz má být odeslán a komu je daná informace dostupná je dáno definicemi uloženými v BM. Právě k nastavení příslušných definic slouží v IS BM činnost „webové služby“ (v hlavním menu Informační centrum – Import/Export – Konfigurace webových služeb – Webové služby). U každé webové služby se definují tyto atributy:

¨ identifikace služby – jednoznačná identifikace služby, která je předávána COM objektu BMWSSRV v prvním parametru metody GETDATA

¨ název služby

¨ platnost – příznak platnosti služby – umožňuje pozastavit platnost služby (např. při údržbě)

¨ výraz – SQL výraz v syntaxi Foxpro, po jehož vyhodnocení vznikne tvar SQL dotazu, např. [select adadsat.ad01id,adadsat.ad01adsat,adadsat.ad01adsat2 from %%%.adadsat where adadsat.ad01adsat like’]+trim(param.ad01adsat)+[%’ and adadsat.ad01id like’]+trim(param.ad01id)+[%’] – ve výrazu se mohou vyskytovat odkazy na parametry (záložka Parametry služby). Celkový tvar dotazu SQL vzniká složením části vzniklé vyhodnocením tohoto výrazu, dále části vzniklé vyhodnocením SQL výrazu uvedeného na záložce Licence a dále vyhodnocením výrazu Order/Group.

Záložka „Výstupní atributy“ slouží pro popis atributů zobrazovaných ve formulářích programu BMWSCLI.EXE, který je určen pro testování definic webových služeb. V popisu jednotlivých atributů se uvádí název atributu, popis návěští a poznámek.

Záložka „Parametry služby“ obsahuje seznam parametrů předávaných webovými službami při volání metody GETDATA. Pro metodu GETDATA u dané služby musí být tyto parametry předávány pozičně podle zadaného pořadí, přičemž parametr webové služby, nadefinovaný jako první v pořadí musí být zároveň uveden jako celkově čtvrtý parametr volání této metody.

Parametry služby se uplatňují pro sestavování výsledného SQL dotazu výrazem (parametr „výraz“ na záložce Webové služby). Při jeho sestavování jsou parametry uloženy jako vlastnosti objektu PARAM s daným jménem. Objekt PARAM má pro předané parametry typu text další vlastnost, jejíž název je odvozen z názvu parametru s postfixem „_LIKE“, který bude obsahovat hodnotu parametru zleva bez mezer doplněnou znakem „%“. Např. po předání parametru JMENO s hodnotou „Chlumec“ bude mít objekt PARAM pro vytvoření SQL dotazu vlastnosti JMENO s hodnotou „Chlumec“ a JMENO_LIKE s hodnotou „Chlumec%“, které budou k dispozici ve tvaru PARAM.JMENO a PARAM.JMENO_LIKE.

Záložka „Licence“ obsahuje seznam uživatelů (resp. skupin uživatelů) webových služeb (v tento okamžik se nejedná o uživatele systému zadávané v činnosti „uživatelé systému“), kteří mají oprávnění používat danou službu. Ke každé licenci je možno definovat „doplňující výraz“, který se po vyhodnocení stane částí celkového SQL dotazu (parametr „výraz“ na záložce Webové služby). V tomto výrazu je možno použít odkazy na parametry uživatele webové služby, které jsou v objektu PARAM reprezentovány vlastnostmi USR_P1, USR_P2 a USR_P3.

Datový model

  • IEWSSLZ Webová služba

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Uživatelé webových služeb | Uživatelé webových služeb

    Formulář

    Formulář činnosti - Uživatelé webových služeb
Mřížka [Webové služby]
Služba | Identifikace webové služby
Název služby | Název webové služby
Listovací rámeček
Stránka #1 Webové služby
Platnost | Platnost webové služby
Výraz | Výraz SQL webové služby
Order/Group | Výraz SQL webové služby - GROUP / ORDER
Poznámka | Poznámka
Stránka #2 Výstupní atributy
Mřížka [Výstupní atributy]
Atribut | Identifikace atributu webové služby
Návěští | Návěští atributu webové služby
Popis | Popis atributu webové služby
Poznámka | Poznámka
Stránka #3 Parametry služby
Mřížka [Parametry služby]
Parametr | Identifikace parametru webové služby
 | Pořadí parametru
Návěští | Návěští parametru webové služby
Popis | Popis parametru webové služby
Typ | Typ parametru dotazu
Délka | Délka numerického nebo znakového parametru
Des. | Počet desetin numerického parametru
Seznam | Výčet hodnot pro překryvný seznam
Poznámka | Poznámka
Stránka #4 Licence
Mřížka [Licence]
Uživatel | Identifikace uživatele webové služby
Jméno | Jméno uživatele webové služby
Doplňující výraz | Doplňující výraz SQL dotazu webové služby
Poznámka | Poznámka

    Mřížka [Webové služby] činnosti - Uživatelé webových služeb

    Mřížka [Webové služby] činnosti - Uživatelé webových služeb
Služba | Identifikace webové služby
Název služby | Název webové služby

    Mřížka [Výstupní atributy] činnosti - Uživatelé webových služeb

    Mřížka [Výstupní atributy] činnosti - Uživatelé webových služeb
Atribut | Identifikace atributu webové služby
Návěští | Návěští atributu webové služby

    Mřížka [Parametry služby] činnosti - Uživatelé webových služeb

    Mřížka [Parametry služby] činnosti - Uživatelé webových služeb
Pořadí | Pořadí parametru
Parametr | Identifikace parametru webové služby
Návěští | Návěští parametru webové služby

    Mřížka [Licence] činnosti - Uživatelé webových služeb

    Mřížka [Licence] činnosti - Uživatelé webových služeb
Uživatel | Identifikace uživatele webové služby
Jméno | Jméno uživatele webové služby

    Viz.také

    Uživatelé webových služeb


Uživatelé webových služeb

Popis

Tato činnost poskytuje přehled uživatelů (resp. skupin uživatelů) webových služeb oprávněných používat webové služby. Jedná se o samostatně definované uživatele, nejsou to uživatelé IS BM definovaní v činnosti Uživatelé systému. Jak je výše zmíněno, uživatelem webových služeb může být konkrétní uživatel nebo skupina uživatelů. Definuje se:

¨ identifikace a jméno uživatele

¨ heslo uživatele

¨ skupina – volba Ano/Ne – zda se jedná o konkrétního uživatele nebo identifikace představuje skupinu uživatelů

¨ aktivní uživatel – volba Ano/Ne (nastavením volby Ne je možno pozastavit přístup uživatele k webovým službám)

¨ uživatelův parametr 1 až 3 – volné parametry uživatele

V případě, že jako uživatel je definována skupina uživatelů, tak se na záložce „zařazení ve skupině“ určí jednotliví uživatelé dané skupiny.

Na záložce „V IS BM provozovatele“ se definují údaje, které uživatelé webových služeb spojí s IS BM. Zadává se IČO organizace, identifikace uživatele, pod kterou je veden v IS BM a který je zákazníkem webové služby a identifikace uživatele webové služby (výběr z číselníku v činnosti Systém – Uživatelé systému).

Pro volání metody GETDATA je uživatel identifikován jménem a heslem. Syntaxe volání metody GETDATA objektu BMWSSRV je:

objekt.GETDATA (<identifikace WS>,<jméno uživatele>,<heslo>,<parametr1>,<parametr2>, ... ,<parametr12>)

Datový model

  • IEWSUSR Uživatel webové služby

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Uživatelé programu | Definování uživatelů programu
F2 | Uživatelé webových služeb | Uživatelé webových služeb

    Formulář

    Formulář činnosti - Uživatelé programu
Mřížka [Uživatelé webových služeb]
Uživatel | Identifikace uživatele webové služby
Jméno | Jméno uživatele webové služby
Listovací rámeček
Stránka #1 Uživatelé webových služeb
Heslo | Heslo uživatele webové služby
Skupina | Skupina uživatelů Ano/Ne
Aktivní uživatel | Aktivní uživatel
Uživatelův parametr 1 | Uživatelův parametr 1
Uživatelův parametr 2 | Uživatelův parametr 2
Uživatelův parametr 3 | Uživatelův parametr 3
Poznámka | Poznámka
Stránka #2 Zařazení ve skupině
Mřížka [Zařazení ve skupině]
Uživatel | Identifikace uživatele webové služby
Jméno | Jméno uživatele webové služby
Stránka #3 V ISBM provozovatele
Mřížka [Uživatelé v ISBM provozovatele webové služby]
IČO | Identifikační číslo organizace.
Uživatel zákazníka WS | Identifikace uživatele v IS BM zákazníka webové služby
Ident. | Identifikace uživatele systému
Uživatel | Jméno uživatele systému

    Mřížka [Uživatelé webových služeb] činnosti - Uživatelé programu

    Mřížka [Uživatelé webových služeb] činnosti - Uživatelé programu
Uživatel | Identifikace uživatele webové služby
Jméno | Jméno uživatele webové služby

    Mřížka [Zařazení ve skupině] činnosti - Uživatelé programu

    Mřížka [Zařazení ve skupině] činnosti - Uživatelé programu
Uživatel | Identifikace uživatele webové služby
Jméno | Jméno uživatele webové služby

    Mřížka [Uživatelé v ISBM provozovatele webové služby] činnosti - Uživatelé programu

    Mřížka [Uživatelé v ISBM provozovatele webové služby] činnosti - Uživatelé programu
Uživatel | Identifikace uživatele webové služby
IČO | Identifikační číslo organizace.
Uživatel zákazníka WS | Identifikace uživatele v IS BM zákazníka webové služby
Uživatel | Identifikace uživatele systému
Uživatel | Jméno uživatele systému

    Viz.také

    Uživatelé programu


STATISTIKA

Popis

V informačním systému BM má uživatel k dispozici velké množství informací. Tyto informace potřebuje určitým způsobem vyhodnotit a třídit. Právě k tomuto účelu slouží komponenta statistiky.

Komponenta "statistika" umožňuje uživateli sledovat statistické hodnoty za selektory za uživatelem zvolené období.

Viz.také

Statistické hodnoty | Přepočet hodnot | Obchodní selektor | Organizační selektor | Technicko-věcný selektor


Statistické hodnoty

Popis

Jsou to určité nadefinované hodnoty, které uživatel sleduje za období, druh hodnoty, komponentu a selektory. U každé hodnoty se evidují selektory, které se mají sledovat a navíc jsou u každé hodnoty k dispozici údaje o počátečním stavu, příjmu, výdeji, obratu a konečném stavu dané hodnoty.

Uživatel tedy může sledovat např. množství vydané ze skladu za určité období nebo spotřebu pohonných hmot apod.

Pokud uživatel potřebuje znát vždy aktuální statistické hodnoty, musí nejprve před aktivací této činnosti spustit činnost "přepočet statistických hodnot".

Datový model

  • SPSTATIS Statistická hodnota
    • SPSTATDI Druh hodnoty
    • SPSEOB Obchodní selektor
    • SPSEOR Organizační selektor
      • SPPRISTU Přístupové právo uživatele k věci
    • SPSETV Technicko-věcný selektor

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Účtový rozvrh | Seznam syntetických a analytických účtů.

    Formulář

    Formulář činnosti - Účtový rozvrh
Mřížka [Statistické hodnoty]
Listovací rámeček
Stránka #1 Statistické hodnoty
Datum | Datum statistické hodnoty
 | Identifikace komponenty
Druh | Identifikace druhu hodnoty
 | Název druhu hodnoty
Obch. sel. | Identifikátor obchodního selektoru
 | Název obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
 | Název organizačního selektoru
Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Název technicko-věcného selektoru.
Poč.stav | Počáteční stav statistické hodnoty
Příjem | Příjem statistické hodnoty
Výdej | Výdej statistické hodnoty
Rozdíl | Rozdíl příjmu a výdeje statistické hodnoty
Kon.stav | Konečný stav statistické hodnoty
Stránka #2 Výběr
Datum | Datum statistické hodnoty
 | Do data statistické hodnoty
Komponenta | Identifikace komponenty
Druh hodnoty | Identifikace druhu hodnoty
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Statistické hodnoty] činnosti - Účtový rozvrh

    Mřížka [Statistické hodnoty] činnosti - Účtový rozvrh
Datum | Datum statistické hodnoty
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Poč.stav | Počáteční stav statistické hodnoty
Příjem | Příjem statistické hodnoty
Výdej | Výdej statistické hodnoty
Rozdíl | Rozdíl příjmu a výdeje statistické hodnoty
Kon.stav | Konečný stav statistické hodnoty
Komp. | Identifikace komponenty
Druh hodnoty | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty

    Atributy tisku

    Základní údaje
Datum | Datum statistické hodnoty | SPSTATIS_sp71datum | D
Komponenta | Identifikace komponenty | SPSTATIS_sp06idsubs | C(3)
Druh hodnoty | Identifikace druhu hodnoty | SPSTATIS_sp67id | C(3)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)
Obchodní selektor | Identifikátor obchodního selektoru | SPSTATIS_sp10idzak | C(9)
Název obchodního selektoru | Název obchodního selektoru | SPSEOB_sp10text | C(60)
Organizační selektor | Identifikátor organizačního selektoru. | SPSTATIS_sp11idzak | C(9)
Název organizačního selektoru | Název organizačního selektoru | SPSEOR_sp11text | C(60)
Technicko-věcný selektor | Identifikátor technicko-věcného selektoru. | SPSTATIS_sp20idzak | C(9)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(60)
Poč.stav | Počáteční stav statistické hodnoty | SPSTATIS_sp71pstav | N(20,4)
Příjem | Příjem statistické hodnoty | SPSTATIS_sp71prijem | N(20,4)
Výdej | Výdej statistické hodnoty | SPSTATIS_sp71vydej | N(20,4)
Rozdíl | Rozdíl příjmu a výdeje statistické hodnoty | Výpočet | N(20,4)
Kon.stav | Konečný stav statistické hodnoty | Výpočet | N(20,4)

    Viz.také

    Druhy hodnot | Obchodní selektor | Organizační selektor | Technicko-věcný selektor | Účtový rozvrh


Přepočet hodnot

Popis

Protože statistické hodnoty jsou v informačním systému plněny dávkově, je pro aktuální zobrazení statistických hodnot nutno aktivovat nejprve tuto činnost.

Přepočet hodnot však neslouží pouze pro přepočet statistických hodnot, ale je možno přepočítat i saldokontní hodnoty, účetní saldokontní hodnoty, aktuální hodnoty a hodnoty obratů. U statistických hodnot a hodnoty obratů je při přepočtu podstatné jakým způsobem je zadán tento druh hodnoty. Pokud má u sebe zatržen příznak "den do ...." počítá se přepočet těchto hodnot po jednotlivých dnech, jinak se jako období bere měsíc.

Pomocí šipek (přesun z levé části formuláře do pravé části) si uživatel určí, kterou komponentu (nebo komponenty) chce přepočítat, zaškrtne si hodnoty, které se mají přepočítat a stiskne tlačítko PŘEPOČET. Po jeho aktivaci se systém dotazuje: „Přepočet hodnot s rezervací dat komponent? Ano/Ne“. V případě volby Ano jsou komponenty, jejich hodnoty se přepočítávají, rezervovány pro tento přepočet, tzn. že v tento okamžik do nich není možno vkládat žádná nová data. Po dokončení přepočtu systém hlásí: „Přepočet hodnot byl proveden“.

Formulář

Formulář činnosti - Spustit přepočet
 | Seznam komponent
Tlačítko
Tlačítko
Tlačítko
Tlačítko
Tlačítko
 | Seznam komponent
Statistické hodnoty | Vykonat přepočet statistických hodnot
Aktuální hodnoty | Vykonat přepočet aktuálních hodnot
Hodnoty obratů | Vykonat přepočet hodnot měnících obraty
Saldokontní hodnoty | Vykonat přepočet saldokontních hodnot
Druh procesu | Identifikátor druhu procesu
Vznik procesu | Datum zahájení procesu
 | Datum zahájení procesu

Vyvolávané činnosti

K. | Činnost | Popis
- | Spustit přepočet | Spuštění přepočtu statistických hodnot

Viz.také

Spustit přepočet


OCEŇOVÁNÍ

Popis

Komponenta oceňování řeší oceňování především pro potřeby komponenty obchod a platby. Umožňuje např. obchodování v cizích měnách, vedení kurzového lístku apod. Dodáván je naplněn standardním číselníkem Ministerstva financí ČR (měny a banky).

Viz.také

Měny a kursy | Banky | Parametry oceňování | Cenové skupiny | Ceník artiklu | Přepočítávací koeficienty | Operace s kurzem prvého dne


Měny a kursy

Popis

Činnost měny a kurzy umožňuje evidovat měny a jejich kurzy vůči referenční měně. Kurzy se vztahují k datu a bance, u které je kurz veden.

Záložka "měna" poskytuje uživateli tyto informace:

¨ měna - kód měny

¨ název měny - název měny

¨ znak - znak (označení) měny, které se hlavně využívá v tisku. Např. dolar = $, koruna česká = Kč ...

¨ zaokrouhlování - zaokrouhlení na řád v přepisu na platby (tzn. že podle tohoto nastaveného zaokrouhlení se zaokrouhlují částky v událostech plateb)

¨ nejmenší jednotka měny - určení nejmenší jednotky dané měny

¨ platnost od

¨ platnost do – tento atribut uživatel využije v případě, že ze zákona nastane změna referenční měny (např. od 1.1.2009 přestávají platit slovenské koruny a jako referenční měna bude EURO.). Novou identifikaci referenční měny si uživatel nastaví v parametrech oceňování a v tomto atributu je nutno nastavit platnost do původní referenční měny (v našem případě to znamená, že u slovenských korun bude nastavena platnost do 31.12.2008). V případě, že je u měny uvedeno období platnosti, nelze pak v událostech vstoupit měnu, jejíž datum nespadá do období platnosti měny.

Záložka "kurz" obsahuje tyto atributy:

¨ referenční měna - je předplněna z parametrů oceňování

¨ kód banky - lze vybrat kód banky z číselníku bank (zobrazí se název banky) pomocí klávesy F2

¨ datum - je předplněn datum aktuálního dne

¨ střed, nákup, prodej - kurzy měny vůči referenční měně

¨ množství - množství oceňovací jednotky (měny) v kurzu (např. 1000 lir)

Datový model

  • OCMENA Měna

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Banky | Číselník bank

    Formulář

    Formulář činnosti - Banky
Mřížka [Měny]
Měna | Kód měny - oceňovací jednotky.
Název měny | Název měny
Listovací rámeček
Stránka #1 Měna
Znak | Označení měny.
Zaokrouhlování | Zaokrouhlení na řád v předpisu platby
Nejmenší jednotka měny | Nejmenší jednotka měny
Platnost od | Platnost měny od
Platnost do | Platnost měny do
Stránka #2 Kurs
Mřížka [Kurs]
Ref. měna | Referenční měna
Kód banky | Kód banky
 | Název banky
Datum | Datum platnosti kursu.
Střed | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - střed.
Nákup | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup.
Prodej | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - prodej.
Množství | Množství oceňovací jednotky v kursu.

    Mřížka [Měny] činnosti - Banky

    Mřížka [Měny] činnosti - Banky
Název měny | Název měny
Měna | Kód měny - oceňovací jednotky.
Znak | Označení měny.
Platnost od | Platnost měny od
Platnost do | Platnost měny do

    Mřížka [Kurs] činnosti - Banky

    Mřížka [Kurs] činnosti - Banky
Datum | Datum platnosti kursu.
Střed | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - střed.
Nákup | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup.
Prodej | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - prodej.
Množství | Množství oceňovací jednotky v kursu.

    Atributy tisku

    Základní údaje
Měna | Kód měny - oceňovací jednotky. | OCMENA_oc01id | C(3)
Název měny | Název měny | OCMENA_oc01nazev | C(18)
Znak | Označení měny. | OCMENA_oc01znak | C(3)
Zaokrouhlování | Zaokrouhlení na řád v předpisu platby | Výpočet | C(9)
Nejmenší jednotka měny | Nejmenší jednotka měny | Výpočet | C(6)
Platnost od | Platnost měny od | OCMENA_oc01platod | D
Platnost do | Platnost měny do | OCMENA_oc01platdo | D
Název banky | Název banky | OCBANKA_oc02nazevb | C(40)

    Při pohybu v Kursy
Referenční měna | Referenční měna | OCKURS_oc01id1 | C(3)
Datum | Datum platnosti kursu. | OCKURS_oc03dat | D
Kód banky | Kód banky | OCKURS_oc02idbank | C(4)
Kurs | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup. | OCKURS_oc03kurz | N(20,6)
Množství | Množství oceňovací jednotky v kursu. | OCKURS_oc03mn | N(5)

    Viz.také

    Banky


Banky

Popis

Činnost banky slouží jako číselník finančních ústavů, které provádí bankovní a finanční operace pro daného adresáta. Vstupují se tyto položky:

¨ kód banky - zadává se kód banky.

¨ název banky - název banky (finančního ústavu).

¨ SWIFT - SWIFT kód banky.

¨ kód BLZ - BLZ kód banky - slouží pro komunikaci mezi bankami.

¨ adresát - identifikace adresáta, číslo adresy adresáta, název adresáta (předplní se podle ID adresáta).

¨ kontrola čísla účtu - umožňuje provádět validaci čísla bankovního účtu v bankovním spojení adresáta. Může nabývat hodnot:

- žádná - tj. nebude se provádět žádná kontrola

-varování modulo 11 - bude se provádět kontrola účtu podle pravidla "modulo 11" a při zadání nevyhovujícího čísla je v pravém horním rohu zobrazeno varovné hlášení a záznam půjde i přes varování zapsat

- nepovolit modulo 11 - bude se provádět kontrola podle pravidla "modulo 11" a při zadání nevyhovujícího čísla nebude možné záznam zapsat

Tato nastavení se uplatňují při zadávání bankovního spojení v adresáři činnostmi "Adresář" a "Bankovní spojení adresáta" a při uvedení čísla bankovního účtu v události změny stavu peněz.

Datový model

  • OCBANKA Banka
    • ADADSAT Adresát
    • ADADR Adresa

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresy | Seznam adres za adresáta.
F2 | Adresář | Přehled adresátů

    Formulář

    Formulář činnosti - Adresy
Mřížka [Banky]
Kód banky | Kód banky
Název banky | Název banky
SWIFT | SWIFT kód banky.
Kód BLZ | BLZ kód banky
Adresát | Identifikace adresáta
 | Číslo adresy adresáta.
 | Název adresáta
Kontrola čísla účtu | Kontrola čísla účtu

    Mřížka [Banky] činnosti - Adresy

    Mřížka [Banky] činnosti - Adresy
Název banky | Název banky
Kód banky | Kód banky
SWIFT | SWIFT kód banky.
Kód BLZ | BLZ kód banky

    Atributy tisku

    Základní údaje
Kód banky | Kód banky | OCBANKA_oc02idbank | C(4)
Název banky | Název banky | OCBANKA_oc02nazevb | C(40)
SWIFT | SWIFT kód banky. | OCBANKA_oc02swift | C(11)
Kód BLZ | BLZ kód banky | OCBANKA_oc02blz | C(10)
Adresát | Identifikace adresáta | OCBANKA_ad01id | C(6)
Adresa | Číslo adresy adresáta. | OCBANKA_ad02cisadr | C(2)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
IČO | Identifikační číslo organizace. | ADADSAT_ad01ico | C(10)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)
Stát | Identifikace státu. | ADADR_ad05id | C(3)
Kontrola čísla účtu | Kontrola čísla účtu | Výpočet | C(19)

    Viz.také

    Adresy | Adresář


Parametry oceňování

Popis

Parametry oceňování slouží pro definici parametrů, které jsou následně používány i při práci v jiných komponentách. Uživatel zadává tyto parametry:

¨ Referenční měna - zadává se kód měny - referenční měna slouží jako oceňovací jednotka.

¨ Kód implicitní banky - zadává se kód banky - zde je možnost nastavit implicitní banku uživatele. Tato položka není povinná. Je vhodné ji vyplnit v okamžiku, kdy uživatel nemá vyplněnou identifikaci centrální banky. Měna účtu s identifikací této implicitní banky pak slouží pro předplňování v událostech, tzn. že kurzový lístek by měl být veden v souvislosti s kurzy této banky. V podstatě lze říci, že platí, že v parametrech musí být prioritně uveden kurz centrální banky, kód implicitní banky zůstává prázdný. Pouze v případě, že uživatel nebude mít zadán kód centrální banky (z nějakého důvodu ji nechce používat), tak vyplní kód implicitní banky. Neměla by nastat situace, že ani jeden kód nebude vyplněn, protože poté dochází v událostech, kde je použita zahraniční měna k chybovým hlášením ohledně kurzového lístku (systém „nechápe“, ke které bance se má uvedená měna vztahovat).

¨ Kód centrální banky - zadává se kód banky - zde se nastaví centrální banka. Pokud je zadaná centrální banka, pozbývá smyslu zároveň zadávat i kód implicitní banky, v takovém případě je vhodné nechat tento atribut prázdný.

¨ Předplňovat kurz pouze je-li aktuální - pokud je tato volba zaškrtnuta, dojde u atributu kurz (na událostech obchodu) k předplnění hodnoty kurzu aktuálním kurzem (tzn. že v kurzovém lístku musí být kurz k aktuálnímu dni zařazen). Aktuálním kurzem se rozumí v případě komponenty platby kurz se stejným datem jako datum události na platbě (nikoliv datum splatnosti). V případě komponenty obchod se aktuálním kurzem rozumí kurz se stejným datem jako datum dodání na události obchodu. Pokud není zaškrtnuto, předplní se kurz vždy a to ten, který je jako poslední zadaný v kurzovém lístku (nezatrhává se např. v kombinaci s použitím činnosti operace s kurzem prvého dne, tzn. při používání pevných ročních nebo měsíčních kurzů).

¨ Pro dnešní datum pracovat s včerejším kurzem do ... h – zatržení respektuje ustanovení, že do uvedené hodiny a minuty lze vyhodnocovat částky v zahraničních měnách kurzem předchozího dne. Při vstupu událostí s aktuálním datem a zároveň s aktuálním časem počítače menším než uvedený čas v parametru systém tedy pak v událostech předplňuje kurz kurzem předchozího dne (v pondělí je to pátečním kurzem). Pozn.: někteří uživatelé zde uvádějí 15h, protože to je čas, kdy ČNB vydává oficiální denní kurzy, nicméně hodina a minuta zde uvedená zcela závisí na vnitropodnikových směrnicích uživatele.

¨ Automatická aktualizace kurzu - pokud je tato volba zaškrtnuta, zadá-li se na událostech kurz, je automaticky aktualizován v číselníku měn a kurzů (jen, pokud ještě pro daný den neexistuje). V případě, že je zaškrtnutý příznak „ pro dnešní datum pracovat s včerejším kurzem do 15:00 hodin“ a vstupují se události s aktuálním datem a zároveň s aktuálním časem počítače menším než 15h, je podle tohoto pravidla aktualizován kurz dané měny uložený v IS BM.

¨ Přepočet měn EMU - historický atribut. V současné době není jeho používání opodstatněné.

Pod menu volby má uživatel k dispozici činnost „Tabulka přechodů na měny“. Uživatel ji použije pouze v případě, že nastane situace přechodu na novou měnu (např. od 1.1.2009 na Slovensku přechod ze slovenských korun na měnu euro). V této činnosti v podstatě uživatel určuje novou referenční měnu, která se pak následně předplňuje jako referenční v událostech, ve kterých se pracuje s měnou (obchod, DPH, platby, změna stavu peněz, zálohy, účetnictví). Ve formuláři „Tabulka přechodů na měny“ se uvádí datum platnosti měny OD a identifikátor měny.

S případnou změnou referenční měny souvisí i nastavení platnosti měny (v činnosti Měny a kursy). U původní referenční měny (v našem případě u slovenských korun) je nutno nastavit platnost měny do, tzn. v této činnosti je nutno nastavit, že od 1.1.2009 je nová referenční měna EURO a v činnosti Měny a kurzy je nutno u slovenských korun nastavit platnost do 31.12.2007. V případě, že je u měny uvedeno období platnosti, nelze pak v událostech vstoupit měnu, jejíž datum nespadá do období platnosti měny.

Důležité upozornění:

Uvedené údaje o referenční měně se v činnosti Parametry oceňování ukládají do tabulky BWMEMOR s celou řadou dalších proměnných. Pro snadnější získání těchto údajů programovými prostředky je v IS BM objekt OCPARAM, nesoucí tyto údaje. S tímto parametrem lze dále uživatelsky pracovat např. v doplňujících vlastnostech formuláře či v předlohách výstupu.

V implementačních doplněních uváděných v jazyce FoxPro (např. právě doplňující vlastnosti formuláře) je vhodné uplatnit tuto konstrukci:

if type('ocparam')<>'O'

do ocparam

endif

která způsobí, že pokud neexistuje objekt ocparam, tak se spustí procedura ocparam a objekt se vytvoří

V předlohách výstupu lze uplatnit tuto konstrukci. Ve vlastnostech předlohy na záložce Deklarace v kolonce Script před SQL dotazem je nutno uvést:

if type('ocparam')<>'O'

do ocparam

endif

a následně ve vlastnostech předlohy na záložce Doplnění v atributech je nutno zapsat:

OBCENIK.oc01id=?ocparam.oc01id

Formulář

Formulář činnosti - Tabulka přechodů na měny
Referenční měna | Kód měny - oceňovací jednotky.
 | Název měny
Kód centrální banky | Kód centrální banky
 | Název banky
Kód implicitní banky | Kód implicitní banky
 | Název banky
Předplňovat kurz pouze je-li aktuální | Předplňovat kurs pouze je-li aktuální
Pro dnešní datum pracovat s včerejším kurzem do | Při zjišťování kurzu k dnešnímu datu do určené hodiny pracovat s včerejším kurzem
hodin | Mezní hodina, do které se pro dnešní datum pracuje s kurzem včerejšího dne
Automatická aktualizace kurzu | Příznak automatické aktualizace kursu
Přepočet měn EMU | Přepočet částek v měnách členských zemí EMU na CZK

Vyvolávané činnosti

K. | Činnost | Popis
- | Tabulka přechodů na měny | Tabulka přechodů na měny
F2 | Banky | Číselník bank
F2 | Měny a kursy | Číselník měn včetně jejich kursů

Viz.také

Tabulka přechodů na měny | Banky | Měny a kursy


Cenové skupiny

Popis

Tato činnost umožňuje uživateli prohlížet seznam vytvořených cenových skupin. Je určen na podporu správy ceníků a automatizaci v oblasti předplnění cen artiklů. U každé cenové skupiny se eviduje:

¨ identifikace a název cenové skupiny

¨ typ ceny (prodejní, nákupní, skladová, ostatní)

¨ implicitní - pokud je zatrženo, uplatní se tato cena v automatizaci vstupu událostí obchodu

¨ spojená cena - je to identifikace cenové skupiny, která je určitým způsobem spojena s cenou aktuální. V podstatě to znamená, že na událostech obchodu má pak uživatel k dispozici aktuální cenovou skupinu a kromě toho na záložce "další" má k dispozici výši i této spojené ceny (může být nadefinována např. u prodejní ceny jako cena spojená cena nákupní nebo smluvní apod.)

Záložka "cenová období" umožňuje uživateli prohlížet a definovat cenová období s počátečním a koncovým datem jejich platnosti. U jednotlivých cenových skupin je při jejich definování kontrolováno datum platnosti od – do, tzn. že nemůže nastat situace s překryvem cenových období.

Záložka "AAA v cenové skupině - obchod" umožňuje uživateli definovat, že daná cenová skupina se bude automaticky uplatňovat v událostech obchodu jako implicitní pro zde uvedené adresáty na artikly se zde uvedenou maskou pro jejich technicko věcný selektor, pokud v ceníku existuje cena v dané cenové skupině. Atributy obchodní smlouva, výběr podle OS a umístění zajistí, že daná cena se v události obchodu automaticky předplní jen tehdy, pokud je v ní uvedeno. Zde uvedené procento slevy se předplní v události obchodu při aplikaci dané cenové skupiny, pokud v ceníku uvedená sleva nabývá hodnoty nula. V případě, že adresát je uveden v několika cenových skupinách, pak se do události obchodu předplní ta cenová skupina, u které je zde uvedena priorita s nižším číslem.

Činnost cenové skupiny umožňuje automatizovaně aktualizovat ceník pomocí funkce "přepočet cen artiklu" v menu Volby.

Datový model

  • OBCENSKP Cenová skupina obchodovatelného artiklu
    • BWUZIVAT Uživatel systému

    • Vyvolávané činnosti

    K. | Činnost | Popis
^P | Přepočet cen artiklů | Přepočet cen artiklů podle výrazu u typu ceny
F2 | Adresář | Přehled adresátů
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Umístění - distr. kanál | Umístění - distribuční kanál

    Formulář

    Formulář činnosti - Spojení adresátů
Mřížka [Cenové skupiny]
Listovací rámeček
Stránka #1 Cenové skupiny
Skupina | Identifikace cenové skupiny
 | Název cenové skupiny
Typ ceny | Typ ceny Prodejní,Nákupní,Skladová,Ostatní
Zákaz překryvu cen. obd. | Zákaz překryvu cenových období (Ano - zákaz překryvu, Ne - překryv povolen)
Implicitní | Implicitní cenová skupina
Spojená | Identifikace spojené cenové skupiny
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Poznámka | Poznámka k cenové skupině
Stránka #2 Cenová období
Mřížka [Cenová období]
Období | Identifikace cenového období
 | Název cenového období
Datum platnosti od | Datum platnosti od
do | Datum platnosti do
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Poznámka | Poznámka k cenovému období
Stránka #3 AAA v cenové skupině - obchod
Mřížka [AAA v cenové skupině - obchod]
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
OS | Číslo obchodní smlouvy
Výběr podle OS | Výběr podle obchodní smlouvy
Maska | Maska technicko-věcného selektoru artiklu
Umístění | Identifikace umístění obchodu - distribučního kanálu
 | Název umístění obchodu - distribučního kanálu
Sleva % | Sleva uvedená v procentech
Priorita | Priorita výběru ceníkové položky

    Mřížka [Cenové skupiny] činnosti - Spojení adresátů

    Mřížka [Cenové skupiny] činnosti - Spojení adresátů
Skupina | Identifikace cenové skupiny
Typ ceny | Typ ceny Prodejní,Nákupní,Skladová,Ostatní
Název cenové skupiny | Název cenové skupiny

    Mřížka [Cenová období] činnosti - Spojení adresátů

    Mřížka [Cenová období] činnosti - Spojení adresátů
Skupina | Identifikace cenové skupiny
Období | Identifikace cenového období
Datum platnosti od | Datum platnosti od
Název cenového období | Název cenového období

    Mřížka [AAA v cenové skupině - obchod] činnosti - Spojení adresátů

    Mřížka [AAA v cenové skupině - obchod] činnosti - Spojení adresátů
Skupina | Identifikace cenové skupiny
Adresát | Identifikace adresáta
Obchodní smlouva | Číslo obchodní smlouvy
Maska | Maska technicko-věcného selektoru artiklu
Umístění | Identifikace umístění obchodu - distribučního kanálu
Priorita | Priorita výběru ceníkové položky
Název adresáta | Název adresáta

    Atributy tisku

    Základní údaje
Skupina | Identifikace cenové skupiny | OBCENSKP_ob11id | C(3)
Název cenové skupiny | Název cenové skupiny | OBCENSKP_ob11nazcsk | C(40)
Typ ceny | Typ ceny Prodejní,Nákupní,Skladová,Ostatní | Výpočet | C(8)
Zákaz překryvu cen. obd. | Zákaz překryvu cenových období (Ano - zákaz překryvu, Ne - překryv povolen) | Výpočet | C(3)
Implicitní | Implicitní cenová skupina | Výpočet | C(3)
Spojená skupina | Identifikace spojené cenové skupiny | OBCENSKP_ob11idspoj | C(3)
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | OBCENSKP_sp00datzap | T
Poznámka | Poznámka k cenové skupině | OBCENSKP_ob11koment | M
Založil | Jméno uživatele systému | BWUZIVA1_bw01jmeno | C(30)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Název umístění | Název umístění obchodu - distribučního kanálu | OBUMIST_ob05text | C(40)

    Při pohybu v Cenová období
Období | Identifikace cenového období | OBCENOBD_ob12id | C(3)
Název cenového období | Název cenového období | OBCENOBD_ob12nazcob | C(40)
Datum platnosti od | Datum platnosti od | OBCENOBD_ob12datum | D
Datum a čas zápisu | Datum a čas zápisu záznamu události | OBCENOBD_sp00datzap | T
Poznámka | Poznámka k cenovému období | OBCENOBD_ob12koment | M

    Při pohybu v AAA cenové skupiny - obchod
Adresát | Identifikace adresáta | OBCENSAK_ad01id | C(6)
Umístění | Identifikace umístění obchodu - distribučního kanálu | OBCENSAK_ob05id | C(6)
Sleva % | Sleva uvedená v procentech | OBCENSAK_ob13sleva | N(7,2)
Artikl | Maska technicko-věcného selektoru artiklu | OBCENSAK_ob13idzak | C(9)
Priorita | Priorita výběru ceníkové položky | OBCENSAK_ob13prior | N(2)
Obchodní smlouva | Číslo obchodní smlouvy | OBCENSAK_ob02hs | C(20)
Výběr podle OS | Výběr podle obchodní smlouvy | Výpočet | C(3)

    Viz.také

    Přepočet cen artiklů | Adresář | Spojení adresátů | Umístění - distr. kanál


Ceník artiklu

Popis

Tato činnost slouží jako přehled, který udává jednotkovou cenu obchodního artiklu pro danou měrnou jednotku a pro danou měnu. Cena je sledována za artikl, za ostatní náklady a celkem.

Pokud chce uživatel po aktivaci této činnosti využít vyhledávání artiklu na záložce Výběr, tak pro tuto činnosti platí:

- je nutno zadat buď celé číslo artiklu

- nebo uvést pouze počáteční znaky čísla artiklu, ale za ně je nutno uvést znak %

U každého artiklu jsou k dispozici atributy identifikace a název artiklu. Dále se při vytváření ceníku artiklu vstupují tyto atributy:

¨ cenová skupina - identifikace typu ceníkové ceny. Lze vybrat z číselníku cenových skupin.

¨ období - období platnosti ceny v ceníku

¨ MJ - identifikátor měrné jednotky (musí být vyplněno). Lze vybrat ze seznamu měrných jednotek klávesou F2. Sám se doplní název měrné jednotky.

¨ měna - kód měny - oceňovací jednotky (musí být uvedeno). Je předplněn z parametrů oceňování referenční měnou. Lze ji měnit - výběr ze seznamu měn a kurzu klávesou F2. Sám se doplní název měny.

¨ CJ - artikl - cena ceníková za artikl za měrnou jednotku v oceňovací jednotce.

¨ CJ - ostatní nákl. - cena ceníková ostatních nákladů za měrnou jednotku v oceňovací jednotce.

¨ CJ - celkem - CJ - cena ceníková celkem za měrnou jednotku v oceňovací jednotce [služba + artikl] (musí být uvedeno) - nevstupuje se, dopočte se podle zadaného CJ - artikl a ostatní. Pokud neexistuje CJ - ostatní nákl., je cena CJ - artikl a CJ - celkem shodná.

Na záložce Historie ceny může uživatel sledovat vývoj a historii ceny u daného artiklu. Historie se zde však zobrazuje pouze v případě, že artikl má na kartě zatržen příznak „historie ceny“.

Na základě příslušnosti artiklu do dané kategorie a platnosti artiklu je následně upravena i výběrová záložka, kde se uvádí:

¨ příslušnost artiklu v dané kategorii – překryvný seznam – Je / Není / Byl / Nebyl (tj. Je=k dnešnímu datu je v kategorii, Není=k dnešnímu datu není v kategorii, Byl=není v kategorii, ale byl, Nebyl=není a nikdy v kategorii nebyl). Dále se zadává identifikátor a název kategorie

¨ platnost – překryvný seznam – Platné i neplatné / Platné dnes / Neplatné dnes / Platné k datu / Neplatné k datu. Následující atribut „datum“ je spojen s platností Platné k datu a Neplatné k datu. Za platný artikl je považován takový, pro který neexistuje žádná událost s kategorií určující platnost a poslední událost o libovolné kategorii určující platnost nenaplánovaná do budoucnosti má uvedenou platnost od – do, do které spadá odpovídající datum.

Na základě zvolení Palety na záložce Výběr je možno přehled artiklů zvýraznit i barevně.

Datový model

  • OBCENIK Položka ceníku artiklu
    • OBCENSKP Cenová skupina obchodovatelného artiklu
    • OBCENOBD Cenové období cenové skupiny obchodovatelného artiklu
    • SPMJ Měrná jednotka
      • SPMJN Měrná jednotka v jazyce
    • OCMENA Měna
    • SPARTIKL Artikl
      • SPARTIKN Název artiklu

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Události správy artiklu |
- | Legenda palety barev |
F2 | Artikl | Seznam artiklu
F2 | Cenová období | Výběr cenového období
F2 | Cenové skupiny | Přehled cenových skupin obchodovatelného artiklu
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Kategorie událostí správy artiklu | Přehled kategorií událostí správy artiklu
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Měrné jednotky | Číselník měrných jednotek
F2 | Palety barev kategorií | Palety barev kategorií

    Formulář

    Formulář činnosti - Legenda palety barev
Mřížka [Ceník]
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Listovací rámeček
Stránka #1 Ceník
Skupina | Identifikace cenové skupiny
 | Název cenové skupiny
Období | Identifikace cenového období
 | Název cenového období
 | Datum platnosti od
 | Datum platnosti do
MJ | Identifikátor měrné jednotky
 | Název měrné jednotky
Měna | Kód měny - oceňovací jednotky.
 | Název měny
CJ - artikl | Cena ceníková za artikl za měrnou jednotku v oceňovací jednotce
CJ - ostatní nákl. | Cena ceníková ostatních nákladů za měrnou jednotku v oceňovací jednotce
CJ - celkem | Cena ceníková celkem za měrnou jednotku v oceňovací jednotce (služba + artikl)
Sleva % | Sleva uvedená v procentech
Stránka #2 Historie cen
Mřížka [Historie cen]
Platnost do | Datum platnosti ceny - do
Příznak | Příznak historické ceny
CJ - artikl | Cena ceníková za artikl za měrnou jednotku v oceňovací jednotce
CJ - ostatní nákl. | Cena ceníková ostatních nákladů za měrnou jednotku v oceňovací jednotce
CJ - celkem | Cena ceníková celkem za měrnou jednotku v oceňovací jednotce (služba + artikl)
Sleva % | Sleva uvedená v procentech
Stránka #3 Výběr
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Skupina | Identifikace cenové skupiny
Období | Identifikace cenového období
Typ ceny | Typ ceny Prodejní,Nákupní,Skladová,Ostatní
MJ | Identifikátor měrné jednotky
Měna | Kód měny - oceňovací jednotky.
Vztah ke kategorii | Vztah ke kategorii - Je=K dnešnímu datu je v kategorii, Není=K dnešnímu datu není v kategorii, Byl=Není v kategorii, ale byl, Nebyl=Není a nikdy nebyl v kategorii,Bude=Bude v kategorii
Kategorie | Identifikace kategorie události správy artiklu
Název kategorie | Název kategorie události správy artiklu
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 | Platnost nebo neplatnost k datu
Paleta | Vybrat záznamy všech kategorií v paletě
 | Identifikace palety barev
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Ceník] činnosti - Legenda palety barev

    Mřížka [Ceník] činnosti - Legenda palety barev
Skupina | Identifikace cenové skupiny
Období | Identifikace cenového období
MJ | Identifikátor měrné jednotky
Měna | Kód měny - oceňovací jednotky.
CJ - celkem | Cena ceníková celkem za měrnou jednotku v oceňovací jednotce (služba + artikl)
CJ - artikl | Cena ceníková za artikl za měrnou jednotku v oceňovací jednotce
CJ - ostatní nákl. | Cena ceníková ostatních nákladů za měrnou jednotku v oceňovací jednotce
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Název cenové skupiny | Název cenové skupiny

    Mřížka [Historie cen] činnosti - Legenda palety barev

    Mřížka [Historie cen] činnosti - Legenda palety barev
Platnost do | Datum platnosti ceny - do
Skupina | Identifikace cenové skupiny
Období | Identifikace cenového období
MJ | Identifikátor měrné jednotky
Měna | Kód měny - oceňovací jednotky.
CJ - artikl | Cena ceníková za artikl za měrnou jednotku v oceňovací jednotce
 | Cena ceníková ostatních nákladů za měrnou jednotku v oceňovací jednotce

    Atributy tisku

    Základní údaje
Skupina | Identifikace cenové skupiny | OBCENIK_ob11id | C(3)
Název cenové skupiny | Název cenové skupiny | OBCENSKP_ob11nazcsk | C(40)
Typ ceny | Typ ceny Prodejní,Nákupní,Skladová,Ostatní | Výpočet | C(8)
Období | Identifikace cenového období | OBCENIK_ob12id | C(3)
Název cenového období | Název cenového období | OBCENOBD_ob12nazcob | C(40)
Datum platnosti od | Datum platnosti od | OBCENOBD_ob12datum | D
Artikl | Identifikace artiklu | OBCENIK_sp60id | C(13)
Druh artiklu | Identifikace druhu artiklu | OBCENIK_sp61id | C(3)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Měrná jednotka | Identifikátor měrné jednotky | OBCENIK_sp24idmj | C(3)
Název měrné jednotky | Název měrné jednotky | SPMJN_sp58mjnaz | C(40)
Měna | Kód měny - oceňovací jednotky. | OBCENIK_oc01id | C(3)
Název měny | Název měny | OCMENA_oc01nazev | C(18)
CJ - artikl | Cena ceníková za artikl za měrnou jednotku v oceňovací jednotce | OBCENIK_ob03cj02 | N(20,6)
CJ - ostatní nákl. | Cena ceníková ostatních nákladů za měrnou jednotku v oceňovací jednotce | OBCENIK_ob03cj03 | N(20,6)
CJ - celkem | Cena ceníková celkem za měrnou jednotku v oceňovací jednotce (služba + artikl) | Výpočet | N(20,6)
Sleva % | Sleva uvedená v procentech | OBCENIK_ob03sleva | N(7,2)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Název umístění | Název umístění obchodu - distribučního kanálu | OBUMIST_ob05text | C(40)

    Při pohybu v AAA cenové skupiny - obchod
Adresát | Identifikace adresáta | OBCENSAK_ad01id | C(6)
Spojení | Číslo spojení adresáta. | OBCENSAK_ad11cisspo | C(2)
Umístění | Identifikace umístění obchodu - distribučního kanálu | OBCENSAK_ob05id | C(6)

    Viz.také

    Události správy artiklu | Legenda palety barev | Artikl | Cenová období | Cenové skupiny | Druhy artiklů | Kategorie událostí správy artiklu | Měny a kursy | Měrné jednotky | Palety barev kategorií


Přepočítávací koeficienty

Popis

V současné době pozbyla tato činnost na významu.

Datový model

  • OCPREPKO Období platnosti přepočítávacího koeficientu

    • Formulář

    Formulář činnosti - Tabulka přechodů na měny
Mřížka [Období platnosti]
Období | Identifikace období platnosti přepočítávacího koeficientu
Datum od | Datum platnosti od
do | Datum platnosti do
Platné období | Platné období, bude užito pro výpočet triangulací
Listovací rámeček
Stránka #1 Období
Stránka #2 Přepočítávací koeficienty
Mřížka [Přepočítávací koeficienty]
Měna | Kód měny - oceňovací jednotky.
 | Název měny
Přepočítávací koeficient | Přepočítávací koeficient

    Mřížka [Období platnosti] činnosti - Tabulka přechodů na měny

    Mřížka [Období platnosti] činnosti - Tabulka přechodů na měny
Období | Identifikace období platnosti přepočítávacího koeficientu
Datum od | Datum platnosti od
do | Datum platnosti do
Platné období | Platné období, bude užito pro výpočet triangulací

    Mřížka [Přepočítávací koeficienty] činnosti - Tabulka přechodů na měny

    Mřížka [Přepočítávací koeficienty] činnosti - Tabulka přechodů na měny
Měna | Kód měny - oceňovací jednotky.
Název měny | Název měny
Přepočítávací koeficient | Přepočítávací koeficient

    Atributy tisku

    Základní údaje
Období | Identifikace období platnosti přepočítávacího koeficientu | OCPREPKO_oc05id | C(3)
Datum od | Datum platnosti od | OCPREPKO_oc05datumo | D
do | Datum platnosti do | OCPREPKO_oc05datumd | D
Platné období | Platné období, bude užito pro výpočet triangulací | Výpočet | C(3)
Měna | Kód měny - oceňovací jednotky. | OCPREPK_oc01id | C(3)
Název měny | Název měny | OCMENA_oc01nazev | C(18)
Přepočítávací koeficient | Přepočítávací koeficient | OCPREPK_oc06koef | N(12,6)


Operace s kurzem prvého dne

Popis

Tuto činnost uživatel využije v případě, pokud při práci s kurzovým lístkem používá v událostech obchodu pevné měsíční kurzy (tzn. chce mít pro jeden měsíc stále stejný kurz). Potom nastaví komponentu a operaci, které se tato vlastnost bude týkat a při aktivaci této operace se bude předplňovat po celý měsíc kurz, který je v kurzovém lístku uveden v daném měsíci jako první.

Atribut posun roku slouží pro zadávání měsíčního kurzu u daných operací v případě, že se ve firmě používají zároveň i běžné denní kurzy. Aby pak nenastala situace, že kurz dané operace, který chce uživatel používat celý měsíc stejný je přepsán kurzem daného dne, použije se atribut posun roku. Do něj uživatel zapíše např. 100, 1000 apod. a pak se při zadávání dané operace do kurzového lístku zapíše kurz s datem o 100 nebo 1000 menší (např. aktuální datum je 1.1.2007, potom kurz v kurzovém lístku musí být zadán s datem 1.1.1907), ale bude platný pro tuto operaci celý měsíc a není možné, aby ho přepsal denní aktuální kurz (v případě, že uživatel chce využívat tuto možnost, nesmí mít zároveň v parametrech oceňování „zaškrtnutý“ atribut předplňovat kurz je-li aktuální).

Datový model

  • OCKUROPE Druh operace s vyhodnocením kurzu k prvému dni měsíce
    • SPTYP Druh procesu/operace

    • Formulář

    Formulář činnosti - Druhy operací
Mřížka [Druh operace]
Komp. | Identifikace komponenty
Název komponenty | Název komponenty
Operace | Identifikátor druhu operace
 | Název druhu operace
Posun roku | Posun roku v kurzovním lístku
Poznámka | Poznámka

    Mřížka [Druh operace] činnosti - Druhy operací

    Mřížka [Druh operace] činnosti - Druhy operací
Komp. | Identifikace komponenty
Operace | Identifikátor druhu operace
Název druhu operace | Název druhu operace
Posun roku | Posun roku v kurzovním lístku

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druhy operací | Přehled druhů operací
F2 | Komponenty | Číselník komponent

    Atributy tisku

    Základní údaje
Operace | Identifikátor druhu operace | OCKUROPE_sp07idtyp | C(6)
Komponenta | Identifikace komponenty | OCKUROPE_sp06idsubs | C(3)
Název druhu operace | Název druhu operace | SPTYP_sp07text | C(30)
Posun roku | Posun roku v kurzovním lístku | OCKUROPE_oc07posunr | N(4)
Poznámka | Poznámka | OCKUROPE_oc07koment | M

    Viz.také

    Druhy operací | Komponenty


VÝKAZY

Popis

Výkazy představují pro uživatele činnost, kde je vlastní výstup podle nastavených definic prezentován pomocí aplikace MS Excel. ). Výkazy IS BM při své definici umožňují i využití kontingenčních tabulek [1] MS Excel (ověřeno ve verzi MS Excel 2007 – zřejmě jsou funkční i ve starších verzích aplikace MS Excel – zde ale není možno dokonale ověřit).

[1] Upozornění, týkající se využití kontingenčních tabulek:

V případě, že databáze nepoužívá interní kódování textu v kódu 1250, potom se nebude v kontingenčních tabulkách správně zobrazovat diakritika. V tom případě může pomoci nastavení parametru BM: Preferences->ADODBcharset=cp1250, který určuje kódovou stránku, ve které mají být vraceny texty SQL dotazů zpracovávaných prostřednictvím ADO.

Viz.také

VÝKAZY KE SPUŠTĚNÍ | Definice výkazů | Druhy výkazů | Listy výkazů | Formát buňky | Funkce výkazů | Šablony listů výkazů | Vzory listů | Dotazy výkazů


VÝKAZY KE SPUŠTĚNÍ

Popis

Jedná se o skupinovou položku menu, kde jsou k dispozici ke spuštění již nadefinované výkazy pro ty uživatele, kteří mají přístupové právo čtení k danému druhu výkazu.

Datový model

  • VKDRUHV Druh výkazu
    • SPPRISTU Přístupové právo uživatele k věci
    • VKVYKAZ Výkaz

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Definice výkazů

Popis

Definice výkazu je daná výčtem definic jednotlivých listů MS Excel s případným doplněním o inicializační parametry listu a parametry listu v daném výkazu a dále doplněním o nastavení možnosti zpřesnit požadavky uživatele na selekci a agregaci dat či uspořádání výsledků formou dotazu na konkrétní hodnoty proměnných dotazu výkazu, které jsou následně parametry listu, v okamžiku jeho sestavení.

Definicí výkazu zde rozumíme uživatelská nastavení, na základě kterých je sestaven výkaz z aktuálních dat (obvykle z dat uživatele) v okamžiku, kdy si toto sestavení uživatel vyvolá. Jinými slovy je definice výkazů něco jako škatulka výkazu, kde se zadá z čeho se výkaz skládá (kolik listů), jaký je výstupní soubor, použitá šablona apod.

Součástí definice výkazu jsou tyto atributy:

¨ identifikace a název výkazu

¨ druh výkazu - druh výkazu umožňuje definice výkazu členit do určitých skupin. Pro každý druh výkazu (věc s přístupem) lze nastavit přístupová práva, kde čtení = právo vidět a užít definici výkazu pro sestavení výkazu a zápis = právo modifikovat definici výkazu (nejedná se o omezení práva k definici listu – ta se může z hlediska přístupu omezit pouze jako činnost).

Každý druh výkazu, pokud existuje alespoň jedna definice výkazu daného druhu, se stává skupinovou položkou hlavního menu zařazenou pod INFORMAČNÍ CENTRUM – VÝKAZY – VÝKAZY KE SPUŠTĚNÍ, pod kterou jsou uživatelům dostupné definice výkazu pro sestavení relevantních výkazů.

¨ dotaz výkazu - dotaz výkazu je uživatelské nastavení, na základě kterého je v okamžiku sestavení výkazu uživatel v dialogovém okně vyzván k zadání hodnot proměnných dotazu, ze kterých mohou být hodnoty jiných proměnných dotazu vypočteny. Proměnné dotazu jsou dostupné v definici listu či výkazu jako parametry, jejich hodnoty jako skutečné hodnoty parametrů při sestavení výkazu. Definice dotazu se skládá z názvu, pod kterým je dostupný v definici výkazu a který je uveden v nadpisu dialogového okna, designu vstupního formuláře (dialogového okna) a volného textu pro popis.

¨ výstupní soubor výkazu – definice souboru (do kterého bude sestaven výkaz) a jeho adresáře. Soubor lze definovat přímo (např. trzby.xls) nebo výrazem (např. s využitím parametrů ‘urp’+[rok]+[mes]+’.xls’). Programový adresář je implicitní. Při opakovaném sestavení výkazu se nejprve načte již existující výstupní soubor výkazu a jeho listy jsou dle nastavení u šablony smazány nebo přepsány. Pokud je v názvu souboru výkazu obsažen adresář který neexistuje, IS BM jej před vytvořením výkazu založí.

¨ výraz názvu – výraz názvu souboru výkazu (může vypadat např. takto: 'c:\ISBM\vykazy\ucrozps'+[rok]+[mes]+'.xls')

¨ zamykat – příznak, zda zamykat listy výkazu

¨ heslo, pokud je výkaz definován jako uzamčený pro uživatele po sestavení

¨ zobrazovat seznam polí – překryvný seznam s možnostmi Ano/Ne – určuje zda se má ve výkazu zobrazovat seznam polí kontingenčních tabulek (pouze pro Excel 2007, v jiných verzích Excelu se neuplatňuje)

¨ popis výkazu - volný text pro poznámky.

Nezbytnou součástí jsou definice listů výkazů přiřazených k dané definici výkazu s uvedením specifických vlastností každé definice listu v ní, které se provádějí na záložce „Listy výkaz“ a jsou to:

¨ identifikace výkazu – předplněna z předchozí záložky

¨ list – identifikace a vlastní název listu

¨ pořadí – pořadí listu ve výkazu

¨ explicitní název listu

¨ parametry INI – parametry listu ve výkazu – počáteční inicializace (dostupné pro dynamické proměnné)

¨ parametry – parametry definice listu

Upozornění, týkající se využití kontingenčních tabulek:

V případě, že databáze nepoužívá interní kódování textu v kódu 1250, potom se nebude v kontingenčních tabulkách správně zobrazovat diakritika. V tom případě může pomoci nastavení parametru BM: Preferences->ADODBcharset=cp1250, který určuje kódovou stránku, ve které mají být vraceny texty SQL dotazů zpracovávaných prostřednictvím ADO.

Datový model

  • VKVYKAZ Výkaz
    • VKDRUHV Druh výkazu
      • SPPRISTU Přístupové právo uživatele k věci
    • BWUZIVAT Uživatel systému

    • Formulář

    Formulář činnosti - Překlad popisek
Mřížka [Výkazy]
Výkaz | Identifikace výkazu
Název výkazu | Název výkazu
Listovací rámeček
Stránka #1 Výkazy
Druh | Identifikace druhu výkazu
Název druhu výkazu | Název druhu výkazu
Dotaz | Identifikace dotazu
Výstupní soubor výkazu | Výstupní soubor výkazu
Popis výkazu | Popis výkazu
Výraz názvu | Výraz názvu souboru výkazu
Zamykat | Zamykat listy výkazu
Heslo | Heslo pro uzavření výkazu
Zobrazovat seznam polí | Zobrazovat seznam polí kontingenčních tabulek (pouze pro Excel 2007)
Založil | Jméno uživatele systému
Datum a čas zápisu | Datum a čas zápisu záznamu události
Stránka #2 Listy výkazu
Mřížka [Listy výkazu]
List | Identifikace listu
Název listu | Název listu
Poř. | Pořadí listu na výkazu
Explicitní název | Explicitní název listu
Parametry INI | Parametry listu ve výkazu - počáteční inicializace (dostupné pro dynamické proměnné)
Parametry | Parametry listu ve výkazu
Stránka #3 Výběr
Výkaz | Identifikace výkazu
Název výkazu | Název výkazu
Druh | Identifikace druhu výkazu
List | Identifikace listu
Založil | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Výkazy] činnosti - Překlad popisek

    Mřížka [Výkazy] činnosti - Překlad popisek
Výkaz | Identifikace výkazu
Název výkazu | Název výkazu
Druh | Identifikace druhu výkazu

    Mřížka [Listy výkazu] činnosti - Překlad popisek

    Mřížka [Listy výkazu] činnosti - Překlad popisek
Poř. | Pořadí listu na výkazu
List | Identifikace listu
Explicitní název | Explicitní název listu
Název listu | Název listu
Typ listu | Typ listu výkazu
Vzor | Identifikace vzoru listu

    Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Definice listu | Definice listu
F7 | Definice listu podle vzoru | Definice listu podle vzoru
F9 | Spustit výkaz | Spustit výkaz
- | Slovník dat | Práce s daty systému
- | Překlad popisek - název výkazu |
F2 | Dotazy výkazů | Dotazy výkazů
F2 | Druhy výkazů | Druhy výkazů
F2 | Listy výkazů | Listy výkazů

    Atributy tisku

    Základní údaje
Výkaz | Identifikace výkazu | VKVYKAZ_vk01id | C(6)
Druh | Identifikace druhu výkazu | VKVYKAZ_vk02id | C(6)
Název druhu výkazu | Název druhu výkazu | VKDRUHV_vk02nazdru | C(40)
Dotaz | Identifikace dotazu | VKVYKAZ_vk17id | C(6)
Název výkazu | Název výkazu | VKVYKAZ_vk01nazev | C(40)
Výstupní soubor výkazu | Výstupní soubor výkazu | VKVYKAZ_vk01soubor | M
Popis výkazu | Popis výkazu | VKVYKAZ_vk01popis | M
Výraz názvu | Výraz názvu souboru výkazu | VKVYKAZ_vk01vyrsou | M
Datum a čas zápisu | Datum a čas zápisu záznamu události | VKVYKAZ_sp00datzap | T
Zamykat | Zamykat listy výkazu | Výpočet | C(3)
Uživatel | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Zobrazovat seznam polí | Zobrazovat seznam polí kontingenčních tabulek (pouze pro Excel 2007) | Výpočet | C(3)
Param. | Parametry listu | VKLIST_vk03param | M
Název listu | Název listu | VKLIST_vk03nazev | C(40)
Vzor | Identifikace vzoru listu | VKLIST_vk14id | C(6)
Sloupec 10 | Nadpis 1.sloupce | VKLIST_vk03s1naz | M
Sloupec 20 | Nadpis 2.sloupce | VKLIST_vk03s2naz | M
Sloupec 30 | Nadpis 3.sloupce | VKLIST_vk03s3naz | M
Šířka | Šířka 1.sloupce | VKLIST_vk03s1sir | N(3)
Šířka | Šířka 2.sloupce | VKLIST_vk03s2sir | N(3)
Šířka | Šířka 3.sloupce | VKLIST_vk03s3sir | N(3)
Nadpis listu | Nadpis listu | VKLIST_vk03nadpis | M
Formát | Identifikace formátu buňky | VKLIST_vk12id1 | C(6)
Formát | Identifikace formátu buňky | VKLIST_vk12id2 | C(6)
Formát | Identifikace formátu buňky | VKLIST_vk12id3 | C(6)

    Při pohybu v Listy výkazu
List | Identifikace listu | VKVYKLIS_vk03id | C(6)
Poř. | Pořadí listu na výkazu | VKVYKLIS_vk08porad | N(3)
Parametry INI | Parametry listu ve výkazu - počáteční inicializace (dostupné pro dynamické proměnné) | VKVYKLIS_vk08parami | M
Parametry | Parametry listu ve výkazu | VKVYKLIS_vk08param | M
Explicitní název | Explicitní název listu | VKVYKLIS_vk08nazev | C(40)

    Viz.také

    Definice listu | Definice listu podle vzoru | Spustit výkaz | Slovník dat | Překlad popisek | Dotazy výkazů | Druhy výkazů | Listy výkazů


Druhy výkazů

Popis

V této činnosti si uživatel nadefinuje jednotlivé druhy výkazů, které bude následně využívat při sestavení vlastní definice výkazu. U každého druhu výkazu se definuje identifikace, jeho popis a libovolná poznámka. Přístup k jednotlivým druhům výkazů je řízen přístupovými právy, které lze u každého druhu výkazu nastavit po stisku Ctrl B nebo aktivací činnosti pod menu Volby.

Datový model

  • VKDRUHV Druh výkazu
    • BWUZIVAT Uživatel systému
    • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Druhy výkazů]
Druh | Identifikace druhu výkazu
Název druhu výkazu | Název druhu výkazu
Poznámka | Poznámka k druhu výkazu
Založil | Jméno uživatele systému
Datum a čas zápisu | Datum a čas zápisu záznamu události

    Mřížka [Druhy výkazů] činnosti - Přístupová práva

    Mřížka [Druhy výkazů] činnosti - Přístupová práva
Druh | Identifikace druhu výkazu
Název druhu výkazu | Název druhu výkazu
Uživatel | Jméno uživatele systému
Datum a čas zápisu | Datum a čas zápisu záznamu události

    Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci

    Atributy tisku

    Základní údaje
Druh | Identifikace druhu výkazu | VKDRUHV_vk02id | C(6)
Název druhu výkazu | Název druhu výkazu | VKDRUHV_vk02nazdru | C(40)
Poznámka | Poznámka k druhu výkazu | VKDRUHV_vk02koment | M
Datum a čas zápisu | Datum a čas zápisu záznamu události | VKDRUHV_sp00datzap | T
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)

    Viz.také

    Přístupová práva


Listy výkazů

Popis

Definice listu výkazu je soubor pravidel, která definují způsob naplnění výsledných informací z jednotlivých tabulek ISBM a která dále definují způsob uspořádání výsledných informací do řádků, sloupců a buněk listu sešitu MS Excel s cílem jejich prezentace uživateli.

V IS BM jsou k dispozici dvě metody pro uživatelské nastavení definice listu výkazů a to metoda přímá nebo metoda s použitím vzoru listů výkazu. Přímá metoda může využívat v jednotlivých elementech (sloupec, řádek, buňka) definice listu přímo funkce výkazu k referenci do zdrojových tabulek IS BM. Pro zajištění korespondence mezi definicí listu a budoucím listem MS Excel je ve fázi sestavení k dispozici navigační „List“, který zahrnuje uspořádání všech definovaných buněk. Metoda s použitím vzoru listu výkazu využívá k referenci do zdrojových tabulek funkce výkazu zprostředkovaně přes výrazy vzoru (ukazatele), které jsou pomocí nich uživatelsky definovány. Tato logická vrstva (ukazatele) umožňuje a usnadňuje laickou definici výkazu. Současně je při použití této metody předdefinována základní struktura výkazu. Z takto uskutečněné definice listu pomocí vzoru vygeneruje IS BM standardní definici listu, která je následně k dispozici pouze pro prohlížení. Jedna definice listu může být užita v několika definicích výkazů.

Ve výkazech IS BM je možno definovat i listy, které obsahují kontingenční tabulky [1]. Pro účely této definice je činnost „Listy výkazů“ rozdělena do čtyř záložek, které si v dalším textu podrobně popíšeme:

¨ Listy výkazů – kde se vstupují základní informace o listu (společná záložka pro běžné i kontingenční typy listů)

¨ Běžný list – zde se vstupují atributy běžných typů listů výkazů

¨ Kontingenční list – zde se vstupují atributy kontingečních typů listů výkazů

¨ Pole kontingenčního výkazu – zde se vstupují vlastnosti jednotlivých polí vytvářené kontingenční tabulky

Záložka „Listy výkazů“:

Jedna definice listu může být přiřazena do několika definic výkazu. Definice listu výkazu obsahuje tyto atributy:

¨ identifikace a název listu

¨ šablona – identifikace šablony, která ovlivňuje uspořádání dat prezentovaných listem MS Excel. Současně definuje počáteční řádek a sloupec, se kterými koresponduje definice prvního řádku a sloupce v definici listu, a dále údaj, zda se při sestavování výkazu má nejprve existující list výstupního souboru (sešit MS Excel) zrušit. Obvykle se v rámci souboru šablony definuje grafika výkazu, pojmenované texty a buňky, jimž mohou být následně přiřazovány hodnoty v definici výkazu a následně při sestavení výkazu.

¨ vzor, pokud je list definován pomocí něj (následně funkční klávesa F7 nebo aktivace příslušné činnosti z menu Volby)

¨ typ listu – překryvný seznam s možnostmi výběru běžný/kontingenční

¨ parametry listu – jsou uživatelem definované parametry, které se užívají v definici výkazu, resp. listu, pro její usnadnění nebo s cílem zajištění určité variability obsahu výkazu dle požadavků uživatele při sestavení výkazu

¨ poznámka – vlastní poznámka k danému listu výkazu

Záložka „Běžný list“:

¨ implicitní název listu

¨ pohled – identifikace pohledu slovníku dat (v současné době nevyužívaný atribut)

¨ Where – doplněk dotazu Where pohledu slovníku dat (v současné době nevyužívaný atribut)

¨ předloha – identifikace předlohy pro výstup (v současné době nevyužívaný atribut)

¨ implicitní formát buněk – identifikace a název implicitního formátu buněk listu

¨ deklarace - dodatečné deklarace umožňují příkazem LOCK zamknout zdrojová data uvedených komponent (např. LOCK UCE zabrání zápisu událostí účetnictví po dobu sestavení výkazu, což vede na zajištění integrity zobrazených informací ve výkazu) a dále umožňují formulovat podmínky, při jejichž nesplnění nebude uvedený sloupec nebo řádek definice listu zařazen do listu sestaveného výkazu (např. $S(80) [rok]='2000' definuje, že sloupec s identifikací 80 v definici listu bude do výkazu při jeho sestavení zařazen pouze tehdy, je-li hodnota parametru rok dva tisíce; podobně pro řádek $R(80) [rok]='2000').

¨ kód – skript v jazyce Foxpro. Tento skript musí začínat slovem SCRIPT. Má-li funkce definované parametry, jsou tyto v programu skriptu dostupné jako proměnné identifikované _par_ + název parametru.

Funkce typu seznam musí vytvářet kurzor s aliasem _WORK, ostatní musí vracet požadovanou hodnotu příkazem RETURN.

Příklad skriptu :

SCRIPT

LOCAL _navrat

_navrat=tool.sql_dotaz([select sum(uc03ksvyk*(if
ucrozvrh.uc01strana=1 then 1 else -1 endif)) from %%%.ucobrtab,%%%.ucrozvrh where uc01id like
?_p1  ]+;

[and uc03mesic=?_p2 and uc03rok=?_p3 and uc03druh=?_p4 and uc03faze=2 ]+;

[and oc01id='CZK' and ucobrtab.uc01id=ucrozvrh.uc01id],_par_ucet,_par_mesd,_par_rokd,_par_druh)

_navrat=_navrat+563

RETURN _navrat

V případě užití přímé metody pro nastavení definice listu (aktivace činnosti v menu Volby nebo klávesa F6) uživatel za pomoci navigačního listu definuje přímo jednotlivé sloupce, řádky a buňky definice listu.

V případě užití metody pro nastavení definice listu pomocí vzoru (aktivace činnosti v menu Volby nebo klávesa F7) uživatel definuje jednotlivé sloupce, řádky a buňky definice listu zprostředkovaně pomocí dříve připraveného vzoru listu s tím, že možnosti i složitost nastavení jsou oproti metodě přímé omezeny.

Záložka „Kontingenční list“:

Na této záložce se vstupuje atribut SQL, vztahující se ke kontingenčnímu typu listu výkazu. Tento textový atribut obsahuje SQL dotaz, který je zdrojem dat pro vytvářenou kontingenční tabulku. V SQL dotazu se mohou uplatnit proměnné listu výkazu uvedené v hranatých závorkách.

Záložka „Pole kontingenčního listu“:

- zde se vstupuje seznam polí vytvářené kontingenční tabulky. Pro každé pole se definuje:

¨ název pole - musí korespondovat s názvem atributu vytvářeným SQL dotazem (musí být exaktně totožný, tj. včetně diakritiky a velkých a malých písmen)

¨ pořadí – uvedené číslo vyjadřuje pořadí zpracování pole při vytváření kontingenční tabulky

¨ oblast - překryvný seznam s možnostmi Žádná/Filtr sestavy/Popisky sloupců/Popisky řádků/Hodnoty - určuje oblast kontingenční tabulky, ve které se má pole uplatnit

¨ určení oblasti výrazem - tento atribut je určen pro uvedení proměnné výkazu tak, aby při použití list v konkrétním výkazu bylo možné měnit umístění jednotlivých polí a uplatní se pouze v případě, že výraz představuje numerickou hodnotu v intervalu 1-5

¨ filtr sestavy - uplatní se pro pole v oblasti 'Filtr sestavy' a uplatní se pouze v případě, že hodnota výrazu odpovídá některé z hodnot pole v kontingenční tabulce

¨ výběr popisků - uplatní se pro pole v oblasti 'Filtr sestavy', 'Popisky sloupců' nebo 'Popisky řádků' - výraz musí obsahovat textový literál, který obsahuje výraz vyhodnocovaný v okamžiku vytváření kontingenční tabulky - tento výraz přitom obvykle pracuje s proměnnou _PIVOTITEM (objekt položky pole), nejčastěji s jeho vlastností _PIVOTITEM.VALUE

¨ zobrazení podpopisků - uplatní se pro pole v oblasti 'Popisky sloupců' nebo 'Popisky řádků' - výraz musí obsahovat textový literál, který obsahuje výraz vyhodnocovaný v okamžiku vytváření kontingenční tabulky - tento výraz přitom obvykle pracuje s proměnnou _PIVOTITEM (objekt položky pole) nejčastěji s jeho vlastností _PIVOTITEM.VALUE

¨ formát čísla - uplatní se pro pole v oblasti 'Hodnoty' (např. #,##0.00)

¨ skript - skript v jazyce FoxPro provedený po zpracování daného pole (kódu jsou přitom k dispozici objekty - v proměnné _PIVOTFIELD objekt pole kontingenční tabulky a v proměnné _PIVOTTABLE objekt kontingenční tabulky)

¨ poznámka – libovolný text k jednotlivým polím kont. listu

Poznámka – zaokrouhlování:

Pro vytvoření běžného listu výkazu, ve kterém mají být hodnoty zobrazovány zaokrouhleny na celá čísla, tisíce, milióny nebo miliardy je možné definovat proměnnou výkazu ZAOKROUHLI. Nabývá-li tato proměnná v okamžiku výpočtu výkazu hodnot 2 nebo 3 nebo 4 nebo 5, potom hodnoty, které mají ve svém sloupci nastavenu vlastnost Zaokrouhlovat=Ano nebudou zobrazovány v Excelu formátem buňky podle vlastnosti 'Formát čísel' , ale podle vlastnosti 'Formát zaokr.' (není-li vyplněn formátem #,##0) doplněným podle požadovaného zaokrouhlení.

V případě, že proměnná ZAOKROUHLI nabývá hodnotu:

2 - hodnoty budou zobrazovány zaokrouhlené na celá čísla - obvykle formátem #,##0

3 - hodnoty budou zobrazovány zaokrouhlené na tisíce - obvykle formátem #,##0,

4 - hodnoty budou zobrazovány zaokrouhlené na milióny - obvykle formátem #,##0,,

5 - hodnoty budou zobrazovány zaokrouhlené na miliardy - obvykle formátem #,##0,,,

Pokud se má způsob zaokrouhlování týkat všech listů výkazu, potom je vhodné definovat proměnnou ZAOKROUHLI v dotazu výkazu např.:

¨ Proměnná - ZAOKROUHLI

¨ Typ - Numerická

¨ Návěští - Zaokrouhlit

¨ Naplnění - Vstup

¨ Inicializace - 1

¨ Třída - Překryvný seznam - Ne,Koruny,Tisíce,Milióny

Pozn.:

Listy výkazů definovaných podle vzoru mohou obsahovat sloupce, které nemají být zobrazovány zaokrouhleně (např. čísla řádků účetní výsledovky, ....). Nastavení vlastnosti Zaokrouhlovat=Ne pro tyto sloupce je možné postupem:

1. zapamatujte si obsah vlastnost listu - Vzor

2. nastavte vlastnost listu Vzor = -

3. vyvolejte opravu listu klávesou F6

4. nastavte vlastnost daného sloupce Zaokrouhlovat=Ne

5. obnovte vlastnost listu - Vzor

Upozornění pro uživatele:

V některých nastaveních u klientů může při opravě nebo spuštění listů výkazů nastat situace, že systém ohlásí chybovou hlášku typu: „Kód chyby OLE „číslo“. Třída není zaregistrována. Objekt OLE je ignorován. Po stisku OK potom následuje další chybová hláška typu „Neznámý člen MUJGRID“.

Systém upozorňuje, že v systému uživatele chybí knihovna, která je pro tento list výkazu nutná. Další postup pro odstranění této chybové hlášky je následující:

¨ z FTP firmy BM Servis je nutno stáhnout příslušnou knihovnu. Knihovna je v sekci ftp://bmftp@mail.bmservis.cz/Pro zakazniky/ISBM_neco_nechodi/GRID32.OCX

¨ aktivovat na PC příkazový řádek a jako správce do něj zapsat příkaz CMD (hlavní menu – programy – příslušenství – příkazový řádek)

¨ aktivuje se černé příkazové okno a tam je nutno ručně vepsat příkaz pro registraci knihovny GRID32 „regsvr32 k:\bmsql\grid32.ocx“ (jméno disku se samozřejmě musí napsat takové, na jakém má uživatel nainstalován IS BM)

Tímto krokem se dá laicky říct, že dojde ke spojení výkazů s příslušnou knihovnou GRID32 a další práce s listy výkazů je již bez problémů.

[1] Uživatelský příklad definice kontingenční tabulky je k dispozici u pojmu „kontingenční tabulky“ (slovník pojmů). Je podrobně popsán příklad kontingenční tabulky, která využívá ke svému naplnění data z komponenty účetnictví z činnosti obratová tabulka.

Datový model

  • VKLIST List výkazu
    • VKSABLON Šablona listu výkazu
    • VKFORMAT Formát buňky ve výkazu
    • VKVZOR Vzor listu

    • Formulář

    Formulář činnosti - Formát buňky
Mřížka [Listy výkazů]
List | Identifikace listu
Název listu | Název listu
Listovací rámeček
Stránka #1 Listy výkazů
Šablona | Identifikace šablony listu dokumentu
Název šablony | Název šablony
Vzor | Identifikace vzoru listu
Název vzoru | Název vzoru listu
Typ listu | Typ listu výkazu
Param. | Parametry listu
Poznámka | Poznámka
Stránka #2 Běžný list
Pohled | Identifikace pohledu slovníku dat
Where | Doplněk dotazu WHERE pohledu slovníku dat
Předloha | Identifikace předlohy pro výstup
Formát | Identifikace formátu buňky
Název formátu | Název formátu buňky
Deklarace | Podmínky pro zařazení sloupců do listu, rezervace zdrojů systému
Kód | Kód v jazyce Foxpro provedený po vytvoření výkazu
Stránka #3 Kontingenční list
SQL | SQL dotaz pro kontingenční tabulku
Stránka #4 Pole kontingenčního listu
Mřížka [Pole kontingenčního listu]
Pole | Název pole kontingenční tabulky
Pořadí | Pořadí zpracování pole kontingenční tabulky
Oblast | Oblast umístění pole
Určení oblasti výrazem | Výraz pro určení umístění pole v oblasti (hodnota)
Filtr sestavy | Výraz pro určení hodnoty filtru sestavy (hodnota)
Výběr popisků | Výraz pro výběr popisků (makro)
Zobrazení podpopisků | Výraz zobrazení podřízených popisků (makro)
Formát čísla | Formát čísla
Skript | Skript v jazyce Foxpro spuštěný pro pole kontingenční tabulky
Poznámka | Poznámka
Stránka #5 Výběr
List | Identifikace listu
Název listu | Název listu
Typ listu | Typ listu výkazu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Listy výkazů] činnosti - Formát buňky

    Mřížka [Listy výkazů] činnosti - Formát buňky
List | Identifikace listu
Název listu | Název listu

    Mřížka [Pole kontingenčního listu] činnosti - Formát buňky

    Mřížka [Pole kontingenčního listu] činnosti - Formát buňky
Pole | Název pole kontingenční tabulky
Oblast | Oblast umístění pole
Pořadí | Pořadí zpracování pole kontingenční tabulky

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Editovat kód vlastnosti | Editovat kód vlastnosti
F6 | Definice listu | Definice listu
F7 | Definice listu podle vzoru | Definice listu podle vzoru
- | Slovník dat | Práce s daty systému
- | Kopie listu výkazu | Kopie listu výkazu
- | Kontrolní kompilace | Kontrolní kompilace
- | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností
F2 | Formát buňky | Formát buňky
F2 | Vzory listů | Vzory listů
F2 | Šablony listů výkazů | Šablony listů výkazů

    Atributy tisku

    Základní údaje
List | Identifikace listu | VKLIST_vk03id | C(6)
Název listu | Název listu | VKLIST_vk03nazev | C(40)
Vzor | Identifikace vzoru listu | VKLIST_vk14id | C(6)
Název vzoru | Název vzoru listu | VKVZOR_vk14nazev | C(40)
Šablona | Identifikace šablony listu dokumentu | VKLIST_vk13id | C(6)
Název šablony | Název šablony | VKSABLON_vk13nazev | C(40)
Typ listu | Typ listu výkazu | Výpočet | C(12)
Soubor šablony | Soubor šablony | VKSABLON_vk13soubor | M
Formát | Identifikace formátu buňky | VKLIST_vk12id | C(6)
Název formátu | Název formátu buňky | VKFORMAT_vk12nazev | C(40)
Tučný | Tučný text | Výpočet | C(3)
Kurzíva | Text kurzívou | Výpočet | C(3)
Ohraničení | Ohraničení | Výpočet | C(5)
Barva | Barva zobrazení | VKFORMAT_vk12barva | N(2)
Poznámka | Poznámka | VKFORMAT_vk12koment | M
Formát čísel | Formát číselných hodnot | VKFORMAT_vk12numfor | C(20)
Param. | Parametry listu | VKLIST_vk03param | M
Dodatečné deklarace | Podmínky pro zařazení sloupců do listu, rezervace zdrojů systému | VKLIST_vk03pdmslp | M
Kód | Kód v jazyce Foxpro provedený po vytvoření výkazu | VKLIST_vk03kod | M
Poznámka | Poznámka | VKLIST_vk03koment | M
SQL | SQL dotaz pro kontingenční tabulku | VKLIST_vk03ktsql | M

    Při pohybu v Pole kontingenční tabulky
Pole | Název pole kontingenční tabulky | VKKTPOLE_vk20id | C(40)
Pořadí | Pořadí zpracování pole kontingenční tabulky | VKKTPOLE_vk20porad | N(3)
Oblast | Oblast umístění pole | Výpočet | C(15)
Určení oblasti výrazem | Výraz pro určení umístění pole v oblasti (hodnota) | VKKTPOLE_vk20vyrobl | M
Formát čísla | Formát čísla | VKKTPOLE_vk20numfor | C(20)
Filtr sestavy | Výraz pro určení hodnoty filtru sestavy (hodnota) | VKKTPOLE_vk20fsest | M
Výběr popisků | Výraz pro výběr popisků (makro) | VKKTPOLE_vk20vyrvis | M
Zobrazení podpopisků | Výraz zobrazení podřízených popisků (makro) | VKKTPOLE_vk20vyrdet | M
Skript | Skript v jazyce Foxpro spuštěný pro pole kontingenční tabulky | VKKTPOLE_vk20script | M
Poznámka | Poznámka | VKKTPOLE_vk20koment | M

    Viz.také

    Editovat kód vlastnosti | Definice listu | Definice listu podle vzoru | Slovník dat | Kopie listu výkazu | Kontrolní kompilace | Knihovny vkládaného kódu | Formát buňky | Vzory listů | Šablony listů výkazů


Formát buňky

Popis

Formát buňky je pravidlo, které po aplikaci v definici listu pro danou buňku definuje, jak bude relevantní buňka výkazu formátována při sestavení výkazu. Formát umožňuje předdefinovat písmo, formát čísla a ohraničení buňky.

V případě, že je formát buňky uveden v definici listu, sloupce, řádku má implicitní charakter pro všechny obsažené buňky.

Atribut formát zaokrouhlení je popsán v helpu u definice listu nebo jako pojem ve slovníku pojmů.

Datový model

  • VKFORMAT Formát buňky ve výkazu

    • Formulář

    Formulář činnosti - Formát buňky
Mřížka [Formáty]
Formát | Identifikace formátu buňky
Název formátu | Název formátu buňky
Font | Název fontu
Velikost | Velikost písma
Tučný | Tučný text
Kurzíva | Text kurzívou
Formát čísel | Formát číselných hodnot
Formát zaokr. | Formát zaokrohlených číselných hodnot
Barva | Barva zobrazení
Levé ohraničení | Levé ohraničení
Pravé ohraničení | Pravé ohraničení
Horní ohraničení | Horní ohraničení
Dolní ohraničení | Dolní ohraničení
Poznámka | Poznámka

    Mřížka [Formáty] činnosti - Formát buňky

    Mřížka [Formáty] činnosti - Formát buňky
Formát | Identifikace formátu buňky
Název formátu | Název formátu buňky

    Atributy tisku

    Základní údaje
Formát | Identifikace formátu buňky | VKFORMAT_vk12id | C(6)
Název formátu | Název formátu buňky | VKFORMAT_vk12nazev | C(40)
Velikost | Velikost písma | VKFORMAT_vk12fonts | N(2)
Tučný | Tučný text | Výpočet | C(3)
Kurzíva | Text kurzívou | Výpočet | C(3)
Ohraničení | Ohraničení | Výpočet | C(5)
Barva | Barva zobrazení | VKFORMAT_vk12barva | N(2)
Poznámka | Poznámka | VKFORMAT_vk12koment | M
Formát čísel | Formát číselných hodnot | VKFORMAT_vk12numfor | C(20)
Formát zaokrouhlených | Formát zaokrohlených číselných hodnot | VKFORMAT_vk12numzao | C(20)
Levé ohraničení | Levé ohraničení | Výpočet | C(3)
Pravé ohraničení | Pravé ohraničení | Výpočet | C(3)
Horní ohraničení | Horní ohraničení | Výpočet | C(3)
Dolní ohraničení | Dolní ohraničení | Výpočet | C(3)


Funkce výkazů

Popis

Funkce výkazu jsou uživatelsky definovatelné funkce, které po svém volání při sestavení výkazu vracejí hodnotu některého z těchto typů: Numerická, Znaková, Datumová nebo Seznam hodnot.

Způsob výpočtu hodnoty je uživatelsky formulován pomocí programového kódu funkce. Variabilitu použití jedné funkce lze zajistit pomocí parametrů funkce, pak i při definici výrazu, ze kterého je volána daná funkce, se uvede funkce s parametry.

Součástí definice funkce výkazu je typ vracené hodnoty, template volání funkce (např.: [selor],[seltv],[selob]), tj. jak IS předplní volání funkce v sestavovaném výrazu po jejím výběru a přenesení (F2 – CTRL Enter) z jejich seznamu, programový kód a strukturu parametrů funkce.

Založení nové funkce výkazu uživatelem je autorizováno.

Kód funkce výkazu je programový kód, ve kterém je napsána funkce výkazu obvykle s cílem získání hodnot, údajů či informací ze zdrojových dat (tabulky IS BM).

Vychází z jazyka FoxPro a jazyka SQL databázového serveru (jednoduché příkazy v syntaxi FOXPRO, příkazy IF a ENDIF a příkaz SET, který provádí SQL dotaz). Parametry funkce, pokud jsou v kódu použity, se uvádějí v syntaxi ?_par_ppp a v syntaxi &_par_ppp pro parametry typu Seznam hodnot nebo Makro, kde ppp je identifikátor parametru uvedený v jejich seznamu na záložce parametry funkce (například: selor).

Uvedení parametru typu Seznam hodnot je automaticky transformováno, například: Kód SET SELECT SUM(sp71prijem) FROM %%%.SPSTATIS WHERE _par_selor AND … bude transformován, pokud při volání funkce platí selor='112%;1135_[^5]%;2%' a v definici parametru [selor] je uveden atribut SPSTATIS. sp11idzak , takto SET SELECT SUM(sp71prijem) FROM %%%.SPSTATIS WHERE (SPSTATIS. sp11idzak LIKE ‘112%‘ OR SPSTATIS. sp11idzak LIKE ‘1135_[^5]%‘ OR SPSTATIS. sp11idzak LIKE ‘2%‘) and ….

Parametr typu Makro je v kódu nahrazen textovým řetězcem, který skutečný parametr obsahuje v okamžiku volání funkce výkazu.

Datový model

  • VKFCE Funkce pro výkazy
    • BWUZIVAT Uživatel systému

    • Formulář

    Formulář činnosti - Formát buňky
Mřížka [Funkce]
Funkce | Identifikátor funkce
Název funkce | Název funkce
Listovací rámeček
Stránka #1 Funkce
Typ | Typ hodnoty funkce
Kód | Kód funkce
Template | Template funkce
Založil | Jméno uživatele systému
Datum a čas zápisu | Datum a čas zápisu záznamu události
Aktualizace | Datum aktualizace
Poznámka | Poznámka
Stránka #2 Parametry funkce
Mřížka [Parametry funkce]
Pořadí | Pořadí parametru
Parametr | Název parametru
Popis parametru | Popis parametru
Typ | Typ parametru
Atribut | Název atributu pro seznam
Délka hodnoty | Délka hodnoty atributu pro seznam
Poznámka | Poznámka

    Mřížka [Funkce] činnosti - Formát buňky

    Mřížka [Funkce] činnosti - Formát buňky
Funkce | Identifikátor funkce
Název funkce | Název funkce
Typ | Typ hodnoty funkce

    Mřížka [Parametry funkce] činnosti - Formát buňky

    Mřížka [Parametry funkce] činnosti - Formát buňky
Pořadí | Pořadí parametru
Parametr | Název parametru
Popis parametru | Popis parametru
Typ | Typ parametru


Šablony listů výkazů

Popis

Šablona listů výkazů definuje soubor se šablonou pro list MS Excel, která se uplatní při sestavení výkazu, a jeho adresář (např.: template\Statvy.xlt). Implicitní je programový adresář.

Na atributu „soubor šablony“ lze klávesou F2 vyvolat vstup, kterým se provede zápis kopie souboru šablony do databáze. Kopie obsahu souboru šablony je ukládána v databázi ve formátu ZIP a přitom se používá knihovna VFPCOMPRESSION.FLL, která je obvykle uložena v adresáři PRGS (při neexistenci knihovny VFPCOMPRESSION.FLL nejsou kopie souborů šablony ukládány). Kopie jednoho souboru se stejným názvem je v databázi uložena pouze jedenkrát a při změně názvu souboru je kopie souboru v databázi automaticky zrušena v případě, kdy se jedná o soubor, který není uveden jako příloha některé předlohy výstupu nebo jako soubor jiné šablony.

Ve formuláři se zobrazuje datum a čas kopie souboru, která je uložena v databázi. Při zápisu dat formuláře se porovnává tento datum a čas s datem a časem souboru, který uložen na disku a v případě, že se nerovnají (+- 2 vteřiny),

je nabídnuta možnost zápisu kopie obsahu souboru do databáze.

Při spuštění výkazu, je prováděna kontrola toho, zda všechny jeho šablony na disku existují a v případě, že neexistují jsou „vybaleny“ jejich kopie z databáze. Provádí se pouze kontrola existence souboru, vůbec se neporovnává datum a čas souboru (tj. nedochází k přepisu souboru na disku ani v případě, že je starší než jeho kopie v databázi).

Podmínkou pro tuto funkci je existence knihovny VFPCOMPRESSION.FLL, pokud není tato knihovna nainstalována, potom se při spuštění nebo opravě předlohy výstupu objeví hlášení „Výkaz obsahuje soubory šablon, které není možné vybalit, protože nemáte nainstalovanou knihovnu VFPCOMPRESSION.FLL“.

Při exportu definice výkazu do balíčku, jsou exportovány také jeho šablony včetně kopie obsahu souboru šablony.

Import balíčku nikdy nepřepisuje kopii souboru šablony v databázi a ani neprovádí její „vybalení“ do souboru na disku (to se provede až při prvním spuštění výkazu).

Knihovna VFPCOMPRESSION.FLL požaduje pro svou funkci ve Windows starších než Vista existenci souborů C:\WINDOWS\SYSTEM32\MSVCP71.DLL a C:\WINDOWS\SYSTEM32\MSVCR71.DLL.

Dále definuje počáteční řádek a sloupec, se kterými koresponduje definice prvního řádku a sloupce v definici listu, a údaj, zda se při sestavování výkazu má nejprve existující list zrušit.

Atributem šablony „vymazat list – Ano/Ne“ je možno nastavit, zda se má obsah listu výkazu v Excelu před jeho vytvářením vymazat, tzn. následný vytvořený výkaz bude přesně korespondovat s nadefinovanou šablonou (řádky, sloupce, velikost tabulky apod.).

Obvykle se v rámci souboru šablony definuje grafika výkazu, pojmenované texty a buňky, jimž mohou být následně přiřazovány hodnoty v definici výkazu a následně při sestavení výkazu.

Pod menu Volby má uživatel k dispozici možnost si vyvolat přímou Editaci šablony.

Datový model

  • VKSABLON Šablona listu výkazu

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Soubor šablony | Soubor šablony

    Formulář

    Formulář činnosti - Soubor šablony
Mřížka [Šablony listů]
Šablona | Identifikace šablony listu dokumentu
Název šablony | Název šablony
Soubor šablony | Soubor šablony
Počáteční řádek | Počáteční řádek výstupu listu
Počáteční sloupec | Počáteční sloupec výstupu listu
Zrušit existující list | Zrušit existující list před založením nového listu
Vymazat list | Vymazat obsah listu při založení listu
Poznámka | Poznámka

    Mřížka [Šablony listů] činnosti - Soubor šablony

    Mřížka [Šablony listů] činnosti - Soubor šablony
Šablona | Identifikace šablony listu dokumentu
Název šablony | Název šablony
Zrušit existující list | Zrušit existující list před založením nového listu
Vymazat list | Vymazat obsah listu při založení listu

    Atributy tisku

    Základní údaje
Šablona | Identifikace šablony listu dokumentu | VKSABLON_vk13id | C(6)
Název šablony | Název šablony | VKSABLON_vk13nazev | C(40)
Počáteční řádek | Počáteční řádek výstupu listu | VKSABLON_vk13strrow | N(4)
Počáteční sloupec | Počáteční sloupec výstupu listu | VKSABLON_vk13strcol | N(4)
Zrušit existující list | Zrušit existující list před založením nového listu | Výpočet | C(3)
Poznámka | Poznámka | VKSABLON_vk13koment | M
Soubor šablony | Soubor šablony | VKSABLON_vk13soubor | M

    Viz.také

    Soubor šablony


Vzory listů

Popis

Vzor listů výkazů je uživatelsky připravená „šablona“, která uživateli usnadní nastavení definice listu. Každý vzor je opakovaně použitelný pro více listů, které jsou si svou strukturou a obsahem podobné, například přípravu všech definic listů účetních výkazů lze usnadnit jediným vzorem.

Příprava vzoru zahrnuje definici jeho identifikace, která se případně uvádí v definici listu, název, atribut parametry a případnou pevné uživatelem při aplikaci vzoru již neovlivnitelné nastavení prvních tří sloupců definice listu. Uvedené nastavení sloupce spočívá v uvedení jeho názvu (budoucí nadpis), definice obsahu výrazem, formátu a šířky. Příprava vzoru dále zahrnuje definici výrazů daného vzoru.

Datový model

  • VKVZOR Vzor listu

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Funkce výkazů | Funkce výkazů

    Formulář

    Formulář činnosti - Funkce výkazů
Mřížka [Vzory]
Vzor | Identifikace vzoru listu
Název vzoru | Název vzoru listu
Listovací rámeček
Stránka #1 Vzory
1.sloupec | Návěští 1.sloupce ve tvaru výrazu
Výraz | Výraz 1.sloupce
Formát | Identifikace formátu buňky
 | Šířka sloupce
2.sloupec | Návěští 2.sloupce ve tvaru výrazu
Výraz | Výraz 2.sloupce
Formát | Identifikace formátu buňky
 | Šířka sloupce
3.sloupec | Návěští 3.sloupce ve tvaru výrazu
Výraz | Výraz 3.sloupce
Formát | Identifikace formátu buňky
 | Šířka sloupce
Parametry | Parametry vzoru listu
Poznámka | Poznámka
Stránka #2 Výrazy vzoru
Mřížka [Výrazy vzoru]
Pořadí | Pořadí výrazu
Popis výrazu | Popis výrazu
Výraz | Výraz
Poznámka | Poznámka
1.p. | 1.parametr výrazu vzoru listu
Typ | Typ 1.parametru výrazu vzoru listu
Délka | Délka hodnoty 1.parametru vzoru listu
Náv. | Návěští 1.parametru vzoru listu
Def. | Implicitní hodnota 1.parametru vzoru listu
2.p. | 2.parametr výrazu vzoru listu
Typ | Typ 2.parametru výrazu vzoru listu
Délka | Délka hodnoty 2.parametru vzoru listu
Náv. | Návěští 2.parametru vzoru listu
Def. | Implicitní hodnota 2.parametru vzoru listu
3.p. | 3.parametr výrazu vzoru listu
Typ | Typ 3.parametru výrazu vzoru listu
Délka | Délka hodnoty 3.parametru vzoru listu
Náv. | Návěští 3.parametru vzoru listu
Def. | Implicitní hodnota 3.parametru vzoru listu
4.p. | 4.parametr výrazu vzoru listu
Typ | Typ 4.parametru výrazu vzoru listu
Délka | Délka hodnoty 4.parametru vzoru listu
Náv. | Návěští 4.parametru vzoru listu
Def. | Implicitní hodnota 4.parametru vzoru listu
5.p. | 5.parametr výrazu vzoru listu
Typ | Typ 5.parametru výrazu vzoru listu
Délka | Délka hodnoty 5.parametru vzoru listu
Náv. | Návěští 5.parametru vzoru listu
Def. | Implicitní hodnota 5.parametru vzoru listu

    Mřížka [Vzory] činnosti - Funkce výkazů

    Mřížka [Vzory] činnosti - Funkce výkazů
Vzor | Identifikace vzoru listu
Název vzoru | Název vzoru listu

    Mřížka [Výrazy vzoru] činnosti - Funkce výkazů

    Mřížka [Výrazy vzoru] činnosti - Funkce výkazů
Vzor | Identifikace vzoru listu
Pořadí | Pořadí výrazu
Popis výrazu | Popis výrazu

    Viz.také

    Funkce výkazů


Dotazy výkazů

Popis

Dotaz výkazu je uživatelské nastavení, na základě kterého je v okamžiku sestavení výkazu uživatel v dialogovém okně vyzván k zadání hodnot proměnných dotazu, ze kterých mohou být hodnoty jiných proměnných dotazu vypočteny.

Proměnné dotazu jsou dostupné v definici listu či výkazu jako parametry, jejich hodnoty jako skutečné hodnoty parametrů při sestavení výkazu. Definice dotazu se skládá z názvu, pod kterým je dostupný v definici výkazu a který je uveden v nadpisu dialogového okna, designu vstupního formuláře (dialogového okna) a volného textu pro popis.

Při úpravě vzhledu formulářů v činnostech, ve kterých definuje implementátor vstupní formulář (volné karty, obecné výběry, šablony, importy/exporty dat, dotazy výkazů), je možné po pravém kliku klávesou myši na atributu určit jeho rozměry. Lze definovat šířku atributů třídy textové pole, překryvný seznam a u atributů typu textové, multimediální, makro je možné navíc definovat jejich výšku.

Proměnná dotazu je (podobně jako proměnná výběru) uživatelsky definovaná proměnná, která je parametrem použitelným v definici výkazu i jeho prvků a po nabytí hodnoty při sestavení výkazu. Použitelné typy proměnných jsou N, C, D a T.

V případě definice jejího naplnění vstupem je možné uvést její implicitní hodnotu výrazem a umístit ji v rámci designu vstupního formuláře. V případě definice jejího naplnění výpočtem je nutné uvést výpočtový výraz, ve kterém lze užít proměnné naplněné vstupem v syntaxi [promvst]. Proměnné jsou současně parametry výkazu s identifikátorem shodným s názvem proměnné.

Datový model

  • VKDOTAZ Vstupní dotaz spuštěného výkazu

    • Formulář

    Formulář činnosti - Překlad popisek
Mřížka [Dotazy výkazů]
Dotaz | Identifikace dotazu
Název dotazu | Název dotazu
Listovací rámeček
Stránka #1 Dotazy výkazů
Kód | Kód provedený po vstupu dotazu
Poznámka | Poznámka
Stránka #2 Proměnné dotazu
Mřížka [Proměnné dotazu]
Proměnná | Číslo proměnné definice výkazu
 | Název proměnné výkazu
Typ | Typ proměnné výkazu
 | Délka proměnné výkazu
 | Počet desetin proměnné výkazu
Návěští | Návěští proměnné výkazu
Naplnění | Způsob naplnění proměnné - vstupem nebo výpočtem
Výraz | Výraz proměnné výkazu
Inicializace | Inicializační hodnota proměnné výkazu
Třída | Třída ovládacího prvku
Hodnoty | Text pro zaškrtávací políčko nebo seznam hodnot pro překryvný seznam oddělených čárkou
F2-reakce | Vyvolání činnosti na klávesu F2

    Mřížka [Dotazy výkazů] činnosti - Překlad popisek

    Mřížka [Dotazy výkazů] činnosti - Překlad popisek
Dotaz | Identifikace dotazu
Název dotazu | Název dotazu

    Mřížka [Proměnné dotazu] činnosti - Překlad popisek

    Mřížka [Proměnné dotazu] činnosti - Překlad popisek
Proměnná | Číslo proměnné definice výkazu
Název proměnné | Název proměnné výkazu
Návěští | Návěští proměnné výkazu

    Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Design vstupního formuláře |
^P | Překlad popisek |
- | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností

    Atributy tisku

    Základní údaje
Dotaz | Identifikace dotazu | VKDOTAZ_vk17id | C(6)
Název dotazu | Název dotazu | VKDOTAZ_vk17nazev | C(40)
Kód | Kód provedený po vstupu dotazu | VKDOTAZ_vk17kod | M
Poznámka | Poznámka | VKDOTAZ_vk17koment | M

    Při pohybu v Proměnné dotazu
Proměnná | Číslo proměnné definice výkazu | VKDOTAZP_vk09cisprm | C(4)
Název proměnné | Název proměnné výkazu | VKDOTAZP_vk09nazev | C(10)
Typ | Typ proměnné výkazu | Výpočet | C(9)
Délka proměnné | Délka proměnné výkazu | VKDOTAZP_vk09delka | N(3)
Počet desetin | Počet desetin proměnné výkazu | VKDOTAZP_vk09deseti | N(2)
Návěští | Návěští proměnné výkazu | VKDOTAZP_vk09label | C(30)
Třída | Třída ovládacího prvku | Výpočet | C(16)
Hodnoty | Text pro zaškrtávací políčko nebo seznam hodnot pro překryvný seznam oddělených čárkou | VKDOTAZP_vk09pict | C(60)
Výraz | Výraz proměnné výkazu | VKDOTAZP_vk09vyraz | M
Naplnění | Způsob naplnění proměnné - vstupem nebo výpočtem | Výpočet | C(7)
Inicializace | Inicializační hodnota proměnné výkazu | VKDOTAZP_vk09init | C(60)
Činnost | Identifikace činnosti | VKDOTAZP_bw02krok | C(6)

    Viz.také

    Design vstupního formuláře | Překlad popisek | Knihovny vkládaného kódu


ALGORITMY A PARAMETRY

Viz.také

SPUŠTĚNÍ ALGORITMU | HODNOTY KONSTANT | Obecné algoritmy | Sady parametrů | Druhy algoritmů a parametrů | Obecný číselník | Sady systémových konstat | Sady vzdálených funkcí


SPUŠTĚNÍ ALGORITMU

Datový model

  • PAALGOR Algoritmus
    • PADRUPAR Druh algoritmu/parametru
      • SPPRISTU Přístupové právo uživatele k věci

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


HODNOTY KONSTANT

Popis

Po stisku klávesy F9 nebo aktivací činnosti v menu Volby lze vyvolat činnost Hodnoty sady konstant. Tato činnost je pro uživatele dostupná i z hlavního menu (Informační centrum – Algoritmy a parametry – Hodnoty konstant), kde se zobrazují všechny uživateli dostupné sady konstant. Pomocí nastavení výběru na výběrové záložce je možné vybírat hodnoty konstant k různému datu platnosti. Definuje se:

¨ konstanta - překryvný seznam naplněný seznamem konstant definovaných pro danou sadu

¨ datum platnosti od

¨ hodnota konstanty podle typu vybrané konstanty

¨ popis

¨ poznámka

¨ aktualizace - datum a čas aktualizace záznamu

Pro použití hodnot konstant v SQL dotazech je možné použít uložené procedury:

Procedura 'PASYSVAL hodnota - text' - zjišťuje hodnotu textové konstanty

Parametry:

¨ identifikace sady systémových konstant

¨ identifikace konstanty

¨ datum, ke kterému se vybere platná konstanta - nepovinný parametr - není-li uveden vybírá se podle aktuálního data

Procedura vrací textovou hodnotu, není-li konstanta k datu nalezena vrací NULL.

Procedura 'PASYSVAL hodnota - cislo' - zjišťuje hodnotu číselné konstanty

Parametry:

¨ identifikace sady systémových konstant

¨ identifikace konstanty

¨ datum, ke kterému se vybere platná konstanta - nepovinný parametr - není-li uveden vybírá se podle aktuálního data

Procedura vrací numerickou hodnotu, není-li konstanta k datu nalezena vrací NULL.

Procedura 'PASYSVAL hodnota - datum' - zjišťuje hodnotu datumové konstanty

Parametry:

¨ identifikace sady systémových konstant

¨ identifikace konstanty

¨ datum, ke kterému se vybere platná konstanta - nepovinný parametr - není-li uveden vybírá se podle aktuálního data

Procedura vrací datumovou hodnotu, není-li konstanta k datu nalezena vrací NULL.

Příklad:

... WHERE .... AND TABULKA.cislo=%%%."PASYSVAL hodnota - cislo"('SADA','konstanta7',current date-30) AND ....

Pro použití hodnot konstant ve skriptech v jazyce Foxpro je možné použít objekt inicializovaný programem PA0119OB a jeho metody:

Metoda LOAD_DATA

Parametry:

¨ identifikace sady systémových konstant

¨ datum, ke kterému se vyberou platné konstanty - nepovinný parametr - není-li uveden vybírá se podle aktuálního data

Metoda vytvoří v objektu atributy se identifikacemi a hodnotami konstant určené sady. Vrací logickou hodnotu .T. (TRUE) v případě, že byly hodnoty všech definovaných konstant naplněny do atributů objektu, jinak zobrazí chybové hlášení a vrátí hodnotu .F. (FALSE). Vlastnost objektu PARAM_VERZE je metodou nastavena na číslo verze sady (používá se pro zjištění aktuálnosti sady).

Příklad:

LOCAL _o

_o=PA0119OB()

IF NOT _o.load_data('MZDLEG',DATE())

RETURN

ENDIF

IF _o.param_verze<2006.010

DO bw_hlase WITH '!','NAČTENÍ SADY','Sada konstant MZDLEG není aktuální.'+CHR(13)+;

'Importuje aktuální balíček s touto sadou.'

RETURN

ENDIF

? 'Odvod SP zaměstnanec=',_o.mz27spzam

? 'Odvod SP organizace =',_o.mz27sporg

Metoda GET_VALUE

Parametry:

¨ identifikace sady systémových konstant

¨ identifikace konstanty

¨ datum, ke kterému se vybere platná konstanta - nepovinný parametr - není-li uveden vybírá se podle aktuálního data

Vrací hodnotu určené konstanty z určené sady systémových konstant k datu. Není-li konstanta nalezena vrátí hodnotu .F. (FALSE).

Příklad:

? hodnota_mz27spzam()

PROCEDURE hodnota_mz27spzam

LOCAL _o

_o=PA0119OB()

RETURN _o.get_value('MZDLEG','mz27spzam',DATE())

Datový model

  • PASYSSAD Sada systémových konstat
    • PADRUPAR Druh algoritmu/parametru
      • SPPRISTU Přístupové právo uživatele k věci

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Obecné algoritmy

Datový model

  • PAALGOR Algoritmus
    • PADRUPAR Druh algoritmu/parametru
      • SPPRISTU Přístupové právo uživatele k věci
    • PASADA Sada parametrů

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Editovat kód algoritmu | Editovat kód algoritmu
F6 | Zkouška spojení kódu | Zkouška spojení kódu algoritmů
F9 | Spuštění kódu algoritmu | Spuštění kódu algoritmu
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Certifikovat kod algoritmu | Certifikovat kod algoritmu
F2 | Adresář | Přehled adresátů
F2 | Bankovní spojení adresátů |
F2 | Druhy algoritmů a parametrů | Druhy obecných algoritmů a parametrů
F2 | Obecné algoritmy | Obecné algoritmy
F2 | Položky obecného číselníku | Položky obecného číselníku
F2 | Sady parametrů | Sady parametrů
F2 | Spojení adresátů | Přehled spojení adresátů

    Formulář

    Formulář činnosti - Certifikovat kod algoritmu
Mřížka [Algoritmy]
Algoritmus | Identifikátor algoritmu
Název algoritmu | Název algoritmu
Listovací rámeček
Stránka #1 Algoritmy
Druh | Identifikátoru druhu parametru
Název druhu | Název druhu parametru
Sada | Identifikátor sady parametrů
Název sady | Název sady parametrů
Typ kódu | Typ kódu
Vrchol | Vrcholový algoritmus
Průchod | Způsob připojení v 1.průchod nebo 2.průchod nebo v oba průchody
Poznámka | Poznámka
Stránka #2 Parametry algoritmu
Mřížka [Hodnoty parametrů]
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Identifikátor spojení na bankovní účet adresáta.
 | Název adresáta
ID | Identifikace položky číselníku
 | Název položky číselníku
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Text1 | Textová elementární hodnota
Dat1 | Datumová elementární hodnota 1
Dat2 | Datumová elementární hodnota 2
Num1 | Numerická elementární hodnota 1
Num2 | Numerická elementární hodnota 2
Cmb1 | Překryvný seznam elementární hodnota 1
Cmb2 | Překryvný seznam elementární hodnota 2
Poznámka | Poznámka
Platnost od | Platnost od
do | Platnost do
Stránka #3 Kódy algoritmu
Mřížka [Kódy algoritmu]
Verze | Číslo verze kódu algoritmu
Popis verze | Popis verze kódu
Platnost | Datum platnosti od
do | Datum platnosti do
Cert.autora | Podpis certifikátu autora systému
Cert.správce | Podpis certifikátu správce systému
Poznámka | Poznámka
Stránka #4 Souvislost s algoritmy
Mřížka [Souvislost s algoritmy]
Algoritmus | Identifikátor algoritmu
Název algoritmu | Název algoritmu
Platnost | Datum platnosti od
do | Datum platnosti do
Podmínka připojení kódu | Podmínka připojení kódu
Poznámka | Poznámka

    Mřížka [Algoritmy] činnosti - Certifikovat kod algoritmu

    Mřížka [Algoritmy] činnosti - Certifikovat kod algoritmu
Označování | Označení záznamu
Algoritmus | Identifikátor algoritmu
Název algoritmu | Název algoritmu
Vrchol | Vrcholový algoritmus
Průchod | Způsob připojení v 1.průchod nebo 2.průchod nebo v oba průchody
Druh | Identifikátoru druhu parametru
Název druhu | Název druhu parametru
Sada | Identifikátor sady parametrů
Název sady | Název sady parametrů

    Mřížka [Hodnoty parametrů] činnosti - Certifikovat kod algoritmu

    Mřížka [Hodnoty parametrů] činnosti - Certifikovat kod algoritmu
Název parametru | Název parametru
Hodnota parametru | Hodnota parametru
Platnost od | Platnost od
do | Platnost do

    Mřížka [Kódy algoritmu] činnosti - Certifikovat kod algoritmu

    Mřížka [Kódy algoritmu] činnosti - Certifikovat kod algoritmu
Verze | Číslo verze kódu algoritmu
Popis verze | Popis verze kódu
Platnost | Datum platnosti od
do | Datum platnosti do

    Mřížka [Souvislost s algoritmy] činnosti - Certifikovat kod algoritmu

    Mřížka [Souvislost s algoritmy] činnosti - Certifikovat kod algoritmu
Algoritmus | Identifikátor algoritmu
Název algoritmu | Název algoritmu
Platnost | Datum platnosti od
do | Datum platnosti do

    Viz.také

    Editovat kód algoritmu | Zkouška spojení kódu | Spuštění kódu algoritmu | OZNAČOVÁNÍ | Certifikovat kod algoritmu | Adresář | Bankovní spojení adresátů | Druhy algoritmů a parametrů | Položky obecného číselníku | Sady parametrů | Spojení adresátů


Sady parametrů

Popis

Evidují se zde volné údaje definované podle vlastních potřeb každého uživatele. Nachází se pod menu Obecné – Hodnoty parametrů objektu – Sady parametrů. Nadefinovat jednotlivé sady je uživatelsky náročnější, takže by to měl provádět buď zkušený uživatel a nebo implementátor. Sady parametrů je možné využít ve všech komponentách IS BM, např. v obchodu v činnosti „vztahy obchodovatelných artiklů k adresátům“ , v artiklech skladu pro doplnění detailních informací o artiklu nebo i pro účely personalistiky apod. Můžeme tuto činnost definovat i tak, že v podstatě kopíruje možnosti, které uživateli poskytují Volné karty, jen v obecnější míře pojetí. Parametry a jejich struktura jsou uživatelsky definovatelné, což umožní popsat např. i jakýkoliv projekt. Aplikace parametrů umožňuje pohodlně vybírat projekty, ve kterých je daný parametr evidován nebo ve kterých nabývá určité hodnoty.

U každé sady parametrů se na záložce „Sady parametrů“ definuje:

¨ identifikace sady

¨ identifikace komponenty – dodává ji systém automaticky. Deklaruje nad jakým objektem je sada vytvořena.

¨ název sady

¨ příznak, zda je aktuální či nikoliv

¨ libovolnou poznámku

Poznámka:

Při použití sady parametrů v komponentě personalistika je v případě potřeby možno u každého pracovníka evidovat další osobní údaje (o dětech, o studiu, školeních apod.). Tato činnost je dostupná v menu Volby. K dispozici jsou čtyři volné texty, volné datum a volné číslo. U každého osobního údaje je navíc možno nastavit jeho platnost od – do.

Na záložce „parametry v sadě“ se definuje:

¨ identifikátor parametru (definovaný v číselníku obecných parametrů)

¨ pořadí parametru

výskyt parametru – ten může nabývat hodnot:

¨ 1:1 - pro každý objekt musí existovat právě jeden tento parametr. Je povinný.

¨ 0:1 - pro každý objekt může existovat žádný nebo právě jeden tento parametr

¨ 1:M - pro každý objekt musí existovat alespoň jeden nebo více těchto parametrů

¨ 0:M - pro každý objekt může existovat žádný nebo více těchto parametrů

Při zařazení nového parametru do sady s výskytem 1:1 nebo 1:M je automaticky ke všem objektům daného druhu připojen záznam o hodnotě parametru s inicializací jeho elementárních hodnot.

Automatické připojení se neprovádí:

¨ pro objekty, které jsou událostmi komponent

¨ pro objekty, ve kterých je sada přímo uvedena (např. pracovní funkce ve personalistice) - automaticky se připojují pouze parametry odpovídající sady

Datový model

  • PASADA Sada parametrů

    • Formulář

    Formulář činnosti - Přehled hodnot parametrů
Mřížka [Sady parametrů]
Sada | Identifikátor sady parametrů
Oblast | Oblast sady parametrů
Název sady | Název sady parametrů
Listovací rámeček
Stránka #1 Sady parametrů
Aktuální | Aktuální sada parametrů
Poznámka | Poznámka
Stránka #2 Parametry v sadě
Mřížka [Parametry v sadě]
Parametr | Identifikátor parametru
Název parametru | Název parametru
Pořadí | Pořadí parametru
Výskyt parametru | Výskyt parametru

    Mřížka [Sady parametrů] činnosti - Přehled hodnot parametrů

    Mřížka [Sady parametrů] činnosti - Přehled hodnot parametrů
Sada | Identifikátor sady parametrů
Název sady | Název sady parametrů

    Mřížka [Parametry v sadě] činnosti - Přehled hodnot parametrů

    Mřížka [Parametry v sadě] činnosti - Přehled hodnot parametrů
Pořadí | Pořadí parametru
Parametr | Identifikátor parametru
Název parametru | Název parametru

    Vyvolávané činnosti

    K. | Činnost | Popis
- | Obecné parametry | Obecné parametry

    Atributy tisku

    Základní údaje
Sada | Identifikátor sady parametrů | PASADA_pa01id | C(6)
Oblast | Oblast sady parametrů | PASADA_pa01oblast | C(2)
Název sady | Název sady parametrů | PASADA_pa01nazsad | C(40)
Aktuální | Aktuální sada parametrů | Výpočet | C(3)
Poznámka | Poznámka | PASADA_pa01koment | M
Název parametru | Název parametru | PAPARAM_pa02nazpar | C(40)

    Při pohybu v Parametry v sadě
Parametr | Identifikátor parametru | PASADPAR_pa02id | C(6)
Pořadí | Pořadí parametru | PASADPAR_pa04porad | N(4)
Výskyt parametru | Výskyt parametru | Výpočet | C(3)

    Viz.také

    Obecné parametry | Hodnoty parametrů objektu | Klasifikace objektů | Přehled hodnot parametrů


Druhy algoritmů a parametrů

Popis

Druhy obecných parametrů definují práva přístupu uživatelů k parametrům a jejich elementárním hodnotám.

Datový model

  • PADRUPAR Druh algoritmu/parametru
    • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Druhy parametrů]
Druh | Identifikátoru druhu parametru
Název druhu | Název druhu parametru
Poznámka | Poznámka

    Mřížka [Druhy parametrů] činnosti - Přístupová práva

    Mřížka [Druhy parametrů] činnosti - Přístupová práva
Druh | Identifikátoru druhu parametru
Název druhu | Název druhu parametru

    Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci

    Atributy tisku

    Základní údaje
Druh | Identifikátoru druhu parametru | PADRUPAR_pa03id | C(6)
Název druhu | Název druhu parametru | PADRUPAR_pa03nazdru | C(40)
Poznámka | Poznámka | PADRUPAR_pa03koment | M

    Viz.také

    Přístupová práva


Obecný číselník

Popis

Číselník se nachází v činnosti Informační centrum – Algoritmy a parametry.

Datový model

  • PACISEL Obecný číselník

    • Formulář

    Formulář činnosti - Položky obecného číselníku
Mřížka [Obecné číselníky]
Číselník | Identifikace číselníku
Název číselníku | Název číselníku
Listovací rámeček
Stránka #1 Obecné číselníky
Poznámka | Poznámka
Stránka #2 Popisky pro zobrazení položek číselníku
Label ID | Label identifikátoru položky číselníku
Label NZ | Label názvu položky číselníku
Label N1 | Label numerické hodnoty 1
Stav.ř. N1 | Stavový řádek numerické hodnoty 1
Label N2 | Label numerické hodnoty 2
Stav.ř. N2 | Stavový řádek numerické hodnoty 2
Label T1 | Label textové hodnoty 1
Stav.ř. T1 | Stavový řádek textové hodnoty 1
Label T2 | Label textové hodnoty 2
Stav.ř. T2 | Stavový řádek textové hodnoty 2

    Mřížka [Obecné číselníky] činnosti - Položky obecného číselníku

    Mřížka [Obecné číselníky] činnosti - Položky obecného číselníku
Číselník | Identifikace číselníku
Název číselníku | Název číselníku

    Vyvolávané činnosti

    K. | Činnost | Popis
F9 | Položky obecného číselníku | Položky obecného číselníku

    Atributy tisku

    Základní údaje
Číselník | Identifikace číselníku | PACISEL_pa07id | C(6)
Název číselníku | Název číselníku | PACISEL_pa07nazcis | C(40)
Label N1 | Label numerické hodnoty 1 | PACISEL_pa07n1lb | M
Stav.ř. N1 | Stavový řádek numerické hodnoty 1 | PACISEL_pa07n1st | M
Label N2 | Label numerické hodnoty 2 | PACISEL_pa07n2lb | M
Stav.ř. N2 | Stavový řádek numerické hodnoty 2 | PACISEL_pa07n2st | M
Label T1 | Label textové hodnoty 1 | PACISEL_pa07t1lb | M
Stav.ř. T1 | Stavový řádek textové hodnoty 1 | PACISEL_pa07t1st | M
Label T2 | Label textové hodnoty 2 | PACISEL_pa07t2lb | M
Stav.ř. T2 | Stavový řádek textové hodnoty 2 | PACISEL_pa07t2st | M
Poznámka | Poznámka | PACISEL_pa07koment | M

    Při pohybu v Položky obecného číselníku
ID | Identifikace položky číselníku | PACISPOL_pa08id | C(10)
Název položky číselníku | Název položky číselníku | PACISPOL_pa08nazpol | C(40)
Poznámka | Poznámka | PACISPOL_pa08koment | M

    Viz.také

    Položky obecného číselníku


Sady systémových konstat

Popis

Činnost „sady systémových konstant“ slouží pro definování a uchování hodnot konstant potřebných pro funkce programu IS BM. Je dostupná v hlavním menu programu v činnosti Informační centrum – Algoritmy a parametry. Tato činnost obsahuje záložku Sady, záložku Konstanty a záložku Popis verzí sady.

Sady konstant je možné exportovat do balíčku (menu Obecné – export dat do balíčku). Přitom je do balíčku exportována jak definice sady konstant, tak i její hodnoty. Při importu balíčku dojde k přepisu dříve zadaných definic konstant resp. jejich hodnot podle u nich uvedeného data a času aktualizace.

Na záložce „Sady“ se definuje:

¨ identifikace sady konstant - 6 znaků

¨ název sady konstant

¨ druh sady konstant - určuje přístupová práva pro definování sady

¨ verze - numerická 8,3 - pro určení aktuálnosti sady - uvádí se obvykle rok a měsíc např. 2006.030 v březnu roku 2006

¨ aktualizace - datum a čas aktualizace záznamu

¨ poznámka

Na záložce „Konstanty“ se definuje struktura sady konstant a zadávají se tyto atributy:

¨ identifikace konstanty - 10 znaků

¨ název konstanty

¨ druh konstanty - určuje přístupová práva uživatele pro nastavení hodnoty konstanty

¨ typ konstanty - překryvný seznam - Text / Číslo / Datum

¨ pořadí zobrazení konstanty při zadávání hodnot sady konstant

¨ délka - pro typ Text / Číslo

¨ desetiny - pro typ Číslo

¨ poznámka

¨ platnost od – do – uvedení platnosti konstanty. Tato možnost je vhodná i pro uživatele mezd a legislativní konstanty, kde se dá tímto ukončit platnost legislativní konstantě, která pro současný výpočet mezd ztratila smysl.

¨ specifická – volba Ano/Ne – označuje konstantu jež je specifická pro různé subjekty. Konstanty s nastavením specifická na hodnotu ANO jsou v mřížce zobrazené na světle modrém podkladu. Hodnoty konstant, které mají nastaveno specifická ANO, nebudou při exportu do balíčku vyvolaném v tomto formuláři do něj zahrnuty.

¨ aktualizace - datum a čas aktualizace záznamu

Na záložce Popis verzí sady jsou k dispozici následující informace:

¨ číslo popisované verze

¨ text popisu verze (jaká změna, její smysl apod.)

¨ datum pořízení popisu

¨ jméno autora popisu (vloží se automaticky – nelze ho přepsat)

Po stisku klávesy F9 nebo aktivací činnosti v menu Volby lze vyvolat činnost Hodnoty sady konstant. Tato činnost je pro uživatele dostupná i z hlavního menu (Informační centrum – Algoritmy a parametry – Hodnoty konstant), kde se zobrazují všechny uživateli dostupné sady konstant. Pomocí nastavení výběru na výběrové záložce je možné vybírat hodnoty konstant k různému datu platnosti. Definuje se:

¨ konstanta - překryvný seznam naplněný seznamem konstant definovaných pro danou sadu

¨ datum platnosti od

¨ hodnota konstanty podle typu vybrané konstanty

¨ popis

¨ poznámka

¨ aktualizace - datum a čas aktualizace záznamu

Pro použití hodnot konstant v SQL dotazech je možné použít uložené procedury:

Procedura 'PASYSVAL hodnota - text' - zjišťuje hodnotu textové konstanty

Parametry:

¨ identifikace sady systémových konstant

¨ identifikace konstanty

¨ datum, ke kterému se vybere platná konstanta - nepovinný parametr - není-li uveden vybírá se podle aktuálního data

Procedura vrací textovou hodnotu, není-li konstanta k datu nalezena vrací NULL.

Procedura 'PASYSVAL hodnota - cislo' - zjišťuje hodnotu číselné konstanty

Parametry:

¨ identifikace sady systémových konstant

¨ identifikace konstanty

¨ datum, ke kterému se vybere platná konstanta - nepovinný parametr - není-li uveden vybírá se podle aktuálního data

Procedura vrací numerickou hodnotu, není-li konstanta k datu nalezena vrací NULL.

Procedura 'PASYSVAL hodnota - datum' - zjišťuje hodnotu datumové konstanty

Parametry:

¨ identifikace sady systémových konstant

¨ identifikace konstanty

¨ datum, ke kterému se vybere platná konstanta - nepovinný parametr - není-li uveden vybírá se podle aktuálního data

Procedura vrací datumovou hodnotu, není-li konstanta k datu nalezena vrací NULL.

Příklad:

... WHERE .... AND TABULKA.cislo=%%%."PASYSVAL hodnota - cislo"('SADA','konstanta7',current date-30) AND ....

Pro použití hodnot konstant ve skriptech v jazyce Foxpro je možné použít objekt inicializovaný programem PA0119OB a jeho metody:

Metoda LOAD_DATA

Parametry:

¨ identifikace sady systémových konstant

¨ datum, ke kterému se vyberou platné konstanty - nepovinný parametr - není-li uveden vybírá se podle aktuálního data

Metoda vytvoří v objektu atributy se identifikacemi a hodnotami konstant určené sady. Vrací logickou hodnotu .T. (TRUE) v případě, že byly hodnoty všech definovaných konstant naplněny do atributů objektu, jinak zobrazí chybové hlášení a vrátí hodnotu .F. (FALSE). Vlastnost objektu PARAM_VERZE je metodou nastavena na číslo verze sady (používá se pro zjištění aktuálnosti sady).

Příklad:

LOCAL _o

_o=PA0119OB()

IF NOT _o.load_data('MZDLEG',DATE())

RETURN

ENDIF

IF _o.param_verze<2006.010

DO bw_hlase WITH '!','NAČTENÍ SADY','Sada konstant MZDLEG není aktuální.'+CHR(13)+;

'Importuje aktuální balíček s touto sadou.'

RETURN

ENDIF

? 'Odvod SP zaměstnanec=',_o.mz27spzam

? 'Odvod SP organizace =',_o.mz27sporg

Metoda GET_VALUE

Parametry:

¨ identifikace sady systémových konstant

¨ identifikace konstanty

¨ datum, ke kterému se vybere platná konstanta - nepovinný parametr - není-li uveden vybírá se podle aktuálního data

Vrací hodnotu určené konstanty z určené sady systémových konstant k datu. Není-li konstanta nalezena vrátí hodnotu .F. (FALSE).

Příklad:

? hodnota_mz27spzam()

PROCEDURE hodnota_mz27spzam

LOCAL _o

_o=PA0119OB()

RETURN _o.get_value('MZDLEG','mz27spzam',DATE())

Datový model

  • PASYSSAD Sada systémových konstat
    • PADRUPAR Druh algoritmu/parametru
      • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Hodnoty sady konstant
Mřížka [Sady]
Sada | Identifikace sady systémových konstant
Název sady | Název sady systémových konstant
Listovací rámeček
Stránka #1 Sady
Verze | Verze sady systémových konstant
Aktualizace | Datum aktualizace
Změnil | Jméno uživatele systému, který změnil záznam
Druh | Identifikátoru druhu parametru
Poznámka | Poznámka
Stránka #2 Konstanty
Mřížka [Konstanty]
Konstanta | Identifikátor systémové konstanty
Název konstanty | Název konstanty
Druh | Identifikátoru druhu parametru
Typ | Typ systémové konstanty Text / Číslo / Datum
Pořadí | Pořadí zobrazení konstanty
Délka | Délka hodnoty konstanty
Desetiny | Počet desetin hodnoty konstanty
Platnost | Platnost výskytu systémové konstanty od
do | Platnost výskytu systémové konstanty do
Poznámka | Poznámka
Specifická | Nastavení Specifická=Ano, označuje konstanty, které jsou hodnotou specifické pro různé subjekty (jejich hodnoty se nemají přenášet balíčkem)
Aktualizace | Datum aktualizace
Stránka #3 Popis verzí sady
Mřížka [Popis verzí sady]
Verze | Verze sady systémových konstant
Aktualizace | Datum aktualizace
Popis | Popis verze
Dne | Datum záznamu o verzi
Popsal | Jméno uživatele systému, který změnil záznam

    Mřížka [Sady] činnosti - Hodnoty sady konstant

    Mřížka [Sady] činnosti - Hodnoty sady konstant
Sada | Identifikace sady systémových konstant
Název sady | Název sady systémových konstant
Druh | Identifikátoru druhu parametru
Název druhu | Název druhu parametru
Verze | Verze sady systémových konstant
Aktualizace | Datum aktualizace

    Mřížka [Konstanty] činnosti - Hodnoty sady konstant

    Mřížka [Konstanty] činnosti - Hodnoty sady konstant
Pořadí | Pořadí zobrazení konstanty
Konstanta | Identifikátor systémové konstanty
Název konstanty | Název konstanty
Typ | Typ systémové konstanty Text / Číslo / Datum
Druh | Identifikátoru druhu parametru
Název druhu | Název druhu parametru

    Mřížka [Popis verzí sady] činnosti - Hodnoty sady konstant

    Mřížka [Popis verzí sady] činnosti - Hodnoty sady konstant
Verze | Verze sady systémových konstant
Dne | Datum záznamu o verzi
Popsal | Jméno uživatele systému, který změnil záznam

    Vyvolávané činnosti

    K. | Činnost | Popis
F9 | Hodnoty sady konstant | Hodnoty sady systémových konstant
F2 | Druhy algoritmů a parametrů | Druhy obecných algoritmů a parametrů

    Atributy tisku

    Základní údaje
Sada | Identifikace sady systémových konstant | PASYSSAD_pa17id | C(6)
Druh | Identifikátoru druhu parametru | PASYSSAD_pa03id | C(6)
Název druhu | Název druhu parametru | PADRUPAR_pa03nazdru | C(40)
Název sady | Název sady systémových konstant | PASYSSAD_pa17nazsad | C(40)
Verze | Verze sady systémových konstant | PASYSSAD_pa17verze | N(8,3)
Aktualizace | Datum aktualizace | PASYSSAD_sp00datakt | T
Změnil | Jméno uživatele systému, který změnil záznam | PASYSSAD_sp00jmeakt | C(40)
Poznámka | Poznámka | PASYSSAD_pa17koment | M
Název druhu | Název druhu parametru | PADRUPAR2_pa03nazdru | C(40)

    Při pohybu v Konstanty
Sada | Identifikace sady systémových konstant | PASYSKON_pa17id | C(6)
Druh | Identifikátoru druhu parametru | PASYSKON_pa03id | C(6)
Konstanta | Identifikátor systémové konstanty | PASYSKON_pa18id | C(10)
Název konstanty | Název konstanty | PASYSKON_pa18nazkon | C(40)
Typ | Typ systémové konstanty Text / Číslo / Datum | Výpočet | C(5)
Pořadí | Pořadí zobrazení konstanty | PASYSKON_pa18porad | N(3)
Délka | Délka hodnoty konstanty | PASYSKON_pa18delka | N(2)
Desetiny | Počet desetin hodnoty konstanty | PASYSKON_pa18deseti | N(2)
Platnost | Platnost výskytu systémové konstanty od | PASYSKON_pa18platod | D
Platnost do | Platnost výskytu systémové konstanty do | PASYSKON_pa18platdo | D
Poznámka | Poznámka | PASYSKON_pa18koment | M
Specifická | Nastavení Specifická=Ano, označuje konstanty, které jsou hodnotou specifické pro různé subjekty (jejich hodnoty se nemají přenášet balíčkem) | Výpočet | C(3)

    Při pohybu v Popis verzí
Verze | Verze sady systémových konstant | PASYVSAD_pa17verze | N(8,3)
Dne | Datum záznamu o verzi | PASYVSAD_pa27dne | D
Popsal | Jméno uživatele systému, který změnil záznam | PASYVSAD_sp00jmeakt | C(40)
Popis | Popis verze | PASYVSAD_pa27koment | M

    Viz.také

    Hodnoty sady konstant | Druhy algoritmů a parametrů


Sady vzdálených funkcí

Popis

Tato činnost slouží ke sledování aktuálnosti verzí a legislativních nastavení u uživatelů, tzn. že u jednotlivých uživatelů lze porovnat jejich verzi vůči nejaktuálnější verzi Bílého Motýla a zjistit, jestli má uživatel aktuální všechny předlohy výstupu, doplňující vlastnosti formuláře, knihovny apod., čímž je plně zajištěno aktuální nastavení BM i u jednotlivých uživatelů.

V činnosti „Sady vzdálených funkcí“ se definují vlastní definice kontroly jednotlivých činností, po jejichž spuštění právě dochází k porovnání verzí aktuálního nastavení BM a nastavení BM u uživatele.

U každé sady se na záložce „sady vzdálených funkcí“ definuje identifikace sady, její název a poznámka (tzn. bližší vysvětlení, k jaké kontrole tato sada slouží, co je jejím cílem apod.).

Uživatel si zde může pouze prohlédnout přehled nadefinovaných sad a vybranou následně aktivovat, jejich vlastní nastavení zde měnit nelze (to se provádí v činnostech Sady vzdálených funkcí – nastavení a Vzdálené funkce – nastavení).

Vedle atributu Poznámka má uživatel k dispozici dvě samostatná tlačítka:

¨ modrá tužka – (ne)zobrazovat kurzor v mřížce – v běžném nastavení platí, že pokud umístíme kurzor na vybraný řádek, tak tento řádek je zvýrazněn jinou barvou (právě aby bylo zřejmé, že je v tuto řádek aktivní). Pokud by toto zvýraznění řádku uživateli ovšem nevyhovovalo, lze stisknout právě toto tlačítko. Pak aktivní řádek není zvýrazněn žádnou barvou, pouze je u něj příznak malé černé šipky na začátku řádku.

¨ zelená šipka – toto tlačítko slouží ke spuštění vybrané sady vzdálených funkcí. Po jeho aktivaci uživatel pouze určí datum, ke kterému tuto sadu aktivuje a stiskne tlačítko OK. Následně se uživateli zobrazí informační panel s protokolem, který je opticky rozdělen do dvou částí.

Menší levá část obsahuje sloupec s názvy jednotlivých sekcí, které daná sada obsahuje. Větší pravá část vždy zobrazuje info k té sekci, na které je umístěn kurzor. Jako první se po aktivaci dané sady kurzor umístí na hlavičku s názvem sady, která má v pravé části info k jednotlivým sekcím a ve sloupečku info je napsaná informace, které nesrovnalosti tam systém při kontrole objevil (tzn. může tam být napsáno „chyba“ – že je nutno některé údaje v sekci aktualizovat nebo hláška „nespuštěna“ – že tuto sekci uživatel ještě nikdy nenahrál apod.). Na dolní liště je info, kolik sekcí bylo OK, v jaké sekci bylo varování, chyby a kolik jich bylo ještě nespuštěno (viz. následující obrázek).

V případě, že uživatel umístí kurzor na řádek označený křížkem (na našem obr. např. „kontrola všech předloh výstupu“), zobrazí se mu v pravé části obrazovky podrobná informace.

Po stisku modře označených záznamů má uživatel dostupné ještě podrobnější informace, např. po stisku čísla verze se přesně dozví bližší údaje o tom, kdy a kým byla daná verze vytvořena, kdo je autor, jaký je typ předlohy apod. Po stisku modře označené informace „chyba“ se uživateli zobrazí nabídka možnosti nahrát si danou předlohu výstupu pomocí balíčku. Naprosto stejný postup je i u jiných druhů informací, např. těch, co se týkají legislativních konstant nebo daňových přiznání. Vždy pod modře označeným záznamem je buď podrobnější informace nebo možnost chybu napravit (nahrát balíčkem nebo informace o tom, kde si má jaké nastavení uživatel opravit).

Druhá záložka v této činnosti se jmenuje „automatické spouštění“ a uživatel zde má možnost si nadefinovat možnost automatického spouštění vybrané sady. Definují se následující atributy:

¨ skupina – identifikace skupiny uživatelů (v podstatě zde se vybírá, kdo bude mít právo danou sadu automaticky spouštět)

¨ spustit – výběr z překryvného seznamu. Možnosti jsou při startu BM, nespouštět, při startu programu

¨ perioda – pokaždé, jednou denně – uživatel, jednou denně – celá firma

¨ balíčky – opět výběr z překryvného seznamu. Možnosti jsou importovat, importovat na pozadí, importovat na pozadí s dotazem, neimportovat – spustit formulář

¨ po chybě – možnost nastavit spustit formulář vzdálených funkcí nebo nespustit formulář vzdálených funkcí

Pomocí kombinace těchto atributů lze nastavit např. že po prvním přihlášení daného uživatele do systému v daný den se má automaticky spustit daná sada vzdálených funkcí a pokud by systém zjistil nesrovnalosti ve verzích, může automaticky na pozadí naimportovat chybějící balíčky.

Vyvolávané činnosti

K. | Činnost | Popis
F7 | (Ne)zobrazovat kurzor v mřížce |
F9 | Spustit sadu funkcí | Spustit sadu funkcí
F2 | Skupiny uživatelů | Definování skupin uživatelů

Formulář

Formulář činnosti - Skupiny uživatelů
Mřížka [Sady vzdálených funkcí]
Sada | Identifikace činnosti
Název sady | Název sady vzdálených funkcí
Listovací rámeček
Stránka #1 Sady vzdálených funkcí
Spustit sadu funkcí | Poznámka
Stránka #2 Automatické spouštění
Mřížka [Automatické spouštění]
Skupina | Identifikace skupiny uživatelů
Spustit | Spustit sadu vzdálených funkcí
Perioda | Spustit sadu vzdálených funkcí pokaždé nebo jednou denně
Balíčky | Automaticky importovat balíček při spuštění sady vzdálených funkcí
Po chybě | Zobrazit formulář sady vzdálených funkcí
Poznámka | Poznámka

Mřížka [Sady vzdálených funkcí] činnosti - Skupiny uživatelů

Mřížka [Sady vzdálených funkcí] činnosti - Skupiny uživatelů
Název sady | Název sady vzdálených funkcí
Název činnosti | Název činnosti
Činnost | Identifikace činnosti
Stav | Stav sady vzdálených funkcí Mimo provoz / Ladící provoz / Ostrý provoz

Mřížka [Automatické spouštění] činnosti - Skupiny uživatelů

Mřížka [Automatické spouštění] činnosti - Skupiny uživatelů
Skupina uživatelů | Jméno uživatele systému
Spustit | Spustit sadu vzdálených funkcí
Perioda | Spustit sadu vzdálených funkcí pokaždé nebo jednou denně
Balíčky | Automaticky importovat balíček při spuštění sady vzdálených funkcí
Po chybě | Zobrazit formulář sady vzdálených funkcí

Viz.také

(Ne)zobrazovat kurzor v mřížce | Spustit sadu funkcí | Skupiny uživatelů


INFORMAČNÍ PANELY

Popis

Informační panel je nástroj, který slouží k přehlednému zobrazení úkolů uživatele vyplývajících z informací uložených v systému. Obsah informačního panelu je volně definovatelný a je ho možné přizpůsobit individuálním potřebám jednotlivých uživatelů. Uživateli se mohou na jediné webové stránce zobrazovat jeho úkoly z různých oblastí IS a z této stránky potom může přímo vyvolávat potřebné funkce a činnosti aktivací hypertextového odkazu.

Informační panely se nacházejí v hlavním menu v činnosti Informační centrum. Po rozbalení tohoto menu má uživatel k dispozici tyto činnosti:

¨ Informační panely ke spuštění – přímo výběr jednotlivých nadefinovaných panelů ke spuštění

¨ Definice uzlů informačních panelů – vlastní definice jednotlivých informačních panelů

¨ Prezentace stránek informačních panelů – definice vzhledu stránek informačního panelu

¨ Hypertextové odkazy – předdefinované hypertextové odkazy, které umožňují spouštění jiných uzlů s parametry nebo spouštění skriptů

Viz.také

INFORMAČNÍ PANELY KE SPUŠTĚNÍ | Definice uzlů inf.panelů | Editor uzlů informačních panelů | Druhy uzlů inf.panelů | Prezentace stránek panelů | Hypertextové odkazy


INFORMAČNÍ PANELY KE SPUŠTĚNÍ

Popis

Jedná se o skupinové menu, pod nímž má uživatel k dispozici jednotlivé nadefinované informační panely ke spuštění.

Datový model

  • IPUZEL Uzel informačního panelu
    • IPDRUH Druh uzlu informačního panelu
      • SPPRISTU Přístupové právo uživatele k věci

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Definice uzlů inf.panelů

Popis

Tato činnost se nachází v menu Informačním centrum – Informační panely.

Informační panel je nástroj, který slouží k přehlednému zobrazení úkolů uživatele vyplývajících z informací uložených v systému. Obsah informačního panelu je volně definovatelný a je ho možné přizpůsobit individuálním potřebám jednotlivých uživatelů. Uživateli se mohou na jediné webové stránce zobrazovat jeho úkoly z různých oblastí IS a z této stránky potom může přímo vyvolávat potřebné funkce a činnosti aktivací hypertextového odkazu.

Touto činností je možné definovat jeden nebo více informačních panelů. Na záložce Uzly a Další se popisují jednotlivé prvky informačních panelů.

Pro každý uzel se definuje:

¨ identifikace uzlu, která ho jednoznačně identifikuje

¨ název uzlu

¨ druh uzlu - definuje práva uživatelů

¨ prezentace - má význam pro uzel typu "Stránka panelu" - určuje HTML formátování

¨ ikona - má význam pro uzel typu "Stránka panelu" - určuje ikonu stránky

¨ typ – překryvný seznam - Informační panel / Stránka panelu / Prvek stránky

¨ adresa - má význam pro uzel typu "Stránka panelu" - přímá URL adresa vyvolaná při aktivaci stránky

¨ typ prvku - pro typ prvek stránky - určuje zda bude vytvářena tabulka nebo odkaz

¨ spojení - určuje datový zdroj, ze kterého budou SQL dotazem získávána data

¨ výraz názvu uzlu - je vyhodnocen při vytváření stránky panelu (výraz v syntaxi Foxpro)

¨ výraz třídění - pro uzel typu prvek stránky - určuje třídění dat získaných dotazem SQL (výraz v syntaxi Foxpro)

¨ SQL dotaz - pro uzel typu prvek stránky - SQL dotaz v syntaxi SQL Anywhere. Ve vlastnosti 'SQL dotaz' definice uzlu je možné vložit dva skripty provedené před a po provedení SQL dotazu. Oběma skriptům jsou přitom předávány parametry, se kterými je stránka vyvolána (_p1,_p2,...,_p14) a v proměnné _this je předán řídící objekt vytvářející stránku, skriptu před SQL dotazem je navíc předán v proměnné _OBJ_SQL objekt, který má ve svém atributu SQL obsažen text následně prováděného SQL dotazu (skript může tento text měnit). Provádí se uvedením slova #SCRIPT na začátku definice SQL dotazu (nesmí být před ním žádné mezery ani prázdné řádky). Za tímto slovem následuje kód skriptu v jazyce Foxpro vyvolaný bezprostředně před provedením SQL dotazu a za ním je na novém řádku slovo #ENDSCRIPT (nesmí být před ním žádné mezery). Pak následuje vlastní tvar SQL dotazu v syntaxi SQL. A potom může být uvedeno na samostatném řádku slovo #SCRIPT (nesmí být před ním žádné mezery), za kterým následuje kód v jazyce Foxpro vyvolaný po provedení SQL dotazu.

Při tvorbě definice informačních panelů lze použít technologii Materialized View. Ta umožňuje např. prezentovat manažerské informace na informačních panelech novou metodou, která byla vyvinuta a v praxi nasazena pro vyhodnocování marketingových kampaní. Díky použité technologii MATERIALIZED VIEW se standardizovanou strukturou a navazujícího agregování GROUP BY CUBE se dosahuje okamžité odezvy.

Př.:

<pre>

#SCRIPT

* vytvoří proměnnou TOOL.MOJE_PROMENNA a ta se potom použije v SQL dotazu

tool.addproperty('MOJE_PROMENNA','A%')

#ENDSCRIPT

select sp26,sp26datum,sp26nazev,bw01jmeno,sp26index,spdokobs.sp01id,sp01predlo,sp57typdok,spdokobs.sp57id,sp26koment,sp26disk,sp26soubor from %%%.spdokobs spdokobs,%%%.bwuzivat bwuzivat,%%%.sppredlo sppredlo,%%%.spdoktyp spdoktyp,%%%.sppristu sppristu where

spdokobs.sp57id=sppristu.sp44vec and sppristu.sp44typ='tdo' and sppristu.bw01uziv=?tool.uziv and

sppristu.sp44pristu>1 and

sp26nazev like ?TOOL.MOJE_PROMENNA and

spdokobs.bw01uziv=bwuzivat.bw01uziv and spdokobs.sp01id=sppredlo.sp01id and spdokobs.sp57id=spdoktyp.sp57id

#SCRIPT

* modifikuje data, která vrátil SQL dotaz v kurzoru DATA

select data

replace all sp26nazev with '* '+sp26nazev

#ENDSCRIPT

</pre>

Nebo:

<pre>

#SCRIPT

* doplní následně provedený SQL dotaz

_OBJ_SQL.SQL=_OBJ_SQL.SQL+" and sp26nazev like 'A%' "

#ENDSCRIPT

select sp26,sp26datum,sp26nazev,bw01jmeno,sp26index,spdokobs.sp01id,sp01predlo,sp57typdok,spdokobs.sp57id,sp26koment,sp26disk,sp26soubor from %%%.spdokobs spdokobs,%%%.bwuzivat bwuzivat,%%%.sppredlo sppredlo,%%%.spdoktyp spdoktyp,%%%.sppristu sppristu where

spdokobs.sp57id=sppristu.sp44vec and sppristu.sp44typ='tdo' and sppristu.bw01uziv=?tool.uziv and

sppristu.sp44pristu>1 and

spdokobs.bw01uziv=bwuzivat.bw01uziv and spdokobs.sp01id=sppredlo.sp01id and spdokobs.sp57id=spdoktyp.sp57id

#SCRIPT

* modifikuje data, která vrátil SQL dotaz v kurzoru DATA

select data

replace all sp26nazev with '* '+sp26nazev

#ENDSCRIPT

</pre>

Pozn.: V případě, že je potřeba použít pouze skript po SQL dotazu, potom je třeba definovat skript prováděný před SQL dotazem prázdný.

Např.:

<pre>

#SCRIPT

#ENDSCRIPT

select sp26,sp26datum,sp26nazev,bw01jmeno,sp26index,spdokobs.sp01id,sp01predlo,sp57typdok,spdokobs.sp57id,sp26koment,sp26disk,sp26soubor from %%%.spdokobs spdokobs,%%%.bwuzivat bwuzivat,%%%.sppredlo sppredlo,%%%.spdoktyp spdoktyp,%%%.sppristu sppristu where

spdokobs.sp57id=sppristu.sp44vec and sppristu.sp44typ='tdo' and sppristu.bw01uziv=?tool.uziv and

sppristu.sp44pristu>1 and

spdokobs.bw01uziv=bwuzivat.bw01uziv and spdokobs.sp01id=sppredlo.sp01id and spdokobs.sp57id=spdoktyp.sp57id

#SCRIPT

* modifikuje data, která vrátil SQL dotaz v kurzoru DATA

select data

replace all sp26nazev with '* '+sp26nazev

#ENDSCRIPT

</pre>

Na stránce informačního panelu je možné vytvářet odkazy, které způsobí vyvolání programu Windows (jiného než internetový prohlížeč) a v něm otevření souboru, který odpovídá celé zobrazené stránce (může to být více tabulek) nebo jednotlivé tabulce zobrazené na stránce. Funkčnost přenosu zobrazené tabulky do Wordu a Excelu je rozšířena o přímou možnost vytvoření dokumentu ve formátu Wordu resp. Excelu. Provádí se vložením kódu v jazyce Foxpro do atributu 'SQL dotaz' v definici uzlu informačního panelu. Tento kód vytvoří soubor v požadovaném formátu (případě, že je nastavena proměnná '_this.output_format') a jeho název vloží do proměnné '_this.rodic.output_file'.

V následujících popsaných příkladech se předpokládá, že na počítači je nainstalován Excel - a v případě použití pro WBM není jeho volání nějakým způsobem omezeno IIS-serverem.

Příklad 1. - klasický SQL dotaz

<pre>

#SCRIPT

#ENDSCRIPT

Select sp26,sp26datum,sp26nazev,bw01jmeno,sp26index,spdokobs.sp01id,sp01predlo,sp57typdok,spdokobs.sp57id,sp26koment,sp26disk,sp26soubor From %%%.spdokobs spdokobs,%%%.bwuzivat bwuzivat,%%%.sppredlo sppredlo,%%%.spdoktyp spdoktyp,%%%.sppristu sppristu Where

spdokobs.sp57id=sppristu.sp44vec And sppristu.sp44typ='TDO' And sppristu.bw01uziv=?Tool.uziv And

sppristu.sp44pristu>1 And

spdokobs.bw01uziv=bwuzivat.bw01uziv And spdokobs.sp01id=sppredlo.sp01id And spdokobs.sp57id=spdoktyp.sp57id

#SCRIPT

Local _txt,_xlapp,_xlwb,_xlsheet,_err

* Pokud má být vytvářen XLS, potom _this.output_format='XLS'

If Empty(_this.output_format) Or _this.output_format<>'XLS'

Return

Endif

If _this.web

* Výstup do Excelu pro WBM musí být uložen v adresáři -> _this.rodic.Path s příponou XLSX nebo XLS

_this.rodic.output_file=_this.rodic.Path+'tmp\'+Stuff(Sys(2015),1,1,'')+'.xlsx'

Else

* Výstup do Excelu pro BM.EXE bude uložen v libovolném pracovním souboru s příponou XLSX nebo XLS

_this.rodic.output_file=bw_param('TMP','.xlsx')

Endif

* _xlapp = OLE object Excelu

_xlapp=Createobject( "Excel.Application")

* _xlwb = objekt dokumentu Excelu

_xlwb=_xlapp.workbooks.Add

* _xlsheet = objekt listu Excelu

_xlsheet=_xlwb.worksheets[1]

Select Data

_i=0

Scan All

* _i obsahuje číslo řádku

_i=_i+1

* sp26datum do prvního sloupce

_xlsheet.cells[_i,1].Value=sp26datum

* sp26nazev do druhého sloupce

_xlsheet.cells[_i,2].Value=sp26nazev

* bw01jmeno do třetího sloupce

_xlsheet.cells[_i,3].Value=bw01jmeno

Endscan

_xlapp.displayalerts=.F.

* uložení dokumentu

_xlwb.SaveAs(_this.rodic.output_file)

_xlapp.displayalerts=.T.

* uzavření dokumentu

_xlwb.Close()

_xlsheet=.F.

_xlwb=.F.

_xlapp=.F.

#ENDSCRIPT

</pre>

Příklad 2. - programovaný SQL dotaz

<pre>

Local _txt,_xlapp,_xlwb,_xlsheet,_err

Local _sql

TEXT TO _sql Noshow

Select sp26,sp26datum,sp26nazev,bw01jmeno,sp26index,spdokobs.sp01id,sp01predlo,sp57typdok,spdokobs.sp57id,sp26koment,sp26disk,sp26soubor From %%%.spdokobs spdokobs,%%%.bwuzivat bwuzivat,%%%.sppredlo sppredlo,%%%.spdoktyp spdoktyp,%%%.sppristu sppristu Where

spdokobs.sp57id=sppristu.sp44vec And sppristu.sp44typ='TDO' And sppristu.bw01uziv=?Tool.uziv And

sppristu.sp44pristu>1 And

spdokobs.bw01uziv=bwuzivat.bw01uziv And spdokobs.sp01id=sppredlo.sp01id And spdokobs.sp57id=spdoktyp.sp57id

ENDTEXT

If !bw_exec(.F.,_sql,'Data')

Return

Endif

* Pokud má být vytvářen XLS, potom _this.output_format='XLS'

If Empty(_this.output_format) Or _this.output_format<>'XLS'

Return

Endif

If _this.web

* Výstup do Excelu pro WBM musí být uložen v adresáři -> _this.rodic.Path s příponou XLSX nebo XLS

_this.rodic.output_file=_this.rodic.Path+'tmp\'+Stuff(Sys(2015),1,1,'')+'.xlsx'

Else

* Výstup do Excelu pro BM.EXE bude uložen v libovolném pracovním souboru s příponou XLSX nebo XLS

_this.rodic.output_file=bw_param('TMP','.xlsx')

Endif

* _xlapp = OLE object Excelu

_xlapp=Createobject( "Excel.Application")

* _xlwb = objekt dokumentu Excelu

_xlwb=_xlapp.workbooks.Add

* _xlsheet = objekt listu Excelu

_xlsheet=_xlwb.worksheets[1]

Select Data

_i=0

Scan All

* _i obsahuje číslo řádku

_i=_i+1

* sp26datum do prvního sloupce

_xlsheet.cells[_i,1].Value=sp26datum

* sp26nazev do druhého sloupce

_xlsheet.cells[_i,2].Value=sp26nazev

* bw01jmeno do třetího sloupce

_xlsheet.cells[_i,3].Value=bw01jmeno

Endscan

_xlapp.displayalerts=.F.

* uložení dokumentu

_xlwb.SaveAs(_this.rodic.output_file)

_xlapp.displayalerts=.T.

* uzavření dokumentu

_xlwb.Close()

_xlsheet=.F.

_xlwb=.F.

_xlapp=.F.

</pre>

Při vytváření stránky informačního panelu je dostupná vlastnost řídícího objektu vytváření stránky OUTPUT_FORMAT, která má při vytváření běžné stránky zobrazované v internetovém prohlížeči hodnotu 'prázdný text' a při vytváření stránky určené pro zobrazení v programu Windows obsahuje hodnotu, kterou je tříznaková přípona souboru. Přitom platí, že je-li stránka vytvářena s nastavenou vlastností OUTPUT_FORMAT řídícího objektu, potom do vytvářených tabulek nejsou vkládány hypertextové odkazy, je potlačeno vytváření automatických hlaviček a patiček stránky a po vytvoření stránky je vyvolán program Windows podle uvedené přípony (hodnoty vlastnosti OUTPUT_FORMAT).

Do stránky informačního panelu je možné vkládat hypertextové odkazy, které zajistí vytvoření stránky s nastavenou vlastností řídícího objektu vytváření stránky OUTPUT_FORMAT třemi způsoby:

- v kódu patičky prezentace stránky

- ve vlastnosti POSTTEXT definice uzlu informačního panelu

- hypertextovým odkazem, který je součástí tabulky informačního panelu

K tomuto účelu slouží např. uživatelská knihovna vkládaného kódu USRPAN. S knihovnou USRPAN je možné zadat v kódu patičky prezentace stránky nebo ve vlastnosti POSTTEXT definice uzlu informačního panelu kód:

<pre>

#SCRIPT

Return zobrazit_v_excelu_a_wordu(_this)

#INCLUDE USRPAN

</pre>

Takto budou do stránky vloženy hypertexty, které převedou do programu Windows celou zobrazenou stránku (může to být více tabulek).

Při vytváření stránky určené pro zobrazení v programu Windows je pro úspěšné uplatnění stylů nutné, aby styly byly přímo obsaženy v souboru předaném programu Windows. Proto je třeba zasáhnou do popisu stylu v prezentaci stránky informačního panelu a v jeho kódu podmínit v případě, že je nastavena vlastnost OUTPUT_FORMAT řídícího objektu, vložení textu stylů do vytvářené stránky.

Např. s užitím knihovny USRPAN:

<pre>

#SCRIPT

Return vrat_styl(_this)

#INCLUDE USRPAN

</pre>

V některých případech je vhodné pro výstup stránky do programu Windows vyloučit některé sloupce tabulky, řádky tabulky,prvky stránek nebo celou jednotlivou tabulku zobrazenou na stránce (poslední platí pro hypertexty v kódu patičky prezentace stránky nebo ve vlastnosti POSTTEXT definice uzlu informačního panelu). V tom případě je možné uvádět ve vlastnosti Podmínka v definici takového sloupce, řádku, prvku stránky nebo podřízeného uzlu výraz 'EMPTY(this.output_format)'.

Pro uzel typu „Prvek stránky“ je možno nastavit tyto parametry typu prvku:

¨ „-„ – bude vytvořen seznam hypertextových odkazů s texty podle vyhodnocení výrazu uvedeného v parametru „výraz názvu“ – počet těchto odkazů odpovídá počtu záznamů vrácených SQL dotazem

¨ „tabulka“ – bude vytvořena tabulka podle popisu tabulky

¨ „odkazy s vyvoláním skriptu“ – bude vytvořen seznam hypertextových odkazů s texty podle vyhodnocení výrazu uvedeného v parametru „výraz názvu“ – počet těchto odkazů odpovídá počtu záznamů vrácených SQL dotazem

Při nastavení atributu „Typ prvku“ s jiným parametrem než „tabulka“ je nutno takový uzel zařadit pod jiný uzel (tzn. vytvořit poduzel uzlu) s nastavením parametru „Návěští – Odkaz na stránku“.

Stisk hypertextu vytvořeného pro uzel s typem prvku „-„ způsobí zobrazení stránky, která je sestavena podle definovaných vztahů s poduzly tohoto uzlu.

Pro uzel „Prvek stránky“ s parametrem „Odkazy s vyvoláním skriptu“ se na záložce Další definuje parametr SKRIPT, ve kterém se uvádí skript v jazyce Foxpro. Tento skript je vyhodnocován při vytváření stránky a vrací jiný skript v jazyce Foxpro, který bude aktivován při stisku odpovídajícího hypertextu a přitom je okno informačního panelu minimalizováno, pokud neprovedl skript při vytváření stránky nastavení _THIS.HREF_WEB=.T..

Pro uzel typu Prvek stránky - tabulka se definují sloupce a elementy sloupců tabulky. Na záložce Sloupce:

¨ sloupec - číslo - jednoznačně identifikuje sloupec - určuje pořadí sloupce

¨ návěští sloupce - určuje návěští sloupce ve vytvářené tabulce. Za znakem ‘~’ (vlnovka) je možno uvádět výraz v syntaxi FoxPro, který je vyhodnocován v okamžiku vytváření tabulky a zjištěná hodnota je vložena do vytvářené tabulky.

¨ HTML–atributy – atributy návěští sloupce následované výrazem v jazyce Foxpro oddělené klávesou Enter (např. TITLE=výraz v jazyce Foxpro)

¨ formát - určuje formát zobrazení hodnoty ve sloupci (např. 999 999 999.99). V tomto atributu je možno uvádět formáty času, zapsané v následujícím tvaru:

- @*TM - převádí numerickou hodnotu, která odpovídá počtu vteřin do tvaru MMM:SS

- @*TH - převádí numerickou hodnotu, která odpovídá počtu vteřin do tvaru HHH:MM

Oba tyto formáty je možno rovněž uvádět ve tvaru @Z*TM, resp. @Z*TH, kterými je do výstupu vkládán prázdný text v případě, že je formátovaný počet vteřin nulový (uvedené formáty nejsou součástí jazyka Visual Foxpro).

¨ podmínka – podmínka zařazení sloupce do tabulky (výraz v syntaxi FoxPro)

¨ výraz třídění – výraz třídění dat vrácený dotazem SQL (výraz v syntaxi FoxPro) – pro takto definovaný sloupec je ve výsledné HTML stránce návěští sloupce uvedeno ve tvaru hypertextového odkazu. Výraz třídění může být uveden znakem '*'. Tímto způsobem se definuje střídavé vzestupné a sestupné třídění při opakovaném stisku hypertextu návěští sloupce. Po stisku tohoto hypertextového odkazu je stránka přezobrazena setříděná podle hodnot získaných na základě výrazu třídění sloupce.

Poznámka:

Výraz třídění by měl reflektovat možnost výskytu hodnoty NULL v obsažených atributech (obvykle se to týká datumových atributů). Např. NVL(sp34datuko,DTOT({}))

¨ zarovnání ve sloupci - vpravo / na střed / vlevo

¨ součtový sloupec - na konci tabulky bude vytvořen součtový řádek se součtem v tomto sloupci (volba Ano/Ne)

Příklad definice HTML-atributů návěští sloupce:

TITLE='Setřízení tabulky podle data splatnosti pohledávky'

TARGET=iif(this.web,'_blank','_self')

Záložka Další poskytuje uživateli možnost nastavit pro rozsáhlé tabulky zobrazované na stránkách informačního panelu stránkování:

¨ uzel – identifikátor a název uzlu

¨ prázdná, Ř. hlavičky, Ř. patičky – příznak, zda vytvářená tabulka může být prázdná (volba Ano/Ne) a počet řádků hlavičky a patičky

¨ sektor – pozice sektoru stránky ve tvaru písmeno+číslo – písmeno určuje pozici v ose X, číslo určuje pozici v ose Y + popis stylu tabulky rozvržení sektorů

¨ počet z. – volba, zda zobrazovat počet záznamů při uplatnění uzlu na stránce jako odkaz (možnosti Ano/Ne)

¨ stránkování – uvádí se číslo, které znamená, že po zadaném počtu záznamů se má stránkovat (hodnota nula znamená, že se stránkování neprovádí). V případě, že počet záznamů pro vytvoření tabulky nepřekročí zde uvedené číslo, potom se řádek s odkazy pro přechod na stránky tabulky nevytváří.

¨ odkazy – výběr z možností v překryvném seznamu (před tabulku/za tabulku/před i za tabulku) – určuje, kam má být umístěn řádek s odkazy pro přechod na jednotlivé stránky

¨ zahrnout – výběr z možností v překryvném seznamu (do tabulky/mimo tabulku) – určuje, jestli má být řádek s odkazy pro přechod na jednotlivé stránky umístěn jako součást tabulky nebo má být umístěn mimo tabulku

¨ tag – text - určuje grafické vlastnosti řádku s odkazy (např. TD STYLE="background:yellow; font-size:120%; text-align=center"), při umístění řádku s odkazy mimo tabulku jsou tagy TD a TH nahrazeny za tag DIV

¨ návěští - text - je určeno pro doplnění textu do řádku s odkazy (např.: <B>Stránky</B>). V textu návěští se může vyskytovat makro ###, které určuje umístění bloku s odkazy v textu návěští (např. 'Text před odkazy ### Text za odkazy' může zobrazit 'Text před odkazy 1 2 3 4 >>> Text za odkazy')

¨ refresh – v tomto atributu se udává čas (ve vteřinách), po jehož uplynutí má být stránka obnovena (příklad z praxe: ve skladu se skladníkovi automaticky aktualizuje stránka, na které se mu zobrazují skladové výdejky vytvářené na jiném pracovišti)

¨ pretext – text zobrazený na HTML před vyhodnocením uzlu

¨ posttext – text zobrazený na HTML po vyhodnocení uzlu

¨ skript – kód v jazyce FoxPro

¨ atributy elementu BODY - pro tvar definice platí stejná pravidla jako pro definování atributů elementů resp. sloupců, s těmito rozdíly:

a/ je možné použít vložení definice uložené v knihovnách vkládaného kódu klausulí #INCLUDE

b/ pokud je
prvním slovem definice slovo NODEFAULT, potom nebudou v elementu BODY atributy
'topmargin=0 id="bodyID"
class = "dtBODY"',
které jsou jinak do elementu vkládány automaticky, např.: onLoad="return relatedActions('ob11id','sp99','sp24idmj','ob02cj01c');"

¨ poznámka – libovolný komentář

Na záložce Řádky se definuje:

¨ Ř – číslo pásu/číslo řádku/návěští řádku - určuje návěští řádku ve vytvářené tabulce. Za znakem ‘~’ (vlnovka) je možno uvádět výraz v syntaxi FoxPro, který je vyhodnocován v okamžiku vytváření tabulky a zjištěná hodnota je vložena do vytvářené tabulky.

¨ podmínka – podmínka zařazení řádku do tabulky (výraz v syntaxi FoxPro)

atributy elementu – atributy elementu řádku (TR) oddělené enterem

V řádku s odkazy jsou odkazy na jednotlivé stránky představovány jejich pořadovými čísly a v případě, že byla data pro zobrazení tabulky setříděna příkazem FoxPro INDEX (tzn. že pro tabulku se uplatní Výraz třídění nebo ji uživatel setřídil klikem na návěští některého jejího sloupce), zobrazuje se při pohybu myší přes číslo stránky text (tooltip), který je vyhodnocením indexového výrazu pro první záznam zobrazovaný na stránce.

V řádku s odkazy je zobrazován seznam maximálně 21 odkazů na jednotlivé stránky tabulky. V případě, že v tomto seznamu není obsažena první stránka, potom řádek s odkazy obsahuje také odkaz s textem '<<<', který způsobuje přechod na stránku s pořadovým číslem (aktuálně_zobrazená_stránka - 20). V případě, že v seznamu odkazů není obsažena poslední stránka, potom řádek s odkazy obsahuje také odkaz s textem '>>>', který způsobuje přechod na stránku s pořadovým číslem (aktuálně_zobrazená_stránka + 20). Pokud tabulka obsahuje sloupce, které je možné třídit, potom je vždy po setřídění klikem na návěští sloupce zobrazována její první stránka.

Pro stránkovanou tabulku musí platit, že se identifikace uzlu informačního panelu, kterým je tabulka definována (včetně Alias - pokud se tabulka uplatňuje na stránce informačního panelu jako poduzel), vyskytne při vytváření stránky informačního panelu právě jednou.

Narozdíl od funkčnosti třídění nestránkované tabulky (klik na návěští sloupce – kde zároveň platí, že pokud je tabulka součástí skupiny tabulek, potom je setříděná tabulka zobrazena samostatně, tzn. není zobrazována stránka, ve které je tabulka obsažena, ale samostatná stránka tabulky), funguje třídění stránkované tabulky (klik na návěští sloupce) tak, že setříděná tabulka je zobrazována znovu jako součást skupiny tabulek. Stejné je chování při přechodu na jinou stránku tabulky, tzn. při přechodu na jinou stránku tabulky je zobrazována stránka informačního panelu, ve které je tabulka obsažena.

Poznámka: Této vlastnosti je možné využít i pro tabulky s možností třídění klikem na návěští sloupce, pro které platí pravidlo její jednoznačné identifikace ve vytvářené stránce informačního panelu a přitom pro tuto tabulku nemá smysl stránkovat. Stačí zadat do vlastnosti uzlu tabulky 'Stránkování' velkou hodnotu a potom bude po kliku na návěští sloupce zobrazována stránka informačního panelu, ve které je tabulka obsažena.

Záložka Sektory poskytuje uživateli možnost definovat pro každou stránku informačního panelu její rozčlenění na sektory. Sektory jsou ve výsledném HTML textu realizovány pomocí tabulky (dále jen tabulky rozvržení sektorů). Pro každý sektor se definuje:

¨ identifikace sektoru – je tvořena 2 znaky – označuje pozici sektoru stránky ve tvaru písmeno + číslo – písmeno určuje pozici v ose X, číslo určuje pozici v ose Y

¨ maximální počet sloupců sloučených do sektoru – číselná hodnota

¨ maximální počet řádků sloučených do sektoru – číselná hodnota

¨ popis sektoru – slovní popis sektoru (tento atribut se neuplatňuje ve výstupu)

¨ prázdný sektor – překryvný seznam Ano/Ne – určuje, zda má být sektor zobrazen i v případě, když je prázdný

¨ pretext – text vložený před buňku selektoru

¨ tag buňky – výraz, který definuje tag buňky vztaženého elementu

¨ posttext – text vložený za buňku sektoru

¨ poznámka – libovolný komentář k sektoru

Na záložce Poduzly uzlu se definují uzly připojené k danému uzlu. Typicky se k uzlům typu Informační panel připojují uzly typu 'Stránka panelu' a pod uzly typu 'Stránka panelu' uzly typu 'Prvek stránky'.

Uvádí se:

¨ uzel - identifikace uzlu

¨ pozice sektoru stránky ve tvaru písmeno + číslo

¨ pořadí - určuje pořadí zpracování uzlu (tj. také zobrazení výstupu uzlu na stránce)

¨ alias - umožňuje použít stejný uzel jako podřízený opakovaně

¨ název podřízeného uzlu - je-li uveden, potom je na stránce zobrazen tento text jako návěští (jinak je zobrazen text uvedený v definici uzlu)

¨ parametry – skutečné parametry použité v doplnění where poduzlu (předané do doplnění příkazu SQL uzlu, kde jsou pozičně reprezentované jako ?_p1, ?_p2 .... (maximální počet parametrů je 14))

¨ atributy - jsou doplňující atributy SQL dotazu podřízeného uzlu, které jsou vkládány do tohoto dotazu přímo za SELECT. Jsou-li uvedeny atributy, potom za posledním musí být uvedena čárka. Např. 'adadsat.ad01adsat, adspoj.ad11jmeno,' nebo 'TOP 200'

¨ from - je doplnění SQL dotazu podřízeného uzlu v jeho části za FROM

¨ where - je doplnění SQL dotazu podřízeného uzlu v jeho části za WHERE

¨ výraz třídění – výraz třídění dat vrácených dotazem SQL

¨ podmínka – podmínka zařazení poduzlu

Záložka Další obsahuje atributy, kde je možno se na nadefinované sektory odkazovat:

¨ sektor – pozice sektoru stránky ve tvaru písmeno + číslo

¨ popis stylu tabulky rozvržení sektorů (např. class=“dtTABLE“ cellspacing=“0“)

¨ alias - umožňuje použít stejný uzel jako podřízený opakovaně

¨ index - identifikátor pomocí kterého se je možné hypertextově odkazovat v XML dokumentech

¨ PRETEXT - text vložený před obsah vytvořený zpracováním uzlu

¨ POSTTEXT - text vložený za obsah vytvořený zpracováním uzlu

V atributech PRETEXT a POSTTEXT je možné uvádět kód v jazyce Foxpro. V tomto případě se uvádí na začátku textu slovo #SCRIPT. Tento kód musí vracet text, který je vložen do stránky.

Příklad vložení tabulky do sektoru:

¨ vlastnost Pretext sektoru -

<pre>

<table class="dtTABLE_papayawhip" cellspacing="0"><tr><th>Mám řešit úkoly</th></tr><td>

</pre>

¨ vlastnost Posttext sektoru -

<pre>

</tr></table></td>

</pre>

Na záložce Elementy sloupců se uvádí:

¨ sloupec - určuje sloupec umístění elementu (číslo pásu – řádku – sloupce)

¨ pořadí elementu

¨ break - Ano/Ne - za element vložení do sloupce může být vloženo odřádkování

¨ výraz - výraz v syntaxi Foxpro jehož vyhodnocená hodnota bude vložena do tabulky

¨ hypertext - s elementem bude spojen hypertextový odkaz

¨ jiný název – jiný název uzlu informačního panelu – za znakem ~ je možno zadat výraz (překrývá jiný název v hypertextu)

¨ parametry – skutečné parametry použité v doplnění where hypertextového odkazu (přebíjejí parametry uvedené v definici hypertextového odkazu)

¨ tučně - zobrazení elementu tučně

¨ kurzíva - zobrazení elementu kurzívou

¨ podtržené - zobrazení elementu podtrženě

¨ tag - jiný tag elementu - např. H2 - vloží <H2>[hodnota elementu]</H2>

¨ HTML–atributy – atributy elementu následované výrazem v jazyce Foxpro oddělené klávesou Enter (např. TITLE=výraz v jazyce Foxpro). Určené HTML-atributy vytvářeného elementu tabulky se uplatí pouze v případě, že:

- element má zaškrtnuto – Tučně nebo Kurzíva nebo Podtržené

- nebo je s elementem spojen hypertextový odkaz

- nebo má element uveden jiný tag (např. neutrální DIV)

¨ podmínka – podmínka zařazení elementu na stránku

Příklad definice HTML-atributů vytvářeného elementu tabulky:

TITLE='Kategorie adresáta:'+chr(13)+tool.sql_dotaz([select list(trim(ad08kateg),char(13)) from %%%.adkatads,%%%.adkat where adkatads.ad01id=?_p1 and adkat.ad08id=adkatads.ad08id],ad01id)

Uživatel má možnost doplnění elementu TR tabulky o další atributy. Na záložce Řádky je k tomuto účelu určena položka „Atributy elementu“. Dále uvedená pravidla se uplatňují také pro odpovídající nastavení návěští sloupce a elementu tabulky. V těchto položkách se uvádějí jednotlivé HTML – atributy elementu následované výrazem v jazyce Foxpro, oddělené klávesou Enter.

Př.: BGCOLOR=IIF(MOD(this.citac_radku,2)=1,'YELLOW','')

Pokud je hodnota vyhodnoceného výrazu prázdná, potom není atribut do elementu vkládán, jinak je hodnota atributu uvedena ohraničením apostrofy (pro uvedený příklad BGCOLOR="YELLOW").

Je-li název atributu uvedený znakem vlnovka, potom hodnota atributu není ohraničena apostrofy.

Např.: ~BGCOLOR=IIF(MOD(this.citac_radku,2)=1,'YELLOW','') -> BGCOLOR=YELLOW

Syntaxe ~= vkládá mezi atributy elementu přímo text bez jakéhokoliv formátování.

Např.: ~=IIF(MOD(this.citac_radku,2)=1,'BGCOLOR=YELLOW','') -> BGCOLOR=YELLOW

Stejné nastavení (tzn. položka „atributy elementů TR“) lze využít v činnosti Prezentace stránek panelů. V případě, že je uvedeno nastavení u jednotlivého řádku v definici uzlů inf. panelů a zároveň v prezentaci stránky, tak se poté uplatní obě tato nastavení.

Poznámka:

Součástí „návodů a balíčků“ je balíček obsahující definice uzlů informačního panelu, které vytvářejí stránky odpovídající hlavnímu menu programu (nebo jeho části). Z těchto stránek je možné spouštět činnosti BM stejně jako z hlavního menu programu.

Datový model

  • IPUZEL Uzel informačního panelu
    • IPDRUH Druh uzlu informačního panelu
      • SPPRISTU Přístupové právo uživatele k věci
    • IPPREZEN Popis prezentace stránky panelu/prvku stránky
    • BWIKONA Ikona v BM

    • Formulář

    Formulář činnosti - Výběr makra
Mřížka [Uzly]
Uzel | Identifikátor uzlu informačního panelu
Název uzlu inf. panelu | Název uzlu informačního panelu
Listovací rámeček
Stránka #1 Uzly
Druh | Identifikace druhu uzlu
Název druhu uzlu | Název druhu uzlu
Prezentace | Identifikátor prezentace
Název prezentace | Název prezentace
Ikona | Identifikace ikony
Název ikony | Název ikony
Typ | Typ uzlu informačního panelu
Adresa | Přímá webová adresa volaná při aktivaci stránky
Typ prvku | Typ prvku stránky
Spojení | Identifikace spojení
Výraz názvu | Výraz názvu uzlu informačního panelu
Výraz třídění | Výraz třídění dat vrácených dotazem SQL
SQL dotaz | SQL dotaz
Stránka #2 Další
Prázdná | Vytvářená tabulka může být prázdná
Ř. hlavičky | Počet řádků hlavičky
Ř. patičky | Počet řádků patičky
Sektor | Pozice sektoru stránky ve tvaru písmeno+cifra - písmeno určuje pozici v ose X, cifra určuje pozici v ose Y
Styl tabulky sektorů | Popis stylu tabulky rozvržení sektorů
Počet z. | Zobrazovat počet záznamů při uplatnění uzlu na stránce jako odkaz
Stránkování | Stránkovat po zadaném počtu záznamů (0=nestánkovat)
Odkazy | Umístění řádky s odkazy na stránky stránkování
Zahrnout | Zahrnout řádku s odkazy stránkování do tabulky nebo mimo tabulku
Tag | Tag odkazů stránkování
Návěští | Návěští odkazů stránkování (text ### může určovat umístění odkazů v textu návěští)
Refresh | Interval obnovení stránky ve vteřinách
PRETEXT | Text zobrazený na HTML před vyhodnocením uzlu
POSTTEXT | Text zobrazený na HTML po vyhodnocení uzlu
SKRIPT | Script typu prvku 'Odkazy s vyvoláním skriptu' v jazyce Foxpro, který vrací skript v jazyce Foxpro vyvolaný pro tento hypertextový odkaz
Atributy elementu BODY | Atributy elementu BODY oddělené enterem (např.TITLE=výraz v jazyce Foxpro)
Poznámka | Poznámka
Stránka #3 Sektory
Mřížka [Sektory]
Sektor | Pozice sektoru stránky ve tvaru písmeno+cifra - písmeno určuje pozici v ose X, cifra určuje pozici v ose Y
MaxCol | Maximální počet sloučených sloupců sektoru
MaxRow | Maximální počet sloučených řádků sektoru
Popis | Popis sektoru - neuplatňuje se ve výstupu
Prázdný sektor | Zobrazovat prázdný sektor Ano/Ne
PRETEXT | Text vložený před buňku sektoru
Tag buňky | Tag buňky
POSTTEXT | Text vložený za buňku sektoru
Poznámka | Poznámka
Stránka #4 Poduzly uzlu
Mřížka [Poduzly uzlu]
Uzel | Identifikátor poduzlu informačního panelu
Název uzlu inf. panelu | Název uzlu informačního panelu
Sektor | Pozice sektoru stránky ve tvaru písmeno+cifra - písmeno určuje pozici v ose X, cifra určuje pozici v ose Y
Pořadí | Pořadí
Alias | Alias poduzlu informačního panelu
Název uzlu informačního panelu (alias) | Název uzlu informačního panelu (alias) - za znakem ~ je možné zadat výraz
Návěští | Návěští poduzlu Rozbalené/Nerozbalené/Žádné
Parametry | Skutečné parametry použité v doplnění where poduzlu
Atributy | Doplnění SQL dotazu na jeho začátku (je-li uveden atribut musí být posledním textu znakem čárka)
FROM | Doplnění FROM dotazu SQL poduzlu
WHERE | Doplnění WHERE dotazu SQL poduzlu
Výraz třídění | Výraz třídění dat vrácených dotazem SQL
Podmínka | Podmínka zařazení poduzlu
Stránka #5 Další
Uzel | Identifikátor poduzlu informačního panelu
Název uzlu inf. panelu | Název uzlu informačního panelu
Alias | Alias poduzlu informačního panelu
Název uzlu informačního panelu (alias) | Název uzlu informačního panelu (alias) - za znakem ~ je možné zadat výraz
Index | Index pro nabídku pro hypertext v při editaci Word v XML dokumentu
PRETEXT | Text zobrazený na HTML před vyhodnocením uzlu
POSTTEXT | Text zobrazený na HTML po vyhodnocení uzlu
Poznámka | Poznámka
Stránka #6 Pásy
Mřížka [Pásy]
P | Číslo pásu
Typ | Typ pásu Datový/Popisný
Podmínka | Podmínka zařazení pásu do tabulky
Opakování | Počet opakování popisného pásu
Aktualizace | Datum aktualizace
Script | Script prvku v jazyce Foxpro vyvolávaný v různých fázích tvorby pásu tabulky
Poznámka | Poznámka
Stránka #7 Řádky
Mřížka [Řádky]
P | Číslo pásu
Ř | Číslo řádku
Návěští řádku | Návěští řádku
Podmínka | Podmínka zařazení řádku do tabulky
Atributy elementu | Atributy elementu řádku (TR) oddělené enterem
Stránka #8 Sloupce
Mřížka [Sloupce]
P | Číslo pásu
S | Číslo sloupce
Návěští sloupce | Návěští sloupce
Atributy návěští | Atributy elementu návěští sloupce oddělené enterem (např.TITLE=výraz v jazyce Foxpro)
Formát | Formátovací maska pro zobrazení hodnoty
Podmínka | Podmínka zařazení sloupce do tabulky
Výraz třídění | Výraz třídění dat vrácených dotazem SQL (výraz uvedený znakem * definuje střídavé vzestupené a sestupné třídění při opakovaném stisku hypertextu návěští sloupce)
Zarovnání | Zarovnání sloupce vpravo/střed/vlevo
Součtový sloupec | Součtový sloupec
Stránka #9 Elementy
Mřížka [Elementy]
Element | Číslo pásu
Ř | Číslo řádku
S | Číslo sloupce
Pořadí | Pořadí elementu
Break | Po vložení elementu následuje tag
Výraz | Výraz pro stanovení hodnoty elementu
Hypertext | Identifikace hypertextového odkazu
Jiný název | Jiný název uzlu informačního panelu - za znakem ~ je možné zadat výraz (překrývá jiný název v hypertextu)
Parametry | Skutečné parametry použité v doplnění where hypertextového odkazu - přebíjejí parametry uvedené v definici hypertextového odkazu
Tučně | Zobrazit tučně
Kurzíva | Zobrazit kurzívou
Podtržené | Zobrazit podtržené
Tag | Tag elementu
Atributy | Atributy elementu oddělené enterem (např.TITLE=výraz v jazyce Foxpro)
Podmínka | Podmínka zařazení elementu na stránku
Stránka #10 Buňky
Mřížka [Buňky]
Buňka | Číslo pásu
Ř | Číslo řádku
S | Číslo sloupce
Tag buňky | Tag buňky
Uzel | Identifikátor poduzlu informačního panelu
Název uzlu inf. panelu | Název uzlu informačního panelu
Název uzlu informačního panelu (alias) | Název uzlu informačního panelu (alias) - za znakem ~ je možné zadat výraz
Návěští | Návěští poduzlu Rozbalené/Nerozbalené/Žádné
Parametry | Skutečné parametry použité v doplnění where poduzlu
Atributy | Doplnění SQL dotazu na jeho začátku (je-li uveden atribut musí být posledním textu znakem čárka)
FROM | Doplnění FROM dotazu SQL poduzlu
WHERE | Doplnění WHERE dotazu SQL poduzlu
Výraz třídění | Výraz třídění dat vrácených dotazem SQL
Stránka #11 Výběr
Uzel | Identifikátor uzlu informačního panelu
Název uzlu inf. panelu | Název uzlu informačního panelu
Druh | Identifikace druhu uzlu
Prezentace | Identifikátor prezentace
Ikona | Identifikace ikony
Typ | Typ uzlu informačního panelu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Uzly] činnosti - Výběr makra

    Mřížka [Uzly] činnosti - Výběr makra
Uzel | Identifikátor uzlu informačního panelu
Název uzlu inf. panelu | Název uzlu informačního panelu
Druh | Identifikace druhu uzlu
Název druhu uzlu | Název druhu uzlu
Prezentace | Identifikátor prezentace
Název prezentace | Název prezentace
Ikona | Identifikace ikony
Název ikony | Název ikony
Typ | Typ uzlu informačního panelu
Typ prvku | Typ prvku stránky

    Mřížka [Sektory] činnosti - Výběr makra

    Mřížka [Sektory] činnosti - Výběr makra
Sektor | Pozice sektoru stránky ve tvaru písmeno+cifra - písmeno určuje pozici v ose X, cifra určuje pozici v ose Y
MaxCol | Maximální počet sloučených sloupců sektoru
MaxRow | Maximální počet sloučených řádků sektoru
Popis | Popis sektoru - neuplatňuje se ve výstupu

    Mřížka [Poduzly uzlu] činnosti - Výběr makra

    Mřížka [Poduzly uzlu] činnosti - Výběr makra
S. | Pozice sektoru stránky ve tvaru písmeno+cifra - písmeno určuje pozici v ose X, cifra určuje pozici v ose Y
Pořadí | Pořadí
Uzel | Identifikátor poduzlu informačního panelu
Alias | Alias poduzlu informačního panelu
Název uzlu | Název uzlu informačního panelu

    Mřížka [Pásy] činnosti - Výběr makra

    Mřížka [Pásy] činnosti - Výběr makra
P | Číslo pásu
Typ | Typ pásu Datový/Popisný

    Mřížka [Řádky] činnosti - Výběr makra

    Mřížka [Řádky] činnosti - Výběr makra
P | Číslo pásu
Ř | Číslo řádku
Návěští řádku | Návěští řádku

    Mřížka [Sloupce] činnosti - Výběr makra

    Mřížka [Sloupce] činnosti - Výběr makra
P | Číslo pásu
S | Číslo sloupce
Návěští sloupce | Návěští sloupce

    Mřížka [Elementy] činnosti - Výběr makra

    Mřížka [Elementy] činnosti - Výběr makra
P | Číslo pásu
Ř | Číslo řádku
S | Číslo sloupce
Pořadí | Pořadí elementu
Výraz | Výraz pro stanovení hodnoty elementu
Break | Po vložení elementu následuje tag

    Mřížka [Buňky] činnosti - Výběr makra

    Mřížka [Buňky] činnosti - Výběr makra
P | Číslo pásu
Ř | Číslo řádku
S | Číslo sloupce
Tag buňky | Tag buňky

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Editovat kód vlastnosti | Editovat kód vlastnosti
F6 | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností
F9 | Spustit informační panel | Spustit informační panel
- | Kontrolní kompilace | Kontrolní kompilace
- | Zobrazovat na stránce informačního panelu | Zobrazit na stránce informačního panelu pro aktuálního uživatele
- | Definice maker | Definice maker
F2 | Definice uzlů inf.panelů | Definice uzlů informačních panelů
F2 | Druhy uzlů inf.panelů | Druhy uzlů informačních panelů
F2 | Hypertextové odkazy | Hypertextové odkazy
F2 | Prezentace stránek panelů | Prezentace stránek panelů
F2 | Seznam ikon | Seznam ikon používaných v BM
F2 | Spojení importů-exportů | Definovaná spojení importů-exportů
F2 | Výběr makra | Výběr makra

    Atributy tisku

    Základní údaje
Uzel | Identifikátor uzlu informačního panelu | IPUZEL_ip01id | C(12)
Název uzlu inf. panelu | Název uzlu informačního panelu | IPUZEL_ip01nazuzl | C(40)
Druh | Identifikace druhu uzlu | IPUZEL_ip05id | C(6)
Název druhu uzlu | Název druhu uzlu | IPDRUH_ip05nazdru | C(40)
Prezentace | Identifikátor prezentace | IPUZEL_ip06id | C(6)
Název prezentace | Název prezentace | IPPREZEN_ip06nazpre | C(40)
Ikona | Identifikace ikony | IPUZEL_bw88id | C(6)
Název ikony | Název ikony | BWIKONA_bw88naziko | C(40)
Typ | Typ uzlu informačního panelu | Výpočet | C(16)
Adresa | Přímá webová adresa volaná při aktivaci stránky | IPUZEL_ip01priadr | M
Typ prvku | Typ prvku stránky | Výpočet | C(26)
Výraz názvu | Výraz názvu uzlu informačního panelu | IPUZEL_ip01vyrlab | M
Spojení | Identifikace spojení | IPUZEL_sp94id | C(6)
SQL dotaz | SQL dotaz | IPUZEL_ip01sql | M
Výraz třídění | Výraz třídění dat vrácených dotazem SQL | IPUZEL_ip01vyrazo | M
Sektor | Pozice sektoru stránky ve tvaru písmeno+cifra - písmeno určuje pozici v ose X, cifra určuje pozici v ose Y | IPUZEL_ip17id | C(2)
Styl tabulky sektorů | Popis stylu tabulky rozvržení sektorů | IPUZEL_ip01poptab | M
Počet z. | Zobrazovat počet záznamů při uplatnění uzlu na stránce jako odkaz | IPUZEL_ip01dcount | N(1)
Stránkování | Stránkovat po zadaném počtu záznamů (0=nestánkovat) | IPUZEL_ip01maxrec | N(9)
Odkazy | Umístění řádky s odkazy na stránky stránkování | Výpočet | C(17)
Zahrnout | Zahrnout řádku s odkazy stránkování do tabulky nebo mimo tabulku | Výpočet | C(12)
Tag | Tag odkazů stránkování | IPUZEL_ip01maxret | M
Návěští | Návěští odkazů stránkování (text ### může určovat umístění odkazů v textu návěští) | IPUZEL_ip01maxren | M
Prázdná | Vytvářená tabulka může být prázdná | Výpočet | C(3)
Ř. hlavičky | Počet řádků hlavičky | IPUZEL_ip01herows | N(3)
Ř. patičky | Počet řádků patičky | IPUZEL_ip01forows | N(3)
PRETEXT | Text zobrazený na HTML před vyhodnocením uzlu | IPUZEL_ip01txpre | M
POSTTEXT | Text zobrazený na HTML po vyhodnocení uzlu | IPUZEL_ip01txpost | M
SKRIPT | Script typu prvku 'Odkazy s vyvoláním skriptu' v jazyce Foxpro, který vrací skript v jazyce Foxpro vyvolaný pro tento hypertextový odkaz | IPUZEL_ip01script | M
Poznámka | Poznámka | IPUZEL_ip01koment | M

    Při pohybu v Pásy
P | Číslo pásu | IPPAS_ip14pas | N(3)
Typ | Typ pásu Datový/Popisný | Výpočet | C(7)
Podmínka | Podmínka zařazení pásu do tabulky | IPPAS_ip14when | M
Opakování | Počet opakování popisného pásu | IPPAS_ip14opak | N(3)
Script | Script prvku v jazyce Foxpro vyvolávaný v různých fázích tvorby pásu tabulky | IPPAS_ip14script | M
Aktualizace | Datum aktualizace | IPPAS_sp00datakt | T
Poznámka | Poznámka | IPPAS_ip14koment | M

    Při pohybu v Řádky
P | Číslo pásu | IPRADEK_ip14pas | N(3)
Ř | Číslo řádku | IPRADEK_ip15radek | N(3)
Návěští řádku | Návěští řádku | IPRADEK_ip15label | M
Podmínka | Podmínka zařazení řádku do tabulky | IPRADEK_ip15when | M

    Při pohybu v Elementy
P | Číslo pásu | IPRADELE_ip14pas | N(3)
Ř | Číslo řádku | IPRADELE_ip15radek | N(3)
S | Číslo sloupce | IPRADELE_ip02sloup | N(3)
Pořadí | Pořadí elementu | IPRADELE_ip03porad | N(3)
Break | Po vložení elementu následuje tag | Výpočet | C(3)
Výraz | Výraz pro stanovení hodnoty elementu | IPRADELE_ip03vyraz | M
Hypertext | Identifikace hypertextového odkazu | IPRADELE_ip08id | C(12)
Jiný název | Jiný název uzlu informačního panelu - za znakem ~ je možné zadat výraz (překrývá jiný název v hypertextu) | IPRADELE_ip03nazuzl | M
Parametry | Skutečné parametry použité v doplnění where hypertextového odkazu - přebíjejí parametry uvedené v definici hypertextového odkazu | IPRADELE_ip03param | M
Tučně | Zobrazit tučně | Výpočet | C(3)
Kurzíva | Zobrazit kurzívou | Výpočet | C(3)
Podtržené | Zobrazit podtržené | Výpočet | C(3)
Tag | Tag elementu | IPRADELE_ip03tag | M
Atributy | Atributy elementu oddělené enterem (např.TITLE=výraz v jazyce Foxpro) | IPRADELE_ip03attrib | M
Podmínka | Podmínka zařazení elementu na stránku | IPRADELE_ip03when | M

    Při pohybu v Sektory
Sektor | Pozice sektoru stránky ve tvaru písmeno+cifra - písmeno určuje pozici v ose X, cifra určuje pozici v ose Y | IPSEKTOR_ip17id | C(2)
MaxCol | Maximální počet sloučených sloupců sektoru | IPSEKTOR_ip17maxcol | N(2)
MaxRow | Maximální počet sloučených řádků sektoru | IPSEKTOR_ip17maxrow | N(2)
Popis | Popis sektoru - neuplatňuje se ve výstupu | IPSEKTOR_ip17popis | C(40)
Tag buňky | Tag buňky | IPSEKTOR_ip17tag | M
Poznámka | Poznámka | IPSEKTOR_ip17koment | M
PRETEXT | Text vložený před buňku sektoru | IPSEKTOR_ip17txpre | M
POSTTEXT | Text vložený za buňku sektoru | IPSEKTOR_ip17txpost | M
Prázdný sektor | Zobrazovat prázdný sektor Ano/Ne | Výpočet | C(3)

    Při pohybu v Sloupce
P | Číslo pásu | IPSLOUPE_ip14pas | N(3)
S | Číslo sloupce | IPSLOUPE_ip02sloup | N(3)
Návěští sloupce | Návěští sloupce | IPSLOUPE_ip02label | M
Atributy návěští | Atributy elementu návěští sloupce oddělené enterem (např.TITLE=výraz v jazyce Foxpro) | IPSLOUPE_ip02attrib | M
Formát | Formátovací maska pro zobrazení hodnoty | IPSLOUPE_ip02format | C(40)
Zarovnání | Zarovnání sloupce vpravo/střed/vlevo | Výpočet | C(6)
Součtový sloupec | Součtový sloupec | Výpočet | C(3)
Podmínka | Podmínka zařazení sloupce do tabulky | IPSLOUPE_ip02when | M

    Při pohybu v Poduzly
Uzel | Identifikátor poduzlu informačního panelu | IPUZELP_ip01id2 | C(12)
Alias | Alias poduzlu informačního panelu | IPUZELP_ip04alias | C(6)
Název uzlu informačního panelu (alias) | Název uzlu informačního panelu (alias) - za znakem ~ je možné zadat výraz | IPUZELP_ip04nazuzl | M
Sektor | Pozice sektoru stránky ve tvaru písmeno+cifra - písmeno určuje pozici v ose X, cifra určuje pozici v ose Y | IPUZELP_ip17id | C(2)
Pořadí | Pořadí | IPUZELP_ip04porad | N(3)
Návěští | Návěští poduzlu Rozbalené/Nerozbalené/Žádné | Výpočet | C(16)
Index | Index pro nabídku pro hypertext v při editaci Word v XML dokumentu | IPUZELP_ip04index | C(40)
Parametry | Skutečné parametry použité v doplnění where poduzlu | IPUZELP_ip04param | M
Atributy | Doplnění SQL dotazu na jeho začátku (je-li uveden atribut musí být posledním textu znakem čárka) | IPUZELP_ip04attr | M
FROM | Doplnění FROM dotazu SQL poduzlu | IPUZELP_ip04from | M
WHERE | Doplnění WHERE dotazu SQL poduzlu | IPUZELP_ip04where | M
Výraz třídění | Výraz třídění dat vrácených dotazem SQL | IPUZELP_ip04vyrazo | M
PRETEXT | Text zobrazený na HTML před vyhodnocením uzlu | IPUZELP_ip04txpre | M
POSTTEXT | Text zobrazený na HTML po vyhodnocení uzlu | IPUZELP_ip04txpost | M
Poznámka | Poznámka | IPUZELP_ip04koment | M

    Viz.také

    Editovat kód vlastnosti | Knihovny vkládaného kódu | Spustit informační panel | Kontrolní kompilace | Zobrazovat na stránce informačního panelu | Definice maker | Druhy uzlů inf.panelů | Hypertextové odkazy | Prezentace stránek panelů | Seznam ikon | Spojení importů-exportů | Výběr makra


Editor uzlů informačních panelů

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Druhy uzlů inf.panelů

Popis

V této činnosti uživatel definuje jednotlivé druhy informačních panelů. U každého druhu se zadává identifikace a jeho název. Po stisku Ctrl B nebo aktivací příslušné činnosti z menu Volby je možno ke každému druhu nadefinovat přístupová práva.

Datový model

  • IPDRUH Druh uzlu informačního panelu
    • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Druh]
Druh | Identifikace druhu uzlu
Název druhu uzlu | Název druhu uzlu
Poznámka | Poznámka

    Mřížka [Druh] činnosti - Přístupová práva

    Mřížka [Druh] činnosti - Přístupová práva
Druh | Identifikace druhu uzlu
Název druhu uzlu | Název druhu uzlu

    Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci

    Atributy tisku

    Základní údaje
Druh | Identifikace druhu uzlu | IPDRUH_ip05id | C(6)
Název druhu uzlu | Název druhu uzlu | IPDRUH_ip05nazdru | C(40)
Poznámka | Poznámka | IPDRUH_ip05koment | M

    Viz.také

    Přístupová práva


Prezentace stránek panelů

Popis

Tato činnosti je určena pro nastavení stylů pro zobrazení stránky informačního panelu. Definuje se :

¨ identifikace a název prezentace

¨ popis stylu stránky - HTML text, který definuje styly

¨ kód hlavičky – umožňuje nastavit přizpůsobení vzhledu hlavičky informačního panelu. Tento kód (v jazyce Foxpro) musí vracet textovou hodnotu. Text vrácený kódem hlavičky je ve výsledném obsahu HTML souboru uložen za koncový tag HEAD.

¨ kód patičky - umožňuje nastavit přizpůsobení vzhledu patičky informačního panelu. Tento kód (v jazyce Foxpro) musí vracet textovou hodnotu. Text vrácený kódem patičky je vložen na konec HTML souboru a musí obsahovat koncový tag BODY.

Na stránce informačního panelu je možné vytvářet odkazy, které způsobí vyvolání programu Windows (jiného než internetový prohlížeč) a v něm otevření souboru, který odpovídá celé zobrazené stránce (může to být více tabulek) nebo jednotlivé tabulce zobrazené na stránce. Při vytváření stránky informačního panelu je dostupná vlastnost řídícího objektu vytváření stránky OUTPUT_FORMAT, která má při vytváření běžné stránky zobrazované v internetovém prohlížeči hodnotu 'prázdný text' a při vytváření stránky určené pro zobrazení v programu Windows obsahuje hodnotu, kterou je tříznaková přípona souboru. Přitom platí, že je-li stránka vytvářena s nastavenou vlastností OUTPUT_FORMAT řídícího objektu, potom do vytvářených tabulek nejsou vkládány hypertextové odkazy, je potlačeno vytváření automatických hlaviček a patiček stránky a po vytvoření stránky je vyvolán program Windows podle uvedené přípony (hodnoty vlastnosti OUTPUT_FORMAT).

Do stránky informačního panelu je možné vkládat hypertextové odkazy, které zajistí vytvoření stránky s nastavenou vlastností řídícího objektu vytváření stránky OUTPUT_FORMAT třemi způsoby:

- v kódu patičky prezentace stránky

- ve vlastnosti POSTTEXT definice uzlu informačního panelu

- hypertextovým odkazem, který je součástí tabulky informačního panelu

K tomuto účelu slouží např. uživatelská knihovna vkládaného kódu USRPAN. S knihovnou USRPAN je možné zadat v kódu patičky prezentace stránky nebo ve vlastnosti POSTTEXT definice uzlu informačního panelu kód:

<pre>

#SCRIPT

Return zobrazit_v_excelu_a_wordu(_this)

#INCLUDE USRPAN

</pre>

Takto budou do stránky vloženy hypertexty, které převedou do programu Windows celou zobrazenou stránku (může to být více tabulek).

Při vytváření stránky určené pro zobrazení v programu Windows je pro úspěšné uplatnění stylů nutné, aby styly byly přímo obsaženy v souboru předaném programu Windows. Proto je třeba zasáhnou do popisu stylu v prezentaci stránky informačního panelu a v jeho kódu podmínit v případě, že je nastavena vlastnost OUTPUT_FORMAT řídícího objektu, vložení textu stylů do vytvářené stránky.

Např. s užitím knihovny USRPAN:

<pre>

#SCRIPT

Return vrat_styl(_this)

#INCLUDE USRPAN

</pre>

V některých případech je vhodné pro výstup stránky do programu Windows vyloučit některé sloupce tabulky, řádky tabulky,prvky stránek nebo celou jednotlivou tabulku zobrazenou na stránce (poslední platí pro hypertexty v kódu patičky prezentace stránky nebo ve vlastnosti POSTTEXT definice uzlu informačního panelu). V tom případě je možné uvádět ve vlastnosti Podmínka v definici takového sloupce, řádku, prvku stránky nebo podřízeného uzlu výraz 'EMPTY(this.output_format)'.

¨ popis stylu prvku stránky - kód v jazyce Foxpro, který vrací text doplňující formát prvku

¨ atributy elementů TR – zde se uvádějí jednotlivé HTML atributy elementu následované výrazem v jazyce Foxpro oddělené klávesou Enter, např. BGCOLOR=IIF(MOD(this.citac_radku,2)=1,'YELLOW','') – stejné nastavení je možno uvádět také u jednotlivých řádků v činnosti definice uzlů inf. panelů. V případě, že je uvedeno nastavení u jednotlivého řádku v definici uzlů inf. panelů a rovněž zde v prezentaci stránek panelů, potom se uplatní obě tato nastavení.

¨ poznámka

Datový model

  • IPPREZEN Popis prezentace stránky panelu/prvku stránky

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností

    Formulář

    Formulář činnosti - Knihovny vkládaného kódu
Mřížka [Prezentace]
Prezentace | Identifikátor prezentace
Název prezentace | Název prezentace
Popis stylu stránky | Popis stylu stránky - pro prvek typu tabulka parametry tag TABLE
Kód hlavičky | Kód v jazyce Foxpro pro vytvoření hlavičky stránky (pokud není uveden vytváří se standardní hlavička)
Kód patičky | Kód v jazyce Foxpro pro vytvoření patičky stránky (pokud není uveden vytváří se standardní patička)
Popis stylu prvku stránky | Popis stylu prvku stránky
Atributy elementů TR | Atributy elementů řádků (TR) oddělené enterem
Poznámka | Poznámka

    Mřížka [Prezentace] činnosti - Knihovny vkládaného kódu

    Mřížka [Prezentace] činnosti - Knihovny vkládaného kódu
Prezentace | Identifikátor prezentace
Název prezentace | Název prezentace

    Atributy tisku

    Základní údaje
Prezentace | Identifikátor prezentace | IPPREZEN_ip06id | C(6)
Název prezentace | Název prezentace | IPPREZEN_ip06nazpre | C(40)
Popis stylu stránky | Popis stylu stránky - pro prvek typu tabulka parametry tag TABLE | IPPREZEN_ip06popsty | M
Kód hlavičky | Kód v jazyce Foxpro pro vytvoření hlavičky stránky (pokud není uveden vytváří se standardní hlavička) | IPPREZEN_ip06heakod | M
Kód patičky | Kód v jazyce Foxpro pro vytvoření patičky stránky (pokud není uveden vytváří se standardní patička) | IPPREZEN_ip06fookod | M
Popis stylu prvku stránky | Popis stylu prvku stránky | IPPREZEN_ip06popprv | M
Atributy elementů TR | Atributy elementů řádků (TR) oddělené enterem | IPPREZEN_ip06poptra | M
Poznámka | Poznámka | IPPREZEN_ip06koment | M

    Viz.také

    Knihovny vkládaného kódu


Hypertextové odkazy

Popis

Hypertextové odkazy se uplatňují při vytváření tabulek na stránce informačních panelů. Před vlastní aktivací dané činnosti se uživateli nejprve zobrazí záložka „výběr“, kde si může pohodlně zvolit množinu dalších zobrazených dat. U každého odkazu se definuje:

¨ hypertext - jednoznačná textová identifikace

¨ název hypertextového odkazu

¨ typ - WEB / Interní BM

¨ kód - kód v jazyce Foxpro, který vrací pro typ WEB URL adresu, jinak vrací kód v jazyce Foxpro vyvolaný při aktivaci hypertextového odkazu na výstupní stránce informačního panelu.

¨ uzel - odkaz na uzel informačního panelu - je-li uveden nemá význam uvádět 'kód'

¨ jiný název – jiný název uzlu informačního panelu – za znakem ~ je možno zadat výraz

¨ parametry - předané do doplnění příkazu SQL uzlu, kde jsou pozičně reprezentované jako ?_p1, ?_p2 .... (maximální počet parametrů je 14)

¨ atributy - jsou doplňující atributy SQL dotazu podřízeného uzlu, které jsou vkládány do tohoto dotazu přímo za SELECT. Jsou-li uvedeny atributy, potom za posledním musí být uvedena čárka. Např. 'adadsat.ad01adsat, adspoj.ad11jmeno,' nebo 'TOP 200'

¨ from - je doplnění SQL dotazu podřízeného uzlu v jeho části za FROM

¨ where - je doplnění SQL dotazu podřízeného uzlu v jeho části za WHERE

¨ výraz třídění – výraz třídění dat vrácených dotazem SQL

Na stránce informačního panelu je možné vytvářet odkazy, které způsobí vyvolání programu Windows (jiného než internetový prohlížeč) a v něm otevření souboru, který odpovídá celé zobrazené stránce (může to být více tabulek) nebo jednotlivé tabulce zobrazené na stránce.

Při vytváření stránky informačního panelu je dostupná vlastnost řídícího objektu vytváření stránky OUTPUT_FORMAT, která má při vytváření běžné stránky zobrazované v internetovém prohlížeči hodnotu 'prázdný text' a při vytváření stránky určené pro zobrazení v programu Windows obsahuje hodnotu, kterou je tříznaková přípona souboru. Přitom platí, že je-li stránka vytvářena s nastavenou vlastností OUTPUT_FORMAT řídícího objektu, potom do vytvářených tabulek nejsou vkládány hypertextové odkazy, je potlačeno vytváření automatických hlaviček a patiček stránky a po vytvoření stránky je vyvolán program Windows podle uvedené přípony (hodnoty vlastnosti OUTPUT_FORMAT).

Do stránky informačního panelu je možné vkládat hypertextové odkazy, které zajistí vytvoření stránky s nastavenou vlastností řídícího objektu vytváření stránky OUTPUT_FORMAT třemi způsoby:

- v kódu patičky prezentace stránky

- ve vlastnosti POSTTEXT definice uzlu informačního panelu

- hypertextovým odkazem, který je součástí tabulky informačního panelu

K tomuto účelu slouží např. uživatelská knihovna vkládaného kódu USRPAN.

Pro vložení hypertextu s nastavení vlastnosti OUTPUT_FORMAT řídícího objektu přímo do tabulky je třeba vytvořit zvláštní definici hypertextu informačních panelů, která obsahuje kód vracející text 'output_format=<přípona>', kde <přípona> je tříznaková přípona souboru (příklad kódu hypertextu RETURN 'output_format=XLS')

Tímto způsobem bude do stránky vložen hypertext, který převede do programu Windows danou tabulku.

Při vytváření stránky určené pro zobrazení v programu Windows je pro úspěšné uplatnění stylů nutné, aby styly byly přímo obsaženy v souboru předaném programu Windows.

Proto je třeba zasáhnou do popisu stylu v prezentaci stránky informačního panelu a v jeho kódu podmínit v případě, že je nastavena vlastnost OUTPUT_FORMAT řídícího objektu, vložení textu stylů do vytvářené stránky.

Např. s užitím knihovny USRPAN:

<pre>

#SCRIPT

Return vrat_styl(_this)

#INCLUDE USRPAN

</pre>

Datový model

  • IPHYPER Hypertextový odkaz

    • Formulář

    Formulář činnosti - Výběr makra
Mřížka [Hypertextový odkaz]
Hypertext | Identifikace hypertextového odkazu
Název hypertextového odkazu | Název hypertextového odkazu
Typ | Typ hypertextového odkazu
Kód | Kód ve Foxpro vracející adresu hypertextového odkazu
Uzel | Identifikátor uzlu informačního panelu
Název uzlu inf. panelu | Název uzlu informačního panelu
Jiný název | Jiný název uzlu informačního panelu - za znakem ~ je možné zadat výraz
Parametry | Skutečné parametry použité v doplnění where hypertextového odkazu
Atributy | Doplnění SQL dotazu na jeho začátku (je-li uveden atribut musí být posledním textu znakem čárka)
FROM | Doplnění FROM dotazu SQL poduzlu
WHERE | Doplnění WHERE dotazu SQL stránky hypertextového odkazu
Výraz třídění | Výraz třídění dat vrácených dotazem SQL
Poznámka | Poznámka

    Mřížka [Hypertextový odkaz] činnosti - Výběr makra

    Mřížka [Hypertextový odkaz] činnosti - Výběr makra
Hypertext | Identifikace hypertextového odkazu
Název hypertextového odkazu | Název hypertextového odkazu
Uzel | Identifikátor uzlu informačního panelu
Typ | Typ hypertextového odkazu

    Vyvolávané činnosti

    K. | Činnost | Popis
- | Definice maker | Definice maker
F2 | Definice uzlů inf.panelů | Definice uzlů informačních panelů
F2 | Výběr makra | Výběr makra

    Atributy tisku

    Základní údaje
Hypertext | Identifikace hypertextového odkazu | IPHYPER_ip08id | C(12)
Název hypertextového odkazu | Název hypertextového odkazu | IPHYPER_ip08nazhyp | C(40)
Uzel | Identifikátor uzlu informačního panelu | IPHYPER_ip01id | C(12)
Název uzlu inf. panelu | Název uzlu informačního panelu | IPUZEL_ip01nazuzl | C(40)
Atributy | Doplnění SQL dotazu na jeho začátku (je-li uveden atribut musí být posledním textu znakem čárka) | IPHYPER_ip08attr | M
FROM | Doplnění FROM dotazu SQL poduzlu | IPHYPER_ip08from | M
WHERE | Doplnění WHERE dotazu SQL stránky hypertextového odkazu | IPHYPER_ip08where | M
Parametry | Skutečné parametry použité v doplnění where hypertextového odkazu | IPHYPER_ip08param | M
Typ | Typ hypertextového odkazu | Výpočet | C(10)
Kód | Kód ve Foxpro vracející adresu hypertextového odkazu | IPHYPER_ip08hypkod | M
Výraz třídění | Výraz třídění dat vrácených dotazem SQL | IPHYPER_ip08vyrazo | M
Poznámka | Poznámka | IPHYPER_ip08koment | M

    Viz.také

    Definice maker | Definice uzlů inf.panelů | Výběr makra


OBECNÉ STROMY

Popis

Nástroj IS BM „obecné stromy“ umožňuje uživatelsky definovat vztahy mezi daty a následně tyto vztahy zobrazovat ve formě stromu (obdobný formát jako je např. strom hlavního procesu).

Obecné stromy se nacházejí v hlavním menu v činnosti Informační centrum. Po rozbalení tohoto menu má uživatel k dispozici tyto činnosti:

¨ vyvolání obecného stromu – přímo výběr jednotlivých nadefinovaných stromů ke spuštění

¨ definice obecných stromů – vlastní definice jednotlivých obecných stromů

¨ druhy uzlů obecných stromů – jednotlivé druhy s možností definice přístupových práv

Viz.také

VYVOLÁNÍ OBECNÉHO STROMU | Definice obecných stromů | Druhy uzlů obecných stromů


VYVOLÁNÍ OBECNÉHO STROMU

Popis

Skupinové menu, pod kterým jsou pro uživatele k dispozici všechny nadefinované obecné stromy ke kterým má přiděleno přístupové právo.

Datový model

  • SPSTROM Uzel obecného stromu
    • SPSTROMD Druh uzlu obecného stromu
      • SPPRISTU Přístupové právo uživatele k věci

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Definice obecných stromů

Popis

Jak název napovídá, slouží tato činnost k vlastní definici uzlů obecných stromů a vztahů mezi nimi.

Na záložce "Uzly obecného stromu" se definuje:

¨ identifikace uzlu - jednoznačně identifikuje uzel

¨ název uzlu - pro vrcholový uzel určuje název odpovídající položky hlavního menu a nadpis formuláře stromu

¨ druh uzlu - definuje práva přístupu

¨ ikona uzlu - určuje ikonu, která bude použita pro položky odvozené z definice uzlu

¨ volba vrcholový uzel Ano/Ne - pro vrcholové uzly je možné vyvolávat výsledný strom a objeví se také jako položky hlavního menu programu v menu VYVOLÁNÍ OBECNÉHO STROMU

¨ SQL dotaz - výstupem tohoto dotazu jsou určeny položky stromu vzniklé na základě dané definice

¨ výraz třídění - výraz v jazyce Foxpro - definuje setřídění dat

¨ výraz zobrazení - výraz v jazyce Foxpro - definuje text zobrazený ve stromu

¨ výraz hierarchie - výraz v jazyce Foxpro - určuje, že daná definice uzlu určuje hierarchické zobrazení

¨ maska hierarchie - text - rozpadá hodnotu vyhodnocenou výrazem hierarchie do struktury stromu

¨ tabulka – zkrácený popis entity pro relace

¨ podmínka – podmínka opravy dat

¨ poznámka

Ke každé definici vrcholového uzlu je možné připojit skript v jazyce Foxpro vyvolávaný při dvojím kliku na odpovídající položce výsledného stromu. Skript je možné definovat volbou F5 menu formuláře a je v něm možné používat odkazy na knihovny vkládaného kódu (např. výstup do HTML). V okamžiku vyvolání skriptu je dostupný objekt _DATA, který obsahuje jako atributy aktuální položky výsledného stromu, např. pro spuštění adresáře se zobrazením odpovídajícího adresáta by bylo možné použít:

tool.makroprikaz([do form AD0137 with '','',.F.,'A',_p1],_data.ad01id)

Příklad uzlu definujícího hierarchické zobrazení obchodního selektoru, ve vlastnostech definice uzlu (tj. záznamy, které mají prvé dva znaky v sp10idzak shodné se vyskytují na stejné úrovni menu):

- SQL dotaz - SELECT sp10idzak,sp10text FROM %%%.SPSEOB WHERE sp10idzak like '____00000'

- výraz třídění - sp10text

- výraz zobrazení - sp10text

- výraz hiearchie - sp10idzak

- maska hierarchie - AABC

Na záložce „Podmíněné ikony“ se definují ikony, které budou zobrazeny u zadané větvě stromu na základě vyhodnocené podmínky.

Na záložce „Atributy“ se po stisku klávesy F5 (nebo volbou příslušné činnosti z menu Volby) nebo po stisku pravé myši (Editor hodnot), definují atributy, které může uživatel editovat.

Na záložce „Funkce“ má uživatel možnost za určité zadané podmínky nadefinovat spouštění programového kódu. Možno nastavit zda se bude spouštět na pravý klik, dvojklik či s využitím klávesy.

Na záložce "Podřízené uzly" se k odpovídající definici uzlu připojují uzly, jejichž definice jsou zpracovávány dynamicky pro jednotlivé položky výsledného stromu. Definuje se:

¨ identifikace připojeného uzlu

¨ alias - totožný uzel může být při použití aliasu připojen vícekrát

¨ pořadí připojeného uzlu

¨ podmínka připojení

¨ skutečné parametry - seznam výrazů v jazyce Foxpro oddělených čárkou , ve kterých je možné použít odkazy na objekt _DATA, který obsahuje jako atributy aktuální položky výsledného stromu - maximální počet paramertů je 8

¨ doplnění ATRIBUTY – doplňuje atributy v SQL SELECTU, vyjmenované atributy musí končit znakem čárka

¨ doplnění FROM – definuje tabulky, které budou přidané do clausule FROM v SELECTU

¨ doplnění WHERE - obsahuje fragment příkazu SQL, který bude doplněn k SQL dotazu při zpracování připojeného uzlu, je v něm možné použít odkaz na hodnoty výrazu "skutečných parametrů" uvedením výrazu ?_pX, X je pozice výrazu v seznamu skutečných parametrů

¨ výraz třídění - výraz v jazyce Foxpro - definuje setřídění dat - je-li uveden přebíjí odpovídající atribut v připojeném uzlu

Příklad napojení adresáře na uzel obchodního selektoru z předchozího příkazu. Předpokládá se, že připojený uzel má ve vlastnosti "SQL dotaz" uvedeno - SELECT ad01id,ad01adsat FROM %%%.ADADSAT, pak platí, že:

- skutečné parametry - LEFT(_data.sp10idzak,4)+'%'

- doplnění WHERE - ADADSAT.sp10idzak LIKE ?_p1

Datový model

  • SPSTROM Uzel obecného stromu
    • SPSTROMD Druh uzlu obecného stromu
      • SPPRISTU Přístupové právo uživatele k věci
    • BWIKONA Ikona v BM

    • Formulář

    Formulář činnosti - Datový model
Mřížka [Uzly obecného stromu]
Uzel | Identifikace uzlu stromu
Název uzlu | Název uzlu stromu
Listovací rámeček
Stránka #1 Uzly obecného stromu
Druh | Identifikace druhu uzlu stromu
Název druhu | Název druhu uzlu stromu
Ikona | Identifikace ikony
Název ikony | Název ikony
Vrchol | Vrcholový uzel stromu
SQL | SQL dotaz uzlu stromu
Výraz třídění | Výraz třídění uzlu stromu
Výraz zobrazení | Výraz pro zobrazení popisu uzlu ve stromu
Výraz hierarchie | Výraz hierarchického členění uzlu stromu
Maska hierarchie | Maska hierarchického členění uzlu stromu
Výraz DRAG | Výraz vrácený při DRAG uzlu
Tabulka | Název entity
 | Zkrácený popis entity pro relace
Podmínka | Podmínka opravy dat
Poznámka | Poznámka
Stránka #2 Podmíněné ikony
Mřížka [Podmíněné ikony]
Ikona | Identifikace ikony
Název ikony | Název ikony
Pořadí | Pořadí vyhodnocení
Podmínka | Podmínka použití ikony
Stránka #3 Atributy
Mřížka [Atributy]
Atribut | Atribut
Pořadí | Pořadí zobrazení
Návěští | Návěští
Stav. ř. | Stavový řádek
Podm. | Podmínka vstupu
Třída | Třída prvku
Formát | Formát prvku
P.oknu | Přizpůsobovat oknu
F2-reakce | Vyvolání činnosti na klávesu F2
Pozn. | Poznámka
Stránka #4 Funkce
Mřížka [Funkce]
Funkce | Popis funkce
Typ | Typ funkce
Klávesa | Vyvolat funkce na klávesu
Pořadí | Pořadí funkce
Podm. | Podmínka vyvolání funkce
Kód | Kód funkce
Pozn. | Poznámka
Stránka #5 Podřízené uzly
Mřížka [Podřízené uzly]
Uzel | Identifikace připojeného uzlu stromu
Alias | Alias připojeného uzlu stromu
Název uzlu | Název uzlu stromu
Popis folderu | Popis folderu
Pořadí | Pořadí
Podmínka připojení | Podmínka připojení uzlu
Skutečné parametry | Skutečné parametry použité v doplnění where uzlu stromu
Doplnění ATRIBUTY | Doplnění SQL dotazu na jeho začátku (je-li uveden atribut musí být posledním textu znakem čárka)
Doplnění FROM | Doplnění FROM připojeného uzlu stromu
Doplnění WHERE | Doplnění WHERE připojeného uzlu stromu
Výraz třídění | Výraz třídění uzlu stromu
Stránka #6 Výběr
Uzel | Identifikace uzlu stromu
Název uzlu | Název uzlu stromu
Druh | Identifikace druhu uzlu stromu
Ikona | Identifikace ikony
Vrchol | Vrcholový uzel stromu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Uzly obecného stromu] činnosti - Datový model

    Mřížka [Uzly obecného stromu] činnosti - Datový model
Označování | Označení záznamu
Uzel | Identifikace uzlu stromu
Název uzlu | Název uzlu stromu
Druh | Identifikace druhu uzlu stromu
Název druhu | Název druhu uzlu stromu
Ikona | Identifikace ikony
Název ikony | Název ikony
Vrchol | Vrcholový uzel stromu

    Mřížka [Podmíněné ikony] činnosti - Datový model

    Mřížka [Podmíněné ikony] činnosti - Datový model
Pořadí | Pořadí vyhodnocení
Ikona | Identifikace ikony
Název ikony | Název ikony
Podmínka | Podmínka použití ikony

    Mřížka [Atributy] činnosti - Datový model

    Mřížka [Atributy] činnosti - Datový model
Pořadí | Pořadí zobrazení
Atribut | Atribut
Návěští | Návěští

    Mřížka [Funkce] činnosti - Datový model

    Mřížka [Funkce] činnosti - Datový model
Pořadí | Pořadí funkce
Typ | Typ funkce
Funkce | Popis funkce

    Mřížka [Podřízené uzly] činnosti - Datový model

    Mřížka [Podřízené uzly] činnosti - Datový model
Pořadí | Pořadí
Uzel | Identifikace připojeného uzlu stromu
Alias | Alias připojeného uzlu stromu
Název uzlu | Název uzlu stromu

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Editovat kód vlastnosti | Editovat kód vlastnosti
F6 | Design formuláře uzlu obecného stromu | Design formuláře uzlu obecného stromu
F9 | Spustit obecný strom | Spustit obecný strom
- | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností
- | Kontrolní kompilace | Kontrolní kompilace
F2 | Datový model | Datový model Bílého motýla
F2 | Definice obecných stromů | Definice obecných stromů
F2 | Druhy uzlů obecných stromů | Druhy uzlů obecných stromů
F2 | Seznam ikon | Seznam ikon používaných v BM

    Atributy tisku

    Základní údaje
Uzel | Identifikace uzlu stromu | SPSTROM_spb6id | C(6)
Název uzlu | Název uzlu stromu | SPSTROM_spb6nazuzl | C(40)
Druh | Identifikace druhu uzlu stromu | SPSTROM_spb8id | C(6)
Název druhu | Název druhu uzlu stromu | SPSTROMD_spb8druuzl | C(40)
Ikona | Identifikace ikony | SPSTROM_bw88id | C(6)
Název ikony | Název ikony | BWIKONA_bw88naziko | C(40)
Vrchol | Vrcholový uzel stromu | Výpočet | C(3)
SQL | SQL dotaz uzlu stromu | SPSTROM_spb6sql | M
Výraz třídění | Výraz třídění uzlu stromu | SPSTROM_spb6vyrazo | M
Výraz zobrazení | Výraz pro zobrazení popisu uzlu ve stromu | SPSTROM_spb6vyraz | M
Výraz hierarchie | Výraz hierarchického členění uzlu stromu | SPSTROM_spb6vyrazh | M
Maska hierarchie | Maska hierarchického členění uzlu stromu | SPSTROM_spb6maskah | M
Tabulka | Název entity | SPSTROM_bw10nazev | C(8)
Podmínka | Podmínka opravy dat | SPSTROM_spb6ediwhe | M
Poznámka | Poznámka | SPSTROM_spb6koment | M
Název uzlu | Název uzlu stromu | SPSTROM2_spb6nazuzl | C(40)
Název ikony | Název ikony | BWIKONA2_bw88naziko | C(40)

    Při pohybu v Atributy
Atribut | Atribut | SPSTROMA_spc2atrib | C(10)
Pořadí | Pořadí zobrazení | SPSTROMA_spc2porad | N(3)
Návěští | Návěští | SPSTROMA_spc2label | M
Stav. ř. | Stavový řádek | SPSTROMA_spc2status | M
P.oknu | Přizpůsobovat oknu | Výpočet | C(12)
Podm. | Podmínka vstupu | SPSTROMA_spc2when | M
Třída | Třída prvku | Výpočet | C(8)
Formát | Formát prvku | SPSTROMA_spc2pict | M
Pozn. | Poznámka | SPSTROMA_spc2koment | M

    Při pohybu v Funkce
Funkce | Popis funkce | SPSTROMF_spc3popfce | C(40)
Typ | Typ funkce | Výpočet | C(12)
Klávesa | Vyvolat funkce na klávesu | Výpočet | C(2)
Pořadí | Pořadí funkce | SPSTROMF_spc3porad | N(3)
Podm. | Podmínka vyvolání funkce | SPSTROMF_spc3podmin | M
Kód | Kód funkce | SPSTROMF_spc3kod | M
Pozn. | Poznámka | SPSTROMF_spc3koment | M

    Při pohybu v Podmíněné ikony
Pořadí | Pořadí vyhodnocení | SPSTROMI_spc6porad | N(3)
Ikona | Identifikace ikony | SPSTROMI_bw88id | C(6)
Podmínka | Podmínka použití ikony | SPSTROMI_spc6podm | M

    Při pohybu v Podřízené uzly
Uzel | Identifikace připojeného uzlu stromu | SPSTROMP_spb6id2 | C(6)
Alias | Alias připojeného uzlu stromu | SPSTROMP_spb7alias | C(6)
Pořadí | Pořadí | SPSTROMP_spb7porad | N(3)
Skutečné parametry | Skutečné parametry použité v doplnění where uzlu stromu | SPSTROMP_spb7param | M
Doplnění ATRIBUTY | Doplnění SQL dotazu na jeho začátku (je-li uveden atribut musí být posledním textu znakem čárka) | SPSTROMP_spb7attr | M
Doplnění FROM | Doplnění FROM připojeného uzlu stromu | SPSTROMP_spb7from | M
Doplnění WHERE | Doplnění WHERE připojeného uzlu stromu | SPSTROMP_spb7where | M
Popis folderu | Popis folderu | SPSTROMP_spb7folder | M
Podmínka připojení | Podmínka připojení uzlu | SPSTROMP_spb7podpri | M
Výraz třídění | Výraz třídění uzlu stromu | SPSTROMP_spb7vyrazo | M

    Viz.také

    Editovat kód vlastnosti | Design formuláře uzlu obecného stromu | Spustit obecný strom | Knihovny vkládaného kódu | Kontrolní kompilace | Datový model | Druhy uzlů obecných stromů | Seznam ikon


Druhy uzlů obecných stromů

Popis

Tato činnost slouží k definování druhů uzlů obecných stromů. U každého druhu se definuje identifikace a název druhu. Zároveň je možno ke každému druhu nadefinovat přístupová práva (Ctrl B nebo příslušná činnost pod menu Volby).

Datový model

  • SPSTROMD Druh uzlu obecného stromu
    • BWUZIVAT Uživatel systému
    • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Druhy uzlů obecného stromu]
Druh | Identifikace druhu uzlu stromu
Název druhu | Název druhu uzlu stromu
Poznámka | Poznámka
Datum a čas zápisu | Datum a čas zápisu záznamu události
Založil | Jméno uživatele systému

    Mřížka [Druhy uzlů obecného stromu] činnosti - Přístupová práva

    Mřížka [Druhy uzlů obecného stromu] činnosti - Přístupová práva
Druh | Identifikace druhu uzlu stromu
Název druhu | Název druhu uzlu stromu
Založil | Jméno uživatele systému
Datum a čas zápisu | Datum a čas zápisu záznamu události

    Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci

    Atributy tisku

    Základní údaje
Druh | Identifikace druhu uzlu stromu | SPSTROMD_spb8id | C(6)
Název druhu | Název druhu uzlu stromu | SPSTROMD_spb8druuzl | C(40)
Poznámka | Poznámka | SPSTROMD_spb8koment | M
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | SPSTROMD_sp00datzap | T

    Viz.také

    Přístupová práva


APLIKACE

Viz.také

Aplikace | Typy popisných údajů


Aplikace

Popis

Tato činnost poskytuje uživateli možnost definovat si jednotlivé aplikace a jejich pohledy. U každé aplikace se zadává:

¨ identifikátor aplikace a její název

¨ ikona aplikace

¨ podmínka – podmínka zařazení procesu do menu

¨ libovolný komentář uživatele

Na záložce „pohledy aplikace“ se definuje následující:

¨ pohled – identifikátor pohledu aplikace (identifikace pohledů je možno pohodlně najít v jednotlivých činnostech IS BM pod činností „Statistika SQL“ – menu Obecné)

¨ update tables

¨ fetchmemo – volba Ano/ne

¨ SQL – SQL dotaz pohledu aplikace (v syntaxi Foxpro)

¨ poznámka

Po stisku klávesy F6 je možno vyvolat „Procesy a operace aplikace“. Po stisku klávesy F5 lze vyvolat „Menu aplikace“.

Datový model

  • APAPLIKA Aplikace BM

    • Formulář

    Formulář činnosti - Menu aplikace
Mřížka [Aplikace]
Aplikace | Identifikátor aplikace
Název aplikace | Název aplikace
Listovací rámeček
Stránka #1 Aplikace
Ikona aplikace | Ikona aplikace
Podmínka | Podmínka zařazení procesu do menu
Poznámka | Poznámka
Stránka #2 Pohledy aplikace
Mřížka [Pohledy aplikace]
Pohled | Identifikátor pohledu aplikace
Update tables | Update tables
Fetchmemo | Fetchmemo
SQL | SQL dotaz pohledu aplikace
Poznámka | Poznámka

    Mřížka [Aplikace] činnosti - Menu aplikace

    Mřížka [Aplikace] činnosti - Menu aplikace
Označování | Označení záznamu
Aplikace | Identifikátor aplikace
Název aplikace | Název aplikace

    Mřížka [Pohledy aplikace] činnosti - Menu aplikace

    Mřížka [Pohledy aplikace] činnosti - Menu aplikace
Aplikace | Identifikátor aplikace
Pohled | Identifikátor pohledu aplikace

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Menu aplikace | Definování menu aplikace
F6 | Procesy a operace aplikace | Procesy a operace aplikace

    Atributy tisku

    Základní údaje
Aplikace | Identifikátor aplikace | APAPLIKA_ap01id | C(6)
Název aplikace | Název aplikace | APAPLIKA_ap01nazapl | C(40)
Ikona aplikace | Ikona aplikace | APAPLIKA_ap01ikona | M
Poznámka | Poznámka | APAPLIKA_ap01koment | M

    Při pohybu v Pohledy aplikace
Pohled | Identifikátor pohledu aplikace | APPOHLED_ap02id | C(20)
SQL | SQL dotaz pohledu aplikace | APPOHLED_ap02sql | M
Update tables | Update tables | APPOHLED_ap02updtab | C(50)
Fetchmemo | Fetchmemo | Výpočet | C(3)
Poznámka | Poznámka | APPOHLED_ap02koment | M

    Viz.také

    Menu aplikace | Procesy a operace aplikace


Typy popisných údajů

Popis

Tato činnost poskytuje uživateli možnost definice, opravy a rušení jednotlivých typů popisných údajů. U každého typu se definuje:

¨ typ – identifikátor a název typu popisného údaje aplikace

¨ třída – třída popisného údaje – výběr z překryvného seznamu (možnosti jsou: combobox / text / num / datum / datum a čas / text-combobox)

¨ dědit hodnotu – volby Ano/Ne

¨ formát popisného údaje

¨ libovolný komentář uživatele

Datový model

  • APPOPUDJ Typ popisného údaje aplikace

    • Formulář

    Formulář činnosti - Menu aplikace
Mřížka [Typy]
Typ | Identifikátor typu popisného údaje aplikace
Text | Text popisného údaje
Třída | Třída popisného údaje
Dědit hodnotu | Dědit hodnotu
Formát | Formát popisného údaje
Poznámka | Poznámka

    Mřížka [Typy] činnosti - Menu aplikace

    Mřížka [Typy] činnosti - Menu aplikace
Typ | Identifikátor typu popisného údaje aplikace
Text | Text popisného údaje
Třída | Třída popisného údaje
Formát | Formát popisného údaje

    Atributy tisku

    Základní údaje
Typ | Identifikátor typu popisného údaje aplikace | APPOPUDJ_ap03id | C(6)
Text | Text popisného údaje | APPOPUDJ_ap03text | C(40)
Třída | Třída popisného údaje | Výpočet | C(13)
Dědit hodnotu | Dědit hodnotu | Výpočet | C(3)
Formát | Formát popisného údaje | APPOPUDJ_ap03format | M
Poznámka | Poznámka | APPOPUDJ_ap03koment | M


UTILITY

Popis

Ve slovníku cizích slov znamenají UTILITY : užitečnost, funkčnost; program vykonávající jisté pomocné činnosti. V našem případě je to činnost, pod kterou se shromažďují pomocné činnosti, které uživatel může využít při práci s IS BM. Nachází se v hlavním menu v činnosti Informační centrum a v současné době je zde k dispozici činnost Archivace.

Viz.také

ARCHIVACE


ARCHIVACE

Popis

Toto menu (hlavní menu – Informační centrum – Utility – Archivace) v sobě sdružuje činnosti přímo související s archivací. Umožňuje uživateli vytvořit si jednotlivé definice archivací, kde si uživatel určí která data chce archivovat a jak často a kdy je chce archivovat. Archivují se především soubory template a banky (certifikáty apod.) a programy, které vyžadují externí uložení (např. soubory jiných systémů) nebo externě ukládané dokumenty. Jednotlivé vytvořené archivace má uživatel kdykoliv k dispozici. Pod menu Archivace jsou tyto činnosti:

¨ Spuštění archivace

¨ Prohlížení archivu

¨ Popis archivací

Viz.také

SPUŠTĚNÍ ARCHIVACE | Prohlížení archivu | Popis archivací


SPUŠTĚNÍ ARCHIVACE

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Prohlížení archivu

Popis

Tato činnost je pro uživatele dostupná v hlavním menu v komponentě Informační centrum – Utility – Archivace – Prohlížení archivu. Uživateli se zde přehledným způsobem zobrazují jednotlivé nadefinované archivace (definice archivace se provádí v činnosti Popis archivací).

Po aktivaci této činnosti je v levém sloupci (ve stromovém zobrazení) k dispozici přehled nadefinovaných skupin archivací z činnosti Popis archivací a v pravé části formuláře jsou k dispozici vlastní archivace. V pravé horní části je vždy hlavní verze souboru archivace a v pravé dolní části jeho kopie (archivace je typu rozdílová, tzn. nearchivuje se vždy vše v daných souborech, ale to co se změnilo či přibylo). Třídění jednotlivých sloupců v pravé části formuláře lze provádět po stisku levého tlačítka myši.

Po stisku pravého tlačítka myši na archivacích ve stromu (levý sloupec) lze provést (totéž lze provést i u souborů):

¨ kopírovat adresář (soubor) „.....“

¨ přejmenovat adresář (soubor) „.....“

¨ odstranit „.....“

U přejmenování souboru platí, že v případě, že uživatel změní např. název souboru a nadále chce archivovat soubor do stejného stromu, je nutno opravit nejprve definici a pak teprve název ve stromu. Pokud uživatel opraví název archivace přímo v její definici (popis archivací) a nikoliv zde ve stromu, tak se nový název zde neprojeví. Tento soubor archivace je pak vhodné ze stromu odstranit, přejmenovat a archivaci spustit znovu.


Popis archivací

Popis

Tato činnost se nachází v hlavním menu v činnosti Informační centrum – Utility – Archivace – Popis archivací. Umožňuje uživateli vytvořit si jednotlivé definice archivací, kde si uživatel určí která data chce archivovat a jak často a kdy je chce archivovat. Archivují se především soubory template a banky (certifikáty apod.) a programy, které vyžadují externí uložení (např. soubory jiných systémů) nebo externě ukládané dokumenty.

Po aktivaci této činnosti se uživateli zobrazí aktivní záložka „Skupiny archivace“, kde jsou k dispozici již současné nadefinované archivace. Při prohlížení stávající archivace či při zakládání nové definice má uživatel k dispozici následující atributy:

¨ skupina – identifikace a název skupiny

¨ počítač – definice počítače, na kterém lze danou skupinu archivace aktivovat. V případě uvedení „pomlčky“ ji lze aktivovat z každého počítače, soubory archivace se vyskytují na síti a jsou dostupné všem. V případě lokálních souborů určených k archivaci je nutno určit počítač, ze kterého se bude daná archivace aktivovat, tzn. nelze ji pak aktivovat na jiném počítači.

¨ druh – jedná se o druh dokumentu. Druh dokumentu rovněž určuje přístupová práva k archivaci, tzn. archivaci smí aktivovat pouze ten, kdo má k danému druhu dokumentu právo zápis. Uživatel, který k danému druhu dokumentu nemá ani právo čtení, nevidí danou archivaci ani v prohlížení archivu.

¨ téma – téma vývěsky, pod kterým bude zapisován protokol o archivaci. Atributy téma, typ a text přímo souvisí s vývěskou, kam se zapisuje vytvořený protokol o archivaci. Výhodou tohoto zápisu na vývěsku je, že pak v datech lze pohodlně zjistit, kdy která archivace proběhla, což se hodí zejména pro případy, kdy se daná archivace spouští programově, tzn. že je nastaveno automatické spouštění archivace např. po 15 dnech. Podle údajů na vývěsce pak program dokáže analyzovat uplynulých 15 dní a automaticky spustí další naplánovanou archivaci.

¨ typ – typ události vývěsky, na kterou bude zapisován protokol o archivaci

¨ text – text události vývěsky

¨ adresář-A – adresář archivu, do kterého se ukládají archivní soubory (nepovinný údaj)

¨ adresář-* - kořenový adresář archivu. Jeho definice přímo souvisí s atributem adresář na záložce „Adresáře“. Uvedený adresář v tomto atributu následně nahrazuje * právě v atributu adresář, tzn. aby uživatel vždy nemusel vypisovat celou dlouhou cestu adresáře na každém atributu, zde uvede hlavní adresář a na záložce „Adresáře“ v atributu adresář je tento adresář nahrazen právě znakem *. Např. zde může být uveden adresář \\server\disk_k a na záložce „Adresáře“ v atributu adresář je potom uvedeno „*\bmsql\template“.

¨ aktivní – výběr z překryvného seznamu Ano/Ne – v případě potřeby vyřazení skupiny z archivace není nutno definici archivace rušit (i pro případ opětovné potřeby archivování), stačí pouze volbou Ne vyřadit z archivace

¨ nabízet – výběr z překryvného seznamu Ano/Ne – volba Ano znamená, že se daná definice archivace bude nabízet ke spuštění v hlavním menu (Inf. centrum – Utility – Archivace – Spuštění archivace) a pod menu Volby (připomenutí - pro uživatele je samozřejmě v nabídce ke spuštění v případě, že je nadefinovaná s druhem dokumentu, na který má uživatel právo zápisu)

¨ počet kopií – udává počet aktuálních kopií, který se má v přehledu archivu udržovat, tzn. je-li zde uvedeno např. 5 – v archivu se pak u dané archivace udržuje jedna hlavní archivace a 5 kopií (vždy 5 nejnovějších podle data, starší kopie se automaticky ruší). Vytváří se tzv. rozdílová archivace, tzn. že se archivují ta data, kde nastala změna. Pokud je zde v počtu kopií uvedeno číslo mínus jedna znamená to, že počet kopií je neomezen, neruší se žádná archivace

¨ poznámka – vlastní poznámka uživatele k definici archivace

Na druhé záložce „Adresáře“ se definuje, které adresáře se na uvedeném počítači mají archivovat. U každého adresáře jsou k dispozici tyto atributy:

¨ adresář – vlastní popis adresáře (tzn. včetně jeho přesné cesty). V případě síťových souborů může být část přesné cesty nahrazena znakem * (viz. atribut adresář-* na předchozí záložce). U popisu souboru je možno použít obrácené lomítko, což způsobí, že se pak v přehledu archivace ve stromu zobrazuje jako jeden adresář.

¨ popis ve stromu – popis, který se zobrazuje v přehledu archivace za atributem datum (popis není povinný údaj, lze ho doplnit i zpětně). Pokud se popis v tomto atributu zadá později, ve stromu se u daného adresáře projeví až po provedení další archivace.

¨ včetně podadresářů – možnosti Ano/ne – zda se mají archivovat i podadresáře daného souboru

¨ aktivní – možnosti Ano/Ne – volba Ano je jasná, volbu Ne uživatel použije v případě, že chce daný adresář vyloučit z archivace (a nechce ho rušit pro případ, že by ho časem opět do archivace chtěl zařadit).

¨ archivovat soubory – seznam souborů, které chce uživatel z daného adresáře archivovat uvedených v syntaxi *.název přípony souboru – oddělených čárkou (např. *dbf,*.fpt)

¨ nearchivovat soubory – stejný způsob zápisu jako u předchozího atributu s tím, že zde uživatel zadává pouze soubory, které nechce archivovat

¨ poznámka – vlastní komentář uživatele

Poslední záložkou této činnosti je záložka „Podskupiny“, která umožňuje uživateli do jedné velké skupiny sloučit několik malých.

Archivaci lze spustit z menu Volby (klávesa F9 – Spuštění archivu) a nebo z činnosti Utility – Archivace – Spuštění archivace. Po její aktivaci se uživateli zobrazí okno s nabídkou „Archivovat?“ – Ano/Ne a zároveň je u dotazu i informace o počtu archivovaných adresářů, počtu souborů a o celkové velikosti souborů.

Jednotlivé archivace lze spouštět programově a lze nastavit interval, po které době se mají automaticky provádět. Toto se provádí pomocí externího příkazu, který lze vyvolat voláním programu UTARCHIV s parametry:

1. identifikace skupiny archivu – povinný parametr

2. perioda – po kolika dnech se má archiv provádět (pokud na vývěsce existuje záznam mladší, archiv se provádět nebude) – nepovinný parametr

3. identifikace tématu vývěsky – nepovinný parametr – pokud je zde uveden, změní téma vývěsky uvedené v definici archivace

4. typ události - pokud je zde uvedeno, změní typ události uvedený v definici archivace

5. text – pokud je zde uveden, změní text uvedený u skupiny v definici archivace

6. doplnění adresáře archivu

7. počet kopií – pomocí předchozího a tohoto parametru lze nastavit automatickou dlouhodobou archivaci (pro potřeby archivace v letech, aby byl vidět průřez programem)

Datový model

  • UTARSKP Skupina archivace
    • BWPRINMC Počítač uživatele systému BM
    • SPDOKTYP Druh dokumentu
      • SPPRISTU Přístupové právo uživatele k věci
    • SPTYPUD Typ události komponenty

    • Vyvolávané činnosti

    K. | Činnost | Popis
F9 | Spuštění archivace | Spuštění archivace
F2 | Druhy dokumentů | Přehled druhů dokumentů
F2 | Druhy operací | Přehled druhů operací
F2 | Popis archivací | Popis archivací
F2 | Počítače uživatelů BM | Počítače uživatelů BM
F2 | Typy událostí komponent | Typy událostí komponent

    Formulář

    Formulář činnosti - Spuštění archivace
Mřížka [Popis archivací]
Skupina | Identifikace skupiny
Název skupiny | Název skupiny
Listovací rámeček
Stránka #1 Skupiny archivace
Počítač | Identifikace počítače v BM
Název počítače | Název počítače v BM
Druh | Identifikátor druhu dokumentu
Název druhu dokumentu | Název druhu dokumentu
Téma | Téma vývěsky, na které bude zapisován protokol o archivaci
 | Název tématu vývěsky
Typ | Typ události vývěsky, na které bude zapisován protokol o archivaci
Text | Text události vývěsky
Název typu | Název typu události komponenty
Adresář-A | Adresář archivu, do kterého má být archiv uložen
Adresář-* | Kořenový adresář (*) doplněný do popisů adresářů
Aktivní | Skupina je aktivní Ano/Ne (pro neaktivní skupinu se neprovádí archivace)
Nabízet | Nabízená skupina Ano/Ne (z nabízených skupin se vybírá při startu archivace)
Počet kopií | Počet ukládaných archivních kopií souborů ve skupině (-1=neomezený počet kopií)
Poznámka | Poznámka
Stránka #2 Adresáře
Mřížka [Adresáře]
Adresář | Archivovaný adresář (jeho název může začínat makrem %userprofile% např. %userprofile%\dokumenty)
Popis ve stromu | Popis adresáře ve stromu
Včetně podadresářů | Archivovat adresář včetně podadresářů Ano/Ne
Aktivní | Definice je aktivní Ano/Ne (pro neaktivní se neprovádí archivace)
Archivovat soubory | Seznam archivovaných souborů
Nearchivovat soubory | Seznam nearchivovaných souborů
Poznámka | Poznámka
Stránka #3 Podskupiny
Mřížka [Podskupiny]
Skupina | Identifikace podřízené skupiny
Název skupiny | Název skupiny

    Mřížka [Popis archivací] činnosti - Spuštění archivace

    Mřížka [Popis archivací] činnosti - Spuštění archivace
Skupina | Identifikace skupiny
Název skupiny | Název skupiny
Aktivní | Skupina je aktivní Ano/Ne (pro neaktivní skupinu se neprovádí archivace)
Nabízet | Nabízená skupina Ano/Ne (z nabízených skupin se vybírá při startu archivace)
Počítač | Identifikace počítače v BM
Název počítače | Název počítače v BM
Druh | Identifikátor druhu dokumentu
Název druhu dokumentu | Název druhu dokumentu

    Mřížka [Adresáře] činnosti - Spuštění archivace

    Mřížka [Adresáře] činnosti - Spuštění archivace
Adresář | Archivovaný adresář (jeho název může začínat makrem %userprofile% např. %userprofile%\dokumenty)
Aktivní | Definice je aktivní Ano/Ne (pro neaktivní se neprovádí archivace)
Včetně podadresářů | Archivovat adresář včetně podadresářů Ano/Ne
Popis ve stromu | Popis adresáře ve stromu

    Mřížka [Podskupiny] činnosti - Spuštění archivace

    Mřížka [Podskupiny] činnosti - Spuštění archivace
Skupina | Identifikace podřízené skupiny
Název skupiny | Název skupiny

    Viz.také

    Spuštění archivace | Druhy dokumentů | Druhy operací | Počítače uživatelů BM | Typy událostí komponent


MARKETING

Popis

Tato komponenta zajišťuje tok marketingových informací ve firmě. Obsahuje následující činnosti:

¨ adresář

¨ diář

¨ dokumenty

¨ vývěska

¨ pošta

¨ zprávy

Viz.také

ZPRÁVY | VÝVĚSKA | DIÁŘ | ADRESÁŘ | POŠTA | DOKUMENTY


ZPRÁVY

Popis

Modul zprávy je nástroj pro podporu managementu firmy, oddělení, projektu apod. Podporuje oblast komunikace mezi jednotlivými pracovníky ve smyslu elektronické pošty propojené na zaznamenané události a informace, čímž vytváří účinný nástroj pro řízení různých organizačních struktur. Umožňuje posílání zpráv, informací, úkolů apod. Ke zprávám je možno se vracet, vybírat je dle priority, přesměrovávat je na jiné pracovníky a mít tak neustále pod kontrolou sled informací ve firmě. Možnost posílat zprávy se signalizací na uvedené datum umožňuje přesouvat některé záležitosti na období, které si vyhradíme na jejich řešení.

Viz.také

Zprávy | Oblíbené skupiny uživatelů | Objekty Outlooku | DEKLARACE OUTLOOKU


Zprávy

Popis

Před vlastním zahájením práce s činností "zprávy" má uživatel možnost zvolit si zobrazené události zpráv pomocí záložky Výběr. Je možné zvolit zprávy nepřijaté, přijaté nebo zpracované a zároveň je možno určit zda se výběr bude týkat zpráv došlých, odeslaných nebo všech. Jako nejvhodnější se jeví si zvolit výběr došlé zprávy a stav nepřijaté a přijaté. Tak má uživatel hned „po ruce“ své přijaté a dosud nezpracované zprávy.

U každé zprávy se uživateli zobrazuje datum a čas zápisu, datum přijetí a zpracování zprávy, krátký text a komentář ke zprávě. Datum signalizace určuje datum, který den se daná zpráva objeví mezi aktuálními (tímto způsobem si uživatel může zapisovat zprávy na které nechce zapomenout, i do budoucna).

Důležitou roli v činnosti zprávy hraje i atribut připomenutí a čas. Pokud je zvoleno připomenutí „Ne“, zpráva se bude uživateli nabízet pouze v této činnosti jako aktuální nepřijatá zpráva (podle zvoleného data signalizace). Pokud je zvoleno „Ano“, tak podle nastaveného data a času se zpráva uživateli zobrazí jako samostatné okno informačního panelu (určení takto spuštěné stránky se provádí nastavením parametru BM, činnost Systém – Nastavení programu BM – Zpravy-pripomenuti_stranka, ve kterém se uvádí identifikace stránky informačního panelu, více o tomto v Návodech a balíčcích.) Zpráva je takto připomínána příjemci v případě, že:

¨ má nastaveno připomenutí „Ano“

¨ zpráva nebyla dosud zpracována

¨ datum a čas připomenutí je menší než aktuální systémové datum a čas

¨ BM v daném okamžiku nemá aktivní modální okno (tj. okno, ze kterého se nelze přepnout, např. okno s určitým systémovým dotazem, kde je nutno zvolit odpověď Ano/Ne).

Okamžik, kdy je zpráva uživateli jako samostatné okno informačního panelu připomenuta nastává:

¨ 15 vteřin po přihlášení uživatele do BM u těch zpráv, jejichž datum a čas připomenutí je v tomto okamžiku menší než aktuální systémové datum a čas

¨ u zpráv, které vznikly po spuštění programu na stejném počítači nebo jiném počítači zadané jiným uživatelem systému s maximálním zpožděním podle parametru Zpravy-pripomenuti_timeout (implicitně nastaveno 5 minut)

¨ je-li v okamžiku, kdy by mělo být zobrazeno okno s připomenutím aktivní modální okno, potom je připomenutí odloženo podle parametru Zpravy-Pripomenuti_timeout_odlozeni

¨ pokud se na zprávu nevztahuje žádná z předchozích možností, je připomenutí provedeno v určený čas

Jednotlivé zprávy (resp. položka datum signalizace v mřížce) jsou v této činnosti barevně odlišeny a zároveň mají i různé příznaky ve sloupečku "stav zpracování", takže potom vypadají následovně:

¨ červená - jedná se o aktuální zprávu, stav zpracování je " ! " a obálka u data zápisu zprávy je žlutá a zavřená

¨ modrá - jedná se o přijatou zprávu, stav zpracování je " # " a obálka u data zápisu zprávy je bílá a otevřená

¨ zelená - jedná o zpracovanou zprávu, stav zpracování je " + " a obálka u data zápisu zprávy je bílá se šipkou

¨ hnědá - jedná se o zprávu zaslanou do budoucna, stav zpracování je " - " a obálka u data zápisu zprávy je žlutá a zavřená

Pro uživatele existují tři varianty, jakým způsobem lze přijmout zprávu:

¨ dvojklikem myši přímo na sloupečku "signalizace" nebo "stav zpracování zprávy" (nejsnadnější a zároveň nejrychlejší metoda)

¨ klávesou F6 (klávesa F7 u zpracování zprávy)

¨ výběrem funkce "přijetí zprávy" přímo z menu Volby

Systém se potom dotazuje: "Skutečně přijímáte zprávu ..... ? Ano/Ne". Po potvrzení volby Ano se položka "přijetí" vyplní aktuálním datem a stav zpracování zprávy má příznak "#" (modrá barva). Stejným způsobem je pak možno zprávu přijatou změnit na zprávu zpracovanou. Po potvrzení volby Ano se položka "zpracování" vyplní aktuálním datem a stav zpracování zprávy má příznak "+" (zelená barva).

Datový model

  • PZZPRAVY Zpráva
    • BWUZIVAT Uživatel systému

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Přijetí zprávy | Potvrzení přijetí aktuální zprávy.
F7 | Potvrzení zprávy | Potvrzení zpracování aktuální zprávy.
F9 | Spustit spojenou operaci | Spustit operaci spojenou se zprávou
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
F2 | Kategorie zpráv | Seznam kategorií upřesňujících zprávy.
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

    Formulář činnosti - Spustit spojenou operaci
Mřížka [Zprávy]
Listovací rámeček
Stránka #1 Zprávy
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Přijal | Identifikace uživatele systému
 | Datum přijetí zprávy.
Zpracování | Datum zpracování zprávy.
Signalizace | Datum signalizace
Připomenutí | Připomenutí Ano/Ne
Čas | Datum a čas připomenutí
Text | Text výstižně popisující zprávu
Komentář | Komentář autora zprávy.
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Potvrzení zprávy
Stránka #2 Výběr
Signalizace od | Datum signalizace zprávy od
do | Datum signalizace zprávy do
Nepřijaté | Zobrazit nepřijaté zprávy
Přijaté | Zobrazit přijaté zprávy
Zpracované | Zobrazit zpracované zprávy
 | Došlé, odeslané, všechny
Zapsal | Identifikace uživatele systému
Přijal | Identifikace uživatele systému
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Zprávy] činnosti - Spustit spojenou operaci

    Mřížka [Zprávy] činnosti - Spustit spojenou operaci
Označování | Označení záznamu
Signalizace | Datum signalizace
S | Stav zpracování zprávy
Text | Text výstižně popisující zprávu
Zápis | Datum a čas zápisu záznamu události
Zapsal | Jméno uživatele systému

    Atributy tisku

    Základní údaje
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Příjemce | Jméno uživatele systému | BWUZIVA1_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | PZZPRAVY_sp00datzap | T
Přijetí | Datum přijetí zprávy. | PZZPRAVY_pz01datpri | T
Zpracování | Datum zpracování zprávy. | PZZPRAVY_pz01datzpr | T
Signalizace | Datum signalizace | PZZPRAVY_pz01datum | D
Připomenutí | Připomenutí Ano/Ne | Výpočet | C(3)
Čas | Datum a čas připomenutí | PZZPRAVY_pz01casprp | T
Text zprávy | Text výstižně popisující zprávu | PZZPRAVY_pz01text | C(40)
Komentář | Komentář autora zprávy. | PZZPRAVY_pz01koment | M
Obchodní selektor | Identifikátor obchodního selektoru | PZZPRAVY_sp10idzak | C(9)
Organizační selektor | Identifikátor organizačního selektoru. | PZZPRAVY_sp11idzak | C(9)
Technicko-věcný selektor | Identifikátor technicko-věcného selektoru. | PZZPRAVY_sp20idzak | C(9)

    Viz.také

    Přijetí zprávy | Potvrzení zprávy | Spustit spojenou operaci | OZNAČOVÁNÍ | Kategorie diáře | Obchodní selektor | Organizační selektor | Technicko-věcný selektor | Výběr uživatelů pro zápis


Oblíbené skupiny uživatelů

Popis

Tato činnost umožňuje uživateli nadefinovat oblíbené skupiny uživatelů, které využije při zasílání zpráv (odesílání zpráv více uživatelům najednou - pomocí šablony) nebo při zápisu do diáře ostatním pracovníkům. Při odesílání zprávy pouze jednomu uživateli tuto činnost nevyužije. V jedné skupině může mít např. pouze pracovníky obchodního oddělení, kterým posílá zprávy o obchodních jednáních, druhá skupina mohou být např. pracovníci systémové integrace apod. Využíváním oblíbených skupin si uživatel značně zjednoduší práci, protože nemusí jednotlivé pracovníky vybírat ze seznamu po jednom a nedojde tím k situaci, že by na někoho nechtěně zapomněl.

Uživatel v této činnosti zadává identifikaci a název skupiny. Po stisku záložky "uživatelé ve skupině" přiřazuje jednotlivé uživatele do aktuální skupiny. Výběr uživatelů do dané skupiny se provádí zatržením příznaku označení (tj. malé okénko před vlastním jménem uživatele).

Po nadefinování jednotlivých skupin (včetně přiřazení uživatelů do skupiny) má uživatel možnost prohlížet si záznamy v diáři vybrané skupiny uživatelů. Tento diář lze vyvolat stiskem klávesy F5 nebo výběrem činnosti z menu "volby".

Pokud si uživatel nenadefinuje žádnou oblíbenou skupinu uživatelů, nabízí se mu při zasílání zpráv nebo při zápisu do diáře seznam všech uživatelů systému, ze kterého si pak vybírá jednotlivé příjemce. Pokud má skupinu nadefinovanou, pak při odesílání zprávy pomocí šablony si v prvním překryvném seznamu tuto skupinu vybere.

Datový model

  • PZOBLSKU Oblíbená skupina uživatelů

    • Formulář

    Formulář činnosti - Diář
Mřížka [Oblíbené skupiny uživatelů]
Skupina | Identifikace oblíbené skupiny uživatelů
Název | Název oblíbené skupiny uživatelů
Diář
Listovací rámeček
Stránka #1 Oblíbené skupiny uživatelů
Mřížka [Uživatelé oblíbené skupiny]
Stránka #2 Uživatelé ve skupině
Mřížka [Uživatelé oblíbené skupiny uživatelů]

    Mřížka [Oblíbené skupiny uživatelů] činnosti - Diář

    Mřížka [Oblíbené skupiny uživatelů] činnosti - Diář
Skupina | Identifikace oblíbené skupiny uživatelů
Název skupiny | Název oblíbené skupiny uživatelů

    Mřížka [Uživatelé oblíbené skupiny] činnosti - Diář

    Mřížka [Uživatelé oblíbené skupiny] činnosti - Diář
Uživatel | Jméno uživatele systému
Uživatel (úplné jméno) | Úplné jméno uživatele systému

    Mřížka [Uživatelé oblíbené skupiny uživatelů] činnosti - Diář

    Mřížka [Uživatelé oblíbené skupiny uživatelů] činnosti - Diář
Označování | Označení záznamu
Uživatel | Jméno uživatele systému
Uživatel (úplné jméno) | Úplné jméno uživatele systému

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Diář skupiny uživatelů | Diář vybrané skupiny uživatelů

    Viz.také

    Diář


Objekty Outlooku

Popis

Tato činnost umožňuje zpracovávat data zapsaná v Outlooku v IS BM.

Datový model

  • PZOLOBT Obraz objektu Outlooku v BM
    • PZOLOB Druh objektu Outlooku

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Zobrazit objekt BM | Zobrazit objekt BM spojený s objektem Outlooku
F2 | Druh objektu Outlooku | Druh objektu Outlooku

    Formulář

    Formulář činnosti - Zobrazit objekt BM
Mřížka [Objekty Outlooku]
Listovací rámeček
Stránka #1 Objekty Outlooku
Datum | Datum a čas objektu Outlooku
Provedl | Úplné jméno uživatele systému
Stav | Stav objektu
Předmět | Předmět
BM | Název objektu BM
Druh OL | Název druhu objektu Outlooku
Poznámka | Poznámka
Stránka #2 Výběr druhu objektu
Druh OL | Identifikace druhu objektu Outlooku
Stav | Stav objektu
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Objekty Outlooku] činnosti - Zobrazit objekt BM

    Mřížka [Objekty Outlooku] činnosti - Zobrazit objekt BM
Datum | Datum a čas objektu Outlooku
Předmět | Předmět
Poznámka | Poznámka
Založil | Úplné jméno uživatele systému
BM | Identifikátor druhu objektu v BM
Název objektu BM | Název objektu BM
Druh OL | Identifikace druhu objektu Outlooku
Název objektu | Název druhu objektu Outlooku

    Viz.také

    Zobrazit objekt BM | Druh objektu Outlooku


DEKLARACE OUTLOOKU

Popis

Činnost umožňují nastavení definic mezi Outlookem a činnostmi v IS BM.

Viz.také

Druh objektu Outlooku | Konverze adresy do outlooku | Transformace BM->Outlook


Druh objektu Outlooku

Popis

Tato činnost umožňuje definovat jednotlivé druhy objektu Outlooku. U každého druhu se zadává:

¨ identifikace a název druhu objektu

¨ seznam složek Outlooku (oddělených středníkem), ve kterých se daný objekt nachází (např. doručená pošta, deník apod.)

¨ text pro návěští (data, předmětu, poznámky) – text pro návěští (data, předmětu, poznámky) v prezentaci v IS BM

¨ výraz vlastnosti (data, předmětu, poznámky) – výraz vlastnosti (data, předmětu, poznámky) objektu Outlooku pro prezentaci v BM

¨ poznámka – vlastní komentář

Datový model

  • PZOLOB Druh objektu Outlooku

    • Formulář

    Formulář činnosti - Spuštění archivace
Mřížka [Druh objektu]
Druh | Identifikace druhu objektu Outlooku
Název objektu | Název druhu objektu Outlooku
Seznam složek Outlooku | Seznam složek Outlooku oddělených středníkem, ve kterých se objekt nachází
Text pro návěští data | Text pro návěští data v prezentaci v BM
Výraz vlastnosti data | Výraz vlastnosti data objektu Outlooku pro prezentaci v BM
Text pro návěští předmětu | Text pro návěští předmětu v prezentaci v BM
Výraz vlastnosti předmětu | Výraz vlastnosti předmětu objektu Outlooku pro prezentaci v BM
Text pro návěští poznámky | Text pro návěští poznámky v prezentaci v BM
Výraz vlastnosti předmětu | Výraz vlastnosti poznámky objektu Outlooku pro prezentaci v BM
Poznámka | Poznámka

    Mřížka [Druh objektu] činnosti - Spuštění archivace

    Mřížka [Druh objektu] činnosti - Spuštění archivace
Druh | Identifikace druhu objektu Outlooku
Název objektu | Název druhu objektu Outlooku

    Atributy tisku

    Základní údaje
Druh | Identifikace druhu objektu Outlooku | PZOLOB_pz09id | C(6)
Název objektu | Název druhu objektu Outlooku | PZOLOB_pz09nazobj | C(40)
Seznam složek Outlooku | Seznam složek Outlooku oddělených středníkem, ve kterých se objekt nachází | PZOLOB_pz09folder | M
Text pro návěští data | Text pro návěští data v prezentaci v BM | PZOLOB_pz09dtalab | M
Výraz vlastnosti data | Výraz vlastnosti data objektu Outlooku pro prezentaci v BM | PZOLOB_pz09dtaatr | M
Text pro návěští předmětu | Text pro návěští předmětu v prezentaci v BM | PZOLOB_pz09sublab | M
Výraz vlastnosti předmětu | Výraz vlastnosti předmětu objektu Outlooku pro prezentaci v BM | PZOLOB_pz09subatr | M
Text pro návěští poznámky | Text pro návěští poznámky v prezentaci v BM | PZOLOB_pz09bodlab | M
Výraz vlastnosti předmětu | Výraz vlastnosti poznámky objektu Outlooku pro prezentaci v BM | PZOLOB_pz09bodatr | M
Poznámka | Poznámka | PZOLOB_pz09koment | M


Konverze adresy do outlooku

Popis

V této činnosti se definují jednotlivé konverze (tj. přeměna, obrat) adresy z IS BM do aplikace Outlook. Zadává se:

¨ identifikace a název konverze adresy příjemce v Outlooku

¨ BM – identifikace objektu IS BM (výběr z překryvného seznamu)

¨ typ – typ určení adresy příjemce v Outlooku (výběr z překryvného seznamu)

¨ výraz konverze

¨ poznámka

Datový model

  • PZOLREC Konverze adresy do Outlooku

    • Formulář

    Formulář činnosti - Spuštění archivace
Mřížka [Konverze]
Konverze | Identifikace konverze adresy příjemce v Outlooku
Název konverze | Název konverze adresy příjemce v Outlooku
BM | Identifikace objektu BM
Typ | Typ určení adresy příjemce v Outlooku
Výraz konverze | Výraz konverze
Poznámka | Poznámka

    Mřížka [Konverze] činnosti - Spuštění archivace

    Mřížka [Konverze] činnosti - Spuštění archivace
Konverze | Identifikace konverze adresy příjemce v Outlooku
BM | Identifikace objektu BM
Název konverze | Název konverze adresy příjemce v Outlooku

    Atributy tisku

    Základní údaje
Identifikace objektu BM | Identifikace objektu BM | PZOLREC_bw55objec | C(2)
Konverze | Identifikace konverze adresy příjemce v Outlooku | PZOLREC_pz12id | C(6)
Název konverze | Název konverze adresy příjemce v Outlooku | PZOLREC_pz12nazkon | C(40)
Typ | Typ určení adresy příjemce v Outlooku | Výpočet | C(17)
Výraz konverze | Výraz konverze | PZOLREC_pz12vyraz | M
Poznámka | Poznámka | PZOLREC_pz12koment | M


Transformace BM->Outlook

Popis

V této činnosti se definují jednotlivé transformace mezi objekty IS BM a aplikací Outlook a k nim výrazy pro transformaci. U každé transformace se zadává:

¨ identifikace a název transformace

¨ BM – identifikace objektu IS BM (výběr z překryvného seznamu)

¨ druh objektu (výběr z číselníku)

¨ konverze (výběr z číselníku)

¨ poznámka

Záložka „výrazy pro transformaci“ obsahuje definici jednotlivých výrazů dané transformace, kterou by měl provádět pouze zkušený uživatel nebo implementátor.

Datový model

  • PZOLTRA Transformace objektu BM do Outlooku
    • PZOLOB Druh objektu Outlooku
    • PZOLREC Konverze adresy do Outlooku

    • Formulář

    Formulář činnosti - Odeslat do Outlooku
Mřížka [Transformace]
Transformace | Identifikace transformace
Transformace | Název transformace
BM | Identifikace objektu BM
Listovací rámeček
Stránka #1 Transformace
Druh OL | Identifikace druhu objektu Outlooku
Název objektu | Název druhu objektu Outlooku
Konverze | Identifikace konverze adresy příjemce v Outlooku
Název konverze | Název konverze adresy příjemce v Outlooku
Poznámka | Poznámka
Stránka #2 Výrazy pro transformaci
Mřížka [Výrazy pro transformaci]
Vlastnost | Vlastnost objektu Outlooku
Výraz objektu BM | Výraz objektu BM
Poznámka | Poznámka

    Mřížka [Transformace] činnosti - Odeslat do Outlooku

    Mřížka [Transformace] činnosti - Odeslat do Outlooku
Transformace | Identifikace transformace
BM | Identifikace objektu BM
Transformace | Název transformace

    Mřížka [Výrazy pro transformaci] činnosti - Odeslat do Outlooku

    Mřížka [Výrazy pro transformaci] činnosti - Odeslat do Outlooku
Vlastnost | Vlastnost objektu Outlooku
Výraz objektu BM | Výraz objektu BM

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druh objektu Outlooku | Druh objektu Outlooku
F2 | Konverze adresy do outlooku | Konverze adresy do outlooku

    Atributy tisku

    Základní údaje
Transformace | Identifikace transformace | PZOLTRA_pz10id | C(6)
Transformace | Název transformace | PZOLTRA_pz10naztra | C(40)
Identifikace objektu BM | Identifikace objektu BM | PZOLTRA_bw55objec | C(2)
Druh OL | Identifikace druhu objektu Outlooku | PZOLTRA_pz09id | C(6)
Název objektu | Název druhu objektu Outlooku | PZOLOB_pz09nazobj | C(40)
Konverze | Identifikace konverze adresy příjemce v Outlooku | PZOLTRA_pz12id | C(6)
Název konverze | Název konverze adresy příjemce v Outlooku | PZOLREC_pz12nazkon | C(40)
Poznámka | Poznámka | PZOLTRA_pz10koment | M

    Při pohybu v Výrazy transformace
Vlastnost | Vlastnost objektu Outlooku | PZOLTRAV_pz11proper | C(30)
Výraz objektu BM | Výraz objektu BM | PZOLTRAV_pz11vyraz | M
Poznámka | Poznámka | PZOLTRAV_pz11koment | M

    Viz.také

    Druh objektu Outlooku | Konverze adresy do outlooku | Odeslat do Outlooku


VÝVĚSKA

Popis

Komponenta vývěska je nástroj pro podporu managementu firmy, oddělení, projektu apod. Podporuje oblast zaznamenání všech událostí, dokumentování chodu organizační jednotky s možností rychlého vyhledávání. Události lze uspořádat do logických uskupení, čímž vytváří účinný nástroj k řízení různých organizačních struktur, k dořešení organizační struktury ve smyslu kompetencí a odpovědnosti a k celkovému zkvalitnění systému řízení. Události lze ukládat strukturovaně podle obsahu a organizační struktury do různých témat. Každá událost má svou základní část a může být rozšířena o další údaje. Každá událost může mít také svůj dokument.

Viz.také

Vývěska | Aktuální hodnoty vývěsky | VÝZNAMNÉ UZLY | Uzly vývěsky


Vývěska

Popis

Před vlastním spuštěním činnosti vývěska má uživatel možnost nadefinovat si záložku Výběr, čímž je určena množina dat, se kterou chce pracovat.

Základní informací vývěsky je "událost vývěsky", což je datovaný záznam o nějaké (pro firmu) významné události. Záznamy se ukládají do pomyslných "škatulek", jimiž jsou témata. Strukturu a počet témat definuje uživatel tak, aby co nejlépe popisovala jeho činnost. Pokud je událost vývěsky součástí operace, která běží v nějakém procesu, automaticky se jako téma předplňuje identifikace dané operace. Když je událost vývěsky zapisována samostatně, identifikace operace se jako téma zadává ručně.

Událost vývěsky se může týkat některého adresáta z adresáře, který je součástí informačního systému. V tomto případě je název "adresát" poněkud nepřesný, neboť mu není záznam určen, pouze je o něm veden. Pro určitou zavedenost pojmu budeme však název adresát dále používat.

Při zadání události vývěsky tedy uživatel zadává:

¨ téma – výběr z číselníku (tj. druhu operací)

¨ adresát a jeho spojení – výběr z adresáře

¨ datum – předplňuje se aktuální datum

¨ text – krátký popis události

¨ příznak blokování – takto zaškrtnutá událost je blokována pro případ editování – povoleno pouze uživateli, který událost zapsal

¨ komentář – libovolný komentář k události

¨ typ události komponenty

¨ zdroj informace – je uveden uživatel, který je zdrojem uvedené informace zapsané v události

¨ selektory

¨ zapsal – automaticky je předplněno jméno uživatele, který událost zadává

K jednotlivým událostem vývěsky lze vytvářet souvislosti, což pak uživateli umožňuje vyvolat si událost vývěsky i z jiných činností (např. ze zpráv, z diáře, z dokumentů, z adresáře....).

Pod menu Volby (nebo po stisku klávesy Ctrl U) má uživatel k dispozici činnost „Komunikace nad záznamem“, jejíž pomocí může sledovat, kterému uživateli byla na základě dané události vývěsky odeslána zpráva a její stav.

Datový model

  • VYUDALOS Událost vývěsky
    • SPPRISTU Přístupové právo uživatele k věci
    • BWUZIVAT Uživatel systému
    • ADSPOJ Spojení adresáta
      • ADADR Adresa
      • ADADSAT Adresát
    • SPTYP Druh procesu/operace
    • SPTYPUD Typ události komponenty

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Strom vývěsky | Strom vývěsky
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^U | Komunikace nad záznamem | Definice přístupových práv jednotlivých pracovníků
- | INFORMACE O ADRESÁTOVI | Vývěska adresáta a pošta adresáta...
- | Štítek adresáta |
- | VÝVĚSKY | Vývěska synů, otců, adresáta, tématu
F2 | Adresář | Přehled adresátů
F2 | Druhy operací | Přehled druhů operací
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Předlohy dokumentů | Definice předloh dokumentů
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Typy událostí komponent | Typy událostí komponent

    Formulář

    Formulář činnosti - Typy událostí komponent
Mřížka [Vývěska]
Listovací rámeček
Stránka #1 Vývěska
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Téma | Identifikátor tématu
 | Název druhu procesu
Adresát | Identifikace adresáta
Spojení | Číslo spojení adresáta.
 | Název adresáta
Datum | Datum pořízení události.
Text | Text výstižně popisující událost.
Komentář | Komentář, který detailně popisuje událost.
Typ | Identifikátor typu události komponenty
Zdroj informace | Identifikace uživatele systému
Blokování | Příznak blokování záznamu události pro opravu.
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Návrat k předchozí
Stránka #2 Výběr
Zapsal | Identifikace uživatele systému
Adresát | Identifikace adresáta
Spojení | Číslo spojení adresáta.
 | Název adresáta
Téma | Identifikátor tématu
Typ | Identifikátor typu události komponenty
Datum od | Datum události od
do | Datum události do
Zdroj info. | Identifikace uživatele systému
Text | Text výstižně popisující událost.
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Vývěska] činnosti - Typy událostí komponent

    Mřížka [Vývěska] činnosti - Typy událostí komponent
Označování | Označení záznamu
Datum | Datum pořízení události.
Text | Text výstižně popisující událost.
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Název tématu | Název druhu procesu
Typ události | Název typu události komponenty

    Atributy tisku

    Základní údaje
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | VYUDALOS_sp00datzap | T
Adresát | Identifikace adresáta | VYUDALOS_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Téma | Identifikátor tématu | VYUDALOS_sp07idtyp | C(6)
Název tématu | Název tématu vývěsky | SPTYP_sp07text | C(30)
Datum pořízení | Datum pořízení události. | VYUDALOS_vy01datum | D
Text | Text výstižně popisující událost. | VYUDALOS_vy01text | C(40)
Komentář | Komentář, který detailně popisuje událost. | VYUDALOS_vy01koment | M
Vyřizuje | Jméno uživatele systému | BWUZIVA1_bw01jmeno | C(30)
Obchodní selektor | Identifikátor obchodního selektoru | VYUDALOS_sp10idzak | C(9)
Organizační selektor | Identifikátor organizačního selektoru. | VYUDALOS_sp11idzak | C(9)
Technicko-věcný selektor | Identifikátor technicko-věcného selektoru. | VYUDALOS_sp20idzak | C(9)
Ulice adresy adresáta | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
Město adresy adresáta | Město adresy adresáta. | ADADR_ad02mesto | C(40)
PSČ adresy adresáta | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Stát v adrese adresáta | Identifikace státu. | ADADR_ad05id | C(3)
UTO | Národní směrové číslo státu pro telefonní spojení (UTO). | ADSPOJ_ad13nsc | C(4)
Volané telefonní číslo | Telefonní číslo | ADSPOJ_ad11cislo | C(60)
Jméno kontaktní osoby | Jméno kontaktní osoby. | ADSPOJ_ad11jmeno | C(40)
Jméno na štítek | Jméno pracovníka na poštovní štítek | ADSPOJ_ad11jmenop | C(100)
Funkce | Funkce kontaktní osoby | ADSPOJ_ad11funkce | C(40)
Adresát | Identifikace adresáta | ADSPOJ_ad01id | C(6)
Fax | Faxové číslo | ADSPOJ_ad11fax | C(60)
Jiné | Jiné spojení adresáta | ADSPOJ_ad11cisost | C(60)
Mobil | Číslo mobilního telefonu | ADSPOJ_ad11mobil | C(60)
e-mail | E-mail spojení adresáta | ADSPOJ_ad11email | C(60)

    Viz.také

    Strom vývěsky | OZNAČOVÁNÍ | Komunikace nad záznamem | INFORMACE O ADRESÁTOVI | Štítek adresáta | VÝVĚSKY | Adresář | Druhy operací | Obchodní selektor | Organizační selektor | Předlohy dokumentů | Spojení adresátů | Technicko-věcný selektor | Typy událostí komponent | DOKUMENTY | Pošta


Aktuální hodnoty vývěsky

Popis

Aktuální hodnoty komponenty vývěska slouží pro potřeby evidence určitých sumárních údajů, např. možnost sledování odesílané korespondence apod.

Datový model

  • VYAH Aktuální hodnota vývěsky
    • ADADSAT Adresát
    • SPSTATDI Druh hodnoty
    • SPTYP Druh procesu/operace

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresář | Přehled adresátů
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Druhy operací | Přehled druhů operací

    Formulář

    Formulář činnosti - Adresář
Mřížka [Aktuální hodnoty vývěsky]
Listovací rámeček
Stránka #1 Aktuální hodnoty
 | Identifikace komponenty
Druh hodnoty | Identifikace druhu hodnoty
 | Název druhu hodnoty
Druh operace | Identifikátor druhu operace
 | Název druhu procesu
Adresát | Identifikace adresáta
 | Název adresáta
Hodnota | Aktuální hodnota vývěsky
Stránka #2 Výběr
Druh hodnoty | Identifikace druhu hodnoty
Druh operace | Identifikátor druhu procesu
Adresát | Identifikace adresáta
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Aktuální hodnoty vývěsky] činnosti - Adresář

    Mřížka [Aktuální hodnoty vývěsky] činnosti - Adresář
Komponenta | Identifikace komponenty
Druh hodnoty | Identifikace druhu hodnoty
Druh operace | Identifikátor druhu procesu
Adresát | Identifikace adresáta
Hodnota | Aktuální hodnota vývěsky
Název druhu hodnoty | Název druhu hodnoty
Název druhu operace | Název druhu operace
Název adresáta | Název adresáta

    Atributy tisku

    Základní údaje
Identifikace adresáta | Identifikace adresáta | VYAH_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Druh operace | Identifikátor druhu operace | VYAH_sp07idtyp | C(6)
Název druhu operace | Název druhu operace | SPTYP_sp07text | C(30)
Hodnota | Aktuální hodnota vývěsky | VYAH_vy52hodnot | N(20,4)
Komponenta | Identifikace komponenty | VYAH_sp06idsubs | C(3)
Druh hodnoty | Identifikace druhu hodnoty | VYAH_sp67id | C(3)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)

    Viz.také

    Adresář | Druhy hodnot | Druhy operací


VÝZNAMNÉ UZLY

Popis

Mezi činnosti, které může uživatel v této komponentě využít patří i uzly vývěsky. Události vložené do činnosti „uzly vývěsky“ se pak automaticky zobrazují jako listové položky hlavního menu i ve skupinové položce menu Významné uzly.

Při vytváření jednotlivých uzlů vývěsky uživatel využívá vytvořené objektové vazby mezi jednotlivými událostmi. Jako uzel vývěsky se vkládá událost typu „otec“ (tj. předchůdce) a po její aktivaci se uživateli aktivuje činnost s událostmi typu „syn“ (tj. následník) k danému uzlu vývěsky. Jak uzly vývěsky, tak i vytváření objektových vazeb (s tím souvisí i pojem objekt) a s tím spojené nastavení rámečku souvislostí je detailně popsáno ve slovníku pojmů.

Datový model

  • VYOZNAC Uzel vývěsky
    • VYUDALOS Událost vývěsky
      • SPTYP Druh procesu/operace

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Uzly vývěsky

Popis

Uživatel má možnost pomocí vytváření souvislostí definovat uzly vývěsky, které v podstatě zastávají roli "oblíbeného otce" událostí.

Na kompletní vývěsce si uživatel zvolí událost, která má být uzlem vývěsky, tzn. takovou událost, která je pomocí souvislostí spojena s mnoha dalšími událostmi, a ke které se uživatel častěji vrací (např. obchodník připravuje významnou firemní akci, takže má vytvořenu událost AKCE, pod níž „věší“ všechny s ní spojené záznamy, tzn. pozvánky, přihlášky apod.). Takže AKCE bude právě ta událost, kterou si vloží do uzlů vývěsky.

Další postup je následující:

¨ na obrazovce má tedy uživatel spuštěnu činnost kompletní vývěska a zároveň činnost uzly vývěsky. Pomocí stisku ikony "strom" v činnosti kompletní vývěska a jejím přenesením do činnosti uzly vývěsky se vytvoří z dané události uzel vývěsky. Přenesení události se provádí způsobem běžným u windowsovských aplikací, tj. "táhni a drž".

¨ u každého uzlu má uživatel po stisku pravého tlačítka myši možnost definovat jeho vlastnosti

¨ kliknutím tlačítka myši (levého) na zvoleném uzlu vývěsky se uživateli zobrazí události vývěsky spojené právě s tímto uzlem

Datový model

  • VYOZNAC Uzel vývěsky
    • VYUDALOS Událost vývěsky
      • SPTYP Druh procesu/operace
      • BWUZIVAT Uživatel systému

    • Formulář

    Formulář činnosti - Vlastnosti uzlu vývěsky
    Uzly vývěsly

    Viz.také

    Vlastnosti uzlu vývěsky


DIÁŘ

Popis

Komponenta diář je nástroj pro time-management pracovníků firmy, který je napojen na komunikační a informační část popsanou v modulech "vývěska" a "zprávy".

Kromě vlastního diáře jsou pracovníkům k dispozici i diáře spolupracovníků, a to podle kompetencí definovaných v činnosti "přístupová práva".

Viz.také

Diář | Kategorie diáře


Diář

Popis

Činnost diář umožňuje uživateli vést záznamy týkající se jeho vlastního diáře nebo má možnost prohlížet si a zapisovat záznamy do diáře svých spolupracovníků (v případě potřeby může i jiný uživatel zapsat záznam do jeho deníku).

Podle nastavení filtru na záložce "Výběr" může uživatel ovlivnit zobrazení záznamů v diáři. Na výběr je několik třídících hledisek, navíc po stisku příznaku "uchovat" se nadefinované výběry uchovají a po dalším spuštění činnosti diář se záznamy diáře budou zobrazovat právě podle tohoto nastaveného výběru.

Mezi základní údaje, které uživatel při zápisu do diáře vyplňuje patří např. datum a čas od - do, kategorie, text a příznak, zda se jedná o událost pracovní či soukromou. Při zápisu záznamů do diáře může dojít k časovému překryvu jednotlivých záznamů. V tomto případě systém uživatele upozorňuje, že došlo k překryvu jednotlivých záznamů. Je zcela na vůli uživatele, zda tento záznam zapíše či nikoliv. Pokud ho přesto zapíše, je u tohoto záznamu zobrazena výstražná značka upozorňující na překryv.

Uživatel má možnost zápisu do diáře ostatním pracovníkům. Tato možnost je ovlivněna nadefinovanými přístupovými právy. Zápisem do diáře vytvořeným na základě vstupu pomocí šablony je pak možno provést zápis do diáře více pracovníkům (k tomu lze využít nadefinované oblíbené skupiny uživatelů, viz. zprávy).

Jednotlivé zápisy v diáři jsou od sebe barevně odlišeny. Možnosti barev jsou:

¨ černá - jedná se o běžný zápis do vlastního diáře

¨ červená - v případě, že u daného záznamu došlo k překryvu s jiným záznamem

¨ modrá - zápis do diáře jinému uživateli nebo zápis ve vlastním diáři, který mi zapsal jiný uživatel

¨ zelená - zápis do vlastního diáře s příznakem soukromé

Datový model

  • DIDIAR Záznam diáře
    • DIPOPDIA Kategorie diáře
    • BWUZIVAT Uživatel systému (alias BWUZIVA1)
    • BWUZIVAT Uživatel systému
    • SPPRISTU Přístupové právo uživatele k věci

    • Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
F2 | Kategorie diáře | Seznam kategorií.
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

    Formulář činnosti - Diář
Mřížka [Diář]
Listovací rámeček
Stránka #1 Diář
Majitel | Identifikace uživatele systému
Začátek | Událost začíná časem
Konec | Událost končí časem
Kategorie | Identifikátor kategorie.
 | Text výstižně popisující kategorii.
Popis | Výstižný popis záznamu diáře.
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Soukromé | Skryje událost před ostatními uživateli
Komentář | Komentář, který detailně popisuje událost.
Stránka #2 Výběr
Majitel | Identifikace uživatele systému
Skupina | JČI oblíbené skupiny
Začátek | Událost začíná časem
Konec | Událost končí časem
Kategorie | Identifikátor kategorie.
Nesoukromé | Příznak zobrazení pracovních událostí diáře
Soukromé | Příznak zobrazení soukromých událostí diáře
Pondělí | Výpis volných termínů v pondělí ?
Úterý | Výpis volných termínů v úterý ?
Středa | Výpis volných termínů ve středu ?
Čtvrtek | Výpis volných termínů ve čtvrtek ?
Pátek | Výpis volných termínů v pátek ?
Sobota | Výpis volných termínů v sobotu ?
Neděle | Výpis volných termínů v neděli ?
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Diář] činnosti - Diář

    Mřížka [Diář] činnosti - Diář
Označování | Označení záznamu
Začátek | Událost začíná časem
Konec | Událost končí časem
Popis | Výstižný popis záznamu diáře.
Majitel | Jméno uživatele systému

    Atributy tisku

    Základní údaje
Majitel | Jméno uživatele systému | BWUZIVA1_bw01jmeno | C(30)
Událost datum a čas od | Událost začíná časem | DIDIAR_di01od | T
Událost datum a čas do | Událost končí časem | DIDIAR_di01do | T
Kategorie | Identifikátor kategorie. | DIDIAR_di02id | C(6)
Název kategorie | Text výstižně popisující kategorii. | DIPOPDIA_di02kateg | C(40)
Popis události diáře | Výstižný popis záznamu diáře. | DIDIAR_di01text | C(40)
Soukromé | Skryje událost před ostatními uživateli | Výpočet | C(3)
Komentář | Komentář, který detailně popisuje událost. | DIDIAR_di01koment | M
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)

    Viz.také

    Přístupová práva | OZNAČOVÁNÍ | Kategorie diáře | Obchodní selektor | Organizační selektor | Technicko-věcný selektor


Kategorie diáře

Popis

Tato činnost umožňuje definovat kategorie, podle kterých je možno rozlišovat a zaznamenávat zprávy nebo záznamy v diáři. U každé kategorie se vyplňují tyto údaje:

¨ identifikace a název kategorie

¨ kolize – Ano/ne – příznak, zda vyhodnocovat kolize při použití v rezervaci spravovaného majetku

Datový model

  • DIPOPDIA Kategorie diáře

    • Vyvolávané činnosti

    K. | Činnost | Popis
- | Diář kategorie | Diář dané kategorie

    Formulář

    Formulář činnosti - Diář
Mřížka [Kategorie diáře]
Kategorie | Identifikátor kategorie.
Název | Text výstižně popisující kategorii.
Kolize | Vyhodnocovat kolize při použití v rezervaci spravovaného majetku
Zapsal | Jméno uživatele systému
Diář

    Mřížka [Kategorie diáře] činnosti - Diář

    Mřížka [Kategorie diáře] činnosti - Diář
Kategorie | Identifikátor kategorie.
Název kategorie | Text výstižně popisující kategorii.

    Atributy tisku

    Základní údaje
Kategorie | Identifikátor kategorie. | DIPOPDIA_di02id | C(6)
Název kategorie | Text výstižně popisující kategorii. | DIPOPDIA_di02kateg | C(40)
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Kolize | Vyhodnocovat kolize při použití v rezervaci spravovaného majetku | Výpočet | C(3)

    Viz.také

    Diář


ADRESÁŘ

Popis

Činnost adresář umožňuje evidenci adresátů. Adresátem se chápe každý, s kým uživatel systému v rámci činnosti vstoupí nebo může vstoupit v jednání. Všechny informace v systému jsou vztaženy (přímo nebo nepřímo) k adresátovi. Činnost umožňuje vést informace o adresách adresáta a o jeho spojení. Adresáta je možno zařazovat do uživatelsky definovaných kategorií.

Formulář

kam jdes breto

Viz.také

Adresář | Kategorie adresátů | INFORMACE K ADRESÁTŮM | ČÍSELNÍKY A PARAMETRY


Adresář

Popis

Tato činnost umožňuje prohlížet a aktualizovat vlastní adresář, tzn., že uživatel má k dispozici veškeré údaje o adresátech, jeho adresách, spojeních a zařazení adresáta v kategoriích. Každého adresáta je navíc možno přiřadit určitému druhu a k druhu adresátů je pak možno nadefinovat přístupová práva (viz. činnost druhy adresátů – adresář – číselníky a parametry). Při zařazení nového adresáta je systémem automaticky předplněno číslo adresáta podle nadefinované číselné řady adresátů (o jedno vyšší než je poslední použité číslo adresáta). V případě, že v mezičase zařazování vložil jiný uživatel dalšího nového adresáta, je číslo adresáta automaticky změněno na první volné číslo v číselné řadě adresátů.

U každého adresáta má uživatel možnost využít celou řadu záložek, kde má k dispozici adresy adresáta, jeho spojení, bankovní spojení, zařazení v kategoriích a další informace (např. plátce DPH, rodné číslo, jednací číslo z obchodního rejstříku apod.), které zřejmě všichni uživatelé plně nevyužijí. Na první záložce jsou k dispozici tyto atributy:

¨ adresát – identifikace a název

¨ IČO, DIČ

¨ implicitní adresa - identifikace

¨ konverze pro štítek

¨ vlastní adresa

¨ identifikace spojení

¨ identifikátor typu subjektu pro spojení adresáta

¨ jméno, telefon, mobil, e-mail apod.

¨ obchodní selektor

¨ druh adresáta (s možností definice přístupových práv)

Při vkládání adresáta může uživatel využít možnosti, kterou mu poskytuje doplňující vlastnost formuláře „předplnění adresáta podle ARES“. Další zajímavou vlastností adresáře je, že pokud uživatel potřebuje, lze si pomocí doplňující vlastnosti formuláře „Mapy“ zobrazit na mapě trasu k vybranému uživateli nebo více vybraným uživatelům najednou.

Na záložce Adresy má uživatel k dispozici jednotlivé adresy, které náleží uživateli. Každá adresa je následně spojena s určitým spojením adresáta.

Na záložce Spojení má uživatel k dispozici tlačítko "Impl", kterým určuje, které spojení adresáta je implicitní, tedy to, které je pak zobrazováno na první záložce Adresát a které se automaticky předplňuje v událostech adresáta. Implicitní spojení je zobrazeno červeně. Při potřebě změny spojení je nutno umístit kurzor na zvolené spojení a stisknout tlačítko Impl.

Stejným způsobem lze nadefinovat implicitní bankovní spojení. Na záložce Bankovní spojení se stiskne tlačítko „Impl“ a implicitní bankovní spojení je zvýrazněno červeně. Bankovní spojení, která nejsou aktuální se zobrazí šedivě. Na záložce Bankovní spojení se evidují bankovní účty daného adresáta. V případě, že adresát má několik bankovních spojení, je vhodné si označit implicitní bankovní spojení (pomocí tlačítka Impl.). Pomocí doplňující vlastnosti „Předplnění bank. účtu dle reg. plát. DPH“ je možno si automaticky natáhnout bankovní spojení daného adresáta. Stačí po stisku F3 dát na kódu banky * a stisknout Enter. V přehledném okně se předplní kód banky, předčíslí a číslo účtu dle rejstříku plátců DPH (pokud tedy toto spojení v IS BM již neexistuje). Má-li adresát více než jeden účet, je v tabulce si možno z nabídky všech jeho účtů vybrat. Zároveň se danému adresátu na záložce „Další“ automaticky nastaví příznak plátce DPH na Ano.

Záložka Kategorie slouží k evidenci příslušnosti adresáta do kategorie. Při zakládání se vybírá kategorie, do které bude příslušet a zároveň je možno zadat datum zařazení (automaticky se předplňuje aktuálním datem). V případě vyřazení adresáta z kategorie se zadá i datum vyřazení. Každý adresát může být zařazen do několika kategorií. Při vlastní definici kategorie je možno vytvářet kategorie vstupované nebo vypočítané. Kategorie vypočítané je nutno zvlášť nadefinovat po stisku klávesy F5 pomocí činnosti „Definování typu kategorie adresáta“.

Záložka Kategorie spojení poskytuje uživateli možnost zařazení spojení adresátů do kategorií. Uživatel vybere spojení adresáta, které chce zařadit do kategorie a zároveň určí i příslušnou kategorii. Do atributu zařazení se automaticky předplní aktuální datum.

U každého adresáta má uživatel k dispozici 40 znaků pro zadání názvu adresáta. Pokud má adresát název delší, je možno využít na záložce "Další " atributu "úplný název adresáta". Pokud uživatel chce, aby se mu se změnou (opravou) názvu adresáta automaticky změnil i úplný název adresáta, musí mít na záložce "další informace" zadáno u atributu "odpovídá názvu" hodnotu ANO. Jako další na této záložce je možno zadat:

¨ měna - pro každého adresáta je možno určit jeho implicitní měnu, tzn. měnu, která se bude automaticky předplňovat na událostech komponent v souvislosti s tímto adresátem.

¨ EORI - registrační a identifikační číslo hospodářských subjektů (Economic Operators Registration and Identification number). EORI číslo musí být uváděno v celním prohlášení jako identifikátor subjektu a slouží jako společný identifikační údaj hospodářských subjektů a jiných osob při jejich kontaktu s celními orgány v celé Evropské unii.

¨ klíč – možnost zadání libovolného výrazu v případě velmi specifických rozlišení adresátů (není zřejmě často využívaný atribut)

¨ rodné číslo – v případě potřeby možno uvést rodné číslo adresáta (využije se spíše u fyzických osob)

¨ konstantní symbol – předplňuje se pak v souvislosti s tímto adresátem v událostech plateb

¨ DPH – příznak plátce DPH (pro správné fungování procesů DPH je nutné mít u každého adresáta vyplněn právě příznak DPH a na první záložce místo, tzn. tuzemsko/zahraničí/EU)

¨ stav – aktuální/neaktuální

¨ komentář

Pro obchodní údaje nebo tisky na fakturách jsou určeny atributy na záložce „obchodní rejstřík“.

Podle nastavení filtru na záložce "výběr" může uživatel ovlivnit zobrazení záznamů v adresáři. Na výběr je několik třídících hledisek, navíc po stisku příznaku "uchovat" se nadefinované výběry uchovají a po dalším spuštění činnosti adresář se bude k potvrzení nabízet tento nastavený výběr. Kromě klasických vyhledávacích atributů (např. název, IČO, jméno, město apod.) má uživatel k dispozici i:

¨ kategorie – výběr adresátů dané kategorie (vstupovaná nebo vypočítaná kategorie platná k datu) nebo adresátů, pro které existuje spojení zařazené do odpovídající vstupované kategorie

¨ druh adresáta – pro každého adresáta je možné definovat jeho druh, jehož prostřednictvím se definují přístupová práva uživatelů k jeho informacím (adresa, bankovní spojení – viz. činnost druhy adresátů)

¨ paleta – umožňuje zobrazovat adresáty v mřížce (na formuláři adresář) v různých barvách v závislosti na jejich zařazení do kategorií

Uživatel např. bude mít vytvořenu paletu barev nazvanou odběratelé. Při definování hodnot do záložky výběr se systém potom chová následovně. Do názvu adresáta zadá písmeno „B“ a v překryvném seznamu zvolí paletu odběratelé. Pak systém vybere všechny adresáty, jejichž název začíná písmenem „B“ bez ohledu na to, jaká je zvolena paleta a ti z nich, kteří splňují podmínky definované v paletě odběratelé jsou označeni příslušnou barvou. V případě, že uživatel na výběrové záložce před atributem paleta označí zaškrtávací políčko, vybírá systém adresáty, jejichž název začíná písmenem „B“ a zároveň splňují podmínky definované v paletě odběratelé. V menu Volby je pak k dispozici funkce 'Legenda palety barev', která zobrazí okno s přehledem barev aktuálně zvolené palety, tzn. že pak uživatel snadno pozná, která kategorie v paletě má přiřazenu kterou barvu.

U činnosti adresář stojí za samostatnou poznámku položka adresát, která je na obrazovce zvýrazněna tučně. Po jejím stisku "tlačítkem myši" se zobrazí následující nabídka, ze které má uživatel možnost si přímo vyvolat:

¨ události adresáta (např. události obchodu, skladu, plateb, ...)

¨ aktuální hodnoty adresáta

¨ obratové hodnoty adresáta

¨ adresář

¨ adresy adresátů

¨ spojení adresátů

¨ bankovní spojení

¨ cenové skupiny adresátů

¨ předkontace adresáta

¨ strom adresáta

¨ vztahy k obchodním artiklům

Každou z těchto činností je možno po stisku tlačítka myši aktivovat. Některé z těchto činností si uživatel může vyvolat i po stisku příslušné ikony, která se nabízí v levém dolním rohu.

Další činnosti poskytují uživateli jednotlivé záložky v horní liště. Pod menu Volby jsou pro uživatele k dispozici činnosti, které mu činnost adresář umožňuje v daný okamžik využívat (např. předkontace adresáta, cenové skupiny, strom adresáta, označování apod.). Pod menu Obecné zkušenější uživatel jistě časem využije činnosti Volné karty adresáta a Volné karty selektorů.

Datový model

  • ADADSAT Adresát
    • SPPRISTU Přístupové právo uživatele k věci
    • ADSPOJ Spojení adresáta (alias ADSPOJI)
      • ADADR Adresa (alias ADADRI)
        • ADSTATY Stát (alias ADSTATY2)
      • ADOSLOV Oslovení
    • BWUZIVAT Uživatel systému
    • OCMENA Měna

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Strom adresáta | Strom adresáta
F7 | Předkontace adresáta | Vstup předkontací adresáta
F9 | Cenové skupiny adresáta | Přehled cenových skupin adresáta
^B | Změna implicitního bank.spojen |
^I | Změna implicitního spojení | Vybrané spojení nastaví jako implicitní.
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Zařazení adresátů do kategorií | Zařazení adresátů do kategorií
- | Bankovní spojení adresátů |
- | Adresy adresátů | Seznam adres za adresáta.
- | Označení sebe |
- | INFORMACE O ADRESÁTOVI | Vývěska adresáta a pošta adresáta...
- | DOS - Dávková replikace | DOS - Dávková replikace
- | Spojení adresátů | Přehled spojení adresátů
- | Legenda palety barev | Legenda palety barev kategorií adresáta
F2 | Adresy adresátů | Seznam adres za adresáta.
F2 | Adresář | Přehled adresátů
F2 | Banky | Číselník bank
F2 | Druhy adresátů | Druhy adresátů
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Konverze pro štítek v události pošty |
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Města | Seznam měst a PSČ.
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Okresy | Seznam okresů měst
F2 | Oslovení |
F2 | Palety barev kategorií adresátů | Palety barev kategorií adresátů
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Státy | Seznam států.
F2 | Typ spojení | Seznam typů spojení.
F2 | Typy subjektů spojení | Typy subjektů spojení

    Formulář

    Formulář činnosti - Konverze pro štítek v události pošty
Mřížka [Adresář]
Spojení adresátů
Listovací rámeček
Stránka #1 Adresát
Adresát | Identifikace adresáta
 | Název adresáta
IČO | Identifikační číslo organizace.
DIČ | Daňové identifikační číslo adresáta.
Adresa | Číslo adresy adresáta.
Konv. | Konverze pro štítek události pošty
Ulice | Ulice adresy adresáta (včetně čísla popisného).
 | Poštovní směrovací číslo adresy adresáta.
Město | Město adresy adresáta.
Okres | Identifikace okresu
Stát | Identifikace státu.
 | Název státu.
 | Typ místa tuzemsko, zahraničí, Evropská Unie ....
Spojení | Číslo spojení adresáta.
Subjekt | Identifikátor typu subjektu pro spojení adresáta
Jméno | Jméno kontaktní osoby.
 | Směrové číslo státu pro telefonní spojení.
 | Národní směrové číslo státu pro telefonní spojení (UTO).
Telefon | Telefonní číslo
Mobil | Číslo mobilního telefonu
Fax | Faxové číslo
e-mail | E-mail spojení adresáta
Obch. sel. | Identifikátor obchodního selektoru
Druh | Druh adresáta
Zapsal | Jméno uživatele systému
Stránka #2 Adresy
Mřížka [Adresy]
Adresa | Číslo adresy adresáta.
Konv. | Konverze pro štítek události pošty
Ulice | Ulice adresy adresáta (včetně čísla popisného).
Byt | Ulice bytu adresáta (včetně čísla popisného)
 | Poštovní směrovací číslo adresy adresáta.
Město | Město adresy adresáta.
Okres | Identifikace okresu
Stát | Identifikace státu.
 | Název státu.
 | Typ místa tuzemsko, zahraničí, Evropská Unie ....
Komentář | Kometář k adrese adresáta.
Adresy adresátů
Mřížka [Spojení k adrese]
Stránka #3 Spojení
Mřížka [Spojení]
Adresát | Identifikace adresáta
Spojení | Číslo spojení adresáta.
 | Název adresáta
Subjekt | Identifikátor typu subjektu pro spojení adresáta
Adresát | Adresát subjektu spojení adresáta
 | Název adresáta
Jméno | Jméno kontaktní osoby.
Jméno št. | Jméno pracovníka na poštovní štítek
Funkce | Funkce kontaktní osoby
Oslovení | Oslovení
Adresa | Číslo adresy adresáta.
Ulice | Ulice adresy adresáta (včetně čísla popisného).
Byt | Ulice bytu adresáta (včetně čísla popisného)
 | Poštovní směrovací číslo adresy adresáta.
Město | Město adresy adresáta.
Okres | Identifikace okresu
Název okresu | Název okresu
Stát | Identifikace státu.
 | Název státu.
 | Směrové číslo státu pro telefonní spojení.
 | Národní směrové číslo státu pro telefonní spojení (UTO).
Telefon | Telefonní číslo
Mobil | Číslo mobilního telefonu
Fax | Faxové číslo
e-mail | E-mail spojení adresáta
Jiné | Jiné spojení adresáta
Alias | Název adresáta pro zobrazení v událostech
Komentář | Komentář ke spojení
Obch. sel. | Identifikátor obchodního selektoru
Stránka #4 Bankovní spojení
Mřížka [Bankovní spojení]
Účet | Identifikátor spojení na bankovní účet adresáta.
Typ | Příznak účet, pokladna
Kód banky | Kód banky
 | Název banky
Banka | Identifikace adresáta
 | Číslo adresy adresáta.
Aktuální | Aktuální bankovní spojení Ano/Ne
Pobočka | Název pobočky, která vede bankovní účet adresátovi.
 | Prefix bankovního účtu adresáta
Č. účtu | Číslo bankovního účtu adresáta.
SS | Specifický symbol adresáta
IBAN | IBAN - mezinárodní bankovní číslo účtu
Měna | Kód měny - oceňovací jednotky.
 | Název měny
Debet | Příznak možnosti debetu (u pokladen, nikoliv u účtů).
Název účtu | Název účtu
Komentář | Komentář k bankovnímu účtu adresáta.
Bankovní spojení adresátů
Stránka #5 Kategorie
Mřížka [Kategorie]
Kategorie | Identifikace kategorie adresáta.
 | Text vystihující charakter kategorie
Zařazení | Datum zařazení adresáta do kategorie.
Vyřazení | Datum vyřazení adresáta z kategorie.
Zařazení adresátů do kategorií
Stránka #6 Kategorie spojení
Mřížka [Kategorie spojení]
Spojení | Číslo spojení adresáta.
SČZ | Směrové číslo státu pro telefonní spojení.
UTO | Národní směrové číslo státu pro telefonní spojení (UTO).
Telefon | Telefonní číslo
Jméno | Jméno kontaktní osoby.
Mobil | Číslo mobilního telefonu
Fax | Faxové číslo
e-mail | E-mail spojení adresáta
Ulice | Ulice adresy adresáta (včetně čísla popisného).
PSČ | Poštovní směrovací číslo adresy adresáta.
Město | Město adresy adresáta.
Kategorie | Identifikace kategorie adresáta.
Název kategorie | Text vystihující charakter kategorie
Zařazení | Datum zařazení adresáta do kategorie.
Vyřazení | Datum vyřazení adresáta z kategorie.
Stránka #7 Další
Odpovídá názvu | Úplný název adresáta odpovídá názvu adresáta
Úplný název adresáta | Úplný název adresáta
Měna | Kód měny - oceňovací jednotky.
EORI | Číslo EORI
Klíč | Klíč
Rodné číslo | Rodné číslo adresáta
Konstantní symbol | Konstantní symbol adresáta
DPH | Příznak plátce DPH
Stav | Aktuální/ neaktuální
Komentář | Komentář k adresátovi
Stránka #8 Obchodní rejstřík
Sídlo | Číslo adresy adresáta.
Ulice | Ulice adresy adresáta (včetně čísla popisného).
PSČ | Poštovní směrovací číslo adresy adresáta.
Město | Město adresy adresáta.
Stát | Identifikace státu.
 | Název státu.
 | Typ místa tuzemsko, zahraničí, Evropská Unie ....
Základní jmění | Základní jmění
Společníci | Obchodní rejstřík - seznam společníků
Identifikace v OR | Obchodní rejstřík - údaj o zápisu v OR včetně spisové značky
Údaj 2 | Obchodní rejstřík - údaj2
Číslo 1 | Obchodní rejstřík - číslo 1
Stránka #9 Výběr
Adresát | Název adresáta
Ident | Identifikace adresáta
RČ | Rodné číslo adresáta
IČO | Identifikační číslo organizace.
DIČ | Daňové identifikační číslo adresáta.
Klíč | Klíč
Subjekt | Identifikátor typu subjektu pro spojení adresáta
Kategorie | Identifikace kategorie adresáta.
Obch. sel. | Identifikátor obchodního selektoru
Jméno | Jméno osoby na spojení adresáta
Ulice | Ulice adresy adresáta (včetně čísla popisného).
PSČ | Poštovní směrovací číslo adresy adresáta.
Město | Město adresy adresáta.
Okres | Identifikace okresu
Stát | Identifikace státu.
Druh | Druh adresáta
Stav | Aktuální/ neaktuální
Komentář | Komentář k adresátovi
Paleta | Vybrat záznamy všech kategorií v paletě
 | Identifikace palety barev
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Adresář] činnosti - Konverze pro štítek v události pošty

    Mřížka [Adresář] činnosti - Konverze pro štítek v události pošty
Označování | Označení záznamu
Ident | Identifikace adresáta
Název adresáta | Název adresáta
IČO | Identifikační číslo organizace.
Ulice adresy adresáta | Ulice adresy adresáta (včetně čísla popisného).
Město adresy adresáta | Město adresy adresáta.
Druh | Druh adresáta

    Mřížka [Adresy] činnosti - Konverze pro štítek v události pošty

    Mřížka [Adresy] činnosti - Konverze pro štítek v události pošty
Ulice | Ulice adresy adresáta (včetně čísla popisného).
Město | Město adresy adresáta.

    Mřížka [Spojení k adrese] činnosti - Konverze pro štítek v události pošty

    Mřížka [Spojení k adrese] činnosti - Konverze pro štítek v události pošty
Jméno | Jméno kontaktní osoby.
Telefon | Telefonní číslo
e-mail | E-mail spojení adresáta
Mobil | Číslo mobilního telefonu
Fax | Faxové číslo

    Mřížka [Spojení] činnosti - Konverze pro štítek v události pošty

    Mřížka [Spojení] činnosti - Konverze pro štítek v události pošty
Jméno | Jméno kontaktní osoby.
Spojení | Číslo spojení adresáta.
Adresa | Číslo adresy adresáta.
UTO | Národní směrové číslo státu pro telefonní spojení (UTO).
Telefon | Telefonní číslo
Mobil | Číslo mobilního telefonu
e-mail | E-mail spojení adresáta
Fax | Faxové číslo

    Mřížka [Bankovní spojení] činnosti - Konverze pro štítek v události pošty

    Mřížka [Bankovní spojení] činnosti - Konverze pro štítek v události pošty
Účet | Identifikátor spojení na bankovní účet adresáta.
Číslo | Číslo účtu
Typ | Příznak účet, pokladna
Měna | Kód měny - oceňovací jednotky.
Název účtu | Název účtu

    Mřížka [Kategorie] činnosti - Konverze pro štítek v události pošty

    Mřížka [Kategorie] činnosti - Konverze pro štítek v události pošty
Kategorie | Identifikace kategorie adresáta.
Název kategorie | Text vystihující charakter kategorie
Zařazení | Datum zařazení adresáta do kategorie.
Vyřazení | Datum vyřazení adresáta z kategorie.

    Mřížka [Kategorie spojení] činnosti - Konverze pro štítek v události pošty

    Mřížka [Kategorie spojení] činnosti - Konverze pro štítek v události pošty
Spojení | Číslo spojení adresáta.
Kategorie | Identifikace kategorie adresáta.
Název kategorie | Text vystihující charakter kategorie
Zařazení | Datum zařazení adresáta do kategorie.
Vyřazení | Datum vyřazení adresáta z kategorie.

    Atributy tisku

    Základní údaje
Identifikace adresáta | Identifikace adresáta | ADADSAT_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Úplný název odpovídá názvu adresáta | Úplný název adresáta odpovídá názvu adresáta | Výpočet | C(3)
Úplný název adresáta | Úplný název adresáta | ADADSAT_ad01adsat2 | M
IČO organizace | Identifikační číslo organizace. | ADADSAT_ad01ico | C(10)
DIČ | Daňové identifikační číslo adresáta. | ADADSAT_ad01dico | C(16)
Komentář k adresátovi | Komentář k adresátovi | ADADSAT_ad01koment | M
Adresáta zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Identifikátor obchodního selektoru | Identifikátor obchodního selektoru | ADADSAT_sp10idzak | C(9)
Název obchodního selektoru | Název obchodního selektoru | SPSEOB_sp10text | C(60)
Druh | Druh adresáta | ADADSAT_ad72id | C(6)
Název druhu adresáta | Název druhu adresáta | ADADSDRU_ad72nazdru | C(40)
Ulice adresy adresáta | Ulice adresy adresáta (včetně čísla popisného). | ADADR1_ad02ulice | C(40)
PSČ adresy adresáta | Poštovní směrovací číslo adresy adresáta. | ADADR1_ad13psc | C(10)
Město adresy adresáta | Město adresy adresáta. | ADADR1_ad02mesto | C(40)
Kometář k adrese adresáta | Kometář k adrese adresáta. | ADADR1_ad02pozn | M
Okres | Identifikace okresu | ADADR1_ad67id | C(6)
Název okresu | Název okresu | OKRESY1_ad67nazokr | C(40)
Stát v adrese adresáta | Identifikace státu. | ADADR1_ad05id | C(3)
Název státu v adrese adresáta | Název státu. | ADSTATY1_ad05stat | C(30)
Název státu v anglickém jazyce | Název státu v anglickém jazyce | ADSTATY1_ad05nazeva | C(40)
Telefon | Telefonní číslo | ADSPOJP_ad11cislo | C(60)
Jméno kontaktní osoby | Jméno kontaktní osoby. | ADSPOJP_ad11jmeno | C(40)
Fax | Faxové číslo | ADSPOJP_ad11fax | C(60)
Mobil | Číslo mobilního telefonu | ADSPOJP_ad11mobil | C(60)
e-mail | E-mail spojení adresáta | ADSPOJP_ad11email | C(60)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADSPOJP_ad02ulice | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADSPOJP_ad13psc | C(10)
Město | Město adresy adresáta. | ADSPOJP_ad02mesto | C(40)
Název kategorie | Text vystihující charakter kategorie | ADKAT_ad08kateg | C(40)
Typ | Identifikátor typu subjektu pro spojení adresáta | ADSPOJI_ad58id | C(6)
Název typu subjektu | Název typu subjektu pro spojení adresáta | ADTYPSUB_ad58naztyp | C(40)
Implicitní: UTO | Národní směrové číslo státu pro telefonní spojení (UTO). | ADSPOJI_ad13nsc | C(4)
Implicitní: Jméno kontaktní osoby | Jméno kontaktní osoby. | ADSPOJI_ad11jmeno | C(40)
Implicitní: Volané telefonní | Telefonní číslo | ADSPOJI_ad11cislo | C(60)
Fax | Faxové číslo | ADSPOJI_ad11fax | C(60)
Mobil | Číslo mobilního telefonu | ADSPOJI_ad11mobil | C(60)
e-mail | E-mail spojení adresáta | ADSPOJI_ad11email | C(60)
Jiné | Jiné spojení adresáta | ADSPOJI_ad11cisost | C(60)
Implicitní: Poznámka ke spojení | Komentář ke spojení | ADSPOJI_ad11pozn | M
Alias | Název adresáta pro zobrazení v událostech | ADSPOJI_ad11adsat | C(100)
Implicitní: Ulice adresy adresáta | Ulice adresy adresáta (včetně čísla popisného). | ADADRI_ad02ulice | C(40)
Implicitní: PSČ adresy adresáta | Poštovní směrovací číslo adresy adresáta. | ADADRI_ad13psc | C(10)
Implicitní: Město adresy adresáta | Město adresy adresáta. | ADADRI_ad02mesto | C(40)
Okres | Identifikace okresu | ADADRI_ad67id | C(6)
Název okresu | Název okresu | OKRESYI_ad67nazokr | C(40)
Implicitní: Název státu v adrese adresáta | Název státu. | ADSTATY2_ad05stat | C(30)
Implicitní: Název státu v anglickém jazyce | Název státu v anglickém jazyce | ADSTATY2_ad05nazeva | C(40)
Klíč adresáta | Klíč adresáta | ADADSAT_ad01klic | C(40)
Rodné číslo adresáta | Rodné číslo adresáta | ADADSAT_ad01rc | C(10)
EORI | Číslo EORI | ADADSAT_ad01eori | C(17)
Konstantní symbol adresáta | Konstantní symbol adresáta | ADADSAT_ad01ksymb | C(4)
Příznak plátce DPH | Příznak plátce DPH | Výpočet | C(8)
Základní jmění | Základní jmění | ADADSAT_ad01zakljm | N(20,4)
Společníci | Obchodní rejstřík - seznam společníků | ADADSAT_ad01spolec | M
Identifikace v OR | Obchodní rejstřík - údaj o zápisu v OR včetně spisové značky | ADADSAT_ad01volne1 | M
Údaj 2 | Obchodní rejstřík - údaj2 | ADADSAT_ad01volne2 | M
Číslo 1 | Obchodní rejstřík - číslo 1 | ADADSAT_ad01volne3 | N(20,4)
Sídlo | Číslo adresy adresáta. | ADADSAT_ad02cisads | C(2)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR3_ad02ulice | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR3_ad13psc | C(10)
Město | Město adresy adresáta. | ADADR3_ad02mesto | C(40)
Stát | Identifikace státu. | ADADR3_ad05id | C(3)
Název státu | Název státu. | ADSTATY3_ad05stat | C(30)
Barva adresáta | Barva adresáta | ad01barva2 | C(20)

    Při pohybu v Adresy adresáta
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)

    Při pohybu v Kategorie adresátů
Identifikace kategorie | Identifikace kategorie adresáta. | ADKATADS_ad08id | C(6)
Platnost kategorie datum od | Datum zařazení adresáta do kategorie. | ADKATADS_ad07datod | D
Platnost kategorie datum do | Datum vyřazení adresáta z kategorie. | ADKATADS_ad07datdo | D

    Při pohybu v Kategorie spojení adresátů
Spojení | Číslo spojení adresáta. | ADKATADS2_ad11cisspo | C(2)
Kategorie | Identifikace kategorie adresáta. | ADKATADS2_ad08id | C(6)
Zařazení | Datum zařazení adresáta do kategorie. | ADKATADS2_ad07datod | D
Vyřazení | Datum vyřazení adresáta z kategorie. | ADKATADS2_ad07datdo | D

    Při pohybu v Spojení adresáta
Číslo spojení adresáta | Číslo spojení adresáta. | ADSPOJ_ad11cisspo | C(2)
Číslo adresy adresáta | Číslo adresy adresáta. | ADSPOJ_ad02cisadr | C(2)
Identifikátor typu spojení | Identifikace typu spojení | ADSPOJ_ad12id | C(6)
UTO | Národní směrové číslo státu pro telefonní spojení (UTO). | ADSPOJ_ad13nsc | C(4)
Volané telefonní číslo | Telefonní číslo | ADSPOJ_ad11cislo | C(60)
Fax | Faxové číslo | ADSPOJ_ad11fax | C(60)
Jiné | Jiné spojení adresáta | ADSPOJ_ad11cisost | C(60)
Mobil | Číslo mobilního telefonu | ADSPOJ_ad11mobil | C(60)
e-mail | E-mail spojení adresáta | ADSPOJ_ad11email | C(60)
Jméno kontaktní osoby | Jméno kontaktní osoby. | ADSPOJ_ad11jmeno | C(40)
Komentář ke spojení | Komentář ke spojení | ADSPOJ_ad11pozn | M

    Viz.také

    Strom adresáta | Předkontace adresáta | Cenové skupiny adresáta | Změna implicitního bank.spojen | Změna implicitního spojení | OZNAČOVÁNÍ | Zařazení adresátů do kategorií | Bankovní spojení adresátů | Označení sebe | INFORMACE O ADRESÁTOVI | DOS - Dávková replikace | Legenda palety barev | Adresy adresátů | Banky | Druhy adresátů | Kategorie adresátů | Konverze pro štítek v události pošty | Měny a kursy | Města | Obchodní selektor | Okresy | Oslovení | Palety barev kategorií adresátů | Spojení adresátů | Státy | Typ spojení | Typy subjektů spojení


Kategorie adresátů

Popis

Tato činnost slouží k vedení evidence (vkládání, editace, rušení) jednotlivých kategorií adresátů, které se potom následně mohou přiřadit jednotlivým adresátům nebo kategoriím spojení. Výběrová záložka bere v potaz kategorie vstupované i vypočítané.

U každé kategorie se definuje:

¨ identifikace, název

¨ uplatnění – překryvný seznam s možností výběru – kategorie adresáta/kategorie spojení adresáta (znamená, zda definovaná kategorie bude novou kategorií pro adresáty nebo bude kategorií pro spojení adresátů)

¨ typ – vstupovaná/vypočítaná. Př.: SQL vypočítané kategorie „Dodací spojení“ podle realizovaných dodacích listů –

if exists (select * from %%%.obudal where ad01id=@ad01id and ad11cisspo=@ad11cisspo and sp07idtyp=’dodlis’) then 1 else 0 endif. Vstupovaná kategorie se vytváří přímo v této činnosti. Pro kategorii Vypočítanou je nutno nejprve nadefinovat SQL dotaz, což uživatel provede v činnosti „Definování typu kategorie adresáta“ (menu volby nebo pomocí klávesy F5). Zde se nadefinuje vypočítaná kategorie a k ní příslušný SQL dotaz.

¨ komentář – libovolný popis ke kategorii

Kategorii spojení adresáta je možno použít ve formuláři Druhy operací na záložce Spojení, kde se definuje přesný algoritmus předplňování spojení adresáta v událostech.

Přiřazení kategorie adresátům je možno si prohlédnout na záložce "adresáti v kategorii", kde si pomocí klávesy F3 může uživatel z adresáře vybrat adresáta, kterého chce následně zařadit do dané kategorie. U vybraného adresáta může zvolit i období (od -do) přítomnosti adresáta v kategorii. Toto období je pak možno využít při různém označování kategorií apod. U každého adresáta v kategorii je i adresa implicitního spojení.

Jednotlivým kategoriím je možno přiřadit i vybranou barvu, tj. záložka "barvy". Adresáti v takto označené kategorii pak budou v adresáři zobrazeni vybranou barvou. Takto je možno si označit např. neplatiče nebo naopak velmi významné klienty. V případě, že adresát je uveden v kategorii, která je zvýrazněna některou barvou a zároveň spadá do kategorie, která je uvedená v paletě barev a má rovněž určenu zvýrazňovací barvu, uplatní se barva, která je uvedena v paletě barev kategorií.

Programová podpora (vhodné pro implementátory):

Uložená funkce 'ADSPOJ je v kategorii'

– vybere ta spojení, která jsou v kategorii vstupované nebo vypočítané (uplatňuje se jako výběr nad tabulkou kategorie spojení). Samozřejmě, že vybere ta spojení k adresátům, ke kterým má daný uživatel přístup a kategorie je platná.

Vrací hodnotu 1 nebo 0 podle toho, zda spojení adresáta patří do požadované kategorie. Parametry:

ad08id - identifikace kategorie nebo %

ad08nazkat - název kategorie nebo %

ad01id - identifikace adresáta

ad11cisspo - spojení adresáta

bw01uziv - identifikace uživatele systému

datum - datum, ke kterému má být vyhodnocována příslušnost v kategorii

např.:

select * from %%%.adspoj where %%%."ADSPOJ je v kategorii"('DODSPO','%',ADSPOJ.ad01id,ADSPOJ.ad11cisspo,?tool.uziv,current date)=1

Uložená funkce 'ADADSAT je v kategorii'

- vybere adresáty (pro uživatele přístupné), kteří jsou v kategorii (vstupované nebo vypočítané) a nebo mají vstupovanou kategorii spojení. Parametry této funkce jsou shodné jako u výše popsané funkce ADSPOJ.

Datový model

  • ADKAT Kategorie adresáta
    • BWUZIVAT Uživatel systému

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Definování typu kategorie adresáta | Definování typu kategorie adresáta
- | INFORMACE O ADRESÁTOVI | Vývěska adresáta a pošta adresáta...
- | Zařazení adresátů do kategorií | Zařazení adresátů do kategorií
- | Adresáti kategorie | Přehled adresátů

    Formulář

    Formulář činnosti - Definování typu kategorie adresáta
Mřížka [Kategorie]
Listovací rámeček
Stránka #1 Kategorie
Kategorie | Identifikace kategorie adresáta.
Název | Text vystihující charakter kategorie
Uplatnění | Uplatnění kategorie - Kategorie adresáta / Kategorie spojení adresáta
Typ | Typ kategorie - Vstupovaná / Vypočítaná
Komentář | Komentář ke kategorii
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Adresáti v kategorii
Mřížka [Adresáti v kategoriích]
Adresát | Identifikace adresáta
 | Název adresáta
Zařazení | Datum zařazení adresáta do kategorie.
Vyřazení | Datum vyřazení adresáta z kategorie.
Implicitní spojení | Jméno kontaktní osoby.
 | Ulice adresy adresáta (včetně čísla popisného).
 | Poštovní směrovací číslo adresy adresáta.
 | Město adresy adresáta.
 | Název státu.
Stránka #3 Barvy
Mřížka [Barvy]
Skupina | Identifikace skupiny uživatelů
Kategorie | Identifikace kategorie adresáta.
Barva kategorie | Barva zvýraznění adresáta zařazeného v této kategorii
Stránka #4 Výběr
Kategorie | Identifikace kategorie adresáta.
Název | Text vystihující charakter kategorie
Uplatnění | Uplatnění kategorie - Kategorie adresáta / Kategorie spojení adresáta
Typ | Typ kategorie - Vstupovaná / Vypočítaná
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Kategorie] činnosti - Definování typu kategorie adresáta

    Mřížka [Kategorie] činnosti - Definování typu kategorie adresáta
Označování | Označení záznamu
Kategorie | Identifikace kategorie adresáta.
Název kategorie | Text vystihující charakter kategorie

    Mřížka [Adresáti v kategoriích] činnosti - Definování typu kategorie adresáta

    Mřížka [Adresáti v kategoriích] činnosti - Definování typu kategorie adresáta
Název adresáta | Název adresáta
Zařazení | Datum zařazení adresáta do kategorie.
Vyřazení | Datum vyřazení adresáta z kategorie.

    Mřížka [Barvy] činnosti - Definování typu kategorie adresáta

    Mřížka [Barvy] činnosti - Definování typu kategorie adresáta
Název skupiny uživatelů | Název skupiny uživatelů
Barva kategorie | Barva zvýraznění adresáta zařazeného v této kategorii

    Atributy tisku

    Základní údaje
Kategorie | Identifikace kategorie adresáta. | ADKAT_ad08id | C(6)
Název kategorie | Text vystihující charakter kategorie | ADKAT_ad08kateg | C(40)
Uplatnění | Uplatnění kategorie - Kategorie adresáta / Kategorie spojení adresáta | Výpočet | C(26)
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Komentář | Komentář ke kategorii | ADKAT_ad08koment | M
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)

    Při pohybu v Adresáti v kategorii
Adresát | Identifikace adresáta | ADKATADS_ad01id | C(6)
Platnost kategorie datum od | Datum zařazení adresáta do kategorie. | ADKATADS_ad07datod | D
Platnost kategorie datum do | Datum vyřazení adresáta z kategorie. | ADKATADS_ad07datdo | D

    Viz.také

    Definování typu kategorie adresáta | INFORMACE O ADRESÁTOVI | Zařazení adresátů do kategorií | Adresář | Skupiny uživatelů


INFORMACE K ADRESÁTŮM

Popis

Jedná se o činnost, která pod sebou v podstatě soustřeďuje činnosti, které má uživatel dostupné u každého adresáta na jednotlivých záložkách. Podle zadaného výběru může vyhledávat všechna spojení všech adresátů nebo spojení pouze konkrétního adresáta apod. K dispozici má tyto činnosti:

¨ spojení adresátů

¨ adresy adresátů

¨ kategorie adresátů

¨ bankovní spojení adresátů

Viz.také

Spojení adresátů | Adresy adresátů | Zařazení adresátů do kategorií | Bankovní spojení adresátů


Spojení adresátů

Popis

Tato činnost poskytuje uživateli možnost definovat si jednotlivé typy spojení. Navíc je možno ke každému spojení přiřadit i číslo adresy adresáta. U každého spojení se tedy definuje:

¨ číslo spojení adresáta

¨ typ subjektu

¨ identifikace adresáta a případná kontaktní osoba včetně její funkce

¨ číslo adresy adresáta

¨ mobil, fax, email apod.

¨ alias – název adresáta pro zobrazení jeho názvu v událostech ostatních komponent (ve formuláři událostí komponent platby, sklad, obchod, zálohy, pošta, změna stavu peněz, vymáhání, vývěska a expedice se v atributu odpovídajícímu názvu adresáta zobrazuje jeho název v tomto složení – „název adresáta+město z adresy+kontaktní osoba ze spojení adresáta“. Je-li vyplněn atribut ALIAS, tj. forma, jak má být v událostech uveden název adresáta, zobrazuje se v událostech tento).

¨ komentář ke spojení

Na záložce Kategorie spojení se definuje, do které kategorie je dané spojení zařazeno. Při zařazování spojení do kategorie uživatel zadává identifikaci kategorie a datum zařazení (předplňuje se aktuální datum). Kategorie spojení adresáta je informace, která je viditelná i v činnosti Adresář (záložka Kategorie spojení). Atribut „kategorie“ na záložce Výběr vybírá pouze spojení zařazená do kategorií s uplatněním „kategorie spojení adresáta“ (definuje se v činnosti Kategorie adresátů), v potaz bere platné kategorie spojení vstupované a vypočítané.

Na záložce Výběr v událostech komponent platby, sklad, obchod, zálohy, pošta, změna stavu peněz a vymáhání je možno vybírat i podle spojení adresáta. Spojení adresáta je k dispozici i v událostech komponenty vývěska.

Vyvolání přehledu událostí adresáta po pravém kliku na návěští adresáta předplňuje na výběrovou záložku spojení adresáta, pokud není nastaven v 'Nastavení BM' parametr 'Vyber_spojeni_adresata=0' v sekci 'Komponenta-XXX', kde XXX odpovídá identifikaci komponenty.

U každého spojení je důležitá i záložka parametry, kde jsou k dispozici jednotlivé parametry a jejich hodnoty. Ty vychází z toho, jak jsou nadefinované typy parametrů u typu subjektu spojení. U každého parametru se eviduje jeho platnost od - do, což uživateli umožňuje sledovat jednotlivé parametry v čase. Neplatný parametr je zobrazen šedivě.

Pod menu Volby má uživatel k dispozici činnost "Export do Outlooku", která umožňuje exportovat zobrazená spojení adresátů do adresáře Outlooku. Opakovaný export aktualizuje již dříve exportovaná spojení (tato činnost je pro uživatele dostupná, pokud je nadefinována příslušná doplňující vlastnost formuláře).

Informace pro implementátory:

Uložená funkce 'ADSPOJ je v kategorii'

– vybere ta spojení, která jsou v kategorii vstupované nebo vypočítané (uplatňuje se jako výběr nad tabulkou kategorie spojení). Samozřejmě, že vybere ta spojení k adresátům, ke kterým má daný uživatel přístup a kategorie je platná.

Vrací hodnotu 1 nebo 0 podle toho, zda spojení adresáta patří do požadované kategorie. Parametry:

ad08id - identifikace kategorie nebo %

ad08nazkat - název kategorie nebo %

ad01id - identifikace adresáta

ad11cisspo - spojení adresáta

bw01uziv - identifikace uživatele systému

datum - datum, ke kterému má být vyhodnocována příslušnost v kategorii

např.:

select * from %%%.adspoj where %%%."ADSPOJ je v kategorii"('DODSPO','%',ADSPOJ.ad01id,ADSPOJ.ad11cisspo,?tool.uziv,current date)=1

Datový model

  • ADSPOJ Spojení adresáta
    • ADADR Adresa
      • ADSTATY Stát
      • ADOKRESY Okres adresy adresáta
    • ADADSAT Adresát
      • SPPRISTU Přístupové právo uživatele k věci
    • ADTYPSPO Typ spojení
    • SPSEOB Obchodní selektor
    • ADOSLOV Oslovení
    • ADADSAT Adresát (alias ADADSAT4)

    • Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Slučování spojení adresáta | Slučování spojení adresáta
F2 | Adresy adresátů | Seznam adres za adresáta.
F2 | Adresář | Přehled adresátů
F2 | Druhy parametrů spojení | Druhy parametrů spojení
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Města | Seznam měst a PSČ.
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Okresy | Seznam okresů měst
F2 | Oslovení |
F2 | Typ spojení | Seznam typů spojení.
F2 | Typy subjektů spojení | Typy subjektů spojení

    Formulář

    Formulář činnosti - Kategorie adresátů
Mřížka [Spojení adresátů]
Listovací rámeček
Stránka #1 Spojení adresáta
Adresát | Identifikace adresáta
Spojení | Číslo spojení adresáta.
 | Název adresáta
Subjekt | Identifikátor typu subjektu pro spojení adresáta
Adresát | Adresát subjektu spojení adresáta
 | Název adresáta
Jméno | Jméno kontaktní osoby.
Jméno št. | Jméno pracovníka na poštovní štítek
Funkce | Funkce kontaktní osoby
Oslovení | Oslovení
Adresa | Číslo adresy adresáta.
Ulice | Ulice adresy adresáta (včetně čísla popisného).
Byt | Ulice bytu adresáta (včetně čísla popisného)
 | Poštovní směrovací číslo adresy adresáta.
Město | Město adresy adresáta.
Okres | Identifikace okresu
Název okresu | Název okresu
Stát | Identifikace státu.
 | Název státu.
 | Směrové číslo státu pro telefonní spojení.
 | Národní směrové číslo státu pro telefonní spojení (UTO).
Telefon | Telefonní číslo
Mobil | Číslo mobilního telefonu
Fax | Faxové číslo
e-mail | E-mail spojení adresáta
Jiné | Jiné spojení adresáta
Alias | Název adresáta pro zobrazení v událostech
Komentář | Komentář ke spojení
Obch. sel. | Identifikátor obchodního selektoru
Stránka #2 Kategorie spojení
Mřížka [Kategorie]
Kategorie | Identifikace kategorie adresáta.
Název kategorie | Text vystihující charakter kategorie
Zařazení | Datum zařazení adresáta do kategorie.
Vyřazení | Datum vyřazení adresáta z kategorie.
Stránka #3 Parametry
Mřížka [Parametry]
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
Parametr | Identifikace druhu parametru
Pořadí | Pořadí parametru v rámci jednoho druhu
Název parametru | Název druhu parametru
Platnost | Datum platnosti parametru od
do | Datum platnosti parametru do
Adresa | Číslo adresy adresáta.
 | Ulice, město a PSČ
Text1 | Textová elementární hodnota parametru 1
Text2 | Textová elementární hodnota parametru 2
Datum1 | Datumová elementární hodnota parametru 1
Datum2 | Datumová elementární hodnota parametru 2
Num1 | Numerická elementární hodnota parametru 1
Num2 | Numerická elementární hodnota parametru 2
Poznámka | Poznámka
Stránka #4 Výběr
Adresát | Identifikace adresáta
 | Název adresáta
Subjekt | Identifikátor typu subjektu pro spojení adresáta
Adresát | Adresát subjektu spojení adresáta
 | Název adresáta subjektu spojení adresáta
Kategorie | Identifikace kategorie adresáta.
Název kategorie | Text vystihující charakter kategorie
Pracovník | Kontaktní osoba na adrese adresáta.
Funkce | Funkce kontaktní osoby
Ulice | Ulice adresy adresáta (včetně čísla popisného).
Byt | Ulice bytu adresáta (včetně čísla popisného)
 | Poštovní směrovací číslo adresy adresáta.
Město | Město adresy adresáta.
Okres | Identifikace okresu
Stát | Identifikace státu.
 | Národní směrové číslo státu pro telefonní spojení (UTO).
Telefon | Telefonní číslo
Mobil | Číslo mobilního telefonu
Fax | Faxové číslo
e-mail | E-mail spojení adresáta
Jiné | Jiné spojení adresáta
Komentář | Kometář k adrese adresáta.
Obch. sel. | Identifikátor obchodního selektoru
Zob.par. | Zobrazení parametrů
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Spojení adresátů] činnosti - Kategorie adresátů

    Mřížka [Spojení adresátů] činnosti - Kategorie adresátů
Označování | Označení záznamu
Adresát | Identifikace adresáta
Spojení | Číslo spojení adresáta.
Telefon | Telefonní číslo
Mobil | Číslo mobilního telefonu
Fax | Faxové číslo
e-mail | E-mail spojení adresáta
Jiné | Jiné spojení adresáta
Jméno kontaktní osoby | Jméno kontaktní osoby.
Funkce | Funkce kontaktní osoby
Obch. sel. | Identifikátor obchodního selektoru
Název adresáta | Název adresáta
Adresa | Číslo adresy adresáta.
Ulice | Ulice adresy adresáta (včetně čísla popisného).
Město | Město adresy adresáta.

    Mřížka [Kategorie] činnosti - Kategorie adresátů

    Mřížka [Kategorie] činnosti - Kategorie adresátů
Kategorie | Identifikace kategorie adresáta.
Název kategorie | Text vystihující charakter kategorie
Zařazení | Datum zařazení adresáta do kategorie.
Vyřazení | Datum vyřazení adresáta z kategorie.

    Mřížka [Parametry] činnosti - Kategorie adresátů

    Mřížka [Parametry] činnosti - Kategorie adresátů
Název parametru | Název druhu parametru
Zobrazení hodnoty | Zobrazení hodnoty parametru
Parametr | Identifikace druhu parametru
Ulice | Ulice adresy adresáta (včetně čísla popisného).
Město | Město adresy adresáta.
PSČ | Poštovní směrovací číslo adresy adresáta.

    Atributy tisku

    Základní údaje
Identifikace adresáta | Identifikace adresáta | ADSPOJ_ad01id | C(6)
Číslo spojení adresáta | Číslo spojení adresáta. | ADSPOJ_ad11cisspo | C(2)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Úplný název adresáta | Úplný název adresáta | ADADSAT_ad01adsat2 | M
Subjekt | Identifikátor typu subjektu pro spojení adresáta | ADSPOJ_ad58id | C(6)
Název typu subjektu | Název typu subjektu pro spojení adresáta | ADTYPSUB_ad58naztyp | C(40)
Adresát subjektu | Adresát subjektu spojení adresáta | ADSPOJ_ad01id2 | C(6)
Název adresáta subjektu | Název adresáta subjektu spojení adresáta | ADADSAT4_ad01adsat | C(100)
Jméno kontaktní osoby | Jméno kontaktní osoby. | ADSPOJ_ad11jmeno | C(40)
Jméno na štítek | Jméno pracovníka na poštovní štítek | ADSPOJ_ad11jmenop | C(100)
Funkce | Funkce kontaktní osoby | ADSPOJ_ad11funkce | C(40)
Oslovení | Text oslovení | ADOSLOV_ad57oslov | C(40)
Číslo adresy adresáta | Číslo adresy adresáta. | ADSPOJ_ad02cisadr | C(2)
Ulice adresy adresáta | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
Byt | Ulice bytu adresáta (včetně čísla popisného) | ADADR_ad02byt | C(40)
PSČ adresy adresáta | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Město adresy adresáta | Město adresy adresáta. | ADADR_ad02mesto | C(40)
Okres | Identifikace okresu | ADADR_ad67id | C(6)
Název okresu | Název okresu | ADOKRESY_ad67nazokr | C(40)
Stát v adrese adresáta | Identifikace státu. | ADADR_ad05id | C(3)
Název státu v adrese adresáta | Název státu. | ADSTATY_ad05stat | C(30)
Kometář k adrese adresáta | Kometář k adrese adresáta. | ADADR_ad02pozn | M
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie .... | Výpočet | C(9)
Identifikátor typu spojení | Identifikace typu spojení | ADSPOJ_ad12id | C(6)
Název typu spojení | Název typu spojení | ADTYPSPO_ad12typspo | C(40)
UTO | Národní směrové číslo státu pro telefonní spojení (UTO). | ADSPOJ_ad13nsc | C(4)
Volané telefonní číslo | Telefonní číslo | ADSPOJ_ad11cislo | C(60)
Fax | Faxové číslo | ADSPOJ_ad11fax | C(60)
Jiné | Jiné spojení adresáta | ADSPOJ_ad11cisost | C(60)
Mobil | Číslo mobilního telefonu | ADSPOJ_ad11mobil | C(60)
e-mail | E-mail spojení adresáta | ADSPOJ_ad11email | C(60)
Alias | Název adresáta pro zobrazení v událostech | ADSPOJ_ad11adsat | C(100)
Komentář ke spojení | Komentář ke spojení | ADSPOJ_ad11pozn | M
Identifikátor obchodního selektoru | Identifikátor obchodního selektoru | ADSPOJ_sp10idzak | C(9)
Název obchodního selektoru | Název obchodního selektoru | SPSEOB_sp10text | C(60)
Název druhu | Název druhu parametru | ADSPOPRD_ad59nazdru | C(40)
Formát | Formát zobrazení v gridu a ve stromu | ADSPOPRD_ad59format | M
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR1_ad02ulice | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR1_ad13psc | C(10)
Město | Město adresy adresáta. | ADADR1_ad02mesto | C(40)
Název kategorie | Text vystihující charakter kategorie | ADKAT_ad08kateg | C(40)

    Při pohybu v Kategorie spojení adresátů
Kategorie | Identifikace kategorie adresáta. | ADKATADS_ad08id | C(6)
Zařazení | Datum zařazení adresáta do kategorie. | ADKATADS_ad07datod | D
Vyřazení | Datum vyřazení adresáta z kategorie. | ADKATADS_ad07datdo | D

    Při pohybu v Parametry spojení
Druh | Identifikace druhu parametru | ADSPOPAR_ad59id | C(6)
Pořadí | Pořadí parametru v rámci jednoho druhu | ADSPOPAR_ad61porad | N(3)
Pořadí zobrazení parametru | Pořadí zobrazení | ADSPOPAR_ad61zobpor | N(3)
Zobrazení hodnoty | Zobrazení hodnoty parametru | Výpočet | C(80)
Platnost | Datum platnosti parametru od | ADSPOPAR_ad61datod | D
do | Datum platnosti parametru do | ADSPOPAR_ad61datdo | D
Text1 | Textová elementární hodnota parametru 1 | ADSPOPAR_ad61txt1 | C(60)
Text2 | Textová elementární hodnota parametru 2 | ADSPOPAR_ad61txt2 | C(60)
Datum1 | Datumová elementární hodnota parametru 1 | ADSPOPAR_ad61dat1 | D
Datum2 | Datumová elementární hodnota parametru 2 | ADSPOPAR_ad61dat2 | D
Num1 | Numerická elementární hodnota parametru 1 | ADSPOPAR_ad61num1 | N(20,4)
Num2 | Numerická elementární hodnota parametru 2 | ADSPOPAR_ad61num2 | N(20,4)
Adresa | Číslo adresy adresáta. | ADSPOPAR_ad02cisadr | C(2)
Poznámka | Poznámka | ADSPOPAR_ad61koment | M

    Viz.také

    OZNAČOVÁNÍ | Slučování spojení adresáta | Adresy adresátů | Adresář | Druhy parametrů spojení | Kategorie adresátů | Města | Obchodní selektor | Okresy | Oslovení | Typ spojení | Typy subjektů spojení


Adresy adresátů

Popis

Tato činnost poskytuje uživateli přehled o všech dosud zapsaných adresách daného adresáta. Jedná se pouze o informativní přehled, měnit implicitní spojení zde nelze.

Na základě toho, jak jsou nastaveny parametry v typech subjektů spojení, je možno jednotlivé adresy adresáta sledovat i v čase, tzn. jsou zde zaznamenány všechny adresy adresáta, ty, které již nejsou platné jsou zvýrazněny šedivě.

Datový model

  • ADADR Adresa
    • ADADSAT Adresát
      • SPPRISTU Přístupové právo uživatele k věci
    • ADSTATY Stát
    • ADOKRESY Okres adresy adresáta

    • Vyvolávané činnosti

    K. | Činnost | Popis
- | DOS - Dávková replikace | DOS - Dávková replikace
F2 | Adresář | Přehled adresátů
F2 | Konverze pro štítek v události pošty |
F2 | Města - PSČ | Seznam měst a PSČ.
F2 | Okresy | Seznam okresů měst
F2 | Státy | Seznam států.

    Formulář

    Formulář činnosti - Konverze pro štítek v události pošty
Mřížka [Adresy adresátů]
Listovací rámeček
Stránka #1 Adresy
Adresát | Identifikace adresáta
 | Název adresáta
Adresa | Číslo adresy adresáta.
Konv. | Konverze pro štítek události pošty
Ulice | Ulice adresy adresáta (včetně čísla popisného).
Byt | Ulice bytu adresáta (včetně čísla popisného)
 | Poštovní směrovací číslo adresy adresáta.
Město | Město adresy adresáta.
Okres | Identifikace okresu
Stát | Identifikace státu.
 | Název státu.
Komentář | Kometář k adrese adresáta.
Typ místa | Identifikace typu místa zdanitelného plnění
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie ....
Stránka #2 Výběr
Adresát | Identifikace adresáta
Konverze | Konverze pro štítek události pošty
PSČ | Poštovní směrovací číslo adresy adresáta.
Město | Město adresy adresáta.
Okres | Identifikace okresu
Stát | Identifikace státu.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Adresy adresátů] činnosti - Konverze pro štítek v události pošty

    Mřížka [Adresy adresátů] činnosti - Konverze pro štítek v události pošty
Adresát | Identifikace adresáta
Adr | Číslo adresy adresáta.
Název adresáta | Název adresáta
PSČ | Poštovní směrovací číslo adresy adresáta.
Město | Město adresy adresáta.
Stát | Identifikace státu.
Název státu | Název státu.
Okres | Identifikace okresu
Název okresu | Název okresu

    Atributy tisku

    Základní údaje
Identifikace adresáta | Identifikace adresáta | ADADR_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Úplný název adresáta | Úplný název adresáta | ADADSAT_ad01adsat2 | M
Číslo adresy adresáta | Číslo adresy adresáta. | ADADR_ad02cisadr | C(2)
Ulice adresy adresáta | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
Byt | Ulice bytu adresáta (včetně čísla popisného) | ADADR_ad02byt | C(40)
PSČ adresy adresáta | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Město adresy adresáta | Město adresy adresáta. | ADADR_ad02mesto | C(40)
Okres | Identifikace okresu | ADADR_ad67id | C(6)
Název okresu | Název okresu | ADOKRESY_ad67nazokr | C(40)
Stát v adrese adresáta | Identifikace státu. | ADADR_ad05id | C(3)
Název státu v adrese adresáta | Název státu. | ADSTATY_ad05stat | C(30)
Kometář k adrese adresáta | Kometář k adrese adresáta. | ADADR_ad02pozn | M
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie .... | Výpočet | C(9)

    Při pohybu v Spojení adresáta
Číslo spojení adresáta | Číslo spojení adresáta. | ADSPOJ_ad11cisspo | C(2)
Identifikátor typu spojení | Identifikace typu spojení | ADSPOJ_ad12id | C(6)
UTO | Národní směrové číslo státu pro telefonní spojení (UTO). | ADSPOJ_ad13nsc | C(4)
Volané telefonní číslo | Telefonní číslo | ADSPOJ_ad11cislo | C(60)
Jméno kontaktní osoby | Jméno kontaktní osoby. | ADSPOJ_ad11jmeno | C(40)
Funkce | Funkce kontaktní osoby | ADSPOJ_ad11funkce | C(40)
Komentář ke spojení | Komentář ke spojení | ADSPOJ_ad11pozn | M
Identifikátor obchodního selektoru | Identifikátor obchodního selektoru | ADSPOJ_sp10idzak | C(9)

    Viz.také

    DOS - Dávková replikace | Adresář | Konverze pro štítek v události pošty | Města | Okresy | Státy


Zařazení adresátů do kategorií

Popis

Tato činnost slouží k vedení evidence jednotlivých kategorií, které jsou přiřazeny k adresátům, resp. jedná se pouze o přehled adresátů, kteří jsou ve vybraných kategoriích zařazeni (není možno v této činnosti adresáty do kategorie zařazovat).

Pokud uživatel neupřesní údaje na záložce „výběr“[1] má k dispozici přehled kategorií a zároveň všech adresátů, kteří jsou do dané kategorie zařazeni. U každé kategorie se eviduje:

¨ adresát – identifikace adresáta, který je v kategorii zařazen

¨ kategorie - identifikace kategorie

¨ platnost kategorie od – do – datum platnosti adresáta v kategorii

¨ komentář

[1] Výběrová záložka bere v potaz pouze kategorie vstupované bez ohledu na jejich platnost.

Datový model

  • ADKATADS Zařazení (spojení) adresáta do kategorie
    • ADADSAT Adresát
    • ADKAT Kategorie adresáta

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresář | Přehled adresátů
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Spojení adresátů | Přehled spojení adresátů

    Formulář

    Formulář činnosti - Spojení adresátů
Mřížka [Kategorie adresátů]
Listovací rámeček
Stránka #1 Zařazení do kategorie
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
 | Text vystihující charakter kategorie
Spojení | Číslo spojení adresáta.
Platnost kategorie datum od | Datum zařazení adresáta do kategorie.
Platnost kategorie datum do | Datum vyřazení adresáta z kategorie.
Komentář | Komentář ke kategorii
Stránka #2 Výběr
Adresát | Identifikace adresáta
Kategorie | Identifikace kategorie adresáta.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Kategorie adresátů] činnosti - Spojení adresátů

    Mřížka [Kategorie adresátů] činnosti - Spojení adresátů
Název kategorie | Text vystihující charakter kategorie
Kategorie | Identifikace kategorie adresáta.
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Zařazení | Datum zařazení adresáta do kategorie.
Vyřazení | Datum vyřazení adresáta z kategorie.

    Atributy tisku

    Základní údaje
Identifikace adresáta | Identifikace adresáta | ADKATADS_ad01id | C(6)
Spojení | Číslo spojení adresáta. | ADKATADS_ad11cisspo | C(2)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Úplný název adresáta | Úplný název adresáta | ADADSAT_ad01adsat2 | M
Identifikace kategorie | Identifikace kategorie adresáta. | ADKATADS_ad08id | C(6)
Název kategorie | Text vystihující charakter kategorie | ADKAT_ad08kateg | C(40)
Platnost kategorie datum od | Datum zařazení adresáta do kategorie. | ADKATADS_ad07datod | D
Platnost kategorie datum do | Datum vyřazení adresáta z kategorie. | ADKATADS_ad07datdo | D

    Viz.také

    Adresář | Kategorie adresátů | Spojení adresátů


Bankovní spojení adresátů

Popis

Ke každému adresátovi v IS je možno přiřadit nejméně jedno bankovní spojení. V případě potřeby je možno zvolené spojení označit jako implicitní (provádí se v adresáři na záložce „bankovní spojení" pomocí tlačítka Impl. nebo z menu Volby pomocí klávesy Ctrl B a pak se v přehledu bankovních spojení zobrazuje červeně). Takto zvolené bankovní spojení se pak na událostech jednotlivých operací automaticky zobrazuje u vybraného adresáta.

Jako první se po aktivaci této činnosti spustí záložka „výběr“, kde si uživatel může vyfiltrovat informace, které chce vidět. Uživatel si může zadané údaje prohlížet, opravovat a rušit a zároveň může zadat i nový údaj. V tomto případě vstupuje tyto položky:

¨ adresáta, jehož bankovní spojení se zakládá (výběr z adresáře)

¨ účet – identifikátor na bankovní spojení adresáta (automaticky se při vstupu nového bank.spojení čísluje)

¨ typ - zda se jedná o účet či pokladnu

¨ údaje - pokud se jedná o účet, zadávají se údaje týkající se banky (tj. kód banky, adresa, pobočka, číslo účtu a specifický symbol). Kód banky uživatel vybírá z číselníku bank, kde by u každého kódu měla být vyplněna i adresa. Po výběru kódu banky se automaticky předplní i adresa.

¨ aktuální – tento atribut nabývá hodnoty Ano/Ne. Vstupuje se ve formulářích 'Adresář' a 'Bankovní spojení adresátů'. V mřížkách těchto formulářů jsou neaktuální bankovní spojení zobrazeny na šedivém podkladě. V této činnosti je možno na výběrové záložce vybírat spojení podle této vlastnosti.

¨ měna - kód a název oceňovací jednotky

¨ IBAN – mezinárodní bankovní číslo účtu

¨ debet – příznak možnosti debetu v pokladně. V případě zaškrtnutí tohoto atributu se stav pokladny (resp.aktuální hodnota uvedená v činnosti „základní druhy hodnot“) nekontroluje. V případě nezaškrtnutého atributu se při zadání debetu pokladny kontroluje stav poklady. Pokud se zadáním debetu dosáhne záporných hodnot v pokladně, program zobrazí chybové hlášení a není možno tuto událost zapsat.

¨ název účtu

¨ komentář

Bankovní spojení k danému adresátovi je možno natáhnout i automaticky a to pomocí doplňující vlastnosti „předplnění bankovního spojení dle registru plátců DPH“.

V zahraničních bankách je obvyklé, že jsou na jednom účtu vedeny zůstatky více měn. Toto je možné nadefinovat na záložce „další měny účtu“. Na první záložce „bankovní spojení – pokladna“ se stále uvádí základní měna účtu. V události změny stavu peněz je možné vstupovat do položky Měna účtu v případě, že bankovní účet je typu 'účet' a má definované 'Další měny' .

Datový model

  • ADBUCTY Bankovní účty adresátů
    • ADADSAT Adresát
      • SPPRISTU Přístupové právo uživatele k věci
    • OCBANKA Banka
    • OCMENA Měna
    • ADADR Adresa

    • Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | DOS - Dávková replikace | DOS - Dávková replikace
F2 | Adresy adresátů | Seznam adres za adresáta.
F2 | Adresář | Přehled adresátů
F2 | Banky | Číselník bank
F2 | Měny a kursy | Číselník měn včetně jejich kursů

    Formulář

    Formulář činnosti - DOS - Dávková replikace
Mřížka [Bankovní spojení / pokladna]
Listovací rámeček
Stránka #1 Bankovní spojení - pokladna
Adresát | Identifikace adresáta
 | Název adresáta
Účet | Identifikátor spojení na bankovní účet adresáta.
Typ | Příznak účet, pokladna
Kód banky | Kód banky
 | Název banky
Banka | Identifikace adresáta
 | Číslo adresy adresáta.
Aktuální | Aktuální bankovní spojení Ano/Ne
Pobočka | Název pobočky, která vede bankovní účet adresátovi.
 | Prefix bankovního účtu adresáta
Č. účtu | Číslo bankovního účtu adresáta.
SS | Specifický symbol adresáta
IBAN | IBAN - mezinárodní bankovní číslo účtu
Měna | Kód měny - oceňovací jednotky.
 | Název měny
Debet | Příznak možnosti debetu (u pokladen, nikoliv u účtů).
Název ú. | Název účtu
Komentář | Komentář k bankovnímu účtu adresáta.
Stránka #2 Další měny účtu
Mřížka [Další měny účtu]
Adresát | Identifikace adresáta
Účet | Identifikátor spojení na bankovní účet adresáta.
 | Název adresáta
Banka | Kód banky
Název banky | Název banky
Měna | Kód měny - oceňovací jednotky.
 | Název měny
Stránka #3 Výběr
Adresát | Identifikace adresáta
 | Prefix bankovního účtu adresáta
Účet | Číslo bankovního účtu adresáta.
SS | Specifický symbol adresáta
Měna | Kód měny - oceňovací jednotky.
Název účtu | Název účtu
Aktuální | Aktuální bankovní spojení Ano/Ne
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Bankovní spojení / pokladna] činnosti - DOS - Dávková replikace

    Mřížka [Bankovní spojení / pokladna] činnosti - DOS - Dávková replikace
Označování | Označení záznamu
Účet | Identifikátor spojení na bankovní účet adresáta.
Typ | Příznak účet, pokladna
Číslo | Číslo účtu
Měna | Kód měny - oceňovací jednotky.
Specifický symbol | Specifický symbol adresáta
Název účtu | Název účtu
Pobočka | Název pobočky, která vede bankovní účet adresátovi.
Adresát | Identifikace adresáta
Název adresáta | Název adresáta

    Mřížka [Další měny účtu] činnosti - DOS - Dávková replikace

    Mřížka [Další měny účtu] činnosti - DOS - Dávková replikace
Měna | Kód měny - oceňovací jednotky.
Název měny | Název měny

    Atributy tisku

    Základní údaje
Identifikace adresáta | Identifikace adresáta | ADADSAT_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Úplný název adresáta | Úplný název adresáta | ADADSAT_ad01adsat2 | M
IČO organizace | Identifikační číslo organizace. | ADADSAT_ad01ico | C(10)
DIČ | Daňové identifikační číslo adresáta. | ADADSAT_ad01dico | C(16)
Komentář k adresátovi | Komentář k adresátovi | ADADSAT_ad01koment | M
Identifikátor obchodního selektoru | Identifikátor obchodního selektoru | ADADSAT_sp10idzak | C(9)
Rodné číslo | Rodné číslo adresáta | ADADSAT_ad01rc | C(10)
Konstantní symbol | Konstantní symbol adresáta | ADADSAT_ad01ksymb | C(4)
DPH | Příznak plátce DPH | Výpočet | C(8)
Účet | Identifikátor spojení na bankovní účet adresáta. | ADBUCTY_ad03cisban | C(2)
Název adresáta | Název adresáta | ADADSAT4_ad01adsat | C(100)
Úplný název adresáta | Úplný název adresáta | ADADSAT4_ad01adsat2 | M
Pobočka | Název pobočky, která vede bankovní účet adresátovi. | ADBUCTY_ad03poboc | C(25)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)
Prefix ú. | Prefix bankovního účtu adresáta | ADBUCTY_ad03pructu | C(6)
Č. účtu | Číslo bankovního účtu adresáta. | ADBUCTY_ad03ucet | C(34)
Specifický symbol | Specifický symbol adresáta | ADBUCTY_ad03ssymb | C(10)
IBAN | IBAN - mezinárodní bankovní číslo účtu | ADBUCTY_ad03iban | C(34)
Měna | Kód měny - oceňovací jednotky. | ADBUCTY_oc01id | C(3)
Název měny | Název měny | OCMENA_oc01nazev | C(18)
Název ú. | Název účtu | ADBUCTY_ad03nauctu | C(20)
Komentář | Komentář k bankovnímu účtu adresáta. | ADBUCTY_ad03koment | M
Debet | Příznak možnosti debetu (u pokladen, nikoliv u účtů). | Výpočet | C(3)
Aktuální | Aktuální bankovní spojení Ano/Ne | Výpočet | C(3)
Kód banky | Kód banky | ADBUCTY_oc02idbank | C(4)
Název měny | Název měny | OCMENA1_oc01nazev | C(18)

    Při pohybu v Další měny účtu
    Měna Kód měny - oceňovací jednotky. ADBUCTYM_oc01id C(3)

    Viz.také

    OZNAČOVÁNÍ | DOS - Dávková replikace | Adresy adresátů | Adresář | Banky | Měny a kursy


ČÍSELNÍKY A PARAMETRY

Popis

Jedná se o činnost, která v sobě soustřeďuje číselníky, které se používají při práci s adresářem a zároveň jsou zde k dispozici i jednotlivé druhy parametrů, které má uživatel možnost si nastavit. Jedná se o:

¨ města

¨ státy

¨ oslovení

¨ typ spojení

¨ parametry adresáře

¨ číselná řada adresátů

¨ typy subjektů spojení

¨ druhy parametrů spojení

¨ duplicita adresátů

Viz.také

Města | Okresy | Kraje | Státy | Oslovení | Typ spojení | Parametry adresáře | Číselná řada adresátů | Typy subjektů spojení | Druhy parametrů spojení | Duplicita adresátů | Druhy adresátů | Palety barev kategorií adresátů | Konverze pro štítek v události pošty


Města

Popis

Činnost umožňuje uživateli prohlížet a aktualizovat číselník PSČ a měst, který využívá zejména při práci s adresářem. Způsob zobrazení tohoto číselníku má uživatel možnost ovlivňovat pomocí záložky výběr, kde si může nastavit např. zobrazení PSČ a měst pouze jednoho státu.

Datový model

  • ADMESTA Město
    • ADSTATY Stát

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Okresy | Seznam okresů měst
F2 | Státy | Seznam států.

    Formulář

    Formulář činnosti - Okresy
Mřížka [Města]
Listovací rámeček
Stránka #1 Města
PSČ | Poštovní směrovací číslo adresy adresáta.
Číslo obce | Číslo obce
Město | Město adresy adresáta.
UTO | Národní směrové číslo státu pro telefonní spojení (UTO).
Okres | Identifikace okresu
Stát | Identifikace státu.
 | Název státu.
Postavení obce | Postavení obce
Stránka #2 Výběr
PSČ | Poštovní směrovací číslo adresy adresáta.
Město | Město adresy adresáta.
Okres | Identifikace okresu
Stát | Identifikace státu.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Města] činnosti - Okresy

    Mřížka [Města] činnosti - Okresy
Město | Město adresy adresáta.
PSČ | Poštovní směrovací číslo adresy adresáta.
Stát | Identifikace státu.
Název státu | Název státu.
Okres | Identifikace okresu
Číslo obce | Číslo obce
Postavení obce | Postavení obce

    Atributy tisku

    Základní údaje
PSČ | Poštovní směrovací číslo adresy adresáta. | ADMESTA_ad13psc | C(10)
Město | Město adresy adresáta. | ADMESTA_ad13mesto | C(40)
UTO | Národní směrové číslo státu pro telefonní spojení (UTO). | ADMESTA_ad13nsc | C(4)
Okres | Identifikace okresu | ADMESTA_ad67id | C(6)
Název okresu | Název okresu | ADOKRESY_ad67nazokr | C(40)
Stát | Identifikace státu. | ADMESTA_ad05id | C(3)
Název státu | Název státu. | ADSTATY_ad05stat | C(30)
Číslo obce | Číslo obce | ADMESTA_ad13cisobc | C(6)
Postavení obce | Postavení obce | Výpočet | C(16)

    Viz.také

    Okresy | Státy


Okresy

Popis

Tato činnost poskytuje uživateli přehled o jednotlivých okresech. Tento přehled je možno aktualizovat, editovat či rušit a uživatel ho využije jako číselník především při práci s adresátem v činnosti adresář.

Datový model

  • ADOKRESY Okres adresy adresáta
    • ADKRAJE Kraj

    • Formulář

    Formulář činnosti - Kraje
Mřížka [Kraje]
Okres | Identifikace okresu
Název okresu | Název okresu
Kraj | Identifikace kraje
Jiná identifikace | Jiná identifikace okresu
Poznámka | Poznámka

    Mřížka [Kraje] činnosti - Kraje

    Mřížka [Kraje] činnosti - Kraje
Okres | Identifikace okresu
Název okresu | Název okresu
Jiná identifikace | Jiná identifikace okresu
Kraj | Identifikace kraje
Název kraje | Název kraje

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Kraje | Seznam krajů okresů

    Atributy tisku

    Základní údaje
Okres | Identifikace okresu | ADOKRESY_ad67id | C(6)
Název okresu | Název okresu | ADOKRESY_ad67nazokr | C(40)
Kraj | Identifikace kraje | ADOKRESY_ad68id | C(6)
Název kraje | Název kraje | ADKRAJE_ad68nazkra | C(40)
Jiná identifikace | Jiná identifikace okresu | ADOKRESY_ad67extid | C(6)
Poznámka | Poznámka | ADOKRESY_ad67koment | M

    Viz.také

    Kraje


Kraje

Popis

Tato činnost poskytuje uživateli přehled nadefinovaných krajů. Tento přehled je možno aktualizovat, editovat či rušit a uživatel ho využije jako číselník především při práci s adresátem v činnosti adresář.

Datový model

  • ADKRAJE Kraj

    • Formulář

    Formulář činnosti - Spojení adresátů
Mřížka [Kraje]
Kraj | Identifikace kraje
Název kraje | Název kraje
Jiná identifikace | Jiná identifikace kraje
Poznámka | Poznámka

    Mřížka [Kraje] činnosti - Spojení adresátů

    Mřížka [Kraje] činnosti - Spojení adresátů
Kraj | Identifikace kraje
Název kraje | Název kraje
Jiná identifikace | Jiná identifikace kraje

    Atributy tisku

    Základní údaje
Kraj | Identifikace kraje | ADKRAJE_ad68id | C(6)
Název kraje | Název kraje | ADKRAJE_ad68nazkra | C(40)
Jiná identifikace | Jiná identifikace kraje | ADKRAJE_ad68extid | C(6)
Poznámka | Poznámka | ADKRAJE_ad68koment | M


Státy

Popis

Pomocí této činnosti má uživatel možnost aktualizovat (editovat či rušit) stávající číselník států nebo v případě potřeby zařazovat nový stát. Uživatel využívá tento číselník zejména při práci s adresářem.

Datový model

  • ADSTATY Stát

    • Formulář

    Formulář činnosti - Organizační selektor
Mřížka [Státy]
Stát | Identifikace státu.
Název státu | Název státu.
Oficiální název | Oficiální název státu
Název v cizí řeči | Název státu v cizí řeči
Název v angl. | Název státu v anglickém jazyce
SČZ | Směrové číslo státu pro telefonní spojení.
Komentář | Komentář ke státu

    Mřížka [Státy] činnosti - Organizační selektor

    Mřížka [Státy] činnosti - Organizační selektor
Stát | Identifikace státu.
Název státu | Název státu.

    Atributy tisku

    Základní údaje
Stát | Identifikace státu. | ADSTATY_ad05id | C(3)
SČZ | Směrové číslo státu pro telefonní spojení. | ADSTATY_ad05scz | C(4)
Název státu | Název státu. | ADSTATY_ad05stat | C(30)
Oficiální název | Oficiální název státu | ADSTATY_ad05nazevo | C(40)
Název v cizí řeči | Název státu v cizí řeči | ADSTATY_ad05nazevc | C(40)
Název státu v anglickém jazyce | Název státu v anglickém jazyce | ADSTATY_ad05nazeva | C(40)
Komentář | Komentář ke státu | ADSTATY_ad05koment | M


Oslovení

Popis

Tato činnost umožňuje uživateli nadefinovat si seznam možných oslovení, které se při kontaktu s adresáty bude používat. V této činnosti se definuje:

¨ identifikace - jednoznačná identifikace oslovení

¨ oslovení - vlastní oslovení (tzn. pan, paní, slečna, mladá paní, vážený pan ředitel apod.)

Tyto nadefinovaná oslovení se pak uživateli nabízejí v událostech pošty na záložce "adresa" na adresním štítku. Uživatel si pak má možnost vybrat vhodné oslovení z překryvného seznamu.

Datový model

  • ADOSLOV Oslovení

    • Formulář

    Formulář činnosti - Spojení adresátů
Mřížka [Oslovení]
Identifikace | Identifikace oslovení
Oslovení | Text oslovení
Komentář | Komentář

    Mřížka [Oslovení] činnosti - Spojení adresátů

    Mřížka [Oslovení] činnosti - Spojení adresátů
Oslovení | Oslovení
Text oslovení | Text oslovení


Typ spojení

Popis

Tato činnost poskytuje uživateli možnost aktualizovat, opravovat a rušit číselník jednotlivých typů spojení. Při zadání nebo opravě nového typu spojení se vstupují tyto údaje:

¨ identifikace a název typu spojení

¨ určení druhu spojení - výběrem z nabízených možností uživatel určuje, zda tento typ spojení je druhu telefon, fax, e-mail, www, nebo jiný

¨ rozlišovací číslo - tj. číslo vytáčené před číslem (jeho vyplnění tedy připadá v úvahu, že typ spojení je druhu telefon nebo fax)

Datový model

  • ADTYPSPO Typ spojení

    • Formulář

    Formulář činnosti - Obecné předkontace
Mřížka [Typ spojení]
Typ spojení | Identifikace typu spojení
Název | Název typu spojení
 | Použitý způsob přenosu.
Rozliš. čís. | Rozlišovací číslo (vytáčené před číslem).

    Mřížka [Typ spojení] činnosti - Obecné předkontace

    Mřížka [Typ spojení] činnosti - Obecné předkontace
Typ spojení | Identifikace typu spojení
Název typu spojení | Název typu spojení

    Atributy tisku

    Základní údaje
Typ spojení | Identifikace typu spojení | ADTYPSPO_ad12id | C(6)
Název typu spojení | Název typu spojení | ADTYPSPO_ad12typspo | C(40)
Použitý způsob přenosu | Použitý způsob přenosu. | Výpočet | C(7)
Rozlišovací číslo | Rozlišovací číslo (vytáčené před číslem). | ADTYPSPO_ad12rozcis | C(4)


Parametry adresáře

Popis

Tato činnost slouží pro definici parametrů používaných při práci s adresářem. Uživatel zadává tyto parametry:

¨ Validace duplicity IČO

je-li zatrženo, proběhne po zadání IČO kontrola duplicity. V případě, že uživatel vstoupil nového adresáta s IČO, které již v adresáři existuje nebo změnil IČO dříve založeného adresáta na IČO, které již v adresáři existuje, je zobrazen formulář s hlášením: „IČO …… bylo již užito pro adresáta ….. „. Po stisku tlačítka OK systém povolí vstup adresáta se zadaným duplicitním IČO. Po stisku tlačítka Storno systém nutí uživatele IČO změnit. V případě potřeby je možno při stisku tlačítka OK zaškrtnou volbu „Vypnout kontrolu duplicitního IČO pro toto spuštění formuláře“, která způsobí potlačení kontroly duplicitního IČO pro právě aktuálně spuštění formulář „Adresář“ (využije se při importu dat do adresáře).

¨ Validace duplicity DIČ

pracuje na stejném principu jako validace duplicity IČO

¨ Validace duplicity telefonu

je-li zatrženo, proběhne po zadání telefonního čísla kontrola duplicity. Případná duplicita je systémem nahlášena. Za duplicitní jsou považována shodná tel. čísla ve stejném státě a stejném UTO. Ze seznamu telefonních čísel (u jedné adresy) systém vždy kontroluje jenom první.

¨ Validace duplicity faxu

je-li zatrženo, proběhne po zadání faxového čísla kontrola duplicity. Případná duplicita je systémem nahlášena. Za duplicitní jsou považována shodná fax. čísla ve stejném státě a stejném UTO. Ze seznamu faxových čísel (u jedné adresy) systém vždy kontroluje jenom první.

¨ Validace duplicity rodného čísla

je-li zatrženo, proběhne po zadání rodného čísla adresáta kontrola duplicity. V případě, že systém najde stejné rodné číslo u jiného adresáta, upozorní uživatele informativní hláškou, že rodné číslo je již užito u "název" adresáta.

¨ Kontrola rodného čísla MOD11

je-li zatrženo, tak při vkládání rodného čísla adresáta probíhá kontrola rodného čísla podle Modulo11, tzn. zda je rodné číslo zapsáno ve správném tvaru (tato kontrola v podstatě zajistí, že není možné vložit rodné číslo v chybném formátu)

¨ Aktuální stát

identifikace aktuálního státu. Aktuální stát se předplňuje při vkládání nových měst v číselníku měst. Spolu s identifikací aktuálního státu se z číselníku předplňuje i jeho název.

¨ České PSČ

pokud je tato volba zatržena, je při zadávání PSČ nutno vyplňovat PSČ ve formě obvyklé v ČR (např. 370 01)

¨ Implicitní adresát

identifikace implicitního adresáta. Tento parametr v podstatě splňuje funkci činnosti "označení sama sebe".

Formulář

Formulář činnosti - Adresář
Validace duplicity IČO | Validace duplicity IČO
Validace duplicity telefonu | Validace duplicity telefonního čísla
Validace duplicity faxu | Validace duplicity faxového čísla
Validace duplicity rodného čísla | Validace duplicity rodného čísla mezi existujícími adresáty
Kontrola rodného čísla MOD11 | Kontrola rodného čísla na hodnotu modulo 11 (provádí se pokud neobsahuje mezeru)
Aktuální stát | Identifikace aktuálního státu.
 | Název státu.
České PSČ | Způsob použití formátovací masky pro vstup PSČ
Implicitní adresát | Identifikace adresáta
 | Název adresáta

Vyvolávané činnosti

K. | Činnost | Popis
F2 | Adresář | Přehled adresátů
F2 | Státy | Seznam států.

Viz.také

Adresář | Státy


Číselná řada adresátů

Popis

Tato činnost slouží k zajištění jednoznačnosti čísel adresátů na jednotlivých pracovních místech.

U každého pracovního místa (např. dvě odloučená pracoviště jedné firmy) má uživatel možnost určit si interval čísel, ve kterém může zadávat nové adresáty. Nemůže potom nastat situace, že na jednotlivých odloučených pracovištích bude více adresátů se stejným číslem.

Datový model

  • ADINTER Interval čísel adresátů

    • Formulář

    Formulář činnosti - Adresář
Mřížka [Číselná řada adresáta]
Identifikace datového úložiště | Číslo pracovního místa
Interval od | Interval od
Interval do | Intervel do

    Mřížka [Číselná řada adresáta] činnosti - Adresář

    Mřížka [Číselná řada adresáta] činnosti - Adresář
Identifikace datového úložiště | Číslo pracovního místa
Interval od | Interval od
Interval do | Intervel do


Typy subjektů spojení

Popis

Jedná se o typy subjektů spojení, které se pak využívají při práci s adresářem, např. při zadávání nového adresáta a jeho spojení. U každého subjektu se zadává typ a jeho název. Typem může být např. adresa nebo určité obchodní spojení pro distribuci informací apod. Jednotlivé typy subjektů spojení lze využívat i při definici spojení adresátů v událostech komponent (např. jiný typ spojení adresáta v platbách při fakturaci, jiný typ spojení adresáta v poštovních událostech pro adresu, na kterou se odesílá pošt. zásilka apod.).

U každého typu subjektu jsou ovšem důležité parametry, které uživatel zadává na záložce "druhy parametrů". Vstupuje následující údaje:

¨ druh - identifikace spojení (např. adresa, mobil, email, telefon apod.)

¨ název spojení

¨ pořadí

¨ inicializovat - ve většině případů je zadáno Ne a uživatel si jednotlivé parametry u spojení adresátů vstupuje ručně. V případě, že se zde zadá Ano, je parametr ve spojení adresátů vytvořen automaticky, např. pokud zadáme inicializovat Ano u parametru email, tak bude v parametrech spojení adresátů vytvořen parametr email, jehož hodnota bude samozřejmě prázdná (uživatel zde bude muset emailovou adresu dopsat), ale parametr pro zadání správné hodnoty již bude připraven.

Po zadání typu subjektů a jeho parametrů uživatel aktivuje činnost "naplnění parametrů spojení" (menu Volby). Ta naplní jednotlivé parametry ke všem adresátům v adresáři, kteří mají v adrese uveden daný typ subjektu.

Jednotlivé zadané parametry u typu subjektu se u každého adresáta rovněž evidují v čase, tzn. pokud dojde např. ke změně adresy nebo telefonního čísla, bude k dispozici jak nový parametr, tak i ten starý, jako nefunkční označen šedivou barvou.

Datový model

  • ADTYPSUB Typ subjektu ve spojení adresáta

    • Formulář

    Formulář činnosti - Naplnění parametrů spojení
Mřížka [Typy subjektů]
Typ | Identifikátor typu subjektu pro spojení adresáta
Název typu subjektu | Název typu subjektu pro spojení adresáta
Listovací rámeček
Stránka #1 Typy subjektů
Poznámka | Poznámka
Stránka #2 Druhy parametrů
Mřížka [Druhy parametrů]
Druh | Identifikace druhu parametru
Název druhu | Název druhu parametru
Pořadí | Pořadí zobrazení
Inicializovat | Inicializovat parametr při založení spojení

    Mřížka [Typy subjektů] činnosti - Naplnění parametrů spojení

    Mřížka [Typy subjektů] činnosti - Naplnění parametrů spojení
Typ | Identifikátor typu subjektu pro spojení adresáta
Název typu subjektu | Název typu subjektu pro spojení adresáta

    Mřížka [Druhy parametrů] činnosti - Naplnění parametrů spojení

    Mřížka [Druhy parametrů] činnosti - Naplnění parametrů spojení
Druh | Identifikace druhu parametru
Název druhu | Název druhu parametru
Pořadí | Pořadí zobrazení
Inicializovat | Inicializovat parametr při založení spojení

    Vyvolávané činnosti

    K. | Činnost | Popis
- | Naplnění parametrů spojení | Naplnění parametrů spojení pro typ subjektu
F2 | Druhy parametrů spojení | Druhy parametrů spojení

    Atributy tisku

    Základní údaje
Typ | Identifikátor typu subjektu pro spojení adresáta | ADTYPSUB_ad58id | C(6)
Název typu subjektu | Název typu subjektu pro spojení adresáta | ADTYPSUB_ad58naztyp | C(40)
Poznámka | Poznámka | ADTYPSUB_ad58koment | M

    Při pohybu v Druhy parametrů
Druh | Identifikace druhu parametru | ADTYPSPR_ad59id | C(6)
Pořadí | Pořadí zobrazení | ADTYPSPR_ad62porad | N(3)
Inicializovat | Inicializovat parametr při založení spojení | Výpočet | C(3)

    Viz.také

    Naplnění parametrů spojení | Druhy parametrů spojení


Druhy parametrů spojení

Popis

Jedná se o druhy parametrů, které uživatel zadává při definici typů subjektů. Definuje se:

¨ druh a název parametru

¨ ikona parametru daného druhu ve stromu

¨ formát zobrazení v gridu a ve stromu

¨ unikátní pro adresáta

¨ unikátní pro spojení

Pro každý druh spojení se navíc zadává i jeho definice struktury, záložka "definice struktury". Zadává se následující:

¨ hodnota – identifikace druhu elementární hodnoty

¨ odpovídá – odpovídá atributu spojení

¨ návěští

¨ stavový řád

¨ validace

¨ délka

¨ desetiny

Datový model

  • ADSPOPRD Druh parametru subjektu spojení

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Vybrat obrázek | Vybrat obrázek

    Formulář

    Formulář činnosti - Vybrat obrázek
Mřížka [Druhy parametrů]
Druh | Identifikace druhu parametru
Název druhu | Název druhu parametru
Listovací rámeček
Stránka #1 Druhy parametrů
Ikona | Ikona parametru daného druhu ve stromu
Formát | Formát zobrazení v gridu a ve stromu
Unikátní pro adresáta | Unikátní pro adresáta
Unikátní pro spojení | Unikátní pro spojení
Poznámka | Poznámka
Stránka #2 Definice struktury
Mřížka [Definice struktury]
Hodnota | Identifikace atributu elementární hodnoty
Odpovídá | Odpovídá atributu spojení
Návěští | Návěští
Stavový řádek | Stavový řádek
Validace | Validace
Délka | Délka elementární hodnoty
Desetiny | Počet desetin

    Mřížka [Druhy parametrů] činnosti - Vybrat obrázek

    Mřížka [Druhy parametrů] činnosti - Vybrat obrázek
Druh | Identifikace druhu parametru
Název druhu | Název druhu parametru

    Mřížka [Definice struktury] činnosti - Vybrat obrázek

    Mřížka [Definice struktury] činnosti - Vybrat obrázek
Hodnota | Identifikace atributu elementární hodnoty
Návěští | Návěští

    Atributy tisku

    Základní údaje
Druh | Identifikace druhu parametru | ADSPOPRD_ad59id | C(6)
Název druhu | Název druhu parametru | ADSPOPRD_ad59nazdru | C(40)
Ikona | Ikona parametru daného druhu ve stromu | ADSPOPRD_ad59ikona | M
Formát | Formát zobrazení v gridu a ve stromu | ADSPOPRD_ad59format | M
Unikátní pro adresáta | Unikátní pro adresáta | Výpočet | C(3)
Unikátní pro spojení | Unikátní pro spojení | Výpočet | C(3)
Poznámka | Poznámka | ADSPOPRD_ad59koment | M

    Při pohybu v Definice struktury
Hodnota | Identifikace atributu elementární hodnoty | ADSPOPRA_ad60id | C(10)
Délka | Délka elementární hodnoty | ADSPOPRA_ad60len | N(2)
Desetiny | Počet desetin | ADSPOPRA_ad60dec | N(1)
Návěští | Návěští | ADSPOPRA_ad60label | M
Stavový řádek | Stavový řádek | ADSPOPRA_ad60status | M
Validace | Validace | ADSPOPRA_ad60valid | M

    Viz.také

    Vybrat obrázek


Duplicita adresátů

Popis

Činnost je přístupná pouze správci systému nebo uživatelům s právy správce nebo uživatelům ze skupin uživatelů, kterým byla tato činnost povolena v "Oprávnění k činnostem" (tj. není implicitně povolena všem uživatelům).

Na záložce "Adresát" formuláře "Duplicita adresátů" se uvádí:

1. původní adresát

2. aktuální adresát

Záložka "Spojení" definuje, která spojení původního adresáta odpovídají spojením aktuálního adresáta. Záložka "Bankovní spojení" definuje, která bankovní spojení původního adresáta odpovídají bankovním spojením aktuálního adresáta.

Po nastavení dat popisující duplicitu adresátů je možné z menu "Volby" vyvolat funkci "Zaměnit vazby na původního". Tato funkce převede datové vazby směrované na původního adresáta aktuálnímu adresátovi tak, aby bylo možné následně původního adresáta běžným způsobem zrušit. Je měněn odkaz na původního adresáta podle záložky "Adresát", na jeho spojení podle záložky "Spojení", na jeho bankovní spojení podle záložky "Bankovní spojení" všude tam, kde se tyto vyskytují jako cizí klíče (např. v událostech komponent). Navíc jsou kopírovány objektové vazby původního adresáta k aktuálnímu adresátovi.

Záměna adresátů v událostech komponenty zálohy není provedena, pokud pro původního adresáta existuje událost typu "vyúčtování" zálohy. V tomto případě je třeba odpovídající operace odblokovat a události vyúčtování smazat a po provedení funkce "Zaměnit vazby na původního" opakovaně tyto události vytvořit pro aktuálního adresáta. Nedefinovaná spojení původního adresáta na záložce "Spojení" způsobí, že tato spojení budou zkopírována ke spojením aktuálního adresáta (včetně adres). Přitom informace o tom, že tato nově založená spojení aktuálního adresáta jsou totožná s odpovídajícími spojeními původního adresáta se zapíše do dat tak, že se po provedení funkce začnou objevovat na záložce "Spojení", jako kdyby je uživatel zadal ručně. To umožňuje tuto funkci spouštět opakovaně.

Nedefinovaná bankovní spojení původního adresáta na záložce "Bankovní spojení" fungují obdobně jako nedefinovaná spojení původního adresáta na záložce "Spojení" s tím rozdílem, že bankovní spojení původního adresáta není k aktuálnímu adresátovi přidáváno v případě, že u něho již existuje bankovní spojení se stejným kódem banky, prefixem účtu, číslem bankovního účtu a specifickým symbolem.

Datový model

  • ADADZAM Hlavička záměn adresátů
    • ADADSAT Adresát
    • ADADSAT Adresát (alias ADADSAT2)

    • Vyvolávané činnosti

    K. | Činnost | Popis
- | Zaměnit vazby na původního | Převede datové vazby z původního adresáta na aktuálního adresáta
F2 | Adresář | Přehled adresátů
F2 | Bankovní spojení | Bankovní spojení daného adresáta
F2 | Spojení | Spojení daného adresáta

    Formulář

    Formulář činnosti - Zaměnit vazby na původního
Mřížka [Duplicita adresátů]
Listovací rámeček
Stránka #1 Adresát
Původní adresát | Identifikace adresáta
 | Název adresáta
Aktuální adresát | Identifikace importovaného adresáta
 | Název adresáta
Poznámka | Poznámka
Stránka #2 Spojení
Mřížka [Spojení]
Původní | Číslo spojení adresáta.
 | Národní směrové číslo státu pro telefonní spojení (UTO).
 | Telefonní číslo
Jméno | Jméno kontaktní osoby.
Ulice | Ulice adresy adresáta (včetně čísla popisného).
 | Poštovní směrovací číslo adresy adresáta.
 | Město adresy adresáta.
 | Identifikace státu.
Aktuální | Číslo spojení adresáta.
 | Národní směrové číslo státu pro telefonní spojení (UTO).
 | Telefonní číslo
Jméno | Jméno kontaktní osoby.
Ulice | Ulice adresy adresáta (včetně čísla popisného).
 | Poštovní směrovací číslo adresy adresáta.
 | Město adresy adresáta.
 | Identifikace státu.
Stránka #3 Bankovní spojení
Mřížka [Bankovní spojení]
Původní | Identifikátor spojení na bankovní účet adresáta.
Kód banky | Kód banky
Pobočka | Název pobočky, která vede bankovní účet adresátovi.
 | Prefix bankovního účtu adresáta
Číslo účtu | Číslo bankovního účtu adresáta.
Název účtu | Název účtu
Aktuální | Identifikátor spojení na bankovní účet adresáta
Kód banky | Kód banky
Pobočka | Název pobočky, která vede bankovní účet adresátovi.
 | Prefix bankovního účtu adresáta
Číslo účtu | Číslo bankovního účtu adresáta.
Název účtu | Název účtu

    Mřížka [Duplicita adresátů] činnosti - Zaměnit vazby na původního

    Mřížka [Duplicita adresátů] činnosti - Zaměnit vazby na původního
Původní adresát | Identifikace adresáta
Název adresáta | Název adresáta
Aktuální adresát | Identifikace adresáta
Název adresáta | Název adresáta

    Mřížka [Spojení] činnosti - Zaměnit vazby na původního

    Mřížka [Spojení] činnosti - Zaměnit vazby na původního
Původní | Číslo spojení adresáta.
Jméno | Jméno kontaktní osoby.
Ulice | Ulice adresy adresáta (včetně čísla popisného).
Město | Město adresy adresáta.
Aktuální | Číslo spojení adresáta.
Jméno | Jméno kontaktní osoby.
Ulice | Ulice adresy adresáta (včetně čísla popisného).
Město | Město adresy adresáta.

    Mřížka [Bankovní spojení] činnosti - Zaměnit vazby na původního

    Mřížka [Bankovní spojení] činnosti - Zaměnit vazby na původního
Původní | Identifikátor spojení na bankovní účet adresáta.
Č. účtu | Číslo bankovního účtu adresáta.
Aktuální | Identifikátor spojení na bankovní účet adresáta
Č. účtu | Číslo bankovního účtu adresáta.

    Viz.také

    Zaměnit vazby na původního | Adresář | Bankovní spojení adresátů | Spojení


Druhy adresátů

Popis

Pro každého adresáta je možné definovat jeho druh, jehož prostřednictvím se definují přístupová práva uživatelů systému. Právo může nabývat hodnot Čtení, Zápis nebo Žádné. Toto právo se vztahuje k základním informacím o adresátovi, jeho adresám a adresním spojením a neomezuje možnost zadat adresáta v událostech komponent (např. při vytváření faktury, pokladního dokladu apod.). Práva k bankovním spojením adresáta se definují při nastavování práv přístupu zvlášť zaškrtnutím voleb - 'Ban.spojení - čtení' a 'Ban.spojení - žádné'.

Při aktivaci dané činnosti uživatel nejprve zadává identifikaci a název druhu adresátů, např. zaměstnanci (uživatel potřebuje mít zaměstnance uvedené v adresáři kvůli příkazům k úhradě apod.), ale zároveň nechce, aby osobní údaje zaměstnanců (adresa, bank. spojení) byly dostupné všem, kteří pracují s adresářem. K danému druhu adresátů pak definuje přístupová práva (menu Volby nebo klávesa Ctrl B).

Např.:

Nastavení práva k druhu adresáta = Zápis

Volba 'Ban.spojení - čtení' = Zaškrtnutá

Uživatel může měnit základní informace o adresátovi, přidávat adresy a adresní spojení adresáta, ale bankovní spojení adresáta může pouze číst.

Nastavení práva k druhu adresáta = Zápis

Volba 'Ban.spojení - žádné' = Zaškrtnutá

Uživatel může měnit základní informace o adresátovi, přidávat adresy a adresní spojení adresáta, ale bankovní spojení adresáta nevidí, ani nesmí nové bankovní spojení přidávat.

Nastavení práva k druhu adresáta = Čtení

Volba 'Ban.spojení - čtení' = Nezaškrtnutá

Volba 'Ban.spojení - žádné' = Nezaškrtnutá

Uživatel nemůže měnit základní informace o adresátovi, nemůže přidávat ani měnit adresy a adresní spojení adresáta, ale bankovní spojení adresáta může měnit i přidávat.

Datový model

  • ADADSDRU Druh adresáta
    • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Druhy adresátů]
Druh | Druh adresáta
Název druhu adresáta | Název druhu adresáta
Poznámka | Poznámka

    Mřížka [Druhy adresátů] činnosti - Přístupová práva

    Mřížka [Druhy adresátů] činnosti - Přístupová práva
Druh | Druh adresáta
Název druhu adresáta | Název druhu adresáta

    Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci

    Atributy tisku

    Základní údaje
Druh | Druh adresáta | ADADSDRU_ad72id | C(6)
Název druhu adresáta | Název druhu adresáta | ADADSDRU_ad72nazdru | C(40)
Poznámka | Poznámka | ADADSDRU_ad72koment | M

    Viz.také

    Přístupová práva


Palety barev kategorií adresátů

Popis

Nadefinování palety barev kategorií adresátů umožňuje zobrazovat adresáty v činnosti adresář v různých barvách v závislosti na jejich zařazení do kategorií. Např. uživatel si může vytvořit paletu barev, kterou nazve odběratelé. Pak v kategoriích může mít kategorie odběratelé do 100 tis.Kč, odběratelé do 200 tis.Kč. apod. Těmto kategoriím nadefinuje příslušné barvy a přiřadí je k paletě barev odběratelé. Při vstupu do adresáře se pak ve výběrové záložce kromě kategorie adresáta nabízí uživateli i možnost výběru za příslušnou paletu barev. Tzn. když si vybere paletu odběratelé, zobrazí se mu adresáti, kteří spadají do kategorií, které jsou obsažené v paletě odběratelé.

Při spuštění této činnosti uživatel zadává identifikaci a název palety barev. Ke každé paletě si může uvést svojí libovolně dlouhou poznámku. Výběrem skupiny se určuje uživatel palety barev. Důležitější je záložka „kategorie v paletě“, kde uživatel zadává:

¨ kategorie – identifikace kategorie adresáta (pokud ji nemá vytvořenu, je možno ji rovnou založit a přenést zpět do formuláře)

¨ priorita - určuje prioritu určení barvy v paletě barev v případě, že adresát odpovídá většímu počtu kategorií v paletě (např. 10, 20, 30 apod.)

¨ barva písma – tzn. jakou barvu písma budou mít adresáti v dané kategorii (nejčastěji se nechává standardní černá, tzn. že barva písma se neuvádí)

¨ barva pozadí – tzn. jakou barvu bude mít pozadí (tzn. řádek) na kterém je v adresáři uveden adresát, který spadá do této kategorie

V souvislosti s paletou barev byly rozšířeny vlastnosti kategorie adresáta o další atributy. Tyto atributy se nevstupují přímo ve formuláři „kategorie adresátů“, ale pomocí činnosti „definování typu kategorie adresáta“ (menu volby nebo klávesa F5) z tohoto formuláře.

Palety barev je možné exportovat do balíčku.

Datový model

  • ADPALETA Paleta barev kategorií adresáta

    • Formulář

    Formulář činnosti - Barvy RGB
Mřížka [Palety barev kategorií]
Paleta | Identifikace palety barev
Název palety | Název palety barev
Listovací rámeček
Stránka #1 Palety barev kategorií
Skupina | Identifikace skupiny uživatelů
Poznámka | Poznámka
Stránka #2 Kategorie v paletě
Mřížka [Kategorie v paletě]
Kategorie | Identifikace kategorie adresáta.
Název kategorie | Text vystihující charakter kategorie
Priorita | Priorita barvy
B.písma | Identifikace barvy RGB
B.pozadí | Identifikace barvy RGB

    Mřížka [Palety barev kategorií] činnosti - Barvy RGB

    Mřížka [Palety barev kategorií] činnosti - Barvy RGB
Paleta | Identifikace palety barev
Název palety | Název palety barev

    Mřížka [Kategorie v paletě] činnosti - Barvy RGB

    Mřížka [Kategorie v paletě] činnosti - Barvy RGB
Priorita | Priorita barvy
Název kategorie | Text vystihující charakter kategorie

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Barvy RGB |
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů

    Atributy tisku

    Základní údaje
Paleta | Identifikace palety barev | ADPALETA_ad73id | C(6)
Název palety | Název palety barev | ADPALETA_ad73nazpal | C(40)
Poznámka | Poznámka | ADPALETA_ad73koment | M
Skupina | Identifikace skupiny uživatelů | ADPALETA_bw05ident | C(6)
Název kategorie | Text vystihující charakter kategorie | ADKAT_ad08kateg | C(40)
Popis | Popis barvy RGB | BWRGBCOL_bw95popbar | C(40)
Popis | Popis barvy RGB | BWRGBCOL2_bw95popbar | C(40)

    Při pohybu v Kategorie v paletě
Priorita | Priorita barvy | ADPALKAT_ad74prior | N(3)
Kategorie | Identifikace kategorie adresáta. | ADPALKAT_ad08id | C(6)
Barva | Identifikace barvy RGB | ADPALKAT_bw95id | C(6)
Barva | Identifikace barvy RGB | ADPALKAT_bw95id2 | C(6)

    Viz.také

    Barvy RGB | Kategorie adresátů


Konverze pro štítek v události pošty

Popis

Nastavení jednotlivých atributů konverze (tj. přeměna, obrat) pro štítek určuje, jakým způsobem mají být naplněny informace tištěné na štítek z události poštovní zásilky, např. u právnické osoby chce mít uživatel oslovení, jméno a úplný název adresáta (Vážený pan, Jan Novák, firma xxx), ale u fyzické osoby mu stačí oslovení a jméno (Vážený pan, Jan Novák).

Tato činnost se nachází v hlavním menu v činnosti Adresář – Číselníky a parametry. Každá definice konverze pro štítek v události pošty obsahuje tyto atributy:

¨ identifikace definice konverze

¨ název definice konverze

¨ výraz konverze 1.řádku štítku - výraz v jazyce Foxpro - není-li uveden, předplní se prázdný text

¨ výraz konverze 2.řádku štítku - výraz v jazyce Foxpro - není-li uveden, předplní se jméno pro štítek resp. jméno uvedené ve spojení

¨ výraz konverze 3.řádku štítku - výraz v jazyce Foxpro - není-li uveden, předplní se název firmy adresáta

¨ poznámka

Datový model

  • ADCNVPOS Konverze pro štítek v události pošty

    • Formulář

    Formulář činnosti - Barvy RGB
Mřížka [Konverze pro štítek v události pošty]
Konverze | Konverze pro štítek události pošty
Název konverze | Název konverze pro štítek události pošty
Výraz R1 | Výraz konverze 1.řádku štítku
Výraz R2 | Výraz konverze 2.řádku štítku
Výraz R3 | Výraz konverze 3.řádku štítku
Poznámka | Poznámka

    Mřížka [Konverze pro štítek v události pošty] činnosti - Barvy RGB

    Mřížka [Konverze pro štítek v události pošty] činnosti - Barvy RGB
Konverze | Konverze pro štítek události pošty
Název konverze | Název konverze pro štítek události pošty

    Atributy tisku

    Základní údaje
Konverze | Konverze pro štítek události pošty | ADCNVPOS_ad75id | C(6)
Název konverze | Název konverze pro štítek události pošty | ADCNVPOS_ad75nazcnv | C(40)
Výraz R1 | Výraz konverze 1.řádku štítku | ADCNVPOS_ad75cnvr1 | M
Výraz R2 | Výraz konverze 2.řádku štítku | ADCNVPOS_ad75cnvr2 | M
Výraz R3 | Výraz konverze 3.řádku štítku | ADCNVPOS_ad75cnvr3 | M
Poznámka | Poznámka | ADCNVPOS_ad75koment | M


POŠTA

Popis

Komponenta pošta je nástroj podporující komunikaci firmy s okolím a administrativní činnost firmy. Eviduje došlou a odeslanou poštu, kterou lze podle obsahu a charakteru zásilky kategorizovat. Každá zásilka je svázána s určitým adresátem. Pokud byly zásilky vytvořeny jako dokumenty, je jejich obsah neustále k dispozici.

Viz.také

Pošta | Aktuální hodnoty pošty | Kategorie pošty | Kategorie zásilky | Doplňkové služby | Uzavření dnešního dne | Číselné řady kategorií zásilek


Pošta

Popis

Po aktivaci této činnosti se uživateli nejprve zobrazí záložka „výběr“, kde si eliminuje, které údaje ho zajímají a které chce vidět (např. jestli poštu došlou nebo odeslanou, v určitý datum apod.).

Poštovní zásilky se v systému tvoří pomocí nastavených procesů a transformací. Hlavní výhodou tohoto postupu je např. možnost v případě potřeby přetransformovat poštovní zásilku na událost vývěsky apod.

U každé poštovní zásilky je rozlišeno jestli se jedná o poštu došlou, odeslanou nebo uloženou v zásobníku (tzn. k odeslání). Každá zásilka má uvedené datum, adresáta a text. Dále je zde uvedena kategorie pošty, kategorie zásilky (která může určovat, zda se jedná o poštu obyčejnou, doporučenou, balík apod.), hmotnost, cena obsahu, cena zásilky, komentář apod. Přehled pošty se zobrazuje barevně (odeslaná – modře, došlá – červeně). K dispozici je i atribut F.cena, který je určen pro vstup částky fakturované na faktuře jako položka poštovného.

U každé události pošty, která má uvedeného adresáta, je možno si po stisku příslušné záložky "adresa" zobrazit štítek, který je možno modifikovat a následně i tisknout. V případě zatržení příznaku „uchovat změny štítku“ nebudou následné změny v adresáři z hlediska této události automaticky reflektovány (tzn. adresát má uvedenu v adresáři svou adresu, na tu mu je odeslána příslušná poštovní zásilka. Po čase adresát adresu změní, ale v případě, že by nebylo zaškrtnuto „uchovat změny štítku“, tak by se současně s adresářem změnila adresa i zde na štítku a uživatel by po čase nevěděl, na jakou původní adresu vlastně poštovní zásilka odešla).

Po stisku F9 nebo pomocí příslušné činnosti pod menu Volby se aktivuje činnosti „odeslání pošty“. Její spuštění u zobrazených událostí pošty změní příznak z "k odeslání" na "odeslaná" a současně je aktuálním systémovým datem naplněn atribut datum odeslání (tento atribut je dostupný pouze formou implementačních rozšíření, např. volná karta, předlohy výstupu, ...).

Údaje na těchto záložkách jsou v okamžiku aktivace dokumentu s definovaným mailmerge a objektově spojeným s operací pošty kopírovány do souboru mailmerge.

Datový model

  • POPOSTA Poštovní zásilka
    • POPOPPO Kategorie pošty
    • ADSPOJ Spojení adresáta
      • ADADSAT Adresát
      • ADADR Adresa
    • BWUZIVAT Uživatel systému
    • BWUZIVAT Uživatel systému (alias BWUZIVA2)
    • SPPRISTU Přístupové právo uživatele k věci
    • ADSTATY Stát
    • SPTYP Druh procesu/operace
    • POKATZAS Kategorie zásilky
    • POCENDSL Ceník doplňkových služeb
    • POCENDSL Ceník doplňkových služeb (alias POCENDSL2)
    • SPPRCOD Operace procesu
      • SPPRC Proces
    • ADOSLOV Oslovení

    • Vyvolávané činnosti

    K. | Činnost | Popis
F9 | Odeslání pošty |
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^S | SUMy |
- | Vyřizuje | Změna uživatele odpovědného za vyřízení zásilky.
- | INFORMACE O ADRESÁTOVI | Vývěska adresáta a pošta adresáta...
F2 | Adresář | Přehled adresátů
F2 | Doplňkové služby |
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Kategorie pošty | Seznam kategorií poštovní zásilky.
F2 | Kategorie zásilky |
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Oslovení |
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Státy | Seznam států.
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

    Formulář činnosti - Kategorie adresátů
Mřížka [Pošta]
Listovací rámeček
Stránka #1 Pošta
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
 | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Název druhu procesu
Datum | Datum zásilky
Druh | Druh události - Došlá, Odeslaná pošta, K odeslání
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
Vyřizuje | Identifikace uživatele systému
Doporučeně | Příznak doporučené zásilky.
Poř. | Pořadové číslo odeslané zásilky v rámci dne
Kategorie | Identifikace kategorie pošty.
 | Název kategorie pošty.
Zásilka | Identifikace kategorie zásilky
 | Identifikace doplňkové služby
 | Identifikace doplňkové služby
Hmotnost | Hmotnost zásilky v gramech
Hodnota | Uvedená hodnota zásilky v Kč
Cena obsahu | Skutečná cena obsahu zásilky
Cena | Cena zásilky, platba přepravní organizaci
F.cena | Cena zásilky uvedená na faktuře odeslané
Text | Text výstižně charakterizující zásilku.
Komentář | Komentář k zásilce
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
 | Nepřepisovat cenu nově vypočtenou hodnotou
Stránka #2 Adresa
Uchovat změny štítku | Uchovat změny štítku, na štítku nebudou údaje dále přepisovány
Oslovení | Oslovení
Štítek | První řádek adresy (např. oslovení)
 | Druhý řádek adresy (např. jméno)
 | Třetí řádek adresy (např. adresát)
Ulice | Ulice adresy adresáta (včetně čísla popisného).
 | Poštovní směrovací číslo adresy adresáta.
Město | Město adresy adresáta.
Stát | Identifikace státu.
 | Název státu.
Stránka #3 Parametry zásilky
Mřížka [Hodnoty parametrů]
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Identifikátor spojení na bankovní účet adresáta.
 | Název adresáta
ID | Identifikace položky číselníku
 | Název položky číselníku
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Text1 | Textová elementární hodnota
Dat1 | Datumová elementární hodnota 1
Dat2 | Datumová elementární hodnota 2
Num1 | Numerická elementární hodnota 1
Num2 | Numerická elementární hodnota 2
Cmb1 | Překryvný seznam elementární hodnota 1
Cmb2 | Překryvný seznam elementární hodnota 2
Poznámka | Poznámka
Platnost od | Platnost od
do | Platnost do
Stránka #4 Výběr
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu od
do | Pořadové číslo procesu do
Operace | Identifikátor druhu operace
Proces | Identifikátor druhu procesu
Datum zásilky | Datum zásilky od
 | Datum zásilky do
Došlá | Došlá pošta
Odeslaná | Odeslaná pošta
K odeslání | Pošta k odeslání
Typ pošty | Typ pošty - Došlá,Odeslaná,k odeslání
 | Výběr poštovních zásilek dle příznaku doporučeně.
Popis | Text výstižně charakterizující zásilku.
Vyřizuje | Identifikace uživatele systému
Adresát | Identifikace adresáta
Spojení | Číslo spojení adresáta.
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Kategorie | Identifikace kategorie pošty.
Kategorie zásilky | Identifikace kategorie zásilky
Doplňková služba | Identifikace doplňkové služby
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Pošta] činnosti - Kategorie adresátů

    Mřížka [Pošta] činnosti - Kategorie adresátů
Označování | Označení záznamu
Datum zásilky | Datum zásilky
Datum | Datum a čas zápisu záznamu události
Příznak | Druh události - Došlá, Odeslaná pošta, K odeslání
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh | Identifikátor druhu operace
Text | Text výstižně charakterizující zásilku.
PSČ | Poštovní směrovací číslo adresy adresáta.
Datum odeslání | Datum odeslání.
Pořadí | Pořadové číslo odeslané zásilky v rámci dne
Adresát | Identifikace adresáta
Název adresáta | Název adresáta

    Mřížka [Hodnoty parametrů] činnosti - Kategorie adresátů

    Mřížka [Hodnoty parametrů] činnosti - Kategorie adresátů
Název parametru | Název parametru
Hodnota parametru | Hodnota parametru
Platnost od | Platnost od
do | Platnost do

    Atributy tisku

    Základní údaje
Rok | Rok v identifikaci procesu | POPOSTA_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | POPOSTA_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | POPOSTA_sp33cisd | C(8)
Druh operace | Identifikátor druhu operace | POPOSTA_sp07idtyp | C(6)
Datum zásilky | Datum zásilky | POPOSTA_po01datza | D
Příznak pošty | Druh události - Došlá, Odeslaná pošta, K odeslání | Výpočet | C(14)
Oslovení | Text oslovení | ADOSLOV_ad57oslov | C(40)
1. řádek štítku | První řádek adresy (např. oslovení) | POPOSTA_po03r1 | M
2. řádek štítku | Druhý řádek adresy (např. jméno) | POPOSTA_po03r2 | M
3. řádek štítku | Třetí řádek adresy (např. adresát) | POPOSTA_po03r3 | M
Identifikace adresáta | Identifikace adresáta | POPOSTA_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie .... | Výpočet | C(9)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | POPOSTA_po01ulice | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | POPOSTA_po01psc | C(10)
Město | Město adresy adresáta. | POPOSTA_po01mesto | C(40)
Stát | Identifikace státu. | POPOSTA_ad05id | C(3)
Název státu | Název státu. | ADSTATY_ad05stat | C(30)
Název státu v anglickém jazyce | Název státu v anglickém jazyce | ADSTATY_ad05nazeva | C(40)
Cena zásilky | Cena zásilky, platba přepravní organizaci | POPOSTA_po01cena | N(20,4)
Cena obsahu zásilky | Skutečná cena obsahu zásilky | POPOSTA_po01cenas | N(20,4)
F.cena | Cena zásilky uvedená na faktuře odeslané | POPOSTA_po01cenaf | N(20,4)
Doporučeně | Příznak doporučené zásilky. | Výpočet | C(3)
Kategorie | Identifikace kategorie pošty. | POPOSTA_po02id | C(6)
Popis zásilky | Text výstižně charakterizující zásilku. | POPOSTA_po01text | C(40)
Název kategorie | Název kategorie pošty. | POPOPPO_po02typ | C(40)
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Vyřizuje | Jméno uživatele systému | BWUZIVA2_bw01jmeno | C(30)
Hmotnost zásilky | Hmotnost zásilky v gramech | POPOSTA_po01hmotn | N(12,2)
Hodnota zásilky | Uvedená hodnota zásilky v Kč | POPOSTA_po01cenaz | N(20,4)
Kategorie zásilky | Identifikace kategorie zásilky | POPOSTA_po52id | C(6)
Popis kategorie | Název kategorie zásilky | POKATZAS_po52kateg | C(40)
Doplňková služba | Identifikace doplňkové služby | POPOSTA_po54id | C(6)
Doplňková služba | Identifikace doplňkové služby | POPOSTA_po54id1 | C(6)
Pořadí v rámci dne | Pořadové číslo odeslané zásilky v rámci dne | POPOSTA_po01porcis | N(6)

    Viz.také

    Odeslání pošty | OZNAČOVÁNÍ | SUMy | Vyřizuje | INFORMACE O ADRESÁTOVI | Adresář | Doplňkové služby | Druhy operací | Druhy procesů | Kategorie adresátů | Kategorie pošty | Kategorie zásilky | Obchodní selektor | Organizační selektor | Oslovení | Spojení adresátů | Státy | Technicko-věcný selektor


Aktuální hodnoty pošty

Popis

V případě, že má uživatel nadefinovány aktuální hodnoty pošty, dokáže zde správně zvoleným výběrem získat jejich hodnotu, a to za druh hodnoty, kategorii a adresáta.

Datový model

  • POAH Aktuální hodnota
    • POPOPPO Kategorie pošty
    • ADADSAT Adresát
    • SPSTATDI Druh hodnoty

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresář | Přehled adresátů
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Kategorie pošty | Seznam kategorií poštovní zásilky.

    Formulář

    Formulář činnosti - Adresář
Mřížka [Aktuální hodnoty pošty]
Listovací rámeček
Stránka #1 Aktuální hodnoty
 | Identifikace komponenty
Druh hodnoty | Identifikace druhu hodnoty
 | Název druhu hodnoty
Kategorie | Identifikace kategorie pošty.
 | Název kategorie pošty.
Adresát | Identifikace adresáta
 | Název adresáta
Hodnota | Aktuální hodnota
Stránka #2 Výběr
Druh hodnoty | Identifikace druhu hodnoty
Kategorie | Identifikace kategorie pošty.
Adresát | Identifikace adresáta
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Aktuální hodnoty pošty] činnosti - Adresář

    Mřížka [Aktuální hodnoty pošty] činnosti - Adresář
Komponenta | Identifikace komponenty
Druh hodnoty | Identifikace druhu hodnoty
Kategorie | Identifikace kategorie pošty.
Adresát | Identifikace adresáta
Hodnota | Aktuální hodnota
Název druhu hodnoty | Název druhu hodnoty
Název kategorie | Název kategorie pošty.
Název adresáta | Název adresáta

    Atributy tisku

    Základní údaje
Kategorie | Identifikace kategorie pošty. | POAH_po02id | C(6)
Název kategorie | Název kategorie pošty. | POPOPPO_po02typ | C(40)
Identifikace adresáta | Identifikace adresáta | POAH_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Hodnota | Aktuální hodnota | POAH_po03hodnot | N(20,4)
Druh hodnoty | Identifikace druhu hodnoty | POAH_sp67id | C(3)
Komponenta | Identifikace komponenty | POAH_sp06idsubs | C(3)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)

    Viz.také

    Adresář | Druhy hodnot | Kategorie pošty


Kategorie pošty

Popis

Tato činnost umožňuje definovat jednotlivé kategorie pošty, které se rozlišují u poštovních zásilek. Uživatel má k dispozici přehled dosud vytvořených kategorií (např. obchodní informace, záloha, upomínka, reklama, pozvánka apod.). Tento přehled může aktualizovat, opravovat a rušit. U každé kategorie je k dispozici:

¨ identifikace a název kategorie

¨ kategorie zásilky - identifikace kategorie zásilky (může být např. obyčejné psaní, doporučené, cenné psaní, balík apod.)

¨ doplňková služba - identifikace doplňkové služby spojené s kategorií pošty

¨ doplňková služba - identifikace doplňkové služby spojené s kategorií pošty

¨ komentář - libovolný popis

V případě vyplnění těchto atributů potom při vstupu událostí pošty dojde při zadání této kategorie k automatickému vyplnění těchto atributů na události právě podle tohoto zadání.

Datový model

  • POPOPPO Kategorie pošty
    • BWUZIVAT Uživatel systému
    • POKATZAS Kategorie zásilky
    • POCENDSL Ceník doplňkových služeb
    • POCENDSL Ceník doplňkových služeb (alias POCENDSL2)

    • Vyvolávané činnosti

    K. | Činnost | Popis
- | Pošta kategorie | Poštovní zásilky dané kategorie
F2 | Doplňkové služby |
F2 | Kategorie zásilky |
F2 | Klasifikace objektů | Klasifikace objektů
F2 | Sady parametrů | Sady parametrů

    Formulář

    Formulář činnosti - Sady parametrů
Mřížka [Kategorie pošty]
Kategorie | Identifikace kategorie pošty.
Název | Název kategorie pošty.
Kategorie zásilky | Identifikace kategorie zásilky
 | Název kategorie zásilky
Doplňková služba | Identifikace doplňkové služby
 | Název doplňkové služby
Doplňková služba | Identifikace doplňkové služby
 | Název doplňkové služby
Klasifikace | Identifikace klasifikace objektu
Sada | Identifikátor sady parametrů
Komentář | Komentář kategorie pošty
Zapsal | Jméno uživatele systému
Pošta

    Mřížka [Kategorie pošty] činnosti - Sady parametrů

    Mřížka [Kategorie pošty] činnosti - Sady parametrů
Kategorie | Identifikace kategorie pošty.
Název kategorie | Název kategorie pošty.

    Atributy tisku

    Základní údaje
Kategorie | Identifikace kategorie pošty. | POPOPPO_po02id | C(6)
Název kategorie | Název kategorie pošty. | POPOPPO_po02typ | C(40)
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)

    Viz.také

    Pošta | Doplňkové služby | Kategorie zásilky | Klasifikace objektů | Sady parametrů


Kategorie zásilky

Popis

Po aktivaci této činnosti se uživateli nejprve zobrazí záložka „výběr“, kde si může zpřesnit údaje výběru nebo nechat výběr prázdný a načíst tak všechny dosud nadefinované kategorie zásilek.

Jedná se o definici jednotlivých kategorií zásilky pošty, kde u každé zásilky eviduje:

¨ identifikaci a název kategorie zásilky

¨ název (strom) – název kategorie zásilky pro strom

¨ řada – identifikátor číselné řady zásilek

¨ aktuální – Ano/Ne – určení, zda kategorie zásilky je aktuální nebo již časově zastaralá. Podle tohoto příznaku je možno i zadávat atribut na záložce „výběr“.

¨ spojená doplňková služba

Datový model

  • POKATZAS Kategorie zásilky
    • POKATCR Číselná řada kategorie zásilky
    • BWUZIVAT Uživatel systému
    • POCENDSL Ceník doplňkových služeb (alias POCENDSL3)

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Doplňkové služby |
F2 | Číselné řady kategorií zásilek | Číselné řady kategorií zásilek

    Formulář

    Formulář činnosti - Číselné řady kategorií zásilek
Mřížka [Kategorie zásilky]
Listovací rámeček
Stránka #1 Kategorie zásilky
Identifikace | Identifikace kategorie zásilky
Název | Název kategorie zásilky
Název (strom) | Popis kategorie zásilky pro strom
Řada | Identifikátor číselné řady zásilek
Název číselné řady | Název číselné řady zásilek
Aktuální | Aktuální Ano/Ne
Spojená doplňková služba | Identifikace doplňkové služby
 | Název doplňkové služby
Komentář | Komentář ke kategorii zásilky
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Cena zásilky
Mřížka [Cena zásilky]
Rozlišení | Rozlišení ceny zásilky
Dle rozlišení do | Cena zásilky pro kategorii dle rozlišení do
Cena zásilky | Cena zásilky pro danou hmotnostní kategorii
Stránka #3 Možné doplňkové služby
Mřížka [Spojení s doplňkovými službami]
Doplňková služba | Identifikace doplňkové služby
 | Název doplňkové služby
 | Komentář k doplňkové službě
Stránka #4 Doplňkové služby
Mřížka [Ceník doplňkových služeb]
Identifikace | Identifikace doplňkové služby
Název | Název doplňkové služby
Cena | Cena doplňkové služby
Platí pro každých... | Cena platí pro každých...
Pro každých | Platí pro každých
 | Jednotka
Od hranice | Za každých započatých nad tuto částku
Komentář | Komentář k doplňkové službě
Stránka #5 Výběr
Kategorie zásilky | Identifikace kategorie zásilky
Popis kategorie | Název kategorie zásilky
Řada | Identifikátor číselné řady zásilek
Spojená doplňková služba | Identifikace doplňkové služby
Aktuální | Aktuální Ano/Ne
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Kategorie zásilky] činnosti - Číselné řady kategorií zásilek

    Mřížka [Kategorie zásilky] činnosti - Číselné řady kategorií zásilek
Označování | Označení záznamu
Identifikace | Identifikace kategorie zásilky
Název | Název kategorie zásilky
Řada | Identifikátor číselné řady zásilek
Název číselné řady | Název číselné řady zásilek

    Mřížka [Cena zásilky] činnosti - Číselné řady kategorií zásilek

    Mřížka [Cena zásilky] činnosti - Číselné řady kategorií zásilek
Rozlišení | Rozlišení ceny zásilky
Dle rozlišení do | Cena zásilky pro kategorii dle rozlišení do
Cena zásilky | Cena zásilky pro danou hmotnostní kategorii

    Mřížka [Spojení s doplňkovými službami] činnosti - Číselné řady kategorií zásilek

    Mřížka [Spojení s doplňkovými službami] činnosti - Číselné řady kategorií zásilek
Doplňková služba | Identifikace doplňkové služby
Název | Název doplňkové služby

    Mřížka [Ceník doplňkových služeb] činnosti - Číselné řady kategorií zásilek

    Mřížka [Ceník doplňkových služeb] činnosti - Číselné řady kategorií zásilek
Identifikace | Identifikace doplňkové služby
Název | Název doplňkové služby

    Atributy tisku

    Základní údaje
Kategorie zásilky | Identifikace kategorie zásilky | POKATZAS_po52id | C(6)
Popis kategorie zásilky | Název kategorie zásilky | POKATZAS_po52kateg | C(40)
Popis kategorie pro strom | Popis kategorie zásilky pro strom | POKATZAS_po52strom | C(40)
Aktuální | Aktuální Ano/Ne | Výpočet | C(3)
Řada | Identifikátor číselné řady zásilek | POKATZAS_po56id | C(6)
Název číselné řady | Název číselné řady zásilek | POKATCR_po56nazrad | C(40)
Spojená doplňková služba | Identifikace doplňkové služby | POKATZAS_po54id | C(6)
Název doplňkové služby | Název doplňkové služby | POCENDSL3_po54sluzba | C(40)
Komentář kategorie zásilky | Komentář ke kategorii zásilky | POKATZAS_po52koment | M
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | POKATZAS_sp00datzap | T
Název doplňkové služby | Název doplňkové služby | POCENDSL2_po54sluzba | C(40)
Cena doplňkové služby | Cena doplňkové služby | POCENDSL2_po54cena | N(20,4)
Platí pro každých .. | Cena platí pro každých... | POCENDSL2_po54prokaz | N(1)
Pro každých | Platí pro každých | POCENDSL2_po54zvypro | N(20,4)
Od hranice | Za každých započatých nad tuto částku | POCENDSL2_po54odhran | N(20,4)
Jednotka | Jednotka | Výpočet | C(18)
Komentář k doplňkové službě | Komentář k doplňkové službě | POCENDSL2_po54koment | M

    Při pohybu v Cena zásilky
U zásilky dle rozlišení do | Cena zásilky pro kategorii dle rozlišení do | POCENZAS_po53hmotn | N(12,2)
Cena zásilky | Cena zásilky pro danou hmotnostní kategorii | POCENZAS_po53cena | N(20,4)

    Při pohybu v Možné doplňkové služby
    Spojená doplňková služba Identifikace doplňkové služby POKATDSL_po54id C(6)

    Viz.také

    Doplňkové služby | Číselné řady kategorií zásilek


Doplňkové služby

Popis

Tato činnost poskytuje uživateli možnost vedení evidence doplňkových služeb použitelných při posílání zásilky a jejich cenové ohodnocení.

Datový model

  • POCENDSL Ceník doplňkových služeb

    • Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených

    Formulář

    Formulář činnosti - OZNAČOVÁNÍ
Mřížka [Doplňkové služby]
Identifikace | Identifikace doplňkové služby
Název | Název doplňkové služby
Cena | Cena doplňkové služby
Platí pro každých... | Cena platí pro každých...
Pro každých | Platí pro každých
 | Jednotka
Od hranice | Za každých započatých nad tuto částku
Komentář k doplňkové službě | Komentář k doplňkové službě

    Mřížka [Doplňkové služby] činnosti - OZNAČOVÁNÍ

    Mřížka [Doplňkové služby] činnosti - OZNAČOVÁNÍ
Označování | Označení záznamu
Identifikace | Identifikace doplňkové služby
Název | Název doplňkové služby

    Atributy tisku

    Základní údaje
Doplňková služba | Identifikace doplňkové služby | POCENDSL_po54id | C(6)
Název doplňkové služby | Název doplňkové služby | POCENDSL_po54sluzba | C(40)
Cena doplňkové služby | Cena doplňkové služby | POCENDSL_po54cena | N(20,4)
Platí pro každých... | Cena platí pro každých... | Výpočet | C(3)
Pro každých | Platí pro každých | POCENDSL_po54zvypro | N(20,4)
Od hranice | Za každých započatých nad tuto částku | POCENDSL_po54odhran | N(20,4)
Jednotka | Jednotka | POCENDSL_po54jedn | N(1)
Komentář k doplňkové službě | Komentář k doplňkové službě | POCENDSL_po54koment | M

    Viz.také

    OZNAČOVÁNÍ


Uzavření dnešního dne

Popis

Po aktivaci této činnosti je uživatel dotázán: „Přejete si provést uzavření dnešního dne pro odesílání poštovních zásilek k dnešnímu datu?“ – volba Ano/Ne. Po volbě Ano dojde k uzavření komponenty pošta (jak pro přijaté, tak pro odeslané zásilky) k dnešnímu dni. Zároveň se do činnosti otevřená období komponent automaticky zapíše ke komponentě pošta do atributu „vstup datum od“ datum následujícího dne.

Tato činnost byla v roce 2002 částečně nahrazena ekvivalentní činností otevřená období komponent.

Datový model

  • SPKOMPUZ Uzavřené období komponenty

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Číselné řady kategorií zásilek

Popis

Tato činnost umožňuje uživateli evidovat si jednotlivé číselné řady kategorií zásilek. U každé řady se definuje:

¨ identifikace a název řady

¨ od – do – číselný interval řady

Datový model

  • POKATCR Číselná řada kategorie zásilky

    • Formulář

    Formulář činnosti - OZNAČOVÁNÍ
Mřížka [Číselné řady]
Řada | Identifikátor číselné řady zásilek
Název číselné řady | Název číselné řady zásilek
Od | Číslování zásilek kategorie zásilek od
do | Číslování zásilek kategorie zásilek od
Poznámka | Poznámka

    Mřížka [Číselné řady] činnosti - OZNAČOVÁNÍ

    Mřížka [Číselné řady] činnosti - OZNAČOVÁNÍ
Řada | Identifikátor číselné řady zásilek
Název číselné řady | Název číselné řady zásilek
Od | Číslování zásilek kategorie zásilek od
do | Číslování zásilek kategorie zásilek od

    Atributy tisku

    Základní údaje
Řada | Identifikátor číselné řady zásilek | POKATCR_po56id | C(6)
Název číselné řady | Název číselné řady zásilek | POKATCR_po56nazrad | C(40)
Od | Číslování zásilek kategorie zásilek od | POKATCR_po56porcod | N(6)
do | Číslování zásilek kategorie zásilek od | POKATCR_po56porcdo | N(6)
Poznámka | Poznámka | POKATCR_po56koment | M


DOKUMENTY

Popis

Tato činnost v sobě shromažďuje činnosti, které se bezprostředně vztahují k práci s dokumenty. Jsou to:

¨ dokument (tj. přehled všech dosud vytvořených a použitých dokumentů)

¨ druhy dokumentů

¨ předlohy dokumentu

¨ spouštěné aplikace

Viz.také

Dokument | Přehled o použití dokumentů | Druhy dokumentů | Kategorie dokumentů | Předlohy dokumentů | Spouštěné aplikace | KONFIGURACE XML DOKUMENTŮ


Dokument

Popis

Na základě zadaného výběru má uživatel k dispozici přehled dokumentů, které byly ve firmě vytvořeny. U každého dokumentu jsou k dispozici následující informace:

¨ název dokumentu

¨ druh dokumentu – identifikace dokumentu. Ke každému druhu dokumentu lze nastavit přístupová práva. Vytvářet nový dokument má uživatel možnost pouze s druhem dokumentu, ke kterému má právo zápis. V případě, že má aktuální uživatel k dokumentu právo zápis a v okamžiku otevření daného dokumentu má tento dokument zároveň otevřen jiný uživatel, zobrazuje se mu v hlášení informace, že „dokument je otevřen pouze pro čtení, případné změny nebudou zaznamenány a jméno uživatele, který má otevřen daný dokument pro zápis“.

¨ předloha – identifikace předlohy. Každá předloha dokumentu je spojena i s druhem dokumentu. K druhu dokumentu lze definovat přístupová práva, čímž jsou zároveň definována přístupová práva i k dané předloze. Uživatel má možnost používat předlohu (tzn. i vytvářet na jejím základě nový dokument), k jejímuž druhu má právo přístupu čtení nebo zápis.

¨ klíč - pokud se jedná o předlohu typu XML, zadává se u dokumentu i klíč

¨ externí uložení - v případě potřeby externího uložení dokumentu. Uživatel po zaškrtnutí tohoto atributu pak udává cestu a název souboru, ve kterém je dokument externě uložen

¨ chráněný dokument - takový dokument pak může opravovat pouze autor dokumentu. Ostatním uživatelům se při otevření tohoto dokumentu zobrazí hlášení, že případné změny nebudou zaznamenány.

¨ automatické ukládání revizí - umožňuje u dokumentu ukládat i jeho revize. Prázdný atribut za umožňuje uživateli nastavit interval autom. ukládání revizí v čase (v hodinách a minutách)

¨ soubor - název souboru, ve kterém je dokument uložen (při externím uložení)

¨ duplikát - název souboru, do kterého je po změně automaticky ukládán duplikát dokumentu

Dokumenty je možno aktivovat, tzn. zobrazit po stisku tlačítka „editovat dokument" nebo příslušnou činností z menu Volby. Jednotlivé záložky poskytují uživateli přehled o příslušnosti dokumentu k určité kategorii (po stisku F3 možno zařadit dokument k vybrané kategorii a datu), použití dokumentu, jeho verzích a protokolech. K jednotlivým dokumentům je možno pomocí vloženého objektu vytvořit prezentaci. V případě, že uživatel vytváří dokument pomocí vazby objektů, má k dispozici i činnost spojené dokumenty.

Datový model

  • SPDOKOBS Dokument
    • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)
    • BWUZIVAT Uživatel systému
    • SPPREDLO Typ předlohy dokumentu
      • SPPROGRA Volání programu (alias SPPROGRA2)
    • SPDOKTYP Druh dokumentu

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Kopírovat odkaz na dokument | Kopírovat odkaz na dokument
F6 | Editace dokumentu | Editace dokumentu v externích aplikacích
F7 | AKCE DOKUMENTU | Akce dokumentu určená spouštěnou aplikací
F9 | Prezentace dokumentu | Prezentace dokumentu
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Uložit novou verzi dokumentu | Uložit novou verzi dokumentu
- | Odeslat dokument |
F2 | Adresář | Přehled adresátů
F2 | Druhy dokumentů | Přehled druhů dokumentů
F2 | Kategorie dokumentů | Kategorie dokumentů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Předlohy dokumentů | Definice předloh dokumentů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Určit soubor duplikátu dokumentu | Určit soubor duplikátu dokumentu
F2 | Vybrat soubor dokumentu | Vybrat soubor dokumentu

    Formulář

    Formulář činnosti - Kategorie dokumentů
Mřížka [Dokumenty]
Listovací rámeček
Stránka #1 Dokumenty
Dokument | Název dokumentu
Druh | Identifikátor druhu dokumentu
 | Název druhu dokumentu
Předloha | Identifikátor předlohy.
 | Text výstižně popisující předlohu.
Klíč | Klíč pro další možné vyhledávání dokumentů a určení výstupního souboru XML dokumentů
Externí uložení | Dokument je uložen externě (soubor na disku, na internetu, ...)
Chráněný dokument | Chráněný dokument může opravovat pouze jeho autor
Automatické ukládání verzí | Automatické ukládání verzí dokumentu
 | Interval automatického ukládání verzí v hodinách a minutách
Soubor | Název souboru, ve kterém je dokument uložen
Duplikát | Název souboru, do kterého je po změně dokumentu automaticky ukládán duplikát dokumentu
Založil | Jméno uživatele systému
 | Datum a čas založení dokumentu
Poznámka | Komentář k dokumentu
Stránka #2 Kategorie dokumentu
Mřížka [Kategorie dokumentu]
Kategorie | Identifikace kategorie dokumentu
Název kategorie | Název kategorie dokumentu
Zařazení | Datum zařazení dokumentu do kategorie
Vyřazení | Datum vyřazení dokumentu z kategorie
Založil | Jméno uživatele systému
Datum a čas zápisu | Datum a čas zápisu záznamu události
Stránka #3 Použití dokumentu
Mřížka [Použití dokumentu]
Stránka #4 Verze dokumentu
Mřížka [Revize dokumentu]
Zapsal | Jméno uživatele systému
Datum | Datum založení verze dokumentu
Poznámka | Poznámka
Stránka #5 Protokol
Mřížka [Protokol]
Dne | Datum zápisu do protokolu
Uživatel | Jméno uživatele systému
Popis | Popis položky protokolu dokumentu
 | 1.klíč položky protokolu
Poznámka | Poznámka
Stránka #6 Výběr
Dokument | Název dokumentu
Klíč | Klíč pro další možné vyhledávání dokumentů a určení výstupního souboru XML dokumentů
Datum od | Datum a čas založení dokumentu
do | Datum a čas založení dokumentu
Obsah poznámky | Výběr podle obsahu poznámky
Druh | Identifikátor druhu dokumentu
Kategorie | Identifikace kategorie dokumentu
Předloha | Identifikátor předlohy.
Zapsané | Identifikace uživatele systému
Adresát | Identifikace adresáta
 | Název adresáta
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Dokumenty] činnosti - Kategorie dokumentů

    Mřížka [Dokumenty] činnosti - Kategorie dokumentů
Označování | Označení záznamu
Datum | Datum a čas založení dokumentu
Dokument | Název dokumentu
Uživatel | Jméno uživatele systému
Druh | Identifikátor druhu dokumentu
Název druhu dokumentu | Název druhu dokumentu
Předloha | Identifikátor předlohy.
Název předlohy dokumentu | Text výstižně popisující předlohu.
Klíč | Klíč pro další možné vyhledávání dokumentů a určení výstupního souboru XML dokumentů

    Mřížka [Kategorie dokumentu] činnosti - Kategorie dokumentů

    Mřížka [Kategorie dokumentu] činnosti - Kategorie dokumentů
Kategorie | Identifikace kategorie dokumentu
Název kategorie | Název kategorie dokumentu
Zařazení | Datum zařazení dokumentu do kategorie
Vyřazení | Datum vyřazení dokumentu z kategorie

    Mřížka [Použití dokumentu] činnosti - Kategorie dokumentů

    Mřížka [Použití dokumentu] činnosti - Kategorie dokumentů
Datum a čas od | Datum a čas použití dokumentu od.
Pracovník | Jméno uživatele systému
Způsob | Způsob použití dokumentu (čtení, čtení a zápis).
Datum a čas do | Datum a čas použití dokumentu do.

    Mřížka [Revize dokumentu] činnosti - Kategorie dokumentů

    Mřížka [Revize dokumentu] činnosti - Kategorie dokumentů
Datum | Datum založení verze dokumentu
Zapsal | Jméno uživatele systému

    Mřížka [Protokol] činnosti - Kategorie dokumentů

    Mřížka [Protokol] činnosti - Kategorie dokumentů
Dne | Datum zápisu do protokolu
Popis | Popis položky protokolu dokumentu
Uživatel | Jméno uživatele systému

    Atributy tisku

    Základní údaje
Datum | Datum a čas založení dokumentu | SPDOKOBS_sp26datum | T
Dokument | Název dokumentu | SPDOKOBS_sp26nazev | C(40)
Poznámka | Komentář k dokumentu | SPDOKOBS_sp26koment | M
Druh | Identifikátor druhu dokumentu | SPDOKOBS_sp57id | C(6)
Název druhu dokumentu | Název druhu dokumentu | SPDOKTYP_sp57typdok | C(40)
Předloha | Identifikátor předlohy. | SPDOKOBS_sp01id | C(6)
Název předlohy dokumentu | Text výstižně popisující předlohu. | SPPREDLO_sp01predlo | C(30)
Ident. | Identifikace uživatele systému | SPDOKOBS_bw01uziv | C(6)
Uživatel | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Uživatel (úplné jméno) | Úplné jméno uživatele systému | BWUZIVAT_bw01jmenot | C(25)
Chráněný dokument | Chráněný dokument může opravovat pouze jeho autor | Výpočet | C(3)
Externí uložení | Dokument je uložen externě (soubor na disku, na internetu, ...) | Výpočet | C(3)
Soubor | Název souboru, ve kterém je dokument uložen | SPDOKOBS_sp26soubor | M
Duplikát | Název souboru, do kterého je po změně dokumentu automaticky ukládán duplikát dokumentu | SPDOKOBS_sp26soudup | M
Automatické ukládání verzí | Automatické ukládání verzí dokumentu | Výpočet | C(3)
Interval | Interval automatického ukládání verzí v hodinách a minutách | SPDOKOBS_sp26revint | C(5)
Uživatel | Jméno uživatele systému | BWUZIVA2_bw01jmeno | C(30)
Uživatel (úplné jméno) | Úplné jméno uživatele systému | BWUZIVA2_bw01jmenot | C(25)
Založil | Jméno uživatele systému | BWUZIVA7_bw01jmeno | C(30)
Uživatel (úplné jméno) | Úplné jméno uživatele systému | BWUZIVA7_bw01jmenot | C(25)

    Při pohybu v Revize dokumentu
Datum | Datum založení verze dokumentu | SPDOKREV_spb9datum | T
Poznámka | Poznámka | SPDOKREV_spb9koment | M

    Při pohybu v Práce s dokumentem
Datum a čas od | Datum a čas použití dokumentu od. | SPDOKUZI_sp03datum | T
Datum a čas do | Datum a čas použití dokumentu do. | SPDOKUZI_sp03datumd | T
Ident. | Identifikace uživatele systému | SPDOKUZI_bw01uziv | C(6)
Způsob | Způsob použití dokumentu (čtení, čtení a zápis). | Výpočet | C(13)

    Viz.také

    Kopírovat odkaz na dokument | Editace dokumentu | AKCE DOKUMENTU | Prezentace dokumentu | OZNAČOVÁNÍ | Uložit novou verzi dokumentu | Odeslat dokument | Adresář | Druhy dokumentů | Kategorie dokumentů | Obchodní selektor | Organizační selektor | Předlohy dokumentů | Technicko-věcný selektor | Určit soubor duplikátu dokumentu | Vybrat soubor dokumentu | Spojené dokumenty


Přehled o použití dokumentů

Popis

Jako první se uživateli zobrazí záložka „výběr“, kde má možnost si vyfiltrovat informace, které chce vidět. Tato činnost poskytuje uživateli přehled o práci s jednotlivými dokumenty a zároveň slouží jako možnost ohlídání, zda některý z uživatelů nenahlédl omylem do citlivého dokumentu (při chybném nastavení přístupových práv k druhům dokumentů).

Uživatel u každého dokumentu může sledovat následující atributy:

¨ datum použití od - do

¨ za uživatele

¨ za způsob použití dokumentu (tzn. čtení, zápis)

¨ za název dokumentu

¨ za jeho druh, předlohu apod.

¨ zda je dokument uložen externě či je součástí databáze

¨ zda se jedná o dokument, který má příznak chráněný

¨ zda je nastaveno automatické ukládání revizí dokumentu

¨ poznámka k dokumentu

¨ jméno uživatele, kdo dokument založil

Pomocí tlačítka „editace dokumentu“ nebo klávesou F6 (případně volbou činnosti z menu Volby) je možno dokument aktivovat. Na záložce „verze dokumentu“ je možno sledovat jednotlivé revize dokumentu (tzn. kdo ho kdy četl, zapisoval apod.)

Datový model

  • SPDOKUZI Práce s dokumentem
    • BWUZIVAT Uživatel systému (alias BWUZIVA1)
    • SPDOKOBS Dokument
      • SPPRISTU Přístupové právo uživatele k věci
      • SPDOKTYP Druh dokumentu
      • SPPREDLO Typ předlohy dokumentu
      • BWUZIVAT Uživatel systému

    • Formulář

    Formulář činnosti - Uložit novou verzi dokumentu
Mřížka [Dokumenty]
Listovací rámeček
Stránka #1 Použití dokumentů
Použití | Datum a čas použití dokumentu od.
do | Datum a čas použití dokumentu do.
Uživatel | Jméno uživatele systému
Způsob | Způsob použití dokumentu (čtení, čtení a zápis).
Dokument | Název dokumentu
Druh | Identifikátor druhu dokumentu
 | Název druhu dokumentu
Předloha | Identifikátor předlohy.
 | Text výstižně popisující předlohu.
Klíč | Klíč pro další možné vyhledávání dokumentů a určení výstupního souboru XML dokumentů
Externí uložení | Dokument je uložen externě (soubor na disku, na internetu, ...)
Chráněný dokument | Chráněný dokument může opravovat pouze jeho autor
Automatické ukládání verzí | Automatické ukládání verzí dokumentu
Soubor | Název souboru, ve kterém je dokument uložen
Založil | Jméno uživatele systému
 | Datum a čas založení dokumentu
Poznámka | Komentář k dokumentu
Stránka #2 Verze dokumentu
Mřížka [Revize dokumentu]
Zapsal | Jméno uživatele systému
Datum | Datum založení verze dokumentu
Poznámka | Poznámka
Stránka #3 Výběr
Použití | Datum a čas použití dokumentu od.
do | Do data a času použití dokumentu od.
Uživatel | Identifikace uživatele systému
Způsob | Způsob použití dokumentu (čtení, čtení a zápis).
Dokument | Název dokumentu
Klíč | Klíč pro další možné vyhledávání dokumentů a určení výstupního souboru XML dokumentů
Datum od | Datum a čas založení dokumentu
do | Datum a čas založení dokumentu
Obsah poznámky | Výběr podle obsahu poznámky
Druh | Identifikátor druhu dokumentu
Předloha | Identifikátor předlohy.
Zapsané | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Dokumenty] činnosti - Uložit novou verzi dokumentu

    Mřížka [Dokumenty] činnosti - Uložit novou verzi dokumentu
Datum a čas od | Datum a čas použití dokumentu od.
Uživatel | Jméno uživatele systému
Dokument | Název dokumentu
Způsob | Způsob použití dokumentu (čtení, čtení a zápis).
Datum a čas do | Datum a čas použití dokumentu do.
Datum | Datum a čas založení dokumentu
Uživatel | Jméno uživatele systému
Druh | Identifikátor druhu dokumentu
Název druhu dokumentu | Název druhu dokumentu
Předloha | Identifikátor předlohy.
Název předlohy dokumentu | Text výstižně popisující předlohu.
Klíč | Klíč pro další možné vyhledávání dokumentů a určení výstupního souboru XML dokumentů

    Mřížka [Revize dokumentu] činnosti - Uložit novou verzi dokumentu

    Mřížka [Revize dokumentu] činnosti - Uložit novou verzi dokumentu
Datum | Datum založení verze dokumentu
Zapsal | Jméno uživatele systému

    Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Editace dokumentu | Editace dokumentu v externích aplikacích
F9 | Prezentace dokumentu | Prezentace dokumentu
- | Odeslat dokument |
- | Uložit novou verzi dokumentu | Uložit novou verzi dokumentu
F2 | Druhy dokumentů | Přehled druhů dokumentů
F2 | Předlohy dokumentů | Definice předloh dokumentů

    Atributy tisku

    Základní údaje
Datum a čas od | Datum a čas použití dokumentu od. | SPDOKUZI_sp03datum | T
Datum a čas do | Datum a čas použití dokumentu do. | SPDOKUZI_sp03datumd | T
Způsob | Způsob použití dokumentu (čtení, čtení a zápis). | Výpočet | C(13)
Uživatel | Jméno uživatele systému | BWUZIVA1_bw01jmeno | C(30)
Datum | Datum a čas založení dokumentu | SPDOKOBS_sp26datum | T
Dokument | Název dokumentu | SPDOKOBS_sp26nazev | C(40)
Klíč | Klíč pro další možné vyhledávání dokumentů a určení výstupního souboru XML dokumentů | SPDOKOBS_sp26index | C(40)
Chráněný dokument | Chráněný dokument může opravovat pouze jeho autor | Výpočet | C(3)
Automatické ukládání verzí | Automatické ukládání verzí dokumentu | Výpočet | C(3)
Externí uložení | Dokument je uložen externě (soubor na disku, na internetu, ...) | Výpočet | C(3)
Soubor | Název souboru, ve kterém je dokument uložen | SPDOKOBS_sp26soubor | M
Poznámka | Komentář k dokumentu | SPDOKOBS_sp26koment | M
Druh | Identifikátor druhu dokumentu | SPDOKOBS_sp57id | C(6)
Název druhu dokumentu | Název druhu dokumentu | SPDOKTYP_sp57typdok | C(40)
Předloha | Identifikátor předlohy. | SPDOKOBS_sp01id | C(6)
Název předlohy dokumentu | Text výstižně popisující předlohu. | SPPREDLO_sp01predlo | C(30)

    Viz.také

    Editace dokumentu | Prezentace dokumentu | Odeslat dokument | Uložit novou verzi dokumentu | Druhy dokumentů | Předlohy dokumentů


Druhy dokumentů

Popis

Po aktivaci této činnosti se uživateli zobrazí přehled dosud nadefinovaných druhů dokumentů. Uživatel má k dispozici rovněž výběrovou záložku, která se ale neaktivuje jako první. Výběrová záložka a na ní nadefinovaný výběr ovšem funguje pouze v případě přihlášení jako běžný uživatel, při přihlášení uživatele SPRÁVCE systém nebude na tento výběr reflektovat.

Uživatel může založit nový druh dokumentu, případně opravovat nebo rušit stávající druh. U každého druhu dokumentu se eviduje:

¨ druh – identifikace a název druhu dokumentu (ke každému druhu dokumentu lze nadefinovat přístupová práva, což se následně využívá při práci v činnosti „dokumenty“ – uživatel nemůže založit dokument s druhem, ke kterému nemá přístupové právo)

¨ příznak aktuální

¨ poznámka

Datový model

  • SPDOKTYP Druh dokumentu
    • BWUZIVAT Uživatel systému
    • SPPRISTU Přístupové právo uživatele k věci

    • Vyvolávané činnosti

    K. | Činnost | Popis
^B | Práva přístupu k typům dokumentů | Definování práv přístupu k typům dokumentů

    Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Druhy dokumentů]
Druh | Identifikátor druhu dokumentu
 | Název druhu dokumentu
Založil | Jméno uživatele systému
 | Datum a čas založení druhu dokumentu
Poznámka | Komentář k druhu dokumentu
Aktuální | Příznak aktuálnosti druhu dokumentu

    Mřížka [Druhy dokumentů] činnosti - Přístupová práva

    Mřížka [Druhy dokumentů] činnosti - Přístupová práva
Druh | Identifikátor druhu dokumentu
Název druhu dokumentu | Název druhu dokumentu
Datum | Datum a čas založení druhu dokumentu

    Atributy tisku

    Základní údaje
Druh | Identifikátor druhu dokumentu | SPDOKTYP_sp57id | C(6)
Název druhu dokumentu | Název druhu dokumentu | SPDOKTYP_sp57typdok | C(40)
Ident. | Identifikace uživatele systému | SPDOKTYP_bw01uziv | C(6)
Uživatel | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Uživatel (úplné jméno) | Úplné jméno uživatele systému | BWUZIVAT_bw01jmenot | C(25)

    Viz.také

    Přístupová práva


Kategorie dokumentů

Popis

Tato činnost poskytuje uživateli přehled vytvořených kategorií dokumentů. Každý dokument BM je možno zařadit do různých kategorií. V této činnosti lze kategorie vytvářet, editovat či rušit. Zařazení dokumentu do kategorie se provádí ve formuláři činnosti „Dokumenty“ na záložce „Kategorie dokumentů“ nebo ve formuláři činnosti „Vlastnosti dokumentu“ na záložce „Kategorie“ (vlastnosti dokumentu se vyvolají stiskem pravého tlačítka myši v okně spojených dokumentů).

U každé kategorie se definuje:

¨ identifikace a název kategorie

¨ složka – překryvný seznam s volbou Ano/Ne – při volbě Ano bude dokument zařazený do této kategorie k dispozici ve formuláři činnosti „Spojené dokumenty“ (Ctrl D) ve složce odpovídající názvu kategorie

¨ rozbalená – překryvný seznam s volbou Ano/Ne – při nastavení složka „Ano“ bude složka ve formuláři činnosti Spojené dokumenty rozbalená

¨ předchůdce – identifikátor kategorie, možný výběr z číselníku. Při nastavení složka „Ano“ a vyplněné identifikaci předchůdce je tímto určena tzv. nadsložka dané složky ve stromu ve formuláři činnosti „Spojené dokumenty (Ctrl D).

¨ poznámka

Spojené dokumenty (Ctrl D) x kategorie dokumentů

Dokumenty, které mají ve své definici nastaveno Složka – „Ano“, jsou pak ve formuláři činnosti Spojené dokumenty řazeny stromově podle jednotlivých kategorií. Je-li dokument zařazen do takové kategorie (složka – Ano), potom se ve stromu vytvoří adresářová struktura vyplývající ze vztahu kategorií (viz. atribut „předchůdce“), tzn. že ve stromu Spojené dokumenty bude viditelný název předchůdce a pod ním budou seřazeny všechny dokumenty kategorie, které ho mají ve své definici uvedeného.

Při zakládání nového dokumentu po pravém kliku na položce stromu, která odpovídá kategorii dokumentu, je u tohoto nově zakládaného dokumentu ve formuláři „vlastnosti dokumentu“ na záložce „kategorie“ předplněno zařazení do odpovídající kategorie. Při kopírování dokumentu se zařazení do kategorie nedědí.

Ve stromu se kromě dokumentů, které jsou přímo spojeny s objektem BM, zobrazují jako jejich poduzly také dokumenty, které jsou objektovou vazbou spojeny s dokumentem (následníci). Z podmenu NAVAZUJÍCÍ DOKUMENTY obsaženého v menu vyvolaném po pravém kliku na dokumentu je možno připojovat jeho nové následníky (Nový dokument, Načíst dokument). Takto vytvořený dokument je pak přímo zařazen ve stromu pod vlastní název dokumentu.

Příklad: K dokumentu charakteru smlouva je vhodné připojit dokumenty s jejími dodatky (dodatky jako navazující dokumenty).

Datový model

  • SPDKAT Kategorie dokumentu

    • Formulář

    Formulář činnosti - Kategorie dokumentů
Mřížka [Kategorie dokumentů]
Kategorie | Identifikace kategorie dokumentu
Název kategorie | Název kategorie dokumentu
Složka | Složka Ano/Ne - kategorie bude vystupovat ve formuláři Spojené dokumenty jako složka
Rozbalená | Rozbalená složka
Předchůdce | Identifikace kategorie dokumentu
Název kategorie | Název kategorie dokumentu
Poznámka | Poznámka

    Mřížka [Kategorie dokumentů] činnosti - Kategorie dokumentů

    Mřížka [Kategorie dokumentů] činnosti - Kategorie dokumentů
Kategorie | Identifikace kategorie dokumentu
Název kategorie | Název kategorie dokumentu
Složka | Složka Ano/Ne - kategorie bude vystupovat ve formuláři Spojené dokumenty jako složka

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Kategorie dokumentů | Kategorie dokumentů

    Atributy tisku

    Základní údaje
Kategorie | Identifikace kategorie dokumentu | SPDKAT_spf4id | C(6)
Název kategorie | Název kategorie dokumentu | SPDKAT_spf4nazkat | C(40)
Poznámka | Poznámka | SPDKAT_spf4koment | M
Složka | Složka Ano/Ne - kategorie bude vystupovat ve formuláři Spojené dokumenty jako složka | Výpočet | C(3)
Rozbalená | Rozbalená složka | Výpočet | C(3)
Předchůdce | Identifikace kategorie dokumentu | SPDKAT_spf4idp | C(6)
Název kategorie | Název kategorie dokumentu | SPDKAT2_spf4nazkat | C(40)


Předlohy dokumentů

Popis

Tato činnost umožňuje uživateli nadefinovat jednotlivé předlohy dokumentů, které pak bude využívat při vlastní práci s dokumenty. Na záložce „předlohy dokumentu“ jsou k dispozici následující údaje:

¨ předloha - identifikace a název předlohy

¨ druh dokumentu – identifikace druhu předlohy. K druhu předlohy je možno nadefinovat přístupová práva a tím je vlastně nadefinováno i přístupové právo k předloze, která má u sebe uveden daný druh předlohy. Přístupové právo může nabývat hodnot čtení a zápis. V činnosti „dokumenty“ nebo při vytváření dokumentu po stisku Ctrl D na událostech se pak práva k předlohám uplatňují takto:

- uživatel může založit nový dokument s předlohou výstupu, ke které má přístupové právo čtení nebo zápis

- přístup k existujícím dokumentům je řízen právy spojenými s druhem daného dokumentu (tj. uživatel může číst nebo opravovat dokumenty vytvořené na základě předloh dokumentů, ke kterým nemá právo přístupu čtení ani zápis, ale má právo přístupu k druhu dokumentu uvedeným u dané předlohy)

¨ aplikace - identifikace a název spouštěného programu (např. Word, Excel ...)

¨ blokování - příznak blokování dokumentu předlohy proti opravě. Ostatní uživatelé mohou na základě této předlohy vytvářet dokumenty, ale nesmí opravovat tuto vytvořenou předlohu.

¨ prázdná předloha - příznak nevytvoření implicitní předlohy a současně i blokování proti opravě. Tzn., že i když je zde nějaká předloha nadefinovaná, při zatržení tohoto příznaku se bude vždy spouštět prázdná předloha.

¨ mailmerge - příznak vytváření mailmerge. Jedná se o funkci, pomocí které je možno vytvořit řadu podobných dokumentů (např. dopisy), lišících se pouze v několika výrazech (adresa, oslovení ...). Potom stačí mít dva dokumenty, hlavní dokument se standardním (neměnným) textem a datový soubor obsahující údaje, které se budou měnit (databáze adres). Po vyvolání předlohy s příznakem mailmerge v aplikaci Word je pak postup následující - uživatel použije činnost Wordu "hromadná korespondence" a potvrdí příkazy "sloučit" (2x). Potom může mít několik dopisů s naprosto shodným textem, ale rozdílnou adresou příjemce. Mailmerge dokumentu BM připojeného k operaci pošty obsahuje také atribut 'ČJ krátké', jehož hodnotou je text odpovídající identifikaci procesu (9999-99-99999999).

¨ cesta pro soubor mailmerge, soubor mailmerge, přípona souboru mailmerge - vlastní definice mailmerge. Pokud nejsou tyto parametry u jednotlivých předloh nadefinovány, nahlásí systém chybu a nedovolí danou předlohu zapsat (typicky bývá jako soubor mailmerge uvedeno BMSERVIS s příponou TXT).

¨ aktuální - zda je daná předloha aktuální (tzn. používaná) nebo je zde pouze z historických důvodů

¨ komentář - komentář, který detailně popisuje význam předlohy

¨ založil - jméno uživatele, který předlohu vytvořil + datum a čas vytvoření dané předlohy

Stiskem tlačítka „editace dokumentu“ nebo klávesou F6 (případně aktivací činnosti z menu Volby) se spustí daná předloha dokumentu.

Na záložce „Další“ je možno definovat:

¨ Skript – text v jazyce Foxpro spouštěný bezprostředně po otevření dokumentu, resp. předlohy dokumentu externím programem (tzn. je-li předloha dokumentu vytvořena na základě aplikace Word, spustí se tento skript po aktivaci dokumentu vytvořeném na základě této předlohy v okamžiku spuštění aplikace Word). Příklady skriptu jsou popsány ve slovníku pojmů.

Kód skriptu v jazyce Foxpro je vyvolán s parametry:

- _this - objekt - řídící objekt BM, který otevírá dokument

- _sp26 - jednoznačná časová identifikace dokumentu BM resp. předlohy dokumentu

- _predloha - logická hodnota nabývající hodnotu .T. (TRUE), pokud je opravována předloha dokumentu

- _workfile - název pracovního souboru, ve kterém je opravován dokument resp. předloha dokumentu

- _poprve - logická hodnota nabývající hodnotu .T. (TRUE) při první opravě dokumentu

¨ definice pro konvertor Winword - text

Konvertor WINWORD je interní objekt BM, který je používán také při výstupu předlohou typu Word. Pro definici konverze může skript použít 'Definici pro konvertor WINWORD' uvedenou v předloze dokumentu. Ve formuláři 'Předlohy dokumentu' je možné spustit volbu z menu Volby - Editovat definici pro konvertor WINWORD (nebo funkční klávesa F7), kterou je vyvolán formulář pro vstup definice konverze stejný jako při definování předlohy výstupu typu Word.

Kromě použití konvertoru WINWORD je možné použít skript např. pro:

- načtení dat mailmerge po otevření dokumentu (prvním založení nebo každém otevření) - Word 2003 toto sám automaticky neprovádí

- vytvoření vlastního specifického mailmerge (mailmerge může být tímto způsobem použit bez nutnosti propojení s operací pošty)

Na záložce „Užití dokumentu“ jsou k dispozici údaje, který uživatel danou předlohu kdy užil a za jakým účelem (čtení, zápis apod.).

Datový model

  • SPPREDLO Typ předlohy dokumentu
    • SPPROGRA Volání programu
    • BWUZIVAT Uživatel systému (alias BWUZIVA1)
    • SPDOKTYP Druh dokumentu
      • SPPRISTU Přístupové právo uživatele k věci

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Editace dokumentu | Editace dokumentu v externích aplikacích
F7 | Editovat definici pro konvertor WINWORD | Spuštění editoru pro konvertor WINWORD
^R | Načtení dokumentu | Spojení záznamu s dokumentem v souboru na disku
- | Kontrolní kompilace | Kontrolní kompilace
- | Editovat kód vlastnosti | Editovat kód vlastnosti
- | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností
F2 | Druhy dokumentů | Přehled druhů dokumentů
F2 | Spouštěné aplikace | Definice spouštěných aplikací (pro předlohy dokumentů)

    Formulář

     | Formulář činnosti - Editovat definici pro konvertor WINWORD
 | Mřížka [Předlohy dokumentů]
 | Předloha | Identifikátor předlohy.
 |  | Text výstižně popisující předlohu.
 | Druh | Identifikátor druhu dokumentu
 | Název druhu dokumentu | Název druhu dokumentu
 | Aplikace | Identifikace spouštěného programu.
 |  | Název spouštěné aplikace
Přípona pracovního souboru.
 | Listovací rámeček
 | Stránka #1 Předlohy dokumentu
 | Blokování | Příznak blokování dokumentu předlohy proti opravě.
 | Prázdná předloha | Příznak nevytvoření imlicitní předlohy a současně i blokování proti opravě.
 | Mailmerge | Příznak vytvoření dat pro hromadnou korespondenci.
 | Cesta pro soubor MailMerge | Cesta (PATH) pro uložení souboru pro hromadnou korespondenci (MailMerge).
 | Soubor MailMerge | Jméno souboru hromadné korespondece (MailMerge).
 |  | Přípona souboru pro mailmerge
 | Komentář | Komentář, který detailně popisuje význam předlohy.
 | Aktuální | Příznak aktuálnosti předlohy
 | Založil | Jméno uživatele systému
 |  | Datum a čas zápisu záznamu události
 | Stránka #2 Další
 | Script | Skript v jazyce Foxpro vyvolaný po otevření dokumentu (parametry_this,_sp26,_predloha,_poprve)
 | Definice pro konvertor WINWORD | Definice pro konvertor WINWORD
 | Stránka #3 Užití dokumentu
 | Mřížka [Užití dokumentu]

    Mřížka [Předlohy dokumentů] činnosti - Editovat definici pro konvertor WINWORD

    Mřížka [Předlohy dokumentů] činnosti - Editovat definici pro konvertor WINWORD
Ident | Identifikátor předlohy.
Název předlohy dokumentu | Text výstižně popisující předlohu.
Aplikace | Identifikace spouštěného programu.
Název aplikace | Název spouštěné aplikace
Komentář | Komentář, který detailně popisuje význam předlohy.
Blokování | Příznak blokování dokumentu předlohy proti opravě.
Prázdná předloha | Příznak nevytvoření imlicitní předlohy a současně i blokování proti opravě.
Mailmerge | Příznak vytvářet mailmerge.

    Mřížka [Užití dokumentu] činnosti - Editovat definici pro konvertor WINWORD

    Mřížka [Užití dokumentu] činnosti - Editovat definici pro konvertor WINWORD
Datum a čas od | Datum a čas použití dokumentu od.
Pracovník | Jméno uživatele systému
Způsob | Způsob použití dokumentu (čtení, čtení a zápis).
Datum a čas do | Datum a čas použití dokumentu do.

    Atributy tisku

    Základní údaje
Předloha | Identifikátor předlohy. | SPPREDLO_sp01id | C(6)
Název předlohy dokumentu | Text výstižně popisující předlohu. | SPPREDLO_sp01predlo | C(30)
Komentář | Komentář, který detailně popisuje význam předlohy. | SPPREDLO_sp01koment | M
Blokování | Příznak blokování dokumentu předlohy proti opravě. | Výpočet | C(3)
Prázdná předloha | Příznak nevytvoření imlicitní předlohy a současně i blokování proti opravě. | Výpočet | C(3)
Mailmerge | Příznak vytvářet mailmerge. | Výpočet | C(3)
Aplikace | Identifikace spouštěného programu. | SPPREDLO_sp02id | C(5)
Script | Skript v jazyce Foxpro vyvolaný po otevření dokumentu (parametry_this,_sp26,_predloha,_poprve) | SPPREDLO_sp01script | M
Definice pro konvertor WINWORD | Definice pro konvertor WINWORD | SPPREDLO_sp01lbx2 | M
Název aplikace | Název spouštěné aplikace | SPPROGRA_sp02nazev | C(25)
Operační systém | Program Windows / program Dos | Výpočet | C(7)
Aplikace | Aplikace DDE | SPPROGRA_sp02ddeapl | C(30)
Zpráva DDE | Zpráva DDE | SPPROGRA_sp02ddemes | C(30)
Položka | Položka DDE | SPPROGRA_sp02ddepol | C(30)
Název druhu dokumentu | Název druhu dokumentu | SPDOKTYP_sp57typdok | C(40)
Druh | Identifikátor druhu dokumentu | SPPREDLO_sp57id | C(6)
Pracoval s dokumentem | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Uživatel (úplné jméno) | Úplné jméno uživatele systému | BWUZIVAT_bw01jmenot | C(25)

    Při pohybu v Práce s dokumentem
Datum a čas od | Datum a čas použití dokumentu od. | SPDOKUZI_sp03datum | T
Čas od | Čas použití dokumentu od. | SPDOKUZI_sp03casod | C(8)
Čas do | Čas použití dokumentu do. | SPDOKUZI_sp03casdo | C(8)
Způsob | Způsob použití dokumentu (čtení, čtení a zápis). | SPDOKUZI_sp03zpusob | N(1)
Způsob použití | Způsob použití dokumentu (čtení, čtení a zápis). | Výpočet | C(13)

    Viz.také

    Editace dokumentu | Editovat definici pro konvertor WINWORD | Načtení dokumentu | Kontrolní kompilace | Editovat kód vlastnosti | Knihovny vkládaného kódu | Druhy dokumentů | Spouštěné aplikace


Spouštěné aplikace

Popis

Tato činnost umožňuje definovat způsob vyvolávání externích programů (aplikací), které se pak používají při definování předloh dokumentů. V následujícím textu si vysvětlíme jednotlivé zadávané položky společně s konkrétním příkladem. Pro názornost budeme u každé položky v závorce uvádět hodnotu, jako kdybychom vytvářeli např. aplikaci Wordu:

¨ aplikace - identifikace spouštěného programu (WORD)

¨ název - název spouštěného programu (WORD)

¨ zabudované OLE - způsob volání pro aplikace Word/Excel (Word 7.0)

¨ typ spuštění a přípona - způsob volání + přípona zvolené aplikace (zabudované OLE + DOC). Příponu souboru lze nadefinovat až na 15 znaků, např. DOCX, XLSX, ISDOCX apod. Mimo jiné je tím uživateli umožněno vložit tažením myši do IS BM i dokumenty, které mají příponu delší než 3 znaky (DOC, XLS apod.). Jednotlivé způsoby volání jsou - Windows DDE, DOS, Windows OLE, zabudované OLE, Windows CALL, Windows podle přípony . Následující popis nám přiblíží vyplnění jednotlivých položek při různých způsobech volání:

______________________________________________________________

Pouze pro aplikace Windows volané způsobem zabudované OLE a Windows podle přípony:

¨ další údaje se uvádět nemusí, pro aplikace Windows volané způsobem "zabudované OLE" je naprosto dostačující určit způsob volání a příponu.

Pouze pro aplikace Windows volané způsobem DDE:

¨ zpráva DDE - zpráva DDE

¨ aplikace - aplikace DDE

¨ položka - položka DDE. Potřebné údaje pro tyto tři položky uživatel získá při použití Registračního souboru pro aplikace Windows (RegEdit), který je standardní součástí Windows.

Pouze pro aplikace Windows volané způsobem OLE:

¨ třída OLE - umožňuje definovat u dokumentu jinou než implicitní třídu OLE, která je uvedena v Asociaci daného typu souboru. Je uvedena v RegEdit.

Pouze pro aplikace DOS a aplikace Windows volané způsobem CALL:

¨ volání - volání programu - příkazový řádek. Pro spouštění aplikací pro DOS pod Windows je nejlépe vytvořit si pro každou aplikaci PIF soubor (viz dokumentace Windows) a jméno PIF souboru uvést do této položky. Druhým možným řešením je uvést přímo cestu k aplikaci.

Pouze pro aplikace Windows volané způsobem CALL:

¨ dle WIN.INI - volání programu dle definice aplikace v souboru WIN.INI v sekci EMBEDDING (použije se v případě nemožnosti spuštění aplikace dle zadání v atributu Volání)

______________________________________________________________

¨ parametry volání - způsob otevření aplikace a jejím umístění do okna:

- aktivní a normální velikost

- aktivní a minimalizovat

- aktivní a maximalizovat

- neaktivní a normální velikost

- neaktivní a minimalizován

¨ info o otevření – tento atribut určuje chování BM po otevření dokumentu. Může nabývat hodnot:

- Ano s potvrzením – po otevření dokumentu bude zároveň otevíráno okno, které uživatel pak musí uzavřít (klávesou ESC, tlačítkem OK nebo ikonou uzavření okna)

- Ano bez potvrzení - po otevření dokumentu bude zároveň otevíráno okno, které uživatel pak musí uzavřít (klávesou ESC, tlačítkem OK nebo ikonou uzavření okna) – v případě, že uživatel okno neuzavře, automaticky se po 5 vteřinách zavře samo

- Ne – po otevření dokumentu nebude zobrazeno žádné okno

Tento atribut je implicitně nastaven na hodnotu „Ano s potvrzením“. Tuto hodnotu je nutno ponechat pro aplikace, které neblokují jimi otevřené soubory. V jejich případě platí, že kdyby systém BM po otevření dokumentu zároveň nezastavil, tak potom by se BM soubor dokumentu bezprostředně zrušil a aplikace by nemohla prezentovat daný dokument. Těmito aplikacemi mohou být programy např. pro zobrazení obrázků, internet explorer (soubory s příponami HTM, XML, ...).

¨ prázdný - pokud soubor ještě neexistuje, vytvoří prázdný soubor

¨ čekej na ukončení - po předání dokumentu je zobrazeno hlášení, po jehož odklepnutí je dokument uložen. Slouží pro práci s dokumenty aplikací, které nedokáží systému sdělit, že s daným dokumentem pracují a systém tedy nemůže zjistit, kdy byl daný dokument uvolněn pro uložení (např. CorelDraw).

Do specifické skupiny dokumentů patří ty, které mají u své aplikace definovány akce (záložka Akce), tj. celý život dokumentu je řízen dle přidělených akcí, které mohou dokument automaticky zakládat, aktualizovat, poskytovat vybraným uživatelům apod. O výsledku akcí je veden a archivován protokol (záložka Protokol v činnosti Dokumenty). Mezi takového dokumenty patří i ty, kterými IS Bílý Motýl® komunikuje se státní správou (Evidenční list důchodového pojištění, Přihláška (odhláška) k nemocenskému pojištění, …), kde akce zajišťují vytvoření těchto dokumentů z dat při udržení integrity s předchozími dokumenty i s novými daty, dále akce zajišťují kompletní výměnu informací s IS státní správy včetně opravných chodů a samozřejmě jsou i tyto dokumenty trvale k dispozici kompetentním uživatelům.

Datový model

  • SPPROGRA Volání programu

    • Formulář

    Formulář činnosti - Kontrolní kompilace
Mřížka [Spouštěné aplikace]
Aplikace | Identifikace spouštěného programu.
Název | Název spouštěné aplikace
Listovací rámeček
Stránka #1 Spouštěné aplikace
Typ spuštění | Aplikace Windows DDE / Dos / Windows OLE / Zabudované OLE / Windows CALL
Přípona | Přípona pracovního souboru.
Zabudované OLE | Zabudované OLE
Zpráva DDE | Zpráva DDE
Aplikace | Aplikace DDE
Položka | Položka DDE
Třída OLE | Třída OLE
Volání | Volání programu - příkazový řádek.
dle WIN.INI | Volání programu - příkazový řádek.z WIN.INI
Parametry volání | Parametry volání aplikace
Info o otevření | Zobrazit informaci o otevření dokumentu
Prázdný | Vytvářet prázdný soubor při prvém použití.
Čekej na ukončení | Příznak čekání na ukončení práce aplikace
Stránka #2 Akce
Mřížka [Akce]
Akce | Interní identifikace akce
Název akce | Název akce
Pořadí | Pořadí zobrazení akce
Stav.řádek | Poznámka o akci v menu
Charakter | Charakter akce
Aktualizace | Datum aktualizace
Kategorie | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
Název kategorie | Název kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
Druh | Identifikace druhu implemetačního rozšíření
Název druhu | Název druhu implemetačního rozšíření
Kód | Kód akce
Kód podm. | Kód podmínky akce
Poznámka | Poznámka

    Mřížka [Spouštěné aplikace] činnosti - Kontrolní kompilace

    Mřížka [Spouštěné aplikace] činnosti - Kontrolní kompilace
Ident | Identifikace spouštěného programu.
Název aplikace | Název spouštěné aplikace
Operační systém | Aplikace Windows DDE / Dos / Windows OLE / Zabudované OLE / Windows CALL
Zpráva DDE | Zpráva DDE
Aplikace | Aplikace DDE
Položka | Položka DDE
Volání | Volání programu - příkazový řádek.
Prázdný | Vytvářet prázdný soubor při prvém použití.
Přípona | Přípona pracovního souboru.
Údržba | Program spouštěný při údržbě předlohy.

    Mřížka [Akce] činnosti - Kontrolní kompilace

    Mřížka [Akce] činnosti - Kontrolní kompilace
Pořadí | Pořadí zobrazení akce
Akce | Interní identifikace akce
Název akce | Název akce

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Editovat kód vlastnosti | Editovat kód vlastnosti
F6 | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností
- | Kontrolní kompilace | Kontrolní kompilace
F2 | Druhy implementačních rozšíření | Druhy implementačních rozšíření
F2 | Kategorie doplňující vlastnosti/knihovny | Kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu

    Atributy tisku

    Základní údaje
Aplikace | Identifikace spouštěného programu. | SPPROGRA.sp02id | C(5)
Název | Název spouštěné aplikace | SPPROGRA.sp02nazev | C(25)
Operační systém | Program Windows / program Dos | Výpočet | C(7)
Aplikace | Aplikace DDE | SPPROGRA.sp02ddeapl | C(30)
Zpráva DDE | Zpráva DDE | SPPROGRA.sp02ddemes | C(30)
Položka | Položka DDE | SPPROGRA.sp02ddepol | C(30)
Přípona | Přípona pracovního souboru. | SPPROGRA.sp02pripon | C(3)

    Viz.také

    Editovat kód vlastnosti | Knihovny vkládaného kódu | Kontrolní kompilace | Druhy implementačních rozšíření | Kategorie doplňující vlastnosti/knihovny


KONFIGURACE XML DOKUMENTŮ

Popis

Mezi další funkce ISBM týkající se dokumentů patří možnost definovat schémata XML dokumentů včetně předloh XSLT pro definici formy výstupu. Tímto je umožněno v IS BM tvořit a spravovat poměrně rozsáhlé dokumentace, na nichž pracuje i několik autorů, s velkým množstvím vnitřních i vnějších vazeb při udržení trvalé integrity dokumentu. Tyto XML dokumenty lze následně pohodlně prohlížet internetovým browserem a to i v rámci informačních panelů IS Bílý Motýl®, kdy z těchto dokumentů lze přímo aktivovat i funkce IS Bílý Motýl®.

Viz.také

Schémata XML dokumentů | XSLT předlohy | Skupiny XSLT předloh


Schémata XML dokumentů

Popis

Mezi další funkce ISBM týkající se dokumentů patří možnost definovat schémata XML dokumentů včetně předloh XSLT pro definici formy výstupu. Tímto je umožněno v IS BM tvořit a spravovat poměrně rozsáhlé dokumentace, na nichž pracuje i několik autorů, s velkým množstvím vnitřních i vnějších vazeb při udržení trvalé integrity dokumentu. Tyto XML dokumenty lze následně pohodlně prohlížet internetovým browserem a to i v rámci informačních panelů IS Bílý Motýl®, kdy z těchto dokumentů lze přímo aktivovat i funkce IS Bílý Motýl®.

Na záložce „seznam TAG“ se definuje:

¨ Tag – identifikace TAG v XML dokumentu

¨ popis – popis tagu dokumentu

¨ druh – identifikace a název druhu dokumentu (výběr z číselníku – řízen přístupovými právy)

¨ ikona – identifikace a název ikony

¨ uzel – je TAG uzlem dokumentu? (Ano/Ne)

¨ vrchol – jedná se o vrcholový uzel dokumentu? (Ano/Ne)

¨ externí s. – externí soubor (Ano/Ne)

¨ typ hodnoty – typ hodnoty, délka údaje a počet desetin údaje

¨ volný text – uzel s volným textem? (Ano/Ne)

¨ třída – třída ovládacího prvku

¨ zobrazení – text pro zaškrtávací políčko nebo seznam hodnot překryvného seznamu oddělený čárkou

¨ stavový ř. – stavový řádek hodnoty

¨ DN – výraz dynamického návěští

¨ DN – děd. – výraz dynamického návěští - děděný

¨ poznámka – libovolná poznámka

Na záložce „vazby“ se definují vazby k jednotlivým TAG v seznamu:

¨ tag – identifikace TAG v XML dokumentu

¨ popis – popis tagu dokumentu

¨ tag – identifikace navazujícího tagu + alias tag při použití pod nadřízeným tagem (není-li uveden, použije se identifikace z vlastní definice tagu)

¨ popis – popis tagu dokumentu

¨ poř. – pořadí zobrazeného popisného údaje

¨ kardinalita – vyjadřuje závislost mezi entitami (0:1, 1:1, 0:N, 1:N)

¨ Z.vždy – zobrazovat vždy (tj. také u podřízených uzlů)

¨ Z.násl. – zobrazovat je-li následníkem

¨ přizp. – přizpůsobovat oknu (Ne, Horizontálně, Vertikálně, Obojí)

¨ odkaz – příznak uzlu odkazujícího na uzel jiného dokumentu

¨ návěští – popis tagu dokumentu

¨ šířka – umístění WIDTH

¨ stavový ř. – stavový řádek hodnoty

¨ init – inicializační hodnota atributu

¨ druh – identifikace a název dokumentu

¨ ikona – identifikace a název ikony

¨ DN – výraz dynamického návěští

¨ třídící klíč – třídící klíč

V případě potřeby může uživatel ke každému seznamu TAG nadefinovat ještě doplňující vlastnosti formuláře:

¨ identifikace doplňující vlastnosti

¨ alias volání doplňující vlastnosti

¨ pořadí zobrazení v menu

¨ název volání doplňující vlastnosti

¨ parametry doplňující vlastnosti

¨ poznámka

Datový model

  • SPXMLTAG Tag XML dokumentu
    • BWIKONA Ikona v BM
    • SPDOKTYP Druh dokumentu
      • SPPRISTU Přístupové právo uživatele k věci

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | XSLT předlohy | XSLT předlohy
F6 | Design formuláře XML | Design formuláře XML
F9 | Strom schématu XML dokumentu | Strom schématu XML dokumentu
F2 | Doplňující vlastnosti formuláře | Doplňující vlastnosti formuláře
F2 | Druhy dokumentů | Přehled druhů dokumentů
F2 | Schémata XML dokumentů | Schémata interních XML dokumentů
F2 | Seznam ikon | Seznam ikon používaných v BM

    Formulář

    Formulář činnosti - Doplňující vlastnosti formuláře
Mřížka [Seznam TAG]
Tag | Identifikace TAG v XML dokumentu
Popis | Popis tagu dokumentu
Listovací rámeček
Stránka #1 Seznam TAG
Druh | Identifikátor druhu dokumentu
Název druhu dokumentu | Název druhu dokumentu
Ikona | Identifikace ikony
Název ikony | Název ikony
Uzel | Je tag uzlem dokumentu ?
Vrchol | Vrcholový uzel dokumentu ?
Volný text | Uzel s volným textem
Externí s. | Externí soubor
Typ hodnoty | Typ hodnoty
Délka | Délka údaje
Desetiny | Počet desetin údaje
Třída | Třída ovládacího prvku
Zobrazení | Text pro zaškrávací políčko nebo seznam hodnot pro překryvný seznam oddělených čárkou
Stavový ř. | Stavový řádek hodnoty
DN | Výraz dynamického návěští
DN - děd. | Výraz dynamického návěští - děděný
Aktualizace | Datum aktualizace
Poznámka | Poznámka
Stránka #2 Vazby
Mřížka [Vazby]
Tag | Identifikace navazujícího tagu
Alias | Alias tag při použití pod nadřízeným tagem (není-uveden použije se identifikace z vlastní definice tagu)
Popis | Popis tagu dokumentu
Poř. | Pořadí zobrazení popisného údaje
Kardinalita | Kardinalita
Z.vždy | Zobrazovat vždy (tj. také u podřízených uzlů)
Z.násl. | Zobrazovat je-li následníkem
Přizp.oknu | Přizpůsobovat oknu
Odkaz | Příznak uzlu odkazujícího na uzel jiného dokumentu
Návěští | Popis tagu dokumentu
Šířka | Umístění WIDTH
Stavový ř. | Stavový řádek hodnoty
Init | Inicializační hodnota atributu
Druh | Identifikátor druhu dokumentu
Název druhu dokumentu | Název druhu dokumentu
Ikona | Identifikace ikony
Název ikony | Název ikony
DN | Výraz dynamického návěští
Třídící klíč | Třídící klíč
Stránka #3 Doplňující vlastnosti formuláře
Mřížka [Doplňující vlastnosti formuláře]
Vlastnost | Identifikace doplňující vlastnosti činnosti
Alias | Alias volání doplňující vlastnosti formuláře
Pořadí | Pořadí zobrazení v menu
Název | Název doplňující vlastnosti činnosti
Název volání | Název volání doplňující vlastnosti
Parametry | Parametry volání doplňující vlastnosti formuláře
Poznámka | Poznámka
Stránka #4 Výběr
Tag | Identifikace TAG v XML dokumentu
Popis | Popis tagu dokumentu
Uzel | Je tag uzlem dokumentu ?
Vrchol | Vrcholový uzel dokumentu ?
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Seznam TAG] činnosti - Doplňující vlastnosti formuláře

    Mřížka [Seznam TAG] činnosti - Doplňující vlastnosti formuláře
Tag | Identifikace TAG v XML dokumentu
Popis | Popis tagu dokumentu
Stavový ř. | Stavový řádek hodnoty
Uzel | Je tag uzlem dokumentu ?
Vrchol | Vrcholový uzel dokumentu ?
Typ hodnoty | Typ hodnoty
Délka | Délka údaje
Desetiny | Počet desetin údaje

    Mřížka [Vazby] činnosti - Doplňující vlastnosti formuláře

    Mřížka [Vazby] činnosti - Doplňující vlastnosti formuláře
Poř. | Pořadí zobrazení popisného údaje
Tag | Identifikace navazujícího tagu
Alias | Alias tag při použití pod nadřízeným tagem (není-uveden použije se identifikace z vlastní definice tagu)
Popis | Popis tagu dokumentu
Návěští | Popis tagu dokumentu

    Mřížka [Doplňující vlastnosti formuláře] činnosti - Doplňující vlastnosti formuláře

    Mřížka [Doplňující vlastnosti formuláře] činnosti - Doplňující vlastnosti formuláře
Pořadí | Pořadí zobrazení v menu
Vlastnost | Identifikace doplňující vlastnosti činnosti
Alias | Alias volání doplňující vlastnosti formuláře
Název volání | Název volání doplňující vlastnosti
Název | Název doplňující vlastnosti činnosti

    Viz.také

    XSLT předlohy | Design formuláře XML | Strom schématu XML dokumentu | Doplňující vlastnosti formuláře | Druhy dokumentů | Seznam ikon | Editor XML


XSLT předlohy

Popis

Tato činnost slouží k definování předloh XSLT pro definici formy výstupu XML dokumentů. Na záložce „XSLT předlohy“ se definuje:

¨ tag – identifikace TAG v XML dokumentu + skupina XSLT předloh + název uzlu XSLT předloh

¨ vrchol – vrcholový uzel XSLT předlohy

¨ popis – popis tagu dokumentu

¨ náz.skup.XSLT – název skupiny XSLT předloh

¨ poznámka – libovolná poznámka

Na záložce „navazující XSLT předlohy“ se definuje:

¨ tag – identifikace navazujícího tagu + skupina XSLT navazujícího uzlu

¨ náz. XSLT uzlu – název

¨ popis – popis tagu

¨ náz.skup.XSLT – název skupiny

¨ alias – alias tag při použití pod nadřízeným tagem (není-li uveden, použije se identifikace z vlastní definice tagu)

¨ pořadí – pořadí zpracování navazujícího uzlu

¨ samostatný – vznikne samostatný dokument? (Ano/Ne)

¨ selektivní – selektivní zpracování? (Ano/Ne)

¨ viz. také – v dokumentu vznikne odkaz viz. také

¨ V.návěští – výraz vyhodnocení návěští uzlu

¨ třídit – výraz setřídění při zpracování

¨ vybrat – výraz podmínky zařazení pro zpracování

Datový model

  • SPXSLTAG Uzel XSLT předlohy
    • SPXMLTAG Tag XML dokumentu
    • SPXSLSKP Skupina XSLT předloh

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Editovat kód vlastnosti | Editovat kód vlastnosti
F6 | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností
- | Kontrolní kompilace | Kontrolní kompilace
- | Předplnit nav. XSLT předlohy | Předplnit navazující XSLT předlohy
F2 | Schémata XML dokumentů | Schémata interních XML dokumentů
F2 | Skupiny XSLT předloh | Skupiny XSLT předloh
F2 | XSLT předlohy | XSLT předlohy

    Formulář

    Formulář činnosti - Schémata XML dokumentů
Mřížka [XSLT předlohy]
Tag | Identifikace TAG v XML dokumentu
Skupina | Skupina XSLT předloh
Náz. XSLT uzlu | Název uzlu XSLT předloh
Listovací rámeček
Stránka #1 XSLT předlohy
Vrchol | Vrcholový uzel XSLT předlohy
Popis | Popis tagu dokumentu
Náz.skup. XSLT | Název skupiny XSLT předloh
Aktualizace | Datum aktualizace
Poznámka | Poznámka
Stránka #2 Navazující XSLT předlohy
Mřížka [Navazující XSLT předlohy]
Tag | Identifikace navazujícího tagu
Skupina | Skupina XSLT navazujícího uzlu XSLT
Náz. XSLT uzlu | Název uzlu XSLT předloh
Popis | Popis tagu dokumentu
Náz.skup. XSLT | Název skupiny XSLT předloh
Alias | Alias tag při použití pod nadřízeným tagem (není-uveden použije se identifikace z vlastní definice tagu)
Návěští | Popis tagu dokumentu
Pořadí | Pořadí zpracování navazujícího uzlu XSLT předloh
Samostatný | Vznikne samostatný dokument
Selektivní | Selektivní zpracování
Viz.také | V dokumentu vznikne odkaz Viz.také
V.návěští | Výraz vyhodnocení návěští uzlu
Třídit | Výraz setřídění při zpracování
Vybrat | Výraz podmínky zařazení do zpracování
Stránka #3 Výběr
Tag | Identifikace TAG v XML dokumentu
Náz. XSLT uzlu | Název uzlu XSLT předloh
Vrchol | Vrcholový uzel XSLT předlohy
Skupina | Skupina XSLT předloh
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [XSLT předlohy] činnosti - Schémata XML dokumentů

    Mřížka [XSLT předlohy] činnosti - Schémata XML dokumentů
Skupina | Skupina XSLT předloh
Tag | Identifikace TAG v XML dokumentu
Náz. XSLT uzlu | Název uzlu XSLT předloh
Náz.skup. XSLT | Název skupiny XSLT předloh
Popis | Popis tagu dokumentu

    Mřížka [Navazující XSLT předlohy] činnosti - Schémata XML dokumentů

    Mřížka [Navazující XSLT předlohy] činnosti - Schémata XML dokumentů
Pořadí | Pořadí zpracování navazujícího uzlu XSLT předloh
Tag | Identifikace navazujícího tagu
Skupina | Skupina XSLT navazujícího uzlu XSLT
Náz. XSLT uzlu | Název uzlu XSLT předloh
Náz.skup. XSLT | Název skupiny XSLT předloh
Samostatný | Vznikne samostatný dokument

    Viz.také

    Editovat kód vlastnosti | Knihovny vkládaného kódu | Kontrolní kompilace | Předplnit nav. XSLT předlohy | Schémata XML dokumentů | Skupiny XSLT předloh


Skupiny XSLT předloh

Popis

Tato činnost poskytuje uživateli přehled XSLT skupin, které se používají při definování vlastních XSLT předloh. U každé XSLT předlohy se definuje:

¨ skupina – identifikace a název skupiny

¨ výstup na WEB – skupina XSLT předloh pro výstup na WEB (Ano/Ne)

¨ vazební skupina – vazební skupina XSLT předloh pro výstup na WEB

¨ poznámka – libovolná poznámka

Datový model

  • SPXSLSKP Skupina XSLT předloh

    • Formulář

    Formulář činnosti - Skupiny XSLT předloh
Mřížka [Skupiny XSLT předloh]
Skupina | Skupina XSLT předloh
Náz.skup. XSLT | Název skupiny XSLT předloh
Výstup na WEB | Skupina XSLT předloh pro výstupu na WEB
Vazební skupina | Vazební skupina XSLT předloh pro výstup na WEB
Aktualizace | Datum aktualizace
Poznámka | Poznámka

    Mřížka [Skupiny XSLT předloh] činnosti - Skupiny XSLT předloh

    Mřížka [Skupiny XSLT předloh] činnosti - Skupiny XSLT předloh
Skupina | Skupina XSLT předloh
Náz.skup. XSLT | Název skupiny XSLT předloh

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Editovat kód vlastnosti | Editovat kód vlastnosti
F6 | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností
- | Kontrolní kompilace | Kontrolní kompilace
F2 | Skupiny XSLT předloh | Skupiny XSLT předloh

    Atributy tisku

    Základní údaje
Skupina | Skupina XSLT předloh | SPXSLSKP_spb5id | C(6)
Náz.skup. XSLT | Název skupiny XSLT předloh | SPXSLSKP_spb5nazskp | C(40)
Výstup na WEB | Skupina XSLT předloh pro výstupu na WEB | Výpočet | C(3)
Vazební skupina | Vazební skupina XSLT předloh pro výstup na WEB | SPXSLSKP_spb5idcall | C(6)
Aktualizace | Datum aktualizace | SPXSLSKP_sp00datakt | T
Poznámka | Poznámka | SPXSLSKP_spb5koment | M

    Viz.také

    Editovat kód vlastnosti | Knihovny vkládaného kódu | Kontrolní kompilace


ÚČETNICTVÍ

Popis

V modulu účetnictví jsou soustředěny veškeré nástroje potřebné pro práci účetního firmy.

K dispozici jsou činnosti pro zápis do účetního deníku a vedení účetních knih, činnosti pro definici a tisk libovolných účetních výkazů atd.

Před zahájením provozu modulu účetnictví je nutno provést činnost inicializace.

Viz.také

Účetní deník | Účetní saldokonto | Účetní saldokonto do data | Obratová tabulka | Obratová tabulka se selektory | Konta | Konta se selektory | Účtový rozvrh | VÝKAZY ÚČETNICTVÍ | SPECIÁLNÍ ČINNOSTI


Účetní deník

Popis

Uživatel má možnost prohlížet si jednotlivé účetní zápisy, které byly pomocí operace napojené v určitém druhu procesu a pomocí transformace zapsané do komponenty účetnictví.

V podstatě se jedná o všechny zaúčtované pohyby, které byly provedeny v ostatních komponentách (platby, sklad, obchod, změna stavu peněz apod.) IS Bílý Motýl.

Účetní zápis se realizuje buď automatizovaně na základě již zaznamenaných údajů popisujících účetní případ[1] nebo přímo. Každá položka účetního zápisu, který se promítá současně do všech účetních knih, má tuto strukturu:

¨ Číslo operace v procesu – jednoznačné číslo účetního zápisu složené z roku-identifikace datového úložiště-čísla operace (podrobnější popis číslování dokladů je popsán v kapitole 5.).

¨ Identifikace a název druhu operace – ke každému druhu operace lze nastavit přístupová práva, tzn. že při prohlížení v účetním deníku má uživatel k dispozici ty účetní zápisy, které jsou vytvořeny na základě druhu operace, ke které má uživatel přístupové právo alespoň čtení. Pro vytváření jednotlivých účetních zápisů je nutno mít k druhu operace právo zápis.

¨ Datum – datum účetního případu. Tento atribut úzce souvisí s nastavením účetního období a nastavením činnosti otevřená období komponent. V případě nesrovnalostí systém uživatele upozorňuje těmito hláškami:

- „Datum události musí být menší nebo rovno dnešnímu datu“ – kontrolní hláška, která se objeví ihned po přechodu na další atribut. Upozorňuje uživatele, že v činnosti otevřená období komponent má chybně vyplněn atribut „vstup datum od – do“ nebo že účtuje do budoucna.

- „Pokus o zápis do nedefinovaného účetního období“ – kontrolní hláška, která se objeví při zápisu události. Upozorňuje uživatele, že v činnosti účetní období nemá nadefinované období pro dané datum (systém toto hlásí např. v případě, že uživatel zadává účetní případ s lednovým datem roku 2008 a přitom nemá v činnosti účetní období nadefinován řádek s rokem 2008).

- „Pokus o zápis do uzavřeného účetního období“ - kontrolní hláška, která se objeví při zápisu události. Upozorňuje uživatele, že v činnosti účetní období má období, kam spadá daný datum na události, již uzavřeno.

- „Nesouhlasí suma na straně MD a D“ – kontrolní hláška, která se objeví při zápisu události. V tomto případě tak úplně nesouvisí se sumou stran, ale s datem na události. Upozorňuje uživatele, že v události má např. několik řádek, kde je různé datum události (tato situace může nastat při různých zpětných opravách apod.).

¨ Druh události – atribut označující fázi události v účetním období. Může nabývat hodnot běžná/otevření/uzavření (tj. otevření a uzavření účetních knih), což se následně užije ve výběrech při prohlížení účetních zápisů, v definici výkazů, v hlavní knize, ....

¨ Druh události 2.část – skutečnost/plán – význam je zřejmý z možných variant, tj. plánování se provádí obdobně jako záznam skutečnosti. Hodnota plán se využívá pro vytvoření účetních zápisů s plánovanými hodnotami, které potom následně uživatel porovnává na skutečnost (např. ve výkazech, při provádění finančních analýz, při přípravě plánů do budoucna apod. – bez ohledu na atribut „povolit účtování do budoucna“ v parametrech účetnictví).

¨ Text – vlastní popis účetní události, např. vymezení obsahu účetního případu, ...

¨ Účet – identifikace účtu – účet musí existovat v účtovém rozvrhu a musí být v období platnosti, jinak systém hlásí: „Datum události se musí nacházet v období platnosti účtu a účetního období“.

¨ Obch.s. – identifikace obchodního selektoru – umožňuje uživateli rozlišení účetních událostí na základě obchodního pohledu (např. obchodních zakázek apod.). U obchodního selektoru se eviduje jeho platnost od – do, tzn. v účetním zápisu nelze použít selektor, který je mimo období platnosti.

¨ Org.s. – identifikace organizačního selektoru – umožňuje uživateli rozlišení účetních událostí na základě rozdělení organizace (např. za jednotlivá střediska, úseky, provozy apod.). U organizačního selektoru se eviduje jeho platnost od – do, tzn. v účetním zápisu nelze použít selektor, který je mimo období platnosti. Ke každému organizačnímu selektoru je možno prostřednictvím atributu „umístění“ nastavit pro jednotlivé uživatele přístupová práva, tzn. uživatel s právem přístupu zápis může daný selektor vstupovat v účetním zápisu, uživatel s právem čtení má účetní zápisy s tímto selektorem k dispozici pro prohlížení.

¨ Tech.s. – identifikace technicko-věcného selektoru – umožňuje uživateli rozlišení účetních událostí z hlediska technicko – věcného (např. za jednotlivá auta nebo majetek apod.). U technicko-věcného selektoru se eviduje jeho platnost od – do, tzn. v účetním zápisu nelze použít selektor, který je mimo období platnosti.

¨ Jiné párování – jedná se o příznak saldokontního párování, implicitně je nastaveno NE, protože účetní saldokonto je automaticky hlídáno pomocí IDP. Tento atribut s hodnotou ANO má smysl především u otevření a uzavření účetních knih a při provádění importů či různých oprav (na těchto záznamech uživatel nechce u saldokontních účtů sledovat saldokonto), tj. výjimečné nastavení ANO.

¨ Strana – výběr strany účtu MD/Dal.

¨ Částka – finanční částka v referenční měně, tj. v Kč (maximálně je 999 999 999 999 999,99).

¨ Kód oceňovací jednotky ZM, tj. kód cizí měny, je-li uváděna.

¨ ZM - částka v zahraniční měně.

¨ IDP – identifikace párování – předplňuje se automaticky na základě čísla hlavního procesu. Tuto identifikaci lze uživatelsky měnit, nicméně to pak předpokládá, že veškerá další práce v řízení salda (opravy i standardní práce) je ze strany uživatele ruční. Nicméně uživateli nedoporučujeme IDP měnit u závazků a pohledávek z dodavatelsko odběratelských vztahů, takto automaticky předplněná IDP je obvykle zcela dostačují a umožňuje pohodlné sledování saldokonta napříč těmito procesy. Ke každému IDP (po stisku klávesy F2) je k dispozici aktuální hodnota saldokonta.

¨ Identifikace adresáta, např. účastník účetního případu.

¨ Údaje o tom, kdo danou položku účetního zápisu zapsal dle přihlášeného uživatele. Tento atribut je ze strany IS BM doplněn automaticky identifikací přihlášeného uživatele, který tuto položku zapsal[2].

¨ Kdy zapsal – datum a čas, kdy byl zahájen zápis dané události (položky zápisu).

V událostech účetnictví neukončených operací je možno rozúčtovat události účetního deníku na více událostí bez nutnosti přepisovat původní hodnotu v Kč. Rozúčtování uživatel aktivuje volbou příslušné činnosti z menu Volby nebo stiskem klávesy F5.

[1] Tj. v rámci procesu, např. v IS BM je v operativní evidenci zaznamenán výdej materiálu ze skladu do spotřeby, na který navazuje účetní zápis.

[2] V souladu s vnitřním předpisem definujícím oprávnění, povinnosti a odpovědnosti osob ve vztahu k připojování podpisového záznamu (identifikačního záznamu) jej lze zřejmě považovat za průkazný podpisový záznam (podobně je tomu s dalšími účetními záznamy), samozřejmě za předpokladu, že je IS BM nastaven v souladu s tímto vnitřním předpisem.

Datový model

  • UCDENIK Účetní událost
    • SPPRISTU Přístupové právo uživatele k věci
    • BWUZIVAT Uživatel systému
    • UCROZVRH Účet z rozvrhu
      • UCROZVRN Cizí popis účtu
    • ADADSAT Adresát
    • SPTYP Druh procesu/operace
    • SPSEOB Obchodní selektor
    • SPSEOR Organizační selektor
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)
    • SPSETV Technicko-věcný selektor
    • SPPRCOD Operace procesu
      • SPPRC Proces

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Rozúčtování události účetnictví | Rozúčtování události účetnictví
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^S | Výpočet sumy stran |
^U | INFORMACE K ÚČTU | Skupina činností souvisejících s číslem účtu.
- | INFORMACE O ADRESÁTOVI | Vývěska adresáta a pošta adresáta...
F2 | Adresář | Přehled adresátů
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Výběr pomocného čísla dokladu | Události účetnictví.
F2 | Účetní saldokonto | Všechny operace komponenty Účetnictví, neuzavřené z pohledu saldokonta.
F2 | Účtový rozvrh | Seznam syntetických a analytických účtů.

    Formulář

    Formulář činnosti - Rozúčtování události účetnictví
Mřížka [Účetní deník]
Listovací rámeček
Stránka #1 Deník
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
 | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Název druhu procesu
Datum | Datum účetního případu
Text | Popis účetní události
Druh | Fáze události v účetním období - otevření, běžná, uzavření
 | Druh události 2.část - skutečnost, plán
Účet | Identifikátor účtu účetnictví
 | Cizojazyčný popis účtu.
Obch.s. | Identifikátor obchodního selektoru
Název obchodního selektoru | Název obchodního selektoru
Org.s. | Identifikátor organizačního selektoru.
 | Název organizačního selektoru
Tech.s. | Identifikátor technicko-věcného selektoru.
Název technicko-věcného selektoru | Název technicko-věcného selektoru.
Jiné párování | Záznam byl saldokontně párován importem
Strana | Strana účtu MD/Dal
Částka | Finanční částka
 | Kód měny - oceňovací jednotky.
ZM | Částka v zahraniční měně
IDP | Identifikace párování
Adresát | Identifikace adresáta
 | Název adresáta
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Protiúčty
Mřížka [Protiúčty]
Text | Popis účetní události
Adresát | Identifikace adresáta
 | Název adresáta
Účet | Identifikátor účtu účetnictví
 | Cizojazyčný popis účtu.
Obch.s. | Identifikátor obchodního selektoru
 | Název obchodního selektoru
Org.s. | Identifikátor organizačního selektoru.
 | Název organizačního selektoru
Tech.s. | Identifikátor technicko-věcného selektoru.
 | Název technicko-věcného selektoru.
Strana | Strana účtu MD/Dal
Částka | Finanční částka
Stránka #3 Saldokonto
Mřížka [Saldokonto]
Text | Popis účetní události
Adresát | Identifikace adresáta
 | Název adresáta
Účet | Identifikátor účtu účetnictví
 | Cizojazyčný popis účtu.
Obch.s. | Identifikátor obchodního selektoru
 | Název obchodního selektoru
Org.s. | Identifikátor organizačního selektoru.
 | Název organizačního selektoru
Tech.s. | Identifikátor technicko-věcného selektoru.
 | Název technicko-věcného selektoru.
Strana | Strana účtu MD/Dal
Částka | Finanční částka
IDP | Identifikace párování
Stránka #4 Výběr
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu od
Číslo procesu do | Pořadové číslo procesu do
 | Identifikátor druhu operace
Druh procesu | Identifikátor druhu procesu
Datum | Datum od
 | Datum do
Text | Popis účetní události
Adresát | Identifikace adresáta
 | Název adresáta
Účet | Identifikátor účtu účetnictví
 | Strana účtu MD/Dal
Měna | Kód měny - oceňovací jednotky.
IDP | Identifikace párování
Částka od | Částka od
do | Částka do
běžná | Typ události běžná
otevření ÚK | Typ události otevření účetní knihy
uzavření ÚK | Typ události uzavření účetní knihy
 | Druh události 2.část - skutečnost, plán
Selektory | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Zapsal | Identifikace uživatele systému
Jiné párování | Záznam byl saldokontně párován importem
Stav | Stav procesu - Nestornovaný,Stornovaný,Stornující
Saldokontně neuzavřené | Události neuzavřené z pohledu saldokonta
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Účetní deník] činnosti - Rozúčtování události účetnictví

    Mřížka [Účetní deník] činnosti - Rozúčtování události účetnictví
Označování | Označení záznamu
Účet | Identifikátor účtu účetnictví
Má dáti | Má dáti
Dal | Dal
Datum | Datum účetního případu
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh operace | Identifikátor druhu operace
Popis události | Popis účetní události
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
IDP | Identifikace párování
Částka ZM | Částka v zahraniční měně
Měna | Kód měny - oceňovací jednotky.
Druh | Fáze události v účetním období - otevření, běžná, uzavření
Druh 2.část | Druh události 2.část - skutečnost, plán
Saldokontní | Jedná se o saldokontní účet Ano/Ne
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Adresát | Identifikace adresáta
Název adresáta | Název adresáta

    Mřížka [Protiúčty] činnosti - Rozúčtování události účetnictví

    Mřížka [Protiúčty] činnosti - Rozúčtování události účetnictví
Účet | Identifikátor účtu účetnictví
Má dáti | Má dáti
Dal | Dal

    Mřížka [Saldokonto] činnosti - Rozúčtování události účetnictví

    Mřížka [Saldokonto] činnosti - Rozúčtování události účetnictví
Datum | Datum účetního případu
Má dáti | Má dáti
Dal | Dal
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Druh | Identifikátor druhu operace
Účet | Identifikátor účtu účetnictví

    Atributy tisku

    Základní údaje
Datum účetního případu | Datum účetního případu | UCDENIK_uc02datum | D
Identifikátor účtu | Identifikátor účtu účetnictví | UCDENIK_uc01id | C(9)
Popis účtu | Cizojazyčný popis účtu. | UCROZVRN_uc04popuct | C(40)
Strana | Strana účtu MD/Dal | Výpočet | C(7)
Částka | Finanční částka | UCDENIK_uc02castka | N(20,4)
Charakter účtu | Fáze události v účetním období - otevření, běžná, uzavření | Výpočet | C(8)
Druh 2.část | Druh události 2.část - skutečnost, plán | Výpočet | C(10)
Platnost účtu | Platnost účtu - platný, stornovaný, stornující | Výpočet | C(10)
Jiné párování | Záznam byl saldokontně párován importem | Výpočet | C(3)
Popis události | Popis účetní události | UCDENIK_uc02popuda | C(40)
Adresát | Identifikace adresáta | UCDENIK_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | UCDENIK_sp00datzap | T
Druh procesu | Identifikátor druhu procesu | UCDENIK_sp07idtyp | C(6)
Pořadí | Pořadí stejného druhu operace v jednom procesu | UCDENIK_sp33porad | N(2)
Rok | Rok v identifikaci procesu | UCDENIK_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | UCDENIK_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | UCDENIK_sp33cisd | C(8)
Komponenta | Identifikace komponenty | UCDENIK_sp06idsubs | C(3)
Obch. sel. | Identifikátor obchodního selektoru | UCDENIK_sp10idzak | C(9)
Název obchodního selektoru | Název obchodního selektoru | SPSEOB_sp10text | C(60)
Organizační selektor | Identifikátor organizačního selektoru. | UCDENIK_sp11idzak | C(9)
Název organizačního selektoru | Název organizačního selektoru | SPSEOR_sp11text | C(60)
Tech. sel. | Identifikátor technicko-věcného selektoru. | UCDENIK_sp20idzak | C(9)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(60)
Popis protiúčtu | Cizojazyčný popis účtu. | UCROZVRN2_uc04popuct | C(40)
Název adresáta protiúčtu | Název adresáta | ADADSAT2_ad01adsat | C(100)

    Při pohybu v Protiúčty
Datum u protiúčtu | Datum účetního případu | UCDENIK2_uc02datum | D
Identifikátor protiúčtu | Identifikátor účtu účetnictví | UCDENIK2_uc01id | C(9)
Strana protiúčtu | Strana účtu MD/Dal | Výpočet | C(7)
Částka protiúčtu | Finanční částka | UCDENIK2_uc02castka | N(20,4)
Popis události protiúčtu | Popis účetní události | UCDENIK2_uc02popuda | C(40)
Adresát protiúčtu | Identifikace adresáta | UCDENIK2_ad01id | C(6)
Obch. sel. | Identifikátor obchodního selektoru | UCDENIK2_sp10idzak | C(9)
Identifikátor organizačního selektoru protiúčtu | Identifikátor organizačního selektoru. | UCDENIK2_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | UCDENIK2_sp20idzak | C(9)

    Viz.také

    Rozúčtování události účetnictví | OZNAČOVÁNÍ | Výpočet sumy stran | INFORMACE K ÚČTU | INFORMACE O ADRESÁTOVI | Adresář | Druhy operací | Druhy procesů | Měny a kursy | Obchodní selektor | Organizační selektor | Technicko-věcný selektor | Účetní saldokonto | Účtový rozvrh | Otevření účetních knih | Sumy stran | Uzavření účetních knih


Účetní saldokonto

Popis

Pokud je u jednotlivých IDP saldokonto vyrovnané, v této činnosti se vůbec nenabízí, tj. zobrazují se pouze IDP, které mají z hlediska účetnictví saldokonto nevyrovnané. Pod záložkou "skladba saldokonta" má uživatel možnost zjistit si, jak je dané saldokonto IDP tvořeno. Pro sledování saldokonta je pro uživatele mnohem vhodnější používat činnost „účetní saldokonto do data“, kde na výběrové záložce lze kromě IDP (identifikace párování) a čísla účtu vybírat informace i podle data a adresáta (při použití obecného výběru „Saldokonto adresáta“).

Účetní saldokonto sleduje, zda jsou vyrovnané účetní strany Má dáti a Dal u jednotlivých saldokontních účtů (dle IDP a identifikace adresáta). Jedinou podmínkou pro správnou evidenci účetního saldokonta je prvotní úprava účetního rozvrhu. Uživatel si u jednotlivých účtů musí nastavit, zda jsou či nejsou saldokontní.

Účetní saldokonto se vždy sleduje při zápisu do účetního deníku na účtu, který má v účtovém rozvrhu nastaven příznak saldokontní „ano“ a událost účetnictví má u atributu Jiné párování příznak „NE“. Ke každému IDP (po stisku klávesy F2) je k dispozici aktuální hodnota saldokonta. Zcela výjimečně mohou uživatelé použít činnost přepočet účetního saldokonta (menu účetnictví – speciální činnosti) a to v případech, kdy během účetního období nesaldokontní účet označí v účtovém rozvrhu jako saldokontní - pak je nutné hodnoty tohoto účtu znovu přepočítat.

Datový model

  • UCPRCSAL Saldokontní hodnota účetníctví
    • UCROZVRH Účet z rozvrhu
      • UCROZVRN Cizí popis účtu

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Strom hlavního procesu | Zobrazení hlavního stromu procesu-operace
F7 | Diagram procesu | Zobrazení diagramu procesu
F9 | Spustit operaci | Spuštění zobrazené operace
^U | INFORMACE K ÚČTU | Skupina činností souvisejících s číslem účtu.
- | Skladba saldokonta | Události účetnictví.
F2 | Účtový rozvrh | Seznam syntetických a analytických účtů.

    Formulář

    Formulář činnosti - Účetní deník
Mřížka [Účetní saldokonto]
Listovací rámeček
Stránka #1 Saldokonto
IDP | Identifikace párování
Účet | Identifikátor účtu účetnictví
 | Cizojazyčný popis účtu.
Hodnota | Hodnota saldokonta
Stránka #2 Skladba saldokonta
Mřížka [Skladba saldokonta]
Datum | Datum účetního případu
 | Popis účetní události
Účet | Identifikátor účtu účetnictví
 | Cizojazyčný popis účtu.
Strana | Strana účtu MD/Dal
Částka | Finanční částka
Adresát | Identifikace adresáta
 | Název adresáta
IDP | Identifikace párování
Jiné párování | Záznam byl saldokontně párován importem
Stránka #3 Výběr
IDP | Identifikace párování
Účet | Identifikátor účtu účetnictví
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Účetní saldokonto] činnosti - Účetní deník

    Mřížka [Účetní saldokonto] činnosti - Účetní deník
Účet | Identifikátor účtu účetnictví
IDP | Identifikace párování
Hodnota | Hodnota saldokonta
Popis účtu | Cizojazyčný popis účtu.

    Mřížka [Skladba saldokonta] činnosti - Účetní deník

    Mřížka [Skladba saldokonta] činnosti - Účetní deník
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh | Identifikátor druhu operace
Účet | Identifikátor účtu účetnictví
Strana | Strana účtu MD/Dal
Částka | Finanční částka

    Atributy tisku

    Základní údaje
IDP | Identifikace párování | UCPRCSAL_uc15parid | C(14)
Identifikátor účtu | Identifikátor účtu účetnictví | UCPRCSAL_uc01id | C(9)
Popis účtu | Cizojazyčný popis účtu. | UCROZVRN_uc04popuct | C(40)
Hodnota saldokonta | Hodnota saldokonta | UCPRCSAL_uc15hodnot | N(20,4)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)

    Při pohybu v Deník
Rok | Rok v identifikaci procesu | UCAHUD_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | UCAHUD_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | UCAHUD_sp33cisd | C(8)
Druh operace | Identifikátor druhu operace | UCAHUD_sp07idtyp | C(6)
Komponenta | Identifikace komponenty | UCAHUD_sp06idsubs | C(3)
Skladba - Datum účetního případu | Datum účetního případu | UCAHUD_uc02datum | D
Skladba - Strana | Strana účtu MD/Dal | Výpočet | C(7)
Skladba - Částka | Finanční částka | UCAHUD_uc02castka | N(20,4)
Popis události | Popis účetní události | UCAHUD_uc02popuda | C(40)
Adresát | Identifikace adresáta | UCAHUD_ad01id | C(6)

    Viz.také

    Strom hlavního procesu | Diagram procesu | Spustit operaci | INFORMACE K ÚČTU | Účetní deník | Účtový rozvrh


Účetní saldokonto do data

Popis

Velmi obdobná činnost s činností „účetní saldokonto“ (viz. popis dále) jen s tím rozdílem, že na výběrové záložce lze kromě IDP (identifikace párování) a čísla účtu vybírat informace i podle data a adresáta (při použití obecného výběru „Saldokonto adresáta“). Pokud je u jednotlivých IDP saldokonto vyrovnané, v této činnosti se vůbec nenabízí, tj. zobrazují se pouze IDP, které mají z hlediska účetnictví saldokonto nevyrovnané. Pod záložkou "skladba saldokonta" má uživatel možnost zjistit si, jak je dané saldokonto IDP tvořeno.

Účetní saldokonto sleduje, zda jsou vyrovnané účetní strany Má dáti a Dal u jednotlivých saldokontních účtů (dle IDP a identifikace adresáta). Jedinou podmínkou pro správnou evidenci účetního saldokonta je prvotní úprava účetního rozvrhu. Uživatel si u jednotlivých účtů musí nastavit, zda jsou či nejsou saldokontní.

Účetní saldokonto se vždy sleduje při zápisu do účetního deníku na účtu, který má v účtovém rozvrhu nastaven příznak saldokontní „ano“ a událost účetnictví má u atributu Jiné párování příznak „NE“. Ke každému IDP (po stisku klávesy F2) je k dispozici aktuální hodnota saldokonta. Zcela výjimečně mohou uživatelé použít činnost přepočet účetního saldokonta (menu účetnictví – speciální činnosti) a to v případech, kdy během účetního období nesaldokontní účet označí v účtovém rozvrhu jako saldokontní - pak je nutné hodnoty tohoto účtu znovu přepočítat.

Datový model

  • UCPRCSA2 Saldokonto do data
    • UCROZVRN Cizí popis účtu

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Strom hlavního procesu | Zobrazení hlavního stromu procesu-operace
F7 | Diagram procesu | Zobrazení diagramu procesu
F9 | Spustit operaci | Spuštění zobrazené operace
^U | INFORMACE K ÚČTU | Skupina činností souvisejících s číslem účtu.
- | Skladba saldokonta | Události účetnictví.
F2 | Účtový rozvrh | Seznam syntetických a analytických účtů.

    Formulář

    Formulář činnosti - Účetní deník
Mřížka [Saldokonto do data]
Listovací rámeček
Stránka #1 Saldokonto
IDP | Identifikace párování
Účet | Identifikátor účtu účetnictví
 | Cizojazyčný popis účtu.
Hodnota | Hodnota saldokonta
Stránka #2 Skladba saldokonta
Mřížka [Skladba saldokonta]
Datum | Datum účetního případu
Popis události | Popis účetní události
Účet | Identifikátor účtu účetnictví
 | Cizojazyčný popis účtu.
Adresát | Identifikace adresáta
 | Název adresáta
Strana | Strana účtu MD/Dal
Částka | Finanční částka
Stránka #3 Výběr
IDP | Identifikace párování
Účet | Identifikátor účtu účetnictví
Do data | Účetní saldokonto do data
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Saldokonto do data] činnosti - Účetní deník

    Mřížka [Saldokonto do data] činnosti - Účetní deník
Účet | Identifikátor účtu účetnictví
IDP | Identifikace párování
Hodnota | Hodnota saldokonta
Popis protiúčtu | Cizojazyčný popis účtu.

    Mřížka [Skladba saldokonta] činnosti - Účetní deník

    Mřížka [Skladba saldokonta] činnosti - Účetní deník
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh operace | Identifikátor druhu operace
Účet | Identifikátor účtu účetnictví
Strana | Strana účtu MD/Dal
Částka | Finanční částka
Datum | Datum účetního případu
Popis události | Popis účetní události
Adresát | Identifikace adresáta

    Atributy tisku

    Základní údaje
IDP | Identifikace párování | UCPRCSA2_uc15parid | C(14)
Identifikátor účtu | Identifikátor účtu účetnictví | UCPRCSA2_uc01id | C(9)
Popis účtu | Cizojazyčný popis účtu. | UCROZVRN_uc04popuct | C(40)
Hodnota saldokonta | Hodnota saldokonta | UCPRCSA2_uc15hodnot | N(20,4)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)

    Při pohybu v Deník
Rok | Rok v identifikaci procesu | UCAHUD_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | UCAHUD_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | UCAHUD_sp33cisd | C(8)
Druh operace | Identifikátor druhu operace | UCAHUD_sp07idtyp | C(6)
Komponenta | Identifikace komponenty | UCAHUD_sp06idsubs | C(3)
Skladba - Datum účetního případu | Datum účetního případu | UCAHUD_uc02datum | D
Skladba - Strana | Strana účtu MD/Dal | UCAHUD_uc02strana | N(1)
Skladba - Částka | Finanční částka | UCAHUD_uc02castka | N(20,4)
Popis události | Popis účetní události | UCAHUD_uc02popuda | C(40)
Adresát | Identifikace adresáta | UCAHUD_ad01id | C(6)

    Viz.také

    Strom hlavního procesu | Diagram procesu | Spustit operaci | INFORMACE K ÚČTU | Účetní deník | Účtový rozvrh


Obratová tabulka

Popis

Hlavní kniha je v podstatě na první pohled shodná s celou obratovou tabulkou. Rozdíl mezi nimi je v zobrazení dat, a to tak, že obratová tabulka obsahuje sumární stavy za jednotlivé analytické účty po měsících, kdežto hlavní kniha obsahuje položkové nápočty daného analytického účtu za konkrétní měsíc.

U každého účtu má uživatel přehled o jeho počátečním stavu, obratech na straně MD, obratech na straně D a konečném stavu za zvolené období. U každého účtu je navíc k dispozici i informace o straně účtu (MD, D) uvedené u daného účtu v účtovém rozvrhu.

Datový model

  • UCHLAKNI Záznam v hlavní knize účtu
    • UCROZVRH Účet z rozvrhu
      • UCROZVRN Cizí popis účtu
    • UCOBDOBI Účetní období (alias UCOBDOBI2)

    • Vyvolávané činnosti

    K. | Činnost | Popis
F9 | Spustit operaci | Spuštění zobrazené operace
^S | Výpočet sumy stran |
^U | INFORMACE K ÚČTU | Skupina činností souvisejících s číslem účtu.
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Účtový rozvrh | Seznam syntetických a analytických účtů.

    Formulář

    Formulář činnosti - Výpočet sumy stran
Mřížka [Hlavní kniha]
Listovací rámeček
Stránka #1 Obratová tabulka
Období | Rok ve kterém došlo k pohybu
 | Měsíc, ve kterém došlo k pohybu
Druh | Druh informace skutečnost, plán ...
Fáze | Fáze události v účetním období - otevření, běžná, uzavření
Název účetního období | Název účetního období
Účet | Identifikátor účtu účetnictví
 | Cizojazyčný popis účtu.
 | Strana účtu MD/Dal
Měna | Kód měny - oceňovací jednotky.
Počáteční stav | Počáteční stav účtu
Má dáti | Obrat strany MD
Dal | Obrat strany Dal
Konečný stav | Konečný stav účtu
Stránka #2 Hlavní kniha
Mřížka [Hlavní kniha]
Druh | Druh informace skutečnost, plán ...
Fáze | Fáze události v účetním období - otevření, běžná, uzavření
Název účetního období | Název účetního období
Období | Rok ve kterém došlo k pohybu
 | Měsíc, ve kterém došlo k pohybu
Účet | Identifikátor účtu účetnictví
 | Cizojazyčný popis účtu.
Měna | Kód měny - oceňovací jednotky.
Počáteční stav | Počáteční stav účtu
Má dáti | Obrat strany MD
Dal | Obrat strany Dal
Konečný stav | Konečný stav účtu
Stránka #3 Výběr
Druh | Druh informace skutečnost, plán ...
Fáze | Fáze události v účetním období - otevření, běžná, uzavření
Období | Identifikace účetního období
Rok | Rok ve kterém došlo k pohybu
Měsíc | Měsíc, ve kterém došlo k pohybu
do | Měsíc, ve kterém došlo k pohybu do
Účet | Identifikátor účtu účetnictví
 | Cizojazyčný popis účtu.
Měna | Kód měny - oceňovací jednotky.
Zobrazit | Zobrazit - Vše/Nenulový obrat/Nenulový obrat plánovaný
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Hlavní kniha] činnosti - Výpočet sumy stran

    Mřížka [Hlavní kniha] činnosti - Výpočet sumy stran
Rok | Rok ve kterém došlo k pohybu
Měsíc | Měsíc, ve kterém došlo k pohybu
Účet | Identifikátor účtu účetnictví
Strana | Strana účtu MD/Dal
Počáteční stav | Počáteční stav účtu
Má dáti | Obrat strany MD
Dal | Obrat strany Dal
Konečný stav | Konečný stav účtu
Popis účtu | Cizojazyčný popis účtu.
Měna | Kód měny - oceňovací jednotky.
Druh | Druh informace skutečnost, plán ...
Fáze | Fáze události v účetním období - otevření, běžná, uzavření
Název účetního období | Název účetního období

    Mřížka [Hlavní kniha] činnosti - Výpočet sumy stran

    Mřížka [Hlavní kniha] činnosti - Výpočet sumy stran
Datum | Datum účetního případu
Má dáti | Má dáti
Dal | Dal
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh operace | Identifikátor druhu operace
Popis události | Popis účetní události
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
IDP | Identifikace párování
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Atributy tisku

    Základní údaje
Rok | Rok ve kterém došlo k pohybu | UCHLAKNI_uc03rok | C(4)
Měsíc | Měsíc, ve kterém došlo k pohybu | UCHLAKNI_uc03mesic | C(2)
Druh | Druh informace skutečnost, plán ... | Výpočet | C(10)
Fáze | Fáze události v účetním období - otevření, běžná, uzavření | Výpočet | C(8)
Název období | Název účetního období | UCOBDOBI2_uc37nazobd | C(40)
Účet | Identifikátor účtu účetnictví | UCHLAKNI_uc01id | C(9)
Měna | Kód měny - oceňovací jednotky. | UCHLAKNI_oc01id | C(3)
Popis protiúčtu | Cizojazyčný popis účtu. | UCROZVRN_uc04popuct | C(40)
Počáteční stav | Počáteční stav účtu | UCHLAKNI_uc03psvyk | N(20,4)
Má dáti | Obrat strany MD | UCHLAKNI_uc03mdr | N(20,4)
Dal | Obrat strany Dal | UCHLAKNI_uc03dalr | N(20,4)
Konečný stav | Konečný stav účtu | UCHLAKNI_uc03ksvyk | N(20,4)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)

    Při pohybu v Deník
Datum | Datum účetního případu | UCDENIK_uc02datum | D
Druh události | Plánovaná/Ujednaná/Realizovaná událost | Výpočet | C(11)
Strana | Strana účtu MD/Dal | Výpočet | C(7)
Částka | Finanční částka | UCDENIK_uc02castka | N(20,4)
Druh | Fáze události v účetním období - otevření, běžná, uzavření | UCDENIK_uc02faze | N(1)
Platnost | Platnost účtu - platný, stornovaný, stornující | UCDENIK_uc02platno | N(1)
Popis události | Popis účetní události | UCDENIK_uc02popuda | C(40)
Adresát | Identifikace adresáta | UCDENIK_ad01id | C(6)
Datum a čas zápisu | Datum a čas zápisu záznamu události | UCDENIK_sp00datzap | T
Druh operace | Identifikátor druhu operace | UCDENIK_sp07idtyp | C(6)
Org. sel. | Identifikátor organizačního selektoru. | UCDENIK_sp11idzak | C(9)
Jiné párování | Záznam byl saldokontně párován importem | Výpočet | C(3)
Měna | Kód měny - oceňovací jednotky. | UCDENIK_oc01id | C(3)
Referenční měna | Referenční měna | UCDENIK_oc01id1 | C(3)
Částka ZM | Částka v zahraniční měně | UCDENIK_uc02castkz | N(20,4)
IDP | Identifikace párování | UCDENIK_uc15parid | C(14)
Pořadí | Pořadí stejného druhu operace v jednom procesu | UCDENIK_sp33porad | N(2)
Komponenta | Identifikace komponenty | UCDENIK_sp06idsubs | C(3)
Rok | Rok v identifikaci procesu | UCDENIK_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | UCDENIK_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | UCDENIK_sp33cisd | C(8)

    Viz.také

    Spustit operaci | Výpočet sumy stran | INFORMACE K ÚČTU | Měny a kursy | Účtový rozvrh


Obratová tabulka se selektory

Popis

Uživatel má k dispozici veškeré údaje o jednotlivých účtech. U každého účtu jsou za jednotlivé měsíce ve zvoleném roce k dispozici údaje o počátečním a konečném stavu a hodnotách na straně Má dáti a Dal za skutečnost a plán. U každého účtu je navíc k dispozici i informace o straně účtu (MD, D) uvedené u daného účtu v účtovém rozvrhu. Z toho vyplývá, že jednotlivé hodnoty, které uživatel v účetnictví potřebuje sledovat, lze zadávat nejen jako skutečné, ale i plánované. Na základě tohoto pak lze provádět určitá srovnání skutečnosti s plánem, připravovat plány do budoucna, provádět finanční analýzy apod.

Pokud bude uživatel využívat obratovou tabulku k prohlížení a tisku hlavní knihy, má vždy k dispozici aktuální stavy jednotlivých obratů.

Hlavní kniha je v podstatě na první pohled shodná s celou obratovou tabulkou. Rozdíl mezi nimi je v zobrazení dat, a to tak, že obratová tabulka obsahuje sumární stavy za jednotlivé analytické účty po měsících a selektorech, kdežto hlavní kniha obsahuje položkové nápočty daného analytického účtu za konkrétní měsíc a selektor.

Obratová tabulka se selektory se vytváří pro účty, které mají v účtovém rozvrhu zatržen příznak „sledovat obrat po selektorech“. Uživatelé mohou použít činnost přepočet obratové tabulky (menu účetnictví – speciální činnosti) a to v případech, kdy během účetního období účet označí v účtovém rozvrhu příznakem „sledovat obrat po selektorech“.

Datový model

  • UCOBRTAB Měsíční obrat
    • UCROZVRH Účet z rozvrhu
      • UCROZVRN Cizí popis účtu
    • SPSEOB Obchodní selektor
    • SPSEOR Organizační selektor
      • SPPRISTU Přístupové právo uživatele k věci
    • SPSETV Technicko-věcný selektor
    • UCOBDOBI Účetní období (alias UCOBDOBI2)

    • Vyvolávané činnosti

    K. | Činnost | Popis
F9 | Spustit operaci | Spuštění zobrazené operace
^S | Výpočet sumy stran |
^U | INFORMACE K ÚČTU | Skupina činností souvisejících s číslem účtu.
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Účtový rozvrh | Seznam syntetických a analytických účtů.

    Formulář

    Formulář činnosti - Obchodní selektor
Mřížka [Obratová tabulka]
Listovací rámeček
Stránka #1 Obratová tabulka se selektory
Období | Rok ve kterém došlo k pohybu
 | Měsíc, ve kterém došlo k pohybu
Druh | Druh informace skutečnost, plán ...
Fáze | Fáze události v účetním období - otevření, běžná, uzavření
Název účetního období | Název účetního období
Účet | Identifikátor účtu účetnictví
 | Cizojazyčný popis účtu.
 | Strana účtu MD/Dal
Měna | Kód měny - oceňovací jednotky.
Obch.s. | Identifikátor obchodního selektoru
 | Název obchodního selektoru
Org.s. | Identifikátor organizačního selektoru.
 | Název organizačního selektoru
Tech.s. | Identifikátor technicko-věcného selektoru.
 | Název technicko-věcného selektoru.
Počáteční stav | Počáteční stav účtu
Dal | Obrat strany Dal
Má dáti | Obrat strany MD
Konečný stav | Konečný stav účtu
Stránka #2 Hlavní kniha
Mřížka [Hlavní kniha]
Období | Rok ve kterém došlo k pohybu
 | Měsíc, ve kterém došlo k pohybu
Druh | Druh informace skutečnost, plán ...
Fáze | Fáze události v účetním období - otevření, běžná, uzavření
Název účetního období | Název účetního období
Účet | Identifikátor účtu účetnictví
 | Cizojazyčný popis účtu.
Obch.s. | Identifikátor obchodního selektoru
 | Název obchodního selektoru
Org.s. | Identifikátor organizačního selektoru.
 | Název organizačního selektoru
Tech.s. | Identifikátor technicko-věcného selektoru.
 | Název technicko-věcného selektoru.
Měna | Kód měny - oceňovací jednotky.
Počáteční stav | Počáteční stav účtu
Má dáti | Obrat strany MD
Dal | Obrat strany Dal
Konečný stav | Konečný stav účtu
Stránka #3 Výběr
Druh | Druh informace skutečnost, plán ...
Fáze | Fáze události v účetním období - otevření, běžná, uzavření
Období | Identifikace účetního období
Rok | Rok ve kterém došlo k pohybu
Měsíc | Měsíc, ve kterém došlo k pohybu
do | Měsíc, ve kterém došlo k pohybu do
Účet | Identifikátor účtu účetnictví
 | Cizojazyčný popis účtu.
Měna | Kód měny - oceňovací jednotky.
Obch. sel. | Identifikátor obchodního selektoru
Název obchodního selektoru | Název obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
 | Název organizačního selektoru
Tech. sel. | Identifikátor technicko-věcného selektoru.
Název technicko-věcného selektoru | Název technicko-věcného selektoru.
Zobrazit | Zobrazit - Vše/Nenulový obrat/Nenulový obrat plánovaný
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Obratová tabulka] činnosti - Obchodní selektor

    Mřížka [Obratová tabulka] činnosti - Obchodní selektor
Rok | Rok ve kterém došlo k pohybu
Měsíc | Měsíc, ve kterém došlo k pohybu
Účet | Identifikátor účtu účetnictví
Strana | Strana účtu MD/Dal
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Počáteční stav | Počáteční stav účtu
Má dáti | Obrat strany MD
Dal | Obrat strany Dal
Konečný stav | Konečný stav účtu
Měna | Kód měny - oceňovací jednotky.
Druh | Druh informace skutečnost, plán ...
Fáze | Fáze události v účetním období - otevření, běžná, uzavření
Název účetního období | Název účetního období

    Mřížka [Hlavní kniha] činnosti - Obchodní selektor

    Mřížka [Hlavní kniha] činnosti - Obchodní selektor
Datum | Datum účetního případu
Má dáti | Má dáti
Dal | Dal
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh operace | Identifikátor druhu operace
Popis události | Popis účetní události
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
IDP | Identifikace párování
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Atributy tisku

    Základní údaje
Rok | Rok ve kterém došlo k pohybu | UCOBRTAB_uc03rok | C(4)
Měsíc | Měsíc, ve kterém došlo k pohybu | UCOBRTAB_uc03mesic | C(2)
Druh | Druh informace skutečnost, plán ... | Výpočet | C(10)
Název účetního období | Název účetního období | UCOBDOBI2_uc37nazobd | C(40)
Fáze | Fáze události v účetním období - otevření, běžná, uzavření | Výpočet | C(8)
Organizační selektor | Identifikátor organizačního selektoru. | UCOBRTAB_sp11idzak | C(9)
Identifikátor účtu | Identifikátor účtu účetnictví | UCOBRTAB_uc01id | C(9)
Měna | Kód měny - oceňovací jednotky. | UCOBRTAB_oc01id | C(3)
Popis účtu | Cizojazyčný popis účtu. | UCROZVRN_uc04popuct | C(40)
Název organizačního selektoru | Název organizačního selektoru | SPSEOR_sp11text | C(60)
Počáteční stav | Počáteční stav účtu | UCOBRTAB_uc03psvyk | N(20,4)
Obraty strany má dáti | Obrat strany MD | UCOBRTAB_uc03mdr | N(20,4)
Obraty strany dal | Obrat strany Dal | UCOBRTAB_uc03dalr | N(20,4)
Konečný stav | Konečný stav účtu | UCOBRTAB_uc03ksvyk | N(20,4)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)

    Při pohybu v Deník
Datum | Datum účetního případu | UCDENIK_uc02datum | D
Druh události | Plánovaná/Ujednaná/Realizovaná událost | Výpočet | C(11)
Strana | Strana účtu MD/Dal | Výpočet | C(7)
Částka | Finanční částka | UCDENIK_uc02castka | N(20,4)
Druh | Fáze události v účetním období - otevření, běžná, uzavření | UCDENIK_uc02faze | N(1)
Platnost | Platnost účtu - platný, stornovaný, stornující | UCDENIK_uc02platno | N(1)
Popis události | Popis účetní události | UCDENIK_uc02popuda | C(40)
Adresát | Identifikace adresáta | UCDENIK_ad01id | C(6)
Datum a čas zápisu | Datum a čas zápisu záznamu události | UCDENIK_sp00datzap | T
Druh operace | Identifikátor druhu operace | UCDENIK_sp07idtyp | C(6)
Org. sel. | Identifikátor organizačního selektoru. | UCDENIK_sp11idzak | C(9)
Jiné párování | Záznam byl saldokontně párován importem | Výpočet | C(3)
Měna | Kód měny - oceňovací jednotky. | UCDENIK_oc01id | C(3)
Referenční měna | Referenční měna | UCDENIK_oc01id1 | C(3)
Částka ZM | Částka v zahraniční měně | UCDENIK_uc02castkz | N(20,4)
IDP | Identifikace párování | UCDENIK_uc15parid | C(14)
Pořadí | Pořadí stejného druhu operace v jednom procesu | UCDENIK_sp33porad | N(2)
Komponenta | Identifikace komponenty | UCDENIK_sp06idsubs | C(3)
Rok | Rok v identifikaci procesu | UCDENIK_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | UCDENIK_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | UCDENIK_sp33cisd | C(8)

    Viz.také

    Spustit operaci | Výpočet sumy stran | INFORMACE K ÚČTU | Měny a kursy | Obchodní selektor | Organizační selektor | Technicko-věcný selektor | Účtový rozvrh


Konta

Popis

Konta poskytují uživateli informace o konečném stavu účtu ke konci vybraného období (počáteční stav je hodnota k prvnímu dni účetního období.). Záložka Hlavní kniha zobrazuje detailní přehled pohybů z účetního deníku konkrétního konta za vybrané období.

Datový model

  • UCKONTO Záznam o stavu konta
    • UCROZVRH Účet z rozvrhu
      • UCROZVRN Cizí popis účtu
    • UCOBDOBI Účetní období

    • Vyvolávané činnosti

    K. | Činnost | Popis
F9 | Spustit operaci | Spuštění zobrazené operace
^S | Výpočet sumy stran |
^U | INFORMACE K ÚČTU | Skupina činností souvisejících s číslem účtu.
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Účtový rozvrh | Seznam syntetických a analytických účtů.

    Formulář

    Formulář činnosti - Výpočet sumy stran
Mřížka [Konta]
Listovací rámeček
Stránka #1 Konta
Období | Rok ve kterém došlo k pohybu
 | Měsíc, ve kterém došlo k pohybu
Druh | Druh informace skutečnost, plán ...
Účet | Identifikátor účtu účetnictví
 | Cizojazyčný popis účtu.
 | Strana účtu MD/Dal
Měna | Kód měny - oceňovací jednotky.
Počáteční stav | Počáteční stav účtu
Má dáti | Obrat strany MD
Dal | Obrat strany Dal
Konečný stav | Konečný stav účtu
Stránka #2 Hlavní kniha
Mřížka [Hlavní kniha]
Druh | Druh informace skutečnost, plán ...
Období | Rok ve kterém došlo k pohybu
 | Měsíc, ve kterém došlo k pohybu
Účet | Identifikátor účtu účetnictví
Měna | Kód měny - oceňovací jednotky.
 | Cizojazyčný popis účtu.
Počáteční stav | Počáteční stav účtu
Má dáti | Obrat strany MD
Dal | Obrat strany Dal
Konečný stav | Konečný stav účtu
Stránka #3 Výběr
Druh | Druh informace skutečnost, plán ...
Rok | Rok ve kterém došlo k pohybu
Měsíc | Měsíc, ve kterém došlo k pohybu
Účet | Identifikátor účtu účetnictví
 | Cizojazyčný popis účtu.
Měna | Kód měny - oceňovací jednotky.
Zobrazit | Zobrazit - Vše/Nenulový obrat/Nenulový obrat plánovaný
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Konta] činnosti - Výpočet sumy stran

    Mřížka [Konta] činnosti - Výpočet sumy stran
Rok | Rok ve kterém došlo k pohybu
Měsíc | Měsíc, ve kterém došlo k pohybu
Účet | Identifikátor účtu účetnictví
Strana | Strana účtu MD/Dal
Počáteční stav | Počáteční stav účtu
Má dáti | Obrat strany MD
Dal | Obrat strany Dal
Konečný stav | Konečný stav účtu
Popis účtu | Cizojazyčný popis účtu.
Měna | Kód měny - oceňovací jednotky.
Druh | Druh informace skutečnost, plán ...

    Mřížka [Hlavní kniha] činnosti - Výpočet sumy stran

    Mřížka [Hlavní kniha] činnosti - Výpočet sumy stran
Datum | Datum účetního případu
Má dáti | Má dáti
Dal | Dal
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh operace | Identifikátor druhu operace
Popis události | Popis účetní události
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
IDP | Identifikace párování
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Atributy tisku

    Základní údaje
Druh | Druh informace skutečnost, plán ... | Výpočet | C(10)
Rok | Rok ve kterém došlo k pohybu | UCKONTO_uc03rok | C(4)
Měsíc | Měsíc, ve kterém došlo k pohybu | UCKONTO_uc03mesic | C(2)
Účet | Identifikátor účtu účetnictví | UCKONTO_uc01id | C(9)
Měna | Kód měny - oceňovací jednotky. | UCKONTO_oc01id | C(3)
Počáteční stav | Počáteční stav účtu | UCKONTO_uc03psvyk | N(20,4)
Má dáti | Obrat strany MD | UCKONTO_uc03mdr | N(20,4)
Dal | Obrat strany Dal | UCKONTO_uc03dalr | N(20,4)
Konečný stav | Konečný stav účtu | UCKONTO_uc03ksvyk | N(20,4)
Popis účtu | Cizojazyčný popis účtu. | UCROZVRN_uc04popuct | C(40)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)

    Při pohybu v Deník
Datum | Datum účetního případu | UCDENIK_uc02datum | D
Druh události | Plánovaná/Ujednaná/Realizovaná událost | Výpočet | C(11)
Strana | Strana účtu MD/Dal | Výpočet | C(7)
Částka | Finanční částka | UCDENIK_uc02castka | N(20,4)
Druh | Fáze události v účetním období - otevření, běžná, uzavření | UCDENIK_uc02faze | N(1)
Platnost | Platnost účtu - platný, stornovaný, stornující | UCDENIK_uc02platno | N(1)
Popis události | Popis účetní události | UCDENIK_uc02popuda | C(40)
Adresát | Identifikace adresáta | UCDENIK_ad01id | C(6)
Datum a čas zápisu | Datum a čas zápisu záznamu události | UCDENIK_sp00datzap | T
Druh operace | Identifikátor druhu operace | UCDENIK_sp07idtyp | C(6)
Org. sel. | Identifikátor organizačního selektoru. | UCDENIK_sp11idzak | C(9)
Jiné párování | Záznam byl saldokontně párován importem | Výpočet | C(3)
Měna | Kód měny - oceňovací jednotky. | UCDENIK_oc01id | C(3)
Referenční měna | Referenční měna | UCDENIK_oc01id1 | C(3)
Částka ZM | Částka v zahraniční měně | UCDENIK_uc02castkz | N(20,4)
IDP | Identifikace párování | UCDENIK_uc15parid | C(14)
Pořadí | Pořadí stejného druhu operace v jednom procesu | UCDENIK_sp33porad | N(2)
Komponenta | Identifikace komponenty | UCDENIK_sp06idsubs | C(3)
Rok | Rok v identifikaci procesu | UCDENIK_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | UCDENIK_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | UCDENIK_sp33cisd | C(8)

    Viz.také

    Spustit operaci | Výpočet sumy stran | INFORMACE K ÚČTU | Měny a kursy | Účtový rozvrh


Konta se selektory

Popis

Konta poskytují uživateli informace o konečném stavu účtu ke konci vybraného období za jednotlivé selektory (počáteční stav je hodnota k prvnímu dni účetního období.). Záložka Hlavní kniha zobrazuje detailní přehled pohybů z účetního deníku konkrétního konta a selektoru za vybrané období.

Datový model

  • UCKONTOS Záznam o stavu konta se selektorem
    • UCROZVRH Účet z rozvrhu
      • UCROZVRN Cizí popis účtu
    • SPSEOB Obchodní selektor
    • SPSEOR Organizační selektor
      • SPPRISTU Přístupové právo uživatele k věci
    • SPSETV Technicko-věcný selektor
    • UCOBDOBI Účetní období

    • Vyvolávané činnosti

    K. | Činnost | Popis
F9 | Spustit operaci | Spuštění zobrazené operace
^S | Výpočet sumy stran |
^U | INFORMACE K ÚČTU | Skupina činností souvisejících s číslem účtu.
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Účtový rozvrh | Seznam syntetických a analytických účtů.

    Formulář

    Formulář činnosti - Obchodní selektor
Mřížka [Konta se selektory]
Listovací rámeček
Stránka #1 Konta se selektory
Druh | Druh informace skutečnost, plán ...
Období | Rok ve kterém došlo k pohybu
 | Měsíc, ve kterém došlo k pohybu
Účet | Identifikátor účtu účetnictví
Měna | Kód měny - oceňovací jednotky.
 | Cizojazyčný popis účtu.
 | Strana účtu MD/Dal
Obch.s. | Identifikátor obchodního selektoru
 | Název obchodního selektoru
Org.s. | Identifikátor organizačního selektoru.
 | Název organizačního selektoru
Tech.s. | Identifikátor technicko-věcného selektoru.
 | Název technicko-věcného selektoru.
Počáteční stav | Počáteční stav účtu
Má dáti | Obrat strany MD
Dal | Obrat strany Dal
Konečný stav | Konečný stav účtu
Stránka #2 Hlavní kniha
Mřížka [Hlavní kniha]
Druh | Druh informace skutečnost, plán ...
Období | Rok ve kterém došlo k pohybu
 | Měsíc, ve kterém došlo k pohybu
Účet | Identifikátor účtu účetnictví
Měna | Kód měny - oceňovací jednotky.
 | Cizojazyčný popis účtu.
 | Strana účtu MD/Dal
Obch.s. | Identifikátor obchodního selektoru
 | Název obchodního selektoru
Org.s. | Identifikátor organizačního selektoru.
 | Název organizačního selektoru
Tech.s. | Identifikátor technicko-věcného selektoru.
 | Název technicko-věcného selektoru.
Počáteční stav | Počáteční stav účtu
Má dáti | Obrat strany MD
Dal | Obrat strany Dal
Konečný stav | Konečný stav účtu
Stránka #3 Výběr
Druh | Druh informace skutečnost, plán ...
Rok | Rok ve kterém došlo k pohybu
Měsíc | Měsíc, ve kterém došlo k pohybu
Účet | Identifikátor účtu účetnictví
 | Cizojazyčný popis účtu.
Měna | Kód měny - oceňovací jednotky.
Obch. sel. | Identifikátor obchodního selektoru
 | Název obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
 | Název organizačního selektoru
Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Název technicko-věcného selektoru.
Zobrazit | Zobrazit - Vše/Nenulový obrat/Nenulový obrat plánovaný
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Konta se selektory] činnosti - Obchodní selektor

    Mřížka [Konta se selektory] činnosti - Obchodní selektor
Rok | Rok ve kterém došlo k pohybu
Měsíc | Měsíc, ve kterém došlo k pohybu
Účet | Identifikátor účtu účetnictví
Strana | Strana účtu MD/Dal
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Počáteční stav | Počáteční stav účtu
Má dáti | Obrat strany MD
Dal | Obrat strany Dal
Konečný stav | Konečný stav účtu
Měna | Kód měny - oceňovací jednotky.
Druh | Druh informace skutečnost, plán ...

    Mřížka [Hlavní kniha] činnosti - Obchodní selektor

    Mřížka [Hlavní kniha] činnosti - Obchodní selektor
Datum | Datum účetního případu
Má dáti | Má dáti
Dal | Dal
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh operace | Identifikátor druhu operace
Popis události | Popis účetní události
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
IDP | Identifikace párování
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Atributy tisku

    Základní údaje
Druh | Druh informace skutečnost, plán ... | Výpočet | C(10)
Rok | Rok ve kterém došlo k pohybu | UCKONTOS_uc03rok | C(4)
Měsíc | Měsíc, ve kterém došlo k pohybu | UCKONTOS_uc03mesic | C(2)
Účet | Identifikátor účtu účetnictví | UCKONTOS_uc01id | C(9)
Měna | Kód měny - oceňovací jednotky. | UCKONTOS_oc01id | C(3)
Popis protiúčtu | Cizojazyčný popis účtu. | UCROZVRN_uc04popuct | C(40)
Org. sel. | Identifikátor organizačního selektoru. | UCKONTOS_sp11idzak | C(9)
Název organizačního selektoru | Název organizačního selektoru | SPSEOR_sp11text | C(60)
Počáteční stav | Počáteční stav účtu | UCKONTOS_uc03psvyk | N(20,4)
Má dáti | Obrat strany MD | UCKONTOS_uc03mdr | N(20,4)
Dal | Obrat strany Dal | UCKONTOS_uc03dalr | N(20,4)
Konečný stav | Konečný stav účtu | UCKONTOS_uc03ksvyk | N(20,4)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)

    Při pohybu v Deník
Datum | Datum účetního případu | UCDENIK_uc02datum | D
Druh události | Plánovaná/Ujednaná/Realizovaná událost | Výpočet | C(11)
Strana | Strana účtu MD/Dal | Výpočet | C(7)
Částka | Finanční částka | UCDENIK_uc02castka | N(20,4)
Druh | Fáze události v účetním období - otevření, běžná, uzavření | UCDENIK_uc02faze | N(1)
Platnost | Platnost účtu - platný, stornovaný, stornující | UCDENIK_uc02platno | N(1)
Popis události | Popis účetní události | UCDENIK_uc02popuda | C(40)
Adresát | Identifikace adresáta | UCDENIK_ad01id | C(6)
Datum a čas zápisu | Datum a čas zápisu záznamu události | UCDENIK_sp00datzap | T
Druh operace | Identifikátor druhu operace | UCDENIK_sp07idtyp | C(6)
Org. sel. | Identifikátor organizačního selektoru. | UCDENIK_sp11idzak | C(9)
Jiné párování | Záznam byl saldokontně párován importem | Výpočet | C(3)
Měna | Kód měny - oceňovací jednotky. | UCDENIK_oc01id | C(3)
Referenční měna | Referenční měna | UCDENIK_oc01id1 | C(3)
Částka ZM | Částka v zahraniční měně | UCDENIK_uc02castkz | N(20,4)
IDP | Identifikace párování | UCDENIK_uc15parid | C(14)
Pořadí | Pořadí stejného druhu operace v jednom procesu | UCDENIK_sp33porad | N(2)
Komponenta | Identifikace komponenty | UCDENIK_sp06idsubs | C(3)
Rok | Rok v identifikaci procesu | UCDENIK_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | UCDENIK_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | UCDENIK_sp33cisd | C(8)

    Viz.také

    Spustit operaci | Výpočet sumy stran | INFORMACE K ÚČTU | Měny a kursy | Obchodní selektor | Organizační selektor | Technicko-věcný selektor | Účtový rozvrh


Účtový rozvrh

Popis

Účtový rozvrh je při dodávce informačního systému z větší části naplněný. Každý uživatel si může účtový rozvrh (zejména jeho analytickou část) upravit podle vlastních firemních zvyklostí. U každého účtu se zadává jeho jednoznačná identifikace, název, strana (Má dáti nebo Dal, podle toho, zda je účet aktivní či pasivní), saldokontní (možnosti jsou Ano/Ne) a zda sledovat obrat v zahraniční měně (možnosti jsou Ano/Ne). Dalším atributem s možnou volbou Ano/Ne je „povinná částka v ZM“. Pro účty s nastavením tohoto atributu na Ano nelze zadat událost účetního deníku s daným účtem s nulovou částkou v zahraniční měně.

Při zápisu do účetního deníku systém provádí kontrolu na účtový rozvrh a v případě, že se jedná o saldokontní účet, zaeviduje částku korektní hodnotou do účetního saldokonta. Aktuální hodnoty saldokonta jsou k dispozici u každého saldokontního účtu (pravý stisk myši na tučném atributu účet).

Jako další se nabízí atributy, které určují, zda se selektor uvedený na události účetnictví daného účtu promítá do obratové tabulky. Jsou to:

¨ sledovat obrat obchodního selektoru Ano/Ne

¨ sledovat obrat organizačního selektoru Ano/Ne

¨ sledovat obrat technicko-věcného selektoru Ano/Ne

Nejvhodnější se jeví používat sledování obratu za organizační selektor (v podstatě umožňuje sledovat obraty za střediska), sledování obratů za ostatní selektory by značným způsobem rozšiřovalo (a tím znepřehlednilo) hodnoty obratové tabulky. Přesto v případě, že uživatel provede jakoukoliv změnu v nastavení tohoto sledování obratů, je nutno provést přepočet obratové tabulky účetnictví.

Další vlastností, kterou je možnost nastavit pro každý účet účtového rozvrhu je:

¨ povinnost uvádět obchodní selektor v událostech účetnictví pro účet – volba Ano/Ne

¨ povinnost uvádět organizační selektor v událostech účetnictví pro účet – volba Ano/Ne

¨ povinnost uvádět technicko-věcný selektor v událostech účetnictví pro účet – volba Ano/Ne

Pokud je pro daný účet nastavena povinnost uvádět selektor v událostech účetnictví, pak při vytváření událostí účetnictví nebude možné zapsat událost s hodnotou selektoru neurčeno (‘-’).

U každého účtu je navíc možno nastavit datum jeho platnosti od - do. Pokud je toto datum u účtu nastaveno, je možno s tímto účtem aktivně pracovat pouze v tomto uvedeném období. Je možno využívat tento účet při přípravě předkontací, ale účtování je systémem kontrolováno na nastavené období platnosti. Pokud není nastavena žádná platnost účtu, není jeho používání samozřejmě ničím omezeno.

Na záložce „cizojazyčné“ je možno mít uvedeny názvy účtů v cizím jazyce.

Datový model

  • UCROZVRH Účet z rozvrhu
    • UCROZVRN Cizí popis účtu
    • BWUZIVAT Uživatel systému

    • Vyvolávané činnosti

    K. | Činnost | Popis
^U | INFORMACE K ÚČTU | Skupina činností souvisejících s číslem účtu.
F2 | Státy | Seznam států.

    Formulář

    Formulář činnosti - INFORMACE K ÚČTU
Mřížka [Účtový rozvrh]
Listovací rámeček
Stránka #1 Rozvrh
Účet | Identifikátor účtu účetnictví
Text | Cizojazyčný popis účtu.
Strana | Strana účtu MD/Dal
Saldokontní | Jedná se o saldokontní účet Ano/Ne
Obrat v ZM | Sledovat obrat v zahraniční měně Ano/Ne
Povinná částka v ZM | Povinnost uvádět nenulovou částku v ZM v událostech účetnictví pro účet Ano/Ne
Obrat obchodního selektoru | Sledovat obrat obchodního selektoru Ano/Ne
Povinný OBS | Povinnost uvádět obchodní selektor v událostech účetnictví pro účet Ano/Ne
Obrat organizačního selektoru | Sledovat obrat organizačního selektoru Ano/Ne
Povinný ORS | Povinnost uvádět organizační selektor v událostech účetnictví pro účet Ano/Ne
Obrat tech.-věcného selektoru | Sledovat obrat technicko-věcného selektoru Ano/Ne
Povinný TVS | Povinnost uvádět technicko-věcný selektor v událostech účetnictví pro účet Ano/Ne
Platný od | Začátek platnosti účtu
Platný do | Konec platnosti účtu
Komentář | Komentář upřesňující používání účtu
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Cizojazyčné
Mřížka [Cizojazyčné]
Jazyk | Identifikace jazyka
Text | Cizojazyčný popis účtu.
Stránka #3 Výběr
Účet | Identifikátor účtu účetnictví
Text | Cizojazyčný popis účtu.
Strana | Strana účtu MD/Dal
Saldokontní | Jedná se o saldokontní účet Ano/Ne
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 | Platnost nebo neplatnost k datu
Zapsal | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Účtový rozvrh] činnosti - INFORMACE K ÚČTU

    Mřížka [Účtový rozvrh] činnosti - INFORMACE K ÚČTU
Účet | Identifikátor účtu účetnictví
Text | Cizojazyčný popis účtu.
Strana | Strana účtu MD/Dal
Saldokontní | Jedná se o saldokontní účet Ano/Ne
Obrat v ZM | Sledovat obrat v zahraniční měně Ano/Ne
Obrat obch.sel. | Sledovat obrat obchodního selektoru Ano/Ne
Obrat org.sel. | Sledovat obrat organizačního selektoru Ano/Ne
Povinný OBS | Povinnost uvádět obchodní selektor v událostech účetnictví pro účet Ano/Ne
Povinný ORS | Povinnost uvádět organizační selektor v událostech účetnictví pro účet Ano/Ne
Povinný TVS | Povinnost uvádět technicko-věcný selektor v událostech účetnictví pro účet Ano/Ne
Obrat tech.sel. | Sledovat obrat technicko-věcného selektoru Ano/Ne
Platný od | Začátek platnosti účtu
Platný do | Konec platnosti účtu

    Mřížka [Cizojazyčné] činnosti - INFORMACE K ÚČTU

    Mřížka [Cizojazyčné] činnosti - INFORMACE K ÚČTU
Jazyk | Identifikace jazyka
Text | Cizojazyčný popis účtu.

    Atributy tisku

    Základní údaje
Identifikátor účtu | Identifikátor účtu účetnictví | UCROZVRH_uc01id | C(9)
Popis účtu | Cizojazyčný popis účtu. | UCROZVRN_uc04popuct | C(40)
Strana účtu | Strana účtu MD/Dal | Výpočet | C(3)
Příznak saldokontního účtu | Jedná se o saldokontní účet Ano/Ne | Výpočet | C(3)
Obrat v ZM | Sledovat obrat v zahraniční měně Ano/Ne | Výpočet | C(3)
Povinný obrat v ZM | Povinnost uvádět nenulový obrat v ZM v událostech účetnictví pro účet Ano/Ne | Výpočet | C(3)
Obrat obchodního selektoru | Sledovat obrat obchodního selektoru Ano/Ne | Výpočet | C(3)
Obrat organizačního selektoru | Sledovat obrat organizačního selektoru Ano/Ne | Výpočet | C(3)
Obrat tech.-věcného selektoru | Sledovat obrat technicko-věcného selektoru Ano/Ne | Výpočet | C(3)
Povinný OBS | Povinnost uvádět obchodní selektor v událostech účetnictví pro účet Ano/Ne | Výpočet | C(3)
Povinný ORS | Povinnost uvádět organizační selektor v událostech účetnictví pro účet Ano/Ne | Výpočet | C(3)
Povinný TVS | Povinnost uvádět technicko-věcný selektor v událostech účetnictví pro účet Ano/Ne | Výpočet | C(3)
Platnost účtu od | Začátek platnosti účtu | UCROZVRH_uc01datzac | D
Platnost účtu do | Konec platnosti účtu | UCROZVRH_uc01datkon | D
Komentář | Komentář upřesňující používání účtu | UCROZVRH_uc01koment | M
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | UCROZVRH_sp00datzap | T

    Viz.také

    INFORMACE K ÚČTU | Státy


VÝKAZY ÚČETNICTVÍ

Popis

Účetní výkazy, které se v podniku vyhotovují, se liší svým obsahem v závislosti na tom, pro kterou kategorii uživatelů účetních informací jsou určeny a jaký účel plní. Z tohoto pohledu lze rozdělit účetní výkazy na finanční a vnitropodnikové. Finanční (externí) účetní výkazy představují výstupní informace systému účetnictví a tvoří podstatu účetní závěrky. Jejím smyslem je také prokázat, jak firma hospodaří; je nedílnou součástí skládání účtů, tzv. výročních zpráv o firmě.

Účetní závěrka je sestavována k poslednímu dni účetního období (běžně 1 rok). Nejdůležitějšími účetními výkazy účetní závěrky jsou rozvaha (bilance), výkaz zisků a ztrát (výsledovka) a příloha, v níž jsou vysvětlovány a rozváděny jednotlivé položky rozvahy a výsledovky. Poskytují celkový přehled o stavu a struktuře majetku podniku a zdrojů jeho krytí, o tvorbě a rozdělení hospodářského výsledku.

Kromě množství analytických přehledů, grafických pohledů a sestav je velká část požadavků na informace z účetnictví kladena na legislativně povinné výkazy (Rozvaha, Výkaz zisku a ztráty, apod.) a Přiznání k DPH. Obě tyto oblasti jsou řešeny úzkou vazbou na MS Excel s možností tvorby výkazů vlastních, včetně cizojazyčných.

Datový model

  • UCDRUHV Druh výkazu

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


SPECIÁLNÍ ČINNOSTI

Popis

Jedná se o speciální činnosti komponenty účetnictví. K dispozici zde jsou činnosti, které se neprovádějí standardně jako běžná součást účtování, ale používají se při výjimečných příležitostech (přepočty) nebo při nastavení jednou ročně (parametry a účetní období).

Viz.také

Definice výkazů účetnictví | Přepočet obratové tabulky | Přepočet účetního saldokonta | Parametry účetnictví | Účetní období


Definice výkazů účetnictví

Popis

Jedná se o výkazy, které uživateli poskytují přehled o jednotlivých vykonaných činnostech z hlediska účetního pohledu. Některé výkazy jsou již dodávané společně s distribucí informačního systému, jiné si uživatel vytvoří sám.

Formulář

Formulář činnosti - Kopie listu
a

Vyvolávané činnosti

K. | Činnost | Popis
F3 | Nový druh výkazu |
- | Export výkazu do balíčku |
- | Export listu výkazu do balíčku |
- | Kopie listu |

Viz.také

Nový druh výkazu | Export výkazu do balíčku | Export listu výkazu do balíčku | Kopie listu | Struktura listu | Výpočet výkazu | Zadej datum


Přepočet obratové tabulky

Popis

Přepočet obratové tabulky je vhodné aktivovat po změně strany účtu v účetním rozvrhu. Je k dispozici v hlavním menu - účetnictví - speciální činnosti. Po spuštění této činnosti je uživatel dotázán na rok, za který chce provádět přepočet, ten si vybere z překryvného seznamu a pak je systémem ještě znovu položen dotaz, zda opravdu provést přepočet. Po potvrzení volby Ano je proveden přepočet obratové tabulky.

Přepočet obratové tabulky blokuje možnost zápisu událostí do účetního deníku po dobu přepočtu. Po ukončení přepočtu je možno zápis do účetního deníku dokončit obvyklým způsobem.

Formulář

Formulář činnosti - Kopie listu
Období Identifikace účetního období


Přepočet účetního saldokonta

Popis

Tuto činnost mají uživatelé k dispozici pod menu Účetnictví – Speciální činnosti. Používají ji zcela výjimečně a to v případech, kdy během účetního období nesaldokontní účet označí v účtovém rozvrhu jako saldokontní a pak je vhodné hodnoty tohoto účtu znovu přepočítat. Právě k tomu účelu slouží činnost přepočet účetního saldokonta.

Formulář

Formulář činnosti - Kopie listu
IDP | Identifikace párování
Účet | Identifikátor účtu účetnictví


Parametry účetnictví

Popis

Parametry účetnictví musí mít uživatel vyplněné před vlastním zahájením práce s komponentou účetnictví. Jedná se o parametry:

¨ povolit účtování do budoucna – při zaškrtnutí tohoto příznaku je povoleno v událostech účetního deníku zadat datum do budoucna. Pokud příznak povolen není a uživatel v událostech zadá datum do budoucna, systém upozorňuje: „datum události musí být menší nebo rovno dnešnímu datu“ a taková událost nejde zapsat

¨ povolit na účetním dokladu záznamy jednoho měsíce – při zatržení tohoto příznaku je hlídáno, aby při zápisu událostí do účetního deníku byla data aktuálního dokladu ve stejném měsíci. Pokud jsou události zapisovány s daty různých měsíců, systém upozorňuje: „události v rámci aktuálního dokladu nemají shodné datum zápisu“ a doklad nejde zapsat.

Informace o funkci šablon a importu v účetnictví:

¨ šablona otevření účetních knih otevírá účty třídy 0 až 4. Je nutno vytvořit pouze jeden doklad, tzn. že bude existovat pouze jeden proces otevření těchto účtů v každém účetním období

¨ šablona uzavření účetních knih uzavírá účty třídy 0 až 4. Je nutno vytvořit pouze jeden doklad, tzn. že bude existovat pouze jeden proces uzavření těchto účtů v každém účetním období

¨ import otevření či uzavření podrozvahových účtů otevírá či uzavírá účty třídy 75 až 79. Je nutno vytvořit pouze jeden doklad, tzn. že bude existovat pouze jeden proces pro otevření či uzavření těchto účtů v každém účetním období

Doporučení:

Společnosti pracující s podrozvahovými účty by měly používat při uzavírání a otevírání podrozvahových účtů import vytvořený k tomuto účelu (tzn. proces otevření nebo uzavření účetních knih – volby Obecné – Import/Export – a výběr činnosti „Otevření“ nebo „Uzavření“ podrozvahových účtů).

Formulář

Formulář činnosti - Druhy operací
Povolit účtování do budoucna | Povolit účtování do budoucna
Povolit na účetním dokladu záznamy jednoho měsíce | Povolit na účetním dokladu záznamy jednoho měsíce

Vyvolávané činnosti

K. | Činnost | Popis
F2 | Druhy operací | Přehled druhů operací
F2 | Státy | Seznam států.

Viz.také

Druhy operací | Státy


Účetní období

Popis

IS BM umožňuje definovat účetní období intervalem začínajícím rokem a měsícem počátku a končícím rokem a měsícem konce účetního období. Účetní období je nadefinováno zápisem s atributy rok, název, rok a měsíc od a rok a měsíc do. Atributy otevřeno a uzavřeno nesouvisí přímo s definicí účetního období, ale s otevřením nebo uzavřením účetních knih, tzn. pro účely definice účetního období je uživatel nechává prázdné, nic nezaškrtává.

Takto definované období je klíčem v obratové tabulce, přičemž se odvozuje z data události, která nesmí být mimo definovaná období.

Oba atributy (otevřeno/uzavřeno) si tedy nastavuje uživatel ručně. Do období, které má zde nastaven stav uzavřeno, nelze zapsat událost. Období, které zde má nastaveno (tzn. zatrženo) stav otevřeno, se automaticky nenabízí v šabloně pro otevření účetních knih, proto dokud není provedeno otevření účetních knih, uživatel atribut otevřeno nechává prázdný, nezatrhává ho. Období, které má nastaveno otevřeno a není současně uzavřeno, se automaticky nabízí v šabloně pro uzavření účetních knih.

V případě, že uživatel zapisuje události (účetní zápisy) do účetního deníku a současně má podle systému nějakou nesrovnalost v nastavení účetních období, tak systém při zápisu do účetního deníku může hlásit tyto chybové hlášky:

- „Pokus o zápis do nedefinovaného účetního období“ – kontrolní hláška, která se objeví při zápisu události. Upozorňuje uživatele, že v činnosti účetní období nemá nadefinované období pro dané datum (systém toto hlásí např. v případě, že uživatel zadává účetní případ s lednovým datem roku 2008 a přitom nemá v činnosti účetní období nadefinován řádek s rokem 2008).

- „Pokus o zápis do uzavřeného účetního období“ - kontrolní hláška, která se objeví při zápisu události. Upozorňuje uživatele, že v činnosti účetní období má období, kam spadá daný datum na události, již uzavřeno.

Datový model

  • UCOBDOBI Účetní období

    • Formulář

    Formulář činnosti - Předplň účetní období
Mřížka [Období]
Období | Identifikace účetního období
 | Název účetního období
Rok od | Rok otevření účetního období
Měsíc od | Měsíc otevření účetního období
Rok do | Rok uzavření účetního období
Měsíc do | Měsíc uzavření účetního období
Otevřeno | Příznak otevřeného účetního období
Uzavřeno | Příznak uzavřeného účetního období
Poznámka | Poznámka

    Mřížka [Období] činnosti - Předplň účetní období

    Mřížka [Období] činnosti - Předplň účetní období
Období | Identifikace účetního období
Název období | Název účetního období
Otevřeno | Příznak otevřeného účetního období
Uzavřeno | Příznak uzavřeného účetního období
Rok od | Rok otevření účetního období
Měsíc od | Měsíc otevření účetního období
Rok do | Rok uzavření účetního období
Měsíc do | Měsíc uzavření účetního období

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Předplň účetní období |

    Atributy tisku

    Základní údaje
Období | Identifikace účetního období | UCOBDOBI_uc37id | C(6)
Název období | Název účetního období | UCOBDOBI_uc37nazobd | C(40)
Rok od | Rok otevření účetního období | UCOBDOBI_uc37rok1 | C(4)
Rok do | Rok uzavření účetního období | UCOBDOBI_uc37rok2 | C(4)
Měsíc od | Měsíc otevření účetního období | UCOBDOBI_uc37mesic1 | C(2)
Měsíc do | Měsíc uzavření účetního období | UCOBDOBI_uc37mesic2 | C(2)
Otevřeno | Příznak otevřeného účetního období | Výpočet | C(3)
Uzavřeno | Příznak uzavřeného účetního období | Výpočet | C(3)
Poznámka | Poznámka | UCOBDOBI_uc37koment | M

    Viz.také

    Předplň účetní období


OBCHOD

Popis

Komponenta OBCHOD umožňuje příjem a dodávku obchodovatelných artiklů a evidenci obchodovatelných artiklů. Dodávky jsou charakterizovány datem dodávky, dodávaným artiklem, množstvím tohoto artiklu v určité měrné jednotce (včetně přepočtu na referenční měrnou jednotku), cenou dodávky, včetně případných slev ve měně, ve které je platba dodávky realizována (včetně přepočtu ceny dodávky na referenční měnu), sazbou a částkou DPH a odběratelem a příjemcem.

Viz.také

Událost obchodu | Aktuální hodnoty obchodu | Obchodovatelný artikl | Vztahy obchodovatelných artiklů k adresátům | Umístění - distr. kanál | Cenové skupiny | Ceník artiklu | Katalog zboží | Propojení operací skladu | Parametry obchodu | Definice výrazů označování | Celní sazebník | Sazby celního sazebníku


Událost obchodu

Popis

Událost obchodu sdružuje každou "plánovanou, ujednanou nebo realizovanou" dodávku konkrétního obchodního artiklu. Může se jednat o objednávku, potvrzení objednávky, předběžnou dodávku, skutečnou dodávku apod. Dodávkou se rozumí jak převzetí zboží od dodavatele, tak dodání zboží odběrateli. Jednotlivé události obchodu se nevstupují samostatně, ale pouze v rámci operace obchodu určitého konkrétního typu procesu.

Vytvořené události obchodu v této činnosti slouží pouze pro prohlížení. Po spuštění této činnosti má uživatel nejprve možnost zvolit si nadefinováním výběru způsob zobrazení přehledu událostí obchodu. Po stisku klávesy F9 lze každou jednotlivou událost aktivovat. Po stisku CTRL S (tj. Sumy – obchod) je zobrazena celková částka zobrazených událostí.

Činnost událost obchodu obsahuje tyto atributy:

¨ rok v identifikaci procesu

¨ identifikace datového úložiště číselné řady procesu

¨ pořadové číslo procesu

¨ identifikátor druhu operace

¨ pořadí stejného druhu operace v procesu

¨ objednávka - příznak, zda jde o objednávku přijatou / vydanou.

¨ název druhu procesu

¨ datum - datum vystavení události obchodovatelného artiklu (musí být vyplněno). Je předplněn aktuální datum. Lze jej změnit kliknutím pravého tlačítka myši.

¨ dodání - je předplněn datum dodání obchodovatelného artiklu (musí být vyplněno). Lze jej změnit kliknutím pravého tlačítka myši. V nastavení parametrů IS BM je možno zvolit, které datum bude převedeno do účetnictví jako datum uskutečnění zdanitelného plnění.

¨ popis - popis události obchodovatelného artiklu (musí být vyplněno).

¨ odb./dod. - identifikace adresáta (odběratel / dodavatel). Lze vybrat z adresáře klávesou F2. Číslo spojení adresáta je možno vybrat z číselníku spojení adresáta klávesou F2. (Oba tyto atributy musí být vyplněny). Sám se doplní název adresáta.

¨ příjemce - identifikace importovaného adresáta. Lze vybrat z adresáře klávesou F2. Číslo spojení adresáta - lze vybrat z číselníku spojení adresáta klávesou F2. (Oba tyto atributy musí být vyplněny). Sám se doplní název adresáta.

¨ čárový kód

¨ výrobní číslo

¨ artikl - identifikace druhu artiklu (musí být uvedeno). Lze vybrat ze seznamu druhů artiklů klávesou F2.

¨ identifikace artiklu (musí být vyplněno). Lze vybrat ze seznamu obchodovatelného artiklu klávesou F2. Automaticky se doplní název artiklu.

¨ umístění - identifikace umístění obchodu - distribučního kanálu (musí být vyplněno). Lze vybrat ze seznamu klávesou F2.

¨ typ zd. pl. - identifikace typu zdanitelného plnění (musí být uvedeno). Lze vybrat ze seznamu klávesou F2.

¨ identifikace typu místa zdanitelného plnění (musí být uvedeno). Lze vybrat ze seznamu klávesou F2.

¨ způsob uplatnění odpočtu daně - 1=100%, 2=0%, 3=kráceno

¨ identifikace předmětu zdanitelného plnění - uživateli se nabízí možné předměty zdan. plnění v souvislosti s kombinací předmět - jeho uplatnění - místo zdanitelného plnění a zadání údajů na artiklu. V podstatě pouze pro možnost, že adresát je plátce DPH v tuzemsku se automaticky předplňuje předmět "nerozhoduje", jinak je nutno správný předmět na události vybrat.

¨ měna - kód měny - oceňovací jednotky (musí být vyplněno). Lze vybrat ze seznamu klávesou F2. Kód referenční měny se vyplní automaticky z parametrů oceňování.

¨ kurs - kurz oceňovací jednotky vůči referenční měně. Pokud k aktuálnímu dni kurz existuje, předplní se tento. Toto platí jen, je-li v parametrech oceňování zaškrtnuto Předplňovat kurz pouze, je-li aktuální. Jinak se předplní poslední nejnovější kurz. Množství oceňovací jednotky v kurzu se předplní automaticky.

¨ vztah k účetnictví - vztah artiklu k účetnictví (např. zboží, materiál, služba, výrobek, ....)

¨ obchodní smlouva - číslo obchodní smlouvy.

¨ klasifikace - identifikace a název klasifikace objektu

¨ množství - množství obchodovatelného artiklu. Jedná se o množství artiklu v jednotce uvedené v události obchodního plnění. Pokud se tento atribut nevyplní, bude automaticky dopočten po zadání Množství ref. MJ.

¨ identifikátor měrné jednotky

¨ množství ref. MJ - množství obchodovatelného artiklu v referenční měrné jednotce (musí být vyplněno). Jedná se o množství artiklu v primární jednotce artiklu, uvedené na obchodní kartě artiklu. Tento atribut se automaticky dopočte po zadání Množství.

¨ identifikátor referenční měrné jednotky

¨ typ ceny - identifikace typu ceníkové ceny (musí být uvedeno). Lze vybrat ze seznamu klávesou F2. Předplnění cenové skupiny při vstupu události obchodu je možné podle adresáta nebo podle příjemce uvedeného na události. Převažující nastavení pro všechny události obchodu se provádí v činnosti Nastavení BM – menu Systém, v sekci obchod. Pro určení cenové skupiny podle příjemce je nastaveno ‚cen_skp_podle_adresata=0’ nebo ‚cen_skp_podle_adresata=1’, tj. pro určení cenové skupiny podle adresáta – default. Kromě toho je možné definovat toto nastavení různě pro vybrané druhy událostí komponenty obchod v parametrech operace komponenty obchod (menu Informační centrum – Typy a řady – Druhy operací – pod menu Volby činnost Parametry operace komponenty.

¨ CJ - kód měny - oceňovací jednotky (musí být uvedeno).

¨ identifikátor měrné jednotky (musí být uvedeno).

¨ cena ceníková celkem za měrnou jednotku v oceňovací jednotce [služba + artikl] (musí být uvedeno). Skládá se z ceny vlastního artiklu a ceny ostatních nákladů, které jsou s artiklem spojeny (např. doprava, montáž apod). Někdy je vhodné z praktických důvodů cenu služby započítat do ceny artiklu. Pokud tato cena, vztažená k měně za měrnou jednotku, existuje, předplní se cena z ceníku. Jinak se musí zadat ručně.

¨ sleva % - sleva uvedená v procentech.

Na záložce „Další informace“ jsou pak k dispozici tyto údaje:

¨ po slevě / jedn. - celková cena za jednotku po slevě. Po zadání slevy se automaticky vypočte.

¨ celková cena slevy za jednotku. Pokud se zadá sleva v procentech, sama se vypočte celková cena slevy za jednotku. A naopak. Zadáte-li celkovou cenu slevy za jednotku a není vyplněna sleva v procentech, procenta se sami vypočtou.

¨ aktualizovat ceník - pokud je tento příznak volný, cena za jednotku cenu ceníkovou se v ceníku nepřepíše a i při příštím zadávání se v událostech obchodu objeví tato ceníková cena. V případě, že je příznak aktualizovat ceník zaškrtnutý, je současná cena v ceníku přepsána aktuální cenou za jednotku (ta se tím pádem stává novou ceníkovou cenou).

¨ volné číslo

¨ poznámka - libovolná poznámka.

¨ cena celkem po slevě za artikl v oceňovací jednotce. Automaticky se vypočte.

¨ cena celkem po slevě za ostatní náklady v oceňovací jednotce. Automaticky se vypočte.

¨ vztah ceny k DPH – určení způsobu výpočtu ceny a DPH v dalších atributech – může být nastaveno – cena bez DPH (pak je základ bez DPH a DPH dopočteno samostatně), cena včetně DPH (pak základ už obsahuje i částku DPH a částka DPH je pouze vyčíslena), cena včetně DPH z rozdílu nákladů a konečné ceny (tato varianta se používá především v kombinaci s komisním prodejem zboží)

¨ spojená cena – souvisí se vztahem ceny k DPH – cena včetně DPH z rozdílu nákladů a konečné ceny

¨ základ DPH v ZM - částka základu daně z přidané hodnoty v zahraniční měně. Pokud se tato položka nevyplní, bude automaticky vypočtena po zadání Základu DPH v RM.

¨ DPH v ZM - částka daně z přidané hodnoty v zahraniční měně. Pokud se tato položka nevyplní, bude automaticky vypočtena po zadání DPH v RM.

¨ základ DPH v RM - částka základu daně z přidané hodnoty v referenční měně (musí být vyplněno). Pokud byly předchozí částky vyplněny, je tato položka vyplněna automaticky.

¨ DPH v RM - částka daně z přidané hodnoty v referenční měně. Tato částka se automaticky vypočte po zadání základu DPH v RM.

¨ pořadí – pořadové číslo události v dané operaci obchodu. Je možné ho libovolně opravovat. Po spuštění založené operace obchodu jsou její události zobrazené podle tohoto pořadí (pokud není určeno jiné setřídění). Pořadí události lze využít také jako atribut tisku v předlohách výstupu (OB02PORADI)

¨ selektory - zadávají se : obchodní selektor, organizační selektor a technicko-věcný selektor. Každý selektor lze vybrat z číselníku klávesou F2.

¨ zapsal - jméno uživatele systému

¨ datum a čas zápisu záznamu - skutečný čas

Datový model

  • OBUDAL Událost obchodního plnění
    • OBCENSKP Cenová skupina obchodovatelného artiklu
    • SPPRISTU Přístupové právo uživatele k věci
    • OBARTIKL Obchodovatelný artikl
    • ADSPOJ Spojení adresáta
      • ADADSAT Adresát
      • ADADR Adresa
    • SPPRCOD Operace procesu
      • SPTYP Druh procesu/operace
      • SPPRC Proces
    • BWUZIVAT Uživatel systému
    • PAOBJDRU Klasifikace objektu
    • ADSPOJ Spojení adresáta (alias ADSPOJ1)
      • ADADSAT Adresát (alias ADADSAT1)
      • ADADR Adresa (alias ADADR1)
    • OBUMIST Umístění - distribuční kanál
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Označení - obchod | Označení událostí ochodu podle podmínky
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^S | SUMy - obchod |
- | Ukončit operaci nepředběžně | Ukončení předběžně ukončené operace obchodu
- | Hromadná změna slevy | Hromadná změna slevy
F2 | Adresář | Přehled adresátů
F2 | Cenové skupiny | Přehled cenových skupin obchodovatelného artiklu
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Klasifikace objektů | Klasifikace objektů
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Měrné jednotky | Číselník měrných jednotek
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Obchodovatelný artikl | Seznam obchodovatelných artiklů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Předměty zdanitelného plnění | Předměty zdanitelného plnění
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Typ zdanitelného plnění | Číselník typů zdanitelného plnění
F2 | Umístění - distr. kanál | Umístění - distribuční kanál

    Formulář

    Formulář činnosti - Předměty zdanitelného plnění
Mřížka [Události obchodu]
Listovací rámeček
Stránka #1 Událost obchodu
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
 | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Objednávka nebo DL přijatý/vydaný
 | Název druhu procesu
Datum | Datum události obch. artiklu - může řídit číselnou řadu procesu
Dodání | Datum dodání obchodovatelného artiklu
Popis | Popis události o obchodovatelném artiklu
Odb./dod. | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
Příjemce | Identifikace importovaného adresáta
 | Číslo spojení adresáta.
 | Název adresáta
ČK | Čárový kód obchodovatelného artiklu
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
VČ | Výrobní číslo
 | Název artiklu
Umístění | Identifikace umístění obchodu - distribučního kanálu
 | Název umístění obchodu - distribučního kanálu
TZP | Identifikace typu zdanitelného plnění
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie ....
Uplatnění odpočtu daně | Způsob uplatnění odpočtu daně - 1=100%,2=0%,3=kráceno
Předmět | Identifikace předmětu zdanitelného plnění
Měna | Kód měny - oceňovací jednotky.
 | Referenční měna
Kurs | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup.
 | Množství oceňovací jednotky v kursu.
Vztah k účet. | Vztah k účetnictví - zboží, materiál, výrobek, služba ...
Obch. smlouva | Číslo obchodní smlouvy
Klasifikace | Identifikace klasifikace objektu
Název klasifikace objektu | Název klasifikace objektu
Množství | Množství obchodovatelného artiklu
 | Identifikátor měrné jednotky
MJ | Identifikátor měrné jednotky
Množství ref. MJ | Množství obchodovatelného artiklu v referenční měrné jednotce
Skupina | Identifikace cenové skupiny
 | Název cenové skupiny
 | Stav události - rezervováno,nerezervováno
 | Kód měny - oceňovací jednotky.
 | Identifikátor měrné jednotky
CJ | Cena ceníková celkem za měrnou jednotku v oceňovací jednotce (služba + artikl)
Sleva % | Sleva uvedená v procentech
 | Hodnota slevy za jednotku celková
 | Stav události - neurčeno, nevykrytá objednávka, vykrytá objednávka
Stránka #2 Další informace
Po slevě/jedn. | Cena za jednotku po slevě celková
Volné číslo | Volné číslo
 | Cena bez daně po slevě za artikl
 | Cena bez daně po slevě za ostatní náklady
Celková cena | Celková cena
Sazba | Procentní sazba daně z přidané hodnoty
Vztah ceny k DPH | Vztah ceny artiklu k DPH - cena bez DPH,cena včetně DPH, cena včetně DPH z rozdílu nákladů a konečné ceny
Spojená cena | Spojená cena
Základ DPH v ZM | Částka základu daně z přidané hodnoty v ZM - odpočet
DPH v ZM | Částka daně z přidané hodnoty v zahraniční měně - odpočet
Základ DPH v RM | Částka základu daně z přidané hodnoty v referenční měně
DPH v RM | Částka daně z přidané hodnoty v referenční měně
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Aktualizovat ceník | Událost aktualizuje ceník
Pozn. | Poznámka k události obchodu
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Pořadí | Pořadí události v operaci
Stránka #3 Účetnictví
Mřížka [Účetnictví]
Stránka #4 Výběr událostí obchodu
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu od
Číslo procesu do | Pořadové číslo procesu do
 | Identifikátor druhu operace
Druh procesu | Identifikátor druhu procesu
Datum | Datum
do | Datum do
 | Vybrat události příjmu, výdeje objednávek a dodacích listů nebo všechny
Popis | Popis události o obchodovatelném artiklu
Odb./dod. | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Příjemce | Identifikace adresáta
Spojení | Číslo spojení adresáta.
 | Název adresáta
Kategorie | Identifikace kategorie
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
ČK | Čárový kód obchodovatelného artiklu
Mn. ref. | Množství obchodovatelného artiklu v referenční měrné jednotce
MJ | Identifikátor měrné jednotky
Měna | Kód měny - oceňovací jednotky.
Umístění | Identifikace umístění obchodu - distribučního kanálu
Stav | Stav události - neurčeno, nevykrytá objednávka, vykrytá objednávka
Vztah k účet. | Vztah k účetnictví - zboží, materiál, výrobek, služba ...
Uplatnění odpočtu daně | Způsob uplatnění odpočtu daně - 1=100%,2=0%,3=kráceno
Účet.sel. | Účetní selektor artiklu
Klasif. | Identifikace klasifikace objektu
VČ | Výrobní číslo
Skupina | Identifikace cenové skupiny
OS | Číslo obchodní smlouvy
Vztah ceny k DPH | Vztah ceny artiklu k DPH - cena bez DPH,cena včetně DPH, cena včetně DPH z rozdílu nákladů a konečné ceny
Celková cena od | Celková cena od
do | Celková cena do
Typ zd.pl. | Identifikace typu zdanitelného plnění
Předmět | Identifikace předmětu zdanitelného plnění
Typ místa | Výběr podle typu místa - všechna, tuzemsko, zahraničí, Evropská Unie ....
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsal | Identifikace uživatele systému
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Události obchodu] činnosti - Předměty zdanitelného plnění

    Mřížka [Události obchodu] činnosti - Předměty zdanitelného plnění
Označování | Označení záznamu
P/V | Objednávka nebo DL přijatý/vydaný
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Datum | Datum události obch. artiklu - může řídit číselnou řadu procesu
Dodání | Datum dodání obchodovatelného artiklu
Množství | Množství obchodovatelného artiklu
Množství ref. MJ | Množství obchodovatelného artiklu v referenční měrné jednotce
CJ | Cena ceníková celkem za měrnou jednotku v oceňovací jednotce (služba + artikl)
MJ | Identifikátor měrné jednotky
Základ DPH v ZM | Částka základu daně z přidané hodnoty v ZM - odpočet
DPH v ZM | Částka daně z přidané hodnoty v zahraniční měně - odpočet
Základ DPH v RM | Částka základu daně z přidané hodnoty v referenční měně
DPH v RM | Částka daně z přidané hodnoty v referenční měně
Popis události | Popis události o obchodovatelném artiklu
Typ zd.pl. | Identifikace typu zdanitelného plnění
Typ místa | Identifikace typu místa zdanitelného plnění
Měna | Kód měny - oceňovací jednotky.
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Umístění | Identifikace umístění obchodu - distribučního kanálu
OS | Číslo obchodní smlouvy
Čárový kód | Čárový kód obchodovatelného artiklu
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
VČ | Výrobní číslo
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Základ DPH+DPH (ZM) | Základ DPH v ZM + DPH v ZM
Základ DPH+DPH (RM) | Základ DPH v RM + DPH v RM

    Mřížka [Účetnictví] činnosti - Předměty zdanitelného plnění

    Mřížka [Účetnictví] činnosti - Předměty zdanitelného plnění
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Datum | Datum účetního případu
Účet | Identifikátor účtu účetnictví
Strana | Strana účtu MD/Dal
Částka | Finanční částka
Popis události | Popis účetní události
Částka ZM | Částka v zahraniční měně
IDP | Identifikace párování
Org. sel. | Identifikátor organizačního selektoru.

    Atributy tisku

    Základní údaje
Rok | Rok v identifikaci procesu | OBUDAL_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | OBUDAL_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | OBUDAL_sp33cisd | C(8)
Druh operace | Identifikátor druhu operace | OBUDAL_sp07idtyp | C(6)
Komponenta | Identifikace komponenty | OBUDAL_sp06idsubs | C(3)
Pořadí | Pořadí stejného druhu operace v jednom procesu | OBUDAL_sp33porad | N(2)
Název druhu operace | Název druhu procesu | SPTYP_sp07text | C(30)
PO/VO/PDL/VDL | Objednávka nebo DL přijatý/vydaný | Výpočet | C(8)
Datum | Datum události obch. artiklu - může řídit číselnou řadu procesu | OBUDAL_ob02dat | D
Dodání | Datum dodání obchodovatelného artiklu | OBUDAL_ob02datdod | D
Adresát | Identifikace adresáta | OBUDAL_ad01id | C(6)
Adresát1 | Identifikace importovaného adresáta | OBUDAL_ad01id1 | C(6)
Popis | Popis události o obchodovatelném artiklu | OBUDAL_ob02text | C(40)
Obchodní smlouva | Číslo obchodní smlouvy | OBUDAL_ob02hs | C(20)
Klasifikace | Identifikace klasifikace objektu | OBUDAL_pa13id | C(12)
Název klasifikace objektu | Název klasifikace objektu | PAOBJDRU_pa13nazdru | C(40)
Množství | Množství obchodovatelného artiklu | OBUDAL_ob02mn | N(20,4)
Měrná jednotka | Identifikátor měrné jednotky | OBUDAL_sp24idmj | C(3)
Měrná jednotka - referenční | Identifikátor měrné jednotky | OBUDAL_sp24idmj1 | C(3)
CJ | Cena ceníková celkem za měrnou jednotku v oceňovací jednotce (služba + artikl) | OBUDAL_ob02cj01c | N(20,6)
Měna - ceníku | Kód měny - oceňovací jednotky. | OBUDAL_oc01id2 | C(3)
Sleva % | Sleva uvedená v procentech | OBUDAL_ob02sleva | N(7,2)
Hodnota slevy | Hodnota slevy za jednotku celková | Výpočet | N(20,4)
Po slevě/jedn. | Cena za jednotku po slevě celková | OBUDAL_ob02cj01 | N(20,6)
Celkem bez daně artikl | Cena bez daně po slevě za artikl | OBUDAL_ob02cc02 | N(20,4)
Celkem bez daně ostatní | Cena bez daně po slevě za ostatní náklady | OBUDAL_ob02cc03 | N(20,4)
Celková cena | Celková cena | Výpočet | N(20,4)
Vztah ceny k DPH | Vztah ceny artiklu k DPH - cena bez DPH,cena včetně DPH, cena včetně DPH z rozdílu nákladů a konečné ceny | Výpočet | C(23)
Spojená cena | Spojená cena | OBUDAL_ob02cnakl | N(20,4)
Měna | Kód měny - oceňovací jednotky. | OBUDAL_oc01id | C(3)
Kurs | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup. | OBUDAL_oc03kurz | N(20,6)
Množství | Množství oceňovací jednotky v kursu. | OBUDAL_oc03mn | N(5)
Množství ref. MJ | Množství obchodovatelného artiklu v referenční měrné jednotce | OBUDAL_ob02mnr | N(20,4)
Typ zd.pl. | Identifikace typu zdanitelného plnění | OBUDAL_dp03id | C(3)
Uplatnění odpočtu daně | Způsob uplatnění odpočtu daně - 1=100%,2=0%,3=kráceno | Výpočet | C(1)
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie .... | Výpočet | C(9)
Sazba DPH | Procentní sazba daně z přidané hodnoty | OBUDAL_dp02sazba | N(5,2)
Základ DPH v ZM | Částka základu daně z přidané hodnoty v ZM - odpočet | OBUDAL_dp02czazm | N(20,4)
DPH v ZM | Částka daně z přidané hodnoty v zahraniční měně - odpočet | OBUDAL_dp02cdpzm | N(20,4)
Základ DPH v RM | Částka základu daně z přidané hodnoty v referenční měně | OBUDAL_dp02czarm | N(20,4)
DPH v RM | Částka daně z přidané hodnoty v referenční měně | OBUDAL_dp02cdprm | N(20,4)
Volné číslo | Volné číslo | OBUDAL_ob02volna | N(20,4)
Pozn. | Poznámka k události obchodu | OBUDAL_ob02koment | M
Obch. sel. | Identifikátor obchodního selektoru | OBUDAL_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | OBUDAL_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | OBUDAL_sp20idzak | C(9)
Druh artiklu | Identifikace druhu artiklu | OBARTIKL_sp61id | C(3)
Artikl | Identifikace artiklu | OBARTIKL_sp60id | C(13)
Název artiklu | Název artiklu | OBARTIKL_sp60artikl | C(60)
VČ | Výrobní číslo | OBUDAL_ob02vc | C(32)
Skladovatelnost | Charakter artiklu - skladovaný, neskladovaný | OBARTIKL_ob01sklado | N(1)
Komentář k artiklu | Komentář k obchodovatelnému artiklu | OBARTIKL_ob01koment | M
Čárový kód | Čárový kód obchodovatelného artiklu | OBARTIKL_ob01carkod | C(36)
Externí identifikace | Externí identifikace obchodovatelného artiklu | OBARTIKL_ob01exid | C(20)
Volné číslo I | Volně použitelné číslo | OBARTIKL_ob01cislo1 | N(20,4)
Volné číslo II | Volně použitelné číslo | OBARTIKL_ob01cislo2 | N(20,4)
Volný text I | Volně použitelný text | OBARTIKL_ob01text1 | C(40)
Volný text II | Volně použitelný text | OBARTIKL_ob01text2 | C(40)
Volné datum I | Volně použitelné datum | OBARTIKL_ob01dat1 | D
Volné datum II | Volně použitelné datum | OBARTIKL_ob01dat2 | D
Účetní selektor artiklu | Účetní selektor artiklu | OBARTIKL_sp00uselar | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | OBARTIKL_sp20idzak | C(9)
Vlastní adresa | Název adresáta | ADADSATVL_ad01adsat | C(100)
Úplný název adresáta | Úplný název adresáta | ADADSATVL_ad01adsat2 | M
IČO | Identifikační číslo organizace. | ADADSATVL_ad01ico | C(10)
DIČ | Daňové identifikační číslo adresáta. | ADADSATVL_ad01dico | C(16)
Základní jmění | Základní jmění | ADADSATVL_ad01zakljm | N(20,4)
Identifikace v OR | Obchodní rejstřík - údaj o zápisu v OR včetně spisové značky | ADADSATVL_ad01volne1 | M
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADRVL_ad02ulice | C(40)
Město | Město adresy adresáta. | ADADRVL_ad02mesto | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADRVL_ad13psc | C(10)
Stát | Identifikace státu. | ADADRVL_ad05id | C(3)
Název státu | Název státu. | ADSTATYVL_ad05stat | C(30)
UTO | Národní směrové číslo státu pro telefonní spojení (UTO). | ADSPOJVL_ad13nsc | C(4)
Volané telefonní číslo | Telefonní číslo | ADSPOJVL_ad11cislo | C(60)
Jméno kontaktní osoby | Jméno kontaktní osoby. | ADSPOJVL_ad11jmeno | C(40)
Komentář ke spojení | Komentář ke spojení | ADSPOJVL_ad11pozn | M
Adresa partnera | Název adresáta | ADADSAT_ad01adsat | C(100)
Úplný název partnera | Úplný název adresáta | ADADSAT_ad01adsat2 | M
IČO | Identifikační číslo organizace. | ADADSAT_ad01ico | C(10)
DIČ | Daňové identifikační číslo adresáta. | ADADSAT_ad01dico | C(16)
Základní jmění | Základní jmění | ADADSAT_ad01zakljm | N(20,4)
Identifikace v OR | Obchodní rejstřík - údaj o zápisu v OR včetně spisové značky | ADADSAT_ad01volne1 | M
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Stát | Identifikace státu. | ADADR_ad05id | C(3)
Název státu | Název státu. | ADSTATY_ad05stat | C(30)
UTO | Národní směrové číslo státu pro telefonní spojení (UTO). | ADSPOJ_ad13nsc | C(4)
Volané telefonní číslo | Telefonní číslo | ADSPOJ_ad11cislo | C(60)
Jméno kontaktní osoby | Jméno kontaktní osoby. | ADSPOJ_ad11jmeno | C(40)
Komentář ke spojení | Komentář ke spojení | ADSPOJ_ad11pozn | M
Název příjemce | Název adresáta | ADADSAT1_ad01adsat | C(100)
Úplný název příjemce | Úplný název adresáta | ADADSAT1_ad01adsat2 | M
IČO | Identifikační číslo organizace. | ADADSAT1_ad01ico | C(10)
DIČ | Daňové identifikační číslo adresáta. | ADADSAT1_ad01dico | C(16)
Základní jmění | Základní jmění | ADADSAT1_ad01zakljm | N(20,4)
Identifikace v OR | Obchodní rejstřík - údaj o zápisu v OR včetně spisové značky | ADADSAT1_ad01volne1 | M
Datum a čas zápisu | Datum a čas zápisu záznamu události | OBUDAL_sp00datzap | T

    Viz.také

    Označení - obchod | OZNAČOVÁNÍ | SUMy - obchod | Ukončit operaci nepředběžně | Hromadná změna slevy | Adresář | Cenové skupiny | Druhy artiklů | Druhy operací | Druhy procesů | Kategorie adresátů | Klasifikace objektů | Měny a kursy | Měrné jednotky | Obchodní selektor | Obchodovatelný artikl | Organizační selektor | Předměty zdanitelného plnění | Spojení adresátů | Technicko-věcný selektor | Typ zdanitelného plnění | Umístění - distr. kanál | Artikly skladu | Parametry operací - obchod | Progr. šablona.- podklad pro | Progr.šabl. - nenulové artikly | Progr.šabl. - nenulový sklad


Aktuální hodnoty obchodu

Popis

Na základě zadaného výběru (tzn. výběr vyfiltrován např. za adresáta, druh artiklu, umístění atd.) má uživatel k dispozici aktuální hodnoty obchodu. Jedná se o hodnoty, které se definují v informačním centru v činnosti komponenty. Může se jednat o hodnotu např. tržby jednotlivého artiklu, množství apod.

Pak má po potvrzení výběru uživatel k dispozici částky aktuálních hodnot podle zadaného výběru. V horní části formuláře je přehled jednotlivých aktuálních hodnot, ve spodní části formuláře jsou informace vždy jen k dané aktuální hodnotě (tzn. k té, na které je umístěn kurzor).

Datový model

  • OBAH Aktuální hodnota obchodu
    • OBARTIKL Obchodovatelný artikl
    • ADADSAT Adresát
    • SPSTATDI Druh hodnoty
    • SPPRISTU Přístupové právo uživatele k věci
    • OBUMIST Umístění - distribuční kanál

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Události správy artiklu |
- | Legenda palety barev |
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Obchodovatelný artikl | Seznam obchodovatelných artiklů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Palety barev kategorií | Palety barev kategorií
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Umístění - distr. kanál | Umístění - distribuční kanál

    Formulář

    Formulář činnosti - Legenda palety barev
Mřížka [Aktuální hodnoty]
Listovací rámeček
Stránka #1 Aktuální hodnoty
Druh hodnoty | Identifikace druhu hodnoty
 | Název druhu hodnoty
Adresát | Identifikace adresáta
 | Název adresáta
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Umístění | Identifikace umístění obchodu - distribučního kanálu
 | Název umístění obchodu - distribučního kanálu
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Hodnota | Hodnota
Stránka #2 Výběr
Druh hodnoty | Identifikace druhu hodnoty
Paleta | Vybrat záznamy všech kategorií v paletě
 | Identifikace palety barev
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Umístění | Identifikace umístění obchodu - distribučního kanálu
 | Název umístění obchodu - distribučního kanálu
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Aktuální hodnoty] činnosti - Legenda palety barev

    Mřížka [Aktuální hodnoty] činnosti - Legenda palety barev
Druh hodnoty | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Adresát | Identifikace adresáta
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Umístění | Identifikace umístění obchodu - distribučního kanálu
Hodnota | Hodnota
Název adresáta | Název adresáta
Název artiklu | Název artiklu
Název umístění | Název umístění obchodu - distribučního kanálu

    Atributy tisku

    Základní údaje
Druh hodnoty | Identifikace druhu hodnoty | OBAH_sp67id | C(3)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)
Adresát | Identifikace adresáta | OBAH_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Druh artiklu | Identifikace druhu artiklu | OBAH_sp61id | C(3)
Artikl | Identifikace artiklu | OBAH_sp60id | C(13)
Název artiklu | Název artiklu | OBARTIKL_sp60artikl | C(60)
Umístění | Identifikace umístění obchodu - distribučního kanálu | OBAH_ob05id | C(6)
Název umístění | Název umístění obchodu - distribučního kanálu | OBUMIST_ob05text | C(40)
Hodnota | Hodnota | OBAH_ob02hodnot | N(20,4)
Obch. sel. | Identifikátor obchodního selektoru | ADADSAT_sp10idzak | C(9)
Název obchodního selektoru | Název obchodního selektoru | SPSEOB_sp10text | C(40)
Název organizačního selektoru | Název organizačního selektoru | SPSEOR_sp11text | C(40)
Org. sel. | Identifikátor organizačního selektoru. | OBUMIST_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | OBARTIKL_sp20idzak | C(9)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(40)

    Viz.také

    Události správy artiklu | Legenda palety barev | Adresář | Druhy artiklů | Druhy hodnot | Kategorie adresátů | Obchodní selektor | Obchodovatelný artikl | Organizační selektor | Palety barev kategorií | Technicko-věcný selektor | Umístění - distr. kanál


Obchodovatelný artikl

Popis

Tato činnost slouží k definici a přehledu obchodovatelného artiklu, tzn. artiklu, který se v informačním systému BM vstupuje v událostech obchodu. Může se tudíž jednat o artikl skladovaný (výrobky, zboží), o spravovaný majetek, investiční majetek, ale i o přijímané či dodávané služby, tedy artikl, který není sledován skladem apod.

Po spuštění činnosti má uživatel nejprve možnost zvolit si nadefinováním výběru množinu zobrazených artiklů.

Při vkládání, opravě nebo prohlížení karet artiklu jsou k dispozici tyto hodnoty:

¨ artikl - identifikace druhu artiklu (musí být vyplněno). Lze vybrat ze seznamu druhů artiklu klávesou F2. Pak vlastní identifikace artiklu.

¨ název artiklu - název artiklu

¨ externí identifikace

¨ ČK - pokud se používá při práci čtečka, zadává se zde čárový kód artiklu, tzn. že čárový kód na událostech obchodu a skladu se vstupuje právě proto, aby se podle něj automaticky předplnil artikl, např. právě při použití čtečky čárového kódu. Pro rozšiřující identifikátor artiklu (např. šarži) je určen na událostech obchodu a skladu atribut výrobní číslo.

¨ klasifikace artiklu - identifikace klasifikace objektu artiklu

¨ charakter - zda se jedná o artikl skladovaný (materiál, zboží) či neskladovaný (služby)

¨ kód CZ-CPA - identifikace klasifikace produkce (dřívější označení SKP). Pokud uživatel nechce zadávat, vybírá možnost neurčeno.

¨ MJ - identifikátor měrné jednotky. Jedná se o měrnou jednotku, která se uvádí na událostech obchodu (tzn. v dodacích listech, objednávkách apod.)

¨ typ zd. pl. - typ zdanitelného plnění. Lze vybrat ze seznamu typů zdan. plnění a určuje jakým způsobem se daný artikl daní, zda se jedná o základní či sníženou daň apod.

¨ vztah k účetnictví - jaký vztah k účetnictví zaujímá daný artikl. Může to být materiál, zboží, výrobek - uživatel má možnost si vybrat z překryvného seznamu, který je v případě potřeby ještě možno rozšířit.

¨ vztah ceny k DPH - určuje, jakým způsobem se u daného artiklu na událostech vstupuje cena. Pokud se zadá cena, tak jestli už je to cena, která je včetně DPH nebo je nutno DPH ještě dopočítat.

¨ CS - identifikace a název položky celního sazebníku vztahujícího se k danému artiklu

¨ technicko-věcný selektor - identifikátor technicko - věcného selektoru. Určuje, jaké činnosti v organizaci se daný artikl týká.

¨ účetní selektor - zadává se zde přímo hodnota účtu, na který se daný artikl účtuje

¨ stav - může být aktuální či neaktuální. Ve většině případů bude určitě aktuální, v případě, že uživatel nechce artikl již používat a on nelze zrušit, protože již byl použit, nastaví u něj právě příznak neaktuální.

¨ povolena nulová cena - tento artikl je možno v událostech vstupovat s nulovou cenou, jinak musí být cena vždy uvedena.

Na formuláři má uživatel k dispozici řadu dalších záložek, které mu poskytují podrobnější informace o daném obchodovatelném artiklu. Jako první se nabízí záložka "Rozš. údaje", kde je k dispozici několik volných polí na využití zcela podle uvážení uživatele. Důležitým atributem na této záložce je „kód předmětu plnění“.

Další záložka je "Ceny". Ta obsahuje informace o jednotlivých skupinách cen za artikl a u každé skupiny se eviduje období, za které je cena platná a výše ceny v Kč. Záložka "Historie cen" poskytuje uživateli přehled jak se jednotlivé ceny cenových skupin utvářely v čase. Atribut "platnost do" poskytuje uživateli informaci o systémovém datu, kdy došlo ke změně ceny v ceníku (tzn. kdy byla změna opravdu zapsána. Nejedná se o datum události, kterou se cena v ceníku mění, ale o datum zápisu dané události). K evidenci historie ceny u jednotlivých artiklů dochází na základě toho, zda je u obecného artiklu zaškrtnuto "historie ceny". Změnu ceny v ceníku je možno provést přepisem ceny a nebo pomocí události (na událostech zaškrtnutý atribut aktualizovat cenu).

Záložka "Názvy artiklu" umožňuje přeložit název artiklu do cizího jazyka, kde je nutno vždy uvést identifikaci cizího jazyka a název artiklu v daném jazyce.

Informace o aktuálních hodnotách, tzn. o těch hodnotách, které jsou nadefinované v informačním centru u komponenty obchod (např. naturální a finanční vyjádření skladu) poskytuje uživateli záložka "Aktuální hodnoty".

Na záložce "Vztah MJ obch. art." uživatel definuje vztah měrných jednotek, tzn. měrné jednotky referenční a ostatní měrné jednotky, např. kg - m, kusy - balení apod.

Záložka „Kategorie“ poskytuje uživateli přehled, v jaké kategorii je případně artikl zařazen (s tím je spojena i informace o době platnosti daného artiklu v kategorii).

Na funkční klávesu (nebo činnosti pod menu Volby) je možno vyvolat i ceník artiklu.

Všechny údaje ze záložek i ceník lze vyvolat ihned souhrnně po stisku pravého tlačítka myši na tučně zvýrazněné položce "artikl". Uživateli se nabízí všechny činnosti, které ho mohou v souvislosti s artiklem zajímat nebo které bude při své práci potřebovat.

Na základě zvolení Palety na záložce Výběr je možno přehled artiklů zvýraznit i barevně.

Datový model

  • OBARTIKL Obchodovatelný artikl
    • SPARTIKL Artikl
    • OBCELSAZ Položka celního sazebníku
    • PAOBJDRU Klasifikace objektu (alias PAOBJDRU2)
    • SPARTIKN Název artiklu
    • SPARTIKD Druh artiklu
    • SPMJ Měrná jednotka
      • SPMJN Měrná jednotka v jazyce
    • SPSETV Technicko-věcný selektor
    • SPSKP SKP
    • DPZPT Typ zdanitelného plnění
    • BWUZIVAT Uživatel systému

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Ceník artiklu | Ceník obchodovatelných artiklů
F6 | Události správy artiklu |
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
- | Dokumenty artiklu | Dokumenty artiklu
- | Legenda palety barev |
F2 | Adresář | Přehled adresátů
F2 | Celní sazebník | Prohlížení a editace celního sazebníku
F2 | Cenová období | Výběr cenového období
F2 | Cenové skupiny | Přehled cenových skupin obchodovatelného artiklu
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Kategorie událostí správy artiklu | Přehled kategorií událostí správy artiklu
F2 | Klasifikace objektů | Klasifikace objektů
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Měrné jednotky | Číselník měrných jednotek
F2 | Palety barev kategorií | Palety barev kategorií
F2 | Spojení | Seznam spojení za adresáta.
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Typ zdanitelného plnění | Číselník typů zdanitelného plnění
F2 | Třídy SKP | Třídy Standardní klasifikace produkce
F2 | Účtový rozvrh | Seznam syntetických a analytických účtů.

    Formulář

     | Formulář činnosti - Spojení
 | Mřížka [Obchodovatelný artikl]
 |  | Identifikace druhu artiklu
 | Artikl | Identifikace artiklu
 | Listovací rámeček
 | Stránka #1 Artikl
 |  | Název artiklu
 | Externí identifikace | Externí identifikace obchodovatelného artiklu
 | ČK | Čárový kód obchodovatelného artiklu
 | Klasifikace artiklu | Identifikace klasifikace objektu artiklu
 | Charakter | Charakter artiklu - skladovaný, neskladovaný
 | Třída SKP | Identifikace třídy Standardní klasifikace produkce.
 |  | Název kategorie Standardní klasifikace produkce.
 | Měrná jednotka | Identifikátor měrné jednotky
 |  | Název měrné jednotky
 | Typ zd.pl. | Identifikace typu zdanitelného plnění
 |  | Název typu zdanitelného plnění
 | Vztah k účetnictví | Vztah k účetnictví - zboží, materiál, výrobek, služba ...
 | Vztah ceny k DPH | Vztah ceny artiklu k DPH - cena bez DPH,cena včetně DPH, cena včetně DPH z rozdílu nákladů a konečné ceny
 | CS | Identifikace položky celního sazebníku.
 | Název položky celního sazebníku | Název položky celního sazebníku.
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 |  | Název technicko-věcného selektoru.
 | Účet.sel. | Účetní selektor artiklu
 | Stav | Aktuální/ neaktuální
 | Povolena nulová cena | Povolena nulová cena v událostech o artiklu
 | Stránka #2 Rozš.údaje
 | Klasif. OBC | Předplňovaná klasifikace na události obchodu
 | Název klasifikace objektu | Název klasifikace objektu
 | Volné číslo I | Volně použitelné číslo
 | Volné číslo II | Volně použitelné číslo
 | Volný text I | Volně použitelný text
 | Volný text II | Volně použitelný text
 | Volné datum I | Volně použitelné datum
 |  | Volně použitelné datum
 | Komentář k artiklu | Komentář k obchodovatelnému artiklu
 | Založil | Jméno uživatele systému
 |  | Datum a čas zápisu záznamu události
 | Stránka #3 Ceny
 | Mřížka [Ceny artiklu]
 | Skupina | Identifikace cenové skupiny
 |  | Název cenové skupiny
 | Období | Identifikace cenového období
 |  | Název cenového období
 |  | Datum platnosti od
 |  | Datum platnosti do
 | MJ | Identifikátor měrné jednotky
 |  | Název měrné jednotky
 | Měna | Kód měny - oceňovací jednotky.
 |  | Název měny
 | CJ - artikl | Cena ceníková za artikl za měrnou jednotku v oceňovací jednotce
 | CJ - ostatní nákl. | Cena ceníková ostatních nákladů za měrnou jednotku v oceňovací jednotce
 | CJ - celkem | Cena ceníková celkem za měrnou jednotku v oceňovací jednotce (služba + artikl)
 | Sleva % | Sleva uvedená v procentech
 | Stránka #4 Historie cen
 | Mřížka [Historie cen]
 | Platnost do | Datum platnosti ceny - do
 | Příznak | Příznak historické ceny
 | CJ - artikl | Cena ceníková za artikl za měrnou jednotku v oceňovací jednotce
 | CJ - ostatní nákl. | Cena ceníková ostatních nákladů za měrnou jednotku v oceňovací jednotce
 | CJ - celkem | Cena ceníková celkem za měrnou jednotku v oceňovací jednotce (služba + artikl)
 | Sleva % | Sleva uvedená v procentech
 | Stránka #5 Názvy artiklu
 | Mřížka [Názvy artiklu v jazycích]
 | Jazyk | Identifikace jazyka
 | Název artiklu | Název artiklu
 | Stránka #6 Aktuální hodnoty
 | Mřížka [Akt. hodnota]
 | Hodnota | Hodnota
 | Název | Název druhu hodnoty
 | Stránka #7 Vztah MJ obch. art.
 | Mřížka [Vztah mj ud. obch. art.]
 | MJ | Identifikátor měrné jednotky
 |  | Název měrné jednotky
 | := | Vztah měrných jednotek
 | MJ | Identifikátor měrné jednotky
 |  | Název měrné jednotky
 | Stránka #8 Kategorie
 | Mřížka [Kategorie artiklu]
 |  | Kategorie
Identifikace kategorie události správy artiklu |  |  | Platnost
Datum platnosti od |  |  | Platnost do
Datum platnosti do |  |  | Adresát
Identifikace adresáta |  |
Název adresáta |  |
Číslo spojení adresáta. |  |  | Popis
Popis události |  |  | Poznámka
Poznámka |  |  | Zapsal
Jméno uživatele systému |  |  | Datum a čas zápisu
Datum a čas zápisu záznamu události
 | Stránka #9 Výběr
 | Druh artiklu | Identifikace druhu artiklu
 | Artikl | Identifikace artiklu
 | Název artiklu | Název artiklu
 | Typ zd.pl. | Identifikace typu zdanitelného plnění
 | MJ | Identifikátor měrné jednotky
 | CS | Identifikace položky celního sazebníku.
 | Stav | Aktuální/ neaktuální
 | Vztah k účetnictví | Vztah k účetnictví - zboží, materiál, výrobek, služba ...
 | Skladovatelnost | Charakter artiklu - skladovaný, neskladovaný
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Účetní selektor artiklu | Účetní selektor artiklu
 | Čárový kód | Čárový kód obchodovatelného artiklu
 | Vztah ke kategorii | Vztah ke kategorii - Je=K dnešnímu datu je v kategorii, Není=K dnešnímu datu není v kategorii, Byl=Není v kategorii, ale byl, Nebyl=Není a nikdy nebyl v kategorii,Bude=Bude v kategorii
 | Kategorie | Identifikace kategorie události správy artiklu
 | Název kategorie | Název kategorie události správy artiklu
 | Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 |  | Platnost nebo neplatnost k datu
 | Paleta | Vybrat záznamy všech kategorií v paletě
 | Paleta | Identifikace palety barev
 | Výběr | Určení výběru
 | Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Obchodovatelný artikl] činnosti - Spojení

    Mřížka [Obchodovatelný artikl] činnosti - Spojení
Označování | Označení záznamu
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Typ zdanitelného plnění | Identifikace typu zdanitelného plnění
Čárový kód | Čárový kód obchodovatelného artiklu
Tech. sel. | Identifikátor technicko-věcného selektoru.
Externí identifikace | Externí identifikace obchodovatelného artiklu
Třída SKP | Identifikace třídy Standardní klasifikace produkce.
MJ | Identifikátor měrné jednotky

    Mřížka [Ceny artiklu] činnosti - Spojení

    Mřížka [Ceny artiklu] činnosti - Spojení
Skupina | Identifikace cenové skupiny
Období | Identifikace cenového období
MJ | Identifikátor měrné jednotky
Měna | Kód měny - oceňovací jednotky.
CJ - celkem | Cena ceníková celkem za měrnou jednotku v oceňovací jednotce (služba + artikl)
CJ - artikl | Cena ceníková za artikl za měrnou jednotku v oceňovací jednotce
CJ - ostatní nákl. | Cena ceníková ostatních nákladů za měrnou jednotku v oceňovací jednotce
Datum platnosti od | Datum platnosti od

    Mřížka [Historie cen] činnosti - Spojení

    Mřížka [Historie cen] činnosti - Spojení
Platnost do | Datum platnosti ceny - do
Skupina | Identifikace cenové skupiny
Období | Identifikace cenového období
MJ | Identifikátor měrné jednotky
Měna | Kód měny - oceňovací jednotky.
CJ - artikl | Cena ceníková za artikl za měrnou jednotku v oceňovací jednotce
 | Cena ceníková ostatních nákladů za měrnou jednotku v oceňovací jednotce

    Mřížka [Názvy artiklu v jazycích] činnosti - Spojení

    Mřížka [Názvy artiklu v jazycích] činnosti - Spojení
Jazyk | Identifikace jazyka
Název artiklu | Název artiklu

    Mřížka [Akt. hodnota] činnosti - Spojení

    Mřížka [Akt. hodnota] činnosti - Spojení
Adresát | Identifikace adresáta
Umístění | Identifikace umístění obchodu - distribučního kanálu
Hodnota | Hodnota
Název druhu hodnoty | Název druhu hodnoty

    Mřížka [Vztah mj ud. obch. art.] činnosti - Spojení

    Mřížka [Vztah mj ud. obch. art.] činnosti - Spojení
MJ | Identifikátor měrné jednotky
MJ | Identifikátor měrné jednotky
Vztah | Vztah měrných jednotek
Název měrné jednotky | Název měrné jednotky
Název měrné jednotky | Název měrné jednotky

    Mřížka [Kategorie artiklu] činnosti - Spojení

    Mřížka [Kategorie artiklu] činnosti - Spojení
Kategorie | Identifikace kategorie události správy artiklu
Název kategorie | Název kategorie události správy artiklu
Platnost od | Datum platnosti od
Platnost do | Datum platnosti do
Adresát | Identifikace adresáta
Název adresáta | Název adresáta

    Atributy tisku

    Základní údaje
Druh artiklu | Identifikace druhu artiklu | OBARTIKL_sp61id | C(3)
Artikl | Identifikace artiklu | OBARTIKL_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Charakter | Charakter artiklu - skladovaný, neskladovaný | Výpočet | C(12)
Čárový kód | Čárový kód obchodovatelného artiklu | OBARTIKL_ob01carkod | C(36)
Měrná jednotka | Identifikátor měrné jednotky | OBARTIKL_sp24idmj | C(3)
Typ zd.pl. | Identifikace typu zdanitelného plnění | OBARTIKL_dp03id | C(3)
Vztah k účetnictví | Vztah k účetnictví - zboží, materiál, výrobek, služba ... | Výpočet | C(8)
Vztah ceny k DPH | Vztah ceny artiklu k DPH - cena bez DPH,cena včetně DPH, cena včetně DPH z rozdílu nákladů a konečné ceny | Výpočet | C(23)
Stav | Aktuální/ neaktuální | Výpočet | C(10)
CS | Identifikace položky celního sazebníku. | OBARTIKL_ob25id | C(10)
Název položky celního sazebníku | Název položky celního sazebníku. | OBCELSAZ_ob25nazpol | C(100)
Tech. sel. | Identifikátor technicko-věcného selektoru. | OBARTIKL_sp20idzak | C(9)
Klasifikace artiklu | Identifikace klasifikace objektu artiklu | OBARTIKL_pa13idart | C(12)
Název klasifikace objektu | Název klasifikace objektu | PAOBJDRU_pa13nazdru | C(40)
Klasif. OBC | Identifikace klasifikace objektu | OBARTIKL_pa13id | C(12)
Název klasifikace objektu | Název klasifikace objektu | PAOBJDRU2_pa13nazdru | C(40)
Komentář k artiklu | Komentář k obchodovatelnému artiklu | OBARTIKL_ob01koment | M
Externí identifikace | Externí identifikace obchodovatelného artiklu | OBARTIKL_ob01exid | C(20)
Volné číslo I | Volně použitelné číslo | OBARTIKL_ob01cislo1 | N(20,4)
Volné číslo II | Volně použitelné číslo | OBARTIKL_ob01cislo2 | N(20,4)
Volný text I | Volně použitelný text | OBARTIKL_ob01text1 | C(40)
Volný text II | Volně použitelný text | OBARTIKL_ob01text2 | C(40)
Volné datum I | Volně použitelné datum | OBARTIKL_ob01dat1 | D
Volné datum II | Volně použitelné datum | OBARTIKL_ob01dat2 | D
Název cenové skupiny | Název cenové skupiny | OBCENSKP_ob11nazcsk | C(40)
Typ ceny | Typ ceny Prodejní,Nákupní,Skladová,Ostatní | Výpočet | C(8)
Název cenového období | Název cenového období | OBCENOBD_ob12nazcob | C(40)
Datum platnosti od | Datum platnosti od | OBCENOBD_ob12datum | D
Název měrné jednotky | Název měrné jednotky | SPMJN4_sp58mjnaz | C(40)
Název měny | Název měny | OCMENA_oc01nazev | C(18)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)

    Při pohybu v Aktuální hodnoty
Druh hodnoty | Identifikace druhu hodnoty | OBAH_sp67id | C(3)
Adresát | Identifikace adresáta | OBAH_ad01id | C(6)
Umístění | Identifikace umístění obchodu - distribučního kanálu | OBAH_ob05id | C(6)
Hodnota | Hodnota | OBAH_ob02hodnot | N(20,4)

    Při pohybu v Historie ceny
Platnost do | Datum platnosti ceny - do | OBCENHIS_ob15datum | D
Skupina | Identifikace cenové skupiny | OBCENHIS_ob11id | C(3)
Období | Identifikace cenového období | OBCENHIS_ob12id | C(3)
MJ | Identifikátor měrné jednotky | OBCENHIS_sp24idmj | C(3)
Měna | Kód měny - oceňovací jednotky. | OBCENHIS_oc01id | C(3)
CJ - celkem | Cena ceníková celkem za měrnou jednotku v oceňovací jednotce (služba + artikl) | Výpočet | N(20,6)
CJ - artikl | Cena ceníková za artikl za měrnou jednotku v oceňovací jednotce | OBCENHIS_ob15cj02 | N(20,6)
CJ - ostatní nákl. | Cena ceníková ostatních nákladů za měrnou jednotku v oceňovací jednotce | OBCENHIS_ob15cj03 | N(20,6)

    Při pohybu v Ceny artiklu
Skupina | Identifikace cenové skupiny | OBCENIK_ob11id | C(3)
Období | Identifikace cenového období | OBCENIK_ob12id | C(3)
MJ | Identifikátor měrné jednotky | OBCENIK_sp24idmj | C(3)
Měna | Kód měny - oceňovací jednotky. | OBCENIK_oc01id | C(3)
CJ - artikl | Cena ceníková za artikl za měrnou jednotku v oceňovací jednotce | OBCENIK_ob03cj02 | N(20,6)
CJ - ostatní nákl. | Cena ceníková ostatních nákladů za měrnou jednotku v oceňovací jednotce | OBCENIK_ob03cj03 | N(20,6)
CJ - celkem | Cena ceníková celkem za měrnou jednotku v oceňovací jednotce (služba + artikl) | Výpočet | N(20,6)
Sleva % | Sleva uvedená v procentech | OBCENIK_ob03sleva | N(7,2)

    Viz.také

    Ceník artiklu | Události správy artiklu | OZNAČOVÁNÍ | Prezentace artiklu | Dokumenty artiklu | Legenda palety barev | Adresář | Celní sazebník | Cenová období | Cenové skupiny | Druhy artiklů | Kategorie událostí správy artiklu | Klasifikace objektů | Měny a kursy | Měrné jednotky | Palety barev kategorií | Spojení | Technicko-věcný selektor | Typ zdanitelného plnění | Třídy SKP | Účtový rozvrh


Vztahy obchodovatelných artiklů k adresátům

Popis

Činnost „vztahy obchodovatelných artiklů k adresátům“ umožňuje uživateli nadefinovat si u každého jednotlivého adresáta informace k danému obchodovatelnému artiklu, především to, jak je ve vztahu k danému adresátovi artikl identifikován (identifikace, název, objednací číslo apod.).

Příkladem použití může být situace, kdy uživatel má zadány obchodovatelné artikly s určitou identifikací a názvem a jeho dodavatel pro vybrané artikly chce používat např. jiný název nebo jiné objednací číslo.

U každého vztahu se zadávají tyto základní údaje:

¨ sada – identifikace sady, která vztah definuje

¨ priorita – hodnota od 1 do 10, přičemž čím nižší číslo, tím je priorita větší

¨ artikl – identifikace obchodovatelného artiklu (druh, vlastní identifikace a název)

¨ adresát – identifikace adresáta, jehož se nadefinovaný vztah týká

¨ údaje k artiklu, které mají být odlišné (objednací číslo, název, čárový kód, volný údaj)

¨ časová platnost vztahu od – do

¨ poznámka

Poznámka:

Při vkládání nového záznamu (F3) se předplní atributy druh artiklu, artikl a identifikace adresáta, pokud jsou předtím uvedeny ve výběru činnosti.

Další vlastnosti vztahu, které tady nejsou nabízeny, je možno popsat obecnými parametry pomocí činnosti sady parametrů.

Vztah obchodovatelného artiklu k adresátovi je objektem, tzn. je možné využívat objektové vazby a připojovat k němu jiné objekty (např. dokumenty, události vývěsky apod.).

Datový model

  • OBARTADR Vztah obchodovatelného artiklu a adresáta
    • ADADSAT Adresát
    • OBARTIKL Obchodovatelný artikl
      • SPARTIKN Název artiklu
    • PASADA Sada parametrů

    • Formulář

    Formulář činnosti - Legenda palety barev
Mřížka [Vztahy]
Listovací rámeček
Stránka #1 Vztahy
Sada | Identifikátor sady parametrů
Priorita | Priorita vztahu
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
Název adresáta | Název adresáta
Obj. číslo | Objednací číslo
Jiný název | Jiný název artiklu
Čárový kód | Čárový kód artiklu u adresáta
Volný údaj | Volný údaj - numerický
Volný údaj - textový | Volný údaj - textový
Platnost | Datum platnosti od
do | Datum platnosti do
Poznámka | Poznámka
Stránka #2 Hodnoty parametrů
Mřížka [Hodnoty parametrů]
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Identifikátor spojení na bankovní účet adresáta.
 | Název adresáta
ID | Identifikace položky číselníku
 | Název položky číselníku
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Text1 | Textová elementární hodnota
Dat1 | Datumová elementární hodnota 1
Dat2 | Datumová elementární hodnota 2
Num1 | Numerická elementární hodnota 1
Num2 | Numerická elementární hodnota 2
Cmb1 | Překryvný seznam elementární hodnota 1
Cmb2 | Překryvný seznam elementární hodnota 2
Poznámka | Poznámka
Platnost od | Platnost od
do | Platnost do
Stránka #3 Výběr
Sada | Identifikátor sady parametrů
Priorita | Priorita vztahu
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Obj. číslo | Objednací číslo
Jiný název | Jiný název artiklu
Čárový kód | Čárový kód artiklu u adresáta
Obch. sel. | Identifikátor obchodního selektoru
Tech. sel. | Identifikátor technicko-věcného selektoru.
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 | Platnost nebo neplatnost k datu
Paleta | Vybrat záznamy všech kategorií v paletě
 | Identifikace palety barev
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Vztahy] činnosti - Legenda palety barev

    Mřížka [Vztahy] činnosti - Legenda palety barev
Označování | Označení záznamu
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Platnost | Datum platnosti od
do | Datum platnosti do
Čárový kód | Čárový kód artiklu u adresáta
Obj. číslo | Objednací číslo
Jiný název | Jiný název artiklu
Sada | Identifikátor sady parametrů
Název sady | Název sady parametrů
Priorita | Priorita vztahu

    Mřížka [Hodnoty parametrů] činnosti - Legenda palety barev

    Mřížka [Hodnoty parametrů] činnosti - Legenda palety barev
Název parametru | Název parametru
Hodnota parametru | Hodnota parametru
Platnost od | Platnost od
do | Platnost do

    Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Události správy artiklu |
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Legenda palety barev |
F2 | Adresář | Přehled adresátů
F2 | Bankovní spojení adresátů |
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Obchodovatelný artikl | Seznam obchodovatelných artiklů
F2 | Obecný číselník | Obecný číselník
F2 | Palety barev kategorií | Palety barev kategorií
F2 | Sady parametrů | Sady parametrů
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Atributy tisku

    Základní údaje
Sada | Identifikátor sady parametrů | OBARTADR_pa01id | C(6)
Název sady | Název sady parametrů | PASADA_pa01nazsad | C(40)
Priorita | Priorita vztahu | Výpočet | C(2)
Druh artiklu | Identifikace druhu artiklu | OBARTADR_sp61id | C(3)
Artikl | Identifikace artiklu | OBARTADR_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Obj. číslo | Objednací číslo | OBARTADR_ob29objcis | C(40)
Jiný název | Jiný název artiklu | OBARTADR_ob29artikl | C(100)
Čárový kód | Čárový kód artiklu u adresáta | OBARTADR_ob29carkod | C(36)
Volný údaj | Volný údaj - numerický | OBARTADR_ob29volnu1 | N(12,2)
Volný údaj - textový | Volný údaj - textový | OBARTADR_ob29voltx1 | C(60)
Adresát | Identifikace adresáta | OBARTADR_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Spojení | Číslo spojení adresáta. | OBARTADR_ad11cisspo | C(2)
Jméno kontaktní osoby | Jméno kontaktní osoby. | ADSPOJ_ad11jmeno | C(40)
Jméno na štítek | Jméno pracovníka na poštovní štítek | ADSPOJ_ad11jmenop | C(100)
Funkce | Funkce kontaktní osoby | ADSPOJ_ad11funkce | C(40)
Fax | Faxové číslo | ADSPOJ_ad11fax | C(60)
Jiné | Jiné spojení adresáta | ADSPOJ_ad11cisost | C(60)
Mobil | Číslo mobilního telefonu | ADSPOJ_ad11mobil | C(60)
e-mail | E-mail spojení adresáta | ADSPOJ_ad11email | C(60)
Adresa | Číslo adresy adresáta. | ADSPOJ_ad02cisadr | C(2)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
Byt | Ulice bytu adresáta (včetně čísla popisného) | ADADR_ad02byt | C(40)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Název okresu | Název okresu | ADOKRESY_ad67nazokr | C(40)
Stát | Identifikace státu. | ADADR_ad05id | C(3)
Název státu | Název státu. | ADSTATY_ad05stat | C(30)
Komentář | Kometář k adrese adresáta. | ADADR_ad02pozn | M
Platnost | Datum platnosti od | OBARTADR_ob29datum | D
do | Datum platnosti do | OBARTADR_ob29datumd | D
Poznámka | Poznámka | OBARTADR_ob29koment | M
Název parametru | Název parametru | PAPARAMPR_pa02nazpar | C(40)
Název adresáta | Název adresáta | ADADSATPR_ad01adsat | C(100)
IČO | Identifikační číslo organizace. | ADADSATPR_ad01ico | C(10)
DIČ | Daňové identifikační číslo adresáta. | ADADSATPR_ad01dico | C(16)
Rodné číslo | Rodné číslo adresáta | ADADSATPR_ad01rc | C(10)
Jméno | Jméno kontaktní osoby. | ADSPOJPR_ad11jmeno | C(40)
Jméno na štítek | Jméno pracovníka na poštovní štítek | ADSPOJPR_ad11jmenop | C(100)
Telefon | Telefonní číslo | ADSPOJPR_ad11cislo | C(60)
Fax | Faxové číslo | ADSPOJPR_ad11fax | C(60)
Jiné | Jiné spojení adresáta | ADSPOJPR_ad11cisost | C(60)
Mobil | Číslo mobilního telefonu | ADSPOJPR_ad11mobil | C(60)
e-mail | E-mail spojení adresáta | ADSPOJPR_ad11email | C(60)
Kód banky | Kód banky | ADBUCTYPR_oc02idbank | C(4)
Pobočka | Název pobočky, která vede bankovní účet adresátovi. | ADBUCTYPR_ad03poboc | C(25)
Prefix ú. | Prefix bankovního účtu adresáta | ADBUCTYPR_ad03pructu | C(6)
Č. účtu | Číslo bankovního účtu adresáta. | ADBUCTYPR_ad03ucet | C(34)
Specifický symbol | Specifický symbol adresáta | ADBUCTYPR_ad03ssymb | C(10)
Měna | Kód měny - oceňovací jednotky. | ADBUCTYPR_oc01id | C(3)
Název ú. | Název účtu | ADBUCTYPR_ad03nauctu | C(20)
Název položky číselníku | Název položky číselníku | PACISPOLPR_pa08nazpol | C(40)
Název artiklu | Název artiklu | SPARTIKNPR_sp62artikl | C(60)

    Při pohybu v Hodnoty parametrů
Parametr | Identifikátor parametru | PAHODNOT_pa02id | C(6)
Hodnota parametru | Hodnota parametru | Výpočet | C(100)
Poznámka | Poznámka | PAHODNOT_pa06koment | M
Platnost od | Platnost od | PAHODNOT_pa06datum | D
do | Platnost do | PAHODNOT_pa06datumd | D
Adresát | Identifikace adresáta | PAHODNOT_ad01id | C(6)
Spojení | Číslo spojení adresáta. | PAHODNOT_ad11cisspo | C(2)
Účet | Identifikátor spojení na bankovní účet adresáta. | PAHODNOT_ad03cisban | C(2)
Text1 | Textová elementární hodnota | PAHODNOT_pa06text1 | C(60)
Identifikace položky číselníku | Identifikace položky číselníku | PAHODNOT_pa08id | C(10)
Druh artiklu | Identifikace druhu artiklu | PAHODNOT_sp61id | C(3)
Artikl | Identifikace artiklu | PAHODNOT_sp60id | C(13)
Num1 | Numerická elementární hodnota 1 | PAHODNOT_pa06num1 | N(20,4)
Num2 | Numerická elementární hodnota 2 | PAHODNOT_pa06num2 | N(20,4)
Dat1 | Datumová elementární hodnota 1 | PAHODNOT_pa06dat1 | D
Dat2 | Datumová elementární hodnota 2 | PAHODNOT_pa06dat2 | D
Cmb1 | Překryvný seznam elementární hodnota 1 | PAHODNOT_pa06cmb1 | N(1)
Cmb2 | Překryvný seznam elementární hodnota 2 | PAHODNOT_pa06cmb2 | N(1)
Oblast | Oblast sady parametrů | PAHODNOT_pa01oblast | C(2)

    Viz.také

    Události správy artiklu | OZNAČOVÁNÍ | Legenda palety barev | Adresář | Bankovní spojení adresátů | Druhy artiklů | Kategorie adresátů | Obchodní selektor | Obchodovatelný artikl | Obecný číselník | Palety barev kategorií | Sady parametrů | Spojení adresátů | Technicko-věcný selektor


Umístění - distr. kanál

Popis

Tato činnost sdružuje každé obchodní místo, distribuční kanál, kterým je prodej realizován a který má smysl evidovat. Může jím být distribuční středisko, dealer, obchodní zástupce apod.

Dostupné jsou tyto atributy:

¨ umístění - identifikace umístění - distribučního kanálu (musí být uvedeno) a název umístění - distribučního kanálu (musí být uvedeno).

¨ adresát - identifikace adresáta (musí být uvedeno). Lze vybrat z adresáře klávesou F2. Číslo spojení adresáta (musí být uvedeno). Po zadání těchto atributů se automaticky doplní celá adresa adresáta.

¨ organizační selektor - identifikátor organizačního selektoru. Lze vybrat ze seznamu klávesou F2. Sám se doplní název organizačního selektoru.

¨ účet. sel. - účetní selektor vztažený k danému umístění.

Ke každému umístění je možno pro uživatele nastavit přístupová práva.

U každého formuláře, který vrací určitou hodnotu (např. číselníky, adresář atd.) je k dispozici činnost parametry formuláře (pod menu "volby").

Datový model

  • OBUMIST Umístění - distribuční kanál
    • SPSEOR Organizační selektor
    • SPPRISTU Přístupové právo uživatele k věci
    • ADADSAT Adresát
    • ADSPOJ Spojení adresáta
      • ADADR Adresa

    • Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci
F2 | Adresář | Přehled adresátů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Spojení adresátů | Přehled spojení adresátů

    Formulář

    Formulář činnosti - Spojení adresátů
Mřížka [Umístění]
Umístění | Identifikace umístění obchodu - distribučního kanálu
 | Název umístění obchodu - distribučního kanálu
Listovací rámeček
Stránka #1 Umístění
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
 | Ulice adresy adresáta (včetně čísla popisného).
 | Město adresy adresáta.
 | Poštovní směrovací číslo adresy adresáta.
Org. sel. | Identifikátor organizačního selektoru.
 | Název organizačního selektoru
Účet.sel. | Účetní selektor umístění
Stránka #2 Výběr
Umístění | Identifikace umístění obchodu - distribučního kanálu
 | Název umístění obchodu - distribučního kanálu
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
Org. sel. | Identifikátor organizačního selektoru.
Účet.sel. | Účetní selektor umístění
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Umístění] činnosti - Spojení adresátů

    Mřížka [Umístění] činnosti - Spojení adresátů
Umístění | Identifikace umístění obchodu - distribučního kanálu
Název umístění | Název umístění obchodu - distribučního kanálu
Organizační selektor | Identifikátor organizačního selektoru.

    Atributy tisku

    Základní údaje
Umístění | Identifikace umístění obchodu - distribučního kanálu | OBUMIST_ob05id | C(6)
Název umístění | Název umístění obchodu - distribučního kanálu | OBUMIST_ob05text | C(40)
Org. sel. | Identifikátor organizačního selektoru. | OBUMIST_sp11idzak | C(9)
Účetní selektor umístění | Účetní selektor umístění | OBUMIST_sp00uselum | C(9)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
IČO | Identifikační číslo organizace. | ADADSAT_ad01ico | C(10)
DIČ | Daňové identifikační číslo adresáta. | ADADSAT_ad01dico | C(16)
Jméno | Jméno kontaktní osoby. | ADSPOJ_ad11jmeno | C(40)
Volané telefonní číslo | Telefonní číslo | ADSPOJ_ad11cislo | C(60)

    Viz.také

    Přístupová práva | Adresář | Organizační selektor | Spojení adresátů


Katalog zboží

Popis

Činnost slouží k definici souborů artiklu nebo pro sestavení katalogu výrobků, který se jako nabídka odešle zákazníkům (příkladem může být počítač - skládá se z monitoru, klávesnice, myši ...).

Jsou dostupné tyto atributy:

¨ druh - identifikace druhu katalogu (musí být uvedeno). Lze vybrat ze seznamu klávesou F2. Sám se po zadání vyplní název druhu katalogu

¨ katalog - identifikace katalogu (musí být uvedeno) a název katalogu

¨ poznámka - poznámka ke katalogu

Záložka "položky katalogu" obsahuje tyto atributy:

¨ artikl - identifikace druhu artiklu (musí být uvedeno) a identifikace artiklu (musí být uvedeno). Po zadání se sám doplní název artiklu.

¨ umístění - identifikace umístění - distribučního kanálu

¨ mn. ref. - množství obchodovatelného artiklu v referenční měrné jednotce (musí být uvedeno)

¨ pořadí - pořadí artiklu v katalogu (musí být větší než 0)

¨ skupina - identifikace cenové skupiny

Datový model

  • OBKATAL Katalog zboží obchodu
    • OBKATALD Druh katalogu zboží obchodu
    • BWUZIVAT Uživatel systému

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Cenové skupiny | Přehled cenových skupin obchodovatelného artiklu
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy katalogu zboží | Seznam druhů katalogů zboží
F2 | Obchodovatelný artikl | Seznam obchodovatelných artiklů
F2 | Umístění - distr. kanál | Umístění - distribuční kanál

    Formulář

    Formulář činnosti - Umístění - distr. kanál
Mřížka [Katalogy]
Druh | Identifikace druhu katalogu
 | Název druhu kalalogu
Katalog | Identifikace katalogu
 | Název katalogu
Listovací rámeček
Stránka #1 Katalogy
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Poznámka | Poznámka ke katalogu
Stránka #2 Položky katalogu
Mřížka [Položky katalogu]
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Umístění | Identifikace umístění obchodu - distribučního kanálu
 | Název umístění obchodu - distribučního kanálu
Mn. ref. | Množství obchodovatelného artiklu v referenční měrné jednotce
Pořadí | Pořadí artiklu v katalogu
Skupina | Identifikace cenové skupiny

    Mřížka [Katalogy] činnosti - Umístění - distr. kanál

    Mřížka [Katalogy] činnosti - Umístění - distr. kanál
Druh | Identifikace druhu katalogu
Katalog | Identifikace katalogu
Název katalogu | Název katalogu

    Mřížka [Položky katalogu] činnosti - Umístění - distr. kanál

    Mřížka [Položky katalogu] činnosti - Umístění - distr. kanál
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Mn. ref. | Množství obchodovatelného artiklu v referenční měrné jednotce
Pořadí | Pořadí artiklu v katalogu

    Atributy tisku

    Základní údaje
Druh | Identifikace druhu katalogu | OBKATAL_ob07id | C(6)
Název druhu kalalogu | Název druhu kalalogu | OBKATALD_ob07druhka | C(40)
Katalog | Identifikace katalogu | OBKATAL_ob06id | C(6)
Název katalogu | Název katalogu | OBKATAL_ob06katal | C(40)
Uživatel | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | OBKATAL_sp00datzap | T
Poznámka | Poznámka ke katalogu | OBKATAL_ob06koment | M
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)

    Při pohybu v Položky katalogu
Druh artiklu | Identifikace druhu artiklu | OBKATALP_sp61id | C(3)
Artikl | Identifikace artiklu | OBKATALP_sp60id | C(13)
Mn. ref. | Množství obchodovatelného artiklu v referenční měrné jednotce | OBKATALP_ob02mnr | N(20,4)
Pořadí | Pořadí artiklu v katalogu | OBKATALP_ob08poradi | N(3)

    Viz.také

    Cenové skupiny | Druhy artiklů | Druhy katalogu zboží | Obchodovatelný artikl | Umístění - distr. kanál | Výstup katalogu zboží


Propojení operací skladu

Popis

Tuto činnost uživatel využije pro potřeby možnosti vidět na událostech obchodu spojenou cenu, která je určitým způsobem odvozena z ceny skladové. Musí se jednat o operace obchodu a skladu jednoho procesu.

Datový model

  • OBDEFPRE Propojení operací obchodu a skladu pro přepočet nákladů v události obchodu
    • SPTYP Druh procesu/operace
    • SPTYP Druh procesu/operace (alias SPTYP1)
    • SPTYP Druh procesu/operace (alias SPTYP2)

    • Formulář

    Formulář činnosti - Druhy operací
Mřížka [Propojení operací obchodu a skladu]
Druh procesu | Identifikátor druhu procesu
 | Název druhu procesu
 | Identifikace komponenty
Druh operace | Identifikátor druhu operace
 | Název druhu operace
 | Identifikace komponenty
Druh operace | Identifikátor druhu operace
 | Název druhu operace

    Mřížka [Propojení operací obchodu a skladu] činnosti - Druhy operací

    Mřížka [Propojení operací obchodu a skladu] činnosti - Druhy operací
Proces | Identifikátor druhu procesu
Název druhu procesu | Název druhu procesu
Komp. | Identifikace komponenty
Operace | Identifikátor druhu operace
Název druhu operace | Název druhu procesu
Komp. | Identifikace komponenty
Operace | Identifikátor druhu operace
Název druhu operace | Název druhu procesu

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů

    Viz.také

    Druhy operací | Druhy procesů


Parametry obchodu

Popis

V parametrech obchodu uživatel nastavuje, který typ zdanitelného plnění se bude v událostech obchodu používat pro:

¨ neplátce DPH – nákup – tuzemsko

¨ neplátce DPH – nákup – zahraničí

¨ neplátce DHP – nákup – EU

Tyto parametry jsou určeny pro události obchodu, kde se vstupují adresáti, kteří mají v adresáři (na záložce Další) uvedeno DPH – Ne. Při vyplnění takového adresáta v události obchodu se poté na základě těchto parametrů automaticky vyplní atribut typ zdanitelného plnění.

Formulář

Formulář činnosti - Typ zdanitelného plnění
Typ zd.pl. neplátce DPH - nákup - tuzemsko | Identifikace typu zdanitelného plnění pro nákup od neplátce DPH - tuzemsko
Typ zd.pl. neplátce DPH - nákup - zahraničí | Identifikace typu zdanitelného plnění pro nákup od neplátce DPH - zahraničí
Typ zd.pl. neplátce DPH - nákup - EU | Identifikace typu zdanitelného plnění pro nákup od neplátce DPH - EU

Vyvolávané činnosti

K. | Činnost | Popis
F2 | Typ zdanitelného plnění | Číselník typů zdanitelného plnění

Viz.také

Typ zdanitelného plnění


Definice výrazů označování

Popis

Tuto činnost bude nastavovat v každém případě zkušenější uživatel. V této činnosti se nastavují výrazy v jazyce FoxPro nebo SQL dotazy. Nadefinované definice výrazů označování se pak uživateli zobrazují jako dotazy nad událostmi obchodu v činnosti "označení - obchod". Tyto definice se mohou např. používat jako dotazy, které se nad událostmi obchodu dotazují na informace volných karet.

Datový model

  • OBOZNVYR Výraz pro označení - obchod
    • BWUZIVAT Uživatel systému

    • Formulář

    Formulář činnosti - Typ zdanitelného plnění
Mřížka [Výrazy pro označení]
Pořadí | Pořadí výrazu v překryvném seznamu
Popis výrazu | Popis výrazu
Typ | Typ výrazu FoxPro nebo SQL-dotaz
Výraz | Výraz označení
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Poznámka | Poznámka k výrazu

    Mřížka [Výrazy pro označení] činnosti - Typ zdanitelného plnění

    Mřížka [Výrazy pro označení] činnosti - Typ zdanitelného plnění
Pořadí | Pořadí výrazu v překryvném seznamu
Popis výrazu | Popis výrazu
Typ | Typ výrazu FoxPro nebo SQL-dotaz
Založil | Jméno uživatele systému

    Atributy tisku

    Základní údaje
Pořadí | Pořadí výrazu v překryvném seznamu | OBOZNVYR_ob21por | N(3)
Výraz | Výraz označení | OBOZNVYR_ob21vyraz | M
Typ | Typ výrazu FoxPro nebo SQL-dotaz | Výpočet | C(6)
Popis výrazu | Popis výrazu | OBOZNVYR_ob21popis | C(40)
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | OBOZNVYR_sp00datzap | T
Poznámka | Poznámka k výrazu | OBOZNVYR_ob21koment | M


Celní sazebník

Popis

Jedná se o číselník, kde má uživatel k dispozici jednotlivé položky celního sazebníku. Položky celního sazebníku jsou dány příslušným zákonem. Tyto položky využívá i při práci s obchodovatelným artiklem, kde každému artiklu může přiřadit identifikaci některé položky celního sazebníku. K dispozici jsou tyto atributy:

¨ identifikace položky

¨ název položky

¨ skupina položky

¨ libovolná poznámka

Datový model

  • OBCELSAZ Položka celního sazebníku

    • Formulář

    Formulář činnosti - Sazby celního sazebníku
Mřížka [Celní sazebník]
Položka | Identifikace položky celního sazebníku.
Název | Název položky celního sazebníku.
Skupina | Skupina položky celního sazebníku
Listovací rámeček
Stránka #1 Celní sazebník
Poznámka | Poznámka položky celního sazebníku.
Stránka #2 Výběr
Položka | Identifikace položky celního sazebníku.
Název | Název položky celního sazebníku.
Skupina | Skupina položky celního sazebníku
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Celní sazebník] činnosti - Sazby celního sazebníku

    Mřížka [Celní sazebník] činnosti - Sazby celního sazebníku
Položka | Identifikace položky celního sazebníku.
Název položky celního sazebníku | Název položky celního sazebníku.
Skupina | Skupina položky celního sazebníku

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Měrné jednotky | Číselník měrných jednotek

    Atributy tisku

    Základní údaje
Položka | Identifikace položky celního sazebníku. | OBCELSAZ_ob25id | C(10)
Název položky celního sazebníku | Název položky celního sazebníku. | OBCELSAZ_ob25nazpol | C(100)
Skupina | Skupina položky celního sazebníku | Výpočet | C(1)
Poznámka | Poznámka položky celního sazebníku. | OBCELSAZ_ob25koment | M

    Viz.také

    Měrné jednotky | Sazby celního sazebníku


Sazby celního sazebníku

Popis

Jedná se o číselník sazeb jednotlivých položek celního sazebníku. Jak položky, tak sazby celního sazebníku jsou dány příslušným zákonem. U každé sazby je k dispozici:

¨ identifikace položky celního sazebníku

¨ název položky

¨ platnost od - do - nastavené datum platnosti

¨ MJ - MJ, ve které se položka eviduje

¨ MJ KN – měrná jednotka kombinované nomenklatury

¨ celní sazba všeobecná

¨ celní sazba smluvní

Datový model

  • OBCELPRC Sazba položky celního sazebníku v období
    • OBCELSAZ Položka celního sazebníku
    • SPMJ Měrná jednotka
      • SPMJN Měrná jednotka v jazyce
    • SPMJ Měrná jednotka (alias SPMJ2)
      • SPMJN Měrná jednotka v jazyce (alias SPMJN2)

    • Formulář

    Formulář činnosti - Měrné jednotky
Mřížka [Sazby celního sazebníku]
Listovací rámeček
Stránka #1 Sazby celního sazebníku
Položka | Identifikace položky celního sazebníku.
Název | Název položky celního sazebníku.
Platnost od | Datum platnosti od
Platnost do | Datum platnosti do
MJ | Identifikátor měrné jednotky
Název měrné jednotky | Název měrné jednotky
MJ KN | Měrná jednotka kombinované nomenklatury
Název měrné jednotky | Název měrné jednotky
Celní sazba všeobecná | Celní sazba všeobecná
Celní sazba smluvní | Celní sazba smluvní
Stránka #2 Výběr
Položka | Identifikace položky celního sazebníku.
Název | Název položky celního sazebníku.
Skupina | Skupina položky celního sazebníku
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 | Platnost nebo neplatnost k datu
MJ | Identifikátor měrné jednotky
MJ KN | Měrná jednotka kombinované nomenklatury
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Sazby celního sazebníku] činnosti - Měrné jednotky

    Mřížka [Sazby celního sazebníku] činnosti - Měrné jednotky
Položka | Identifikace položky celního sazebníku.
Název položky celního sazebníku | Název položky celního sazebníku.
Všeob. | Celní sazba všeobecná
Sml. | Celní sazba smluvní
MJ | Identifikátor měrné jednotky
MJ KN | Měrná jednotka kombinované nomenklatury
Platnost od | Datum platnosti od
Platnost do | Datum platnosti do

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Celní sazebník | Prohlížení a editace celního sazebníku
F2 | Měrné jednotky | Číselník měrných jednotek

    Atributy tisku

    Základní údaje
Položka | Identifikace položky celního sazebníku. | OBCELPRC_ob25id | C(10)
Název položky celního sazebníku | Název položky celního sazebníku. | OBCELSAZ_ob25nazpol | C(100)
Skupina | Skupina položky celního sazebníku | Výpočet | C(1)
Poznámka | Poznámka položky celního sazebníku. | OBCELSAZ_ob25koment | M
MJ | Identifikátor měrné jednotky | OBCELPRC_sp24idmj | C(3)
Název měrné jednotky | Název měrné jednotky | SPMJN_sp58mjnaz | C(40)
MJ KN | Měrná jednotka kombinované nomenklatury | OBCELPRC_sp24idmj2 | C(3)
Název měrné jednotky | Název měrné jednotky | SPMJN2_sp58mjnaz | C(40)
Platnost od | Datum platnosti od | OBCELPRC_ob26datum | D
Platnost do | Datum platnosti do | OBCELPRC_ob26datumd | D
Celní sazba všeobecná | Celní sazba všeobecná | OBCELPRC_ob26sazvse | N(5,1)
Celní sazba smluvní | Celní sazba smluvní | OBCELPRC_ob26sazsml | N(5,1)

    Viz.také

    Celní sazebník | Měrné jednotky


EXPEDICE

Popis

Komponenta Expedice v sobě sdružuje veškeré činnosti, které umožňují firmě pohodlným způsobem vést evidenci přepravy. K dispozici jsou definice jednotlivých vozidel, tras, řidičů apod. Správným nastavením procesů pak dochází k automatickému vystavení expedičních příkazů na základě vystavených dodacích listů.

Viz.také

Události expedice | Vozidla expedice | Typy vozidel expedice | Trasy expedice | Řidiči expedice | Převod dat z vážního serveru | Parametry expedice | Obecné kalendáře


Události expedice

Popis

Události expedice poskytují uživateli informace o procesně zpracovaných pohybech v komponentě Expedice. Na základě činnosti „rozdělení dodacích listů“ (klávesa F7) se načítají nevykryté dodací listy do expedičního příkazu. Při vytváření událostí expedice se vstupují tyto údaje:

¨ odjezd – datum od – do ve kterém má být proveden rozvoz po zvolené trase (pokud má rozvoz provést řidič během jednoho dne, zůstává datum stejný, mění se pouze čas od – do)

¨ trasa – definice trasy

¨ definice vozidla a řidiče a předplnění technických parametrů vozidla

Záložka Dodací listy obsahuje informace o hlavičkách dodacích listů, na které již byl vytvořen expediční příkaz a záložka Položky DL obsahuje o jednotlivých položkách každého DL.

Datový model

  • EXUDAL Událost expedice
    • SPPRISTU Přístupové právo uživatele k věci
    • BWUZIVAT Uživatel systému
    • EXARTIKL Vozidlo - expedice
      • SPARTIKN Název artiklu
    • EXRIDIC Řidič - expedice
    • EXTRASA Trasa expedice
    • SPPRCOD Operace procesu
      • SPPRC Proces
      • SPTYP Druh procesu/operace
    • SPSEOB Obchodní selektor
    • SPSEOR Organizační selektor
    • SPSETV Technicko-věcný selektor

    • Formulář

    Formulář činnosti - Druhy artiklů
Mřížka [Události expedice]
Listovací rámeček
Stránka #1 Události expedice
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
 | Identifikátor druhu operace
 | Název druhu operace
 | Pořadí stejného druhu operace v jednom procesu
Pořadí | Pořadí expedičního příkazu
Odjezd | Datum a čas odjezdu
 | Datum a čas přijezdu
Popis | Popis události
Trasa | Identifikace trasy
 | Název trasy
 | Identifikace druhu artiklu
Vozidlo | Identifikace artiklu
 | SPZ vozidla
 | Název artiklu
Řidič | Identifikace řidiče
 | Jméno řidiče
Hmotnost (kg) | Hmotnost v kilogramech
Vzdálenost (km) | Ujetý počet kilometrů
Plocha (m2) | Úložná plocha v metrech čtverečných
Objem (m3) | Úložný objem v metrech kubických
Počet DL | Počet dodacích listů
Počet odběratelů | Počet odběratelů
Poznámka | Poznámka k události
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Dodací listy
Mřížka [Dodací listy]
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
 | Identifikátor druhu operace
 | Identifikace komponenty
 | Pořadí stejného druhu operace v jednom procesu
Pořadí | Pořadí na trase
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
Jméno | Jméno kontaktní osoby.
 | Národní směrové číslo státu pro telefonní spojení (UTO).
Telefon | Telefonní číslo
Ulice | Ulice adresy adresáta (včetně čísla popisného).
 | Poštovní směrovací číslo adresy adresáta.
Město | Město adresy adresáta.
Stránka #3 Položky DL
Mřížka [Položky DL]
Stránka #4 Výběr
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu od
 | Pořadové číslo procesu do
Pořadí | Pořadí expedičního příkazu
 | Identifikátor druhu operace
 | Identifikátor druhu procesu
Odjezd | Datum a čas odjezdu
 | Datum a čas odjezdu do
Popis | Popis události
Trasa | Identifikace trasy
 | Identifikace druhu artiklu
Vozidlo | Identifikace vozidla
Řidič | Identifikace řidiče
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsané | Identifikace uživatele systému
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Události expedice] činnosti - Druhy artiklů

    Mřížka [Události expedice] činnosti - Druhy artiklů
Označování | Označení záznamu
Odjezd | Datum a čas odjezdu
Příjezd | Datum a čas přijezdu
Trasa | Identifikace trasy
Název trasy | Název trasy
Druh artiklu | Identifikace druhu artiklu
Vozidlo | Identifikace vozidla
SPZ | SPZ vozidla
Řidič | Identifikace řidiče
Jméno řidiče | Jméno řidiče
Popis | Popis události
Hmotnost (kg) | Hmotnost v kilogramech
Vzdálenost (km) | Ujetý počet kilometrů
Plocha (m2) | Úložná plocha v metrech čtverečných
Objem (m3) | Úložný objem v metrech kubických
Počet DL | Počet dodacích listů
Počet odběratelů | Počet odběratelů
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Pořadí | Pořadí stejného druhu operace v jednom procesu
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Mřížka [Dodací listy] činnosti - Druhy artiklů

    Mřížka [Dodací listy] činnosti - Druhy artiklů
Poř. | Pořadí na trase
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Komp. | Identifikace komponenty
Pořadí | Pořadí stejného druhu operace v jednom procesu
Název druhu operace | Název druhu procesu
Adresát | Identifikace adresáta
Spojení | Číslo spojení adresáta.
Název adresáta | Název adresáta
Jméno | Jméno kontaktní osoby.
Ulice | Ulice adresy adresáta (včetně čísla popisného).
Město | Město adresy adresáta.
PSČ | Poštovní směrovací číslo adresy adresáta.

    Mřížka [Položky DL] činnosti - Druhy artiklů

    Mřížka [Položky DL] činnosti - Druhy artiklů
Sklad | Identifikace umístění skladové evidence
Buňka | Identifikace skladové buňky
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
MJ | Identifikátor měrné jednotky
Množství | Množství obchodovatelného artiklu
MJ | Identifikátor měrné jednotky
Mn. ref. | Množství obchodovatelného artiklu v referenční měrné jednotce
Název artiklu | Název artiklu
Adresát | Identifikace adresáta
Spojení | Číslo spojení adresáta.
Název adresáta | Název adresáta
Město | Město adresy adresáta.

    Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Export pro vážní server | Export pro vážní server
F7 | Rozdělení dodacích listů | Rozdělení dodacích listů expedice
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Trasy expedice | Trasy expedice
F2 | Vozidla expedice | Vozidla expedice
F2 | Řidiči expedice | Řidiči expedice

    Atributy tisku

    Základní údaje
Rok | Rok v identifikaci procesu | EXUDAL_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | EXUDAL_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | EXUDAL_sp33cisd | C(8)
Pořadí druhu operace | Pořadí stejného druhu operace v jednom procesu | EXUDAL_sp33porad | N(2)
Druh operace | Identifikátor druhu operace | EXUDAL_sp07idtyp | C(6)
Pořadí | Pořadí expedičního příkazu | EXUDAL_ex02porad | C(3)
Řidič | Identifikace řidiče | EXUDAL_ex07id | C(6)
Jméno řidiče | Jméno řidiče | EXRIDIC_ex07jmerid | C(40)
Druh artiklu | Identifikace druhu artiklu | EXUDAL_sp61id | C(3)
Vozidlo | Identifikace artiklu | EXUDAL_sp60id | C(13)
Název vozidla | Název artiklu | SPARTIKN_sp62artikl | C(60)
SPZ | SPZ vozidla | EXARTIKL_ex01spz | C(12)
Trasa | Identifikace trasy | EXUDAL_ex04id | C(6)
Název trasy | Název trasy | EXTRASA_ex04naztra | C(40)
Obch. sel. | Identifikátor obchodního selektoru | EXUDAL_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | EXUDAL_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | EXUDAL_sp20idzak | C(9)
Odjezd | Datum a čas odjezdu | EXUDAL_ex02datum | T
Příjezd | Datum a čas přijezdu | EXUDAL_ex02datump | T
Hmotnost (kg) | Hmotnost v kilogramech | EXUDAL_ex02kg | N(5)
Vzdálenost (km) | Ujetý počet kilometrů | EXUDAL_ex02km | N(5)
Plocha (m2) | Úložná plocha v metrech čtverečných | EXUDAL_ex02m2 | N(6,2)
Objem (m3) | Úložný objem v metrech kubických | EXUDAL_ex02m3 | N(6,2)
Počet DL | Počet dodacích listů | EXUDAL_ex02pocdl | N(3)
Počet odběratelů | Počet odběratelů | EXUDAL_ex02pocodb | N(3)
Popis | Popis události | EXUDAL_ex02text | C(40)
Poznámka | Poznámka k události | EXUDAL_ex02koment | M
Název adresáta | Název adresáta | ADADSAT2_ad01adsat | C(100)
UTO | Národní směrové číslo státu pro telefonní spojení (UTO). | ADSPOJ_ad13nsc | C(4)
Telefon | Telefonní číslo | ADSPOJ_ad11cislo | C(60)
Jméno kontaktní osoby | Jméno kontaktní osoby. | ADSPOJ_ad11jmeno | C(40)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR2_ad02ulice | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR2_ad13psc | C(10)
Město | Město adresy adresáta. | ADADR2_ad02mesto | C(40)
Datum | Datum události obch. artiklu - může řídit číselnou řadu procesu | OBUDAL2_ob02dat | D
Dodání | Datum dodání obchodovatelného artiklu | OBUDAL2_ob02datdod | D
Druh artiklu | Identifikace druhu artiklu | OBUDAL2_sp61id | C(3)
Artikl | Identifikace artiklu | OBUDAL2_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN2_sp62artikl | C(60)
MJ | Identifikátor měrné jednotky | OBUDAL2_sp24idmj | C(3)
Množství | Množství obchodovatelného artiklu | OBUDAL2_ob02mn | N(20,4)
Měrná jednotka - referenční | Identifikátor měrné jednotky | OBUDAL2_sp24idmj1 | C(3)
Mn. ref. | Množství obchodovatelného artiklu v referenční měrné jednotce | OBUDAL2_ob02mnr | N(20,4)
Sklad | Identifikace umístění skladové evidence | OBUDASKL2_mt04id | C(6)
Buňka | Identifikace skladové buňky | OBUDASKL2_mt05id | C(9)
Čarový kód | Kód automatické identifikace | MTBUN_mt05ck | C(36)
Umístění buňky osa X | Umístění buňky osa X | MTBUN_mt05x | N(5)
Umístění buňky osa Y | Umístění buňky osa Y | MTBUN_mt05y | N(5)
Umístění buňky osa Z | Umístění buňky osa Z | MTBUN_mt05z | N(5)
Volný text | Volný text | MTBUN_mt05txt | C(30)
Obchodní smlouva | Číslo obchodní smlouvy | OBUDAL2_ob02hs | C(20)
Popis | Popis události o obchodovatelném artiklu | OBUDAL2_ob02text | C(40)
Umístění | Identifikace umístění obchodu - distribučního kanálu | OBUDAL2_ob05id | C(6)
CJ | Cena ceníková celkem za měrnou jednotku v oceňovací jednotce (služba + artikl) | OBUDAL2_ob02cj01c | N(20,6)
Po slevě/jedn. | Cena za jednotku po slevě celková | OBUDAL2_ob02cj01 | N(20,6)
Celkem bez daně artikl | Cena bez daně po slevě za artikl | OBUDAL2_ob02cc02 | N(20,4)
Celkem bez daně ostatní | Cena bez daně po slevě za ostatní náklady | OBUDAL2_ob02cc03 | N(20,4)
Měna | Kód měny - oceňovací jednotky. | OBUDAL2_oc01id | C(3)
Referenční měna | Referenční měna | OBUDAL2_oc01id1 | C(3)
Kurs | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup. | OBUDAL2_oc03kurz | N(20,6)
Sazba DPH | Procentní sazba daně z přidané hodnoty | OBUDAL2_dp02sazba | N(5,2)
Základ DPH v ZM | Částka základu daně z přidané hodnoty v ZM - odpočet | OBUDAL2_dp02czazm | N(20,4)
DPH v ZM | Částka daně z přidané hodnoty v zahraniční měně - odpočet | OBUDAL2_dp02cdpzm | N(20,4)
Základ DPH v RM | Částka základu daně z přidané hodnoty v referenční měně | OBUDAL2_dp02czarm | N(20,4)
DPH v RM | Částka daně z přidané hodnoty v referenční měně | OBUDAL2_dp02cdprm | N(20,4)
Adresát | Identifikace adresáta | OBUDAL2_ad01id | C(6)
IČO | Identifikační číslo organizace. | ADADSAT_ad01ico | C(10)
DIČ | Daňové identifikační číslo adresáta. | ADADSAT_ad01dico | C(16)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)
UTO | Národní směrové číslo státu pro telefonní spojení (UTO). | ADSPOJ2_ad13nsc | C(4)
Telefon | Telefonní číslo | ADSPOJ2_ad11cislo | C(60)
Jméno | Jméno kontaktní osoby. | ADSPOJ2_ad11jmeno | C(40)

    Při pohybu v Spojené operace
Rok | Rok v identifikaci procesu | EXUDAOPE_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | EXUDAOPE_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | EXUDAOPE_sp33cisd | C(8)
Pořadí druhu operace | Pořadí stejného druhu operace v jednom procesu | EXUDAOPE_sp33porad | N(2)
Pořadí | Pořadí na trase | EXUDAOPE_ex10poradi | N(3)
Adresát | Identifikace adresáta | EXUDAOPE_ad01id | C(6)

    Při pohybu v Spojené položky dodacích listů
Rok | Rok v identifikaci procesu | EXUDAOPE3_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | EXUDAOPE3_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | EXUDAOPE3_sp33cisd | C(8)
Pořadí druhu operace | Pořadí stejného druhu operace v jednom procesu | EXUDAOPE3_sp33porad | N(2)
Pořadí | Pořadí na trase | EXUDAOPE3_ex10poradi | N(3)

    Viz.také

    Export pro vážní server | Rozdělení dodacích listů | Prezentace artiklu | Adresář | Druhy artiklů | Druhy operací | Druhy procesů | Obchodní selektor | Organizační selektor | Spojení adresátů | Technicko-věcný selektor | Trasy expedice | Vozidla expedice | Řidiči expedice


Vozidla expedice

Popis

Tato činnost umožňuje uživateli nadefinovat si přehled všech vozidel, které při přepravě, rozvozu apod. bude využívat. U každého vozidla se definuje:

¨ druh artiklu

¨ identifikace vozidla

¨ název

¨ SPZ

¨ typ – výběr z číselníku (např. dodávka, Avia)

¨ výběr řidiče – osoba, která je odpovědným řidičem daného vozidla

¨ nebezpečný náklad – příznak, zda toto konkrétní vozidlo daného typu je vybaveno pro přepravu nebezpečného nákladu

¨ možnost přívěsu – příznak, zda toto konkrétní vozidlo daného typu je vybaveno závěsným zařízením

¨ aktuální – vozidlo je aktuální pro použití (Ano/Ne)

¨ technický selektor daného vozidla

Na druhé záložce „Rozměry“ jsou konkrétní technické údaje daného vozidla.

Datový model

  • EXARTIKL Vozidlo - expedice
    • SPARTIKL Artikl
    • EXTYPVOZ Typ vozidla expedice
    • SPARTIKN Název artiklu
    • SPSETV Technicko-věcný selektor
    • BWUZIVAT Uživatel systému
    • EXRIDIC Řidič - expedice

    • Formulář

     | Formulář činnosti - Spojení
 | Mřížka [Vozidla]
 |  | Identifikace druhu artiklu
 | Vozidlo | Identifikace vozidla
 | Listovací rámeček
 | Stránka #1 Vozidla
 | Název artiklu | Název artiklu
 | SPZ | SPZ vozidla
 | Typ | Typ vozidla
 |  | Název typu vozidla
 | Řidič | Identifikace řidiče
 |  | Jméno řidiče
 | Nebezpečný náklad | Nebezpečný náklad
 | Možnost přívěsu | Možnost přívěsu
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 |  | Název technicko-věcného selektoru.
 | Aktuální | Vozidlo je aktuální pro použití
 | Založil | Jméno uživatele systému
 |  | Datum a čas zápisu záznamu události
 | Stránka #2 Rozměry
 | Šířka (mm) | Šířka vozidla v milimetrech
 | Výška (mm) | Výška vozidla v milimetrech
 | Délka (mm) | Délka vozidla v milimetrech
 | Šířka LP (mm) | Šířka ložné plochy vozidla v milimetrech
 | Výška LP (mm) | Výška ložné plochy vozidla v milimetrech
 | Délka LP (mm) | Délka ložné plochy vozidla v milimetrech
 | Pohotov. hm. (kg) | Pohotovostní hmotnost v kilogramech
 | Užitečná hm. (kg) | Užitečná hmotnost v kilogramech
 | Celková hm. (kg) | Celková hmotnost v kilogramech
 | Stránka #3 Kategorie artiklu
 | Mřížka [Kategorie artiklu]
 |  | Kategorie
Identifikace kategorie události správy artiklu |  |  | Platnost
Datum platnosti od |  |  | Platnost do
Datum platnosti do |  |  | Adresát
Identifikace adresáta |  |
Název adresáta |  |
Číslo spojení adresáta. |  |  | Popis
Popis události |  |  | Poznámka
Poznámka |  |  | Zapsal
Jméno uživatele systému |  |  | Datum a čas zápisu
Datum a čas zápisu záznamu události
 | Stránka #4 Výběr
 |  | Identifikace druhu artiklu
 | Vozidlo | Identifikace vozidla
 | Název artiklu | Název artiklu
 | SPZ | SPZ vozidla
 | Typ | Typ vozidla
 | Řidič | Identifikace řidiče
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Aktuální | Vozidlo je aktuální pro použití
 | Vztah ke kategorii | Vztah ke kategorii - Je=K dnešnímu datu je v kategorii, Není=K dnešnímu datu není v kategorii, Byl=Není v kategorii, ale byl, Nebyl=Není a nikdy nebyl v kategorii,Bude=Bude v kategorii
 | Kategorie | Identifikace kategorie události správy artiklu
 | Název kategorie | Název kategorie události správy artiklu
 | Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 |  | Platnost nebo neplatnost k datu
 | Paleta | Vybrat záznamy všech kategorií v paletě
 |  | Identifikace palety barev
 | Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Vozidla] činnosti - Spojení

    Mřížka [Vozidla] činnosti - Spojení
Označování | Označení záznamu
Druh artiklu | Identifikace druhu artiklu
Vozidlo | Identifikace artiklu
SPZ | SPZ vozidla
Název artiklu | Název artiklu
Typ | Typ vozidla
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Mřížka [Kategorie artiklu] činnosti - Spojení

    Mřížka [Kategorie artiklu] činnosti - Spojení
Kategorie | Identifikace kategorie události správy artiklu
Název kategorie | Název kategorie události správy artiklu
Platnost od | Datum platnosti od
Platnost do | Datum platnosti do
Adresát | Identifikace adresáta
Název adresáta | Název adresáta

    Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Události správy artiklu |
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
- | Legenda palety barev |
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Kategorie událostí správy artiklu | Přehled kategorií událostí správy artiklu
F2 | Obecné kalendáře | Obecné kalendáře
F2 | Palety barev kategorií | Palety barev kategorií
F2 | Spojení | Seznam spojení za adresáta.
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Typy vozidel expedice | Typy vozidel expedice
F2 | Řidiči expedice | Řidiči expedice

    Atributy tisku

    Základní údaje
Druh artiklu | Identifikace druhu artiklu | EXARTIKL_sp61id | C(3)
Vozidlo | Identifikace artiklu | EXARTIKL_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKL_sp60artikl | C(60)
Typ | Typ vozidla | EXARTIKL_ex03id | C(6)
Tech. sel. | Identifikátor technicko-věcného selektoru. | EXARTIKL_sp20idzak | C(9)
Uživatel | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | EXARTIKL_sp00datzap | T
SPZ | SPZ vozidla | EXARTIKL_ex01spz | C(12)
Řidič | Identifikace řidiče | EXARTIKL_ex07id | C(6)
Jméno řidiče | Jméno řidiče | EXRIDIC_ex07jmerid | C(40)
Adresát | Identifikace adresáta | EXRIDIC_ad01id | C(6)
Šířka (mm) | Šířka vozidla v milimetrech | EXARTIKL_ex03sirka | N(5)
Číslo spojení adresáta | Číslo spojení adresáta. | EXRIDIC_ad11cisspo | C(2)
Výška (mm) | Výška vozidla v milimetrech | EXARTIKL_ex03vyska | N(5)
Délka (mm) | Délka vozidla v milimetrech | EXARTIKL_ex03delka | N(5)
Délka LP (mm) | Délka ložné plochy vozidla v milimetrech | EXARTIKL_ex03lpdelk | N(5)
Šířka LP (mm) | Šířka ložné plochy vozidla v milimetrech | EXARTIKL_ex03lpsirk | N(5)
Výška LP (mm) | Výška ložné plochy vozidla v milimetrech | EXARTIKL_ex03lpvysk | N(5)
Pohotov. hm. (kg) | Pohotovostní hmotnost v kilogramech | EXARTIKL_ex03hmopoh | N(5)
Užitečná hm. (kg) | Užitečná hmotnost v kilogramech | EXARTIKL_ex03hmouzi | N(5)
Celková hm. (kg) | Celková hmotnost v kilogramech | Výpočet | N(5)
Nebezpečný náklad | Nebezpečný náklad | Výpočet | C(3)
Možnost přívěsu | Možnost přívěsu | Výpočet | C(3)
Aktuální | Vozidlo je aktuální pro použití | Výpočet | C(3)

    Viz.také

    Události správy artiklu | OZNAČOVÁNÍ | Prezentace artiklu | Legenda palety barev | Adresář | Druhy artiklů | Kategorie událostí správy artiklu | Obecné kalendáře | Palety barev kategorií | Spojení | Technicko-věcný selektor | Typy vozidel expedice | Řidiči expedice


Typy vozidel expedice

Popis

Tato činnost umožňuje uživateli nadefinovat si jednotlivé typy vozidel (např. osobní auto, dodávka, Avia), které se pak následně v expedici využívají. U každého vozidla se zadávají podrobné technické údaje, kde v závorkách je vždy uvedeno, v jakých jednotkách mají být hodnoty uvedeny. Zatržený příznak „nebezpečný náklad“ znamená, že vozidlo je způsobilé vozit i nebezpečné náklady a příznak „možnost přívěsu“ definuje vozidlo, které sice nemá přívěs ve standardní výbavě, nicméně je možnost ho připojit.

Datový model

  • EXTYPVOZ Typ vozidla expedice

    • Formulář

    Formulář činnosti - Spojení
Mřížka [Typy vozidel expedice]
Typ | Typ vozidla
 | Název typu vozidla
Šířka (mm) | Šířka vozidla v milimetrech
Výška (mm) | Výška vozidla v milimetrech
Délka (mm) | Délka vozidla v milimetrech
Délka LP (mm) | Délka ložné plochy vozidla v milimetrech
Šířka LP (mm) | Šířka ložné plochy vozidla v milimetrech
Výška LP (mm) | Výška ložné plochy vozidla v milimetrech
Pohotov. hm. (kg) | Pohotovostní hmotnost v kilogramech
Užitečná hm. (kg) | Užitečná hmotnost v kilogramech
Celková hm. (kg) | Celková hmotnost v kilogramech
Nebezpečný náklad | Nebezpečný náklad
Možnost přívěsu | Možnost přívěsu

    Mřížka [Typy vozidel expedice] činnosti - Spojení

    Mřížka [Typy vozidel expedice] činnosti - Spojení
Typ | Typ vozidla
Název typu vozidla | Název typu vozidla
Šířka (mm) | Šířka vozidla v milimetrech
Výška (mm) | Výška vozidla v milimetrech
Délka (mm) | Délka vozidla v milimetrech
Délka LP (mm) | Délka ložné plochy vozidla v milimetrech
Šířka LP (mm) | Šířka ložné plochy vozidla v milimetrech
Výška LP (mm) | Výška ložné plochy vozidla v milimetrech
Pohotov. hm. (kg) | Pohotovostní hmotnost v kilogramech
Užitečná hm. (kg) | Užitečná hmotnost v kilogramech
Celková hm. (kg) | Celková hmotnost v kilogramech
Nebezpečný náklad | Nebezpečný náklad
Možnost přívěsu | Možnost přívěsu

    Atributy tisku

    Základní údaje
Typ | Typ vozidla | EXTYPVOZ_ex03id | C(6)
Název typu vozidla | Název typu vozidla | EXTYPVOZ_ex03naztyp | C(40)
Šířka (mm) | Šířka vozidla v milimetrech | EXTYPVOZ_ex03sirka | N(5)
Výška (mm) | Výška vozidla v milimetrech | EXTYPVOZ_ex03vyska | N(5)
Délka (mm) | Délka vozidla v milimetrech | EXTYPVOZ_ex03delka | N(5)
Délka LP (mm) | Délka ložné plochy vozidla v milimetrech | EXTYPVOZ_ex03lpdelk | N(5)
Šířka LP (mm) | Šířka ložné plochy vozidla v milimetrech | EXTYPVOZ_ex03lpsirk | N(5)
Výška LP (mm) | Výška ložné plochy vozidla v milimetrech | EXTYPVOZ_ex03lpvysk | N(5)
Pohotov. hm. (kg) | Pohotovostní hmotnost v kilogramech | EXTYPVOZ_ex03hmopoh | N(5)
Užitečná hm. (kg) | Užitečná hmotnost v kilogramech | EXTYPVOZ_ex03hmouzi | N(5)
Celková hm. (kg) | Celková hmotnost v kilogramech | Výpočet | N(5)
Nebezpečný náklad | Nebezpečný náklad | Výpočet | C(3)
Možnost přívěsu | Možnost přívěsu | Výpočet | C(3)


Trasy expedice

Popis

Tato činnost představuje jednu ze stěžejních částí komponenty expedice a poskytuje uživateli možnost definice jednotlivých tras a s nimi spojených veškerých údajů. Na první záložce „trasy“ má uživatel k dispozici tyto informace:

¨ identifikace a název trasy (např. 001 – trasa Č.Budějovice – Praha)

¨ trvání – obvyklá délka trasy (v hodinách)

¨ délka trasy v km

¨ obvykle odběratelů - obvyklý počet odběratelů, kteří jsou na dané trase

¨ nejvíce odběratelů – maximální počet odběratelů, které je možno na této trase „zvládnout“

¨ vozidlo – implicitní vozidlo, které vždy rozváží tuto trasu (může a nemusí být uvedeno). Může zde být uvedena „-„ s tím, že uživatel si při definici expedičního příkazu k této trase pak ručně přidělí vozidlo, které je právě k dispozici

¨ kalendář platný pro tuto trasu

¨ organizační selektor

¨ aktuální – příznak, zda je trasa aktuální (Ano/Ne)

Druhá záložka „adresy na trase“ poskytuje uživateli informace o jednotlivých adresátech, kteří se vyskytují na dané trase. Uživatel by si neměl vložit více adresátů než je zvolený maximální počet odběratelů. U každého adresáta je vhodné si určit pořadí na trase, podle definice pořadí se pak i tisknou dodací listy.

Datový model

  • EXTRASA Trasa expedice
    • EXARTIKL Vozidlo - expedice
      • SPARTIKN Název artiklu
    • SPSEOR Organizační selektor

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Výjimky v kalendáři | Výjimky v kalendáři
F7 | Obecné kalendáře | Obecné kalendáře
F2 | Adresy adresátů | Seznam adres za adresáta.
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Obecné kalendáře | Obecné kalendáře
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Vozidla expedice | Vozidla expedice

    Formulář

    Formulář činnosti - Obecné kalendáře
Mřížka [Trasy]
Trasa | Identifikace trasy
 | Název trasy
Listovací rámeček
Stránka #1 Trasy
Trvání (hod) | Trvání v hodinách
Délka (km) | Délka trasy v kilometrech
Obvykle odběratelů | Obvyklý počet odběratelů
Nejvíce odběratelů | Maximální počet odběratelů
 | Identifikace druhu artiklu
Vozidlo | Identifikace artiklu
 | Název artiklu
SPZ | SPZ vozidla
Kalendář | Identifikace kalendáře
Org. sel. | Identifikátor organizačního selektoru.
 | Název organizačního selektoru
Aktuální | Trasa je aktuální Ano/Ne
Stránka #2 Adresy na trase
Mřížka [Adresy na trase]
Adresát | Identifikace adresáta
Adresa | Číslo adresy adresáta.
 | Název adresáta
Ulice | Ulice adresy adresáta (včetně čísla popisného).
Město | Město adresy adresáta.
PSČ | Poštovní směrovací číslo adresy adresáta.
Pořadí | Pořadí na trase
Popis | Popis adresy na trase
Pozn. | Poznámka
Stránka #3 Výběr
Trasa | Identifikace trasy
 | Název trasy
 | Identifikace druhu artiklu
Vozidlo | Identifikace artiklu
Adresát | Identifikace adresáta
 | Číslo adresy adresáta.
Org. sel. | Identifikátor organizačního selektoru.
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 | Platnost nebo neplatnost k datu
Aktuální | Trasa je aktuální Ano/Ne
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Trasy] činnosti - Obecné kalendáře

    Mřížka [Trasy] činnosti - Obecné kalendáře
Trasa | Identifikace trasy
Název trasy | Název trasy
Trvání (hod) | Trvání v hodinách
Délka (km) | Délka trasy v kilometrech
Obvykle odběratelů | Obvyklý počet odběratelů
Nejvíce odběratelů | Maximální počet odběratelů
Vozidlo | Identifikace artiklu
Druh artiklu | Identifikace druhu artiklu
SPZ | SPZ vozidla
Název artiklu | Název artiklu

    Mřížka [Adresy na trase] činnosti - Obecné kalendáře

    Mřížka [Adresy na trase] činnosti - Obecné kalendáře
Poř. | Pořadí na trase
Adresát | Identifikace adresáta
Adresa | Číslo adresy adresáta.
Název adresáta | Název adresáta
Ulice | Ulice adresy adresáta (včetně čísla popisného).
Město | Město adresy adresáta.
PSČ | Poštovní směrovací číslo adresy adresáta.

    Atributy tisku

    Základní údaje
Trasa | Identifikace trasy | EXTRASA_ex04id | C(6)
Název trasy | Název trasy | EXTRASA_ex04naztra | C(40)
Trvání (hod) | Trvání v hodinách | EXTRASA_ex04trvani | N(5,2)
Délka (km) | Délka trasy v kilometrech | EXTRASA_ex04km | N(8,2)
Obvykle odběratelů | Obvyklý počet odběratelů | EXTRASA_ex04odbobv | N(3)
Nejvíce odběratelů | Maximální počet odběratelů | EXTRASA_ex04odbmax | N(3)
Artikl | Identifikace artiklu | EXTRASA_sp60id | C(13)
Druh artiklu | Identifikace druhu artiklu | EXTRASA_sp61id | C(3)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
SPZ | SPZ vozidla | EXARTIKL_ex01spz | C(12)
Kalendář | Identifikace kalendáře | EXTRASA_spd3id | C(6)
Název kalendáře | Název kalendáře | SPKALEN_spd3nazkal | C(40)
Org. sel. | Identifikátor organizačního selektoru. | EXTRASA_sp11idzak | C(9)
Aktuální | Trasa je aktuální Ano/Ne | Výpočet | C(3)
Adresát | Identifikace adresáta | EXTRASAV_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Adresa | Číslo adresy adresáta. | EXTRASAV_ad02cisadr | C(2)
Popis | Popis adresy na trase | EXTRASAV_ex05popis | C(80)
Pozn. | Poznámka | EXTRASAV_ex05koment | M

    Viz.také

    Výjimky v kalendáři | Adresy adresátů | Adresář | Druhy artiklů | Obecné kalendáře | Organizační selektor | Vozidla expedice


Řidiči expedice

Popis

Jedná se o přehled řidičů, kteří „obsluhují“ vozidla, která jsou v expedici nadefinována. U každého řidiče se zadává:

¨ identifikace a jméno (pro komponentu expedice)

¨ adresát – výběr z číselníku adresátů (pod jakým číslem je řidič zadán v adresáři)

¨ kompletní adresa – automaticky se natáhne z údajů z adresáře

¨ kalendář – jaký typ kalendáře má řidič přidělen

¨ v případě, že se k němu vztahuje konkrétní obchodní selektor, tak identifikace obchodního selektoru

¨ aktuální – příznak Ano/Ne (zda je řidič aktuální, tzn. zda se může považovat za řidiče aktivní pro komponentu expedice)

Datový model

  • EXRIDIC Řidič - expedice
    • ADADSAT Adresát
    • ADSPOJ Spojení adresáta
      • ADADR Adresa
    • SPSEOB Obchodní selektor

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Výjimky v kalendáři | Výjimky v kalendáři
F7 | Obecné kalendáře | Obecné kalendáře
F2 | Adresář | Přehled adresátů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Obecné kalendáře | Obecné kalendáře
F2 | Spojení adresátů | Přehled spojení adresátů

    Formulář

    Formulář činnosti - Obecné kalendáře
Mřížka [Řidiči]
Řidič | Identifikace řidiče
 | Jméno řidiče
Listovací rámeček
Stránka #1 Řidiči
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
Jméno | Jméno kontaktní osoby.
UTO | Národní směrové číslo státu pro telefonní spojení (UTO).
Telefon | Telefonní číslo
Ulice | Ulice adresy adresáta (včetně čísla popisného).
Město | Město adresy adresáta.
PSČ | Poštovní směrovací číslo adresy adresáta.
Kalendář | Identifikace kalendáře
Obch. sel. | Identifikátor obchodního selektoru
Název obchodního selektoru | Název obchodního selektoru
Aktuální | Řidič je aktuální Ano/Ne
Stránka #2 Výběr
Řidič | Identifikace řidiče
 | Jméno řidiče
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
Obch. sel. | Identifikátor obchodního selektoru
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 | Platnost nebo neplatnost k datu
Aktuální | Řidič je aktuální Ano/Ne
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Řidiči] činnosti - Obecné kalendáře

    Mřížka [Řidiči] činnosti - Obecné kalendáře
Řidič | Identifikace řidiče
Jméno řidiče | Jméno řidiče
Adresát | Identifikace adresáta
Spojení | Číslo spojení adresáta.
Název adresáta | Název adresáta
Jméno | Jméno kontaktní osoby.
UTO | Národní směrové číslo státu pro telefonní spojení (UTO).
Telefon | Telefonní číslo
Ulice | Ulice adresy adresáta (včetně čísla popisného).
Město | Město adresy adresáta.
PSČ | Poštovní směrovací číslo adresy adresáta.
Obch. sel. | Identifikátor obchodního selektoru

    Atributy tisku

    Základní údaje
Řidič | Identifikace řidiče | EXRIDIC_ex07id | C(6)
Jméno řidiče | Jméno řidiče | EXRIDIC_ex07jmerid | C(40)
Adresát | Identifikace adresáta | EXRIDIC_ad01id | C(6)
Spojení | Číslo spojení adresáta. | EXRIDIC_ad11cisspo | C(2)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Telefon | Telefonní číslo | ADSPOJ_ad11cislo | C(60)
Fax | Faxové číslo | ADSPOJ_ad11fax | C(60)
Mobil | Číslo mobilního telefonu | ADSPOJ_ad11mobil | C(60)
e-mail | E-mail spojení adresáta | ADSPOJ_ad11email | C(60)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Kalendář | Identifikace kalendáře | EXRIDIC_spd3id | C(6)
Název kalendáře | Název kalendáře | SPKALEN_spd3nazkal | C(40)
Obch. sel. | Identifikátor obchodního selektoru | EXRIDIC_sp10idzak | C(9)
Název obchodního selektoru | Název obchodního selektoru | SPSEOB_sp10text | C(60)
Aktuální | Řidič je aktuální Ano/Ne | Výpočet | C(3)

    Viz.také

    Výjimky v kalendáři | Adresář | Obchodní selektor | Obecné kalendáře | Spojení adresátů


Převod dat z vážního serveru

Popis

V případě, že firma využívá při práci s expedicí váhu (např. firma, která dodává písek musí každé vozidlo s nákladem zvážit), vážní server zaznamenává údaje o jednotlivých vozidlech a pomocí činnosti „převod dat z vážního serveru“ jsou tyto údaje zároveň zaznamenány do systému.

Formulář

Formulář činnosti - Obecné kalendáře
Soubor vážního serveru Soubor vážního serveru


Parametry expedice

Popis

Parametry expedice slouží k nadefinování způsobu výběru dodacích listů na expediční příkaz. Mezi atributy činnosti parametry expedice patří:

¨ identifikátor a popis

¨ datové úložiště, pro které se tyto parametry budou uplatňovat

¨ SQL DL – doplnění dotazu SQL pro správné nastavení výběru dodacích listů na expediční příkaz. Sestavení tohoto SQL dotazu není triviální záležitost, proto by ji měl provádět pouze velmi zkušený uživatel nebo implementátor.

¨ poznámka parametru

¨ platnost parametru

Datový model

  • EXPARAM Parametry expedice

    • Formulář

    Formulář činnosti - Obecné kalendáře
Mřížka [Parametry expedice]
ID | Identifikátor parametrů expedice
Popis | Popis parametrů expedice
IDÚ | Datové úložiště uplatnění parametrů
SQL DL | Doplnění dotazu SQL pro výběr dodacích listů expedičního příkazu
Poznámka | Poznámka
Platnost | Platnost od
do | Platnost do

    Mřížka [Parametry expedice] činnosti - Obecné kalendáře

    Mřížka [Parametry expedice] činnosti - Obecné kalendáře
ID | Identifikátor parametrů expedice
IDÚ | Datové úložiště uplatnění parametrů
Popis | Popis parametrů expedice
Platnost | Platnost od
do | Platnost do

    Atributy tisku

    Základní údaje
ID | Identifikátor parametrů expedice | EXPARAM_ex13id | C(6)
IDÚ | Datové úložiště uplatnění parametrů | EXPARAM_ex13idu | C(2)
Popis | Popis parametrů expedice | EXPARAM_ex13poppar | C(40)
SQL DL | Doplnění dotazu SQL pro výběr dodacích listů expedičního příkazu | EXPARAM_ex13sql | M
Poznámka | Poznámka | EXPARAM_ex13koment | M
Platnost | Platnost od | EXPARAM_ex13datum | D
do | Platnost do | EXPARAM_ex13datumd | D


SPRAVOVANÝ MAJETEK

Popis

Komponenta spravovaný majetek je určena pro evidenci a správu spravovaného majetku, obvykle i inventarizovaného, různého druhu. Na každé kartě spravovaného majetku je evidován právě jeho jeden výskyt jednoznačně identifikovatelný v IS BM i v reálném světě, tj. jedná se o druhovou evidenci, kde je významnějším údajem stav oproti množství. Komponenta eviduje ve svých událostech též veškeré změny stavu, odpovědnosti i alokace, ale také případné servisní zásahy apod.

Viz.také

Změny spravovaného majetku | Aktuální hodnoty sprav.maj. | Rezervace majetku | Spravovaný majetek | Umístění spravovaného majetku


Změny spravovaného majetku

Popis

Uživatel má k dispozici události týkající se spravovaného majetku, např. jeho příjem, výdej, přeřazení, předání do opravy apod. Jednotlivé události jsou zapsány pomocí vytvoření příslušného procesu, tzn. není možno jednotlivé události vkládat ručně po stisku F3, ale vždy až po aktivaci příslušného procesu.

Atributy dostupné v této činnosti jsou:

¨ údaje o procesu – rok/IDÚ/číslo/identifikace operace

¨ datum události

¨ popis změny stavu - zařazen, vyřazen, neučeno apod.

¨ stručný popis události

¨ adresát, kterého se událost týká

¨ artikl - identifikace a název artiklu

¨ umístění spravovaného majetku

¨ atributy změny odpovědnosti, změny umístění - Ano, Ne (dochází-li např. k přeřazení sprav. majetku, určuje se, zda s jeho přeřazením za něj odpovídá jiný pracovník, či zda bylo přeřazeno na jiné umístění - do jiné kanceláře apod.)

¨ změna ceny - Ne, Nová cena, Přírůstek - zda současně se stavem události dochází ke změně ceny artiklu. Při zařazení se zcela jistě zadává nová cena artiklu, při různých opravách apod. může dojít k jejímu přírůstku apod.

¨ komentář k události

¨ jednotlivé selektory

Na záložce „aktuální stav artiklu“ jsou podrobné informace o stavu artiklu k aktuálnímu datu. K dispozici je název artiklu, čárový kód, výrobní číslo, třída SKP, komentář, stav artiklu (tzn. zařazen, vyřazen, neurčeno), jeho umístění. V případě vyřazení je zde kompletní informace nejen o datu vyřazení, ale zároveň i o datu, kdy byl majetek zařazen a za jakou cenu.

Datový model

  • SMUDAL Událost spravovaného majetku
    • SMMAJ Spravovaný majetek
      • SPARTIKN Název artiklu
      • SPSKP SKP
      • SMUMIS Umístění (alias SMUMIS6)
      • ADADSAT Adresát (alias ADADSAT2)
    • ADADSAT Adresát
    • SMUMIS Umístění
      • SPPRISTU Přístupové právo uživatele k věci
    • BWUZIVAT Uživatel systému
    • SPARTIKD Druh artiklu
    • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)
    • SPPRCOD Operace procesu
      • SPPRC Proces
    • SPTYP Druh procesu/operace

    • Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^S | Sumy - spravovaný majetek |
- | INFORMACE O ADRESÁTOVI | Vývěska adresáta a pošta adresáta...
- | UDÁLOSTI A KARTY ARTIKLU |
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Měrné jednotky | Číselník měrných jednotek
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Pořadové číslo artiklu | Seznam spravovaného majetku
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Umístění spravovaného majetku | Seznam umístění spravovaného majetku.

    Formulář

    Formulář činnosti - Sumy - spravovaný majetek
Mřížka [Změny spravovaného majetku]
Listovací rámeček
Stránka #1 Změny majetku
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
 | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Název druhu procesu
Datum | Datum události
Změna stavu | Změna stavu majetku
Popis | Popis události
Adresát | Identifikace adresáta
 | Název adresáta
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Pořadové číslo | Pořadové číslo
Název art. | Název artiklu
Umístění | Identifikátor umístění
 | Název umístění
Změna odpovědnosti | Změna odpovědnosti Ano/Ne
Změna umístění | Změna umístění Ano/Ne
Změna ceny | Změna ceny Ne/Nová cena/Přírůstek ceny
Cena | Cena majetku
Komentář | Komentář k události
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Aktuální stav artiklu
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Pořadové číslo
 | Název artiklu
Čárový kód | Čárový kód
Třída SKP | Identifikace třídy Standardní klasifikace produkce.
 | Název kategorie Standardní klasifikace produkce.
Výrobní číslo | Výrobní číslo
Umístění | Identifikátor umístění
 | Název umístění
Adresát | Identifikace adresáta
 | Název adresáta
Komentář | Komentář k evidovanému majetku
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Cena z. | Cena při zařazení
Cena v. | Cena při vyřazení
Stav | Stav majetku Nezařazen/Zařazen/Vyřazen
Datum zařazení | Datum zařazení
Datum vyřazení | Datum vyřazení
Stránka #3 Výběr
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu od
 | Pořadové číslo procesu do
 | Identifikátor druhu operace
 | Identifikátor druhu procesu
Datum od | Datum události od
 | Datum události do
Změna stavu | Změna stavu majetku
Adresát | Identifikace adresáta
 | Název adresáta
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Pořadové číslo
Název artiklu | Název artiklu
Stav | Stav majetku Nezařazen/Zařazen/Vyřazen
Změna odpovědnosti | Změna odpovědnosti Ano/Ne
Změna umístění | Změna umístění Ano/Ne
Umístění | Identifikátor umístění
Popis | Popis události
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsal | Identifikace uživatele systému
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Změny spravovaného majetku] činnosti - Sumy - spravovaný majetek

    Mřížka [Změny spravovaného majetku] činnosti - Sumy - spravovaný majetek
Označování | Označení záznamu
Datum | Datum události
Změna stavu | Změna stavu majetku
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Umístění | Identifikátor umístění
Popis | Popis události
Změna odpovědnosti | Změna odpovědnosti Ano/Ne
Změna umístění | Změna umístění Ano/Ne
Cena | Cena majetku
Poř. | Pořadové číslo
Adresát | Identifikace adresáta
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh | Identifikátor druhu operace
Pořadí | Pořadí stejného druhu operace v jednom procesu
Název druhu operace | Název druhu procesu
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující

    Atributy tisku

    Základní údaje
Rok | Rok v identifikaci procesu | SMUDAL_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | SMUDAL_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | SMUDAL_sp33cisd | C(8)
Druh operace | Identifikátor druhu operace | SMUDAL_sp07idtyp | C(6)
Pořadí druhu operace | Pořadí stejného druhu operace v jednom procesu | SMUDAL_sp33porad | N(2)
Název druhu operace | Název druhu operace | SPTYP_sp07text | C(30)
Datum události | Datum události | SMUDAL_sm02datum | D
Druh události | Druh události - Příjem, Výdej | Výpočet | C(6)
Změna stavu | Změna stavu majetku | Výpočet | C(9)
Popis události | Popis události | SMUDAL_sm02text | C(40)
Adresát | Identifikace adresáta | SMUDAL_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Druh artiklu | Identifikace druhu artiklu | SMUDAL_sp61id | C(3)
Název druhu artiklu | Název druhu artiklu | SPARTIKD_sp61nazdru | C(40)
Artikl | Identifikace artiklu | SMUDAL_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Pořadové číslo | Pořadové číslo | SMUDAL_sm01por | N(4)
Identifikátor umístění | Identifikátor umístění | SMUDAL_sm05id | C(6)
Název umístění | Název umístění | SMUMIS_sm05umis | C(40)
Změna odpovědnosti | Změna odpovědnosti Ano/Ne | Výpočet | C(3)
Změna umístění | Změna umístění Ano/Ne | Výpočet | C(3)
Změna ceny | Změna ceny Ne/Nová cena/Přírůstek ceny | Výpočet | C(14)
Cena za jednotku | Cena majetku | SMUDAL_sm02cenaj | N(20,4)
Komentář | Komentář k události | SMUDAL_sm02koment | M
Obch. sel. | Identifikátor obchodního selektoru | SMUDAL_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | SMUDAL_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | SMUDAL_sp20idzak | C(9)
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | SMUDAL_sp00datzap | T

    Viz.také

    OZNAČOVÁNÍ | Sumy - spravovaný majetek | INFORMACE O ADRESÁTOVI | UDÁLOSTI A KARTY ARTIKLU | Adresář | Druhy artiklů | Druhy operací | Druhy procesů | Měrné jednotky | Obchodní selektor | Organizační selektor | Spravovaný majetek | Technicko-věcný selektor | Umístění spravovaného majetku


Aktuální hodnoty sprav.maj.

Popis

Aktuální hodnoty poskytují uživateli přehled o jednotlivých hodnotách na kartách spravovaného majetku. Nejčastější aktuální hodnota, která se u sprav. majetku sleduje je jeho vyjádření ve finančním množství. Uživatel si výběrem může nadefinovat různý pohled na aktuální hodnoty, např. za adresáta, artikl nebo umístění.

Datový model

  • SMAH Aktuální hodnota spravovaného majetku
    • SPARTIKL Artikl
      • SPARTIKN Název artiklu
    • SPSTATDI Druh hodnoty
    • ADADSAT Adresát
    • SMUMIS Umístění
      • SPPRISTU Přístupové právo uživatele k věci

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Spravovaný majetek | Seznam spravovaného majetku
F2 | Umístění spravovaného majetku | Seznam umístění spravovaného majetku.

    Formulář

    Formulář činnosti - Umístění spravovaného majetku
Mřížka [Aktuální hodnoty sprav.maj.]
Listovací rámeček
Stránka #1 Aktuální hodnoty
 | Identifikace komponenty
Druh hodnoty | Identifikace druhu hodnoty
 | Název druhu hodnoty
Adresát | Identifikace adresáta
 | Název adresáta
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Umístění | Identifikátor umístění
 | Název umístění
Hodnota | Aktuální hodnota
Stránka #2 Výběr
Druh hodnoty | Identifikace druhu hodnoty
Adresát | Identifikace adresáta
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Umístění | Identifikátor umístění
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Aktuální hodnoty sprav.maj.] činnosti - Umístění spravovaného majetku

    Mřížka [Aktuální hodnoty sprav.maj.] činnosti - Umístění spravovaného majetku
Komponenta | Identifikace komponenty
Druh hodnoty | Identifikace druhu hodnoty
Adresát | Identifikace adresáta
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Umístění | Identifikátor umístění
Hodnota | Aktuální hodnota
Název druhu hodnoty | Název druhu hodnoty
Název adresáta | Název adresáta
Název artiklu | Název artiklu
Název umístění | Název umístění

    Atributy tisku

    Základní údaje
Komponenta | Identifikace komponenty | SMAH_sp06idsubs | C(3)
Druh hodnoty | Identifikace druhu hodnoty | SMAH_sp67id | C(3)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)
Identifikace adresáta | Identifikace adresáta | SMAH_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Artikl | Identifikace artiklu | SMAH_sp60id | C(13)
Druh artiklu | Identifikace druhu artiklu | SMAH_sp61id | C(3)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Identifikátor umístění | Identifikátor umístění | SMAH_sm05id | C(6)
Název umístění | Název umístění | SMUMIS_sm05umis | C(40)
Hodnota | Aktuální hodnota | SMAH_sm08hodnot | N(20,4)

    Viz.také

    Adresář | Druhy artiklů | Druhy hodnot | Spravovaný majetek | Umístění spravovaného majetku


Rezervace majetku

Popis

V této činnosti může uživatel jednak prohlížet doposud vytvořené rezervace a jednak samozřejmě zakládat rezervace nové. U každé vytvářené rezervace se zadávají údaje o začátku a konci rezervace (tj. datum a čas od - do), rezervovaném majetku, je možno zadat i pro koho (jméno konkrétního uživatele), kategorii, popis a komentář. To jsou základní údaje, které uživatel vstupuje při vytváření nové rezervace.

Při vytváření rezervací může nastat situace, kdy dojde k časovému překryvu jednotlivých záznamů. Už při vytváření takového záznamu systém hlásí, že došlo k překryvu záznamů a u dané události se objeví výstražný žlutý trojúhelník s vykřičníkem. Při zápisu této události systém nahlásí "kolizi záznamů" a je zcela v kompetenci uživatele, zda kolizi odstraní či nikoliv (tzn. zda záznam rezervace přepíše nebo zapíše i tak, přesto, že je tam hlášena kolize a danou situaci si vyřeší jinak).

Datový model

  • SMREZER Rezervace
    • SMMAJ Spravovaný majetek
      • SPARTIKN Název artiklu
      • SMUMIS Umístění
        • SPPRISTU Přístupové právo uživatele k věci
    • ADADSAT Adresát
    • DIPOPDIA Kategorie diáře
    • SPSETV Technicko-věcný selektor
    • SPSEOR Organizační selektor
    • SPSEOB Obchodní selektor
    • BWUZIVAT Uživatel systému
    • SPARTIKD Druh artiklu

    • Vyvolávané činnosti

    K. | Činnost | Popis
- | UDÁLOSTI A KARTY ARTIKLU |
- | INFORMACE O ADRESÁTOVI | Vývěska adresáta a pošta adresáta...
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Kategorie rezervace | Seznam kategorií upřesňujících záznam rezervace.
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Spravovaný majetek | Seznam spravovaného majetku
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

    Formulář činnosti - INFORMACE O ADRESÁTOVI
Mřížka [Rezervace majetku]
Listovací rámeček
Stránka #1 Rezervace
Začátek | Datum a čas od kterého rezervace začíná
Konec | Datum a čas ve kterém rezervace končí
Adresát | Identifikace adresáta
 | Název adresáta
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Pořadové číslo
Název art. | Název artiklu
Pro | Identifikace uživatele systému
Kategorie | Identifikátor kategorie.
 | Text výstižně popisující kategorii.
Popis | Popis důvodu rezervace
Komentář | Komentář k rezervaci
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Výběr
Začátek | Datum a čas od kterého rezervace začíná
Konec | Datum a čas ve kterém rezervace končí
Adresát | Identifikace adresáta
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Pořadové číslo
Název artiklu | Název artiklu
Kategorie | Identifikátor kategorie.
Pro | Identifikace uživatele systému
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsal | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Rezervace majetku] činnosti - INFORMACE O ADRESÁTOVI

    Mřížka [Rezervace majetku] činnosti - INFORMACE O ADRESÁTOVI
Označování | Označení záznamu
Začátek | Datum a čas od kterého rezervace začíná
Konec | Datum a čas ve kterém rezervace končí
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Název kategorie | Text výstižně popisující kategorii.

    Atributy tisku

    Základní údaje
Čas začátku rezervace | Datum a čas od kterého rezervace začíná | SMREZER_sm03od | T
Čas konce rezervace | Datum a čas ve kterém rezervace končí | SMREZER_sm03do | T
Adresát | Identifikace adresáta | SMREZER_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Druh artiklu | Identifikace druhu artiklu | SMREZER_sp61id | C(3)
Název druhu artiklu | Název druhu artiklu | SPARTIKD_sp61nazdru | C(40)
Artikl | Identifikace artiklu | SMREZER_sp60id | C(13)
Pořadové číslo | Pořadové číslo | SMREZER_sm01por | N(4)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Překryv událostí | Událost je v překryvu s jinou | Výpočet | C(3)
Rezervace pro pracovníka | Jméno uživatele systému | BWUZIVA1_bw01jmeno | C(30)
Identifikátor kategorie | Identifikátor kategorie. | SMREZER_di02id | C(6)
Název kategorie | Text výstižně popisující kategorii. | DIPOPDIA_di02kateg | C(40)
Popis události | Popis důvodu rezervace | SMREZER_sm03text | C(40)
Komentář události | Komentář k rezervaci | SMREZER_sm03koment | M
Obchodní selektor | Identifikátor obchodního selektoru | SMREZER_sp10idzak | C(9)
Organizační selektor | Identifikátor organizačního selektoru. | SMREZER_sp11idzak | C(9)
Technicko-věcný selektor | Identifikátor technicko-věcného selektoru. | SMREZER_sp20idzak | C(9)
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | SMREZER_sp00datzap | T
Rok | Rok v identifikaci procesu | SMREZER_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | SMREZER_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | SMREZER_sp33cisd | C(8)
Pořadí | Pořadí stejného druhu operace v jednom procesu | SMREZER_sp33porad | N(2)
Druh operace | Identifikátor druhu operace | SMREZER_sp07idtyp | C(6)
Komponenta | Identifikace komponenty | SMREZER_sp06idsubs | C(3)

    Viz.také

    UDÁLOSTI A KARTY ARTIKLU | INFORMACE O ADRESÁTOVI | Adresář | Druhy artiklů | Kategorie diáře | Obchodní selektor | Organizační selektor | Spravovaný majetek | Technicko-věcný selektor


Spravovaný majetek

Popis

Tato činnost představuje pro uživatele vlastní evidenci jednotlivých karet spravovaného majetku. Není nutno zvlášť popisovat všechny položky, které jsou přístupny na formuláři - jejich význam je většinou snadno odvoditelný od jejich názvu. Podrobněji se zastavíme pouze u těchto atributů:

¨ identifikace druhu artiklu - spravovaný majetek je možno členit do několika druhů. Výhodou takového rozdělení je možnost evidence vlastní číselné řady pro každý z druhů spravovaného majetku. Znamená to tedy, že stejné číslo spravovaného majetku může být použito několikrát, pokud je tento majetek vždy jiného druhu (při vstupu nové karty spravovaného majetku s identifikací artiklu, která je již v BM zavedena, dochází automaticky k předplnění dalšího volného pořadového čísla pro danou identifikaci artiklu).

¨ mezi další údaje patří výrobní číslo, zaškrtávátko zda lze rezervovat (tzn. zda je možno daný sprav. majetek využívat pro rezervace), možnost zadání čárového kódu, třídy SKP, umístění, kam spravovaný majetek spadá a zodpovídá. Zde se uvádí jméno pracovníka, který je za daný spravovaný majetek zodpovědný (nenabízí se však pracovníci zadaní ve mzdách, ale nabízí se výběr pracovníků z adresáře, tzn. při zadávání jednotlivých pracovníků do položky zodpovídá je nutno mít tyto pracovníky uvedeny v adresáři).

¨ důležitým atributem u spravovaného majetku je stav (zařazen, vyřazen) a datum, kdy ke změně tohoto stavu došlo. Datum zařazení nebo vyřazení se na kartu spravovaného majetku automaticky dostává z příslušných událostí sprav. majetku. V okamžiku aktualizace (vložení, modifikace, zrušení) události sprav. majetku se aktualizují atributy na kartě spravovaného majetku s respektováním pořadí událostí dle jejich data. Následně vstupují v platnost omezení aktualizace dané karty (např. atribut změna stavu a změna ceny nelze po zápisu události již opravovat, u vyřazených artiklů již nelze měnit stav apod.).

Po zadání těchto údajů je možno u každého spravovaného majetku uvést jeho název v různých jazycích (viz. záložka "názvy artiklu") a prohlížet si další údaje o majetku, viz. záložka "další". Záložka aktuální hodnoty poskytuje uživateli přehled o aktuálních hodnotách dané karty spravovaného majetku, nejčastěji asi hodnota spravovaného majetku ve finančním vyjádření.

Na základě zvolení Palety na záložce Výběr je možno přehled artiklů zvýraznit i barevně.

Datový model

  • SMMAJ Spravovaný majetek
    • SPARTIKN Název artiklu
    • BWUZIVAT Uživatel systému
    • SPSKP SKP
    • SPSETV Technicko-věcný selektor
    • SPSEOR Organizační selektor
    • SPARTIKD Druh artiklu
    • ADADSAT Adresát
    • SMUMIS Umístění
      • SPPRISTU Přístupové právo uživatele k věci

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Události správy artiklu |
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
- | Dokumenty artiklu | Dokumenty artiklu
- | UDÁLOSTI A KARTY ARTIKLU |
- | Legenda palety barev |
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Měrné jednotky | Číselník měrných jednotek
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Palety barev kategorií | Palety barev kategorií
F2 | Spojení | Seznam spojení za adresáta.
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Třídy SKP | Třídy Standardní klasifikace produkce
F2 | Umístění spravovaného majetku | Seznam umístění spravovaného majetku.

    Formulář

     | Formulář činnosti - Spojení
 | Mřížka [Spravovaný majetek]
 | Listovací rámeček
 | Stránka #1 Majetek
 |  | Identifikace druhu artiklu
 | Artikl | Identifikace artiklu
 |  | Pořadové číslo
 | Název artiklu | Název artiklu
 | Výr. číslo | Výrobní číslo
 | Lze rezervovat | Majetek lze rezervovat
 | Čárový kód | Čárový kód
 | Třída SKP | Identifikace třídy Standardní klasifikace produkce.
 |  | Název kategorie Standardní klasifikace produkce.
 | Zodpovídá | Identifikace adresáta
 |  | Název adresáta
 | Umístění | Identifikátor umístění
 |  | Název umístění
 | Stav | Stav majetku Nezařazen/Zařazen/Vyřazen
 | Zařazení | Datum zařazení
 |  | Cena při zařazení
 | Vyřazení | Datum vyřazení
 |  | Cena při vyřazení
 | Org. sel. | Identifikátor organizačního selektoru.
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Účet.sel. | Účetní selektor artiklu
 | Zapsal | Jméno uživatele systému
 |  | Datum a čas zápisu záznamu události
 | Stránka #2 Další
 | Komentář | Komentář k evidovanému majetku
 | Stránka #3 Aktuální hodnoty
 | Mřížka [Aktuální hodnoty]
 | Stránka #4 Názvy artiklu
 | Mřížka [Názvy artiklu v jazycích]
 | Jazyk | Identifikace jazyka
 | Název artiklu | Název artiklu
 | Stránka #5 Kategorie artiklu
 | Mřížka [Kategorie artiklu]
 |  | Kategorie
Identifikace kategorie události správy artiklu |  |  | Platnost
Datum platnosti od |  |  | Platnost do
Datum platnosti do |  |  | Adresát
Identifikace adresáta |  |
Název adresáta |  |
Číslo spojení adresáta. |  |  | Popis
Popis události |  |  | Poznámka
Poznámka |  |  | Zapsal
Jméno uživatele systému |  |  | Datum a čas zápisu
Datum a čas zápisu záznamu události
 | Stránka #6 Výběr
 |  | Identifikace druhu artiklu
 | Artikl | Identifikace artiklu
 |  | Pořadové číslo
 | Název artiklu | Název artiklu
 | Zařazen od | Datum zařazení
 | do | Zařazení - do data
 | Vyřazen od | Datum vyřazení
 | do | Vyřazení - do data
 | Zodpovídá | Identifikace adresáta
 |  | Název adresáta
 | Umístění | Identifikátor umístění
 | Třída SKP | Identifikace třídy Standardní klasifikace produkce.
 | Rezerv. | Majetek lze rezervovat
 | Stav | Stav majetku Nezařazen/Zařazen/Vyřazen
 | Org. sel. | Identifikátor organizačního selektoru.
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Účetní selektor | Účetní selektor artiklu
 | Zapsal | Identifikace uživatele systému
 | Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 |  | Platnost nebo neplatnost k datu
 | Paleta | Vybrat záznamy všech kategorií v paletě
 |  | Identifikace palety barev
 | Výběr | Určení výběru
 | Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Spravovaný majetek] činnosti - Spojení

    Mřížka [Spravovaný majetek] činnosti - Spojení
Označování | Označení záznamu
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Poř. | Pořadové číslo
Stav | Stav majetku Nezařazen/Zařazen/Vyřazen
Datum zařazení | Datum zařazení
Cena z. | Cena při zařazení
Datum vyřazení | Datum vyřazení
Cena v. | Cena při vyřazení

    Mřížka [Aktuální hodnoty] činnosti - Spojení

    Mřížka [Aktuální hodnoty] činnosti - Spojení
Umístění | Identifikátor umístění
Adresát | Identifikace adresáta
Druh hodnoty | Identifikace druhu hodnoty
Hodnota | Aktuální hodnota
Název druhu hodnoty | Název druhu hodnoty
Název umístění | Název umístění

    Mřížka [Názvy artiklu v jazycích] činnosti - Spojení

    Mřížka [Názvy artiklu v jazycích] činnosti - Spojení
Jazyk | Identifikace jazyka
Název artiklu | Název artiklu

    Mřížka [Kategorie artiklu] činnosti - Spojení

    Mřížka [Kategorie artiklu] činnosti - Spojení
Kategorie | Identifikace kategorie události správy artiklu
Název kategorie | Název kategorie události správy artiklu
Platnost od | Datum platnosti od
Platnost do | Datum platnosti do
Adresát | Identifikace adresáta
Název adresáta | Název adresáta

    Atributy tisku

    Základní údaje
Druh artiklu | Identifikace druhu artiklu | SMMAJ_sp61id | C(3)
Artikl | Identifikace artiklu | SMMAJ_sp60id | C(13)
Pořadové číslo | Pořadové číslo | SMMAJ_sm01por | N(4)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Výrobní číslo | Výrobní číslo | SMMAJ_sm01vyrcis | C(20)
Majetek lze rezervovat | Majetek lze rezervovat | Výpočet | C(3)
Čárový kód | Čárový kód | SMMAJ_sm01carkod | C(36)
Třída SKP | Identifikace třídy Standardní klasifikace produkce. | SMMAJ_sp17idskp | C(8)
Název třídy Standardní klasifikace produkce | Název kategorie Standardní klasifikace produkce. | SPSKP_sp17text | C(70)
Zodpovídá | Identifikace adresáta | SMMAJ_ad01id | C(6)
Zodpovídá jméno adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Identifikátor umístění | Identifikátor umístění | SMMAJ_sm05id | C(6)
Název umístění | Název umístění | SMUMIS_sm05umis | C(40)
Stav | Stav majetku Nezařazen/Zařazen/Vyřazen | Výpočet | C(9)
Datum zařazení | Datum zařazení | SMMAJ_sm01datzar | D
Cena z. | Cena při zařazení | SMMAJ_sm01cenaz | N(20,4)
Datum vyřazení | Datum vyřazení | SMMAJ_sm01datvyr | D
Cena v. | Cena při vyřazení | SMMAJ_sm01cenav | N(20,4)
Organizační selektor | Identifikátor organizačního selektoru. | SMMAJ_sp11idzak | C(9)
Technicko-věcný selektor | Identifikátor technicko-věcného selektoru. | SMMAJ_sp20idzak | C(9)
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | SMMAJ_sp00datzap | T
Komentář majetku | Komentář k evidovanému majetku | SMMAJ_sm01koment | M
Název umístění | Název umístění | SMUMIS6_sm05umis | C(40)

    Při pohybu v Druh hodnoty
    Název druhu hodnoty Název druhu hodnoty SPSTATDI_sp67druinf C(40)

    Při pohybu v Aktuální hodnoty
Identifikátor umístění | Identifikátor umístění | SMAH_sm05id | C(6)
Adresát | Identifikace adresáta | SMAH_ad01id | C(6)
Druh hodnoty | Identifikace druhu hodnoty | SMAH_sp67id | C(3)
Hodnota | Aktuální hodnota | SMAH_sm08hodnot | N(20,4)

    Viz.také

    Události správy artiklu | OZNAČOVÁNÍ | Prezentace artiklu | Dokumenty artiklu | UDÁLOSTI A KARTY ARTIKLU | Legenda palety barev | Adresář | Druhy artiklů | Měrné jednotky | Organizační selektor | Palety barev kategorií | Spojení | Technicko-věcný selektor | Třídy SKP | Umístění spravovaného majetku


Umístění spravovaného majetku

Popis

Jedná se o číselník, který obsahuje informace o možném umístění spravovaného majetku. Může se jednat o sklad, poschodí, místnost, určitou kancelář apod. Ke každému umístění lze nadefinovat i organizační selektor. Aktuální umístění každého spravovaného artiklu je evidováno na jeho kartě, přičemž jeho změna je realizována událostí sprav. majetku.

Ke každému umístění se definují přístupová práva, tzn., že vybraní uživatelé mají umístění přístupné, pro ostatní je práce s ním zakázána nebo mohou události s daným umístěním pouze číst, nemohou je však zapsat.

Datový model

  • SMUMIS Umístění
    • BWUZIVAT Uživatel systému
    • SPPRISTU Přístupové právo uživatele k věci
    • SPSEOR Organizační selektor

    • Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci
F2 | Organizační selektor | Číselník organizačních selektorů

    Formulář

    Formulář činnosti - Organizační selektor
Mřížka [Umístění]
Listovací rámeček
Stránka #1 Umístění spravovaného majetku
Umístění | Identifikátor umístění
Název | Název umístění
Organizační selektor | Identifikátor organizačního selektoru.
Komentář | Komentář k umístění
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Výběr
Umístění | Identifikátor umístění
Název | Název umístění
Org. sel. | Identifikátor organizačního selektoru.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Umístění] činnosti - Organizační selektor

    Mřížka [Umístění] činnosti - Organizační selektor
Umístění | Identifikátor umístění
Název umístění | Název umístění

    Atributy tisku

    Základní údaje
Identifikátor umístění | Identifikátor umístění | SMUMIS_sm05id | C(6)
Název umístění | Název umístění | SMUMIS_sm05umis | C(40)
Org. sel. | Identifikátor organizačního selektoru. | SMUMIS_sp11idzak | C(9)
Komentář umístění | Komentář k umístění | SMUMIS_sm05koment | M
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | SMUMIS_sp00datzap | T

    Viz.také

    Přístupová práva | Organizační selektor


DPH

Popis

Tato komponenta řeší problematiku práce s daní z přidané hodnoty. Eviduje samostatné události obsahující informace o DPH, případně zajišťuje výpočet DPH pro jiné komponenty. DPH je možno evidovat i v cizích měnách.

Problematika sazeb DPH je řešena otevřeně vůči jakýmkoliv změnám, ať už v počtu sazeb DPH, různosti zdanění pro určitá místa prodeje i změn sazeb v čase. Kromě toho má uživatel možnost tuto komponentu využít k výpočtu podkladů pro daňové přiznání.

Při aktivaci této komponenty má uživatel k dispozici tyto činnosti:

¨ události DPH

¨ typ zdanitelného plnění

¨ daňová přiznání

¨ umístění DPH

Viz.také

Události DPH | Typ zdanitelného plnění | Daňová přiznání | Umístění DPH | Předměty zdanitelného plnění | Uplatnění předmětů zdanitelného plnění


Události DPH

Popis

Po spuštění činnosti má nejprve uživatel možnost zvolit si vlastní výběr zobrazení přehledu událostí DPH. Na atributu výběr má uživatel kromě standardního běžného výběru ještě možnost využít i obecný výběr:

¨ přiznání plný a krácený nárok – zobrazí se pouze ty události, které mají v atributu způsob uplatnění odpočtu daně uvedeno číslo 1 (=100%) nebo 3 (=kráceno)

¨ souhrnné hlášení – zobrazí se události, které jsou podkladem pro Souhrnné hlášení za příslušné období

Událostí je každý údaj, který obsahuje informace o dani z přidané hodnoty. Jednotlivé události DPH (tj. daňové doklady) vznikají prostřednictvím procesů. Jinými slovy lze toto vysvětlit tak, že někde v operativní evidenci v systému (např. komponenta obchod nebo zálohy) je vytvořen prvotní doklad (např. vystavená faktura nebo vystavený zálohový list) a na základě procesu a v něm nadefinovaných transformací dojde k zápisu do událostí DPH.

Většina položek (atributů) se v přehledu událostí vůbec nevstupuje, jsou k dispozici pouze pro prohlížení. Editovat je možno pouze atribut popis. Ostatní položky jsou vytvořeny procesně a uživatel je nemůže měnit. Samozřejmě je možno využít klávesy Ctrl S (suma), která sečte zobrazené údaje.

Na záložce "Účetnictví" má uživatel ke každé události informace o tom, jakým způsobem bylo o této události účtováno. Po stisku klávesy F9 je možno aktivovat danou operaci účetnictví.

Na záložce „Detaily k události DPH“ má uživatel ke každé události informace o tom, zda a jakým způsobem daná událost DPH spadá do kontrolního hlášení. Po stisku klávesy F5, je možno přejít do „Detailu k události DPH“.

Pod menu Volby se uživateli nabízejí další možnosti, které může v událostech DPH využít, např. si ke každé události zobrazit diagram procesu, strom hlavního procesu atd., takže uživatel má přehled, z jakého obchodního případu (dodací list, faktura apod.) událost DPH vznikla.

Další popis se týká konkrétních atributů činnosti události DPH:

¨ číslo operace - na základě číselné řady a druhu daného procesu jsou předplněny atributy týkající se procesu (číslo, identifikace operace, pořadí, název)

¨ odpočet/nápočet – předplněno na základě masky operace v procesu

¨ datum – předplněn datem z předchozí operace (v případě ručního vstupu operace DPH, tzn. pokud operace DPH zahajuje proces, se předplní aktuálním datem)

¨ druh události – běžná, dodatečné hlášení, ostatní ... – předplněno na základě masky operace v procesu, případně výběr ručně

¨ popis – vlastní popis události

¨ adresát – výběr adresáta z adresáře – v případě, že je operace součástí procesu, předplní se na základě transformace adresát z předchozí operace

¨ umístění – umístění DPH (k jednotlivým umístěním je možno nadefinovat přístupová práva. Pokud je na události DPH uvedeno umístění, na které nemá uživatel právo ani čtení, nemá danou událost DPH k dispozici).

¨ typ zd. pl. – předplněn pomocí transformace (nejčastěji na základě předchozí operace obchodu a tam je zadán na základě typu zdan. plnění uvedeného artiklu) a zároveň s typem zdanitelného plnění se automaticky přenese typ místa, způsob uplatnění a předmět. Pokud není operace DPH součástí žádného procesu, ale vstupuje se zde samostatně, uživatel si ručně vybere typ zdan. plnění a ostatní atributy.

¨ PID – pomocná identifikace záznamu DPH – identifikace DPH ze zálohy. Přiřazuje se buď automaticky nebo ručně události DPH, která následuje po úhradě zálohy. Slouží pro automatické vyčíslení již zdaněné hodnoty DPH z titulu zálohy v navazujících dokladech jejího vyúčtování, případně její následnou kontrolu z pohledu DPH.

¨ měna – automaticky předplněna pomocí transformace (předplňuje se na základě měny uvedené na záložce „další“ u adresáta uvedeného na události)

¨ základ DPH v ZM – celková částka základu DPH v zahraniční měně

¨ DPH v ZM – celková částka DPH v zahraniční měně

¨ základ DPH v RM – celková částka základu DPH v referenční měně

¨ DPH v RM – celková částka DPH v referenční měně

¨ DPH v RM (zaokr.) – celková částka DPH v referenční měně zaokrouhlená

¨ selektory – identifikace selektorů, které se na událost DPH zapisují automaticky (obchodní selektor na základě selektoru, který má u sebe uveden adresát události, organizační selektor na základě selektoru uvedeného u umístění DHP a technicko-věcný selektor na základě selektoru, který je uveden na kartě obchodovatelného artiklu v předchozí události obchodu)

¨ zapsal – kdo a kdy danou událost zapsal (datum, čas, jméno uživatele)

Po stisku pravého tlačítka myši na tučném atributu „Adresát“ si uživatel může vyvolat další potřebné informace vztahující se k adresátovi dané události, např. události daného adresáta v jednotlivých komponentách, aktuální hodnoty adresáta, obratové hodnoty a další podrobné údaje z adresáře (tj. adresa, spojení, cenové skupiny, ...).

Po stisku pravého tlačítka myši na tučném atributu „PID“ má uživatel následující možnosti:

¨ přehled záloh – aktivuje se činnost přehled záloh s předplněnou výběrovou záložkou (podle PID je předplněno číslo zálohy a identifikace adresáta). Uživatel má k dispozici údaje o záloze – celková částka, kolik je uhrazeno, kolik zbývá uhradit apod.

¨ události o zálohách – aktivuje se činnost události záloh, kde je na základě PID zobrazena událost dané zálohy

¨ události DPH – uživateli se aktivuje daná událost DPH

Datový model

  • DPUDA Událost DPH
    • ADSPOJ Spojení adresáta
      • ADADSAT Adresát
      • ADADR Adresa
    • SPPRISTU Přístupové právo uživatele k věci
    • DPUMIST Umístění DPH
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU3)
    • BWUZIVAT Uživatel systému
    • SPPRCOD Operace procesu
      • SPTYP Druh procesu/operace
      • SPPRC Proces

    • Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^S | SUMy - DPH |
- | INFORMACE O ZÁLOHÁCH | Informace o zálohách
F2 | Adresář | Přehled adresátů
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Předměty zdanitelného plnění | Předměty zdanitelného plnění
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Typ zdanitelného plnění | Číselník typů zdanitelného plnění
F2 | Umístění DPH | Přehled umístění DPH

    Formulář

    Formulář činnosti - INFORMACE O ZÁLOHÁCH
Mřížka [Události - DPH]
Listovací rámeček
Stránka #1 Události
 | Pořadové číslo procesu
 | Identifikace datového úložiště číselné řady procesu
 | Rok v identifikaci procesu
 | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Odpočet/Nápočet
 | Název druhu procesu
Datum | Datum uskutečnění zdanitelného plnění
 | Běžná, opravné hlášení, neuplatněné DPH ....
Popis | Popis události DPH
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
Umístění | Identifikace umístění DPH
 | Název umístění DPH
Typ zd.pl. | Identifikace typu zdanitelného plnění
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie ....
 | Způsob uplatnění odpočtu daně - 1=100%,2=0%,3=kráceno
Předmět | Identifikace předmětu zdanitelného plnění
PID | Pomocná identifikace záznamu DPH
Měna | Kód měny - oceňovací jednotky.
 | Referenční měna
Kurs | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup.
 | Množství oceňovací jednotky v kursu.
Sazba | Procentní sazba daně z přidané hodnoty
Základ DPH v ZM | Částka základu daně z přidané hodnoty v ZM - odpočet
DPH v ZM | Částka daně z přidané hodnoty v zahraniční měně - odpočet
Základ DPH v RM | Částka základu daně z přidané hodnoty v referenční měně
DPH v RM | Částka daně z přidané hodnoty v referenční měně
Zaokrouhlovat | Zaokrouhlovat částku daně z přidané hodnoty ?
DPH v RM (zaokr.) | Zaokrouhlená částka daně z přidané hodnoty v referenční měně
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
 | Název adresáta
Stránka #2 Účetnictví
Mřížka [Účetnictví]
Stránka #3 Výběr
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu od
Číslo procesu do | Pořadové číslo procesu do
 | Identifikátor druhu operace
Druh procesu | Identifikátor druhu procesu
Datum | Datum
do | Datum do
O/N | Zobrazení událostí vyjadřujících odpočet, nápočet nebo obojí
Typ místa | Výběr podle typu místa - všechna, tuzemsko, zahraničí, Evropská Unie ....
Typ zd.pl. | Identifikace typu zdanitelného plnění
Předmět | Identifikace předmětu zdanitelného plnění
Popis | Popis události DPH
PID | Pomocná identifikace záznamu DPH
Adresát | Identifikace adresáta
Spojení | Číslo spojení adresáta.
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Umístění | Identifikace umístění DPH
Událost | Běžná, opravné hlášení, neuplatněné DPH ....
Měna | Kód měny - oceňovací jednotky.
Uplat. | Způsob uplatnění odpočtu daně - 1=100%,2=0%,3=kráceno
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
Základ DPH v ZM od | Částka základu daně z přidané hodnoty v ZM - odpočet
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsal | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska
do | Částka základu daně z přidané hodnoty v ZM - odpočet
Základ DPH v RM od | Částka základu daně z přidané hodnoty v referenční měně
do | Částka základu daně z přidané hodnoty v referenční měně
DPH v ZM od | Částka daně z přidané hodnoty v zahraniční měně - odpočet
do | Částka daně z přidané hodnoty v zahraniční měně - odpočet
DPH v RM od | Částka daně z přidané hodnoty v referenční měně
do | Částka daně z přidané hodnoty v referenční měně
DPH v RM (zaokr.) od | Zaokrouhlená částka daně z přidané hodnoty v referenční měně
do | Zaokrouhlená částka daně z přidané hodnoty v referenční měně

    Mřížka [Události - DPH] činnosti - INFORMACE O ZÁLOHÁCH

    Mřížka [Události - DPH] činnosti - INFORMACE O ZÁLOHÁCH
Označování | Označení záznamu
O/N | Odpočet/Nápočet
Datum | Datum uskutečnění zdanitelného plnění
Typ zd.pl. | Identifikace typu zdanitelného plnění
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie ....
Adresát | Identifikace adresáta
Popis | Popis události DPH
Základ DPH v ZM | Částka základu daně z přidané hodnoty v ZM - odpočet
Měna | Kód měny - oceňovací jednotky.
DPH v ZM | Částka daně z přidané hodnoty v zahraniční měně - odpočet
Základ DPH v RM | Částka základu daně z přidané hodnoty v referenční měně
DPH v RM | Částka daně z přidané hodnoty v referenční měně
DPH v RM (zaokr.) | Zaokrouhlená částka daně z přidané hodnoty v referenční měně
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh operace | Identifikátor druhu operace
Referenční identifikace | Referenční identifikace operace
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
Sazba DPH | Procentní sazba daně z přidané hodnoty
Umístění DPH | Identifikace umístění DPH
PID | Pomocná identifikace záznamu DPH
Název adresáta | Název adresáta

    Mřížka [Účetnictví] činnosti - INFORMACE O ZÁLOHÁCH

    Mřížka [Účetnictví] činnosti - INFORMACE O ZÁLOHÁCH
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Datum | Datum účetního případu
Účet | Identifikátor účtu účetnictví
Strana | Strana účtu MD/Dal
Částka | Finanční částka
Popis události | Popis účetní události
Částka ZM | Částka v zahraniční měně
IDP | Identifikace párování
Org. sel. | Identifikátor organizačního selektoru.

    Atributy tisku

    Základní údaje
Rok | Rok v identifikaci procesu | DPUDA_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | DPUDA_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | DPUDA_sp33cisd | C(8)
Druh operace | Identifikátor druhu operace | DPUDA_sp07idtyp | C(6)
Komponenta | Identifikace komponenty | DPUDA_sp06idsubs | C(3)
Pořadí | Pořadí stejného druhu operace v jednom procesu | DPUDA_sp33porad | N(2)
O/N | Odpočet/Nápočet | Výpočet | C(7)
Název druhu operace | Název druhu operace | SPTYP_sp07text | C(30)
Datum | Datum uskutečnění zdanitelného plnění | DPUDA_dp02datzdp | D
Popis | Popis události DPH | DPUDA_dp02text | C(40)
PID | Pomocná identifikace záznamu DPH | DPUDA_dp02pid | C(32)
Měna | Kód měny - oceňovací jednotky. | DPUDA_oc01id | C(3)
Referenční měna | Referenční měna | DPUDA_oc01id1 | C(3)
Kurs | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup. | DPUDA_oc03kurz | N(20,6)
Množství | Množství oceňovací jednotky v kursu. | DPUDA_oc03mn | N(5)
Typ zd.pl. | Identifikace typu zdanitelného plnění | DPUDA_dp03id | C(3)
Předmět | Identifikace předmětu zdanitelného plnění | DPUDA_dp16id | C(6)
Název | Název typu zdanitelného plnění | DPZPT_dp03text | C(40)
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie .... | Výpočet | C(9)
Pro vývoz | Pro vývoz do zahraničí - Vývoz zboží, Vývoz služeb, Mezinárodní přeprava, .... | Výpočet | C(33)
Zdan.plnění | Pro tuzemsko a zahraniční odpočet - Osvobozená,Osvobozená pro koef.,Snížená,Základní,Dočasné použití | Výpočet | C(20)
Uplatnění odpočtu daně | Způsob uplatnění odpočtu daně - 1=100%,2=0%,3=kráceno | Výpočet | C(1)
Sazba DPH | Procentní sazba daně z přidané hodnoty | DPUDA_dp02sazba | N(5,2)
Základ DPH v RM | Částka základu daně z přidané hodnoty v referenční měně | DPUDA_dp02czarm | N(20,4)
DPH v RM | Částka daně z přidané hodnoty v referenční měně | DPUDA_dp02cdprm | N(20,4)
DPH v RM (zaokr.) | Zaokrouhlená částka daně z přidané hodnoty v referenční měně | DPUDA_dp02cdzrm | N(20,4)
Základ DPH v ZM | Částka základu daně z přidané hodnoty v ZM - odpočet | DPUDA_dp02czazm | N(20,4)
DPH v ZM | Částka daně z přidané hodnoty v zahraniční měně - odpočet | DPUDA_dp02cdpzm | N(20,4)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Úplný název adresáta | Úplný název adresáta | ADADSAT_ad01adsat2 | M
Účet | Identifikátor spojení na bankovní účet adresáta. | ADADSAT_ad03cisban | C(2)
Adresa | Číslo adresy adresáta. | ADADR_ad02cisadr | C(2)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)
Komentář | Kometář k adrese adresáta. | ADADR_ad02pozn | M
Datum a čas zápisu | Datum a čas zápisu záznamu události | DPUDA_sp00datzap | T
Umístění DPH | Identifikace umístění DPH | DPUDA_dp15id | C(6)
Název umístění DPH | Název umístění DPH | DPUMIST_dp15text | C(40)

    Viz.také

    OZNAČOVÁNÍ | SUMy - DPH | INFORMACE O ZÁLOHÁCH | Adresář | Druhy operací | Druhy procesů | Kategorie adresátů | Měny a kursy | Obchodní selektor | Organizační selektor | Předměty zdanitelného plnění | Spojení adresátů | Technicko-věcný selektor | Typ zdanitelného plnění | Umístění DPH


Typ zdanitelného plnění

Popis

Jedná se o číselník typů zdanitelného plnění a dalších činností s ním souvisejících, který se v celém informačním systému používá při práci s DPH. Tento číselník je dodáván se systémem naplněný tak, aby odpovídal stávající legislativě. Další změny v legislativě v letech si uživatel opravuje sám pomocí balíčků, které mu jsou se změnami v legislativě od nás dodávány.

V systému se u každého artiklu eviduje typ plnění DPH, který je pro artikl platný. V událostech DPH je pak tento typ zdanitelného plnění uváděn jako implicitní (s možností změny). Každý typ zdanitelného plnění, resp. jeho sazby, je navíc spojen s určitým technicko-věcným selektorem, což umožňuje využít komponentu statistika.

Každý „typ zdanitelného plnění“ obsahuje informace o jeho identifikaci, názvu, zdanitelném plnění (např. bez daně, snížená sazba, osvobozené plnění apod.), možnostech při vývozu do zahraničí a účelu daně.

Druhou záložkou jsou „sazby DPH“, přičemž každá sazba se vztahuje k právě aktuálnímu typu zdanitelného plnění. Uživatel při jejich zadávání vstupuje tyto údaje:

¨ typ místa - tuzemsko, zahraničí, Evropská Unie apod.

¨ platnost od - od kterého data je daná sazba platná

¨ sazba DPH - vstup - sazba při nákupu (sazba se vždy vztahuje k typu místa, takže bude rozdíl mezi tuzemskem a zahraničním)

¨ účet - vstup - zadaný analytický účet je dostupný jako výstupní atribut komponenty v transformaci do účetnictví. Systém hledá, jaká je zde nadefinována sazba DPH a podle sazby a tohoto nadefinovaného účtu proběhne zaúčtování.

¨ sazba DPH - výstup - sazba při prodeji (sazba se vždy vztahuje k typu místa, takže bude rozdíl mezi tuzemskem a zahraničním)

¨ účet - výstup - zadaný analytický účet je dostupný jako výstupní atribut komponenty v transformaci do účetnictví. Systém hledá, jaká je zde nadefinována sazba DPH a podle sazby a tohoto nadefinovaného účtu proběhne zaúčtování.

¨ zaokrouhlení na řád - výběr na jaký řád se mají výsledné částky daně zaokrouhlovat

¨ nahoru od cifry - ještě souvisí se zaokrouhlováním (od jakého čísla se má zaokrouhlovat nahoru či-li výše)

¨ tech. sel. - předplňuje se při vstupu události s touto sazbou. Při zadávání technického selektoru se pak pomocí komponenty statistika dají zjistit takové údaje jako např. prodej bez daně, prodej do zahraniční s daní - bez daně apod.

Na záložce „uplatnění předmětů“ má uživatel k dispozici varianty zdanitelného plnění konkrétní sazby. Ke každému uplatnění se zadává kdy a za jakých podmínek se toto uplatnění uplatní. U každého uplatnění se navíc eviduje jeho platnost od do a ta uplatnění, která jsou již neplatná, se uživateli zobrazují šedivě. Při vstupu událostí obchodu se pak na základě kombinace – typ a místo plnění a plátce/neplátce předplní odpovídající uplatnění předmětů.

Na záložce „substituce TZP“ se ke každému typu zdanitelného plnění definuje pravidlo, které umožní uplatnit uvedenou sazbu než je sazba definovaná na obchodovatelném artiklu.

Příklad:

¨ je vstupována událost obchodu - prodej pro adresáta s typem místa EU, který je plátcem DPH a artiklem, který má u sebe uvedenu klasifikací Z (zboží) a typ zdanitelného plnění ZA1

¨ pro TZP ZA1 je definovaná substituce (OSV, EU, Nápočet, Plátce DPH=Ano, Z)

¨ potom na události obchodu bude předplněn TZP OSV

Datový model

  • DPZPT Typ zdanitelného plnění

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Klasifikace objektů | Klasifikace objektů
F2 | Předměty zdanitelného plnění | Předměty zdanitelného plnění
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Typ zdanitelného plnění | Číselník typů zdanitelného plnění
F2 | Účtový rozvrh | Seznam syntetických a analytických účtů.

    Formulář

    Formulář činnosti - Typ zdanitelného plnění
Mřížka [Typy zdanit. plnění]
Listovací rámeček
Stránka #1 Typy zdanitelného plnění
Typ zdanitelného plnění | Identifikace typu zdanitelného plnění
Název | Název typu zdanitelného plnění
Zdan.plnění | Pro tuzemsko a zahraniční odpočet - Osvobozená,Osvobozená pro koef.,Snížená,Základní,Dočasné použití
Pro vývoz | Pro vývoz do zahraničí - Vývoz zboží, Vývoz služeb, Mezinárodní přeprava, ....
Účel daně | Účel daně
Stránka #2 Sazby DPH
Mřížka [Sazba]
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie ....
Platnost od | Datum platnosti sazby DPH od
Sazba DPH - vstup | Procentní sazba daně z přidané hodnoty na vstupu
Účet - vstup | Identifikátor účtu
Sazba DPH - výstup | Procentní sazba daně z přidané hodnoty na výstupu
Účet - výstup | Identifikátor účtu účetnictví
Zaokrouhlení na řád | Zaokrouhlení na řád.
Nahoru od cifry | Zaokrouhlení nahoru od cifry
Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Název technicko-věcného selektoru.
Stránka #3 Uplatnění předmětů
Mřížka [Uplatnění předmětů]
Paragraf | Paragraf zákona o DPH
Předmět | Identifikace předmětu zdanitelného plnění
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie ....
Plátce DPH | Příznak plátce DPH
O/N | Odpočet/Nápočet
Účet | Identifikátor účtu účetnictví
Popis protiúčtu | Cizojazyčný popis účtu.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Název technicko-věcného selektoru | Název technicko-věcného selektoru.
Klasif.art. | Identifikace klasifikace objektu artiklu
Platnost od | Platnost od
do | Platnost do
Poznámka | Poznámka
Stránka #4 Substituce TZP
Mřížka [Substituce TZP]
TZP | Identifikace typu zdanitelného plnění substituovaného na událostech obchodu
Název | Název typu zdanitelného plnění
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie ....
O/N | Odpočet/Nápočet
DPH | Příznak plátce DPH
Klasifikace artiklu | Identifikace klasifikace objektu artiklu
Platnost od | Platnost od
do | Platnost do

    Mřížka [Typy zdanit. plnění] činnosti - Typ zdanitelného plnění

    Mřížka [Typy zdanit. plnění] činnosti - Typ zdanitelného plnění
Typ zd.pl. | Identifikace typu zdanitelného plnění
Název | Název typu zdanitelného plnění

    Mřížka [Sazba] činnosti - Typ zdanitelného plnění

    Mřížka [Sazba] činnosti - Typ zdanitelného plnění
Typ zd.pl. | Identifikace typu zdanitelného plnění
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie ....
Platnost od | Datum platnosti sazby DPH od
Vstup | Procentní sazba daně z přidané hodnoty na vstupu
Výstup | Procentní sazba daně z přidané hodnoty na výstupu

    Mřížka [Uplatnění předmětů] činnosti - Typ zdanitelného plnění

    Mřížka [Uplatnění předmětů] činnosti - Typ zdanitelného plnění
TZP | Identifikace typu zdanitelného plnění
Předmět | Identifikace předmětu zdanitelného plnění
Popis předmětu | Popis předmětu zdanitelného plnění
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie ....
Plátce DPH | Příznak plátce DPH
O/N | Odpočet/Nápočet
Účet | Identifikátor účtu účetnictví
Popis protiúčtu | Cizojazyčný popis účtu.
Platnost od | Platnost od
do | Platnost do
Tech. sel. | Identifikátor technicko-věcného selektoru.
Název technicko-věcného selektoru | Název technicko-věcného selektoru.

    Mřížka [Substituce TZP] činnosti - Typ zdanitelného plnění

    Mřížka [Substituce TZP] činnosti - Typ zdanitelného plnění
TZP | Identifikace typu zdanitelného plnění substituovaného na událostech obchodu
Název | Název typu zdanitelného plnění
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie ....
O/N | Odpočet/Nápočet
DPH | Příznak plátce DPH
Klasifikace artiklu | Identifikace klasifikace objektu artiklu
Platnost od | Platnost od
do | Platnost do

    Atributy tisku

    Základní údaje
Typ zd.pl. | Identifikace typu zdanitelného plnění | DPZPT_dp03id | C(3)
Název | Název typu zdanitelného plnění | DPZPT_dp03text | C(40)
Zdan.plnění | Pro tuzemsko a zahraniční odpočet - Osvobozená,Osvobozená pro koef.,Snížená,Základní,Dočasné použití | Výpočet | C(20)
Pro vývoz | Pro vývoz do zahraničí - Vývoz zboží, Vývoz služeb, Mezinárodní přeprava, .... | Výpočet | C(33)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(60)
Popis předmětu | Popis předmětu zdanitelného plnění | DPZPCH_dp16popcha | C(40)
Klasifikace artiklu | Identifikace klasifikace objektu artiklu | DPZPCH_pa13idart | C(12)
Pouze DPH | Možné zadat pouze na události DPH Ano/Ne | Výpočet | C(3)
Výraz předpl. | Logický v jazyce Foxpro pro předplnění předmětu ZDP | DPZPCH_dp16vyrpre | M
TZP | Identifikace typu zdanitelného plnění substituovaného na událostech obchodu | DPZPD_dp03id2 | C(3)
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie .... | Výpočet | C(9)
O/N | Odpočet/Nápočet | Výpočet | C(7)
DPH | Příznak plátce DPH | Výpočet | C(11)
Název | Název typu zdanitelného plnění | DPZPT3_dp03text | C(40)
Klasifikace artiklu | Identifikace klasifikace objektu artiklu | DPZPD_pa13idart | C(12)
Platnost od | Platnost od | DPZPD_dp20datum | D
do | Platnost do | DPZPD_dp20datumd | D

    Při pohybu v Sazby DPH
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie .... | Výpočet | C(9)
Platnost od | Datum platnosti sazby DPH od | DPZPS_dp04datpld | D
Sazba DPH - vstup | Procentní sazba daně z přidané hodnoty na vstupu | DPZPS_dp04sazba | N(5,2)
Účet pro nápočet | Identifikátor účtu účetnictví | DPZPS_uc01id | C(9)
Sazba DPH - výstup | Procentní sazba daně z přidané hodnoty na výstupu | DPZPS_dp04sazbao | N(5,2)
Účet pro odpočet | Identifikátor účtu | DPZPS_uc01id2 | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | DPZPS_sp20idzak | C(9)

    Při pohybu v Uplatnění předmětu
Typ zd.pl. | Identifikace typu zdanitelného plnění | DPZPTU_dp03id | C(3)
Účet | Identifikátor účtu účetnictví | DPZPTU_uc01id | C(9)
Předmět | Identifikace předmětu zdanitelného plnění | DPZPTU_dp16id | C(6)
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie .... | Výpočet | C(9)
Plátce DPH | Příznak plátce DPH | Výpočet | C(11)
O/N | Odpočet/Nápočet | Výpočet | C(7)
Klasifikace artiklu | Identifikace klasifikace objektu artiklu | DPZPTU_pa13idart | C(12)
Platnost od | Platnost od | DPZPTU_dp18datum | D
do | Platnost do | DPZPTU_dp18datumd | D

    Viz.také

    Klasifikace objektů | Předměty zdanitelného plnění | Technicko-věcný selektor | Účtový rozvrh


Daňová přiznání

Popis

Pomocí této činnosti má uživatel možnost evidovat již vytvořená daňová přiznání a zároveň může v případě potřeby definovat nová. Daňové přiznání vyplývající ze zákona je v této činnosti při dodávce informačního systému již nadefinováno.

I přesto se uživateli pokusíme postup tvorby daňového přiznání více přiblížit. Na první obrazovce se záložkou "daňová přiznání" si uživatel vytvoří hlavičku daňového přiznání. Uvede název a výběr událostí, které mají do daňového přiznání vstupovat (tzn. zda se jedná o běžné, opravné či dodatečné daňové hlášení). V případě potřeby může uživatel u přiznání uvést i libovolnou poznámku.

Pro definici daňového přiznání je možno určit její platnost zadáním data platnosti OD a DO. Vyplněná platnost definice se uplatní na výběrové záložce, kde je možné následně podle tohoto atributu vybírat daňová přiznání:

¨ platná i neplatná

¨ platná dnes

¨ platná minulý měsíc

Pro vytvoření daňového přiznání DPH však nestačí mít jen správné definice včetně položek DP. Uživatel musí mít správně vyplněnu i volnou kartu „hlavička daňového přiznání“ (viz obr. 11) se všemi potřebnými údaji (menu Obecné – Volné karty – Hlavička daňového přiznání). Podle platného znění daného roku je k dispozici volná karta „hlavička daňového přiznání 2009“ a „hlavička daňového přiznání 2010“. Tato volná karta se používá i při výpočtu souhrnného hlášení. Údaje zapsané na této volné kartě se pak při vytváření vlastního daňového přiznání (ať už v textové či elektronické podobě) automaticky přenášejí na první stránku daňového přiznání, kde jsou k dispozici veškeré nacionále o uživateli, proto je nutné mít zde veškeré atributy vyplněny opravdu správně a pečlivě.

Do výpočtu daňového přiznání není možné zadat měsíc a rok výpočtu, který nespadá do období platnosti definice daňového přiznání (v případě, že je období platnosti vyplněno).

Důležitější atributy daňového přiznání se skrývají pod záložkou "Položky DP". Zde uživatel v podstatě zadává jednotlivé řádky daňového přiznání. Vstupuje se:

¨ popis řádku - jednoznačná identifikace a popis řádku

¨ dlouhý popis – dlouhý popis řádku daňového přiznání (není povinný atribut)

¨ paragraf - číslo paragrafu řádku daň. přiznání (musí být větší než 0). Paragraf slouží k seskupení položek DP do jedné kategorie (např. přijatá zdanitelná plnění, uskutečněná zdanitelná plnění apod.)

¨ pořadí - pořadí řádku v daňovém přiznání

¨ označ. - číslo, které se na řádku daňového přiznání zobrazuje hned za položkou název, např. řádka z dovozu sníž. sazba daně má označení [12,16], tzn. že v položce označ. musí být uvedeno [12,16]

¨ způsob výpočtu - může být výraz nebo hodnota. Podle toho, co je zde vybráno se liší i další zobrazení položek.

Při zadání možnosti výraz se pak v daném řádku DP zobrazuje částka, která je uvedena v činnosti proměnné DP. Další položky jsou:

¨ pomocný - zda se jedná či nejedná pouze o pomocný řádek, který nebude přenesen na DP a jehož výpočet bude použit pro další řádky

¨ výraz - uvádí se vlastní název proměnné

¨ základ/vstup/výstup - zaškrtávací políčka, která udávají, do kterého sloupce daný řádek DP patří

Při zadání možnosti hodnota jsou položky následující:

¨ pomocný - zda se jedná či nejedná pouze o pomocný řádek, který nebude přenesen na DP a jehož výpočet bude použit pro další řádky

¨ O/N - zda se jedná o odpočet či nápočet

¨ uplat. - způsob uplatnění odpočtu daně (-, 1=100%, 2=0%, 3=kráceno)

¨ typ místa - může být zahraniční, tuzemsko nebo EU

¨ zdan. plnění - může nabývat těchto stavů: osvobozená, osvobozená pro koef., snížená, základní, dočasné použití, finanční pronájem

¨ předmět – identifikace předmětu zdanitelného plnění

¨ identifikátor technicko věcného selektoru – pro přiznání DPH je nutno filtrovat události DPH zahrnuté do výpočtu hodnot některých řádků přiznání podle techn.-věcného selektoru uvedeného v události DPH. Bez tohoto řešení by neúměrně narostl počet předmětů zdanitelného plnění a zároveň by se ztížil vstup událostí DPH pro případy, které jsou pro většinu firem používajících IS BM pouze ojedinělé (např. vývoz zlata apod.). Proto zde má uživatel na řádku u „způsobu výpočtu = hodnota“ možnost uvádět i identifikaci technicko věcného selektoru. Je-li v řádku selektor vyplněn a je uveden jiný selektor než ‘-’, potom se do vypočtených hodnot daného řádku zahrnou pouze události DPH, které mají v sobě zapsán tento technicko-věcný selektor. Je-li v daném řádku uveden selektor ‘-’, potom budou vypočtené hodnoty řádku nulové. Řádek definice s technicko–věcným selektorem není možné běžně vstupovat[1].

¨ základ/vstup/výstup - zaškrtávací políčka, která udávají, do kterého sloupce daný řádek DP patří

¨ XML atributy – jsou dodávány naplněné spolu s definicí daňového přiznání. Jejich vyplnění slouží pro bezproblémové odeslání daňového přiznání DPH elektronickou cestou, tj. ADIS.

Pod menu Volby má uživatel k dispozici následující činnosti:

¨ výpočet daňového přiznání (klávesa F5)

¨ vypočtená daňová přiznání (klávesa F6) – v této činnosti lze daňové přiznání vytisknout, jsou zde k dispozici předlohy výstupu nebo případně odeslat elektronicky

¨ proměnné daňového přiznání (klávesa F7)

[1] Při exportu definice daňového přiznání do balíčku je v případě, že tato definice daňového přiznání obsahuje řádek s vyplněným selektorem jiným než ‘-’ zobrazen dotaz „Nastavit vyplněný technicko-věcný selektor v řádcích definice na hodnotu ‘-’?”.

Datový model

  • DPPRI Daňové přiznání

    • Formulář

    Formulář činnosti - Technicko-věcný selektor
Mřížka [Daňová přiznání]
Listovací rámeček
Stránka #1 Daňová přiznání
Daň.přiz. | Identifikace daňového přiznání
Název | Název daňového přiznání
Událost | Běžná, opravné hlášení, neuplatněné DPH ....
Platnost | Platnost definice daňového přiznání od
do | Platnost definice daňového přiznání do
Poznámka | Poznámka k daňovému přiznání
Stránka #2 Položky DP
Mřížka [řádek DP]
Daň.přiz. | Identifikace daňového přiznání
Název | Název daňového přiznání
 | Identifikace řádku daňového přiznání
Popis řádku | Popis řádku daňového přiznání
Dlouhý popis | Popis řádku daňového přiznání - dlouhý
Paragraf | Číslo paragrafu řádku daňového přiznání
Pořadí | Pořadí řádku daňového přiznání v paragrafu
Označ. | Označení řádku na formuláři vypočtené daně
Pomocný | Pomocný řádek, který nebude přenesen na DP
Způsob výp. | Způsob výpočtu řádku - hodnota/součet řádků
O/N | Odpočet/Nápočet
Tuzemsko | Vybírat typ místa tuzemsko
Zahraničí | Vybírat typ místa zahraničí
EU | Vybírat typ místa EU
Zdan.pln. | Respektovat zdanitelé plnění
Zdan.plnění | Pro tuzemsko a zahraniční odpočet - Osvobozená,Osvobozená pro koef.,Snížená,Základní,Dočasné použití
Předmět | Identifikace předmětu zdanitelného plnění
Tech. sel. | Identifikátor technicko-věcného selektoru.
Uplat. | Způsob uplatnění odpočtu daně - 1=100%,2=0%,3=kráceno
Výraz | Výraz pro výpočet řádku
Základ | Zahrnout na daňové přiznání / vypočítat hodnotu sloupce - základ daně
Vstup | Zahrnout na daňové přiznání / vypočítat hodnotu sloupce - DPH vstup
Výstup | Zahrnout na daňové přiznání / vypočítat hodnotu sloupce - DPH výstup
XML | Název XML atributu pro hodnotu základu daně
 | Název XML atributu pro hodnotu vstupu daně
 | Název XML atributu pro hodnotu výstupu daně
Stránka #3 Výběr
Daň.přiz. | Identifikace daňového přiznání
Název | Název daňového přiznání
Událost | Běžná, opravné hlášení, neuplatněné DPH ....
Platnost | Výběr platnosti definice daňového přiznání
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Daňová přiznání] činnosti - Technicko-věcný selektor

    Mřížka [Daňová přiznání] činnosti - Technicko-věcný selektor
Daň.přiz. | Identifikace daňového přiznání
Název | Název daňového přiznání
Událost | Běžná, opravné hlášení, neuplatněné DPH ....
Platnost | Platnost definice daňového přiznání od
do | Platnost definice daňového přiznání do

    Mřížka [řádek DP] činnosti - Technicko-věcný selektor

    Mřížka [řádek DP] činnosti - Technicko-věcný selektor
Daň.přiz. | Identifikace daňového přiznání
Řádek | Identifikace řádku daňového přiznání
Paragraf | Číslo paragrafu řádku daňového přiznání
Pořadí | Pořadí řádku daňového přiznání v paragrafu
Označ. | Označení řádku na formuláři vypočtené daně
Popis řádku | Popis řádku daňového přiznání
Způsob výp. | Způsob výpočtu řádku - hodnota/součet řádků
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie ....
Pro vývoz | Pro vývoz do zahraničí - Vývoz zboží, Vývoz služeb, Mezinárodní přeprava, ....
Zdan.plnění | Pro tuzemsko a zahraniční odpočet - Osvobozená,Osvobozená pro koef.,Snížená,Základní,Dočasné použití

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Výpočet DP | Výpočet daňového přiznání
F6 | Vypočtená daňová přiznání | Zobrazení vypočtených daňových přiznání
F7 | Proměnné daňového přiznání | Vstup proměnných daňového přiznání
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Viz.také

    Výpočet DP | Vypočtená daňová přiznání | Proměnné daňového přiznání | Technicko-věcný selektor


Umístění DPH

Popis

Nadefinováním umístění DPH má uživatel možnost rozlišit si firemní toky DPH podle zvoleného umístění (např. podle jednotlivých oddělení nebo středisek apod.). U každého umístění se zadává jeho identifikace, adresát a organizační selektor, který je k umístění vztažen. Ke každému umístění je možno nadefinovat i přístupová práva.

Datový model

  • DPUMIST Umístění DPH
    • ADADSAT Adresát
    • ADSPOJ Spojení adresáta
      • ADADR Adresa
    • SPSEOR Organizační selektor
    • SPPRISTU Přístupové právo uživatele k věci

    • Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci
F2 | Adresář | Přehled adresátů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Spojení adresátů | Přehled spojení adresátů

    Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Umístění DPH]
Umístění DPH | Identifikace umístění DPH
 | Název umístění DPH
Adresát | Identifikace adresáta
 | Název adresáta
 | Číslo spojení adresáta.
 | Jméno kontaktní osoby.
 | Telefonní číslo
 | Ulice adresy adresáta (včetně čísla popisného).
 | Ulice bytu adresáta (včetně čísla popisného)
 | Poštovní směrovací číslo adresy adresáta.
 | Město adresy adresáta.
Org. sel. | Identifikátor organizačního selektoru.
 | Název organizačního selektoru

    Mřížka [Umístění DPH] činnosti - Přístupová práva

    Mřížka [Umístění DPH] činnosti - Přístupová práva
Umístění DPH | Identifikace umístění DPH
Název umístění DPH | Název umístění DPH
Org. sel. | Identifikátor organizačního selektoru.
Adresát | Identifikace adresáta
 | Název adresáta
Jméno kontaktní osoby | Jméno kontaktní osoby.
Telefon | Telefonní číslo
Ulice | Ulice adresy adresáta (včetně čísla popisného).
Byt | Ulice bytu adresáta (včetně čísla popisného)
PSČ | Poštovní směrovací číslo adresy adresáta.
Město | Město adresy adresáta.

    Atributy tisku

    Základní údaje
Umístění DPH | Identifikace umístění DPH | DPUMIST_dp15id | C(6)
Název umístění DPH | Název umístění DPH | DPUMIST_dp15text | C(40)
Org. sel. | Identifikátor organizačního selektoru. | DPUMIST_sp11idzak | C(9)
Adresát | Identifikace adresáta | DPUMIST_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Úplný název adresáta | Úplný název adresáta | ADADSAT_ad01adsat2 | M
Spojení | Číslo spojení adresáta. | DPUMIST_ad11cisspo | C(2)
Telefon | Telefonní číslo | ADSPOJ_ad11cislo | C(60)
Jméno kontaktní osoby | Jméno kontaktní osoby. | ADSPOJ_ad11jmeno | C(40)
Funkce | Funkce kontaktní osoby | ADSPOJ_ad11funkce | C(40)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
Byt | Ulice bytu adresáta (včetně čísla popisného) | ADADR_ad02byt | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)

    Viz.také

    Přístupová práva | Adresář | Organizační selektor | Spojení adresátů


Předměty zdanitelného plnění

Popis

Předměty zdanitelného plnění jsou základním nástrojem pro určení druhů zdanitelného plnění. Jednotlivé předměty samostatně neznamenají nic, důležitá je jejich kombinace s uplatněním, kde se určuje typ zdanitelného plnění, typ místa a zda se jedná o odpočet či nápočet. Tyto jednotlivé vytvořené kombinace jsou potom podkladem pro vyplnění příslušných řádek daňového přiznání.

Atribut „pouze DPH“ s možností Ano/Ne určuje zda se bude daný předmět dát zadat pouze na události DPH (pak volba Ano) nebo zda je možno ho využít i v zadávání událostí v ostatních komponentách, např. v obchodu. Standardně tedy v tomto atributu je vhodné mít nastavenu možnost Ne.

Pro předměty ZP je zároveň velmi důležité jejich datum platnosti (to se zadává na záložce uplatnění předmětu).

Datový model

  • DPZPCH Předmět zdanitelného plnění

    • Formulář

    Formulář činnosti - Typ zdanitelného plnění
Mřížka [Předměty zdanitelného plnění]
Předmět | Identifikace předmětu zdanitelného plnění
Popis předmětu | Popis předmětu zdanitelného plnění
Listovací rámeček
Stránka #1 Předměty zdanitelného plnění
Další popis | Další popis předmětu zdanitelného plnění
Pouze DPH | Možné zadat pouze na události DPH Ano/Ne
Klasifikace artiklu | Identifikace klasifikace objektu artiklu
Výraz předpl. | Logický v jazyce Foxpro pro předplnění předmětu ZDP
Aktuální | Předmět je aktuální pro aktuální implementaci IS BM
Poznámka | Poznámka
Stránka #2 Uplatnění předmětu
Mřížka [Uplatnění předmětu]
Paragraf | Paragraf zákona o DPH
Typ zd.pl. | Identifikace typu zdanitelného plnění
Název | Název typu zdanitelného plnění
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie ....
Plátce DPH | Příznak plátce DPH
O/N | Odpočet/Nápočet
Účet | Identifikátor účtu účetnictví
Text | Cizojazyčný popis účtu.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Název technicko-věcného selektoru | Název technicko-věcného selektoru.
Klasif.art. | Identifikace klasifikace objektu artiklu
Platnost od | Platnost od
do | Platnost do
Poznámka | Poznámka

    Mřížka [Předměty zdanitelného plnění] činnosti - Typ zdanitelného plnění

    Mřížka [Předměty zdanitelného plnění] činnosti - Typ zdanitelného plnění
Předmět | Identifikace předmětu zdanitelného plnění
Popis předmětu | Popis předmětu zdanitelného plnění
Pouze DPH | Možné zadat pouze na události DPH Ano/Ne
Klasifikace artiklu | Identifikace klasifikace objektu artiklu

    Mřížka [Uplatnění předmětu] činnosti - Typ zdanitelného plnění

    Mřížka [Uplatnění předmětu] činnosti - Typ zdanitelného plnění
Předmět | Identifikace předmětu zdanitelného plnění
Typ zd.pl. | Identifikace typu zdanitelného plnění
Název | Název typu zdanitelného plnění
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie ....
O/N | Odpočet/Nápočet
Účet | Identifikátor účtu účetnictví
Popis účtu | Cizojazyčný popis účtu.
Platnost od | Platnost od
do | Platnost do
Plátce DPH | Příznak plátce DPH

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Klasifikace objektů | Klasifikace objektů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Typ zdanitelného plnění | Číselník typů zdanitelného plnění
F2 | Účtový rozvrh | Seznam syntetických a analytických účtů.

    Atributy tisku

    Základní údaje
Předmět | Identifikace předmětu zdanitelného plnění | DPZPCH_dp16id | C(6)
Popis předmětu | Popis předmětu zdanitelného plnění | DPZPCH_dp16popcha | C(40)
Další popis | Další popis předmětu zdanitelného plnění | DPZPCH_dp16popch2 | C(40)
Poznámka | Poznámka | DPZPCH_dp16koment | M
Klasifikace artiklu | Identifikace klasifikace objektu artiklu | DPZPCH_pa13idart | C(12)
Pouze DPH | Možné zadat pouze na události DPH Ano/Ne | Výpočet | C(3)
Výraz předpl. | Logický v jazyce Foxpro pro předplnění předmětu ZDP | DPZPCH_dp16vyrpre | M
Aktuální | Předmět je aktuální pro aktuální implementaci IS BM | Výpočet | C(3)
Název | Název typu zdanitelného plnění | DPZPT_dp03text | C(40)
Popis účtu | Cizojazyčný popis účtu. | UCROZVRN_uc04popuct | C(40)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(60)

    Při pohybu v Uplatnění předmětu
Paragraf | Paragraf zákona o DPH | DPZPTU_dp18parag | C(40)
Typ zd.pl. | Identifikace typu zdanitelného plnění | DPZPTU_dp03id | C(3)
Účet | Identifikátor účtu účetnictví | DPZPTU_uc01id | C(9)
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie .... | Výpočet | C(9)
Plátce DPH | Příznak plátce DPH | Výpočet | C(11)
O/N | Odpočet/Nápočet | Výpočet | C(7)
Tech. sel. | Identifikátor technicko-věcného selektoru. | DPZPTU_sp20idzak | C(9)
Klasifikace artiklu | Identifikace klasifikace objektu artiklu | DPZPTU_pa13idart | C(12)
Platnost od | Platnost od | DPZPTU_dp18datum | D
Poznámka | Poznámka | DPZPTU_dp18koment | M
do | Platnost do | DPZPTU_dp18datumd | D

    Viz.také

    Klasifikace objektů | Technicko-věcný selektor | Typ zdanitelného plnění | Účtový rozvrh


Uplatnění předmětů zdanitelného plnění

Popis

Tato činnost poskytuje uživateli přehled nadefinovaných uplatnění předmětů zdanitelného plnění. Ke každému uplatnění se zadává kdy a za jakých podmínek se toto uplatnění uplatní (tzn. jakého paragrafu se týká a do jakého řádku daňového přiznání pak vstupuje). Ke každému uplatnění, které vstupuje do kontrolního hlášení, je určen oddíl.

U každého uplatnění se navíc eviduje jeho platnost od - do a ta uplatnění, která jsou již neplatná, jsou zvýrazněna šedou barvou.

Datový model

  • DPZPTU Uplatnění předmětu ZDP
    • DPZPCH Předmět zdanitelného plnění
    • DPZPT Typ zdanitelného plnění
    • UCROZVRH Účet z rozvrhu
      • UCROZVRN Cizí popis účtu
    • SPSETV Technicko-věcný selektor

    • Formulář

    Formulář činnosti - Technicko-věcný selektor
Mřížka [Uplatnění předmětů zdanitelného plnění]
Listovací rámeček
Stránka #1 Uplatnění předmětů zdanitelného plnění
Paragraf | Paragraf zákona o DPH
Předmět | Identifikace předmětu zdanitelného plnění
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie ....
Plátce DPH | Příznak plátce DPH
O/N | Odpočet/Nápočet
Typ zd.pl. | Identifikace typu zdanitelného plnění
Název | Název typu zdanitelného plnění
Účet | Identifikátor účtu účetnictví
Popis účtu | Cizojazyčný popis účtu.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Název technicko-věcného selektoru | Název technicko-věcného selektoru.
Klasifikace artiklu | Identifikace klasifikace objektu artiklu
Platnost od | Platnost od
do | Platnost do
Poznámka | Poznámka
Stránka #2 Výběr
Paragraf | Paragraf zákona o DPH
Předmět | Identifikace předmětu zdanitelného plnění
Popis předmětu | Popis předmětu zdanitelného plnění
Typ zd.pl. | Identifikace typu zdanitelného plnění
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie ....
O/N | Odpočet/Nápočet
Účet | Identifikátor účtu účetnictví
Tech. sel. | Identifikátor technicko-věcného selektoru.
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 | Platnost nebo neplatnost k datu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Uplatnění předmětů zdanitelného plnění] činnosti - Technicko-věcný selektor

    Mřížka [Uplatnění předmětů zdanitelného plnění] činnosti - Technicko-věcný selektor
Předmět | Identifikace předmětu zdanitelného plnění
Popis předmětu | Popis předmětu zdanitelného plnění
Paragraf | Paragraf zákona o DPH
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie ....
Plátce DPH | Příznak plátce DPH
O/N | Odpočet/Nápočet
Typ zd.pl. | Identifikace typu zdanitelného plnění
Název | Název typu zdanitelného plnění
Účet | Identifikátor účtu účetnictví
Popis účtu | Cizojazyčný popis účtu.
Platnost od | Platnost od
do | Platnost do
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Klasifikace objektů | Klasifikace objektů
F2 | Předměty zdanitelného plnění | Předměty zdanitelného plnění
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Typ zdanitelného plnění | Číselník typů zdanitelného plnění
F2 | Účtový rozvrh | Seznam syntetických a analytických účtů.

    Atributy tisku

    Základní údaje
Paragraf | Paragraf zákona o DPH | DPZPTU_dp18parag | C(40)
Předmět | Identifikace předmětu zdanitelného plnění | DPZPTU_dp16id | C(6)
Popis předmětu | Popis předmětu zdanitelného plnění | DPZPCH_dp16popcha | C(40)
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie .... | Výpočet | C(9)
Plátce DPH | Příznak plátce DPH | Výpočet | C(11)
O/N | Odpočet/Nápočet | Výpočet | C(7)
Typ zd.pl. | Identifikace typu zdanitelného plnění | DPZPTU_dp03id | C(3)
Název | Název typu zdanitelného plnění | DPZPT_dp03text | C(40)
Účet | Identifikátor účtu účetnictví | DPZPTU_uc01id | C(9)
Text | Cizojazyčný popis účtu. | UCROZVRN_uc04popuct | C(40)
Tech. sel. | Identifikátor technicko-věcného selektoru. | DPZPTU_sp20idzak | C(9)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(60)
Klasifikace artiklu | Identifikace klasifikace objektu artiklu | DPZPTU_pa13idart | C(12)
Poznámka | Poznámka | DPZPTU_dp18koment | M
Platnost od | Platnost od | DPZPTU_dp18datum | D
do | Platnost do | DPZPTU_dp18datumd | D
Klasifikace artiklu | Identifikace klasifikace objektu artiklu | DPZPCH_pa13idart | C(12)
Pouze DPH | Možné zadat pouze na události DPH Ano/Ne | Výpočet | C(3)
Výraz předpl. | Logický v jazyce Foxpro pro předplnění předmětu ZDP | DPZPCH_dp16vyrpre | M

    Viz.také

    Klasifikace objektů | Předměty zdanitelného plnění | Technicko-věcný selektor | Typ zdanitelného plnění | Účtový rozvrh


ODPISOVANÝ MAJETEK

Popis

Komponenta investiční majetek se zabývá především evidencí investičního majetku, to představuje především jeho inventarizaci a činnosti s tímto spojené, jako je pořízení, nákup, prodej apod. Každý investiční majetek má vytvořenu svoji kartu, kde jsou uvedeny základní údaje o tomto majetku.

Viz.také

Změny odpisovaného majetku | Aktuální hodnoty odpis.maj. | Odpisovaný majetek | Evidence výkonů | Prognózování odpisů | Odpisové skupiny | Parametry odpisovaného majetku | Inicializace odpisovaného maj.


Změny odpisovaného majetku

Popis

Jako první se při aktivaci této činnosti uživateli nabídne záložka "výběr", kde si nastavením filtru zvolí, jaké události chce vidět (datum, adresáta, druh události apod.).

Po potvrzení výběru má uživatel k dispozici události, které se týkají určitých změn odpisovaného majetku nebo odpisů a opravných položek pohledávek (pro tyto činnosti je tato obrazovka shodná). Tyto události má však možnost pouze prohlížet, není možno je zadávat, opravovat ani rušit. Pro zadávání těchto událostí musí uživatel využít jednotlivé nadefinované druhy procesů.

Každá taková událost může být různého druhu, může se jednat o běžný příjem, běžný výdej, účetní odpis, daňový odpis, technické zhodnocení odpisovaného majetku, účetní odpis pohledávky, daňový odpis pohledávky, účetní opravnou položku, daňovou opravnou položku. Při každém takovém pohybu se zadává i číslo a název odpisovaného majetku nebo karta pohledávky a zaškrtává se, jakou cenu daný druh pohybu upravuje.

Tato činnost uživateli poskytuje následující informace:

¨ číslo procesu, kterým byl pohyb vytvořen a identifikace druhu operace

¨ název druhu operace

¨ druh komponenty - pohledávky nebo inv. majetek

¨ druh pohybu a doplňující popis události

¨ adresáta, kterého se pohyb týká

¨ typ události – běžný/mimořádný (bližší popis na konkrétním příkladu níže)

¨ artikl - tzn. určitý odepisovaný majetek nebo karta pohledávky

¨ název artiklu

¨ kolik % se odepisuje z ceny artiklu

¨ částka, která se odepisuje - u odpis. majetku se zadává, kterou cenu odpis upravuje (výchozí cena pohledávky, ze které se odepisuje)

¨ zda došlo ke změně hodnoty pohledávky (Ano, Ne)

Další informace např. o adresátovi nebo kartě artiklu si uživatel může vyvolat stiskem pravé myši na tučně vyznačených atributech a nebo volbou příslušné činnosti z menu Volby.

Na záložce „poznámka“ má uživatel k dispozici přehled způsobu výpočtu částky daňového nebo účetního odpisu.

Vysvětlivky k atributu „typ“ a příklad:

Pro výpočet účetních a daňových odpisů používá uživatel programové šablony „účetní odpis“ a „daňový odpis“. V případě, že uživatel potřebuje provést částečné vyřazení odepisovaného majetku a zároveň zachovat správnou funkčnost šablon účetních a daňových odpisů, musí použít typ „mimořádný odpis“ daňový i účetní.

Vysvětlíme si postup ohledně částečného vyřazení na konkrétním případu. Firma si pořídila např. traktor s kartáčem a dalším příslušenstvím. Dne 31.7.2004 byl zadán běžný příjem na částku 173 184,87 Kč. Poté následuje sled těchto událostí (výpočty zaokrouhleny směrem nahoru):

¨ účetní odpis k datu 31.12.2004 (173 184,87 / 72) * 5 = 12 030,-

¨ účetní odpis k datu 31.12.2005 (173 184,87 / 72) * 12 = 28 872,-

¨ účetní odpis k datu 31.12.2006 (173 184,87 / 72) * 12 = 28 872,-

¨ účetní odpis k datu 31.01.2007 (173 184,87 / 72) * 1 = 2 406,-

¨ účetní odpis k datu 28.02.2007 (173 184,87 / 72) * 2 = 4 812,-. Následně se odečtou již provedené účetní odpisy za rok 2007. V tento okamžik je částka 2 406,- (4812 – 2406) uplatněna v únoru.

¨ K DATU 09.03.2007 DOJDE K ČÁSTEČNÉMU VYŘAZENÍ (kartáče) Z KARTY TRAKTORU. V tomto okamžiku je nutno provést několik nestandardních záznamů:

- 09.03.2007 je nutno zadat běžný příjem zápornou částkou, tj. minus 39 747,90 (hodnota kartáče) – vyřazení části

- 09.03.2007 je nutno provést účetní odpis s typem události „mimořádný“ jako doodepsání vyřazené části kladnou částkou 22 631,-. Tento úkon provede uživatel ručním zápisem, bez pomoci šablony. Částku odpisu je nutné si vypočítat.

- 09.03.2007 je nutno provést účetní odpis s typem události „mimořádný“ jako vynulování odpisů z událostí, tj. minus 39 747,-, jinak se zůstatková cena vypočítává ze snížené pořizovací ceny mínus celkem dosud odepsáno (tj. z původní vyšší ceny) – chybná kladná až minusová hodnota zůstatkové ceny.

¨ standardní účetní odpis k datu 31.03.2007 se potom počítá jako odpis za měsíc 01/2007 (2 406,-) + odpis za měsíc 02/2007 (2 406,-) + odpis za měsíc 03/2007 (1 854,-). Celkový odpis má hodnotu 6 666,-. Následně se odečtou již provedené odpisy za rok 2007, takže odpis za 01-03/2007 je částka 1 854,- (6666 – 4812) – neodečítají se odpisy „mimořádné“.

Podobné kroky je nutno provést i pro daňové odpisy. Po vyřazení kartáče (operace vyřazení je jedna událost společná pro aktualizaci účetních i daňových cen) je nutno ručně provést záznam daňový odpis ve výši dosud uplatněných daňových odpisů vyřazené části majetku, který aktualizuje zůstatkovou cenu daňovou. Tento záznam je nutné odlišit od běžných záznamů daňových odpisů, proto bude zapsán s typem „mimořádný“.

Datový model

  • ODUDAL Událost odpisovaného majetku
    • ODKARTA Karta
      • SPARTIKN Název artiklu
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)
    • ADADSAT Adresát
    • BWUZIVAT Uživatel systému
    • SPPRISTU Přístupové právo uživatele k věci
    • SPTYP Druh procesu/operace
    • SPPRCOD Operace procesu
      • SPPRC Proces

    • Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^S | Suma |
- | INFORMACE O ADRESÁTOVI | Vývěska adresáta a pošta adresáta...
- | UDÁLOSTI A KARTY ARTIKLU |
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Karty pohledávek | Seznam odpisovaných pohledávek.
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Odpisovaný majetek | Seznam odpisovaného majetku
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Umístění spravovaného majetku | Seznam umístění spravovaného majetku.

    Formulář

    Formulář činnosti - Umístění spravovaného majetku
Mřížka [Událost odpisovaného majetku]
Listovací rámeček
Stránka #1 Událost
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
 | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Název druhu procesu
Komp. | Majetek souvisí s komponentou
Datum | Datum události
Druh | Druh události - Příjem,Výdej, Úč.odpis, Daň.odpis, Tech.zhod., Úč.odpis pohledávky,Daň.odpis pohledávky,Účetní opr.pol.,Daňová opr.pol.
 | Charakter výdeje
Popis | Doplňující popis události
Adresát | Identifikace adresáta
 | Název adresáta
Typ | Typ události - Běžný, Mimořádný
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Umístění | Identifikátor umístění
% | Odepsat procent z ceny pohledávky
Částky | Finanční částka nesnížená
 | Finanční částka
 | Výchozí cena - základ výpočtu odpisu pohledávky
Zm.poh. | Změna hodnoty pohledávky
PC účetní | Pořizovací cena účetní
ZC účetní | Zůstatková cena účetní
VC daňová | Vstupní cena daňová
ZC daňová | Zůstatková cena daňová
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Upravuje cenu | Událost upravuje cenu
Stránka #2 Poznámka
Poznámka | Poznámka
Stránka #3 Výběr
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu od
Číslo procesu do | Pořadové číslo procesu do
 | Identifikátor druhu operace
Druh procesu | Identifikátor druhu procesu
Datum | Datum události od
 | Datum události do
Druh | Druh události - Příjem,Výdej, Úč.odpis, Daň.odpis, Tech.zhod., Úč.odpis pohledávky,Daň.odpis pohledávky,Účetní opr.pol.,Daňová opr.pol.
Umístění | Identifikátor umístění
Popis | Doplňující popis události
Adresát | Identifikace adresáta
Stav | Stav procesu - Nestornovaný,Stornovaný,Stornující
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Typ | Typ události - Běžný, Mimořádný
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsal | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Událost odpisovaného majetku] činnosti - Umístění spravovaného majetku

    Mřížka [Událost odpisovaného majetku] činnosti - Umístění spravovaného majetku
Označování | Označení záznamu
Datum | Datum události
Druh události | Druh události - Příjem,Výdej, Úč.odpis, Daň.odpis, Tech.zhod., Úč.odpis pohledávky,Daň.odpis pohledávky,Účetní opr.pol.,Daňová opr.pol.
Adresát | Identifikace adresáta
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Částka | Finanční částka
Popis | Doplňující popis události
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh procesu | Identifikátor druhu procesu
Pořadí | Pořadí stejného druhu operace v jednom procesu
Název druhu operace | Název druhu operace
Název artiklu | Název artiklu
Umístění | Identifikátor umístění
Název adresáta | Název adresáta
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující

    Atributy tisku

    Základní údaje
Datum události | Datum události | ODUDAL_od02datum | D
Událost souvisí s komponentou | Majetek souvisí s komponentou | Výpočet | C(18)
Změna - příjem/výdej | Změna - příjem / výdej | Výpočet | C(6)
Druh události | Druh události - Příjem,Výdej, Úč.odpis, Daň.odpis, Tech.zhod., Úč.odpis pohledávky,Daň.odpis pohledávky,Účetní opr.pol.,Daňová opr.pol. | Výpočet | C(20)
Charakter výdeje | Charakter výdeje | Výpočet | C(9)
Popis události | Doplňující popis události | ODUDAL_od02text | C(40)
Adresát | Identifikace adresáta | ODUDAL_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Částka | Finanční částka | ODUDAL_od02castka | N(20,4)
Aktualizuje PC účetní | Pořizovací cena účetní | Výpočet | C(3)
Aktualizuje ZC účetní | Zůstatková cena účetní | Výpočet | C(3)
Aktualizuje VC daňovou | Vstupní cena daňová | Výpočet | C(3)
Aktualizuje ZC daňovou | Zůstatková cena daňová | Výpočet | C(3)
Pohledávka | Výchozí cena - základ výpočtu odpisu pohledávky | ODUDAL_od01pc | N(20,4)
Zm.poh. | Změna hodnoty pohledávky | Výpočet | C(3)
% | Odepsat procent z ceny pohledávky | ODUDAL_od02procen | N(6,2)
Obchodní selektor | Identifikátor obchodního selektoru | ODUDAL_sp10idzak | C(9)
Organizační selektor | Identifikátor organizačního selektoru. | ODUDAL_sp11idzak | C(9)
Technicko-věcný selektor | Identifikátor technicko-věcného selektoru. | ODUDAL_sp20idzak | C(9)
Poznámka | Poznámka | ODUDAL_od02koment | M
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | ODUDAL_sp00datzap | T
Druh artiklu | Identifikace druhu artiklu | ODUDAL_sp61id | C(3)
Artikl | Identifikace artiklu | ODUDAL_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Rok | Rok v identifikaci procesu | ODUDAL_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | ODUDAL_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | ODUDAL_sp33cisd | C(8)
Pořadí | Pořadí stejného druhu operace v jednom procesu | ODUDAL_sp33porad | N(2)
Druh operace | Identifikátor druhu procesu | ODUDAL_sp07idtyp | C(6)
Komponenta | Identifikace komponenty | ODUDAL_sp06idsubs | C(3)
Název druhu operace | Název druhu procesu | SPTYP_sp07text | C(30)

    Viz.také

    OZNAČOVÁNÍ | Suma | INFORMACE O ADRESÁTOVI | UDÁLOSTI A KARTY ARTIKLU | Adresář | Druhy artiklů | Druhy operací | Druhy procesů | Karty pohledávek | Obchodní selektor | Odpisovaný majetek | Organizační selektor | Technicko-věcný selektor | Umístění spravovaného majetku | Daňová oprávka pohledávky | Daňová změna pohledávek | Daňové odpisy | Import událostí odpisů | Snížení odpisů opravných položek | Účetní odpisy | Účetní oprávka pohledávek | Účetní změna pohledávek


Aktuální hodnoty odpis.maj.

Popis

Uživatel má v této činnosti k dispozici aktuální výši částky účetních a daňových odpisů a opravných položek a odpisů pohledávky. Podle zadaného výběru se mu pak zobrazují příslušné informace. Může si zvolit určitý druh artiklu nebo přímo jednotlivý artikl nebo může chtít vidět aktuální hodnoty za adresáta a druh hodnoty apod.

Datový model

  • ODAH Aktuální hodnota
    • SPSTATDI Druh hodnoty
    • ODKARTA Karta
      • SPARTIKN Název artiklu
      • SMUMIS Umístění
        • SPPRISTU Přístupové právo uživatele k věci

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Odpisovaný majetek | Seznam odpisovaného majetku

    Formulář

    Formulář činnosti - Adresář
Mřížka [Aktuální hodnoty odpis.maj.]
Listovací rámeček
Stránka #1 Aktuální hodnoty
 | Identifikace komponenty
Druh hodnoty | Identifikace druhu hodnoty
 | Název druhu hodnoty
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Adresát | Identifikace adresáta
 | Název adresáta
Částka | Finanční částka
Stránka #2 Výběr
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Druh hodnoty | Identifikace druhu hodnoty
Adresát | Identifikace adresáta
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Aktuální hodnoty odpis.maj.] činnosti - Adresář

    Mřížka [Aktuální hodnoty odpis.maj.] činnosti - Adresář
Komponenta | Identifikace komponenty
Druh hodnoty | Identifikace druhu hodnoty
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Adresát | Identifikace adresáta
Částka | Finanční částka
Název druhu hodnoty | Název druhu hodnoty
Název artiklu | Název artiklu
Název adresáta | Název adresáta

    Atributy tisku

    Základní údaje
Identifikace adresáta | Identifikace adresáta | ODAH_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Komponenta | Identifikace komponenty | ODAH_sp06idsubs | C(3)
Druh hodnoty | Identifikace druhu hodnoty | ODAH_sp67id | C(3)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)
Částka | Finanční částka | ODAH_od02castka | N(20,4)
Artikl | Identifikace artiklu | ODAH_sp60id | C(13)
Druh artiklu | Identifikace druhu artiklu | ODAH_sp61id | C(3)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)

    Viz.také

    Adresář | Druhy artiklů | Druhy hodnot | Odpisovaný majetek


Odpisovaný majetek

Popis

Tato činnost poskytuje uživateli možnost zakládat, aktualizovat a rušit jednotlivé karty investičního majetku. U jednotlivých karet investičního majetku se zadává:

¨ druh, identifikace a název odpisovaného majetku

¨ kód CZ – CPA – kód klasifikace produkce (původní třída SKP)

¨ datum zařazení – doplní se automaticky z první události typu příjem a zůstává neměnné bez ohledu na následující události stejného typu (není uživatelsky modifikovatelné, pouze pomocí událostí)

¨ datum vyřazení – doplní se automaticky z události typu výdej (není uživatelsky modifikovatelné, pouze pomocí událostí)

¨ dat. zaháj. UO – datum zahájení účetních odpisů – vyplní se automaticky shodně s datem zařazení. Toto datum je možno podle potřeb uživatele ručně změnit (posunout vpřed), např. pro odpisy sadu je nutné posunout datum odepisování zhruba až po třech letech od data zařazení, jinými slovy – uživatel má pomocí těchto atributů (dat. zaháj. UO a dat. zaháj. DO) možnost individuálního zahájení účetních a daňových odpisů odlišně od data zařazení (příklad použití – pro pěstitelské celky trvalých porostů, které nedosáhly plodonosného stáří – např. výše zmíněný sad). V případě použití tohoto data (tzn. datum zařazení je rozdílný od data zahájení) je pro výpočet UO nutné nastavení parametru „odpis v měsíci zařazení“ na dané kartě.

¨ dat. zaháj. DO – datum zahájení daňových odpisů - vyplní se automaticky shodně s datem zařazení. Toto datum je možno podle potřeb uživatele ručně změnit (posunout vpřed).

¨ druh inv. maj. – výběr druhu investičního majetku z překryvného seznamu

¨ umístění – možnost výběru či definice umístění odp. majetku (je shodné s umístěním nadefinovaným pro spravovaný majetek). V odpisovaném majetku plní toto umístění funkci definice přístupových práv. Tato přístupová práva se uplatní v odp. majetku takto:
- při prohlížení karet investičního majetku daný uživatel vidí jen ty karty, ke kterým má alespoň právo čtení; při založení F3 či opravě F4 karty lze uvést jen ta umístění, ke kterým má daný uživatel přístup "zápis",
- při prohlížení událostí IMO (tj. změny odepisovaného majetku) daný uživatel vidí jen události týkající se těch karet, ke kterým má alespoň právo čtení; zápis (oprava) změn lze provést jen k těm kartám, k jejichž umístění má daný uživatel nastaveno právo zápisu,
- události IMO "účetní odpisy" se automaticky připravují šablonou, kde je doplněn dotaz na umístění, za které se má udělat odpis, tj. bude možné odepsat najednou skupinu majetku vymezenou jednotným umístěním nebo veškerý majetek přístupný (zápis) danému uživateli. Při výběru umístění a při zápisu odpisů se uplatní práva.

¨ jednotlivé selektory

Za zmínku určitě stojí záložky "účetní" a "daňový" odpis, které jsou popsány v samostatném helpu. Uživatel zde má informace o počtu odpisů, jejich výši, vstupní a zůstatkové ceně apod. Podle par. 30a Zákona o dani z příjmu ve znění platném od 20.7.2009 lze pro výpočet mimořádného odpisu použít záložku individuální odpis.

Další záložky v této činnosti jsou“

¨ názvy artiklu – možnost přeložit si název odpisovaného majetku do vybraného cizího jazyka

¨ kategorie artiklu

Na základě zvolení Palety na záložce Výběr je možno přehled artiklů zvýraznit i barevně.

Další činnosti, která má uživatel dostupné v menu "volby" jsou:

¨ události a karty artiklu - uživatel má k dispozici všechny potřebné údaje které se týkají odpisovaného majetku uvedeného na kartě. Jsou to:

- události odpisovaného majetku

- události spravovaného majetku

- rezervace majetku

- odpisovaný majetek

- spravovaný majetek

- prognózování odpisů

Datový model

  • ODKARTA Karta
    • SPARTIKL Artikl
    • SPARTIKN Název artiklu
    • SMUMIS Umístění
      • SPPRISTU Přístupové právo uživatele k věci
    • SPSETV Technicko-věcný selektor
    • SPSKP SKP
    • SPMJN Měrná jednotka v jazyce
    • SPARTIKD Druh artiklu
    • BWUZIVAT Uživatel systému
    • ODODPSKU Odpis.skupina
    • SPSEOR Organizační selektor

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Události správy artiklu |
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
- | Legenda palety barev |
- | UDÁLOSTI A KARTY ARTIKLU |
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Kategorie událostí správy artiklu | Přehled kategorií událostí správy artiklu
F2 | Měrné jednotky | Číselník měrných jednotek
F2 | Odpisovaný majetek | Seznam odpisovaného majetku
F2 | Odpisové skupiny | Koeficienty pro daňové odpisy odpisovaného majetku
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Palety barev kategorií | Palety barev kategorií
F2 | Spojení | Seznam spojení za adresáta.
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Třídy SKP | Třídy Standardní klasifikace produkce
F2 | Umístění spravovaného majetku | Seznam umístění spravovaného majetku.

    Formulář

     | Formulář činnosti - Umístění spravovaného majetku
 | Mřížka [Odpisovaný majetek]
 | Listovací rámeček
 | Stránka #1 Odpisovaný majetek
 |  | Identifikace druhu artiklu
 | Artikl | Identifikace artiklu
 | Název artiklu | Název artiklu
 | Třída SKP | Identifikace třídy Standardní klasifikace produkce.
 |  | Název kategorie Standardní klasifikace produkce.
 | Datum zařazení | Datum zařazení
 | Datum vyřazení | Datum vyřazení
 | Dat. zaháj. UO | Datum zahájení odepisování účetních odpisů
 | Dat. zaháj. DO | Datum zahájení odepisování daňových odpisů
 | Druh inv.maj. | Druh investičního majetku
 | Umístění | Identifikátor umístění
 | Název umístění | Název umístění
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Org. sel. | Identifikátor organizačního selektoru.
 | Účet.sel. | Účetní selektor artiklu
 | Komentář | Komentář
 | Zapsal | Jméno uživatele systému
 |  | Datum a čas zápisu záznamu události
 | Stránka #2 Účetní odpis
 | Způsob odpisování | Způsob účetního odpisování investičního majetku
 | Pořiz. cena | Pořizovací cena - účetní
 | Zůst. cena | Zůstatková cena - účetní
 | Plán. celož. výkon | Plánovaný celoživotní výkon (pro odpis dle času je výkon v měsících)
 | Roč. výkon | Uvedený roční výkon se použije při výpočtu prognózy odpisů
 | MJ | Identifikátor měrné jednotky
 |  | Název měrné jednotky
 | Snížení odpisu % | O uvedené procento se snižuje vypočtený účetní odpis
 | Odpis v měs.zař. | Počítat účetní odpis i za měsíc, kdy došlo k zařazení
 | Odpis v měs.vyř. | Počítat účetní odpis i za měsíc, kdy došlo k vyřazení
 | Stránka #3 Daňový odpis
 | Způsob odpisování | Způsob daňového odpisování investičního majetku
 | Měsíců | Počet měsíců rovnoměrného odepisování nehmotného majetku
 | Odpisová skupina | Odpisová skupina
 | Po TZ | Minimální počet měsíců rovnoměrného odepisování nehmotného majetku po technickém zhodnocení
 | Vstup.cena | Vstupní cena - daňová
 | Zůst.cena | Zůstatková cena - daňová
 | Datum prvního TZ | Datum prvního technického zhodnocení
 | Datum posl. TZ | Datum posledního technického zhodnocení
 | Snížení odpisu % | O uvedené procento se snižuje vypočtený daňový odpis
 | odpisů | Počet uplatněných odpisů ze zvýšené ceny. Počítá se od naposledy provedeného technického zhodnocení.
 | Počet odpisů | Počet uplatněných odpisů celkem
 | Majetek je hlavním předmětem souboru | Inv.maj. je hlavním předmětem souboru IM
 | odpisů | Počet uplatněných odpisů ze zvýšené ceny po prvním technickém zhodnocení.
 |  | Druh artiklu nadřízeného majetku
 | Nadřízený artikl | Číslo artiklu nadřízeného majetku
 | Soubor majetku | Soubor majetku
 | Stránka #4 Individuální odpis
 | Mřížka [Individuální odpis]
 | Rok | Rok
 | Měsíc | Měsíc
 | Částka | Částka
 | Popis | Popis
 | Komentář | Komentář
 | Stránka #5 Názvy artiklu
 | Mřížka [Názvy artiklu v jazycích]
 | Jazyk | Identifikace jazyka
 | Název artiklu | Název artiklu
 | Stránka #6 Kategorie artiklu
 | Mřížka [Kategorie artiklu]
 |  | Kategorie
Identifikace kategorie události správy artiklu |  |  | Platnost
Datum platnosti od |  |  | Platnost do
Datum platnosti do |  |  | Adresát
Identifikace adresáta |  |
Název adresáta |  |
Číslo spojení adresáta. |  |  | Popis
Popis události |  |  | Poznámka
Poznámka |  |  | Zapsal
Jméno uživatele systému |  |  | Datum a čas zápisu
Datum a čas zápisu záznamu události
 | Stránka #7 Výběr
 |  | Identifikace druhu artiklu
 | Artikl | Identifikace artiklu
 | Název artiklu | Název artiklu
 |  | Inv.maj. je hlavním předmětem souboru IM
 | Účetně neodpis. | Účetně neodpisovaný
 | Dle času | Účetně odpisovaný dle času
 | Dle výkonu | Účetně odpisovaný dle výkonu
 | Dle daňových odpisů | Účetně odpisovaný dle daňových odpisů
 | Daňově nedpisovaný | Danově neodpisovaný
 | Rovnoměrný odpis | Daňový odpis rovnoměrný
 | Zrychlený odpis | Daňový odpis zrychlený
 | Rovnoměrný odpis - NM | Daňový odpis rovnoměrný - nehmotný majetek
 | Individuální odpis | Individuální odpis
 |  | Vybrat Všechny,Vyřazené,Nevyřazené
 | K datu | Vyřazené nebo nevyřazené k datu
 | Datum zařazení od | Datum zařazení od
 | do | Datum zařazení do
 | Datum vyřazení od | Datum vyřazení od
 | do | Datum vyřazení do
 | Zůstatková cena | Zůstatková cena daňová nebo účetní od
 |  | Zůstatková cena daňová nebo účetní do
 | Odpisová skupina | Odpisová skupina
 | Umístění | Identifikátor umístění
 | Org. sel. | Identifikátor organizačního selektoru.
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Třída SKP | Identifikace třídy Standardní klasifikace produkce.
 | Účet.sel. | Účetní selektor artiklu
 |  | Vztah ke kategorii - Je=K dnešnímu datu je v kategorii, Není=K dnešnímu datu není v kategorii, Byl=Není v kategorii, ale byl, Nebyl=Není a nikdy nebyl v kategorii
 | Kat.artiklu | Identifikace kategorie události správy artiklu
 |  | Název kategorie události správy artiklu
 | Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 |  | Platnost nebo neplatnost k datu
 | Paleta | Vybrat záznamy všech kategorií v paletě
 |  | Identifikace palety barev
 | Zapsal | Identifikace uživatele systému
 | Výběr | Určení výběru
 | Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Odpisovaný majetek] činnosti - Umístění spravovaného majetku

    Mřížka [Odpisovaný majetek] činnosti - Umístění spravovaného majetku
Označování | Označení záznamu
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název | Název artiklu
Umístění | Identifikátor umístění

    Mřížka [Individuální odpis] činnosti - Umístění spravovaného majetku

    Mřížka [Individuální odpis] činnosti - Umístění spravovaného majetku
Rok | Rok
Měsíc | Měsíc
Částka | Částka
Popis | Popis

    Mřížka [Názvy artiklu v jazycích] činnosti - Umístění spravovaného majetku

    Mřížka [Názvy artiklu v jazycích] činnosti - Umístění spravovaného majetku
Jazyk | Identifikace jazyka
Název artiklu | Název artiklu

    Mřížka [Kategorie artiklu] činnosti - Umístění spravovaného majetku

    Mřížka [Kategorie artiklu] činnosti - Umístění spravovaného majetku
Kategorie | Identifikace kategorie události správy artiklu
Název kategorie | Název kategorie události správy artiklu
Platnost od | Datum platnosti od
Platnost do | Datum platnosti do
Adresát | Identifikace adresáta
Název adresáta | Název adresáta

    Atributy tisku

    Základní údaje
Druh artiklu | Identifikace druhu artiklu | ODKARTA_sp61id | C(3)
Název druhu artiklu | Název druhu artiklu | SPARTIKD_sp61nazdru | C(40)
Artikl | Identifikace artiklu | ODKARTA_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Komentář odpisovaného majetku | Komentář | ODKARTA_od01koment | M
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | ODKARTA_sp00datzap | T
Snížení daňového odpisu % | O uvedené procento se snižuje vypočtený daňový odpis | ODKARTA_od01oprocd | N(5,2)
Snížení účetního odpisu % | O uvedené procento se snižuje vypočtený účetní odpis | ODKARTA_od01oprocu | N(5,2)
Třída SKP | Identifikace třídy Standardní klasifikace produkce. | ODKARTA_sp17idskp | C(8)
Název třídy Standardní klasifikace produkce | Název kategorie Standardní klasifikace produkce. | SPSKP_sp17text | C(70)
Měrná jednotka | Identifikátor měrné jednotky | ODKARTA_sp24idmj | C(3)
Název měrné jednotky | Název měrné jednotky | SPMJN_sp58mjnaz | C(40)
Umístění | Identifikátor umístění | ODKARTA_sm05id | C(6)
Název umístění | Název umístění | SMUMIS_sm05umis | C(40)
Organizační selektor | Identifikátor organizačního selektoru. | ODKARTA_sp11idzak | C(9)
Technicko-věcný selektor | Identifikátor technicko-věcného selektoru. | ODKARTA_sp20idzak | C(9)
Datum zařazení | Datum zařazení | ODKARTA_od01datzar | D
Datum vyřazení | Datum vyřazení | ODKARTA_od01datvyr | D
Druh inv.maj. | Druh investičního majetku | Výpočet | C(27)
Způsob účetního odpisování | Způsob účetního odpisování investičního majetku | Výpočet | C(12)
Odpis v měs.zař. | Počítat účetní odpis i za měsíc, kdy došlo k zařazení | Výpočet | C(27)
Odpis v měs.vyř. | Počítat účetní odpis i za měsíc, kdy došlo k vyřazení | Výpočet | C(27)
Pořizovací cena účetní | Pořizovací cena - účetní | ODKARTA_od01pc | N(20,4)
Zůstatková cena účetní | Zůstatková cena - účetní | ODKARTA_od01zcu | N(20,4)
Vstupní cena daňová | Vstupní cena - daňová | ODKARTA_od01vc | N(20,4)
Zůstatková cena daňová | Zůstatková cena - daňová | ODKARTA_od01zcd | N(20,4)
Plánovaný celoživotní výkon | Plánovaný celoživotní výkon (pro odpis dle času je výkon v měsících) | ODKARTA_od01plczv | N(10)
Prognózovaný roční výkon | Uvedený roční výkon se použije při výpočtu prognózy odpisů | ODKARTA_od01rocvyk | N(10)
Způsob daňového odpisování | Způsob daňového odpisování investičního majetku | Výpočet | C(18)
Měsíců | Počet měsíců rovnoměrného odepisování nehmotného majetku | ODKARTA_od01domes | N(3)
Po TZ | Minimální počet měsíců rovnoměrného odepisování nehmotného majetku po technickém zhodnocení | ODKARTA_od01domtz | N(3)
Počet odpisů | Počet uplatněných odpisů z nezvýšené ceny | ODKARTA_od01pocodp | N(3)
Ze zvýš.ceny | Počet uplatněných odpisů ze zvýšené ceny po posledním technickém zhodnocení. | ODKARTA_od01zezvce | N(3)
Odhad počtu odpisů | Předpokládaný počet daňových odpisů | ODKARTA_od01pocopr | N(3)
Odpisová skupina | Odpisová skupina | ODKARTA_od05odpsku | C(9)
Majetek je hlavním předmětem souboru | Inv.maj. je hlavním předmětem souboru IM | Výpočet | C(3)
Druh artiklu nadřízeného majetku | Druh artiklu nadřízeného majetku | ODKARTA_sp61id1 | C(3)
Nadřízený artikl | Číslo artiklu nadřízeného majetku | ODKARTA_sp60id1 | C(13)

    Viz.také

    Události správy artiklu | OZNAČOVÁNÍ | Prezentace artiklu | Legenda palety barev | UDÁLOSTI A KARTY ARTIKLU | Adresář | Druhy artiklů | Kategorie událostí správy artiklu | Měrné jednotky | Odpisové skupiny | Organizační selektor | Palety barev kategorií | Spojení | Technicko-věcný selektor | Třídy SKP | Umístění spravovaného majetku


Evidence výkonů

Popis

Jedná se o činnost, kde má uživatel k dispozici jednotlivé záznamy týkající se investičního majetku, kde se účetní odpisy provádějí podle výkonu. Tyto záznamy má možnost zakládat, opravovat a rušit. Při odepisování podle výkonu vede uživatel k investičnímu majetku průběžnou evidenci výkonů, které se potom v rámci odpisovaného období sečtou. V takovém případě je však nutno mít u každého investičního majetku na kartě uveden plánovaný celoživotní výkon a měrné jednotky (např. u nákladního automobilu to mohou být třeba tuny či kilometry).

Datový model

  • ODVYKON Výkon
    • SPARTIKN Název artiklu
    • SPMJN Měrná jednotka v jazyce
    • BWUZIVAT Uživatel systému

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Odpisovaný majetek | Seznam odpisovaného majetku

    Formulář

    Formulář činnosti - Druhy artiklů
Mřížka [Evidence výkonů]
Listovací rámeček
Stránka #1 Evidence výkonů
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
MJ | Identifikátor měrné jednotky
Datum | Datum, kdy byl evidovaný výkon proveden
Název artiklu | Název artiklu
 | Název měrné jednotky
Výkon | Výkon
Text | Upřesňující text - poznámka
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Výběr
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Datum od | Datum záznamu od
do | Datum záznamu do
Zapsal | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Evidence výkonů] činnosti - Druhy artiklů

    Mřížka [Evidence výkonů] činnosti - Druhy artiklů
Datum | Datum, kdy byl evidovaný výkon proveden
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
MJ | Identifikátor měrné jednotky
Výkon | Výkon
Text | Upřesňující text - poznámka

    Atributy tisku

    Základní údaje
Datum evidence výkonu | Datum, kdy byl evidovaný výkon proveden | ODVYKON_od04datum | D
Druh artiklu | Identifikace druhu artiklu | ODVYKON_sp61id | C(3)
Název druhu artiklu | Název druhu artiklu | SPARTIKD_sp61nazdru | C(40)
Artikl | Identifikace artiklu | ODVYKON_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Měrná jednotka | Identifikátor měrné jednotky | ODVYKON_sp24idmj | C(3)
Název měrné jednotky | Název měrné jednotky | SPMJN_sp58mjnaz | C(40)
Evidovaný výkon | Výkon | ODVYKON_od04vykon | N(12,2)
Popis výkonu | Upřesňující text - poznámka | ODVYKON_od04popvyk | C(40)
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | ODVYKON_sp00datzap | T

    Viz.také

    Druhy artiklů | Odpisovaný majetek


Prognózování odpisů

Popis

Tato činnost se nachází v hlavním menu – Odpisovaný majetek – Prognózování odpisů. Po aktivaci této činnosti se uživateli nejprve zobrazí záložka „Výběr“, kde si vybere období (tj. nadefinované účetní období v komponentě účetnictví), za které chce prognózu odpisů spočítat a případně i konkrétní kartu odpisovaného majetku. Prognóza poskytuje uživateli informace v jaké výši budou odpisy za zvolené období pokud se nezmění způsob odepisování. Tyto informace jsou přínosem v případě velkých firemních investic, aby měl podnik představu o svých nákladech na odpisy. Prognózování odpisů představuje pro uživatele nástroj, který mu poměrně přesně spočítá odpisy příštích let.

Tato činnost tedy uživateli poskytuje informace o vypočtených odpisech příštích let, tzn. odpisech za zbytek letošního roku a odpisech dalších let (podle období uvedeného na záložce „Výběr“). V podstatě tedy ukazuje finanční údaje týkající se hodnoty odpisů za vybrané i předchozí období.

Po nadefinování záložky „Výběr“ proběhne výpočet prognózy a uživatel má k nahlédnutí formulář, kde jsou ke každé řádce zvoleného období k dispozici následující atributy:

¨ období – název období (jedná se o účetní období, které uživatel definuje v komponentě Účetnictví – Speciální činnosti – Účetní období)

¨ artikl – identifikace druhu artiklu a identifikace artiklu

¨ název artiklu – název odpisovaného majetku (z karty)

¨ účetní odpis – částka účetního odpisu, která se ještě v daném období odepíše a dosud není odepsána

¨ pořiz. cena – hodnota z karty odpisovaného majetku

¨ zůst. cena – částka, která se očekává jako zůstatková cena na konci daného období (tzn. pořizovací cena mínus všechny uskutečněné a prognózované odpisy)

¨ daňový odpis – částka daňového odpisu, která se ještě v daném období odepíše a dosud není odepsána

¨ vstup. cena – hodnota z karty odpisovaného majetku

¨ zůst. cena – částka, která se očekává jako zůstatková cena na konci daného období (tzn. pořizovací cena mínus všechny uskutečněné a prognózované odpisy)

¨ počet odpisů – počet daňových odpisů, které se uplatnily (buď v události odepisování nebo v prognóze předchozích let) v předchozích účetních obdobích

¨ počet odp. ze zv. ceny – počet daňových odpisů po posledním technickém zhodnocení, které se uplatnily v předchozích účetních obdobích (buď v událostech nebo v prognóze)

Datový model

  • ODW1PROG Prognózování odpisů
    • SPARTIKN Název artiklu
      • ODKARTA Karta (alias ODKARTA5)

    • Vyvolávané činnosti

    K. | Činnost | Popis
- | UDÁLOSTI A KARTY ARTIKLU |
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Odpisovaný majetek | Seznam odpisovaného majetku
F2 | Umístění spravovaného majetku | Seznam umístění spravovaného majetku.
F2 | Účetní období | Účetní období

    Formulář

    Formulář činnosti - Umístění spravovaného majetku
Mřížka [Zobrazení prognózy]
Listovací rámeček
Stránka #1 Prognóza odpisů
Období | Identifikace účetního období
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Umístění | Identifikátor umístění
Pořiz. cena | Pořizovací cena - účetní
Účetní odpis | Prognózovaná hodnota účetního odpisu
Zůst. cena | Zůstatková cena - účetní
Vstup.cena | Vstupní cena - daňová
Daňový odpis | Prognózovaná hodnota daňového odpisu
Zůst.cena | Zůstatková cena - daňová
Počet odpisů | Počet provedených daňových odpisů
Počet odp.ze zv.ceny | Počet provedených daňových odpisů ze zvýšené ceny
Stránka #2 Poznámky
Poznámka k účetnímu odpisu | Poznámka k účetnímu odpisu
Poznámka k daňovému odpisu | Poznámka k daňovému odpisu
Stránka #3 Výběr
Prognóza do roku (období) | Poslední rok pro výpočet prognózy
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Umístění | Identifikátor umístění
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Zobrazení prognózy] činnosti - Umístění spravovaného majetku

    Mřížka [Zobrazení prognózy] činnosti - Umístění spravovaného majetku
Období | Identifikace účetního období
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Pořizovací cena účetní | Pořizovací cena - účetní
Zůstatková cena účetní | Zůstatková cena - účetní
Účetní odpis | Prognózovaná hodnota účetního odpisu
Vstupní cena daňová | Vstupní cena - daňová
Zůstatková cena daňová | Zůstatková cena - daňová
Daňový odpis | Prognózovaná hodnota daňového odpisu
Umístění | Identifikátor umístění

    Atributy tisku

    Základní údaje
Období | Identifikace účetního období | ODW1PROG_uc37id | C(6)
Druh artiklu | Identifikace druhu artiklu | ODW1PROG_sp61id | C(3)
Artikl | Identifikace artiklu | ODW1PROG_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Umístění | Identifikátor umístění | ODKARTA5_sm05id | C(6)
Počet odpisů | Počet provedených daňových odpisů | ODW1PROG_odw1pocodp | N(3)
Počet odp.ze zv.ceny | Počet provedených daňových odpisů ze zvýšené ceny | ODW1PROG_odw1zezvce | N(3)
Pořizovací cena účetní | Pořizovací cena - účetní | ODW1PROG_od01pc | N(20,4)
Zůstatková cena účetní | Zůstatková cena - účetní | ODW1PROG_od01zcu | N(20,4)
Vstupní cena daňová | Vstupní cena - daňová | ODW1PROG_od01vc | N(20,4)
Zůstatková cena daňová | Zůstatková cena - daňová | ODW1PROG_od01zcd | N(20,4)
Hodnota daňového odpisu | Prognózovaná hodnota daňového odpisu | ODW1PROG_odw1castk2 | N(20,4)
Hodnota účetního odpisu | Prognózovaná hodnota účetního odpisu | ODW1PROG_odw1castk1 | N(20,4)
Poznámka k daňovému odpisu | Poznámka k daňovému odpisu | ODW1PROG_od02koment | M
Poznámka k účetnímu odpisu | Poznámka k účetnímu odpisu | ODW1PROG_od02komenu | M
Komentář | Komentář | ODKARTA5_od01koment | M
Ident. | Identifikace uživatele systému | ODKARTA5_bw01uziv | C(6)
Datum a čas zápisu | Datum a čas zápisu záznamu události | ODKARTA5_sp00datzap | T
Snížení daňového odpisu % | O uvedené procento se snižuje vypočtený daňový odpis | ODKARTA5_od01oprocd | N(5,2)
Snížení účetního odpisu % | O uvedené procento se snižuje vypočtený účetní odpis | ODKARTA5_od01oprocu | N(5,2)
Třída SKP | Identifikace třídy Standardní klasifikace produkce. | ODKARTA5_sp17idskp | C(8)
MJ | Identifikátor měrné jednotky | ODKARTA5_sp24idmj | C(3)
Org. sel. | Identifikátor organizačního selektoru. | ODKARTA5_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | ODKARTA5_sp20idzak | C(9)
Účetní selektor artiklu | Účetní selektor artiklu | ODKARTA5_sp00uselar | C(9)
Datum zařazení | Datum zařazení | ODKARTA5_od01datzar | D
Datum vyřazení | Datum vyřazení | ODKARTA5_od01datvyr | D
Druh inv.maj. | Druh investičního majetku | Výpočet | C(27)
Způsob odpisování | Způsob účetního odpisování investičního majetku | Výpočet | C(12)
Pořiz. cena | Pořizovací cena - účetní | ODKARTA5_od01pc | N(20,4)
Zůst. cena | Zůstatková cena - účetní | ODKARTA5_od01zcu | N(20,4)
Vstup.cena | Vstupní cena - daňová | ODKARTA5_od01vc | N(20,4)
Zůst.cena | Zůstatková cena - daňová | ODKARTA5_od01zcd | N(20,4)
Plán. celož. výkon | Plánovaný celoživotní výkon (pro odpis dle času je výkon v měsících) | ODKARTA5_od01plczv | N(10)
Roč. výkon | Uvedený roční výkon se použije při výpočtu prognózy odpisů | ODKARTA5_od01rocvyk | N(10)
Způsob odpisování | Způsob daňového odpisování investičního majetku | Výpočet | C(13)
Skupina | Odpisová skupina | ODKARTA5_od05odpsku | C(9)
Počet odpisů | Počet uplatněných odpisů z nezvýšené ceny | ODKARTA5_od01pocodp | N(3)
Ze zvýš.ceny | Počet uplatněných odpisů ze zvýšené ceny po posledním technickém zhodnocení. | ODKARTA5_od01zezvce | N(3)
Datum prvního TZ | Datum prvního technického zhodnocení | ODKARTA5_od01dattz | D
Je hlav.předmětem | Inv.maj. je hlavním předmětem souboru IM | Výpočet | C(3)
Patří pod hl.předmět | Inv.maj. patří pod hlavní předmět souboru IM | ODKARTA5_od01podhlp | C(6)
Druh artiklu nadřízeného majetku | Druh artiklu nadřízeného majetku | ODKARTA5_sp61id1 | C(3)
Nadřízený artikl | Číslo artiklu nadřízeného majetku | ODKARTA5_sp60id1 | C(13)
Suma úč. odp. dle daň. za rok | Suma ucetnich odpisu dle danovych za rok | ODKARTA5_od01uonap | N(20,4)
Komp. | Majetek souvisí s komponentou | Výpočet | C(8)
Obch. sel. | Identifikátor obchodního selektoru | ODKARTA5_sp10idzak | C(9)

    Viz.také

    UDÁLOSTI A KARTY ARTIKLU | Druhy artiklů | Odpisovaný majetek | Umístění spravovaného majetku | Účetní období


Odpisové skupiny

Popis

Jedná se o číselník odpisových skupin, který má uživatel možnost aktualizovat, opravovat a rušit. U každé odpisové skupiny jsou k dispozici sazby pro rovnoměrný odpis a koeficienty pro zrychlený odpis na záložce Sazby a koeficienty.

Číselník odpisových skupin a jejich sazeb je s pořízením informačního systému Bílý Motýl dodáván naplněný. Na případné legislativní změny v sazbách apod. je uživatel upozorněn a tyto změny si následně ručně zaznamená do tohoto číselníku.

Tuto činnost má uživatel k dispozici v hlavním menu – Odpisovaný majetek – Odpisové skupiny. Po aktivaci této činnosti má uživatel k dispozici záložku odpisové skupiny, kde jsou uvedeny jednotlivé odpisové skupiny v letech. U každé skupiny je uvedena její identifikace a platnost s datem od – do. Pod záložkou Výběr může uživatel pak následně vyhledávat podle této identifikace a na základě atributu „platnost“ lze pak výběr ještě blíže specifikovat. Uživatel si může vybrat z těchto možností:

¨ platné i neplatné – tj. všechny odp. skupiny z hlediska platnosti

¨ platné dnes – uživateli se zobrazí všechny odp. skupiny, jejichž období platnosti od – do je aktuální pro dnešní datum

¨ neplatné dnes - uživateli se zobrazí všechny odp. skupiny, jejichž období platnosti od – do je neaktuální pro dnešní datum

¨ platné k datu - uživateli se zobrazí všechny odp. skupiny, jejichž období platnosti od – do je aktuální pro zadané datum, tzn. uživatel si může najít ty odp. skupiny, které byly platné např. k 1.1.2005

¨ neplatné k datu - uživateli se zobrazí všechny odp. skupiny, jejichž období platnosti od – do je neaktuální pro zadané datum

Další informace, které má uživatel k dispozici jsou na záložce „Sazby a koeficienty“. Zde jsou ke každé odpisové skupině uvedeny její sazby a koeficienty s datem platnosti od, tzn. jeden řádek sazeb a koeficientů může u dané skupiny mít platnost např. od 01.01.2003 a druhý řádek pak může být např. s platností od 01.01.2008. Jinými slovy, u každé odpisové skupiny je možno mít nadefinováno několik řádek s různými sazbami a koeficienty rozlišených různým datem platnosti.

Atribut „sazby pro rovnoměrný odpis“ poskytuje uživateli přehled o sazbách odpisů při rovnoměrném způsobu odepisování v prvním roce, v dalších letech a pro odpis ze zvýšené ceny. Výpočet rovnoměrných odpisů upravuje §31 zákona o dani z příjmu odst. a). Zákon určuje sazby pro výpočet odpisu. Tyto sazby jsou vyjádřeny procentem. Odlišná odpisová sazba je v prvním roce odepisování a v dalších letech. Sazba pro zvýšenou vstupní cenu se používá v případě, že u majetku v průběhu jeho užívání bylo provedeno technické zhodnocení.

Atribut „koeficienty pro zrychlený odpis“ poskytuje uživateli přehled o sazbách odpisů při zrychleném způsobu odepisování v prvním roce, v dalších letech a pro odpis ze zvýšené ceny. Výpočet zrychlených odpisů upravuje §32 zákona o dani z příjmu. Zákon určuje koeficienty pro výpočet odpisu. Koeficient pro 1 rok odpisu odpovídá době odepisování.

Daňové odpisy lze v prvním roce odpisování navýšit o 10, 15 nebo 20% (viz. atribut „procento“ ). Zvýšení odpisu v prvním roce odepisování je možné v těchto výších:

¨ 10% - pro poplatníka, který je prvním vlastníkem majetku, který je zatříděn v odpisových skupinách 1 až 3,

¨ 15% - pro poplatníka, který je prvním vlastníkem zařízení pro čištění a úpravu vody, třídícího a úpravárenského zařízení na zhodnocení druhotných surovin,

¨ 20% - pro poplatníka, který je prvním vlastníkem stroje pro zemědělství a lesnictví (jen pro poplatníka s převážně zemědělskou a lesní výrobou).

Datový model

  • ODODPSKU Odpis.skupina

    • Formulář

    Formulář činnosti - Umístění spravovaného majetku
Mřížka [Odpisové skupiny]
Listovací rámeček
Stránka #1 Odpisové skupiny
Skupina | Odpisová skupina
Platnost | Platnost odpisové skupiny od
do | Platnost odpisové skupiny do
Komentář | Komentář k odpisové skupině
Stránka #2 Sazby a koeficienty
Mřížka [Sazby a koeficienty]
Platnost od | Platnost sazeb a koeficientů od data včetně
Sazby pro rovnoměrný odpis | Sazby pro rovnoměrný odpis
V prvním roce | Sazba pro rovnoměrný odpis v prvním roce
V dalších letech | Sazba pro rovnoměrný odpis v dalších letech
Pro odpis ze zvýšené ceny | Sazba pro rovnoměrný odpis ze zvýšené vstupní ceny
Koeficienty pro zrychlený odpis | Koeficienty pro zrychlený odpis
V prvním roce | Koeficient pro zrychlený odpis v prvním roce
Procento | Procento (první rok odepisování) vstupní ceny
V dalších letech | Koeficient pro zrychlený odpis v dalších letech
Pro odpis ze zvýšené ceny | Koeficient pro zrychlený odpis ze zvýšené ceny
Stránka #3 Výběr
Skupina | Odpisová skupina
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 | Platnost nebo neplatnost k datu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Odpisové skupiny] činnosti - Umístění spravovaného majetku

    Mřížka [Odpisové skupiny] činnosti - Umístění spravovaného majetku
Skupina | Odpisová skupina
Komentář | Komentář k odpisové skupině
do | Platnost odpisové skupiny do

    Mřížka [Sazby a koeficienty] činnosti - Umístění spravovaného majetku

    Mřížka [Sazby a koeficienty] činnosti - Umístění spravovaného majetku
Skupina | Odpisová skupina
Platnost od | Platnost sazeb a koeficientů od data včetně
V prvním roce | Sazba pro rovnoměrný odpis v prvním roce
V dalších letech | Sazba pro rovnoměrný odpis v dalších letech
Pro odpis ze zvýšené ceny | Sazba pro rovnoměrný odpis ze zvýšené vstupní ceny
V prvním roce | Koeficient pro zrychlený odpis v prvním roce
V dalších letech | Koeficient pro zrychlený odpis v dalších letech
Pro odpis ze zvýšené ceny | Koeficient pro zrychlený odpis ze zvýšené ceny

    Atributy tisku

    Základní údaje
Odpisová skupina | Odpisová skupina | ODODPSKU_od05odpsku | C(9)
Platnost | Platnost odpisové skupiny od | od05platod | D
do | Platnost odpisové skupiny do | ODODPSKU_od05platdo | D
Komentář | Komentář k odpisové skupině | ODODPSKU_od05koment | M

    Při pohybu v Sazby a koeficienty
Platnost od | Platnost sazeb a koeficientů od data včetně | ODODPSKP_od40datum | D
Sazba pro rovnoměrný odpis v prvním roce | Sazba pro rovnoměrný odpis v prvním roce | ODODPSKP_od40r1rok | N(5,2)
Sazba pro rovnoměrný odpis v dalších letech | Sazba pro rovnoměrný odpis v dalších letech | ODODPSKP_od40rdalsi | N(5,2)
Sazba pro rovnoměrný odpis ze zvýšené vstupní ceny | Sazba pro rovnoměrný odpis ze zvýšené vstupní ceny | ODODPSKP_od40rzvys | N(5,2)
Koeficient pro zrychlený odpis v prvním roce | Koeficient pro zrychlený odpis v prvním roce | ODODPSKP_od40z1rok | N(2)
Koeficient pro zrychlený odpis v dalších letech | Koeficient pro zrychlený odpis v dalších letech | ODODPSKP_od40zdalsi | N(2)
Koeficient pro zrychlený odpis ze zvýšené ceny | Koeficient pro zrychlený odpis ze zvýšené ceny | ODODPSKP_od40zzvys | N(2)


Parametry odpisovaného majetku

Popis

Jedná se o parametry, které musí uživatel vyplnit před vlastním zahájením práce s komponentou odpisovaný majetek. Jsou to:

¨ datum inicializace - automaticky se naplní po provedené inicializaci

¨ datum účetního odpisu - v rámci inicializace uživatel zadává datum, kdy byly naposledy provedeny účetní odpisy. Každým dalším provedeným účetním odpisem se tato položka aktualizuje automaticky.

¨ rok daňového odpisu - předplní se podle roku uvedeného při provádění účetních odpisů

¨ odpis v měsíci zařazení - zda se má u investičního majetku počítat účetní odpis i v měsíci, kdy byl tento majetek zařazen

¨ odpis v měsíci vyřazení - zda se má u investičního majetku počítat účetní odpis i v měsíci, kdy byl tento majetek vyřazen

¨ neomezovat datum události - při zaškrtnutí tohoto příznaku systém nehlídá při vkládání události ani datum inicializace, ani datum uzavřeného období. Není rozhodně vhodné mít tento příznak zaškrtnutý standardně, používá se pouze pro prvotní naplnění událostí karet (pro možnost získání zůstatkové ceny).

Nastavení parametru odpis v měsíci zařazení a odpis v měsíci vyřazení je platné pro všechny karty odepisovaného majetku a týká se pouze účetního odpisu. Jeho nastavení podléhá konkrétním vnitropodnikovým směrnicím u každé firmy. V případě, že na konkrétní kartě odpis. majetku je nutno tento parametr změnit, nastaví se tato změna přímo na dané kartě – záložka Účetní odpis.

Nastavené parametry by měl uživatel vždy používat stejné během roku, není vhodné jejich definici v průběhu roku měnit.

Formulář

Formulář činnosti - Druhy operací
Datum inicializace | Datum inicializace
Datum účetního odpisu | Datum posledního účetního odpisu
Rok daňového odpisu | Rok posledního daňového odpisu
Odpis v měsíci zařazení | Počítat účetní odpis i za měsíc, kdy došlo k zařazení
Odpis v měsíci vyřazení | Počítat účetní odpis i za měsíc, kdy došlo k vyřazení
Neomezovat datum události | Příznak že u událostí nebude testováno datum

Vyvolávané činnosti

K. | Činnost | Popis
F2 | Druhy operací | Přehled druhů operací

Viz.také

Druhy operací


Inicializace odpisovaného maj.

Popis

Inicializaci je nutno provést před zahájením ostrého provozu komponenty odpisovaný majetek. Datum provedené inicializace se automaticky přepíše do parametrů odpisovaného majetku i do parametrů odpisů a opravných položek pohledávek (datum inicializace je pro obě komponenty shodný).

Formulář

Formulář činnosti - Druhy operací
Datum inicializace Datum, ke kterému se provede inicializace odpisovaného majetku


PLATBY

Popis

Komponenta zajišťuje informace o událostech, týkajících se peněžních nebo naturálních plateb. Eviduje očekávané a realizované platby a to přijímané i vydávané. Očekávanou platbou se rozumí předpis platby k úhradě (přijatý – došlá faktura nebo vydaný - pohledávka). Realizovanou platbou se rozumí úhrada očekávané platby (existuje jako samostatná událost), s platbou očekávanou je spojena mírou plnění. Realizovaná platba je také spojena s položkou bankovního výpisu nebo s pokladním dokladem (událost komponenty Změna stavu peněz).

Viz.také

Události plateb | Aktuální hodnoty plateb | Vlastní účty/pokladny | Parametry plateb | Příkazy k úhradě | Události vymáhání | Algoritmy vymáhání | Postupy vymáhání | Umístění plateb


Události plateb

Popis

Tato činnost poskytuje uživateli přehled událostí komponenty platby obsahující informace o vystavených (pohledávky) nebo přijatých (závazky) platbách. Umožňuje evidovat platby také v zahraničních měnách. Po spuštění činnosti má uživatel nejprve možnost zvolit si nadefinováním výběru způsob zobrazení seznamu událostí plateb.

Atributy události plateb lze vstupovat pouze procesně, tzn. při zadávání v určité operaci plateb. V této činnosti je možno si je pouze prohlížet a některé (povolené) atributy je možno i opravovat.

Uživatel má při vstupu k dispozici atributy:

¨ datum - datum platby (musí být uvedeno). Předplní se aktuální datum. Uživatel jej může změnit – přepsáním nebo výběrem z kalendáře (po kliknutí na pravé tlačítko myši)

¨ splatnost - předplní se datum splatnosti. Doba splatnosti (počet dnů) se nastavuje v Parametrech plateb. V případě, že uživatel potřebuje mít individuální datum splatnosti pro vybrané adresáty, nastaví si toto v adresáři u vybraných adresátů v činnosti „předkontace adresáta“ (menu Volby nebo klávesa F7)

¨ popis - popis platby.

¨ adresát - identifikace adresáta (odesílatel/příjemce). Lze jej vybrat z adresáře klávesou F2.

¨ číslo spojení adresáta - lze vybrat ze seznamu spojení aktuálního adresáta klávesou F2.

¨ identifikátor spojení adresáta na bankovní účet. Lze vybrat ze seznamu Bankovní spojení / pokladna aktuálního adresáta klávesou F2.

¨ název adresáta - po zadání identifikace adresáta se automaticky předplní.

¨ B.úč./pok. - identifikace účtu / pokladny (musí být uvedeno). Lze vybrat ze seznamu Vlastní účty/pokladny klávesou F2. Automaticky se doplní název účtu/pokladny.

¨ umístění - identifikace umístění plateb.

¨ měna - kód měny - oceňovací jednotky (musí být uvedeno). Lze vybrat z číselníku Měn a kurzů klávesou F2. Referenční měna se předplní automaticky.

¨ kurz - kurz oceňovací jednotky vůči referenční měně. Pokud k aktuálnímu dni kurz existuje předplní se tento.

¨ účet - identifikátor účtu účetnictví. Nevyplňuje se při vstupu, ale automaticky se do události plateb doplní po zaúčtování platby (pouze po prvním zápisu).

¨ konstantní symbol - konstantní symbol.

¨ variabilní symbol - variabilní symbol (musí být uveden. U pohledávek se naplňuje automaticky –sestavením z čísla procesu, u závazku musí být zapsán).

¨ částka v ZM - částka v zahraniční měně. Pokud je tato položka prázdná, vyplní se po zadání referenční měny. Přepočet kurzu je automatický.

¨ částka v RM - částka v referenční měně (musí být uvedeno). Pokud byla zadána částka v zahraniční měně, je referenční měna předplněna. Přepočet kurzu je automatický.

¨ dosud uhrazeno - dosud uhrazeno (v referenční měně). Vyplní se, pokud je část (celá) pohledávky uhrazena.

¨ dosud neuhrazeno - dosud neuhrazeno (v referenční měně).

¨ selektory - identifikátor obchodního, organizačního a technicko-věcného selektoru. U všech selektorů lze vybrat z číselníku selektorů klávesou F2.

Kromě těchto atributů má uživatel v tabulce pod záložkou Platby k dispozici i údaje týkající se vyčíslených kurzových rozdílů. Popis přecenění závazků a pohledávek v cizí měně koncem roku je k dispozici ve slovníku pojmů (viz. zvýrazněný hypertextový odkaz).

Na událostech plateb má pak uživatel k dispozici i jednotlivé záložky:

¨ změny stavu peněz – tato záložka poskytuje uživateli informace o tom, jak byla daná platba uhrazována na výpisu z banky, tzn. jaká hodnota platby byla s danou fakturou spárována (položka bankovního výpisu, pokladní doklad, zápočet apod.). V horní části formuláře má uživatel informace o platbě tak, jak je evidována v událostech plateb. Ve spodní část formuláře jsou informace o platbě tak, jak je evidována na výpisu z banky. Částka v zahraniční měně je přepočtena na částku v referenční měně kurzem uvedeným na výpisu z banky. Stiskem klávesy F9 lze spustit danou operaci úhrady (změny stavu peněz).

¨ položky příkazu k úhradě - tato záložka poskytuje uživateli informace o tom, jakým způsobem byl na danou platbu vystaven příkaz (příkazy) k úhradě. V horní části formuláře má uživatel informace o platbě tak, jak je evidována v událostech plateb. Spodní část formuláře poskytuje uživateli informace o vystaveném příkazu k úhradě na celou částku.

¨ vymáhání – tato záložka poskytuje uživateli informace o procesech, které jsou spojeny s vymáháním dané platby. V horní části formuláře má uživatel informace o platbě tak, jak je evidována v událostech plateb. Spodní část formuláře poskytuje uživateli informace o provedených vymáháních. Stiskem klávesy F9 lze spustit danou operaci vymáhání.

¨ účetnictví - tato záložka poskytuje uživateli informace o tom, jak byla daná platba (předpis i následné úhrady) zaúčtována v komponentě účetnictví. V horní části formuláře má uživatel informace o platbě tak, jak je evidována v událostech plateb. Spodní část formuláře poskytuje uživateli informace o zaúčtování platby (včetně případných kurzových rozdílů). Stiskem klávesy F9 lze spustit danou operaci účetnictví (předpis nebo úhradu platby).

Datový model

  • PLUDA Událost plateb
    • PLUP Účet/pokladna (vlastní)
      • ADBUCTY Bankovní účty adresátů (alias ADBUCTY1)
    • ADSPOJ Spojení adresáta
      • ADADSAT Adresát
      • ADADR Adresa
    • ADBUCTY Bankovní účty adresátů
    • BWUZIVAT Uživatel systému
    • SPPRISTU Přístupové právo uživatele k věci
    • PLUMIST Umístění plateb
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU3)
    • SPTYP Druh procesu/operace
    • SPPRC Proces (alias SPPRC2)
    • SPPRCOD Operace procesu (alias SPPRCOD2)

    • Vyvolávané činnosti

    K. | Činnost | Popis
^K | Karty pohledávek | Seznam odpisovaných pohledávek.
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^S | SUMy - Platby |
- | Změna bankovního spojení |
- | INFORMACE O VARIABILNÍM SYMBOLU | Přehledy událostí plateb a změny stavu peněz s variabilním symbolem
F2 | Adresář | Přehled adresátů
F2 | Algoritmy vymáhání | Přehled algoritmů vymáhání
F2 | Bankovní spojení adresátů |
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Umístění plateb | Umístění plateb
F2 | Vlastní účty/pokladny | Vlastní účty/pokladny
F2 | Volné texty | Přehled volných textů
F2 | Účtový rozvrh | Seznam syntetických a analytických účtů.

    Formulář

    Formulář činnosti - Parametry plateb
Mřížka [Platby]
Listovací rámeček
Stránka #1 Platby
 | Pořadové číslo procesu
 | Identifikace datového úložiště číselné řady procesu
 | Rok v identifikaci procesu
 | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Pohledávka/Závazek
 | Název druhu procesu
Datum | Datum platby
Splatnost | Datum splatnosti
Kategorie | Kategorie předepsané platby
Popis | Popis platby
Adresát | Identifikace adresáta (odesílatel / příjemce)
 | Číslo spojení adresáta.
 | Identifikátor spojení na bankovní účet adresáta.
 | Název adresáta
Kód banky | Kód banky
Prefix ú. | Prefix bankovního účtu adresáta
Č. účtu | Číslo bankovního účtu adresáta.
B.úč./pok. | Identifikace účtu/pokladny
 | Název účtu/pokladny
Umístění | Umístění - platby
Měna | Kód měny - oceňovací jednotky.
 | Referenční měna
Kurs | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup.
 | Množství oceňovací jednotky v kursu.
Účet | Identifikátor účtu účetnictví
KS | Konstantní symbol
VS | Variabilní symbol (příjemce)
 | Částka v zahraniční měně nezaokrouhlená
V ZM | Částka v zahraniční měně
 | Záloha v zahraniční měně
 | Částka v referenční měně nezaokrouhlená
V RM | Částka v referenční měně zaokrouhlená
 | Záloha v referenční měně
Uhrazeno v RM | Dosud uhrazeno (v referenční měně)
Neuhrazeno ZM | Dosud neuhrazeno (v zahr. měně)
Text | Identifikace textu
Vymáhání | Identifikace algoritmu vymáhání
Založil | Jméno uživatele systému
Datum a čas zápisu | Datum a čas zápisu záznamu události
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Uhrazená | Příznak uhrazené platby
Stránka #2 Změny stavu peněz
Mřížka [Změny stavu peněz]
Stránka #3 Položky příkazu k úhradě
Mřížka [Položky příkazu k úhradě]
Stránka #4 Vymáhání
Mřížka [Vymáhání]
Stránka #5 Účetnictví
Mřížka [Účetnictví]
Stránka #6 Výběr plateb
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu od
Číslo procesu do | Pořadové číslo procesu do
 | Identifikátor druhu operace
Druh procesu | Identifikátor druhu procesu
Datum události | Datum události
do | Datum události
 | Výběr pohledávek, závazků nebo obou
Datum splat. | Datum splatnosti od
do | Datum splatnosti do
Kat. | Kategorie předepsané platby
Popis | Popis platby
Adresát | Identifikace adresáta
Spojení | Číslo spojení adresáta.
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Úč./pok. | Identifikace účtu/pokladny
Měna | Kód měny - oceňovací jednotky.
Umís. | Umístění - platby
Účet účetnictví | Výběr plateb spojených s účtem účetnictví
VS | Variabilní symbol (příjemce)
Stav procesu | Zobrazit události podle stavu procesu
Očekávaný úkon vymáhání | Úkon očekávaného vymáhání, tj. příští vymáhání bude ...
 | Očekávaný úkon k vymáhání - neomezeně,k dnešnímu dni
Příznak | Zobrazit všechny, uhrazené, neuhrazené platby
Částka v RM | Částka v referenční měně zaokrouhlená
do | Částka v referenční měně do
Neuhrazeno | Dosud neuhrazeno (v referenční měně)
do | Dosud neuhrazeno (v referenční měně) do
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsal | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Platby] činnosti - Parametry plateb

    Mřížka [Platby] činnosti - Parametry plateb
Označování | Označení záznamu
P/Z | Pohledávka/Závazek
Datum | Datum platby
Splatnost | Datum splatnosti
Popis | Popis platby
Účet/pokladna | Identifikace účtu/pokladny
Částka v ZM | Částka v zahraniční měně
Částka v RM | Částka v referenční měně zaokrouhlená
VS | Variabilní symbol (příjemce)
Měna | Kód měny - oceňovací jednotky.
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Kód banky | Kód banky
Prefix ú. | Prefix bankovního účtu adresáta
Č. účtu | Číslo bankovního účtu adresáta.
Specifický symbol | Specifický symbol adresáta
Proces | Pořadové číslo procesu
Dosud neuhrazeno RM | Dosud neuhrazeno (v referenční měně)
Kurzový rozdíl - KPP | Kurzový rozdíl - kurz předepsané platby je menší než kurz úhrady
Kurzový rozdíl - KPP>KÚ | Kurzový rozdíl - kurz předepsané platby je větší než kurz úhrady
Kurzový rozdíl - KPP | Kurzový rozdíl - kurz neuhrazené části předepsané platby je menší než kurz na konci roku
Kurzový rozdíl - KPP>K.ROK | Kurzový rozdíl - kurz neuhrazené části předepsané platby je větší než kurz na konci roku
Dosud neuhrazeno ZM | Dosud neuhrazeno (v zahr. měně)
Vymáhat | Datum očekávaného vymáhání
Úkon vymáhání | Úkon očekávaného vymáhání
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
Umístění | Umístění - platby

    Mřížka [Změny stavu peněz] činnosti - Parametry plateb

    Mřížka [Změny stavu peněz] činnosti - Parametry plateb
CR/DB | Příjem/Výdej = Credit/Debet
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Externí číslo | Externí číslo procesu
Druh operace | Identifikátor druhu operace
Datum | Datum výpisu z banky/příkazu k úhradě
Variabilní symbol | Variabilní symbol (příjemce)
Částka v ZM platby | Hodnota částky z výpisu uhrazující platbu v zahraniční měně platby
Uhrazená částka | Hodnota částky z výpisu uhrazující platbu v zahraniční měně úhrady
Měna | Kód měny - oceňovací jednotky.
Částka v RM | Částka k úhradě/inkasu v RM
Kód banky | Kód banky
Č. účtu | Číslo bankovního účtu adresáta.

    Mřížka [Položky příkazu k úhradě] činnosti - Parametry plateb

    Mřížka [Položky příkazu k úhradě] činnosti - Parametry plateb
Rok | Rok vystavení příkazu k úhradě
IDÚ | Identifikace datového úložiště
Příkaz | Číslo příkazu k úhradě
Datum | Datum příkazu k úhradě
Popis | Popis příkazu k úhradě
Částka na příkazu | Částka v zahraniční měně
Účet | Identifikace účtu
Název účtu | Název účtu

    Mřížka [Vymáhání] činnosti - Parametry plateb

    Mřížka [Vymáhání] činnosti - Parametry plateb
Datum | Datum události vymáhání pohledávky pro spojení s platbou podle kalendáře
Popis | Popis události vymáhání pohledávky
Adresát | Identifikace adresáta
Úkon | Upomínka nebo penále
Měna | Kód měny - oceňovací jednotky.
Částka penále | Částka v zahraniční měně
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Druh operace | Identifikátor druhu operace
Pořadí | Pořadí stejného druhu operace v jednom procesu

    Mřížka [Účetnictví] činnosti - Parametry plateb

    Mřížka [Účetnictví] činnosti - Parametry plateb
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Datum | Datum účetního případu
Účet | Identifikátor účtu účetnictví
Strana | Strana účtu MD/Dal
Částka | Finanční částka
Popis události | Popis účetní události
Částka ZM | Částka v zahraniční měně
IDP | Identifikace párování
Org. sel. | Identifikátor organizačního selektoru.

    Atributy tisku

    Základní údaje
Rok | Rok v identifikaci procesu | PLUDA_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | PLUDA_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | PLUDA_sp33cisd | C(8)
Druh operace | Identifikátor druhu operace | PLUDA_sp07idtyp | C(6)
Komponenta | Identifikace komponenty | PLUDA_sp06idsubs | C(3)
Pořadí druhu operace | Pořadí stejného druhu operace v jednom procesu | PLUDA_sp33porad | N(2)
Název druhu operace | Název druhu operace | SPTYP_sp07text | C(30)
Účet účetnictví | Identifikátor účtu účetnictví | PLUDA_uc01id | C(9)
P/Z | Pohledávka/Závazek | Výpočet | C(10)
Datum platby | Datum platby | PLUDA_pl02datpla | D
Splatnost | Datum splatnosti | PLUDA_pl02datspl | D
Popis platby | Popis platby | PLUDA_pl02text | C(40)
Kategorie | Kategorie předepsané platby | Výpočet | C(1)
Obsah textu | Obsah textu | SPTEXTYN_sp89obsah | M
Variabilní symbol | Variabilní symbol (příjemce) | PLUDA_pl02vs | C(10)
Konstantní symbol | Konstantní symbol | PLUDA_pl02ks | C(4)
Částka v ZM (nezaok.) | Částka v zahraniční měně nezaokrouhlená | PLUDA_pl02czmnez | N(20,4)
Částka v ZM | Částka v zahraniční měně | PLUDA_pl02czm | N(20,4)
Záloha v ZM | Záloha v zahraniční měně | PLUDA_pl02zalzm | N(20,4)
Dosud neuhrazeno ZM | Dosud neuhrazeno (v zahr. měně) | PLUDA_pl02czmnu | N(20,4)
Částka v RM (nezaok.) | Částka v referenční měně nezaokrouhlená | PLUDA_pl02crmnez | N(20,4)
Částka v RM | Částka v referenční měně zaokrouhlená | PLUDA_pl02crm | N(20,4)
Záloha v RM | Záloha v referenční měně | PLUDA_pl02zalrm | N(20,4)
Dosud uhrazeno | Dosud uhrazeno (v referenční měně) | PLUDA_pl02crmu | N(20,4)
Dosud neuhrazeno RM | Dosud neuhrazeno (v referenční měně) | PLUDA_pl02crmnu | N(20,4)
Měna | Kód měny - oceňovací jednotky. | PLUDA_oc01id | C(3)
Kurs | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup. | PLUDA_oc03kurz | N(20,6)
Množství | Množství oceňovací jednotky v kursu. | PLUDA_oc03mn | N(5)
Účet/pokladna | Identifikace účtu/pokladny | PLUDA_pl01id | C(6)
Název účtu/pokladny | Název účtu/pokladny | PLUP_pl01text | C(40)
Umístění - platby | Umístění - platby | PLUDA_pl08id | C(6)
Název umístění | Název umístění - platby | PLUMIST_pl08text | C(40)
Penále % | Hodnota penále | VMALGOR_vm06penale | N(8,4)
Poznámka | Poznámka | VMALGOR_vm06koment | M
Kód banky | Kód banky | ADBUCTY1_oc02idbank | C(4)
Název banky | Název banky | OCBANKA1_oc02nazevb | C(40)
SWIFT | SWIFT kód banky. | OCBANKA1_oc02swift | C(11)
Kód BLZ | BLZ kód banky | OCBANKA1_oc02blz | C(10)
Pobočka | Název pobočky, která vede bankovní účet adresátovi. | ADBUCTY1_ad03poboc | C(25)
Prefix ú. | Prefix bankovního účtu adresáta | ADBUCTY1_ad03pructu | C(6)
Č. účtu | Číslo bankovního účtu adresáta. | ADBUCTY1_ad03ucet | C(34)
Specifický symbol | Specifický symbol adresáta | ADBUCTY1_ad03ssymb | C(10)
IBAN | IBAN - mezinárodní bankovní číslo účtu | ADBUCTY1_ad03iban | C(34)
Měna | Kód měny - oceňovací jednotky. | ADBUCTY1_oc01id | C(3)
Název účtu | Název účtu | ADBUCTY1_ad03nauctu | C(20)
Komentář | Komentář k bankovnímu účtu adresáta. | ADBUCTY1_ad03koment | M
Debet | Příznak možnosti debetu (u pokladen, nikoliv u účtů). | Výpočet | C(3)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Rok (vymáhání) | Rok v identifikaci procesu | VMUDA_sp33cisdr | C(4)
IDÚ (vymáhání) | Identifikace datového úložiště číselné řady procesu | VMUDA_sp33cisdpm | C(2)
Proces (vymáhání) | Pořadové číslo procesu | VMUDA_sp33cisd | C(8)
Druh operace (vymáhání) | Identifikátor druhu operace | VMUDA_sp07idtyp | C(6)
Komponenta (vymáhání) | Identifikace komponenty | VMUDA_sp06idsubs | C(3)
Pořadí druhu operace (vymáhání) | Pořadí stejného druhu operace v jednom procesu | VMUDA_sp33porad | N(2)
Upomínka / penále (vymáhání) | Upomínka nebo penále | Výpočet | C(8)
Datum vymáhání pohledávky | Datum události vymáhání pohledávky pro spojení s platbou podle kalendáře | VMUDA_vm02datum | D
Popis vymáhání pohledávky | Popis události vymáhání pohledávky | VMUDA_vm02text | C(40)
Měna (vymáhání) | Kód měny - oceňovací jednotky. | VMUDA_oc01id | C(3)
Částka v ZM (vymáhání) | Částka v zahraniční měně | VMUDA_vm02czm | N(20,4)
Poznámka (vymáhání) | Poznámka k vymáhání | VMUDA_vm02koment | M
Stát | Identifikace státu. | ADADR_ad05id | C(3)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
Byt | Ulice bytu adresáta (včetně čísla popisného) | ADADR_ad02byt | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
IČO | Identifikační číslo organizace. | ADADSAT_ad01ico | C(10)
Adresát | Identifikace adresáta | PLUDA_ad01id | C(6)
DIČ | Daňové identifikační číslo adresáta. | ADADSAT_ad01dico | C(16)
Účet/pokladna | Identifikace účtu/pokladny | PLUP_pl01id | C(6)
Datum a čas zápisu | Datum a čas zápisu záznamu události | PLUDA_sp00datzap | T

    Viz.také

    Karty pohledávek | OZNAČOVÁNÍ | SUMy - Platby | Změna bankovního spojení | INFORMACE O VARIABILNÍM SYMBOLU | Adresář | Algoritmy vymáhání | Bankovní spojení adresátů | Druhy operací | Druhy procesů | Kategorie adresátů | Měny a kursy | Obchodní selektor | Organizační selektor | Spojení adresátů | Technicko-věcný selektor | Umístění plateb | Vlastní účty/pokladny | Volné texty | Účtový rozvrh | Parametry operací plateb | Parametry plateb


Aktuální hodnoty plateb

Popis

Činnost Aktuální hodnoty plateb slouží jako přehled plateb a jejich aktuálních hodnot (jako aktuální hodnoty plateb má smysl definovat např. pohledávku, závazek, stav účtu/pokladny apod.). Podle zvoleného výběru má pak uživatel k dispozici jednotlivé aktuální hodnoty za období, za adresáta nebo umístění.

Datový model

  • PLAH Aktuální hodnota plateb
    • PLUMIST Umístění plateb
      • SPPRISTU Přístupové právo uživatele k věci
    • ADADSAT Adresát
    • SPSTATDI Druh hodnoty

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresář | Přehled adresátů
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Umístění plateb | Umístění plateb

    Formulář

    Formulář činnosti - Kategorie adresátů
Mřížka [Aktuální hodnoty plateb]
Listovací rámeček
Stránka #1 Aktuální hodnoty plateb
Druh | Identifikace druhu hodnoty
 | Název druhu hodnoty
Adresát | Identifikace adresáta
 | Název adresáta
Umístění - platby | Umístění - platby
 | Název umístění - platby
Hodnota | Aktuální hodnota
Stránka #2 Výběr
Druh | Identifikace druhu hodnoty
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Umístění | Umístění - platby
 | Název umístění - platby
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Aktuální hodnoty plateb] činnosti - Kategorie adresátů

    Mřížka [Aktuální hodnoty plateb] činnosti - Kategorie adresátů
Druh hodnoty | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Umístění - platby | Umístění - platby
Název umístění | Název umístění - platby
Hodnota | Aktuální hodnota

    Atributy tisku

    Základní údaje
Druh hodnoty | Identifikace druhu hodnoty | PLAH_sp67id | C(3)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)
Adresát | Identifikace adresáta | PLAH_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Umístění - platby | Umístění - platby | PLAH_pl08id | C(6)
Název umístění | Název umístění - platby | PLUMIST_pl08text | C(40)
Hodnota | Aktuální hodnota | PLAH_pl02hodnot | N(20,4)

    Viz.také

    Adresář | Druhy hodnot | Kategorie adresátů | Umístění plateb


Vlastní účty/pokladny

Popis

Činnost účty/pokladny slouží k definici vlastních účtů a pokladen. Rozšiřující údaje přebírá z bankovního spojení v adresáři.

K dispozici jsou atributy:

¨ B.účet/pokladna - identifikace a název účtu nebo pokladny

¨ číslo účtu – zadává se zde přímo číslo účtu

¨ typ – zda se jedná o účet nebo pokladnu

¨ debet - příznak možnosti debetu

¨ kód banky

¨ účet - předplní se identifikace adresáta označeného v parametrech adresáře jako "já", nutno pouze zadat identifikaci bankovního spojení daného adresáta. Následující údaje (název, pobočka) se automaticky předplní podle zadaného bankovního spojení.

¨ SS – pokud se daného účtu týká přímo určitý specifický symbol, který chce uživatel ve spojitosti s tímto účtem používat

¨ měna – identifikace měny účtu

¨ další měny – identifikace měn, pokud má daný bankovní účet nadefinovány ještě další měny

¨ účet - identifikátor účtu (účetnictví). Účet lze vybrat z číselníku Účtový rozvrh klávesou F2. Sám se předplní Cizojazyčný popis účtu.

¨ přenos - identifikace definice přenosů komunikace s bankou. Lze vybrat z přehledu definic přenosů klávesou F2. Sám se předplní název definice přenosů. V případě, že se daný účet bude používat při komunikaci s bankou, je nutno zde mít identifikaci přenosu vyplněnou.

¨ organizační selektor - identifikátor organizačního selektoru. Lze jej vybrat ze seznamu organizačních selektorů klávesou F2.

Na záložce aktuální hodnoty změny stavu peněz má uživatel u každého účtu nebo pokladny k dispozici informaci o výši nadefinované aktuální hodnoty (nejčastěji to bývá stav účtu/pokladny). Atributy na této záložce nelze vstupovat, slouží pouze pro prohlížení.

Ke každému účtu nebo pokladně je možno nadefinovat přístupová práva (příslušná činnost pod menu Volby nebo klávesa Ctrl B).

Datový model

  • PLUP Účet/pokladna (vlastní)
    • ADADSAT Adresát
    • ZPPRHLA Definice přenosu příkazu
    • UCROZVRH Účet z rozvrhu
      • UCROZVRN Cizí popis účtu
    • ADBUCTY Bankovní účty adresátů
      • OCBANKA Banka
      • OCMENA Měna
    • SPSEOR Organizační selektor
    • SPPRISTU Přístupové právo uživatele k věci

    • Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci
F2 | Bankovní spojení adresátů |
F2 | Definice komunikace s bankou | Vstup definic pro vytvoření souborů pro elektronický styk s bankou
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Účtový rozvrh | Seznam syntetických a analytických účtů.

    Formulář

    Formulář činnosti - Účtový rozvrh
Mřížka [Účty/pokladny]
Listovací rámeček
Stránka #1 Účty/pokladny
B.účet/pokladna | Identifikace účtu/pokladny
 | Název účtu/pokladny
 | Adresát
Účet | Identifikátor spojení na bankovní účet adresáta.
Typ | Příznak účet, pokladna
Kód banky | Kód banky
 | Název banky
Pobočka | Název pobočky, která vede bankovní účet adresátovi.
 | Prefix bankovního účtu adresáta
Č. účtu | Číslo bankovního účtu adresáta.
SS | Specifický symbol adresáta
Název ú. | Název účtu
Měna | Kód měny - oceňovací jednotky.
 | Název měny
Další měny | Seznam dalších měn účtu
Debet | Příznak možnosti debetu (u pokladen, nikoliv u účtů).
Účet | Identifikátor účtu účetnictví
 | Cizojazyčný popis účtu.
Přenos | Identifikace definice přenosů
 | Název definice přenosů
Org. sel. | Identifikátor organizačního selektoru.
 | Název organizačního selektoru
Stránka #2 Aktuální hodnoty změny stavu peněz
Mřížka [Aktuální hodnoty změny stavu peněz]
B.účet/pokladna | Identifikace účtu/pokladny
Druh hodnoty | Identifikace druhu hodnoty
 | Název druhu hodnoty
Adresát | Identifikace adresáta
 | Název adresáta
Měna | Kód měny - oceňovací jednotky.
Hodnota | Aktuální hodnota změny stavu peněz

    Mřížka [Účty/pokladny] činnosti - Účtový rozvrh

    Mřížka [Účty/pokladny] činnosti - Účtový rozvrh
Účet/pokladna | Identifikace účtu/pokladny
Název účtu/pokladny | Název účtu/pokladny
Účet | Identifikátor spojení na bankovní účet adresáta.

    Mřížka [Aktuální hodnoty změny stavu peněz] činnosti - Účtový rozvrh

    Mřížka [Aktuální hodnoty změny stavu peněz] činnosti - Účtový rozvrh
Název druhu hodnoty | Název druhu hodnoty
Měna | Kód měny - oceňovací jednotky.
Hodnota | Aktuální hodnota změny stavu peněz
Adresát | Identifikace adresáta
 | Název adresáta

    Atributy tisku

    Základní údaje
Účet/pokladna | Identifikace účtu/pokladny | PLUP_pl01id | C(6)
Název účtu/pokladny | Název účtu/pokladny | PLUP_pl01text | C(40)
Adresát | Identifikace adresáta | PLUP_ad01id | C(6)
Účet | Identifikátor spojení na bankovní účet adresáta. | PLUP_ad03cisban | C(2)
Kód banky | Kód banky | ADBUCTY_oc02idbank | C(4)
Název banky | Název banky | OCBANKA_oc02nazevb | C(40)
Pobočka | Název pobočky, která vede bankovní účet adresátovi. | ADBUCTY_ad03poboc | C(25)
Č. účtu | Číslo bankovního účtu adresáta. | ADBUCTY_ad03ucet | C(34)
Specifický symbol | Specifický symbol adresáta | ADBUCTY_ad03ssymb | C(10)
Název ú. | Název účtu | ADBUCTY_ad03nauctu | C(20)
Komentář | Komentář k bankovnímu účtu adresáta. | ADBUCTY_ad03koment | M
Měna | Kód měny - oceňovací jednotky. | ADBUCTY_oc01id | C(3)
Další měny | Seznam dalších měn účtu | PLUP_pl01sezmen | C(50)
Název měny | Název měny | OCMENA_oc01nazev | C(18)
Debet | Příznak možnosti debetu (u pokladen, nikoliv u účtů). | Výpočet | C(3)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)
Název adresáta | Název adresáta | ADADSAT1_ad01adsat | C(100)

    Při pohybu v Aktuální hodnoty změnu stavu peněz
Druh hodnoty | Identifikace druhu hodnoty | ZPAH_sp67id | C(3)
Adresát | Identifikace adresáta | ZPAH_ad01id | C(6)
Měna | Kód měny - oceňovací jednotky. | ZPAH_oc01id2 | C(3)
Hodnota | Aktuální hodnota změny stavu peněz | ZPAH_zp02hodnot | N(20,4)

    Viz.také

    Přístupová práva | Bankovní spojení adresátů | Definice komunikace s bankou | Organizační selektor | Účtový rozvrh


Parametry plateb

Popis

Činnost Parametry plateb slouží k nastavení parametrů pro komponentu PLATBY:

¨ implicitní doba splatnosti pohledávky - zadává se zde počet dnů, po které trvá splatnost pohledávky. Je použit pro výpočet data splatnosti, tzn. že při zadání data na události platby se automaticky dopočte datum splatnosti (při potřebě nastavení individuálního data splatnosti pro vybrané adresáty lze využít činnost „předkontace adresáta“). Tato doba splatnosti pohledávky se vztahuje k datu zápisu platby (tzn. datum splatnosti je tvořeno způsobem: datum zápisu platby + zde uvedená implicitní doba splatnosti pohledávky).

¨ vzhledem k datu platby – možnosti Ano/Ne (implicitně nastaveno Ne). Tuto možnost uživatel využije v případě, že implicitní dobu splatnosti pohledávky chce vztahovat k datu zdanitelného plnění (tzn. tj. shodné s datem platby). Pak se datum splatnosti pohledávky tvoří způsobem: datum platby + zde uvedená implicitní doba splatnosti pohledávky. I toto nastavení lze uplatnit individuálně pro vybrané adresáty, viz. nastavení předkontace adresáta.

¨ implicitní doba splatnosti závazku - v případě potřeby je možno nastavit počet dnů, po které trvá splatnost závazku. Pokud uživatel tento parametr nechce využívat, nechá nastaveno číslo nula. Stejně jako u pohledávky, i zde platí, že doba splatnosti závazku se vztahuje k datu zápisu platby (tzn. datum splatnosti je tvořeno způsobem: datum zápisu platby + zde uvedená implicitní doba splatnosti závazku).

¨ vzhledem k datu platby - možnosti Ano/Ne (implicitně nastaveno Ne). Tuto možnost uživatel využije v případě, že implicitní dobu splatnosti závazku chce vztahovat k datu zdanitelného plnění (tzn. tj. shodné s datem platby). Pak se datum splatnosti závazku tvoří způsobem: datum platby + zde uvedená implicitní doba splatnosti závazku.

¨ 1.část variabilního symbolu - možnost nastavit si první čtyři znaky variabilního symbolu pohledávek (mohou být tvořeny kombinací čísel a znaků R – rok a znaků U – identifikace datového úložiště). Pak zde v tomto atributu může být kombinace RU (rok, úložiště – vždy poslední znak z tohoto atributu, je-li rok 2007 a identifikace úložiště je 01, pak první část var.symbolu bude 71) nebo RUU, RRUU apod. Variabilní symbol v IS BM je tvořen 10 znaky. První čtyři znaky jsou určeny tímto parametrem, dalších 6 znaků je automaticky generováno z čísla procesu. Pokud zde má uživatel nastaveno tento parametr jako např. RU, bude jeho generovaný VS pouze osmimístný.

Důležité upozornění:

Druhy procesů, které tvoří pohledávky, musí mít číselnou řadu menší než jeden milion, tzn. tvořenu 6 místy. Pokud si uživatel vytvoří číselnou řadu delší, může vzniknout problém ve VS v letech. V případě, že vygenerovaný variabilní symbol z plateb (6 znaků) by obsahoval na prvních místech číslice nula, jsou nuly automaticky mazány.

¨ validace variabilního symbolu - je možno zvolit Ne, Ano, Ano stejného adresáta, Podle parametrů plateb. Ne způsobí, že se variabilní symbol přijatých faktur vůbec kontrolovat nebude. Ano znamená, že systém nahlásí, pokud najde platbu se stejným variabilním symbolem. Ano stejného adresáta znamená, že systém nahlásí, že našel platbu se shodným variabilním symbolem, pokud se zároveň budou shodovat adresáti plateb. Podle parametrů plateb znamená, že kontrola se bude provádět podle nastavení ekvivalentního parametru operace komponenty plateb (druhy operací, v menu Volby Parametry operace komponenty). Tato volba umožňuje nastavit chování BM při zápisu události (závazku) operace daného druhu z hlediska kontroly duplicity variabilního symbolu.

¨ nevalidované variabilní symboly - zde se uvádí seznam variabilních symbolů (oddělených čárkou), pro které se nebude provádět validace. Může se jednat např. o var. symboly různých převodů na účet apod.

Tyto údaje se v činnosti Parametry plateb ukládají do tabulky BWMEMOR s celou řadou dalších proměnných.

Formulář

Formulář činnosti - Účtový rozvrh
Implicitní doba splatnosti pohledávky | Implicitní doba splatnosti pohledávky ve dnech
Vzhledem k datu platby | Doba splatnosti pohledávky je: Ano=vzhledem k datu platby, Ne=vzhledem k aktuánímu datu
Implicitní doba splatnosti závazku | Implicitní doba splatnosti závazku ve dnech
Vzhledem k datu platby | Doba splatnosti závazku je: Ano=vzhledem k datu platby, Ne=vzhledem k aktuánímu datu
1.část variabilního symbolu | Konstrukce prefixu variabilního symbolu
Validace variabilního symbolu | Provádět validaci existence závazku se stejným variabilním symbolem
Nevalidované variabilní symboly | Seznam variabilních symbolů oddělených čárkou , pro které nemá být prováděna validace


Příkazy k úhradě

Popis

Činnost příkazy k úhradě je dostupná v hlavním menu v činnosti Platby. Po aktivaci této činnosti se uživateli nejprve zobrazí záložka „výběr“. Její atributy uživatel využije v případě, že hledá konkrétní, již vytvořený, příkaz k úhradě. Je možno hledat podle čísla příkazu, podle data vystavení od – do apod. Nadefinovaný výběr je nutno načíst (ikona „disketa“ nebo klávesa PgDn).

Pokud uživatel bude definovat nový příkaz k úhradě, záložku „výběr“ nechává prázdnou a ukončí ji ikonou „šipka zpět“ (pak se mu zobrazí čistý formulář) nebo ikonou „disketa“ (jsou zobrazeny všechny dosud vystavené příkazy k úhradě). Nový příkaz k úhradě uživatel zadává po stisku klávesy F3 nebo ikony „vložení nového záznamu“. Definuje se:

¨ pořadové číslo – automaticky se předplní o jedno vyšší než číslo posledního příkazu (doporučujeme nepřepisovat)

¨ datum vystavení, které je následně považováno za den, kdy má banka zrealizovat úhrady – předplní se aktuální datum

¨ popis příkazu – vlastní popis uživatele

¨ bankovní účet – výběr bankovního účtu, ze kterého bude příkaz k úhradě proveden

Tímto krokem má uživatel vytvořenu hlavičku příkazu k úhradě. Nyní je nutno na příkaz vložit platby, které mají být uhrazeny.

Jednotlivé platby k úhradě se na příkaz přiřadí pomocí klávesy F9 nebo volbou činnosti „události plateb“ pod menu Volby. Po aktivaci této činnosti se uživateli nabídne záložka „výběr“ událostí plateb. Zde je naprosto nejvhodnější způsob nechat tento výběr prázdný (v některých případech je vhodné zadat rok) a v atributu výběr zvolit „nepřikázané závazky“. Tento obecný výběr zajistí, že uživateli se zobrazí dosud neuhrazené závazky, které ještě nejsou součástí žádného vystaveného příkazu k úhradě. V některých verzích se tento výběr jmenuje „nepřikázané závazky bez *“, jeho funkčnost však zůstává shodná.

Zobrazí se přehled dosud neuhrazených závazků. Uživatel si tento přehled může setřídit (např. podle data splatnosti) a pak je nutné jednotlivé závazky, které chce přenést na příkaz k úhradě označit („zaškrtnutím“ čtverečku označení záznamu). Po jejich označení stiskne klávesu ESC a tyto označené závazky se přenesou na příkaz k úhradě a jsou k dispozici pod záložkou „položky příkazu k úhradě“. Na příkaz k úhradě se přenáší částka závazku „dosud neuhrazeno“. V případě, že je na danou platbu vystaven další částečný příkaz k úhradě, je částka „dosud neuhrazeno“ automaticky snížena o hodnotu příkazu k úhradě (a ta se přenese na příkaz k úhradě).

V případě kombinace hotovostních úhrad, zápočtů a příkazů k úhradě na jednom závazku je nutné vytvořit fiktivní příkazy k úhradě na hotovostní a nepeněžní úhrady faktury (tj.závazku). Stejné pravidlo platí i pro kombinaci zápočtu a příkazu k úhradě a hotovostní úhrady a příkazu k úhradě.

V levé části obrazovky je k dispozici přehled všech závazků k úhradě, v pravé části jsou vždy informace k aktuálnímu závazku (tzn. tomu, na kterém je umístěn kurzor). V případě potřeby je samozřejmě možno částku na příkazu změnit (např. pouze částečná úhrada platby), pak je nutno ručně opravit atribut „částka na příkazu“.

Příkazy v úhradě je možno vystavovat i v cizí měně, pak u každé platby bude skutečně vyčíslena hodnota v cizí měně a identifikátor měny (např. EUR).

Pro ideální zpracovaní příkazu elektronickou formou doporučujeme s ohledem na některé bankovní software, aby každý příkaz k úhradě byl vystaven v jednotné měně (tzn. nekombinovat na jednom příkazu platby v CZK a EUR).

Při zobrazení záložky „příkazy k úhradě“ se uživateli znovu zobrazí hlavička příkazu k úhradě, po jejím znovunačtení (volby Obecné – Znovu načíst) se doplní i celková částka PÚ.

Takto vystavený příkaz k úhradě je možno vytisknout (volba předlohy výstupu po stisku ikonky „tiskárna“ – předloha „hromadný příkaz k úhradě“ nebo „příkaz k úhradě – individuální“) nebo po stisku klávesy F5 provést „export příkazu k úhradě“ (v případě, že uživatel používá elektronický platební styk).

Po celkové kontrole vystaveného příkazu k úhradě a zejména před jeho odesláním do banky je vhodné tento příkaz uzamknout (klávesa F6 nebo činnost „uzavřít příkaz“ pod menu Volby). Uzavření příkazu znemožní editaci příkazu (tzn. nikdo již nemůže opravovat data, která byla odeslána do banky). V případě, že se příkaz uzavřel a je ještě před odesláním do banky, a je nutno provést určitou změnu, je možno ho znovu otevřít (pod menu Volby aktivovat činnost „zrušit uzavření příkazu“), provést opravu, znovu uzavřít a následně odeslat do banky.

Datový model

  • PLPRIU Příkaz k úhradě
    • PLUP Účet/pokladna (vlastní)
      • SPPRISTU Přístupové právo uživatele k věci
      • ADBUCTY Bankovní účty adresátů (alias ADBUCTY3)
    • BWUZIVAT Uživatel systému

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Export příkazu k úhradě | Export příkazu k úhradě pro elektronický styk s bankou
F6 | Uzavřít příkaz | Uzavření příkazu k úhradě
F9 | Události plateb | Evidence událostí plateb (přijatých a vydaných)
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Zrušit uzavření příkazu |
F2 | Vlastní účty/pokladny | Vlastní účty/pokladny

    Formulář

    Formulář činnosti - Spuštění výstupu
Mřížka [Příkazy k úhradě]
 | Rok vystavení příkazu k úhradě
 | Identifikace datového úložiště
Příkaz | Číslo příkazu k úhradě
Datum | Datum příkazu k úhradě
 | Popis příkazu k úhradě
Celková částka PÚ | Celková částka příkazu k úhradě
Listovací rámeček
Stránka #1 Příkazy k úhradě
Uzavřený příkaz k úhradě | Uzavřený příkaz k úhradě
B. účet | Identifikace účtu
 | Název účtu/pokladny
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Poznámka | Poznámka k příkazu k úhradě
Stránka #2 Položky příkazu k úhradě
Mřížka [Položky příkazu k úhradě]
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
 | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
VS | Variabilní symbol (příjemce)
Splatnost | Datum splatnosti
 | Popis platby
Adresát | Identifikace adresáta
 | Název adresáta
Částka v ZM | Částka v zahraniční měně
Záloha v ZM | Záloha v zahraniční měně
Částka na příkazu | Částka v zahraniční měně
 | Kód měny - oceňovací jednotky.
Kód banky | Kód banky
Prefix ú. | Prefix bankovního účtu adresáta
Č. účtu | Číslo bankovního účtu adresáta.
Stránka #3 Výběr
 | Rok vystavení příkazu k úhradě
 | Identifikace datového úložiště
Příkaz | Číslo příkazu k úhradě
B. účet | Identifikace účtu
Datum | Datum příkazu k úhradě
 | Datum příkazu k úhradě
Popis | Popis příkazu k úhradě
Zapsané | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Příkazy k úhradě] činnosti - Spuštění výstupu

    Mřížka [Příkazy k úhradě] činnosti - Spuštění výstupu
Označování | Označení záznamu
Rok | Rok vystavení příkazu k úhradě
IDÚ | Identifikace datového úložiště
Příkaz | Číslo příkazu k úhradě
Datum | Datum příkazu k úhradě
Celkem | Celková částka příkazu k úhradě
Popis | Popis příkazu k úhradě
Účet | Identifikace účtu
Název účtu | Název účtu
Přenos | Identifikace definice přenosů

    Mřížka [Položky příkazu k úhradě] činnosti - Spuštění výstupu

    Mřížka [Položky příkazu k úhradě] činnosti - Spuštění výstupu
VS | Variabilní symbol (příjemce)
Částka na příkazu | Částka v zahraniční měně
Měna | Kód měny - oceňovací jednotky.
Dosud neuhrazeno ZM | Dosud neuhrazeno (v zahr. měně)
Splatnost | Datum splatnosti
Popis platby | Popis platby
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh procesu | Identifikátor druhu operace
Pořadí | Pořadí stejného druhu operace v jednom procesu
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Částka v ZM | Částka v zahraniční měně
Záloha v ZM | Záloha v zahraniční měně
Částka v RM | Částka v referenční měně zaokrouhlená
Dosud neuhrazeno RM | Dosud neuhrazeno (v referenční měně)

    Atributy tisku

    Základní údaje
Rok | Rok vystavení příkazu k úhradě | PLPRIU_pl03rok | C(4)
IDÚ | Identifikace datového úložiště | PLPRIU_pl03idu | C(2)
Příkaz | Číslo příkazu k úhradě | PLPRIU_pl03id | C(6)
Datum | Datum příkazu k úhradě | PLPRIU_pl03datum | D
Popis | Popis příkazu k úhradě | PLPRIU_pl03prikuh | C(40)
Celková částka PÚ | Celková částka příkazu k úhradě | PLPRIU_pl03suma | N(20,4)
Účet | Identifikace účtu | PLPRIU_pl01id | C(6)
Název účtu | Název účtu | PLUP_pl01text | C(40)
Kód banky | Kód banky | ADBUCTY3_oc02idbank | C(4)
Pobočka | Název pobočky, která vede bankovní účet adresátovi. | ADBUCTY3_ad03poboc | C(25)
Prefix ú. | Prefix bankovního účtu adresáta | ADBUCTY3_ad03pructu | C(6)
Č. účtu | Číslo bankovního účtu adresáta. | ADBUCTY3_ad03ucet | C(34)
Specifický symbol | Specifický symbol adresáta | ADBUCTY3_ad03ssymb | C(10)
Poznámka | Poznámka k příkazu k úhradě | PLPRIU_pl03koment | M
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | PLPRIU_sp00datzap | T
Rok | Rok v identifikaci procesu | PLUDA_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | PLUDA_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | PLUDA_sp33cisd | C(8)
Druh operace | Identifikátor druhu operace | PLUDA_sp07idtyp | C(6)
Pořadí | Pořadí stejného druhu operace v jednom procesu | PLUDA_sp33porad | N(2)
Splatnost | Datum splatnosti | PLUDA_pl02datspl | D
Částka v RM | Částka v referenční měně zaokrouhlená | PLUDA_pl02crm | N(20,4)
Dosud neuhrazeno RM | Dosud neuhrazeno (v referenční měně) | PLUDA_pl02crmnu | N(20,4)
Adresát | Identifikace adresáta | PLUDA_ad01id | C(6)
Název příjemce | Název adresáta | ADADSAT_ad01adsat | C(100)
Kód banky | Kód banky | ADBUCTY_oc02idbank | C(4)
Pobočka | Název pobočky, která vede bankovní účet adresátovi. | ADBUCTY_ad03poboc | C(25)
Č. účtu | Číslo bankovního účtu adresáta. | ADBUCTY_ad03ucet | C(34)
Prefix ú. | Prefix bankovního účtu adresáta | ADBUCTY_ad03pructu | C(6)
Specifický symbol | Specifický symbol adresáta | ADBUCTY_ad03ssymb | C(10)
Variabilní symbol | Variabilní symbol (příjemce) | PLUDA_pl02vs | C(10)
Konstantní symbol | Konstantní symbol | PLUDA_pl02ks | C(4)
Měna | Kód měny - oceňovací jednotky. | PLUDA_oc01id | C(3)
Částka na příkazu | Částka v zahraniční měně | PLPRIUP_pl04crm | N(20,4)

    Viz.také

    Export příkazu k úhradě | Uzavřít příkaz | Události plateb | OZNAČOVÁNÍ | Zrušit uzavření příkazu | Vlastní účty/pokladny | Spuštění výstupu


Události vymáhání

Popis

Uživatel má k dispozici přehled vytvořených událostí vymáhání. Na základě nastavených algoritmů a postupů vymáhání se pak procesně vytvářejí události vymáhání. Aktivuje se proces vymáhání, kde si pomocí funkční klávesy F6 uživatel vybere události plateb, kterých se vymáhání bude týkat. Tyto události se označí (tj. zaškrtají) a pomocí klávesy ESC přenesou zpět do událostí vymáhání. Zde nejprve vyplní parametry výpočtu vymáhání:

¨ datum, ke kterému se budou události (nebo událost) vymáhat – předplňuje se dnešní datum

¨ úkon – může nabývat hodnot - upomínka

- penále

- podle dat (dnů)

- podle dat (textů)

- chování jednotlivých hodnot závisí na nastavených algoritmech vymáhání.

¨ nepřenášet do částky včetně – určení min. částky, která se nebude vymáhat (např. pokud by vypočtené penále vycházelo méně než 50,- Kč, tak se nemá vymáhat)

¨ text – identifikace textu, který se má s daným úkonem vytisknout (např. text první upomínky)

U každé události je pak následně uvedeno:

¨ identifikace procesu a úkon, který se provádí

¨ datum vzniku události vymáhání

¨ datum události vymáhání pohledávky pro spojení s platbou podle kalendáře

¨ popis

¨ identifikace adresáta

¨ základní částka – celková původní částka přenesená z událostí plateb

¨ počet dnů – počet penalizovaných dnů

¨ měna – měna, ve které je vypočteno penále

¨ částka penále – podle nadefinovaných algoritmů a postupů a na základě výše celkové částky a dnů je vypočtena částka penále

¨ poznámka – libovolná poznámka uživatele

Datový model

  • VMUDA Událost vymáhání
    • SPPRISTU Přístupové právo uživatele k věci
    • ADSPOJ Spojení adresáta
      • ADADSAT Adresát
      • ADADR Adresa
    • BWUZIVAT Uživatel systému
    • OCMENA Měna
    • SPTYP Druh procesu/operace
    • SPPRCOD Operace procesu (alias SPPRCOD2)
      • SPPRC Proces

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Události plateb | Evidence událostí plateb (přijatých a vydaných)
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^S | SUMY - vymáhání |
F2 | Adresář | Přehled adresátů
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Volné texty | Přehled volných textů

    Formulář

    Formulář činnosti - Spojení adresátů
Mřížka [Události vymáhání]
Listovací rámeček
Stránka #1 Vymáhání
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
 | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Upomínka nebo penále
 | Název druhu procesu
Vznik | Datum vzniku události vymáhání
Datum | Datum události vymáhání pohledávky pro spojení s platbou podle kalendáře
Popis | Popis události vymáhání pohledávky
Adresát | Identifikace adresáta
 | Název adresáta
 | Číslo spojení adresáta.
Měna | Kód měny - oceňovací jednotky.
Základní částka | Základní penalizovaná částka
Počet dnů | Počet penalizovaných dnů
Částka penále | Částka penále
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Poznámka | Poznámka k vymáhání
Text | Identifikace textu
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Stránka #2 Platba
 | Pořadové číslo procesu
 | Identifikace datového úložiště číselné řady procesu
 | Rok v identifikaci procesu
 | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Pohledávka/Závazek
Datum | Datum platby
Splatnost | Datum splatnosti
Popis | Popis platby
Adresát | Identifikace adresáta (odesílatel / příjemce)
 | Číslo spojení adresáta.
 | Identifikátor spojení na bankovní účet adresáta.
Úč./pok. | Identifikace účtu/pokladny
 | Název účtu/pokladny
Měna | Kód měny - oceňovací jednotky.
 | Referenční měna
Kurs | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup.
 | Množství oceňovací jednotky v kursu.
KS | Konstantní symbol
VS | Variabilní symbol (příjemce)
 | Částka v zahraniční měně nezaokrouhlená
V ZM | Částka v zahraniční měně
 | Záloha v zahraniční měně
 | Částka v referenční měně nezaokrouhlená
V RM | Částka v referenční měně zaokrouhlená
 | Záloha v referenční měně
Dosud uhrazeno | Dosud uhrazeno (v referenční měně)
Dosud neuhrazeno RM | Dosud neuhrazeno (v referenční měně)
Vymáhání | Identifikace algoritmu vymáhání
Text | Identifikace textu
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Stránka #3 Výběr
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
Číslo procesu do | Pořadové číslo procesu
 | Identifikátor druhu operace
Druh procesu | Identifikátor druhu procesu
Datum | Datum
do | Datum do
Úkon | Zobrazit upomínky nebo penále nebo obojí
Vznik | Datum vzniku události vymáhání
do | Datum vzniku události vymáhání do
Popis | Popis události vymáhání pohledávky
Adresát | Identifikace adresáta
Spojení | Číslo spojení adresáta.
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Měna | Kód měny - oceňovací jednotky.
Text | Identifikace textu
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsal | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Události vymáhání] činnosti - Spojení adresátů

    Mřížka [Události vymáhání] činnosti - Spojení adresátů
Označování | Označení záznamu
Vznik | Datum vzniku události vymáhání
Datum | Datum události vymáhání pohledávky pro spojení s platbou podle kalendáře
Popis | Popis události vymáhání pohledávky
Adresát | Identifikace adresáta
Měna | Kód měny - oceňovací jednotky.
Částka v ZM | Částka v zahraniční měně
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Název adresáta | Název adresáta
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Druh operace | Identifikátor druhu operace
Pořadí | Pořadí stejného druhu operace v jednom procesu
Popis | Popis textu

    Atributy tisku

    Základní údaje
Rok | Rok v identifikaci procesu | VMUDA_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | VMUDA_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | VMUDA_sp33cisd | C(8)
Druh operace | Identifikátor druhu operace | VMUDA_sp07idtyp | C(6)
Komponenta | Identifikace komponenty | VMUDA_sp06idsubs | C(3)
Pořadí | Pořadí stejného druhu operace v jednom procesu | VMUDA_sp33porad | N(2)
Název druhu operace | Název druhu procesu | SPTYP_sp07text | C(30)
Úkon | Upomínka nebo penále | Výpočet | C(8)
Vznik | Datum vzniku události vymáhání | VMUDA_vm02datud | D
Datum | Datum události vymáhání pohledávky pro spojení s platbou podle kalendáře | VMUDA_vm02datum | D
Popis | Popis události vymáhání pohledávky | VMUDA_vm02text | C(40)
Počet penalizovaných dnů | Počet penalizovaných dnů | VMUDA_vm02dnu | N(5)
Základní částka k penalizaci | Základní penalizovaná částka | VMUDA_vm02zaklad | N(20,4)
Identifikace textu | Identifikace textu | VMUDA_sp88id | C(6)
Obsah textu | Obsah textu | SPTEXTYN_sp89obsah | M
Adresát | Identifikace adresáta | VMUDA_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Stát | Identifikace státu. | ADADR_ad05id | C(3)
Název státu | Název státu. | ADSTATY_ad05stat | C(30)
Oficiální název | Oficiální název státu | ADSTATY_ad05nazevo | C(40)
Jméno kontaktní osoby | Jméno kontaktní osoby. | ADSPOJ_ad11jmeno | C(40)
UTO | Národní směrové číslo státu pro telefonní spojení (UTO). | ADSPOJ_ad13nsc | C(4)
Telefon | Telefonní číslo | ADSPOJ_ad11cislo | C(60)
Měna | Kód měny - oceňovací jednotky. | VMUDA_oc01id | C(3)
Název měny | Název měny | OCMENA_oc01nazev | C(18)
Částka v ZM | Částka v zahraniční měně | VMUDA_vm02czm | N(20,4)
Poznámka | Poznámka k vymáhání | VMUDA_vm02koment | M
Obch. sel. | Identifikátor obchodního selektoru | VMUDA_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | VMUDA_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | VMUDA_sp20idzak | C(9)
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Rok | Rok v identifikaci procesu | PLUDA_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | PLUDA_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | PLUDA_sp33cisd | C(8)
Druh operace | Identifikátor druhu operace | PLUDA_sp07idtyp | C(6)
Komponenta | Identifikace komponenty | PLUDA_sp06idsubs | C(3)
Pořadí | Pořadí stejného druhu operace v jednom procesu | PLUDA_sp33porad | N(2)
P/Z | Pohledávka/Závazek | Výpočet | C(10)
Datum | Datum platby | PLUDA_pl02datpla | D
Splatnost | Datum splatnosti | PLUDA_pl02datspl | D
Popis | Popis platby | PLUDA_pl02text | C(40)
Variabilní symbol | Variabilní symbol (příjemce) | PLUDA_pl02vs | C(10)
Konstantní symbol | Konstantní symbol | PLUDA_pl02ks | C(4)
Účet/pokladna | Identifikace účtu/pokladny | PLUDA_pl01id | C(6)
Název účtu | Název účtu/pokladny | PLUP_pl01text | C(40)
Částka v ZM | Částka v zahraniční měně | PLUDA_pl02czm | N(20,4)
Záloha v ZM | Záloha v zahraniční měně | PLUDA_pl02zalzm | N(20,4)
Dosud uhrazeno | Dosud uhrazeno (v referenční měně) | PLUDA_pl02crmu | N(20,4)
Dosud neuhrazeno RM | Dosud neuhrazeno (v referenční měně) | PLUDA_pl02crmnu | N(20,4)
Vymáhání | Identifikace algoritmu vymáhání | PLUDA_vm06id | C(6)
Kód banky | Kód banky | ADBUCTY1_oc02idbank | C(4)
Pobočka | Název pobočky, která vede bankovní účet adresátovi. | ADBUCTY1_ad03poboc | C(25)
Prefix ú. | Prefix bankovního účtu adresáta | ADBUCTY1_ad03pructu | C(6)
Č. účtu | Číslo bankovního účtu adresáta. | ADBUCTY1_ad03ucet | C(34)
Název banky | Název banky | OCBANKA1_oc02nazevb | C(40)
SWIFT | SWIFT kód banky. | OCBANKA1_oc02swift | C(11)
Kód BLZ | BLZ kód banky | OCBANKA1_oc02blz | C(10)
Datum a čas zápisu | Datum a čas zápisu záznamu události | VMUDA_sp00datzap | T

    Viz.také

    Události plateb | OZNAČOVÁNÍ | SUMY - vymáhání | Adresář | Druhy operací | Druhy procesů | Kategorie adresátů | Měny a kursy | Obchodní selektor | Organizační selektor | Spojení adresátů | Technicko-věcný selektor | Volné texty | Parametry výpočtu vymáhání


Algoritmy vymáhání

Popis

Tato činnost umožňuje uživateli nadefinovat, opravovat a rušit algoritmy, které se pak uplatňují při vytváření událostí vymáhání. U každého algoritmu se zadává:

¨ identifikace a název vymáhání

¨ % penále

¨ postup – výběr z číselníku postupů vymáhání

¨ libovolná poznámka

Datový model

  • VMALGOR Algoritmus vymáhání
    • BWUZIVAT Uživatel systému
    • VMPOSTU Postup vymáhání

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Postupy vymáhání | Přehled postupů vymáhání

    Formulář

    Formulář činnosti - Postupy vymáhání
Mřížka [Algoritmy vymáhání]
Vymáhání | Identifikace algoritmu vymáhání
 | Popis algoritmu vymáhání
Penále % | Hodnota penále
Postup | Identifikace postupu vymáhání
 | Název postupu vymáhání
Uživatel | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Poznámka | Poznámka

    Mřížka [Algoritmy vymáhání] činnosti - Postupy vymáhání

    Mřížka [Algoritmy vymáhání] činnosti - Postupy vymáhání
Vymáhání | Identifikace algoritmu vymáhání
Popis | Popis algoritmu vymáhání

    Atributy tisku

    Základní údaje
Vymáhání | Identifikace algoritmu vymáhání | VMALGOR_vm06id | C(6)
Popis | Popis algoritmu vymáhání | VMALGOR_vm06text | C(40)
Poznámka | Poznámka | VMALGOR_vm06koment | M
Penále % | Hodnota penále | VMALGOR_vm06penale | N(8,4)
Postup | Identifikace postupu vymáhání | VMALGOR_vm04id | C(6)
Název postupu | Název postupu vymáhání | VMPOSTU_vm04text | C(40)
Uživatel | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | VMALGOR_sp00datzap | T

    Viz.také

    Postupy vymáhání


Postupy vymáhání

Popis

Tato činnost umožňuje uživateli definovat jednotlivé postupy vymáhání, které se pak využijí při definici algoritmu vymáhání a následně při plnění událostí vymáhání. U každého postupu se definují údaje na dvou záložkách. První záložka „postupy vymáhání“ slouží pro definici hlavičky, tzn. zadává se identifikace a název postupu.

Teprve na druhé záložce „dny v postupu vymáhání“ se definují konkrétní údaje k danému postupu. Jsou to:

¨ den v postupu vymáhání od data splatnosti – např. definice, že 30-tý den od data splatnosti se posílá první upomínka, 60-tý den od data splatnosti druhá upomínka a 100-tý den od data splatnosti se již počítá penále

¨ úkon – definice úkonu, který je spojen s počtem dnů, např. 30 dnů – upomínka, 60 dnů – upomínka, 100 dnů – penalizace

¨ změna penále – příznak zda změnit hodnotu procenta penále o ....... % - např. můžeme mít nastavenu penalizaci po 100 a 150 dnech od data splatnosti, pokud však počet dnů od data splatnosti přesáhne hodnotu 200, změní se procento penále o tolik a tolik procent

¨ hodnota o kterou chci zvýšit původní procento penále

¨ text – výběr z číselníku nadefinovaných textů k daným úkonům

Datový model

  • VMPOSTU Postup vymáhání
    • BWUZIVAT Uživatel systému

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Postupy vymáhání | Přehled postupů vymáhání
F2 | Volné texty | Přehled volných textů

    Formulář

    Formulář činnosti - Volné texty
Mřížka [Postupy vymáhání]
Listovací rámeček
Stránka #1 Postupy vymáhání
Postup | Identifikace postupu vymáhání
 | Název postupu vymáhání
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Poznámka | Poznámka postupu vymáhání
Stránka #2 Dny v postupu vymáhání
Mřížka [Dny v postupu vymáhání]
Den | Den v postupu vymáhání od data splatnosti
Úkon | Úkon v postupu vymáhání - žádný, penalizace, upomínka
Změna penále | Změnit hodnotu procent penále o % ?
 | Hodnota změny penále
Text | Identifikace textu
Povolit přeskočení úkonu | Povolit přeskočit tento řádek, pokud v postupu vymáhání došlo ke skluzu.
Poznámka | Poznámka

    Mřížka [Postupy vymáhání] činnosti - Volné texty

    Mřížka [Postupy vymáhání] činnosti - Volné texty
Postup | Identifikace postupu vymáhání
Název postupu | Název postupu vymáhání

    Mřížka [Dny v postupu vymáhání] činnosti - Volné texty

    Mřížka [Dny v postupu vymáhání] činnosti - Volné texty
Postup | Identifikace postupu vymáhání
Den | Den v postupu vymáhání od data splatnosti
Úkon | Úkon v postupu vymáhání - žádný, penalizace, upomínka
Přeskočení | Povolit přeskočit tento řádek, pokud v postupu vymáhání došlo ke skluzu.
Změna penále | Změnit hodnotu procent penále o % ?
Hodnota změny penále | Hodnota změny penále
Text | Identifikace textu

    Atributy tisku

    Základní údaje
Postup | Identifikace postupu vymáhání | VMPOSTU_vm04id | C(6)
Název postupu | Název postupu vymáhání | VMPOSTU_vm04text | C(40)
Poznámka | Poznámka postupu vymáhání | VMPOSTU_vm04koment | M
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | VMPOSTU_sp00datzap | T

    Při pohybu v Dny v postupu vymáhání
Postup | Identifikace postupu vymáhání | VMPOSTUB_vm04id | C(6)
Den | Den v postupu vymáhání od data splatnosti | VMPOSTUB_vm05den | N(4)
Úkon | Úkon v postupu vymáhání - žádný, penalizace, upomínka | Výpočet | C(10)
Změna penále | Změnit hodnotu procent penále o % ? | Výpočet | C(3)
Hodnota změny penále | Hodnota změny penále | VMPOSTUB_vm05plusp | N(8,4)
Poznámka | Poznámka | VMPOSTUB_vm05koment | M
Text | Identifikace textu | VMPOSTUB_sp88id | C(6)

    Viz.také

    Volné texty


Umístění plateb

Popis

Jedná se o rozdělení umístění plateb podobné jako v činnosti obchod, tzn. že je možno události plateb pak filtrovat podle jednotlivých umístění, např. obchodní centrum, výrobní úsek, různá střediska apod. U každého umístění se eviduje jeho identifikace, název, příslušný adresát a organizační selektor. Ke každému umístění je možno nadefinovat přístupová práva, což pak způsobí, že uživatel vidí události pouze toho umístění, ke kterému má nadefinováno přístupové právo (min. čtení).

Datový model

  • PLUMIST Umístění plateb
    • ADADSAT Adresát
    • ADSPOJ Spojení adresáta
      • ADADR Adresa
    • SPSEOR Organizační selektor
    • SPPRISTU Přístupové právo uživatele k věci

    • Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci
F2 | Adresář | Přehled adresátů
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Spojení adresátů | Přehled spojení adresátů

    Formulář

    Formulář činnosti - Kategorie adresátů
Mřížka [Umístění plateb]
Umístění - platby | Umístění - platby
Název umístění | Název umístění - platby
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
 | Jméno kontaktní osoby.
 | Telefonní číslo
 | Ulice adresy adresáta (včetně čísla popisného).
 | Ulice bytu adresáta (včetně čísla popisného)
 | Poštovní směrovací číslo adresy adresáta.
 | Město adresy adresáta.
Org. sel. | Identifikátor organizačního selektoru.
 | Název organizačního selektoru

    Mřížka [Umístění plateb] činnosti - Kategorie adresátů

    Mřížka [Umístění plateb] činnosti - Kategorie adresátů
Umístění - platby | Umístění - platby
Název umístění | Název umístění - platby
Org. sel. | Identifikátor organizačního selektoru.
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Jméno kontaktní osoby | Jméno kontaktní osoby.
Telefon | Telefonní číslo
Ulice | Ulice adresy adresáta (včetně čísla popisného).
Byt | Ulice bytu adresáta (včetně čísla popisného)
PSČ | Poštovní směrovací číslo adresy adresáta.
Město | Město adresy adresáta.

    Atributy tisku

    Základní údaje
Umístění - platby | Umístění - platby | PLUMIST_pl08id | C(6)
Název umístění | Název umístění - platby | PLUMIST_pl08text | C(40)
Org. sel. | Identifikátor organizačního selektoru. | PLUMIST_sp11idzak | C(9)
Název organizačního selektoru | Název organizačního selektoru | SPSEOR_sp11text | C(60)
Adresát | Identifikace adresáta | PLUMIST_ad01id | C(6)
Spojení | Číslo spojení adresáta. | PLUMIST_ad11cisspo | C(2)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Úplný název adresáta | Úplný název adresáta | ADADSAT_ad01adsat2 | M
Telefon | Telefonní číslo | ADSPOJ_ad11cislo | C(60)
Jméno | Jméno kontaktní osoby. | ADSPOJ_ad11jmeno | C(40)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
Byt | Ulice bytu adresáta (včetně čísla popisného) | ADADR_ad02byt | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)

    Viz.také

    Přístupová práva | Adresář | Kategorie adresátů | Organizační selektor | Spojení adresátů


ZÁLOHY

Popis

Komponenta zálohy se využívá ke správě a evidenci poskytnutých a přijatých finančních záloh, tj. v podstatě úhrada (přijetí nebo poskytnutí) zálohy a její vyúčtování.

Viz.také

Události o zálohách | Aktuální hodnoty záloh | Přehled záloh | Umístění záloh


Události o zálohách

Popis

Podle nastaveného filtru na záložce Výběr má uživatel k dispozici údaje týkající se přijatých nebo poskytnutých záloh. Jednotlivé události záloh se vstupují procesně, tzn. není zde aktivní ikona pro vstup nového záznamu. Černě zobrazené události záloh jsou již vyúčtované, modře zobrazené události záloh jsou ještě nevyúčtované. U každé události zálohy jsou k dispozici tyto informace:

¨ identifikace a číslo operace

¨ charakter události – úhrada / vyúčtování

¨ záloha – přijatá / poskytnutá

¨ datum události

¨ adresát události

¨ umístění záloh

¨ měna

¨ částky v ZM a RM

¨ případný kurzový rozdíl

¨ výše částky v měně účtu a měna

¨ částka, která zbývá vyúčtovat

Na příslušných záložkách „spojená vyúčtování zálohy“ a „spojené úhrady zálohy“ jsou k dispozici další údaje související s danou zálohou. Po stisku F9 je možno vyvolat příslušnou událost vyúčtování nebo úhrady.

Datový model

  • ZAUDAL Událost o záloze
    • SPPRCOD Operace procesu
      • SPTYP Druh procesu/operace
      • SPPRC Proces
    • ADSPOJ Spojení adresáta
      • ADADSAT Adresát
      • ADADR Adresa
    • ZAUMISTE Umístění zálohy
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)
    • BWUZIVAT Uživatel systému
    • SPPRISTU Přístupové právo uživatele k věci

    • Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^S | SUMy - zálohy |
- | INFORMACE O ZÁLOHÁCH | Informace o zálohách
F2 | Adresář | Přehled adresátů
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Přehled záloh | Přehled záloh
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Umístění záloh | Umístění záloh

    Formulář

    Formulář činnosti - Parametry operací ZAL
Mřížka [Události o zálohách]
Listovací rámeček
Stránka #1 Události o zálohách
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Charakter | Charakter události úhrada/vyúčtování zálohy
P/P | Záloha přijatá/poskytnutá
 | Název druhu operace
Datum | Datum události
Popis | Popis události
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
Záloha | Identifikace zálohy
Umístění | Identifikace umístění zálohy
Název umístění | Název umístění zálohy
Měna | Kód měny - oceňovací jednotky.
 | Referenční měna
Kurs | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup.
Množství | Množství oceňovací jednotky v kursu.
Částka v ZM | Částka v zahraniční měně
Částka v RM | Částka v referenční měně
 | Kód měny úhrady zálohy
Částka v MÚ | Částka v měně úhrady zálohy
Kurzový rozdíl | Kurzový rozdíl
Zbývá vyúčtovat | Dosud nevyúčtovaná část zálohy
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Selektory | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Poznámka | Poznámka
Stránka #2 Spojená vyúčtování zálohy
Mřížka [Spojená vyúčtování zálohy]
Stránka #3 Spojené úhrady zálohy
Mřížka [Spojené úhrady zálohy]
Stránka #4 Výběr
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu od | Pořadové číslo procesu
do | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Proces | Identifikátor druhu procesu
Datum | Datum události
do | Datum události do
Popis | Popis události
Charakter | Charakter události úhrada/vyúčtování zálohy
P/P | Záloha přijatá/poskytnutá
Zobrazit | Zobrazit všechny/nevyúčtované/vyúčtované
Záloha | Identifikace zálohy
Adresát | Identifikace adresáta
Spojení | Číslo spojení adresáta.
Název adresáta | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Umístění | Identifikace umístění zálohy
Měna | Kód měny - oceňovací jednotky.
 | Kód měny - oceňovací jednotky.
Selektory | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
Zapsané | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Události o zálohách] činnosti - Parametry operací ZAL

    Mřížka [Události o zálohách] činnosti - Parametry operací ZAL
Označování | Označení záznamu
Datum | Datum události
Char. | Charakter události úhrada/vyúčtování zálohy
P/P | Záloha přijatá/poskytnutá
Adresát | Identifikace adresáta
Záloha | Identifikace zálohy
Měna | Kód měny - oceňovací jednotky.
Částka v MÚ | Částka v měně úhrady zálohy
Zbývá vyúčtovat | Dosud nevyúčtovaná část zálohy
Název adresáta | Název adresáta
Popis | Popis události
Měna | Kód měny - oceňovací jednotky.
Částka v ZM | Částka v zahraniční měně
Částka v RM | Částka v referenční měně
Kurzový rozdíl | Kurzový rozdíl
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace

    Mřížka [Spojená vyúčtování zálohy] činnosti - Parametry operací ZAL

    Mřížka [Spojená vyúčtování zálohy] činnosti - Parametry operací ZAL
Datum | Datum události
Měna | Kód měny - oceňovací jednotky.
Spojená částka | Částka v měně úhrady zálohy
Částka v MÚ | Částka v měně úhrady zálohy
Měna | Kód měny - oceňovací jednotky.
Částka v ZM | Částka v zahraniční měně
Částka v RM | Částka v referenční měně
Kurzový rozdíl | Kurzový rozdíl
Popis | Popis události
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Adresát | Identifikace adresáta
Záloha | Identifikace zálohy

    Mřížka [Spojené úhrady zálohy] činnosti - Parametry operací ZAL

    Mřížka [Spojené úhrady zálohy] činnosti - Parametry operací ZAL
Datum | Datum události
Měna | Kód měny - oceňovací jednotky.
Spojená částka | Částka v měně úhrady zálohy
Částka v MÚ | Částka v měně úhrady zálohy
Zbývá vyúčtovat | Dosud nevyúčtovaná část zálohy
Měna | Kód měny - oceňovací jednotky.
Částka v ZM | Částka v zahraniční měně
Částka v RM | Částka v referenční měně
Popis | Popis události
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Adresát | Identifikace adresáta
Záloha | Identifikace zálohy

    Atributy tisku

    Základní údaje
Rok | Rok v identifikaci procesu | ZAUDAL_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | ZAUDAL_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | ZAUDAL_sp33cisd | C(8)
Pořadí druhu operace | Pořadí stejného druhu operace v jednom procesu | ZAUDAL_sp33porad | N(2)
Operace | Identifikátor druhu operace | ZAUDAL_sp07idtyp | C(6)
Název druhu operace | Název druhu procesu | SPTYP_sp07text | C(30)
Charakter | Charakter události úhrada/vyúčtování zálohy | Výpočet | C(10)
P/P | Záloha přijatá/poskytnutá | Výpočet | C(5)
Datum | Datum události | ZAUDAL_za02datum | D
Popis | Popis události | ZAUDAL_za02text | C(40)
Záloha | Identifikace zálohy | ZAUDAL_za02id | C(32)
Adresát | Identifikace adresáta | ZAUDAL_ad01id | C(6)
Spojení | Číslo spojení adresáta. | ZAUDAL_ad11cisspo | C(2)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Úplný název adresáta | Úplný název adresáta | ADADSAT_ad01adsat2 | M
UTO | Národní směrové číslo státu pro telefonní spojení (UTO). | ADSPOJ_ad13nsc | C(4)
Volané telefonní číslo | Telefonní číslo | ADSPOJ_ad11cislo | C(60)
Implicitní spojení | Jméno kontaktní osoby. | ADSPOJ_ad11jmeno | C(40)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)
Stát | Identifikace státu. | ADADR_ad05id | C(3)
Umístění | Identifikace umístění zálohy | ZAUDAL_za04id | C(6)
Název umístění | Název umístění zálohy | ZAUMISTE_za04text | C(40)
Měna | Kód měny - oceňovací jednotky. | ZAUDAL_oc01id | C(3)
Kurs | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup. | ZAUDAL_oc03kurz | N(20,6)
Množství | Množství oceňovací jednotky v kursu. | ZAUDAL_oc03mn | N(5)
Částka v ZM | Částka v zahraniční měně | ZAUDAL_za02czm | N(20,4)
Částka v RM | Částka v referenční měně | ZAUDAL_za02crm | N(20,4)
Zbývá vyúčtovat | Dosud nevyúčtovaná část zálohy | ZAUDAL_za02cumnv | N(20,4)
Kurzový rozdíl | Kurzový rozdíl | ZAUDAL_za02kuroz | N(20,4)
Měna úhrady zálohy | Kód měny - oceňovací jednotky. | ZAUDAL_oc01id2 | C(3)
Částka v MÚ | Částka v měně úhrady zálohy | ZAUDAL_za02cum | N(20,4)
Obch. sel. | Identifikátor obchodního selektoru | ZAUDAL_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | ZAUDAL_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | ZAUDAL_sp20idzak | C(9)
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | ZAUDAL_sp00datzap | T
Poznámka | Poznámka | ZAUDAL_za02koment | M

    Viz.také

    OZNAČOVÁNÍ | SUMy - zálohy | INFORMACE O ZÁLOHÁCH | Adresář | Druhy operací | Druhy procesů | Kategorie adresátů | Měny a kursy | Obchodní selektor | Organizační selektor | Přehled záloh | Spojení adresátů | Technicko-věcný selektor | Umístění záloh | Parametry operací ZAL


Aktuální hodnoty záloh

Popis

Zobrazení informací v činnosti „aktuální hodnoty záloh“ plně záleží na tom, jakým způsobem je nastaven filtr na záložce Výběr. Je možno vybírat podle druhu hodnoty, podle adresáta a podle měny. Podle nastaveného výběru pak uživatel vidí určitý druh záloh, adresáta, kterého se týká, měnu, umístění a hodnotu zálohy.

Datový model

  • ZAAH Aktuální hodnota záloh
    • ADADSAT Adresát
    • OCMENA Měna
    • SPSTATDI Druh hodnoty
    • ZAUMISTE Umístění zálohy
      • SPPRISTU Přístupové právo uživatele k věci

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresář | Přehled adresátů
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Umístění záloh | Umístění záloh

    Formulář

    Formulář činnosti - Kategorie adresátů
Mřížka [Aktuální hodnoty záloh]
Listovací rámeček
Stránka #1 Aktuální hodnoty záloh
Druh | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Adresát | Identifikace adresáta
 | Název adresáta
Měna | Kód měny - oceňovací jednotky.
 | Název měny
Umístění | Identifikace umístění zálohy
Název umístění | Název umístění zálohy
Hodnota | Aktuální hodnota změny stavu záloh
Stránka #2 Výběr
Druh hodnoty | Identifikace druhu hodnoty
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Měna | Kód měny - oceňovací jednotky.
Umístění | Identifikace umístění zálohy
Název umístění | Název umístění zálohy
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Aktuální hodnoty záloh] činnosti - Kategorie adresátů

    Mřížka [Aktuální hodnoty záloh] činnosti - Kategorie adresátů
Druh | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Adresát | Identifikace adresáta
Měna | Kód měny - oceňovací jednotky.
Umístění | Identifikace umístění zálohy
Název umístění | Název umístění zálohy
Hodnota | Aktuální hodnota změny stavu záloh
Název adresáta | Název adresáta

    Atributy tisku

    Základní údaje
Druh hodnoty | Identifikace druhu hodnoty | ZAAH_sp67id | C(3)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)
Adresát | Identifikace adresáta | ZAAH_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Umístění | Identifikace umístění zálohy | ZAAH_za04id | C(6)
Název umístění | Název umístění zálohy | ZAUMISTE_za04text | C(40)
Měna | Kód měny - oceňovací jednotky. | ZAAH_oc01id2 | C(3)
Název měny | Název měny | OCMENA_oc01nazev | C(18)
Hodnota | Aktuální hodnota změny stavu záloh | ZAAH_za02hodnot | N(20,4)

    Viz.také

    Adresář | Druhy hodnot | Kategorie adresátů | Měny a kursy | Umístění záloh


Přehled záloh

Popis

Uživatel má podle nastaveného filtru na záložce Výběr (např. přijaté/poskytnuté, vyúčtované/nevyúčtované, za adresáta nebo určitou měnu) k dispozici přehled záloh. Na první záložce „přehled záloh“ je k dispozici hlavička zálohy, tzn. informace o adresátovi, kterého se týká, zda se jedná o zálohu přijatou nebo poskytnutou, v jaké výši a v jaké měně. Jednoznačnými údaji v přehledu záloh je adresát a číslo (identifikace) zálohy. Podle těchto údajů se ke každé záloze vztahují jednotlivé úhrady a vyúčtování, tzn. mezi zálohou, úhradou a vyúčtováním není vztah 1:1, ale uživatel může mít zálohu, k ní např. 5 úhrad a následně 3 vyúčtování. Přes adresáta a identifikaci zálohy jsou však tyto údaje sumovány a zobrazeny na první záložce „přehled záloh“ v atributech „částka v MÚ“ a „zbývá vyúčtovat“. Modře jsou zobrazeny dosud nevyúčtované zálohy, černě zobrazené zálohy jsou vyúčtované.

Záložka „úhrady zálohy“ poskytuje uživateli informaci, jakou událostí, kdy, v jaké výši byla záloha uhrazena, případně kolik ještě zbývá uhradit. Po stisku klávesy F9 je možno přímo aktivovat operaci úhrady.

Záložka „vyúčtování zálohy“ poskytuje uživateli informaci, kdy (datum) proběhlo vyúčtování zálohy, v jaké hodnotě měny účtu, případně i v jaké hodnotě zahraniční měny a je vyčíslen případný kurzový rozdíl. Po stisku klávesy F9 je možno přímo aktivovat operaci vyúčtování.

Datový model

  • ZAKARTA Karta zálohy
    • ADADSAT Adresát

    • Vyvolávané činnosti

    K. | Činnost | Popis
F7 | Diagram procesu | Zobrazení diagramu procesu
F9 | Spustit operaci | Spuštění zobrazené operace
^S | SUMy - Přehled záloh |
- | INFORMACE O ZÁLOHÁCH | Informace o zálohách
F2 | Adresář | Přehled adresátů
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Měny a kursy | Číselník měn včetně jejich kursů

    Formulář

    Formulář činnosti - INFORMACE O ZÁLOHÁCH
Mřížka [Přehled záloh]
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Měna | Kód měny - oceňovací jednotky.
P/P | Záloha přijatá/poskytnutá
Záloha | Identifikace zálohy
Listovací rámeček
Stránka #1 Přehled záloh
Částka v MÚ | Částka v měně úhrady zálohy
Zbývá vyúčtovat | Dosud nevyúčtovaná část zálohy
Stránka #2 Úhrady zálohy
Mřížka [Úhrady zálohy]
Rok | Rok v identifikaci procesu
Proces | Pořadové číslo procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Operace | Identifikátor druhu operace
Umístění | Identifikace umístění zálohy
Datum | Datum události
Popis | Popis události
 | Kód měny - oceňovací jednotky.
Částka v MÚ | Částka v měně úhrady zálohy
Zbývá vyúčtovat | Dosud nevyúčtovaná část zálohy
Měna | Kód měny - oceňovací jednotky.
Částka v ZM | Částka v zahraniční měně
Částka v RM | Částka v referenční měně
Stránka #3 Vyúčtování zálohy
Mřížka [Vyúčtování zálohy]
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Umístění | Identifikace umístění zálohy
Datum | Datum události
Popis | Popis události
 | Kód měny - oceňovací jednotky.
Částka v MÚ | Částka v měně úhrady zálohy
Měna | Kód měny - oceňovací jednotky.
Částka v ZM | Částka v zahraniční měně
Částka v RM | Částka v referenční měně
Kurzový rozdíl | Kurzový rozdíl
Stránka #4 Výběr
P/P | Záloha přijatá/poskytnutá
Zobrazit | Zobrazit všechny/nevyúčtované/vyúčtované
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Záloha | Identifikace zálohy
Měna | Kód měny - oceňovací jednotky.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Přehled záloh] činnosti - INFORMACE O ZÁLOHÁCH

    Mřížka [Přehled záloh] činnosti - INFORMACE O ZÁLOHÁCH
P/P | Záloha přijatá/poskytnutá
Adresát | Identifikace adresáta
Měna | Kód měny - oceňovací jednotky.
Záloha | Identifikace zálohy
Zbývá vyúčtovat | Dosud nevyúčtovaná část zálohy
Částka v MÚ | Částka v měně úhrady zálohy
Název adresáta | Název adresáta

    Mřížka [Úhrady zálohy] činnosti - INFORMACE O ZÁLOHÁCH

    Mřížka [Úhrady zálohy] činnosti - INFORMACE O ZÁLOHÁCH
Datum | Datum události
Částka v MÚ | Částka v měně úhrady zálohy
Zbývá vyúčtovat | Dosud nevyúčtovaná část zálohy
Měna | Kód měny - oceňovací jednotky.
Částka v ZM | Částka v zahraniční měně
Částka v RM | Částka v referenční měně
Popis | Popis události
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Umístění | Identifikace umístění zálohy
Název umístění | Název umístění zálohy

    Mřížka [Vyúčtování zálohy] činnosti - INFORMACE O ZÁLOHÁCH

    Mřížka [Vyúčtování zálohy] činnosti - INFORMACE O ZÁLOHÁCH
Datum | Datum události
Částka v MÚ | Částka v měně úhrady zálohy
Měna | Kód měny - oceňovací jednotky.
Částka v ZM | Částka v zahraniční měně
Částka v RM | Částka v referenční měně
Kurzový rozdíl | Kurzový rozdíl
Popis | Popis události
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Umístění | Identifikace umístění zálohy
Název umístění | Název umístění zálohy

    Atributy tisku

    Základní údaje
P/P | Záloha přijatá/poskytnutá | Výpočet | C(5)
Záloha | Identifikace zálohy | ZAKARTA_za02id | C(32)
Adresát | Identifikace adresáta | ZAKARTA_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Měna | Kód měny - oceňovací jednotky. | ZAKARTA_oc01id2 | C(3)
Částka v MÚ | Částka v měně úhrady zálohy | ZAKARTA_za02cum | N(20,4)
Zbývá vyúčtovat | Dosud nevyúčtovaná část zálohy | ZAKARTA_za02cumnv | N(20,4)

    Viz.také

    Diagram procesu | Spustit operaci | SUMy - Přehled záloh | INFORMACE O ZÁLOHÁCH | Adresář | Kategorie adresátů | Měny a kursy


Umístění záloh

Popis

Tato činnost poskytuje uživateli přehled nadefinovaných umístění záloh. U každého umístění se definuje identifikace, název a případný organizační selektor. Ke každému umístění lze nadefinovat pro uživatele přístupová práva.

Datový model

  • ZAUMISTE Umístění zálohy
    • SPSEOR Organizační selektor
    • SPPRISTU Přístupové právo uživatele k věci

    • Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci
F2 | Organizační selektor | Číselník organizačních selektorů

    Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Umístění]
Umístění | Identifikace umístění zálohy
Název umístění | Název umístění zálohy
Org. sel. | Identifikátor organizačního selektoru.
Název organizačního selektoru | Název organizačního selektoru
Poznámka | Poznámka

    Mřížka [Umístění] činnosti - Přístupová práva

    Mřížka [Umístění] činnosti - Přístupová práva
Umístění | Identifikace umístění zálohy
Název umístění | Název umístění zálohy
Org. sel. | Identifikátor organizačního selektoru.

    Atributy tisku

    Základní údaje
Umístění | Identifikace umístění zálohy | ZAUMISTE_za04id | C(6)
Název umístění | Název umístění zálohy | ZAUMISTE_za04text | C(40)
Poznámka | Poznámka | ZAUMISTE_za04koment | M
Org. sel. | Identifikátor organizačního selektoru. | ZAUMISTE_sp11idzak | C(9)
Název organizačního selektoru | Název organizačního selektoru | SPSEOR_sp11text | C(60)

    Viz.také

    Přístupová práva | Organizační selektor


SKLAD

Popis

Slouží k evidenci skladovaného artiklu a sledování pohybu tohoto artiklu v rámci příjmu, výdeje či převodu (týkající se skladu). Kromě množství artiklu na skladech má uživatel k dispozici možnost sledovat obraty artiklu i druhy hodnot artiklu.

Viz.také

Událost skladové evidence | Aktuální hodnoty skladu | Množství artiklu na skladech | Obraty skladu | Obraty skladu - VČ | Artikly skladu | Artikly skladu - VČ | Sklady | Základní druhy hodnot


Událost skladové evidence

Popis

Po spuštění této činnosti se zobrazují události skladové evidence, které jsou vždy součástí určitého procesu, tzn., že události do této činnosti lze zařazovat pouze procesně, není možno je zde vkládat samostatně. Formulář poskytuje uživateli k dispozici značné množství informací (např. datum, popis, adresáta, artikl, sklad, množství, cenu, ...), které není třeba podrobně popisovat (význam vyplývá z názvu atributů). Podrobněji si vysvětlíme pouze položku "ocenění" a pak jednotlivé záložky na obrazovce.

Oceňování na událostech, a to zatím u skladové evidence, může mít atribut konečné a předběžné. Možnost "konečné" uživatel použije v případě, že např. při příjmu nebo výdeji artiklu ze skladu zná přesnou a konečnou cenu artiklu, a to v případě, ať oceňuje metodou FIFO nebo metodou váženého průměru.

Pokud uživateli není cena artiklu při příjmu nebo výdeji dosud známa, vybere u této události v položce ocenění možnost "předběžné". Diagram procesu pak v tomto případě vypadá následovně. Proces bude začínat událostí "příjem", která však bude předběžná, protože neznáme přesnou cenu příjmu. A v tuto chvíli proces pokračuje dvěma směry:

¨ je nutno zaúčtovat příjem - pro tyto případy, kdy je první operace v procesu ukončena předběžně, je vhodné v diagramu procesu u operace zaúčtování (ve vlastnostech) zaškrtnout příznak „spouštět po nepředběžném ukončení předchozích operací“, tzn., že byl-li příjem nebo výdej ukončen předběžně, nebude ani zahájena další operace účtování. Teprve až bude původní operace ukončena, tedy příznak předběžná se změní na konečná, spustí systém operaci zaúčtování.

¨ pokračují další operace v procesu - ostatní operace v procesu probíhají podle nastaveného diagramu procesu. Pokud je však diagram procesu nastaven tak, že z předběžného příjmu se rovnou i vybraný artikl vydává, získává operace výdej rovněž příznak předběžná.

Další záložky na událostech skladové evidence souvisí s metodou oceňování FIFO (FIFO - příjem, FIFO - výdej) a poslední záložka poskytuje uživateli informaci o tom, jak byla událost skladové evidence zaúčtována (po stisku klávesy F9 je možno operaci zaúčtování aktivovat).

Datový model

  • MTUDA Událost skladu
    • SPPRISTU Přístupové právo uživatele k věci
    • MTARTIKL Skladovaný artikl
    • ADSPOJ Spojení adresáta
      • ADADR Adresa
      • ADADSAT Adresát
    • BWUZIVAT Uživatel systému
    • SPPRCOD Operace procesu
      • SPTYP Druh procesu/operace
      • SPPRC Proces
    • MTSKL Sklad
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Konečné ocenění | Nastavení konečného ocenění
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
^S | Celkem - sklad |
F2 | Adresář | Přehled adresátů
F2 | Artikly skladu | Seznam skladovaných artiklů
F2 | Artikly skladu - VČ | Artikly skladu s výrobním číslem
F2 | Buňky |
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Množství artiklu na skladech | Množství artiklu na skladech a buňkách
F2 | Měrné jednotky | Číselník měrných jednotek
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Sklady | Seznam skladů
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

    Formulář činnosti - Spojení adresátů
Mřížka [Události skl. art.]
Listovací rámeček
Stránka #1 Události skl. art.
 | Identifikátor druhu operace
 | Pořadové číslo procesu
 | Identifikace datového úložiště číselné řady procesu
 | Rok v identifikaci procesu
 | Pořadí stejného druhu operace v jednom procesu
 | Příznak příjem / výdej
 | Název druhu procesu
Datum | Datum události skladové evidence
Ocenění | Ocenění - konečné/předběžné
Popis | Popis události skladové evidence
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
ČK | Kód automatické identifikace
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Sklad | Identifikace umístění skladové evidence
 | Identifikace skladové buňky
Vztah k účetnictví | Vztah k účetnictví - zboží, materiál, výrobek, služba ...
VČ | Výrobní číslo
Množství | Množství artiklu - příjem
 | Identifikátor měrné jednotky
MJ | Identifikátor měrné jednotky
Cena za MJ | Cena za jednotku (cena skladová)
Množství v RMJ | Množství artiklu v referenční měrné jednotce - příjem
Cena za RMJ | Cena za jednotku (cena skladová) v referenční měrné jednotce
Celkem | Cena celkem - příjem
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Pořadí | Pořadí události v operaci
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 FIFO - příjem
Mřížka [FIFO - příjem]
Stránka #3 FIFO - výdej
Mřížka [FIFO - výdej]
Stránka #4 Účetnictví
Mřížka [Účetnictví]
Stránka #5 Výběr
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu od
Číslo procesu do | Pořadové číslo procesu do
 | Identifikátor druhu operace
Druh procesu | Identifikátor druhu procesu
Datum | Datum
do | Datum do
 | Události příjmu,výdeje nebo obojí
Popis | Popis události skladové evidence
Ocenění | Zobrazit ocenění - konečné/předběžné/obojí
Vztah k účetnictví | Vztah k účetnictví - zboží, materiál, výrobek, služba ...
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
Adresát | Identifikace adresáta
Spojení | Číslo spojení adresáta.
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
VČ | Výrobní číslo
ČK | Kód automatické identifikace
Sklad | Identifikace umístění skladové evidence
MJ | Identifikátor měrné jednotky
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Účet.sel. | Účetní selektor artiklu
Zapsal | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Události skl. art.] činnosti - Spojení adresátů

    Mřížka [Události skl. art.] činnosti - Spojení adresátů
Označování | Označení záznamu
P/V | Příznak příjem / výdej
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Datum | Datum události skladové evidence
Popis | Popis události skladové evidence
Množství | Množství artiklu - příjem
Množství v RMJ | Množství artiklu v referenční měrné jednotce - příjem
MJ | Identifikátor měrné jednotky
Sklad | Identifikace umístění skladové evidence
Buňka | Identifikace skladové buňky
Cena za MJ | Cena za jednotku (cena skladová)
Celkem | Cena celkem - příjem
Cena za RMJ | Cena za jednotku (cena skladová) v referenční měrné jednotce
VČ | Výrobní číslo
Čarový kód | Kód automatické identifikace
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Název artiklu | Název artiklu
Referenční identifikace | Referenční identifikace operace
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
Množství FIFO | Množství artiklu v referenční měrné jednotce - pro FIFO

    Mřížka [FIFO - příjem] činnosti - Spojení adresátů

    Mřížka [FIFO - příjem] činnosti - Spojení adresátů
Datum | Datum události skladové evidence
Sklad | Identifikace umístění skladové evidence
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Cena za RMJ | Cena za jednotku (cena skladová) v referenční měrné jednotce
Množství | Množství artiklu - FIFO
Ocenění | Ocenění - konečné/předběžné
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh operace | Identifikátor druhu operace
Pořadí | Pořadí stejného druhu operace v jednom procesu

    Mřížka [FIFO - výdej] činnosti - Spojení adresátů

    Mřížka [FIFO - výdej] činnosti - Spojení adresátů
Datum | Datum události skladové evidence
Sklad | Identifikace umístění skladové evidence
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Cena za RMJ | Cena za jednotku (cena skladová) v referenční měrné jednotce
Množství | Množství artiklu - FIFO
Ocenění | Ocenění - konečné/předběžné
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh operace | Identifikátor druhu operace
Pořadí | Pořadí stejného druhu operace v jednom procesu

    Mřížka [Účetnictví] činnosti - Spojení adresátů

    Mřížka [Účetnictví] činnosti - Spojení adresátů
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Datum | Datum účetního případu
Účet | Identifikátor účtu účetnictví
Strana | Strana účtu MD/Dal
Částka | Finanční částka
Popis události | Popis účetní události
Částka ZM | Částka v zahraniční měně
IDP | Identifikace párování
Org. sel. | Identifikátor organizačního selektoru.

    Atributy tisku

    Základní údaje
Číslo procesu | Pořadové číslo procesu | MTUDA_sp33cisd | C(8)
IDÚ | Identifikace datového úložiště číselné řady procesu | MTUDA_sp33cisdpm | C(2)
Rok | Rok v identifikaci procesu | MTUDA_sp33cisdr | C(4)
Druh operace | Identifikátor druhu operace | MTUDA_sp07idtyp | C(6)
Pořadí druhu operace | Pořadí stejného druhu operace v jednom procesu | MTUDA_sp33porad | N(2)
Datum | Datum události skladové evidence | MTUDA_mt02dat | D
Příjem / výdej | Příznak příjem / výdej | Výpočet | C(6)
Popis | Popis události skladové evidence | MTUDA_mt02text | C(40)
Sklad | Identifikace umístění skladové evidence | MTUDA_mt04id | C(6)
Buňka | Identifikace skladové buňky | MTUDA_mt05id | C(9)
Měrná jednotka | Identifikátor měrné jednotky | MTUDA_sp24idmj | C(3)
Množství | Množství artiklu - příjem | MTUDA_mt02mn | N(20,4)
Cena za MJ | Cena za jednotku (cena skladová) | MTUDA_mt02cj | N(20,4)
Měrná jednotka - referenční | Identifikátor měrné jednotky | MTUDA_sp24idmj1 | C(3)
Množství v RMJ | Množství artiklu v referenční měrné jednotce - příjem | MTUDA_mt02mnr | N(20,4)
Cena za RMJ | Cena za jednotku (cena skladová) v referenční měrné jednotce | MTUDA_mt02cjr | N(20,4)
Celkem | Cena celkem - příjem | MTUDA_mt02cc | N(20,4)
Pozn. | Komentář - poznámka k artiklu | MTARTIKL_mt01koment | M
Název | Název skladu | MTSKL_mt04text | C(40)
Vlastní adresa | Název adresáta | ADADSATVL_ad01adsat | C(100)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADRVL_ad02ulice | C(40)
Město | Město adresy adresáta. | ADADRVL_ad02mesto | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADRVL_ad13psc | C(10)
UTO | Národní směrové číslo státu pro telefonní spojení (UTO). | ADSPOJVL_ad13nsc | C(4)
Volané telefonní číslo | Telefonní číslo | ADSPOJVL_ad11cislo | C(60)
Jméno kontaktní osoby | Jméno kontaktní osoby. | ADSPOJVL_ad11jmeno | C(40)
Komentář ke spojení | Komentář ke spojení | ADSPOJVL_ad11pozn | M
IČO | Identifikační číslo organizace. | ADADSATVL_ad01ico | C(10)
DIČ | Daňové identifikační číslo adresáta. | ADADSATVL_ad01dico | C(16)
Adresa partnera | Název adresáta | ADADSAT_ad01adsat | C(100)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
UTO | Národní směrové číslo státu pro telefonní spojení (UTO). | ADSPOJ_ad13nsc | C(4)
Volané telefonní číslo | Telefonní číslo | ADSPOJ_ad11cislo | C(60)
Jméno kontaktní osoby | Jméno kontaktní osoby. | ADSPOJ_ad11jmeno | C(40)
Komentář ke spojení | Komentář ke spojení | ADSPOJ_ad11pozn | M
IČO | Identifikační číslo organizace. | ADADSAT_ad01ico | C(10)
DIČ | Daňové identifikační číslo adresáta. | ADADSAT_ad01dico | C(16)
Druh artiklu | Identifikace druhu artiklu | MTARTIKL_sp61id | C(3)
Artikl | Identifikace artiklu | MTARTIKL_sp60id | C(13)
Název artiklu | Název artiklu | MTARTIKL_sp60artikl | C(60)
VČ | Výrobní číslo | MTUDA_mt02vc | C(32)
Čarový kód | Kód automatické identifikace | MTARTIKL_mt01ck | C(36)
Třída SKP | Identifikace třídy Standardní klasifikace produkce. | MTARTIKL_sp17idskp | C(8)
Účetní selektor artiklu | Účetní selektor artiklu | MTARTIKL_sp00uselar | C(9)
Datum a čas zápisu | Datum a čas zápisu záznamu události | MTUDA_sp00datzap | T

    Viz.také

    Konečné ocenění | OZNAČOVÁNÍ | Prezentace artiklu | Celkem - sklad | Adresář | Artikly skladu | Artikly skladu - VČ | Buňky | Druhy artiklů | Druhy operací | Druhy procesů | Kategorie adresátů | Množství artiklu na skladech | Měrné jednotky | Obchodní selektor | Organizační selektor | Sklady | Spojení adresátů | Technicko-věcný selektor | Progr. sablona - nenulovy skla | Převod mezi sklady


Aktuální hodnoty skladu

Popis

Jedná se o hodnoty, které vyjadřují určitý aktuální stav (k datu) na skladě. Může se jednat o finanční či naturální vyjádření stavu skladu nebo o informaci o materiálu na skladě. Každá aktuální hodnota se může vztahovat k jednomu nebo všem adresátům, záleží na tom, jaký výběr si uživatel při spuštění této činnosti nastaví. Definice sledovaných aktuálních hodnot se provádí v činnosti Informační centrum – Komponenty – Druhy hodnot.

Na základě těchto druhů hodnot a jejich používání v jednotlivých procesech je pak uživatel v podstatě schopen zjistit jakoukoliv potřebnou informaci o stavu skladu.

Po stisku klávesy Ctrl S má uživatel možnost nechat si vyčíslit celkovou sumu zobrazených aktuálních hodnot.

Datový model

  • MTAH Aktuální hodnota skladu
    • MTARTIKL Skladovaný artikl
    • ADADSAT Adresát
    • SPPRISTU Přístupové právo uživatele k věci
    • SPSTATDI Druh hodnoty
    • MTSKL Sklad

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Události správy artiklu |
^S | Celkem - AH | Součet celkem - AH
- | Legenda palety barev |
F2 | Adresář | Přehled adresátů
F2 | Artikly skladu | Seznam skladovaných artiklů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Palety barev kategorií | Palety barev kategorií
F2 | Sklady | Seznam skladů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

    Formulář činnosti - Legenda palety barev
Mřížka [Aktuální hodnoty]
Listovací rámeček
Stránka #1 Aktuální hodnoty
Druh hodnoty | Identifikace druhu hodnoty
 | Název druhu hodnoty
Adresát | Identifikace adresáta
 | Název adresáta
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Sklad | Identifikace umístění skladové evidence
 | Název skladu
 | Identifikace skladové buňky
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Hodnota | Hodnota
Stránka #2 Výběr
Druh hodnoty | Identifikace druhu hodnoty
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Sklad | Identifikace umístění skladové evidence
 | Identifikace skladové buňky
 | Název skladu
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Paleta | Vybrat záznamy všech kategorií v paletě
 | Identifikace palety barev
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Aktuální hodnoty] činnosti - Legenda palety barev

    Mřížka [Aktuální hodnoty] činnosti - Legenda palety barev
Druh hodnoty | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Adresát | Identifikace adresáta
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Sklad | Identifikace umístění skladové evidence
Buňka | Identifikace skladové buňky
Hodnota | Hodnota
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Název adresáta | Název adresáta
Název artiklu | Název artiklu
Název skladu | Název skladu

    Atributy tisku

    Základní údaje
Druh hodnoty | Identifikace druhu hodnoty | MTAH_sp67id | C(3)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)
Adresát | Identifikace adresáta | MTAH_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Druh artiklu | Identifikace druhu artiklu | MTAH_sp61id | C(3)
Artikl | Identifikace artiklu | MTAH_sp60id | C(13)
Název artiklu | Název artiklu | MTARTIKL_sp60artikl | C(60)
Sklad | Identifikace umístění skladové evidence | MTAH_mt04id | C(6)
Název | Název skladu | MTSKL_mt04text | C(40)
Hodnota | Hodnota | MTAH_mt02hodnot | N(20,4)
Měrná jednotka | Identifikátor měrné jednotky | MTARTIKL_sp24idmj | C(3)
Obch. sel. | Identifikátor obchodního selektoru | ADADSAT_sp10idzak | C(9)
Název obchodního selektoru | Název obchodního selektoru | SPSEOB_sp10text | C(60)
Org. sel. | Identifikátor organizačního selektoru. | MTSKL_sp11idzak | C(9)
Název organizačního selektoru | Název organizačního selektoru | SPSEOR_sp11text | C(60)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MTARTIKL_sp20idzak | C(9)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(60)

    Viz.také

    Události správy artiklu | Celkem - AH | Legenda palety barev | Adresář | Artikly skladu | Druhy artiklů | Druhy hodnot | Kategorie adresátů | Obchodní selektor | Organizační selektor | Palety barev kategorií | Sklady | Technicko-věcný selektor


Množství artiklu na skladech

Popis

Uživatel má k dispozici aktuální informace o množství materiálu na skladě. U každého vybraného materiálu se mu zobrazuje množství materiálu na skladě, množství materiálu, které bylo rezervováno, celková cena materiálu a cena za MJ.

Kromě aktivace této činnosti v menu Sklad je možno si tyto informace zobrazit v každé činnosti na tučně zvýrazněné položce "artikl" po stisku pravého tlačítka myši.

Datový model

  • MTMNP Množství artiklu ve skladové buňce
    • MTSKL Sklad
    • MTARTIKL Skladovaný artikl
      • SPARTIKN Název artiklu
    • SPPRISTU Přístupové právo uživatele k věci

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Vybrat jinou buňku | Vybrat jinou buňku
F5 | Vybrat jiný sklad | Vybrat jiný sklad
F6 | Události správy artiklu |
- | Legenda palety barev |
F2 | Artikly skladu | Seznam skladovaných artiklů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Palety barev kategorií | Palety barev kategorií
F2 | Sklady | Seznam skladů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

    Formulář činnosti - Legenda palety barev
Mřížka [Množství artiklu na skladech]
Listovací rámeček
Stránka #1 Množství artiklu na skladech
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Sklad | Identifikace umístění skladové evidence
 | Identifikace skladové buňky
 | Název skladu
Množství | Množství artiklu v umístění
Rezervováno | Rezervované množství artiklu v umístění
Celková cena | Celková cena artiklu v umístění
Stránka #2 Výběr
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Sklad | Identifikace umístění skladové evidence
 | Identifikace skladové buňky
 | Název skladu
Selektory | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Paleta | Vybrat záznamy všech kategorií v paletě
 | Identifikace palety barev
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Množství artiklu na skladech] činnosti - Legenda palety barev

    Mřížka [Množství artiklu na skladech] činnosti - Legenda palety barev
Sklad | Identifikace umístění skladové evidence
Buňka | Identifikace skladové buňky
Množství | Množství artiklu v umístění
Rezervováno | Rezervované množství artiklu v umístění
Celková cena | Celková cena artiklu v umístění
Cena za MJ | Cena za jednotku - skladová cena
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu

    Atributy tisku

    Základní údaje
Druh artiklu | Identifikace druhu artiklu | MTMNP_sp61id | C(3)
Artikl | Identifikace artiklu | MTMNP_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MTARTIKL_sp20idzak | C(9)
Sklad | Identifikace umístění skladové evidence | MTMNP_mt04id | C(6)
Buňka | Identifikace skladové buňky | MTMNP_mt05id | C(9)
Název skladu | Název skladu | MTSKL_mt04text | C(40)
Org. sel. | Identifikátor organizačního selektoru. | MTSKL_sp11idzak | C(9)
Množství | Množství artiklu v umístění | MTMNP_mt03mn | N(20,4)
Celková cena | Celková cena artiklu v umístění | MTMNP_mt03cena | N(20,4)
Rezervováno | Rezervované množství artiklu v umístění | MTMNP_mt03rezmn | N(20,4)

    Viz.také

    Vybrat jinou buňku | Vybrat jiný sklad | Události správy artiklu | Legenda palety barev | Artikly skladu | Druhy artiklů | Organizační selektor | Palety barev kategorií | Sklady | Technicko-věcný selektor


Obraty skladu

Popis

Při práci s obratovou tabulkou skladu je nutno si uvědomit, jaké informace uživatel potřebuje mít k dispozici. Zobrazení potřebných údajů je přímo závislé na tom, jakým způsobem si uživatel nadefinuje záložku „výběr“. Jako u jiných výběrových záložek je možno si vybírat z několika atributů, na základě kterých se budou vybírat data. Kromě těch běžných jako je datum, druh hodnoty, adresát, artikl, sklad apod. je zde atribut, který má zásadní význam pro zobrazení dat. Tento atribut se nazývá „poslední obrat“ a dosahuje těchto hodnot:

¨ neurčeno - zobrazuje veškeré obraty nezávisle na období (tzn. není nutno zadávat žádné období od - do). Tuto hodnotu je vhodné využít např. při zobrazení hodnot za vybraný sklad, artikl nebo adresáta.

¨ zahrnout - hodnota zahrnout naopak úzce souvisí s obdobím od - do. Při použití hodnoty zahrnout je zároveň nutno zadat období OD - DO a systém pak zobrazí obraty za dané období s tím, že pokud u některého artiklu nenajde obrat v zadaném období OD - DO, zobrazí obrat s nejvyšším nižším datem

¨ pouze - hodnotu pouze má smysl používat nikoliv pro zjišťování obratů, ale pro zjištění konečných stavů s tím, že zároveň s touto hodnotou musí být uvedeno období DO (období OD zůstává nevyplněné).

Na základě zvolení Palety na záložce Výběr je možno přehled artiklů zvýraznit i barevně.

Datový model

  • MTOBRAT Obrat skladu
    • SPSTATDI Druh hodnoty
    • ADADSAT Adresát
    • MTARTIKL Skladovaný artikl
      • SPARTIKN Název artiklu
    • MTSKL Sklad
      • SPPRISTU Přístupové právo uživatele k věci

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Události správy artiklu |
- | Legenda palety barev |
F2 | Adresář | Přehled adresátů
F2 | Artikly skladu | Seznam skladovaných artiklů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Palety barev kategorií | Palety barev kategorií
F2 | Sklady | Seznam skladů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

    Formulář činnosti - Legenda palety barev
Mřížka [Obraty skladů]
Listovací rámeček
Stránka #1 Obraty skladů
Datum | Datum obratu
Druh hodnoty | Identifikace druhu hodnoty
 | Název druhu hodnoty
Adresát | Identifikace adresáta
 | Název adresáta
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
MJ | Identifikátor měrné jednotky
Sklad | Identifikace umístění skladové evidence
 | Název skladu
PS | Počáteční stav
P | Příjem
V | Výdej
KS | Konečný stav
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Stránka #2 Výběr
Datum | Datum obratu
do | Datum obratu do
Poslední obrat | Zobrazení posledního obratu
Druh hodnoty | Identifikace druhu hodnoty
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Sklad | Identifikace umístění skladové evidence
 | Název skladu
Paleta | Vybrat záznamy všech kategorií v paletě
 | Identifikace palety barev
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Obraty skladů] činnosti - Legenda palety barev

    Mřížka [Obraty skladů] činnosti - Legenda palety barev
Druh hodnoty | Identifikace druhu hodnoty
Datum | Datum obratu
Adresát | Identifikace adresáta
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Sklad | Identifikace umístění skladové evidence
Poč.stav | Počáteční stav
Příjem | Příjem
Výdej | Výdej
Kon.stav | Konečný stav
Název druhu hodnoty | Název druhu hodnoty
Název adresáta | Název adresáta
Název artiklu | Název artiklu
MJ | Identifikátor měrné jednotky
Název | Název skladu
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Atributy tisku

    Základní údaje
Datum | Datum obratu | MTOBRAT_mt14datum | D
Druh hodnoty | Identifikace druhu hodnoty | MTOBRAT_sp67id | C(3)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)
Adresát | Identifikace adresáta | MTOBRAT_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Druh artiklu | Identifikace druhu artiklu | MTOBRAT_sp61id | C(3)
Artikl | Identifikace artiklu | MTOBRAT_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Sklad | Identifikace umístění skladové evidence | MTOBRAT_mt04id | C(6)
Název | Název skladu | MTSKL_mt04text | C(40)
Poč.stav | Počáteční stav | MTOBRAT_mt14pstav | N(20,4)
Příjem | Příjem | MTOBRAT_mt14prijem | N(20,4)
Výdej | Výdej | MTOBRAT_mt14vydej | N(20,4)
Kon.stav | Konečný stav | Výpočet | N(20,4)
MJ | Identifikátor měrné jednotky | MTARTIKL_sp24idmj | C(3)
Obch. sel. | Identifikátor obchodního selektoru | ADADSAT_sp10idzak | C(9)
Název obchodního selektoru | Název obchodního selektoru | SPSEOB_sp10text | C(60)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MTARTIKL_sp20idzak | C(9)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(60)
Org. sel. | Identifikátor organizačního selektoru. | MTSKL_sp11idzak | C(9)
Název organizačního selektoru | Název organizačního selektoru | SPSEOR_sp11text | C(60)

    Viz.také

    Události správy artiklu | Legenda palety barev | Adresář | Artikly skladu | Druhy artiklů | Druhy hodnot | Kategorie adresátů | Obchodní selektor | Organizační selektor | Palety barev kategorií | Sklady | Technicko-věcný selektor


Obraty skladu - VČ

Popis

Na základě zadaného výběru má uživatel k dispozici informace o obratech skladu, kde se evidují artikly s výrobním číslem. U každého artiklu jsou kromě základních informací (tj. výrobní číslo, identifikace, název, sklad apod.) další údaje:

¨ druh aktuální hodnoty, za kterou jsou tyto údaje zobrazovány

¨ datum obratu

¨ poč. stav

¨ příjem

¨ výdej

¨ kon. stav

Datový model

  • MTOBRATV Vypočtený obrat skladovaného artiklu s výrobním číslem
    • MTSKL Sklad
    • SPARTIKN Název artiklu
    • SPSTATDI Druh hodnoty

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Události správy artiklu |
- | Legenda palety barev |
F2 | Artikly skladu | Seznam skladovaných artiklů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Palety barev kategorií | Palety barev kategorií
F2 | Sklady | Seznam skladů

    Formulář

    Formulář činnosti - Druhy hodnot
Mřížka [Obraty skladu]
Listovací rámeček
Stránka #1 Obraty skladu dle VČ
VČ | Výrobní číslo
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Sklad | Identifikace umístění skladové evidence
 | Název skladu
Datum | Datum obratu
Poč.stav | Počáteční stav
Příjem | Příjem
Výdej | Výdej
Kon.stav | Konečný stav
Druh hodnoty | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Stránka #2 Výběr
VČ | Výrobní číslo
Datum | Datum
 | Datum do
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Sklad | Identifikace umístění skladové evidence
Druh hodnoty | Identifikace druhu hodnoty
Poslední obrat | Zobrazení posledního obratu
Paleta | Identifikace palety barev
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Obraty skladu] činnosti - Druhy hodnot

    Mřížka [Obraty skladu] činnosti - Druhy hodnot
Datum | Datum obratu
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Sklad | Identifikace umístění skladové evidence
Adresát | Identifikace adresáta
VČ | Výrobní číslo
Poč.stav | Počáteční stav
Příjem | Příjem
Výdej | Výdej
Kon.stav | Konečný stav
Druh hodnoty | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Název artiklu | Název artiklu
Název skladu | Název skladu

    Atributy tisku

    Základní údaje
Druh artiklu | Identifikace druhu artiklu | MTOBRATV_sp61id | C(3)
Artikl | Identifikace artiklu | MTOBRATV_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Sklad | Identifikace umístění skladové evidence | MTOBRATV_mt04id | C(6)
Název skladu | Název skladu | MTSKL_mt04text | C(40)
Adresát | Identifikace adresáta | MTOBRATV_ad01id | C(6)
VČ | Výrobní číslo | MTOBRATV_mt02vc | C(32)
Datum | Datum obratu | MTOBRATV_mt14datum | D
Poč.stav | Počáteční stav | MTOBRATV_mt14pstav | N(20,4)
Příjem | Příjem | MTOBRATV_mt14prijem | N(20,4)
Výdej | Výdej | MTOBRATV_mt14vydej | N(20,4)
Kon.stav | Konečný stav | Výpočet | N(20,4)
Druh hodnoty | Identifikace druhu hodnoty | MTOBRATV_sp67id | C(3)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)
Komponenta | Identifikace komponenty | MTOBRATV_sp06idsubs | C(3)

    Viz.také

    Události správy artiklu | Legenda palety barev | Artikly skladu | Druhy artiklů | Druhy hodnot | Palety barev kategorií | Sklady


Artikly skladu

Popis

Tato činnost slouží k definici a přehledu skladovaného artiklu, tzn. artiklu, který se vstupuje v událostech skladu. Jedná se o artikl, který se skladuje, sleduje se u něj aktuální množství na skladě, aktuální hodnoty apod.

Po spuštění činnosti má uživatel nejprve možnost zvolit si nadefinováním výběru zobrazení artiklu. Při vkládání, opravě nebo prohlížení artiklu se vstupují tyto údaje:

¨ artikl - identifikace druhu artiklu. Lze vybrat ze seznamu druhů artiklu klávesou F2.

¨ identifikace artiklu

¨ název artiklu - název artiklu

¨ ČK - pokud se používá při práci čtečka, zadává se zde čárový kód artiklu, tzn. že čárový kód na událostech obchodu a skladu se vstupuje právě proto, aby se podle něj automaticky předplnil artikl, např. právě při použití čtečky čárového kódu. Pro rozšiřující identifikátor artiklu (např. šarži) je určen na událostech obchodu a skladu atribut výrobní číslo.

¨ MJ - identifikátor měrné jednotky (jedná se o MJ, v níž se daný artikl skladuje, přijímá, vydává apod.), tzn. je to referenční měrná jednotka

¨ třída SKP - identifikace třídy standardní klasifikace produkce. Pokud uživatel nechce zadávat, vybírá možnost neurčeno.

¨ vztah k účetnictví - jaký vztah k účetnictví zaujímá daný artikl. Může to být materiál, zboží, výrobek - uživatel má možnost si vybrat z překryvného seznamu, který je v případě potřeby ještě možno rozšířit.

¨ technicko-věcný selektor - identifikátor technicko - věcného selektoru. V postatě určuje, jaké činnosti v organizaci se daný artikl týká.

¨ účetní selektor - zadává se zde přímo hodnota účtu, na který se daný artikl účtuje

¨ stav - může být aktuální či neaktuální. Ve většině případů bude určitě aktuální, v případě, že uživatel nechce artikl již používat a on nelze zrušit, protože již byl použit v událostech, nastaví u něj právě příznak neaktuální (pak je vhodné si ve výběrové záložce vybírat pouze aktuální artikly).

¨ povolena nulová cena - tento artikl je možno v událostech vstupovat s nulovou cenou, jinak musí být cena vždy uvedena.

¨ libovolná poznámka k artiklu

Tato činnost poskytuje uživateli řadu dalších záložek, kde jsou k dispozici další informace o daném skladovaném artiklu. Všechny údaje ze záložek lze vyvolat ihned souhrnně po stisku pravého tlačítka myši na tučně zvýrazněné položce "artikl". Uživateli se nabízí všechny činnosti, které ho mohou v souvislosti s artiklem zajímat nebo které bude při své práci potřebovat (např. události, množství, ceník, ...).

Záložka "názvy skl. artiklu v jazycích" umožňuje uživateli evidovat si názvy artiklů v jazycích, které jsou v systému nadefinovány. Uživatel si vybere identifikaci jazyka, ve kterém chce artikl evidovat a do položky název artiklu napíše název artiklu ve zvoleném jazyce.

Záložka "přepočet MJ skl.art." umožňuje uživateli nastavit si poměr mezi referenční měrnou jednotkou a jím zvolenou jednotkou. Např. ref. MJ může být metry, což je tolik a tolik kg, nebo se může určitý artikl prodávat na balení a to je tolik a tolik kusů. V případě, že přepočet měrných jednotek je zde nadefinován, je při výdeji a příjmu daného artiklu k dispozici množství v obou měrných jednotkách, jak v referenční, tak v přepočtené.

Záložka "množství" poskytuje uživateli informace o aktuálním množství artiklu na skladu (nebo více skladech).

Záložka "aktuální hodnoty" poskytuje uživateli informaci o hodnotě artiklu, např. ve finančním nebo naturálním vyjádření.

Na základě zvolení Palety na záložce Výběr je možno přehled artiklů zvýraznit i barevně.

Datový model

  • MTARTIKL Skladovaný artikl
    • SPARTIKL Artikl
    • SPMJ Měrná jednotka
      • SPMJN Měrná jednotka v jazyce
    • SPARTIKN Název artiklu
    • SPSETV Technicko-věcný selektor
    • SPSKP SKP
    • BWUZIVAT Uživatel systému

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Události správy artiklu |
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
- | Dokumenty artiklu | Dokumenty artiklu
- | Legenda palety barev |
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Kategorie událostí správy artiklu | Přehled kategorií událostí správy artiklu
F2 | Měrné jednotky | Číselník měrných jednotek
F2 | Palety barev kategorií | Palety barev kategorií
F2 | Spojení | Seznam spojení za adresáta.
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Třídy SKP | Třídy Standardní klasifikace produkce

    Formulář

     | Formulář činnosti - Spojení
 | Mřížka [Skladovaný artikl]
 |  | Identifikace druhu artiklu
 | Artikl | Identifikace artiklu
 | Název artiklu | Název artiklu
 | Listovací rámeček
 | Stránka #1 Skladovaný artikl
 | Čarový kód | Kód automatické identifikace
 | MJ | Identifikátor měrné jednotky
 |  | Název měrné jednotky
 | Třída SKP | Identifikace třídy Standardní klasifikace produkce.
 |  | Název kategorie Standardní klasifikace produkce.
 | Vztah k účet. | Vztah k účetnictví - zboží, materiál, výrobek ....
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 |  | Název technicko-věcného selektoru.
 | Účet.sel. | Účetní selektor artiklu
 | Stav | Aktuální/ neaktuální
 | Pozn. | Komentář - poznámka k artiklu
 | Povolena nulová cena | Povolena nulová cena v událostech o artiklu
 | Zapsal | Jméno uživatele systému
 |  | Datum a čas zápisu záznamu události
 | Stránka #2 Názvy skl. artiklu v jazycích
 | Mřížka [Názvy artiklu v jazycích]
 | Jazyk | Identifikace jazyka
 | Název artiklu | Název artiklu
 | Stránka #3 Přepočet MJ skl. art.
 | Mřížka [Vztah MJ skl.art]
 | MJ | Identifikátor měrné jednotky
 |  | Název měrné jednotky
 | := | Vztah měrných jednotek
 | MJ | Identifikátor měrné jednotky
 |  | Název měrné jednotky
 | Stránka #4 Množství
 | Mřížka [Množství]
 | Sklad | Identifikace umístění skladové evidence
 |  | Identifikace skladové buňky
 | Množství | Množství artiklu v umístění
 | Rezervováno | Rezervované množství artiklu v umístění
 | Celková cena | Celková cena artiklu v umístění
 | Cena za MJ | Cena za jednotku - skladová cena
 | Stránka #5 Aktuální hodnoty
 | Mřížka [Aktuální hodnoty]
 | Sklad | Identifikace umístění skladové evidence
 |  | Identifikace skladové buňky
 | Druh hodnoty | Identifikace druhu hodnoty
 |  | Název druhu hodnoty
 | Hodnota | Hodnota
 | Stránka #6 Kategorie
 | Mřížka [Kategorie artiklu]
 |  | Kategorie
Identifikace kategorie události správy artiklu |  |  | Platnost
Datum platnosti od |  |  | Platnost do
Datum platnosti do |  |  | Adresát
Identifikace adresáta |  |
Název adresáta |  |
Číslo spojení adresáta. |  |  | Popis
Popis události |  |  | Poznámka
Poznámka |  |  | Zapsal
Jméno uživatele systému |  |  | Datum a čas zápisu
Datum a čas zápisu záznamu události
 | Stránka #7 Výběr
 |  | Identifikace druhu artiklu
 | Artikl | Identifikace artiklu
 | Název artiklu | Název artiklu
 | MJ | Identifikátor měrné jednotky
 | Množství | Množství artiklu na skladech
 | Stav | Aktuální/ neaktuální
 |  | Vztah k účetnictví - zboží, materiál, výrobek, služba ...
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Účet.sel. | Účetní selektor artiklu
 | Vztah ke kategorii | Vztah ke kategorii - Je=K dnešnímu datu je v kategorii, Není=K dnešnímu datu není v kategorii, Byl=Není v kategorii, ale byl, Nebyl=Není a nikdy nebyl v kategorii,Bude=Bude v kategorii
 | Kategorie | Identifikace kategorie události správy artiklu
 | Název kategorie | Název kategorie události správy artiklu
 | Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 |  | Platnost nebo neplatnost k datu
 | Zapsal | Identifikace uživatele systému
 | Paleta | Vybrat záznamy všech kategorií v paletě
 |  | Identifikace palety barev
 | Výběr | Určení výběru
 | Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Skladovaný artikl] činnosti - Spojení

    Mřížka [Skladovaný artikl] činnosti - Spojení
Označování | Označení záznamu
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
MJ | Identifikátor měrné jednotky
Třída SKP | Identifikace třídy Standardní klasifikace produkce.
Technicko-věcný selektor | Identifikátor technicko-věcného selektoru.
Čarový kód | Kód automatické identifikace
Název artiklu | Název artiklu
Datum a čas zápisu | Datum a čas zápisu záznamu události

    Mřížka [Názvy artiklu v jazycích] činnosti - Spojení

    Mřížka [Názvy artiklu v jazycích] činnosti - Spojení
Jazyk | Identifikace jazyka
Název artiklu | Název artiklu

    Mřížka [Vztah MJ skl.art] činnosti - Spojení

    Mřížka [Vztah MJ skl.art] činnosti - Spojení
MJ | Identifikátor měrné jednotky
MJ | Identifikátor měrné jednotky
Vztah | Vztah měrných jednotek
Název měrné jednotky | Název měrné jednotky
Název měrné jednotky | Název měrné jednotky

    Mřížka [Množství] činnosti - Spojení

    Mřížka [Množství] činnosti - Spojení
Sklad | Identifikace umístění skladové evidence
Buňka | Identifikace skladové buňky
Množství | Množství artiklu v umístění
Rezervováno | Rezervované množství artiklu v umístění
Celková cena | Celková cena artiklu v umístění
Cena za MJ | Cena za jednotku - skladová cena

    Mřížka [Aktuální hodnoty] činnosti - Spojení

    Mřížka [Aktuální hodnoty] činnosti - Spojení
Sklad | Identifikace umístění skladové evidence
Buňka | Identifikace skladové buňky
Druh hodnoty | Identifikace druhu hodnoty
Hodnota | Hodnota
Název druhu hodnoty | Název druhu hodnoty

    Mřížka [Kategorie artiklu] činnosti - Spojení

    Mřížka [Kategorie artiklu] činnosti - Spojení
Kategorie | Identifikace kategorie události správy artiklu
Název kategorie | Název kategorie události správy artiklu
Platnost od | Datum platnosti od
Platnost do | Datum platnosti do
Adresát | Identifikace adresáta
Název adresáta | Název adresáta

    Atributy tisku

    Základní údaje
Druh artiklu | Identifikace druhu artiklu | MTARTIKL_sp61id | C(3)
Artikl | Identifikace artiklu | MTARTIKL_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Čarový kód | Kód automatické identifikace | MTARTIKL_mt01ck | C(36)
Měrná jednotka | Identifikátor měrné jednotky | MTARTIKL_sp24idmj | C(3)
Vztah k účetnictví | Vztah k účetnictví - zboží, materiál, výrobek, služba ... | Výpočet | C(8)
Povolena nulová cena | Povolena nulová cena v událostech o artiklu | Výpočet | C(3)
Třída SKP | Identifikace třídy Standardní klasifikace produkce. | MTARTIKL_sp17idskp | C(8)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MTARTIKL_sp20idzak | C(9)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(60)
Účetní selektor artiklu | Účetní selektor artiklu | MTARTIKL_sp00uselar | C(9)
Pozn. | Komentář - poznámka k artiklu | MTARTIKL_mt01koment | M
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)

    Při pohybu v Aktuální hodnoty
Druh hodnoty | Identifikace druhu hodnoty | MTAH_sp67id | C(3)
Adresát | Identifikace adresáta | MTAH_ad01id | C(6)
Sklad | Identifikace umístění skladové evidence | MTAH_mt04id | C(6)
Hodnota | Hodnota | MTAH_mt02hodnot | N(20,4)

    Při pohybu v Množství na skladech
Sklad | Identifikace umístění skladové evidence | MTMNP_mt04id | C(6)
Množství | Množství artiklu v umístění | MTMNP_mt03mn | N(20,4)
Celková cena | Celková cena artiklu v umístění | MTMNP_mt03cena | N(20,4)
Rezervováno | Rezervované množství artiklu v umístění | MTMNP_mt03rezmn | N(20,4)

    Viz.také

    Události správy artiklu | OZNAČOVÁNÍ | Prezentace artiklu | Dokumenty artiklu | Legenda palety barev | Adresář | Druhy artiklů | Kategorie událostí správy artiklu | Měrné jednotky | Palety barev kategorií | Spojení | Technicko-věcný selektor | Třídy SKP


Artikly skladu - VČ

Popis

Jedná se o číselník artiklů, u kterých se kromě identifikace a názvu eviduje i výrobní číslo. Výrobní číslo může být samostatně pro každý artikl nebo i pro určitou skupinu artiklů. U každého takového artiklu se eviduje:

¨ identifikace a název

¨ výrobní číslo

¨ technicko - věcný selektor

¨ sklad

¨ datum prvního příjmu

¨ množství tohoto artiklu v referenční měrné jednotce

Datový model

  • MTKARVC Karta artiklu s výrobním číslem
    • MTARTIKL Skladovaný artikl
      • SPARTIKN Název artiklu
      • SPSETV Technicko-věcný selektor
    • MTSKL Sklad
      • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Legenda palety barev
Mřížka [Artikly s výrobním číslem]
Listovací rámeček
Stránka #1 Artikly s výrobním číslem
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
VČ | Výrobní číslo
TVS | Identifikátor technicko-věcného selektoru.
Název tech. sel. | Název technicko-věcného selektoru.
Sklad | Identifikace umístění skladové evidence
Název skladu | Název skladu
Datum | Datum
Poznámka | Poznámka
1.příjem | Datum prvního příjmu
Množství v RMJ | Aktuální množství artiklu s výrobním číslem v referenční měrné jednotce
Stránka #2 Výběr
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
VČ | Výrobní číslo
Sklad | Identifikace umístění skladové evidence
TVS | Identifikátor technicko-věcného selektoru.
Množství | Množství artiklu na skladech
Paleta | Vybrat záznamy všech kategorií v paletě
 | Identifikace palety barev
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Artikly s výrobním číslem] činnosti - Legenda palety barev

    Mřížka [Artikly s výrobním číslem] činnosti - Legenda palety barev
Datum | Datum
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
VČ | Výrobní číslo
Množství v RMJ | Aktuální množství artiklu s výrobním číslem v referenční měrné jednotce
Sklad | Identifikace umístění skladové evidence
Název artiklu | Název artiklu
Název skladu | Název skladu
1.příjem | Datum prvního příjmu

    Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Události správy artiklu |
- | Naplnění artiklů s VČ | Naplnění artiklů s VČ do seznamu
- | Legenda palety barev |
F2 | Artikly skladu | Seznam skladovaných artiklů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Palety barev kategorií | Palety barev kategorií
F2 | Sklady | Seznam skladů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Atributy tisku

    Základní údaje
Datum | Datum | MTKARVC_mt21dat | D
1.příjem | Datum prvního příjmu | MTKARVC_mt21dat1 | D
Druh artiklu | Identifikace druhu artiklu | MTKARVC_sp61id | C(3)
Artikl | Identifikace artiklu | MTKARVC_sp60id | C(13)
Název artiklu | Název artiklu | MTARTIKL_sp60artikl | C(60)
VČ | Výrobní číslo | MTKARVC_mt02vc | C(32)
Sklad | Identifikace umístění skladové evidence | MTKARVC_mt04id | C(6)
Název skladu | Název skladu | MTSKL_mt04text | C(40)
Množství v RMJ | Aktuální množství artiklu s výrobním číslem v referenční měrné jednotce | mt21mnr | N(20,4)
Množství v RMJ | Aktuální množství artiklu s výrobním číslem v referenční měrné jednotce | MTKARVC_mt21mnr | N(20,4)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MTARTIKL_sp20idzak | C(9)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(60)

    Viz.také

    Události správy artiklu | Naplnění artiklů s VČ | Legenda palety barev | Artikly skladu | Druhy artiklů | Palety barev kategorií | Sklady | Technicko-věcný selektor


Sklady

Popis

Tato činnost představuje pro uživatele přehled jeho úložného prostoru, který má smysl evidovat v rámci sledování skladové evidence v každém podniku. Každý uživatel může vést neomezený počet skladů. Pokud podnik nevede více skladů, musí zde být uveden minimálně jeden záznam, který má význam skladu firmy (může to být i záznam uvedený pomlčkou). V případě potřeby je možno sklad rozdělit na tzn. skladové buňky.

K dispozici jsou tyto údaje:

¨ sklad - identifikace umístění skladové evidence a název skladu

¨ adresát - adresa vlastníka skladu

¨ organizační selektor - identifikátor organizačního selektoru. Pokud je vyplněn, zobrazí se název organizačního selektoru. Lze vybrat ze seznamu klávesou F2.

¨ účetní selektor – nutno ručně zadat, nejde výběr z číselníku

¨ FIFO / vážený průměr - zaškrtnutím jedné z možností uživatel zvolí způsob oceňování skladu

Každý sklad může být rozdělen na úložný prostor (buňky). Každá buňka přísluší určitému skladu. Buňky se evidují na druhé záložce a uvádí se tyto atributy:

¨ buňka - identifikace skladové buňky a název skladové buňky. Identifikátor skladové buňky může být zadán strukturovaně (řada, regál, patro).

¨ čárový kód - kód automatické identifikace (např. pro automatické zakladače).

¨ umístění buňky osa X, Y, Z - možnost ještě více rozčlenit umístění v buňce

Ke každému skladu (umístění) je možno nadefinovat přístupová práva.

Datový model

  • MTSKL Sklad
    • SPSEOR Organizační selektor
    • SPPRISTU Přístupové právo uživatele k věci
    • ADADSAT Adresát
    • ADSPOJ Spojení adresáta
      • ADADR Adresa

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Buňky |
^B | Přístupová práva | Definování práv přístupu k věci
F2 | Adresář | Přehled adresátů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Spojení adresátů | Přehled spojení adresátů

    Formulář

    Formulář činnosti - Spojení adresátů
Mřížka [Sklad]
Sklad | Identifikace umístění skladové evidence
 | Název skladu
Listovací rámeček
Stránka #1 Sklady
Oceňování | Sklad je oceňován metodou: FIFO / Vážený průměr
Adresát | Identifikace adresáta
 | Název adresáta
 | Číslo spojení adresáta.
 | Ulice adresy adresáta (včetně čísla popisného).
 | Město adresy adresáta.
 | Poštovní směrovací číslo adresy adresáta.
Org. sel. | Identifikátor organizačního selektoru.
 | Název organizačního selektoru
Účet.sel. | Účetní selektor umístění
Poznámka | Poznámka
Stránka #2 Buňky
Mřížka [Buňky]
Buňka | Identifikace skladové buňky
 | Název skladové buňky
Čarový kód | Kód automatické identifikace
Umístění buňky osa X | Umístění buňky osa X
Umístění buňky osa Y | Umístění buňky osa Y
Umístění buňky osa Z | Umístění buňky osa Z
Volný text | Volný text
Stránka #3 Výběr
Sklad | Identifikace umístění skladové evidence
 | Název skladu
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
Typ | Sklad je oceňován metodou: FIFO / Vážený průměr
Org. sel. | Identifikátor organizačního selektoru.
Účet.sel. | Účetní selektor umístění
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Sklad] činnosti - Spojení adresátů

    Mřížka [Sklad] činnosti - Spojení adresátů
Sklad | Identifikace umístění skladové evidence
Název | Název skladu
Organizační selektor | Identifikátor organizačního selektoru.

    Mřížka [Buňky] činnosti - Spojení adresátů

    Mřížka [Buňky] činnosti - Spojení adresátů
Sklad | Identifikace umístění skladové evidence
Buňka | Identifikace skladové buňky
Název | Název skladové buňky
Čarový kód | Kód automatické identifikace

    Atributy tisku

    Základní údaje
Sklad | Identifikace umístění skladové evidence | MTSKL_mt04id | C(6)
Název | Název skladu | MTSKL_mt04text | C(40)
Typ | Sklad je oceňován metodou: FIFO / Vážený průměr | Výpočet | C(13)
Poznámka | Poznámka | MTSKL_mt04koment | M
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Jméno | Jméno kontaktní osoby. | ADSPOJ_ad11jmeno | C(40)
Telefon | Telefonní číslo | ADSPOJ_ad11cislo | C(60)
Organizační selektor | Identifikátor organizačního selektoru. | MTSKL_sp11idzak | C(9)
Název organizačního selektoru | Název organizačního selektoru | SPSEOR_sp11text | C(60)
Účetní selektor umístění | Účetní selektor umístění | MTSKL_sp00uselum | C(9)

    Při pohybu v Buňky
Buňka | Identifikace skladové buňky | MTBUN_mt05id | C(9)
Název | Název skladové buňky | MTBUN_mt05text | C(40)
Čarový kód | Kód automatické identifikace | MTBUN_mt05ck | C(36)
Umístění buňky osa X | Umístění buňky osa X | MTBUN_mt05x | N(5)
Umístění buňky osa Y | Umístění buňky osa Y | MTBUN_mt05y | N(5)
Umístění buňky osa Z | Umístění buňky osa Z | MTBUN_mt05z | N(5)
Volný text | Volný text | MTBUN_mt05txt | C(30)

    Viz.také

    Buňky | Přístupová práva | Adresář | Organizační selektor | Spojení adresátů


Základní druhy hodnot

Popis

Uživateli se zobrazuje přehled základních druhů hodnot, které se vztahují k informacím o skladu a k těmto základním hodnotám je nutno nastavit konkrétní aktuální hodnoty nebo-li nastavit, která aktuální hodnota určuje danou základní hodnotu.

Při zadávání hodnot si uživatel příslušné aktuální hodnoty vybírá z číselníku pomocí klávesy F2, stiskem ikony s lupou a nebo stiskem pravého tlačítka myši přímo na žlutém výběrovém políčku.

Jednotlivé druhy aktuálních hodnot (nadefinované v činnosti Informační centrum - Komponenty) se přiřazují k těmto základním druhům hodnot:

¨ množství na skladě ve finančním vyjádření

¨ množství na skladě v naturálním vyjádření

¨ rezervované množství na skladě

¨ množství na skladě ve finančním vyjádření - předběžné ocenění

¨ množství na skladě v naturálním vyjádření - předběžné ocenění

¨ rezervované množství na skladě - předběžné ocenění

Datový model

  • MTPARSKL Parametry komponenty sklady
    • BWUZIVAT Uživatel systému

    • Formulář

    Formulář činnosti - Druhy hodnot
Množství na skladě ve finačním vyjádření | Identifikace druhu hodnoty
 | Název druhu hodnoty
Množství na skladě v naturálním vyjádření | Identifikace druhu hodnoty
 | Název druhu hodnoty
Rezervované množství na skladě | Identifikace druhu hodnoty
 | Název druhu hodnoty
Množství na skladě ve finačním vyjádření - předběžné ocenění | Identifikace druhu hodnoty
 | Název druhu hodnoty
Množství na skladě ve naturálním vyjádření - předběžné ocenění | Identifikace druhu hodnoty
 | Název druhu hodnoty
Rezervované množství na skladě - předběžné ocenění | Identifikace druhu hodnoty
Změnil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
 | Název druhu hodnoty

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druhy hodnot | Seznam druhů statistických informací

    Viz.také

    Druhy hodnot


ZMĚNA STAVU PENĚZ

Popis

Komponenta změna stavu peněz sleduje změnu stavu peněz na účtech a pokladnách a pohyb peněz mezi institucemi vůbec.

Viz.také

Události změny stavu peněz | Aktuální hodnoty ZSP | Obraty na účtech ZSP | Definice komunikace s bankou | Základní druhy hodnot ZSP


Události změny stavu peněz

Popis

Objektem činnosti události změny stavu peněz je každá položka výpisu z banky (příjmová nebo výdajová) nebo událost příjmu či výdeje z pokladny. Události změny stavu peněz mohou být v referenční, ale i v jakékoliv zvolené zahraniční měně. Jednotlivé události se vstupují procesně, tzn. v této činnosti je nelze vkládat, ale pouze prohlížet (např. na výdej z pokladny je nadefinován druh procesu „ZSVH01 - VPD – nákup za hotové“).

Po spuštění činnosti Události změny stavu peněz má uživatel nejprve možnost zvolit si nadefinováním výběru množinu dat seznamu událostí změn stavu peněz, kterou chce prohlížet.

Kromě popisu události o změně stavu peněz, poplatků v zahraničí a tuzemsku, důvodu, titulu, variabilních symbolů, konstantního symbolu, avíza a selektorů jsou veškeré atributy dostupné pouze v operaci (tzn. nejsou dostupné pro případnou opravu).

Atributy, která má uživatel viditelné na formuláři (a které zároveň vstupuje při procesním vytváření událostí) jsou následující:

¨ příjem / výdej - příznak, zda se jedná o příjem či výdej (Credit / Debet). Lze vybrat z překryvného seznamu.

¨ datum - datum výpisu z banky / příkazu k úhradě (musí být uvedeno). Lze změnit kliknutím pravého tlačítka myši.

¨ popis - popis události (musí být uvedeno).

¨ adresát - identifikace adresáta (musí být uvedeno). Lze vybrat z adresáře klávesou F2. Číslo spojení adresáta (musí být uvedeno). Lze vybrat ze seznamu klávesou F2. Identifikátor spojení na bankovní účet adresáta (musí být uvedeno). Lze vybrat ze seznamu klávesou F2. Sám se předplní název adresáta.

¨ účet / pokladna - identifikace účtu / pokladny (musí být vyplněno). Lze vybrat ze seznamu klávesou F2. Sám se doplní název účtu / pokladny.

¨ č. účtu - číslo bankovního účtu adresáta a kód banky.

¨ měna - kód měny - oceňovací jednotky (musí být vyplněno). Lze vybrat ze seznamu klávesou F2. Kód referenční měny (předplní se z parametrů oceňování).

¨ kurz - kurz oceňovací jednotky vůči referenční měně. Pokud k aktuálnímu dni kurz existuje, předplní se tento. Toto platí jen, je-li v parametrech oceňování zaškrtnuto „Předplňovat kurz pouze, je-li aktuální“. Jinak se předplní poslední nejnovější kurz. Množství oceňovací jednotky v kurzu se předplní automaticky.

¨ částka v ZM - částka k úhradě / inkasu v zahraniční měně. Pokud se nevyplní, automaticky se dopočte, podle kurzu, po zadání Částky v RM (zahraniční měna – jakákoliv měna, která se liší od měny referenční. V této měně může být veden účet či pokladna a dále se může objevovat v událostech souvisejících s nákupem, prodejem, .... Obvykle je uváděn kurz mezi touto měnou a referenční měnou).

¨ částka v RM - částka k úhradě / inkasu v referenční měně (musí být uvedeno). Automaticky se dopočte, podle kurzu, po zadání Částky v ZM (referenční měna – při aplikaci informačního systému v České republice je to CZK. V této měně se vede účetnictví a ve všech činnostech, kde se objevuje zahraniční měna je uváděn kurz vůči této měně. Identifikace referenční měny se nastavuje v činnosti Parametry oceňování - Informační centrum – Oceňování).

¨ částka v MÚ – částka v měně účtu – částka úhrady v měně, která je definovaná jako měna bankovního účtu. Je to hodnota o kterou se sníží (zvýší) stav účtu (jeho aktuální hodnota) uvedený v dané události. Může nastat situace, že na účet přijde částka v jiné měně než v jaké je účet veden.

¨ VS – variabilní symbol úhrady (povinný údaj u párovaných úhrad). Důležitý atribut pro správné spárování úhrady s platbou. Je nutno ho vyplňovat přesně a správně dle výpisu.

¨ KS – konstatntí symbol (není povinný údaj)

¨ důvod - důvod / účel platby. Při styku se zahraničím uvádějte cizojazyčně (musí obsahovat minimálně 10 znaků (včetně čísla faktury)).

¨ titul - platební titul.

¨ selektory - zadávají se : obchodní selektor, organizační selektor a technicko-věcný selektor. Každý selektor lze vybrat z číselníku po stisku klávesy F2.

Jako události ZSP se prezentují i částky kurzových rozdílů, které jsou vytvořené koncem roku při provedení přecenění závazků a pohledávek v cizí měně. Popis přecenění závazků a pohledávek v cizí měně koncem roku je k dispozici ve slovníku pojmů (viz. zvýrazněný hypertextový odkaz).

Možnosti zobrazení jednotlivých událostí ZSP (změny stavu peněz) jsou:

¨ červená barva – znamená událost ZSP, která není dosud zaúčtovaná

¨ modrá barva (u párovaných úhrad) – je zaúčtovaná, systém však signalizuje případný problém (odlišná částka v účetnictví, ZSP a platbách)

¨ černá barva – vše OK

¨ modrá barva (u nepárovaných úhrad) – událost ZSP je zaúčtovaná, vše OK

Na záložce „další“ jsou informace o:

¨ avízu – zpráva pro příjemce (1. část a 2. část)

¨ poplatky v zahraničí - jedná se o poplatky cizích bank. Specifikuje, kdo bude hradit poplatky (OUR/BEN).

¨ v tuzemsku - poplatky v tuzemsku (viz. Poplatky v zahraničí).

Na záložce „platby“ má uživatel k dispozici informace o tom, s kterou platbou byla daná úhrada spárována. V horní části formuláře jsou údaje o úhradě, ve spodní části jsou údaje o platbě. Stiskem klávesy F9 lze spustit danou operaci platby (události plateb).

Na záložce „účetnictví“ má uživatel k dispozici informace o tom, jak byla daná úhrada zaúčtována. V horní části formuláře jsou údaje o úhradě, ve spodní části jsou údaje z komponenty účetnictví. Stiskem klávesy F9 lze spustit danou operaci účetnictví.

Datový model

  • ZPUDA Událost změny stavu peněz - výpisy a příkazy
    • ADSPOJ Spojení adresáta
      • ADADSAT Adresát
      • ADADR Adresa
    • SPPRCOD Operace procesu
      • SPTYP Druh procesu/operace
      • SPPRC Proces
    • BWUZIVAT Uživatel systému
    • SPPRISTU Přístupové právo uživatele k věci
    • PLUP Účet/pokladna (vlastní)
      • ADBUCTY Bankovní účty adresátů (alias ADBUCTY1)
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Přehled spárování | Párování událostí změny stavu peněz a plateb
F7 | Kredit a debet | Celkový součet částky v RM událostí operace
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^S | SUMy - ZP |
- | INFORMACE O VARIABILNÍM SYMBOLU | Přehledy událostí plateb a změny stavu peněz s variabilním symbolem
F2 | Adresář | Přehled adresátů
F2 | Bankovní spojení adresátů |
F2 | Banky | Číselník bank
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Vlastní účty/pokladny | Vlastní účty/pokladny

    Formulář

    Formulář činnosti - Měny a kursy
Mřížka [Změna stavu peněz]
Listovací rámeček
Stránka #1 Změna stavu peněz
 | Pořadové číslo procesu
 | Identifikace datového úložiště číselné řady procesu
 | Rok v identifikaci procesu
 | Identifikátor druhu
 | Pořadí stejného druhu operace v jednom procesu
 | Externí číslo procesu
 | Příjem/Výdej = Credit/Debet
 | Název druhu procesu
Datum | Datum výpisu z banky/příkazu k úhradě
Párov. | Bude se událost změny stavu peněz párovat na události plateb
Popis | Popis události
B.úč./pok. | Identifikace účtu/pokladny
 | Název účtu/pokladny
 | Kód banky
 | Prefix bankovního účtu adresáta
Č. účtu | Číslo bankovního účtu adresáta.
 | Pořadí události v bankovním výpisu
SS | Specifický symbol adresáta
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Identifikátor spojení na bankovní účet adresáta.
 | Název adresáta
Měna | Kód měny - oceňovací jednotky.
 | Referenční měna
Kurs | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup.
 | Množství oceňovací jednotky v kursu.
Částka v ZM | Částka k úhradě/inkasu v ZM
Částka v RM | Částka k úhradě/inkasu v RM
 | Kód měny - oceňovací jednotky.
Částka v MÚ | Částka v měně bankovního účtu / pokladny
VS | Variabilní symbol (příjemce)
 | Variabilní symbol (plátce)
KS | Konstantní symbol
Důvod | Důvod/účel platby
Titul | Platební titul
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zaúčt. | Změna stavu peněz je považována za zaúčtovanou
Stránka #2 Další
Avízo | Avízo pro příjemce (1. část)
 | Avízo pro příjemce (2. část)
Poplatky v zahraničí | Poplatky v zahraničí
v tuzemsku | Poplatky v tuzemsku
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #3 Platby
Mřížka [Platby]
Stránka #4 Účetnictví
Mřížka [Účetnictví]
Stránka #5 Výběr
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu od
Číslo procesu do | Pořadové číslo procesu do
 | Identifikátor druhu operace
Druh procesu | Identifikátor druhu procesu
Datum | Datum
do | Datum do
 | Události s charakterem credit nebo debet nebo obojí
 | Vybrat události spárované,nespárované nebo obojí
Ext.č. | Externí číslo procesu
Popis | Popis události
Adresát | Identifikace adresáta
Spojení | Číslo spojení adresáta.
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
B.účet/poklad. | Identifikace účtu/pokladny
 | Výběr událostí nad účty, pokladnami nebo bez rozlišení
Měna | Kód měny - oceňovací jednotky.
Titul | Platební titul
VS (příjemce) | Variabilní symbol (příjemce)
VS (plátce) | Variabilní symbol (plátce)
Částka v RM | Částka k úhradě/inkasu v RM
do | Částka k úhradě/inkasu v RM
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsal | Identifikace uživatele systému
Stav procesu | Zobrazit události podle stavu procesu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Změna stavu peněz] činnosti - Měny a kursy

    Mřížka [Změna stavu peněz] činnosti - Měny a kursy
Označování | Označení záznamu
CR/DB | Příjem/Výdej = Credit/Debet
Datum | Datum výpisu z banky/příkazu k úhradě
Pořadí | Pořadí události v bankovním výpisu
Účet/pokladna | Identifikace účtu/pokladny
Měna | Kód měny - oceňovací jednotky.
Částka v RM | Částka k úhradě/inkasu v RM
Částka v ZM | Částka k úhradě/inkasu v ZM
Párov. | Bude se událost změny stavu peněz párovat na události plateb
Popis | Popis události
Variabilní symbol | Variabilní symbol (příjemce)
Variabilní symbol (plátce) | Variabilní symbol (plátce)
Adresát | Identifikace adresáta
Prefix ú. | Prefix bankovního účtu adresáta
Č. účtu | Číslo bankovního účtu adresáta.
Referenční identifikace | Referenční identifikace operace
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Operace | Identifikátor druhu operace
 | Název adresáta

    Mřížka [Platby] činnosti - Měny a kursy

    Mřížka [Platby] činnosti - Měny a kursy
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh operace | Identifikátor druhu operace
Splatnost | Datum splatnosti
Částka ZP | Hodnota částky z výpisu uhrazující platbu v zahraniční měně úhrady
Částka v RM | Částka v referenční měně zaokrouhlená
Dosud uhrazeno | Dosud uhrazeno (v referenční měně)
Dosud neuhrazeno RM | Dosud neuhrazeno (v referenční měně)
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Variabilní symbol | Variabilní symbol (příjemce)
Popis | Popis platby

    Mřížka [Účetnictví] činnosti - Měny a kursy

    Mřížka [Účetnictví] činnosti - Měny a kursy
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Datum | Datum účetního případu
Účet | Identifikátor účtu účetnictví
Strana | Strana účtu MD/Dal
Částka | Finanční částka
Popis události | Popis účetní události
Částka ZM | Částka v zahraniční měně
IDP | Identifikace párování
Org. sel. | Identifikátor organizačního selektoru.

    Atributy tisku

    Základní údaje
Rok | Rok v identifikaci procesu | ZPUDA_sp33cisdr | C(4)
IČO | Identifikační číslo organizace. | ADADSAT_ad01ico | C(10)
IDÚ | Identifikace datového úložiště číselné řady procesu | ZPUDA_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | ZPUDA_sp33cisd | C(8)
Druh operace | Identifikátor druhu operace | ZPUDA_sp07idtyp | C(6)
Komponenta | Identifikace komponenty | ZPUDA_sp06idsubs | C(3)
Pořadí | Pořadí stejného druhu operace v jednom procesu | ZPUDA_sp33porad | N(2)
Externí číslo | Externí číslo procesu | SPPRC_sp33extcis | C(15)
Název druhu operace | Název druhu operace | SPTYP_sp07text | C(30)
Příjem/Výdej | Příjem/Výdej = Credit/Debet | Výpočet | C(2)
Datum | Datum výpisu z banky/příkazu k úhradě | ZPUDA_zp02dat | D
Popis | Popis události | ZPUDA_zp02text | C(40)
Kód banky | Kód banky | ZPUDA_oc02idbank | C(4)
Prefix ú. | Prefix bankovního účtu adresáta | ZPUDA_ad03pructu | C(6)
Č. účtu | Číslo bankovního účtu adresáta. | ZPUDA_ad03ucet | C(34)
Účet/pokladna | Identifikace účtu/pokladny | ZPUDA_pl01id | C(6)
Částka v ZM | Částka k úhradě/inkasu v ZM | ZPUDA_zp02czm | N(20,4)
Částka v RM | Částka k úhradě/inkasu v RM | ZPUDA_zp02crm | N(20,4)
Měna účtu | Kód měny - oceňovací jednotky. | ZPUDA_oc01id2 | C(3)
Částka v MÚ | Částka v měně bankovního účtu / pokladny | ZPUDA_zp02cum | N(20,4)
Měna | Kód měny - oceňovací jednotky. | ZPUDA_oc01id | C(3)
Kurs | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup. | ZPUDA_oc03kurz | N(20,6)
Množství | Množství oceňovací jednotky v kursu. | ZPUDA_oc03mn | N(5)
Poplatky v zahraničí | Poplatky v zahraničí | Výpočet | C(3)
Poplatky v tuzemsku | Poplatky v tuzemsku | Výpočet | C(3)
Důvod | Důvod/účel platby | ZPUDA_zp02ucel | C(35)
Titul | Platební titul | ZPUDA_zp02titul | C(3)
Variabilní symbol | Variabilní symbol (příjemce) | ZPUDA_pl02vs | C(10)
Variabilní symbol (plátce) | Variabilní symbol (plátce) | ZPUDA_pl02vs1 | C(10)
Konstantní symbol | Konstantní symbol | ZPUDA_pl02ks | C(4)
Avízo | Avízo pro příjemce (1. část) | ZPUDA_zp02avizo1 | C(70)
Avízo | Avízo pro příjemce (2. část) | ZPUDA_zp02avizo2 | C(70)
Adresát | Identifikace adresáta | ZPUDA_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
DIČ | Daňové identifikační číslo adresáta. | ADADSAT_ad01dico | C(16)
Referenční identifikace | Referenční identifikace operace | SPPRCOD_sp34frefid | C(40)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
Byt | Ulice bytu adresáta (včetně čísla popisného) | ADADR_ad02byt | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)
Stát | Identifikace státu. | ADADR_ad05id | C(3)
Datum a čas zápisu | Datum a čas zápisu záznamu události | ZPUDA_sp00datzap | T

    Viz.také

    Přehled spárování | Kredit a debet | OZNAČOVÁNÍ | SUMy - ZP | INFORMACE O VARIABILNÍM SYMBOLU | Adresář | Bankovní spojení adresátů | Banky | Druhy operací | Druhy procesů | Kategorie adresátů | Měny a kursy | Obchodní selektor | Organizační selektor | Spojení adresátů | Technicko-věcný selektor | Vlastní účty/pokladny | Parametry operací ZSP | Spuštění vstupu


Aktuální hodnoty ZSP

Popis

Tato činnost poskytuje uživateli přehled aktuálních hodnot ZSP, tzn. aktuální hodnotu prostředků, které má uživatel v daný okamžik k dispozici na účtě nebo v pokladně. Zobrazené údaje je možno vyfiltrovat na záložce Výběr, např. pouze za určitou pokladnu nebo účet nebo za konkrétní měnu apod.

Datový model

  • ZPAH Aktuální hodnota změny stavu peněz
    • ADADSAT Adresát
    • PLUP Účet/pokladna (vlastní)
      • SPPRISTU Přístupové právo uživatele k věci
    • SPSTATDI Druh hodnoty
    • OCMENA Měna

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresář | Přehled adresátů
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Vlastní účty/pokladny | Vlastní účty/pokladny

    Formulář

    Formulář činnosti - Kategorie adresátů
Mřížka [Aktuální hodnoty]
Listovací rámeček
Stránka #1 Aktuální hodnoty
Druh | Identifikace druhu hodnoty
 | Název druhu hodnoty
Adresát | Identifikace adresáta
 | Název adresáta
Měna | Kód měny - oceňovací jednotky.
 | Název měny
B.úč./pok. | Identifikace účtu/pokladny
 | Název účtu/pokladny
Hodnota | Aktuální hodnota změny stavu peněz
Stránka #2 Výběr
Druh hodnoty | Identifikace druhu hodnoty
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
B.účet/pokladna | Identifikace účtu/pokladny
 | Název účtu/pokladny
Měna | Kód měny - oceňovací jednotky.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Aktuální hodnoty] činnosti - Kategorie adresátů

    Mřížka [Aktuální hodnoty] činnosti - Kategorie adresátů
Druh hodnoty | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Adresát | Identifikace adresáta
Měna | Kód měny - oceňovací jednotky.
Účet/pokladna | Identifikace účtu/pokladny
Název účtu/pokladny | Název účtu/pokladny
Hodnota | Aktuální hodnota změny stavu peněz
Název adresáta | Název adresáta

    Atributy tisku

    Základní údaje
Druh hodnoty | Identifikace druhu hodnoty | ZPAH_sp67id | C(3)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)
Adresát | Identifikace adresáta | ZPAH_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Měna | Kód měny - oceňovací jednotky. | ZPAH_oc01id2 | C(3)
Název měny | Název měny | OCMENA_oc01nazev | C(18)
Účet/pokladna | Identifikace účtu/pokladny | ZPAH_pl01id | C(6)
Název účtu/pokladny | Název účtu/pokladny | PLUP_pl01text | C(40)
Hodnota | Aktuální hodnota změny stavu peněz | ZPAH_zp02hodnot | N(20,4)

    Viz.také

    Adresář | Druhy hodnot | Kategorie adresátů | Měny a kursy | Vlastní účty/pokladny


Obraty na účtech ZSP

Popis

U této činnosti je nejprve třeba si rozhodnout, jaké údaje chce mít uživatel k dispozici a podle toho správně nastavit filtr na záložce Výběr. Jako u jiných výběrových záložek je možno si vybírat z několika atributů, na základě kterých se budou data filtrovat. Kromě těch běžných jako je datum, druh hodnoty, adresát, b.účet/pokladna je zde atribut, který má zásadní význam pro zobrazení dat obratů. Tento atribut se nazývá „poslední obrat“ a dosahuje těchto hodnot:

¨ neurčeno - zobrazuje veškeré obraty nezávisle na období (tzn. není nutno zadávat žádné období od - do). Tuto hodnotu je vhodné využít např. při zobrazení hodnot za vybraný b.účet/pokladnu nebo adresáta.

¨ zahrnout - hodnota zahrnout naopak úzce souvisí s obdobím od - do. Při použití hodnoty zahrnout je zároveň nutno zadat období OD - DO a systém pak zobrazí obraty za dané období s tím, že pokud u některého b.účtu/pokladny nenajde obrat v zadaném období OD - DO, zobrazí obrat s nejvyšším nižším datem

¨ pouze - hodnotu pouze má smysl používat nikoliv pro zjišťování obratů, ale pro zjištění konečných stavů s tím, že zároveň s touto hodnotou musí být uvedeno období DO (období OD zůstává nevyplněné).

Datový model

  • ZPOBRAT Obrat účtu ZP
    • SPSTATDI Druh hodnoty
    • ADADSAT Adresát
    • PLUP Účet/pokladna (vlastní)
      • SPPRISTU Přístupové právo uživatele k věci
    • OCMENA Měna

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresář | Přehled adresátů
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Vlastní účty/pokladny | Vlastní účty/pokladny

    Formulář

    Formulář činnosti - Kategorie adresátů
Mřížka [Obraty na účtech]
Listovací rámeček
Stránka #1 Obraty na účtech
Datum | Datum obratu
Druh hodnoty | Identifikace druhu hodnoty
 | Název druhu hodnoty
Adresát | Identifikace adresáta
 | Název adresáta
Měna | Kód měny - oceňovací jednotky.
 | Název měny
B.účet/pokladna | Identifikace účtu/pokladny
 | Název účtu/pokladny
PS | Počáteční stav
P | Příjem
V | Výdej
KS | Konečný stav
Stránka #2 Výběr
Datum | Datum obratu
do | Datum obratu do
Poslední obrat | Zobrazení posledního obratu
Druh hodnoty | Identifikace druhu hodnoty
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
B.účet/pokladna | Identifikace účtu/pokladny
Měna | Kód měny - oceňovací jednotky.
 | Název účtu/pokladny
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Obraty na účtech] činnosti - Kategorie adresátů

    Mřížka [Obraty na účtech] činnosti - Kategorie adresátů
Druh hodnoty | Identifikace druhu hodnoty
Datum | Datum obratu
Adresát | Identifikace adresáta
Měna | Kód měny - oceňovací jednotky.
Účet/pokladna | Identifikace účtu/pokladny
Poč.stav | Počáteční stav
Příjem | Příjem
Výdej | Výdej
Kon.stav | Konečný stav
Název druhu hodnoty | Název druhu hodnoty
Název měny | Název měny
Název účtu/pokladny | Název účtu/pokladny
Název adresáta | Název adresáta

    Atributy tisku

    Základní údaje
Datum | Datum obratu | ZPOBRAT_zp11datum | D
Druh hodnoty | Identifikace druhu hodnoty | ZPOBRAT_sp67id | C(3)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)
Adresát | Identifikace adresáta | ZPOBRAT_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Měna | Kód měny - oceňovací jednotky. | ZPOBRAT_oc01id2 | C(3)
Název měny | Název měny | OCMENA_oc01nazev | C(18)
Účet/pokladna | Identifikace účtu/pokladny | ZPOBRAT_pl01id | C(6)
Název účtu/pokladny | Název účtu/pokladny | PLUP_pl01text | C(40)
Poč.stav | Počáteční stav | ZPOBRAT_zp11pstav | N(20,4)
Příjem | Příjem | ZPOBRAT_zp11prijem | N(20,4)
Výdej | Výdej | ZPOBRAT_zp11vydej | N(20,4)
Kon.stav | Konečný stav | Výpočet | N(20,4)

    Viz.také

    Adresář | Druhy hodnot | Kategorie adresátů | Měny a kursy | Vlastní účty/pokladny


Definice komunikace s bankou

Popis

Činnost definice komunikace s bankou slouží k definici přenosu dat mezi bankou a uživatelem. Při nastavování definice jsou uživateli k dispozici tyto záložky:

Hlavička definice

¨ identifikace - identifikace definice přenosů (musí být uvedeno).

¨ název definice - název definice přenosů.

¨ komentář - komentář.

Nastavení vstupu

¨ koncovka vstupních souborů - koncovka vstupních souborů

¨ podmínka - podmínka pro zpracování řádky.

¨ jméno souboru - definice jména vstupního souboru.

¨ program zpracovávající výpis - program, který explicitně zpracuje výpis z banky.

Definice položek vstupu

¨ typ položky - typ položky lze vybrat z překryvného seznamu.

¨ příkaz - příkaz položky vstupu.

¨ komentář -komentář položky vstupu.

Nastavení výstupu

¨ definice řádku - definice řádku.

¨ definice kontrolního řádku - definice kontrolního řádku.

¨ jméno souboru - definice jména výstupního souboru.

¨ formulář parametrů - formulář parametrů

¨ program dělající příkaz - externí program, který generuje příkaz.

¨ předplnění parametrů - předplnění parametrů

Proměnné

¨ Prom1 = .. Prom5 = definice nápočtu PROM1 .. PROM5

Podmíněné definice

V některých případech nepostačuje jediná definice komunikace s bankou vztažená k jednomu bankovnímu účtu (např. HVB Bank používá pro příkazy k úhradě jiný formát dat pro tuzemsko (*.cfd) a jiný formát dat pro zahraničí (*.cfa)). Na této záložce je možné zadat jiné definice komunikace, které mohou být použity namísto základní definice uvedené na první záložce formuláře. Uvádí se:

¨ přenos - text - identifikace podmíněné definice komunikace s bankou

¨ směr - překryvný seznam - Vstup/Výstup - určuje to, zda se jedná o podmíněnou definici užitou při exportu příkazu k úhradě nebo importu bankovního výpisu

¨ kód podmínky - text - kód v jazyce Foxpro - musí vracet numerickou hodnotu

¨ poznámka - libovolný text

Podmíněná definice - směr Vstup:

Uplatní se při načítání bankovního výpisu odpovídající šablonou v operaci změny stavu peněz. V proměnné _SOUBOR má kód podmínky k dispozici název souboru, který bude importován. Předpokládá se, že kód rozpozná formát importovaného souboru a vrátí numerickou hodnotu:

0 - formát neodpovídá podmíněné definici

1 (nebo větší než 0) - formát odpovídá podmíněné definici - import výpisu bude proveden podle této definice

-1 (nebo menší než 0) - byla zjištěna chyba - import nemá být vůbec proveden

Podmíněná definice - směr Výstup:

Uplatní se při vytváření příkazu k úhradě. V proměnné _PL03ROK,_PL03IDU a _PL03ID má kód podmínky k dispozici identifikátory exportovaného příkazu k úhradě. Předpokládá se, že kód rozpozná podle položek příkazu, že by měl být užit a vrátí numerickou hodnotu:

0 - podmíněná definice nemá být užita (např. její formát dat je určen pro tuzemské příkazy, ale všechny položky příkazu odkazují na zahraniční adresáty)

1 (nebo větší než 0) - podmíněná definice má být užita (např. její formát dat je určen pro tuzemské příkazy a přitom všechny položky příkazu odkazují na tuzemské adresáty)

-1 (nebo menší než 0) - byla zjištěna chyba - export nemá být vůbec proveden - (např. nedá se rozhodnout, protože položky příkazu odkazují na tuzemské i zahraniční adresáty)

V případě, že všechny podmíněné definice vrátí hodnotu 0, provede se import resp. export podle základní definice. Pokud podmíněná definice vrátí hodnotu -1, měla by o důvodu přerušení vyvolat odpovídající hlášení.

Datový model

  • ZPPRHLA Definice přenosu příkazu
    • BWUZIVAT Uživatel systému

    • Formulář

    Formulář činnosti - Knihovny vkládaného kódu
Mřížka [Definice přenosů]
Listovací rámeček
Stránka #1 Hlavička definice
Přenos | Identifikace definice přenosů
Název definice | Název definice přenosů
Komentář | Komentář
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Nastavení vstupu
Koncovka vstupních souborů | Koncovka vstupních souborů
Podmínka | Podmínka pro zpracování řádky
Jméno souboru | Definice jména vstupního souboru
Program zpracovávající výpis | Program který explicitně zpracuje výpis z banky
Stránka #3 Definice položek vstupu
Mřížka [Položky definice přenosů]
Typ položky | Typ položky
Příkaz | Příkaz
Komentář | Komentář
Stránka #4 Nastavení výstupu
Definice řádku | Definice řádku
Definice kontrolního řádku | Definice kontrolního řádku
Jméno souboru | Definice jména výstupního souboru
Formulář parametrů | Formulář parametrů
Program dělající příkaz | Externí program, který generuje příkaz
Předplnění parametrů | Předplnění parametrů
Stránka #5 Proměnné
Prom1= | Definice nápočtu PROM1
Prom2= | Definice nápočtu PROM2
Prom3= | Definice nápočtu PROM3
Prom4= | Definice nápočtu PROM4
Prom5= | Definice nápočtu PROM5
Stránka #6 Podmíněné definice
Mřížka [Podmíněné definice]
Přenos | Identifikace definice přenosů
Název definice | Název definice přenosů
Směr | Směr přenosu Vstup/Výstup
Kód podmínky | Kód podmínky uplatnění přenosu
Poznámka | Poznámka

    Mřížka [Definice přenosů] činnosti - Knihovny vkládaného kódu

    Mřížka [Definice přenosů] činnosti - Knihovny vkládaného kódu
Přenos | Identifikace definice přenosů
Název definice | Název definice přenosů

    Mřížka [Položky definice přenosů] činnosti - Knihovny vkládaného kódu

    Mřížka [Položky definice přenosů] činnosti - Knihovny vkládaného kódu
Typ položky | Typ položky
Příkaz | Příkaz

    Mřížka [Podmíněné definice] činnosti - Knihovny vkládaného kódu

    Mřížka [Podmíněné definice] činnosti - Knihovny vkládaného kódu
Směr | Směr přenosu Vstup/Výstup
Přenos | Identifikace definice přenosů
Název definice | Název definice přenosů

    Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností
F2 | Definice komunikace s bankou | Vstup definic pro vytvoření souborů pro elektronický styk s bankou

    Viz.také

    Knihovny vkládaného kódu | Aktuální hodnoty ZSP | Spuštění vstupu | Spuštění výstupu


Základní druhy hodnot ZSP

Popis

V této činnosti má uživatel možnost nastavit hodnotu množství ve finančním vyjádření na jednu z aktuálních hodnot (obvykle je to hodnota STU). Nastavení této hodnoty přímo souvisí s atributem „debet“ v činnosti Bankovní spojení adresátů.

V událostech změny stavu peněz potom při vkládání událostí dochází k následující kontrole:

¨ jestliže je atribut „debet“ zaškrtnut, pak se stav pokladny (podle výše uvedené aktuální hodnoty) při zadávání události nekontroluje

¨ jestliže atribut „debet“ zaškrtnut není, pak se stav pokladny (podle výše uvedené aktuální hodnoty) při zadávání události KONTROLUJE. V případě, že by se zápisem události dosáhlo záporných hodnot v pokladně, program zobrazí chybové hlášení a neumožní uživateli takovou událost zapsat.

Datový model

  • ZPPARZSP Parametry změny stavu peněz

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druhy hodnot | Seznam druhů statistických informací

    Formulář

    Formulář činnosti - Druhy hodnot
Množství ve finačním vyjádření | Identifikace druhu hodnoty
 | Název druhu hodnoty
Změnil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události

    Viz.také

    Druhy hodnot


ODPISY A OPRAV.POL. POHLEDÁVEK

Popis

Tato komponenta je určena k evidenci neuhrazených pohledávek, na které je možné uplatnit odpis nebo opravné položky. Mezi nejvýznamnější atributy této komponenty patří kromě standardních odepsat procento z ceny pohledávky, finanční částka a výchozí cena a atribut, zda dochází ke změně stavu pohledávky. S komponentou Platby sdílí tato komponenta tabulku s vazbou karty odepisované pohledávky a události platby, na základě které byla založena.

Viz.také

Změny odpisovaného majetku | Karty pohledávek | Tabulka koeficientů | Parametry odpisů a opr.pol.


Karty pohledávek

Popis

Uživateli se nabízejí jednotlivé vytvořené karty odpisů a opravných položek. Karty se zde nezadávají ručně, ale vstupují se přes události plateb. Na událostech plateb si uživatel vhodným filtrem (obecný výběr „pro tvorbu opravných položek“ a datum splatnosti dle zákona o rezervách) zvolí pohledávky, které odpovídají podmínkám, za kterých je možno kartu pohledávky vytvořit a na dané platbě uživatel aktivuje klávesu Ctrl K (nebo z menu Volby zvolí příslušnou činnost), tím se přepne do činnosti karty pohledávek, kde stiskne klávesu F3 (nebo ikonu pro vstup nového záznamu) a karta pohledávky se podle vybrané platby zčásti předplní.

Do identifikace karty pohledávky se předplní variabilní symbol platby, je nutno vybrat tabulku, která určuje konkrétní způsoby vytváření opravných položek a dále datum, ke kterému se opravná položka zakládá. Atribut výše pohledávky udává hodnotu pohledávky v okamžiku založení karty. Tato je dále aktualizovaná událostmi komponenty (rozpouštění opravné položky při úhradě). Pro daňový odpis se uvádí procento ročního odpisu (10%, 20%) a tabulka pomlčka s druhem pohledávky odpis. Procento odpisu pro účetní odepisování se uvádí na druhé záložce (aktualizované identifikace dle koeficientů zákona je nutno na kartách ručně vyměnit).

V přehledu karet pohledávek jsou šedě zbarveny ty karty, kde došlo k úhradě pohledávky (i částečné).

U každé karty jsou tedy k dispozici následující atributy:

¨ artikl - identifikace a název artiklu (předplní se variabilní symbol faktury, druh artiklu je nutno dopsat)

¨ název artiklu – předplněno číslo procesu dané platby

¨ datum splatnosti - předplněno z pohledávky

¨ stav - předplní se na aktuální (neaktuální se zvolí v případě, že pominou důvody pro existenci opravné položky, ale kartu pohledávky není možno zrušit, protože již proběhly některé změny)

¨ druh pohledávky - je nutno určit zda se jedná o opravnou položku nebo odpis

¨ v případě, že se jedná o odpis, je nutno určit procento odpisu

¨ tabulka - je nutno vybrat z tabulky koeficientů ten správný způsob - zda se jedná o standardní opravnou položku nebo konkurs či soudní řízení

¨ datum vzniku karty

¨ výše pohledávky - předplní se z události plateb

Záložka "stav pohledávek" obsahuje následující informace:

¨ pohledávka - výše pohledávky

¨ účetní stav - tzn. o kolik účetně snížena, kolik zbývá po snížení a kolik % se má odepsat z pohledávky

¨ daňový stav - stejné jako o účetního stavu, pouze nás tyto informace zajímají z daňového, ne z účetního, hlediska

Na záložce "změna pohledávky" uživatel sleduje pohyby (události) karty pohledávky. Po stisku klávesy F9 lze aktivovat událost změny pohledávky. K dispozici jsou tyto údaje:

¨ číslo procesu, identifikace operace a název pohybu (účetní odpis, daňová oprávka)

¨ datum - datum, kdy se pohyb uskutečnil a doplňující popis události

¨ pohledávka - celková výše pohledávky (tj. pořizovací cena - účetní)

¨ finanční částka, která se odepisuje

Na záložce "pohledávka" jsou veškeré informace o pohledávce, které jsou zapsány při tvorbě karty z událostí plateb. Na záložce „úhrady pohledávky“ jsou k dispozici události změny stavu peněz, kterými byla pohledávka hrazena.

Poznámka: U druhu artiklu definovaném pro odpisy a opravné položky pohledávek nesmí být na záložce „výskyt artiklu“ použito žádné zaškrtávátko (jinak může docházet k problému při zápisu karty pohledávky, např. chyba „data nebyla změněna“).

Datový model

  • ODKARTA Karta
    • PLPLOD Vazba mezi platbou a kartou odpisu,opravné položky aktiva
      • PLUDA Událost plateb
        • ADADSAT Adresát (alias ADADSAT2)
    • SPARTIKN Název artiklu
    • SPSEOB Obchodní selektor
    • SPSEOR Organizační selektor
    • SPSETV Technicko-věcný selektor
    • SPARTIKD Druh artiklu
    • ODTABOPR Tabulka koeficientů oprávek

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Události správy artiklu |
F9 | Spustit operaci | Spuštění zobrazené operace
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
- | Zrušení příznaku změna platby |
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Palety barev kategorií | Palety barev kategorií
F2 | Tabulka koeficientů |
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

    Formulář činnosti - Palety barev kategorií
Mřížka [Karty pohledávek]
Listovací rámeček
Stránka #1 Karty
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Datum splatnosti | Datum splatnosti pohledávky
Stav | Aktuální / Neaktuální karta
Druh pohledávky | Druh pohledávky
Roční odpis | Procento ročního odpisu pohledávky
Tabulka | Identifikace tabulky
 | Název tabulky
Datum | Datum
Výše pohledávky | Hodnota pohledávky
Komentář | Komentář
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Stav pohledávek
Účetní stav | Účetní stav
Pohledávka | Neuhrazená část pohledávky - účetní stav
Snížena o | Částka snižující hodnotu pohledávky - účetní stav
% | Procento snížení hodnoty pohledávka - účetní stav
Po snížení | Aktuální hodnota pohledávky - účetní stav
Odepsat % z pohledávky | Odepsat % z pohledávky - účetní stav
Daňový stav | Daňový stav
Snížena o | Částka snižující hodnotu pohledávky - daňový stav
% | Procento snížení hodnoty pohledávka - daňový stav
Po snížení | Aktuální hodnota pohledávky - daňový stav
Stránka #3 Změna pohledávky
Mřížka [Změna pohledávky]
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Operace | Identifikátor druhu operace
 | Druh události - Příjem,Výdej, Úč.odpis, Daň.odpis, Tech.zhod., Úč.odpis pohledávky,Daň.odpis pohledávky,Účetní opr.pol.,Daňová opr.pol.
Datum | Datum události
Popis | Doplňující popis události
Pohledávka | Pořizovací cena - účetní
Částka | Finanční částka
Stránka #4 Pohledávka
 | Pořadové číslo procesu
 | Identifikace datového úložiště číselné řady procesu
 | Rok v identifikaci procesu
 | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Pohledávka/Závazek
 | Název druhu procesu
Datum | Datum platby
Splatnost | Datum splatnosti
Popis | Popis platby
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Identifikátor spojení na bankovní účet adresáta.
 | Název adresáta
Úč./pok. | Identifikace účtu/pokladny
 | Název účtu/pokladny
Měna | Kód měny - oceňovací jednotky.
 | Referenční měna
 | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup.
 | Množství oceňovací jednotky v kursu.
KS | Konstantní symbol
VS | Variabilní symbol (příjemce)
 | Částka v zahraniční měně nezaokrouhlená
 | Částka v zahraniční měně
 | Záloha v zahraniční měně
 | Částka v referenční měně nezaokrouhlená
 | Částka v referenční měně zaokrouhlená
 | Záloha v referenční měně
 | Dosud uhrazeno (v referenční měně)
 | Dosud neuhrazeno (v referenční měně)
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Vymáhání | Identifikace algoritmu vymáhání
Text | Identifikace textu
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Stránka #5 Úhrady pohledávky
Mřížka [Úhrady pohledávky]
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Externí číslo | Externí číslo procesu
Druh operace | Identifikátor druhu operace
 | Název druhu operace
Datum | Datum výpisu z banky/příkazu k úhradě
Variabilní symbol | Variabilní symbol (příjemce)
Částka v ZM platby | Hodnota částky z výpisu uhrazující platbu v zahraniční měně platby
Měna | Kód měny - oceňovací jednotky.
Uhrazená částka | Hodnota částky z výpisu uhrazující platbu v zahraniční měně úhrady
Měna | Kód měny - oceňovací jednotky.
Částka v RM | Částka k úhradě/inkasu v RM
Stránka #6 Výběr
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Identifikace tabulky
 | Název artiklu
VS | Variabilní symbol (příjemce)
Adresát | Identifikace adresáta
 | Název adresáta
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Stav změny | V platbách byla provedena změna
Stav | Vše / Aktuální / Neaktuální karta
Zapsal | Identifikace uživatele systému
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 | Platnost nebo neplatnost k datu
Paleta | Vybrat záznamy všech kategorií v paletě
 | Identifikace palety barev
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Karty pohledávek] činnosti - Palety barev kategorií

    Mřížka [Karty pohledávek] činnosti - Palety barev kategorií
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název | Název artiklu
Adresát | Identifikace adresáta
Název adresáta | Název adresáta

    Mřížka [Změna pohledávky] činnosti - Palety barev kategorií

    Mřížka [Změna pohledávky] činnosti - Palety barev kategorií
Datum | Datum události
Částka | Finanční částka
Pohledávka | Pořizovací cena - účetní
Druh | Druh události - Příjem,Výdej, Úč.odpis, Daň.odpis, Tech.zhod., Úč.odpis pohledávky,Daň.odpis pohledávky,Účetní opr.pol.,Daňová opr.pol.
Popis události | Doplňující popis události
Druh operace | Identifikátor druhu operace
Zm.poh. | Změna hodnoty pohledávky

    Mřížka [Úhrady pohledávky] činnosti - Palety barev kategorií

    Mřížka [Úhrady pohledávky] činnosti - Palety barev kategorií
Datum | Datum výpisu z banky/příkazu k úhradě
Částka v ZM platby | Hodnota částky z výpisu uhrazující platbu v zahraniční měně platby
Částka v RM | Částka k úhradě/inkasu v RM
Uhrazená částka | Hodnota částky z výpisu uhrazující platbu v zahraniční měně úhrady
Měna | Kód měny - oceňovací jednotky.

    Atributy tisku

    Základní údaje
Druh artiklu | Identifikace druhu artiklu | ODKARTA_sp61id | C(3)
Artikl | Identifikace artiklu | ODKARTA_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Splatnost | Datum splatnosti | PLUDA2_pl02datspl | D
Stav | Aktuální / Neaktuální karta | Výpočet | C(10)
Druh pohledávky | Druh pohledávky | Výpočet | C(15)
Roční odpis | Procento ročního odpisu pohledávky | ODKARTA_od01daodpr | N(6,2)
Tabulka | Identifikace tabulky | ODKARTA_od37id | C(6)
Název | Název tabulky | ODTABOPR_od37naztab | C(40)
Datum | Datum | ODKARTA_od01datum | D
Výše pohledávky | Hodnota pohledávky | ODKARTA_od01odpz | N(20,4)
Komentář | Komentář | ODKARTA_od01koment | M
Org. sel. | Identifikátor organizačního selektoru. | ODKARTA_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | ODKARTA_sp20idzak | C(9)
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | ODKARTA_sp00datzap | T
Pohledávka | Dosud neuhrazeno (v referenční měně) | PLUDA2_pl02crmnu | N(20,4)
Snížena o | Částka snižující hodnotu pohledávky - účetní stav | ODKARTA_od01pohzu | N(20,4)
% | Procento snížení hodnoty pohledávka - účetní stav | Výpočet | N(6,2)
Po snížení | Aktuální hodnota pohledávky - účetní stav | Výpočet | N(20,4)
Odepsat % z pohledávky | Odepsat % z pohledávky - účetní stav | ODKARTA_od01ucodpr | N(6,2)
Snížena o | Částka snižující hodnotu pohledávky - daňový stav | ODKARTA_od01pohzd | N(20,4)
% | Procento snížení hodnoty pohledávka - daňový stav | Výpočet | N(6,2)
Po snížení | Aktuální hodnota pohledávky - daňový stav | Výpočet | N(20,4)
Rok | Rok v identifikaci procesu | PLUDA2_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | PLUDA2_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | PLUDA2_sp33cisd | C(8)
Druh operace | Identifikátor druhu operace | PLUDA2_sp07idtyp | C(6)
Pořadí druhu operace | Pořadí stejného druhu operace v jednom procesu | PLUDA2_sp33porad | N(2)
P/Z | Pohledávka/Závazek | Výpočet | C(10)
Kategorie | Kategorie předepsané platby | Výpočet | C(1)
Datum platby | Datum platby | PLUDA2_pl02datpla | D
Popis platby | Popis platby | PLUDA2_pl02text | C(40)
Umístění - platby | Umístění - platby | PLUDA2_pl08id | C(6)
Identifikace textu | Identifikace textu | PLUDA2_sp88id | C(6)
Adresát | Identifikace adresáta | PLUDA2_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Účet/pokladna | Identifikace účtu/pokladny | PLUDA2_pl01id | C(6)
Účet účetnictví | Identifikátor účtu účetnictví | PLUDA2_uc01id | C(9)
Variabilní symbol | Variabilní symbol (příjemce) | PLUDA2_pl02vs | C(10)
Konstantní symbol | Konstantní symbol | PLUDA2_pl02ks | C(4)
Částka v ZM (nezaok.) | Částka v zahraniční měně nezaokrouhlená | PLUDA2_pl02czmnez | N(20,4)
Částka v ZM | Částka v zahraniční měně | PLUDA2_pl02czm | N(20,4)
Záloha v ZM | Záloha v zahraniční měně | PLUDA2_pl02zalzm | N(20,4)
Částka v RM (nezaok.) | Částka v referenční měně nezaokrouhlená | PLUDA2_pl02crmnez | N(20,4)
Částka v RM | Částka v referenční měně zaokrouhlená | PLUDA2_pl02crm | N(20,4)
Záloha v RM | Záloha v referenční měně | PLUDA2_pl02zalrm | N(20,4)
Dosud uhrazeno | Dosud uhrazeno (v referenční měně) | PLUDA2_pl02crmu | N(20,4)
Dosud neuhrazeno ZM | Dosud neuhrazeno (v zahr. měně) | PLUDA2_pl02czmnu | N(20,4)
Měna | Kód měny - oceňovací jednotky. | PLUDA2_oc01id | C(3)
Kurs | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup. | PLUDA2_oc03kurz | N(20,6)
Množství | Množství oceňovací jednotky v kursu. | PLUDA2_oc03mn | N(5)
Datum a čas zápisu | Datum a čas zápisu záznamu události | PLUDA2_sp00datzap | T
Obch. sel. | Identifikátor obchodního selektoru | PLUDA2_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | PLUDA2_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | PLUDA2_sp20idzak | C(9)
K.rozdíl | Účtovat kursový rozdíl | Výpočet | C(3)
Kurzový rozdíl - KPP | Kurzový rozdíl - kurz předepsané platby je menší než kurz úhrady | PLUDA2_pl02kpmenu | N(20,4)
Kurzový rozdíl - KPP>KÚ | Kurzový rozdíl - kurz předepsané platby je větší než kurz úhrady | PLUDA2_pl02kpvetu | N(20,4)
Vymáhání | Identifikace algoritmu vymáhání | PLUDA2_vm06id | C(6)
Vymáhat | Datum očekávaného vymáhání | PLUDA2_pl02datvym | D
Úkon vymáhání | Úkon očekávaného vymáhání | Výpočet | C(10)
Uhrazená | Příznak uhrazené platby | Výpočet | C(3)

    Při pohybu v Změny pohledávek
Rok | Rok v identifikaci procesu | ODUDAL_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | ODUDAL_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | ODUDAL_sp33cisd | C(8)
Druh operace | Identifikátor druhu operace | ODUDAL_sp07idtyp | C(6)
Pořadí druhu operace | Pořadí stejného druhu operace v jednom procesu | ODUDAL_sp33porad | N(2)
Datum | Datum události | ODUDAL_od02datum | D
Popis | Doplňující popis události | ODUDAL_od02text | C(40)
Druh | Druh události - Příjem,Výdej, Úč.odpis, Daň.odpis, Tech.zhod., Úč.odpis pohledávky,Daň.odpis pohledávky,Účetní opr.pol.,Daňová opr.pol. | Výpočet | C(20)
Pohledávka | Výchozí cena - základ výpočtu odpisu pohledávky | ODUDAL_od01pc | N(20,4)
Částka | Finanční částka | ODUDAL_od02castka | N(20,4)
Datum a čas zápisu | Datum a čas zápisu záznamu události | ODUDAL_sp00datzap | T

    Viz.také

    Události správy artiklu | Spustit operaci | Prezentace artiklu | Zrušení příznaku změna platby | Adresář | Druhy artiklů | Obchodní selektor | Organizační selektor | Palety barev kategorií | Tabulka koeficientů | Technicko-věcný selektor


Tabulka koeficientů

Popis

Jedná se o tabulku koeficientů, která se používá při zadávání nové karty pohledávky. U každé karty pohledávky je nutno zvolit podle které tabulky se bude odepisovat. Na první záložce "tabulka" jsou tedy nadefinovány jednotlivé druhy pohledávek a název tabulky, který se k ní vztahuje. Záložka "koeficienty" poskytuje uživateli přehled o tom, jaké procento se v závislosti na měsících odepisování může v dané tabulce použít.

Tabulka koeficientů se s instalací programu dodává naplněna.

Datový model

  • ODTABOPR Tabulka koeficientů oprávek

    • Formulář

    Formulář činnosti - Palety barev kategorií
Mřížka [Tabulka koeficientů]
Listovací rámeček
Stránka #1 Tabulka
Identifikace | Identifikace tabulky
Druh pohledávky | Druh pohledávky
Název | Název tabulky
Komentář | Komentář k tabulkce
Stránka #2 Koeficienty
Mřížka [Koeficienty]
Počet měsíců | Počet měsíců
Procento | Procento

    Mřížka [Tabulka koeficientů] činnosti - Palety barev kategorií

    Mřížka [Tabulka koeficientů] činnosti - Palety barev kategorií
Identifikace | Identifikace tabulky
Druh pohledávky | Druh pohledávky
Název | Název tabulky

    Mřížka [Koeficienty] činnosti - Palety barev kategorií

    Mřížka [Koeficienty] činnosti - Palety barev kategorií
Počet měsíců | Počet měsíců
Procento | Procento

    Atributy tisku

    Základní údaje
Tabulka | Identifikace tabulky | ODTABOPR_od37id | C(6)
Název | Název tabulky | ODTABOPR_od37naztab | C(40)
Komentář | Komentář k tabulkce | ODTABOPR_od37koment | M

    Při pohybu v Koeficienty
Počet měsíců | Počet měsíců | ODTABKOE_od38mesic | N(4)
Procento | Procento | ODTABKOE_od38procen | N(6,2)


Parametry odpisů a opr.pol.

Popis

Jedná se o parametry odpisů a opravných položek pohledávek. Jednotlivé údaje jsou zde předplněny automaticky systémem tak, jak on si "přečte" v jakém stavu jsou jednotlivé parametry a údaje do těchto parametrů automaticky předplní. Jediný údaj, který doplňuje uživatel sám je identifikace druhu artiklu, který má uživatel vyčleněn pro odpisy a opravné položky pohledávek.

Upozornění:

Datum inicializace je shodné pro odpisy a opravné položky pohledávek a pro odpisovaný majetek.

Formulář

Formulář činnosti - Druhy artiklů
Datum inicializace | Datum inicializace
Rok úč.odp. | Rok posledního účetního odpisu
Rok daň.odp. | Rok posledního daňového odpisu
Rok úč.opr. | Rok poslední účetní oprávky
Rok daň.opr. | Rok poslední daňové oprávky
Druh artiklu | Identifikace druhu artiklu

Vyvolávané činnosti

K. | Činnost | Popis
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy operací | Přehled druhů operací

Viz.také

Druhy artiklů | Druhy operací


MZDY A PERSONALISTIKA

Popis

Modul mzdy slouží především k evidenci a výpočtu mezd pracovníků a dalších údajů souvisejících se zpracováním a evidencí mezd.

Viz.také

PERSONALISTIKA | MZDY


PERSONALISTIKA

Popis

Neexistuje obecné použití této komponenty. Její využití je zcela závislé na potřebách organizace a na základě této analýzy nastaví její používání implementátor (např. je možné nastavit hodnoty požadavku na typová a skutečná pracovní místa, že obchodník má dostat každý druhý rok mobilní telefon, že má každý měsíc nárok na GO kupon, že 1x ročně musí projít školením apod.). Poté musí implementátor vytvořit příslušný druh procesu na evidování těchto nároků a potřeb (zároveň s tím i šablonu na vkládání těchto požadavků).

Viz.také

Událost personalistiky | Artikly personalistiky | Pracovní místa skut. a typová | Hodnoty požadavku/vlastnost | Druhy požadavků a vlastností | Přehled hodnot parametrů


Událost personalistiky

Popis

Využití komponenty personalistika je ve většině případů zcela závislé na potřebách a způsobu fungování dané organizace a na základě této analýzy se teprve nastaví její konkrétní používání v dané organizaci, např. je možné nastavit hodnoty požadavku na typová a skutečná pracovní místa, že obchodník má dostat každý druhý rok mobilní telefon, že má každý měsíc nárok na GO kupon, že 1x ročně musí projít školením apod. nebo je možné si vytvořit proces na přijetí nového pracovníka s definicí nároků na toto místo (tzn. požadavky na dosažené vzdělání, praxi, řidičské oprávnění, znalost jazyka apod.)

Na základě těchto informací se nadefinují příslušné procesy na evidování nároků a potřeb. Při aktivaci těchto procesů dochází k plnění událostí personalistiky. Uživatel má k dispozici následující údaje:

¨ identifikaci procesu (tj. číslo, druh operace)

¨ datum události a její popis

¨ adresáta

¨ adresáta – druhý adresát pro libovolné použití (např. do prvního adresáta se zaznamená kdo byl školen, v tomto druhém adresátovi je možno uvést kde byl školen)

¨ prac. funkce – týká-li se událost personalistiky určité pracovní funkce (ať už skutečné nebo typové)

¨ změna stavu – týká se procesů personalistiky, které řeší pracovní místa (tzn. přijetí nového pracovníka apod.) a mohou nabývat těchto stavů – bezy změny, v přípravě, obsazeno, neobsazeno – volné, zrušeno

¨ identifikace druhu artiklu

¨ identifikace artiklu – např. při procesu plnění nároků na určité pracovní místo je zde uveden GO kupon, mobilní telefon apod.

¨ cena za měrnou jednotku

¨ počet

¨ cena celkem

¨ libovolný komentář

Datový model

  • MZPERUDA Událost personalistiky
    • MZPRACFU Pracovní funkce - skutečné a typové
    • ADADSAT Adresát
    • SPPRCOD Operace procesu
      • SPPRC Proces
    • SPPRISTU Přístupové právo uživatele k věci
    • MZPERART Artikly personalistiky
    • ADADSAT Adresát (alias ADADSAT1)

    • Formulář

    Formulář činnosti - Adresář
Mřížka [Události personalistiky]
Listovací rámeček
Stránka #1 Události personalistiky
 | Pořadové číslo procesu
 | Identifikace datového úložiště číselné řady procesu
 | Rok v identifikaci procesu
 | Identifikátor druhu procesu
 | Pořadí stejného druhu operace v jednom procesu
Typ | Typ události
 | Název druhu procesu
Datum | Datum události
Popis | Popis události
Adresát | Identifikace adresáta
 | Název adresáta
Adresát 2 | Identifikace dalšího adresáta
 | Název adresáta
Prac.funkce | Identifikace pracovní funkce (zařazení)
 | Popis pracovní funkce (pracovního zařazení)
 | Identifikace typové pracovní funkce (zařazení)
Změna stavu | Změna stavu
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Cena | Cena za jednotku
MJ | Identifikátor měrné jednotky
Počet | Počet
Celková cena | Celková cena
Komentář | Komentář
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Výběr
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
 | Pořadové číslo procesu
 | Identifikátor druhu operace
 | Identifikátor druhu procesu
Datum od | Datum události personalistiky od
do | Datum události personalistiky do
Typ | Typ události
Popis | Popis události
Adresát | Identifikace adresáta
 | Název adresáta
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Prac.funkce | Identifikace pracovní funkce (zařazení)
 | Popis pracovní funkce (pracovního zařazení)
 | Identifikace typové pracovní funkce (zařazení)
Změna stavu | Změna stavu
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsané | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Události personalistiky] činnosti - Adresář

    Mřížka [Události personalistiky] činnosti - Adresář
Označování | Označení záznamu
Datum | Datum události
Popis | Popis události
Prac.funkce | Identifikace pracovní funkce (zařazení)
Typové místo | Identifikace typové pracovní funkce (zařazení)
Celková cena | Celková cena
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Typ | Typ události

    Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | INFORMACE O ADRESÁTOVI | Vývěska adresáta a pošta adresáta...
F2 | Adresář | Přehled adresátů
F2 | Artikly personalistiky | Artikly personalistiky
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Pracovní místa skut. a typová | Popis pracovní funkce (zařazení)
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Atributy tisku

    Základní údaje
Datum | Datum události | MZPERUDA_mz90datum | D
Popis | Popis události | MZPERUDA_mz90popis | C(60)
Typ | Typ události | Výpočet | C(1)
Prac.funkce | Identifikace pracovní funkce (zařazení) | MZPERUDA_mz31id | C(6)
Typové pracovní místo | Jednoznačná identifikace typové pracovní funkce (zařazení) | MZPERUDA_mz82id | C(6)
Adresát | Identifikace adresáta | MZPERUDA_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Obch. sel. | Identifikátor obchodního selektoru | MZPERUDA_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | MZPERUDA_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MZPERUDA_sp20idzak | C(9)
Druh operace | Identifikátor druhu operace | MZPERUDA_sp07idtyp | C(6)
Název druhu operace | Název druhu procesu | SPTYP_sp07text | C(30)
Druh artiklu | Identifikace druhu artiklu | MZPERUDA_sp61id | C(3)
Artikl | Identifikace artiklu | MZPERUDA_sp60id | C(13)
Název artiklu | Název artiklu | MZPERART_sp60artikl | C(60)
Komentář | Komentář | MZPERUDA_mz90koment | M
Množství | Množství | MZPERUDA_mz90mnozs | N(12,3)
Celková cena | Celková cena | MZPERUDA_mz90cena | N(12,3)
Změna stavu | Změna stavu | Výpočet | C(16)
Pořadí druhu operace | Pořadí stejného druhu operace v jednom procesu | MZPERUDA_sp33porad | N(2)
Komponenta | Identifikace komponenty | MZPERUDA_sp06idsubs | C(3)
Číslo procesu | Pořadové číslo procesu | MZPERUDA_sp33cisd | C(8)
IDÚ | Identifikace datového úložiště číselné řady procesu | MZPERUDA_sp33cisdpm | C(2)
Rok | Rok v identifikaci procesu | MZPERUDA_sp33cisdr | C(4)

    Při pohybu v Pracovní funkce
Popis | Popis pracovní funkce (pracovního zařazení) | MZPRACFU_mz31pracfu | C(40)
Typové místo | Identifikace typové pracovní funkce (zařazení) | MZPRACFU_mz31idt | C(6)
Stav | Stav | Výpočet | C(16)
Komentář | Komentář k popisu pracovního místa | MZPRACFU_mz31koment | M
Typ | Typ pracovního místa | Výpočet | C(8)
Tř. KZAM | Třída podle klasifikace zaměstnání | MZPRACFU_mz31kzam | C(5)
Kalendář | Jednoznačná identifikace kalendáře | MZPRACFU_mz25id | C(6)
Stupnice | Identifikace tarifní stupnice | MZPRACFU_mz23id | C(6)
Třída | Tarifní třída (1-99) | MZPRACFU_mz24trida | C(2)

    Při pohybu v Hodnoty
Druh požadavku | Identifikace druhu požadavku | MZPERS2_mz81id | C(6)
Volný údaj 1 | Volný údaj znakový | MZPERS2_mz83volny1 | C(10)
Volný údaj 2 | Volný údaj znakový | MZPERS2_mz83volny2 | C(10)
Volný údaj 3 | Volný údaj znakový | MZPERS2_mz83volny3 | C(40)
Volný údaj 4 (od) | Volný údaj numerický | MZPERS2_mz83volny4 | N(20,4)
Volný údaj 5 | Volný údaj | MZPERS2_mz83volny5 | M
Adresát | Identifikace adresáta | MZPERS2_ad01id | C(6)
Platné od | Platné od | MZPERS2_mz83datum | D

    Viz.také

    OZNAČOVÁNÍ | INFORMACE O ADRESÁTOVI | Adresář | Artikly personalistiky | Druhy artiklů | Druhy operací | Druhy procesů | Obchodní selektor | Organizační selektor | Pracovní místa skut. a typová | Technicko-věcný selektor


Artikly personalistiky

Popis

Tato činnost umožňuje uživateli zakládat, opravovat a rušit artikly, které se následně používají ve zpracování událostí personalistiky (např. při přijímání nového pracovníka na určité pracovní místo, které má nadefinované požadavky – obchodníkovi je pak s nástupem přidělen počítač, mobil apod.). U každého artiklu se definuje:

¨ druh artiklu

¨ identifikace a popis artiklu

¨ MJ – měrná jednotka ve které je artikl evidován

¨ cena artiklu

¨ technický selektor

Datový model

  • MZPERART Artikly personalistiky
    • SPARTIKN Název artiklu
    • SPSETV Technicko-věcný selektor
    • BWUZIVAT Uživatel systému
    • SPARTIKL Artikl
    • SPMJ Měrná jednotka
      • SPMJN Měrná jednotka v jazyce

    • Formulář

     | Formulář činnosti - Palety barev kategorií
 | Mřížka [Artikly personalistiky]
 |  | Identifikace druhu artiklu
 | Artikl | Identifikace artiklu
 |  | Název artiklu
 | Listovací rámeček
 | Stránka #1 Artikly personalistiky
 | MJ | Identifikátor měrné jednotky
 |  | Název měrné jednotky
 | Cena | Cena za jednotku
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 |  | Název technicko-věcného selektoru.
 | Komentář | Komentář
 |  | Datum a čas zápisu záznamu události
 | Zapsal | Jméno uživatele systému
 | Stránka #2 Kategorie artiklu
 | Mřížka [Kategorie artiklu]
 |  | Kategorie
Identifikace kategorie události správy artiklu |  |  | Platnost
Datum platnosti od |  |  | Platnost do
Datum platnosti do |  |  | Adresát
Identifikace adresáta |  |
Název adresáta |  |
Číslo spojení adresáta. |  |  | Popis
Popis události |  |  | Poznámka
Poznámka |  |  | Zapsal
Jméno uživatele systému |  |  | Datum a čas zápisu
Datum a čas zápisu záznamu události
 | Stránka #3 Výběr
 |  | Identifikace druhu artiklu
 | Artikl | Identifikace artiklu
 | Název artiklu | Název artiklu
 | MJ | Identifikátor měrné jednotky
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Zapsané | Identifikace uživatele systému
 |  | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 |  | Platnost nebo neplatnost k datu
 | Kat.artiklu | Identifikace kategorie události správy artiklu
 |  | Název kategorie události správy artiklu
 |  | Vztah ke kategorii - Je=K dnešnímu datu je v kategorii, Není=K dnešnímu datu není v kategorii, Byl=Není v kategorii, ale byl, Nebyl=Není a nikdy nebyl v kategorii,Bude=Bude v kategorii
 | Paleta | Identifikace palety barev
 | Paleta | Vybrat záznamy všech kategorií v paletě
 | Výběr | Určení výběru
 | Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Artikly personalistiky] činnosti - Palety barev kategorií

    Mřížka [Artikly personalistiky] činnosti - Palety barev kategorií
Označování | Označení záznamu
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Mřížka [Kategorie artiklu] činnosti - Palety barev kategorií

    Mřížka [Kategorie artiklu] činnosti - Palety barev kategorií
Kategorie | Identifikace kategorie události správy artiklu
Název kategorie | Název kategorie události správy artiklu
Platnost od | Datum platnosti od
Platnost do | Datum platnosti do
Adresát | Identifikace adresáta
Název adresáta | Název adresáta

    Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Události správy artiklu |
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Legenda palety barev |
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Kategorie událostí správy artiklu | Přehled kategorií událostí správy artiklu
F2 | Měrné jednotky | Číselník měrných jednotek
F2 | Palety barev kategorií | Palety barev kategorií
F2 | Spojení | Seznam spojení za adresáta.
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Atributy tisku

    Základní údaje
Druh artiklu | Identifikace druhu artiklu | MZPERART_sp61id | C(3)
Artikl | Identifikace artiklu | MZPERART_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MZPERART_sp20idzak | C(9)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(60)
Komentář | Komentář | MZPERART_mz92koment | M
MJ | Identifikátor měrné jednotky | MZPERART_sp24idmj | C(3)
Cena | Cena za jednotku | MZPERART_mz92cenaj | N(9,2)

    Viz.také

    Události správy artiklu | OZNAČOVÁNÍ | Legenda palety barev | Adresář | Druhy artiklů | Kategorie událostí správy artiklu | Měrné jednotky | Palety barev kategorií | Spojení | Technicko-věcný selektor


Pracovní místa skut. a typová

Popis

Jedná se o číselník pracovních míst skutečných a typových (přehled podle nadefinované záložky Výběr) a nadefinovaných pracovních funkcí k jednotlivým pracovním místům. Každá organizace může mít nadefinováno několik typových pracovních míst (např. obchodník, manager, technik apod.). Na základě těchto typových míst pak vznikají konkrétní skutečná pracovní místa. A ke každému pracovnímu místu lze nadefinovat k němu se vztahující pracovní funkce.

U každého pracovního místa se na záložce pracovní funkce definuje:

¨ identifikace pracovní funkce

¨ typ – typ místa skutečné/typové

¨ popis pracovní funkce

¨ typové místo – v případě, že se jedná o pracovní místo skutečné, které je definováno na základě typového místa

¨ sada – identifikátor sady parametrů

¨ tř. KZAM – třída podle klasifikace zaměstnání

¨ stav – v přípravě, obsazeno, neobsazeno – volné, zrušeno (stav se mění podle údajů v událostech personalistiky. Tzn. přijmeme-li příslušným procesem obchodníka na vytvořenou pracovní funkci obchodník, změní se automaticky stav této prac. funkce na obsazeno)

¨ jednoznačná identifikace kalendáře

¨ tarifní stupnice

¨ třída (0-99)

¨ umístění – identifikace umístění mezd

¨ organizační selektor

¨ způsob odměňování – typ mzdy měsíční, hodinová, další ...

¨ komentář

Datový model

  • MZPRACFU Pracovní funkce - skutečné a typové
    • MZKALEN Kalendář má
    • MZTARSTU Stupnice zahrnuje
    • MZTARTRI Tarifní třída
    • MZUMIST Alokace mezd - umístění
      • SPPRISTU Přístupové právo uživatele k věci
    • PASADA Sada parametrů

    • Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Hodnoty požadavku/vlastnost | Prac. místa a druhy požadavků - přiřazení
- | Pracovní poměry | Pracovní poměry
- | Obecné parametry | Obecné parametry
- | Sady parametrů | Sady parametrů
- | Přehled hodnot parametrů | Přehled hodnot parametrů
F2 | Adresář | Přehled adresátů
F2 | Artikl | Seznam artiklu
F2 | Bankovní spojení adresátů |
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Položky obecného číselníku | Položky obecného číselníku
F2 | Pracovní doba | Kalendáře a jim odpovídající měsíční fond pracovní doby.
F2 | Sady parametrů | Sady parametrů
F2 | Seznam typových pracovních míst | Seznam typových pracovních míst
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Tarifní stupnice | Mzdové tarifní stupnice a jim odpovídající tarifní třídy.
F2 | Třídy KZAM | Třídy KZAM
F2 | Umístění mezd | Umístění mezd - alokace
F2 | Výběr tar. třídy | Umožní zvolit nějakou existující tar. třídu

    Formulář

    Formulář činnosti - Třídy KZAM
Mřížka [prac. zařazení]
Listovací rámeček
Stránka #1 Pracovní funkce
Identifikace | Identifikace pracovní funkce (zařazení)
Typ | Typ pracovního místa
Prac.funkce | Popis pracovní funkce (pracovního zařazení)
Typové místo | Identifikace typové pracovní funkce (zařazení)
Sada | Identifikátor sady parametrů
Název sady | Název sady parametrů
Stav | Stav
Tř. KZAM | Třída podle klasifikace zaměstnání
Kalendář | Jednoznačná identifikace kalendáře
 | Název kalendáře
Stupnice | Identifikace tarifní stupnice
 | Popis tarifní stupnice
Třída | Tarifní třída (1-99)
 | Firemní mzda hodinová
 | Minimální mzda měsíční
Typ mzdy | Způsob odměňování - typ mzdy (měsíční, hodinová, ....)
Umístění | Identifikace umístění mezd
 | Název umístění mezd
Org. sel. | Identifikátor organizačního selektoru.
Komentář | Komentář k popisu pracovního místa
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Parametry pracovní funkce
Mřížka [Hodnoty parametrů]
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Identifikátor spojení na bankovní účet adresáta.
 | Název adresáta
ID | Identifikace položky číselníku
 | Název položky číselníku
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Text1 | Textová elementární hodnota
Dat1 | Datumová elementární hodnota 1
Dat2 | Datumová elementární hodnota 2
Num1 | Numerická elementární hodnota 1
Num2 | Numerická elementární hodnota 2
Cmb1 | Překryvný seznam elementární hodnota 1
Cmb2 | Překryvný seznam elementární hodnota 2
Poznámka | Poznámka
Platnost od | Platnost od
do | Platnost do
Stránka #3 Výběr
Identifikace | Identifikace pracovní funkce (zařazení)
Popis | Popis pracovní funkce (pracovního zařazení)
Typ | Typ pracovního místa
Stav | Stav
Umístění | Identifikace umístění mezd
Typové místo | Identifikace typové pracovní funkce (zařazení)
Organizační selektor | Identifikátor organizačního selektoru.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [prac. zařazení] činnosti - Třídy KZAM

    Mřížka [prac. zařazení] činnosti - Třídy KZAM
Označování | Označení záznamu
Identifikace | Identifikace pracovní funkce (zařazení)
Prac.funkce | Popis pracovní funkce (pracovního zařazení)
Identifikace | Jednoznačná identifikace kalendáře
Identifikace | Identifikace tarifní stupnice
Třída | Tarifní třída (1-99)
Tř. KZAM | Třída podle klasifikace zaměstnání
Umístění | Identifikace umístění mezd
Typové místo | Identifikace typové pracovní funkce (zařazení)
Typ | Typ pracovního místa
Stav | Stav

    Mřížka [Hodnoty parametrů] činnosti - Třídy KZAM

    Mřížka [Hodnoty parametrů] činnosti - Třídy KZAM
Název parametru | Název parametru
Hodnota parametru | Hodnota parametru
Platnost od | Platnost od
do | Platnost do

    Atributy tisku

    Základní údaje
Prac. funkce | Identifikace pracovní funkce (zařazení) | MZPRACFU_mz31id | C(6)
Popis | Popis pracovní funkce (pracovního zařazení) | MZPRACFU_mz31pracfu | C(40)
Stav | Stav | Výpočet | C(16)
Typové místo | Identifikace typové pracovní funkce (zařazení) | MZPRACFU_mz31idt | C(6)
Typ | Typ pracovního místa | Výpočet | C(8)
Tř. KZAM | Třída podle klasifikace zaměstnání | MZPRACFU_mz31kzam | C(5)
Kalendář | Jednoznačná identifikace kalendáře | MZPRACFU_mz25id | C(6)
Hod / den | Pracovní doba hodin / den | MZKALEN_mz25hodden | N(5,2)
Stupnice | Identifikace tarifní stupnice | MZPRACFU_mz23id | C(6)
Popis | Popis tarifní stupnice | MZTARSTU_mz23popis | C(20)
Třída | Tarifní třída (1-99) | MZPRACFU_mz24trida | C(2)
Sazba | Firemní mzda hodinová | MZTARTRI_mz24hodmzd | N(8,2)
Min. měsíční mzda | Minimální mzda měsíční | MZTARTRI_mz24minmzd | N(5)
Komentář | Komentář k popisu pracovního místa | MZPRACFU_mz31koment | M
Org. sel. | Identifikátor organizačního selektoru. | MZPRACFU_sp11idzak | C(9)
Název parametru | Název parametru | PAPARAMPR_pa02nazpar | C(40)
Název adresáta | Název adresáta | ADADSATPR_ad01adsat | C(100)
IČO | Identifikační číslo organizace. | ADADSATPR_ad01ico | C(10)
DIČ | Daňové identifikační číslo adresáta. | ADADSATPR_ad01dico | C(16)
Rodné číslo | Rodné číslo adresáta | ADADSATPR_ad01rc | C(10)
Jméno | Jméno kontaktní osoby. | ADSPOJPR_ad11jmeno | C(40)
Jméno na štítek | Jméno pracovníka na poštovní štítek | ADSPOJPR_ad11jmenop | C(100)
Telefon | Telefonní číslo | ADSPOJPR_ad11cislo | C(60)
Fax | Faxové číslo | ADSPOJPR_ad11fax | C(60)
Jiné | Jiné spojení adresáta | ADSPOJPR_ad11cisost | C(60)
Mobil | Číslo mobilního telefonu | ADSPOJPR_ad11mobil | C(60)
e-mail | E-mail spojení adresáta | ADSPOJPR_ad11email | C(60)
Kód banky | Kód banky | ADBUCTYPR_oc02idbank | C(4)
Pobočka | Název pobočky, která vede bankovní účet adresátovi. | ADBUCTYPR_ad03poboc | C(25)
Prefix ú. | Prefix bankovního účtu adresáta | ADBUCTYPR_ad03pructu | C(6)
Č. účtu | Číslo bankovního účtu adresáta. | ADBUCTYPR_ad03ucet | C(34)
Specifický symbol | Specifický symbol adresáta | ADBUCTYPR_ad03ssymb | C(10)
Měna | Kód měny - oceňovací jednotky. | ADBUCTYPR_oc01id | C(3)
Název ú. | Název účtu | ADBUCTYPR_ad03nauctu | C(20)
Název položky číselníku | Název položky číselníku | PACISPOLPR_pa08nazpol | C(40)
Název artiklu | Název artiklu | SPARTIKNPR_sp62artikl | C(60)
JČI | Jednoznačná časová identifikace | MZPRACFU_mz31 | C(12)

    Při pohybu v Hodnoty
Druh požadavku | Identifikace druhu požadavku | MZPERS2_mz81id | C(6)
Prac.funkce | Identifikace pracovní funkce (zařazení) | MZPERS2_mz31id | C(6)
Volný údaj 1 | Volný údaj znakový | MZPERS2_mz83volny1 | C(10)
Volný údaj 2 | Volný údaj znakový | MZPERS2_mz83volny2 | C(10)
Volný údaj 3 | Volný údaj znakový | MZPERS2_mz83volny3 | C(40)
Volný údaj 4 (od) | Volný údaj numerický | MZPERS2_mz83volny4 | N(20,4)
Volný údaj 5 | Volný údaj | MZPERS2_mz83volny5 | M
Adresát | Identifikace adresáta | MZPERS2_ad01id | C(6)
Platné od | Platné od | MZPERS2_mz83datum | D

    Při pohybu v Hodnoty parametrů
Parametr | Identifikátor parametru | PAHODNOT_pa02id | C(6)
Hodnota parametru | Hodnota parametru | Výpočet | C(100)
Poznámka | Poznámka | PAHODNOT_pa06koment | M
Platnost od | Platnost od | PAHODNOT_pa06datum | D
do | Platnost do | PAHODNOT_pa06datumd | D
Adresát | Identifikace adresáta | PAHODNOT_ad01id | C(6)
Spojení | Číslo spojení adresáta. | PAHODNOT_ad11cisspo | C(2)
Účet | Identifikátor spojení na bankovní účet adresáta. | PAHODNOT_ad03cisban | C(2)
Text1 | Textová elementární hodnota | PAHODNOT_pa06text1 | C(60)
Identifikace položky číselníku | Identifikace položky číselníku | PAHODNOT_pa08id | C(10)
Druh artiklu | Identifikace druhu artiklu | PAHODNOT_sp61id | C(3)
Artikl | Identifikace artiklu | PAHODNOT_sp60id | C(13)
Num1 | Numerická elementární hodnota 1 | PAHODNOT_pa06num1 | N(20,4)
Num2 | Numerická elementární hodnota 2 | PAHODNOT_pa06num2 | N(20,4)
Dat1 | Datumová elementární hodnota 1 | PAHODNOT_pa06dat1 | D
Dat2 | Datumová elementární hodnota 2 | PAHODNOT_pa06dat2 | D
Cmb1 | Překryvný seznam elementární hodnota 1 | PAHODNOT_pa06cmb1 | N(1)
Cmb2 | Překryvný seznam elementární hodnota 2 | PAHODNOT_pa06cmb2 | N(1)
Oblast | Oblast sady parametrů | PAHODNOT_pa01oblast | C(2)

    Viz.také

    OZNAČOVÁNÍ | Hodnoty požadavku/vlastnost | Pracovní poměry | Obecné parametry | Přehled hodnot parametrů | Adresář | Artikl | Bankovní spojení adresátů | Druhy artiklů | Organizační selektor | Položky obecného číselníku | Pracovní doba | Sady parametrů | Seznam typových pracovních míst | Spojení adresátů | Tarifní stupnice | Třídy KZAM | Umístění mezd | Výběr tar. třídy


Hodnoty požadavku/vlastnost

Popis

Tato činnost umožňuje uživateli evidovat konkrétní požadavky na danou pracovní funkci. Např. může zde být evidováno, že pracovní funkce obchodník musí každý rok projít školením, že 1x za rok má nárok na nový mobilní telefon apod. V podstatě lze říct, že možnost využití této funkce záleží na konkrétních zvycích a fungování každé společnosti. Nadefinované požadavky se následně využijí v oblasti personalistiky při definování jednotlivých pracovních míst.

Datový model

  • MZPERS2 Hodnoty požadavků a vlastností
    • ADADSAT Adresát

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresář | Přehled adresátů
F2 | Druhy požadavků a vlastností | Druhy požadavků a vlastností
F2 | Pracovní místa skut. a typová | Popis pracovní funkce (zařazení)

    Formulář

    Formulář činnosti - Adresář
Mřížka [Prac. místa a druhy požadavků - přiřazení]
Listovací rámeček
Stránka #1 Hodnoty požadavků a vlastností
Druh požadavku | Identifikace druhu požadavku
 | Název druhu požadavku
Prac.funkce | Identifikace pracovní funkce (zařazení)
 | Popis pracovní funkce (pracovního zařazení)
Platné od | Platné od
Volný údaj | Volný údaj znakový
Volný údaj | Volný údaj znakový
Volný údaj | Volný údaj znakový
Volný údaj | Volný údaj numerický
Volné datum | Volné datum
Volný údaj | Volný údaj
Adresát | Identifikace adresáta
 | Název adresáta
Stránka #2 Výběr
Druh požadavku | Identifikace druhu požadavku
Prac. funkce | Identifikace pracovní funkce (zařazení)
Platné k datu | Platné od
Volný údaj 1 | Volný údaj znakový
Volný údaj 2 | Volný údaj znakový
Volný údaj 3 | Volný údaj znakový
Volný údaj 4 (od) | Volný údaj numerický
Volný údaj 4 (do) | Volný údaj numerický
Adresát | Identifikace adresáta
 | Název adresáta
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Prac. místa a druhy požadavků - přiřazení] činnosti - Adresář

    Mřížka [Prac. místa a druhy požadavků - přiřazení] činnosti - Adresář
Druh požadavku | Identifikace druhu požadavku
Prac.funkce | Identifikace pracovní funkce (zařazení)
Volný údaj | Volný údaj znakový
Volný údaj | Volný údaj znakový
Volný údaj | Volný údaj znakový
Volný údaj | Volný údaj numerický
Volné datum | Volné datum

    Atributy tisku

    Základní údaje
Druh požadavku | Identifikace druhu požadavku | MZPERS2_mz81id | C(6)
Název | Název druhu požadavku | MZPERS1_mz81nazev | C(40)
Prac. funkce | Identifikace pracovní funkce (zařazení) | MZPERS2_mz31id | C(6)
Popis | Popis pracovní funkce (pracovního zařazení) | MZPRACFU_mz31pracfu | C(40)
Volný údaj 1 | Volný údaj znakový | MZPERS2_mz83volny1 | C(10)
Volný údaj 2 | Volný údaj znakový | MZPERS2_mz83volny2 | C(10)
Volný údaj 3 | Volný údaj znakový | MZPERS2_mz83volny3 | C(40)
Volný údaj 4 (od) | Volný údaj numerický | MZPERS2_mz83volny4 | N(20,4)
Volný údaj 5 | Volný údaj | MZPERS2_mz83volny5 | M
Volné datum | Volné datum | MZPERS2_mz83volny6 | D
Adresát | Identifikace adresáta | MZPERS2_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Platné od | Platné od | MZPERS2_mz83datum | D

    Viz.také

    Adresář | Druhy požadavků a vlastností | Pracovní místa skut. a typová


Druhy požadavků a vlastností

Popis

V této činnosti uživatel eviduje jednotlivé druhy požadavků a vlastností na skutečná nebo typová pracovní místa. Tyto nadefinované požadavky následně využije v činnosti Hodnoty požadavku/vlastnosti. U každého druhu se definuje:

¨ identifikace

¨ název

¨ volný znakový údaj

¨ volný numerický údaj

¨ komentář

Datový model

  • MZPERS1 Druhy požadavků a vlastností

    • Formulář

    Formulář činnosti - Adresář
Mřížka [Druhy a požadavků a vlastností]
Listovací rámeček
Stránka #1 Druhy požadavků a vlastností
Identifikace | Identifikace druhu požadavku
Název | Název druhu požadavku
Volný údaj C | Volný údaj znakový
Volný údaj N | Volný údaj numerický
Komentář | Komentář
Stránka #2 Výběr
Druh požadavku | Identifikace druhu požadavku
Název | Název druhu požadavku
Uchovat | Příznak uchování výběrového hlediska
Výběr | Určení výběru

    Mřížka [Druhy a požadavků a vlastností] činnosti - Adresář

    Mřížka [Druhy a požadavků a vlastností] činnosti - Adresář
Identifikace | Identifikace druhu požadavku
Název | Název druhu požadavku
Volný údaj C | Volný údaj znakový
Volný údaj N | Volný údaj numerický

    Atributy tisku

    Základní údaje
Druh požadavku | Identifikace druhu požadavku | MZPERS1_mz81id | C(6)
Název | Název druhu požadavku | MZPERS1_mz81nazev | C(40)
Komentář | Komentář | MZPERS1_mz81koment | M
Volný údaj C | Volný údaj znakový | MZPERS1_mz81hodn1 | C(40)
Volný údaj N | Volný údaj numerický | MZPERS1_mz81hodn2 | N(20,4)


Přehled hodnot parametrů

Popis

Tato činnost poskytuje uživateli komplexní přehled (je možnost ho pomocí záložky výběr specifikovat) o nadefinovaných obecných parametrech (které byly užity při definici sady parametrů). U každého parametru je k dispozici informace k jakému se váže objektu, jeho název, vlastní hodnota a platnost parametru (datum od – do).

V levé mřížce je zobrazen seznam sad hodnot parametrů, ve kterých existuje alespoň jeden parametr dostupný aktuálnímu uživateli s právem alespoň čtení. V pravé mřížce je seznam hodnot obecných parametrů, které jsou automaticky k objektu připojovány při zařazení parametru do sady parametrů při uvedení výskytu 1:1 nebo 1:M.

Další hodnoty parametrů může uživatel vstupovat klávesou F3, po jejímž stisku uživatel vybírá parametry ze seznamu, ve kterém se nabízejí parametry, pro které platí:

¨ parametr je uveden v odpovídající sadě parametrů

¨ a zároveň - přístupové právo k parametru podle jeho druhu je pro uživatele 'zápis'

¨ a zároveň - neexistuje žádný záznam s daným parametrem s platností vyhovující aktuálnímu datu nebo je parametr v sadě uveden s výskytem 1:M nebo 0:M

Rušení hodnot parametrů klávesou F8 je povoleno:

¨ přístupové právo k parametru podle jeho druhu je pro uživatele 'zápis'

¨ a zároveň - parametr je v sadě uveden s výskytem 0:1 nebo 0:M

nebo

¨ přístupové právo k parametru podle jeho druhu je pro uživatele 'zápis'

¨ a zároveň - parametr je v sadě uveden s výskytem 1:1 nebo 1:M

¨ a zároveň - existuje jiný záznam o hodnotě daného parametru s platností vyhovující aktuálnímu datu

Při pohybu v seznamu hodnot parametrů se vzhled formuláře mění způsobem odpovídajícím popisu elementárních hodnot parametru.

Datový model

  • PAHODNOT Hodnota parametru
    • PAPARAM Parametr (alias PAPARAMPR)
      • PADRUPAR Druh algoritmu/parametru (alias PADRUPARPR)
        • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTUPR)
    • ADSPOJ Spojení adresáta (alias ADSPOJPR)
    • ADADSAT Adresát (alias ADADSATPR)
    • ADBUCTY Bankovní účty adresátů (alias ADBUCTYPR)
    • PACISPOL Položka obecného číselníku (alias PACISPOLPR)
    • SPARTIKL Artikl (alias SPARTIKLPR)
      • SPARTIKN Název artiklu (alias SPARTIKNPR)

    • Formulář

    Formulář činnosti - Položky obecného číselníku
Mřížka [Přehled hodnot parametrů]
Listovací rámeček
Stránka #1 Přehled hodnot parametrů
Objekt | Identifikace objektu
Popis objektu | Popis objektu
Poznámka k objektu | Poznámka k objektu
Parametr | Identifikátor parametru
Název parametru | Název parametru
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Identifikátor spojení na bankovní účet adresáta.
 | Název adresáta
ID | Identifikace položky číselníku
 | Název položky číselníku
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Text1 | Textová elementární hodnota
Dat1 | Datumová elementární hodnota 1
Dat2 | Datumová elementární hodnota 2
Num1 | Numerická elementární hodnota 1
Num2 | Numerická elementární hodnota 2
Cmb1 | Překryvný seznam elementární hodnota 1
Cmb2 | Překryvný seznam elementární hodnota 2
Poznámka | Poznámka
Platnost od | Platnost od
do | Platnost do
Stránka #2 Výběr
Objekt | Identifikace objektu
Popis obj. | Popis objektu
Parametr | Identifikátor parametru
Text1 | Textová elementární hodnota
Adresát | Identifikace adresáta
 | Název adresáta
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
ID | Identifikace položky číselníku
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 | Platnost nebo neplatnost k datu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Přehled hodnot parametrů] činnosti - Položky obecného číselníku

    Mřížka [Přehled hodnot parametrů] činnosti - Položky obecného číselníku
Objekt | Identifikace objektu
Název parametru | Název parametru
Hodnota parametru | Hodnota parametru
Platnost od | Platnost od
do | Platnost do
Popis objektu | Popis objektu

    Vyvolávané činnosti

    K. | Činnost | Popis
- | Popis pro zobrazení v přehledu hodnot | Popis pro zobrazení v přehledu hodnot
F2 | Adresář | Přehled adresátů
F2 | Artikl | Seznam artiklu
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Obecné parametry | Obecné parametry
F2 | Položky obecného číselníku | Položky obecného číselníku

    Atributy tisku

    Základní údaje
Objekt | Identifikace objektu | pa06defide | C(30)
Popis objektu | Popis objektu | pa06deftxt | C(80)
Poznámka k objektu | Poznámka k objektu | pa06defmem | M
Parametr | Identifikátor parametru | PAHODNOT_pa02id | C(6)
Název parametru | Název parametru | PAPARAMPR_pa02nazpar | C(40)
Hodnota parametru | Hodnota parametru | Výpočet | C(100)
Poznámka | Poznámka | PAHODNOT_pa06koment | M
Platnost od | Platnost od | PAHODNOT_pa06datum | D
do | Platnost do | PAHODNOT_pa06datumd | D
Adresát | Identifikace adresáta | PAHODNOT_ad01id | C(6)
Název adresáta | Název adresáta | ADADSATPR_ad01adsat | C(100)
IČO | Identifikační číslo organizace. | ADADSATPR_ad01ico | C(10)
DIČ | Daňové identifikační číslo adresáta. | ADADSATPR_ad01dico | C(16)
Rodné číslo | Rodné číslo adresáta | ADADSATPR_ad01rc | C(10)
Spojení | Číslo spojení adresáta. | PAHODNOT_ad11cisspo | C(2)
Jméno | Jméno kontaktní osoby. | ADSPOJPR_ad11jmeno | C(40)
Jméno na štítek | Jméno pracovníka na poštovní štítek | ADSPOJPR_ad11jmenop | C(100)
Telefon | Telefonní číslo | ADSPOJPR_ad11cislo | C(60)
Fax | Faxové číslo | ADSPOJPR_ad11fax | C(60)
Jiné | Jiné spojení adresáta | ADSPOJPR_ad11cisost | C(60)
Mobil | Číslo mobilního telefonu | ADSPOJPR_ad11mobil | C(60)
e-mail | E-mail spojení adresáta | ADSPOJPR_ad11email | C(60)
Účet | Identifikátor spojení na bankovní účet adresáta. | PAHODNOT_ad03cisban | C(2)
Kód banky | Kód banky | ADBUCTYPR_oc02idbank | C(4)
Pobočka | Název pobočky, která vede bankovní účet adresátovi. | ADBUCTYPR_ad03poboc | C(25)
Prefix ú. | Prefix bankovního účtu adresáta | ADBUCTYPR_ad03pructu | C(6)
Č. účtu | Číslo bankovního účtu adresáta. | ADBUCTYPR_ad03ucet | C(34)
Specifický symbol | Specifický symbol adresáta | ADBUCTYPR_ad03ssymb | C(10)
Měna | Kód měny - oceňovací jednotky. | ADBUCTYPR_oc01id | C(3)
Název ú. | Název účtu | ADBUCTYPR_ad03nauctu | C(20)
Text1 | Textová elementární hodnota | PAHODNOT_pa06text1 | C(60)
Identifikace položky číselníku | Identifikace položky číselníku | PAHODNOT_pa08id | C(10)
Název položky číselníku | Název položky číselníku | PACISPOLPR_pa08nazpol | C(40)
Druh artiklu | Identifikace druhu artiklu | PAHODNOT_sp61id | C(3)
Artikl | Identifikace artiklu | PAHODNOT_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKNPR_sp62artikl | C(60)
Num1 | Numerická elementární hodnota 1 | PAHODNOT_pa06num1 | N(20,4)
Num2 | Numerická elementární hodnota 2 | PAHODNOT_pa06num2 | N(20,4)
Dat1 | Datumová elementární hodnota 1 | PAHODNOT_pa06dat1 | D
Dat2 | Datumová elementární hodnota 2 | PAHODNOT_pa06dat2 | D
Cmb1 | Překryvný seznam elementární hodnota 1 | PAHODNOT_pa06cmb1 | N(1)
Cmb2 | Překryvný seznam elementární hodnota 2 | PAHODNOT_pa06cmb2 | N(1)
Oblast | Oblast sady parametrů | PAHODNOT_pa01oblast | C(2)

    Viz.také

    Popis pro zobrazení v přehledu hodnot | Adresář | Artikl | Druhy artiklů | Obecné parametry | Položky obecného číselníku


MZDY

Popis

Tato činnost v sobě sdružuje veškeré činnosti týkající se mezd (např. kartu pracovníka, definice, speciální činnosti apod.).

Viz.také

Události mezd | Úkolové listy | Artikly mezd | Karta pracovníka | MZDY | DEFINICE | SPECIÁLNÍ ČINNOSTI | VÝKAZY | PARAMETRY | INFORMACE O PRACOVNÍKOVI | INFO K PRACOVNÍKOVI


Události mezd

Popis

K odeslání mezd do systému se používá nadefinovaných druhů událostí. Jedná se o procesní způsob zpracování, tzn. že činnost události se naplní událostmi automaticky, nikoliv ručně po stisku F3. Uživatel si v menu Nový proces – Mzdy zvolí proces, který chce aktivovat a po jeho zapsání je zároveň aktivována i činnost události mezd.

Datový model

  • MZUDALOS Událostní entita mezd
    • SPPRCOD Operace procesu
      • SPPRC Proces
    • MZKARTA Pracovník
    • MZKARTA Pracovník (alias MZKARTA3)
    • MZUMIST Alokace mezd - umístění
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)
    • SPPRISTU Přístupové právo uživatele k věci
    • ADSPOJ Spojení adresáta
      • ADADSAT Adresát

    • Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^S | SUMA - události mezd | SUMA - události mezd
F2 | Adresy | Seznam adres za adresáta.
F2 | Adresář | Přehled adresátů
F2 | Bankovní spojení adresátů |
F2 | Druh události | Druh události (mzdové)
F2 | Druhy operací | Přehled druhů operací
F2 | Karta pracovníka | Karta pracovníka
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Umístění mezd | Umístění mezd - alokace
F2 | Výběr mzdové položky | Lupa v činnosti Výplatní lístky na Identifikace mzdové položky
F2 | Výběr pracovního poměru | Výběr prac. poměru - k již zadanému pracovníkovi

    Formulář

    Formulář činnosti - Spojení adresátů
Mřížka [Události mezd]
Listovací rámeček
Stránka #1 Události
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
 | Identifikátor druhu procesu
 | Pořadí stejného druhu operace v jednom procesu
 | Název druhu procesu
 | Typ mzdové události, dle způsobu pokračování
Datum | Datum zpracovaných mezd
Mzd.pol. | Jednoznačná identifikace mzdové položky
Popis | Popis události mzdové komponenty
Účet | Identifikátor účtu účetnictví
Strana | Strana účtu MD/Dal
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Číslo p.p. | Číslo pracovního poměru
Umístění | Identifikace umístění mezd
Adresát | Identifikace adresáta
Spojení | Číslo spojení adresáta.
 | Název adresáta
Adresa | Číslo adresy adresáta.
Účet | Identifikátor spojení na bankovní účet adresáta.
KS | Konstantní symbol
VS | Variabilní symbol
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
Poznámka | Poznámka
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Výběr
 | Rok v identifikaci procesu
 | Identifikace datového úložiště
 | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Typ | Typ mzdové události, dle způsobu pokračování
Datum od | Datum od
do | Datum do
Popis | Popis události mzdové komponenty
Účet účetnictví | Identifikátor účtu účetnictví
Mzd.pol. | Jednoznačná identifikace mzdové položky
Strana | Strana účtu MD/Dal
Umístění | Identifikace umístění mezd
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Číslo p.p. | Číslo pracovního poměru
Adresát | Identifikace adresáta
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
do | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsané | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Události mezd] činnosti - Spojení adresátů

    Mřížka [Události mezd] činnosti - Spojení adresátů
Označování | Označení záznamu
Datum | Datum zpracovaných mezd
Popis | Popis události mzdové komponenty
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
Účet | Identifikátor účtu účetnictví
Strana | Strana účtu MD/Dal
Adresát | Identifikace adresáta
Účet | Identifikátor spojení na bankovní účet adresáta.
KS | Konstantní symbol
VS | Variabilní symbol
Pracovník | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Titul | Titul pracovníka (před jménem)
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh procesu | Identifikátor druhu
Pořadí | Pořadí stejného druhu operace v jednom procesu
Název druhu procesu | Název druhu procesu
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Atributy tisku

    Základní údaje
Datum | Datum zpracovaných mezd | MZUDALOS_mz41datum | D
Typ události | Typ mzdové události, dle způsobu pokračování | Výpočet | C(3)
Popis | Popis události mzdové komponenty | MZUDALOS_mz41text | C(40)
Mzd.pol. | Jednoznačná identifikace mzdové položky | MZUDALOS_mz28id | C(6)
Pracovník | Jednoznačná identifikace pracovníka | MZUDALOS_mz01id | C(6)
Číslo p.p. | Číslo pracovního poměru | MZUDALOS_mz32cispp | C(2)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Účet pro nápočet | Identifikátor účtu účetnictví | MZUDALOS_uc01id | C(9)
Strana | Strana účtu MD/Dal | Výpočet | C(3)
Adresát | Identifikace adresáta | MZUDALOS_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Účet | Identifikátor spojení na bankovní účet adresáta. | MZUDALOS_ad03cisban | C(2)
Adresa | Číslo adresy adresáta. | MZUDALOS_ad02cisadr | C(2)
Spojení | Číslo spojení adresáta. | MZUDALOS_ad11cisspo | C(2)
KS | Konstantní symbol | MZUDALOS_mz41ksymb | C(4)
VS | Variabilní symbol | MZUDALOS_mz41vsymb | C(10)
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.) | MZUDALOS_mz41kc | N(16,2)
Poznámka | Poznámka | MZUDALOS_mz41pozn | C(40)
Obch. sel. | Identifikátor obchodního selektoru | MZUDALOS_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | MZUDALOS_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MZUDALOS_sp20idzak | C(9)
Druh | Identifikátor druhu | MZUDALOS_sp07idtyp | C(6)
Pořadí | Pořadí stejného druhu operace v jednom procesu | MZUDALOS_sp33porad | N(2)
Komponenta | Identifikace komponenty | MZUDALOS_sp06idsubs | C(3)
Rok | Rok v identifikaci procesu | MZUDALOS_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | MZUDALOS_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | MZUDALOS_sp33cisd | C(8)

    Viz.také

    OZNAČOVÁNÍ | SUMA - události mezd | Adresy | Adresář | Bankovní spojení adresátů | Druh události | Druhy operací | Karta pracovníka | Obchodní selektor | Organizační selektor | Spojení adresátů | Technicko-věcný selektor | Umístění mezd | Výběr mzdové položky | Výběr pracovního poměru | Generace - UC dle org + SP org | Generace událostí - UC dle org | Generace událostí - podrobně - | Generace událostí - souhrn UC | Generace událostí - statistika | Generace událostí - statistika jednotlivě | Generace událostí - účetnictví | Generace událostí mezd - UC podrobně org.sel. | Generace událostí mezd - jen U | Generace událostí mezd-UC i PL | Generace událostí-platby- sumá


Úkolové listy

Popis

Tato činnost slouží uživateli k evidenci a prohlížení úkolových listů. Úkolové listy vytváří buď sám mistr nebo alespoň dodává podklady pro vytvoření úkolových listů mzdové účetní.

Jednotlivé úkolové listy není možno zadat přímo, je nutný vstup pomocí procesu. Uživateli pro tento případ bude stačit vytvoření jednoduchého procesu o jedné operaci (ta bude mít ve vlastnostech v diagramu procesu zatrhnut příznak "operaci automaticky neukončovat při opuštění formuláře"). Zatržením tohoto příznaku bude zajištěna možnost neustálého přidávání řádků (každý řádek většinou představuje jeden den, ale není to podmínkou, zvlášť pokud má pracovník velmi různorodou práci) v operaci až do té doby, dokud mistr úkolový list neuzavře (ukončí operaci) a nepředá ho jako podklad pro mzdy. Úkolový list se stane podkladem pro výpočet mezd až ve chvíli, kdy uživatel aktivuje činnost "načtení úkolových listů".

Při vytváření úkolového listu se tedy vstupují následující údaje:

¨ org. jedn. - organizační jednotka, do které je pracovník jemuž se vytváří úkolový list zařazen

¨ adresát - kterého adresáta se prováděný výkon týká (není povinný údaj)

¨ pracovník - který pracovník výkon provádí

¨ prac. poměr - identifikace jeho pracovního poměru

¨ mzd. pol. - výběr z číselníku mzdových položek. Jedná se o mzdovou položku, která má příznak jako příjem a je nutné takovéto zadání - v položce původ Kč/j by mělo být zadáno "úkolová dle tar. prac.", v položce výpočet Kč "výkon x Kč/j" a pod tlačítkem úkolová - tarifní musí stupnice a tarif souhlasit s údaji zadanými na kartě pracovníka (záložka prac. poměry)

¨ datum - datum, kdy je výkon prováděn

¨ od - do - tj. čas dne od a čas dne do

¨ hodin - podle zadaného času se automaticky přepočtou hodiny

¨ výkon - množství vykonané práce v úkolové mzdě

¨ Kč/j - předplní se podle zadané stupnice a tarifu u dané mzdové položky

¨ Kč - automaticky se spočítá hodnota Kč (podle zadaného výkonu a Kč/j)

Po vytvoření úkolových listů se pokračuje činností načtení úkolových listů (viz. popis ve vlastním helpu).

Datový model

  • MZUKOLLI Úkolové listy
    • MZKARTA Pracovník
    • MZMZDPOL Mzdová položka
    • ADADSAT Adresát
    • SPPRCOD Operace procesu
      • SPPRC Proces
    • SPPRISTU Přístupové právo uživatele k věci
    • MZARTIKL Artikl mezd
    • MZKARTA Pracovník (alias MZKARTA3)
    • MZUMIST Alokace mezd - umístění
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)

    • Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^S | SUMY - úkolové listy | SUMY - úkolové listy
- | INFORMACE O ARTIKLU | Přehled informací o artiklu
F2 | Adresář | Přehled adresátů
F2 | Artikly mezd | Artikly mezd - mzdová položka
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy operací | Přehled druhů operací
F2 | Karta pracovníka | Karta pracovníka
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Umístění mezd | Umístění mezd - alokace
F2 | Výběr mzdové položky | Lupa v činnosti Výplatní lístky na Identifikace mzdové položky
F2 | Výběr pracovního poměru | Výběr prac. poměru - k již zadanému pracovníkovi

    Formulář

    Formulář činnosti - INFORMACE O ARTIKLU
Mřížka [Úkolové listy]
Listovací rámeček
Stránka #1 Úkolové listy
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
 | Identifikátor druhu procesu
 | Pořadí stejného druhu operace v jednom procesu
 | Název druhu procesu
 | Stav události
 | Pořadí události v úkolovém lístku
Datum | Datum
 | Popis události vstupní komponenty
Pro koho | Identifikace adresáta, pro kterého pracovník pracuje
 | Název adresáta
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Prac. poměr | Číslo pracovního poměru
Umístění | Identifikace umístění mezd
Funkce | Identifikace pracovní funkce (zařazení)
 | Popis pracovní funkce (pracovního zařazení)
Mzd.pol. | Jednoznačná identifikace mzdové položky
 | Popis mzdové položky
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Od | Výkon práce od (čas zahájení práce)
Do | Výkon práce do (čas ukončení práce)
 | Počet hodin (výkonu práce, volna, nemoci,...)
H/D/M | Počet dnů (výkonu práce, volna, nemoci,...)
 | Počet minut (výkonu práce, volna, nemoci,...)
Přest. | Přestávka v práci - v hodinách
Výkon | Množství vykonané práce při úkolové mzdě
Kč/ j | Částka za jednotku (tarifní sazba za hodinu, sazba za jednotku výkonu,...)
Koef. | Koeficient, jímž se násobí Kč / j
 | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Výběr
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Stav | Stav události
Od data | Datum od
do data | Datum do
Popis | Popis události vstupní komponenty
Pro koho | Identifikace adresáta
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Číslo p.p. | Číslo pracovního poměru
Mzdová položka | Jednoznačná identifikace mzdové položky
Umístění | Identifikace umístění mezd
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
do | Částka do
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsal | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Úkolové listy] činnosti - INFORMACE O ARTIKLU

    Mřížka [Úkolové listy] činnosti - INFORMACE O ARTIKLU
Označování | Označení záznamu
Pracovník - OSC | Jednoznačná identifikace pracovníka
Číslo p.p. | Číslo pracovního poměru
Datum | Datum
Popis | Popis události vstupní komponenty
Od | Výkon práce od (čas zahájení práce)
Do | Výkon práce do (čas ukončení práce)
Dnů | Počet dnů (výkonu práce, volna, nemoci,...)
Hodin | Počet hodin (výkonu práce, volna, nemoci,...)
Minuty | Počet minut (výkonu práce, volna, nemoci,...)
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu

    Atributy tisku

    Základní údaje
Datum | Datum | MZUKOLLI_mz61datum | D
Popis | Popis události vstupní komponenty | MZUKOLLI_mz61text | C(40)
Pro koho | Identifikace adresáta | MZUKOLLI_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Pracovník | Jednoznačná identifikace pracovníka | MZUKOLLI_mz01id | C(6)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Prac. poměr | Číslo pracovního poměru | MZUKOLLI_mz32cispp | C(2)
Mzdová položka | Jednoznačná identifikace mzdové položky | MZUKOLLI_mz28id | C(6)
Popis mzdové položky | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Druh artiklu | Identifikace druhu artiklu | MZUKOLLI_sp61id | C(3)
Artikl | Identifikace artiklu | MZUKOLLI_sp60id | C(13)
Název artiklu | Název artiklu | MZARTIKL_sp60artikl | C(60)
Od | Výkon práce od (čas zahájení práce) | MZUKOLLI_mz61od | C(5)
Do | Výkon práce do (čas ukončení práce) | MZUKOLLI_mz61do | C(5)
Dnů | Počet dnů (výkonu práce, volna, nemoci,...) | MZUKOLLI_mz61dnu | N(6,2)
Hodin | Počet hodin (výkonu práce, volna, nemoci,...) | MZUKOLLI_mz61hodin | N(7,2)
Minuty | Počet minut (výkonu práce, volna, nemoci,...) | MZUKOLLI_mz61minuty | N(5)
Přestávka | Přestávka v práci - v hodinách | MZUKOLLI_mz61presta | N(20,2)
Výkon | Množství vykonané práce při úkolové mzdě | MZUKOLLI_mz61vykon | N(10,2)
Kč/ j | Částka za jednotku (tarifní sazba za hodinu, sazba za jednotku výkonu,...) | MZUKOLLI_mz61kc_j | N(11,4)
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.) | MZUKOLLI_mz61kc | N(24,2)
Obch. sel. | Identifikátor obchodního selektoru | MZUKOLLI_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | MZUKOLLI_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MZUKOLLI_sp20idzak | C(9)
Kalendář | Jednoznačná identifikace kalendáře | MZPRACPO_mz25id | C(6)
Hod / den | Pracovní doba hodin / den | MZKALEN_mz25hodden | N(5,2)

    Při pohybu v 12měsíců fondu pracovní doby
Měsíc dle FPD | Měsíc | MZFPD_mz26mesic | C(2)
Hodin dle FPD | Pracovních hodin v měsíci | MZFPD_mz26hodin | N(20,2)
Dnů dle FPD | Počet pracovních dnů v měsíci. | MZFPD_mz26dnu | N(20,2)

    Viz.také

    OZNAČOVÁNÍ | SUMY - úkolové listy | INFORMACE O ARTIKLU | Adresář | Artikly mezd | Druhy artiklů | Druhy operací | Karta pracovníka | Obchodní selektor | Organizační selektor | Technicko-věcný selektor | Umístění mezd | Výběr mzdové položky | Výběr pracovního poměru


Artikly mezd

Popis

Jedná se o číselník artiklů, které se používají při zpracovávání mezd. Každý artikl má u sebe uvedenu svoji identifikaci, název, výkonovou normu za časovou jednotku a příslušný technický selektor.

U každého artiklu je možno navíc evidovat jednotlivé kategorie artiklu.

Datový model

  • MZARTIKL Artikl mezd
    • SPARTIKL Artikl
    • SPARTIKN Název artiklu
    • BWUZIVAT Uživatel systému

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Události správy artiklu |
- | Legenda palety barev |
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Kategorie událostí správy artiklu | Přehled kategorií událostí správy artiklu
F2 | Palety barev kategorií | Palety barev kategorií
F2 | Spojení | Seznam spojení za adresáta.
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

     | Formulář činnosti - Kategorie událostí správy artiklu
 | Mřížka [Artikly mezd]
 |  | Identifikace druhu artiklu
 | Artikl | Identifikace artiklu
 |  | Název artiklu
 | Listovací rámeček
 | Stránka #1 Artikly mezd
 | Norma | Norma výkonu za časovou jednotku
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Komentář | Komentář - poznámka k artiklu
 |  | Datum a čas zápisu záznamu události
 | Zapsal | Jméno uživatele systému
 | Stránka #2 Kategorie artiklu
 | Mřížka [Kategorie artiklu]
 |  | Kategorie
Identifikace kategorie události správy artiklu |  |  | Platnost
Datum platnosti od |  |  | Platnost do
Datum platnosti do |  |  | Adresát
Identifikace adresáta |  |
Název adresáta |  |
Číslo spojení adresáta. |  |  | Popis
Popis události |  |  | Poznámka
Poznámka |  |  | Zapsal
Jméno uživatele systému |  |  | Datum a čas zápisu
Datum a čas zápisu záznamu události
 | Stránka #3 Výběr
 |  | Identifikace druhu artiklu
 | Artikl | Identifikace artiklu
 | Název artiklu | Název artiklu
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Zapsal | Identifikace uživatele systému
 |  | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 |  | Platnost nebo neplatnost k datu
 | Kat.artiklu | Identifikace kategorie události správy artiklu
 |  | Název kategorie události správy artiklu
 |  | Vztah ke kategorii - Je=K dnešnímu datu je v kategorii, Není=K dnešnímu datu není v kategorii, Byl=Není v kategorii, ale byl, Nebyl=Není a nikdy nebyl v kategorii,Bude=Bude v kategorii
 | Paleta | Identifikace palety barev
 | Paleta | Vybrat záznamy všech kategorií v paletě
 | Výběr | Určení výběru
 | Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Artikly mezd] činnosti - Kategorie událostí správy artiklu

    Mřížka [Artikly mezd] činnosti - Kategorie událostí správy artiklu
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Mřížka [Kategorie artiklu] činnosti - Kategorie událostí správy artiklu

    Mřížka [Kategorie artiklu] činnosti - Kategorie událostí správy artiklu
Kategorie | Identifikace kategorie události správy artiklu
Název kategorie | Název kategorie události správy artiklu
Platnost od | Datum platnosti od
Platnost do | Datum platnosti do
Adresát | Identifikace adresáta
Název adresáta | Název adresáta

    Atributy tisku

    Základní údaje
Druh artiklu | Identifikace druhu artiklu | MZARTIKL_sp61id | C(3)
Artikl | Identifikace artiklu | MZARTIKL_sp60id | C(13)
Název artiklu | Název artiklu | MZARTIKL_sp60artikl | C(60)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MZARTIKL_sp20idzak | C(9)
Komentář | Komentář - poznámka k artiklu | MZARTIKL_mz73koment | M
Zapsal | Identifikace uživatele systému | MZARTIKL_bw01uziv | C(6)

    Viz.také

    Události správy artiklu | Legenda palety barev | Adresář | Druhy artiklů | Kategorie událostí správy artiklu | Palety barev kategorií | Spojení | Technicko-věcný selektor


Karta pracovníka

Popis

Po spuštění této činnosti se jako první nabídne záložka výběr. Zde má uživatel na výběr z mnoha možností … může vyhledávat pracovníky podle osobního čísla, jména, výplatního místa, podle kategorie apod. Pokud si uživatel chce přímo na prohlížení načíst všechny karty pracovníků, nebude výběrové pole vůbec zohledňovat a načte výběr prázdný.

Na kartě pracovníka má uživatel k dispozici osobní údaje o jednotlivých pracovnících (jméno, adresu, rodné číslo apod.) a údaje potřebné k evidenci mezd (pracovní poměr, srážky, půjčky, exekuce, daňová zvýhodnění apod.). Tyto informace má uživatel kompletně k dispozici i ve „stromu pracovníka“ (pod menu Volby).

Přístupová práva ke kartě pracovníka jsou řízena přes výplatní místo a pracovní poměr, tzn. přístupové právo ke kartě pracovníka má uživatel, který má přístup k výplatnímu místu, které je uvedeno na kartě a zároveň k některému z pracovních poměrů – přístupová práva k pracovnímu poměru jsou dána přístupovými právy k umístění, které je uvedeno na pracovní funkci daného pracovního poměru (nebo dosud není zařazen žádný pracovní poměr).

V následujících kapitolách si podrobněji popíšeme jednotlivé záložky činnosti karta. Údaje uvedené u každého pracovníka je pak možno vidět i v činnosti „Info k pracovníkovi“ (menu Mzdy – Mzdy).

Pracovníci

Tato záložka obsahuje základní informace o pracovníkovi, tzn. jeho osobní číslo, externí identifikátor (ten je možno využít i v případě, že organizace potřebuje u pracovníků vést druhé osobní číslo), příjmení, jméno, adresu, která zajišťuje spojení s adresářem a zařazení pracovníka k příslušnému výplatnímu místu. Protože každý pracovník je ve mzdách evidován pouze pod svým osobním číslem, ale pro spojení s okolním světem, např. pro účely vytvoření příkazu k úhradě v platbách, je nutné ho mít zaevidováno přímo v činnosti adresář. Proto je zde na této záložce vidět jeho osobní číslo, ale zároveň i identifikační číslo, pod kterým je zařazen v centrálním adresáři. U každého pracovníka v adresáři se evidují základní údaje (např. jeho jméno, adresa, bankovní účet apod.) Jednotlivý popis činností adresáře je uveden v helpu této činnosti.

Osobní údaje

Jako první jsou na této záložce k dispozici atributy, které přímo souvisí s řízením běhu výpočtu mezd. Jedná se o:

¨ zdravotní pojištění – zvolená možnost z překryvného seznamu řídí způsob výpočtu zdravotního pojištění pracovníka. Možnosti jsou:

- sledovat - nejběžnější varianta

- nesledovat - pracovník zastává veřejnou funkci, ...

- plátcem je stát (neponižovat o konstantu) - důchodce, žena na mateřské dovolené, .... Vyměř. základ zůstává, nesnižuje se o žádnou částku.

- plátcem je stát (snížit o konstantu) - invalida u firmy, které zaměstnávají více než 50% zdr. postižených,..., vyměř.základ se snižuje se o nějakou částku

¨ daňová tabulka – uvede se zde způsob, jakým bude pracovníkova mzda zdaněna. Daňová tabulka neruší povinnost správně nastavit atributy podepsal prohlášení a lze srážet (viz níže).

¨ podepsal prohlášení – tento atribut přímo řídí způsob výpočtu uplatnění zálohové daně

¨ lze srážet – tento atribut přímo řídí způsob výpočtu uplatnění srážkové daně

¨ provést roční zúčtování – pokud je zatrženo, provede se u tohoto pracovníka výpočet ročního zúčtování daně. Pokud zatrženo není, znamená to, že pracovník si přiznání daně provádí sám, mimo firmu.

Další údaje, které jsou zde k dispozici slouží částečně i jako podklad pro hlášení RELDP:

¨ rodné číslo

¨ číslo občanského průkazu

¨ rodné příjmení

¨ datum narození

¨ místo narození

¨ státní příslušnost

¨ stav – tzn. rodinný stav (možno vybrat z překryvného seznamu)

¨ počet dětí

¨ informace, zda se jedná či nejedná o pracovníka zdravotně postiženého

¨ muž/žena

¨ další příjmení – tzn. příjmení předcházející současnému příjmení

¨ v případě, že se jedná o pracujícího důchodce, tak informace o typu důchodu, od kdy ho pracovník pobírá a kolik Kč

Tyto vyplněné údaje mohou mít vliv na uživatelem nadefinované sestavy, které si vytvořil pro své interní účely, některé informace se uvádějí i na mzdovém listu.

Volné údaje

Na této záložce je vhodné evidovat údaje o pracovníkovi, které nás zajímají a které nám neumožňují sledovat jiné záložky, např. údaje o dosaženém vzdělání, o provedených školeních apod. Jsou to uživatelsky nastavitelné údaje a pro jejich správné fungování je třeba mít nadefinovány sady parametrů a jejich strukturu (menu Obecné – Hodnoty parametrů objektu - Sady parametrů).

Zdravotní pojišťovny

Tato záložka poskytuje přehled o zdravotních pojišťovnách daného pracovníka. Eviduje se:

¨ zdravotní pojišťovna – tj. kód pojišťovny a číslo pod kterým je daná pojišťovna zařazena v adresáři IS BM (toto číslo se automaticky natáhne z karty pojišťovny)

¨ číslo pojištěnce – zadává se pouze v případě, že je odlišné od rodného čísla pracovníka

¨ datum zahájení platnosti položky

¨ datum ukončení platnosti položky

Sociální pojišťovny

Tato záložka poskytuje přehled o sociálních pojišťovnách daného pracovníka (obdobně jako se na kartě zadává u pracovníka Zdravotní pojišťovna). Z praxe je možné, aby v organizaci pracovali lidé s různými sociálními pojišťovnami. Implicitně platí, že pokud nemá pracovník v této činnosti uvedenu žádnou sociální pojišťovnu, použije se automaticky adresa pojišťovny, která je uvedena v činnosti Parametry.

Číselník zdravotní pojišťovny byl přejmenován na zdravotní a sociální pojišťovny. Jsou zde oba druhy pojišťoven zároveň, pouze odlišeny typem.

V souvislosti s vytvořením sociálních pojišťoven došlo k rozšíření vlivu atributu „způsob výpočtu sociálního pojištění“ jednotlivě nebo souhrnně (činnost Parametry, záložka Chování).

U způsobu výpočtu „jednotlivě“ dochází k těmto zaokrouhlením. Pro každou skupinu pracovníků se stejnou sociální pojišťovnou uvedenou na kartě pracovníka vznikne položka I31000 s adresátem podle sociální pojišťovny. Rozdíl součtu těchto I31000 a odvodu vypočítaného ze součtu I30000 je zapsán na adresáta podle sociální pojišťovny.

U způsobu výpočtu „souhrnně“ dochází k těmto zaokrouhlením. Za každou sociální pojišťovnu dojde k výpočtu položky I31000 ze součtu I30000. Rozdíl součtu těchto I31000 o odvodu vypočítaného z celkového součtu I30000 se zapíše s adresátem dle činnosti Parametry.

Pro skupinu pracovníků, která nemá na kartě uvedenu žádnou sociální pojišťovnu vznikne položka I31000 s adresátem dle nastavení v činnosti Parametry. Rozdíl součtu těchto I31000 a odvodu vypočítaného ze součtu I30000 se zapíše s adresátem dle činnosti Parametry.

Eviduje se:

¨ sociální pojišťovna – tj. kód pojišťovny a číslo pod kterým je daná pojišťovna zařazena v adresáři IS BM (toto číslo se automaticky natáhne z karty pojišťovny)

¨ číslo pojištěnce – zadává se pouze v případě, že je odlišné od rodného čísla pracovníka

¨ datum zahájení platnosti položky

¨ datum ukončení platnosti položky

Pracovní poměry

Tato záložka je svojí důležitostí pro pracovníka klíčová. Zadává se zde seznam pracovních poměrů pracovníka u organizace. K dispozici jsou tyto atributy:

¨ číslo p.p. – číslo prac. poměru a jeho druh (na výběr z překryvného seznamu)

¨ prac. funkce – identifikace pracovní funkce (seznam pracovních funkcí by si měla každá organizace uživatelsky nadefinovat)

¨ kalendář – identifikace kalendáře, který je platný pro daného pracovníka, je nedílnou součásti pracovního poměru a ve výpočtu mezd má zásadní vliv (např. pro výpočet FPD, minimální mzdy apod.). Při vytváření nového kalendáře se definuje jeho identifikace, název a počet hodin za den. Pak je nutno každému kalendáři v číselníku vygenerovat fond pracovní doby ve dnech nebo v měsících (menu Volby) – podle nastavení atributu „typ kalendáře“ v činnosti Parametry – záložka Chování.

¨ stupnice – identifikace tarifní stupnice. V číselníku se u každé stupnice evidují i jednotlivé tarifní třídy

¨ třída – identifikace tarifní třídy

¨ určující – možná volba Ano/Ne. Pokud má uživatel více pracovních poměrů, musí mít jeden určený jako určující.

¨ vznik p.p. – datum zahájení daného pracovního poměru

¨ typ mzdy – volbou typu mzdy se v podstatě určuje způsob odměňování (měsíční, hodinová apod.). Typ mzdy byl vyvinut pro účely hlídání překročení minimální mzdy. Je nastaven na kartě pracovníka (záložka pracovní poměry) a předplňuje se podle uvedené pracovní funkce.

¨ skončení p.p. – datum ukončení pracovního poměru

¨ zkušeb. lhůta – datum ukončení zkušební lhůty pracovníka u daného prac. poměru

Na této záložce má uživatel pod menu Volby k dispozici další důležité atributy, které je nutno u pracovníka evidovat . Jsou dostupné v činnosti:

¨ pravidelné příjmy (funkční klávesa F5)

¨ další informace (funkční klávesa F6)

¨ další informace karty (ke sledování limitu vyměřovacího základu SP, limitu vyměřovacího základu ZP, limitu penzijního a životního připojištění)

Pro snadnější zadání a zamezení opomenutí některých údajů u pracovníka je možné po zadání a uložení pracovního poměru využít možnost, kterou uživateli nabízí činnost Cyklus při vstupu nového pracovníka (menu Volby nebo funkční klávesa F7). Po aktivaci této činnosti se uživateli postupně zobrazující všechny činnosti, které je nutné v této souvislosti vyplnit.

Měsíční nezdanitelné položky

Údaje, které se zadávaly na této záložce byly platné do prosince 2005. Jednalo se o částky, o které je možné snížit základ daně – v současné době nahrazeno na záložce daňová zvýhodnění.

Roční položky

Na této záložce se evidují údaje, které jsou potřebné k provedení ročního zúčtování daně. Mzdová účetní je může vyplňovat postupně během roku. Údaje se do výpočtu zahrnou až v okamžiku, kdy je příznak „provést roční zúčtování“ nastaven na Ano (záložka osobní údaje). V této činnosti je zároveň možno zadávat v souvislosti s ročním zúčtováním daně i údaje od předchozího zaměstnavatele (mzdové položky L30000 - Loňský příjem, L31000 - Loňský odvod, L32000 - Loňská daň a L35000 - Loňský daňový bonus).

Daňová zvýhodnění

Tato záložka je platná od 1.1.2005 pro zadání zvýhodnění na děti a od 1.1.2006 pro zadání zvýhodnění i na ostatní položky. Důležité jsou tyto atributy:

¨ identifikace (identifikace, popis a druh daň. zvýhodnění. Daň. zvýh. může být charakteru měsíční, měsíční s bonusem, roční a roční s bonusem. Druh na poplatníka,na druhého z manželů,na částeč. inval. důchod,na plný inval. důchod,na průkaz ZTP/P,pro studenta,na dítě,na ZTP dítě je důležité nastavit pro spolupráci s obecně navrženými sestavami. U každého daň. zvýhodnění se dále uvádí částka a příznak, zda se má tisknout tato hodnota na výplatním lístku)

¨ datum signalizace – signalizuje datum do kdy je možno dané daňové zvýhodnění uplatňovat (např. odpočet na dítě nebo na studenta). Výpočet mezd pak toto datum zachytí a v případě potřeby upozorní, že uživatel by měl změnit datum platnosti.

Půjčky, srážky, exekuce

Na záložku půjčky doporučujeme zadávat pohledávky, které mají nepřednostní fixní charakter a u kterých se splácí jedna pevná částka každý měsíc. Při uzávěrce mezd dojde o odečtení provedené splátky půjčky od zůstatku půjčky. Datum doručení soudního rozhodnutí je povinné.

Na záložku srážky doporučujeme zadávat pouze nepohledávky, např. srážku typu „vše na účet“. Datum doručení rozhodnutí je v tomto případě nepovinný. Na záložce srážky je možné zadat příspěvek zaměstnavatele na penzijní připojištění (tj. srážka, která má v definici uvedeno Srážet – procento ze základu SP) a zároveň odvod samotného zaměstnance na penzijní připojištění (tj. jako běžnou srážku). Srážky pro penzijní připojištění je vhodné nadefinovat ve spolupráci se svým implementátorem.

Na záložku exekuce doporučujeme zadávat pohledávky přednostní či nepředností, s fixní měsíční splátkou či pohyblivou splátkou typu „tolik, kolik lze“. Datum doručení soudního rozhodnutí je povinný. Při uzávěrce mezd dojde k odečtení provedené splátky exekuce od zůstatku exekuce. Od zůstatku se odečte pouze taková částka, která byla skutečně sražena. Při tvorbě mzdových položek typu exekuce pečlivě volte první znak identifikace této mzdové položky. Podle identifikace se ve většině implementací třídí záznamy na výplatním lístku.

Ať už se jedná o půjčku, srážku či exekuci na záložce se u každé z nich zadávají tyto shodné údaje:

¨ identifikace mzdové položky (složitější nastavování, které by měl provádět pouze zkušený uživatel nebo implementátor)

¨ částka – celková exekuční částka

¨ zůstatek – exekuční částka k doplacení, její výši snižuje uzávěrka

¨ srážet – měsíční srážená exekuční částka (např. částka výživného)

¨ nedoplatek – slouží jenom pro účely výživného (jeho výši zvyšuje a snižuje uzávěrka)

¨ adresát – příjemce peněžních částek

¨ bankovní údaje příjemce

¨ typ – bankovní údaj (speciální bank.styk se spořitelnou)

¨ doručení – datum doručení exekučního rozhodnutí

¨ platnost záznamu od - do

Datový model

  • MZKARTA Pracovník
    • ADSTATY Stát
    • MZVYPMIS Výplatní místo
    • SPPRISTU Přístupové právo uživatele k věci

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Pravidelné příjmy | Pravidelné měsíční příjmy
F6 | Další informace | Další informace
F9 | Volné údaje pracovníků | Volné údaje pracovníků
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Charakter pracovníka v p. p. | Charakter pracovníka v prac. poměru - zaměstnanec, společník, ...
- | Vztahy k osobám | Vztahy k osobám
- | Pracovníci v kategoriích | Vztahy k adresátům
- | Osobní údaje | Osobní údaje o dětech, invaliditě, studiu, ...
- | Další informace - dílčí |
- | INFORMACE O PRACOVNÍKOVI |
- | Sady parametrů | Sady parametrů
- | Obecné parametry | Obecné parametry
- | Přehled volných údajů pracovníků | Přehled hodnot parametrů
- | Další informace karty |
- | Nastavení zkušební doby | Nastavení zkušební doby
- | Strom pracovníka | Strom pracovníka
F2 | Adresy adresátů | Seznam adres za adresáta.
F2 | Adresář | Přehled adresátů
F2 | Artikl | Seznam artiklu
F2 | Bankovní spojení adresátů |
F2 | Daňová zvýhodnění a slevy na dani | Daňová zvýhodnění a slevy na dani
F2 | Daňové tabulky souhrnné | Daňové tabulky souhrnné
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Exekuce | Exekuce
F2 | Kategorie pracovníků | Kategorie pracovníků
F2 | Mzdové položky použitelné jako roční | Mzdové položky použitelné jako roční
F2 | Nezdanitelné položky měsíční | U nezdaň. položek, u kterých je částka společná, uvádí uživatel 1/12
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Osoby | Osoby
F2 | Palety barev kategorií pracovníků | Palety barev kategorií pracovníků
F2 | Položky obecného číselníku | Položky obecného číselníku
F2 | Pracovní doba | Kalendáře a jim odpovídající měsíční fond pracovní doby.
F2 | Pracovní místa skut. a typová | Popis pracovní funkce (zařazení)
F2 | Půjčky | Slouží k evidenci půjček vč. jejich zůstatku, který se snižuje o uhrazené částky až do nuly
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Srážky | K evidenci pravidelných srážek
F2 | Státy | Seznam států.
F2 | Tarifní stupnice | Mzdové tarifní stupnice a jim odpovídající tarifní třídy.
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Výběr pracovního poměru | Výběr prac. poměru - k již zadanému pracovníkovi
F2 | Výběr tar. třídy | Umožní zvolit nějakou existující tar. třídu
F2 | Výplatní místa | Místa, pro která se při výplatě dělají výčetky platidel.
F2 | Zdravotní a sociální pojišťovny | Seznam zdravotních pojišťoven

    Formulář

    Formulář činnosti - Strom pracovníka
Mřížka [pracovníci]
Listovací rámeček
Stránka #1 Pracovníci
OSC | Jednoznačná identifikace pracovníka
Ext.id. | Externí identifikace pracovníka
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Titul | Titul pracovníka (před jménem)
 | Titul pracovníka (za jménem)
Výpl. místo | Jednoznačná identifikace výplatního místa
Adresát | Identifikace adresáta
Adresa | Číslo adresy adresáta.
 | Název adresáta
 | Ulice adresy adresáta (včetně čísla popisného).
 | Poštovní směrovací číslo adresy adresáta.
 | Město adresy adresáta.
 | Název výplatního místa
Komentář | Komentář - poznámka
Stránka #2 Osobní údaje
Zdravotní pojištění | Zdravotní pojištění
Podepsal prohlášení | Podepsal pracovník daňové prohlášení?
Provést roč. zúčt. | Provést roční zúčtování ?
Lze srážet | Lze u pracovníka uplatnit srážkovou daň?
Daňová tabulka | Identifikace daňové tabulky
Rodné číslo | Rodné číslo
OP | Číslo občanského průkazu
Rodné příjmení | Rodné příjmení
Dat. a místo naroz. | Datum narození
 | Místo narození
Státní příslušnost | Identifikace státu.
Název státu | Název státu.
Stav | Stav - svobodný/á,ženatý,vdaná,vdovec,vdova,rozvedený/á
Počet dětí | Počet dětí
Těžce ZTP | Těžce ZTP - Ano,Ne
Žena/muž | Žena, muž
Další příjmení | Další příjmení - předcházející k současnému příjmení
Důchod typ | Typ důchodu
Od kdy | Datum přiznání důchodu, pracovník dovršil důchodový věk
Kč | Důchod - částka
Stránka #3 Volné údaje
Mřížka [Hodnoty parametrů]
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Identifikátor spojení na bankovní účet adresáta.
 | Název adresáta
ID | Identifikace položky číselníku
 | Název položky číselníku
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Text1 | Textová elementární hodnota
Dat1 | Datumová elementární hodnota 1
Dat2 | Datumová elementární hodnota 2
Num1 | Numerická elementární hodnota 1
Num2 | Numerická elementární hodnota 2
Cmb1 | Překryvný seznam elementární hodnota 1
Cmb2 | Překryvný seznam elementární hodnota 2
Poznámka | Poznámka
Platnost od | Platnost od
do | Platnost do
Stránka #4 Zdravotní pojišťovny
Mřížka [Zdravotní pojišťovny]
Identifikace | Identifikace pojišťovny, např. 111, 121 ,...
 | Identifikace adresáta
 | Název adresáta
Číslo pojištěnce | Číslo pojištěnce ve zdravotní pojišťovně. Uvádějte pouze je-li různé od rodného čísla.
Platnost od | Datum zahájení platnosti položky
do | Datum ukončení platnosti položky
Stránka #5 Sociální pojišťovny
Mřížka [Sociální pojišťovna]
Pojišťovna | Identifikace pojišťovny, např. 111, 121 ,...
 | Identifikace adresáta
 | Název adresáta
Číslo pojištěnce | Číslo pojištěnce ve zdravotní pojišťovně. Uvádějte pouze je-li různé od rodného čísla.
Platnost od | Datum zahájení platnosti položky
do | Datum ukončení platnosti položky
Stránka #6 Pracovní poměry
Mřížka [Prac. poměr]
Číslo p.p. | Číslo pracovního poměru
 | Druh pracovního poměru
Prac. funkce | Identifikace pracovní funkce (zařazení)
 | Popis pracovní funkce (pracovního zařazení)
Kalendář | Jednoznačná identifikace kalendáře
 | Název kalendáře
Stupnice | Identifikace tarifní stupnice
 | Popis tarifní stupnice
 | Tarifní třída (1-99)
Vznik p.p. | Vznik prac. poměru
Skončení p.p. | Skončení prac. poměru
 | Způsob odměňování - typ mzdy (měsíční, hodinová, ....)
Zk.lhůta | Datum ukončení zkušební lhůty
Selektory | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Alias | Název pracovníka v pracovním poměru (alias)
Určující | Jedná se o určující prac.pom. (při více prac.poměrech)?
Stránka #7 Měs. nezdan. pol.
Mřížka [Nezdanitelné položky]
Identifikace | Jednoznačná identifikace mzdové položky
 | Popis mzdové položky
 | Částka je společná,částka je individuální
Společná částka | Kč / j
Individuální částka | Kč/ j
Datum signalizace | Datum signalizace skončení platnosti měsíční nezdanitelné položky
Platnost od | Datum zahájení platnosti položky
do | Datum ukončení platnosti položky
Stránka #8 Roční pol.
Mřížka [Nezd. p. roční]
Identifikace | Jednoznačná identifikace mzdové položky
 | Popis mzdové položky
 | Částka je společná,částka je individuální
Společná částka | Kč / j
Individuální částka | Kč/ j
Platnost od | Datum zahájení platnosti položky
do | Datum ukončení platnosti položky
Stránka #9 Daňová zvýh. a slevy
Mřížka [Daňové zvýhodnění]
Identifikace | Jednoznačná identifikace mzdové položky
 | Popis mzdové položky
Osoba | Identifikace osoby
ZTP | Je ZTP - Ano, Ne
 | Jméno a příjmení osoby
Rodné číslo | Rodné číslo
 | Částka slevy
Datum signalizace | Datum signalizace skončení platnosti měsíční nezdanitelné položky
Platnost od | Datum zahájení platnosti položky
do | Datum ukončení platnosti položky
Stránka #10 Půjčky
Mřížka [Půjčky]
Identifikace | Jednoznačná identifikace mzdové položky
 | Popis mzdové položky
Půjčka Kč | Kč/ j
Srážet | Kolik Kč se má z výplaty srážet
Zůstatek | Zůstatek půjčky
Adresát | Identifikace adresáta
 | Název adresáta
Účet | Identifikátor spojení na bankovní účet adresáta.
KS | Konstantní symbol
VS | Variabilní symbol
 | Specifický symbol adresáta
Typ | Volný typ
Komentář | Komentář
Pořadí půjčky | Pořadí uplatnění půjčky z karty ve výpočtu výplatního lístku
Doručení | Datum doručení pohledávky
Platnost od | Datum zahájení platnosti položky
do | Datum ukončení platnosti položky
Stránka #11 Srážky
Mřížka [Srážky]
Identifikace | Jednoznačná identifikace mzdové položky
 | Popis mzdové položky
Indiv. částka | Kč/ j
Spol. částka | Kč / j
S limitem do | Srážet částku s limitem ve výši ... (tj. v intervalu 0 až ...)
Srážet | Způsob srážení
Zůstatek | Zůstatek půjčky nebo zůstatek srážky "s kontrolou zůstatku"
Adresát | Identifikace adresáta
 | Název adresáta
Účet | Identifikátor spojení na bankovní účet adresáta.
KS | Konstantní symbol
 | Specifický symbol adresáta
VS | Variabilní symbol
Typ | Volný typ
Komentář | Komentář
Platnost od | Datum zahájení platnosti položky
do | Datum ukončení platnosti položky
Pořadí srážky | Pořadí uplatnění srážky z karty ve výpočtu výplatního lístku
Doručení | Datum doručení pohledávky
Stránka #12 Exekuce
Mřížka [Exekuce]
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Částka | Kč/ j
Srážet | Kolik Kč se má z výplaty srážet
Zůstatek | Zůstatek půjčky
Nedoplatek | Nedoplatek z minulého měsíce
Adresát | Identifikace adresáta
 | Název adresáta
Účet | Identifikátor spojení na bankovní účet adresáta.
KS | Konstantní symbol
VS | Variabilní symbol
 | Specifický symbol adresáta
Typ | Volný typ
Komentář | Komentář
Platnost od | Datum zahájení platnosti položky
Doručení | Datum doručení pohledávky
do | Datum ukončení platnosti položky
Stránka #13 Výběr
Pracovník - OSC | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Výpl. místo | Jednoznačná identifikace výplatního místa
 | Název výplatního místa
Zobrazit pracovníky | Zobrazit pracovníky všechny, dosud pracující, již nepracující
Externí identifikace | Externí identifikace pracovníka
 | Vztah ke kategorii - Je=K dnešnímu datu je v kategorii, Není=K dnešnímu datu není v kategorii
Kategorie | Identifikace kategorie pracovníka
 | Název kategorie pracovníka
K datu | Je nebo není v kategorii k datu
Paleta | Vybrat záznamy všech kategorií v paletě
 | Identifikace palety barev
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [pracovníci] činnosti - Strom pracovníka

    Mřížka [pracovníci] činnosti - Strom pracovníka
Označování | Označení záznamu
OSC | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Datum narození | Datum narození
Rodné číslo | Rodné číslo
Žena/muž | Žena, muž
Stav | Stav - svobodný/á,ženatý,vdaná,vdovec,vdova,rozvedený/á
Typ důchodu | Typ důchodu
Datum přiznání | Datum přiznání důchodu, pracovník dovršil důchodový věk
Ext.id. | Externí identifikace pracovníka

    Mřížka [Hodnoty parametrů] činnosti - Strom pracovníka

    Mřížka [Hodnoty parametrů] činnosti - Strom pracovníka
Název parametru | Název parametru
Hodnota parametru | Hodnota parametru
Platnost od | Platnost od
do | Platnost do

    Mřížka [Zdravotní pojišťovny] činnosti - Strom pracovníka

    Mřížka [Zdravotní pojišťovny] činnosti - Strom pracovníka
Od | Datum zahájení platnosti položky
Do | Datum ukončení platnosti položky
Pojišťovna | Identifikace pojišťovny, např. 111, 121 ,...
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Pracovník | Jednoznačná identifikace pracovníka

    Mřížka [Sociální pojišťovna] činnosti - Strom pracovníka

    Mřížka [Sociální pojišťovna] činnosti - Strom pracovníka
Od | Datum zahájení platnosti položky
Do | Datum ukončení platnosti položky
Pojišťovna | Identifikace pojišťovny, např. 111, 121 ,...
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Pracovník | Jednoznačná identifikace pracovníka

    Mřížka [Prac. poměr] činnosti - Strom pracovníka

    Mřížka [Prac. poměr] činnosti - Strom pracovníka
Číslo p.p. | Číslo pracovního poměru
Druh | Druh pracovního poměru
Prac. funkce | Identifikace pracovní funkce (zařazení)

    Mřížka [Nezdanitelné položky] činnosti - Strom pracovníka

    Mřížka [Nezdanitelné položky] činnosti - Strom pracovníka
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky

    Mřížka [Nezd. p. roční] činnosti - Strom pracovníka

    Mřížka [Nezd. p. roční] činnosti - Strom pracovníka
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky

    Mřížka [Daňové zvýhodnění] činnosti - Strom pracovníka

    Mřížka [Daňové zvýhodnění] činnosti - Strom pracovníka
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky

    Mřížka [Půjčky] činnosti - Strom pracovníka

    Mřížka [Půjčky] činnosti - Strom pracovníka
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky

    Mřížka [Srážky] činnosti - Strom pracovníka

    Mřížka [Srážky] činnosti - Strom pracovníka
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky

    Mřížka [Exekuce] činnosti - Strom pracovníka

    Mřížka [Exekuce] činnosti - Strom pracovníka
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky

    Atributy tisku

    Základní údaje
Pracovník | Jednoznačná identifikace pracovníka | MZKARTA_mz01id | C(6)
Ext.id. | Externí identifikace pracovníka | MZKARTA_mz01idext | C(20)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Rodné příjmení | Rodné příjmení | MZKARTA_mz01rodne | C(15)
Rodné číslo | Rodné číslo | MZKARTA_mz01rodc | C(11)
Číslo OP | Číslo občanského průkazu | MZKARTA_mz01cislop | C(20)
Datum narození | Datum narození | MZKARTA_mz01naroz | D
Místo narození | Místo narození | MZKARTA_mz01misnar | C(40)
Stav | Stav - svobodný/á,ženatý,vdaná,vdovec,vdova,rozvedený/á | Výpočet | C(12)
Žena/muž | Žena, muž | Výpočet | C(4)
Zdravotní pojištění | Zdravotní pojištění | Výpočet | C(27)
Podepsal prohlášení | Podepsal pracovník daňové prohlášení? | Výpočet | C(3)
Lze srážet | Lze u pracovníka uplatnit srážkovou daň? | Výpočet | C(3)
Daňová tabulka | Identifikace daňové tabulky | MZKARTA_mza7id | C(6)
Výpl. místo | Jednoznačná identifikace výplatního místa | MZKARTA_mz22id | C(6)
Provést roční zúčtování ? | Provést roční zúčtování ? | Výpočet | C(3)
Komentář | Komentář - poznámka | MZKARTA_mz01koment | M
Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,... | MZKARTA_mz70idp | C(3)
Název | Název adresáta | ADADSAT4_ad01adsat | C(100)
Počet dětí | Počet dětí | MZKARTA_mz01deti | N(2)
Typ důchodu | Typ důchodu | Výpočet | C(18)
Datum přiznání důchodu | Datum přiznání důchodu, pracovník dovršil důchodový věk | MZKARTA_mz01duchda | D
Částka důchodu | Důchod - částka | MZKARTA_mz01duchkc | N(5)
Adresát | Identifikace adresáta | MZKARTA_ad01id | C(6)
Název adresáta | Název adresáta | ADADSATE_ad01adsat | C(100)
Adresa | Číslo adresy adresáta. | MZKARTA_ad02cisadr | C(2)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)
Popis nezd. pol. měsíční | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Spol. částka nezd. p. měs. | Kč / j | MZMZDPOL_mz28kc_j | N(15,2)
Popis nezd. pol. roční | Popis mzdové položky | MZMZDPOL2_mz28mzdpol | C(40)
Spol. částka nezd. p. roč. | Kč / j | MZMZDPOL2_mz28kc_j | N(15,2)
Popis půjčky | Popis mzdové položky | MZMZDPOL3_mz28mzdpol | C(40)
Název | Název adresáta | ADADSAT3_ad01adsat | C(100)
Popis srážky | Popis mzdové položky | MZMZDPOL4_mz28mzdpol | C(40)
Způsob srážení | Způsob srážení | Výpočet | C(42)
Spol. částka srážky | Kč / j | MZMZDPOL4_mz28kc_j | N(15,2)
Název | Název adresáta | ADADSAT_ad01adsat | C(100)
SS - srážky | Specifický symbol adresáta | ADBUCTY_ad03ssymb | C(10)
Popis | Popis mzdové položky | MZMZDPOL8_mz28mzdpol | C(40)
Druh mzd. položky | Druh položky - příjem, náhrada mzdy,... | Výpočet | C(17)
Srážet | Způsob srážení | Výpočet | C(42)
Specifický symbol | Specifický symbol adresáta | ADBUCTYK_ad03ssymb | C(10)
Spol. částka | Kč / j | MZMZDPOL8_mz28kc_j | N(15,2)
Kód banky | Kód banky | ADBUCTYK_oc02idbank | C(4)
Prefix ú. | Prefix bankovního účtu adresáta | ADBUCTYK_ad03pructu | C(6)
Měna | Kód měny - oceňovací jednotky. | ADBUCTYK_oc01id | C(3)
Název adresáta | Název adresáta | ADADSATJ_ad01adsat | C(100)
Č. účtu | Číslo bankovního účtu adresáta. | ADBUCTYK_ad03ucet | C(34)
Název ú. | Název účtu | ADBUCTYK_ad03nauctu | C(20)
Název parametru | Název parametru | PAPARAMPR_pa02nazpar | C(40)
Název adresáta | Název adresáta | ADADSATPR_ad01adsat | C(100)
IČO | Identifikační číslo organizace. | ADADSATPR_ad01ico | C(10)
DIČ | Daňové identifikační číslo adresáta. | ADADSATPR_ad01dico | C(16)
Rodné číslo | Rodné číslo adresáta | ADADSATPR_ad01rc | C(10)
Jméno | Jméno kontaktní osoby. | ADSPOJPR_ad11jmeno | C(40)
Jméno na štítek | Jméno pracovníka na poštovní štítek | ADSPOJPR_ad11jmenop | C(100)
Telefon | Telefonní číslo | ADSPOJPR_ad11cislo | C(60)
Fax | Faxové číslo | ADSPOJPR_ad11fax | C(60)
Jiné | Jiné spojení adresáta | ADSPOJPR_ad11cisost | C(60)
Mobil | Číslo mobilního telefonu | ADSPOJPR_ad11mobil | C(60)
e-mail | E-mail spojení adresáta | ADSPOJPR_ad11email | C(60)
Kód banky | Kód banky | ADBUCTYPR_oc02idbank | C(4)
Pobočka | Název pobočky, která vede bankovní účet adresátovi. | ADBUCTYPR_ad03poboc | C(25)
Prefix ú. | Prefix bankovního účtu adresáta | ADBUCTYPR_ad03pructu | C(6)
Č. účtu | Číslo bankovního účtu adresáta. | ADBUCTYPR_ad03ucet | C(34)
Specifický symbol | Specifický symbol adresáta | ADBUCTYPR_ad03ssymb | C(10)
Měna | Kód měny - oceňovací jednotky. | ADBUCTYPR_oc01id | C(3)
Název ú. | Název účtu | ADBUCTYPR_ad03nauctu | C(20)
Název položky číselníku | Název položky číselníku | PACISPOLPR_pa08nazpol | C(40)
Název artiklu | Název artiklu | SPARTIKNPR_sp62artikl | C(60)
JČI | Jednoznačná časová identifikace | MZKARTA_mz01 | C(12)

    Při pohybu v Měs. nezd. pol.
Nezdan. pol. měsíční | Jednoznačná identifikace mzdové položky | MZNEZDPO_mz28id | C(6)
Indiv. částka - nezd. p. roč. | Kč/ j | MZNEZDPO_mz36kc_j | N(11,2)
Datum signalizace - nezd. p. měs. | Datum signalizace skončení platnosti měsíční nezdanitelné položky | MZNEZDPO_mz36signal | D

    Při pohybu v Roč. pol.
Nezdan. pol. roční | Jednoznačná identifikace mzdové položky | MZNEZDPO2_mz28id | C(6)
Indiv. částka - nezd. p. roč. | Kč/ j | MZNEZDPO2_mz36kc_j | N(11,2)

    Při pohybu v Půjčky
Půjčky | Jednoznačná identifikace mzdové položky | MZNEZDPO3_mz28id | C(6)
Částka - půjčky | Kč/ j | MZNEZDPO3_mz36kc_j | N(11,2)
Zůstatek - půjčky | Zůstatek půjčky | MZNEZDPO3_mz36zustat | N(11,2)
Adresát - půjčky | Identifikace adresáta | MZNEZDPO3_ad01id | C(6)
Účet - půjčky | Identifikátor spojení na bankovní účet adresáta. | MZNEZDPO3_ad03cisban | C(2)

    Při pohybu v Srážky a půjčky
Srážka nebo půjčka | Jednoznačná identifikace mzdové položky | MZNEZDPO34_mz28id | C(6)
Účet | Identifikátor spojení na bankovní účet adresáta. | MZNEZDPO34_ad03cisban | C(2)
Částka | Kč/ j | MZNEZDPO34_mz36kc_j | N(11,2)
Adresát | Identifikace adresáta | MZNEZDPO34_ad01id | C(6)
Zůstatek | Zůstatek půjčky | MZNEZDPO34_mz36zustat | N(11,2)
Do data | Datum ukončení platnosti položky | MZNEZDPO34_mz36dodata | D
KS | Konstantní symbol | MZNEZDPO34_mz36ksymb | C(4)
VS | Variabilní symbol | MZNEZDPO34_mz36vsymb | C(10)
Srážet | Kolik Kč se má z výplaty srážet | MZNEZDPO34_mz36srazet | N(7)

    Při pohybu v Srážky
Srážky | Jednoznačná identifikace mzdové položky | MZNEZDPO4_mz28id | C(6)
Do data - srážky | Datum ukončení platnosti položky | MZNEZDPO4_mz36dodata | D
Částka - srážky | Kč/ j | MZNEZDPO4_mz36kc_j | N(11,2)
Adresát - srážky | Identifikace adresáta | MZNEZDPO4_ad01id | C(6)
Účet - srážky | Identifikátor spojení na bankovní účet adresáta. | MZNEZDPO4_ad03cisban | C(2)
KS - srážky | Konstantní symbol | MZNEZDPO4_mz36ksymb | C(4)
VS - srážky | Variabilní symbol | MZNEZDPO4_mz36vsymb | C(10)

    Při pohybu v Osobní údaje ke kartě pracovníka
Typ údaje | Typ údaje - údaje o dětech, o invaliditě, o studiu | Výpočet | C(12)
Volný text1 | Volný text1 | MZOSOBNI_mz80text1 | C(40)
Volný text2 | Volný text2 | MZOSOBNI_mz80text2 | C(40)
Volný text3 | Volný text3 | MZOSOBNI_mz80text3 | C(40)
Volný text4 | Volný text4 | MZOSOBNI_mz80text4 | C(40)
Platnost od | Platnost od | MZOSOBNI_mz80od | D
do | Platnost do | MZOSOBNI_mz80do | D
Komentář | Komentář | MZOSOBNI_mz80koment | M

    Při pohybu v Pracovní poměry
Číslo p.p. | Číslo pracovního poměru | MZPRACPO_mz32cispp | C(2)
Druh prac. poměru | Druh pracovního poměru | Výpočet | C(19)
Kalendář | Jednoznačná identifikace kalendáře | MZPRACPO_mz25id | C(6)
Stupnice | Identifikace tarifní stupnice | MZPRACPO_mz23id | C(6)
Třída | Tarifní třída (1-99) | MZPRACPO_mz24trida | C(2)
Prac. funkce | Identifikace pracovní funkce (zařazení) | MZPRACPO_mz31id | C(6)
Účast na n.p. | Zakládá pracovní poměr účast na nemocenském pojištění? | Výpočet | C(3)
Denní vyměřovací základ | Denní vyměřovací základ nemocenského pojištění. | MZPRACPO_mz32npzakl | N(3)
Denní vyměřovací základ (neredukovaný) | Denní vyměřovací základ nemocenského pojištění neredukovaný. | MZPRACPO_mz32npzakd | N(9,2)
Vznik p.p. | Vznik prac. poměru | MZPRACPO_mz32vznipp | D
Skončení p.p. | Skončení prac. poměru | MZPRACPO_mz32skonpp | D
Důvod ukončení p.p. | Důvod ukončení pracovního poměru | MZPRACPO_mz32duvod | C(40)
Určující p.p. | Jedná se o určující prac.pom. (při více prac.poměrech)? | Výpočet | C(3)
Roční nárok na dovolenou | Roční nárok na dovolenou. | MZPRACPO_mz32dovnar | N(6,2)
Zůstatek staré dovolené | Zůstatek staré dovolené | MZPRACPO_mz32dovsta | N(6,2)
Zůstatek nové dovolené | Zůstatek nové dovolené | MZPRACPO_mz32dovnov | N(6,2)
Zůstatek dovolené z minulého roku | Zůstatek dovolené z minulého roku | MZPRACPO_mz32dovmin | N(6,2)
Převod dovolené do příštího roku | Převod dovolené do příštího roku | MZPRACPO_mz32dovpre | N(6,2)
Hodinový průměr | Hodinový průměr | MZPRACPO_mz32pruhod | N(9,2)
Denní průměr | Denní průměr | MZPRACPO_mz32pruden | N(9,2)
Měsíční průměr | Měsíční průměr | MZPRACPO_mz32prumes | N(9,2)
Zkušební lhůta | Datum ukončení zkušební lhůty | MZPRACPO_mz32zkuseb | D
Org. sel. | Identifikátor organizačního selektoru. | MZPRACPO_sp11idzak | C(9)

    Při pohybu v Zdravotní pojišťovny pracovníka
Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,... | MZZDRPOJ_mz70idp | C(3)
Datum zahájení platnosti položky | Datum zahájení platnosti položky | MZZDRPOJ_mz97oddata | D
Datum ukončení platnosti položky | Datum ukončení platnosti položky | MZZDRPOJ_mz97dodata | D

    Při pohybu v Hodnoty parametrů
Parametr | Identifikátor parametru | PAHODNOT_pa02id | C(6)
Hodnota parametru | Hodnota parametru | Výpočet | C(100)
Poznámka | Poznámka | PAHODNOT_pa06koment | M
Platnost od | Platnost od | PAHODNOT_pa06datum | D
do | Platnost do | PAHODNOT_pa06datumd | D
Adresát | Identifikace adresáta | PAHODNOT_ad01id | C(6)
Spojení | Číslo spojení adresáta. | PAHODNOT_ad11cisspo | C(2)
Účet | Identifikátor spojení na bankovní účet adresáta. | PAHODNOT_ad03cisban | C(2)
Text1 | Textová elementární hodnota | PAHODNOT_pa06text1 | C(60)
Identifikace položky číselníku | Identifikace položky číselníku | PAHODNOT_pa08id | C(10)
Druh artiklu | Identifikace druhu artiklu | PAHODNOT_sp61id | C(3)
Artikl | Identifikace artiklu | PAHODNOT_sp60id | C(13)
Num1 | Numerická elementární hodnota 1 | PAHODNOT_pa06num1 | N(20,4)
Num2 | Numerická elementární hodnota 2 | PAHODNOT_pa06num2 | N(20,4)
Dat1 | Datumová elementární hodnota 1 | PAHODNOT_pa06dat1 | D
Dat2 | Datumová elementární hodnota 2 | PAHODNOT_pa06dat2 | D
Cmb1 | Překryvný seznam elementární hodnota 1 | PAHODNOT_pa06cmb1 | N(1)
Cmb2 | Překryvný seznam elementární hodnota 2 | PAHODNOT_pa06cmb2 | N(1)
Oblast | Oblast sady parametrů | PAHODNOT_pa01oblast | C(2)

    Viz.také

    Pravidelné příjmy | Další informace | Volné údaje pracovníků | OZNAČOVÁNÍ | Charakter pracovníka v p. p. | Vztahy k osobám | Pracovníci v kategoriích | Osobní údaje | Další informace - dílčí | INFORMACE O PRACOVNÍKOVI | Sady parametrů | Obecné parametry | Přehled hodnot parametrů | Další informace karty | Nastavení zkušební doby | Strom pracovníka | Adresy adresátů | Adresář | Artikl | Bankovní spojení adresátů | Daňová zvýhodnění a slevy na dani | Daňové tabulky souhrnné | Druhy artiklů | Exekuce | Kategorie pracovníků | Mzdové položky použitelné jako roční | Nezdanitelné položky měsíční | Organizační selektor | Osoby | Palety barev kategorií pracovníků | Položky obecného číselníku | Pracovní doba | Pracovní místa skut. a typová | Půjčky | Spojení adresátů | Srážky | Státy | Tarifní stupnice | Technicko-věcný selektor | Výběr pracovního poměru | Výběr tar. třídy | Výplatní místa | Zdravotní a sociální pojišťovny | Algoritmus stanovení nem. dávky | Záložka daňová zvýhodnění (PA2) | Záložka exekuce (PA3) | Záložka měs.nezd.pol. (P5) | Záložka osob.údaje(P2) | Záložka prac.poměry (P4) | Záložka půjčky (P7) | Záložka roč.nezd.pol (P6) | Záložka sociální pojišťovny (PA4) | Záložka srážky (P8) | Záložka volné údaje (PA1) | Záložka zdrav.poj. (P3)


MZDY

Popis

Tato činnost v sobě sdružuje veškeré činnosti, které přímo souvisí s vlastním výpočtem mezd pracovníků.

Viz.také

Nepřítomnost pro nemoc | Načtení úkolových listů | Výplatní lístky | Všechny výpl. lístky-zadávání | Prohlížení výplatních lístků | Komplexní zadávání výplatních lístků | Protokol strukturovaný | ZÁLOHY | Optimalizovaný výpočet mezd | Odblokování uzamčení pořizování a výpočtu | VÝČETKA PLATIDEL | ODVODY NA ZP A SP | Uzávěrka mezd | ROČNÍ ZÚČTOVÁNÍ DANĚ


Nepřítomnost pro nemoc

Popis

Nepřítomností rozumíme evidenci nepřítomnosti na pracovišti z důvodu nemoci (náhrada mzdy), ošetřování člena rodiny, mateřské dovolené, rodičovské dovolené nebo jiné nemoci. Eviduje se celková doba nemoci a systém v datech automaticky dopočítá dobu, kdy se jedná o náhradu mzdy (prvních 14 kalendářních dnů hrazených organizací) a pokračování nemoci (kvůli evidenci).

Do výpočtu výplatních lístků vstupují údaje z činnosti „nepřítomnost pro nemoc“. Při uzávěrce mezd se aktualizuje atribut „kalendářních dnů pracovní neschopnosti“ a atribut „proplaceno dne“. Uzávěrka zasahuje rovněž do historie pracovních poměrů.

Pracovní poměr musí zakládat účast na nemocenském pojištění. Jednotlivé nepřítomnosti u pracovníka a jeho pracovního poměru se nesmějí překrývat. Dávku nelze vyplácet déle než trvala nemoc a jedním záznamem lze vyplácet pouze dávky v rámci jednoho měsíce. Systém umožňuje zadat nepřítomnost i do minulosti, tuto variantu by však uživatel měl používat pouze v krajní nouzi.

Při zadávání nepřítomností platí několik následujících pravidel:

¨ před zahájením vkládání nepřítomností daného měsíce je nutno mít provedenu uzávěrku za předchozí měsíc, jinak nebudou aktuální denní vyměřovací základy, které systém automaticky nabízí

¨ pokud pracovní neschopnost vznikla ve stejném měsíci jako pracovní poměr pracovníka, systém na tuto skutečnost upozorní

¨ je-li nemoc zadávána zpětně, tzn. do minulosti, předplní se denní vyměřovací základ z historie pracovních poměrů

¨ nemocenská dávka se vypočítá podle tabulek uvedených v parametrech

Činnost „nepřítomnost pro nemoc“ (v hlavním menu mzdy a personalistika – mzdy) umožňuje zadávání, prohlížení a údržbu přehledu nepřítomností. Evidují se zde nepřítomnosti pracovníků na pracovišti z důvodu nemoci, ošetřování člena rodiny, mateřské dovolené nebo jiné nepřítomnosti. Při zadávání nepřítomnosti vstupuje uživatel tyto základní údaje:

¨ osobní číslo, na jehož základě se předplní i jméno pracovníka

¨ číslo jeho pracovního poměru

¨ důvod nepřítomnosti (nemoc, ošetřování, vyrovnávací příspěvek, mateřská dovolená, jiná nepřítomnost, rodičovská dovolená, ošetřování osamělou osobou apod.) – výběr z překryvného seznamu. I při zadávání důvodu „ošetřování osamělou osobou“ vytvoří výpočet výplatních lístků mzdové položky jako u běžného ošetřování (N20000 a N21000). Zadáním údajů v této činnosti typu „nemoc“ od r. 2009 automaticky vznikne na výplatním lístku mzdová položka náhrada mzdy (její definice se zadává v parametrech nemocenských dávek).

¨ typ nemoci – zadává se pouze pokud je důvod nepřítomnosti nemoc (pak je nutno určit zda se jedná o „Karanténu“ či nikoliv z důvodu, že u Karantény se proplácejí i první tři dny nemoci).

¨ od – do – datum od kdy do kdy je pracovník nepřítomen (systém pak automaticky spočítá kolik je to kalendářních dnů)

¨ dnů – počet kalendářních dnů pracovní neschopnosti – systém při měsíční uzávěrce automaticky dopočte

¨ základ – do výpočtu výše „náhrady mzdy“ se použije hodinový průměr z Karty pracovníka – Další informace, případně z Historie pracovního poměru

¨ krátit o % - o uvedené % se krátí základ nemocenské dávky (např. z důvodu porušení léčebného režimu pacienta)

Ve většině případů není žádoucí, aby byla nepřítomnost zadána tak, že se na jednom pracovním poměru u jednoho pracovníka nemoci překrývají. Může však nastat situace, že uživatel bude potřebovat takovýto překryv přesto zadat. Po zadání nepřítomnosti pro nemoc s datem, který se překrývá s datem již jiné zadané nepřítomnosti systém hlásí:

"Zadaná nepřítomnost se překrývá s jinou !!!! Skutečně chcete zapsat údaje PŘES jinou nepřítomnost ?“ Volba Ano/Ne.

Pokud uživatel odpoví Ano, systém dovolí zapsat záznam nepřítomnosti, který se překrývá s jinou již dříve zapsanou nepřítomností. Pokud uživatel odpoví Ne, pak systém záznam nedovolí zapsat dokud ho uživatel neopraví na datum, které se s jinou nepřítomností nepřekrývá. Implicitně je nastavena odpověď Ne.

Na druhé záložce „dávky“ se uvádějí konkrétní nemocenské dávky. Výpočet bere v úvahu nastavení údajů v parametrech nemocenských dávek. Při uzávěrce mezd se aktualizuje atribut „kalendářních dnů pracovní neschopnosti“ a atribut „proplaceno dne“. K dispozici jsou tyto údaje:

¨ datum, kdy se poskytuje nemocenská dávka (od – do se předplní automaticky podle zadané nepřítomnosti na předchozí záložce)

¨ dnů kalendářních, dnů pracovních – rovněž se předplňuje automaticky, uživatel tyto údaje může podle potřeby opravit, např. když pracovník byl nemocen jiný počet dnů, ale k tomu ještě i několik hodin. Po takové ruční opravě těchto údajů je vhodné zaškrtnout atribut „nepřepočítávat“, tzn. aby systém opět údaje neopravil podle zadaných hodnot, ale ponechal hodnoty, které uživatel opravil.

¨ dávka Kč - výše nemocenské dávky, která se doplní automaticky. Pokud ji chce uživatel z nějakého důvodu upravit, změní ji a zaškrtne příznak nepřepočítávat, aby tuto dávku systém znovu automaticky nepřepsal. Platí pouze pro dávky z r. 2008 (mateřská nebo např. pokračování dlouhodobé nemoci apod.), v r. 2009 se klasická nemocenská změnila na evidenci náhrady mzdy (kterou vyplácí organizace) a pokračování nemoci, které organizace již nehradí. Při evidenci náhrady mzdy se sem žádná dávka neuvádí, automaticky se pak vypočte až při vlastním výpočtu mezd.

¨ nepřepoč. – lze použít v případě, že systém automaticky předplní určitou výši dávky, ale uživatel chce mít tuto hodnotu jinou, pak si ji opraví a zatrhne nepřepočítávat, aby mu ji systém při dalším výpočtu mezd znovu neopravil

¨ krátit o % - o uvedené % se krátí základ nemocenské dávky

¨ do výpočtu v – období, ve kterém bude dávka zahrnuta do výpočtu. U většiny dávek zůstane tento atribut prázdný, zadává se pouze v případě, že chceme nemocenskou dávku zadat zpětně, tj. do měsíce, který již byl uzavřen

¨ proplatit v nejbližším výplatním termínu (ano/ne)

¨ proplaceno dne – doplní se sem pak automaticky datum, kdy byla dávka proplacena (po měsíční uzávěrce)

Na záložce dávky je možné klávesou F6 nebo aktivací příslušné činnosti z menu Volby spustit činnost „Složení dávky“. Jedná se o podrobný přehled složení dávky za kalendářní měsíc, tzn. částí, ze kterých při výpočtu vznikala. Tento přehled o podrobném složení nemocenské dávky vzniká postupně během jejího výpočtu.

Při provádění uzávěrky mezd jsou všechny tyto záznamy o dávkách kontrolovány a u všech záznamů, které měli zaškrtnutou položku "proplatit" se doplní datum do položky "proplaceno dne" a původní zatržení "proplatit" se automaticky zruší.

Zadání nepřítomnosti do minulosti:

Jako první u této činnosti je nutno napsat upozornění, že se rozhodně nejedná o triviální činnost a zápis nemocenských dávek do minulosti je nutno používat s rozmyslem.

U nemocenské dávky zadávané do minulosti se vyplní všechny atributy stejně jako u běžné dávky, s tím rozdílem, že na záložce „dávky“ se pak správně vyplní datum „do výpočtu v“. Uvedeme si tyto údaje na zkušebním příkladu. Máme aktuální měsíc březen, leden a únor již jsou uzavřeny a přesto chceme zadat zpětně dávku, která se týká právě měsíce ledna. Pak dávku zadáme jako běžnou lednovou a do výpočtu uvedeme datum např. 1.3. nebo 31.3. Po spuštění optimalizovaného výpočtu pak v systému dojde k těmto akcím:

¨ v měsíci lednu, kam dávka logicky patří, vznikne nová položka nemocenské dávky

¨ do protokolu bude zapsáno, že je nutné danému pracovníkovi přepočítat průměry na nemocenskou, aby měl správné průměry u nemocí vzniklých v měsíci únoru a březnu

Datový model

  • MZNEMOC Nemoc
    • MZPRACPO Pracovní poměr
      • MZKARTA Pracovník
      • MZKALEN Kalendář má
      • MZPRACFU Pracovní funkce - skutečné a typové
    • MZPRACPO Pracovní poměr (alias MZPRACPOX)
      • MZKALEN Kalendář má (alias MZKALENX)

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Složení dávky | Složení dávky
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Přes měsíc | Dávku začínající a končící v jiných měsících rozdělí po měsících
F2 | Karta pracovníka | Karta pracovníka
F2 | Výběr pracovního poměru | Výběr prac. poměru - k již zadanému pracovníkovi

    Formulář

    Formulář činnosti - OZNAČOVÁNÍ
Mřížka [Nepřítomnost]
Listovací rámeček
Stránka #1 Nepřítomnost
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
Prac. poměr | Číslo pracovního poměru
 | Popis pracovní funkce (pracovního zařazení)
 | Rodné číslo
Číslo | Pořadové číslo nepřítomnosti / dávky pracovníka
Legitimace | Číslo legitimace práce neschoopného
Důvod | Důvod nepřítomnosti
Typ | Typ nemoci
Typ nemoci | Typ nemoci
Od | Datum začátku pracovní neschopnosti
Do | Datum ukončení pracovní neschopnosti
Dnů | Kalendářních dnů pracovní neschopnosti
Základ | Denní vyměřovací základ neredukovaný
Krátit o % | O uvedené procento se krátí základ nemocenské dávky.
 | Datum porodu (pouze pro důvod mateřská dovolená)
Komentář | Komentář
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Dávky
Mřížka [Dávky]
Od | Datum, od kterého se poskytuje nemocenská dávka
 | Znaménko výpočtu dávky
Do | Datum, do kterého se poskytuje nemocenská dávka
Dnů kal. | Kalendářní dny, za které se poskytuje nemocenská dávka
hod. kal. | Kalendářní hodiny, které se přičtou k uvedeným kal. dnům
z toho prac. | Pracovní dny, za které se poskytuje nemocenská dávka
hod.prac. | Pracovní hodiny, které se přičtou k uvedeným pracovním dnům
Krátit o % | O uvedené procento se krátí nemocenská dávka.
Do výpočtu v | Období, ve kterém bude dávka zahrnuta do výpočtu (prázdné = dle od - do). Ovlivňuje FPD.
Dávka Kč | Výše nemocenské dávky
Proplaceno dne | Datum, ve kterém byla nemocenská dávka vyplacena
Proplatit | Proplatit v nejbližším výplatním termínu?
Nepřepoč. | Nepřepisovat kalendářní dny nově vypočtenou hodnotou
Nepřepoč. | Nepřepisovat pracovní dny nově vypočtenou hodnotou
Nepřepoč. | Nepřepisovat dávku nově vypočtenou hodnotou
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #3 Výběr
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Prac. poměr | Číslo pracovního poměru
Číslo | Pořadové číslo nepřítomnosti / dávky pracovníka
Legitimace | Číslo legitimace práce neschoopného
Dnů větší než | Kalendářních dnů pracovní neschopnosti
Nemoc | Důvod-nemoc
Ošetřování | Důvod - ošetřování
Jiná nepřítomnost | Důvod - jiná nepřítomnost
Vyrovnávací příspěvek | Důvod - vyrovnávací příspěvek
Mateřská dovolená | Důvod - mateřská dovolená
Rodičovská dovolená | Rodičovská dovolená
Ostatní důvody | Důvod - všechny ostatní důvody
Nepřítomnost od | Datum začátku pracovní neschopnosti
do | Datum ukončení pracovní neschopnosti
Dávka od | Datum, od kterého se poskytuje nemocenská dávka
do | Datum, do kterého se poskytuje nemocenská dávka
Proplacení | Výběr dávky - vše, proplaceno, neproplaceno
Proplatit | Proplatit v nejbližším výplatním termínu?
Uchovat | Příznak uchování výběrového hlediska
Výběr | Určení výběru
Zapsané | Identifikace uživatele systému

    Mřížka [Nepřítomnost] činnosti - OZNAČOVÁNÍ

    Mřížka [Nepřítomnost] činnosti - OZNAČOVÁNÍ
Označování | Označení záznamu
OSC | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Od | Datum začátku pracovní neschopnosti
Do | Datum ukončení pracovní neschopnosti
Důvod | Důvod nepřítomnosti

    Mřížka [Dávky] činnosti - OZNAČOVÁNÍ

    Mřížka [Dávky] činnosti - OZNAČOVÁNÍ
Od | Datum, od kterého se poskytuje nemocenská dávka
Do | Datum, do kterého se poskytuje nemocenská dávka
Dávka Kč | Výše nemocenské dávky
Pl. | Proplatit v nejbližším výplatním termínu?
Dne | Datum, ve kterém byla nemocenská dávka vyplacena

    Atributy tisku

    Základní údaje
OSC | Jednoznačná identifikace pracovníka | MZNEMOC_mz01id | C(6)
Číslo p.p. | Číslo pracovního poměru | MZNEMOC_mz32cispp | C(2)
Pořadové číslo nemoci | Pořadové číslo nepřítomnosti / dávky pracovníka | MZNEMOC_mz37cisnem | C(3)
Legitimace | Číslo legitimace práce neschoopného | MZNEMOC_mz37legit | C(15)
Důvod | Důvod nepřítomnosti | Výpočet | C(26)
Od | Datum začátku pracovní neschopnosti | MZNEMOC_mz37od | D
Do | Datum ukončení pracovní neschopnosti | MZNEMOC_mz37do | D
Dnů | Kalendářních dnů pracovní neschopnosti | MZNEMOC_mz37dnu | N(6)
Základ | Denní vyměřovací základ upravený podle redukčních hranic | MZNEMOC_mz37zaklad | N(3)
Základ (neredukovaný) | Denní vyměřovací základ neredukovaný | MZNEMOC_mz37zakld | N(9,2)
Krátit o % | O uvedené procento se krátí základ nemocenské dávky. | MZNEMOC_mz37kratit | N(6,2)
Komentář | Komentář | MZNEMOC_mz37koment | M
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Datum narození | Datum narození | MZKARTA_mz01naroz | D
Číslo p.p. | Číslo pracovního poměru | MZPRACPO_mz32cispp | C(2)
Druh prac. poměru | Druh pracovního poměru | Výpočet | C(19)
Vznik p.p. | Vznik prac. poměru | MZPRACPO_mz32vznipp | D
Skončení p.p. | Skončení prac. poměru | MZPRACPO_mz32skonpp | D
Zapsal | Identifikace uživatele systému | MZNEMOC_bw01uziv | C(6)

    Při pohybu v Nemocenské dávky
Od | Datum, od kterého se poskytuje nemocenská dávka | MZNEMDAV_mz38od | D
Do | Datum, do kterého se poskytuje nemocenská dávka | MZNEMDAV_mz38do | D
Dnů kal. | Kalendářní dny, za které se poskytuje nemocenská dávka | MZNEMDAV_mz38dnu | N(8,4)
hod. kal. | Kalendářní hodiny, které se přičtou k uvedeným kal. dnům | MZNEMDAV_mz38hod | N(5,2)
z toho prac. | Pracovní dny, za které se poskytuje nemocenská dávka | MZNEMDAV_mz38dnupra | N(8,4)
hod.prac. | Pracovní hodiny, které se přičtou k uvedeným pracovním dnům | MZNEMDAV_mz38hodpra | N(5,2)
Dávka Kč | Výše nemocenské dávky | MZNEMDAV_mz38davka | N(6)
Vyšší sazb. | Počet dnů nemoci proplacených horní sazbou | MZNEMDAV_mz38dnyhs | N(8,4)
Nižší sazb. | Počet dnů nemoci proplacených sníženou sazbou | MZNEMDAV_mz38dnyns | N(8,4)
Základ | Základ pro výpočet nemocenské dávky za kalendářní den | MZNEMDAV_mz38zaklad | N(5)
Proplatit | Proplatit v nejbližším výplatním termínu? | Výpočet | C(3)
Proplaceno dne | Datum, ve kterém byla nemocenská dávka vyplacena | MZNEMDAV_mz38propla | D
Kal. dny (do výpočtu) | Kalendářní dny zahrnuté do výpočtu | MZNEMDAV_mz38vypdnk | N(8,4)
Prac. dny (do výpočtu) | Pracovní dny zahrnuté do výpočtu | MZNEMDAV_mz38vypdnp | N(8,4)
Období (do výpočtu) | Období, ve kterém byla dávka naposledy zahrnuta do výpočtu | MZNEMDAV_mz38vypobd | D

    Viz.také

    Složení dávky | OZNAČOVÁNÍ | Přes měsíc | Karta pracovníka | Výběr pracovního poměru


Načtení úkolových listů

Popis

Systém provede načtení dosud vytvořených úkolových listů. Na úkolových listech jsou jednotlivé záznamy vedeny tak, že co záznam, to vlastní řádek. Po aktivaci činnosti "načtení úkolových listů" dojde k tomu, že se všechny záznamy evidované u jednotlivých pracovníků sečtou a jako jeden záznam (tj. součet za každého pracovníka) se převedou do výplatních lístků.

Při zadávání mezd se tedy ve výplatních lístcích zobrazí nejprve hodnoty vytvořené pomocí úkolových listů, pak je možno zadávat další údaje mezd.

Datový model

  • MZKARTA Pracovník

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Výplatní lístky

Popis

Zadávání výplatního lístku je možno provádět těmito způsoby:

¨ jednotlivě zadávat každý výplatní lístek pro každého pracovníka (Mzdy a personalistika – Mzdy – Výplatní lístek)

¨ hromadně zadávat pracovníky najednou (Mzdy a personalistika – Mzdy – Všechny výpl. lístky – Zadávání)

¨ pomocí procesního zadávání úkolových lístků

Uživatel má jednak možnost zadávat nové mzdové položky nebo si prohlížet již vysčítané údaje z minulých období (po zadání příslušných údajů do vstupního výběru). Pokud v organizaci pracují i s úkolovými listy, po spuštění této činnosti se u vybraného pracovníka před zadáváním další mzdy zobrazuje celková částka, která byla dosud spočítána na základě úkolových listů.

Přístupová práva k výplatním lístkům jsou řízena pomocí přístupových práv k umístění, které je uvedeno na pracovní funkci a je nedílnou součástí definice pracovního poměru.

Pokud má uživatel u pracovníků nadefinované pravidelné příjmy (na kartě pracovníka), jejich hodnoty zde již nezadává, systém je při výpočtu výplatního lístku načte automaticky.

Mzdovými položkami se rozumí vše, co se tiskne pracovníkovi na výplatním lístku (příjmy, náhrady mezd, odvody,...apod.). Současně jsou mzdovými položkami údaje, které se na výplatním lístku zpravidla netisknou (odvod soc.poj. hrazeného organizací, odvod zdrav.poj. hrazeného organizací,...). Jednotlivé mzdové položky jsou:

¨ podle zadaného výběru se předplní jméno pracovníka, jeho prac. poměr, měsíc a rok zpracování mezd

¨ mzd.pol. - zadává se jednoznačná identifikace mzdové položky (např. přímá mzda, odvod, prémie apod.)

¨ výkon práce od - do - čas zahájení a ukončení práce. Není to povinný údaj, je možno zadat rovnou dny.

¨ dnů - počet dnů práce

¨ hodin - podle kalendáře se zadané dny přepočtou na hodiny. Pokud je zadáno pouze období od - do, přepočtou se hodiny podle tohoto rozmezí.

¨ výkon - tj. množství vykonané práce při úkolové mzdě (měrná jednotka je závislá na druhu práce, kterou pracovník vykonával, např. u orby to budou hektary apod.)

¨ Kč / j - tarifní sazba za hodinu, sazba za jednotku výkonu

¨ koef. - koeficient, kterým se násobí výsledná částka. Pokud není uvedeno jinak, implicitně se předplňuje 1

¨ v penězích - zda vyplatit uvedenou částku hotově. Ve většině případů se samozřejmě vyplácí, nevyplácí se např. u nepeněžních darů.

¨ Kč - celková částka v Kč (její výpočet záleží na způsobu výpočtu, který je uveden u dané mzdové položky)

¨ v případě potřeby i selektory

¨ zadáno - způsob, jakým byl záznam pořízen (ručně, výpočtem nebo na základě úkolového listu od mistra). Ručně zadané záznamy i úkolové listy lze kdykoliv opravovat. Záznamy vytvořené výpočtem nelze opravovat, ani rušit. Při každém novém výpočtu si program tyto záznamy automaticky zruší a nově vypočte.

¨ tisknout - zda tento údaj tisknout na výplatním lístku. Např. částka pojistného hrazená zaměstnavatelem se na výplatním lístku běžně netiskne. Údaj tisknout je přístupný u všech typů "zadáno" (tedy lze zaškrtávat i u "výpočtem").

Po zadání všech údajů (pravidelné příjmy se definují na kartě pracovníka - pod záložkou pracovní poměry) pak uživatel v menu Volby aktivuje činnost "výpočet výplatního lístku". Spočte se výplatní lístek daného pracovníka, který je pak možno si kdykoliv zpětně prohlédnout v činnosti prohlížení výplatních lístků.

Při zapsání mzdové položky do následujícího měsíce (odlišného od aktuálního) je aktivováno varovné hlášení. V případě, že uživatel si je vědom toho, že zapisuje do následujícího měsíce, je mu tato možnost umožněna.

Datový model

  • MZMZDY Mzda
    • MZKARTA Pracovník
    • MZMZDPOL Mzdová položka
      • MZDOPPOL Doplnění mzdové položky
    • MZKARTA Pracovník (alias MZKARTA3)
    • MZPRACPO Pracovní poměr (alias MZPRACPO2)
      • MZPRACFU Pracovní funkce - skutečné a typové (alias MZPRACFU2)
        • MZUMIST Alokace mezd - umístění
          • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)

    • Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^S | SUMY | Sumy
- | Protokol strukturovaný |
- | Pomocný optimalizovaný výpočet JEDNOHO pracovníka | Výpočet mezd všech pracovníků
F2 | Adresář | Přehled adresátů
F2 | Bankovní spojení adresátů |
F2 | Karta pracovníka | Karta pracovníka
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Výběr mzdové položky | Lupa v činnosti Výplatní lístky na Identifikace mzdové položky
F2 | Výběr pracovního poměru | Výběr prac. poměru - k již zadanému pracovníkovi

    Formulář

    Formulář činnosti - Optimalizovaný výpočet mezd
Mřížka [Mzdy]
Listovací rámeček
Stránka #1 Výplatní lístek
Pracovník | Příjmení pracovníka
Prac. poměr | Číslo pracovního poměru
 | Popis pracovní funkce (pracovního zařazení)
Měsíc | Měsíc zpracování mezd
 | Jméno pracovníka
Rok | Rok zpracování mezd
Zadáno | Způsob, jakým byl záznam pořízen.
Mzd.pol. | Jednoznačná identifikace mzdové položky
 | Popis mzdové položky
 | Druh položky - příjem, náhrada mzdy,...
Dopl. údaje | Jednoznačná identifikace doplňující položky mezd
 | Popis doplňující položky mezd
Od | Výkon práce od (čas zahájení práce)
Do | Výkon práce do (čas ukončení práce)
Dnů | Počet dnů (výkonu práce, volna, nemoci,...)
 | Počet kalendářních dnů.
Hodin | Počet hodin (výkonu práce, volna, nemoci,...)
Původ Kč / j | Původ Kč / j
Výpočet Kč | Způsob výpočtu celkové částky Kč
Výkon | Množství vykonané práce při úkolové mzdě
Kč / j | Kč za jednotku (tarifní sazba za hodinu, sazba za jednotku výkonu,...)
Koef. | Koeficient, kterým se násobí výsledná částka Kč.
Adresát | Identifikace adresáta
 | Název adresáta
Účet | Identifikátor spojení na bankovní účet adresáta.
KS | Konstantní symbol
VS | Variabilní symbol
SS | Specifický symbol adresáta
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
 | Poznámka
Tisknout | Tisknout na výplatním lístku (netisknout = pojistné hrazené zaměstnavatelem,...)
Detaily | Vyplatit uvedenou částku hotově (nevyplácet = např. nepeněžní dar)
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Hodiny jsou součástí FPD | Hodiny jsou součástí FPD
 | Nemoc v p.d.,Nemoc,Ošetřování v p.d.,Ošetřování,Vyrov. přísp.,Mat. dov.,Mat. dov. v p.d.,Import,Jiná nepřítomnost v p.d.,Jiná nepřítomnost,Rodičovská dovolená v p.d.,Rodičovská dovolená
Stránka #2 Poznámka
Komentář | Poznámka k výpočtu částky
Stránka #3 Výběr
OSC | Jednoznačná identifikace pracovníka
Číslo p.p. | Číslo pracovního poměru
Měsíc | Měsíc zpracování mezd
Rok | Rok zpracování mezd
Mzdová položka | Jednoznačná identifikace mzdové položky
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Mzdy] činnosti - Optimalizovaný výpočet mezd

    Mřížka [Mzdy] činnosti - Optimalizovaný výpočet mezd
Označování | Označení záznamu
Pracovník - OSC | Jednoznačná identifikace pracovníka
Číslo p.p. | Číslo pracovního poměru
Měsíc | Měsíc zpracování mezd
Rok | Rok zpracování mezd
Mzdová položka | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
Tisknout | Tisknout na výplatním lístku (netisknout = pojistné hrazené zaměstnavatelem,...)
Příjmení | Příjmení pracovníka

    Atributy tisku

    Základní údaje
Měsíc | Měsíc zpracování mezd | MZMZDY_mz02mesic | C(2)
Rok | Rok zpracování mezd | MZMZDY_mz02rok | C(4)
Pracovník | Jednoznačná identifikace pracovníka | MZMZDY_mz01id | C(6)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Číslo p.p. | Číslo pracovního poměru | MZMZDY_mz32cispp | C(2)
Druh prac. poměru | Druh pracovního poměru | Výpočet | C(19)
Roční nárok na dovolenou | Roční nárok na dovolenou. | MZPRACPO_mz32dovnar | N(6,2)
Zůstatek staré dovolené | Zůstatek staré dovolené | MZPRACPO_mz32dovsta | N(6,2)
Zůstatek nové dovolené | Zůstatek nové dovolené | MZPRACPO_mz32dovnov | N(6,2)
Mzdová položka | Jednoznačná identifikace mzdové položky | MZMZDY_mz28id | C(6)
Popis mzdové položky | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Druh | Druh položky - příjem, náhrada mzdy,... | Výpočet | C(17)
Poddruh1 | Hrubý příjem,Čistý příjem,K výplatě | Výpočet | C(42)
Poddruh2 | Základ s.p.,Odvod s.p. zaměst.,Odvod s.p. org.,Základ z.p.,Odvod z.p. zaměst.,Odvod z.p. org.,Základ záloh. daně,Daň zálohová,Zákl. srážk. daně,Daň srážková,Zákl. roč. zúčt. daně,Vyrovnání přepl. na dani | Výpočet | C(15)
Poddruh3 | Nemoc v p.d.,Nemoc,Ošetřování v p.d.,Ošetřování,Vyrov. přísp.,Mat. dov.,Mat. dov. v p.d.,Import,Jiná nepřítomnost v p.d.,Jiná nepřítomnost,Rodičovská dovolená v p.d.,Rodičovská dovolená | Výpočet | C(26)
Příznak dovolené | Dovolená - ovlivňuje čerpání dovolené | Výpočet | C(3)
Od | Výkon práce od (čas zahájení práce) | MZMZDY_mz02od | C(5)
Do | Výkon práce do (čas ukončení práce) | MZMZDY_mz02do | C(5)
Dnů | Počet dnů (výkonu práce, volna, nemoci,...) | MZMZDY_mz02dnu | N(10,2)
Hodin | Počet hodin (výkonu práce, volna, nemoci,...) | MZMZDY_mz02hodin | N(12,2)
Výkon | Množství vykonané práce při úkolové mzdě | MZMZDY_mz02vykon | N(10,2)
Kč / j | Kč za jednotku (tarifní sazba za hodinu, sazba za jednotku výkonu,...) | MZMZDY_mz02kc_j | N(20,4)
Koef. | Koeficient, kterým se násobí výsledná částka Kč. | MZMZDY_mz02koef | N(9,4)
Vyplatit v penězích | Vyplatit uvedenou částku hotově (nevyplácet = např. nepeněžní dar) | Výpočet | C(3)
Dopl. údaje | Jednoznačná identifikace doplňující položky mezd | MZMZDY_mz29id | C(6)
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.) | MZMZDY_mz02kc | N(20,2)
Zadáno | Způsob, jakým byl záznam pořízen. | Výpočet | C(14)
Tisknout | Tisknout na výplatním lístku (netisknout = pojistné hrazené zaměstnavatelem,...) | Výpočet | C(3)

    Viz.také

    OZNAČOVÁNÍ | SUMY | Protokol strukturovaný | Optimalizovaný výpočet mezd | Adresář | Bankovní spojení adresátů | Karta pracovníka | Obchodní selektor | Organizační selektor | Technicko-věcný selektor | Výběr mzdové položky | Výběr pracovního poměru


Všechny výpl. lístky-zadávání

Popis

Zadávání výplatního lístku je možno provádět těmito způsoby:

¨ jednotlivě zadávat každý výplatní lístek pro každého pracovníka (Mzdy a personalistika – Mzdy – Výplatní lístek)

¨ hromadně zadávat pracovníky najednou (Mzdy a personalistika – Mzdy – Všechny výpl. lístky – Zadávání)

¨ pomocí procesního zadávání úkolových lístků

V této činnosti jsou k dispozici příjmy, které se pak při výpočtu mezd automaticky doplní na výplatní lístek. Tyto pravidelné příjmy uživatel zadává na kartě pracovníka, na záložce „pracovní poměr“ po stisku klávesy F5 nebo po volbě příslušné činnosti z menu Volby.

U těchto pravidelných příjmů se při výpočtu mezd kontroluje zároveň jejich platnost (tzn. pravidelné příjmy s jiným obdobím platnosti než je aktuální datum se na výplatní lístek nenačtou).

Přístupová práva k výplatním lístkům jsou řízena pomocí přístupových práv k umístění, které je uvedeno na pracovní funkci a je nedílnou součástí definice pracovního poměru. Při zapsání mzdové položky do následujícího měsíce (odlišného od aktuálního) je aktivováno varovné hlášení. V případě, že uživatel si je vědom toho, že zapisuje do následujícího měsíce, je mu tato možnost umožněna.

Poznámka:

Velmi častá uživatelská chyba, která se v této činnosti stává je, že uživatel si uvede chybné datum ve výběru a pak v činnosti není dostupná ikona pro vložení nového záznamu. Nelze se pokoušet vkládat před datum poslední uzávěrky (tento datum uživatel zjistí v hlavním menu Mzdy – činnost Parametry – Parametry – a atribut „poslední zpracované mzdy k datu“), tzn. pokud je uzávěrka např. k 31.3.2008, tak nelze vkládat události před toto datum a ikona „vložení nového záznamu“ není dostupná.

Datový model

  • MZMZDY Mzda (alias MZMZDY5)
    • MZKARTA Pracovník
    • MZMZDPOL Mzdová položka
      • MZDOPPOL Doplnění mzdové položky
    • MZKARTA Pracovník (alias MZKARTA3)
    • MZPRACPO Pracovní poměr (alias MZPRACPO2)
      • MZPRACFU Pracovní funkce - skutečné a typové (alias MZPRACFU2)
        • MZUMIST Alokace mezd - umístění
          • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)

    • Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^S | SUMY | Sumy
- | Protokol strukturovaný |
- | Pomocný optimalizovaný výpočet JEDNOHO pracovníka | Výpočet mezd všech pracovníků
F2 | Adresář | Přehled adresátů
F2 | Bankovní spojení adresátů |
F2 | Karta pracovníka | Karta pracovníka
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Výběr mzdové položky | Lupa v činnosti Výplatní lístky na Identifikace mzdové položky
F2 | Výběr pracovního poměru | Výběr prac. poměru - k již zadanému pracovníkovi

    Formulář

    Formulář činnosti - Optimalizovaný výpočet mezd
Mřížka [Mzdy]
Listovací rámeček
Stránka #1 Výplatní lístek
 | Jednoznačná identifikace pracovníka
Pracovník | Příjmení pracovníka
Prac.p. | Číslo pracovního poměru
 | Popis pracovní funkce (pracovního zařazení)
Měsíc | Měsíc zpracování mezd
 | Jméno pracovníka
Rok | Rok zpracování mezd
Zadáno | Způsob, jakým byl záznam pořízen.
Mzd.pol. | Jednoznačná identifikace mzdové položky
 | Popis mzdové položky
 | Druh položky - příjem, náhrada mzdy,...
Dopl. údaje | Jednoznačná identifikace doplňující položky mezd
 | Popis doplňující položky mezd
Od | Výkon práce od (čas zahájení práce)
Do | Výkon práce do (čas ukončení práce)
Dnů | Počet dnů (výkonu práce, volna, nemoci,...)
 | Počet kalendářních dnů.
Hodin | Počet hodin (výkonu práce, volna, nemoci,...)
Původ Kč / j | Původ Kč / j
Výpočet Kč | Způsob výpočtu celkové částky Kč
Výkon | Množství vykonané práce při úkolové mzdě
Kč / j | Kč za jednotku (tarifní sazba za hodinu, sazba za jednotku výkonu,...)
Koef. | Koeficient, kterým se násobí výsledná částka Kč.
Adresát | Identifikace adresáta
 | Název adresáta
Účet | Identifikátor spojení na bankovní účet adresáta.
KS | Konstantní symbol
VS | Variabilní symbol
SS | Specifický symbol adresáta
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Detaily | Vyplatit uvedenou částku hotově (nevyplácet = např. nepeněžní dar)
Tisknout | Tisknout na výplatním lístku (netisknout = pojistné hrazené zaměstnavatelem,...)
 | Poznámka
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Hodiny jsou součástí FPD | Hodiny jsou součástí FPD
Poddruh3 | Nemoc v p.d.,Nemoc,Ošetřování v p.d.,Ošetřování,Vyrov. přísp.,Mat. dov.,Mat. dov. v p.d.,Import,Jiná nepřítomnost v p.d.,Jiná nepřítomnost,Rodičovská dovolená v p.d.,Rodičovská dovolená
Stránka #2 Výběr
OSC | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Číslo p.p. | Číslo pracovního poměru
Měsíc | Měsíc zpracování mezd
Rok | Rok zpracování mezd
Mzdová položka | Jednoznačná identifikace mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...
Zadáno | Způsob, jakým byl záznam pořízen.
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Mzdy] činnosti - Optimalizovaný výpočet mezd

    Mřížka [Mzdy] činnosti - Optimalizovaný výpočet mezd
Označování | Označení záznamu
Pracovník - OSC | Jednoznačná identifikace pracovníka
Číslo p.p. | Číslo pracovního poměru
Měsíc | Měsíc zpracování mezd
Rok | Rok zpracování mezd
Mzdová položka | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
Tisknout | Tisknout na výplatním lístku (netisknout = pojistné hrazené zaměstnavatelem,...)
Příjmení | Příjmení pracovníka

    Atributy tisku

    Základní údaje
Pracovník | Jednoznačná identifikace pracovníka | MZMZDY5_mz01id | C(6)
Číslo p.p. | Číslo pracovního poměru | MZMZDY5_mz32cispp | C(2)
Měsíc | Měsíc zpracování mezd | MZMZDY5_mz02mesic | C(2)
Rok | Rok zpracování mezd | MZMZDY5_mz02rok | C(4)
Mzdová položka | Jednoznačná identifikace mzdové položky | MZMZDY5_mz28id | C(6)
Od | Výkon práce od (čas zahájení práce) | MZMZDY5_mz02od | C(5)
Do | Výkon práce do (čas ukončení práce) | MZMZDY5_mz02do | C(5)
Dnů | Počet dnů (výkonu práce, volna, nemoci,...) | MZMZDY5_mz02dnu | N(10,2)
Dnů kalendářních | Počet kalendářních dnů. | MZMZDY5_mz02dnukal | N(10,2)
Hodin | Počet hodin (výkonu práce, volna, nemoci,...) | MZMZDY5_mz02hodin | N(12,2)
Výkon | Množství vykonané práce při úkolové mzdě | MZMZDY5_mz02vykon | N(10,2)
Kč / j | Kč za jednotku (tarifní sazba za hodinu, sazba za jednotku výkonu,...) | MZMZDY5_mz02kc_j | N(20,4)
Koef. | Koeficient, kterým se násobí výsledná částka Kč. | MZMZDY5_mz02koef | N(9,4)
Vyplatit v penězích | Vyplatit uvedenou částku hotově (nevyplácet = např. nepeněžní dar) | Výpočet | C(3)
Dopl. údaje | Jednoznačná identifikace doplňující položky mezd | MZMZDY5_mz29id | C(6)
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.) | MZMZDY5_mz02kc | N(20,2)
Zadáno | Způsob, jakým byl záznam pořízen. | Výpočet | C(14)
Tisknout | Tisknout na výplatním lístku (netisknout = pojistné hrazené zaměstnavatelem,...) | Výpočet | C(3)
Obch. sel. | Identifikátor obchodního selektoru | MZMZDY5_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | MZMZDY5_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MZMZDY5_sp20idzak | C(9)
Poznámka | Poznámka | MZMZDY5_mz02pozn | C(40)
Druh prac. poměru | Druh pracovního poměru | Výpočet | C(19)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)

    Viz.také

    OZNAČOVÁNÍ | SUMY | Protokol strukturovaný | Optimalizovaný výpočet mezd | Adresář | Bankovní spojení adresátů | Karta pracovníka | Obchodní selektor | Organizační selektor | Technicko-věcný selektor | Výběr mzdové položky | Výběr pracovního poměru


Prohlížení výplatních lístků

Popis

Uživatel má možnost prohlížet si dosud vytvořené výplatní lístky za vybraného pracovníka, pracovní poměr a období od - do. Přístupová práva k výplatním lístkům jsou řízena pomocí přístupových práv k umístění, které je uvedeno na pracovní funkci a je nedílnou součástí definice pracovního poměru.

Po stisku klávesy Ctrl S má uživatel možnost zkontrolovat si (při výběru konkrétního jednoho pracovníka) počet dnů za daný měsíc, z toho dnů kalendářních a počet hodin. K tomu je i info o částce, tj. celkové výši výplaty a počtu dnů a hodin, co se načítají do fondu pracovní doby.

Při zapsání mzdové položky do následujícího měsíce (odlišného od aktuálního) je aktivováno varovné hlášení. V případě, že uživatel si je vědom toho, že zapisuje do následujícího měsíce, je mu tato možnost umožněna.

Datový model

  • MZMZDY Mzda
    • MZKARTA Pracovník
    • MZPRACPO Pracovní poměr
    • MZMZDPOL Mzdová položka
      • MZDOPPOL Doplnění mzdové položky
    • MZKARTA Pracovník (alias MZKARTA3)
      • MZVYPMIS Výplatní místo
    • MZPRACPO Pracovní poměr (alias MZPRACPO3)
      • MZPRACFU Pracovní funkce - skutečné a typové (alias MZPRACFU2)
        • MZUMIST Alokace mezd - umístění
          • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)

    • Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^S | SUMY | Sumy
F2 | Adresář | Přehled adresátů
F2 | Bankovní spojení adresátů |
F2 | Karta pracovníka | Karta pracovníka
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Výběr mzdové položky | Lupa v činnosti Výplatní lístky na Identifikace mzdové položky
F2 | Výběr pracovního poměru | Výběr prac. poměru - k již zadanému pracovníkovi
F2 | Výplatní místa | Místa, pro která se při výplatě dělají výčetky platidel.

    Formulář

    Formulář činnosti - Bankovní spojení adresátů
Mřížka [Mzdy]
Listovací rámeček
Stránka #1 Prohlížení výplatních lístků
 | Jednoznačná identifikace pracovníka
Prac.p. | Číslo pracovního poměru
Pracovník | Příjmení pracovníka
 | Jméno pracovníka
 | Popis pracovní funkce (pracovního zařazení)
Měsíc | Měsíc zpracování mezd
Rok | Rok zpracování mezd
Zadáno | Způsob, jakým byl záznam pořízen.
Mzd.pol. | Jednoznačná identifikace mzdové položky
 | Popis mzdové položky
 | Druh položky - příjem, náhrada mzdy,...
Dopl. údaje | Jednoznačná identifikace doplňující položky mezd
 | Popis doplňující položky mezd
Od | Výkon práce od (čas zahájení práce)
Do | Výkon práce do (čas ukončení práce)
Dnů | Počet dnů (výkonu práce, volna, nemoci,...)
 | Počet kalendářních dnů.
Hodin | Počet hodin (výkonu práce, volna, nemoci,...)
Původ Kč / j | Původ Kč / j
Výpočet Kč | Způsob výpočtu celkové částky Kč
Výkon | Množství vykonané práce při úkolové mzdě
Kč / j | Kč za jednotku (tarifní sazba za hodinu, sazba za jednotku výkonu,...)
Koef. | Koeficient, kterým se násobí výsledná částka Kč.
Adresát | Identifikace adresáta
 | Název adresáta
Účet | Identifikátor spojení na bankovní účet adresáta.
KS | Konstantní symbol
VS | Variabilní symbol
SS | Specifický symbol adresáta
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Detaily | Vyplatit uvedenou částku hotově (nevyplácet = např. nepeněžní dar)
Tisknout | Tisknout na výplatním lístku (netisknout = pojistné hrazené zaměstnavatelem,...)
 | Poznámka
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Hodiny jsou součástí FPD | Hodiny jsou součástí FPD
 | Nemoc v p.d.,Nemoc,Ošetřování v p.d.,Ošetřování,Vyrov. přísp.,Mat. dov.,Mat. dov. v p.d.,Import,Jiná nepřítomnost v p.d.,Jiná nepřítomnost,Rodičovská dovolená v p.d.,Rodičovská dovolená
Stránka #2 Poznámka
Komentář | Poznámka k výpočtu částky
Stránka #3 Výběr
OSC | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Číslo p.p. | Číslo pracovního poměru
Od | Měsíc od
 | Rok od
do | Měsíc do
 | Rok do
Výpl. místo | Jednoznačná identifikace výplatního místa
 | Název výplatního místa
Mzdová položka | Jednoznačná identifikace mzdové položky
 | Druh položky - příjem, náhrada mzdy,...
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Mzdy] činnosti - Bankovní spojení adresátů

    Mřížka [Mzdy] činnosti - Bankovní spojení adresátů
Označování | Označení záznamu
Pracovník - OSC | Jednoznačná identifikace pracovníka
Číslo p.p. | Číslo pracovního poměru
Měsíc | Měsíc zpracování mezd
Rok | Rok zpracování mezd
Mzdová položka | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
Tisknout | Tisknout na výplatním lístku (netisknout = pojistné hrazené zaměstnavatelem,...)
Příjmení | Příjmení pracovníka

    Atributy tisku

    Základní údaje
Pracovník | Jednoznačná identifikace pracovníka | MZMZDY_mz01id | C(6)
Číslo p.p. | Číslo pracovního poměru | MZMZDY_mz32cispp | C(2)
Měsíc | Měsíc zpracování mezd | MZMZDY_mz02mesic | C(2)
Rok | Rok zpracování mezd | MZMZDY_mz02rok | C(4)
Mzdová položka | Jednoznačná identifikace mzdové položky | MZMZDY_mz28id | C(6)
Popis | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Druh mzd. položky | Druh položky - příjem, náhrada mzdy,... | Výpočet | C(17)
Poddruh1 | Hrubý příjem,Čistý příjem,K výplatě | Výpočet | C(42)
Poddruh2 | Základ s.p.,Odvod s.p. zaměst.,Odvod s.p. org.,Základ z.p.,Odvod z.p. zaměst.,Odvod z.p. org.,Základ záloh. daně,Daň zálohová,Zákl. srážk. daně,Daň srážková,Zákl. roč. zúčt. daně,Vyrovnání přepl. na dani | Výpočet | C(15)
Poddruh3 | Nemoc v p.d.,Nemoc,Ošetřování v p.d.,Ošetřování,Vyrov. přísp.,Mat. dov.,Mat. dov. v p.d.,Import,Jiná nepřítomnost v p.d.,Jiná nepřítomnost,Rodičovská dovolená v p.d.,Rodičovská dovolená | Výpočet | C(26)
Poddruh4 | Doplatek ZP zam.,Doplatek SP zam.,Doplatek daně záloh.,Doplatek daně srážk.,Doplatek ZP org.,Doplatek SP org. | MZMZDPOL_mz28pdruh4 | N(2)
Příznak dovolené | Dovolená - ovlivňuje čerpání dovolené | Výpočet | C(3)
Od | Výkon práce od (čas zahájení práce) | MZMZDY_mz02od | C(5)
Do | Výkon práce do (čas ukončení práce) | MZMZDY_mz02do | C(5)
Dnů | Počet dnů (výkonu práce, volna, nemoci,...) | MZMZDY_mz02dnu | N(10,2)
Dnů kalendářních | Počet kalendářních dnů. | MZMZDY_mz02dnukal | N(10,2)
Hodin | Počet hodin (výkonu práce, volna, nemoci,...) | MZMZDY_mz02hodin | N(12,2)
Výkon | Množství vykonané práce při úkolové mzdě | MZMZDY_mz02vykon | N(10,2)
Kč / j | Kč za jednotku (tarifní sazba za hodinu, sazba za jednotku výkonu,...) | MZMZDY_mz02kc_j | N(20,4)
Koef. | Koeficient, kterým se násobí výsledná částka Kč. | MZMZDY_mz02koef | N(9,4)
Hotově | Vyplatit uvedenou částku hotově (nevyplácet = např. nepeněžní dar) | Výpočet | C(3)
Dopl. údaje | Jednoznačná identifikace doplňující položky mezd | MZMZDY_mz29id | C(6)
Dny odečíst od vym. z. pro n.p. | Dny odečíst od vyměřovacího základu pro nem. pojištění | Výpočet | C(3)
Hodiny zahrnout do průměru | Hodiny zahrnout do průměru | Výpočet | C(3)
Kč zahrnout do průměru | Kč zahrnout do průměru | Výpočet | C(3)
KČ zahrnout do hrub. příjmu | Kč zahrnout do hrubého příjmu | Výpočet | C(3)
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.) | MZMZDY_mz02kc | N(20,2)
Zadáno | Způsob, jakým byl záznam pořízen. | Výpočet | C(14)
Tisknout | Tisknout na výplatním lístku (netisknout = pojistné hrazené zaměstnavatelem,...) | Výpočet | C(3)
Obch. sel. | Identifikátor obchodního selektoru | MZMZDY_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | MZMZDY_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MZMZDY_sp20idzak | C(9)
Poznámka | Poznámka | MZMZDY_mz02pozn | C(40)
Druh prac. poměru | Druh pracovního poměru | Výpočet | C(19)
Kalendář | Jednoznačná identifikace kalendáře | MZPRACPO_mz25id | C(6)
Hod / den | Pracovní doba hodin / den | MZKALEN_mz25hodden | N(5,2)
Stupnice | Identifikace tarifní stupnice | MZPRACPO_mz23id | C(6)
Třída | Tarifní třída (1-99) | MZPRACPO_mz24trida | C(2)
Prac. funkce | Identifikace pracovní funkce (zařazení) | MZPRACPO_mz31id | C(6)
Prac.funkce | Popis pracovní funkce (pracovního zařazení) | MZPRACFU_mz31pracfu | C(40)
Skončení p.p. | Skončení prac. poměru | MZPRACPO_mz32skonpp | D
Důvod ukončení p.p. | Důvod ukončení pracovního poměru | MZPRACPO_mz32duvod | C(40)
Vznik p.p. | Vznik prac. poměru | MZPRACPO_mz32vznipp | D
Určující | Jedná se o určující prac.pom. (při více prac.poměrech)? | Výpočet | C(3)
Roční nárok na dovolenou | Roční nárok na dovolenou. | MZPRACPO_mz32dovnar | N(6,2)
Zůstatek staré dovolené | Zůstatek staré dovolené | MZPRACPO_mz32dovsta | N(6,2)
Zůstatek nové dovolené | Zůstatek nové dovolené | MZPRACPO_mz32dovnov | N(6,2)
Převod dovolené do příštího roku | Převod dovolené do příštího roku | MZPRACPO_mz32dovpre | N(6,2)
Hodinový průměr | Hodinový průměr | MZPRACPO_mz32pruhod | N(9,2)
Denní průměr | Denní průměr | MZPRACPO_mz32pruden | N(9,2)
Měsíční průměr | Měsíční průměr | MZPRACPO_mz32prumes | N(9,2)
Zkušební lhůta | Datum ukončení zkušební lhůty | MZPRACPO_mz32zkuseb | D
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Rodné číslo | Rodné číslo | MZKARTA_mz01rodc | C(11)
Provést roční zúčtování ? | Provést roční zúčtování ? | Výpočet | C(3)
Výpl. místo | Jednoznačná identifikace výplatního místa | MZKARTA_mz22id | C(6)
Adresát | Identifikace adresáta | MZKARTA_ad01id | C(6)
Město adresy adresáta | Město adresy adresáta. | ADADR1_ad02mesto | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR1_ad13psc | C(10)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR1_ad02ulice | C(40)
Zdrav. poj. z osobnich udaju | Identifikace pojišťovny, např. 111, 121 ,... | MZKARTA_mz70idp | C(3)
Adresát | Identifikace adresáta | MZPOJSEZ_ad01id | C(6)
Název | Název adresáta | ADADSAT_ad01adsat | C(100)
Číslo adresy adresáta | Číslo adresy adresáta. | MZPOJSEZ_ad02cisadr | C(2)
Účet zdrav. pojišťovny | Identifikátor spojení na bankovní účet adresáta. | MZPOJSEZ_ad03cisban | C(2)
Zapsal | Identifikace uživatele systému | MZMZDY_bw01uziv | C(6)
Min. měsíční mzda | Minimální mzda měsíční | MZTARTRI_mz24minmzd | N(5)
Den výplaty mezd | Den výplaty mezd | MZPARAM_mz27denvyp | N(2)
Typ kalendáře | Typ používaného kalendáře - po měsících, po dnech | Výpočet | C(11)

    Při pohybu v 12měsíců fondu pracovní doby
    Hodin v měsíci Pracovních hodin v měsíci MZFPD_mz26hodin N(20,2)

    Při pohybu v Osobní údaje ke kartě pracovníka
Typ údaje | Typ údaje - údaje o dětech, o invaliditě, o studiu | Výpočet | C(12)
Volný text1 | Volný text1 | MZOSOBNI_mz80text1 | C(40)
Volný text2 | Volný text2 | MZOSOBNI_mz80text2 | C(40)
Volný text3 | Volný text3 | MZOSOBNI_mz80text3 | C(40)
Volný text4 | Volný text4 | MZOSOBNI_mz80text4 | C(40)
Platnost od | Platnost od | MZOSOBNI_mz80od | D
do | Platnost do | MZOSOBNI_mz80do | D
Komentář | Komentář | MZOSOBNI_mz80koment | M

    Při pohybu v Zdravotní pojišťovny pracovníka
Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,... | MZZDRPOJ_mz70idp | C(3)
Datum zahájení platnosti položky | Datum zahájení platnosti položky | MZZDRPOJ_mz97oddata | D
Datum ukončení platnosti položky | Datum ukončení platnosti položky | MZZDRPOJ_mz97dodata | D

    Viz.také

    OZNAČOVÁNÍ | SUMY | Adresář | Bankovní spojení adresátů | Karta pracovníka | Obchodní selektor | Organizační selektor | Technicko-věcný selektor | Výběr mzdové položky | Výběr pracovního poměru | Výplatní místa


Komplexní zadávání výplatních lístků

Datový model

  • MZMZDY Mzda
    • MZKARTA Pracovník
    • MZPRACPO Pracovní poměr
      • MZPRACFU Pracovní funkce - skutečné a typové
      • MZKARTA Pracovník (alias MZKARTA2)
    • MZMZDPOL Mzdová položka
      • MZDOPPOL Doplnění mzdové položky
    • MZKARTA Pracovník (alias MZKARTA3)
      • MZVYPMIS Výplatní místo
    • MZPRACPO Pracovní poměr (alias MZPRACPO3)
      • MZPRACFU Pracovní funkce - skutečné a typové (alias MZPRACFU2)
        • MZUMIST Alokace mezd - umístění
          • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)

    • Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^S | SUMY | Sumy
- | Optimalizovaný výpočet mezd | Výpočet mezd všech pracovníků
F2 | Adresář | Přehled adresátů
F2 | Bankovní spojení adresátů |
F2 | Karta pracovníka | Karta pracovníka
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Výběr mzdové položky | Lupa v činnosti Výplatní lístky na Identifikace mzdové položky
F2 | Výběr pracovního poměru | Výběr prac. poměru - k již zadanému pracovníkovi
F2 | Výplatní místa | Místa, pro která se při výplatě dělají výčetky platidel.

    Formulář

    Formulář činnosti - OZNAČOVÁNÍ
Mřížka [Mzdy]
Listovací rámeček
Stránka #1 Komplexní zadávání výplatních lístků
Pracovník | Jednoznačná identifikace pracovníka
 | Číslo pracovního poměru
 | Popis pracovní funkce (pracovního zařazení)
 | Jednoznačná identifikace kalendáře
Mzd.pol. | Jednoznačná identifikace mzdové položky
 | Příjmení pracovníka
 | Popis mzdové položky
 | Druh položky - příjem, náhrada mzdy,...
 | Hodiny jsou součástí FPD
 | Způsob výpočtu celkové částky Kč
 | Původ Kč / j
 | Jednoznačná identifikace doplňující položky mezd
 | Identifikace účetní události
Období | Rok zpracování mezd
 | Měsíc zpracování mezd
Dnů | Počet dnů (výkonu práce, volna, nemoci,...)
Dnů kal. | Počet kalendářních dnů.
Hodin | Počet hodin (výkonu práce, volna, nemoci,...)
Výkon | Množství vykonané práce při úkolové mzdě
Kč / j | Kč za jednotku (tarifní sazba za hodinu, sazba za jednotku výkonu,...)
Koef. | Koeficient, kterým se násobí výsledná částka Kč.
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
Adresát | Identifikace adresáta
 | Identifikátor spojení na bankovní účet adresáta.
 | Konstantní symbol
 | Variabilní symbol
 | Název adresáta
 | Specifický symbol adresáta
Poznámka | Poznámka
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
V penězích | Vyplatit uvedenou částku hotově (nevyplácet = např. nepeněžní dar)
Tisknout | Tisknout na výplatním lístku (netisknout = pojistné hrazené zaměstnavatelem,...)
 | Způsob, jakým byl záznam pořízen.
 | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Poznámka
Komentář | Poznámka k výpočtu částky
Stránka #3 Výběr
OSC | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Číslo p.p. | Číslo pracovního poměru
Od | Měsíc od
 | Rok od
do | Měsíc do
 | Rok do
Výpl. místo | Jednoznačná identifikace výplatního místa
 | Název výplatního místa
Mzdová položka | Jednoznačná identifikace mzdové položky
 | Druh položky - příjem, náhrada mzdy,...
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Mzdy] činnosti - OZNAČOVÁNÍ

    Mřížka [Mzdy] činnosti - OZNAČOVÁNÍ
Označování | Označení záznamu
Pracovník - OSC | Jednoznačná identifikace pracovníka
Číslo p.p. | Číslo pracovního poměru
Měsíc | Měsíc zpracování mezd
Rok | Rok zpracování mezd
Mzdová položka | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
Tisknout | Tisknout na výplatním lístku (netisknout = pojistné hrazené zaměstnavatelem,...)
Příjmení | Příjmení pracovníka

    Atributy tisku

    Základní údaje
Pracovník | Jednoznačná identifikace pracovníka | MZMZDY_mz01id | C(6)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Titul za | Titul pracovníka (za jménem) | MZKARTA_mz01titul2 | C(15)
Číslo p.p. | Číslo pracovního poměru | MZMZDY_mz32cispp | C(2)
Druh | Druh pracovního poměru | Výpočet | C(19)
Měsíc | Měsíc zpracování mezd | MZMZDY_mz02mesic | C(2)
Rok | Rok zpracování mezd | MZMZDY_mz02rok | C(4)
Mzdová položka | Jednoznačná identifikace mzdové položky | MZMZDY_mz28id | C(6)
Od | Výkon práce od (čas zahájení práce) | MZMZDY_mz02od | C(5)
Do | Výkon práce do (čas ukončení práce) | MZMZDY_mz02do | C(5)
Dnů | Počet dnů (výkonu práce, volna, nemoci,...) | MZMZDY_mz02dnu | N(10,2)
Dnů kalendářních | Počet kalendářních dnů. | MZMZDY_mz02dnukal | N(10,2)
Hodin | Počet hodin (výkonu práce, volna, nemoci,...) | MZMZDY_mz02hodin | N(12,2)
Výkon | Množství vykonané práce při úkolové mzdě | MZMZDY_mz02vykon | N(10,2)
Kč / j | Kč za jednotku (tarifní sazba za hodinu, sazba za jednotku výkonu,...) | MZMZDY_mz02kc_j | N(20,4)
Koef. | Koeficient, kterým se násobí výsledná částka Kč. | MZMZDY_mz02koef | N(9,4)
Vyplatit v penězích | Vyplatit uvedenou částku hotově (nevyplácet = např. nepeněžní dar) | Výpočet | C(3)
Identifikace | Jednoznačná identifikace doplňující položky mezd | MZMZDY_mz29id | C(6)
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.) | MZMZDY_mz02kc | N(20,2)
Zadáno | Způsob, jakým byl záznam pořízen. | Výpočet | C(14)
Tisknout | Tisknout na výplatním lístku (netisknout = pojistné hrazené zaměstnavatelem,...) | Výpočet | C(3)
Adresát | Identifikace adresáta | MZMZDY_ad01id | C(6)
Účet | Identifikátor spojení na bankovní účet adresáta. | MZMZDY_ad03cisban | C(2)
KS | Konstantní symbol | MZMZDY_mz36ksymb | C(4)
VS | Variabilní symbol | MZMZDY_mz36vsymb | C(10)
Obch. sel. | Identifikátor obchodního selektoru | MZMZDY_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | MZMZDY_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MZMZDY_sp20idzak | C(9)
Ident. | Identifikace uživatele systému | MZMZDY_bw01uziv | C(6)
Datum a čas zápisu | Datum a čas zápisu záznamu události | MZMZDY_sp00datzap | T
Poznámka | Poznámka | MZMZDY_mz02pozn | C(40)
Identifikace | Identifikace osoby | MZMZDY_mz05id | C(6)
Komentář | Poznámka k výpočtu částky | MZMZDY_mz02koment | M

    Viz.také

    OZNAČOVÁNÍ | SUMY | Optimalizovaný výpočet mezd | Adresář | Bankovní spojení adresátů | Karta pracovníka | Obchodní selektor | Organizační selektor | Technicko-věcný selektor | Výběr mzdové položky | Výběr pracovního poměru | Výplatní místa


Protokol strukturovaný

Popis

V této činnosti jsou k dispozici strukturované protokoly, které se automaticky vytvářejí při výpočtu mezd, při uzávěrce mezd a při přepočtu průměrů, tzn. že během jednoho měsíce může mít uživatel i několik protokolů. V této činnosti si je může uchovávat nebo v případě potřeby i rušit. U každého protokolu jsou k dispozici tyto údaje:

¨ typ hlavičky – tzn. čeho se daný protokol týká (výpočtu mzdy, uzávěrky, přepočtu průměrů, přepočtu pro nepřítomnosti)

¨ pořadové číslo protokolu

¨ období – které období daný protokol představuje

¨ poslední zpracované mzdy k datu – informace o datu posledního zpracování mezd

Vlastní položky protokolu si lze prohlédnout po stisku funkční klávesy F6 nebo volbou činnosti „položky protokolu“ pod menu Volby.

Datový model

  • MZPROTHL Hlavička protokolu

    • Formulář

    Formulář činnosti - Položky protokolu
Mřížka [Hlavičky protokolu]
Listovací rámeček
Stránka #1 Protokol
Typ hlavičky | Typ hlavičky protokolu
Pořadové číslo | Absolutní pořadové číslo výpočtu
Období | Výpočet/uzávěrka proběhl za odbobí rok/měsíc
Poznámka | Poznámka
Poslední zpracované mzdy k datu | Datum, ke kterému jsou spočteny poslední mzdy.
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Výběr
Typ hlavičky | Typ hlavičky protokolu
Období | Výpočet/uzávěrka proběhl za odbobí rok/měsíc
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Hlavičky protokolu] činnosti - Položky protokolu

    Mřížka [Hlavičky protokolu] činnosti - Položky protokolu
Typ hlavičky | Typ hlavičky protokolu
Pořadí | Absolutní pořadové číslo výpočtu
Období | Výpočet/uzávěrka proběhl za odbobí rok/měsíc
Datum poslení uzávěrky | Datum, ke kterému jsou spočteny poslední mzdy.
Datum a čas zápisu | Datum a čas zápisu záznamu události
Zapsal | Identifikace uživatele systému

    Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Položky protokolu |

    Atributy tisku

    Základní údaje
Pořadové číslo | Absolutní pořadové číslo výpočtu | MZPROTHL_mz03poradi | N(10)
Typ hlavičky | Typ hlavičky protokolu | Výpočet | C(38)
Poznámka | Poznámka | MZPROTHL_mz03pozn | M
Poslední zpracované mzdy k datu | Datum, ke kterému jsou spočteny poslední mzdy. | MZPROTHL_mz27datmzd | D
Zapsal | Identifikace uživatele systému | MZPROTHL_bw01uziv | C(6)
Datum a čas zápisu | Datum a čas zápisu záznamu události | MZPROTHL_sp00datzap | T

    Viz.také

    Položky protokolu


ZÁLOHY

Popis

Pomocí této činnosti je možno vytvářet u jednotlivých pracovníků zálohy, a to i několikrát měsíčně. Vydané zálohy je samozřejmě možno následně prohlížet, popř. i tisknout. Bližší popis je v helpu k činnosti "výpočet zálohy".

Viz.také

Výplata zálohy | Prohlížení vypočtených záloh


Výplata zálohy

Popis

Při výpočtu zálohy uživatel zadává pouze identifikaci zálohy. Z toho vyplývá, že jednotlivé zálohy musí mít uživatel nadefinovány v číselníku srážek.

Důležité upozornění:

Pokud uživatel vyplácí zálohy během měsíce vícekrát, je nutno mít pro každou výplatu zálohu s jinou identifikací. Tzn., že pokud uživatel vyplácí zálohy např. 3x měsíčně, je nutno mít v činnosti srážky uvedenu zálohu 3x, a to pokaždé s jinou identifikací.

Datový model

  • MZZALOHY Záloha vyplacená

    • Formulář

    Formulář činnosti - Výběr mzdové položky
    Zadejte identifikaci zálohy, která se má vyplácet Identifikace zálohy

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Výběr mzdové položky | Lupa v činnosti Výplatní lístky na Identifikace mzdové položky

    Viz.také

    Výběr mzdové položky


Prohlížení vypočtených záloh

Popis

Před vlastním spuštěním činnosti uživatel zadává identifikaci zálohy, jejíž výplaty si chce zobrazit. Po jejím zadání se mu zobrazí přehled vypočtených záloh s vybranou identifikací.

Datový model

  • MZZALOHY Záloha vyplacená
    • MZKARTA Pracovník

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Srážky | K evidenci pravidelných srážek

    Formulář

    Formulář činnosti - Srážky
Mřížka [Zálohy]
Listovací rámeček
Stránka #1 Zálohy
OSC | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Záloha | Jednoznačná identifikace mzdové položky
 | Popis mzdové položky
Částka | Kč/ j
Stránka #2 Výběr
Záloha | Jednoznačná identifikace mzdové položky
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Zálohy] činnosti - Srážky

    Mřížka [Zálohy] činnosti - Srážky
OSC | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Titul | Titul pracovníka (před jménem)
Identifikace zálohy | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
 | Kč/ j

    Atributy tisku

    Základní údaje
OSC | Jednoznačná identifikace pracovníka | MZZALOHY_mz01id | C(6)
Záloha | Jednoznačná identifikace mzdové položky | MZZALOHY_mz28id | C(6)
Částka | Kč/ j | MZZALOHY_mz36kc_j | N(11,2)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Popis | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)

    Viz.také

    Srážky


Optimalizovaný výpočet mezd

Popis

Výpočet výplatních lístků se provede pomocí činnosti „optimalizovaný výpočet mezd“ (menu Mzdy – Mzdy). Uživatel pak může zvolit konkrétní číslo pracovníka (napíše přímo jeho osobní číslo), skupinu pracovníků (napíše např. číslo jedna a systém pak vybere skupinu pracovníků, jejichž osobní číslo začíná na číslo 1) nebo všechny pracovníky (ponechá znak %).

Důležité momenty pro správné zpracování:

¨ nastavení parametrů

¨ definice mzdových položek

¨ zadání nepřítomností pro nemoc

¨ vytvořený kalendář pracovních dob

¨ správně zadané údaje na kartě pracovníka (tzn. nastavení zaškrtávátek a definičně přesné zadání pravidelných příjmů)

Výpočet výplatních lístků jednotlivých pracovníků je možné provést ve zpracovávaném měsíci opakovaně. Výpočet provádí též řadu kontrol, jejichž výsledky jsou generovány do Protokolu. Záznamy vzniklé výpočtem výplatních lístků jsou podkladem pro komponentu MZD.

Pokud má pracovník v organizaci současně několik pracovních poměrů, systém mu připraví za každý pracovní poměr výplatní lístek s položkami příjmů, sociálního a zdravotního pojištění, základu daně a nemocenských dávek.

Na výplatním lístku z pracovního poměru označeného jako „určující“ systém navíc uplatní nezdanitelné položky, vypočítá daň za všechny příjmy, vypočítá čistý příjem, srážky a částku k výplatě.

Pokud má pracovník víc výplatních lístků a nemá ani jeden pracovní poměr s příznakem „určující“ nebo jich má víc, pak systém vybere za hlavní výplatní lístek kterýkoliv z vypočítaných a do „protokolu“ zapíše hlášku „pracovník nemá žádný pracovní poměr označen jako určující. Bude vybrán pracovní poměr, který je první v pořadí“.

Optimalizovaný výpočet mezd pro každého pracovníka a jeho pracovní poměr postupně provede :

¨ přenos pravidelných příjmů z karty pracovníka

¨ kontrolu evidované doby

¨ výpočet hrubých příjmů

¨ výpočet sociálního pojištění hrazeného zaměstnancem

Je-li v parametrech mezd nastaven způsob výpočtu sociálního pojištění za organizaci „jednotlivě“, provede se výpočet sociálního pojištění hrazeného organizací (za jednoho zaměstnance)

¨ výpočet zdravotního pojištění hrazeného zaměstnancem a hrazeného organizací

¨ přenos nemocenských dávek z nepřítomnosti pro nemoc

Dále pro každého pracovníka a jeho pracovní poměr s příznakem určující = Ano systém provede :

¨ výpočet měsíční daně ze všech pracovních poměrů pracovníka

¨ výpočet čistého příjmu ze všech pracovních poměrů pracovníka

¨ výpočet srážek

¨ výpočet půjček

¨ výpočet k výplatě

Je-li v parametrech mezd nastaven způsob výpočtu sociálního pojištění za organizaci „souhrnně“, pak se po výpočtu příjmů posledního pracovníka provede výpočet základu a odvodu sociálního pojištění organizace v celkové částce za všechny pracovníky.

Při optimalizovaném výpočtu všech mezd se vypočtou mzdy všech pracovníků a všechny odvody za organizaci. Poté může nastat situace, kdy se určité údaje u jednotlivých pracovníků změní, pak uživatel spustí optimalizovaný výpočet mezd pouze daného pracovníka. Odvody se ovšem v tento okamžik nepřepočítají, tzn. že před finalizací mezd je nutno znovu ještě jednou spustit optimalizovaný výpočet všech, aby se znovu správně přepočítaly odvody za organizaci.

Optimalizovaný výpočet mezd JEDNOHO pracovníka

Pod menu Volby v činnosti Výplatní lístky je k dispozici činnost "Pomocný optimalizovaný výpočet JEDNOHO pracovníka". Tato činnost je výhodná zejména pro společnosti s vysokým počtem zaměstnanců, protože klasický Optimalizovaný výpočet bývá v některých případech příliš pomalý. Činnost je vhodná pro přepočet jednoho pracovníka, pokud je potřeba zjistit, jak bude vypadat jeho výplatní lístek a pokud si nejsme jisti, zda je u tohoto pracovníka vše zadáno správně.

Po kontrole pracovníka se MUSÍ spustit klasický Optimalizovaný výpočet pro všechny pracovníky nebo se ručně musí dorovnat zaokrouhlení odvodu sociálního pojištění.

POZOR - činnost "Pomocný optimalizovaný výpočet JEDNOHO pracovníka" neprovádí korekci zaokrouhlování na položce Odvod sociálního pojištění.

Minimální mzda:

Při optimalizovaném výpočtu mezd je zobrazena tabulka s pracovníky, systém vznese dotaz „Hrubý příjem je menší než min. mzda. Doplnit položku pro vyrovnání do výše minimální mzdy? Pokud ano, doplní se položka, pokud ne, ponechá se vypočtený hrubý příjem.„ a výpočet se pak dokončí podle odpovědi na dotaz.

Testuje se měsíční min. mzda nebo hodinová min. mzda podle toho, jakým způsobem je pracovník odměňován (příslušný atribut na záložce pracovního poměru a rovněž na pracovní funkci). Pracovní funkce má u sebe informaci o tom, jak je pracovník odměňován (měsíčně nebo hodinově). Tento atribut slouží k předplnění atributu na záložce pracovní poměry – zadá se tam pracovní funkce a způsob odměňování se předplní (jako i atributy kalendář, stupnice, třída, …). Do mzdy se pro tyto účely nezahrnuje mzda za práci přesčas, příplatek za práci ve ztíženém a zdraví škodlivém pracovním prostředí, za práci v noci a za práci ve svátek.

Kalendáře fondu pracovní doby zůstávají beze změn. Hodinová mzda se upraví podle údajů v kalendáři uvedeném u pracovního místa. U měsíční mzdy dochází ke krácení minimální mzdy ve vztahu k odpracované době. Ke každému pracovníkovi se stanoví procentu krácení hodinové min. mzdy. Při výpočtu minimální mzdy se pracuje s mzdovými položkami, které mají zaškrtnuto „mzda pro účely srovnání s minimální mzdou“ a „odpracované hodiny pro účely srovnání s minimální mzdou“. Minimální mzda se vztahuje jen na některé zaměstnance, je to v závislosti na druhu pracovního poměru (např. na druh pracovního poměru dohoda se nevztahuje).

Algoritmus výpočtu min. mzdy je následující, systém zjistí:

¨ součet peněz u mzdových položek, které mají zaškrtnuto „částku zahrnout pro srovnání s min. mzdou“

¨ součet odpracovaných hodin u mzdových položek, které mají zaškrtnuto „hodiny zahrnout pro srovnání s min. mzdou“

¨ zda má pracovník hodinovou nebo měsíční mzdu

¨ věk a invaliditu zaměstnance a jeho hodinovou či měsíční mzdu krátí na několik procent

¨ dochází k úpravě hodinové minimální mzdy (nastaveno podle parametrů plánovacího kalendáře):

- pracuje-li prac. v 8h prac. době, je ponechána sazba 42,50 Kč (sazba platná pro r. 2005)

- pracuje-li prac. méně než 8h denně, je přepočítáno podle vzorce sazba=42,50 * (40/skut.hodiny*5). Sazba pak vyjde vyšší než 42,50

- pracuje-li více než 8h, je ponechána sazba 42,50

Formulář

Formulář činnosti - Karta pracovníka
Pracovník Jednoznačná identifikace pracovníka

Vyvolávané činnosti

K. | Činnost | Popis
F2 | Karta pracovníka | Karta pracovníka

Viz.také

Karta pracovníka | Dotazy výpočtu | Protokol strukturovaný


Odblokování uzamčení pořizování a výpočtu

Popis

Prvotním cílem této činnosti je zamezit opravám hrubých mezd, pokud již byly vypočteny čisté mzdy. Možnost tohoto zablokování zároveň zasahuje do činností parametry, optimalizovaný výpočet mezd, výplatní lístky a výplatní lístky – zadávání.

Doporučené kroky při zadávání mezd jsou:

¨ kompletní zadání hrubých mezd

¨ spuštění optimalizovaného výpočtu všech pracovníků. Tím dojde k zamknutí (zablokování) pořizování hrubých mezd a spuštění výpočtu.

¨ v případě potřeby návratu k hrubým mzdám je možno je odemknout činností „odblokování uzamčení pořizování a výpočtu“ (menu Mzdy – Mzdy)

¨ pak provést potřebné úpravy v hrubých mzdách

¨ opět spustit výpočet mezd a tím zároveň opět dojde k jeho zablokování

Projevující se vliv této činnosti v ostatních činnostech mezd:

¨ parametry – v činnosti je parametr „uzamčení“, který obsahuje datum, ke kterému jsou opravy a výpočet mezd uzamčeny. Je-li datum vyplněné, pak jsou výplatní lístky a jejich výpočet právě k tomuto datu zablokovány (uzamčeny). Je-li datum prázdné, pak jsou výplatní lístky a jejich výpočet odblokovány a přístupny k potřebným opravám.

¨ výplatní lístky, výplatní lístky – zadávání – možnost vkládání, opravy a rušení záznamů na výplatních lístcích závisí právě na výše uvedeném parametru „uzamčení“. Zároveň je nutno zdůraznit, že vkládání, oprava a rušení záznamů závisí rovněž na datu poslední uzávěrky.

¨ optimalizovaný výpočet mezd – spuštění této činnosti je přímo závislé na parametru „uzamčení“. Je-li datum uzamčení nastaveno na měsíc, který je právě zpracováván, nelze pak tuto činnost spustit a je nutné datum uzamčení odblokovat. Pokud dojde ke spuštění optimalizovaného výpočtu a je prováděn výpočet za VŠECHNY pracovníky, kód výpočtu automaticky nastaví parametr uzamčení a tím dojde k zablokování oprav a opětovného výpočtu. Pokud dojde ke spuštění optimalizovaného výpočtu a je prováděn pouze pro jednoho pracovníka nebo skupinu pracovníků, kód výpočtu parametr uzamčení nenastavuje a nedojde k žádnému zablokování.

¨ odblokování uzamčení pořizování a výpočtu – tato činnost umožňuje uživateli odblokovat parametr uzamčení. Po spuštění odblokování je pak parametr uzamčení nastaven na prázdné datum. Odblokování uzamčení je rovněž možno provést smazáním data uzamčení v činnosti parametry.

Datový model

  • MZPARAM Parametry

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


VÝČETKA PLATIDEL

Popis

Tato činnost se nachází v menu Mzdy – Mzdy. Využije ji nejspíš pouze ten uživatel, který vyplácí své mzdy nikoliv převodem na účet pracovníka, ale v hotovosti. Činnost mu usnadní spočítat výčetku platidel pro výplatu každého pracovníka. Obsahuje tři možnosti:

¨ číselník platidel – nadefinovaný číselník jednotlivých platidel

¨ jednotlivé výčetky platidel – přehled za vybrané pracovníky

¨ sumární výčetka platidel za výplatní místo – celkový přehled výčetky platidel za zvolené výplatní místo

Datový model

  • MZMZDY Mzda

    • Viz.také

    Číselník platidel | Jednotlivé výčetky platidel | Sumární výčetka platidel


Číselník platidel

Popis

Jedná se o číselník platidel používaných při peněžním styku. Uživatel si zde zadá všechny platidla, která bude následně ve výčetkách používat (např. koruny, desetikoruny, stokoruny, tisícikoruny, ..).

Datový model

  • MZPLATID Číselník platidel

    • Formulář

    Formulář činnosti - Srážky
Hodnota | Hodnota platidla
Název | Název platidla
Mřížka [Číselník bankovek a mincí]

    Mřížka [Číselník bankovek a mincí] činnosti - Srážky

    Mřížka [Číselník bankovek a mincí] činnosti - Srážky
Hodnota | Hodnota platidla
Název | Název platidla

    Atributy tisku

    Základní údaje
Hodnota | Hodnota platidla | MZPLATID_mz57id | N(4)
Název | Název platidla | MZPLATID_mz57popis | C(40)


Jednotlivé výčetky platidel

Popis

Uživatel má možnost připravit si výčetku platidel (neboli seznam kolik Kč v jaké hodnotě má pracovníkovi při mzdě vyplatit) za daného pracovníka. Přestože na obrazovce je vidět pouze výčetka platidel daného pracovníka, systém na pozadí automaticky počítá sumární (tzn. za všechny pracovníky) výčetku platidel.

Při prvním spuštění této činnosti v každém novém měsíci je nejprve nutno zaškrtnout příznak "přepočítat", aby se uživateli zobrazily aktuální hodnoty výčetky. Pokud dojde ke změně již vypočtených mezd (oprava položek), je i v tomto případě výčetku platidel nutno přepočítat.

Datový model

  • MZPLSACK Výčetka platidel pro jednotlivé výplatní sáčky
    • MZPLATID Číselník platidel
    • MZKARTA Pracovník (alias MZKARTA7)

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Seznam pracovníků pro výběr | Seznam pracovníků pro výběr (karta pracovníka)

    Formulář

    Formulář činnosti - Seznam pracovníků pro výběr
Mřížka [Jednotlivé výčetky platidel]
Listovací rámeček
Stránka #1 Jednotlivé výčetky platidel
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Hodnota | Hodnota platidla
 | Název platidla
Počet | Počet kusů jednotlivého platidla
Stránka #2 Výběr
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Měsíc | Měsíc zpracování mezd
Rok | Rok zpracování mezd
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska
Přepočítat | Přepočítat výčetku platidel - Ano/Ne ?

    Mřížka [Jednotlivé výčetky platidel] činnosti - Seznam pracovníků pro výběr

    Mřížka [Jednotlivé výčetky platidel] činnosti - Seznam pracovníků pro výběr
OSC | Jednoznačná identifikace pracovníka
Hodnota | Hodnota platidla
Počet | Počet kusů jednotlivého platidla
Název | Název platidla
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Titul | Titul pracovníka (před jménem)

    Atributy tisku

    Základní údaje
OSC | Jednoznačná identifikace pracovníka | MZPLSACK_mz01id | C(6)
Hodnota | Hodnota platidla | MZPLSACK_mz57id | N(4)
Počet | Počet kusů jednotlivého platidla | MZPLSACK_mz58pocet | N(4)
Název | Název platidla | MZPLATID_mz57popis | C(40)

    Viz.také

    Seznam pracovníků pro výběr


Sumární výčetka platidel

Popis

Uživateli se zobrazí sumární výčetka platidel za dané výplatní místo. V tomto případě není nutno zadávat žádný příznak "přepočítat".

Datový model

  • MZPLSUMA Sumární výčetka platidel
    • MZPLATID Číselník platidel
    • MZVYPMIS Výplatní místo

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Výplatní místa | Místa, pro která se při výplatě dělají výčetky platidel.

    Formulář

    Formulář činnosti - Výplatní místa
Mřížka [Sumární výčetka platidel]
Listovací rámeček
Stránka #1 Sumární výčetka platidel
Výpl. místo | Jednoznačná identifikace výplatního místa
 | Název výplatního místa
Hodnota | Hodnota platidla
 | Název platidla
Počet | Počet kusů daného platidla (bankovky, mince)
Stránka #2 Výběr
Výpl. místo | Jednoznačná identifikace výplatního místa
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Sumární výčetka platidel] činnosti - Výplatní místa

    Mřížka [Sumární výčetka platidel] činnosti - Výplatní místa
Výpl. místo | Jednoznačná identifikace výplatního místa
Hodnota | Hodnota platidla
Počet | Počet kusů daného platidla (bankovky, mince)
 | Název výplatního místa
 | Název platidla

    Atributy tisku

    Základní údaje
Výpl. místo | Jednoznačná identifikace výplatního místa | MZPLSUMA_mz22id | C(6)
Název výplatního místa | Název výplatního místa | MZVYPMIS_mz22nazev | C(40)
Hodnota | Hodnota platidla | MZPLSUMA_mz57id | N(4)
Název platidla | Název platidla | MZPLATID_mz57popis | C(40)
Počet | Počet kusů daného platidla (bankovky, mince) | MZPLSUMA_mz64pocet | N(4)

    Viz.také

    Výplatní místa


ODVODY NA ZP A SP

Popis

Tuto činnost má uživatel k dispozici v menu Mzdy – Mzdy. Obsahuje tři činnosti:

¨ sumář odvodů zdrav. poj. – uživatel si zvolí výběr za měsíc, rok a zdravotní pojišťovnu a má pak k dispozici údaje jakou výši zdravotního pojištění organizace zdravotní pojišťovně odvedla (přesněji počet pracovníků, základ zdrav.poj., zdrav.poj. za organizaci a zdrav.poj. za pracovníky)

¨ odvody zdrav.poj. – lidi – přehled jednotlivých odvodů zdravotního pojištění za pracovníky

¨ odvody soc.poj. dle lidí – přehled jednotlivých odvodů sociálního pojištění za pracovníky

Viz.také

Sumář odvodů zdrav. poj. | Odvody zdrav. poj. - lidi | Odvody soc. poj. dle lidí


Sumář odvodů zdrav. poj.

Popis

Jedná se o činnost, poskytující uživateli informace o měsíčních částkách, které organizace odvedla zdravotním pojišťovnám. Výběr je možný definovat za měsíc, rok a příslušnou zdravotní pojišťovnu.

Tato činnost má pouze informativní charakter, v případě potřeby je možno zobrazené informace i vytisknout.

Datový model

  • MZPOJSUM Sumární přehled za pojišťovny

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Zdravotní a sociální pojišťovny | Seznam zdravotních pojišťoven

    Formulář

    Formulář činnosti - Zdravotní a sociální pojišťovny
Mřížka [Sumární přehled za pojišťovny]
Listovací rámeček
Stránka #1 Sumární přehled za pojišťovny
Měsíc | Měsíc zpracování mezd
Rok | Rok zpracování mezd
Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,...
 | Název adresáta
Počet lidí | Počet lidí, kteří jsou v jedné pojišťovně
Základ ZP | Základ zdravotního pojištění
Odvod ZP prac. | Odvod zdravotního pojištění pracovník
Odvod ZP org. | Odvod ZP organizace
Stránka #2 Výběr
Měsíc | Měsíc zpracování mezd
Rok | Rok zpracování mezd
Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,...
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Sumární přehled za pojišťovny] činnosti - Zdravotní a sociální pojišťovny

    Mřížka [Sumární přehled za pojišťovny] činnosti - Zdravotní a sociální pojišťovny
Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,...
Počet lidí | Počet lidí, kteří jsou v jedné pojišťovně
Základ ZP | Základ zdravotního pojištění
Odvod ZP prac. | Odvod zdravotního pojištění pracovník
Odvod ZP org. | Odvod ZP organizace
Měsíc | Měsíc zpracování mezd
Rok | Rok zpracování mezd

    Atributy tisku

    Základní údaje
Mzdová položka | Jednoznačná identifikace mzdové položky | MZPOJSUM_mz28id | C(6)
Počet lidí | Počet lidí, kteří jsou v jedné pojišťovně | MZPOJSUM_mz65pocet | N(6)
Základ ZP | Základ zdravotního pojištění | MZPOJSUM_mz65zakl | N(16,4)
Odvod ZP prac. | Odvod zdravotního pojištění pracovník | MZPOJSUM_mz65odvpr | N(16,4)
Odvod ZP org. | Odvod ZP organizace | MZPOJSUM_mz65odvorg | N(16,4)
Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,... | MZPOJSUM_mz70idp | C(3)
Adresát | Identifikace adresáta | ADADSAT_ad01id | C(6)
Název | Název adresáta | ADADSAT_ad01adsat | C(100)
Měsíc | Měsíc zpracování mezd | MZPOJSUM_mz02mesic | C(2)
Rok | Rok zpracování mezd | MZPOJSUM_mz02rok | C(4)
Identifikace adresáta | Identifikace adresáta | ADADSATVL_ad01id | C(6)
Název adresáta | Název adresáta | ADADSATVL_ad01adsat | C(100)
IČO | Identifikační číslo organizace. | ADADSATVL_ad01ico | C(10)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADRVL_ad02ulice | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADRVL_ad13psc | C(10)
Město | Město adresy adresáta. | ADADRVL_ad02mesto | C(40)
Kód banky | Kód banky | ADBUCTY_oc02idbank | C(4)
Prefix ú. | Prefix bankovního účtu adresáta | ADBUCTY_ad03pructu | C(6)
Č. účtu | Číslo bankovního účtu adresáta. | ADBUCTY_ad03ucet | C(34)

    Viz.také

    Zdravotní a sociální pojišťovny


Odvody zdrav. poj. - lidi

Popis

Jedná se o činnost, poskytující uživateli informace o měsíčních částkách, které organizace odvedla na zdravotním pojištění za jednotlivé pracovníky. Výběr je možný definovat za měsíc, rok a příslušnou zdravotní pojišťovnu.

Tato činnost má pouze informativní charakter, v případě potřeby je možno zobrazené informace i vytisknout.

Datový model

  • MZPOJIST Přehled za pojišťovny za jednotlivé lidi
    • MZKARTA Pracovník (alias MZKARTA3)

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Karta pracovníka | Karta pracovníka
F2 | Zdravotní a sociální pojišťovny | Seznam zdravotních pojišťoven

    Formulář

    Formulář činnosti - Karta pracovníka
Mřížka [Odvody zdravotního pojištění]
Listovací rámeček
Stránka #1 Odvody zdravotního pojištění
OSC | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Rodné číslo | Rodné číslo
Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,...
 | Název adresáta
Číslo pojištěnce | Číslo pojištěnce ve zdravotní pojišťovně. Uvádějte pouze je-li různé od rodného čísla.
Měsíc | Měsíc zpracování mezd
Rok | Rok zpracování mezd
Základ ZP | Základ zdravotního pojištění
Odvod ZP pracovník | Odvod zdravotního pojištění pracovník
Odvod ZP organizace | Odvod zdravotníhopojištění organizace
Stránka #2 Výběr
Měsíc | Měsíc zpracování mezd
Rok | Rok zpracování mezd
Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,...
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Odvody zdravotního pojištění] činnosti - Karta pracovníka

    Mřížka [Odvody zdravotního pojištění] činnosti - Karta pracovníka
Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,...
OSC | Jednoznačná identifikace pracovníka
Základ ZP | Základ zdravotního pojištění
Odvod ZP pracovník | Odvod zdravotního pojištění pracovník
Odvod ZP organizace | Odvod zdravotníhopojištění organizace
Měsíc | Měsíc zpracování mezd
Rok | Rok zpracování mezd

    Atributy tisku

    Základní údaje
Měsíc | Měsíc zpracování mezd | MZPOJIST_mz02mesic | C(2)
Rok | Rok zpracování mezd | MZPOJIST_mz02rok | C(4)
Základ ZP | Základ zdravotního pojištění | MZPOJIST_mz67zakl | N(16,4)
Odvod ZP pracovník | Odvod zdravotního pojištění pracovník | MZPOJIST_mz67odvpr | N(16,4)
Odvod ZP organizace | Odvod zdravotníhopojištění organizace | MZPOJIST_mz67odvorg | N(16,4)
Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,... | MZPOJIST_mz70idp | C(3)
Adresát | Identifikace adresáta | MZPOJSEZ_ad01id | C(6)
Název | Název adresáta | ADADSAT_ad01adsat | C(100)
OSC | Jednoznačná identifikace pracovníka | MZPOJIST_mz01id | C(6)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Rodné číslo | Rodné číslo | MZKARTA_mz01rodc | C(11)

    Viz.také

    Karta pracovníka | Zdravotní a sociální pojišťovny


Odvody soc. poj. dle lidí

Popis

Jedná se o činnost, poskytující uživateli informace o měsíčních částkách, které organizace odvedla na sociálním pojištění za jednotlivé pracovníky. Výběr je možný definovat za měsíc, rok a příslušnou zdravotní pojišťovnu.

Tato činnost má pouze informativní charakter, v případě potřeby je možno zobrazené informace i vytisknout.

Datový model

  • MZSOCPOJ Přehled sociálního pojištění za jednotlivé lidi
    • MZKARTA Pracovník (alias MZKARTA3)

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Karta pracovníka | Karta pracovníka

    Formulář

    Formulář činnosti - Karta pracovníka
Mřížka [Přehled sociálního pojištění]
Průměrný počet zaměstnanců | Průměrný počet zaměstnanců v měsíci
Listovací rámeček
Stránka #1 Základy a odvody SP
Datum výplaty mezd | Datum výplaty mezd
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Rodné číslo | Rodné číslo
Číslo p.p. | Číslo pracovního poměru
Měsíc | Měsíc zpracování mezd
Rok | Rok zpracování mezd
Základ SP | Základ sociálního pojištění
Odvod SP pracovník | Odvod sociálního pojištění pracovník
Odvod SP organizace | Odvod sociálního pojištění - organizace
Nemoc - kal. dnů | Kalendářních dnů nemoci
Kč | Proplacená dávka za nemoc
Ošetřování -kal. dnů | Kalendářních dnů ošetřování
Kč | Proplacená dávka za ošetřování
Vyr. př. - kal. dnů | Počet případů vyrovnávacích příspěvků
Kč | Proplacená dávka za vyrovnávací příspěvek
MD - kal. dnů | Počet případů mateřské dovolené
Kč | Proplacená dávka za mateřskou dovolenou
Stránka #2 Výběr
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Číslo p.p. | Číslo pracovního poměru
Od | Měsíc zpracování mezd
 | Rok zpracování mezd
Do | Měsíc zpracování mezd - do
 | Rok zpracování mezd - do
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Přehled sociálního pojištění] činnosti - Karta pracovníka

    Mřížka [Přehled sociálního pojištění] činnosti - Karta pracovníka
Pracovník | Jednoznačná identifikace pracovníka
Číslo p.p. | Číslo pracovního poměru
Měsíc | Měsíc zpracování mezd
Rok | Rok zpracování mezd
Základ SP | Základ sociálního pojištění
Odvod SP pracovník | Odvod sociálního pojištění pracovník
Odvod SP organizace | Odvod sociálního pojištění - organizace

    Atributy tisku

    Základní údaje
Průměrný počet zaměstnanců | Průměrný počet zaměstnanců v měsíci | Výpočet | N(10,2)
Den výplaty mezd | Den výplaty mezd | MZPARAM_mz27denvyp | N(2)
Den výplaty připadá na SOBOTU | Jestliže den výplaty mezd připadá na sobotu, vyplácejte v ... | Výpočet | C(7)
Den výplaty připadá na NEDĚLI | Jestliže den výplaty mezd připadá na neděli, vyplácejte v ... | Výpočet | C(7)
Pracovník | Jednoznačná identifikace pracovníka | MZSOCPOJ_mz01id | C(6)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Rodné číslo | Rodné číslo | MZKARTA_mz01rodc | C(11)
Rodné příjmení | Rodné příjmení | MZKARTA_mz01rodne | C(15)
Datum narození | Datum narození | MZKARTA_mz01naroz | D
Místo narození | Místo narození | MZKARTA_mz01misnar | C(40)
Adresát | Identifikace adresáta | MZKARTA_ad01id | C(6)
Adresa | Číslo adresy adresáta. | MZKARTA_ad02cisadr | C(2)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Město adresy adresáta | Město adresy adresáta. | ADADR_ad02mesto | C(40)
Číslo p.p. | Číslo pracovního poměru | MZSOCPOJ_mz32cispp | C(2)
Měsíc | Měsíc zpracování mezd | MZSOCPOJ_mz02mesic | C(2)
Rok | Rok zpracování mezd | MZSOCPOJ_mz02rok | C(4)
Základ SP | Základ sociálního pojištění | MZSOCPOJ_mz68zaklsp | N(16,4)
Odvod SP pracovník | Odvod sociálního pojištění pracovník | MZSOCPOJ_mz68odvpr | N(16,4)
Odvod SP organizace | Odvod sociálního pojištění - organizace | MZSOCPOJ_mz68odvorg | N(16,4)
Nemoc - kal. dnů | Kalendářních dnů nemoci | MZSOCPOJ_mz68dnuNE | N(3)
Kč | Proplacená dávka za nemoc | MZSOCPOJ_mz68kcne | N(6)
Ošetřování -kal. dnů | Kalendářních dnů ošetřování | MZSOCPOJ_mz68dnuos | N(3)
Kč | Proplacená dávka za ošetřování | MZSOCPOJ_mz68kcos | N(6)
Vyr. př. - kal. dnů | Počet případů vyrovnávacích příspěvků | MZSOCPOJ_mz68dnuvp | N(3)
Kč | Proplacená dávka za vyrovnávací příspěvek | MZSOCPOJ_mz68kcvp | N(6)
MD - kal. dnů | Počet případů mateřské dovolené | MZSOCPOJ_mz68dnumd | N(3)
Kč | Proplacená dávka za mateřskou dovolenou | MZSOCPOJ_mz68kcmd | N(6)
Dávka od | Datum, od kterého se poskytuje nemocenská dávka | MZNEMDAV_mz38od | D
Dávka do | Datum, do kterého se poskytuje nemocenská dávka | MZNEMDAV_mz38do | D
Dnů nepřítomnosti | Kalendářní dny, za které se poskytuje nemocenská dávka | MZNEMDAV_mz38dnu | N(8,4)
Adresát | Identifikace adresáta | ADADSATVL_ad01id | C(6)
Název | Název adresáta | ADADSATVL_ad01adsat | C(100)
IČO | Identifikační číslo organizace. | ADADSATVL_ad01ico | C(10)
DIČ | Daňové identifikační číslo adresáta. | ADADSATVL_ad01dico | C(16)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADRVL_ad02ulice | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADRVL_ad13psc | C(10)
Město | Město adresy adresáta. | ADADRVL_ad02mesto | C(40)
Nebyl v prac. poměru | Dnů v měsíci, kdy zaměstnanec nebyl v pracovním poměru. | Výpočet | N(3)
Stát | Identifikace státu. | ADADRVL_ad05id | C(3)
Pracovník | Jednoznačná identifikace pracovníka | MZM15.mz01id | C(6)
Číslo p.p. | Číslo pracovního poměru | MZM15.mz32cispp | C(2)
Od | Měsíc zpracování mezd | MZM15.mz02mesic | C(2)
Rok od | Rok zpracování mezd | MZM15.mz02rok | C(4)
Do | Měsíc zpracování mezd - do | MZM15.mz75mesdo | C(2)
Do | Rok zpracování mezd - do | MZM15.mz75rokdo | C(4)

    Viz.také

    Karta pracovníka


Uzávěrka mezd

Popis

Tato činnost (a její help) je v podstatě společná pro několik činností z komponenty mzdy. Jedná se o:

¨ uzávěrku mezd, která se aktivuje z hlavního menu Mzdy – Mzdy – Uzávěrka mezd a její podrobný popis je uveden níže

a další činnosti, které se aktivují z menu Mzdy – Speciální činnosti a v podstatě provedou pouze vždy přepočty, které se vztahují k názvu dané činnosti. Jedná se o tyto činnosti:

¨ zákonné pojištění odpovědnosti

¨ přepočet průměrů (hodinový, denní, měsíční)

¨ zjištění pravděpodobného průměru

Přepočet průměrů provede současně i uzávěrka mezd, tzn. že není nutné tuto činnost pouštět samostatně, pokud máme v plánu pustit uzávěrku mezd. Výpočet zákonného pojištění odpovědnosti a zjištění pravděpodobného průměru je však nutno aktivovat jako tuto samostatnou činnost, uzávěrka mezd s těmito údaji nepracuje.

Uzávěrku lze provést pouze v případě, že od posledního výpočtu mezd nebyla provedena žádná změna. Uzávěrka mezd pak definitivně zablokuje údaje daného měsíce pro vkládání dalších údajů. Po jejich uzavření není možné do nich znovu zasahovat, měnit jejich položky a nechat je znovu počítat. Záznamy mezd uzavřeného měsíce nelze tedy vkládat, opravovat ani rušit.

Nejschůdnější variantou je uzavírat mzdy až po jejich vyplacení, nejlépe až před výpočtem mezd za následující období. Uzávěrku mezd má uživatel k dispozici v hlavním menu mzdy – mzdy – uzávěrka mezd. Po aktivaci této činnosti se systém dotazuje „Opravdu chcete spustit uzávěrku mezd za měsíc … a rok ……? Možnosti jsou Ano – Ne. Některé akce provádí uzávěrka každý měsíc, některé pouze jestliže končí čtvrtletí.

Uzávěrka měsíčně provádí tyto akce :

¨ odečtení zůstatku dovolené

¨ pro všechny nemocenské dávky, které měly nastaveno Proplatit = Ano se nastaví Proplaceno dne a Proplatit se nastaví na Ne

¨ snížení zůstatku půjčky o uhrazenou částku

¨ aktualizaci data posledního zpracování mezd

¨ zápis do Historie karty

¨ zápis do Historie pracovního poměru

- jedná se o stav atributů „zůstatek staré dovolené“ a „zůstatek nové dovolené“ k prvnímu dni uzavíraného měsíce, tj. před započtením čerpání dovolené v uzavíraném měsíci, např. údaj pro měsíc a rok 03/2007 udává stav dovolených k 1.3.2007)

- aktualizace atributů „zůstatek staré dovolené“ a „zůstatek nové dovolené“ podle počtu dní, které byly v uzavíraném měsíci čerpány

Uzávěrka čtvrtletně provádí (pouze pro každého pracovníka a jeho pracovní poměr, který ke konci čtvrtletí trvá) :

¨ výpočet průměrného výdělku - hodinový, denní a měsíční průměr

Uzávěrka za měsíc PROSINEC aktualizuje tyto atributy:

¨ do atributu „převod dovolené do příštího roku“ se zapíše součet „zůstatku staré dovolené! a „zůstatek nové dovolené“ k datu 31.12.

¨ do atributu „zůstatek staré dovolené“ se zapíše tentýž součet „zůstatku staré dovolené“ a „zůstatku nové dovolené“ k datu 31.12.

¨ do atributu „zůstatek nové dovolené“ se zapíše počet dní, který je uveden v atributu „roční nárok na dovolenou“, tzn. že před provedením uzávěrky za prosinec je nutno mít v pořádku roční nároky na dovolenou na následující rok.

V případě nesrovnalostí zapíše uzávěrka tyto údaje do protokolu.

Datový model

  • MZPARAM Parametry (alias MP)

    • Formulář

    Formulář činnosti - Odvody soc. poj. dle lidí


ROČNÍ ZÚČTOVÁNÍ DANĚ

Popis

Tato činnost (Mzdy a personalistika – Mzdy) se spouští v systému jednou ročně, obvykle při zpracování únorových mezd. Činnost provede roční zúčtování daně z příjmu fyzických osob, tj. vypočte základ ročního zúčtování, vyrovnání přeplatku na dani a dorovná daňový bonus.

Údaje a nastavení k tomu potřebná jsou :

¨ Na kartě pracovníka – atribut podepsal prohlášení nastaven na Ano, atribut Provést roční zúčtování nastaven na Ano, doplnit roční nezdanitelné položky

¨ Na výplatním lístku – u pracovníků, kteří část roku pracovali u jiné firmy zadat údaje poskytnuté cizím zaměstnavatelem - mzdové položky Loňský příjem (příjem od jiného zaměstnavatele za uplynulý rok), Loňský odvod (odvod zdravotního a sociálního pojištění, které pracovník odvedl u jiného zaměstnavatele za uplynulý rok), Loňská daň, Loňský nárok, Loňská sleva a Loňský bonus Všechno jsou to položky typu Odvod. Musí být nadefinovány v činnosti Definice – Položky mezd – Odvody.

Ve výběru činnosti Roční zúčtování daně uživatel nastavuje:

¨ číslo pracovníka (pokud není vyplněno, automaticky se berou všichni)

¨ zaškrtávátko „přepočítat“ reguluje, zda se má spustit výpočet nebo zda chcete údaje pouze prohlížet

¨ po spuštění výpočtu se ke každému pracovníkovi (dle nastavení ve výběru) předplní dva řádky s datem. Jsou to řádky L40000 – Základ ročního zúčtování a L41000 – Vyrovnání přeplatku na dani. Tyto řádky se stanou součástí výplatního lístku (zda se budou tisknout se reguluje zaškrtnutím „Tisknout“ v činnosti Definice – Položky mezd – Odvody). Od zúčtování r.2005 se nově může objevit položka L43000 – Vyrovnání ročního daňového bonusu (položky L40000, L41000, L43000 musí být nadefinovány v činnosti Definice – Položky mezd – Odvody).

¨ Tento přepočet může uživatel spouštět několikrát

Viz.také

Roční zúčtování daně

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Roční zúčtování daně

Popis

Tato činnost (Mzdy a personalistika – Mzdy) se spouští v systému jednou ročně, obvykle při zpracování únorových mezd.

Činnost provede roční zúčtování daně z příjmu fyzických osob, tj. vypočte základ ročního zúčtování, vyrovnání přeplatku na dani a dorovná daňový bonus.

Údaje a nastavení k tomu potřebná jsou :

¨ Roční daňová tabulka

Zkontrolujte si nastavení Roční daňové tabulky. Naleznete ji v činnosti DEFINICE – Daňové tabulky souhrnné. Má identifikaci DPR001 - Podepsal, roční (druh roční).

Položky nastavte takto :

Platnost od | Od | Do | Pevná část | Sazba % | Typ vzniklé daně
1.1.2008 | 0 | 99 999 999 | 0 | 15 | Roční zúčtování

¨ Karta pracovníka

Na Kartě pracovníka - Osobní údaje – zaškrtněte „Provést roč. zúčt.“ - u těch pracovníků, kterým budete vytvářet roční zúčtování.

¨ Roční položky

Karta pracovníka má záložku Roční položky. Zde se definují: :

¨ roční nezdanitelné položky

¨ daňová zvýhodnění typu roční nebo roční s bonusem

¨ položky od jiného zaměstnavatele (loňský příjem, loňský odvod, loňská daň, loňský daňový bonus)

Roční nezdanitelné položky daně jsou např.:

KOZP | životní kapitálové připojištění
KOPP | penzijní připojištění (zadává se jen částka uznatelná jako odpočet od základu daně)
KO09 | služební auto pro soukromé účely (dodanění)
KO10 | odpočet pro dárce krve (dva tisíce Kč za každý odběr krve)
KO12 | dary (zadává se pouze částka uznatelných darů pro odpočet od základu daně)
KO13 | úroky z úvěrů
KOOD | Členské příspěvky člena odborové organizace
KOZK | Úhrady za zkoušky ověřující výsledky dalšího vzdělávání

Doporučené identifikace daňových zvýhodnění typu roční nebo roční s bonusem jsou:

Na poplatníka | JJR021
Na manželku | JJR022
Na manželku ZTP | JJR023
Na částečnou invaliditu | JJR024
Na plnou invaliditu | JJR025
Držitel průkazu ZTP/P | JJR026
Na studium | JJR027
Na dítě | JJR01
Na ZTP dítě | JJR11

Pozn.: Karta pracovníka má též záložku Daňová zvýhodnění, ale zadávají se do ní pouze Daňová zvýhodnění, která NEJSOU typu roční nebo roční s bonusem.

Identifikace položek od jiného zaměstnavatele jsou:

Loňský příjem | L30000
Loňský odvod | L31000
Loňská daň | L32000
Loňský bonus | L35000

U položky L35000 se nejedná o nároky, ale o skutečně vyplacené bonusy od jiného zaměstnavatele. Pro zpracování ročního zúčtování za rok 2008 zadejte do položky platnost 1.1.2008 až 31.12.2008. Do výplatního lístku se položky ze záložky Roční položky dostanou automaticky při výpočtu ročního zúčtování.

Ve výběru činnosti Roční zúčtování daně se nastavuje:

¨ číslo pracovníka (pokud není vyplněno, automaticky se berou všichni)

¨ zaškrtávátko „přepočítat“ reguluje, zda se má spustit výpočet nebo zda chcete údaje pouze prohlížet

¨ po spuštění výpočtu se ke každému pracovníkovi (dle nastavení ve výběru) předplní tři řádky s datem. Jsou to řádky L40000 – Základ ročního zúčtování a L41000 – Vyrovnání přeplatku na dani a položka L43000 – Vyrovnání ročního daňového bonusu (položky L40000, L41000, L43000 musí být nadefinovány v činnosti Definice – Položky mezd – Odvody).. Tyto řádky se stanou součástí výplatního lístku (zda se budou tisknout se reguluje zaškrtnutím „Tisknout“ v činnosti Definice – Položky mezd – Odvody).

¨ Tento přepočet může uživatel spouštět několikrát

Je-li vyrovnání přeplatku na dani větší než 50,- Kč, pak se vyplatí, tzn. přičte se k čisté mzdě. Je-li vyrovnání přeplatku na dani menší než 0,- Kč (nedoplatek), pak se v ročním zúčtování uvažuje jako 0,- Kč a situace se srovná další měsíc jako doplatek daně.

Algoritmus ročního zúčtování

¨ základ ročního zúčtování se vypočte jakou součet všech zálohově zdanitelných příjmů aktuálního pracovníka za uplynulý rok. Přičtou se odvody zdravotního a sociálního pojištění aktuálního pracovníka za uplynulý rok, které za pracovníka odvedla organizace. Odečtou se nezdanitelné měsíční položky aktuálního pracovníka za uplynulý rok. K základu se přičte Loňský příjem a přičte se Loňský odvod. Loňský příjem je příjem od jiného zaměstnavatele za uplynulý rok. Loňský odvod je odvod zdravotního a sociálního pojištění, který jiný zaměstnavatel odvedl za pracovníka za uplynulý rok.

¨ sčítají se základy aktuálního pracovníka za všechny jeho pracovní poměry, tj. základ ročního zúčtování daně = příjmy zdanitelné zálohově + odvody SP organizace + odvody ZP organizace – nezdanitelné položky měsíční + loňský příjem + loňský odvod – nezdanitelné položky roční

¨ vypočtený základ se pak zaokrouhlí na celé stokoruny směrem dolů

¨ daň se vypočte podle roční daňové tabulky

¨ maximální daňové zvýhodnění na děti se skládá z nároku na daňové zvýhodnění od stávajícího zaměstnavatele a z nároku na daňové zvýhodnění od minulého zaměstnavatele (mzdová položka L33000)

¨ porovnáním maximálního daňového zvýhodnění na děti a daně vypočtené dle roční daňové tabulky se určí roční sleva na dani

¨ daň po slevě = daň podle roční daňové tabulky – roční sleva na dani

¨ přeplatek na dani se vypočte jako součet zálohových daní + loňská daň – (daň dle roční daňové tabulky – roční sleva na dani). Tato hodnota se zapíše do mzdové položky L41000

¨ roční daňový bonus se určí jako maximální daňové zvýhodnění na děti mínus roční sleva na dani

¨ vyplacené měsíční daňové bonusy a měsíční daňové bonusy vyplacené od minulého zaměstnavatele (mzdová položka L35000) se sečtou

¨ rozdíl na daňovém bonusu se určí jako roční daňový bonus mínus součet vyplacených měsíčních daňových bonusů. Na rozdíl na daňovém bonusu má nárok pouze ten zaměstnanec, který dosáhl příjmu alespoň ve výši šestinásobku minimální mzdy. Tato hodnota se zapíše do mzdové položky L43000.

¨ vyrovnání přeplatku na dani se určí kompenzací přeplatku na dani a rozdílu na daňovém bonusu

Datový model

  • MZMZDY Mzda
    • MZKARTA Pracovník
    • MZMZDPOL Mzdová položka
      • MZDOPPOL Doplnění mzdové položky
    • MZKARTA Pracovník (alias MZKARTA3)

    • Formulář

    Formulář činnosti - INFORMACE O PRACOVNÍKOVI
Mřížka [Mzdy]
Listovací rámeček
Stránka #1 Roční zúčtování mezd
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Prac. poměr | Číslo pracovního poměru
 | Popis pracovní funkce (pracovního zařazení)
Měsíc | Měsíc zpracování mezd
Rok | Rok zpracování mezd
Mzd.pol. | Jednoznačná identifikace mzdové položky
 | Popis mzdové položky
Adresát | Identifikace adresáta
 | Název adresáta
Účet | Identifikátor spojení na bankovní účet adresáta.
KS | Konstantní symbol
VS | Variabilní symbol
Poznámka | Poznámka
V penězích | Vyplatit uvedenou částku hotově (nevyplácet = např. nepeněžní dar)
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
Zadáno | Způsob, jakým byl záznam pořízen.
Tisknout | Tisknout na výplatním lístku (netisknout = pojistné hrazené zaměstnavatelem,...)
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Výběr
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
do měsíce | Měsíc zpracování mezd
a roku | Rok zpracování mezd
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska
Přepočítat | Spustit přepočet ročního zúčtování - Ano/Ne ?

    Mřížka [Mzdy] činnosti - INFORMACE O PRACOVNÍKOVI

    Mřížka [Mzdy] činnosti - INFORMACE O PRACOVNÍKOVI
Pracovník - OSC | Jednoznačná identifikace pracovníka
Číslo p.p. | Číslo pracovního poměru
Měsíc | Měsíc zpracování mezd
Rok | Rok zpracování mezd
Mzdová položka | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
Tisknout | Tisknout na výplatním lístku (netisknout = pojistné hrazené zaměstnavatelem,...)
Příjmení | Příjmení pracovníka

    Vyvolávané činnosti

    K. | Činnost | Popis
- | INFORMACE O PRACOVNÍKOVI |
F2 | Karta pracovníka | Karta pracovníka
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Výběr mzdové položky | Lupa v činnosti Výplatní lístky na Identifikace mzdové položky
F2 | Výběr pracovního poměru | Výběr prac. poměru - k již zadanému pracovníkovi

    Atributy tisku

    Základní údaje
OSC | Jednoznačná identifikace pracovníka | MZMZDY_mz01id | C(6)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Číslo p.p. | Číslo pracovního poměru | MZMZDY_mz32cispp | C(2)
Měsíc | Měsíc zpracování mezd | MZMZDY_mz02mesic | C(2)
Rok | Rok zpracování mezd | MZMZDY_mz02rok | C(4)
Mzdová položka | Jednoznačná identifikace mzdové položky | MZMZDY_mz28id | C(6)
Popis | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.) | MZMZDY_mz02kc | N(20,2)

    Viz.také

    INFORMACE O PRACOVNÍKOVI | Karta pracovníka | Obchodní selektor | Organizační selektor | Technicko-věcný selektor | Výběr mzdové položky | Výběr pracovního poměru


DEFINICE

Popis

Tato činnost v sobě sdružuje všechny činnosti, které mají definiční charakter, tzn., že před vlastním výpočtem mezd musí být vyplněny (např. číselník tarifních stupnic, výplatních míst apod.).

Viz.také

Pracovní místa skut. a typová | POLOŽKY MEZD | Tarifní stupnice | Daňové tabulky souhrnné | Výplatní místa | Pracovní doba | Zdravotní a sociální pojišťovny | Druh události | Umístění mezd | Palety barev kategorií pracovníků | Kategorie pracovníků | Dotazy při běhu výpočtu | Algoritmy výpočtu protokolu | Hodnoty sady konstant | Stav dovolených


POLOŽKY MEZD

Popis

Definice mzdových položek se provádí v činnosti Mzdy – Definice – Položky mezd. Vlastní nastavení mzdových položek má přímý vliv na výpočet mezd.

Nastavením definic položek mezd se ovlivňuje běh výpočtu hrubých mezd. Zejména vztah právě definované položky mezd k sociálnímu a zdravotnímu pojištění, ke čtvrtletním průměrům, ke kalendáři a jeho fondu pracovní doby, k druhu události mezd, atd. Na výplatním lístku pracovníka se položky tisknou v pořadí podle identifikace položky. Kombinací atributů Původ Kč/j a Výpočet Kč se nastaví chování mzdové položky.

Nastavení definice mzdových položek není rozhodně triviální záležitostí, proto se domníváme, že by toto měl dělat zkušený pracovník mezd v součinnosti s implementátorem.

Viz.také

PŘÍJMY A NÁHRADY | Neplacené volno | Součty příjmů | Odvody | Nezdanitelné položky měsíční | Nezdanitelné položky roční | Daňová zvýhodnění a slevy na dani | Dávky nemocenského pojištění | Půjčky | Srážky | Doplňkové odvody a daňová zvýhodnění | Exekuce | Výběr mzdové položky


PŘÍJMY A NÁHRADY

Popis

Činnost Příjmy a náhrady je součástí sekce DEFINICE. Jedná se o činnost, ve které je možné nastavit jednotlivé mzdové položky, které během výpočtu vytvoří hrubou část mezd. Jedná se o číselník příjmů a náhrad. Z větší části je dodáván naplněný, lze ho naplnit i pomocí importů a samozřejmě ho lze běžně aktualizovat a modifikovat. Podrobný popis a nastavení jednotlivých atributů je uvedeno přímo v helpu vlastní činnosti Příjmy a náhrady.

Viz.také

Příjmy a náhrady | Doplňující údaje k příjmům


Příjmy a náhrady

Popis

Jedná se o číselník příjmů a náhrad. Z větší části je dodáván naplněný, lze ho naplnit i pomocí importů a samozřejmě ho lze běžně aktualizovat a modifikovat.

Význam jednotlivých položek je následující:

¨ identifikace - jednoznačná identifikace mzdové položky

¨ příjem - popis mzdové položky

¨ původ Kč/j - původ Kč za jednotku. Pomocí tohoto atributu se určí způsob, kterým se při použití ve výplatních lístcích (činnost Prohlížení výplatních lístků) nastaví atribut Kč/j tj. částka za jednotku času. Možnosti jsou :

- zadaná částka - do Kč / j se přenese hodnota uvedená u příjmu, nebo u pravidelného příjmu na kartě pracovníka. Hodnota na kartě má přednost před hodnotou uvedenou u příjmu!!! Např. při zadávání klasické měsíční mzdy se do Kč/j neuvede nic, protože se to uvede u každého pracovníka zvlášť (na jeho kartě). Tato možnost se použije též u prémií a odměn.

- dle tarifu prac. - do Kč / j se po zadání ke konkrétnímu pracovníkovi přenese jeho sazba uvedená v jeho tarifní třídě (tato tarifní třída odpovídá jeho tarifní stupnici).

- úkolová dle tar. prac. - příjem s touto hodnotou musí mít vyplněnou volbu úkolová - tarifní. V této volbě se zadá kombinace tarifní stupnice a tarifní třídy a hodnota Kč/j. Tato hodnota Kč/j není shodná s hodinovou mzdou uvedenou v číselníku tarifních stupnic a jejich tříd. Např. daný pracovník má přidělenu tarifní stupnici A a tarifní třídu 5 s hodinovou mzdou 56,- Kč. U mzdové položky je ve volbě úkolová - tarifní pro stupnici A a tarifní třídu 5 uvedena hodnota Kč/j 70,- Kč. Při použití takové mzdové položky (která má tedy uveden původ Kč/j - úkolová dle tarifu pracovníka) bude program automaticky počítat s hodnotou 70,- Kč/j.

- vyšší ze zadaná částka - tarif pracovníka - porovná se hodnota Kč/j a tarif pracovníka (systém vybere tu vyšší)

- vyšší ze zadaná částka - úkolová dle tar. prac. - porovná se hodnota Kč/j a tarif pracovníka. V tomto případě se tarif pracovníka zadává přímo v této činnosti pomocí volby Úkolová-tarifní.

- hod.průměr - do Kč / j se přenese hodnota uvedená na kartě pracovníka, tj. hodinový průměr. Tento původ Kč/j se využije např. při zadávání dovolené hodinově, paragrafu, ......

- den.průměr - do Kč / j se přenese hodnota uvedená na kartě pracovníka, tj. denní průměr. Tento původ Kč/j se využije např. při zadávání denní dovolené, .....

- měs.průměr - do Kč / j se přenese hodnota uvedená na kartě pracovníka, tj. měsíční průměr.

- dle artiklu mezd – tento příjem se používá pouze v úkolových listech, nikoliv v zadávání mezd přes výplatní lístky. V úkolových listech je k dispozici artikl (je v artiklech mezd a zároveň i v ceníku na obchodu), ve výplatních lístcích artikl mezd není. Pracovník má v pracovním poměru tarifní třídu a v ní je cenová skupina. Při použití mzdové položky typu „dle artiklu mezd“ se najde podle pracovníka cenová skupina a podle artiklu mezd (zadá se na úkolovém listu) se hledá v ceníku komponenty obchod. V ceníku se podle skupiny a artiklu najde částka a ta se použije do mzdové položky.

- vzorcem – používá se spolu s atributem Vzorec, atribut Kč/j se předplní podle údaje uvedeného v atributu Vzorec

¨ vzorec pro zjištění položky koeficient - vzorec pro koeficient se bude používat až ve výpočtu, pro zjištění skutečného koeficientu. Vzorec pro koeficient může záviset na pracovníkovi, na jeho pracovním poměru, na mzdové položce v aktuálním měsíci apod. Pokud je z hlediska obsahu vzorce možné ho v činnosti Příjmy a náhrady vyčíslit, pak se přímo v této činnosti zapíše, jinak zůstane na hodnotě 1 a vzorec se uplatní až později. Uplatňuje se při výpočtu v kombinaci s použitím mzdové položky v Pravidelných příjmech. Může být zapsán i výrazem ve tvaru FoxPro (tzn. vytvořen select např. že když pracovník nepřekročí určitou výši vyrobených zmetků, tak má nárok na 20% prémií apod.).

¨ Kč / j - korun za jednotku (např. výkonu, hodin, ....)

¨ koeficient - koeficient, jímž se násobí Kč/j. Na jeho základě se vypočítá konečná částka mzdové položky. Obvykle je tento koeficient 1. Je možné ho ale přepsat na libovolnou hodnotu, např. hodnota 0,5 znamená, že se konečná částka mzdové položky vezme jen z 50-ti %.

¨ výpočet Kč - způsob výpočtu celkové částky Kč (výběr z možností). Ač to u této položky není uvedeno (kvůli nedostatku místa) je každá tato možnost při výpočtu mzdy násobena koeficientem. Možnosti jsou:

- Kč/j – celková částka na mzdové položce bude totožná s atributem Kč/j

- Dnů * Kč/j - celková částka na mzdové položce vznikne vynásobením počtu odpracovaných dnů atributem Kč/j

- Dnů/ Dnů FPD v období x Kč/j – celková částka na mzdové položce vznikne úpravou podle fondu pracovní doby a to ve dnech a vynásobením atributem Kč/j

- Hodin * Kč/j - celková částka na mzdové položce vznikne vynásobením počtu odpracovaných hodin atributem Kč/j

- Hodin/ hodin FPD v období x Kč/j - celková částka na mzdové položce vznikne úpravou podle fondu pracovní doby a to v hodinách a vynásobením atributem Kč/j

- Výkon * Kč/j - celková částka na mzdové položce vznikne vynásobením atributu Výkon atributem Kč/j

¨ dopl. údaje - jednoznačná identifikace doplňující položky mezd. Vazba na sadu doplňujících údajů, které řídí chování mzdové položky např. vůči daním, zdravotnímu pojištění, ...

¨ vyplatit v penězích - zda vyplácet částku (v Kč) v hotovosti, tzn. mzdová položka bude započtena do výplatního lístku v penězích, nikoliv jako nepeněžní plnění

¨ tisknout - zda se položka má tisknout na výplatním lístku

¨ povoleny nulové dny – zaškrtnutím je povoleno uvést počet dnů 0 (u příjmové položky, která vznikla pomocí pravidelných příjmů je nutná možnost zápisu odlišných hodin a odlišných dnů)

¨ povoleny nulové hodiny – zaškrtnutím je povoleno uvést počet hodin 0

¨ komentář - bližší popis k dané mzdové položce

¨ platnost položky od data do data (datum zahájení a datum ukončení platnosti položky)

¨ druh události – identifikace druhu účetní události (výběr z číselníku)

¨ technický selektor – možnost výběru z číselníku technicko-věcných selektorů

Pokud se jedná o úkolovou - tarifní mzdovou položku, je nutno na záložce "úkolová - tarifní" zadat další údaje, které se týkají právě této položky. Zadává se tarifní stupnice, třída a Kč/j (viz. příklady vyplnění uvedené výše v popisu).

Datový model

  • MZMZDPOL Mzdová položka
    • MZDOPPOL Doplnění mzdové položky

    • Vyvolávané činnosti

    K. | Činnost | Popis
^O | Úkolová-tarifní | Sazba za úkolovou mzdu závisí na stupnici a tarifní třídě pracovníka.
F2 | Doplňující údaje k příjmům | Informace o zařazení položky do zdrav. poj., zdanění, ap. ...
F2 | Druh události | Druh události (mzdové)
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

    Formulář činnosti - Druh události
Mřížka [příjmy]
Listovací rámeček
Stránka #1 Příjmy a náhrady
Identifikace | Jednoznačná identifikace mzdové položky
 | Popis mzdové položky
Původ Kč / j | Původ Kč / j
Vzorce | Vzorec pro zjištění položky Kč_j
 | Vzorec pro zjištění položky koeficient
Kč / j | Kč / j
Koeficient | Koeficient, jímž se násobí Kč / j
Výpočet Kč | Způsob výpočtu celkové částky Kč
Dopl. údaje | Jednoznačná identifikace doplňující položky mezd
 | Popis doplňující položky mezd
Od data | Datum zahájení platnosti položky. Platnost se bere v potaz při vložení položky na Kartu pracovníka nebo do Výplatního lístku.
do data | Datum ukončení platnosti položky.Platnost se bere v potaz při vložení položky na Kartu pracovníka nebo do Výplatního lístku.
Druh události | Identifikace účetní události
Vyplatit v penězích | Vyplácet částku (Kč) v hotovosti
Tisknout | Položka bude/nebude tisknuta na výplatním lístku
Povoleny nulové dny | Povoleno nastavení dnů na hodnotu nula.
Povoleny nulové hodiny | Povoleno nastavení dnů na hodnotu nula.
Komentář | Komentář
Tech. sel. | Identifikátor technicko-věcného selektoru.
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Výběr
Identifikace | Jednoznačná identifikace mzdové položky
 | Popis mzdové položky
 | Platnost nebo neplatnost k datu
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [příjmy] činnosti - Druh události

    Mřížka [příjmy] činnosti - Druh události
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky

    Atributy tisku

    Základní údaje
Identifikace | Jednoznačná identifikace mzdové položky | MZMZDPOL_mz28id | C(6)
Popis | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Původ Kč / j | Původ Kč / j | Výpočet | C(47)
Kč / j | Kč / j | MZMZDPOL_mz28kc_j | N(15,2)
Koeficient | Koeficient, jímž se násobí Kč / j | MZMZDPOL_mz28koef | N(8,4)
Výpočet Kč | Způsob výpočtu celkové částky Kč | Výpočet | C(35)
Vyplatit v penězích | Vyplácet částku (Kč) v hotovosti | Výpočet | C(3)
Dopl. údaje | Jednoznačná identifikace doplňující položky mezd | MZMZDPOL_mz29id | C(6)
Popis | Popis doplňující položky mezd | MZDOPPOL_mz29popis | C(40)
Komentář | Komentář | MZMZDPOL_mz28koment | M
Tisknout | Položka bude/nebude tisknuta na výplatním lístku | Výpočet | C(3)

    Viz.také

    Úkolová-tarifní | Doplňující údaje k příjmům | Druh události | Technicko-věcný selektor


Doplňující údaje k příjmům

Popis

Uživateli se zobrazuje číselník obsahující doplňující údaje k příjmům. Doplňující údaje přitom říkají, jak bude položka zdaněna, jestli z ní bude počítán odvod na sociální a zdravotní pojištění apod.

K dispozici jsou tyto položky

¨ identifikace a popis - jednoznačná identifikace a popis doplňujícího údaje

¨ hodiny jsou součástí FPD - při zatržení se vypočítávají hodiny z těch příjmů a náhrad, jejichž hodiny se do fondu pracovní doby zahrnují. Naopak nezahrnují se např. přesčasy.

¨ Kč zahrnout do hrubého příjmu - klasické příjmy mají tento příznak zatržen, ostatní (např. roční prémie) se nezatrhávají. Např. u roční prémie, kterou pracovník dostal vyplacenu v prosinci, by se rozhodily čtvrtletní průměry na dovolenou. Proto se tato prémie nezahrnuje do hrubého příjmu a mzdová účetní ji ručně rozdělí do několika následujících čtvrtletí.

¨ Kč zahrnout do průměru

¨ hodiny zahrnout do průměru

¨ dny zahrnout do průměru

¨ dny odečíst od vym. základu pro nem. poj. - zatrhává se např. u dovolené, nemoci, ošetřování, základní vojenské služby apod.

¨ hodiny započítávat pro nárok na pohyblivou složku měsíční - tento příznak souvisí s nastavením výpočtu pravidelného příjmu. Může se použít např. v situaci, kdy je prémie vyplácena v závislosti na množství vykonaných prací určitého druhu.

¨ částku zahrnout pro srovnání s minimální mzdou

¨ hodiny zahrnout pro srovnání s minimální mzdou

¨ dovolená (čerpání) - je určen k tomu, aby dny a hodiny správně snižovaly základ dovolené

¨ dovolená (předpokládaný nárok)

¨ dovolená (skutečný nárok)

¨ dovolená (převod do dalšího roku)

¨ celoroční charakter – použije se u odměn, které se rozpočítávají do průměru na celý rok

¨ půlroční charakter - použije se u odměn, které se rozpočítávají do průměru na půlrok

¨ základ soc. pojištění

¨ základ pro zdravotní pojištění

¨ zdanitelný příjem – pokud je zaškrtnuto, bude tato mzdová položka započtena do základu zálohové daně

¨ solidární daň – pokud je zaškrtnuto, bude tato mzdová položka započtena do základu solidární daně

¨ dohoda o prov. práce

¨ zák. poj. odpovědnosti – zaškrtává se u těch příjmů, které se započítávají do zákonného pojištění odpovědnosti

¨ rozpočítávaná odměna, atribut na počet měsíců - použije se u odměn, které se rozpočítávají do průměru na daný počet měsíců

¨ druh události

Datový model

  • MZDOPPOL Doplnění mzdové položky

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druh události | Druh události (mzdové)

    Formulář

    Formulář činnosti - Druh události
Mřížka [dopl.udaje]
Listovací rámeček
Stránka #1 Doplňující údaje k příjmům
Identifikace | Jednoznačná identifikace doplňující položky mezd
Popis | Popis doplňující položky mezd
Hodiny jsou součástí FPD | Hodiny jsou součástí FPD. Odpracované hodiny, které se mají porovnávat proti FPD vymezenému kalendářem.
Kč zahrnout do hrubého příjmu | Kč zahrnout do hrubého příjmu
Kč zahrnout do průměru | Kč zahrnout do průměru
Hodiny zahrnout do průměru | Hodiny zahrnout do průměru
Dny zahrnout do průměru | Dny zahrnout do průměru
Dny odečíst od vym. z. pro n. p. | Dny odečíst od vyměřovacího základu pro nem. pojištění
Hodiny - pohyb. složka měsíční | Hodiny započítávat pro nárok na pohyblivou složku měsíční
Částku zahrnout pro srovnání s min. mzdou | Částku zahrnout pro účely srovnání s minimální mzdou
Hodiny zahrnout pro srovnání s min. mzdou | Hodiny zahrnout pro účely srovnání s minimální mzdou
Dovolená (čerpání) | Dovolená - ovlivňuje čerpání dovolené
Dovolená (předpokládaný nárok) | Dovolená - předpokládaný nárok
Dovolená (skutečný nárok) | Dovolená - skutečný nárok
Dovolená (převod do dalšího roku) | Dovolená - převést do dalšího roku
Rozpočítávaná odměna | Rozpočítat položku do průměrů na x měsíců ?
 | Počet měsíců rozpočítávané odměny.
Druh události | Identifikace účetní události
Celoroční charakter | Rozpočítat celoroční položku do průměrů na jednotlivá čtvrtlení ?
Půlroční charakter | Rozpočítat půlroční položku do průměrů na dvě čtvrtlení ?
Základ s.p. | Příjem je součástí základu sociálního pojištění
Základ pro zdrav. poj. | Příjem je součástí základu zdravotního pojištění
Zdanitelný příjem | Příjem podléhá dani
Dohoda o prov. práce | Dohoda o provedení práce
Zák.poj. odpovědnosti | Položka se zahrnuje do výpočtu zákonného pojištění odpovědnosti.
Stránka #2 Poznámka
Komentář | Komentář

    Mřížka [dopl.udaje] činnosti - Druh události

    Mřížka [dopl.udaje] činnosti - Druh události
Identifikace | Jednoznačná identifikace doplňující položky mezd
Popis | Popis doplňující položky mezd

    Atributy tisku

    Základní údaje
Identifikace | Jednoznačná identifikace doplňující položky mezd | MZDOPPOL_mz29id | C(6)
Popis | Popis doplňující položky mezd | MZDOPPOL_mz29popis | C(40)
Součást FDP? | Hodiny jsou součástí FPD. Odpracované hodiny, které se mají porovnávat proti FPD vymezenému kalendářem. | Výpočet | C(3)
KČ zahrnout do hrub. příjmu | Kč zahrnout do hrubého příjmu | Výpočet | C(3)
Kč a hod. zahrnout do průměru | Kč a hodiny zahrnout do průměru | Výpočet | C(3)
Hodiny zahrnout do průměru | Hodiny zahrnout do průměru | Výpočet | C(3)
Kč zahrnout do průměru | Kč zahrnout do průměru | Výpočet | C(3)
Dny odečíst od vym. z. pro n.p. | Dny odečíst od vyměřovacího základu pro nem. pojištění | Výpočet | C(3)
Pohybl. složka měs. | Hodiny započítávat pro nárok na pohyblivou složku měsíční | Výpočet | C(3)
Základ s.p. | Příjem je součástí základu sociálního pojištění | Výpočet | C(3)
Základ pro z.p. | Příjem je součástí základu zdravotního pojištění | Výpočet | C(3)
Zdanitelný příjem | Příjem podléhá dani | Výpočet | C(3)
Dovolená | Dovolená - ovlivňuje čerpání dovolené | Výpočet | C(3)
Druh události | Identifikace účetní události | MZDOPPOL_mz40id | C(6)
Rozpočítávaná odměna | Rozpočítat položku do průměrů na x měsíců ? | Výpočet | C(3)
na počet měsíců | Počet měsíců rozpočítávané odměny. | MZDOPPOL_mz29mesicu | N(2)
Zák.poj. odpovědnosti | Položka se zahrnuje do výpočtu zákonného pojištění odpovědnosti. | Výpočet | C(3)

    Viz.také

    Druh události


Neplacené volno

Popis

Jedná se o číselník, kde si uživatel eviduje možné druhy volna, může to být např. neplacené volno, absence, prostoj vinou organizace apod.

Tento číselník není dodáván naplněný s programem, protože v každé organizaci mohou používat jiné druhy.

Vyplnění jednotlivých položek je závislé na znění jednotlivých zákonů, které musí mít každá mzdová účetní dokonale nastudovány, tudíž zde ani nebudeme jednotlivé položky nějak podrobně popisovat.

Datový model

  • MZMZDPOL Mzdová položka

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druh události | Druh události (mzdové)
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

    Formulář činnosti - Technicko-věcný selektor
Mřížka [příjmy]
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...
Zdrav. poj. hradí | ZP hradí
Hodiny jsou součástí FPD | Hodiny jsou součástí FPD
Tisknout | Položka bude/nebude tisknuta na výplatním lístku
Druh události | Identifikace účetní události
Dny odečíst od vym. z. pro n. p. | Dny odečíst od vyměřovacího základu pro nem. pojištění
Povoleny nulové dny | Povoleno nastavení dnů na hodnotu nula.
Povoleny nulové hodiny | Povoleno nastavení dnů na hodnotu nula.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události

    Mřížka [příjmy] činnosti - Technicko-věcný selektor

    Mřížka [příjmy] činnosti - Technicko-věcný selektor
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky

    Atributy tisku

    Základní údaje
Identifikace | Jednoznačná identifikace mzdové položky | MZMZDPOL_mz28id | C(6)
Popis | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Druh | Druh položky - příjem, náhrada mzdy,... | Výpočet | C(17)
Hodiny jsou součástí FPD | Hodiny jsou součástí FPD | Výpočet | C(3)
Zdrav. poj. hradí | ZP hradí | Výpočet | C(24)
Tisknout | Položka bude/nebude tisknuta na výplatním lístku | Výpočet | C(3)
Druh události | Identifikace účetní události | MZMZDPOL_mz40id | C(6)

    Viz.také

    Druh události | Technicko-věcný selektor


Součty příjmů

Popis

Součty příjmů jsou v podstatě vlastní mzdovou položkou, která v sobě obsahuje položky, které jsou dodávány s programem. Protože program při výpočtu mezd s těmito položkami počítá, není možno tyto položky rušit. V případě potřeby může uživatel pouze opravit názvy těchto položek.

Přestože program při výpočtu mezd pracuje se všemi těmito položkami, není nutno je všechny mít k dispozici na výplatním lístku. Zatržením příznaku "tisknout" si uživatel sám určí, kterou položku chce mít dostupnou na výplatním lístku a kterou nikoliv.

Datový model

  • MZMZDPOL Mzdová položka

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druh události | Druh události (mzdové)
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

    Formulář činnosti - Technicko-věcný selektor
Mřížka [Mzd. položky]
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...
Poddruh1 | Hrubý příjem,Čistý příjem,K výplatě
Tisknout | Položka bude/nebude tisknuta na výplatním lístku
Druh události | Identifikace účetní události
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Mřížka [Mzd. položky] činnosti - Technicko-věcný selektor

    Mřížka [Mzd. položky] činnosti - Technicko-věcný selektor
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky

    Atributy tisku

    Základní údaje
Identifikace | Jednoznačná identifikace mzdové položky | MZMZDPOL_mz28id | C(6)
Popis | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Druh | Druh položky - příjem, náhrada mzdy,... | Výpočet | C(17)
Poddruh1 | Hrubý příjem,Čistý příjem,K výplatě | Výpočet | C(42)
Tisknout | Položka bude/nebude tisknuta na výplatním lístku | Výpočet | C(3)
Druh události | Identifikace účetní události | MZMZDPOL_mz40id | C(6)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MZMZDPOL_sp20idzak | C(9)

    Viz.také

    Druh události | Technicko-věcný selektor


Odvody

Popis

Jedná se o částečně naplněný číselník odvodů. Číselník je dodáván s programem a je s ním počítáno při výpočtu mezd. Obsahuje tyto identifikace:

¨ identifikace – identifikace mzdové položky

¨ popis – upřesňující popis mzdové položky typu „odvod“

¨ druh – automaticky předplněn druh typu „odvod“

¨ poddruh 2 – týká se odvodů sociálního a zdravotního pojištění a daní. Možnosti jsou:

- Z. sp z. – základ sociálního pojištění - zaměstnanec

- Odv sp z. – odvod sociálního pojištění - zaměstnanec

- Odv sp o. – odvod sociálního pojištění - organizace

- Z. zp – základ zdravotního pojištění

- Odv zp z. – odvod zdravotního pojištění - zaměstnanec

- Odv zp o. – odvod zdravotního pojištění - organizace

- Z. zál. daně – základ zálohové daně

- Daň zál. – zálohová daň

- Z sráž. daně – základ srážkové daně

- Daň sr. – srážková daň

- Z. roč. zúč. – základ ročního zúčtování daně

- Daň přepl. – vyrovnání přeplatku na dani

- Z. sp o. – základ sociálního pojištění organizace

- Imp –

- L. příjem – loňský příjem

- L. odv. – loňský odvod

- L. daň – loňská daň

- Př. zál. – příjem zdanitelný zálohově

- Odv zp. prac org – odvod zdrav. pojiš. pracovník za organizaci

- L. nár – loňský nárok

- L. sleva – loňská sleva

- L. bon – loňský bonus

- Z. dp z. – základ důchodového pojištění zaměstnanec

- Od dp z. – odvod důchodového pojištění zaměstnanec

- Z. dp o. – základ důchodového pojištění organizace

- Od. do o. – odvod důchodového pojištění organizace

- Základ důchodového spoření (pro II. pilíř důch. reformy)

- Odvod důchodového spoření (pro II. pilíř důch. reformy)

- Základ solidární daně

- Základ solidární daně (rozdíl)

¨ poddruh 4 – týká se doplatků a daní. Možnosti jsou následující:

- Dop. ZP zam – doplatek zdrav. pojišt. zaměstnanec

- Dop. SP zam – doplatek sociál. pojišt. zaměstnanec

- Dop. daně zál. – doplatek zálohové daně

- Dop. daně sr. – doplatek srážkové daně

- Dop. ZP org. – doplatek zdrav. pojišt. organizace

- Dop. SP org. – doplatek sociál. pojišt. organizace

- Vypočtená daň – záloha na daň před slevou

- Měs. sleva na dani – sleva na dani měsíční

- Měs. daň. bonus – bonus daňový - měsíční

- Roč. daň. bonus – vyrovnání ročního daňového bonusu

- Zákl. zák. poj. odp. – základ zákonného pojištění odpovědnosti

- Odvod zák. poj. odp. – odvod zákonného pojištění odpovědnosti

- zákl. 2 pilíř

- odvod 2 pilíř

- zákl. sol. d.

¨ tisknout - umožňuje uživateli určit si, který odvod se bude tisknout (tzn. zobrazovat) na výplatním lístku

¨ druh události – vazba na události plateb a účetnictví

¨ tech. sel. – identifikace technického selektoru (v parametrech mezd se následně uvádí odkud se na výplatní lístek má technický selektor brát – zda ze mzdové položky nebo z karty pracovníka)

Datový model

  • MZMZDPOL Mzdová položka

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druh události | Druh události (mzdové)
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

    Formulář činnosti - Technicko-věcný selektor
Mřížka [Mzd. položky]
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...
Poddruh2 | Základ s.p.,Odvod s.p. zaměst.,Odvod s.p. org.,Základ z.p.,Odvod z.p. zaměst.,Odvod z.p. org.,Základ záloh. daně,Daň zálohová,Zákl. srážk. daně,Daň srážková,Zákl. roč. zúčt. daně,Vyrovnání přepl. na dani
Poddruh4 | Doplatek ZP zam.,Doplatek SP zam.,Doplatek daně záloh.,Doplatek daně srážk.,Doplatek ZP org.,Doplatek SP org.
Tisknout | Položka bude/nebude tisknuta na výplatním lístku
Druh události | Identifikace účetní události
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Mřížka [Mzd. položky] činnosti - Technicko-věcný selektor

    Mřížka [Mzd. položky] činnosti - Technicko-věcný selektor
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky

    Atributy tisku

    Základní údaje
Identifikace | Jednoznačná identifikace mzdové položky | MZMZDPOL_mz28id | C(6)
Popis | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Druh | Druh položky - příjem, náhrada mzdy,... | Výpočet | C(17)
Tisknout | Položka bude/nebude tisknuta na výplatním lístku | Výpočet | C(3)
Poddruh2 | Základ s.p.,Odvod s.p. zaměst.,Odvod s.p. org.,Základ z.p.,Odvod z.p. zaměst.,Odvod z.p. org.,Základ záloh. daně,Daň zálohová,Zákl. srážk. daně,Daň srážková,Zákl. roč. zúčt. daně,Vyrovnání přepl. na dani | Výpočet | C(14)
Druh události | Identifikace účetní události | MZMZDPOL_mz40id | C(6)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MZMZDPOL_sp20idzak | C(9)

    Viz.také

    Druh události | Technicko-věcný selektor


Nezdanitelné položky měsíční

Popis

Jedná se o číselník nezdanitelných položek, které má uživatel možnost v měsíci uplatnit. Nejdůležitější je zřejmě položka "poddruh", která určuje, zda se jedná o částku společnou pro všechny pracovníky nebo zda se jedná o částku individuální, která se uplatní pouze u některých pracovníků.

Datový model

  • MZMZDPOL Mzdová položka

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druh události | Druh události (mzdové)
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

    Formulář činnosti - Technicko-věcný selektor
Mřížka [Mzd. položky]
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...
Poddruh | Částka je společná,částka je individuální
Kč / j | Kč / j
Tisknout | Položka bude/nebude tisknuta na výplatním lístku
Druh události | Identifikace účetní události
Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Datum a čas zápisu záznamu události
Zapsal | Jméno uživatele systému

    Mřížka [Mzd. položky] činnosti - Technicko-věcný selektor

    Mřížka [Mzd. položky] činnosti - Technicko-věcný selektor
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky

    Atributy tisku

    Základní údaje
Identifikace | Jednoznačná identifikace mzdové položky | MZMZDPOL_mz28id | C(6)
Popis | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Druh | Druh položky - příjem, náhrada mzdy,... | Výpočet | C(17)
Poddruh | Částka je společná,částka je individuální | Výpočet | C(22)
Kč / j | Kč / j | MZMZDPOL_mz28kc_j | N(15,2)
Tisknout | Položka bude/nebude tisknuta na výplatním lístku | Výpočet | C(3)
Druh události | Identifikace účetní události | MZMZDPOL_mz40id | C(6)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MZMZDPOL_sp20idzak | C(9)

    Viz.také

    Druh události | Technicko-věcný selektor


Nezdanitelné položky roční

Popis

Jedná se o číselník nezdanitelných položek, které má uživatel možnost jednou za rok uplatnit. Nejdůležitější je zřejmě položka "poddruh", která určuje, zda se jedná o částku společnou pro všechny pracovníky nebo zda se jedná o částku individuální, která se uplatní pouze u některých pracovníků.

Datový model

  • MZMZDPOL Mzdová položka

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druh události | Druh události (mzdové)
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

    Formulář činnosti - Technicko-věcný selektor
Mřížka [Mzd. položky]
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...
Poddruh | Částka je společná,částka je individuální
Kč / j | Kč / j
Tisknout | Položka bude/nebude tisknuta na výplatním lístku
Druh události | Identifikace účetní události
Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Datum a čas zápisu záznamu události
Zapsal | Jméno uživatele systému

    Mřížka [Mzd. položky] činnosti - Technicko-věcný selektor

    Mřížka [Mzd. položky] činnosti - Technicko-věcný selektor
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky

    Atributy tisku

    Základní údaje
Identifikace | Jednoznačná identifikace mzdové položky | MZMZDPOL_mz28id | C(6)
Popis | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Druh | Druh položky - příjem, náhrada mzdy,... | Výpočet | C(17)
Poddruh | Částka je společná,částka je individuální | Výpočet | C(22)
Kč / j | Kč / j | MZMZDPOL_mz28kc_j | N(15,2)
Druh události | Identifikace účetní události | MZMZDPOL_mz40id | C(6)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MZMZDPOL_sp20idzak | C(9)

    Viz.také

    Druh události | Technicko-věcný selektor


Daňová zvýhodnění a slevy na dani

Popis

Tato činnost slouží pro správné nadefinování daňových zvýhodnění, jejichž identifikaci pak uživatel použije v činnosti Karta pracovníka na záložce Daňová zvýhodnění. Definuje se:

¨ identifikace a název mzdové položky (např. daňové zvýhodnění na jedno dítě)

¨ druh – je předplněno daňové zvýhodnění

¨ druh mzdové položky – měsíční, roční, měsíční s bonusem, roční s bonusem

¨ druh - na poplatníka,na druhého z manželů,na částeč. inval. důchod,na plný inval. důchod,na průkaz ZTP/P,pro studenta,na dítě,na ZTP dítě (je důležitý zejména pro práci s obecně navrženými sestavami)

¨ částka – výše částky daň. zvýh.

¨ od data – do data - určení data platnosti položky. Toto datum se uplatňuje pouze v okamžiku zápisu dané položky na kartu pracovníka.

¨ tisknout – zda se tato mzdová položka bude tisknout na výplatním lístku

¨ druh události – výběr druhu události, který umožňuje provázání mzdové položky do plateb, účetnictví nebo statistiky

¨ technický selektor

Datový model

  • MZMZDPOL Mzdová položka

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druh události | Druh události (mzdové)
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

    Formulář činnosti - Technicko-věcný selektor
Mřížka [Mzd. položky]
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...
 | Položka měsíční, položka roční (sleva na dani či daňové zvýhodnění)
 | Druhy daňových zvýhodnění
Částka | Částka slevy
Od data | Datum zahájení platnosti položky. Platnost se bere v potaz při vložení položky na Kartu pracovníka nebo do Výplatního lístku.
do data | Datum ukončení platnosti položky.Platnost se bere v potaz při vložení položky na Kartu pracovníka nebo do Výplatního lístku.
Tisknout | Položka bude/nebude tisknuta na výplatním lístku
Druh události | Identifikace účetní události
Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Datum a čas zápisu záznamu události
Zapsal | Jméno uživatele systému

    Mřížka [Mzd. položky] činnosti - Technicko-věcný selektor

    Mřížka [Mzd. položky] činnosti - Technicko-věcný selektor
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky

    Atributy tisku

    Základní údaje
Mzdová položka | Jednoznačná identifikace mzdové položky | MZMZDPOL_mz28id | C(6)
Popis | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Druh | Druh položky - příjem, náhrada mzdy,... | Výpočet | C(17)
Kč / j | Kč / j | MZMZDPOL_mz28kc_j | N(15,2)
Od data | Datum zahájení platnosti položky. Platnost se bere v potaz při vložení položky na Kartu pracovníka nebo do Výplatního lístku. | MZMZDPOL_mz28oddata | D
do data | Datum ukončení platnosti položky.Platnost se bere v potaz při vložení položky na Kartu pracovníka nebo do Výplatního lístku. | MZMZDPOL_mz28dodata | D
Druh události | Identifikace účetní události | MZMZDPOL_mz40id | C(6)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MZMZDPOL_sp20idzak | C(9)

    Viz.také

    Druh události | Technicko-věcný selektor


Dávky nemocenského pojištění

Popis

Jedná se o číselník dávek nemocenského pojištění. Z toho číselníku pak uživatel vybírá při zadávání nepřítomnosti. Může se jednat o nemoc, ošetřování, vyrovnávací příspěvek, mateřskou dovolenou apod.

Datový model

  • MZMZDPOL Mzdová položka

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druh události | Druh události (mzdové)
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

    Formulář činnosti - Technicko-věcný selektor
Mřížka [Mzd. položky]
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...
Tisknout | Položka bude/nebude tisknuta na výplatním lístku
Povoleny nulové dny | Povoleno nastavení dnů na hodnotu nula.
Povoleny nulové hodiny | Povoleno nastavení dnů na hodnotu nula.
Druh události | Identifikace účetní události
Tech. sel. | Identifikátor technicko-věcného selektoru.
Poddruh3 | Nemoc v p.d.,Nemoc,Ošetřování v p.d.,Ošetřování,Vyrov. přísp.,Mat. dov.,Mat. dov. v p.d.,Import,Jiná nepřítomnost v p.d.,Jiná nepřítomnost,Rodičovská dovolená v p.d.,Rodičovská dovolená

    Mřížka [Mzd. položky] činnosti - Technicko-věcný selektor

    Mřížka [Mzd. položky] činnosti - Technicko-věcný selektor
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky

    Atributy tisku

    Základní údaje
Identifikace | Jednoznačná identifikace mzdové položky | MZMZDPOL_mz28id | C(6)
Popis | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Druh | Druh položky - příjem, náhrada mzdy,... | Výpočet | C(17)
Kč / j | Kč / j | MZMZDPOL_mz28kc_j | N(15,2)
Tisknout | Položka bude/nebude tisknuta na výplatním lístku | Výpočet | C(3)
Poddruh3 | Nemoc v p.d.,Nemoc,Ošetřování v p.d.,Ošetřování,Vyrov. přísp.,Mat. dov.,Mat. dov. v p.d.,Import,Jiná nepřítomnost v p.d.,Jiná nepřítomnost,Rodičovská dovolená v p.d.,Rodičovská dovolená | Výpočet | C(26)
Druh události | Identifikace účetní události | MZMZDPOL_mz40id | C(6)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MZMZDPOL_sp20idzak | C(9)

    Viz.také

    Druh události | Technicko-věcný selektor


Půjčky

Popis

Jedná se pouze o číselník půjček, které mohou být u jednotlivých pracovníků použity. Definuje se :

¨ identifikace – jednoznačná identifikace mzdové položky

¨ popis

¨ druh – implicitně předplněno půjčky

¨ typ – priorita – 1 je pro pohledávky, 2 pro srážky na vlastní účet, 3 pro pohledávky výživného

¨ způsob (nastaveno z 1. třetiny)

¨ tisknout – při zaškrtnutí tohoto atributu se bude daná položka zároveň předplňovat a tisknout na mzdový lístek

¨ druh události

¨ tech. sel. – identifikace technického selektoru

Datový model

  • MZMZDPOL Mzdová položka

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druh události | Druh události (mzdové)
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

    Formulář činnosti - Technicko-věcný selektor
Mřížka [Mzd. položky]
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...
 | Datum a čas zápisu záznamu události
Typ | Priorita mzdové položky. 1 - pohledávky, 2 - srážky na vlastní účet, 3 - pohledávka výživné
Způsob | Způsob uplatnění exekuční pohledávky
Druh události | Identifikace účetní události
Tisknout | Položka bude/nebude tisknuta na výplatním lístku
Tech. sel. | Identifikátor technicko-věcného selektoru.
Zapsal | Jméno uživatele systému

    Mřížka [Mzd. položky] činnosti - Technicko-věcný selektor

    Mřížka [Mzd. položky] činnosti - Technicko-věcný selektor
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky

    Atributy tisku

    Základní údaje
Identifikace | Jednoznačná identifikace mzdové položky | MZMZDPOL_mz28id | C(6)
Popis | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Druh | Druh položky - příjem, náhrada mzdy,... | Výpočet | C(17)
Tisknout | Položka bude/nebude tisknuta na výplatním lístku | Výpočet | C(3)
Druh události | Identifikace účetní události | MZMZDPOL_mz40id | C(6)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MZMZDPOL_sp20idzak | C(9)

    Viz.také

    Druh události | Technicko-věcný selektor


Srážky

Popis

Jedná se o číselník srážek, které mohou být u jednotlivých pracovníků na výplatním lístku použity. Mezi nejdůležitější položku patří "poddruh", která určuje zda se jedná o srážku individuální, tzn. používanou pouze pro některé pracovníky nebo srážku společnou, která se používá komplet u všech pracovníků.

U mzdové položky „odvod připojištění firma“ (týká se příspěvku firmy na penzijní pojištění pracovníka) musí být zatržen příznak „započítávat do limitu penzijního a životního pojištění“.

Datový model

  • MZMZDPOL Mzdová položka

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druh události | Druh události (mzdové)
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

    Formulář činnosti - Technicko-věcný selektor
Mřížka [Mzd. položky]
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...
Poddruh | Částka je společná,částka je individuální
Kč / j | Kč / j
Srážet | Způsob srážení
Typ | Priorita mzdové položky. 1 - pohledávky, 2 - srážky na vlastní účet, 3 - pohledávka výživné
 | Způsob uplatnění exekuční pohledávky
Vzorec | Vzorec pro zjištění položky Kč_j
Započítávat do limitu penzijního a životního připojištění. | Započítávat do limitu penzijního a životního připojištění.
Tisknout | Položka bude/nebude tisknuta na výplatním lístku
Druh události | Identifikace účetní události
Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Datum a čas zápisu záznamu události
Zapsal | Jméno uživatele systému

    Mřížka [Mzd. položky] činnosti - Technicko-věcný selektor

    Mřížka [Mzd. položky] činnosti - Technicko-věcný selektor
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky

    Atributy tisku

    Základní údaje
Identifikace | Jednoznačná identifikace mzdové položky | MZMZDPOL_mz28id | C(6)
Popis | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Druh | Druh položky - příjem, náhrada mzdy,... | Výpočet | C(17)
Kč / j | Kč / j | MZMZDPOL_mz28kc_j | N(15,2)
Poddruh | Částka je společná,částka je individuální | Výpočet | C(22)
Srážet | Způsob srážení | Výpočet | C(42)
Započítávat do limitu penzijního a životního připojištění. | Započítávat do limitu penzijního a životního připojištění. | Výpočet | C(3)
Druh události | Identifikace účetní události | MZMZDPOL_mz40id | C(6)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MZMZDPOL_sp20idzak | C(9)

    Viz.také

    Druh události | Technicko-věcný selektor


Doplňkové odvody a daňová zvýhodnění

Popis

Přehled jednotlivých mzdových položek, které slouží zejména k opravě údajů chyb minulých měsíců. U každé položky se eviduje:

¨ identifikace – jednoznačná identifikace mzdové položky

¨ popis

¨ druh – implicitně předplněno odvod

¨ poddruh – určující atribut k rozlišení čeho se zadávaný odvod týká (např. všech možných doplatků, vypočtené daně, měsíční slevy na dani, měsíčního daňového bonusu, ročního daňového bonusu atd.)

¨ tisknout – při zaškrtnutí tohoto atributu se bude daná položka zároveň předplňovat a tisknout na výplatní lístek

¨ druh události – identifikace účetní události (výběr z číselníku – definice druhů událostí – kam a jak se daný odvod bude dál zobrazovat – do událostí plateb, do účetnictví apod.)

¨ tech. sel. – identifikace technického selektoru

Datový model

  • MZMZDPOL Mzdová položka

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druh události | Druh události (mzdové)
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

    Formulář činnosti - Technicko-věcný selektor
Mřížka [Mzd. položky]
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...
Poddruh4 | Doplatek ZP zam.,Doplatek SP zam.,Doplatek daně záloh.,Doplatek daně srážk.,Doplatek ZP org.,Doplatek SP org.
Tisknout | Položka bude/nebude tisknuta na výplatním lístku
Druh události | Identifikace účetní události
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Mřížka [Mzd. položky] činnosti - Technicko-věcný selektor

    Mřížka [Mzd. položky] činnosti - Technicko-věcný selektor
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky

    Atributy tisku

    Základní údaje
Identifikace | Jednoznačná identifikace mzdové položky | MZMZDPOL_mz28id | C(6)
Popis | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Druh | Druh položky - příjem, náhrada mzdy,... | Výpočet | C(17)
Poddruh4 | Doplatek ZP zam.,Doplatek SP zam.,Doplatek daně záloh.,Doplatek daně srážk.,Doplatek ZP org.,Doplatek SP org. | Výpočet | C(17)
Tisknout | Položka bude/nebude tisknuta na výplatním lístku | Výpočet | C(3)
Druh události | Identifikace účetní události | MZMZDPOL_mz40id | C(6)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MZMZDPOL_sp20idzak | C(9)

    Viz.také

    Druh události | Technicko-věcný selektor


Exekuce

Popis

Tato činnost slouží k nastavení mechanismu přednostního uplatnění exekucí. Definuje se:

¨ identifikace

¨ popis

¨ druh – exekuce

¨ typ – určení priority – 1 = pohledávka, 2 = srážka na účet, 3 = výživné

- třetina, ze které může být exekuce uplatněna – z 1. třetiny, z 2. třetiny, z 3. třetiny

¨ tisknout – zda se bude tento údaj tisknout na výplatním lístku

¨ druh události – nastavení druhu události pro výstup do plateb

¨ technický selektor

Datový model

  • MZMZDPOL Mzdová položka

    • Formulář

    Formulář činnosti - Technicko-věcný selektor
Mřížka [Mzd. položky]
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...
Typ | Priorita mzdové položky. 1 - pohledávky, 2 - srážky na vlastní účet, 3 - pohledávka výživné
 | Způsob uplatnění exekuční pohledávky
Tisknout | Položka bude/nebude tisknuta na výplatním lístku
Druh události | Identifikace účetní události
 | Popis účetní události
Tech. sel. | Identifikátor technicko-věcného selektoru.
Komentář | Komentář
 | Datum a čas zápisu záznamu události
Zapsal | Jméno uživatele systému

    Mřížka [Mzd. položky] činnosti - Technicko-věcný selektor

    Mřížka [Mzd. položky] činnosti - Technicko-věcný selektor
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druh události | Druh události (mzdové)
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Atributy tisku

    Základní údaje
Mzdová položka | Jednoznačná identifikace mzdové položky | MZMZDPOL_mz28id | C(6)
Popis | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Druh | Druh položky - příjem, náhrada mzdy,... | Výpočet | C(17)
Typ | Priorita mzdové položky. 1 - pohledávky, 2 - srážky na vlastní účet, 3 - pohledávka výživné | MZMZDPOL_mz28priori | N(3)
Způsob | Způsob uplatnění exekuční pohledávky | Výpočet | C(12)
Druh události | Identifikace účetní události | MZMZDPOL_mz40id | C(6)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MZMZDPOL_sp20idzak | C(9)

    Viz.také

    Druh události | Technicko-věcný selektor


Výběr mzdové položky

Popis

Uživateli se nabízí číselník mzdových položek, ze kterého jednotlivé položky vybírá a v podstatě sestavuje pracovníkovi výplatní lístek.

Jednotlivé mzdové položky se uživateli zobrazí až po zadání výběru. Identifikace a popis zřejmě nebudou nejčastější údaje, podle kterých bude uživatel vybírat. Nejlepší způsob vyhledávání mzdových položek bude podle údaje "druh". Ten může nabývat těchto stavů:

¨ příjem

¨ součet příjmů

¨ odvod

¨ neplacené volno

¨ nezd.pol.měs.

¨ nezd.pol.roč.

¨ nemoc.dávka

¨ srážky

Podle tohoto výběru se pak uživateli zobrazí mzdové položky daného druhu.

Datový model

  • MZMZDPOL Mzdová položka

    • Formulář

    Formulář činnosti - Charakter vlastnosti
Mřížka [Mzd. položky]
Listovací rámeček
Stránka #1 Mzdové položky
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...
Od data | Datum zahájení platnosti položky. Platnost se bere v potaz při vložení položky na Kartu pracovníka nebo do Výplatního lístku.
do data | Datum ukončení platnosti položky.Platnost se bere v potaz při vložení položky na Kartu pracovníka nebo do Výplatního lístku.
Stránka #2 Výběr
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...
 | Platnost nebo neplatnost k datu
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Mzd. položky] činnosti - Charakter vlastnosti

    Mřížka [Mzd. položky] činnosti - Charakter vlastnosti
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...

    Atributy tisku

    Základní údaje
Identifikace | Jednoznačná identifikace mzdové položky | MZMZDPOL_mz28id | C(6)
Popis | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Druh | Druh položky - příjem, náhrada mzdy,... | Výpočet | C(17)
Poddruh1 | Hrubý příjem,Čistý příjem,K výplatě | MZMZDPOL_mz28pdruh1 | N(1)


Tarifní stupnice

Popis

Jedná se o číselník tarifních stupnic, které jsou definovány pro danou organizaci. Každá tarifní stupnice obsahuje svoji identifikaci, popis a vlastní komentář. K jednotlivé tarifní stupnici je možno navázat libovolný počet tarifních tříd. U každé tarifní třídy se definuje její identifikace, výše hodinové mzdy, výše minimální měsíční mzdy, cenová skupina a komentář.

Datový model

  • MZTARSTU Stupnice zahrnuje

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Cenové skupiny | Přehled cenových skupin obchodovatelného artiklu

    Formulář

    Formulář činnosti - Cenové skupiny
Mřížka [Stupnice]
Listovací rámeček
Stránka #1 Tarifní stupnice
Identifikace | Identifikace tarifní stupnice
Popis | Popis tarifní stupnice
Komentář | Komentář k tarifní stupnici
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Tarifní třídy
Mřížka [Třídy]
Třída | Tarifní třída (1-99)
Sazba | Firemní mzda hodinová
Min. měsíční mzda | Minimální mzda měsíční
Skupina | Identifikace cenové skupiny
Komentář | Komentář

    Mřížka [Stupnice] činnosti - Cenové skupiny

    Mřížka [Stupnice] činnosti - Cenové skupiny
Identifikace | Identifikace tarifní stupnice
Popis | Popis tarifní stupnice

    Mřížka [Třídy] činnosti - Cenové skupiny

    Mřížka [Třídy] činnosti - Cenové skupiny
Stupnice | Identifikace tarifní stupnice
Třída | Tarifní třída (1-99)
Sazba | Firemní mzda hodinová
Min. měsíční mzda | Minimální mzda měsíční

    Atributy tisku

    Základní údaje
Stupnice | Identifikace tarifní stupnice | MZTARSTU_mz23id | C(6)
Popis | Popis tarifní stupnice | MZTARSTU_mz23popis | C(20)
Komentář | Komentář k tarifní stupnici | MZTARSTU_mz23koment | M

    Při pohybu v Tarifní třídy
Třída | Tarifní třída (1-99) | MZTARTRI_mz24trida | C(2)
Sazba | Firemní mzda hodinová | MZTARTRI_mz24hodmzd | N(8,2)
Min. měsíční mzda | Minimální mzda měsíční | MZTARTRI_mz24minmzd | N(5)
Komentář | Komentář | MZTARTRI_mz24komen | M

    Viz.také

    Cenové skupiny


Daňové tabulky souhrnné

Popis

Jedná se o činnost, kde jsou nadefinované jednotlivé daňové tabulky a jejich položky. Tato činnost je částečně naplněna s dodávkou systému. Příslušnou daňovou tabulku musí mít pak každý pracovník zadánu na Kartě pracovníka na záložce „osobní údaje“ v atributu „daňová tabulka“. Údaje těchto daňových tabulek je možno nahrát balíčkem.

Tento formulář obsahuje dvě záložky:

¨ hlavička – kde jsou k dispozici atributy identifikace, popis, druh (měsíční, roční) a komentář

¨ položky – u každé položky dané tabulky se uvádí platnost od, dolní a horní hranice, pevná část a sazba. Navíc se u každého řádku uvádí „typ vzniklé daně“ (výběr z překryvného seznamu – zálohová, srážková, roční zúčtování). Tento typu určuje mzdovou položku, která na jeho základě vzniká.

Upozornění:

V případě, že se údaje daňové tabulky v následujícím roce nemění, lze ponechat všechny záznamy tak, jak jsou uvedeny, např. máme-li zadány údaje s platností od 1.1.2006 a nenastala žádná změna, budou všechny tyto údaje platit i v roce 2007.

Pokud se údaje daňové tabulky v následujícím roce částečně nebo zcela změní, je nutné znovu vložit všechny položky tabulky s novou platností od, tedy i ty, které se nezměnily, např. pokud od 1.1.2008 bude platit nová daňová tabulka, je nutno ji k tomuto datu nadefinovat zcela znovu, neplatí, že řádky (položky s platností od 1.1.2007), kde změna nenastala (tzn. s platností od 1.1.2006), zůstávají i nadále platné. Program vyhledává vždy k dané identifikaci tabulky záznamy s platností od, která je nejblíže zpracovávanému období, na ostatní řádky tabulky (tzn. s jinou – menší platností od) nebere zřetel.

Vlastní hodnoty u daňových tabulek se definují na záložce „Položky“. Jednotlivé daňové tabulky a jejich položky jsou:

Podepsal prohlášení - DPM001

Od | Do | Pevná | % | Typ daně
0 | 999999999999 | 0 | 15 | zálohová

Nepodepsal prohlášení kombinovaná - DKM001

Od | Do | Pevná | % | Typ daně
0 | 6750 | 0 | 15 | Srážková
6751 | 999999999999 | 1012 | 15 | Zálohová

Pozn.: Částka 6750 je příjem 5000 + pojistné zaměstnavatele 450+1300. Pevná částka 1012 ve druhé řádce vznikla jako 15% z částky 6750.

Pozn. : Tato tabulka je vhodná pro Dohodu o pracovní činnosti. Naopak NENÍ vhodná pro dohodu o provedení práce.

Daňová tabulka pro cizince - DNC001

Od | Do | Pevná | % | Typ daně
0 | 999999999999 | 0 | 15 | srážková

Nepodepsal prohlášení - DNM001

Od | Do | Pevná | % | Typ daně
0 | 999999999999 | 0 | 15 | zálohová

Podepsal roční - DPR001

Od | Do | Pevná | % | Typ daně
0 | 999999999999 | 0 | 15 | roční vyúčtování

Nepodepsal prohlášení kombinovaná - DKM002

Od | Do | Pevná | % | Typ daně
0 | 5000 | 0 | 15 | Srážková
5001 | 999999999999 | 750 | 15 | Zálohová

Pozn. : Tato tabulka je vhodná pro Dohodu o provedení práce. Pozn.: Pevná částka 750 ve druhé řádce vznikla jako 15% z částky 5000.

Datový model

  • MZDANHLA Hlavička daňových tabulek

    • Formulář

    Formulář činnosti - Technicko-věcný selektor
Mřížka [Dańové tabulky souhrnné]
Listovací rámeček
Stránka #1 Hlavička
Identifikace | Identifikace daňové tabulky
Popis | Popis
Verze | Verze daňových tabulek
Druh | Druh tabulky
Komentář | Komentář
Stránka #2 Položky
Mřížka [Položky]
Platnost od | Platnost od
Od | Dolní hranice
do | Horní hranice
Pevná část | Pevná část
Sazba v % | Sazba v %
Typ vzniklé daně | Typ vzniklé daně
Stránka #3 Popis verzí daňových tabulek
Mřížka [Popis verzí daňových tabulek]
Verze | Verze daňových tabulek
 | Datum aktualizace
Popis | Popis verze
Popsal | Jméno uživatele systému, který změnil záznam

    Mřížka [Dańové tabulky souhrnné] činnosti - Technicko-věcný selektor

    Mřížka [Dańové tabulky souhrnné] činnosti - Technicko-věcný selektor
Identifikace | Identifikace daňové tabulky
Popis | Popis
Druh | Druh tabulky

    Mřížka [Položky] činnosti - Technicko-věcný selektor

    Mřížka [Položky] činnosti - Technicko-věcný selektor
Platnost od | Platnost od
Identifikace | Identifikace daňové tabulky
Od | Dolní hranice
do | Horní hranice
Pevná část | Pevná část
Sazba v % | Sazba v %

    Mřížka [Popis verzí daňových tabulek] činnosti - Technicko-věcný selektor

    Mřížka [Popis verzí daňových tabulek] činnosti - Technicko-věcný selektor
Verze | Verze daňových tabulek
Dne | Datum záznamu o verzi
Popsal | Jméno uživatele systému, který změnil záznam

    Atributy tisku

    Základní údaje
Identifikace | Identifikace daňové tabulky | MZDANHLA_mza7id | C(6)
Popis | Popis | MZDANHLA_mza7popis | C(40)
Komentář | Komentář | MZDANHLA_mza7koment | M
Druh | Druh tabulky | Výpočet | C(7)

    Při pohybu v Položky daňové tabulky
Od | Dolní hranice | MZDANPOL_mza8dolhra | N(8)
do | Horní hranice | MZDANPOL_mza8horhra | N(8)
Pevná část | Pevná část | MZDANPOL_mza8pevcas | N(8)
Sazba v % | Sazba v % | MZDANPOL_mza8sazba | N(3)
Typ vzniklé daně | Typ vzniklé daně | Výpočet | C(15)
Platnost od | Platnost od | MZDANPOL_mza8platod | D


Výplatní místa

Popis

Uživateli se zobrazuje přehled (číselník) výplatních míst. Identifikace výplatního místa je k dispozici i na výplatním lístku. Po aktivaci příslušné činnosti z menu Volby nebo po stisku klávesy Ctrl B je možno k daným umístěním nadefinovat přístupová práva.

Datový model

  • MZVYPMIS Výplatní místo
    • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Výplatní místa]
Identifikace | Jednoznačná identifikace výplatního místa
Název | Název výplatního místa
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události

    Mřížka [Výplatní místa] činnosti - Přístupová práva

    Mřížka [Výplatní místa] činnosti - Přístupová práva
Identifikace | Jednoznačná identifikace výplatního místa
Název | Název výplatního místa

    Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci

    Atributy tisku

    Základní údaje
Výpl. místo | Jednoznačná identifikace výplatního místa | MZVYPMIS_mz22id | C(6)
Název | Název výplatního místa | MZVYPMIS_mz22nazev | C(40)

    Viz.také

    Přístupová práva


Pracovní doba

Popis

Uživatel má jednak k dispozici nabídku stávajících kalendářů a jednak má možnost si nový kalendář založit a vygenerovat si k němu příslušný fond pracovní doby (FPD). Kalendář slouží pro kontrolu počtu zadaných hodin, nehlídá práci ve svátek a přesčasy.

Pokud uživatel zadává nový kalendář, postupuje tímto způsobem. Pod záložkou kalendář založí nový kalendář (včetně denního úvazku). V případě, že organizace používá denní kalendáře (nastaví se v činnosti Parametry), uživatel určí typ denního kalendáře – Pravidelná pracovní doba. Typ „pravidelná pracovní doba“ znamená, že každý den má stejný počet hodin. Typ „zvlášť ke každému dni“ znamená, že jednotlivé dny mají různý počet hodin (nastavuje se ručně). Pro denní kalendáře je na záložce FPD – po dnech k dispozici nový atribut „typ dne“ (za atributem datum). Uživatel má možnost vybrat si z překryvného seznamu hodnoty: -, pracovní, sobota, neděle, svátek, nepracovní. Typ „nepracovní“ použije uživatel u dne, který není pracovním dnem pracovníka, ale není to ani sobota nebo neděle.

Při používání denních kalendářů existují tedy dvě možnosti:

¨ pravidelný kalendář – nemění se v něm úvazek jednotlivých dnů, tj. pracovní doba připadající na jeden den je vždy shodná, např. 8h

¨ nepravidelný kalendář – úvazek se určuje ke každému dni zvlášť, tzn. že pracovní doba připadající na jeden den může být jiná než v jiný den tohoto kalendáře

Ke každému kalendáři náleží atribut aktuální Ano/Ne. Toto se využije např. při zadávání pracovního poměru.

Používání denních kalendářů typu „ke každému dni zvlášť“ může mít několik logických úskalí:

¨ pokud u svých pracovníků používáte každý měsíc některé pravidelné příjmy (přes činnost Pravidelné příjmy), pak se k použití u pracovníka s tímto kalendářem nehodí možnosti „dopočíst do FPD dle hodin“ a „součet odpracovaných“. Může dojít k chybnému dopočtení počtu pracovních dnů.

¨ při uzávěrce mezd se předpokládá, že pracovník s tímto kalendářem nemá pravidelný kalendář a tím pádem se mu mění úvazek

¨ v Parametrech doporučujeme používat u atributu „způsob výpočtu denního průměru“ možnost „dle odpracovaných dnů“ a nikoliv „dle úvazku“ (je zde hlášení do Protokolu). Pokud přesto chcete používat v Parametrech „způsob výpočtu denního průměru“ s možností „dle úvazku“, pak pracovníci, kteří mají tento kalendář budou zpracováni tak, jako by bylo nastaveno „dle odpracovaných dnů“.

¨ je nutno nastavit správně význam dne, který je označen jako „svátek“. Svátky, které jsou propláceny mzdovou položkou „náhrada mzdy za svátek“ budou v případě nemoci propláceny mzdovou položkou „náhrada mzdy za nemoc“. Proto je nutné tyto dny mít správně v kalendáři označené jako svátky. Naopak svátky, které nejsou propláceny mzdovou položkou „náhrada mzdy za svátek“ (tzn. jsou to skutečně nepracovní dny daného pracovníka) nebudou v případě nemoci propláceny mzdovou položkou „náhrada mzdy za nemoc“. Proto je nutno mít tyto dny v kalendáři označené jako sobota, neděle nebo – nově – nepracovní. Označení „svátek“ platí tedy pouze pro ty dny, které připadají na pracovníkův placený den (tzn. pracuje nebo pobírá náhradu mzdy za svátek). Pro svátky je zaveden číselník „Číselník svátků“. Zde je možno si nastavit dny, které jsou svátky. Obsahuje datum svátku, jeho popis a komentář. Slouží ke generování denních kalendářů. Při generování denních kalendářů se poté program ptá, zda chcete označit pracovní dny jako svátky (podle číselníku svátků).

U jiných kalendářů než „zvlášť ke každému dni“ se spustí činnost "generuj FPD" (menu volby). Program poté spočítá FPD k danému kalendáři. Lze vygenerovat FPD:

¨ po měsících

¨ po dnech – možnost označit pracovní dny jako svátky

¨ s periodou po dnech - vygeneruje nový fond prac. doby po dnech pro zadané období podle zadané periody a hodin v periodě, tzn. zadává se období od – do, perioda střídání pracovních a nepracovních dnů a hodiny příslušející periodě. Perioda se uvádí pomocí znaků P(prac. den) a N (neprac. den), např. PPPPPNN – po 5-ti pracovních dnech následují 2 dny nepracovní. Hodiny se uvádí oddělené znakem /, používá se desetinná čárka (příklad: 8/8/12/12/7,5/7,5/0/0/0/). Perioda musí odpovídat Hodinám, tj. pro každý den v periodě musí být určen počet hodin. Na dotaz je zde možnost označit pracovní dny jako svátky (podle číselníku svátků).

¨ podle číselníků svátků – do již vygenerovaného denního kalendáře označí pracovní dny jako svátky

¨ veškerý FPD po dnech – možnost označit pracovní dny jako svátky

¨ veškerý FPD po měsících

Na FPD se při výpočtu mezd porovnává, zda má pracovník zadán plný počet hodin. Po zadání mzdových položek (dovolená, nemoc,...), lze podle FPD dopočítávat hodiny implicitní práce do plně odpracované doby v měsíci.

Datový model

  • MZKALEN Kalendář má

    • Vyvolávané činnosti

    K. | Činnost | Popis
- | Generuj FPD po měsících | Vygeneruje nový fond pracovní doby po měsících pro rok z parametrů.
- | Generuj veškerý FPD po měs. | Vygeneruje všechny fondy prac. doby po měsících pro všechny kalendáře pro rok z parametrů.
- | Generuj FPD po dnech | Vygeneruje nový fond pracovní doby po dnech pro rok z parametrů.
- | Generuj veškerý FPD po dnech | Vygeneruje všechny fondy prac. doby po dnech pro všechny kalendáře pro rok z parametrů.
F2 | Kalendáře | Kalendáře

    Formulář

    Formulář činnosti - Kalendáře
Mřížka [kalendáře]
Listovací rámeček
Stránka #1 Kalendář
Identifikace | Jednoznačná identifikace kalendáře
Kalendář | Název kalendáře
Typ denního kalendáře | Typ denního kalendáře. Neplatí pro měsíční kalendáře. Zjištění hodin FPD v každém dni.
Hod / den | Pracovní doba hodin / den
Komentář | Komentář
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 FPD - po měsících
Mřížka [FPD - po měsících]
Měsíc | Měsíc
Rok | Rok platnosti
Dnů v měsíci | Počet pracovních dnů v měsíci.
Hodin | Pracovních hodin v měsíci
Stránka #3 FPD - po dnech
Mřížka [MZFPD - po dnech]
Datum | Datum
 | Typ dne
Hodin ve dni | FPD - počet hodin, které přísluší tomuto dni
 | Den v týdnu
Popis | Popis
Komentář | Komentář
Stránka #4 Výběr
Kalendář | Jednoznačná identifikace kalendáře
FPD po dnech - datum od | FPD po dnech - datum od
do | FPD po dnech - datum do
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [kalendáře] činnosti - Kalendáře

    Mřížka [kalendáře] činnosti - Kalendáře
Identifikace | Jednoznačná identifikace kalendáře
Kalendář | Název kalendáře
Hod / den | Pracovní doba hodin / den

    Mřížka [FPD - po měsících] činnosti - Kalendáře

    Mřížka [FPD - po měsících] činnosti - Kalendáře
Měsíc | Měsíc
Rok | Rok platnosti
Dnů v měsíci | Počet pracovních dnů v měsíci.
Hodin | Pracovních hodin v měsíci

    Mřížka [MZFPD - po dnech] činnosti - Kalendáře

    Mřížka [MZFPD - po dnech] činnosti - Kalendáře
Datum | Datum
Typ dne | Typ dne
Hodin ve dni | FPD - počet hodin, které přísluší tomuto dni
Popis | Popis

    Atributy tisku

    Základní údaje
Kalendář | Jednoznačná identifikace kalendáře | MZKALEN_mz25id | C(6)
Popis | Název kalendáře | MZKALEN_mz25kalen | C(40)
Hod / den | Pracovní doba hodin / den | MZKALEN_mz25hodden | N(5,2)
Komentář | Komentář | MZKALEN_mz25koment | M

    Při pohybu v 12měsíců fondu pracovní doby
Měsíc | Měsíc | MZFPD_mz26mesic | C(2)
Hodin v měsíci | Pracovních hodin v měsíci | MZFPD_mz26hodin | N(20,2)
Dnů v měsíci | Počet pracovních dnů v měsíci. | MZFPD_mz26dnu | N(20,2)

    Při pohybu v Dny fondu pracovní doby
Datum | Datum | MZFPDD_mz85datum | D
Typ dne | Typ dne | Výpočet | C(10)
Popis | Popis | MZFPDD_mz85popis | C(40)

    Viz.také

    Generuj FPD po měsících | Generuj veškerý FPD po měs. | Generuj FPD po dnech | Generuj veškerý FPD po dnech | Kalendáře


Zdravotní a sociální pojišťovny

Popis

Jedná se o číselník zdravotních a sociálních pojišťoven, ze kterého si pak uživatel podle svých potřeb vybírá. U každé pojišťovny se zadává:

¨ identifikace a typ (zdravotní/sociální)

¨ měna – kód měny – pracovníci mohou mít u sebe uvedenu i cizí sociální pojišťovnu, např. pokud je někdo zaměstnancem firmy, která sídlí v Německu. Potom je zřejmé, že platby do této pojišťovny budou uvedeny v jiné měně než CZK, kterou bude mít uvedeno většina uživatelů.

¨ odvod SP zaměstnanec (%) – procento odvodu cizí sociální pojišťovny za zaměstnance. U tuzemských pojišťoven zůstává uvedeno 0,00, protože % odvodu je uvedeno v legislativních konstantách.

¨ odvod SP organizace (%) – procento odvodu cizí sociální pojišťovny za organizaci (viz. bod výše)

¨ max. vyměřovací základ pro SP – maximální výše (tzv. strop) odvodu soc. pojištění – nutno uvést v měně sociální pojišťovny

¨ údaje k pojišťovně – adresa, spojení, účet apod.

Datový model

  • MZPOJSEZ Seznam zdravotních pojišťoven

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresy | Seznam adres za adresáta.
F2 | Adresář | Přehled adresátů
F2 | Bankovní spojení adresátů |
F2 | Měny a kursy | Číselník měn včetně jejich kursů

    Formulář

    Formulář činnosti - Měny a kursy
Mřížka [Seznam pojišťoven]
Identifikace | Identifikace pojišťovny, např. 111, 121 ,...
Typ pojišťovny | Typ pojišťovny
Měna | Kód měny - oceňovací jednotky.
Odvod zaměstnanec (%) | Pojištění hrazené zaměstnancem (%). Je-li nulové, použije se údaj v legislativních konstantách.
Odvod organizace (%) | Pojištění hrazené organizací (%). Je-li nulové, použije se údaj v legislativních konstantách.
Limit (strop) pojištění | Limit (strop) sociálního pojištění v příslušné měně
Typ limitu | Typ limitu vyměřovacího základu
Adresát | Identifikace adresáta
 | Název adresáta
Adresa | Číslo adresy adresáta.
Spojení | Číslo spojení adresáta.
Účet | Identifikátor spojení na bankovní účet adresáta.
KS | Konstantní symbol
VS | Variabilní symbol
Komentář | Komentář

    Mřížka [Seznam pojišťoven] činnosti - Měny a kursy

    Mřížka [Seznam pojišťoven] činnosti - Měny a kursy
Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,...
Adresát | Identifikace adresáta
Adresa | Číslo adresy adresáta.
Účet | Identifikátor spojení na bankovní účet adresáta.

    Atributy tisku

    Základní údaje
Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,... | MZPOJSEZ_mz70idp | C(3)
Odvod zaměstnanec (%) | Pojištění hrazené zaměstnancem (%). Je-li nulové, použije se údaj v legislativních konstantách. | MZPOJSEZ_mz70pzam | N(5,2)
Odvod organizace (%) | Pojištění hrazené organizací (%). Je-li nulové, použije se údaj v legislativních konstantách. | MZPOJSEZ_mz70porg | N(5,2)
Adresát | Identifikace adresáta | MZPOJSEZ_ad01id | C(6)
Název | Název adresáta | ADADSAT_ad01adsat | C(100)
Účet | Identifikátor spojení na bankovní účet adresáta. | MZPOJSEZ_ad03cisban | C(2)
Adresa | Číslo adresy adresáta. | MZPOJSEZ_ad02cisadr | C(2)

    Viz.také

    Adresy | Adresář | Bankovní spojení adresátů | Měny a kursy


Druh události

Popis

Pro využití možnosti odeslat výsledky mezd procesně do ostatních částí systému je nutno mít přesně nadefinované druhy událostí. Tato činnost se nachází v menu Mzdy – Definice – Druh události. Definuje se:

¨ identifikace události

¨ popis (např. odvod zdravotního pojištění, odvod zálohové daně, mzdové náklady apod.)

¨ do účetnictví, do plateb, do statistiky, ostatní – ve všech těchto případech je možno v překryvném seznamu volit z těchto možností:

- Ano

- Ne

- Ano v absolutní hodnotě – přenese se kladné číslo

- Ano s obráceným znaménkem – využije se např. u nemocenských dávek

Při zvolení možnosti Ano do účetnictví je pak vhodné si na záložce „účty a strany“ nastavit správný účet a účetní stranu (tzn. způsob jak se který druh události bude účtovat). Tyto nadefinované druhy události se pak vyplní k příslušným mzdovým položkám.

K dispozici je zde i atribut „Procento uplatnění“ a Vlastnost (např. rozlišení společník nebo zaměstnanec). Tyto atributy jsou pro uživatele k dispozici např. vzhledem k nové evidenci nemocenských dávek. Prvních 14 dní nemoci uživatel platí zaměstnanci tzv. „náhradu mzdy“. Polovinu této částky má zaměstnavatel možnost si ze zákona odečítat. Proto je nutné v této činnosti na záložce „Účty a strany“ tento druh události správně nastavit a toto mu umožňují následující atributy:

¨ platné pro účetnictví

¨ platné pro platby

¨ platné pro statistiku

¨ platné pro ostatní

Jejich hodnoty jsou Ano, Ne, Neurčeno. Jestliže je nastaveno Ano, pak se příslušný účet a strana uplatní při spuštění šablony (události mezd vznikají pomocí naprogramovaných šablon). Pokud je nastaveno Ne nebo Neurčeno, pak šablona s takovým záznamem účtu a strany nepracuje.

K dispozici je i atribut „Zaokr.“ (zaokrouhlení), jenž může nabývat hodnot: Ne, Ano+, Ano-. Tyto hodnoty je vždy nutno ručně zvolit a potom platí při nastavení:

¨ Ano+ - šablona vypočte zaokrouhlení a pro řádky s hodnotou Ano+ vytvoří událost na „pomlčkového“ zaměstnance s hodnotou +0,50 Kč

¨ Ano- - šablona vypočte zaokrouhlení a pro řádky s hodnotou Ano- vytvoří událost na „pomlčkového“ zaměstnance s hodnotou -0,50 Kč

Datový model

  • MZDRUHUD Druh události

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Charakter vlastnosti | Charakter vlastnosti - spolěčníci, zaměstnanci ,...
F2 | Účtový rozvrh | Seznam syntetických a analytických účtů.

    Formulář

    Formulář činnosti - Charakter vlastnosti
Mřížka [Druh události]
Listovací rámeček
Stránka #1 Druh události
Druh události | Identifikace účetní události
Popis | Popis účetní události
Do účetnictví | Příznak, zda daný typ události bude přecházet do účetnictví
Do plateb | Příznak, zda daný typ události bude přecházet do plateb
Do statistiky | Příznak, zda daný typ události bude přecházet do statistiky
Ostatní | Příznak, zda daný typ události bude přecházet jako ostatní
Komentář | Komentář - poznámka
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Účty a strany
Mřížka [Účet a strana MD/Dal]
Účet účetnictví | Identifikátor účtu účetnictví
 | Strana účtu MD/Dal
Procento uplatnění | Procento uplatnění (max. 100%)
Platné pro účetnictví | Bude řádek přecházet do účetnictví?
Platné pro platby | Bude řádek přecházet do plateb ?
Platné pro statistiku | Bude řádek přecházet do statistiky?
Platné pro ostatní | Bude řádek přecházet dotypu ostatní?
Vlastnost | Charakter vlastnosti

    Mřížka [Druh události] činnosti - Charakter vlastnosti

    Mřížka [Druh události] činnosti - Charakter vlastnosti
Druh události | Identifikace účetní události
Popis | Popis účetní události

    Mřížka [Účet a strana MD/Dal] činnosti - Charakter vlastnosti

    Mřížka [Účet a strana MD/Dal] činnosti - Charakter vlastnosti
Účet účetnictví | Identifikátor účtu účetnictví
Strana | Strana účtu MD/Dal
Charakter | Charakter vlastnosti
Druh události | Identifikace účetní události
Popis | Popis účetní události
Procento uplatnění | Procento uplatnění (max. 100%)
Platné pro platby | Bude řádek přecházet do plateb ?

    Atributy tisku

    Základní údaje
Identifikace | Identifikace účetní události | MZDRUHUD_mz40id | C(6)
Popis | Popis účetní události | MZDRUHUD_mz40popis | C(40)
Do účetnictví | Příznak, zda daný typ události bude přecházet do účetnictví | Výpočet | C(25)
Do plateb | Příznak, zda daný typ události bude přecházet do plateb | Výpočet | C(25)
Do statistiky | Příznak, zda daný typ události bude přecházet do statistiky | Výpočet | C(25)
Ostatní | Příznak, zda daný typ události bude přecházet jako ostatní | Výpočet | C(25)

    Při pohybu v Účty druhu události
Účet účetnictví | Identifikátor účtu účetnictví | MZDRUCET_uc01id | C(9)
Strana účtu | Strana účtu MD/Dal | Výpočet | C(3)
Procento uplatnění | Procento uplatnění (max. 100%) | MZDRUCET_mz69procen | N(6,2)
Vlastnost | Charakter vlastnosti | MZDRUCET_mz72id | C(20)
Platné pro platby | Bude řádek přecházet do plateb ? | Výpočet | C(8)
Platné pro statistiku | Bude řádek přecházet do statistiky? | MZDRUCET_mz69stat | N(1)
Platné pro účetnictví | Bude řádek přecházet do účetnictví? | MZDRUCET_mz69ucet | N(1)
Platné pro ostatní | Bude řádek přecházet dotypu ostatní? | Výpočet | C(8)

    Viz.také

    Charakter vlastnosti | Účtový rozvrh


Umístění mezd

Popis

Tato činnost poskytuje uživateli přehled vytvořených umístění mezd. U každého umístění se definuje:

¨ umístění – jednoznačná identifikace

¨ název umístění

¨ organizační selektor – v případě, že je dané umístění svázáno s konkrétním organizačním selektorem

Po aktivaci příslušné činnosti z menu Volby nebo po stisku klávesy Ctrl B je možno k daným umístěním nadefinovat přístupová práva.

Datový model

  • MZUMIST Alokace mezd - umístění
    • SPPRISTU Přístupové právo uživatele k věci
    • SPSEOR Organizační selektor

    • Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci
F2 | Organizační selektor | Číselník organizačních selektorů

    Formulář

    Formulář činnosti - Organizační selektor
Mřížka [Umístění mezd]
Umístění | Identifikace umístění mezd
Název umístění | Název umístění mezd
Org. sel. | Identifikátor organizačního selektoru.
 | Název organizačního selektoru

    Mřížka [Umístění mezd] činnosti - Organizační selektor

    Mřížka [Umístění mezd] činnosti - Organizační selektor
Umístění | Identifikace umístění mezd
Název umístění | Název umístění mezd

    Atributy tisku

    Základní údaje
Umístění | Identifikace umístění mezd | MZUMIST_mz79id | C(6)
Název umístění | Název umístění mezd | MZUMIST_mz79text | C(40)
Org. sel. | Identifikátor organizačního selektoru. | MZUMIST_sp11idzak | C(9)

    Viz.také

    Přístupová práva | Organizační selektor


Palety barev kategorií pracovníků

Popis

Tato činnost umožňuje nadefinovat si jednotlivé palety barev kategorií pracovníků a do každé barevné palety pak přiřadit vybrané kategorie a zvolit u nich barvu. Postup definování je následující. Na první záložce „palety barev kategorií pracovníků“ se nadefinuje hlavička palety, tzn. identifikace a název. Zároveň se vybráním skupiny uživatelů nastaví přístupová práva k dané paletě.

Na druhé záložce „kategorie v paletě“ se následně definuje:

¨ kategorie náležící do dané palety

¨ priorita – seřazení kategorií v dané paletě podle důležitosti (nejvyšší priorita 1)

¨ barva písma

¨ barva pozadí

Pro názornější vysvětlení si můžeme uvést příklad. Máme např. vytvořenu paletu barev, která se jmenuje „Pracovní poměry“. Do této palety pak na záložce „kategorie v paletě“ přiřadíme kategorie typu hlavní pracovní poměr, vedlejší pracovní poměr, dohoda o provedení práce apod. a každé z těchto kategorií přiřadíme prioritu a barvu. Na výběrové záložce činnosti Karta pracovníka pak lze vyhledávat i podle vytvořené palety barev a tím má hned uživatel k dispozici zajímavý, barevně odlišený přehled, kolik pracovníků pracuje na hlavní pracovní poměr, kolik na vedlejší atd.

Datový model

  • MZPALETA Paleta barev kategorií pracovníků

    • Formulář

    Formulář činnosti - Barvy RGB
Mřížka [Palety barev kategorií pracovníků]
Paleta | Identifikace palety barev
Název palety | Název palety barev
Listovací rámeček
Stránka #1 Palety barev kategorií pracovníků
Skupina | Identifikace skupiny uživatelů
Poznámka | Poznámka
Stránka #2 Kategorie v paletě
Mřížka [Kategorie v paletě]
Kategorie | Identifikace kategorie pracovníka
Název kategorie | Název kategorie pracovníka
Priorita | Priorita
B.písma | Identifikace barvy RGB
B.pozadí | Identifikace barvy RGB

    Mřížka [Palety barev kategorií pracovníků] činnosti - Barvy RGB

    Mřížka [Palety barev kategorií pracovníků] činnosti - Barvy RGB
Paleta | Identifikace palety barev
Název palety | Název palety barev

    Mřížka [Kategorie v paletě] činnosti - Barvy RGB

    Mřížka [Kategorie v paletě] činnosti - Barvy RGB
Priorita | Priorita
Kategorie | Identifikace kategorie pracovníka
Název kategorie | Název kategorie pracovníka

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Barvy RGB |
F2 | Kategorie pracovníků | Kategorie pracovníků

    Viz.také

    Barvy RGB | Kategorie pracovníků


Kategorie pracovníků

Popis

Tato činnost umožňuje uživateli evidovat, opravovat a rušit kategorie pracovníků. Pomocí příslušné činnosti pod menu Volby nebo po stisku klávesy Ctrl B lze ke kategoriím nastavit přístupová práva. U každé kategorie se definuje:

¨ identifikace kategorie – jednoznačná identifikace kategorie a její název

¨ účel – důvod (typ) kategorie pracovníka. Výběr z překryvného seznamu, který si uživatel nadefinuje po stisku klávesy F5 nebo volbou činnosti „definování typu kategorie pracovníků“ z pod menu Volby

¨ libovolná poznámka

Datový model

  • MZKARADD Kategorie pracovníka
    • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Definování typu kategorie pracovníků
Mřížka [Kategorie pracovníků]
Kategorie | Identifikace kategorie pracovníka
Název kategorie | Název kategorie pracovníka
Účel | Účel (důvod, typ) kategorie pracovníka
Poznámka | Poznámka

    Mřížka [Kategorie pracovníků] činnosti - Definování typu kategorie pracovníků

    Mřížka [Kategorie pracovníků] činnosti - Definování typu kategorie pracovníků
Kategorie | Identifikace kategorie pracovníka
Název kategorie | Název kategorie pracovníka
Účel | Účel (důvod, typ) kategorie pracovníka

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Definování typu kategorie pracovníků | Definování typu kategorie pracovníků
^B | Přístupová práva | Definování práv přístupu k věci

    Atributy tisku

    Základní údaje
Kategorie | Identifikace kategorie pracovníka | MZKARADD_mz16id | C(6)
Název kategorie | Název kategorie pracovníka | MZKARADD_mz16popdru | C(40)
Účel | Účel (důvod, typ) kategorie pracovníka | Výpočet | C(28)
Poznámka | Poznámka | MZKARADD_mz16koment | M

    Viz.také

    Definování typu kategorie pracovníků | Přístupová práva


Dotazy při běhu výpočtu

Popis

Při běhu optimalizovaného výpočtu mezd je nutné několikrát uživatelsky rozhodnout o dalším postupu výpočtu mzdy u konkrétního pracovníka, např.:

¨ rozhodnout o doplatku mzdy do výše minimální mzdy

¨ rozhodnout o způsobu výpočtu zdravotního pojištění ze mzdy, která je menší než vyměřovací základ zdravotního pojištění

¨ rozhodnout o způsobu odvedení sociální pojištění ze mzdy, která je příliš malá

Tyto jednotlivé dotazy se sdružují do jedné tabulky (dotazy výpočtu), která je zobrazena uprostřed běhu výpočtu a pomocí níž bude na dotazy odpovězeno.

Jednotlivé dotazy, které jsou pak při běhu výpočtu systémem pokládány jsou nadefinovány v činnosti „dotazy při běhu výpočtu“ (menu Mzdy – Definice). Tato činnost zachycuje přehled typů dotazů. Udává se identifikace dotazu, popis, priorita a komentář. Text uvedený v položce popis je právě ten text, který se uživateli zobrazí v dotazovací tabulce při běhu výpočtu. Text by tedy měl být dostatečně jasný a srozumitelný, aby uživatel podle toho měl možnost správně rozhodnout o dalším postupu výpočtu. Priorita umožňuje třídění údajů v dotazovací tabulce.

K této činnosti by měl mít přístup pouze pověřený pracovník (např. implementátor nebo správce).

Dotazovací tabulka se při běhu optimalizovaného výpočtu mezd zobrazí pouze jednou. Obsahuje souhrn pracovníků, kteří spadají do sféry jednoho nebo několika definovaných dotazů. Údaje v ní je možno třídit rovněž podle priority. Na každý z uvedených záznamů je nutno odpovědět. Poté se opět rozeběhne výpočet mezd a pracovníci, ke kterým byl položen dotaz se dopočtou podle rozhodnutí uživatele.

V případě, že žádný pracovník není zachycen do sítě předdefinovaných dotazů, tabulka se během výpočtu vůbec nezobrazí.

V případě, že uživatel zvolí doplatit do výše minimální mzdy, tak není nutné dávat odvod na zdravotní pojištění za předpokladu, že typ mzdy, který je nastaven jako doplatek do min. mzdy má u sebe nastaven, že je součástí základu na zdravotní pojištění.

Datový model

  • MZDOTPRI Druhy speciálních testů výpočtu při běhu výpočtu

    • Formulář

    Formulář činnosti - Výběr mzdové položky
Mřížka [Hromadné dotazy při běhu výpočtu]
Důvod | Důvod dotazu
Popis | Popisný text dotazu
Priorita | Priorita
Komentář | Komentář

    Mřížka [Hromadné dotazy při běhu výpočtu] činnosti - Výběr mzdové položky

    Mřížka [Hromadné dotazy při běhu výpočtu] činnosti - Výběr mzdové položky
Důvod | Důvod dotazu
Popis | Popisný text dotazu


Algoritmy výpočtu protokolu

Popis

Pro uživatele je tato činnost dostupná v menu Mzdy – Definice. Přímo souvisí s optimalizovaným výpočtem mezd. Při tomto výpočtu se vytváří „protokol“, který obsahuje hlášení o nalezených chybách nebo jiných informacích, které byly zjištěny během výpočtu. Tuto činnost je možno (a doporučeno jako vhodné) nastavit pomocí balíčku dat. I v případě, že uživatel nebude mít tuto činnosti nastavenu, proběhne výpočet mezd správně.

Činnost obsahuje dvě záložky:

¨ záložka Algoritmy

¨ záložka Užití algoritmu

Na záložce „algoritmy“ má uživatel k dispozici následující údaje:

¨ identifikaci a popis hlášení

¨ druh (např. systémový)

¨ typ (volba Zabudovaný, Skript před výpočtem, Skript po výpočtu)

¨ kód

¨ poznámku

¨ aktualizaci (datum a čas)

Je-li nastaveno, že je typ „Zabudovaný“, jedná se pak o hlášení pevně zabudované v kódu vlastního výpočtu výplatního lístku.

Je-li nastaveno, že je typ „Skript před výpočtem“, jedná se pak o hlášení uživatelské, ke kterému se váže kód uvedený v atributu „kód“. Tento skript se provede hned na začátku výpočtu výplatních lístků.

Je-li nastavené, že je typ „Skript po výpočtu“, jedná se rovněž o hlášení uživatelské, ke kterému se váže kód uvedený v atributu „kód“. Tento skript se provede až na konci výpočtu výplatních lístků.

Záložka „užití algoritmu“ obsahuje tyto údaje:

¨ provádět (volba Ano/Ne)

¨ skrytá (volba Ano/Ne)

¨ stupeň (volba Informace, Chyba zpracování)

¨ barva písma, barva pozadí

¨ priorita

¨ poznámka

V následujícím odstavci se blíže vrátíme k významu jednotlivých atributů:

¨ provádět – je-li položka protokolu nastavena na Ano, pak se test provede a zapíše do protokolu. Je-li nastavena na Ne, pak se test sice provede, ale do protokolu se jeho výsledek nezapíše. Uživatel pak ale tímto nemá žádnou informaci o tom, že se testem případný problém zachytil, tzn. že volbu Ne je vhodné použít jedině u testů, kde uživatel jejich výsledky opravdu sledovat nechce. Správné nastavení „provádět – Ano/Ne“ je tedy klíčovým nastavením v celé činnosti, protože jak jsme se zmínili výše, je možno některé testy zcela vyřadit.

¨ skrytá – je-li položka protokolu nastavena na skrytá Ano, pak se ve výsledném protokolu výpočtu nezobrazuje. Je-li nastavena na skrytá Ne, pak se ve výsledném protokolu zobrazuje. Zobrazování je možno vyfiltrovat na záložce výběr v protokolu. Jedná se o jemnější formu nastavení než u atributu provádět, protože tímto nastavením uživatel test zcela nevyřazuje, pouze řídí zobrazování jeho výsledku ve výběru protokolu.

¨ stupeň – tento atribut řídí chování samotného běhu výpočtu. Při položce, která má stupeň „informace“ dojde k zápisu do protokolu a výpočet běží dál. Pokud se provádí výpočet pro všechny pracovníky, dojde k zablokování výpočtu pro další přepočítávání. Při položce, která má stupeň „chyba“ dojde k zápisu do protokolu a výpočet u pracovníka, který byl tímto testem zachycen tímto okamžikem končí. Nedojde k zablokování výpočtu pro další přepočítávání. Výplatní lístky pak tímto nejsou kompletní, zachycený problém musí uživatel vyřešit a následně pustit znovu výpočet.

¨ barva písma a barva pozadí umožňuje hlášení uživatelsky barevně zvýraznit

¨ atribut priorita určuje třídění jednotlivých položek protokolu

Standardní nastavení algoritmu výpočtu protokolu mezd je „provádět – Ano“, „skrytá – Ne“ a „stupeň – Informace“.

Datový model

  • MZPROTAL Algoritmus výpočtu položky protokolu při výpočtu mezd
    • SPCINDVT Druh implementačního rozšíření
      • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Druhy implementačních rozšíření
Mřížka [Algoritmy]
Algoritmus | Identifikace algoritmu
Název algoritmu | Název algoritmu
Listovací rámeček
Stránka #1 Algoritmy
Druh | Identifikace druhu implemetačního rozšíření
Typ | Typ algoritmu
Verze | Verze algoritmů protokolu
Kód | Kód algoritmu v jazyce Foxpro
Poznámka | Poznámka
Aktualizace | Datum aktualizace
Stránka #2 Užití algoritmu
Provádět | Provádět algoritmus Ano/Ne
Skrytá | Skrytá položka protokolu Ano / Ne
Stupeň | Stupeň významnosti položky protokolu Informace / Chyba zpracování
Priorita | Priorita zobrazení v protokolu
B.písma | Identifikace barvy RGB
B.pozadí | Identifikace barvy RGB
Poznámka | Poznámka
Stránka #3 Popis verzí algoritmů protokolu
Mřížka [Popis verzí algoritmů protokolu]
Verze | Verze algoritmů protokolu
 | Datum aktualizace
Dne | Datum záznamu o verzi
Popis | Popis verze
 | Jméno uživatele systému, který změnil záznam

    Mřížka [Algoritmy] činnosti - Druhy implementačních rozšíření

    Mřížka [Algoritmy] činnosti - Druhy implementačních rozšíření
Algoritmus | Identifikace algoritmu
Název algoritmu | Název algoritmu
Druh | Identifikace druhu implemetačního rozšíření
Název druhu | Název druhu implemetačního rozšíření

    Mřížka [Popis verzí algoritmů protokolu] činnosti - Druhy implementačních rozšíření

    Mřížka [Popis verzí algoritmů protokolu] činnosti - Druhy implementačních rozšíření
Algoritmus | Identifikace algoritmu
Verze | Verze algoritmů protokolu
Popsal | Jméno uživatele systému, který změnil záznam

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Editovat kód vlastnosti | Editovat kód vlastnosti
F6 | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností
- | Kontrolní kompilace | Kontrolní kompilace
F2 | Barvy RGB |
F2 | Druhy implementačních rozšíření | Druhy implementačních rozšíření

    Atributy tisku

    Základní údaje
Algoritmus | Identifikace algoritmu | MZPROTAL_mza3id | C(6)
Název algoritmu | Název algoritmu | MZPROTAL_mza3nazalg | C(40)
Druh | Identifikace druhu implemetačního rozšíření | MZPROTAL_spa6id | C(6)
Typ | Typ algoritmu | Výpočet | C(20)
Aktualizace | Datum aktualizace | MZPROTAL_sp00datakt | T
Poznámka | Poznámka | MZPROTAL_mza3koment | M

    Při pohybu v Užití algoritmu
Provádět | Provádět algoritmus Ano/Ne | Výpočet | C(3)
Priorita | Priorita zobrazení v protokolu | MZPROTAU_mza4prior | N(5)
Stupeň | Stupeň významnosti položky protokolu Informace / Chyba zpracování | Výpočet | C(16)
Poznámka | Poznámka | MZPROTAU_mza4koment | M
Skrytá | Skrytá položka protokolu Ano / Ne | Výpočet | C(3)

    Viz.také

    Editovat kód vlastnosti | Knihovny vkládaného kódu | Kontrolní kompilace | Barvy RGB | Druhy implementačních rozšíření


Hodnoty sady konstant

Popis

Tato činnost poskytuje uživateli přehled jednotlivých hodnot systémových konstant. Definice systémových konstant se provádí v činnosti „sady systémových konstant“. Tato činnost poskytuje uživateli už pouze výsledné hodnoty konstant.

Ve formuláři Sady systémových konstant lze na záložce „Konstanty“ nastavit atribut „specifická“ (volba Ano/Ne). Pokud je nastaveno specifická ANO, jsou v mřížce řádky 'hodnotou specifických' konstant zobrazované na světle modrém podkladu a na výběrové záložce je možné vybírat 'Konstanty' (překryvný seznam):

- Všechny

- Hodnotou specifické pro různé subjekty

- Hodnotou shodné pro různé subjekty

Činnost „legislativní konstanty“ (menu Mzdy – Definice) obsahuje konstanty (údaje), které jsou limitující pro rozhodnutí o položení některého z dotazů při běhu činnosti optimalizovaný výpočet mezd. Tyto legislativní konstanty dostává 1x ročně uživatel od svého implementátora ve formě balíčku dat. Jsou to:

¨ výše minimální mzdy měsíční

¨ výše minimální mzdy hodinové

¨ limit placení sociálního pojištění

¨ plánovací kalendář se základní pracovní dobou

Kromě těchto údajů obsahuje tabulka legislativních konstant i údaje, které se týkají hodnot, které byly dříve uvedeny v parametrech. V současné době jsou do tabulky legislativních konstant přesunuty všechny parametry, jejichž hodnota se dá vyjádřit číslem.

Konstanta | Identifikace | Hodnota | Poznámka | Změny od 1.1.2009
Odvod SP zaměstnanec | mz27spzam | 8 |  | 0
Odvod SP organizace | mz27sporg | 26 |  | 0
Limit soc. poj. | mz27limsp | 400 |  | 2000
Sazba zdrav. poj. | mz27zpsazb | 13,5 |  |
Vym. základ ZP | mz27zpstat | 0 |  |
Min. mzda měsíční | mz27zpnepl | 8500 |  |
Min. mzda hodinová | mz27minhod | 50,60 |  |
Sazba (promile) | mz27zakpoj | 2 | Zákonné pojištění odpovědnosti |
Procento min. mzdy při invalidním důchodu | mz27inval | 50 | Práce s minimální mzdou |
Procento min. mzdy při část. invalidním důchodu | mz27cinval | 75 | Práce s minimální mzdou |
Limit odprac. dnů (průměrný výdělek) | mz27dnuodp | 21 |  |
Dolní limit vyplacení měs. daň. bonusu | mz27dzbol1 | 50 |  |
Horní limit vyplacení měs. daň. bonusu | mz27dzbol2 | 4350 |  |
Limit penz. a život. poji. | mz27penzli | 24000 |  |
Max. vym. základ pro SP | mz27vymz |  |  | 1 130 640
Limit hodin pro DPP | mz27limdpp | 150 | Dohoda o provedení práce |

V souvislosti se změnami v evidenci nemocenských dávek pro rok 2009 došlo k několika změnám ve stávajících konstantách (viz. tabulka) a zároveň byly zavedeny nové legislativní konstanty:

¨ trvání náhrady mzdy (kal.) - identifikace mz27nahrde - hodnota 14

¨ odvod důchodového pojištění zam. - identifikace mz27duczam - hodnota 6,5%

¨ odvod nemocenského pojištění zam. - identifikace mz27nemzam - hodnota 0%

¨ odvod na politiku nezaměstnanosti zam. - identifikace mz27stpzam - hodnota 0%

¨ odvod důchodového pojištění org. - identifikace mz27ducorg - hodnota 21,5%

¨ odvod nemocenského pojištění org. - identifikace mz27nemorg - hodnota 2,3%

¨ odvod na politiku nezaměstnanosti org. - identifikace mz27stporg - hodnota 1,2%

Vysvětlení:

Konstanta „trvání náhrady mzdy (kal.)“ byla zavedena pro účely náhrady mzdy. Náhrada mzdy se nyní poskytuje po dobu 14 kalendářních dnů podle pravidel, která jsou uvedena v činnosti „Parametry nemocenských dávek“. V r. 2009 je nutno zvlášť vyčíslovat „odvod na důchodové pojištění“, a proto se původní konstanty (odvod SP zaměstnanec a odvod SP organizace) rozdělily každá na tři samostatné, tzn. odvod důchodového pojištění, odvod nemocenského pojištění a odvod na politiku nezaměstnanosti (každá z těchto konstant je za zaměstnance a organizaci).

Poznámka ke konstantě „Limit hodin pro DPP“:

¨ Pokud konstanta nebude ve verzi definována, výpočet to nahlásí, ale bude pokračovat. Test dosažení limitu hodin pro DPP nebude proveden.

¨ Pokud konstanta bude definována, ale její hodnota nebude zadána, pak výpočet nebude pokračovat.

¨ Pokud konstanta bude definována i zadána, bude proveden test dosažení limitu hodin pro DPP.

Definici legislativních konstant lze využít např. i při stanovení výměry na dovolenou.

Poznámka:

Pro změny v důchodovém pojištění od r. 2013 jsou přidány další příslušné legislativní konstanty. Je možné je automaticky nahrát pomocí Sady vzdálených funkcí, pokud si je uživatel nenahraje, je možno je nastavit ručně.

Datový model

  • PASYSVAL Hodnota systémové konstanty
    • PASYSKON Systémová konstanta
      • PADRUPAR Druh algoritmu/parametru
        • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Definice výrazu
Mřížka [Hodnoty]
Listovací rámeček
Stránka #1 Hodnoty konstant
Konstanta | Identifikátor systémové konstanty
Platnost | Platnost od
 | Hodnota konstanty - číslo
 | Hodnota konstanty - text
 | Hodnota konstanty - datum
Popis konstanty | Poznámka
Poznámka | Poznámka
Aktualizace | Datum aktualizace
Stránka #2 Výběr
Konstanty | Výběr z hlediska specifičnosti hodnoty konstanty pro různé subjekty
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 | Platnost nebo neplatnost k datu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Hodnoty] činnosti - Definice výrazu

    Mřížka [Hodnoty] činnosti - Definice výrazu
Název konstanty | Název konstanty
Hodnota | Hodnota
Platnost | Platnost od
Platnost do | Platnost do
Konstanta | Identifikátor systémové konstanty
Aktualizace | Datum aktualizace

    Atributy tisku

    Základní údaje
Sada | Identifikace sady systémových konstant | PASYSVAL_pa17id | C(6)
Název sady | Název sady systémových konstant | PASYSSAD_pa17nazsad | C(40)
Konstanta | Identifikátor systémové konstanty | PASYSVAL_pa18id | C(10)
Název konstanty | Název konstanty | PASYSKON_pa18nazkon | C(40)
Typ | Typ systémové konstanty Text / Číslo / Datum | Výpočet | C(5)
Délka | Délka hodnoty konstanty | PASYSKON_pa18delka | N(2)
Desetiny | Počet desetin hodnoty konstanty | PASYSKON_pa18deseti | N(2)
Platnost | Platnost od | PASYSVAL_pa19platod | D
Platnost do | Platnost do | pa19platdo | D
Hodnota - číslo | Hodnota konstanty - číslo | PASYSVAL_pa19num | N(20,6)
Hodnota - text | Hodnota konstanty - text | PASYSVAL_pa19text | C(40)
Hodnota - datum | Hodnota konstanty - datum | PASYSVAL_pa19dat | D
Poznámka | Poznámka | PASYSVAL_pa19koment | M
Aktualizace | Datum aktualizace | PASYSVAL_sp00datakt | T


Stav dovolených

Popis

Tato činnost poskytuje uživateli informace o stavu dovolených jednotlivých pracovníků a souvisí s celkových nastavením evidence dovolených. Na základě údajů vyfiltrovaných na záložce Výběr lze informace rozdělit podle jednotlivých pracovníků, měsíců a za vybrané roky. Pokud uživatel nechá Výběr prázdný, bude vybráno vše. K dispozici jsou tyto informace:

¨ rok a měsíc

¨ číslo a jméno pracovníka

¨ číslo pracovního poměru

¨ předpokládaný nárok na dovolenou v daném roce

¨ skutečný nárok na dovolenou v daném roce

¨ čerpáno od počátku (od počátku roku nebo od vzniku pracovního poměru)

¨ zbývá dovolené k danému měsíci

¨ čerpáno dovolené v daném měsíci

¨ odpracováno – celkem odpracovaných hodin od počátku vzniku pracovního poměru

Datový model

  • MZDOVNAR Evidence dovolených - nároky a čerpání - stav
    • MZKARTA Pracovník

    • Formulář

    Formulář činnosti - Druhy implementačních rozšíření
Mřížka [Stav dovolených]
Listovací rámeček
Stránka #1 Stav dovolených
Rok | Rok zpracování mezd
Měsíc | Měsíc zpracování mezd
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Číslo p.p. | Číslo pracovního poměru
Předpokládaný nárok | Předpokládaný nárok
Skutečný nárok | Skutečný nárok
Čerpáno od počátku | Čerpáno od počátku roku nebo od vzniku prac. poměru
Zbývá | Zbývá dovolené k danému měsíci
Čerpáno v měsíci | Čerpáno dovolené v daném měsíci
Odpracováno | Odpracováno dnů
Stránka #2 Výběr
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Číslo p.p. | Číslo pracovního poměru
Rok | Rok zpracování mezd
Měsíc | Měsíc zpracování mezd
Uchovat | Příznak uchování výběrového hlediska
Výběr | Určení výběru

    Mřížka [Stav dovolených] činnosti - Druhy implementačních rozšíření

    Mřížka [Stav dovolených] činnosti - Druhy implementačních rozšíření
Rok | Rok zpracování mezd
Měsíc | Měsíc zpracování mezd
Pracovník | Jednoznačná identifikace pracovníka
Předp. nárok | Předpokládaný nárok
Čerpáno od počátku | Čerpáno od počátku roku nebo od vzniku prac. poměru
Zbývá | Zbývá dovolené k danému měsíci
Čerpáno | Čerpáno dovolené v daném měsíci
Skut. nárok | Skutečný nárok
Odpracováno | Odpracováno dnů
Číslo p.p. | Číslo pracovního poměru


SPECIÁLNÍ ČINNOSTI

Popis

Tyto činnosti se nacházejí v menu Mzdy – Mzdy – Speciální činnosti. Poskytují uživateli přehled o historicky zadaných údajích na kartě pracovníka a údajích týkajících se prac. poměru. Uživatel má pak možnost si zvolit rok, měsíc a pracovníka, jehož údaje chce vidět. Tuto činnost zřejmě může využívat většina uživatelů ve chvíli, kdy potřebuje zjistit určité údaje o pracovníkovi týkající se minulosti (např. loňského roku apod.)

Viz.také

Inicializace | Historie údajů na kartě | Historie pracovního poměru | Aktualizace seznamu věcí | Uzávěrka mezd


Inicializace

Popis

Uživateli se zobrazuje datum, k němuž bylo v systému provedeno zatím poslední zpracování mezd. Tato činnost slouží uživateli jako informace o současném zpracování mezd.

Při prvotním provedení inicializace se toto datum automaticky přepíše do parametrů mezd.

Datový model

  • MZPARAM Parametry

    • Formulář

    Formulář činnosti - Druhy implementačních rozšíření
    Poslední zpracované mzdy k datu Datum, ke kterému jsou spočteny poslední mzdy.

    Atributy tisku

    Základní údaje
    Poslední zpracované mzdy k datu Datum, ke kterému jsou spočteny poslední mzdy. MZPARAM_mz27datmzd D


Historie údajů na kartě

Popis

Jedná se o historické údaje karty. Tyto údaje jsou naplněny po provedení měsíční, čtvrtletní nebo roční uzávěrky.

Datový model

  • MZKARHIS Historie karet pracovníků

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Karta pracovníka | Karta pracovníka

    Formulář

    Formulář činnosti - Karta pracovníka
Mřížka [Historie karty]
Listovací rámeček
Stránka #1 Historie karty
Rok | Rok zpracováných mezd
Měsíc | Měsíc zpracováných mezd
OSC | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Zdravotní pojištění | Zdravotní pojištění
Podepsal prohlášení | Podepsal pracovník daňové prohlášení?
Lze srážet | Lze u pracovníka uplatnit srážkovou daň?
Provést roční zúčtování | Provést roční zúčtování ?
Výpl. místo | Jednoznačná identifikace výplatního místa
Daňová tabulka | Identifikace daňové tabulky
Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,...
 | Identifikace adresáta
Adresa | Číslo adresy adresáta.
Účet | Identifikátor spojení na bankovní účet adresáta.
ZP vyměř. základy nápočet | Nápočet dosavadních vyměřovacích základů ZP v aktuálním roce pro porovnání s maximálním vyměřovacím základem ZP.
SP vyměř. základy nápočet | Nápočet dosavadních vyměřovacích základů SP v aktuálním roce pro porovnání s maximálním vyměřovacím základem SP.
Penzij. a život. přip. nápočet | Nápočet dosavadních příspěvků penzij. a život. pojištění v aktuálním roce pro porovnání s limitem připojištění.
Stránka #2 Výběr
Rok | Rok zpracováných mezd
Měsíc | Měsíc zpracováných mezd
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Historie karty] činnosti - Karta pracovníka

    Mřížka [Historie karty] činnosti - Karta pracovníka
Rok | Rok zpracováných mezd
Měsíc | Měsíc zpracováných mezd
OSC | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Titul | Titul pracovníka (před jménem)
Zdravotní pojištění | Zdravotní pojištění
Podepsal prohlášení | Podepsal pracovník daňové prohlášení?
Lze srážet | Lze u pracovníka uplatnit srážkovou daň?
Provést roční zúčtování | Provést roční zúčtování ?
Identifikace | Jednoznačná identifikace výplatního místa
Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,...
 | Identifikace adresáta
Adresa | Číslo adresy adresáta.
Účet | Identifikátor spojení na bankovní účet adresáta.

    Atributy tisku

    Základní údaje
OSC | Jednoznačná identifikace pracovníka | MZKARHIS_mz01id | C(6)
Příjmení | Příjmení pracovníka | MZKARHIS_mz01prijme | C(50)
Zdravotní pojištění | Zdravotní pojištění | MZKARHIS_mz01zdravp | N(1)
Podepsal prohlášení | Podepsal pracovník daňové prohlášení? | Výpočet | C(3)
Lze srážet | Lze u pracovníka uplatnit srážkovou daň? | Výpočet | C(3)
Provést roční zúčtování ? | Provést roční zúčtování ? | Výpočet | C(3)
Výpl. místo | Jednoznačná identifikace výplatního místa | MZKARHIS_mz22id | C(6)
Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,... | MZKARHIS_mz70idp | C(3)
Adresát | Identifikace adresáta | MZKARHIS_ad01id | C(6)
Adresa | Číslo adresy adresáta. | MZKARHIS_ad02cisadr | C(2)
Účet zdrav. pojišťovny | Identifikátor spojení na bankovní účet adresáta. | MZKARHIS_ad03cisban | C(2)
Měsíc | Měsíc zpracováných mezd | MZKARHIS_mz44mesic | C(2)
Rok | Rok zpracováných mezd | MZKARHIS_mz44rok | C(4)

    Viz.také

    Karta pracovníka


Historie pracovního poměru

Popis

Tato činnost shromažďuje historii pracovních poměrů. Tyto údaje jsou naplněny po provedení měsíční, čtvrtletní nebo roční uzávěrky.

Datový model

  • MZPPHIS Historie prac. poměrů pracovníků

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Karta pracovníka | Karta pracovníka

    Formulář

    Formulář činnosti - Karta pracovníka
Mřížka [Historie prcovních poměrů]
Listovací rámeček
Stránka #1 Historie pracovních poměrů
Rok | Rok zpracováných mezd
Měsíc | Měsíc zpracováných mezd
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Číslo p.p. | Číslo pracovního poměru
 | Identifikace pracovní funkce (zařazení)
 | Jednoznačná identifikace kalendáře
 | Identifikace tarifní stupnice
 | Tarifní třída (1-99)
Účast na n.p. | Zakládá pracovní poměr účast na nemocenském pojištění?
 | Vztah k pojistnému na sociální zabezpečení
Den.vym.zákl. | Denní vyměřovací základ nemocenského pojištění.
 | Denní vyměřovací základ nemocenského pojištění neredukovaný.
Hodinový průměr | Hodinový průměr
Denní průměr | Denní průměr
Měsíční průměr | Měsíční průměr
Volné číslo I | Volně použitelné číslo
Volné číslo II | Volně použitelné číslo
Volné číslo III | Volně použitelné číslo
Výpověď | Datum doručení výpovědi nebo datum uzavření dohody rozvázání pracovního poměru
 | Datum odvolání výpovědi
Zůst.nové dov. | Zůstatek nové dovolené
Zůst. staré dov. | Zůstatek staré dovolené
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Stránka #2 Výběr
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Číslo p.p. | Číslo pracovního poměru
Měsíc | Měsíc zpracováných mezd
Rok | Rok zpracováných mezd
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Historie prcovních poměrů] činnosti - Karta pracovníka

    Mřížka [Historie prcovních poměrů] činnosti - Karta pracovníka
Rok | Rok zpracováných mezd
Měsíc | Měsíc zpracováných mezd
OSC | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Titul | Titul pracovníka (před jménem)
Číslo p.p. | Číslo pracovního poměru
Kalendář | Jednoznačná identifikace kalendáře
Stupnice | Identifikace tarifní stupnice
Třída | Tarifní třída (1-99)
Prac. funkce | Identifikace pracovní funkce (zařazení)
Účast na n.p. | Zakládá pracovní poměr účast na nemocenském pojištění?
Denní vyměřovací základ | Denní vyměřovací základ nemocenského pojištění.
Hodinový průměr | Hodinový průměr
Denní průměr | Denní průměr
Měsíční průměr | Měsíční průměr

    Atributy tisku

    Základní údaje
OSC | Jednoznačná identifikace pracovníka | MZPPHIS_mz01id | C(6)
Příjmení | Příjmení pracovníka | MZPPHIS_mz01prijme | C(50)
Číslo p.p. | Číslo pracovního poměru | MZPPHIS_mz32cispp | C(2)
Kalendář | Jednoznačná identifikace kalendáře | MZPPHIS_mz25id | C(6)
Stupnice | Identifikace tarifní stupnice | MZPPHIS_mz23id | C(6)
Třída | Tarifní třída (1-99) | MZPPHIS_mz24trida | C(2)
Prac. funkce | Identifikace pracovní funkce (zařazení) | MZPPHIS_mz31id | C(6)
Účast na n.p. | Zakládá pracovní poměr účast na nemocenském pojištění? | Výpočet | C(3)
Denní vyměřovací základ | Denní vyměřovací základ nemocenského pojištění. | MZPPHIS_mz32npzakl | N(3)
Den.vym.zákl.(nered.) | Denní vyměřovací základ nemocenského pojištění neredukovaný. | MZPPHIS_mz32npzakd | N(9,2)
Hodinový průměr | Hodinový průměr | MZPPHIS_mz32pruhod | N(9,2)
Denní průměr | Denní průměr | MZPPHIS_mz32pruden | N(9,2)
Měsíční průměr | Měsíční průměr | MZPPHIS_mz32prumes | N(9,2)
Volné číslo I | Volně použitelné číslo | MZPPHIS_mz32cislo1 | N(20,4)
Volné číslo II | Volně použitelné číslo | MZPPHIS_mz32cislo2 | N(20,4)
Volné číslo III | Volně použitelné číslo | MZPPHIS_mz32cislo3 | N(20,4)
Zůstatek nové dovolené | Zůstatek nové dovolené | MZPPHIS_mz32dovnov | N(6,2)
Zůstatek staré dovolené | Zůstatek staré dovolené | MZPPHIS_mz32dovsta | N(6,2)
Měsíc | Měsíc zpracováných mezd | MZPPHIS_mz45mesic | C(2)
Rok | Rok zpracováných mezd | MZPPHIS_mz45rok | C(4)

    Viz.také

    Karta pracovníka


Aktualizace seznamu věcí

Popis

Jedná se o záložku s informacemi o přístupových právech k věcem s přístupem, která je dostupná v činnosti uživatelé programu a skupiny uživatelů. Informace na této záložce jsou naplněny automaticky podle nastavených přístupových práv, dojde-li však ke změně (např. vybranému uživateli je zpřístupněn nový druh operace nebo nový sklad apod.) je nutno spustit činnost „aktualizace seznamu věcí“ v menu Volby.


VÝKAZY

Popis

Sdružují v sobě činnosti, které se týkají možnosti definice, výpočtu, prohlížení a tisku mzdových výkazů.

Viz.také

Prohlížení vypočteného výkazu | Seznam výkazů | Typy řádků pro výkazy


Prohlížení vypočteného výkazu

Popis

Tuto činnost uživatel spouští z menu Volby v činnosti seznam výkazů. Po aktivaci této činnosti si uživatel vybere zda si chce výkaz prohlédnout za vybraného pracovníka (a pak ho po stisku F2 vybere) nebo zda chce vidět výkaz pro všechny pracovníky najednou. Po tomto výběru se uživateli zobrazí spočtené řádky výkazu tak, jak si je v definici vytvořil.

Datový model

  • MZDLIST Mzdový list
    • MZKARTA Pracovník
    • MZDLD Výkazy - řádky

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Karta pracovníka | Karta pracovníka
F2 | Seznam výkazů | Seznam výkazů a jejich definice

    Formulář

    Formulář činnosti - Seznam výkazů
Mřížka [Vypočtený výkaz]
Listovací rámeček
Stránka #1 Výkaz
Rok | Rok
Výkaz | Identifikace výkazu
 | Popis výkazu
OSC | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Prac. poměr | Číslo pracovního poměru
 | Druh pracovního poměru
 | Vznik prac. poměru
 | Skončení prac. poměru
Řádek | Číslo řádku
 | Popis řádku
Leden | Lednová hodnota řádku
Únor | Únorová hodnota řádku
Březen | Březnová hodnota řádku
Duben | Dubnová hodnota řádku
Květen | Květnová hodnota řádku
Červen | Červnová hodnota řádku
Červenec | Červencová hodnota řádku
Srpen | Srpnová hodnota řádku
Září | Záříjová hodnota řádku
Říjen | Říjnová hodnota řádku
Listopad | Listopadová hodnota řádku
Prosinec | Prosincová hodnota řádku
Stránka #2 Výběr
Výkaz | Identifikace výkazu
Pracovník - OSC | Jednoznačná identifikace pracovníka
Číslo p.p. | Číslo pracovního poměru
Rok | Rok
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Vypočtený výkaz] činnosti - Seznam výkazů

    Mřížka [Vypočtený výkaz] činnosti - Seznam výkazů
Řádek | Číslo řádku
Popis | Popis řádku
Rok | Rok
OSC | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Leden | Lednová hodnota řádku
Únor | Únorová hodnota řádku
Březen | Březnová hodnota řádku
Duben | Dubnová hodnota řádku
Květen | Květnová hodnota řádku
Červen | Červnová hodnota řádku
Červenec | Červencová hodnota řádku
Srpen | Srpnová hodnota řádku
Září | Záříjová hodnota řádku
Říjen | Říjnová hodnota řádku
Listopad | Listopadová hodnota řádku
Prosinec | Prosincová hodnota řádku
Výkaz | Identifikace výkazu
Popis | Popis výkazu

    Atributy tisku

    Základní údaje
Rok | Rok | MZDLIST_mz53rok | C(4)
Výkaz | Identifikace výkazu | MZDLIST_mz49id | C(6)
Pracovník | Jednoznačná identifikace pracovníka | MZDLIST_mz01id | C(6)
Číslo p.p. | Číslo pracovního poměru | MZDLIST_mz32cispp | C(2)
Druh | Druh pracovního poměru | Výpočet | C(19)
Skončení p.p. | Skončení prac. poměru | MZDLIST_mz32skonpp | D
Vznik p.p. | Vznik prac. poměru | MZDLIST_mz32vznipp | D
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Rodné příjmení | Rodné příjmení | MZKARTA_mz01rodne | C(15)
Datum narození | Datum narození | MZKARTA_mz01naroz | D
Rodné číslo | Rodné číslo | MZKARTA_mz01rodc | C(11)
Místo narození | Místo narození | MZKARTA_mz01misnar | C(40)
Rodinný stav | Stav - svobodný/á,ženatý,vdaná,vdovec,vdova,rozvedený/á | Výpočet | C(12)
Počet dětí | Počet dětí | MZKARTA_mz01deti | N(2)
Těžce ZTP | Těžce ZTP - Ano,Ne | Výpočet | C(3)
Typ důchodu | Typ důchodu | Výpočet | C(18)
Od kdy | Datum přiznání důchodu, pracovník dovršil důchodový věk | MZKARTA_mz01duchda | D
Kč | Důchod - částka | MZKARTA_mz01duchkc | N(5)
Prac.funkce | Popis pracovní funkce (pracovního zařazení) | MZPRACFU_mz31pracfu | C(40)
Pracovní doba | Pracovní doba hodin / den | MZKALEN_mz25hodden | N(5,2)
Výplatní místo | Název výplatního místa | MZVYPMIS_mz22nazev | C(40)
Řádek | Číslo řádku | MZDLIST_mz50id | N(4)
Popis | Popis řádku | MZDLD_mz50nazev | C(40)
Typ řádku | Typ řádku | MZDLD_mz51typ | C(1)
Tisknout řádek | Tisknout ano/ne? | Výpočet | C(3)
Leden | Lednová hodnota řádku | MZDLIST_mz53leden | N(14,2)
Únor | Únorová hodnota řádku | MZDLIST_mz53unor | N(14,2)
Březen | Březnová hodnota řádku | MZDLIST_mz53brezen | N(14,2)
Duben | Dubnová hodnota řádku | MZDLIST_mz53duben | N(14,2)
Květen | Květnová hodnota řádku | MZDLIST_mz53kveten | N(14,2)
Červen | Červnová hodnota řádku | MZDLIST_mz53cerven | N(14,2)
Červenec | Červencová hodnota řádku | MZDLIST_mz53cervec | N(14,2)
Srpen | Srpnová hodnota řádku | MZDLIST_mz53srpen | N(14,2)
Září | Záříjová hodnota řádku | MZDLIST_mz53zari | N(14,2)
Říjen | Říjnová hodnota řádku | MZDLIST_mz53rijen | N(14,2)
Listopad | Listopadová hodnota řádku | MZDLIST_mz53listop | N(14,2)
Prosinec | Prosincová hodnota řádku | MZDLIST_mz53prosin | N(14,2)

    Při pohybu v Pracovní poměry
Prac. poměr | Číslo pracovního poměru | MZPRACPO_mz32cispp | C(2)
Nástup do firmy (org.) | Vznik prac. poměru | MZPRACPO_mz32vznipp | D
Výstup | Skončení prac. poměru | MZPRACPO_mz32skonpp | D
Důvod ukončení p.p. | Důvod ukončení pracovního poměru | MZPRACPO_mz32duvod | C(40)
Třída | Tarifní třída (1-99) | MZPRACPO_mz24trida | C(2)
Aktuální základ nemocenské za kalendářní den | Denní vyměřovací základ nemocenského pojištění. | MZPRACPO_mz32npzakl | N(3)
Roční nárok na dovolenou | Roční nárok na dovolenou. | MZPRACPO_mz32dovnar | N(6,2)
Zůstatek staré dovolené | Zůstatek staré dovolené | MZPRACPO_mz32dovsta | N(6,2)
Zůstatek nové dovolené | Zůstatek nové dovolené | MZPRACPO_mz32dovnov | N(6,2)
Převod dovolené do příštího roku | Převod dovolené do příštího roku | MZPRACPO_mz32dovpre | N(6,2)
Zůstatek dovolené z minulého roku | Zůstatek dovolené z minulého roku | MZPRACPO_mz32dovmin | N(6,2)
Aktuální hodinový průměr na dovolenou | Hodinový průměr | MZPRACPO_mz32pruhod | N(9,2)
Aktuální denní základ pro výpočet dovolené | Denní průměr | MZPRACPO_mz32pruden | N(9,2)

    Viz.také

    Karta pracovníka | Seznam výkazů


Seznam výkazů

Popis

K dispozici je skutečně pouze přehled (neboli seznam) dosud vytvořených výkazů. V případě potřeby nového výkazu zde uživatel zadává jen hlavičku (tj. identifikace a název) nového výkazu. Výkazem může být např. mzdový list, přehled čistých mezd, přehled pracovní neschopnosti apod.

Pro vlastní definici, výpočet a prohlížení jednotlivých mzdových výkazů musí uživatel využít činnosti, které jsou k dispozici po stisku menu Volby.

Datový model

  • MZVYKAZY Výkaz

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Definice výkazu | Definice výkazu
F6 | Výpočet výkazu | Výpočet výkazu
F9 | Prohlížení vypočteného výkazu | Prohlížení vypočteného výkazu a případný tisk

    Formulář

    Formulář činnosti - Algoritmus stanovení nem. dávky
Mřížka [Seznam výkazů]
Identifikace | Identifikace výkazu
Popis | Popis výkazu
Komentář | Komentář
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události

    Mřížka [Seznam výkazů] činnosti - Algoritmus stanovení nem. dávky

    Mřížka [Seznam výkazů] činnosti - Algoritmus stanovení nem. dávky
Identifikace | Identifikace výkazu
Popis | Popis výkazu

    Atributy tisku

    Základní údaje
Identifikace | Identifikace výkazu | MZVYKAZY_mz49id | C(6)
Popis | Popis výkazu | MZVYKAZY_mz49popis | C(30)
Komentář | Komentář | MZVYKAZY_mz49pozn | M

    Viz.také

    Definice výkazu | Výpočet výkazu | Prohlížení vypočteného výkazu | Algoritmus stanovení nem. dávky


Typy řádků pro výkazy

Popis

Zde uživatel definuje, jakého typu mohou být jednotlivé řádky mzdových výkazů. Většinou jsou typem peníze, hodiny nebo dny. Ostatně za jiné hodnoty ani nemá význam mzdové údaje ve výkazech sledovat.

Datový model

  • MZDLTYPR Číselník typů řádků

    • Formulář

    Formulář činnosti - Algoritmus stanovení nem. dávky
Mřížka [Typy řádků]
Identifikace | Typ řádku
Popis | Popis řádku
Typ | Atribut řádku - vlastnost

    Mřížka [Typy řádků] činnosti - Algoritmus stanovení nem. dávky

    Mřížka [Typy řádků] činnosti - Algoritmus stanovení nem. dávky
Identifikace | Typ řádku
Popis | Popis řádku

    Atributy tisku

    Základní údaje
Typ | Typ řádku | MZDLTYPR_mz51typ | C(1)
Popis | Popis řádku | MZDLTYPR_mz51popis | C(55)
Typ | Atribut řádku - vlastnost | Výpočet | C(14)


PARAMETRY

Popis

Toto menu v sobě zahrnuje činnost, kde je možno nastavit potřebné parametry pro úspěšné zahájení práce s komponentou mzdy.

Viz.také

Parametry | PARAMETRY NEMOC. POJIŠTĚNÍ


Parametry

Popis

Parametry jsou k dispozici v menu Mzdy – Mzdy – Parametry. Jednotlivé parametry ovlivňují jakým způsobem se bude chovat optimalizovaný výpočet mezd. Obsahují základní nastavení hodnot systému mzdové agendy a jsou rozděleny do tří záložek:

záložka Hodnoty

¨ poslední zpracované mzdy k datu – datum posledního výpočtu mezd

¨ uzamknutí – datum uzamčení výpočtu mezd. Je-li vyplněno, pak k tomuto datu již nelze provádět opravy a výpočty mezd pracovníků

¨ dorovnání min. mzda – mzdová položka, sloužící k dorovnání příjmu do minimální mzdy

¨ náhrada mzdy za nemoc – identifikace položky náhrady mzdy (slouží k výstupu mezd do plateb a účetnictví)

¨ min. roč. daňový bonus

¨ max. roč. daňový bonus

¨ kontrola příslušnosti

záložka Chování

¨ den výplaty (a zároveň kdy bude den výplaty, jestliže by měl připadat na sobotu nebo neděli)

¨ velká / malá organizace

¨ technický selektor na výpl. lístek odkud

¨ typ kalendáře (po měsících nebo po dnech)

¨ plánovací kalendář – určuje jeden z měsíčních kalendářů FPD jako plánovací kalendář, platný pro všechny zaměstnance. I když organizace používá denní kalendáře (viz. atribut výše), musí být tento plánovací kalendář vygenerován i ve variantě měsíční a to v případě, že organizace používá ve mzdách měsíční průměry ve mzdách (např. při výplatě odstupného).

¨ způsob výpočtu denního průměru

¨ způsob výpočtu SP

¨ uplatňovat slevy na sociálním pojištění

¨ způsob výpočtu nepřítomnosti pro nemoc

¨ sada

¨ velikost zkušeb. doby v měs.

¨ typ daňového subjektu – možnosti jsou Neurčeno, F-Fyzická osoba, P-právnická osoba, L-Plátcova pokladna. Pro formulář „Hlášení k záloze na pojistné na důchodové spoření“ je nutno vyplnit, kdo je plátcem pojistného.

záložka Adresáti

¨ adresát, spojení, účet, adresa, KS a VS pro odvod zálohové daně

¨ adresát, spojení, účet, adresa, KS a VS pro odvod daňového bonusu

¨ adresát, spojení, účet, adresa, KS a VS pro odvod srážkové daně

¨ adresát, spojení, účet, adresa, KS a VS pro odvod sociálního pojištění

¨ adresát, spojení, účet, adresa, KS a VS pro odvod zákonného pojištění odpovědnosti

Datový model

  • MZPARAM Parametry

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresy adresátů | Seznam adres za adresáta.
F2 | Adresář | Přehled adresátů
F2 | Bankovní spojení adresátů |
F2 | Pracovní doba | Kalendáře a jim odpovídající měsíční fond pracovní doby.
F2 | Příjmy a náhrady |
F2 | Sady parametrů | Sady parametrů
F2 | Spojení | Seznam spojení za adresáta.

    Formulář

    Formulář činnosti - Příjmy a náhrady
Listovací rámeček
Stránka #1 Hodnoty
Poslední zpracované mzdy k datu | Datum, ke kterému jsou spočteny poslední mzdy.
Uzamknutí | Datum uzamknutí výpočtu mezd - je-li vyplněno, pak k tomuto datu nelze provádět opravy a výpočet mezd pracovníků
Dorovnání min. mzda | Mzdová položka sloužící k dorovnání příjmu do minimální mzdy
Náhrada mzdy za nemoc | Mzdová položka sloužící k výpočtu Náhrady mzdy za nemoc
Min. roč. daňový bonus | Minimální roční daňový bonus
Max. roč. daňový bonus | Maximální roční daňový bonus
Kontrola příslušnosti | Kontrola příslušnosti pracovníků k osobám
Stránka #2 Chování
Den výplaty | Den výplaty mezd
Den výplaty připadá na SOBOTU | Jestliže den výplaty mezd připadá na sobotu, vyplácejte v ...
Den výplaty připadá na NEDĚLI | Jestliže den výplaty mezd připadá na neděli, vyplácejte v ...
Technický selektor na výpl. lístek odkud | Odkud nastavovat technický selektor na výplatní lístek.
Typ kalendáře | Typ používaného kalendáře - po měsících, po dnech
Plánovací kalendář | Plánovací kalendář - kalendář společný pro všechyn pracovníky, pro účely měsíčního průměru
Způsob výpočtu denního průměru | Způsob výpočtu denního průměru
Způsob výpočtu SP | Způsob výpočtu sociálního pojištění za organizaci.
Uplatňovat slevy na sociálním pojištění. | Uplatňovat slevy na sociálním pojištění.
Způsob výpočtu nepřítomnosti pro nemoc | Způsob výpočtu nepřítomnosti pro nemoc, plus - dnů+hodin, mínus - dnů-hodin
Sada | Identifikátor sady parametrů
Velikost zkušeb. doby v měs. | Standardní velikost zkušební doby v měsících, zadá-li se 0, nebude se zkušební doba předplňovat.
Velká organizace | Velká organizace z hlediska sociálního pojištění.
Stránka #3 Adresáti
Zálohová daň | Adresát pro odeslání odvodu zálohové daně
 | Název adresáta
 | Číslo spojení adresáta pro zálohovou daň
 | Číslo adresy adresáta.
Účet | Identifikátor spojení na bankovní účet adresáta.
KS | Konstantní symbol - zálohová daň
VS | Variabilní symbol - zálohová daň
Daňový bonus | Adresát pro uplatnění daňového bonusu
 | Číslo spojení adresáta pro daňový bonus
 | Číslo adresy adresáta.
 | Název adresáta
Účet | Identifikátor spojení na bankovní účet adresáta.
KS | Konstantní symbol - daňový bonus
VS | Variabilní symbol - daňový bonus
Srážková daň | Adresát pro odeslání odvodu srážkové daně
 | Název adresáta
 | Číslo spojení adresáta pro srážkovou daň
 | Číslo adresy adresáta.
Účet | Identifikátor spojení na bankovní účet adresáta.
KS | Konstantní symbol - srážková daň
VS | Variabilní symbol - srážková daň
Soc. pojištění | Adresát pro odeslání odvodu sociálního pojištění
 | Název adresáta
 | Číslo spojení adresáta.
 | Adresa adresáta pro sociální pojištění
Účet | Identifikátor spojení na bankovní účet adresáta.
KS | Konstantní symbol - sociální odvody
VS | Variabilní symbol - sociální odvody
Zák. pojištění | Adresát pro uplatnění zákonného pojištění odpovědnosti
 | Název adresáta
 | Číslo spojení adresáta pro zákonné pojištění odpovědnosti
 | Číslo adresy adresáta.
Účet | Identifikátor spojení na bankovní účet adresáta.
KS | Konstantní symbol - zákonné pojištění odpovědnosti
VS | Variabilní symbol - zákonné pojištění odpovědnosti

    Atributy tisku

    Základní údaje
Poslední zpracované mzdy k datu | Datum, ke kterému jsou spočteny poslední mzdy. | MZPARAM_mz27datmzd | D
S.p. zaměstnance | Sociální pojištění hrazené zaměstnancem (%) | MZPARAM_mz27spzam | N(5,2)
S.p. organizace | Sociální pojištění hrazené organizací (%) | MZPARAM_mz27sporg | N(5,2)
Sazba zdravotního pojištění | Sazba zdravotního pojištění (%) | MZPARAM_mz27zpsazb | N(5,2)
Sazba(promile) | Sazba zákonného pojištění odpovědnosti organizace (promile) | MZPARAM_mz27zakpoj | N(6,2)
Minimální mzda | Základ, ze kterého se platí zdrav. poj. při neplaceném volnu. | MZPARAM_mz27zpnepl | N(5)
Vym. základ z.p. | Vyměřovací základ, ze kterého platí zdravotní pojištění stát | MZPARAM_mz27zpstat | N(5)
Limit srážkové daně | Limit srážkové daně | MZPARAM_mz27dalims | N(5)
Sazba srážkové daně | Sazba srážkové daně | MZPARAM_mz27dasazs | N(5,2)
Max. denní vyměř.zákl. - plná částka | Maximální denní vyměřovací základ - plná částka | MZPARAM_mz27npmaxz | N(3)
Max. denní vyměř.zákl. - 60% částka | Maximální denní vyměřovací základ - 60% částka | MZPARAM_mz27npmax2 | N(3)
Nemocenské za první tři dny (%) | Nemocenské za první tři dny (%) | MZPARAM_mz27np3dny | N(3)
Nemocenské za den (%) | Nemocenské za den (%) | MZPARAM_mz27npden | N(3)
Velká organizace | Velká organizace z hlediska sociálního pojištění. | Výpočet | C(3)
Adresát - soc. pojištění | Adresát pro odeslání odvodu sociálního pojištění | MZPARAM_mz27socad | C(6)
Adresa | Adresa adresáta pro sociální pojištění | MZPARAM_mz27socadr | C(2)
Spojení | Číslo spojení adresáta. | MZPARAM_mz27socspo | C(2)
Účet | Identifikátor spojení na bankovní účet adresáta. | MZPARAM_mz27socban | C(2)
KS | Konstantní symbol - sociální odvody | MZPARAM_mz27socks | C(4)
VS | Variabilní symbol - sociální odvody | MZPARAM_mz27socvs | C(10)
Adresát - zálohová daň | Adresát pro odeslání odvodu zálohové daně | MZPARAM_mz27zalda | C(6)
Adresa | Číslo adresy adresáta. | MZPARAM_mz27zaladr | C(2)
Spojení | Číslo spojení adresáta pro zálohovou daň | MZPARAM_mz27zalspo | C(2)
Účet | Identifikátor spojení na bankovní účet adresáta. | MZPARAM_mz27zalban | C(2)
KS | Konstantní symbol - zálohová daň | MZPARAM_mz27zalks | C(4)
VS | Variabilní symbol - zálohová daň | MZPARAM_mz27zalvs | C(10)
Adresát - srážková daň | Adresát pro odeslání odvodu srážkové daně | MZPARAM_mz27srda | C(6)
Adresa | Číslo adresy adresáta. | MZPARAM_mz27sradr | C(2)
Spojení | Číslo spojení adresáta pro srážkovou daň | MZPARAM_mz27srspo | C(2)
Účet | Identifikátor spojení na bankovní účet adresáta. | MZPARAM_mz27srban | C(2)
KS | Konstantní symbol - srážková daň | MZPARAM_mz27srks | C(4)
VS | Variabilní symbol - srážková daň | MZPARAM_mz27srvs | C(10)

    Viz.také

    Adresy adresátů | Adresář | Bankovní spojení adresátů | Pracovní doba | Příjmy a náhrady | Sady parametrů | Spojení


PARAMETRY NEMOC. POJIŠTĚNÍ

Popis

Tyto parametry má uživatel k dispozici v menu Mzdy – Parametry – Parametry nemocenského pojištění. Slouží ke vstupu parametrů potřebných pro výpočet dávek nemocenského pojištění. Definice těchto parametrů je daná současnými zákony, tzn. hodnoty zde uvedené si uživatel nevymýšlí. Pokud by měl uživatel pocit, že nadefinovat si tyto parametry je tzv. „nad jeho síly“, svěří tuto činnost do rukou svému implementátorovi. Jsou to tyto parametry:

¨ algoritmus stanovení nem. dávky

¨ denní vyměřovací základ

¨ platnost algoritmu v období

V činnosti Parametry jsou k dispozici další dva atributy, které souvisí s výpočtem nemocenského pojištění. Na záložce „chování“ je to příznak zaškrtnutí, zda se jedná o velkou či malou organizaci a příznak plus nebo mínus u způsobu výpočtu nepřítomnosti pro nemoc.

Nastavení položek Mzdy – Parametry – Parametry nemocenského pojištění je v souladu s legislativou. Vzhledem ke složitosti dané problematiky posíláme uživatelům vždy balíček s nastavením těchto parametrů. V případě potřeby jejich úpravu provádí zkušený implementátor.

Viz.také

Algoritmus stanovení nem. dávky | Denní vyměřovací základ | Platnost algoritmu v období


Algoritmus stanovení nem. dávky

Popis

Tato činnost zobrazuje nastavené algoritmy stanovení výše nemocenské dávky. Na záložce „algoritmus stanovení nem. dávky“ je pouze hlavička algoritmu (tzn. její identifikace a název), záložka „stanovení dávky“ obsahuje konkrétní údaje k danému algoritmu. Tento přehled je s dodávkou systému naplněn, v případě změn v legislativě je nové nastavení řešeno dodáním implementačního balíčku.

Datový model

  • MZPAALGN Parametry nepřítomností - Algoritmus stanovení dávky

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Denní vyměřovací základ | Denní vyměřovací základ
F2 | Příjmy a náhrady |

    Formulář

    Formulář činnosti - Příjmy a náhrady
Mřížka [Algoritmus stanovení nem. dávky]
Listovací rámeček
Stránka #1 Algoritmus stanovení nem. dávky
Algoritmus | Identifikace algoritmu
 | Popis algoritmu
Verze | Verze algoritmu stanovení dávky
Komentář | Komentář
Zaokrouhlení | Zaokrouhlení - žádné, od 0.5 nahoru, vždy nahoru, vždy dolu
 | Zaokrouhlení na kolik míst ?
Stránka #2 Stanovení dávky
Mřížka [Stanovení dávky]
Platnost od | Platnost stanovení částky od
do | Platnost stanovení částky do
Identif. DVZ | Identifikace redukce denního vyměřovacího základu
Den od | Den dávky od
do | Den dávky do
Procento | Procento započítávání dávky
Zaokrouhlení | Zaokrouhlení - žádné, od 0.5 nahoru, vždy nahoru, vždy dolu
Podrobnosti | Význam - způsob použití
 | Jednoznačná identifikace mzdové položky
 | Typ dnů, se kterými se dále pracuje
 | Vztah k datu. Je klíčové datum nepřítomnosti nebo datum dávky ?
 | Typ záznamu
Komentář | Komentář
Stránka #3 Popis verzí algoritmu stanovení nem. dávky
Mřížka [Popis verzí algirotmu stanovení nem. dávky]
Verze | Verze algoritmu stanovení dávky
Dne | Datum záznamu o verzi
 | Datum aktualizace
Popis | Popis verze
 | Jméno uživatele systému, který změnil záznam

    Mřížka [Algoritmus stanovení nem. dávky] činnosti - Příjmy a náhrady

    Mřížka [Algoritmus stanovení nem. dávky] činnosti - Příjmy a náhrady
Identifikace algoritmu | Identifikace algoritmu
Popis | Popis algoritmu

    Mřížka [Stanovení dávky] činnosti - Příjmy a náhrady

    Mřížka [Stanovení dávky] činnosti - Příjmy a náhrady
Identif. DVZ | Identifikace redukce denního vyměřovacího základu
Den od | Den dávky od
Den do | Den dávky do
Procento | Procento započítávání dávky
Zaokrouhlení | Zaokrouhlení - žádné, od 0.5 nahoru, vždy nahoru, vždy dolu
Platnost od | Platnost stanovení částky od
Platnost do | Platnost stanovení částky do
Význam | Význam - způsob použití
Dny | Typ dnů, se kterými se dále pracuje
Vztah k datu | Vztah k datu. Je klíčové datum nepřítomnosti nebo datum dávky ?
Druh náhrady | Jednoznačná identifikace mzdové položky
Typ | Typ záznamu

    Mřížka [Popis verzí algirotmu stanovení nem. dávky] činnosti - Příjmy a náhrady

    Mřížka [Popis verzí algirotmu stanovení nem. dávky] činnosti - Příjmy a náhrady
Identifikace algoritmu | Identifikace algoritmu
Verze | Verze algoritmu stanovení dávky
Popsal | Jméno uživatele systému, který změnil záznam

    Atributy tisku

    Základní údaje
Identifikace algoritmu | Identifikace algoritmu | MZPAALGN_mz11id | C(6)
Popis | Popis algoritmu | MZPAALGN_mz11popis | C(40)

    Při pohybu v Stanovení dávky
Den od | Den dávky od | MZPADAVK_mz14denod | N(4)
Den do | Den dávky do | MZPADAVK_mz14dendo | N(4)
Procento | Procento započítávání dávky | MZPADAVK_mz14proc | N(5,2)
Zaokrouhlení | Zaokrouhlení - žádné, od 0.5 nahoru, vždy nahoru, vždy dolu | Výpočet | C(13)
Identif. DVZ | Identifikace redukce denního vyměřovacího základu | MZPADAVK_mz12id | C(6)
Význam | Význam - způsob použití | Výpočet | C(7)
Typ | Typ záznamu | Výpočet | C(9)
Vztah k datu | Vztah k datu. Je klíčové datum nepřítomnosti nebo datum dávky ? | Výpočet | C(6)
Dny | Typ dnů, se kterými se dále pracuje | Výpočet | C(10)
Mzdová položka | Jednoznačná identifikace mzdové položky | MZPADAVK_mz28id | C(6)
Platnost od | Platnost stanovení částky od | MZPADAVK_mz14platod | D
do | Platnost stanovení částky do | MZPADAVK_mz14platdo | D

    Viz.také

    Denní vyměřovací základ | Příjmy a náhrady


Denní vyměřovací základ

Popis

Tato činnost zobrazuje přehled nastavení denních vyměřovacích základů, který se uplatňuje v algoritmu stanovení výše nemocenské dávky. Tento přehled je s dodávkou systému naplněn, v případě změn v legislativě je nastavení řešeno dodávkou implementačního balíčku.

Datový model

  • MZPADVZH Parametry nepřítomností - DVZ hlavička

    • Formulář

    Formulář činnosti - Druh události
Mřížka [Hlavička DVZ]
Listovací rámeček
Stránka #1 Hlavička DVZ
Identif. DVZ | Identifikace redukce denního vyměřovacího základu
 | Popis
Zaokrouhlení | Zaokrouhlení - žádné, od 0.5 nahoru, vždy nahoru, vždy dolu
 | Zaokrouhlení na kolik míst ?
Původ reduk. částky | Původ redukované částky - základu
Komentář | Komentář
Stránka #2 Intervaly DVZ
Mřížka [Intervaly DVZ]
Hranice od | Redukční hranice od
do | Redukční hranice do
Procento | Procento započítávání DVZ
Zaokrouhlení | Zaokrouhlení - žádné, od 0.5 nahoru, vždy nahoru, vždy dolu
Komentář | Komentář

    Mřížka [Hlavička DVZ] činnosti - Druh události

    Mřížka [Hlavička DVZ] činnosti - Druh události
Identif. DVZ | Identifikace redukce denního vyměřovacího základu
Popis | Popis
Zaokrouhlení | Zaokrouhlení - žádné, od 0.5 nahoru, vždy nahoru, vždy dolu

    Mřížka [Intervaly DVZ] činnosti - Druh události

    Mřížka [Intervaly DVZ] činnosti - Druh události
Hranice od | Redukční hranice od
Hranice do | Redukční hranice do
Procento | Procento započítávání DVZ
Zaokrouhlení | Zaokrouhlení - žádné, od 0.5 nahoru, vždy nahoru, vždy dolu

    Atributy tisku

    Základní údaje
Identif. DVZ | Identifikace redukce denního vyměřovacího základu | MZPADVZH_mz12id | C(6)
Zaokrouhlení | Zaokrouhlení - žádné, od 0.5 nahoru, vždy nahoru, vždy dolu | Výpočet | C(13)
Popis | Popis | MZPADVZH_mz12popis | C(40)
Komentář | Komentář | MZPADVZH_mz12pozn | M
Původ reduk. částky | Původ redukované částky - základu | Výpočet | C(15)

    Při pohybu v Intervaly DVZ
Hranice od | Redukční hranice od | MZPADVZP_mz13hranod | N(10,2)
Hranice do | Redukční hranice do | MZPADVZP_mz13hrando | N(10,2)
Procento | Procento započítávání DVZ | MZPADVZP_mz13proc | N(6,2)
Zaokrouhlení | Zaokrouhlení - žádné, od 0.5 nahoru, vždy nahoru, vždy dolu | Výpočet | C(13)
Komentář | Komentář | MZPADVZP_mz13pozn | M


Platnost algoritmu v období

Popis

Tato činnost zobrazuje přehled platností (období od – do) jednotlivých důvodů nepřítomnosti. Tento přehled je s dodávkou systému naplněn, v případě změn v legislativě je nastavení řešeno dodávkou implementačního balíčku. U každého důvodu je k dispozici i informace, ke kterému se vztahuje algoritmu.

Datový model

  • MZPAPLAT Parametry nepřítomností - platnost v období

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Algoritmus stanovení nem. dávky | Algoritmus stanovení nem. dávky

    Formulář

    Formulář činnosti - Algoritmus stanovení nem. dávky
Mřížka [Platnost v období]
Důvod | Důvod nepřítomnosti
Identifikace algoritmu | Identifikace algoritmu
Platnost od | Platnost od
Platnost do | Platnost do
Komentář | Komentář

    Mřížka [Platnost v období] činnosti - Algoritmus stanovení nem. dávky

    Mřížka [Platnost v období] činnosti - Algoritmus stanovení nem. dávky
Důvod | Důvod nepřítomnosti
Platnost od | Platnost od
Platnost do | Platnost do
Identifikace algoritmu | Identifikace algoritmu

    Atributy tisku

    Základní údaje
Důvod | Důvod nepřítomnosti | Výpočet | C(26)
Platnost od | Platnost od | MZPAPLAT_mz10platod | D
Platnost do | Platnost do | MZPAPLAT_mz10platdo | D
Identifikace algoritmu | Identifikace algoritmu | MZPAPLAT_mz11id | C(6)
Komentář | Komentář | MZPAPLAT_mz10pozn | M
Popis | Popis algoritmu | MZPAALGN_mz11popis | C(40)

    Viz.také

    Algoritmus stanovení nem. dávky


INFORMACE O PRACOVNÍKOVI

Popis

Jedná se o souhrn informací, které má uživatel k dispozici pod hlavičkou této činnosti. K dispozici jsou vždy po pravém stisku myši na tučném atributu OSC nebo např. na kartě pracovníka pod menu Volby. Zobrazují se následující údaje:

¨ nepřítomnost pro nemoc

¨ události mezd

¨ jednotlivé výčetky platidel

¨ prohlížení výplatních lístků

¨ výplatní lístky

¨ všechny výplatní lístky - zadávání

Viz.také

Nepřítomnost pro nemoc | Události mezd | Jednotlivé výčetky platidel | Prohlížení výplatních lístků | Výplatní lístky | Všechny výpl. lístky-zadávání | Prohlížení vypočteného výkazu | Karta pracovníka | Pracovníci v kategoriích | Osobní údaje | Vztahy k osobám | Přehled hodnot parametrů | Pracovní poměry | Strom pracovníka | INFO K PRACOVNÍKOVI


Pracovníci v kategoriích

Popis

Tato činnost poskytuje uživateli přehled o pracovnících a jejich zařazení do kategorií (informace závisí na nadefinovaném filtru na záložce Výběr). Zároveň je možno přiřadit pracovníky do jednotlivých nadefinovaných kategorií. Při zadávání se vstupují tyto údaje:

¨ identifikace pracovníka (jméno se pak předplní automaticky)

¨ kategorie – výběr z překryvného seznamu nadefinovaných kategorií

¨ datum platnosti zahájení příslušnosti v kategorii

¨ stav – zahajuje platnost/ukončuje platnost – jedním záznamem se platnost zahajuje, dalším záznamem se platnost v kategorii ukončuje

¨ popis – krátký popis, který vyjadřuje vztah pracovníka k adresátovi

¨ adresát – má smysl ho uvádět pouze u některých kategorií, jinde smysl nemá (např.kategorie cizinec pracující v ČR – je uvedena jeho adresa v zahraničí nebo kategorie místo výkonu činnosti – je uvedena adresa, kde vykonává svou práci apod.)

Datový model

  • MZKARADA Pracovník v kategorii
    • MZKARTA Pracovník
    • ADSPOJ Spojení adresáta
      • ADADSAT Adresát
    • MZKARADD Kategorie pracovníka
      • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Kategorie pracovníků
Mřížka [Pracovníci v kategoriích]
Listovací rámeček
Stránka #1 Pracovníci v kategoriích
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Rodné číslo | Rodné číslo
Kategorie | Identifikace kategorie pracovníka
Platnost od | Platné od data
Platnost do | Platné do data
Stav | Stav - Zahajuje platnost/Ukončuje platnost
Popis | Popis vztahu pracovníka k adresátovi
Adresát | Identifikace adresáta
 | Název adresáta
 | Číslo spojení adresáta.
Komentář | Komentář
Stránka #2 Výběr
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Kategorie | Identifikace kategorie pracovníka
Účel | Účel (důvod, typ) kategorie pracovníka
Adresát | Identifikace adresáta
 | Název adresáta
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 | Platnost nebo neplatnost k datu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Pracovníci v kategoriích] činnosti - Kategorie pracovníků

    Mřížka [Pracovníci v kategoriích] činnosti - Kategorie pracovníků
Pracovník | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Adresát | Identifikace adresáta
Platnost od | Platné od data
Platnost do | Platné do data
Kategorie | Identifikace kategorie pracovníka
Název kategorie | Název kategorie pracovníka

    Vyvolávané činnosti

    K. | Činnost | Popis
- | INFORMACE O PRACOVNÍKOVI |
F2 | Adresář | Přehled adresátů
F2 | Karta pracovníka | Karta pracovníka
F2 | Kategorie pracovníků | Kategorie pracovníků
F2 | Spojení | Seznam spojení za adresáta.

    Viz.také

    INFORMACE O PRACOVNÍKOVI | Adresář | Karta pracovníka | Kategorie pracovníků | Spojení


Osobní údaje

Popis

Tuto činnost má uživatel k dispozici pod menu Volby ve formuláři Karta pracovníka. Jedná se v podstatě o seznam volných atributů, kde si podle svých potřeb může nadefinovat jakékoliv údaje související s daným pracovníkem, které jsou v dané firmě zvyklostí o pracovnících evidovat. Údaje mohou být různého typu, mohou mít zadánu platnost od – do a mohou být rozepsány do několika volných textů.

Datový model

  • MZOSOBNI Osobní údaje ke kartě pracovníka

    • Formulář

    Formulář činnosti - Kategorie pracovníků
Mřížka [Osob. údaje]
Pracovník | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Typ údaje | Typ údaje - údaje o dětech, o invaliditě, o studiu
Volný text1 | Volný text1
Volný text2 | Volný text2
Volný text3 | Volný text3
Volný text4 | Volný text4
Volné datum1 | Volné datum1
Volné číslo1 | Volné číslo1
Platnost od | Platnost od
do | Platnost do
Komentář | Komentář

    Mřížka [Osob. údaje] činnosti - Kategorie pracovníků

    Mřížka [Osob. údaje] činnosti - Kategorie pracovníků
Pracovník | Jednoznačná identifikace pracovníka
Typ údaje | Typ údaje - údaje o dětech, o invaliditě, o studiu
Platnost od | Platnost od
do | Platnost do
Volný text1 | Volný text1
Volný text2 | Volný text2
Volný text3 | Volný text3
Volný text4 | Volný text4
Volné datum1 | Volné datum1
Volné číslo1 | Volné číslo1

    Atributy tisku

    Základní údaje
Pracovník | Jednoznačná identifikace pracovníka | MZOSOBNI_mz01id | C(6)
Typ údaje | Typ údaje - údaje o dětech, o invaliditě, o studiu | Výpočet | C(12)
Volný text1 | Volný text1 | MZOSOBNI_mz80text1 | C(40)
Volný text2 | Volný text2 | MZOSOBNI_mz80text2 | C(40)
Volný text3 | Volný text3 | MZOSOBNI_mz80text3 | C(40)
Volný text4 | Volný text4 | MZOSOBNI_mz80text4 | C(40)
Platnost od | Platnost od | MZOSOBNI_mz80od | D
do | Platnost do | MZOSOBNI_mz80do | D
Komentář | Komentář | MZOSOBNI_mz80koment | M


Vztahy k osobám

Popis

Každý pracovník, který má nadefinovaná daňová zvýhodnění musí mít v této souvislosti nastaveny i vztahy k osobám. Tato činnost je dostupná z menu Volby na Kartě pracovníka. Uživatel na první záložce „vztahy pracovníků k osobám“ definuje:

¨ číslo a jméno pracovníka

¨ osoba – identifikace osoby, které se vztah týká

¨ rodné číslo osoby

¨ vztah mezi pracovníkem a osobou – výběr z překryvného seznamu (např. manžel, manželka, dítě, sourozenec, příbuzný apod.)

Význam jednotlivých nadefinovaných vztahů se definuje na další záložce „významy vztahu“. Význam může nabývat hodnot daňové zvýhodnění a vyživovaná osoba. Pro příklad: pokud má pracovník uvedeno dítě v daňových zvýhodněních, musí zde mít ve vztazích nastaven vztah dítě s významem daňové zvýhodnění. Pokud firma zároveň provádí exekuce, musí mít pracovník ve vztazích nastaven vztah dítě s významem vyživovaná osoba, tzn. že v praxi je to pak tak, že je uveden jeden vztah dítě a dva významy.

Datový model

  • MZKAROSO Vztah mezi pracovníkem a příslušnou osobou
    • MZKARTA Pracovník
    • MZOSOBA Tabulka osob nějakým způsobem vázaných k pracovníkovi

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Karta pracovníka | Karta pracovníka
F2 | Osoby | Osoby
F2 | Vztahy mezi pracovníky a osobami | Vztahy mezi pracovníky a osobami

    Formulář

    Formulář činnosti - Karta pracovníka
Mřížka [Vztah pracovníka a osoby]
Listovací rámeček
Stránka #1 Vztahy pracovníků k osobám
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Osoba | Identifikace osoby
 | Jméno a příjmení osoby
Rodné číslo | Rodné číslo
Vztah | Vztah mezi pracovníkem a osobou
Komnetář | Komnetář
Stránka #2 Významy vztahu
Mřížka [Platnost]
Význam | Identifikace vztahu
Od | Platnost od
do | Platnost do
Komentář | Komentář
Stránka #3 Výběr
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Osoba | Identifikace osoby
 | Jméno a příjmení osoby
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Vztah pracovníka a osoby] činnosti - Karta pracovníka

    Mřížka [Vztah pracovníka a osoby] činnosti - Karta pracovníka
Osoba | Identifikace osoby
Jméno a příjmení | Jméno a příjmení osoby
Pracovník | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka

    Mřížka [Platnost] činnosti - Karta pracovníka

    Mřížka [Platnost] činnosti - Karta pracovníka
Identifikace | Identifikace vztahu
Popis | Popis vztahu
Od | Platnost od
do | Platnost do
Osoba | Identifikace osoby
Pracovník | Jednoznačná identifikace pracovníka

    Atributy tisku

    Základní údaje
Osoba | Identifikace osoby | MZKAROSO_mz05id | C(6)
Pracovník | Jednoznačná identifikace pracovníka | MZKAROSO_mz01id | C(6)
Komnetář | Komnetář | MZKAROSO_mz06koment | M
Vztah | Vztah mezi pracovníkem a osobou | Výpočet | C(15)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Jméno a příjmení | Jméno a příjmení osoby | MZOSOBA_mz05jmprij | C(40)
Datum narození | Datum narození | MZOSOBA_mz05datnar | D
Rodné číslo | Rodné číslo | MZOSOBA_mz05rodc | C(11)
ZTP | Je ZTP - Ano, Ne | Výpočet | C(3)

    Viz.také

    Karta pracovníka | Osoby | Vztahy mezi pracovníky a osobami


Pracovní poměry

Popis

Jedná se o přehled pracovních poměrů jednotlivých pracovníků nebo všech (záleží na nastaveném filtru na záložce Výběr). Tyto informace jsou zároveň dostupné na kartě pracovníka – záložka pracovní poměry – funkční klávesa F6 nebo příslušná činnost pod menu Volby. U každého pracovního poměru jsou k dispozici tyto základní informace:

¨ jméno pracovníka

¨ číslo, druh pracovního poměru (tzn. hlavní, vedlejší) a funkce

¨ kalendář, stupnice, třída

Další informace jsou buď naplněny z karty (např. vznik pracovního poměru) nebo jejich hodnotu vyplňuje uzávěrka mezd (průměry na dovolenou, nárok dovolené apod.)

Tato činnost je v podstatě shodná s příslušnou záložkou na kartě pracovníka, z důvodu zajištění přístupových práv k této činnosti a možnosti importů existuje ještě i takto samostatně.

Datový model

  • MZPRACPO Pracovní poměr
    • MZKARTA Pracovník
    • MZPRACFU Pracovní funkce - skutečné a typové
      • MZUMIST Alokace mezd - umístění
        • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - OZNAČOVÁNÍ
Mřížka [Prac .poměr]
Listovací rámeček
Stránka #1 Pracovní poměry
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
Prac.p. | Číslo pracovního poměru
 | Druh pracovního poměru
 | Identifikace pracovní funkce (zařazení)
 | Jednoznačná identifikace kalendáře
 | Identifikace tarifní stupnice
 | Tarifní třída (1-99)
 | Datum ukončení zkušební lhůty
 | Způsob odměňování - typ mzdy (měsíční, hodinová, ....)
Externí identifikace | Externí identifikace pracovníka
Vznik a skončení p.p. | Vznik prac. poměru
 | Skončení prac. poměru
Výpověď | Datum doručení výpovědi nebo datum uzavření dohody rozvázání pracovního poměru
 | Datum odvolání výpovědi
 | Jedná se o určující prac.pom. (při více prac.poměrech)?
 | Důvod ukončení pracovního poměru
Průměry na dov. | Hodinový průměr
 | Denní průměr
 | Měsíční průměr
Účast na n.p. | Zakládá pracovní poměr účast na nemocenském pojištění?
 | Vztah k pojistnému na sociální zabezpečení
DVZ | Denní vyměřovací základ neredukovaný ke konci roku 2008.
Dovolená | Zůstatek staré dovolené
 | Zůstatek nové dovolené
 | Roční nárok na dovolenou.
 | Zůstatek dovolené z minulého roku, stav k 1.1. - neodečítá se z něj, ke mzdovému listu
 | Převod dovolené do příštího roku - stav k 1.1., neodečítá se z něj, ke mzdovému listu
 | Volně použitelné datum
Volné | Volně použitelné číslo
 | Volně použitelné číslo
 | Volně použitelné číslo
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Stránka #2 Výběr
Pracovník | Jednoznačná identifikace pracovníka
Číslo p.p. | Číslo pracovního poměru
Prac. funkce | Identifikace pracovní funkce (zařazení)
Prac. poměr od | Datum trvání pracovního poměru - od
do | Datum trvání pracovního poměru - do
Externí identifikace | Externí identifikace pracovníka
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Prac .poměr] činnosti - OZNAČOVÁNÍ

    Mřížka [Prac .poměr] činnosti - OZNAČOVÁNÍ
Označování | Označení záznamu
Pracovník | Jednoznačná identifikace pracovníka
Číslo p.p. | Číslo pracovního poměru
Druh | Druh pracovního poměru
Prac. funkce | Identifikace pracovní funkce (zařazení)

    Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
F2 | Karta pracovníka | Karta pracovníka
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Pracovní doba | Kalendáře a jim odpovídající měsíční fond pracovní doby.
F2 | Pracovní místa skut. a typová | Popis pracovní funkce (zařazení)
F2 | Tarifní stupnice | Mzdové tarifní stupnice a jim odpovídající tarifní třídy.
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Výběr pracovního poměru | Výběr prac. poměru - k již zadanému pracovníkovi
F2 | Výběr tar. třídy | Umožní zvolit nějakou existující tar. třídu

    Atributy tisku

    Základní údaje
Pracovník | Jednoznačná identifikace pracovníka | MZPRACPO_mz01id | C(6)
Číslo p.p. | Číslo pracovního poměru | MZPRACPO_mz32cispp | C(2)
Druh | Druh pracovního poměru | Výpočet | C(19)
Kalendář | Jednoznačná identifikace kalendáře | MZPRACPO_mz25id | C(6)
Stupnice | Identifikace tarifní stupnice | MZPRACPO_mz23id | C(6)
Třída | Tarifní třída (1-99) | MZPRACPO_mz24trida | C(2)
Prac. funkce | Identifikace pracovní funkce (zařazení) | MZPRACPO_mz31id | C(6)
Typové pracovní místo | Jednoznačná identifikace typové pracovní funkce (zařazení) | MZPRACPO_mz82id | C(6)
Org. sel. | Identifikátor organizačního selektoru. | MZPRACPO_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MZPRACPO_sp20idzak | C(9)
Účast na n.p. | Zakládá pracovní poměr účast na nemocenském pojištění? | Výpočet | C(3)
Vztah k pojistnému na soc. zabezp. | Vztah k pojistnému na sociální zabezpečení | Výpočet | C(6)
Denní vyměřovací základ | Denní vyměřovací základ nemocenského pojištění. | MZPRACPO_mz32npzakl | N(3)
Denní vyměřovací základ (neredukovaný) | Denní vyměřovací základ nemocenského pojištění neredukovaný. | MZPRACPO_mz32npzakd | N(9,2)
Skončení p.p. | Skončení prac. poměru | MZPRACPO_mz32skonpp | D
Důvod ukončení p.p. | Důvod ukončení pracovního poměru | MZPRACPO_mz32duvod | C(40)
Vznik p.p. | Vznik prac. poměru | MZPRACPO_mz32vznipp | D
Určující | Jedná se o určující prac.pom. (při více prac.poměrech)? | Výpočet | C(3)
Roční nárok na dovolenou | Roční nárok na dovolenou. | MZPRACPO_mz32dovnar | N(6,2)
Zůstatek staré dovolené | Zůstatek staré dovolené | MZPRACPO_mz32dovsta | N(6,2)
Zůstatek nové dovolené | Zůstatek nové dovolené | MZPRACPO_mz32dovnov | N(6,2)
Zůstatek dovolené z minulého roku | Zůstatek dovolené z minulého roku | MZPRACPO_mz32dovmin | N(6,2)
Převod dovolené do příštího roku | Převod dovolené do příštího roku | MZPRACPO_mz32dovpre | N(6,2)
Hodinový průměr | Hodinový průměr | MZPRACPO_mz32pruhod | N(9,2)
Denní průměr | Denní průměr | MZPRACPO_mz32pruden | N(9,2)
Měsíční průměr | Měsíční průměr | MZPRACPO_mz32prumes | N(9,2)
Zkušební lhůta | Datum ukončení zkušební lhůty | MZPRACPO_mz32zkuseb | D
Volné číslo I | Volně použitelné číslo | MZPRACPO_mz32cislo1 | N(20,4)
Volné číslo II | Volně použitelné číslo | MZPRACPO_mz32cislo2 | N(20,4)
Volné číslo III | Volně použitelné číslo | MZPRACPO_mz32cislo3 | N(20,4)

    Viz.také

    OZNAČOVÁNÍ | Karta pracovníka | Organizační selektor | Pracovní doba | Pracovní místa skut. a typová | Tarifní stupnice | Technicko-věcný selektor | Výběr pracovního poměru | Výběr tar. třídy


Strom pracovníka

Popis

Tuto činnost uživatel aktivuje nad Kartou pracovníka (pod menu Volby). Jedná se o stromové zobrazení údajů, které jsou v IS BM u každého pracovníka k dispozici (např. údaje z karty pracovníka, údaje o zdravotní pojišťovně, srážkách, půjčkách, exekucích apod.). Po stisku pravého tlačítka myši v hlavičce stromu (tj. na jménu pracovníka) si uživatel aktivuje činnost „nastavení stromu“, kdy si může mírně změnit zobrazení a vybrat způsob ovládání daného stromu.

Formulář

Formulář činnosti - Technicko-věcný selektor
Seznam komponent


INFO K PRACOVNÍKOVI

Popis

Karta pracovníka obsahuje jednotlivé záložky se všemi potřebnými údaji vztahujícími se k pracovníkovi. Pod činností Info k pracovníkovi jsou tyto záložky z karty pracovníka rozděleny do jednotlivých samostatných činností. Prvotním důvodem tohoto osamostatnění těchto činností je možnost importu (který do záložek na kartu nešel realizovat), další důvody je možnost nastavení přístupových práv a mnohem snadnější hledání v jednotlivých činnostech (nastavením filtru na záložce Výběr).

Viz.také

Jména pracovníků a PP | Pracovní poměry | Nezd. pol.,srážky,půjčk,exekuce | Osobní údaje k pracovníkům | Pravidelné příjmy k prac. | Charakter pracovníka v prac. p | Dávky v nepřítomnostech | Jména pracovníků a PP a další | Pojišťovny pracovníka | Osoby | Vztahy k osobám | Přehled hodnot parametrů | Pracovníci v kategoriích | Karta pracovníka - nápočty


Jména pracovníků a PP

Popis

Tato činnost poskytuje uživateli přehled o jednotlivých pracovnících a jejich výplatním místu. Na druhé záložce pracovní poměry jsou k dispozici veškeré údaje, které jsou potřebné ke správné definici pracovního poměru.

Datový model

  • MZKARTA Pracovník
    • SPPRISTU Přístupové právo uživatele k věci
    • MZVYPMIS Výplatní místo

    • Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | INFORMACE O PRACOVNÍKOVI |
F2 | Adresy | Seznam adres za adresáta.
F2 | Adresář | Přehled adresátů
F2 | Karta pracovníka | Karta pracovníka
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Pracovní doba | Kalendáře a jim odpovídající měsíční fond pracovní doby.
F2 | Pracovní místa skut. a typová | Popis pracovní funkce (zařazení)
F2 | Tarifní stupnice | Mzdové tarifní stupnice a jim odpovídající tarifní třídy.
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Výběr pracovního poměru | Výběr prac. poměru - k již zadanému pracovníkovi
F2 | Výběr tar. třídy | Umožní zvolit nějakou existující tar. třídu
F2 | Výplatní místa | Místa, pro která se při výplatě dělají výčetky platidel.

    Formulář

    Formulář činnosti - Technicko-věcný selektor
Mřížka [pracovníci]
Listovací rámeček
Stránka #1 Pracovníci
OSC | Jednoznačná identifikace pracovníka
Ext.id. | Externí identifikace pracovníka
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Titul | Titul pracovníka (před jménem)
Výpl. místo | Jednoznačná identifikace výplatního místa
Adresát | Identifikace adresáta
Adresa | Číslo adresy adresáta.
 | Název adresáta
 | Ulice adresy adresáta (včetně čísla popisného).
 | Poštovní směrovací číslo adresy adresáta.
 | Město adresy adresáta.
 | Název výplatního místa
Komentář | Komentář - poznámka
Stránka #2 Pracovní poměry
Mřížka [Prac. poměr]
Číslo p.p. | Číslo pracovního poměru
 | Druh pracovního poměru
Prac. funkce | Identifikace pracovní funkce (zařazení)
 | Popis pracovní funkce (pracovního zařazení)
Kalendář | Jednoznačná identifikace kalendáře
 | Název kalendáře
Stupnice | Identifikace tarifní stupnice
 | Popis tarifní stupnice
 | Tarifní třída (1-99)
Vznik p.p. | Vznik prac. poměru
Skončení p.p. | Skončení prac. poměru
 | Způsob odměňování - typ mzdy (měsíční, hodinová, ....)
Zk.lhůta | Datum ukončení zkušební lhůty
Selektory | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Alias | Název pracovníka v pracovním poměru (alias)
Určující | Jedná se o určující prac.pom. (při více prac.poměrech)?
Stránka #3 Výběr
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Výpl. místo | Jednoznačná identifikace výplatního místa
 | Název výplatního místa
Zobrazit pracovníky | Zobrazit pracovníky všechny, dosud pracující, již nepracující
Externí identifikace | Externí identifikace pracovníka
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [pracovníci] činnosti - Technicko-věcný selektor

    Mřížka [pracovníci] činnosti - Technicko-věcný selektor
Označování | Označení záznamu
OSC | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Datum narození | Datum narození
Rodné číslo | Rodné číslo
Žena/muž | Žena, muž
Stav | Stav - svobodný/á,ženatý,vdaná,vdovec,vdova,rozvedený/á
Typ důchodu | Typ důchodu
Datum přiznání | Datum přiznání důchodu, pracovník dovršil důchodový věk
Ext.id. | Externí identifikace pracovníka

    Mřížka [Prac. poměr] činnosti - Technicko-věcný selektor

    Mřížka [Prac. poměr] činnosti - Technicko-věcný selektor
Číslo p.p. | Číslo pracovního poměru
Druh | Druh pracovního poměru
Prac. funkce | Identifikace pracovní funkce (zařazení)

    Atributy tisku

    Základní údaje
OSC | Jednoznačná identifikace pracovníka | MZKARTA_mz01id | C(6)
Externí identifikace | Externí identifikace pracovníka | MZKARTA_mz01idext | C(20)
Adresát | Identifikace adresáta | MZKARTA_ad01id | C(6)
Adresa | Číslo adresy adresáta. | MZKARTA_ad02cisadr | C(2)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Zdravotní pojištění | Zdravotní pojištění | Výpočet | C(27)
Podepsal prohlášení | Podepsal pracovník daňové prohlášení? | Výpočet | C(3)
Lze srážet | Lze u pracovníka uplatnit srážkovou daň? | Výpočet | C(3)
Daňová tabulka | Identifikace daňové tabulky | MZKARTA_mza7id | C(6)
Výpl. místo | Jednoznačná identifikace výplatního místa | MZKARTA_mz22id | C(6)
Provést roční zúčtování ? | Provést roční zúčtování ? | Výpočet | C(3)
Komentář | Komentář - poznámka | MZKARTA_mz01koment | M

    Při pohybu v Pracovní poměry
Číslo p.p. | Číslo pracovního poměru | MZPRACPO_mz32cispp | C(2)
Druh | Druh pracovního poměru | Výpočet | C(19)
Kalendář | Jednoznačná identifikace kalendáře | MZPRACPO_mz25id | C(6)
Stupnice | Identifikace tarifní stupnice | MZPRACPO_mz23id | C(6)
Třída | Tarifní třída (1-99) | MZPRACPO_mz24trida | C(2)
Prac.funkce | Identifikace pracovní funkce (zařazení) | MZPRACPO_mz31id | C(6)
Typové pracovní místo | Jednoznačná identifikace typové pracovní funkce (zařazení) | MZPRACPO_mz82id | C(6)
Vznik p.p. | Vznik prac. poměru | MZPRACPO_mz32vznipp | D
Skončení p.p. | Skončení prac. poměru | MZPRACPO_mz32skonpp | D
Určující | Jedná se o určující prac.pom. (při více prac.poměrech)? | Výpočet | C(3)

    Viz.také

    OZNAČOVÁNÍ | INFORMACE O PRACOVNÍKOVI | Adresy | Adresář | Karta pracovníka | Organizační selektor | Pracovní doba | Pracovní místa skut. a typová | Tarifní stupnice | Technicko-věcný selektor | Výběr pracovního poměru | Výběr tar. třídy | Výplatní místa


Nezd. pol.,srážky,půjčk,exekuce

Popis

Jedná se o činnost, která je zároveň dostupná jako záložka na kartě pracovníka. V těchto místech však lze omezit přístupovými právy, je zde možnost importu dat a navíc záložka výběr umožňuje vyfiltrování dat podle okamžitých potřeb.

U každého pracovníka je k dispozici informace o tom, jaké nezdanitelné položky uplatňuje (případně na jakou osobu je uplatňuje – v případě daňového zvýhodnění na dítě) a jejich platnost od – do.

Datový model

  • MZNEZDPO Položky nezdanit. nebo srážky
    • MZMZDPOL Mzdová položka

    • Formulář

    Formulář činnosti - Osoby
Mřížka [Položky]
Listovací rámeček
Stránka #1 Nezdanitelné položky
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Mzdová položka | Jednoznačná identifikace mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...
 | Popis mzdové položky
Druh částky | Částka je společná,částka je individuální
Společná částka | Kč / j
 | Volný typ
Částka | Kč/ j
Osoba | Identifikace osoby
ZTP | Je ZTP - Ano, Ne
Datum signalizace | Datum signalizace skončení platnosti měsíční nezdanitelné položky
Pořadí srážky | Pořadí uplatnění srážky z karty ve výpočtu výplatního lístku
Pořadí půjčky | Pořadí uplatnění půjčky z karty ve výpočtu výplatního lístku
Srážet/S limitem do | Kolik Kč se má z výplaty srážet
Zůstatek | Zůstatek půjčky
Nedoplatek | Nedoplatek z minulého měsíce
Od data | Datum zahájení platnosti položky
Do data | Datum ukončení platnosti položky
Adresát | Identifikace adresáta
Účet | Identifikátor spojení na bankovní účet adresáta.
VS | Variabilní symbol
KS | Konstantní symbol
Stránka #2 Výběr
Pracovník | Jednoznačná identifikace pracovníka
Mzdová položka | Jednoznačná identifikace mzdové položky
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Položky] činnosti - Osoby

    Mřížka [Položky] činnosti - Osoby
Pracovník | Jednoznačná identifikace pracovníka
Mzd.pol. | Jednoznačná identifikace mzdové položky
Popis mzdové položky | Popis mzdové položky
Adresát | Identifikace adresáta
Účet | Identifikátor spojení na bankovní účet adresáta.

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresář | Přehled adresátů
F2 | Bankovní spojení adresátů |
F2 | Karta pracovníka | Karta pracovníka
F2 | Osoby | Osoby
F2 | Výběr položky | Lupa na Identifikace mzdové položky

    Atributy tisku

    Základní údaje
Pracovník | Jednoznačná identifikace pracovníka | MZNEZDPO_mz01id | C(6)
Mzdová položka | Jednoznačná identifikace mzdové položky | MZNEZDPO_mz28id | C(6)
Indiv. částka, půjčka,srážka | Kč/ j | MZNEZDPO_mz36kc_j | N(11,2)
Zůstatek | Zůstatek půjčky | MZNEZDPO_mz36zustat | N(11,2)
Od data | Datum zahájení platnosti položky | MZNEZDPO_mz36oddata | D
Do data | Datum ukončení platnosti položky | MZNEZDPO_mz36dodata | D
Adresát | Identifikace adresáta | MZNEZDPO_ad01id | C(6)
Účet | Identifikátor spojení na bankovní účet adresáta. | MZNEZDPO_ad03cisban | C(2)
KS | Konstantní symbol | MZNEZDPO_mz36ksymb | C(4)
VS | Variabilní symbol | MZNEZDPO_mz36vsymb | C(10)
Srážet | Kolik Kč se má z výplaty srážet | MZNEZDPO_mz36srazet | N(7)
Datum signalizace | Datum signalizace skončení platnosti měsíční nezdanitelné položky | MZNEZDPO_mz36signal | D
Pořadí srážky | Pořadí uplatnění srážky z karty ve výpočtu výplatního lístku | MZNEZDPO_mz36por_sr | C(3)
Pořadí půjčky | Pořadí uplatnění půjčky z karty ve výpočtu výplatního lístku | MZNEZDPO_mz36por_pu | C(3)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Zdravotní pojištění | Zdravotní pojištění | MZKARTA_mz01zdravp | N(1)
Popis | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Druh | Druh položky - příjem, náhrada mzdy,... | Výpočet | C(17)

    Viz.také

    Adresář | Bankovní spojení adresátů | Karta pracovníka | Osoby | Výběr položky


Osobní údaje k pracovníkům

Popis

Tato činnost poskytuje uživateli možnost zadání si libovolných osobních údajů k jednotlivým pracovníkům (např. dosažené vzdělání, řidičský průkaz apod.). Tato činnost zároveň představuje jednu ze záložek na kartě pracovníka.

Datový model

  • MZOSOBNI Osobní údaje ke kartě pracovníka

    • Formulář

    Formulář činnosti - Karta pracovníka
Mřížka [Osob. údaje]
Listovací rámeček
Stránka #1 Osobní údaje
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Typ údaje | Typ údaje - údaje o dětech, o invaliditě, o studiu
Volný text1 | Volný text1
Volný text2 | Volný text2
Volný text3 | Volný text3
Volný text4 | Volný text4
Volné datum1 | Volné datum1
Volné číslo1 | Volné číslo1
Platnost od | Platnost od
do | Platnost do
Komentář | Komentář
Stránka #2 Výběr
Pracovník | Jednoznačná identifikace pracovníka
Typ údaje | Typ údaje - údaje o dětech, o invaliditě, o studiu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Osob. údaje] činnosti - Karta pracovníka

    Mřížka [Osob. údaje] činnosti - Karta pracovníka
Pracovník | Jednoznačná identifikace pracovníka
Typ údaje | Typ údaje - údaje o dětech, o invaliditě, o studiu
Platnost od | Platnost od
do | Platnost do
Volný text1 | Volný text1
Volný text2 | Volný text2
Volný text3 | Volný text3
Volný text4 | Volný text4
Volné datum1 | Volné datum1
Volné číslo1 | Volné číslo1

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Karta pracovníka | Karta pracovníka

    Atributy tisku

    Základní údaje
Pracovník | Jednoznačná identifikace pracovníka | MZOSOBNI_mz01id | C(6)
Typ údaje | Typ údaje - údaje o dětech, o invaliditě, o studiu | Výpočet | C(12)
Volný text1 | Volný text1 | MZOSOBNI_mz80text1 | C(40)
Volný text2 | Volný text2 | MZOSOBNI_mz80text2 | C(40)
Volný text3 | Volný text3 | MZOSOBNI_mz80text3 | C(40)
Volný text4 | Volný text4 | MZOSOBNI_mz80text4 | C(40)
Platnost od | Platnost od | MZOSOBNI_mz80od | D
do | Platnost do | MZOSOBNI_mz80do | D
Komentář | Komentář | MZOSOBNI_mz80koment | M
Volné datum1 | Volné datum1 | MZOSOBNI_mz80datum1 | D
Volné číslo1 | Volné číslo1 | MZOSOBNI_mz80cislo1 | N(12,2)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)

    Viz.také

    Karta pracovníka


Pravidelné příjmy k prac.

Popis

Tato činnost umožňuje uživateli definovat, opravovat a rušit pravidelné příjmy pracovníka. Ty jsou dále k dispozici na kartě pracovníka na záložce pracovní poměr po stisku klávesy F5 nebo volbou příslušné činnosti z menu Volby.

U každého pravidelného příjmu se definuje:

¨ identifikace pracovníka – jméno, příjmení

¨ číslo pracovního poměru

¨ jednoznačná identifikace mzdové položky

¨ popis – přetáhne se současně s identifikací mzdové položky

¨ Kč/j – množství Kč za jednotku

¨ hodiny – způsob dopočtu hodin na výplatním lístku. Na výběr z překryvného seznamu jsou tyto možnosti:

- nevyplňovat – po přenosu pravidelných příjmů do výplatního lístku se atribut hodiny nevyplní. Na výplatní lístek se pak přenese přesně tolik Kč, kolik je zde vyplněno. Atribut hodiny na výplatním lístku bude 0.

- dopočíst do FPD dle hodin – hodiny na výplatním lístku se pak počítají jako hodiny FPD ve zpracovávaném měsíci mínus součet hodin mzdových položek s doplňujícím údajem („hodiny jsou součástí FPD – Ano“) mínus součet hodin nepřítomností mínus součet hodin neplaceného volna mínus součet hodin ve kterých pracovní poměr ve zpracovávaném měsíci netrval. Dny na výplatním lístku jsou pak výsledkem poměru hodin na výplatním lístku a pracovního úvazku (úvazek je součástí kalendáře pracovníka a tento je součástí pracovního poměru). Odečítané mzdové položky byly zadány do výplatního lístku ručně nebo pomocí úkolových lístků.

- součet odpracovaných dle hodin – hodiny se vypočte jako suma těch mzdových položek, které mají v doplňujících údajích zadáno „hodiny započítávat pro nárok na pohyblivou složku měsíční – Ano“. Použije se např. při pravidelné měsíční pohyblivé složce, jejíž výše je závislá na počtu odpracovaných hodin při výkonu určitých prací. Dny na výplatním lístku jsou pak výsledkem poměru hodin na výplatním lístku a pracovního úvazku (úvazek je součástí kalendáře pracovníka a tento je součástí pracovního poměru).

- dopočíst do FPD odděleně ve dnech a v hodinách – hodiny se zjistí s ohledem na FPD (stejný postup výpočtu jako u možnosti „dopočíst FPD dle hodin“). Dny se pak samostatně zjistí s ohledem na FPD (stejný postup výpočtu jako u možnosti „dopočíst FPD dle dnů“). Dny a hodiny pak tedy spolu vůbec nemusí korespondovat. Používá se hlavně v případech, kdy na výplatní lístek vstupují položky jako paragraf (nebo dovolená půl dne), které mají pak specifický způsob zápisu, např. 0dnů, 2,5 hodiny apod.

- součet odpracovaných odděleně ve dnech a v hodinách – stejný výpočet jako při možnosti „součet odpracovaných dle hodin“, ale hodiny a dny se počítají samostatně, nikoliv podle úvazku.

- dopočíst do FPD dle dnů – stejný výpočet jako při možnosti „dopočíst do FPD dle hodin“, ale výpočet se zajímá pouze o dny a hodiny se pak spočítají jako dny * úvazek.

¨ indiv. koef. – individuální koeficient, jímž se násobí mzda (je-li uvedena hodnota 0,00 použije se koeficient uvedený u mzdové položky)

¨ od data – do data – datum platnosti položky od - do

Datový model

  • MZMZDPPV Pravidelná mzdová položka
    • MZMZDPOL Mzdová položka

    • Formulář

    Formulář činnosti - Výběr mzdové položky
Mřížka [Pravidelné měs. příjmy]
Listovací rámeček
Stránka #1 Pravidelné příjmy
Pracovník | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Titul | Titul pracovníka (před jménem)
Číslo p.p. | Číslo pracovního poměru
Mzdová položka | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Kč / j | Kč / j
Hodiny | Způsob dopočtu hodin na výplatním lístku.
Indiv. koef. | Individuální koeficient, jímž se násobí Kč / j (je-li 0 použije se koeficient mzdové položky)
Od data | Datum zahájení platnosti položky
Do data | Datum ukončení platnosti položky
Stránka #2 Výběr
Pracovník | Jednoznačná identifikace pracovníka
Číslo p.p. | Číslo pracovního poměru
Výběr | Určení výběru
Od | Datum trvání pracovního poměru - od
do | Datum trvání pracovního poměru - do
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Pravidelné měs. příjmy] činnosti - Výběr mzdové položky

    Mřížka [Pravidelné měs. příjmy] činnosti - Výběr mzdové položky
Identifikace | Jednoznačná identifikace mzdové položky
Příjem | Popis mzdové položky
Pracovník | Jednoznačná identifikace pracovníka
Číslo p.p. | Číslo pracovního poměru
Hodiny | Způsob dopočtu hodin na výplatním lístku.
Kč / j | Kč / j

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Karta pracovníka | Karta pracovníka
F2 | Výběr mzdové položky | Lupa v činnosti Výplatní lístky na Identifikace mzdové položky
F2 | Výběr pracovního poměru | Výběr prac. poměru - k již zadanému pracovníkovi

    Atributy tisku

    Základní údaje
OSC | Jednoznačná identifikace pracovníka | MZMZDPPV_mz01id | C(6)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Číslo p.p. | Číslo pracovního poměru | MZMZDPPV_mz32cispp | C(2)
Mzdová položka | Jednoznačná identifikace mzdové položky | MZMZDPPV_mz28id | C(6)
Popis mzdové položky | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Kč / j | Kč / j | MZMZDPPV_mz35kc_j | N(9,2)
Hodiny | Způsob dopočtu hodin na výplatním lístku. | Výpočet | C(42)
Od data | Datum zahájení platnosti položky | MZMZDPPV_mz35oddata | D
Do data | Datum ukončení platnosti položky | MZMZDPPV_mz35dodata | D
Indiv. koef. | Individuální koeficient, jímž se násobí Kč / j (je-li 0 použije se koeficient mzdové položky) | MZMZDPPV_mz35koef | N(8,4)

    Viz.také

    Karta pracovníka | Výběr mzdové položky | Výběr pracovního poměru


Charakter pracovníka v prac. p

Popis

Nastavení této činnost souvisí s událostmi mezd a s činností druhy událostí. Slouží pro možnost výstupu mezd do okolního systému, např. do plateb (příkazy k úhradě) nebo do účetnictví. Údaje obsažené v této činnosti má uživatel zároveň k dispozici i na kartě pracovníka – záložka pracovní poměry – příslušná činnost pod menu Volby.

Datový model

  • MZCHARPP Charaktery pracovníka v prac. poměru

    • Formulář

    Formulář činnosti - Karta pracovníka
Mřížka [Charakter pracovníka v prac. poměru]
Listovací rámeček
Stránka #1 Charakter pracovníka v prac. poměru
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Číslo p.p. | Číslo pracovního poměru
Charakter | Charakter vlastnosti
Stránka #2 Výběr
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Číslo p.p. | Číslo pracovního poměru
Charakter | Charakter vlastnosti
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Charakter pracovníka v prac. poměru] činnosti - Karta pracovníka

    Mřížka [Charakter pracovníka v prac. poměru] činnosti - Karta pracovníka
Pracovník | Jednoznačná identifikace pracovníka
Číslo p.p. | Číslo pracovního poměru
Vlastnost | Charakter vlastnosti

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Charakter vlastnosti | Charakter vlastnosti - spolěčníci, zaměstnanci ,...
F2 | Karta pracovníka | Karta pracovníka
F2 | Výběr pracovního poměru | Výběr prac. poměru - k již zadanému pracovníkovi

    Atributy tisku

    Základní údaje
Pracovník | Jednoznačná identifikace pracovníka | MZCHARPP_mz01id | C(6)
Číslo p.p. | Číslo pracovního poměru | MZCHARPP_mz32cispp | C(2)
Charakter | Charakter vlastnosti | MZCHARPP_mz72id | C(20)

    Viz.také

    Charakter vlastnosti | Karta pracovníka | Výběr pracovního poměru


Dávky v nepřítomnostech

Popis

Činnost dávky v nepřítomnosti poskytuje uživateli přehled o vyplacených nemocenských dávkách podle vyfiltrovaných údajů na záložce Výběr. Vlastní definice dávky se provádí v činnosti nepřítomnost pro nemoc (menu Mzdy – Mzdy).

Na záložce „dávky“ jsou k dispozici údaje o jménu pracovníka a jeho pracovním poměru. K nemocenské dávce jsou zde informace o době trvání (od – do), délce trvání (počet hodin a z toho pracovních dnů) a o výši dávky a datu, kdy byla proplacena.

Záložka složení nemocenské dávky poskytuje přehled typů hodnot, z nichž je konkrétní dávka složena.

Datový model

  • MZNEMDAV Nemocenská dávka
    • MZKARTA Pracovník

    • Formulář

    Formulář činnosti - Karta pracovníka
Mřížka [Dávky]
Listovací rámeček
Stránka #1 Dávky
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
 | Rodné číslo
Prac. poměr | Číslo pracovního poměru
Číslo | Pořadové číslo nepřítomnosti / dávky pracovníka
Od | Datum, od kterého se poskytuje nemocenská dávka
do | Datum, do kterého se poskytuje nemocenská dávka
Dnů kal. | Kalendářní dny, za které se poskytuje nemocenská dávka
hod. kal. | Kalendářní hodiny, které se přičtou k uvedeným kal. dnům
z toho prac. | Pracovní dny, za které se poskytuje nemocenská dávka
hod.prac. | Pracovní hodiny, které se přičtou k uvedeným pracovním dnům
Nepřepoč. | Nepřepisovat kalendářní dny nově vypočtenou hodnotou
Nepřepoč. | Nepřepisovat pracovní dny nově vypočtenou hodnotou
 | Znaménko výpočtu dávky
Dávka Kč | Výše nemocenské dávky
Nepřepoč. | Nepřepisovat dávku nově vypočtenou hodnotou
Krátit o % | O uvedené procento se krátí nemocenská dávka.
Proplatit | Proplatit v nejbližším výplatním termínu?
Proplaceno dne | Datum, ve kterém byla nemocenská dávka vyplacena
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Složení nemocenské dávky
Mřížka [Složení nem. dávky]
Typ | Typ údaje
Hodnota | Hodnota údaje určitého typu
Ode dne | Platné od pořadového čísla dne
Počet dnů | Počet dnů dávky
Stránka #3 Výběr
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Prac. poměr | Číslo pracovního poměru
Číslo | Pořadové číslo nepřítomnosti / dávky pracovníka
Dávka od | Datum, od kterého se poskytuje nemocenská dávka
do | Datum, do kterého se poskytuje nemocenská dávka
Proplacení | Výběr dávky - vše, proplaceno, neproplaceno
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Dávky] činnosti - Karta pracovníka

    Mřížka [Dávky] činnosti - Karta pracovníka
Pracovník | Jednoznačná identifikace pracovníka
Číslo p.p. | Číslo pracovního poměru
Číslo | Pořadové číslo nepřítomnosti / dávky pracovníka
Od | Datum, od kterého se poskytuje nemocenská dávka
Do | Datum, do kterého se poskytuje nemocenská dávka
Dávka Kč | Výše nemocenské dávky
Pl. | Proplatit v nejbližším výplatním termínu?
Dne | Datum, ve kterém byla nemocenská dávka vyplacena
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Titul | Titul pracovníka (před jménem)

    Mřížka [Složení nem. dávky] činnosti - Karta pracovníka

    Mřížka [Složení nem. dávky] činnosti - Karta pracovníka
Typ | Typ údaje
Hodnota | Hodnota údaje určitého typu
Ode dne | Platné od pořadového čísla dne
Počet dnů | Počet dnů dávky

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Karta pracovníka | Karta pracovníka

    Atributy tisku

    Základní údaje
OSC | Jednoznačná identifikace pracovníka | MZNEMDAV_mz01id | C(6)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Číslo p.p. | Číslo pracovního poměru | MZNEMDAV_mz32cispp | C(2)
Pořadové číslo nemoci | Pořadové číslo nepřítomnosti / dávky pracovníka | MZNEMDAV_mz37cisnem | C(3)
Dávka od | Datum, od kterého se poskytuje nemocenská dávka | MZNEMDAV_mz38od | D
Dávka do | Datum, do kterého se poskytuje nemocenská dávka | MZNEMDAV_mz38do | D
Dnů kal. | Kalendářní dny, za které se poskytuje nemocenská dávka | MZNEMDAV_mz38dnu | N(8,4)
hod. kal. | Kalendářní hodiny, které se přičtou k uvedeným kal. dnům | MZNEMDAV_mz38hod | N(5,2)
z toho prac. | Pracovní dny, za které se poskytuje nemocenská dávka | MZNEMDAV_mz38dnupra | N(8,4)
hod.prac. | Pracovní hodiny, které se přičtou k uvedeným pracovním dnům | MZNEMDAV_mz38hodpra | N(5,2)
Znaménko | Znaménko výpočtu dávky | Výpočet | C(1)
Dávka Kč | Výše nemocenské dávky | MZNEMDAV_mz38davka | N(6)
Krátit o % | O uvedené procento se krátí nemocenská dávka. | MZNEMDAV_mz38kratit | N(6,2)
Proplatit | Proplatit v nejbližším výplatním termínu? | Výpočet | C(3)
Proplaceno dne | Datum, ve kterém byla nemocenská dávka vyplacena | MZNEMDAV_mz38propla | D
Ident. | Identifikace uživatele systému | MZNEMDAV_bw01uziv | C(6)
Datum a čas zápisu | Datum a čas zápisu záznamu události | MZNEMDAV_sp00datzap | T
Nepřepoč. | Nepřepisovat dávku nově vypočtenou hodnotou | Výpočet | C(3)
Identifikace období | Identifikace období platnosti parametrů | MZNEMDAV_mz77id | C(4)
Základ | Základ pro výpočet nemocenské dávky za kalendářní den | MZNEMDAV_mz38zaklad | N(5)
Nižší sazb. | Počet dnů nemoci proplacených sníženou sazbou | MZNEMDAV_mz38dnyns | N(8,4)
Vyšší sazb. | Počet dnů nemoci proplacených horní sazbou | MZNEMDAV_mz38dnyhs | N(8,4)
Nepřepoč. | Nepřepisovat kalendářní dny nově vypočtenou hodnotou | Výpočet | C(3)
Nepřepoč. | Nepřepisovat pracovní dny nově vypočtenou hodnotou | Výpočet | C(3)

    Při pohybu v Složení nemocenské dávky
Typ | Typ údaje | Výpočet | C(12)
Hodnota | Hodnota údaje určitého typu | MZNDSLOZ_mz15hodnot | N(10,4)
Ode dne | Platné od pořadového čísla dne | MZNDSLOZ_mz15odedne | N(3)
Počet dnů | Počet dnů dávky | MZNDSLOZ_mz15pocdnu | N(10,4)

    Viz.také

    Karta pracovníka


Jména pracovníků a PP a další

Popis

Tato činnost poskytuje uživateli základní informace o pracovníkovi. Na první záložce „pracovníci“ jsou k dispozici údaje o nacionálech pracovníka a identifikaci výplatního místa. Záložka „osobní údaje“ eviduje základní osobní údaje o pracovníkovi (rodné číslo, datum narození, státní občanství apod.). Záložka „pracovní údaje“ souvisí s výpočtem ročního zúčtování (údaje podepsal prohlášení, provést roční zúčtování apod.) a zároveň se zde eviduje zdravotní pojišťovna pracovníka. Na záložce „pracovní poměry“ jsou uvedeny veškeré pracovní poměry pracovníka a s nimi související informace (např. funkce, kalendář, třída apod.). Záložka „další informace“ eviduje údaje o pracovníkovi, které se týkají doby trvání pracovního poměru a jednotlivých nároků na dovolenou.

Datový model

  • MZKARTA Pracovník
    • SPPRISTU Přístupové právo uživatele k věci
    • MZVYPMIS Výplatní místo

    • Formulář

    Formulář činnosti - Karta pracovníka
Mřížka [pracovníci]
Listovací rámeček
Stránka #1 Pracovníci
OSC | Jednoznačná identifikace pracovníka
Ext.id. | Externí identifikace pracovníka
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Titul | Titul pracovníka (před jménem)
 | Titul pracovníka (za jménem)
Výpl. místo | Jednoznačná identifikace výplatního místa
Adresát | Identifikace adresáta
Adresa | Číslo adresy adresáta.
 | Název adresáta
 | Ulice adresy adresáta (včetně čísla popisného).
 | Poštovní směrovací číslo adresy adresáta.
 | Město adresy adresáta.
 | Název výplatního místa
Komentář | Komentář - poznámka
Stránka #2 Osobní údaje
Rodné číslo | Rodné číslo
Rodné příjmení | Rodné příjmení
Datum narození | Datum narození
Místo narození | Místo narození
Státní občanství | Státní občanství
Číslo OP | Číslo občanského průkazu
Stav | Stav - svobodný/á,ženatý,vdaná,vdovec,vdova,rozvedený/á
Počet dětí | Počet dětí
Žena/muž | Žena, muž
Těžce ZTP | Těžce ZTP - Ano,Ne
Další příjmení | Další příjmení - předcházející k současnému příjmení
Důchod typ | Typ důchodu
Od kdy | Datum přiznání důchodu, pracovník dovršil důchodový věk
Kč | Důchod - částka
Stránka #3 Prac. údaje
Zdravotní pojištění | Zdravotní pojištění
Podepsal prohlášení | Podepsal pracovník daňové prohlášení?
Lze srážet | Lze u pracovníka uplatnit srážkovou daň?
Provést roční zúčtování | Provést roční zúčtování ?
Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,...
 | Název adresáta
Stránka #4 Pracovní poměry
Mřížka [Prac. poměr]
Číslo p.p. | Číslo pracovního poměru
 | Druh pracovního poměru
Prac. funkce | Identifikace pracovní funkce (zařazení)
 | Popis pracovní funkce (pracovního zařazení)
Kalendář | Jednoznačná identifikace kalendáře
 | Název kalendáře
Stupnice | Identifikace tarifní stupnice
 | Popis tarifní stupnice
 | Tarifní třída (1-99)
Vznik p.p. | Vznik prac. poměru
Skončení p.p. | Skončení prac. poměru
 | Způsob odměňování - typ mzdy (měsíční, hodinová, ....)
Zk.lhůta | Datum ukončení zkušební lhůty
Selektory | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Alias | Název pracovníka v pracovním poměru (alias)
Určující | Jedná se o určující prac.pom. (při více prac.poměrech)?
Stránka #5 Další informace
Účast na n.p. | Zakládá pracovní poměr účast na nemocenském pojištění?
Vztah k pojistnému na soc. zabezp. | Vztah k pojistnému na sociální zabezpečení
Vznik p.p. | Vznik prac. poměru
Skončení p.p. | Skončení prac. poměru
Datum doručení výpovědi | Datum doručení výpovědi nebo datum uzavření dohody rozvázání pracovního poměru
Datum odvolání výpovědi | Datum odvolání výpovědi
Důvod ukončení p.p. | Důvod ukončení pracovního poměru
Roční nárok na dovolenou | Roční nárok na dovolenou.
Zůstatek staré dovolené | Zůstatek staré dovolené
Zůstatek nové dovolené | Zůstatek nové dovolené
Zůstatek dovolené z minulého roku | Zůstatek dovolené z minulého roku
Převod dovolené do příštího roku | Převod dovolené do příštího roku
Stránka #6 Výběr
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Výpl. místo | Jednoznačná identifikace výplatního místa
 | Název výplatního místa
Zobrazit pracovníky | Zobrazit pracovníky všechny, dosud pracující, již nepracující
Externí identifikace | Externí identifikace pracovníka
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [pracovníci] činnosti - Karta pracovníka

    Mřížka [pracovníci] činnosti - Karta pracovníka
Označování | Označení záznamu
OSC | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Datum narození | Datum narození
Rodné číslo | Rodné číslo
Žena/muž | Žena, muž
Stav | Stav - svobodný/á,ženatý,vdaná,vdovec,vdova,rozvedený/á
Typ důchodu | Typ důchodu
Datum přiznání | Datum přiznání důchodu, pracovník dovršil důchodový věk
Ext.id. | Externí identifikace pracovníka

    Mřížka [Prac. poměr] činnosti - Karta pracovníka

    Mřížka [Prac. poměr] činnosti - Karta pracovníka
Číslo p.p. | Číslo pracovního poměru
Druh | Druh pracovního poměru
Prac. funkce | Identifikace pracovní funkce (zařazení)

    Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
F2 | Adresy | Seznam adres za adresáta.
F2 | Adresář | Přehled adresátů
F2 | Karta pracovníka | Karta pracovníka
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Pracovní doba | Kalendáře a jim odpovídající měsíční fond pracovní doby.
F2 | Pracovní místa skut. a typová | Popis pracovní funkce (zařazení)
F2 | Tarifní stupnice | Mzdové tarifní stupnice a jim odpovídající tarifní třídy.
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Výběr pracovního poměru | Výběr prac. poměru - k již zadanému pracovníkovi
F2 | Výběr tar. třídy | Umožní zvolit nějakou existující tar. třídu
F2 | Výplatní místa | Místa, pro která se při výplatě dělají výčetky platidel.
F2 | Zdravotní a sociální pojišťovny | Seznam zdravotních pojišťoven

    Atributy tisku

    Základní údaje
Pracovník | Jednoznačná identifikace pracovníka | MZKARTA_mz01id | C(6)
Externí identifikace | Externí identifikace pracovníka | MZKARTA_mz01idext | C(20)
Adresát | Identifikace adresáta | MZKARTA_ad01id | C(6)
Adresa | Číslo adresy adresáta. | MZKARTA_ad02cisadr | C(2)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Zdravotní pojištění | Zdravotní pojištění | MZKARTA_mz01zdravp | N(1)
Podepsal prohlášení | Podepsal pracovník daňové prohlášení? | Výpočet | C(3)
Lze srážet | Lze u pracovníka uplatnit srážkovou daň? | Výpočet | C(3)
Identifikace | Jednoznačná identifikace výplatního místa | MZKARTA_mz22id | C(6)
Provést roční zúčtování | Provést roční zúčtování ? | Výpočet | C(3)
Komentář | Komentář - poznámka | MZKARTA_mz01koment | M
Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,... | MZKARTA_mz70idp | C(3)
Rodné příjmení | Rodné příjmení | MZKARTA_mz01rodne | C(15)
Rodné číslo | Rodné číslo | MZKARTA_mz01rodc | C(11)
Datum narození | Datum narození | MZKARTA_mz01naroz | D
Číslo OP | Číslo občanského průkazu | MZKARTA_mz01cislop | C(20)
Místo narození | Místo narození | MZKARTA_mz01misnar | C(40)
Stav | Stav - svobodný/á,ženatý,vdaná,vdovec,vdova,rozvedený/á | Výpočet | C(12)
Počet dětí | Počet dětí | MZKARTA_mz01deti | N(2)
Typ důchodu | Typ důchodu | MZKARTA_mz01duchty | N(1)
Datum přiznání | Datum přiznání důchodu, pracovník dovršil důchodový věk | MZKARTA_mz01duchda | D
Částka | Důchod - částka | MZKARTA_mz01duchkc | N(5)
Těžce ZTP | Těžce ZTP - Ano,Ne | Výpočet | C(3)
Název | Název výplatního místa | MZVYPMIS_mz22nazev | C(40)
Hod / den | Pracovní doba hodin / den | MZKALEN_mz25hodden | N(5,2)
Kalendář | Název kalendáře | MZKALEN_mz25kalen | C(40)

    Při pohybu v Pracovní poměry
Pracovník | Jednoznačná identifikace pracovníka | MZPRACPO_mz01id | C(6)
Číslo p.p. | Číslo pracovního poměru | MZPRACPO_mz32cispp | C(2)
Druh | Druh pracovního poměru | Výpočet | C(19)
Identifikace | Jednoznačná identifikace kalendáře | MZPRACPO_mz25id | C(6)
Identifikace | Identifikace tarifní stupnice | MZPRACPO_mz23id | C(6)
Třída | Tarifní třída (1-99) | MZPRACPO_mz24trida | C(2)
Identifikace | Identifikace pracovní funkce (zařazení) | MZPRACPO_mz31id | C(6)
Typové pracovní místo | Jednoznačná identifikace typové pracovní funkce (zařazení) | MZPRACPO_mz82id | C(6)
Org. sel. | Identifikátor organizačního selektoru. | MZPRACPO_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MZPRACPO_sp20idzak | C(9)
Účast na n.p. | Zakládá pracovní poměr účast na nemocenském pojištění? | Výpočet | C(3)
Denní vyměřovací základ | Denní vyměřovací základ nemocenského pojištění. | MZPRACPO_mz32npzakl | N(3)
Denní vyměřovací základ (neredukovaný) | Denní vyměřovací základ nemocenského pojištění neredukovaný. | MZPRACPO_mz32npzakd | N(9,2)
Skončení p.p. | Skončení prac. poměru | MZPRACPO_mz32skonpp | D
Důvod ukončení p.p. | Důvod ukončení pracovního poměru | MZPRACPO_mz32duvod | C(40)
Vznik p.p. | Vznik prac. poměru | MZPRACPO_mz32vznipp | D
Datum doručení výpovědi | Datum doručení výpovědi nebo datum uzavření dohody rozvázání pracovního poměru | MZPRACPO_mz32vypdor | D
Datum odvolání výpovědi | Datum odvolání výpovědi | MZPRACPO_mz32vypodv | D
Ano,Ne | Jedná se o určující prac.pom. (při více prac.poměrech)? | Výpočet | C(3)
Roční nárok na dovolenou | Roční nárok na dovolenou. | MZPRACPO_mz32dovnar | N(6,2)
Zůstatek staré dovolené | Zůstatek staré dovolené | MZPRACPO_mz32dovsta | N(6,2)
Zůstatek nové dovolené | Zůstatek nové dovolené | MZPRACPO_mz32dovnov | N(6,2)
Zůstatek dovolené z minulého roku | Zůstatek dovolené z minulého roku | MZPRACPO_mz32dovmin | N(6,2)
Převod dovolené do příštího roku | Převod dovolené do příštího roku | MZPRACPO_mz32dovpre | N(6,2)
Hodinový průměr | Hodinový průměr | MZPRACPO_mz32pruhod | N(9,2)
Denní průměr | Denní průměr | MZPRACPO_mz32pruden | N(9,2)
Měsíční průměr | Měsíční průměr | MZPRACPO_mz32prumes | N(9,2)
Zkušební lhůta | Datum ukončení zkušební lhůty | MZPRACPO_mz32zkuseb | D
Volné číslo I | Volně použitelné číslo | MZPRACPO_mz32cislo1 | N(20,4)
Volné číslo II | Volně použitelné číslo | MZPRACPO_mz32cislo2 | N(20,4)
Volné číslo III | Volně použitelné číslo | MZPRACPO_mz32cislo3 | N(20,4)

    Viz.také

    OZNAČOVÁNÍ | Adresy | Adresář | Karta pracovníka | Organizační selektor | Pracovní doba | Pracovní místa skut. a typová | Tarifní stupnice | Technicko-věcný selektor | Výběr pracovního poměru | Výběr tar. třídy | Výplatní místa | Zdravotní a sociální pojišťovny


Pojišťovny pracovníka

Popis

Tato činnost obsahuje přehled pojišťoven uvedených na kartách pracovníků (v podstatě supluje záložku zdravotní a sociální pojišťovny na kartě pracovníka) s tím rozdílem, že v této činnosti je možno si zobrazené údaje vyfiltrovat na záložce Výběr.

K dispozici jsou tyto informace:

¨ jméno pracovníka

¨ identifikace a název pojišťovny

¨ datum zahájení platnosti položky

¨ datum ukončení platnosti položky

Datový model

  • MZZDRPOJ Zdravotní pojišťovny a jejich přidělení
    • MZPOJSEZ Seznam zdravotních pojišťoven
      • ADADSAT Adresát
    • MZKARTA Pracovník

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Karta pracovníka | Karta pracovníka
F2 | Zdravotní a sociální pojišťovny | Seznam zdravotních pojišťoven

    Formulář

    Formulář činnosti - Karta pracovníka
Mřížka [Zdravotní pojišťovny]
Listovací rámeček
Stránka #1 Zdravotní a sociální pojišťovny
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Pojišťovna | Identifikace pojišťovny, např. 111, 121 ,...
 | Identifikace adresáta
 | Název adresáta
Datum zahájení platnosti položky | Datum zahájení platnosti položky
Datum ukončení platnosti položky | Datum ukončení platnosti položky
Stránka #2 Výběr
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Pojišťovna | Identifikace pojišťovny, např. 111, 121 ,...
Datum zahájení platnosti položky | Datum zahájení platnosti položky
Datum ukončení platnosti položky | Datum ukončení platnosti položky
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Zdravotní pojišťovny] činnosti - Karta pracovníka

    Mřížka [Zdravotní pojišťovny] činnosti - Karta pracovníka
Pojišťovna | Identifikace pojišťovny, např. 111, 121 ,...
Název | Název adresáta
Pracovník | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Titul | Titul pracovníka (před jménem)
Datum zahájení platnosti položky | Datum zahájení platnosti položky
Datum ukončení platnosti položky | Datum ukončení platnosti položky

    Atributy tisku

    Základní údaje
Pojišťovna | Identifikace pojišťovny, např. 111, 121 ,... | MZZDRPOJ_mz70idp | C(3)
Adresát | Identifikace adresáta | MZPOJSEZ_ad01id | C(6)
Adresa | Číslo adresy adresáta. | MZPOJSEZ_ad02cisadr | C(2)
Účet | Identifikátor spojení na bankovní účet adresáta. | MZPOJSEZ_ad03cisban | C(2)
Spojení | Číslo spojení adresáta. | MZPOJSEZ_ad11cisspo | C(2)
KS | Konstantní symbol | MZPOJSEZ_mz70ks | C(4)
VS | Variabilní symbol | MZPOJSEZ_mz70vs | C(10)
Typ pojišťovny | Typ pojišťovny | Výpočet | C(9)
OSC | Jednoznačná identifikace pracovníka | MZZDRPOJ_mz01id | C(6)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Datum zahájení platnosti položky | Datum zahájení platnosti položky | MZZDRPOJ_mz97oddata | D
Datum ukončení platnosti položky | Datum ukončení platnosti položky | MZZDRPOJ_mz97dodata | D
Číslo pojištěnce | Číslo pojištěnce ve zdravotní pojišťovně. Uvádějte pouze je-li různé od rodného čísla. | MZZDRPOJ_mz97ciszp | C(15)

    Viz.také

    Karta pracovníka | Zdravotní a sociální pojišťovny


Osoby

Popis

Tato činnost velmi úzce souvisí se záložkou „daňová zvýhodnění“ na Kartě pracovníka. Jednotlivá daňová zvýhodnění se vždy definují k určité osobě a právě tato činnost umožňuje definici přehledu daňově zvýhodňovaných osob. Uvádí se:

¨ jednoznačná identifikace

¨ jméno

¨ rodné číslo

¨ datum narození

¨ ZTP – zda se jedná o osobu se zdravotně-tělesným postižením – volba Ano/Ne

¨ další volné údaje – je možno je využít k libovolné evidenci nebo mohou zůstat tyto atributy i prázdné

Datový model

  • MZOSOBA Tabulka osob nějakým způsobem vázaných k pracovníkovi

    • Formulář

    Formulář činnosti - Karta pracovníka
Mřížka [Osoba]
Listovací rámeček
Stránka #1 Osoby
Identifikace | Identifikace osoby
Jméno | Jméno a příjmení osoby
Rodné číslo | Rodné číslo
Datum narození | Datum narození
ZTP | Je ZTP - Ano, Ne
Komentář | Komentář
Volný text1 | Volný text1
Volný text2 | Volný text2
Volný text3 | Volný text3
Volné číslo1 | Volné číslo1
Volné číslo2 | Volné číslo2
Volné číslo3 | Volné číslo3
Stránka #2 Výběr
Identifikace | Identifikace osoby
Jméno | Jméno a příjmení osoby
Rodné číslo | Rodné číslo
ZTP | Je ZTP - Ano, Ne
Pracovník | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Osoba] činnosti - Karta pracovníka

    Mřížka [Osoba] činnosti - Karta pracovníka
Identifikace | Identifikace osoby
Jméno | Jméno a příjmení osoby
Datum narození | Datum narození
Rodné číslo | Rodné číslo
ZTP | Je ZTP - Ano, Ne

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Karta pracovníka | Karta pracovníka

    Atributy tisku

    Základní údaje
Identifikace | Identifikace osoby | MZOSOBA_mz05id | C(6)
Jméno a příjmení | Jméno a příjmení osoby | MZOSOBA_mz05jmprij | C(40)
Datum narození | Datum narození | MZOSOBA_mz05datnar | D
Rodné číslo | Rodné číslo | MZOSOBA_mz05rodc | C(11)
ZTP | Je ZTP - Ano, Ne | Výpočet | C(3)
Komentář | Komentář | MZOSOBA_mz05koment | M
Volný text1 | Volný text1 | MZOSOBA_mz05text1 | C(40)
Volný text2 | Volný text2 | MZOSOBA_mz05text2 | C(40)
Volný text3 | Volný text3 | MZOSOBA_mz05text3 | C(40)
Volné číslo1 | Volné číslo1 | MZOSOBA_mz05cislo1 | N(12,2)
Volné číslo2 | Volné číslo2 | MZOSOBA_mz05cislo2 | N(12,2)
Volné číslo3 | Volné číslo3 | MZOSOBA_mz05cislo3 | N(12,2)

    Viz.také

    Karta pracovníka


Karta pracovníka - nápočty

Popis

Tato činnost sleduje výši hodnot uvedených u jednotlivých atributů v činnosti Další informace karty (menu Volby z Karty pracovníka).

Datový model

  • MZKARTA Pracovník

    • Formulář

    Formulář činnosti - Karta pracovníka
Mřížka [Karta pracovníka a nápočty]
Listovací rámeček
Stránka #1 Nápočty
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
ZP vyměř. základy nápočet | Nápočet dosavadních vyměřovacích základů ZP v aktuálním roce pro porovnání s maximálním vyměřovacím základem ZP.
SP vyměř. základy nápočet | Nápočet dosavadních vyměřovacích základů SP v aktuálním roce pro porovnání s maximálním vyměřovacím základem SP.
Penzij. a život. přip. nápočet | Nápočet dosavadních příspěvků penzij. a život. pojištění v aktuálním roce pro porovnání s limitem připojištění.
Stránka #2 Výběr
Pracovník | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Titul | Titul pracovníka (před jménem)
Uchovat | Příznak uchování výběrového hlediska
Výběr | Určení výběru

    Mřížka [Karta pracovníka a nápočty] činnosti - Karta pracovníka

    Mřížka [Karta pracovníka a nápočty] činnosti - Karta pracovníka
Pracovník | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
ZP vyměř. základy nápočet | Nápočet dosavadních vyměřovacích základů ZP v aktuálním roce pro porovnání s maximálním vyměřovacím základem ZP.
SP vyměř. základy nápočet | Nápočet dosavadních vyměřovacích základů SP v aktuálním roce pro porovnání s maximálním vyměřovacím základem SP.
Penzij. a život. připojištění nápočet | Nápočet dosavadních příspěvků penzij. a život. pojištění v aktuálním roce pro porovnání s limitem připojištění.

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Karta pracovníka | Karta pracovníka

    Atributy tisku

    Základní údaje
Pracovník | Jednoznačná identifikace pracovníka | MZKARTA_mz01id | C(6)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
ZP vyměř. základy nápočet | Nápočet dosavadních vyměřovacích základů ZP v aktuálním roce pro porovnání s maximálním vyměřovacím základem ZP. | MZKARTA_mz01zpnapo | N(20,2)
SP vyměř. základy nápočet | Nápočet dosavadních vyměřovacích základů SP v aktuálním roce pro porovnání s maximálním vyměřovacím základem SP. | MZKARTA_mz01spnapo | N(20,2)
Penzij. a život. připojištění nápočet | Nápočet dosavadních příspěvků penzij. a život. pojištění v aktuálním roce pro porovnání s limitem připojištění. | MZKARTA_mz01pznapo | N(20,2)

    Viz.také

    Karta pracovníka


TECHNICKÁ PŘÍPRAVA VÝROBY

Popis

Technická příprava výroby (TPV) zahrnuje komplexní definici způsobu výroby jednotlivých produktů (resp. variant produktů). V TPV se definují technologické postupy jako posloupnost technologických operací, mezi kterými lze definovat časový posun. K jednotlivým technologickým operacím se přiřazují vstupní a výstupní artikly v poměrech množství definovaném tabulkou vztahů. Současně se definuje časová norma a struktura pracovních výkonů.

Viz.také

Artikly výroby | Technologické postupy | TP k datu rozpracované na KJ | Technologické operace | Přehled referenčních artiklů | Druhy výrobních linek | Výrobní linky a stroje | Skladová úložiště | Parametry TPV | Třídy výrobního artiklu | Trasy | Šablony procesů | Kalkulační vzorce a proměnné | Tabulky vztahů artiklů | Tabulky pracovních výkonů


Artikly výroby

Popis

Činnost artikly výroby soustřeďuje všechny artikly, které vystupují jako vstupy a výstupy výroby. Mezi typické artikly patří materiál, polotovary, výrobky a pracovní výkony. U každého artiklu se definují tyto atributy:

¨ identifikace druhu artiklu

¨ identifikace artiklu – jednoznačné označení

¨ název artiklu

¨ pomocné číslo artiklu – nepovinný údaj

¨ M/O – rozlišení materiálu a odpadu (nejlépe ponechat předplněné hodnoty)

¨ MJ k.j. – definuje měrnou jednotku pro kalkulační jednici, tzn., že v přehledu technologických postupů k datu rozpracovaných na kalkulační jednici se množství artiklu přepočte právě na tuto měrnou jednotku

¨ N/V – rozlišení nákladu a výnosu (nejlépe ponechat předplněné hodnoty)

¨ MJ tab. – definuje měrnou jednotku pro tabulky vztahů artiklů výroby, tzn., že v přehledu tabulky vztahů artiklu se množství artiklu přepočte právě na tuto měrnou jednotku

¨ čas – volba Ano/Ne zda je množství artiklu na vstupu/výstupu úkolu odvozováno podle trvání úkolu

¨ kalkulační jednice – množství výrobku obsažené v jedné kalkulační jednici (podle ní se množství vstupů a výstupů přepočítává v přehledu technologických postupů k datu rozpracovaných na KJ). Ve většině případů se zde uvádí 1, hodnota různá od 1 se volí u artiklů, které se vyrábějí v řádovém množství tisíců

¨ kvalita – pomocí tohoto atributu lze definovat vztah mezi stejnými artikly různých kvalit (+ uvést vybraný artikl)

¨ rozp. mn. – rozpočítávat množství na vstupu – volba Ano/Ne. Tento atribut označuje materiál, jehož množství na realizovaných vstupech výrobních úkolů se rozpočítává podle skutečně spotřebovaného množství artiklu za období (rozpočítávání se provádí nad činností „přehled nerozpočteného“ v komponentě Výroba, kde se rozpočítávají vstupy dle období, linky, artiklu a výrobního čísla)

¨ úložiště – implicitní místo úložiště artiklu (úložiště ve většině případů korespondují se sklady)

¨ tech. sel. – technický selektor daného artiklu

¨ třída – identifikace třídy výrobního artiklu

¨ komentář k artiklu

Uživatel má v této činnosti údaje k artiklu k dispozici ještě na dalších záložkách. Jsou to:

¨ záložka Další – možnost evidence dalších potřebných údajů k artiklu výroby (mimo jiné se zde definuje i položka celního sazebníku k danému artiklu)

¨ záložka Technologické postupy – zde se evidují všechny TP potřebné k výrobě daného artiklu (např. budeme mít artikl stůl – pak TP zde uvedené budou výroba desky stolu, výroba nohou stolu a kompletace stolu)

¨ záložka Zaokrouhlování MJ – způsob zaokrouhlování (na jaké řády) měrných jednotek artiklu

¨ záložka Vztah MJ – definuje se vztah měrných artiklů (např. kolik daný artikl váží kg apod.)

¨ záložka Ceny – uvedené cenové skupiny, které se v souvislosti s artiklem používají

¨ záložka Stav skladu – množství artiklu na skladu, tj. hodnota v naturálním vyjádření za jednotlivé sklady

¨ záložka Názvy artiklu – umožňuje evidenci artiklu výroby ve zvolených jazycích

¨ záložka Kategorie – kategorie událostí správy artiklu

Pro uživatele jsou v této činnosti k dispozici také tyto funkční klávesy:

F5 – Technologické postupy

F6 – Přehled referenčních artiklů

F9 – Přehled vstupů a výstupů

Na základě zvolení Palety na záložce Výběr je možno přehled artiklů zvýraznit i barevně.

Datový model

  • TPVYROB Artikl výroby
    • SPARTIKL Artikl
    • SPARTIKN Název artiklu
    • SPMJ Měrná jednotka
      • SPMJN Měrná jednotka v jazyce
    • SPMJ Měrná jednotka (alias SPMJ4)
      • SPMJN Měrná jednotka v jazyce (alias SPMJN4)
    • SPSETV Technicko-věcný selektor
    • SPSKP SKP
    • SPARTIKD Druh artiklu
    • SPARTIKD Druh artiklu (alias SPARTIKD2)
    • TPVYROB Artikl výroby (alias TPVYROB2)
    • TPSKLADU Skladové úložiště TPV (alias TPSKLAD)
    • TPVYROBT Třída výrobního artiklu

    • Formulář

     | Formulář činnosti - Spojení
 | Mřížka [Artikl výroby]
 |  | Identifikace druhu artiklu
 | Artikl | Identifikace artiklu
 |  | Název artiklu
 | Listovací rámeček
 | Stránka #1 Artikly výroby
 | Číslo | Pomocné číslo artiklu výroby
 | MJ k. j. | Měrná jednotka kalkulační jednice
 |  | Název měrné jednotky
 | MJ tab. | Měrná jednotka tabulek vztahů artiklů výroby
 |  | Název měrné jednotky
 | M/O | Rozlišení materiálu a odpadu.
 | N/V | Artikl výroby představuje náklad (materiál, likvidace opadu) nebo výnos (prodej odpadu).
 | Čas | Množství artiklu na vstupu/výstupu úkolu je odvozováno podle trvání úkolu
 | Kalkulační jednice | Množství výrobku, obsažené v jedné kalkulační jednici
 | Kvalita | Kvalita I./II./III./IV.
 |  | Identifikace druhu artiklu
 | Výrobku | Identifikace artiklu
 | Rozp. mn. | Rozpočítávat množství na vstupu
 | Úložiště | Identifikace skladového úložiště
 |  | Název úložiště
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 |  | Název technicko-věcného selektoru.
 | Třída | Identifikace třídy výrobního artiklu
 |  | Název třídy výrobního artiklu
 | Komentář | Komentář, podrobně popisující artikl výroby
 | Stránka #2 Další
 | JKPOV | Identifikace třídy klasifikace průmyslových oborů a výrobců
 | Čárový kód | Čárový kód artiklu výroby
 | Třída SKP | Identifikace třídy Standardní klasifikace produkce.
 | Pozn. 1 | Poznámka
 | Pozn. 2 | Poznámka
 | Pozn. 3 | Poznámka
 | Pozn. 4 | Poznámka
 | Volné číslo I | Volně použitelné číslo
 | Volné číslo II | Volně použitelné číslo
 | Volné číslo III | Volně použitelné číslo
 | Stránka #3 Tech.postupy
 | Mřížka [Technologické postupy]
 | Tech. postup | Identifikace technologického postupu
 |  | Stručný popis, charakterizující technologický postup
 | Datum platnosti od | Datum platnosti definice technologického postupu od
 | do | Datum platnosti definice technologického postupu do
 | Šablona | Identifikace šablony procesu technologického postupu
 | Název šablony | Název šablony procesu technologického postupu
 | Komentář | Komentář, podrobně popisující technologický postup
 | Stránka #4 Zaokr.MJ
 | Mřížka [Zaokrouhlování MJ]
 | Měrná jednotka | Identifikátor měrné jednotky
 |  | Název měrné jednotky
 | Řád | Zaokrouhlení na řád
 | Stránka #5 Vztah MJ
 | Mřížka [Vztah MJ]
 | MJ | Identifikátor měrné jednotky
 | Název měrné jednotky | Název měrné jednotky
 | := | Vztah měrných jednotek
 | MJ | Identifikátor měrné jednotky
 | Název měrné jednotky | Název měrné jednotky
 | Stránka #6 Ceny
 | Mřížka [Ceny]
 | Skupina | Identifikace cenové skupiny
 |  | Název cenové skupiny
 | Období | Identifikace cenového období
 |  | Název cenového období
 |  | Datum platnosti od
 |  | Datum platnosti do
 | MJ | Identifikátor měrné jednotky
 |  | Název měrné jednotky
 | Měna | Kód měny - oceňovací jednotky.
 |  | Název měny
 | CJ - artikl | Cena ceníková za artikl za měrnou jednotku v oceňovací jednotce
 | CJ - ostatní nákl. | Cena ceníková ostatních nákladů za měrnou jednotku v oceňovací jednotce
 | CJ - celkem | Cena ceníková celkem za měrnou jednotku v oceňovací jednotce (služba + artikl)
 | Sleva % | Sleva uvedená v procentech
 | Stránka #7 Názvy artiklu
 | Mřížka [Názvy artiklu v jazycích]
 | Jazyk | Identifikace jazyka
 | Název artiklu | Název artiklu
 | Stránka #8 Kategorie
 | Mřížka [Kategorie artiklu]
 |  | Kategorie
Identifikace kategorie události správy artiklu |  |  | Platnost
Datum platnosti od |  |  | Platnost do
Datum platnosti do |  |  | Adresát
Identifikace adresáta |  |
Název adresáta |  |
Číslo spojení adresáta. |  |  | Popis
Popis události |  |  | Poznámka
Poznámka |  |  | Zapsal
Jméno uživatele systému |  |  | Datum a čas zápisu
Datum a čas zápisu záznamu události
 | Stránka #9 Výběr
 |  | Identifikace druhu artiklu
 | Artikl | Identifikace artiklu
 | Název artiklu | Název artiklu
 | MJ | Identifikátor měrné jednotky
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 | M/O | Rozlišení materiálu a odpadu.
 | N/V | Artikl výroby představuje náklad (materiál, likvidace opadu) nebo výnos (prodej odpadu).
 | Kvalita | Kvalita I./II./III./IV.
 | Úložiště | Identifikace skladového úložiště
 | Vybrat | Vyráběné artikly, nevyráběné artikly, všechny artikly
 | Vztah ke kategorii | Vztah ke kategorii - Je=K dnešnímu datu je v kategorii, Není=K dnešnímu datu není v kategorii, Byl=Není v kategorii, ale byl, Nebyl=Není a nikdy nebyl v kategorii,Bude=Bude v kategorii
 | Kategorie | Identifikace kategorie události správy artiklu
 | Název kategorie | Název kategorie události správy artiklu
 | Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 |  | Platnost nebo neplatnost k datu
 | Paleta | Vybrat záznamy všech kategorií v paletě
 |  | Identifikace palety barev
 | Výběr | Určení výběru
 | Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Artikl výroby] činnosti - Spojení

    Mřížka [Artikl výroby] činnosti - Spojení
Označování | Označení záznamu
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Číslo | Pomocné číslo artiklu výroby

    Mřížka [Technologické postupy] činnosti - Spojení

    Mřížka [Technologické postupy] činnosti - Spojení
Tech. postup | Identifikace technologického postupu
Popis tech. postupu | Stručný popis, charakterizující technologický postup
Datum platnosti od | Datum platnosti definice technologického postupu od
Datum platnosti do | Datum platnosti definice technologického postupu do
Platný | Technologický postup je platný, resp. neplatný

    Mřížka [Zaokrouhlování MJ] činnosti - Spojení

    Mřížka [Zaokrouhlování MJ] činnosti - Spojení
Měrná jednotka | Identifikátor měrné jednotky
Název měrné jednotky | Název měrné jednotky
Řád | Zaokrouhlení na řád

    Mřížka [Vztah MJ] činnosti - Spojení

    Mřížka [Vztah MJ] činnosti - Spojení
MJ | Identifikátor měrné jednotky
Název měrné jednotky | Název měrné jednotky
:= | Vztah měrných jednotek
MJ | Identifikátor měrné jednotky
Název měrné jednotky | Název měrné jednotky

    Mřížka [Ceny] činnosti - Spojení

    Mřížka [Ceny] činnosti - Spojení
Skupina | Identifikace cenové skupiny
Období | Identifikace cenového období
MJ | Identifikátor měrné jednotky
Měna | Kód měny - oceňovací jednotky.
CJ - celkem | Cena ceníková celkem za měrnou jednotku v oceňovací jednotce (služba + artikl)
CJ - artikl | Cena ceníková za artikl za měrnou jednotku v oceňovací jednotce
CJ - ostatní nákl. | Cena ceníková ostatních nákladů za měrnou jednotku v oceňovací jednotce
Datum platnosti od | Datum platnosti od

    Mřížka [Názvy artiklu v jazycích] činnosti - Spojení

    Mřížka [Názvy artiklu v jazycích] činnosti - Spojení
Jazyk | Identifikace jazyka
Název artiklu | Název artiklu

    Mřížka [Kategorie artiklu] činnosti - Spojení

    Mřížka [Kategorie artiklu] činnosti - Spojení
Kategorie | Identifikace kategorie události správy artiklu
Název kategorie | Název kategorie události správy artiklu
Platnost od | Datum platnosti od
Platnost do | Datum platnosti do
Adresát | Identifikace adresáta
Název adresáta | Název adresáta

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Technologické postupy | Definice technologických postupů výroby
F6 | Přehled referenčních artiklů | Přehled referenčních artiklů
F7 | Diagram technolog.postupu | Diagram technologického postupu
F9 | Přehled vstupů a výstupů | Přehled vstupů potřebných pro výrobu artiklu
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
- | Dokumenty artiklu | Dokumenty artiklu
- | Události správy artiklu |
- | Legenda palety barev |
F2 | Adresář | Přehled adresátů
F2 | Artikly výroby | Vstup artiklů výroby
F2 | Cenová období | Výběr cenového období
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy procesů | Přehled druhů procesů
F2 | Kategorie událostí správy artiklu | Přehled kategorií událostí správy artiklu
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Měrné jednotky | Číselník měrných jednotek
F2 | Palety barev kategorií | Palety barev kategorií
F2 | Skladová úložiště | Skladová úložiště
F2 | Spojení | Seznam spojení za adresáta.
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Třídy SKP | Třídy Standardní klasifikace produkce
F2 | Třídy výrobního artiklu | Seznam tříd výrobního artiklu

    Atributy tisku

    Základní údaje
Artikl | Identifikace artiklu | TPVYROB_sp60id | C(13)
Druh artiklu | Identifikace druhu artiklu | TPVYROB_sp61id | C(3)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Komentář | Komentář, podrobně popisující artikl výroby | TPVYROB_tp01koment | M
Číslo | Pomocné číslo artiklu výroby | TPVYROB_tp01cis | C(20)
MJ | Identifikátor měrné jednotky | TPVYROB_sp24idmj | C(3)
Kalkulační jednice | Množství výrobku, obsažené v jedné kalkulační jednici | TPVYROB_tp01kj | N(8,2)
Pozn. 1 | Poznámka | TPVYROB_tp01pozn1 | C(20)
Pozn. 2 | Poznámka | TPVYROB_tp01pozn2 | C(20)
Pozn. 3 | Poznámka | TPVYROB_tp01pozn3 | C(20)
Pozn. 4 | Poznámka | TPVYROB_tp01pozn4 | C(20)
Volné číslo I | Volně použitelné číslo | TPVYROB_tp01cislo1 | N(20,4)
Volné číslo II | Volně použitelné číslo | TPVYROB_tp01cislo2 | N(20,4)
Volné číslo III | Volně použitelné číslo | TPVYROB_tp01cislo3 | N(20,4)
Tech. sel. | Identifikátor technicko-věcného selektoru. | TPVYROB_sp20idzak | C(9)
Třída | Identifikace třídy výrobního artiklu | TPVYROB_tp21id | C(3)
Název třídy | Název třídy výrobního artiklu | TPVYROBT_tp21naztri | C(40)
JKPOV | Identifikace třídy klasifikace průmyslových oborů a výrobců | TPVYROB_tp01jkpov | C(13)
Čárový kód | Čárový kód artiklu výroby | TPVYROB_tp01carkod | C(36)
Třída SKP | Identifikace třídy Standardní klasifikace produkce. | TPVYROB_sp17idskp | C(8)
Název třídy Standardní klasifikace produkce | Název kategorie Standardní klasifikace produkce. | SPSKP_sp17text | C(70)
M/O | Rozlišení materiálu a odpadu. | Výpočet | C(8)
N/V | Artikl výroby představuje náklad (materiál, likvidace opadu) nebo výnos (prodej odpadu). | Výpočet | C(6)
Čas | Množství artiklu na vstupu/výstupu úkolu je odvozováno podle trvání úkolu | Výpočet | C(3)
Kvalita | Kvalita I./II./III./IV. | Výpočet | C(4)
Druh výrobku I. kvality | Identifikace druhu artiklu | TPVYROB_sp61id2 | C(3)
Výrobek I. kvality | Identifikace artiklu | TPVYROB_sp60id2 | C(13)
Rozp. mn. | Rozpočítávat množství na vstupu | Výpočet | C(3)
Tech. postup | Identifikace technologického postupu | TPTECHPO_tp03id | C(13)
Popis tech. postupu | Stručný popis, charakterizující technologický postup | TPTECHPO_tp03techpo | C(40)
Komentář | Komentář, podrobně popisující technologický postup | TPTECHPO_tp03koment | M
Datum platnosti od | Datum platnosti definice technologického postupu od | TPTECHPO_tp03datod | D
Datum platnosti do | Datum platnosti definice technologického postupu do | TPTECHPO_tp03datdo | D
Platný | Technologický postup je platný, resp. neplatný | Výpočet | C(3)
Šablona | Identifikace šablony procesu technologického postupu | TPTECHPO_tp25id | C(6)
Název šablony | Název šablony procesu technologického postupu | TPSABPRC_tp25nazsab | C(40)

    Při pohybu v Názvy artiklu v jazycích
Jazyk | Identifikace jazyka | SPARTIKN2_sp38id | C(3)
Název artiklu | Název artiklu | SPARTIKN2_sp62artikl | C(60)

    Při pohybu v Vztah měrných jednotek
MJ | Identifikátor měrné jednotky | SPMJP_sp24idmj | C(3)
Měrná jednotka | Identifikátor měrné jednotky | SPMJP_sp24idmj2 | C(3)
Vztah | Vztah měrných jednotek | SPMJP_sp59podil | N(20,10)

    Viz.také

    Technologické postupy | Přehled referenčních artiklů | Diagram technolog.postupu | Přehled vstupů a výstupů | OZNAČOVÁNÍ | Prezentace artiklu | Dokumenty artiklu | Události správy artiklu | Legenda palety barev | Adresář | Cenová období | Druhy artiklů | Druhy procesů | Kategorie událostí správy artiklu | Měny a kursy | Měrné jednotky | Palety barev kategorií | Skladová úložiště | Spojení | Technicko-věcný selektor | Třídy SKP | Třídy výrobního artiklu


Technologické postupy

Popis

Tato činnost poskytuje uživateli přehled nadefinovaných technologických postupů. Technologický postup je přesné vyjádření posloupností úkonů (tj. jednotlivých operací) nutných k finalizaci výstupu technologického postupu. U každého technologického postupu se definuje:

¨ identifikace a název – identifikace je ve většině případů odvozena od skupiny artiklů, které jsou pro tento postup pilotním artiklem

¨ datum platnosti od – do – určení platnosti technologického postupu. Toto datum platnosti se uplatňuje ve výběru technologického postupu při generování v činnosti „TP k datu rozpracované na KJ“.

¨ platný – volba platnosti TP (Ano/Ne)

¨ pilotní – zda se jedná o pilotní TP pro určení ceny vstupu/výstupu podle TP k datu (při volbě Ano v podstatě určuje TP pro určení ceny výrobku v případě, že se výrobek vyskytuje jako pilotní artikl ve více technologických postupech)

¨ šablona – identifikace šablony procesu TP (definuje druh procesu, který vznikne a napojí se na proces výrobní zakázky v případě, že podobný druh procesu již v diagramu procesu výrobní zakázky není)

¨ komentář – libovolný popis

Jednotlivé záložky této činnosti poskytují uživateli následující informace:

¨ záložka Technologické operace – přehled technol. operací daného technol. postupu – přehled jednotlivých operací se naplní automaticky vytvořením Diagramu technologického postupu. Jedna (obvykle výstupní) technologická operace se určuje jako pilotní.

¨ záložka Pilotní artikly postupu – jedná se o artikly, které jsou nadefinovány jako referenční u pilotní technologické operace

Uživatel má pod menu Volby k dispozici tyto funkční klávesy:

¨ F5 – Kopie technologického postupu – definuje se identifikace a název nového technologického postupu

¨ F7 – Diagram technologického postupu – obvyklý způsob práce jako s diagramem procesu (pouze s tím rozdílem, že uzly mezi kterými uživatel definuje vazby nejsou druhy operací, ale jednotlivé nadefinované technologické operace)

¨ F9 – Příprava rozpracování TP – definuje se datum platnosti technologického postupu od a možnost určení zpracování TP pouze pro jeden určený konkrétní výrobek. Po stisku klávesy F9 „Rozpracovat TP k datu“ proběhne výpočet, jehož výsledky se ukládají v činnosti „TP k datu rozpracované na KJ“, kde jsou vidět detailně vstupy a výstupy daného technologického postupu.

Datový model

  • TPTECHPO Technologický postup
    • TPSABPRC Šablona procesu technologického postupu

    • Formulář

    Formulář činnosti - Kopie tech.postupu
Mřížka [Technologické postupy]
Tech. postup | Identifikace technologického postupu
 | Stručný popis, charakterizující technologický postup
Listovací rámeček
Stránka #1 Technologické postupy
Datum platnosti od | Datum platnosti definice technologického postupu od
do | Datum platnosti definice technologického postupu do
Platný | Technologický postup je platný, resp. neplatný
Pilotní | Pilotní pro určení ceny vstupu/výstupu podle TP k datu
Šablona | Identifikace šablony procesu technologického postupu
Název šablony | Název šablony procesu technologického postupu
Komentář | Komentář, podrobně popisující technologický postup
Stránka #2 Technologické operace
Mřížka [Technologické operace]
ID | Identifikace technologického postupu/operace
Popis | Stručný popis, charakterizující technologický postup/operaci
Pilot | Pilotní uzel v diagramu technologického postupu
Stránka #3 Pilotní artikly postupu
Mřížka [Artikly postupu]
 | Identifikace druhu artiklu
Artikl výroby | Identifikace artiklu
 | Název artiklu
Stránka #4 Výběr
Tech. postup | Identifikace technologického postupu
 | Stručný popis, charakterizující technologický postup
Druh artiklu | Identifikace druhu artiklu
Artikl výroby | Identifikace artiklu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Technologické postupy] činnosti - Kopie tech.postupu

    Mřížka [Technologické postupy] činnosti - Kopie tech.postupu
Označování | Označení záznamu
Tech. postup | Identifikace technologického postupu
Popis tech. postupu | Stručný popis, charakterizující technologický postup
Datum platnosti od | Datum platnosti definice technologického postupu od
Datum platnosti do | Datum platnosti definice technologického postupu do
Platný | Technologický postup je platný, resp. neplatný

    Mřížka [Technologické operace] činnosti - Kopie tech.postupu

    Mřížka [Technologické operace] činnosti - Kopie tech.postupu
Postup/Operace | Identifikace technologického postupu/operace
Popis | Stručný popis, charakterizující technologický postup/operaci

    Mřížka [Artikly postupu] činnosti - Kopie tech.postupu

    Mřížka [Artikly postupu] činnosti - Kopie tech.postupu
Druh | Identifikace druhu artiklu
Artikl výroby | Identifikace artiklu
Název artiklu | Název artiklu

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Kopie tech.postupu | Kopie technologického postupu
F7 | Diagram technolog.postupu | Diagram technologického postupu
F9 | Příprava rozpracování TP | Příprava rozpracování TP k datu
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Diagram šablony | Diagram šablony
F2 | Artikly výroby | Vstup artiklů výroby
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy operací | Přehled druhů operací
F2 | Přehled referenčních artiklů | Přehled referenčních artiklů
F2 | Šablony procesů | Šablony procesů

    Atributy tisku

    Základní údaje
Tech. postup | Identifikace technologického postupu | TPTECHPO_tp03id | C(13)
Popis tech. postupu | Stručný popis, charakterizující technologický postup | TPTECHPO_tp03techpo | C(40)
Komentář | Komentář, podrobně popisující technologický postup | TPTECHPO_tp03koment | M
Datum platnosti od | Datum platnosti definice technologického postupu od | TPTECHPO_tp03datod | D
Datum platnosti do | Datum platnosti definice technologického postupu do | TPTECHPO_tp03datdo | D
Platný | Technologický postup je platný, resp. neplatný | Výpočet | C(3)
Pilotní | Pilotní pro určení ceny vstupu/výstupu podle TP k datu | Výpočet | C(3)
Šablona | Identifikace šablony procesu technologického postupu | TPTECHPO_tp25id | C(6)
Název šablony | Název šablony procesu technologického postupu | TPSABPRC_tp25nazsab | C(40)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)

    Při pohybu v Artikly technologického postupu
Artikl výroby | Identifikace artiklu | TPTECHAX_sp60id | C(13)
Druh artiklu | Identifikace druhu artiklu | TPTECHAX_sp61id | C(3)

    Viz.také

    Kopie tech.postupu | Diagram technolog.postupu | Příprava rozpracování TP | OZNAČOVÁNÍ | Diagram šablony | Artikly výroby | Druhy artiklů | Druhy operací | Přehled referenčních artiklů | Šablony procesů


TP k datu rozpracované na KJ

Popis

Tato činnost poskytuje uživateli přehled všech vygenerovaných technologických postupů k datu (zobrazené údaje jsou závislé na filtru nastaveném na záložce Výběr – technologický postup/datum platnosti od – do/artikl/paleta). Tento přehled se generuje z technologických postupů pro každý pilotní artikl technologického pokusu a každé „TP k datu“ má své datum platnosti.

Přehled TP k datu zobrazuje všechny (i v současnosti neplatné) „TP k datu“. Tento přehled se naplňuje aktivací z činnosti Technologické postupy. V činnosti Technologické postupy je pod menu Volby dostupná činnost „Příprava rozpracování TP“ (funkční klávesa F9). Zobrazí se nejdříve záložka Výběr, kde si uživatel nadefinuje, který TP (případně jen konkrétní pilotní artikl) s datem platnosti OD chce vygenerovat. Po potvrzení Výběru uživatel aktivuje činnost „Rozpracovat TP k datu“ (menu Volby nebo funkční klávesa F9). Tato činnost vygeneruje nové „TP k datu“, které pak má uživatel k dispozici v tomto přehledu.

Pokud v případě generování nového „TP k datu“ systém zjistí chyby, uživateli se zobrazí protokol generování úkolů zakázky, kde jsou jednotlivé chyby popsány (např. nebyl nalezen vztah artiklů, není známá cena pro artikl apod.).

Na záložce „Vstupy a výstupy“ je přehled všech vstupů a výstupů (jak materiálových, tak i pracovních) ze všech operací technologického postupu, které je nutno vykonat pro vyrobení pilotního artiklu daného technologického postupu. Všechny údaje (množství, ocenění) na této záložce jsou přepočteny na kalkulační jednici pilotního artiklu technologického postupu (podle nastavení v parametrech TPV).

Datový model

  • TPTECVV Technologický postup k datu rozpracovaný na KJ pilotního artiklu
    • TPTECHPO Technologický postup
    • TPVYROB Artikl výroby
      • SPARTIKN Název artiklu
    • BWUZIVAT Uživatel systému

    • Formulář

    Formulář činnosti - Legenda palety barev
Mřížka [TP k datu]
Listovací rámeček
Stránka #1 TP k datu
Postup | Identifikace technologického postupu
Popis tech. postupu | Stručný popis, charakterizující technologický postup
Platnost od | Datum platnosti od
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Kalkulační jednice | Množství výrobku, obsažené v jedné kalkulační jednici
MJ | Identifikátor měrné jednotky
Cena | Cena pilotního artiklu
Aktualizace | Datum poslední aktualizace
Provedl | Úplné jméno uživatele systému
Stránka #2 Vstupy a výstupy
Mřížka [Vstupy a výstupy]
Postup | Identifikace technologického postupu
 | Stručný popis, charakterizující technologický postup
Platnost od | Datum platnosti od
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Operace | Identifikace technologické operace
 | Varianta technologické operace
 | Stručný popis, charakterizující technologickou operaci
 | Název kalkulačního vzorce / název proměnné kalkulačního vzorce
 | Vstup / Výstup
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Dr.linky | Identifikace druhu výrobní linky
 | Název druhu výrobní linky
Dr.stroje | Identifikace druhu stroje
 | Název druhu stroje
 | Zdroj pro stanovení ceny
Množství | Množství
MJ | Identifikátor měrné jednotky
Cena za j. | Cena za jednotku materiálu / práce
Cena za j. | Cena za jednotku materiálu / práce - druhá část
Cena | Celková cena
Stránka #3 Výběr
Tech. postup | Identifikace technologického postupu
Popis tech. postupu | Stručný popis, charakterizující technologický postup
Platnost od | Datum platnosti od
do | Datum platnosti do
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Paleta | Vybrat záznamy všech kategorií v paletě
 | Identifikace palety barev
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [TP k datu] činnosti - Legenda palety barev

    Mřížka [TP k datu] činnosti - Legenda palety barev
Označování | Označení záznamu
Postup | Identifikace technologického postupu
Popis tech. postupu | Stručný popis, charakterizující technologický postup
Platnost od | Datum platnosti od
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Kalkulační jednice | Množství výrobku, obsažené v jedné kalkulační jednici
MJ | Identifikátor měrné jednotky
Cena | Cena pilotního artiklu
Aktualizace | Datum poslední aktualizace
Provedl | Úplné jméno uživatele systému

    Mřížka [Vstupy a výstupy] činnosti - Legenda palety barev

    Mřížka [Vstupy a výstupy] činnosti - Legenda palety barev
Poř. | Pořadí
Operace | Identifikace technologické operace
V/V | Vstup / Výstup
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Množství | Množství
MJ | Identifikátor měrné jednotky
Cena | Celková cena
Cena za j. | Cena za jednotku materiálu / práce
Cena za j. | Cena za jednotku materiálu / práce - druhá část
Název KV | Název kalkulačního vzorce / název proměnné kalkulačního vzorce
Název operace | Stručný popis, charakterizující technologickou operaci
Druh linky | Identifikace druhu výrobní linky
Název linky | Název druhu výrobní linky
Dr.stroje | Identifikace druhu stroje
Název druhu stroje | Název druhu stroje
Zdroj ceny | Zdroj pro stanovení ceny

    Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Události správy artiklu |
F7 | Diagram technolog.postupu | Diagram technologického postupu
F9 | Příprava rozpracování TP | Příprava rozpracování TP k datu
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Legenda palety barev |
F2 | Artikly výroby | Vstup artiklů výroby
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Palety barev kategorií | Palety barev kategorií
F2 | Technologické postupy | Definice technologických postupů výroby

    Atributy tisku

    Základní údaje
Tech. postup | Identifikace technologického postupu | TPTECVV_tp03id | C(13)
Popis tech. postupu | Stručný popis, charakterizující technologický postup | TPTECHPO_tp03techpo | C(40)
Platnost od | Datum platnosti od | TPTECVV_tp32datum | D
Druh artiklu | Identifikace druhu artiklu | TPTECVV_sp61id | C(3)
Artikl | Identifikace artiklu | TPTECVV_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Kalkulační jednice | Množství výrobku, obsažené v jedné kalkulační jednici | TPTECVV_tp01kj | N(8,2)
MJ | Identifikátor měrné jednotky | TPTECVV_sp24idmj | C(3)
Cena | Cena pilotního artiklu | TPTECVV_tp32cena | N(20,6)
Aktualizace | Datum poslední aktualizace | TPTECVV_tp32datakt | T
Provedl | Úplné jméno uživatele systému | BWUZIVAT_bw01jmenot | C(25)
Název operace | Stručný popis, charakterizující technologickou operaci | TPOPERAC_tp05operac | C(40)
Druh linky | Identifikace druhu výrobní linky | TPOPERAC_tp12id | C(6)
Název linky | Název druhu výrobní linky | TPLINKAD_tp12linka | C(40)
Název druhu stroje | Název druhu stroje | TPLINKAD2_tp12linka | C(40)
Název KV | Název kalkulačního vzorce / název proměnné kalkulačního vzorce | TPKALK_tp27nazrol | C(40)
Název artiklu | Název artiklu | SPARTIKN2_sp62artikl | C(60)

    Při pohybu v Vstupy a výstupy
Operace | Identifikace technologické operace | TPTECVVP_tp05id | C(13)
Varianta | Varianta technologické operace | TPTECVVP_tp02varian | C(6)
Dr.stroje | Identifikace druhu stroje | TPTECVVP_tp12id | C(6)
KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce | TPTECVVP_tp27id | C(3)
V/V | Vstup / Výstup | Výpočet | C(6)
Druh artiklu | Identifikace druhu artiklu | TPTECVVP_sp61id | C(3)
Artikl | Identifikace artiklu | TPTECVVP_sp60id | C(13)
Zdroj ceny | Zdroj pro stanovení ceny | TPTECVVP_tp33zdroj | C(30)
Množství | Množství | TPTECVVP_tp33mn | N(20,6)
MJ | Identifikátor měrné jednotky | TPTECVVP_sp24idmj | C(3)
Cena za j. | Cena za jednotku materiálu / práce | TPTECVVP_tp33cj | N(20,6)
Cena za j. | Cena za jednotku materiálu / práce - druhá část | TPTECVVP_tp33cj2 | N(20,6)
Cena | Celková cena | TPTECVVP_tp33cena | N(20,6)

    Viz.také

    Události správy artiklu | Diagram technolog.postupu | Příprava rozpracování TP | OZNAČOVÁNÍ | Legenda palety barev | Artikly výroby | Druhy artiklů | Palety barev kategorií | Technologické postupy


Technologické operace

Popis

Činnost technologické operace a činnost artikly výroby jsou základním podkladem pro definici technologických postupů. Aby je bylo možno co nejefektivněji nadefinovat, je nutno správně zadat technologické operace, kde každá jedna operace představuje činnost ve výrobním postupu pro finalizaci výrobku (polotovaru) nebo skupiny výrobků. Různé technologické postupy pak mohou obsahovat stejné technologické operace. U každé operace se definuje:

¨ identifikace a název operace

¨ tabulka – identifikace tabulky vztahů artiklů. Tabulka přiřazená technologické operaci definuje vztahy mezi artikly, které jsou vstupem a výstupem technologické operace.

¨ druh linky – druh výrobní linky přiřazený technologické operaci – definuje, na jakém místě (lince) ve výrobě se bude operace provádět

¨ barva – zvolení barvy jakou se bude daná technologická operace zobrazovat v harmonogramu výroby

¨ technický selektor

¨ vstupy a výstupy – identifikace druhu operace ve kterém se definují algoritmy pro plnění aktuálních či statistických hodnot z událostí vstupů a výstupů

¨ zobrazení – zobrazení v diagramu technol. postupu – slouží k výběru operací při jeho tvorbě

Pro uživatele jsou k dispozici tyto funkční klávesy:

¨ F5 – Kopie operace

¨ F7 – Přehled referenčních artiklů

¨ F9 – Vytvořit jednokrokový TP – z dané operace se vytvoří technologický postup složený z dané operace

Datový model

  • TPOPERAC Technologická operace
    • SPTYP Druh procesu/operace (alias SPTYP2)
    • TPLINKAD Druh výrobní linky/stroje
    • TPTAB Tabulka vztahů artiklů výroby
    • SPSETV Technicko-věcný selektor

    • Formulář

    Formulář činnosti - Barvy RGB
Mřížka [Technologické operace]
Listovací rámeček
Stránka #1 Technologické operace
Operace | Identifikace technologické operace
 | Stručný popis, charakterizující technologickou operaci
Tabulka | Identifikace tabulky artiklu výroby
 | Název tabulky vztahu artiklů
Druh linky | Identifikace druhu výrobní linky
 | Název druhu výrobní linky
Barva | Identifikace barvy RGB
Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Název technicko-věcného selektoru.
Vstupy a výstupy | Identifikátor druhu operace
 | Identifikace komponenty - přijemce transformovaných dat
 | Název druhu operace
 | Komentář, podrobně popisující technologickou operaci.
Stránka #2 Výběr
Operace | Identifikace technologické operace
Název operace | Stručný popis, charakterizující technologickou operaci
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Druh linky | Identifikace druhu výrobní linky
Název druhu linky | Název druhu výrobní linky
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Technologické operace] činnosti - Barvy RGB

    Mřížka [Technologické operace] činnosti - Barvy RGB
Operace | Identifikace technologické operace
Název operace | Stručný popis, charakterizující technologickou operaci

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Kopie operace | Provedení kopie technologického operace
F7 | Přehled referenčních artiklů | Přehled referenčních artiklů
F9 | Vytvořit jednokrokový TP | Vytvořit jednokrokový technologický postup
F2 | Artikly výroby | Vstup artiklů výroby
F2 | Barvy RGB |
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy výrobních linek | Číselník druhů výrobních linek
F2 | Tabulky vztahů artiklů | Tabulky vztahů artiklů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Atributy tisku

    Základní údaje
Operace | Identifikace technologické operace | TPOPERAC_tp05id | C(13)
Název operace | Stručný popis, charakterizující technologickou operaci | TPOPERAC_tp05operac | C(40)
Tabulka | Identifikace tabulky artiklu výroby | TPOPERAC_tp14id | C(13)
Název tabulky | Název tabulky vztahu artiklů | TPTAB_tp14naztab | C(40)
Druh linky | Identifikace druhu výrobní linky | TPOPERAC_tp12id | C(6)
Název druhu linky | Název druhu výrobní linky | TPLINKAD_tp12linka | C(40)
Číslo implic. linky | Číslo výrobní linky, resp. stroje | TPLINKAD_tp13id | C(6)
Barva | Identifikace barvy RGB | TPOPERAC_bw95id | C(6)
Popis | Popis barvy RGB | BWRGBCOL_bw95popbar | C(40)
Tech. sel. | Identifikátor technicko-věcného selektoru. | TPOPERAC_sp20idzak | C(9)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(60)
Poznámka | Komentář, podrobně popisující technologickou operaci. | TPOPERAC_tp05koment | M

    Viz.také

    Kopie operace | Přehled referenčních artiklů | Vytvořit jednokrokový TP | Artikly výroby | Barvy RGB | Druhy artiklů | Druhy operací | Druhy výrobních linek | Tabulky vztahů artiklů | Technicko-věcný selektor


Přehled referenčních artiklů

Popis

Referenční artikl v podstatě slučuje definované artikly výroby a technologické operace do jednoho logického celku. Uživatel má k dispozici informaci, že právě touto technologickou operací (v dané variantě) je vyráběn tento artikl. Referenční artikly představují již zcela konkrétní případy výroby, kde určitý artikl lze vyrábět více technologickými operacemi a na druhou stranu určitou technologickou operací lze vyrábět více artiklů. U každého referenčního artiklu se definují následující atributy:

¨ identifikace technologické operace – výběr z číselníku

¨ varianta technologické operace (TO) – odlišuje referenční artikly se stejnou technologickou operací z pohledu vstupů (vztažené artikly) referenčního artiklu (např. výroba desky stolu – technologická operace „barvení desky namáčením“ – stejná technologická operace, ale jednou ve variantě M – modrá barva desky a podruhé ve variantě Z – žlutá barva desky)

¨ identifikace referenčního artiklu – referenční artikl vztahující se k dané technologické operaci (ve většině případů je to výstupní artikl dané technologické operace), např. u výše zmíněné TO „barvení desky namáčením“ je uveden artikl „natřený plech“

¨ druh linky – je daný příslušnou technologickou operací

¨ linka – implicitní linka pro daný referenční artikl. Je-li implicitní linka zadána, její hodnota při plánování výroby (tj. při generování výrobních úkolů) „přebije“ implicitní linku uvedenou u daného druhu linky.

¨ TVS – identifikace a název technicko-věcného selektoru vztahujícímu se k danému ref. artiklu

¨ výkon. norma – počet kalkulačních jednic, vyrobených za jednotku času (uvedenou v parametrech TPV)

¨ opakování – hodnota, která vyjadřuje počet opakování jednoho výrobního úkolu (ovlivňuje jen čas trvání výrobního úkolu)

¨ normohodin – doba vyjádřená v jednotce času (uvedenou v parametrech TPV) na vyrobení jedné kalkulační jednice

¨ plus – připočítávaný konstantní čas délky kroku (výrobního úkolu) v minutách

¨ výkon. norma celkem – hodnota výkonové normy celkem (přepočtena podle výkon. norma * opakování)

¨ normohodin celkem – hodnota normohodin celkem (přepočtena podle normohodin * opakování)

¨ KV – kalkulační vzorec + identifikace proměnné kalkulačního vzorce – KV u referenčního artiklu definuje vzorec, podle kterého se počítá ocenění výstupu referenčního artiklu. Proměnná kalkulačního vzorce u vztaženého artiklu nebo u pracovních výkonů sděluje způsob, jakým bude vstup zahrnut do výpočtu ocenění výstupu referenčního artiklu podle daného KV.

¨ úložiště – identifikace skladového úložiště. Na základě svých výrobních potřeb si firmy definují své skladové prostory, tj. skladová úložiště. Nejčastěji jsou skladová úložiště shodná s počtem skladů. U daného referenčního artiklu definuje úložiště místo, kam se ukládá výstup referenčního artiklu. Typicky je shodné s úložištěm na artiklu výroby, který je výstupem referenčního artiklu. U vztažených artiklů definuje úložiště místo, odkud se vztažené artikly spotřebovávají. Typicky je shodné s úložištěm na artiklu výroby, který je vztaženým artiklem referenčního artiklu.

¨ směr – vstup (materiál) / výstup (meziprodukt, odpad) – u referenčního a vztaženého artiklu tato hodnota sděluje, zda se jedná o vstup nebo výstup výrobního úkolu. U výroby ve většině případů platí, že referenční artikly jsou výstupy a vztažené artikly vstupy (až na případné výjimky, např. odpad). Opačná situace je u „zpracovatelské“ výroby, kde referenční artikl je vstupem a vztažený artikl je výstupem výrobního úkolu.

¨ měřená položka – volba Ano/Ne. Označuje vstup nebo výstup, který je měřitelný. V případě volby Ano bude u tohoto artiklu možno při výrobě zjistit jeho množství na vstupu/výstupu (pomocný parametr pro identifikaci vstupů a výstupů, jejichž hodnoty ve výrobě je možné zjišťovat nějakým technologickým zařízením, např. automatická čtečka vyrobeného množství).

¨ jednotková cena – ceníková cena artiklu za měrnou jednotku v oceňovací jednotce

¨ minimální množství – definuje minimální množství pro vstup artiklu do následující operace, typicky používané při proudové výrobě. Tato hodnota má smysl jen u artiklů, jejichž „směr“ je vstup.

Následující záložky poskytují uživateli zpřesňující informace vztahující se k definici referenčních artiklů. Důležitá záložka je:

¨ záložka Vztažené artikly – definují se zde vztažené artikly k referenčnímu artiklu (např. výroba desky stolu – referenční artikl je modrá deska, vztažený artikl je barva a plech). Na jakém druhu linky se ve výrobě použije vztažený artikl určuje atribut „dr.stroje“ (má dopad na naplánování výrobních úkolů). Další atributy jsou významem totožné s atributy na záložce Referenční artikly. Pomocí klávesy F6 lze aktivovat formulář kusovníku, kde se zadávají vztahy mezi vstupy a výstupy referenčního artiklu (jedná se v podstatě o tabulku vztahů artiklu pro danou operaci a referenční artikl).

¨ záložka Pracovní výkony – definuje pracovní výkony nutné k výrobě referenčního artiklu. Atribut „profese“ odkazuje do komponenty mezd, přiřazuje pracovnímu výkonu pracovní místo, které je ohodnoceno hodinovou mzdou. Další důležitý atribut je atribut „čas“, který eviduje čas potřebný k provedení pracovního výkonu. Konstantní čas trvání pracovního výkonu se používá v případě, že se jedná o pracovní výkon nezávislý na počtu vyráběných výrobků. Čas podle délky kroku je vypočítáván v závislosti na počtu vyráběných výrobků podle tabulky vztahů pracovních výkonů. Atribut „procento kroku“ (proc.kr.) definuje podíl času, který věnuje uvedená profese danému kroku pracovního výkonu (např. pokud se pracovník v určitý čas věnuje zároveň práci na více výrobních linkách)

Datový model

  • TPKUSOV Položka kusovníku TPV
    • TPVYROB Artikl výroby
      • SPARTIKN Název artiklu
      • SPARTIKL Artikl
    • TPSKLADU Skladové úložiště TPV (alias TPSKLAD)
    • TPPROFTB Tabulka pracovních výkonů výroby
    • SPMJ Měrná jednotka
    • TPOPERAC Technologická operace
      • SPTYP Druh procesu/operace (alias SPTYP2)
      • TPLINKAD Druh výrobní linky/stroje
      • TPTAB Tabulka vztahů artiklů výroby
      • SPSETV Technicko-věcný selektor
    • OBCENIK Položka ceníku artiklu

    • Formulář

    Formulář činnosti - Výrobní linky a stroje
Mřížka [Referenční artikly]
Operace | Identifikace technologické operace
Varianta | Varianta technologické operace
Název operace | Stručný popis, charakterizující technologickou operaci
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
MJ | Identifikátor měrné jednotky
Listovací rámeček
Stránka #1 Referenční artikly
 | Název artiklu
Dr.linky | Identifikace druhu výrobní linky
Číslo linky | Implicitní linka pro tento referenční artikl
 | Název druhu výrobní linky
TVS | Identifikátor technicko-věcného selektoru.
 | Název technicko-věcného selektoru.
Výkon. norma | Počet kalkulačních jednic, vyrobených za jednotku času uvedenou v parametrech.
Opakování | Počet opakování kroku.
Normohodin | Normohodin
Plus | Připočítávaný konstantní čas délky kroku v minutách
Výkon. norma cel. | Výkonová norma celkem
Celk. | Normohodin celkem
KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
Úložiště | Identifikace skladového úložiště
 | Název úložiště
Směr | Vstup (materiál) nebo výstup (meziprodukt, odpad).
Měřená položka | Měřená položka - tj. bude u ní možné při výrobě zjistit její množství na vstupu/výstupu, neměřenou bude možné rozpočítat
Jednotková cena | Cena ceníková za artikl za měrnou jednotku v oceňovací jednotce
Minimální množství | Minimální množství artiklu na vstupu pří proudové výrobě (nula = neurčeno)
Stránka #2 Další
 | Název artiklu
TB-VZA | Identifikace tabulky artiklu výroby
 | Název tabulky vztahu artiklů
TB-PV | Identifikátor tabulky pracovních výkonů
Název tabulky | Název tabulky pracovních výkonů
Vstupy a výstupy | Identifikátor druhu operace
 | Identifikace komponenty - přijemce transformovaných dat
 | Název druhu operace
Poznámka | Komentář, podrobně popisující technologickou operaci.
Popis | Popis k referenčnímu artiklu
Poznámka | Poznámka k referenčnímu artiklu
Stránka #3 Vztažené artikly
Mřížka [Vztažené artikly]
Dr.stroje | Identifikace druhu stroje
Název druhu stroje | Název druhu stroje
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Varianta | Varianta technologické operace
MJ | Identifikátor měrné jednotky
 | Název artiklu
KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
Úložiště | Identifikace skladového úložiště
 | Název úložiště
Směr | Vstup (materiál) nebo výstup (meziprodukt, odpad).
Měřená položka | Měřená položka - tj. bude u ní možné při výrobě zjistit její množství na vstupu/výstupu, neměřenou bude možné rozpočítat
Jednotková cena | Cena ceníková za artikl za měrnou jednotku v oceňovací jednotce
Minimální množství | Minimální množství artiklu na vstupu pří proudové výrobě (nula = neurčeno)
Stránka #4 Další
Dr.stroje | Identifikace druhu stroje
Název druhu stroje | Název druhu stroje
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Varianta | Varianta technologické operace
 | Název artiklu
Popis | Popis ke vztaženému artiklu
Poznámka | Poznámka ke vztaženému artiklu
Stránka #5 Výskyt v oper.
Mřížka [Výskyt v operacích]
Stránka #6 Pracovní výk.
Mřížka [Pracovní výkony]
Dr.stroje | Identifikace druhu stroje
Název druhu stroje | Název druhu stroje
Varianta | Varianta technologické operace
Pořadí | Pořadí zobrazení pracovního výkonu v mřížce
Profese | Identifikace pracovní funkce (zařazení)
 | Popis pracovní funkce (pracovního zařazení)
 | Počet pracovníků provádějících krok
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
Čas | Čas potřebný k provedení jednoho kroku
Konst. | Konstantní čas na provedení kroku (např. seřízení)
Proc. kr. | Výkon práce jako procento času trvání kroku
 | Pomocné číslo
Proc. prémií | Procento prémií
Základ | Firemní mzda hodinová
Prémie | Mzdové náklady - prémie
Celkem | Mzdové náklady celkem
Mzda 1 prac. | Osobní náklady - základ
Mzd.nákl. | Osobní náklady - prémie
S odvody | Osobní náklady celkem
Stránka #7 Tech. postupy
Mřížka [Technologické postupy]
Stránka #8 Výběr
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Operace | Identifikace technologické operace
Varianta | Varianta technologické operace
Druh linky | Identifikace druhu výrobní linky
Vztah ke kategorii | Vztah ke kategorii - Je=K dnešnímu datu je v kategorii, Není=K dnešnímu datu není v kategorii, Byl=Není v kategorii, ale byl, Nebyl=Není a nikdy nebyl v kategorii,Bude=Bude v kategorii
Kategorie | Identifikace kategorie události správy artiklu
Název kategorie | Název kategorie události správy artiklu
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 | Platnost nebo neplatnost k datu
Paleta | Vybrat záznamy všech kategorií v paletě
 | Identifikace palety barev
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Referenční artikly] činnosti - Výrobní linky a stroje

    Mřížka [Referenční artikly] činnosti - Výrobní linky a stroje
Označování | Označení záznamu
Operace | Identifikace technologické operace
Varianta | Varianta technologické operace
Artikl | Identifikace artiklu
Třída | Identifikace třídy výrobního artiklu
Směr | Vstup (materiál) nebo výstup (meziprodukt, odpad).
Druh artiklu | Identifikace druhu artiklu
Název artiklu | Název artiklu
MJ | Identifikátor měrné jednotky
CJ - artikl | Cena ceníková za artikl za měrnou jednotku v oceňovací jednotce
Úložiště | Identifikace skladového úložiště

    Mřížka [Vztažené artikly] činnosti - Výrobní linky a stroje

    Mřížka [Vztažené artikly] činnosti - Výrobní linky a stroje
Dr.stroje | Identifikace druhu stroje
Varianta | Varianta technologické operace
Artikl | Identifikace artiklu
Směr | Vstup (materiál) nebo výstup (meziprodukt, odpad).
Druh artiklu | Identifikace druhu artiklu
Název artiklu | Název artiklu
MJ | Identifikátor měrné jednotky
CJ - artikl | Cena ceníková za artikl za měrnou jednotku v oceňovací jednotce
Název druhu stroje | Název druhu stroje

    Mřížka [Výskyt v operacích] činnosti - Výrobní linky a stroje

    Mřížka [Výskyt v operacích] činnosti - Výrobní linky a stroje
Směr | Vstup (materiál) nebo výstup (meziprodukt, odpad).
Operace | Identifikace technologické operace
Varianta | Varianta technologické operace
Název operace | Stručný popis, charakterizující technologickou operaci

    Mřížka [Pracovní výkony] činnosti - Výrobní linky a stroje

    Mřížka [Pracovní výkony] činnosti - Výrobní linky a stroje
TB-PV | Identifikátor tabulky pracovních výkonů
Varianta | Varianta technologické operace
Dr.stroje | Identifikace druhu stroje
Profese | Identifikace pracovní funkce (zařazení)
Název profese | Popis pracovní funkce (pracovního zařazení)
Název druhu stroje | Název druhu stroje
Počet | Počet pracovníků provádějících krok
Čas | Čas potřebný k provedení jednoho kroku
Konstantní | Konstantní čas na provedení kroku (např. seřízení)
Proc. kr. | Výkon práce jako procento času trvání kroku
Proc. prémií | Procento prémií

    Mřížka [Technologické postupy] činnosti - Výrobní linky a stroje

    Mřížka [Technologické postupy] činnosti - Výrobní linky a stroje
Tech. postup | Identifikace technologického postupu
Popis tech. postupu | Stručný popis, charakterizující technologický postup

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Kopie operace | Provedení kopie technologického operace
F6 | Vztahy artiklů | Údržba tabulky vztahů artiklů výroby
F7 | Diagram technolog.postupu | Diagram technologického postupu
F9 | Vytvořit jednokrokový TP | Vytvořit jednokrokový technologický postup
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Události správy artiklu |
- | Legenda palety barev |
F2 | Artikly výroby | Vstup artiklů výroby
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy výrobních linek | Číselník druhů výrobních linek
F2 | Kategorie událostí správy artiklu | Přehled kategorií událostí správy artiklu
F2 | Měrné jednotky | Číselník měrných jednotek
F2 | Palety barev kategorií | Palety barev kategorií
F2 | Pracovní místa skut. a typová | Popis pracovní funkce (zařazení)
F2 | Skladová úložiště | Skladová úložiště
F2 | Tabulky pracovních výkonů | Tabulky pracovních výkonů
F2 | Tabulky vztahů artiklů | Tabulky vztahů artiklů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Technologické operace | Číselník technologických operací
F2 | Výrobní linky a stroje | Seznam výrobních linek a strojů

    Atributy tisku

    Základní údaje
Operace | Identifikace technologické operace | TPKUSOV_tp05id | C(13)
Varianta | Varianta technologické operace | TPKUSOV_tp02varian | C(6)
Název operace | Stručný popis, charakterizující technologickou operaci | TPOPERAC_tp05operac | C(40)
Druh linky | Identifikace druhu výrobní linky | TPOPERAC_tp12id | C(6)
Název linky | Název druhu výrobní linky | TPLINKAD_tp12linka | C(40)
Implicitní linka | Implicitní linka pro tento referenční artikl | TPKUSOV_tp13id | C(6)
Název linky | Název výrobní linky | TPLINKA_tp13linka | C(40)
Tech. sel. | Identifikátor technicko-věcného selektoru. | TPOPERAC_sp20idzak | C(9)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(60)
Tabulka | Identifikace tabulky artiklu výroby | TPOPERAC_tp14id | C(13)
Název tabulky | Název tabulky vztahu artiklů | TPTAB_tp14naztab | C(40)
Poznámka | Komentář, podrobně popisující technologickou operaci. | TPOPERAC_tp05koment | M
Druh artiklu | Identifikace druhu artiklu | TPKUSOV_sp61id | C(3)
Artikl | Identifikace artiklu | TPKUSOV_sp60id | C(13)
MJ | Identifikátor měrné jednotky | TPKUSOV_sp24idmj | C(3)
Název měrné jednotky | Název měrné jednotky | SPMJN_sp58mjnaz | C(40)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Výkon. norma | Počet kalkulačních jednic, vyrobených za jednotku času uvedenou v parametrech. | TPKUSOV_tp02vyknor | N(10,3)
Počet opakování | Počet opakování kroku. | TPKUSOV_tp02pocop | N(3)
Plus | Připočítávaný konstantní čas délky kroku v minutách | TPKUSOV_tp02normhp | N(9,3)
KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce | TPKUSOV_tp27id | C(3)
Název KV | Název kalkulačního vzorce / název proměnné kalkulačního vzorce | TPKALK1_tp27nazrol | C(40)
Úložiště | Identifikace skladového úložiště | TPKUSOV_tp17id | C(6)
Název úložiště | Název úložiště | TPSKLAD_tp17ulozis | C(40)
Směr | Vstup (materiál) nebo výstup (meziprodukt, odpad). | Výpočet | C(6)
Měřená položka | Měřená položka - tj. bude u ní možné při výrobě zjistit její množství na vstupu/výstupu, neměřenou bude možné rozpočítat | Výpočet | C(3)
Minimální množství | Minimální množství artiklu na vstupu pří proudové výrobě (nula = neurčeno) | TPKUSOV_tp02minmn | N(20,4)
CJ - artikl | Cena ceníková za artikl za měrnou jednotku v oceňovací jednotce | OBCENIK_ob03cj02 | N(20,6)
CJ - ostatní nákl. | Cena ceníková ostatních nákladů za měrnou jednotku v oceňovací jednotce | OBCENIK_ob03cj03 | N(20,6)
Název měrné jednotky | Název měrné jednotky | SPMJN2_sp58mjnaz | C(40)
Název artiklu | Název artiklu | SPARTIKN2_sp62artikl | C(60)
Název druhu stroje | Název druhu stroje | TPLINKAD3_tp12linka | C(40)
Název KV | Název kalkulačního vzorce / název proměnné kalkulačního vzorce | TPKALK2_tp27nazrol | C(40)
Název úložiště | Název úložiště | TPSKLAD2_tp17ulozis | C(40)
CJ - artikl | Cena ceníková za artikl za měrnou jednotku v oceňovací jednotce | OBCENIK2_ob03cj02 | N(20,6)
CJ - ostatní nákl. | Cena ceníková ostatních nákladů za měrnou jednotku v oceňovací jednotce | OBCENIK2_ob03cj03 | N(20,6)
Název profese | Popis pracovní funkce (pracovního zařazení) | MZPRACFU_mz31pracfu | C(40)
Třída | Tarifní třída (1-99) | MZTARTRI_mz24trida | C(2)
Název druhu stroje | Název druhu stroje | TPLINKAD4_tp12linka | C(40)
Název artiklu | Název artiklu | SPARTIKN3_sp62artikl | C(60)
Název KV | Název kalkulačního vzorce / název proměnné kalkulačního vzorce | TPKALK3_tp27nazrol | C(40)
Sazba | Firemní mzda hodinová | MZTARTRI_mz24hodmzd | N(8,2)
Min. měsíční mzda | Minimální mzda měsíční | MZTARTRI_mz24minmzd | N(5)
Tech. postup | Identifikace technologického postupu | TPTECHPO_tp03id | C(13)
Popis tech. postupu | Stručný popis, charakterizující technologický postup | TPTECHPO_tp03techpo | C(40)
Název operace | Stručný popis, charakterizující technologickou operaci | TPOPERAC3_tp05operac | C(40)

    Při pohybu v Vztažené artikly
Druh artiklu | Identifikace druhu artiklu | TPKUSOV2_sp61id | C(3)
Artikl | Identifikace artiklu | TPKUSOV2_sp60id | C(13)
Varianta | Varianta technologické operace | TPKUSOV2_tp02varian | C(6)
MJ | Identifikátor měrné jednotky | TPKUSOV2_sp24idmj | C(3)
Dr.stroje | Identifikace druhu stroje | TPKUSOV2_tp12id | C(6)
KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce | TPKUSOV2_tp27id | C(3)
Úložiště | Identifikace skladového úložiště | TPKUSOV2_tp17id | C(6)
Směr | Vstup (materiál) nebo výstup (meziprodukt, odpad). | Výpočet | C(6)
Měřená položka | Měřená položka - tj. bude u ní možné při výrobě zjistit její množství na vstupu/výstupu, neměřenou bude možné rozpočítat | Výpočet | C(3)
Minimální množství | Minimální množství artiklu na vstupu pří proudové výrobě (nula = neurčeno) | TPKUSOV2_tp02minmn | N(20,4)

    Při pohybu v Odkazy na vstupy/výstupy jiných operací
Operace | Identifikace technologické operace | TPKUSOV3_tp05id | C(13)
Varianta | Varianta technologické operace | TPKUSOV3_tp02varian | C(6)
Směr | Vstup (materiál) nebo výstup (meziprodukt, odpad). | Výpočet | C(6)

    Při pohybu v Pracovní výkon
Profese | Identifikace pracovní funkce (zařazení) | TPPROFOP_mz31id | C(6)
Dr.stroje | Identifikace druhu stroje | TPPROFOP_tp12id | C(6)
Varianta | Varianta technologické operace | TPPROFOP_tp02varian | C(6)
Druh artiklu | Identifikace druhu artiklu | TPPROFOP_sp61id | C(3)
Artikl | Identifikace artiklu | TPPROFOP_sp60id | C(13)
KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce | TPPROFOP_tp27id | C(3)
Počet | Počet pracovníků provádějících krok | TPPROFOP_tp06pocet | N(3)
Čas na oper. | Čas potřebný k provedení jednoho kroku | Výpočet | C(17)
Konstantní | Konstantní čas na provedení kroku (např. seřízení) | TPPROFOP_tp06konstc | N(8,2)
Proc. čas oper. | Výkon práce jako procento času trvání kroku | TPPROFOP_tp06procca | N(6,2)
Proc. prémií | Procento prémií | TPPROFOP_tp06procpr | N(6,2)
Pomocné číslo | Pomocné číslo | TPPROFOP_tp06pomcis | N(10,2)

    Viz.také

    Kopie operace | Vztahy artiklů | Diagram technolog.postupu | Vytvořit jednokrokový TP | OZNAČOVÁNÍ | Události správy artiklu | Legenda palety barev | Artikly výroby | Druhy artiklů | Druhy operací | Druhy výrobních linek | Kategorie událostí správy artiklu | Měrné jednotky | Palety barev kategorií | Pracovní místa skut. a typová | Skladová úložiště | Tabulky pracovních výkonů | Tabulky vztahů artiklů | Technicko-věcný selektor | Technologické operace | Výrobní linky a stroje


Druhy výrobních linek

Popis

Činnost představuje definici druhů výrobních linek. Ke každému druhu je navíc možno zvolit implicitní linku. Tato implicitní linka se vygeneruje ve výrobních úkolech při plánování výroby (jediná výjimka je v případě, že je jiná implicitní linka uvedena u druhu linky v činnosti referenční artikly. Tato linka potom „přebije“ hodnotu v této činnosti nadefinované implicitní linky).

Datový model

  • TPLINKAD Druh výrobní linky/stroje
    • TPLINKA Výrobní linka / stroj / skladové úložiště výroby

    • Formulář

    Formulář činnosti - Výrobní linky a stroje
Mřížka [Druhy linek]
Druh linky | Identifikace druhu výrobní linky
 | Název druhu výrobní linky
Implicitní linka | Číslo výrobní linky, resp. stroje
 | Název výrobní linky
Komentář | Komentář, podrobně popisující druh výrobní linky, resp. stroje

    Mřížka [Druhy linek] činnosti - Výrobní linky a stroje

    Mřížka [Druhy linek] činnosti - Výrobní linky a stroje
Dr.linky | Identifikace druhu výrobní linky
Název druhu linky | Název druhu výrobní linky
Implicitní linka | Číslo výrobní linky, resp. stroje
Název implic. linky | Název výrobní linky

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Výrobní linky a stroje | Seznam výrobních linek a strojů

    Atributy tisku

    Základní údaje
Druh linky | Identifikace druhu výrobní linky | TPLINKAD_tp12id | C(6)
Název druhu linky | Název druhu výrobní linky | TPLINKAD_tp12linka | C(40)
Číslo implic. linky | Číslo výrobní linky, resp. stroje | TPLINKAD_tp13id | C(6)
Název implic. linky | Název výrobní linky | TPLINKA_tp13linka | C(40)
Komentář | Komentář, podrobně popisující druh výrobní linky, resp. stroje | TPLINKAD_tp12koment | M

    Viz.také

    Výrobní linky a stroje


Výrobní linky a stroje

Popis

Tato činnost poskytuje uživateli přehled nadefinovaných výrobních linek (jsou zvýrazněny modrou barvou) a jednotlivých strojů. Ke každé lince nebo stroji lze nadefinovat přístupová práva (menu Volby nebo Ctrl B). Údaje této činnosti jsou pro uživatele k dispozici na následujících záložkách:

¨ výrobní linky a stroje – identifikace a název výrobní linky, druh linky a určení, zda se jedná o linku nebo stroj

¨ stroje výrobní linky – ke každé výrobní lince se zde přiřazují stroje, které se na lince vyskytují. Každý stroj na lince má uveden datum platnosti zařazení na linku. Poslední stroj linky určuje, jaký se předplní stroj do výstupu ve vstupech a výstupech výrobního úkolu.

¨ obsluha – ke každé výrobní lince nebo stroji se přiřazují konkrétní pracovníci. Tímto dojde k vyplnění hodnoty osobního čísla „OSC“ na vstupech výrobních úkolů (pracovní výkony) podle profese nadefinované v pracovních výkonech referenčního artiklu, který je předmětem daného výrobního úkolu

¨ výjimky v kalendáři – definují se výjimky v kalendáři pro konkrétní výrobní linku

¨ přidělené kalendáře – informace o kalendáři přiřazeném dané výrobní lince (vlastní definice kalendářů se provádí v komponentě Výroba – Kalendáře směn výroby)

Datový model

  • TPLINKA Výrobní linka / stroj / skladové úložiště výroby
    • TPLINKAD Druh výrobní linky/stroje
    • SPSEOR Organizační selektor
    • SPSETV Technicko-věcný selektor

    • Formulář

    Formulář činnosti - Předplnit směny
Mřížka [Výrobní linky a stroje]
Výrobní linka | Číslo výrobní linky, resp. stroje
 | Název výrobní linky
Listovací rámeček
Stránka #1 Výrobní linky a stroje
Druh linky | Identifikace druhu výrobní linky
 | Název druhu výrobní linky
Stroj/Linka | Stroj nebo výrobní linka
Komentář | Komentář, podrobně popisující výrobní linku, resp. stroj
Selektory | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Stránka #2 Stroje výrobní linky
Mřížka [Stroje výrobní linky]
Stroj | Číslo výrobní linky, resp. stroje
Název stroje | Název stroje
Ode dne | Datum zařazení ve výrobní lince
do | Datum vyřazení z výrobní linky
Poslední | Poslední stroj linky
Stránka #3 Obsluha
Mřížka [Obsluha]
Datum | Datum v kalendáři využití linky
do | Datum v kalendáři využití linky do
Číslo směny | Číslo směny
Pracovník | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Profese | Identifikace pracovní funkce (zařazení)
Název profese | Popis pracovní funkce (pracovního zařazení)
Stránka #4 Výjimky v kalendáři
Mřížka [Dny kalendáře]
Datum | Datum v kalendáři využití linky
Číslo směny | Číslo směny
Od | Hodina začátku směny
Doba trvání | Doba trvání směny v hodinách
Směna se uskuteční (uskutečnila) | Směna se uskuteční (uskutečnila) Ano/Ne
Poznámka | Poznámka
Stránka #5 Přidělené kalendáře
Mřížka [Přidělené kalendáře]
Kalendář | Identifikace kalendáře
Název kalendáře | Název kalendáře
Platnost od | Platnost od
do | Platnost do
Stránka #6 Výběr
Linka | Číslo výrobní linky, resp. stroje
Název linky | Název výrobní linky
Druh linky | Identifikace druhu výrobní linky
Stroj/Linka | Stroj nebo výrobní linka
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Výrobní linky a stroje] činnosti - Předplnit směny

    Mřížka [Výrobní linky a stroje] činnosti - Předplnit směny
Číslo linky | Číslo výrobní linky, resp. stroje
Název linky | Název výrobní linky
Druh linky | Identifikace druhu výrobní linky
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Mřížka [Stroje výrobní linky] činnosti - Předplnit směny

    Mřížka [Stroje výrobní linky] činnosti - Předplnit směny
Dr.stroje | Identifikace druhu výrobní linky
Ode dne | Datum zařazení ve výrobní lince
Stroj | Číslo výrobní linky, resp. stroje
Název stroje | Název stroje
Poslední | Poslední stroj linky

    Mřížka [Obsluha] činnosti - Předplnit směny

    Mřížka [Obsluha] činnosti - Předplnit směny
Datum | Datum v kalendáři využití linky
do | Datum v kalendáři využití linky do
S. | Číslo směny
Pracovník | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Identifikace | Identifikace pracovní funkce (zařazení)
Prac.funkce | Popis pracovní funkce (pracovního zařazení)

    Mřížka [Dny kalendáře] činnosti - Předplnit směny

    Mřížka [Dny kalendáře] činnosti - Předplnit směny
Datum | Datum v kalendáři využití linky
Název dne | Název dne
Číslo směny | Číslo směny
Od | Hodina začátku směny
Doba trvání | Doba trvání směny v hodinách

    Mřížka [Přidělené kalendáře] činnosti - Předplnit směny

    Mřížka [Přidělené kalendáře] činnosti - Předplnit směny
Kalendář | Identifikace kalendáře
Název kalendáře | Název kalendáře
Platnost od | Platnost od
do | Platnost do

    Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci
- | Přehled směn výrobních linek | Přehled směn výrobních linek
- | Předplnit směny | Předplnit směny do kalendáře linek
F2 | Druhy výrobních linek | Číselník druhů výrobních linek
F2 | Kalendáře směn výroby | Kalendáře směn výroby
F2 | Karta pracovníka | Karta pracovníka
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Pracovní místa skut. a typová | Popis pracovní funkce (zařazení)
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Výrobní linky a stroje | Seznam výrobních linek a strojů

    Atributy tisku

    Základní údaje
Číslo linky | Číslo výrobní linky, resp. stroje | TPLINKA_tp13id | C(6)
Název linky | Název výrobní linky | TPLINKA_tp13linka | C(40)
Druh linky | Identifikace druhu výrobní linky | TPLINKA_tp12id | C(6)
Název druhu linky | Název druhu výrobní linky | TPLINKAD_tp12linka | C(40)
Komentář | Komentář, podrobně popisující výrobní linku, resp. stroj | TPLINKA_tp13koment | M
Org. sel. | Identifikátor organizačního selektoru. | TPLINKA_sp11idzak | C(9)
Název organizačního selektoru | Název organizačního selektoru | SPSEOR_sp11text | C(40)
Tech. sel. | Identifikátor technicko-věcného selektoru. | TPLINKA_sp20idzak | C(9)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(40)
Název stroje | Název stroje | TPLINKA3_tp13linka | C(40)
Dr.stroje | Identifikace druhu výrobní linky | TPLINKA3_tp12id | C(6)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Prac.funkce | Popis pracovní funkce (pracovního zařazení) | MZPRACFU_mz31pracfu | C(40)
Název kalendáře | Název kalendáře | VRKAL_vr32nazkal | C(40)

    Při pohybu v Obsluha výrobní linky/stroje
Datum | Datum v kalendáři využití linky | TPLINKAP_tp23datum | D
do | Datum v kalendáři využití linky do | TPLINKAP_tp23datum2 | D
Číslo směny | Číslo směny | Výpočet | C(7)
Pracovník | Jednoznačná identifikace pracovníka | TPLINKAP_mz01id | C(6)
Identifikace | Identifikace pracovní funkce (zařazení) | TPLINKAP_mz31id | C(6)

    Při pohybu v Stroje výrobní linky
Stroj | Číslo výrobní linky, resp. stroje | TPLINKAV_tp13id | C(6)
Ode dne | Datum zařazení ve výrobní lince | TPLINKAV_tp38datum | D
do | Datum vyřazení z výrobní linky | TPLINKAV_tp38datumd | D

    Při pohybu v Přidělené kalendáře
Kalendář | Identifikace kalendáře | VRKALPLI_vr32id | C(6)
Platnost od | Platnost od | VRKALPLI_vr36datod | D
do | Platnost do | VRKALPLI_vr36datdo | D

    Při pohybu v Vyjímky v kalendáři
Datum | Datum v kalendáři využití linky | VRKALPOL_tp23datum | D
Od | Hodina začátku směny | VRKALPOL_tp23casod | C(4)
Poznámka | Poznámka | VRKALPOL_tp23koment | M
Doba trvání | Doba trvání směny v hodinách | VRKALPOL_tp23trvani | N(5,2)
Číslo směny | Číslo směny | Výpočet | C(7)
Název dne | Název dne | Výpočet | C(7)
Směna se uskuteční (uskutečnila) | Směna se uskuteční (uskutečnila) Ano/Ne | Výpočet | C(3)

    Viz.také

    Přístupová práva | Přehled směn výrobních linek | Předplnit směny | Druhy výrobních linek | Kalendáře směn výroby | Karta pracovníka | Organizační selektor | Pracovní místa skut. a typová | Technicko-věcný selektor


Skladová úložiště

Popis

Skladová úložiště většinou korespondují s definicí skladů v IS BM. U každého skladového úložiště se definuje identifikace, název a identifikace umístění skladové evidence. V této činnosti k nim nelze definovat přístupová práva.

Datový model

  • TPSKLADU Skladové úložiště TPV (alias TPSKLAD)
    • MTSKL Sklad

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Sklady | Seznam skladů

    Formulář

    Formulář činnosti - Sklady
Mřížka [Skladová úložiště]
Úložiště | Identifikace skladového úložiště
 | Název úložiště
Sklad | Identifikace umístění skladové evidence
 | Název skladu

    Mřížka [Skladová úložiště] činnosti - Sklady

    Mřížka [Skladová úložiště] činnosti - Sklady
Úložiště | Identifikace skladového úložiště
Název úložiště | Název úložiště
Sklad | Identifikace umístění skladové evidence

    Viz.také

    Sklady


Parametry TPV

Popis

Činnost parametry TPV představuje jednotlivé definice parametrů, které zajišťují správné předplňování atributů v činnostech TPV. Definuje se:

¨ cenová skupina – identifikace cenové skupiny (s touto cenovou skupinou jsou v ceníku uložena ocenění artiklů vstupujících do výroby). U identifikace cenové skupiny je možno navíc ještě i zvolit:

- jen platné – zaškrtávátko se vztahuje k cenovým obdobím. Pokud zůstane nezaškrtnuté, zobrazí se uživateli v činnosti Artikly výroby na záložce Ceny všechna dostupná cenová období. Pokud bude zaškrtnuto, zobrazí se v dané činnosti na záložce Ceny pouze ta cenová období, která jsou platná vůči aktuálnímu datu.

- všechny – zaškrtávátko se vztahuje k cenovým skupinám. Pokud zůstane nezaškrtnuté, zobrazí se uživateli v činnosti Artikly výroby na záložce Ceny pouze cenová skupina, která je uvedena zde v parametrech (atribut „cenová skupina“). Pokud bude zaškrtnuto, zobrazí se v dané činnosti na záložce Ceny všechny cenové skupiny, které náleží k danému artiklu (tzn. i prodejní, nákupní apod.).

¨ šablona – definice šablony, která se používá při generování jednokrokových technologických postupů

¨ hodin výk. normy – počet hodin, za které se uvádí výkonová norma

¨ obvyklé množství – definice množství, které se pak předplňuje při zadávání vztahů artiklů u výstupního (pilotního) artiklu

¨ pracovní náklady zahrnují – volba mzdové/mzdové s odvody – rozlišení zda celkové náklady zahrnují mzdové či osobní náklady

¨ předplňovat KV pro ref. artikl – identifikace kalkulačního vzorce předplňovaná pro výstupy v kusovníku (tabulky vztahů artiklu)

¨ předplňovat KV pro vztaž. artikl – identifikace proměnné kalkulačního vzorce předplňovaná v kusovníku (tabulky vztahů artiklu)

¨ předplňovat KV pro pracovní výkon – identifikace proměnné kalkulačního vzorce předplňovaná pro pracovní výkony v kusovníku (tabulky vztahů artiklu)

¨ směrování referenčního artiklu – předplňované směrování referenčního artiklu (vstup/výstup)

¨ využívat varianty operací – volba Ano/Ne – parametr, který dovoluje založit více referenčních artiklů se stejnou technologickou operací

¨ předplňovat číslo varianty – volba Ano/Ne – pokud je parametr nastaven na Ano, pak se při pořizování nového referenčního artiklu se stejnou technologickou operací předplní varianta o jedna větší než má největší varianta s touto operací

¨ vstupy a výstupy – definice inicializačního druhu operace pro nové technologické operace (v tomto druhu operace se definují algoritmy pro plnění aktuálních či statistických hodnot z událostí vstupů a výstupů)

¨ předplňovat min. ve směně – hodnota, která inicializuje atribut „Min.“ ve směně (při generování výrobních úkolů)

¨ vytěžovat linky – volba Ano/Ne – při volbě Ano se respektuje obsazení času linky jinými zakázkami (tj. nedochází k překryvu výrobních úkolů v harmonogramu výroby)

¨ kopírovat vždy vztažené artikly – volba Ano/Ne – při kopírováním operace referenčního artiklu zároveň vždy kopírovat všechny vztažené artikly varianty

¨ maska org. sel. – jedná se o masku organizačního selektoru. Tento atribut má vazbu do činnosti Artikly výroby do záložky Stav skladu. Pokud zde nebude žádná maska zadána, pak se na této záložce zobrazí všechny zapsané údaje. Pokud zde bude maska vyplněna, pak se na dané záložce zobrazí pouze údaje, ve kterých se nachází organizační selektor uvedený zde v masce. Je zde možno uvést přímo konkrétní organizační selektor nebo identifikaci zapsat stejným způsobem, který se používá ve výběrových záložkách, např. první písmeno má být B a na čtvrté pozici A, pak bude maska zapsáno B___A (B, tři podtržítka a písmeno A).

Datový model

  • TPPARAM Parametry výroby
    • OBCENSKP Cenová skupina obchodovatelného artiklu
    • TPSABPRC Šablona procesu technologického postupu

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Cenové skupiny | Přehled cenových skupin obchodovatelného artiklu
F2 | Druhy operací | Přehled druhů operací
F2 | Šablony procesů | Šablony procesů

    Formulář

    Formulář činnosti - Šablony procesů
Cenová skupina | Identifikace cenové skupiny
 | Název cenové skupiny
Šablona | Šablona používaná při generování jednokrokových technologických postupů
Název šablony | Název šablony procesu technologického postupu
Hodin výk. normy | Počet hodin, za které se uvádí výkonová norma
Obvyklé množství | Obvyklé množství pilotního artiklu v tabulce artiklů
Pracovní náklady zahrnují | Rozlišení, zda celkové náklady zahrnují mzdové či osobní náklady
Předplňovat KV pro ref.artikl | Identifikace kalkulačního vzorce předplňovaná pro výstupy v kusovníku
Předplňovat KV pro vztaž.artikl | Identifikace proměnné kalkulačního vzorce předplňovaná v kusovníku
Předplňovat KV pro pracovní výkon | Identifikace proměnné kalkulačního vzorce předplňovaná pro pracovní výkony v kusovníku
Směrování referenčního artiklu | Předplňované směrování referenčního artiklu
Využívat varianty operací | Možná existence referenčních artiklů se stejnou tech.operací
Předplňovat číslo varianty | Předplňovat číslo varianty při vstupu referenčního artiklu
Vstupy a výstupy | Identifikátor druhu operace
Předplňovat min. ve směně | Předplňovat minimální čas v rozdělené směně při generování úkolů zakázky
Vytěžovat linky | Při výpočtu výroby respektovat obsazení času linky jinými zakázkami
Kopírovat vždy vztažené artikly | Při kopírování operace referenčního artiklu kopírovat vždy všechny vztažené artikly varianty

    Viz.také

    Cenové skupiny | Druhy operací | Šablony procesů


Třídy výrobního artiklu

Popis

V současnosti nepříliš využívaná činnost. Definuje se identifikace a název třídy výrobního artiklu.

Datový model

  • TPVYROBT Třída výrobního artiklu

    • Formulář

    Formulář činnosti - Šablony procesů
Mřížka [Třídy výrobního artiklu]
Třída | Identifikace třídy výrobního artiklu
 | Název třídy výrobního artiklu
Poznámka | Poznámka

    Mřížka [Třídy výrobního artiklu] činnosti - Šablony procesů

    Mřížka [Třídy výrobního artiklu] činnosti - Šablony procesů
Třída | Identifikace třídy výrobního artiklu
Název třídy | Název třídy výrobního artiklu

    Atributy tisku

    Základní údaje
Třída | Identifikace třídy výrobního artiklu | TPVYROBT_tp21id | C(3)
Název třídy | Název třídy výrobního artiklu | TPVYROBT_tp21naztri | C(40)
Poznámka | Poznámka | TPVYROBT_tp21koment | M


Trasy

Popis

Tato činnost umožňuje uživateli nadefinovat si jednotlivé trasy výroby a k nim zdrojové a cílové umístění skladového úložiště.

Datový model

  • TPTRASY Výrobní trasa
    • TPLINKA Výrobní linka / stroj / skladové úložiště výroby
    • TPLINKA Výrobní linka / stroj / skladové úložiště výroby (alias TPLINKA2)

    • Formulář

    Formulář činnosti - Výrobní linky a stroje
Mřížka [Trasy]
Trasa | Identifikace trasy
 | Popis trasy
Zdroj | Identifikace skladového úložiště
 | Název výrobní linky
Cíl | Identifikace skladového úložiště
 | Název výrobní linky

    Mřížka [Trasy] činnosti - Výrobní linky a stroje

    Mřížka [Trasy] činnosti - Výrobní linky a stroje
Trasa | Identifikace trasy
Popis trasy | Popis trasy
Zdroj | Identifikace skladového úložiště
Cíl | Identifikace skladového úložiště
Název zdrojového úložiště | Název výrobní linky
Název cílového úložiště | Název výrobní linky

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Výrobní linky a stroje | Seznam výrobních linek a strojů

    Atributy tisku

    Základní údaje
Trasa | Identifikace trasy | TPTRASY_tp22id | C(6)
Popis trasy | Popis trasy | TPTRASY_tp22naztra | C(40)
Zdroj | Identifikace skladového úložiště | TPTRASY_tp17id | C(6)
Název zdrojového úložiště | Název výrobní linky | TPLINKA_tp13linka | C(40)
Cíl | Identifikace skladového úložiště | TPTRASY_tp17id2 | C(6)
Název cílového úložiště | Název výrobní linky | TPLINKA2_tp13linka | C(40)

    Viz.také

    Výrobní linky a stroje


Šablony procesů

Popis

V této činnosti uživatel definuje šablony, které přímo souvisí s určitým druhem procesu (např. šablona pro jednu operaci a k tomu připojen druh procesu „výrobní proces o jedné operaci“). Ke každé šabloně si uživatel vytvoří diagram šablony (menu Volby nebo klávesa F7). Diagram šablony se definuje shodným způsobem jako diagram procesu.

Definice šablon pak uživatel využije při vytváření jednotlivých technologických postupů.

Datový model

  • TPSABPRC Šablona procesu technologického postupu
    • BWUZIVAT Uživatel systému
    • SPTYP Druh procesu/operace (alias SPTYP2)

    • Formulář

    Formulář činnosti - Druhy procesů
Mřížka [Šablony]
Šablona | Identifikace šablony procesu technologického postupu
Název šablony | Název šablony procesu technologického postupu
Proces | Identifikátor druhu procesu
 | Název druhu procesu
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Poznámka | Poznámka

    Mřížka [Šablony] činnosti - Druhy procesů

    Mřížka [Šablony] činnosti - Druhy procesů
Šablona | Identifikace šablony procesu technologického postupu
Název šablony | Název šablony procesu technologického postupu
Uživatel | Jméno uživatele systému

    Vyvolávané činnosti

    K. | Činnost | Popis
F7 | Diagram šablony | Diagram šablony
F2 | Druhy procesů | Přehled druhů procesů

    Atributy tisku

    Základní údaje
Šablona | Identifikace šablony procesu technologického postupu | TPSABPRC_tp25id | C(6)
Název šablony | Název šablony procesu technologického postupu | TPSABPRC_tp25nazsab | C(40)
Druh procesu | Identifikátor druhu procesu | TPSABPRC_sp07idtypd | C(6)
Název druhu procesu | Název druhu procesu | SPTYP2_sp07text | C(30)
Poznámka | Poznámka | TPSABPRC_tp25koment | M
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | TPSABPRC_sp00datzap | T

    Viz.také

    Diagram šablony | Druhy procesů


Kalkulační vzorce a proměnné

Popis

Tato činnost umožňuje uživateli nadefinovat si jednotlivé kalkulační vzorce nebo proměnné. Kalkulační vzorec se pak následně přiřazuje při definici referenčního artiklu a v podstatě určuje způsob ocenění. U každého kalkulačního vzorce se zadává:

¨ KV - identifikace a název kalk. vzorce

¨ typ – může nabývat hodnot kalkulační vzorec nebo proměnná v kalkulačním vzorci. Kalkulační vzorec u referenčního artiklu vypovídá o tom, podle jakého vzorce se bude vypočítávat ocenění výstupu referenčního artiklu. Proměnná kalkulačního vzorce u vztaženého artiklu nebo u pracovních výkonů vypovídá o tom, jakým způsobem bude vstup zahrnut do výpočtu ocenění výstupu refer. artiklu dle kalkulačního vzorce.

¨ libovolná poznámka

Na záložce „výrazy kalkulačního vzorce“ se definují vlastní výrazy, podle kterých se pak počítá. U každého výrazu se zadává:

¨ platnost od – do

¨ linka – číslo výrobní linky (jen v případě, že přímo souvisí s výrazem daného kalkulačního vzorce)

¨ výraz

¨ poznámka

Výraz kalkulačního vzorce může vypadat např. takto:

([P1] + [P2] - [P3]) * 1,3 kde platí, že:

P1= vstupní materiál (vztažené artikly)

P2 = pracovní výkony

P3 = dále použitelný odpad

násobení 1,3 = režijní náklady

Pokud chce uživatel v kalkulačním vzorci použít konstanty, je nutno pro tuto možnost využít činnosti obecné předkontace. Výraz kalkulačního vzorce může pak vypadat např. takto:

[P2]+[P1]*(([kv-rv]+[kv-rs])/100) kde platí, že:

kv, rv a rs jsou hodnoty z obecných předkontací. Obecná předkontace je nadefinována jako „kv“ – konstanty pro KV a obsahuje tyto položky:

¨ rs – režie správní

¨ rv – režie výrobní

Datový model

  • TPKALK Kalkulační vzorec / proměnná kalkulačního vzorce
    • BWUZIVAT Uživatel systému

    • Formulář

    Formulář činnosti - Obecné předkontace
Mřížka [Kalkulační vzorce a proměnné]
KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
Název KV | Název kalkulačního vzorce / název proměnné kalkulačního vzorce
Listovací rámeček
Stránka #1 Kalkulační vzorce a proměnné
Typ | Typ - kalkulační vzorec / proměnná v kalkulačním vzorci
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Poznámka | Poznámka
Stránka #2 Výrazy kalkulačního vzorce
Mřížka [Výrazy kalkulačního vzorce]
Platnost od | Datum platnosti výrazu kalkulačního vzorce od
do | Datum platnosti výrazu kalkulačního vzorce do
Linka | Číslo výrobní linky, resp. stroje
Název linky | Název výrobní linky
Výraz | Výraz kalkulačního vzorce
Poznámka | Poznámka

    Mřížka [Kalkulační vzorce a proměnné] činnosti - Obecné předkontace

    Mřížka [Kalkulační vzorce a proměnné] činnosti - Obecné předkontace
KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
Název KV | Název kalkulačního vzorce / název proměnné kalkulačního vzorce
Typ | Typ - kalkulační vzorec / proměnná v kalkulačním vzorci

    Mřížka [Výrazy kalkulačního vzorce] činnosti - Obecné předkontace

    Mřížka [Výrazy kalkulačního vzorce] činnosti - Obecné předkontace
Výraz | Výraz kalkulačního vzorce
Platnost od | Datum platnosti výrazu kalkulačního vzorce od
do | Datum platnosti výrazu kalkulačního vzorce do
Linka | Číslo výrobní linky, resp. stroje
Název linky | Název výrobní linky

    Vyvolávané činnosti

    K. | Činnost | Popis
- | Obecné předkontace | Seznam obecných předkontací
F2 | Výrobní linky a stroje | Seznam výrobních linek a strojů

    Atributy tisku

    Základní údaje
KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce | TPKALK_tp27id | C(3)
Název KV | Název kalkulačního vzorce / název proměnné kalkulačního vzorce | TPKALK_tp27nazrol | C(40)
Typ | Typ - kalkulační vzorec / proměnná v kalkulačním vzorci | Výpočet | C(29)
Poznámka | Poznámka | TPKALK_tp27koment | M
Uživatel | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | TPKALK_sp00datzap | T

    Při pohybu v Výrazy kalkulačních vzorců
KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce | TPKALKVR_tp27id | C(3)
Platnost od | Datum platnosti výrazu kalkulačního vzorce od | TPKALKVR_tp28datod | D
do | Datum platnosti výrazu kalkulačního vzorce do | TPKALKVR_tp28datdo | D
Výraz | Výraz kalkulačního vzorce | TPKALKVR_tp28vyraz | M
Poznámka | Poznámka | TPKALKVR_tp28koment | M
Číslo linky | Číslo výrobní linky, resp. stroje | TPKALKVR_tp13id | C(6)

    Viz.také

    Obecné předkontace | Výrobní linky a stroje


Tabulky vztahů artiklů

Popis

Tabulka vztahů artiklů obsahuje definice vztahů mezi vstupy a výstupy technologických operací (pro tabulku vztahů můžeme používat i termín „kusovník“). Vlastní definice vztahů se definují přímo na záložce „vztahy“. Ke každému artiklu výroby (referenční artikl) odpovídá určité množství (vztažené artikly referenčního artiklu).

Datový model

  • TPTAB Tabulka vztahů artiklů výroby

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Artikly výroby | Vstup artiklů výroby
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy výrobních linek | Číselník druhů výrobních linek

    Formulář

    Formulář činnosti - Druhy artiklů
Mřížka [Tabulka]
Listovací rámeček
Stránka #1 Tabulka
Tabulka | Identifikace tabulky artiklu výroby
 | Název tabulky vztahu artiklů
Komentář | Komentář k tabulce artiklu výroby
Stránka #2 Vztahy
Mřížka [Vztahy]
Dr.stroje | Identifikace druhu stroje
Název druhu stroje | Název druhu stroje
 | Identifikace druhu artiklu
Artiklu výroby | Identifikace artiklu
Název artiklu | Název artiklu
Množství | Množství artiklu, které se má vyrobit
MJ | Identifikátor měrné jednotky
 | Identifikace druhu artiklu
Odpovídá množství | Identifikace artiklu
Název artiklu | Název artiklu
Množství | Množství artiklu potřebné k výrobě množství svázaného artiklu
MJ | Identifikátor měrné jednotky
Komentář | Komentář

    Mřížka [Tabulka] činnosti - Druhy artiklů

    Mřížka [Tabulka] činnosti - Druhy artiklů
Tabulka | Identifikace tabulky artiklu výroby
Název tabulky | Název tabulky vztahu artiklů

    Mřížka [Vztahy] činnosti - Druhy artiklů

    Mřížka [Vztahy] činnosti - Druhy artiklů
Tabulka | Identifikace tabulky artiklu výroby
Dr.stroje | Identifikace druhu stroje
Druh | Identifikace druhu artiklu
Artikl výroby | Identifikace artiklu
Množství | Množství artiklu, které se má vyrobit
MJ | Identifikátor měrné jednotky
Množství | Množství artiklu potřebné k výrobě množství svázaného artiklu
MJ | Identifikátor měrné jednotky
Druh | Identifikace druhu artiklu
Artikl výroby | Identifikace artiklu
Název artiklu | Název artiklu
Název artiklu | Název artiklu
Název druhu stroje | Název druhu stroje

    Atributy tisku

    Základní údaje
Tabulka | Identifikace tabulky artiklu výroby | TPTAB_tp14id | C(13)
Název tabulky | Název tabulky vztahu artiklů | TPTAB_tp14naztab | C(40)
Komentář | Komentář k tabulce artiklu výroby | TPTAB_tp14koment | M
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Název druhu stroje | Název druhu stroje | TPLINKAD_tp12linka | C(40)
Měrná jednotka | Identifikátor měrné jednotky | TPVYROB_sp24idmj2 | C(3)
Název artiklu | Název artiklu | SPARTIKN2_sp62artikl | C(60)
Měrná jednotka | Identifikátor měrné jednotky | TPVYROB2_sp24idmj2 | C(3)

    Při pohybu v Vztahy
Druh artiklu | Identifikace druhu artiklu | TPTABP_sp61id | C(3)
Artikl | Identifikace artiklu | TPTABP_sp60id | C(13)
Dr.stroje | Identifikace druhu stroje | TPTABP_tp12id | C(6)
Množství | Množství artiklu, které se má vyrobit | TPTABP_tp15mnoz | N(14,6)
Druh | Identifikace druhu artiklu | TPTABP_sp61id2 | C(3)
Artikl | Identifikace artiklu | TPTABP_sp60id2 | C(13)
Množství | Množství artiklu potřebné k výrobě množství svázaného artiklu | TPTABP_tp15mnoz2 | N(14,6)
Komentář | Komentář | TPTABP_tp15koment | M

    Viz.také

    Artikly výroby | Druhy artiklů | Druhy výrobních linek


Tabulky pracovních výkonů

Popis

Pro každý referenční artikl je definována tabulka pracovních výkonů (jen zřídka je použita jedna tabulka pracovních výkonů pro více referenčních artiklů, i přesto, že IS BM to umožňuje). Tabulka pracovních výkonů obsahuje výčet pracovních výkonů nutných k realizaci referenčního artiklu. Na záložce „pracovní výkony“ se definují konkrétní výkony. Atribut „profese“ odkazuje do komponenty mezd, přiřazuje pracovnímu výkonu pracovní místo, které je ohodnoceno hodinovou mzdou. Další důležitý atribut je atribut „čas“, který eviduje čas potřebný k provedení pracovního výkonu. Konstantní čas trvání pracovního výkonu se používá v případě, že se jedná o pracovní výkon nezávislý na počtu vyráběných výrobků. Čas podle délky kroku je vypočítáván v závislosti na počtu vyráběných výrobků podle tabulky vztahů pracovních výkonů. Atribut „procento kroku“ (proc.kr.) definuje podíl času, který věnuje uvedená profese danému kroku pracovního výkonu (např. pokud se pracovník v určitý čas věnuje zároveň práci na více výrobních linkách).

Datový model

  • TPPROFTB Tabulka pracovních výkonů výroby

    • Formulář

    Formulář činnosti - Druhy artiklů
Mřížka [Tabulky pracovních výkonů]
Listovací rámeček
Stránka #1 Tabulky pracovních výkonů
Tabulka | Identifikátor tabulky pracovních výkonů
Název tabulky | Název tabulky pracovních výkonů
Poznámka | Poznámka
Stránka #2 Pracovní výkony
Mřížka [Pracovní výkony]
Dr.stroje | Identifikace druhu stroje
Název druhu stroje | Název druhu stroje
Varianta | Varianta technologické operace
Pořadí | Pořadí zobrazení pracovního výkonu v mřížce
Profese | Identifikace pracovní funkce (zařazení)
 | Popis pracovní funkce (pracovního zařazení)
 | Počet pracovníků provádějících krok
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
Čas | Čas potřebný k provedení jednoho kroku
Konst. | Konstantní čas na provedení kroku (např. seřízení)
Proc. kr. | Výkon práce jako procento času trvání kroku
Pomocné číslo | Pomocné číslo
Proc. prémií | Procento prémií
Základ | Firemní mzda hodinová
Prémie | Mzdové náklady - prémie
Celkem | Mzdové náklady celkem
Mzda 1 prac. | Osobní náklady - základ
Mzd.nákl. | Osobní náklady - prémie
S odvody | Osobní náklady celkem
Stránka #3 Výběr
Tabulka | Identifikátor tabulky pracovních výkonů
Název tabulky | Název tabulky pracovních výkonů
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Tabulky pracovních výkonů] činnosti - Druhy artiklů

    Mřížka [Tabulky pracovních výkonů] činnosti - Druhy artiklů
Tabulka | Identifikátor tabulky pracovních výkonů
Název tabulky | Název tabulky pracovních výkonů

    Mřížka [Pracovní výkony] činnosti - Druhy artiklů

    Mřížka [Pracovní výkony] činnosti - Druhy artiklů
TB-PV | Identifikátor tabulky pracovních výkonů
Varianta | Varianta technologické operace
Dr.stroje | Identifikace druhu stroje
Profese | Identifikace pracovní funkce (zařazení)
Název profese | Popis pracovní funkce (pracovního zařazení)
Název druhu stroje | Název druhu stroje
Počet | Počet pracovníků provádějících krok
Čas | Čas potřebný k provedení jednoho kroku
Konstantní | Konstantní čas na provedení kroku (např. seřízení)
Proc. kr. | Výkon práce jako procento času trvání kroku
Proc. prémií | Procento prémií

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Artikly výroby | Vstup artiklů výroby
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Pracovní místa skut. a typová | Popis pracovní funkce (zařazení)

    Atributy tisku

    Základní údaje
Tabulka | Identifikátor tabulky pracovních výkonů | TPPROFTB_tp30id | C(13)
Název tabulky | Název tabulky pracovních výkonů | TPPROFTB_tp30naztab | C(40)
Poznámka | Poznámka | TPPROFTB_tp30koment | M
Profese | Identifikace pracovní funkce (zařazení) | MZPRACFU_mz31id | C(6)
Název profese | Popis pracovní funkce (pracovního zařazení) | MZPRACFU_mz31pracfu | C(40)
Název druhu stroje | Název druhu stroje | TPLINKAD4_tp12linka | C(40)
Název artiklu | Název artiklu | SPARTIKN3_sp62artikl | C(60)
Tř. KZAM | Třída podle klasifikace zaměstnání | MZPRACFU_mz31kzam | C(5)
Identifikace | Jednoznačná identifikace kalendáře | MZPRACFU_mz25id | C(6)
Identifikace | Identifikace tarifní stupnice | MZPRACFU_mz23id | C(6)
Třída | Tarifní třída (1-99) | MZPRACFU_mz24trida | C(2)
Umístění | Identifikace umístění mezd | MZPRACFU_mz79id | C(6)
Sazba | Firemní mzda hodinová | MZTARTRI_mz24hodmzd | N(8,2)
Min. měsíční mzda | Minimální mzda měsíční | MZTARTRI_mz24minmzd | N(5)

    Při pohybu v Pracovní výkon
Dr.stroje | Identifikace druhu stroje | TPPROFOP_tp12id | C(6)
Druh artiklu | Identifikace druhu artiklu | TPPROFOP_sp61id | C(3)
Artikl | Identifikace artiklu | TPPROFOP_sp60id | C(13)
KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce | TPPROFOP_tp27id | C(3)
Počet | Počet pracovníků provádějících krok | TPPROFOP_tp06pocet | N(3)
Čas na oper. | Čas potřebný k provedení jednoho kroku | Výpočet | C(17)
Konstantní | Konstantní čas na provedení kroku (např. seřízení) | TPPROFOP_tp06konstc | N(8,2)
Proc. čas oper. | Výkon práce jako procento času trvání kroku | TPPROFOP_tp06procca | N(6,2)
Proc. prémií | Procento prémií | TPPROFOP_tp06procpr | N(6,2)

    Viz.také

    Artikly výroby | Druhy artiklů | Pracovní místa skut. a typová


OBECNÁ KOMPONENTA

Popis

Užití této komponenty se předpokládá v souvislosti se specifickou problematikou daného uživatele, která není řešena ostatními komponentami, mnohdy jako dočasné řešení. Rozsah funkcí této komponenty poměrně koresponduje s vlastnostmi standardizované komponenty.

Viz.také

Události obecné komponenty | Aktuální hodnoty obecné komp. | Artikl obecné komponenty | Umístění obecné komponenty


Události obecné komponenty

Popis

Uživateli se zobrazují pouze události vytvořené v obecné komponentě. Události je možné členit zejména na příjmy a výdeje nebo dle vztahu ke statistice. Mezi nejvýznamnější atributy kromě standardních patří množství a cena. Programový kód zajišťuje předplnění data aktuálním datem.

Po stisku záložky "saldo" je možno si u každé události prohlédnout hodnoty, které vytvářejí saldokonto. Zobrazuje se vždy druh hodnoty, vyjádření dané konkrétní hodnoty (položka hodnota), vyjádření dané hodnoty v procesu, jehož je daná událost součástí a aktuální hodnota. Aktuální hodnota je souhrnné vyjádření dané hodnoty za obecnou komponentu v celém informačním systému.

Datový model

  • OKUDALOS Událost obecné komponenty
    • OKARTIKL Artikl obecné komponenty
      • SPMJN Měrná jednotka v jazyce
      • SPARTIKN Název artiklu
    • OKUMISTE Umístění pro obecnou komponentu
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)
    • ADADSAT Adresát
    • SPPRISTU Přístupové právo uživatele k věci
    • BWUZIVAT Uživatel systému
    • SPPRCOD Operace procesu
      • SPTYP Druh procesu/operace
      • SPPRC Proces

    • Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^S | SUMY - obecná komponenta |
F2 | Adresář | Přehled adresátů
F2 | Artikl obecné komponenty | Přehled artiklu obecné komponenty
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Umístění obecné komponenty | Přehled umístění obecné komponenty

    Formulář

    Formulář činnosti - Druhy procesů
Mřížka [Událost obecné komponenty]
Listovací rámeček
Stránka #1 Událost obecné komponenty
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
 | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Příznak příjem / výdej
 | Název druhu operace
Datum | Datum
 | Popis události obecné komponenty
Vztah ke statistice | Vztah ke statistice - náklady,výnosy,....
Adresát | Identifikace adresáta
 | Název adresáta
Umístění | Identifikace umístění pro obecnou komponentu
 | Název umístění
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
MJ | Identifikátor měrné jednotky
Název měrné jednotky | Název měrné jednotky
Cena | Cena za jednotku
Množství | Množství
Celková cena | Celková cena
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Saldo
Mřížka [Saldo]
Druh | Identifikace druhu saldokontní hodnoty procesu
Název druhu | Název druhu saldokontní hodnoty procesu
Artikl | Identifikace artiklu
Druh artiklu | Identifikace druhu artiklu
Adresát | Identifikace adresáta
Umístění | Umístění
Hodnota | Aktuální hodnota procesu
Hodnota procesu | Saldokontní hodnota v procesu
Stránka #3 Výběr
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu od
Číslo procesu do | Pořadové číslo procesu do
 | Identifikátor druhu operace
Druh procesu | Identifikátor druhu procesu
Datum | Datum od
do | Datum do
 | Příznak příjem / výdej
Popis | Popis události obecné komponenty
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Umístění | Identifikace umístění pro obecnou komponentu
Vztah ke statistice | Vztah ke statistice - náklady,výnosy,....
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsal | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Událost obecné komponenty] činnosti - Druhy procesů

    Mřížka [Událost obecné komponenty] činnosti - Druhy procesů
Označování | Označení záznamu
P/V | Příznak příjem / výdej
Vztah ke statistice | Vztah ke statistice - náklady,výnosy,....
Adresát | Identifikace adresáta
Umístění | Identifikace umístění pro obecnou komponentu
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Popis | Popis události obecné komponenty
Množství | Množství
Celková cena | Celková cena
Název adresáta | Název adresáta
Název artiklu | Název artiklu
Název umístění | Název umístění
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh | Identifikátor druhu operace
Datum | Datum
Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující

    Mřížka [Saldo] činnosti - Druhy procesů

    Mřížka [Saldo] činnosti - Druhy procesů
Druh | Identifikace druhu saldokontní hodnoty procesu
Datum | Datum události
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh operace | Identifikátor druhu operace
Adresát | Identifikace adresáta
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Umístění | Umístění
Hodnota | Aktuální hodnota procesu
Hodnota procesu | Saldokontní hodnota v procesu

    Atributy tisku

    Základní údaje
Rok | Rok v identifikaci procesu | OKUDALOS_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | OKUDALOS_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | OKUDALOS_sp33cisd | C(8)
Komponenta | Identifikace komponenty | OKUDALOS_sp06idsubs | C(3)
Druh | Identifikátor druhu operace | OKUDALOS_sp07idtyp | C(6)
Pořadí | Pořadí stejného druhu operace v jednom procesu | OKUDALOS_sp33porad | N(2)
Příjem / výdej | Příznak příjem / výdej | Výpočet | C(6)
Název druhu operace | Název druhu procesu | SPTYP_sp07text | C(30)
Datum | Datum | OKUDALOS_ok01datum | D
Popis | Popis události obecné komponenty | OKUDALOS_ok01text | C(40)
Vztah ke statistice | Vztah ke statistice - náklady,výnosy,.... | Výpočet | C(7)
Adresát | Identifikace adresáta | OKUDALOS_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Název státu | Název státu. | ADSTATY_ad05stat | C(30)
Umístění | Identifikace umístění pro obecnou komponentu | OKUDALOS_ok03id | C(6)
Název umístění | Název umístění | OKUMISTE_ok03text | C(40)
Druh artiklu | Identifikace druhu artiklu | OKUDALOS_sp61id | C(3)
Artikl | Identifikace artiklu | OKUDALOS_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
MJ | Identifikátor měrné jednotky | OKARTIKL_sp24idmj | C(3)
Cena za jednotku | Cena za jednotku | OKARTIKL_ok02cenaj | N(7,2)
Název měrné jednotky | Název měrné jednotky | SPMJN_sp58mjnaz | C(40)
Množství | Množství | OKUDALOS_ok01mnozs | N(12,3)
Celková cena | Celková cena | OKUDALOS_ok01cena | N(12,3)
Obchodní selektor | Identifikátor obchodního selektoru | OKUDALOS_sp10idzak | C(9)
Organizační selektor | Identifikátor organizačního selektoru. | OKUDALOS_sp11idzak | C(9)
Technicko-věcný selektor | Identifikátor technicko-věcného selektoru. | OKUDALOS_sp20idzak | C(9)
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | OKUDALOS_sp00datzap | T

    Viz.také

    OZNAČOVÁNÍ | SUMY - obecná komponenta | Adresář | Artikl obecné komponenty | Druhy artiklů | Druhy operací | Druhy procesů | Kategorie adresátů | Obchodní selektor | Organizační selektor | Technicko-věcný selektor | Umístění obecné komponenty


Aktuální hodnoty obecné komp.

Popis

Zobrazují se aktuální hodnoty daného druhu hodnoty za jednotlivé artikly nebo adresáta, podle toho, jak si uživatel nadefinuje záložku výběr.

Datový model

  • OKAH Aktuální hodnota xy
    • OKARTIKL Artikl obecné komponenty
    • OKUMISTE Umístění pro obecnou komponentu
      • SPPRISTU Přístupové právo uživatele k věci
    • ADADSAT Adresát
    • SPSTATDI Druh hodnoty

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresář | Přehled adresátů
F2 | Artikl obecné komponenty | Přehled artiklu obecné komponenty
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Umístění obecné komponenty | Přehled umístění obecné komponenty

    Formulář

    Formulář činnosti - Kategorie adresátů
Mřížka [Aktuální hodnoty obecné komponety]
Listovací rámeček
Stránka #1 Aktuální hodnoty
Druh hodnoty | Identifikace druhu hodnoty
 | Název druhu hodnoty
Adresát | Identifikace adresáta
 | Název adresáta
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Umístění | Identifikace umístění pro obecnou komponentu
 | Název umístění
Aktuální hodnota | Aktuální hodnota
Stránka #2 Výběr
Druh hodnoty | Identifikace druhu hodnoty
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Umístění | Identifikace umístění pro obecnou komponentu
 | Název umístění
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Aktuální hodnoty obecné komponety] činnosti - Kategorie adresátů

    Mřížka [Aktuální hodnoty obecné komponety] činnosti - Kategorie adresátů
Druh hodnoty | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Adresát | Identifikace adresáta
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Umístění | Identifikace umístění pro obecnou komponentu
Aktuální hodnota | Aktuální hodnota
Název adresáta | Název adresáta
Název artiklu | Název artiklu
Název umístění | Název umístění

    Atributy tisku

    Základní údaje
Druh hodnoty | Identifikace druhu hodnoty | OKAH_sp67id | C(3)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)
Adresát | Identifikace adresáta | OKAH_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Druh artiklu | Identifikace druhu artiklu | OKAH_sp61id | C(3)
Artikl | Identifikace artiklu | OKAH_sp60id | C(13)
Název artiklu | Název artiklu | OKARTIKL_sp60artikl | C(60)
Umístění | Identifikace umístění pro obecnou komponentu | OKAH_ok03id | C(6)
Název umístění | Název umístění | OKUMISTE_ok03text | C(40)
Aktuální hodnota | Aktuální hodnota | OKAH_ok07hodnot | N(20,4)

    Viz.také

    Adresář | Artikl obecné komponenty | Druhy artiklů | Druhy hodnot | Kategorie adresátů | Umístění obecné komponenty


Artikl obecné komponenty

Popis

Uživateli se zobrazuje číselník artiklů obecné komponenty, kde je stěžejní atribut identifikace a název artiklu. Jako další atributy má uživatel k dispozici měrnou jednotku artiklu, jeho cenu a identifikace technického a účetního selektoru.

Záložka "názvy artiklu" umožňuje využití cizojazyčnosti a možnost překladu názvu artiklu do zvoleného cizího jazyka.

Záložky "stav - umístění" a "stav - adresáti" poskytuje uživateli informace o aktuálních hodnotách daného artiklu ve vztahu k umístění obecné komponenty a k jednotlivým adresátům.

Datový model

  • OKARTIKL Artikl obecné komponenty
    • SPARTIKN Název artiklu
    • SPMJN Měrná jednotka v jazyce
    • SPARTIKD Druh artiklu
    • SPSETV Technicko-věcný selektor

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Události správy artiklu |
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
- | Dokumenty artiklu | Dokumenty artiklu
- | Legenda palety barev |
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Kategorie událostí správy artiklu | Přehled kategorií událostí správy artiklu
F2 | Měrné jednotky | Číselník měrných jednotek
F2 | Palety barev kategorií | Palety barev kategorií
F2 | Spojení | Seznam spojení za adresáta.
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

     | Formulář činnosti - Spojení
 | Mřížka [Artikl]
 |  | Identifikace druhu artiklu
 | Artikl | Identifikace artiklu
 | Název artiklu | Název artiklu
 | Listovací rámeček
 | Stránka #1 Artikl
 | MJ | Identifikátor měrné jednotky
 | Cena | Cena za jednotku
 |  | Název měrné jednotky
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 |  | Název technicko-věcného selektoru.
 | Účet.sel. | Účetní selektor artiklu
 | Stránka #2 Rozš. údaje
 | Volné číslo I | Volně použitelné číslo uživatelem
 | Volné číslo II | Volně použitelné číslo uživatelem
 | Volné číslo III | Volně použitelné číslo uživatelem
 | Volný text I | Volně použitelný text uživatelem
 | Volný text II | Volně použitelný text uživatelem
 | Volný text III | Volně použitelný text uživatelem
 | Stránka #3 Názvy artiklu
 | Mřížka [Názvy artiklu v jazycích]
 | Jazyk | Identifikace jazyka
 | Název artiklu | Název artiklu
 | Stránka #4 Stav - umístění
 | Mřížka [Stav]
 | Druh hodnoty | Identifikace druhu hodnoty
 |  | Název druhu hodnoty
 | Umístění | Identifikace umístění pro obecnou komponentu
 |  | Název umístění
 | Aktuální hodnota | Aktuální hodnota
 | Stránka #5 Stav - adresáti
 | Mřížka [Stav - adresáti]
 | Druh hodnoty | Identifikace druhu hodnoty
 |  | Název druhu hodnoty
 | Adresát | Identifikace adresáta
 |  | Název adresáta
 | Aktuální hodnota | Aktuální hodnota
 | Stránka #6 Kategorie artiklu
 | Mřížka [Kategorie artiklu]
 |  | Kategorie
Identifikace kategorie události správy artiklu |  |  | Platnost
Datum platnosti od |  |  | Platnost do
Datum platnosti do |  |  | Adresát
Identifikace adresáta |  |
Název adresáta |  |
Číslo spojení adresáta. |  |  | Popis
Popis události |  |  | Poznámka
Poznámka |  |  | Zapsal
Jméno uživatele systému |  |  | Datum a čas zápisu
Datum a čas zápisu záznamu události
 | Stránka #7 Výběr
 | Druh artiklu | Identifikace druhu artiklu
 | Artikl | Identifikace artiklu
 | Název artiklu | Název artiklu
 | MJ | Identifikátor měrné jednotky
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Účet.sel. | Účetní selektor artiklu
 | Vztah ke kategorii | Vztah ke kategorii - Je=K dnešnímu datu je v kategorii, Není=K dnešnímu datu není v kategorii, Byl=Není v kategorii, ale byl, Nebyl=Není a nikdy nebyl v kategorii,Bude=Bude v kategorii
 | Kategorie | Identifikace kategorie události správy artiklu
 | Název kategorie | Název kategorie události správy artiklu
 | Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 |  | Platnost nebo neplatnost k datu
 | Paleta | Vybrat záznamy všech kategorií v paletě
 |  | Identifikace palety barev
 | Výběr | Určení výběru
 | Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Artikl] činnosti - Spojení

    Mřížka [Artikl] činnosti - Spojení
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
MJ | Identifikátor měrné jednotky
Název měrné jednotky | Název měrné jednotky

    Mřížka [Názvy artiklu v jazycích] činnosti - Spojení

    Mřížka [Názvy artiklu v jazycích] činnosti - Spojení
Jazyk | Identifikace jazyka
Název artiklu | Název artiklu

    Mřížka [Stav] činnosti - Spojení

    Mřížka [Stav] činnosti - Spojení
Druh hodnoty | Identifikace druhu hodnoty
Umístění | Identifikace umístění pro obecnou komponentu
Aktuální hodnota | Aktuální hodnota

    Mřížka [Stav - adresáti] činnosti - Spojení

    Mřížka [Stav - adresáti] činnosti - Spojení
Druh hodnoty | Identifikace druhu hodnoty
Adresát | Identifikace adresáta
Aktuální hodnota | Aktuální hodnota

    Mřížka [Kategorie artiklu] činnosti - Spojení

    Mřížka [Kategorie artiklu] činnosti - Spojení
Kategorie | Identifikace kategorie události správy artiklu
Název kategorie | Název kategorie události správy artiklu
Platnost od | Datum platnosti od
Platnost do | Datum platnosti do
Adresát | Identifikace adresáta
Název adresáta | Název adresáta

    Atributy tisku

    Základní údaje
Druh artiklu | Identifikace druhu artiklu | OKARTIKL_sp61id | C(3)
Artikl | Identifikace artiklu | OKARTIKL_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
MJ | Identifikátor měrné jednotky | OKARTIKL_sp24idmj | C(3)
Název měrné jednotky | Název měrné jednotky | SPMJN_sp58mjnaz | C(40)
Cena | Cena za jednotku | OKARTIKL_ok02cenaj | N(7,2)
Tech. sel. | Identifikátor technicko-věcného selektoru. | OKARTIKL_sp20idzak | C(9)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(60)
Účetní selektor artiklu | Účetní selektor artiklu | OKARTIKL_sp00uselar | C(9)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)
Název umístění | Název umístění | OKUMISTE_ok03text | C(40)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI2_sp67druinf | C(40)
Název adresáta | Název adresáta | ADADSAT2_ad01adsat | C(100)

    Při pohybu v Aktuální hodnoty - umístění
Druh hodnoty | Identifikace druhu hodnoty | OKAH_sp67id | C(3)
Umístění | Identifikace umístění pro obecnou komponentu | OKAH_ok03id | C(6)
Aktuální hodnota | Aktuální hodnota | OKAH_ok07hodnot | N(20,4)

    Při pohybu v Aktuální hodnoty - adresát
Druh hodnoty | Identifikace druhu hodnoty | OKAH2_sp67id | C(3)
Adresát | Identifikace adresáta | OKAH2_ad01id | C(6)
Aktuální hodnota | Aktuální hodnota | OKAH2_ok07hodnot | N(20,4)

    Viz.také

    Události správy artiklu | Prezentace artiklu | Dokumenty artiklu | Legenda palety barev | Adresář | Druhy artiklů | Kategorie událostí správy artiklu | Měrné jednotky | Palety barev kategorií | Spojení | Technicko-věcný selektor


Umístění obecné komponenty

Popis

Uživateli se zobrazuje přehled umístění obecné komponenty, který uživatel využívá pouze při práci s obecnou komponentou. Jako umístění může být nadefinován sklad, účet, pokladna apod. U každého umístění se definuje jeho identifikace, název a vztah k organizačnímu a účetnímu selektoru.

Ke každému umístění je možno nadefinovat pro uživatele různá přístupová práva.

Datový model

  • OKUMISTE Umístění pro obecnou komponentu
    • SPSEOR Organizační selektor
    • SPPRISTU Přístupové právo uživatele k věci

    • Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci
F2 | Organizační selektor | Číselník organizačních selektorů

    Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Umístění]
Umístění | Identifikace umístění pro obecnou komponentu
 | Název umístění
Org. sel. | Identifikátor organizačního selektoru.
 | Název organizačního selektoru
Účet.sel. | Účetní selektor umístění

    Mřížka [Umístění] činnosti - Přístupová práva

    Mřížka [Umístění] činnosti - Přístupová práva
Umístění | Identifikace umístění pro obecnou komponentu
Název umístění | Název umístění

    Atributy tisku

    Základní údaje
Umístění | Identifikace umístění pro obecnou komponentu | OKUMISTE_ok03id | C(6)
Název umístění | Název umístění | OKUMISTE_ok03text | C(40)
Organizační selektor | Identifikátor organizačního selektoru. | OKUMISTE_sp11idzak | C(9)
Název organizačního selektoru | Název organizačního selektoru | SPSEOR_sp11text | C(60)
Účetní selektor umístění | Účetní selektor umístění | OKUMISTE_sp00uselum | C(9)

    Viz.také

    Přístupová práva | Organizační selektor


SYSTÉM

Popis

Souhrn činností, které souvisí s nadefinováním činností, které se týkají přihlášení uživatelů a správné definice jednotlivých činností, které přímo souvisí se spuštěním programu. Jsou to např. :

¨ uživatelé programu

¨ skupiny uživatelů

¨ přehled přihlášených

¨ oprávnění k činnostem

¨ parametry uživatele

¨ import balíčku

¨ seznam předloh výstupu

¨ spuštění činnosti identifikací

Viz.také

Uživatelé programu | Skupiny uživatelů | Zařazení do skupin uživatelů | Přehled přihlášených | Přehled přihlášených (SQL) | Oprávnění k činnostem | Slovník dat | Parametry uživatele | Nastavení - Souvislosti objekt | Import balíčku | Přehled balíčků | Seznam předloh výstupu | Profily spuštění předloh | Překlad textů | Spuštění činnosti identifikací | Přehled prováděných činností | WEB DEFINICE | Datový model | Uživatelské triggery | Nastavení sledování změn tabulek | Rezervované zdroje systému | Logické tiskárny | Fyzické tiskárny | Pracoviště uživatelů BM | Počítače uživatelů BM | Uložit obrázek v clipboardu | Otevřít HTML dokument | Nastavení programu BM | Přehled změn záznamů tabulek | Zprávy databázového serveru


Uživatelé programu

Popis

Tato činnost by měla být nastavena tak, že bude přístupná pouze správci systému. Slouží k definování uživatelů programu a jejich zařazení do skupin. Při jejím spuštění se nejprve zobrazí záložka výběr. Má smysl mít trvale nastaven výběr na aktivní uživatele.

Správce má možnost si jednotlivé definice uživatele prohlížet, aktualizovat a zadávat nové. Přitom vstupuje tyto atributy:

¨ Ident. - identifikaci uživatele je vhodné odvodit z rodného čísla uživatele, které se vstupuje po stisku klávesy F2. Tímto je jeho identifikace s velkou pravděpodobností jednoznačná v celé republice, což může mít význam při přenosu dat programu mezi různými organizacemi, protože tato identifikace zároveň slouží jako "elektronický podpis" informace.

¨ Uživatel - jméno uživatele systému

¨ Uživatel (úplné jméno) - úplné jméno uživatele systému (včetně titulu apod.)

¨ Počáteční heslo - počáteční heslo uživatele, tj. heslo, pod kterým se uživatel poprvé přihlásí k programu. Toto heslo si pak samozřejmě může podle svých potřeb změnit. V případě, že ho zapomene, provede správce u jeho jména inicializaci hesla, tzn. systém mu znovu přiřadí toto počáteční heslo a uživatel si ho pak může znovu změnit (v případě potřeby existuje možnost ukládat „hash“ hesla uživatele, viz. poznámka níže)

¨ E-mail - jedná se o e-mailovou adresu uživatele. Tento údaj se využívá při odesílání poštovních zásilek přes internet. V případě, že je zde adresa uživatele zadána, automaticky se k poštovním zásilkám předplňuje. V této činnosti nemá možnost uživatel tuto adresu měnit (činnost je přístupná pouze správci systému), ale pokud potřebuje změnit adresu, provede to v činnosti parametry uživatele - pod menu systém.

¨ Telefon – telefonní číslo (např. přímá linka nebo mobil) na daného uživatele

¨ Jazyk - volba jazyku. Tímto jazykem se potom budou uživateli zobrazovat názvy činností a obrazovky jednotlivých formulářů.

¨ Práva správce – pokud je zatrženo, má uživatel stejná práva jako správce (viz ve slovníku pojmů pojem „specifická práva správce“)

¨ Právo odblokování – pokud je zatrženo, má uživatel právo na odblokování systému BM, který je v dané chvíli zablokován jiným uživatelem. Blokace systému BM se provádí z hlavního menu z nabídky Volby – zablokování systému BM.

¨ Aktivní uživatel - pouze aktivní uživatel má právo přihlásit se k programu. Příznakem „neaktivní“ jsou označeny osoby, které v organizaci již nepracují, ale jejich "elektronický podpis" se vyskytuje v datech (např. osoby, které opustily firmu ...)

¨ Povolena změna hesla - příznak, zda má daný uživatel povolenu změnu hesla

¨ Explicitní WEB menu – primární identifikace prvku WEB a adresát, kterého se to týká

Po stisku záložky "skupiny uživatelů" má správce k dispozici tabulku, ve které je zobrazen seznam všech skupin a je zaškrtnuta skupina, ve které je zařazen aktuálně zobrazený uživatel.

¨ Skupina - má význam pro definování přístupových práv k jednotlivým činnostem. Každý uživatel musí být zařazen do některé skupiny uživatelů. Do stejné skupiny může být zařazeno více uživatelů, což pak znamená, že mají stejná práva při používání programu (např. skupina každý uživatel systému).

¨ Název skupiny - stručný a výstižný název skupiny

Po stisku záložky „skupiny uživatele“ je k dispozici pouze přehled těch skupin, ve kterých je daný uživatel zařazen. Záložka „přístupy k věcem“ poskytuje přehled činností, ke kterým má daný uživatel právo a jeho typ (čtení, zápis).

Poznámka:

V některých firmách potřebují využívat databázi uživatelů IS BM (tzn. jméno a heslo) zároveň i pro přihlašování do jiných programů (např. intranet, ...). BM volitelně ukládá do tabulky uživatelů systému (BWUZIVAT) při změně hesla uživatelem zadané heslo zakódované určenou hash funkcí. Před zakódováním hash funkcí se zadané heslo převede na malé znaky.

Hash funkce je transformace, která jako vstup přijímá řetězec znaků o libovolné délce a výsledkem je pak řetězec znaků s pevnou délkou, tzv. hash nebo také otisk. Hash funkce se často používají v kryptografii, kde se však na její kvalitu kladou další kritéria. Funkce je jednosměrná, je nemožné jednoznačně najít k otisku původní text.

Parametrem programu BM Preferencess->PasswordHashAlgorithm se určuje použitá hash funkce pro zakódování hesla.

1 = SHA1 (a.k.a SHA160)

2 = SHA256

3 = SHA384

4 = SHA512 *Default

5 nebo 50= MD5

6 = RIPEMD128

7 = RIPEMD256

Hash se ukládá do atributu BW01HHASH tabulky BWUZIVAT v binárním nebo hexadecimálním tvaru (při nastavení Preferencess->PasswordHashHexa=1) a číslo hash funkce se zapisuje do atributu BW01HHASHT. Pro použití hash funkcí 1 až 7 je nutné, aby v adresáři programu BM byl nainstalován soubor VFPENCRYPTION.FLL a dále je nutno na každou stanici instalovat knihovny VC++ 8.0 runtime. Použití funkce 50 (MD5) nevyžaduje instalaci žádných externích prostředků.

Možnost ukládat hash hesla uživatele je pouze ve verzích BM pod Visual Foxpro 8.0 nebo vyšší.

Datový model

  • BWUZIVAT Uživatel systému
    • SPPREDKV Význam položky obecné předkontace

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Uživatel přihlášený k serveru | Jméno a heslo uživatele přihlášeného k serveru
F7 | Inicializace hesla | Inicializace hesla uživatele podle zadání správce
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Aktualizace seznamu věcí | Aktualizace seznamu věcí s přístupem
- | Přepočet práv přístupu | Přepočet práv přístupu uživatelů k věcem
F2 | Rodné číslo | Vstup identifikace uživatele rodným číslem
F2 | Významy položek předkontací | Seznam významů položek obecných předkontací

    Formulář

    Formulář činnosti - OZNAČOVÁNÍ
Mřížka [Uživatelé]
Ident. | Identifikace uživatele systému
Uživatel | Jméno uživatele systému
Listovací rámeček
Stránka #1 Uživatelé programu
Uživatel (úplné jméno) | Úplné jméno uživatele systému
Počáteční heslo | Počáteční heslo uživatele
E-mail | E-mailová adresa uživatele
Telefon | Telefonní číslo uživatele
Jazyk | Identifikace jazyka
Práva správce | Uživatel s oprávněním správce
Právo odblokování | Uživatel s oprávněním odblokování systému BM zablokovaného jiným uživatelem
Aktivní uživatel | Aktivní uživatel (tj. smí se přihlásit do systému)
Povolena změna hesla | Povolena změna hesla
Explicitní WEB menu | Primární identifikace prvku WEB
Význam | Identifikace významu položky obecné předkontace
Popis významu | Popis významu položky obecné předkontace
Stránka #2 Skupiny uživatelů
Mřížka [Skupiny uživatelů]
Skupina | Identifikace skupiny uživatelů
Název skupiny uživatelů | Název skupiny uživatelů
 | Poznámka ke skupině uživatelů
Stránka #3 Skupiny uživatele
Mřížka [Skupiny uživatele]
Stránka #4 Přístupy k věcem
Mřížka [Přístupy k věcem]
Typ | Typ práva přístupu
 | Název práva věci s přístupem
Věc | Přistupovaná věc
 | Popis věci
Právo přístupu | Právo přístupu - Žádné,Čtení,Zápis
 | Poznámka k věci s přístupem
Stránka #5 Výběr
Ident. | Identifikace uživatele systému
Uživatel | Jméno uživatele systému
Uživatel (úplné jméno) | Úplné jméno uživatele systému
E-mail | E-mailová adresa uživatele
Telefon | Telefonní číslo uživatele
Aktivní uživatel | Aktivní uživatel (tj. smí se přihlásit do systému)
Práva správce | Uživatel s oprávněním správce
Právo odblokování | Uživatel s oprávněním odblokování systému BM zablokovaného jiným uživatelem
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Uživatelé] činnosti - OZNAČOVÁNÍ

    Mřížka [Uživatelé] činnosti - OZNAČOVÁNÍ
Označování | Označení záznamu
Uživatel | Jméno uživatele systému
Ident. | Identifikace uživatele systému
Uživatel (úplné jméno) | Úplné jméno uživatele systému
Aktivní uživatel | Aktivní uživatel (tj. smí se přihlásit do systému)
Práva správce | Uživatel s oprávněním správce
Právo odblokování | Uživatel s oprávněním odblokování systému BM zablokovaného jiným uživatelem

    Mřížka [Skupiny uživatelů] činnosti - OZNAČOVÁNÍ

    Mřížka [Skupiny uživatelů] činnosti - OZNAČOVÁNÍ
Označování | Označení záznamu
Skupina | Identifikace skupiny uživatelů
Název skupiny uživatelů | Název skupiny uživatelů

    Mřížka [Skupiny uživatele] činnosti - OZNAČOVÁNÍ

    Mřížka [Skupiny uživatele] činnosti - OZNAČOVÁNÍ
Úroveň | Úroveň vztahu
Skupina | Identifikace skupiny uživatelů
Název skupiny uživatelů | Název skupiny uživatelů

    Mřížka [Přístupy k věcem] činnosti - OZNAČOVÁNÍ

    Mřížka [Přístupy k věcem] činnosti - OZNAČOVÁNÍ
Typ | Typ práva přístupu
 | Přistupovaná věc
Popis | Popis věci
Název práva | Název práva věci s přístupem

    Atributy tisku

    Základní údaje
Ident. | Identifikace uživatele systému | BWUZIVAT_bw01uziv | C(6)
Uživatel | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Uživatel (úplné jméno) | Úplné jméno uživatele systému | BWUZIVAT_bw01jmenot | C(25)
Aktivní uživatel | Aktivní uživatel (tj. smí se přihlásit do systému) | Výpočet | C(3)
Práva správce | Uživatel s oprávněním správce | Výpočet | C(3)
Právo odblokování | Uživatel s oprávněním odblokování systému BM zablokovaného jiným uživatelem | Výpočet | C(3)
Povolena změna hesla | Povolena změna hesla | Výpočet | C(3)
E-mail | E-mailová adresa uživatele | BWUZIVAT_bw01email | C(40)
Telefon | Telefonní číslo uživatele | BWUZIVAT_bw01telef | C(40)
Význam | Identifikace významu položky obecné předkontace | BWUZIVAT_sp47id | C(6)
Popis významu | Popis významu položky obecné předkontace | SPPREDKV_sp47nazvyz | C(40)
Skupina | Identifikace skupiny uživatelů | BWODBOR_bw05ident | C(6)
Název skupiny uživatelů | Název skupiny uživatelů | BWODBOR_bw05popis | C(30)
Poznámka | Poznámka ke skupině uživatelů | BWODBOR_bw05koment | M
Typ | Typ práva přístupu | SPPRISTV_sp44typ | C(3)
Název práva | Název práva věci s přístupem | SPPRISTV_sp85nazpra | C(40)
Věc | Přistupovaná věc | SPPRISTV_sp44vec | C(6)
Popis | Popis věci | SPPRISTV_sp85text | C(40)
Poznámka | Poznámka k věci s přístupem | SPPRISTV_sp85koment | M

    Při pohybu v Skupiny uživatelů
    Úroveň Úroveň vztahu BWOVAZBS_bwa4uroven N(3)

    Při pohybu v Přístupy k věcem
    Právo přístupu Právo přístupu - Žádné,Čtení,Zápis Výpočet C(5)

    Viz.také

    Uživatel přihlášený k serveru | Inicializace hesla | OZNAČOVÁNÍ | Aktualizace seznamu věcí | Přepočet práv přístupu | Rodné číslo | Významy položek předkontací | Překlad popisu | Výběry vstupem


Skupiny uživatelů

Popis

Uživateli se zobrazuje přehled nadefinovaných skupin uživatelů a jednotlivé záložky této činnosti. Každý uživatel musí být zařazen do některé skupiny uživatelů (může být i ve více skupinách). Více uživatelů může být zařazeno do stejné skupiny, což znamená, že mají stejná práva při používání programu.

Uživatele je možno zařadit do skupiny uživatelů, která je tvořena pouze uživatelem systému. V takovém případě zařazený uživatel vlastní pouze ta přístupová práva, která jsou přímo udělena uživateli, který v tomto vztahu vystupuje jako skupina uživatelů.

Každá skupina má svůj identifikátor a název. Na záložce „uživatelé“ je přehled všech aktivních uživatelů systému a ten uživatel, který patří do dané skupiny, je označen (příznak zaškrtnutí). Na záložce „uživatelé ve skupině“ je k dispozici přehled jen těch uživatelů, kteří mají přístupové právo k dané skupině.

Zaškrtnutím uživatele na záložce „uživatelé“ je daný uživatel automaticky zařazen do dané skupiny uživatelů.

Datový model

  • BWODBOR Skupina uživatelů

    • Vyvolávané činnosti

    K. | Činnost | Popis
- | Přepočet práv přístupu | Přepočet práv přístupu uživatelů k věcem
- | Aktualizace seznamu věcí | Aktualizace seznamu věcí s přístupem

    Formulář

    Formulář činnosti - Aktualizace seznamu věcí
Mřížka [Odbornosti]
Skupina | Identifikace skupiny uživatelů
 | Název skupiny uživatelů
Listovací rámeček
Stránka #1 Skupiny uživatelů
Poznámka | Poznámka ke skupině uživatelů
Stránka #2 Uživatelé
Mřížka [Uživatelé]
Stránka #3 Uživatelé ve skupině
Mřížka [Uživatelé ve skupině]
Stránka #4 Přístupy k věcem
Mřížka [Přístupy k věcem]
Typ | Typ práva přístupu
 | Název práva věci s přístupem
Věc | Přistupovaná věc
 | Popis věci
Právo přístupu | Právo přístupu - Žádné,Čtení,Zápis
 | Poznámka k věci s přístupem

    Mřížka [Odbornosti] činnosti - Aktualizace seznamu věcí

    Mřížka [Odbornosti] činnosti - Aktualizace seznamu věcí
Název skupiny uživatelů | Název skupiny uživatelů
Skupina | Identifikace skupiny uživatelů

    Mřížka [Uživatelé] činnosti - Aktualizace seznamu věcí

    Mřížka [Uživatelé] činnosti - Aktualizace seznamu věcí
Označování | Označení záznamu
Uživatel | Jméno uživatele systému
Ident. | Identifikace uživatele systému
Uživatel (úplné jméno) | Úplné jméno uživatele systému

    Mřížka [Uživatelé ve skupině] činnosti - Aktualizace seznamu věcí

    Mřížka [Uživatelé ve skupině] činnosti - Aktualizace seznamu věcí
Úroveň | Úroveň vztahu
Uživatel | Jméno uživatele systému
Ident. | Identifikace uživatele systému
Uživatel (úplné jméno) | Úplné jméno uživatele systému
Práva správce | Uživatel s oprávněním správce
Povolena změna hesla | Povolena změna hesla
Aktivní uživatel | Aktivní uživatel (tj. smí se přihlásit do systému)
E-mail | E-mailová adresa uživatele

    Mřížka [Přístupy k věcem] činnosti - Aktualizace seznamu věcí

    Mřížka [Přístupy k věcem] činnosti - Aktualizace seznamu věcí
Typ | Typ práva přístupu
Věc | Přistupovaná věc
Popis | Popis věci
Název práva | Název práva věci s přístupem

    Atributy tisku

    Základní údaje
Skupina | Identifikace skupiny uživatelů | BWODBOR_bw05ident | C(6)
Název skupiny uživatelů | Název skupiny uživatelů | BWODBOR_bw05popis | C(30)
Poznámka | Poznámka ke skupině uživatelů | BWODBOR_bw05koment | M
Typ | Typ práva přístupu | SPPRISTV_sp44typ | C(3)
Název práva | Název práva věci s přístupem | SPPRISTV_sp85nazpra | C(40)
Věc | Přistupovaná věc | SPPRISTV_sp44vec | C(6)
Popis | Popis věci | SPPRISTV_sp85text | C(40)
Poznámka | Poznámka k věci s přístupem | SPPRISTV_sp85koment | M
Ident. | Identifikace uživatele systému | BWUZIVA4_bw01uziv | C(6)
Uživatel | Jméno uživatele systému | BWUZIVA4_bw01jmeno | C(30)
Uživatel (úplné jméno) | Úplné jméno uživatele systému | BWUZIVA4_bw01jmenot | C(25)
Práva správce | Uživatel s oprávněním správce | Výpočet | C(3)
Aktivní uživatel | Aktivní uživatel (tj. smí se přihlásit do systému) | Výpočet | C(3)
Povolena změna hesla | Povolena změna hesla | Výpočet | C(3)
E-mail | E-mailová adresa uživatele | BWUZIVA4_bw01email | C(40)
Jazyk | Identifikace jazyka | BWUZIVA4_sp38id | C(3)

    Při pohybu v Přístupy k věcem
    Právo přístupu Právo přístupu - Žádné,Čtení,Zápis Výpočet C(5)

    Viz.také

    Přepočet práv přístupu | Aktualizace seznamu věcí


Zařazení do skupin uživatelů

Popis

Tato činnost poskytuje uživateli přehled jak o jednotlivých aktivních uživatelích, tak o nadefinovaných skupinách.

U každého uživatele je k dispozici přehled jeho zařazení ve skupinách. Jednak je tato skupina vidět zaškrtnutá v pravé části formuláře a jednak je u každého uživatele k dispozici po rozbalení jeho menu (tj. znaménko plus před jménem uživatele).

Stejný princip platí i u přehledu skupin. V pravé části formuláře jsou zaškrtnuti ti uživatelé, kteří patří do dané skupiny a zároveň je jejich přehled k dispozici po rozbalení menu skupiny (tj. znaménko plus před názvem skupiny).

Přiřazovat uživatelům skupiny lze dvojím způsobem:

¨ v levé části formuláře bude kurzor umístěn na jménu uživatele a v pravé části se zaškrtne příslušná skupina (tím je do ní tento uživatel zařazen)

¨ nebo pravou myší na jménu uživatele zvolit volbu „Kopírovat ...xxxxx ....“? poté kliknout pravou myší na názvu skupiny, kam chceme uživatele zařadit a aktivovat volbu „Vložit ... xxxxx ...“

Uživatelé a skupiny uživatelů jsou tímto uloženy v jediné společné tabulce (BWUZIVAT). To umožňuje kromě definování zařazení uživatelů do skupin také definování vztahů mezi skupinami uživatelů. Hierarchická struktura skupin uživatelů má pak vliv na definování přístupových práv. Uvedeme si příklad:

¨ v systému je definovaná skupina uživatelů „vedení“ a skupiny „obchodní ředitel“ a „ředitel výroby“, které jsou zařazené do skupiny „vedení“ (stejný postup vytváření hierarchické struktury jako u uživatelů. Pravá myš na skupině „obchodní ředitel“ a volba „kopírovat“, pak pravá myš na skupině „vedení“ a volba „vložit“). Potom uživatel zařazený do skupiny „obchodní ředitel“ je nepřímo zařazen i do skupiny „vedení“ a vztahují se k němu všechna přístupová práva definovaná pro skupinu „vedení“.

Uživatele je možné zařadit do skupiny uživatelů, která je zároveň uživatelem systému. V takovém případě pak zařazený uživatel vlastní pouze ta přístupová práva, která jsou přímo udělena uživateli, který v tomto vztahu vystupuje jako skupina uživatelů.

Poznámka pro implementátory:

Při instalaci nové verze BM dochází ke sloučení obsahu tabulek BWOBDOR a BWUZIVAT, přitom nejsou přenášeny ty skupiny uživatelů, které mají stejnou identifikaci jako některý uživatel. Proto by měl správce systému před instalací nové verze změnit jejich identifikace (není nutno měnit pouze identifikaci skupiny uživatelů $SPRAV, tu instalace automaticky změní na SPRAVC).

Datový model

  • BWODBOR Skupina uživatelů

    • Formulář

    Formulář činnosti - Aktualizace seznamu věcí
    Fiktivní položka pro zobrazení příznaku práva k činnosti
    Mřížka [1]

    Mřížka [1] činnosti - Aktualizace seznamu věcí

    Mřížka [1] činnosti - Aktualizace seznamu věcí
Označování | Označení záznamu
Název skupiny uživatelů | Název skupiny uživatelů
Skupina | Identifikace skupiny uživatelů


Přehled přihlášených

Popis

Tato činnost poskytuje přehled uživatelů přihlášených do systému BM (každý uživatel je přihlášen svým jménem a heslem). K dispozici jsou tyto informace:

¨ uživatel (jméno uživatele)

¨ činnost (název probíhající činnosti)

¨ datum, čas (datum a čas poslední aktivity uživatele)

¨ identifikace

¨ transakce

¨ spojení (identifikace ODBC spojení)

Formulář

Formulář činnosti - Parametry komp. sklad zvířat
Mřížka [Přihlášení uživatelé]
Opakovat Opakovat pokus

Mřížka [Přihlášení uživatelé] činnosti - Parametry komp. sklad zvířat

Mřížka [Přihlášení uživatelé] činnosti - Parametry komp. sklad zvířat
Uživatel | Jméno uživatele systému
Činnost | Název probíhající činnosti
Datum | Datum posledního zápisu
Čas | Čas posledního zápisu
Identifikace | Interní identifikace uživatele
Transakce | Probíhající transakce
Spojení | Síťová karta přihlášeného


Přehled přihlášených (SQL)

Popis

Tato činnost poskytuje přehled přihlášených uživatelů. K dispozici jsou tyto informace:

¨ identifikace (čísla spojení, která uživatelům přidělil databázový server)

¨ jméno uživatele

¨ činnost (název probíhající činnosti)

¨ čas (datum a čas poslední aktivity uživatele)

¨ název počítače

¨ multiverze (číslo multiverze přihlášeného uživatele)

Další vlastností, kterou tato činnost uživateli poskytuje, je možnost sledování počtu přihlášených uživatelů na základě zakoupených licencí. Chování této vlastnosti přímo závisí na nastavení parametru „Preferencess ->Licence_prodluzovat“ v činnosti „Nastavení programu BM“.

Pokud počet současně přihlášených uživatelů překročí licenci provozovatele BM na počet současně přihlášených:

¨ při nastavení parametru“Licence_prodluzovat=1“ – se uživateli zobrazí dotaz: „Po Vašem vstupu do BM bude k BM přihlášeno „nn“ uživatelů a tím bude licence Vaší firmy pro používání BM překročena o „nn“ současně přihlášených uživatelů. Vaše odpověď ANO Vám umožní vstup do programu a bude považována za objednání dalších licencí BM.

¨ při nastavení parametru“Licence_prodluzovat=0“ – tento dotaz zobrazen nebude a uživateli není vstup do BM povolen.

V horní liště z menu Volby lze vyvolat tyto činnosti:

¨ obrazovka uživatele – vyvolá formulář, ve kterém je periodicky zobrazován obsah obrazovky daného uživatele

¨ stav programu BM uživatele – vyvolá formulář, ve kterém je periodicky zobrazován stav programu BM daného uživatele

V souvislosti s tímto způsobem záznamu aktuálně přihlášených uživatelů eviduje BM maximální počet současně přihlášených uživatelů. Každý den, kdy došlo k alespoň jednomu přihlášení uživatele k BM, zapisuje program do tabulky BWCONNES datum, největší počet současně přihlášených v daném dni a identifikaci uživatele, který byl posledním z přihlášených.

Datový model

  • BWCONNEQ Přihlášený uživatel do systému (SQL)
    • BWUZIVAT Uživatel systému

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Obrazovka uživatele |
F6 | Stav programu BM uživatele |
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených

    Formulář

    Formulář činnosti - Stav programu BM uživatele
    Mřížka [Přihlášení]

    Mřížka [Přihlášení] činnosti - Stav programu BM uživatele

    Mřížka [Přihlášení] činnosti - Stav programu BM uživatele
Označování | Označení záznamu
Identifikace | Interní identifikace uživatele
Uživatel | Jméno uživatele systému
Činnost | Název probíhající činnosti
Čas | Datum a čas poslední aktivity uživatele
Název počítače | Název počítače

    Viz.také

    Obrazovka uživatele | Stav programu BM uživatele | OZNAČOVÁNÍ


Oprávnění k činnostem

Popis

Tato činnost slouží k přidělování oprávnění k provádění činností vybraným skupinám uživatelů nebo přímo jednotlivým uživatelům (činnost, ke které nemá uživatel oprávnění v hlavním menu vůbec nemá dostupnou, tzn. viditelnou).

Přidělování práv k provádění jednotlivých činností se provádí následujícím způsobem. Uživateli se zobrazuje seznam funkčních činností a v pravé části obrazovky je přehled nadefinovaných skupin uživatelů a jednotlivých uživatelů. U jednotlivých funkčních činností je navíc třeba rozlišovat, zda mají před názvem přítomnou "tečku" či nikoliv. Pokud je tam tečka, znamená to, že činnost se může dvojklikem ještě dále rozbalit. Uživatel si potom prochází jednotlivé činnosti a zatržením příznaku může přiřadit právo k provádění dané činnosti vybrané skupině nebo konkrétnímu uživateli. Mezi jednotlivými funkčními činnostmi se uživatel pohybuje pomocí dvojitého stlačení levého tlačítka myši. Po dvojkliku se zobrazí všechny činnosti, které jsou navázány na danou činnost (stiskem ESC nebo ikony "zpět" se uživatel vrátí zpět do původní nabídky). Pokud je přehled skupin uživatelů zobrazen modrou barvou, znamená to, že k dané činnosti mají přístup všichni uživatelé. Pokud má přístup k činnosti zatržena pouze některá skupina, je naopak tato skupina zobrazena modře a ostatní skupiny bez přístupu jsou vysvíceny černě.

U jednotlivých činností, např. adresář, je možno přiřazovat oprávnění až na úroveň editačních činností, tzn. že uživatel pak např. nemá právo nového adresáta zařadit, nicméně číst v adresáři již vytvořené záznamy právo má. U které činnosti se rozsvítí záložka "editační činnosti", té je možno takto podrobně přiřazovat oprávnění. Pomocí klávesy "návrat zpět" se uživatel vrací k činnosti vždy o úroveň výš.

Oprávnění k činnostem má právo definovat uživatel s „právy správce“. K dispozici má tyto možnosti:

¨ menu Systém – činnost Oprávnění k činnostem

¨ hlavní menu – pravý klik na názvu činnosti – volba Oprávnění k činnostem

¨ menu Obecné v horní liště libovolného formuláře – volba Oprávnění k činnostem

Datový model

  • BWODBOR Skupina uživatelů

    • Formulář

    Formulář činnosti - Nápověda k činnosti
Mřížka [Odbornosti]
Činnost | Název činnosti
Poznámka | Poznámka k činnosti
Listovací rámeček
Stránka #1 Funkční činnosti
Funkční činnosti
Stránka #2 Editační činnosti
Editační činnosti

    Mřížka [Odbornosti] činnosti - Nápověda k činnosti

    Mřížka [Odbornosti] činnosti - Nápověda k činnosti
Označování | Označení záznamu
Skupina | Identifikace skupiny uživatelů
Název skupiny uživatelů | Název skupiny uživatelů

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Návrat zpět | Návrat zpět k předchozí činnosti
F6 | Nápověda k činnosti | Vyvolání nápovědy aktuální činnosti

    Viz.také

    Návrat zpět | Nápověda k činnosti


Slovník dat

Popis

SD je nástroj (funkce) informačního systému Bílý Motýl, který uživateli umožňuje definovat pohledy na data (struktura - datový submodel, výběr - vymezení podmnožiny, předloha výstupu - forma zobrazení) nezávisle na funkcích IS připravených poskytovatelem. Pohledy se kategorizují do tříd, což umožní jejich zpřehlednění, ale i dědění vlastností. V IS jej lze najít v hlavním menu ve skupině SYSTÉM.


Parametry uživatele

Popis

Jedná se o činnost, která umožňuje každému uživateli nastavit si některé parametry podle jeho vlastních potřeb, tj. je součástí personifikace IS. Parametry lze nastavit nebo změnit v činnosti Systém - Parametry uživatele. Jsou to tyto parametry:

¨ reakce na klávesu ESC při prohlížení - možnost nastavit si chování systému po stisku klávesy ESC v prohlížení jakékoliv činnosti. Pokud je nastaveno „zrušit prohlížení“, činnost se po stisku klávesy ESC automaticky ukončí, pokud je nastaveno „dotaz“, po stisku klávesy ESC se systém dotazuje „Ukončit prohlížení?Ano/Ne“, pokud je nastaveno „žádná reakce“, tak systém po stisku klávesy ESC nereaguje a činnost je nutno ukončit jiným způsobem (např. ikonou křížek)

¨ ukončovat textové pole psaním za poslední znak - při zatržení této možnosti kurzor po naplnění textového pole (např. zapsání 40-ti možných znaků v položce popis) automaticky přeskočí na další položku ve formuláři

¨ zobrazovat úplné století v datumových údajích - datum se potom zobrazuje ve tvaru DD.MM.RRRR, pokud by toto nebylo zatrženo, je rok zobrazen pouze dvěmi koncovými znaky (DD.MM.RR).

¨ zobrazovat grafický stavový řádek - při zatržení se uživateli zobrazuje řádek v dolním okraji okna, kde má např. možnost si přečíst message k dané položce.

¨ zobrazovat čas na stavovém řádku - na tomto stavovém řádku je pak v pravém dolním rohu okna k dispozici i čas.

¨ povolena změna pozice panelu nástrojů - pokud je tato možnost zatržena, je možno panel nástrojů přesouvat po okně, jinak zůstává standardně umístěn pod horní lištou okna.

¨ povoleno ukončení programu klávesou Alt + F4 - při zatržení je možno ukončit program, resp. hlavní menu, i po stisku klávesy Alt F4, jinak se program standardně ukončuje ikonou „křížek“.

¨ zobrazovat nabídku aktivních oken - uživateli se při zatržení této možnosti zobrazuje nabídka aktivních oken, což je seznam všech aktivně spuštěných činností.

¨ ikony – při zaškrtnutí této možnosti je pak nabídka aktivních oken zobrazována jako tlačítka s ikonami a při příštím spuštění programu se ukotví v dolní části obrazovky. Tuto možnost uživatel využije asi zejména, pokud si mřížku formuláře roztahuje do šířky a lišta s nabídkou aktivních oken mu pak zbytečně zabírá místo v pravé části obrazovky.

¨ stránka výběru po spuštění č. „Procesy“, „Operace“ - při zatržení této možnosti uživateli po aktivaci těchto dvou činností nejprve nabíhá záložka Výběr, kde si definuje, které údaje chce mít v okně k dispozici. V případě, že tato možnost zatržena není, aktivují se tyto činnosti podle posledního nastaveného výběru a to může být někdy i značně zdlouhavé. Zdlouhavému výběru je možno předejít tak, že uživatel si do výběru zadá napevno (možnost uchovat) č. nějakého procesu, tudíž po aktivaci činnosti procesy nebo operace se zobrazí tento proces, uživatel si sám přepne záložku výběr a vybere si data, která potřebuje.

¨ uchovávat pozice oken – možnost nastavení zaznamenání pozice oken formulářů pro jednotlivé uživatele systému. Jedná se o překryvný seznam s možnostmi:

- Nikdy

- Ne

- Ano – automaticky vždy při uzavření okna

- Ano – při nastavení parametrů formuláře

¨ uchovávání pozice okna ve vztahu k rozlišení obrazovky – při uchovávání pozice okna formuláře je možno zaznamenávat i aktuální rozlišení monitoru uživatele. Možnosti nastavení jsou:

- přepočítávat pozice poměrem aktuálního rozlišení obrazovky – uživatel si uchová pozici okna formuláře (na svém PC) a při spuštění daného formuláře na jiném PC (tzn. s jiným rozlišením monitoru) systém automaticky přepočítává:

- umístění levého horní rohu okna v pixelech v ose X = [uložená pozice] * [uložené rozlišení v ose X] / [aktuální rozlišení v ose X]

- výška okna v pixelech = [uložená výška] * [uložené rozlišení v ose X] / [aktuální rozlišení v ose X]

- umístění levého horní rohu okna v pixelech v ose Y = [uložená pozice] * [uložené rozlišení v ose Y] / [aktuální rozlišení v ose Y]

- šířka okna v pixelech = [uložená šířka] * [uložené rozlišení v ose Y] / [aktuální rozlišení v ose Y]

- zvlášť pro různá rozlišení obrazovky

¨ koeficient zobrazení - možnost zvětšit si nebo zmenšit si velikost formulářů (včetně velikosti písma atributů) podle vlastních potřeb. Standardně je nastaven koeficient 1, pokud se zadá např. 0,8, velikost formuláře na obrazovce se zmenší, pokud se zadá např. 1,2, velikost se naopak o něco zvětší.

¨ mřížka – nastavený koeficient mění na událostech velikost písma v mřížce. Nastavený koeficient u mřížky funguje pouze za předpokladu, že koeficient zobrazení je různý od hodnoty 1.

¨ MDI formuláře – implicitní nastavení vlastností formulářů (MDI=vícedokladové rozhraní)

¨ zvýraznění řádku v mřížce – možnost nastavit si barevné zobrazení aktuální řádky v mřížkách formulářů. Možnosti způsobu zobrazení jsou:

- Ne – aktuální řádek v mřížkách nebude barevně zvýrazňován

- Ano – varianta 1 – aktuální řádek v mřížkách bude barevně zvýrazňován – při vstupu do buňky mřížky bude buňka vybarvena B/W (černé písmo na bílém podkladu) – při pohybu v mřížce pomocí klávesnice bude obsah buňky zčásti vybarven W/B (bílé písmo na modrém podkladu) – označení pro funkčnost klávesy Ctrl + C

- Ano – varianta 2 – aktuální řádek v mřížkách bude barevně zvýrazňován – při vstupu do buňky mřížky bude buňka vybarvena barvou zvýraznění – při pohybu v mřížce pomocí klávesnice bude obsah buňky zčásti vybarven W/B (bílé písmo na modrém podkladu) – označení pro funkčnost klávesy Ctrl + C

- Ano – varianta 3 - aktuální řádek v mřížkách bude barevně zvýrazňován – při vstupu do buňky mřížky bude buňka vybarvena barvou zvýraznění - při pohybu v mřížce pomocí klávesnice nebude obsah buňky automaticky označován pro funkčnost klávesy Ctrl + C

- (poznámka – možnost nastavení barevného zobrazování aktuální řádky v mřížkách formulářů je funkční pouze ve verzích BM pod Visual Foxpro verze 8.0 nebo vyšší).

¨ barva písma zvýraznění – barva zvýraznění písma v aktuálním řádku v mřížce

¨ barva pozadí zvýraznění – barva zvýraznění pozadí v aktuálním řádku v mřížce

¨ výstupy procesů - nejedná se o výstupy procesů jako takové, přesnější termín je nastavení způsobu tisku zvolených nebo předdefinovaných předloh výstupu nebo dokladů a toto nastavení se uplatní pouze tehdy, pokud je u dané předlohy výstupu na záložce „popis“ v atributu „výstupy procesů“ vybrána možnost „podle parametrů uživatele“. Možnosti tisku tedy jsou:

- rozhodnout - uživatel má možnost si zvolit, jestli chce tisknout na tiskárnu, do souboru nebo pouze předlohu prohlížet v okně

- prohlížet - předloha se automaticky zobrazí pouze k prohlížení v okně

- tisknout se zastavením - uživatel má v tomto případě k dispozici možnost zvolit si tiskárnu a počet kopií dané předlohy

- tisknout bez zastavení - daná předloha výstupu nebo doklad se automaticky tiskne bez zásahu uživatele

¨ E-mail - do této položky se zapíše e-mail uživatele, který se pak automaticky zobrazuje při posílání dokumentů nebo tiskových sestav pomocí elektronické pošty.

¨ aktuální datum uživatele - zapsáním data zde je možno krátkodobě změnit aktuální systémové datum, tzn. pokud uživatel potřebuje zadat např. větší množství událostí zpět k nějakému datu, změní si zde aktuální datum a systém bere jako aktuální datum toto datum zde nastavené. Pouze v případě storna nebere systém toto aktuální datum v potaz.

¨ zobrazování ikon seznamů hodnot – možnost určit si variantu zobrazování „ikony seznamu hodnot“ na výběrových záložkách jednotlivých formulářů při nastavení atributu „ikona – vlevo vedle atributu“. Možnosti jsou:

- varianta 1 – zobrazuje se čtvereček □ vlevo před atributem (při výběru více hodnot u atributu je to zaškrtnutý □)

- varianta 2 - zobrazuje se žlutý čtvereček □ vlevo před atributem (při výběru více hodnot u atributu je to zaškrtnutý žlutý □)

- varianta 3 - zobrazuje se malý čtvereček ▪ vlevo před atributem (při výběru více hodnot u atributu je to zaškrtnutý malý žlutý ▪ )

- varianta 4 - zobrazuje se malý čtvereček ▪ vlevo před atributem (při výběru více hodnot u atributu je to zaškrtnutý □)

- varianta 5 - zobrazuje se malý žlutý čtvereček ▪ vlevo před atributem (při výběru více hodnot u atributu je to zaškrtnutý žlutý □)

- varianta 6 - zobrazuje se malý čtvereček ▪ v pravém horním rohu atributu (při výběru více hodnot u atributu je to zaškrtnutý □ v pravém horním rohu)

- varianta 7 - zobrazuje se malý čtvereček ▪ v pravém horním rohu atributu (při výběru více hodnot u atributu je to zaškrtnutý □ v pravém horním rohu) + malý žlutý čtvereček ▪ před atributem typu překryvný seznam (po výběru více hodnot je to zaškrtnutý žlutý □)

- varianta 8 - zobrazuje se malý čtvereček ▪ v pravém horním rohu atributu (při výběru více hodnot u atributu je to zaškrtnutý □ v pravém horním rohu) + malý čtvereček ▪ před atributem typu překryvný seznam (po výběru více hodnot je to zaškrtnutý □)

Formulář

Formulář činnosti - Barvy RGB
Reakce na klávesu ESCAPE při prohlížení | Reakce na klávesu ESCAPE při prohlížení
Ukončovat textové pole psaním za poslední znak | Ukončovat textové pole psaním za poslední znak v textovém poli.
Zobrazovat úplné století v datumových údajích | Způsob zobrazení století v datumových údajích
Zobrazovat grafický stavový řádek | Zobrazovat grafický stavový řádek
Zobrazovat čas na stavovém řádku | Zobrazovat čas na stavovém řádku
Povolena změna pozice panelu nástrojů | Povolena změna pozice panelu nástrojů
Povoleno ukončení programu klávesou ALT+F4 | Povoleno ukončení programu klávesou ALT+F4
Zobrazovat nabídku aktivních oken | Zobrazovat nabídku aktivních oken
Ikony | Zobrazovat ikony v nabídce aktivních oken
Stránka výběru po spuštění č. "Procesy","Operace" | Nástavení na stránku výběru po spuštění formulářů "Procesy" a "Operace"
Koeficient zobrazení | Koeficient zobrazení
Mřížka | Koeficient zobrazení mřížky
Zvýraznění řádku v mřížce | Zvýraznění řádku v mřížce
Barva písma zvýraznění | Identifikace barvy RGB
Barva pozadí zvýraznění | Identifikace barvy RGB
Výstupy procesů | Tiskové výstupy procesů - prohlížet nebo tisknout se zastavením nebo tisknout bez zastavení
E-mail | E-mailová adresa uživatele
Aktuální datum uživatele | Aktuální datum uživatele
Uchovávat pozice oken | Uchovávat pozice oken
Uchovávání pozice okna ve vztahu k rozlišení obrazovky | Uchovávat pozice oken zvlášť pro různá rozlišení obrazovky nebo je přepočítávat poměrem aktuálního rozlišení obrazovky
MDI fomuláře | Implicitní nastavení vlastnosti formulářů MDI=vícedokladové rozhraní
Zobrazování ikon seznamů hodnot | Varianty způsobu zobrazování ikon seznamů hodnot na výběrových záložkách formulářů

Vyvolávané činnosti

K. | Činnost | Popis
F2 | Barvy RGB |

Viz.také

Barvy RGB | Parametry formuláře | Parametry polí formulářů


Nastavení - Souvislosti objekt

Popis

Nastavením této činnosti uživatel definuje způsob zobrazení rámečku souvislostí po stisku ikony objekty (ikonka se „stromečkem“) v panelu nástrojů. Rámeček souvislostí si metodou „táhni a drž“ může uživatel rozmístit na libovolné místo v okně. Po jeho zavření a opětovném spuštění si systém pamatuje poslední místo, kde byl umístěn a na tomto místě se rámeček souvislostí opětovně aktivuje. Možnost této definice má uživatel v činnosti menu „Systém“. Po její aktivaci se mu zobrazí tabulka s nabídkou všech objektů, které se mohou zobrazovat v rámečku souvislostí. Příslušná znaménka plus nebo mínus v rámečku souvislostí poskytují uživateli informace o přítomnosti objektových vazeb. V levé části této tabulky má uživatel možnost změnit pořadí těchto objektů (stiskem malého čtverečku před názvem objektu pravým tlačítkem myši - po jeho stisku se zobrazí na čtverečku šipka - a jeho následným přetažením na jiné místo v seznamu).

U každého objektu v seznamu je možno z překryvného seznamu (v dolní části okna) vybrat tyto možnosti:

¨ zobrazit - tento objekt se bude po aktivaci rámečku souvislostí standardně nabízet v daném pořadí

¨ skrýt - tento objekt zůstává skrytý, tzn. po aktivaci rámečku souvislostí se standardně nezobrazí. V případě, že by uživatel potřeboval v některém okamžiku vidět v rámečku souvislostí i objekty, které mají příznak skrýt, zatrhne možnost „zobrazovat skryté“. Do té chvíle, dokud bude tato možnost zatržena, se budou v rámečku souvislostí nabízet i objekty, které mají příznak skrýt. Uživatel má však možnost vidět i objekty, které jsou skryté a přesto nemají zatrženo „zobrazovat skryté“. Po stisku pravého tlačítka myši v šedivém poli rámečku souvislostí se uživateli zobrazí i objekty, které mají příznak skryté. Opětovným stiskem pravého tlačítka myši se obnoví původní zobrazení.

¨ potlačit - tyto objekty se v rámečku souvislostí nebudou nabízet nikdy. V případě, že by je uživatel přesto chtěl vidět, musí příznak potlačit změnit na zobrazit nebo skrýt.

Nastavení - souvislosti objekt se vždy váže k danému uživateli a jeho přístupovému heslu (tedy k tomu, který je právě přihlášen do systému), tzn., že pro každého uživatele může být toto nastavení individuální a zcela podle jeho potřeb. Po stisku tlačítka OK se toto nastavení uloží.


Import balíčku

Popis

Balíček je prostředek přenosu vybraných definičních dat (definic) z jednoho datového úložiště do jiných, a to i u různých uživatelů (nezávisle na replikacích). Balíčkem lze přenášet:

¨ druhy procesů (na rozdíl od následujících přenášených definic se nepřenáší pouze základní definice, ale celý komplex definic, např. diagram procesu a jeho vazby, masky operací, transformace mezi uzly, šablony procesu a tisková sestava, pokud je uvedena jako předloha výstupu u druhu operace)

¨ předlohy výstupu (včetně druhu předlohy)

¨ metapředlohy výstupu

¨ definice volné karty (včetně druhu VK)

¨ definice výkazů (upozornění: nepřenesou se funkce v definici použité)

¨ obecné výběry

¨ uživatelské triggery

¨ šablony (pouze v tom případě, pokud jsou uvedeny ve vlastnostech operace jako „šablona prvého vstupu“ a pokud je tento druh operace součástí druhu procesu, který se přenáší balíčkem) - (včetně druhu šablony)

¨ definice importů/exportů, procesních importů

¨ definice výkazů

Při přenosu definic balíčkem je nutno vědět, že bez ohledu na předchozí přenosy se stále dokola mohou přenášet pouze předlohy výstupu (tj. dojde k jejich přepsání), u ostatních přenosů se v pořádku přenesou vždy jen první definice, další změny se nepřenášejí. Přenesou se pouze v případě, že se přenášená definice smaže a pomocí balíčku se naimportuje znovu. Balíčkem nelze přenášet volné karty operace, volné karty procesu a informace o nastavených parametrech operací.

Export do balíčku se provádí vždy v dané činnosti (např. Druhy procesů, Seznam předloh výstupu apod.) vyvoláním příslušné činnosti na horní liště v menu Volby („Export dat do balíčku“), kde uživatel určí soubor (jeho cestu), kam se balíček má uložit, jeho název (tj. popis) a které záznamy se mají exportovat (všechny vybrané, aktuální nebo označené). Ke každému vytvářenému balíčku je možno si připsat libovolnou poznámku. Cyklicky se vytváří soubory s příponou .BEX a .FPT (u předloh výstupu, kde se provádí export do balíčku přímo z okna činnosti výstupy se kromě souborů s příponou .bex a .fpt vytvoří ještě soubor s příponou .txt). Pro vytvoření balíčků se implicitně nabízí programový adresář, uživatel má však samozřejmě možnost si nastavenou cestu změnit a zvolit si adresář podle svých potřeb. Následný import balíčku se provádí v hlavním menu v činnosti SYSTÉM - Import balíčku. Po aktivaci této činnosti se uživateli jako první rovněž nabídne načtení balíčku z programového adresáře, uživatel si ale může určit libovolnou cestu, odkud a z jakého souboru se má provést import.


Přehled balíčků

Popis

Přehled připravených balíčků s možností prohlížení (záložka „ukázat“) a importu (záložka „import“). V levé části formuláře jsou názvy jednotlivých balíčků, v pravé části podrobné informace ke každému z nich.


Seznam předloh výstupu

Popis

Informativní přehled všech vytvořených předloh výstupu v jednotlivých komponentách. Uživatel zde má k dispozici informace o činnosti, ve které je daná předloha vytvořena, o jejím názvu, typu, druhu a uživateli, kdo předlohu založil. Zároveň je zde informace, kdy proběhla v dané předloze výstupu poslední provedená změna.

Datový model

  • BWPRINTD Předloha pro výstup (alias BWPRINT3)
    • BWPRINTT Druh předlohy
    • BWUZIVAT Uživatel systému

    • Formulář

    Formulář činnosti - Skupiny procesů / předloh výstupu
Mřížka [Předlohy výstupu]
Činnost | Identifikace činnosti
 | Název činnosti
 | Poznámka k činnosti
Předloha | Název předlohy pro výstup
Typ | Určení typu výstupu
skrytá všem | Předloha skrytá všem uživatelům
Druh | Identifikace druhu předlohy
Skupina | Identifikace skupiny procesů
 | Název druhu předlohy
Založil | Úplné jméno uživatele systému
 | Datum vzniku předlohy pro výstup
Poslední změna | Datum a čas změny předlohy pro výstup
Poznámka | Poznámka k předloze pro výstup

    Mřížka [Předlohy výstupu] činnosti - Skupiny procesů / předloh výstupu

    Mřížka [Předlohy výstupu] činnosti - Skupiny procesů / předloh výstupu
Označování | Označení záznamu
Činnost | Identifikace činnosti
Název předlohy | Název předlohy pro výstup
Druh | Identifikace druhu předlohy
Název druhu předlohy | Název druhu předlohy
Skupina | Identifikace skupiny procesů
Poslední změna | Datum a čas změny předlohy pro výstup

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druhy předloh výstupu | Druhy předloh výstupu
F2 | Skupiny procesů / předloh výstupu | Seznam skupin procesů / předloh výstupu

    Viz.také

    Druhy předloh výstupu | Skupiny procesů / předloh výstupu | Profily spuštění předloh | Předlohy výstupu


Profily spuštění předloh

Popis

Jednotlivé profily se definují v činnosti „profily spuštění předloh“ v menu SYSTÉM a určuje se u nich zda má při odpovídajícím způsobu spuštění (dvojklikem na názvu předlohy nebo stiskem ikony) následovat přímo spuštění předlohy nebo rozhodnutí. Kromě identifikace a názvu profilu je dostupný ještě atribut „parametr“, který ovlivňuje vytváření PDF dokumentů. Zapsané parametry mohou být oddělené Ctrl F nebo středníkem.

Jedná se o:

PDF=0 - výstup do PDF nemá být prováděn - default PDF=1

GHOSTSCRIPT=0 - nebude používán Ghostscript, ale PDF tiskárna - default GHOSTSCRIPT=1

PRINTER=název tiskárny - jiný název použité tiskárny než default - default při GHOSTSCRIPT=1 je to PRINTER=GENERIC POSTSCRIPT PRINTER a při GHOSTSCRIPT=0 je to PRINTER=PRINT2PDF

PRINTERFILE=název výstupního dokumentu PDF tiskárny (při GHOSTSCRIPT=0) - default PRINTERFILE=C:\TMP\SOUBOR.PDF

PRINTRESOLUTION=600 - rozlišení PDF dokumentu v pixelech při GHOSTSCRIPT=1 (při GHOSTSCRIPT=1) - default PRINTRESOLUTION=300

GSFOLDER=kořenový adresář, ve kterém je nainstalován Ghostscript (při GHOSTSCRIPT=1) - default GSFOLDER=C:\Program Files\GS a GSFOLDER=C:\GS

EMAIL=0 - nebude odeslán email, i když je Subject uveden - default EMAIL=0

DROPPDF=0 - dokument PDF nebude po odeslání emailu zrušen - default DROPPDF=1

VIEWPDF=0 - nebude spouštěn Acrobat Reader pro prohlížení dokumentu ani v případě, že není odesílán email - VIEWPDF=1

AUTOINSTALLPATH=jiný adresář pro automatickou instalaci Ghostscriptu a postscriptové tiskárny (při GHOSTSCRIPT=1) - default AUTOINSTALLPATH=AUTOINSTALL

Parametr AUTOINSTALLPATH naznačuje, že může být při tisku automatizovaně prováděna instalace Ghostscriptu a postscriptové tiskárny, pokud nejsou na počítači uživatele nalezeny. Pro tuto instalaci je třeba vytvořit adresář podle tohoto parametru s podadresáři GHOSTSCRIPT a PSDRIVERS a do nich umístit jejich instalační EXE. Při nastavení AUTOINSTALLPATH=NO není automatická instalace prováděna.

Pro předlohy typu „sestava“ a „excel“ se v profilu určuje směrování výstupu (tiskárna/do souboru/prohlížení). Pro předlohy typu „sestava“ se navíc určuje, zda má při výstupu předlohy na tiskárnu předcházet dotaz na výběr tiskárny (zaškrtnuto nastavení tiskárny). Lze nadefinovat tisk předlohy ve formátu TIFF.

Pokud je tedy v profilu nastaveno u ikony „spuštění předlohy“, u sestavy „na tiskárnu“ a „nastavení tiskárny“ není zaškrtnuto, dochází v běhu procesu u operace, která má nadefinováno, že po jejím ukončení probíhá tisk dokladu, k automatickému tisku sestavy přímo na tiskárnu (tisková předloha je nastavena v metapředloze). U typu „sestava“ tisk „do souboru“ představuje PDF dokumenty.

Jednotlivé profily spuštění předloh je možno nastavit jak u metapředlohy, tak přímo u předlohy výstupu. Pokud uživatel chce, aby se předloha chovala jinak po spuštění předlohy a jinak pokud se jedná o tisk dokladu (tzn. tisk předlohy v metapředloze), nastaví příslušné profily spuštění předloh jak u metapředlohy, tak přímo u vlastní předlohy.

Pro uživatele je dále k dispozici možnost definice profilu spuštění předlohy pro předlohy typu Word. Výběr zda na tiskárnu/do souboru/prohlížení je stejný jako u předloh typu sestava a Excel. Další možnosti pro předlohy typu Word je nastavení těchto atributů:

¨ Digitální podpis

¨ Příprava e-mailu

¨ Uložit jako dokument BM

Tyto nastavení velmi úzce souvisí s nastavením těchto atributů přímo v definici dané předlohy Word. Nastavení přímo v předloze přitom mají přednost před nastavením v profilu. Pokud je u těchto nastavení v předloze nastaveno NIKDY, tak ať už je v profilu nastaveno cokoliv, výsledkem je, že při spuštění okna „zahájení výstupu dle předlohy“ jsou všechny tyto tři možnost nezaškrtnuté a šedivé (tzn. není povoleno měnit).

Další nastavení u těchto atributů v předloze je možno Ano a Ne. V následující tabulce je popsáno předplnění atributů v okně „zahájení výstupu dle předlohy“ podle nastavení v předloze a profilu (platí směr zleva doprava).

Předloha | Profil | Okno „zahájení výstupu dle předlohy“
Ano | Volitelné | Povoleno měnit – zaškrtnuto
Ano | Volitelné Ano | Povoleno měnit – zaškrtnuto
Ano | Volitelné Ne | Povoleno měnit – nezaškrtnuto
Ano | Nevolitelné | Nepovoleno měnit – zaškrtnuto
Ano | Nevolitelné Ano | Nepovoleno měnit – zaškrtnuto
Ano | Nevolitelné Ne | Nepovoleno měnit – nezaškrtnuto
Ne | Volitelné | Povoleno měnit – nezaškrtnuto
Ne | Volitelné Ano | Povoleno měnit – zaškrtnuto
Ne | Volitelné Ne | Povoleno měnit – nezaškrtnuto
Ne | Nevolitelné | Nepovoleno měnit – nezaškrtnuto
Ne | Nevolitelné Ano | Nepovoleno měnit – zaškrtnuto
Ne | Nevolitelné Ne | Nepovoleno měnit – nezaškrtnuto

Datový model

  • BWPRINTC Profil spuštění předlohy výstupu

    • Formulář

    Formulář činnosti - Skupiny procesů / předloh výstupu
Mřížka [Profil spuštění předlohy výstupu]
Profil | Identifikace profilu spuštění předlohy
 | Název profilu
Ikona | Reakce na vyvolání předlohy ikonou
Sestava | Způsob výstupu pro typ předlohy Sestava aktivací ikonou
Nastavení tiskárny | Vyvolat nastavení tisku pro výstupy typu Sestava aktivací ikonou
Excel | Způsob výstupu pro typ předlohy Excel aktivací ikonou
Word | Způsob výstupu pro typ předlohy Word aktivací ikonou
Digitální podpis | Připojit digitální podpis k vytvořenénu dokumentu
Příprava e-mail | Příprava e-mailu vytvořeného dokumentu
Dokument BM | Uložení vytvořeného dokumentu Wordu jako dokumentu BM
Dvojklik | Reakce na vyvolání předlohy dvojklikem
Sestava | Způsob výstupu pro typ předlohy Sestava aktivací dvojklikem
Nastavení tiskárny | Vyvolat nastavení tisku pro výstupy typu Sestava aktivací dvojklikem
Excel | Způsob výstupu pro typ předlohy Excel aktivací dvojklikem
Word | Způsob výstupu pro typ předlohy Word aktivací dvojklikem
Digitální podpis | Připojit digitální podpis k vytvořenénu dokumentu
Příprava e-mail | Příprava e-mailu vytvořeného dokumentu
Dokument BM | Uložení vytvořeného dokumentu Wordu jako dokumentu BM
Parametr | Parametr profilu dostupný při výstupu předlohou výstupu
Poznámka | Poznámka

    Mřížka [Profil spuštění předlohy výstupu] činnosti - Skupiny procesů / předloh výstupu

    Mřížka [Profil spuštění předlohy výstupu] činnosti - Skupiny procesů / předloh výstupu
Profil | Identifikace profilu spuštění předlohy
Název profilu | Název profilu

    Atributy tisku

    Základní údaje
Profil | Identifikace profilu spuštění předlohy | BWPRINTC_bw71id | C(3)
Název profilu | Název profilu | BWPRINTC_bw71nazpro | C(40)
Poznámka | Poznámka | BWPRINTC_bw71koment | M
Ikona | Reakce na vyvolání předlohy ikonou | Výpočet | C(17)
Sestava | Způsob výstupu pro typ předlohy Sestava aktivací ikonou | Výpočet | C(11)
Excel | Způsob výstupu pro typ předlohy Excel aktivací ikonou | Výpočet | C(11)
Word | Způsob výstupu pro typ předlohy Word aktivací ikonou | Výpočet | C(11)
Digitální podpis | Připojit digitální podpis k vytvořenénu dokumentu | Výpočet | C(17)
Příprava e-mail | Příprava e-mailu vytvořeného dokumentu | Výpočet | C(17)
Dokument BM | Uložení vytvořeného dokumentu Wordu jako dokumentu BM | Výpočet | C(17)
Nastavení tiskárny | Vyvolat nastavení tisku pro výstupy typu Sestava aktivací ikonou | Výpočet | C(3)
Dvojklik | Reakce na vyvolání předlohy dvojklikem | Výpočet | C(17)
Sestava | Způsob výstupu pro typ předlohy Sestava aktivací dvojklikem | Výpočet | C(11)
Excel | Způsob výstupu pro typ předlohy Excel aktivací dvojklikem | Výpočet | C(11)
Word | Způsob výstupu pro typ předlohy Word aktivací dvojklikem | Výpočet | C(11)
Digitální podpis | Připojit digitální podpis k vytvořenénu dokumentu | Výpočet | C(17)
Příprava e-mail | Příprava e-mailu vytvořeného dokumentu | Výpočet | C(17)
Dokument BM | Uložení vytvořeného dokumentu Wordu jako dokumentu BM | Výpočet | C(17)
Nastavení tiskárny | Vyvolat nastavení tisku pro výstupy typu Sestava aktivací dvojklikem | Výpočet | C(3)
Parametr | Parametr profilu dostupný při výstupu předlohou výstupu | BWPRINTC_bw71param | M


Překlad textů

Popis

V této činnosti se uživateli zobrazuje překlad textů ve zvoleném jazyce. V nabídce hlavního menu si uživatel pod volbou JAZYK vybere určitý jazyk a v činnosti překlad textů se mu budou zobrazovat všechny přeložené texty ve zvoleném jazyce. Ve sloupci překlad textů se uživateli nabízí texty tak, jak jsou v jednotlivých činnostech nadefinovány v překryvných seznamech činností. V pravé části formuláře v kolonce text je vidět jak jsou původně nadefinovány, kolonka přeložený text poskytuje informace o tom, jak si je uživatel vytvořil podle vlastních potřeb.

Vybrané údaje IS BM (atributy, hodnoty překryvných seznamů apod.) je možno překládat i pomocí činnosti režim oprav. Po jejím zatržení (menu Jazyk v horní liště) se pak po stisku pravého tlačítka myši zobrazí možnost překladu popisu v daném jazyce (v tom, který je právě aktivní). Návěští popisu definuje překládané hodnoty, poznámka popisu slouží pouze jako informační popis k překladu.

Při překladu textu prvku typu překryvný seznam pomocí režimu oprav je možné zatrhnout atribut „uložit přeložený text do BWSLOVPP“. Toto uložení následně v SQL dotazech umožňuje přístup k hodnotám, které jsou definované pro atributy zobrazované jako překryvný seznam.

Ve formuláři je možné provádět export a import přeložených textů do tabulky BWSLOVNI pomocí činností menu Volby:

¨ export slovníku textů

¨ import slovníku textů – je možné importovat soubory vytvořené exportem nebo soubory původně uložené mimo databázi (SLOVNIK\SLOV_XXX.DBF)

Obě tyto funkce jsou dostupné při nastavení Preferences – Slovnik_SQL=1 (menu Systém – Nastavení programu BM).

Formulář

Formulář činnosti - Export slovníku textů
Mřížka [Texty k přeložení]
Text | Text k přeložení
Přeložený text | Přeložený text

Mřížka [Texty k přeložení] činnosti - Export slovníku textů

Mřížka [Texty k přeložení] činnosti - Export slovníku textů
Text Text k přeložení

Vyvolávané činnosti

K. | Činnost | Popis
- | Import slovníku textů | Import slovníku textů
- | Export slovníku textů | Export slovníku textů

Atributy tisku

Základní údaje
Text Text k přeložení BWSLOVA.bw57text M

Viz.také

Import slovníku textů | Export slovníku textů


Spuštění činnosti identifikací

Popis

Tato činnost nahrazuje v systému metodu tzv. "rychlého hledání". Uživateli se zobrazuje přehled všech činností dostupných v informačním systému a výpisem a uložením celé identifikace činnosti (např. SP0128) do políčka vpravo nahoře se daná činnost spustí.

Formulář

Formulář činnosti - Export slovníku textů
Mřížka [Činnosti menu]
Ident. Rozšířená identifikace činnosti

Mřížka [Činnosti menu] činnosti - Export slovníku textů

Mřížka [Činnosti menu] činnosti - Export slovníku textů
Ident. | Rozšířená identifikace činnosti
Činnost | Název činnosti


Přehled prováděných činností

Popis

Za určité datum zadané ve výběru má uživatel možnost zjistit, co, kdy, kde, jak dlouho a jaký uživatel prováděl za činnost v systému.

Datový model

  • BWPROVED Provedená činnost
    • BWUZIVAT Uživatel systému

    • Formulář

    Formulář činnosti - Export slovníku textů
Mřížka [Prováděné činnosti]
Listovací rámeček
Stránka #1 Prováděné činnosti
Dne | Datum provedení činnosti
Čas | Čas provedení činnosti (HHMM)
Trvání | Trvání činnosti v minutách
Uživatel | Jméno uživatele systému
Činnost | Identifikace činnosti
 | Název činnosti
 | Modul činnosti
 | Verze modulu činnosti
 | Autor činnosti
 | Poslední změna v činnosti - dne
Stránka #2 Výběr
Dne | Datum provedení činnosti
do | Datum provedení činnosti do
Činnost | Identifikace činnosti
Provedl | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Prováděné činnosti] činnosti - Export slovníku textů

    Mřížka [Prováděné činnosti] činnosti - Export slovníku textů
Dne | Datum provedení činnosti
Čas | Čas provedení činnosti (HHMM)
Trvání | Trvání činnosti v minutách
Uživatel | Jméno uživatele systému
Činnost | Identifikace činnosti
Název činnosti | Název činnosti
Modul | Modul činnosti
Verze modulu | Verze modulu činnosti
Autor činnosti | Autor činnosti
Poslední změna - dne | Poslední změna v činnosti - dne


WEB DEFINICE

Popis

WEB definice je složka menu, která je dostupná v menu Systém. Obsahuje funkce, kde je nadefinováno, jak má být vytvářeno menu v BM pro WEB. Činností „definice WEB menu“ se definuje struktura menu a činnost „druhy prvků WEB“ umožňuje nadefinovat přístupová práva, která se projevují ve vytvořeném menu na internetu.

Tento způsob navigace v BM pro WEB umožňuje integrovat v menu informace z různých zdrojů a řešení.

Viz.také

Definice WEB menu | Druhy prvků WEB


Definice WEB menu

Popis

Tato činnost poskytuje uživateli možnost nadefinovat si strukturu WEB menu. Ve vlastnostech se definují položky typu menu 1 (mohou obsahovat pouze další podmenu), položky typu menu 2 (mohou obsahovat pouze listy) a listové položky (ekvivalent koncových položek menu).

Položky typu menu mohou mít ve vlastnostech nastavený atribut "vrchol" (tj. menu bude dostupné na internetu), "default" (je vždy jediné a použije se jako vrcholové pro uživatele, kteří nemají uvedené "Explicitní WEB menu" - to se zadává v seznamu uživatelů).

Listové položky menu vyvolají při výběru buď internetovou adresu nebo pohled ve slovníku dat. Je-li funkcí vyvolání pohledu, je nutno zadat filtr pohledu a volitelně určit předlohu výstupu.

Formulář

Formulář činnosti - Menu formuláře
WEB menu

Vyvolávané činnosti

K. | Činnost | Popis
F6 | Menu formuláře | Vyvolání menu formuláře

Viz.také

Menu formuláře


Druhy prvků WEB

Popis

Každá nadefinovaná položka WEB menu je určitého druhu. Ke každému druhu prvku WEB je možno nadefinovat přístupová práva, která se projevují ve vytvořeném menu na internetu. Jednotlivé položky WEB menu se mohou vyskytovat ve více různých menu.

Datový model

  • BWWEBDRU Druh prvku WEB
    • BWUZIVAT Uživatel systému

    • Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci

    Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Druhy prvků WEB]
Druh | Identifikace druhu prvku WEB
Název druhu | Název druhu prvku WEB
Založil | Jméno uživatele systému
 | Datum založení prvku WEB
Poznámka | Poznámka

    Mřížka [Druhy prvků WEB] činnosti - Přístupová práva

    Mřížka [Druhy prvků WEB] činnosti - Přístupová práva
Druh | Identifikace druhu prvku WEB
Název druhu | Název druhu prvku WEB

    Atributy tisku

    Základní údaje
Druh | Identifikace druhu prvku WEB | BWWEBDRU_bw70id | C(6)
Název druhu | Název druhu prvku WEB | BWWEBDRU_bw70nazdru | C(40)
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(17)
Datum | Datum založení prvku WEB | BWWEBDRU_bw70datum | T
Poznámka | Poznámka | BWWEBDRU_bw70koment | M

    Viz.také

    Přístupová práva


Datový model

Popis

Fyzický datový model se skládá z definice tabulek (entit, někdy též nazývaných objekty), z definice jejich atributů a z definice souvislostí mezi tabulkami implementovanými jako relace ve vazbě na indexy. Ke zmíněným tabulkám mohou být definovány triggery.

Datový model využije uživatel při nastavení některých definičních dat. U každého datového modelu je hned na první záložce k dispozici identifikace a název tabulky a popis entity. Na dalších záložkách (atributy, relace, indexy, triggery) má uživatel k dispozici konkrétní informace k dané entitě.

Typ |
C česky | binary(délka)
C | Char(délka)
M | Long varchar
MG | Long binary
D | Date
T | Timestamp
N, délka <3, (žádné desetiny nebo L) | Tinyint
N, délka <5, (žádné desetiny nebo L) | Smallint
N, délka <10, žádné desetiny | Integer
N | Numeric(délka, desetiny)

Formulář

Formulář činnosti - Uživatelské triggery
Mřížka [Tabulky]
Tabulka | Název entity
Název tabulky | Zkrácený popis entity pro relace
Listovací rámeček
Stránka #1 Tabulky
 | Jméno autora entity
 | Datum změny struktury entity
 | Subsystém entity
Konstantní | Konstantní entita ?
Popis | Popis entity
Stránka #2 Atributy
Mřížka [Atributy]
Atribut | Název atributu
 | Poznámka - message - atributu
Typ | Typ atributu
 | Délka atributu
 | Počet desetiných míst atributu
Fiktivní | Fiktivní atribut
Návěští | Label atributu
 | Popis atributu
 | Autor atributu
 | Datum poslední změny atributu.
 | Subsystém atributu
Stránka #3 Relace
Mřížka [Relace]
Popis | Popis relace
Tabulka | Název entity
 | Zkrácený popis entity pro relace
 | Mocnost relace
 | Mocnost relace (opačná strana)
Atributy | Atributy
.= | Atributy =
 | Název relace v databázi
Stránka #4 Indexy
Mřížka [Indexy]
Název indexu | Název indexu
Indexový výraz | Indexový výraz
 | Autor indexu
 | Index změněn dne
 | Subsystém indexu
Stránka #5 Triggery
Mřížka [Triggery]
Název | Název triggeru
Kód | Kód triggeru
Poznámka | Poznámka k triggeru

Mřížka [Tabulky] činnosti - Uživatelské triggery

Mřížka [Tabulky] činnosti - Uživatelské triggery
Entita | Název entity
Název tabulky | Zkrácený popis entity pro relace

Mřížka [Atributy] činnosti - Uživatelské triggery

Mřížka [Atributy] činnosti - Uživatelské triggery
Atribut | Název atributu
Typ | Typ atributu
Délka | Délka atributu
Desetiny | Počet desetiných míst atributu
Popis | Poznámka - message - atributu

Mřížka [Relace] činnosti - Uživatelské triggery

Mřížka [Relace] činnosti - Uživatelské triggery
Tabulka | Název entity
Popis | Popis relace

Mřížka [Indexy] činnosti - Uživatelské triggery

Mřížka [Indexy] činnosti - Uživatelské triggery
Název indexu Název indexu

Mřížka [Triggery] činnosti - Uživatelské triggery

Mřížka [Triggery] činnosti - Uživatelské triggery
Název Název triggeru

Vyvolávané činnosti

K. | Činnost | Popis
F5 | Uživatelské triggery | Definování uživatelských triggerů

Viz.také

Uživatelské triggery


Uživatelské triggery

Popis

Trigger je program uložený v databázi, který je spojený s některou tabulkou databáze. Je vyvoláván při změnách dané tabulky (lze zvolit zda v okamžiku vkládání, opravy či rušení záznamu). Nemá žádné parametry a je aktivován určitou změnou dat (formulář už. triggery lze v případě potřeby uživatele pohodlně zvětšit na celou obrazovku).

Jak již vyplývá z názvu činnosti, slouží tato činnost, uložená v hlavním menu v činnosti Systém, k tvorbě uživatelem definovaných triggerů. Ty mohou sloužit k různým účelům:

¨ automatizace v aktualizaci dat (tzn. jedna uživatelská změna vyvolá řadu změn v tabulkách a záznamech) - např. uživatel má pohledávky a k nim vytvořené volné karty. Pak může být trigger napsán tak, že při změně stavu pohledávky se tato změna zapíše automaticky i do volné karty, která se k dané pohledávce vztahuje.

¨ signalizace změn dat - např. každá změna adresáře může vyvolat automatický zápis o změně a zapsat ho na vývěsku apod.

¨ autorizace změn dat - u každé změny je pak možno dohledat, kdo a kdy danou změnu provedl

Důležité upozornění: Špatně zkonstruovaným triggerem si uživatel může způsobit neodstranitelné chyby v datech, proto je třeba tuto činnost používat s rozvahou a v každém případě by uživatel měl mít alespoň min. povědomí o programování a datovém modelu IS BM. Za nejschůdnější řešení lze v případě potřeby vytvoření triggeru považovat, aby se uživatel obrátil na svého implementátora.

V definici triggeru se uvádí:

¨ tabulka, ke které přísluší

¨ název volné karty, která se k tabulce vztahuje (pouze pokud se jedná o trigger volné karty)

¨ vlastní název triggeru

¨ pořadí triggeru (toto je ve skutečném triggeru v databázi zvětšeno o 50 tak, aby nedocházelo ke konfliktu s triggery BM)

¨ timming spuštění triggeru "before" (před) nebo "after" (po) událostí, která mění data tabulky (čili zda se data změní před zapsáním událostí či až po jejich zapsání)

¨ určení, k jaké činnosti s tabulkou se trigger vztahuje, jestli se má udělat před nebo po vkládání, opravě nebo zrušení - "insert" (vkládání), "update" (oprava) nebo "delete" (rušení)

¨ kód triggeru - definice příkazu pomocí programovacích příkazů Sybase SQL Anywhere

Je-li uživatelský trigger definován, je třeba aktivovat příslušnou činnost v menu Volby „generovat triggery tabulky“ (žádný uživatel v případě generování nesmí být přítomný, tzn. „držet“ danou tabulku. Z praxe je ověřeno, že při generování triggerů je vhodné, pokud se všichni přihlášení uživatelé z IS BM odhlásí). V případě definičních dat lze uživatelský trigger vstoupit pomocí importu balíčku.

Příklad:

Typickým příkladem použití uživatelského triggeru je trigger tabulky "OBARTIKL" (obchodovatelný artikl), který při opravě technicko-věcného selektoru aktualizuje selektor odpovídajícího skladovaného artiklu (tabulka "MTARTIKL"). Kód pro událost "AFTER","UPDATE" může mít obsah:

if new_name.sp20idzak<>old_name.sp20idzak then

update %%%.mtartikl set sp20idzak=new_name.sp20idzak where

mtartikl.sp60id=new_name.sp60id and mtartikl.sp61id=new_name.sp61id and

sp20idzak<>new_name.sp20idzak;

end if;

Pozn.1: v kódu je při generování text %%% nahrazen identifikací uživatele (v daném případě BM_SERVIS)

Pozn.2: pro použití je třeba vytvořit obdobný trigger pro tabulku "MTARTIKL"

Datový model

  • BWTRGUSR Uživatelský trigger

    • Vyvolávané činnosti

    K. | Činnost | Popis
- | Generovat triggery tabulky | Generovat uživatelské triggery pro tabulku
- | Generovat všechny triggery | Generovat všechny definované uživatelské triggery
F2 | Datový model | Datový model Bílého motýla

    Formulář

    Formulář činnosti - Generovat všechny triggery
Mřížka [Uživatelské triggery]
Listovací rámeček
Stránka #1 Uživatelské triggery
Tabulka | Název entity
VK | Název volné karty
 | Zkrácený popis entity pro relace
Název | Název triggeru
Pořadí | Pořadí triggeru
 | Spuštění triggeru Před/Po události
Událost | Událost, která vyvolá trigger Vkládání/Oprava/Rušení
Kód | Kód triggeru
Poznámka | Poznámka k triggeru
Stránka #2 Výběr
Tabulka | Název entity
Název | Název triggeru
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Uživatelské triggery] činnosti - Generovat všechny triggery

    Mřížka [Uživatelské triggery] činnosti - Generovat všechny triggery
Tabulka | Název entity
Název | Název triggeru
Pořadí | Pořadí triggeru

    Atributy tisku

    Základní údaje
Tabulka | Název entity | BWTRGUSR_bw10nazev | C(8)
Karta | Název volné karty | BWTRGUSR_sp64nazev | C(8)
Název | Název triggeru | BWTRGUSR_bw72nazev | C(40)
Pořadí | Pořadí triggeru | BWTRGUSR_bw72poradi | N(2)
Spustit | Spuštění triggeru Před/Po události | Výpočet | C(6)
Událost | Událost, která vyvolá trigger Vkládání/Oprava/Rušení | Výpočet | C(6)
Kód | Kód triggeru | BWTRGUSR_bw72kod | M
Poznámka | Poznámka k triggeru | BWTRGUSR_bw72koment | M

    Viz.také

    Generovat triggery tabulky | Generovat všechny triggery | Datový model


Nastavení sledování změn tabulek

Popis

Tato činnost umožňuje uživateli určit tabulky, jejichž změny záznamů mají být sledovány. Změny nadefinovaných tabulek je pak možno prohlížet v činnosti „přehled změn záznamů tabulek“ (menu Systém). Kromě změn v tabulkách umožňuje IS BM sledovat také změny záznamů na volných kartách.

Po aktivaci této činnosti uživatel definuje následující položky:

¨ tabulka - identifikace tabulky IS BM (výběr se seznamu tabulek obsažených v datovém modelu)

¨ VK – název volné karty, která je spojena s tabulkou. Při změně struktury volné karty nejsou automaticky přegenerovávány triggery pro sledování změn záznamů VK. Generovat triggery je možno z formuláře definování VK volbou „generovat triggery tabulky“ nebo z menu Volby tohoto formuláře vyvolat „nastavení sledování změn tabulek“ a „uživatelské triggery“.

¨ založení - Ano/Ne – zda bude zaznamenávána informace o založení záznamu do tabulky

¨ oprava - Ano/Ne – zda bude zaznamenávána informace o změně záznamu tabulky

¨ zrušení - Ano/Ne – zda bude zaznamenávána informace o zrušení záznamu tabulky

¨ podmínka - omezuje množinu sledovaných záznamů. Je to výraz v syntaxi Sybase SQL Anywhere - před jednotlivými atributy je třeba uvádět prefix $$$., který je v generovaných triggerech nahrazován textem new_name, resp. old_name

¨ atributy – výběr z překryvného seznamu - určuje způsob výběru atributů uvedených v následujícím atributu 'seznam atributů'. Je možno zvolit „všechny vyjmenované atributy“ nebo „všechny kromě vyjmenovaných atributů“

¨ seznam atributů - uvádí se přímo seznam atributů tabulky, jejichž hodnoty mají být, resp. nemají být sledovány (v návaznosti na to, co je uvedeno u atributu „atributy“)

¨ výraz popisu - výraz v syntaxi Sybase SQL Anywhere - před jednotlivými atributy je třeba uvádět prefix $$$., který je v generovaných triggerech nahrazován textem new_name resp. old_name

¨ aktivní - Ano/Ne - nastavení Ne je určeno pro pozastavení sledování změn (např. před hromadnou změnou dat pomocí ISQL)

¨ poznámka - libovolný text

Po vložení definic sledování změn je třeba vygenerovat triggery, které budou sledovat změny v určených tabulkách. Toto generování se provede aktivací příslušné činnosti z menu Volby:

¨ generovat triggery tabulky – pouze pro aktuální definici tabulky

¨ generovat všechny triggery - pro všechny definice tabulek

Jejich funkčnost je totožná s činností „uživatelské triggery“. Při generování triggerů je nutné, aby v daném okamžiku nepracoval s dotyčnými tabulkami jiný uživatel.

Příklady výrazu popisu:

Tabulka ADADSAT - $$$.ad01adsat

Tabulka ADADR - (select ad01adsat from %%%.ADADSAT where ad01id=$$$.ad01id)

Tabulka ADSPOJ - (select ad01adsat from %%%.ADADSAT where ad01id=$$$.ad01id)

Tabulka SPARTIKN (název artiklu) - $$$.sp62artikl

Tabulka OBARTIKL - (select sp62artikl from %%%.SPARTIKN where sp61id=$$$.sp61id and sp60id=$$$.sp60id and sp38id='CZE')

Tabulka MTARTIKL - (select sp62artikl from %%%.SPARTIKN where sp61id=$$$.sp61id and sp60id=$$$.sp60id and sp38id='CZE')

Omezení sledování změn tabulky obchodovatelného artiklu (OBARTIKL) výhradně pro druh artiklu 'ZBO' .

Podmínka = $$$.sp61id='ZBO'

Při sledování změn tabulky uživatelé programu (BWUZIVAT) je vhodné vyloučit ze sledování atributy BW01NAPOSL (Datum a čas posledního vyvolání systému - aktualizuje se při každém přihlášení uživatele) a SP38ID (Identifikace jazyka - může uživatel sám měnit). Pak je nastavení následující:

¨ Atributy = všechny kromě vyjmenovaných atributů

¨ Seznam atributů = bw01naposl,sp38id

Datový model

  • BWTRGUSR Uživatelský trigger

    • Formulář

    Formulář činnosti - Generovat všechny triggery
Mřížka [Nastavení sledování změn tabulky]
Tabulka | Název entity
Název tabulky | Zkrácený popis entity pro relace
VK | Název volné karty
Založení | Sledovat změny typu založení záznamu
Oprava | Sledovat změny typu oprava záznamu
Zrušení | Sledovat změny typu zrušení záznamu
Podmínka | Výraz podmínky sledování záznamu - uvádějte v syntaxi SQL $$$ bude nahrazeno new_name resp. old_name
Atributy | Výběr atributů
Seznam atributů | Seznam atributů pro výběr sledování
Výraz popisu | Výraz popisu záznamu - uvádějte v syntaxi SQL $$$ bude nahrazeno new_name resp. old_name
Aktivní | Aktivní Ano/Ne
Poznámka | Poznámka k triggeru

    Mřížka [Nastavení sledování změn tabulky] činnosti - Generovat všechny triggery

    Mřížka [Nastavení sledování změn tabulky] činnosti - Generovat všechny triggery
Tabulka | Název entity
VK | Název volné karty
Název tabulky | Zkrácený popis entity pro relace

    Vyvolávané činnosti

    K. | Činnost | Popis
- | Generovat triggery tabulky | Generovat uživatelské triggery pro tabulku
- | Generovat všechny triggery | Generovat všechny definované uživatelské triggery
F2 | Datový model | Datový model Bílého motýla

    Atributy tisku

    Základní údaje
Tabulka | Název entity | BWTRGUSR_bw10nazev | C(8)
VK | Název volné karty | BWTRGUSR_sp64nazev | C(8)
Založení | Sledovat změny typu založení záznamu | Výpočet | C(3)
Oprava | Sledovat změny typu oprava záznamu | Výpočet | C(3)
Zrušení | Sledovat změny typu zrušení záznamu | Výpočet | C(3)
Atributy | Výběr atributů | Výpočet | C(36)
Seznam atributů | Seznam atributů pro výběr sledování | BWTRGUSR_bw72sleatr | M
Podmínka | Výraz podmínky sledování záznamu - uvádějte v syntaxi SQL $$$ bude nahrazeno new_name resp. old_name | BWTRGUSR_bw72slevyb | M
Aktivní | Aktivní Ano/Ne | Výpočet | C(3)
Výraz popisu | Výraz popisu záznamu - uvádějte v syntaxi SQL $$$ bude nahrazeno new_name resp. old_name | BWTRGUSR_bw72vyrpop | M
Poznámka | Poznámka k triggeru | BWTRGUSR_bw72koment | M

    Viz.také

    Generovat triggery tabulky | Generovat všechny triggery | Datový model


Rezervované zdroje systému

Popis

Uživatel má k dispozici tabulku, která obsahuje informace o rezervovaném zdroji a uživateli, který si zdroj rezervoval, jeho důvodu a času rezervace. Tuto činnost má uživatel k dispozici pod skupinovou položkou hlavního menu SYSTÉM. Jednotlivé zobrazené rezervace, které se zobrazují uživateli se do této činnosti zapisují nepřímo pomocí jiných činností:

¨ výkazy

¨ přepočet hodnot

Datový model

  • BWSEMAF Semafor pro blokování činností

    • Formulář

    Formulář činnosti - Generovat všechny triggery
Mřížka [Semafor]
Zdroj | Identifikace zdroje systému
Výhradně | Příznak výhradní rezervace zdroje
Uživatel | Jméno uživatele systému
Důvod | Důvod rezervace zdroje
Čas | Čas rezervace zdroje
Spojení | Číslo spojení uživatele rezervujícího zdroj

    Mřížka [Semafor] činnosti - Generovat všechny triggery

    Mřížka [Semafor] činnosti - Generovat všechny triggery
Zdroj | Identifikace zdroje systému
Výhradně | Příznak výhradní rezervace zdroje
Uživatel | Jméno uživatele systému
Důvod | Důvod rezervace zdroje
Čas | Čas rezervace zdroje
Spojení | Číslo spojení uživatele rezervujícího zdroj


Logické tiskárny

Popis

Vlastnosti předlohy výstupu (záložka Info) byly doplněny o možnost určení "Logické tiskárny". Logická tiskárna určuje nepřímo skutečnou fyzickou tiskárnu, na kterou má být proveden výstup. Logické tiskárny se definují v menu SYSTÉM spolu s dalšími souvisejícími objekty. Jsou to:

1. Logické tiskárny

2. Fyzické tiskárny

3. Pracoviště uživatelů BM

4. Počítače uživatelů BM

Logická tiskárna (1.) je propojena s pracovištěm (3.) a v této vazbě je odkaz na fyzickou tiskárnu (3.). Pracoviště (3.) definuje množinu počítačů (4.), které mají z hlediska výstupu na tiskárnu shodné vlastnosti. Přidělení logické tiskárny předloze výstupu má význam při přímém výstupu na tiskárnu klasickou předlohou nebo předlohou typu Excel.

Je-li uvedena, potom při přímém výstupu BM před tiskem vyhledává podle systémové (Windows) identifikace počítače (4.) vazbou pracoviště (3.) na danou logickou tiskárnu (1.) konkrétní fyzickou tiskárnu (2.), na kterou má být proveden výstup. Je-li taková fyzická tiskárna nalezena, potom BM vloží do předlohy parametry nalezené tiskárny. Není-li nalezena, potom je před tiskem uživatel vyzván k výběru tiskárny, i když podle profilu měl být proveden přímý výstup bez dotazu na výstupní tiskárnu.

Fyzická tiskárna k logické tiskárně není nalezena v případě, že pro odpovídající pracoviště není definována vazba na odpovídající logickou tiskárnu nebo není-li fyzická tiskárna aktivní (vlastnost objektu fyzická tiskárna).

Příklady logických tiskáren:

¨ výstup na hlavičkový papír

¨ výstup na běžný papír

¨ výstup na obálky

¨ výstup na etikety

¨ ....

Má-li skutečná tiskárna více zásobníků pro vstup papíru, je pro ní možné definovat více fyzických tiskáren. Tato možnost se bohužel neuplatní při výstupu předlohou typu Excel.

Nastavení parametrů fyzické tiskárny se provádí v předhledu fyzických tiskáren klávesou F5, po které se zobrazí prázdná výstupní předloha, ve které se volbou menu "Soubor" -> "Vzhled stránky" určí parametry tiskárny. Tiskárny uvedené v metapředlohách jsou logické tiskárny. Metapředloha může změnit logickou tiskárnu definovanou v ní obsažené předloze. Při výstupu do Excel je v ní možné určit současný výstup na více různých logických tiskáren.

Datový model

  • BWPRINML Logická tiskárna systému BM

    • Formulář

    Formulář činnosti - Pracoviště uživatelů BM
Mřížka [Logické tiskárny]
L-Tiskárna | Identifikace logické tiskárny systému BM
Název logické tiskárny | Název logické tiskárny
Listovací rámeček
Stránka #1 Logické tiskárny
Poznámka | Poznámka
Stránka #2 Pracoviště
Mřížka [Pracoviště]
Pracoviště | Identifikace pracoviště uživatele BM
Název pracoviště | Název pracoviště
F-Tiskárna | Identifikace fyzické tiskárny
Název BM | Název tiskárny v BM
Název WINDOWS | Název tiskárny ve WINDOWS

    Mřížka [Logické tiskárny] činnosti - Pracoviště uživatelů BM

    Mřížka [Logické tiskárny] činnosti - Pracoviště uživatelů BM
L-Tiskárna | Identifikace logické tiskárny systému BM
Název logické tiskárny | Název logické tiskárny

    Mřížka [Pracoviště] činnosti - Pracoviště uživatelů BM

    Mřížka [Pracoviště] činnosti - Pracoviště uživatelů BM
Pracoviště | Identifikace pracoviště uživatele BM
Název pracoviště | Název pracoviště
F-Tiskárna | Identifikace fyzické tiskárny
Název BM | Název tiskárny v BM
Název WINDOWS | Název tiskárny ve WINDOWS
Aktivní | Tiskárna nastavena pro výstup Ano,Ne

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Fyzické tiskárny | Fyzické tiskárny
F2 | Pracoviště uživatelů BM | Pracoviště uživatelů systému BM

    Atributy tisku

    Základní údaje
L-Tiskárna | Identifikace logické tiskárny systému BM | BWPRINML_bw85id | C(6)
Název logické tiskárny | Název logické tiskárny | BWPRINML_bw85logtis | C(40)
Poznámka | Poznámka | BWPRINML_bw85koment | M
Pracoviště | Identifikace pracoviště uživatele BM | BWPRINMP_bw83id | C(6)
Název pracoviště | Název pracoviště | BWPRINMP_bw83nazpra | C(40)
Poznámka | Poznámka | BWPRINMP_bw83koment | M
F-Tiskárna | Identifikace fyzické tiskárny | BWPRINMF_bw84id | C(6)
Název BM | Název tiskárny v BM | BWPRINMF_bw84fyztis | C(40)
Název WINDOWS | Název tiskárny ve WINDOWS | BWPRINMF_bw84sysid | C(60)
Aktivní | Tiskárna nastavena pro výstup Ano,Ne | Výpočet | C(3)
Poznámka | Poznámka | BWPRINMF_bw84koment | M

    Viz.také

    Fyzické tiskárny | Pracoviště uživatelů BM


Fyzické tiskárny

Popis

Vlastnosti předlohy výstupu (záložka Info) byly doplněny o možnost určení "Logické tiskárny". Logická tiskárna určuje nepřímo skutečnou fyzickou tiskárnu, na kterou má být proveden výstup. Logické tiskárny se definují v menu SYSTÉM spolu s dalšími souvisejícími objekty. Jsou to:

1. Logické tiskárny

2. Fyzické tiskárny

3. Pracoviště uživatelů BM

4. Počítače uživatelů BM

Logická tiskárna (1.) je propojena s pracovištěm (3.) a v této vazbě je odkaz na fyzickou tiskárnu (3.). Pracoviště (3.) definuje množinu počítačů (4.), které mají z hlediska výstupu na tiskárnu shodné vlastnosti. Přidělení logické tiskárny předloze výstupu má význam při přímém výstupu na tiskárnu klasickou předlohou nebo předlohou typu Excel.

Je-li uvedena, potom při přímém výstupu BM před tiskem vyhledává podle systémové (Windows) identifikace počítače (4.) vazbou pracoviště (3.) na danou logickou tiskárnu (1.) konkrétní fyzickou tiskárnu (2.), na kterou má být proveden výstup. Je-li taková fyzická tiskárna nalezena, potom BM vloží do předlohy parametry nalezené tiskárny. Není-li nalezena, potom je před tiskem uživatel vyzván k výběru tiskárny, i když podle profilu měl být proveden přímý výstup bez dotazu na výstupní tiskárnu.

Fyzická tiskárna k logické tiskárně není nalezena v případě, že pro odpovídající pracoviště není definována vazba na odpovídající logickou tiskárnu nebo není-li fyzická tiskárna aktivní (vlastnost objektu fyzická tiskárna).

Má-li skutečná tiskárna více příhradek pro vstup papíru, je pro ní možné definovat více fyzických tiskáren. Tato možnost se bohužel neuplatní při výstupu předlohou typu Excel.

Nastavení parametrů fyzické tiskárny se provádí v předhledu fyzických tiskáren klávesou F5, po které se zobrazí prázdná výstupní předloha, ve které se volbou menu "Soubor" -> "Vzhled stránky" určí parametry tiskárny. Tiskárny uvedené v metapředlohách jsou logické tiskárny. Metapředloha může změnit logickou tiskárnu definovanou v ní obsažené předloze. Při výstupu do Excel je v ní možné určit současný výstup na více různých logických tiskáren.

Datový model

  • BWPRINMF Fyzická tiskárna
    • BWPRINMC Počítač uživatele systému BM

    • Formulář

    Formulář činnosti - Typy tiskáren
Mřížka [Fyzické tiskárny]
F-Tiskárna | Identifikace fyzické tiskárny
Název BM | Název tiskárny v BM
Počítač | Identifikace počítače, ke kterému je tiskárna připojena lokálně
Název počítače | Název počítače v BM
Listovací rámeček
Stránka #1 Fyzické tiskárny
Typ | Identifikace typu fyzické tiskárny
Lokální název WIN | Název tiskárny ve WINDOWS na lokálním počítači
Popis tiskárny | Popis tiskárny
Síťový název WIN | Název tiskárny ve WINDOWS
Popis tiskárny | Popis tiskárny
Aktivní | Tiskárna nastavena pro výstup Ano,Ne
Grafická | Grafická tiskárna Ano/Ne - Ne = např.jehličková tiskárna - vyžaduje uzpůsobené předlohy výstupu
CP | Kódová stránka negrafické tiskárny
Init.kód | Inicializační kód negrafické tiskárny (hexa)
Sloupců | Počet sloupců negrafické tiskárny
Řádků | Počet řádků negrafické tiskárny
Testovací mód | Testovací mód - výstup na negrafickou tiskárnu bude prováděn do souboru
Poznámka | Poznámka
Stránka #2 Pracoviště
Mřížka [Pracoviště]
Pracoviště | Identifikace pracoviště uživatele BM
Název pracoviště | Název pracoviště
L-Tiskárna | Identifikace logické tiskárny systému BM
Název logické tiskárny | Název logické tiskárny

    Mřížka [Fyzické tiskárny] činnosti - Typy tiskáren

    Mřížka [Fyzické tiskárny] činnosti - Typy tiskáren
F-Tiskárna | Identifikace fyzické tiskárny
Název BM | Název tiskárny v BM
Aktivní | Tiskárna nastavena pro výstup Ano,Ne
Název WINDOWS | Název tiskárny ve WINDOWS
Lokální název WIN | Název tiskárny ve WINDOWS na lokálním počítači
Počítač | Identifikace počítače v BM
Název počítače | Název počítače v BM
Název WINDOWS | Úplný název počítače ve WINDOWS

    Mřížka [Pracoviště] činnosti - Typy tiskáren

    Mřížka [Pracoviště] činnosti - Typy tiskáren
Pracoviště | Identifikace pracoviště uživatele BM
Název pracoviště | Název pracoviště
L-Tiskárna | Identifikace logické tiskárny systému BM
Název logické tiskárny | Název logické tiskárny

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Definovat nastavení tiskárny | Definovat nastavení tiskárny
F2 | Logické tiskárny | Logické tiskárny
F2 | Počítače uživatelů BM | Počítače uživatelů BM
F2 | Pracoviště uživatelů BM | Pracoviště uživatelů systému BM
F2 | Typy tiskáren | Přehled typů tiskáren
F2 | Vybrat tiskárnu | Vybrat tiskárnu

    Atributy tisku

    Základní údaje
F-Tiskárna | Identifikace fyzické tiskárny | BWPRINMF_bw84id | C(6)
Název BM | Název tiskárny v BM | BWPRINMF_bw84fyztis | C(40)
Typ | Identifikace typu fyzické tiskárny | BWPRINMF_bw97id | C(6)
Název typu | Název typu fyzické tiskárny | BWPRINMT_bw97naztyp | C(40)
Název WINDOWS | Název tiskárny ve WINDOWS | BWPRINMF_bw84sysid | C(60)
Aktivní | Tiskárna nastavena pro výstup Ano,Ne | Výpočet | C(3)
Grafická | Grafická tiskárna Ano/Ne - Ne = např.jehličková tiskárna - vyžaduje uzpůsobené předlohy výstupu | Výpočet | C(3)
CP | Kódová stránka negrafické tiskárny | BWPRINMF_bw84cppage | N(4)
Init.kód | Inicializační kód negrafické tiskárny (hexa) | BWPRINMF_bw84kodini | C(40)
Sloupců | Počet sloupců negrafické tiskárny | BWPRINMF_bw84cols | N(5)
Řádků | Počet řádků negrafické tiskárny | BWPRINMF_bw84rows | N(5)
Testovací mód | Testovací mód - výstup na negrafickou tiskárnu bude prováděn do souboru | Výpočet | C(3)
Poznámka | Poznámka | BWPRINMF_bw84koment | M
Pracoviště | Identifikace pracoviště uživatele BM | BWPRINMP_bw83id | C(6)
Název pracoviště | Název pracoviště | BWPRINMP_bw83nazpra | C(40)
Poznámka | Poznámka | BWPRINMP_bw83koment | M
L-Tiskárna | Identifikace logické tiskárny systému BM | BWPRINML_bw85id | C(6)
Název logické tiskárny | Název logické tiskárny | BWPRINML_bw85logtis | C(40)
Poznámka | Poznámka | BWPRINML_bw85koment | M

    Viz.také

    Definovat nastavení tiskárny | Logické tiskárny | Počítače uživatelů BM | Pracoviště uživatelů BM | Typy tiskáren | Vybrat tiskárnu


Pracoviště uživatelů BM

Popis

V této činnosti se definují jednotlivá pracoviště uživatelů BM. Ke každému pracovišti je možno na záložkách přiřadit logickou a fyzickou tiskárnu a počítače, které náleží k pracovišti.

Datový model

  • BWPRINMP Pracoviště uživatele systému BM

    • Formulář

    Formulář činnosti - Logické tiskárny
Mřížka [Pracoviště]
Pracoviště | Identifikace pracoviště uživatele BM
Název pracoviště | Název pracoviště
Listovací rámeček
Stránka #1 Pracoviště
Poznámka | Poznámka
Stránka #2 Logické tiskárny
Mřížka [Logické tiskárny]
L-Tiskárna | Identifikace logické tiskárny systému BM
Název logické tiskárny | Název logické tiskárny
F-Tiskárna | Identifikace fyzické tiskárny
Název BM | Název tiskárny v BM
Název WINDOWS | Název tiskárny ve WINDOWS
Stránka #3 Počítače na pracovišti
Mřížka [Počítače na pracovišti]
Počítač | Identifikace počítače v BM
Název počítače | Název počítače v BM
Název WINDOWS | Úplný název počítače ve WINDOWS
Poznámka | Poznámka

    Mřížka [Pracoviště] činnosti - Logické tiskárny

    Mřížka [Pracoviště] činnosti - Logické tiskárny
Pracoviště | Identifikace pracoviště uživatele BM
Název pracoviště | Název pracoviště

    Mřížka [Logické tiskárny] činnosti - Logické tiskárny

    Mřížka [Logické tiskárny] činnosti - Logické tiskárny
L-Tiskárna | Identifikace logické tiskárny systému BM
Název logické tiskárny | Název logické tiskárny
F-Tiskárna | Identifikace fyzické tiskárny
Název BM | Název tiskárny v BM
Název WINDOWS | Název tiskárny ve WINDOWS
Aktivní | Tiskárna nastavena pro výstup Ano,Ne

    Mřížka [Počítače na pracovišti] činnosti - Logické tiskárny

    Mřížka [Počítače na pracovišti] činnosti - Logické tiskárny
Počítač | Identifikace počítače v BM
Název počítače | Název počítače v BM
Název WINDOWS | Úplný název počítače ve WINDOWS

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Fyzické tiskárny | Fyzické tiskárny
F2 | Logické tiskárny | Logické tiskárny

    Atributy tisku

    Základní údaje
Pracoviště | Identifikace pracoviště uživatele BM | BWPRINMP_bw83id | C(6)
Název pracoviště | Název pracoviště | BWPRINMP_bw83nazpra | C(40)
Poznámka | Poznámka | BWPRINMP_bw83koment | M
F-Tiskárna | Identifikace fyzické tiskárny | BWPRINMF_bw84id | C(6)
Název BM | Název tiskárny v BM | BWPRINMF_bw84fyztis | C(40)
Název WINDOWS | Název tiskárny ve WINDOWS | BWPRINMF_bw84sysid | C(60)
Aktivní | Tiskárna nastavena pro výstup Ano,Ne | Výpočet | C(3)
Poznámka | Poznámka | BWPRINMF_bw84koment | M
L-Tiskárna | Identifikace logické tiskárny systému BM | BWPRINML_bw85id | C(6)
Název logické tiskárny | Název logické tiskárny | BWPRINML_bw85logtis | C(40)
Poznámka | Poznámka | BWPRINML_bw85koment | M

    Při pohybu v Počítače na pracovišti
Počítač | Identifikace počítače v BM | BWPRINMC_bw87id | C(6)
Název WINDOWS | Úplný název počítače ve WINDOWS | BWPRINMC_bw87sysid | C(60)
Název počítače | Název počítače v BM | BWPRINMC_bw87nazpoc | C(40)
Poznámka | Poznámka | BWPRINMC_bw87koment | M

    Viz.také

    Fyzické tiskárny | Logické tiskárny


Počítače uživatelů BM

Popis

V této činnosti se definují jednotlivé počítače uživatelů IS BM. U každého záznamu se eviduje:

¨ identifikace a název PC

¨ úplný název PC ve Windows

¨ identifikace a název pracoviště

¨ libovolná poznámka

Datový model

  • BWPRINMC Počítač uživatele systému BM
    • BWPRINMP Pracoviště uživatele systému BM

    • Formulář

    Formulář činnosti - Pracoviště uživatelů BM
Mřížka [Počítače]
Počítač | Identifikace počítače v BM
Název počítače | Název počítače v BM
Název WINDOWS | Úplný název počítače ve WINDOWS
Pracoviště | Identifikace pracoviště uživatele BM
Název pracoviště | Název pracoviště
Poznámka | Poznámka

    Mřížka [Počítače] činnosti - Pracoviště uživatelů BM

    Mřížka [Počítače] činnosti - Pracoviště uživatelů BM
Počítač | Identifikace počítače v BM
Název počítače | Název počítače v BM
Název WINDOWS | Úplný název počítače ve WINDOWS
Pracoviště | Identifikace pracoviště uživatele BM
Název pracoviště | Název pracoviště

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Pracoviště uživatelů BM | Pracoviště uživatelů systému BM

    Atributy tisku

    Základní údaje
Počítač | Identifikace počítače v BM | BWPRINMC_bw87id | C(6)
Název počítače | Název počítače v BM | BWPRINMC_bw87nazpoc | C(40)
Název WINDOWS | Úplný název počítače ve WINDOWS | BWPRINMC_bw87sysid | C(60)
Pracoviště | Identifikace pracoviště uživatele BM | BWPRINMC_bw83id | C(6)
Název pracoviště | Název pracoviště | BWPRINMP_bw83nazpra | C(40)
Poznámka | Poznámka | BWPRINMC_bw87koment | M

    Viz.také

    Pracoviště uživatelů BM


Uložit obrázek v clipboardu

Popis

Tato činnost umožňuje uživateli načíst do systému obrázek, který má uložen v clipboardu (tzn. načten pomocí činnosti "kopírovat" nebo klávesami Ctrl C, případně klávesou Prt Scrn). Po aktivaci této činnosti je obrázek vložen do rámečku a uživatel má možnost ho po stisku klávesy OK uložit (zvolí si cestu kam) a nebo je po stisku klávesy Storno tato činnost beze změn ukončena.


Otevřít HTML dokument

Popis

Tato činnost poskytuje uživateli možnost aktivovat si vybraný dokument typu HTML. Po spuštění činnosti si uživatel z přehledu souborů vybere ten, který chce spustit (soubor s příponou htm).


Nastavení programu BM

Popis

Nastavení pro IS BM se původně ukládala v souboru BW.INI. V současnosti se již nastavení pro IS BM ukládají přímo do dat (tabulka BWOPTION a BWOPTIOC) v činnosti „Nastavení programu BM“ (menu Systém).

Tato činnost poskytuje uživateli možnost definice jednotlivých nastavení potřebných pro IS BM. Význam nastavení včetně jejich popisu definují programátoři v Galaxii a při instalaci nové verze jsou nová nastavení programu BM do dat automaticky přidávána. Při doplňování nového nastavení do dat, které je aktuálně nastaveno také v souboru BW.INI je toto nastavení do této činnosti přidáno s hodnotou, která je nastavená v souboru BW.INI.

V přehledu definic nastavení programu BM jsou nastavení, která je možné definovat pouze v souboru BW.INI zobrazována v šedivých řádcích (jedná se o informace, které jsou pro program potřebné ještě před jeho vlastním připojením k databázovému serveru). Těmto nastavením zde není možné definovat žádnou hodnotu.

Nastavení, která je možná definovat v datech, jsou zobrazena v bílých řádcích a případné změny odpovídajících parametrů v souboru BW.INI nemají po instalaci nové verze žádný vliv na chod programu. Některá nastavení je možné definovat pouze lokálně pro datová úložiště nebo konkrétní počítače. Přitom v lokální definici hodnota datového úložiště „-„ znamená libovolné datové úložiště a hodnota počítač „-„ znamená libovolný počítač.

Přeložené texty popisků formulářů jsou ukládány mimo SQL databázi implementace BM nebo v databázi implementace BM. O tom rozhoduje nastavení programu BM – Preferences – Slovník SQL. Hodnoty mohou být

¨ 0 (implicitní) – přeložené texty jsou ukládány v souborech SLOVNIK\SLOV_XXX.DBF a SLOVNIK\SLOV_XXX.FPT a SLOVNIK\SLOV_XXX.CDX, kde XXX je identifikace jazyka

¨ 1 – přeložené texty jsou ukládány do tabulky BWSLOVNI v SQL databázi

Datový model

  • BWOPTION Nastavení programu BM

    • Formulář

    Formulář činnosti - Počítače uživatelů BM
Mřížka [Nastavení]
Sekce | Sekce nastavení
Parametr | Identifikátor nastavení
Hodnota | Hodnota parametru nastavení
Default | Default hodnota nastavení
Listovací rámeček
Stránka #1 Nastavení
Pouze BW.INI | Nastavení musí být provedeno v BW.INI
Lokální | Je možné lokální nastavení ?
Aktualizace | Datum vzniku nebo aktualizace parametru u dodavatele systému
Popis nastavení | Popis nastavení
Stránka #2 Nastavení počítačů
Mřížka [Nastavení počítačů]
IDÚ | Identifikace datového úložiště
Pořadí | Pořadí vyhodnocení
Počítač | Identifikace počítače v BM
Název počítače | Název počítače v BM
Hodnota | Hodnota parametru nastavení

    Mřížka [Nastavení] činnosti - Počítače uživatelů BM

    Mřížka [Nastavení] činnosti - Počítače uživatelů BM
Sekce | Sekce nastavení
Parametr | Identifikátor nastavení
Hodnota | Hodnota parametru nastavení
Default | Default hodnota nastavení
Aktualizace | Datum vzniku nebo aktualizace parametru u dodavatele systému

    Mřížka [Nastavení počítačů] činnosti - Počítače uživatelů BM

    Mřížka [Nastavení počítačů] činnosti - Počítače uživatelů BM
Pořadí | Pořadí vyhodnocení
IDÚ | Identifikace datového úložiště
Počítač | Identifikace počítače v BM
Název počítače | Název počítače v BM
Hodnota | Hodnota parametru nastavení

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Počítače uživatelů BM | Počítače uživatelů BM

    Atributy tisku

    Základní údaje
Sekce | Sekce nastavení | BWOPTION_bw90sect | C(20)
Parametr | Identifikátor nastavení | BWOPTION_bw90id | C(40)
Pouze BW.INI | Nastavení musí být provedeno v BW.INI | Výpočet | C(3)
Lokální | Je možné lokální nastavení ? | Výpočet | C(3)
Hodnota | Hodnota parametru nastavení | BWOPTION_bw90value | C(80)
Default | Default hodnota nastavení | BWOPTION_bw90defval | C(80)
Aktualizace | Datum vzniku nebo aktualizace parametru u dodavatele systému | BWOPTION_bw90datakt | T
Popis nastavení | Popis nastavení | BWOPTION_bw90koment | M
Název počítače | Název počítače v BM | BWPRINMC_bw87nazpoc | C(40)

    Při pohybu v Nastavení počítače
IDÚ | Identifikace datového úložiště | BWOPTIOC_bw91idu | C(2)
Pořadí | Pořadí vyhodnocení | BWOPTIOC_bw91porad | N(3)
Počítač | Identifikace počítače v BM | BWOPTIOC_bw87id | C(6)
Hodnota | Hodnota parametru nastavení | BWOPTIOC_bw91value | C(80)

    Viz.také

    Počítače uživatelů BM


Přehled změn záznamů tabulek

Popis

Tato činnost poskytuje uživateli přehled změn, které byly provedeny ve vybraných tabulkách. Které změny se budou sledovat a v jakých tabulkách přímo souvisí s nastavením definic v činnosti „nastavení sledování změn tabulek“.

Pro snadnější vyhledávání změněných záznamů tabulek je po aktivaci této činnosti k dispozici výběrová záložka. Uživatel má k dispozici tyto atributy:

¨ tabulka - identifikace tabulky IS BM

¨ popis - předplněný podle výrazu popisu v definici - je ho možné upravovat

¨ změna - může dosahovat hodnot založení/oprava/zrušení

¨ klíč - text odpovídající primárnímu klíči záznamu

¨ uživatel - jméno uživatele (pro změny provedené mimo IS BM uživatel SYSTÉM)

¨ datum a čas změny

¨ poznámka - libovolný text

Na záložce „atributy“ jsou zaznamenány změny jednotlivých atributů v tabulkách. Změna typu „založení“ nezaznamenává vstoupené atributy. Změna typu „oprava“ zaznamenává původní a nové hodnoty změněných atributů. Změna typu „zrušení“ zaznamenává původní hodnoty atributů zrušeného záznamu s výjimkou prázdných textových atributů (C resp.char) a poznámky (M resp. long varchar).

Po spuštění formulářů, které pracují s tabulkou uvedenou v činnosti „nastavení sledování změn tabulek“ je možné pro aktuální záznam vyvolat formulář „přehled změn záznamů tabulek“ (činnost v menu Obecné - Přehled změn záznamu). Přitom se automaticky odpovídajícím způsobem předplní výběrová záložka.

Při implementaci IS BM s použitím replikací je třeba řešit problém identifikace uživatele, který provedl změnu. Změny dat prováděné triggery totiž nejsou replikovány, protože se předpokládá, že totožný trigger bude spuštěn na vzdáleném počítači při synchronizaci dat prováděné replikačním agentem. Replikační agent však nemůže identifikovat uživatele IS BM, který provedl změnu. Proto záznamy o změnách dat, které byly provedeny na vzdáleném datovém úložišti mají uvedeného uživatele SYSTÉM.

Pro následné doplnění uživatele, který skutečně provedl změnu je k dispozici uložená procedura:

'BWUPDRC prepis bw01uziv'

kterou je možné vyvolávat událostním triggerem v syntaxi:

CALL bm_servis."BWUPDRC prepis bw01uziv"().

Datový model

  • BWUPDRC Zápis o změně záznamu tabulky
    • BWUZIVAT Uživatel systému

    • Formulář

    Formulář činnosti - Spustit operaci
Mřížka [Změny záznamů]
Tabulka | Název entity
Název tabulky | Zkrácený popis entity pro relace
VK | Název volné karty
Popis | Popis záznamu
Listovací rámeček
Stránka #1 Změny záznamů
Změna | Změna - oprava záznamu nebo zrušení záznamu
Klíč | Klíč změněného záznamu
Dne | Datum a čas změny záznamu
Uživatel | Jméno uživatele systému
Poznámka | Poznámka
Stránka #2 Atributy
Mřížka [Atributy]
Atribut | Název atributu
Popis | Popis atributu
Nová | Nová hodnota atributu
Původní | Původní hodnota atributu
Stránka #3 Výběr
Tabulka | Název entity
VK | Název volné karty
Atribut | Název atributu
Popis | Popis záznamu
Změna | Změna - oprava záznamu nebo zrušení záznamu
Klíč | Klíč změněného záznamu
Dne | Datum a čas změny záznamu
 | Datum a čas změny záznamu do
Změnil | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Změny záznamů] činnosti - Spustit operaci

    Mřížka [Změny záznamů] činnosti - Spustit operaci
Změna | Změna - oprava záznamu nebo zrušení záznamu
Tabulka | Název entity
Název tabulky | Zkrácený popis entity pro relace
Klíč | Klíč změněného záznamu
Popis | Popis záznamu
Dne | Datum a čas změny záznamu
Uživatel | Jméno uživatele systému
VK | Název volné karty

    Mřížka [Atributy] činnosti - Spustit operaci

    Mřížka [Atributy] činnosti - Spustit operaci
Atribut | Název atributu
Popis | Popis atributu
Nová | Nová hodnota atributu
Původní | Původní hodnota atributu

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Zobrazit objekt | Zobrazit objekt odpovídající záznamu
F9 | Spustit operaci | Spuštění zobrazené operace
- | Datový model | Datový model Bílého motýla

    Atributy tisku

    Základní údaje
Tabulka | Název entity | BWUPDRC_bw10nazev | C(8)
VK | Název volné karty | BWUPDRC_sp64nazev | C(8)
Klíč | Klíč změněného záznamu | BWUPDRC_bw92key | C(50)
Dne | Datum a čas změny záznamu | BWUPDRC_bw92datum | T
Změnil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Změna | Změna - oprava záznamu nebo zrušení záznamu | Výpočet | C(8)
Poznámka | Poznámka | BWUPDRC_bw92koment | M
Atribut | Název atributu | BWUPDRCA_bw11nazev | C(10)
Původní | Původní hodnota atributu | BWUPDRCA_bw93oldval | M
Nová | Nová hodnota atributu | BWUPDRCA_bw93newval | M

    Viz.také

    Zobrazit objekt | Spustit operaci | Datový model


Zprávy databázového serveru

Popis

Činnost „zprávy databázového serveru“ je k dispozici v menu Systém. Po její aktivaci se zobrazí formulář a v něm seznam zpráv databázového serveru. Zprávy se v seznamu doplňují každých 5 vteřin (podobný seznam zpráv je možné vidět v programech SQL Central nebo DBConsole) a jsou zobrazovány pro verze databázového serveru 8 nebo vyšší. K dispozici jsou např. zprávy týkající se procedur, triggerů, spouštěných databází a jejich případných chyb atd.

Tato činnost používá volání programu BWSRVMES. Tento program má následující parametry:

_form_caption - text - nadpis okna formuláře

_cmdfree_caption - text - popis volného tlačítka formuláře

_cmdfree_script - text - skript v jazyce Foxpro vyvolaný po stisku volného tlačítka

_interval - číslo - interval aktualizace seznamu zpráv databázového serveru - uplatní se, pokud se větší než 3

_filtr - text - je-li uveden budou zobrazeny pouze zprávy začínající daným textem

Pozn.: je-li program BWSRVMES volán v externím příkazu, doplňující vlastnosti formuláře apod. ..., musí se jednat o kompilovaný kód.

Např.:

<pre>

LOCAL _kod_foxpro

* v proměnné _kod_foxpro bude kód volného tlačítka formuláře

TEXT TO _kod_foxpro NOSHOW

* kód skriptu nejdříve odstartuje událostní trigger "Prepocet FIFO"

tool.sqlcall(.F.,'TRIGGER EVENT "Prepocet FIFO"')

* a potom znepřístupní volné tlačítko formuláře

_thisform.cmdfree.enabled=.F.

ENDTEXT

* formulář bude mít nadpis 'FIFO'

* volné tlačítko bude mít popis 'Přepočet FIFO'

* po jeho stisku bude vyvolán skript uvedený v proměnné _kod_foxpro

* frekvence aktualizace seznamu zpráv databázového serveru bude 3 vteřiny

DO bwsrvmes WITH 'FIFO','Přepočet FIFO',_kod_foxpro,3

</pre>


VÝROBA

Popis

Komponenta výroba podporuje zejména operativní řízení výroby a to samozřejmě ve vztahu k ostatním oblastem podniku, jako jsou účetnictví, sklady, nákup, prodej, odměňování apod. Správným nadefinováním řízení výroby lze dosáhnout snížení výrobních nákladů (např. sledováním a normováním spotřeby materiálu, optimalizací výrobních zákázek apod.).

Viz.také

Zakázky výroby | Výrobní úkoly | Vstupy a výstupy výr. úkolů | Aktuální hodnoty výrob. úkolů | Aktuální hodnoty vst. a výst. | Přehled nerozpočteného | Přehled vstupů a výstupů | Výroba - měření a vážení | Kalendáře směn výroby | Přehled směn výrobních linek | Harmonogram výroby | Nový harmonogram výroby


Zakázky výroby

Popis

Tato činnost poskytuje uživateli přehled výrobních zakázek. Struktura přehledu zakázek je závislá na tom, jak si uživatel nadefinuje záložku „Výběr“. Každá výrobní zakázka představuje událost v procesu výrobních zakázek. Pro výrobní zakázky je v IS BM speciální komponenta VR1 – „Výroba – výrobní zakázka“, operace výrobních zakázek pak tedy náleží této komponentě.

Uživatel má k dispozici tyto údaje:

¨ identifikace procesu – rok/IDÚ/číslo procesu/identifikace operace

¨ fáze výroby – zakázka výroby může dosahovat těchto stavů: V přípravě, Plánovaná, Očekávaná, V realizaci a Realizovaná (fáze výrobní zakázky se z jednoho stavu do dalšího dostávají uživatelským zásahem, nikoliv dynamicky podle událostí výrobních úkolů)

¨ datum výroby od data – představuje datum založení výrobní zakázky, typicky se jedná o stejný den, kdy se výrobní zakázka zadá do IS

¨ datum ukončení výroby – stanovuje, do jakého data má být výrobní zakázka realizována. Toto datum je velmi důležité vzhledem k plánování výroby, protože při generování výrobních úkolů z hlediska časového se hledá první volné místo od konce intervalu výrobní zakázky

¨ VČ – výrobní číslo – jednoznačné číslo výrobní zakázky, generované vždy o jedničku vyšší než měla předchozí výrobní zakázka

¨ adresát – adresát vztahující se k výrobní zakázce, typicky odběratel, pro něhož je výrobní zakázka realizována

¨ artikl – artikl, který je předmětem výroby

¨ množství – počet ks, které se má výrobní zakázkou realizovat

¨ % navýšení - % navýšení požadavku na výrobu – tento atribut navyšuje množství v referenční měrné jednotce zadaným procentem, pro výrobu je pak stěžejní množství v atributu „požadavek na výrobu“

¨ obchodní selektor výrobní zakázky – účelem obchodního selektoru (typicky číslo obchodní zakázky) ve výrobě je propojení událostí výroby souvisejících s jednou obchodní zakázkou

Záložka „výrobní úkoly“ obsahuje přehled všech existujících výrobních úkolů s výrobním číslem zakázky výroby.

Záložka „ekonomika“ obsahuje přehled hodnot vypočtených ze vstupů a výstupů výrobních úkolů (normovaných, plánovaných, očekávaných a realizovaných) zvolené výrobní zakázky. Náklady jsou vypočítané ze vstupů, výnosy z výstupů.

Datový model

  • VRVYR Výrobní zakázka
    • ADADSAT Adresát
    • ADSPOJ Spojení adresáta
    • SPPRISTU Přístupové právo uživatele k věci
    • SPPRCOD Operace procesu
      • SPTYP Druh procesu/operace
    • TPVYROB Artikl výroby
      • SPARTIKN Název artiklu
    • BWUZIVAT Uživatel systému

    • Formulář

    Formulář činnosti - Zakázky výroby
Mřížka [Výrobní zakázky]
Listovací rámeček
Stránka #1 Výrobní zakázky
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
 | Pořadí stejného druhu operace v jednom procesu
 | Identifikátor druhu operace
 | Fáze výroby.
 | Název druhu procesu
Datum | Datum výroby od data.
 | Datum ukončení výroby.
Popis | Popis výrobní zakázky
VČ | Číslo výroby.
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Množství | Množství v uvedené jednotce
MJ | Identifikátor měrné jednotky
 | Identifikátor měrné jednotky
Množství ref. MJ | Množství v referenční měrné jednotce
% navýšení | Procento navýšení požadavku na výrobu/zpracování
Požadavek | Množství v referenční měrné jednotce - požadavek na výrobu
Komentář | Komentář, podrobně popisující požadavek na výrobu.
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Výrobní úkoly
Mřížka [Výrobní úkoly]
Stránka #3 Ekonomika
Normované náklady | Normované náklady
Plánované náklady | Plánované náklady
Očekávané náklady | Očekávané náklady
Realizované náklady | Realizované náklady
Normované výnosy | Normované výnosy
Plánované výnosy | Plánované výnosy
Očekávané výnosy | Očekávané výnosy
Realizované výnosy | Realizované výnosy
Stránka #4 Výběr
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Fáze | Fáze výroby.
Popis | Popis výrobní zakázky
Datum výr. od | Datum výroby od data.
do | Datum výroby do data.
Datum ukon. od | Datum ukončení výroby.
do | Datum ukončení výroby do data.
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
VČ | Číslo výroby.
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsané | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Výrobní zakázky] činnosti - Zakázky výroby

    Mřížka [Výrobní zakázky] činnosti - Zakázky výroby
Označování | Označení záznamu
Datum od | Datum výroby od data.
Datum ukončení | Datum ukončení výroby.
Fáze | Fáze výroby.
Výroba č. | Číslo výroby.
Druh | Identifikace druhu artiklu
Artikl výroby | Identifikace artiklu
Množství | Množství v uvedené jednotce
MJ | Identifikátor měrné jednotky
Mn. ref. | Množství v referenční měrné jednotce
MJ | Identifikátor měrné jednotky
Název artiklu | Název artiklu
Popis | Popis výrobní zakázky
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Mřížka [Výrobní úkoly] činnosti - Zakázky výroby

    Mřížka [Výrobní úkoly] činnosti - Zakázky výroby
Fáze | Fáze výroby.
Datum | Datum
Trvání (hod) | Délka trvání výrobního úkolu
Operace | Identifikace technologické operace
Linka | Číslo výrobní linky, resp. stroje
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh | Identifikátor druhu operace
Komponenta | Identifikace komponenty
Pořadí | Pořadí stejného druhu operace v jednom procesu

    Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Harmonogram výroby | Harmonogram výroby
F7 | Generování úkolů zakázky | Generování úkolů zakázky
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
- | Výrobní úkoly | Události výrobních úkolů
- | Vstupy a výstupy výr. úkolů | Události o vstupech a výstupech výrobních úkolů
F2 | Adresář | Přehled adresátů
F2 | Artikly výroby | Vstup artiklů výroby
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Měrné jednotky | Číselník měrných jednotek
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Technologické postupy | Definice technologických postupů výroby

    Atributy tisku

    Základní údaje
Výroba č. | Číslo výroby. | VRVYR_vr02vyrc | C(15)
Datum | Datum výroby od data. | VRVYR_vr02datum | D
Fáze - výrobní zakázka | Fáze výroby. | Výpočet | C(11)
Popis - výrobní zakázka | Popis výrobní zakázky | VRVYR_vr02text | C(40)
Adresát | Identifikace adresáta | VRVYR_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Spojení | Číslo spojení adresáta. | VRVYR_ad11cisspo | C(2)
UTO | Národní směrové číslo státu pro telefonní spojení (UTO). | ADSPOJ_ad13nsc | C(4)
Telefon | Telefonní číslo | ADSPOJ_ad11cislo | C(60)
Jméno kontaktní osoby | Jméno kontaktní osoby. | ADSPOJ_ad11jmeno | C(40)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)
Stát | Identifikace státu. | ADADR_ad05id | C(3)
Druh artiklu | Identifikace druhu artiklu | VRVYR_sp61id | C(3)
Artikl | Identifikace artiklu | VRVYR_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Měrná jednotka - referenční | Identifikátor měrné jednotky | VRVYR_sp24idmj1 | C(3)
Měrná jednotka | Identifikátor měrné jednotky | VRVYR_sp24idmj | C(3)
Množství | Množství v uvedené jednotce | VRVYR_vr02mn | N(20,4)
Mn. ref. | Množství v referenční měrné jednotce | VRVYR_vr02mnr | N(20,4)
Komentář - výrobní zakázka | Komentář, podrobně popisující požadavek na výrobu. | VRVYR_vr02koment | M
Rok | Rok v identifikaci procesu | VRVYR_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | VRVYR_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | VRVYR_sp33cisd | C(8)
Komponenta | Identifikace komponenty | VRVYR_sp06idsubs | C(3)
Operace | Identifikátor druhu operace | VRVYR_sp07idtyp | C(6)
Normované náklady | Normované náklady | VRVYR_vr02naknor | N(20,4)
Plánované náklady | Plánované náklady | VRVYR_vr02nakpla | N(20,4)
Očekávané náklady | Očekávané náklady | VRVYR_vr02nakoce | N(20,4)
Realizované náklady | Realizované náklady | VRVYR_vr02nakrea | N(20,4)
Normované výnosy | Normované výnosy | VRVYR_vr02vynnor | N(20,4)
Plánované výnosy | Plánované výnosy | VRVYR_vr02vynpla | N(20,4)
Očekávané výnosy | Očekávané výnosy | VRVYR_vr02vynoce | N(20,4)
Realizované výnosy | Realizované výnosy | VRVYR_vr02vynrea | N(20,4)

    Při pohybu v Výrobní kroky
Operace | Identifikace technologické operace | VRUDOPER_tp05id | C(13)
Fáze - výrobní krok | Fáze výroby. | Výpočet | C(11)
Popis - výrobní krok | Popis události | VRUDOPER_vr09text | C(40)
Číslo linky | Číslo výrobní linky, resp. stroje | VRUDOPER_tp13id | C(6)
Druh linky | Identifikace druhu výrobní linky | VRUDOPER_tp12id | C(6)
Datum - výrobní krok | Datum | VRUDOPER_vr09datum | T
Trvání (hod) | Délka trvání výrobního úkolu | VRUDOPER_vr09trvani | N(10,5)
Poznámka - výrobní krok | Poznámka, podrobně popisující událost výrobního úkolu | VRUDOPER_vr09koment | M

    Viz.také

    Harmonogram výroby | Generování úkolů zakázky | OZNAČOVÁNÍ | Prezentace artiklu | Výrobní úkoly | Vstupy a výstupy výr. úkolů | Adresář | Artikly výroby | Druhy artiklů | Měrné jednotky | Obchodní selektor | Organizační selektor | Spojení adresátů | Technicko-věcný selektor | Technologické postupy


Výrobní úkoly

Popis

Tato činnost představuje přehled dílčích výrobních úkolů k jednotlivým zakázkám. Struktura poskytovaných informací je závislá na tom, jaké kritérium si uživatel zvolí na záložce „výběr“.

Přehled výrobních úkolů se tvoří automaticky a to po spuštění generování úkolů zakázky, tzn. že výrobní úkoly jsou dílčí kroky vedoucí k realizaci výrobní zakázky. Tyto kroky jsou definovány jako technologické operace v technologickém postupu, jehož pilotním artiklem je artikl z výrobní zakázky.

Každý výrobní úkol poskytuje uživateli tyto základní a pro něj specifické informace:

¨ identifikaci procesu

¨ příznak, zda se jedná o aktuální výrobní úkol – Ano/Ne – jedná o další možnost, jak třídit výrobní úkoly. Normované výrobní úkoly mají vždy příznak aktuální NE, plánované se stávají neaktuálními po přesunutí do očekávaných, očekávané se stávají neaktuálními po přesunutí do realizovaných.

¨ fáze výrobního úkolu - plánované (typicky vygenerované dle TPV a tudíž rovnající se hodnotami hodnotám normovaným, nastávají ale i situace, kdy je nutno změnit hodnoty předplněné z TPV, např. změnit artikl nebo množství na vstupu)

- očekávané (výrobní úkoly se typicky přesouvají z fáze plánované do fáze očekávané tehdy, když jsou výrobní úkoly naplánovány z hlediska času, tj. výrobní úkol je naplánován v harmonogramu výroby a je definována materiálová i pracovní náročnost)

- realizované – označuje již hotové výrobní úkoly s hodnotami u stupů a výstupů odpovídající realitě

- normované – vstupy a výstupy podle TPV, slouží jen pro porovnání

¨ VČ – výrobní číslo sjednocuje výrobní úkoly náležející stejné výrobní zakázce

¨ skupina výrobního úkolu – představuje časové uspořádání výrobních úkolů (technologických operací) dle technologického postupu. Jedná se o tříznakový atribut nabývající hodnot 001, 002, ... (u normovaných výrobních úkolů 701, 702, ...). Pokud je výstup výrobního úkolu vstupem následujícího výrobního úkolu, je na záložce „následující skupiny úkolů“ přehled následujících výrobních úkolů.

¨ pořadové číslo výrobního úkolu (6-ti znakový atribut) – označuje podmnožinu skupiny výrobního úkolu (např. jeden výrobní úkol bude trvat 3 dny, výroba funguje na 3 směny a pracuje se na 2 výrobních linkách. Potom bude existovat 18 výrobních úkolů se stejným výrobním číslem, stejnou skupinou výrobního úkolu, ale budou se lišit právě pořadovým číslem – 000001, 000002, ...

¨ směna – označuje v jaké směně se bude výrobní úkol dělat

¨ datum zahájení a ukončení – určuje časové naplánování (realizaci) výrobního úkolu, mění se podle naplánování výrobního úkolu v harmonogramu výroby

¨ délka trvání – čas potřebný na realizaci výrobního úkolu

¨ linka – definice, na jaké lince bude výrobní úkol prováděn

¨ artikl – jedná se o výstup výrobního úkolu (referenční artikl technologické operace výrobního úkolu)

¨ operace – jedná se o technologickou operaci z technologického postupu, kterou je realizován výrobní úkol

Datový model

  • VRUDOPER Událost úkolu ve výrobě
    • SPPRCOD Operace procesu
      • SPTYP Druh procesu/operace
    • SPPRISTU Přístupové právo uživatele k věci
    • VRVYR Výrobní zakázka
      • ADADSAT Adresát
    • TPOPERAC Technologická operace
    • BWUZIVAT Uživatel systému
    • TPLINKA Výrobní linka / stroj / skladové úložiště výroby
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)
    • TPVYROB Artikl výroby (alias TPVYROB2)
      • SPARTIKN Název artiklu

    • Formulář

    Formulář činnosti - Přidělit pracovníka výkonu úkolu
Mřížka [Výrobní úkoly]
Listovací rámeček
Stránka #1 Výrobní úkoly
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
 | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Název druhu procesu
Fáze | Fáze výroby.
VČ | Číslo výroby.
Skupina | Skupina výrobních úkolů
Poř.č. | Pořadové číslo úkolu v rámci výrobní zakázky
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Datum | Datum
Číslo směny | Číslo směny
Ukonč. | Datum a čas ukončení plnění výrobního úkolu
Trvání (hod) | Délka trvání výrobního úkolu
Popis | Popis události
 | Identifikace druhu výrobní linky
Linka | Číslo výrobní linky, resp. stroje
 | Název výrobní linky
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Operace | Identifikace technologické operace
 | Stručný popis, charakterizující technologickou operaci
Množství | Objem výrobního úkolu
 | Identifikátor měrné jednotky
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Aktuální | Aktuální výrobní úkol Ano/Ne
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Poznámka
Poznámka | Poznámka, podrobně popisující událost výrobního úkolu
Stránka #3 Vstupy a výstupy
Mřížka [Vstupy a výstupy]
Fáze | Fáze výroby.
 | Vstup / Výstup
Datum | Datum události.
Popis | Popis
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Úložiště | Identifikace skladového úložiště
 | Název úložiště
Stroj | Číslo výrobní linky, resp. stroje
Název stroje | Název stroje
OSC | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
Čas | Čas konstantní nebo odvozený z trvání úkolu
Proc. čas oper. | Výkon jako procento času trvání úkolu
Množství | Množství
MJ | Identifikátor měrné jednotky
Cena za j. | Cena za jednotku materiálu.
Cena | Celková cena
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Stránka #4 Poznámka
Komentář | Komentář, podrobně popisující událost pohybu materiálu ve výrobě.
Stránka #5 Následující skupiny úkolů
Mřížka [Následující skupiny úkolů]
VČ | Číslo výroby.
Skupina | Skupina výrobních úkolů
Datum | Datum výroby od data.
Popis | Popis výrobní zakázky
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Požadavek | Množství v referenční měrné jednotce - požadavek na výrobu
Stránka #6 Výběr
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Fáze | Fáze výroby.
Operace připravena | Operace je připravena ke spuštění
Aktuální | Aktuální výrobní úkol Ano/Ne
Datum | Datum
 | Datum do
Popis | Popis události
Výroba č. | Číslo výroby.
Skupina | Skupina výrobních úkolů
Poř.č. | Pořadové číslo úkolu v rámci výrobní zakázky
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Operace | Identifikace technologické operace
 | Artikl výrobního úkolu nebo vstup/výstup
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Linka | Číslo výrobní linky, resp. stroje
Dr.linky | Identifikace druhu výrobní linky
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsané | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Výrobní úkoly] činnosti - Přidělit pracovníka výkonu úkolu

    Mřížka [Výrobní úkoly] činnosti - Přidělit pracovníka výkonu úkolu
Označování | Označení záznamu
Fáze | Fáze výroby.
Datum | Datum
Číslo směny | Číslo směny
Trvání (hod) | Délka trvání výrobního úkolu
Ukonč. | Datum a čas ukončení plnění výrobního úkolu
Množství | Objem výrobního úkolu
Výroba č. | Číslo výroby.
Skup. | Skupina výrobních úkolů
Poř.č. | Pořadové číslo úkolu v rámci výrobní zakázky
Operace | Identifikace technologické operace
Číslo linky | Číslo výrobní linky, resp. stroje
Název operace | Stručný popis, charakterizující technologickou operaci
Popis | Popis události
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Operace | Identifikátor druhu operace

    Mřížka [Vstupy a výstupy] činnosti - Přidělit pracovníka výkonu úkolu

    Mřížka [Vstupy a výstupy] činnosti - Přidělit pracovníka výkonu úkolu
Fáze | Fáze výroby.
Datum | Datum události.
V/V | Vstup / Výstup
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Množství | Množství
MJ | Identifikátor měrné jednotky
Cena za j. | Cena za jednotku materiálu.
Cena | Celková cena
Název artiklu | Název artiklu
Popis | Popis
OSC | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka

    Mřížka [Následující skupiny úkolů] činnosti - Přidělit pracovníka výkonu úkolu

    Mřížka [Následující skupiny úkolů] činnosti - Přidělit pracovníka výkonu úkolu
Výroba č. | Číslo výroby.
Skupina | Skupina výrobních úkolů
Datum | Datum výroby od data.
Popis | Popis výrobní zakázky

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Předplnění vstupů a výstupů | Předplnění vstupů a výstupů úkolu
F6 | Harmonogram výroby | Harmonogram výroby
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^P | Přidělit pracovníka výkonu úkolu | Přidělit pracovníka výkonu úkolu
- | Slučování výrobních úkolů | Události výrobních úkolů
- | Sloučit výrobní úkoly | Sloučit výrobní úkoly
F2 | Adresář | Přehled adresátů
F2 | Artikly výroby | Vstup artiklů výroby
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy výrobních linek | Číselník druhů výrobních linek
F2 | Karta pracovníka | Karta pracovníka
F2 | Měrné jednotky | Číselník měrných jednotek
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Pracovní místa skut. a typová | Popis pracovní funkce (zařazení)
F2 | Přehled referenčních artiklů | Přehled referenčních artiklů
F2 | Skladová úložiště | Skladová úložiště
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Výrobní linky a stroje | Seznam výrobních linek a strojů
F2 | Zakázky výroby | Přehled zakázek výroby

    Atributy tisku

    Základní údaje
Druh artiklu - výrobní zakázka | Identifikace druhu artiklu | VRVYR_sp61id | C(3)
Artikl - výrobní zakázka | Identifikace artiklu | VRVYR_sp60id | C(13)
Výroba č. | Číslo výroby. | VRUDOPER_vr02vyrc | C(15)
Skupina | Skupina výrobních úkolů | VRUDOPER_vr09skup | C(3)
Poř.č. | Pořadové číslo úkolu v rámci výrobní zakázky | VRUDOPER_vr09porc | C(6)
Operace | Identifikace technologické operace | VRUDOPER_tp05id | C(13)
Název operace | Stručný popis, charakterizující technologickou operaci | TPOPERAC_tp05operac | C(40)
Stroj | Číslo výrobní linky, resp. stroje | VRUDOPER_tp13id | C(6)
Název stroje | Název výrobní linky | TPLINKA_tp13linka | C(40)
Druh linky | Identifikace druhu výrobní linky | VRUDOPER_tp12id | C(6)
Fáze - výrobní krok | Fáze výroby. | Výpočet | C(11)
Datum - výrobní krok | Datum | VRUDOPER_vr09datum | T
Ukonč. | Datum a čas ukončení plnění výrobního úkolu | VRUDOPER_vr09datumd | T
Číslo směny | Číslo směny | Výpočet | C(7)
Trvání (hod) | Délka trvání výrobního úkolu | VRUDOPER_vr09trvani | N(10,5)
Druh artiklu - výrobní úkol | Identifikace druhu artiklu | VRUDOPER_sp61id | C(3)
Artikl - výrobní úkol | Identifikace artiklu | VRUDOPER_sp60id | C(13)
Název artiklu - výrobní úkol | Název artiklu | SPARTIKN_sp62artikl | C(60)
Popis - výrobní krok | Popis události | VRUDOPER_vr09text | C(40)
Aktuální | Aktuální výrobní úkol Ano/Ne | Výpočet | C(3)
Poznámka - výrobní krok | Poznámka, podrobně popisující událost výrobního úkolu | VRUDOPER_vr09koment | M
Rok | Rok v identifikaci procesu | VRUDOPER_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | VRUDOPER_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | VRUDOPER_sp33cisd | C(8)
Komponenta | Identifikace komponenty | VRUDOPER_sp06idsubs | C(3)
Operace | Identifikátor druhu operace | VRUDOPER_sp07idtyp | C(6)
Název artiklu - VV výr. kroku | Název artiklu | SPARTIKN2_sp62artikl | C(60)
Název úložiště | Název úložiště | TPSKLAD_tp17ulozis | C(40)
Název stroje | Název stroje | TPLINKA3_tp13linka | C(40)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Název KV | Název kalkulačního vzorce / název proměnné kalkulačního vzorce | TPKALK2_tp27nazrol | C(40)
Datum | Datum výroby od data. | VRVYR2_vr02datum | D
Popis | Popis výrobní zakázky | VRVYR2_vr02text | C(40)
Druh artiklu | Identifikace druhu artiklu | VRVYR2_sp61id | C(3)
Artikl | Identifikace artiklu | VRVYR2_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN3_sp62artikl | C(60)
Požadavek | Množství v referenční měrné jednotce - požadavek na výrobu | VRVYR2_vr02mnrv | N(20,4)

    Při pohybu v Vstup nebo výstup výr. kroku
Vstup / Výstup | Vstup / Výstup | Výpočet | C(6)
Druh artiklu - VV výr. kroku | Identifikace druhu artiklu | VRUDOPMA_sp61id | C(3)
Artikl - VV výr. kroku | Identifikace artiklu | VRUDOPMA_sp60id | C(13)
Čas | Čas konstantní nebo odvozený z trvání úkolu | Výpočet | C(6)
Proc. čas oper. | Výkon jako procento času trvání úkolu | VRUDOPMA_vr14procca | N(6,2)
MJ | Identifikátor měrné jednotky | VRUDOPMA_sp24idmj | C(3)
Množství | Množství | VRUDOPMA_vr14mn | N(20,6)
Úložiště | Identifikace skladového úložiště | VRUDOPMA_tp17id | C(6)
Stroj | Číslo výrobní linky, resp. stroje | VRUDOPMA_tp13id | C(6)
Cena | Celková cena | VRUDOPMA_vr14cena | N(20,4)
Cena za j. | Cena za jednotku materiálu. | VRUDOPMA_vr14cj | N(20,4)
Datum - VV výr. kroku | Datum události. | VRUDOPMA_vr14datum | T
Popis - VV výr. kroku | Popis | VRUDOPMA_vr14text | C(40)
Komentář - VV výr. kroku | Komentář, podrobně popisující událost pohybu materiálu ve výrobě. | VRUDOPMA_vr14koment | M
Pracovník | Jednoznačná identifikace pracovníka | VRUDOPMA_mz01id | C(6)
KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce | VRUDOPMA_tp27id | C(3)

    Při pohybu v Následující skupiny úkolů
Výroba č. | Číslo výroby. | VRUDOPNS_vr02vyrc | C(15)
Skupina | Skupina výrobních úkolů | VRUDOPNS_vr09skup | C(3)

    Viz.také

    Předplnění vstupů a výstupů | Harmonogram výroby | OZNAČOVÁNÍ | Přidělit pracovníka výkonu úkolu | Sloučit výrobní úkoly | Adresář | Artikly výroby | Druhy artiklů | Druhy výrobních linek | Karta pracovníka | Měrné jednotky | Obchodní selektor | Organizační selektor | Pracovní místa skut. a typová | Přehled referenčních artiklů | Skladová úložiště | Technicko-věcný selektor | Výrobní linky a stroje | Zakázky výroby


Vstupy a výstupy výr. úkolů

Popis

Tato činnost představuje přehled vstupů a výstupů výrobních úkolů k jednotlivým zakázkám. Struktura poskytovaných informací je závislá na tom, jaké kritérium si uživatel zvolí na záložce „výběr“. Na výběrové záložce je možno zaškrtnout návěští „datum“. Toto zaškrtávací políčko ovlivní vybírané události následovně:

- zaškrtnuté – vyhledávané datum je datem vstupu/výstupu

- nezaškrtnuté – vyhledávané datum je datem zahájení výrobního úkolu

Přehled vstupů a výstupů se tvoří automaticky a to po spuštění generování úkolů zakázky. Většina primárních klíčů (tzn. základních atributů) je shodná s atributy u výrobních úkolů (výrobní fáze, výrobní číslo, skupina, pořad, číslo procesu atd.). Mezi další údaje patří:

¨ datum – je odvozeno z data výrobního úkolu, u vstupů je datum zahájení výrobního úkolu, u výstupů je datum ukončení výrobního úkolu. Pro uživatele je možnost návěští datum zaškrtnout. Toto zaškrtnutí následně ovlivní vybírané události takto:

- zaškrtnuté – vyhledávané datum je datem vstupu/výstupu

- nezaškrtnuté – vyhledávané datum je datem zahájení výrobního úkolu – použití tohoto výběru (tzn. nezaškrtnuté datum) může dramaticky zrychlit výběr při velkém objemu dat.

¨ artikl – artikl výrobní operace, ve které je obsažen daný vstup nebo výstup výrobní operace

¨ úložiště – představuje jedno z úložišť definovaných v TPV. Implicitně se předplňuje úložiště definované u artiklu v „Artiklech výroby“. Má význam v předplňování skladů pro procesy (operace) skladu navazující na výrobní operace v diagramu procesu výrobních úkolů.

¨ artikl – vstupní artikl představuje materiál, polotovar, pracovní výkon atd. potřebný pro realizaci výrobního úkolu. Výstupní artikl představuje výsledky výrobního úkolu, jedním z výstupů je artikl výrobního úkolu (výstupem může být i dále zpracovatelný odpad).

¨ stroj – stroj vstupu nebo výstupu je uveden podle definic v referenčním artiklu výrobního úkolu

¨ OSC – představuje osobní číslo (jednoznačnou identifikaci pracovníka) z komponenty mezd

¨ KV – definuje jakou proměnnou představuje vstup nebo výstup výrobní operace v kalkulačním vzorci výrobního úkolu

¨ množství – obsahuje hodnotu přepočtenou dle TPV k množství artiklu výrobního úkolu

¨ cena za jednotku – představuje u vztažených artiklů cenu artiklu z ceníku podle cenové skupiny definované v parametrech TPV, u pracovních výkonů ocenění práce za jednotku času dle definic TPV

Datový model

  • VRUDOPMA Vstup nebo výstup výrobního úkolu
    • VRUDOPER Událost úkolu ve výrobě
      • SPPRISTU Přístupové právo uživatele k věci
      • VRVYR Výrobní zakázka
      • SPPRCOD Operace procesu
        • SPTYP Druh procesu/operace
      • TPLINKA Výrobní linka / stroj / skladové úložiště výroby (alias TPLINKA4)
    • TPVYROB Artikl výroby
      • SPARTIKN Název artiklu
    • MZKARTA Pracovník
    • BWUZIVAT Uživatel systému
    • TPLINKA Výrobní linka / stroj / skladové úložiště výroby (alias TPLINKA2)
    • TPLINKA Výrobní linka / stroj / skladové úložiště výroby (alias TPLINKA3)

    • Formulář

    Formulář činnosti - Výrobní linky a stroje
Mřížka [Vstupy a výstupy výroby]
Listovací rámeček
Stránka #1 Vstupy a výstupy výroby
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
 | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Název druhu operace
Fáze | Fáze výroby.
 | Vstup / Výstup
VČ | Číslo výroby.
Skupina | Skupina výrobních úkolů
Poř.č. | Pořadové číslo úkolu v rámci výrobní zakázky
Datum | Datum události.
Popis | Popis
Úložiště | Identifikace skladového úložiště
 | Název výrobní linky
Stroj | Číslo výrobní linky, resp. stroje
Název stroje | Název stroje
OSC | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Identifikace druhu artiklu (výrobní úkol)
Artikl | Identifikace artiklu (výrobní úkol)
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
Čas | Čas konstantní nebo odvozený z trvání úkolu
Proc. čas oper. | Výkon jako procento času trvání úkolu
Množství | Množství
MJ | Identifikátor měrné jednotky
Cena za j. | Cena za jednotku materiálu.
Cena | Celková cena
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Stránka #2 Poznámka
Komentář | Komentář, podrobně popisující událost pohybu materiálu ve výrobě.
Uživatel | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #3 Výběr
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Fáze | Fáze výroby.
 | Vstup / Výstup
Aktuální | Aktuální výrobní úkol Ano/Ne
Kon.mn. | Konečné množství na vstupu
Datum | Zaškrtnuté=vyhledávané datum je datumem vstupu/výstupu, nezaškrtnuté=vyhledávané datum je datumem zahájení výrobního úkolu
Datum | Datum události.
 | Datum události do.
Popis | Popis
VČ | Číslo výroby.
Skupina | Skupina výrobních úkolů
Poř.č. | Pořadové číslo úkolu v rámci výrobní zakázky
Operace | Identifikace technologické operace
OSC | Jednoznačná identifikace pracovníka
Linka | Číslo výrobní linky, resp. stroje
Druh linky | Identifikace druhu výrobní linky
Stroj | Identifikace stroje
Množství | Množství
do | Množství do
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Úložiště | Identifikace skladového úložiště
KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Zapsané | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Vstupy a výstupy výroby] činnosti - Výrobní linky a stroje

    Mřížka [Vstupy a výstupy výroby] činnosti - Výrobní linky a stroje
Označování | Označení záznamu
Datum | Datum události.
Fáze | Fáze výroby.
V/V | Vstup / Výstup
Aktuální | Aktuální výrobní úkol Ano/Ne
Výroba č. | Číslo výroby.
Skup. | Skupina výrobních úkolů
Poř.č. | Pořadové číslo úkolu v rámci výrobní zakázky
Operace | Identifikace technologické operace
Linka | Číslo výrobní linky, resp. stroje
Stroj | Číslo výrobní linky, resp. stroje
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Množství | Množství
MJ | Identifikátor měrné jednotky
Cena za j. | Cena za jednotku materiálu.
Cena | Celková cena
Kon.množ. | Konečné množství na vstupu
Název artiklu | Název artiklu
Popis | Popis
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
OSC | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka

    Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Harmonogram výroby | Harmonogram výroby
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
- | Nastavení příznaku rozpočteného množství | Nastavení příznaku rozpočteného množství
F2 | Artikly výroby | Vstup artiklů výroby
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy výrobních linek | Číselník druhů výrobních linek
F2 | Kalkulační vzorce a proměnné | Kalkulační vzorce a proměnné v nich obsažené
F2 | Karta pracovníka | Karta pracovníka
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Pracovní místa skut. a typová | Popis pracovní funkce (zařazení)
F2 | Přehled referenčních artiklů | Přehled referenčních artiklů
F2 | Skladová úložiště | Skladová úložiště
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Výrobní linky a stroje | Seznam výrobních linek a strojů
F2 | Zakázky výroby | Přehled zakázek výroby

    Atributy tisku

    Základní údaje
Výroba č. | Číslo výroby. | VRUDOPMA_vr02vyrc | C(15)
Skupina | Skupina výrobních úkolů | VRUDOPMA_vr09skup | C(3)
Poř.č. | Pořadové číslo úkolu v rámci výrobní zakázky | VRUDOPMA_vr09porc | C(6)
Vstup / Výstup | Vstup / Výstup | Výpočet | C(6)
Druh artiklu - výrobní zakázka | Identifikace druhu artiklu | VRVYR_sp61id | C(3)
Artikl - výrobní zakázka | Identifikace artiklu | VRVYR_sp60id | C(13)
Operace | Identifikace technologické operace | VRUDOPER_tp05id | C(13)
Číslo linky | Číslo výrobní linky, resp. stroje | VRUDOPER_tp13id | C(6)
Název linky | Název výrobní linky | TPLINKA2_tp13linka | C(40)
Druh linky | Identifikace druhu výrobní linky | VRUDOPER_tp12id | C(6)
Druh artiklu - VV výr. kroku | Identifikace druhu artiklu | VRUDOPMA_sp61id | C(3)
Artikl - VV výr. kroku | Identifikace artiklu | VRUDOPMA_sp60id | C(13)
Název artiklu - VV výr. kroku | Název artiklu | SPARTIKN_sp62artikl | C(60)
MJ | Identifikátor měrné jednotky | VRUDOPMA_sp24idmj | C(3)
Množství | Množství | VRUDOPMA_vr14mn | N(20,6)
Úložiště | Identifikace skladového úložiště | VRUDOPMA_tp17id | C(6)
Pracovník | Jednoznačná identifikace pracovníka | VRUDOPMA_mz01id | C(6)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Cena | Celková cena | VRUDOPMA_vr14cena | N(20,4)
Cena za j. | Cena za jednotku materiálu. | VRUDOPMA_vr14cj | N(20,4)
Fáze | Fáze výroby. | Výpočet | C(11)
Datum - VV výr. kroku | Datum události. | VRUDOPMA_vr14datum | T
Popis - VV výr. kroku | Popis | VRUDOPMA_vr14text | C(40)
Komentář - VV výr. kroku | Komentář, podrobně popisující událost pohybu materiálu ve výrobě. | VRUDOPMA_vr14koment | M
KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce | VRUDOPMA_tp27id | C(3)
Proc. čas oper. | Výkon jako procento času trvání úkolu | VRUDOPMA_vr14procca | N(6,2)
Čas | Čas konstantní nebo odvozený z trvání úkolu | Výpočet | C(6)
Název KV | Název kalkulačního vzorce / název proměnné kalkulačního vzorce | TPKALK2_tp27nazrol | C(40)
Rok | Rok v identifikaci procesu | VRUDOPMA_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | VRUDOPMA_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | VRUDOPMA_sp33cisd | C(8)
Komponenta | Identifikace komponenty | VRUDOPMA_sp06idsubs | C(3)
Operace | Identifikátor druhu operace | VRUDOPMA_sp07idtyp | C(6)

    Viz.také

    Harmonogram výroby | OZNAČOVÁNÍ | Prezentace artiklu | Nastavení příznaku rozpočteného množství | Artikly výroby | Druhy artiklů | Druhy výrobních linek | Kalkulační vzorce a proměnné | Karta pracovníka | Obchodní selektor | Organizační selektor | Pracovní místa skut. a typová | Přehled referenčních artiklů | Skladová úložiště | Technicko-věcný selektor | Výrobní linky a stroje | Zakázky výroby


Aktuální hodnoty výrob. úkolů

Popis

Přehled aktuálních hodnot výrobních úkolů poskytuje uživateli informace o aktuálních hodnotách výrobních úkolů podle výrobních linek. Může být sledován počet, doba trvání neb množství artiklů.

Datový model

  • VRAHOPER Aktuální hodnota komponenty výrobní operace
    • SPSTATDI Druh hodnoty
    • TPLINKA Výrobní linka / stroj / skladové úložiště výroby

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Výrobní linky a stroje | Seznam výrobních linek a strojů

    Formulář

    Formulář činnosti - Druhy hodnot
Mřížka [Aktuální hodnoty výrobních kroků]
Listovací rámeček
Stránka #1 Aktuální hodnoty výrobních kroků
Druh hodnoty | Identifikace druhu hodnoty
 | Název druhu hodnoty
Výrobní linka | Číslo výrobní linky, resp. stroje
 | Název výrobní linky
Hodnota | Aktuální hodnota
Stránka #2 Výběr
Druh hodnoty | Identifikace druhu hodnoty
Číslo linky | Číslo výrobní linky, resp. stroje
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Aktuální hodnoty výrobních kroků] činnosti - Druhy hodnot

    Mřížka [Aktuální hodnoty výrobních kroků] činnosti - Druhy hodnot
Druh hodnoty | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Číslo linky | Číslo výrobní linky, resp. stroje
Název linky | Název výrobní linky
Hodnota | Aktuální hodnota

    Viz.také

    Druhy hodnot | Výrobní linky a stroje


Aktuální hodnoty vst. a výst.

Popis

Tato činnost poskytuje uživateli přehled aktuálních hodnot vstupů a výstupů výrobních úkolů podle druhů artiklů nebo jednotlivých artiklů. Je sledován jejich počet, cena za jednotku, cena celkem a množství ve vstupech a výstupech výrobních úkolů.

Datový model

  • VRAHOPMA Aktuální hodnota komponenty vstupy výrobní operace
    • SPSTATDI Druh hodnoty
    • SPARTIKL Artikl

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Artikly výroby | Vstup artiklů výroby
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy hodnot | Seznam druhů statistických informací

    Formulář

    Formulář činnosti - Artikly výroby
Mřížka [Aktuální hodnoty vstupů a výstupů]
Listovací rámeček
Stránka #1 Aktuální hodnoty vstupů a výstupů
Druh hodnoty | Identifikace druhu hodnoty
 | Název druhu hodnoty
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Hodnota | Aktuální hodnota
Stránka #2 Výběr
Druh hodnoty | Identifikace druhu hodnoty
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Aktuální hodnoty vstupů a výstupů] činnosti - Artikly výroby

    Mřížka [Aktuální hodnoty vstupů a výstupů] činnosti - Artikly výroby
Druh hodnoty | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Hodnota | Aktuální hodnota

    Viz.také

    Artikly výroby | Druhy artiklů | Druhy hodnot


Přehled nerozpočteného

Popis

Tato činnost podle nastaveného kritéria na záložce „výběr“ (nejčastěji číslo linky, artikl a období od – do) poskytuje uživateli přehled nerozpočteného artiklu. Jedná se o artikl, který má na kartě (činnost „artikly výroby“ – komponenta TPV) v atributu „rozp.mn.“ (rozpočítávat množství) uvedenu hodnotu Ano. Tímto příznakem se označuje artikl (materiál), jehož množství na realizovaných vstupech výrobních úkolů se rozpočítává podle skutečně spotřebovaného množství artiklu za období.

Můžeme si uvést tuto situaci na příkladu: výrobní podnik má 3 zakázky na výrobu montovaných stolků. Tyto stolky je nutno nalakovat. Na každý stolek je určena normovaná spotřeba laku. Nicméně po realizaci těchto tří zakázek se spočítá skutečná spotřeba laku a ta se následně rozpočítá (váženým průměrem) ke každé ze tří zakázek (normovaná spotřeba první zakázky je 2kg, druhé zakázky 5kg a třetí zakázky 10kg, což je celkem 17kg). Po realizaci těchto zakázek bylo ale zjištěno, že skutečně se spotřebovalo 34kg laku. Po provedení rozpočtu je u první zakázky uvedeno 4kg laku, u druhé zakázky 10kg a u třetí zakázky 20kg laku.

Rozpočet artiklu se provádí po stisku klávesy F9 nebo volbou činnosti „rozpočet množství“ z menu Volby.

Datový model

  • VRUDOPMA Vstup nebo výstup výrobního úkolu
    • VRUDOPER Událost úkolu ve výrobě
      • SPPRCOD Operace procesu
        • SPPRC Proces
      • TPLINKA Výrobní linka / stroj / skladové úložiště výroby
        • SPPRISTU Přístupové právo uživatele k věci
    • TPVYROB Artikl výroby
      • SPARTIKN Název artiklu

    • Vyvolávané činnosti

    K. | Činnost | Popis
F7 | Rozpočet množství - označených | Rozpočet množství - označených
F9 | Rozpočet množství | Rozpočet množství artiklu na vstupech
- | INFORMACE O ARTIKLU | Přehled informací o artiklu
F2 | Artikly výroby | Vstup artiklů výroby
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Výrobní linky a stroje | Seznam výrobních linek a strojů
F2 | Zakázky výroby | Přehled zakázek výroby

    Formulář

    Formulář činnosti - INFORMACE O ARTIKLU
Mřížka [Artikl k rozpočtu]
Listovací rámeček
Stránka #1 Nerozpočteno
Stránka #2 Výběr
Agregace | Agregovat podle linky nebo druhu linky
Číslo linky | Číslo výrobní linky, resp. stroje
Datum od | Datum
Datum do | Datum do
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
VČ | Číslo výroby.
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Artikl k rozpočtu] činnosti - INFORMACE O ARTIKLU

    Mřížka [Artikl k rozpočtu] činnosti - INFORMACE O ARTIKLU
Označování | Označení záznamu
Linka | Číslo výrobní linky, resp. stroje
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
MJ | Identifikátor měrné jednotky
Zadáno | Zadané celkové množství artiklu
K rozpočtení | K rozpočtení
Odchylka % | % odchylka rozpočtení vs. zadáno

    Viz.také

    Rozpočet množství - označených | Rozpočet množství | INFORMACE O ARTIKLU | Artikly výroby | Druhy artiklů | Výrobní linky a stroje | Zakázky výroby


Přehled vstupů a výstupů

Popis

Na základě nadefinovaných údajů na záložce „parametry“ (druh artiklu, artikl, technologický postup, množství a datum zahájení výroby) má uživatel k dispozici přehled vstupů a výstupů, které se týkají daného artiklu v souvislosti s daným technologickým postupem a zadaným množstvím.

Jedná se ale o okamžitý přehled vstupů a výstupů, tzn. po ukončení činnosti nejsou tyto data v této činnosti nijak ukládána. V podstatě tato činnost poskytuje uživateli možnost vytvořit si přehled vstupů a výstupů, jak by vypadal, kdyby chtěl realizovat zakázku uvedenou v parametrech. Tento okamžitý přehled mu pak může sloužit např. jako předběžné rozhodnutí, zda danou zakázku může v nejbližší době realizovat.

Vyvolávané činnosti

K. | Činnost | Popis
F6 | Harmonogram výroby | Harmonogram výroby
F2 | Artikly výroby | Vstup artiklů výroby
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Technologické postupy | Definice technologických postupů výroby
F2 | Výrobní linky a stroje | Seznam výrobních linek a strojů

Formulář

Formulář činnosti - Výrobní linky a stroje
Mřížka [Vstupní artikly]
Listovací rámeček
Stránka #1 Vstupní artikly
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Tech. p. | Identifikace technologického postupu
Množství | Množství v uvedené jednotce
Datum | Datum události.
Stránka #2 Množství artiklu na skladech
Mřížka [Množství artiklu na skladech]
Stránka #3 Výroba
Mřížka [Výroba]
Stránka #4 Parametry
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Tech. postup | Identifikace technologického postupu
Množství | Množství
Datum výroby | Datum platnosti od
Druh | Identifikace druhu artiklu
Výběr artiklu | Identifikace artiklu
Výběr linky | Číslo implicitní výrobní linky, resp. stroje
Uchovat | Příznak uchování výběrového hlediska

Mřížka [Vstupní artikly] činnosti - Výrobní linky a stroje

Mřížka [Vstupní artikly] činnosti - Výrobní linky a stroje
Datum | Datum události.
Operace | Identifikace technologické operace
Úložiště | Identifikace skladového úložiště
Číslo linky | Číslo výrobní linky, resp. stroje
V/V | Vstup / Výstup
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Množství | Množství
MJ | Identifikátor měrné jednotky
Cena za j. | Cena za jednotku materiálu.
Cena | Celková cena

Mřížka [Množství artiklu na skladech] činnosti - Výrobní linky a stroje

Mřížka [Množství artiklu na skladech] činnosti - Výrobní linky a stroje
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Sklad | Identifikace umístění skladové evidence
Buňka | Identifikace skladové buňky
Množství | Množství na skladě
Adresát | Identifikace adresáta

Mřížka [Výroba] činnosti - Výrobní linky a stroje

Mřížka [Výroba] činnosti - Výrobní linky a stroje
Výroba č. | Číslo výroby.
Datum | Datum události.
Úložiště | Identifikace skladového úložiště
V/V | Vstup / Výstup
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Množství | Množství
Fáze | Fáze výroby.

Atributy tisku

Základní údaje
Datum | Datum události. | VRW1.vr14datum | T
Operace | Identifikace technologické operace | VRW1.tp05id | C(13)
Úložiště | Identifikace skladového úložiště | VRW1.tp17id | C(6)
Číslo linky | Číslo výrobní linky, resp. stroje | VRW1.tp13id | C(6)
Vstup / Výstup | Vstup / Výstup | Výpočet | C(6)
Druh artiklu | Identifikace druhu artiklu | VRW1.sp61id | C(3)
Artikl | Identifikace artiklu | VRW1.sp60id | C(13)
Množství | Množství | VRW1.vr14mn | N(20,6)
MJ | Identifikátor měrné jednotky | VRW1.sp24idmj | C(3)
Cena za j. | Cena za jednotku materiálu. | VRW1.vr14cj | N(20,4)
Cena | Celková cena | VRW1.vr14cena | N(20,4)

Viz.také

Harmonogram výroby | Artikly výroby | Druhy artiklů | Technologické postupy | Výrobní linky a stroje


Výroba - měření a vážení

Popis

Podle zadaného časového intervalu periodicky zapisuje výsledky realizovaných výrobních úkolů ze souboru aktualizovaného vážním serverem.

Formulář

Formulář činnosti - Výrobní linky a stroje
Výroba č. | Číslo výroby.
Čas příštího spuštění | Čas příštího spuštění zpracování dat vážního systému
Prodleva zpracování | Prodleva zpracovnání
Soubor vážního systému | Název souboru vážního systému
 | Timer


Kalendáře směn výroby

Popis

Kalendáře v komponentě výroby definují použitelný čas (období plánovaného či očekávaného výrobního úkolu) dané linky a jsou využity zejména pro:

¨ automatické plánování (generování) výrobních úkolů

¨ zobrazení harmonogramu (s jeho následnou aplikací „ručního“ plánování)

Tato činnost tedy umožňuje uživateli definovat, opravovat, popřípadě i rušit jednotlivé kalendáře směn výroby. U každého kalendáře jsou k dispozici tyto informace:

¨ identifikace a název kalendáře

¨ úroveň – pro danou linku v daném období může být definováno libovolné množství kalendářů, podle kterých se v okamžiku aplikace kalendáře vyhodnotí její použitelný čas způsobem, kdy vyšší úroveň „přebíjí“ nižší úroveň (pokud se uživateli podaří chybně zadat, že jedna linka v jenom čase má platné 2 či více kalendářů se shodnou úrovní, je o tom uživatel informován při spuštění relevantních činností (přehled kalendářů, generování úkolů, ...) systémovou hláškou: „Kalendář nelze aplikovat“. Úroveň kalendáře je v okamžiku jeho vstupu (po stisku klávesy F3) automaticky předplněna hodnotou o 10 vyšší než dosud nejvyšší užitá úroveň (toto neplatí pro kalendáře výjimek).

¨ všeobecný kalendář – kalendář definovaný jako všeobecný je automaticky platný pro každou nově zařazenou linku

Specifická je aplikace kalendářů s identifikátorem, který je shodný s identifikátorem linky – tento kalendář se pak vytváří automaticky (pokud již neexistuje) s nastavenou nejvyšší úrovní při definici výjimek linky. Kalendář výjimek linky se zobrazuje modře (je nutno si dát pozor, aby nebyl založen kalendář s id jako linka, ale byl míněn na jiné použití). Tyto výjimky jsou dostupné i na záložce činnosti s přehledem linek.

Na záložce „Dny kalendáře“ se definují elementy kalendáře – jeho směny. K předplnění směn lze užít funkci, která je následně automaticky vygeneruje (menu Volby, činnost „předplnit směny“). V případě potřeby je k dispozici i funkce pro zrušení všech vybraných (na záložce dostupných) směn (menu Volby, činnost „zrušit zobrazené dny kalendáře“).

Na záložce „Přidělené linky“ se definuje, pro které linky a v kterém období je kalendář platný. Lze použít funkci z menu Volby („přidělit všechny linky ke kalendáři“), která nadefinuje všechny linky na „nekonečné“ období. V případě, že se jedná o všeobecný kalendář, je sem automaticky zařazena každá nově založená linka. V případě, že se jedná o kalendář výjimek (shodné identifikátory), není linka na záložce uváděna (platí implicitně).

Datový model

  • VRKAL Kalendář výroby

    • Formulář

    Formulář činnosti - Kontrolovat strukturu kalendářů
Mřížka [Kalendáře]
Kalendář | Identifikace kalendáře
Název kalendáře | Název kalendáře
Listovací rámeček
Stránka #1 Kalendáře
Úroveň | Úroveň kalendáře
Všeobecný kalendář | Všeobecný kalendář
Poznámka | Poznámka
Stránka #2 Dny kalendáře
Mřížka [Dny kalendáře]
Datum | Datum v kalendáři využití linky
Číslo směny | Číslo směny
Od | Hodina začátku směny
Doba trvání | Doba trvání směny v hodinách
Směna se uskuteční (uskutečnila) | Směna se uskuteční (uskutečnila) Ano/Ne
Poznámka | Poznámka
Stránka #3 Přidělené linky
Mřížka [Přidělené linky]
Linka | Číslo výrobní linky, resp. stroje
Název linky | Název výrobní linky
Platnost od | Platnost od
do | Platnost do
Stránka #4 Výběr
Kalendář | Identifikace kalendáře
Datum | Datum v kalendáři využití linky
do | Datum v kalendáři využití linky do
Číslo směny | Číslo směny
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Kalendáře] činnosti - Kontrolovat strukturu kalendářů

    Mřížka [Kalendáře] činnosti - Kontrolovat strukturu kalendářů
Kalendář | Identifikace kalendáře
Název kalendáře | Název kalendáře

    Mřížka [Dny kalendáře] činnosti - Kontrolovat strukturu kalendářů

    Mřížka [Dny kalendáře] činnosti - Kontrolovat strukturu kalendářů
Datum | Datum v kalendáři využití linky
Název dne | Název dne
Číslo směny | Číslo směny
Od | Hodina začátku směny
Doba trvání | Doba trvání směny v hodinách

    Mřížka [Přidělené linky] činnosti - Kontrolovat strukturu kalendářů

    Mřížka [Přidělené linky] činnosti - Kontrolovat strukturu kalendářů
Linka | Číslo výrobní linky, resp. stroje
Název linky | Název výrobní linky
Platnost od | Platnost od
do | Platnost do

    Vyvolávané činnosti

    K. | Činnost | Popis
- | Předplnit směny | Předplnit směny do kalendáře linek
- | Přidělit všechny linky ke kalendáři | Přidělit všechny linky ke kalendáři
- | Zrušit zobrazené dny kalendáře | Zrušit zobrazené dny kalendáře
- | Kontrolovat strukturu kalendářů | Kontrolovat strukturu kalendářů
F2 | Výrobní linky a stroje | Seznam výrobních linek a strojů

    Atributy tisku

    Základní údaje
Kalendář | Identifikace kalendáře | VRKAL_vr32id | C(6)
Název kalendáře | Název kalendáře | VRKAL_vr32nazkal | C(40)
Úroveň | Úroveň kalendáře | VRKAL_vr32uroven | N(5)
Všeobecný kalendář | Všeobecný kalendář | Výpočet | C(3)
Poznámka | Poznámka | VRKAL_vr32koment | M
Název linky | Název výrobní linky | TPLINKA_tp13linka | C(40)

    Při pohybu v Přidělené linky
Číslo linky | Číslo výrobní linky, resp. stroje | VRKALPLI_tp13id | C(6)
Platnost od | Platnost od | VRKALPLI_vr36datod | D
do | Platnost do | VRKALPLI_vr36datdo | D

    Při pohybu v Dny kalendáře
Datum | Datum v kalendáři využití linky | VRKALPOL_tp23datum | D
Od | Hodina začátku směny | VRKALPOL_tp23casod | C(4)
Doba trvání | Doba trvání směny v hodinách | VRKALPOL_tp23trvani | N(5,2)
Číslo směny | Číslo směny | Výpočet | C(7)
Název dne | Název dne | Výpočet | C(7)
Směna se uskuteční (uskutečnila) | Směna se uskuteční (uskutečnila) Ano/Ne | Výpočet | C(3)
Poznámka | Poznámka | VRKALPOL_tp23koment | M

    Viz.také

    Předplnit směny | Přidělit všechny linky ke kalendáři | Zrušit zobrazené dny kalendáře | Kontrolovat strukturu kalendářů | Výrobní linky a stroje


Přehled směn výrobních linek

Popis

Tento přehled uživatel aktivuje z menu Výroba – Přehled směn výrobních linek a nebo v menu Technická příprava výroby – Výrobní linky a stroje - záložka Výjimky v kalendáři (menu Volby). Po aktivaci této činnosti má uživatel k dispozici záložku Výběr, kde si může informace vyfiltrovat podle konkrétní linky, podle období od – do a podle čísla směny. Na záložce kalendář jsou pak k dispozici informace o výrobní lince, kalendáři linky, datu, číslu směny, době trvání od a celkový čas a příznak (Ano/Ne), zda se směna uskutečnila.

Datový model

  • VRKALLIN Směna výrobní linky
    • TPLINKA Výrobní linka / stroj / skladové úložiště výroby (alias TPLINKA2)
    • VRKAL Kalendář výroby

    • Formulář

    Formulář činnosti - Výrobní linky a stroje
Mřížka [Kalendář]
Listovací rámeček
Stránka #1 Kalendář
Linka | Číslo výrobní linky, resp. stroje
Název linky | Název výrobní linky
Kalendář | Identifikace kalendáře
Název kalendáře | Název kalendáře
Datum | Datum v kalendáři využití linky
Číslo směny | Číslo směny
Od | Hodina začátku směny
Doba trvání | Doba trvání směny v hodinách
Směna se uskuteční (uskutečnila) | Směna se uskuteční (uskutečnila) Ano/Ne
Poznámka | Poznámka
Stránka #2 Výběr
Číslo linky | Číslo výrobní linky, resp. stroje
Datum | Datum v kalendáři využití linky
do | Datum v kalendáři využití linky do
Číslo směny | Číslo směny
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Kalendář] činnosti - Výrobní linky a stroje

    Mřížka [Kalendář] činnosti - Výrobní linky a stroje
Datum | Datum v kalendáři využití linky
Název dne | Název dne
Číslo směny | Číslo směny
Od | Hodina začátku směny
Doba trvání | Doba trvání směny v hodinách
Linka | Číslo výrobní linky, resp. stroje
Název linky | Název výrobní linky
Kalendář | Identifikace kalendáře
Název kalendáře | Název kalendáře

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Výrobní linky a stroje | Seznam výrobních linek a strojů

    Atributy tisku

    Základní údaje
Číslo linky | Číslo výrobní linky, resp. stroje | VRKALLIN_tp13id | C(6)
Název linky | Název výrobní linky | TPLINKA2_tp13linka | C(40)
Kalendář | Identifikace kalendáře | VRKALLIN_vr32id | C(6)
Název kalendáře | Název kalendáře | VRKAL_vr32nazkal | C(40)
Datum | Datum v kalendáři využití linky | VRKALLIN_tp23datum | D
Název dne | Název dne | Výpočet | C(7)
Číslo směny | Číslo směny | Výpočet | C(7)
Od | Hodina začátku směny | VRKALLIN_tp23casod | C(4)
Doba trvání | Doba trvání směny v hodinách | VRKALLIN_tp23trvani | N(5,2)
Poznámka | Poznámka | VRKALLIN_tp23koment | M

    Viz.také

    Výrobní linky a stroje


Harmonogram výroby

Popis

Po aktivaci této činnosti se uživateli nejprve zobrazí činnost Harmonogram výroby s aktivní záložkou „Výběr“. Zde si nadefinuje data, která chce mít v harmonogramu k dispozici (tzn. číslo výroby, datum od – do, fáze, adresát, druh linky, linka, operace, ...). Důležitým atributem je „provádět změny – Ano/Ne“. Pokud je nastaveno Ano, může uživatel v harmonogramu realizovat posun úkolů, v případě, že je nastaveno Ne, změny v harmonogramu realizovat nemůže a harmonogram mu slouží pouze k prohlížení.

Po načtení záložky výběr se uživateli zobrazí dva formuláře. Menší formulář s informacemi o konkrétním výrobním úkolu a větší formulář s grafickým zobrazením výrobních úkolů. K dispozici jsou údaje o dnu, na které lince se výrobní úkol plní, na kolik směn a v jakém časovém rozpětí.

V případě potřeby (a pokud je to na záložce „výběr“ povoleno) lze výrobní úkoly přesunovat. Jejich přesun se následně zaznamená pomocí klávesy F5 (Zapsat změny harmonogramu).

Datový model

  • VRUDOPER Událost úkolu ve výrobě
    • VRVYR Výrobní zakázka
      • ADADSAT Adresát
    • TPOPERAC Technologická operace
      • BWRGBCOL Hodnota RGB barvy

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Zapsat změny harmonogramu | Zapsat změny harmonogramu
F9 | Spustit operaci | Spuštění zobrazené operace
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Označit výr.úkoly ke sloučení | Označit výrobní úkoly ke sloučení
- | Slučování výrobních úkolů | Události výrobních úkolů
F2 | Adresář | Přehled adresátů
F2 | Druhy výrobních linek | Číselník druhů výrobních linek
F2 | Přehled referenčních artiklů | Přehled referenčních artiklů
F2 | Výrobní linky a stroje | Seznam výrobních linek a strojů
F2 | Zakázky výroby | Přehled zakázek výroby

    Formulář

    Formulář činnosti - OZNAČOVÁNÍ
Listovací rámeček
Stránka #1 Harmonogram
Mřížka [Harmonogram]
Fáze | Fáze výroby.
VČ | Číslo výroby.
Skupina | Skupina výrobních úkolů
Poř.č. | Pořadové číslo úkolu v rámci výrobní zakázky
Adresát | Identifikace adresáta
 | Název adresáta
Datum | Datum
Číslo směny | Číslo směny
Ukonč. | Datum a čas ukončení plnění výrobního úkolu
 | Délka trvání výrobního úkolu
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Operace | Identifikace technologické operace
 | Stručný popis, charakterizující technologickou operaci
Číslo linky | Číslo výrobní linky, resp. stroje
Následníci | Následující spojené úkoly
Stránka #2 Výběr
VČ | Číslo výroby.
Datum | Datum v kalendáři využití linky
do | Datum v kalendáři využití linky do
Fáze | Fáze výroby.
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Druh linky | Identifikace druhu výrobní linky
Linka | Číslo výrobní linky, resp. stroje
Operace | Identifikace technologické operace
Zobrazit | Zobrazit harmonogram včetně nenaplněných směn/bez nenaplněných směn/danou zakázku - adresáta - operaci
Interval | Nejmenší časový interval
Provádět změny | Provádět změny v harmonogramu Ano/Ne
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Harmonogram] činnosti - OZNAČOVÁNÍ

    Mřížka [Harmonogram] činnosti - OZNAČOVÁNÍ
Označování | Označení záznamu
Fáze | Fáze výroby.
Výroba č. | Číslo výroby.
Skupina | Skupina výrobních úkolů
Poř.č. | Pořadové číslo úkolu v rámci výrobní zakázky
Datum | Datum
Číslo směny | Číslo směny
Trvání (hod) | Délka trvání výrobního úkolu
Operace | Identifikace technologické operace
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Číslo linky | Číslo výrobní linky, resp. stroje
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Pořadí | Pořadí stejného druhu operace v jednom procesu
Datum od | Datum výroby od data.
Datum ukončení | Datum ukončení výroby.
Obch. sel. | Identifikátor obchodního selektoru výrobní zakázky
Org. sel. | Identifikátor organizačního selektoru výrobní zakázky
Tech. sel. | Identifikátor technicko-věcného selektoru výrobní zakázky
Adresát | Identifikace adresáta
Název adresáta | Název adresáta

    Viz.také

    Zapsat změny harmonogramu | Spustit operaci | OZNAČOVÁNÍ | Označit výr.úkoly ke sloučení | Výrobní úkoly | Adresář | Druhy výrobních linek | Přehled referenčních artiklů | Výrobní linky a stroje | Zakázky výroby | Harmonogram - posun úkolů


Nový harmonogram výroby

Popis

Nový harmonogram výroby (v popisu dále pouze „NHV“) slouží k naplánování výrobních úkolů na jednotlivých výrobních linkách (roštech). Po aktivaci této činnosti se uživateli nejprve zobrazí činnost „NHV“ s aktivní záložkou „Výběr“. Zde si nadefinuje data, která chce mít v harmonogramu k dispozici (tzn. číslo výroby, datum od – do, fáze, adresáta, druh linky, linku, operaci, ...). Důležitým atributem je „provádět změny – Ano/Ne“. Pokud je nastaveno Ano, může uživatel v harmonogramu realizovat posun úkolů, v případě, že je nastaveno Ne, změny v harmonogramu realizovat nemůže a harmonogram mu slouží pouze k prohlížení.

Po načtení záložky výběr se uživateli zobrazí dva formuláře. Menší formulář „NHV“ s informacemi o konkrétním výrobním úkolu (aktivní záložka Výrobní úkoly) a větší formulář s grafickým zobrazením výrobních úkolů („NHV“ – přehled). K dispozici jsou údaje o dnu, na které lince se výrobní úkol plní, na kolik směn a v jakém časovém rozpětí.

Jednotlivé sloupce ve formuláři „NHV“ (menší formulář) lze kdykoliv podle potřeby přesouvat (např. pro potřebu zvýšení přehlednosti v tiskových sestavách). Jak je viditelné z obrázku, jsou výrobní úkoly řazeny v řádcích a jejich zbarvení určuje v jaké fázi zadávání se výrobní úkol nachází.

V případě, že výrobní úkol ještě nebyl zadán, je zbarven fialově. Úkoly, se kterými bylo manipulováno a které ještě nejsou zapsány jsou zbarveny šedě. Šedě jsou zbarveny i úkoly, které již byly zapsány, následně se s nimi znovu manipulovalo (např. přesouvání mezi výrobními linkami apod.) a tyto změny ještě nebyly zapsány.

Výrobní úkol si může uživatel zobrazit dvojím způsobem:

¨ překliknutím na záložku Popis, kde jsou konkrétní údaje k danému výrobnímu úkolu

¨ kliknutím na výrobní úkol přímo v „NHV – přehled“

Formulář „Nový harmonogram výroby – přehled“ poskytuje uživateli v horní liště následující informace:

¨ 1/1 (případně 1/2 ...n) – počet stran NHV, na jednu stranu připadá 70 řádků

¨ P – předchozí strana - pravý klik o pět záznamů (nikoliv stran) zpět

¨ N – následující strana – pravý klid o pět záznamů (nikoliv stran) vpřed

¨ O – označují se výrobní úkoly vhodné ke sloučení

¨ Z – krok zpět (vrátí poslední provedenou změnu v harmonogramu)

¨ U – uloží se změny provedené v harmonogramu

Sloupce odpovídají časovému úseku 30 nebo 60 minut výroby (časový úsek si uživatel nastaví na záložce Výběr). Časový harmonogram začíná s časem zahájení první směny. V prvním sloupci je zapsán den a číslo výrobní linky, přičemž znak „#“ označuje delší směnu.

Zadávání výrobního úkolu uživatel provede v okně „Nový harmonogram výroby – přehled“. Vkládání výrobního úkolu provede uživatel přetažením z okna Nový harmonogram výroby ze záložky Výrobní úkol (lze vkládat pouze nezadané úkoly, tj. fialově zbarvené). Uživatel si označí daný výrobní úkol (kliknutím na něj), v dolní části okna se objeví ikona „ruky s nataženým ukazováčkem“ a metodou „táhni a drž“ (na ikonu ruky) přetáhne výrobní úkol na požadované místo. Po přetažení výrobního úkolu se ve formuláři „NHV – záložka Výrobní úkoly“ zbarví výrobní úkol šedě. Po uložení této procedury pomocí tlačítka „U“ změní zbarvení na bílou barvu a tímto je výrobní úkol zadán.

Při vkládání více různých výrobních úkolů se může každý zbarvit jinak, ale úkoly jedné výrobní zakázky mají vždy stejné zbarvení. Po vložení výrobních úkolů je nutno změny zapsat (pomocí klávesy F5 - Zapsat změny harmonogramu). Uložený výrobní úkol uživatel pozná podle toho, zda je název artiklu podtržen (podtržen = není uložen). Při ukončení harmonogramu bez uložení změn je uživatel systémem automaticky dotázán zda chce provedené změny uložit.

V praxi může nastat situace, že výrobní úkol přesahuje pracovní dobu linky. V takovém případě se systém při ukládání dotazuje, zda má výrobní úkol rozdělit. Po potvrzení volby „Ano“ se část přesahující čas denní výroby „odřízne“ a automaticky zařadí na začátek nejbližšího možného termínu stejného výrobní linky. Zbývající část výrobního úkolu se přesune na začátek další směny i v případě, že se na lince nachází již jiný výrobní úkol. Nastane tedy potom situace, že na jedné lince ve stejnou dobu bude více výrobních úkolů (tzn. zvětší se šířka řádka v přehledu NHV). Výrobní úkoly se v takové situaci řadí sestupně pod sebe podle času začátku výroby. Záleží zcela na uživateli, jestli některý výrobní úkol přesune na jiný termín. Pokud nastane situace, že se v harmonogramu výroby nachází více výrobních úkolů přesahujících pracovní dobu linky, je pak uživatel na každý z nich systém dotazován postupně.

V případě potřeby je pro uživatele k dispozici činnost, která mu umožňuje rozdělené výrobní úkoly opět spojit (využije ji i při nutnosti spojení vybraných výrobních úkolů). Tato činnost se nazývá slučování.

Jaké výrobní úkoly lze sloučit uživatel zjistí dvojklikem myši na dané události. Na záložce Výrobní úkoly se pak následně ve sloupci Výroba č. označí červeně ty výrobní úkoly, které je možno s původním výrobním úkolem sloučen. Toto označení pomocí zbarvení funguje pouze v případě, že na záložce „výběr“ má uživatel použitu paletu „barvy dle artiklu“.

V případě, že uživatel nevyužívá palety barev, je možno provést slučování trojím způsobem:

¨ pomocí ikony v horní liště

¨ pomocí činnosti pod menu Volby „Označit výr. úkoly ke sloučení“

¨ ručním označením výrobních úkolů v NHV – záložka „výrobní úkoly“

Po zvolení výrobních úkolů ke sloučení uživatel aktivuje pod menu Volby činnost „Slučování výrobních úkolů“. Následuje systémový dotaz, zda uživatel chce slučovat výrobní úkoly i z různých směn. Toto je uživatelské rozhodnutí, v programu je implicitně nastavena volba NE. Po potvrzení OK se zobrazí okno „slučování“, ve kterém jsou k dispozici informace o slučovaných výrobních úkolech, č. zakázek, fázích, linkách operace, artiklu a umístění. V tento okamžik má uživatel možnost ještě proces slučování zrušit. Pokud ale potvrdí volbu ANO, jsou vybrané výrobní úkoly sloučeny. Pokud se slučují události z více výrobních linek, IS se dotazuje na každou zvlášť. Provedené změny se ihned graficky neprojeví, ale IS si je již pamatuje a nedovolí provést změny, které by zasahovaly do předchozích změn.

Datový model

  • VRUDOPER Událost úkolu ve výrobě
    • VRVYR Výrobní zakázka
      • ADADSAT Adresát
    • TPOPERAC Technologická operace
      • BWRGBCOL Hodnota RGB barvy
    • TPLINKA Výrobní linka / stroj / skladové úložiště výroby (alias TPLINKA3)
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU3)
    • SPPRCOD Operace procesu
      • SPPRC Proces
    • TPVYROB Artikl výroby
      • SPARTIKN Název artiklu

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Zapsat změny harmonogramu | Zapsat změny harmonogramu
^F9 | Spustit operaci | Spuštění zobrazené operace
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Označit výr.úkoly ke sloučení | Označit výrobní úkoly ke sloučení
- | Slučování výrobních úkolů | Události výrobních úkolů
F2 | Adresář | Přehled adresátů
F2 | Druhy výrobních linek | Číselník druhů výrobních linek
F2 | Paleta zobrazení v harmonogramu | Paleta zobrazení v harmonogramu
F2 | Přehled referenčních artiklů | Přehled referenčních artiklů
F2 | Výrobní linky a stroje | Seznam výrobních linek a strojů
F2 | Zakázky výroby | Přehled zakázek výroby

    Formulář

    Formulář činnosti - Paleta zobrazení v harmonogramu
Mřížka [Harmonogram]
Listovací rámeček
Stránka #1 Výrobní úkoly
Stránka #2 Popis
Fáze | Fáze výroby.
VČ | Číslo výroby.
Skupina | Skupina výrobních úkolů
Poř.č. | Pořadové číslo úkolu v rámci výrobní zakázky
Adresát | Identifikace adresáta
 | Název adresáta
Datum | Datum
Číslo směny | Číslo směny
Ukonč. | Datum a čas ukončení plnění výrobního úkolu
 | Délka trvání výrobního úkolu
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Operace | Identifikace technologické operace
 | Stručný popis, charakterizující technologickou operaci
Číslo linky | Číslo výrobní linky, resp. stroje
Název linky | Název výrobní linky
Následníci | Následující spojené úkoly
Stránka #3 Výběr
VČ | Číslo výroby.
Datum | Datum v kalendáři využití linky
do | Datum v kalendáři využití linky do
Skryté všechny | Zobrazit skryté bez ohledu na datum
Fáze | Fáze výroby.
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Druh linky | Identifikace druhu výrobní linky
Linka | Číslo výrobní linky, resp. stroje
Operace | Identifikace technologické operace
Zobrazit | Zobrazit harmonogram včetně nenaplněných směn/bez nenaplněných směn/danou zakázku - adresáta - operaci
Skryté | Příznak skrytého úkolu v harmonogramu
Interval | Nejmenší časový interval
Provádět změny | Provádět změny v harmonogramu Ano/Ne
Paleta | Identifikace palety zobrazení v harmonogramu
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Harmonogram] činnosti - Paleta zobrazení v harmonogramu

    Mřížka [Harmonogram] činnosti - Paleta zobrazení v harmonogramu
Označování | Označení záznamu
Fáze | Fáze výroby.
Výroba č. | Číslo výroby.
Skupina | Skupina výrobních úkolů
Poř.č. | Pořadové číslo úkolu v rámci výrobní zakázky
Datum | Datum
Číslo směny | Číslo směny
Trvání (hod) | Délka trvání výrobního úkolu
Operace | Identifikace technologické operace
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Číslo linky | Číslo výrobní linky, resp. stroje
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Pořadí | Pořadí stejného druhu operace v jednom procesu
Datum od | Datum výroby od data.
Datum ukončení | Datum ukončení výroby.
Obch. sel. | Identifikátor obchodního selektoru výrobní zakázky
Org. sel. | Identifikátor organizačního selektoru výrobní zakázky
Tech. sel. | Identifikátor technicko-věcného selektoru výrobní zakázky
Adresát | Identifikace adresáta
Název adresáta | Název adresáta

    Viz.také

    Zapsat změny harmonogramu | Spustit operaci | OZNAČOVÁNÍ | Označit výr.úkoly ke sloučení | Výrobní úkoly | Adresář | Druhy výrobních linek | Paleta zobrazení v harmonogramu | Přehled referenčních artiklů | Výrobní linky a stroje | Zakázky výroby


SPUŠTĚNÍ EXTERNÍHO PŘÍKAZU

Popis

V této činnosti má uživatel možnost spustit si vybraný externí příkaz. Jednotlivé externí příkazy se definují v činnosti externí příkazy v činnosti Informační centrum - Typy a řady.

Datový model

  • SPEXTPR Externí příkaz
    • SPEXTPRD Druh externího příkazu
      • SPPRISTU Přístupové právo uživatele k věci

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PROJEKTOVÉ ŘÍZENÍ

Popis

V oblasti projektového řízení IS Bílý Motýl zaměřuje na definici projektu, na plánování projektových úkolů s řízením kapacit, na sledování a řízení plnění projektových úkolů a to vždy ve vztahu k cíli projektu a samozřejmě v procesních vztazích k ostatním oblastem, například k prodeji a nákupu, odměňování, výrobě, expedici, ale také třeba i ke správě majetku apod.

Viz.také

O PŘEDMĚTU PROJEKTU | O SMLOUVÁCH | O ŘÍZENÍ PROJEKTU


O PŘEDMĚTU PROJEKTU

Popis

Jádrem každého projektu je definice předmětu projektu, který je výsledkem uskutečnění projektu, tj. to proč se projekt zakládá a realizuje. Může se jednat o hmotné předměty projektu, jako je například stavba, prototyp stroje, kniha, nová chemická sloučenina, ale také prodávané auto,…, anebo o nehmotné předměty projektu, jako je například urbanistická studie, technická dokumentace, analýza informačních potřeb, definice plánu realizace zakázky atd.

V případě, že je projektové řízení z IS BM aplikováno na podporu „neprojektových“ aktivit, jako je poskytování „drobných“ služeb nebo realizace „drobných“ zakázek nebo jako jsou kontinuální činnosti (prodej, marketing, správa majetku, …), pak je jako předmět projektu definován opakovaný výkon dané aktivity.

V IS BM lze cíl projektu popsat několika způsoby. Mezi nejstručnější bude zcela jistě patřit popis volným textem. Pokud se k projektu vztahuje řada dokumentů, může být vhodné předmět projektu popsat připojením těchto dokumentů (text, tabulky, foto, video, ….) objektovou vazbou. V situaci, kdy se opakovaně realizuje poměrně velké množství „podobných“ projektů, je nejvhodnější cíl projektu popsat sadou parametrů.

Viz.také

Předmět projektu | Hodnoty předmětu projektu | Aktuální hodnoty hodnot PP | NASTAVENÍ PŘEDMĚTU PROJEKTU


Předmět projektu

Popis

Tato činnost poskytuje uživatel přehled jednotlivých nadefinovaných předmětů projektu (dále jen PP). Celá struktura PP může být v některých implementacích poměrná náročná a rozsáhlá, proto je vhodné (a velmi efektní) si pro tuto činnost nadefinovat složitější obecný výběr, který uživateli zpřesňuje a rozšiřuje možnosti záložky Výběr. Předmět projektu (PP) definuje cíl projektu jeho realizací.

Na záložce „Předměty projektu“ má uživatel k dispozici tyto atributy:

¨ předmět – v podstatě se jedná o identifikaci druhu artiklu a vlastní identifikaci artiklu. Uvádí se zde i číslo verze.

¨ název – vlastní název artiklu

¨ prac. název – pracovní (neboli pomocný) název projektu

¨ čárový kód - čárový kód artiklu, který daným projektem vznikne. Údaj je povinný v případě, že v parametrech, které náleží k danému PP je uvedeno ČK? „Ano“.

¨ externí ID – externí identifikace předmětu projektu. Údaj je povinný v případě, že v parametrech, které náleží k danému PP je uvedeno EID? „Ano“.

¨ stav – výběr z překryvného seznamu. Může dosahovat hodnot – uvažovaný, zamítnutý, odložený, schválený, rozpracovaný, ukončený a generický.

¨ uzavřen – volba Ano/Ne – při volbě „Ano“ je popis předmětu uzavřen pro opravy

¨ umístění – identifikace umístění. Ke každému umístění je možno nadefinovat přístupová práva. V některých případech může být rozumné provázat umístění na uživatele 1 : 1, tzn. jedno umístění = jeden uživatel.

¨ vedoucí – identifikace a jméno uživatele, který je vedoucím daného předmětu projektu

¨ prezentace – zvolení identifikace prezentace parametrů

¨ obch. sel. – identifikace obchodního selektoru, který se přímo vztahuje k předmětu projektu

¨ tech. sel. – identifikace technicko-věcného selektoru, který se přímo vztahuje k předmětu projektu

¨ popis – vlastní komentář k předmětu projektu

¨ zapsal – jméno uživatele, který projekt zadal a datum a čas zápisu

Důležitou součástí popisu PP jsou jeho hodnoty (záložka Hodnoty), které získává inicializací podle jemu přidělené prezentace. I zde je možno vyvolat „strom hodnot PP – klávesa F9“, který v podstatě pro uživatele poskytuje stejné informace, pouze přehledněji zobrazené ve stromovém uskupení. Přehled jednotlivých hodnot PP má uživatel i po stisku pravého tlačítka myši na tučném atributu „Předmět“ na záložce Předměty projektu (Předmět – Události artiklu – Hodnoty předmětu projektu).

Na záložce Změny stavu se mohou na předmětu projektu hlídat důležité změny, které je vhodné a smysluplné zaznamenat, typicky je to stav PP. Stav PP je možné nastavit při jeho založení, změna stavu PP se provádí na záložce "Změny stavu". Stav PP mohou měnit také události plnění projektového úkolu podle svého druhu plnění. Nastavení atributu PP "Uzavřen" na hodnotu "Ano" slouží k zablokování přepisu atributů PP "Čárový kód" a "Externí ID". Nastavení sledování změn se provádí v činnosti Parametry PP, na záložce Definice struktury, atribut Změny (možnosti Ano/Ne).

Kromě popsaných záložek má uživatel k dispozici v daném formuláři ještě:

¨ Kategorie artiklu – k dispozici jsou informace o přiřazené kategorii správy artiklu, která se vztahuje k předmětu projektu. Na základě zvolení Palety na záložce Výběr je možno přehled artiklů zvýraznit i barevně.

¨ Názvy – možnost definice cizojazyčných názvů předmětu projektu

Datový model

  • NKPREDPR Předmět projektu
    • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU4)
    • SPARTIKL Artikl
    • SPARTIKN Název artiklu
    • NKPARDRU Umístění parametru předmětu projektu (alias NKPARDRU2)
    • SPARTIKD Druh artiklu
    • BWUZIVAT Uživatel systému
    • SPSEOB Obchodní selektor
    • SPSETV Technicko-věcný selektor
    • ADADSAT Adresát
    • NKPRP Prezentace parametrů

    • Formulář

     | Formulář činnosti - Měny a kursy
 | Mřížka [Předměty projektu]
 | Listovací rámeček
 | Stránka #1 Předměty projektu
 |  | Identifikace druhu artiklu
 | Předmět | Identifikace artiklu
 |  | Verze projektu
 | Název | Název artiklu
 | Prac. název | Pracovní název projektu
 | Čárový kód | Čárový kód artiklu, který vznikne projektem
 | Externí ID | Externí identifikace předmětu projektu
 | Stav | Stav projektu (uvažovaný, zahájený,...)
 | Umístění | Identifikace umístění
 | Název umístění | Název umístění parametru
 | Vedoucí | Identifikace adresáta
 |  | Název adresáta
 | Prezentace | Identifikace prezentace parametrů
 | Název prezentace | Název prezentace parametrů
 | Obch. sel. | Identifikátor obchodního selektoru
 |  | Název obchodního selektoru
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 |  | Název technicko-věcného selektoru.
 | Uzavřen | Popis předmětu uzavřen pro opravy Ano/Ne
 | Popis | Uživatelský popis předmětu projektu
 | Zapsal | Jméno uživatele systému
 |  | Datum a čas zápisu záznamu události
 | Stránka #2 Hodnoty
 | Mřížka [Hodnoty]
 |  | Identifikace druhu artiklu
 | Předmět | Identifikace artiklu
 |  | Verze projektu
 |  | Název artiklu
 | Parametr | Identifikace parametru předmětu projektu
 | Název parametru | Název parametru předmětu projektu
 | Umístění | Identifikace umístění
 |  | Název umístění parametru
 | Adresát | Identifikace adresáta
 |  | Číslo spojení adresáta.
 |  | Název adresáta
 | ID | Identifikace hodnoty
 | Datum 1 | Datumová položka 1 číselníku
 | Datum 2 | Datumová položka 2 číselníku
 | Text 1 | Textová položka 1 číselníku
 | Num 1 | Numerická položka 1 číselníku
 | Měna | Kód měny - oceňovací jednotky.
 | Num 2 | Numerická položka 2 číselníku
 | Výpočet | Výpočet
 | Obch. sel. | Identifikátor obchodního selektoru
 |  | Název obchodního selektoru
 | Org. sel. | Identifikátor organizačního selektoru.
 |  | Název organizačního selektoru
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 |  | Název technicko-věcného selektoru.
 | Poznámka | Poznámka
 | Stránka #3 Změny stavu
 | Mřížka [Změny stavu]
 | Druh | Identifikace druhu artiklu
 | Předmět | Identifikace artiklu
 | Verze | Verze projektu
 | Název artiklu | Název artiklu
 | Typ změny | Typ změny - Stav předmětu projektu/Hodnota parametru
 | Název parametru | Název parametru předmětu projektu
 | Parametr | Identifikace parametru předmětu projektu
 | Stav | Stav projektu (uvažovaný, zahájený,...)
 | Zapsal | Jméno uživatele systému
 | Datum a čas zápisu | Datum a čas zápisu záznamu události
 | Poznámka | Poznámka
 | Stránka #4 Karegorie artiklu
 | Mřížka [Kategorie artiklu]
 |  | Kategorie
Identifikace kategorie události správy artiklu |  |
Název kategorie události správy artiklu |  |  | Platnost
Datum platnosti od |  |  | Platnost do
Datum platnosti do |  |  | Adresát
Identifikace adresáta |  |
Název adresáta |  |
Číslo spojení adresáta. |  |  | Popis
Popis události |  |  | Poznámka
Poznámka |  |  | Zapsal
Jméno uživatele systému |  |  | Datum a čas zápisu
Datum a čas zápisu záznamu události
 | Stránka #5 Výběr
 |  | Identifikace druhu artiklu
 | Předmět | Identifikace artiklu
 |  | Verze projektu
 | Název | Název artiklu
 | Prac. název | Pracovní název projektu
 | Čárový kód | Čárový kód artiklu, který vznikne projektem
 | Externí ID | Externí identifikace předmětu projektu
 | Stav | Stav projektu
 | Vedoucí | Identifikace adresáta
 | Obch. sel. | Identifikátor obchodního selektoru
 | Umístění | Identifikace umístění
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Kategorie | Identifikace kategorie události správy artiklu
 | Skupina | Identifikace skupiny
 | Prezentace | Identifikace prezentace parametrů
 | Vznikl od | Datum vzniku projektu
 | do | Datum vzniku projektu
 | Zapsal | Identifikace uživatele systému
 | Parametr | Identifikace parametru předmětu projektu
 | ID | Identifikace hodnoty
 | Paleta | Vybrat záznamy všech kategorií v paletě
 |  | Identifikace palety barev
 | Výběr | Určení výběru
 | Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Předměty projektu] činnosti - Měny a kursy

    Mřížka [Předměty projektu] činnosti - Měny a kursy
Označování | Označení záznamu
Druh | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
Název artiklu | Název artiklu
Prac. název | Pracovní název projektu
Stav | Stav projektu (uvažovaný, zahájený,...)
Prezentace | Identifikace prezentace parametrů
Název prezentace | Název prezentace parametrů
Čárový kód | Čárový kód artiklu, který vznikne projektem
Externí ID | Externí identifikace předmětu projektu
Obch. sel. | Identifikátor obchodního selektoru
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Mřížka [Hodnoty] činnosti - Měny a kursy

    Mřížka [Hodnoty] činnosti - Měny a kursy
Název parametru | Název parametru předmětu projektu
Zobrazení hodnoty | Zobrazení hodnoty
Parametr | Identifikace parametru předmětu projektu
Pořadí | Pořadí v prezentaci

    Mřížka [Změny stavu] činnosti - Měny a kursy

    Mřížka [Změny stavu] činnosti - Měny a kursy
Název parametru | Název parametru předmětu projektu
Datum a čas zápisu | Datum a čas zápisu záznamu události
Stav | Stav projektu (uvažovaný, zahájený,...)
Zapsal | Jméno uživatele systému
IDÚ | Identifikace datového úložiště číselné řady procesu
Pořadí | Pořadové číslo změny v rámci předmětu

    Mřížka [Kategorie artiklu] činnosti - Měny a kursy

    Mřížka [Kategorie artiklu] činnosti - Měny a kursy
Kategorie | Identifikace kategorie události správy artiklu
Název kategorie | Název kategorie události správy artiklu
Platnost od | Datum platnosti od
Platnost do | Datum platnosti do
Adresát | Identifikace adresáta
Název adresáta | Název adresáta

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Inicializace předmětu projektu | Inicializace předmětu projektu
F6 | Strom hlavního procesu | Zobrazení hlavního stromu procesu-operace
F7 | Diagram procesu | Zobrazení diagramu procesu
F9 | Strom hodnot předmětu projektu | Strom hodnot předmětu projektu
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
- | Zrušit inicializaci předmětu | Zrušit inicializaci předmětu
- | Kopie popisu předmětu | Kopie popisu předmětu
- | Dokumenty artiklu | Dokumenty artiklu
- | Přehled hodnot parametrů | Přehled hodnot parametrů
- | Události správy artiklu |
- | Legenda palety barev |
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Kategorie událostí správy artiklu | Přehled kategorií událostí správy artiklu
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Palety barev kategorií | Palety barev kategorií
F2 | Parametry předmětů projektu | Seznam parametrů předmětů projektu
F2 | Prezentace parametrů | Prezentace parametrů
F2 | Skupiny | Seznam skupin
F2 | Spojení | Seznam spojení za adresáta.
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Umístění parametrů př.projektu | Umístění parametrů předmětu projektu

    Atributy tisku

    Základní údaje
Druh artiklu | Identifikace druhu artiklu | NKPREDPR_sp61id | C(3)
Předmět | Identifikace artiklu | NKPREDPR_sp60id | C(13)
Verze | Verze projektu | NKPREDPR_nk01verze | C(3)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Prac. název | Pracovní název projektu | NKPREDPR_nk01nazpra | C(50)
Prezentace | Identifikace prezentace parametrů | NKPREDPR_nk10id | C(6)
Název prezentace | Název prezentace parametrů | NKPRP_nk10nazprp | C(40)
Čárový kód | Čárový kód artiklu, který vznikne projektem | NKPREDPR_nk01ck | C(36)
Externí ID | Externí identifikace předmětu projektu | NKPREDPR_nk01exid | C(36)
Stav | Stav projektu (uvažovaný, zahájený,...) | Výpočet | C(12)
Adresát | Identifikace adresáta | NKPREDPR_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Umístění | Identifikace umístění | NKPREDPR_nk06id | C(6)
Název umístění | Název umístění parametru | NKPARDRU2_nk06nazdru | C(40)
Obch. sel. | Identifikátor obchodního selektoru | NKPREDPR_sp10idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | NKPREDPR_sp20idzak | C(9)
Popis | Uživatelský popis předmětu projektu | NKPREDPR_nk01popis | M
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | NKPREDPR_sp00datzap | T
Název parametru | Název parametru předmětu projektu | NKPAR_nk05nazpar | C(40)
Výraz zobrazení | Zobrazení hodnoty v mřížce a tisku | NKPAR_nk05zhodn | M
Popis | Popis hodnoty | NKCISHOD_nk09popis | C(40)
Název umístění | Název umístění parametru | NKPARDRU_nk06nazdru | C(40)
Název organizačního selektoru | Název organizačního selektoru | SPSEOR2_sp11text | C(60)
Zapsal | Jméno uživatele systému | BWUZIVA2_bw01jmeno | C(30)
Název kategorie | Název kategorie události správy artiklu | SAKATEG_sa05nazkat | C(40)
Uživatel | Jméno uživatele systému | BWUZIVASA_bw01jmeno | C(30)
Uživatel | Jméno uživatele systému | BWUZIVA4_bw01jmeno | C(30)

    Při pohybu v Hodnoty
Parametr | Identifikace parametru předmětu projektu | NKHODNP_nk05id | C(6)
Kategorie | Kategorie parametru | Výpočet | C(1)
Zobrazení hodnoty | Zobrazení hodnoty | Výpočet | C(90)
ID | Identifikace hodnoty | NKHODNP_nk09id | C(9)
Text 1 | Textová položka 1 číselníku | NKHODNP_nk13text1 | C(80)
Datum 1 | Datumová položka 1 číselníku | NKHODNP_nk13dat1 | D
Datum 2 | Datumová položka 2 číselníku | NKHODNP_nk13dat2 | D
Num 1 | Numerická položka 1 číselníku | NKHODNP_nk13num1 | N(20,4)
Měna | Kód měny - oceňovací jednotky. | NKHODNP_oc01id | C(3)
Num 2 | Numerická položka 2 číselníku | NKHODNP_nk13num2 | N(20,4)
Výpočet | Výpočet | NKHODNP_nk13vypoc | N(20,4)
Adresát | Identifikace adresáta | NKHODNP_ad01id | C(6)
Umístění | Identifikace umístění | NKHODNP_nk06id | C(6)
Obch. sel. | Identifikátor obchodního selektoru | NKHODNP_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | NKHODNP_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | NKHODNP_sp20idzak | C(9)
Poznámka | Poznámka | NKHODNP_nk13koment | M
Rok | Rok v identifikaci procesu | NKHODNP_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | NKHODNP_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | NKHODNP_sp33cisd | C(8)
Druh operace | Identifikátor druhu operace | NKHODNP_sp07idtyp | C(6)
Komponenta | Identifikace komponenty | NKHODNP_sp06idsubs | C(3)
Pořadí | Pořadí stejného druhu operace v jednom procesu | NKHODNP_sp33porad | N(2)
Datum a čas zápisu | Datum a čas zápisu záznamu události | NKHODNP_sp00datzap | T

    Při pohybu v Změny stavu
Změna stavu předmětu projektu | Stav projektu (uvažovaný, zahájený,...) | Výpočet | C(12)
Datum a čas zápisu | Datum a čas zápisu záznamu události | NKPREDZS_sp00datzap | T
Poznámka | Poznámka | NKPREDZS_nk71koment | M

    Při pohybu v Kategorie artiklu
Kategorie | Identifikace kategorie události správy artiklu | SAUDAL_sa05id | C(6)
Adresát | Identifikace adresáta | SAUDAL_ad01id | C(6)
Číslo spojení adresáta | Číslo spojení adresáta. | SAUDAL_ad11cisspo | C(2)
Datum | Datum události | SAUDAL_sa02dat | D
Platnost od | Datum platnosti od | SAUDAL_sa02platod | D
Platnost do | Datum platnosti do | SAUDAL_sa02platdo | D
Popis | Popis události | SAUDAL_sa02text | C(40)
Poznámka | Poznámka | SAUDAL_sa02koment | M
Datum a čas zápisu | Datum a čas zápisu záznamu události | SAUDAL_sp00datzap | T

    Viz.také

    Inicializace předmětu projektu | Strom hlavního procesu | Diagram procesu | Strom hodnot předmětu projektu | OZNAČOVÁNÍ | Prezentace artiklu | Zrušit inicializaci předmětu | Kopie popisu předmětu | Dokumenty artiklu | Přehled hodnot parametrů | Události správy artiklu | Legenda palety barev | Adresář | Druhy artiklů | Kategorie událostí správy artiklu | Měny a kursy | Obchodní selektor | Organizační selektor | Palety barev kategorií | Parametry předmětů projektu | Prezentace parametrů | Skupiny | Spojení | Spojení adresátů | Technicko-věcný selektor | Umístění parametrů př.projektu


Hodnoty předmětu projektu

Popis

Události činnosti "Hodnoty předmětu projektu" slouží k zaznamenávání hodnot parametrů předmětu projektu (PP). Tyto události mohou vznikat při inicializaci PP nebo obvyklým způsobem v procesech IS BM. Struktura zobrazovaných informací je dána popisem odpovídajícího parametru PP. Hodnoty PP si uživatel může vyvolat i přímo z činnosti Předmět projektu. Na tučném atributu Předmět po stisku pravého tlačítka myši zvolit Události artiklu – Hodnoty předmětu projektu.

Datový model

  • NKHODNP Hodnota parametru předmětu projektu
    • SPPRISTU Přístupové právo uživatele k věci
    • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)
    • BWUZIVAT Uživatel systému
    • ADSPOJ Spojení adresáta
      • ADADSAT Adresát
    • NKPARDRU Umístění parametru předmětu projektu
    • NKPREDPR Předmět projektu
      • SPARTIKN Název artiklu
    • NKPAR Parametr předmětu projektu
    • SPPRCOD Operace procesu
      • SPTYP Druh procesu/operace
      • SPPRC Proces
    • NKCISHOD Hodnota číselníku hodnot parametru předmětu projektu
    • SPSEOR Organizační selektor
    • SPSETV Technicko-věcný selektor

    • Formulář

    Formulář činnosti - Měny a kursy
Mřížka [Hodnoty předmětu projektu]
Listovací rámeček
Stránka #1 Hodnoty předmětu projektu
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
 | Identifikátor druhu operace
 | Název druhu operace
Parametr | Identifikace parametru předmětu projektu
Název parametru | Název parametru předmětu projektu
Kategorie | Kategorie parametru
Druh artiklu | Identifikace druhu artiklu
Př. | Identifikace artiklu
Verze | Verze projektu
Název artiklu | Název artiklu
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
Umístění | Identifikace umístění
 | Název umístění parametru
Stav | Stav hodnoty parametru Aktuální/Neaktuální
ID | Identifikace hodnoty
Datum 1 | Datumová položka 1 číselníku
Datum 2 | Datumová položka 2 číselníku
Text 1 | Textová položka 1 číselníku
Num 1 | Numerická položka 1 číselníku
Num 2 | Numerická položka 2 číselníku
Výpočet | Výpočet
Měna | Kód měny - oceňovací jednotky.
Poznámka | Poznámka
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Výběr
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
 | Pořadové číslo procesu do
Druh operace | Identifikátor druhu operace
Druh procesu | Identifikátor druhu procesu
Datum 1 | Datumová položka 1 číselníku
do | Datumová položka 1 číselníku do
Text 1 | Textová položka 1 číselníku
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Druh artiklu | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
 | Název artiklu
Umístění | Identifikace umístění
Parametr | Identifikace parametru předmětu projektu
ID | Identifikace hodnoty
Kategorie | Kategorie parametru
Stav | Stav hodnoty parametru Aktuální/Neaktuální
Selektory | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Zapsané | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Hodnoty předmětu projektu] činnosti - Měny a kursy

    Mřížka [Hodnoty předmětu projektu] činnosti - Měny a kursy
Označování | Označení záznamu
Datum 1 | Datumová položka 1 číselníku
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Verze | Verze projektu
Název parametru | Název parametru předmětu projektu
Zobrazení hodnoty | Zobrazení hodnoty
Parametr | Identifikace parametru předmětu projektu
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Umístění | Identifikace umístění
Název umístění | Název umístění parametru
Text 1 | Textová položka 1 číselníku
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Název předmětu projektu | Název artiklu
Stav | Stav hodnoty parametru Aktuální/Neaktuální

    Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
- | Změna stavu hodnoty PP |
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Parametry předmětů projektu | Seznam parametrů předmětů projektu
F2 | Předmět projektu | Seznam předmětů projektu
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Umístění parametrů př.projektu | Umístění parametrů předmětu projektu

    Atributy tisku

    Základní údaje
Rok | Rok v identifikaci procesu | NKHODNP_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | NKHODNP_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | NKHODNP_sp33cisd | C(8)
Komponenta | Identifikace komponenty | NKHODNP_sp06idsubs | C(3)
Pořadí | Pořadí stejného druhu operace v jednom procesu | NKHODNP_sp33porad | N(2)
Druh operace | Identifikátor druhu operace | NKHODNP_sp07idtyp | C(6)
Adresát | Identifikace adresáta | NKHODNP_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Artikl | Identifikace artiklu | NKHODNP_sp60id | C(13)
Druh artiklu | Identifikace druhu artiklu | NKHODNP_sp61id | C(3)
Verze | Verze projektu | NKHODNP_nk01verze | C(3)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Umístění | Identifikace umístění | NKHODNP_nk06id | C(6)
Název umístění | Název umístění parametru | NKPARDRU_nk06nazdru | C(40)
ID | Identifikace hodnoty | NKHODNP_nk09id | C(9)
Popis | Popis hodnoty | NKCISHOD_nk09popis | C(40)
Parametr | Identifikace parametru předmětu projektu | NKHODNP_nk05id | C(6)
Název parametru | Název parametru předmětu projektu | NKPAR_nk05nazpar | C(40)
Kategorie | Kategorie parametru | Výpočet | C(1)
Stav | Stav hodnoty parametru Aktuální/Neaktuální | Výpočet | C(10)
Výraz zobrazení | Zobrazení hodnoty v mřížce a tisku | NKPAR_nk05zhodn | M
Zobrazení hodnoty | Zobrazení hodnoty | Výpočet | C(90)
Datum 1 | Datumová položka 1 číselníku | NKHODNP_nk13dat1 | D
Datum 2 | Datumová položka 2 číselníku | NKHODNP_nk13dat2 | D
Num 1 | Numerická položka 1 číselníku | NKHODNP_nk13num1 | N(20,4)
Měna | Kód měny - oceňovací jednotky. | NKHODNP_oc01id | C(3)
Num 2 | Numerická položka 2 číselníku | NKHODNP_nk13num2 | N(20,4)
Text 1 | Textová položka 1 číselníku | NKHODNP_nk13text1 | C(80)
Výpočet | Výpočet | NKHODNP_nk13vypoc | N(20,4)
Obch. sel. | Identifikátor obchodního selektoru | NKHODNP_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | NKHODNP_sp11idzak | C(9)
Název organizačního selektoru | Název organizačního selektoru | SPSEOR_sp11text | C(60)
Tech. sel. | Identifikátor technicko-věcného selektoru. | NKHODNP_sp20idzak | C(9)
Poznámka | Poznámka | NKHODNP_nk13koment | M
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | NKHODNP_sp00datzap | T

    Viz.také

    OZNAČOVÁNÍ | Prezentace artiklu | Změna stavu hodnoty PP | Adresář | Druhy artiklů | Druhy operací | Druhy procesů | Měny a kursy | Obchodní selektor | Organizační selektor | Parametry předmětů projektu | Předmět projektu | Spojení adresátů | Technicko-věcný selektor | Umístění parametrů př.projektu


Aktuální hodnoty hodnot PP

Popis

Podle nadefinované záložky „výběr“ je zobrazen přehled aktuálních hodnot komponenty hodnoty předmětu projektu.

Datový model

  • NKAH Aktuální hodnota PP
    • ADADSAT Adresát
    • NKPARDRU Umístění parametru předmětu projektu
    • SPARTIKL Artikl
      • SPARTIKN Název artiklu
    • SPSTATDI Druh hodnoty
    • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Organizační selektor
Mřížka [Aktuální hodnoty]
Listovací rámeček
Stránka #1 Aktuální hodnoty
Druh hodnoty | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Adresát | Identifikace adresáta
 | Název adresáta
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Umístění | Identifikace umístění
Název umístění | Název umístění parametru
Hodnota | Aktuální hodnota
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
Stránka #2 Výběr
Druh hodnoty | Identifikace druhu hodnoty
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Umístění | Identifikace umístění
Název umístění | Název umístění parametru
Selektory | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Aktuální hodnoty] činnosti - Organizační selektor

    Mřížka [Aktuální hodnoty] činnosti - Organizační selektor
Druh hodnoty | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Adresát | Identifikace adresáta
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Umístění | Identifikace umístění
Hodnota | Aktuální hodnota
 | Název adresáta
Název artiklu | Název artiklu
Název umístění | Název umístění parametru
Org. sel. | Identifikátor organizačního selektoru.
Obch. sel. | Identifikátor obchodního selektoru

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Předmět projektu | Seznam předmětů projektu
F2 | Umístění parametrů př.projektu | Umístění parametrů předmětu projektu

    Atributy tisku

    Základní údaje
Druh hodnoty | Identifikace druhu hodnoty | NKAH_sp67id | C(3)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)
Adresát | Identifikace adresáta | NKAH_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Druh artiklu | Identifikace druhu artiklu | NKAH_sp61id | C(3)
Artikl | Identifikace artiklu | NKAH_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKL_sp60artikl | C(60)
Umístění | Identifikace umístění | NKAH_nk06id | C(6)
Název umístění | Název umístění parametru | NKPARDRU_nk06nazdru | C(40)
Hodnota | Aktuální hodnota | NKAH_nk19hodnot | N(20,4)

    Viz.také

    Adresář | Druhy artiklů | Druhy hodnot | Kategorie adresátů | Obchodní selektor | Organizační selektor | Předmět projektu | Umístění parametrů př.projektu


NASTAVENÍ PŘEDMĚTU PROJEKTU

Popis

V IS BM lze cíl projektu popsat několika způsoby. Mezi nejstručnější bude zcela jistě patřit popis volným textem. Pokud se k projektu vztahuje řada dokumentů, může být vhodné předmět projektu popsat připojením těchto dokumentů objektovou vazbou. Parametry a jejich struktura jsou uživatelsky definovatelné, což umožní popsat jakýkoliv projekt. Aplikace parametrů umožňuje pohodlně vybírat projekty, ve kterých je daný parametr evidován nebo ve kterých nabývá určité hodnoty.

Nastavení parametrů obvykle probíhá automatizovaně „děděním“ v určité míře (dvojče, bratr, bratranec) od jiného věcně blízkého projektu při inicializaci předmětu projektu, kdy je založen i odpovídající proces, ve kterém obvykle navazuje plánování úkolů (čas a kapacity), ale také další operace (například, sklad, mzdy, fakturace, nákup, expedice, výrobní zakázka, …) dle firemních procesů.

Kromě detailního popisu předmětu projektu je další součástí jeho definice identifikace včetně verze, externí a pracovní identifikace, čárový kód, vedoucí projektu, alokace řídící přístupová práva, prezentace definující způsob zobrazení parametrů, obchodní a technicko věcný selektor umožňující referovat projekt z ostatních aktivit. Dále je zde k dispozici stav projektu (např. uvažovaný, schválený, zamítnutý, odložený, připravený, zahájený, před dokončením, předaný, hotový, …), který je automaticky aktualizován dle plnění projektu či dle rozhodnutí kompetentních osob.

Viz.také

Parametry předmětů projektu | Prezentace parametrů | Umístění parametrů př.projektu | Číselník hodnot parametrů | Přehled hodnot číselníků | Skupiny | Parametry projektového řízení | Reset parametrů předmětu


Parametry předmětů projektu

Popis

Parametry předmětů projektů definují volně definovatelné vlastnosti předmětu projektu (PP). Proto, aby se určitý parametr uplatnil pro konkrétní PP musí být přímo nebo nepřímo zařazen do u něho uvedené prezentace. U každého parametru se definuje:

¨ parametr – identifikace a název

¨ umístění – identifikace a název umístění parametru. Přístup k parametru je potom definován oprávněním spojenými s jeho umístěním.

¨ číselník – identifikace a název číselníku spojeného s daným parametrem

¨ typ – může nabývat hodnot „skupina“ nebo „hodnota“. Pokud je parametr typu „Skupina“, je zde v podstatě pouze jeho nadpis, jednotlivé parametry Skupiny je nutno zadat na záložce „podřízené parametry“.

¨ naplnění – jakým způsobem vznikne v systému záznam o daném parametru. Může být naplněn pomocí inicializace nebo vznikem procesu.

¨ barva – definuje jakou barvou se parametr zobrazuje

¨ zobrazovat – znamená, kdy má být daný parametr k dispozici. Možnosti jsou vždy, v editaci, v tisku a nikdy. Lze nastavit pouze pro typ parametru Skupina.

¨ kategorie – překryvný seznam s volně definovanými výběrovými hodnotami (implicitně předplněno 1,2,3,4 ..., cizojazyčností lze vytvořit vlastní překryvný seznam). Podle kategorie je pak možno případně i omezit výběr parametrů na záložce Výběr.

¨ příb. výskyt – příbuznost pro dědění výskytu parametru při inicializaci nepovinného parametru neboli jakým způsobem se má dědit hodnota. Možnosti jsou dvojče (klon), bratr, bratranec. Nejvíce dědí dvojče (klon), nejméně bratranec.

¨ příb. hodnota – příbuznost pro dědění hodnoty parametru při inicializaci. Stejné možnosti a chování jako u předchozího atributu.

¨ dědit pozn. – možnosti jsou Ano/Ne. Zda se má v případě nastavení dědit s hodnotu parametru i poznámka.

¨ EID? – povinná externí identifikace předmětu při vzniku události s tímto parametrem, možnosti jsou Ano/Ne. Pokud bude nastaveno Ano, tak na předmětu projektu musí být uveden atribut EI, jinak se parametr nepodaří zapsat.

¨ ČK? – povinný čárový kód předmětu při vzniku události s tímto parametrem, možnosti jsou Ano/Ne. Pokud bude nastaveno Ano, tak na předmětu projektu musí být uveden atribut ČK, jinak se parametr nepodaří zapsat.

¨ výraz z. – definuje výraz, podle kterého budou zobrazovány hodnoty přiděleného parametru k PP v mřížce na záložce "hodnoty" ve formuláři "Předměty projektu" a v tiskových sestavách. Ve výrazu je možné použít tyto prvky:

- ##nk13dat1## - 1.atribut typu datum

- ##nk13dat2## - 2.atribut typu datum

- ##nk13num1## - 1.atribut typu číslo

- ##nk13num2## - 2.atribut typu číslo

- ##nk13text1## - textový atribut

- ##nk09popis## - hodnota číselníku

- ##ad01id## - identifikace adresáta

- ##ad01adsat## - název adresáta

- ##sp10idzak## - obchodní selektor

- ##sp11idzak## - organizační selektor

- ##sp20idzak## - technicko-věcný selektor

- ##nk13vypoc## - vypočtený atribut

¨ povinný – možnosti jsou Ano/Ne/Ano bez hodnoty. Je-li nastaveno Ano, bude se tento parametr automaticky zahrnovat do dané inicializace a zejména pokud se bude provádět reinicializace, tak se přiřadí automaticky všem PP. O nepovinných parametrech může uživatel při inicializaci PP rozhodnout, zda mají být k danému PP připojeny. Při inicializaci je také možné určit odvození parametrů podle jiného dříve inicializovaného PP. Pro nepovinné parametry mají potom význam nastavení vlastností "příbuznost výskytu" a "příbuznost hodnoty", které shodně nabývají hodnot "klon" nebo "bratr" nebo "bratranec". Při inicializaci PP se určuje v jakém vztahu je nově inicializovaný PP k PP, podle kterého má být odvozen. Podle tohoto zadaného vztahu dědí nově inicializovaný PP výskyt nepovinného parametru, případně jeho hodnotu, pokud je jeho příbuznost vyšší nebo rovna příbuznosti uvedené v odpovídající vlastnosti parametru.

¨ podmínka - definuje výraz, který rozhodne o přidělení parametru k PP na základě vstoupených hodnot při inicializaci (jejich struktura se definuje v prezentaci PP). Uvádí se při možnosti povinný parametr Ano.

¨ přímý vstup – přímé vkládání parametru z předmětu projektu – možnosti Ano/Ne. Jinými slovy definuje možnost, zda je tento parametr přímo editovatelný po stisku F3 na hodnotách PP.

¨ četnost – četnost výskytu při přímém vkládání z předmětu projektu. Možnosti jsou:

- 0 : 1 – nemusí být ani jeden nebo maximálně jeden

- 1 : 1 – musí být právě jeden

- 0 : M – nemusí být ani jeden nebo libovolné množství

- 1 : M – nejméně jeden

¨ závislý – parametr je závislý na verzi (poslední číslo u identifikace PP), možnosti jsou Ano/Ne. Pokud bude uvedena možnost Ne, znamená to, že tento parametr platí automaticky pro všechny verze.

Každý parametr PP může být složen z několika elementárních hodnot. Jejich složení se zadává na záložce Definice struktury. Uvedení elementární hodnoty parametru PP má vliv na její zobrazení ve formulářích "Předměty projektu" a "Hodnoty předmětu projektu". Každý parametr může mít tímto způsobem definovány až dvě datumové, dvě numerické, jednu textovou, jednu výpočtovou a jednu číselníkovou elementární hodnotu. Kromě toho může obsahovat elementární hodnoty identifikace adresáta, obchodní selektor, organizační selektor, technicko-věcný selektor, umístění parametru PP a identifikaci měny. Pro elementární hodnotu typu číselník platí, že její obsah může být definován shodný pro různé parametry výběrem číselníku na první záložce formuláře.

Pro každou elementární hodnotu lze definovat:

¨ hodnota – vlastní výběr definované hodnoty z překryvného seznamu

¨ umístění – výběr z číselníku umístění parametrů PP (ke každému umístění lze nadefinovat příst. práva). Nadefinovaná přístupová práva k jednotlivým elementárním hodnotám ovlivňují dostupnost (resp. zobrazování) těchto hodnot v činnosti předmět projektu – záložka Hodnoty a ve vlastní činnosti Hodnoty předmětů projektu (hodnoty, které mají uvedeno přístupové právo zápis se pro uživatele jeví dostupné – bílé, hodnoty, které mají uvedeno umístění, ke kterému nemá uživatel přístupové právo jsou pro uživatele šedivé, tzn. nedostupné k editaci).

¨ návěští

¨ stavový řádek

¨ inicializace podle hodnot vstoupených podle prezentace PP

¨ validace - logický výraz vyhodnocovaný při opravě el.hodnoty (přitom ### odpovídají dané el.hodnotě) a za středníkem může být text chybového hlášení (např. ###>0;číslo musí být větší než 0)

¨ délka - počet znaků

¨ desetiny - počet desetin numerické hodnoty

¨ změny – možnost, zda sledovat změny hodnot parametru. Volba Ano/Ne. Pokud bude zvoleno Ano, jsou změny dostupné na záložce Změna stavu v činnosti Předmět projektu.

Vlastnost "inicializace" má odlišný význam pro výpočtovou elementární hodnotu parametru, pro kterou v ní musí být uveden výraz SQL dotazu. V tomto dotazu je vhodné odkázat se na odpovídající PP proměnnými @sp60id,@sp61id a @nk01verze.

Např.: (select
sum(NKHODNPX.nk13num1) from bm_servis.NKHODNP NKHODNPX where
NKHODNPX.sp60id=@sp60id and NKHODNPX.sp61id=@sp61id and
NKHODNPX.nk05id='MSV000')

Na záložce „podřízené parametry“ je k dispozici přehled parametrů, které jsou do daného parametru vnořeny. Při vkládání jim systém automaticky přiřazuje pořadí, to je však možné kdykoliv uživatelsky změnit a nastavit si tak pořadí parametrů podle svých potřeb.

Datový model

  • NKPAR Parametr předmětu projektu
    • BWUZIVAT Uživatel systému
    • NKPARDRU Umístění parametru předmětu projektu
    • NKCIS Číselník hodnot parametru předmětu projektu

    • Formulář

    Formulář činnosti - Číselník hodnot parametrů
Mřížka [Parametry předmětů projektu]
Parametr | Identifikace parametru předmětu projektu
Název parametru | Název parametru předmětu projektu
Listovací rámeček
Stránka #1 Parametry předmětů projektu
Umístění | Identifikace umístění
Název umístění | Název umístění parametru
Číselník | Identifikace číselníku
Název číselníku | Název číselníku
Typ | Typ parametru předmětu projektu Skupina/Hodnota
Naplnění | Způsob naplnění hodnoty
Barva | Barva parametru
Zobrazovat | Zobrazovaný parametr
Kategorie | Kategorie parametru
Příb.výskyt | Příbuznost pro dědění výskytu parametru při inicializaci nepovinného parametru
EID ? | Povinná externí identifikace předmětu při vzniku události s tímto parametrem
Příb.hodnota | Příbuznost pro dědění hodnoty parametru při inicializaci
ČK ? | Povinný čárový kód předmětu při vzniku události s tímto parametrem
Dědit pozn. | Při dědění hodnoty parametru dědit také poznámku
Výraz z. | Zobrazení hodnoty v mřížce a tisku
Povinný | Povinný parametr
Podmínka | Podmínka zařazení parametru
Přímý vstup | Přímé vkládání parametru z předmětu projektu
Četnost | Četnost výskytu při přímém vkládání z předmětu projektu
Závislý | Parametr je závislý na verzi předmětu projektu
Poznámka | Poznámka k parametru předmětu projektu
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Definice struktury
Mřížka [Definice struktury]
Hodnota | Elementární hodnota
Umístění | Identifikace umístění
Název umístění | Název umístění parametru
Návěští | Návěští elementární hodnoty
Stavový řádek | Stavový řádek elementární hodnoty
Inicializace | Inicializace elementární hodnoty
Validace | Validace elementární hodnoty
Délka | Délka numerické elementární hodnoty
Desetiny | Desetiny numerické elementární hodnoty
Změny | Sledovat změny hodnot parametru
Stránka #3 Číselník
Mřížka [Číselník]
ID | Identifikace hodnoty
Popis | Popis hodnoty
Poznámka | Poznámka k popisu hodnoty
Stránka #4 Podřízené parametry
Mřížka [Podřízené parametry]
Podřízený | Identifikace podřízeného parametru předmětu projektu
Název parametru | Název parametru předmětu projektu
Pořadí | Pořadí mezi podřízenými parametry
Stránka #5 Výběr
Parametr | Identifikace parametru předmětu projektu
Název parametru | Název parametru předmětu projektu
Umístění | Identifikace umístění
Kategorie | Kategorie parametru
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Parametry předmětů projektu] činnosti - Číselník hodnot parametrů

    Mřížka [Parametry předmětů projektu] činnosti - Číselník hodnot parametrů
Parametr | Identifikace parametru předmětu projektu
Název parametru | Název parametru předmětu projektu
Umístění | Identifikace umístění
Název umístění | Název umístění parametru
Založil | Jméno uživatele systému
Datum a čas zápisu | Datum a čas zápisu záznamu události

    Mřížka [Definice struktury] činnosti - Číselník hodnot parametrů

    Mřížka [Definice struktury] činnosti - Číselník hodnot parametrů
Hodnota | Elementární hodnota
Návěští | Návěští elementární hodnoty

    Mřížka [Číselník] činnosti - Číselník hodnot parametrů

    Mřížka [Číselník] činnosti - Číselník hodnot parametrů
ID | Identifikace hodnoty
Popis | Popis hodnoty

    Mřížka [Podřízené parametry] činnosti - Číselník hodnot parametrů

    Mřížka [Podřízené parametry] činnosti - Číselník hodnot parametrů
Pořadí | Pořadí mezi podřízenými parametry
Podřízený | Identifikace podřízeného parametru předmětu projektu
Název parametru | Název parametru předmětu projektu
Umístění | Identifikace umístění
Název umístění | Název umístění parametru
Založil | Jméno uživatele systému
Datum a čas zápisu | Datum a čas zápisu záznamu události
Typ | Typ parametru předmětu projektu Skupina/Hodnota
Barva | Barva parametru

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Parametry předmětů projektu | Seznam parametrů předmětů projektu
F2 | Umístění parametrů př.projektu | Umístění parametrů předmětu projektu
F2 | Číselník hodnot parametrů | Číselník hodnot parametrů předmětu projektu

    Atributy tisku

    Základní údaje
Parametr | Identifikace parametru předmětu projektu | NKPAR_nk05id | C(6)
Název parametru | Název parametru předmětu projektu | NKPAR_nk05nazpar | C(40)
Umístění | Identifikace umístění | NKPAR_nk06id | C(6)
Název umístění | Název umístění parametru | NKPARDRU_nk06nazdru | C(40)
Číselník | Identifikace číselníku | NKPAR_nk35id | C(6)
Název číselníku | Název číselníku | NKCIS_nk35nazcis | C(40)
Kategorie | Kategorie parametru | Výpočet | C(1)
Typ | Typ parametru předmětu projektu Skupina/Hodnota | Výpočet | C(7)
Barva | Barva parametru | Výpočet | C(8)
Zobrazovat | Zobrazovaný parametr | Výpočet | C(9)
Naplnění | Způsob naplnění hodnoty | Výpočet | C(12)
Kontrola EID | Povinná externí identifikace předmětu při vzniku události s tímto parametrem | Výpočet | C(3)
Kontrola ČK | Povinný čárový kód předmětu při vzniku události s tímto parametrem | Výpočet | C(3)
Výraz zobrazení | Zobrazení hodnoty v mřížce a tisku | NKPAR_nk05zhodn | M
Povinný | Povinný parametr | Výpočet | C(3)
Podmínka | Podmínka zařazení parametru | NKPAR_nk05podm | M
Příb.výskyt | Příbuznost pro dědění výskytu parametru při inicializaci nepovinného parametru | Výpočet | C(9)
Dědit hodnotu | Příbuznost pro dědění hodnoty parametru při inicializaci | Výpočet | C(9)
Dědit pozn. | Při dědění hodnoty parametru dědit také poznámku | Výpočet | C(3)
Přímý vstup | Přímé vkládání parametru z předmětu projektu | Výpočet | C(3)
Četnost | Četnost výskytu při přímém vkládání z předmětu projektu | Výpočet | C(3)
Závislý | Parametr je závislý na verzi předmětu projektu | Výpočet | C(3)
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | NKPAR_sp00datzap | T
Poznámka | Poznámka k parametru předmětu projektu | NKPAR_nk05koment | M
Název parametru | Název parametru předmětu projektu | NKPAR2_nk05nazpar | C(40)
Umístění | Identifikace umístění | NKPAR2_nk06id | C(6)
Název umístění | Název umístění parametru | NKPARDRU2_nk06nazdru | C(40)
Typ | Typ parametru předmětu projektu Skupina/Hodnota | Výpočet | C(7)
Název umístění | Název umístění parametru | NKPARDRU3_nk06nazdru | C(40)

    Při pohybu v Hodnoty číselníku
ID | Identifikace hodnoty | NKCISHOD_nk09id | C(9)
Popis | Popis hodnoty | NKCISHOD_nk09popis | C(40)
Poznámka | Poznámka k popisu hodnoty | NKCISHOD_nk09koment | M

    Při pohybu v Definice struktury
Hodnota | Elementární hodnota | NKPARDEF_nk15id | C(10)
Umístění | Identifikace umístění | NKPARDEF_nk06id | C(6)
Návěští | Návěští elementární hodnoty | NKPARDEF_nk15label | M
Stavový řádek | Stavový řádek elementární hodnoty | NKPARDEF_nk15status | M
Inicializace | Inicializace elementární hodnoty | NKPARDEF_nk15init | M
Validace | Validace elementární hodnoty | NKPARDEF_nk15valid | M
Délka | Délka numerické elementární hodnoty | NKPARDEF_nk15len | N(2)
Desetiny | Desetiny numerické elementární hodnoty | NKPARDEF_nk15dec | N(1)
Změny | Sledovat změny hodnot parametru | Výpočet | C(3)

    Při pohybu v Podřízené parametry
Podřízený | Identifikace podřízeného parametru předmětu projektu | NKPARPAR_nk05id2 | C(6)
Pořadí | Pořadí mezi podřízenými parametry | NKPARPAR_nk07poradi | N(4)

    Viz.také

    Umístění parametrů př.projektu | Číselník hodnot parametrů


Prezentace parametrů

Popis

Prezentace parametrů definuje, které parametry mohou být připojeny k předmětu projektu (PP) a v jakém pořadí mají být prezentovány. Každá neprázdná prezentace je složena z jednoho nebo více skupinových parametrů PP. Definuje se:

¨ prezentace – identifikace a název prezentace

¨ D. procesu - důležité pro inicializaci PP je určení procesu, který při ní vznikne. Tento proces musí být zahajován operací komponenty "hodnoty předmětu projektu", která je při první inicializaci na pozadí automaticky zahájena, jsou do ní zapsány události s parametry PP a operace je ukončena. Po stisku klávesy F6 nebo volbě činnosti „strom prezentace předmětu“ má uživatel k dispozici strom daného procesu.

¨ implicitní – volba Ano/Ne. Pokud je nastaveno ANO, tak se daná prezentace implicitně předplňuje při zadávání nového PP.

¨ script – programový kód v jazyce FoxPro. V kódu je možno využít i knihovny vkládaného kódu. Potom se do scriptu píše příkaz ve znění

#include frag28 (přičemž FRAG28 je název knihovny vkl. kódu)

Po sestavení prezentace parametrů je třeba udělat "Naplnění prezentace hodnot – klávesa F5" z menu "Volby" formuláře. Tuto funkci uživatel aktivuje i v případě, že v prezentaci parametrů provede nějakou změnu (přidá parametr, změní pořadí apod.).

Další funkce z menu tohoto formuláře je "Reinicializace předmětů projektu – klávesa F7", dovoluje přidat do prezentace další parametry a tímto způsobem je doplnit k dříve inicializovaným PP (jinými slovy umožňuje zařadit další parametry do již vytvořené a používané prezentace a tím je přiřadit k příslušným předmětům projektu).

Na záložce „Skupinové parametry“ se ke každé prezentaci definují skupinové parametry, tzn. že jednotlivé nadefinované parametry PP se soustředí do zvolených skupin. Podle pořadí nadefinovaných skup. parametrů se potom jednotlivé parametry zobrazují u PP na záložce „Hodnoty“.

Na záložce "Popis hodnot inicializace" je možné definovat hodnoty vstupované při inicializaci PP. Odkazy na tyto hodnoty je možné použít ve výrazech definice parametru PP podmínka zařazení parametru při inicializaci PP a ve výrazu inicializace elementární hodnoty parametru. Jinými slovy, tyto hodnoty bude uživatel vstupovat v okamžiku, kdy aktivuje činnost Inicializace PP. Tímto způsobem je možné definovat:

¨ 3 numerické hodnoty @N1, @N2, @N3

¨ 3 textové hodnoty @T1, @T2, @T3

¨ 3 datumové hodnoty @D1, @D2, @D3

¨ 3 hodnoty pro překryvný seznam @C1, @C2, @C3

Pro hodnoty pro překryvný seznam se ve vlastnosti překryvný seznam definuje seznam hodnot oddělených čárkou. Ve výrazech uvedených u parametrů PP vystupují hodnoty inicializace uvedené včetně zavináče např. @D1 nebo @C1=1.

Datový model

  • NKPRP Prezentace parametrů
    • SPTYP Druh procesu/operace

    • Formulář

    Formulář činnosti - Knihovny vkládaného kódu
Mřížka [Prezentace parametrů]
Prezentace | Identifikace prezentace parametrů
Název prezentace | Název prezentace parametrů
Listovací rámeček
Stránka #1 Prezentace parametrů
D. procesu | Identifikátor druhu procesu
 | Název druhu procesu
Implicitní | Implicitní prezentace - při vstupu nového předmětu projektu
Script | Script používaný v souvislosti s předmětem projektu
Poznámka | Poznámka k prezentaci parametrů
Stránka #2 Skupinové parametry
Mřížka [Skupinové parametry]
Parametr | Identifikace parametru předmětu projektu
Název parametru | Název parametru předmětu projektu
Skupina | Identifikace skupiny
Název skupiny | Název skupiny
Pořadí | Pořadí skupinového parametru předmětu projektu
Stránka #3 Popis hodnoty inicializace
Mřížka [Popis hodnoty inicializace]
ID | Identifikátor hodnoty inicializace
Návěští | Návěští hodnoty inicializace
Stavový řádek | Stavový řádek hodnoty inicializace
Validace | Validace hodnoty inicializace
Seznam | Překryvný seznam hodnoty inicializace
Délka | Délka hodnoty
Desetiny | Desetiny numerické hodnoty
Dědit | Dědit hodnotu inicializace

    Mřížka [Prezentace parametrů] činnosti - Knihovny vkládaného kódu

    Mřížka [Prezentace parametrů] činnosti - Knihovny vkládaného kódu
Prezentace | Identifikace prezentace parametrů
Název prezentace | Název prezentace parametrů

    Mřížka [Skupinové parametry] činnosti - Knihovny vkládaného kódu

    Mřížka [Skupinové parametry] činnosti - Knihovny vkládaného kódu
Pořadí | Pořadí skupinového parametru předmětu projektu
Parametr | Identifikace parametru předmětu projektu
Název parametru | Název parametru předmětu projektu
Typ | Typ parametru předmětu projektu Skupina/Hodnota
Skupina | Identifikace skupiny
Barva | Barva parametru

    Mřížka [Popis hodnoty inicializace] činnosti - Knihovny vkládaného kódu

    Mřížka [Popis hodnoty inicializace] činnosti - Knihovny vkládaného kódu
ID | Identifikátor hodnoty inicializace
Návěští | Návěští hodnoty inicializace

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Naplnění prezentace hodnot | Naplnění prezentace hodnot
F6 | Strom prezentace předmětu | Strom prezentace předmětu
F7 | Reinicializace předmětů projek | Reinicializace předmětů projektu - doplnění hodnot parametrů
F9 | Editovat kód vlastnosti | Editovat kód vlastnosti
- | Kontrolní kompilace | Kontrolní kompilace
- | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností
F2 | Druhy procesů | Přehled druhů procesů
F2 | Parametry předmětů projektu | Seznam parametrů předmětů projektu
F2 | Skupiny | Seznam skupin

    Atributy tisku

    Základní údaje
Prezentace | Identifikace prezentace parametrů | NKPRP_nk10id | C(6)
Název prezentace | Název prezentace parametrů | NKPRP_nk10nazprp | C(40)
Druh procesu | Identifikátor druhu procesu | NKPRP_sp07idtyp | C(6)
Název druhu procesu | Název druhu procesu | SPTYP_sp07text | C(30)
Implicitní | Implicitní prezentace - při vstupu nového předmětu projektu | Výpočet | C(3)
Script | Script používaný v souvislosti s předmětem projektu | NKPRP_nk10script | M
Poznámka | Poznámka k prezentaci parametrů | NKPRP_nk10koment | M
Název parametru | Název parametru předmětu projektu | NKPAR_nk05nazpar | C(40)

    Při pohybu v Skupinové parametry
Parametr | Identifikace parametru předmětu projektu | NKPRPPAR_nk05id | C(6)
Pořadí | Pořadí skupinového parametru předmětu projektu | NKPRPPAR_nk08poradi | N(4)

    Při pohybu v Popis hodnot inicializace
ID | Identifikátor hodnoty inicializace | NKPRPPOP_nk23id | C(4)
Návěští | Návěští hodnoty inicializace | NKPRPPOP_nk23label | M
Stavový řádek | Stavový řádek hodnoty inicializace | NKPRPPOP_nk23status | M
Validace | Validace hodnoty inicializace | NKPRPPOP_nk23valid | M
Seznam | Překryvný seznam hodnoty inicializace | NKPRPPOP_nk23combo | M
Délka | Délka hodnoty | NKPRPPOP_nk23len | N(2)
Desetiny | Desetiny numerické hodnoty | NKPRPPOP_nk23dec | N(1)
Dědit | Dědit hodnotu inicializace | Výpočet | C(3)

    Viz.také

    Naplnění prezentace hodnot | Strom prezentace předmětu | Reinicializace předmětů projek | Editovat kód vlastnosti | Kontrolní kompilace | Knihovny vkládaného kódu | Druhy procesů | Parametry předmětů projektu | Skupiny


Umístění parametrů př.projektu

Popis

Jsou určeny k definování přístupových práv k parametrům předmětů projektu a k jejich elementárním hodnotám. Při přidělení parametru k předmětu projektu jeho inicializací se přepisuje umístění do události.

Datový model

  • NKPARDRU Umístění parametru předmětu projektu
    • BWUZIVAT Uživatel systému
    • SPPRISTU Přístupové právo uživatele k věci
    • SPSEOR Organizační selektor
    • ADADSAT Adresát

    • Formulář

    Formulář činnosti - Adresář
Mřížka [Umístění parametrů předmětu projektu]
Umístění | Identifikace umístění
Název umístění | Název umístění parametru
Adresát | Identifikace adresáta
 | Název adresáta
Majitel | Identifikace uživatele systému
Org. sel. | Identifikátor organizačního selektoru.
Název organizačního selektoru | Název organizačního selektoru
Poznámka | Poznámka k umístění parametru
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události

    Mřížka [Umístění parametrů předmětu projektu] činnosti - Adresář

    Mřížka [Umístění parametrů předmětu projektu] činnosti - Adresář
Umístění | Identifikace umístění
Název umístění | Název umístění parametru
Založil | Jméno uživatele systému
Datum a čas zápisu | Datum a čas zápisu záznamu události
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Org. sel. | Identifikátor organizačního selektoru.
Název organizačního selektoru | Název organizačního selektoru

    Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci
F2 | Adresář | Přehled adresátů
F2 | Organizační selektor | Číselník organizačních selektorů

    Atributy tisku

    Základní údaje
Umístění | Identifikace umístění | NKPARDRU_nk06id | C(6)
Název umístění | Název umístění parametru | NKPARDRU_nk06nazdru | C(40)
Org. sel. | Identifikátor organizačního selektoru. | NKPARDRU_sp11idzak | C(9)
Název organizačního selektoru | Název organizačního selektoru | SPSEOR_sp11text | C(60)
Adresát | Identifikace adresáta | NKPARDRU_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Poznámka | Poznámka k umístění parametru | NKPARDRU_nk06koment | M
Datum a čas zápisu | Datum a čas zápisu záznamu události | NKPARDRU_sp00datzap | T
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)

    Viz.také

    Přístupová práva | Adresář | Organizační selektor


Číselník hodnot parametrů

Popis

Zde je možné definovat číselníky používané parametry předmětu projektu v jejich elementární hodnotě typu číselník.

Datový model

  • NKCIS Číselník hodnot parametru předmětu projektu

    • Formulář

    Formulář činnosti - Číselník hodnot parametrů
Mřížka [Číselníky]
Číselník | Identifikace číselníku
Název číselníku | Název číselníku
Listovací rámeček
Stránka #1 Číselníky
Poznámka | Poznámka
Stránka #2 Hodnoty číselníku
Mřížka [Hodnoty číselníku]
ID | Identifikace hodnoty
Popis | Popis hodnoty
Poznámka | Poznámka k popisu hodnoty

    Mřížka [Číselníky] činnosti - Číselník hodnot parametrů

    Mřížka [Číselníky] činnosti - Číselník hodnot parametrů
Číselník | Identifikace číselníku
Název číselníku | Název číselníku

    Mřížka [Hodnoty číselníku] činnosti - Číselník hodnot parametrů

    Mřížka [Hodnoty číselníku] činnosti - Číselník hodnot parametrů
ID | Identifikace hodnoty
Popis | Popis hodnoty

    Atributy tisku

    Základní údaje
Číselník | Identifikace číselníku | NKCIS_nk35id | C(6)
Název číselníku | Název číselníku | NKCIS_nk35nazcis | C(40)
Poznámka | Poznámka | NKCIS_nk35koment | M
ID | Identifikace hodnoty | NKCISHOD_nk09id | C(9)
Popis | Popis hodnoty | NKCISHOD_nk09popis | C(40)
Poznámka | Poznámka k popisu hodnoty | NKCISHOD_nk09koment | M


Přehled hodnot číselníků

Popis

Zobrazuje přehled hodnot používaných v číselnících pro elementární hodnoty typu číselník parametrů předmětů projektu.

Datový model

  • NKCISHOD Hodnota číselníku hodnot parametru předmětu projektu
    • NKCIS Číselník hodnot parametru předmětu projektu

    • Formulář

    Formulář činnosti - Číselník hodnot parametrů
Mřížka [Přehled hodnot]
Listovací rámeček
Stránka #1 Přehled hodnot
ID | Identifikace hodnoty
Číselník | Identifikace číselníku
Popis | Popis hodnoty
Poznámka | Poznámka k popisu hodnoty
Stránka #2 Výběr
ID | Identifikace hodnoty
Číselník | Identifikace číselníku
Popis | Popis hodnoty
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Přehled hodnot] činnosti - Číselník hodnot parametrů

    Mřížka [Přehled hodnot] činnosti - Číselník hodnot parametrů
Číselník | Identifikace číselníku
ID | Identifikace hodnoty
Popis | Popis hodnoty

    Atributy tisku

    Základní údaje
ID | Identifikace hodnoty | NKCISHOD_nk09id | C(9)
Číselník | Identifikace číselníku | NKCISHOD_nk35id | C(6)
Název číselníku | Název číselníku | NKCIS_nk35nazcis | C(40)
Popis | Popis hodnoty | NKCISHOD_nk09popis | C(40)
Poznámka | Poznámka k popisu hodnoty | NKCISHOD_nk09koment | M


Skupiny

Popis

Jsou přidělovány skupinovým parametrům předmětu projektu uvedeným v prezentacích předmětů projektu. Slouží potom ve formuláři "Předměty projektu" na výběrové záložce pro omezení parametrů zobrazovaných na záložce "hodnoty". Ve výběrové záložce je atribut SKUPINA uveden kurzívou. Uvedení skupiny neovlivňuje vlastní výběr PP, ale pouze omezí výběr na záložce Hodnoty. Zobrazují se pouze hodnoty dané skupiny (skupina se uvádí u prezentace PP).

Datový model

  • NKSKUPIN Skupina skupinového parametru

    • Formulář

    Formulář činnosti - Adresář
Mřížka [Skupiny]
Skupina | Identifikace skupiny
Název skupiny | Název skupiny
Komentář | Komentář

    Mřížka [Skupiny] činnosti - Adresář

    Mřížka [Skupiny] činnosti - Adresář
Skupina | Identifikace skupiny
Název skupiny | Název skupiny

    Atributy tisku

    Základní údaje
Skupina | Identifikace skupiny | NKSKUPIN_nk18id | C(6)
Název skupiny | Název skupiny | NKSKUPIN_nk18nazskp | C(40)
Komentář | Komentář | NKSKUPIN_nk18koment | M


Parametry projektového řízení

Popis

Parametr "Při výpočtu plnění" rozhoduje, zda se mají informace o vyplacených zálohách při výpočtu plnění smluv čerpat z informací o zálohách uložených v projektovém řízení nebo z komponenty záloh BM.

Parametr "Hodinová konstanta projektového úkolu" určuje délku pracovního dne pro kapacitní plánování.

Označením příznaku „předplňovat datum ukončení úkolu“ se bude automaticky předplňovat datum ukončení úkolu při vstupu projektového úkolu aktuálním datem.

Je-li uvedena "Maska validace", slouží k určení povoleného tvaru identifikace předmětu projektu. Přitom je možné uvádět maskovací znaky:

¨ N - v odpovídající pozici může být pouze číslice

¨ A - v odpovídající pozici může být pouze znak

¨ X - v odpovídající pozici může být libovolný znak

¨ jiný znak - v odpovídající pozici může být pouze tento znak

Vyvolávané činnosti

K. | Činnost | Popis
F2 | Číselník hodnot parametrů | Číselník hodnot parametrů předmětu projektu

Formulář

Formulář činnosti - Číselník hodnot parametrů
Při výpočtu plnění | Při výpočtech plnění smluv používat zálohy komponenty záloh nebo vlastní
Hodinová konstanta projektového úkolu | Počet hodin odpovídajících 1 dni časové náročnosti projektového úkolu
Předplňovat datum ukončení úkolu | Předplňovat datum ukončení úkolu při vstupu projektového úkolu

Viz.také

Číselník hodnot parametrů


Reset parametrů předmětu

Popis

Provádí znovunačtení definic parametrů a prezentací předmětů projektu tak, aby nebylo nutné ukončovat IS BM a znovu ho spouštět po změně těchto definic na jiném počítači v systému.


O SMLOUVÁCH

Popis

Tato činnost je skupinové menu, které v sobě soustřeďuje veškeré činnosti týkající se smluv, jako jsou položky smluv, události plnění smluv, přehled záloh plnění smluv a další.

Viz.také

Položky smluv | Události plnění smluv | Přehled záloh plnění smluv | Výpočet plnění smluv | NASTAVENÍ SMLUV


Položky smluv

Popis

Činnost "položky smluv" slouží k vlastní evidenci smluv. Každá položka smlouvy je spojena a s aktérem (adresátem) a jeho rolí, ve které v dané souvislosti vystupuje. Je vztažena ke konkrétnímu předmětu projektu (PP). Výběrem pravidel výše, podmínky, splatnosti a agregace je dán algoritmus výpočtu plnění položky smlouvy. Jednotlivé smlouvy mají v podstatě dva druhy událostí – vlastní definici smlouvy a její plnění.

Položka "termín" určuje počáteční datum, od kterého má být výpočet prováděn. Položka "perioda" určuje periodu opakování výpočtu v měsících od posledního provedeného výpočtu. Počáteční stav položky smlouvy je nastaven podle druhu plnění položky smlouvy a není ho možné přímo měnit, změnu provádějí plnění určitého specifického druhu. Pro položky smlouvy, které nejsou ve stavu "aktuální" není vypočítáváno jejich plnění.

Druh plnění položky smlouvy definuje její charakter, určuje jaká pravidla výše je možné pro daný druh smlouvy použít a podle pravidla výše jsou určeny použitelná pravidla podmínky, splatnosti a agregace.

Položky smluv charakteru "poskytnutí zálohy" automaticky vytváří záznam o budoucí poskytnuté záloze (v projektovém řízení) dostupný na záložce "zálohy". Pokud je druhem plnění položky smlouvy dán její charakter "nákup" nebo "prodej", potom je možné na záložce "zálohy" určit zálohy komponenty projektové řízení, které mohou být vyúčtovávány při plnění dané položky smlouvy. Při vstupu položky smlouvy o nákupu nebo prodeji, kterému ve stejné operaci procesu předcházel vstup položky smlouvy o poskytnuté záloze pro stejného aktéra ve stejné roli je zápis o možném vyúčtování zálohy proveden automaticky na pozadí.

Pravidla výše, podmínky a splatnosti určují hodnoty, které vstupují do algoritmu výpočtu plnění položky smlouvy. Tyto údaje se zadávají na záložce "Hodnoty".

Na záložce "Plnění smlouvy" je přehled plnění, která na základě položky smlouvy vznikla. Zde je také možné i zadávat nová plnění vyplývající k této položce (plnění druhu, které to ve své definici povoluje). Tímto způsobem budou zadávána plnění, která mění stav položky smlouvy a případně plnění, která jsou podkladem pro její výpočet (např. pro smlouvu úhradě po dodání díla záznam o dodání díla). Proto, aby bylo možné tato plnění zadávat, je třeba, aby v procesu, ve kterém je položka smlouvy zadávána, byla také založena operace "plnění položek smluv".

Datový model

  • NKSMLOUV Položka smlouvy
    • SPPRISTU Přístupové právo uživatele k věci
    • PAOBJDRU Klasifikace objektu
    • ADSPOJ Spojení adresáta
      • ADADR Adresa
      • ADADSAT Adresát
    • NKROLE Role aktéra
    • BWUZIVAT Uživatel systému
    • SPPRCOD Operace procesu
      • SPTYP Druh procesu/operace
      • SPPRC Proces
    • NKPREDPR Předmět projektu
      • SPARTIKN Název artiklu
    • NKDRUHPR Pravidlo smlouvy (alias NKDRUHPRH)
    • NKDRUHPR Pravidlo smlouvy (alias NKDRUHPRS)
    • NKDRUHPR Pravidlo smlouvy (alias NKDRUHPRP)
    • NKDRUHPR Pravidlo smlouvy (alias NKDRUHPRT)
    • OBARTIKL Obchodovatelný artikl
      • SPARTIKN Název artiklu (alias SPARTIKN2)
    • NKPARDRU Umístění parametru předmětu projektu
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)
    • NKPLNDRU Druh události položky smlouvy nebo události plnění položky smlouvy (alias NKPLNDRU2)
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU3)

    • Formulář

    Formulář činnosti - Klasifikace objektů
Mřížka [Položky smluv]
Listovací rámeček
Stránka #1 Položky smluv
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
 | Název druhu operace
Předání | Způsob předání
Plnění | Identifikace druhu události smlouvy
Datum | Datum položky smlouvy
Popis | Popis položky smlouvy
Druh artiklu | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
Poř. | Pořadové číslo položky smlouvy k předmětu projektu
Název předmětu projektu | Název artiklu
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Identifikátor spojení na bankovní účet adresáta.
 | Název adresáta
Role | Identifikace role aktéra
Termín | Termín prvního vyhodnocení
Perioda | Perioda vyhodnocení v měsících
Stav | Stav položky smlouvy
Výše | Pravidlo výše plnění
Podmínka | Pravidlo podmínky platnosti
Splatnost | Pravidlo termínu splatnosti
Agregace | Agregace
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Umístění | Identifikace umístění
Název umístění | Název umístění parametru
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Stránka #2 Hodnoty
Podmínka | Název pravidla
Datum P1 | Podmínka vyhodnocení - datumová položka 1
Num P1 | Podmínka vyhodnocení - numerická položka 1
Datum P2 | Podmínka vyhodnocení - datumová položka 2
Num P2 | Podmínka vyhodnocení - numerická položka 2
Splatnost | Název pravidla
Datum S1 | Splatnost - datumová položka 1
Num S1 | Splatnost - numerická položka 1
Datum S2 | Splatnost - datumová položka 2
Num S2 | Splatnost - numerická položka 2
Popis | Popis položky smlouvy
Klasifikace | Identifikace klasifikace objektu
Měna | Kód měny - oceňovací jednotky.
Výše | Název pravidla
Num H1 | Výše honoráře - numerická položka 1
Num H2 | Výše honoráře - numerická položka 2
Datum H1 | Výše honoráře - datumová položka 1
Datum H2 | Výše honoráře - datumová položka 2
Datum H3 | Výše honoráře - datumová položka 3
Num H3 | Výše honoráře - numerická položka 3
Num H4 | Výše honoráře - numerická položka 4
Num H6 | Výše honoráře - numerická položka 6
Num H5 | Výše honoráře - numerická položka 5
Num H7 | Výše honoráře - numerická položka 7
Num H8 | Výše honoráře - numerická položka 8
Num H9 | Výše honoráře - numerická položka 9
Txt H1 | Podmínka vyhodnocení - textová položka 1
Stránka #3 Ostatní
Poznámka | Poznámka
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #4 Zálohy
Mřížka [Zálohy]
Adresát | Identifikace adresáta
 | Název adresáta
Měna | Kód měny - oceňovací jednotky.
Záloha | Identifikace zálohy
Částka v MÚ | Částka v měně úhrady zálohy
Zbývá vyúčtovat | Dosud nevyúčtovaná část zálohy
 | Identifikace zálohy
Částka v MÚ | Částka v měně úhrady zálohy
Zbývá vyúčtovat | Dosud nevyúčtovaná část zálohy
Stránka #5 Plnění smlouvy
Mřížka [Plnění smlouvy]
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
 | Název druhu operace
Předání | Způsob předání
Druh artiklu | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
Poř. | Pořadové číslo položky smlouvy k předmětu projektu
Název artiklu | Název artiklu
Plnění | Identifikace druhu události smlouvy
Datum | Datum plnění
Splatnost | Datum splatnosti
Popis | Popis události
Umíst. | Identifikace umístění
Název umístění | Název umístění parametru
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
Název role | Název role aktéra
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Záloha | Identifikace zálohy
Hodnota | Hodnota plnění
Vyúčt.záloha | Hodnota vyúčtované zálohy spojené s plněním
Měna | Kód měny - oceňovací jednotky.
Poznámka | Poznámka
Selektory | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #6 Výběr
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Číslo procesu do | Pořadové číslo procesu
Druh operace | Identifikátor druhu operace
Druh procesu | Identifikátor druhu procesu
Datum | Datum položky smlouvy
do | Datum do
Plnění | Identifikace druhu události smlouvy
Popis | Popis položky smlouvy
Stav | Stav položky smlouvy
Druh artiklu | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
Poř. | Pořadové číslo položky smlouvy k předmětu projektu
Název artiklu | Název artiklu
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Role | Identifikace role aktéra
Název role | Název role aktéra
Selektory | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Operace smlouvy | Stav operace smlouvy
Podmínka | Pravidlo podmínky platnosti
Splatnost | Pravidlo termínu splatnosti
Výše | Pravidlo výše plnění
Agregace | Agregace
Klasif. | Identifikace klasifikace objektu
Název klasifikace objektu | Název klasifikace objektu
Zapsané | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Položky smluv] činnosti - Klasifikace objektů

    Mřížka [Položky smluv] činnosti - Klasifikace objektů
Označování | Označení záznamu
Datum | Datum položky smlouvy
Plnění | Název druhu události smlouvy
Výše | Název pravidla
Popis | Popis položky smlouvy
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Role | Identifikace role aktéra
Název role | Název role aktéra
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Druh | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
Poř. | Pořadové číslo položky smlouvy k předmětu projektu
Název předmětu projektu | Název artiklu

    Mřížka [Zálohy] činnosti - Klasifikace objektů

    Mřížka [Zálohy] činnosti - Klasifikace objektů
    Záloha Identifikace zálohy

    Mřížka [Plnění smlouvy] činnosti - Klasifikace objektů

    Mřížka [Plnění smlouvy] činnosti - Klasifikace objektů
Datum | Datum plnění
Plnění | Název druhu události smlouvy
Záloha | Identifikace zálohy
Hodnota | Hodnota plnění
Měna | Kód měny - oceňovací jednotky.
Popis | Popis události
Splatnost | Datum splatnosti
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Druh operace | Identifikátor druhu operace
Artikl | Identifikace artiklu
Druh artiklu | Identifikace druhu artiklu
Verze | Verze projektu
Poř. | Pořadové číslo položky smlouvy k předmětu projektu

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Kopie záznamu | Kopie záznamu
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
- | POPISY PRAVIDEL | Zobrazení popisů pravidel
F2 | Adresář | Přehled adresátů
F2 | Bankovní spojení adresátů |
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy událostí smluv | Druhy událostí smluv
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Klasifikace objektů | Klasifikace objektů
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Obchodovatelný artikl | Seznam obchodovatelných artiklů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Pravidla smluv - Agregace | Seznam pravidel smluv
F2 | Předmět projektu | Seznam předmětů projektu
F2 | Přehled záloh plnění smluv | Přehled záloh plnění smluv
F2 | Role aktérů smluv | Seznam rolí aktérů smluv
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Umístění parametrů př.projektu | Umístění parametrů předmětu projektu

    Atributy tisku

    Základní údaje
Rok | Rok v identifikaci procesu | NKSMLOUV_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | NKSMLOUV_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | NKSMLOUV_sp33cisd | C(8)
Pořadí druhu operace | Pořadí stejného druhu operace v jednom procesu | NKSMLOUV_sp33porad | N(2)
Druh operace | Identifikátor druhu operace | NKSMLOUV_sp07idtyp | C(6)
Plnění | Identifikace druhu události smlouvy | NKSMLOUV_nk56id | C(6)
Plnění | Název druhu události smlouvy | NKPLNDRU2_nk56nazdru | C(40)
Charakter | Charakter druhu události smlouvy | Výpočet | C(30)
Stav | Stav položky smlouvy | Výpočet | C(12)
Předání | Způsob předání | Výpočet | C(6)
Datum | Datum položky smlouvy | NKSMLOUV_nk27datum | D
Popis | Popis položky smlouvy | NKSMLOUV_nk27text | C(40)
Artikl | Identifikace artiklu | NKSMLOUV_sp60id | C(13)
Druh artiklu | Identifikace druhu artiklu | NKSMLOUV_sp61id | C(3)
Verze | Verze projektu | NKSMLOUV_nk01verze | C(3)
Poř. | Pořadové číslo položky smlouvy k předmětu projektu | NKSMLOUV_nk27porad | C(3)
Adresát | Identifikace adresáta | NKSMLOUV_ad01id | C(6)
Spojení | Číslo spojení adresáta. | NKSMLOUV_ad11cisspo | C(2)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Úplný název adresáta | Úplný název adresáta | ADADSAT_ad01adsat2 | M
Volané telefonní číslo | Telefonní číslo | ADSPOJ_ad11cislo | C(60)
Jméno kontaktní osoby | Jméno kontaktní osoby. | ADSPOJ_ad11jmeno | C(40)
Jméno na štítek | Jméno pracovníka na poštovní štítek | ADSPOJ_ad11jmenop | C(100)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
Byt | Ulice bytu adresáta (včetně čísla popisného) | ADADR_ad02byt | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)
Stát | Identifikace státu. | ADADR_ad05id | C(3)
Role | Identifikace role aktéra | NKSMLOUV_nk25id | C(6)
Název role | Název role aktéra | NKROLE_nk25nazrol | C(40)
Termín | Termín prvního vyhodnocení | NKSMLOUV_nk27termd | D
Perioda | Perioda vyhodnocení v měsících | NKSMLOUV_nk27termp | N(2)
Název pravidla - honorář | Název pravidla | NKDRUHPRH_nk26nazpra | C(40)
Název pravidla - splatnost | Název pravidla | NKDRUHPRS_nk26nazpra | C(40)
Název pravidla - podmínka | Název pravidla | NKDRUHPRP_nk26nazpra | C(40)
Název pravidla - agregace | Název pravidla | NKDRUHPRT_nk26nazpra | C(40)
Umístění | Identifikace umístění | NKSMLOUV_nk06id | C(6)
Název umístění | Název umístění parametru | NKPARDRU_nk06nazdru | C(40)
Artikl | Identifikace artiklu | NKSMLOUV_sp60id2 | C(13)
Druh | Identifikace druhu artiklu | NKSMLOUV_sp61id2 | C(3)
Název artiklu | Název artiklu | NKPREDPR_sp60artikl | C(60)
Měna | Kód měny - oceňovací jednotky. | NKSMLOUV_oc01id | C(3)
Poznámka | Poznámka | NKSMLOUV_nk27koment | M
Obch. sel. | Identifikátor obchodního selektoru | NKSMLOUV_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | NKSMLOUV_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | NKSMLOUV_sp20idzak | C(9)
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | NKSMLOUV_sp00datzap | T
Výše | Pravidlo výše plnění | NKSMLOUV_nk26idh | C(6)
Splatnost | Pravidlo termínu splatnosti | NKSMLOUV_nk26ids | C(6)
Podmínka | Pravidlo podmínky platnosti | NKSMLOUV_nk26idp | C(6)
Agregace | Agregace | NKSMLOUV_nk26idt | C(6)
Klasifikace | Identifikace klasifikace objektu | NKSMLOUV_pa13id | C(12)
Název klasifikace objektu | Název klasifikace objektu | PAOBJDRU_pa13nazdru | C(40)
Datum S1 | Splatnost - datumová položka 1 | NKSMLOUV_nk27sdat1 | D
Num S1 | Splatnost - numerická položka 1 | NKSMLOUV_nk27snum1 | N(13,4)
Datum S2 | Splatnost - datumová položka 2 | NKSMLOUV_nk27sdat2 | D
Num S2 | Splatnost - numerická položka 2 | NKSMLOUV_nk27snum2 | N(13,4)
Datum H1 | Výše honoráře - datumová položka 1 | NKSMLOUV_nk27hdat1 | D
Num H1 | Výše honoráře - numerická položka 1 | NKSMLOUV_nk27hnum1 | N(13,4)
Datum H2 | Výše honoráře - datumová položka 2 | NKSMLOUV_nk27hdat2 | D
Num H2 | Výše honoráře - numerická položka 2 | NKSMLOUV_nk27hnum2 | N(13,4)
Datum P1 | Podmínka vyhodnocení - datumová položka 1 | NKSMLOUV_nk27pdat1 | D
Num P1 | Podmínka vyhodnocení - numerická položka 1 | NKSMLOUV_nk27pnum1 | N(13,4)
Datum P2 | Podmínka vyhodnocení - datumová položka 2 | NKSMLOUV_nk27pdat2 | D
Num P2 | Podmínka vyhodnocení - numerická položka 2 | NKSMLOUV_nk27pnum2 | N(13,4)
Datum H3 | Výše honoráře - datumová položka 3 | NKSMLOUV_nk27hdat3 | D
Num H3 | Výše honoráře - numerická položka 3 | NKSMLOUV_nk27hnum3 | N(13,4)
Num H4 | Výše honoráře - numerická položka 4 | NKSMLOUV_nk27hnum4 | N(13,4)
Num H5 | Výše honoráře - numerická položka 5 | NKSMLOUV_nk27hnum5 | N(20,4)
Num H6 | Výše honoráře - numerická položka 6 | NKSMLOUV_nk27hnum6 | N(20,4)
Num H7 | Výše honoráře - numerická položka 7 | NKSMLOUV_nk27hnum7 | N(20,4)
Num H8 | Výše honoráře - numerická položka 8 | NKSMLOUV_nk27hnum8 | N(20,4)
Num H9 | Výše honoráře - numerická položka 9 | NKSMLOUV_nk27hnum9 | N(20,4)
Txt H1 | Podmínka vyhodnocení - textová položka 1 | NKSMLOUV_nk27htxt1 | C(40)

    Při pohybu v Plnění položek smluv
Plnění | Identifikace druhu události smlouvy | NKSMLPLN_nk56id | C(6)
Stav | Změna stavu položky smlouvy | Výpočet | C(12)
Předání | Způsob předání | Výpočet | C(6)
Umístění | Identifikace umístění | NKSMLPLN_nk06id | C(6)
Datum | Datum plnění | NKSMLPLN_nk30datum | D
Popis | Popis události | NKSMLPLN_nk30text | C(40)
Hodnota | Hodnota plnění | NKSMLPLN_nk30hodnot | N(20,4)

    Při pohybu v Zálohy
    Záloha Identifikace zálohy NKSMLZAL_za02id C(32)

    Viz.také

    Kopie záznamu | OZNAČOVÁNÍ | Prezentace artiklu | POPISY PRAVIDEL | Adresář | Bankovní spojení adresátů | Druhy artiklů | Druhy událostí smluv | Kategorie adresátů | Klasifikace objektů | Měny a kursy | Obchodní selektor | Obchodovatelný artikl | Organizační selektor | Pravidla smluv | Předmět projektu | Přehled záloh plnění smluv | Role aktérů smluv | Spojení adresátů | Technicko-věcný selektor | Umístění parametrů př.projektu


Události plnění smluv

Popis

V činnosti události plnění smluv se evidují plnění položek smluv. Události o plnění mohou vzniknout procesním importem vypočtených plnění nebo zadáváním na záložce "plnění smluv" formuláře "položky smluv".

Tato ručně zadávaná plnění mohou měnit stav položky smlouvy nebo sloužit jako podklad pro výpočet plnění (počet předaných jednotek díla).

Na záložce "hodnoty výpočtu" jsou kromě hodnoty plnění informace o hodnotách smlouvy používané při výpočtu a referenční hodnoty zjištěné při výpočtu.

Na záložce "poznámky" jsou poznámky k výpočtu naplněné podle pravidel smluv vysvětlující postup výpočtu.

Datový model

  • NKSMLPLN Událost plnění položky smlouvy
    • NKPREDPR Předmět projektu
      • SPARTIKN Název artiklu
    • BWUZIVAT Uživatel systému
    • NKSMLOUV Položka smlouvy
      • ADADSAT Adresát
      • NKROLE Role aktéra
      • NKDRUHPR Pravidlo smlouvy
      • PAOBJDRU Klasifikace objektu
    • SPPRCOD Operace procesu
      • SPPRC Proces
      • SPTYP Druh procesu/operace
    • SPPRISTU Přístupové právo uživatele k věci
    • OBARTIKL Obchodovatelný artikl
      • SPARTIKN Název artiklu (alias SPARTIKN2)
    • NKPARDRU Umístění parametru předmětu projektu
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)
    • NKPLNDRU Druh události položky smlouvy nebo události plnění položky smlouvy (alias NKPLNDRU2)
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU3)

    • Formulář

    Formulář činnosti - Klasifikace objektů
Mřížka [Události plnění]
Listovací rámeček
Stránka #1 Události plnění
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
 | Název druhu operace
Předání | Způsob předání
Druh artiklu | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
Poř. | Pořadové číslo položky smlouvy k předmětu projektu
Plnění | Identifikace druhu události smlouvy
Datum | Datum plnění
Splatnost | Datum splatnosti
Popis | Popis události
Název artiklu | Název artiklu
Um. | Identifikace umístění
Název umístění | Název umístění parametru
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
Název role | Název role aktéra
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Záloha | Identifikace zálohy
Hodnota | Hodnota plnění
Vyúčt.záloha | Hodnota vyúčtované zálohy spojené s plněním
Měna | Kód měny - oceňovací jednotky.
Selektory | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Stránka #2 Hodnoty výpočtu
Výše | Název pravidla
Měna | Kód měny - oceňovací jednotky.
Datum H1 | Výše honoráře - datumová položka 1
Num H1 | Výše honoráře - numerická položka 1
Datum H2 | Výše honoráře - datumová položka 2
Num H2 | Výše honoráře - numerická položka 2
Datum H3 | Výše honoráře - datumová položka 3
Num H3 | Výše honoráře - numerická položka 3
Num H9 | Výše honoráře - numerická položka 9
Num H4 | Výše honoráře - numerická položka 4
Num H5 | Výše honoráře - numerická položka 5
Num H6 | Výše honoráře - numerická položka 6
Num H7 | Výše honoráře - numerická položka 7
Num H8 | Výše honoráře - numerická položka 8
Txt H1 | Podmínka vyhodnocení - textová položka 1
Klasifikace | Identifikace klasifikace objektu
Reference | Referenční hodnota - základní
Reference 2 | Referenční hodnota - 2
Reference 3 | Referenční hodnota - 3
Reference 4 | Referenční hodnota - 4
Reference 5 | Referenční hodnota - 5
Reference 6 | Referenční hodnota - 6
Reference 7 | Referenční hodnota - 7
Reference 8 | Referenční hodnota - 8
Hodnota | Hodnota plnění
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #3 Poznámky
Poznámka k podmínce | Poznámka k podmínce
Poznámka ke splatnosti | Poznámka ke splatnosti
Poznámka k výši | Poznámka k výši
Poznámka k agregaci | Poznámka k agregaci
Poznámka | Poznámka
Pořadí | Pořadí události v operaci
Stránka #4 Výběr
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Číslo procesu do | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Druh procesu | Identifikátor druhu procesu
Datum | Datum plnění
do | Datum plnění do
Plnění | Identifikace druhu události smlouvy
Popis | Popis události
Druh artiklu | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
Poř. | Pořadové číslo položky smlouvy k předmětu projektu
Název artiklu | Název artiklu
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Role | Identifikace role aktéra
Název role | Název role aktéra
Selektory | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Změna stavu | Změna stavu položky smlouvy při plnění smlouvy
Klasif. | Identifikace klasifikace objektu
Název klasifikace objektu | Název klasifikace objektu
Zapsané | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Události plnění] činnosti - Klasifikace objektů

    Mřížka [Události plnění] činnosti - Klasifikace objektů
Označování | Označení záznamu
Datum | Datum plnění
Plnění | Název druhu události smlouvy
Výše | Název pravidla
Záloha | Identifikace zálohy
Hodnota | Hodnota plnění
Měna | Kód měny - oceňovací jednotky.
Popis | Popis události
Splatnost | Datum splatnosti
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Role | Identifikace role aktéra
Název role | Název role aktéra
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Druh operace | Identifikátor druhu operace
Artikl | Identifikace artiklu
Druh artiklu | Identifikace druhu artiklu
Verze | Verze projektu
Poř. | Pořadové číslo položky smlouvy k předmětu projektu
Název artiklu | Název artiklu

    Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy událostí smluv | Druhy událostí smluv
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Klasifikace objektů | Klasifikace objektů
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Obchodovatelný artikl | Seznam obchodovatelných artiklů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Položky smluv | Položky smluv předmětu projektu
F2 | Předmět projektu | Seznam předmětů projektu
F2 | Přehled záloh | Přehled záloh
F2 | Role aktérů smluv | Seznam rolí aktérů smluv
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Umístění parametrů př.projektu | Umístění parametrů předmětu projektu

    Atributy tisku

    Základní údaje
IDÚ | Identifikace datového úložiště číselné řady procesu | NKSMLPLN_sp33cisdpm | C(2)
Rok | Rok v identifikaci procesu | NKSMLPLN_sp33cisdr | C(4)
Číslo procesu | Pořadové číslo procesu | NKSMLPLN_sp33cisd | C(8)
Pořadí druhu operace | Pořadí stejného druhu operace v jednom procesu | NKSMLPLN_sp33porad | N(2)
Druh operace | Identifikátor druhu operace | NKSMLPLN_sp07idtyp | C(6)
Název druhu operace | Název druhu operace | SPTYP_sp07text | C(30)
Plnění | Identifikace druhu události smlouvy | NKSMLPLN_nk56id | C(6)
Charakter | Charakter druhu události smlouvy | Výpočet | C(30)
Název druhu | Název druhu události smlouvy | NKPLNDRU2_nk56nazdru | C(40)
Datum | Datum plnění | NKSMLPLN_nk30datum | D
Splatnost | Datum splatnosti | NKSMLPLN_nk30datspl | D
Popis | Popis události | NKSMLPLN_nk30text | C(40)
Předání | Způsob předání | Výpočet | C(6)
Druh artiklu | Identifikace druhu artiklu | NKSMLPLN_sp61id | C(3)
Předmět | Identifikace artiklu | NKSMLPLN_sp60id | C(13)
Verze | Verze projektu | NKSMLPLN_nk01verze | C(3)
Poř. | Pořadové číslo položky smlouvy k předmětu projektu | NKSMLPLN_nk27porad | C(3)
Název artiklu | Název artiklu | NKPREDPR_sp60artikl | C(60)
Prac. název | Pracovní název projektu | NKPREDPR_nk01nazpra | C(50)
Adresát | Identifikace adresáta | NKSMLOUV_ad01id | C(6)
Spojení | Číslo spojení adresáta. | NKSMLOUV_ad11cisspo | C(2)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Úplný název adresáta | Úplný název adresáta | ADADSAT_ad01adsat2 | M
Volané telefonní číslo | Telefonní číslo | ADSPOJ_ad11cislo | C(60)
Jméno kontaktní osoby | Jméno kontaktní osoby. | ADSPOJ_ad11jmeno | C(40)
Jméno na štítek | Jméno pracovníka na poštovní štítek | ADSPOJ_ad11jmenop | C(100)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
Byt | Ulice bytu adresáta (včetně čísla popisného) | ADADR_ad02byt | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)
Stát | Identifikace státu. | ADADR_ad05id | C(3)
Role | Identifikace role aktéra | NKSMLOUV_nk25id | C(6)
Název role | Název role aktéra | NKROLE_nk25nazrol | C(40)
Záloha | Identifikace zálohy | NKSMLPLN_za02id | C(32)
Hodnota | Hodnota plnění | NKSMLPLN_nk30hodnot | N(20,4)
Vyúčt.záloha | Hodnota vyúčtované zálohy spojené s plněním | NKSMLPLN_nk30hodnoz | N(20,4)
Měna | Kód měny - oceňovací jednotky. | NKSMLPLN_oc01id | C(3)
Poznámka ke splatnosti | Poznámka ke splatnosti | NKSMLPLN_nk30spozn | M
Poznámka k výši | Poznámka k výši | NKSMLPLN_nk30hpozn | M
Poznámka k podmínce | Poznámka k podmínce | NKSMLPLN_nk30ppozn | M
Poznámka k agregaci | Poznámka k agregaci | NKSMLPLN_nk30tpozn | M
Poznámka | Poznámka | NKSMLPLN_nk30koment | M
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Klasifikace | Identifikace klasifikace objektu | NKSMLOUV_pa13id | C(12)
Název klasifikace objektu | Název klasifikace objektu | PAOBJDRU_pa13nazdru | C(40)
Datum a čas zápisu | Datum a čas zápisu záznamu události | NKSMLPLN_sp00datzap | T

    Viz.také

    OZNAČOVÁNÍ | Prezentace artiklu | Adresář | Druhy artiklů | Druhy událostí smluv | Kategorie adresátů | Klasifikace objektů | Měny a kursy | Obchodní selektor | Obchodovatelný artikl | Organizační selektor | Položky smluv | Předmět projektu | Přehled záloh | Role aktérů smluv | Spojení adresátů | Technicko-věcný selektor | Umístění parametrů př.projektu


Přehled záloh plnění smluv

Popis

Zobrazuje přehled záloh plnění smluv projektového řízení (ne zálohy z komponenty zálohy). Modrá barva v mřížce označuje zálohy, které byly poskytnuty a nebyly dosud vyúčtovány. Na záložce "položky smluv" je možné vidět přehled položek smluv, na kterých informace o budoucí poskytnuté záloze vznikla nebo které budou danou zálohu vyúčtovávat. Na záložce "plnění položek smluv" je přehled plnění položek smluv, kterými byla záloha poskytnuta resp. vyúčtována. Z obou záložek je možné spouštět odpovídající operace klávesou F9.

Datový model

  • NKSMLPLZ Karta zálohy plnění smluv
    • ADADSAT Adresát
    • ZAKARTA Karta zálohy

    • Formulář

    Formulář činnosti - Spustit operaci
Mřížka [Zálohy]
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Měna | Kód měny - oceňovací jednotky.
P/P | Záloha přijatá/poskytnutá
Záloha | Identifikace zálohy
Listovací rámeček
Stránka #1 Zálohy
Částka v MÚ | Částka v měně úhrady zálohy
Zbývá vyúčtovat | Dosud nevyúčtovaná část zálohy
 | Identifikace zálohy
Částka v MÚ | Částka v měně úhrady zálohy
Zbývá vyúčtovat | Dosud nevyúčtovaná část zálohy
Stránka #2 Položky smluv
Mřížka [Položky smluv]
Datum | Datum položky smlouvy
Název druhu | Název druhu události smlouvy
Výše | Název pravidla
Stav | Stav položky smlouvy
Předmět | Identifikace artiklu
Druh | Identifikace druhu artiklu
Verze | Verze projektu
Poř. | Pořadové číslo položky smlouvy k předmětu projektu
Název artiklu | Název artiklu
Termín | Termín prvního vyhodnocení
 | Perioda vyhodnocení v měsících
Stránka #3 Plnění položek smluv
Mřížka [Plnění položek smluv]
Datum | Datum plnění
Název druhu | Název druhu události smlouvy
Předmět | Identifikace artiklu
Druh | Identifikace druhu artiklu
Verze | Verze projektu
Poř. | Pořadové číslo položky smlouvy k předmětu projektu
Název artiklu | Název artiklu
Hodnota | Hodnota plnění
Stránka #4 Výběr
P/P | Záloha přijatá/poskytnutá
Zobrazit | Zobrazit všechny/nehrazené/nevyúčtované/vyúčtované
Souhlas | Souhlas s komponentou záloh
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Záloha | Identifikace zálohy
Měna | Kód měny - oceňovací jednotky.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Zálohy] činnosti - Spustit operaci

    Mřížka [Zálohy] činnosti - Spustit operaci
P/P | Záloha přijatá/poskytnutá
Adresát | Identifikace adresáta
Měna | Kód měny - oceňovací jednotky.
Záloha | Identifikace zálohy
Zbývá vyúčtovat | Dosud nevyúčtovaná část zálohy
Částka v MÚ | Částka v měně úhrady zálohy
Název adresáta | Název adresáta

    Mřížka [Položky smluv] činnosti - Spustit operaci

    Mřížka [Položky smluv] činnosti - Spustit operaci
Datum | Datum položky smlouvy
Plnění | Název druhu události smlouvy
Artikl | Identifikace artiklu
Druh artiklu | Identifikace druhu artiklu
Verze | Verze projektu
Poř. | Pořadové číslo položky smlouvy k předmětu projektu
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Název předmětu projektu | Název artiklu

    Mřížka [Plnění položek smluv] činnosti - Spustit operaci

    Mřížka [Plnění položek smluv] činnosti - Spustit operaci
Datum | Datum plnění
Plnění | Název druhu události smlouvy
Hodnota | Hodnota plnění
Měna | Kód měny - oceňovací jednotky.
Popis | Popis události
Splatnost | Datum splatnosti
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Druh operace | Identifikátor druhu operace
Název artiklu | Název artiklu

    Vyvolávané činnosti

    K. | Činnost | Popis
F7 | Diagram procesu | Zobrazení diagramu procesu
F9 | Spustit operaci | Spuštění zobrazené operace
F2 | Adresář | Přehled adresátů
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Přehled záloh | Přehled záloh

    Atributy tisku

    Základní údaje
P/P | Záloha přijatá/poskytnutá | Výpočet | C(5)
Měna | Kód měny - oceňovací jednotky. | NKSMLPLZ_oc01id2 | C(3)
Záloha | Identifikace zálohy | NKSMLPLZ_za02id | C(32)
Adresát | Identifikace adresáta | NKSMLPLZ_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Částka v MÚ | Částka v měně úhrady zálohy | NKSMLPLZ_za02cum | N(20,4)
Zbývá vyúčtovat | Dosud nevyúčtovaná část zálohy | NKSMLPLZ_za02cumnv | N(20,4)
Částka v MÚ | Částka v měně úhrady zálohy | ZAKARTA_za02cum | N(20,4)
Zbývá vyúčtovat | Dosud nevyúčtovaná část zálohy | ZAKARTA_za02cumnv | N(20,4)

    Při pohybu v Plnění položek smluv
Druh artiklu | Identifikace druhu artiklu | NKSMLPLN_sp61id | C(3)
Artikl | Identifikace artiklu | NKSMLPLN_sp60id | C(13)
Verze | Verze projektu | NKSMLPLN_nk01verze | C(3)
Poř. | Pořadové číslo položky smlouvy k předmětu projektu | NKSMLPLN_nk27porad | C(3)
Plnění | Charakter plnění položky smlouvy | Výpočet | C(29)
Stav | Změna stavu položky smlouvy | Výpočet | C(12)
Umístění | Identifikace umístění | NKSMLPLN_nk06id | C(6)
Artikl | Identifikace artiklu | NKSMLPLN_sp60id2 | C(13)
Druh | Identifikace druhu artiklu | NKSMLPLN_sp61id2 | C(3)
Obch. sel. | Identifikátor obchodního selektoru | NKSMLPLN_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | NKSMLPLN_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | NKSMLPLN_sp20idzak | C(9)
Rok | Rok v identifikaci procesu | NKSMLPLN_sp33cisdr | C(4)
Číslo procesu | Pořadové číslo procesu | NKSMLPLN_sp33cisd | C(8)
IDÚ | Identifikace datového úložiště číselné řady procesu | NKSMLPLN_sp33cisdpm | C(2)
Pořadí druhu operace | Pořadí stejného druhu operace v jednom procesu | NKSMLPLN_sp33porad | N(2)
Druh operace | Identifikátor druhu operace | NKSMLPLN_sp07idtyp | C(6)

    Viz.také

    Diagram procesu | Spustit operaci | Adresář | Kategorie adresátů | Měny a kursy | Přehled záloh


Výpočet plnění smluv

Popis

Výpočet plnění připravuje záznamy (do pracovní tabulky) o plnění položek smluv na základě kritérií zadaných na záložce "výběr" formuláře, algoritmů a hodnot definovaných pravidly uvedenými na položkách smluv. Na výběrové záložce je k dispozici i atribut „umístění“. Atribut „umístění“ je povinný, tzn. pro správný výpočet smluv musí být zadán (je to proto, že následný SQL dotaz u tabulky NKSMLOUV má nadefinováno "nk06id = hodnota ve výběru"). Pokud zůstane umístění prázdné nebo zadané jen částečně, činnost nebude správně fungovat. Podle zadaného výběru provede systém výpočet, zobrazí uživateli vypočtené hodnoty a po stisku klávesy ESC následuje dotaz na procesní import (import uvedený na výběrové záložce), který potom naplní události plnění smluv.

Do výpočtu výše plnění vstupují položky smluv, jejichž stav je následující:

¨ vyhovují zadáním uvedeným na záložce "výběr"

¨ jejich termín prvého zpracování je menší nebo roven zadanému datu

¨ nebyly dosud plněny nebo mají uvedenu periodu opakování a nebyly v této periodě alespoň jednou vyhodnoceny

¨ pravidlo pro vyhodnocení splatnosti vrátilo neprázdné datum

¨ pravidlo pro vyhodnocení podmínky vrátilo hodnotu pravda

¨ pravidlo pro určení agregace vrátilo neprázdný text

¨ nebyla potlačena kontrola termínu podle smlouvy

Dále rozhoduje o výstupu výpočtu "kód" definovaný pravidlem pro vyhodnocení výše na položce smlouvy. Tento kód by měl brát v úvahu všechna plnění, která byla dosud pro danou položku smlouvy vytvořena. K tomuto slouží tzv. referenční hodnoty, které jsou mu při výpočtu předány a obsahují agregované hodnoty z předchozích plnění. V kódu mohou být tyto vstupní, agregované hodnoty symbolicky zadány @R1@, @R2@, @R3@, @R4@ a @R5@. Dále musí kód pravidla výše nastavit výstupní hodnoty referenčních hodnot, tj. musí nastavit alespoň první referenční hodnotu do proměnné _RFR1 a může nastavit další referenční hodnoty (_RFR2, _RFR3, _RFR4 a _RFR5). Tyto hodnoty budou zapsány do výsledného plnění pro případné příští zpracování.

Kromě první referenční hodnoty musí kód nastavit proměnnou (_RETURN), jejíž hodnota bude zapsána do hodnoty plnění položky smlouvy. Např.: pro položku smlouvy o honoráři částka za kus podle počtu prodaných kusů díla bylo dosud prodáno 5420 kusů a v minulém období bylo již uhrazeno za 3104 kusů by měl kód vrátit referenční hodnotu 2316 a hodnotu výše 2316*(částka za kus uvedená na položce smlouvy).

Pozn.: v mnoha zejména nepeněžních případech může být hodnota _RFR1 a _RETURN stejná, ale např. pro pravidlo % z prodejní ceny v USD minimálně však N USD za kus to neplatí.

Dle nastavení v činnosti Parametry smluv jsou možné různé způsoby vyhodnocování periody. Při výpočtu plnění smluv se na výběrové záložce zadává datum, ke kterému se smlouvy vyhodnocují. V Parametrech smluv může být nastavena možnost „datum plnění“ (toto datum se následně v události smluv zobrazuje jako datum vyhodnocení) nebo možnost „termín smlouvy“ (program vyhodnotí a zapíše do událostí datum dalšího plnění podle periody).

Při běžném zpracování, pokud kód pravidla výše vrátil nulovou první referenční hodnotu nebo nulovou hodnotu výše, nebude záznam o plnění vytvořen. Kód pravidla výše může také výpočet přerušit tak, že vloží do proměnné _MESS text chybového hlášení.

Připravené záznamy o plnění položky smlouvy mohou být dále zpracovány jako vstup procesního importu uvedeného na záložce "výběr", který bude spuštěn po ukončení formuláře klávesou ESC v případě, že:

¨ import byl vybrán na záložce výběr

¨ výpočet byl proveden pro aktuální položky smluv

¨ výpočet byl proveden pro nenulovou referenční hodnotu

¨ výpočet byl proveden pro nenulovou hodnotu

¨ výpočet nebyl přerušen kódem některého pravidla

¨ výpočet vrátil alespoň jeden záznam

V případě, že je k položce smlouvy, která je vyhodnocována, v její definici připojena dosud nevyúčtovaná uhrazená záloha, vytvoří se navíc události o vyúčtování zálohy.

Pokud program předpokládá, že po ukončení výpočtu bude následovat procesní import, provede před výpočtem zablokování vstupu a oprav událostí komponent "položky smluv" a "plnění položek smluv". Samotný procesní import by měl provádět import s vytvořením nového procesu, jehož prvou operací je operace komponenty "plnění položky smlouvy" s rozpadem na procesy podle atributu "Data.nk36slucov" (jeho obsah je nastaven podle pravidla agregace).

Import použitý v procesním importu musí být typu XBASE a měl by obsahovat příkaz "DO NK0119OP WITH 32,this.wrk2".

Datový model

  • NKSMLPLT Událost plnění položky smlouvy před importem
    • NKPREDPR Předmět projektu
      • SPARTIKN Název artiklu
    • OBARTIKL Obchodovatelný artikl
      • SPARTIKN Název artiklu (alias SPARTIKN2)
    • NKSMLOUV Položka smlouvy (alias NKSMLOUV2)
      • ADADSAT Adresát
      • NKROLE Role aktéra
      • NKPARDRU Umístění parametru předmětu projektu (alias NKPARDRU2)
      • NKDRUHPR Pravidlo smlouvy
      • PAOBJDRU Klasifikace objektu
    • NKPLNDRU Druh události položky smlouvy nebo události plnění položky smlouvy (alias NKPLNDRU2)

    • Formulář

    Formulář činnosti - Kategorie adresátů
Mřížka [Výpočet plnění]
Listovací rámeček
Stránka #1 Vypočtená plnění
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Plnění | Název druhu události smlouvy
Předání | Způsob předání
Datum | Datum plnění
Splatnost | Datum splatnosti
Popis | Popis události
Druh artiklu | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
Poř. | Pořadové číslo položky smlouvy k předmětu projektu
Název artiklu | Název artiklu
Umístění | Identifikace umístění
Název umístění | Název umístění parametru
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
Název role | Název role aktéra
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Záloha | Identifikace zálohy
Hodnota | Hodnota plnění
Vyúčt.záloha | Hodnota vyúčtované zálohy spojené s plněním
Měna | Kód měny - oceňovací jednotky.
Stránka #2 Hodnoty výpočtu
Měna | Kód měny - oceňovací jednotky.
Výše | Název pravidla
Datum H1 | Výše honoráře - datumová položka 1
Num H1 | Výše honoráře - numerická položka 1
Datum H2 | Výše honoráře - datumová položka 2
Num H2 | Výše honoráře - numerická položka 2
Datum H3 | Výše honoráře - datumová položka 3
Num H3 | Výše honoráře - numerická položka 3
Num H9 | Výše honoráře - numerická položka 9
Num H4 | Výše honoráře - numerická položka 4
Num H5 | Výše honoráře - numerická položka 5
Num H6 | Výše honoráře - numerická položka 6
Num H7 | Výše honoráře - numerická položka 7
Num H8 | Výše honoráře - numerická položka 8
Txt H1 | Podmínka vyhodnocení - textová položka 1
Klasifikace | Identifikace klasifikace objektu
Reference | Referenční hodnota - základní
Reference 2 | Referenční hodnota - 2
Reference 3 | Referenční hodnota - 3
Reference 4 | Referenční hodnota - 4
Reference 5 | Referenční hodnota - 5
Hodnota | Hodnota plnění
Stránka #3 Poznámky
Poznámka k podmínce | Poznámka k podmínce
Poznámka ke splatnosti | Poznámka ke splatnosti
Poznámka k výši | Poznámka k výši
Poznámka k agregaci | Poznámka k agregaci
Poznámka | Poznámka
Selektory | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Stránka #4 Výběr
Datum | Datum vyhodnocení, ke kterému jsou smlouvy vyhodnocovány
 | Datum zpracování (určuje datum pro události operací), není-li uveden potom odpovídá datu vyhodnocení
Stav | Stav položky smlouvy
Plnění | Identifikace druhu události smlouvy
Operace smlouvy | Stav operace smlouvy
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Role | Identifikace role aktéra
 | Typ místa tuzemsko, zahraničí, Evropská Unie ....
Druh artiklu | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
Poř. | Pořadové číslo položky smlouvy k předmětu projektu
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Výše | Pravidlo výše plnění
Splatnost | Pravidlo termínu splatnosti
Podmínka | Pravidlo podmínky platnosti
Agregace | Agregace
Klasifikace | Identifikace klasifikace objektu
Průchod | Pořadové číslo průchodu vyhodnocení události smlouvy
Ref.hodnota | Výpočet položek smluv s nulovou nebo nenulovou referenční hodnotou
Hodnota | Výpočet položek smluv s nulovou nebo nenulovou hodnotou
Kontrola termínu podle smlouvy | Kontrola termínu podle smlouvy
Import | Identifikace importu pro volání prostředky BM
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Výpočet plnění] činnosti - Kategorie adresátů

    Mřížka [Výpočet plnění] činnosti - Kategorie adresátů
Datum | Datum plnění
Plnění | Název druhu události smlouvy
Adresát | Identifikace adresáta
Hodnota | Hodnota plnění
Měna | Kód měny - oceňovací jednotky.
Popis | Popis události
Záloha | Identifikace zálohy
Splatnost | Datum splatnosti
Název adresáta | Název adresáta
Role | Identifikace role aktéra
Název role | Název role aktéra
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Druh | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
Poř. | Pořadové číslo položky smlouvy k předmětu projektu
Název artiklu | Název artiklu

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Měny a kursy | Číselník měn včetně jejich kursů
F6 | Strom hlavního procesu | Zobrazení hlavního stromu procesu-operace
F7 | Diagram procesu | Zobrazení diagramu procesu
F9 | Spustit operaci | Spuštění zobrazené operace
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy událostí smluv | Druhy událostí smluv
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Klasifikace objektů | Klasifikace objektů
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Obchodovatelný artikl | Seznam obchodovatelných artiklů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Pravidla smluv - Agregace | Seznam pravidel smluv
F2 | Předmět projektu | Seznam předmětů projektu
F2 | Přehled záloh plnění smluv | Přehled záloh plnění smluv
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Atributy tisku

    Základní údaje
Artikl | Identifikace artiklu | NKSMLPLT_sp60id | C(13)
Druh artiklu | Identifikace druhu artiklu | NKSMLPLT_sp61id | C(3)
Verze | Verze projektu | NKSMLPLT_nk01verze | C(3)
Poř. | Pořadové číslo položky smlouvy k předmětu projektu | NKSMLOUV2_nk27porad | C(3)
Stav | Stav položky smlouvy | Výpočet | C(12)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Artikl | Identifikace artiklu | NKSMLPLT_sp60id2 | C(13)
Druh | Identifikace druhu artiklu | NKSMLPLT_sp61id2 | C(3)
Název artiklu | Název artiklu | SPARTIKN2_sp62artikl | C(60)
Adresát | Identifikace adresáta | NKSMLOUV2_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Název role | Název role aktéra | NKROLE_nk25nazrol | C(40)
Plnění | Charakter plnění položky smlouvy | Výpočet | C(29)
Stav | Změna stavu položky smlouvy | Výpočet | C(12)
Datum | Datum plnění | NKSMLPLT_nk30datum | D
Splatnost | Datum splatnosti | NKSMLPLT_nk30datspl | D
Popis | Popis události | NKSMLPLT_nk30text | C(40)
Poznámka ke splatnosti | Poznámka ke splatnosti | NKSMLPLT_nk30spozn | M
Poznámka k výši | Poznámka k výši | NKSMLPLT_nk30hpozn | M
Poznámka k podmínce | Poznámka k podmínce | NKSMLPLT_nk30ppozn | M
Poznámka k agregaci | Poznámka k agregaci | NKSMLPLT_nk30tpozn | M
Poznámka | Poznámka | NKSMLPLT_nk30koment | M
Hodnota | Hodnota plnění | NKSMLPLT_nk30hodnot | N(20,4)
Reference | Referenční hodnota - základní | NKSMLPLT_nk30rfr1 | N(20,4)
Reference 2 | Referenční hodnota - 2 | NKSMLPLT_nk30rfr2 | N(20,4)
Reference 3 | Referenční hodnota - 3 | NKSMLPLT_nk30rfr3 | N(20,4)
Reference 4 | Referenční hodnota - 4 | NKSMLPLT_nk30rfr4 | N(20,4)
Termín | Termín prvního vyhodnocení | NKSMLOUV2_nk27termd | D
Perioda | Perioda vyhodnocení v měsících | NKSMLOUV2_nk27termp | N(2)
Datum S1 | Splatnost - datumová položka 1 | NKSMLOUV2_nk27sdat1 | D
Num S1 | Splatnost - numerická položka 1 | NKSMLOUV2_nk27snum1 | N(13,4)
Datum S2 | Splatnost - datumová položka 2 | NKSMLOUV2_nk27sdat2 | D
Num S2 | Splatnost - numerická položka 2 | NKSMLOUV2_nk27snum2 | N(13,4)
Datum H1 | Výše honoráře - datumová položka 1 | NKSMLOUV2_nk27hdat1 | D
Num H1 | Výše honoráře - numerická položka 1 | NKSMLOUV2_nk27hnum1 | N(13,4)
Datum H2 | Výše honoráře - datumová položka 2 | NKSMLOUV2_nk27hdat2 | D
Num H2 | Výše honoráře - numerická položka 2 | NKSMLOUV2_nk27hnum2 | N(13,4)
Datum H3 | Výše honoráře - datumová položka 3 | NKSMLOUV2_nk27hdat3 | D
Num H3 | Výše honoráře - numerická položka 3 | NKSMLOUV2_nk27hnum3 | N(13,4)
Num H9 | Výše honoráře - numerická položka 9 | NKSMLOUV2_nk27hnum9 | N(20,4)
Num H4 | Výše honoráře - numerická položka 4 | NKSMLOUV2_nk27hnum4 | N(13,4)
Num H5 | Výše honoráře - numerická položka 5 | NKSMLOUV2_nk27hnum5 | N(20,4)
Num H6 | Výše honoráře - numerická položka 6 | NKSMLOUV2_nk27hnum6 | N(20,4)
Num H7 | Výše honoráře - numerická položka 7 | NKSMLOUV2_nk27hnum7 | N(20,4)
Num H8 | Výše honoráře - numerická položka 8 | NKSMLOUV2_nk27hnum8 | N(20,4)
Datum P1 | Podmínka vyhodnocení - datumová položka 1 | NKSMLOUV2_nk27pdat1 | D
Num P1 | Podmínka vyhodnocení - numerická položka 1 | NKSMLOUV2_nk27pnum1 | N(13,4)
Datum P2 | Podmínka vyhodnocení - datumová položka 2 | NKSMLOUV2_nk27pdat2 | D
Num P2 | Podmínka vyhodnocení - numerická položka 2 | NKSMLOUV2_nk27pnum2 | N(13,4)
Txt H1 | Podmínka vyhodnocení - textová položka 1 | NKSMLOUV2_nk27htxt1 | C(40)
Klasifikace | Identifikace klasifikace objektu | NKSMLOUV2_pa13id | C(12)
Název klasifikace objektu | Název klasifikace objektu | PAOBJDRU_pa13nazdru | C(40)

    Viz.také

    Strom hlavního procesu | Diagram procesu | Spustit operaci | Adresář | Druhy artiklů | Druhy událostí smluv | Kategorie adresátů | Klasifikace objektů | Měny a kursy | Obchodní selektor | Obchodovatelný artikl | Organizační selektor | Pravidla smluv | Předmět projektu | Přehled záloh plnění smluv | Technicko-věcný selektor


NASTAVENÍ SMLUV

Popis

Obsahuje činnosti potřebné k nastavení části projektového řízení týkajících se smluv.

Viz.také

Druhy událostí smluv | Pravidla smluv | SQL dotazy pro pravidla smluv | Role aktérů smluv | Parametry smluv | Číselné řady pořadí položek smluv


Druhy událostí smluv

Popis

Druh události smlouvy (DUS) je bazálním objektem definujícím systém zpracování smluv projektového řízení BM. Je uváděn na každé položce smlouvy a plnění položky smlouvy.

U každého druhu událostí smluv se definuje:

¨ identifikace a název druhu

¨ umístění smlouva – pomocí tohoto umístění se definují přístupová práva pro její založení

¨ umístění plnění – pomocí tohoto umístění se definují přístupová práva pro její plnění

¨ charakter – určení charakteru má význam pro algoritmus výpočtu plnění smlouvy:

- charakter "nákup" má souvislost s charakterem "úhrada zálohy - poskytnuté" a "vyúčtování zálohy - poskytnuté" (pro charakter "nákup" je povinné určit plnění "Pro vyúčtování zálohy").

- charakter "prodej" má souvislost s charakterem "úhrada zálohy - přijaté" a "vyúčtování zálohy - přijaté" (pro charakter "prodej" je povinné určit plnění "Pro vyúčtování zálohy").

- pro jiná, nepeněžní plnění je možné vytvořit DUS s charakterem „ostatní“.

¨ položky smluv - některé DUS se mohou vyskytovat pouze na plnění položky smlouvy (typicky DUS s charakterem vyúčtování zálohy nebo plnění měnící vlastnost "stav" položky smlouvy). Pro tyto DUS je možné nastavit vlastnost "Položky smluv" na "Ne".

¨ vstup ze smlouvy - je-li nastavena vlastnost "Vstup ze smluv" na "Ano", potom je možné událost plnění položky smlouvy zadat přímo v události zadání položky smlouvy na záložce "plnění". Typicky se tato možnost využije pro DUS měnící vlastnost "stav" položky smlouvy nebo pro plnění, která slouží jako podklad pro výpočet plnění (např. na smlouvě o úhradě po dodání díla).

¨ průchod - "Průchod" rozděluje různé položky smluv do skupin, jejichž plnění není vhodné vypočítávat současně (např. je třeba vypočítat odděleně nejprve plnění poskytnutí zálohy a potom plnění úhrad).

¨ počáteční stav – uplatňuje se při vzniku události položky smlouvy. Její využití je pro ty smlouvy, pro které má proběhnout schvalovací řízení.

¨ změna stavu – uplatňuje se při vzniku události plnění položky smlouvy. Plněními s tímto DUS je možné ukončovat platnost smlouvy nebo jí aktivovat.

¨ druh události smlouvy pro vyúčtování zálohy

¨ výraz termínu - je vyhodnocován při zadávání položky smlouvy. Obvykle bude obsahovat výraz DATE().

¨ perioda - je předplňována při zadávání položky smlouvy

¨ artikl - je obchodovatelný artikl zapisovaný do události plnění položky smlouvy při jejím vzniku

¨ měna - je předplňována při zadávání položky smlouvy

Na záložce "Pravidla - výše" jsou uváděna povolená pravidla výpočtu výše plnění pro tento druh události. Má-li některé zde uvedené pravidlo nastavenu vlastnost "Implicitní" na "Ano", potom bude toto pravidlo při založení položky smlouvy předplněno.

Na záložce "Druhy plnění" jsou uváděny povolené druhy plnění pro plnění položky smlouvy. Vlastnost "Pro pravidlo" navíc rozšiřuje omezení na plnění položek smluv se zadaným pravidlem výše (je-li uvedeno).

Na záložce "Stavy" je možné zadat při jakých stavech položky smlouvy :

¨ je povoleno ukončit operaci položky smlouvy

¨ je možné měnit obsah smlouvy při ukončené operaci

¨ má být při změně stavu položky smlouvy změněn stav operace na neukončena

Pokud na záložce Použití v operacích uživatel zadá nějakou operaci komponenty HPS (položky smluv), tak následně při spuštění procesu s touto operací nabízí systém u atributu „druh“ jen ty druhy událostí smluv, které jsou propojené právě s aktuální operací.

Datový model

  • NKPLNDRU Druh události položky smlouvy nebo události plnění položky smlouvy
    • BWUZIVAT Uživatel systému
    • NKPARDRU Umístění parametru předmětu projektu
    • NKPARDRU Umístění parametru předmětu projektu (alias NKPARDRU2)

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Editovat kód vlastnosti | Editovat kód vlastnosti
F6 | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností
- | Kontrolní kompilace | Kontrolní kompilace
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy událostí smluv | Druhy událostí smluv
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Obchodovatelný artikl | Seznam obchodovatelných artiklů
F2 | Pravidla smluv - Výše | Seznam pravidel smluv
F2 | Umístění parametrů př.projektu | Umístění parametrů předmětu projektu

    Formulář

    Formulář činnosti - Kontrolní kompilace
Mřížka [Druhy událostí smluv]
Plnění | Identifikace druhu události smlouvy
Název druhu | Název druhu události smlouvy
Listovací rámeček
Stránka #1 Druhy událostí
U.smlouva | Identifikace umístění
Název umístění | Název umístění parametru
U.plnění | Identifikátor umístění druhu události plnění položky smlouvy
Název umístění | Název umístění parametru
Charakter | Charakter druhu události smlouvy
Poř. | Pořadí zobrazení v seznamu plnění
TID | Pomocný identifikátor pro transformace
Selektory | Způsob předplňování selektorů Nákup = TVS<-obch.art.,OBS<-PP / Prodej = TVS<-PP
Položky smluv | Uplatňuje se také pro položky smluv
Vstup ze smluv | Povolen ruční vstup z událostí smluv
Průchod | Pořadové číslo průchodu vyhodnocení události smlouvy
Nastavuje počáteční stav položky | Nastavuje počáteční stav položky smlouvy při jejím založení Ano/Ne
Počáteční stav | Počáteční stav položky smlouvy při jejím založení
Změna stavu | Změna stavu položky smlouvy při plnění smlouvy
Pro vyúčtování zálohy | Druh události smlouv pro vyúčtování zálohy
Název druhu | Název druhu události smlouvy
Výraz termínu | Výraz pro přednastavení termínu vyhodnocení
Perioda | Perioda vyhodnocení v měsících
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Měna | Kód měny - oceňovací jednotky.
Komentář | Komentář
Založil | Jméno uživatele systému
Datum a čas zápisu | Datum a čas zápisu záznamu události
Stránka #2 Pravidla - výše
Mřížka [Pravidla - výše]
Pravidlo | Identifikace pravidla
Název pravidla | Název pravidla
Implicitní | Implicitní pro druh události smlouvy
Pořadí | Pořadí pravidla smlouvy druhu události smlouvy
Poč.stav | Počáteční stav položky smlouvy při jejím založení
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Skript | Script pro určení obchodovatelného artiklu volaný s parametrem _attr='SP61ID2' resp. _attr='SP60ID2' a _this=thisform
Stránka #3 Druhy plnění
Mřížka [Druhy plnění]
Plnění | Identifikace druhu události smlouvy
Název druhu | Název druhu události smlouvy
Poř. | Pořadí zobrazení v seznamu plnění
Pro pravidlo | Identifikace pravidla výše, pro které se uplatní daná definice (neuvedeno = uplatní se vždy)
Název pravidla | Název pravidla
Stránka #4 Stavy
Mřížka [Vlastnosti stavů]
Stav | Stav položky smlouvy
Povoleno ukončit operaci | Povoleno ukončit operaci položky smlouvy
Povolena oprava v ukončené operaci | Povolena oprava v ukončené operaci položky smlouvy
Zrušení ukončení operace | Zrušení ukončení operace položky smlouvy při nastavení na stav
Stránka #5 Použití v operacích
Mřížka [Použití v operacích]
 | Identifikace komponenty
Operace | Identifikátor druhu operace
Název druhu operace | Název druhu operace

    Mřížka [Druhy událostí smluv] činnosti - Kontrolní kompilace

    Mřížka [Druhy událostí smluv] činnosti - Kontrolní kompilace
Poř. | Pořadí zobrazení v seznamu plnění
Plnění | Identifikace druhu události smlouvy
Název druhu | Název druhu události smlouvy
Umístění | Identifikace umístění
Umístění plnění | Identifikátor umístění druhu události plnění položky smlouvy
Položky smluv | Uplatňuje se také pro položky smluv
Vstup ze smluv | Povolen ruční vstup z událostí smluv
Počáteční stav | Počáteční stav položky smlouvy při jejím založení
Změna stavu | Změna stavu položky smlouvy při plnění smlouvy

    Mřížka [Pravidla - výše] činnosti - Kontrolní kompilace

    Mřížka [Pravidla - výše] činnosti - Kontrolní kompilace
Pořadí | Pořadí pravidla smlouvy druhu události smlouvy
Pravidlo | Identifikace pravidla
Implicitní | Implicitní pro druh události smlouvy
Název pravidla | Název pravidla

    Mřížka [Druhy plnění] činnosti - Kontrolní kompilace

    Mřížka [Druhy plnění] činnosti - Kontrolní kompilace
Poř. | Pořadí zobrazení v seznamu plnění
Plnění | Identifikace druhu události smlouvy
Název druhu | Název druhu události smlouvy

    Mřížka [Vlastnosti stavů] činnosti - Kontrolní kompilace

    Mřížka [Vlastnosti stavů] činnosti - Kontrolní kompilace
    Stav Stav položky smlouvy

    Mřížka [Použití v operacích] činnosti - Kontrolní kompilace

    Mřížka [Použití v operacích] činnosti - Kontrolní kompilace
Komp. | Identifikace komponenty
Operace | Identifikátor druhu operace
Název druhu operace | Název druhu operace

    Viz.také

    Editovat kód vlastnosti | Knihovny vkládaného kódu | Kontrolní kompilace | Druhy artiklů | Druhy operací | Měny a kursy | Obchodovatelný artikl | Pravidla smluv | Umístění parametrů př.projektu


Pravidla smluv

Popis

Pravidla smluv (výše, podmínka, splatnost, agregace) definují algoritmy plnění položek smluv. Pro každé pravidlo je možné definovat na záložce "Vlastnosti hodnot" několik parametrů vstupovaných pro dané pravidlo při vzniku položky smlouvy. Každý tento parametr může mít u sebe definováno:

¨ návěští

¨ stavový řádek

¨ validace – výraz FoxPro, hodnota se referuje třemi #. Na jiné hodnoty smluv lze odkazovat do kurzoru, např. NKSMLOUV.nk27hnum2=1

¨ chybové hlášení zobrazené při nesplnění validace

¨ rozměry (délka, desetiny)

¨ výraz inicializace

Pro pravidla smluv výše je možné definovat :

¨ 9 numerických parametrů

¨ 3 datumové parametry

¨ 1 textový parametr

Pro pravidla smluv podmínka a splatnost je možné definovat :

¨ 2 numerické parametry

¨ 2 datumové parametry

Pro pravidlo smluv agregace není možné definovat žádný parametr.

Pro pravidlo výše platí, že v atributu „kód“ je definován programový kód, který naplní nebo vypočte hodnotu plnění, ale současně může vypočítat i uvedené referenční hodnoty (jsou zapisovány do událostí plnění a jsou využívány jako integrální hodnota algoritmu výpočtu). Při definici referenčních hodnot lze používat připravené selekty (v činnosti SQL – dotazy pro pravidla smluv).

Pro pravidla výše se navíc ještě definuje, která pravidla podmínky, splatnosti a agregace je dovoleno pro dané pravidlo výše použít (slouží pak především při zadávání položek smluv. Při zadání pravidla výše se pak v následných překryvných seznamech (podmínka, splatnost a agregace) nabízí uživateli v překryvném seznamu jen ta pravidla, která lze v kombinaci s tímto pravidlem výše použít.

Výpočet plnění položek smluv probíhá na základě parametrů (vlastností hodnot pravidel) uvedených na položkách smluv.

Na každé položce smlouvy jsou podle pravidel dostupné parametry smlouvy, které vstupují do výpočtu. Tyto hodnoty jsou dostupné v kódu pravidla (atribut "kód") a kódu pro výpočet poznámky (atribut "kód poznámky") syntaxí:

¨ @d1@, @d2@, @d3@ - datumové hodnoty

¨ @n1@, @n2@, @n3@, @n4@, @n5@, @n6@, @n7@, @n8@, @n9@ - numerické hodnoty

¨ @t1@ - textovoá hodnota

¨ @p@ - název pravidla

¨ @r1@, @r2@, @r3@, @r4@, @r5@ - agregované referenční hodnoty

¨ @dp@ - datum posledního plnění

¨ @ds@ - datum poslední splatnosti

¨ @h@ - agregovaná hodnota dosavadního plnění

¨ @d@ - datum, ke kterému je prováděn výpočet

¨ _datump termín vyhodnocení

¨ _sp61id druh artiklu

¨ _sp60id artikl

¨ _nk01verze verze

Kód pravidla musí obsahovat musí obsahovat přiřazení hodnoty proměnné _RETURN, kód pravidla výše navíc _RFR1. Typ hodnoty proměnné _RETURN musí být:

¨ pro pravidlo výše - numerický

¨ pro pravidlo podmínka - logický

¨ pro pravidlo splatnost - datumový

¨ pro pravidlo agregace - textový

V kódu pravidla se mohou vyskytovat odkazy na "SQL dotazy pro pravidla smluv" v hranatých závorkách.

V kódu pravidla nelze použít příkazy jazyka FoxPro: FOR ... ENDFOR, DO WHILE ... ENDDO, SCAN ... ENDSCAN, CASE ... ENDCASE, ale pouze IF ... ENDIF. V případě potřeby použití těchto příkazů je nutné tyto napsat jako SCRIPT.

Příklad kódu pravidla výše:

<<pre>>

_wrkd1=IIF(EMPTY(@d1@),{01.01.1900},@d1@)

_wrkd2=IIF(EMPTY(@d2@) OR @d2@>@d@,@d@,@d2@)

_wrk60id=nksp60id('nkhodnp')

* hodnoty proměnných _wrkd1, _wrkd2 a _wrk60id budou dostupné pro SQL dotaz [NPVK]

_wrkpocet=[NPVK]

* interní metoda interval vrací počet, který je v interval od - do

* agregovaná hodnota @R1@ určuje kolik bylo již předchozím plněním splněno

_rfr1=this.interval(_wrkpocet,@n3@,@n4@)-@R1@

IF _rfr1=0

* není co plnit

_return=0

ELSE

IF @n3@>0 OR @n4@>0

_rfr2=fr_NPVKC(this,@n3@,@n4@)-@R2@

ELSE

_rfr2=([NPVKC]-@R2@)

ENDIF

_wrkcena=_rfr2/_rfr1

_rfr3=_wrkcena/(100+this.dph())*100

IF @n2@=2

_rfr3=_rfr3*@n6@/100

ENDIF

_rfr3=_rfr3*@n1@/100

IF NKSMLOUV.oc01id<>'CZK'

_wrkkurs=this.kurs_meny(1)

_rfr3=_rfr3/_wrkkurs

ENDIF

IF @n8@>0 AND @n8@>_rfr3

_rfr4=@n8@

ELSE

_rfr4=_rfr3

ENDIF

_rfr5=[NPVP]-@R5@

_return=ROUND(_rfr4*(_rfr1*@n5@-_rfr5*@n7@)/100,1)

ENDIF

<</pre>>

Příklad kódu pravidla podmínky:

<<pre>>

_wrkd1={1.1.1900}

_wrkd2={1.1.2100}

_wrk60id=nksp60id()

_wrkd1=[DVYTIP]

IF EMPTY(_wrkd1)

_wrkd1={1.1.1900}

ELSE

_wrkd1=_wrkd1+1

ENDIF

_return=[NPOBJ]<>0

<</pre>>

Příklad kódu pravidla splatnosti:

<<pre>>

_return=_datump+@n1@

<</pre>>

Příklad kódu pravidla agregace:

<<pre>>

_return=[CSTAT]+_ad01id+_sp60id+_sp61id+_nk01verze

<</pre>>

Datový model

  • NKDRUHPR Pravidlo smlouvy

    • Formulář

    Formulář činnosti - Pravidla smluv
Mřížka [Pravidla]
Pravidlo | Identifikace pravidla
Název pravidla | Název pravidla
Listovací rámeček
Stránka #1 Pravidla smluv
Kód | Kód pravidla
Kód poznámky | Kód poznámky o hodnotě
Příznak | Příznak pravidla použitelný např. v řízení procesů kódy po ukončení
Poznámka | Poznámka
Stránka #2 Vlastnosti hodnot
Mřížka [Vlastnosti hodnot]
Hodnota | Identifikace hodnoty
Návěští | Návěští hodnoty
Stavový řádek | Stavový řádek hodnoty
Validace | Validace hodnoty
Chyb.hlášení | Chybové hlášení
Délka | Délka numerické hodnoty
Desetiny | Desetiny numerické hodnoty
Inicializace | Inicializace hodnoty
Stránka #3 Popis referenčních hodnot
Mřížka [Popis referenčních hodnot]
Hodnota | Identifikace referenční hodnoty
Návěští | Návěští referenční hodnoty
Délka | Délka numerické hodnoty
Desetiny | Desetiny numerické hodnoty
Stránka #4 Podmínky
Mřížka [Podmínky]
Pravidlo | Identifikace pravidla
Název pravidla | Název pravidla
Implicitní | Implicitní pro pravidlo výše
Pořadí | Pořadí pravidla smlouvy
Stránka #5 Splatnosti
Mřížka [Splatnosti]
Pravidlo | Identifikace pravidla
Název pravidla | Název pravidla
Implicitní | Implicitní pro pravidlo výše
Pořadí | Pořadí pravidla smlouvy
Stránka #6 Agregace
Mřížka [Agregace]
Pravidlo | Identifikace pravidla
Název pravidla | Název pravidla
Implicitní | Implicitní pro pravidlo výše
Pořadí | Pořadí pravidla smlouvy

    Mřížka [Pravidla] činnosti - Pravidla smluv

    Mřížka [Pravidla] činnosti - Pravidla smluv
Pravidlo | Identifikace pravidla
Název pravidla | Název pravidla

    Mřížka [Vlastnosti hodnot] činnosti - Pravidla smluv

    Mřížka [Vlastnosti hodnot] činnosti - Pravidla smluv
Pravidlo | Identifikace pravidla
Hodnota | Identifikace hodnoty
Návěští | Návěští hodnoty

    Mřížka [Popis referenčních hodnot] činnosti - Pravidla smluv

    Mřížka [Popis referenčních hodnot] činnosti - Pravidla smluv
Pravidlo | Identifikace pravidla
Hodnota | Identifikace referenční hodnoty
Návěští | Návěští referenční hodnoty

    Mřížka [Podmínky] činnosti - Pravidla smluv

    Mřížka [Podmínky] činnosti - Pravidla smluv
Poř. | Pořadí pravidla smlouvy
Pravidlo | Identifikace pravidla
Implicitní | Implicitní pro pravidlo výše
Název pravidla | Název pravidla

    Mřížka [Splatnosti] činnosti - Pravidla smluv

    Mřížka [Splatnosti] činnosti - Pravidla smluv
Poř. | Pořadí pravidla smlouvy
Pravidlo | Identifikace pravidla
Implicitní | Implicitní pro pravidlo výše
Název pravidla | Název pravidla

    Mřížka [Agregace] činnosti - Pravidla smluv

    Mřížka [Agregace] činnosti - Pravidla smluv
Poř. | Pořadí pravidla smlouvy
Pravidlo | Identifikace pravidla
Implicitní | Implicitní pro pravidlo výše
Název pravidla | Název pravidla

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Modifikace kódu pravidla | Modifikace kódu pravidla
F6 | Modifikace kódu poznámky | Modifikace kódu poznámky
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Pravidla smluv - Agregace | Seznam pravidel smluv
F2 | SQL dotazy pro pravidla smluv | SQL dotazy pro pravidla smluv

    Atributy tisku

    Základní údaje
Pravidlo | Identifikace pravidla | NKDRUHPR_nk26id | C(6)
Název pravidla | Název pravidla | NKDRUHPR_nk26nazpra | C(40)
Typ | Typ pravidla | Výpočet | C(19)
Kód | Kód pravidla | NKDRUHPR_nk26vyraz | M
Kód poznámky | Kód poznámky o hodnotě | NKDRUHPR_nk26vyrazp | M
Příznak | Příznak pravidla použitelný např. v řízení procesů kódy po ukončení | Výpočet | C(1)
Poznámka | Poznámka | NKDRUHPR_nk26koment | M
Název pravidla | Název pravidla | NKDRUHPR2_nk26nazpra | C(40)
Název pravidla | Název pravidla | NKDRUHPR3_nk26nazpra | C(40)

    Při pohybu v Vlastnosti hodnot
Návěští | Návěští hodnoty | NKDRUHPA_nk34label | M
Stavový řádek | Stavový řádek hodnoty | NKDRUHPA_nk34status | M
Validace | Validace hodnoty | NKDRUHPA_nk34valid | M
Chyb.hlášení | Chybové hlášení | NKDRUHPA_nk34error | M
Délka | Délka numerické hodnoty | NKDRUHPA_nk34len | N(3)
Desetiny | Desetiny numerické hodnoty | NKDRUHPA_nk34dec | N(1)

    Při pohybu v Popis referenčních hodnot
Návěští | Návěští referenční hodnoty | NKDRUHPI_nk38label | C(30)
Délka | Délka numerické hodnoty | NKDRUHPI_nk38len | N(3)
Desetiny | Desetiny numerické hodnoty | NKDRUHPI_nk38dec | N(1)

    Při pohybu v Spojená pravidla podmínky
Pravidlo podmínky | Identifikace pravidla | NKPLNDRH_nk26id | C(6)
Implicitní | Implicitní pro pravidlo výše | Výpočet | C(3)
Pořadí | Pořadí pravidla smlouvy | NKPLNDRH_nk61porad | N(3)

    Při pohybu v Spojená pravidla splatnosti
Pravidlo splatnosti | Identifikace pravidla | NKPLNDRH2_nk26id | C(6)
Implicitní | Implicitní pro pravidlo výše | Výpočet | C(3)
Pořadí | Pořadí pravidla smlouvy | NKPLNDRH2_nk61porad | N(3)

    Viz.také

    Modifikace kódu pravidla | Modifikace kódu poznámky | Měny a kursy | SQL dotazy pro pravidla smluv


SQL dotazy pro pravidla smluv

Popis

V této činnosti se definují SQL dotazy využívané při výpočtu plnění položek smluv v kódech pravidel výše, podmínky, splatnosti a agregace.

Ve výrazech je možné používat proměnné:

¨ _sp61id - druh artiklu

¨ _sp60id - artikl

¨ _nk01verze - verze předmětu projektu

¨ _nk27porad - pořadové číslo položky smlouvy v rámci předmětu projektu

¨ _nk27datum - datum vzniku položky smlouvy

¨ _datump - datum plnění

Ve výrazu je možné také používat makra uvedená znakem ampersand (tj. &).

Příklad:

<<pre>>

select sum(OBCENIK.ob03cj02*nkhodnp.nk13num1) from %%%.nkhodnp,%%%.obcenik where

&_wrk60id AND nkhodnp.sp61id=?_sp61id AND nk05id='MSV000' AND

nk13dat1 BETWEEN ?_wrkd1 AND ?_wrkd2 and

obcenik.ob11id='ODB'
and obcenik.oc01id='CZK' and obcenik.sp61id=nkhodnp.sp61id and
obcenik.sp60id=nkhodnp.sp60id and

obcenik.ob12id=(select
max(obcenobd.ob12id) from %%%.obcenobd
where obcenobd.ob11id=obcenik.ob11id and

nkhodnp.nk13dat1 between obcenobd.ob12datum and obcenobd.ob12datumd)

<</pre>>

Datový model

  • NKDOTSQL Dotaz SQL pro pravidlo závazku

    • Formulář

    Formulář činnosti - Kontrolní kompilace
Mřížka [SQL dotazy]
Dotaz | Identifikace SQL dotazu
Název SQL dotazu | Název SQL dotazu
SQL | SQL dotaz
Poznámka | Poznámka

    Mřížka [SQL dotazy] činnosti - Kontrolní kompilace

    Mřížka [SQL dotazy] činnosti - Kontrolní kompilace
Dotaz | Identifikace SQL dotazu
Název SQL dotazu | Název SQL dotazu

    Atributy tisku

    Základní údaje
Dotaz | Identifikace SQL dotazu | NKDOTSQL_nk29id | C(6)
Název SQL dotazu | Název SQL dotazu | NKDOTSQL_nk29nazvyr | C(40)
SQL | SQL dotaz | NKDOTSQL_nk29dotaz | M
Poznámka | Poznámka | NKDOTSQL_nk29koment | M


Role aktérů smluv

Popis

Definuje role, ve kterých vystupují jednotliví aktéři na položkách smluv.

Datový model

  • NKROLE Role aktéra

    • Formulář

    Formulář činnosti - Číselník hodnot parametrů
Mřížka [Role]
Role | Identifikace role aktéra
Název role | Název role aktéra
Poznámka | Poznámka

    Mřížka [Role] činnosti - Číselník hodnot parametrů

    Mřížka [Role] činnosti - Číselník hodnot parametrů
Role | Identifikace role aktéra
Název role | Název role aktéra

    Atributy tisku

    Základní údaje
Role | Identifikace role aktéra | NKROLE_nk25id | C(6)
Název role | Název role aktéra | NKROLE_nk25nazrol | C(40)
Poznámka | Poznámka | NKROLE_nk25koment | M


Parametry smluv

Popis

Činnost parametry smluv obsahuje následující definice:

¨ prog. – název programu, který se po ukončení výpočtu smluv spustí

¨ validace OBARTIKL – volba Ano/Ne – zda validovat existenci artiklu obchodu při vstupu položky smlouvy

¨ k jakému datu vyhodnocovat periodu – volba datum plnění (implicitní) nebo termín smlouvy. Při výpočtu plnění smluv se na výběrové záložce zadává datum, ke kterému se smlouvy vyhodnocují. V této činnosti může být nastavena možnost „datum plnění“ (toto datum se následně v události smluv zobrazuje jako datum vyhodnocení) nebo možnost „termín smlouvy“ (program vyhodnotí a zapíše do událostí datum dalšího plnění podle periody).

Formulář

Formulář činnosti - Kontrolní kompilace
Prog. | Po ukončení výpočtu vyvolat program
Validace OBARTIKL | Validovat existenci artiklu obchodu při vstupu položky smlouvy


Číselné řady pořadí položek smluv

Popis

Tato činnost umožňuje uživateli definovat si pro jednotlivá datová úložiště číselné řady, které následně určují pořadí nově zakládané položky smlouvy. Uživatel definuje:

¨ IDÚ – identifikaci datového úložiště

¨ Od – pořadí smlouvy Od

¨ Do – pořadí smlouvy Do

Datový model

  • NKSMLRAD Číselná řada smluv

    • Formulář

    Formulář činnosti - Kontrolní kompilace
Mřížka [Číselné řady]
IDÚ | Identifikace datového úložiště
Od | Pořadí smlouvy OD
Do | Pořadí smlouvy DO
Poznámka | Poznámka

    Mřížka [Číselné řady] činnosti - Kontrolní kompilace

    Mřížka [Číselné řady] činnosti - Kontrolní kompilace
IDÚ | Identifikace datového úložiště
Od | Pořadí smlouvy OD
Do | Pořadí smlouvy DO
Poznámka | Poznámka

    Atributy tisku

    Základní údaje
IDÚ | Identifikace datového úložiště | NKSMLRAD_nk93idu | C(2)
Od | Pořadí smlouvy OD | NKSMLRAD_nk93porad1 | C(3)
Do | Pořadí smlouvy DO | NKSMLRAD_nk93porad2 | C(3)
Poznámka | Poznámka | NKSMLRAD_nk93koment | M


O ŘÍZENÍ PROJEKTU

Popis

Jedná se o skupinové menu, které v sobě soustřeďuje veškeré činnosti, které jsou nutné k řízení projektu (od definice projektových úkolů, harmonogramy plnění po parametry projektového řízení).

Viz.také

Projektové úkoly | Plnění projektových úkolů | Harmonogram projektových úkolů | Harmonogram plnění úkolů | Aktuální hodnoty proj.úkolů | Aktuální hodnoty plnění úkolů | NASTAVENÍ O ŘÍZENÍ PROJEKTU


Projektové úkoly

Popis

Při vstupu nového projektového úkolu se obsah překryvného seznamu zadavatele dynamicky mění podle zadaného druhu projektového úkolu a obsah překryvného seznamu řešitele se dynamicky mění podle zadaného druhu projektového úkolu a zadavatele (viz. druhy projektových úkolů).

Jinak činnost Projektové úkoly podle nastaveného výběru (záložka Výběr) poskytuje uživateli informace o jednotlivých projektových úkolech a jejich stavech, včetně termínů, popisu vlastního úkolu, druhu, zadavatele, řešitele apod.

Záložka Další poskytuje uživateli podrobnější informace daného projektového úkolu. K dispozici jsou atributy:

¨ plán. náklady

¨ % - procento realizované plněním úkolů

¨ real. náklady – výše realizovaných nákladů a datum poslední aktualizace realizovaných nákladů

¨ fixovat – možnosti jsou Ne, Zahájení, Ukončení. Při plánování úkolu je možno pro jeho zahájení nebo ukončení fixovat datum, kdy by tato skutečnost podle plánu měla nastat.

¨ priorita

¨ pořadí – pořadí úkolu v rámci operace

¨ sada – identifikátor sady parametrů, které se proj. úkol týká (výběr z číselníku)

¨ změna stavu předmětu projektu – nastavení, zda má dojít ke změně stavu předmětu projektu při ukončení úkolu. Možnosti jsou

¨ zpráva při změně zahájení – nastavení, zda odeslat zprávu vedoucímu projektu při změně data zahájen

¨ zpráva při změně ukončení – nastavení, zda odeslat zprávu vedoucímu projektu při změně data ukončení

Záložka Připomenutí umožňuje nastavit uživateli (sám sobě a nebo i pro jiného uživatele) k danému projektovému úkolu libovolné připomenutí. Jako zapsal se předplní aktuální uživatel, přijal je výběr uživatele z překryvného seznamu. V atributu čas se předplní aktuální datum, text je popis úkolu a pak je možno vložit libovolnou poznámku do atributu komentář.

Záložka Hosté umožňuje uvést jako „hosta“ k danému projektovému úkolu i uživatele, který k danému projektovému úkolu nemá přístupové právo, tudíž se potom může podílet na jeho plnění.

Záložka Plnění úkolu poskytuje informace o jednotlivých provedených plnění úkolu. Kdo, kdy, kolik času, popis.

Aktuálním uživateli jsou zobrazovány projektové úkoly pokud má:

¨ právo přístupu k druhu operace alespoň čtení

¨ právo přístupu k druhu projektového úkolu alespoň čtení

¨ právo přístupu k zadavateli alespoň čtení

¨ právo přístupu k řešiteli alespoň čtení

Datový model

  • NKUKOL Projektový úkol
    • PAOBJDRU Klasifikace objektu
    • SPPRISTU Přístupové právo uživatele k věci
    • NKUKOLD Druh projektového úkolu
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)
    • NKZDROJZ Zadavatel úkolu
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU5)
    • PASADA Sada parametrů
    • BWUZIVAT Uživatel systému
    • SPPRCOD Operace procesu
      • SPPRC Proces
      • SPTYP Druh procesu/operace
    • ADADSAT Adresát
    • NKPREDPR Předmět projektu
    • NKZDROJ Řešitel projektového úkolu
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU6)
    • SPARTIKN Název artiklu

    • Formulář

    Formulář činnosti - Potvrzení zprávy
Mřížka [Projektové úkoly]
Listovací rámeček
Stránka #1 Úkoly
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Název druhu operace
Stav | Stav projektového úkolu
Termín | Datum zahájení
Čas zahájení | Čas zahájení
Dnů | Časová náročnost ve dnech
Ukončení | Datum ukončení
Čas ukončení | Čas ukončení
% | Procento plnění
Druh artiklu | Identifikace druhu artiklu
Úkol | Identifikace artiklu
Verze | Verze projektu
IDÚ úkolu | Identifikace datového úložiště úkolu
Poř. | Pořadí v rámci úkolů předmětu projektu
Název artiklu | Název artiklu
Adresát | Identifikace adresáta
 | Název adresáta
Druh | Identifikátor druhu úkolů
Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu
Řešitel | Identifikace řešitele
Popis | Popis úkolu
Poznámka | Poznámka k projektovému úkolu
Klasifikace | Identifikace klasifikace objektu
Název klasifikace objektu | Název klasifikace objektu
Selektory | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Stránka #2 Další
Plán.náklady | Výše plánovaných nákladů
% | Procento realizované plněním úkolů
Real.náklady | Výše realizovaných nákladů
Aktualizace | Datum poslední aktualizace realizovaných nákladů
Fixovat | Fixování - Ne,Zahájení,Ukončení - při plánování úkolu
Ke dni | Fixované datum zahájení nebo ukončení
Změna stavu předmětu projektu | Změna stavu předmětu projektu při ukončení úkolu
Zpráva při změně zahájení | Odeslat zprávu vedoucímu projektu při změně data zahájen
Zpráva při změně ukončení | Odeslat zprávu vedoucímu projektu při změně data ukončení
Priorita | Priorita projektového úkolu
Pořadí | Pořadí úkolu v rámci operace
Sada | Identifikátor sady parametrů
Název sady | Název sady parametrů
Další poznámka | Další poznámka zadavatele k úkolu
Založil | Jméno uživatele systému
Datum a čas zápisu | Datum a čas zápisu záznamu události
Stránka #3 Připomenutí
Mřížka [Připomenutí]
Zapsal | Jméno uživatele systému
Přijal | Identifikace uživatele systému
Čas | Datum a čas připomenutí
Text | Text výstižně popisující zprávu
Komentář | Komentář autora zprávy.
Potvrzení zprávy
Stránka #4 Hosté
Mřížka [Hosté úkolu]
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Poznámka | Poznámka
Stránka #5 Zařazení do úkolů
Mřížka [Zařazení do úkolů]
Stránka #6 Plnění úkolu
Mřížka [Plnění úkolu]
Jméno řešitele | Jméno řešitele
Řešitel | Identifikace řešitele
 | Název adresáta
Adresát | Identifikace adresáta
Název druhu | Název druhu plnění úkolu projektového řízení
Pln.druh | Identifikace druhu plnění úkolu projektového řízení
Datum | Datum plnění projektového úkolu
Hodin | Čerpání času řešitele v hodinách
% | Přírůstek procenta plnění
Popis | Popis plnění projektového úkolu
Poznámka | Poznámka k plnění projektového úkolu
Stránka #7 Parametry úkolu
Mřížka [Hodnoty parametrů]
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Identifikátor spojení na bankovní účet adresáta.
 | Název adresáta
ID | Identifikace položky číselníku
 | Název položky číselníku
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Text1 | Textová elementární hodnota
Dat1 | Datumová elementární hodnota 1
Dat2 | Datumová elementární hodnota 2
Num1 | Numerická elementární hodnota 1
Num2 | Numerická elementární hodnota 2
Cmb1 | Překryvný seznam elementární hodnota 1
Cmb2 | Překryvný seznam elementární hodnota 2
Poznámka | Poznámka
Platnost od | Platnost od
do | Platnost do
Stránka #8 Historie
Mřížka [Historie]
Zapsal | Jméno uživatele systému
Datum a čas zápisu | Datum a čas zápisu záznamu události
Popis změny | Popis změny úkolu
Stránka #9 Výběr
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Číslo procesu do | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Druh procesu | Identifikátor druhu procesu
Zahájení | Datum zahájení
do | Datum zahájení do
Ukončení | Datum ukončení
do | Datum ukončení do
Stav | Stav projektového úkolu
Typ | Typ úkolu - složený=je složen z více úkolů
Popis | Popis úkolu
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Druh artiklu | Identifikace druhu artiklu
Úkol | Identifikace artiklu
Verze | Verze projektu
IDÚ úkolu | Identifikace datového úložiště úkolu
Poř. | Pořadí v rámci úkolů předmětu projektu
Název artiklu | Název artiklu
Druh | Identifikátor druhu úkolů
Název druhu úkolu | Název druhu úkolu
Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu
Jméno zadavatele | Jméno zadavatele projektového úkolu nebo plnění projektového úkolu
Řešitel | Zaškrtnuté vybere řešitele úkolované skupinou řešitelů
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Klasifikace | Identifikace klasifikace objektu
Název klasifikace objektu | Název klasifikace objektu
Sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Zapsané | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Projektové úkoly] činnosti - Potvrzení zprávy

    Mřížka [Projektové úkoly] činnosti - Potvrzení zprávy
Označování | Označení záznamu
Stav | Stav projektového úkolu
Zahájení | Datum zahájení
Čas | Čas zahájení
Ukončení | Datum ukončení
Čas | Čas ukončení
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název druhu úkolu | Název druhu úkolu
Popis | Popis úkolu
Verze | Verze projektu
IDÚ úkolu | Identifikace datového úložiště úkolu
Poř. | Pořadí v rámci úkolů předmětu projektu
Název předmětu projektu | Název artiklu
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Plán.náklady | Výše plánovaných nákladů
Real.náklady | Výše realizovaných nákladů
Aktualizace | Datum poslední aktualizace realizovaných nákladů
Typ | Typ úkolu - složený=je složen z více úkolů
Druh | Identifikátor druhu úkolů
Pořadí | Pořadí úkolu v rámci operace
Priorita | Priorita projektového úkolu
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Mřížka [Připomenutí] činnosti - Potvrzení zprávy

    Mřížka [Připomenutí] činnosti - Potvrzení zprávy
S | Stav zpracování zprávy
Čas | Datum a čas připomenutí
Text | Text výstižně popisující zprávu
Přijetí | Datum přijetí zprávy.
Zpracování | Datum zpracování zprávy.

    Mřížka [Hosté úkolu] činnosti - Potvrzení zprávy

    Mřížka [Hosté úkolu] činnosti - Potvrzení zprávy
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele

    Mřížka [Zařazení do úkolů] činnosti - Potvrzení zprávy

    Mřížka [Zařazení do úkolů] činnosti - Potvrzení zprávy
Stav | Stav projektového úkolu
Zahájení | Datum zahájení
Ukončení | Datum ukončení
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Verze | Verze projektu
Poř. | Pořadí v rámci úkolů předmětu projektu
Název artiklu | Název artiklu
Popis | Popis úkolu
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace

    Mřížka [Plnění úkolu] činnosti - Potvrzení zprávy

    Mřížka [Plnění úkolu] činnosti - Potvrzení zprávy
Datum | Datum plnění projektového úkolu
Popis | Popis plnění projektového úkolu
Jméno řešitele | Jméno řešitele
Název druhu | Název druhu plnění úkolu projektového řízení
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Operace | Identifikátor druhu operace

    Mřížka [Hodnoty parametrů] činnosti - Potvrzení zprávy

    Mřížka [Hodnoty parametrů] činnosti - Potvrzení zprávy
Název parametru | Název parametru
Hodnota parametru | Hodnota parametru
Platnost od | Platnost od
do | Platnost do

    Mřížka [Historie] činnosti - Potvrzení zprávy

    Mřížka [Historie] činnosti - Potvrzení zprávy
Datum a čas zápisu | Datum a čas zápisu záznamu události
Zapsal | Jméno uživatele systému

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Plnění projektových úkolů | Plnění projektových úkolů
F6 | Přepočet projektového úkolu | Přepočet projektového úkolu
F7 | Diagram projektového úkolu | Diagram složeného projektového úkolu
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
- | Aplikovat generický úkol | Aplikovat generický úkol
- | Přijetí zprávy | Potvrzení přijetí aktuální zprávy.
- | Potvrzení zprávy | Potvrzení zpracování aktuální zprávy.
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Druhy projektových úkolů | Druhy projektových úkolů
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Klasifikace objektů | Klasifikace objektů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Předmět projektu | Seznam předmětů projektu
F2 | Sady parametrů | Sady parametrů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Řešitelé projektových úkolů | Řešitelé projektových úkolů

    Atributy tisku

    Základní údaje
Rok | Rok v identifikaci procesu | NKUKOL_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | NKUKOL_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | NKUKOL_sp33cisd | C(8)
Operace | Identifikátor druhu operace | NKUKOL_sp07idtyp | C(6)
Název druhu operace | Název druhu operace | SPTYP_sp07text | C(30)
Druh | Identifikátor druhu úkolů | NKUKOL_nk53id | C(6)
Název druhu úkolu | Název druhu úkolu | NKUKOLD_nk53nazdru | C(40)
Priorita | Priorita projektového úkolu | NKUKOL_nk43prior | N(2)
Artikl | Identifikace artiklu | NKUKOL_sp60id | C(13)
Druh artiklu | Identifikace druhu artiklu | NKUKOL_sp61id | C(3)
Verze | Verze projektu | NKUKOL_nk01verze | C(3)
IDÚ úkolu | Identifikace datového úložiště úkolu | NKUKOL_nk43idu | C(2)
Poř. | Pořadí v rámci úkolů předmětu projektu | NKUKOL_nk43porad | C(6)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu | NKUKOL_nk42id | C(6)
Jméno zadavatele | Jméno zadavatele projektového úkolu nebo plnění projektového úkolu | NKZDROJZ_nk42nazzad | C(40)
Řešitel | Identifikace řešitele | NKUKOL_nk44id | C(6)
Jméno řešitele | Jméno řešitele | NKZDROJ_nk44nazzdr | C(40)
Adresát | Identifikace adresáta | NKUKOL_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Klasifikace | Identifikace klasifikace objektu | NKUKOL_pa13id | C(12)
Název klasifikace objektu | Název klasifikace objektu | PAOBJDRU_pa13nazdru | C(40)
Stav | Stav projektového úkolu | Výpočet | C(11)
Zahájení | Datum zahájení | NKUKOL_nk43datz | D
Čas zahájení | Čas zahájení | NKUKOL_nk43casz | C(4)
Ukončení | Datum ukončení | NKUKOL_nk43datu | D
Čas ukončení | Čas ukončení | NKUKOL_nk43casu | C(4)
Popis | Popis úkolu | NKUKOL_nk43text | C(40)
Dnů | Časová náročnost ve dnech | NKUKOL_nk43dennar | N(8,2)
% | Procento plnění | NKUKOL_nk43procpl | N(6,2)
Plán.náklady | Výše plánovaných nákladů | NKUKOL_nk43nakpla | N(20,4)
Real.náklady | Výše realizovaných nákladů | NKUKOL_nk43nakrea | N(20,4)
Aktualizace | Datum poslední aktualizace realizovaných nákladů | NKUKOL_nk43datarn | D
Poznámka | Poznámka k projektovému úkolu | NKUKOL_nk43koment | M
Další poznámka | Další poznámka zadavatele k úkolu | NKUKOL_nk43komen2 | M
Obch. sel. | Identifikátor obchodního selektoru | NKUKOL_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | NKUKOL_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | NKUKOL_sp20idzak | C(9)
Stav | Stav projektu (uvažovaný, zahájený,...) | Výpočet | C(12)
Fixovat | Fixování - Ne,Zahájení,Ukončení - při plánování úkolu | Výpočet | C(8)
Den fixování | Fixované datum zahájení nebo ukončení | NKUKOL_nk43datfix | D
Zpráva při změně zahájení | Odeslat zprávu vedoucímu projektu při změně data zahájen | Výpočet | C(3)
Zpráva při změně ukončení | Odeslat zprávu vedoucímu projektu při změně data ukončení | Výpočet | C(3)
Datum a čas zápisu | Datum a čas zápisu záznamu události | NKUKOL_sp00datzap | T
Název druhu | Název druhu plnění úkolu projektového řízení | NKUKOPD_nk70nazdru | C(40)
Jméno řešitele | Jméno řešitele | NKZDROJ5_nk44nazzdr | C(40)
Název adresáta | Název adresáta | ADADSAT4_ad01adsat | C(100)
Zapsal | Jméno uživatele systému | BWUZIVA4_bw01jmeno | C(30)

    Při pohybu v Historie
Popis změny | Popis změny úkolu | NKUKOLH_nk69zmena | M
Datum a čas zápisu | Datum a čas zápisu záznamu události | NKUKOLH_sp00datzap | T

    Při pohybu v Plnění úkolů
Pln.druh | Identifikace druhu plnění úkolu projektového řízení | NKUKOLP_nk70id | C(6)
Řešitel | Identifikace řešitele | NKUKOLP_nk44id | C(6)
Adresát | Identifikace adresáta | NKUKOLP_ad01id | C(6)
Datum | Datum plnění projektového úkolu | NKUKOLP_nk62datum | D
Popis | Popis plnění projektového úkolu | NKUKOLP_nk62text | C(40)
Hodin | Čerpání času řešitele v hodinách | NKUKOLP_nk62hodin | N(7,2)
Dnů | Čerpání času zdroje ve dnech | NKUKOLP_nk62dnu | N(6,2)
% | Přírůstek procenta plnění | NKUKOLP_nk62procpl | N(6,2)
Poznámka | Poznámka k plnění projektového úkolu | NKUKOLP_nk62koment | M
Obch. sel. | Identifikátor obchodního selektoru | NKUKOLP_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | NKUKOLP_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | NKUKOLP_sp20idzak | C(9)

    Při pohybu v Hosté úkolu
Řešitel | Identifikace řešitele | NKUKOLRH_nk44id | C(6)
Poznámka | Poznámka | NKUKOLRH_nk86koment | M

    Při pohybu v Hosté úkolu
    Jméno řešitele Jméno řešitele NKZDROJ6_nk44nazzdr C(40)

    Viz.také

    Plnění projektových úkolů | Přepočet projektového úkolu | Diagram projektového úkolu | OZNAČOVÁNÍ | Prezentace artiklu | Aplikovat generický úkol | Přijetí zprávy | Potvrzení zprávy | Adresář | Druhy artiklů | Druhy operací | Druhy procesů | Druhy projektových úkolů | Kategorie adresátů | Klasifikace objektů | Obchodní selektor | Organizační selektor | Předmět projektu | Sady parametrů | Technicko-věcný selektor | Řešitelé projektových úkolů


Plnění projektových úkolů

Popis

Projektové úkoly se v této činnosti nevstupují samostatně, jedná se o procesní zpracování. Daná činnost poskytuje uživateli v podstatě již jenom přehled provedených plnění projektových úkolů.

Aktuálním uživateli jsou zobrazována plnění projektových úkolů, ke kterým má:

¨ právo přístupu k druhu operace alespoň čtení

¨ právo přístupu k druhu projektového úkolu alespoň čtení

¨ právo přístupu k druhu plnění projektového úkolu alespoň čtení

¨ právo přístupu k řešiteli alespoň čtení

Datový model

  • NKUKOLP Plnění projektového úkolu
    • SPPRISTU Přístupové právo uživatele k věci
    • ADADSAT Adresát
    • BWUZIVAT Uživatel systému
    • NKUKOL Projektový úkol
      • SPARTIKN Název artiklu
      • NKUKOLD Druh projektového úkolu
        • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU5)
      • NKZDROJZ Zadavatel úkolu
        • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU6)
      • PAOBJDRU Klasifikace objektu
    • SPPRCOD Operace procesu
      • SPTYP Druh procesu/operace
      • SPPRC Proces
    • NKUKOPD Druh plnění projektového úkolu
    • NKZDROJ Řešitel projektového úkolu
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)

    • Formulář

    Formulář činnosti - Změna stavu plnění úkolu
Mřížka [Plnění úkolů]
Listovací rámeček
Stránka #1 Plnění úkolů
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Název druhu operace
Druh | Identifikace druhu artiklu
Úkol | Identifikace artiklu
Verze | Verze projektu
IDÚ úkolu | Identifikace datového úložiště úkolu
Poř. | Pořadí v rámci úkolů předmětu projektu
Název artiklu | Název artiklu
Druh | Název druhu úkolu
Popis | Popis úkolu
Zadav. | Jméno zadavatele projektového úkolu nebo plnění projektového úkolu
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Adresát | Identifikace adresáta
 | Název adresáta
Pln.druh | Identifikace druhu plnění úkolu projektového řízení
Datum | Datum plnění projektového úkolu
Hodin | Čerpání času řešitele v hodinách
Dnů | Čerpání času zdroje ve dnech
Popis | Popis plnění projektového úkolu
Pozn. | Poznámka k plnění projektového úkolu
Kateg. | Kategorie plnění projektového úkolu
% | Přírůstek procenta plnění
Sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Založil | Jméno uživatele systému
Datum a čas zápisu | Datum a čas zápisu záznamu události
Stránka #2 Popis úkolu
Stav | Stav projektového úkolu
Termín | Datum zahájení
Čas zahájení | Čas zahájení
Ukončení | Datum ukončení
Čas ukončení | Čas ukončení
Dnů | Časová náročnost ve dnech
% | Procento plnění
Druh | Název druhu úkolu
Zadavatel | Jméno zadavatele projektového úkolu nebo plnění projektového úkolu
Řešitel | Jméno řešitele
Popis | Popis úkolu
Poznámka | Poznámka k projektovému úkolu
Klasifikace | Identifikace klasifikace objektu
Název klasifikace objektu | Název klasifikace objektu
Stránka #3 Výběr
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Číslo procesu do | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Druh procesu | Identifikátor druhu procesu
Datum | Datum plnění projektového úkolu
do | Datum plnění do
Stav | Stav projektového úkolu
Typ | Typ úkolu - složený=je složen z více úkolů
Druh artiklu | Identifikace druhu artiklu
Úkol | Identifikace artiklu
Verze | Verze projektu
IDÚ úkolu | Identifikace datového úložiště úkolu
Poř. | Pořadí v rámci úkolů předmětu projektu
Název artiklu | Název artiklu
Popis | Popis plnění projektového úkolu
Druh | Identifikátor druhu úkolů
Název druhu úkolu | Název druhu úkolu
Pln.druh | Identifikace druhu plnění úkolu projektového řízení
Název druhu | Název druhu plnění úkolu projektového řízení
Stav pln. | Stav plnění úkolu - Nestornované/Stornované
Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu
Jméno zadavatele | Jméno zadavatele projektového úkolu nebo plnění projektového úkolu
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Klasif. | Identifikace klasifikace objektu
Název klasifikace objektu | Název klasifikace objektu
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Změna s. | Události, které způsobily změna stavu projektového úkolu
Kateg. | Kategorie plnění projektového úkolu
Sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Zapsané | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Plnění úkolů] činnosti - Změna stavu plnění úkolu

    Mřížka [Plnění úkolů] činnosti - Změna stavu plnění úkolu
Označování | Označení záznamu
Datum | Datum plnění projektového úkolu
Jméno řešitele | Jméno řešitele
Hodin | Čerpání času řešitele v hodinách
Dnů | Čerpání času zdroje ve dnech
Název předmětu projektu | Název artiklu
Název druhu úkolu | Název druhu úkolu
Popis | Popis plnění projektového úkolu
Stav plnění | Stav plnění úkolu - Nestornované/Stornované
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Verze | Verze projektu
Poř. | Pořadí v rámci úkolů předmětu projektu
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Řešitel | Identifikace řešitele
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Priorita | Priorita projektového úkolu

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Projektové úkoly | Projektové úkoly
F7 | Diagram projektového úkolu | Diagram složeného projektového úkolu
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Změna stavu plnění úkolu | Změna stavu plnění úkolu
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy plnění proj.úkolů | Druhy plnění projektových úkolů
F2 | Druhy procesů | Přehled druhů procesů
F2 | Druhy projektových úkolů | Druhy projektových úkolů
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Klasifikace objektů | Klasifikace objektů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Projektové úkoly | Projektové úkoly
F2 | Předmět projektu | Seznam předmětů projektu
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Řešitelé projektových úkolů | Řešitelé projektových úkolů

    Atributy tisku

    Základní údaje
Rok | Rok v identifikaci procesu | NKUKOLP_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | NKUKOLP_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | NKUKOLP_sp33cisd | C(8)
Operace | Identifikátor druhu operace | NKUKOLP_sp07idtyp | C(6)
Datum | Datum plnění projektového úkolu | NKUKOLP_nk62datum | D
Popis | Popis plnění projektového úkolu | NKUKOLP_nk62text | C(40)
Kateg. | Kategorie plnění projektového úkolu | Výpočet | C(1)
Řešitel | Identifikace řešitele | NKUKOLP_nk44id | C(6)
Jméno řešitele | Jméno řešitele | NKZDROJ_nk44nazzdr | C(40)
Hodin | Čerpání času řešitele v hodinách | NKUKOLP_nk62hodin | N(7,2)
Dnů | Čerpání času zdroje ve dnech | NKUKOLP_nk62dnu | N(6,2)
% | Přírůstek procenta plnění | NKUKOLP_nk62procpl | N(6,2)
Druh artiklu | Identifikace druhu artiklu | NKUKOLP_sp61id | C(3)
Artikl | Identifikace artiklu | NKUKOLP_sp60id | C(13)
Verze | Verze projektu | NKUKOLP_nk01verze | C(3)
IDÚ úkolu | Identifikace datového úložiště úkolu | NKUKOLP_nk43idu | C(2)
Poř. | Pořadí v rámci úkolů předmětu projektu | NKUKOLP_nk43porad | C(6)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Stav | Stav projektového úkolu | Výpočet | C(11)
Zahájení | Datum zahájení | NKUKOL_nk43datz | D
Ukončení | Datum ukončení | NKUKOL_nk43datu | D
Priorita | Priorita projektového úkolu | NKUKOL_nk43prior | N(2)
Plán.náklady | Výše plánovaných nákladů | NKUKOL_nk43nakpla | N(20,4)
Real.náklady | Výše realizovaných nákladů | NKUKOL_nk43nakrea | N(20,4)
Aktualizace | Datum poslední aktualizace realizovaných nákladů | NKUKOL_nk43datarn | D
Poznámka úkolu | Poznámka k projektovému úkolu | NKUKOL_nk43koment | M
Druh | Identifikátor druhu úkolů | NKUKOL_nk53id | C(6)
Název druhu úkolu | Název druhu úkolu | NKUKOLD_nk53nazdru | C(40)
Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu | NKUKOL_nk42id | C(6)
Jméno zadavatele | Jméno zadavatele projektového úkolu nebo plnění projektového úkolu | NKZDROJZ_nk42nazzad | C(40)
Pln.druh | Identifikace druhu plnění úkolu projektového řízení | NKUKOLP_nk70id | C(6)
Název druhu | Název druhu plnění úkolu projektového řízení | NKUKOPD_nk70nazdru | C(40)
Stav plnění | Stav plnění úkolu - Nestornované/Stornované | Výpočet | C(12)
Klasifikace | Identifikace klasifikace objektu | NKUKOL_pa13id | C(12)
Název klasifikace objektu | Název klasifikace objektu | PAOBJDRU_pa13nazdru | C(40)
Adresát | Identifikace adresáta | NKUKOLP_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Obch. sel. | Identifikátor obchodního selektoru | NKUKOLP_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | NKUKOLP_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | NKUKOLP_sp20idzak | C(9)
Poznámka plnění | Poznámka k plnění projektového úkolu | NKUKOLP_nk62koment | M
Datum a čas zápisu | Datum a čas zápisu záznamu události | NKUKOLP_sp00datzap | T

    Viz.také

    Diagram projektového úkolu | OZNAČOVÁNÍ | Změna stavu plnění úkolu | Adresář | Druhy artiklů | Druhy operací | Druhy plnění proj.úkolů | Druhy procesů | Druhy projektových úkolů | Kategorie adresátů | Klasifikace objektů | Obchodní selektor | Organizační selektor | Projektové úkoly | Předmět projektu | Technicko-věcný selektor | Řešitelé projektových úkolů | Šablona - plnění proj. úkolu


Harmonogram projektových úkolů

Popis

Podle nastavených údajů na záložce výběr (datum od – do, předmět, druh, zadavatel, řešitel, adresát apod.) se uživateli automaticky nabízí graficky zpracovaný harmonogram přehledu projektových úkolů. Při kliknutí na jakékoliv políčko v harmonogramu se uživateli nabízí podrobné informace k zadanému projektovému úkolu. Jednotlivé projektové úkoly lze v harmonogramu přesouvat (metoda „táhni a drž“). Zapsání změn se provede po stisku klávesy F5 (činnost „zapsat změny harmonogramu).

Datový model

  • NKUKOL Projektový úkol
    • PAOBJDRU Klasifikace objektu
    • NKUKOLD Druh projektového úkolu
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)
    • NKZDROJ Řešitel projektového úkolu
      • SPPRISTU Přístupové právo uživatele k věci
    • SPPRCOD Operace procesu
      • SPTYP Druh procesu/operace
    • SPARTIKN Název artiklu
    • ADADSAT Adresát
    • NKZDROJZ Zadavatel úkolu
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU3)

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Zapsat změny harmonogramu |
F7 | Diagram projektového úkolu | Diagram složeného projektového úkolu
F9 | Spustit operaci | Spuštění zobrazené operace
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy projektových úkolů | Druhy projektových úkolů
F2 | Klasifikace objektů | Klasifikace objektů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Předmět projektu | Seznam předmětů projektu
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Řešitelé projektových úkolů | Řešitelé projektových úkolů

    Formulář

    Formulář činnosti - Klasifikace objektů
Mřížka [Projektové úkoly]
Listovací rámeček
Stránka #1 Projektové úkoly
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Stav | Stav projektového úkolu
Název druhu operace | Název druhu operace
Termín | Datum zahájení
Čas zahájení | Čas zahájení
Ukončení | Datum ukončení
Čas ukončení | Čas ukončení
Dnů | Časová náročnost ve dnech
% | Procento plnění
Druh artiklu | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
IDÚ úkolu | Identifikace datového úložiště úkolu
Poř. | Pořadí v rámci úkolů předmětu projektu
Název artiklu | Název artiklu
Název druhu úkolu | Název druhu úkolu
Druh | Identifikátor druhu úkolů
Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu
Jméno zadavatele | Jméno zadavatele projektového úkolu nebo plnění projektového úkolu
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Popis | Popis úkolu
Pozn. | Poznámka k projektovému úkolu
Klasifikace | Identifikace klasifikace objektu
Název klasifikace objektu | Název klasifikace objektu
Adresát | Identifikace adresáta
 | Název adresáta
Stránka #2 Výběr
Den | Den kalendáře
do | Den kalendáře do
Druh | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
Název předmětu projektu | Název artiklu
Druh | Identifikátor druhu úkolů
Název druhu úkolu | Název druhu úkolu
Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu
Jméno zadavatele | Jméno zadavatele projektového úkolu nebo plnění projektového úkolu
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Klasifikace | Identifikace klasifikace objektu
Název klasifikace objektu | Název klasifikace objektu
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Selektory | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Projektové úkoly] činnosti - Klasifikace objektů

    Mřížka [Projektové úkoly] činnosti - Klasifikace objektů
Stav | Stav projektového úkolu
Zahájení | Datum zahájení
Ukončení | Datum ukončení
Dnů | Časová náročnost ve dnech
Druh artiklu | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
IDÚ úkolu | Identifikace datového úložiště úkolu
Poř. | Pořadí v rámci úkolů předmětu projektu
Název druhu úkolu | Název druhu úkolu
Popis | Popis úkolu
Název artiklu | Název artiklu
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Název druhu operace | Název druhu operace
Druh | Identifikátor druhu úkolů
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Adresát | Identifikace adresáta
Název adresáta | Název adresáta

    Viz.také

    Zapsat změny harmonogramu | Diagram projektového úkolu | Spustit operaci | Adresář | Druhy artiklů | Druhy projektových úkolů | Klasifikace objektů | Obchodní selektor | Organizační selektor | Předmět projektu | Technicko-věcný selektor | Řešitelé projektových úkolů


Harmonogram plnění úkolů

Popis

Podle nastavených údajů na záložce výběr (datum od – do, předmět, druh, řešitel, adresát apod.) se uživateli automaticky nabízí graficky zpracovaný harmonogram plnění úkolů. Při kliknutí na jakékoliv políčko v harmonogramu se uživateli nabízí podrobné informace k zadanému plnění úkolu.

Datový model

  • NKUKOLP Plnění projektového úkolu
    • NKUKOL Projektový úkol
      • NKUKOLD Druh projektového úkolu
        • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)
      • SPARTIKN Název artiklu
      • NKZDROJZ Zadavatel úkolu
        • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU3)
      • PAOBJDRU Klasifikace objektu
    • NKUKOPD Druh plnění projektového úkolu
    • NKZDROJ Řešitel projektového úkolu
      • SPPRISTU Přístupové právo uživatele k věci
    • ADADSAT Adresát
    • SPPRCOD Operace procesu
      • SPTYP Druh procesu/operace

    • Vyvolávané činnosti

    K. | Činnost | Popis
F7 | Diagram projektového úkolu | Diagram složeného projektového úkolu
F9 | Spustit operaci | Spuštění zobrazené operace
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy plnění proj.úkolů | Druhy plnění projektových úkolů
F2 | Druhy projektových úkolů | Druhy projektových úkolů
F2 | Klasifikace objektů | Klasifikace objektů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Předmět projektu | Seznam předmětů projektu
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Řešitelé projektových úkolů | Řešitelé projektových úkolů

    Formulář

    Formulář činnosti - Klasifikace objektů
Mřížka [Harmonogram plnění úkolů]
Listovací rámeček
Stránka #1 Plnění úkolu
Druh artiklu | Identifikace druhu artiklu
Úkol | Identifikace artiklu
Verze | Verze projektu
IDÚ úkolu | Identifikace datového úložiště úkolu
Poř. | Pořadí v rámci úkolů předmětu projektu
Název artiklu | Název artiklu
Název druhu úkolu | Název druhu úkolu
Druh | Identifikátor druhu úkolů
Popis | Popis úkolu
Jméno zadavatele | Jméno zadavatele projektového úkolu nebo plnění projektového úkolu
Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu
Jméno řešitele | Jméno řešitele
Řešitel | Identifikace řešitele
Název klasifikace objektu | Název klasifikace objektu
Klasifikace | Identifikace klasifikace objektu
Název adresáta | Název adresáta
Adresát | Identifikace adresáta
Název druhu | Název druhu plnění úkolu projektového řízení
Pln.druh | Identifikace druhu plnění úkolu projektového řízení
Datum | Datum plnění projektového úkolu
Hodin | Čerpání času řešitele v hodinách
Popis | Popis plnění projektového úkolu
% | Přírůstek procenta plnění
Pozn. | Poznámka k plnění projektového úkolu
Kateg. | Kategorie plnění projektového úkolu
Stránka #2 Výběr
Den | Den kalendáře
do | Den kalendáře do
Druh | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
Název předmětu projektu | Název artiklu
Druh | Identifikátor druhu úkolů
Název druhu úkolu | Název druhu úkolu
Pln.druh | Identifikace druhu plnění úkolu projektového řízení
Název druhu | Název druhu plnění úkolu projektového řízení
Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu
Jméno zadavatele | Jméno zadavatele projektového úkolu nebo plnění projektového úkolu
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Klasifikace | Identifikace klasifikace objektu
Název klasifikace objektu | Název klasifikace objektu
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Selektory | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Harmonogram plnění úkolů] činnosti - Klasifikace objektů

    Mřížka [Harmonogram plnění úkolů] činnosti - Klasifikace objektů
Druh artiklu | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
Poř. | Pořadí v rámci úkolů předmětu projektu
Název druhu úkolu | Název druhu úkolu
Název druhu | Název druhu plnění úkolu projektového řízení
Popis | Popis plnění projektového úkolu
Popis | Popis úkolu
Název artiklu | Název artiklu
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Název druhu operace | Název druhu operace
Druh | Identifikátor druhu úkolů
Pln.druh | Identifikace druhu plnění úkolu projektového řízení
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Adresát | Identifikace adresáta
Stav | Stav projektového úkolu
Ukončení | Datum ukončení
Zahájení | Datum zahájení
Dnů | Časová náročnost ve dnech
Název adresáta | Název adresáta

    Viz.také

    Diagram projektového úkolu | Spustit operaci | Adresář | Druhy artiklů | Druhy plnění proj.úkolů | Druhy projektových úkolů | Klasifikace objektů | Obchodní selektor | Organizační selektor | Předmět projektu | Technicko-věcný selektor | Řešitelé projektových úkolů


Aktuální hodnoty proj.úkolů

Popis

Na základě zadaného výběru (tzn. výběr vyfiltrován např. za druh, řešitele, adresáta atd.) má uživatel k dispozici aktuální hodnoty projektových úkolů. Jedná se o hodnoty, které se definují v informačním centru v činnosti komponenty.

Po potvrzení výběru má uživatel k dispozici částky aktuálních hodnot podle zadaného výběru. V horní části formuláře je přehled jednotlivých aktuálních hodnot, ve spodní části formuláře jsou informace vždy jen k dané aktuální hodnotě (tzn. k té, na které je umístěn kurzor).

Datový model

  • NKAHUK Aktuální hodnota projektových úkolů
    • NKPREDPR Předmět projektu
      • SPARTIKN Název artiklu
    • NKUKOLD Druh projektového úkolu
      • SPPRISTU Přístupové právo uživatele k věci
    • NKZDROJ Řešitel projektového úkolu
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)
    • SPSTATDI Druh hodnoty
    • ADADSAT Adresát

    • Formulář

    Formulář činnosti - Kategorie adresátů
Mřížka [Aktuální hodnoty]
Listovací rámeček
Stránka #1 Aktuální hodnoty
Druh hodnoty | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Druh artiklu | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
Název artiklu | Název artiklu
Selektory | Identifikátor obchodního selektoru
Druh | Identifikátor druhu úkolů
Název druhu úkolu | Název druhu úkolu
Tech. sel. | Identifikátor technicko-věcného selektoru.
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Org. sel. | Identifikátor organizačního selektoru.
Adresát | Identifikace adresáta
 | Název adresáta
Hodnota | Aktuální hodnota
Stránka #2 Výběr
Druh hodnoty | Identifikace druhu hodnoty
Druh artiklu | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
Název artiklu | Název artiklu
Selektory | Identifikátor obchodního selektoru
Druh | Identifikátor druhu úkolů
Název druhu úkolu | Název druhu úkolu
Tech. sel. | Identifikátor technicko-věcného selektoru.
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Org. sel. | Identifikátor organizačního selektoru.
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Aktuální hodnoty] činnosti - Kategorie adresátů

    Mřížka [Aktuální hodnoty] činnosti - Kategorie adresátů
Druh hodnoty | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Verze | Verze projektu
Druh | Identifikátor druhu úkolů
Řešitel | Identifikace řešitele
Hodnota | Aktuální hodnota
Název artiklu | Název artiklu
Název druhu úkolu | Název druhu úkolu
Jméno řešitele | Jméno řešitele
Adresát | Identifikace adresáta
 | Název adresáta

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Druhy projektových úkolů | Druhy projektových úkolů
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Předmět projektu | Seznam předmětů projektu
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Řešitelé projektových úkolů | Řešitelé projektových úkolů

    Atributy tisku

    Základní údaje
Druh hodnoty | Identifikace druhu hodnoty | NKAHUK_sp67id | C(3)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)
Druh artiklu | Identifikace druhu artiklu | NKAHUK_sp61id | C(3)
Artikl | Identifikace artiklu | NKAHUK_sp60id | C(13)
Verze | Verze projektu | NKAHUK_nk01verze | C(3)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Adresát | Identifikace adresáta | NKPREDPR_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Druh | Identifikátor druhu úkolů | NKAHUK_nk53id | C(6)
Název druhu úkolu | Název druhu úkolu | NKUKOLD_nk53nazdru | C(40)
Řešitel | Identifikace řešitele | NKAHUK_nk44id | C(6)
Jméno řešitele | Jméno řešitele | NKZDROJ_nk44nazzdr | C(40)
Obch. sel. | Identifikátor obchodního selektoru | NKPREDPR_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | NKZDROJ_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | NKUKOLD_sp20idzak | C(9)
Hodnota | Aktuální hodnota | NKAHUK_nk73hodnot | N(20,4)

    Viz.také

    Adresář | Druhy artiklů | Druhy hodnot | Druhy projektových úkolů | Kategorie adresátů | Obchodní selektor | Organizační selektor | Předmět projektu | Technicko-věcný selektor | Řešitelé projektových úkolů


Aktuální hodnoty plnění úkolů

Popis

Na základě zadaného výběru (tzn. výběr vyfiltrován např. za druh, druh plnění, řešitele, adresáta atd.) má uživatel k dispozici aktuální hodnoty plnění úkolů. Jedná se o hodnoty, které se definují v informačním centru v činnosti komponenty.

Po potvrzení výběru má uživatel k dispozici částky aktuálních hodnot podle zadaného výběru. V horní části formuláře je přehled jednotlivých aktuálních hodnot, ve spodní části formuláře jsou informace vždy jen k dané aktuální hodnotě (tzn. k té, na které je umístěn kurzor).

Datový model

  • NKAHUP Aktuální hodnota plnění projektových úkolů
    • NKPREDPR Předmět projektu
      • SPARTIKN Název artiklu
    • NKUKOPD Druh plnění projektového úkolu
      • SPPRISTU Přístupové právo uživatele k věci
    • NKZDROJ Řešitel projektového úkolu
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)
    • NKUKOLD Druh projektového úkolu
      • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU3)
    • SPSTATDI Druh hodnoty
    • ADADSAT Adresát

    • Formulář

    Formulář činnosti - Technicko-věcný selektor
Mřížka [Aktuální hodnoty]
Listovací rámeček
Stránka #1 Aktuální hodnoty
Druh hodnoty | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Druh artiklu | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
Název artiklu | Název artiklu
Selektory | Identifikátor obchodního selektoru
Druh | Identifikátor druhu úkolů
Název druhu úkolu | Název druhu úkolu
Tech. sel. | Identifikátor technicko-věcného selektoru.
Pln.druh | Identifikace druhu plnění úkolu projektového řízení
Název druhu | Název druhu plnění úkolu projektového řízení
Tech. sel. | Identifikátor technicko-věcného selektoru.
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Org. sel. | Identifikátor organizačního selektoru.
Adresát | Identifikace adresáta
 | Název adresáta
Hodnota | Aktuální hodnota
Stránka #2 Výběr
Druh hodnoty | Identifikace druhu hodnoty
Druh artiklu | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
Název artiklu | Název artiklu
Selektory | Identifikátor obchodního selektoru
Druh | Identifikátor druhu úkolů
Název druhu úkolu | Název druhu úkolu
Tech. sel. | Identifikátor technicko-věcného selektoru.
Pln.druh | Identifikace druhu plnění úkolu projektového řízení
Název druhu plnění | Název druhu plnění úkolu projektového řízení
Tech. sel. | Identifikátor technicko-věcného selektoru.
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Org. sel. | Identifikátor organizačního selektoru.
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Aktuální hodnoty] činnosti - Technicko-věcný selektor

    Mřížka [Aktuální hodnoty] činnosti - Technicko-věcný selektor
Druh hodnoty | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Verze | Verze projektu
Druh | Identifikátor druhu úkolů
Pln.druh | Identifikace druhu plnění úkolu projektového řízení
Řešitel | Identifikace řešitele
Hodnota | Aktuální hodnota
Název artiklu | Název artiklu
Název druhu úkolu | Název druhu úkolu
Název druhu plnění | Název druhu plnění úkolu projektového řízení
Jméno řešitele | Jméno řešitele
Adresát | Identifikace adresáta
 | Název adresáta

    Vyvolávané činnosti

    K. | Činnost | Popis
T | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Druhy plnění proj.úkolů | Druhy plnění projektových úkolů
F2 | Druhy projektových úkolů | Druhy projektových úkolů
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Předmět projektu | Seznam předmětů projektu
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Řešitelé projektových úkolů | Řešitelé projektových úkolů

    Atributy tisku

    Základní údaje
Druh hodnoty | Identifikace druhu hodnoty | NKAHUP_sp67id | C(3)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)
Druh artiklu | Identifikace druhu artiklu | NKAHUP_sp61id | C(3)
Artikl | Identifikace artiklu | NKAHUP_sp60id | C(13)
Verze | Verze projektu | NKAHUP_nk01verze | C(3)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Adresát | Identifikace adresáta | NKPREDPR_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Druh úkolu | Identifikátor druhu úkolů | NKAHUP_nk53idp | C(6)
Název druhu úkolu | Název druhu úkolu | NKUKOLD_nk53nazdru | C(40)
Druh plnění | Identifikace druhu plnění úkolu projektového řízení | NKAHUP_nk70id | C(6)
Název druhu | Název druhu plnění úkolu projektového řízení | NKUKOPD_nk70nazdru | C(40)
Řešitel | Identifikace řešitele | NKAHUP_nk44id | C(6)
Jméno řešitele | Jméno řešitele | NKZDROJ_nk44nazzdr | C(40)
Obch. sel. | Identifikátor obchodního selektoru | NKPREDPR_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | NKZDROJ_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | NKUKOLD_sp20idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | NKUKOPD_sp20idzak | C(9)
Hodnota | Aktuální hodnota | NKAHUP_nk76hodnot | N(20,4)

    Viz.také

    Adresář | Druhy artiklů | Druhy hodnot | Druhy plnění proj.úkolů | Druhy projektových úkolů | Kategorie adresátů | Obchodní selektor | Organizační selektor | Předmět projektu | Technicko-věcný selektor | Řešitelé projektových úkolů


NASTAVENÍ O ŘÍZENÍ PROJEKTU

Popis

Obsahuje činnosti potřebné k nastavení části projektového řízení týkajících se řízení projektu.

Viz.také

Druhy projektových úkolů | Druhy plnění proj.úkolů | Řešitelé projektových úkolů | Kalendáře řešitelů | Generické projektové úkoly | Prezentace úkolu v diagramech | Parametry projektového řízení


Druhy projektových úkolů

Popis

Druhy projektových úkolů (PÚ) jsou spojeny s projektovými úkoly. Práva nastavená pro druh projektového úkolu definují právo uživatele vidět události daného druhu a vytvářet události daného druhu.

U každého druhu projektového úkolu jsou zásadní tyto atributy:

¨ druh – identifikace a název druhu

¨ typ druhu PÚ – může nabývat hodnot jednoduchý nebo složený (tj. je složen z více úkolů)

¨ osobní – možnost v případě potřeby si nastavit druh PÚ jako osobní

¨ zadavatel - zadavatel vymezuje množinu řešitelů, kteří mohou zadávat úkol - při vytváření nového úkolu se po uvedení druhu úkolu automaticky předplňuje překryvný seznam zadavatele úkolu s jedinou položkou, je-li uveden neskupinový řešitel nebo více položkami, je-li uveden skupinový řešitel. Do tohoto seznamu jsou zařazeni pouze řešitelé, ke kterým má aktuální uživatel systému právo přístupu alespoň čtení.

¨ řešitel - řešitel vymezuje množinu řešitelů, kteří mohou řešit úkol - při vytváření nového úkolu se po uvedení zadavatele úkolu automaticky předplňuje překryvný seznam řešitele úkolu s jedinou položkou, je-li uveden neskupinový řešitel nebo více položkami, je-li uveden skupinový řešitel. Do tohoto seznamu jsou zařazeni pouze řešitelé, které uvedený zadavatel úkoluje, a ke kterým má aktuální uživatel systému právo přístupu alespoň čtení. Navíc nejsou do překryvného seznamu zařazeni řešitelé - neskupinoví a mají ve svém popisu uvedeného uživatele systému, který nemá právo přístupu k zadávanému druhu projektového úkolu nebo zadavateli alespoň čtení.

¨ prezentace - prezentace projektového úkolu určuje jakým způsobem bude úkol prezentován v diagramech. Identifikátor sady parametrů je předplňován do úkolu při pořízení nového úkolu. Předplňovat zadavatele=Ano způsobí při vstupu nového úkolu předplnění zadavatele, ke kterému má aktuální uživatel právo přístupu zápis (při tom je přednostně předplněn řešitel, který má u sebe uvedenu identifikaci aktuálního uživatele systému).

¨ předplňovat zadavatele – předplňovat zadavatele při vstupu PÚ – volba Ano/Ne

¨ předplňovat řešitele - Ano - s právem zápis. Předplní prvního řešitele, ke kterému má aktuální uživatel právo přístupu zápis (při tom je přednostně předplněn řešitel, který má u sebe uvedenu identifikaci aktuálního uživatele systému).

- Ano - podle pořadí. Předplní řešitele s uvedeným nejnižším nenulovým pořadím ve skupině řešitelů

¨ harmonogram – zda zobrazovat PÚ daného druhu v harmonogramu PÚ. Možnosti jsou Ano/Ne. Nastavením vlastnosti druhu na hodnotu "Ne" je možné potlačit zobrazování úkolu v harmonogramech. Aby mohl být projektový úkol daného druhu plněn, musí k němu být přidělen alespoň jeden druh plnění projektového úkolu, který se uplatňuje při zadání jeho plnění. S druhem projektového úkolu je spojen technicko-věcný selektor.

¨ připomenutí řešiteli – při založení úkolu lze automaticky odeslat připomenutí – zprávu řešiteli – možnosti nastavení jsou Ano/Ne

Na záložce Další je možnost detailního nastavení způsobu odesílání zpráv a předmětu projektu.

Na záložce Druhy plnění je informace o tom, které druhy plnění přímo souvisí s tímto druhem projektového úkolu.

Pokud na záložce Použití v operacích uživatel zadá nějakou operaci komponenty HPZ (projektové řízení), tak následně při spuštění procesu s touto operací nabízí systém u atributu „druh k vyplnění“ jen ty druhy projektových úkolů, které jsou propojené právě s aktuální operací.

Datový model

  • NKUKOLD Druh projektového úkolu
    • PAOBJDRU Klasifikace objektu
    • SPPRISTU Přístupové právo uživatele k věci
    • NKZDROJ Řešitel projektového úkolu
    • SPSETV Technicko-věcný selektor
    • NKZDROJZ Zadavatel úkolu
    • NKUKOLX Prezentace úkolu v diagramu úkolu
    • PASADA Sada parametrů

    • Formulář

    Formulář činnosti - Druhy operací
Mřížka [Skupiny projektových úkolů]
Listovací rámeček
Stránka #1 Druhy úkolů
Druh | Identifikátor druhu úkolů
Název druhu úkolu | Název druhu úkolu
Typ | Typ úkolu - složený=je složen z více úkolů
Osobní | Druh osobních projektových úkolů
Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu
Jméno zadavatele | Jméno zadavatele projektového úkolu nebo plnění projektového úkolu
Řešitel | Předplňovaný zdroj při vzniku úkolu
Jméno řešitele | Jméno řešitele
Klasif. | Identifikace klasifikace objektu
Název klasifikace objektu | Název klasifikace objektu
Prezen. | Identifikátor prezentace úkolu v diagramech
Název prezentace | Název prezentace úkolu v diagramech
Sada | Identifikátor sady parametrů
Název sady | Název sady parametrů
Předplňovat zadavatele | Předplňovat zadavatele při vstupu úkolu
Předplňovat řešitele | Předplňovat řešitele při vstupu úkolu
Harmonogram | Zobrazovat v harmonogramu projektových úkolů
Milník | Milník Ano/Ne
Připomenutí řešiteli | Při založení úkolu automaticky odeslat připomentutí-zprávu řešiteli
Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Název technicko-věcného selektoru.
Stránka #2 Další
Přednastavit - Zpráva při změně zahájení | Odeslat zprávu vedoucímu projektu při změně data zahájen
Přednastavit - Zpráva při změně ukončení | Odeslat zprávu vedoucímu projektu při změně data ukončení
Přednastavit - Změna stavu předmětu | Stav projektu (uvažovaný, zahájený,...)
Poznámka | Poznámka
Stránka #3 Druhy plnění
Druh | Identifikátor druhu úkolů
 | Název druhu úkolu
Mřížka [Druhy plnění]
Pln.druh | Identifikace druhu plnění úkolu projektového řízení
Název druhu | Název druhu plnění úkolu projektového řízení
Předplňovat | Předplňovat pro druh projektového úkolu
Pořadí | Pořadí zobrazení druhu plnění
Stránka #4 Použití v operacích
Mřížka [Použití v operacích]
 | Identifikace komponenty
Operace | Identifikátor druhu operace
 | Název druhu operace
Stránka #5 Aministrátoři druhu úkolu
Druh | Identifikátor druhu úkolů
 | Název druhu úkolu
Mřížka [Aministrátoři druhu úkolu]
Aministrátor | Identifikátor administrátora druhu projektového úkolu
Jméno administrátora | Jméno administrátora druhu projektového úkolu
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Editace | Právo administrátora editovat úkol
Stránka #6 Výběr
Druh | Identifikátor druhu úkolů
Název druhu úkolu | Název druhu úkolu
Typ | Typ úkolu - složený=je složen z více úkolů
Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu
Jméno zadavatele | Jméno zadavatele projektového úkolu nebo plnění projektového úkolu
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Klasifikace | Identifikace klasifikace objektu
Název klasifikace objektu | Název klasifikace objektu
Sada | Identifikátor sady parametrů
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Skupiny projektových úkolů] činnosti - Druhy operací

    Mřížka [Skupiny projektových úkolů] činnosti - Druhy operací
Druh | Identifikátor druhu úkolů
Název druhu úkolu | Název druhu úkolu
Typ | Typ úkolu - složený=je složen z více úkolů
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu
Jméno zadavatele | Jméno zadavatele projektového úkolu nebo plnění projektového úkolu
Prezentace | Identifikátor prezentace úkolu v diagramech
Název prezentace | Název prezentace úkolu v diagramech
Klasifikace | Identifikace klasifikace objektu
Název klasifikace objektu | Název klasifikace objektu

    Mřížka [Druhy plnění] činnosti - Druhy operací

    Mřížka [Druhy plnění] činnosti - Druhy operací
Pořadí | Pořadí zobrazení druhu plnění
Pln.druh | Identifikace druhu plnění úkolu projektového řízení
Předplňovat | Předplňovat pro druh projektového úkolu
Název druhu | Název druhu plnění úkolu projektového řízení

    Mřížka [Použití v operacích] činnosti - Druhy operací

    Mřížka [Použití v operacích] činnosti - Druhy operací
Komp. | Identifikace komponenty
Operace | Identifikátor druhu operace
Název druhu operace | Název druhu operace

    Mřížka [Aministrátoři druhu úkolu] činnosti - Druhy operací

    Mřížka [Aministrátoři druhu úkolu] činnosti - Druhy operací
Aministrátor | Identifikátor zadavatele úkolu nebo plnění úkolu
Jméno administrátora | Jméno administrátora druhu projektového úkolu
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele

    Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy plnění proj.úkolů | Druhy plnění projektových úkolů
F2 | Klasifikace objektů | Klasifikace objektů
F2 | Prezentace úkolu v diagramech | Prezentace úkolu v diagramech
F2 | Sady parametrů | Sady parametrů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Řešitelé projektových úkolů | Řešitelé projektových úkolů

    Atributy tisku

    Základní údaje
Druh | Identifikátor druhu úkolů | NKUKOLD_nk53id | C(6)
Název druhu úkolu | Název druhu úkolu | NKUKOLD_nk53nazdru | C(40)
Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu | NKUKOLD_nk42id | C(6)
Jméno zadavatele | Jméno zadavatele projektového úkolu nebo plnění projektového úkolu | NKZDROJZ_nk42nazzad | C(40)
Předp.řešitel | Předplňovaný zdroj při vzniku úkolu | NKUKOLD_nk44id | C(6)
Jméno řešitele | Jméno řešitele | NKZDROJ_nk44nazzdr | C(40)
Klasifikace | Identifikace klasifikace objektu | NKUKOLD_pa13id | C(12)
Název klasifikace objektu | Název klasifikace objektu | PAOBJDRU_pa13nazdru | C(40)
Prezentace | Identifikátor prezentace úkolu v diagramech | NKUKOLD_nk72id | C(6)
Název prezentace | Název prezentace úkolu v diagramech | NKUKOLX_nk72nazpre | C(40)
Sada | Identifikátor sady parametrů | NKUKOLD_pa01id | C(6)
Název sady | Název sady parametrů | PASADA_pa01nazsad | C(40)
Předplňovat zadavatele | Předplňovat zadavatele při vstupu úkolu | Výpočet | C(3)
Předplňovat řešitele | Předplňovat řešitele při vstupu úkolu | Výpočet | C(20)
Typ | Typ úkolu - složený=je složen z více úkolů | Výpočet | C(10)
Harmonogram | Zobrazovat v harmonogramu projektových úkolů | Výpočet | C(3)
Milník | Milník Ano/Ne | Výpočet | C(3)
Přednastavit - Zpráva při změně zahájení | Přednastavení vlastnosti - Odeslat zprávu vedoucímu projektu při změně data zahájení - při vzniku úkolu | Výpočet | C(3)
Přednastavit - Zpráva při změně ukončení | Přednastavení vlastnosti - Odeslat zprávu vedoucímu projektu při změně data ukončení - při vzniku úkolu | Výpočet | C(3)
Přednastavit - Změna stavu předmětu | Přednastavení vlastnosti - Změna stavu předmětu projektu při ukončení úkolu - při vzniku úkolu | Výpočet | C(12)
Tech. sel. | Identifikátor technicko-věcného selektoru. | NKUKOLD_sp20idzak | C(9)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(60)
Poznámka | Poznámka | NKUKOLD_nk53koment | M
Název druhu | Název druhu plnění úkolu projektového řízení | NKUKOPD_nk70nazdru | C(40)
Jméno administrátora | Jméno administrátora druhu projektového úkolu | NKZDROJZ2_nk42nazzad | C(40)
Jméno řešitele | Jméno řešitele | NKZDROJ2_nk44nazzdr | C(40)

    Při pohybu v Druhy plnění
Druh | Identifikace druhu plnění úkolu projektového řízení | NKUKDPD_nk70id | C(6)
Předplňovat | Předplňovat pro druh projektového úkolu | Výpočet | C(3)
Pořadí | Pořadí zobrazení druhu plnění | NKUKDPD_nk80porad | N(3)

    Při pohybu v Aministrátoři druhu projektového úkolu
Aministrátor | Identifikátor administrátora druhu projektového úkolu | NKUKOLDA_nk42id | C(6)
Řešitel | Identifikace řešitele | NKUKOLDA_nk44id | C(6)
Editace | Právo administrátora editovat úkol | Výpočet | C(3)

    Viz.také

    Přístupová práva | Druhy operací | Druhy plnění proj.úkolů | Klasifikace objektů | Prezentace úkolu v diagramech | Sady parametrů | Technicko-věcný selektor | Řešitelé projektových úkolů


Druhy plnění proj.úkolů

Popis

V této činnosti se definují jednotlivé druhy plnění projektových úkolů (např. zahájen, schválen, ukončen nebo 1. kontakt se zákazníkem, uskutečněný prodej apod.). U každého druhu se zadává:

¨ identifikace a název druhu plnění

¨ zadavatel – identifikátor zadavatele úkolu nebo plnění úkolu

¨ povinné zadání času – volba Ano/Ne – zda řešitel při plnění úkolu tohoto druhu musí povinně uvést čas strávený na úkolu (v hod)

¨ změna stavu úkolu – změna stavu projektového úkolu při plnění daným druhem plnění (např. druh plnění „schvaluji“ může mít nastaveno, že po jeho naplnění se stav projektového úkolu změní na „ukončený“)

¨ automaticky přidělit – přidělit druh plnění nově založenému druhu projektového úkolu

¨ technický selektor

¨ skript – kód v jazyce Foxpro provedený při ukončení operace s druhem plnění

¨ skript valid – kód v jazyce Foxpro provedený před zápisem události s druhem plnění

¨ poznámka – libovolný komentář k druhu plnění

Zajímavou vlastnost druhu plnění představuje pro uživatele záložka „dynamické transformace“. Nastavení dynamické transformace způsobí, že se na základě její definice vytvoří další operace, která ani nemusí souviset s komponentou projektové řízení. Např. druh plnění může být „prodej ukončen“ – jako dynamickou transformaci bude mít uveden proces faktury z komponenty OBC, což způsobí, že po zadání druhu plnění „prodej ukončen“ se uživateli podle nastavených parametrů automaticky spustí proces „fakturace“. Nebo se tato vlastnost může využít např. při projektovém úkolu „1. kontaktáž zákazníka“ a podle zadaného plnění tohoto druhu úkolu se může spustit opakovaný kontakt (tzn. v podstatě další nový projektový úkol, protože uživatel zákazníka nezastihnul) nebo odeslání smlouvy apod. U každé dynamické transformace se definuje:

¨ identifikace procesu

¨ identifikace komponenty a druhu operace (tj. ta operace, která se nastavením této dynamické transformace aktivuje)

¨ spouštět – nastavení způsobu aktivace dané operace

¨ transformace – výběr dostupných transformací z překryvného seznamu

¨ vazba – vazba vstupující do druhého uzlu

¨ pořadí transformace

¨ rozlišení vazby

¨ předkontace – identifikace obecné předkontace

Datový model

  • NKUKOPD Druh plnění projektového úkolu
    • NKZDROJZ Zadavatel úkolu
      • SPPRISTU Přístupové právo uživatele k věci
    • SPSETV Technicko-věcný selektor

    • Formulář

    Formulář činnosti - Editovat kód vlastnosti
Mřížka [Druhy plnění]
Druh | Identifikace druhu plnění úkolu projektového řízení
Název druhu | Název druhu plnění úkolu projektového řízení
Listovací rámeček
Stránka #1 Druhy plnění
Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu
Jméno zadavatele | Jméno zadavatele projektového úkolu nebo plnění projektového úkolu
Povinné zadání času | Povinné zadání času řešitele v hodinách
Změna stavu úkolu | Změna stavu projektového úkolu při plnění daným druhem plnění
Automaticky přidělit | Přidělit druh plnění nově založenému druhu projektového úkolu
Tech. sel. | Identifikátor technicko-věcného selektoru.
Název technicko-věcného selektoru | Název technicko-věcného selektoru.
Skript | Kód v jazyce Foxpro provedený při ukončení operace s druhem plnění
Skript valid | Kód v jazyce Foxpro provedený před zápisem události s druhem plnění
Poznámka | Poznámka
Stránka #2 Dynamické transformace
Mřížka [Dynamické transformace]
Proces | Identifikátor druhu procesu
 | Název druhu procesu
 | Identifikace komponenty
Operace | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Název druhu operace
Spouštět | Spouštět operaci
Transformace | Tranformace mezi operacemi
Vazba | Vazba vstupující do druhého uzlu
Pořadí transf. | Pořadí transformace
Rozlišení vazby | Rozlišení vazby pro transformaci
Předkontace | Identifikace obecné předkontace

    Mřížka [Druhy plnění] činnosti - Editovat kód vlastnosti

    Mřížka [Druhy plnění] činnosti - Editovat kód vlastnosti
Druh | Identifikace druhu plnění úkolu projektového řízení
Název druhu | Název druhu plnění úkolu projektového řízení
Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu
Jméno zadavatele | Jméno zadavatele projektového úkolu nebo plnění projektového úkolu
Tech. sel. | Identifikátor technicko-věcného selektoru.
Název technicko-věcného selektoru | Název technicko-věcného selektoru.

    Mřížka [Dynamické transformace] činnosti - Editovat kód vlastnosti

    Mřížka [Dynamické transformace] činnosti - Editovat kód vlastnosti
Proces | Identifikátor druhu procesu
Název druhu procesu | Název druhu procesu
Komp. | Identifikace komponenty
Operace | Identifikátor druhu operace
Název druhu operace | Název druhu operace
Pořadí | Pořadí stejného druhu operace v jednom procesu

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Editovat kód vlastnosti | Editovat kód vlastnosti
F6 | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností
- | Kontrolní kompilace | Kontrolní kompilace
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Komponenty | Číselník komponent
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Řešitelé projektových úkolů | Řešitelé projektových úkolů

    Atributy tisku

    Základní údaje
Druh | Identifikace druhu plnění úkolu projektového řízení | NKUKOPD_nk70id | C(6)
Název druhu | Název druhu plnění úkolu projektového řízení | NKUKOPD_nk70nazdru | C(40)
Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu | NKUKOPD_nk42id | C(6)
Jméno zadavatele | Jméno zadavatele projektového úkolu nebo plnění projektového úkolu | NKZDROJZ_nk42nazzad | C(40)
Povinné zadání času | Povinné zadání času řešitele v hodinách | Výpočet | C(3)
Změna stavu úkolu | Změna stavu projektového úkolu při plnění daným druhem plnění | Výpočet | C(11)
Automaticky přidělit | Přidělit druh plnění nově založenému druhu projektového úkolu | Výpočet | C(20)
Tech. sel. | Identifikátor technicko-věcného selektoru. | NKUKOPD_sp20idzak | C(9)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(60)
Skript | Kód v jazyce Foxpro provedený při ukončení operace s druhem plnění | NKUKOPD_nk70kod | M
Skript valid | Kód v jazyce Foxpro provedený před zápisem události s druhem plnění | NKUKOPD_nk70kodvld | M
Poznámka | Poznámka | NKUKOPD_nk70koment | M
Název druhu procesu | Název druhu procesu | SPTYP_sp07text | C(30)
Název druhu operace | Název druhu operace | SPTYP2_sp07text | C(30)

    Při pohybu v Dynamické transformace
Proces | Identifikátor druhu procesu | NKUKOPDT_sp07idtypd | C(6)
Komponenta | Identifikace komponenty | NKUKOPDT_sp06idsubs | C(3)
Druh operace | Identifikátor druhu operace | NKUKOPDT_sp07idtyp | C(6)
Pořadí druhu operace | Pořadí stejného druhu operace v jednom procesu | NKUKOPDT_sp33porad | N(2)
Spouštět | Spouštět operaci | Výpočet | C(11)
Vazba | Vazba vstupující do druhého uzlu | Výpočet | C(23)

    Viz.také

    Editovat kód vlastnosti | Knihovny vkládaného kódu | Kontrolní kompilace | Druhy operací | Druhy procesů | Komponenty | Technicko-věcný selektor | Řešitelé projektových úkolů


Řešitelé projektových úkolů

Popis

Řešitel vystupuje na událostech projektových úkolů jako jejich zadavatel a jejich řešitel. Může mít u sebe uvedeného uživatele systému (slouží při zadávání úkolu pro předplnění zadavatele resp. řešitele úkolu viz. Druhy projektových úkolů).

Na první záložce „Řešitelé“ jsou k dispozici tyto atributy:

¨ řešitel – identifikace a název

¨ profese – identifikace pracovní funkce (zařazení)

¨ uživatel

¨ adresát

¨ úkoluje – lze uvést i identifikaci jiného řešitele, kterého daný řešitel může úkolovat. Obvykle zde bývá uvedena skupina řešitelů, která vymezuje spolu se skupinou řešitelů uvedenou u druhu projektových úkolů množinu řešitelů, kteří budou předplněni do překryvného seznamu řešitelů, při zadávání nového úkolu daného druhu daným zadavatelem.

¨ kalendář – identifikace kalendáře, který daný řešitel používá pro plnění projektových úkolů

¨ aktivní řešitel – volba Ano/Ne

¨ skupina řešitelů – volba Ano/Ne

¨ kapacitní plánování – možnosti jsou Plné, Kalendář, Žádné.

¨ Plné - při přepočtu projektu se bere v úvahu čas řešitele na projektových úkolech tohoto druhu

¨ Kalendář - při přepočtu projektu se bere v úvahu pouze čas kalendáře

¨ Ne - při přepočtu projektu se nebere v úvahu ani čas kalendáře

¨ kapacity hodin – denní, max. denní, týdenní a max. týdenní – předplní se podle uvedeného kalendáře, možno samozřejmě opravit podle potřeby

Pokud se jedná o řešitele, který má u atributu „skupina řešitelů“ uvedeno Ano, je nutno uvést řešitele ve skupině. K tomuto zadání slouží druhá

záložka, kde se uvádí:

¨ identifikace a název řešitele ve skupině

¨ člen skupiny = NE - úkoly s uvedeným daným skupinovým řešitelem nejsou určeny pro tohoto řešitele uvedeného ve skupině (ve skupině je uveden proto, aby bylo možné pro druh úkolu zadávat úkoly tomuto řešiteli jako jednotlivci)

¨ pořadí předplnění - souvisí s předplňováním řešitele při zadání úkolu viz. Druhy projektových úkol

Může nastat situace, že při plánování úkolů daného řešitele je nutno vzít v potaz i výjimky v kalendáři, tzn. dny, kdy daný řešitel je nedostupný, tudíž mu na tyto dny nelze plánovat práci. Může jít např. o nutnou práci na jiném projekt. úkolu, o dovolenou, nemoc nebo různé jiné nenadálé události.

U každého řešitele je možno nastavit přístupová práva k plnění projektových úkolů (menu Volby nebo klávesa Ctrl B).

Datový model

  • NKZDROJ Řešitel projektového úkolu
    • MZPRACFU Pracovní funkce - skutečné a typové
    • BWUZIVAT Uživatel systému
    • NKZDKAL Kalendář zdroje pro plnění projektového kroku
    • SPSEOR Organizační selektor
    • ADADSAT Adresát

    • Formulář

    Formulář činnosti - Pracovní místa skut. a typová
Mřížka [Řešitelé]
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Listovací rámeček
Stránka #1 Řešitelé
Profese | Identifikace pracovní funkce (zařazení)
Název profese | Popis pracovní funkce (pracovního zařazení)
Uživatel | Identifikace uživatele systému
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Úkoluje | Identifikace úkolovaného řešitele
Jméno řešitele | Jméno řešitele
Kalendář | Identifikace kalendáře řešitele pro plnění projektového úkolu
Název kalendáře | Název kalendáře zdroje pro plnění projektového kroku
Aktivní řešitel | Aktivní řešitel
Skupina řešitelů | Skupina řešitelů
Kapacitní plánování | Kapacitní plánování
Denní kapacita (hod) | Denní kapacita v hodinách
Max.denní kapacita (hod) | Maximální denní kapacita v hodinách
Týdenní kapacita (hod) | Týdenní kapacita v hodinách
Max.týdenní kapacita (hod) | Maximální týdenní kapacita v hodinách
Org. sel. | Identifikátor organizačního selektoru.
 | Název organizačního selektoru
Pozn. | Poznámka
Stránka #2 Řešitelé ve skupině
Mřížka [Řešitelé ve skupině]
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Člen skupiny | Člen skupiny - Ano=přijímá úkoly skupiny nebo přímé, Ne=přijímá úkoly přímo určené řešiteli
Pořadí předplnění | Pořadí předplnění řešitele při zadání úkolu 0=nepředplňovat
Stránka #3 Vyjímky v kalendáři
Mřížka [Vyjímky zdroje v kalendáři]
Den | Den kalendáře
Dostupnost | Dostupnost kapacity zdroje ke dni kalendáře
Změna kapacity | Změna kapacity zdroje v hodinách
Stránka #4 Výběr
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Profese | Identifikace pracovní funkce (zařazení)
Název profese | Popis pracovní funkce (pracovního zařazení)
Adresát | Identifikace adresáta
 | Název adresáta
Aktivní řešitel | Aktivní řešitel
Skupina řešitelů | Skupina řešitelů
Kapacitní plánování | Kapacitní plánování
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Řešitelé] činnosti - Pracovní místa skut. a typová

    Mřížka [Řešitelé] činnosti - Pracovní místa skut. a typová
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Uživatel | Identifikace uživatele systému
Jméno uživatele | Jméno uživatele systému
Org. sel. | Identifikátor organizačního selektoru.
Název organizačního selektoru | Název organizačního selektoru

    Mřížka [Řešitelé ve skupině] činnosti - Pracovní místa skut. a typová

    Mřížka [Řešitelé ve skupině] činnosti - Pracovní místa skut. a typová
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Pořadí předplnění | Pořadí předplnění řešitele při zadání úkolu 0=nepředplňovat
Skupina řešitelů | Skupina řešitelů

    Mřížka [Vyjímky zdroje v kalendáři] činnosti - Pracovní místa skut. a typová

    Mřížka [Vyjímky zdroje v kalendáři] činnosti - Pracovní místa skut. a typová
Den | Den kalendáře
Název | Název dne
Dostupnost | Dostupnost kapacity zdroje ke dni kalendáře
Změna | Změna kapacity zdroje v hodinách
Kalendář | Identifikace kalendáře řešitele pro plnění projektového úkolu

    Vyvolávané činnosti

    K. | Činnost | Popis
^B | Právo přístupu plnění projektového úkolu | Právo přístupu plnění projektového úkolu
- | Předplnit kalendář | Předplnit kalendář
F2 | Adresář | Přehled adresátů
F2 | Kalendáře řešitelů | Kalendáře řešitelů projektových úkolů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Pracovní místa skut. a typová | Popis pracovní funkce (zařazení)
F2 | Řešitelé projektových úkolů | Řešitelé projektových úkolů

    Atributy tisku

    Základní údaje
Řešitel | Identifikace řešitele | NKZDROJ_nk44id | C(6)
Jméno řešitele | Jméno řešitele | NKZDROJ_nk44nazzdr | C(40)
Profese | Identifikace pracovní funkce (zařazení) | NKZDROJ_mz31id | C(6)
Název profese | Popis pracovní funkce (pracovního zařazení) | MZPRACFU_mz31pracfu | C(40)
Uživatel | Identifikace uživatele systému | NKZDROJ_bw01uziv | C(6)
Jméno uživatele | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Adresát | Identifikace adresáta | NKZDROJ_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Úkoluje | Identifikace úkolovaného řešitele | NKZDROJ_nk44iduk | C(6)
Jméno řešitele | Jméno řešitele | NKZDROJ4_nk44nazzdr | C(40)
Aktivní řešitel | Aktivní řešitel | Výpočet | C(3)
Skupina řešitelů | Skupina řešitelů | Výpočet | C(3)
Kalendář | Identifikace kalendáře řešitele pro plnění projektového úkolu | NKZDROJ_nk45id | C(6)
Název kalendáře | Název kalendáře zdroje pro plnění projektového kroku | NKZDKAL_nk45nazkal | C(40)
Denní kapacita (hod) | Denní kapacita v hodinách | NKZDROJ_nk44hodden | N(5,2)
Max.denní kapacita (hod) | Maximální denní kapacita v hodinách | NKZDROJ_nk44hoddmx | N(5,2)
Týdenní kapacita (hod) | Týdenní kapacita v hodinách | NKZDROJ_nk44hodtyd | N(6,2)
Max.týdenní kapacita (hod) | Maximální týdenní kapacita v hodinách | NKZDROJ_nk44hodtmx | N(6,2)
Kapacitní plánování | Kapacitní plánování | Výpočet | C(8)
Org. sel. | Identifikátor organizačního selektoru. | NKZDROJ_sp11idzak | C(9)
Název organizačního selektoru | Název organizačního selektoru | SPSEOR_sp11text | C(60)
Poznámka | Poznámka | NKZDROJ_nk44koment | M
Jméno řešitele | Jméno řešitele | NKZDROJ3_nk44nazzdr | C(40)
Skupina řešitelů | Skupina řešitelů | Výpočet | C(3)

    Při pohybu v Dny kalendáře
Den | Den kalendáře | NKZDKALP_nk46datum | D
Dostupnost | Dostupnost kapacity zdroje ke dni kalendáře | Výpočet | C(14)
Kalendář | Identifikace kalendáře řešitele pro plnění projektového úkolu | NKZDKALP_nk45id | C(6)
Změna kapacity | Změna kapacity zdroje v hodinách | NKZDKALP_nk46hodden | N(5,2)

    Při pohybu v Řešitelé ve skupině
Řešitel | Identifikace řešitele | NKZDROJS_nk44id | C(6)
Člen skupiny | Člen skupiny - Ano=přijímá úkoly skupiny nebo přímé, Ne=přijímá úkoly přímo určené řešiteli | Výpočet | C(3)
Pořadí předplnění | Pořadí předplnění řešitele při zadání úkolu 0=nepředplňovat | NKZDROJS_nk64porad | N(3)

    Viz.také

    Přístupová práva | Předplnit kalendář | Adresář | Kalendáře řešitelů | Organizační selektor | Pracovní místa skut. a typová


Kalendáře řešitelů

Popis

Tato činnost poskytuje uživateli možnost nadefinovat si kalendáře pro jednotlivé řešitele projektových úkolů. U každého kalendáře se zadává jeho identifikace a název.

Záložka „dny v kalendáři“ se automaticky naplní po aktivaci činnosti „předplnit kalendář“ (pod menu Volby). Tato činnost je pod menu Volby aktivní právě pouze v okamžiku, kdy má uživatel aktivní záložku „dny v kalendáři“.

Datový model

  • NKZDKAL Kalendář zdroje pro plnění projektového kroku

    • Formulář

    Formulář činnosti - Předplnit kalendář
Mřížka [Kalendáře]
Kalendář | Identifikace kalendáře řešitele pro plnění projektového úkolu
Název kalendáře | Název kalendáře zdroje pro plnění projektového kroku
Listovací rámeček
Stránka #1 Kalendáře
Poznámka | Poznámka
Stránka #2 Dny v kalendáři
Mřížka [Dny v kalendáři]
Den | Den kalendáře
Dostupnost | Dostupnost kapacity zdroje ke dni kalendáře
Změna kapacity | Změna kapacity zdroje v hodinách
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Stránka #3 Výběr
Den | Den kalendáře
do | Den kalendáře do
Řešitel | Identifikace řešitele
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Kalendáře] činnosti - Předplnit kalendář

    Mřížka [Kalendáře] činnosti - Předplnit kalendář
Kalendář | Identifikace kalendáře řešitele pro plnění projektového úkolu
Název kalendáře | Název kalendáře zdroje pro plnění projektového kroku

    Mřížka [Dny v kalendáři] činnosti - Předplnit kalendář

    Mřížka [Dny v kalendáři] činnosti - Předplnit kalendář
Den | Den kalendáře
Název | Název dne
Dostupnost | Dostupnost kapacity zdroje ke dni kalendáře
Změna kapacity | Změna kapacity zdroje v hodinách
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele

    Vyvolávané činnosti

    K. | Činnost | Popis
- | Předplnit kalendář | Předplnit kalendář
F2 | Řešitelé projektových úkolů | Řešitelé projektových úkolů

    Atributy tisku

    Základní údaje
Kalendář | Identifikace kalendáře řešitele pro plnění projektového úkolu | NKZDKAL_nk45id | C(6)
Název kalendáře | Název kalendáře zdroje pro plnění projektového kroku | NKZDKAL_nk45nazkal | C(40)
Poznámka | Poznámka | NKZDKAL_nk45koment | M
Jméno řešitele | Jméno řešitele | NKZDROJ_nk44nazzdr | C(40)

    Při pohybu v Dny kalendáře
Kalendář | Identifikace kalendáře řešitele pro plnění projektového úkolu | NKZDKALP_nk45id | C(6)
Řešitel | Identifikace řešitele | NKZDKALP_nk44id | C(6)
Den | Den kalendáře | NKZDKALP_nk46datum | D
Dostupnost | Dostupnost kapacity zdroje ke dni kalendáře | Výpočet | C(14)
Změna kapacity | Změna kapacity zdroje v hodinách | NKZDKALP_nk46hodden | N(5,2)

    Viz.také

    Předplnit kalendář | Řešitelé projektových úkolů


Generické projektové úkoly

Popis

Tato činnost umožňuje uživateli nadefinovat si generické (tj. stále se opakující) projektové úkoly. Na základě jejich definice je pak možno vytvořit konkrétní projektové úkoly (pomocí činnosti aplikovat generický úkol). Např. uživatel má definovaný projekt pro určitého zákazníka a přitom do budoucna ví, že takto definovaný projekt by mohl využít i pro další zákazníky. V tento okamžik je vhodné si nadefinovat generické projektové úkoly s tím, že při vytváření projektu pro dalšího nového zákazníka využije činnost „aplikovat generický úkol“ a automaticky se mu vytvoří nové projektové úkoly pro nového zákazníka.

Na záložce „generické úkoly“ se nadefinuje hlavička generického (tzv. typového) úkolu, tj. druh artiklu, artikl, název a případný komentář.

Na záložce „proměnné“ se definuje:

¨ typ proměnné generického úkolu – může nabývat hodnot řešitel 1 – 4, datum 1 – 3 a num 1 – 3

¨ návěští

¨ seznam řešitelů

¨ poznámka

Na záložce „náhrady“ se definuje, jakým atributem lze v případě potřeby nahradit nadefinované proměnné. Zadává se:

¨ typ proměnné – výběr z překryvného seznamu

¨ atribut – kterým má být proměnná nahrazena (výběr z překryvného seznamu)

¨ předmět je předplněn z první záložky + nutno uvést pořadí v rámci úkolů předmětu projektu

Datový model

  • NKUKOLG Generický projektový úkol
    • NKUKOL Projektový úkol
      • NKUKOLD Druh projektového úkolu
        • SPPRISTU Přístupové právo uživatele k věci
      • SPARTIKN Název artiklu

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Předmět projektu | Seznam předmětů projektu
F2 | Umístění parametrů př.projektu | Umístění parametrů předmětu projektu

    Formulář

    Formulář činnosti - Umístění parametrů př.projektu
Mřížka [Generické úkoly]
Druh artiklu | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
IDÚ úkolu | Identifikace datového úložiště úkolu
Poř. | Pořadí v rámci úkolů předmětu projektu
Název artiklu | Název artiklu
Generický úkol | Název generického projektového úkolu
Listovací rámeček
Stránka #1 Generické úkoly
Komentář | Komentář
Stránka #2 Proměnné
Mřížka [Proměnné]
Typ | Typ proměnné generického projektového úkolu
Návěští | Návěští proměnné generického projektového úkolu
Seznam řešitelů | Seznam řešitelů
Poznámka | Poznámka
Stránka #3 Náhrady
Mřížka [Náhrady]
Typ | Typ proměnné generického projektového úkolu
Atribut | Název atributu
Druh | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
IDÚ úkolu | Identifikace datového úložiště úkolu
Poř. | Pořadí v rámci úkolů předmětu projektu

    Mřížka [Generické úkoly] činnosti - Umístění parametrů př.projektu

    Mřížka [Generické úkoly] činnosti - Umístění parametrů př.projektu
Generický úkol | Název generického projektového úkolu
Druh | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
Poř. | Pořadí v rámci úkolů předmětu projektu

    Mřížka [Proměnné] činnosti - Umístění parametrů př.projektu

    Mřížka [Proměnné] činnosti - Umístění parametrů př.projektu
Typ | Typ proměnné generického projektového úkolu
Návěští | Návěští proměnné generického projektového úkolu
Seznam řešitelů | Seznam řešitelů

    Mřížka [Náhrady] činnosti - Umístění parametrů př.projektu

    Mřížka [Náhrady] činnosti - Umístění parametrů př.projektu
Typ | Typ proměnné generického projektového úkolu
Druh | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
IDÚ úkolu | Identifikace datového úložiště úkolu
Poř. | Pořadí v rámci úkolů předmětu projektu

    Viz.také

    Druhy artiklů | Předmět projektu | Umístění parametrů př.projektu


Prezentace úkolu v diagramech

Popis

Definuje jakým způsobem má být projektový úkol (složený typ) prezentován v diagramech.

Zadává se identifikace a název prezentace a výraz v syntaxi jazyka Foxpro, který bude vyhodnocen při zobrazování úkolu v diagramu složeného úkolu. Ve výrazu se mohou vyskytovat odkazy na atributy projektového úkolu s aliasem Data.

Např.:

DTOC( Data.nk43datz)+' - '+DTOC(Data.nk43datu)+' '+ALLTRIM(Data.nk53nazdru)+chr(13)+ALLTRIM(Data.nk44nazzdr)+chr(13)+ALLTRIM(Data.nk43text)+chr(13)+Data.nk43koment

Datový model

  • NKUKOLX Prezentace úkolu v diagramu úkolu

    • Formulář

    Formulář činnosti - Výraz
Mřížka [Prezentace]
Prezentace | Identifikátor prezentace úkolu v diagramech
Název prezentace | Název prezentace úkolu v diagramech
Výraz | Výraz prezentace úkolu v diagramech
Poznámka | Poznámka

    Mřížka [Prezentace] činnosti - Výraz

    Mřížka [Prezentace] činnosti - Výraz
Prezentace | Identifikátor prezentace úkolu v diagramech
Název prezentace | Název prezentace úkolu v diagramech

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Výraz | Tvorba výrazu tvůrcem výrazů

    Atributy tisku

    Základní údaje
Prezentace | Identifikátor prezentace úkolu v diagramech | NKUKOLX_nk72id | C(6)
Název prezentace | Název prezentace úkolu v diagramech | NKUKOLX_nk72nazpre | C(40)
Výraz | Výraz prezentace úkolu v diagramech | NKUKOLX_nk72vyraz | M
Poznámka | Poznámka | NKUKOLX_nk72koment | M

    Viz.také

    Výraz


SKLAD ZVÍŘAT

Popis

Užití této komponenty se předpokládá v souvislosti se správou a evidencí zvířat zejména základního stáda dle kategorií a dle jednotlivého umístění (tzn. stáje, pastviny apod.) zejména ve vazbě na účetnictví. Zvířata jsou evidována v naturálním množství i ve více jednotkách a ve finančním vyjádření (ocenění). Kromě tohoto je u kategorie možno sledovat pohyby zvířat (např. zařazení, nákup, prodej, přeřazení, úhyn, krádež apod.). Komponenta umožňuje automatizovaný výpočet krmných dnů a u vybraných kategorií se počítá i vzrůstový přírůstek.

Viz.také

Událost skladu zvířat | Aktuální hodnoty skladu zvířat | Kategorie zvířat | Umístění | Jednotlivá zvířata | Obraty skladu zvířat | Typ události skladu zvířat | Povolené typy události druhu operace | Povolená umístění kategorie | Povolené typy událostí kategorie | Parametry komp. sklad zvířat


Událost skladu zvířat

Popis

Události skladu zvířat je možno členit na příjmové nebo výdajové události. Na každé události skladu zvířat má uživatel k dispozici následující atributy:

¨ identifikaci a číslo operace

¨ druh operace - příjem, výdej

¨ datum události

¨ pořadí - předplňuje se automaticky číslem 100 a každé následující je o sto vyšší. Výjimku tvoří operace zápočet krmných dnů, kde se pořadí předplňuje podle nastavených parametrů (činnost parametry komp. skladu zvířat - parametr "započítávat stavy do KD"). Zápočet krmných dnů se provádí na základě počátečních nebo konečných stavů.

¨ typ události – definuje bližší určení druhu operace (příjem na fakturu, výdej – prodej, výdej – úhyn, příjem – narození apod.)

¨ popis události

¨ adresát - identifikace a název adresáta události

¨ kategorie - identifikace a název kategorie

¨ ID zvířete – atribut, který je povinný pro kategorie vedené dle jednotlivých zvířat (tj. způsob vedení – kusově)

¨ volné datum – libovolné datum (nejčastější užití je pro kategorie vedené kusově zadat při příjmu datum narození zvířete)

¨ umístění - identifikace a název umístění

¨ selektory, které jsou vztaženy k dané události

¨ cena - může být použita cena "zadaná" nebo cena "skladová". Skladová cena je cena průměrná, uživatel ji v událostech nezadává, systém ji doplňuje automaticky sám (dle parametrů skladu zvířat). Cena zadaná je vyplňována uživatelem ručně.

¨ vztah ceny k MJ – může být zadána RMJ nebo MJ-pomocná. Určuje, ke které MJ se vztahuje cena za MJ (množství v RMJ nebo v MJ-pomocné). V případě použití ceny skladové by mělo být implementačně zajištěno, že vztah ceny k MJ je nastaven: "RMJ", neboť skladová cena se vždy odvíjí k RMJ. Je-li přesto vztah ceny k MJ nastaven: "MJ-pomocná", potom je cena celkem spočtena jako cena skladová x množství v RMJ, cena za MJ je pak vypočtena jako cena celkem / množství v MJ-pomocné.

¨ cena za MJ – cena za MJ dle vyplněného atributu vztah ceny k MJ

¨ cena upravená za MJ - pokud uživatel před určitý výdej (za určitou skladovou cenu) předřadí (změnou pořadí operací) příjem (tzn. skladová cena je v tuto chvíli změněná od původního výdeje), automaticky se na původní operaci výdeje tato cena upravená předplní touto novou cenou skladovou. Pokud je operace výdeje ve stavu připravena - zahájena, přepočte se automaticky cena upravená a rovněž se upraví i cena skladová za MJ. Pokud je operace výdeje již ukončena, cena za MJ zůstává beze změn, ale cena upravená se automaticky změní.

¨ cena celkem

¨ cena celkem upravená - platí totéž co u atributu cena upravená za MJ

Na záložce ostatní má uživatel k dispozici libovolnou poznámku, která se vztahuje k dané události a záložka "účetnictví" mu poskytuje přehled, jak bylo o dané události účtováno (po stisku klávesy F9 lze danou operaci účetnictví aktivovat).

Na klávesu Ctrl S nebo volbou příslušné činnost z menu Volby je možno aktivovat činnost SUMA. Uživateli se zobrazí součet příjmů a výdajů zobrazených událostí.

Datový model

  • SZUDAL Událost skladu zvířat
    • SZARTIKL Kategorie zvířat
    • SZUMIST Umístění kategorie zvířat
      • SPPRISTU Přístupové právo uživatele k věci
      • ADADSAT Adresát (alias ADADSATVL)
      • ADSPOJ Spojení adresáta (alias ADSPOJVL)
        • ADADR Adresa (alias ADADRVL)
    • ADADSAT Adresát
    • SPPRCOD Operace procesu
      • SPTYP Druh procesu/operace
      • SPPRC Proces
    • BWUZIVAT Uživatel systému
    • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)
    • SZTYPUD Typ události skladu zvířat

    • Formulář

    Formulář činnosti - Jednotlivá zvířata
Mřížka [Události skladu zvířat]
Listovací rámeček
Stránka #1 Události
P-V | Příznak příjem / výdej
Proces | Pořadové číslo procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Rok | Rok v identifikaci procesu
 | Pořadí stejného druhu operace v jednom procesu
 | Název druhu procesu
Datum | Datum pohybu
Poř. | Pořadí v rámci datumu pohybu
TU | Identifikace typu události skladu zvířat
Druh | Identifikátor druhu operace
Popis | Popis události
Adresát | Identifikace adresáta
 | Název adresáta
 | Číslo spojení adresáta.
Druh artiklu | Identifikace druhu artiklu
Kategorie | Identifikace kategorie
 | Identifikátor měrné jednotky
Název kategorie | Název kategorie
Zvíře | Identifikace zvířete
Volné datum | Volné datum události
Umístění | Identifikace umístění kategorie zvířat
Název | Název umístění kategorie zvířat
Cena | Typ ceny
Vztah | Vztah ceny k MJ: cena za MJ se vztahuje k RMJ, nebo k MJ-pomocné
Množství v | Množství v RMJ
 | Identifikátor měrné jednotky
Množství v | Množství v MJ - pomocné
Cena za MJ | Cena za oceňovací měrnou jednotku
Celkem | Cena celkem
Upravená | Cena celkem - upravená
Upravená | Cena za oceňovací měrnou jednotku - upravená
Sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Zapsal | Jméno uživatele systému
Datum | Datum a čas zápisu záznamu události
Stránka #2 Ostatní
Poznámka | Poznámka
Stránka #3 Účetnictví
Mřížka [Účetnictví]
Stránka #4 Výběr
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu od
 | Pořadové číslo procesu do
Druh | Identifikátor druhu operace
 | Identifikátor druhu procesu
Datum | Datum od
do | Datum do
 | Příznak příjem / výdej
TU | Identifikace typu události skladu zvířat
Popis | Popis události
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Druh | Identifikace druhu artiklu
Kategorie | Identifikace kategorie
Název kategorie | Název kategorie
Umístění | Identifikace umístění kategorie zvířat
Zvíře | Identifikace zvířete
MJ | Identifikátor měrné jednotky
Cena | Typ ceny
Vztah | Vztah ceny k MJ: cena za MJ se vztahuje k RMJ, nebo k MJ-pomocné
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Zapsal | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Události skladu zvířat] činnosti - Jednotlivá zvířata

    Mřížka [Události skladu zvířat] činnosti - Jednotlivá zvířata
Označování | Označení záznamu
Číslo procesu | Pořadové číslo procesu
Datum | Datum pohybu
Poř. | Pořadí v rámci datumu pohybu
P-V | Příznak příjem / výdej
Druh artiklu | Identifikace druhu artiklu
Kategorie | Identifikace kategorie
Název kategorie | Název artiklu
Umístění | Identifikace umístění kategorie zvířat
Název umístění | Název umístění kategorie zvířat
Zvíře | Identifikace zvířete
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Druh | Identifikátor druhu operace
Množství v RMJ | Množství v RMJ
Množství v MJ - pomocné | Množství v MJ - pomocné
Cena za MJ | Cena za oceňovací měrnou jednotku
Cena za MJ - upravená | Cena za oceňovací měrnou jednotku - upravená
Cena celkem | Cena celkem
Cena celkem - upravená | Cena celkem - upravená
Typ události | Název typu události skladu zvířat
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Mřížka [Účetnictví] činnosti - Jednotlivá zvířata

    Mřížka [Účetnictví] činnosti - Jednotlivá zvířata
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Datum | Datum účetního případu
Účet | Identifikátor účtu účetnictví
Strana | Strana účtu MD/Dal
Částka | Finanční částka
Popis události | Popis účetní události
Částka ZM | Částka v zahraniční měně
IDP | Identifikace párování
Org. sel. | Identifikátor organizačního selektoru.

    Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
^S | Celkem - sklad zvířat |
- | Přepočet krmných dnů | Přepočet krmných dnů
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Jednotlivá zvířata | Přehled jednotlivých zvířat
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Kategorie zvířat | Seznam kategorií zvířat
F2 | Měrné jednotky | Číselník měrných jednotek
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Spojení | Seznam spojení za adresáta.
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Typ události skladu zvířat | Seznam typů události skladu zvířat
F2 | Umístění | Seznam umístění

    Atributy tisku

    Základní údaje
Příjem / výdej | Příznak příjem / výdej | Výpočet | C(1)
Ident. | Identifikace uživatele systému | SZUDAL_bw01uziv | C(6)
Datum a čas zápisu | Datum a čas zápisu záznamu události | SZUDAL_sp00datzap | T
Druh | Identifikátor druhu operace | SZUDAL_sp07idtyp | C(6)
Adresát | Identifikace adresáta | SZUDAL_ad01id | C(6)
Číslo spojení adresáta | Číslo spojení adresáta. | SZUDAL_ad11cisspo | C(2)
Druh artiklu | Identifikace druhu artiklu | SZUDAL_sp61id | C(3)
Artikl | Identifikace kategorie | SZUDAL_sp60id | C(13)
Zvíře | Identifikace zvířete | SZUDAL_sz17id | C(20)
Umístění | Identifikace umístění kategorie zvířat | SZUDAL_sz04id | C(6)
Datum | Datum pohybu | SZUDAL_sz02datum | D
Pořadí v rámci datumu pohybu | Pořadí v rámci datumu pohybu | SZUDAL_sz02dpor | N(5)
MJ | Identifikátor měrné jednotky | SZUDAL_sp24idmj | C(3)
MJ - pomocná | Identifikátor měrné jednotky | SZUDAL_sp24idmj1 | C(3)
Množství v RMJ | Množství v RMJ | SZUDAL_sz02mnmj | N(20,4)
Množství v MJ - pomocné | Množství v MJ - pomocné | SZUDAL_sz02mnmj1 | N(20,4)
Cena za MJ | Cena za oceňovací měrnou jednotku | SZUDAL_sz02cj | N(20,4)
Cena za MJ - upravená | Cena za oceňovací měrnou jednotku - upravená | SZUDAL_sz02cj1 | N(20,4)
Cena celkem | Cena celkem | SZUDAL_sz02cc | N(20,4)
Cena celkem - upravená | Cena celkem - upravená | SZUDAL_sz02cc1 | N(20,4)
Popis | Popis události | SZUDAL_sz02text | C(40)
Poznámka | Poznámka | SZUDAL_sz02koment | M
Obch. sel. | Identifikátor obchodního selektoru | SZUDAL_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | SZUDAL_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | SZUDAL_sp20idzak | C(9)
Komponenta | Identifikace komponenty | SZUDAL_sp06idsubs | C(3)
Číslo procesu | Pořadové číslo procesu | SZUDAL_sp33cisd | C(8)
IDÚ | Identifikace datového úložiště číselné řady procesu | SZUDAL_sp33cisdpm | C(2)
Pořadí druhu operace | Pořadí stejného druhu operace v jednom procesu | SZUDAL_sp33porad | N(2)
Rok | Rok v identifikaci procesu | SZUDAL_sp33cisdr | C(4)
Vztah | Vztah ceny k MJ: cena za MJ se vztahuje k RMJ, nebo k MJ-pomocné | Výpočet | C(10)
Cena | Typ ceny | Výpočet | C(8)
Typ | Identifikace typu události skladu zvířat | SZUDAL_sz16id | C(3)
Volné datum | Volné datum události | SZUDAL_sz02datvol | D
Název artiklu | Název kategorie | SZARTIKL_sp60artikl | C(60)
Název umístění | Název umístění kategorie zvířat | SZUMIST_sz04text | C(40)
Adresát | Název adresáta | ADADSAT_ad01adsat | C(100)
IČO | Identifikační číslo organizace. | ADADSAT_ad01ico | C(10)
DIČ | Daňové identifikační číslo adresáta. | ADADSAT_ad01dico | C(16)
Identifikace v OR | Obchodní rejstřík - údaj o zápisu v OR včetně spisové značky | ADADSAT_ad01volne1 | M
Údaj 2 | Obchodní rejstřík - údaj2 | ADADSAT_ad01volne2 | M
Číslo 1 | Obchodní rejstřík - číslo 1 | ADADSAT_ad01volne3 | N(20,4)
Jméno kontaktní osoby | Jméno kontaktní osoby. | ADSPOJ_ad11jmeno | C(40)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
Byt | Ulice bytu adresáta (včetně čísla popisného) | ADADR_ad02byt | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)
Adresát | Identifikace adresáta | ADADSATVL_ad01id | C(6)
Název adresáta | Název adresáta | ADADSATVL_ad01adsat | C(100)
IČO | Identifikační číslo organizace. | ADADSATVL_ad01ico | C(10)
DIČ | Daňové identifikační číslo adresáta. | ADADSATVL_ad01dico | C(16)
Identifikace v OR | Obchodní rejstřík - údaj o zápisu v OR včetně spisové značky | ADADSATVL_ad01volne1 | M
Údaj 2 | Obchodní rejstřík - údaj2 | ADADSATVL_ad01volne2 | M
Číslo 1 | Obchodní rejstřík - číslo 1 | ADADSATVL_ad01volne3 | N(20,4)
Jméno | Jméno kontaktní osoby. | ADSPOJVL_ad11jmeno | C(40)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADRVL_ad02ulice | C(40)
Byt | Ulice bytu adresáta (včetně čísla popisného) | ADADRVL_ad02byt | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADRVL_ad13psc | C(10)
Město | Město adresy adresáta. | ADADRVL_ad02mesto | C(40)
Zapsal | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Název | Název typu události skladu zvířat | SZTYPUD_sz16text | C(40)

    Viz.také

    OZNAČOVÁNÍ | Prezentace artiklu | Celkem - sklad zvířat | Přepočet krmných dnů | Adresář | Druhy artiklů | Druhy operací | Druhy procesů | Jednotlivá zvířata | Kategorie adresátů | Kategorie zvířat | Měrné jednotky | Obchodní selektor | Organizační selektor | Spojení | Technicko-věcný selektor | Typ události skladu zvířat | Umístění | Parametry operací skladu zvířa


Aktuální hodnoty skladu zvířat

Popis

Uživatel má k dispozici přehled aktuálních hodnot, které jsou nadefinované tak, že se mají u vybraných kategorií sledovat. Na základě zadaného výběru si může uživatel informace vyfiltrovat pouze za určitou hodnotu, za určitou kategorii nebo umístění apod.

Datový model

  • SZAH Aktuální hodnota skladu zvířat
    • SZARTIKL Kategorie zvířat
      • SPSETV Technicko-věcný selektor
    • SZUMIST Umístění kategorie zvířat
      • SPSEOR Organizační selektor
    • ADADSAT Adresát
      • SPSEOB Obchodní selektor
    • SPPRISTU Přístupové právo uživatele k věci
    • SPSTATDI Druh hodnoty

    • Formulář

    Formulář činnosti - Celkem - AH
Mřížka [Aktuální hodnoty]
Listovací rámeček
Stránka #1 Aktuální hodnoty
Druh hodnoty | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Adresát | Identifikace adresáta
 | Název adresáta
Druh artiklu | Identifikace druhu artiklu
Kategorie | Identifikace kategorie
Název kategorie | Název kategorie
Umístění | Identifikace umístění kategorie zvířat
Název | Název umístění kategorie zvířat
Selektory | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Hodnota | Hodnota
Stránka #2 Výběr
Druh hodnoty | Identifikace druhu hodnoty
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Druh artiklu | Identifikace druhu artiklu
Kategorie | Identifikace kategorie
Název kategorie | Název kategorie
Umístění | Identifikace umístění kategorie zvířat
Název | Název umístění kategorie zvířat
Selektory | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Aktuální hodnoty] činnosti - Celkem - AH

    Mřížka [Aktuální hodnoty] činnosti - Celkem - AH
Druh hodnoty | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Adresát | Identifikace adresáta
Druh artiklu | Identifikace druhu artiklu
Kategorie | Identifikace kategorie
Umístění | Identifikace umístění kategorie zvířat
Hodnota | Hodnota
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Název adresáta | Název adresáta
Název kategorie | Název kategorie
Název umístění | Název umístění kategorie zvířat

    Vyvolávané činnosti

    K. | Činnost | Popis
^S | Celkem - AH |
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Kategorie zvířat | Seznam kategorií zvířat
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Umístění | Seznam umístění

    Atributy tisku

    Základní údaje
Komponenta | Identifikace komponenty | SZAH_sp06idsubs | C(3)
Adresát | Identifikace adresáta | SZAH_ad01id | C(6)
Kategorie | Identifikace kategorie | SZAH_sp60id | C(13)
Druh artiklu | Identifikace druhu artiklu | SZAH_sp61id | C(3)
Umístění | Identifikace umístění kategorie zvířat | SZAH_sz04id | C(6)
Druh hodnoty | Identifikace druhu hodnoty | SZAH_sp67id | C(3)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)
Hodnota | Hodnota | SZAH_sz03hodnot | N(20,4)
Název kategorie | Název kategorie | SZARTIKL_sp60artikl | C(60)
MJ | Identifikátor měrné jednotky | SZARTIKL_sp24idmj | C(3)
Tech. sel. | Identifikátor technicko-věcného selektoru. | SZARTIKL_sp20idzak | C(9)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(40)
Název | Název umístění kategorie zvířat | SZUMIST_sz04text | C(40)
Org. sel. | Identifikátor organizačního selektoru. | SZUMIST_sp11idzak | C(9)
Název organizačního selektoru | Název organizačního selektoru | SPSEOR_sp11text | C(40)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
IČO | Identifikační číslo organizace. | ADADSAT_ad01ico | C(10)
DIČ | Daňové identifikační číslo adresáta. | ADADSAT_ad01dico | C(16)
Obch. sel. | Identifikátor obchodního selektoru | ADADSAT_sp10idzak | C(9)
Název obchodního selektoru | Název obchodního selektoru | SPSEOB_sp10text | C(40)

    Viz.také

    Celkem - AH | Adresář | Druhy artiklů | Druhy hodnot | Kategorie adresátů | Kategorie zvířat | Obchodní selektor | Organizační selektor | Technicko-věcný selektor | Umístění


Kategorie zvířat

Popis

Uživatel má k dispozici přehled jednotlivých nadefinovaných kategorií zvířat (v podstatě se jedná o artikly skladu zvířat) a jejich aktuální hodnoty. U každé kategorie je k dispozici:

¨ identifikace druhu a vlastní identifikace kategorie

¨ KD - zaškrtávátko, které určuje, zda se u dané kategorie mají počítat krmné dny. Pokud ano, je nutno ho zaškrtnout, pokud ne, je nutno ho nechat prázdné.

¨ název kategorie

¨ způsob vedení – překryvný seznam – kusově, obecně. U kategorie zvířat vedených kusově pak množství v kusech na události s uvedeným ID zvířete musí být vždy jedna.

¨ MJ - identifikátor referenční měrné jednotky, ve které se daná kategorie bude evidovat

¨ tech. sel. - identifikace technického selektoru, který je spojen s kategorií

¨ účet. sel. – identifikace účetního selektoru, který je spojen s kategorií

¨ libovolná poznámka ke kategorii

V dolní části činnosti kategorie se uživateli zobrazují hodnoty, které si uživatel nadefinoval jako první tři parametry v činnosti "parametry komp. sklad zvířat".

Na záložce "aktuální hodnoty" má uživatel k dispozici informace o jednotlivých aktuálních hodnotách dané kategorie, tzn. nejčastěji jaké množství zvířat je v kterém umístění a to jak v naturálním, tak ve finančním vyjádření.

Na záložce „umístění“ jsou k dispozici informace o množství ve finančním a naturálním vyjádření a o počtu krmných dnů (první tři parametry v činnosti „parametry komp. sklad zvířat) vzhledem k danému umístění.

Záložka „povolená umístění“ poskytuje uživateli možnost označit (tj. zaškrtnout) u každé kategorie ta umístění, které má daná kategorie povoleny. Povolená umístění jsou potom hlídána v událostech skladu zvířat, tzn. není možno provést pohyb (příjem, výdej) kategorie na umístění, které nemá povoleno (tzn. nemůže nastat situace, že by uživatel např. omylem zařadil kategorii prasata do umístění kravín apod.).

Stejným způsobem funguje záložka „povolené typy událostí“. U každé kategorie je označen (tj. zaškrtnut) typ události, který lze s danou kategorií provést, tzn. nemůže nastat situace, že by uživatel např. omylem u kategorie telata provedl v událostech pohyb oprasení.

Záložka „kategorie artiklu“ umožňuje rozčlenit si jednotlivé kategorie zvířat (čili artikly) ještě podrobnějším členěním na kategorie artiklu. U každé kategorie artiklu se eviduje:

¨ název kategorie (výběr z překryvného seznamu)

¨ platnost kategorie od – do

¨ adresát, popis a poznámka

Datový model

  • SZARTIKL Kategorie zvířat
    • SPARTIKL Artikl
    • SPARTIKN Název artiklu
    • SPMJ Měrná jednotka
      • SPMJN Měrná jednotka v jazyce
    • BWUZIVAT Uživatel systému
    • SPSETV Technicko-věcný selektor

    • Formulář

     | Formulář činnosti - Události správy artiklu
 | Mřížka [Kategorie zvířat]
 | Druh | Identifikace druhu artiklu
 | Kategorie | Identifikace kategorie
 | Název kategorie | Název kategorie
 | KD | Počítat krmné dny
 | Listovací rámeček
 | Stránka #1 Kategorie
 | Zp.vedení | Způsob vedení kategorie
 | MJ | Identifikátor měrné jednotky
 | Název měrné jednotky | Název měrné jednotky
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Název tech. sel. | Název technicko-věcného selektoru.
 | Účet.sel. | Účetní selektor artiklu
 | Založil | Jméno uživatele systému
 | 1. zobrazovaná hodnota (u kategorie) | 1. zobrazovaná hodnota (u kategorie)
 | 2. zobrazovaná hodnota (u kategorie) | 2. zobrazovaná hodnota (u kategorie)
 | 3. zobrazovaná hodnota (u kategorie) | 3. zobrazovaná hodnota (u kategorie)
 | Poznámka | Poznámka kategorie
 | Stránka #2 Aktuální hodnoty
 | Mřížka [Aktuální hodnoty]
 | Umístění | Identifikace umístění kategorie zvířat
 | Název | Název umístění kategorie zvířat
 | Druh hodnoty | Identifikace druhu hodnoty
 | Název druhu hodnoty | Název druhu hodnoty
 | Hodnota | Hodnota
 | Stránka #3 Umístění
 | Mřížka [Sledované hodnoty]
 | Umístění | Identifikace umístění kategorie zvířat
 | Název | Název umístění kategorie zvířat
 | 1. zobrazovaná hodnota (u kategorie a umístění) | 1. zobrazovaná hodnota (u kategorie a umístění)
 | 2. zobrazovaná hodnota (u kategorie a umístění) | 2. zobrazovaná hodnota (u kategorie a umístění)
 | 3. zobrazovaná hodnota (u kategorie a umístění) | 3. zobrazovaná hodnota (u kategorie a umístění)
 | Stránka #4 Povolená umístění
 | Mřížka [Povolená umístění]
 | Stránka #5 Povolené typy událostí
 | Mřížka [Povolené typy událostí]
 | Stránka #6 Kategorie artiklu
 | Mřížka [Kategorie artiklu]
 |  | Kategorie
Identifikace kategorie události správy artiklu |  |  | Platnost
Datum platnosti od |  |  | Platnost do
Datum platnosti do |  |  | Adresát
Identifikace adresáta |  |
Název adresáta |  |
Číslo spojení adresáta. |  |  | Popis
Popis události |  |  | Poznámka
Poznámka |  |  | Zapsal
Jméno uživatele systému |  |  | Datum a čas zápisu
Datum a čas zápisu záznamu události
 | Stránka #7 Výběr
 | Druh | Identifikace druhu artiklu
 | Kategorie | Identifikace artiklu
 | Název kategorie | Název kategorie
 | Zp.vedení | Způsob vedení kategorie
 | MJ | Identifikátor měrné jednotky
 | Množství | Množství na skladě (nenulové/nulové)
 | Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Účet.sel. | Účetní selektor artiklu
 | Vztah ke kategorii | Vztah ke kategorii - Je=K dnešnímu datu je v kategorii, Není=K dnešnímu datu není v kategorii, Byl=Není v kategorii, ale byl, Nebyl=Není a nikdy nebyl v kategorii,Bude=Bude v kategorii
 | Kat.artiklu | Identifikace kategorie události správy artiklu
 | Název kategorie | Název kategorie události správy artiklu
 | Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 |  | Platnost nebo neplatnost k datu
 | Paleta | Vybrat záznamy všech kategorií v paletě
 |  | Identifikace palety barev
 | Výběr | Určení výběru
 | Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Kategorie zvířat] činnosti - Události správy artiklu

    Mřížka [Kategorie zvířat] činnosti - Události správy artiklu
Označování | Označení záznamu
Druh | Identifikace druhu artiklu
Kategorie | Identifikace kategorie
Název kategorie | Název artiklu
1. zobrazovaná hodnota (u kategorie) | 1. zobrazovaná hodnota (u kategorie)
2. zobrazovaná hodnota (u kategorie) | 2. zobrazovaná hodnota (u kategorie)
3. zobrazovaná hodnota (u kategorie) | 3. zobrazovaná hodnota (u kategorie)

    Mřížka [Aktuální hodnoty] činnosti - Události správy artiklu

    Mřížka [Aktuální hodnoty] činnosti - Události správy artiklu
Umístění | Identifikace umístění kategorie zvířat
Druh | Identifikace druhu hodnoty
Hodnota | Hodnota
Název druhu hodnoty | Název druhu hodnoty
Název umístění | Název umístění kategorie zvířat

    Mřížka [Sledované hodnoty] činnosti - Události správy artiklu

    Mřížka [Sledované hodnoty] činnosti - Události správy artiklu
Umístění | Identifikace umístění kategorie zvířat
1. zobrazovaná hodnota (u kategorie a umístění) | 1. zobrazovaná hodnota (u kategorie a umístění)
2. zobrazovaná hodnota (u kategorie a umístění) | 2. zobrazovaná hodnota (u kategorie a umístění)
3. zobrazovaná hodnota (u kategorie a umístění) | 3. zobrazovaná hodnota (u kategorie a umístění)
Název umístění | Název umístění kategorie zvířat

    Mřížka [Povolená umístění] činnosti - Události správy artiklu

    Mřížka [Povolená umístění] činnosti - Události správy artiklu
Označování | Označení záznamu
Umístění | Identifikace umístění kategorie zvířat
Název umístění | Název umístění kategorie zvířat

    Mřížka [Povolené typy událostí] činnosti - Události správy artiklu

    Mřížka [Povolené typy událostí] činnosti - Události správy artiklu
Označování | Označení záznamu
Typ | Identifikace typu události skladu zvířat
Typ události | Název typu události skladu zvířat

    Mřížka [Kategorie artiklu] činnosti - Události správy artiklu

    Mřížka [Kategorie artiklu] činnosti - Události správy artiklu
Kategorie | Identifikace kategorie události správy artiklu
Název kategorie | Název kategorie události správy artiklu
Platnost od | Datum platnosti od
Platnost do | Datum platnosti do
Adresát | Identifikace adresáta
Název adresáta | Název adresáta

    Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Události správy artiklu |
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
- | Legenda palety barev |
- | Ceník artiklu | Ceník obchodovatelných artiklů
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Kategorie událostí správy artiklu | Přehled kategorií událostí správy artiklu
F2 | Měrné jednotky | Číselník měrných jednotek
F2 | Palety barev kategorií | Palety barev kategorií
F2 | Spojení | Seznam spojení za adresáta.
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Atributy tisku

    Základní údaje
Druh artiklu | Identifikace druhu artiklu | SZARTIKL_sp61id | C(3)
Kategorie | Identifikace kategorie | SZARTIKL_sp60id | C(13)
Název kategorie | Název kategorie | SPARTIKN_sp62artikl | C(60)
Zp.vedení | Způsob vedení kategorie | Výpočet | C(6)
MJ | Identifikátor měrné jednotky | SZARTIKL_sp24idmj | C(3)
Poznámka | Poznámka kategorie | SZARTIKL_sz01koment | M
Tech. sel. | Identifikátor technicko-věcného selektoru. | SZARTIKL_sp20idzak | C(9)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(60)
Účetní selektor artiklu | Účetní selektor artiklu | SZARTIKL_sp00uselar | C(9)
Název druhu hodnoty 1. zobrazované hodnoty | Název druhu hodnoty 1. zobrazované hodnoty | SZARTIKL_sz01druin1 | C(40)
Název druhu hodnoty 2. zobrazované hodnoty | Název druhu hodnoty 2. zobrazované hodnoty | SZARTIKL_sz01druin2 | C(40)
Název druhu hodnoty 3. zobrazované hodnoty | Název druhu hodnoty 3. zobrazované hodnoty | SZARTIKL_sz01druin3 | C(40)
1. zobrazovaná hodnota (u kategorie) | 1. zobrazovaná hodnota (u kategorie) | SZARTIKL_sz01hodn1 | N(20,4)
2. zobrazovaná hodnota (u kategorie) | 2. zobrazovaná hodnota (u kategorie) | SZARTIKL_sz01hodn2 | N(20,4)
3. zobrazovaná hodnota (u kategorie) | 3. zobrazovaná hodnota (u kategorie) | SZARTIKL_sz01hodn3 | N(20,4)
Název | Název umístění kategorie zvířat | SZUMIST_sz04text | C(40)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)
Název | Název umístění kategorie zvířat | SZUMIST1_sz04text | C(40)

    Při pohybu v Aktuální hodnoty
Umístění | Identifikace umístění kategorie zvířat | SZAH_sz04id | C(6)
Druh hodnoty | Identifikace druhu hodnoty | SZAH_sp67id | C(3)
Hodnota | Hodnota | SZAH_sz03hodnot | N(20,4)

    Při pohybu v Umístění
Umístění | Identifikace umístění kategorie zvířat | SZMNP_sz04id | C(6)
1. zobrazovaná hodnota (u kategorie a umístění) | 1. zobrazovaná hodnota (u kategorie a umístění) | SZMNP_sz10hodn1 | N(20,4)
2. zobrazovaná hodnota (u kategorie a umístění) | 2. zobrazovaná hodnota (u kategorie a umístění) | SZMNP_sz10hodn2 | N(20,4)
3. zobrazovaná hodnota (u kategorie a umístění) | 3. zobrazovaná hodnota (u kategorie a umístění) | SZMNP_sz10hodn3 | N(20,4)

    Viz.také

    Události správy artiklu | OZNAČOVÁNÍ | Prezentace artiklu | Legenda palety barev | Ceník artiklu | Adresář | Druhy artiklů | Kategorie událostí správy artiklu | Měrné jednotky | Palety barev kategorií | Spojení | Technicko-věcný selektor


Umístění

Popis

Uživatel má k dispozici přehled jednotlivých umístění skladu zvířat (např. kravín, teletník, stáj apod.). Každé umístění je spojeno s organizačním a účetním selektorem a určitým adresátem.

Ke každému umístění je možno nadefinovat přístupová práva (po stisku Ctrl B nebo volbou příslušné činnost z menu Volby).

Záložka „povolené kategorie“ poskytuje uživateli možnost označit (tj. zaškrtnout) u každého umístění ty kategorie, které má dané umístění povoleno. Povolené kategorie jsou potom hlídány v událostech skladu zvířat, tzn. není možno provést pohyb (příjem, výdej) s kategorií na zvolené umístění, pokud nemá dané umístění tuto kategorii povolenu (tzn. nemůže nastat situace, že by uživatel např. omylem zařadil kategorii prasata do umístění kravín apod.).

Datový model

  • SZUMIST Umístění kategorie zvířat
    • SPSEOR Organizační selektor
    • SPPRISTU Přístupové právo uživatele k věci
    • ADADSAT Adresát
    • ADSPOJ Spojení adresáta
      • ADADR Adresa

    • Formulář

    Formulář činnosti - Spojení
Mřížka [Umístění zvířat]
Umístění | Identifikace umístění kategorie zvířat
Název | Název umístění kategorie zvířat
Org. sel. | Identifikátor organizačního selektoru.
Název organizačního selektoru | Název organizačního selektoru
Účet.sel. | Účetní selektor umístění
Listovací rámeček
Stránka #1 Umístění
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
Ulice | Ulice adresy adresáta (včetně čísla popisného).
PSČ | Poštovní směrovací číslo adresy adresáta.
Město | Město adresy adresáta.
Poznámka | Poznámka
Stránka #2 Povolené kategorie
Mřížka [Povolené kategorie]
Stránka #3 Výběr
Umístění | Identifikace umístění kategorie zvířat
Název | Název umístění kategorie zvířat
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
Org. sel. | Identifikátor organizačního selektoru.
Účet.sel. | Účetní selektor umístění
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Umístění zvířat] činnosti - Spojení

    Mřížka [Umístění zvířat] činnosti - Spojení
Označování | Označení záznamu
Umístění | Identifikace umístění kategorie zvířat
Název | Název umístění kategorie zvířat

    Mřížka [Povolené kategorie] činnosti - Spojení

    Mřížka [Povolené kategorie] činnosti - Spojení
Označování | Označení záznamu
Druh | Identifikace druhu artiklu
Kategorie | Identifikace artiklu
Název kategorie | Název artiklu

    Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
F2 | Adresář | Přehled adresátů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Spojení | Seznam spojení za adresáta.

    Atributy tisku

    Základní údaje
Umístění | Identifikace umístění kategorie zvířat | SZUMIST_sz04id | C(6)
Název umístění | Název umístění kategorie zvířat | SZUMIST_sz04text | C(40)
Org. sel. | Identifikátor organizačního selektoru. | SZUMIST_sp11idzak | C(9)
Název organizačního selektoru | Název organizačního selektoru | SPSEOR_sp11text | C(60)
Účetní selektor umístění | Účetní selektor umístění | SZUMIST_sp00uselum | C(9)
Poznámka | Poznámka | SZUMIST_sz04koment | M
Adresát | Identifikace adresáta | SZUMIST_ad01id | C(6)
Spojení | Číslo spojení adresáta. | SZUMIST_ad11cisspo | C(2)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Ulice | Ulice adresy adresáta (včetně čísla popisného). | ADADR_ad02ulice | C(40)
PSČ | Poštovní směrovací číslo adresy adresáta. | ADADR_ad13psc | C(10)
Město | Město adresy adresáta. | ADADR_ad02mesto | C(40)

    Viz.také

    Přístupová práva | OZNAČOVÁNÍ | Adresář | Organizační selektor | Spojení


Jednotlivá zvířata

Popis

Uživateli se zobrazuje přehled jednotlivých nadefinovaných zvířat. V této činnosti nejsou zvířata členěna na základě kategorie, ale jako jednotlivé kusy s vlastní identifikací. U každého zvířete se na záložce „zvíře“ eviduje:

¨ číslo (tj. jednoznačná identifikace zvířete)

¨ množství – množství na skladě

¨ popis zvířete

¨ volné datum

Záložka „umístění“ poskytuje uživateli informace o umístění, na kterém je zvíře vedeno (tzn. datum zařazení, identifikace umístění a množství). Na záložce „události“ jsou vidět jednotlivé pohyby zvířat (po stisku klávesy F9 lze aktivovat operaci pohybu).

Datový model

  • SZZVIR Jednotlivé zvíře

    • Formulář

    Formulář činnosti - Spustit operaci
Mřížka [Jednotlivá zvířata]
Zvíře | Identifikace zvířete
Popis | Popis zvířete
Volné datum | Volné datum
Množství | Množství na skladě
Listovací rámeček
Stránka #1 Zvíře
Poznámka | Poznámka
Stránka #2 Umístění
Mřížka [Stav]
Stránka #3 Události
Mřížka [Události]
Stránka #4 Výběr
Zvíře | Identifikace zvířete
Na skladě | Stav na skladě
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Jednotlivá zvířata] činnosti - Spustit operaci

    Mřížka [Jednotlivá zvířata] činnosti - Spustit operaci
Označování | Označení záznamu
Zvíře | Identifikace zvířete
Popis | Popis zvířete
Volné datum | Volné datum

    Mřížka [Stav] činnosti - Spustit operaci

    Mřížka [Stav] činnosti - Spustit operaci
Datum | Datum pohybu
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Umístění | Identifikace umístění kategorie zvířat
Množství | Množství zvířat na skladě v umístění

    Mřížka [Události] činnosti - Spustit operaci

    Mřížka [Události] činnosti - Spustit operaci
Datum | Datum pohybu
Poř. | Pořadí v rámci datumu pohybu
P-V | Příznak příjem / výdej
Typ události | Název typu události skladu zvířat
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Umístění | Identifikace umístění kategorie zvířat
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
Množství v RMJ | Množství v RMJ
Množství v MJ - pomocné | Množství v MJ - pomocné
Upravená | Cena celkem - upravená
Popis | Popis události
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Komponenta | Identifikace komponenty
Číslo procesu | Pořadové číslo procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Pořadí | Pořadí stejného druhu operace v jednom procesu
Rok | Rok v identifikaci procesu
Vztah | Vztah ceny k MJ: cena za MJ se vztahuje k RMJ, nebo k MJ-pomocné
MJ | Identifikátor měrné jednotky
MJ - pomocná | Identifikátor měrné jednotky
Cena | Typ ceny

    Vyvolávané činnosti

    K. | Činnost | Popis
F9 | Spustit operaci | Spuštění zobrazené operace
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených

    Atributy tisku

    Základní údaje
Zvíře | Identifikace zvířete | SZZVIR_sz17id | C(20)
Množství | Množství na skladě | SZZVIR_sz17mn | N(20,4)
Popis | Popis zvířete | SZZVIR_sz17text | C(40)
Poznámka | Poznámka | SZZVIR_sz17koment | M
Volné datum | Volné datum | SZZVIR_sz17datvol | D
Název | Název typu události skladu zvířat | SZTYPUD_sz16text | C(40)

    Při pohybu v Události
Časová identifikace | Jednoznačná časová identifikace | SZUDAL_sz02 | C(12)
Ident. | Identifikace uživatele systému | SZUDAL_bw01uziv | C(6)
Datum a čas zápisu | Datum a čas zápisu záznamu události | SZUDAL_sp00datzap | T
Druh | Identifikátor druhu procesu | SZUDAL_sp07idtyp | C(6)
Adresát | Identifikace adresáta | SZUDAL_ad01id | C(6)
Spojení | Číslo spojení adresáta. | SZUDAL_ad11cisspo | C(2)
Druh artiklu | Identifikace druhu artiklu | SZUDAL_sp61id | C(3)
Artikl | Identifikace artiklu | SZUDAL_sp60id | C(13)
Umístění | Identifikace umístění kategorie zvířat | SZUDAL_sz04id | C(6)
Datum | Datum pohybu | SZUDAL_sz02datum | D
Pořadí v rámci datumu pohybu | Pořadí v rámci datumu pohybu | SZUDAL_sz02dpor | N(5)
MJ | Identifikátor měrné jednotky | SZUDAL_sp24idmj | C(3)
MJ - pomocná | Identifikátor měrné jednotky | SZUDAL_sp24idmj1 | C(3)
Množství v RMJ | Množství v RMJ | SZUDAL_sz02mnmj | N(20,4)
Množství v MJ - pomocné | Množství v MJ - pomocné | SZUDAL_sz02mnmj1 | N(20,4)
Cena za MJ | Cena za oceňovací měrnou jednotku | SZUDAL_sz02cj | N(20,4)
Cena za MJ - upravená | Cena za oceňovací měrnou jednotku - upravená | SZUDAL_sz02cj1 | N(20,4)
Cena celkem | Cena celkem | SZUDAL_sz02cc | N(20,4)
Cena celkem - upravená | Cena celkem - upravená | SZUDAL_sz02cc1 | N(20,4)
Popis | Popis události | SZUDAL_sz02text | C(40)
Poznámka | Poznámka | SZUDAL_sz02koment | M
Obch. sel. | Identifikátor obchodního selektoru | SZUDAL_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | SZUDAL_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | SZUDAL_sp20idzak | C(9)
Komponenta | Identifikace komponenty | SZUDAL_sp06idsubs | C(3)
Číslo procesu | Pořadové číslo procesu | SZUDAL_sp33cisd | C(8)
IDÚ | Identifikace datového úložiště číselné řady procesu | SZUDAL_sp33cisdpm | C(2)
Pořadí druhu operace | Pořadí stejného druhu operace v jednom procesu | SZUDAL_sp33porad | N(2)
Rok | Rok v identifikaci procesu | SZUDAL_sp33cisdr | C(4)
Vztah | Vztah ceny k MJ: cena za MJ se vztahuje k RMJ, nebo k MJ-pomocné | Výpočet | C(10)
Cena | Typ ceny | Výpočet | C(8)
Typ | Identifikace typu události skladu zvířat | SZUDAL_sz16id | C(3)
Volné datum | Volné datum události | SZUDAL_sz02datvol | D

    Při pohybu v Stavy
Druh artiklu | Identifikace druhu artiklu | SZZVIRP_sp61id | C(3)
Artikl | Identifikace artiklu | SZZVIRP_sp60id | C(13)
Umístění | Identifikace umístění kategorie zvířat | SZZVIRP_sz04id | C(6)
Množství | Množství zvířat na skladě v umístění | SZZVIRP_sz18mn | N(20,4)
Datum | Datum pohybu | SZZVIRP_sz02datum | D

    Viz.také

    Spustit operaci | OZNAČOVÁNÍ


Obraty skladu zvířat

Popis

Tato činnost umožňuje uživateli prohlížet si jednotlivé obraty skladu zvířat. Zobrazení potřebných údajů je přímo závislé na tom, jakým způsobem si uživatel nadefinuje záložku „výběr“. Jako u jiných výběrových záložek je možno si vybírat z několika atributů, na základě kterých se budou vybírat data. Kromě těch běžných jako je datum od - do, druh hodnoty, adresát, artikl, sklad apod. je zde atribut, který má zásadní význam pro zobrazení dat. Tento atribut se nazývá „poslední obrat“ a dosahuje těchto hodnot:

¨ neurčeno - zobrazuje veškeré obraty nezávisle na období (tzn. není nutno zadávat žádné období od - do). Tuto hodnotu je vhodné využít např. při zobrazení hodnot za vybraný sklad, artikl nebo adresáta.

¨ zahrnout - hodnota zahrnout naopak úzce souvisí s obdobím od - do. Při použití hodnoty zahrnout je zároveň nutno zadat období OD - DO a systém pak zobrazí obraty za dané období s tím, že pokud u některého artiklu nenajde obrat v zadaném období OD - DO, zobrazí obrat s nejvyšším nižším datem

¨ pouze - hodnotu pouze má smysl používat nikoliv pro zjišťování obratů, ale pro zjištění konečných stavů s tím, že zároveň s touto hodnotou musí být uvedeno období DO (období OD zůstává nevyplněné).

U každého druhu hodnoty vyfiltrované za adresáta nebo kategorii je k dispozici informace o počátečním stavu, příjmu, výdeji a konečném stavu.

Datový model

  • SZOBRAT Obrat skladu zvířat
    • SPSTATDI Druh hodnoty
    • SZARTIKL Kategorie zvířat
      • SPARTIKN Název artiklu
      • SPSETV Technicko-věcný selektor
    • SZUMIST Umístění kategorie zvířat
      • SPPRISTU Přístupové právo uživatele k věci
      • SPSEOR Organizační selektor
    • ADADSAT Adresát
      • SPSEOB Obchodní selektor

    • Formulář

    Formulář činnosti - Technicko-věcný selektor
Mřížka [Obraty skladu zvířat]
Listovací rámeček
Stránka #1 Obraty skladu zvířat
 | Datum obratu
Druh hodnoty | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Adresát | Identifikace adresáta
 | Název adresáta
Druh artiklu | Identifikace druhu artiklu
Kategorie | Identifikace artiklu
Název artiklu | Název artiklu
MJ | Identifikátor měrné jednotky
Umístění | Identifikace umístění kategorie zvířat
Název | Název umístění kategorie zvířat
Selektory | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
PS | Počáteční stav
P | Příjem
V | Výdej
KS | Konečný stav
Stránka #2 Výběr
Datum | Datum
do | Datum do
Poslední obrat | Zobrazení posledního obratu
Druh hodnoty | Identifikace druhu hodnoty
Druh artiklu | Identifikace druhu artiklu
Kategorie | Identifikace artiklu
Název artiklu | Název artiklu
Umístění | Identifikace umístění kategorie zvířat
Název | Název umístění kategorie zvířat
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Selektory | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Obraty skladu zvířat] činnosti - Technicko-věcný selektor

    Mřížka [Obraty skladu zvířat] činnosti - Technicko-věcný selektor
Datum | Datum obratu
Druh hodnoty | Identifikace druhu hodnoty
Druh artiklu | Identifikace druhu artiklu
Kategorie | Identifikace artiklu
Umístění | Identifikace umístění kategorie zvířat
Adresát | Identifikace adresáta
Poč.stav | Počáteční stav
Příjem | Příjem
Výdej | Výdej
Kon.stav | Konečný stav
Název druhu hodnoty | Název druhu hodnoty
Název artiklu | Název artiklu
Název umístění | Název umístění kategorie zvířat
Název adresáta | Název adresáta
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Kategorie zvířat | Seznam kategorií zvířat
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Umístění | Seznam umístění

    Atributy tisku

    Základní údaje
Druh artiklu | Identifikace druhu artiklu | SZOBRAT_sp61id | C(3)
Kategorie | Identifikace kategorie | SZOBRAT_sp60id | C(13)
Umístění | Identifikace umístění kategorie zvířat | SZOBRAT_sz04id | C(6)
Adresát | Identifikace adresáta | SZOBRAT_ad01id | C(6)
Datum | Datum obratu | SZOBRAT_sz08datum | D
Poč.stav | Počáteční stav | SZOBRAT_sz08pstav | N(20,4)
Příjem | Příjem | SZOBRAT_sz08prijem | N(20,4)
Výdej | Výdej | SZOBRAT_sz08vydej | N(20,4)
Kon.stav | Konečný stav | Výpočet | N(20,4)
Druh hodnoty | Identifikace druhu hodnoty | SZOBRAT_sp67id | C(3)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)
Komponenta | Identifikace komponenty | SZOBRAT_sp06idsubs | C(3)
Název kategorie | Název kategorie | SPARTIKN_sp62artikl | C(60)
Tech. sel. | Identifikátor technicko-věcného selektoru. | SZARTIKL_sp20idzak | C(9)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(60)
MJ | Identifikátor měrné jednotky | SZARTIKL_sp24idmj | C(3)
Název umístění | Název umístění kategorie zvířat | SZUMIST_sz04text | C(40)
Org. sel. | Identifikátor organizačního selektoru. | SZUMIST_sp11idzak | C(9)
Název organizačního selektoru | Název organizačního selektoru | SPSEOR_sp11text | C(60)
Adresát | Název adresáta | ADADSAT_ad01adsat | C(100)
IČO | Identifikační číslo organizace. | ADADSAT_ad01ico | C(10)
DIČ | Daňové identifikační číslo adresáta. | ADADSAT_ad01dico | C(16)
Obch. sel. | Identifikátor obchodního selektoru | ADADSAT_sp10idzak | C(9)
Název obchodního selektoru | Název obchodního selektoru | SPSEOB_sp10text | C(60)

    Viz.také

    Adresář | Druhy artiklů | Druhy hodnot | Kategorie adresátů | Kategorie zvířat | Obchodní selektor | Organizační selektor | Technicko-věcný selektor | Umístění


Typ události skladu zvířat

Popis

Číselník typů událostí skladu zvířat, který se využívá jak při vytváření událostí skladu zvířat, tak je možno ho používat jako atribut na záložce výběr v Událostech skladu zvířat. Definuje se:

¨ typ a název

¨ účetní selektor

¨ poznámka

Ke každému typu události lze přiřadit (tj. zaškrtnout) povolené kategorie. Toto se provede na záložce „povolené kategorie“. Jinými slovy je tímto označením povolených kategorií zařízeno, že každý typ pohybu má přiřazen správnou kategorii pro použití v událostech, takže nemůže nastat situace, že by např. typ pohybu „oprasení“ byl v událostech svázán s kategorií „telata“.

Zároveň ke každému typu události lze přiřadit (tj. vložit) povolené druhy operací. Tímto je jednoznačně určeno, že daný typ události může být použit pouze v souvislosti s povolenými druhy operací, takže nemůže nastat případ, že typ události např. výdej – prodej na fakturu by byl zadán na operaci příjem.

Datový model

  • SZTYPUD Typ události skladu zvířat

    • Formulář

    Formulář činnosti - Druhy operací
Mřížka [Typ události skladu zvířat]
Typ | Identifikace typu události skladu zvířat
Název | Název typu události skladu zvířat
Účetní selektor | Účetní selektor
Listovací rámeček
Stránka #1 Typy událostí
Poznámka | Poznámka
Stránka #2 Povolené kategorie
Mřížka [Poolené kategorie]
Stránka #3 Povolené druhy operací
Mřížka [Povolené druhy ooperace]
Druh operace | Identifikátor druhu operace
 | Název druhu procesu
Příjem / výdej | Příznak příjem / výdej
Stránka #4 Výběr
Typ | Identifikace typu události skladu zvířat
Název | Název typu události skladu zvířat
Účetní selektor | Účetní selektor
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Typ události skladu zvířat] činnosti - Druhy operací

    Mřížka [Typ události skladu zvířat] činnosti - Druhy operací
Označování | Označení záznamu
Typ | Identifikace typu události skladu zvířat
Název | Název typu události skladu zvířat

    Mřížka [Poolené kategorie] činnosti - Druhy operací

    Mřížka [Poolené kategorie] činnosti - Druhy operací
Označování | Označení záznamu
Druh | Identifikace druhu artiklu
Kategorie | Identifikace artiklu
Název kategorie | Název artiklu

    Mřížka [Povolené druhy ooperace] činnosti - Druhy operací

    Mřížka [Povolené druhy ooperace] činnosti - Druhy operací
Druh operace | Identifikátor druhu operace
Název druhu operace | Název druhu procesu
P-V | Příznak příjem / výdej

    Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
F2 | Druhy operací | Přehled druhů operací

    Atributy tisku

    Základní údaje
TU | Identifikace typu události skladu zvířat | SZTYPUD_sz16id | C(3)
Název | Název typu události skladu zvířat | SZTYPUD_sz16text | C(40)
Účetní selektor | Účetní selektor | SZTYPUD_sp00ucsel | C(9)
Poznámka | Poznámka | SZTYPUD_sz16koment | M

    Viz.také

    OZNAČOVÁNÍ | Druhy operací


Povolené typy události druhu operace

Popis

V této činnosti uživatel zadává k jednotlivým druhům operace povolené typy událostí. U každé vazby druhu operace na zvolený typu události se zadává:

¨ identifikace a název operace

¨ identifikace a název typu události

¨ P-V – zda se jedná o příjmový či výdajový pohyb

¨ libovolná poznámka

Datový model

  • SZDOTU Vazba druh operace-typ události
    • SPTYP Druh procesu/operace
    • SZTYPUD Typ události skladu zvířat

    • Formulář

    Formulář činnosti - Typ události skladu zvířat
Mřížka [Vazba druhu operace na typ události]
Operace | Identifikátor druhu operace
 | Název druhu procesu
Typ události | Identifikace typu události skladu zvířat
 | Název typu události skladu zvířat
P-V | Příznak příjem / výdej
Listovací rámeček
Stránka #1 Vazba druhu operace na typ události
Poznámka | Poznámka
Stránka #2 Výběr
Operace | Identifikátor druhu operace
 | Název druhu operace
Typ události | Identifikace typu události skladu zvířat
 | Název typu události skladu zvířat
P-V | Příznak příjem / výdej
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Vazba druhu operace na typ události] činnosti - Typ události skladu zvířat

    Mřížka [Vazba druhu operace na typ události] činnosti - Typ události skladu zvířat
Druh operace | Identifikátor druhu operace
Typ události | Identifikace typu události skladu zvířat
Příjem / výdej | Příznak příjem / výdej
Název druhu operace | Název druhu procesu
Typ události | Název typu události skladu zvířat

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druhy operací | Přehled druhů operací
F2 | Typ události skladu zvířat | Seznam typů události skladu zvířat

    Atributy tisku

    Základní údaje
Komponenta | Identifikace komponenty | SZDOTU_sp06idsubs | C(3)
Druh operace | Identifikátor druhu operace | SZDOTU_sp07idtyp | C(6)
Název druhu operace | Název druhu procesu | SPTYP_sp07text | C(30)
Typ události | Identifikace typu události skladu zvířat | SZDOTU_sz16id | C(3)
Název | Název typu události skladu zvířat | SZTYPUD_sz16text | C(40)
Příjem / výdej | Příznak příjem / výdej | Výpočet | C(6)
Poznámka | Poznámka | SZDOTU_sz25koment | M

    Viz.také

    Druhy operací | Typ události skladu zvířat


Povolená umístění kategorie

Popis

Tato činnost poskytuje uživateli možnost nadefinovat si ke každé kategorii zvířat (tj. v podstatě k artiklu skladu zvířat) povolené umístění, tzn. v událostech skladu zvířat je pak hlídáno, že např. kategorie selata nemůže být použita s umístěním teletník apod. (pokud si to tak ovšem uživatel chybně nenadefinuje). U každé vazby umístění na kategorii se definuje:

¨ identifikace a název kategorie zvířat

¨ identifikace a název umístění

¨ poznámka

Datový model

  • SZARTUM Vazba kategorie-umístění
    • SZARTIKL Kategorie zvířat
    • SZUMIST Umístění kategorie zvířat

    • Formulář

    Formulář činnosti - Prezentace artiklu
Mřížka [Vazba umístěníi na kategorii]
Druh artiklu | Identifikace druhu artiklu
Kategorie | Identifikace artiklu
Název artiklu | Název kategorie
Umístění | Identifikace umístění kategorie zvířat
Název | Název umístění kategorie zvířat
Listovací rámeček
Stránka #1 Vazba umístění na kategorii
Poznámka | Poznámka
Stránka #2 Výběr
Druh artiklu | Identifikace druhu artiklu
Kategorie | Identifikace kategorie
Název kategorie | Název kategorie
Umístění | Identifikace umístění kategorie zvířat
Název | Název umístění kategorie zvířat
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Vazba umístěníi na kategorii] činnosti - Prezentace artiklu

    Mřížka [Vazba umístěníi na kategorii] činnosti - Prezentace artiklu
Druh | Identifikace druhu artiklu
Kategorie | Identifikace artiklu
Umístění | Identifikace umístění kategorie zvířat
Název artiklu | Název kategorie
Název umístění | Název umístění kategorie zvířat

    Vyvolávané činnosti

    K. | Činnost | Popis
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Kategorie zvířat | Seznam kategorií zvířat
F2 | Umístění | Seznam umístění

    Atributy tisku

    Základní údaje
Druh artiklu | Identifikace druhu artiklu | SZARTUM_sp61id | C(3)
Kategorie | Identifikace artiklu | SZARTUM_sp60id | C(13)
Název kategorie | Název artiklu | SZARTIKL_sp60artikl | C(40)
Umístění | Identifikace umístění kategorie zvířat | SZARTUM_sz04id | C(6)
Název umístění | Název umístění kategorie zvířat | SZUMIST_sz04text | C(40)
Poznámka | Poznámka | SZARTUM_sz20koment | M

    Viz.také

    Prezentace artiklu | Druhy artiklů | Kategorie zvířat | Umístění


Povolené typy událostí kategorie

Popis

Tato činnost poskytuje uživateli možnost nadefinovat si ke každé kategorii zvířat (tj. v podstatě k artiklu skladu zvířat) povolené typy události, tzn. v událostech skladu zvířat je pak hlídáno, že např. kategorie jalovice (příjmový pohyb) nemůže být použita s typem události výdej – prodej na fakturu apod. (pokud si to tak ovšem uživatel chybně nenadefinuje). U každé vazby typu události na kategorii se definuje:

¨ identifikace a název kategorie zvířat

¨ identifikace a název typu události

¨ poznámka

Datový model

  • SZARTTU Vazba kategorie-typ události
    • SZARTIKL Kategorie zvířat
    • SZTYPUD Typ události skladu zvířat

    • Formulář

    Formulář činnosti - Typ události skladu zvířat
Mřížka [Vazba typu události na kategorii]
Druh artiklu | Identifikace druhu artiklu
Kategorie | Identifikace artiklu
Název kategorie | Název kategorie
Typ události | Identifikace typu události skladu zvířat
Název | Název typu události skladu zvířat
Listovací rámeček
Stránka #1 Vazba typu události na kategorii
Poznámka | Poznámka
Stránka #2 Výběr
Druh artiklu | Identifikace druhu artiklu
Kategorie | Identifikace kategorie
Název kategorie | Název kategorie
Typ události | Identifikace typu události skladu zvířat
Název | Název typu události skladu zvířat
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Vazba typu události na kategorii] činnosti - Typ události skladu zvířat

    Mřížka [Vazba typu události na kategorii] činnosti - Typ události skladu zvířat
Druh artiklu | Identifikace druhu artiklu
Kategorie | Identifikace kategorie
Typ události | Identifikace typu události skladu zvířat
Název kategorie | Název kategorie
Typ události | Název typu události skladu zvířat

    Vyvolávané činnosti

    K. | Činnost | Popis
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Kategorie zvířat | Seznam kategorií zvířat
F2 | Typ události skladu zvířat | Seznam typů události skladu zvířat

    Atributy tisku

    Základní údaje
Druh artiklu | Identifikace druhu artiklu | SZARTTU_sp61id | C(3)
Kategorie | Identifikace kategorie | SZARTTU_sp60id | C(13)
Název kategorie | Název kategorie | SZARTIKL_sp60artikl | C(40)
Typ události | Identifikace typu události skladu zvířat | SZARTTU_sz16id | C(3)
Typ události | Název typu události skladu zvířat | SZTYPUD_sz16text | C(40)
Poznámka | Poznámka | SZARTTU_sz21koment | M

    Viz.také

    Prezentace artiklu | Druhy artiklů | Kategorie zvířat | Typ události skladu zvířat


Parametry komp. sklad zvířat

Popis

Parametry ovlivňující chování komponenty skladu zvířat, tj.:

¨ 1. zobrazovaná hodnota (u kategorie) - nastavený druh hodnoty a výše hodnoty uvedeného druhu se pak zobrazuje na kartě kategorie zvířat jako 1. zobrazovaná hodnota

¨ 2. zobrazovaná hodnota (u kategorie) - nastavený druh hodnoty a výše hodnoty uvedeného druhu se pak zobrazuje na kartě kategorie zvířat jako 2. zobrazovaná hodnota

¨ 3. zobrazovaná hodnota (u kategorie) - nastavený druh hodnoty a výše hodnoty uvedeného druhu se pak zobrazuje na kartě kategorie zvířat jako 3. zobrazovaná hodnota

¨ cena skladová - nastavení druhu hodnoty, který představuje cenu skladovou. Cenu skladovou u jednotlivých kategorií si pak systém automaticky dopočítává z událostí a obratů skladu zvířat a v operacích výdeje, kde je nastaveno, že výdej bude za cenu skladovou, se pak tato cena automaticky předplňuje.

¨ množství v RMJ pro výpočet ceny skladové - druh hodnoty, který udává množství zvířat v referenční měrné jednotce (slouží pro výpočet jednotkové ceny skladové)

¨ množství v MJ pro výpočet KD - druh hodnoty, který udává množství zvířat v referenční měrné jednotce (slouží pro výpočet počtu krmných dnů u kategorií, které mají zaškrtnutý příznak KD)

¨ cenová skupina pro výpočet vzrůst. přír. - identifikace cenové skupiny, která je určena pro výpočet vzrůstového přírůstku. Jestliže požadujeme u kategorie výpočet vzrůstového přírustku, musí mít tato kategorie záznam v ceníku (třebaže ceníková cena bude nulová).

¨ započítávat stavy do KD - zápočet krmných dnů se provádí na základě počátečních nebo konečných stavů. V případě nastavení „počátečních stavů“ se v daný den do krmných dnů nezapočítávají naskladněná zvířata, ale započítávají se pouze v ten den vyskladněná a do příjmových operací se do atributu pořadí automaticky předplňuje 1. V případě nastavení „konečných stavů“ se v daný den do krmných dnů nezapočítávají vyskladněná (prodaná) zvířata, ale započítávají se pouze v ten den naskladněná a do výdajových operací se do atributu pořadí automaticky předplňuje 99999.

Datový model

  • SZPAR Parametry komponenty sklad zvířat
    • BWUZIVAT Uživatel systému
    • SPSTATDI Druh hodnoty (alias SPSTATDI1)
    • SPSTATDI Druh hodnoty (alias SPSTATDI2)
    • SPSTATDI Druh hodnoty (alias SPSTATDI3)
    • SPSTATDI Druh hodnoty (alias SPSTATDI4)
    • SPSTATDI Druh hodnoty (alias SPSTATDI5)
    • SPSTATDI Druh hodnoty (alias SPSTATDI6)
    • OBCENSKP Cenová skupina obchodovatelného artiklu

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Cenové skupiny | Přehled cenových skupin obchodovatelného artiklu
F2 | Druhy hodnot | Seznam druhů statistických informací

    Formulář

    Formulář činnosti - Druhy hodnot
1. zobrazovaná hodnota (u kategorie) | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
2. zobrazovaná hodnota (u kategorie) | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
3. zobrazovaná hodnota (u kategorie) | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Cena skladová | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Množství v RMJ pro výpočet ceny skladové | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Množství v MJ pro výpočet: KD; mn. jednotlivých zvířat | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty
Cenová skupina pro výpočet vzrůst. přír. | Identifikace cenové skupiny
Název cenové skupiny | Název cenové skupiny
Započítávat stavy do KD | Zápočet KD se provádí na základě PS nebo KS
Změnil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události

    Viz.také

    Cenové skupiny | Druhy hodnot


POZEMKY

Popis

Tato komponenta poskytuje uživateli možnost komfortního vedení správy a evidence jednotlivých nemovitostí či celků z nich vytvářených. Podstatnou vlastností této komponenty je schopnost využití dat evidovaných Českým úřadem zeměměřickým a katastrálním s další možností uživatelského zpracování.

U každé nemovitosti pak dále sledujeme její stav a umístění, katastr, správní celky, jednotlivé listy vlastnictví apod.

Viz.také

Události o nemovitostech | Nemovitosti | BMTopol | Oprávněné subjekty | Katastry nemovitostí | Jiné právní vztahy | Listiny - pozemky | Listy vlastnictví | Řízení - pozemky | Správní celky | Složené typy pro pozemky | Druhy událostí o nemovitostech | Stavy nemovitostí | Transformace změn - nemovitost | Umístění nemovitostí | Parametry komp. nemovitosti | Stavy dat | Popis mapy Topolu


Události o nemovitostech

Popis

Uživatel má na základě zvoleného výběru k dispozici jednotlivé vytvořené události nemovitostí. Jednotlivé události nelze vkládat samostatně, ale pouze v rámci procesu. Uživatel aktivuje nový proces a přes menu Volby spustí činnost "Provedení importu".

Naimportovaná data z Českého úřadu zeměměřického a katastrálního pak uživateli poskytují informace, jaké změny a jakého druhu se s danou nemovitostí udály.

Datový model

  • PYUDAL Událost o nemovitosti
    • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU3)
    • ADADSAT Adresát
    • ADSPOJ Spojení adresáta
    • PYNEMOV Nemovitost
      • PYUMIST Umístění nemovitosti
        • SPPRISTU Přístupové právo uživatele k věci
    • PYDRUUDA Druh události o nemovitosti
      • PYUMIST Umístění nemovitosti (alias PYUMIST2)
        • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)
    • SPPRCOD Operace procesu
      • SPPRC Proces
    • BWUZIVAT Uživatel systému
    • SPTYP Druh procesu/operace

    • Formulář

    Formulář činnosti - BMTopol
Mřížka [Události]
Listovací rámeček
Stránka #1 Události
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
 | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Název druhu procesu
Datum | Datum události o nemovitosti
Druhé datum | Druhé datum události o nemovitosti
Třetí datum | Třetí datum události o nemovitosti
Popis | Popis události o nemovitosti
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
 | Identifikace druhu artiklu
Nemovitost | Identifikace artiklu
 | Název artiklu
Druh | Identifikace druhu události o nemovitosti
Název druhu | Název druhu události o nemovitosti
Změna stavu | Změnit stav nemovitosti Ne/Vznik stavu/Ukončení stavu/Zrušení stavu
Hodnota | Hodnota
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Pozn. | Poznámka
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Stránka #2 Výběr
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
do | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Druh procesu | Identifikátor druhu procesu
Datum | Datum události o nemovitosti
do | Datum události o nemovitosti do
Druh | Identifikace druhu události o nemovitosti
Popis | Popis události o nemovitosti
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Druh artiklu | Identifikace druhu artiklu
Nemovitost | Identifikace artiklu
Název artiklu | Název artiklu
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Zapsal | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Události] činnosti - BMTopol

    Mřížka [Události] činnosti - BMTopol
Označování | Označení záznamu
IDÚ | Identifikace datového úložiště číselné řady procesu
Rok | Rok v identifikaci procesu
Číslo procesu | Pořadové číslo procesu
Datum | Datum události o nemovitosti
Popis | Popis události o nemovitosti
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Druh | Identifikace druhu artiklu
Nemovitost | Identifikace artiklu
Název nemovitosti | Název artiklu
Druh | Identifikace druhu události o nemovitosti
Název druhu | Název druhu události o nemovitosti
Změna stavu | Změnit stav nemovitosti Ne/Vznik stavu/Ukončení stavu/Zrušení stavu
Druhé datum | Druhé datum události o nemovitosti
Třetí datum | Třetí datum události o nemovitosti
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | BMTopol |
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Přepočet stavu nemovitostí | Přepočet stavu nemovitostí
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Druhy událostí o nemovitostech | Druhy událostí o nemovitostech
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Nemovitosti | Nemovitosti
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Atributy tisku

    Základní údaje
IDÚ | Identifikace datového úložiště číselné řady procesu | PYUDAL_sp33cisdpm | C(2)
Rok | Rok v identifikaci procesu | PYUDAL_sp33cisdr | C(4)
Číslo procesu | Pořadové číslo procesu | PYUDAL_sp33cisd | C(8)
Operace | Identifikátor druhu operace | PYUDAL_sp07idtyp | C(6)
Název druhu operace | Název druhu procesu | SPTYP_sp07text | C(30)
Pořadí | Pořadí stejného druhu operace v jednom procesu | PYUDAL_sp33porad | N(2)
Datum | Datum události o nemovitosti | PYUDAL_py02datum | D
Druhé datum | Druhé datum události o nemovitosti | PYUDAL_py02datum2 | D
Třetí datum | Třetí datum události o nemovitosti | PYUDAL_py02datum3 | D
Popis | Popis události o nemovitosti | PYUDAL_py02text | C(40)
Druh artiklu | Identifikace druhu artiklu | PYUDAL_sp61id | C(3)
Nemovitost | Identifikace artiklu | PYUDAL_sp60id | C(13)
Název artiklu | Název artiklu | PYNEMOV_sp60artikl | C(60)
Adresát | Identifikace adresáta | PYUDAL_ad01id | C(6)
Spojení | Číslo spojení adresáta. | PYUDAL_ad11cisspo | C(2)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Druh | Identifikace druhu události o nemovitosti | PYUDAL_py03id | C(6)
Název druhu | Název druhu události o nemovitosti | PYDRUUDA_py03nazdru | C(40)
Změna stavu | Změnit stav nemovitosti Ne/Vznik stavu/Ukončení stavu/Zrušení stavu | Výpočet | C(14)
Hodnota | Hodnota | PYUDAL_py02hodnot | N(20,4)
Obch. sel. | Identifikátor obchodního selektoru | PYUDAL_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | PYUDAL_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | PYUDAL_sp20idzak | C(9)
Pozn. | Poznámka | PYUDAL_py02koment | M
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum a čas zápisu | Datum a čas zápisu záznamu události | PYUDAL_sp00datzap | T


Nemovitosti

Popis

Uživatel má k dispozici přehled jednotlivých nemovitostí a veškeré informace s nimi spojené. Tyto údaje uživatel nevstupuje samostatně, jsou vytvořeny pomocí importu oficiálních dat z Českého úřadu zeměměřického a katastrálního.

Na první záložce "nemovitosti" má uživatel k dispozici základní údaje o nemovitosti (identifikace, parcelní číslo, katastr, výměra, list vlastnictví apod.). Na základě zadaného stavu nemovitosti jsou jednotlivé nemovitosti odlišeny barevně (pokud je tedy na stavech nemovitostí nastaveno barevné rozlišení).

Mezi další důležité záložky patří "BDP", kde jsou sledovány bonitní díly parcel, záložka "parametry", "podíly", "ochrana", "řízení", "JPV (jiné právní vztahy) a "stavy".

V menu Volby má uživatel k dispozici činnost Informace o nemovitosti, kde jsou soustředěny veškeré informace k právě aktuální nemovitosti.

Datový model

  • PYNEMOV Nemovitost
    • PYSTADAT Stav dat
    • SPARTIKL Artikl
    • SPARTIKN Název artiklu
    • SPSEOR Organizační selektor
    • SPSETV Technicko-věcný selektor
    • PYUMIST Umístění nemovitosti
      • SPPRISTU Přístupové právo uživatele k věci
    • PYNEMLV List vlastnictví nemovitosti (těleso)
    • PYKATAST Katastrální území
    • PYTYPCIS Sloučený typ - spojené číselníky (alias PYTYPCIS1)
    • PYTYPCIS Sloučený typ - spojené číselníky (alias PYTYPCIS2)
    • PYTYPCIS Sloučený typ - spojené číselníky (alias PYTYPCIS3)
    • PYTYPCIS Sloučený typ - spojené číselníky (alias PYTYPCIS4)

    • Formulář

    Formulář činnosti - Události správy artiklu
Mřížka [Nemovitosti]
Druh | Identifikace druhu artiklu
Nemovitost | Identifikace artiklu
Název artiklu | Název artiklu
Listovací rámeček
Stránka #1 Nemovitosti
Externí id. | Externí identifikace nemovitosti
Katastr | Číslo katastru
Název katastru | Název katastru nemovitostí
Kmenové číslo | Kmenové číslo parcely
Číslo dílu | Číslo dílu parcely
Výměra | Výměra parcely
Charakter | Charakter nemovitosti - Parcela/Díl parcely/Budova/Část budovy/Jednotka
List vl. | ID listu vlastnictví
Druh | Druh artiklu
Vyšší celek | Identifikace artiklu
Druh | Identifikace druhu artiklu
Budova | Identifikace artiklu
Typ | Typ nemovitosti
Název typu | Název typu
Zdroj evidence | Zdroj evidence parcel
Název typu | Název typu
Určení výměry | Způsob určení výměry
Název typu | Název typu
Způsob využití | Způsob využití nemovitosti
Název typu | Název typu
Stav dat | Identifikátor stavu dat
Název stavu dat | Název stavu dat
Stránka #2 Další
Umístění | Identifikace umístění nemovitosti
Název umístění | Název umístění nemovitosti
Org. sel. | Identifikátor organizačního selektoru.
 | Název organizačního selektoru
Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Název technicko-věcného selektoru.
Dat.vzniku | Datum vzniku
Dat.zániku | Datum zániku
Řízení vzniku | Řízení vzniku
Řízení zániku | Řízení zániku
Stránka #3 BDP
Mřížka [BDP]
BPEJ | Kód bonitního dílu parcely BPEJ
Výměra | Výměra bonitního dílu
Stav dat | Identifikátor stavu dat
Název stavu dat | Název stavu dat
Řízení vzniku | Řízení vzniku
Řízení zániku | Řízení zániku
Datum vzniku | Datum vzniku
Datum zániku | Datum zániku
Stránka #4 Parametry
Mřížka [Hodnoty parametrů]
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Identifikátor spojení na bankovní účet adresáta.
 | Název adresáta
ID | Identifikace položky číselníku
 | Název položky číselníku
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Text1 | Textová elementární hodnota
Dat1 | Datumová elementární hodnota 1
Dat2 | Datumová elementární hodnota 2
Num1 | Numerická elementární hodnota 1
Num2 | Numerická elementární hodnota 2
Cmb1 | Překryvný seznam elementární hodnota 1
Cmb2 | Překryvný seznam elementární hodnota 2
Poznámka | Poznámka
Platnost od | Platnost od
do | Platnost do
Stránka #5 Podíly
Mřížka [Podíly]
Vlastnictví | Číslo vlastnictví
Subjekt | Identifikace adresáta
 | Název adresáta
Právní vztah | Typ právního vztahu
Název typu | Název typu
Stav dat | Identifikátor stavu dat
Název stavu dat | Název stavu dat
Datum vzniku | Datum vzniku
Datum zániku | Datum zániku
Řízení vzniku | Řízení vzniku
Řízení zániku | Řízení zániku
Čitatel | Čitatel podílu vlastnictví spoluvlastníka
Jmenovatel | Jmenovatel podílu vlastnictví spoluvlastníka
Stránka #6 Ochrana
Mřížka [Způsoby ochrany]
ID | Identifikace záznamu
Ochrana | Způsob ochrany nemovitosti
Název typu | Název typu
Stav dat | Identifikátor stavu dat
Název stavu dat | Název stavu dat
Datum vzniku | Datum vzniku
Datum zániku | Datum zániku
Řízení vzniku | Řízení vzniku
Řízení zániku | Řízení zániku
Stránka #7 Řízení
Mřížka [Řízení]
ID | Identifikace objektu řízení
Řízení | Číslo řízení
Předmět řízení | Předmět řízení
Stav | Aktuální stav řízení
Zaplombování | Datum zaplombování nebo zápisu objektů do řízení.
Odplombování | Datum odstranění plomby
Stránka #8 JPV +
Mřížka [JPV +]
JPV | Identifikace jiného právního vztahu
List vl. | ID listu vlastnictví
Právní vztah | Typ právního vztahu
Název typu | Název typu
Stav dat | Identifikátor stavu dat
Název stavu dat | Název stavu dat
 | Druh artiklu
N. k tíži | Identifikace artiklu
Popis | Poznámka - popis
Datum vzniku | Datum vzniku
Datum zániku | Datum zániku
Stránka #9 JPV
Mřížka [JPV -]
JPV | Identifikace jiného právního vztahu
List vl. | ID listu vlastnictví
Právní vztah | Typ právního vztahu
Název typu | Název typu
Stav dat | Identifikátor stavu dat
Název stavu dat | Název stavu dat
 | Identifikace druhu artiklu
N. ku prosp. | Identifikace artiklu
Popis | Poznámka - popis
Datum vzniku | Datum vzniku
Datum zániku | Datum zániku
Stránka #10 Stavy
Mřížka [Stavy nemovitosti]
Stav | Identifikace stavu nemovitosti
Název stavu | Název stavu nemovitosti
Platnost od | Platnost od
do | Platnost do
Stránka #11 Výběr
Druh | Identifikace druhu artiklu
Nemovitost | Identifikace artiklu
Název nemovitosti | Název artiklu
Externí id. | Externí identifikace nemovitosti
Charakter | Charakter nemovitosti - Parcela/Díl parcely/Budova/Část budovy/Jednotka
Katastr | Číslo katastru
List vl. | ID listu vlastnictví
Subjekt | Identifikace adresáta
 | Název adresáta
Typ | Typ nemovitosti
Zdroj evidence | Zdroj evidence parcel
Určení výměry | Způsob určení výměry
Způsob využití | Způsob využití nemovitosti
Umístění | Identifikace umístění nemovitosti
Stav | Identifikace stavu nemovitosti
Řízení | Číslo řízení
Stav dat | Identifikátor stavu dat
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Nemovitosti] činnosti - Události správy artiklu

    Mřížka [Nemovitosti] činnosti - Události správy artiklu
Označování | Označení záznamu
Druh | Identifikace druhu artiklu
Nemovitost | Identifikace artiklu
Název nemovitosti | Název artiklu
Katastr | Číslo katastru
Název katastru | Název katastru nemovitostí
Externí id. | Externí identifikace nemovitosti
List vl. | ID listu vlastnictví
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Mřížka [BDP] činnosti - Události správy artiklu

    Mřížka [BDP] činnosti - Události správy artiklu
BPEJ | Kód bonitního dílu parcely BPEJ
Výměra | Výměra bonitního dílu
Stav dat | Identifikátor stavu dat
Název stavu dat | Název stavu dat

    Mřížka [Hodnoty parametrů] činnosti - Události správy artiklu

    Mřížka [Hodnoty parametrů] činnosti - Události správy artiklu
Název parametru | Název parametru
Hodnota parametru | Hodnota parametru
Platnost od | Platnost od
do | Platnost do

    Mřížka [Podíly] činnosti - Události správy artiklu

    Mřížka [Podíly] činnosti - Události správy artiklu
Název adresáta | Název adresáta
Název typu | Název typu
Čitatel | Čitatel podílu vlastnictví spoluvlastníka
Jmenovatel | Jmenovatel podílu vlastnictví spoluvlastníka

    Mřížka [Způsoby ochrany] činnosti - Události správy artiklu

    Mřížka [Způsoby ochrany] činnosti - Události správy artiklu
Ochrana | Způsob ochrany nemovitosti
Název typu | Název typu
Datum vzniku | Datum vzniku
Datum zániku | Datum zániku

    Mřížka [Řízení] činnosti - Události správy artiklu

    Mřížka [Řízení] činnosti - Události správy artiklu
Řízení | Číslo řízení
Předmět řízení | Předmět řízení
Zaplombování | Datum zaplombování nebo zápisu objektů do řízení.
Odplombování | Datum odstranění plomby

    Mřížka [JPV +] činnosti - Události správy artiklu

    Mřížka [JPV +] činnosti - Události správy artiklu
Název typu | Název typu
JPV | Identifikace jiného právního vztahu
List vl. | ID listu vlastnictví
Datum vzniku | Datum vzniku
Datum zániku | Datum zániku

    Mřížka [JPV -] činnosti - Události správy artiklu

    Mřížka [JPV -] činnosti - Události správy artiklu
Název typu | Název typu
List vl. | ID listu vlastnictví
JPV | Identifikace jiného právního vztahu
Datum vzniku | Datum vzniku
Datum zániku | Datum zániku

    Mřížka [Stavy nemovitosti] činnosti - Události správy artiklu

    Mřížka [Stavy nemovitosti] činnosti - Události správy artiklu
Stav | Identifikace stavu nemovitosti
Název stavu | Název stavu nemovitosti
Platnost od | Platnost od
do | Platnost do

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | BMTopol |
F6 | Události správy artiklu |
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
^P | Prezentace artiklu | Obrázek, multimediální klip, ....
- | INFORMACE O NEMOVITOSTI | Informace o nemovitosti
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Katastry nemovitostí | Katastry nemovitostí
F2 | Listy vlastnictví | Listy vlastnictví nemovitostí
F2 | Nemovitosti | Nemovitosti
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Složené typy pro pozemky | Složené typy pro pozemky
F2 | Stavy dat | Stavy dat
F2 | Stavy nemovitostí | Stavy nemovitostí
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Umístění nemovitostí | Umístění nemovitostí
F2 | Řízení - pozemky | Řízení - pozemky

    Atributy tisku

    Základní údaje
Druh artiklu | Identifikace druhu artiklu | PYNEMOV_sp61id | C(3)
Nemovitost | Identifikace artiklu | PYNEMOV_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Externí id. | Externí identifikace nemovitosti | PYNEMOV_py01extid | C(40)
Charakter | Charakter nemovitosti - Parcela/Díl parcely/Budova/Část budovy/Jednotka | Výpočet | C(11)
Katastr | Číslo katastru | PYNEMOV_py10id | C(6)
Název katastru | Název katastru nemovitostí | PYKATAST_py10nazkat | C(60)
List vl. | ID listu vlastnictví | PYNEMOV_py18id | C(30)
Kmenové číslo | Kmenové číslo parcely | PYNEMOV_py01kmecis | N(5)
Číslo dílu | Číslo dílu parcely | PYNEMOV_py01cisdil | N(1)
Výměra | Výměra parcely | PYNEMOV_py01vymera | N(6)
Typ | Typ nemovitosti | PYNEMOV_py12typnem | C(10)
Název typu | Název typu | PYTYPCIS4_py12nazev | C(60)
Způsob využití | Způsob využití nemovitosti | PYNEMOV_py12zpuvyu | C(10)
Název typu | Název typu | PYTYPCIS1_py12nazev | C(60)
Umístění | Identifikace umístění nemovitosti | PYNEMOV_py04id | C(6)
Název umístění | Název umístění nemovitosti | PYUMIST_py04nazumi | C(40)
Dat.vzniku | Datum vzniku | PYNEMOV_py01datvzn | D
Řízení vzniku | Řízení vzniku | PYNEMOV_py21rizvzn | C(30)
Dat.zániku | Datum zániku | PYNEMOV_py01datzan | D
Řízení zániku | Řízení zániku | PYNEMOV_py21rizzan | C(30)
Název stavu | Název stavu nemovitosti | PYSTAV_py06nazsta | C(40)
Název typu | Název typu | PYTYPCIS5_py12nazev | C(60)
Název stavu dat | Název stavu dat | PYSTADAT4_py32popsta | C(40)
Název typu | Název typu | PYTYPCIS6_py12nazev | C(60)
Název stavu dat | Název stavu dat | PYSTADAT3_py32popsta | C(40)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Název typu | Název typu | PYTYPCIS7_py12nazev | C(60)
Název stavu dat | Název stavu dat | PYSTADAT2_py32popsta | C(40)
Název typu | Název typu | PYTYPCIS8_py12nazev | C(60)
Název stavu dat | Název stavu dat | PYSTADAT1_py32popsta | C(40)
Název parametru | Název parametru | PAPARAMPR_pa02nazpar | C(40)
Název adresáta | Název adresáta | ADADSATPR_ad01adsat | C(100)
IČO | Identifikační číslo organizace. | ADADSATPR_ad01ico | C(10)
DIČ | Daňové identifikační číslo adresáta. | ADADSATPR_ad01dico | C(16)
Rodné číslo | Rodné číslo adresáta | ADADSATPR_ad01rc | C(10)
Jméno | Jméno kontaktní osoby. | ADSPOJPR_ad11jmeno | C(40)
Jméno na štítek | Jméno pracovníka na poštovní štítek | ADSPOJPR_ad11jmenop | C(100)
Telefon | Telefonní číslo | ADSPOJPR_ad11cislo | C(60)
Fax | Faxové číslo | ADSPOJPR_ad11fax | C(60)
Jiné | Jiné spojení adresáta | ADSPOJPR_ad11cisost | C(60)
Mobil | Číslo mobilního telefonu | ADSPOJPR_ad11mobil | C(60)
e-mail | E-mail spojení adresáta | ADSPOJPR_ad11email | C(60)
Kód banky | Kód banky | ADBUCTYPR_oc02idbank | C(4)
Pobočka | Název pobočky, která vede bankovní účet adresátovi. | ADBUCTYPR_ad03poboc | C(25)
Prefix ú. | Prefix bankovního účtu adresáta | ADBUCTYPR_ad03pructu | C(6)
Č. účtu | Číslo bankovního účtu adresáta. | ADBUCTYPR_ad03ucet | C(34)
Specifický symbol | Specifický symbol adresáta | ADBUCTYPR_ad03ssymb | C(10)
Měna | Kód měny - oceňovací jednotky. | ADBUCTYPR_oc01id | C(3)
Název ú. | Název účtu | ADBUCTYPR_ad03nauctu | C(20)
Název položky číselníku | Název položky číselníku | PACISPOLPR_pa08nazpol | C(40)
Název artiklu | Název artiklu | SPARTIKNPR_sp62artikl | C(60)
Název stavu dat | Název stavu dat | PYSTADAT5_py32popsta | C(40)

    Při pohybu v Hodnoty parametrů
Parametr | Identifikátor parametru | PAHODNOT_pa02id | C(6)
Hodnota parametru | Hodnota parametru | Výpočet | C(100)
Poznámka | Poznámka | PAHODNOT_pa06koment | M
Platnost od | Platnost od | PAHODNOT_pa06datum | D
do | Platnost do | PAHODNOT_pa06datumd | D
Adresát | Identifikace adresáta | PAHODNOT_ad01id | C(6)
Spojení | Číslo spojení adresáta. | PAHODNOT_ad11cisspo | C(2)
Účet | Identifikátor spojení na bankovní účet adresáta. | PAHODNOT_ad03cisban | C(2)
Text1 | Textová elementární hodnota | PAHODNOT_pa06text1 | C(60)
Identifikace položky číselníku | Identifikace položky číselníku | PAHODNOT_pa08id | C(10)
Druh artiklu | Identifikace druhu artiklu | PAHODNOT_sp61id | C(3)
Artikl | Identifikace artiklu | PAHODNOT_sp60id | C(13)
Num1 | Numerická elementární hodnota 1 | PAHODNOT_pa06num1 | N(20,4)
Num2 | Numerická elementární hodnota 2 | PAHODNOT_pa06num2 | N(20,4)
Dat1 | Datumová elementární hodnota 1 | PAHODNOT_pa06dat1 | D
Dat2 | Datumová elementární hodnota 2 | PAHODNOT_pa06dat2 | D
Cmb1 | Překryvný seznam elementární hodnota 1 | PAHODNOT_pa06cmb1 | N(1)
Cmb2 | Překryvný seznam elementární hodnota 2 | PAHODNOT_pa06cmb2 | N(1)
Oblast | Oblast sady parametrů | PAHODNOT_pa01oblast | C(2)

    Při pohybu v Bonitní díly
BPEJ | Kód bonitního dílu parcely BPEJ | PYBDP_py31bpej | C(5)
Výměra | Výměra bonitního dílu | PYBDP_py31vymera | N(6)
Stav dat | Identifikátor stavu dat | PYBDP_py32id | C(6)
Řízení vzniku | Řízení vzniku | PYBDP_py21rizvzn | C(30)
Řízení zániku | Řízení zániku | PYBDP_py21rizzan | C(30)
Datum vzniku | Datum vzniku | PYBDP_py31datvzn | D
Datum zániku | Datum zániku | PYBDP_py31datzan | D

    Při pohybu v JPV k tíži
JPV | Identifikace jiného právního vztahu | PYJPV1_py23id | C(30)
Právní vztah | Typ právního vztahu | PYJPV1_py12typpra | C(10)
Stav dat | Identifikátor stavu dat | PYJPV1_py32id | C(6)
N. ku prosp. | Identifikace artiklu | PYJPV1_sp60id2 | C(13)
Druh | Identifikace druhu artiklu | PYJPV1_sp61id2 | C(3)
Datum vzniku | Datum vzniku | PYJPV1_py23datvzn | D
Datum zániku | Datum zániku | PYJPV1_py23datzan | D

    Při pohybu v JPV ku prospěchu
JPV | Identifikace jiného právního vztahu | PYJPV2_py23id | C(30)
Právní vztah | Typ právního vztahu | PYJPV2_py12typpra | C(10)
Stav dat | Identifikátor stavu dat | PYJPV2_py32id | C(6)
N. k tíži | Identifikace artiklu | PYJPV2_sp60id1 | C(13)
Druh | Druh artiklu | PYJPV2_sp61id1 | C(3)
Datum vzniku | Datum vzniku | PYJPV2_py23datvzn | D
Datum zániku | Datum zániku | PYJPV2_py23datzan | D

    Při pohybu v Podíly
Vlastnictví | Číslo vlastnictví | PYNEMLVP_py19id | C(30)
Právní vztah | Typ právního vztahu | PYNEMLVP_py12typpra | C(10)
Stav dat | Identifikátor stavu dat | PYNEMLVP_py32id | C(6)
Subjekt | Identifikace adresáta | PYNEMLVP_ad01id | C(6)
Čitatel | Čitatel podílu vlastnictví spoluvlastníka | PYNEMLVP_py19podcit | N(30)
Jmenovatel | Jmenovatel podílu vlastnictví spoluvlastníka | PYNEMLVP_py19podjme | N(30)
Datum vzniku | Datum vzniku | PYNEMLVP_py19datvzn | D
Datum zániku | Datum zániku | PYNEMLVP_py19datzan | D

    Při pohybu v Stavy nemovitosti
Stav | Identifikace stavu nemovitosti | PYNEMSTA_py06id | C(6)
Platnost od | Platnost od | PYNEMSTA_py07platod | D
do | Platnost do | PYNEMSTA_py07platdo | D

    Při pohybu v Způsoby ochrany
Ochrana | Způsob ochrany nemovitosti | PYNEMZPO_py12zpuoch | C(10)
Stav dat | Identifikátor stavu dat | PYNEMZPO_py32id | C(6)
Datum vzniku | Datum vzniku | PYNEMZPO_py27datvzn | D
Datum zániku | Datum zániku | PYNEMZPO_py27datzan | D

    Při pohybu v Řízení
Řízení | Číslo řízení | PYRIZOBJ_py21id | C(30)
Zaplombování | Datum zaplombování nebo zápisu objektů do řízení. | PYRIZOBJ_py20datplo | D
Odplombování | Datum odstranění plomby | PYRIZOBJ_py20datodp | D


BMTopol

Popis

Tato činnost umožňuje propojení informací uložených v komponentě pozemky IS BM s aplikací Topol, která umožňuje uživateli zobrazit si vybrané údaje graficky. V případě, že je to technologicky možné, je v činnostech komponenty pozemky možno aktivovat BM Topol po stisku klávesy F5 nebo pod menu Volby spuštěním činnosti „BM Topol“.

Podle aktivované činnosti v IS BM se mohou graficky zobrazené informace lišit, ale obecně platí, že BM Topol (pomocí objektu AKTIVE X – COM) uživateli umožňuje:

¨ zobrazení digitální mapy parcely – nemovitosti

¨ zobrazení digitální mapy vybrané parcely

¨ zobrazenou parcelu nebo skupinu umožňuje uložit do clipboardu (Ctrl C)

¨ zobrazení příslušných dat z IS BM při dvojkliku na parcelu na mapě

Vyvolávané činnosti

K. | Činnost | Popis
- | INFORMACE O ARTIKLU | Přehled informací o artiklu
- | INFORMACE O ADRESÁTOVI | Vývěska adresáta a pošta adresáta...
- | Nemovitosti | Nemovitosti
- | Adresář | Přehled adresátů

Formulář

Formulář činnosti - Adresář
Topol


Oprávněné subjekty

Popis

Jednotlivé oprávněné subjekty jsou do systému vloženy pomocí importu oficiálních dat z Českého úřadu zeměměřického a katastrálního.

Každý oprávněný subjekt má vytvořen odpovídající záznam v adresáři v informačním centru. Pokud při importu systém zjistí, že oprávněný subjekt nemá svůj odpovídající záznam v adresáři, je tento automaticky vytvořen.

Datový model

  • PYOPSUB Oprávněný subjekt - OPSUB
    • ADADSAT Adresát
    • PYTYPCIS Sloučený typ - spojené číselníky (alias PYTYPCIS2)
    • PYTYPCIS Sloučený typ - spojené číselníky
    • ADADSAT Adresát (alias ADADSAT2)
    • ADADSAT Adresát (alias ADADSAT1)
    • PYSTADAT Stav dat

    • Formulář

    Formulář činnosti - Stavy dat
Mřížka [Oprávněný subjekt]
Subjekt | Identifikace oprávněného subjektu
Název subjektu | Název nebo příjmení oprávněného subjektu
Listovací rámeček
Stránka #1 Oprávněné subjekty
Adresát | Identifikace adresáta
 | Název adresáta
Jméno | Jméno
 | Titul před jménem
 | Titul za jménem
Rodné číslo | Rodné číslo
IČO | IČO
 | Doplněk IČO
Ulice | Ulice
 | Číslo domovní
 | Číslo orientační
PSČ | PSČ
Obec | Obec
 | Část obce
Stát | Stát
Typ | Typ oprávněného subjektu
Název typu | Název typu
Charakteristika | Charakteristika oprávněného subjektu
Název typu | Název typu
Stav dat | Identifikátor stavu dat
Název stavu | Název stavu dat
1 partner BSM | Identifikace adresáta
 | Název adresáta
2 partner BSM | Identifikace adresáta
 | Název adresáta
Stránka #2 Další
Datum vzniku | Datum vzniku
Datum zániku | Datum zániku
Řízení vzniku | Řízení vzniku
Řízení zániku | Řízení zániku
Pracoviště | Identifikace zdrojového pracoviště
Stránka #3 Výběr
Subjekt | Identifikace oprávněného subjektu
Název subjektu | Název nebo příjmení oprávněného subjektu
IČO | IČO
Rodné číslo | Rodné číslo
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Stav dat | Identifikátor stavu dat
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Oprávněný subjekt] činnosti - Stavy dat

    Mřížka [Oprávněný subjekt] činnosti - Stavy dat
Subjekt | Identifikace oprávněného subjektu
Název subjektu | Název nebo příjmení oprávněného subjektu

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresář | Přehled adresátů
F2 | Oprávněné subjekty | Oprávněné subjekty
F2 | Složené typy pro pozemky | Složené typy pro pozemky
F2 | Stavy dat | Stavy dat
F2 | Řízení - pozemky | Řízení - pozemky

    Atributy tisku

    Základní údaje
Subjekt | Identifikace oprávněného subjektu | PYOPSUB_py16id | C(30)
Název subjektu | Název nebo příjmení oprávněného subjektu | PYOPSUB_py16nazpri | C(254)
Typ | Typ oprávněného subjektu | PYOPSUB_py12typos | C(10)
Charakteristika | Charakteristika oprávněného subjektu | PYOPSUB_py12charos | C(10)
Stav dat | Identifikátor stavu dat | PYOPSUB_py32id | C(6)
Název stavu | Název stavu dat | PYSTADAT_py32popsta | C(40)
Adresát | Identifikace adresáta | PYOPSUB_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Datum vzniku | Datum vzniku | PYOPSUB_py16datvzn | D
Datum zániku | Datum zániku | PYOPSUB_py16datzan | D
Řízení vzniku | Řízení vzniku | PYOPSUB_py21rizvzn | C(30)
Řízení zániku | Řízení zániku | PYOPSUB_py21rizzan | C(30)
1 partner BSM | Identifikace adresáta | PYOPSUB_ad01id1 | C(6)
Název adresáta | Název adresáta | ADADSAT1_ad01adsat | C(100)
2 partner BSM | Identifikace adresáta | PYOPSUB_ad01id2 | C(6)
Název adresáta | Název adresáta | ADADSAT2_ad01adsat | C(100)
Pracoviště | Identifikace zdrojového pracoviště | PYOPSUB_py16zdroj | C(40)
IČO | IČO | PYOPSUB_py16ico | C(10)
Doplněk IČO | Doplněk IČO | PYOPSUB_py16dopico | C(3)
Rodné číslo | Rodné číslo | PYOPSUB_py16rodcis | C(10)
Titul před | Titul před jménem | PYOPSUB_py16titpre | C(40)
Titul za | Titul za jménem | PYOPSUB_py16titza | C(10)
Jméno | Jméno | PYOPSUB_py16jmeno | C(24)
Číslo domovní | Číslo domovní | PYOPSUB_py16cisdom | N(4)
Číslo orientační | Číslo orientační | PYOPSUB_py16cisor | C(4)
Ulice | Ulice | PYOPSUB_py16ulice | C(40)
Část obce | Část obce | PYOPSUB_py16castob | C(60)
Obec | Obec | PYOPSUB_py16obec | C(60)
Okres | Okres | PYOPSUB_py16okres | C(40)
Stát | Stát | PYOPSUB_py16stat | C(40)
PSČ | PSČ | PYOPSUB_py16psc | N(5)


Katastry nemovitostí

Popis

Uživateli se nabízí přehled jednotlivých katastrů nemovitostí. U každého katastru se eviduje jeho identifikace a název a identifikace správního celku (tj. obec, část obce, okres, kraj), který do daného katastru náleží. Navíc je možno u každého katastru evidovat jeho platnost do - do.

Datový model

  • PYKATAST Katastrální území
    • PYSPRCEL Správní celek

    • Formulář

    Formulář činnosti - Správní celky
Mřížka [Katastry]
Katastr | Číslo katastru
Název katastru | Název katastru nemovitostí
Obec | Obec,Část obce, Okres,Kraj
Název | Název správního celku
Platnost od | Platnost katastru od
do | Platnost katastru do

    Mřížka [Katastry] činnosti - Správní celky

    Mřížka [Katastry] činnosti - Správní celky
Katastr | Číslo katastru
Název katastru | Název katastru nemovitostí
Obec | Obec,Část obce, Okres,Kraj
Název | Název správního celku

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Správní celky | Správní celky

    Atributy tisku

    Základní údaje
Katastr | Číslo katastru | PYKATAST_py10id | C(6)
Správní celek | Obec,Část obce, Okres,Kraj | PYKATAST_py11id | C(8)
Název | Název správního celku | PYSPRCEL_py11nazspc | C(60)
Název katastru | Název katastru nemovitostí | PYKATAST_py10nazkat | C(60)
Platnost od | Platnost katastru od | PYKATAST_py10platod | D
do | Platnost katastru do | PYKATAST_py10platdo | D


Jiné právní vztahy

Popis

Uživateli se zobrazuje přehled jiných právních vztahů vedených u jednotlivých listů vlastnictví tak, jak jsou vedeny Českým úřadem zeměměřickým a katastrálním. Tyto údaje má uživatel k dispozici pomocí provedeného importu těchto oficiálních dat.

U každého jiného právního vztahu se evidují základní údaje na záložce "jiné právní vztahy", ostatní potřebné informace má uživatel k dispozici na záložkách "další" a "listiny".

Datový model

  • PYJPV Jiný právní vztah
    • PYSTADAT Stav dat
    • PYNEMLV List vlastnictví nemovitosti (těleso)
      • PYKATAST Katastrální území
    • ADADSAT Adresát (alias ADADSAT1)
    • ADADSAT Adresát (alias ADADSAT2)
    • PYNEMOV Nemovitost (alias PYNEMOV1)
      • SPARTIKN Název artiklu
    • PYNEMOV Nemovitost (alias PYNEMOV2)
      • SPARTIKN Název artiklu (alias SPARTIKN2)
    • PYTYPCIS Sloučený typ - spojené číselníky

    • Formulář

    Formulář činnosti - BMTopol
Mřížka [Jiné právní vztahy]
JPV | Identifikace jiného právního vztahu
List vl. | ID listu vlastnictví
Katastr | Číslo katastru
Název katastru | Název katastru nemovitostí
Číslo listu | Číslo listu vlastnictví
Listovací rámeček
Stránka #1 Jiné právní vztahy
Právní vztah | Typ právního vztahu
Název typu | Název typu
Stav dat | Identifikátor stavu dat
Název stavu dat | Název stavu dat
Popis | Poznámka - popis
S. k tíži | Identifikace importovaného adresáta
 | Název adresáta
S. ku prosp. | Adresát subjektu spojení adresáta
 | Název adresáta
Druh | Druh artiklu
N. k tíži | Identifikace artiklu
Název artiklu | Název artiklu
Druh | Identifikace druhu artiklu
N. ku prosp. | Identifikace artiklu
Název artiklu | Název artiklu
Stránka #2 Další
Datum vzniku | Datum vzniku
Datum zániku | Datum zániku
Řízení vzniku | Řízení vzniku
Řízení zániku | Řízení zániku
Stav dat | Identifikátor stavu dat
Stránka #3 Listiny
Mřížka [Listiny]
Listina | Identifikace listiny
Stav dat | Identifikátor stavu dat
Název stavu dat | Název stavu dat
Řízení | Číslo řízení
Typ | Typ listiny
Název typu | Název typu
Popis | Popis obsahu listiny
Vyhotovení | Datum vyhotovení listiny
Platnost | Datum platnosti nebo nabytí právní moci
Právní moc | Datum nabytí právní moci
Vykonavatelnost | Datum vykonavatelnosti
Stránka #4 Výběr
JPV | Identifikace jiného právního vztahu
List vl. | ID listu vlastnictví
Právní vztah | Typ právního vztahu
Řízení | Číslo řízení
Subjekt | Identifikace adresáta
 | Název adresáta
Druh | Identifikace druhu artiklu
Nemovitost | Identifikace artiklu
Stav dat | Identifikátor stavu dat
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Jiné právní vztahy] činnosti - BMTopol

    Mřížka [Jiné právní vztahy] činnosti - BMTopol
JPV | Identifikace jiného právního vztahu
List vl. | ID listu vlastnictví
Číslo listu | Číslo listu vlastnictví
S. k tíži | Identifikace importovaného adresáta
Název adresáta | Název adresáta
S. ku prosp. | Adresát subjektu spojení adresáta
Název adresáta | Název adresáta
Druh | Druh artiklu
N. k tíži | Identifikace artiklu
Název artiklu | Název artiklu
Druh | Identifikace druhu artiklu
N. ku prosp. | Identifikace artiklu
Název artiklu | Název artiklu
Právní vztah | Typ právního vztahu
Název typu | Název typu
Datum vzniku | Datum vzniku
Datum zániku | Datum zániku

    Mřížka [Listiny] činnosti - BMTopol

    Mřížka [Listiny] činnosti - BMTopol
Listina | Identifikace listiny
Vyhotovení | Datum vyhotovení listiny
Platnost | Datum platnosti nebo nabytí právní moci
Právní moc | Datum nabytí právní moci
Vykonavatelnost | Datum vykonavatelnosti

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | BMTopol |
- | INFORMACE O JPV | Informace o jiném právním vztahu
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Listy vlastnictví | Listy vlastnictví nemovitostí
F2 | Nemovitosti | Nemovitosti
F2 | Složené typy pro pozemky | Složené typy pro pozemky
F2 | Stavy dat | Stavy dat
F2 | Řízení - pozemky | Řízení - pozemky

    Atributy tisku

    Základní údaje
JPV | Identifikace jiného právního vztahu | PYJPV_py23id | C(30)
List vl. | ID listu vlastnictví | PYJPV_py18id | C(30)
Datum vzniku | Datum vzniku | PYJPV_py23datvzn | D
Datum zániku | Datum zániku | PYJPV_py23datzan | D
Řízení vzniku | Řízení vzniku | PYJPV_py21rizvzn | C(30)
Řízení zániku | Řízení zániku | PYJPV_py21rizzan | C(30)
Popis | Poznámka - popis | PYJPV_py23poznam | M
Právní vztah | Typ právního vztahu | PYJPV_py12typpra | C(10)
Název typu | Název typu | PYTYPCIS_py12nazev | C(60)
Stav dat | Identifikátor stavu dat | PYJPV_py32id | C(6)
Název stavu dat | Název stavu dat | PYSTADAT_py32popsta | C(40)
S. k tíži | Oprávněnému subjektu k tíži | PYJPV_py16id1 | C(30)
S. ku prosp. | Oprávněnému subjektu ku prospěchu | PYJPV_py16id2 | C(30)
N. ku prosp. | Identifikace artiklu | PYJPV_sp60id2 | C(13)
Druh | Identifikace druhu artiklu | PYJPV_sp61id2 | C(3)
N. k tíži | Identifikace artiklu | PYJPV_sp60id1 | C(13)
Druh | Druh artiklu | PYJPV_sp61id1 | C(3)
S. k tíži | Identifikace importovaného adresáta | PYJPV_ad01id1 | C(6)
Název adresáta | Název adresáta | ADADSAT1_ad01adsat | C(100)
S. ku prosp. | Identifikace adresáta | PYJPV_ad01id2 | C(6)
Název adresáta | Název adresáta | ADADSAT2_ad01adsat | C(100)
Název stavu dat | Název stavu dat | PYSTADAT1_py32popsta | C(40)
Typ | Typ listiny | PYLISTIN_py12typlis | C(10)
Popis | Popis obsahu listiny | PYLISTIN_py17popis | M
Obsah existuje | Identifikátor existence obsahu listiny | PYLISTIN_py17obsah | C(1)
Stran | Počet stran | PYLISTIN_py17stran | N(4)
Platnost | Datum platnosti nebo nabytí právní moci | PYLISTIN_py17datpla | D
Zhotovitel | Jméno zhotovitele listiny | PYLISTIN_py17zhotov | C(60)
Vyhotovení | Datum vyhotovení listiny | PYLISTIN_py17datzho | D
Číslo | Pořadové číslo zhotovitele listiny | PYLISTIN_py17pczhot | C(7)
JČ zhotovitele | Doplnění jednacího čísla listiny zhotovitele | PYLISTIN_py17dopzho | C(60)
Zkratka | Zkratka zhotovitlele | PYLISTIN_py17zhozkr | C(10)
Z. právního vztahu | Indikace změny právního vztahu | PYLISTIN_py17zmepvz | C(1)
Právní moc | Datum nabytí právní moci | PYLISTIN_py17pravmo | D
Vykonavatelnost | Datum vykonavatelnosti | PYLISTIN_py17datvyk | D

    Při pohybu v Listiny
Listina | Identifikace listiny | PYLISNEM_py17id | C(30)
Stav dat | Identifikátor stavu dat | PYLISNEM_py32id | C(6)


Listiny - pozemky

Popis

Tato činnost poskytuje uživateli přehled jednotlivých listin - pozemků vedených příslušným Českým úřadem zeměměřickým a katastrálním. Jednotlivé listiny se dostávají do systému pomocí importu, který do komponenty pozemky natahuje oficiální data vedená Českým úřadem zeměměřickým a katastrálním.

Uživatel má k dispozici veškeré údaje, které je nutno vést v souvislosti s listinami - pozemky. Základní údaje má uživatel dostupné na záložce "listiny", ostatní informace mu poskytují další záložky.

Datový model

  • PYLISTIN Listina
    • PYTYPCIS Sloučený typ - spojené číselníky

    • Formulář

    Formulář činnosti - Stavy dat
Mřížka [Listiny]
Listina | Identifikace listiny
Listovací rámeček
Stránka #1 Listiny
Popis | Popis obsahu listiny
Řízení | Číslo řízení
Typ | Typ listiny
Název typu | Název typu
Obsah existuje | Identifikátor existence obsahu listiny
Stran | Počet stran
Zhotovitel | Jméno zhotovitele listiny
Číslo | Pořadové číslo zhotovitele listiny
JČ zhotovitele | Doplnění jednacího čísla listiny zhotovitele
Zkratka | Zkratka zhotovitlele
Z. právního vztahu | Indikace změny právního vztahu
Vyhotovení | Datum vyhotovení listiny
Platnost | Datum platnosti nebo nabytí právní moci
Právní moc | Datum nabytí právní moci
Vykonavatelnost | Datum vykonavatelnosti
Stránka #2 Další údaje
Mřížka [Další údaje]
Kód | Kód dalšího údaje
Název typu | Název typu
Stránka #3 Nemovitosti
Mřížka [Nemovitosti]
ID | Identifikace přiřazení listiny k nemovitostem
Druh | Identifikace druhu artiklu
Nemovitost | Identifikace artiklu
Název artiklu | Název artiklu
Externí id. | Externí identifikace nemovitosti
Subjekt | Identifikace adresáta
 | Název adresáta
JPV | Identifikace jiného právního vztahu
Stav dat | Identifikátor stavu dat
Název stavu dat | Název stavu dat
Datum vzniku | Datum vzniku
Datum zániku | Datum zániku
Řízení vzniku | Řízení vzniku
Řízení zániku | Řízení zániku
Stránka #4 Výběr
Listina | Identifikace listiny
Řízení | Číslo řízení
Typ | Typ listiny
Popis | Popis obsahu listiny
Druh artiklu | Identifikace druhu artiklu
Nemovitost | Identifikace artiklu
Subjekt | Identifikace adresáta
 | Název adresáta
JPV | Identifikace jiného právního vztahu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Listiny] činnosti - Stavy dat

    Mřížka [Listiny] činnosti - Stavy dat
Listina | Identifikace listiny
Řízení | Číslo řízení
Vyhotovení | Datum vyhotovení listiny
Platnost | Datum platnosti nebo nabytí právní moci
Vykonavatelnost | Datum vykonavatelnosti
Právní moc | Datum nabytí právní moci

    Mřížka [Další údaje] činnosti - Stavy dat

    Mřížka [Další údaje] činnosti - Stavy dat
Kód | Kód dalšího údaje
Název typu | Název typu

    Mřížka [Nemovitosti] činnosti - Stavy dat

    Mřížka [Nemovitosti] činnosti - Stavy dat
Druh | Identifikace druhu artiklu
Nemovitost | Identifikace artiklu
Název artiklu | Název artiklu
Subjekt | Identifikace oprávněného subjektu

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Jiné právní vztahy | Jiné právní vztahy
F2 | Nemovitosti | Nemovitosti
F2 | Složené typy pro pozemky | Složené typy pro pozemky
F2 | Stavy dat | Stavy dat
F2 | Řízení - pozemky | Řízení - pozemky

    Atributy tisku

    Základní údaje
Řízení | Číslo řízení | PYLISTIN_py21id | C(30)
Typ | Typ listiny | PYLISTIN_py12typlis | C(10)
Název typu | Název typu | PYTYPCIS_py12nazev | C(60)
Popis | Popis obsahu listiny | PYLISTIN_py17popis | M
Obsah existuje | Identifikátor existence obsahu listiny | PYLISTIN_py17obsah | C(1)
Stran | Počet stran | PYLISTIN_py17stran | N(4)
Platnost | Datum platnosti nebo nabytí právní moci | PYLISTIN_py17datpla | D
Zhotovitel | Jméno zhotovitele listiny | PYLISTIN_py17zhotov | C(60)
Vyhotovení | Datum vyhotovení listiny | PYLISTIN_py17datzho | D
Číslo | Pořadové číslo zhotovitele listiny | PYLISTIN_py17pczhot | C(7)
JČ zhotovitele | Doplnění jednacího čísla listiny zhotovitele | PYLISTIN_py17dopzho | C(60)
Zkratka | Zkratka zhotovitlele | PYLISTIN_py17zhozkr | C(10)
Z. právního vztahu | Indikace změny právního vztahu | PYLISTIN_py17zmepvz | C(1)
Právní moc | Datum nabytí právní moci | PYLISTIN_py17pravmo | D
Vykonavatelnost | Datum vykonavatelnosti | PYLISTIN_py17datvyk | D
Název typu | Název typu | PYTYPCIS2_py12nazev | C(60)
Název stavu dat | Název stavu dat | PYSTADAT_py32popsta | C(40)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)

    Při pohybu v Další údaje
    Kód Kód dalšího údaje PYLISDU_py12koddal C(10)

    Při pohybu v Nemovitosti
ID | Identifikace přiřazení listiny k nemovitostem | PYLISNEM_py22id | C(30)
JPV | Identifikace jiného právního vztahu | PYLISNEM_py23id | C(30)
Datum vzniku | Datum vzniku | PYLISNEM_py22datvzn | D
Datum zániku | Datum zániku | PYLISNEM_py22datzan | D
Řízení vzniku | Řízení vzniku | PYLISNEM_py21rizvzn | C(30)
Řízení zániku | Řízení zániku | PYLISNEM_py21rizzan | C(30)
Stav dat | Identifikátor stavu dat | PYLISNEM_py32id | C(6)
Nemovitost | Identifikace artiklu | PYLISNEM_sp60id | C(13)
Druh artiklu | Identifikace druhu artiklu | PYLISNEM_sp61id | C(3)
Subjekt | Identifikace adresáta | PYLISNEM_ad01id | C(6)


Listy vlastnictví

Popis

Tato činnost poskytuje uživateli přehled jednotlivých listů vlastnictví vedených příslušným Českým úřadem zeměměřickým a katastrálním. Jednotlivé listy vlastnictví se dostávají do systému pomocí importu, který do komponenty pozemky natahuje oficiální data vedená Českým úřadem zeměměřickým a katastrálním.

U každého listu se eviduje jeho identifikační číslo, datum vzniku, případně zániku, identifikace řízení, jehož je list součástí apod. Jednotlivé záložky pak poskytují uživateli informace, které nemovitosti se list vlastnictví týká, jaké podíly subjektů jsou k němu vázány, jestli jsou s listem vlastnictví svázány jiné právní vztahy.

Pod menu Volby má uživatel k dispozici činnost "informace o listu vlastnictví", kde má možnost si prohlédnout veškeré informace vztahující se k aktuálnímu listu vlastnictví.

Datový model

  • PYNEMLV List vlastnictví nemovitosti (těleso)
    • PYSTADAT Stav dat
    • PYKATAST Katastrální území

    • Formulář

    Formulář činnosti - Stavy dat
Mřížka [Listy vlastnictví]
List vl. | ID listu vlastnictví
Katastr | Číslo katastru
Číslo listu | Číslo listu vlastnictví
Název katastru | Název katastru nemovitostí
Listovací rámeček
Stránka #1 Listy vlastnictví
Datum vzniku | Datum vzniku
Datum zániku | Datum zániku
Řízení vzniku | Řízení vzniku
Řízení zániku | Řízení zániku
Stav dat | Identifikátor stavu dat
Název stavu dat | Název stavu dat
Externí | Externí ID listu vlastnictví
Stránka #2 Nemovitosti
Mřížka [Nemovitosti]
Druh | Identifikace druhu artiklu
Nemovitost | Identifikace artiklu
Název artiklu | Název artiklu
Externí id. | Externí identifikace nemovitosti
Stránka #3 Podíly
Mřížka [Podíly]
Vlastnictví | Číslo vlastnictví
Subjekt | Identifikace adresáta
 | Název adresáta
Právní vztah | Typ právního vztahu
Název typu | Název typu
Stav dat | Identifikátor stavu dat
Název stavu dat | Název stavu dat
Datum vzniku | Datum vzniku
Datum zániku | Datum zániku
Řízení vzniku | Řízení vzniku
Řízení zániku | Řízení zániku
Čitatel | Čitatel podílu vlastnictví spoluvlastníka
Jmenovatel | Jmenovatel podílu vlastnictví spoluvlastníka
Stránka #4 Jiné právní vztahy
Mřížka [Jiné právní vztahy]
JPV | Identifikace jiného právního vztahu
Právní vztah | Typ právního vztahu
Název typu | Název typu
Popis | Poznámka - popis
S. k tíži | Identifikace importovaného adresáta
 | Název adresáta
S. ku prosp. | Adresát subjektu spojení adresáta
 | Název adresáta
Druh | Druh artiklu
N. k tíži | Identifikace artiklu
Název artiklu | Název artiklu
Druh | Identifikace druhu artiklu
N. ku prosp. | Identifikace artiklu
Název artiklu | Název artiklu
Stránka #5 JPV - další
Datum vzniku | Datum vzniku
Datum zániku | Datum zániku
Řízení vzniku | Řízení vzniku
Řízení zániku | Řízení zániku
Stav dat | Identifikátor stavu dat
Název stavu dat | Název stavu dat
Stránka #6 Výběr
List vl. | ID listu vlastnictví
Druh | Identifikace druhu artiklu
Nemovitost | Identifikace artiklu
Řízení | Číslo řízení
JPV | Identifikace jiného právního vztahu
Subjekt | Identifikace adresáta
 | Název adresáta
Právní vztah | Typ právního vztahu
Stav dat | Identifikátor stavu dat
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Listy vlastnictví] činnosti - Stavy dat

    Mřížka [Listy vlastnictví] činnosti - Stavy dat
List vl. | ID listu vlastnictví
Katastr | Číslo katastru
Číslo listu | Číslo listu vlastnictví
Název katastru | Název katastru nemovitostí

    Mřížka [Nemovitosti] činnosti - Stavy dat

    Mřížka [Nemovitosti] činnosti - Stavy dat
Druh | Identifikace druhu artiklu
Nemovitost | Identifikace artiklu
Název artiklu | Název artiklu
Externí id. | Externí identifikace nemovitosti

    Mřížka [Podíly] činnosti - Stavy dat

    Mřížka [Podíly] činnosti - Stavy dat
Název adresáta | Název adresáta
Název typu | Název typu
Čitatel | Čitatel podílu vlastnictví spoluvlastníka
Jmenovatel | Jmenovatel podílu vlastnictví spoluvlastníka

    Mřížka [Jiné právní vztahy] činnosti - Stavy dat

    Mřížka [Jiné právní vztahy] činnosti - Stavy dat
    JPV Identifikace jiného právního vztahu

    Vyvolávané činnosti

    K. | Činnost | Popis
- | INFORMACE O LISTU VLASTNICTVÍ | Informace o listu vlastnictví
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Jiné právní vztahy | Jiné právní vztahy
F2 | Katastry nemovitostí | Katastry nemovitostí
F2 | Nemovitosti | Nemovitosti
F2 | Složené typy pro pozemky | Složené typy pro pozemky
F2 | Stavy dat | Stavy dat
F2 | Řízení - pozemky | Řízení - pozemky

    Atributy tisku

    Základní údaje
List vl. | ID listu vlastnictví | PYNEMLV_py18id | C(30)
Číslo listu | Číslo listu vlastnictví | PYNEMLV_py18cistel | N(6)
Katastr | Číslo katastru | PYNEMLV_py10id | C(6)
Název katastru | Název katastru nemovitostí | PYKATAST_py10nazkat | C(60)
Datum vzniku | Datum vzniku | PYNEMLV_py18datvzn | D
Datum zániku | Datum zániku | PYNEMLV_py18datzan | D
Řízení vzniku | Řízení vzniku | PYNEMLV_py21rizvzn | C(30)
Řízení zániku | Řízení zániku | PYNEMLV_py21rizzan | C(30)
Stav dat | Identifikátor stavu dat | PYNEMLV_py32id | C(6)
Název stavu dat | Název stavu dat | PYSTADAT_py32popsta | C(40)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Název typu | Název typu | PYTYPCIS6_py12nazev | C(60)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Název typu | Název typu | PYTYPCIS_py12nazev | C(60)
Název artiklu | Název artiklu | SPARTIKN4_sp62artikl | C(60)
Název artiklu | Název artiklu | SPARTIKN2_sp62artikl | C(60)
Název adresáta | Název adresáta | ADADSAT1_ad01adsat | C(100)
Název adresáta | Název adresáta | ADADSAT2_ad01adsat | C(100)

    Při pohybu v Jiné právní vztahy
JPV | Identifikace jiného právního vztahu | PYJPV_py23id | C(30)
Právní vztah | Typ právního vztahu | PYJPV_py12typpra | C(10)
Popis | Poznámka - popis | PYJPV_py23poznam | M
N. k tíži | Identifikace artiklu | PYJPV_sp60id1 | C(13)
Druh | Druh artiklu | PYJPV_sp61id1 | C(3)
N. ku prosp. | Identifikace artiklu | PYJPV_sp60id2 | C(13)
Druh | Identifikace druhu artiklu | PYJPV_sp61id2 | C(3)
S. k tíži | Identifikace adresáta | PYJPV_ad01id1 | C(6)
S. ku prosp. | Identifikace adresáta | PYJPV_ad01id2 | C(6)

    Při pohybu v Podíly
List vl. | ID listu vlastnictví | PYNEMLVP_py18id | C(30)
Právní vztah | Typ právního vztahu | PYNEMLVP_py12typpra | C(10)
Subjekt | Identifikace adresáta | PYNEMLVP_ad01id | C(6)
Čitatel | Čitatel podílu vlastnictví spoluvlastníka | PYNEMLVP_py19podcit | N(30)
Jmenovatel | Jmenovatel podílu vlastnictví spoluvlastníka | PYNEMLVP_py19podjme | N(30)
Datum vzniku | Datum vzniku | PYNEMLVP_py19datvzn | D
Řízení vzniku | Řízení vzniku | PYNEMLVP_py21rizvzn | C(30)
Datum zániku | Datum zániku | PYNEMLVP_py19datzan | D
Řízení zániku | Řízení zániku | PYNEMLVP_py21rizzan | C(30)

    Při pohybu v Nemovitosti
Nemovitost | Identifikace artiklu | PYNEMOV_sp60id | C(13)
Druh artiklu | Identifikace druhu artiklu | PYNEMOV_sp61id | C(3)


Řízení - pozemky

Popis

Tato činnost poskytuje uživateli přehled jednotlivých řízení vedených příslušným Českým úřadem zeměměřickým a katastrálním. Jednotlivá řízení se dostávají do systému pomocí importu, který do komponenty pozemky natahuje oficiální data vedená Českým úřadem zeměměřickým a katastrálním. Jako řízení se bere např. změna majitele nemovitosti, její prodej, zablokování, věcné břemeno apod. Na základě provedeného importu se naplní jednak číselník řízení a jednak všechny s ním související informace, které má uživatel dostupné na dalších záložkách této činnosti:

¨ nemovitosti - přehled nemovitostí, kterých se dané řízení týká

¨ předměty řízení - např. změna vlastnictví, věcné břemeno apod.

¨ účastníci řízení - to znamená, kterých účastníků se dané řízení týká

¨ listiny - přehled listin (např. určité zákonné rozhodnutí), které jsou svázány s daným řízením

V menu Volby má uživatel k dispozici činnost "Informace o řízení". Ta mu poskytuje informace související vždy s aktuálním řízením.

Datový model

  • PYRIZENI Řízení
    • PYTYPCIS Sloučený typ - spojené číselníky

    • Formulář

    Formulář činnosti - INFORMACE O ŘÍZENÍ
Mřížka [Řízení]
Listovací rámeček
Stránka #1 Řízení
Řízení | Číslo řízení
Typ | Kód typu řízení
Pořadí | Pořadí řízení daného charakteru
Název typu | Název typu
Stav | Aktuální stav řízení
Zahájeno | Datum zahájení řízení
Datum uzavření | Datum uzavření řízení
Poslední funkce | Kód poslední realizované funkce
Poslední operace | Kód poslední realizované operace
Významná funkce | Kód poslední významné realizované funkce
Významná operace | Kód poslední významné realizované operace
Odpovědná osoba | Jméno uživatele, který má přiřazeno řízení
Role | Jméno role, která má přiřazeno řízení
Osvobozeno | Osvobozeno od platby Ano/Ne
Kolek | Hodnota kolkové známky
Další datum | Datum (další význam podle typu řízení)
Další datum | Datum (další význam podle typu řízení)
Popis | Popis (další význam podle typu řízení)
Stránka #2 Nemovitosti
Řízení | Číslo řízení
Typ | Kód typu řízení
Pořadí | Pořadí řízení daného charakteru
Název typu | Název typu
Mřížka [Nemovitosti]
ID | Identifikace objektu řízení
Druh | Identifikace druhu artiklu
Nemovitost | Identifikace artiklu
Název artiklu | Název artiklu
Externí id. | Externí identifikace nemovitosti
Zaplombování | Datum zaplombování nebo zápisu objektů do řízení.
Odplombování | Datum odstranění plomby
Stránka #3 Předměty řízení
Řízení | Číslo řízení
Typ | Kód typu řízení
Pořadí | Pořadí řízení daného charakteru
Název typu | Název typu
Mřížka [Předměty řízení]
Typ | Typ předmětu řízení
 | Název typu
Stránka #4 Účastníci řízení
Mřížka [Účastníci řízení]
Listovací rámeček
Stránka #1 Základní údaje
Účastník | Identifikace účastníka řízení
Název | Obchodní jméno
Příjmení rodné | Příjmení rodné
Jméno | Jméno
Titul před | Titul před jménem
Titul za | Titul za jménem
Rodné číslo | Rodné číslo
IČO | IČO
Doplněk IČO | Doplněk IČO
DIČ | DIČ
Stránka #2 Další
Ověření podpisu | Ověření podpisu proti podpisovému vzoru.
Ověření proti OPSUB | Ověření proti OPSUB - oprávněné subjekty
Druh účastníka | Druh účastníka řízení (fyzická, právnická osoba).
Stránka #3 Adresy
Mřížka [Adresy účastníka]
Typ | Typ adresy
Ulice | Ulice
 | Číslo domovní
 | Číslo orientační
Psč | Psč
Část obce | %Cást obce
Obec | Obec
Okres | Okres
Stát | Stát
Telefon | Telefonní číslo
Fax | Fax
Stránka #4 Typy
Mřížka [Typy]
Typ | Typ účastníka řízení
Název typu | Název typu
Stránka #5 Obeslání
Mřížka [Obeslání]
Obeslání | Identifikace obeslání úč.řízení
Způsob | Způsob obeslání
Název typu | Název typu
Přijato | Datum přijetí korespondence účastníkem - doručenka
Stav obeslání | Stav obeslání
Subjekt | Identifikace oprávněného subjektu
Název subjektu | Název nebo příjmení oprávněného subjektu
Stránka #5 Listiny
Řízení | Číslo řízení
Typ | Kód typu řízení
Pořadí | Pořadí řízení daného charakteru
Název typu | Název typu
Mřížka [Listiny]
Listina | Identifikace listiny
Typ | Typ listiny
 | Název typu
Popis | Popis obsahu listiny
Vyhotovení | Datum vyhotovení listiny
Platnost | Datum platnosti nebo nabytí právní moci
Právní moc | Datum nabytí právní moci
Vykonavatelnost | Datum vykonavatelnosti
Stránka #6 Výběr
Řízení | Číslo řízení
Zahájeno | Datum zahájení řízení
Stav | Aktuální stav řízení
Typ | Typ předmětu řízení
Druh | Identifikace druhu artiklu
Nemovitost | Identifikace artiklu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Řízení] činnosti - INFORMACE O ŘÍZENÍ

    Mřížka [Řízení] činnosti - INFORMACE O ŘÍZENÍ
Řízení | Číslo řízení
Typ | Kód typu řízení
Pořadí | Pořadí řízení daného charakteru
Název typu | Název typu

    Mřížka [Nemovitosti] činnosti - INFORMACE O ŘÍZENÍ

    Mřížka [Nemovitosti] činnosti - INFORMACE O ŘÍZENÍ
Druh | Identifikace druhu artiklu
Nemovitost | Identifikace artiklu
Název artiklu | Název artiklu
Externí id. | Externí identifikace nemovitosti

    Mřížka [Předměty řízení] činnosti - INFORMACE O ŘÍZENÍ

    Mřížka [Předměty řízení] činnosti - INFORMACE O ŘÍZENÍ
Typ | Typ předmětu řízení
Název typu | Název typu

    Mřížka [Účastníci řízení] činnosti - INFORMACE O ŘÍZENÍ

    Mřížka [Účastníci řízení] činnosti - INFORMACE O ŘÍZENÍ
Název | Obchodní jméno
Jméno | Jméno
IČO | IČO
Rodné číslo | Rodné číslo

    Mřížka [Adresy účastníka] činnosti - INFORMACE O ŘÍZENÍ

    Mřížka [Adresy účastníka] činnosti - INFORMACE O ŘÍZENÍ
Typ | Typ adresy
Obec | Obec
Ulice | Ulice

    Mřížka [Typy] činnosti - INFORMACE O ŘÍZENÍ

    Mřížka [Typy] činnosti - INFORMACE O ŘÍZENÍ
Typ | Typ účastníka řízení
Název typu | Název typu

    Mřížka [Obeslání] činnosti - INFORMACE O ŘÍZENÍ

    Mřížka [Obeslání] činnosti - INFORMACE O ŘÍZENÍ
Přijato | Datum přijetí korespondence účastníkem - doručenka
Stav obeslání | Stav obeslání
Způsob | Způsob obeslání
Název typu | Název typu

    Mřížka [Listiny] činnosti - INFORMACE O ŘÍZENÍ

    Mřížka [Listiny] činnosti - INFORMACE O ŘÍZENÍ
Listina | Identifikace listiny
Vyhotovení | Datum vyhotovení listiny
Platnost | Datum platnosti nebo nabytí právní moci
Vykonavatelnost | Datum vykonavatelnosti
Právní moc | Datum nabytí právní moci

    Vyvolávané činnosti

    K. | Činnost | Popis
- | INFORMACE O ŘÍZENÍ | Informace o řízení
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Nemovitosti | Nemovitosti
F2 | Složené typy pro pozemky | Složené typy pro pozemky

    Atributy tisku

    Základní údaje
Řízení | Číslo řízení | PYRIZENI_py21id | C(30)
Typ | Kód typu řízení | PYRIZENI_py12typriz | C(10)
Název typu | Název typu | PYTYPCIS_py12nazev | C(60)
Pořadí | Pořadí řízení daného charakteru | PYRIZENI_py21porcis | N(8)
Zahájeno | Datum zahájení řízení | PYRIZENI_py21datriz | D
Stav | Aktuální stav řízení | PYRIZENI_py21stav | C(20)
Poslední funkce | Kód poslední realizované funkce | PYRIZENI_py21fcekod | N(4)
Poslední operace | Kód poslední realizované operace | PYRIZENI_py21typope | N(4)
Významná funkce | Kód poslední významné realizované funkce | PYRIZENI_py21fcekov | N(4)
Významná operace | Kód poslední významné realizované operace | PYRIZENI_py21typopv | N(4)
Odpovědná osoba | Jméno uživatele, který má přiřazeno řízení | PYRIZENI_py21uzisys | C(30)
Role | Jméno role, která má přiřazeno řízení | PYRIZENI_py21uzirol | C(30)
Osvobozeno | Osvobozeno od platby Ano/Ne | PYRIZENI_py21osvob | N(1)
Kolek | Hodnota kolkové známky | PYRIZENI_py21kolek | N(5)
Další datum | Datum (další význam podle typu řízení) | PYRIZENI_py21datum | D
Další datum | Datum (další význam podle typu řízení) | PYRIZENI_py21datum2 | D
Popis | Popis (další význam podle typu řízení) | PYRIZENI_py21popis | M
Datum uzavření | Datum uzavření řízení | PYRIZENI_py21datuza | D
Předmět řízení | Předmět řízení | PYRIZENI_py21typpre | M
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Název typu | Název typu | PYTYPCIS2_py12nazev | C(60)
Název typu | Název typu | PYTYPCIS5_py12nazev | C(60)

    Při pohybu v Listiny
Listina | Identifikace listiny | PYLISTIN_py17id | C(30)
Typ | Typ listiny | PYLISTIN_py12typlis | C(10)
Popis | Popis obsahu listiny | PYLISTIN_py17popis | M
Obsah existuje | Identifikátor existence obsahu listiny | PYLISTIN_py17obsah | C(1)
Stran | Počet stran | PYLISTIN_py17stran | N(4)
Platnost | Datum platnosti nebo nabytí právní moci | PYLISTIN_py17datpla | D
Zhotovitel | Jméno zhotovitele listiny | PYLISTIN_py17zhotov | C(60)
Vyhotovení | Datum vyhotovení listiny | PYLISTIN_py17datzho | D
Číslo | Pořadové číslo zhotovitele listiny | PYLISTIN_py17pczhot | C(7)
JČ zhotovitele | Doplnění jednacího čísla listiny zhotovitele | PYLISTIN_py17dopzho | C(60)
Zkratka | Zkratka zhotovitlele | PYLISTIN_py17zhozkr | C(10)
Z. právního vztahu | Indikace změny právního vztahu | PYLISTIN_py17zmepvz | C(1)
Právní moc | Datum nabytí právní moci | PYLISTIN_py17pravmo | D
Vykonavatelnost | Datum vykonavatelnosti | PYLISTIN_py17datvyk | D

    Při pohybu v Nemovitosti
ID | Identifikace objektu řízení | PYRIZOBJ_py20id | C(30)
Nemovitost | Identifikace artiklu | PYRIZOBJ_sp60id | C(13)
Druh artiklu | Identifikace druhu artiklu | PYRIZOBJ_sp61id | C(3)
Zaplombování | Datum zaplombování nebo zápisu objektů do řízení. | PYRIZOBJ_py20datplo | D
Odplombování | Datum odstranění plomby | PYRIZOBJ_py20datodp | D

    Při pohybu v Předměty řízení
    Typ Typ předmětu řízení PYRIZPRE_py12typpre C(10)

    Při pohybu v Účastníci řízení
Účastník | Identifikace účastníka řízení | PYRIZUC_py14id | C(30)
Název | Obchodní jméno | PYRIZUC_py14objm | C(254)
Jméno | Jméno | PYRIZUC_py14jmeno | C(40)
Titul před | Titul před jménem | PYRIZUC_py14titpre | C(40)
Titul za | Titul za jménem | PYRIZUC_py14titza | C(10)
Příjmení rodné | Příjmení rodné | PYRIZUC_py14prijmr | C(40)
IČO | IČO | PYRIZUC_py14ico | C(8)
Doplněk IČO | Doplněk IČO | PYRIZUC_py14doplic | C(3)
Rodné číslo | Rodné číslo | PYRIZUC_py14rodcis | C(10)
DIČ | DIČ | PYRIZUC_py14dic | C(14)
Ověření podpisu | Ověření podpisu proti podpisovému vzoru. | PYRIZUC_py14podpis | C(1)
Ověření proti OPSUB | Ověření proti OPSUB - oprávněné subjekty | PYRIZUC_py14overen | C(1)
Druh účastníka | Druh účastníka řízení (fyzická, právnická osoba). | PYRIZUC_py14druhuc | N(1)


Správní celky

Popis

Tato činnost umožňuje uživateli evidovat jednotlivé správní celky, které se vážou k nemovitostem. U každého správního celku jsou k dispozici tyto atributy:

¨ správní celek - identifikace a název správního celku

¨ nadřazený celek - identifikace nadřazeného správního celku (tzn. u obcí zřejmě identifikace okresu, kraje apod.)

¨ platnost od - do

Datový model

  • PYSPRCEL Správní celek
    • PYSPRCEP Pohled do PYSPRCEL

    • Formulář

    Formulář činnosti - Správní celky
Mřížka [Správní celky]
Správní celek | Obec,Část obce, Okres,Kraj
Název | Název správního celku
Nadř. celek | Nadřazený správní celek
Název | Název správního celku
Platnost od | Platnost spr.celku od
Platnost do | Platnost spr.celku do

    Mřížka [Správní celky] činnosti - Správní celky

    Mřížka [Správní celky] činnosti - Správní celky
Správní celek | Obec,Část obce, Okres,Kraj
Název | Název správního celku

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Správní celky | Správní celky

    Atributy tisku

    Základní údaje
Správní celek | Obec,Část obce, Okres,Kraj | PYSPRCEL_py11id | C(8)
Název | Název správního celku | PYSPRCEL_py11nazspc | C(60)
Nadř. celek | Nadřazený správní celek | PYSPRCEL_py11idnsc | C(8)
Název | Název správního celku | PYSPRCEP_py11nazspc | C(60)
Platnost od | Platnost spr.celku od | PYSPRCEL_py11platod | D
Platnost do | Platnost spr.celku do | PYSPRCEL_py11platdo | D


Složené typy pro pozemky

Popis

Uživatel má k dispozici číselník složených typů pro pozemky. U každého typu je možno evidovat:

¨ identifikace a název složeného typu

¨ identifikace barvy RGB – pro BM Topol

¨ platnost od

¨ platnost do

¨ zkratka typu

¨ doplňkový kód – způsob využití jednotek

¨ zpoplatněn – zda-li je typ zpoplatněn

¨ druh listiny

¨ poznámka

Datový model

  • PYTYPCIS Sloučený typ - spojené číselníky

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | BMTopol |
F2 | Barvy RGB |

    Formulář

    Formulář činnosti - Barvy RGB
Mřížka [Typy]
ID | Identifikace typu
Název typu | Název typu
Barva pro BMTopol | Identifikace barvy RGB
Platnost od | Platnost od
Platnost do | Platnost do
Zkratka | Zkratka typu
Doplňkový kód | Doplňkový kód - Způsob využití jednotek ZPVYJE
Zpoplatněn | Je typ rizeni zpoplatněn TYPRIZ Ano/Ne
Druh listiny | Druh listiny - TYPLIS
Poznámka | Poznámka

    Mřížka [Typy] činnosti - Barvy RGB

    Mřížka [Typy] činnosti - Barvy RGB
ID | Identifikace typu
Název typu | Název typu
Platnost od | Platnost od
Platnost do | Platnost do

    Atributy tisku

    Základní údaje
ID | Identifikace typu | PYTYPCIS_py12id | C(10)
Název typu | Název typu | PYTYPCIS_py12nazev | C(60)
ID | Identifikace barvy RGB | PYTYPCIS_bw95id | C(6)
Popis | Popis barvy RGB | BWRGBCOL_bw95popbar | C(40)
Platnost od | Platnost od | PYTYPCIS_py12platod | D
Platnost do | Platnost do | PYTYPCIS_py12platdo | D
Zkratka | Zkratka typu | PYTYPCIS_py12zkrat | C(16)
Doplňkový kód | Doplňkový kód - Způsob využití jednotek ZPVYJE | PYTYPCIS_py12dopkod | C(3)
Zpoplatněn | Je typ rizeni zpoplatněn TYPRIZ Ano/Ne | PYTYPCIS_py12zpopla | C(1)
Druh listiny | Druh listiny - TYPLIS | PYTYPCIS_py12druhli | C(2)
Poznámka | Poznámka | PYTYPCIS_py12poznam | M


Druhy událostí o nemovitostech

Popis

Uživatel má k dispozici číselník druhu událostí o nemovitostech, kde může druhy událostí zakládat, opravovat či rušit. Ke každému druhu události se vztahují tyto atributy:

¨ druh - identifikace a název druhu

¨ umístění - identifikace umístění, které se vztahuje k danému druhu události. Pokud jsou u umístění nadefinována přístupová práva, budou se vztahovat i k druhu události, tzn. uživatel nebude mít právo k druhu události, které je svázáno s umístěním, na které nemá přístupové právo (min. čtení)

¨ stav - identifikace stavu, který se vztahuje k druhu události. Pokud je stav odlišen barevně, je stejnou barvou jako stav označen i daný druh události o nemovitostech

Datový model

  • PYDRUUDA Druh události o nemovitosti
    • PYUMIST Umístění nemovitosti
    • PYSTAV Stav nemovitosti podle našeho zájmu

    • Formulář

    Formulář činnosti - Umístění nemovitostí
Mřížka [Druhy událostí o nemovitostech]
Druh | Identifikace druhu události o nemovitosti
Název druhu | Název druhu události o nemovitosti
Umístění | Identifikace umístění nemovitosti
Název umístění | Název umístění nemovitosti
Stav | Identifikace stavu nemovitosti
Název stavu | Název stavu nemovitosti
Poznámka | Poznámka

    Mřížka [Druhy událostí o nemovitostech] činnosti - Umístění nemovitostí

    Mřížka [Druhy událostí o nemovitostech] činnosti - Umístění nemovitostí
Druh | Identifikace druhu události o nemovitosti
Název druhu | Název druhu události o nemovitosti

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Stavy nemovitostí | Stavy nemovitostí
F2 | Umístění nemovitostí | Umístění nemovitostí

    Atributy tisku

    Základní údaje
Druh | Identifikace druhu události o nemovitosti | PYDRUUDA_py03id | C(6)
Název druhu | Název druhu události o nemovitosti | PYDRUUDA_py03nazdru | C(40)
Umístění | Identifikace umístění nemovitosti | PYDRUUDA_py04id | C(6)
Název umístění | Název umístění nemovitosti | PYUMIST_py04nazumi | C(40)
Stav | Identifikace stavu nemovitosti | PYDRUUDA_py06id | C(6)
Název stavu | Název stavu nemovitosti | PYSTAV_py06nazsta | C(40)
Poznámka | Poznámka | PYDRUUDA_py03koment | M


Stavy nemovitostí

Popis

Uživatel má k dispozici číselník jednotlivých nadefinovaných stavů, kterých mohou nemovitosti dosahovat. Změny ve stavech nemovitostí se provádí zápisem událostí o nemovitostech (pomocí nastavených procesů). U každého stavu nemovitosti se eviduje:

¨ stav - identifikace a název stavu

¨ priorita – priorita stavu pro zobrazení barvy nemovitosti (čím menší číslo, tím vyšší priorita)

¨ barva - tzn. jakou barvou se pak budou uživateli zobrazovat nemovitosti, které mají u sebe tento stav

¨ barva pro BM Topol – barva zvýraznění nemovitosti pro programovou aplikaci BM Topol

¨ odvozený stav - zda je stav nemovitosti odvozený od stavu dat (volba Ano/Ne)

¨ určující SQL dotaz odvozeného stavu – určující SQL dotaz odvozeného stavu (vracející atributy s významem sp61id, sp60id, py07datod, py07datdo)

¨ libovolná poznámka ke stavu nemovitosti

Při provedení změn a nutnosti přepočtu stavu uživatel stiskne klávesu F6 nebo pod menu Volby aktivuje činnost „přepočet stavu nemovitostí“.

Datový model

  • PYSTAV Stav nemovitosti podle našeho zájmu

    • Formulář

    Formulář činnosti - Barvy RGB
Mřížka [Stavy nemovitostí]
Stav | Identifikace stavu nemovitosti
Název stavu | Název stavu nemovitosti
Priorita | Priorita stavu pro zobrazení barvy nemovitosti
Barva | Barva zvýraznění nemovitosti ve stavu
Barva pro BMTopol | Identifikace barvy RGB
Odvozený stav | Stav nemovitosti je odvozený podle stavu dat Ano/Ne
Určující SQL dotaz odvozeného stavu | Určující SQL dotaz odvozeného stavu vracející atributy s významem sp61id,sp60id,py07datod,py07datdo
Poznámka | Poznámka

    Mřížka [Stavy nemovitostí] činnosti - Barvy RGB

    Mřížka [Stavy nemovitostí] činnosti - Barvy RGB
Stav | Identifikace stavu nemovitosti
Název stavu | Název stavu nemovitosti
Priorita | Priorita stavu pro zobrazení barvy nemovitosti

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | BMTopol |
F6 | Přepočet stavu nemovitostí | Přepočet stavu nemovitostí
F2 | Barvy RGB |

    Atributy tisku

    Základní údaje
Stav | Identifikace stavu nemovitosti | PYSTAV_py06id | C(6)
Název stavu | Název stavu nemovitosti | PYSTAV_py06nazsta | C(40)
Priorita | Priorita stavu pro zobrazení barvy nemovitosti | PYSTAV_py06prior | N(3)
Barva | Barva zvýraznění nemovitosti ve stavu | Výpočet | C(8)
Barva pro BMTopol | Identifikace barvy RGB | PYSTAV_bw95id | C(6)
Popis | Popis barvy RGB | BWRGBCOL_bw95popbar | C(40)
Odvozený stav | Stav nemovitosti je odvozený podle stavu dat Ano/Ne | Výpočet | C(3)
Určující SQL dotaz odvozeného stavu | Určující SQL dotaz odvozeného stavu vracející atributy s významem sp61id,sp60id,py07datod,py07datdo | PYSTAV_py06sql | M
Poznámka | Poznámka | PYSTAV_py06koment | M


Transformace změn - nemovitost

Popis

Tato činnost popisuje nastavení sledování změn v tabulkách nemovitostí tak, aby po načtení souboru katastru bylo zřejmé, k jakým změnám informací o nemovitostech došlo. Změny jsou zaznamenávány jako události komponenty nemovitosti a jsou zjišťovány triggery na základě výrazů podmínek, ve kterých se vyskytují atributy ve tvaru @atribut_entity případně @OLD_atribut_entity. K dispozici jsou tyto údaje:

¨ transformace – název

¨ tabulka – název entity

¨ druh – identifikace druhu události o nemovitosti

¨ vkládání – dotaz, zda se uplatní při vložení záznamu tabulky (volba Ano/Ne)

¨ podmínka – podmínka vzniku události o nemovitosti při vložení záznamu (předchozí atribut musí mít tedy hodnotu Ano)

¨ oprava – dotaz, zda se uplatí při opravě záznamu tabulky (volba Ano/Ne)

¨ podmínka – podmínka vzniku události o nemovitosti při opravě záznamu (předchozí atribut musí mít tedy hodnotu Ano)

¨ rušení – dotaz, zda se uplatí při rušení záznamu tabulky (volba Ano/Ne)

¨ podmínka – podmínka vzniku události o nemovitosti při zrušení záznamu (předchozí atribut musí mít tedy hodnotu Ano)

¨ poznámka

Na záložce „atributy“ se definují jednotlivé položky dané transformace a přesně popisují to, co má být zapsáno do události o změně. Jsou to:

¨ název atributu – výběr z překryvného seznamu

¨ výraz – výraz transformované hodnoty do atributu

¨ poznámka

Datový model

  • PYTRAN Transformace změny obsahu entity do události o nemovitosti
    • PYDRUUDA Druh události o nemovitosti

    • Formulář

    Formulář činnosti - Datový model
Mřížka [Transformace]
Transformace | Název transformace
Tabulka | Název entity
 | Název tabulky
Listovací rámeček
Stránka #1 Transformace
Druh | Identifikace druhu události o nemovitosti
Název druhu | Název druhu události o nemovitosti
Vkládání | Uplatní se při vložení záznamu tabulky Ano/Ne
Podmínka | Podmínka vzniku události o nemovitosti při vložení záznamu
Oprava | Uplatní se při opravě záznamu tabulky Ano/Ne
Podmínka | Podmínka vzniku události o nemovitosti při opravě záznamu
Rušení | Uplatní se při rušení záznamu tabulky Ano/Ne
Podmínka | Podmínka vzniku události o nemovitosti při zrušení záznamu
Poznámka | Poznámka
Stránka #2 Atributy
Mřížka [Atributy]
Atribut | Název atributu
Výraz | Výraz transformované hodnoty do atributu
Poznámka | Poznámka

    Mřížka [Transformace] činnosti - Datový model

    Mřížka [Transformace] činnosti - Datový model
Transformace | Název transformace
Tabulka | Název entity
Vkládání | Uplatní se při vložení záznamu tabulky Ano/Ne
Oprava | Uplatní se při opravě záznamu tabulky Ano/Ne
Rušení | Uplatní se při rušení záznamu tabulky Ano/Ne

    Mřížka [Atributy] činnosti - Datový model

    Mřížka [Atributy] činnosti - Datový model
Atribut | Název atributu
Výraz | Výraz transformované hodnoty do atributu

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Datový model | Datový model Bílého motýla
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy událostí o nemovitostech | Druhy událostí o nemovitostech

    Atributy tisku

    Základní údaje
Transformace | Název transformace | PYTRAN_py09naztra | C(40)
Tabulka | Název entity | PYTRAN_bw10nazev | C(8)
Vkládání | Uplatní se při vložení záznamu tabulky Ano/Ne | Výpočet | C(3)
Podmínka | Podmínka vzniku události o nemovitosti při vložení záznamu | PYTRAN_py09podins | M
Oprava | Uplatní se při opravě záznamu tabulky Ano/Ne | Výpočet | C(3)
Podmínka | Podmínka vzniku události o nemovitosti při opravě záznamu | PYTRAN_py09podupd | M
Rušení | Uplatní se při rušení záznamu tabulky Ano/Ne | Výpočet | C(3)
Podmínka | Podmínka vzniku události o nemovitosti při zrušení záznamu | PYTRAN_py09poddel | M
Druh | Identifikace druhu události o nemovitosti | PYTRAN_py03id | C(6)
Název druhu | Název druhu události o nemovitosti | PYDRUUDA_py03nazdru | C(40)
Poznámka | Poznámka | PYTRAN_py09koment | M


Umístění nemovitostí

Popis

Uživatel má k dispozici přehled jednotlivých umístění, kde u každého umístění má k dispozici identifikaci umístění a organizačního selektoru.

Ke každému umístění lze nadefinovat přístupová práva, čímž se nepřímo určují přístupová práva i pro druhy událostí o nemovitostech. Každý druh události je totiž svázán s určitým umístěním a pokud uživatel nemá přístupové právo na umístění uvedené na druhu události, nemá právo ani k druhu události o nemovitostech.

Datový model

  • PYUMIST Umístění nemovitosti
    • SPSEOR Organizační selektor
    • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Umístění nemovitostí]
Umístění | Identifikace umístění nemovitosti
Název umístění | Název umístění nemovitosti
Org. sel. | Identifikátor organizačního selektoru.
Název organizačního selektoru | Název organizačního selektoru
Poznámka | Poznámka

    Mřížka [Umístění nemovitostí] činnosti - Přístupová práva

    Mřížka [Umístění nemovitostí] činnosti - Přístupová práva
Umístění | Identifikace umístění nemovitosti
Název umístění | Název umístění nemovitosti
Org. sel. | Identifikátor organizačního selektoru.

    Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci
F2 | Organizační selektor | Číselník organizačních selektorů

    Atributy tisku

    Základní údaje
Umístění | Identifikace umístění nemovitosti | PYUMIST_py04id | C(6)
Název umístění | Název umístění nemovitosti | PYUMIST_py04nazumi | C(40)
Org. sel. | Identifikátor organizačního selektoru. | PYUMIST_sp11idzak | C(9)
Název organizačního selektoru | Název organizačního selektoru | SPSEOR_sp11text | C(60)
Poznámka | Poznámka | PYUMIST_py04koment | M


Parametry komp. nemovitosti

Popis

Parametry ovlivňující chování komponenty pozemky:

¨ sada - tj. identifikace sady parametrů z oblasti AAA. Obecné parametry této sady je možné aktualizovat a prezentovat na záložce „parametry“ v činnosti s přehledem nemovitostí.

¨ operace zápisu událostí na pozadí - identifikuje operaci do které import dat z Katastrálního úřadu zaznamená události reflektující změny. Uživatel zde uvádí identifikaci a číslo operace (číslo operace se pak mění automaticky po každém provedeném importu o jedno výš).

Datový model

  • PYPARAM Parametry komponenty nemovitosti
    • PASADA Sada parametrů

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Sady parametrů | Sady parametrů

    Formulář

    Formulář činnosti - Sady parametrů
Sada | Identifikátor sady parametrů
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
Operace zápisu událostí na pozadí | Pořadové číslo procesu
Komponenta | Identifikace komponenty
 | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu


Stavy dat

Popis

Stavy dat, které jsou dostupné v souboru katastru nemovitostí. U každého stavu jsou k dispozici tyto údaje:

¨ stav – identifikace a název stavu

¨ stav ISKN – stav v informačním systému katastru nemovitostí

¨ kontext změny ISKN – kontext změny v informačním systému katastru nemovitostí

¨ podbarvit – podbarvení v mřížce formuláře (volby Ano/Ne)

Datový model

  • PYSTADAT Stav dat

    • Formulář

    Formulář činnosti - Sady parametrů
Mřížka [Stavy dat]
Stav | Identifikátor stavu dat
Název stavu | Název stavu dat
Stav ISKN | Stav v informačním systému katastru nemovitostí
Kontext změny ISKN | Kontext změny v informačním systému katastru nemovitostí
Podbarvit | Podbarvení v mřížce
Poznámka | Poznámka

    Mřížka [Stavy dat] činnosti - Sady parametrů

    Mřížka [Stavy dat] činnosti - Sady parametrů
Stav | Identifikátor stavu dat
Název stavu | Název stavu dat
Stav ISKN | Stav v informačním systému katastru nemovitostí
Kontext změny ISKN | Kontext změny v informačním systému katastru nemovitostí

    Atributy tisku

    Základní údaje
Stav | Identifikátor stavu dat | PYSTADAT_py32id | C(6)
Název stavu | Název stavu dat | PYSTADAT_py32popsta | C(40)
Poznámka | Poznámka | PYSTADAT_py32koment | M
Stav ISKN | Stav v informačním systému katastru nemovitostí | PYSTADAT_py32stadat | N(3)
Podbarvit | Podbarvení v mřížce | Výpočet | C(3)
Kontext změny ISKN | Kontext změny v informačním systému katastru nemovitostí | PYSTADAT_py32prikon | N(1)


Popis mapy Topolu

Popis

Tato činnost představuje pro uživatele pouze základní informace (resp. hlavičku) mapy, která bude pomocí aplikace Topol vytvářena. Uživatel nadefinuje název a příslušné SQL dotazy (pro zobrazení popisu, pro zobrazení barev, pro zobrazení legendy).

Datový model

  • PYTOPMAP Popis mapy v Topolu

    • Formulář

    Formulář činnosti - Export výsledků SQL dotazu
Mřížka [Mapy Topolu]
Mapa | Popis mapy
SQL popisu | Identifikace dotazu SQL pro zobrazení popisů
SQL barvy | Identifikace dotazu SQL pro zobrazení barev
SQL legendy | Identifikace dotazu SQL pro zobrazení legendy
Poznámka | Poznámka

    Mřížka [Mapy Topolu] činnosti - Export výsledků SQL dotazu

    Mřížka [Mapy Topolu] činnosti - Export výsledků SQL dotazu
    Mapa Popis mapy

    Vyvolávané činnosti

    K. | Činnost | Popis
- | Export výsledků SQL dotazu |
F2 | SQL dotazy pro BMTopol |


Tabulky AD...

ADADR | Adresa
ADADSAP | Adresát s kompletní adresou a spojením
ADADSAT | Adresát
ADADSDRU | Druh adresáta
ADADZAM | Hlavička záměn adresátů
ADADZAMS | Záměny adresátů - pravidla záměny spojení
ADADZAMU | Záměny adresátů - pravidla záměny bankovního spojení
ADBUCTY | Bankovní účty adresátů
ADBUCTYM | Další měna bankovního účtu
ADCNVPOS | Konverze pro štítek v události pošty
ADINTER | Interval čísel adresátů
ADKAT | Kategorie adresáta
ADKATADS | Zařazení (spojení) adresáta do kategorie
ADKATBAR | Barvy kategorií
ADKRAJE | Kraj
ADMESTA | Město
ADOKRESY | Okres adresy adresáta
ADOSLOV | Oslovení
ADOZNAC | Označený záznam o adresátovi
ADPALETA | Paleta barev kategorií adresáta
ADPALKAT | Barva kategorie adresáta v paletě barev
ADSPOJ | Spojení adresáta
ADSPOJP | Spojení s kompletní informací o adrese, adresátovi a bankovním spojení
ADSPOPAR | Parametr subjektu připojeného pomocí spojení
ADSPOPRA | Popis elementátní hodnoty druhu parametru
ADSPOPRD | Druh parametru subjektu spojení
ADSPOSLU | Popis sloučení spojení adresáta
ADSTATY | Stát
ADTYPSPO | Typ spojení
ADTYPSPR | Druh parametru pro typ subjektu
ADTYPSUB | Typ subjektu ve spojení adresáta

Viz.také

ADADR Adresa | ADADSAT Adresát | ADBUCTY Bankovní účty adresátů | ADINTER Interval čísel adresátů | ADKAT Kategorie adresáta | ADKATADS Zařazení (spojení) adresáta do kategorie | ADKATBAR Barvy kategorií | ADMESTA Město | ADOSLOV Oslovení | ADOZNAC Označený záznam o adresátovi | ADSPOJ Spojení adresáta | ADSTATY Stát | ADTYPSPO Typ spojení | ADSPOPAR Parametr subjektu připojeného pomocí spojení | ADSPOPRA Popis elementátní hodnoty druhu parametru | ADSPOPRD Druh parametru subjektu spojení | ADSPOSLU Popis sloučení spojení adresáta | ADTYPSPR Druh parametru pro typ subjektu | ADTYPSUB Typ subjektu ve spojení adresáta | ADADZAM Hlavička záměn adresátů | ADADZAMS Záměny adresátů - pravidla záměny spojení | ADADZAMU Záměny adresátů - pravidla záměny bankovního spojení | ADKRAJE Kraj | ADOKRESY Okres adresy adresáta | ADADSAP Adresát s kompletní adresou a spojením | ADSPOJP Spojení s kompletní informací o adrese, adresátovi a bankovním spojení | ADBUCTYM Další měna bankovního účtu | ADADSDRU Druh adresáta | ADPALETA Paleta barev kategorií adresáta | ADPALKAT Barva kategorie adresáta v paletě barev | ADCNVPOS Konverze pro štítek v události pošty


ADADR Adresa

Popis

Objektem typu ADADR je každý záznam, který obsahuje adresu a kontaktní údaje k danému adresátovi (#ADADSAT) potřebné pro navázání kontaktu s adresátem.
*** Dříve ADRESY.

Atributy

Atribut | Typ | Návěští | Message | Popis
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad02cisadr | C(2) | Adresa | Číslo adresy adresáta. | Číslo adresy adresáta. Program generuje automaticky. *** Dříve CISADR. C,1 !!!
ad02ulice | C(40) | Ulice | Ulice adresy adresáta (včetně čísla popisného). | Ulice adresy adresáta (včetně čísla popisného). *** Dříve ULICE.
ad02byt | C(40) | Byt | Ulice bytu adresáta (včetně čísla popisného) |
ad13psc | C(10) | PSČ | Poštovní směrovací číslo adresy adresáta. | Poštovní směrovací číslo adresy adresáta. *** Dříve PSC.
ad02mesto | C(40) | Město | Město adresy adresáta. | Město adresy adresáta.
ad05id | C(3) | Stát | Identifikace státu. | Identifikace státu. *** Dříve ZIP.
ad75id | C(6) | Konverze | Konverze pro štítek události pošty | Konverze pro štítek události pošty
ad02pozn | M | Komentář | Kometář k adrese adresáta. | Poznámka k adrese adresáta. *** Dříve POZNADR.
dp05id | C(3) | Typ místa | Identifikace typu místa zdanitelného plnění | Identifikace typu místa zdanitelného plnění
dp04tuzzah | N(1,0) | Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie .... | Tuzemsko/Zahraničí
ad67id | C(6) | Okres | Identifikace okresu | Identifikace okresu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Adresa - včetně státu | ADADR ad05id | 1,1 : 0,M | ADSTATY ad05id |
Adresa - patří do okresu | ADADR ad67id | 1,1 : 0,M | ADOKRESY ad67id |
Adresa - je konvertována na štítek podle definice | ADADR ad75id | 1,1 : 0,M | ADCNVPOS ad75id |
Adresa - přísluší adresátovi | ADADR ad01id | 1,1 : 0,M s rušením | ADADSAT ad01id |
Parametr subjektu připojeného pomocí spojení - definuje adresu | ADSPOPAR ad01id ad02cisadr | 0,1 : 0,M | ADADR ad01id ad02cisadr |
Spojení adresáta - má adresu !! RI !! | ADSPOJ ad01id ad02cisadr | 1,1 : 0,M | ADADR ad01id ad02cisadr |
Banka - má adresu adresáta (banky) | OCBANKA ad01id ad02cisadr | 0,1 : 0,M | ADADR ad01id ad02cisadr |
Pracovník - má adresu - bydliště | MZKARTA ad01id ad02cisadr | 0,1 : 0,M | ADADR ad01id ad02cisadr |
Událostní entita mezd - má adresu | MZUDALOS ad01id ad02cisadr | 0,1 : 0,M | ADADR ad01id ad02cisadr |
Seznam zdravotních pojišťoven - má adresu | MZPOJSEZ ad01id ad02cisadr | 1,1 : 0,M | ADADR ad01id ad02cisadr |
Adresa na trase expedice - má adresu | EXTRASAV ad01id ad02cisadr | 1,1 : 0,M | ADADR ad01id ad02cisadr |

Indexy

Název | Primární | Výraz | Popis
ix_ADADR_ad01id |  | ad01id | Identifikace adresáta
ix_ADADR_ad02cisadr |  | ad02cisadr | Číslo adresy adresáta. Program generuje automaticky.
ix_ADADR_ad02ulice |  | ad02ulice | Ulice adresy adresáta (včetně čísla popisného).
ix_ADADR_ad02byt |  | ad02byt |
ix_ADADR_ad13psc |  | ad13psc | Poštovní směrovací číslo adresy adresáta.
ix_ADADR_ad02mesto |  | ad02mesto | Město adresy adresáta.
ix_ADADR_ad05id |  | ad05id | Identifikace státu.
ix_ADADR_ad75id |  | ad75id | Konverze pro štítek události pošty
ix_ADADR_adadr1 | P | ad01id, ad02cisadr | Adresát + číslo adresy Pro zobrazení
ix_ADADR_adadr21 |  | ad01id, ad02mesto | Adresát + Město Pro zobrazení v oknech Adresát - 2 a Adresy
ix_ADADR_dp05id |  | dp05id | Identifikace typu místa zdanitelného plnění
ix_ADADR_adadsatx |  |  |
ix_ADADR_ad67id |  | ad67id | Identifikace okresu


ADADSAP Adresát s kompletní adresou a spojením

Popis

Adresát s kompletní adresou a spojením

Atributy

Atribut | Typ | Návěští | Message | Popis
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta


ADADSAT Adresát

Popis

Objektem typu ADADSAT je každý záznam, který obsahuje identifikační údaje adresáta. Adresátem je kdokoliv s kým se v rámci činnosti uživatele systému vstoupí nebo je možno vstoupit v jednání. Všechny informace v systému jsou vztaženy (přímo nebo nepřímo) k adresátovi.

Př: Fyzická, právnická osoba, úřady, vnitropodniková střediska uživatele, zaměstnanci uživatele, fiktivní (drobný prodej, prodej za hotové ap.). Speciálním výskytem je uživatel sám - z hlediska zpracování má výjimečné postavení.

*** Dříve DUCISO.

Atributy

Atribut | Typ | Návěští | Message | Popis
ad01 | C(12) | ad01 | Jednoznačná časová identifikace adresáta | Jednoznačná časová identifikace adresáta
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad01adsat | C(100) | Název adresáta | Název adresáta | Název adresáta. *** Dříve NAZEV1.
ad01adsat2 | M | ad01adsat2 | Úplný název adresáta |
ad01ico | C(10) | IČO | Identifikační číslo organizace. | Identifikační číslo organizace. *** Dříve ICO.
ad01dico | C(16) | DIČ | Daňové identifikační číslo adresáta. | Daňové identifikační číslo adresáta. *** Dříve ICDP.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
ad03cisban | C(2) | Účet | Identifikátor spojení na bankovní účet adresáta. | Číslo spojení na bankovní účet adresáta. *** Dříve CISBANK.
ad01koment | M | Komentář |  |
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
ad72id | C(6) | Druh | Druh adresáta | Druh adresáta
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
ad01klic | C(40) | ad01klic |  |
ad01rc | C(10) | ad01rc |  |
ad01ksymb | C(4) | ad01ksymb | Konstantní symbol | Konstantní symbol zapsala Olina
ad01pladph | N(1,0) | DPH | Příznak plátce DPH | Příznak plátce DPH (Povolené hodnoty A/N/mezera). *** Dříve PLDPH.
sp00aktual | N(1,0) | sp00aktual | Aktuální/ neaktuální | Aktuální/ neaktuální neboli skrytý/ neskrytý
ad01zakljm | N(20,4) | ad01zakljm | Základní jmění | Obchodní rejstřík - základní jmění
ad01spolec | M | ad01spolec | Obchodní rejstřík - seznam společníků | Obchodní rejstřík - seznam společníků
ad01volne1 | M | ad01volne1 | Obchodní rejstřík - údaj1 | Obchodní rejstřík - údaj1
ad01volne2 | M | ad01volne2 | Obchodní rejstřík - údaj2 | Obchodní rejstřík - údaj2
ad01volne3 | N(20,4) | ad01volne3 | Obchodní rejstřík - číslo 1 | Obchodní rejstřík - číslo 1
ad02cisads | C(2) | Sídlo | Číslo adresy adresáta. | Číslo adresy adresáta.
ad01unodpo | N(1,0) | Úplný název odpovídá názvu adresáta | Úplný název adresáta odpovídá názvu adresáta | Úplný název adresáta odpovídá názvu adresáta
ad01eori | C(17) | EORI | Číslo EORI | Číslo EORI

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Adresát - byl založen uživatelem | ADADSAT bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Adresát - odpovídá obchodnímu selektoru | ADADSAT sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Adresát - má implicitní měnu | ADADSAT oc01id | 1,1 : 0,M | OCMENA oc01id |
Adresát - je druhu | ADADSAT ad72id | 1,1 : 0,M | ADADSDRU ad72id |
Předmět projektu - má vedoucího projektu | NKPREDPR ad01id | 1,1 : 0,M | ADADSAT ad01id |
Umístění parametru předmětu projektu - odpovídá adresátovi | NKPARDRU ad01id | 1,1 : 0,M | ADADSAT ad01id |
Aktuální hodnota PP - je pro adresáta | NKAH ad01id | 1,1 : 0,M | ADADSAT ad01id |
Položka smlouvy - je vztažena k adresátovi | NKSMLOUV ad01id | 1,1 : 0,M | ADADSAT ad01id |
Událost o záloze - se spojená s adresátem | ZAUDAL ad01id | 1,1 : 0,M | ADADSAT ad01id |
Projektový úkol - je spojen s adresátem | NKUKOL ad01id | 1,1 : 0,M | ADADSAT ad01id |
Řešitel projektového úkolu - je adresátem | NKZDROJ ad01id | 1,1 : 0,M | ADADSAT ad01id |
Hodnoty požadavků a vlastností - ??? | MZPERS2 ad01id | 1,1 : 0,M | ADADSAT ad01id |
Plnění projektového úkolu - ve vztahu k adresátovi | NKUKOLP ad01id | 1,1 : 0,M | ADADSAT ad01id |
Aktuální hodnota projektových úkolů - je hodnotou adresáta | NKAHUK ad01id | 1,1 : 0,M | ADADSAT ad01id |
Aktuální hodnota plnění projektových úkolů - je hodnotou adresáta | NKAHUP ad01id | 1,1 : 0,M | ADADSAT ad01id |
Popis sloučení spojení adresáta - popisuje spojení adresáta | ADSPOSLU ad01id | 1,1 : 0,M | ADADSAT ad01id |
Událost personalistiky - má adresáta | MZPERUDA ad01id | 1,1 : 0,M | ADADSAT ad01id |
Událost personalistiky - má dalšího adresáta | MZPERUDA ad01id1 | 1,1 : 0,M | ADADSAT ad01id |
Hodnota parametru - definuje adresata | PAHODNOT ad01id | 1,1 : 0,M | ADADSAT ad01id |
Vztah obchodovatelného artiklu a adresáta - vyjadřuje vztah adresáta | OBARTADR ad01id | 1,1 : 0,M | ADADSAT ad01id |
Adresa - přísluší adresátovi | ADADR ad01id | 1,1 : 0,M s rušením | ADADSAT ad01id |
Zařazení (spojení) adresáta do kategorie - ve které je zařazen adresát | ADKATADS ad01id | 1,1 : 0,M s rušením | ADADSAT ad01id |
Poštovní zásilka - má adresáta | POPOSTA ad01id | 1,1 : 0,M | ADADSAT ad01id |
Označený záznam o adresátovi - označuje adresáta | ADOZNAC ad01id | 1,1 : 0,M s rušením | ADADSAT ad01id |
Operace procesu - má uvedeného adresáta | SPPRCOD ad01id | 1,1 : 0,M | ADADSAT ad01id |
Událost obecné komponenty - souvisí s adresátem | OKUDALOS ad01id | 1,1 : 0,M | ADADSAT ad01id |
Spojení adresáta - patří adresátovi | ADSPOJ ad01id | 1,1 : 0,M s rušením | ADADSAT ad01id |
Spojení adresáta - má definovaného připojeného adresáta | ADSPOJ ad01id2 | 1,1 : 0,M | ADADSAT ad01id |
Účetní událost - má adresáta | UCDENIK ad01id | 1,1 : 0,M | ADADSAT ad01id |
Spravovaný majetek - spravuje adresat | SMMAJ ad01id | 1,1 : 0,M | ADADSAT ad01id |
Událost spravovaného majetku - má adresáta | SMUDAL ad01id | 1,1 : 0,M | ADADSAT ad01id |
Rezervace - pro adresáta | SMREZER ad01id | 1,1 : 0,M | ADADSAT ad01id |
Událost odpisovaného majetku - a její adresát | ODUDAL ad01id | 1,1 : 0,M | ADADSAT ad01id |
Aktuální hodnota - má uvedené adresové spojení | POAH ad01id | 1,1 : 0,M | ADADSAT ad01id |
Banka - má adresáta (jako banku) | OCBANKA ad01id | 0,1 : 0,M | ADADSAT ad01id |
Bankovní účty adresátů - vztahuje se k adresátovi | ADBUCTY ad01id | 1,1 : 0,M | ADADSAT ad01id |
Bankovní účty adresátů - má adresáta jako banku | ADBUCTY ad01id1 | 1,1 : 0,M s rušením | ADADSAT ad01id |
Saldokontní hodnota procesu - se týká adresáta | SPPRCSAL ad01id | 1,1 : 0,M | ADADSAT ad01id |
Událost - skladba - se týká aktéra | OBAHUD ad01id | 0,1 : 0,M | ADADSAT ad01id |
Událost - skladba - se týká aktéra | DPAHUD ad01id | 0,1 : 0,M | ADADSAT ad01id |
Událost - skladba - týká se adresáta | PLAHUD ad01id | 0,1 : 0,M | ADADSAT ad01id |
Parametry - mají adresáta pro odvod SP | MZPARAM mz27socad | 1,1 : 0,M | ADADSAT ad01id |
Parametry - mají adresáta pro odvod zálohové daně | MZPARAM mz27zalda | 1,1 : 0,M | ADADSAT ad01id |
Parametry - mají adresáta pro odvod srážkové daně | MZPARAM mz27srda | 1,1 : 0,M | ADADSAT ad01id |
Parametry - mají adresáta pro uplatnění daňového bonusu | MZPARAM mz27bonad | 1,1 : 0,M | ADADSAT ad01id |
Parametry - mají adresáta pro uplatnění zákonného pojištění odpovědnosti | MZPARAM mz27zakad | 1,1 : 0,M | ADADSAT ad01id |
Aktuální hodnota - má uvedené adresové spojení | ODAH ad01id | 1,1 : 0,M | ADADSAT ad01id |
Událost - skladba - týká se aktéra | MTAHUD ad01id | 0,1 : 0,M | ADADSAT ad01id |
Pracovník - je uveden v adresáři | MZKARTA ad01id | 0,1 : 0,M | ADADSAT ad01id |
Mzda - odvody, srážky a půjčky mají adresáta | MZMZDY ad01id | 1,1 : 0,M | ADADSAT ad01id |
Událost - skladba - týká se adresáta | ZPAHUD ad01id | 0,1 : 0,M | ADADSAT ad01id |
Položky nezdanit. nebo srážky - mají adresáta | MZNEZDPO ad01id | 1,1 : 0,M | ADADSAT ad01id |
Kredit adresáta pro druh hodnoty v operaci - se vztahuje k adresátovi | SPTYPVAD ad01id | 1,1 : 0,M s rušením | ADADSAT ad01id |
Událostní entita mezd - má adresáta | MZUDALOS ad01id | 0,1 : 0,M | ADADSAT ad01id |
Záložka operace - se vztahuje k adresátovi | SPPRCODZ ad01id | 1,1 : 0,M s rušením | ADADSAT ad01id |
AAA v cenové skupině - se týká aktéra | OBCENSAK ad01id | 1,1 : 0,M s rušením | ADADSAT ad01id |
Úkolové listy - má adresáta | MZUKOLLI ad01id | 1,1 : 0,M | ADADSAT ad01id |
Seznam zdravotních pojišťoven - má adresář | MZPOJSEZ ad01id | 1,1 : 0,M | ADADSAT ad01id |

Indexy

Název | Primární | Výraz | Popis
ix_ADADSAT_ad01 |  | ad01 | Jednoznačná časová identifikace adresáta
ix_ADADSAT_ad01id | P | ad01id | Identifikace adresáta
ix_ADADSAT_ad01adsat |  | ad01adsat | Název adresáta.
ix_ADADSAT_ad01ico |  | ad01ico | Identifikační číslo organizace.
ix_ADADSAT_ad01dico |  | ad01dico | Daňové identifikační číslo adresáta.
ix_ADADSAT_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_ADADSAT_ad11cisspo |  | ad11cisspo | Číslo spojení adresáta. Program generuje automaticky.
ix_ADADSAT_ad03cisban |  | ad03cisban | Číslo spojení na bankovní účet adresáta.
ix_ADADSAT_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_ADADSAT_ad72id |  | ad72id | Druh adresáta
ix_ADADSAT_oc01id |  | oc01id | Kód měny - oceňovací jednotky.
ix_ADADSAT_ad01klic |  | ad01klic |
ix_ADADSAT_ad01rc |  | ad01rc |
ix_ADADSAT_adadrs |  | ad01id, ad02cisads | ad01id+ad02cisads


ADADSDRU Druh adresáta

Popis

Druh adresáta

Atributy

Atribut | Typ | Návěští | Message | Popis
ad72id | C(6) | Druh | Druh adresáta | Druh adresáta
ad72nazdru | C(40) | Název druhu adresáta | Název druhu adresáta | Název druhu adresáta
ad72koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Adresát - je druhu | ADADSAT ad72id | 1,1 : 0,M | ADADSDRU ad72id |

Indexy

Název | Primární | Výraz | Popis
ix_ADADSDRU_ad72id | P | ad72id | Druh adresáta
ix_ADADSDRU_ad72nazdru |  | ad72nazdru | Název druhu adresáta


ADADZAM Hlavička záměn adresátů

Popis

Hlavička záměn adresátů

Atributy

Atribut | Typ | Návěští | Message | Popis
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad01id1 | C(6) | Importovaný | Identifikace importovaného adresáta | Identifikace adresáta - pro import
ad64proved | N(1,0) | ad64proved |  |
ad64koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Záměny adresátů - pravidla záměny bankovního spojení - má hlavičku | ADADZAMU ad01id | 1,1 : 0,M s rušením | ADADZAM ad01id |
Záměny adresátů - pravidla záměny spojení - má hlavičku | ADADZAMS ad01id | 1,1 : 0,M s rušením | ADADZAM ad01id |

Indexy

Název | Primární | Výraz | Popis
ix_ADADZAM_adadzam | P | ad01id | PI - ad01id
ix_ADADZAM_ad01id |  | ad01id | Identifikace adresáta
ix_ADADZAM_ad01id1 |  | ad01id1 | Identifikace adresáta - pro import


ADADZAMS Záměny adresátů - pravidla záměny spojení

Popis

Záměny adresátů - pravidla záměny spojení

Atributy

Atribut | Typ | Návěští | Message | Popis
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
ad01id1 | C(6) | Importovaný | Identifikace importovaného adresáta | Identifikace adresáta - pro import
ad11cissp1 | C(2) | ad11cissp1 | Číslo spojení adresáta. | Číslo spojení adresáta.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Záměny adresátů - pravidla záměny spojení - má hlavičku | ADADZAMS ad01id | 1,1 : 0,M s rušením | ADADZAM ad01id |

Indexy

Název | Primární | Výraz | Popis
ix_ADADZAMS_adspoj5 | P | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_ADADZAMS_adspoj51 |  | ad01id1, ad11cissp1 | ad01id1+ad11cissp1
ix_ADADZAMS_adadzam |  | ad01id | PI - ad01id
ix_ADADZAMS_ad11cisspo |  | ad11cisspo | Číslo spojení adresáta. Program generuje automaticky.
ix_ADADZAMS_ad11cissp1 |  | ad11cissp1 | Číslo spojení adresáta.


ADADZAMU Záměny adresátů - pravidla záměny bankovního spojení

Popis

Záměny adresátů - pravidla záměny bankovního spojení

Atributy

Atribut | Typ | Návěští | Message | Popis
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad03cisban | C(2) | Účet | Identifikátor spojení na bankovní účet adresáta. | Číslo spojení na bankovní účet adresáta. *** Dříve CISBANK.
ad01id1 | C(6) | Importovaný | Identifikace importovaného adresáta | Identifikace adresáta - pro import
ad03cisba1 | C(2) | ad03cisba1 |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Záměny adresátů - pravidla záměny bankovního spojení - má hlavičku | ADADZAMU ad01id | 1,1 : 0,M s rušením | ADADZAM ad01id |

Indexy

Název | Primární | Výraz | Popis
ix_ADADZAMU_adbucty1 | P | ad01id, ad03cisban | ad01id+ad03cisban
ix_ADADZAMU_adadzam |  | ad01id | PI - ad01id
ix_ADADZAMU_adbucty11 |  | ad01id1, ad03cisba1 |


ADBUCTY Bankovní účty adresátů

Popis

Objektem typu ADBUCTY je každý záznam, který obsahuje údaje o konkrétním bankovním účtu daného adresáta (#ADADSAT), potřebné pro platební styk s adresátem.
Identifikace banky je nepovinná pokud je atribut ad03up nastaven na "Pokladna"
Obsahuje též identifikaci adresy, která má význam adresy banky v níž je bankovní spojení realizováno. Uvedení je nepovinné. Atribut je nepřístupný pokud hodnota atributu OCBANKA.ad01id je prázdná. Číselník adres je volán s parametrem OCBANKA.ad01id. Využití pro zahraniční platební styk.
*** Dříve BKONTA.

Atributy

Atribut | Typ | Návěští | Message | Popis
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad03cisban | C(2) | Účet | Identifikátor spojení na bankovní účet adresáta. | Číslo spojení na bankovní účet adresáta. *** Dříve CISBANK.
ad03ucet | C(34) | Č. účtu | Číslo bankovního účtu adresáta. | Číslo bankovního účtu adresáta. *** Dříve UCET.
ad03ssymb | C(10) | Specifický symbol | Specifický symbol adresáta | Specifický symbol adresáta
oc02idbank | C(4) | Kód banky | Kód banky | Kód banky
ad01id1 | C(6) | Importovaný | Identifikace importovaného adresáta | Identifikace adresáta - pro import
ad02cisadr | C(2) | Adresa | Číslo adresy adresáta. | Číslo adresy adresáta. Program generuje automaticky. *** Dříve CISADR. C,1 !!!
ad03poboc | C(25) | Pobočka | Název pobočky, která vede bankovní účet adresátovi. | Název pobočky, která vede bankovní účet adresátovi. *** Dříve POBOC.
ad03pructu | C(6) | Prefix ú. | Prefix bankovního účtu adresáta | Prefix bankovního účtu adresáta
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
ad03nauctu | C(20) | Název ú. | Název účtu | Název účtu
ad03koment | M | Komentář | Komentář k bankovnímu účtu adresáta. | Poznámka k bankovnímu účtu adresáta. *** Dříve POZNBKON.
ad03up | N(1,0) | Typ | Příznak účet, pokladna | Příznak účet/ pokladna
ad03zapor | N(1,0) | ad03zapor | Příznak možnosti debetu (u pokladen, nikoliv u účtů). | Příznak možnosti debetu. SMI změněn význam - předtím asi nic 1.8.2007
ad03iban | C(34) | IBAN | IBAN - mezinárodní bankovní číslo účtu | IBAN - mezinárodní bankovní číslo účtu
ad03aktual | N(1,0) | Aktuální | Aktuální bankovní spojení Ano/Ne | Aktuální bankovní spojení Ano/Ne

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Bankovní účty adresátů - vztahuje se k adresátovi | ADBUCTY ad01id | 1,1 : 0,M | ADADSAT ad01id |
Bankovní účty adresátů - patří bance | ADBUCTY oc02idbank | 1,1 : 0,M | OCBANKA oc02idbank |
Bankovní účty adresátů - je veden v měně | ADBUCTY oc01id | 1,1 : 0,M | OCMENA oc01id |
Bankovní účty adresátů - má adresáta jako banku | ADBUCTY ad01id1 | 1,1 : 0,M s rušením | ADADSAT ad01id |
Položka smlouvy - bude vyhodnocena pro bankovní spojení | NKSMLOUV ad01id ad03cisban | 0,1 : 0,M | ADBUCTY ad01id ad03cisban |
Hodnota parametru - definuje bankovní účet | PAHODNOT ad01id ad03cisban | 0,1 : 0,M | ADBUCTY ad01id ad03cisban |
Další měna bankovního účtu - jsou měnami bankovního účtu adresáta | ADBUCTYM ad01id ad03cisban | 1,1 : 0,M | ADBUCTY ad01id ad03cisban |
Událost plateb - má bankovní spojení aktéra (odesilatele/příjemce) | PLUDA ad01id ad03cisban | 0,1 : 0,M | ADBUCTY ad01id ad03cisban |
Účet/pokladna (vlastní) - jsou spojeny s bankovním spojením | PLUP ad01id ad03cisban | 1,1 : 0,M | ADBUCTY ad01id ad03cisban |
Parametry - mají účet adresáta - sociální pojištění | MZPARAM mz27socad mz27socban | 1,1 : 0,M | ADBUCTY ad01id ad03cisban |
Parametry - mají účet adresáta - zálohová daň | MZPARAM mz27zalda mz27zalban | 1,1 : 0,M | ADBUCTY ad01id ad03cisban |
Parametry - mají účet adresáta - srážková daň | MZPARAM mz27srda mz27srban | 1,1 : 0,M | ADBUCTY ad01id ad03cisban |
Parametry - mají účet adresáta - daňový bonus | MZPARAM mz27bonad mz27bonban | 1,1 : 0,M | ADBUCTY ad01id ad03cisban |
Parametry - mají účet adresáta - zákonné pojištění odpovědnosti | MZPARAM mz27zakad mz27zakban | 1,1 : 0,M | ADBUCTY ad01id ad03cisban |
Událost změny stavu peněz - výpisy a příkazy - má bankovní spojení adresáta | ZPUDA ad01id ad03cisban | 0,1 : 0,M | ADBUCTY ad01id ad03cisban |
Mzda - mají bankovní účet | MZMZDY ad01id ad03cisban | 1,1 : 0,M | ADBUCTY ad01id ad03cisban |
Položky nezdanit. nebo srážky - mají bankovní účet | MZNEZDPO ad01id ad03cisban | 1,1 : 0,M | ADBUCTY ad01id ad03cisban |
Událostní entita mezd - má bankovní spojení | MZUDALOS ad01id ad03cisban | 0,1 : 0,M | ADBUCTY ad01id ad03cisban |
Seznam zdravotních pojišťoven - má účty | MZPOJSEZ ad01id ad03cisban | 1,1 : 0,M | ADBUCTY ad01id ad03cisban |

Indexy

Název | Primární | Výraz | Popis
ix_ADBUCTY_adbucty1 | P | ad01id, ad03cisban | ad01id+ad03cisban
ix_ADBUCTY_adbucty2 |  | ad03ucet, ad03ssymb | Prefix účtu + účet
ix_ADBUCTY_ad01id |  | ad01id | Identifikace adresáta
ix_ADBUCTY_oc02idbank |  | oc02idbank | Kód banky
ix_ADBUCTY_ad01id1 |  | ad01id1 | Identifikace adresáta - pro import
ix_ADBUCTY_ad03poboc |  | ad03poboc | Název pobočky, která vede bankovní účet adresátovi.
ix_ADBUCTY_ad03ucet |  | ad03ucet | Číslo bankovního účtu adresáta.
ix_ADBUCTY_oc01id |  | oc01id | Kód měny - oceňovací jednotky.
ix_ADBUCTY_ad03nauctu |  | ad03nauctu | Název účtu
ix_ADBUCTY_adbucty3 |  | ad01id1, ad02cisadr | adresat (banka) + adresa
ix_ADBUCTY_adbucty4 |  | oc02idbank, ad03pructu, ad03ucet, ad03ssymb | Index : oc02idbank+ad03pructu+ad03ucet
ix_ADBUCTY_adadsatx |  |  |


ADBUCTYM Další měna bankovního účtu

Popis

Další měny bankovního účtu

Atributy

Atribut | Typ | Návěští | Message | Popis
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad03cisban | C(2) | Účet | Identifikátor spojení na bankovní účet adresáta. | Číslo spojení na bankovní účet adresáta. *** Dříve CISBANK.
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Další měna bankovního účtu - jsou měnami bankovního účtu adresáta | ADBUCTYM ad01id ad03cisban | 1,1 : 0,M | ADBUCTY ad01id ad03cisban |
Další měna bankovního účtu - určuje měny | ADBUCTYM oc01id | 1,1 : 0,M | OCMENA oc01id |

Indexy

Název | Primární | Výraz | Popis
ix_ADBUCTYM_adbuctym | P | ad01id, ad03cisban, oc01id | PI - ADBUCTY1+oc01id
ix_ADBUCTYM_adbucty1 |  | ad01id, ad03cisban | ad01id+ad03cisban
ix_ADBUCTYM_oc01id |  | oc01id | Kód měny - oceňovací jednotky.


ADCNVPOS Konverze pro štítek v události pošty

Popis

Konverze pro štítek v události pošty

Atributy

Atribut | Typ | Návěští | Message | Popis
ad75id | C(6) | Konverze | Konverze pro štítek události pošty | Konverze pro štítek události pošty
ad75nazcnv | C(40) | Název konverze | Název konverze pro štítek události pošty | Název konverze pro štítek události pošty
ad75cnvr1 | M | Výraz R1 | Výraz konverze 1.řádku štítku | Výraz konverze 1.řádku štítku
ad75cnvr2 | M | Výraz R2 | Výraz konverze 2.řádku štítku | Výraz konverze 2.řádku štítku
ad75cnvr3 | M | Výraz R3 | Výraz konverze 3.řádku štítku | Výraz konverze 3.řádku štítku
ad75koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Adresa - je konvertována na štítek podle definice | ADADR ad75id | 1,1 : 0,M | ADCNVPOS ad75id |

Indexy

Název | Primární | Výraz | Popis
ix_ADCNVPOS_ad75id | P | ad75id | Konverze pro štítek události pošty
ix_ADCNVPOS_ad75nazcnv |  | ad75nazcnv | Název konverze pro štítek události pošty


ADINTER Interval čísel adresátů

Popis

Objektem typu ADINTER je každý záznam, který obsahuje

Atributy

Atribut | Typ | Návěští | Message | Popis
ad17cpm | C(2) | Identifikace datového úložiště | Číslo pracovního místa |
ad17intod | C(6) | Interval od | Interval od |
ad17intdo | C(6) | Interval do | Intervel do |

Indexy

Název | Primární | Výraz | Popis
ix_ADINTER_ad17cpm | P | ad17cpm |


ADKAT Kategorie adresáta

Popis

Objektem typu ADKAT je každý záznam, který obsahuje definice vlastnosti, která vymezuje určitou množinu adresátů. Kategorie souvisí s předmětem podnikání uživatele systému a uživatel si jejich členění navrhne podle svých potřeb. Kategorie musí mít atribut Popis, který volným textem vysvětluje význam dané kategorie.

Př: dealer, neplatič, uživatel ZEMANa, zaměstnanec atd.

*** Dříve DUKLIC.

Atributy

Atribut | Typ | Návěští | Message | Popis
ad08id | C(6) | Kategorie | Identifikace kategorie adresáta. | Identifikace kategorie. *** Dříve KLICID.
ad08kateg | C(40) | Název kategorie | Text vystihující charakter kategorie | Název kategorie. *** Dříve KLICTEXT.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
ad08koment | M | Komentář | Komentář ke kategorii | Komentář ke kategorii
ad08typ | N(1,0) | Typ | Typ kategorie - Vstupovaná / Vypočítaná | Typ kategorie - Vstupovaná / Vypočítaná
ad08sql | M | SQL | Výraz v SQL vyhodnocovaný dotazem vracející numerickou hodnotu (0=není v kategoriii) použivá ID adresáta @ad01id,@ad11cisspo,@datum | Výraz v SQL vyhodnocovaný dotazem vracející numerickou hodnotu (0=není v kategoriii) použivá ID adresáta @ad01id,@ad11cisspo,@datum
ad08uplat | N(1,0) | Uplatnění | Uplatnění kategorie - Kategorie adresáta / Kategorie spojení adresáta | Uplatnění kategorie - Kategorie adresáta / Kategorie spojení adresáta

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Kategorie adresáta - zapsána uživatelem | ADKAT bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Barva kategorie adresáta v paletě barev - je určena pro kategorii | ADPALKAT ad08id | 1,1 : 0,M | ADKAT ad08id |
Určení typu subjektu spojení adresáta pro druh operace - má uvedenou kategorii spojení | SPTYPSUB ad08id | 0,1 : 0,M | ADKAT ad08id |
Zařazení (spojení) adresáta do kategorie - do dané kategorie | ADKATADS ad08id | 1,1 : 0,M s rušením | ADKAT ad08id |
Barvy kategorií - patří kategorii | ADKATBAR ad08id | 1,1 : 0,M | ADKAT ad08id |

Indexy

Název | Primární | Výraz | Popis
ix_ADKAT_ad08id | P | ad08id | Identifikace kategorie.
ix_ADKAT_ad08kateg |  | ad08kateg | Název kategorie.
ix_ADKAT_bw01uziv |  | bw01uziv | Identifikace uživatele systému


ADKATADS Zařazení (spojení) adresáta do kategorie

Popis

Objektem typu ADKATADS je každý záznam, který obsahuje složitější vazbu mezi adresáty (spojení adresátů) a jejich kategoriemi v závislosti na čase. Přesně vyjadřuje následující funkční závislost: Adresáti (#ADADSAT), kteří od daného data - do daného data patří díky svým aktuálním vlastnostem do dané kategorie (#ADKAT) /0,M:0,M

Atributy

Atribut | Typ | Návěští | Message | Popis
ad07 | C(12) | ad07 | Jednoznačná časová identifikace zařazení do kategorie | Jednoznačná časová identifikace zařazení do kategorie
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
ad08id | C(6) | Kategorie | Identifikace kategorie adresáta. | Identifikace kategorie. *** Dříve KLICID.
ad07datod | D | Zařazení | Datum zařazení adresáta do kategorie. | Datum zařazení adresáta do kategorie.
ad07datdo | D | Vyřazení | Datum vyřazení adresáta z kategorie. | Datum vyřazení adresáta z kategorie.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Zařazení (spojení) adresáta do kategorie - ve které je zařazeno spojení adresáta | ADKATADS ad01id ad11cisspo | 0,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Zařazení (spojení) adresáta do kategorie - ve které je zařazen adresát | ADKATADS ad01id | 1,1 : 0,M s rušením | ADADSAT ad01id |
Zařazení (spojení) adresáta do kategorie - do dané kategorie | ADKATADS ad08id | 1,1 : 0,M s rušením | ADKAT ad08id |

Indexy

Název | Primární | Výraz | Popis
ix_ADKATADS_ad07 | P | ad07 | Jednoznačná časová identifikace zařazení do kategorie
ix_ADKATADS_ad01id |  | ad01id | Identifikace adresáta
ix_ADKATADS_ad08id |  | ad08id | Identifikace kategorie.
ix_ADKATADS_ad07datod |  | ad07datod | Datum zařazení adresáta do kategorie.
ix_ADKATADS_ad07datdo |  | ad07datdo | Datum vyřazení adresáta z kategorie.
ix_ADKATADS_adkatads2 |  | ad08id, ad01id | Kategorie + adresát Pro zobrazení v okně Kategorie - 2
ix_ADKATADS_adkatads3 |  | ad01id, ad08id | ad01id+ad08id
ix_ADKATADS_adadsatx |  |  |
ix_ADKATADS_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo


ADKATBAR Barvy kategorií

Atributy

Atribut | Typ | Návěští | Message | Popis
ad08id | C(6) | Kategorie | Identifikace kategorie adresáta. | Identifikace kategorie. *** Dříve KLICID.
bw05ident | C(6) | Skupina | Identifikace skupiny uživatelů | Identifikace skupiny uživatelů
ad08barva | N(1,0) | ad08barva |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Barvy kategorií - patří kategorii | ADKATBAR ad08id | 1,1 : 0,M | ADKAT ad08id |

Indexy

Název | Primární | Výraz | Popis
ix_ADKATBAR_adkatbar2 | P | ad08id, bw05ident |
ix_ADKATBAR_ad08id |  | ad08id | Identifikace kategorie.
ix_ADKATBAR_bw05ident |  | bw05ident | Identifikace skupiny uživatelů


ADKRAJE Kraj

Popis

Kraj

Atributy

Atribut | Typ | Návěští | Message | Popis
ad68id | C(6) | Kraj | Identifikace kraje | Identifikace kraje
ad68nazkra | C(40) | Název kraje | Název kraje | Název kraje
ad68extid | C(6) | Jiná identifikace | Jiná identifikace kraje | Jiná identifikace kraje
ad68koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Okres adresy adresáta - patří do kraje | ADOKRESY ad68id | 1,1 : 0,M | ADKRAJE ad68id |

Indexy

Název | Primární | Výraz | Popis
ix_ADKRAJE_ad68id | P | ad68id | Identifikace kraje
ix_ADKRAJE_ad68nazkra |  | ad68nazkra | Název kraje


ADMESTA Město

Popis

Objektem typu ADMESTA je každý záznam, který obsahuje identifikační údaje o městu, v němž sídlí některý z evidovaných adresátů.
Současně obsahuje i národní směrové číslo státu pro telefonní spojení (UTO).

Atributy

Atribut | Typ | Návěští | Message | Popis
ad13 | C(12) | ad13 | Jednoznačná identifikace města. | Jednoznačná identifikace města.
ad13psc | C(10) | PSČ | Poštovní směrovací číslo adresy adresáta. | Poštovní směrovací číslo adresy adresáta. *** Dříve PSC.
ad13mesto | C(40) | Město | Město adresy adresáta. | Město adresy adresáta. *** Dříve MESTO.
ad13nsc | C(4) | UTO | Národní směrové číslo státu pro telefonní spojení (UTO). | Národní směrové číslo státu pro telefonní spojení (UTO).
ad05id | C(3) | Stát | Identifikace státu. | Identifikace státu. *** Dříve ZIP.
ad67id | C(6) | Okres | Identifikace okresu | Identifikace okresu
ad13posobc | N(1,0) | Postavení obce | Postavení obce | Postavení obce
ad13cisobc | C(6) | Číslo obce | Číslo obce | Číslo obce

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Město - je ve státě | ADMESTA ad05id | 1,1 : 0,M | ADSTATY ad05id |
Město - je v okrese | ADMESTA ad67id | 1,1 : 0,M | ADOKRESY ad67id |

Indexy

Název | Primární | Výraz | Popis
ix_ADMESTA_ad13 | P | ad13 | Jednoznačná identifikace města.
ix_ADMESTA_ad13psc |  | ad13psc | Poštovní směrovací číslo adresy adresáta.
ix_ADMESTA_ad13mesto |  | ad13mesto | Město adresy adresáta.
ix_ADMESTA_ad13nsc |  | ad13nsc | Národní směrové číslo státu pro telefonní spojení (UTO).
ix_ADMESTA_ad05id |  | ad05id | Identifikace státu.
ix_ADMESTA_ad67id |  | ad67id | Identifikace okresu


ADOKRESY Okres adresy adresáta

Popis

Okres adresy adresáta

Atributy

Atribut | Typ | Návěští | Message | Popis
ad67id | C(6) | Okres | Identifikace okresu | Identifikace okresu
ad67nazokr | C(40) | Název okresu | Název okresu | Název okresu
ad67extid | C(6) | Jiná identifikace | Jiná identifikace okresu | Jiná identifikace okresu
ad68id | C(6) | Kraj | Identifikace kraje | Identifikace kraje
ad67koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Okres adresy adresáta - patří do kraje | ADOKRESY ad68id | 1,1 : 0,M | ADKRAJE ad68id |
Adresa - patří do okresu | ADADR ad67id | 1,1 : 0,M | ADOKRESY ad67id |
Město - je v okrese | ADMESTA ad67id | 1,1 : 0,M | ADOKRESY ad67id |

Indexy

Název | Primární | Výraz | Popis
ix_ADOKRESY_ad67id | P | ad67id | Identifikace okresu
ix_ADOKRESY_ad67nazokr |  | ad67nazokr | Název okresu
ix_ADOKRESY_ad68id |  | ad68id | Identifikace kraje


ADOSLOV Oslovení

Atributy

Atribut | Typ | Návěští | Message | Popis
ad57id | C(6) | Identifikace | Identifikace oslovení |
ad57oslov | C(40) | Oslovení | Text oslovení |
ad57koment | M | Komentář | Komentář |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Poštovní zásilka - má oslovení | POPOSTA ad57id | 1,1 : 0,M | ADOSLOV ad57id |
Spojení adresáta - má oslovení | ADSPOJ ad57id | 1,1 : 0,M | ADOSLOV ad57id |

Indexy

Název | Primární | Výraz | Popis
ix_ADOSLOV_ad57id | P | ad57id |
ix_ADOSLOV_ad57oslov |  | ad57oslov |


ADOZNAC Označený záznam o adresátovi

Popis

Pomocný soubor pro zobrazování označených adresátů

Atributy

Atribut | Typ | Návěští | Message | Popis
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
ad51 | C(10) | ad51 | Identifikace označovacího formuláře | Identifikace označovacího formuláře
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Označený záznam o adresátovi - patří uživateli | ADOZNAC bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Označený záznam o adresátovi - označuje adresáta | ADOZNAC ad01id | 1,1 : 0,M s rušením | ADADSAT ad01id |

Indexy

Název | Primární | Výraz | Popis
ix_ADOZNAC_adoznac | P | bw01uziv, ad51, ad01id |
ix_ADOZNAC_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_ADOZNAC_ad51 |  | ad51 | Identifikace označovacího formuláře
ix_ADOZNAC_ad01id |  | ad01id | Identifikace adresáta


ADPALETA Paleta barev kategorií adresáta

Popis

Paleta barev kategorií adresáta

Atributy

Atribut | Typ | Návěští | Message | Popis
ad73id | C(6) | Paleta | Identifikace palety barev | Identifikace palety barev
ad73nazpal | C(40) | Název palety | Název palety barev | Název palety barev
ad73koment | M | Poznámka | Poznámka | Poznámka
bw05ident | C(6) | Skupina | Identifikace skupiny uživatelů | Identifikace skupiny uživatelů

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Paleta barev kategorií adresáta - je používána skupinou uživatelů | ADPALETA bw05ident | 1,1 : 0,M | BWUZIVAT bw01uziv |
Barva kategorie adresáta v paletě barev - je v paletě barev | ADPALKAT ad73id | 1,1 : 0,M | ADPALETA ad73id |

Indexy

Název | Primární | Výraz | Popis
ix_ADPALETA_ad73id | P | ad73id | Identifikace palety barev
ix_ADPALETA_ad73nazpal |  | ad73nazpal | Název palety barev
ix_ADPALETA_bw05ident |  | bw05ident | Identifikace skupiny uživatelů


ADPALKAT Barva kategorie adresáta v paletě barev

Popis

Barva kategorie adresáta v paletě barev

Atributy

Atribut | Typ | Návěští | Message | Popis
ad73id | C(6) | Paleta | Identifikace palety barev | Identifikace palety barev
ad08id | C(6) | Kategorie | Identifikace kategorie adresáta. | Identifikace kategorie. *** Dříve KLICID.
bw95id | C(6) | Barva | Identifikace barvy RGB | Identifikace barvy RGB
bw95id2 | C(6) | Barva | Identifikace barvy RGB | Identifikace barvy RGB
ad74prior | N(3,0) | Priorita | Priorita barvy | Priorita barvy

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Barva kategorie adresáta v paletě barev - je určena pro kategorii | ADPALKAT ad08id | 1,1 : 0,M | ADKAT ad08id |
Barva kategorie adresáta v paletě barev - je v paletě barev | ADPALKAT ad73id | 1,1 : 0,M | ADPALETA ad73id |
Barva kategorie adresáta v paletě barev - definuje barvu RGB - popředí | ADPALKAT bw95id | 1,1 : 0,M | BWRGBCOL bw95id |
Barva kategorie adresáta v paletě barev - definuje barvu RGB - pozadí | ADPALKAT bw95id2 | 1,1 : 0,M | BWRGBCOL bw95id |

Indexy

Název | Primární | Výraz | Popis
ix_ADPALKAT_adpalkat | P | ad73id, ad08id | PI - ad73id+ad08id
ix_ADPALKAT_ad73id |  | ad73id | Identifikace palety barev
ix_ADPALKAT_ad08id |  | ad08id | Identifikace kategorie.
ix_ADPALKAT_bw95id |  | bw95id | Identifikace barvy RGB
ix_ADPALKAT_bw95id2 |  | bw95id2 | Identifikace barvy RGB


ADSPOJ Spojení adresáta

Popis

Objektem typu ADSPOJ je každý záznam, který obsahuje seznam všech spojení (telefonních, faxových, e-mailových) adresáta. Jednotlivá spojení mohou být spojena s konkrétní adresou adresáta. V takovém případě se pro telefonní a faxové spojení automaticky předplňuje rozlišovací číslo, směrové číslo země a národní směrové číslo.

Atributy

Atribut | Typ | Návěští | Message | Popis
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad02cisadr | C(2) | Adresa | Číslo adresy adresáta. | Číslo adresy adresáta. Program generuje automaticky. *** Dříve CISADR. C,1 !!!
ad11jmeno | C(40) | Jméno | Jméno kontaktní osoby. | Jméno kontaktní osoby. !!! Širku udělat stejnou, jako máme u uživatelů!!!
ad12id | C(6) | Typ | Identifikace typu spojení | Identifikace typu spojení.
ad11cisspo | C(2) | Spojení | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
ad58id | C(6) | Typ | Identifikátor typu subjektu pro spojení adresáta | Identifikátor typu subjektu pro spojení adresáta
ad13nsc | C(4) | UTO | Národní směrové číslo státu pro telefonní spojení (UTO). | Národní směrové číslo státu pro telefonní spojení (UTO).
ad11cislo | C(60) | Telefon | Telefonní číslo | Volané číslo, nebo e-mailová adresa. Musí být uvedeno.
ad57id | C(6) | ad57id |  |
ad11jmenop | C(100) | ad11jmenop |  |
ad11funkce | C(40) | Funkce | Funkce kontaktní osoby |
ad11pozn | M | Komentář | Komentář ke spojení | Poznámka ke spojení.
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
ad01id2 | C(6) | Adresát | Adresát subjektu spojení adresáta | Adresát subjektu spojení adresáta
ad11fax | C(60) | Fax | Faxové číslo | Fax spojení adresáta
ad11cisost | C(60) | Jiné | Jiné spojení adresáta | Jiné spojení adresáta
ad11mobil | C(60) | Mobil | Číslo mobilního telefonu | Mobil spojení adresáta
ad11email | C(60) | e-mail | E-mail spojení adresáta | E-mail spojení adresáta
ad11adsat | C(100) | Alias | Název adresáta pro zobrazení v událostech | Název adresáta pro zobrazení v událostech

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Spojení adresáta - patří adresátovi | ADSPOJ ad01id | 1,1 : 0,M s rušením | ADADSAT ad01id |
Spojení adresáta - má obchodní selektor | ADSPOJ sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Spojení adresáta - má oslovení | ADSPOJ ad57id | 1,1 : 0,M | ADOSLOV ad57id |
Spojení adresáta - je určeno pro typ subjektu | ADSPOJ ad58id | 1,1 : 0,M | ADTYPSUB ad58id |
Spojení adresáta - má definovaného připojeného adresáta | ADSPOJ ad01id2 | 1,1 : 0,M | ADADSAT ad01id |
Spojení adresáta - má adresu !! RI !! | ADSPOJ ad01id ad02cisadr | 1,1 : 0,M | ADADR ad01id ad02cisadr |
Hodnota parametru předmětu projektu - se vztahuje ke spojení adresáta | NKHODNP ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Položka smlouvy - je vztažena ke spojení adresáta | NKSMLOUV ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost o záloze - má spojení adresáta | ZAUDAL ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost skladu zvířat - má spojení na adresáta | SZUDAL ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Umístění kategorie zvířat - má spojení na adresáta | SZUMIST ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Parametr subjektu připojeného pomocí spojení - patří ke spojení | ADSPOPAR ad01id ad11cisspo | 1,1 : 0,M s rušením | ADSPOJ ad01id ad11cisspo |
Popis sloučení spojení adresáta - popisuje spojení, které zůstane | ADSPOSLU ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Hodnota parametru - definuje spojení | PAHODNOT ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Vztah obchodovatelného artiklu a adresáta - může mít uvedeno spojení adresáta | OBARTADR ad01id ad11cisspo | 0,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost správy artiklu - určuje spojení na adresáta | SAUDAL ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Pracovník v kategorii - patří k spojení adresáta | MZKARADA ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Zařazení (spojení) adresáta do kategorie - ve které je zařazeno spojení adresáta | ADKATADS ad01id ad11cisspo | 0,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost vývěsky - souvisí se spojením adresáta | VYUDALOS ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Poštovní zásilka - má spojení | POPOSTA ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost obchodního plnění - má spojení na adresáta odběratele | OBUDAL ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost obchodního plnění - má spojení na adresáta příjemce | OBUDAL ad01id1 ad11cissp1 | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost DPH - Má adresu adresáta | DPUDA ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost plateb - má adresu aktéra (odesilatele/příjemce) | PLUDA ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Parametry - mají adresu adresáta - sociální pojištění | MZPARAM mz27socad mz27socspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Parametry - mají adresu adresáta - zálohová daň | MZPARAM mz27zalda mz27zalspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Parametry - mají adresu adresáta - srážková daň | MZPARAM mz27srda mz27srspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Parametry - mají adresu adresáta - daňový bonus | MZPARAM mz27bonad mz27bonspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Parametry - mají adresu adresáta - zákonné pojištění odpovědnosti | MZPARAM mz27zakad mz27zakspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost skladu - má spojení adresáta | MTUDA ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Umístění - distribuční kanál - má spojení na adresáta | OBUMIST ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Sklad - je na adrese podle spojení | MTSKL ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost změny stavu peněz - výpisy a příkazy - má spojení adresáta | ZPUDA ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost vymáhání - má adresu aktéra (odesilatele/příjemce) | VMUDA ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
AAA v cenové skupině - se týká spojení adresáta | OBCENSAK ad01id ad11cisspo | 0,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Výrobní zakázka - je zakázkou apojení adresáta | VRVYR ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Řidič - expedice - má adresátové spojení | EXRIDIC ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Operace spojená s událostí expedice - má spojení na adresu | EXUDAOPE ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Umístění DPH - má spojení na adresáta | DPUMIST ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Umístění plateb - má spojení na adresáta | PLUMIST ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |

Indexy

Název | Primární | Výraz | Popis
ix_ADSPOJ_adspoj1 |  | ad01id, ad02cisadr | Adresát + číslo adresy Pro relaci
ix_ADSPOJ_adspoj2 |  | ad01id, ad11jmeno, ad12id | Adresát + jméno + typ spojení Pro zobrazení
ix_ADSPOJ_adspoj3 |  | ad01id, ad02cisadr, ad11jmeno, ad12id | Adresát + adresa + jméno + typ spojení Pro zobrazení v okně adresy
ix_ADSPOJ_adspoj4 |  | ad01id, ad02cisadr, ad11cisspo | ad01id+ad02cisadr+ad11cisspo
ix_ADSPOJ_adspoj5 | P | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_ADSPOJ_ad01id |  | ad01id | Identifikace adresáta
ix_ADSPOJ_ad11cisspo |  | ad11cisspo | Číslo spojení adresáta. Program generuje automaticky.
ix_ADSPOJ_ad02cisadr |  | ad02cisadr | Číslo adresy adresáta. Program generuje automaticky.
ix_ADSPOJ_ad58id |  | ad58id | Identifikátor typu subjektu pro spojení adresáta
ix_ADSPOJ_ad12id |  | ad12id | Identifikace typu spojení.
ix_ADSPOJ_ad13nsc |  | ad13nsc | Národní směrové číslo státu pro telefonní spojení (UTO).
ix_ADSPOJ_ad11jmeno |  | ad11jmeno | Jméno kontaktní osoby. !!! Širku udělat stejnou, jako máme u uživatelů!!!
ix_ADSPOJ_ad57id |  | ad57id |
ix_ADSPOJ_ad11funkce |  | ad11funkce |
ix_ADSPOJ_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_ADSPOJ_adadsatx |  |  |
ix_ADSPOJ_adadru |  |  |
ix_ADSPOJ_adadrm |  |  |
ix_ADSPOJ_ad01id2 |  | ad01id2 | Adresát subjektu spojení adresáta
ix_ADSPOJ_ad11fax |  | ad11fax | Fax spojení adresáta
ix_ADSPOJ_ad11cisost |  | ad11cisost | Jiné spojení adresáta
ix_ADSPOJ_ad11mobil |  | ad11mobil | Mobil spojení adresáta
ix_ADSPOJ_ad11email |  | ad11email | E-mail spojení adresáta


ADSPOJP Spojení s kompletní informací o adrese, adresátovi a bankovním spojení

Popis

Spojení s kompletní informací o adrese, adresátovi a bankovním spojení

Atributy

Atribut | Typ | Návěští | Message | Popis
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
ad58id | C(6) | Typ | Identifikátor typu subjektu pro spojení adresáta | Identifikátor typu subjektu pro spojení adresáta
ad02cisadr | C(2) | Adresa | Číslo adresy adresáta. | Číslo adresy adresáta. Program generuje automaticky. *** Dříve CISADR. C,1 !!!
ad11cislo | C(60) | ad11cislo | Volané číslo, nebo e-mailová adresa. Musí být uvedeno. | Volané číslo, nebo e-mailová adresa. Musí být uvedeno.
ad11jmeno | C(40) | ad11jmeno | Jméno kontaktní osoby. !!! Širku udělat stejnou, jako máme u uživatelů!!! | Jméno kontaktní osoby. !!! Širku udělat stejnou, jako máme u uživatelů!!!
ad11jmenop | C(100) | ad11jmenop |  |
ad11funkce | C(40) | ad11funkce |  |
ad11pozn | M | ad11pozn | Poznámka ke spojení. | Poznámka ke spojení.
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
ad11fax | C(60) | Fax | Faxové číslo | Fax spojení adresáta
ad11cisost | C(60) | Jiné | Jiné spojení adresáta | Jiné spojení adresáta
ad11mobil | C(60) | Mobil | Číslo mobilního telefonu | Mobil spojení adresáta
ad11email | C(60) | e-mail | E-mail spojení adresáta | E-mail spojení adresáta
ad11adsat | C(100) | Alias | Název adresáta pro zobrazení v událostech | Název adresáta pro zobrazení v událostech
ad01id2 | C(6) | Adresát | Adresát subjektu spojení adresáta | Adresát subjektu spojení adresáta
ad05scz | C(4) | SČZ | Směrové číslo státu pro telefonní spojení. | Směrové číslo státu pro telefonní spojení.
ad13nsc | C(4) | UTO | Národní směrové číslo státu pro telefonní spojení (UTO). | Národní směrové číslo státu pro telefonní spojení (UTO).
ad02ulice | C(40) | Ulice | Ulice adresy adresáta (včetně čísla popisného). | Ulice adresy adresáta (včetně čísla popisného). *** Dříve ULICE.
ad02byt | C(40) | ad02byt |  |
ad13psc | C(10) | PSČ | Poštovní směrovací číslo adresy adresáta. | Poštovní směrovací číslo adresy adresáta. *** Dříve PSC.
ad02mesto | C(40) | ad02mesto | Město adresy adresáta. | Město adresy adresáta.
dp04tuzzah | N(1,0) | dp04tuzzah | Typ místa tuzemsko, zahraničí, Evropská Unie .... | Tuzemsko/Zahraničí
ad02pozn | M | Komentář | Kometář k adrese adresáta. | Poznámka k adrese adresáta. *** Dříve POZNADR.
dp05id | C(3) | Typ místa | Identifikace typu místa zdanitelného plnění | Identifikace typu místa zdanitelného plnění
ad05stat | C(30) | Název státu | Název státu. | Název státu. *** Dříve STAT.

Indexy

Název | Primární | Výraz | Popis
ix_ADSPOJP_adspoj5 | P | ad01id, ad11cisspo | ad01id+ad11cisspo


ADSPOPAR Parametr subjektu připojeného pomocí spojení

Popis

Parametr subjektu připojeného pomocí spojení

Atributy

Atribut | Typ | Návěští | Message | Popis
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
ad59id | C(6) | Druh | Identifikace druhu parametru | Identifikace druhu parametru
ad61porad | N(3,0) | Pořadí | Pořadí parametru v rámci jednoho druhu | Pořadí parametru v rámci jednoho druhu
ad02cisadr | C(2) | Adresa | Číslo adresy adresáta. | Číslo adresy adresáta. Program generuje automaticky. *** Dříve CISADR. C,1 !!!
ad61datod | D | Platnost | Datum platnosti parametru od | Datum platnosti parametru od
ad61datdo | D | do | Datum platnosti parametru do | Datum platnosti parametru do
ad61txt1 | C(60) | Text1 | Textová elementární hodnota parametru 1 | Textová elementární hodnota parametru 1
ad61txt2 | C(60) | Text2 | Textová elementární hodnota parametru 2 | Textová elementární hodnota parametru 1
ad61dat1 | D | Datum1 | Datumová elementární hodnota parametru 1 | Datumová elementární hodnota parametru 1
ad61dat2 | D | Datum2 | Datumová elementární hodnota parametru 2 | Datumová elementární hodnota parametru 2
ad61num1 | N(20,4) | Num1 | Numerická elementární hodnota parametru 1 | Numerická elementární hodnota parametru 1
ad61num2 | N(20,4) | Num2 | Numerická elementární hodnota parametru 2 | Numerická elementární hodnota parametru 2
ad61koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametr subjektu připojeného pomocí spojení - patří ke spojení | ADSPOPAR ad01id ad11cisspo | 1,1 : 0,M s rušením | ADSPOJ ad01id ad11cisspo |
Parametr subjektu připojeného pomocí spojení - má připojený parametr druhu | ADSPOPAR ad59id | 1,1 : 0,M | ADSPOPRD ad59id |
Parametr subjektu připojeného pomocí spojení - definuje adresu | ADSPOPAR ad01id ad02cisadr | 0,1 : 0,M | ADADR ad01id ad02cisadr |

Indexy

Název | Primární | Výraz | Popis
ix_ADSPOPAR_adspopar | P | ad01id, ad11cisspo, ad59id, ad61porad | PI - ADSPOJ5+ad59id+ad61porad
ix_ADSPOPAR_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_ADSPOPAR_adadr1 |  | ad01id, ad02cisadr | Adresát + číslo adresy Pro zobrazení
ix_ADSPOPAR_ad59id |  | ad59id | Identifikace druhu parametru
ix_ADSPOPAR_ad61datod |  | ad61datod | Datum platnosti parametru od
ix_ADSPOPAR_ad61datdo |  | ad61datdo | Datum platnosti parametru do
ix_ADSPOPAR_ad61txt1 |  | ad61txt1 | Textová elementární hodnota parametru 1
ix_ADSPOPAR_ad61txt2 |  | ad61txt2 | Textová elementární hodnota parametru 1


ADSPOPRA Popis elementátní hodnoty druhu parametru

Popis

Popis elementátní hodnoty druhu parametru

Atributy

Atribut | Typ | Návěští | Message | Popis
ad59id | C(6) | Druh | Identifikace druhu parametru | Identifikace druhu parametru
ad60id | C(10) | Hodnota | Identifikace atributu elementární hodnoty | Identifikace atributu elementární hodnoty
ad60len | N(2,0) | Délka | Délka elementární hodnoty | Délka elementární hodnoty
ad60dec | N(1,0) | Desetiny | Počet desetin | Počet desetin
ad60label | M | Návěští | Návěští | Návěští
ad60status | M | Stavový řádek | Stavový řádek | Stavový řádek
ad60valid | M | Validace | Validace | Validace
ad60equal | C(10) | Odpovídá | Odpovídá atributu spojení | Odpovídá atributu spojení

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis elementátní hodnoty druhu parametru - je popisem k druhu parametru | ADSPOPRA ad59id | 1,1 : 0,M s rušením | ADSPOPRD ad59id |

Indexy

Název | Primární | Výraz | Popis
ix_ADSPOPRA_adspopra | P | ad59id, ad60id | PI - ad59id+ad60id
ix_ADSPOPRA_ad59id |  | ad59id | Identifikace druhu parametru


ADSPOPRD Druh parametru subjektu spojení

Popis

Druh parametru subjektu spojení

Atributy

Atribut | Typ | Návěští | Message | Popis
ad59id | C(6) | Druh | Identifikace druhu parametru | Identifikace druhu parametru
ad59nazdru | C(40) | Název druhu | Název druhu parametru | Název druhu parametru
ad59ikona | M | Ikona | Ikona parametru daného druhu ve stromu | Ikona parametru daného druhu ve stromu
ad59format | M | Formát | Formát zobrazení v gridu a ve stromu | Formát zobrazení v gridu a ve stromu
ad59uniadr | N(1,0) | Unikátní pro adresáta | Unikátní pro adresáta | Unikátní pro adresáta
ad59unispo | N(1,0) | Unikátní pro spojení | Unikátní pro spojení | Unikátní pro spojení
ad59koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis elementátní hodnoty druhu parametru - je popisem k druhu parametru | ADSPOPRA ad59id | 1,1 : 0,M s rušením | ADSPOPRD ad59id |
Druh parametru pro typ subjektu - určuje druh parametru | ADTYPSPR ad59id | 1,1 : 0,M | ADSPOPRD ad59id |
Parametr subjektu připojeného pomocí spojení - má připojený parametr druhu | ADSPOPAR ad59id | 1,1 : 0,M | ADSPOPRD ad59id |

Indexy

Název | Primární | Výraz | Popis
ix_ADSPOPRD_ad59id | P | ad59id | Identifikace druhu parametru
ix_ADSPOPRD_ad59nazdru |  | ad59nazdru | Název druhu parametru


ADSPOSLU Popis sloučení spojení adresáta

Popis

Popis sloučení spojení adresáta

Atributy

Atribut | Typ | Návěští | Message | Popis
ad63 | C(10) | ad63 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
ad63slouce | C(100) | Sloučená spojení | Seznam sloučených spojení | Seznam sloučených spojení
ad63cislo | C(60) | Změněný telefon | Telefonní číslo | Telefonní číslo
ad63fax | C(60) | Změněný fax | Faxové číslo | Faxové číslo
ad63mobil | C(60) | Změněný mobil | Číslo mobilního telefonu | Číslo mobilního telefonu
ad63email | C(60) | Změněný e-mail | E-mail spojení adresáta | E-mail spojení adresáta
ad63cisost | C(60) | Změněné jiné | Jiné spojení adresáta | Jiné spojení adresáta
ad63vypoce | N(1,0) | ad63vypoce | Provádět výpočet | Provádět výpočet
ad63pozn | M | ad63pozn | Komentář ke spojení | Komentář ke spojení

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis sloučení spojení adresáta - popisuje spojení adresáta | ADSPOSLU ad01id | 1,1 : 0,M | ADADSAT ad01id |
Popis sloučení spojení adresáta - popisuje spojení, které zůstane | ADSPOSLU ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |

Indexy

Název | Primární | Výraz | Popis
ix_ADSPOSLU_adsposlu | P | ad63, ad01id, ad11cisspo | PI - ad63+ad01id+ad11cisspo
ix_ADSPOSLU_ad01id |  | ad01id | Identifikace adresáta
ix_ADSPOSLU_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo


ADSTATY Stát

Popis

Objektem typu ADSTATY je každý záznam, který obsahuje identifikační údaje o státu, v němž sídlí některý z evidovaných adresátů.
Současně obsahuje i směrové číslo státu pro telefonní spojení.

Atributy

Atribut | Typ | Návěští | Message | Popis
ad05id | C(3) | Stát | Identifikace státu. | Identifikace státu. *** Dříve ZIP.
ad05scz | C(4) | SČZ | Směrové číslo státu pro telefonní spojení. | Směrové číslo státu pro telefonní spojení.
ad05stat | C(30) | Název státu | Název státu. | Název státu. *** Dříve STAT.
ad05nazevo | C(40) | Oficiální název | Oficiální název státu | Úplný oficiální název státu
ad05nazevc | C(40) | Název v cizí řeči | Název státu v cizí řeči | Úplný název státu v cizí řeči
ad05koment | M | Komentář | Komentář ke státu |
ad05nazeva | C(40) | Název v angl. | Název státu v anglickém jazyce |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Adresa - včetně státu | ADADR ad05id | 1,1 : 0,M | ADSTATY ad05id |
Poštovní zásilka - má na štítku stát | POPOSTA ad05id | 1,1 : 0,M | ADSTATY ad05id |
Město - je ve státě | ADMESTA ad05id | 1,1 : 0,M | ADSTATY ad05id |
Pracovník - má státní příslušnost | MZKARTA ad05id | 1,1 : 0,M | ADSTATY ad05id |

Indexy

Název | Primární | Výraz | Popis
ix_ADSTATY_ad05id | P | ad05id | Identifikace státu.
ix_ADSTATY_ad05scz |  | ad05scz | Směrové číslo státu pro telefonní spojení.
ix_ADSTATY_ad05stat |  | ad05stat | Název státu.


ADTYPSPO Typ spojení

Popis

Objektem typu ADTYPSPO je každý záznam, který obsahuje různé typy spojení (telefon, fax, e-mail). Uživatel může vybírat pouze ze seznamu typů spojení, které dodává výrobce programu. Časem bude pro každý typ spojení dána možnost, navazovat spojení automaticky, bez nutnosti ručního vytáčení čísla.
Součástí typu spojení je i rozlišovací číslo. To je číslo, které se vytáčí před samotným číslem spojení (např. číslo, které je potřeba vytočit proto, aby se volající dostal z budovy na státní linku, meziměstskou, nebo mezinárodní ústřednu...).

Atributy

Atribut | Typ | Návěští | Message | Popis
ad12id | C(6) | Typ | Identifikace typu spojení | Identifikace typu spojení.
ad12typspo | C(40) | Název | Název typu spojení | Popis typu spojení
ad12prenos | N(1,0) | ad12prenos | Použitý způsob přenosu. | Použitý způsob přenosu - Telefon, Fax, E-mail
ad12rozcis | C(4) | Rozliš. čís. | Rozlišovací číslo (vytáčené před číslem). | Rozlišovací číslo je číslo, které se vytáčí před samotným číslem spojení (např. číslo, které je potřeba vytočit proto, aby se volající dostal z budovy na státní linku, meziměstskou, nebo mezinárodní ústřednu...).

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Spojení - je typu | ADSPOJ ad12id | 1,1 : 0,M | ADTYPSPO ad12id |

Indexy

Název | Primární | Výraz | Popis
ix_ADTYPSPO_ad12id | P | ad12id | Identifikace typu spojení.
ix_ADTYPSPO_ad12typspo |  | ad12typspo | Popis typu spojení


ADTYPSPR Druh parametru pro typ subjektu

Popis

Druh parametru pro druh subjektu

Atributy

Atribut | Typ | Návěští | Message | Popis
ad58id | C(6) | Typ | Identifikátor typu subjektu pro spojení adresáta | Identifikátor typu subjektu pro spojení adresáta
ad59id | C(6) | Druh | Identifikace druhu parametru | Identifikace druhu parametru
ad62porad | N(3,0) | Pořadí | Pořadí zobrazení | Pořadí zobrazení
ad62inicia | N(1,0) | Inicializovat | Inicializovat parametr při založení spojení | Inicializovat parametr při založení spojení

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh parametru pro typ subjektu - je pro typ subjektu | ADTYPSPR ad58id | 1,1 : 0,M s rušením | ADTYPSUB ad58id |
Druh parametru pro typ subjektu - určuje druh parametru | ADTYPSPR ad59id | 1,1 : 0,M | ADSPOPRD ad59id |

Indexy

Název | Primární | Výraz | Popis
ix_ADTYPSPR_adtypspr | P | ad58id, ad59id | PI - ad58id+ad59id
ix_ADTYPSPR_ad58id |  | ad58id | Identifikátor typu subjektu pro spojení adresáta
ix_ADTYPSPR_ad59id |  | ad59id | Identifikace druhu parametru


ADTYPSUB Typ subjektu ve spojení adresáta

Popis

Typ subjektu ve spojení adresáta

Atributy

Atribut | Typ | Návěští | Message | Popis
ad58id | C(6) | Typ | Identifikátor typu subjektu pro spojení adresáta | Identifikátor typu subjektu pro spojení adresáta
ad58naztyp | C(40) | Název typu subjektu | Název typu subjektu pro spojení adresáta | Název typu subjektu pro spojení adresáta
ad58koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh parametru pro typ subjektu - je pro typ subjektu | ADTYPSPR ad58id | 1,1 : 0,M s rušením | ADTYPSUB ad58id |
Určení typu subjektu spojení adresáta pro druh operace - má uvedený typ subjektu spojení | SPTYPSUB ad58id | 1,1 : 0,M | ADTYPSUB ad58id |
Spojení adresáta - je určeno pro typ subjektu | ADSPOJ ad58id | 1,1 : 0,M | ADTYPSUB ad58id |

Indexy

Název | Primární | Výraz | Popis
ix_ADTYPSUB_ad58id | P | ad58id | Identifikátor typu subjektu pro spojení adresáta
ix_ADTYPSUB_ad58naztyp |  | ad58naztyp | Název typu subjektu pro spojení adresáta


Tabulky AP...

APAPLIKA | Aplikace BM
APMENU | Prvek menu aplikace
APMENUSQ | SQL dotaz formuláře prvku menu aplikace
APMENUV | Vazba prvků menu aplikace
APOPEPOU | Popis operace procesu pro jednotlivého uživatele
APPOHLED | Pohled aplikace
APPOPUDJ | Typ popisného údaje aplikace
APPRCPOP | Popis procesu popisným údajem aplikace
APPROP | Proces/Operace aplikace
APPROPOD | Uzel procesu aplikace
APPROPPO | Popisný údaj top procesu aplikace
APPROPPR | Předloha výstupu pro proces/operaci aplikace
APPROPSK | Skupina uživatelů užívajících proces/operaci aplikace

Viz.také

APAPLIKA Aplikace BM | APMENU Prvek menu aplikace | APMENUSQ SQL dotaz formuláře prvku menu aplikace | APMENUV Vazba prvků menu aplikace | APOPEPOU Popis operace procesu pro jednotlivého uživatele | APPOHLED Pohled aplikace | APPOPUDJ Typ popisného údaje aplikace | APPRCPOP Popis procesu popisným údajem aplikace | APPROP Proces/Operace aplikace | APPROPOD Uzel procesu aplikace | APPROPPO Popisný údaj top procesu aplikace | APPROPPR Předloha výstupu pro proces/operaci aplikace | APPROPSK Skupina uživatelů užívajících proces/operaci aplikace


APAPLIKA Aplikace BM

Popis

Aplikace BM

Atributy

Atribut | Typ | Návěští | Message | Popis
ap01id | C(6) | Aplikace | Identifikátor aplikace | Identifikátor aplikace
ap01nazapl | C(40) | Název aplikace | Název aplikace | Název aplikace
ap01ikona | M | Ikona aplikace | Ikona aplikace | Ikona aplikace
ap01koment | M | Poznámka | Poznámka | Poznámka
ap01podm | M | Podmínka | Podmínka zařazení procesu do menu | Podmínka zařazení procesu do menu
mz12id | C(6) | Identif. DVZ | Identifikace redukce denního vyměřovacího základu | Identifikace redukce denního vyměřovacího základu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Pohled aplikace - má definovaný pohled | APPOHLED ap01id | 1,1 : 0,M | APAPLIKA ap01id |
Proces/Operace aplikace - patří k aplikaci | APPROP ap01id | 1,1 : 0,M | APAPLIKA ap01id |
Prvek menu aplikace - patří k aplikaci | APMENU ap01id | 1,1 : 0,M | APAPLIKA ap01id |

Indexy

Název | Primární | Výraz | Popis
ix_APAPLIKA_ap01id | P | ap01id | Identifikátor aplikace
ix_APAPLIKA_ap01nazapl |  | ap01nazapl | Název aplikace


APMENU Prvek menu aplikace

Popis

Prvek menu aplikace

Atributy

Atribut | Typ | Návěští | Message | Popis
ap11id | C(6) | ID | Identifikace položky menu | Identifikace položky menu
ap01id | C(6) | Aplikace | Identifikátor aplikace | Identifikátor aplikace
ap11top | N(1,0) | Vrchol | Vrcholový prvek menu | Vrcholový prvek menu
ap11typ | N(1,0) | Typ | Typ položky menu | Typ položky menu
ap11nazev | C(60) | Název | Název položky menu | Název položky menu
ap11popis | C(100) | Popis | Popis položky menu | Popis položky menu
ap11navrat | M | Návratová hodnota | Návratová hodnota formuláře | Návratová hodnota formuláře
ap11kod | M | Kód | Kód programu/formuláře | Kód programu/formuláře
ap11scx | M | ap11scx | Obsah souboru FORMULAR.SCX | Obsah souboru FORMULAR.SCX
ap11sct | M | ap11sct | Obsah souboru FORMULAR.SCT | Obsah souboru FORMULAR.SCT
ap11koment | M | Poznámka | Poznámka | Poznámka
ap11packed | N(1,0) | ap11packed | Příznak pakovaného formuláře | Příznak pakovaného formuláře
ap11fparam | M | Formální parametry | Formální parametry | Formální parametry
ap11timeid | C(10) | ap11timeid | Časová identifikace pro cizojazyčnost | Časová identifikace pro cizojazyčnost

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Prvek menu aplikace - patří k aplikaci | APMENU ap01id | 1,1 : 0,M | APAPLIKA ap01id |
Vazba prvků menu aplikace - definuje předchůdce v menu | APMENUV ap11id | 1,1 : 0,M | APMENU ap11id |
Vazba prvků menu aplikace - definuje následníka v menu | APMENUV ap11id2 | 1,1 : 0,M s rušením | APMENU ap11id |
SQL dotaz formuláře prvku menu aplikace - patří k prvku menu | APMENUSQ ap11id | 1,1 : 0,M | APMENU ap11id |

Indexy

Název | Primární | Výraz | Popis
ix_APMENU_ap11id | P | ap11id | Identifikace položky menu
ix_APMENU_ap01id |  | ap01id | Identifikátor aplikace
ix_APMENU_ap11nazev |  | ap11nazev | Název položky menu


APMENUSQ SQL dotaz formuláře prvku menu aplikace

Popis

SQL dotaz formuláře prvku menu aplikace

Atributy

Atribut | Typ | Návěští | Message | Popis
ap11id | C(6) | ID | Identifikace položky menu | Identifikace položky menu
ap13alias | C(10) | Alias | Alias dotazu | Alias dotazu
ap13poradi | N(2,0) | Pořadí | Pořadí otevření souboru podle dotazu SQL | Pořadí otevření souboru podle dotazu SQL
ap13sql | M | SQL | Dotaz SQL (!!! včetně aliasů tabulek za FROM - jinak nemusí správně fungovat aktualizace dat !!!) | Dotaz SQL
ap13oblast | C(80) | Editační oblasti | Stránky editační oblasti např. Page1,Page2,... | Stránky editační oblasti např. Page1,Page2,...
ap13vklada | N(1,0) | ap13vklada | Vkládání dat povoleno | Vkládání dat povoleno
ap13oprava | N(1,0) | ap13oprava | Oprava dat povolena | Oprava dat povolena
ap13ruseni | N(1,0) | ap13ruseni | Rušení dat povoleno | Rušení dat povoleno
ap13kodpo | M | Kód po zápisu dat | Kód po zápisu dat | Kód po zápisu dat
ap13koment | M | Poznámka | Poznámka | Poznámka
ap13nacist | N(1,0) | ap13nacist | Načítat data dotazu ihned po spuštění formuláře | Načítat data dotazu ihned po spuštění formuláře
ap13obec | M | Všeobecný kód | Všeobecný kód | Všeobecný kód

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
SQL dotaz formuláře prvku menu aplikace - patří k prvku menu | APMENUSQ ap11id | 1,1 : 0,M | APMENU ap11id |

Indexy

Název | Primární | Výraz | Popis
ix_APMENUSQ_apmenusq | P | ap11id, ap13alias | PI - ap11id+ap13alias
ix_APMENUSQ_ap11id |  | ap11id | Identifikace položky menu


APMENUV Vazba prvků menu aplikace

Popis

Vazba prvků menu aplikace

Atributy

Atribut | Typ | Návěští | Message | Popis
ap12 | C(12) | ap12 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
ap11id | C(6) | ID | Identifikace položky menu | Identifikace položky menu
ap11id2 | C(6) | ap11id2 | Následující položka menu | Následující položka menu
ap12statpo | M | Stat.podmínka | Statická podmínka | Statická podmínka
ap12dynpod | M | Dyn.podmínka | Dynamická podmínka | Dynamická podmínka
ap12klaves | C(2) | Funkční klávesa | Funkční klávesa | Funkční klávesa
ap12f2pole | C(10) | F2-položka | Položka přijímající reakci na klávesu F2 | Položka přijímající reakci na klávesu F2
ap12sparam | M | Skutečné par. | Skutečné parametry | Skutečné parametry

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vazba prvků menu aplikace - definuje předchůdce v menu | APMENUV ap11id | 1,1 : 0,M | APMENU ap11id |
Vazba prvků menu aplikace - definuje následníka v menu | APMENUV ap11id2 | 1,1 : 0,M s rušením | APMENU ap11id |

Indexy

Název | Primární | Výraz | Popis
ix_APMENUV_ap12 | P | ap12 | Jednoznačná časová identifikace
ix_APMENUV_ap11id |  | ap11id | Identifikace položky menu
ix_APMENUV_ap11id2 |  | ap11id2 | Následující položka menu


APOPEPOU Popis operace procesu pro jednotlivého uživatele

Popis

Popis operace procesu pro jednotlivého uživatele

Atributy

Atribut | Typ | Návěští | Message | Popis
ap10skup | C(6) | ap10skup | Skupina údajů | Skupina údajů
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
ap10cmb | N(2,0) | ap10cmb | Atribut pro Combobox | Atribut pro Combobox
ap10txt | C(60) | ap10txt | Atribut pro Textbox - text | Atribut pro Textbox - text
ap10num | N(20,4) | ap10num | Atribut pro Textbox - num | Atribut pro Textbox - num
ap10dat | D | ap10dat | Atribut pro Textbox - dat | Atribut pro Textbox - dat
ap10tim | T | ap10tim | Atribut pro Textbox - tim | Atribut pro Textbox - tim

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis operace procesu pro jednotlivého uživatele - je pro operaci procesu | APOPEPOU sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M s rušením | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Popis operace procesu pro jednotlivého uživatele - je pro uživatele | APOPEPOU bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_APOPEPOU_apopepou | P | ap10skup, sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad, bw01uziv | PI - SPPRCOD+bw01uziv
ix_APOPEPOU_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_APOPEPOU_bw01uziv |  | bw01uziv | Identifikace uživatele systému


APPOHLED Pohled aplikace

Popis

Pohled aplikace

Atributy

Atribut | Typ | Návěští | Message | Popis
ap01id | C(6) | Aplikace | Identifikátor aplikace | Identifikátor aplikace
ap02id | C(20) | Pohled | Identifikátor pohledu aplikace | Identifikátor pohledu aplikace
ap02sql | M | SQL | SQL dotaz pohledu aplikace | SQL dotaz pohledu aplikace
ap02koment | M | Poznámka | Poznámka | Poznámka
ap02updtab | C(50) | Update tables | Update tables | Update tables
ap02fetchm | N(1,0) | Fetchmemo | Fetchmemo | Fetchmemo

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Pohled aplikace - má definovaný pohled | APPOHLED ap01id | 1,1 : 0,M | APAPLIKA ap01id |

Indexy

Název | Primární | Výraz | Popis
ix_APPOHLED_appohled | P | ap01id, ap02id | PI - ap01id+ap02id
ix_APPOHLED_ap01id |  | ap01id | Identifikátor aplikace


APPOPUDJ Typ popisného údaje aplikace

Popis

Typ popisného údaje aplikace

Atributy

Atribut | Typ | Návěští | Message | Popis
ap03id | C(6) | Typ | Identifikátor typu popisného údaje aplikace | Identifikátor popisného údaje
ap03text | C(40) | Text | Text popisného údaje | Text popisného údaje
ap03trida | N(1,0) | Třída | Třída popisného údaje | Třída popisného údaje
ap03format | M | Formát | Formát popisného údaje | Formát popisného údaje
ap03koment | M | Poznámka | Poznámka | Poznámka
ap03dedit | N(1,0) | Dědit hodnotu | Dědit hodnotu | Dědit hodnotu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popisný údaj top procesu aplikace - je typu | APPROPPO ap03id | 1,1 : 0,M | APPOPUDJ ap03id |
Popis procesu popisným údajem aplikace - používá typ popisného údaje aplikace | APPRCPOP ap03id | 1,1 : 0,M | APPOPUDJ ap03id |

Indexy

Název | Primární | Výraz | Popis
ix_APPOPUDJ_ap03id | P | ap03id | Identifikátor popisného údaje
ix_APPOPUDJ_ap03text |  | ap03text | Text popisného údaje


APPRCPOP Popis procesu popisným údajem aplikace

Popis

Popis procesu popisným údajem aplikace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
ap03id | C(6) | Typ | Identifikátor typu popisného údaje aplikace | Identifikátor popisného údaje
ap09cmb | N(2,0) | ap09cmb | Atribut pro Combobox | Atribut pro Combobox
ap09txt | C(60) | ap09txt | Atribut pro Textbox - text | Atribut pro Textbox - text
ap09num | N(20,4) | ap09num | Atribut pro Textbox - num | Atribut pro Textbox - num
ap09dat | D | ap09dat | Atribut pro Textbox - dat | Atribut pro Textbox - dat
ap09tim | T | ap09tim | Atribut pro Textbox - tim | Atribut pro Textbox - tim

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis procesu popisným údajem aplikace - popisuje proces | APPRCPOP sp33cisd sp33cisdpm sp33cisdr | 1,1 : 0,M s rušením | SPPRC sp33cisd sp33cisdpm sp33cisdr |
Popis procesu popisným údajem aplikace - používá typ popisného údaje aplikace | APPRCPOP ap03id | 1,1 : 0,M | APPOPUDJ ap03id |

Indexy

Název | Primární | Výraz | Popis
ix_APPRCPOP_apprcpop | P | sp33cisd, sp33cisdpm, sp33cisdr, ap03id | PI - SPPRC+ap03id
ix_APPRCPOP_spprc |  | sp33cisd, sp33cisdpm, sp33cisdr | Identifikace procesu
ix_APPRCPOP_ap03id |  | ap03id | Identifikátor popisného údaje


APPROP Proces/Operace aplikace

Popis

Proces/Operace aplikace

Atributy

Atribut | Typ | Návěští | Message | Popis
ap01id | C(6) | Aplikace | Identifikátor aplikace | Identifikátor aplikace
sp07idtyp | C(6) | Druh | Identifikátor druhu | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
ap04nazpro | C(40) | Název | Název procesu/operace | Název procesu/operace
ap04umiodv | N(1,0) | Odvození umístění | Způsob odvození umístění pro operaci/proces | Způsob odvození umístění pro operaci/proces
sp56typ | C(3) | Typ | Typ práva přístupu | Typ práva přístupu
sp34umiste | C(6) | sp34umiste | Umístění | Umístění
ap04top | N(1,0) | Top proces | Top proces | Top proces
ap04koment | M | Poznámka | Poznámka | Poznámka
ap04flag | C(40) | Řídící příznaky | Řídící příznaky procesu/operace | Řídící příznaky procesu/operace
ap04call | M | Příkaz | Příkaz pro spuštění z menu | Příkaz pro spuštění z menu
ap04rozmis | N(1,0) | Údaje rozmístěny | Popisné údaje rozmístěny | Popisné údaje rozmístěny

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Proces/Operace aplikace - odpovídá procesu BM | APPROP sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Proces/Operace aplikace - patří k aplikaci | APPROP ap01id | 1,1 : 0,M | APAPLIKA ap01id |
Uzel procesu aplikace - určuje vnořený proces/operaci | APPROPOD ap01id sp07idtyp sp06idsubs | 1,1 : 0,M | APPROP ap01id sp07idtyp sp06idsubs |
Uzel procesu aplikace - je uzlem vrcholového procesu aplikace | APPROPOD ap01id sp07idtypd sp06idsubd | 1,1 : 0,M | APPROP ap01id sp07idtyp sp06idsubs |
Popisný údaj top procesu aplikace - je určen pro proces | APPROPPO ap01id sp07idtyp sp06idsubs | 1,1 : 0,M | APPROP ap01id sp07idtyp sp06idsubs |
Skupina uživatelů užívajících proces/operaci aplikace - používá proces/operaci aplikace | APPROPSK ap01id sp07idtyp sp06idsubs | 1,1 : 0,M | APPROP ap01id sp07idtyp sp06idsubs |
Předloha výstupu pro proces/operaci aplikace - patří k procesu/operaci | APPROPPR ap01id sp07idtyp sp06idsubs | 1,1 : 0,M | APPROP ap01id sp07idtyp sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_APPROP_approp | P | ap01id, sp07idtyp, sp06idsubs | PI - ap01id+SPTYP
ix_APPROP_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_APPROP_ap01id |  | ap01id | Identifikátor aplikace
ix_APPROP_ap04nazpro |  | ap04nazpro | Název procesu/operace


APPROPOD Uzel procesu aplikace

Popis

Uzel procesu aplikace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp07idtypd | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu procesu
sp06idsubd | C(3) | sp06idsubd | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery
ap01id | C(6) | Aplikace | Identifikátor aplikace | Identifikátor aplikace
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ap05samuko | N(1,0) | Samostatné ukončení | Samostatné ukončení | Samostatné ukončení
ap05runpo | N(1,0) | Zakládat při stavu nadřízeného procesu | Zakládat při stavu nadřízeného procesu | Zakládat při stavu nadřízeného procesu
ap05kod | M | ap05kod | Kód transformace uzlu procesu aplikace | Kód transformace uzlu procesu aplikace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Uzel procesu aplikace - určuje vnořený proces/operaci | APPROPOD ap01id sp07idtyp sp06idsubs | 1,1 : 0,M | APPROP ap01id sp07idtyp sp06idsubs |
Uzel procesu aplikace - odpovídá uzlu v procesu inf.centra | APPROPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPTYPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad |
Uzel procesu aplikace - je uzlem vrcholového procesu aplikace | APPROPOD ap01id sp07idtypd sp06idsubd | 1,1 : 0,M | APPROP ap01id sp07idtyp sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_APPROPOD_appropod | P | sp07idtyp, sp06idsubs, sp07idtypd, sp06idsubd, ap01id | PI - ap01id+SPTYP+SPTYPD
ix_APPROPOD_approp |  | ap01id, sp07idtyp, sp06idsubs | PI - ap01id+SPTYP
ix_APPROPOD_appropd |  | ap01id, sp07idtypd, sp06idsubd | I - ap01id+SPTYPD
ix_APPROPOD_sptypod |  | sp07idtypd, sp06idsubd, sp07idtyp, sp06idsubs, sp33porad | Identifikace druhu operace v druhu procesu


APPROPPO Popisný údaj top procesu aplikace

Popis

Popisný údaj top procesu aplikace

Atributy

Atribut | Typ | Návěští | Message | Popis
ap01id | C(6) | Aplikace | Identifikátor aplikace | Identifikátor aplikace
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
ap03id | C(6) | Typ | Identifikátor typu popisného údaje aplikace | Identifikátor popisného údaje
ap06porad | N(3,0) | Pořadí | Pořadí zobrazení popisného údaje | Pořadí zobrazení popisného údaje
ap06left | N(5,0) | ap06left | Umístění LEFT | Umístění LEFT
ap06top | N(5,0) | ap06top | Umístění TOP | Umístění TOP
ap06laleft | N(5,0) | ap06laleft | Umístění návěští LEFT | Umístění návěští LEFT
ap06latop | N(5,0) | ap06latop | Umístění návěští TOP | Umístění návěští TOP
ap06width | N(5,0) | ap06width | Umístění WIDTH | Umístění WIDTH
ap06labvis | N(1,0) | Zobrazovat návěští | Zobrazovat návěští ve formuláři | Zobrazovat návěští ve formuláři

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popisný údaj top procesu aplikace - je určen pro proces | APPROPPO ap01id sp07idtyp sp06idsubs | 1,1 : 0,M | APPROP ap01id sp07idtyp sp06idsubs |
Popisný údaj top procesu aplikace - je typu | APPROPPO ap03id | 1,1 : 0,M | APPOPUDJ ap03id |

Indexy

Název | Primární | Výraz | Popis
ix_APPROPPO_approppo | P | ap01id, sp07idtyp, sp06idsubs, ap03id | PI - ap01id+SPTYP+ap03id
ix_APPROPPO_approp |  | ap01id, sp07idtyp, sp06idsubs | PI - ap01id+SPTYP
ix_APPROPPO_ap03id |  | ap03id | Identifikátor popisného údaje


APPROPPR Předloha výstupu pro proces/operaci aplikace

Popis

Předloha výstupu pro proces/operaci aplikace

Atributy

Atribut | Typ | Návěští | Message | Popis
ap01id | C(6) | Aplikace | Identifikátor aplikace | Identifikátor aplikace
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
ap08id | C(3) | ID | Identifikace předlohy | Identifikace předlohy
ap08popis | C(40) | Název předlohy | Název předlohy | Název předlohy
ap08predlo | C(40) | Předloha | Soubor předlohy | Soubor předlohy
ap08prompt | N(1,0) | Dotaz při výstupu | Dotaz při výstupu předlohou | Dotaz při výstupu předlohou
ap08kopie | N(2,0) | Počet kopií | Počet kopií při výstupu předlohou | Počet kopií při výstupu předlohou
ap08sql | M | SQL | SQL dotaz pro výstup předlohou | SQL dotaz pro výstup předlohou

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Předloha výstupu pro proces/operaci aplikace - patří k procesu/operaci | APPROPPR ap01id sp07idtyp sp06idsubs | 1,1 : 0,M | APPROP ap01id sp07idtyp sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_APPROPPR_approppr | P | ap01id, sp07idtyp, sp06idsubs, ap08id | PI - APPROP+ap08id


APPROPSK Skupina uživatelů užívajících proces/operaci aplikace

Popis

Skupina uživatelů užívajících proces/operaci aplikace

Atributy

Atribut | Typ | Návěští | Message | Popis
ap01id | C(6) | Aplikace | Identifikátor aplikace | Identifikátor aplikace
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
bw05ident | C(6) | Skupina | Identifikace skupiny uživatelů | Identifikace skupiny uživatelů
ap07pravo | C(40) | Popis práva | Popis práva skupiny uživatelů | Popis práva skupiny uživatelů
sp34umiste | C(6) | sp34umiste | Umístění | Umístění

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Skupina uživatelů užívajících proces/operaci aplikace - používá proces/operaci aplikace | APPROPSK ap01id sp07idtyp sp06idsubs | 1,1 : 0,M | APPROP ap01id sp07idtyp sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_APPROPSK_appropsk | P | ap01id, sp07idtyp, sp06idsubs, bw05ident | PI - APPROP+bw05ident
ix_APPROPSK_approp |  | ap01id, sp07idtyp, sp06idsubs | PI - ap01id+SPTYP
ix_APPROPSK_bw05ident |  | bw05ident | Identifikace skupiny uživatelů


Tabulky BW...

BWCIODB | Právo odbornosti k činnosti
BWCONNEC | Přihlášený uživatel do systému
BWCONNEQ | Přihlášený uživatel do systému (SQL)
BWCONNES | Statistka největšího počtu přihlášených uživatelů po dnech
BWCONUSR | Uživatel připojený do systému
BWCOOKIE | Cookie pro intranet
BWDEFM | Definice menu
BWDEFMK | Klíč kroku v definici menu
BWDEFMP | Krok v definici menu
BWDEFOBJ | Typ objektu BM
BWF2CALL | Reakce na F2 v šablonách a výběrech
BWFLDACV | Uložený návrh funkce automatického dokončování
BWFLDPAR | Parametry pole formuláře
BWFXPSRC | Kompilovaný skript Foxpro
BWGHELP | Údaj o HELP k činnosti
BWIKONA | Ikona v BM
BWINSTAL | Instalované soubory
BWMEMOR | Seznam paměťových proměnných
BWMENPAR | Parametr činnosti menu
BWMENPOD | Skupina uživatelů výběru vstupem
BWMENU | Činnost
BWMENUM | Výběr pro OUTLINE menu
BWOBJECG | GUID objektu
BWOBJECN | Pseudo-objekt
BWOBJECT | Vazba objektů
BWOBJECX | Popis vazby objektů
BWODBOR | Skupina uživatelů
BWOKROKY | Definice oprávnění k činnosti
BWOPTIOC | Nastavení programu BM pro počítač uživatele BM nebo datové úložiště
BWOPTION | Nastavení programu BM
BWOVAZBA | Zařazení uživatele to skupiny uživatelů
BWOVAZBS | Zařazení uživatele to skupiny uživatelů - skutečná
BWOZMCR | Makro výrazů
BWOZMCRD | Druh makra výrazů
BWOZMCRP | Parametr makra výrazů
BWOZNAC | Označený objekt
BWOZVRZ | Výraz označování výběrem
BWPRINMC | Počítač uživatele systému BM
BWPRINME | Řídící kód negrafické tiskárny
BWPRINMF | Fyzická tiskárna
BWPRINML | Logická tiskárna systému BM
BWPRINMP | Pracoviště uživatele systému BM
BWPRINMT | Typ fyzické tiskárny
BWPRINMV | Logická tiskárna pracoviště
BWPRINS | Metapředloha výstupu
BWPRINSP | Předloha výstupu v makropředloze
BWPRINTA | Příloha předlohy výstupu
BWPRINTC | Profil spuštění předlohy výstupu
BWPRINTD | Předloha pro výstup
BWPRINTF | Výběr výstupu
BWPRINTT | Druh předlohy
BWPRINTU | Užití předlohy výstupu uživatelem
BWPRINTV | Popis verze předlohy výstupu
BWPROVED | Provedená činnost
BWRGBCOL | Hodnota RGB barvy
BWSAVESC | Vlastnosti formuláře
BWSEMAF | Semafor pro blokování činností
BWSINFO | Systémová informace
BWSLDPOH | Pohled slovníku dat
BWSLDSCR | Obrazovka pohledu slovníku dat
BWSLDUZI | Uživatelský index pro SLD
BWSLOVA | Text k přeložení
BWSLOVNI | Přeložený text
BWSLOVPP | Popisná entita překladu
BWSYSTRG | Triggery v databázi
BWTOOL | Uživatelský toolbar
BWTOOLP | Položka toolbaru
BWTOOLPI | Ikona položky toobaru
BWTOOLS | Pozice okna uživatele toolbaru
BWTRGUSR | Uživatelský trigger
BWTRIGG | Trigger tabulky
BWUPDRC | Zápis o změně záznamu tabulky
BWUPDRCA | Zápis o změně atributu záznamu tabulky
BWUPDTRG | Záznam o update triggerem
BWUZIVAT | Uživatel systému
BWUZSKUP | Skupina uživatele
BWUZSTAR | Činnost spuštěná při startu programu pro uživatele
BWUZVOL | Uživatelská volba definice menu
BWWEBDRU | Druh prvku WEB
BWWEBPRV | Prvek WEB
BWWEBVAZ | Vazba prvků WEB
BWWINDPS | Uchovaná pozice okna
BWZIPFIL | Soubor ZIP

Viz.také

BWCIODB Právo odbornosti k činnosti | BWCONUSR Uživatel připojený do systému | BWCOOKIE Cookie pro intranet | BWDEFM Definice menu | BWDEFMP Krok v definici menu | BWGHELP Údaj o HELP k činnosti | BWINSTAL Instalované soubory | BWMEMOR Seznam paměťových proměnných | BWMENPAR Parametr činnosti menu | BWMENPOD Skupina uživatelů výběru vstupem | BWODBOR Skupina uživatelů | BWOKROKY Definice oprávnění k činnosti | BWOVAZBA Zařazení uživatele to skupiny uživatelů | BWOZMCR Makro výrazů | BWOZMCRD Druh makra výrazů | BWOZMCRP Parametr makra výrazů | BWOZNAC Označený objekt | BWOZVRZ Výraz označování výběrem | BWPRINMC Počítač uživatele systému BM | BWPRINMF Fyzická tiskárna | BWPRINML Logická tiskárna systému BM | BWPRINMP Pracoviště uživatele systému BM | BWPRINMV Logická tiskárna pracoviště | BWPRINS Metapředloha výstupu | BWPRINSP Předloha výstupu v makropředloze | BWPRINTC Profil spuštění předlohy výstupu | BWPRINTD Předloha pro výstup | BWPRINTF Výběr výstupu | BWPRINTT Druh předlohy | BWSAVESC Vlastnosti formuláře | BWSEMAF Semafor pro blokování činností | BWSINFO Systémová informace | BWSLDPOH Pohled slovníku dat | BWSLDSCR Obrazovka pohledu slovníku dat | BWSLDUZI Uživatelský index pro SLD | BWSLOVNI Přeložený text | BWSYSTRG Triggery v databázi | BWTOOL Uživatelský toolbar | BWTOOLP Položka toolbaru | BWTOOLPI Ikona položky toobaru | BWTOOLS Pozice okna uživatele toolbaru | BWTRGUSR Uživatelský trigger | BWUPDTRG Záznam o update triggerem | BWUZIVAT Uživatel systému | BWUZSKUP Skupina uživatele | BWUZSTAR Činnost spuštěná při startu programu pro uživatele | BWUZVOL Uživatelská volba definice menu | BWWEBDRU Druh prvku WEB | BWWEBPRV Prvek WEB | BWWEBVAZ Vazba prvků WEB | BWCONNEC Přihlášený uživatel do systému | BWOBJECT Vazba objektů | BWPROVED Provedená činnost | BWIKONA Ikona v BM | BWDEFMK Klíč kroku v definici menu | BWOPTIOC Nastavení programu BM pro počítač uživatele BM nebo datové úložiště | BWOPTION Nastavení programu BM | BWUPDRC Zápis o změně záznamu tabulky | BWUPDRCA Zápis o změně atributu záznamu tabulky | BWPRINME Řídící kód negrafické tiskárny | BWPRINMT Typ fyzické tiskárny | BWRGBCOL Hodnota RGB barvy | BWOBJECN Pseudo-objekt | BWOBJECX Popis vazby objektů | BWPRINTU Užití předlohy výstupu uživatelem | BWFXPSRC Kompilovaný skript Foxpro | BWFLDACV Uložený návrh funkce automatického dokončování | BWFLDPAR Parametry pole formuláře | BWOVAZBS Zařazení uživatele to skupiny uživatelů - skutečná | BWCONNEQ Přihlášený uživatel do systému (SQL) | BWCONNES Statistka největšího počtu přihlášených uživatelů po dnech | BWWINDPS Uchovaná pozice okna | BWSLOVPP Popisná entita překladu | BWOBJECG GUID objektu | BWPRINTA Příloha předlohy výstupu | BWPRINTV Popis verze předlohy výstupu | BWZIPFIL Soubor ZIP


BWCIODB Právo odbornosti k činnosti

Popis

Právo odbornosti k činnosti

Atributy

Atribut | Typ | Návěští | Message | Popis
bw16ident | C(8) | Ident. | Rozšířená identifikace činnosti | Rozšířená identifikace činnosti
bw05ident | C(6) | Skupina | Identifikace skupiny uživatelů | Identifikace skupiny uživatelů
bw17plat | L | bw17plat |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Právo odbornosti k činnosti - je odbornosti | BWCIODB bw05ident | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_BWCIODB_bwciodb | P | bw16ident, bw05ident | Index k opránění k činnosti činnost+identifikace !!!! neplatí !!!
ix_BWCIODB_bw16ident |  | bw16ident | Rozšířená identifikace činnosti
ix_BWCIODB_bw05ident |  | bw05ident | Identifikace skupiny uživatelů


BWCONNEC Přihlášený uživatel do systému

Popis

Přihlášený uživatel do systému

Atributy

Atribut | Typ | Návěští | Message | Popis
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw01jmeno | C(30) | Uživatel | Jméno uživatele systému | Jméno uživatele systému
bw14nazev | C(30) | Činnost | Název probíhající činnosti | Název probíhající činnosti
bw14trans | C(1) | Transakce | Probíhající transakce | Probíhající transakce
bw14iden | N(9,0) | Identifikace | Interní identifikace uživatele | Interní identifikace uživatele
bw14datum | D | Datum | Datum posledního zápisu | Datum posledního zápisu
bw14cas | C(8) | Čas | Čas posledního zápisu | Čas posledního zápisu
bw14lock | C(1) | bw14lock | Přechodný příznak zalokování (pro UNLOCK) | Přechodný příznak zalokování (pro UNLOCK)
bw14karta | C(40) | bw14karta | Název počítače | Název počítače


BWCONNEQ Přihlášený uživatel do systému (SQL)

Popis

Přihlášený uživatel do systému (SQL)

Atributy

Atribut | Typ | Návěští | Message | Popis
bw14iden | N(9,0) | Identifikace | Interní identifikace uživatele | Interní identifikace uživatele
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw14nazev | C(30) | Činnost | Název probíhající činnosti | Název probíhající činnosti
bw14datcas | T | Čas | Datum a čas poslední aktivity uživatele | Datum a čas poslední aktivity uživatele
bw14karta | C(40) | bw14karta | Název počítače | Název počítače
bw14zaksys | N(2,0) | Multiverze | Číslo multiverze přihlášeného uživatele | Číslo multiverze přihlášeného uživatele
bw14 | C(12) | bw14 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
bw14spykod | M | bw14spykod | Script v jazyce Foxpro | Script v jazyce Foxpro
bw14spyjpg | M | bw14spyjpg | Obsah JPG obrazu obrazovky uživatele | Obsah JPG obrazu obrazovky uživatele
bw14spyjti | T | bw14spyjti | Čas posledního sejmutí obrazovky | Čas posledního sejmutí obrazovky
bw14spycnt | N(5,0) | bw14spycnt | Počet požadavků na sejmutí obrazovky | Počet požadavků na sejmutí obrazovky
bw14spysta | M | bw14spysta | Stav programu BM | Stav programu BM
bw14spysti | T | bw14spysti | Čas posledního zjištění stavu BM | Čas posledního zjištění stavu BM
bw14spycns | N(5,0) | bw14spycns | Počet požadavků na zjištění stavu BM | Počet požadavků na zjištění stavu BM

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Přihlášený uživatel do systému (SQL) - má jméno | BWCONNEQ bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_BWCONNEQ_bw14iden | P | bw14iden | Interní identifikace uživatele
ix_BWCONNEQ_bw01uziv |  | bw01uziv | Identifikace uživatele systému


BWCONNES Statistka největšího počtu přihlášených uživatelů po dnech

Popis

Statistka největšího počtu přihlášených uživatelů po dnech

Atributy

Atribut | Typ | Návěští | Message | Popis
bwa5datum | D | bwa5datum | Den statistky počtu přihlášených uživatelů | Den statistky počtu přihlášených uživatelů
bwa5ucount | N(5,0) | bwa5ucount | Počet současně přihlášených | Počet současně přihlášených
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému

Indexy

Název | Primární | Výraz | Popis
ix_BWCONNES_bwa5datum | P | bwa5datum | Den statistky počtu přihlášených uživatelů


BWCONUSR Uživatel připojený do systému

Popis

Uživatel připojený do systému

Atributy

Atribut | Typ | Návěští | Message | Popis
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému

Indexy

Název | Primární | Výraz | Popis
ix_BWCONUSR_bw01uziv | P | bw01uziv | Identifikace uživatele systému


BWCOOKIE Cookie pro intranet

Popis

Cookie pro intranet

Atributy

Atribut | Typ | Návěští | Message | Popis
bw65id | C(60) | bw65id | Identifikace cookie | Identifikace cookie
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw65cas | T | bw65cas | Datum a čas poslední aktivace cookie | Datum a čas poslední aktivace cookie
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta

Indexy

Název | Primární | Výraz | Popis
ix_BWCOOKIE_bw65id | P | bw65id | Identifikace cookie


BWDEFM Definice menu

Popis

Definice menu

Atributy

Atribut | Typ | Návěští | Message | Popis
bw24nazev | C(30) | Název menu | Název menu | Název menu
bw24ident | C(10) | bw24ident | Identifikace menu | Identifikace menu
bw24otec | C(10) | bw24otec | Identifikace nadřazeného menu | Identifikace nadřazeného menu
bw24edit | N(1,0) | bw24edit | Menu vytvořené uživatelem | Menu vytvořené uživatelem
bw24oprava | N(1,0) | bw24oprava | Povolena oprava menu | Povolena oprava menu
bw24spust | N(1,0) | bw24spust | Povoleno spuštění menu | Povoleno spuštění menu
bw24zrus | N(1,0) | bw24zrus | Povoleno zrušení menu | Povoleno zrušení menu
bw24soukr | N(1,0) | bw24soukr | Soukromé menu | Soukromé menu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Definice menu - byla založena uživatelem | BWDEFM bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Uživatel systému - používá menu | BWUZIVAT bw24ident | 0,1 : 0,M | BWDEFM bw24ident |
Krok v definici menu - náleží definici menu | BWDEFMP bw24ident | 1,1 : 0,M s rušením | BWDEFM bw24ident |

Indexy

Název | Primární | Výraz | Popis
ix_BWDEFM_bw24nazev |  | bw24nazev | Název menu
ix_BWDEFM_bw24ident | P | bw24ident | Identifikace menu
ix_BWDEFM_bw01uziv |  | bw01uziv | Identifikace uživatele systému


BWDEFMK Klíč kroku v definici menu

Popis

Klíč kroku v definici menu

Atributy

Atribut | Typ | Návěští | Message | Popis
bw26ident | C(12) | bw26ident | Identifikace kroku | Identifikace kroku
bw26krok | C(12) | Identifikace nadřazeného kroku | Identifikace nadřazeného kroku | Identifikace nadřazeného kroku
bw89index | C(60) | bw89index | Index pro identifikace položky menu v XML dokumentech | Index pro identifikace položky menu v XML dokumentech

Indexy

Název | Primární | Výraz | Popis
ix_BWDEFMK_bwdefmk | P | bw26ident, bw26krok |
ix_BWDEFMK_bw89index | U | bw89index | Index pro identifikace položky menu v XML dokumentech


BWDEFMP Krok v definici menu

Popis

Krok v definici menu

Atributy

Atribut | Typ | Návěští | Message | Popis
bw24ident | C(10) | bw24ident | Identifikace menu | Identifikace menu
bw26ident | C(12) | bw26ident | Identifikace kroku | Identifikace kroku
bw26krok | C(12) | Identifikace nadřazeného kroku | Identifikace nadřazeného kroku | Identifikace nadřazeného kroku
bw26identx | C(12) | Identifikace kroku v programu | Identifikace kroku v programu | Identifikace kroku v programu
bw26krokx | C(12) | Identifikace nadřazeného kroku v programu | Identifikace nadřazeného kroku v programu | Identifikace nadřazeného kroku v programu
bw26typ | N(1,0) | Typ uzlu | Typ uzlu | Typ uzlu
bw26nazev | M | Název kroku | Název kroku | Název kroku
bw26pozn | M | Poznámka kroku | Poznámka kroku | Poznámka kroku
bw26nazevj | M | bw26nazevj | Názvy kroků v jazycích | Názvy kroků v jazycích
bw26poznj | M | bw26poznj | Poznámky ke krokům v jazycích | Poznámky ke krokům v jazycích
bw26ikona | M | Ikona kroku | Ikona kroku | Ikona kroku
bw26poradi | N(5,0) | bw26poradi | Pořadí kroku v submenu | Pořadí kroku v submenu
bw26skryta | N(2,0) | bw26skryta | Příznak skrytého kroku | Příznak skrytého kroku
bw26poradd | N(1,0) | bw26poradd | Příznak dědění pořadí | Příznak dědění pořadí
bw26uziva | N(2,0) | bw26uziva | Příznak uživatelsky definovaného kroku | Příznak uživatelsky definovaného kroku
bw26dynam | N(2,0) | bw26dynam | Příznak dynamického kroku | Příznak dynamického kroku
bw26skrytd | N(1,0) | bw26skrytd | Příznak dědění skryté položky menu | Příznak dědění skryté položky menu
bw26menu | N(2,0) | bw26menu | Vyvolávací klávesa | Vyvolávací klávesa
bw22ident | C(10) | Parametr činnosti menu | Parametr činnosti menu | Identifikace parametru činnosti menu
bw26menud | N(1,0) | bw26menud | Příznak dědění vyvolávací klávesy | Příznak dědění vyvolávací klávesy
bw26d22 | N(1,0) | bw26d22 | Příznak dědění identifikace parametru činnosti menu | Příznak dědění identifikace parametru činnosti menu
bw26odvoz | N(1,0) | bw26odvoz | Odvozený krok | Odvozený krok
bw26datv | T | bw26datv |  |
bw26xtool | N(1,0) | bw26xtool |  |
bw26index | C(40) | bw26index | Index pro identifikace položky menu v XML dokumentech | Index pro identifikace položky menu v XML dokumentech

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Krok v definici menu - používá parametr menu | BWDEFMP bw22ident | 0,1 : 0,M | BWMENPAR bw22ident |
Krok v definici menu - náleží definici menu | BWDEFMP bw24ident | 1,1 : 0,M s rušením | BWDEFM bw24ident |

Indexy

Název | Primární | Výraz | Popis
ix_BWDEFMP_bwdefmp | P | bw24ident, bw26ident, bw26krok |
ix_BWDEFMP_bw22ident |  | bw22ident | Identifikace parametru činnosti menu
ix_BWDEFMP_bw26datv |  | bw26datv |


BWFLDACV Uložený návrh funkce automatického dokončování

Popis

Uložený návrh funkce automatického dokončování

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bwa2nazev | C(30) | bwa2nazev | Pole formuláře | Pole formuláře
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bwa3navrh | M | bwa3navrh | Text uloženého návrhu funkce automatického dokončování | Text uloženého návrhu funkce automatického dokončování

Indexy

Název | Primární | Výraz | Popis
ix_BWFLDACV_bwfldpar | P | bw02krok, bwa2nazev, bw01uziv | PI - bw02krok+bwa2atr+bw01uziv


BWFLDPAR Parametry pole formuláře

Popis

Parametry vstupního pole formuláře

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bwa2nazev | C(30) | Pole | Pole formuláře | Pole formuláře
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bwa2acmp | N(1,0) | Funkce automatického dokončování | Aktivní funkce automatického dokončování Ano/Ne | Aktivní funkce automatického dokončování Ano/Ne
bwa2acmpnv | N(1,0) | bwa2acmpnv | Naplnění seznamu návrhů | Naplnění seznamu návrhů
bwa2acmpsq | M | SQL/Výčet/Skript | SQL dotaz pro vytvoření seznamu návrhů / Výčet obsahu návrhu / Skript v jazyce Foxpro | SQL dotaz pro vytvoření seznamu návrhů
bwa2koment | M | Poznámka | Poznámka | Poznámka
bwa2acmppx | M | Výraz prefixu | Výraz prefixu hodnoty v seznamu návrhů | Výraz prefixu hodnoty v seznamu návrhů
bwa2chrcnt | N(3,0) | Uplatní se znaků | Počet znaků vstupovaného pole, které se uplatní jako výběr pro naplnění seznamu návrhů (-1=všechny) | Počet znaků vstupovaného pole, které se uplatní jako výběr pro naplnění seznamu návrhů (-1=všechny)
bwa2listvl | N(1,0) | Přenášet hodnotu | Přenášení hodnoty do vstupovaného pole při listování v aktivním seznamu návrhů (aktivním např. po užití klávesy CTRL+ŠIPKA_DOLŮ) | Přenášení hodnoty do vstupovaného pole při listování v aktivním seznamu návrhů (aktivním např. po užití klávesy CTRL+ŠIPKA_DOLŮ)

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametry pole formuláře - jsou parametry uživatele | BWFLDPAR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_BWFLDPAR_bwfldpar | P | bw02krok, bwa2nazev, bw01uziv | PI - bw02krok+bwa2atr+bw01uziv
ix_BWFLDPAR_bw02krok |  | bw02krok | Identifikace činnosti
ix_BWFLDPAR_bwa2nazev |  | bwa2nazev | Pole formuláře
ix_BWFLDPAR_bw01uziv |  | bw01uziv | Identifikace uživatele systému


BWFXPSRC Kompilovaný skript Foxpro

Popis

Kompilovaný skript Foxpro

Atributy

Atribut | Typ | Návěští | Message | Popis
bwa1 | C(10) | bwa1 | Identifikace souboru kompilovaného skriptu | Identifikace souboru kompilovaného skriptu
bwa1kod | M | bwa1kod | Kód v jazyce Foxpro | Kód v jazyce Foxpro
bwa1date | D | bwa1date | Datum souboru FXP | Datum souboru FXP
bwa1time | C(10) | bwa1time | Čas souboru FXP | Čas souboru FXP
bwa1size | N(6,0) | bwa1size | Velikost souboru FXP | Velikost souboru FXP
bwa1owner | C(50) | bwa1owner | Vlastník kódu - primární index | Vlastník kódu - primární index

Indexy

Název | Primární | Výraz | Popis
ix_BWFXPSRC_bwa1 | P | bwa1 | Identifikace souboru kompilovaného skriptu
ix_BWFXPSRC_bwa1owner | U | bwa1owner | Vlastník kódu - primární index


BWGHELP Údaj o HELP k činnosti

Popis

Údaje generátoru HELP

Atributy

Atribut | Typ | Návěští | Message | Popis
bw30sekv1 | C(6) | Sekvence procházení | Sekvence procházení helpem 1.část | Sekvence procházení helpem 1.část
bw30sekv2 | C(3) | bw30sekv2 | Sekvence procházení helpem 2.část | Sekvence procházení helpem 2.část
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw30nazev | C(30) | Generovaný n. | Název činnosti v době generování | Název činnosti v době generování
bw30autom | N(1,0) | Help programové činnosti | Help programové činnosti | Help programové činnosti
bw30dat1 | T | První výskyt | Datum prvního výskytu | Datum prvního výskytu
bw30pozn | M | Poznámka | Poznámka | Poznámka
bw30otec | M | Otcové činnosti při posledním generování | Otcové činnosti při posledním generování | Otcové činnosti při posledním generování
bw30syn | M | Synové činnosti při posledním generování | Synové činnosti při posledním generování | Synové činnosti při posledním generování
bw30chyba | C(20) | Chybové hlášení kontroly generátoru | Chybové hlášení kontroly generátoru | Chybové hlášení kontroly generátoru
bw30uklic | C(20) | Uživatelský klíč | Uživatelský klíč | Uživatelský klíč
bw30hotovo | N(1,0) | bw30hotovo | Činnost je popsána | Činnost je popsána
bw30datg | T | Naposledy základní | Naposledy generovaný základní help | Naposledy generovaný základní help
bw30datgcn | T | Naposledy ovládání | Naposledy generovaný help ovládání | Naposledy generovaný help ovládání
bw30datgti | T | Naposledy tisky | Naposledy generovaný help tisky | Naposledy generovaný help tisky
bw30datggr | T | Naposledy formulář | Naposledy generovaný help formulář | Naposledy generovaný help mřížky
bw30datgzd | T | Naposledy zdroje | Naposledy generovaný help zdrojových činností | Naposledy generovaný help zdrojových činností
bw30gen | N(1,0) | bw30gen | Byl opraven help základní help | Byl opraven help základní help
bw30gencn | N(1,0) | bw30gencn | Byl opraven help navazující menu činností | Byl opraven help navazující menu činností
bw30gengr | N(1,0) | bw30gengr | Byl opraven help formulář | Byl opraven help formulář
bw30genti | N(1,0) | bw30genti | Byl opraven help tisky | Byl opraven help tisky
bw30genzd | N(1,0) | bw30genzd | Byl opraven help zdrojové činnosti | Byl opraven help zdrojové činnosti
bw30hlp | M | Help základní stránky | Help základní stránky | Help základní stránky
bw30hlpcn | M | bw30hlpcn | Help stránky - ovládání | Help stránky - ovládání
bw30hlpgr | M | Help stránky - formulář | Help stránky - formulář | Help stránky - formulář
bw30hlpti | M | Help stránky - tisk | Help stránky - tisk | Help stránky - tisk
bw30hlpzd | M | bw30hlpzd | Help stránky - zdroje | Help stránky - zdroje
bw30crc | C(5) | bw30crc |  |
bw30crccn | C(5) | bw30crccn |  |
bw30crcgr | C(5) | bw30crcgr |  |
bw30crcti | C(5) | bw30crcti |  |
bw30crczd | C(5) | bw30crczd |  |
bw30inf | N(1,0) | bw30inf | Informační text | Informační text
bw30stat | C(10) | bw30stat |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Údaj o HELP k činnosti - popisuje činnost systému | BWGHELP bw02krok | 0,1 : 0,1 | BWMENU bw02krok |
Činnost - váže na záznam o generovaní helpu | BWMENU bw02krok | 0,1 : 0,1 | BWGHELP bw02krok |

Indexy

Název | Primární | Výraz | Popis
ix_BWGHELP_bw30sekv |  | bw30sekv1, bw30sekv2 | Klíč sekvence procházení
ix_BWGHELP_bw02krok | P | bw02krok | Identifikace činnosti
ix_BWGHELP_bw30nazev |  | bw30nazev | Název činnosti v době generování
ix_BWGHELP_bw30dat1 |  | bw30dat1 | Datum prvního výskytu
ix_BWGHELP_bw30chyba |  | bw30chyba | Chybové hlášení kontroly generátoru
ix_BWGHELP_bw30uklic |  | bw30uklic | Uživatelský klíč
ix_BWGHELP_bw30datg |  | bw30datg | Naposledy generovaný základní help
ix_BWGHELP_bw30datgcn |  | bw30datgcn | Naposledy generovaný help ovládání
ix_BWGHELP_bw30datgti |  | bw30datgti | Naposledy generovaný help tisky
ix_BWGHELP_bw30datggr |  | bw30datggr | Naposledy generovaný help mřížky
ix_BWGHELP_bw30datgzd |  | bw30datgzd | Naposledy generovaný help zdrojových činností


BWIKONA Ikona v BM

Popis

Ikona v BM

Atributy

Atribut | Typ | Návěští | Message | Popis
bw88id | C(6) | Ikona | Identifikace ikony | Identifikace ikony
bw88naziko | C(40) | Název ikony | Název ikony | Název ikony
bw88soubor | M | Soubor ikony | Soubor ikony | Soubor ikony
bw88koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Tag XML dokumentu - používá ikonu | SPXMLTAG bw88id | 1,1 : 0,M | BWIKONA bw88id |
Vazba mezi tagy XML dokumentu - používá ikonu | SPXMLVAZ bw88id | 1,1 : 0,M | BWIKONA bw88id |
Uzel obecného stromu - je zobrazován s ikonou | SPSTROM bw88id | 1,1 : 0,M | BWIKONA bw88id |
Uzel informačního panelu - používá ikonu | IPUZEL bw88id | 1,1 : 0,M | BWIKONA bw88id |
Podmíněná ikona pro uzel obecného stromu - určuje ikonu | SPSTROMI bw88id | 1,1 : 0,M | BWIKONA bw88id |

Indexy

Název | Primární | Výraz | Popis
ix_BWIKONA_bw88id | P | bw88id | Identifikace ikony
ix_BWIKONA_bw88naziko |  | bw88naziko | Název ikony


BWINSTAL Instalované soubory

Popis

Instalované soubory

Atributy

Atribut | Typ | Návěští | Message | Popis
bw13soubor | C(12) | bw13soubor | Název souboru | Název souboru
bw13subs | C(10) | bw13subs | Subsystém | Subsystém
bw13typ | N(1,0) | bw13typ | Typ souboru 1=první instalace, 2=demo | Typ souboru 1=první instalace, 2=demo
bw13dbf | M | bw13dbf | První část souboru | První část souboru
bw13fpt | M | bw13fpt | Druhá část souboru | Druhá část souboru


BWMEMOR Seznam paměťových proměnných

Atributy

Atribut | Typ | Návěští | Message | Popis
bw28sbr | C(10) | Soubor | Identifikace souboru paměťových proměnných | Identifikace souboru paměťových proměnných
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw28id | C(10) | Identifikace | Identifikace paměťové proměnné | Identifikace paměťové proměnné
bw28typ | C(1) | Typ | Typ proměnné | Typ proměnné
bw28hodn | C(60) | Hodnota | Hodnota paměťové proměnné | Hodnota paměťové proměnné

Indexy

Název | Primární | Výraz | Popis
ix_BWMEMOR_bwmemor | P | bw28sbr, bw01uziv, bw28id, bw28typ |


BWMENPAR Parametr činnosti menu

Popis

Parametr činnosti menu

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw22ident | C(10) | Parametr činnosti menu | Parametr činnosti menu | Identifikace parametru činnosti menu
bw04ident | C(10) | Ident. | Identifikace předlohy pro výstup | Identifikace předlohy pro výstup
bw81id | C(6) | MPV | Identifikace metapředlohy výstupu | Identifikace makropředlohy výstupu
bw22nazev | C(40) | Název parametru činnosti menu | Název parametru činnosti menu | Název parametru činnosti menu
bw22konst | M | bw22konst | Konstantní hodnoty výběru | Konstantní hodnoty výběru
sp27id | C(12) | sp27id | Jednoznačná časová identifikace obecného výběru | Jednoznačná časová identifikace obecného výběru
bw22koment | M | Poznámka | Poznámka | Poznámka
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw22verej | N(1,0) | Veřejný přístup | Veřejný přístup k výběru - Ano=podle skupin uživatelů, Ne=pouze vlastník výběru | Veřejný přístup k výběru

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametr činnosti menu - definuje užití obecného výběru | BWMENPAR sp27id | 0,1 : 0,M | SPVYBER sp27id |
Parametr činnosti menu - určuje metapředlohu výstupu volanou na klávesu F12 | BWMENPAR bw02krok bw81id | 0,1 : 0,M | BWPRINS bw02krok bw81id |
Parametr činnosti menu - vlastní uživatel | BWMENPAR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Skupina uživatelů výběru vstupem - používá výběr | BWMENPOD bw02krok bw22ident | 1,1 : 0,M s rušením | BWMENPAR bw02krok bw22ident |
Krok v definici menu - používá parametr menu | BWDEFMP bw22ident | 0,1 : 0,M | BWMENPAR bw22ident |

Indexy

Název | Primární | Výraz | Popis
ix_BWMENPAR_bwmenpar | P | bw02krok, bw22ident | Primární index parametru menu
ix_BWMENPAR_bw04printd |  | bw02krok, bw04ident | Primární klíč předlohy pro výstup BW02krok+BW04ident
ix_BWMENPAR_bwprins |  | bw02krok, bw81id | PI - bw02krok+bw81id
ix_BWMENPAR_bw22ident | U | bw22ident | Identifikace parametru činnosti menu
ix_BWMENPAR_bw22nazev |  | bw22nazev | Název parametru činnosti menu
ix_BWMENPAR_sp27id |  | sp27id | Jednoznačná časová identifikace obecného výběru
ix_BWMENPAR_bw01uziv |  | bw01uziv | Identifikace uživatele systému


BWMENPOD Skupina uživatelů výběru vstupem

Popis

Skupina uživatelů výběru vstupem

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw22ident | C(10) | Parametr činnosti menu | Parametr činnosti menu | Identifikace parametru činnosti menu
bw05ident | C(6) | Skupina | Identifikace skupiny uživatelů | Identifikace skupiny uživatelů

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Skupina uživatelů výběru vstupem - používá výběr | BWMENPOD bw02krok bw22ident | 1,1 : 0,M s rušením | BWMENPAR bw02krok bw22ident |
Skupina uživatelů výběru vstupem - má jméno | BWMENPOD bw05ident | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_BWMENPOD_bwmenpod | P | bw02krok, bw22ident, bw05ident | PI - BWMENPAR+bw01uziv
ix_BWMENPOD_bwmenpar |  | bw02krok, bw22ident | Primární index parametru menu
ix_BWMENPOD_bw05ident |  | bw05ident | Identifikace skupiny uživatelů


BWOBJECG GUID objektu

Popis

GUID objektu

Atributy

Atribut | Typ | Návěští | Message | Popis
bw09inst1 | C(12) | bw09inst1 | Jednoznačný časový identifikátor instance objektu typu 1. |
bw09typ1 | C(2) | bw09typ1 | Identifikátor typu objektu 1. | Typ objektu
bwa8guid | C(36) | GUID objektu | GUID objektu | GUID objektu

Indexy

Název | Primární | Výraz | Popis
ix_BWOBJECG_bw09k1 | P | bw09inst1, bw09typ1 |
ix_BWOBJECG_bwa8guid | U | bwa8guid | GUID objektu


BWOBJECN Pseudo-objekt

Popis

Pseudo-objekt

Atributy

Atribut | Typ | Návěští | Message | Popis
bw10nazev | C(8) | Tabulka | Název entity | Název entity
bw99key | C(50) | bw99key | Klíč záznamu | Klíč záznamu
bw99 | C(12) | bw99 | Jednoznačný časový identifikátor | Jednoznačný časový identifikátor

Indexy

Název | Primární | Výraz | Popis
ix_BWOBJECN_bwobjecn | P | bw10nazev, bw99key | PI - bw10nazev+bw99key


BWOBJECT Vazba objektů

Popis

Soubor vazeb objektů.

Atributy

Atribut | Typ | Návěští | Message | Popis
bw09inst1 | C(12) | bw09inst1 | Jednoznačný časový identifikátor instance objektu typu 1. |
bw09typ1 | C(2) | bw09typ1 | Identifikátor typu objektu 1. | Typ objektu
bw09inst2 | C(12) | bw09inst2 |  |
bw09typ2 | C(2) | bw09typ2 |  |
bw09del | L | bw09del |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis vazby objektů - popisuje vazbu objektů | BWOBJECX bw09inst1 bw09inst2 | 1,1 : 0,M s rušením | BWOBJECT bw09inst1 bw09inst2 |

Indexy

Název | Primární | Výraz | Popis
ix_BWOBJECT_bw09k1 |  | bw09inst1, bw09typ1 |
ix_BWOBJECT_bw09k2 |  | bw09inst2, bw09typ2 |
ix_BWOBJECT_bw09inst2 |  | bw09inst2 |
ix_BWOBJECT_bw09prim | P | bw09inst1, bw09inst2 |
ix_BWOBJECT_bw09k3 |  | bw09inst1, bw09typ1, bw09typ2 |
ix_BWOBJECT_bw09k4 |  | bw09inst2, bw09typ2, bw09typ1 |


BWOBJECX Popis vazby objektů

Popis

Popis vazby objektů

Atributy

Atribut | Typ | Návěští | Message | Popis
bw98 | C(12) | bw98 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
bw09inst1 | C(12) | bw09inst1 | Jednoznačný časový identifikátor instance objektu typu 1. |
bw09inst2 | C(12) | bw09inst2 |  |
bw98obsah | M | bw98obsah | Obsah popisu vazby | Obsah popisu vazby

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis vazby objektů - popisuje vazbu objektů | BWOBJECX bw09inst1 bw09inst2 | 1,1 : 0,M s rušením | BWOBJECT bw09inst1 bw09inst2 |

Indexy

Název | Primární | Výraz | Popis
ix_BWOBJECX_bw98 | P | bw98 | Jednoznačná časová identifikace
ix_BWOBJECX_bw09prim |  | bw09inst1, bw09inst2 |


BWODBOR Skupina uživatelů

Popis

Skupina uživatelů

Atributy

Atribut | Typ | Návěští | Message | Popis
bw05ident | C(6) | Skupina | Identifikace skupiny uživatelů | Identifikace skupiny uživatelů
bw05popis | C(30) | Název skupiny uživatelů | Název skupiny uživatelů | Název skupiny uživatelů
bw05koment | M | Poznámka | Poznámka ke skupině uživatelů | Poznámka ke skupině uživatelů
bw01aktiv | N(1,0) | bw01aktiv | Aktivní uživatel (tj. smí se přihlásit do systému) | Aktivní uživatel (tj. smí se přihlásit do systému)
bw01us | N(1,0) | Typ | Uživatel / skupina uživatelů | Uživatel / skupina uživatelů

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Skupina uživatelů výběru vstupem - má jméno | BWMENPOD bw05ident | 1,1 : 0,M s rušením | BWODBOR bw05ident |
Paleta barev kategorií artiklu - je používána skupinou uživatelů | SAPALETA bw05ident | 1,1 : 0,M | BWODBOR bw05ident |
Paleta barev kategorií pracovníků - je používána skupinou uživatelů | MZPALETA bw05ident | 1,1 : 0,M | BWODBOR bw05ident |
Paleta barev kategorií adresáta - je používána skupinou uživatelů | ADPALETA bw05ident | 1,1 : 0,M | BWODBOR bw05ident |
Zařazení uživatele to skupiny uživatelů - váže odbornost | BWOVAZBA bw05ident | 1,1 : 0,M s rušením | BWODBOR bw05ident |
Právo odbornosti k činnosti - je odbornosti | BWCIODB bw05ident | 1,1 : 0,M s rušením | BWODBOR bw05ident |
Druh operace v druhu procesu - má určenou skupinu uživatelů, která ji smí ukončit | SPTYPOD bw05ident | 0,1 : 0,M | BWODBOR bw05ident |
Vazba druhů operací v druhu procesu - bude rozhodnuta skupinou uživatelů | SPTYPVO bw05ident | 0,1 : 0,M | BWODBOR bw05ident |
Operace procesu - má určenou skupinu uživatelů, která ji smí ukončit | SPPRCOD bw05ident | 0,1 : 0,M | BWODBOR bw05ident |
Vazba operací v procesu - bude rozhodnuta skupinou uživatelů | SPPRCVO bw05ident | 0,1 : 0,M | BWODBOR bw05ident |
Přístupové právo skupiny uživatelů k věci - souvisí se skupinou uživatelů | SPPRISTS bw05ident | 1,1 : 0,M s rušením | BWODBOR bw05ident |
Barvy kategori\í - patří skupině | ADKATBAR bw05ident | 1,1 : 0,M | BWODBOR bw05ident |

Indexy

Název | Primární | Výraz | Popis
ix_BWODBOR_bw05ident | P | bw05ident | Identifikace skupiny uživatelů
ix_BWODBOR_bw05popis |  | bw05popis | Název skupiny uživatelů


BWOKROKY Definice oprávnění k činnosti

Popis

Definice oprávnění k činnosti

Atributy

Atribut | Typ | Návěští | Message | Popis
bw05ident | C(6) | Skupina | Identifikace skupiny uživatelů | Identifikace skupiny uživatelů
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw07krok | C(6) | bw07krok | Identifikace činnosti, ze které je krok bw02krok volán v případě lokání ochrany heslem | Identifikace činnosti, ze které je krok bw02krok volán v případě lokání ochrany heslem
bw07prist | N(1,0) | bw07prist | Přístup k činnosti povolen ? | Přístup k činnosti povolen ?
bw07vklad | N(1,0) | bw07vklad | Je v činnosti povoleno vkládání ? | Je v činnosti povoleno vkládání ?
bw07oprava | N(1,0) | bw07oprava | Je v činnosti povolena oprava ? | Je v činnosti povolena oprava ?
bw07ruseni | N(1,0) | bw07ruseni | Je v činnosti povoleno rušení ? | Je v činnosti povoleno rušení ?

Indexy

Název | Primární | Výraz | Popis
ix_BWOKROKY_bwokroky | P | bw05ident, bw02krok, bw07krok | Index k definici oprávnění k činnosti


BWOPTIOC Nastavení programu BM pro počítač uživatele BM nebo datové úložiště

Popis

Nastavení programu BM pro počítač uživatele BM nebo datové úložiště

Atributy

Atribut | Typ | Návěští | Message | Popis
bw90sect | C(20) | Sekce | Sekce nastavení | Sekce nastavení
bw90id | C(40) | Parametr | Identifikátor nastavení | Identifikátor nastavení
bw91idu | C(2) | IDÚ | Identifikace datového úložiště | Identifikace datového úložiště
bw87id | C(6) | Počítač | Identifikace počítače v BM | Identifikace počítače v BM
bw91value | C(80) | Hodnota | Hodnota parametru nastavení | Hodnota parametru nastavení
bw91porad | N(3,0) | Pořadí | Pořadí vyhodnocení | Pořadí vyhodnocení

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Nastavení programu BM pro počítač uživatele BM nebo datové úložiště - se týká nastavení | BWOPTIOC bw90sect bw90id | 1,1 : 0,M | BWOPTION bw90sect bw90id |
Nastavení programu BM pro počítač uživatele BM nebo datové úložiště - se týká počítače uživatele BM | BWOPTIOC bw87id | 1,1 : 0,M | BWPRINMC bw87id |

Indexy

Název | Primární | Výraz | Popis
ix_BWOPTIOC_bwoptioc | P | bw90sect, bw90id, bw91idu, bw87id | PI - BWOPTION+bw91idu+bw87id
ix_BWOPTIOC_bwoption |  | bw90sect, bw90id | PI - bw90sect+bw90id
ix_BWOPTIOC_bw87id |  | bw87id | Identifikace počítače v BM


BWOPTION Nastavení programu BM

Popis

Nastavení programu BM

Atributy

Atribut | Typ | Návěští | Message | Popis
bw90sect | C(20) | Sekce | Sekce nastavení | Sekce nastavení
bw90id | C(40) | Parametr | Identifikátor nastavení | Identifikátor nastavení
bw90local | N(1,0) | Lokální | Je možné lokální nastavení ? | Je možné lokální nastavení ?
bw90value | C(80) | Hodnota | Hodnota parametru nastavení | Hodnota parametru nastavení
bw90defval | C(80) | Default | Default hodnota nastavení | Default hodnota nastavení
bw90koment | M | Popis nastavení | Popis nastavení | Popis nastavení
bw90cid | C(10) | bw90cid | Jednoznačná identifikace v Galaxii | Jednoznačná identifikace v Galaxii
bw90bwini | N(1,0) | Pouze BW.INI | Nastavení musí být provedeno v BW.INI | Nastavení musí být provedeno v BW.INI
bw90datakt | T | Aktualizace | Datum vzniku nebo aktualizace parametru u dodavatele systému | Datum aktualizace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Nastavení programu BM pro počítač uživatele BM nebo datové úložiště - se týká nastavení | BWOPTIOC bw90sect bw90id | 1,1 : 0,M | BWOPTION bw90sect bw90id |

Indexy

Název | Primární | Výraz | Popis
ix_BWOPTION_bwoption | P | bw90sect, bw90id | PI - bw90sect+bw90id
ix_BWOPTION_bw90value |  | bw90value | Hodnota parametru nastavení
ix_BWOPTION_bw90datakt |  | bw90datakt | Datum aktualizace


BWOVAZBA Zařazení uživatele to skupiny uživatelů

Popis

Zařazení uživatele to skupiny uživatelů

Atributy

Atribut | Typ | Návěští | Message | Popis
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw05ident | C(6) | Skupina | Identifikace skupiny uživatelů | Identifikace skupiny uživatelů

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Zařazení uživatele to skupiny uživatelů - váže odbornost | BWOVAZBA bw05ident | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Zařazení uživatele to skupiny uživatelů - Patří uživateli | BWOVAZBA bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_BWOVAZBA_bwovazba | P | bw01uziv, bw05ident | identifikace uživatele + skupina - Index vazby skupiny
ix_BWOVAZBA_bwovazba2 | P | bw05ident, bw01uziv | skupina + uživatel - Index vazby skupiny
ix_BWOVAZBA_bw05ident |  | bw05ident | Identifikace skupiny uživatelů
ix_BWOVAZBA_bw01uziv |  | bw01uziv | Identifikace uživatele systému


BWOVAZBS Zařazení uživatele to skupiny uživatelů - skutečná

Popis

Zařazení uživatele to skupiny uživatelů - skutečná

Atributy

Atribut | Typ | Návěští | Message | Popis
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw05ident | C(6) | Skupina | Identifikace skupiny uživatelů | Identifikace skupiny uživatelů
bwa4uroven | N(3,0) | Úroveň | Úroveň vztahu | Úroveň vztahu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Zařazení uživatele to skupiny uživatelů - skutečná - určuje uživatele | BWOVAZBS bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Zařazení uživatele to skupiny uživatelů - skutečná - určuje skupinu | BWOVAZBS bw05ident | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_BWOVAZBS_bwovazba | P | bw01uziv, bw05ident | identifikace uživatele + skupina - Index vazby skupiny
ix_BWOVAZBS_bw05ident |  | bw05ident | Identifikace skupiny uživatelů
ix_BWOVAZBS_bw01uziv |  | bw01uziv | Identifikace uživatele systému


BWOZMCR Makro výrazů

Popis

Makro výrazů

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw78id | C(6) | ID | Interní identifikace makra | Interní identifikace makra
bw80id | C(6) | Druh | Identifikátor druhu makra | Identifikátor druhu makra
bw78nazev | C(40) | Makro | Název makra | Název makra
bw78templa | M | Template | Template makra | Template makra
bw78vyraz | M | Výraz | Výraz makra | Výraz makra
bw78koment | M | Poznámka | Poznámka | Poznámka
bw78typ | N(1,0) | Typ | Typ hodnoty makra | Typ hodnoty makra
bw78from | M | From | Doplnění tabulek do SQL dotazu za FROM | Doplnění tabulek do SQL dotazu za FROM
bw78propar | N(1,0) | Proměnné | Parametry makra jsou proměnné Ano/Ne | Parametry makra jsou proměnné Ano/Ne

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Makro výrazů - je druhu | BWOZMCR bw80id | 1,1 : 0,M | BWOZMCRD bw80id |
Parametr makra výrazů - je parametrem makra | BWOZMCRP bw02krok bw78id | 1,1 : 0,M s rušením | BWOZMCR bw02krok bw78id |

Indexy

Název | Primární | Výraz | Popis
ix_BWOZMCR_bwozmcr | P | bw02krok, bw78id | PI - bw02krok+bw78id
ix_BWOZMCR_bw78id |  | bw78id | Interní identifikace makra
ix_BWOZMCR_bw80id |  | bw80id | Identifikátor druhu makra
ix_BWOZMCR_bw78nazev |  | bw78nazev | Název makra


BWOZMCRD Druh makra výrazů

Popis

Druh makra výrazů

Atributy

Atribut | Typ | Návěští | Message | Popis
bw80id | C(6) | Druh | Identifikátor druhu makra | Identifikátor druhu makra
bw80drumcr | C(40) | Název druhu makra | Název druhu makra | Název druhu makra
bw80koment | M | Poznámka | Poznámka | Poznámka
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw80datum | T | Datum vzniku | Datum založení druhu makra | Datum založení druhu makra

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh makra výrazů - založil uživatel | BWOZMCRD bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Makro výrazů - je druhu | BWOZMCR bw80id | 1,1 : 0,M | BWOZMCRD bw80id |

Indexy

Název | Primární | Výraz | Popis
ix_BWOZMCRD_bw80id | P | bw80id | Identifikátor druhu makra
ix_BWOZMCRD_bw80drumcr |  | bw80drumcr | Název druhu makra
ix_BWOZMCRD_bw01uziv |  | bw01uziv | Identifikace uživatele systému


BWOZMCRP Parametr makra výrazů

Popis

Parametr makra výrazů

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw78id | C(6) | ID | Interní identifikace makra | Interní identifikace makra
bw79porad | N(2,0) | Pořadí | Pořadí parametru | Pořadí parametru
bw79nazev | C(8) | Parametr | Název parametru | Název parametru
bw79typ | N(1,0) | Typ | Typ parametru | Typ parametru
bw79delka | N(3,0) | Délka | Délka hodnoty parametru | Délka hodnoty parametru
bw79deseti | N(1,0) | Des. | Počet desetin parametru |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametr makra výrazů - je parametrem makra | BWOZMCRP bw02krok bw78id | 1,1 : 0,M s rušením | BWOZMCR bw02krok bw78id |

Indexy

Název | Primární | Výraz | Popis
ix_BWOZMCRP_bwozmcrp | P | bw02krok, bw78id, bw79porad | PI - BWOZMCR+bw79porad
ix_BWOZMCRP_bwozmcr |  | bw02krok, bw78id | PI - bw02krok+bw78id


BWOZNAC Označený objekt

Popis

Označený objekt

Atributy

Atribut | Typ | Návěští | Message | Popis
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw51 | C(10) | bw51 | Identifikace typu objektu | Identifikace typu objektu
bw51ob | C(12) | bw51ob | Časová identifikace objektu | Časová identifikace objektu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Označený objekt - patří uživateli | BWOZNAC bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_BWOZNAC_bwoznac | P | bw01uziv, bw51, bw51ob |
ix_BWOZNAC_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_BWOZNAC_bw51 |  | bw51 | Identifikace typu objektu
ix_BWOZNAC_bw51ob |  | bw51ob | Časová identifikace objektu


BWOZVRZ Výraz označování výběrem

Popis

Výraz označování výběrem

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw77 | C(12) | bw77 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
bw77popvrz | C(40) | Popis výrazu | Popis výrazu označování | Popis výrazu označování
bw77vyraz | M | Výraz | Výraz označování | Výraz označování
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Výraz označování výběrem - patří uživateli | BWOZVRZ bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_BWOZVRZ_bwozvrz | P | bw02krok, bw77 | PI - bw02krok+bw77
ix_BWOZVRZ_bw01uziv |  | bw01uziv | Identifikace uživatele systému


BWPRINMC Počítač uživatele systému BM

Popis

Počítač uživatele systému BM

Atributy

Atribut | Typ | Návěští | Message | Popis
bw87id | C(6) | Počítač | Identifikace počítače v BM | Identifikace počítače v BM
bw87nazpoc | C(40) | Název počítače | Název počítače v BM | Název počítače v BM musí být uveden
bw87sysid | C(60) | Název WINDOWS | Úplný název počítače ve WINDOWS | Úplný název počítače ve WINDOWS
bw83id | C(6) | Pracoviště | Identifikace pracoviště uživatele BM | Identifikace pracoviště uživatele BM
bw87koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Počítač uživatele systému BM - je na pracovišti | BWPRINMC bw83id | 1,1 : 0,M | BWPRINMP bw83id |
Fyzická tiskárna - je lokální tiskárnou počítače | BWPRINMF bw87id | 1,1 : 0,M | BWPRINMC bw87id |
Nastavení programu BM pro počítač uživatele BM nebo datové úložiště - se týká počítače uživatele BM | BWOPTIOC bw87id | 1,1 : 0,M | BWPRINMC bw87id |
Skupina archivace - může být použita při spuštění z počítače | UTARSKP bw87id | 1,1 : 0,M | BWPRINMC bw87id |

Indexy

Název | Primární | Výraz | Popis
ix_BWPRINMC_bw87id | P | bw87id | Identifikace počítače v BM
ix_BWPRINMC_bw87nazpoc |  | bw87nazpoc | Název počítače v BM musí být uveden
ix_BWPRINMC_bw87sysid |  | bw87sysid | Úplný název počítače ve WINDOWS
ix_BWPRINMC_bw83id |  | bw83id | Identifikace pracoviště uživatele BM


BWPRINME Řídící kód negrafické tiskárny

Popis

Řídící kód negrafické tiskárny

Atributy

Atribut | Typ | Návěští | Message | Popis
bw96id | C(6) | ID | Identifikace řídícího kódu tiskárny | Identifikace řídícího kódu tiskárny
bw97id | C(6) | Typ | Identifikace typu fyzické tiskárny | Identifikace typu fyzické tiskárny
bw96popis | C(40) | Popis | Popis kódu pro tiskárnu | Popis kódu pro tiskárnu
bw96kod | C(40) | Kód | Kód pro tiskárnu (hexa) | Kód pro tiskárnu (hexa)
bw96koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Řídící kód negrafické tiskárny - je kódem typu tiskárny | BWPRINME bw97id | 1,1 : 0,M | BWPRINMT bw97id |

Indexy

Název | Primární | Výraz | Popis
ix_BWPRINME_bwprinme | P | bw96id, bw97id | PI - bw96id+bw97id
ix_BWPRINME_bw97id |  | bw97id | Identifikace typu fyzické tiskárny


BWPRINMF Fyzická tiskárna

Popis

Fyzická tiskárna

Atributy

Atribut | Typ | Návěští | Message | Popis
bw84id | C(6) | F-Tiskárna | Identifikace fyzické tiskárny | Identifikace fyzické tiskárny
bw97id | C(6) | Typ | Identifikace typu fyzické tiskárny | Identifikace typu fyzické tiskárny
bw84fyztis | C(40) | Název BM | Název tiskárny v BM | Název tiskárny v BM
bw84sysid | C(60) | Název WINDOWS | Název tiskárny ve WINDOWS | Název tiskárny ve WINDOWS
bw84sysidl | C(60) | Lokální název WIN | Název tiskárny ve WINDOWS na lokálním počítači | Název tiskárny ve WINDOWS na lokálním počítači
bw87id | C(6) | Počítač | Identifikace počítače v BM | Identifikace počítače v BM
bw84aktiv | N(1,0) | Aktivní | Tiskárna nastavena pro výstup Ano,Ne | Tiskárna nastavena pro výstup Ano,Ne
bw84koment | M | Poznámka | Poznámka | Poznámka
bw84expr | M | Popis tiskárny | Popis tiskárny | Popis tiskárny
bw84tag | M | bw84tag | Popis výstupní tiskárny v reportu FoxPro | Popis výstupní tiskárny v reportu FoxPro
bw84tag2 | M | bw84tag2 | Popis výstupní tiskárny v reportu FoxPro | Popis výstupní tiskárny v reportu FoxPro
bw84exprl | M | Popis tiskárny | Popis tiskárny | Popis tiskárny
bw84tagl | M | bw84tagl | Popis výstupní tiskárny v reportu FoxPro | Popis výstupní tiskárny v reportu FoxPro
bw84tag2l | M | bw84tag2l | Popis výstupní tiskárny v reportu FoxPro | Popis výstupní tiskárny v reportu FoxPro
bw84gratis | N(1,0) | Grafická | Grafická tiskárna Ano/Ne - Ne = např.jehličková tiskárna - vyžaduje uzpůsobené předlohy výstupu | Grafická tiskárna Ano/Ne - Ne = např.jehličková tiskárna - vyžaduje uzpůsobené předlohy výstupu
bw84cppage | N(4,0) | CP | Kódová stránka negrafické tiskárny | Kódová stránka negrafické tiskárny
bw84kodini | C(40) | Init.kód | Inicializační kód negrafické tiskárny (hexa) | Inicializační kód negrafické tiskárny
bw84cols | N(5,0) | Sloupců | Počet sloupců negrafické tiskárny | Počet sloupců negrafické tiskárny
bw84rows | N(5,0) | Řádků | Počet řádků negrafické tiskárny | Počet řádků negrafické tiskárny
bw84debug | N(1,0) | Testovací mód | Testovací mód - výstup na negrafickou tiskárnu bude prováděn do souboru | Testovací mód - výstup na negrafickou tiskárnu bude prováděn do souboru

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Fyzická tiskárna - je lokální tiskárnou počítače | BWPRINMF bw87id | 1,1 : 0,M | BWPRINMC bw87id |
Fyzická tiskárna - je typu | BWPRINMF bw97id | 1,1 : 0,M | BWPRINMT bw97id |
Logická tiskárna pracoviště - odpovídá fyzické tiskárně | BWPRINMV bw84id | 1,1 : 0,M | BWPRINMF bw84id |

Indexy

Název | Primární | Výraz | Popis
ix_BWPRINMF_bw84id | P | bw84id | Identifikace fyzické tiskárny
ix_BWPRINMF_bw97id |  | bw97id | Identifikace typu fyzické tiskárny
ix_BWPRINMF_bw84fyztis |  | bw84fyztis | Název tiskárny v BM
ix_BWPRINMF_bw84sysid |  | bw84sysid | Název tiskárny ve WINDOWS
ix_BWPRINMF_bw87id |  | bw87id | Identifikace počítače v BM


BWPRINML Logická tiskárna systému BM

Popis

Logická tiskárna systému BM

Atributy

Atribut | Typ | Návěští | Message | Popis
bw85id | C(6) | L-Tiskárna | Identifikace logické tiskárny systému BM | Identifikace logické tiskárny systému BM
bw85logtis | C(40) | Název logické tiskárny | Název logické tiskárny | Název logické tiskárny
bw85koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Logická tiskárna pracoviště - patří k logické tiskárně | BWPRINMV bw85id | 1,1 : 0,M | BWPRINML bw85id |
Předloha pro výstup - vystupuje na logickou tiskárnu BM | BWPRINTD bw85id | 0,1 : 0,M | BWPRINML bw85id |

Indexy

Název | Primární | Výraz | Popis
ix_BWPRINML_bw85id | P | bw85id | Identifikace logické tiskárny systému BM
ix_BWPRINML_bw85logtis |  | bw85logtis | Název logické tiskárny


BWPRINMP Pracoviště uživatele systému BM

Popis

Pracoviště uživatele systému BM

Atributy

Atribut | Typ | Návěští | Message | Popis
bw83id | C(6) | Pracoviště | Identifikace pracoviště uživatele BM | Identifikace pracoviště uživatele BM
bw83nazpra | C(40) | Název pracoviště | Název pracoviště | Název pracoviště
bw83koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Logická tiskárna pracoviště - patří k pracovišti | BWPRINMV bw83id | 1,1 : 0,M | BWPRINMP bw83id |
Počítač uživatele systému BM - je na pracovišti | BWPRINMC bw83id | 1,1 : 0,M | BWPRINMP bw83id |

Indexy

Název | Primární | Výraz | Popis
ix_BWPRINMP_bw83id | P | bw83id | Identifikace pracoviště uživatele BM
ix_BWPRINMP_bw83nazpra |  | bw83nazpra | Název pracoviště


BWPRINMT Typ fyzické tiskárny

Popis

Typ fyzické tiskárny

Atributy

Atribut | Typ | Návěští | Message | Popis
bw97id | C(6) | Typ | Identifikace typu fyzické tiskárny | Identifikace typu fyzické tiskárny
bw97naztyp | C(40) | Název typu | Název typu fyzické tiskárny | Název typu fyzické tiskárny
bw97koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Fyzická tiskárna - je typu | BWPRINMF bw97id | 1,1 : 0,M | BWPRINMT bw97id |
Řídící kód negrafické tiskárny - je kódem typu tiskárny | BWPRINME bw97id | 1,1 : 0,M | BWPRINMT bw97id |

Indexy

Název | Primární | Výraz | Popis
ix_BWPRINMT_bw97id | P | bw97id | Identifikace typu fyzické tiskárny
ix_BWPRINMT_bw97naztyp |  | bw97naztyp | Název typu fyzické tiskárny


BWPRINMV Logická tiskárna pracoviště

Popis

Logická tiskárna pracoviště

Atributy

Atribut | Typ | Návěští | Message | Popis
bw85id | C(6) | L-Tiskárna | Identifikace logické tiskárny systému BM | Identifikace logické tiskárny systému BM
bw83id | C(6) | Pracoviště | Identifikace pracoviště uživatele BM | Identifikace pracoviště uživatele BM
bw84id | C(6) | F-Tiskárna | Identifikace fyzické tiskárny | Identifikace fyzické tiskárny

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Logická tiskárna pracoviště - patří k pracovišti | BWPRINMV bw83id | 1,1 : 0,M | BWPRINMP bw83id |
Logická tiskárna pracoviště - patří k logické tiskárně | BWPRINMV bw85id | 1,1 : 0,M | BWPRINML bw85id |
Logická tiskárna pracoviště - odpovídá fyzické tiskárně | BWPRINMV bw84id | 1,1 : 0,M | BWPRINMF bw84id |

Indexy

Název | Primární | Výraz | Popis
ix_BWPRINMV_bwprinmv | P | bw85id, bw83id | PI - bw85id+bw83id
ix_BWPRINMV_bw84id |  | bw84id | Identifikace fyzické tiskárny
ix_BWPRINMV_bw85id |  | bw85id | Identifikace logické tiskárny systému BM
ix_BWPRINMV_bw83id |  | bw83id | Identifikace pracoviště uživatele BM


BWPRINS Metapředloha výstupu

Popis

Metapředloha výstupu pro tisk z procesů

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw81id | C(6) | MPV | Identifikace metapředlohy výstupu | Identifikace makropředlohy výstupu
bw66id | C(6) | Druh | Identifikace druhu předlohy | Identifikace druhu předlohy
sp79id | C(6) | Skupina | Identifikace skupiny procesů | Identifikace skupiny procesů
bw81skupre | C(40) | Název metapředlohy | Název metapředlohy výstupu | Název makropředlohy výstupu
bw81koment | M | Poznámka | Poznámka | Poznámka
bw81nabiz | N(1,0) | Nabízet | Nabízet v seznamu předloh výstupu formulářů | Nabízet v seznamu předloh

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Metapředloha výstupu - je druhu | BWPRINS bw66id | 1,1 : 0,M | BWPRINTT bw66id |
Metapředloha výstupu - patří do skupiny | BWPRINS sp79id | 0,1 : 0,M | SPTYPFOL sp79id |
Předloha výstupu v makropředloze - patří k předloze výstupu | BWPRINSP bw02krok bw81id | 1,1 : 0,M s rušením | BWPRINS bw02krok bw81id |
Doplňující vlastnost formuláře - spouští metapředlohu | SPCINDV bw02krokx bw81id | 0,1 : 0,M | BWPRINS bw02krok bw81id |
Parametr činnosti menu - určuje metapředlohu výstupu volanou na klávesu F12 | BWMENPAR bw02krok bw81id | 0,1 : 0,M | BWPRINS bw02krok bw81id |
Druh procesu/operace - tiskne doklad metapředlohou výstupu | SPTYP bw02krok bw81id | 0,1 : 0,M | BWPRINS bw02krok bw81id |
Druh operace v druhu procesu - tiskne metapředlohou výstupu | SPTYPOD bw02krok bw81id | 0,1 : 0,M | BWPRINS bw02krok bw81id |
Operace procesu - tiskne metapředlohou výstupu | SPPRCOD bw02krok bw81id | 0,1 : 0,M | BWPRINS bw02krok bw81id |

Indexy

Název | Primární | Výraz | Popis
ix_BWPRINS_bwprins | P | bw02krok, bw81id | PI - bw02krok+bw81id
ix_BWPRINS_bw02krok |  | bw02krok | Identifikace činnosti
ix_BWPRINS_bw66id |  | bw66id | Identifikace druhu předlohy
ix_BWPRINS_sp79id |  | sp79id | Identifikace skupiny procesů
ix_BWPRINS_bw81skupre |  | bw81skupre | Název makropředlohy výstupu


BWPRINSP Předloha výstupu v makropředloze

Popis

Předloha výstupu v makropředloze

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw81id | C(6) | MPV | Identifikace metapředlohy výstupu | Identifikace makropředlohy výstupu
bw82porad | N(2,0) | Poř. | Pořadí předlohy v metapředloze | Pořadí předlohy v makropředloze
bw04ident | C(10) | Ident. | Identifikace předlohy pro výstup | Identifikace předlohy pro výstup
bw71id | C(3) | Profil | Identifikace profilu spuštění předlohy | Identifikace profilu spuštění předlohy
bw82nazev | C(40) | Popis | Popis předlohy v metapředloze | Popis předlohy v makropředloze
bw82kopie | N(2,0) | Počet kopií | Počet kopií | Počet kopií
bw82tiskar | M | Tiskárna | Výstupní tiskárna při přímém výstupu předlohou typu Excel | Výstupní tiskárna při přímém výstupu předlohou typu Excel
bw82rozhod | N(1,0) | Rozhodnutí | Uživatel rozhodne o výstupu | Uživatel rozhodne o výstupu
bw82podmin | M | Podmínka | Podmínka výstupu předlohou | Podmínka výstupu předlohou
bw82profil | N(1,0) | Použít profil | Použít profil předlohy (ne=v procesech podle parametrů předlohy) | Použít profil předlohy (ne=podle parametrů předlohy)
sp38id | C(3) | Jazyk | Identifikace jazyka | Identifikace jazyka
bw82pluspa | M | Parametr | Parametr předaný předloze | Parametr předaný předloze

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Předloha výstupu v makropředloze - patří k předloze výstupu | BWPRINSP bw02krok bw81id | 1,1 : 0,M s rušením | BWPRINS bw02krok bw81id |
Předloha výstupu v makropředloze - určuje výstup předlohou výstupu | BWPRINSP bw02krok bw04ident | 1,1 : 0,M | BWPRINTD bw02krok bw04ident |
Předloha výstupu v makropředloze - používá pro výstup profil výstupu | BWPRINSP bw71id | 1,1 : 0,M | BWPRINTC bw71id |
Předloha výstupu v makropředloze - bude tisknout jazykem | BWPRINSP sp38id | 0,1 : 0,M | SPJAZYK sp38id |

Indexy

Název | Primární | Výraz | Popis
ix_BWPRINSP_bwprinsp | P | bw02krok, bw81id, bw82porad | PI - BWPRINS+bw82porad
ix_BWPRINSP_bwprins |  | bw02krok, bw81id | PI - bw02krok+bw81id
ix_BWPRINSP_bw04printd |  | bw02krok, bw04ident | Primární klíč předlohy pro výstup BW02krok+BW04ident
ix_BWPRINSP_bw71id |  | bw71id | Identifikace profilu spuštění předlohy
ix_BWPRINSP_sp38id |  | sp38id | Identifikace jazyka


BWPRINTA Příloha předlohy výstupu

Popis

Příloha předlohy výstupu

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw04ident | C(10) | Ident. | Identifikace předlohy pro výstup | Identifikace předlohy pro výstup
bwb0nazev | C(80) | bwb0nazev | Název souboru templatu | Název souboru templatu
bwb1koment | M | bwb1koment |  |
bwb1typ | N(1,0) | bwb1typ | Typ přílohy Soubor/Volná karta | Typ přílohy Soubor/Volná karta

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Příloha předlohy výstupu - patří k předloze | BWPRINTA bw02krok bw04ident | 1,1 : 0,M s rušením | BWPRINTD bw02krok bw04ident |
Příloha předlohy výstupu - používá ZIP soubor | BWPRINTA bwb0nazev | 1,1 : 0,M | BWZIPFIL bwb0nazev |

Indexy

Název | Primární | Výraz | Popis
ix_BWPRINTA_bwprinta | P | bw02krok, bw04ident, bwb0nazev | PI - BW04PRINTD+bwb0nazev
ix_BWPRINTA_bw04printd |  | bw02krok, bw04ident | Primární klíč předlohy pro výstup BW02krok+BW04ident
ix_BWPRINTA_bwb0nazev |  | bwb0nazev | Název souboru templatu


BWPRINTC Profil spuštění předlohy výstupu

Popis

Profil spuštění předlohy výstupu

Atributy

Atribut | Typ | Návěští | Message | Popis
bw71id | C(3) | Profil | Identifikace profilu spuštění předlohy | Identifikace profilu spuštění předlohy
bw71nazpro | C(40) | Název profilu | Název profilu | Název profilu
bw71koment | M | Poznámka | Poznámka | Poznámka
bw71iakce | N(1,0) | Ikona | Reakce na vyvolání předlohy ikonou | Reakce na vyvolání předlohy ikonou
bw71i1druh | N(1,0) | Sestava | Způsob výstupu pro typ předlohy Sestava aktivací ikonou | Způsob výstupu pro typ předlohy Sestava aktivací ikonou
bw71i2druh | N(1,0) | Excel | Způsob výstupu pro typ předlohy Excel aktivací ikonou | Způsob výstupu pro typ předlohy Excel aktivací ikonou
bw71i3druh | N(1,0) | Word | Způsob výstupu pro typ předlohy Word aktivací ikonou | Způsob výstupu pro typ předlohy Word aktivací ikonou
bw71idotaz | N(1,0) | bw71idotaz | Vyvolat nastavení tisku pro výstupy typu Sestava aktivací ikonou | Vyvolat nastavení tisku pro výstupu typu Sestava aktivací ikonou
bw71dakce | N(1,0) | Dvojklik | Reakce na vyvolání předlohy dvojklikem | Reakce na vyvolání předlohy dvojklikem
bw71d1druh | N(1,0) | Sestava | Způsob výstupu pro typ předlohy Sestava aktivací dvojklikem | Způsob výstupu pro typ předlohy Sestava aktivací dvojklikem
bw71d2druh | N(1,0) | Excel | Způsob výstupu pro typ předlohy Excel aktivací dvojklikem | Způsob výstupu pro typ předlohy Excel aktivací dvojklikem
bw71d3druh | N(1,0) | Word | Způsob výstupu pro typ předlohy Word aktivací dvojklikem | Způsob výstupu pro typ předlohy Word aktivací dvojklikem
bw71ddotaz | N(1,0) | bw71ddotaz | Vyvolat nastavení tisku pro výstupy typu Sestava aktivací dvojklikem | Vyvolat nastavení tisku pro výstupy typu Sestava aktivací dvojklikem
bw71iwrsig | N(1,0) | Digitální podpis | Připojit digitální podpis k vytvořenénu dokumentu | Připojit digitální podpis k vytvořenénu dokumentu
bw71iwrema | N(1,0) | Příprava e-mail | Příprava e-mailu vytvořeného dokumentu | Příprava e-mailu vytvořeného dokumentu
bw71iwrbin | N(1,0) | Dokument BM | Uložení vytvořeného dokumentu Wordu jako dokumentu BM | Uložení vytvořeného dokumentu Wordu jako dokumentu BM
bw71dwrsig | N(1,0) | Digitální podpis | Připojit digitální podpis k vytvořenénu dokumentu | Připojit digitální podpis k vytvořenénu dokumentu
bw71dwrema | N(1,0) | Příprava e-mail | Příprava e-mailu vytvořeného dokumentu | Příprava e-mailu vytvořeného dokumentu
bw71dwrbin | N(1,0) | Dokument BM | Uložení vytvořeného dokumentu Wordu jako dokumentu BM | Uložení vytvořeného dokumentu Wordu jako dokumentu BM
bw71param | M | Parametr | Parametr profilu dostupný při výstupu předlohou výstupu | Parametr profilu dostupný při výstupu předlohou výstupu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Předloha výstupu v makropředloze - používá pro výstup profil výstupu | BWPRINSP bw71id | 1,1 : 0,M | BWPRINTC bw71id |
Předloha pro výstup - Používá profil spuštění | BWPRINTD bw71id | 1,1 : 0,M | BWPRINTC bw71id |

Indexy

Název | Primární | Výraz | Popis
ix_BWPRINTC_bw71id | P | bw71id | Identifikace profilu spuštění předlohy
ix_BWPRINTC_bw71nazpro |  | bw71nazpro | Název profilu


BWPRINTD Předloha pro výstup

Popis

Předloha pro výstup

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw04ident | C(10) | Ident. | Identifikace předlohy pro výstup | Identifikace předlohy pro výstup
bw04filt | C(10) | bw04filt | Identifikace filtru předlohy | Identifikace filtru předlohy
sp79id | C(6) | Skupina | Identifikace skupiny procesů | Identifikace skupiny procesů
bw04nazev | C(30) | Název předlohy | Název předlohy pro výstup | Název předlohy pro výstup
bw04typ | N(1,0) | bw04typ | Určení typu výstupu | Určení typu výstupu
bw04ver | N(6,3) | bw04ver | Verze předlohy výstupu | Verze předlohy výstupu
sp00jmeakt | C(40) | Změnil | Jméno uživatele systému, který změnil záznam | Jméno uživatele systému, který změnil záznam
bw04edit | L | bw04edit | Povolení opravy tiskové předlohy | Povolení opravy tiskové předlohy
bw04tisk1 | N(1,0) | bw04tisk1 | Tisk pouze aktuálního záznamu ? | Příznak pro tisk pouze aktuálního záznamu
bw04sumar | N(1,0) | bw04sumar | Tisk pouze součtových řádků | Tisk pouze součtových řádků
bw04frxc | C(10) | bw04frxc | Časová identifikace změny předlohy | Časová identifikace změny předlohy
bw04frx1 | M | bw04frx1 | Uložení 1.části definice tisku .FRX | Uložení 1.části definice tisku .FRX
bw04frx2 | M | bw04frx2 | Uložení 2.části definice tisku .FRT | Uložení 2.části definice tisku .FRT
bw04excelc | C(10) | bw04excelc | Časová identifikace změny předlohy - EXCEL | Časová identifikace změny předlohy - EXCEL
bw04excel | M | bw04excel | Textový popis definice pro výstup do EXCEL | Textový popis definice pro výstup do EXCEL
bw04popis | M | Poznámka | Poznámka k předloze pro výstup | Poznámka k předloze pro výstup
bw04order | C(10) | bw04order | Určení třídění pro výstup | Určení třídění pro výstup
bw04skip | M | bw04skip | Popis set skip pro tisk | Popis set skip pro tisk
bw04vznik | T | bw04vznik | Datum vzniku předlohy pro výstup | Datum vzniku předlohy pro výstup
bw04verze | N(2,0) | bw04verze | Verze subsystému ve které byla předloha vytvořena | Verze subsystému ve které byla předloha vytvořena
bw04lbx1 | M | bw04lbx1 | Uložení 1.části definice tisku nálepky | Uložení 1.části definice tisku nálepky
bw04lbx2 | M | bw04lbx2 | Uložení 2.části definice tisku nálepky | Uložení 2.části definice tisku nálepky
bw04podm | M | Podmínka | Výběrová podmínka pro výstup | Výběrová podmínka pro výstup
bw04 | C(12) | bw04 | Jednoznačná časová identifikace záznamu v souboru BWPRINTD | Jednoznačná časová identifikace záznamu v souboru BWPRINTD
bw04packed | L | bw04packed | Příznak zapakované sestavy | Příznak zapakované sestavy
bw04desc | N(1,0) | bw04desc | Třídění sestupně | Třídění sestupně
bw04slovd | C(1) | bw04slovd | Patří do slovníku dat (S) | Patří do slovníku dat (S)
bw04prohl | M | bw04prohl | Informace ukládaná prohlížečem | Informace ukládaná prohlížečem
bw04zmenen | T | bw04zmenen | Datum a čas změny předlohy pro výstup | Datum a čas změny předlohy pro výstup
bw04skryty | M | bw04skryty | Skrytí předlohy pro výstup | Skrytí předlohy pro výstup
bw04ikona | M | bw04ikona |  |
bw04zmord | N(1,0) | bw04zmord | Je povoleno uživateli při výstupu změnit setřídění ? | Je povoleno uživateli při výstupu změnit setřídění ?
sp38id | C(3) | Jazyk | Identifikace jazyka | Identifikace jazyka
bw04kompon | M | bw04kompon | Komponenty jejichž záznamy událostí mají být zařazeny do výstupu | Komponenty jejichž záznamy událostí mají být zařazeny do výstupu
sp77id | C(6) | Prezentace | Identifikátor prezentace procesu | Identifikátor prezentace procesu
bw04kopie | N(1,0) | bw04kopie |  |
bw04ein | N(1,0) | bw04ein |  |
bw04einv | M | bw04einv |  |
bw04edipos | M | bw04edipos | Pozice sloupců při editaci dat před tiskem | Pozice sloupců při editaci dat před tiskem
bw04plusjo | M | bw04plusjo |  |
bw04plusfi | M | bw04plusfi |  |
bw04pluswh | M | bw04pluswh |  |
bw04tiskpr | N(1,0) | bw04tiskpr | Tisk procesů | Tisk procesů -,Rozhodnout,Prohlížet,Tisknout se zastavením,Tisknout bez zastavení
bw04emptyz | N(1,0) | bw04emptyz | Přidat prázdné záznamy | Přidat prázdné záznamy
bw66id | C(6) | Druh | Identifikace druhu předlohy | Identifikace druhu předlohy
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw04skryto | N(1,0) | bw04skryto | Předloha skrytá všem uživatelům | Předloha skrytá všem uživatelům
bw04gr | N(1,0) | bw04gr | Grupování | Grupování
bw04grfiel | M | bw04grfiel | Seznam atributů a výrazů předaných do grupování | Seznam atributů a výrazů předaných do grupování
bw04grplus | M | bw04grplus | Dodatečné klausule grupování | Dodatečné klausule grupování
bw71id | C(3) | Profil | Identifikace profilu spuštění předlohy | Identifikace profilu spuštění předlohy
bw85id | C(6) | L-Tiskárna | Identifikace logické tiskárny systému BM | Identifikace logické tiskárny systému BM
bw04declar | M | bw04declar | Dodatečné deklarace | Dodatečné deklarace
bw04script | M | bw04script | Skript provedený před zahájením výstupu předlohy před SQL dotazem | Skript provedený před zahájením výstupu předlohy před SQL dotazem
bw04scripx | M | bw04scripx | Skript provedený bezprostředně před zahájením výstupu předlohy po SQL dotazem | Skript provedený bezprostředně před zahájením výstupu předlohy po SQL dotazem
bw04wrdsig | N(1,0) | bw04wrdsig | Podepsat dokument Wordu - Nenabízet/Ano/Ne | Podepsat dokument Wordu - Nenabízet/Ano/Ne
bw04wrdema | N(1,0) | bw04wrdema | Podepsat otevřít panel e-mail Wordu - Nenabízet/Ano/Ne | Podepsat otevřít panel e-mail Wordu - Nenabízet/Ano/Ne
bw04wrdbin | N(1,0) | bw04wrdbin | Připojit dokument Wordu k objektu BM - Nenabízet/Ano/Ne | Připojit dokument Wordu k objektu BM - Nenabízet/Ano/Ne

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Předloha pro výstup - souvisí s prezentací procesu | BWPRINTD sp77id | 0,1 : 0,M | SPPREZ sp77id |
Předloha pro výstup - má přednastavený jazyk | BWPRINTD sp38id | 0,1 : 0,M | SPJAZYK sp38id |
Předloha pro výstup - je druhu | BWPRINTD bw66id | 1,1 : 0,M | BWPRINTT bw66id |
Předloha pro výstup - založil uživatel | BWPRINTD bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Předloha pro výstup - Používá profil spuštění | BWPRINTD bw71id | 1,1 : 0,M | BWPRINTC bw71id |
Předloha pro výstup - vystupuje na logickou tiskárnu BM | BWPRINTD bw85id | 0,1 : 0,M | BWPRINML bw85id |
Předloha pro výstup - patří do skupiny předloh | BWPRINTD sp79id | 0,1 : 0,M | SPTYPFOL sp79id |
Prvek WEB - vystupuje pohled předlohou | BWWEBPRV bw02krok bw04ident | 0,1 : 0,M | BWPRINTD bw02krok bw04ident |
List výkazu - používá předlohu výstupu | VKLIST bw20id bw04ident | 0,1 : 0,M | BWPRINTD bw02krok bw04ident |
Předloha výstupu v makropředloze - určuje výstup předlohou výstupu | BWPRINSP bw02krok bw04ident | 1,1 : 0,M | BWPRINTD bw02krok bw04ident |
Užití předlohy výstupu uživatelem - je užitím předlohy | BWPRINTU bw02krok bw04ident | 1,1 : 0,M s rušením | BWPRINTD bw02krok bw04ident |
Předepsané užití předlohy výstupu s obecným výběrem - je pro předlohu výstupu | SPVYBERV bw02krok bw04ident | 1,1 : 0,M s rušením | BWPRINTD bw02krok bw04ident |
Popis verze předlohy výstupu - je popisem předlohy výstupu | BWPRINTV bw02krok bw04ident | 1,1 : 0,M s rušením | BWPRINTD bw02krok bw04ident |
Příloha předlohy výstupu - patří k předloze | BWPRINTA bw02krok bw04ident | 1,1 : 0,M s rušením | BWPRINTD bw02krok bw04ident |
Výběr tiskové předlohy procesu - definuje použitou předlohu | SPTYPPRT bw02krok bw04ident | 1,1 : 0,M | BWPRINTD bw02krok bw04ident |

Indexy

Název | Primární | Výraz | Popis
ix_BWPRINTD_bw04printd | P | bw02krok, bw04ident | Primární klíč předlohy pro výstup BW02krok+BW04ident
ix_BWPRINTD_bw02krok |  | bw02krok | Identifikace činnosti
ix_BWPRINTD_bw04ident |  | bw04ident | Identifikace předlohy pro výstup
ix_BWPRINTD_sp79id |  | sp79id | Identifikace skupiny procesů
ix_BWPRINTD_bw04nazev |  | bw04nazev | Název předlohy pro výstup
ix_BWPRINTD_bw04order |  | bw04order | Určení třídění pro výstup
ix_BWPRINTD_bw04zmenen |  | bw04zmenen | Datum a čas změny předlohy pro výstup
ix_BWPRINTD_sp38id |  | sp38id | Identifikace jazyka
ix_BWPRINTD_sp77id |  | sp77id | Identifikátor prezentace procesu
ix_BWPRINTD_bw66id |  | bw66id | Identifikace druhu předlohy
ix_BWPRINTD_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_BWPRINTD_bw71id |  | bw71id | Identifikace profilu spuštění předlohy
ix_BWPRINTD_bw85id |  | bw85id | Identifikace logické tiskárny systému BM


BWPRINTF Výběr výstupu

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw35 | C(12) | bw35 | Jednoznačná časová identifikace výběru výstupu | Jednoznačná časová identifikace výběru výstupu
bw04slovd | C(1) | bw04slovd | Patří do slovníku dat (S) | Patří do slovníku dat (S)
bw35nazev | C(30) | Název výběru | Název výběru výstupu | Název výběru výstupu
bw35popis | M | Popis výběru výstupu | Popis výběru výstupu | Popis výběru výstupu
bw35kod | M | bw35kod | Kód výběru výstupu | Kód výběru výstupu
bw35tabl | M | bw35tabl | Tabulky obsažené v dotazu | Tabulky obsažené v dotazu
bw35tcomm | M | bw35tcomm | Text doplněný do výstupu | Text doplněný do výstupu
bw35edit | N(1,0) | bw35edit | Příznak povolení oprav definice výběru | Příznak povolení oprav definice výběru
bw35vznik | T | bw35vznik | Datum a čas vzniku definice výběru | Datum a čas vzniku definice výběru

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Prvek WEB - má výběr pohledu slovníku dat | BWWEBPRV bw02krok bw35 | 0,1 : 0,M | BWPRINTF bw02krok bw35 |

Indexy

Název | Primární | Výraz | Popis
ix_BWPRINTF_bwprintf | P | bw02krok, bw35 | Index podle bw02krok+bw35
ix_BWPRINTF_bw02krok |  | bw02krok | Identifikace činnosti
ix_BWPRINTF_bw35nazev |  | bw35nazev | Název výběru výstupu


BWPRINTT Druh předlohy

Popis

Druh předlohy

Atributy

Atribut | Typ | Návěští | Message | Popis
bw66id | C(6) | Druh | Identifikace druhu předlohy | Identifikace druhu předlohy
bw66nazdru | C(40) | Název druhu předlohy | Název druhu předlohy | Název druhu předlohy
bw66koment | M | bw66koment | Poznámka k druhu předlohy | Poznámka k druhu předlohy
bw66datum | T | Datum | Datum a čas založení druhu předlohy | Datum a čas založení druhu předlohy
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh předlohy - založil uživatel | BWPRINTT bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Metapředloha výstupu - je druhu | BWPRINS bw66id | 1,1 : 0,M | BWPRINTT bw66id |
Předloha pro výstup - je druhu | BWPRINTD bw66id | 1,1 : 0,M | BWPRINTT bw66id |
Obecný výběr - je druhu | SPVYBER bw66id | 1,1 : 0,M | BWPRINTT bw66id |

Indexy

Název | Primární | Výraz | Popis
ix_BWPRINTT_bw66id | P | bw66id | Identifikace druhu předlohy
ix_BWPRINTT_bw66nazdru |  | bw66nazdru | Název druhu předlohy
ix_BWPRINTT_bw01uziv |  | bw01uziv | Identifikace uživatele systému


BWPRINTU Užití předlohy výstupu uživatelem

Popis

Užití předlohy výstupu uživatelem

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw04ident | C(10) | Ident. | Identifikace předlohy pro výstup | Identifikace předlohy pro výstup
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bwa0dat1 | D | bwa0dat1 | Datum prvního užití předlohy | Datum prvního užití předlohy
bwa0dat2 | D | bwa0dat2 | Datum posledního užití předlohy | Datum posledního užití předlohy
bwa0pocet | N(6,0) | bwa0pocet | Celkový počet užití předlohy | Celkový počet užití předlohy

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Užití předlohy výstupu uživatelem - je užitím předlohy | BWPRINTU bw02krok bw04ident | 1,1 : 0,M s rušením | BWPRINTD bw02krok bw04ident |
Užití předlohy výstupu uživatelem - určuje užití předlohy uživatelem | BWPRINTU bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_BWPRINTU_bwprintu | P | bw02krok, bw04ident, bw01uziv | PI - BW04PRINTD+bw01uziv
ix_BWPRINTU_bw04printd |  | bw02krok, bw04ident | Primární klíč předlohy pro výstup BW02krok+BW04ident
ix_BWPRINTU_bw01uziv |  | bw01uziv | Identifikace uživatele systému


BWPRINTV Popis verze předlohy výstupu

Popis

Popis verze předlohy výstupu

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw04ident | C(10) | Ident. | Identifikace předlohy pro výstup | Identifikace předlohy pro výstup
bw04ver | N(6,3) | bw04ver | Verze předlohy výstupu | Verze předlohy výstupu
bwa9dne | D | bwa9dne | Datum záznamu o verzi | Datum záznamu o verzi
bwa9koment | M | bwa9koment | Popis verze | Popis verze
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace
sp00jmeakt | C(40) | Změnil | Jméno uživatele systému, který změnil záznam | Jméno uživatele systému, který změnil záznam

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis verze předlohy výstupu - je popisem předlohy výstupu | BWPRINTV bw02krok bw04ident | 1,1 : 0,M s rušením | BWPRINTD bw02krok bw04ident |

Indexy

Název | Primární | Výraz | Popis
ix_BWPRINTV_bwprintv | P | bw02krok, bw04ident, bw04ver | PI - BWPRINTD+bw04ver
ix_BWPRINTV_bw04printd |  | bw02krok, bw04ident | Primární klíč předlohy pro výstup BW02krok+BW04ident


BWPROVED Provedená činnost

Popis

Provedené činnosti
resp. soubor pro ukládání systémových informací o posledním nastavení ORDER v tom případě je proměnné BW02CAS text SORD

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw03cas | C(4) | Čas provedení činnosti | Čas provedení činnosti (HHMM) | Čas provedení činnosti (HHMM)
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw03dne | D | Datum provedení činnosti | Datum provedení činnosti | Datum provedení činnosti
bw03trvani | N(5,1) | Trvání činnosti | Trvání činnosti v minutách | Trvání činnosti v minutách
bw03pozn | C(11) | Poznámka programu | Poznámka programu | Poznámka provedené činnosti
bw03parita | C(1) | bw03parita | Parita uschovávaného parametru | Parita uschovávaného parametru
bw03 | C(12) | bw03 | Jednoznačná časová identifikace provedení činnosti | Jednoznačná časová identifikace provedení činnosti

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Provedená činnost - udělal uživatel | BWPROVED bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Provedená činnost - je popsána | BWPROVED bw02krok | 1,1 : 0,M | BWMENU bw02krok |

Indexy

Název | Primární | Výraz | Popis
ix_BWPROVED_bw03puzi |  | bw02krok, bw03cas, bw01uziv | Index do seznamu provedených činností pro vyhledání parametru uživatele
ix_BWPROVED_bw03doba |  | bw03dne, bw03cas | Doba a cas pro index
ix_BWPROVED_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_BWPROVED_bw02krok |  | bw02krok | Identifikace činnosti
ix_BWPROVED_bw03dne |  | bw03dne | Datum provedení činnosti
ix_BWPROVED_bw03 | P | bw03 | Jednoznačná časová identifikace provedení činnosti


BWRGBCOL Hodnota RGB barvy

Popis

Hodnota RGB barvy

Atributy

Atribut | Typ | Návěští | Message | Popis
bw95id | C(6) | Barva | Identifikace barvy RGB | Identifikace barvy RGB
bw95popbar | C(40) | Popis | Popis barvy RGB | Popis barvy RGB
bw95rgb | N(8,0) | RGB | Hodnota RGB | Hodnota RGB
bw95koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Kategorie události správy artiklu - má implicitní barvu písma | SAKATEG bw95id | 1,1 : 0,M | BWRGBCOL bw95id |
Kategorie události správy artiklu - má implicitní barvu pozadí | SAKATEG bw95id2 | 1,1 : 0,M | BWRGBCOL bw95id |
Barva kategorie události správy artiklu v paletě barev - definuje barvu RGB - popředí | SAPALKAT bw95id | 1,1 : 0,M | BWRGBCOL bw95id |
Barva kategorie události správy artiklu v paletě barev - definuje barvu RGB - pozadí | SAPALKAT bw95id2 | 1,1 : 0,M | BWRGBCOL bw95id |
Barva kategorie pracovníka v paletě barev - definuje barvu RGB - popředí | MZPALKAT bw95id | 1,1 : 0,M | BWRGBCOL bw95id |
Barva kategorie pracovníka v paletě barev - definuje barvu RGB - pozadí | MZPALKAT bw95id2 | 1,1 : 0,M | BWRGBCOL bw95id |
Barva kategorie adresáta v paletě barev - definuje barvu RGB - popředí | ADPALKAT bw95id | 1,1 : 0,M | BWRGBCOL bw95id |
Barva kategorie adresáta v paletě barev - definuje barvu RGB - pozadí | ADPALKAT bw95id2 | 1,1 : 0,M | BWRGBCOL bw95id |
Užití algoritmu výpočtu položky protokolu při výpočtu mezd - určuje zobrazení barvou v popředí protokolu | MZPROTAU bw95id | 1,1 : 0,M | BWRGBCOL bw95id |
Užití algoritmu výpočtu položky protokolu při výpočtu mezd - určuje zobrazení barvou v pozadí protokolu | MZPROTAU bw95id2 | 1,1 : 0,M | BWRGBCOL bw95id |
Druh artiklu - má definovanou barvu písma | SPARTIKD bw95id | 1,1 : 0,M | BWRGBCOL bw95id |
Druh artiklu - má definovanou barvu pozadí | SPARTIKD bw95id2 | 1,1 : 0,M | BWRGBCOL bw95id |
Technologická operace - používá v harmonogramu zobrazení barvou | TPOPERAC bw95id | 1,1 : 0,M | BWRGBCOL bw95id |

Indexy

Název | Primární | Výraz | Popis
ix_BWRGBCOL_bw95id | P | bw95id | Identifikace barvy RGB
ix_BWRGBCOL_bw95popbar |  | bw95popbar | Popis barvy RGB


BWSAVESC Vlastnosti formuláře

Popis

Vlastnosti formuláře

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw12tag | C(10) | bw12tag | Název (TAG) indexu | Název (TAG) indexu
bw59grid1 | M | bw59grid1 | Pozice GRIDu | Pozice GRIDu
bw59descen | N(1,0) | bw59descen | Vzestupné setřídění | Vzestupné setřídění

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vlastnosti formuláře - jsou uživatele | BWSAVESC bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_BWSAVESC_bwsavesc | P | bw02krok, bw01uziv | PI - Vlastnosti formuláře
ix_BWSAVESC_bw01uziv |  | bw01uziv | Identifikace uživatele systému


BWSEMAF Semafor pro blokování činností

Popis

Semafor pro blokování činností

Atributy

Atribut | Typ | Návěští | Message | Popis
bw75number | N(15,0) | Spojení | Číslo spojení uživatele rezervujícího zdroj | Číslo blokujícího spojení
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
bw75excl | N(1,0) | Výhradně | Příznak výhradní rezervace zdroje | Příznak výhradního zablokování
bw75duvod | C(60) | Důvod | Důvod rezervace zdroje | Důvod rezervace
bw01jmeno | C(30) | Uživatel | Jméno uživatele systému | Jméno uživatele systému
bw75time | T | Čas | Čas rezervace zdroje | Čas rezervace
bw75ident | C(12) | bw75ident | Identifikace semaforu | Identifikace semaforu

Indexy

Název | Primární | Výraz | Popis
ix_BWSEMAF_bwsemaf | P | bw75number, sp06idsubs |


BWSINFO Systémová informace

Atributy

Atribut | Typ | Návěští | Message | Popis
bw32id | C(20) | bw32id | Identifikace systémové informace | Identifikace systémové informace
bw32text | C(80) | bw32text | Text systémové informace | Text systémové informace
bw32dbc | M | bw32dbc |  |
bw32dct | M | bw32dct |  |

Indexy

Název | Primární | Výraz | Popis
ix_BWSINFO_bw32id | P | bw32id | Identifikace systémové informace


BWSLDPOH Pohled slovníku dat

Popis

Pohled slovníku dat

Atributy

Atribut | Typ | Návěští | Message | Popis
bw20id | C(6) | Pohled | Identifikace pohledu slovníku dat | Identifikace pohledu
bw20 | C(12) | bw20 | Jednoznačná časová identifikace pohledu | Jednoznačná časová identifikace pohledu
bw20nazev | C(40) | Název pohledu | Název pohledu | Název pohledu
bw20dat | D | Datum změny pohledu | Datum změny pohledu | Datum změny pohledu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw20trida | C(40) | bw20trida |  |
bw20ikona | M | bw20ikona |  |
bw20popis | M | bw20popis | Popis významu pohledu | Popis významu pohledu
bw20files | M | bw20files | Popis relačního prostředí pohledu | Popis relačního prostředí pohledu
bw20fields | M | bw20fields | Atributy pohledu | Atributy pohledu
bw20edit | N(1,0) | bw20edit | Povolení opravy pohledu | Povolení opravy pohledu
bw20skryty | M | bw20skryty | Skrytí pohledu | Skrytí pohledu
bw20zmenen | T | bw20zmenen | Datum a čas změny pohledu | Datum a čas změny pohledu
bw20vznik | T | bw20vznik | Datum a čas vzniku pohledu | Datum a čas vzniku pohledu
bw20tabl | M | bw20tabl | Seznam tabulek obsažených v pohledu | Seznam tabulek obsažených v pohledu
bw20indx | M | bw20indx | Uživatelské indexy pohledu | Uživatelské indexy pohledu
bw20menu | N(1,0) | Zařadit do menu | Zařadit do menu | Zařadit do menu
bw20intran | N(1,0) | Zařadit do intranet | Zařadit do intranet | Zařadit do intranet
bw20urlf | C(10) | bw20urlf | Referenční pole pro URL | Referenční pole pro URL
bw20includ | M | bw20includ | Soubor doplnění intranetové stránky | Soubor doplnění intranetové stránky
bw20burl | M | bw20burl | Popis URL odkazů v seznamu | Popis URL odkazů v seznamu BW20ID-TOPALS-URLF-pole=hodnota,
bw20doplok | M | bw20doplok | Doplněná okna | Doplněná okna

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Pohled slovníku dat - vytvořil uživatel | BWSLDPOH bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Prvek WEB - je listem dotazu pohledem | BWWEBPRV bw02krok | 0,1 : 0,M | BWSLDPOH bw20id |
List výkazu - používá pohled slovníku dat | VKLIST bw20id | 0,1 : 0,M | BWSLDPOH bw20id |
Obrazovka pohledu slovníku dat - používá atributy | BWSLDSCR bw20id | 1,1 : 0,M s rušením | BWSLDPOH bw20id |

Indexy

Název | Primární | Výraz | Popis
ix_BWSLDPOH_bw20id | P | bw20id | Identifikace pohledu
ix_BWSLDPOH_bw20 | U | bw20 | Jednoznačná časová identifikace pohledu
ix_BWSLDPOH_bw20nazev |  | bw20nazev | Název pohledu
ix_BWSLDPOH_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_BWSLDPOH_bw20trida |  | bw20trida |


BWSLDSCR Obrazovka pohledu slovníku dat

Popis

Parametry formuláře prohlížení dat slovníkem

Atributy

Atribut | Typ | Návěští | Message | Popis
bw20id | C(6) | Pohled | Identifikace pohledu slovníku dat | Identifikace pohledu
bw23alias | C(15) | bw23alias | Alias formuláře | Alias formuláře
bw23left | N(6,0) | bw23left | Umístění - levá souřadnice | Umístění - levá souřadnice
bw23top | N(6,0) | bw23top | Umístění - horní souřadnice | Umístění - horní souřadnice
bw23width | N(6,0) | bw23width | Umístění - šířka | Umístění - šířka
bw23height | N(6,0) | bw23height | Umístění - výška | Umístění - výška
bw23column | M | bw23column | Umístění - rozměry sloupců | Umístění - rozměry sloupců
bw23status | N(1,0) | bw23status | Status okna | Status okna
bw23top2 | N(6,0) | bw23top2 | Umístění - horní souřadnice | Umístění - horní souřadnice
bw23left2 | N(6,0) | bw23left2 | Umístění - levá souřadnice | Umístění - levá souřadnice
bw23width2 | N(6,0) | bw23width2 | Umístění - šířka | Umístění - šířka
bw23heigh2 | N(6,0) | bw23heigh2 | Umístění - výška | Umístění - výška
bw23statu2 | N(1,0) | bw23statu2 | Status okna | Status okna
bw23contro | M | bw23contro | Umístění - atributy ve formulářovém okně | Umístění - atributy ve formulářovém okně
bw23tables | M | bw23tables | Tabulky editované v rámci screenu | Tabulky editované v rámci screenu
bw23init | M | bw23init | Inicializované hodnoty při vstupu nové věty | Inicializované hodnoty při vstupu nové věty

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Obrazovka pohledu slovníku dat - používá atributy | BWSLDSCR bw20id | 1,1 : 0,M s rušením | BWSLDPOH bw20id |

Indexy

Název | Primární | Výraz | Popis
ix_BWSLDSCR_bw23scr | P | bw20id, bw23alias | Index informací o formuláři slovník+alias
ix_BWSLDSCR_bw20id |  | bw20id | Identifikace pohledu


BWSLDUZI Uživatelský index pro SLD

Popis

Uživatelský index pro SLD

Atributy

Atribut | Typ | Návěští | Message | Popis
bw25nazev | C(30) | Název indexu | Název indexu | Název indexu
bw25vyr | C(60) | Indexový výraz | Indexový výraz | Indexový výraz
bw25vyhrad | N(1,0) | bw25vyhrad | Výhradní použití pro pohled | Výhradní použití pro pohled
bw20id | C(6) | Pohled | Identifikace pohledu slovníku dat | Identifikace pohledu
bw10id | C(10) | bw10id | Interní identifikace entity | Interní identifikace entity
bw04order | C(10) | bw04order | Určení třídění pro výstup | Určení třídění pro výstup

Indexy

Název | Primární | Výraz | Popis
ix_BWSLDUZI_bw25nazev |  | bw25nazev | Název indexu
ix_BWSLDUZI_bw10id |  | bw10id | Interní identifikace entity


BWSLOVNI Přeložený text

Popis

Slovník překladu systému

Atributy

Atribut | Typ | Návěští | Message | Popis
bw57idt | C(10) | bw57idt | Identifikace textu | Identifikace textu
sp38id | C(3) | Jazyk | Identifikace jazyka | Identifikace jazyka
bw58text | M | bw58text | Přeložený text | Přeložený text
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace
bw58popent | N(1,0) | bw58popent | Příznak - zaznamenat přeložený text v popisné entitě SLOVPP | Zaznamenat přeložený text v popisné entitě SLOVPP

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popisná entita překladu - Obsahuje přeložený text | BWSLOVPP bw57idt sp38id | 1,1 : 0,M s rušením | BWSLOVNI bw57idt sp38id |

Indexy

Název | Primární | Výraz | Popis
ix_BWSLOVNI_bwslovnik | P | bw57idt, sp38id |
ix_BWSLOVNI_bw57idt |  | bw57idt | Identifikace textu
ix_BWSLOVNI_sp38id |  | sp38id | Identifikace jazyka


BWSLOVPP Popisná entita překladu

Popis

Popisná entita překladu

Atributy

Atribut | Typ | Návěští | Message | Popis
bw57idt | C(10) | bw57idt | Identifikace textu | Identifikace textu
sp38id | C(3) | Jazyk | Identifikace jazyka | Identifikace jazyka
bwa7id | N(2,0) | bwa7id | Identifikace přeloženého textu | Identifikace přeloženého textu
bwa7text | M | bwa7text | Přeložený text | Přeložený text

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popisná entita překladu - Obsahuje přeložený text | BWSLOVPP bw57idt sp38id | 1,1 : 0,M s rušením | BWSLOVNI bw57idt sp38id |

Indexy

Název | Primární | Výraz | Popis
ix_BWSLOVPP_bwslovpp | P | bw57idt, sp38id, bwa7id |
ix_BWSLOVPP_bwslovnik |  | bw57idt, sp38id |


BWSYSTRG Triggery v databázi

Popis

Triggery v databázi

Atributy

Atribut | Typ | Návěští | Message | Popis
bw73name | C(90) | bw73name |  |
bw73table | C(8) | bw73table |  |
bw73event | C(20) | bw73event |  |
bw73gtime | C(10) | bw73gtime |  |
bw73kod | M | bw73kod |  |
bw73owner | C(40) | bw73owner |  |


BWTOOL Uživatelský toolbar

Popis

Uživatelský toolbar

Atributy

Atribut | Typ | Návěští | Message | Popis
bw61id | C(10) | bw61id | Identifikace toobaru | Identifikace toobaru
bw61name | M | bw61name | Název toolbaru | Název toolbaru
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw61verej | N(1,0) | bw61verej |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Uživatelský toolbar - založil uživatel | BWTOOL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Položka toolbaru - patří do toolbaru | BWTOOLP bw61id | 1,1 : 0,M s rušením | BWTOOL bw61id |
Pozice okna uživatele toolbaru - se vztahuje k toolbaru | BWTOOLS bw61id | 1,1 : 0,M s rušením | BWTOOL bw61id |

Indexy

Název | Primární | Výraz | Popis
ix_BWTOOL_bw61id | P | bw61id | Identifikace toobaru
ix_BWTOOL_bw01uziv |  | bw01uziv | Identifikace uživatele systému


BWTOOLP Položka toolbaru

Popis

Položka toolbaru

Atributy

Atribut | Typ | Návěští | Message | Popis
bw62id | C(20) | bw62id |  |
bw61id | C(10) | bw61id | Identifikace toobaru | Identifikace toobaru
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw62name | M | bw62name |  |
bw62poradi | N(1,0) | bw62poradi |  |
bw62dynam | N(1,0) | bw62dynam |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Položka toolbaru - patří do toolbaru | BWTOOLP bw61id | 1,1 : 0,M s rušením | BWTOOL bw61id |

Indexy

Název | Primární | Výraz | Popis
ix_BWTOOLP_bwtoolp | P | bw62id, bw61id, bw02krok |
ix_BWTOOLP_bwtoolpi |  | bw02krok, bw62id |
ix_BWTOOLP_bw61id |  | bw61id | Identifikace toobaru


BWTOOLPI Ikona položky toobaru

Popis

Ikona položky toobaru

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw62id | C(20) | bw62id |  |
bw63pict | M | bw63pict |  |
bw63menu | N(1,0) | bw63menu | Zobrazovat položku nabídky v menu | Zobrazovat položku nabídky v menu

Indexy

Název | Primární | Výraz | Popis
ix_BWTOOLPI_bwtoolpi | P | bw02krok, bw62id |


BWTOOLS Pozice okna uživatele toolbaru

Popis

Pozice okna uživatele toolbaru

Atributy

Atribut | Typ | Návěští | Message | Popis
bw61id | C(10) | bw61id | Identifikace toobaru | Identifikace toobaru
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw64visibl | N(1,0) | bw64visibl |  |
bw64dock1 | N(6,0) | bw64dock1 |  |
bw64dock2 | N(6,0) | bw64dock2 |  |
bw64dock3 | N(6,0) | bw64dock3 |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Pozice okna uživatele toolbaru - se vztahuje k toolbaru | BWTOOLS bw61id | 1,1 : 0,M s rušením | BWTOOL bw61id |
Pozice okna uživatele toolbaru - je uživatele | BWTOOLS bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_BWTOOLS_bwtools | P | bw61id, bw01uziv |
ix_BWTOOLS_bw61id |  | bw61id | Identifikace toobaru
ix_BWTOOLS_bw01uziv |  | bw01uziv | Identifikace uživatele systému


BWTRGUSR Uživatelský trigger

Popis

Uživatelský trigger

Atributy

Atribut | Typ | Návěští | Message | Popis
bw10nazev | C(8) | Tabulka | Název entity | Název entity
bw72poradi | N(2,0) | Pořadí | Pořadí triggeru | Pořadí triggeru
sp64nazev | C(8) | Karta | Název volné karty | Identifikace volné karty
bw72nazev | C(40) | Název | Název triggeru | Název triggeru
bw72kod | M | Kód | Kód triggeru | Kód triggeru
bw72koment | M | Poznámka | Poznámka k triggeru | Poznámka k triggeru
bw72event | N(1,0) | Událost | Událost, která vyvolá trigger Vkládání/Oprava/Rušení | Událost, která vyvolá trigger Vkládání/Oprava/Rušení
bw72after | N(1,0) | bw72after | Spuštění triggeru Před/Po události | Spuštění triggeru Před/Po události
bw72systrg | N(2,0) | bw72systrg | Příznak interního triggeru BM 0=uživatelský, 1=sledování změn záznamu | Příznak interního triggeru BM 0=uživatelský, 1=sledování změn záznamu
bw72aktiv | N(1,0) | Aktivní | Aktivní Ano/Ne | Aktivní Ano/Ne
bw72vyrpop | M | Výraz popisu | Výraz popisu záznamu - uvádějte v syntaxi SQL $$$ bude nahrazeno new_name resp. old_name | Výraz popisu záznamu - uvádějte v syntaxi SQL $$$ bude nahrazeno new_name resp. old_name
bw72sleins | N(1,0) | Založení | Sledovat změny typu založení záznamu | Sledovat změny typu založení záznamu
bw72sleupd | N(1,0) | Oprava | Sledovat změny typu oprava záznamu | Sledovat změny typu oprava záznamu
bw72sledel | N(1,0) | Zrušení | Sledovat změny typu zrušení záznamu | Sledovat změny typu zrušení záznamu
bw72slevyb | M | Podmínka | Výraz podmínky sledování záznamu - uvádějte v syntaxi SQL $$$ bude nahrazeno new_name resp. old_name | Výraz podmínky sledování záznamu - uvádějte v syntaxi SQL $$$ bude nahrazeno new_name resp. old_name
bw72sleatr | M | Seznam atributů | Seznam atributů pro výběr sledování | Seznam atributů pro výběr sledování
bw72sleaty | N(1,0) | Atributy | Výběr atributů | Výběr atributů

Indexy

Název | Primární | Výraz | Popis
ix_BWTRGUSR_bwtrgusr | P | bw10nazev, bw72poradi, sp64nazev | PI - bw10nazev+bw72poradi
ix_BWTRGUSR_bw10nazev |  | bw10nazev | Název entity


BWUPDRC Zápis o změně záznamu tabulky

Popis

Zápis o změně záznamu tabulky

Atributy

Atribut | Typ | Návěští | Message | Popis
bw92 | C(12) | bw92 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
bw10nazev | C(8) | Tabulka | Název entity | Název entity
bw92key | C(50) | Klíč | Klíč změněného záznamu | Klíč změněného záznamu
bw92popis | C(40) | Popis | Popis záznamu | Popis záznamu
bw92datum | T | Dne | Datum a čas změny záznamu | Datum a čas změny záznamu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw92zmena | N(1,0) | Změna | Změna - oprava záznamu nebo zrušení záznamu | Změna - oprava záznamu nebo zrušení záznamu
bw92koment | M | Poznámka | Poznámka | Poznámka
bw92uziv | C(6) | bw92uziv | Pomocná id.uživatele systému pro aktualizaci uživatele po replikaci | Pomocná id.uživatele systému pro aktualizaci uživatele po replikaci
bw92datumr | T | bw92datumr | Datum a čas změny záznamu - pomocný pro replikace | Datum a čas změny záznamu - pomocný pro replikace
sp64nazev | C(8) | Karta | Název volné karty | Identifikace volné karty

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Zápis o změně záznamu tabulky - kterou provedl uživatel | BWUPDRC bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Zápis o změně atributu záznamu tabulky - je součástí zápisu o změně záznamu tabulky | BWUPDRCA bw92 | 1,1 : 0,M s rušením | BWUPDRC bw92 |

Indexy

Název | Primární | Výraz | Popis
ix_BWUPDRC_bw92 | P | bw92 | Jednoznačná časová identifikace
ix_BWUPDRC_bw10nazev |  | bw10nazev | Název entity
ix_BWUPDRC_bw92key |  | bw92key | Klíč změněného záznamu
ix_BWUPDRC_bw92popis |  | bw92popis | Popis záznamu
ix_BWUPDRC_bw92datum |  | bw92datum | Datum a čas změny záznamu
ix_BWUPDRC_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_BWUPDRC_bw92uziv |  | bw92uziv | Pomocná id.uživatele systému pro aktualizaci uživatele po replikaci


BWUPDRCA Zápis o změně atributu záznamu tabulky

Popis

Zápis o změně atributu záznamu tabulky

Atributy

Atribut | Typ | Návěští | Message | Popis
bw11nazev | C(10) | Atribut | Název atributu | Název atributu
bw92 | C(12) | bw92 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
bw93oldval | M | Původní | Původní hodnota atributu | Původní hodnota atributu
bw93newval | M | Nová | Nová hodnota atributu | Nová hodnota atributu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Zápis o změně atributu záznamu tabulky - je součástí zápisu o změně záznamu tabulky | BWUPDRCA bw92 | 1,1 : 0,M s rušením | BWUPDRC bw92 |

Indexy

Název | Primární | Výraz | Popis
ix_BWUPDRCA_bwupdrca | P | bw11nazev, bw92 | PI - bw11nazev+bw92
ix_BWUPDRCA_bw11nazev |  | bw11nazev | Název atributu
ix_BWUPDRCA_bw92 |  | bw92 | Jednoznačná časová identifikace


BWUPDTRG Záznam o update triggerem

Popis

Záznam o update triggerem

Atributy

Atribut | Typ | Návěští | Message | Popis
bw74 | C(9) | bw74 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
bw74cas | T | bw74cas | Datum a čas provedení příkazu | Datum a čas provedení příkazu
bw74prikaz | M | bw74prikaz | Příkaz provedený triggerem | Příkaz provedený triggerem

Indexy

Název | Primární | Výraz | Popis
ix_BWUPDTRG_bw74 | P | bw74 | Jednoznačná časová identifikace


BWUZIVAT Uživatel systému

Popis

Seznam uživatelů systému

Atributy

Atribut | Typ | Návěští | Message | Popis
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp47id | C(6) | Význam | Identifikace významu položky obecné předkontace | Identifikace významu položky obecné předkontace
bw01jmeno | C(30) | Uživatel | Jméno uživatele systému | Jméno uživatele systému
bw01jmenot | C(25) | Uživatel (úplné jméno) | Úplné jméno uživatele systému | Rozšířené jméno uživatele systému
bw01privat | M | bw01privat | Privátní nastavení uživatele pro řízení chodu systému | Privátní nastavení uživatele pro řízení chodu systému
bw01multi | C(49) | Přístup k multiverzím | Přístup k uvedeným číslům multiverzí | Přístup k uvedným číslům multiverzí
bw01heslo1 | C(17) | Počáteční heslo | Počáteční heslo uživatele | Počáteční heslo uživatele
bw01hslzm | N(1,0) | bw01hslzm | Povolena změna hesla | Povolena změna hesla
bw01aktiv | N(1,0) | bw01aktiv | Aktivní uživatel (tj. smí se přihlásit do systému) | Aktivní uživatel (tj. smí se přihlásit do systému)
bw01 | C(12) | bw01 | Jednoznačná časová identifikace záznamu v souboru BWUZIVAT | Jednoznačná časová identifikace záznamu v souboru BWUZIVAT
bw08ident | C(6) | Skupina | Identifikace skupiny uživatele | Identifikace skupiny uživatele
bw01uzvol | C(30) | bw01uzvol | Poslední volba uživatelského menu | Poslední volba uživatelského menu
bw01heslo | C(36) | bw01heslo |  |
bw24ident | C(10) | bw24ident | Identifikace menu | Identifikace menu
bw01naposl | T | bw01naposl | Datum a čas posledního vyvolání systému | Datum a čas posledního vyvolání systému
sp38id | C(3) | Jazyk | Identifikace jazyka | Identifikace jazyka
bw01foto | G | Foto | Fotografie uživatele systému | Fotografie uživatele systému
bw01dbusr | C(36) | Uživatel | Jméno uživatele pro přihlášení k databázovému serveru | Jméno uživatele pro přihlášení k databázovému serveru
bw01dbpwd | C(36) | Heslo | Heslo uživatele přihlášeného k databázovému serveru | Heslo uživatele přihášeného k databázovému serveru
bw01email | C(40) | E-mail | E-mailová adresa uživatele | E-mailová adresa uživatele
bw01stool | M | bw01stool | Nastavení souvislostí objektů uživatele | Nastavení souvislostí objektů uživatele
bw01pravas | N(1,0) | bw01pravas | Uživatel s oprávněním správce | Uživatel s oprávněním správce
bw68 | C(9) | bw68 | Primární identifikace prvku WEB | Primární identifikace prvku WEB
bw01pravab | N(1,0) | bw01pravab | Uživatel s oprávněním odblokování systému BM zablokovaného jiným uživatelem | Uživatel s oprávněním odblokování systému BM zablokovaného jiným uživatelem
bw01telef | C(40) | Telefon | Telefonní číslo uživatele | Telefonní číslo uživatele
bw01mtop | N(5,0) | bw01mtop | Pozice okna hlavního menu TOP | Pozice okna hlavního menu TOP
bw01mleft | N(5,0) | bw01mleft | Pozice okna hlavního menu LEFT | Pozice okna hlavního menu LEFT
bw01mheigh | N(5,0) | bw01mheigh | Pozice okna hlavního menu HEIGHT | Pozice okna hlavního menu HEIGHT
bw01mwidth | N(5,0) | bw01mwidth | Pozice okna hlavního menu WIDTH | Pozice okna hlavního menu WIDTH
bw01koment | M | bw01koment | Poznámka | Poznámka
bw01us | N(1,0) | Typ | Uživatel / skupina uživatelů | Uživatel / skupina uživatelů
bw01hhasht | N(2,0) | bw01hhasht | Identifikace hašovací funkce uživatele programu, použité pro zakódování do atributu BW01HHASH | Identifikace hašovací funkce uživatele programu, použité pro zakódování do atributu BW01HHASH
bw01hhash | M | bw01hhash | Heslo uživatele zakódované hašovací funkcí pro ověření hesla jinými systémy | Heslo uživatele zakódované hašovací funkcí pro ověření hesla jinými systémy
bw01token | N(1,0) | bw01token | Pomocný příznak uživatele | Pomocný příznak uživatele

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Uživatel systému - používá menu | BWUZIVAT bw24ident | 0,1 : 0,M | BWDEFM bw24ident |
Uživatel systému - mluví zazykem | BWUZIVAT sp38id | 0,1 : 0,M | SPJAZYK sp38id |
Uživatel systému - používá WEB menu | BWUZIVAT bw68 | 0,1 : 0,M | BWWEBPRV bw68 |
Uživatel systému - je spojen s významen položky obecné předkontace | BWUZIVAT sp47id | 0,1 : 0,M | SPPREDKV sp47id |
Výraz pro označení - obchod - založil uživatel systému | OBOZNVYR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Uživatelský toolbar - založil uživatel | BWTOOL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Pozice okna uživatele toolbaru - je uživatele | BWTOOLS bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Předmět projektu - založil uživatel | NKPREDPR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Druh předlohy - založil uživatel | BWPRINTT bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Prvek WEB - založil uživatel | BWWEBPRV bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Druh prvku WEB - založil uživatel | BWWEBDRU bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Parametr předmětu projektu - založil uživatel | NKPAR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Umístění parametru předmětu projektu - založil uživatel | NKPARDRU bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Umístění parametru předmětu projektu - reprezentuje uživatele systému | NKPARDRU bw01uziv1 | 1,1 : 0,M | BWUZIVAT bw01uziv |
Hodnota parametru předmětu projektu - založil uživatele | NKHODNP bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Položka smlouvy - založil uživatel | NKSMLOUV bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost plnění položky smlouvy - založil uživatel | NKSMLPLN bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost o záloze - založil uživatel | ZAUDAL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Výkaz - založil uživatel | VKVYKAZ bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Druh výkazu - založil uživatel | VKDRUHV bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Funkce pro výkazy - založil uživatel | VKFCE bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Šablona procesu technologického postupu - byla založena uživatelem | TPSABPRC bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Kalkulační vzorec / proměnná kalkulačního vzorce - byla založena uživatelem | TPKALK bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Skupina uživatelů výběru vstupem - má jméno | BWMENPOD bw05ident | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Výraz označování výběrem - patří uživateli | BWOZVRZ bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Druh makra výrazů - založil uživatel | BWOZMCRD bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Projektový úkol - založil uživatel | NKUKOL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Řešitel projektového úkolu - je uživatelem systému | NKZDROJ bw01uziv | 0,1 : 0,M | BWUZIVAT bw01uziv |
Druh události položky smlouvy nebo události plnění položky smlouvy - založil uživatel | NKPLNDRU bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Plnění projektového úkolu - založil uživatel | NKUKOLP bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Záznam o změně vlastností úkolu - kterou provedl uživatel | NKUKOLH bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Poslední transformace a konverze adresy Outlooku vybraná uživatelem při odeslání zprávy z komponenty BM - je uživatele | PZOLUSR bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Záznam o změně stavu předmětu projektu nebo hodnoty jeho parametru - založil uživatel | NKPREDZS bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Událost skladu zvířat - zapsal uživatel | SZUDAL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Kategorie zvířat - založil uživatel | SZARTIKL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Druh implementačního rozšíření - byl založen uživatelem | SPCINDVT bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Technologický postup k datu rozpracovaný na KJ pilotního artiklu - přepočet uživatel | TPTECVV bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Popis operace procesu pro jednotlivého uživatele - je pro uživatele | APOPEPOU bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost personalistiky - zapsal uživatel | MZPERUDA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Artikly personalistiky - založil uživatel systému | MZPERART bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Parametry komponenty sklad zvířat - aktualizoval uživatel | SZPAR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Druh uzlu obecného stromu - založil uživatel | SPSTROMD bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Verze dokumentu - byla založena uživatelem | SPDOKREV bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Hlavička protokolu - zapsána pracovníkem | MZPROTHL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Poslední stránka na panelu použitá uživatelm systému - určuje uživatele | IPUZIUZE bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Zobrazení poduzlu pro uživatele - se týká uživatele | IPUZELPZ bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Klasifikace objektu - naposledy změnil popis uživatel | PAOBJDRU bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Uživatel v IS BM provozovatele webové služby - odpovídá uživateli v datech provozovatele webové | IEWSUSBM bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Zápis o změně záznamu tabulky - kterou provedl uživatel | BWUPDRC bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Položka protokolu dokumentu - byla založena uživatelem | SPDOKPRO bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Poslední výběrové volání externího programu uživatele - je výběrové volání uživatele | SPEXTPRU bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost správy artiklu - založil uživatel | SAUDAL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Paleta barev kategorií artiklu - je používána skupinou uživatelů | SAPALETA bw05ident | 1,1 : 0,M | BWUZIVAT bw01uziv |
Paleta barev kategorií pracovníků - je používána skupinou uživatelů | MZPALETA bw05ident | 1,1 : 0,M | BWUZIVAT bw01uziv |
Užití předlohy výstupu uživatelem - určuje užití předlohy uživatelem | BWPRINTU bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Užití obecného výběru - zaznamenává užití obecného výběru uživatelem | SPVYBERU bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Užití volné karty - zaznamenává užití předlohy uživatelem | SPVOLSTU bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Paleta barev kategorií adresáta - je používána skupinou uživatelů | ADPALETA bw05ident | 1,1 : 0,M | BWUZIVAT bw01uziv |
Parametry pole formuláře - jsou parametry uživatele | BWFLDPAR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Zařazení uživatele to skupiny uživatelů - skutečná - určuje uživatele | BWOVAZBS bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Zařazení uživatele to skupiny uživatelů - skutečná - určuje skupinu | BWOVAZBS bw05ident | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Přihlášený uživatel do systému (SQL) - má jméno | BWCONNEQ bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Kategorie přidělená dokumentu - byla přidělena uživatelem | SPDOKKAT bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Parametry změny stavu peněz - aktualizoval uživatel | ZPPARZSP bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Uchovaná pozice okna - je pozice okna uživatele | BWWINDPS bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Obsah archivovaného souboru - založil uživatel | UTARDATC bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Záznam o plnění úkolu v programu EVIVYK.EXE - založil uživatel | NKUKOLPE bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Záznam o spuštění vzdálené funkce - je záznamem uživatele | PAVFFCPR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Nastavení automatického spuštění sady vzdálených funkcí - platí pro skupinu uživatelů | PAVFSASP bw05ident | 1,1 : 0,M | BWUZIVAT bw01uziv |
Provedená činnost - udělal uživatel | BWPROVED bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Předloha pro výstup - založil uživatel | BWPRINTD bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Adresát - byl založen uživatelem | ADADSAT bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Kategorie adresáta - zapsána uživatelem | ADKAT bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Zařazení uživatele to skupiny uživatelů - váže odbornost | BWOVAZBA bw05ident | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Zařazení uživatele to skupiny uživatelů - Patří uživateli | BWOVAZBA bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Téma vývěsky - bylo založeno pracovníkem | VYTEMA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost vývěsky - zapsal pracovník | VYUDALOS bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost vývěsky - vyřizuje pracovník | VYUDALOS bw01uziv1 | 1,1 : 0,M | BWUZIVAT bw01uziv |
Kategorie diáře - byla zapsána | DIPOPDIA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Záznam diáře - přísluší pracovníkovi | DIDIAR bw01uziv1 | 1,1 : 0,M | BWUZIVAT bw01uziv |
Záznam diáře - zapsal pracovník | DIDIAR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Kategorie pošty - zapsal uživatel | POPOPPO bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Poštovní zásilka - byla zapsána pracovníkem | POPOSTA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Poštovní zásilka - je vyřizována pracovníkem | POPOSTA bw01uziv2 | 0,1 : 0,M | BWUZIVAT bw01uziv |
Zpráva - byla zapsána pracovníkem | PZZPRAVY bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Zpráva - je poslána pracovníkovi | PZZPRAVY bw01uziv1 | 1,1 : 0,M | BWUZIVAT bw01uziv |
Typ předlohy dokumentu - byla založena pracovníkem | SPPREDLO bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Práce s dokumentem - s dokumentem pracoval | SPDOKUZI bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Definice menu - byla založena uživatelem | BWDEFM bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Právo odbornosti k činnosti - je odbornosti | BWCIODB bw05ident | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Pohled slovníku dat - vytvořil uživatel | BWSLDPOH bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Činnost spuštěná při startu programu pro uživatele - patří uživateli | BWUZSTAR bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Parametr činnosti menu - vlastní uživatel | BWMENPAR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Druh procesu/operace - založil uživatel | SPTYP bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Oblíbená skupina uživatelů - patří uživateli | PZOBLSKU bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Uživatelé v oblíbených skupinách uživatelů - má uživatele systému | PZOBLUZI bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Dokument - založil uživatel | SPDOKOBS bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Označený záznam o adresátovi - patří uživateli | ADOZNAC bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Uzel vývěsky - patří uživateli | VYOZNAC bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Pravidlo transformace - založil uživatel | SPTRNR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Druh operace v druhu procesu - má určenou skupinu uživatelů, která ji smí ukončit | SPTYPOD bw05ident | 0,1 : 0,M | BWUZIVAT bw01uziv |
Vazba druhů operací v druhu procesu - bude rozhodnuta skupinou uživatelů | SPTYPVO bw05ident | 0,1 : 0,M | BWUZIVAT bw01uziv |
Proces - založil uživatel | SPPRC bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Operace procesu - zahájil uživatel | SPPRCOD bw01uziv | 0,1 : 0,M | BWUZIVAT bw01uziv |
Operace procesu - ukončil uživatel | SPPRCOD bw01uziv1 | 0,1 : 0,M | BWUZIVAT bw01uziv |
Vazba operací v procesu - bude rozhodnuta skupinou uživatelů | SPPRCVO bw05ident | 0,1 : 0,M | BWUZIVAT bw01uziv |
Transformace - provedl uživatel | SPTRN bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost obecné komponenty - založil uživatel | OKUDALOS bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Přístupové právo uživatele k věci - souvisí s uživatelem | SPPRISTU bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Přístupové právo skupiny uživatelů k věci - souvisí se skupinou uživatelů | SPPRISTS bw05ident | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Evidence změn obsahu záznamů komponent a logických věcí - se týká uživatele | SPZMENY bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Šablona - byla založena uživatelem | SPSABL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Druh šablony - založil uživatel | SPSABLT bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Poslední šablona spuštěná uživatelem v komponentě - souvisí s uživatelem | SPSABLM bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Účet z rozvrhu - někdo zapsal | UCROZVRH bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Účetní událost - zapsal uživatel | UCDENIK bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Druh dokumentu - založil uživatel | SPDOKTYP bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Záznam o posledním použitém druhu dokumentu a předloze - pamatuje uživatele | SPDOKMEM bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Spravovaný majetek - zapsal uživatel | SMMAJ bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost spravovaného majetku - zapsal uživatel | SMUDAL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Umístění - zapsal uživatel | SMUMIS bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Rezervace - zapsaná uživatelem | SMREZER bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Rezervace - pro uživatele | SMREZER bw01uziv1 | 1,1 : 0,M | BWUZIVAT bw01uziv |
Karta - zapsal | ODKARTA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost odpisovaného majetku - zapsal | ODUDAL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Výkon - zapsal uživatel | ODVYKON bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Obchodovatelný artikl - založil uživatel systému | OBARTIKL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Volná karta - byla založena uživatelem | SPVOLST bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Druh volné karty - založil uživatel | SPVOLSTT bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost obchodního plnění - byla založena uživatelem | OBUDAL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Druh hodnoty - založil uživatel | SPSTATDI bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Vyvolání operace z hlavního procesu - založil uživatel | SPTYPGO bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost DPH - byla zapsána uživatelem | DPUDA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost plateb - byla založena uživatelem | PLUDA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Druh saldokontní hodnoty procesu - Založil uživatel | SPSTATDS bw01uziv | 0,1 : 0,M | BWUZIVAT bw01uziv |
Výplatní místo - zapsáno uživatelem | MZVYPMIS bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Stupnice zahrnuje - vytvořena uživatelem | MZTARSTU bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Kalendář má - je zapsán uživatelem | MZKALEN bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Mzdová položka - zapsána uživatelem | MZMZDPOL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Skladovaný artikl - založil uživatel systému | MTARTIKL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost skladu - byla zapsána uživatelem | MTUDA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Pracovní funkce - skutečné a typové - zapsal uživatel | MZPRACFU bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost změny stavu peněz - výpisy a příkazy - byla zapsána uživateleme | ZPUDA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Mzda - zapsána pracovníkem | MZMZDY bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Prezentace procesu - založil uživatel | SPPREZ bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Skupina procesů / předloh pro zobrazení v menu - založil uživatel | SPTYPFOL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Příkaz k úhradě - založil uživatel | PLPRIU bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Nemoc - zapsal uživatel | MZNEMOC bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Nemocenská dávka - zapsána uživatelem | MZNEMDAV bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Pravidlo validace zápisu dat operace - obsahuje požadavek odeslání zprávy uživateli systému | SPTYPVLU bw01uziv | 0,1 : 0,M | BWUZIVAT bw01uziv |
Definice přenosu příkazu - zapsal | ZPPRHLA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Osobní maska operace - patří uživateli systému | SPTYPOMO bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Katalog zboží obchodu - založil uživatel | OBKATAL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Druh katalogu zboží obchodu - založil uživatel | OBKATALD bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost dávkové komponenty - založil uživatel | SPDAVKA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Druh události - vytvořena uživatelem | MZDRUHUD bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událostní entita mezd - zapsal uživatel | MZUDALOS bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Druh výkazu - zapsal uživatel | UCDRUHV bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
List výkazu - zapsal uživatel | UCLIST bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Definice výkazu - zapsal uživatel | UCVYKAZ bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost vymáhání - byla založena uživatelem | VMUDA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Výkaz - zapsán pracovníkem | MZVYKAZY bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Postup vymáhání - založil uživatel | VMPOSTU bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Algoritmus vymáhání - založil uživatel | VMALGOR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Cenová skupina obchodovatelného artiklu - založil uživatel | OBCENSKP bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Cenové období cenové skupiny obchodovatelného artiklu - založil uživatel | OBCENOBD bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Organizační jednotka - číselník - zapsal uživatel | MZORGJED bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Úkolové listy - zapsána pracovníkem | MZUKOLLI bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Obecný výběr - založil uživatel | SPVYBER bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Parametry komponenty sklady - aktualizoval uživatel | MTPARSKL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Vlastnosti formuláře - jsou uživatele | BWSAVESC bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Výrobní zakázka - zapsána uživatelem | VRVYR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost úkolu ve výrobě - zapsal uživatel | VRUDOPER bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Artikl mezd - založil uživatel systému | MZARTIKL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Definice importu/exportu - založil uživatel | SPIMP bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Druh importu - založil uživatel | SPIMPD bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Spojení - založil uživatel | SPIMPS bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Kategorie zásilky - zapsal | POKATZAS bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Procesní import - založil uživatel | SPIMPP bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Vstup nebo výstup výrobního úkolu - zapsal uživatel | VRUDOPMA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Vozidlo - expedice - založil uživatel | EXARTIKL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost expedice - založil uživatel | EXUDAL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Externí příkaz - založil uživatel | SPEXTPR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Druh externího příkazu - založil uživatel | SPEXTPRD bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_BWUZIVAT_bw01uziv | P | bw01uziv | Identifikace uživatele systému
ix_BWUZIVAT_sp47id |  | sp47id | Identifikace významu položky obecné předkontace
ix_BWUZIVAT_bw01jmeno |  | bw01jmeno | Jméno uživatele systému
ix_BWUZIVAT_bw01 |  | bw01 | Jednoznačná časová identifikace záznamu v souboru BWUZIVAT
ix_BWUZIVAT_bw08ident |  | bw08ident | Identifikace skupiny uživatele
ix_BWUZIVAT_sp38id |  | sp38id | Identifikace jazyka
ix_BWUZIVAT_bw01pravas |  | bw01pravas | Uživatel s oprávněním správce
ix_BWUZIVAT_bw68 |  | bw68 | Primární identifikace prvku WEB


BWUZSKUP Skupina uživatele

Popis

Skupina uživatele

Atributy

Atribut | Typ | Návěští | Message | Popis
bw08ident | C(6) | Skupina | Identifikace skupiny uživatele | Identifikace skupiny uživatele
bw08nazev | C(30) | Název skupiny | Název skupiny uživatele | Název skupiny uživatele

Indexy

Název | Primární | Výraz | Popis
ix_BWUZSKUP_bw08ident | P | bw08ident | Identifikace skupiny uživatele
ix_BWUZSKUP_bw08nazev |  | bw08nazev | Název skupiny uživatele


BWUZSTAR Činnost spuštěná při startu programu pro uživatele

Popis

Činnost spuštěná při startu programu pro uživatele

Atributy

Atribut | Typ | Návěští | Message | Popis
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw21ident | C(12) | bw21ident | Identifikace činnosti - vyvolávající činnost | Identifikace činnosti - vyvolávající činnost
bw21krok | C(12) | bw21krok | Identifikace činnosti - volaná činnost | Identifikace činnosti - volaná činnost
bw21poradi | N(3,0) | bw21poradi | Pořadí v rámci seznamu činností | Pořadí v rámci seznamu činností
bw21jednou | N(1,0) | bw21jednou | Mocnost relace | Vyvolávat jednou denně

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Činnost spuštěná při startu programu pro uživatele - patří uživateli | BWUZSTAR bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_BWUZSTAR_bwuzstar | P | bw01uziv, bw21ident, bw21krok | Index podle otce pohledu
ix_BWUZSTAR_bw01uziv |  | bw01uziv | Identifikace uživatele systému


BWUZVOL Uživatelská volba definice menu

Popis

Uživatelská volba definice menu

Atributy

Atribut | Typ | Návěští | Message | Popis
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw16ident | C(8) | Ident. | Rozšířená identifikace činnosti | Rozšířená identifikace činnosti
bw01uzvol | C(30) | bw01uzvol | Poslední volba uživatelského menu | Poslední volba uživatelského menu
bw17x | N(4,0) | bw17x | Osa X umístění ikony | Osa X umístění ikony
bw17y | N(4,0) | bw17y | Osa Y umístění ikony | Osa Y umístění ikony
bw17klv | C(2) | bw17klv | Funkční klávesa | Funkční klávesa
bw17panel | N(1,0) | bw17panel | Je ikona umístěna na panelu | Je ikona umístěna na panelu
bw17sedi | N(1,0) | bw17sedi |  |
bw17height | N(4,0) | bw17height | Výška okna | Výška okna
bw17widht | N(4,0) | bw17widht | Šířka okna | Šířka okna

Indexy

Název | Primární | Výraz | Popis
ix_BWUZVOL_bwuzvol | P | bw01uziv, bw02krok, bw16ident | Index bw01uziv+bw02krok+bw16ident


BWWEBDRU Druh prvku WEB

Popis

Druh prvku WEB

Atributy

Atribut | Typ | Návěští | Message | Popis
bw70id | C(6) | Druh | Identifikace druhu prvku WEB | Identifikace druhu prvku WEB
bw70nazdru | C(40) | Název druhu | Název druhu prvku WEB | Název druhu prvku WEB
bw70koment | M | Poznámka | Poznámka | Poznámka
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw70datum | T | Datum | Datum založení prvku WEB | Datum založení prvku WEB

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh prvku WEB - založil uživatel | BWWEBDRU bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Prvek WEB - je druhu | BWWEBPRV bw70id | 1,1 : 0,M | BWWEBDRU bw70id |

Indexy

Název | Primární | Výraz | Popis
ix_BWWEBDRU_bw70id | P | bw70id | Identifikace druhu prvku WEB
ix_BWWEBDRU_bw70nazdru |  | bw70nazdru | Název druhu prvku WEB
ix_BWWEBDRU_bw01uziv |  | bw01uziv | Identifikace uživatele systému


BWWEBPRV Prvek WEB

Popis

Prvek WEB

Atributy

Atribut | Typ | Návěští | Message | Popis
bw68 | C(9) | bw68 | Primární identifikace prvku WEB | Primární identifikace prvku WEB
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw35 | C(12) | bw35 | Jednoznačná časová identifikace výběru výstupu | Jednoznačná časová identifikace výběru výstupu
bw04ident | C(10) | Ident. | Identifikace předlohy pro výstup | Identifikace předlohy pro výstup
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw70id | C(6) | Druh | Identifikace druhu prvku WEB | Identifikace druhu prvku WEB
bw68messg | C(40) | bw68messg | Popis položky menu | Popis položky menu
bw68koment | M | bw68koment | Poznámka | Poznámka
bw68typ | N(1,0) | bw68typ | Typ vyšší menu,nižší menu,list | Typ vyšší menu,nižší menu,list
bw68vrchol | N(1,0) | bw68vrchol | Vrcholové menu | Vrcholové menu
bw68datum | T | bw68datum | Datum a čas založení | Datum a čas založení
bw68defa | N(1,0) | bw68defa | Default menu | Default menu
bw68typlis | N(1,0) | bw68typlis | Typ listové položky - Slovník dat nebo adresa | Typ listové položky - Slovník dat nebo adresa
bw68adresa | M | bw68adresa | WWW adresa | WWW adresa
bw68wap | C(9) | bw68wap | Alternativní uzel pro WAP | Alternativní uzel pro WAP

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Prvek WEB - vystupuje pohled předlohou | BWWEBPRV bw02krok bw04ident | 0,1 : 0,M | BWPRINTD bw02krok bw04ident |
Prvek WEB - má výběr pohledu slovníku dat | BWWEBPRV bw02krok bw35 | 0,1 : 0,M | BWPRINTF bw02krok bw35 |
Prvek WEB - založil uživatel | BWWEBPRV bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Prvek WEB - je listem dotazu pohledem | BWWEBPRV bw02krok | 0,1 : 0,M | BWSLDPOH bw20id |
Prvek WEB - je druhu | BWWEBPRV bw70id | 1,1 : 0,M | BWWEBDRU bw70id |
Prvek WEB - je alternativním prvkem prvku WEB pro WAP | BWWEBPRV bw68wap | 0,1 : 0,M | BWWEBPRV bw68 |
Prvek WEB - je alternativním prvkem prvku WEB pro WAP | BWWEBPRV bw68wap | 0,1 : 0,M | BWWEBPRV bw68 |
Vazba prvků WEB - váže předchůdce | BWWEBVAZ bw68 | 1,1 : 0,M s rušením | BWWEBPRV bw68 |
Vazba prvků WEB - váže následníka | BWWEBVAZ bw68syn | 1,1 : 0,M s rušením | BWWEBPRV bw68 |
Uživatel systému - používá WEB menu | BWUZIVAT bw68 | 0,1 : 0,M | BWWEBPRV bw68 |

Indexy

Název | Primární | Výraz | Popis
ix_BWWEBPRV_bw68 | P | bw68 | Primární identifikace prvku WEB
ix_BWWEBPRV_bw02krok |  | bw02krok | Identifikace činnosti
ix_BWWEBPRV_bwprintf |  | bw02krok, bw35 | Index podle bw02krok+bw35
ix_BWWEBPRV_bw04printd |  | bw02krok, bw04ident | Primární klíč předlohy pro výstup BW02krok+BW04ident
ix_BWWEBPRV_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_BWWEBPRV_bw70id |  | bw70id | Identifikace druhu prvku WEB
ix_BWWEBPRV_bw68wap |  | bw68wap | Alternativní uzel pro WAP


BWWEBVAZ Vazba prvků WEB

Popis

Vazba prvků WEB

Atributy

Atribut | Typ | Návěští | Message | Popis
bw68 | C(9) | bw68 | Primární identifikace prvku WEB | Primární identifikace prvku WEB
bw68syn | C(9) | bw68syn | Identifikace následníka | Identifikace následníka
bw69porad | N(3,0) | bw69porad | Pořadí vazby | Pořadí vazby

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vazba prvků WEB - váže předchůdce | BWWEBVAZ bw68 | 1,1 : 0,M s rušením | BWWEBPRV bw68 |
Vazba prvků WEB - váže následníka | BWWEBVAZ bw68syn | 1,1 : 0,M s rušením | BWWEBPRV bw68 |

Indexy

Název | Primární | Výraz | Popis
ix_BWWEBVAZ_bwwebvaz | P | bw68, bw68syn | PI - bw68+bw68syn
ix_BWWEBVAZ_bw68 |  | bw68 | Primární identifikace prvku WEB
ix_BWWEBVAZ_bw68syn |  | bw68syn | Identifikace následníka


BWWINDPS Uchovaná pozice okna

Popis

Uchovaná pozice okna

Atributy

Atribut | Typ | Návěští | Message | Popis
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bwa6key | C(20) | bwa6key | Identifikace okna | Identifikace okna
bwa6scrh | N(5,0) | bwa6scrh | Rozlišení HEIGHT obrazovky v okamžiku uložení pozice okna | Rozlišení HEIGHT obrazovky v okamžiku uložení pozice okna
bwa6scrw | N(5,0) | bwa6scrw | Rozlišení WIDTH obrazovky v okamžiku uložení pozice okna | Rozlišení WIDTH obrazovky v okamžiku uložení pozice okna
bwa6top | N(5,0) | bwa6top | Pozice okna TOP | Pozice okna TOP
bwa6left | N(5,0) | bwa6left | Pozice okna LEFT | Pozice okna LEFT
bwa6height | N(5,0) | bwa6height | Pozice okna HEIGHT | Pozice okna HEIGHT
bwa6width | N(5,0) | bwa6width | Pozice okna WIDTH | Pozice okna WIDTH
bwa6saveps | N(1,0) | bwa6saveps | Uchovávat pozice oken | Uchovávat pozice oken

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Uchovaná pozice okna - je pozice okna uživatele | BWWINDPS bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_BWWINDPS_bwwindps | P | bw01uziv, bwa6key, bwa6scrh, bwa6scrw | PI - bw01uziv+bwa6key
ix_BWWINDPS_bw01uziv |  | bw01uziv | Identifikace uživatele systému


BWZIPFIL Soubor ZIP

Popis

Soubor ZIP

Atributy

Atribut | Typ | Návěští | Message | Popis
bwb0nazev | C(80) | bwb0nazev | Název souboru templatu | Název souboru templatu
bwb0soubor | M | bwb0soubor | Obsah souboru (ZIP) | Obsah souboru (ZIP)
bwb0datum | T | bwb0datum | Datum a čas souboru | Datum a čas souboru

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Příloha předlohy výstupu - používá ZIP soubor | BWPRINTA bwb0nazev | 1,1 : 0,M | BWZIPFIL bwb0nazev |

Indexy

Název | Primární | Výraz | Popis
ix_BWZIPFIL_bwb0nazev | P | bwb0nazev | Název souboru templatu


Tabulky DI...

DIDIAR | Záznam diáře
DIPOPDIA | Kategorie diáře

Viz.také

DIDIAR Záznam diáře | DIPOPDIA Kategorie diáře


DIDIAR Záznam diáře

Popis

Objektem typu DIDAR je každý záznam, který obsahuje záznam v diáři uživatele systému.
*** Dříve VYVESKAX.

'Diář', DTOC($$$.di01datod), ALLTRIM($$$.di01text), 'Kategorie - '+ALLT($$$.di02id) + ' - ' + ALLT(DIPOPDIA.di02kateg),'', .F.

Atributy

Atribut | Typ | Návěští | Message | Popis
di01 | C(12) | di01 | Jednoznačný časový identifikátor záznamu diáře. | Jednoznačný časový identifikátor záznamu diáře. *** Dříve VYV_OZ5.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw01uziv1 | C(6) | bw01uziv1 | Identifikace uživatele systému - druhá identifikace | Identifikace uživatele systému - druhá identifikace předplňovaná většinou na pozadí
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
di01od | T | di01od |  |
di01do | T | di01do |  |
di02id | C(6) | Kategorie | Identifikátor kategorie. | Identifikátor kategorie předdefinovaného popisu. *** Dříve VYR_ID.
di01text | C(40) | Popis | Výstižný popis záznamu diáře. | Text výstižně popisující záznam diáře. *** Dříve VYX_VOL.
di01udal | N(1,0) | Událost | Charakter události | Charakter události. *** Dříve VYX_SOUKR.
di01koment | M | Komentář | Komentář, který detailně popisuje událost. | Komentář, který detailně popisuje událost.
di01kolize | N(1,0) | di01kolize |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Záznam diáře - má kategorii | DIDIAR di02id | 1,1 : 0,M | DIPOPDIA di02id |
Záznam diáře - přísluší pracovníkovi | DIDIAR bw01uziv1 | 1,1 : 0,M | BWUZIVAT bw01uziv |
Záznam diáře - zapsal pracovník | DIDIAR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_DIDIAR_di01 | P | di01 | Jednoznačný časový identifikátor záznamu diáře.
ix_DIDIAR_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_DIDIAR_bw01uziv1 |  | bw01uziv1 | Identifikace uživatele systému - druhá identifikace předplňovaná většinou na pozadí
ix_DIDIAR_di01od |  | di01od |
ix_DIDIAR_di01do |  | di01do |
ix_DIDIAR_di02id |  | di02id | Identifikátor kategorie předdefinovaného popisu.
ix_DIDIAR_di01text |  | di01text | Text výstižně popisující záznam diáře.
ix_DIDIAR_di01udal |  | di01udal | Charakter události.


DIPOPDIA Kategorie diáře

Popis

Objektem typu DIPOPDIA je každý záznam, který obsahuje typ záznamu diáře. Pomocí typů lze záznamy v diáři kategorizovat.
Typy záznamů diáře slouží současně jako typy záznamů zpráv a záznamů rezervace materiálu.

Atributy

Atribut | Typ | Návěští | Message | Popis
di02id | C(6) | Kategorie | Identifikátor kategorie. | Identifikátor kategorie předdefinovaného popisu. *** Dříve VYR_ID.
di02 | C(12) | di02 | Jednoznačný časový identifikátor předdefinovaných textů pro diář. | Jednoznačný časový identifikátor předdefinovaných textů pro diář. *** Dříve VYR_OZ.
di02kateg | C(40) | Název kategorie | Text výstižně popisující kategorii. | Text výstižně popisující kategorii. *** Dříve VYR_TXT.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
di02rezer | N(1,0) | Kolize | Vyhodnocovat kolize při použití v rezervaci spravovaného majetku | Rezevovat při použití v rezervaci spravovaného majetku

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Kategorie diáře - byla zapsána | DIPOPDIA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Záznam diáře - má kategorii | DIDIAR di02id | 1,1 : 0,M | DIPOPDIA di02id |
Rezervace - je kategorie | SMREZER di02id | 1,1 : 0,M | DIPOPDIA di02id |

Indexy

Název | Primární | Výraz | Popis
ix_DIPOPDIA_di02id | P | di02id | Identifikátor kategorie předdefinovaného popisu.
ix_DIPOPDIA_di02 | U | di02 | Jednoznačný časový identifikátor předdefinovaných textů pro diář.
ix_DIPOPDIA_di02kateg |  | di02kateg | Text výstižně popisující kategorii.
ix_DIPOPDIA_bw01uziv |  | bw01uziv | Identifikace uživatele systému


Tabulky DP...

DPAH | Aktuální hodnota
DPAHUD | Událost - skladba
DPPRI | Daňové přiznání
DPPRIHOD | Hodnoty doplňované na daňové přiznání
DPPRIRD | Řádek daňového přiznání
DPPRIRDH | Hodnota řádku daňového přiznání v období
DPUDA | Událost DPH
DPUMIST | Umístění DPH
DPZPCH | Předmět zdanitelného plnění
DPZPD | Substituce TZP při vstupu události obchodu pro definiční TZP
DPZPS | Sazba daně z přidané hodnoty
DPZPT | Typ zdanitelného plnění
DPZPTU | Uplatnění předmětu ZDP

Viz.také

DPAH Aktuální hodnota | DPAHUD Událost - skladba | DPPRI Daňové přiznání | DPPRIHOD Hodnoty doplňované na daňové přiznání | DPPRIRD Řádek daňového přiznání | DPPRIRDH Hodnota řádku daňového přiznání v období | DPUDA Událost DPH | DPUMIST Umístění DPH | DPZPS Sazba daně z přidané hodnoty | DPZPT Typ zdanitelného plnění | DPZPCH Předmět zdanitelného plnění | DPZPTU Uplatnění předmětu ZDP | DPZPD Substituce TZP při vstupu události obchodu pro definiční TZP


DPAH Aktuální hodnota

Atributy

Atribut | Typ | Návěští | Message | Popis
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
dp15id | C(6) | Umístění DPH | Identifikace umístění DPH | Identifikace umístění DPH
ad01id | C(6) | Adresát | Adresát | Identifikace adresáta
dp02hodnot | N(20,4) | Aktuální hodnota | Aktuální hodnota |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Aktuální hodnota - se týká aktéra | DPAH ad01id | 1,1 : 0,M | ADADSAT ad01id |

Indexy

Název | Primární | Výraz | Popis
ix_DPAH_dpah | P | sp67id, sp06idsubs, dp15id, ad01id |
ix_DPAH_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_DPAH_ad01id |  | ad01id | Identifikace adresáta
ix_DPAH_dp02hodnot |  | dp02hodnot |


DPAHUD Událost - skladba

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
dp02 | C(12) | dp02 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ad01id | C(6) | Adresát | Adresát | Identifikace adresáta
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp74id | C(6) | Umístění | Umístění | Umístění
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp00datum | D | Datum | Datum události | Datum události
sp00text | C(40) | Popis | Popis události | Popis události
sp00hodnot | N(20,4) | Hodnota | Aktuální hodnota procesu |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost - skladba - se týká aktéra | DPAHUD ad01id | 0,1 : 0,M | ADADSAT ad01id |
Událost - skladba - týká se operace | DPAHUD dp02 | 1,1 : 0,M s rušením | DPUDA dp02 |
Událost - skladba - týká se druhu hodnoty | DPAHUD sp67id sp06idsubs | 0,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_DPAHUD_sp33hid |  | sp33hid | Časová identifikace hlavního procesu
ix_DPAHUD_dp02 |  | dp02 | Jednoznačná časová identifikace
ix_DPAHUD_ad01id |  | ad01id | Identifikace adresáta
ix_DPAHUD_sp74id |  | sp74id | Umístění
ix_DPAHUD_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_DPAHUD_spahud |  | sp60id, sp61id, ad01id, sp74id, sp67id, sp06idsubs | Artikl+Aktér+Umístění+Druh hodnoty


DPPRI Daňové přiznání

Popis

Daňové přiznání

Atributy

Atribut | Typ | Návěští | Message | Popis
dp08id | C(6) | Daň.přiz. | Identifikace daňového přiznání | Identifikace daňového přiznání
dp08nazpri | C(40) | dp08nazpri | Název daňového přiznání | Název daňového přiznání
dp08koment | M | dp08koment | Poznámka k daňovému přiznání | Poznámka k daňovému přiznání
dp02char2 | N(1,0) | dp02char2 | Běžná, opravné hlášení, neuplatněné DPH .... | Běžná, Opravné hlášení Běžná,Opravné hlášení,Ostatní,Neuplatněné DPH opraveno 20.7.2006
dp08platod | D | Platnost | Platnost definice daňového přiznání od | Platnost definice daňového přiznání od
dp08platdo | D | do | Platnost definice daňového přiznání do | Platnost definice daňového přiznání do

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Řádek daňového přiznání - patří na k daňovému přiznání | DPPRIRD dp08id | 1,1 : 0,M s rušením | DPPRI dp08id |
Hodnoty doplňované na daňové přiznání - se vztahují k typu daňového přiznání | DPPRIHOD dp08id | 1,1 : 0,M s rušením | DPPRI dp08id |

Indexy

Název | Primární | Výraz | Popis
ix_DPPRI_dp08id | P | dp08id | Identifikace daňového přiznání
ix_DPPRI_dp08nazpri |  | dp08nazpri | Název daňového přiznání


DPPRIHOD Hodnoty doplňované na daňové přiznání

Popis

Hodnoty doplňované na daňové přiznání

Atributy

Atribut | Typ | Návěští | Message | Popis
dp08id | C(6) | Daň.přiz. | Identifikace daňového přiznání | Identifikace daňového přiznání
dp14rok | C(4) | dp14rok | Rok | Rok
dp14meskva | C(2) | Měsíc / kvartál | Měsíc / kvartál - 01,02,...,11,12 / Q1,Q2,Q3,Q4 | Měsíc / kvartál
dp14rezim | N(20,2) | $REŽIM$ | Odpočet daně při změně režimu | Odpočet daně při změně režimu
dp14vypor1 | N(20,2) | $VYPOŘÁDÁNÍ-VSTUP$ | Vypořádání vstup | Vypořádání vstup
dp14vypor2 | N(20,2) | $VYPOŘÁDÁNÍ-VÝSTUP$ | Vypořádání výstup | Vypořádání výstup
dp14dalsi1 | N(20,2) | $DALŠÍ1$ | Pomocná proměnná | Pomocná proměnná
dp14dalsi2 | N(20,2) | $DALŠÍ2$ | Pomocná proměnná | Pomocná proměnná
dp14dalsi3 | N(20,2) | $DALŠÍ3$ | Pomocná proměnná | Pomocná proměnná
dp14koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Hodnoty doplňované na daňové přiznání - se vztahují k typu daňového přiznání | DPPRIHOD dp08id | 1,1 : 0,M s rušením | DPPRI dp08id |

Indexy

Název | Primární | Výraz | Popis
ix_DPPRIHOD_dpprihod | P | dp08id, dp14rok, dp14meskva | PI - Hodnoty doplňované na daňové přiznání
ix_DPPRIHOD_dp08id |  | dp08id | Identifikace daňového přiznání


DPPRIRD Řádek daňového přiznání

Popis

Řádek daňového přiznání

Atributy

Atribut | Typ | Návěští | Message | Popis
dp08id | C(6) | Daň.přiz. | Identifikace daňového přiznání | Identifikace daňového přiznání
dp09id | C(6) | Řádek | Identifikace řádku daňového přiznání | Identifikace řádku daňového přiznání
dp09parag | N(2,0) | Paragraf | Číslo paragrafu řádku daňového přiznání | Číslo paragrafu řádku daňového přiznání
dp09porad | N(3,0) | Pořadí | Pořadí řádku daňového přiznání v paragrafu | Pořadí řádku daňového přiznání v paragrafu
dp09text | C(40) | Popis řádku | Popis řádku daňového přiznání | Popis řádku daňového přiznání
dp09text2 | M | Dlouhý popis | Popis řádku daňového přiznání - dlouhý | Popis řádku daňového přiznání - dlouhý
dp09oznace | C(9) | dp09oznace | Označení řádku na formuláři vypočtené daně | Označení řádku na formuláři vypočtené daně
dp09typ | N(1,0) | Způsob výp. | Způsob výpočtu řádku - hodnota/součet řádků | Způsob výpočtu řádku - hodnota/součet řádků
dp09vyraz | M | Výraz | Výraz pro výpočet řádku | Výraz pro výpočet řádku
dp02odpnap | N(1,0) | O/N | Odpočet/Nápočet | Odpočet/Nápočet
dp05id | C(3) | Typ místa | Identifikace typu místa zdanitelného plnění | Identifikace typu místa zdanitelného plnění
dp09vbrzdp | N(1,0) | dp09vbrzdp | Respektovat zdanitelé plnění | Respektovat zdanitelé plnění
dp04tuzzah | N(1,0) | dp04tuzzah | Typ místa tuzemsko, zahraničí, Evropská Unie .... | Tuzemsko/Zahraničí
dp03chzah | N(1,0) | dp03chzah | Pro vývoz do zahraničí - Vývoz zboží, Vývoz služeb, Mezinárodní přeprava, .... | Vývoz zboží, Vývoz služeb, Mezinárodní přeprava, ....
dp03chtuz | N(1,0) | dp03chtuz | Pro tuzemsko a zahraniční odpočet - Osvobozená,Osvobozená pro koef.,Snížená,Základní,Dočasné použití | Pro tuzemsko - Osvobozená,Snížená,Základní
dp02uod | N(1,0) | dp02uod | Způsob uplatnění odpočtu daně - 1=100%,2=0%,3=kráceno | Způsob uplatnění odpočtu daně
dp03ucel | N(1,0) | Účel daně | Účel daně | Účel daně - pro potřeby daňového přiznání - řádek 35a, 36a, 37a, 38a. Vývoz zboží bez změny vlastnictví.
dp09pomoc | N(1,0) | Pomocný | Pomocný řádek, který nebude přenesen na DP | Pomocný řádek, který nebude přenesen na DP
dp09zaklad | N(1,0) | Základ | Zahrnout na daňové přiznání / vypočítat hodnotu sloupce - základ daně | Zahrnout na daňové přiznání / vypočítat hodnotu sloupce - základ daně
dp09vstup | N(1,0) | Vstup | Zahrnout na daňové přiznání / vypočítat hodnotu sloupce - DPH vstup | Zahrnout na daňové přiznání / vypočítat hodnotu sloupce - DPH vstup
dp09vystup | N(1,0) | Výstup | Zahrnout na daňové přiznání / vypočítat hodnotu sloupce - DPH výstup | Zahrnout na daňové přiznání / vypočítat hodnotu sloupce - DPH výstup
dp09vbreu | N(1,0) | dp09vbreu | Vybírat typ místa EU | Vybírat typ místa EU
dp09vbrtuz | N(1,0) | dp09vbrtuz | Vybírat typ místa tuzemsko | Vybírat typ místa tuzemsko
dp09vbrzah | N(1,0) | dp09vbrzah | Vybírat typ místa zahraničí | Vybírat typ místa zahraničí
dp16id | C(6) | Předmět | Identifikace předmětu zdanitelného plnění | Identifikace předmětu zdanitelného plnění
dp09xmlzak | M | XML - základ | Název XML atributu pro hodnotu základu daně | Název XML atributu pro hodnotu základu daně
dp09xmlvst | M | XML - vstup | Název XML atributu pro hodnotu vstupu daně | Název XML atributu pro hodnotu vstupu daně
dp09xmlvys | M | XML - výstup | Název XML atributu pro hodnotu výstupu daně | Název XML atributu pro hodnotu výstupu daně
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Řádek daňového přiznání - patří na k daňovému přiznání | DPPRIRD dp08id | 1,1 : 0,M s rušením | DPPRI dp08id |
Řádek daňového přiznání - vybírá maskou události DPH | DPPRIRD dp16id | 1,1 : 0,M | DPZPCH dp16id |
Řádek daňového přiznání - se uplatňuje pro technicko-věcný selektor | DPPRIRD sp20idzak | 0,1 : 0,M | SPSETV sp20idzak |
Hodnota řádku daňového přiznání v období - se vztahuje k řádku daňového přiznání | DPPRIRDH dp08id dp09id | 1,1 : 0,M s rušením | DPPRIRD dp08id dp09id |

Indexy

Název | Primární | Výraz | Popis
ix_DPPRIRD_dpprird | P | dp08id, dp09id |
ix_DPPRIRD_dp08id |  | dp08id | Identifikace daňového přiznání
ix_DPPRIRD_dp04tuzzah |  | dp04tuzzah | Tuzemsko/Zahraničí
ix_DPPRIRD_dp16id |  | dp16id | Identifikace předmětu zdanitelného plnění
ix_DPPRIRD_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.


DPPRIRDH Hodnota řádku daňového přiznání v období

Popis

Hodnota řádku daňového přiznání

Atributy

Atribut | Typ | Návěští | Message | Popis
dp08id | C(6) | Daň.přiz. | Identifikace daňového přiznání | Identifikace daňového přiznání
dp09id | C(6) | Řádek | Identifikace řádku daňového přiznání | Identifikace řádku daňového přiznání
dp11rok | C(4) | dp11rok | Rok | Rok
dp11meskva | C(2) | dp11meskva | Měsíc / kvartál | Měsíc / kvartál
dp11zaklad | N(20,4) | dp11zaklad | Základ daně | Základ daně
dp11vstup | N(20,4) | dp11vstup | DPH - vstup | DPH - vstup
dp11vystup | N(20,4) | dp11vystup | DPH - vystup | DPH - vystup

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Hodnota řádku daňového přiznání v období - se vztahuje k řádku daňového přiznání | DPPRIRDH dp08id dp09id | 1,1 : 0,M s rušením | DPPRIRD dp08id dp09id |

Indexy

Název | Primární | Výraz | Popis
ix_DPPRIRDH_dpprirdh | P | dp08id, dp09id, dp11rok, dp11meskva |
ix_DPPRIRDH_dpprird |  | dp08id, dp09id |
ix_DPPRIRDH_dpprirdhi |  |  |


DPUDA Událost DPH

Popis

Objektem typu DPUDA je každá událost DPH - informace o dani z přidané hodnoty. Obsahuje atributy typ plnění DPH, typ místa zdanitelného plnění, procento daně z přidané hodnoty, částku základu daně z přidané hodnoty a částku daně. Typ zdanitelného plnění je získán z artiklu, který je obchodován. Typ místa zdanitelného plnění je získán z místa určení artiklu (adresy příjemce). Hodnota DPH je určena ze základu daně a ze sazby DPH (získané z parametrů Typ zdanitelného plnění, Typ místa zdanitelného plnění, Datum zdanitelného plnění), s případným zaokrouhlením. Po výpočtu DPH se provádí přepočet na refernční měnu.
*** Dříve DPH

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ad01id | C(6) | Adresát | Adresát | Identifikace adresáta
ad11cisspo | C(2) | Číslo spojení adresáta | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
dp05id | C(3) | Typ místa zdanitelného plnění | Identifikace typu místa zdanitelného plnění | Identifikace typu místa zdanitelného plnění
dp03id | C(3) | Typ zdanitelného plnění | Identifikace typu zdanitelného plnění | Identifikace typu zdanitelného plnění
dp02 | C(12) | dp02 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
dp02datzdp | D | Datum | Datum uskutečnění zdanitelného plnění | Datum uskutečnění zdanitelného plnění
dp02text | C(40) | Popis | Popis události DPH | Popis události DPH
dp02pid | C(32) | PID | Pomocná identifikace záznamu DPH | Pomocná identifikace záznamu DPH
dp15id | C(6) | Umístění DPH | Identifikace umístění DPH | Identifikace umístění DPH
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
oc01id1 | C(3) | Referenční měna | Referenční měna | Referenční měna kursu (je na pozadí)
oc03kurz | N(20,6) | Kurs | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup. | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup.
oc03mn | N(5,0) | Množství | Množství oceňovací jednotky v kursu. | Množství oceňovací jednotky v kurzu.
dp04tuzzah | N(1,0) | dp04tuzzah | Typ místa tuzemsko, zahraničí, Evropská Unie .... | Tuzemsko/Zahraničí
dp02sazba | N(5,2) | Sazba DPH | Procentní sazba daně z přidané hodnoty | Sazba daně z přidané hodnoty. Povolené hodnoty jsou základní, snížená nebo nulová.
dp02czazm | N(20,4) | Základ DPH v ZM | Částka základu daně z přidané hodnoty v ZM - odpočet | Částka základu daně z přidané hodnoty v zahraniční měně
dp02cdpzm | N(20,4) | DPH v ZM | Částka daně z přidané hodnoty v zahraniční měně - odpočet | Částka daně z přidané hodnoty v zahraniční měně
dp02czarm | N(20,4) | Základ DPH v RM | Částka základu daně z přidané hodnoty v referenční měně | Částka základu daně z přidané hodnoty v referenční měně
dp02cdprm | N(20,4) | DPH v RM | Částka daně z přidané hodnoty v referenční měně | Částka daně z přidané hodnoty v referenční měně
dp02cdzrm | N(20,4) | DPH v RM (zaokr.) | Zaokrouhlená částka daně z přidané hodnoty v referenční měně | Zaokrouhlená částka daně z přidané hodnoty v referenční měně
bw01uziv | C(6) | Zapsal | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
sp10idzak | C(9) | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Identifikátor organizačního selektoru | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Identifikátor technicko-věcného selektoru | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
dp02char2 | N(1,0) | dp02char2 | Běžná, opravné hlášení, neuplatněné DPH .... | Běžná, Opravné hlášení Běžná,Opravné hlášení,Ostatní,Neuplatněné DPH opraveno 20.7.2006
dp02odpnap | N(1,0) | O/N | Odpočet/Nápočet | Odpočet/Nápočet
dp02zaokro | N(1,0) | Zaokrouhlovat částku daně | Zaokrouhlovat částku daně z přidané hodnoty ? | Zaokrouhlovat částku daně z přidané hodnoty ?
dp02uod | N(1,0) | dp02uod | Způsob uplatnění odpočtu daně - 1=100%,2=0%,3=kráceno | Způsob uplatnění odpočtu daně
dp16id | C(6) | Předmět | Identifikace předmětu zdanitelného plnění | Identifikace předmětu zdanitelného plnění

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost DPH - Má typ zdanitelného plnění | DPUDA dp03id | 1,1 : 0,M | DPZPT dp03id |
Událost DPH - má měnu | DPUDA oc01id | 1,1 : 0,M | OCMENA oc01id |
Událost DPH - má referenční měnu | DPUDA oc01id1 | 1,1 : 0,M | OCMENA oc01id |
Událost DPH - Má adresu adresáta | DPUDA ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost DPH - byla zapsána uživatelem | DPUDA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost DPH - patří do fyzické operace | DPUDA sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost DPH - má obchodní selektor | DPUDA sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost DPH - má organizační selektor | DPUDA sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost DPH - má technicko-věcný selektor | DPUDA sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost DPH - vznikla na umístění | DPUDA dp15id | 1,1 : 0,M | DPUMIST dp15id |
Událost DPH - má charakter zdanitelného plnění | DPUDA dp16id | 1,1 : 0,M | DPZPCH dp16id |
Událost - skladba - týká se operace | DPAHUD dp02 | 1,1 : 0,M s rušením | DPUDA dp02 |

Indexy

Název | Primární | Výraz | Popis
ix_DPUDA_spprc |  | sp33cisd, sp33cisdpm, sp33cisdr | Identifikace procesu
ix_DPUDA_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_DPUDA_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_DPUDA_dpprird1 |  | dp05id, dp03id | dp05id+dp03id
ix_DPUDA_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_DPUDA_dp02 | P | dp02 | Jednoznačná časová identifikace
ix_DPUDA_dp02datzdp |  | dp02datzdp | Datum uskutečnění zdanitelného plnění
ix_DPUDA_dp02text |  | dp02text | Popis události DPH
ix_DPUDA_dp02pid |  | dp02pid | Pomocná identifikace záznamu DPH
ix_DPUDA_dp15id |  | dp15id | Identifikace umístění DPH
ix_DPUDA_oc01id |  | oc01id | Kód měny - oceňovací jednotky.
ix_DPUDA_oc01id1 |  | oc01id1 | Referenční měna kursu (je na pozadí)
ix_DPUDA_dp03id |  | dp03id | Identifikace typu zdanitelného plnění
ix_DPUDA_dp04tuzzah |  | dp04tuzzah | Tuzemsko/Zahraničí
ix_DPUDA_dp05id |  | dp05id | Identifikace typu místa zdanitelného plnění
ix_DPUDA_dp02czarm |  | dp02czarm | Částka základu daně z přidané hodnoty v referenční měně
ix_DPUDA_ad01id |  | ad01id | Identifikace adresáta
ix_DPUDA_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_DPUDA_sp00datzap |  | sp00datzap | Datum a čas zápisu záznamu události
ix_DPUDA_sp33cisdr |  | sp33cisdr | Rok řady čísla procesu
ix_DPUDA_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_DPUDA_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_DPUDA_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_DPUDA_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_DPUDA_dp16id |  | dp16id | Identifikace předmětu zdanitelného plnění


DPUMIST Umístění DPH

Popis

Umístění DPH
Provizorně pozastavená RI na SPSEOR a ADSPOJ kvůli generování

Atributy

Atribut | Typ | Návěští | Message | Popis
dp15id | C(6) | Umístění DPH | Identifikace umístění DPH | Identifikace umístění DPH
dp15text | C(40) | Název umístění DPH | Název umístění DPH | Název umístění DPH
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Umístění DPH - má spojení na adresáta | DPUMIST ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost DPH - vznikla na umístění | DPUDA dp15id | 1,1 : 0,M | DPUMIST dp15id |

Indexy

Název | Primární | Výraz | Popis
ix_DPUMIST_dp15id | P | dp15id | Identifikace umístění DPH
ix_DPUMIST_dp15text |  | dp15text | Název umístění DPH
ix_DPUMIST_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_DPUMIST_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_DPUMIST_ad01id |  | ad01id | Identifikace adresáta


DPZPD Substituce TZP při vstupu události obchodu pro definiční TZP

Popis

Substituce TZP při vstupu události obchodu pro definiční TZP

Atributy

Atribut | Typ | Návěští | Message | Popis
dp03id | C(3) | Typ zd.pl. | Identifikace typu zdanitelného plnění | Identifikace typu zdanitelného plnění
dp04tuzzah | N(1,0) | dp04tuzzah | Typ místa tuzemsko, zahraničí, Evropská Unie .... | Tuzemsko/Zahraničí
dp02odpnap | N(1,0) | O/N | Odpočet/Nápočet | Odpočet/Nápočet
ad01pladph | N(1,0) | DPH | Příznak plátce DPH | Příznak plátce DPH (Povolené hodnoty A/N/mezera). *** Dříve PLDPH.
pa13idart | C(12) | Klasifikace artiklu | Identifikace klasifikace objektu artiklu | Identifikace klasifikace objektu artiklu
dp20datum | D | Platnost od | Platnost od | Platnost od
dp03id2 | C(3) | Typ zd.pl. neplátce DPH - nákup - zahraničí | Identifikace typu zdanitelného plnění pro nákup od neplátce DPH - zahraničí | Typ zd.pl. neplátce DPH - nápočet - zahraničí
dp20datumd | D | do | Platnost do | Platnost do

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Substituce TZP při vstupu události obchodu pro definiční TZP - určuje substituované TZP | DPZPD dp03id | 1,1 : 0,M s rušením | DPZPT dp03id |
Substituce TZP při vstupu události obchodu pro definiční TZP - určuje předplňované TZP | DPZPD dp03id2 | 1,1 : 0,M | DPZPT dp03id |

Indexy

Název | Primární | Výraz | Popis
ix_DPZPD_dpzpd | P | dp03id, dp04tuzzah, dp02odpnap, ad01pladph, pa13idart, dp20datum | PI - dp03id+dp04tuzzah+dp02odpnap+ad01pladph+pa13idart+dp20datum
ix_DPZPD_dp03id |  | dp03id | Identifikace typu zdanitelného plnění
ix_DPZPD_dp03id2 |  | dp03id2 | Typ zd.pl. neplátce DPH - nápočet - zahraničí


DPZPCH Předmět zdanitelného plnění

Popis

Předmět zdanitelného plnění

Atributy

Atribut | Typ | Návěští | Message | Popis
dp16id | C(6) | Předmět | Identifikace předmětu zdanitelného plnění | Identifikace předmětu zdanitelného plnění
dp16popcha | C(40) | Popis předmětu | Popis předmětu zdanitelného plnění | Popis předmětu zdanitelného plnění
dp16popch2 | C(40) | Další popis | Další popis předmětu zdanitelného plnění | Další popis předmětu zdanitelného plnění
dp16koment | M | Poznámka | Poznámka | Poznámka
pa13idart | C(12) | Klasifikace artiklu | Identifikace klasifikace objektu artiklu | Identifikace klasifikace objektu artiklu
dp16jendph | N(1,0) | Pouze DPH | Možné zadat pouze na události DPH Ano/Ne | Možné zadat pouze na události DPH Ano/Ne
dp16vyrpre | M | Výraz předpl. | Logický v jazyce Foxpro pro předplnění předmětu ZDP | Logický v jazyce Foxpro pro předplnění předmětu ZDP
dp16aktual | N(1,0) | Aktuální | Předmět je aktuální pro aktuální implementaci IS BM | Předmět je aktuální pro aktuální implementaci IS BM

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Uplatnění předmětu ZDP - se uplatňuje pro předmět ZDP | DPZPTU dp16id | 1,1 : 0,M | DPZPCH dp16id |
Událost obchodního plnění - má charakter zdanitelného plnění | OBUDAL dp16id | 1,1 : 0,M | DPZPCH dp16id |
Událost DPH - má charakter zdanitelného plnění | DPUDA dp16id | 1,1 : 0,M | DPZPCH dp16id |
Řádek daňového přiznání - vybírá maskou události DPH | DPPRIRD dp16id | 1,1 : 0,M | DPZPCH dp16id |

Indexy

Název | Primární | Výraz | Popis
ix_DPZPCH_dp16id | P | dp16id | Identifikace předmětu zdanitelného plnění
ix_DPZPCH_dp16popcha |  | dp16popcha | Popis předmětu zdanitelného plnění


DPZPS Sazba daně z přidané hodnoty

Popis

Objektem typu DPZPS je každá definice sazby, její platnosti a způsobu zaokrouhlení příslušné danému typu zdanitelného plnění (#DPZPT) a k typu místa zdanitelného plnění (#DPZPM).

Obsahuje procentní sazby příslušné k typům plnění DPH a jejich platnosti. Vytváří třírozměrný prostor v němž:
osa x obsahuje Typy zdanitelného plnění (Bez daně, Snížená, Základní)
osa y obsahuje Typy míst zdanitelného plnění (Tuzemsko, Vývoz)
osa z je časovou osou - obashuje data od kterých sazba pro daný Typ zdanitelného plnění a daný Typ místa zdanitelného plnění platila.
Prvek v prostoru obsahuje hodnotu sazby.
Zjištění sazby se provádí vyhledáním v tomto prostoru dle zadaných parametrů. Pokud nelze sazbu vyhledat není možné realizovat danou událost DPH.
Pro daný způsob uložení dat je ideální grafický způsob realizace (matice, krychle).

Obsahuje též způsob zaokrouhlení částky DPH při použití dané sazby.

Atributy

Atribut | Typ | Návěští | Message | Popis
dp03id | C(3) | Typ zdanitelného plnění | Identifikace typu zdanitelného plnění | Identifikace typu zdanitelného plnění
dp04tuzzah | N(1,0) | dp04tuzzah | Typ místa tuzemsko, zahraničí, Evropská Unie .... | Tuzemsko/Zahraničí
dp04datpld | D | Platnost od | Datum platnosti sazby DPH od | Datum platnosti sazby DPH do
dp04sazba | N(5,2) | Sazba DPH - vstup | Procentní sazba daně z přidané hodnoty na vstupu | Sazba daně z přidané hodnoty na vstupu. Povolené hodnoty jsou základní, snížená nebo nulová.
dp04sazbao | N(5,2) | Sazba DPH - výstup | Procentní sazba daně z přidané hodnoty na výstupu | Sazba daně z přidané hodnoty na výstupu. Povolené hodnoty jsou základní, snížená nebo nulová.
dp04zar | N(2,0) | Zaokrouhlení na řád | Zaokrouhlení na řád. | Zaokrouhlení na řád. Určuje způsob zaokrouhlení (stovky, desítky, jednotky, desetiny, setiny)
dp04zac | N(1,0) | Nahoru od cifry | Zaokrouhlení nahoru od cifry | Zaokrouhlení nahoru od cifry Určuje způsob zaokrouhlení (od cifry 5 nahoru, od cifry 6 nahoru)
uc01id | C(9) | Účet | Identifikátor účtu účetnictví | Identifikátor účtu
uc01id2 | C(9) | uc01id2 | Identifikátor účtu | Identifikátor účtu
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
dp05id | C(3) | Typ místa zdanitelného plnění | Identifikace typu místa zdanitelného plnění | Identifikace typu místa zdanitelného plnění

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Sazba daně z přidané hodnoty - má technicko-věcný selektor | DPZPS sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Sazba daně z přidané hodnoty - odpovídá účtu účetnictví pro nápočet | DPZPS uc01id | 0,1 : 0,M | UCROZVRH uc01id |
Sazba daně z přidané hodnoty - odpovídá účtu účetnictví pro odpočet | DPZPS uc01id2 | 0,1 : 0,M | UCROZVRH uc01id |
Sazba daně z přidané hodnoty - přísluší typu zdanitelného plnění | DPZPS dp03id | 1,1 : 0,M s rušením | DPZPT dp03id |

Indexy

Název | Primární | Výraz | Popis
ix_DPZPS_dpzps1 | P | dp03id, dp04tuzzah, dp04datpld | dp03id+dp05id+dp04dat
ix_DPZPS_dp03id | P | dp03id | Identifikace typu zdanitelného plnění
ix_DPZPS_dp04datpld | P | dp04datpld | Datum platnosti sazby DPH do
ix_DPZPS_uc01id |  | uc01id | Identifikátor účtu
ix_DPZPS_uc01id2 |  | uc01id2 | Identifikátor účtu
ix_DPZPS_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.


DPZPT Typ zdanitelného plnění

Popis

Objektem typu DPZPT je každá definice typu zdanitelného plnění. Obsahuje pouze identifikaci a popis typu plnění DPH. Typem plnění se rozumí např. Bez daně, Snížená sazba, Základní sazba nebo i případně Osvobozené plnění, Mezinárodní přeprava, Vývoz ap. Konkrétní procentní sazby a jejich platnost je v entitě Sazba a její platnost.
Artikly v systému evidují Typ plnění DPH, který je pro ně platný. Tento typ zdanitelného plnění je uváděn jako implicitní (s možností změny) v událostech DPH.
Každý typ zdanitelného plnění je spojen s určitým technicko-věcným selektorem, což umožňuje použít obecný modul statistik.

Atributy

Atribut | Typ | Návěští | Message | Popis
dp03id | C(3) | Typ zdanitelného plnění | Identifikace typu zdanitelného plnění | Identifikace typu zdanitelného plnění
dp03text | C(40) | Název | Název typu zdanitelného plnění | Název typu zdanitelného plnění
dp03chzah | N(1,0) | dp03chzah | Pro vývoz do zahraničí - Vývoz zboží, Vývoz služeb, Mezinárodní přeprava, .... | Vývoz zboží, Vývoz služeb, Mezinárodní přeprava, ....
dp03chtuz | N(1,0) | dp03chtuz | Pro tuzemsko a zahraniční odpočet - Osvobozená,Osvobozená pro koef.,Snížená,Základní,Dočasné použití | Pro tuzemsko - Osvobozená,Snížená,Základní
dp03ucel | N(1,0) | Účel daně | Účel daně | Účel daně - pro potřeby daňového přiznání - řádek 35a, 36a, 37a, 38a. Vývoz zboží bez změny vlastnictví.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Uplatnění předmětu ZDP - se uplatňuje pro ZDP | DPZPTU dp03id | 1,1 : 0,M s rušením | DPZPT dp03id |
Substituce TZP při vstupu události obchodu pro definiční TZP - určuje substituované TZP | DPZPD dp03id | 1,1 : 0,M s rušením | DPZPT dp03id |
Substituce TZP při vstupu události obchodu pro definiční TZP - určuje předplňované TZP | DPZPD dp03id2 | 1,1 : 0,M | DPZPT dp03id |
Obchodovatelný artikl - má implicitní typ zdanitelného plnění | OBARTIKL dp03id | 0,1 : 0,M | DPZPT dp03id |
Druh artiklu - předplňuje typ zdanitelného plnění | SPARTIKD dp03id | 0,1 : 0,M | DPZPT dp03id |
Událost obchodního plnění - má typ zdanitelného plnění | OBUDAL dp03id | 1,1 : 0,M | DPZPT dp03id |
Událost DPH - Má typ zdanitelného plnění | DPUDA dp03id | 1,1 : 0,M | DPZPT dp03id |
Sazba daně z přidané hodnoty - přísluší typu zdanitelného plnění | DPZPS dp03id | 1,1 : 0,M s rušením | DPZPT dp03id |

Indexy

Název | Primární | Výraz | Popis
ix_DPZPT_dp03id | P | dp03id | Identifikace typu zdanitelného plnění
ix_DPZPT_dp03text |  | dp03text | Název typu zdanitelného plnění


DPZPTU Uplatnění předmětu ZDP

Popis

Uplatnění předmětu ZDP

Atributy

Atribut | Typ | Návěští | Message | Popis
dp16id | C(6) | Předmět | Identifikace předmětu zdanitelného plnění | Identifikace předmětu zdanitelného plnění
dp03id | C(3) | Typ zd.pl. | Identifikace typu zdanitelného plnění | Identifikace typu zdanitelného plnění
dp04tuzzah | N(1,0) | dp04tuzzah | Typ místa tuzemsko, zahraničí, Evropská Unie .... | Tuzemsko/Zahraničí
dp02odpnap | N(1,0) | O/N | Odpočet/Nápočet | Odpočet/Nápočet
dp18datum | D | Platnost od | Platnost od | Platnost od
uc01id | C(9) | Účet | Identifikátor účtu účetnictví | Identifikátor účtu
dp18datumd | D | do | Platnost do | Platnost do
ad01pladph | N(1,0) | DPH | Příznak plátce DPH | Příznak plátce DPH (Povolené hodnoty A/N/mezera). *** Dříve PLDPH.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
dp18koment | M | Poznámka | Poznámka | Poznámka
dp18parag | C(40) | Paragraf | Paragraf zákona o DPH | Paragraf zákona o DPH
pa13idart | C(12) | Klasifikace artiklu | Identifikace klasifikace objektu artiklu | Identifikace klasifikace objektu artiklu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Uplatnění předmětu ZDP - se uplatňuje pro ZDP | DPZPTU dp03id | 1,1 : 0,M s rušením | DPZPT dp03id |
Uplatnění předmětu ZDP - se uplatňuje pro předmět ZDP | DPZPTU dp16id | 1,1 : 0,M | DPZPCH dp16id |
Uplatnění předmětu ZDP - definuje účetní účet | DPZPTU uc01id | 1,1 : 0,M | UCROZVRH uc01id |
Uplatnění předmětu ZDP - předplňuje TV-selektor na události | DPZPTU sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |

Indexy

Název | Primární | Výraz | Popis
ix_DPZPTU_dpzptu | P | dp16id, dp03id, dp04tuzzah, dp02odpnap, dp18datum | PI - dp16id+dp03id+dp04tuzzah+dp02odpnap+dp18datum
ix_DPZPTU_dp03id |  | dp03id | Identifikace typu zdanitelného plnění
ix_DPZPTU_uc01id |  | uc01id | Identifikátor účtu
ix_DPZPTU_dp16id |  | dp16id | Identifikace předmětu zdanitelného plnění
ix_DPZPTU_dp18datum |  | dp18datum | Platnost od
ix_DPZPTU_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.


Tabulky EX...

EXAH | Aktuální hodnota expedice
EXAHUD | Skladba aktuální hodnoty expedice
EXARTIKL | Vozidlo - expedice
EXPARAM | Parametry expedice
EXRIDIC | Řidič - expedice
EXTRASA | Trasa expedice
EXTRASAV | Adresa na trase expedice
EXTYPVOZ | Typ vozidla expedice
EXUDAL | Událost expedice
EXUDAOPE | Operace spojená s událostí expedice

Viz.také

EXAH Aktuální hodnota expedice | EXAHUD Skladba aktuální hodnoty expedice | EXARTIKL Vozidlo - expedice | EXRIDIC Řidič - expedice | EXTRASA Trasa expedice | EXTRASAV Adresa na trase expedice | EXTYPVOZ Typ vozidla expedice | EXUDAL Událost expedice | EXUDAOPE Operace spojená s událostí expedice | EXPARAM Parametry expedice


EXAH Aktuální hodnota expedice

Popis

Aktuální hodnota expedice

Atributy

Atribut | Typ | Návěští | Message | Popis
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
ex07id | C(6) | Řidič | Identifikace řidiče | Identifikace řidiče
ex04id | C(6) | Trasa | Identifikace trasy | Identifikace trasy
ex08hodnot | N(20,4) | Hodnota | Hodnota | Hodnota

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Aktuální hodnota expedice - se vztahuje k vozidlu expedice | EXAH sp60id sp61id | 1,1 : 0,M | EXARTIKL sp60id sp61id |
Aktuální hodnota expedice - se vztahuje k řidiči expedice | EXAH ex07id | 1,1 : 0,M | EXRIDIC ex07id |
Aktuální hodnota expedice - se vztahuje k trase expedice | EXAH ex04id | 1,1 : 0,M | EXTRASA ex04id |
Aktuální hodnota expedice - je druhu hodnoty | EXAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_EXAH_exah | P | sp67id, sp06idsubs, sp60id, sp61id, ex07id, ex04id |
ix_EXAH_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_EXAH_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_EXAH_ex07id |  | ex07id | Identifikace řidiče
ix_EXAH_ex04id |  | ex04id | Identifikace trasy


EXAHUD Skladba aktuální hodnoty expedice

Popis

Skladba aktuální hodnoty expedice

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
ex07id | C(6) | Řidič | Identifikace řidiče | Identifikace řidiče
ex04id | C(6) | Trasa | Identifikace trasy | Identifikace trasy
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp00datum | D | Datum | Datum události | Datum události
sp00text | C(40) | Popis | Popis události | Popis události
sp00hodnot | N(20,4) | Hodnota | Aktuální hodnota procesu |


EXARTIKL Vozidlo - expedice

Popis

Vozidlo - expedice

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
ex03id | C(6) | Typ | Typ vozidla | Typ vozidla
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
ex01spz | C(12) | SPZ | SPZ vozidla | SPZ vozidla
ex07id | C(6) | Řidič | Identifikace řidiče | Identifikace řidiče
ex03sirka | N(5,0) | Šířka (mm) | Šířka vozidla v milimetrech | Šířka vozidla v milimetrech
ex03vyska | N(5,0) | Výška (mm) | Výška vozidla v milimetrech | Výška vozidla v milimetrech
ex03delka | N(5,0) | Délka (mm) | Délka vozidla v milimetrech | Délka vozidla v milimetrech
ex03lpdelk | N(5,0) | Délka LP (mm) | Délka ložné plochy vozidla v milimetrech | Délka ložné plochy vozidla v milimetrech
ex03lpsirk | N(5,0) | Šířka LP (mm) | Šířka ložné plochy vozidla v milimetrech | Šířka ložné plochy vozidla v milimetrech
ex03lpvysk | N(5,0) | Výška LP (mm) | Výška ložné plochy vozidla v milimetrech | Výška ložné plochy vozidla v milimetrech
ex03hmopoh | N(5,0) | Pohotov. hm. (kg) | Pohotovostní hmotnost v kilogramech | Pohotovostní hmotnost v kilogramech
ex03hmouzi | N(5,0) | Užitečná hm. (kg) | Užitečná hmotnost v kilogramech | Užitečná hmotnost v kilogramech
ex03nebnak | N(1,0) | ex03nebnak | Nebezpečný náklad | Nebezpečný náklad
ex03prives | N(1,0) | ex03prives | Možnost přívěsu | Možnost přívěsu
ex01aktual | N(1,0) | Aktuální | Vozidlo je aktuální pro použití | Vozidlo je aktuální pro použití

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vozidlo - expedice - je artiklem | EXARTIKL sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Vozidlo - expedice - založil uživatel | EXARTIKL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Vozidlo - expedice - má TV selektor | EXARTIKL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Vozidlo - expedice - je typu | EXARTIKL ex03id | 1,1 : 0,M | EXTYPVOZ ex03id |
Vozidlo - expedice - má obvykle řidiče | EXARTIKL ex07id | 1,1 : 0,M | EXRIDIC ex07id |
Trasa expedice - má implicitní vozidlo | EXTRASA sp60id sp61id | 1,1 : 0,M | EXARTIKL sp60id sp61id |
Událost expedice - je o vozidle expedice | EXUDAL sp60id sp61id | 1,1 : 0,M | EXARTIKL sp60id sp61id |
Aktuální hodnota expedice - se vztahuje k vozidlu expedice | EXAH sp60id sp61id | 1,1 : 0,M | EXARTIKL sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_EXARTIKL_spartikl | P | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_EXARTIKL_sp61id |  | sp61id | Identifikace druhu artiklu
ix_EXARTIKL_ex03id |  | ex03id | Typ vozidla
ix_EXARTIKL_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_EXARTIKL_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_EXARTIKL_ex01spz |  | ex01spz | SPZ vozidla
ix_EXARTIKL_ex07id |  | ex07id | Identifikace řidiče


EXPARAM Parametry expedice

Popis

Parametry expedice

Atributy

Atribut | Typ | Návěští | Message | Popis
ex13id | C(6) | ID | Identifikátor parametrů expedice | Identifikátor parametrů expedice
ex13idu | C(2) | IDÚ | Datové úložiště uplatnění parametrů | Datové úložiště uplatnění parametrů
ex13poppar | C(40) | Popis | Popis parametrů expedice | Popis parametrů expedice
ex13sql | M | SQL DL | Doplnění dotazu SQL pro výběr dodacích listů expedičního příkazu | Doplnění dotazu SQL pro výběr dodacích listů expedičního příkazu
ex13koment | M | Poznámka | Poznámka | Poznámka
ex13datum | D | Platnost | Platnost od | Platnost od
ex13datumd | D | do | Platnost do | Platnost do

Indexy

Název | Primární | Výraz | Popis
ix_EXPARAM_ex13id | P | ex13id | Identifikátor parametrů expedice
ix_EXPARAM_ex13poppar |  | ex13poppar | Popis parametrů expedice


EXRIDIC Řidič - expedice

Popis

Řidič - expedice

Atributy

Atribut | Typ | Návěští | Message | Popis
ex07id | C(6) | Řidič | Identifikace řidiče | Identifikace řidiče
ex07jmerid | C(40) | Jméno řidiče | Jméno řidiče | Jméno řidiče
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
ex07aktual | N(1,0) | Aktuální | Řidič je aktuální Ano/Ne | Řidič je aktuální Ano/Ne
spd3id | C(6) | Kalendář | Identifikace kalendáře | Identifikace kalendáře

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Řidič - expedice - má adresátové spojení | EXRIDIC ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Řidič - expedice - odpovídá obchodnímu selektoru | EXRIDIC sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Řidič - expedice - je vytěžován podle kalendáře | EXRIDIC spd3id | 1,1 : 0,M | SPKALEN spd3id |
Vozidlo - expedice - má obvykle řidiče | EXARTIKL ex07id | 1,1 : 0,M | EXRIDIC ex07id |
Událost expedice - je o řidiči expedice | EXUDAL ex07id | 1,1 : 0,M | EXRIDIC ex07id |
Aktuální hodnota expedice - se vztahuje k řidiči expedice | EXAH ex07id | 1,1 : 0,M | EXRIDIC ex07id |

Indexy

Název | Primární | Výraz | Popis
ix_EXRIDIC_ex07id | P | ex07id | Identifikace řidiče
ix_EXRIDIC_ex07jmerid |  | ex07jmerid | Jméno řidiče
ix_EXRIDIC_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_EXRIDIC_ad01id |  | ad01id | Identifikace adresáta
ix_EXRIDIC_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_EXRIDIC_spd3id |  | spd3id | Identifikace kalendáře


EXTRASA Trasa expedice

Popis

Trasa expedice

Atributy

Atribut | Typ | Návěští | Message | Popis
ex04id | C(6) | Trasa | Identifikace trasy | Identifikace trasy
ex04naztra | C(40) | Název trasy | Název trasy | Název trasy
ex04trvani | N(5,2) | Trvání (hod) | Trvání v hodinách | Trvání v hodinách
ex04km | N(8,2) | Délka (km) | Délka trasy v kilometrech | Délka trasy v kilometrech
ex04odbobv | N(3,0) | Obvykle odběratelů | Obvyklý počet odběratelů | Obvyklý počet odběratelů
ex04odbmax | N(3,0) | Nejvíce odběratelů | Maximální počet odběratelů | Maximální počet odběratelů
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
ex04aktual | N(1,0) | Aktuální | Trasa je aktuální Ano/Ne | Trasa je aktuální Ano/Ne
spd3id | C(6) | Kalendář | Identifikace kalendáře | Identifikace kalendáře

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Trasa expedice - má implicitní vozidlo | EXTRASA sp60id sp61id | 1,1 : 0,M | EXARTIKL sp60id sp61id |
Trasa expedice - má organizační selektor | EXTRASA sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Trasa expedice - používá kalendář | EXTRASA spd3id | 1,1 : 0,M | SPKALEN spd3id |
Adresa na trase expedice - patří k trase expedice | EXTRASAV ex04id | 1,1 : 0,M | EXTRASA ex04id |
Událost expedice - je o trase expedice | EXUDAL ex04id | 1,1 : 0,M | EXTRASA ex04id |
Aktuální hodnota expedice - se vztahuje k trase expedice | EXAH ex04id | 1,1 : 0,M | EXTRASA ex04id |

Indexy

Název | Primární | Výraz | Popis
ix_EXTRASA_ex04id | P | ex04id | Identifikace trasy
ix_EXTRASA_ex04naztra |  | ex04naztra | Název trasy
ix_EXTRASA_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_EXTRASA_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_EXTRASA_spd3id |  | spd3id | Identifikace kalendáře


EXTRASAV Adresa na trase expedice

Popis

Adresy na trase

Atributy

Atribut | Typ | Návěští | Message | Popis
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad02cisadr | C(2) | Adresa | Číslo adresy adresáta. | Číslo adresy adresáta. Program generuje automaticky. *** Dříve CISADR. C,1 !!!
ex04id | C(6) | Trasa | Identifikace trasy | Identifikace trasy
ex05poradi | N(3,0) | Pořadí | Pořadí na trase | Pořadí na trase
ex05popis | C(80) | Popis | Popis adresy na trase | Popis adresy na trase
ex05koment | M | Pozn. | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Adresa na trase expedice - patří k trase expedice | EXTRASAV ex04id | 1,1 : 0,M | EXTRASA ex04id |
Adresa na trase expedice - má adresu | EXTRASAV ad01id ad02cisadr | 1,1 : 0,M | ADADR ad01id ad02cisadr |

Indexy

Název | Primární | Výraz | Popis
ix_EXTRASAV_extrasav | P | ad01id, ad02cisadr, ex04id | Adresa+trasa
ix_EXTRASAV_ex04id |  | ex04id | Identifikace trasy
ix_EXTRASAV_adadr1 |  | ad01id, ad02cisadr | Adresát + číslo adresy Pro zobrazení
ix_EXTRASAV_ad01id |  | ad01id | Identifikace adresáta


EXTYPVOZ Typ vozidla expedice

Popis

Typ vozidla expedice

Atributy

Atribut | Typ | Návěští | Message | Popis
ex03id | C(6) | Typ | Typ vozidla | Typ vozidla
ex03naztyp | C(40) | Název typu vozidla | Název typu vozidla | Název typu vozidla
ex03sirka | N(5,0) | Šířka (mm) | Šířka vozidla v milimetrech | Šířka vozidla v milimetrech
ex03vyska | N(5,0) | Výška (mm) | Výška vozidla v milimetrech | Výška vozidla v milimetrech
ex03delka | N(5,0) | Délka (mm) | Délka vozidla v milimetrech | Délka vozidla v milimetrech
ex03lpdelk | N(5,0) | Délka LP (mm) | Délka ložné plochy vozidla v milimetrech | Délka ložné plochy vozidla v milimetrech
ex03lpsirk | N(5,0) | Šířka LP (mm) | Šířka ložné plochy vozidla v milimetrech | Šířka ložné plochy vozidla v milimetrech
ex03lpvysk | N(5,0) | Výška LP (mm) | Výška ložné plochy vozidla v milimetrech | Výška ložné plochy vozidla v milimetrech
ex03hmopoh | N(5,0) | Pohotov. hm. (kg) | Pohotovostní hmotnost v kilogramech | Pohotovostní hmotnost v kilogramech
ex03hmouzi | N(5,0) | Užitečná hm. (kg) | Užitečná hmotnost v kilogramech | Užitečná hmotnost v kilogramech
ex03nebnak | N(1,0) | ex03nebnak | Nebezpečný náklad | Nebezpečný náklad
ex03prives | N(1,0) | ex03prives | Možnost přívěsu | Možnost přívěsu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vozidlo - expedice - je typu | EXARTIKL ex03id | 1,1 : 0,M | EXTYPVOZ ex03id |

Indexy

Název | Primární | Výraz | Popis
ix_EXTYPVOZ_ex03id | P | ex03id | Typ vozidla
ix_EXTYPVOZ_ex03naztyp |  | ex03naztyp | Název typu vozidla


EXUDAL Událost expedice

Popis

Události expedice

Atributy

Atribut | Typ | Návěští | Message | Popis
ex02 | C(12) | ex02 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ex02porad | C(3) | Pořadí | Pořadí expedičního příkazu | Pořadí expedičního příkazu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
ex07id | C(6) | Řidič | Identifikace řidiče | Identifikace řidiče
ex04id | C(6) | Trasa | Identifikace trasy | Identifikace trasy
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
ex02datum | T | Odjezd | Datum a čas odjezdu | Datum a čas odjezdu
ex02datump | T | Příjezd | Datum a čas přijezdu | Datum a čas přijezdu
ex02kg | N(5,0) | Hmotnost (kg) | Hmotnost v kilogramech | Hmotnost v kilogramech
ex02km | N(5,0) | Vzdálenost (km) | Ujetý počet kilometrů | Ujetý počet kilometrů
ex02m2 | N(6,2) | Plocha (m2) | Úložná plocha v metrech čtverečných | Úložná plocha v metrech čtverečných
ex02m3 | N(6,2) | Objem (m3) | Úložný objem v metrech kubických | Úložný objem v metrech kubických
ex02pocdl | N(3,0) | Počet DL | Počet dodacích listů | Počet dodacích listů
ex02pocodb | N(3,0) | Počet odběratelů | Počet odběratelů | Počet odběratelů
ex02text | C(40) | Popis | Popis události | Popis události
ex02koment | M | Poznámka | Poznámka k události | Poznámka k události

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost expedice - je o vozidle expedice | EXUDAL sp60id sp61id | 1,1 : 0,M | EXARTIKL sp60id sp61id |
Událost expedice - je o řidiči expedice | EXUDAL ex07id | 1,1 : 0,M | EXRIDIC ex07id |
Událost expedice - je o trase expedice | EXUDAL ex04id | 1,1 : 0,M | EXTRASA ex04id |
Událost expedice - založil uživatel | EXUDAL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost expedice - patří operaci procesu | EXUDAL sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost expedice - má obchodní selektor | EXUDAL sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost expedice - má organizační selektor | EXUDAL sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost expedice - má tecnicko-věcný selektor | EXUDAL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Operace spojená s událostí expedice - se týká události expedice | EXUDAOPE ex02 | 1,1 : 0,M s rušením | EXUDAL ex02 |

Indexy

Název | Primární | Výraz | Popis
ix_EXUDAL_ex02 | P | ex02 | Jednoznačná časová identifikace
ix_EXUDAL_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_EXUDAL_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_EXUDAL_ex07id |  | ex07id | Identifikace řidiče
ix_EXUDAL_ex04id |  | ex04id | Identifikace trasy
ix_EXUDAL_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_EXUDAL_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_EXUDAL_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_EXUDAL_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_EXUDAL_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_EXUDAL_ex02datum |  | ex02datum | Datum a čas odjezdu
ix_EXUDAL_ex02text |  | ex02text | Popis události


EXUDAOPE Operace spojená s událostí expedice

Popis

Operace spojená s událostí expedice

Atributy

Atribut | Typ | Návěští | Message | Popis
ex02 | C(12) | ex02 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
ex10poradi | N(3,0) | Pořadí | Pořadí na trase | Pořadí na trase

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Operace spojená s událostí expedice - se týká operace | EXUDAOPE sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Operace spojená s událostí expedice - má spojení na adresu | EXUDAOPE ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Operace spojená s událostí expedice - se týká události expedice | EXUDAOPE ex02 | 1,1 : 0,M s rušením | EXUDAL ex02 |

Indexy

Název | Primární | Výraz | Popis
ix_EXUDAOPE_exudaope | P | ex02, sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad |
ix_EXUDAOPE_ex02 |  | ex02 | Jednoznačná časová identifikace
ix_EXUDAOPE_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_EXUDAOPE_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo


Tabulky IE...

IEDEFPUX | Entita replikovaná v publikaci
IEKONV | Konverzní tabulka
IEPUB | Publikace
IERAH | Replikovat aktuální hodnoty komponenty
IERAHUM | Replikovat umístění aktuálních hodnot
IERNCIN | Činnost ve vztahu k replikaci
IERPRC | Replikovaný proces mezi DÚ
IERUDA | Informace o replikovaných událostech operace v procesu
IESMTP | Nastavení SMTP pro replikace
IEUZEL | Datové úložiště
IEUZVAZ | Vazba pracovních míst
IEWSLIC | Licence k použití webové služby uživatelem
IEWSSLAT | Popis atributu Webové služby
IEWSSLPR | Parametr webové služby
IEWSSLZ | Webová služba
IEWSUSBM | Uživatel v IS BM provozovatele webové služby
IEWSUSR | Uživatel webové služby
IEWSUSRS | Zařazení uživatele webové služby do skupiny uživatelů

Viz.také

IEDEFPUX Entita replikovaná v publikaci | IEKONV Konverzní tabulka | IEPUB Publikace | IERAH Replikovat aktuální hodnoty komponenty | IERAHUM Replikovat umístění aktuálních hodnot | IERNCIN Činnost ve vztahu k replikaci | IERPRC Replikovaný proces mezi DÚ | IERUDA Informace o replikovaných událostech operace v procesu | IESMTP Nastavení SMTP pro replikace | IEUZEL Datové úložiště | IEUZVAZ Vazba pracovních míst | IEWSLIC Licence k použití webové služby uživatelem | IEWSSLAT Popis atributu Webové služby | IEWSSLPR Parametr webové služby | IEWSSLZ Webová služba | IEWSUSR Uživatel webové služby | IEWSUSRS Zařazení uživatele webové služby do skupiny uživatelů | IEWSUSBM Uživatel v IS BM provozovatele webové služby


IEDEFPUX Entita replikovaná v publikaci

Popis

Entita replikovaná v publikaci

Atributy

Atribut | Typ | Návěští | Message | Popis
ie09entita | C(8) | ie09entita |  |
ie16id | C(6) | Publikace | Identifikace publikace | Identifikace publikace
ie09replik | N(1,0) | Replikovat | Replikovat Ano/Ne | Replikovat Ano/Ne

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Entita replikovaná v publikaci - přísluší k publikaci | IEDEFPUX ie16id | 1,1 : 0,M s rušením | IEPUB ie16id |

Indexy

Název | Primární | Výraz | Popis
ix_IEDEFPUX_iedefpux | P | ie09entita, ie16id |
ix_IEDEFPUX_ie16id |  | ie16id | Identifikace publikace


IEKONV Konverzní tabulka

Atributy

Atribut | Typ | Návěští | Message | Popis
ie03ent | C(10) | Entita | Název entity |
ie05puv | C(15) | Původní | Původní hodnota |
ie05nova | C(15) | Nová | Nová hodnota |
ie05kom | C(40) | Poznámka | Poznámka |

Indexy

Název | Primární | Výraz | Popis
ix_IEKONV_iekonv1 | P | ie03ent, ie05puv |
ix_IEKONV_ie03ent |  | ie03ent |
ix_IEKONV_ie05puv |  | ie05puv |


IEPUB Publikace

Popis

Publikace

Atributy

Atribut | Typ | Návěští | Message | Popis
ie16id | C(6) | Publikace | Identifikace publikace | Identifikace publikace
ie16nazpub | C(40) | Název publikace | Název publikace | Název publikace
ie16koment | M | Poznámka | Poznámka | Poznámka
ie16whup | M | ie16whup | Doplňující podmínky pro nadřízené DÚ | Doplňující podmínky pro nadřízené DÚ
ie16whdn | M | ie16whdn | Doplňující podmínky pro podřízené DÚ | Doplňující podmínky pro podřízené DÚ
ie16rprcp | N(1,0) | Podle popisu procesů | Replikace podle popisu procesů pro nadřízené DÚ | Replikace podle popisu procesů pro nadřízené DÚ
ie16rprcn | N(1,0) | Podle popisu procesů | Replikace podle popisu procesů pro podřízené DÚ | Replikace podle popisu procesů pro podřízené DÚ
ie16symet | N(1,0) | Všechny tabulky | Replikovat všechny tabulky | Replikovat všechny tabulky
ie16rstap | N(1,0) | Replikovat statistiky | Replikovat tabulky statistik z nadřízeného DÚ | Replikovat tabulky statistik z nadřízeného DÚ
ie16rstan | N(1,0) | Replikovat statistiky | Replikovat tabulky statistik z podřízeného DÚ | Replikovat tabulky statistik z podřízeného DÚ

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Replikovaný proces mezi DÚ - patří k publikaci | IERPRC ie16id | 1,1 : 0,M | IEPUB ie16id |
Činnost ve vztahu k replikaci - je definována v publikaci | IERNCIN ie16id | 1,1 : 0,M | IEPUB ie16id |
Datové úložiště - používá publikaci | IEUZEL ie16id | 1,1 : 0,M | IEPUB ie16id |
Entita replikovaná v publikaci - přísluší k publikaci | IEDEFPUX ie16id | 1,1 : 0,M s rušením | IEPUB ie16id |

Indexy

Název | Primární | Výraz | Popis
ix_IEPUB_ie16id | P | ie16id | Identifikace publikace
ix_IEPUB_ie16nazpub |  | ie16nazpub | Název publikace


IERAH Replikovat aktuální hodnoty komponenty

Popis

Replikovat aktuální hodnoty komponenty

Atributy

Atribut | Typ | Návěští | Message | Popis
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
ie07pm | C(2) | DÚ | Nadřízené datové úložiště | Datové úložiště
ie18koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Replikovat aktuální hodnoty komponenty - datového úložiště | IERAH ie07pm | 1,1 : 0,M | IEUZEL ie07pm |
Replikovat aktuální hodnoty komponenty - pro komponentu | IERAH sp06idsubs | 1,1 : 0,M | SPSUBSYS sp06idsubs |
Replikovat umístění aktuálních hodnot - pro pravidlo replikace | IERAHUM sp06idsubs ie07pm | 1,1 : 0,M s rušením | IERAH sp06idsubs ie07pm |

Indexy

Název | Primární | Výraz | Popis
ix_IERAH_ierah | P | sp06idsubs, ie07pm |
ix_IERAH_ie07pm |  | ie07pm | Datové úložiště
ix_IERAH_sp06idsubs |  | sp06idsubs | Identifikace subsystému.


IERAHUM Replikovat umístění aktuálních hodnot

Popis

Replikovat umístění aktuálních hodnot

Atributy

Atribut | Typ | Návěští | Message | Popis
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
ie07pm | C(2) | ie07pm | Nadřízené datové úložiště | Datové úložiště
sp74id | C(6) | sp74id | Umístění | Umístění
ie19replik | N(1,0) | Replikovat | Replikovat AH umístění | Replikovat AH umístění
ie19koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Replikovat umístění aktuálních hodnot - pro pravidlo replikace | IERAHUM sp06idsubs ie07pm | 1,1 : 0,M s rušením | IERAH sp06idsubs ie07pm |

Indexy

Název | Primární | Výraz | Popis
ix_IERAHUM_ierahum | P | sp06idsubs, ie07pm, sp74id |
ix_IERAHUM_ierah |  | sp06idsubs, ie07pm |


IERNCIN Činnost ve vztahu k replikaci

Popis

Činnost ve vztahu k replikaci

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
ie16id | C(6) | Publikace | Identifikace publikace | Identifikace publikace
ie17replik | N(1,0) | Replikovat | Replikovat činnost |
ie17koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Činnost ve vztahu k replikaci - je definována v publikaci | IERNCIN ie16id | 1,1 : 0,M | IEPUB ie16id |
Činnost ve vztahu k replikaci - je činnost BM | IERNCIN bw02krok | 0,1 : 0,M | BWMENU bw02krok |

Indexy

Název | Primární | Výraz | Popis
ix_IERNCIN_ierncin | P | bw02krok, ie16id | PI - bw02krok+ie16id
ix_IERNCIN_ie16id |  | ie16id | Identifikace publikace
ix_IERNCIN_bw02krok |  | bw02krok | Identifikace činnosti


IERPRC Replikovaný proces mezi DÚ

Popis

Replikovaný proces mezi IDÚ

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtypd | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu procesu
sp06idsubd | C(3) | sp06idsubd | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery
ie16id | C(6) | Publikace | Identifikace publikace | Identifikace publikace
ie13idu2 | C(2) | DÚ | Platí výhradně pro DÚ | Identifikace datového úložiště 2
ie13koment | M | Poznámka | Poznámka | Poznámka
ie13podmin | M | Podmínka | Doplňující podmínka pro proces | Doplňující podmínka pro proces
ie13povoin | N(1,0) | Povolit podmínku výčtem operací | Povolit podmínku výčtem operací | Povolit podmínku výčtem operací
ie13ridu1 | C(30) | IDÚ procesu | Replikovat pouze proces s IDÚ | Replikovat pouze proces s IDÚ
ie13ridu2 | C(30) | IDÚ nadř.procesu | Replikovat pouze proces, kterému předchází proces s IDÚ | Replikovat pouze proces, kterému předchází proces s IDÚ

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Replikovaný proces mezi DÚ - replikuje proces | IERPRC sp07idtypd sp06idsubd | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Replikovaný proces mezi DÚ - patří k publikaci | IERPRC ie16id | 1,1 : 0,M | IEPUB ie16id |
Informace o replikovaných událostech operace v procesu - patří k replikovanému procesu mezi DÚ | IERUDA sp07idtypd sp06idsubd ie16id ie13idu2 | 1,1 : 0,M s rušením | IERPRC sp07idtypd sp06idsubd ie16id ie13idu2 |

Indexy

Název | Primární | Výraz | Popis
ix_IERPRC_ierprc | P | sp07idtypd, sp06idsubd, ie16id, ie13idu2 | PI - SPTYD+ie13idu1+ie13idu2
ix_IERPRC_sptypd |  | sp07idtypd, sp06idsubd | Index podle typu dokladu a subsystému dokladu
ix_IERPRC_ie16id |  | ie16id | Identifikace publikace


IERUDA Informace o replikovaných událostech operace v procesu

Popis

Informace o replikovaných událostech operace v procesu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtypd | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu procesu
sp06idsubd | C(3) | sp06idsubd | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery
ie16id | C(6) | Publikace | Identifikace publikace | Identifikace publikace
ie13idu2 | C(2) | DÚ | Platí výhradně pro DÚ | Identifikace datového úložiště 2
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
ie14replik | N(1,0) | Replikovat | Replikovat události operace Ano/Ne | Replikovat události operace Ano/Ne
ie14koment | M | Poznámka | Poznámka |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Informace o replikovaných událostech operace v procesu - patří k replikovanému procesu mezi DÚ | IERUDA sp07idtypd sp06idsubd ie16id ie13idu2 | 1,1 : 0,M s rušením | IERPRC sp07idtypd sp06idsubd ie16id ie13idu2 |
Informace o replikovaných událostech operace v procesu - je informace o operaci v procesu | IERUDA sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_IERUDA_ieruda | P | sp07idtypd, sp06idsubd, ie16id, ie13idu2, sp07idtyp, sp06idsubs | PI - IERPRC+SPTYP
ix_IERUDA_ierprc |  | sp07idtypd, sp06idsubd, ie16id, ie13idu2 | PI - SPTYD+ie13idu1+ie13idu2
ix_IERUDA_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_IERUDA_ie16id |  | ie16id | Identifikace publikace


IESMTP Nastavení SMTP pro replikace

Popis

Nastavení SMTP pro replikace

Atributy

Atribut | Typ | Návěští | Message | Popis
ie12 | C(1) | ie12 | Jednoznačná identifikace | Jednoznačná identifikace
ie12adress | C(70) | Adresa | E-mailová adresa | E-mailová adresa
ie12smtp_h | C(70) | smtp_host | Identifikace počítače, na kterém běží SMTP server | Identifikace počítače, na kterém běží SMTP server
ie12pop3_h | C(70) | pop3_host | Identifikace počítače, na kterém běží POP host obvykle = smtp_host | Identifikace počítače, na kterém běží POP host obvykle = smtp_host
ie12pop3_u | C(70) | pop3_userid | Identifikace uživatele pro odesílání a příjem pošty | Identifikace uživatele pro odesílání a příjem pošty
ie12pop3_p | C(70) | pop3_password | Heslo uživatele pro odesílání a příjem pošty | Heslo uživatele pro odesílání a příjem pošty

Indexy

Název | Primární | Výraz | Popis
ix_IESMTP_ie12 | P | ie12 | Jednoznačná identifikace


IEUZEL Datové úložiště

Popis

Datové úložiště

Atributy

Atribut | Typ | Návěští | Message | Popis
ie07pm | C(2) | Identifikace | Nadřízené datové úložiště | Datové úložiště
ie07nazev | C(40) | Název | Název datového úložiště |
ie07popis | M | Komentář | Popis pracovního místa |
ie16id | C(6) | Publikace | Identifikace publikace | Identifikace publikace
ie07odbc | C(20) | ODBC | Odbc spojení datového úložiště | Odbc spojení datového úložiště
ie07path | C(40) | Adresář DB | Adresář uložení databáze | Adresář uložení databáze
ie07file | C(20) | Název DB | Název databázového souboru | Název databázového souboru
ie07param1 | C(20) | ie07param1 | Další parametr 1 | Další parametr 1
ie07param2 | C(20) | ie07param2 | Další parametr 2 | Další parametr 2
ie07param3 | C(20) | ie07param3 | Další parametr 3 | Další parametr 3
ie07koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Datové úložiště - používá publikaci | IEUZEL ie16id | 1,1 : 0,M | IEPUB ie16id |
Replikovat aktuální hodnoty komponenty - datového úložiště | IERAH ie07pm | 1,1 : 0,M | IEUZEL ie07pm |
Vazba pracovních míst - má nadřízené pracovní místo | IEUZVAZ ie07pm | 1,1 : 0,M | IEUZEL ie07pm |
Vazba pracovních míst - má podřízené pracovní místo | IEUZVAZ ie07pm1 | 1,1 : 0,M | IEUZEL ie07pm |

Indexy

Název | Primární | Výraz | Popis
ix_IEUZEL_ie07pm | P | ie07pm | Datové úložiště
ix_IEUZEL_ie07nazev |  | ie07nazev |
ix_IEUZEL_ie16id |  | ie16id | Identifikace publikace


IEUZVAZ Vazba pracovních míst

Atributy

Atribut | Typ | Návěští | Message | Popis
ie08 | C(12) | ie08 |  |
ie07pm | C(2) | Nadřízené pracovní místo | Nadřízené datové úložiště | Datové úložiště
ie07pm1 | C(2) | Podřízené pracovní místo | Podřízené pracovní místo |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vazba pracovních míst - má nadřízené pracovní místo | IEUZVAZ ie07pm | 1,1 : 0,M | IEUZEL ie07pm |
Vazba pracovních míst - má podřízené pracovní místo | IEUZVAZ ie07pm1 | 1,1 : 0,M | IEUZEL ie07pm |

Indexy

Název | Primární | Výraz | Popis
ix_IEUZVAZ_ie08 | P | ie08 |


IEWSLIC Licence k použití webové služby uživatelem

Popis

Licence k použití webové služby uživatelem

Atributy

Atribut | Typ | Návěští | Message | Popis
ie20id | C(6) | Služba | Identifikace webové služby | Identifikace webové služby
ie21id | C(6) | Uživatel | Identifikace uživatele webové služby | Identifikace uživatele webové služby
ie24vyraz | M | Doplňující výraz | Doplňující výraz SQL dotazu webové služby | Doplňující výraz SQL dotazu webové služby
ie24koment | M | ie24koment | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Licence k použití webové služby uživatelem - má licenci pro použití webové služby | IEWSLIC ie21id | 1,1 : 0,M | IEWSUSR ie21id |
Licence k použití webové služby uživatelem - určuje webovou službu | IEWSLIC ie20id | 1,1 : 0,M | IEWSSLZ ie20id |

Indexy

Název | Primární | Výraz | Popis
ix_IEWSLIC_iewslic | P | ie20id, ie21id | PI - ie20id+ie21id
ix_IEWSLIC_ie20id |  | ie20id | Identifikace webové služby
ix_IEWSLIC_ie21id |  | ie21id | Identifikace uživatele webové služby


IEWSSLAT Popis atributu Webové služby

Popis

Popis atributu Webové služby

Atributy

Atribut | Typ | Návěští | Message | Popis
ie22id | C(30) | Atribut | Identifikace atributu webové služby | Identifikace atributu webové služby
ie20id | C(6) | Služba | Identifikace webové služby | Identifikace webové služby
ie22label | M | Návěští | Návěští atributu webové služby | Návěští atributu webové služby
ie22captio | M | Popis | Popis atributu webové služby | Popis atributu webové služby
ie22koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis atributu Webové služby - patří k webové službě | IEWSSLAT ie20id | 1,1 : 0,M | IEWSSLZ ie20id |

Indexy

Název | Primární | Výraz | Popis
ix_IEWSSLAT_iewsslat | P | ie22id, ie20id | PI - ie22id+ie20id
ix_IEWSSLAT_ie20id |  | ie20id | Identifikace webové služby
ix_IEWSSLAT_ie22id |  | ie22id | Identifikace atributu webové služby


IEWSSLPR Parametr webové služby

Popis

Parametr webové služby

Atributy

Atribut | Typ | Návěští | Message | Popis
ie23id | C(30) | Parametr | Identifikace parametru webové služby | Identifikace parametru webové služby
ie20id | C(6) | Služba | Identifikace webové služby | Identifikace webové služby
ie23label | M | Návěští | Návěští parametru webové služby | Návěští parametru webové služby
ie23captio | M | Popis | Popis parametru webové služby | Popis parametru webové služby
ie23porad | N(3,0) | Pořadí | Pořadí parametru | Pořadí parametru
ie23typ | N(1,0) | Typ | Typ parametru dotazu | Typ parametru dotazu
ie23len | N(3,0) | Délka | Délka numerického nebo znakového parametru | Délka numerického nebo znakového parametru
ie23dec | N(1,0) | Des. | Počet desetin numerického parametru | Počet desetin numerického parametru
ie23sezn | M | Seznam | Výčet hodnot pro překryvný seznam | Výčet hodnot pro překryvný seznam
ie23koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametr webové služby - patří k webové službě | IEWSSLPR ie20id | 1,1 : 0,M | IEWSSLZ ie20id |

Indexy

Název | Primární | Výraz | Popis
ix_IEWSSLPR_iewssldt | P | ie23id, ie20id | PI - ie23id+ie20id
ix_IEWSSLPR_ie20id |  | ie20id | Identifikace webové služby


IEWSSLZ Webová služba

Popis

Webová služba

Atributy

Atribut | Typ | Návěští | Message | Popis
ie20id | C(6) | Služba | Identifikace webové služby | Identifikace webové služby
ie20nazslz | C(40) | Název služby | Název webové služby | Název webové služby
ie20koment | M | Poznámka | Poznámka | Poznámka
ie20vyraz | M | Výraz | Výraz SQL webové služby | Výraz SQL webové služby
ie20vyrazg | M | Order/Group | Výraz SQL webové služby - GROUP / ORDER | Výraz SQL webové služby - GROUP / ORDER
ie20platno | N(1,0) | Platnost | Platnost webové služby | Platnost webové služby

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis atributu Webové služby - patří k webové službě | IEWSSLAT ie20id | 1,1 : 0,M | IEWSSLZ ie20id |
Parametr webové služby - patří k webové službě | IEWSSLPR ie20id | 1,1 : 0,M | IEWSSLZ ie20id |
Licence k použití webové služby uživatelem - určuje webovou službu | IEWSLIC ie20id | 1,1 : 0,M | IEWSSLZ ie20id |

Indexy

Název | Primární | Výraz | Popis
ix_IEWSSLZ_ie20id | P | ie20id | Identifikace webové služby
ix_IEWSSLZ_ie20nazslz |  | ie20nazslz | Název webové služby


IEWSUSBM Uživatel v IS BM provozovatele webové služby

Popis

Uživatel v IS BM provozovatele webové služby

Atributy

Atribut | Typ | Návěští | Message | Popis
ie21id | C(6) | Uživatel | Identifikace uživatele webové služby | Identifikace uživatele webové služby
ie26uziv | C(6) | Uživatel zákazníka WS | Identifikace uživatele v IS BM zákazníka webové služby | Identifikace uživatele v IS BM zákazníka webové služby
ad01ico | C(10) | IČO | Identifikační číslo organizace. | Identifikační číslo organizace. *** Dříve ICO.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Uživatel v IS BM provozovatele webové služby - definuje uživateli webové služby | IEWSUSBM ie21id | 1,1 : 0,M | IEWSUSR ie21id |
Uživatel v IS BM provozovatele webové služby - odpovídá uživateli v datech provozovatele webové | IEWSUSBM bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_IEWSUSBM_iewsusbm | P | ie21id, ie26uziv, ad01ico | PI - ie21id+sp26uziv+ad01ico
ix_IEWSUSBM_ie21id |  | ie21id | Identifikace uživatele webové služby
ix_IEWSUSBM_bw01uziv |  | bw01uziv | Identifikace uživatele systému


IEWSUSR Uživatel webové služby

Popis

Uživatel webové služby

Atributy

Atribut | Typ | Návěští | Message | Popis
ie21id | C(6) | Uživatel | Identifikace uživatele webové služby | Identifikace uživatele webové služby
ie21jmeno | C(40) | Jméno | Jméno uživatele webové služby | Jméno uživatele webové služby
ie21pwd | C(40) | Heslo | Heslo uživatele webové služby | Heslo uživatele webové služby
ie21koment | M | Poznámka | Poznámka | Poznámka
ie21up1 | C(40) | Uživatelův parametr 1 | Uživatelův parametr 1 | Uživatelův parametr 1
ie21up2 | C(40) | Uživatelův parametr 2 | Uživatelův parametr 2 | Uživatelův parametr 2
ie21up3 | C(40) | Uživatelův parametr 3 | Uživatelův parametr 3 | Uživatelův parametr 3
ie21skup | N(1,0) | Skupina | Skupina uživatelů Ano/Ne | Skupina uživatelů Ano/Ne
ie21aktiv | N(1,0) | Aktivní uživatel | Aktivní uživatel | Aktivní uživatel

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Licence k použití webové služby uživatelem - má licenci pro použití webové služby | IEWSLIC ie21id | 1,1 : 0,M | IEWSUSR ie21id |
Zařazení uživatele webové služby do skupiny uživatelů - určuje skupinu | IEWSUSRS ie21ids | 1,1 : 0,M s rušením | IEWSUSR ie21id |
Zařazení uživatele webové služby do skupiny uživatelů - určuje uživatele | IEWSUSRS ie21id | 1,1 : 0,M s rušením | IEWSUSR ie21id |
Uživatel v IS BM provozovatele webové služby - definuje uživateli webové služby | IEWSUSBM ie21id | 1,1 : 0,M | IEWSUSR ie21id |

Indexy

Název | Primární | Výraz | Popis
ix_IEWSUSR_ie21id | P | ie21id | Identifikace uživatele webové služby
ix_IEWSUSR_ie21jmeno |  | ie21jmeno | Jméno uživatele webové služby


IEWSUSRS Zařazení uživatele webové služby do skupiny uživatelů

Popis

Zařazení uživatele webové služby do skupiny uživatelů

Atributy

Atribut | Typ | Návěští | Message | Popis
ie21ids | C(6) | ie21ids | Identifikace skupinového uživatele webové služby | Identifikace skupinového uživatele webové služby
ie21id | C(6) | Uživatel | Identifikace uživatele webové služby | Identifikace uživatele webové služby

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Zařazení uživatele webové služby do skupiny uživatelů - určuje skupinu | IEWSUSRS ie21ids | 1,1 : 0,M s rušením | IEWSUSR ie21id |
Zařazení uživatele webové služby do skupiny uživatelů - určuje uživatele | IEWSUSRS ie21id | 1,1 : 0,M s rušením | IEWSUSR ie21id |

Indexy

Název | Primární | Výraz | Popis
ix_IEWSUSRS_iewsusrs | P | ie21ids, ie21id | PI - ie21ids+ie21id
ix_IEWSUSRS_ie21ids |  | ie21ids | Identifikace skupinového uživatele webové služby
ix_IEWSUSRS_ie21id |  | ie21id | Identifikace uživatele webové služby


Tabulky IP...

IPBUNKA | Buňka tabulky uzlu informačního panelu
IPDRUH | Druh uzlu informačního panelu
IPHYPER | Hypertextový odkaz
IPPAS | Pás tabulky uzlu informačního panelu
IPPREZEN | Popis prezentace stránky panelu/prvku stránky
IPRADEK | Řádek pásu tabulky uzlu informačního panelu
IPRADELE | Element sloupce pro řádku tabulky
IPSEKTOR | Sektor stránky informačního panelu
IPSLOUPE | Sloupec pásu tabulky uzlu informačního panelu
IPUZEL | Uzel informačního panelu
IPUZELP | Poduzel uzlu informačního panelu
IPUZELPZ | Zobrazení poduzlu pro uživatele
IPUZIUZE | Poslední stránka na panelu použitá uživatelm systému

Viz.také

IPDRUH Druh uzlu informačního panelu | IPHYPER Hypertextový odkaz | IPPREZEN Popis prezentace stránky panelu/prvku stránky | IPRADELE Element sloupce pro řádku tabulky | IPSLOUPE Sloupec pásu tabulky uzlu informačního panelu | IPUZEL Uzel informačního panelu | IPUZELP Poduzel uzlu informačního panelu | IPUZIUZE Poslední stránka na panelu použitá uživatelm systému | IPUZELPZ Zobrazení poduzlu pro uživatele | IPBUNKA Buňka tabulky uzlu informačního panelu | IPPAS Pás tabulky uzlu informačního panelu | IPRADEK Řádek pásu tabulky uzlu informačního panelu | IPSEKTOR Sektor stránky informačního panelu


IPBUNKA Buňka tabulky uzlu informačního panelu

Popis

Buňka tabulky uzlu informačního panelu

Atributy

Atribut | Typ | Návěští | Message | Popis
ip01id | C(12) | Uzel | Identifikátor uzlu informačního panelu | Identifikátor uzlu informačního panelu
ip14pas | N(3,0) | P | Číslo pásu | Číslo pásu
ip15radek | N(3,0) | Ř | Číslo řádku | Číslo řádku
ip02sloup | N(3,0) | S | Číslo sloupce | Číslo sloupce
ip16tag | M | Tag buňky | Tag buňky | Tag buňky
ip16span | N(1,0) | Návěští | Návěští poduzlu Rozbalené/Nerozbalené/Žádné | Obsah poduzlu má být rozbalen
ip16from | M | FROM | Doplnění FROM dotazu SQL poduzlu | Doplnění FROM dotazu SQL poduzlu
ip16where | M | WHERE | Doplnění WHERE dotazu SQL poduzlu | Doplnění WHERE dotazu SQL poduzlu
ip16param | M | Parametry | Skutečné parametry použité v doplnění where poduzlu | Skutečné parametry použité v doplnění where poduzlu
ip16vyrazo | M | Výraz třídění | Výraz třídění dat vrácených dotazem SQL | Výraz třídění dat vrácených dotazem SQL
ip01id2 | C(12) | Uzel | Identifikátor poduzlu informačního panelu | Identifikátor poduzlu informačního panelu
ip16attr | M | Atributy | Doplnění SQL dotazu na jeho začátku (je-li uveden atribut musí být posledním textu znakem čárka) | Doplnění SQL dotazu na jeho začátku (je-li uveden atribut musí být posledním textu znakem čárka)
ip16nazuzl | M | Název uzlu informačního panelu (alias) | Název uzlu informačního panelu (alias) - za znakem ~ je možné zadat výraz | Název uzlu informačního panelu (alias) - za znakem ~ je možné zadat výraz

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Buňka tabulky uzlu informačního panelu - patří do řádky pásu tabulky | IPBUNKA ip01id ip14pas ip15radek | 1,1 : 0,M | IPRADEK ip01id ip14pas ip15radek |
Buňka tabulky uzlu informačního panelu - patří do sloupce pásu tabulky | IPBUNKA ip01id ip14pas ip02sloup | 1,1 : 0,M | IPSLOUPE ip01id ip14pas ip02sloup |
Buňka tabulky uzlu informačního panelu - obsahuje tabulku vytvořenou uzlem | IPBUNKA ip01id2 | 0,1 : 0,M | IPUZEL ip01id |

Indexy

Název | Primární | Výraz | Popis
ix_IPBUNKA_ipbunka | P | ip01id, ip14pas, ip15radek, ip02sloup | PI - ip01id+ip14pas+ip15radek+ip02sloup
ix_IPBUNKA_ip01id |  | ip01id | Identifikátor uzlu informačního panelu
ix_IPBUNKA_ippas |  | ip01id, ip14pas | PI - ip01id+ip14pas
ix_IPBUNKA_ipradek |  | ip01id, ip14pas, ip15radek | PI - ip01id+ip14pas+ip15radek
ix_IPBUNKA_ipsloupe |  | ip01id, ip14pas, ip02sloup | PI - ip01id+ip14pas+ip02sloup
ix_IPBUNKA_ip01id2 |  | ip01id2 | Identifikátor poduzlu informačního panelu


IPDRUH Druh uzlu informačního panelu

Popis

Druh uzlu informačního panelu

Atributy

Atribut | Typ | Návěští | Message | Popis
ip05id | C(6) | Druh | Identifikace druhu uzlu | Identifikace druhu uzlu
ip05nazdru | C(40) | Název druhu uzlu | Název druhu uzlu | Název druhu uzlu
ip05koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Uzel informačního panelu - je druhu | IPUZEL ip05id | 1,1 : 0,M | IPDRUH ip05id |

Indexy

Název | Primární | Výraz | Popis
ix_IPDRUH_ip05id | P | ip05id | Identifikace druhu uzlu
ix_IPDRUH_ip05nazdru |  | ip05nazdru | Název druhu uzlu


IPHYPER Hypertextový odkaz

Popis

Hypertextový odkaz

Atributy

Atribut | Typ | Návěští | Message | Popis
ip08id | C(12) | Hypertext | Identifikace hypertextového odkazu | Identifikace hypertextového odkazu
ip08nazhyp | C(40) | Název hypertextového odkazu | Název hypertextového odkazu | Název hypertextového odkazu
ip01id | C(12) | Uzel | Identifikátor uzlu informačního panelu | Identifikátor uzlu informačního panelu
ip08param | M | Parametry | Skutečné parametry použité v doplnění where hypertextového odkazu | Skutečné parametry použité v doplnění where hypertextového odkazu
ip08attr | M | Atributy | Doplnění SQL dotazu na jeho začátku (je-li uveden atribut musí být posledním textu znakem čárka) | Doplnění SQL dotazu na jeho začátku (je-li uveden atribut musí být posledním textu znakem čárka)
ip08from | M | FROM | Doplnění FROM dotazu SQL poduzlu | Doplnění FROM dotazu SQL poduzlu
ip08where | M | WHERE | Doplnění WHERE dotazu SQL stránky hypertextového odkazu | Doplnění WHERE dotazu SQL stránky hypertextového odkazu
ip08typ | N(1,0) | Typ | Typ hypertextového odkazu | Typ hypertextového odkazu
ip08hypkod | M | Kód | Kód ve Foxpro vracející adresu hypertextového odkazu | Kód ve Foxpro vracející adresu hypertextového odkazu
ip08koment | M | Poznámka | Poznámka | Poznámka
ip08vyrazo | M | Výraz třídění | Výraz třídění dat vrácených dotazem SQL | Výraz třídění dat vrácených dotazem SQL
ip08nazuzl | M | Jiný název | Jiný název uzlu informačního panelu - za znakem ~ je možné zadat výraz | Jiný název uzlu informačního panelu - za znakem ~ je možné zadat výraz

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Hypertextový odkaz - odkazuje na uzel | IPHYPER ip01id | 0,1 : 0,M | IPUZEL ip01id |
Element sloupce pro řádku tabulky - používá hypertextový odkaz na uzel | IPRADELE ip08id | 0,1 : 0,M | IPHYPER ip08id |

Indexy

Název | Primární | Výraz | Popis
ix_IPHYPER_ip08id | P | ip08id | Identifikace hypertextového odkazu
ix_IPHYPER_ip08nazhyp |  | ip08nazhyp | Název hypertextového odkazu
ix_IPHYPER_ip01id |  | ip01id | Identifikátor uzlu informačního panelu


IPPAS Pás tabulky uzlu informačního panelu

Popis

Pás tabulky uzlu informačního panelu

Atributy

Atribut | Typ | Návěští | Message | Popis
ip01id | C(12) | Uzel | Identifikátor uzlu informačního panelu | Identifikátor uzlu informačního panelu
ip14pas | N(3,0) | P | Číslo pásu | Číslo pásu
ip14script | M | Script | Script prvku v jazyce Foxpro vyvolávaný v různých fázích tvorby pásu tabulky | Script prvku v jazyce Foxpro vyvolávaný v různých fázích tvorby pásu tabulky
ip14koment | M | Poznámka | Poznámka | Poznámka
ip14typ | N(1,0) | Typ | Typ pásu Datový/Popisný | Typ pásu Datový/Popisný
ip14opak | N(3,0) | Opakování | Počet opakování popisného pásu | Počet opakování popisného pásu
ip14when | M | Podmínka | Podmínka zařazení pásu do tabulky | Podmínka zařazení pásu do tabulky
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Pás tabulky uzlu informačního panelu - náleží k uzlu | IPPAS ip01id | 1,1 : 0,M | IPUZEL ip01id |
Sloupec pásu tabulky uzlu informačního panelu - patří do pásu tabulky | IPSLOUPE ip01id ip14pas | 1,1 : 0,M | IPPAS ip01id ip14pas |
Řádek pásu tabulky uzlu informačního panelu - patří do pásu tabulky | IPRADEK ip01id ip14pas | 1,1 : 0,M | IPPAS ip01id ip14pas |

Indexy

Název | Primární | Výraz | Popis
ix_IPPAS_ippas | P | ip01id, ip14pas | PI - ip01id+ip14pas
ix_IPPAS_ip01id |  | ip01id | Identifikátor uzlu informačního panelu


IPPREZEN Popis prezentace stránky panelu/prvku stránky

Popis

Popis prezentace stránky panelu/prvku stránky

Atributy

Atribut | Typ | Návěští | Message | Popis
ip06id | C(6) | Prezentace | Identifikátor prezentace | Identifikátor prezentace
ip06nazpre | C(40) | Název prezentace | Název prezentace | Název prezentace
ip06popsty | M | Popis stylu stránky | Popis stylu stránky - pro prvek typu tabulka parametry tag TABLE | Popis stylu stránky
ip06popprv | M | Popis stylu prvku stránky | Popis stylu prvku stránky | Popis stylu prvku stránky
ip06koment | M | Poznámka | Poznámka | Poznámka
ip06heakod | M | Kód hlavičky | Kód v jazyce Foxpro pro vytvoření hlavičky stránky (pokud není uveden vytváří se standardní hlavička) | Kód v jazyce Foxpro pro vytvoření hlavičky stránky (pokud není uveden vytváří se standardní hlavička)
ip06fookod | M | Kód patičky | Kód v jazyce Foxpro pro vytvoření patičky stránky (pokud není uveden vytváří se standardní patička) | Kód v jazyce Foxpro pro vytvoření patičky stránky (pokud není uveden vytváří se standardní patička)
ip06poptra | M | Atributy elementů TR | Atributy elementů řádků (TR) oddělené enterem | Atributy elementu řádku (TR) oddělené enterem

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Uzel informačního panelu - je prezentován | IPUZEL ip06id | 1,1 : 0,M | IPPREZEN ip06id |

Indexy

Název | Primární | Výraz | Popis
ix_IPPREZEN_ip06id | P | ip06id | Identifikátor prezentace
ix_IPPREZEN_ip06nazpre |  | ip06nazpre | Název prezentace


IPRADEK Řádek pásu tabulky uzlu informačního panelu

Popis

Řádek pásu tabulky uzlu informačního panelu

Atributy

Atribut | Typ | Návěští | Message | Popis
ip01id | C(12) | Uzel | Identifikátor uzlu informačního panelu | Identifikátor uzlu informačního panelu
ip14pas | N(3,0) | P | Číslo pásu | Číslo pásu
ip15radek | N(3,0) | Ř | Číslo řádku | Číslo řádku
ip15label | M | Návěští řádku | Návěští řádku | Návěští řádku
ip15when | M | Podmínka | Podmínka zařazení řádku do tabulky | Podmínka zařazení řádku do tabulky
ip15attrib | M | Atributy elementu | Atributy elementu řádku (TR) oddělené enterem | Atributy elementu řádku (TR) oddělené enterem

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Řádek pásu tabulky uzlu informačního panelu - patří do pásu tabulky | IPRADEK ip01id ip14pas | 1,1 : 0,M | IPPAS ip01id ip14pas |
Element sloupce pro řádku tabulky - náleží řádku pásu tabulky | IPRADELE ip01id ip14pas ip15radek | 1,1 : 0,M | IPRADEK ip01id ip14pas ip15radek |
Buňka tabulky uzlu informačního panelu - patří do řádky pásu tabulky | IPBUNKA ip01id ip14pas ip15radek | 1,1 : 0,M | IPRADEK ip01id ip14pas ip15radek |

Indexy

Název | Primární | Výraz | Popis
ix_IPRADEK_ipradek | P | ip01id, ip14pas, ip15radek | PI - ip01id+ip14pas+ip15radek
ix_IPRADEK_ippas |  | ip01id, ip14pas | PI - ip01id+ip14pas
ix_IPRADEK_ip01id |  | ip01id | Identifikátor uzlu informačního panelu


IPRADELE Element sloupce pro řádku tabulky

Popis

Element sloupce pro řádku tabulky

Atributy

Atribut | Typ | Návěští | Message | Popis
ip01id | C(12) | Uzel | Identifikátor uzlu informačního panelu | Identifikátor uzlu informačního panelu
ip14pas | N(3,0) | P | Číslo pásu | Číslo pásu
ip15radek | N(3,0) | Ř | Číslo řádku | Číslo řádku
ip02sloup | N(3,0) | S | Číslo sloupce | Číslo sloupce
ip03porad | N(3,0) | Pořadí | Pořadí elementu | Pořadí elementu
ip03band | C(3) | Pás | Pás řádků tabulky - Hlavička/Tělo/Patička | Hlavička/Tělo/Patička
ip03break | N(1,0) | Break | Po vložení elementu následuje tag | Po vložení elementu následuje tag
ip03vyraz | M | Výraz | Výraz pro stanovení hodnoty elementu | Výraz pro stanovení hodnoty elementu
ip08id | C(12) | Hypertext | Identifikace hypertextového odkazu | Identifikace hypertextového odkazu
ip03bold | N(1,0) | ip03bold | Zobrazit tučně | Zobrazit tučně
ip03italic | N(1,0) | ip03italic | Zobrazit kurzívou | Zobrazit kurzívou
ip03underl | N(1,0) | ip03underl | Zobrazit podtržené | Zobrazit podtržené
ip03tag | M | Tag | Tag elementu | Tag elementu
ip03when | M | Podmínka | Podmínka zařazení elementu na stránku | Podmínka zařazení elementu na stránku
ip03param | M | Parametry | Skutečné parametry použité v doplnění where hypertextového odkazu - přebíjejí parametry uvedené v definici hypertextového odkazu | Skutečné parametry použité v doplnění where hypertextového odkazu - přebíjejí parametry uvedené v definici hypertextového odkazu
ip03nazuzl | M | Jiný název | Jiný název uzlu informačního panelu - za znakem ~ je možné zadat výraz (překrývá jiný název v hypertextu) | Jiný název uzlu informačního panelu - za znakem ~ je možné zadat výraz (překrývá jiný název v hypertextu)
ip03attrib | M | Atributy | Atributy elementu oddělené enterem (např.TITLE=výraz v jazyce Foxpro) | Atributy elementu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Element sloupce pro řádku tabulky - náleží sloupci pásu tabulky | IPRADELE ip01id ip14pas ip02sloup | 1,1 : 0,M | IPSLOUPE ip01id ip14pas ip02sloup |
Element sloupce pro řádku tabulky - používá hypertextový odkaz na uzel | IPRADELE ip08id | 0,1 : 0,M | IPHYPER ip08id |
Element sloupce pro řádku tabulky - náleží řádku pásu tabulky | IPRADELE ip01id ip14pas ip15radek | 1,1 : 0,M | IPRADEK ip01id ip14pas ip15radek |

Indexy

Název | Primární | Výraz | Popis
ix_IPRADELE_ipradele | P | ip01id, ip14pas, ip15radek, ip02sloup, ip03porad | PI - ip01id+ip14pas+ip15radek+ip02sloup+ip03porad
ix_IPRADELE_ippas |  | ip01id, ip14pas | PI - ip01id+ip14pas
ix_IPRADELE_ipsloupe |  | ip01id, ip14pas, ip02sloup | PI - ip01id+ip14pas+ip02sloup
ix_IPRADELE_ipradek |  | ip01id, ip14pas, ip15radek | PI - ip01id+ip14pas+ip15radek
ix_IPRADELE_ip01id |  | ip01id | Identifikátor uzlu informačního panelu
ix_IPRADELE_ip08id |  | ip08id | Identifikace hypertextového odkazu


IPSEKTOR Sektor stránky informačního panelu

Popis

Sektor stránky informačního panelu

Atributy

Atribut | Typ | Návěští | Message | Popis
ip01id | C(12) | Uzel | Identifikátor uzlu informačního panelu | Identifikátor uzlu informačního panelu
ip17id | C(2) | Sektor | Pozice sektoru stránky ve tvaru písmeno+cifra - písmeno určuje pozici v ose X, cifra určuje pozici v ose Y | Pozice sektoru stránky ve tvaru písmeno+cifra - písmeno určuje pozici v ose X, cifra určuje pozici v ose Y
ip17tag | M | Tag buňky | Tag buňky | Tag buňky
ip17koment | M | Poznámka | Poznámka | Poznámka
ip17txpre | M | PRETEXT | Text vložený před buňku sektoru | Text vložený před buňku sektoru
ip17txpost | M | POSTTEXT | Text vložený za buňku sektoru | Text vložený za buňku sektoru
ip17zobemp | N(1,0) | Prázdný sektor | Zobrazovat prázdný sektor Ano/Ne | Zobrazovat prázdný sektor Ano/Ne
ip17maxrow | N(2,0) | MaxRow | Maximální počet sloučených řádků sektoru | Maximální počet sloučených řádků sektoru
ip17maxcol | N(2,0) | MaxCol | Maximální počet sloučených sloupců sektoru | Maximální počet sloučených sloupců sektoru
ip17popis | C(40) | Popis | Popis sektoru - neuplatňuje se ve výstupu | Popis sektoru - neuplatňuje se ve výstupu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Sektor stránky informačního panelu - patří k stránce | IPSEKTOR ip01id | 1,1 : 0,M | IPUZEL ip01id |

Indexy

Název | Primární | Výraz | Popis
ix_IPSEKTOR_ipsektor | P | ip01id, ip17id | PI - ip01id+ip17id
ix_IPSEKTOR_ip01id |  | ip01id | Identifikátor uzlu informačního panelu


IPSLOUPE Sloupec pásu tabulky uzlu informačního panelu

Popis

Sloupec pásu tabulky uzlu informačního panelu

Atributy

Atribut | Typ | Návěští | Message | Popis
ip01id | C(12) | Uzel | Identifikátor uzlu informačního panelu | Identifikátor uzlu informačního panelu
ip14pas | N(3,0) | P | Číslo pásu | Číslo pásu
ip02sloup | N(3,0) | S | Číslo sloupce | Číslo sloupce
ip02label | M | Návěští sloupce | Návěští sloupce | Návěští sloupce
ip02suma | N(1,0) | Součtový sloupec | Součtový sloupec | Součtový sloupec
ip02align | N(1,0) | Zarovnání | Zarovnání sloupce vpravo/střed/vlevo | Zarovnání sloupce vpravo/střed/vlevo
ip02format | C(40) | Formát | Formátovací maska pro zobrazení hodnoty | Formátovací maska pro zobrazení hodnoty
ip02when | M | Podmínka | Podmínka zařazení sloupce do tabulky | Podmínka zařazení sloupce do tabulky
ip02vyrazo | M | Výraz třídění | Výraz třídění dat vrácených dotazem SQL (výraz uvedený znakem * definuje střídavé vzestupené a sestupné třídění při opakovaném stisku hypertextu návěští sloupce) | Výraz třídění dat vrácených dotazem SQL (výraz uvedený znakem * definuje střídavé vzestupené a sestupné třídění při opakovaném stisku hypertextu návěští sloupce)
ip02attrib | M | Atributy návěští | Atributy elementu návěští sloupce oddělené enterem (např.TITLE=výraz v jazyce Foxpro) | Atributy elementu návěští sloupce

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Sloupec pásu tabulky uzlu informačního panelu - patří do pásu tabulky | IPSLOUPE ip01id ip14pas | 1,1 : 0,M | IPPAS ip01id ip14pas |
Element sloupce pro řádku tabulky - náleží sloupci pásu tabulky | IPRADELE ip01id ip14pas ip02sloup | 1,1 : 0,M | IPSLOUPE ip01id ip14pas ip02sloup |
Buňka tabulky uzlu informačního panelu - patří do sloupce pásu tabulky | IPBUNKA ip01id ip14pas ip02sloup | 1,1 : 0,M | IPSLOUPE ip01id ip14pas ip02sloup |

Indexy

Název | Primární | Výraz | Popis
ix_IPSLOUPE_ipsloupe | P | ip01id, ip14pas, ip02sloup | PI - ip01id+ip14pas+ip02sloup
ix_IPSLOUPE_ippas |  | ip01id, ip14pas | PI - ip01id+ip14pas
ix_IPSLOUPE_ip01id |  | ip01id | Identifikátor uzlu informačního panelu


IPUZEL Uzel informačního panelu

Popis

Uzel informačního panelu

Atributy

Atribut | Typ | Návěští | Message | Popis
ip01id | C(12) | Uzel | Identifikátor uzlu informačního panelu | Identifikátor uzlu informačního panelu
ip01nazuzl | C(40) | Název uzlu inf. panelu | Název uzlu informačního panelu | Název uzlu informačního panelu
ip05id | C(6) | Druh | Identifikace druhu uzlu | Identifikace druhu uzlu
ip06id | C(6) | Prezentace | Identifikátor prezentace | Identifikátor prezentace
bw88id | C(6) | Ikona | Identifikace ikony | Identifikace ikony
ip01typ | N(1,0) | Typ | Typ uzlu informačního panelu | Typ uzlu informačního panelu
ip01typprv | N(1,0) | Typ prvku | Typ prvku stránky | Typ prvku stránky
ip01vyrlab | M | Výraz názvu | Výraz názvu uzlu informačního panelu | Výraz názvu uzlu informačního panelu
sp94id | C(6) | Spojení | Identifikace spojení | Identifikace spojení
ip01sql | M | SQL dotaz | SQL dotaz | SQL dotaz
ip01vyrazo | M | Výraz třídění | Výraz třídění dat vrácených dotazem SQL | Výraz třídění dat vrácených dotazem SQL
ip01txpre | M | PRETEXT | Text zobrazený na HTML před vyhodnocením uzlu | Text zobrazený na HTML před vyhodnocením uzlu
ip01txpost | M | POSTTEXT | Text zobrazený na HTML po vyhodnocení uzlu | Text zobrazený na HTML po vyhodnocení uzlu
ip01koment | M | Poznámka | Poznámka | Poznámka
ip01priadr | M | Adresa | Přímá webová adresa volaná při aktivaci stránky | Přímá webová adresa volaná při aktivaci stránky
ip01script | M | SKRIPT | Script typu prvku 'Odkazy s vyvoláním skriptu' v jazyce Foxpro, který vrací skript v jazyce Foxpro vyvolaný pro tento hypertextový odkaz | Script prvku v jazyce Foxpro vyvolávaný v různých fázích tvorby prvku
ip01empty | N(1,0) | Prázdná | Vytvářená tabulka může být prázdná | Vytvářená tabulka může být prázdná
ip01herows | N(3,0) | Ř. hlavičky | Počet řádků hlavičky | Počet řádků hlavičky
ip01forows | N(3,0) | Ř. patičky | Počet řádků patičky | Počet řádků patičky
ip17id | C(2) | Sektor | Pozice sektoru stránky ve tvaru písmeno+cifra - písmeno určuje pozici v ose X, cifra určuje pozici v ose Y | Pozice sektoru stránky ve tvaru písmeno+cifra - písmeno určuje pozici v ose X, cifra určuje pozici v ose Y
ip01poptab | M | Styl tabulky sektorů | Popis stylu tabulky rozvržení sektorů | Popis stylu tabulky rozvržení sektorů
ip01dcount | N(1,0) | ip01dcount | Zobrazovat počet záznamů při uplatnění uzlu na stránce jako odkaz | Zobrazovat počet záznamů při uplatnění uzlu na stránce jako odkaz
ip01maxrec | N(9,0) | Stránkování | Stránkovat po zadaném počtu záznamů (0=nestánkovat) | Stránkovat po zadaném počtu záznamů (0=nestánkovat)
ip01maxreu | N(1,0) | Odkazy | Umístění řádky s odkazy na stránky stránkování | Umístění řádky s odkazy na stránky stránkování
ip01maxrez | N(1,0) | Zahrnout | Zahrnout řádku s odkazy stránkování do tabulky nebo mimo tabulku | Zahrnout řádku s odkazy stránkování do tabulky nebo mimo tabulku
ip01maxret | M | Tag | Tag odkazů stránkování | Tag odkazů stránkování
ip01maxren | M | Návěští | Návěští odkazů stránkování (text ### může určovat umístění odkazů v textu návěští) | Návěští odkazů stránkování
ip01bodatt | M | Atributy elementu BODY | Atributy elementu BODY oddělené enterem (např.TITLE=výraz v jazyce Foxpro) |
ip01reftim | N(5,0) | Refresh | Interval obnovení stránky ve vteřinách | Interval obnovení stránky ve vteřinách

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Uzel informačního panelu - je druhu | IPUZEL ip05id | 1,1 : 0,M | IPDRUH ip05id |
Uzel informačního panelu - je prezentován | IPUZEL ip06id | 1,1 : 0,M | IPPREZEN ip06id |
Uzel informačního panelu - používá spojení | IPUZEL sp94id | 0,1 : 0,M | SPIMPS sp94id |
Uzel informačního panelu - používá ikonu | IPUZEL bw88id | 1,1 : 0,M | BWIKONA bw88id |
Poduzel uzlu informačního panelu - určuje předchůdce | IPUZELP ip01id | 1,1 : 0,M | IPUZEL ip01id |
Poduzel uzlu informačního panelu - určuje následníka | IPUZELP ip01id2 | 1,1 : 0,M | IPUZEL ip01id |
Poslední stránka na panelu použitá uživatelm systému - určuje panel | IPUZIUZE ip01id | 1,1 : 0,M s rušením | IPUZEL ip01id |
Poslední stránka na panelu použitá uživatelm systému - určuje stránku | IPUZIUZE ip01id2 | 1,1 : 0,M s rušením | IPUZEL ip01id |
Hypertextový odkaz - odkazuje na uzel | IPHYPER ip01id | 0,1 : 0,M | IPUZEL ip01id |
Pás tabulky uzlu informačního panelu - náleží k uzlu | IPPAS ip01id | 1,1 : 0,M | IPUZEL ip01id |
Buňka tabulky uzlu informačního panelu - obsahuje tabulku vytvořenou uzlem | IPBUNKA ip01id2 | 0,1 : 0,M | IPUZEL ip01id |
Sektor stránky informačního panelu - patří k stránce | IPSEKTOR ip01id | 1,1 : 0,M | IPUZEL ip01id |

Indexy

Název | Primární | Výraz | Popis
ix_IPUZEL_ip01id | P | ip01id | Identifikátor uzlu informačního panelu
ix_IPUZEL_ip01nazuzl |  | ip01nazuzl | Název uzlu informačního panelu
ix_IPUZEL_ip05id |  | ip05id | Identifikace druhu uzlu
ix_IPUZEL_ip06id |  | ip06id | Identifikátor prezentace
ix_IPUZEL_bw88id |  | bw88id | Identifikace ikony
ix_IPUZEL_ip01typ |  | ip01typ | Typ uzlu informačního panelu
ix_IPUZEL_sp94id |  | sp94id | Identifikace spojení


IPUZELP Poduzel uzlu informačního panelu

Popis

Poduzel uzlu informačního panelu

Atributy

Atribut | Typ | Návěští | Message | Popis
ip01id | C(12) | Uzel | Identifikátor uzlu informačního panelu | Identifikátor uzlu informačního panelu
ip01id2 | C(12) | Uzel | Identifikátor poduzlu informačního panelu | Identifikátor poduzlu informačního panelu
ip04alias | C(6) | Alias | Alias poduzlu informačního panelu | Alias poduzlu informačního panelu
ip04nazuzl | M | Název uzlu informačního panelu (alias) | Název uzlu informačního panelu (alias) - za znakem ~ je možné zadat výraz | Název uzlu informačního panelu (alias) - za znakem ~ je možné zadat výraz
ip04porad | N(3,0) | Pořadí | Pořadí | Pořadí
ip04span | N(1,0) | Návěští | Návěští poduzlu Rozbalené/Nerozbalené/Žádné | Obsah poduzlu má být rozbalen
ip04attr | M | Atributy | Doplnění SQL dotazu na jeho začátku (je-li uveden atribut musí být posledním textu znakem čárka) | Doplnění SQL dotazu na jeho začátku (je-li uveden atribut musí být posledním textu znakem čárka)
ip04from | M | FROM | Doplnění FROM dotazu SQL poduzlu | Doplnění FROM dotazu SQL poduzlu
ip04where | M | WHERE | Doplnění WHERE dotazu SQL poduzlu | Doplnění WHERE dotazu SQL poduzlu
ip04param | M | Parametry | Skutečné parametry použité v doplnění where poduzlu | Skutečné parametry použité v doplnění where poduzlu
ip04txpre | M | PRETEXT | Text zobrazený na HTML před vyhodnocením uzlu | Text zobrazený na HTML před vyhodnocením uzlu
ip04txpost | M | POSTTEXT | Text zobrazený na HTML po vyhodnocení uzlu | Text zobrazený na HTML po vyhodnocení uzlu
ip04koment | M | Poznámka | Poznámka | Poznámka
ip04index | C(40) | Index | Index pro nabídku pro hypertext v při editaci Word v XML dokumentu | Nabízet pro nabídku pro hypertext v při editaci Word v XML dokumentu
ip04vyrazo | M | Výraz třídění | Výraz třídění dat vrácených dotazem SQL | Výraz třídění dat vrácených dotazem SQL
ip04when | M | Podmínka | Podmínka zařazení poduzlu | Podmínka zařazení poduzlu
ip17id | C(2) | Sektor | Pozice sektoru stránky ve tvaru písmeno+cifra - písmeno určuje pozici v ose X, cifra určuje pozici v ose Y | Pozice sektoru stránky ve tvaru písmeno+cifra - písmeno určuje pozici v ose X, cifra určuje pozici v ose Y

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Poduzel uzlu informačního panelu - určuje předchůdce | IPUZELP ip01id | 1,1 : 0,M | IPUZEL ip01id |
Poduzel uzlu informačního panelu - určuje následníka | IPUZELP ip01id2 | 1,1 : 0,M | IPUZEL ip01id |
Zobrazení poduzlu pro uživatele - se týká poduzlu | IPUZELPZ ip01id ip01id2 ip04alias | 1,1 : 0,M s rušením | IPUZELP ip01id ip01id2 ip04alias |

Indexy

Název | Primární | Výraz | Popis
ix_IPUZELP_ipuzelp | P | ip01id, ip01id2, ip04alias | PI - ip01id+id01id2+ip04alias
ix_IPUZELP_ip01id |  | ip01id | Identifikátor uzlu informačního panelu
ix_IPUZELP_ip01id2 |  | ip01id2 | Identifikátor poduzlu informačního panelu
ix_IPUZELP_ip04index |  | ip04index | Nabízet pro nabídku pro hypertext v při editaci Word v XML dokumentu


IPUZELPZ Zobrazení poduzlu pro uživatele

Popis

Zobrazení poduzlu pro uživatele

Atributy

Atribut | Typ | Návěští | Message | Popis
ip01id | C(12) | Uzel | Identifikátor uzlu informačního panelu | Identifikátor uzlu informačního panelu
ip01id2 | C(12) | Uzel | Identifikátor poduzlu informačního panelu | Identifikátor poduzlu informačního panelu
ip04alias | C(6) | Alias | Alias poduzlu informačního panelu | Alias poduzlu informačního panelu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
ip09zobr | N(1,0) | Zobrazení poduzlu | Zobrazení poduzlu pro uživatele Vždy,Skryté,Nikdy | Zobrazení poduzlu pro uživatele Vždy,Skryté,Nikdy

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Zobrazení poduzlu pro uživatele - se týká poduzlu | IPUZELPZ ip01id ip01id2 ip04alias | 1,1 : 0,M s rušením | IPUZELP ip01id ip01id2 ip04alias |
Zobrazení poduzlu pro uživatele - se týká uživatele | IPUZELPZ bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_IPUZELPZ_ipuzelpz | P | ip01id, ip01id2, ip04alias, bw01uziv | PI - IPUZELP+bw01uziv
ix_IPUZELPZ_ipuzelp |  | ip01id, ip01id2, ip04alias | PI - ip01id+id01id2+ip04alias
ix_IPUZELPZ_bw01uziv |  | bw01uziv | Identifikace uživatele systému


IPUZIUZE Poslední stránka na panelu použitá uživatelm systému

Popis

Poslední stránka na panelu použitá uživatelm systému

Atributy

Atribut | Typ | Návěští | Message | Popis
ip01id | C(12) | Uzel | Identifikátor uzlu informačního panelu | Identifikátor uzlu informačního panelu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
ip01id2 | C(12) | Uzel | Identifikátor poduzlu informačního panelu | Identifikátor poduzlu informačního panelu
ip07left | N(5,0) | ip07left | Pozice okna informačního panelu - LEFT | Pozice okna informačního panelu - LEFT
ip07top | N(5,0) | ip07top | Pozice okna informačního panelu - TOP | Pozice okna informačního panelu - TOP
ip07height | N(5,0) | ip07height | Pozice okna informačního panelu - HEIGHT | Pozice okna informačního panelu - HEIGHT
ip07width | N(5,0) | ip07width | Pozice okna informačního panelu - WIDTH | Pozice okna informačního panelu - WIDTH
ip07skryte | N(1,0) | ip07skryte | Zobrazovat skryté uzly | Zobrazovat skryté uzly

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Poslední stránka na panelu použitá uživatelm systému - určuje panel | IPUZIUZE ip01id | 1,1 : 0,M s rušením | IPUZEL ip01id |
Poslední stránka na panelu použitá uživatelm systému - určuje stránku | IPUZIUZE ip01id2 | 1,1 : 0,M s rušením | IPUZEL ip01id |
Poslední stránka na panelu použitá uživatelm systému - určuje uživatele | IPUZIUZE bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_IPUZIUZE_ipuziuze | P | ip01id, bw01uziv | PI - ip01id+bw01uziv
ix_IPUZIUZE_ip01id |  | ip01id | Identifikátor uzlu informačního panelu
ix_IPUZIUZE_ip01id2 |  | ip01id2 | Identifikátor poduzlu informačního panelu
ix_IPUZIUZE_bw01uziv |  | bw01uziv | Identifikace uživatele systému


Tabulky MT...

MTAH | Aktuální hodnota skladu
MTAHR | Aktuální hodnota skladu (replikovaná)
MTAHTEMP | Temp soubor pro hromadný vstup množství
MTAHUD | Událost - skladba
MTARTIKL | Skladovaný artikl
MTBUN | Skladová buňka
MTFIFO | FIFO
MTKARVC | Karta artiklu s výrobním číslem
MTMN | Množství artiklu na skladech
MTMNB | Množství artiklu v a buňkách
MTMNN | Artikl na skladě s nenulovým množstvím
MTMNP | Množství artiklu ve skladové buňce
MTOBRAT | Obrat skladu
MTOBRATQ | Pohled pro zjištění posledního data obratu skladu
MTOBRATV | Vypočtený obrat skladovaného artiklu s výrobním číslem
MTPARSKL | Parametry komponenty sklady
MTSKL | Sklad
MTUDA | Událost skladu
MTUDAX | Hodnota skladu s vysčítanou cenou a množstvím pro import

Viz.také

MTAH Aktuální hodnota skladu | MTAHR Aktuální hodnota skladu (replikovaná) | MTAHTEMP Temp soubor pro hromadný vstup množství | MTAHUD Událost - skladba | MTARTIKL Skladovaný artikl | MTBUN Skladová buňka | MTFIFO FIFO | MTKARVC Karta artiklu s výrobním číslem | MTMN Množství artiklu na skladech | MTMNB Množství artiklu v a buňkách | MTMNN Artikl na skladě s nenulovým množstvím | MTMNP Množství artiklu ve skladové buňce | MTOBRAT Obrat skladu | MTOBRATQ Pohled pro zjištění posledního data obratu skladu | MTOBRATV Vypočtený obrat skladovaného artiklu s výrobním číslem | MTPARSKL Parametry komponenty sklady | MTSKL Sklad | MTUDA Událost skladu | MTUDAX Hodnota skladu s vysčítanou cenou a množstvím pro import


MTAH Aktuální hodnota skladu

Popis

Aktuální hodnota skladu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
mt04id | C(6) | Sklad | Identifikace umístění skladové evidence | Identifikace umístění skladové evidence
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
mt05id | C(9) | mt05id | Identifikace skladové buňky | Identifikace skladové buňky
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
ad01id | C(6) | Adresát | Adresát | Identifikace adresáta
mt02hodnot | N(20,4) | Hodnota | Hodnota |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Aktuální hodnota skladu - týká se statistické informace | MTAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_MTAH_mtah | P | sp60id, sp67id, mt04id, sp61id, mt05id, sp06idsubs, ad01id |
ix_MTAH_mtbun1 |  | mt04id, mt05id | mt04id+mt05id
ix_MTAH_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_MTAH_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_MTAH_ad01id |  | ad01id | Identifikace adresáta
ix_MTAH_mt04id |  | mt04id | Identifikace umístění skladové evidence
ix_MTAH_adadsatx |  |  |
ix_MTAH_spartiknx |  |  |


MTAHR Aktuální hodnota skladu (replikovaná)

Popis

Aktuální hodnota skladu (replikovaná)

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
mt04id | C(6) | Sklad | Identifikace umístění skladové evidence | Identifikace umístění skladové evidence
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
mt05id | C(9) | mt05id | Identifikace skladové buňky | Identifikace skladové buňky
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
mt02hodnot | N(20,4) | mt02hodnot |  |

Indexy

Název | Primární | Výraz | Popis
ix_MTAHR_mtah | P | sp60id, sp67id, mt04id, sp61id, mt05id, sp06idsubs, ad01id |


MTAHTEMP Temp soubor pro hromadný vstup množství

Popis

Temp soubor pro hromadný vstup množství

Atributy

Atribut | Typ | Návěští | Message | Popis
mt16 | C(10) | mt16 |  |
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
mt04id | C(6) | Sklad | Identifikace umístění skladové evidence | Identifikace umístění skladové evidence
mt05id | C(9) | mt05id | Identifikace skladové buňky | Identifikace skladové buňky
mt04id2 | C(6) | Cílový sklad | Identifikace cílového skladu | Identifikace cílového skladu
mt16index | C(12) | mt16index | Index pro označování | Index pro označování
mt02hodnot | N(20,4) | mt02hodnot |  |
mt05id2 | C(9) | Buňka | Identifikace skladové buňky | Identifikace skladové buňky
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
mt16text | C(40) | Popis | Popis | Popis

Indexy

Název | Primární | Výraz | Popis
ix_MTAHTEMP_mtahtemp | P | mt16, sp60id, sp61id, mt04id, mt05id, mt04id2, mt16index |
ix_MTAHTEMP_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_MTAHTEMP_spartiknx |  |  |
ix_MTAHTEMP_mt04id |  | mt04id | Identifikace umístění skladové evidence
ix_MTAHTEMP_mt04id2 |  | mt04id2 | Identifikace cílového skladu


MTAHUD Událost - skladba

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
mt02 | C(12) | mt02 | Jednoznačná časová identifikace události skladu | Jednoznačná časová identifikace události skladu
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ad01id | C(6) | Adresát | Adresát | Identifikace adresáta
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp74id | C(6) | sp74id | Umístění | Umístění
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp00datum | D | Datum | Datum události | Datum události
sp00text | C(40) | Popis | Popis události | Popis události
sp00hodnot | N(20,4) | Hodnota | Aktuální hodnota procesu |
sp69id | C(6) | Druh | Identifikace druhu saldokontní hodnoty procesu | Identifikace druhu saldokontní hodnoty procesu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost - skladba - týká se aktéra | MTAHUD ad01id | 0,1 : 0,M | ADADSAT ad01id |
Událost - skladba - koresponduje s aktuální hodnotou procesu | MTAHUD sp33hid sp69id ad01id sp60id sp61id sp74id | 1,1 : 0,M | SPPRCSAL sp33hid sp69id ad01id sp60id sp61id sp74id |
Událost - skladba - týká se druhu hodnoty | MTAHUD sp67id sp06idsubs | 0,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_MTAHUD_sp33hid |  | sp33hid | Časová identifikace hlavního procesu
ix_MTAHUD_mt02 |  | mt02 | Jednoznačná časová identifikace události skladu
ix_MTAHUD_ad01id |  | ad01id | Identifikace adresáta
ix_MTAHUD_sp74id |  | sp74id | Umístění
ix_MTAHUD_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_MTAHUD_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_MTAHUD_spahud |  | sp60id, sp61id, ad01id, sp74id, sp67id, sp06idsubs | Artikl+Aktér+Umístění+Druh hodnoty
ix_MTAHUD_spprcsal |  | sp33hid, sp69id, ad01id, sp60id, sp61id, sp74id | Primární index salda procesu


MTARTIKL Skladovaný artikl

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp00aktual | N(1,0) | sp00aktual | Aktuální/ neaktuální | Aktuální/ neaktuální neboli skrytý/ neskrytý
mt01koment | M | Pozn. | Komentář - poznámka k artiklu | Komentář k artiklu
mt01ck | C(36) | Čarový kód | Kód automatické identifikace | Kód automatické identifikace
sp24idmj | C(3) | Měrná jednotka | Identifikátor měrné jednotky | Identifikátor měrné jednotky
sp20idzak | C(9) | Identifikátor technicko-věcného selektoru | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
bw01uziv | C(6) | Zapsal | Identifikace uživatele systému | Identifikace uživatele systému
sp17idskp | C(8) | Třída SKP | Identifikace třídy Standardní klasifikace produkce. | Identifikace kategorie Standardní klasifikace produkce. *** Dříve SKPID.
ob02vzucet | N(1,0) | Vztah k účetnictví | Vztah k účetnictví - zboží, materiál, výrobek, služba ... | Vztah k účetnictví
sp00uselar | C(9) | Účetní selektor artiklu | Účetní selektor artiklu | Účetní selektor artiklu
ob01nulcen | N(1,0) | ob01nulcen | Povolena nulová cena v událostech o artiklu | Povolena nulová cena

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Skladovaný artikl - má referenční měrnou jednotku | MTARTIKL sp24idmj | 1,1 : 1,1 | SPMJ sp24idmj |
Skladovaný artikl - má tech. věc. selektor | MTARTIKL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Skladovaný artikl - založil uživatel systému | MTARTIKL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Skladovaný artikl - je artiklem | MTARTIKL sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Skladovaný artikl - je veden ve třídě SKP | MTARTIKL sp17idskp | 1,1 : 0,M | SPSKP sp17idskp |
Událost skladu - pracuje s artiklem skladu | MTUDA sp60id sp61id | 1,1 : 0,M | MTARTIKL sp60id sp61id |
Množství artiklu na skladech - je za artikl | MTMN sp60id sp61id | 1,1 : 0,M | MTARTIKL sp60id sp61id |
Množství artiklu v a buňkách - je za artikl | MTMNB sp60id sp61id | 1,1 : 0,M | MTARTIKL sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_MTARTIKL_spartikl | P | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_MTARTIKL_sp61id |  | sp61id | Identifikace druhu artiklu
ix_MTARTIKL_sp60id |  | sp60id | Identifikace artiklu
ix_MTARTIKL_sp00aktual |  | sp00aktual | Aktuální/ neaktuální neboli skrytý/ neskrytý
ix_MTARTIKL_mt01ck |  | mt01ck | Kód automatické identifikace
ix_MTARTIKL_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky
ix_MTARTIKL_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_MTARTIKL_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_MTARTIKL_sp17idskp |  | sp17idskp | Identifikace kategorie Standardní klasifikace produkce.
ix_MTARTIKL_sp00uselar |  | sp00uselar | Účetní selektor artiklu
ix_MTARTIKL_spartiknx |  |  |


MTBUN Skladová buňka

Atributy

Atribut | Typ | Návěští | Message | Popis
mt04id | C(6) | Sklad | Identifikace umístění skladové evidence | Identifikace umístění skladové evidence
mt05id | C(9) | Buňka | Identifikace skladové buňky | Identifikace skladové buňky
mt05text | C(40) | Název | Název skladové buňky | Název skladové buňky - není povinný
mt05ck | C(36) | Čarový kód | Kód automatické identifikace | Kód automatické identifikace skladové buňky
mt05x | N(5,0) | Umístění buňky osa X | Umístění buňky osa X | Umístění buňky osa X
mt05y | N(5,0) | Umístění buňky osa Y | Umístění buňky osa Y | Umístění buňky osa Y
mt05z | N(5,0) | Umístění buňky osa Z | Umístění buňky osa Z | Umístění buňky osa Z
mt05txt | C(30) | Volný text | Volný text | Volný text

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Skladová buňka - přísluší skladu | MTBUN mt04id | 1,1 : 0,M s rušením | MTSKL mt04id |
Událost skladu - je ve skladové buňce | MTUDA mt04id mt05id | 1,1 : 0,M | MTBUN mt04id mt05id |
Množství artiklu v a buňkách - je za skladovou buňku | MTMNB mt04id mt05id | 1,1 : 0,M | MTBUN mt04id mt05id |
Očekávaný výdej artiklu ze skladové buňky - se týká skladovové buňky | OBUDASKL mt04id mt05id | 1,1 : 0,M | MTBUN mt04id mt05id |

Indexy

Název | Primární | Výraz | Popis
ix_MTBUN_mtbun1 | P | mt04id, mt05id | mt04id+mt05id
ix_MTBUN_mt04id |  | mt04id | Identifikace umístění skladové evidence
ix_MTBUN_mt05id |  | mt05id | Identifikace skladové buňky
ix_MTBUN_mt05text |  | mt05text | Název skladové buňky - není povinný
ix_MTBUN_mt05ck |  | mt05ck | Kód automatické identifikace skladové buňky


MTFIFO FIFO

Atributy

Atribut | Typ | Návěští | Message | Popis
mt08p | C(12) | mt08p | Jednoznačná časová identifikace - FIFO - Příjem | Jednoznačná časová identifikace - FIFO - Příjem
mt08v | C(12) | mt08v | Jednoznačná časová identifikace - FIFO - výdej | Jednoznačná časová identifikace - FIFO - výdej
mt08mnoz | N(20,4) | mt08mnoz | Množství artiklu - FIFO | Množství artiklu - FIFO

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
FIFO - váže událost skladu na straně příjmu | MTFIFO mt08p | 1,1 : 0,M s rušením | MTUDA mt02 |
FIFO - váže událost skladu na straně výdeje | MTFIFO mt08v | 1,1 : 0,M s rušením | MTUDA mt02 |

Indexy

Název | Primární | Výraz | Popis
ix_MTFIFO_mt08 | P | mt08p, mt08v | mt08p+mt08v
ix_MTFIFO_mt08p |  | mt08p | Jednoznačná časová identifikace - FIFO - Příjem
ix_MTFIFO_mt08v |  | mt08v | Jednoznačná časová identifikace - FIFO - výdej


MTKARVC Karta artiklu s výrobním číslem

Popis

Karta artiklu s výrobním číslem

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
mt04id | C(6) | Sklad | Identifikace umístění skladové evidence | Identifikace umístění skladové evidence
mt02vc | C(32) | VČ | Výrobní číslo | Výrobní číslo
mt21dat | D | Datum | Datum | Datum
mt21koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Karta artiklu s výrobním číslem - je karta na skladě | MTKARVC mt04id | 1,1 : 0,M | MTSKL mt04id |

Indexy

Název | Primární | Výraz | Popis
ix_MTKARVC_mtkarvc | P | sp60id, sp61id, mt04id, mt02vc |
ix_MTKARVC_spartiknx |  |  |
ix_MTKARVC_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_MTKARVC_mt04id |  | mt04id | Identifikace umístění skladové evidence
ix_MTKARVC_mt02vc |  | mt02vc | Výrobní číslo
ix_MTKARVC_mt21dat |  | mt21dat | Datum


MTMN Množství artiklu na skladech

Atributy

Atribut | Typ | Návěští | Message | Popis
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
mt04id | C(6) | Sklad | Identifikace umístění skladové evidence | Identifikace umístění skladové evidence
mt03mn | N(20,4) | Množství | Množství artiklu v umístění | Množství artiklu v umístění
mt03cena | N(20,4) | Celková cena | Celková cena artiklu v umístění | Celková cena artiklu v umístění

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Množství artiklu na skladech - je za artikl | MTMN sp60id sp61id | 1,1 : 0,M | MTARTIKL sp60id sp61id |
Množství artiklu na skladech - je za sklad | MTMN mt04id | 1,1 : 0,M | MTSKL mt04id |

Indexy

Název | Primární | Výraz | Popis
ix_MTMN_mtmn1 | P | sp61id, sp60id, mt04id | sp60id+sp61id+mt04id
ix_MTMN_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_MTMN_mt04id |  | mt04id | Identifikace umístění skladové evidence
ix_MTMN_sp61id |  | sp61id | Identifikace druhu artiklu


MTMNB Množství artiklu v a buňkách

Atributy

Atribut | Typ | Návěští | Message | Popis
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
mt04id | C(6) | Sklad | Identifikace umístění skladové evidence | Identifikace umístění skladové evidence
mt05id | C(9) | Buňka | Identifikace skladové buňky | Identifikace skladové buňky
mt03mn | N(20,4) | Množství | Množství artiklu v umístění | Množství artiklu v umístění
mt03cena | N(20,4) | Celková cena | Celková cena artiklu v umístění | Celková cena artiklu v umístění

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Množství artiklu v a buňkách - je za skladovou buňku | MTMNB mt04id mt05id | 1,1 : 0,M | MTBUN mt04id mt05id |
Množství artiklu v a buňkách - je za artikl | MTMNB sp60id sp61id | 1,1 : 0,M | MTARTIKL sp60id sp61id |
Množství artiklu v a buňkách - je za sklad | MTMNB mt04id | 1,1 : 0,M | MTSKL mt04id |

Indexy

Název | Primární | Výraz | Popis
ix_MTMNB_mtmnb1 | P | sp61id, sp60id, mt04id, mt05id | sp60id+sp61id+mt04id+mt05id
ix_MTMNB_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_MTMNB_mtbun1 |  | mt04id, mt05id | mt04id+mt05id
ix_MTMNB_mt04id |  | mt04id | Identifikace umístění skladové evidence
ix_MTMNB_sp61id |  | sp61id | Identifikace druhu artiklu


MTMNN Artikl na skladě s nenulovým množstvím

Popis

Artikl na skladě s nenulovým množstvím

Atributy

Atribut | Typ | Návěští | Message | Popis
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu


MTMNP Množství artiklu ve skladové buňce

Popis

Množství artiklu ve skladové buňce

Atributy

Atribut | Typ | Návěští | Message | Popis
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
mt04id | C(6) | Sklad | Identifikace umístění skladové evidence | Identifikace umístění skladové evidence
mt05id | C(9) | mt05id | Identifikace skladové buňky | Identifikace skladové buňky
mt03mn | N(20,4) | Množství | Množství artiklu v umístění | Množství artiklu v umístění
mt03cena | N(20,4) | Celková cena | Celková cena artiklu v umístění | Celková cena artiklu v umístění
mt03rezmn | N(20,4) | Rezervováno | Rezervované množství artiklu v umístění | Rezervované množství artiklu v umístění

Indexy

Název | Primární | Výraz | Popis
ix_MTMNP_mtmn1 |  | sp61id, sp60id, mt04id | sp60id+sp61id+mt04id
ix_MTMNP_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_MTMNP_spartiknx |  |  |
ix_MTMNP_mt04id |  | mt04id | Identifikace umístění skladové evidence
ix_MTMNP_mt05id |  | mt05id | Identifikace skladové buňky


MTOBRAT Obrat skladu

Popis

Obrat skladu

Atributy

Atribut | Typ | Návěští | Message | Popis
mt14datum | D | Datum | Datum obratu | Datum obratu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
mt04id | C(6) | Sklad | Identifikace umístění skladové evidence | Identifikace umístění skladové evidence
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
mt14pstav | N(20,4) | Poč.stav | Počáteční stav | Počáteční stav k datu
mt14prijem | N(20,4) | Příjem | Příjem | Příjem
mt14vydej | N(20,4) | Výdej | Výdej | Výdej

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Obrat skladu - se vztahuje k druhu hodnoty | MTOBRAT sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_MTOBRAT_mtobrat | P | mt14datum, sp60id, mt04id, sp67id, sp61id, sp06idsubs, ad01id | PI - obraty sklatu
ix_MTOBRAT_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_MTOBRAT_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_MTOBRAT_sp61id |  | sp61id | Identifikace druhu artiklu
ix_MTOBRAT_mt04id |  | mt04id | Identifikace umístění skladové evidence
ix_MTOBRAT_ad01id |  | ad01id | Identifikace adresáta
ix_MTOBRAT_mt14datum |  | mt14datum | Datum obratu
ix_MTOBRAT_adadsatx |  |  |
ix_MTOBRAT_spartiknx |  |  |
ix_MTOBRAT_mtobrat1 |  | sp61id, sp60id, mt04id, ad01id, mt14datum | Index - sp61id+sp60id+mt04id+ad01id+mt14datum


MTOBRATQ Pohled pro zjištění posledního data obratu skladu

Popis

Pohled pro zjištění posledního data obratu skladu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
mt04id | C(6) | Sklad | Identifikace umístění skladové evidence | Identifikace umístění skladové evidence
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
mt14datum | D | Datum | Datum obratu | Datum obratu


MTOBRATV Vypočtený obrat skladovaného artiklu s výrobním číslem

Popis

Vypočtený obrat skladovaného artiklu s výrobním číslem

Atributy

Atribut | Typ | Návěští | Message | Popis
mt02vc | C(32) | VČ | Výrobní číslo | Výrobní číslo
mt14datum | D | Datum | Datum obratu | Datum obratu
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
mt04id | C(6) | Sklad | Identifikace umístění skladové evidence | Identifikace umístění skladové evidence
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
mt14pstav | N(20,4) | Poč.stav | Počáteční stav | Počáteční stav k datu
mt14prijem | N(20,4) | Příjem | Příjem | Příjem
mt14vydej | N(20,4) | Výdej | Výdej | Výdej

Indexy

Název | Primární | Výraz | Popis
ix_MTOBRATV_mtobratv | P | mt02vc, mt14datum, sp67id, sp06idsubs, sp60id, sp61id, mt04id, ad01id |
ix_MTOBRATV_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_MTOBRATV_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_MTOBRATV_mt04id |  | mt04id | Identifikace umístění skladové evidence
ix_MTOBRATV_mt02vc |  | mt02vc | Výrobní číslo
ix_MTOBRATV_mt14datum |  | mt14datum | Datum obratu
ix_MTOBRATV_adadsatx |  |  |
ix_MTOBRATV_spartiknx |  |  |


MTPARSKL Parametry komponenty sklady

Popis

Parametry komponenty sklady

Atributy

Atribut | Typ | Návěští | Message | Popis
mt10 | C(12) | mt10 | Primární klíč parametrů komponenty sklady | Primární klíč parametrů komponenty sklady
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp67id2 | C(3) | Množství na skladě v naturálním vyjádření | Identifikace druhu hodnoty |
sp06idsub2 | C(3) | Komponenta | Identifikace komponenty - přijemce transformovaných dat | Identifikace komponenty - přijemce transformovaných dat
sp67id3 | C(3) | Rezervované množství na skladě | Identifikace druhu hodnoty |
sp06idsub3 | C(3) | Subsystém SDN | Identifikace subsystému SDN. |
sp67id4 | C(3) | Množství na skladě ve finačním vyjádření - předběžné ocenění | Identifikace druhu hodnoty | Množství na skladě ve finačním vyjádření - předběžné
sp06idsub4 | C(3) | Subsystém SKL | Identifikace subsystému SKL |
sp67id5 | C(3) | Množství na skladě ve naturálním vyjádření - předběžné ocenění | Identifikace druhu hodnoty | Množství na skladě ve naturálním vyjádření - předběžné ocenění
sp06idsub5 | C(3) | Subsystém POK | Identifikace subsystému POK |
sp67id6 | C(3) | Rezervované množství na skladě - předběžné ocenění | Identifikace druhu hodnoty | Rezervované množství na skladě - předběžné ocenění
sp06idsub6 | C(3) | Subsystém ZAP | Identifikace subsystému ZAP |
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametry komponenty sklady - definují druh hodnoty - stav ve finančním vyjádření | MTPARSKL sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Parametry komponenty sklady - definují druh hodnoty - stav v naturálním vyjádření | MTPARSKL sp67id2 sp06idsub2 | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Parametry komponenty sklady - definují druh hodnoty - rezervované množství v naturálním vyjádření | MTPARSKL sp67id3 sp06idsub3 | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Parametry komponenty sklady - aktualizoval uživatel | MTPARSKL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Parametry komponenty sklady - definují druh hodnoty - stav ve finančním vyjádření - ocenění předběžné | MTPARSKL sp67id4 sp06idsub4 | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Parametry komponenty sklady - definují druh hodnoty - rezervované množství v naturálním vyjádření - předběžné ocenění | MTPARSKL sp67id6 sp06idsub6 | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_MTPARSKL_mt10 | P | mt10 | Primární klíč parametrů komponenty sklady
ix_MTPARSKL_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_MTPARSKL_spstatdi22 |  | sp67id2, sp06idsub2 | sp67id2+sp06idsub2
ix_MTPARSKL_spstatdi3 |  | sp67id3, sp06idsub3 | sp67id3+sp06idsub3
ix_MTPARSKL_spstatdi4 |  | sp67id4, sp06idsub4 | sp67id4+sp06idsub4
ix_MTPARSKL_spstatdi5 |  | sp67id5, sp06idsub5 | sp67id5+sp06idsub5
ix_MTPARSKL_spstatdi6 |  | sp67id6, sp06idsub6 | sp67id6+sp06idsub6
ix_MTPARSKL_bw01uziv |  | bw01uziv | Identifikace uživatele systému


MTSKL Sklad

Atributy

Atribut | Typ | Návěští | Message | Popis
mt04id | C(6) | Sklad | Identifikace umístění skladové evidence | Identifikace umístění skladové evidence
mt04text | C(40) | Název | Název skladu | Název skladu
sp11idzak | C(9) | Identifikátor organizačního selektoru | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | Spojení | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
mt04stcen | N(1,0) | mt04stcen | Sklad je oceňován metodou: FIFO / Vážený průměr |
sp00uselum | C(9) | Účetní selektor umístění | Účetní selektor umístění | Účetní selektor umístění
mt04koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Sklad - má organizační selektor | MTSKL sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Sklad - je na adrese podle spojení | MTSKL ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Karta artiklu s výrobním číslem - je karta na skladě | MTKARVC mt04id | 1,1 : 0,M | MTSKL mt04id |
Událost skladu - je ve skladu | MTUDA mt04id | 1,1 : 0,M | MTSKL mt04id |
Skladová buňka - přísluší skladu | MTBUN mt04id | 1,1 : 0,M s rušením | MTSKL mt04id |
Množství artiklu na skladech - je za sklad | MTMN mt04id | 1,1 : 0,M | MTSKL mt04id |
Množství artiklu v a buňkách - je za sklad | MTMNB mt04id | 1,1 : 0,M | MTSKL mt04id |
Výrobní linka / stroj / skladové úložiště výroby - odpovídá skladu | TPLINKA mt04id | 0,1 : 0,M | MTSKL mt04id |

Indexy

Název | Primární | Výraz | Popis
ix_MTSKL_mt04id | P | mt04id | Identifikace umístění skladové evidence
ix_MTSKL_mt04text |  | mt04text | Název skladu
ix_MTSKL_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_MTSKL_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_MTSKL_ad01id |  | ad01id | Identifikace adresáta


MTUDA Událost skladu

Atributy

Atribut | Typ | Návěští | Message | Popis
mt02 | C(12) | mt02 | Jednoznačná časová identifikace události skladu | Jednoznačná časová identifikace události skladu
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
ad01id | C(6) | Adresát | Adresát | Identifikace adresáta
ad11cisspo | C(2) | Číslo spojení adresáta | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
mt04id | C(6) | Sklad | Identifikace umístění skladové evidence | Identifikace umístění skladové evidence
mt05id | C(9) | Buňka | Identifikace skladové buňky | Identifikace skladové buňky
mt02dat | D | Datum | Datum události skladové evidence | Datum události skladu
mt02pv | N(1,0) | Příjem / výdej | Příznak příjem / výdej | Příznak příjem / výdej
mt02text | C(40) | Popis | Popis události skladové evidence | Popis události skladu
sp24idmj | C(3) | Měrná jednotka | Identifikátor měrné jednotky | Identifikátor měrné jednotky
sp24idmj1 | C(3) | Měrná jednotka | Identifikátor měrné jednotky | Identifikátor měrné jednotky
mt02mn | N(20,4) | Množství | Množství artiklu - příjem | Množství artiklu
mt02mnr | N(20,4) | Množství v RMJ | Množství artiklu v referenční měrné jednotce - příjem | Množství artiklu v referenční měrné jednotce
mt02cj | N(20,4) | Cena za MJ | Cena za jednotku (cena skladová) | Cena za jednotku (cena skladová)
mt02cjr | N(20,4) | Cena za RMJ | Cena za jednotku (cena skladová) v referenční měrné jednotce | Cena za jednotku (cena skladová) v referenční měrné jednotce
mt02cc | N(20,4) | Celkem | Cena celkem - příjem | Cena celkem
sp10idzak | C(9) | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Identifikátor organizačního selektoru | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Identifikátor technicko-věcného selektoru | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
bw01uziv | C(6) | Zapsal | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
ob02vzucet | N(1,0) | Vztah k účetnictví | Vztah k účetnictví - zboží, materiál, výrobek, služba ... | Vztah k účetnictví
mt02mnr2 | N(20,4) | mt02mnr2 | Množství artiklu v referenční měrné jednotce - pro FIFO | Množství artiklu v referenční měrné jednotce - pro FIFO
mt02ocenen | N(1,0) | Ocenění | Ocenění - konečné/předběžné | Cena v události - konečná/předběžná
mt02vc | C(32) | VČ | Výrobní číslo | Výrobní číslo
mt02poradi | N(4,0) | Pořadí | Pořadí události v operaci | Pořadí události v operaci

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost skladu - pracuje s artiklem skladu | MTUDA sp60id sp61id | 1,1 : 0,M | MTARTIKL sp60id sp61id |
Událost skladu - má obchodní selektor | MTUDA sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost skladu - má organizační selektor | MTUDA sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost skladu - má technicko-věcný selektor | MTUDA sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost skladu - byla zapsána uživatelem | MTUDA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost skladu - má měrnou jednotku | MTUDA sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Událost skladu - má referenční měrnou jednotku | MTUDA sp24idmj1 | 1,1 : 0,M | SPMJ sp24idmj |
Událost skladu - má spojení adresáta | MTUDA ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost skladu - je ve skladu | MTUDA mt04id | 1,1 : 0,M | MTSKL mt04id |
Událost skladu - je ve skladové buňce | MTUDA mt04id mt05id | 1,1 : 0,M | MTBUN mt04id mt05id |
Událost skladu - patří do fyzické operace | MTUDA sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
FIFO - váže událost skladu na straně příjmu | MTFIFO mt08p | 1,1 : 0,M s rušením | MTUDA mt02 |
FIFO - váže událost skladu na straně výdeje | MTFIFO mt08v | 1,1 : 0,M s rušením | MTUDA mt02 |

Indexy

Název | Primární | Výraz | Popis
ix_MTUDA_mt02 | P | mt02 | Jednoznačná časová identifikace události skladu
ix_MTUDA_spprc |  | sp33cisd, sp33cisdpm, sp33cisdr | Identifikace procesu
ix_MTUDA_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_MTUDA_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_MTUDA_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_MTUDA_mtbun1 |  | mt04id, mt05id | mt04id+mt05id
ix_MTUDA_mtmn1 |  | sp61id, sp60id, mt04id | sp60id+sp61id+mt04id
ix_MTUDA_mtmnb1 |  | sp61id, sp60id, mt04id, mt05id | sp60id+sp61id+mt04id+mt05id
ix_MTUDA_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_MTUDA_spartiknx |  |  |
ix_MTUDA_adadsatx |  |  |
ix_MTUDA_mtartiklx |  |  |
ix_MTUDA_mt02dat |  | mt02dat | Datum události skladu
ix_MTUDA_mt02text |  | mt02text | Popis události skladu
ix_MTUDA_sp61id |  | sp61id | Identifikace druhu artiklu
ix_MTUDA_sp60id |  | sp60id | Identifikace artiklu
ix_MTUDA_mt04id |  | mt04id | Identifikace umístění skladové evidence
ix_MTUDA_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky
ix_MTUDA_sp24idmj1 |  | sp24idmj1 | Identifikátor měrné jednotky
ix_MTUDA_mt02mn |  | mt02mn | Množství artiklu
ix_MTUDA_mt02mnr |  | mt02mnr | Množství artiklu v referenční měrné jednotce
ix_MTUDA_mt02cc |  | mt02cc | Cena celkem
ix_MTUDA_ad01id |  | ad01id | Identifikace adresáta
ix_MTUDA_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_MTUDA_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_MTUDA_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_MTUDA_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_MTUDA_sp00datzap |  | sp00datzap | Datum a čas zápisu záznamu události
ix_MTUDA_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_MTUDA_mt02mnr2 |  | mt02mnr2 | Množství artiklu v referenční měrné jednotce - pro FIFO
ix_MTUDA_mt02ocenen |  | mt02ocenen | Cena v události - konečná/předběžná
ix_MTUDA_mt02vc |  | mt02vc | Výrobní číslo
ix_MTUDA_mtkarvc |  | sp60id, sp61id, mt04id, mt02vc |
ix_MTUDA_mtuda1 |  | sp61id, sp60id, mt04id, mt02dat | Index - sp61id+sp60id+mt04id+mt02dat
ix_MTUDA_mt02poradi |  | mt02poradi | Pořadí události v operaci


MTUDAX Hodnota skladu s vysčítanou cenou a množstvím pro import

Popis

Hodnoty skladu s vysčítanou cenou a množstvím pro import

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
mt04id | C(6) | Sklad | Identifikace umístění skladové evidence | Identifikace umístění skladové evidence
mt03mn | N(20,4) | Množství | Množství artiklu v umístění | Množství artiklu v umístění
mt03cena | N(20,4) | Celková cena | Celková cena artiklu v umístění | Celková cena artiklu v umístění

Indexy

Název | Primární | Výraz | Popis
ix_MTUDAX_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id


Tabulky MZ...

MZAH | Aktuální hodnota mezd
MZARTIKL | Artikl mezd
MZCHARAK | Charakter vlastnosti
MZCHARPP | Charaktery pracovníka v prac. poměru
MZDANHLA | Hlavička daňových tabulek
MZDANPOL | Položky daňové tabulky
MZDANTAB |
MZDAVHLA | Popis verzí daňových tabulek
MZDLD | Výkazy - řádky
MZDLIST | Mzdový list
MZDLP | Položky výkazů
MZDLTYPR | Číselník typů řádků
MZDOPPOL | Doplnění mzdové položky
MZDOTAZ | Hromadný speciální dotaz při běhu výpočtu
MZDOTPRI | Druhy speciálních testů výpočtu při běhu výpočtu
MZDOVNAR | Evidence dovolených - nároky a čerpání - stav
MZDRUCET | Účet a strana k druhu události
MZDRUHUD | Druh události
MZFPD | Fond pracovní doby - po měsících
MZFPDD | Fond pracovní doby - po dnech
MZKALEN | Kalendář má
MZKARADA | Pracovník v kategorii
MZKARADD | Kategorie pracovníka
MZKARADP | Pracovník v kategorii - pohled
MZKARHIS | Historie karet pracovníků
MZKAROSO | Vztah mezi pracovníkem a příslušnou osobou
MZKAROSP | Platnost vztahu určitého typu mezi pracovníkem a osobou
MZKARTA | Pracovník
MZKZAM | Třída KZAM
MZMZDPOL | Mzdová položka
MZMZDPPV | Pravidelná mzdová položka
MZMZDY | Mzda
MZNDSLOZ | Nemocenská dávka - složení
MZNEMDAV | Nemocenská dávka
MZNEMOC | Nemoc
MZNEZDPO | Položky nezdanit. nebo srážky
MZORGJED | Organizační jednotka - číselník
MZOSOBA | Tabulka osob nějakým způsobem vázaných k pracovníkovi
MZOSOBNI | Osobní údaje ke kartě pracovníka
MZPAALGN | Parametry nepřítomností - Algoritmus stanovení dávky
MZPADAVK | Parametry nepřítomností - stanovení dávky
MZPADVZH | Parametry nepřítomností - DVZ hlavička
MZPADVZP | Parametry nepřítomností - DVZ intervaly
MZPALETA | Paleta barev kategorií pracovníků
MZPALKAT | Barva kategorie pracovníka v paletě barev
MZPAPLAT | Parametry nepřítomností - platnost v období
MZPARAM | Parametry
MZPARNEM | Parametry nepřítomností
MZPAVLGN | Popis verzí algoritmu stanovení dávky
MZPERAH | Aktuální hodnoty personalistiky
MZPERART | Artikly personalistiky
MZPERS1 | Druhy požadavků a vlastností
MZPERS2 | Hodnoty požadavků a vlastností
MZPERUDA | Událost personalistiky
MZPLATID | Číselník platidel
MZPLSACK | Výčetka platidel pro jednotlivé výplatní sáčky
MZPLSUMA | Sumární výčetka platidel
MZPOJIST | Přehled za pojišťovny za jednotlivé lidi
MZPOJSEZ | Seznam zdravotních pojišťoven
MZPOJSUM | Sumární přehled za pojišťovny
MZPPHIS | Historie prac. poměrů pracovníků
MZPRACFU | Pracovní funkce - skutečné a typové
MZPRACPO | Pracovní poměr
MZPROTAL | Algoritmus výpočtu položky protokolu při výpočtu mezd
MZPROTAU | Užití algoritmu výpočtu položky protokolu při výpočtu mezd
MZPROTHL | Hlavička protokolu
MZPROTOK | Protokol
MZPROTPL | Položky protokolu k hlavičce protokolu
MZPRVTAL | Popis verzí algoritmů protokolu
MZSOCPOJ | Přehled sociálního pojištění za jednotlivé lidi
MZTARSTU | Stupnice zahrnuje
MZTARTRI | Tarifní třída
MZUDALOS | Událostní entita mezd
MZUKOLLI | Úkolové listy
MZUKOLTA | Úkolová mzda tarifní
MZUMIST | Alokace mezd - umístění
MZVSTULI | Vztah mezi záznamem výplatního lístku a mzdovou položkou z karty, nemocenskou dávkou, úkolovým listem
MZVYKAZY | Výkaz
MZVYPMIS | Výplatní místo
MZVZTAHY | Číselník možných vztahů mezi pracovníkem a osobou
MZZALOHY | Záloha vyplacená
MZZDRPOJ | Zdravotní pojišťovny a jejich přidělení

Viz.také

MZAH Aktuální hodnota mezd | MZARTIKL Artikl mezd | MZCHARAK Charakter vlastnosti | MZCHARPP Charaktery pracovníka v prac. poměru | MZDANTAB | MZDLD Výkazy - řádky | MZDLIST Mzdový list | MZDLP Položky výkazů | MZDLTYPR Číselník typů řádků | MZDOPPOL Doplnění mzdové položky | MZDRUCET Účet a strana k druhu události | MZDRUHUD Druh události | MZFPD Fond pracovní doby - po měsících | MZKALEN Kalendář má | MZKARHIS Historie karet pracovníků | MZKARTA Pracovník | MZMZDPOL Mzdová položka | MZMZDPPV Pravidelná mzdová položka | MZMZDY Mzda | MZNEMDAV Nemocenská dávka | MZNEMOC Nemoc | MZNEZDPO Položky nezdanit. nebo srážky | MZORGJED Organizační jednotka - číselník | MZOSOBNI Osobní údaje ke kartě pracovníka | MZPARAM Parametry | MZPARNEM Parametry nepřítomností | MZPERS1 Druhy požadavků a vlastností | MZPERS2 Hodnoty požadavků a vlastností | MZPLATID Číselník platidel | MZPLSACK Výčetka platidel pro jednotlivé výplatní sáčky | MZPLSUMA Sumární výčetka platidel | MZPOJIST Přehled za pojišťovny za jednotlivé lidi | MZPOJSEZ Seznam zdravotních pojišťoven | MZPOJSUM Sumární přehled za pojišťovny | MZPPHIS Historie prac. poměrů pracovníků | MZPRACFU Pracovní funkce - skutečné a typové | MZPRACPO Pracovní poměr | MZPROTOK Protokol | MZSOCPOJ Přehled sociálního pojištění za jednotlivé lidi | MZTARSTU Stupnice zahrnuje | MZTARTRI Tarifní třída | MZUDALOS Událostní entita mezd | MZUKOLLI Úkolové listy | MZUKOLTA Úkolová mzda tarifní | MZUMIST Alokace mezd - umístění | MZVYKAZY Výkaz | MZVYPMIS Výplatní místo | MZZALOHY Záloha vyplacená | MZFPDD Fond pracovní doby - po dnech | MZPERART Artikly personalistiky | MZPERUDA Událost personalistiky | MZZDRPOJ Zdravotní pojišťovny a jejich přidělení | MZPROTHL Hlavička protokolu | MZPROTPL Položky protokolu k hlavičce protokolu | MZNDSLOZ Nemocenská dávka - složení | MZPAALGN Parametry nepřítomností - Algoritmus stanovení dávky | MZPADAVK Parametry nepřítomností - stanovení dávky | MZPADVZH Parametry nepřítomností - DVZ hlavička | MZPADVZP Parametry nepřítomností - DVZ intervaly | MZPAPLAT Parametry nepřítomností - platnost v období | MZPERAH Aktuální hodnoty personalistiky | MZKAROSO Vztah mezi pracovníkem a příslušnou osobou | MZOSOBA Tabulka osob nějakým způsobem vázaných k pracovníkovi | MZDOTAZ Hromadný speciální dotaz při běhu výpočtu | MZVSTULI Vztah mezi záznamem výplatního lístku a mzdovou položkou z karty, nemoc | MZDOTPRI Druhy speciálních testů výpočtu při běhu výpočtu | MZKARADA Pracovník v kategorii | MZKARADD Kategorie pracovníka | MZKARADP Pracovník v kategorii - pohled | MZKAROSP Platnost vztahu určitého typu mezi pracovníkem a osobou | MZPALETA Paleta barev kategorií pracovníků | MZPALKAT Barva kategorie pracovníka v paletě barev | MZVZTAHY Číselník možných vztahů mezi pracovníkem a osobou | MZDOVNAR Evidence dovolených - nároky a čerpání - stav | MZPROTAL Algoritmus výpočtu položky protokolu při výpočtu mezd | MZPROTAU Užití algoritmu výpočtu položky protokolu při výpočtu mezd | MZDANHLA Hlavička daňových tabulek | MZDANPOL Položky daňové tabulky | MZKZAM Třída KZAM | MZDAVHLA Popis verzí daňových tabulek | MZPAVLGN Popis verzí algoritmu stanovení dávky | MZPRVTAL Popis verzí algoritmů protokolu


MZAH Aktuální hodnota mezd

Popis

Aktuální hodnota mezd

Atributy

Atribut | Typ | Návěští | Message | Popis
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
mz28id | C(6) | Mzdová položka | Jednoznačná identifikace mzdové položky | Jednoznačná identifikace mzdové položky
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz79id | C(6) | Umístění | Identifikace umístění mezd | Identifikace umístění mezd
mz41kc | N(16,2) | Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.) | Celková částka v Kč (mzda, daň, srážka, ..., ap.) Aktuální hodnota

Indexy

Název | Primární | Výraz | Popis
ix_MZAH_mzah | P | sp67id, sp06idsubs, mz28id, mz01id, mz79id |
ix_MZAH_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_MZAH_mz28id |  | mz28id | Jednoznačná identifikace mzdové položky
ix_MZAH_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.


MZARTIKL Artikl mezd

Popis

Artikl mezd - pro události mezd, pro úkolové listy

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
mz73koment | M | mz73koment | Komentář - poznámka k artiklu | Komentář - poznámka k artiklu
mz73norma | N(12,2) | Norma | Norma výkonu za časovou jednotku | Norma výkonu za časovou jednotku
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Artikl mezd - je artiklem | MZARTIKL sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Artikl mezd - má technicko věcný selektor | MZARTIKL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Artikl mezd - založil uživatel systému | MZARTIKL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Úkolové listy - mají artikl mezd | MZUKOLLI sp60id sp61id | 1,1 : 0,M | MZARTIKL sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_MZARTIKL_spartikl | P | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_MZARTIKL_sp61id |  | sp61id | Identifikace druhu artiklu
ix_MZARTIKL_sp60id |  | sp60id | Identifikace artiklu
ix_MZARTIKL_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_MZARTIKL_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_MZARTIKL_spartiknx |  |  |


MZDANHLA Hlavička daňových tabulek

Popis

Hlavička daňových tabulek

Atributy

Atribut | Typ | Návěští | Message | Popis
mza7id | C(6) | Identifikace | Identifikace daňové tabulky | Identifikace daňové tabulky
mza7popis | C(40) | Popis | Popis |
mza7koment | M | Komentář | Komentář | Komentář
mza7druhtb | N(1,0) | Druh | Druh tabulky | Druh tabulky
mza7verze | N(8,3) | Verze | Verze daňových tabulek |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis verzí daňových tabulek - je popisem verze daňových tabulek | MZDAVHLA mza7id | 1,1 : 0,M | MZDANHLA mza7id |

Indexy

Název | Primární | Výraz | Popis
ix_MZDANHLA_mza7id | P | mza7id | Identifikace daňové tabulky
ix_MZDANHLA_mza7popis |  | mza7popis |
ix_MZDANHLA_mza7verze |  | mza7verze |


MZDANPOL Položky daňové tabulky

Atributy

Atribut | Typ | Návěští | Message | Popis
mza7id | C(6) | Identifikace | Identifikace daňové tabulky | Identifikace daňové tabulky
mza8dolhra | N(8,0) | Od | Dolní hranice | Dolní hranice
mza8horhra | N(8,0) | do | Horní hranice | Horní hranice
mza8pevcas | N(8,0) | Pevná část | Pevná část | Pevná část
mza8sazba | N(3,0) | Sazba v % | Sazba v % | Sazba v %
mza8typdan | N(1,0) | Typ vzniklé daně | Typ vzniklé daně | Typ vzniklé daně. Typ mzdové položky, které uplatněním této daně vznikne.
mza8platod | D | Platnost od | Platnost od | Platnost od

Indexy

Název | Primární | Výraz | Popis
ix_MZDANPOL_mza7id |  | mza7id | Identifikace daňové tabulky
ix_MZDANPOL_mza8dolhra |  | mza8dolhra | Dolní hranice
ix_MZDANPOL_mza8horhra |  | mza8horhra | Horní hranice
ix_MZDANPOL_mza8platod |  | mza8platod | Platnost od
ix_MZDANPOL_mzdanpol | P | mza7id, mza8platod, mza8dolhra |


MZDANTAB

Popis

Objektem typu MZDANTAB je každý záznam, který obsahuje roční sazbu daně ze závislé činnosti.
Systém obsahuje pouze roční daňovou tabulku. Pro zálohovou srážku se horní, dolní hranice a pevná část počítají dělením dvanácti.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz21 | C(12) | mz21 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
mz21dolhra | N(8,0) | Od Kč | Od Kč | Dolní hranice příjmu, pro který platí uvedená sazba
mz21horhra | N(8,0) | Do Kč | Do Kč | Horní hranice příjmu, pro který platí uvedená sazba
mz21pevcas | N(8,0) | Pevná část | Pevná část | Základní (pevná) část daně
mz21sazba | N(3,0) | Sazba v % | Sazba v % | Procentická sazba dle zákona.
mz21druhta | N(1,0) | mz21druhta | Druh tabulky - měsíční, roční | Atribut slouží pouze k filtrování záznamů podle toho, s jakou tabulkou chce uživatel pracovat.
mz21rok | C(4) | Rok platnosti údaje | Platnost údaje v daňové tabulce - rok | Platnost údaje v daňové tabulce - rok

Indexy

Název | Primární | Výraz | Popis
ix_MZDANTAB_mz21 | P | mz21 | Jednoznačná časová identifikace
ix_MZDANTAB_mz21dolhra |  | mz21dolhra | Dolní hranice příjmu, pro který platí uvedená sazba
ix_MZDANTAB_mz21horhra |  | mz21horhra | Horní hranice příjmu, pro který platí uvedená sazba
ix_MZDANTAB_mz21pevcas |  | mz21pevcas | Základní (pevná) část daně
ix_MZDANTAB_mz21sazba |  | mz21sazba | Procentická sazba dle zákona.
ix_MZDANTAB_mz21rok |  | mz21rok | Platnost údaje v daňové tabulce - rok
ix_MZDANTAB_mzdantab1 |  | mz21rok, mz21dolhra |


MZDAVHLA Popis verzí daňových tabulek

Popis

Popis verzí daňových tabulek

Atributy

Atribut | Typ | Návěští | Message | Popis
mza7id | C(6) | Identifikace | Identifikace daňové tabulky | Identifikace daňové tabulky
mza7verze | N(8,3) | Verze | Verze daňových tabulek |
mzb0dne | D | Dne | Datum záznamu o verzi | Datum záznamu o verzi
sp00jmeakt | C(40) | Změnil | Jméno uživatele systému, který změnil záznam | Jméno uživatele systému, který změnil záznam
mzb0koment | M | Popis | Popis verze | Popis verze
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis verzí daňových tabulek - je popisem verze daňových tabulek | MZDAVHLA mza7id | 1,1 : 0,M | MZDANHLA mza7id |

Indexy

Název | Primární | Výraz | Popis
ix_MZDAVHLA_mzdavhla | P | mza7id, mza7verze |
ix_MZDAVHLA_mza7id |  | mza7id | Identifikace daňové tabulky


MZDLD Výkazy - řádky

Popis

Objektem typu MZDLD je každý záznam, který obsahuje ...

Atributy

Atribut | Typ | Návěští | Message | Popis
mz50id | N(4,0) | Řádek | Číslo řádku | Číslo řádku
mz50nazev | C(40) | Popis | Popis řádku | Popis řádku
mz50tisk | N(1,0) | mz50tisk | Tisknout ano/ne? | Tisknout ano/ne?
mz51typ | C(1) | mz51typ | Typ řádku | Typ řádku
mz49id | C(6) | Identifikace | Identifikace výkazu | Identifikace výkazu
mz50koment | M | mz50koment | Komentář | Komentář
mz50nulovy | N(1,0) | Vytvářet nulový řádek ? | Vytvářet nulový řádek ? Má být řádek vytvořen i v případě, že jeho hodnoty jsou v celém roce nula ? | Vytvářet nulový řádek ? Má být řádek vytvořen i v případě, že jeho hodnoty jsou v celém roce nula ?

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Výkazy - řádky - obsahuje typ řádku | MZDLD mz51typ | 1,1 : 0,M | MZDLTYPR mz51typ |
Výkazy - řádky - odpovídají výkazu ze seznamu výkazů | MZDLD mz49id | 1,1 : 0,M s rušením | MZVYKAZY mz49id |
Položky výkazů - odpovídají řádku | MZDLP mz49id mz50id | 1,1 : 0,M s rušením | MZDLD mz49id mz50id |

Indexy

Název | Primární | Výraz | Popis
ix_MZDLD_mz50id |  | mz50id | Číslo řádku
ix_MZDLD_mz50nazev |  | mz50nazev | Popis řádku
ix_MZDLD_mz51typ |  | mz51typ | Typ řádku
ix_MZDLD_mz49id |  | mz49id | Identifikace výkazu
ix_MZDLD_mzdlist1 |  | mz49id, mz50id | mz49id+mz50id
ix_MZDLD_mzdld1 | P | mz49id, mz50id | mz49id+mz50id


MZDLIST Mzdový list

Atributy

Atribut | Typ | Návěští | Message | Popis
mz53 | C(12) | JČI | Jednoznačná časová identifikace | Jednoznačná časová identifikace
mz53rok | C(4) | Rok | Rok | Rok zpracování výkazu
mz49id | C(6) | Identifikace | Identifikace výkazu | Identifikace výkazu
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz32cispp | C(2) | Číslo p.p. | Číslo pracovního poměru | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
mz32druh | N(1,0) | Druh | Druh pracovního poměru | Výčet druhů pracovních poměrů. Pro výpočet mezd nemá žádný význam.
mz32skonpp | D | Skončení p.p. | Skončení prac. poměru | Skončení prac. poměru Po skončení prac. poměru lze mzdu vyplácet, ale do mezd se nepřenáší pravidelné příjmy, nezdanitelné položky, půjčky ani srážky. Nemocenské dávky lze vyplácet.
mz32vznipp | D | Vznik p.p. | Vznik prac. poměru | Vznik prac. poměru
mz50id | N(4,0) | Řádek | Číslo řádku | Číslo řádku
mz53leden | N(14,2) | Leden | Lednová hodnota řádku | Lednová hodnota řádku
mz53unor | N(14,2) | Únor | Únorová hodnota řádku | Únorová hodnota řádku
mz53brezen | N(14,2) | Březen | Březnová hodnota řádku | Březnová hodnota řádku
mz53duben | N(14,2) | Duben | Dubnová hodnota řádku | Dubnová hodnota řádku
mz53kveten | N(14,2) | Květen | Květnová hodnota řádku | Květnová hodnota řádku
mz53cerven | N(14,2) | Červen | Červnová hodnota řádku | Červnová hodnota řádku
mz53cervec | N(14,2) | Červenec | Červencová hodnota řádku | Červencová hodnota řádku
mz53srpen | N(14,2) | Srpen | Srpnová hodnota řádku | Srpnová hodnota řádku
mz53zari | N(14,2) | Září | Záříjová hodnota řádku | Záříjová hodnota řádku
mz53rijen | N(14,2) | Říjen | Říjnová hodnota řádku | Říjnová hodnota řádku
mz53listop | N(14,2) | Listopad | Listopadová hodnota řádku | listopadová hodnota řádku
mz53prosin | N(14,2) | Prosinec | Prosincová hodnota řádku | Prosincová hodnota řádku

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Mzdový list - odpovídá výkazu | MZDLIST mz49id | 1,1 : 0,1 s rušením | MZVYKAZY mz49id |
Mzdový list - odpovídá nějakému pracovníkovi | MZDLIST mz01id | 1,1 : 0,1 s rušením | MZKARTA mz01id |
Mzdový list - má pracovní poměr | MZDLIST mz01id mz32cispp | 1,1 : 0,1 | MZPRACPO mz01id mz32cispp |

Indexy

Název | Primární | Výraz | Popis
ix_MZDLIST_mz53 | P | mz53 | Jednoznačná časová identifikace
ix_MZDLIST_mz49id |  | mz49id | Identifikace výkazu
ix_MZDLIST_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZDLIST_mz32cispp |  | mz32cispp | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
ix_MZDLIST_mz50id |  | mz50id | Číslo řádku
ix_MZDLIST_mzdlist1 |  | mz49id, mz50id | mz49id+mz50id
ix_MZDLIST_mzdlist2 |  | mz01id, mz32cispp, mz50id | mz01id+mz32cispp+mz50id
ix_MZDLIST_mzpracpo1 |  | mz01id, mz32cispp | mz01id + mz32cispp


MZDLP Položky výkazů

Popis

Objektem typu MZDLP je každý záznam, který obsahuje

Atributy

Atribut | Typ | Návěští | Message | Popis
mz52 | C(12) | JČI | Jednoznačná časová identifikace | Jednoznačná časová identifikace
mz50id | N(4,0) | Řádek | Číslo řádku | Číslo řádku
mz52ident | N(1,0) | Identifikace | Identifikace | Identifikace
mz28id | C(6) | Mzdová položka | Jednoznačná identifikace mzdové položky | Jednoznačná identifikace mzdové položky
mz52radek | N(5,0) | mz52radek | Číslo řádku | Číslo řádku (Rad2)
mz52oper | N(1,0) | Operace | Identifikace operace | Identifikace operace
mz49id | C(6) | Identifikace | Identifikace výkazu | Identifikace výkazu
mz52popis | C(40) | Popis | Název řádku uvedeného jako složka jiného řádku | Název řádku uvedeného jako složka jiného řádku

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Položky výkazů - mají mzdovou položku | MZDLP mz28id | 0,1 : 0,M | MZMZDPOL mz28id |
Položky výkazů - odpovídají řádku | MZDLP mz49id mz50id | 1,1 : 0,M s rušením | MZDLD mz49id mz50id |

Indexy

Název | Primární | Výraz | Popis
ix_MZDLP_mz52 | P | mz52 | Jednoznačná časová identifikace
ix_MZDLP_mz50id |  | mz50id | Číslo řádku
ix_MZDLP_mz28id |  | mz28id | Jednoznačná identifikace mzdové položky
ix_MZDLP_mz52radek |  | mz52radek | Číslo řádku (Rad2)
ix_MZDLP_mz49id |  | mz49id | Identifikace výkazu
ix_MZDLP_mzdld1 |  | mz49id, mz50id | mz49id+mz50id


MZDLTYPR Číselník typů řádků

Popis

Objektem typu MZDLTYPR je každý záznam, který obsahuje ...

Atributy

Atribut | Typ | Návěští | Message | Popis
mz51typ | C(1) | Identifikace | Typ řádku | Typ řádku
mz51popis | C(55) | Popis | Popis řádku | Popis řádku
mz51typ2 | N(1,0) | Typ | Atribut řádku - vlastnost | Atribut řádku - vlastnost

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Výkazy - řádky - obsahuje typ řádku | MZDLD mz51typ | 1,1 : 0,M | MZDLTYPR mz51typ |

Indexy

Název | Primární | Výraz | Popis
ix_MZDLTYPR_mz51typ | P | mz51typ | Typ řádku
ix_MZDLTYPR_mz51popis |  | mz51popis | Popis řádku


MZDOPPOL Doplnění mzdové položky

Popis

Objektem typu MZDOPPOL je každý záznam, který obsahuje doplňující údaje ke mzdovým položkám.
Doplňující údaje říkají, jak bude položka daněna, jestli z ní bude počítán odvod na soc. a zdrav. poj. ap.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz29id | C(6) | Identifikace | Jednoznačná identifikace doplňující položky mezd | Jednoznačná identifikace doplňující položky mezd
mz29popis | C(40) | Popis | Popis doplňující položky mezd | Popis doplňující položky mezd
mz29hodi | N(1,0) | mz29hodi | Hodiny jsou součástí FPD. Odpracované hodiny, které se mají porovnávat proti FPD vymezenému kalendářem. | Hodiny jsou součástí FPD - A/N Zaškrtnutí Ano znamená: 1). Pokud má pracovník nějaké pravidelné příjmy, u kterých je příznak mz35hodiny = Dopočíst do FPD, Při výpočtu mezd 2). Hodiny v záznamech se při výpočtu mezd sčítají a jejich suma se porovná s hodnotou ve fondu pracovní doby pracovníka pro daný měsíc. Pokud je rozdíl, zapíše se upozornění do protokolu.
mz29hodi2 | N(1,0) | mz29hodi2 | Hodiny započítávat pro nárok na pohyblivou složku měsíční | Má-li pracovník pravidelný příjem mz35hodiny = Součet odpracovaných, pak se hodiny tohoto záznamu dopočtou jako součet hodin příjmů, které mají nastaven tento příznak na Ano. Použije se např. v situacích, kdy je prémie vyplácena v závislosti na množství vykonaných prací určitého druhu.
mz29zaklsp | N(1,0) | Základ s.p. | Příjem je součástí základu sociálního pojištění | Příjem je součástí základu sociálního pojištění.
mz29zaklzp | N(1,0) | Základ pro zdravotní pojištění | Příjem je součástí základu zdravotního pojištění | Příjem je součástí základu zdravotního pojištění.
mz29zdanpr | N(1,0) | Zdanitelný příjem | Příjem podléhá dani | Zdanitelný příjem
mz29npdny | N(1,0) | mz29npdny | Dny odečíst od vyměřovacího základu pro nem. pojištění | Dny odečíst od vyměřovacího základu pro nem. pojištění
mz29hpkc | N(1,0) | mz29hpkc | Kč zahrnout do hrubého příjmu | Kč zahrnout do HP je standardní varianta pro všechny příjmy a náhrady. Nezahrnout se použije v případě, kdy uživatel potřebuje z hlediska výpočtu průměrů na náhrady rozpustit příjem dosažený za delší období do několika po sobě jdoucích čtvrtletí. Jednotlivé záznamy mají příznak nezahrnout do HP.
mz29prhkc | N(1,0) | mz29prhkc | Kč a hodiny zahrnout do průměru | Kč a hodiny zahrnout do průměru
mz29dovole | N(1,0) | mz29dovole | Dovolená - ovlivňuje čerpání dovolené | Dovolená
mz29predpn | N(4,1) | mz29predpn | Dovolená - předpokládaný nárok | Dovolená - předpokládaný nárok
mz29skutn | N(4,1) | mz29skutn | Dovolená - skutečný nárok | Dovolená - skutečný nárok
mz29dovpre | N(1,0) | mz29dovpre | Dovolená - převést do dalšího roku |
mz29celoro | N(1,0) | Celoroční charakter | Rozpočítat celoroční položku do průměrů na jednotlivá čtvrtlení ? | Rozpočítat položku do průměrů na jednotlivá čtvrtlení - Ano/Ne Použije se u celoročních odměn (např. vánoční prémie), při výpočtu průměrů na další čtvrtletí se vždy započte čtvrtina odměny. Pokud dá pracovník výpověď dřív, než skončí rok (tj. poslední čtvrtletí), pak se zbytek odměny do průměrů neuplatní.
mz29pulroc | N(1,0) | mz29pulroc | Rozpočítat půlroční položku do průměrů na dvě čtvrtlení ? | Rozpočítat položku do průměrů na dvě čtvrtlení - Ano/Ne Použije se u půlročních odměn (např. půlroční prémie), při výpočtu průměrů na další čtvrtletí se vždy započte polovina odměny. Pokud dá pracovník výpověď dřív, než skončí rok (tj. poslední čtvrtletí), pak se zbytek odměny do průměrů neuplatní.
mz40id | C(6) | Druh události | Identifikace účetní události | Identifikace účetní události
mz29prhod | N(1,0) | mz29prhod | Hodiny zahrnout do průměru | Hodiny zahrnout do průměru
mz29prkc | N(1,0) | mz29prkc | Kč zahrnout do průměru | Kč zahrnout do průměru
mz29prden | N(1,0) | mz29prden | Dny zahrnout do průměru | Dny zahrnout do průměru
mz29rozpoc | N(1,0) | mz29rozpoc | Rozpočítat položku do průměrů na x měsíců ? | Rozpočítat položku do průměrů na x měsíců ? Ano/Ne Použije se u odměn (např. vánoční prémie), při výpočtu průměrů na další čtvrtletí se vždy započte jen část odměny. Pokud dá pracovník výpověď dřív, než skončí rok (tj. poslední čtvrtletí), pak se zbytek odměny do průměrů neuplatní.
mz29mesicu | N(2,0) | na počet měsíců | Počet měsíců rozpočítávané odměny. | Počet měsíců, na které se má rozpočítávat odměna. Souvisí s atributem mz29rozpoc.
mz29mincst | N(1,0) | mz29mincst | Částku zahrnout pro účely srovnání s minimální mzdou | Částku zahrnout pro účely srovnání s minimální mzdou
mz29minhod | N(1,0) | mz29minhod | Hodiny zahrnout pro účely srovnání s minimální mzdou | Hodiny zahrnout pro účely srovnání s minimální mzdou
mz29dpp | N(1,0) | mz29dpp | Dohoda o provedení práce | Dohoda o provedení práce - zaškrtne se u mzdových položek, kterými se výpklácí odměna za dohodu o provedení práce.
mz29zakpoj | N(1,0) | mz29zakpoj | Položka se zahrnuje do výpočtu zákonného pojištění odpovědnosti. |
mz29koment | M | Komentář | Komentář | Komentář

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Doplnění mzdové položky - může mít druh účetní události | MZDOPPOL mz40id | 0,1 : 0,M | MZDRUHUD mz40id |
Mzdová položka - má doplňující údaje | MZMZDPOL mz29id | 0,1 : 0,M | MZDOPPOL mz29id |
Mzda - obsahuje doplňující údaje | MZMZDY mz29id | 0,1 : 0,M | MZDOPPOL mz29id |

Indexy

Název | Primární | Výraz | Popis
ix_MZDOPPOL_mz29id | P | mz29id | Jednoznačná identifikace doplňující položky mezd
ix_MZDOPPOL_mz29popis |  | mz29popis | Popis doplňující položky mezd
ix_MZDOPPOL_mz40id |  | mz40id | Identifikace účetní události
ix_MZDOPPOL_mzdoppol1 |  | mz29id, mz40id | mz29id+mz40id


MZDOTAZ Hromadný speciální dotaz při běhu výpočtu

Popis

Hromadný speciální dotaz při běhu výpočtu. Při běhu výpočtu zapíši seznam pracovníků se speciální vlastností a podle rozhodnutí v této tabulce pokračuji ve výpočtu danným způsobem.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz32cispp | C(2) | Číslo p.p. | Číslo pracovního poměru | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
mz08duvod | C(6) | Důvod | Důvod dotazu | Důvod dotazu - druh dotazu
mz08typdot | C(6) | Typ hlášení v protokolu | Typ dotazu (koresponduje se záznamem v Protokolu) | Typ dotazu (koresponduje se záznamem v Protokolu)
mz08dotaz | M | Dotaz | Dotaz - znění | Dotaz - znění
mz08koment | M | Komentář | Komentář | Komentář
mz08odpov | N(1,0) | Odpověď | Odpověď | Odpověď
mz08platny | N(1,0) | Platný | Záznam je platný v aktuálním výpočtu | Záznam je platný v aktuálním výpočtu
mz08cislo1 | N(20,2) | Číslo 1 | Číselná hodnota |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Hromadný speciální dotaz při běhu výpočtu - mají pracovníka | MZDOTAZ mz01id | 1,1 : 0,M | MZKARTA mz01id |
Hromadný speciální dotaz při běhu výpočtu - musí mít svůj druh | MZDOTAZ mz08duvod | 1,1 : 0,M | MZDOTPRI mz08duvod |

Indexy

Název | Primární | Výraz | Popis
ix_MZDOTAZ_mzdotaz | P | mz01id, mz32cispp, mz08duvod |
ix_MZDOTAZ_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZDOTAZ_mz32cispp |  | mz32cispp | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
ix_MZDOTAZ_mz08duvod |  | mz08duvod | Důvod dotazu - druh dotazu
ix_MZDOTAZ_mz08typdot |  | mz08typdot | Typ dotazu (koresponduje se záznamem v Protokolu)
ix_MZDOTAZ_mz08odpov |  | mz08odpov | Odpověď
ix_MZDOTAZ_mz08platny |  | mz08platny | Záznam je platný v aktuálním výpočtu
ix_MZDOTAZ_mzdotprix |  |  |
ix_MZDOTAZ_mzdotaz2 |  |  | MZDOTPRIX + mz01id
ix_MZDOTAZ_mzdotaz3 |  |  |


MZDOTPRI Druhy speciálních testů výpočtu při běhu výpočtu

Popis

Druhy speciálních testů výpočtu při běhu výpočtu.
Číselník druhů testů s jejich prioritami.
Souvisí s tabulkou MZDOTAZ.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz19prior | N(3,0) | Priorita | Priorita | Priorita
mz08duvod | C(6) | Důvod | Důvod dotazu | Důvod dotazu - druh dotazu
mz19popis | M | Popis | Popisný text dotazu | Popisný text dotazu
mz19koment | M | Komentář | Komentář | Komentář

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Hromadný speciální dotaz při běhu výpočtu - musí mít svůj druh | MZDOTAZ mz08duvod | 1,1 : 0,M | MZDOTPRI mz08duvod |

Indexy

Název | Primární | Výraz | Popis
ix_MZDOTPRI_mz08duvod | P | mz08duvod | Důvod dotazu - druh dotazu


MZDOVNAR Evidence dovolených - nároky a čerpání - stav

Popis

Evidence dovolených - nároky a čerpání - stav
Na základě událostí se vyhodnotí stav předpokládaného nároku, skutečného nároku a čerpání dovolené.

Atributy

Atribut | Typ | Návěští | Message | Popis
mza5predpn | N(20,4) | Předpokládaný nárok | Předpokládaný nárok | Předpokládaný nárok
mza5skutn | N(20,4) | Skutečný nárok | Skutečný nárok | Skutečný nárok
mza5dovole | N(20,4) | Čerpáno v měsíci | Čerpáno dovolené v daném měsíci | Čerpáno dovolené
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz32cispp | C(2) | Číslo p.p. | Číslo pracovního poměru | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
mz02rok | C(4) | Rok | Rok zpracování mezd | Rok zpracování mezd
mz02mesic | C(2) | Měsíc | Měsíc zpracování mezd | Měsíc zpracování mezd
mza5 | C(10) | mza5 | Časová identifikace | Časová identifikace
mza5odprac | N(20,2) | mza5odprac | Odpracováno dnů | Odpracováno dnů
mza5cerpz | N(20,4) | Čerpáno od počátku | Čerpáno od počátku roku nebo od vzniku prac. poměru | Čerpáno od počátku roku nebo od vzniku prac. poměru

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Evidence dovolených - nároky a čerpání - stav - odpovídá pracovníkovi | MZDOVNAR mz01id | 1,1 : 0,M | MZKARTA mz01id |

Indexy

Název | Primární | Výraz | Popis
ix_MZDOVNAR_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZDOVNAR_mz32cispp |  | mz32cispp | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
ix_MZDOVNAR_mz02rok |  | mz02rok | Rok zpracování mezd
ix_MZDOVNAR_mz02mesic |  | mz02mesic | Měsíc zpracování mezd
ix_MZDOVNAR_mzdovnar | P | mz01id, mz32cispp, mz02rok, mz02mesic, mza5 |
ix_MZDOVNAR_mzdovnar1 |  | mz02rok, mz02mesic |


MZDRUCET Účet a strana k druhu události

Popis

Účet a strana k druhu události

Atributy

Atribut | Typ | Návěští | Message | Popis
mz40id | C(6) | Druh události | Identifikace účetní události | Identifikace účetní události
uc01id | C(9) | Účet | Identifikátor účtu účetnictví | Identifikátor účtu
uc01strana | N(1,0) | uc01strana | Strana účtu MD/Dal | Strana účtu MD/Dal
mz69 | C(12) | JČI | Jednoznačná časová identifikace | Jednoznačná časová identifikace
mz72id | C(20) | mz72id | Charakter vlastnosti | Charakter vlastnosti
mz69procen | N(6,2) | Procento uplatnění | Procento uplatnění (max. 100%) |
mz69ucet | N(1,0) | Platné pro účetnictví | Bude řádek přecházet do účetnictví? | Bude řádek přecházet do účetnictví?
mz69platby | N(1,0) | Platné pro platby | Bude řádek přecházet do plateb ? | Bude řádek přecházet do plateb ?
mz69stat | N(1,0) | Platné pro statistiku | Bude řádek přecházet do statistiky? | Bude řádek přecházet do statistiky?
mz69ostat | N(1,0) | Platné pro ostatní | Bude řádek přecházet dotypu ostatní? | Bude řádek přecházet dotypu ostatní?

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Účet a strana k druhu události - odpovídá druhu události | MZDRUCET mz40id | 1,1 : 1,M s rušením | MZDRUHUD mz40id |
Účet a strana k druhu události - váže na účtový rozvrh | MZDRUCET uc01id | 0,1 : 0,M | UCROZVRH uc01id |
Účet a strana k druhu události - se vážou k vlastnosti prac. poměru | MZDRUCET mz72id | 1,1 : 0,M | MZCHARAK mz72id |

Indexy

Název | Primární | Výraz | Popis
ix_MZDRUCET_mz40id |  | mz40id | Identifikace účetní události
ix_MZDRUCET_uc01id |  | uc01id | Identifikátor účtu
ix_MZDRUCET_uc01strana |  | uc01strana | Strana účtu MD/Dal
ix_MZDRUCET_mz69 |  | mz69 | Jednoznačná časová identifikace
ix_MZDRUCET_mzdrucet1 | P | mz40id, mz69 | mz40id+mz69
ix_MZDRUCET_mz72id |  | mz72id | Charakter vlastnosti


MZDRUHUD Druh události

Atributy

Atribut | Typ | Návěští | Message | Popis
mz40id | C(6) | Druh události | Identifikace účetní události | Identifikace účetní události
mz40popis | C(40) | Popis | Popis účetní události | Popis účetní události
mz40koment | M | Komentář | Komentář - poznámka | Komentář - poznámka
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
mz40ucet | N(1,0) | Do účetnictví | Příznak, zda daný typ události bude přecházet do účetnictví | Příznak, zda daný typ události bude přecházet do účetnictví
mz40platby | N(1,0) | Do plateb | Příznak, zda daný typ události bude přecházet do plateb | Příznak, zda daný typ události bude přecházet do plateb
mz40statis | N(1,0) | Do statistiky | Příznak, zda daný typ události bude přecházet do statistiky | Příznak, zda daný typ události bude přecházet do statistiky
mz40ostat | N(1,0) | Ostatní | Příznak, zda daný typ události bude přecházet jako ostatní | Příznak, zda daný typ události bude přecházet do událostí mezd jako ostatní

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh události - vytvořena uživatelem | MZDRUHUD bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Mzdová položka - může mít druh události | MZMZDPOL mz40id | 0,1 : 0,M | MZDRUHUD mz40id |
Doplnění mzdové položky - může mít druh účetní události | MZDOPPOL mz40id | 0,1 : 0,M | MZDRUHUD mz40id |
Účet a strana k druhu události - odpovídá druhu události | MZDRUCET mz40id | 1,1 : 1,M s rušením | MZDRUHUD mz40id |

Indexy

Název | Primární | Výraz | Popis
ix_MZDRUHUD_mz40id | P | mz40id | Identifikace účetní události
ix_MZDRUHUD_mz40popis |  | mz40popis | Popis účetní události
ix_MZDRUHUD_bw01uziv |  | bw01uziv | Identifikace uživatele systému


MZFPD Fond pracovní doby - po měsících

Popis

Objektem typu MZFPD je každý záznam, který obsahuje měsíční údaje o fondu pracovní doby.
Na FPD se při výpočtu mezd porovnává, zda má pracovník zadán plný počet hodin.
Po zadání mzdových položek (dovolená, nemoc,...), lze podle FPD dopočítávat hodiny implicitní práce do plně odpracované doby v měsíci.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz25id | C(6) | Identifikace | Jednoznačná identifikace kalendáře | Jednoznačná identifikace kalendáře
mz26mesic | C(2) | Měsíc | Měsíc | Měsíc
mz26rok | C(4) | Rok | Rok platnosti |
mz26hodin | N(20,2) | Hodin | Pracovních hodin v měsíci | Pracovních hodin v měsíci
mz26dnu | N(20,2) | Dnů v měsíci | Počet pracovních dnů v měsíci. |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Fond pracovní doby - po měsících - odpovídá kalendáři | MZFPD mz25id | 1,1 : 0,M s rušením | MZKALEN mz25id |

Indexy

Název | Primární | Výraz | Popis
ix_MZFPD_mz25id |  | mz25id | Jednoznačná identifikace kalendáře
ix_MZFPD_mz26mesic |  | mz26mesic | Měsíc
ix_MZFPD_mz26rok |  | mz26rok |
ix_MZFPD_mzfpd1 | P | mz25id, mz26mesic, mz26rok | mz25id + mz26mesic


MZFPDD Fond pracovní doby - po dnech

Popis

Objektem typu MZFPDD je každý záznam, který obsahuje denní údaje o fondu pracovní doby.
Na FPD se při výpočtu mezd porovnává, zda má pracovník zadán plný počet hodin.
Po zadání mzdových položek (dovolená, nemoc,...), lze podle FPD dopočítávat hodiny implicitní práce do plně odpracované doby v měsíci.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz25id | C(6) | Identifikace | Jednoznačná identifikace kalendáře | Jednoznačná identifikace kalendáře
mz85datum | D | Datum | Datum | Datum
mz85typ | N(1,0) | Typ dne | Typ dne | Typ dne
mz85popis | C(40) | Popis | Popis | Popis
mz85koment | M | Komentář | Komentář | Komentář
mz85hod | N(5,2) | Hodin ve dni | FPD - počet hodin, které přísluší tomuto dni | FPD - počet hodin, které přísluší tomuto dni Souvisí s nastavením typu kalendáře. (MZKALEN.mz25typhd)
mz85den | N(1,0) | mz85den | Den v týdnu |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Fond pracovní doby - po dnech - odpovídá kalendáři | MZFPDD mz25id | 1,1 : 0,M s rušením | MZKALEN mz25id |

Indexy

Název | Primární | Výraz | Popis
ix_MZFPDD_mz25id |  | mz25id | Jednoznačná identifikace kalendáře
ix_MZFPDD_mz85datum |  | mz85datum | Datum
ix_MZFPDD_mz85typ |  | mz85typ | Typ dne
ix_MZFPDD_mzfpd2 | P | mz25id, mz85datum |


MZCHARAK Charakter vlastnosti

Atributy

Atribut | Typ | Návěští | Message | Popis
mz72id | C(20) | Vlastnost | Charakter vlastnosti | Charakter vlastnosti
mz72koment | M | Komentář | Komentář | Komentář

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Účet a strana k druhu události - se vážou k vlastnosti prac. poměru | MZDRUCET mz72id | 1,1 : 0,M | MZCHARAK mz72id |
Charaktery pracovníka v prac. poměru - jsou v číselníku charakterů | MZCHARPP mz72id | 1,1 : 0,M | MZCHARAK mz72id |

Indexy

Název | Primární | Výraz | Popis
ix_MZCHARAK_mz72id | P | mz72id | Charakter vlastnosti


MZCHARPP Charaktery pracovníka v prac. poměru

Atributy

Atribut | Typ | Návěští | Message | Popis
mz71 | C(12) | JČI | Jednoznačná časová identifikace | Jednoznačná časová identifikace
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz32cispp | C(2) | Číslo p.p. | Číslo pracovního poměru | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
mz72id | C(20) | Charakter | Charakter vlastnosti | Charakter vlastnosti

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Charaktery pracovníka v prac. poměru - jsou v číselníku charakterů | MZCHARPP mz72id | 1,1 : 0,M | MZCHARAK mz72id |
Charaktery pracovníka v prac. poměru - odpovídají prac. poměru pracovníka | MZCHARPP mz01id mz32cispp | 1,1 : 0,M s rušením | MZPRACPO mz01id mz32cispp |

Indexy

Název | Primární | Výraz | Popis
ix_MZCHARPP_mz71 | P | mz71 | Jednoznačná časová identifikace
ix_MZCHARPP_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZCHARPP_mz72id |  | mz72id | Charakter vlastnosti
ix_MZCHARPP_mzpracpo1 |  | mz01id, mz32cispp | mz01id + mz32cispp


MZKALEN Kalendář má

Popis

Objektem typu MZKALEN je každý záznam, který obsahuje popis kalendáře pracovní doby.
Na kalendář pracovní doby váže fond pracovní doby (MZFPD, MZFPDD).
Jeden kalendář obsahuje fond pracovní doby pro jeden rok po jednotlivých měsících nebo po jednotlivých dnech.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz25id | C(6) | Identifikace | Jednoznačná identifikace kalendáře | Jednoznačná identifikace kalendáře
mz25kalen | C(40) | Kalendář | Název kalendáře | Název kalendáře
mz25hodden | N(5,2) | Hod / den | Pracovní doba hodin / den | Pracovní doba hodin / den Touto dobou se při výpočtu nového kalendáře násobí počet pracovních dnů v měsíci. Tím se automaticky počítá počet pracovních hodin v jednotlivých měsících v roce.
mz25koment | M | Komentář | Komentář | Komentář
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
mz25typhd | N(1,0) | Typ denního kalendáře | Typ denního kalendáře. Neplatí pro měsíční kalendáře. Zjištění hodin FPD v každém dni. | Typ denního kalendáře. Zjištění hodin FPD v každém dni. Neplatí pro měsíční kalendáře. Hodnoty - Pravidelná pracovní doba,Zvlášť ke každému dni

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Kalendář má - je zapsán uživatelem | MZKALEN bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Fond pracovní doby - po dnech - odpovídá kalendáři | MZFPDD mz25id | 1,1 : 0,M s rušením | MZKALEN mz25id |
Fond pracovní doby - po měsících - odpovídá kalendáři | MZFPD mz25id | 1,1 : 0,M s rušením | MZKALEN mz25id |
Pracovní funkce - skutečné a typové - má kalendář | MZPRACFU mz25id | 1,1 : 0,M | MZKALEN mz25id |
Pracovní poměr - má kalendář | MZPRACPO mz25id | 1,1 : 0,M | MZKALEN mz25id |

Indexy

Název | Primární | Výraz | Popis
ix_MZKALEN_mz25id | P | mz25id | Jednoznačná identifikace kalendáře
ix_MZKALEN_mz25kalen |  | mz25kalen | Název kalendáře


MZKARADA Pracovník v kategorii

Popis

Objektem typu MZKARADA je každý záznam, který obsahuje základní údaje o kategorii pracovníka.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz09datod | D | Platnost od | Platné od data | Platné od data
mz16id | C(6) | Kategorie | Identifikace kategorie pracovníka | Identifikace kategorie pracovníka
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
mz09ucel | N(1,0) | Účel | Účel (důvod, typ) vztahu pracovníka k adresátovi |
mz09popis | C(40) | Popis | Popis vztahu pracovníka k adresátovi |
mz09koment | M | Komentář | Komentář |
mz09stav | N(1,0) | Stav | Stav - Zahajuje platnost/Ukončuje platnost | Platnost - Zahajuje platnost nebo Ukončuje platnost

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Pracovník v kategorii - patří pracovníkovi | MZKARADA mz01id | 1,1 : 0,M | MZKARTA mz01id |
Pracovník v kategorii - patří k spojení adresáta | MZKARADA ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Pracovník v kategorii - je druhu | MZKARADA mz16id | 1,1 : 0,M | MZKARADD mz16id |

Indexy

Název | Primární | Výraz | Popis
ix_MZKARADA_mzkarad1 | P | mz01id, mz09datod, mz16id |
ix_MZKARADA_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZKARADA_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_MZKARADA_ad01id |  | ad01id | Identifikace adresáta
ix_MZKARADA_ad11cisspo |  | ad11cisspo | Číslo spojení adresáta. Program generuje automaticky.
ix_MZKARADA_mz09ucel |  | mz09ucel |
ix_MZKARADA_mz09datod |  | mz09datod | Platné od data
ix_MZKARADA_mz16id |  | mz16id | Identifikace kategorie pracovníka


MZKARADD Kategorie pracovníka

Popis

Kategorie pracovníka

Atributy

Atribut | Typ | Návěští | Message | Popis
mz16id | C(6) | Kategorie | Identifikace kategorie pracovníka | Identifikace kategorie pracovníka
mz16popdru | C(40) | Název kategorie | Název kategorie pracovníka | Popis kategorie pracovníka
mz16ucel | N(2,0) | Účel | Účel (důvod, typ) kategorie pracovníka | Účel (důvod, typ) kategorie pracovníka
mz16koment | M | Poznámka | Poznámka | Poznámka
mz16typ | N(1,0) | Typ | Typ kategorie - Vstupovaná / Vypočítaná | Typ kategorie - Vstupovaná / Vypočítaná
mz16sql | M | SQL | Výraz v SQL vyhodnocovaný dotazem vracející numerickou hodnotu (0=není v kategoriii) použivá ID pracovníka @mz01id | Výraz v SQL vyhodnocovaný dotazem vracející numerickou hodnotu (0=není v kategoriii) použivá ID pracovníka @mz01id

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Pracovník v kategorii - je druhu | MZKARADA mz16id | 1,1 : 0,M | MZKARADD mz16id |
Barva kategorie pracovníka v paletě barev - je určena pro kategorii | MZPALKAT mz16id | 1,1 : 0,M | MZKARADD mz16id |

Indexy

Název | Primární | Výraz | Popis
ix_MZKARADD_mz16id | P | mz16id | Identifikace kategorie pracovníka
ix_MZKARADD_mz16popdru |  | mz16popdru | Popis kategorie pracovníka


MZKARADP Pracovník v kategorii - pohled

Popis

Pracovník v kategorii - pohled

Atributy

Atribut | Typ | Návěští | Message | Popis
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz09datod | D | Platnost od | Platné od data | Platné od data
mz16id | C(6) | Kategorie | Identifikace kategorie pracovníka | Identifikace kategorie pracovníka
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
mz09popis | C(40) | Popis | Popis vztahu pracovníka k adresátovi |
mz09koment | M | Komentář | Komentář |
ad01adsat | C(100) | ad01adsat | Název adresáta | Název adresáta. *** Dříve NAZEV1.
ad02ulice | C(40) | Ulice | Ulice adresy adresáta (včetně čísla popisného). | Ulice adresy adresáta (včetně čísla popisného). *** Dříve ULICE.
ad02mesto | C(40) | ad02mesto | Město adresy adresáta. | Město adresy adresáta.
ad13psc | C(10) | PSČ | Poštovní směrovací číslo adresy adresáta. | Poštovní směrovací číslo adresy adresáta. *** Dříve PSC.
ad05id | C(3) | Stát | Identifikace státu. | Identifikace státu. *** Dříve ZIP.
ad02cisadr | C(2) | Adresa | Číslo adresy adresáta. | Číslo adresy adresáta. Program generuje automaticky. *** Dříve CISADR. C,1 !!!
ad05koment | M | ad05koment |  |
ad01ico | C(10) | IČO | Identifikační číslo organizace. | Identifikační číslo organizace. *** Dříve ICO.
ad01dico | C(16) | DIČ | Daňové identifikační číslo adresáta. | Daňové identifikační číslo adresáta. *** Dříve ICDP.
mz16ucel | N(2,0) | Účel | Účel (důvod, typ) kategorie pracovníka | Účel (důvod, typ) kategorie pracovníka

Indexy

Název | Primární | Výraz | Popis
ix_MZKARADP_mzkarad1 |  | mz01id, mz09datod, mz16id |


MZKARHIS Historie karet pracovníků

Popis

Objektem typu MZKARHISe každý záznam, který obsahuje základní zpětné (historické) údaje o pracovníkovi.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz44 | C(12) | Jednoznačná časová identifikace | Jednoznačná časová identifikace | Jednoznačná časová identifikace
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz01prijme | C(50) | Příjmení | Příjmení pracovníka | Příjmení pracovníka
mz01jmeno | C(50) | Jméno | Jméno pracovníka | Jméno pracovníka
mz01titul | C(15) | Titul | Titul pracovníka (před jménem) | Titul pracovníka (před jménem)
mz01zdravp | N(1,0) | Zdravotní pojištění | Zdravotní pojištění | Sledovat minimální základ při výpočtu zdravotního pojištění? Sledovat - nejběžnější varianta Nesledovat - pracovník zastává veřejnou funkci,... Plátcem je stát - důchodce, žena na mateřské dovolené,...
mz01prohla | N(1,0) | Podepsal prohlášení | Podepsal pracovník daňové prohlášení? | Když =Ano, při výpočtu mezd se uplatní uvedené nezdanitelné částky. Když = Ne, neuplatní se uvedené nezdanitelné částky a mzda může být daněna zvláštní sazbou daně ($6,odst.4.), nebo zálohově, nejméně 20 % (38h,odst. 3.)
mz01srazet | N(1,0) | Lze srážet | Lze u pracovníka uplatnit srážkovou daň? | Srážkovou daň nelze uplatnit Příjmy nelze danit srážkovou daní v případě, kdy je práce vykonávána členem družstva, společníkem s.r.o. nebo jde o odměny člena statutárního orgánu.
mz01roczuc | N(1,0) | mz01roczuc | Provést roční zúčtování ? | Provést roční zúčtování ? Pracovníkovi lze zaškrtnout pouze v měsících leden - březen. Uzávěrkou mezd se tento příznak ruší. Progam nehlídá opakované zaškrtnutí (např. v lednu i v únoru).
mz22id | C(6) | Identifikace | Jednoznačná identifikace výplatního místa | Jednoznačná identifikace výplatního místa
mz70idp | C(3) | Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,... | Identifikace pojišťovny, např. 111, 121 ,...
mza7id | C(6) | Identifikace | Identifikace daňové tabulky | Identifikace daňové tabulky
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad02cisadr | C(2) | Adresa | Číslo adresy adresáta. | Číslo adresy adresáta. Program generuje automaticky. *** Dříve CISADR. C,1 !!!
ad03cisban | C(2) | Účet | Identifikátor spojení na bankovní účet adresáta. | Číslo spojení na bankovní účet adresáta. *** Dříve CISBANK.
mz44rok | C(4) | mz44rok | Rok zpracováných mezd | Rok zpracováných mezd
mz44mesic | C(2) | mz44mesic | Měsíc zpracováných mezd | Měsíc zpracováných mezd
mz44zpnapo | N(20,2) | ZP vyměř. základy nápočet | Nápočet dosavadních vyměřovacích základů ZP v aktuálním roce pro porovnání s maximálním vyměřovacím základem ZP. | Nápočet dosavadních vyměřovacích základů ZP v aktuálním roce pro porovnání s maximálním vyměřovacím základem ZP.
mz44spnapo | N(20,2) | SP vyměř. základy nápočet | Nápočet dosavadních vyměřovacích základů SP v aktuálním roce pro porovnání s maximálním vyměřovacím základem SP. | Nápočet dosavadních vyměřovacích základů SP v aktuálním roce pro porovnání s maximálním vyměřovacím základem SP.
mz44pznapo | N(20,2) | Penzij. a život. připojištění nápočet | Nápočet dosavadních příspěvků penzij. a život. pojištění v aktuálním roce pro porovnání s limitem připojištění. | Nápočet dosavadních příspěvků penzij. a život. pojištění v aktuálním roce pro porovnání s limitem připojištění.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Historie karet pracovníků - má výplatní místo | MZKARHIS mz22id | 1,1 : 0,M | MZVYPMIS mz22id |

Indexy

Název | Primární | Výraz | Popis
ix_MZKARHIS_mz44 | P | mz44 | Jednoznačná časová identifikace
ix_MZKARHIS_mz01prijme |  | mz01prijme | Příjmení pracovníka
ix_MZKARHIS_mz01jmeno |  | mz01jmeno | Jméno pracovníka
ix_MZKARHIS_mz22id |  | mz22id | Jednoznačná identifikace výplatního místa
ix_MZKARHIS_mz70idp |  | mz70idp | Identifikace pojišťovny, např. 111, 121 ,...
ix_MZKARHIS_ad01id |  | ad01id | Identifikace adresáta
ix_MZKARHIS_ad02cisadr |  | ad02cisadr | Číslo adresy adresáta. Program generuje automaticky.
ix_MZKARHIS_ad03cisban |  | ad03cisban | Číslo spojení na bankovní účet adresáta.
ix_MZKARHIS_mzkarhis1 |  | mz44rok, mz44mesic, mz01id | mz44rok+mz44mesic+mz01id
ix_MZKARHIS_mzkarhis2 |  | mz01prijme, mz01jmeno | příjmení + jméno
ix_MZKARHIS_mzkarhis3 |  | mz44rok, mz44mesic, mz01prijme, mz01jmeno | mz44rok+mz44mesic+příjmení+jméno
ix_MZKARHIS_mzkarhis4 |  | mz44rok, mz44mesic, mz22id | mz44rok+mz44mesic+mz22id


MZKAROSO Vztah mezi pracovníkem a příslušnou osobou

Popis

Objektem typu MZKAROSO je každý záznam, který obsahuje základní údaje o vztahu pracovníkova a příslušné osoby.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz05id | C(6) | Identifikace | Identifikace osoby | Identifikace osoby
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz06koment | M | Komnetář | Komnetář | Komnetář
mz06vztah | N(1,0) | Vztah | Vztah mezi pracovníkem a osobou | Vztah mezi pracovníkem a osobou

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vztah mezi pracovníkem a příslušnou osobou - patří pracovníkovi | MZKAROSO mz01id | 1,1 : 0,M | MZKARTA mz01id |
Vztah mezi pracovníkem a příslušnou osobou - patří k osobě | MZKAROSO mz05id | 1,1 : 0,M | MZOSOBA mz05id |
Platnost vztahu určitého typu mezi pracovníkem a osobou - odpovídá vztahu mezi pracovníkem a osobou | MZKAROSP mz01id mz05id | 1,1 : 0,M s rušením | MZKAROSO mz01id mz05id |

Indexy

Název | Primární | Výraz | Popis
ix_MZKAROSO_mz05id |  | mz05id | Identifikace osoby
ix_MZKAROSO_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZKAROSO_mzkaros1 | P | mz01id, mz05id | mz01id+mz05id


MZKAROSP Platnost vztahu určitého typu mezi pracovníkem a osobou

Popis

Objektem typu MZKAROSP je každý záznam, který obsahuje údaje o platnosti vztahu pracovníka a příslušné osoby.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz05id | C(6) | Identifikace | Identifikace osoby | Identifikace osoby
mza1id | C(6) | Identifikace | Identifikace vztahu |
mza2oddata | D | Od | Platnost od |
mza2dodata | D | do | Platnost do |
mza2koment | M | Komentář | Komentář |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Platnost vztahu určitého typu mezi pracovníkem a osobou - obsahuje číselník možných vztahů | MZKAROSP mza1id | 1,1 : 0,M | MZVZTAHY mza1id |
Platnost vztahu určitého typu mezi pracovníkem a osobou - odpovídá vztahu mezi pracovníkem a osobou | MZKAROSP mz01id mz05id | 1,1 : 0,M s rušením | MZKAROSO mz01id mz05id |

Indexy

Název | Primární | Výraz | Popis
ix_MZKAROSP_mzkarosp1 | P | mz01id, mz05id, mza1id, mza2oddata |
ix_MZKAROSP_mzkaros1 |  | mz01id, mz05id | mz01id+mz05id
ix_MZKAROSP_mza1id |  | mza1id |


MZKARTA Pracovník

Popis

Objektem typu MZKARTA je každý záznam, který obsahuje základní údaje o pracovníkovi.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz01 | C(12) | mz01 | Jednoznačná časová identifikace | Jednoznačná časová identifikace Je tady kvůli propojení pracovníka na dokumenty. Pracovník musí být objekt.
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz01idext | C(20) | Externí identifikace | Externí identifikace pracovníka | Externí identifikace pracovníka
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad02cisadr | C(2) | Adresa | Číslo adresy adresáta. | Číslo adresy adresáta. Program generuje automaticky. *** Dříve CISADR. C,1 !!!
mz01prijme | C(50) | Příjmení | Příjmení pracovníka | Příjmení pracovníka
mz01jmeno | C(50) | Jméno | Jméno pracovníka | Jméno pracovníka
mz01titul | C(15) | Titul | Titul pracovníka (před jménem) | Titul pracovníka (před jménem)
mz01titul2 | C(15) | Titul za | Titul pracovníka (za jménem) | Titul pracovníka (za jménem)
mz01zdravp | N(1,0) | Zdravotní pojištění | Zdravotní pojištění | Sledovat minimální základ při výpočtu zdravotního pojištění? Sledovat - nejběžnější varianta Nesledovat - pracovník zastává veřejnou funkci,... Plátcem je stát - důchodce, žena na mateřské dovolené,...
mz01prohla | N(1,0) | Podepsal prohlášení | Podepsal pracovník daňové prohlášení? | Když =Ano, při výpočtu mezd se uplatní uvedené nezdanitelné částky. Když = Ne, neuplatní se uvedené nezdanitelné částky a mzda může být daněna zvláštní sazbou daně ($6,odst.4.), nebo zálohově, nejméně 20 % (38h,odst. 3.)
mz01srazet | N(1,0) | Lze srážet | Lze u pracovníka uplatnit srážkovou daň? | Srážkovou daň nelze uplatnit Příjmy nelze danit srážkovou daní v případě, kdy je práce vykonávána členem družstva, společníkem s.r.o. nebo jde o odměny člena statutárního orgánu.
mza7id | C(6) | Identifikace | Identifikace daňové tabulky | Identifikace daňové tabulky
mz22id | C(6) | Identifikace | Jednoznačná identifikace výplatního místa | Jednoznačná identifikace výplatního místa
mz01roczuc | N(1,0) | mz01roczuc | Provést roční zúčtování ? | Provést roční zúčtování ? Pracovníkovi lze zaškrtnout pouze v měsících leden - březen. Uzávěrkou mezd se tento příznak ruší. Progam nehlídá opakované zaškrtnutí (např. v lednu i v únoru).
mz01koment | M | Komentář | Komentář - poznámka | Komentář - poznámka k pracovníkovi
mz70idp | C(3) | Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,... | Identifikace pojišťovny, např. 111, 121 ,...
mz01rodne | C(15) | Rodné příjmení | Rodné příjmení | Rodné příjmení
mz01prijpr | M | Další příjmení | Další příjmení - předcházející k současnému příjmení | Další příjmení - předcházející k současnému příjmení
mz01rodc | C(11) | Rodné číslo | Rodné číslo | Rodné číslo
mz01naroz | D | Datum narození | Datum narození | Datum narození
mz01cislop | C(20) | Číslo OP | Číslo občanského průkazu | Číslo občanského průkazu
mz01misnar | C(40) | mz01misnar | Místo narození | Místo narození
mz01obcan | M | Státní občanství | Státní občanství | Státní občanství
mz01stav | N(1,0) | mz01stav | Stav - svobodný/á,ženatý,vdaná,vdovec,vdova,rozvedený/á | Stav - svobodný/á,ženatý,vdaná,vdovec,vdova,rozvedený/á
mz01muzena | N(1,0) | Žena/muž | Žena, muž | Žena/muž
mz01deti | N(2,0) | Počet dětí | Počet dětí | Počet dětí
mz01duchty | N(1,0) | Typ důchodu | Typ důchodu | Typ důchodu
mz01duchda | D | Datum přiznání | Datum přiznání důchodu, pracovník dovršil důchodový věk | Datum přiznání důchodu
mz01duchkc | N(5,0) | Částka | Důchod - částka | Důchod - částka
ad05id | C(3) | Stát | Identifikace státu. | Identifikace státu. *** Dříve ZIP.
mz01ztp | N(1,0) | Těžce ZTP | Těžce ZTP - Ano,Ne | Těžce ZTP - Ano , Ne
mz01zpnapo | N(20,2) | ZP vyměř. základy nápočet | Nápočet dosavadních vyměřovacích základů ZP v aktuálním roce pro porovnání s maximálním vyměřovacím základem ZP. | Nápočet dosavadních vyměřovacích základů ZP v aktuálním roce pro porovnání s maximálním vyměřovacím základem ZP.
mz01spnapo | N(20,2) | SP vyměř. základy nápočet | Nápočet dosavadních vyměřovacích základů SP v aktuálním roce pro porovnání s maximálním vyměřovacím základem SP. | Nápočet dosavadních vyměřovacích základů SP v aktuálním roce pro porovnání s maximálním vyměřovacím základem SP.
mz01pznapo | N(20,2) | Penzij. a život. připojištění nápočet | Nápočet dosavadních příspěvků penzij. a život. pojištění v aktuálním roce pro porovnání s limitem připojištění. | Nápočet dosavadních příspěvků penzij. a život. pojištění v aktuálním roce pro porovnání s limitem připojištění.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Pracovník - má výplatní místo | MZKARTA mz22id | 1,1 : 0,M | MZVYPMIS mz22id |
Pracovník - má zdravotní pojišťovnu | MZKARTA mz70idp | 1,1 : 0,M | MZPOJSEZ mz70idp |
Pracovník - má adresu - bydliště | MZKARTA ad01id ad02cisadr | 0,1 : 0,M | ADADR ad01id ad02cisadr |
Pracovník - je uveden v adresáři | MZKARTA ad01id | 0,1 : 0,M | ADADSAT ad01id |
Pracovník - má státní příslušnost | MZKARTA ad05id | 1,1 : 0,M | ADSTATY ad05id |
Osobní údaje ke kartě pracovníka - patří ke kartě pracovníka | MZOSOBNI mz01id | 1,1 : 0,M s rušením | MZKARTA mz01id |
Pracovník obsluhy výrobní linky/stroje ve směně s profesí - určuje pracovníka | TPLINKAP mz01id | 1,1 : 0,M s rušením | MZKARTA mz01id |
Zdravotní pojišťovny a jejich přidělení - patří pracovníkovi | MZZDRPOJ mz01id | 1,1 : 0,M | MZKARTA mz01id |
Položky protokolu k hlavičce protokolu - mají pracovníka | MZPROTPL mz01id | 1,1 : 0,M | MZKARTA mz01id |
Vztah mezi pracovníkem a příslušnou osobou - patří pracovníkovi | MZKAROSO mz01id | 1,1 : 0,M | MZKARTA mz01id |
Hromadný speciální dotaz při běhu výpočtu - mají pracovníka | MZDOTAZ mz01id | 1,1 : 0,M | MZKARTA mz01id |
Pracovník v kategorii - patří pracovníkovi | MZKARADA mz01id | 1,1 : 0,M | MZKARTA mz01id |
Evidence dovolených - nároky a čerpání - stav - odpovídá pracovníkovi | MZDOVNAR mz01id | 1,1 : 0,M | MZKARTA mz01id |
Pracovní poměr - odpovídá pracovníkovi | MZPRACPO mz01id | 1,1 : 0,M s rušením | MZKARTA mz01id |
Mzda - patří pracovníkovi | MZMZDY mz01id | 1,1 : 0,M s rušením | MZKARTA mz01id |
Pravidelná mzdová položka - patří pracovníkovi | MZMZDPPV mz01id | 1,1 : 0,M s rušením | MZKARTA mz01id |
Položky nezdanit. nebo srážky - patří pracovníkovi | MZNEZDPO mz01id | 1,1 : 0,M s rušením | MZKARTA mz01id |
Nemocenská dávka - přísluší pracovníkovi | MZNEMDAV mz01id | 1,1 : 0,M | MZKARTA mz01id |
Událostní entita mezd - má pracovníka | MZUDALOS mz01id | 1,1 : 0,M | MZKARTA mz01id |
Mzdový list - odpovídá nějakému pracovníkovi | MZDLIST mz01id | 1,1 : 0,1 s rušením | MZKARTA mz01id |
Záloha vyplacená - pracovníkovi | MZZALOHY mz01id | 1,1 : 0,M s rušením | MZKARTA mz01id |
Výčetka platidel pro jednotlivé výplatní sáčky - odpovídá pracovníkovi | MZPLSACK mz01id | 1,1 : 0,M s rušením | MZKARTA mz01id |
Úkolové listy - patří pracovníkovi | MZUKOLLI mz01id | 1,1 : 0,M s rušením | MZKARTA mz01id |
Přehled za pojišťovny za jednotlivé lidi - odpovídá kartě pracovníka | MZPOJIST mz01id | 1,1 : 0,M | MZKARTA mz01id |
Přehled sociálního pojištění za jednotlivé lidi - odpovídá pracovníkům | MZSOCPOJ mz01id | 1,1 : 0,M | MZKARTA mz01id |
Vstup nebo výstup výrobního úkolu - byl proveden pracovníkem | VRUDOPMA mz01id | 1,1 : 0,M | MZKARTA mz01id |

Indexy

Název | Primární | Výraz | Popis
ix_MZKARTA_mz01 |  | mz01 | Jednoznačná časová identifikace Je tady kvůli propojení pracovníka na dokumenty. Pracovník musí být objekt.
ix_MZKARTA_mz01id | P | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZKARTA_mz01idext |  | mz01idext | Externí identifikace pracovníka
ix_MZKARTA_ad01id |  | ad01id | Identifikace adresáta
ix_MZKARTA_adadr1 |  | ad01id, ad02cisadr | Adresát + číslo adresy Pro zobrazení
ix_MZKARTA_ad02cisadr |  | ad02cisadr | Číslo adresy adresáta. Program generuje automaticky.
ix_MZKARTA_mz01prijme |  | mz01prijme | Příjmení pracovníka
ix_MZKARTA_mza7id |  | mza7id | Identifikace daňové tabulky
ix_MZKARTA_mz22id |  | mz22id | Jednoznačná identifikace výplatního místa
ix_MZKARTA_mzkarta1 |  | mz01prijme, mz01jmeno | mz01prijme + mz01jmeno
ix_MZKARTA_mz70idp |  | mz70idp | Identifikace pojišťovny, např. 111, 121 ,...
ix_MZKARTA_mz01rodc |  | mz01rodc | Rodné číslo
ix_MZKARTA_mz01naroz |  | mz01naroz | Datum narození
ix_MZKARTA_ad05id |  | ad05id | Identifikace státu.
ix_MZKARTA_mz01zpnapo |  | mz01zpnapo | Nápočet dosavadních vyměřovacích základů ZP v aktuálním roce pro porovnání s maximálním vyměřovacím základem ZP.
ix_MZKARTA_mz01spnapo |  | mz01spnapo | Nápočet dosavadních vyměřovacích základů SP v aktuálním roce pro porovnání s maximálním vyměřovacím základem SP.
ix_MZKARTA_mz01pznapo |  | mz01pznapo | Nápočet dosavadních příspěvků penzij. a život. pojištění v aktuálním roce pro porovnání s limitem připojištění.


MZKZAM Třída KZAM

Popis

Číselník KZAM - klasifikace zaměstnání

Atributy

Atribut | Typ | Návěští | Message | Popis
mza6id | C(5) | Identifikace | Identifikace třídy KZAM | Identifikace třídy KZAM
mza6popis | C(40) | Popis | Popis třídy KZAM | Popis třídy KZAM
mza6koment | M | Komentář | Komentář | Komentář

Indexy

Název | Primární | Výraz | Popis
ix_MZKZAM_mza6id | P | mza6id | Identifikace třídy KZAM
ix_MZKZAM_mza6popis |  | mza6popis | Popis třídy KZAM


MZMZDPOL Mzdová položka

Popis

Objektem typu MZMZDPOL je každý záznam, který obsahuje mzdovou položku.
Mzdové položky jsou všechny položky, které lze použít na výplatním lístku (příjmy, náhrady mezd, odvody, ....).

Atributy

Atribut | Typ | Návěští | Message | Popis
mz28id | C(6) | Mzdová položka | Jednoznačná identifikace mzdové položky | Jednoznačná identifikace mzdové položky
mz28mzdpol | C(40) | Popis | Popis mzdové položky | Popis mzdové položky
mz28druh | N(1,0) | Druh | Druh položky - příjem, náhrada mzdy,... | Druh položky - příjem, náhrada mzdy,... Tuto položku plní program, uživatel ji nemá možnost měnit!
mz28puvod | N(1,0) | Původ Kč / j | Původ Kč / j | Původ Kč za jednotku: Zadaná částka = Do Kč / j se přenese hodnota uvedená u příjmu, nebo u pravidelného příjmu na kartě pracovníka. Hodnota na kartě má přednost před hodnotou uvedenou u příjmu!!! Dle tarifu prac. = Do Kč / j se přenese hodnota uvedená v tarifu tarifní stupnice, které má uvedeny pracovník Úkolová dle tar. prac. = Do Kč / j se přenese hodnota uvedená v tarifu tarifní stupnice, které jsou uvedeny u daného příjmu a souhlasí se stupnicí a tarifem přiznaných pracovníkovi Vyšší ze zadaná částka -tarif prac. Vyšší ze zadaná částka - úkolová dle tar. prac. Hod.průměr = Do Kč / j se přenese hodnota uvedená na kartě pracovníka Den.průměr = Do Kč / j se přenese hodnota uvedená na kartě pracovníka Měs.průměr = Do Kč / j se přenese hodnota uvedená na kartě pracovníka
mz28kc_j | N(15,2) | Kč / j | Kč / j | Korun za jednotku (výkonu, hodin,...)
mz28koef | N(8,4) | Koeficient | Koeficient, jímž se násobí Kč / j | Koeficient, jímž se vždy násobí Kč / j při výpočtu Kč.
mz28vypoc | N(1,0) | Výpočet Kč | Způsob výpočtu celkové částky Kč | Způsob výpočtu je uveden v Picture. POZOR - Celková částka (Kč) se počítá podle uvedeného vzorce, který je navíc vždy násoben koeficientem. To není v Picture uvedeno kvůli nedostatku místa.
mz28hotove | N(1,0) | Vyplatit v penězích | Vyplácet částku (Kč) v hotovosti | Vyplácet částku (Kč) v hotovosti
mz29id | C(6) | Identifikace | Jednoznačná identifikace doplňující položky mezd | Jednoznačná identifikace doplňující položky mezd
mz28koment | M | Komentář | Komentář |
mz28tisk | N(1,0) | Tisknout | Položka bude/nebude tisknuta na výplatním lístku | Položka bude/nebude tisknuta na výplatním lístku
mz28pdruh1 | N(1,0) | Poddruh1 | Hrubý příjem,Čistý příjem,K výplatě | Hrubý příjem vyplácený,Hrubý příjem nevyplácený,Hrubý příjem celkem,Čistý příjem,K výplatě
mz28pdruh2 | N(2,0) | Poddruh2 | Základ s.p.,Odvod s.p. zaměst.,Odvod s.p. org.,Základ z.p.,Odvod z.p. zaměst.,Odvod z.p. org.,Základ záloh. daně,Daň zálohová,Zákl. srážk. daně,Daň srážková,Zákl. roč. zúčt. daně,Vyrovnání přepl. na dani | Základ s.p.,Odvod s.p. zaměst.,Odvod s.p. org.,Základ z.p.,Odvod z.p. zaměst.,Odvod z.p. org.,Základ záloh. daně,Daň zálohová,Zákl. srážk. daně,Daň srážková,Zákl. roč. zúčt. daně,Vyrovnání přepl. na dani
mz28pdruh3 | N(1,0) | Poddruh3 | Nemoc v p.d.,Nemoc,Ošetřování v p.d.,Ošetřování,Vyrov. přísp.,Mat. dov.,Mat. dov. v p.d.,Import,Jiná nepřítomnost v p.d.,Jiná nepřítomnost,Rodičovská dovolená v p.d.,Rodičovská dovolená | Nemoc v p.d.,Nemoc,Ošetřování v p.d.,Ošetřování,Vyrov. přísp.,Mat. dov.,Mat. dov. v p.d.,Import,Jiná nepřítomnost v p.d.,Jiná nepřítomnost,Rodičovská dovolená v p.d.,Rodičovská dovolená
mz28pdruh4 | N(2,0) | Poddruh4 | Doplatek ZP zam.,Doplatek SP zam.,Doplatek daně záloh.,Doplatek daně srážk.,Doplatek ZP org.,Doplatek SP org. | Využito u typu odvod. Doplatek ZP zam.,Doplatek SP zam.,Doplatek daně záloh.,Doplatek daně srážk.,Doplatek ZP org.,Doplatek SP org.
mz28pdruh5 | N(1,0) | mz28pdruh5 | Položka měsíční, položka roční (sleva na dani či daňové zvýhodnění) |
mz28pdruh6 | N(1,0) | mz28pdruh6 | Druhy daňových zvýhodnění |
mz28zphra | N(1,0) | Zdrav. poj. hradí | ZP hradí | Zobrazuje se pouze na obrazovce položek neplaceného volna a určuje, kdo bude z neplaceného volna hradit zdravotní pojištění.
mz28spolin | N(1,0) | Poddruh | Částka je společná,částka je individuální | Částka je společná,částka je individuální
mz28hodi | N(1,0) | mz28hodi | Hodiny jsou součástí FPD | Zobrazuje se pouze na obrazovce položek neplaceného volna. Tam má stejný význam, jako mají v doplňujících údajích pro příjmy. (viz.MZDOPPOL, mz29hodi)
mz28srazet | N(2,0) | Srážet | Způsob srážení | Částku srážet,Procento z HP,Vše k výplatě,Procento z ČP(odbory),Částku vyplatit,Procento ze základu SP,Vzorcem,Penzij. poj. s daňovým limitem(jen v 2007),Procento z vyplácen. HP
mz28npdny | N(1,0) | Dny odečíst od vym. z. pro n. p. | Dny odečíst od vyměřovacího základu pro nem. pojištění | Dny odečíst od vyměřovacího základu pro nem. pojištění
mz40id | C(6) | Druh události | Identifikace účetní události | Identifikace účetní události
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
mz28vzorec | M | Vzorec | Vzorec pro zjištění položky Kč_j | Vzorec pro zjištění položky Kč_j, objevuje se pouze, je-li původ 10 (vzorcem)
mz28vzorkf | M | Vzorec | Vzorec pro zjištění položky koeficient | Vzorec pro zjištění položky Koeficient. Pokud není vzorec uveden, platí hodnota uvedená přímo v koeficientu.
mz28nuldnu | N(1,0) | mz28nuldnu | Povoleno nastavení dnů na hodnotu nula. |
mz28nulhod | N(1,0) | mz28nulhod | Povoleno nastavení dnů na hodnotu nula. |
mz28oddata | D | Od data | Datum zahájení platnosti položky. Platnost se bere v potaz při vložení položky na Kartu pracovníka nebo do Výplatního lístku. | Datum zahájení platnosti položky. Platnost se bere v potaz při vložení položky na Kartu pracovníka nebo do Výplatního lístku.
mz28dodata | D | do data | Datum ukončení platnosti položky.Platnost se bere v potaz při vložení položky na Kartu pracovníka nebo do Výplatního lístku. | Datum ukončení platnosti položky. Platnost se bere v potaz při vložení položky na Kartu pracovníka nebo do Výplatního lístku.
mz28priori | N(3,0) | Typ | Priorita mzdové položky. 1 - pohledávky, 2 - srážky na vlastní účet, 3 - pohledávka výživné | Priorita mzdové položky - pro typy srážky, půjčky, exekuce
mz28tretin | N(1,0) | Způsob | Způsob uplatnění exekuční pohledávky | Způsob uplatnění exekuční pohledávky
mz28penziv | N(1,0) | mz28penziv | Započítávat do limitu penzijního a životního připojištění. | Započítávat do limitu penzijního a životního připojištění.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Mzdová položka - zapsána uživatelem | MZMZDPOL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Mzdová položka - má doplňující údaje | MZMZDPOL mz29id | 0,1 : 0,M | MZDOPPOL mz29id |
Mzdová položka - může mít druh události | MZMZDPOL mz40id | 0,1 : 0,M | MZDRUHUD mz40id |
Mzdová položka - má technicko věcný selektor | MZMZDPOL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Parametry nepřítomností - stanovení dávky - mají mzdovou položku | MZPADAVK mz28id | 1,1 : 0,M | MZMZDPOL mz28id |
Úkolová mzda tarifní - souvisí s mzdovou položkou | MZUKOLTA mz28id | 1,1 : 0,M s rušením | MZMZDPOL mz28id |
Mzda - má mzdovou položku | MZMZDY mz28id | 1,1 : 0,M | MZMZDPOL mz28id |
Pravidelná mzdová položka - souvisí s mzdovou položkou | MZMZDPPV mz28id | 1,1 : 0,M | MZMZDPOL mz28id |
Položky nezdanit. nebo srážky - patří pracovníkovi | MZNEZDPO mz28id | 1,1 : 0,M | MZMZDPOL mz28id |
Událostní entita mezd - obsahuje mzdovou položku | MZUDALOS mz28id | 1,1 : 0,M | MZMZDPOL mz28id |
Položky výkazů - mají mzdovou položku | MZDLP mz28id | 0,1 : 0,M | MZMZDPOL mz28id |
Záloha vyplacená - existuje v číselníku mzdových položek | MZZALOHY mz28id | 1,1 : 0,M | MZMZDPOL mz28id |
Úkolové listy - má mzdovou položku | MZUKOLLI mz28id | 1,1 : 0,M | MZMZDPOL mz28id |
Sumární přehled za pojišťovny - odpovídá mzdové položce | MZPOJSUM mz28id | 1,1 : 0,M | MZMZDPOL mz28id |
Přehled za pojišťovny za jednotlivé lidi - odpovídá mzdovým položkám | MZPOJIST mz28id | 1,1 : 0,M | MZMZDPOL mz28id |

Indexy

Název | Primární | Výraz | Popis
ix_MZMZDPOL_mz28id | P | mz28id | Jednoznačná identifikace mzdové položky
ix_MZMZDPOL_mz28mzdpol |  | mz28mzdpol | Popis mzdové položky
ix_MZMZDPOL_mz29id |  | mz29id | Jednoznačná identifikace doplňující položky mezd
ix_MZMZDPOL_mz40id |  | mz40id | Identifikace účetní události
ix_MZMZDPOL_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_MZMZDPOL_mzmzdpol1 |  | mz29id, mz28id |
ix_MZMZDPOL_mzmzdy3 |  | mz28id, mz29id | mz28id+mz29id
ix_MZMZDPOL_mzdoppol1 |  | mz29id, mz40id | mz29id+mz40id
ix_MZMZDPOL_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.


MZMZDPPV Pravidelná mzdová položka

Popis

Objektem typu MZMZDPPV je každý záznam, který obsahuje mzdovou položku pravidelně vyplácenou.
Každému pracovníkovi je možné v souvislosti s jeho konkrétním pracovním poměrem uvádět každý měsíc na výplatním lístku pravidelné mzdové položky. Použije se to např. při jednosložkové (měsíční) mzdě, pravidelně vyplácené měsíční pohyblivé složce, pravidelných srážkách, spožení,...ap.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz35 | C(12) | mz35 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz32cispp C(2) Číslo p.p. Číslo pracovního poměru Číslo pracovního poměru
Při vkládání program generuje automaticky a nelze je opravit.
mz28id | C(6) | Mzdová položka | Jednoznačná identifikace mzdové položky | Jednoznačná identifikace mzdové položky
mz35kc_j N(9,2) Kč / j Kč / j Korun za jednotku (výkonu, hodin,...).

Pokud je zde uvedená nějaká částka, přenáší se na výplatní lístek. Není-li zde uvedena žádná hodnota (Kč / j = 0), přenáší se na výplatní lístek částka uvedená v příjmech. Nebo jinak - částka Kč/j v pravidelných příjmech má přednost před Kč/j v příjmech.
mz35hodiny N(1,0) Hodiny Způsob dopočtu hodin na výplatním lístku. Způsob, jakým se dopočtou hodiny při přenosu na výplatní lístek.

-----------------------------------
Nevyplňovat = hodiny na výplatním lístku zůstanou nevyplněny. Použije se např. u paušálních cestovních náhrad.
-----------------------------------
Dopočíst do FPD = hodiny v přenesením záznamu se vypočtou jako zbytek hodin do plně odpracované doby. Např.:
Pracovník má ve FPD uvedeno, že měsíc má 187,5 hodin.
V pravidelných příjmech má uvedený záznam Měsíční mzda a
Hodiny = Dopočíst do FPD
Kč / j = 15.000,-

Při zadávání mezd zadá mzdová účetní pracovníkovi 5 dnů dovolené, t.j. 42,5 hodiny. Po spuštění výpočtu mezd se na výplatní lístek doplní pravidelna položka Měsíční mzda a její hodiny budou mít uvedeno 187,5 - 42,5 = 145.
Měsíční (jednosložková) mzda bude nejčastějším pravidelným příjmem s tímto nastavením.
Pozn.: Pravidelných příjmů s tímto nastavením může mít pracovník uvedeno více najednou.
-----------------------------------
Součet odpracovaných = hodiny v přeneseném záznamu se doplní součtem hodin již zadaných záznamů bez ohledu na to, zda byly zadány ručně, nebo byly založeny až při výpočtu. Podmínkou je, že mají tyto položky v doplňujících údajích uvedeno Pohyblivá složka měsíční = Ano.

Např.:
V příjmech jsou položky a v doplňujících údajích mají příznak Pohyblivá složka měsíční nastavený tak, jak je uvedeno v závorce:
Dovolená (Ne)
Měsíční mzda (Ano)
Měsíční odměna (Ne)

V pravidelných příjmech má pracovník uvedené záznamy:
Měsíční mzda a
Hodiny = Dopočíst do FPD
Kč / j = 15.000,-

Měsíční odměna (Ne)
Hodiny = Součet odpracovaných
Kč / j = 1.000,-

Při předchozím příkladu se nejprve dopočte měsíční mzda. Po ní se doplní záznam s měsíční odměnou. Počet hodin bude roven hodinám měsíční mzdy, protože ona jediná má v doplňujích údajích nastaven příznak Pohyblivá složka měsíční na Ano.
-----------------------------------
Dopočíst do FPD odděleně ve dnech a v hodinách - atribut hodiny se zjistí s ohledem na FPD, atribut dny se zjistí s ohledem na FPD. Dny a hodiny tedy spolu vůbec nemusí korespondovat.
----------------------------------
Součet odpracovaných odděleně ve dnech a v hodinách - atribut hodiny se zjistí s ohledem na příjmy se zaškrtávátkem hodiny započítávat pro pohyblivou složku měsíční, atribut dny se zjistí s ohledem na příjmy se zaškrtávátkem hodiny započítávat pro pohyblivou složku měsíční. Dny a hodiny tedy spolu vůbec nemusí korespondovat.
----------------------------
mz35oddata | D | Od data | Datum zahájení platnosti položky | Datum zahájení platnosti položky
mz35dodata | D | Do data | Datum ukončení platnosti položky | Datum ukončení platnosti položky
mz35koef | N(8,4) | Indiv. koef. | Individuální koeficient, jímž se násobí Kč / j (je-li 0 použije se koeficient mzdové položky) | Individuální koeficient, jímž se násobí Kč / j

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Pravidelná mzdová položka - patří pracovníkovi | MZMZDPPV mz01id | 1,1 : 0,M s rušením | MZKARTA mz01id |
Pravidelná mzdová položka - patří k pracovnímu poměru pracovníka | MZMZDPPV mz01id mz32cispp | 1,1 : 0,M s rušením | MZPRACPO mz01id mz32cispp |
Pravidelná mzdová položka - souvisí s mzdovou položkou | MZMZDPPV mz28id | 1,1 : 0,M | MZMZDPOL mz28id |

Indexy

Název | Primární | Výraz | Popis
ix_MZMZDPPV_mz35 | P | mz35 | Jednoznačná časová identifikace
ix_MZMZDPPV_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZMZDPPV_mz28id |  | mz28id | Jednoznačná identifikace mzdové položky
ix_MZMZDPPV_mzpracpo1 |  | mz01id, mz32cispp | mz01id + mz32cispp
ix_MZMZDPPV_mzmzdppv1 |  | mz01id, mz32cispp, mz28id | mz01id + mz32cispp + mz28id (pracovník + pracovní poměr + mzdová položka)


MZMZDY Mzda

Popis

Objektem typu MZMZDY je každý záznam, který obsahuje mzdovou položku.
Mzdovými položkami je vše, co se tiskne pracovníkovi na výplatním lístku (příjmy, náhrady mezd, odvody,...ap). Současně jsou mzdovými položkami údaje, které se na výplatním lístku zpravidla netisknou (odvod soc.poj. hrazeného organizací, odvod zdrav.poj. hrazeného organizací,...)

Atributy

Atribut | Typ | Návěští | Message | Popis
mz02 | C(12) | JČI | Jednoznačná časová identifikace | Jednoznačná časová identifikace
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz32cispp | C(2) | Číslo p.p. | Číslo pracovního poměru | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
mz02mesic | C(2) | Měsíc | Měsíc zpracování mezd | Měsíc zpracování mezd
mz02rok | C(4) | Rok | Rok zpracování mezd | Rok zpracování mezd
mz28id | C(6) | Mzdová položka | Jednoznačná identifikace mzdové položky | Jednoznačná identifikace mzdové položky
mz02od | C(5) | Od | Výkon práce od (čas zahájení práce) | Výkon práce od (čas zahájení práce)
mz02do | C(5) | Do | Výkon práce do (čas ukončení práce) | Výkon práce do (čas ukončení práce)
mz02dnu | N(10,2) | Dnů | Počet dnů (výkonu práce, volna, nemoci,...) | Počet dnů (výkonu práce, volna, nemoci,...)
mz02dnukal | N(10,2) | Dnů kalendářních | Počet kalendářních dnů. | Počet kalendářních dnů (neplacené volno)
mz02hodin | N(12,2) | Hodin | Počet hodin (výkonu práce, volna, nemoci,...) | Počet hodin (výkonu práce, volna, nemoci,...)
mz02vykon | N(10,2) | Výkon | Množství vykonané práce při úkolové mzdě | Množství vykonané práce při úkolové mzdě
mz02kc_j | N(20,4) | Kč / j | Kč za jednotku (tarifní sazba za hodinu, sazba za jednotku výkonu,...) | Kč za jednotku (tarifní sazba za hodinu, sazba za jednotku výkonu,...)
mz02koef | N(9,4) | Koef. | Koeficient, kterým se násobí výsledná částka Kč. | Koeficient, kterým se násobí výsledná částka Kč.
mz02hotove | N(1,0) | Vyplatit v penězích | Vyplatit uvedenou částku hotově (nevyplácet = např. nepeněžní dar) | Vyplatit uvedenou částku hotově (nevyplácet = např. nepeněžní dar)
mz29id | C(6) | Identifikace | Jednoznačná identifikace doplňující položky mezd | Jednoznačná identifikace doplňující položky mezd
mz02kc | N(20,2) | Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.) | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
mz02zadano | N(1,0) | Zadáno | Způsob, jakým byl záznam pořízen. | Způsob, jakým byl záznam pořízen. Ručně zadané záznamy lze opravovat. Záznamy vytvořené výpočtem nelze opravovat, ani rušit. Při každém novém výpočtu se tyto záznamy zruší a nově se vypočtou.
mz02tisk | N(1,0) | Tisknout | Tisknout na výplatním lístku (netisknout = pojistné hrazené zaměstnavatelem,...) | Tisknout na výplatním lístku (netisknout = pojistné hrazené zaměstnavatelem,...)
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad03cisban | C(2) | Účet | Identifikátor spojení na bankovní účet adresáta. | Číslo spojení na bankovní účet adresáta. *** Dříve CISBANK.
mz36ksymb | C(4) | KS | Konstantní symbol | Konstantní symbol
mz36vsymb | C(10) | VS | Variabilní symbol | Variabilní symbol
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
mz02pozn | C(40) | Poznámka | Poznámka | Poznámka
mz05id | C(6) | Identifikace | Identifikace osoby | Identifikace osoby
mz02koment | M | Komentář | Poznámka k výpočtu částky | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Mzda - patří pracovníkovi | MZMZDY mz01id | 1,1 : 0,M s rušením | MZKARTA mz01id |
Mzda - z pracovního poměru | MZMZDY mz01id mz32cispp | 1,1 : 0,M | MZPRACPO mz01id mz32cispp |
Mzda - zapsána pracovníkem | MZMZDY bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Mzda - má obchodní selektor | MZMZDY sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Mzda - má orgnizační selektor | MZMZDY sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Mzda - má technicko-věcný selektor | MZMZDY sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Mzda - má mzdovou položku | MZMZDY mz28id | 1,1 : 0,M | MZMZDPOL mz28id |
Mzda - obsahuje doplňující údaje | MZMZDY mz29id | 0,1 : 0,M | MZDOPPOL mz29id |
Mzda - mají bankovní účet | MZMZDY ad01id ad03cisban | 1,1 : 0,M | ADBUCTY ad01id ad03cisban |
Mzda - odvody, srážky a půjčky mají adresáta | MZMZDY ad01id | 1,1 : 0,M | ADADSAT ad01id |
Mzda - souvisí s danou osobou | MZMZDY mz05id | 1,1 : 0,M | MZOSOBA mz05id |
Vztah mezi záznamem výplatního lístku a mzdovou položkou z karty, nemocenskou dávkou, úkolovým listem - ve vztahu k výplatnímu lístku | MZVSTULI mz02 | 1,1 : 0,M s rušením | MZMZDY mz02 |

Indexy

Název | Primární | Výraz | Popis
ix_MZMZDY_mz02 | P | mz02 | Jednoznačná časová identifikace
ix_MZMZDY_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZMZDY_mz32cispp |  | mz32cispp | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
ix_MZMZDY_mz02mesic |  | mz02mesic | Měsíc zpracování mezd
ix_MZMZDY_mz02rok |  | mz02rok | Rok zpracování mezd
ix_MZMZDY_mz28id |  | mz28id | Jednoznačná identifikace mzdové položky
ix_MZMZDY_mz29id |  | mz29id | Jednoznačná identifikace doplňující položky mezd
ix_MZMZDY_mz02kc |  | mz02kc | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
ix_MZMZDY_ad01id |  | ad01id | Identifikace adresáta
ix_MZMZDY_ad03cisban |  | ad03cisban | Číslo spojení na bankovní účet adresáta.
ix_MZMZDY_adbucty1 |  | ad01id, ad03cisban | ad01id+ad03cisban
ix_MZMZDY_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_MZMZDY_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_MZMZDY_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_MZMZDY_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_MZMZDY_mzpracpo1 |  | mz01id, mz32cispp | mz01id + mz32cispp
ix_MZMZDY_mzmzdy1 |  | mz01id, mz32cispp, mz02rok, mz02mesic, mz28id | mz01id + mz32cispp + mz02rok + mz02mesic + mz28id
ix_MZMZDY_mzmzdy2 |  | mz02rok, mz02mesic, mz28id, mz01id | mz02rok+mz02mesic+mz28id+mz01id
ix_MZMZDY_mzmzdy3 |  | mz28id, mz29id | mz28id+mz29id
ix_MZMZDY_mzmzdy4 |  | mz02rok, mz02mesic, mz01id, mz32cispp, sp20idzak | rok+měsíc+pracovník+prac.poměr+TV selektor
ix_MZMZDY_mzmzdy5 |  | mz02rok, mz02mesic, mz01id, mz32cispp, mz28id | rok+měsíc+pracovník+prac.poměr+mzdová položka
ix_MZMZDY_mzmzdyx |  |  |
ix_MZMZDY_mz05id |  | mz05id | Identifikace osoby
ix_MZMZDY_mzmzdyy |  |  |
ix_MZMZDY_mzmzdyz |  |  |


MZNDSLOZ Nemocenská dávka - složení

Popis

Objektem typu MZNDSLOZ je každý záznam, který obsahuje informaci o podrobném složení nemocenské dávky vyplácené za kalendářní měsíc.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz15typ | N(1,0) | Typ | Typ údaje | Typ údaje
mz38 | C(12) | mz38 | Jednoznačná časová identifikace | Jednoznačná časová identifikace.
mz15hodnot | N(10,4) | Hodnota | Hodnota údaje určitého typu | Hodnota údaje určitého typu
mz15odedne | N(3,0) | Ode dne | Platné od pořadového čísla dne | Platné od pořadového čísla dne
mz15pocdnu | N(10,4) | Počet dnů | Počet dnů dávky | Počet dnů dávky

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Nemocenská dávka - složení - odpovídá nemocenské dávce | MZNDSLOZ mz38 | 1,1 : 0,M s rušením | MZNEMDAV mz38 |

Indexy

Název | Primární | Výraz | Popis
ix_MZNDSLOZ_mz15typ |  | mz15typ | Typ údaje
ix_MZNDSLOZ_mz38 |  | mz38 | Jednoznačná časová identifikace.
ix_MZNDSLOZ_mz15hodnot |  | mz15hodnot | Hodnota údaje určitého typu
ix_MZNDSLOZ_mz15odedne |  | mz15odedne | Platné od pořadového čísla dne
ix_MZNDSLOZ_mzndsloz | P | mz38, mz15typ, mz15odedne | mz38+mz15typ+mz15odedne


MZNEMDAV Nemocenská dávka

Popis

Objektem typu MZNEMDAV je každý záznam, který obsahuje informaci o nemocenské dávce vyplácené za kalendářní měsíc.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz38 | C(12) | mz38 | Jednoznačná časová identifikace | Jednoznačná časová identifikace.
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz32cispp | C(2) | Číslo p.p. | Číslo pracovního poměru | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
mz37cisnem | C(3) | Číslo | Pořadové číslo nepřítomnosti / dávky pracovníka | Pořadové číslo nepřítomnosti / dávky pracovníka. Program toto číslo generuje sám.
mz38od | D | Od | Datum, od kterého se poskytuje nemocenská dávka | Datum, od kterého se poskytuje nemocenská dávka
mz38do | D | Do | Datum, do kterého se poskytuje nemocenská dávka | Datum, do kterého se poskytuje nemocenská dávka
mz38dnu | N(8,4) | Dnů kal. | Kalendářní dny, za které se poskytuje nemocenská dávka | Kalendářní dny, za které se poskytuje nemocenská dávka
mz38hod | N(5,2) | mz38hod | Kalendářní hodiny, které se přičtou k uvedeným kal. dnům | Kalendářní hodiny, které se přičtou k uvedeným kal. dnům
mz38dnupra | N(8,4) | z toho prac. | Pracovní dny, za které se poskytuje nemocenská dávka | Pracovní dny, za které se poskytuje nemocenská dávka. Ve mzdách slouží v případech, kdy se počítá s fondem pracovní doby.
mz38hodpra | N(5,2) | mz38hodpra | Pracovní hodiny, které se přičtou k uvedeným pracovním dnům | Pracovní hodiny, které se přičtou k uvedeným pracovním dnům
mz38znamen | N(1,0) | mz38znamen | Znaménko výpočtu dávky | Znaménko výpočtu dávky - souvisí s nastavením v Parametrech
mz38davka | N(6,0) | Dávka Kč | Výše nemocenské dávky | Výše nemocenské dávky
mz38kratit | N(6,2) | Krátit o % | O uvedené procento se krátí nemocenská dávka. | O uvedené procento se krátí nemocenská dávka.
mz38platit | N(1,0) | Proplatit | Proplatit v nejbližším výplatním termínu? | Proplatit v nejbližším výplatním termínu?
mz38propla | D | Proplaceno dne | Datum, ve kterém byla nemocenská dávka vyplacena | Datum, ve kterém byla nemocenská dávka vyplacena
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
mz38ucho2 | N(1,0) | mz38ucho2 | Nepřepisovat dávku nově vypočtenou hodnotou | Nepřepisovat dávku nově vypočtenou hodnotou
mz77id | C(4) | mz77id | Identifikace období platnosti parametrů | Identifikace období platnosti parametrů
mz38zaklad | N(5,0) | mz38zaklad | Základ pro výpočet nemocenské dávky za kalendářní den (redukovaný) | Základ pro výpočet nemocenské dávky za kalendářní den (redukovaný)
mz38dnyns | N(8,4) | mz38dnyns | Počet dnů nemoci proplacených sníženou sazbou | Počet dnů nemoci proplacených sníženou sazbou
mz38dnyhs | N(8,4) | mz38dnyhs | Počet dnů nemoci proplacených horní sazbou | Počet dnů nemoci proplacených horní sazbou
mz38uchok | N(1,0) | mz38uchok | Nepřepisovat kalendářní dny nově vypočtenou hodnotou | Nepřepisovat kalendářní dny nově vypočtenou hodnotou
mz38uchop | N(1,0) | mz38uchop | Nepřepisovat pracovní dny nově vypočtenou hodnotou | Nepřepisovat pracovní dny nově vypočtenou hodnotou
mz38vypdnk | N(8,4) | Kal. dny (do výpočtu) | Kalendářní dny zahrnuté do výpočtu | Kalendářní dny zahrnuté do výpočtu - počet dnů této nemocenské dávky, které již byly zpracovány výpočtem. 0 - dávka ještě neprošla výpočtem
mz38vypdnp | N(8,4) | Prac. dny (do výpočtu) | Pracovní dny zahrnuté do výpočtu | Pracovní dny zahrnuté do výpočtu - počeet dnů této nemocenské dávky, které již byly zpracovány výpočtem. 0 - dávka ještě neprošla výpočtem
mz38vypobd | D | Období (do výpočtu) | Období, ve kterém byla dávka naposledy zahrnuta do výpočtu | Období, ve kterém byla dávka naposledy zahrnuta do výpočtu
mz38vypoce | D | Do výpočtu v | Období, ve kterém bude dávka zahrnuta do výpočtu (prázdné = dle od - do). Ovlivňuje FPD. | Období, ve kterém bude dávka zahrnuta do výpočtu (prázdné = dle od - do). Ovlivňuje FPD.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Nemocenská dávka - zapsána uživatelem | MZNEMDAV bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Nemocenská dávka - má parametry | MZNEMDAV mz77id | 1,1 : 0,M | MZPARNEM mz77id |
Nemocenská dávka - přísluší pracovníkovi | MZNEMDAV mz01id | 1,1 : 0,M | MZKARTA mz01id |
Nemocenská dávka - souvisí s nemocí | MZNEMDAV mz01id mz32cispp mz37cisnem | 1,1 : 0,M | MZNEMOC mz01id mz32cispp mz37cisnem |
Nemocenská dávka - složení - odpovídá nemocenské dávce | MZNDSLOZ mz38 | 1,1 : 0,M s rušením | MZNEMDAV mz38 |

Indexy

Název | Primární | Výraz | Popis
ix_MZNEMDAV_mz38 | P | mz38 | Jednoznačná časová identifikace.
ix_MZNEMDAV_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZNEMDAV_mz32cispp |  | mz32cispp | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
ix_MZNEMDAV_mz37cisnem |  | mz37cisnem | Pořadové číslo nepřítomnosti / dávky pracovníka. Program toto číslo generuje sám.
ix_MZNEMDAV_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_MZNEMDAV_mznemoc1 |  | mz01id, mz32cispp, mz37cisnem | mz01id + mz32cispp + mz37cisnem
ix_MZNEMDAV_mzpracpo1 |  | mz01id, mz32cispp | mz01id + mz32cispp
ix_MZNEMDAV_mz77id |  | mz77id | Identifikace období platnosti parametrů


MZNEMOC Nemoc

Popis

Objektem typu MZNEMOC je každý záznam, který obsahuje informaci o nepřítomnosti pracovníka pro nemoc,....

Atributy

Atribut | Typ | Návěští | Message | Popis
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz32cispp | C(2) | Číslo p.p. | Číslo pracovního poměru | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
mz37cisnem | C(3) | Číslo | Pořadové číslo nepřítomnosti / dávky pracovníka | Pořadové číslo nepřítomnosti / dávky pracovníka. Program toto číslo generuje sám.
mz37legit | C(15) | Legitimace | Číslo legitimace práce neschoopného | Číslo legitimace práce neschopného.
mz37duvod | N(1,0) | Důvod | Důvod nepřítomnosti | Důvod nepřítomnosti
mz37od | D | Od | Datum začátku pracovní neschopnosti | Datum začátku pracovní neschopnosti
mz37do | D | Do | Datum ukončení pracovní neschopnosti | Datum ukončení pracovní neschopnosti
mz37dnu | N(6,0) | Dnů | Kalendářních dnů pracovní neschopnosti | Kalendářních dnů pracovní neschopnosti. Aktualizuje se vždy při uzávěrce mezd.
mz37zaklad | N(3,0) | Základ | Denní vyměřovací základ upravený podle redukčních hranic | Denní vyměřovací základ upravený podle redukčních hranic
mz37zakld | N(9,2) | mz37zakld | Denní vyměřovací základ neredukovaný | Denní vyměřovací základ neredukovaný
mz37kratit | N(6,2) | Krátit o % | O uvedené procento se krátí základ nemocenské dávky. | O uvedené procento se krátí základ nemocenské dávky.
mz37koment | M | Komentář | Komentář | Komentář
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
mz37dunem | N(1,0) | mz37dunem | Důvod-nemoc | Důvod-nemoc
mz37duos | N(1,0) | mz37duos | Důvod - ošetřování | Důvod - ošetřování
mz37duvp | N(1,0) | mz37duvp | Důvod - vyrovnávací příspěvek | Důvod - vyrovnávací příspěvek
mz37dumd | N(1,0) | mz37dumd | Důvod - mateřská dovolená | Důvod - mateřská dovolená
mz37dujn | N(1,0) | mz37dujn | Důvod - jiná nepřítomnost | Důvod - jiná nepřítomnost
mz37durd | N(1,0) | mz37durd | Rodičovská dovolená | Rodičovská dovolená
mz37duost | N(1,0) | mz37duost | Důvod - všechny ostatní důvody | Důvod - všechny ostatní důvody
mz37typnem | N(1,0) | Typ | Typ nemoci | Nic,Nemoc,Úraz,Pracovní úraz
mz37typ | N(1,0) | Typ nemoci | Typ nemoci |
mz37datum | D | mz37datum | Datum porodu (pouze pro důvod mateřská dovolená) | Datum porodu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Nemoc - souvisí s pracovním poměrem | MZNEMOC mz01id mz32cispp | 1,1 : 0,M s rušením | MZPRACPO mz01id mz32cispp |
Nemoc - zapsal uživatel | MZNEMOC bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Nemocenská dávka - souvisí s nemocí | MZNEMDAV mz01id mz32cispp mz37cisnem | 1,1 : 0,M | MZNEMOC mz01id mz32cispp mz37cisnem |

Indexy

Název | Primární | Výraz | Popis
ix_MZNEMOC_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZNEMOC_mz32cispp |  | mz32cispp | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
ix_MZNEMOC_mz37duvod |  | mz37duvod | Důvod nepřítomnosti
ix_MZNEMOC_mz37od |  | mz37od | Datum začátku pracovní neschopnosti
ix_MZNEMOC_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_MZNEMOC_mzpracpo1 |  | mz01id, mz32cispp | mz01id + mz32cispp
ix_MZNEMOC_mznemoc1 | P | mz01id, mz32cispp, mz37cisnem | mz01id + mz32cispp + mz37cisnem
ix_MZNEMOC_mznemoc2 |  | mz01id, mz32cispp, mz37od | mz01id + mz32cispp + mz37od


MZNEZDPO Položky nezdanit. nebo srážky

Popis

Objektem typu MZNEZDPO je každý záznam, který obsahuje vazbu mezi pracovníkem a jeho nezdanitelnými položkami nebo srážkami.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz28id | C(6) | Mzdová položka | Jednoznačná identifikace mzdové položky | Jednoznačná identifikace mzdové položky
mz36 | C(12) | JČI | Jednoznačná časová identifikace | Jednoznačná časová identifikace
mz36kc_j | N(11,2) | Individuální částka | Kč/ j |
mz36zustat | N(11,2) | Zůstatek | Zůstatek půjčky | Zůstatek půjčky
mz36oddata | D | mz36oddata | Datum zahájení platnosti položky | Datum zahájení platnosti položky
mz36dodata | D | Do data | Datum ukončení platnosti položky | Datum ukončení platnosti položky
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad03cisban | C(2) | Účet | Identifikátor spojení na bankovní účet adresáta. | Číslo spojení na bankovní účet adresáta. *** Dříve CISBANK.
mz36ksymb | C(4) | KS | Konstantní symbol | Konstantní symbol
mz36vsymb | C(10) | mz36vsymb | Variabilní symbol | Variabilní symbol
mz36srazet | N(7,0) | Srážet | Kolik Kč se má z výplaty srážet | Kolik Kč se má z výplaty srážet
mz36signal | D | Datum signalizace | Datum signalizace skončení platnosti měsíční nezdanitelné položky |
mz36por_sr | C(3) | Pořadí srážky | Pořadí uplatnění srážky z karty ve výpočtu výplatního lístku | Pořadí uplatnění srážky z karty ve výpočtu výplatního lístku
mz36por_pu | C(3) | Pořadí půjčky | Pořadí uplatnění půjčky z karty ve výpočtu výplatního lístku | Pořadí uplatnění půjčky z karty ve výpočtu výplatního lístku
mz36ztp | N(1,0) | ZTP | Je ZTP - Ano, Ne | Je ZTP - Ano, Ne
mz05id | C(6) | Identifikace | Identifikace osoby | Identifikace osoby
mz36doruce | D | Doručení | Datum doručení pohledávky | Datum doručení pohledávky (pro exekuce a půjčky)
mz36nedopl | N(9,2) | mz36nedopl | Nedoplatek z minulého měsíce (exekuce) | Nedoplatek z minulého měsíce (exekuce)
mz36typ | N(1,0) | Typ | Volný typ | Volný překryvný seznam - pro různé účely
mz36koment | M | Komentář | Komentář |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Položky nezdanit. nebo srážky - patří pracovníkovi | MZNEZDPO mz01id | 1,1 : 0,M s rušením | MZKARTA mz01id |
Položky nezdanit. nebo srážky - patří pracovníkovi | MZNEZDPO mz28id | 1,1 : 0,M | MZMZDPOL mz28id |
Položky nezdanit. nebo srážky - mají bankovní účet | MZNEZDPO ad01id ad03cisban | 1,1 : 0,M | ADBUCTY ad01id ad03cisban |
Položky nezdanit. nebo srážky - mají adresáta | MZNEZDPO ad01id | 1,1 : 0,M | ADADSAT ad01id |
Položky nezdanit. nebo srážky - patří dané osobě | MZNEZDPO mz05id | 1,1 : 0,M | MZOSOBA mz05id |

Indexy

Název | Primární | Výraz | Popis
ix_MZNEZDPO_mznezdpo1 |  | mz01id, mz28id | mz01id + mz28id
ix_MZNEZDPO_mz36 | P | mz36 | Jednoznačná časová identifikace
ix_MZNEZDPO_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZNEZDPO_mz28id |  | mz28id | Jednoznačná identifikace mzdové položky
ix_MZNEZDPO_ad01id |  | ad01id | Identifikace adresáta
ix_MZNEZDPO_ad03cisban |  | ad03cisban | Číslo spojení na bankovní účet adresáta.
ix_MZNEZDPO_adbucty1 |  | ad01id, ad03cisban | ad01id+ad03cisban
ix_MZNEZDPO_mz36por_sr |  | mz36por_sr | Pořadí uplatnění srážky z karty ve výpočtu výplatního lístku
ix_MZNEZDPO_mz36por_pu |  | mz36por_pu | Pořadí uplatnění půjčky z karty ve výpočtu výplatního lístku
ix_MZNEZDPO_mz05id |  | mz05id | Identifikace osoby


MZORGJED Organizační jednotka - číselník

Popis

Objektem typu MZORGJED je každý záznam, který obsahuje popis organizační jednotky.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz60id | C(6) | Organizační jednotka | Identifikace organizační jednotky | Identifikace organizační jednotky
mz60popis | C(40) | Název | Název organizační jednotky | Název organizační jednotky
mz60koment | M | Komentář | Komentář | Komentář
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Organizační jednotka - číselník - zapsal uživatel | MZORGJED bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Organizační jednotka - číselník - má organizační selektor | MZORGJED sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Úkolové listy - mohou mít organizační jednotku | MZUKOLLI mz60id | 0,1 : 0,M | MZORGJED mz60id |

Indexy

Název | Primární | Výraz | Popis
ix_MZORGJED_mz60id | P | mz60id | Identifikace organizační jednotky
ix_MZORGJED_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_MZORGJED_bw01uziv |  | bw01uziv | Identifikace uživatele systému


MZOSOBA Tabulka osob nějakým způsobem vázaných k pracovníkovi

Popis

Objektem typu MZOSOBA je každý záznam, který obsahuje údaje o osobách , které jsou v nějakém vztahu k pracovníkovi, např. údaje o dětech.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz05id | C(6) | Identifikace | Identifikace osoby | Identifikace osoby
mz05jmprij | C(40) | Jméno | Jméno a příjmení osoby | Jméno a příjmení osoby
mz05datnar | D | Datum narození | Datum narození | Datum narození
mz05rodc | C(11) | Rodné číslo | Rodné číslo | Rodné číslo
mz05ztp | N(1,0) | ZTP | Je ZTP - Ano, Ne | Je ZTP - Ano, Ne
mz05koment | M | Komentář | Komentář | Komentář
mz05text1 | C(40) | Volný text1 | Volný text1 | Volný text1
mz05text2 | C(40) | Volný text2 | Volný text2 | Volný text2
mz05text3 | C(40) | Volný text3 | Volný text3 | Volný text3
mz05cislo1 | N(12,2) | Volné číslo1 | Volné číslo1 | Volné číslo1
mz05cislo2 | N(12,2) | Volné číslo2 | Volné číslo2 | Volné číslo2
mz05cislo3 | N(12,2) | Volné číslo3 | Volné číslo3 | Volné číslo3

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vztah mezi pracovníkem a příslušnou osobou - patří k osobě | MZKAROSO mz05id | 1,1 : 0,M | MZOSOBA mz05id |
Mzda - souvisí s danou osobou | MZMZDY mz05id | 1,1 : 0,M | MZOSOBA mz05id |
Položky nezdanit. nebo srážky - patří dané osobě | MZNEZDPO mz05id | 1,1 : 0,M | MZOSOBA mz05id |

Indexy

Název | Primární | Výraz | Popis
ix_MZOSOBA_mz05id | P | mz05id | Identifikace osoby
ix_MZOSOBA_mz05jmprij |  | mz05jmprij | Jméno a příjmení osoby
ix_MZOSOBA_mz05rodc |  | mz05rodc | Rodné číslo


MZOSOBNI Osobní údaje ke kartě pracovníka

Popis

Objektem typu MZOSOBNI je každý záznam, který obsahuje další osobní údaje k pracovníkovi, např. údaje o dětech, o studiu školy, o invaliditě.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz80id | C(12) | mz80id | Jednoznačná časová identifikace. | Jednoznačná časová identifikace.
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz80typ | N(1,0) | Typ údaje | Typ údaje - údaje o dětech, o invaliditě, o studiu | Typ údaje - údaje o dětech, o invaliditě, o studiu. Pro potřeba potvrzení o zdanitelných příjmech
mz80text1 | C(40) | Volný text1 | Volný text1 | Volný text1
mz80text2 | C(40) | Volný text2 | Volný text2 | Volný text2
mz80text3 | C(40) | Volný text3 | Volný text3 | Volný text3
mz80text4 | C(40) | Volný text4 | Volný text4 | Volný text4
mz80od | D | Platnost od | Platnost od | Platnost od
mz80do | D | do | Platnost do | Platnost do
mz80koment | M | Komentář | Komentář | Komentář
mz80datum1 | D | Volné datum1 | Volné datum1 | Volné datum1
mz80cislo1 | N(12,2) | Volné číslo1 | Volné číslo1 | Volné číslo1

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Osobní údaje ke kartě pracovníka - patří ke kartě pracovníka | MZOSOBNI mz01id | 1,1 : 0,M s rušením | MZKARTA mz01id |

Indexy

Název | Primární | Výraz | Popis
ix_MZOSOBNI_mz80id | P | mz80id | Jednoznačná časová identifikace.
ix_MZOSOBNI_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZOSOBNI_mz80typ |  | mz80typ | Typ údaje - údaje o dětech, o invaliditě, o studiu. Pro potřeba potvrzení o zdanitelných příjmech
ix_MZOSOBNI_mz80text1 |  | mz80text1 | Volný text1
ix_MZOSOBNI_mz80text2 |  | mz80text2 | Volný text2
ix_MZOSOBNI_mz80text3 |  | mz80text3 | Volný text3
ix_MZOSOBNI_mz80text4 |  | mz80text4 | Volný text4
ix_MZOSOBNI_mz80cislo1 |  | mz80cislo1 | Volné číslo1


MZPAALGN Parametry nepřítomností - Algoritmus stanovení dávky

Popis

Algoritmus stanovení dávky
Platí od roku 2004. Pro nastavení způsobů chování evidence a vyplácení nepřítomností (nemoc, OČR, MD).

Atributy

Atribut | Typ | Návěští | Message | Popis
mz11id | C(6) | Identifikace algoritmu | Identifikace algoritmu | Identifikace algoritmu
mz11popis | C(40) | Popis | Popis algoritmu |
mz11pozn | M | Komentář | Komentář |
mz11zaokr | N(1,0) | Zaokrouhlení | Zaokrouhlení - žádné, od 0.5 nahoru, vždy nahoru, vždy dolu |
mz11kolikm | N(1,0) | mz11kolikm | Zaokrouhlení na kolik míst ? | Zaokrouhlení na kolik míst ?
mz11verze | N(8,3) | Verze | Verze algoritmu stanovení dávky | Verze algoritmu stanovení dávky

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametry nepřítomností - platnost v období - odpovídá algoritmu | MZPAPLAT mz11id | 1,1 : 0,M | MZPAALGN mz11id |
Parametry nepřítomností - stanovení dávky - odpovídá algoritmu stanovení dávky | MZPADAVK mz11id | 1,1 : 0,M s rušením | MZPAALGN mz11id |
Popis verzí algoritmu stanovení dávky - je popisem verze algoritmu stanovení nem. dávky | MZPAVLGN mz11id | 1,1 : 0,M | MZPAALGN mz11id |

Indexy

Název | Primární | Výraz | Popis
ix_MZPAALGN_mz11id | P | mz11id | Identifikace algoritmu
ix_MZPAALGN_mz11popis |  | mz11popis |
ix_MZPAALGN_mz11verze |  | mz11verze | Verze algoritmu stanovení dávky


MZPADAVK Parametry nepřítomností - stanovení dávky

Popis

Tabulka MZPADAVK obsahuje záznamy o způsobu stanovení nemocenské dávky.
Platí od roku 2004. Pro nastavení způsobů chování evidence a vyplácení nepřítomností (nemoc, OČR, MD).

Atributy

Atribut | Typ | Návěští | Message | Popis
mz12id | C(6) | Identif. DVZ | Identifikace redukce denního vyměřovacího základu | Identifikace redukce denního vyměřovacího základu
mz11id | C(6) | Identifikace algoritmu | Identifikace algoritmu | Identifikace algoritmu
mz14denod | N(4,0) | Den od | Den dávky od |
mz14dendo | N(4,0) | Den do | Den dávky do |
mz14proc | N(5,2) | Procento | Procento započítávání dávky |
mz14zaokr | N(1,0) | Zaokrouhlení | Zaokrouhlení - žádné, od 0.5 nahoru, vždy nahoru, vždy dolu |
mz14pozn | M | Komentář | Komentář |
mz14platod | D | Platnost od | Platnost stanovení částky od | Platnost stanovení částky od, platnost daného řádku
mz14vyznam | N(1,0) | mz14vyznam | Význam - způsob použití | Význam - způsob použití
mz14typ | N(1,0) | mz14typ | Typ záznamu | Typ záznamu
mz14typdne | N(1,0) | mz14typdne | Typ dnů, se kterými se dále pracuje | Typ dnů, se kterými se dále pracuje při výpočtu
mz28id | C(6) | Mzdová položka | Jednoznačná identifikace mzdové položky | Jednoznačná identifikace mzdové položky
mz14platdo | D | do | Platnost stanovení částky do | Platnost stanovení částky do, platnost daného řádku
mz14vztahd | N(1,0) | Vztah k datu | Vztah k datu. Je klíčové datum nepřítomnosti nebo datum dávky ? |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametry nepřítomností - stanovení dávky - mají mzdovou položku | MZPADAVK mz28id | 1,1 : 0,M | MZMZDPOL mz28id |
Parametry nepřítomností - stanovení dávky - odpovídá algoritmu stanovení dávky | MZPADAVK mz11id | 1,1 : 0,M s rušením | MZPAALGN mz11id |
Parametry nepřítomností - stanovení dávky - odpovídá hlavičce DVZ | MZPADAVK mz12id | 1,1 : 0,M | MZPADVZH mz12id |

Indexy

Název | Primární | Výraz | Popis
ix_MZPADAVK_mz12id |  | mz12id | Identifikace redukce denního vyměřovacího základu
ix_MZPADAVK_mz11id |  | mz11id | Identifikace algoritmu
ix_MZPADAVK_mz14denod |  | mz14denod |
ix_MZPADAVK_mz14dendo |  | mz14dendo |
ix_MZPADAVK_mz14proc |  | mz14proc |
ix_MZPADAVK_mzpadavk | P | mz11id, mz14denod, mz14platod, mz14vyznam, mz14typ |
ix_MZPADAVK_mz28id |  | mz28id | Jednoznačná identifikace mzdové položky


MZPADVZH Parametry nepřítomností - DVZ hlavička

Popis

Tabulka MZPADVZH obsahuje záznamy o typech redukce denního vyměřovacího základu pro účely výpočtu nemocenské dávky.
Platí od roku 2004. Pro nastavení způsobů chování evidence a vyplácení nepřítomností (nemoc, OČR, MD).

Atributy

Atribut | Typ | Návěští | Message | Popis
mz12id | C(6) | Identif. DVZ | Identifikace redukce denního vyměřovacího základu | Identifikace redukce denního vyměřovacího základu
mz12zaokr | N(1,0) | Zaokrouhlení | Zaokrouhlení - žádné, od 0.5 nahoru, vždy nahoru, vždy dolu |
mz12popis | C(40) | Popis | Popis | Popis
mz12pozn | M | Komentář | Komentář |
mz12prec | N(1,0) | mz12prec | Původ redukované částky - základu | Původ redukované částky - základu
mz12kolikm | N(1,0) | mz12kolikm | Zaokrouhlení na kolik míst ? | Zaokrouhlení na kolik míst

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametry nepřítomností - DVZ intervaly - odpovídá hlavičce DVZ | MZPADVZP mz12id | 1,1 : 0,M s rušením | MZPADVZH mz12id |
Parametry nepřítomností - stanovení dávky - odpovídá hlavičce DVZ | MZPADAVK mz12id | 1,1 : 0,M | MZPADVZH mz12id |

Indexy

Název | Primární | Výraz | Popis
ix_MZPADVZH_mz12id | P | mz12id | Identifikace redukce denního vyměřovacího základu
ix_MZPADVZH_mz12popis |  | mz12popis | Popis


MZPADVZP Parametry nepřítomností - DVZ intervaly

Popis

Tabulka MZPADVZP obsahuje záznamy o redukčních intervalech pro redukci denního vyměřovacího základu pro účely výpočtu nemocenské dávky.
Platí od roku 2004. Pro nastavení způsobů chování evidence a vyplácení nepřítomností (nemoc, OČR, MD).

Atributy

Atribut | Typ | Návěští | Message | Popis
mz12id | C(6) | Identif. DVZ | Identifikace redukce denního vyměřovacího základu | Identifikace redukce denního vyměřovacího základu
mz13hranod | N(10,2) | Hranice od | Redukční hranice od |
mz13hrando | N(10,2) | Hranice do | Redukční hranice do |
mz13proc | N(6,2) | Procento | Procento započítávání DVZ |
mz13zaokr | N(1,0) | Zaokrouhlení | Zaokrouhlení - žádné, od 0.5 nahoru, vždy nahoru, vždy dolu |
mz13pozn | M | Komentář | Komentář |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametry nepřítomností - DVZ intervaly - odpovídá hlavičce DVZ | MZPADVZP mz12id | 1,1 : 0,M s rušením | MZPADVZH mz12id |

Indexy

Název | Primární | Výraz | Popis
ix_MZPADVZP_mz12id |  | mz12id | Identifikace redukce denního vyměřovacího základu
ix_MZPADVZP_mz13hranod |  | mz13hranod |
ix_MZPADVZP_mz13hrando |  | mz13hrando |
ix_MZPADVZP_mz13proc |  | mz13proc |
ix_MZPADVZP_mzpadvzp | P | mz12id, mz13hranod |


MZPALETA Paleta barev kategorií pracovníků

Popis

Paleta barev kategorií pracovníků

Atributy

Atribut | Typ | Návěští | Message | Popis
mz17id | C(6) | Paleta | Identifikace palety barev | Identifikace palety barev
mz17nazpal | C(40) | Název palety | Název palety barev | Název palety barev
mz17koment | M | Poznámka | Poznámka | Poznámka
bw05ident | C(6) | Skupina | Identifikace skupiny uživatelů | Identifikace skupiny uživatelů

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Paleta barev kategorií pracovníků - je používána skupinou uživatelů | MZPALETA bw05ident | 1,1 : 0,M | BWUZIVAT bw01uziv |
Barva kategorie pracovníka v paletě barev - je paletě barev | MZPALKAT mz17id | 1,1 : 0,M | MZPALETA mz17id |

Indexy

Název | Primární | Výraz | Popis
ix_MZPALETA_mz17id | P | mz17id | Identifikace palety barev
ix_MZPALETA_mz17nazpal |  | mz17nazpal | Název palety barev
ix_MZPALETA_bw05ident |  | bw05ident | Identifikace skupiny uživatelů


MZPALKAT Barva kategorie pracovníka v paletě barev

Popis

Barva kategorie pracovníka v paletě barev

Atributy

Atribut | Typ | Návěští | Message | Popis
mz16id | C(6) | Kategorie | Identifikace kategorie pracovníka | Identifikace kategorie pracovníka
mz17id | C(6) | Paleta | Identifikace palety barev | Identifikace palety barev
bw95id | C(6) | Barva | Identifikace barvy RGB | Identifikace barvy RGB
bw95id2 | C(6) | Barva | Identifikace barvy RGB | Identifikace barvy RGB
mz18prior | N(3,0) | Priorita | Priorita | Priorita

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Barva kategorie pracovníka v paletě barev - definuje barvu RGB - popředí | MZPALKAT bw95id | 1,1 : 0,M | BWRGBCOL bw95id |
Barva kategorie pracovníka v paletě barev - definuje barvu RGB - pozadí | MZPALKAT bw95id2 | 1,1 : 0,M | BWRGBCOL bw95id |
Barva kategorie pracovníka v paletě barev - je určena pro kategorii | MZPALKAT mz16id | 1,1 : 0,M | MZKARADD mz16id |
Barva kategorie pracovníka v paletě barev - je paletě barev | MZPALKAT mz17id | 1,1 : 0,M | MZPALETA mz17id |

Indexy

Název | Primární | Výraz | Popis
ix_MZPALKAT_mzpalkat | P | mz16id, mz17id | PI - mz16id+mz17id
ix_MZPALKAT_mz17id |  | mz17id | Identifikace palety barev
ix_MZPALKAT_mz16id |  | mz16id | Identifikace kategorie pracovníka
ix_MZPALKAT_bw95id |  | bw95id | Identifikace barvy RGB
ix_MZPALKAT_bw95id2 |  | bw95id2 | Identifikace barvy RGB


MZPAPLAT Parametry nepřítomností - platnost v období

Popis

Parametry nepřítomností - platnost v období
Platí od roku 2004. Pro nastavení způsobů chování evidence a vyplácení nepřítomností (nemoc, OČR, MD).

Atributy

Atribut | Typ | Návěští | Message | Popis
mz37duvod | N(1,0) | Důvod | Důvod nepřítomnosti | Důvod nepřítomnosti
mz10platod | D | Platnost od | Platnost od | Platnost od
mz10platdo | D | Platnost do | Platnost do | Platnost do
mz11id | C(6) | Identifikace algoritmu | Identifikace algoritmu | Identifikace algoritmu
mz10pozn | M | Komentář | Komentář | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametry nepřítomností - platnost v období - odpovídá algoritmu | MZPAPLAT mz11id | 1,1 : 0,M | MZPAALGN mz11id |

Indexy

Název | Primární | Výraz | Popis
ix_MZPAPLAT_mz37duvod |  | mz37duvod | Důvod nepřítomnosti
ix_MZPAPLAT_mz10platod |  | mz10platod | Platnost od
ix_MZPAPLAT_mz10platdo |  | mz10platdo | Platnost do
ix_MZPAPLAT_mz11id |  | mz11id | Identifikace algoritmu
ix_MZPAPLAT_mzpaplat | P | mz37duvod, mz10platod | mz37duvod+mz10platod


MZPARAM Parametry

Atributy

Atribut | Typ | Návěští | Message | Popis
mz27id | C(12) | Ident. | Jednoznačná časová identifikace. |
mz27datmzd | D | Poslední zpracované mzdy k datu | Datum, ke kterému jsou spočteny poslední mzdy. | Měsíc a rok, pro který se zpracovávají mzdy.
mz27spzam | N(5,2) | S.p. zaměstnance | Sociální pojištění hrazené zaměstnancem (%) | Sociální pojištění hrazené zaměstnancem (%)
mz27sporg | N(5,2) | S.p. organizace | Sociální pojištění hrazené organizací (%) | Sociální pojištění hrazené organizací (%)
mz27spzpus | N(1,0) | Způsob výpočtu SP | Způsob výpočtu sociálního pojištění za organizaci. | Způsob výpočtu sociálního pojištění za organizaci.
mz27zpsazb | N(5,2) | Sazba zdravotního pojištění | Sazba zdravotního pojištění (%) | Sazba zdravotního pojištění (%)
mz27zpnepl | N(5,0) | mz27zpnepl | Min. vym. základ z.p. | Min. vym. základ z.p. Minimální vyměřovací základ, ze kterého se platí zdravotní pojištění při neplaceném volnu a absenci.
mz27minhod | N(5,2) | Min. mzda hodinová | Minimální mzda hodinová (při úvazku 40 hodin týdně) | Minimální mzda hodinová (při úvazku 40 hodin týdně)
mz27limsp | N(8,2) | mz27limsp | Spodní hranice odvodu sociálního pojištění. Pod tuto hranici se sociální pojištění neodvádí. | Spodní hranice odvodu sociálního pojištění. Pod tuto hranici se sociální pojištění neodvádí.
mz27nahrid | C(6) | Náhrada mzdy za nemoc | Mzdová položka sloužící k výpočtu Náhrady mzdy za nemoc | Mzdová položka sloužící k výpočtu Náhrady mzdy za nemoc
mz27zpmzdp | C(6) | Dorovnání min. mzda | Mzdová položka sloužící k dorovnání příjmu do minimální mzdy | Mzdová položka sloužící k dorovnání příjmu do minimální mzdy
mz27zpstat | N(5,0) | Vym. základ z.p. | Vyměřovací základ, ze kterého platí zdravotní pojištění stát | Vyměřovací základ, ze kterého platí zdravotní pojištění stát
mz27dalims | N(5,0) | mz27dalims | Limit srážkové daně | Limit srážkové daně
mz27dasazs | N(5,2) | Sazba srážkové daně | Sazba srážkové daně | Sazba srážkové daně
mz27npmaxz | N(3,0) | Max. denní vyměř.zákl. - plná částka | Maximální denní vyměřovací základ - plná částka | Maximální denní vyměřovací základ
mz27npmax2 | N(3,0) | Max. denní vyměř.zákl. - 60% částka | Maximální denní vyměřovací základ - 60% částka |
mz27np3dny | N(3,0) | Nemocenské za první tři dny (%) | Nemocenské za první tři dny (%) | Nemocenské za první tři dny (%)
mz27npden | N(3,0) | Nemocenské za den (%) | Nemocenské za den (%) | Nemocenské za den (%)
mz27npvelo | N(1,0) | Velká organizace | Velká organizace z hlediska sociálního pojištění. | Velká organizace - Ano/Ne
mz27socad | C(6) | Adresát - soc. pojištění | Adresát pro odeslání odvodu sociálního pojištění | Adresát pro odeslání odvodu sociálního pojištění
mz27socadr | C(2) | mz27socadr | Adresa adresáta pro sociální pojištění | Adresa adresáta pro sociální pojištění
mz27socspo | C(2) | Spojení | Číslo spojení adresáta. | Číslo spojení adresáta.
mz27socban | C(2) | Účet | Identifikátor spojení na bankovní účet adresáta. | Identifikátor spojení na bankovní účet adresáta.
pa01id | C(6) | Sada | Identifikátor sady parametrů | Identifikátor sady parametrů
pa01oblast | C(2) | Oblast | Oblast sady parametrů | Oblast sady parametrů
mz27socks | C(4) | KS | Konstantní symbol - sociální odvody | Konstantní symbol - sociální odvody
mz27socvs | C(10) | VS | Variabilní symbol - sociální odvody | Variabilní symbol - sociální odvody
mz27zalda | C(6) | Adresát - zálohová daň | Adresát pro odeslání odvodu zálohové daně | Adresát pro odeslání odvodu zálohové daně
mz27zaladr | C(2) | Adresa | Číslo adresy adresáta. | Číslo adresy adresáta pro zálohovou daň
mz27zalspo | C(2) | Spojení | Číslo spojení adresáta pro zálohovou daň | Číslo spojení adresáta pro zálohovou daň
mz27zalban | C(2) | Účet | Identifikátor spojení na bankovní účet adresáta. | Identifikátor spojení na bankovní účet adresáta pro zálohovou daň
mz27srspo | C(2) | Spojení | Číslo spojení adresáta pro srážkovou daň | Číslo spojení adresáta pro srážkovou daň
mz27zalks | C(4) | KS | Konstantní symbol - zálohová daň | Konstantní symbol - zálohová daň
mz27zalvs | C(10) | VS | Variabilní symbol - zálohová daň | Variabilní symbol - zálohová daň
mz27srda | C(6) | Adresát - srážková daň | Adresát pro odeslání odvodu srážkové daně | Adresát pro odeslání odvodu srážkové daně
mz27sradr | C(2) | mz27sradr | Číslo adresy adresáta pro srážkovou daň | Číslo adresy adresáta pro srážkovou daň
mz27srban | C(2) | mz27srban | Identifikátor spojení na bankovní účet adresáta pro srážkovou daň | Identifikátor spojení na bankovní účet adresáta pro srážkovou daň
mz27srks | C(4) | KS | Konstantní symbol - srážková daň | Konstantní symbol - srážková daň
mz27srvs | C(10) | VS | Variabilní symbol - srážková daň | Variabilní symbol - srážková daň
mz27bonad | C(6) | Adresát - daňový bonus | Adresát pro uplatnění daňového bonusu | Adresát pro uplatnění daňového bonusu
mz27bonadr | C(2) | Adresa | Číslo adresy adresáta. |
mz27bonspo | C(2) | Spojení | Číslo spojení adresáta pro daňový bonus | Číslo spojení adresáta pro daňový bonus
mz27bonban | C(2) | Účet | Identifikátor spojení na bankovní účet adresáta. |
mz27bonks | C(4) | KS | Konstantní symbol - daňový bonus | Konstantní symbol - daňový bonus
mz27bonvs | C(10) | VS | Variabilní symbol - daňový bonus | Variabilní symbol - daňový bonus
mz27denvyp | N(2,0) | Den výplaty mezd | Den výplaty mezd | Den výplaty mezd
mz27denso | N(1,0) | Den výplaty připadá na SOBOTU | Jestliže den výplaty mezd připadá na sobotu, vyplácejte v ... | Jestliže den výplaty mezd připadá na sobotu, vyplácejte v ...
mz27denne | N(1,0) | Den výplaty připadá na NEDĚLI | Jestliže den výplaty mezd připadá na neděli, vyplácejte v ... | Jestliže den výplaty mezd připadá na neděli, vyplácejte v ...
mz27tsodku | N(1,0) | Technický selektor na výpl. lístek odkud | Odkud nastavovat technický selektor na výplatní lístek. | Odkud nastavovat technický selektor na výplatní lístek.
mz27typkal | N(1,0) | Typ kalendáře | Typ používaného kalendáře - po měsících, po dnech | Typ používaného kalendáře - po měsících, po dnech
mz27prden | N(1,0) | Způsob výpočtu denního průměru | Způsob výpočtu denního průměru | Způsob výpočtu denního průměru
mz27znamen | N(1,0) | Způsob výpočtu nepřítomnosti pro nemoc | Způsob výpočtu nepřítomnosti pro nemoc, plus - dnů+hodin, mínus - dnů-hodin | Způsob výpočtu nepřítomnosti pro nemoc, plus - dnů+hodin, mínus - dnů-hodin Pro činnost nepřítomnost pro nemoc, způsob evidence nepřítomnosti, která trvá část dne
mz27zakpoj | N(6,2) | Sazba(promile) | Sazba zákonného pojištění odpovědnosti organizace (promile) | Sazba zákonného pojištění odpovědnosti organizace (promile)
mz27zkuseb | N(2,0) | Velikost zkušeb. doby v měs. | Standardní velikost zkušební doby v měsících, zadá-li se 0, nebude se zkušební doba předplňovat. | Standardní velikost zkušební doby v měsících
mz27datuza | D | Uzamknutí | Datum uzamknutí výpočtu mezd - je-li vyplněno, pak k tomuto datu nelze provádět opravy a výpočet mezd pracovníků | Datum uzamknutí výpočtu mezd - je-li vyplněno, pak k tomuto datu nelze provádět opravy a výpočet mezd pracovníků
mz27dzne | N(10,2) | Max. zvýh. na dítě | Maximální daňové zvýhodnění na dítě (ne ZTP) | Maximální daňové zvýhodnění na dítě (ne ZTP)
mz27dzano | N(10,2) | Max. zvýh. na ZTP dítě | Maximální daňové zvýhodnění na dítě (ano ZTP) | Maximální daňové zvýhodnění na dítě (ano ZTP)
mz27dzboma | N(10,2) | Max. roč. daňový bonus | Maximální roční daňový bonus | Maximální daňový bonus
mz27dzbomi | N(10,2) | Min. roč. daňový bonus | Minimální roční daňový bonus | Minimální daňový bonus
mz27karoso | N(1,0) | Kontrola příslušnosti | Kontrola příslušnosti pracovníků k osobám |
mz25id | C(6) | Identifikace | Jednoznačná identifikace kalendáře | Jednoznačná identifikace kalendáře
mz27zakad | C(6) | Zák. pojištění | Adresát pro uplatnění zákonného pojištění odpovědnosti | Adresát pro uplatnění zákonného pojištění odpovědnosti
mz27zakadr | C(2) | mz27zakadr | Číslo adresy adresáta. |
mz27zakspo | C(2) | mz27zakspo | Číslo spojení adresáta pro zákonné pojištění odpovědnosti | Číslo spojení adresáta pro zákonné pojištění odpovědnosti
mz27zakban | C(2) | Účet | Identifikátor spojení na bankovní účet adresáta. |
mz27zakks | C(4) | KS | Konstantní symbol - zákonné pojištění odpovědnosti | Konstantní symbol - zákonné pojištění odpovědnosti
mz27zakvs | C(10) | VS | Variabilní symbol - zákonné pojištění odpovědnosti | Variabilní symbol - zákonné pojištění odpovědnosti
mz27spslev | N(1,0) | Uplatňovat slevy na sociálním pojištění. | Uplatňovat slevy na sociálním pojištění. |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametry - mají adresu adresáta - sociální pojištění | MZPARAM mz27socad mz27socspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Parametry - mají adresáta pro odvod SP | MZPARAM mz27socad | 1,1 : 0,M | ADADSAT ad01id |
Parametry - mají účet adresáta - sociální pojištění | MZPARAM mz27socad mz27socban | 1,1 : 0,M | ADBUCTY ad01id ad03cisban |
Parametry - mají adresáta pro odvod zálohové daně | MZPARAM mz27zalda | 1,1 : 0,M | ADADSAT ad01id |
Parametry - mají adresáta pro odvod srážkové daně | MZPARAM mz27srda | 1,1 : 0,M | ADADSAT ad01id |
Parametry - mají účet adresáta - zálohová daň | MZPARAM mz27zalda mz27zalban | 1,1 : 0,M | ADBUCTY ad01id ad03cisban |
Parametry - mají účet adresáta - srážková daň | MZPARAM mz27srda mz27srban | 1,1 : 0,M | ADBUCTY ad01id ad03cisban |
Parametry - mají adresu adresáta - zálohová daň | MZPARAM mz27zalda mz27zalspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Parametry - mají adresu adresáta - srážková daň | MZPARAM mz27srda mz27srspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Parametry - defininují užití sady parametrů | MZPARAM pa01id pa01oblast | 1,1 : 0,M | PASADA pa01id pa01oblast |
Parametry - mají adresáta pro uplatnění daňového bonusu | MZPARAM mz27bonad | 1,1 : 0,M | ADADSAT ad01id |
Parametry - mají účet adresáta - daňový bonus | MZPARAM mz27bonad mz27bonban | 1,1 : 0,M | ADBUCTY ad01id ad03cisban |
Parametry - mají adresu adresáta - daňový bonus | MZPARAM mz27bonad mz27bonspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Parametry - mají adresáta pro uplatnění zákonného pojištění odpovědnosti | MZPARAM mz27zakad | 1,1 : 0,M | ADADSAT ad01id |
Parametry - mají účet adresáta - zákonné pojištění odpovědnosti | MZPARAM mz27zakad mz27zakban | 1,1 : 0,M | ADBUCTY ad01id ad03cisban |
Parametry - mají adresu adresáta - zákonné pojištění odpovědnosti | MZPARAM mz27zakad mz27zakspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |

Indexy

Název | Primární | Výraz | Popis
ix_MZPARAM_mz27id | P | mz27id |
ix_MZPARAM_mz27zpmzdp |  | mz27zpmzdp | Mzdová položka sloužící k dorovnání příjmu do minimální mzdy
ix_MZPARAM_mz27socad |  | mz27socad | Adresát pro odeslání odvodu sociálního pojištění
ix_MZPARAM_mzspadr1 |  | mz27socad, mz27socadr | adresát+adresa sociální pojištění
ix_MZPARAM_mzspspoj |  | mz27socad, mz27socspo | Adresát + spojení sociální pojištění
ix_MZPARAM_mzspban1 |  | mz27socad, mz27socban | adresát+účet sociální pojištění
ix_MZPARAM_pasada |  | pa01id, pa01oblast | PI - pa01id+pa01oblast
ix_MZPARAM_mz27zalda |  | mz27zalda | Adresát pro odeslání odvodu zálohové daně
ix_MZPARAM_mzzaladr1 |  | mz27zalda, mz27zaladr | adresát+adresa zálohová daň
ix_MZPARAM_mzzalsp1 |  | mz27zalda, mz27zalspo | Adresát + spojení zálohová daň
ix_MZPARAM_mzzalban1 |  | mz27zalda, mz27zalban | adresát+účet zálohová daň
ix_MZPARAM_mz27srda |  | mz27srda | Adresát pro odeslání odvodu srážkové daně
ix_MZPARAM_mzsrard1 |  | mz27srda, mz27sradr | adresát+adresa srážková daň
ix_MZPARAM_mzsrsp1 |  | mz27srda, mz27srspo | Adresát+spojení srážková daň
ix_MZPARAM_mzsrban1 |  | mz27srda, mz27srban | adresát + banka srážková daň
ix_MZPARAM_mz27bonad |  | mz27bonad | Adresát pro uplatnění daňového bonusu
ix_MZPARAM_mzbonadr1 |  | mz27bonad, mz27bonadr | adresát+adresa daňový bonus
ix_MZPARAM_mzbonspo1 |  | mz27bonad, mz27bonspo | Adresát+spojení daňový bonus
ix_MZPARAM_mzbonba1 |  | mz27bonad, mz27bonban | adresát + banka daňový bonus
ix_MZPARAM_mz25id |  | mz25id | Jednoznačná identifikace kalendáře
ix_MZPARAM_mz27zakad |  | mz27zakad | Adresát pro uplatnění zákonného pojištění odpovědnosti
ix_MZPARAM_mzzakban1 |  | mz27zakad, mz27zakban | adresát+účet zákonné pojištění odpovědnosti
ix_MZPARAM_mzzakspo1 |  | mz27zakad, mz27zakspo | adresát+spojení zákonné pojištění odpovědnosti
ix_MZPARAM_mzzakadr1 |  | mz27zakad, mz27zakadr | adresát+adresa zákonné pojištění odpovědnosti


MZPARNEM Parametry nepřítomností

Popis

Parametry nepřítomností - platné do konce roku 2003

Atributy

Atribut | Typ | Návěští | Message | Popis
mz77id | C(4) | Identifikace období | Identifikace období platnosti parametrů | Identifikace období platnosti parametrů
mz77datod | D | Od | Datum začátku období | Datum začátku období
mz77datdo | D | Do | Datum konce období | Datum konce období
mz77hran1 | N(5,0) | První (dolní) redukční hranice | První (dolní) redukční hranice | První (dolní) redukční hranice (pro rok 1999 360 Kč)
mz77proce | N(3,0) | % | Procento z částky vyměř. základu převyšující první hranici | Procento z částky vyměř. základu převyšující první hranici (pro rok 1999 60%)
mz77hran2 | N(5,0) | Druhá (horní) redukční hranice | Druhá (horní) redukční hranice | Druhá (horní) redukční hranice
mz77np3dny | N(3,0) | Nemocenské za první tři dny (%) | Nemocenská dávka za první tři dny | Nemocenská dávka za první tři dny
mz77npden | N(3,0) | Nemocenské za den (%) | Nemocenská dávka za den | Nemocenská dávka za den

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Nemocenská dávka - má parametry | MZNEMDAV mz77id | 1,1 : 0,M | MZPARNEM mz77id |

Indexy

Název | Primární | Výraz | Popis
ix_MZPARNEM_mz77id | P | mz77id | Identifikace období platnosti parametrů
ix_MZPARNEM_mz77datod |  | mz77datod | Datum začátku období
ix_MZPARNEM_mz77datdo |  | mz77datdo | Datum konce období


MZPAVLGN Popis verzí algoritmu stanovení dávky

Popis

Popis verzí algoritmu stanovení dávky

Atributy

Atribut | Typ | Návěští | Message | Popis
mz11id | C(6) | Identifikace algoritmu | Identifikace algoritmu | Identifikace algoritmu
mz11verze | N(8,3) | Verze | Verze algoritmu stanovení dávky | Verze algoritmu stanovení dávky
mzb2dne | D | Dne | Datum záznamu o verzi | Datum záznamu o verzi
sp00jmeakt | C(40) | Změnil | Jméno uživatele systému, který změnil záznam | Jméno uživatele systému, který změnil záznam
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace
mzb2koment | M | Popis | Popis verze | Popis verze

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis verzí algoritmu stanovení dávky - je popisem verze algoritmu stanovení nem. dávky | MZPAVLGN mz11id | 1,1 : 0,M | MZPAALGN mz11id |

Indexy

Název | Primární | Výraz | Popis
ix_MZPAVLGN_mzpavlgn | P | mz11id, mz11verze |
ix_MZPAVLGN_mz11id |  | mz11id | Identifikace algoritmu


MZPERAH Aktuální hodnoty personalistiky

Popis

Aktuální hodnoty personalistiky

Atributy

Atribut | Typ | Návěští | Message | Popis
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
mz31id | C(6) | Identifikace | Identifikace pracovní funkce (zařazení) | Identifikace pracovní funkce (zařazení)
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
mz90cena | N(12,3) | Celková cena | Celková cena | Celková cena
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace

Indexy

Název | Primární | Výraz | Popis
ix_MZPERAH_ad01id |  | ad01id | Identifikace adresáta
ix_MZPERAH_mz31id |  | mz31id | Identifikace pracovní funkce (zařazení)
ix_MZPERAH_sp61id |  | sp61id | Identifikace druhu artiklu
ix_MZPERAH_sp60id |  | sp60id | Identifikace artiklu
ix_MZPERAH_mz90cena |  | mz90cena | Celková cena
ix_MZPERAH_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_MZPERAH_mzperah | P | sp67id, sp06idsubs, ad01id, mz31id, sp61id, sp60id |


MZPERART Artikly personalistiky

Popis

Artikl personalistiky

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
mz92koment | M | Komentář | Komentář |
sp24idmj | C(3) | MJ | Identifikátor měrné jednotky | Identifikátor měrné jednotky
mz92cenaj | N(9,2) | mz92cenaj | Cena za jednotku | Cena za jednotku

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Artikly personalistiky - je artiklem | MZPERART sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Artikly personalistiky - má technicko věcný selektor | MZPERART sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Artikly personalistiky - založil uživatel systému | MZPERART bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Artikly personalistiky - v měrné jednotce | MZPERART sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Událost personalistiky - mají artikl personalistiky | MZPERUDA sp60id sp61id | 1,1 : 0,M | MZPERART sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_MZPERART_spartikl | P | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_MZPERART_sp60id |  | sp60id | Identifikace artiklu
ix_MZPERART_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_MZPERART_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_MZPERART_spartiknx |  |  |
ix_MZPERART_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky


MZPERS1 Druhy požadavků a vlastností

Popis

Druhy požadavků a vlastností - číselník

Atributy

Atribut | Typ | Návěští | Message | Popis
mz81id | C(6) | Druh požadavku | Identifikace druhu požadavku | Identifikace druhu požadavku
mz81nazev | C(40) | Název | Název druhu požadavku |
mz81koment | M | Komentář | Komentář |
mz81hodn1 | C(40) | Volný údaj C | Volný údaj znakový |
mz81hodn2 | N(20,4) | mz81hodn2 | Volný údaj numerický | Volný údaj numerický

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Hodnoty požadavků a vlastností - se vážou k druhům požadavků a vlastností | MZPERS2 mz81id | 1,1 : 0,M | MZPERS1 mz81id |

Indexy

Název | Primární | Výraz | Popis
ix_MZPERS1_mz81id | P | mz81id | Identifikace druhu požadavku


MZPERS2 Hodnoty požadavků a vlastností

Popis

Pracovní místa a druhy požadavků a vlastností

Atributy

Atribut | Typ | Návěští | Message | Popis
mz81id | C(6) | Druh požadavku | Identifikace druhu požadavku | Identifikace druhu požadavku
mz31id | C(6) | Identifikace | Identifikace pracovní funkce (zařazení) | Identifikace pracovní funkce (zařazení)
mz83volny1 | C(10) | Volný údaj | Volný údaj znakový | Volný údaj znakový
mz83volny2 | C(10) | Volný údaj | Volný údaj znakový | Volný údaj znakový
mz83volny3 | C(40) | Volný údaj | Volný údaj znakový | Volný údaj znakový
mz83volny4 | N(20,4) | Volný údaj | Volný údaj numerický | Volný údaj numerický
mz83volny5 | M | Volný údaj | Volný údaj | Volný údaj
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
mz83datum | D | Platné od | Platné od | Platné od
mz83volny6 | D | mz83volny6 | Volné datum | Volné datum

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Hodnoty požadavků a vlastností - se vážou k druhům požadavků a vlastností | MZPERS2 mz81id | 1,1 : 0,M | MZPERS1 mz81id |
Hodnoty požadavků a vlastností - ??? | MZPERS2 ad01id | 1,1 : 0,M | ADADSAT ad01id |
Hodnoty požadavků a vlastností - patří k pracovnímu místu | MZPERS2 mz31id | 1,1 : 0,M s rušením | MZPRACFU mz31id |

Indexy

Název | Primární | Výraz | Popis
ix_MZPERS2_mz81id |  | mz81id | Identifikace druhu požadavku
ix_MZPERS2_mz31id |  | mz31id | Identifikace pracovní funkce (zařazení)
ix_MZPERS2_ad01id |  | ad01id | Identifikace adresáta
ix_MZPERS2_mz83datum |  | mz83datum | Platné od
ix_MZPERS2_mzpers2 | P | mz81id, mz31id, mz83datum, ad01id |


MZPERUDA Událost personalistiky

Popis

Událost personalistiky

Atributy

Atribut | Typ | Návěští | Message | Popis
mz90 | C(12) | JČI | Jednotná časová identifikace | Jednotná časová identifikace
mz90datum | D | Datum | Datum události | Datum události
mz90popis | C(60) | mz90popis | Popis události | Popis události
mz90typ | N(1,0) | mz90typ | Typ události | Typ události
mz31id | C(6) | Identifikace | Identifikace pracovní funkce (zařazení) | Identifikace pracovní funkce (zařazení)
mz82id | C(6) | Typové pracovní místo | Jednoznačná identifikace typové pracovní funkce (zařazení) | Jednoznačná identifikace pracovní funkce (zařazení)
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad01id1 | C(6) | Importovaný | Identifikace importovaného adresáta | Identifikace adresáta - pro import
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
mz90koment | M | Komentář | Komentář | Komentář
mz90mnozs | N(12,3) | Množství | Množství | Množství
mz90cena | N(12,3) | Celková cena | Celková cena | Celková cena
mz90zmstav | N(1,0) | Změna stavu | Změna stavu | Změna stavu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost personalistiky - má adresáta | MZPERUDA ad01id | 1,1 : 0,M | ADADSAT ad01id |
Událost personalistiky - má skutečné pracovní místo | MZPERUDA mz31id | 0,1 : 0,M | MZPRACFU mz31id |
Událost personalistiky - zapsal uživatel | MZPERUDA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost personalistiky - patří do fyzické operace | MZPERUDA sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost personalistiky - má obchodní selektor | MZPERUDA sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost personalistiky - má organizační selektor | MZPERUDA sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost personalistiky - má technicko-vědecký selektor | MZPERUDA sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost personalistiky - mají artikl personalistiky | MZPERUDA sp60id sp61id | 1,1 : 0,M | MZPERART sp60id sp61id |
Událost personalistiky - má dalšího adresáta | MZPERUDA ad01id1 | 1,1 : 0,M | ADADSAT ad01id |

Indexy

Název | Primární | Výraz | Popis
ix_MZPERUDA_mz90 | P | mz90 | Jednotná časová identifikace
ix_MZPERUDA_mz90datum |  | mz90datum | Datum události
ix_MZPERUDA_mz90popis |  | mz90popis | Popis události
ix_MZPERUDA_mz90typ |  | mz90typ | Typ události
ix_MZPERUDA_mz31id |  | mz31id | Identifikace pracovní funkce (zařazení)
ix_MZPERUDA_mz82id |  | mz82id | Jednoznačná identifikace pracovní funkce (zařazení)
ix_MZPERUDA_ad01id |  | ad01id | Identifikace adresáta
ix_MZPERUDA_ad01id1 |  | ad01id1 | Identifikace adresáta - pro import
ix_MZPERUDA_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_MZPERUDA_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_MZPERUDA_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_MZPERUDA_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_MZPERUDA_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_MZPERUDA_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_MZPERUDA_sp61id |  | sp61id | Identifikace druhu artiklu
ix_MZPERUDA_sp60id |  | sp60id | Identifikace artiklu
ix_MZPERUDA_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_MZPERUDA_mz90cena |  | mz90cena | Celková cena
ix_MZPERUDA_adadsatx |  |  |


MZPLATID Číselník platidel

Popis

Objektem typu MZPLATID je každý záznam, který obsahuje číselník platidel (mincí a bankovek).

Atributy

Atribut | Typ | Návěští | Message | Popis
mz57id | N(4,0) | Hodnota | Hodnota platidla | Hodnota platidla
mz57popis | C(40) | Název | Název platidla | Název platidla

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Výčetka platidel pro jednotlivé výplatní sáčky - odpovídá číselníku platidel | MZPLSACK mz57id | 1,1 : 0,M s rušením | MZPLATID mz57id |
Sumární výčetka platidel - váže na číselník platidel | MZPLSUMA mz57id | 1,1 : 0,M s rušením | MZPLATID mz57id |

Indexy

Název | Primární | Výraz | Popis
ix_MZPLATID_mz57id | P | mz57id | Hodnota platidla
ix_MZPLATID_mz57popis |  | mz57popis | Název platidla


MZPLSACK Výčetka platidel pro jednotlivé výplatní sáčky

Popis

Objektem typu MZPLSACK je každý záznam, který obsahuje výčetku platidel pro jednotlivé výplatní sáčky pracovníků.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz57id | N(4,0) | Hodnota | Hodnota platidla | Hodnota platidla
mz58pocet | N(4,0) | Počet | Počet kusů jednotlivého platidla | Počet kusů jednotlivého platidla

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Výčetka platidel pro jednotlivé výplatní sáčky - odpovídá pracovníkovi | MZPLSACK mz01id | 1,1 : 0,M s rušením | MZKARTA mz01id |
Výčetka platidel pro jednotlivé výplatní sáčky - odpovídá číselníku platidel | MZPLSACK mz57id | 1,1 : 0,M s rušením | MZPLATID mz57id |

Indexy

Název | Primární | Výraz | Popis
ix_MZPLSACK_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZPLSACK_mz57id |  | mz57id | Hodnota platidla
ix_MZPLSACK_mz58pocet |  | mz58pocet | Počet kusů jednotlivého platidla
ix_MZPLSACK_mzplsack | P | mz01id, mz57id | mz01id+mz57id


MZPLSUMA Sumární výčetka platidel

Popis

Objektem typu MZPLSUMA je každý záznam, který obsahuje údaje sumární výčetky platidel za jednotlivá střediska (podle výplatního místa).

Atributy

Atribut | Typ | Návěští | Message | Popis
mz64 | C(12) | mz64 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
mz22id | C(6) | Identifikace | Jednoznačná identifikace výplatního místa | Jednoznačná identifikace výplatního místa
mz57id | N(4,0) | Hodnota | Hodnota platidla | Hodnota platidla
mz64pocet | N(4,0) | mz64pocet | Počet kusů daného platidla (bankovky, mince) | Počet kusů daného platidla (bankovky, mince)

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Sumární výčetka platidel - odpovídá výplatnímu místu | MZPLSUMA mz22id | 1,1 : 0,M s rušením | MZVYPMIS mz22id |
Sumární výčetka platidel - váže na číselník platidel | MZPLSUMA mz57id | 1,1 : 0,M s rušením | MZPLATID mz57id |

Indexy

Název | Primární | Výraz | Popis
ix_MZPLSUMA_mz64 | P | mz64 | Jednoznačná časová identifikace
ix_MZPLSUMA_mz22id |  | mz22id | Jednoznačná identifikace výplatního místa
ix_MZPLSUMA_mz57id |  | mz57id | Hodnota platidla
ix_MZPLSUMA_mzplsuma1 |  | mz22id, mz57id | mz22id+mz57id


MZPOJIST Přehled za pojišťovny za jednotlivé lidi

Popis

Přehled za pojišťovny za jednotlivé lidi

Atributy

Atribut | Typ | Návěští | Message | Popis
mz28id | C(6) | Mzdová položka | Jednoznačná identifikace mzdové položky | Jednoznačná identifikace mzdové položky
mz70idp | C(3) | Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,... | Identifikace pojišťovny, např. 111, 121 ,...
mz97ciszp | C(15) | Číslo pojištěnce | Číslo pojištěnce ve zdravotní pojišťovně. Uvádějte pouze je-li různé od rodného čísla. | Číslo pojištěnce ve zdravotní pojišťovně. Uvádějte pouze je-li různé od rodného čísla.
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz02mesic | C(2) | Měsíc | Měsíc zpracování mezd | Měsíc zpracování mezd
mz02rok | C(4) | Rok | Rok zpracování mezd | Rok zpracování mezd
mz67zakl | N(16,4) | mz67zakl |  |
mz67odvpr | N(16,4) | mz67odvpr |  |
mz67odvorg | N(16,4) | mz67odvorg |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Přehled za pojišťovny za jednotlivé lidi - odpovídá kartě pracovníka | MZPOJIST mz01id | 1,1 : 0,M | MZKARTA mz01id |
Přehled za pojišťovny za jednotlivé lidi - odpovídá seznamu pojišťoven | MZPOJIST mz70idp | 1,1 : 0,M | MZPOJSEZ mz70idp |
Přehled za pojišťovny za jednotlivé lidi - odpovídá mzdovým položkám | MZPOJIST mz28id | 1,1 : 0,M | MZMZDPOL mz28id |

Indexy

Název | Primární | Výraz | Popis
ix_MZPOJIST_mz28id |  | mz28id | Jednoznačná identifikace mzdové položky
ix_MZPOJIST_mz70idp |  | mz70idp | Identifikace pojišťovny, např. 111, 121 ,...
ix_MZPOJIST_mz97ciszp |  | mz97ciszp | Číslo pojištěnce ve zdravotní pojišťovně. Uvádějte pouze je-li různé od rodného čísla.
ix_MZPOJIST_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZPOJIST_mzpojist |  | mz70idp, mz01id | mz70idp+mz01id


MZPOJSEZ Seznam zdravotních pojišťoven

Popis

Seznam zdravotních pojišťoven

Atributy

Atribut | Typ | Návěští | Message | Popis
mz70idp | C(3) | Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,... | Identifikace pojišťovny, např. 111, 121 ,...
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad02cisadr | C(2) | Adresa | Číslo adresy adresáta. | Číslo adresy adresáta. Program generuje automaticky. *** Dříve CISADR. C,1 !!!
ad03cisban | C(2) | Účet | Identifikátor spojení na bankovní účet adresáta. | Číslo spojení na bankovní účet adresáta. *** Dříve CISBANK.
ad11cisspo | C(2) | Spojení | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
mz70ks | C(4) | KS | Konstantní symbol | Konstantní symbol
mz70vs | C(10) | VS | Variabilní symbol | Variabilní symbol
mz70typ | N(1,0) | Typ pojišťovny | Typ pojišťovny | Typ pojišťovny - zdravotní, sociální
mz70pzam | N(5,2) | Odvod zaměstnanec (%) | Pojištění hrazené zaměstnancem (%). Je-li nulové, použije se údaj v legislativních konstantách. | Pojištění hrazené zaměstnancem (%)
mz70porg | N(5,2) | Odvod organizace (%) | Pojištění hrazené organizací (%). Je-li nulové, použije se údaj v legislativních konstantách. | Pojištění hrazené organizací (%)
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
mz70vymz | N(20,4) | Max. vyměřovací základ pro SP | Max. vyměřovací základ pro SP | Max. vyměřovací základ pro SP (cizozemská pojišťovna)
mz70typz | N(1,0) | Typ limitu | Typ limitu vyměřovacího základu | Typ limitu vyměřovacího základu
mz70pozn | M | Komentář | Komentář | Komentář

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Seznam zdravotních pojišťoven - má adresář | MZPOJSEZ ad01id | 1,1 : 0,M | ADADSAT ad01id |
Seznam zdravotních pojišťoven - má adresu | MZPOJSEZ ad01id ad02cisadr | 1,1 : 0,M | ADADR ad01id ad02cisadr |
Seznam zdravotních pojišťoven - má účty | MZPOJSEZ ad01id ad03cisban | 1,1 : 0,M | ADBUCTY ad01id ad03cisban |
Seznam zdravotních pojišťoven - sociální pojišťovna má měnu | MZPOJSEZ oc01id | 0,1 : 0,M | OCMENA oc01id |
Zdravotní pojišťovny a jejich přidělení - patří pracovníkovi | MZZDRPOJ mz70idp | 1,1 : 0,M | MZPOJSEZ mz70idp |
Pracovník - má zdravotní pojišťovnu | MZKARTA mz70idp | 1,1 : 0,M | MZPOJSEZ mz70idp |
Sumární přehled za pojišťovny - odpovídá zdravotní pojišťovně ze seznamu | MZPOJSUM mz70idp | 1,1 : 0,M | MZPOJSEZ mz70idp |
Přehled za pojišťovny za jednotlivé lidi - odpovídá seznamu pojišťoven | MZPOJIST mz70idp | 1,1 : 0,M | MZPOJSEZ mz70idp |

Indexy

Název | Primární | Výraz | Popis
ix_MZPOJSEZ_mz70idp | P | mz70idp | Identifikace pojišťovny, např. 111, 121 ,...
ix_MZPOJSEZ_ad01id |  | ad01id | Identifikace adresáta
ix_MZPOJSEZ_ad02cisadr |  | ad02cisadr | Číslo adresy adresáta. Program generuje automaticky.
ix_MZPOJSEZ_adadr1 |  | ad01id, ad02cisadr | Adresát + číslo adresy Pro zobrazení
ix_MZPOJSEZ_ad03cisban |  | ad03cisban | Číslo spojení na bankovní účet adresáta.
ix_MZPOJSEZ_ad11cisspo |  | ad11cisspo | Číslo spojení adresáta. Program generuje automaticky.
ix_MZPOJSEZ_adbucty1 |  | ad01id, ad03cisban | ad01id+ad03cisban
ix_MZPOJSEZ_oc01id |  | oc01id | Kód měny - oceňovací jednotky.
ix_MZPOJSEZ_mz70vymz |  | mz70vymz | Max. vyměřovací základ pro SP (cizozemská pojišťovna)


MZPOJSUM Sumární přehled za pojišťovny

Popis

Sumární přehled za pojišťovny

Atributy

Atribut | Typ | Návěští | Message | Popis
mz70idp | C(3) | Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,... | Identifikace pojišťovny, např. 111, 121 ,...
mz28druh | N(1,0) | Druh | Druh položky - příjem, náhrada mzdy,... | Druh položky - příjem, náhrada mzdy,... Tuto položku plní program, uživatel ji nemá možnost měnit!
mz28id | C(6) | Mzdová položka | Jednoznačná identifikace mzdové položky | Jednoznačná identifikace mzdové položky
mz02mesic | C(2) | Měsíc | Měsíc zpracování mezd | Měsíc zpracování mezd
mz02rok | C(4) | Rok | Rok zpracování mezd | Rok zpracování mezd
mz65pocet | N(6,0) | mz65pocet |  |
mz65zakl | N(16,4) | mz65zakl |  |
mz65odvpr | N(16,4) | mz65odvpr |  |
mz65odvorg | N(16,4) | mz65odvorg |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Sumární přehled za pojišťovny - odpovídá mzdové položce | MZPOJSUM mz28id | 1,1 : 0,M | MZMZDPOL mz28id |
Sumární přehled za pojišťovny - odpovídá zdravotní pojišťovně ze seznamu | MZPOJSUM mz70idp | 1,1 : 0,M | MZPOJSEZ mz70idp |

Indexy

Název | Primární | Výraz | Popis
ix_MZPOJSUM_mz70idp |  | mz70idp | Identifikace pojišťovny, např. 111, 121 ,...
ix_MZPOJSUM_mz28id |  | mz28id | Jednoznačná identifikace mzdové položky


MZPPHIS Historie prac. poměrů pracovníků

Popis

Objektem typu MZPPHIS je každý záznam, který obsahuje zpětný (historický) popis pracovního poměru pracovníka.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz01prijme | C(50) | Příjmení | Příjmení pracovníka | Příjmení pracovníka
mz01jmeno | C(50) | Jméno | Jméno pracovníka | Jméno pracovníka
mz01titul | C(15) | Titul | Titul pracovníka (před jménem) | Titul pracovníka (před jménem)
mz32cispp | C(2) | Číslo p.p. | Číslo pracovního poměru | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
mz25id | C(6) | Identifikace | Jednoznačná identifikace kalendáře | Jednoznačná identifikace kalendáře
mz23id | C(6) | Identifikace | Identifikace tarifní stupnice | Jednoznačná identifikace tarifní stupnice
mz24trida | C(2) | Třída | Tarifní třída (1-99) | Tarifní třída (1-99)
mz31id | C(6) | Identifikace | Identifikace pracovní funkce (zařazení) | Identifikace pracovní funkce (zařazení)
mz32nempoj | N(1,0) | Účast na n.p. | Zakládá pracovní poměr účast na nemocenském pojištění? | Pracovní poměr zakládá účast na nemocenském pojištění. Pokud nezakládá, nelze evidovat nemoci a nemocenské dávky. Pro potřebu kontroly FPD ve mzdách musí mzdová účetní zadat počet dnů nemoci bez Kč ručně.
mz32pojist | N(1,0) | Vztah k pojistnému na soc. zabezp. | Vztah k pojistnému na sociální zabezpečení |
mz32npzakl | N(3,0) | Denní vyměřovací základ | Denní vyměřovací základ nemocenského pojištění. | Denní vyměřovací základ nemocenského pojištění (redukovaný). Vznikne-li nemoc ve čtvrtletí, kdy pracovník nastoupil, musí mzdová účetní tento ukazatel ručně zadat.
mz32npzakd | N(9,2) | mz32npzakd | Denní vyměřovací základ neredukovaný | Denní vyměřovací základ neredukovaný
mz32pruhod | N(9,2) | Hodinový průměr | Hodinový průměr | Hodinový průměr Vznikne-li potřeba náhrady mzdy ve čtvrtletí, kdy pracovník nastoupil, musí mzdová účetní tento údaj ručně zadat.
mz32pruden | N(9,2) | Denní průměr | Denní průměr | Denní průměr Vznikne-li potřeba náhrady mzdy ve čtvrtletí, kdy pracovník nastoupil, musí mzdová účetní tento údaj ručně zadat.
mz32prumes | N(9,2) | Měsíční průměr | Měsíční průměr | Měsíční průměr Vznikne-li potřeba náhrady mzdy ve čtvrtletí, kdy pracovník nastoupil, musí mzdová účetní tento údaj ručně zadat.
mz32cislo1 | N(20,4) | Volné číslo I | Volně použitelné číslo |
mz32cislo2 | N(20,4) | Volné číslo II | Volně použitelné číslo |
mz32cislo3 | N(20,4) | Volné číslo III | Volně použitelné číslo |
mz32dovnov | N(6,2) | Zůstatek nové dovolené | Zůstatek nové dovolené | Zůstatek nové dovolené
mz32dovsta | N(6,2) | Zůstatek staré dovolené | Zůstatek staré dovolené | Zůstatek staré dovolené
mz32vypodv | D | Datum odvolání výpovědi | Datum odvolání výpovědi | Datum odvolání výpovědi
mz32vypdor | D | Datum doručení výpovědi | Datum doručení výpovědi nebo datum uzavření dohody rozvázání pracovního poměru | Datum doručení výpovědi
mz45rok | C(4) | mz45rok | Rok zpracováných mezd | Rok zpracováných mezd
mz45mesic | C(2) | mz45mesic | Měsíc zpracováných mezd | Měsíc zpracováných mezd
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.

Indexy

Název | Primární | Výraz | Popis
ix_MZPPHIS_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZPPHIS_mz32cispp |  | mz32cispp | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
ix_MZPPHIS_mz25id |  | mz25id | Jednoznačná identifikace kalendáře
ix_MZPPHIS_mz23id |  | mz23id | Jednoznačná identifikace tarifní stupnice
ix_MZPPHIS_mz24trida |  | mz24trida | Tarifní třída (1-99)
ix_MZPPHIS_mz31id |  | mz31id | Identifikace pracovní funkce (zařazení)
ix_MZPPHIS_mztartri1 |  | mz23id, mz24trida | mz23id + mz24trida
ix_MZPPHIS_mzpphis1 | P | mz45rok, mz45mesic, mz01id, mz32cispp | mz45rok+mz45mesic+mz01id+mz32cispp
ix_MZPPHIS_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_MZPPHIS_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_MZPPHIS_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.


MZPRACFU Pracovní funkce - skutečné a typové

Popis

Objektem typu MZPRACFU je každý záznam, který obsahuje popis pracovního funkce (zařazení).
Pracovním zařazením se zde rozumí pracovní místo v organizaci (funkce).

Atributy

Atribut | Typ | Návěští | Message | Popis
mz31id | C(6) | Identifikace | Identifikace pracovní funkce (zařazení) | Identifikace pracovní funkce (zařazení)
mz31pracfu | C(40) | Prac.funkce | Popis pracovní funkce (pracovního zařazení) | Popis pracovní funkce - zařazení (pracovního místa)
mz31kzam | C(5) | Tř. KZAM | Třída podle klasifikace zaměstnání |
mz25id | C(6) | Identifikace | Jednoznačná identifikace kalendáře | Jednoznačná identifikace kalendáře
mz23id | C(6) | Identifikace | Identifikace tarifní stupnice | Jednoznačná identifikace tarifní stupnice
mz24trida | C(2) | Třída | Tarifní třída (1-99) | Tarifní třída (1-99)
mz79id | C(6) | Umístění | Identifikace umístění mezd | Identifikace umístění mezd
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
mz31koment | M | Komentář | Komentář k popisu pracovního místa | Komentář k popisu pracovního místa
mz31 | C(12) | mz31 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
mz31typ | N(1,0) | Typ | Typ pracovního místa | Typ pracovního místa
mz31idt | C(6) | Typové místo | Identifikace typové pracovní funkce (zařazení) | Identifikace typové pracovní funkce (zařazení)
mz31stav | N(1,0) | Stav | Stav | Stav pracovního místa
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
pa01id | C(6) | Sada | Identifikátor sady parametrů | Identifikátor sady parametrů
pa01oblast | C(2) | Oblast | Oblast sady parametrů | Oblast sady parametrů
mz31odmen | N(1,0) | Typ mzdy | Způsob odměňování - typ mzdy (měsíční, hodinová, ....) |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Pracovní funkce - skutečné a typové - má kalendář | MZPRACFU mz25id | 1,1 : 0,M | MZKALEN mz25id |
Pracovní funkce - skutečné a typové - má tarifní stupnici | MZPRACFU mz23id | 1,1 : 0,M | MZTARSTU mz23id |
Pracovní funkce - skutečné a typové - má tarifní třídu | MZPRACFU mz23id mz24trida | 1,1 : 0,M | MZTARTRI mz23id mz24trida |
Pracovní funkce - skutečné a typové - zapsal uživatel | MZPRACFU bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Pracovní funkce - skutečné a typové - má umístění | MZPRACFU mz79id | 1,1 : 0,M | MZUMIST mz79id |
Pracovní funkce - skutečné a typové - skutečné místo může mít jedno typové | MZPRACFU mz31idt | 0,1 : 0,M | MZPRACFU mz31id |
Pracovní funkce - skutečné a typové - používá sadu parametrů | MZPRACFU pa01id pa01oblast | 1,1 : 0,M | PASADA pa01id pa01oblast |
Řešitel projektového úkolu - má pracovní funkci | NKZDROJ mz31id | 1,1 : 0,M | MZPRACFU mz31id |
Hodnoty požadavků a vlastností - patří k pracovnímu místu | MZPERS2 mz31id | 1,1 : 0,M s rušením | MZPRACFU mz31id |
Pracovník obsluhy výrobní linky/stroje ve směně s profesí - určuje pracovní funkci | TPLINKAP mz31id | 1,1 : 0,M s rušením | MZPRACFU mz31id |
Událost personalistiky - má skutečné pracovní místo | MZPERUDA mz31id | 0,1 : 0,M | MZPRACFU mz31id |
Pracovní funkce - skutečné a typové - skutečné místo může mít jedno typové | MZPRACFU mz31idt | 0,1 : 0,M | MZPRACFU mz31id |
Pracovní poměr - má pracovní zařazení | MZPRACPO mz31id | 1,1 : 0,M | MZPRACFU mz31id |
Pracovní výkon - je ve mzdách | TPPROFOP mz31id | 1,1 : 0,M | MZPRACFU mz31id |

Indexy

Název | Primární | Výraz | Popis
ix_MZPRACFU_mz31id | P | mz31id | Identifikace pracovní funkce (zařazení)
ix_MZPRACFU_mz31pracfu |  | mz31pracfu | Popis pracovní funkce - zařazení (pracovního místa)
ix_MZPRACFU_mz31kzam |  | mz31kzam |
ix_MZPRACFU_mz25id |  | mz25id | Jednoznačná identifikace kalendáře
ix_MZPRACFU_mz23id |  | mz23id | Jednoznačná identifikace tarifní stupnice
ix_MZPRACFU_mz24trida |  | mz24trida | Tarifní třída (1-99)
ix_MZPRACFU_mz79id |  | mz79id | Identifikace umístění mezd
ix_MZPRACFU_mztartri1 |  | mz23id, mz24trida | mz23id + mz24trida
ix_MZPRACFU_mz31 | U | mz31 | Jednoznačná časová identifikace
ix_MZPRACFU_mz31idt |  | mz31idt | Identifikace typové pracovní funkce (zařazení)
ix_MZPRACFU_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_MZPRACFU_pasada |  | pa01id, pa01oblast | PI - pa01id+pa01oblast


MZPRACPO Pracovní poměr

Popis

Objektem typu MZPRACPO je každý záznam, který obsahuje popis pracovního poměru pracovníka.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz32 | C(12) | JČI | Jednoznačná časová identifikace | Jednoznačná časová identifikace
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz32cispp | C(2) | Číslo p.p. | Číslo pracovního poměru | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
mz32druh | N(1,0) | Druh | Druh pracovního poměru | Výčet druhů pracovních poměrů. Pro výpočet mezd nemá žádný význam.
mz25id | C(6) | Identifikace | Jednoznačná identifikace kalendáře | Jednoznačná identifikace kalendáře
mz23id | C(6) | Identifikace | Identifikace tarifní stupnice | Jednoznačná identifikace tarifní stupnice
mz24trida | C(2) | Třída | Tarifní třída (1-99) | Tarifní třída (1-99)
mz31id | C(6) | Identifikace | Identifikace pracovní funkce (zařazení) | Identifikace pracovní funkce (zařazení)
mz82id | C(6) | Typové pracovní místo | Jednoznačná identifikace typové pracovní funkce (zařazení) | Jednoznačná identifikace pracovní funkce (zařazení)
mz31odmen | N(1,0) | Typ mzdy | Způsob odměňování - typ mzdy (měsíční, hodinová, ....) |
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
mz32nempoj | N(1,0) | Účast na n.p. | Zakládá pracovní poměr účast na nemocenském pojištění? | Pracovní poměr zakládá účast na nemocenském pojištění. Pokud nezakládá, nelze evidovat nemoci a nemocenské dávky. Pro potřebu kontroly FPD ve mzdách musí mzdová účetní zadat počet dnů nemoci bez Kč ručně.
mz32npzakl | N(3,0) | Denní vyměřovací základ | Denní vyměřovací základ nemocenského pojištění. | Denní vyměřovací základ nemocenského pojištění (redukovaný). Vznikne-li nemoc ve čtvrtletí, kdy pracovník nastoupil, musí mzdová účetní tento ukazatel ručně zadat.
mz32npzakd | N(9,2) | Denní vyměřovací základ 2008 (poslední hodnota platná pro 12/2008) | Denní vyměřovací základ nemocenského pojištění neredukovaný. | Denní vyměřovací základ neredukovaný
mz32skonpp | D | Skončení p.p. | Skončení prac. poměru | Skončení prac. poměru Po skončení prac. poměru lze mzdu vyplácet, ale do mezd se nepřenáší pravidelné příjmy, nezdanitelné položky, půjčky ani srážky. Nemocenské dávky lze vyplácet.
mz32duvod | C(40) | Důvod ukončení p.p. | Důvod ukončení pracovního poměru | Důvod ukončení pracovního poměru
mz32vznipp | D | Vznik p.p. | Vznik prac. poměru | Vznik prac. poměru
mz32urcuji | N(1,0) | Určující | Jedná se o určující prac.pom. (při více prac.poměrech)? | Při více pracovních poměrech jsou na výplatním lístku určujícího pracovního poměru soustředěny nezdanitelné položky, je zde vypočtena daň, čistý příjem, srážky a k výplatě. Na ostatních výplatních lístcích jsou uvedeny pouze příjmy a odvody zdravotního a sociálního pojištění.
mz32dovnar | N(6,2) | Roční nárok na dovolenou | Roční nárok na dovolenou. | Roční nárok na dovolenou
mz32dovsta | N(6,2) | Zůstatek staré dovolené | Zůstatek staré dovolené | Zůstatek staré dovolené
mz32dovnov | N(6,2) | Zůstatek nové dovolené | Zůstatek nové dovolené | Zůstatek nové dovolené
mz32dovmin | N(6,2) | Zůstatek dovolené z minulého roku | Zůstatek dovolené z minulého roku | Zůstatek dovolené z minulého roku
mz32dovpre | N(6,2) | Převod dovolené do příštího roku | Převod dovolené do příštího roku | Převod dovolené do příštího roku
mz32pruhod | N(9,2) | Hodinový průměr | Hodinový průměr | Hodinový průměr Vznikne-li potřeba náhrady mzdy ve čtvrtletí, kdy pracovník nastoupil, musí mzdová účetní tento údaj ručně zadat.
mz32pruden | N(9,2) | Denní průměr | Denní průměr | Denní průměr Vznikne-li potřeba náhrady mzdy ve čtvrtletí, kdy pracovník nastoupil, musí mzdová účetní tento údaj ručně zadat.
mz32prumes | N(9,2) | Měsíční průměr | Měsíční průměr | Měsíční průměr Vznikne-li potřeba náhrady mzdy ve čtvrtletí, kdy pracovník nastoupil, musí mzdová účetní tento údaj ručně zadat.
mz32zkuseb | D | Zkušební lhůta | Datum ukončení zkušební lhůty | Datum ukončení zkušební lhůty
mz32cislo1 | N(20,4) | Volné číslo I | Volně použitelné číslo |
mz32cislo2 | N(20,4) | Volné číslo II | Volně použitelné číslo |
mz32cislo3 | N(20,4) | Volné číslo III | Volně použitelné číslo |
mz32datum1 | D | Volné datum I | Volně použitelné datum | Datum doručení výpovědiVolně použitelné datum
mz32pojist | N(1,0) | Vztah k pojistnému na soc. zabezp. | Vztah k pojistnému na sociální zabezpečení |
mz32vypdor | D | Datum doručení výpovědi | Datum doručení výpovědi nebo datum uzavření dohody rozvázání pracovního poměru | Datum doručení výpovědi
mz32vypodv | D | Datum odvolání výpovědi | Datum odvolání výpovědi | Datum odvolání výpovědi
mz32nazev | C(100) | Alias | Název pracovníka v pracovním poměru (alias) | Název pracovníka v pracovním poměru (alias)

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Pracovní poměr - má kalendář | MZPRACPO mz25id | 1,1 : 0,M | MZKALEN mz25id |
Pracovní poměr - má pracovní zařazení | MZPRACPO mz31id | 1,1 : 0,M | MZPRACFU mz31id |
Pracovní poměr - má tarifní třídu | MZPRACPO mz23id mz24trida | 1,1 : 0,M | MZTARTRI mz23id mz24trida |
Pracovní poměr - má tarifní stupnici | MZPRACPO mz23id | 1,1 : 0,M | MZTARSTU mz23id |
Pracovní poměr - odpovídá pracovníkovi | MZPRACPO mz01id | 1,1 : 0,M s rušením | MZKARTA mz01id |
Pracovní poměr - má organizační selektor | MZPRACPO sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Pracovní poměr - má technicko věcný selektor | MZPRACPO sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Mzda - z pracovního poměru | MZMZDY mz01id mz32cispp | 1,1 : 0,M | MZPRACPO mz01id mz32cispp |
Pravidelná mzdová položka - patří k pracovnímu poměru pracovníka | MZMZDPPV mz01id mz32cispp | 1,1 : 0,M s rušením | MZPRACPO mz01id mz32cispp |
Nemoc - souvisí s pracovním poměrem | MZNEMOC mz01id mz32cispp | 1,1 : 0,M s rušením | MZPRACPO mz01id mz32cispp |
Událostní entita mezd - váže na pracovní poměry pracovníka | MZUDALOS mz01id mz32cispp | 1,1 : 0,M | MZPRACPO mz01id mz32cispp |
Mzdový list - má pracovní poměr | MZDLIST mz01id mz32cispp | 1,1 : 0,1 | MZPRACPO mz01id mz32cispp |
Úkolové listy - z pracovního poměru | MZUKOLLI mz01id mz32cispp | 1,1 : 0,M | MZPRACPO mz01id mz32cispp |
Charaktery pracovníka v prac. poměru - odpovídají prac. poměru pracovníka | MZCHARPP mz01id mz32cispp | 1,1 : 0,M s rušením | MZPRACPO mz01id mz32cispp |

Indexy

Název | Primární | Výraz | Popis
ix_MZPRACPO_mz32 | U | mz32 | Jednoznačná časová identifikace
ix_MZPRACPO_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZPRACPO_mz25id |  | mz25id | Jednoznačná identifikace kalendáře
ix_MZPRACPO_mz23id |  | mz23id | Jednoznačná identifikace tarifní stupnice
ix_MZPRACPO_mz24trida |  | mz24trida | Tarifní třída (1-99)
ix_MZPRACPO_mz31id |  | mz31id | Identifikace pracovní funkce (zařazení)
ix_MZPRACPO_mz82id |  | mz82id | Jednoznačná identifikace pracovní funkce (zařazení)
ix_MZPRACPO_mz31odmen |  | mz31odmen |
ix_MZPRACPO_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_MZPRACPO_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_MZPRACPO_mzpracpo1 | P | mz01id, mz32cispp | mz01id + mz32cispp
ix_MZPRACPO_mztartri1 |  | mz23id, mz24trida | mz23id + mz24trida


MZPROTAL Algoritmus výpočtu položky protokolu při výpočtu mezd

Popis

Algoritmus výpočtu položky protokolu při výpočtu mezd

Atributy

Atribut | Typ | Návěští | Message | Popis
mza3id | C(6) | Algoritmus | Identifikace algoritmu | Identifikace algoritmu
mza3nazalg | C(40) | Název algoritmu | Název algoritmu | Název algoritmu
spa6id | C(6) | Druh | Identifikace druhu implemetačního rozšíření | Identifikace druhu implemetačního rozšíření
mza3typ | N(1,0) | Typ | Typ algoritmu | Typ algoritmu
mza3kod | M | Kód | Kód algoritmu v jazyce Foxpro | Kód algoritmu v jazyce Foxpro
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace
mza3koment | M | Poznámka | Poznámka | Poznámka
mza3verze | N(8,3) | Verze | Verze algoritmů protokolu | Verze algoritmů protokolu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Algoritmus výpočtu položky protokolu při výpočtu mezd - je druhu | MZPROTAL spa6id | 1,1 : 0,M | SPCINDVT spa6id |
Užití algoritmu výpočtu položky protokolu při výpočtu mezd - se týká algoritmu | MZPROTAU mza3id | 1,1 : 0,1 s rušením | MZPROTAL mza3id |
Popis verzí algoritmů protokolu - je popisem verze algoritmů protokolu | MZPRVTAL mza3id | 1,1 : 0,M | MZPROTAL mza3id |

Indexy

Název | Primární | Výraz | Popis
ix_MZPROTAL_mza3id | P | mza3id | Identifikace algoritmu
ix_MZPROTAL_mza3nazalg |  | mza3nazalg | Název algoritmu
ix_MZPROTAL_spa6id |  | spa6id | Identifikace druhu implemetačního rozšíření
ix_MZPROTAL_mza3verze |  | mza3verze | Verze algoritmů protokolu


MZPROTAU Užití algoritmu výpočtu položky protokolu při výpočtu mezd

Atributy

Atribut | Typ | Návěští | Message | Popis
mza3id | C(6) | Algoritmus | Identifikace algoritmu | Identifikace algoritmu
mza4proved | N(1,0) | Provádět | Provádět algoritmus Ano/Ne | Provádět algoritmus Ano/Ne
mza4prior | N(5,0) | mza4prior | Priorita zobrazení v protokolu | Priorita zobrazení v protokolu
mza4stupen | N(1,0) | Stupeň | Stupeň významnosti položky protokolu Informace / Chyba zpracování | Stupeň významnosti položky protokolu Informace / Chyba zpracování
mza4koment | M | Poznámka | Poznámka | Poznámka
bw95id | C(6) | Barva | Identifikace barvy RGB | Identifikace barvy RGB
bw95id2 | C(6) | Barva | Identifikace barvy RGB | Identifikace barvy RGB
mza4skryta | N(1,0) | Skrytá | Skrytá položka protokolu Ano / Ne | Skrytá položka protokolu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Užití algoritmu výpočtu položky protokolu při výpočtu mezd - se týká algoritmu | MZPROTAU mza3id | 1,1 : 0,1 s rušením | MZPROTAL mza3id |
Užití algoritmu výpočtu položky protokolu při výpočtu mezd - určuje zobrazení barvou v popředí protokolu | MZPROTAU bw95id | 1,1 : 0,M | BWRGBCOL bw95id |
Užití algoritmu výpočtu položky protokolu při výpočtu mezd - určuje zobrazení barvou v pozadí protokolu | MZPROTAU bw95id2 | 1,1 : 0,M | BWRGBCOL bw95id |

Indexy

Název | Primární | Výraz | Popis
ix_MZPROTAU_mza3id | P | mza3id | Identifikace algoritmu
ix_MZPROTAU_bw95id |  | bw95id | Identifikace barvy RGB
ix_MZPROTAU_bw95id2 |  | bw95id2 | Identifikace barvy RGB


MZPROTHL Hlavička protokolu

Popis

Objektem typu MZPROTHL je každý záznam, který obsahuje údaj protokolu, který vznikl při výpočtu mezd.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz03poradi | N(10,0) | Pořadové číslo | Absolutní pořadové číslo výpočtu | Pořadové číslo výpočtu - absolutní
mz03typ | N(1,0) | Typ hlavičky | Typ hlavičky protokolu | Typ hlavičky protokolu - způsob vzniku protokolu Způsoby : Výpočet,Uzávěrka,Přepočet průměrů h/d/m,Přepočet pro nepřítomnosti v rok/měsíc,Zákonné pojištění odpov. v rok/měsíc
mz03pozn | M | Poznámka | Poznámka | Poznámka
mz27datmzd | D | Poslední zpracované mzdy k datu | Datum, ke kterému jsou spočteny poslední mzdy. | Měsíc a rok, pro který se zpracovávají mzdy.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
mz03obdobi | C(7) | Období | Výpočet/uzávěrka proběhl za odbobí rok/měsíc |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Hlavička protokolu - zapsána pracovníkem | MZPROTHL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Položky protokolu k hlavičce protokolu - patří k hlavičce protokolu | MZPROTPL mz03poradi | 1,1 : 0,M s rušením | MZPROTHL mz03poradi |

Indexy

Název | Primární | Výraz | Popis
ix_MZPROTHL_mz03poradi | P | mz03poradi | Pořadové číslo výpočtu - absolutní
ix_MZPROTHL_mz03typ |  | mz03typ | Typ hlavičky protokolu - způsob vzniku protokolu Způsoby : Výpočet,Uzávěrka,Přepočet průměrů h/d/m,Přepočet pro nepřítomnosti v rok/měsíc,Zákonné pojištění odpov. v rok/měsíc
ix_MZPROTHL_mz27datmzd |  | mz27datmzd | Měsíc a rok, pro který se zpracovávají mzdy.
ix_MZPROTHL_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_MZPROTHL_sp00datzap |  | sp00datzap | Datum a čas zápisu záznamu události
ix_MZPROTHL_mz03obdobi |  | mz03obdobi |


MZPROTOK Protokol

Popis

Objektem typu MZPROTOK je každý záznam, který obsahuje údaj protokolu, který vznikl při výpočtu mezd.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz43id | C(12) | JČI | Jednoznačná časová identifikace. | Jednoznačná časová identifikace.
mz43text | M | Protokol | Text protokolu | Text protokolu

Indexy

Název | Primární | Výraz | Popis
ix_MZPROTOK_mz43id | P | mz43id | Jednoznačná časová identifikace.


MZPROTPL Položky protokolu k hlavičce protokolu

Popis

Objektem typu MZPROTPL je každý záznam, který obsahuje údaj protokolu, který vznikl při výpočtu mezd.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz03poradi | N(10,0) | Pořadové číslo | Absolutní pořadové číslo výpočtu | Pořadové číslo výpočtu - absolutní
mz04poradi | N(5,0) | Pořadové číslo | Pořadové číslo jednotlivého hlášení v rámci hlavičky. | Pořadové číslo jednotlivého hlášení v rámci hlavičky.
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz32cispp | C(2) | Číslo p.p. | Číslo pracovního poměru | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
mz04id | C(6) | Položka | Identifikace položky | Identifikace položky
mz04popis | C(40) | Popis | Popis hlášení | Popis hlášení
mz04pozn | M | Text hlášení | Text hlášení | Text hlášení
mz04pozn2 | M | Poznámka uživatele | Poznámka uživatele | Poznámka uživatele

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Položky protokolu k hlavičce protokolu - patří k hlavičce protokolu | MZPROTPL mz03poradi | 1,1 : 0,M s rušením | MZPROTHL mz03poradi |
Položky protokolu k hlavičce protokolu - mají pracovníka | MZPROTPL mz01id | 1,1 : 0,M | MZKARTA mz01id |

Indexy

Název | Primární | Výraz | Popis
ix_MZPROTPL_mzprotpl | P | mz03poradi, mz04poradi |
ix_MZPROTPL_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZPROTPL_mz32cispp |  | mz32cispp | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
ix_MZPROTPL_mzpracpo1 |  | mz01id, mz32cispp | mz01id + mz32cispp
ix_MZPROTPL_mz04id |  | mz04id | Identifikace položky
ix_MZPROTPL_mz04poradi |  | mz04poradi | Pořadové číslo jednotlivého hlášení v rámci hlavičky.
ix_MZPROTPL_mz03poradi |  | mz03poradi | Pořadové číslo výpočtu - absolutní


MZPRVTAL Popis verzí algoritmů protokolu

Popis

Popis verzí algoritmů protokolu

Atributy

Atribut | Typ | Návěští | Message | Popis
mza3id | C(6) | Algoritmus | Identifikace algoritmu | Identifikace algoritmu
mza3verze | N(8,3) | Verze | Verze algoritmů protokolu | Verze algoritmů protokolu
mzb1dne | D | mzb1dne | Datum záznamu o verzi | Datum záznamu o verzi
sp00jmeakt | C(40) | Změnil | Jméno uživatele systému, který změnil záznam | Jméno uživatele systému, který změnil záznam
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace
mzb1koment | M | mzb1koment | Popis verze | Popis verze

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis verzí algoritmů protokolu - je popisem verze algoritmů protokolu | MZPRVTAL mza3id | 1,1 : 0,M | MZPROTAL mza3id |

Indexy

Název | Primární | Výraz | Popis
ix_MZPRVTAL_mzprvtal | P | mza3id, mza3verze |
ix_MZPRVTAL_mza3id |  | mza3id | Identifikace algoritmu


MZSOCPOJ Přehled sociálního pojištění za jednotlivé lidi

Popis

### as select MZMZDY.mz28id,MZMZDY.mz02mesic,MZMZDY.mz02rok,MZMZDY.mz01id,MZMZDY.mz32cispp,
cast (1*(if MZMZDY.mz28id='I20000' then (MZMZDY.mz02kc) else 0 endif)as decimal (20,4)) mz68zaklsp,
cast (1*(if MZMZDY.mz28id='I21000' then (MZMZDY.mz02kc) else 0 endif)as decimal (20,4)) mz68odvpr,
cast (1*(if MZMZDY.mz28id='I31000' then (MZMZDY.mz02kc) else 0 endif)as decimal (20,4)) mz68odvorg,
(SELECT SUM(MZMZDY.mz02dnu) as mz68dnune FROM %%%.MZMZDY
WHERE (MZKARTA.mz01id=MZMZDY.mz01id AND
MZMZDY.mz28id='N11000') ),
(SELECT SUM(MZMZDY.mz02kc) as mz68kcne FROM %%%.MZMZDY
WHERE (MZKARTA.mz01id=MZMZDY.mz01id AND
MZMZDY.mz28id='N11000') ),
(SELECT SUM(MZMZDY.mz02dnu) as mz68dnuos FROM %%%.MZMZDY
WHERE (MZKARTA.mz01id=MZMZDY.mz01id AND
MZMZDY.mz28id='N21000') ),
(SELECT SUM(MZMZDY.mz02kc) as mz68kcos FROM %%%.MZMZDY
WHERE (MZKARTA.mz01id=MZMZDY.mz01id AND
MZMZDY.mz28id='N21000') ),
(SELECT SUM(MZMZDY.mz02dnu) as mz68dnuvp FROM %%%.MZMZDY
WHERE (MZKARTA.mz01id=MZMZDY.mz01id AND
MZMZDY.mz28id='N30000') ),
(SELECT SUM(MZMZDY.mz02kc) as mz68kcvp FROM %%%.MZMZDY
WHERE (MZKARTA.mz01id=MZMZDY.mz01id AND
MZMZDY.mz28id='N30000') ),
(SELECT SUM(MZMZDY.mz02dnu) as mz68dnumd FROM %%%.MZMZDY
WHERE (MZKARTA.mz01id=MZMZDY.mz01id AND
MZMZDY.mz28id='N41000') ),
(SELECT SUM(MZMZDY.mz02kc) as mz68kcmd FROM %%%.MZMZDY
WHERE (MZKARTA.mz01id=MZMZDY.mz01id AND
MZMZDY.mz28id='N41000') )
from %%%.MZKARTA,%%%.MZMZDY
where MZKARTA.mz01id=MZMZDY.mz01id

Atributy

Atribut | Typ | Návěští | Message | Popis
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz32cispp | C(2) | Číslo p.p. | Číslo pracovního poměru | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
mz28id | C(6) | Mzdová položka | Jednoznačná identifikace mzdové položky | Jednoznačná identifikace mzdové položky
mz02mesic | C(2) | Měsíc | Měsíc zpracování mezd | Měsíc zpracování mezd
mz02rok | C(4) | Rok | Rok zpracování mezd | Rok zpracování mezd
mz68zaklsp | N(16,4) | mz68zaklsp | Základ sociálního pojištění | Základ sociálního pojištění
mz68odvpr | N(16,4) | mz68odvpr | Odvod sociálního pojištění pracovník | Odvod sociálního pojištění pracovník
mz68odvorg | N(16,4) | mz68odvorg | Odvod sociálního pojištění - organizace | Odvod sociálního pojištění - organizace
mz68dnuNE | N(3,0) | mz68dnuNE | Kalendářních dnů nemoci, proplacených dnů nemoci | Kalendářních dnů nemoci, proplacených dnů nemoci
mz68dnuos | N(3,0) | Ošetřování -kal. dnů | Kalendářních dnů ošetřování | Kalendářních dnů ošetřování
mz68dnuvp | N(3,0) | Vyr. př. - kal. dnů | Počet případů vyrovnávacích příspěvků | Počet případů vyrovnávacích příspěvků
mz68dnumd | N(3,0) | MD - kal. dnů | Počet případů mateřské dovolené | Počet případů mateřské dovolené
mz68 | C(12) | JČI | Jednoznačná časová identifikace | Jednoznačná časová identifikace
mz68kcne | N(6,0) | Kč | Proplacená dávka za nemoc | Proplacená dávka za nemoc
mz68kcos | N(6,0) | Kč | Proplacená dávka za ošetřování | Proplacená dávka za ošetřování
mz68kcvp | N(6,0) | Kč | Proplacená dávka za vyrovnávací příspěvek | Proplacená dávka za vyrovnávací příspěvek
mz68kcmd | N(6,0) | Kč | Proplacená dávka za mateřskou dovolenou | Proplacená dávka za mateřskou dovolenou

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Přehled sociálního pojištění za jednotlivé lidi - odpovídá pracovníkům | MZSOCPOJ mz01id | 1,1 : 0,M | MZKARTA mz01id |

Indexy

Název | Primární | Výraz | Popis
ix_MZSOCPOJ_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZSOCPOJ_mz32cispp |  | mz32cispp | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
ix_MZSOCPOJ_mz28id |  | mz28id | Jednoznačná identifikace mzdové položky
ix_MZSOCPOJ_mzsocpoj1 |  | mz01id, mz32cispp | mz01id+mz32cispp


MZTARSTU Stupnice zahrnuje

Popis

Objektem typu MZTARSTU je každý záznam, který obsahuje identifikaci a popis vnitrofiremní tarifní stupnice

Atributy

Atribut | Typ | Návěští | Message | Popis
mz23id | C(6) | Identifikace | Identifikace tarifní stupnice | Jednoznačná identifikace tarifní stupnice
mz23popis | C(20) | Popis | Popis tarifní stupnice | Popis tarifní stupnice
mz23koment | M | Komentář | Komentář k tarifní stupnici | Komentář k tarifní stupnici
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Stupnice zahrnuje - vytvořena uživatelem | MZTARSTU bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Tarifní třída - patří do stupnice | MZTARTRI mz23id | 1,1 : 1,M s rušením | MZTARSTU mz23id |
Úkolová mzda tarifní - odpovída tarifní stupnici | MZUKOLTA mz23id | 1,1 : 0,M | MZTARSTU mz23id |
Pracovní funkce - skutečné a typové - má tarifní stupnici | MZPRACFU mz23id | 1,1 : 0,M | MZTARSTU mz23id |
Pracovní poměr - má tarifní stupnici | MZPRACPO mz23id | 1,1 : 0,M | MZTARSTU mz23id |

Indexy

Název | Primární | Výraz | Popis
ix_MZTARSTU_mz23id | P | mz23id | Jednoznačná identifikace tarifní stupnice
ix_MZTARSTU_mz23popis |  | mz23popis | Popis tarifní stupnice


MZTARTRI Tarifní třída

Popis

Objektem typu MZTARTRI je každý záznam, který obsahuje hodinovou a měsíční minimální mzdu pro konkrétní tarifní třídu.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz23id | C(6) | Identifikace | Identifikace tarifní stupnice | Jednoznačná identifikace tarifní stupnice
mz24trida | C(2) | Třída | Tarifní třída (1-99) | Tarifní třída (1-99)
mz24hodmzd | N(8,2) | Sazba | Firemní mzda hodinová | Firemní mzda hodinová
mz24minmzd | N(5,0) | Min. měsíční mzda | Minimální mzda měsíční | Minimální mzda měsíční
mz24komen | M | Komentář | Komentář | Komentář k tarifním třídám
ob11id | C(3) | Skupina | Identifikace cenové skupiny | Identifikace cenové skupiny
mz24text1 | C(40) | Text | Volný text |
mz24cislo1 | N(20,4) | Volné číslo | Volné číslo 1 |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Tarifní třída - má cenovou skupinu | MZTARTRI ob11id | 1,1 : 0,M | OBCENSKP ob11id |
Tarifní třída - patří do stupnice | MZTARTRI mz23id | 1,1 : 1,M s rušením | MZTARSTU mz23id |
Úkolová mzda tarifní - má tarifní třídu | MZUKOLTA mz23id mz24trida | 1,1 : 0,M | MZTARTRI mz23id mz24trida |
Pracovní funkce - skutečné a typové - má tarifní třídu | MZPRACFU mz23id mz24trida | 1,1 : 0,M | MZTARTRI mz23id mz24trida |
Pracovní poměr - má tarifní třídu | MZPRACPO mz23id mz24trida | 1,1 : 0,M | MZTARTRI mz23id mz24trida |

Indexy

Název | Primární | Výraz | Popis
ix_MZTARTRI_mz23id |  | mz23id | Jednoznačná identifikace tarifní stupnice
ix_MZTARTRI_mz24trida |  | mz24trida | Tarifní třída (1-99)
ix_MZTARTRI_ob11id |  | ob11id | Identifikace cenové skupiny
ix_MZTARTRI_mztartri1 | P | mz23id, mz24trida | mz23id + mz24trida
ix_MZTARTRI_mz24text1 |  | mz24text1 |
ix_MZTARTRI_mz24cislo1 |  | mz24cislo1 |


MZUDALOS Událostní entita mezd

Atributy

Atribut | Typ | Návěští | Message | Popis
mz41 | C(12) | JČI | Jednoznačná časová identifikace |
mz41datum | D | Datum | Datum zpracovaných mezd | Datum právě zpracovaných a přenášených mezd
mz41text | C(40) | Popis | Popis události mzdové komponenty | Popis události mzdové komponenty
mz28id | C(6) | Mzdová položka | Jednoznačná identifikace mzdové položky | Jednoznačná identifikace mzdové položky
uc01id | C(9) | Účet | Identifikátor účtu účetnictví | Identifikátor účtu
uc01strana | N(1,0) | uc01strana | Strana účtu MD/Dal | Strana účtu MD/Dal
mz41kc | N(16,2) | Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.) | Celková částka v Kč (mzda, daň, srážka, ..., ap.) Aktuální hodnota
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz32cispp | C(2) | Číslo p.p. | Číslo pracovního poměru | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
mz79id | C(6) | Umístění | Identifikace umístění mezd | Identifikace umístění mezd
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad02cisadr | C(2) | Adresa | Číslo adresy adresáta. | Číslo adresy adresáta. Program generuje automaticky. *** Dříve CISADR. C,1 !!!
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
ad03cisban | C(2) | Účet | Identifikátor spojení na bankovní účet adresáta. | Číslo spojení na bankovní účet adresáta. *** Dříve CISBANK.
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
mz41typuda | N(1,0) | Typ | Typ mzdové události, dle způsobu pokračování | Typ mzdové události, dle způsobu pokračování
mz41ksymb | C(4) | KS | Konstantní symbol | Konstantní symbol
mz41vsymb | C(10) | VS | Variabilní symbol | Variabilní symbol
mz41pozn | C(40) | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událostní entita mezd - má obchodní selektor | MZUDALOS sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událostní entita mezd - má organizační selektor | MZUDALOS sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událostní entita mezd - má technicko-vědecký selektor | MZUDALOS sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událostní entita mezd - má adresáta | MZUDALOS ad01id | 0,1 : 0,M | ADADSAT ad01id |
Událostní entita mezd - má bankovní spojení | MZUDALOS ad01id ad03cisban | 0,1 : 0,M | ADBUCTY ad01id ad03cisban |
Událostní entita mezd - zapsal uživatel | MZUDALOS bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událostní entita mezd - patří do fyzické operace | MZUDALOS sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událostní entita mezd - má pracovníka | MZUDALOS mz01id | 1,1 : 0,M | MZKARTA mz01id |
Událostní entita mezd - obsahuje mzdovou položku | MZUDALOS mz28id | 1,1 : 0,M | MZMZDPOL mz28id |
Událostní entita mezd - váže na pracovní poměry pracovníka | MZUDALOS mz01id mz32cispp | 1,1 : 0,M | MZPRACPO mz01id mz32cispp |
Událostní entita mezd - má umístění | MZUDALOS mz79id | 1,1 : 0,M | MZUMIST mz79id |
Událostní entita mezd - má adresu | MZUDALOS ad01id ad02cisadr | 0,1 : 0,M | ADADR ad01id ad02cisadr |

Indexy

Název | Primární | Výraz | Popis
ix_MZUDALOS_mz41 | P | mz41 |
ix_MZUDALOS_mz41datum |  | mz41datum | Datum právě zpracovaných a přenášených mezd
ix_MZUDALOS_mz41text |  | mz41text | Popis události mzdové komponenty
ix_MZUDALOS_mz28id |  | mz28id | Jednoznačná identifikace mzdové položky
ix_MZUDALOS_uc01id |  | uc01id | Identifikátor účtu
ix_MZUDALOS_mz41kc |  | mz41kc | Celková částka v Kč (mzda, daň, srážka, ..., ap.) Aktuální hodnota
ix_MZUDALOS_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZUDALOS_mz32cispp |  | mz32cispp | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
ix_MZUDALOS_mz79id |  | mz79id | Identifikace umístění mezd
ix_MZUDALOS_ad01id |  | ad01id | Identifikace adresáta
ix_MZUDALOS_ad02cisadr |  | ad02cisadr | Číslo adresy adresáta. Program generuje automaticky.
ix_MZUDALOS_ad11cisspo |  | ad11cisspo | Číslo spojení adresáta. Program generuje automaticky.
ix_MZUDALOS_ad03cisban |  | ad03cisban | Číslo spojení na bankovní účet adresáta.
ix_MZUDALOS_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_MZUDALOS_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_MZUDALOS_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_MZUDALOS_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_MZUDALOS_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_MZUDALOS_adbucty1 |  | ad01id, ad03cisban | ad01id+ad03cisban
ix_MZUDALOS_adadr1 |  | ad01id, ad02cisadr | Adresát + číslo adresy Pro zobrazení
ix_MZUDALOS_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_MZUDALOS_mzpracpo1 |  | mz01id, mz32cispp | mz01id + mz32cispp
ix_MZUDALOS_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_MZUDALOS_mz41typuda |  | mz41typuda | Typ mzdové události, dle způsobu pokračování
ix_MZUDALOS_mzudalosx |  |  |


MZUKOLLI Úkolové listy

Popis

Objektem typu MZUKOLLI je každý záznam, který obsahuje úkolové listy.

Dok: Slouží k pořizování mezd jiným pracovníkem, než mzdovou účetní (např. mistrem). V této části lze pořizovat pouze příjmy, náhrady mezd a neplacená volna. Nelze pořizovat údaje jako nemoc, srážky, apod. Výhledově může být toto vykazování propojeno na elektronický sběr dat - elektronické píchačky, počítadla na strojních linkách, ad. Každý nový měsíc začíná založením nové operace. Během měsíce mistr pořizuje data a teprve po skončení měsíce operaci ukončí. Data se nikam netransformují. Po skončení měsíce si mzdová účetní přetáhne funkcí Načtení úkolových listů údaje do účetnictví.
Zadané údaje se po uložení operace promítnou do statistiky.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz61 | C(12) | JČI | Jednoznačná časová identifikace | Jednoznačná časová identifikace
mz60id | C(6) | Organizační jednotka | Identifikace organizační jednotky | Identifikace organizační jednotky
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz32cispp | C(2) | Číslo p.p. | Číslo pracovního poměru | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
mz61datum | D | Datum | Datum | Datum
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
mz28id | C(6) | Mzdová položka | Jednoznačná identifikace mzdové položky | Jednoznačná identifikace mzdové položky
mz61od | C(5) | Od | Výkon práce od (čas zahájení práce) | Výkon práce od (čas zahájení práce)
mz61do | C(5) | Do | Výkon práce do (čas ukončení práce) | Výkon práce do (čas ukončení práce)
mz61dnu | N(6,2) | Dnů | Počet dnů (výkonu práce, volna, nemoci,...) | Počet dnů (výkonu práce, volna, nemoci,...)
mz61hodin | N(7,2) | Hodin | Počet hodin (výkonu práce, volna, nemoci,...) | Počet hodin (výkonu práce, volna, nemoci,...)
mz61minuty | N(5,0) | mz61minuty | Počet minut (výkonu práce, volna, nemoci,...) | Počet minut (výkonu práce, volna, nemoci,...)
mz61presta | N(20,2) | Přestávka | Přestávka v práci - v hodinách | Přestávka v práci - v hodinách. Obvykle po 4.5 hodinách práce následuje přestávka.
mz61vykon | N(10,2) | Výkon | Množství vykonané práce při úkolové mzdě | Množství vykonané práce při úkolové mzdě
mz61kc_j | N(11,4) | Kč/ j | Částka za jednotku (tarifní sazba za hodinu, sazba za jednotku výkonu,...) | Kč za jednotku (tarifní sazba za hodinu, sazba za jednotku výkonu,...)
mz61kc | N(24,2) | Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.) | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
mz61text | C(40) | Popis | Popis události vstupní komponenty | Popis události vstupní komponenty (údaje od mistra)
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
mz79id | C(6) | Umístění | Identifikace umístění mezd | Identifikace umístění mezd
mz61stav | N(1,0) | mz61stav | Stav události |
mz61poradi | N(5,0) | mz61poradi | Pořadí události v úkolovém lístku |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Úkolové listy - mohou mít organizační jednotku | MZUKOLLI mz60id | 0,1 : 0,M | MZORGJED mz60id |
Úkolové listy - má mzdovou položku | MZUKOLLI mz28id | 1,1 : 0,M | MZMZDPOL mz28id |
Úkolové listy - má adresáta | MZUKOLLI ad01id | 1,1 : 0,M | ADADSAT ad01id |
Úkolové listy - patří pracovníkovi | MZUKOLLI mz01id | 1,1 : 0,M s rušením | MZKARTA mz01id |
Úkolové listy - z pracovního poměru | MZUKOLLI mz01id mz32cispp | 1,1 : 0,M | MZPRACPO mz01id mz32cispp |
Úkolové listy - má orgnizační selektor | MZUKOLLI sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Úkolové listy - zapsána pracovníkem | MZUKOLLI bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Úkolové listy - patří do fyzické operace | MZUKOLLI sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Úkolové listy - má obchodní selektor | MZUKOLLI sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Úkolové listy - má techinicko-věcný selektor | MZUKOLLI sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Úkolové listy - mají artikl mezd | MZUKOLLI sp60id sp61id | 1,1 : 0,M | MZARTIKL sp60id sp61id |
Úkolové listy - mají umístění | MZUKOLLI mz79id | 1,1 : 0,M | MZUMIST mz79id |

Indexy

Název | Primární | Výraz | Popis
ix_MZUKOLLI_mz61 | P | mz61 | Jednoznačná časová identifikace
ix_MZUKOLLI_mz60id |  | mz60id | Identifikace organizační jednotky
ix_MZUKOLLI_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZUKOLLI_mz32cispp |  | mz32cispp | Číslo pracovního poměru Při vkládání program generuje automaticky a nelze je opravit.
ix_MZUKOLLI_mz61datum |  | mz61datum | Datum
ix_MZUKOLLI_ad01id |  | ad01id | Identifikace adresáta
ix_MZUKOLLI_mz28id |  | mz28id | Jednoznačná identifikace mzdové položky
ix_MZUKOLLI_mz61kc |  | mz61kc | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
ix_MZUKOLLI_mzpracpo1 |  | mz01id, mz32cispp | mz01id + mz32cispp
ix_MZUKOLLI_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_MZUKOLLI_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_MZUKOLLI_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_MZUKOLLI_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_MZUKOLLI_mzukolli1 |  | mz01id, mz32cispp, mz61datum, mz28id | mz01id + mz32cispp + mz61datum + mz28id
ix_MZUKOLLI_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_MZUKOLLI_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_MZUKOLLI_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_MZUKOLLI_mzukolli2 |  | mz01id, mz32cispp, mz28id, sp10idzak, sp11idzak, sp20idzak |
ix_MZUKOLLI_sp61id |  | sp61id | Identifikace druhu artiklu
ix_MZUKOLLI_sp60id |  | sp60id | Identifikace artiklu
ix_MZUKOLLI_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_MZUKOLLI_mz79id |  | mz79id | Identifikace umístění mezd
ix_MZUKOLLI_mzukollix |  |  |
ix_MZUKOLLI_mz61poradi |  | mz61poradi |


MZUKOLTA Úkolová mzda tarifní

Popis

Objektem typu MZUKOLTA je každý záznam, který obsahuje úkolovou mzdu tarifní.
Úkolová mzda může mít sazby podle stupnice a tarifní třídy pracovníka, který ji vykonává.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz28id | C(6) | Mzdová položka | Jednoznačná identifikace mzdové položky | Jednoznačná identifikace mzdové položky
mz23id | C(6) | Identifikace | Identifikace tarifní stupnice | Jednoznačná identifikace tarifní stupnice
mz24trida | C(2) | Třída | Tarifní třída (1-99) | Tarifní třída (1-99)
mz30kc_j | N(9,2) | Kč/ j | Kč/ j |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Úkolová mzda tarifní - souvisí s mzdovou položkou | MZUKOLTA mz28id | 1,1 : 0,M s rušením | MZMZDPOL mz28id |
Úkolová mzda tarifní - odpovída tarifní stupnici | MZUKOLTA mz23id | 1,1 : 0,M | MZTARSTU mz23id |
Úkolová mzda tarifní - má tarifní třídu | MZUKOLTA mz23id mz24trida | 1,1 : 0,M | MZTARTRI mz23id mz24trida |

Indexy

Název | Primární | Výraz | Popis
ix_MZUKOLTA_mz28id |  | mz28id | Jednoznačná identifikace mzdové položky
ix_MZUKOLTA_mz23id |  | mz23id | Jednoznačná identifikace tarifní stupnice
ix_MZUKOLTA_mz24trida |  | mz24trida | Tarifní třída (1-99)
ix_MZUKOLTA_mzukolta1 | P | mz28id, mz23id, mz24trida | mz28id + mz23id + mz24trida
ix_MZUKOLTA_mztartri1 |  | mz23id, mz24trida | mz23id + mz24trida


MZUMIST Alokace mezd - umístění

Atributy

Atribut | Typ | Návěští | Message | Popis
mz79id | C(6) | Umístění | Identifikace umístění mezd | Identifikace umístění mezd
mz79text | C(40) | Název umístění | Název umístění mezd | Název umístění mezd
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Alokace mezd - umístění - odpovídá organizačnímu selektoru | MZUMIST sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Pracovní funkce - skutečné a typové - má umístění | MZPRACFU mz79id | 1,1 : 0,M | MZUMIST mz79id |
Událostní entita mezd - má umístění | MZUDALOS mz79id | 1,1 : 0,M | MZUMIST mz79id |
Úkolové listy - mají umístění | MZUKOLLI mz79id | 1,1 : 0,M | MZUMIST mz79id |

Indexy

Název | Primární | Výraz | Popis
ix_MZUMIST_mz79id | P | mz79id | Identifikace umístění mezd
ix_MZUMIST_mz79text |  | mz79text | Název umístění mezd
ix_MZUMIST_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.


MZVSTULI Vztah mezi záznamem výplatního lístku a mzdovou položkou z karty, nemoc

Popis

Vztah mezi záznamem výplatního lístku a mzdovou položkou z karty, nemocenskou dávkou, úkolovým listem

Atributy

Atribut | Typ | Návěští | Message | Popis
mz02 | C(12) | JČI | Jednoznačná časová identifikace | Jednoznačná časová identifikace
mz07 | C(12) | mz07 | Jednoznačná časová identifikace - MZNEZDPO,MZNEMDAV, MZUKOLLI | Jednoznačná časová identifikace - MZNEZDPO,MZNEMDAV, MZUKOLLI
mz07typ | C(2) | mz07typ | Typ (tabulka) | Typ (tabulka)

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vztah mezi záznamem výplatního lístku a mzdovou položkou z karty, nemocenskou dávkou, úkolovým listem - ve vztahu k výplatnímu lístku | MZVSTULI mz02 | 1,1 : 0,M s rušením | MZMZDY mz02 |

Indexy

Název | Primární | Výraz | Popis
ix_MZVSTULI_mz02 |  | mz02 | Jednoznačná časová identifikace
ix_MZVSTULI_mz07 |  | mz07 | Jednoznačná časová identifikace - MZNEZDPO,MZNEMDAV, MZUKOLLI
ix_MZVSTULI_mzvstuli | P | mz02, mz07 |


MZVYKAZY Výkaz

Popis

Objektem typu MZVYKAZY je každý záznam, který obsahuje ....

Atributy

Atribut | Typ | Návěští | Message | Popis
mz49id | C(6) | Identifikace | Identifikace výkazu | Identifikace výkazu
mz49popis | C(30) | Popis | Popis výkazu | Popis výkazu
mz49pozn | M | Komentář | Komentář | Komentář
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Výkaz - zapsán pracovníkem | MZVYKAZY bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Výkazy - řádky - odpovídají výkazu ze seznamu výkazů | MZDLD mz49id | 1,1 : 0,M s rušením | MZVYKAZY mz49id |
Mzdový list - odpovídá výkazu | MZDLIST mz49id | 1,1 : 0,1 s rušením | MZVYKAZY mz49id |

Indexy

Název | Primární | Výraz | Popis
ix_MZVYKAZY_mz49id | P | mz49id | Identifikace výkazu
ix_MZVYKAZY_mz49popis |  | mz49popis | Popis výkazu
ix_MZVYKAZY_bw01uziv |  | bw01uziv | Identifikace uživatele systému


MZVYPMIS Výplatní místo

Popis

Objektem typu MZVYPMIS je každý záznam, který obsahuje popis výplatního místa.

Atributy

Atribut | Typ | Návěští | Message | Popis
mz22id | C(6) | Identifikace | Jednoznačná identifikace výplatního místa | Jednoznačná identifikace výplatního místa
mz22nazev | C(40) | Název | Název výplatního místa | Název, (popis) výplatního místa
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Výplatní místo - zapsáno uživatelem | MZVYPMIS bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Pracovník - má výplatní místo | MZKARTA mz22id | 1,1 : 0,M | MZVYPMIS mz22id |
Historie karet pracovníků - má výplatní místo | MZKARHIS mz22id | 1,1 : 0,M | MZVYPMIS mz22id |
Sumární výčetka platidel - odpovídá výplatnímu místu | MZPLSUMA mz22id | 1,1 : 0,M s rušením | MZVYPMIS mz22id |

Indexy

Název | Primární | Výraz | Popis
ix_MZVYPMIS_mz22id | P | mz22id | Jednoznačná identifikace výplatního místa
ix_MZVYPMIS_mz22nazev |  | mz22nazev | Název, (popis) výplatního místa


MZVZTAHY Číselník možných vztahů mezi pracovníkem a osobou

Popis

Objektem typu MZVZTAHY je každý záznam, který obsahuje identifikaci a popis vztahu mezi pracovníkem a osobou.

Atributy

Atribut | Typ | Návěští | Message | Popis
mza1id | C(6) | Identifikace | Identifikace vztahu |
mza1popis | C(40) | Popis | Popis vztahu |
mza1koment | M | Komentář | Komentář |
mza1predpl | N(1,0) | Předplňovat | Předplňovat do vazby pracovník - osoba. Ano/ne |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Platnost vztahu určitého typu mezi pracovníkem a osobou - obsahuje číselník možných vztahů | MZKAROSP mza1id | 1,1 : 0,M | MZVZTAHY mza1id |

Indexy

Název | Primární | Výraz | Popis
ix_MZVZTAHY_mza1id | P | mza1id |
ix_MZVZTAHY_mza1popis |  | mza1popis |


MZZALOHY Záloha vyplacená

Popis

již nepoužívat - 29.1.2003

Atributy

Atribut | Typ | Návěští | Message | Popis
mz55 | C(12) | mz55 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz28id | C(6) | Mzdová položka | Jednoznačná identifikace mzdové položky | Jednoznačná identifikace mzdové položky
mz36kc_j | N(11,2) | mz36kc_j | Kč/ j |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Záloha vyplacená - pracovníkovi | MZZALOHY mz01id | 1,1 : 0,M s rušením | MZKARTA mz01id |
Záloha vyplacená - existuje v číselníku mzdových položek | MZZALOHY mz28id | 1,1 : 0,M | MZMZDPOL mz28id |

Indexy

Název | Primární | Výraz | Popis
ix_MZZALOHY_mz55 | P | mz55 | Jednoznačná časová identifikace
ix_MZZALOHY_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZZALOHY_mz28id |  | mz28id | Jednoznačná identifikace mzdové položky


MZZDRPOJ Zdravotní pojišťovny a jejich přidělení

Atributy

Atribut | Typ | Návěští | Message | Popis
mz70idp | C(3) | Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,... | Identifikace pojišťovny, např. 111, 121 ,...
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
mz97oddata | D | Datum zahájení platnosti položky | Datum zahájení platnosti položky | Datum zahájení platnosti položky
mz97dodata | D | Datum ukončení platnosti položky | Datum ukončení platnosti položky | Datum ukončení platnosti položky
mz97 | C(12) | JCI | Jednoznačná časová identifikace | Jednoznačná časová identifikace
mz97ciszp | C(15) | Číslo pojištěnce | Číslo pojištěnce ve zdravotní pojišťovně. Uvádějte pouze je-li různé od rodného čísla. | Číslo pojištěnce ve zdravotní pojišťovně. Uvádějte pouze je-li různé od rodného čísla.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Zdravotní pojišťovny a jejich přidělení - patří pracovníkovi | MZZDRPOJ mz01id | 1,1 : 0,M | MZKARTA mz01id |
Zdravotní pojišťovny a jejich přidělení - patří pracovníkovi | MZZDRPOJ mz70idp | 1,1 : 0,M | MZPOJSEZ mz70idp |

Indexy

Název | Primární | Výraz | Popis
ix_MZZDRPOJ_mz70idp |  | mz70idp | Identifikace pojišťovny, např. 111, 121 ,...
ix_MZZDRPOJ_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_MZZDRPOJ_mz97 | P | mz97 | Jednoznačná časová identifikace


Tabulky NK...

NKAH | Aktuální hodnota PP
NKAHUD | Událost hodnoty předmětu projektu - skladba
NKAHUK | Aktuální hodnota projektových úkolů
NKAHUKD | Událost projektového úkolu - skladba
NKAHUP | Aktuální hodnota plnění projektových úkolů
NKAHUPD | Událost plnění projektového úkolu - skladba
NKCIS | Číselník hodnot parametru předmětu projektu
NKCISHOD | Hodnota číselníku hodnot parametru předmětu projektu
NKDOTSQL | Dotaz SQL pro pravidlo závazku
NKDRUHPA | Vlastnost hodnoty pravidla smlouvy
NKDRUHPI | Interpretace referenční hodnoty pravidla smlouvy
NKDRUHPR | Pravidlo smlouvy
NKHODNP | Hodnota parametru předmětu projektu
NKINIPRE | Inicializace předmětu projektu
NKINIWRK | Pomocný soubor pro přepis inicializace
NKPAR | Parametr předmětu projektu
NKPARDEF | Definice struktury elementární hodnoty parametru
NKPARDRU | Umístění parametru předmětu projektu
NKPARPAR | Vztah podřízenosti parametrů předmětu projektu
NKPARTMP | Temp soubor pro zabraneni rekurze pro vypoctu prezentace
NKPLNDOP | Druh položky smlouvy použitelný v druhu operace
NKPLNDRH | Pravidlo smlouvy k pravidlu výše smlouvy
NKPLNDRO | Vlastnost stavu smlouvy druhu plnění smlouvy
NKPLNDRP | Pravidlo smlouvy druhu plnění položky smlouvy
NKPLNDRU | Druh události položky smlouvy nebo události plnění položky smlouvy
NKPLNDRV | Spojení druhu události plnění položky smlouvy k druhu události položky smlouvy
NKPREDPR | Předmět projektu
NKPREDZS | Záznam o změně stavu předmětu projektu nebo hodnoty jeho parametru
NKPRH | Prezentovaná hodnota parametru
NKPRP | Prezentace parametrů
NKPRPPAR | Skupinový parametr prezentace parametrů
NKPRPPOP | Popis hodnoty inicializace
NKROLE | Role aktéra
NKSKUPIN | Skupina skupinového parametru
NKSMLOUV | Položka smlouvy
NKSMLPLN | Událost plnění položky smlouvy
NKSMLPLT | Událost plnění položky smlouvy před importem
NKSMLPLZ | Karta zálohy plnění smluv
NKSMLRAD | Číselná řada smluv
NKSMLZAL | Záloha čerpaná položkou smlouvy
NKUKDIA | Uzel v diagramu složeného projektového úkolu
NKUKDIAP | Temporary pro výběr množiny projektových úkolů
NKUKDIAV | Vazba mezi uzly diagramu složeného projektového úkolu
NKUKDPD | Druh plnění úkolu použitelný pro druh úkolu projektového řízení
NKUKOL | Projektový úkol
NKUKOLD | Druh projektového úkolu
NKUKOLDA | Administrátor druhu projektového úkolu
NKUKOLDO | Druh projektového úkolu použitelný v druhu operace
NKUKOLDX | Vztahy řešitelů a zadavatelů vzhledem k druhu projektového úkolu
NKUKOLG | Generický projektový úkol
NKUKOLGP | Proměnná generického projektového úkolu
NKUKOLGU | Definice náhrady při aplikaci generického projektového úkolu
NKUKOLH | Záznam o změně vlastností úkolu
NKUKOLP | Plnění projektového úkolu
NKUKOLPE | Záznam o plnění úkolu v programu EVIVYK.EXE
NKUKOLRH | Host úkolu
NKUKOLS | Pracovní plnění projektového úkolu pro vstup šablonou
NKUKOLU | Uživatel systému - řešitel daného projektového úkolu
NKUKOLX | Prezentace úkolu v diagramu úkolu
NKUKOLZ | Řešitel - řešitel daného projektového úkolu
NKUKOPD | Druh plnění projektového úkolu
NKUKOPDT | Dynamická transformace druhu plnění projektového úkolu
NKZDKAL | Kalendář zdroje pro plnění projektového kroku
NKZDKALP | Den v kalendáři zdroje pro plnění projektového kroku
NKZDROJ | Řešitel projektového úkolu
NKZDROJS | Zařazení řešitele do skupiny řešitelů projektového úkolu
NKZDROJZ | Zadavatel úkolu

Viz.také

NKZDROJZ Zadavatel úkolu | NKAH Aktuální hodnota PP | NKAHUD Událost hodnoty předmětu projektu - skladba | NKAHUK Aktuální hodnota projektových úkolů | NKAHUKD Událost projektového úkolu - skladba | NKAHUP Aktuální hodnota plnění projektových úkolů | NKAHUPD Událost plnění projektového úkolu - skladba | NKCIS Číselník hodnot parametru předmětu projektu | NKCISHOD Hodnota číselníku hodnot parametru předmětu projektu | NKDOTSQL Dotaz SQL pro pravidlo závazku | NKDRUHPA Vlastnost hodnoty pravidla smlouvy | NKDRUHPI Interpretace referenční hodnoty pravidla smlouvy | NKDRUHPR Pravidlo smlouvy | NKHODNP Hodnota parametru předmětu projektu | NKINIPRE Inicializace předmětu projektu | NKINIWRK Pomocný soubor pro přepis inicializace | NKPAR Parametr předmětu projektu | NKPARDEF Definice struktury elementární hodnoty parametru | NKPARDRU Umístění parametru předmětu projektu | NKPARPAR Vztah podřízenosti parametrů předmětu projektu | NKPARTMP Temp soubor pro zabraneni rekurze pro vypoctu prezentace | NKPLNDRH Pravidlo smlouvy k pravidlu výše smlouvy | NKPLNDRO Vlastnost stavu smlouvy druhu plnění smlouvy | NKPLNDRP Pravidlo smlouvy druhu plnění položky smlouvy | NKPLNDRU Druh události položky smlouvy nebo události plnění položky smlouvy | NKPLNDRV Spojení druhu události plnění položky smlouvy k druhu události položky | NKPREDPR Předmět projektu | NKPREDZS Záznam o změně stavu předmětu projektu nebo hodnoty jeho parametru | NKPRH Prezentovaná hodnota parametru | NKPRP Prezentace parametrů | NKPRPPAR Skupinový parametr prezentace parametrů | NKPRPPOP Popis hodnoty inicializace | NKROLE Role aktéra | NKSKUPIN Skupina skupinového parametru | NKSMLOUV Položka smlouvy | NKSMLPLN Událost plnění položky smlouvy | NKSMLPLT Událost plnění položky smlouvy před importem | NKSMLPLZ Karta zálohy plnění smluv | NKSMLZAL Záloha čerpaná položkou smlouvy | NKUKDIA Uzel v diagramu složeného projektového úkolu | NKUKDIAP Temporary pro výběr množiny projektových úkolů | NKUKDIAV Vazba mezi uzly diagramu složeného projektového úkolu | NKUKDPD Druh plnění úkolu použitelný pro druh úkolu projektového řízení | NKUKOL Projektový úkol | NKUKOLD Druh projektového úkolu | NKUKOLG Generický projektový úkol | NKUKOLGP Proměnná generického projektového úkolu | NKUKOLGU Definice náhrady při aplikaci generického projektového úkolu | NKUKOLH Záznam o změně vlastností úkolu | NKUKOLP Plnění projektového úkolu | NKUKOLS Pracovní plnění projektového úkolu pro vstup šablonou | NKUKOLX Prezentace úkolu v diagramu úkolu | NKUKOPD Druh plnění projektového úkolu | NKZDKAL Kalendář zdroje pro plnění projektového kroku | NKZDKALP Den v kalendáři zdroje pro plnění projektového kroku | NKZDROJ Řešitel projektového úkolu | NKZDROJS Zařazení řešitele do skupiny řešitelů projektového úkolu | NKUKOLDA Administrátor druhu projektového úkolu | NKUKOLDX Vztahy řešitelů a zadavatelů vzhledem k druhu projektového úkolu | NKUKOLRH Host úkolu | NKUKOLU Uživatel systému - řešitel daného projektového úkolu | NKUKOLZ Řešitel - řešitel daného projektového úkolu | NKPLNDOP Druh položky smlouvy použitelný v druhu operace | NKUKOLDO Druh projektového úkolu použitelný v druhu operace | NKUKOPDT Dynamická transformace druhu plnění projektového úkolu | NKSMLRAD Číselná řada smluv | NKUKOLPE Záznam o plnění úkolu v programu EVIVYK.EXE


NKAH Aktuální hodnota PP

Popis

Aktuální hodnoty PP

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
nk06id | C(6) | Umístění | Identifikace umístění | Identifikace umístění
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
nk19hodnot | N(20,4) | Hodnota | Aktuální hodnota | Aktuální hodnota

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Aktuální hodnota PP - je pro druh hodnoty | NKAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Aktuální hodnota PP - je pro artikl | NKAH sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Aktuální hodnota PP - je pro adresáta | NKAH ad01id | 1,1 : 0,M | ADADSAT ad01id |
Aktuální hodnota PP - je pro umístění | NKAH nk06id | 1,1 : 0,M | NKPARDRU nk06id |

Indexy

Název | Primární | Výraz | Popis
ix_NKAH_nkah | P | sp60id, sp61id, ad01id, nk06id, sp67id, sp06idsubs | PI - SPARTIKL+ad01id+nk06id+SPSTATDI
ix_NKAH_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_NKAH_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_NKAH_spartiknx |  |  |
ix_NKAH_adadsatx |  |  |
ix_NKAH_nk06id |  | nk06id | Identifikace umístění
ix_NKAH_ad01id |  | ad01id | Identifikace adresáta


NKAHUD Událost hodnoty předmětu projektu - skladba

Popis

Událost hodnoty předmětu projektu - skladba

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
nk13 | C(12) | nk13 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp74id | C(6) | sp74id | Umístění | Umístění
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp00datum | D | Datum | Datum události | Datum události
sp00text | C(40) | Popis | Popis události | Popis události
sp00hodnot | N(20,4) | Hodnota | Aktuální hodnota procesu |
sp69id | C(6) | Druh | Identifikace druhu saldokontní hodnoty procesu | Identifikace druhu saldokontní hodnoty procesu


NKAHUK Aktuální hodnota projektových úkolů

Popis

Aktuální hodnota projektových úkolů

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
nk01verze | C(3) | Verze | Verze projektu | Verze projektu
nk53id | C(6) | Druh | Identifikátor druhu úkolů | Identifikátor druhu úkolů
nk44id | C(6) | Řešitel | Identifikace řešitele | Identifikace řešitele
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
nk73hodnot | N(20,4) | Hodnota | Aktuální hodnota | Aktuální hodnota

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Aktuální hodnota projektových úkolů - je pro předmět projektu | NKAHUK sp60id sp61id nk01verze | 1,1 : 0,M | NKPREDPR sp60id sp61id nk01verze |
Aktuální hodnota projektových úkolů - je pro druh projektového úkolu | NKAHUK nk53id | 1,1 : 0,M | NKUKOLD nk53id |
Aktuální hodnota projektových úkolů - je hodnotou řešitele | NKAHUK nk44id | 1,1 : 0,M | NKZDROJ nk44id |
Aktuální hodnota projektových úkolů - je druhu hodnoty | NKAHUK sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Aktuální hodnota projektových úkolů - je hodnotou adresáta | NKAHUK ad01id | 1,1 : 0,M | ADADSAT ad01id |

Indexy

Název | Primární | Výraz | Popis
ix_NKAHUK_nkahuk | P | sp60id, sp61id, nk01verze, nk53id, nk44id, ad01id, sp67id, sp06idsubs | PI - NKPREDPR+nk53id+nk44id
ix_NKAHUK_nkpredpr |  | sp60id, sp61id, nk01verze | PI - SPARTIKL+nk01verze
ix_NKAHUK_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_NKAHUK_spartiknx |  |  |
ix_NKAHUK_adadsatx |  |  |
ix_NKAHUK_nk53id |  | nk53id | Identifikátor druhu úkolů
ix_NKAHUK_nk44id |  | nk44id | Identifikace řešitele
ix_NKAHUK_ad01id |  | ad01id | Identifikace adresáta


NKAHUKD Událost projektového úkolu - skladba

Popis

Událost projektového úkolu - skladba

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
nk13 | C(12) | nk13 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp74id | C(6) | sp74id | Umístění | Umístění
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp00datum | D | Datum | Datum události | Datum události
sp00text | C(40) | Popis | Popis události | Popis události
sp00hodnot | N(20,4) | Hodnota | Aktuální hodnota procesu |
sp69id | C(6) | Druh | Identifikace druhu saldokontní hodnoty procesu | Identifikace druhu saldokontní hodnoty procesu


NKAHUP Aktuální hodnota plnění projektových úkolů

Popis

Aktuální hodnota plnění projektových úkolů

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
nk01verze | C(3) | Verze | Verze projektu | Verze projektu
nk53idp | C(6) | Druh | Identifikátor druhu úkolů | Identifikátor druhu úkolů
nk70id | C(6) | Druh | Identifikace druhu plnění úkolu projektového řízení | Identifikace druhu plnění úkolu projektového řízení
nk44id | C(6) | Řešitel | Identifikace řešitele | Identifikace řešitele
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
nk76hodnot | N(20,4) | nk76hodnot | Aktuální hodnota | Aktuální hodnota

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Aktuální hodnota plnění projektových úkolů - je pro předmět projektu | NKAHUP sp60id sp61id nk01verze | 1,1 : 0,M | NKPREDPR sp60id sp61id nk01verze |
Aktuální hodnota plnění projektových úkolů - je pro druh plnění projektového úkolu | NKAHUP nk70id | 1,1 : 0,M | NKUKOPD nk70id |
Aktuální hodnota plnění projektových úkolů - je hodnotou řešitele | NKAHUP nk44id | 1,1 : 0,M | NKZDROJ nk44id |
Aktuální hodnota plnění projektových úkolů - je druhu hodnoty | NKAHUP sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Aktuální hodnota plnění projektových úkolů - je pro druh projektového úkolu | NKAHUP nk53idp | 1,1 : 0,M | NKUKOLD nk53id |
Aktuální hodnota plnění projektových úkolů - je hodnotou adresáta | NKAHUP ad01id | 1,1 : 0,M | ADADSAT ad01id |

Indexy

Název | Primární | Výraz | Popis
ix_NKAHUP_nkahup | P | sp60id, sp61id, nk01verze, nk53idp, nk70id, nk44id, ad01id, sp67id, sp06idsubs | PI - NKPREDPR+nk53idp+nk70id+nk44id
ix_NKAHUP_nkpredpr |  | sp60id, sp61id, nk01verze | PI - SPARTIKL+nk01verze
ix_NKAHUP_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_NKAHUP_spartiknx |  |  |
ix_NKAHUP_adadsatx |  |  |
ix_NKAHUP_nk44id |  | nk44id | Identifikace řešitele
ix_NKAHUP_nk53idp |  | nk53idp | Identifikátor druhu úkolů
ix_NKAHUP_nk70id |  | nk70id | Identifikace druhu plnění úkolu projektového řízení
ix_NKAHUP_ad01id |  | ad01id | Identifikace adresáta


NKAHUPD Událost plnění projektového úkolu - skladba

Popis

Událost plnění projektového úkolu - skladba

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
nk13 | C(12) | nk13 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp74id | C(6) | sp74id | Umístění | Umístění
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp00datum | D | Datum | Datum události | Datum události
sp00text | C(40) | Popis | Popis události | Popis události
sp00hodnot | N(20,4) | Hodnota | Aktuální hodnota procesu |
sp69id | C(6) | Druh | Identifikace druhu saldokontní hodnoty procesu | Identifikace druhu saldokontní hodnoty procesu


NKCIS Číselník hodnot parametru předmětu projektu

Popis

Číselník hodnot parametru předmětu projektu

Atributy

Atribut | Typ | Návěští | Message | Popis
nk35id | C(6) | Číselník | Identifikace číselníku | Identifikace číselníku
nk35nazcis | C(40) | Název číselníku | Název číselníku | Název číselníku hodnot parametrů
nk35koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametr předmětu projektu - používá číselník | NKPAR nk35id | 1,1 : 0,M | NKCIS nk35id |
Hodnota číselníku hodnot parametru předmětu projektu - patří k číselníku | NKCISHOD nk35id | 1,1 : 0,M | NKCIS nk35id |

Indexy

Název | Primární | Výraz | Popis
ix_NKCIS_nk35id | P | nk35id | Identifikace číselníku
ix_NKCIS_nk35nazcis |  | nk35nazcis | Název číselníku hodnot parametrů


NKCISHOD Hodnota číselníku hodnot parametru předmětu projektu

Popis

Hodnota číselníku hodnot parametru předmětu projektu

Atributy

Atribut | Typ | Návěští | Message | Popis
nk09id | C(9) | ID | Identifikace hodnoty | Identifikace hodnoty
nk35id | C(6) | Číselník | Identifikace číselníku | Identifikace číselníku
nk09popis | C(40) | Popis | Popis hodnoty | Popis hodnoty
nk09koment | M | Poznámka | Poznámka k popisu hodnoty | Poznámka k popisu hodnoty

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Hodnota číselníku hodnot parametru předmětu projektu - patří k číselníku | NKCISHOD nk35id | 1,1 : 0,M | NKCIS nk35id |
Hodnota parametru předmětu projektu - obsahuje hodnotu číselníku | NKHODNP nk09id | 1,1 : 0,M | NKCISHOD nk09id |

Indexy

Název | Primární | Výraz | Popis
ix_NKCISHOD_nk09id | P | nk09id | Identifikace hodnoty
ix_NKCISHOD_nk35id |  | nk35id | Identifikace číselníku
ix_NKCISHOD_nk09popis |  | nk09popis | Popis hodnoty


NKDOTSQL Dotaz SQL pro pravidlo závazku

Popis

Dotaz SQL pro pravidlo závazku

Atributy

Atribut | Typ | Návěští | Message | Popis
nk29id | C(6) | Dotaz | Identifikace SQL dotazu | Identifikace SQL dotazu musí být uvedena
nk29nazvyr | C(40) | Název SQL dotazu | Název SQL dotazu | Název SQL dotazu
nk29dotaz | M | SQL | SQL dotaz | SQL dotaz
nk29koment | M | Poznámka | Poznámka | Poznámka

Indexy

Název | Primární | Výraz | Popis
ix_NKDOTSQL_nk29id | P | nk29id | Identifikace SQL dotazu musí být uvedena
ix_NKDOTSQL_nk29nazvyr |  | nk29nazvyr | Název SQL dotazu


NKDRUHPA Vlastnost hodnoty pravidla smlouvy

Atributy

Atribut | Typ | Návěští | Message | Popis
nk26id | C(6) | Pravidlo | Identifikace pravidla | Identifikace pravidla
nk34id | C(2) | Hodnota | Identifikace hodnoty | Hodnota
nk34label | M | Návěští | Návěští hodnoty | Návěští hodnoty
nk34status | M | Stavový řádek | Stavový řádek hodnoty | Stavový řádek hodnoty
nk34valid | M | Validace | Validace hodnoty | Validace hodnoty
nk34error | M | Chyb.hlášení | Chybové hlášení | Chybové hlášení
nk34len | N(3,0) | Délka | Délka numerické hodnoty | Délka numerické hodnoty
nk34dec | N(1,0) | Desetiny | Desetiny numerické hodnoty | Desetiny numerické hodnoty
nk34init | M | Inicializace | Inicializace hodnoty | Inicializace hodnoty

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vlastnost hodnoty pravidla smlouvy - je vlastností hodnoty pravidla smlouvy | NKDRUHPA nk26id | 1,1 : 0,M s rušením | NKDRUHPR nk26id |

Indexy

Název | Primární | Výraz | Popis
ix_NKDRUHPA_nkdruhpa | P | nk26id, nk34id |
ix_NKDRUHPA_nk26id |  | nk26id | Identifikace pravidla


NKDRUHPI Interpretace referenční hodnoty pravidla smlouvy

Popis

Interpretace referenční hodnoty pravidla smlouvy

Atributy

Atribut | Typ | Návěští | Message | Popis
nk26id | C(6) | Pravidlo | Identifikace pravidla | Identifikace pravidla
nk38id | C(2) | Hodnota | Identifikace referenční hodnoty | Identifikace referenční hodnoty
nk38len | N(3,0) | Délka | Délka numerické hodnoty | Délka numerické hodnoty
nk38dec | N(1,0) | Desetiny | Desetiny numerické hodnoty | Desetiny numerické hodnoty
nk38label | C(30) | Návěští | Návěští referenční hodnoty | Návěští referenční hodnoty

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Interpretace referenční hodnoty pravidla smlouvy - je vlastností referenční hodnoty pravidla smlouvy | NKDRUHPI nk26id | 1,1 : 0,M s rušením | NKDRUHPR nk26id |

Indexy

Název | Primární | Výraz | Popis
ix_NKDRUHPI_nkdruhpi | P | nk26id, nk38id | PI: nk26id + nk38id
ix_NKDRUHPI_nk26id |  | nk26id | Identifikace pravidla


NKDRUHPR Pravidlo smlouvy

Popis

Pravidlo smlouvy

Atributy

Atribut | Typ | Návěští | Message | Popis
nk26id | C(6) | Pravidlo | Identifikace pravidla | Identifikace pravidla
nk26nazpra | C(40) | Název pravidla | Název pravidla | Název pravidla
nk26typ | N(1,0) | Typ | Typ pravidla | Typ pravidla
nk26koment | M | Poznámka | Poznámka | Poznámka
nk26vyraz | M | Kód | Kód pravidla | Výraz pravidla
nk26vyrazp | M | Kód poznámky | Kód poznámky o hodnotě | Výraz poznámky o hodnotě
nk26prizna | N(2,0) | Příznak | Příznak pravidla použitelný např. v řízení procesů kódy po ukončení | Příznak pravidla použitelný např. v řízení procesů kódy po ukončení

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Položka smlouvy - má pravidlo pro vyhodnocení výše hodnoráře | NKSMLOUV nk26idh | 1,1 : 0,M | NKDRUHPR nk26id |
Položka smlouvy - má pravidlo pro vyhodnocení termínu splatnosti | NKSMLOUV nk26ids | 1,1 : 0,M | NKDRUHPR nk26id |
Položka smlouvy - má pravidlo pro vyhodnocení podmínky splatnosti | NKSMLOUV nk26idp | 1,1 : 0,M | NKDRUHPR nk26id |
Položka smlouvy - má pravidlo pro vyhodnocení termínu vyhodnocení | NKSMLOUV nk26idt | 1,1 : 0,M | NKDRUHPR nk26id |
Vlastnost hodnoty pravidla smlouvy - je vlastností hodnoty pravidla smlouvy | NKDRUHPA nk26id | 1,1 : 0,M s rušením | NKDRUHPR nk26id |
Interpretace referenční hodnoty pravidla smlouvy - je vlastností referenční hodnoty pravidla smlouvy | NKDRUHPI nk26id | 1,1 : 0,M s rušením | NKDRUHPR nk26id |
Pravidlo smlouvy druhu plnění položky smlouvy - používá pravidlo | NKPLNDRP nk26id | 1,1 : 0,M | NKDRUHPR nk26id |
Spojení druhu události plnění položky smlouvy k druhu události položky smlouvy - se uplatní pouze pro uvedený druh pravidla | NKPLNDRV nk26id | 0,1 : 0,M | NKDRUHPR nk26id |
Pravidlo smlouvy k pravidlu výše smlouvy - definuje pravidlo výše | NKPLNDRH nk26idh | 1,1 : 0,M s rušením | NKDRUHPR nk26id |
Pravidlo smlouvy k pravidlu výše smlouvy - definuje podřízené pravidlo | NKPLNDRH nk26id | 1,1 : 0,M | NKDRUHPR nk26id |

Indexy

Název | Primární | Výraz | Popis
ix_NKDRUHPR_nk26id | P | nk26id | Identifikace pravidla
ix_NKDRUHPR_nk26nazpra |  | nk26nazpra | Název pravidla


NKHODNP Hodnota parametru předmětu projektu

Popis

Hodnota parametru předmětu projektu

Atributy

Atribut | Typ | Návěští | Message | Popis
nk13 | C(12) | nk13 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
nk05id | C(6) | Parametr | Identifikace parametru předmětu projektu | Identifikace parametru předmětu projektu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
nk01verze | C(3) | Verze | Verze projektu | Verze projektu
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
nk09id | C(9) | ID | Identifikace hodnoty | Identifikace hodnoty
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
nk13dat1 | D | Datum 1 | Datumová položka 1 číselníku | Datumová položka 1 číselníku
nk13dat2 | D | Datum 2 | Datumová položka 2 číselníku | Datumová položka 2 číselníku
nk13num1 | N(20,4) | Num 1 | Numerická položka 1 číselníku | Numerická položka 1 číselníku
nk13num2 | N(20,4) | Num 2 | Numerická položka 2 číselníku | Numerická položka 2 číselníku
nk13text1 | C(80) | Text 1 | Textová položka 1 číselníku | Textová položka 1 číselníku
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
nk06id | C(6) | Umístění | Identifikace umístění | Identifikace umístění
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
nk13koment | M | Poznámka | Poznámka | Poznámka
nk05kateg | N(1,0) | Kategorie | Kategorie parametru | Kategorie parametru
nk13stav | N(1,0) | Stav | Stav hodnoty parametru Aktuální/Neaktuální | Stav hodnoty parametru Aktuální/Neaktuální

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Hodnota parametru předmětu projektu - je hodnotou parametru | NKHODNP nk05id | 1,1 : 0,M | NKPAR nk05id |
Hodnota parametru předmětu projektu - obsahuje hodnotu číselníku | NKHODNP nk09id | 1,1 : 0,M | NKCISHOD nk09id |
Hodnota parametru předmětu projektu - patří předmětu projektu | NKHODNP sp60id sp61id nk01verze | 1,1 : 0,M | NKPREDPR sp60id sp61id nk01verze |
Hodnota parametru předmětu projektu - byla založena v operaci procesu | NKHODNP sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Hodnota parametru předmětu projektu - má obchodní selektor | NKHODNP sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Hodnota parametru předmětu projektu - má organizační selektor | NKHODNP sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Hodnota parametru předmětu projektu - má technicko-věcný selektor | NKHODNP sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Hodnota parametru předmětu projektu - založil uživatele | NKHODNP bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Hodnota parametru předmětu projektu - čerpá kapacitu umístění | NKHODNP nk06id | 1,1 : 0,M | NKPARDRU nk06id |
Hodnota parametru předmětu projektu - se vztahuje ke spojení adresáta | NKHODNP ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Hodnota parametru předmětu projektu - je uvedena v měně | NKHODNP oc01id | 0,1 : 0,M | OCMENA oc01id |

Indexy

Název | Primární | Výraz | Popis
ix_NKHODNP_nk13 | P | nk13 | Jednoznačná časová identifikace
ix_NKHODNP_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_NKHODNP_nkpredpr |  | sp60id, sp61id, nk01verze | PI - SPARTIKL+nk01verze
ix_NKHODNP_nkparcis |  | nk09id, nk05id | PI - nk09id+nk05id
ix_NKHODNP_spartiknx |  |  |
ix_NKHODNP_adadsatx |  |  |
ix_NKHODNP_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_NKHODNP_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_NKHODNP_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_NKHODNP_oc01id |  | oc01id | Kód měny - oceňovací jednotky.
ix_NKHODNP_nk09id |  | nk09id | Identifikace hodnoty
ix_NKHODNP_nk05id |  | nk05id | Identifikace parametru předmětu projektu
ix_NKHODNP_nk13dat1 |  | nk13dat1 | Datumová položka 1 číselníku
ix_NKHODNP_nk13text1 |  | nk13text1 | Textová položka 1 číselníku
ix_NKHODNP_ad01id |  | ad01id | Identifikace adresáta
ix_NKHODNP_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_NKHODNP_nk06id |  | nk06id | Identifikace umístění
ix_NKHODNP_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_NKHODNP_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_NKHODNP_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_NKHODNP_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_NKHODNP_nk05kateg |  | nk05kateg | Kategorie parametru
ix_NKHODNP_nk13stav |  | nk13stav | Stav hodnoty parametru Aktuální/Neaktuální


NKINIPRE Inicializace předmětu projektu

Popis

Inicializace předmětu projektu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
nk01verze | C(3) | Verze | Verze projektu | Verze projektu
nk14d1 | D | @D1 | Parametr inicializace předmětu projektu - Datum 1 | Parametr inicializace předmětu projektu - Datum 1
nk14d2 | D | @D2 | Parametr inicializace předmětu projektu - Datum 2 | Parametr inicializace předmětu projektu - Datum 2
nk14d3 | D | @D3 | Parametr inicializace předmětu projektu - Datum 3 | Parametr inicializace předmětu projektu - Datum 3
nk14n1 | N(20,4) | @N1 | Parametr inicializace předmětu projektu - Num 1 | Parametr inicializace předmětu projektu - Num 1
nk14n2 | N(20,4) | @N2 | Parametr inicializace předmětu projektu - Num 2 | Parametr inicializace předmětu projektu - Num 2
nk14n3 | N(20,4) | @N3 | Parametr inicializace předmětu projektu - Num 3 | Parametr inicializace předmětu projektu - Num 3
nk14t1 | C(80) | @T1 | Parametr inicializace předmětu projektu - Text 1 | Parametr inicializace předmětu projektu - Text 1
nk14t2 | C(80) | @T2 | Parametr inicializace předmětu projektu - Text 2 | Parametr inicializace předmětu projektu - Text 2
nk14t3 | C(80) | @T3 | Parametr inicializace předmětu projektu - Text 3 | Parametr inicializace předmětu projektu - Text 3
nk14c1 | N(1,0) | @C1 | Parametr inicializace předmětu projektu - Seznam 1 | Parametr inicializace předmětu projektu - Seznam 1
nk14c2 | N(1,0) | @C2 | Parametr inicializace předmětu projektu - Seznam 2 | Parametr inicializace předmětu projektu - Seznam 2
nk14c3 | N(1,0) | @C3 | Parametr inicializace předmětu projektu - Seznam 3 | Parametr inicializace předmětu projektu - Seznam 3
sp60id2 | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id2 | C(3) | Druh | Identifikace druhu artiklu | Identifikace druhu artiklu
nk01verze2 | C(3) | Verze | Verze projektu | Verze projektu
nk05dedit | N(1,0) | Příb.hodnota | Příbuznost pro dědění hodnoty parametru při inicializaci | Příbuznost pro dědění hodnoty parametru při inicializaci

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Inicializace předmětu projektu - definuje hodnoty inicializace pro předmět projektu | NKINIPRE sp60id sp61id nk01verze | 1,1 : 0,M s rušením | NKPREDPR sp60id sp61id nk01verze |
Inicializace předmětu projektu - je odvozena z předmětu projektu | NKINIPRE sp60id2 sp61id2 nk01verze2 | 0,1 : 0,1 | NKPREDPR sp60id sp61id nk01verze |

Indexy

Název | Primární | Výraz | Popis
ix_NKINIPRE_nkpredpr | P | sp60id, sp61id, nk01verze | PI - SPARTIKL+nk01verze
ix_NKINIPRE_nkpredp2 |  | sp60id2, sp61id2, nk01verze2 | PI - SPARTIKL2+nk01verze2


NKINIWRK Pomocný soubor pro přepis inicializace

Popis

Pomocný soubor pro přepis inicializace

Atributy

Atribut | Typ | Návěští | Message | Popis
nk05id | C(6) | Parametr | Identifikace parametru předmětu projektu | Identifikace parametru předmětu projektu

Indexy

Název | Primární | Výraz | Popis
ix_NKINIWRK_nk05id | P | nk05id | Identifikace parametru předmětu projektu


NKPAR Parametr předmětu projektu

Popis

Parametr předmětu projektu

Atributy

Atribut | Typ | Návěští | Message | Popis
nk05id | C(6) | Parametr | Identifikace parametru předmětu projektu | Identifikace parametru předmětu projektu
nk05nazpar | C(40) | Název parametru | Název parametru předmětu projektu | Název parametru předmětu projektu
nk06id | C(6) | Umístění | Identifikace umístění | Identifikace umístění
nk35id | C(6) | Číselník | Identifikace číselníku | Identifikace číselníku
nk05koment | M | Poznámka | Poznámka k parametru předmětu projektu | Poznámka k parametru předmětu projektu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
nk05typ | N(1,0) | Typ | Typ parametru předmětu projektu Skupina/Hodnota | Typ parametru předmětu projektu Skupina/Hodnota
nk05zobraz | N(1,0) | Zobrazovat | Zobrazovaný parametr | Zobrazovaný parametr
nk05barva | N(1,0) | Barva | Barva parametru | Barva parametru
nk05napln | N(1,0) | Naplnění | Způsob naplnění hodnoty | Způsob naplnění hodnoty
nk05kateg | N(1,0) | Kategorie | Kategorie parametru | Kategorie parametru
nk05zhodn | M | Výraz zobrazení | Zobrazení hodnoty v mřížce a tisku | Zobrazení hodnoty v mřížce a tisku
nk05povin | N(1,0) | Povinný | Povinný parametr | Povinný parametr
nk05podm | M | Podmínka | Podmínka zařazení parametru | Podmínka zařazení parametru
nk05dedit | N(1,0) | Příb.hodnota | Příbuznost pro dědění hodnoty parametru při inicializaci | Příbuznost pro dědění hodnoty parametru při inicializaci
nk05koneid | N(1,0) | Kontrola EID | Povinná externí identifikace předmětu při vzniku události s tímto parametrem | Povinná externí identifikace předmětu při vzniku události s tímto parametrem
nk05konck | N(1,0) | Kontrola ČK | Povinný čárový kód předmětu při vzniku události s tímto parametrem | Povinný čárový kód předmětu při vzniku události s tímto parametrem
nk05deditv | N(1,0) | Příb.výskyt | Příbuznost pro dědění výskytu parametru při inicializaci nepovinného parametru | Příbuznost pro dědění výskytu parametru při inicializaci nepovinného parametru
nk05deditp | N(1,0) | Dědit pozn. | Při dědění hodnoty parametru dědit také poznámku | Při dědění hodnoty parametru dědit také poznámku
nk05privkl | N(1,0) | Přímý vstup | Přímé vkládání parametru z předmětu projektu | Přímé vkládání z předmětu projektu
nk05cetn | N(1,0) | Četnost | Četnost výskytu při přímém vkládání z předmětu projektu | Četnost výskytu při přímém vkládání z předmětu projektu
nk05verzav | N(1,0) | Závislý | Parametr je závislý na verzi předmětu projektu | Parametr je závislý na verzi předmětu projektu
nk05mavypo | N(1,0) | nk05mavypo | Příznak - parametr má elementární výpočtovou hodnotu | Příznak - parametr má elementární výpočtovou hodnotu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametr předmětu projektu - založil uživatel | NKPAR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Parametr předmětu projektu - má umístění | NKPAR nk06id | 1,1 : 0,M | NKPARDRU nk06id |
Parametr předmětu projektu - používá číselník | NKPAR nk35id | 1,1 : 0,M | NKCIS nk35id |
Vztah podřízenosti parametrů předmětu projektu - určuje nadřízený parametr | NKPARPAR nk05id | 1,1 : 0,M | NKPAR nk05id |
Vztah podřízenosti parametrů předmětu projektu - určuje podřízený parametr | NKPARPAR nk05id2 | 1,1 : 0,M s rušením | NKPAR nk05id |
Skupinový parametr prezentace parametrů - se týká parametru předmětu | NKPRPPAR nk05id | 1,1 : 0,M s rušením | NKPAR nk05id |
Prezentovaná hodnota parametru - má skupinový parametr | NKPRH nk05id | 1,1 : 0,M | NKPAR nk05id |
Prezentovaná hodnota parametru - má podřízený parametr | NKPRH nk05id2 | 1,1 : 0,M | NKPAR nk05id |
Hodnota parametru předmětu projektu - je hodnotou parametru | NKHODNP nk05id | 1,1 : 0,M | NKPAR nk05id |
Definice struktury elementární hodnoty parametru - se týká parametru | NKPARDEF nk05id | 1,1 : 0,M | NKPAR nk05id |
Záznam o změně stavu předmětu projektu nebo hodnoty jeho parametru - určuje záznam změny parametru | NKPREDZS nk05id | 0,1 : 0,M | NKPAR nk05id |

Indexy

Název | Primární | Výraz | Popis
ix_NKPAR_nk05id | P | nk05id | Identifikace parametru předmětu projektu
ix_NKPAR_nk05nazpar |  | nk05nazpar | Název parametru předmětu projektu
ix_NKPAR_nk06id |  | nk06id | Identifikace umístění
ix_NKPAR_nk35id |  | nk35id | Identifikace číselníku
ix_NKPAR_bw01uziv |  | bw01uziv | Identifikace uživatele systému


NKPARDEF Definice struktury elementární hodnoty parametru

Popis

Definice struktury elementární hodnoty parametru

Atributy

Atribut | Typ | Návěští | Message | Popis
nk15id | C(10) | Hodnota | Elementární hodnota | Elementární hodnota
nk05id | C(6) | Parametr | Identifikace parametru předmětu projektu | Identifikace parametru předmětu projektu
nk06id | C(6) | Umístění | Identifikace umístění | Identifikace umístění
nk15label | M | Návěští | Návěští elementární hodnoty | Návěští elementární hodnoty
nk15status | M | Stavový řádek | Stavový řádek elementární hodnoty | Stavový řádek elementární hodnoty
nk15init | M | Inicializace | Inicializace elementární hodnoty | Inicializace elementární hodnoty
nk15valid | M | Validace | Validace elementární hodnoty | Validace elementární hodnoty
nk15len | N(2,0) | Délka | Délka numerické elementární hodnoty | Délka numerické elementární hodnoty
nk15dec | N(1,0) | Desetiny | Desetiny numerické elementární hodnoty | Desetiny numerické elementární hodnoty
nk15zmeny | N(1,0) | Změny | Sledovat změny hodnot parametru | Sledovat změny hodnot parametru

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Definice struktury elementární hodnoty parametru - se týká parametru | NKPARDEF nk05id | 1,1 : 0,M | NKPAR nk05id |
Definice struktury elementární hodnoty parametru - má umístění | NKPARDEF nk06id | 1,1 : 0,M | NKPARDRU nk06id |

Indexy

Název | Primární | Výraz | Popis
ix_NKPARDEF_nk15pardef | P | nk15id, nk05id | PI - nk15id+nk05id
ix_NKPARDEF_nk06id |  | nk06id | Identifikace umístění
ix_NKPARDEF_nk05id |  | nk05id | Identifikace parametru předmětu projektu


NKPARDRU Umístění parametru předmětu projektu

Popis

Umístění parametru předmětu projektu

Atributy

Atribut | Typ | Návěští | Message | Popis
nk06id | C(6) | Umístění | Identifikace umístění | Identifikace umístění
nk06nazdru | C(40) | Název umístění | Název umístění parametru | Název umístění parametru musí být uveden
nk06koment | M | Poznámka | Poznámka k umístění parametru | Poznámka k umístění parametru
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
bw01uziv1 | C(6) | Majitel | Identifikace uživatele systému | Identifikace uživatele systému - druhá identifikace předplňovaná většinou na pozadí

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Umístění parametru předmětu projektu - založil uživatel | NKPARDRU bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Umístění parametru předmětu projektu - má organizační selektor | NKPARDRU sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Umístění parametru předmětu projektu - odpovídá adresátovi | NKPARDRU ad01id | 1,1 : 0,M | ADADSAT ad01id |
Umístění parametru předmětu projektu - reprezentuje uživatele systému | NKPARDRU bw01uziv1 | 1,1 : 0,M | BWUZIVAT bw01uziv |
Předmět projektu - má umístění | NKPREDPR nk06id | 1,1 : 0,M | NKPARDRU nk06id |
Parametr předmětu projektu - má umístění | NKPAR nk06id | 1,1 : 0,M | NKPARDRU nk06id |
Hodnota parametru předmětu projektu - čerpá kapacitu umístění | NKHODNP nk06id | 1,1 : 0,M | NKPARDRU nk06id |
Definice struktury elementární hodnoty parametru - má umístění | NKPARDEF nk06id | 1,1 : 0,M | NKPARDRU nk06id |
Aktuální hodnota PP - je pro umístění | NKAH nk06id | 1,1 : 0,M | NKPARDRU nk06id |
Položka smlouvy - se vztahuje k umístění | NKSMLOUV nk06id | 1,1 : 0,M | NKPARDRU nk06id |
Událost plnění položky smlouvy - se vztahuje k umístění | NKSMLPLN nk06id | 1,1 : 0,M | NKPARDRU nk06id |
Druh události položky smlouvy nebo události plnění položky smlouvy - má umístění pro druh události položky smlouvy | NKPLNDRU nk06id | 1,1 : 0,M | NKPARDRU nk06id |
Druh události položky smlouvy nebo události plnění položky smlouvy - má umístění pro druh události plnění položky smlouvy | NKPLNDRU nk06id2 | 1,1 : 0,M | NKPARDRU nk06id |

Indexy

Název | Primární | Výraz | Popis
ix_NKPARDRU_nk06id | P | nk06id | Identifikace umístění
ix_NKPARDRU_nk06nazdru |  | nk06nazdru | Název umístění parametru musí být uveden
ix_NKPARDRU_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_NKPARDRU_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_NKPARDRU_ad01id |  | ad01id | Identifikace adresáta
ix_NKPARDRU_bw01uziv1 |  | bw01uziv1 | Identifikace uživatele systému - druhá identifikace předplňovaná většinou na pozadí


NKPARPAR Vztah podřízenosti parametrů předmětu projektu

Popis

Vztah podřízenosti parametrů předmětu projektu

Atributy

Atribut | Typ | Návěští | Message | Popis
nk05id | C(6) | Parametr | Identifikace parametru předmětu projektu | Identifikace parametru předmětu projektu
nk05id2 | C(6) | Podřízený | Identifikace podřízeného parametru předmětu projektu | Identifikace podřízeného parametru předmětu projektu
nk07poradi | N(4,0) | Pořadí | Pořadí mezi podřízenými parametry | Pořadí mezi podřízenými parametry

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vztah podřízenosti parametrů předmětu projektu - určuje nadřízený parametr | NKPARPAR nk05id | 1,1 : 0,M | NKPAR nk05id |
Vztah podřízenosti parametrů předmětu projektu - určuje podřízený parametr | NKPARPAR nk05id2 | 1,1 : 0,M s rušením | NKPAR nk05id |

Indexy

Název | Primární | Výraz | Popis
ix_NKPARPAR_nkparpar | P | nk05id, nk05id2 | PI - nk05id+nk05id2
ix_NKPARPAR_nk05id |  | nk05id | Identifikace parametru předmětu projektu
ix_NKPARPAR_nk05id2 |  | nk05id2 | Identifikace podřízeného parametru předmětu projektu


NKPARTMP Temp soubor pro zabraneni rekurze pro vypoctu prezentace

Popis

Temp soubor pro zabraneni rekurze pro vypoctu prezentace

Atributy

Atribut | Typ | Návěští | Message | Popis
nk05id | C(6) | Parametr | Identifikace parametru předmětu projektu | Identifikace parametru předmětu projektu

Indexy

Název | Primární | Výraz | Popis
ix_NKPARTMP_nk05id | P | nk05id | Identifikace parametru předmětu projektu


NKPLNDOP Druh položky smlouvy použitelný v druhu operace

Popis

Druh položky smlouvy použitelný v druhu operace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
nk56id | C(6) | Plnění | Identifikace druhu události smlouvy | Identifikace druhu události smlouvy

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh položky smlouvy použitelný v druhu operace - definuje druh operace | NKPLNDOP sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Druh položky smlouvy použitelný v druhu operace - definuje druh položky smlouvy | NKPLNDOP nk56id | 1,1 : 0,M s rušením | NKPLNDRU nk56id |

Indexy

Název | Primární | Výraz | Popis
ix_NKPLNDOP_nkplndop | P | sp07idtyp, sp06idsubs, nk56id | PI - SPTYP+nk56id
ix_NKPLNDOP_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_NKPLNDOP_nk56id |  | nk56id | Identifikace druhu události smlouvy


NKPLNDRH Pravidlo smlouvy k pravidlu výše smlouvy

Popis

Pravidlo smlouvy k pravidlu výše smlouvy

Atributy

Atribut | Typ | Návěští | Message | Popis
nk26idh | C(6) | Výše | Pravidlo výše plnění | Pravidlo výše honoráře
nk26id | C(6) | Pravidlo | Identifikace pravidla | Identifikace pravidla
nk61implic | N(1,0) | Implicitní | Implicitní pro pravidlo výše | Implicitní pro pravidlo výše
nk61porad | N(3,0) | Pořadí | Pořadí pravidla smlouvy | Pořadí pravidla smlouvy

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Pravidlo smlouvy k pravidlu výše smlouvy - definuje pravidlo výše | NKPLNDRH nk26idh | 1,1 : 0,M s rušením | NKDRUHPR nk26id |
Pravidlo smlouvy k pravidlu výše smlouvy - definuje podřízené pravidlo | NKPLNDRH nk26id | 1,1 : 0,M | NKDRUHPR nk26id |

Indexy

Název | Primární | Výraz | Popis
ix_NKPLNDRH_nkplndrh | P | nk26idh, nk26id | PI - nk26idh+nk26id
ix_NKPLNDRH_nk26idh |  | nk26idh | Pravidlo výše honoráře
ix_NKPLNDRH_nk26id |  | nk26id | Identifikace pravidla


NKPLNDRO Vlastnost stavu smlouvy druhu plnění smlouvy

Popis

Vlastnost stavu smlouvy druhu plnění smlouvy

Atributy

Atribut | Typ | Návěští | Message | Popis
nk56id | C(6) | Plnění | Identifikace druhu události smlouvy | Identifikace druhu události smlouvy
nk27stav | N(1,0) | Stav | Stav položky smlouvy | Stav položky smlouvy
nk60ukonce | N(1,0) | Povoleno ukončit operaci | Povoleno ukončit operaci položky smlouvy | Povoleno ukončit operaci položky smlouvy
nk60edit | N(1,0) | Povolena oprava v ukončené operaci | Povolena oprava v ukončené operaci položky smlouvy | Povolena oprava v ukončené operaci položky smlouvy
nk60zmukon | N(1,0) | Zrušení ukončení operace | Zrušení ukončení operace položky smlouvy při nastavení na stav | Zrušení ukončení operace položky smlouvy při nastavení na stav

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vlastnost stavu smlouvy druhu plnění smlouvy - platí pro druh události plnění položky smlouvy | NKPLNDRO nk56id | 1,1 : 0,M s rušením | NKPLNDRU nk56id |

Indexy

Název | Primární | Výraz | Popis
ix_NKPLNDRO_nkplndro | P | nk56id, nk27stav | PI - nk56id+nk27stav
ix_NKPLNDRO_nk56id |  | nk56id | Identifikace druhu události smlouvy


NKPLNDRP Pravidlo smlouvy druhu plnění položky smlouvy

Popis

Pravidlo smlouvy druhu plnění položky smlouvy

Atributy

Atribut | Typ | Návěští | Message | Popis
nk56id | C(6) | Plnění | Identifikace druhu události smlouvy | Identifikace druhu události smlouvy
nk26id | C(6) | Pravidlo | Identifikace pravidla | Identifikace pravidla
nk57porad | N(3,0) | Pořadí | Pořadí pravidla smlouvy druhu události smlouvy | Pořadí pravidla smlouvy druhu události smlouvy
nk57implic | N(1,0) | Implicitní | Implicitní pro druh události smlouvy | Implicitní pro druh události smlouvy
nk57pstav | N(1,0) | Poč.stav | Počáteční stav položky smlouvy při jejím založení | Počáteční stav položky smlouvy při jejím založení
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
nk57script | M | Skript | Script pro určení obchodovatelného artiklu volaný s parametrem _attr='SP61ID2' resp. _attr='SP60ID2' a _this=thisform | Script pro určení obchodovatelného artiklu volaný s parametrem _attr='SP61ID2' resp. _attr='SP60ID2' a _this=thisform

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Pravidlo smlouvy druhu plnění položky smlouvy - používá pravidlo | NKPLNDRP nk26id | 1,1 : 0,M | NKDRUHPR nk26id |
Pravidlo smlouvy druhu plnění položky smlouvy - je použito v druhu události smluv | NKPLNDRP nk56id | 1,1 : 0,M s rušením | NKPLNDRU nk56id |
Pravidlo smlouvy druhu plnění položky smlouvy - má předplňovaný artikl obchodu při vstupu smlouvy | NKPLNDRP sp60id sp61id | 0,1 : 0,M | OBARTIKL sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_NKPLNDRP_nkplndrp | P | nk56id, nk26id | PI - nk56id+nk26id
ix_NKPLNDRP_nk56id |  | nk56id | Identifikace druhu události smlouvy
ix_NKPLNDRP_nk26id |  | nk26id | Identifikace pravidla
ix_NKPLNDRP_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id


NKPLNDRU Druh události položky smlouvy nebo události plnění položky smlouvy

Popis

Druh události položky smlouvy nebo události plnění položky smlouvy

Atributy

Atribut | Typ | Návěští | Message | Popis
nk56id | C(6) | Plnění | Identifikace druhu události smlouvy | Identifikace druhu události smlouvy
nk56nazdru | C(40) | Název druhu | Název druhu události smlouvy | Název druhu události smlouvy
nk06id | C(6) | Umístění | Identifikace umístění | Identifikace umístění
nk06id2 | C(6) | Umístění plnění | Identifikátor umístění druhu události plnění položky smlouvy | Identifikátor umístění druhu události plnění položky smlouvy
nk56smlouv | N(1,0) | Položky smluv | Uplatňuje se také pro položky smluv | Uplatňuje se také pro položky smluv
nk56povruc | N(1,0) | Vstup ze smluv | Povolen ruční vstup z událostí smluv | Povolen ruční vstup z událostí smluv
nk56jepst | N(2,0) | Nastavuje počáteční stav položky | Nastavuje počáteční stav položky smlouvy při jejím založení Ano/Ne | Nastavuje počáteční stav položky smlouvy při jejím založení Ano/Ne
nk56pstav | N(2,0) | Počáteční stav | Počáteční stav položky smlouvy při jejím založení | Počáteční stav položky smlouvy při jejím založení
nk56zstav | N(2,0) | Změna stavu | Změna stavu položky smlouvy při plnění smlouvy | Změna stavu položky smlouvy při plnění smlouvy
nk56koment | M | Komentář | Komentář | Komentář
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
nk56porad | N(3,0) | Poř. | Pořadí zobrazení v seznamu plnění | Pořadí zobrazení v seznamu plnění
nk27termp | N(2,0) | Perioda | Perioda vyhodnocení v měsících | Perioda vyhodnocení v měsících
nk56term | M | Výraz termínu | Výraz pro přednastavení termínu vyhodnocení | Výraz pro přednastavení termínu vyhodnocení
nk56id2 | C(6) | Pro vyúčtování zálohy | Druh události smlouv pro vyúčtování zálohy | Druh události smlouv pro vyúčtování zálohy
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
nk56tid | N(3,0) | TID | Pomocný identifikátor pro transformace | Pomocný identifikátor pro transformace
nk56prucho | N(2,0) | Průchod | Pořadové číslo průchodu vyhodnocení události smlouvy | Pořadové číslo průchodu vyhodnocení události smlouvy
nk56plnen | N(2,0) | Charakter | Charakter druhu události smlouvy | Charakter druhu události smlouvy
nk56presel | N(1,0) | Selektory | Způsob předplňování selektorů Nákup = TVS<-obch.art.,OBS<-PP / Prodej = TVS<-PP | Způsob předplňování selektorů Nákup = TVS<-obch.art.,OBS<-PP / Prodej = TVS<-PP

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh události položky smlouvy nebo události plnění položky smlouvy - má umístění pro druh události položky smlouvy | NKPLNDRU nk06id | 1,1 : 0,M | NKPARDRU nk06id |
Druh události položky smlouvy nebo události plnění položky smlouvy - založil uživatel | NKPLNDRU bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Druh události položky smlouvy nebo události plnění položky smlouvy - má definovaný druh události pro vyúčtování zálohy | NKPLNDRU nk56id2 | 0,1 : 0,M | NKPLNDRU nk56id |
Druh události položky smlouvy nebo události plnění položky smlouvy - má umístění pro druh události plnění položky smlouvy | NKPLNDRU nk06id2 | 1,1 : 0,M | NKPARDRU nk06id |
Druh události položky smlouvy nebo události plnění položky smlouvy - má předplňovaný artikl obchodu při vstupu smlouvy | NKPLNDRU sp60id sp61id | 0,1 : 0,M | OBARTIKL sp60id sp61id |
Druh události položky smlouvy nebo události plnění položky smlouvy - má předplňovanou měnu | NKPLNDRU oc01id | 0,1 : 0,M | OCMENA oc01id |
Položka smlouvy - je druhu události položky | NKSMLOUV nk56id | 1,1 : 0,M | NKPLNDRU nk56id |
Událost plnění položky smlouvy - je druhu události položky | NKSMLPLN nk56id | 1,1 : 0,M | NKPLNDRU nk56id |
Druh události položky smlouvy nebo události plnění položky smlouvy - má definovaný druh události pro vyúčtování zálohy | NKPLNDRU nk56id2 | 0,1 : 0,M | NKPLNDRU nk56id |
Pravidlo smlouvy druhu plnění položky smlouvy - je použito v druhu události smluv | NKPLNDRP nk56id | 1,1 : 0,M s rušením | NKPLNDRU nk56id |
Spojení druhu události plnění položky smlouvy k druhu události položky smlouvy - určuje validovaný druh události položky smlouvy | NKPLNDRV nk56id | 1,1 : 0,M s rušením | NKPLNDRU nk56id |
Spojení druhu události plnění položky smlouvy k druhu události položky smlouvy - určuje validní druh události plnění k druhu události položky smlouvy | NKPLNDRV nk56id2 | 1,1 : 0,M | NKPLNDRU nk56id |
Vlastnost stavu smlouvy druhu plnění smlouvy - platí pro druh události plnění položky smlouvy | NKPLNDRO nk56id | 1,1 : 0,M s rušením | NKPLNDRU nk56id |
Druh položky smlouvy použitelný v druhu operace - definuje druh položky smlouvy | NKPLNDOP nk56id | 1,1 : 0,M s rušením | NKPLNDRU nk56id |

Indexy

Název | Primární | Výraz | Popis
ix_NKPLNDRU_nk56id | P | nk56id | Identifikace druhu události smlouvy
ix_NKPLNDRU_nk56nazdru |  | nk56nazdru | Název druhu události smlouvy
ix_NKPLNDRU_nk06id |  | nk06id | Identifikace umístění
ix_NKPLNDRU_nk06id2 |  | nk06id2 | Identifikátor umístění druhu události plnění položky smlouvy
ix_NKPLNDRU_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_NKPLNDRU_nk56id2 |  | nk56id2 | Druh události smlouv pro vyúčtování zálohy
ix_NKPLNDRU_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_NKPLNDRU_oc01id |  | oc01id | Kód měny - oceňovací jednotky.


NKPLNDRV Spojení druhu události plnění položky smlouvy k druhu události položky

Popis

Spojení druhu události plnění položky smlouvy k druhu události položky smlouvy

Atributy

Atribut | Typ | Návěští | Message | Popis
nk56id | C(6) | Plnění | Identifikace druhu události smlouvy | Identifikace druhu události smlouvy
nk56id2 | C(6) | Pro vyúčtování zálohy | Druh události smlouv pro vyúčtování zálohy | Druh události smlouv pro vyúčtování zálohy
nk58porad | N(3,0) | Poř. | Pořadí zobrazení v seznamu plnění | Pořadí zobrazení v seznamu plnění
nk26id | C(6) | Pravidlo | Identifikace pravidla | Identifikace pravidla

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Spojení druhu události plnění položky smlouvy k druhu události položky smlouvy - určuje validovaný druh události položky smlouvy | NKPLNDRV nk56id | 1,1 : 0,M s rušením | NKPLNDRU nk56id |
Spojení druhu události plnění položky smlouvy k druhu události položky smlouvy - určuje validní druh události plnění k druhu události položky smlouvy | NKPLNDRV nk56id2 | 1,1 : 0,M | NKPLNDRU nk56id |
Spojení druhu události plnění položky smlouvy k druhu události položky smlouvy - se uplatní pouze pro uvedený druh pravidla | NKPLNDRV nk26id | 0,1 : 0,M | NKDRUHPR nk26id |

Indexy

Název | Primární | Výraz | Popis
ix_NKPLNDRV_nkplndrv | P | nk56id, nk56id2 | PI - nk56id+nk56id2
ix_NKPLNDRV_nk56id |  | nk56id | Identifikace druhu události smlouvy
ix_NKPLNDRV_nk56id2 |  | nk56id2 | Druh události smlouv pro vyúčtování zálohy
ix_NKPLNDRV_nk26id |  | nk26id | Identifikace pravidla


NKPREDPR Předmět projektu

Popis

Je to vlastně artikl komponenty Nakladatelství.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
nk01verze | C(3) | Verze | Verze projektu | Verze projektu
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
nk01 | C(12) | nk01 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
nk10id | C(6) | Prezentace | Identifikace prezentace parametrů | Identifikace prezentace parametrů
nk01nazpra | C(50) | Prac. název | Pracovní název projektu |
nk06id | C(6) | Umístění | Identifikace umístění | Identifikace umístění
nk01ck | C(36) | Čárový kód | Čárový kód artiklu, který vznikne projektem |
nk01exid | C(36) | Externí ID | Externí identifikace předmětu projektu |
nk01stav | N(1,0) | Stav | Stav projektu (uvažovaný, zahájený,...) | Stav projektu (uvažovaný, zahájený,...)
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
nk01popis | M | nk01popis |  |
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
nk01uzavre | N(1,0) | Uzavřen | Popis předmětu uzavřen pro opravy Ano/Ne | Popis předmětu uzavřen pro opravy Ano/Ne

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Předmět projektu - je artiklem | NKPREDPR sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Předmět projektu - založil uživatel | NKPREDPR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Předmět projektu - má obchodní selektor | NKPREDPR sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Předmět projektu - Má TV selektor | NKPREDPR sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Předmět projektu - má vedoucího projektu | NKPREDPR ad01id | 1,1 : 0,M | ADADSAT ad01id |
Předmět projektu - používá prezentaci parametrů | NKPREDPR nk10id | 1,1 : 0,M | NKPRP nk10id |
Předmět projektu - používá inicializační operaci | NKPREDPR sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 0,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Předmět projektu - má umístění | NKPREDPR nk06id | 1,1 : 0,M | NKPARDRU nk06id |
Hodnota parametru předmětu projektu - patří předmětu projektu | NKHODNP sp60id sp61id nk01verze | 1,1 : 0,M | NKPREDPR sp60id sp61id nk01verze |
Inicializace předmětu projektu - definuje hodnoty inicializace pro předmět projektu | NKINIPRE sp60id sp61id nk01verze | 1,1 : 0,M s rušením | NKPREDPR sp60id sp61id nk01verze |
Inicializace předmětu projektu - je odvozena z předmětu projektu | NKINIPRE sp60id2 sp61id2 nk01verze2 | 0,1 : 0,1 | NKPREDPR sp60id sp61id nk01verze |
Položka smlouvy - se vztahuje k předmětu projektu | NKSMLOUV sp60id sp61id nk01verze | 1,1 : 0,M | NKPREDPR sp60id sp61id nk01verze |
Projektový úkol - je prvkem předmětu projektu | NKUKOL sp60id sp61id nk01verze | 1,1 : 0,M | NKPREDPR sp60id sp61id nk01verze |
Záznam o změně stavu předmětu projektu nebo hodnoty jeho parametru - se týká předmětu projektu | NKPREDZS sp60id sp61id nk01verze | 1,1 : 0,M s rušením | NKPREDPR sp60id sp61id nk01verze |
Aktuální hodnota projektových úkolů - je pro předmět projektu | NKAHUK sp60id sp61id nk01verze | 1,1 : 0,M | NKPREDPR sp60id sp61id nk01verze |
Aktuální hodnota plnění projektových úkolů - je pro předmět projektu | NKAHUP sp60id sp61id nk01verze | 1,1 : 0,M | NKPREDPR sp60id sp61id nk01verze |

Indexy

Název | Primární | Výraz | Popis
ix_NKPREDPR_nkpredpr | P | sp60id, sp61id, nk01verze | PI - SPARTIKL+nk01verze
ix_NKPREDPR_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_NKPREDPR_spprc |  | sp33cisd, sp33cisdpm, sp33cisdr | Identifikace procesu
ix_NKPREDPR_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_NKPREDPR_spartiknx |  |  |
ix_NKPREDPR_nk01 | U | nk01 | Jednoznačná časová identifikace
ix_NKPREDPR_sp61id |  | sp61id | Identifikace druhu artiklu
ix_NKPREDPR_sp60id |  | sp60id | Identifikace artiklu
ix_NKPREDPR_nk10id |  | nk10id | Identifikace prezentace parametrů
ix_NKPREDPR_nk01nazpra |  | nk01nazpra |
ix_NKPREDPR_nk06id |  | nk06id | Identifikace umístění
ix_NKPREDPR_nk01ck |  | nk01ck |
ix_NKPREDPR_nk01exid |  | nk01exid |
ix_NKPREDPR_ad01id |  | ad01id | Identifikace adresáta
ix_NKPREDPR_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_NKPREDPR_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_NKPREDPR_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_NKPREDPR_sp00datzap |  | sp00datzap | Datum a čas zápisu záznamu události


NKPREDZS Záznam o změně stavu předmětu projektu nebo hodnoty jeho parametru

Popis

Záznam o změně stavu předmětu projektu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
nk01verze | C(3) | Verze | Verze projektu | Verze projektu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
nk71porad | C(6) | nk71porad | Pořadové číslo změny v rámci předmětu |
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
nk71koment | M | Poznámka | Poznámka | Poznámka
nk01stav | N(1,0) | Stav | Stav projektu (uvažovaný, zahájený,...) | Stav projektu (uvažovaný, zahájený,...)
nk71typzme | N(1,0) | Typ změny | Typ změny - Stav předmětu projektu/Hodnota parametru | Typ změny - Stav předmětu/Hodnota parametru
nk05id | C(6) | Parametr | Identifikace parametru předmětu projektu | Identifikace parametru předmětu projektu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Záznam o změně stavu předmětu projektu nebo hodnoty jeho parametru - se týká předmětu projektu | NKPREDZS sp60id sp61id nk01verze | 1,1 : 0,M s rušením | NKPREDPR sp60id sp61id nk01verze |
Záznam o změně stavu předmětu projektu nebo hodnoty jeho parametru - založil uživatel | NKPREDZS bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Záznam o změně stavu předmětu projektu nebo hodnoty jeho parametru - určuje záznam změny parametru | NKPREDZS nk05id | 0,1 : 0,M | NKPAR nk05id |

Indexy

Název | Primární | Výraz | Popis
ix_NKPREDZS_nkpredzs | P | sp60id, sp61id, nk01verze, sp33cisdpm, nk71porad | PI - NKPREDPR+nk71porad
ix_NKPREDZS_nkpredpr |  | sp60id, sp61id, nk01verze | PI - SPARTIKL+nk01verze
ix_NKPREDZS_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_NKPREDZS_nk05id |  | nk05id | Identifikace parametru předmětu projektu


NKPRH Prezentovaná hodnota parametru

Popis

Prezentovaná hodnota parametru

Atributy

Atribut | Typ | Návěští | Message | Popis
nk10id | C(6) | Prezentace | Identifikace prezentace parametrů | Identifikace prezentace parametrů
nk18id | C(6) | Skupina | Identifikace skupiny | Identifikace skupiny
nk05id | C(6) | Parametr | Identifikace parametru předmětu projektu | Identifikace parametru předmětu projektu
nk05id2 | C(6) | Podřízený | Identifikace podřízeného parametru předmětu projektu | Identifikace podřízeného parametru předmětu projektu
nk11poradi | N(6,0) | Pořadí | Pořadí v prezentaci | Pořadí v prezentaci

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Prezentovaná hodnota parametru - patří k prezentaci parametrů | NKPRH nk10id | 1,1 : 0,M | NKPRP nk10id |
Prezentovaná hodnota parametru - má skupinový parametr | NKPRH nk05id | 1,1 : 0,M | NKPAR nk05id |
Prezentovaná hodnota parametru - má podřízený parametr | NKPRH nk05id2 | 1,1 : 0,M | NKPAR nk05id |
Prezentovaná hodnota parametru - patří do skupiny | NKPRH nk18id | 1,1 : 0,M | NKSKUPIN nk18id |

Indexy

Název | Primární | Výraz | Popis
ix_NKPRH_nkprh | P | nk10id, nk18id, nk05id, nk05id2, nk11poradi | PI - nk11poradi+nk10id+nk05id+nk05id2
ix_NKPRH_nk10id |  | nk10id | Identifikace prezentace parametrů
ix_NKPRH_nk05id |  | nk05id | Identifikace parametru předmětu projektu
ix_NKPRH_nk05id2 |  | nk05id2 | Identifikace podřízeného parametru předmětu projektu
ix_NKPRH_nk18id |  | nk18id | Identifikace skupiny


NKPRP Prezentace parametrů

Popis

Prezentace parametrů

Atributy

Atribut | Typ | Návěští | Message | Popis
nk10id | C(6) | Prezentace | Identifikace prezentace parametrů | Identifikace prezentace parametrů
nk10nazprp | C(40) | Název prezentace | Název prezentace parametrů | Název prezentace parametrů
nk10koment | M | Poznámka | Poznámka k prezentaci parametrů | Poznámka k prezentaci parametrů
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
nk10defa | N(1,0) | Implicitní | Implicitní prezentace - při vstupu nového předmětu projektu | Implicitní prezentace - při vstupu nového předmětu projektu
nk10script | M | Script | Script používaný v souvislosti s předmětem projektu | Script používaný v souvislosti s předmětem projektu inicializace PP - filtr parametrů - Lparameters _ucel='FILTR_INICIALIZACE',_nk05id

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Prezentace parametrů - definuje inicializační proces předmětu projektu | NKPRP sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Předmět projektu - používá prezentaci parametrů | NKPREDPR nk10id | 1,1 : 0,M | NKPRP nk10id |
Skupinový parametr prezentace parametrů - se týká prezentace parametrů | NKPRPPAR nk10id | 1,1 : 0,M | NKPRP nk10id |
Prezentovaná hodnota parametru - patří k prezentaci parametrů | NKPRH nk10id | 1,1 : 0,M | NKPRP nk10id |
Popis hodnoty inicializace - popisuje hodnotu prezentace | NKPRPPOP nk10id | 1,1 : 0,M s rušením | NKPRP nk10id |

Indexy

Název | Primární | Výraz | Popis
ix_NKPRP_nk10id | P | nk10id | Identifikace prezentace parametrů
ix_NKPRP_nk10nazprp |  | nk10nazprp | Název prezentace parametrů
ix_NKPRP_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému


NKPRPPAR Skupinový parametr prezentace parametrů

Popis

Skupinový parametr prezentace parametrů

Atributy

Atribut | Typ | Návěští | Message | Popis
nk10id | C(6) | Prezentace | Identifikace prezentace parametrů | Identifikace prezentace parametrů
nk05id | C(6) | Parametr | Identifikace parametru předmětu projektu | Identifikace parametru předmětu projektu
nk18id | C(6) | Skupina | Identifikace skupiny | Identifikace skupiny
nk08poradi | N(4,0) | Pořadí | Pořadí skupinového parametru předmětu projektu | Pořadí skupinového parametru předmětu projektu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Skupinový parametr prezentace parametrů - se týká parametru předmětu | NKPRPPAR nk05id | 1,1 : 0,M s rušením | NKPAR nk05id |
Skupinový parametr prezentace parametrů - se týká prezentace parametrů | NKPRPPAR nk10id | 1,1 : 0,M | NKPRP nk10id |
Skupinový parametr prezentace parametrů - patří do skupiny | NKPRPPAR nk18id | 1,1 : 0,M | NKSKUPIN nk18id |

Indexy

Název | Primární | Výraz | Popis
ix_NKPRPPAR_nkprppar | P | nk10id, nk05id | PI - nk10id + nk05id
ix_NKPRPPAR_nk10id |  | nk10id | Identifikace prezentace parametrů
ix_NKPRPPAR_nk05id |  | nk05id | Identifikace parametru předmětu projektu
ix_NKPRPPAR_nk18id |  | nk18id | Identifikace skupiny


NKPRPPOP Popis hodnoty inicializace

Popis

Popis hodnoty inicializace

Atributy

Atribut | Typ | Návěští | Message | Popis
nk10id | C(6) | Prezentace | Identifikace prezentace parametrů | Identifikace prezentace parametrů
nk23id | C(4) | ID | Identifikátor hodnoty inicializace | Idenitfikátor hodnoty inicializace
nk23label | M | Návěští | Návěští hodnoty inicializace | Návěští hodnoty inicializace
nk23combo | M | Seznam | Překryvný seznam hodnoty inicializace | Překryvný seznam hodnoty inicializace
nk23valid | M | Validace | Validace hodnoty inicializace | Validace hodnoty inicializace
nk23status | M | Stavový řádek | Stavový řádek hodnoty inicializace | Stavový řádek hodnoty inicializace
nk23len | N(2,0) | Délka | Délka hodnoty | Délka hodnoty
nk23dec | N(1,0) | Desetiny | Desetiny numerické hodnoty | Desetiny numerické hodnoty
nk23dedit | N(1,0) | Dědit | Dědit hodnotu inicializace | Dědit hodnotu inicializace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis hodnoty inicializace - popisuje hodnotu prezentace | NKPRPPOP nk10id | 1,1 : 0,M s rušením | NKPRP nk10id |

Indexy

Název | Primární | Výraz | Popis
ix_NKPRPPOP_nkprppop | P | nk10id, nk23id |
ix_NKPRPPOP_nk10id |  | nk10id | Identifikace prezentace parametrů


NKROLE Role aktéra

Popis

Role aktéra

Atributy

Atribut | Typ | Návěští | Message | Popis
nk25id | C(6) | Role | Identifikace role aktéra | Identifikace role aktéra
nk25nazrol | C(40) | Název role | Název role aktéra | Název role aktéra
nk25koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Položka smlouvy - je vztažena k roli aktéra | NKSMLOUV nk25id | 1,1 : 0,M | NKROLE nk25id |

Indexy

Název | Primární | Výraz | Popis
ix_NKROLE_nk25id | P | nk25id | Identifikace role aktéra
ix_NKROLE_nk25nazrol |  | nk25nazrol | Název role aktéra


NKSKUPIN Skupina skupinového parametru

Popis

Skupina skupinového parametru

Atributy

Atribut | Typ | Návěští | Message | Popis
nk18id | C(6) | Skupina | Identifikace skupiny | Identifikace skupiny
nk18nazskp | C(40) | Název skupiny | Název skupiny | Název skupiny
nk18koment | M | Komentář | Komentář | Komentář

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Skupinový parametr prezentace parametrů - patří do skupiny | NKPRPPAR nk18id | 1,1 : 0,M | NKSKUPIN nk18id |
Prezentovaná hodnota parametru - patří do skupiny | NKPRH nk18id | 1,1 : 0,M | NKSKUPIN nk18id |

Indexy

Název | Primární | Výraz | Popis
ix_NKSKUPIN_nk18id | P | nk18id | Identifikace skupiny
ix_NKSKUPIN_nk18nazskp |  | nk18nazskp | Název skupiny


NKSMLOUV Položka smlouvy

Popis

Položka smlouvy

Atributy

Atribut | Typ | Návěští | Message | Popis
nk27 | C(12) | nk27 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
nk56id | C(6) | Plnění | Identifikace druhu události smlouvy | Identifikace druhu události smlouvy
nk27plnen | N(2,0) | Plnění | Charakter plnění položky smlouvy | Charakter plnění položky smlouvy
nk27predan | N(1,0) | Předání | Způsob předání | Způsob předání
nk27stav | N(1,0) | Stav | Stav položky smlouvy | Stav položky smlouvy
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
nk01verze | C(3) | Verze | Verze projektu | Verze projektu
nk27porad | C(3) | Poř. | Pořadové číslo položky smlouvy k předmětu projektu | Pořadové číslo položky smlouvy k předmětu projektu
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
sp60id2 | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id2 | C(3) | Druh | Identifikace druhu artiklu | Identifikace druhu artiklu
ad03cisban | C(2) | Účet | Identifikátor spojení na bankovní účet adresáta. | Číslo spojení na bankovní účet adresáta. *** Dříve CISBANK.
pa13id | C(12) | Klasifikace | Identifikace klasifikace objektu | Identifikace klasifikace objektu
bw55objec | C(2) | Identifikace objektu BM | Identifikace objektu BM | Identifikace objektu BM
nk06id | C(6) | Umístění | Identifikace umístění | Identifikace umístění
nk25id | C(6) | Role | Identifikace role aktéra | Identifikace role aktéra
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
nk26idh | C(6) | Výše | Pravidlo výše plnění | Pravidlo výše honoráře
nk26ids | C(6) | Splatnost | Pravidlo termínu splatnosti | Pravidlo termínu splatnosti
nk26idp | C(6) | Podmínka | Pravidlo podmínky platnosti | Pravidlo podmínky splatnosti
nk26idt | C(6) | Agregace | Agregace | Agregace
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
nk27datum | D | Datum | Datum položky smlouvy | Datum položky smlouvy
nk27text | C(40) | Popis | Popis položky smlouvy | Popis položky smlouvy
nk27koment | M | Poznámka | Poznámka | Poznámka
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
nk27den | N(3,0) | Den vyhodnocení | Den automatizovaného vyhodnocení | Den automatizovaného vyhodnocení
nk27obdobi | N(1,0) | Období | Období vyhodnocení | Období vyhodnocení
nk27zaloha | N(20,4) | Záloha | Záloha spojená s položkou smlouvy | Záloha spojená s položkou smlouvy
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
nk27termd | D | Termín | Termín prvního vyhodnocení | Termín prvního vyhodnocení
nk27termp | N(2,0) | Perioda | Perioda vyhodnocení v měsících | Perioda vyhodnocení v měsících
nk27sdat1 | D | Datum S1 | Splatnost - datumová položka 1 | Splatnost - datumová položka 1
nk27snum1 | N(13,4) | Num S1 | Splatnost - numerická položka 1 | Splatnost - numerická položka 1
nk27sdat2 | D | Datum S2 | Splatnost - datumová položka 2 | Splatnost - datumová položka 2
nk27snum2 | N(13,4) | Num S2 | Splatnost - numerická položka 2 | Splatnost - numerická položka 2
nk27hdat1 | D | Datum H1 | Výše honoráře - datumová položka 1 | Výše honoráře - datumová položka 1
nk27hnum1 | N(13,4) | Num H1 | Výše honoráře - numerická položka 1 | Výše honoráře - numerická položka 1
nk27hdat2 | D | Datum H2 | Výše honoráře - datumová položka 2 | Výše honoráře - datumová položka 2
nk27hnum2 | N(13,4) | Num H2 | Výše honoráře - numerická položka 2 | Výše honoráře - numerická položka 2
nk27hdat3 | D | Datum H3 | Výše honoráře - datumová položka 3 | Výše honoráře - datumová položka 3
nk27hnum3 | N(13,4) | Num H3 | Výše honoráře - numerická položka 3 | Výše honoráře - numerická položka 3
nk27hnum4 | N(13,4) | Num H4 | Výše honoráře - numerická položka 4 | Výše honoráře - numerická položka 4
nk27hnum5 | N(20,4) | Num H5 | Výše honoráře - numerická položka 5 | Výše honoráře - numerická položka 5
nk27hnum6 | N(20,4) | Num H6 | Výše honoráře - numerická položka 6 | Výše honoráře - numerická položka 6
nk27hnum7 | N(20,4) | Num H7 | Výše honoráře - numerická položka 7 | Výše honoráře - numerická položka 7
nk27hnum8 | N(20,4) | Num H8 | Výše honoráře - numerická položka 8 | Výše honoráře - numerická položka 8
nk27hnum9 | N(20,4) | Num H9 | Výše honoráře - numerická položka 9 | Výše honoráře - datumová položka 4
nk27pdat1 | D | Datum P1 | Podmínka vyhodnocení - datumová položka 1 | Podmínka vyhodnocení - datumová položka 1
nk27pnum1 | N(13,4) | Num P1 | Podmínka vyhodnocení - numerická položka 1 | Podmínka vyhodnocení - numerická položka 1
nk27pdat2 | D | Datum P2 | Podmínka vyhodnocení - datumová položka 2 | Podmínka vyhodnocení - datumová položka 2
nk27pnum2 | N(13,4) | Num P2 | Podmínka vyhodnocení - numerická položka 2 | Podmínka vyhodnocení - numerická položka 1
nk27htxt1 | C(40) | Txt H1 | Podmínka vyhodnocení - textová položka 1 | Podmínka vyhodnocení - textová položka 1

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Položka smlouvy - vznikla v operaci | NKSMLOUV sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Položka smlouvy - se vztahuje k předmětu projektu | NKSMLOUV sp60id sp61id nk01verze | 1,1 : 0,M | NKPREDPR sp60id sp61id nk01verze |
Položka smlouvy - je vztažena ke spojení adresáta | NKSMLOUV ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Položka smlouvy - je vztažena k adresátovi | NKSMLOUV ad01id | 1,1 : 0,M | ADADSAT ad01id |
Položka smlouvy - je vztažena k roli aktéra | NKSMLOUV nk25id | 1,1 : 0,M | NKROLE nk25id |
Položka smlouvy - má obchodní selektor | NKSMLOUV sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Položka smlouvy - má organizační selektor | NKSMLOUV sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Položka smlouvy - má technicko-věcný selektor | NKSMLOUV sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Položka smlouvy - má pravidlo pro vyhodnocení výše hodnoráře | NKSMLOUV nk26idh | 1,1 : 0,M | NKDRUHPR nk26id |
Položka smlouvy - má pravidlo pro vyhodnocení termínu splatnosti | NKSMLOUV nk26ids | 1,1 : 0,M | NKDRUHPR nk26id |
Položka smlouvy - má pravidlo pro vyhodnocení podmínky splatnosti | NKSMLOUV nk26idp | 1,1 : 0,M | NKDRUHPR nk26id |
Položka smlouvy - má pravidlo pro vyhodnocení termínu vyhodnocení | NKSMLOUV nk26idt | 1,1 : 0,M | NKDRUHPR nk26id |
Položka smlouvy - založil uživatel | NKSMLOUV bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Položka smlouvy - je o měně | NKSMLOUV oc01id | 1,1 : 0,M | OCMENA oc01id |
Položka smlouvy - se vztahuje k umístění | NKSMLOUV nk06id | 1,1 : 0,M | NKPARDRU nk06id |
Položka smlouvy - je spojena s obchodovatelným artiklem | NKSMLOUV sp60id2 sp61id2 | 1,1 : 0,M | OBARTIKL sp60id sp61id |
Položka smlouvy - bude vyhodnocena pro bankovní spojení | NKSMLOUV ad01id ad03cisban | 0,1 : 0,M | ADBUCTY ad01id ad03cisban |
Položka smlouvy - je druhu události položky | NKSMLOUV nk56id | 1,1 : 0,M | NKPLNDRU nk56id |
Položka smlouvy - je druhu objektu | NKSMLOUV pa13id bw55objec | 1,1 : 0,M | PAOBJDRU pa13id bw55objec |
Událost plnění položky smlouvy - ve vztahuje k položce smlouvy | NKSMLPLN sp60id sp61id nk01verze nk27porad | 1,1 : 0,M | NKSMLOUV sp60id sp61id nk01verze nk27porad |
Záloha čerpaná položkou smlouvy - je záloha položky smlouvy | NKSMLZAL sp60id sp61id nk01verze nk27porad | 1,1 : 0,M s rušením | NKSMLOUV sp60id sp61id nk01verze nk27porad |

Indexy

Název | Primární | Výraz | Popis
ix_NKSMLOUV_nk27 | P | nk27 | Jednoznačná časová identifikace
ix_NKSMLOUV_nk56id |  | nk56id | Identifikace druhu události smlouvy
ix_NKSMLOUV_nk27plnen |  | nk27plnen | Charakter plnění položky smlouvy
ix_NKSMLOUV_nk27stav |  | nk27stav | Stav položky smlouvy
ix_NKSMLOUV_nksmlouv | U | sp60id, sp61id, nk01verze, nk27porad | NKPREDPR+nk27porad
ix_NKSMLOUV_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_NKSMLOUV_nkpredpr |  | sp60id, sp61id, nk01verze | PI - SPARTIKL+nk01verze
ix_NKSMLOUV_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_NKSMLOUV_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_NKSMLOUV_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_NKSMLOUV_spartikl2 |  | sp60id2, sp61id2 | CI - sp60id2+sp61id2
ix_NKSMLOUV_adbucty1 |  | ad01id, ad03cisban | ad01id+ad03cisban
ix_NKSMLOUV_spartiknx |  |  |
ix_NKSMLOUV_adadsatx |  |  |
ix_NKSMLOUV_paobjdru |  | pa13id, bw55objec | PI - pa13id+bw55objec
ix_NKSMLOUV_nk06id |  | nk06id | Identifikace umístění
ix_NKSMLOUV_nk25id |  | nk25id | Identifikace role aktéra
ix_NKSMLOUV_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_NKSMLOUV_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_NKSMLOUV_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_NKSMLOUV_nk26idh |  | nk26idh | Pravidlo výše honoráře
ix_NKSMLOUV_nk26ids |  | nk26ids | Pravidlo termínu splatnosti
ix_NKSMLOUV_nk26idp |  | nk26idp | Pravidlo podmínky splatnosti
ix_NKSMLOUV_nk26idt |  | nk26idt | Agregace
ix_NKSMLOUV_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_NKSMLOUV_nk27datum |  | nk27datum | Datum položky smlouvy
ix_NKSMLOUV_nk27text |  | nk27text | Popis položky smlouvy
ix_NKSMLOUV_ad01id |  | ad01id | Identifikace adresáta
ix_NKSMLOUV_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_NKSMLOUV_sp00datzap |  | sp00datzap | Datum a čas zápisu záznamu události
ix_NKSMLOUV_oc01id |  | oc01id | Kód měny - oceňovací jednotky.


NKSMLPLN Událost plnění položky smlouvy

Popis

Událost plnění položky smlouvy

Atributy

Atribut | Typ | Návěští | Message | Popis
nk30 | C(12) | nk30 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
nk56id | C(6) | Plnění | Identifikace druhu události smlouvy | Identifikace druhu události smlouvy
nk27plnen | N(2,0) | Plnění | Charakter plnění položky smlouvy | Charakter plnění položky smlouvy
nk27predan | N(1,0) | Předání | Způsob předání | Způsob předání
nk30zstav | N(1,0) | Stav | Změna stavu položky smlouvy | Změna stavu položky smlouvy
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
nk01verze | C(3) | Verze | Verze projektu | Verze projektu
nk27porad | C(3) | Poř. | Pořadové číslo položky smlouvy k předmětu projektu | Pořadové číslo položky smlouvy k předmětu projektu
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp60id2 | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id2 | C(3) | Druh | Identifikace druhu artiklu | Identifikace druhu artiklu
nk06id | C(6) | Umístění | Identifikace umístění | Identifikace umístění
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
nk30datum | D | Datum | Datum plnění | Datum plnění
nk30text | C(40) | Popis | Popis události | Popis události
nk30hodnot | N(20,4) | Hodnota | Hodnota plnění | Hodnota plnění
nk30koment | M | Poznámka | Poznámka | Poznámka
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
za02id | C(32) | Záloha | Identifikace zálohy | Identifikace zálohy
nk30datspl | D | Splatnost | Datum splatnosti | Datum splatnosti
nk30spozn | M | Poznámka ke splatnosti | Poznámka ke splatnosti | Poznámka ke splatnosti
nk30hpozn | M | Poznámka k výši | Poznámka k výši | Poznámka k výši
nk30ppozn | M | Poznámka k podmínce | Poznámka k podmínce | Poznámka k podmínce
nk30tpozn | M | Poznámka k agregaci | Poznámka k agregaci | Poznámka k agregaci
nk30rfr1 | N(20,4) | Reference | Referenční hodnota - základní | Referenční hodnota - základní
nk30rfr2 | N(20,4) | Reference 2 | Referenční hodnota - 2 | Referenční hodnota - 2
nk30rfr3 | N(20,4) | Reference 3 | Referenční hodnota - 3 | Referenční hodnota - 3
nk30rfr4 | N(20,4) | Reference 4 | Referenční hodnota - 4 | Referenční hodnota - 4
nk30rfr5 | N(20,4) | Reference 5 | Referenční hodnota - 5 | Referenční hodnota - 5
nk30poradi | N(4,0) | Pořadí | Pořadí události v operaci | Pořadí události v operaci
nk30rfr6 | N(20,4) | Reference 6 | Referenční hodnota - 6 | Referenční hodnota - 6
nk30rfr7 | N(20,4) | Reference 7 | Referenční hodnota - 7 | Referenční hodnota - 7
nk30rfr8 | N(20,4) | Reference 8 | Referenční hodnota - 8 | Referenční hodnota - 8

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost plnění položky smlouvy - vznikla v operaci | NKSMLPLN sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost plnění položky smlouvy - ve vztahuje k položce smlouvy | NKSMLPLN sp60id sp61id nk01verze nk27porad | 1,1 : 0,M | NKSMLOUV sp60id sp61id nk01verze nk27porad |
Událost plnění položky smlouvy - založil uživatel | NKSMLPLN bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost plnění položky smlouvy - má obchodní selektor | NKSMLPLN sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost plnění položky smlouvy - má organizační selektor | NKSMLPLN sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost plnění položky smlouvy - má technicko-věcný selektor | NKSMLPLN sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost plnění položky smlouvy - má měnu | NKSMLPLN oc01id | 1,1 : 0,M | OCMENA oc01id |
Událost plnění položky smlouvy - je spojena s obchodovatelným artiklem | NKSMLPLN sp60id2 sp61id2 | 1,1 : 0,M | OBARTIKL sp60id sp61id |
Událost plnění položky smlouvy - se vztahuje k umístění | NKSMLPLN nk06id | 1,1 : 0,M | NKPARDRU nk06id |
Událost plnění položky smlouvy - je druhu události položky | NKSMLPLN nk56id | 1,1 : 0,M | NKPLNDRU nk56id |

Indexy

Název | Primární | Výraz | Popis
ix_NKSMLPLN_nk30 | P | nk30 | Jednoznačná časová identifikace
ix_NKSMLPLN_nk56id |  | nk56id | Identifikace druhu události smlouvy
ix_NKSMLPLN_nk27plnen |  | nk27plnen | Charakter plnění položky smlouvy
ix_NKSMLPLN_nksmlouv |  | sp60id, sp61id, nk01verze, nk27porad | NKPREDPR+nk27porad
ix_NKSMLPLN_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_NKSMLPLN_nkpredpr |  | sp60id, sp61id, nk01verze | PI - SPARTIKL+nk01verze
ix_NKSMLPLN_spartikl2 |  | sp60id2, sp61id2 | CI - sp60id2+sp61id2
ix_NKSMLPLN_spartiknx |  |  |
ix_NKSMLPLN_adadsatx |  |  |
ix_NKSMLPLN_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_NKSMLPLN_nk06id |  | nk06id | Identifikace umístění
ix_NKSMLPLN_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_NKSMLPLN_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_NKSMLPLN_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_NKSMLPLN_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_NKSMLPLN_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_NKSMLPLN_sp00datzap |  | sp00datzap | Datum a čas zápisu záznamu události
ix_NKSMLPLN_nk30datum |  | nk30datum | Datum plnění
ix_NKSMLPLN_nk30text |  | nk30text | Popis události
ix_NKSMLPLN_oc01id |  | oc01id | Kód měny - oceňovací jednotky.
ix_NKSMLPLN_za02id |  | za02id | Identifikace zálohy
ix_NKSMLPLN_nk30datspl |  | nk30datspl | Datum splatnosti
ix_NKSMLPLN_nk30poradi |  | nk30poradi | Pořadí události v operaci


NKSMLPLT Událost plnění položky smlouvy před importem

Popis

Událost plnění položky smlouvy před importem

Atributy

Atribut | Typ | Návěští | Message | Popis
nk36 | C(18) | nk36 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
nk56id | C(6) | Plnění | Identifikace druhu události smlouvy | Identifikace druhu události smlouvy
nk27plnen | N(2,0) | Plnění | Charakter plnění položky smlouvy | Charakter plnění položky smlouvy
nk27predan | N(1,0) | Předání | Způsob předání | Způsob předání
nk30zstav | N(1,0) | Stav | Změna stavu položky smlouvy | Změna stavu položky smlouvy
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
nk01verze | C(3) | Verze | Verze projektu | Verze projektu
nk27porad | C(3) | Poř. | Pořadové číslo položky smlouvy k předmětu projektu | Pořadové číslo položky smlouvy k předmětu projektu
sp60id2 | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id2 | C(3) | Druh | Identifikace druhu artiklu | Identifikace druhu artiklu
nk30datum | D | Datum | Datum plnění | Datum plnění
nk30datspl | D | Splatnost | Datum splatnosti | Datum splatnosti
nk30text | C(40) | Popis | Popis události | Popis události
nk30hodnot | N(20,4) | Hodnota | Hodnota plnění | Hodnota plnění
nk27stav | N(1,0) | Stav | Stav položky smlouvy | Stav položky smlouvy
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
za02id | C(32) | Záloha | Identifikace zálohy | Identifikace zálohy
nk30spozn | M | Poznámka ke splatnosti | Poznámka ke splatnosti | Poznámka ke splatnosti
nk30hpozn | M | Poznámka k výši | Poznámka k výši | Poznámka k výši
nk30ppozn | M | Poznámka k podmínce | Poznámka k podmínce | Poznámka k podmínce
nk30tpozn | M | Poznámka k agregaci | Poznámka k agregaci | Poznámka k agregaci
nk30koment | M | Poznámka | Poznámka | Poznámka
nk36slucov | C(80) | Slučování | Slučování záznamů | Slučování záznamů
nk30rfr1 | N(20,4) | Reference | Referenční hodnota - základní | Referenční hodnota - základní
nk30rfr2 | N(20,4) | Reference 2 | Referenční hodnota - 2 | Referenční hodnota - 2
nk30rfr3 | N(20,4) | Reference 3 | Referenční hodnota - 3 | Referenční hodnota - 3
nk30rfr4 | N(20,4) | Reference 4 | Referenční hodnota - 4 | Referenční hodnota - 4
nk30rfr5 | N(20,4) | Reference 5 | Referenční hodnota - 5 | Referenční hodnota - 5

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost plnění položky smlouvy před importem - je spojena s obchodovatelným artiklem | NKSMLPLT sp60id2 sp61id2 | 1,1 : 0,M | OBARTIKL sp60id sp61id |
Událost plnění položky smlouvy před importem - má obchodní selektor | NKSMLPLT sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost plnění položky smlouvy před importem - má organizační selektor | NKSMLPLT sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost plnění položky smlouvy před importem - má technicko-věcný selektor | NKSMLPLT sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |

Indexy

Název | Primární | Výraz | Popis
ix_NKSMLPLT_nk36 | P | nk36 | Jednoznačná časová identifikace
ix_NKSMLPLT_nk56id |  | nk56id | Identifikace druhu události smlouvy
ix_NKSMLPLT_nksmlouv |  | sp60id, sp61id, nk01verze, nk27porad | NKPREDPR+nk27porad
ix_NKSMLPLT_nkpredpr |  | sp60id, sp61id, nk01verze | PI - SPARTIKL+nk01verze
ix_NKSMLPLT_spartikl2 |  | sp60id2, sp61id2 | CI - sp60id2+sp61id2
ix_NKSMLPLT_spartiknx |  |  |
ix_NKSMLPLT_adadsatx |  |  |
ix_NKSMLPLT_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_NKSMLPLT_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_NKSMLPLT_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.


NKSMLPLZ Karta zálohy plnění smluv

Popis

Karta zálohy plnění smluv

Atributy

Atribut | Typ | Návěští | Message | Popis
za02id | C(32) | Záloha | Identifikace zálohy | Identifikace zálohy
oc01id2 | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
za02pripos | N(1,0) | P/P | Záloha přijatá/poskytnutá | Záloha přijatá/poskytnutá
za02cumnv | N(20,4) | Zbývá vyúčtovat | Dosud nevyúčtovaná část zálohy | Dosud nevyúčtovaná část zálohy
za02cum | N(20,4) | Částka v MÚ | Částka v měně úhrady zálohy | Částka v měně předepsání zálohy

Indexy

Název | Primární | Výraz | Popis
ix_NKSMLPLZ_zakarta |  | za02id, oc01id2, ad01id, za02pripos |
ix_NKSMLPLZ_za02id |  | za02id | Identifikace zálohy
ix_NKSMLPLZ_ad01id |  | ad01id | Identifikace adresáta


NKSMLRAD Číselná řada smluv

Popis

Číselná řada smluv

Atributy

Atribut | Typ | Návěští | Message | Popis
nk93idu | C(2) | IDÚ | Identifikace datového úložiště | Identifikace datového úložiště
nk93porad1 | C(3) | Od | Pořadí smlouvy OD | Pořadí smlouvy OD
nk93porad2 | C(3) | Do | Pořadí smlouvy DO | Pořadí smlouvy DO
nk93koment | M | Poznámka | Poznámka | Poznámka

Indexy

Název | Primární | Výraz | Popis
ix_NKSMLRAD_nk93idu | P | nk93idu | Identifikace datového úložiště


NKSMLZAL Záloha čerpaná položkou smlouvy

Popis

Záloha čerpaná položkou skmlouvy

Atributy

Atribut | Typ | Návěští | Message | Popis
za02id | C(32) | Záloha | Identifikace zálohy | Identifikace zálohy
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
nk01verze | C(3) | Verze | Verze projektu | Verze projektu
nk27porad | C(3) | Poř. | Pořadové číslo položky smlouvy k předmětu projektu | Pořadové číslo položky smlouvy k předmětu projektu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Záloha čerpaná položkou smlouvy - je záloha položky smlouvy | NKSMLZAL sp60id sp61id nk01verze nk27porad | 1,1 : 0,M s rušením | NKSMLOUV sp60id sp61id nk01verze nk27porad |

Indexy

Název | Primární | Výraz | Popis
ix_NKSMLZAL_nksmlzal | P | za02id, sp60id, sp61id, nk01verze, nk27porad |
ix_NKSMLZAL_nksmlouv |  | sp60id, sp61id, nk01verze, nk27porad | NKPREDPR+nk27porad
ix_NKSMLZAL_za02id |  | za02id | Identifikace zálohy


NKUKDIA Uzel v diagramu složeného projektového úkolu

Popis

Uzel v diagramu složeného projektového úkolu

Atributy

Atribut | Typ | Návěští | Message | Popis
nk43d | C(12) | nk43d | Jednoznačná časová identifikace diagramu | Jednoznačná časová identifikace diagramu
nk43 | C(12) | nk43 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
nk49left | N(5,0) | nk49left | Pozice okna - levá souřadnice | Pozice okna - levá souřadnice
nk49top | N(5,0) | nk49top | Pozice okna - horní souřadnice | Pozice okna - horní souřadnice
nk49height | N(4,0) | nk49height | Výška okna | Výška okna
nk49width | N(4,0) | nk49width | Šířka okna | Šířka okna

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Uzel v diagramu složeného projektového úkolu - je odkazem na diagram složeného projektového úkolu | NKUKDIA nk43d | 1,1 : 0,M s rušením | NKUKOL nk43 |
Uzel v diagramu složeného projektového úkolu - má vložený projektový úkol | NKUKDIA nk43 | 1,1 : 0,M s rušením | NKUKOL nk43 |
Vazba mezi uzly diagramu složeného projektového úkolu - definuje vazbu předchůdce | NKUKDIAV nk43d nk43 | 1,1 : 0,M s rušením | NKUKDIA nk43d nk43 |
Vazba mezi uzly diagramu složeného projektového úkolu - definuje vazbu následníka | NKUKDIAV nk43d nk43n | 1,1 : 0,M s rušením | NKUKDIA nk43d nk43 |

Indexy

Název | Primární | Výraz | Popis
ix_NKUKDIA_nkukdia | P | nk43d, nk43 | PI - nk43d+nk43
ix_NKUKDIA_nk43d |  | nk43d | Jednoznačná časová identifikace diagramu
ix_NKUKDIA_nk43 |  | nk43 | Jednoznačná časová identifikace


NKUKDIAP Temporary pro výběr množiny projektových úkolů

Popis

Temporary pro výběr množiny projektových úkolů

Atributy

Atribut | Typ | Návěští | Message | Popis
nk43 | C(12) | nk43 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
nk52datz | D | Nové zahájení | Vypočtené datum zahájení | Vypočtené datum zahájení
nk52datu | D | nk52datu | Vypočtené datum ukončení | Vypočtené datum ukončení
nk52cislo | N(5,0) | Číslo | Číslo úkolu při přepočtu úkolu | Číslo úkolu při přepočtu úkolu

Indexy

Název | Primární | Výraz | Popis
ix_NKUKDIAP_nk43 | P | nk43 | Jednoznačná časová identifikace


NKUKDIAV Vazba mezi uzly diagramu složeného projektového úkolu

Popis

Vazba mezi uzly diagramu složeného projektového úkolu

Atributy

Atribut | Typ | Návěští | Message | Popis
nk43d | C(12) | nk43d | Jednoznačná časová identifikace diagramu | Jednoznačná časová identifikace diagramu
nk43 | C(12) | nk43 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
nk43n | C(12) | nk43n | Jednoznačná časová identifikace následujícího úkolu | Jednoznačná časová identifikace následujícího úkolu
nk50posun | N(4,0) | nk50posun | Časový posun zahájení následujícího úkolu | Časový posun zahájení následujícího úkolu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vazba mezi uzly diagramu složeného projektového úkolu - definuje vazbu předchůdce | NKUKDIAV nk43d nk43 | 1,1 : 0,M s rušením | NKUKDIA nk43d nk43 |
Vazba mezi uzly diagramu složeného projektového úkolu - definuje vazbu následníka | NKUKDIAV nk43d nk43n | 1,1 : 0,M s rušením | NKUKDIA nk43d nk43 |

Indexy

Název | Primární | Výraz | Popis
ix_NKUKDIAV_nkudiav | P | nk43d, nk43, nk43n | PI - nk43d+nk43+nk43n
ix_NKUKDIAV_nkukdia |  | nk43d, nk43 | PI - nk43d+nk43
ix_NKUKDIAV_nkudian |  | nk43d, nk43n | CI - nk43d+nk43n
ix_NKUKDIAV_nk43d |  | nk43d | Jednoznačná časová identifikace diagramu
ix_NKUKDIAV_nk43 |  | nk43 | Jednoznačná časová identifikace


NKUKDPD Druh plnění úkolu použitelný pro druh úkolu projektového řízení

Popis

Druh plnění úkolu použitelný pro druh úkolu projektového řízení

Atributy

Atribut | Typ | Návěští | Message | Popis
nk53id | C(6) | Druh | Identifikátor druhu úkolů | Identifikátor druhu úkolů
nk70id | C(6) | Druh | Identifikace druhu plnění úkolu projektového řízení | Identifikace druhu plnění úkolu projektového řízení
nk80implic | N(1,0) | Předplňovat | Předplňovat pro druh projektového úkolu | Předplňovat pro druh projektového úkolu
nk80porad | N(3,0) | Pořadí | Pořadí zobrazení druhu plnění | Pořadí zobrazení druhu plnění

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh plnění úkolu použitelný pro druh úkolu projektového řízení - určuje druh projektového úkolu | NKUKDPD nk53id | 1,1 : 0,M s rušením | NKUKOLD nk53id |
Druh plnění úkolu použitelný pro druh úkolu projektového řízení - určuje druh plnění projektového úkolu | NKUKDPD nk70id | 1,1 : 0,M | NKUKOPD nk70id |

Indexy

Název | Primární | Výraz | Popis
ix_NKUKDPD_nkukdpd | P | nk53id, nk70id | PI - nk53id+nk70id
ix_NKUKDPD_nk53id |  | nk53id | Identifikátor druhu úkolů
ix_NKUKDPD_nk70id |  | nk70id | Identifikace druhu plnění úkolu projektového řízení


NKUKOL Projektový úkol

Popis

Projektový úkol

Atributy

Atribut | Typ | Návěští | Message | Popis
nk43 | C(12) | nk43 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
nk01verze | C(3) | Verze | Verze projektu | Verze projektu
nk43porad | C(6) | Poř. | Pořadí v rámci úkolů předmětu projektu | Pořadí v rámci úkolů předmětu projektu
nk43idu | C(2) | IDÚ úkolu | Identifikace datového úložiště úkolu | Identifikace datového úložiště úkolu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
pa13id | C(12) | Klasifikace | Identifikace klasifikace objektu | Identifikace klasifikace objektu
bw55objec | C(2) | Identifikace objektu BM | Identifikace objektu BM | Identifikace objektu BM
nk53id | C(6) | Druh | Identifikátor druhu úkolů | Identifikátor druhu úkolů
nk42id | C(6) | Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu | Identifikátor zadavatele úkolu pro řešitele
nk44id | C(6) | Řešitel | Identifikace řešitele | Identifikace řešitele
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor druhu operace | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
nk43dennar | N(8,2) | Dnů | Časová náročnost ve dnech | Časová náročnost ve dnech
nk43procpl | N(6,2) | % | Procento plnění | Procento plnění
nk43datz | D | Zahájení | Datum zahájení | Datum zahájení
nk43text | C(40) | Popis | Popis úkolu | Popis úkolu
nk43datu | D | Ukončení | Datum ukončení | Datum ukončení
nk43nakpla | N(20,4) | Plán.náklady | Výše plánovaných nákladů | Výše plánovaných nákladů
nk43nakrea | N(20,4) | Real.náklady | Výše realizovaných nákladů | Výše realizovaných nákladů
nk43datarn | D | Aktualizace | Datum poslední aktualizace realizovaných nákladů | Datum poslední aktualizace realizovaných nákladů
nk43stav | N(1,0) | Stav | Stav projektového úkolu | Stav prvku projektu
nk43koment | M | Poznámka | Poznámka k projektovému úkolu | Poznámka
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
nk01stav | N(1,0) | Stav | Stav projektu (uvažovaný, zahájený,...) | Stav projektu (uvažovaný, zahájený,...)
nk43prior | N(2,0) | Priorita | Priorita projektového úkolu | Priorita projektového úkolu
nk43fixov | N(1,0) | Fixovat | Fixování - Ne,Zahájení,Ukončení - při plánování úkolu | Fixování - Ne,Zahájení,Ukončení - při plánování úkolu
nk43datfix | D | Ke dni | Fixované datum zahájení nebo ukončení | Fixované datum zahájení nebo ukončení
nk43zpdtz | N(1,0) | Zpráva při změně zahájení | Odeslat zprávu vedoucímu projektu při změně data zahájen | Odeslat zprávu vedoucímu projektu při změně data zahájení
nk43zpdtu | N(1,0) | Zpráva při změně ukončení | Odeslat zprávu vedoucímu projektu při změně data ukončení | Odeslat zprávu vedoucímu projektu při změně data ukončení
nk43oppor | N(3,0) | Pořadí | Pořadí úkolu v rámci operace | Pořadí úkolu v rámci operace
nk43komen2 | M | Další poznámka | Další poznámka zadavatele k úkolu | Další poznámka zadavatele k úkolu
pa01id | C(6) | Sada | Identifikátor sady parametrů | Identifikátor sady parametrů
pa01oblast | C(2) | Oblast | Oblast sady parametrů | Oblast sady parametrů
nk43casz | C(4) | Čas zahájení | Čas zahájení | Čas zahájení
nk43casu | C(4) | Čas ukončení | Čas ukončení | Čas ukončení

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Projektový úkol - je spojen s adresátem | NKUKOL ad01id | 1,1 : 0,M | ADADSAT ad01id |
Projektový úkol - je prvkem předmětu projektu | NKUKOL sp60id sp61id nk01verze | 1,1 : 0,M | NKPREDPR sp60id sp61id nk01verze |
Projektový úkol - byl založen v operaci | NKUKOL sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Projektový úkol - má řešitele | NKUKOL nk44id | 1,1 : 0,M | NKZDROJ nk44id |
Projektový úkol - má obchodní selektor | NKUKOL sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Projektový úkol - má organizační selektor | NKUKOL sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Projektový úkol - má technicko-věcný selektor | NKUKOL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Projektový úkol - založil uživatel | NKUKOL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Projektový úkol - je druhu úkolů | NKUKOL nk53id | 1,1 : 0,M | NKUKOLD nk53id |
Projektový úkol - používá sadu parametrů | NKUKOL pa01id pa01oblast | 1,1 : 0,M | PASADA pa01id pa01oblast |
Projektový úkol - má zadavetele | NKUKOL nk42id | 1,1 : 0,M | NKZDROJ nk44id |
Projektový úkol - má klasifikaci | NKUKOL pa13id bw55objec | 1,1 : 0,M | PAOBJDRU pa13id bw55objec |
Uzel v diagramu složeného projektového úkolu - je odkazem na diagram složeného projektového úkolu | NKUKDIA nk43d | 1,1 : 0,M s rušením | NKUKOL nk43 |
Uzel v diagramu složeného projektového úkolu - má vložený projektový úkol | NKUKDIA nk43 | 1,1 : 0,M s rušením | NKUKOL nk43 |
Generický projektový úkol - je definován projektovým úkolem | NKUKOLG sp60id sp61id nk01verze nk43porad nk43idu | 1,1 : 0,1 s rušením | NKUKOL sp60id sp61id nk01verze nk43porad nk43idu |
Plnění projektového úkolu - se týká projektového úkolu | NKUKOLP sp60id sp61id nk01verze nk43porad nk43idu | 1,1 : 0,M | NKUKOL sp60id sp61id nk01verze nk43porad nk43idu |
Záznam o změně vlastností úkolu - se vztahuje k úkolu | NKUKOLH nk43 | 1,1 : 0,M s rušením | NKUKOL nk43 |
Definice náhrady při aplikaci generického projektového úkolu - je určena pro úkol, který je součástí generického úkolu | NKUKOLGU sp60id2 sp61id2 nk01verze2 nk43porad2 nk43idu2 | 1,1 : 0,M s rušením | NKUKOL sp60id sp61id nk01verze nk43porad nk43idu |
Host úkolu - určuje projektový úkol | NKUKOLRH nk43 | 1,1 : 0,M s rušením | NKUKOL nk43 |
Záznam o plnění úkolu v programu EVIVYK.EXE - se týká projektového úkolu | NKUKOLPE sp60id sp61id nk01verze nk43porad nk43idu | 1,1 : 0,M | NKUKOL sp60id sp61id nk01verze nk43porad nk43idu |

Indexy

Název | Primární | Výraz | Popis
ix_NKUKOL_nk43 | P | nk43 | Jednoznačná časová identifikace
ix_NKUKOL_nkukol | U | sp60id, sp61id, nk01verze, nk43porad, nk43idu | UI - NKPREDPR+sp33cisdpm+nk43porad
ix_NKUKOL_ad01id |  | ad01id | Identifikace adresáta
ix_NKUKOL_nkpredpr |  | sp60id, sp61id, nk01verze | PI - SPARTIKL+nk01verze
ix_NKUKOL_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_NKUKOL_spartiknx |  |  |
ix_NKUKOL_adadsatx |  |  |
ix_NKUKOL_paobjdru |  | pa13id, bw55objec | PI - pa13id+bw55objec
ix_NKUKOL_nk53id |  | nk53id | Identifikátor druhu úkolů
ix_NKUKOL_nk42id |  | nk42id | Identifikátor zadavatele úkolu pro řešitele
ix_NKUKOL_nk44id |  | nk44id | Identifikace řešitele
ix_NKUKOL_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_NKUKOL_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_NKUKOL_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_NKUKOL_nk43datz |  | nk43datz | Datum zahájení
ix_NKUKOL_nk43datu |  | nk43datu | Datum ukončení
ix_NKUKOL_nk43stav |  | nk43stav | Stav prvku projektu
ix_NKUKOL_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_NKUKOL_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_NKUKOL_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_NKUKOL_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_NKUKOL_sp00datzap |  | sp00datzap | Datum a čas zápisu záznamu události
ix_NKUKOL_nk43prior |  | nk43prior | Priorita projektového úkolu
ix_NKUKOL_nk43oppor |  | nk43oppor | Pořadí úkolu v rámci operace
ix_NKUKOL_pasada |  | pa01id, pa01oblast | PI - pa01id+pa01oblast
ix_NKUKOL_nk43casze |  | nk43datz, nk43casz | KY - nk43datz+nk43casz
ix_NKUKOL_nk43casue |  | nk43datu, nk43casu | KY - nk43datu+nk43casu


NKUKOLD Druh projektového úkolu

Popis

Druh projektových úkolů

Atributy

Atribut | Typ | Návěští | Message | Popis
nk53id | C(6) | Druh | Identifikátor druhu úkolů | Identifikátor druhu úkolů
pa01id | C(6) | Sada | Identifikátor sady parametrů | Identifikátor sady parametrů
pa01oblast | C(2) | Oblast | Oblast sady parametrů | Oblast sady parametrů
pa13id | C(12) | Klasifikace | Identifikace klasifikace objektu | Identifikace klasifikace objektu
bw55objec | C(2) | Identifikace objektu BM | Identifikace objektu BM | Identifikace objektu BM
nk42id | C(6) | Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu | Identifikátor zadavatele úkolu pro řešitele
nk44id | C(6) | Řešitel | Identifikace řešitele | Identifikace řešitele
nk53koment | M | Poznámka | Poznámka | Poznámka
nk72id | C(6) | Prezentace | Identifikátor prezentace úkolu v diagramech | Identifikátor prezentace úkolu v diagramech
nk53typ | N(1,0) | Typ | Typ úkolu - složený=je složen z více úkolů | Typ úkolu - složený=je složen z více úkolů
nk43zpdtz | N(1,0) | Zpráva při změně zahájení | Odeslat zprávu vedoucímu projektu při změně data zahájen | Odeslat zprávu vedoucímu projektu při změně data zahájení
nk43zpdtu | N(1,0) | Zpráva při změně ukončení | Odeslat zprávu vedoucímu projektu při změně data ukončení | Odeslat zprávu vedoucímu projektu při změně data ukončení
nk01stav | N(1,0) | Stav | Stav projektu (uvažovaný, zahájený,...) | Stav projektu (uvažovaný, zahájený,...)
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
nk53harmon | N(1,0) | Harmonogram | Zobrazovat v harmonogramu projektových úkolů | Zobrazovat v harmonogramu projektových úkolů
nk53milnik | N(1,0) | Milník | Milník Ano/Ne | Milník Ano/Ne
nk53prezad | N(1,0) | Předplňovat zadavatele | Předplňovat zadavatele při vstupu úkolu | Předplňovat zadavatele při vstupu úkolu
nk53preres | N(1,0) | Předplňovat řešitele | Předplňovat řešitele při vstupu úkolu | Předplňovat řešitele při vstupu úkolu
nk53nazdru | C(40) | Název druhu úkolu | Název druhu úkolu | Název druhu úkolu
nk53osobni | N(1,0) | Osobní | Druh osobních projektových úkolů | Druh osobních projektových úkolů
nk53zprres | N(1,0) | Připomenutí řešiteli | Při založení úkolu automaticky odeslat připomentutí-zprávu řešiteli | Při založení úkolu automaticky odeslat připomentutí-zprávu řešiteli

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh projektového úkolu - předplňuje řešitele úkolu | NKUKOLD nk44id | 1,1 : 0,M | NKZDROJ nk44id |
Druh projektového úkolu - má TV-selektor | NKUKOLD sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Druh projektového úkolu - prezentuje události v diagramech projektového úkolu | NKUKOLD nk72id | 1,1 : 0,M | NKUKOLX nk72id |
Druh projektového úkolu - předplňuje sadu parametrů pro projektový úkol | NKUKOLD pa01id pa01oblast | 1,1 : 0,M | PASADA pa01id pa01oblast |
Druh projektového úkolu - má zadavetele úkolu | NKUKOLD nk42id | 1,1 : 0,M | NKZDROJ nk44id |
Druh projektového úkolu - předplňuje klasifikaci projektového úkolu | NKUKOLD pa13id bw55objec | 1,1 : 0,M | PAOBJDRU pa13id bw55objec |
Projektový úkol - je druhu úkolů | NKUKOL nk53id | 1,1 : 0,M | NKUKOLD nk53id |
Aktuální hodnota projektových úkolů - je pro druh projektového úkolu | NKAHUK nk53id | 1,1 : 0,M | NKUKOLD nk53id |
Aktuální hodnota plnění projektových úkolů - je pro druh projektového úkolu | NKAHUP nk53idp | 1,1 : 0,M | NKUKOLD nk53id |
Druh plnění úkolu použitelný pro druh úkolu projektového řízení - určuje druh projektového úkolu | NKUKDPD nk53id | 1,1 : 0,M s rušením | NKUKOLD nk53id |
Administrátor druhu projektového úkolu - určuje administrátora pro řešitele v druhu proj.úkolu | NKUKOLDA nk53id | 1,1 : 0,M | NKUKOLD nk53id |
Druh projektového úkolu použitelný v druhu operace - definuje druh projektového úkolu | NKUKOLDO nk53id | 1,1 : 0,M s rušením | NKUKOLD nk53id |

Indexy

Název | Primární | Výraz | Popis
ix_NKUKOLD_nk53id | P | nk53id | Identifikátor druhu úkolů
ix_NKUKOLD_pasada |  | pa01id, pa01oblast | PI - pa01id+pa01oblast
ix_NKUKOLD_paobjdru |  | pa13id, bw55objec | PI - pa13id+bw55objec
ix_NKUKOLD_nk42id |  | nk42id | Identifikátor zadavatele úkolu pro řešitele
ix_NKUKOLD_nk44id |  | nk44id | Identifikace řešitele
ix_NKUKOLD_nk72id |  | nk72id | Identifikátor prezentace úkolu v diagramech
ix_NKUKOLD_nk53typ |  | nk53typ | Typ úkolu - složený=je složen z více úkolů
ix_NKUKOLD_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_NKUKOLD_nk53nazdru |  | nk53nazdru | Název druhu úkolu


NKUKOLDA Administrátor druhu projektového úkolu

Popis

Administrátor druhu úkolu

Atributy

Atribut | Typ | Návěští | Message | Popis
nk53id | C(6) | Druh | Identifikátor druhu úkolů | Identifikátor druhu úkolů
nk42id | C(6) | Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu | Identifikátor zadavatele úkolu pro řešitele
nk44id | C(6) | Řešitel | Identifikace řešitele | Identifikace řešitele
nk85editac | N(1,0) | Editace | Právo administrátora editovat úkol | Právo administrátora editovat úkol

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Administrátor druhu projektového úkolu - ovládá v druhu úkolu řešitele | NKUKOLDA nk44id | 1,1 : 0,M | NKZDROJ nk44id |
Administrátor druhu projektového úkolu - definuje zadavatele ovládajícího řešitele v druhu projektového úkolu | NKUKOLDA nk42id | 1,1 : 0,M | NKZDROJ nk44id |
Administrátor druhu projektového úkolu - určuje administrátora pro řešitele v druhu proj.úkolu | NKUKOLDA nk53id | 1,1 : 0,M | NKUKOLD nk53id |

Indexy

Název | Primární | Výraz | Popis
ix_NKUKOLDA_nkukolda | P | nk53id, nk42id, nk44id | PI - nk53id+nk42id+nk44id
ix_NKUKOLDA_nk53id |  | nk53id | Identifikátor druhu úkolů
ix_NKUKOLDA_nk42id |  | nk42id | Identifikátor zadavatele úkolu pro řešitele
ix_NKUKOLDA_nk44id |  | nk44id | Identifikace řešitele
ix_NKUKOLDA_nk85editac |  | nk85editac | Právo administrátora editovat úkol


NKUKOLDO Druh projektového úkolu použitelný v druhu operace

Popis

Druh projektového úkolu použitelný v druhu operace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
nk53id | C(6) | Druh | Identifikátor druhu úkolů | Identifikátor druhu úkolů

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh projektového úkolu použitelný v druhu operace - definuje druh operace | NKUKOLDO sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Druh projektového úkolu použitelný v druhu operace - definuje druh projektového úkolu | NKUKOLDO nk53id | 1,1 : 0,M s rušením | NKUKOLD nk53id |

Indexy

Název | Primární | Výraz | Popis
ix_NKUKOLDO_nkukoldo | P | sp07idtyp, sp06idsubs, nk53id | PI - SPTYP+nk53id
ix_NKUKOLDO_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_NKUKOLDO_nk53id |  | nk53id | Identifikátor druhu úkolů


NKUKOLDX Vztahy řešitelů a zadavatelů vzhledem k druhu projektového úkolu

Popis

Vztahy řešitelů a zadavatelů vzhledem k druhu projektového úkolu

Atributy

Atribut | Typ | Návěští | Message | Popis
nk53id | C(6) | Druh | Identifikátor druhu úkolů | Identifikátor druhu úkolů
nk42id | C(6) | Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu | Identifikátor zadavatele úkolu pro řešitele
nk44id | C(6) | Řešitel | Identifikace řešitele | Identifikace řešitele
nk53osobni | N(1,0) | Osobní | Druh osobních projektových úkolů | Druh osobních projektových úkolů
nk64porad | N(3,0) | Pořadí předplnění | Pořadí předplnění řešitele při zadání úkolu 0=nepředplňovat | Pořadí předplnění řešitele při zadání úkolu 0=nepředplňovat
nk85editac | N(1,0) | Editace | Právo administrátora editovat úkol | Právo administrátora editovat úkol


NKUKOLG Generický projektový úkol

Popis

Generický projektový úkol

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
nk01verze | C(3) | Verze | Verze projektu | Verze projektu
nk43porad | C(6) | Poř. | Pořadí v rámci úkolů předmětu projektu | Pořadí v rámci úkolů předmětu projektu
nk43idu | C(2) | IDÚ úkolu | Identifikace datového úložiště úkolu | Identifikace datového úložiště úkolu
nk54gennaz | C(40) | Generický úkol | Název generického projektového úkolu | Název generického projektového úkolu
nk54koment | M | Komentář | Komentář | Komentář

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Generický projektový úkol - je definován projektovým úkolem | NKUKOLG sp60id sp61id nk01verze nk43porad nk43idu | 1,1 : 0,1 s rušením | NKUKOL sp60id sp61id nk01verze nk43porad nk43idu |
Proměnná generického projektového úkolu - patří ke generickému úkolu | NKUKOLGP sp60id sp61id nk01verze nk43porad nk43idu | 1,1 : 0,M s rušením | NKUKOLG sp60id sp61id nk01verze nk43porad nk43idu |

Indexy

Název | Primární | Výraz | Popis
ix_NKUKOLG_nkukol | P | sp60id, sp61id, nk01verze, nk43porad, nk43idu | UI - NKPREDPR+sp33cisdpm+nk43porad
ix_NKUKOLG_nk54gennaz |  | nk54gennaz | Název generického projektového úkolu


NKUKOLGP Proměnná generického projektového úkolu

Popis

Proměnná generického projektového úkolu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
nk01verze | C(3) | Verze | Verze projektu | Verze projektu
nk43porad | C(6) | Poř. | Pořadí v rámci úkolů předmětu projektu | Pořadí v rámci úkolů předmětu projektu
nk43idu | C(2) | IDÚ úkolu | Identifikace datového úložiště úkolu | Identifikace datového úložiště úkolu
nk81typ | N(1,0) | Typ | Typ proměnné generického projektového úkolu | Typ proměnné generického projektového úkolu
nk81label | M | Návěští | Návěští proměnné generického projektového úkolu | Návěští proměnné generického projektového úkolu
nk81valres | M | Seznam řešitelů | Seznam řešitelů | Seznam řešitelů
nk81koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Proměnná generického projektového úkolu - patří ke generickému úkolu | NKUKOLGP sp60id sp61id nk01verze nk43porad nk43idu | 1,1 : 0,M s rušením | NKUKOLG sp60id sp61id nk01verze nk43porad nk43idu |
Definice náhrady při aplikaci generického projektového úkolu - používá proměnnou | NKUKOLGU sp60id sp61id nk01verze nk43porad nk43idu nk81typ | 1,1 : 0,M s rušením | NKUKOLGP sp60id sp61id nk01verze nk43porad nk43idu nk81typ |

Indexy

Název | Primární | Výraz | Popis
ix_NKUKOLGP_nkukolgp | P | sp60id, sp61id, nk01verze, nk43porad, nk43idu, nk81typ | PI - NKUKOL+nk81typ
ix_NKUKOLGP_nkukol |  | sp60id, sp61id, nk01verze, nk43porad, nk43idu | UI - NKPREDPR+sp33cisdpm+nk43porad


NKUKOLGU Definice náhrady při aplikaci generického projektového úkolu

Popis

Definice náhrady při aplikaci generického projektového úkolu

Atributy

Atribut | Typ | Návěští | Message | Popis
nk82 | C(12) | nk82 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
nk01verze | C(3) | Verze | Verze projektu | Verze projektu
nk43porad | C(6) | Poř. | Pořadí v rámci úkolů předmětu projektu | Pořadí v rámci úkolů předmětu projektu
nk43idu | C(2) | IDÚ úkolu | Identifikace datového úložiště úkolu | Identifikace datového úložiště úkolu
nk81typ | N(1,0) | Typ | Typ proměnné generického projektového úkolu | Typ proměnné generického projektového úkolu
sp60id2 | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id2 | C(3) | Druh | Identifikace druhu artiklu | Identifikace druhu artiklu
nk01verze2 | C(3) | Verze | Verze projektu | Verze projektu
nk43porad2 | C(6) | Poř. | Pořadí v rámci úkolů předmětu projektu | Pořadí v rámci úkolů předmětu projektu
nk43idu2 | C(2) | IDÚ úkolu | Identifikace datového úložiště úkolu | Identifikace datového úložiště úkolu
bw11nazev | C(10) | Atribut | Název atributu | Název atributu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Definice náhrady při aplikaci generického projektového úkolu - používá proměnnou | NKUKOLGU sp60id sp61id nk01verze nk43porad nk43idu nk81typ | 1,1 : 0,M s rušením | NKUKOLGP sp60id sp61id nk01verze nk43porad nk43idu nk81typ |
Definice náhrady při aplikaci generického projektového úkolu - je určena pro úkol, který je součástí generického úkolu | NKUKOLGU sp60id2 sp61id2 nk01verze2 nk43porad2 nk43idu2 | 1,1 : 0,M s rušením | NKUKOL sp60id sp61id nk01verze nk43porad nk43idu |

Indexy

Název | Primární | Výraz | Popis
ix_NKUKOLGU_nk82 | P | nk82 | Jednoznačná časová identifikace
ix_NKUKOLGU_nkukolgp |  | sp60id, sp61id, nk01verze, nk43porad, nk43idu, nk81typ | PI - NKUKOL+nk81typ
ix_NKUKOLGU_nkukol |  | sp60id, sp61id, nk01verze, nk43porad, nk43idu | UI - NKPREDPR+sp33cisdpm+nk43porad
ix_NKUKOLGU_nkukol2 |  | sp60id2, sp61id2, nk01verze2, nk43porad2, nk43idu2 | CI - NKPREDPR+sp33cisdp2+nk43porad


NKUKOLH Záznam o změně vlastností úkolu

Popis

Záznam o změně vlastností úkolu

Atributy

Atribut | Typ | Návěští | Message | Popis
nk43 | C(12) | nk43 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
nk69porad | C(6) | Pořadí zápisu | Pořadí zápisu | Pořadí zápisu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
nk69zmena | M | nk69zmena | Popis změny úkolu | Popis změny úkolu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Záznam o změně vlastností úkolu - se vztahuje k úkolu | NKUKOLH nk43 | 1,1 : 0,M s rušením | NKUKOL nk43 |
Záznam o změně vlastností úkolu - kterou provedl uživatel | NKUKOLH bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_NKUKOLH_nkukolh | P | nk43, nk69porad |
ix_NKUKOLH_nk43 |  | nk43 | Jednoznačná časová identifikace
ix_NKUKOLH_bw01uziv |  | bw01uziv | Identifikace uživatele systému


NKUKOLP Plnění projektového úkolu

Popis

Plnění projektového úkolu

Atributy

Atribut | Typ | Návěští | Message | Popis
nk62 | C(12) | nk62 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
nk01verze | C(3) | Verze | Verze projektu | Verze projektu
nk43porad | C(6) | Poř. | Pořadí v rámci úkolů předmětu projektu | Pořadí v rámci úkolů předmětu projektu
nk43idu | C(2) | IDÚ úkolu | Identifikace datového úložiště úkolu | Identifikace datového úložiště úkolu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
nk44id | C(6) | Řešitel | Identifikace řešitele | Identifikace řešitele
nk53idp | C(6) | Druh | Identifikátor druhu úkolů | Identifikátor druhu úkolů
nk70id | C(6) | Druh | Identifikace druhu plnění úkolu projektového řízení | Identifikace druhu plnění úkolu projektového řízení
nk62datum | D | Datum | Datum plnění projektového úkolu | Datum plnění projektového úkolu
nk62text | C(40) | Popis | Popis plnění projektového úkolu | Popis plnění projektového úkolu
nk62hodin | N(7,2) | Hodin | Čerpání času řešitele v hodinách | Čerpání času řešitele v hodinách
nk62dnu | N(6,2) | Dnů | Čerpání času zdroje ve dnech | Čerpání času zdroje ve dnech
nk62procpl | N(6,2) | % | Přírůstek procenta plnění | Procento plnění
nk62kateg | N(2,0) | Kateg. | Kategorie plnění projektového úkolu | Kategorie plnění projektového úkolu
nk62koment | M | Poznámka | Poznámka k plnění projektového úkolu | Poznámka k plnění projektového úkolu
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
nk62storno | N(1,0) | Stav plnění | Stav plnění úkolu - Nestornované/Stornované | Stav plnění úkolu - Nestornované/Stornované

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Plnění projektového úkolu - vzniklo v operaci | NKUKOLP sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Plnění projektového úkolu - ve vztahu k adresátovi | NKUKOLP ad01id | 1,1 : 0,M | ADADSAT ad01id |
Plnění projektového úkolu - bylo provedeno zdrojem | NKUKOLP nk44id | 1,1 : 0,M | NKZDROJ nk44id |
Plnění projektového úkolu - se týká projektového úkolu | NKUKOLP sp60id sp61id nk01verze nk43porad nk43idu | 1,1 : 0,M | NKUKOL sp60id sp61id nk01verze nk43porad nk43idu |
Plnění projektového úkolu - založil uživatel | NKUKOLP bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Plnění projektového úkolu - má obchodní selektor | NKUKOLP sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Plnění projektového úkolu - má organizační selektor | NKUKOLP sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Plnění projektového úkolu - má technicko-věcný selektor | NKUKOLP sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Plnění projektového úkolu - je druhu plnění | NKUKOLP nk70id | 1,1 : 0,M | NKUKOPD nk70id |

Indexy

Název | Primární | Výraz | Popis
ix_NKUKOLP_nk62 | P | nk62 | Jednoznačná časová identifikace
ix_NKUKOLP_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_NKUKOLP_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_NKUKOLP_nkukol |  | sp60id, sp61id, nk01verze, nk43porad, nk43idu | UI - NKPREDPR+sp33cisdpm+nk43porad
ix_NKUKOLP_ad01id |  | ad01id | Identifikace adresáta
ix_NKUKOLP_spartiknx |  |  |
ix_NKUKOLP_adadsatx |  |  |
ix_NKUKOLP_nk44id |  | nk44id | Identifikace řešitele
ix_NKUKOLP_nk53idp |  | nk53idp | Identifikátor druhu úkolů
ix_NKUKOLP_nk70id |  | nk70id | Identifikace druhu plnění úkolu projektového řízení
ix_NKUKOLP_nk62datum |  | nk62datum | Datum plnění projektového úkolu
ix_NKUKOLP_nk62text |  | nk62text | Popis plnění projektového úkolu
ix_NKUKOLP_nk62kateg |  | nk62kateg | Kategorie plnění projektového úkolu
ix_NKUKOLP_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_NKUKOLP_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_NKUKOLP_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_NKUKOLP_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_NKUKOLP_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_NKUKOLP_sp00datzap |  | sp00datzap | Datum a čas zápisu záznamu události


NKUKOLPE Záznam o plnění úkolu v programu EVIVYK.EXE

Popis

Záznam o plnění úkolu v programu EVIVYK.EXE

Atributy

Atribut | Typ | Návěští | Message | Popis
nk62 | C(12) | nk62 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
nk01verze | C(3) | Verze | Verze projektu | Verze projektu
nk43porad | C(6) | Poř. | Pořadí v rámci úkolů předmětu projektu | Pořadí v rámci úkolů předmětu projektu
nk43idu | C(2) | IDÚ úkolu | Identifikace datového úložiště úkolu | Identifikace datového úložiště úkolu
nk44id | C(6) | Řešitel | Identifikace řešitele | Identifikace řešitele
nk70id | C(6) | Druh | Identifikace druhu plnění úkolu projektového řízení | Identifikace druhu plnění úkolu projektového řízení
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
nk62datum | D | Datum | Datum plnění projektového úkolu | Datum plnění projektového úkolu
nk62hodin | N(7,2) | Hodin | Čerpání času řešitele v hodinách | Čerpání času řešitele v hodinách
nk62text | C(40) | Popis | Popis plnění projektového úkolu | Popis plnění projektového úkolu
nk62koment | M | Poznámka | Poznámka k plnění projektového úkolu | Poznámka k plnění projektového úkolu
nk94casov | N(1,0) | nk94casov | Pro záznam plnění je použit časovač | Pro záznam plnění je použit časovač
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Záznam o plnění úkolu v programu EVIVYK.EXE - založil uživatel | NKUKOLPE bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Záznam o plnění úkolu v programu EVIVYK.EXE - se týká projektového úkolu | NKUKOLPE sp60id sp61id nk01verze nk43porad nk43idu | 1,1 : 0,M | NKUKOL sp60id sp61id nk01verze nk43porad nk43idu |
Záznam o plnění úkolu v programu EVIVYK.EXE - bylo provedeno zdrojem | NKUKOLPE nk44id | 1,1 : 0,M | NKZDROJ nk44id |
Záznam o plnění úkolu v programu EVIVYK.EXE - založil uživatel | NKUKOLPE nk70id | 1,1 : 0,M | NKUKOPD nk70id |
Záznam o plnění úkolu v programu EVIVYK.EXE - má obchodní selektor | NKUKOLPE sp10idzak | 0,1 : 0,M | SPSEOB sp10idzak |

Indexy

Název | Primární | Výraz | Popis
ix_NKUKOLPE_nk62 | P | nk62 | Jednoznačná časová identifikace
ix_NKUKOLPE_nkukol |  | sp60id, sp61id, nk01verze, nk43porad, nk43idu | UI - NKPREDPR+sp33cisdpm+nk43porad
ix_NKUKOLPE_nk44id |  | nk44id | Identifikace řešitele
ix_NKUKOLPE_nk70id |  | nk70id | Identifikace druhu plnění úkolu projektového řízení
ix_NKUKOLPE_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_NKUKOLPE_bw01uziv |  | bw01uziv | Identifikace uživatele systému


NKUKOLRH Host úkolu

Popis

Host úkolu

Atributy

Atribut | Typ | Návěští | Message | Popis
nk44id | C(6) | Řešitel | Identifikace řešitele | Identifikace řešitele
nk43 | C(12) | nk43 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
nk86koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Host úkolu - určuje projektový úkol | NKUKOLRH nk43 | 1,1 : 0,M s rušením | NKUKOL nk43 |
Host úkolu - má jako hosta řešitele | NKUKOLRH nk44id | 1,1 : 0,M | NKZDROJ nk44id |

Indexy

Název | Primární | Výraz | Popis
ix_NKUKOLRH_nkukolrh | P | nk44id, nk43 | PI - nk43+nk44id
ix_NKUKOLRH_nk44id |  | nk44id | Identifikace řešitele
ix_NKUKOLRH_nk43 |  | nk43 | Jednoznačná časová identifikace


NKUKOLS Pracovní plnění projektového úkolu pro vstup šablonou

Popis

Plnění projektového úkolu vstoupené šablonou

Atributy

Atribut | Typ | Návěští | Message | Popis
nk62 | C(12) | nk62 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
nk66f | C(10) | nk66f | Filtr pro zpracování formulářem | Filtr pro zpracování formulářem
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
nk01verze | C(3) | Verze | Verze projektu | Verze projektu
nk43porad | C(6) | Poř. | Pořadí v rámci úkolů předmětu projektu | Pořadí v rámci úkolů předmětu projektu
nk43idu | C(2) | IDÚ úkolu | Identifikace datového úložiště úkolu | Identifikace datového úložiště úkolu
nk62datum | D | Datum | Datum plnění projektového úkolu | Datum plnění projektového úkolu
nk62text | C(40) | Popis | Popis plnění projektového úkolu | Popis plnění projektového úkolu
nk62hodin | N(7,2) | Hodin | Čerpání času řešitele v hodinách | Čerpání času řešitele v hodinách
nk62procpl | N(6,2) | % | Přírůstek procenta plnění | Procento plnění
nk44id | C(6) | Řešitel | Identifikace řešitele | Identifikace řešitele
nk62kateg | N(2,0) | Kateg. | Kategorie plnění projektového úkolu | Kategorie plnění projektového úkolu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
nk62koment | M | Poznámka | Poznámka k plnění projektového úkolu | Poznámka k plnění projektového úkolu
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
nk70id | C(6) | Druh | Identifikace druhu plnění úkolu projektového řízení | Identifikace druhu plnění úkolu projektového řízení
nk53id | C(6) | Druh | Identifikátor druhu úkolů | Identifikátor druhu úkolů
sp20idzak2 | C(9) | Identifikátor technicko-věcného selektoru | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.

Indexy

Název | Primární | Výraz | Popis
ix_NKUKOLS_nk62 | P | nk62 | Jednoznačná časová identifikace
ix_NKUKOLS_nkukol |  | sp60id, sp61id, nk01verze, nk43porad, nk43idu | UI - NKPREDPR+sp33cisdpm+nk43porad
ix_NKUKOLS_nk44id |  | nk44id | Identifikace řešitele
ix_NKUKOLS_ad01id |  | ad01id | Identifikace adresáta
ix_NKUKOLS_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_NKUKOLS_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_NKUKOLS_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_NKUKOLS_nk70id |  | nk70id | Identifikace druhu plnění úkolu projektového řízení


NKUKOLU Uživatel systému - řešitel daného projektového úkolu

Popis

Uživatel systému - řešitel daného projektového úkolu

Atributy

Atribut | Typ | Návěští | Message | Popis
nk43 | C(12) | nk43 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému


NKUKOLX Prezentace úkolu v diagramu úkolu

Popis

Prezentace úkolu v diagramu úkolu

Atributy

Atribut | Typ | Návěští | Message | Popis
nk72id | C(6) | Prezentace | Identifikátor prezentace úkolu v diagramech | Identifikátor prezentace úkolu v diagramech
nk72nazpre | C(40) | Název prezentace | Název prezentace úkolu v diagramech | Název prezentace úkolu v diagramech
nk72vyraz | M | Výraz | Výraz prezentace úkolu v diagramech | Výraz prezentace úkolu v diagramech
nk72koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh projektového úkolu - prezentuje události v diagramech projektového úkolu | NKUKOLD nk72id | 1,1 : 0,M | NKUKOLX nk72id |

Indexy

Název | Primární | Výraz | Popis
ix_NKUKOLX_nk72id | P | nk72id | Identifikátor prezentace úkolu v diagramech
ix_NKUKOLX_nk72nazpre |  | nk72nazpre | Název prezentace úkolu v diagramech


NKUKOLZ Řešitel - řešitel daného projektového úkolu

Popis

Řešitel - řešitel daného projektového úkolu

Atributy

Atribut | Typ | Návěští | Message | Popis
nk43 | C(12) | nk43 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
nk44id | C(6) | Řešitel | Identifikace řešitele | Identifikace řešitele
nk44skupin | N(1,0) | Skupina řešitelů | Skupina řešitelů | Skupina řešitelů


NKUKOPD Druh plnění projektového úkolu

Popis

Druh plnění projektového úkolu

Atributy

Atribut | Typ | Návěští | Message | Popis
nk70id | C(6) | Druh | Identifikace druhu plnění úkolu projektového řízení | Identifikace druhu plnění úkolu projektového řízení
nk42id | C(6) | Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu | Identifikátor zadavatele úkolu pro řešitele
nk70nazdru | C(40) | Název druhu | Název druhu plnění úkolu projektového řízení | Název druhu plnění úkolu projektového řízení
nk70pvncas | N(1,0) | Povinné zadání času | Povinné zadání času řešitele v hodinách | Povinné zadání času řešitele v hodinách
nk43stav | N(1,0) | Stav | Stav projektového úkolu | Stav prvku projektu
nk70koment | M | Poznámka | Poznámka | Poznámka
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
nk70pridel | N(1,0) | Automaticky přidělit | Přidělit druh plnění nově založenému druhu projektového úkolu | Přidělit druh plnění nově založenému druhu projektového úkolu
nk70kod | M | Skript | Kód v jazyce Foxpro provedený při ukončení operace s druhem plnění | Kód v jazyce Foxpro provedený při ukončení operace s druhem plnění
nk70kodvld | M | Skript valid | Kód v jazyce Foxpro provedený před zápisem události s druhem plnění | Kód v jazyce Foxpro provedený před zápisem události s druhem plnění

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh plnění projektového úkolu - má TV-selektor | NKUKOPD sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Druh plnění projektového úkolu - má zadavetele plnění úkolu | NKUKOPD nk42id | 1,1 : 0,M | NKZDROJ nk44id |
Plnění projektového úkolu - je druhu plnění | NKUKOLP nk70id | 1,1 : 0,M | NKUKOPD nk70id |
Aktuální hodnota plnění projektových úkolů - je pro druh plnění projektového úkolu | NKAHUP nk70id | 1,1 : 0,M | NKUKOPD nk70id |
Druh plnění úkolu použitelný pro druh úkolu projektového řízení - určuje druh plnění projektového úkolu | NKUKDPD nk70id | 1,1 : 0,M | NKUKOPD nk70id |
Dynamická transformace druhu plnění projektového úkolu - je definována pro druh plnění | NKUKOPDT nk70id | 1,1 : 0,M | NKUKOPD nk70id |
Záznam o plnění úkolu v programu EVIVYK.EXE - založil uživatel | NKUKOLPE nk70id | 1,1 : 0,M | NKUKOPD nk70id |

Indexy

Název | Primární | Výraz | Popis
ix_NKUKOPD_nk70id | P | nk70id | Identifikace druhu plnění úkolu projektového řízení
ix_NKUKOPD_nk42id |  | nk42id | Identifikátor zadavatele úkolu pro řešitele
ix_NKUKOPD_nk70nazdru |  | nk70nazdru | Název druhu plnění úkolu projektového řízení
ix_NKUKOPD_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.


NKUKOPDT Dynamická transformace druhu plnění projektového úkolu

Popis

Dynamická transformace druhu plnění projektového úkolu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtypd | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu procesu
sp06idsubd | C(3) | sp06idsubd | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
nk70id | C(6) | Druh | Identifikace druhu plnění úkolu projektového řízení | Identifikace druhu plnění úkolu projektového řízení
sp36 | C(12) | sp36 | Jednoznačná časová identifikace transformace | Jednoznačná časová identifikace transformace
sp19id | C(6) | Předkontace | Identifikace obecné předkontace | Identifikace obecné předkontace
sp32poradi | N(3,0) | Pořadí transf. | Pořadí transformace | Pořadí transformace
sp32rozlis | C(1) | Rozlišení vazby | Rozlišení vazby pro transformaci | Rozlišení vazby pro transformaci
sp32samost | N(1,0) | Vazba | Vazba vstupující do druhého uzlu | Vazba není svázaná s vazbami vstupujícími do druhého uzlu
sp31autom | N(1,0) | sp31autom | Spouštět operaci | Spouštět operaci automaticky

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Dynamická transformace druhu plnění projektového úkolu - je směřována do uzlu procesu | NKUKOPDT sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPTYPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad |
Dynamická transformace druhu plnění projektového úkolu - je definována pro druh plnění | NKUKOPDT nk70id | 1,1 : 0,M | NKUKOPD nk70id |
Dynamická transformace druhu plnění projektového úkolu - používá obecnou předkontaci | NKUKOPDT sp19id | 0,1 : 0,M | SPPREDK sp19id |
Dynamická transformace druhu plnění projektového úkolu - používá transformaci | NKUKOPDT sp36 | 0,1 : 0,M | SPTRN sp36 |

Indexy

Název | Primární | Výraz | Popis
ix_NKUKOPDT_nkukopdt | P | sp07idtypd, sp06idsubd, sp07idtyp, sp06idsubs, sp33porad, nk70id | PI - SPTYPOD+nk70id+nk92alias
ix_NKUKOPDT_sptypod |  | sp07idtypd, sp06idsubd, sp07idtyp, sp06idsubs, sp33porad | Identifikace druhu operace v druhu procesu
ix_NKUKOPDT_nk70id |  | nk70id | Identifikace druhu plnění úkolu projektového řízení
ix_NKUKOPDT_sptypd |  | sp07idtypd, sp06idsubd | Index podle typu dokladu a subsystému dokladu
ix_NKUKOPDT_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_NKUKOPDT_sp36 |  | sp36 | Jednoznačná časová identifikace transformace
ix_NKUKOPDT_sp19id |  | sp19id | Identifikace obecné předkontace


NKZDKAL Kalendář zdroje pro plnění projektového kroku

Popis

Kalendář zdroje pro plnění projektového kroku

Atributy

Atribut | Typ | Návěští | Message | Popis
nk45id | C(6) | Kalendář | Identifikace kalendáře řešitele pro plnění projektového úkolu | Identifikace kalendáře řešitele pro plnění projektového úkolu
nk45nazkal | C(40) | Název kalendáře | Název kalendáře zdroje pro plnění projektového kroku | Název kalendáře zdroje pro plnění projektového kroku
nk45koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Řešitel projektového úkolu - používá kalendář | NKZDROJ nk45id | 1,1 : 0,M | NKZDKAL nk45id |
Den v kalendáři zdroje pro plnění projektového kroku - je dnem kalendáře | NKZDKALP nk45id | 1,1 : 0,M | NKZDKAL nk45id |

Indexy

Název | Primární | Výraz | Popis
ix_NKZDKAL_nk45id | P | nk45id | Identifikace kalendáře řešitele pro plnění projektového úkolu
ix_NKZDKAL_nk45nazkal |  | nk45nazkal | Název kalendáře zdroje pro plnění projektového kroku


NKZDKALP Den v kalendáři zdroje pro plnění projektového kroku

Popis

Den v kalendáři zdroje pro plnění projektového kroku

Atributy

Atribut | Typ | Návěští | Message | Popis
nk46datum | D | Den | Den kalendáře | Den kalendáře
nk44id | C(6) | Řešitel | Identifikace řešitele | Identifikace řešitele
nk45id | C(6) | Kalendář | Identifikace kalendáře řešitele pro plnění projektového úkolu | Identifikace kalendáře řešitele pro plnění projektového úkolu
nk46dostup | N(1,0) | Dostupnost | Dostupnost kapacity zdroje ke dni kalendáře | Dostupnost kapacity zdroje ke dni kalendáře
nk46hodden | N(5,2) | Změna kapacity | Změna kapacity zdroje v hodinách | Kapacita v hodinách danného dne pro změnu kapacity

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Den v kalendáři zdroje pro plnění projektového kroku - je dnem kalendáře | NKZDKALP nk45id | 1,1 : 0,M | NKZDKAL nk45id |
Den v kalendáři zdroje pro plnění projektového kroku - je dnem kalendáře pro zdroj | NKZDKALP nk44id | 1,1 : 0,M | NKZDROJ nk44id |

Indexy

Název | Primární | Výraz | Popis
ix_NKZDKALP_nkzdkalp | P | nk46datum, nk44id, nk45id | PI - nk46datum+nk45id+nk44id
ix_NKZDKALP_nk45id |  | nk45id | Identifikace kalendáře řešitele pro plnění projektového úkolu
ix_NKZDKALP_nk44id |  | nk44id | Identifikace řešitele
ix_NKZDKALP_nk46datum |  | nk46datum | Den kalendáře


NKZDROJ Řešitel projektového úkolu

Popis

Řešitel projektového úkolu

Atributy

Atribut | Typ | Návěští | Message | Popis
nk44id | C(6) | Řešitel | Identifikace řešitele | Identifikace řešitele
nk44nazzdr | C(40) | Jméno řešitele | Jméno řešitele | Jméno řešitele
nk44koment | M | Poznámka | Poznámka | Poznámka
nk44hodden | N(5,2) | Denní kapacita (hod) | Denní kapacita v hodinách | Denní kapacita v hodinách
nk44hoddmx | N(5,2) | Max.denní kapacita (hod) | Maximální denní kapacita v hodinách | Maximální denní kapacita v hodinách
nk44hodtyd | N(6,2) | Týdenní kapacita (hod) | Týdenní kapacita v hodinách | Týdenní kapacita v hodinách
nk44hodtmx | N(6,2) | Max.týdenní kapacita (hod) | Maximální týdenní kapacita v hodinách | Maximální týdenní kapacita v hodinách
nk45id | C(6) | Kalendář | Identifikace kalendáře řešitele pro plnění projektového úkolu | Identifikace kalendáře řešitele pro plnění projektového úkolu
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
nk44kapaci | N(1,0) | Kapacitní plánování | Kapacitní plánování | Kapacitní plánování
nk44skupin | N(1,0) | Skupina řešitelů | Skupina řešitelů | Skupina řešitelů
nk44aktiv | N(1,0) | Aktivní řešitel | Aktivní řešitel | Aktivní řešitel
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
nk44iduk | C(6) | Úkoluje | Identifikace úkolovaného řešitele | Identifikace úkolovaného řešitele
mz31id | C(6) | Identifikace | Identifikace pracovní funkce (zařazení) | Identifikace pracovní funkce (zařazení)

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Řešitel projektového úkolu - používá kalendář | NKZDROJ nk45id | 1,1 : 0,M | NKZDKAL nk45id |
Řešitel projektového úkolu - má organizační selektor | NKZDROJ sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Řešitel projektového úkolu - je adresátem | NKZDROJ ad01id | 1,1 : 0,M | ADADSAT ad01id |
Řešitel projektového úkolu - je uživatelem systému | NKZDROJ bw01uziv | 0,1 : 0,M | BWUZIVAT bw01uziv |
Řešitel projektového úkolu - úkoluje řešitele | NKZDROJ nk44iduk | 0,1 : 0,M | NKZDROJ nk44id |
Řešitel projektového úkolu - má pracovní funkci | NKZDROJ mz31id | 1,1 : 0,M | MZPRACFU mz31id |
Projektový úkol - má řešitele | NKUKOL nk44id | 1,1 : 0,M | NKZDROJ nk44id |
Projektový úkol - má zadavetele | NKUKOL nk42id | 1,1 : 0,M | NKZDROJ nk44id |
Řešitel projektového úkolu - úkoluje řešitele | NKZDROJ nk44iduk | 0,1 : 0,M | NKZDROJ nk44id |
Den v kalendáři zdroje pro plnění projektového kroku - je dnem kalendáře pro zdroj | NKZDKALP nk44id | 1,1 : 0,M | NKZDROJ nk44id |
Druh projektového úkolu - předplňuje řešitele úkolu | NKUKOLD nk44id | 1,1 : 0,M | NKZDROJ nk44id |
Druh projektového úkolu - má zadavetele úkolu | NKUKOLD nk42id | 1,1 : 0,M | NKZDROJ nk44id |
Plnění projektového úkolu - bylo provedeno zdrojem | NKUKOLP nk44id | 1,1 : 0,M | NKZDROJ nk44id |
Zařazení řešitele do skupiny řešitelů projektového úkolu - obsahuje skupinu řešitelů | NKZDROJS nk44ids | 1,1 : 0,M s rušením | NKZDROJ nk44id |
Zařazení řešitele do skupiny řešitelů projektového úkolu - obsahuje řešitele zařazeného do skupiny | NKZDROJS nk44id | 1,1 : 0,M | NKZDROJ nk44id |
Druh plnění projektového úkolu - má zadavetele plnění úkolu | NKUKOPD nk42id | 1,1 : 0,M | NKZDROJ nk44id |
Aktuální hodnota projektových úkolů - je hodnotou řešitele | NKAHUK nk44id | 1,1 : 0,M | NKZDROJ nk44id |
Aktuální hodnota plnění projektových úkolů - je hodnotou řešitele | NKAHUP nk44id | 1,1 : 0,M | NKZDROJ nk44id |
Administrátor druhu projektového úkolu - ovládá v druhu úkolu řešitele | NKUKOLDA nk44id | 1,1 : 0,M | NKZDROJ nk44id |
Administrátor druhu projektového úkolu - definuje zadavatele ovládajícího řešitele v druhu projektového úkolu | NKUKOLDA nk42id | 1,1 : 0,M | NKZDROJ nk44id |
Host úkolu - má jako hosta řešitele | NKUKOLRH nk44id | 1,1 : 0,M | NKZDROJ nk44id |
Záznam o plnění úkolu v programu EVIVYK.EXE - bylo provedeno zdrojem | NKUKOLPE nk44id | 1,1 : 0,M | NKZDROJ nk44id |

Indexy

Název | Primární | Výraz | Popis
ix_NKZDROJ_nk44id | P | nk44id | Identifikace řešitele
ix_NKZDROJ_nk44nazzdr |  | nk44nazzdr | Jméno řešitele
ix_NKZDROJ_nk45id |  | nk45id | Identifikace kalendáře řešitele pro plnění projektového úkolu
ix_NKZDROJ_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_NKZDROJ_ad01id |  | ad01id | Identifikace adresáta
ix_NKZDROJ_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_NKZDROJ_nk44iduk |  | nk44iduk | Identifikace úkolovaného řešitele
ix_NKZDROJ_mz31id |  | mz31id | Identifikace pracovní funkce (zařazení)


NKZDROJS Zařazení řešitele do skupiny řešitelů projektového úkolu

Popis

Zařazení zdroje do skupinového zdroje

Atributy

Atribut | Typ | Návěští | Message | Popis
nk44ids | C(6) | nk44ids | Identifikace skupinového řešitele | Identifikace skupinového řešitele
nk44id | C(6) | Řešitel | Identifikace řešitele | Identifikace řešitele
nk64porad | N(3,0) | Pořadí předplnění | Pořadí předplnění řešitele při zadání úkolu 0=nepředplňovat | Pořadí předplnění řešitele při zadání úkolu 0=nepředplňovat
nk64clen | N(1,0) | Člen skupiny | Člen skupiny - Ano=přijímá úkoly skupiny nebo přímé, Ne=přijímá úkoly přímo určené řešiteli | Člen skupiny - Ano=přijímá úkoly skupiny nebo přímé, Ne=přijímá úkoly přímo určené řešiteli

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Zařazení řešitele do skupiny řešitelů projektového úkolu - obsahuje skupinu řešitelů | NKZDROJS nk44ids | 1,1 : 0,M s rušením | NKZDROJ nk44id |
Zařazení řešitele do skupiny řešitelů projektového úkolu - obsahuje řešitele zařazeného do skupiny | NKZDROJS nk44id | 1,1 : 0,M | NKZDROJ nk44id |

Indexy

Název | Primární | Výraz | Popis
ix_NKZDROJS_nkzdrojs | P | nk44ids, nk44id | PI - nk44ids+nk44id
ix_NKZDROJS_nk44ids |  | nk44ids | Identifikace skupinového řešitele
ix_NKZDROJS_nk44id |  | nk44id | Identifikace řešitele


NKZDROJZ Zadavatel úkolu

Popis

Zadavatel úkolu pro řešitele

Atributy

Atribut | Typ | Návěští | Message | Popis
nk42id | C(6) | Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu | Identifikátor zadavatele úkolu pro řešitele
nk42nazzad | C(40) | Jméno zadavatele | Jméno zadavatele projektového úkolu nebo plnění projektového úkolu | Název zadavatele úkolu pro řešitele
nk44iduk | C(6) | Úkoluje | Identifikace úkolovaného řešitele | Identifikace úkolovaného řešitele
nk42koment | M | Poznámka | Poznámka | Poznámka
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh projektového úkolu - má zadavetele úkolu | NKUKOLD nk42id | 1,1 : 0,M | NKZDROJZ nk42id |
Druh plnění projektového úkolu - má zadavetele plnění úkolu | NKUKOPD nk42id | 1,1 : 0,M | NKZDROJZ nk42id |

Indexy

Název | Primární | Výraz | Popis
ix_NKZDROJZ_nk42id | P | nk42id | Identifikátor zadavatele úkolu pro řešitele
ix_NKZDROJZ_nk42nazzad |  | nk42nazzad | Název zadavatele úkolu pro řešitele
ix_NKZDROJZ_nk44iduk |  | nk44iduk | Identifikace úkolovaného řešitele
ix_NKZDROJZ_bw01uziv |  | bw01uziv | Identifikace uživatele systému


Tabulky OB...

OBAH | Aktuální hodnota obchodu
OBAHR | Aktuální hodnota obchodu (replikovaná)
OBAHUD | Událost - skladba
OBARTADR | Vztah obchodovatelného artiklu a adresáta
OBARTIKL | Obchodovatelný artikl
OBCELPRC | Sazba položky celního sazebníku v období
OBCELSAZ | Položka celního sazebníku
OBCENHIS | Historie ceny obchodovatelného artiklu
OBCENIK | Položka ceníku artiklu
OBCENOBD | Cenové období cenové skupiny obchodovatelného artiklu
OBCENSAK | AAA v cenové skupině
OBCENSKP | Cenová skupina obchodovatelného artiklu
OBDEFPRE | Propojení operací obchodu a skladu pro přepočet nákladů v události obchodu
OBKATAL | Katalog zboží obchodu
OBKATALD | Druh katalogu zboží obchodu
OBKATALP | Položka katalogu zboží obchodu
OBOZNVYR | Výraz pro označení - obchod
OBPAROPE | Parametry komponenty obchod pro druh operace
OBUDAL | Událost obchodního plnění
OBUDASKL | Očekávaný výdej artiklu ze skladové buňky
OBUMIST | Umístění - distribuční kanál

Viz.také

OBCENIK Položka ceníku artiklu | OBCENHIS Historie ceny obchodovatelného artiklu | OBAH Aktuální hodnota obchodu | OBAHR Aktuální hodnota obchodu (replikovaná) | OBAHUD Událost - skladba | OBARTIKL Obchodovatelný artikl | OBCENOBD Cenové období cenové skupiny obchodovatelného artiklu | OBCENSAK AAA v cenové skupině | OBCENSKP Cenová skupina obchodovatelného artiklu | OBDEFPRE Propojení operací obchodu a skladu pro přepočet nákladů v události obc | OBKATAL Katalog zboží obchodu | OBKATALD Druh katalogu zboží obchodu | OBKATALP Položka katalogu zboží obchodu | OBOZNVYR Výraz pro označení - obchod | OBPAROPE Parametry komponenty obchod pro druh operace | OBUDAL Událost obchodního plnění | OBUMIST Umístění - distribuční kanál | OBUDASKL Očekávaný výdej artiklu ze skladové buňky | OBCELPRC Sazba položky celního sazebníku v období | OBCELSAZ Položka celního sazebníku | OBARTADR Vztah obchodovatelného artiklu a adresáta


OBAH Aktuální hodnota obchodu

Popis

Aktuální hodnota obchodu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
ob05id | C(6) | Umístění | Identifikace umístění obchodu - distribučního kanálu | Identifikace umístění obchodu - distribučního kanálu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
ad01id | C(6) | Adresát | Adresát | Identifikace adresáta
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
ob02hodnot | N(20,4) | Hodnota | Hodnota | Aktuální hodnota

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Aktuální hodnota obchodu - se týká druhu statistické informace | OBAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_OBAH_obah | P | sp60id, sp67id, ob05id, sp61id, ad01id, sp06idsubs |
ix_OBAH_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_OBAH_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_OBAH_spartiknx |  |  |
ix_OBAH_adadsatx |  |  |
ix_OBAH_ad01id |  | ad01id | Identifikace adresáta
ix_OBAH_ob05id |  | ob05id | Identifikace umístění obchodu - distribučního kanálu


OBAHR Aktuální hodnota obchodu (replikovaná)

Popis

Aktuální hodnota obchodu (replikovaná)

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
ob05id | C(6) | Umístění | Identifikace umístění obchodu - distribučního kanálu | Identifikace umístění obchodu - distribučního kanálu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
ob02hodnot | N(20,4) | Hodnota | Hodnota | Aktuální hodnota

Indexy

Název | Primární | Výraz | Popis
ix_OBAHR_obah | P | sp60id, sp67id, ob05id, sp61id, ad01id, sp06idsubs |


OBAHUD Událost - skladba

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
ob02 | C(12) | ob02 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ad01id | C(6) | Adresát | Adresát | Identifikace adresáta
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp74id | C(6) | Umístění | Umístění | Umístění
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp00datum | D | Datum | Datum události | Datum události
sp00text | C(40) | Popis | Popis události | Popis události
sp00hodnot | N(20,4) | Hodnota | Aktuální hodnota procesu |
sp69id | C(6) | Druh | Identifikace druhu saldokontní hodnoty procesu | Identifikace druhu saldokontní hodnoty procesu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost - skladba - se týká aktéra | OBAHUD ad01id | 0,1 : 0,M | ADADSAT ad01id |
Událost - skladba - týká se operace | OBAHUD sp33hid | 1,1 : 0,M | OBUDAL ob02 |
Událost - skladba - koresponduje s aktuální hodnotou procesu | OBAHUD sp33hid sp69id ad01id sp60id sp61id sp74id | 1,1 : 0,M | SPPRCSAL sp33hid sp69id ad01id sp60id sp61id sp74id |
Událost - skladba - týká se druhu hodnoty | OBAHUD sp67id sp06idsubs | 0,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_OBAHUD_sp33hid |  | sp33hid | Časová identifikace hlavního procesu
ix_OBAHUD_ob02 |  | ob02 | Jednoznačná časová identifikace
ix_OBAHUD_ad01id |  | ad01id | Identifikace adresáta
ix_OBAHUD_sp74id |  | sp74id | Umístění
ix_OBAHUD_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_OBAHUD_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_OBAHUD_spahud |  | sp60id, sp61id, ad01id, sp74id, sp67id, sp06idsubs | Artikl+Aktér+Umístění+Druh hodnoty
ix_OBAHUD_spprcsal |  | sp33hid, sp69id, ad01id, sp60id, sp61id, sp74id | Primární index salda procesu


OBARTADR Vztah obchodovatelného artiklu a adresáta

Popis

Vztah obchodovatelného artiklu a adresáta

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
pa01id | C(6) | Sada | Identifikátor sady parametrů | Identifikátor sady parametrů
pa01oblast | C(2) | Oblast | Oblast sady parametrů | Oblast sady parametrů
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ob29datum | D | Platnost | Datum platnosti od | Datum platnosti od
ob29 | C(12) | ob29 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
ob29datumd | D | do | Datum platnosti do | Datum platnosti do
ob29carkod | C(36) | Čárový kód | Čárový kód artiklu u adresáta | Čárový kód artiklu u partnera
ob29objcis | C(40) | Obj. číslo | Objednací číslo | Objednací číslo
ob29artikl | C(100) | Jiný název | Jiný název artiklu | Název artiklu
ob29koment | M | Poznámka | Poznámka | Poznámka
ob29volnu1 | N(12,2) | Volný údaj | Volný údaj - numerický | Volný údaj - numerický
ob29voltx1 | C(60) | Volný údaj - textový | Volný údaj - textový | Volný údaj - textový
ob29prior | N(2,0) | Priorita | Priorita vztahu | Priorita vztahu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vztah obchodovatelného artiklu a adresáta - vyjadřuje vztah artiklu | OBARTADR sp60id sp61id | 1,1 : 0,M | OBARTIKL sp60id sp61id |
Vztah obchodovatelného artiklu a adresáta - vyjadřuje vztah adresáta | OBARTADR ad01id | 1,1 : 0,M | ADADSAT ad01id |
Vztah obchodovatelného artiklu a adresáta - může mít uvedeno spojení adresáta | OBARTADR ad01id ad11cisspo | 0,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Vztah obchodovatelného artiklu a adresáta - používá sadu parametrů | OBARTADR pa01id pa01oblast | 1,1 : 0,M | PASADA pa01id pa01oblast |

Indexy

Název | Primární | Výraz | Popis
ix_OBARTADR_obartadr | P | sp60id, sp61id, pa01id, pa01oblast, ad01id, ob29datum | PI - SPARTIKL+PASADA+ad01id+ob29datum
ix_OBARTADR_ob29 | U | ob29 | Jednoznačná časová identifikace
ix_OBARTADR_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_OBARTADR_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_OBARTADR_pasada |  | pa01id, pa01oblast | PI - pa01id+pa01oblast
ix_OBARTADR_ad01id |  | ad01id | Identifikace adresáta
ix_OBARTADR_ob29datum |  | ob29datum | Datum platnosti od
ix_OBARTADR_ob29carkod |  | ob29carkod | Čárový kód artiklu u partnera
ix_OBARTADR_ob29objcis |  | ob29objcis | Objednací číslo
ix_OBARTADR_ob29artikl |  | ob29artikl | Název artiklu
ix_OBARTADR_ob29prior |  | ob29prior | Priorita vztahu


OBARTIKL Obchodovatelný artikl

Popis

Obchodovatelný artikl

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
pa13id | C(12) | Klasifikace | Identifikace klasifikace objektu | Identifikace klasifikace objektu
bw55objec | C(2) | Identifikace objektu BM | Identifikace objektu BM | Identifikace objektu BM
pa13idart | C(12) | Klasifikace artiklu | Identifikace klasifikace objektu artiklu | Identifikace klasifikace objektu artiklu
bw55objeca | C(2) | bw55objeca | Identifikace objektu BM - artiklu | Identifikace objektu BM - artiklu
dp03id | C(3) | Typ zdanitelného plnění | Identifikace typu zdanitelného plnění | Identifikace typu zdanitelného plnění
ob01koment | M | Komentář k artiklu | Komentář k obchodovatelnému artiklu | Komentář k obchodovatelnému artiklu. Používá se k popisu různých vlastností artiklu, způsobu jeho prodeje, distribuce apod. Slouží k popsání důležitých informací, které jsou přístupny všem uživatelům.
sp17idskp | C(8) | Třída SKP | Identifikace třídy Standardní klasifikace produkce. | Identifikace kategorie Standardní klasifikace produkce. *** Dříve SKPID.
sp24idmj | C(3) | Měrná jednotka | Identifikátor měrné jednotky | Identifikátor měrné jednotky
ob25id | C(10) | Položka | Identifikace položky celního sazebníku. | Identifikace položky celního sazebníku. *** Dříve PCELSAZ.
ob01carkod | C(36) | Čárový kód | Čárový kód obchodovatelného artiklu | Čárový kód obchodovatelného artiklu.
ob01exid | C(20) | Externí identifikace | Externí identifikace obchodovatelného artiklu | Externí identifikace obchodovatelného artiklu
ob01cislo1 | N(20,4) | Volné číslo I | Volně použitelné číslo | Volně použitelné číslo
ob01cislo2 | N(20,4) | Volné číslo II | Volně použitelné číslo | Volně použitelné číslo
ob01text1 | C(40) | Volný text I | Volně použitelný text | Volně použitelný text
ob01text2 | C(40) | Volný text II | Volně použitelný text | Volně použitelný text
ob01dat1 | D | Volné datum I | Volně použitelné datum | Volně použitelné datum
ob01dat2 | D | Volné datum II | Volně použitelné datum | Volně použitelné datum
sp20idzak | C(9) | Technicko-věcný selektor | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
bw01uziv | C(6) | Zapsal | Identifikace uživatele systému | Identifikace uživatele systému
ob01sklado | N(1,0) | ob01sklado | Charakter artiklu - skladovaný, neskladovaný | Příznak artiklu, který je skladován
ob02vzucet | N(1,0) | Vztah k účetnictví | Vztah k účetnictví - zboží, materiál, výrobek, služba ... | Vztah k účetnictví
sp00uselar | C(9) | Účetní selektor artiklu | Účetní selektor artiklu | Účetní selektor artiklu
sp00aktual | N(1,0) | sp00aktual | Aktuální/ neaktuální | Aktuální/ neaktuální neboli skrytý/ neskrytý
ob02vzdph | N(1,0) | Vztah ceny k DPH | Vztah ceny artiklu k DPH - cena bez DPH,cena včetně DPH, cena včetně DPH z rozdílu nákladů a konečné ceny | Vztah ceny artiklu k DPH - cena bez DPH,cena s DPH, ....
ob01nulcen | N(1,0) | ob01nulcen | Povolena nulová cena v událostech o artiklu | Povolena nulová cena
ob01 | C(12) | ob01 | Jednoznačná časová identifikace obchodovatelného artiklu. | Jednoznačná časová identifikace obchodovatelného artiklu.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Obchodovatelný artikl - je artiklem | OBARTIKL sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Obchodovatelný artikl - založil uživatel systému | OBARTIKL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Obchodovatelný artikl - je veden ve třídě SKP | OBARTIKL sp17idskp | 1,1 : 0,M | SPSKP sp17idskp |
Obchodovatelný artikl - má měrnou jednotku jako referenční | OBARTIKL sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Obchodovatelný artikl - je zařazena do technicko-věcného selektoru | OBARTIKL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Obchodovatelný artikl - má implicitní typ zdanitelného plnění | OBARTIKL dp03id | 0,1 : 0,M | DPZPT dp03id |
Obchodovatelný artikl - odpovídá položce celního sazebníku | OBARTIKL ob25id | 1,1 : 0,M | OBCELSAZ ob25id |
Obchodovatelný artikl - předplňuje klasifikaci na událost obchodu | OBARTIKL pa13id bw55objec | 1,1 : 0,M | PAOBJDRU pa13id bw55objec |
Obchodovatelný artikl - má klasifikaci artiklu | OBARTIKL pa13idart bw55objeca | 1,1 : 0,M | PAOBJDRU pa13id bw55objec |
Položka smlouvy - je spojena s obchodovatelným artiklem | NKSMLOUV sp60id2 sp61id2 | 1,1 : 0,M | OBARTIKL sp60id sp61id |
Událost plnění položky smlouvy - je spojena s obchodovatelným artiklem | NKSMLPLN sp60id2 sp61id2 | 1,1 : 0,M | OBARTIKL sp60id sp61id |
Druh události položky smlouvy nebo události plnění položky smlouvy - má předplňovaný artikl obchodu při vstupu smlouvy | NKPLNDRU sp60id sp61id | 0,1 : 0,M | OBARTIKL sp60id sp61id |
Pravidlo smlouvy druhu plnění položky smlouvy - má předplňovaný artikl obchodu při vstupu smlouvy | NKPLNDRP sp60id sp61id | 0,1 : 0,M | OBARTIKL sp60id sp61id |
Vztah obchodovatelného artiklu a adresáta - vyjadřuje vztah artiklu | OBARTADR sp60id sp61id | 1,1 : 0,M | OBARTIKL sp60id sp61id |
Událost obchodního plnění - týká se obchodovatelného artiklu | OBUDAL sp60id sp61id | 1,1 : 0,M | OBARTIKL sp60id sp61id |
Položka katalogu zboží obchodu - obsahuje artikl | OBKATALP sp60id sp61id | 1,1 : 0,M | OBARTIKL sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_OBARTIKL_spartikl | P | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_OBARTIKL_paobjdru |  | pa13id, bw55objec | PI - pa13id+bw55objec
ix_OBARTIKL_paobjdra |  | pa13idart, bw55objeca | CI - pa13idart+bw55objeca
ix_OBARTIKL_sp61id |  | sp61id | Identifikace druhu artiklu
ix_OBARTIKL_sp60id |  | sp60id | Identifikace artiklu
ix_OBARTIKL_dp03id |  | dp03id | Identifikace typu zdanitelného plnění
ix_OBARTIKL_sp17idskp |  | sp17idskp | Identifikace kategorie Standardní klasifikace produkce.
ix_OBARTIKL_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky
ix_OBARTIKL_ob25id |  | ob25id | Identifikace položky celního sazebníku.
ix_OBARTIKL_ob01carkod |  | ob01carkod | Čárový kód obchodovatelného artiklu.
ix_OBARTIKL_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_OBARTIKL_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_OBARTIKL_sp00uselar |  | sp00uselar | Účetní selektor artiklu
ix_OBARTIKL_spartiknx |  |  |
ix_OBARTIKL_sp00aktual |  | sp00aktual | Aktuální/ neaktuální neboli skrytý/ neskrytý


OBCELPRC Sazba položky celního sazebníku v období

Popis

Sazby položky celního sazebníku v období

Atributy

Atribut | Typ | Návěští | Message | Popis
ob25id | C(10) | Položka | Identifikace položky celního sazebníku. | Identifikace položky celního sazebníku. *** Dříve PCELSAZ.
ob26datum | D | Platnost od | Datum platnosti od | Datum platnosti od
sp24idmj | C(3) | MJ | Identifikátor měrné jednotky | Identifikátor měrné jednotky
sp24idmj2 | C(3) | Měrná jednotka | Identifikátor měrné jednotky | Identifikátor měrné jednotky
ob26datumd | D | Platnost do | Datum platnosti do | Datum platnosti do
ob26sazvse | N(5,1) | Celní sazba všeobecná | Celní sazba všeobecná | Celní sazba všeobecná *** Dříve CLOSAZBA.
ob26sazsml | N(5,1) | Celní sazba smluvní | Celní sazba smluvní | Celní sazba smluvní

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Sazba položky celního sazebníku v období - má měrnou jednotku | OBCELPRC sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Sazba položky celního sazebníku v období - se týká pložky celního sazebníku | OBCELPRC ob25id | 1,1 : 0,M | OBCELSAZ ob25id |
Sazba položky celního sazebníku v období - má měrnou jednotku KN | OBCELPRC sp24idmj2 | 1,1 : 0,M | SPMJ sp24idmj |

Indexy

Název | Primární | Výraz | Popis
ix_OBCELPRC_obcelprc | P | ob25id, ob26datum |
ix_OBCELPRC_ob25id |  | ob25id | Identifikace položky celního sazebníku.
ix_OBCELPRC_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky
ix_OBCELPRC_sp24idmj2 |  | sp24idmj2 | Identifikátor měrné jednotky
ix_OBCELPRC_obcelsax |  |  |


OBCELSAZ Položka celního sazebníku

Popis

Objektem typu SPCELSAZ je každý záznam definující položku celního sazebníku.

*** Dříve CELSAZ.

Atributy

Atribut | Typ | Návěští | Message | Popis
ob25id | C(10) | Položka | Identifikace položky celního sazebníku. | Identifikace položky celního sazebníku. *** Dříve PCELSAZ.
ob25nazpol | C(100) | Název položky celního sazebníku | Název položky celního sazebníku. | Název položky celního sazebníku. *** Dříve CLOTEXT.
ob25skupin | N(1,0) | Skupina | Skupina položky celního sazebníku | Skupina položky celního sazebníku
ob25koment | M | Poznámka | Poznámka položky celního sazebníku. | Poznámka položky celního sazebníku. *** Dříve CLOPOZN.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Sazba položky celního sazebníku v období - se týká pložky celního sazebníku | OBCELPRC ob25id | 1,1 : 0,M | OBCELSAZ ob25id |
Obchodovatelný artikl - odpovídá položce celního sazebníku | OBARTIKL ob25id | 1,1 : 0,M | OBCELSAZ ob25id |

Indexy

Název | Primární | Výraz | Popis
ix_OBCELSAZ_ob25id | P | ob25id | Identifikace položky celního sazebníku.
ix_OBCELSAZ_ob25nazpol |  | ob25nazpol | Název položky celního sazebníku.


OBCENHIS Historie ceny obchodovatelného artiklu

Popis

Historie ceny obchodovatelného artiklu

Atributy

Atribut | Typ | Návěští | Message | Popis
ob15datum | D | Platnost do | Datum platnosti ceny - do | Datum platnosti ceny - do
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp24idmj | C(3) | MJ | Identifikátor měrné jednotky | Identifikátor měrné jednotky
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
ob11id | C(3) | Skupina | Identifikace cenové skupiny | Identifikace cenové skupiny
ob12id | C(3) | Období | Identifikace cenového období | Identifikace cenového období cenové skupiny obchodovatelného artiklu
ob15cj02 | N(20,6) | CJ - artikl | Cena ceníková za artikl za měrnou jednotku v oceňovací jednotce | Cena ceníková artiklu za měrnou jednotku v oceňovací jednotce. Je to cena artiklu, která je očištěná od ostatních nákladů. Slouží pak k různým přesným analýzám.
ob15cj03 | N(20,6) | CJ - ostatní nákl. | Cena ceníková ostatních nákladů za měrnou jednotku v oceňovací jednotce | Cena ceníková ostatních nákladů za měrnou jednotku v oceňovací jednotce. Jsou to dodatečné náklady, které zatěžují cenu za artikl celkem. Lze ji později statisticky vyhodnocovat a použít k rozhodování. Př. vnitřní náklady na dopravu, apod.
ob15sleva | N(5,2) | Sleva % | Sleva uvedená v procentech | Sleva uvedená v procentech
ob15prizna | N(2,0) | Příznak | Příznak historické ceny | Příznak historické ceny

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Historie ceny obchodovatelného artiklu - se týká artiklu v ceníku | OBCENHIS sp60id sp61id sp24idmj oc01id ob11id ob12id | 1,1 : 0,M s rušením | OBCENIK sp60id sp61id sp24idmj oc01id ob11id ob12id |

Indexy

Název | Primární | Výraz | Popis
ix_OBCENHIS_obcenhis | P | ob15datum, sp60id, sp61id, sp24idmj, oc01id, ob11id, ob12id |
ix_OBCENHIS_obcenik1 |  | sp60id, sp61id, sp24idmj, oc01id, ob11id, ob12id | sp60id+sp61id+ob04id+sp24id+oc01id
ix_OBCENHIS_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_OBCENHIS_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky
ix_OBCENHIS_oc01id |  | oc01id | Kód měny - oceňovací jednotky.
ix_OBCENHIS_ob11id |  | ob11id | Identifikace cenové skupiny


OBCENIK Položka ceníku artiklu

Popis

Položka ceníku obchodovatelného artiklu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp24idmj | C(3) | Měrná jednotka | Identifikátor měrné jednotky | Identifikátor měrné jednotky
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
ob11id | C(3) | Skupina | Identifikace cenové skupiny | Identifikace cenové skupiny
ob12id | C(3) | Období | Identifikace cenového období | Identifikace cenového období cenové skupiny obchodovatelného artiklu
ob03cj02 | N(20,6) | Cena za jednotku - artikl | Cena ceníková za artikl za měrnou jednotku v oceňovací jednotce | Cena ceníková artiklu za měrnou jednotku v oceňovací jednotce. Je to cena artiklu, která je očištěná od ostatních nákladů. Slouží pak k různým přesným analýzám.
ob03cj03 | N(20,6) | Cena za jednotku - ostatní náklady | Cena ceníková ostatních nákladů za měrnou jednotku v oceňovací jednotce | Cena ceníková ostatních nákladů za měrnou jednotku v oceňovací jednotce. Jsou to dodatečné náklady, které zatěžují cenu za artikl celkem. Lze ji později statisticky vyhodnocovat a použít k rozhodování. Př. vnitřní náklady na dopravu, apod.
ob03sleva | N(7,2) | Sleva % | Sleva uvedená v procentech | Sleva uvedená v procentech

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Položka ceníku artiklu - je za měrnou jednotku | OBCENIK sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Položka ceníku artiklu - je za měnu | OBCENIK oc01id | 1,1 : 0,M | OCMENA oc01id |
Položka ceníku artiklu - spadá do cenového období | OBCENIK ob11id ob12id | 1,1 : 0,M | OBCENOBD ob11id ob12id |
Položka ceníku artiklu - se týká artiklu | OBCENIK sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Historie ceny obchodovatelného artiklu - se týká artiklu v ceníku | OBCENHIS sp60id sp61id sp24idmj oc01id ob11id ob12id | 1,1 : 0,M s rušením | OBCENIK sp60id sp61id sp24idmj oc01id ob11id ob12id |

Indexy

Název | Primární | Výraz | Popis
ix_OBCENIK_obcenik1 | P | sp60id, sp61id, sp24idmj, oc01id, ob11id, ob12id | sp60id+sp61id+ob04id+sp24id+oc01id
ix_OBCENIK_obcenik2 |  | sp60id, sp61id, sp24idmj, oc01id | ob04id+sp60id+sp61id+sp24id+oc01id
ix_OBCENIK_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_OBCENIK_obcenobd |  | ob11id, ob12id | PI - cenového období cenové skupiny obchodovatelného artiklu
ix_OBCENIK_spartiknx |  |  |
ix_OBCENIK_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky
ix_OBCENIK_oc01id |  | oc01id | Kód měny - oceňovací jednotky.
ix_OBCENIK_ob11id |  | ob11id | Identifikace cenové skupiny
ix_OBCENIK_ob12id |  | ob12id | Identifikace cenového období cenové skupiny obchodovatelného artiklu
ix_OBCENIK_obceniki |  | ob12id, ob11id, sp61id, sp60id | Období+Skupina+Typ+Artikl


OBCENOBD Cenové období cenové skupiny obchodovatelného artiklu

Popis

Cenové období cenové skupiny obchodovatelného artiklu

Atributy

Atribut | Typ | Návěští | Message | Popis
ob11id | C(3) | Skupina | Identifikace cenové skupiny | Identifikace cenové skupiny
ob12id | C(3) | Období | Identifikace cenového období | Identifikace cenového období cenové skupiny obchodovatelného artiklu
ob12datum | D | Datum platnosti od | Datum platnosti od | Datum platnosti od
ob12datumd | D | do | Datum platnosti do | Datum platnosti do
ob12nazcob | C(40) | Název cenového období | Název cenového období | Název cenového období
ob12koment | M | Poznámka | Poznámka k cenovému období | Poznámka k cenovému období
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Cenové období cenové skupiny obchodovatelného artiklu - patří cenové skupině obchodovatelného artiklu | OBCENOBD ob11id | 1,1 : 0,M | OBCENSKP ob11id |
Cenové období cenové skupiny obchodovatelného artiklu - založil uživatel | OBCENOBD bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Položka ceníku artiklu - spadá do cenového období | OBCENIK ob11id ob12id | 1,1 : 0,M | OBCENOBD ob11id ob12id |

Indexy

Název | Primární | Výraz | Popis
ix_OBCENOBD_obcenobd | P | ob11id, ob12id | PI - cenového období cenové skupiny obchodovatelného artiklu
ix_OBCENOBD_ob11id |  | ob11id | Identifikace cenové skupiny
ix_OBCENOBD_bw01uziv |  | bw01uziv | Identifikace uživatele systému


OBCENSAK AAA v cenové skupině

Popis

Adresát spojení s cenovou skupinou obchodovatelného artiklu

Atributy

Atribut | Typ | Návěští | Message | Popis
ob13 | C(12) | ob13 |  |
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
ob11id | C(3) | Skupina | Identifikace cenové skupiny | Identifikace cenové skupiny
ob05id | C(6) | Umístění | Identifikace umístění obchodu - distribučního kanálu | Identifikace umístění obchodu - distribučního kanálu
ob13prior | N(2,0) | Priorita | Priorita výběru ceníkové položky | Priorita výběru ceníkové položky
ob13idzak | C(9) | Artikl | Maska technicko-věcného selektoru artiklu | Maska technicko-věcného selektoru artiklu
ob13sleva | N(7,2) | Sleva % | Sleva uvedená v procentech |
ob02hs | C(20) | Obchodní smlouva | Číslo obchodní smlouvy | Číslo obchodní smlouvy
ob13vybhs | N(1,0) | Výběr podle OS | Výběr podle obchodní smlouvy | Výběr podle obchodní smlouvy

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
AAA v cenové skupině - se týká aktéra | OBCENSAK ad01id | 1,1 : 0,M s rušením | ADADSAT ad01id |
AAA v cenové skupině - je v cenové skupině | OBCENSAK ob11id | 1,1 : 0,M s rušením | OBCENSKP ob11id |
AAA v cenové skupině - se týká spojení adresáta | OBCENSAK ad01id ad11cisspo | 0,1 : 0,M | ADSPOJ ad01id ad11cisspo |
AAA v cenové skupině - se týká umístění obchodu | OBCENSAK ob05id | 0,1 : 0,M | OBUMIST ob05id |

Indexy

Název | Primární | Výraz | Popis
ix_OBCENSAK_ob13 | P | ob13 |
ix_OBCENSAK_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_OBCENSAK_ob11id |  | ob11id | Identifikace cenové skupiny
ix_OBCENSAK_ad01id |  | ad01id | Identifikace adresáta
ix_OBCENSAK_ob05id |  | ob05id | Identifikace umístění obchodu - distribučního kanálu


OBCENSKP Cenová skupina obchodovatelného artiklu

Popis

Cenová skupina obchodovatelného artiklu

Atributy

Atribut | Typ | Návěští | Message | Popis
ob11id | C(3) | Skupina | Identifikace cenové skupiny | Identifikace cenové skupiny
ob11nazcsk | C(40) | Název cenové skupiny | Název cenové skupiny | Název cenové skupiny
ob11koment | M | Poznámka | Poznámka k cenové skupině | Poznámka k cenové skupině
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
ob11idspoj | C(3) | Spojená skupina | Identifikace spojené cenové skupiny | Identifikace spojené cenové skupiny
ob11typcen | N(1,0) | Typ ceny | Typ ceny Prodejní,Nákupní,Skladová,Ostatní | Typ ceny Prodejní,Nákupní,Skladová,Ostatní
ob11implic | N(1,0) | ob11implic | Implicitní cenová skupina | Implicitní cenová skupina
ob11prekrv | N(1,0) | Zákaz překryvu cen. obd. | Zákaz překryvu cenových období (Ano - zákaz překryvu, Ne - překryv povolen) | Zákaz překryvu cenových období Ano - je zakázán překryv cenových období Ne - je povolen překryv cenových období

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Cenová skupina obchodovatelného artiklu - založil uživatel | OBCENSKP bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Cenová skupina obchodovatelného artiklu - Je spojen s jinou cenovou skupinou | OBCENSKP ob11idspoj | 0,1 : 0,M | OBCENSKP ob11id |
Parametry komponenty sklad zvířat - definují druh hodnoty - Cenová skupina zápočtu KD | SZPAR ob11id | 1,1 : 0,M | OBCENSKP ob11id |
Událost obchodního plnění - byla oceněna v cenové skupině | OBUDAL ob11id | 1,1 : 0,M | OBCENSKP ob11id |
Tarifní třída - má cenovou skupinu | MZTARTRI ob11id | 1,1 : 0,M | OBCENSKP ob11id |
Položka katalogu zboží obchodu - má cenovou skupinu | OBKATALP ob11id | 0,1 : 0,M | OBCENSKP ob11id |
Cenová skupina obchodovatelného artiklu - Je spojen s jinou cenovou skupinou | OBCENSKP ob11idspoj | 0,1 : 0,M | OBCENSKP ob11id |
Cenové období cenové skupiny obchodovatelného artiklu - patří cenové skupině obchodovatelného artiklu | OBCENOBD ob11id | 1,1 : 0,M | OBCENSKP ob11id |
AAA v cenové skupině - je v cenové skupině | OBCENSAK ob11id | 1,1 : 0,M s rušením | OBCENSKP ob11id |

Indexy

Název | Primární | Výraz | Popis
ix_OBCENSKP_ob11id | P | ob11id | Identifikace cenové skupiny
ix_OBCENSKP_ob11nazcsk |  | ob11nazcsk | Název cenové skupiny
ix_OBCENSKP_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_OBCENSKP_ob11idspoj |  | ob11idspoj | Identifikace spojené cenové skupiny


OBDEFPRE Propojení operací obchodu a skladu pro přepočet nákladů v události obc

Popis

Propojení operací obchodu a skladu pro přepočet nákladů v události obchodu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtypd | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu procesu
sp06idsubd | C(3) | sp06idsubd | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery
sp07idtyp2 | C(6) | Druh operace | Identifikátor druhu operace | Identifikace druhu operace - druhý uzel
sp06idsub2 | C(3) | Komponenta | Identifikace komponenty - přijemce transformovaných dat | Identifikace komponenty - přijemce transformovaných dat
sp07idtyp | C(6) | Druh | Identifikátor druhu operace | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Propojení operací obchodu a skladu pro přepočet nákladů v události obchodu - se vztahují k druhu procesu | OBDEFPRE sp07idtypd sp06idsubd | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Propojení operací obchodu a skladu pro přepočet nákladů v události obchodu - váže operaci obchodu | OBDEFPRE sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Propojení operací obchodu a skladu pro přepočet nákladů v události obchodu - váže operaci skladu | OBDEFPRE sp07idtyp2 sp06idsub2 | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_OBDEFPRE_obdefpre | P | sp07idtypd, sp06idsubd, sp07idtyp2, sp06idsub2 | PI - SPTYPD+SPTYP2 tj. typ procesu+typ operace skladu
ix_OBDEFPRE_sptypd |  | sp07idtypd, sp06idsubd | Index podle typu dokladu a subsystému dokladu
ix_OBDEFPRE_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_OBDEFPRE_sptyp2 |  | sp07idtyp2, sp06idsub2 |


OBKATAL Katalog zboží obchodu

Popis

Katalog zboží obchodu

Atributy

Atribut | Typ | Návěští | Message | Popis
ob06id | C(6) | Katalog | Identifikace katalogu | Identifikace katalogu
ob07id | C(6) | Druh | Identifikace druhu katalogu | Identifikace druhu katalogu
ob06katal | C(40) | Název katalogu | Název katalogu | Název katalogu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
ob06koment | M | Poznámka | Poznámka ke katalogu | Poznámka ke katalogu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Katalog zboží obchodu - založil uživatel | OBKATAL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Katalog zboží obchodu - má druh | OBKATAL ob07id | 1,1 : 0,M | OBKATALD ob07id |
Položka katalogu zboží obchodu - patří do katalogu | OBKATALP ob06id ob07id | 1,1 : 0,M s rušením | OBKATAL ob06id ob07id |

Indexy

Název | Primární | Výraz | Popis
ix_OBKATAL_obkatal | P | ob06id, ob07id | PI ob06id+ob07id
ix_OBKATAL_ob06id |  | ob06id | Identifikace katalogu
ix_OBKATAL_ob06katal |  | ob06katal | Název katalogu
ix_OBKATAL_ob07id |  | ob07id | Identifikace druhu katalogu
ix_OBKATAL_bw01uziv |  | bw01uziv | Identifikace uživatele systému


OBKATALD Druh katalogu zboží obchodu

Popis

Druh katalogu zboží obchodu

Atributy

Atribut | Typ | Návěští | Message | Popis
ob07id | C(6) | Druh | Identifikace druhu katalogu | Identifikace druhu katalogu
ob07druhka | C(40) | ob07druhka | Název druhu kalalogu | Název druhu kalalogu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
ob07koment | M | Poznámka | Poznámka k druhu katalogu | Poznámka k druhu katalogu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh katalogu zboží obchodu - založil uživatel | OBKATALD bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Katalog zboží obchodu - má druh | OBKATAL ob07id | 1,1 : 0,M | OBKATALD ob07id |

Indexy

Název | Primární | Výraz | Popis
ix_OBKATALD_ob07id | P | ob07id | Identifikace druhu katalogu
ix_OBKATALD_ob07druhka |  | ob07druhka | Název druhu kalalogu
ix_OBKATALD_bw01uziv |  | bw01uziv | Identifikace uživatele systému


OBKATALP Položka katalogu zboží obchodu

Popis

Položka katalogu zboží obchodu

Atributy

Atribut | Typ | Návěští | Message | Popis
ob06id | C(6) | Katalog | Identifikace katalogu | Identifikace katalogu
ob07id | C(6) | ob07id | Identifikace druhu katalogu | Identifikace druhu katalogu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
ob05id | C(6) | Umístění | Identifikace umístění obchodu - distribučního kanálu | Identifikace umístění obchodu - distribučního kanálu
ob02mnr | N(20,4) | Mn. ref. | Množství obchodovatelného artiklu v referenční měrné jednotce | Množství obchodovatelného artiklu v referenční měrné jednotce.
ob08poradi | N(3,0) | Pořadí | Pořadí artiklu v katalogu | Pořadí artiklu v katalogu
ob11id | C(3) | Skupina | Identifikace cenové skupiny | Identifikace cenové skupiny

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Položka katalogu zboží obchodu - patří do katalogu | OBKATALP ob06id ob07id | 1,1 : 0,M s rušením | OBKATAL ob06id ob07id |
Položka katalogu zboží obchodu - obsahuje artikl | OBKATALP sp60id sp61id | 1,1 : 0,M | OBARTIKL sp60id sp61id |
Položka katalogu zboží obchodu - definuje uložení artiklu | OBKATALP ob05id | 0,1 : 0,M | OBUMIST ob05id |
Položka katalogu zboží obchodu - má cenovou skupinu | OBKATALP ob11id | 0,1 : 0,M | OBCENSKP ob11id |

Indexy

Název | Primární | Výraz | Popis
ix_OBKATALP_obkatalp | P | ob06id, ob07id, sp60id, sp61id | PI OBKATAL+SPARTIKL
ix_OBKATALP_obkatal |  | ob06id, ob07id | PI ob06id+ob07id
ix_OBKATALP_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_OBKATALP_ob05id |  | ob05id | Identifikace umístění obchodu - distribučního kanálu
ix_OBKATALP_ob11id |  | ob11id | Identifikace cenové skupiny


OBOZNVYR Výraz pro označení - obchod

Popis

Výraz pro označení - obchod

Atributy

Atribut | Typ | Návěští | Message | Popis
ob21 | C(10) | ob21 | Jednoznačná časová identifikace výrazu | Jednoznačná časová identifikace výrazu
ob21por | N(3,0) | Pořadí | Pořadí výrazu v překryvném seznamu | Pořadí výrazu v překryvném seznamu
ob21vyraz | M | Výraz | Výraz označení | Výraz označení
ob21typ | N(1,0) | Typ | Typ výrazu FoxPro nebo SQL-dotaz | Typ výrazu FoxPro nebo SQL-dotaz
ob21popis | C(40) | Popis výrazu | Popis výrazu | Popis výrazu
ob21koment | M | Poznámka | Poznámka k výrazu | Poznámka k výrazu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Výraz pro označení - obchod - založil uživatel systému | OBOZNVYR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_OBOZNVYR_ob21 | P | ob21 | Jednoznačná časová identifikace výrazu
ix_OBOZNVYR_ob21por |  | ob21por | Pořadí výrazu v překryvném seznamu
ix_OBOZNVYR_ob21popis |  | ob21popis | Popis výrazu
ix_OBOZNVYR_bw01uziv |  | bw01uziv | Identifikace uživatele systému


OBPAROPE Parametry komponenty obchod pro druh operace

Popis

Parametry komponenty obchod pro druh operace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
ob18zstav1 | N(1,0) | ob18zstav1 | Změna stavu události při vstupu navazující události obchodu propojené mírou plnění | Změna stavu události při vstupu navazující události obchodu propojené mírou plnění
ob02stav | N(1,0) | ob02stav | Stav události - neurčeno, nevykrytá objednávka, vykrytá objednávka | Stav události - neurčeno, nevykrytá objednávka, vykrytá objednávka
ob18zstav2 | N(1,0) | ob18zstav2 | Změna stavu události při zrušení navazující události obchodu propojené mírou plnění | Změna stavu události při zrušení navazující události obchodu propojené mírou plnění
ob02stav2 | N(1,0) | ob02stav2 | Stav události - neurčeno, nevykrytá objednávka, vykrytá objednávka | Stav události - neurčeno,vykrytá objednávka,nevykrytá objednávka (nevykrývat)
ob18koment | M | Poznámka | Poznámka | Poznámka
ob18predbe | N(1,0) | Operaci ukončovat předběžně | Operaci ukončovat pouze předběžně | Operaci ukončovat pouze předběžně
ob18cenurc | N(1,0) | Cenová skupina podle | Přidělování cenové skupiny podle Nastavení BM/Adresáta/Příjemce události obchodu | Přidělování cenové skupiny podle příjemce události obchodu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametry komponenty obchod pro druh operace - se týkají druhu operace | OBPAROPE sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_OBPAROPE_sptyp | P | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému


OBUDAL Událost obchodního plnění

Popis

Událostí obchodního plnění, např. objednávka obchodovatelného artiklu, dodací list, potvrzení objednávky, apod.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
ad01id | C(6) | Adresát | Adresát | Identifikace adresáta
ad11cisspo | C(2) | Spojení | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
ad01id1 | C(6) | Importovaný | Identifikace importovaného adresáta | Identifikace adresáta - pro import
ad11cissp1 | C(2) | Spojení | Číslo spojení adresáta. | Číslo spojení adresáta.
sp24idmj2 | C(3) | Měrná jednotka | Identifikátor měrné jednotky | Identifikátor měrné jednotky
oc01id2 | C(3) | oc01id2 | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
pa13id | C(12) | Klasifikace | Identifikace klasifikace objektu | Identifikace klasifikace objektu
bw55objec | C(2) | Identifikace objektu BM | Identifikace objektu BM | Identifikace objektu BM
ob02 | C(12) | ob02 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
ob02privyd | N(1,0) | PO/VO/PDL/VDL | Objednávka nebo DL přijatý/vydaný | Objednávka přijatá/vydaná
ob02dat | D | Datum | Datum události obch. artiklu - může řídit číselnou řadu procesu | Datum vystavení události obchodovatelného artiklu (není datem zápisu)
ob02datdod | D | Dodání | Datum dodání obchodovatelného artiklu | Datum dodání
ob02mn | N(20,4) | Množství | Množství obchodovatelného artiklu | Množství obchodovatelného artiklu
ob02text | C(40) | Popis události | Popis události o obchodovatelném artiklu | Popis události o obchodovatelném artiklu
ob02koment | M | Pozn. | Poznámka k události obchodu | Poznámka k události obchodu
ob02hs | C(20) | Obchodní smlouva | Číslo obchodní smlouvy | Číslo obchodní smlouvy
sp24idmj | C(3) | Měrná jednotka | Identifikátor měrné jednotky | Identifikátor měrné jednotky
sp24idmj1 | C(3) | Měrná jednotka | Identifikátor měrné jednotky | Identifikátor měrné jednotky
dp04tuzzah | N(1,0) | dp04tuzzah | Typ místa tuzemsko, zahraničí, Evropská Unie .... | Tuzemsko/Zahraničí
ob05id | C(6) | Umístění | Identifikace umístění obchodu - distribučního kanálu | Identifikace umístění obchodu - distribučního kanálu
dp03id | C(3) | Typ zdanitelného plnění | Identifikace typu zdanitelného plnění | Identifikace typu zdanitelného plnění
dp05id | C(3) | Typ místa zdanitelného plnění | Identifikace typu místa zdanitelného plnění | Identifikace typu místa zdanitelného plnění
ob11id | C(3) | Skupina | Identifikace cenové skupiny | Identifikace cenové skupiny
ob02cj01c | N(20,6) | CJ | Cena ceníková celkem za měrnou jednotku v oceňovací jednotce (služba + artikl) | Cena ceníková celkem za měrnou jednotku v oceňovací jednotce. Skládá se z ceny vlastního artiklu a ceny ostatních nákladů, které jsou s artiklem spojeny, např. doprava, montáž apod,. Někdy je vhodné z praktických důvodů cenu služby započítat do ceny artiklu.
ob02sleva | N(7,2) | Sleva % | Sleva uvedená v procentech | Sleva k artiklu v dodávce uvedená v procentech. Lze ji uvádět přímo nebo automatizovaně pomocí aparátu na vyhodnocování slev.
ob02cj01 | N(20,6) | Po slevě/jedn. | Cena za jednotku po slevě celková | Cena za jednotku po slevě celková, tj. artikl a ostatní náklady.
ob02cc02 | N(20,4) | Celkem bez daně artikl | Cena bez daně po slevě za artikl | Cena bez daně po slevě za artikl bez ostatních nákladů.
ob02cc03 | N(20,4) | Celkem bez daně ostatní | Cena bez daně po slevě za ostatní náklady | Cena bez daně po slevě za ostatní náklady
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
oc01id1 | C(3) | Referenční měna | Referenční měna | Referenční měna kursu (je na pozadí)
oc03kurz | N(20,6) | Kurs | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup. | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup.
oc03mn | N(5,0) | Množství | Množství oceňovací jednotky v kursu. | Množství oceňovací jednotky v kurzu.
ob02mnr | N(20,4) | Množství ref. MJ | Množství obchodovatelného artiklu v referenční měrné jednotce | Množství obchodovatelného artiklu v referenční měrné jednotce.
dp02sazba | N(5,2) | Sazba DPH | Procentní sazba daně z přidané hodnoty | Sazba daně z přidané hodnoty. Povolené hodnoty jsou základní, snížená nebo nulová.
dp02czazm | N(20,4) | Základ DPH v ZM | Částka základu daně z přidané hodnoty v ZM - odpočet | Částka základu daně z přidané hodnoty v zahraniční měně
dp02cdpzm | N(20,4) | DPH v ZM | Částka daně z přidané hodnoty v zahraniční měně - odpočet | Částka daně z přidané hodnoty v zahraniční měně
dp02czarm | N(20,4) | Základ DPH v RM | Částka základu daně z přidané hodnoty v referenční měně | Částka základu daně z přidané hodnoty v referenční měně
dp02cdprm | N(20,4) | DPH v RM | Částka daně z přidané hodnoty v referenční měně | Částka daně z přidané hodnoty v referenční měně
dp02uod | N(1,0) | dp02uod | Způsob uplatnění odpočtu daně - 1=100%,2=0%,3=kráceno | Způsob uplatnění odpočtu daně
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
bw01uziv | C(6) | Zapsal | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
ob02vzucet | N(1,0) | Vztah k účetnictví | Vztah k účetnictví - zboží, materiál, výrobek, služba ... | Vztah k účetnictví
ob02vzdph | N(1,0) | Vztah ceny k DPH | Vztah ceny artiklu k DPH - cena bez DPH,cena včetně DPH, cena včetně DPH z rozdílu nákladů a konečné ceny | Vztah ceny artiklu k DPH - cena bez DPH,cena s DPH, ....
ob02cnakl | N(20,4) | Spojená cena | Spojená cena |
ob02aktcen | N(1,0) | ob02aktcen | Událost aktualizuje ceník | Událost aktualizuje ceník
ob02stav | N(1,0) | ob02stav | Stav události - neurčeno, nevykrytá objednávka, vykrytá objednávka | Stav události - neurčeno, nevykrytá objednávka, vykrytá objednávka
ob02rezer | N(1,0) | ob02rezer | Stav události - rezervováno,nerezervováno | Stav události - rezervováno,nerezervováno
ob02volna | N(20,4) | Volné číslo | Volné číslo | Volné číslo
dp16id | C(6) | Předmět | Identifikace předmětu zdanitelného plnění | Identifikace předmětu zdanitelného plnění
ob02poradi | N(4,0) | Pořadí | Pořadí události v operaci | Pořadí události v operaci
ob02vc | C(32) | VČ | Výrobní číslo | Výrobní číslo

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost obchodního plnění - týká se obchodovatelného artiklu | OBUDAL sp60id sp61id | 1,1 : 0,M | OBARTIKL sp60id sp61id |
Událost obchodního plnění - je obchodována v měrné jednotce | OBUDAL sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Událost obchodního plnění - má zahraniční měnu | OBUDAL oc01id | 1,1 : 0,M | OCMENA oc01id |
Událost obchodního plnění - má referenční měnu | OBUDAL oc01id1 | 1,1 : 0,M | OCMENA oc01id |
Událost obchodního plnění - byla založena uživatelem | OBUDAL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost obchodního plnění - má referenční měrnou jednotku | OBUDAL sp24idmj1 | 1,1 : 0,M | SPMJ sp24idmj |
Událost obchodního plnění - patří do fyzické operace | OBUDAL sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost obchodního plnění - má obchodní selektor | OBUDAL sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost obchodního plnění - má organizační selektor | OBUDAL sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost obchodního plnění - má technicko-věcný selektor | OBUDAL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost obchodního plnění - má spojení na adresáta odběratele | OBUDAL ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost obchodního plnění - má typ zdanitelného plnění | OBUDAL dp03id | 1,1 : 0,M | DPZPT dp03id |
Událost obchodního plnění - má umístění | OBUDAL ob05id | 1,1 : 0,M | OBUMIST ob05id |
Událost obchodního plnění - má spojení na adresáta příjemce | OBUDAL ad01id1 ad11cissp1 | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost obchodního plnění - má měnu pro dopřesnění jednotkové ceny | OBUDAL oc01id2 | 1,1 : 0,M s rušením | OCMENA oc01id |
Událost obchodního plnění - má dopřesňující měrnou jednotku | OBUDAL sp24idmj2 | 1,1 : 0,M | SPMJ sp24idmj |
Událost obchodního plnění - byla oceněna v cenové skupině | OBUDAL ob11id | 1,1 : 0,M | OBCENSKP ob11id |
Událost obchodního plnění - je druhu objektu | OBUDAL pa13id bw55objec | 1,1 : 0,M | PAOBJDRU pa13id bw55objec |
Událost obchodního plnění - má charakter zdanitelného plnění | OBUDAL dp16id | 1,1 : 0,M | DPZPCH dp16id |
Událost - skladba - týká se operace | OBAHUD sp33hid | 1,1 : 0,M | OBUDAL ob02 |
Očekávaný výdej artiklu ze skladové buňky - se týká události obchodu | OBUDASKL ob02 | 1,1 : 0,M s rušením | OBUDAL ob02 |

Indexy

Název | Primární | Výraz | Popis
ix_OBUDAL_spprc |  | sp33cisd, sp33cisdpm, sp33cisdr | Identifikace procesu
ix_OBUDAL_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_OBUDAL_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_OBUDAL_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_OBUDAL_adspoj51 |  | ad01id1, ad11cissp1 | ad01id1+ad11cissp1
ix_OBUDAL_obcenikx |  | sp60id, sp61id, sp24idmj2, oc01id2 | !!!! sp60id+sp61id+ob04id+sp24id+oc01id2 !!!!!
ix_OBUDAL_spartiknx |  |  |
ix_OBUDAL_adadsatx |  |  |
ix_OBUDAL_obartiklx |  |  |
ix_OBUDAL_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_OBUDAL_paobjdru |  | pa13id, bw55objec | PI - pa13id+bw55objec
ix_OBUDAL_ob02 | P | ob02 | Jednoznačná časová identifikace
ix_OBUDAL_ob02dat |  | ob02dat | Datum vystavení události obchodovatelného artiklu (není datem zápisu)
ix_OBUDAL_ob02datdod |  | ob02datdod | Datum dodání
ix_OBUDAL_sp61id |  | sp61id | Identifikace druhu artiklu
ix_OBUDAL_ob02text |  | ob02text | Popis události o obchodovatelném artiklu
ix_OBUDAL_ob02hs |  | ob02hs | Číslo obchodní smlouvy
ix_OBUDAL_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky
ix_OBUDAL_sp24idmj1 |  | sp24idmj1 | Identifikátor měrné jednotky
ix_OBUDAL_sp24idmj2 |  | sp24idmj2 | Identifikátor měrné jednotky
ix_OBUDAL_ob05id |  | ob05id | Identifikace umístění obchodu - distribučního kanálu
ix_OBUDAL_dp03id |  | dp03id | Identifikace typu zdanitelného plnění
ix_OBUDAL_dp05id |  | dp05id | Identifikace typu místa zdanitelného plnění
ix_OBUDAL_ob11id |  | ob11id | Identifikace cenové skupiny
ix_OBUDAL_oc01id |  | oc01id | Kód měny - oceňovací jednotky.
ix_OBUDAL_oc01id1 |  | oc01id1 | Referenční měna kursu (je na pozadí)
ix_OBUDAL_oc01id2 |  | oc01id2 | Kód měny - oceňovací jednotky.
ix_OBUDAL_ob02mnr |  | ob02mnr | Množství obchodovatelného artiklu v referenční měrné jednotce.
ix_OBUDAL_dp02czazm |  | dp02czazm | Částka základu daně z přidané hodnoty v zahraniční měně
ix_OBUDAL_dp02cdpzm |  | dp02cdpzm | Částka daně z přidané hodnoty v zahraniční měně
ix_OBUDAL_dp02czarm |  | dp02czarm | Částka základu daně z přidané hodnoty v referenční měně
ix_OBUDAL_dp02cdprm |  | dp02cdprm | Částka daně z přidané hodnoty v referenční měně
ix_OBUDAL_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_OBUDAL_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_OBUDAL_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_OBUDAL_ad01id |  | ad01id | Identifikace adresáta
ix_OBUDAL_ad01id1 |  | ad01id1 | Identifikace adresáta - pro import
ix_OBUDAL_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_OBUDAL_sp00datzap |  | sp00datzap | Datum a čas zápisu záznamu události
ix_OBUDAL_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_OBUDAL_dp16id |  | dp16id | Identifikace předmětu zdanitelného plnění
ix_OBUDAL_ob02poradi |  | ob02poradi | Pořadí události v operaci
ix_OBUDAL_ob02vc |  | ob02vc | Výrobní číslo
ix_OBUDAL_obudal1 |  |  |
ix_OBUDAL_obudal2 |  |  |


OBUDASKL Očekávaný výdej artiklu ze skladové buňky

Popis

Očekávaný výdej artiklu ze skladové buňky

Atributy

Atribut | Typ | Návěští | Message | Popis
ob02 | C(12) | ob02 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
mt04id | C(6) | Sklad | Identifikace umístění skladové evidence | Identifikace umístění skladové evidence
mt05id | C(9) | Buňka | Identifikace skladové buňky | Identifikace skladové buňky

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Očekávaný výdej artiklu ze skladové buňky - se týká skladovové buňky | OBUDASKL mt04id mt05id | 1,1 : 0,M | MTBUN mt04id mt05id |
Očekávaný výdej artiklu ze skladové buňky - se týká události obchodu | OBUDASKL ob02 | 1,1 : 0,M s rušením | OBUDAL ob02 |

Indexy

Název | Primární | Výraz | Popis
ix_OBUDASKL_ob02 | P | ob02 | Jednoznačná časová identifikace
ix_OBUDASKL_mtbun1 |  | mt04id, mt05id | mt04id+mt05id


OBUMIST Umístění - distribuční kanál

Atributy

Atribut | Typ | Návěští | Message | Popis
ob05id | C(6) | Umístění | Identifikace umístění obchodu - distribučního kanálu | Identifikace umístění obchodu - distribučního kanálu
ob05 | C(12) | ob05 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
ob05text | C(40) | Název umístění | Název umístění obchodu - distribučního kanálu | Název umístění obchodu - distribučního kanálu
sp11idzak | C(9) | Organizační selektor | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
sp00uselum | C(9) | Účetní selektor umístění | Účetní selektor umístění | Účetní selektor umístění

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Umístění - distribuční kanál - má organizační selektor | OBUMIST sp11idzak | 1,1 : 1,1 | SPSEOR sp11idzak |
Umístění - distribuční kanál - má spojení na adresáta | OBUMIST ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost obchodního plnění - má umístění | OBUDAL ob05id | 1,1 : 0,M | OBUMIST ob05id |
Položka katalogu zboží obchodu - definuje uložení artiklu | OBKATALP ob05id | 0,1 : 0,M | OBUMIST ob05id |
AAA v cenové skupině - se týká umístění obchodu | OBCENSAK ob05id | 0,1 : 0,M | OBUMIST ob05id |

Indexy

Název | Primární | Výraz | Popis
ix_OBUMIST_ob05id | P | ob05id | Identifikace umístění obchodu - distribučního kanálu
ix_OBUMIST_ob05 | U | ob05 | Jednoznačná časová identifikace
ix_OBUMIST_ob05text |  | ob05text | Název umístění obchodu - distribučního kanálu
ix_OBUMIST_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_OBUMIST_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_OBUMIST_ad01id |  | ad01id | Identifikace adresáta


Tabulky OC...

OCBANKA | Banka
OCKUROPE | Druh operace s vyhodnocením kurzu k prvému dni měsíce
OCKURS | Kurs
OCMENA | Měna
OCPREMEN | Přechod na měnu
OCPREPK | Přepočítávací koeficient
OCPREPKO | Období platnosti přepočítávacího koeficientu

Viz.také

OCBANKA Banka | OCKUROPE Druh operace s vyhodnocením kurzu k prvému dni měsíce | OCKURS Kurs | OCMENA Měna | OCPREPK Přepočítávací koeficient | OCPREPKO Období platnosti přepočítávacího koeficientu | OCPREMEN Přechod na měnu


OCBANKA Banka

Popis

Objektem typu ADBANKY je každý finanční ústav, který provádí bankovní a finanční operace pro daného adresáta. Uvedením identifikace adresy je umožněno specifikovat v bankovních spojeních přesné adresy bankovních poboček. Využití pro zahraniční platební styk.
*** Dříve BANKY.

Atributy

Atribut | Typ | Návěští | Message | Popis
ad01id | C(6) | Adresát | Adresát | Identifikace adresáta
ad02cisadr | C(2) | Číslo adresy adresáta | Číslo adresy adresáta. | Číslo adresy adresáta. Program generuje automaticky. *** Dříve CISADR. C,1 !!!
oc02idbank | C(4) | Kód banky | Kód banky | Kód banky
oc02nazevb | C(40) | Název banky | Název banky | Název banky
oc02swift | C(11) | SWIFT | SWIFT kód banky. | SWIFT kód banky.
oc02blz | C(10) | Kód BLZ | BLZ kód banky | BLZ kód banky
oc02mod11 | N(1,0) | Kontrola čísla účtu | Kontrola čísla účtu | Kontrola čísla účtu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Banka - má adresáta (jako banku) | OCBANKA ad01id | 0,1 : 0,M | ADADSAT ad01id |
Banka - má adresu adresáta (banky) | OCBANKA ad01id ad02cisadr | 0,1 : 0,M | ADADR ad01id ad02cisadr |
Kurs - je veden v bance | OCKURS oc02idbank | 1,1 : 0,M s rušením | OCBANKA oc02idbank |
Bankovní účty adresátů - patří bance | ADBUCTY oc02idbank | 1,1 : 0,M | OCBANKA oc02idbank |

Indexy

Název | Primární | Výraz | Popis
ix_OCBANKA_oc02idbank | P | oc02idbank | Kód banky
ix_OCBANKA_oc02nazevb |  | oc02nazevb | Název banky
ix_OCBANKA_ad01id |  | ad01id | Identifikace adresáta


OCKUROPE Druh operace s vyhodnocením kurzu k prvému dni měsíce

Popis

Druh operace s vyhodnocením kurzu k prvému dni měsíce

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor druhu operace | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
oc07posunr | N(4,0) | Posun roku | Posun roku v kurzovním lístku | Posun roku v kurzovním lístku
oc07koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh operace s vyhodnocením kurzu k prvému dni měsíce - je druhu operace | OCKUROPE sp07idtyp sp06idsubs | 1,1 : 0,1 | SPTYP sp07idtyp sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_OCKUROPE_sptyp | P | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_OCKUROPE_sp06idsubs |  | sp06idsubs | Identifikace subsystému.


OCKURS Kurs

Popis

Kurs vyjadřuje poměr ve které je daná oceňovací jednotka směnitelná k jiné oceňovací jednotce. Kursy příslušející jednotlivým oceňovacím jednotkám jsou vztaženy k referenční měně a k bance v níž jsou platné. Z důvodu možnosti změny referenční měny jsou v entitě realizovány dvě identifikace oceňovacích jednotek. Při změně referenční měny tak nedochází ke ztrátě vypovídací schopnosti dat. Kurs se skládá z kursu a množství měny v kursu (viz ITL, BEF, HUF)
*** Dříve KURZY.

Atributy

Atribut | Typ | Návěští | Message | Popis
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
oc01id1 | C(3) | Referenční měna | Referenční měna | Referenční měna kursu (je na pozadí)
oc02idbank | C(4) | Kód banky | Kód banky | Kód banky
oc03dat | D | Datum | Datum platnosti kursu. | Datum platnosti kurzu.
oc03kurz | N(20,6) | Kurs | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup. | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup.
oc03kurzp | N(20,6) | Prodej | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - prodej. | Kurs oceňovací jednotky vůči referenční oceňovací jednotce prodej.
oc03kurzs | N(20,6) | Střed | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - střed. | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - střed.
oc03mn | N(5,0) | Množství | Množství oceňovací jednotky v kursu. | Množství oceňovací jednotky v kurzu.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Kurs - je určen měně | OCKURS oc01id | 1,1 : 0,M s rušením | OCMENA oc01id |
Kurs - je veden v bance | OCKURS oc02idbank | 1,1 : 0,M s rušením | OCBANKA oc02idbank |

Indexy

Název | Primární | Výraz | Popis
ix_OCKURS_ockurs1 | P | oc01id, oc01id1, oc02idbank, oc03dat | Měna+referenční měna+banka+datum
ix_OCKURS_oc01id |  | oc01id | Kód měny - oceňovací jednotky.
ix_OCKURS_oc02idbank |  | oc02idbank | Kód banky


OCMENA Měna

Popis

Objektem typu OCMENA je každá oceňovací jednotka - měna. Jedná se především o měnu. Jedna z oceňovacích jednotek je určena (v parametrech) jako referenční vůči ostatním. Kursy příslušející jednotlivým oceňovacím jednotkám jsou vztaženy k této referenční měně. Obchodovatelné artikly mohou mít ceníkovou cenu uvedenou v různých oceňovacích jednotkách. Typické je však ocenění v referenční měně.
*** Dříve MENY

Atributy

Atribut | Typ | Návěští | Message | Popis
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
oc01nazev | C(18) | Název měny | Název měny | Název měny
oc01znak | C(3) | Znak | Označení měny. | Označení měny. Např. "Kč", "DM"
oc01zar | N(1,0) | Zaokrouhlování | Zaokrouhlení na řád v předpisu platby | Zaokrouhlení na řád. Určuje způsob zaokrouhlení (stovky, desítky, jednotky, desetiny, setiny)
oc01min | N(1,0) | oc01min | Nejmenší jednotka měny | Nejmenší jednotka měny
oc01platod | D | Platnost od | Platnost měny od | Platnost měny od
oc01platdo | D | Platnost do | Platnost měny do | Platnost měny do

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Hodnota parametru předmětu projektu - je uvedena v měně | NKHODNP oc01id | 0,1 : 0,M | OCMENA oc01id |
Položka smlouvy - je o měně | NKSMLOUV oc01id | 1,1 : 0,M | OCMENA oc01id |
Událost plnění položky smlouvy - má měnu | NKSMLPLN oc01id | 1,1 : 0,M | OCMENA oc01id |
Událost o záloze - uvádí částku v zahraniční měně | ZAUDAL oc01id | 1,1 : 0,M | OCMENA oc01id |
Událost o záloze - uvádí částku v refrenční měně | ZAUDAL oc01id1 | 1,1 : 0,M | OCMENA oc01id |
Událost o záloze - uvádí částku v měně předpisu zálohy | ZAUDAL oc01id2 | 1,1 : 0,M | OCMENA oc01id |
Druh události položky smlouvy nebo události plnění položky smlouvy - má předplňovanou měnu | NKPLNDRU oc01id | 0,1 : 0,M | OCMENA oc01id |
Další měna bankovního účtu - určuje měny | ADBUCTYM oc01id | 1,1 : 0,M | OCMENA oc01id |
Přechod na měnu - je pro měnu | OCPREMEN oc01id | 1,1 : 0,M | OCMENA oc01id |
Adresát - má implicitní měnu | ADADSAT oc01id | 1,1 : 0,M | OCMENA oc01id |
Účetní událost - účtuje o zahraniční měně | UCDENIK oc01id | 1,1 : 0,M | OCMENA oc01id |
Účetní událost - účtuje o referenční měně | UCDENIK oc01id1 | 1,1 : 0,M | OCMENA oc01id |
Měsíční obrat - je v měně | UCOBRTAB oc01id | 1,1 : 0,M | OCMENA oc01id |
Událost obchodního plnění - má zahraniční měnu | OBUDAL oc01id | 1,1 : 0,M | OCMENA oc01id |
Událost obchodního plnění - má referenční měnu | OBUDAL oc01id1 | 1,1 : 0,M | OCMENA oc01id |
Událost obchodního plnění - má měnu pro dopřesnění jednotkové ceny | OBUDAL oc01id2 | 1,1 : 0,M s rušením | OCMENA oc01id |
Kurs - je určen měně | OCKURS oc01id | 1,1 : 0,M s rušením | OCMENA oc01id |
Bankovní účty adresátů - je veden v měně | ADBUCTY oc01id | 1,1 : 0,M | OCMENA oc01id |
Událost DPH - má měnu | DPUDA oc01id | 1,1 : 0,M | OCMENA oc01id |
Událost DPH - má referenční měnu | DPUDA oc01id1 | 1,1 : 0,M | OCMENA oc01id |
Položka ceníku artiklu - je za měnu | OBCENIK oc01id | 1,1 : 0,M | OCMENA oc01id |
Událost plateb - má zahraniční měnu | PLUDA oc01id | 1,1 : 0,M | OCMENA oc01id |
Událost plateb - má referenční měnu | PLUDA oc01id1 | 1,1 : 0,M | OCMENA oc01id |
Událost změny stavu peněz - výpisy a příkazy - má měnu | ZPUDA oc01id | 1,1 : 0,M | OCMENA oc01id |
Událost změny stavu peněz - výpisy a příkazy - má měnu bankovního účtu/pokladny | ZPUDA oc01id2 | 1,1 : 0,M | OCMENA oc01id |
Událost vymáhání - má zahraniční měnu | VMUDA oc01id | 1,1 : 0,M | OCMENA oc01id |
Seznam zdravotních pojišťoven - sociální pojišťovna má měnu | MZPOJSEZ oc01id | 0,1 : 0,M | OCMENA oc01id |
Přepočítávací koeficient - se vztahuje k měně | OCPREPK oc01id | 1,1 : 0,M | OCMENA oc01id |

Indexy

Název | Primární | Výraz | Popis
ix_OCMENA_oc01id | P | oc01id | Kód měny - oceňovací jednotky.
ix_OCMENA_oc01nazev |  | oc01nazev | Název měny


OCPREMEN Přechod na měnu

Popis

Přechod na měnu

Atributy

Atribut | Typ | Návěští | Message | Popis
oc08dat | D | Dne | Datum přechodu na měnu | Datum přechodu na měnu
oc08datdo | D | Do | Datum platnosti měny do | Datum platnosti měny do
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Přechod na měnu - je pro měnu | OCPREMEN oc01id | 1,1 : 0,M | OCMENA oc01id |

Indexy

Název | Primární | Výraz | Popis
ix_OCPREMEN_oc08dat | P | oc08dat | Datum přechodu na měnu
ix_OCPREMEN_oc01id |  | oc01id | Kód měny - oceňovací jednotky.


OCPREPK Přepočítávací koeficient

Popis

Přepočítávací koeficient

Atributy

Atribut | Typ | Návěští | Message | Popis
oc05id | C(3) | Období | Identifikace období platnosti přepočítávacího koeficientu | Identifikace období platnosti přepočítávacího koeficientu
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
oc06koef | N(12,6) | Přepočítávací koeficient | Přepočítávací koeficient | Přepočítávací koeficient

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Přepočítávací koeficient - se vztahuje k období | OCPREPK oc05id | 1,1 : 0,M | OCPREPKO oc05id |
Přepočítávací koeficient - se vztahuje k měně | OCPREPK oc01id | 1,1 : 0,M | OCMENA oc01id |

Indexy

Název | Primární | Výraz | Popis
ix_OCPREPK_ocprepk | P | oc05id, oc01id |
ix_OCPREPK_oc05id |  | oc05id | Identifikace období platnosti přepočítávacího koeficientu
ix_OCPREPK_oc01id |  | oc01id | Kód měny - oceňovací jednotky.


OCPREPKO Období platnosti přepočítávacího koeficientu

Popis

Období platnosti přepočítávacího koeficientu

Atributy

Atribut | Typ | Návěští | Message | Popis
oc05id | C(3) | Období | Identifikace období platnosti přepočítávacího koeficientu | Identifikace období platnosti přepočítávacího koeficientu
oc05datumo | D | Datum od | Datum platnosti od | Datum platnosti od
oc05datumd | D | do | Datum platnosti do | Datum platnosti do
oc05platne | N(1,0) | oc05platne | Platné období, bude užito pro výpočet triangulací | Platné období

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Přepočítávací koeficient - se vztahuje k období | OCPREPK oc05id | 1,1 : 0,M | OCPREPKO oc05id |

Indexy

Název | Primární | Výraz | Popis
ix_OCPREPKO_oc05id | P | oc05id | Identifikace období platnosti přepočítávacího koeficientu


Tabulky OD...

ODAH | Aktuální hodnota
ODAHUD | Událost - skladba
ODKARTA | Karta
ODODPIND | Tabulka individuálního odpisu
ODODPSKP | Sazby a koeficienty odpisových skupin
ODODPSKU | Odpis.skupina
ODTABKOE | Tabulka samotných keficientů
ODTABOPR | Tabulka koeficientů oprávek
ODUDAL | Událost odpisovaného majetku
ODVYKON | Výkon
ODW1PROG | Prognózování odpisů

Viz.také

ODUDAL Událost odpisovaného majetku | ODAH Aktuální hodnota | ODAHUD Událost - skladba | ODKARTA Karta | ODODPSKU Odpis.skupina | ODTABKOE Tabulka samotných keficientů | ODTABOPR Tabulka koeficientů oprávek | ODVYKON Výkon | ODW1PROG Prognózování odpisů | ODODPSKP Sazby a koeficienty odpisových skupin | ODODPIND Tabulka individuálního odpisu


ODAH Aktuální hodnota

Atributy

Atribut | Typ | Návěští | Message | Popis
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
od02castka | N(20,4) | Částka | Finanční částka | Finanční částka
od02castk2 | N(20,4) | od02castk2 |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Aktuální hodnota - má uvedené adresové spojení | ODAH ad01id | 1,1 : 0,M | ADADSAT ad01id |
Aktuální hodnota - má druh hodnoty | ODAH sp67id sp06idsubs | 1,1 : 1,1 | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_ODAH_odah | P | sp67id, sp06idsubs, sp60id, sp61id, ad01id |
ix_ODAH_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_ODAH_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_ODAH_sp61id |  | sp61id | Identifikace druhu artiklu
ix_ODAH_ad01id |  | ad01id | Identifikace adresáta


ODAHUD Událost - skladba

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
od02 | C(12) | od02 | Časová identifikace události. | Časová identifikace události.
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp69id | C(6) | Druh | Identifikace druhu saldokontní hodnoty procesu | Identifikace druhu saldokontní hodnoty procesu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp00datum | D | Datum | Datum události | Datum události
sp00text | C(40) | Popis | Popis události | Popis události
sp00hodnot | N(20,4) | Hodnota | Aktuální hodnota procesu |
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp74id | C(6) | sp74id | Umístění | Umístění

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost - skladba - týká se operace | ODAHUD od02 | 1,1 : 0,M s rušením | ODUDAL od02 |

Indexy

Název | Primární | Výraz | Popis
ix_ODAHUD_sp33hid |  | sp33hid | Časová identifikace hlavního procesu
ix_ODAHUD_od02 |  | od02 | Časová identifikace události.
ix_ODAHUD_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_ODAHUD_sp69id |  | sp69id | Identifikace druhu saldokontní hodnoty procesu
ix_ODAHUD_ad01id |  | ad01id | Identifikace adresáta
ix_ODAHUD_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_ODAHUD_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_ODAHUD_spahud |  | sp60id, sp61id, ad01id, sp74id, sp67id, sp06idsubs | Artikl+Aktér+Umístění+Druh hodnoty
ix_ODAHUD_spprcsal |  | sp33hid, sp69id, ad01id, sp60id, sp61id, sp74id | Primární index salda procesu


ODKARTA Karta

Popis

Objektem typu ODKARTA je každý záznam, který obsahuje základní údaje o odepisovaném majetku - investiční majetek, pohledávky.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
od01koment | M | Komentář | Komentář | Komentář
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
od01oprocd | N(5,2) | od01oprocd |  |
od01oprocu | N(5,2) | od01oprocu |  |
sp17idskp | C(8) | Třída SKP | Identifikace třídy Standardní klasifikace produkce. | Identifikace kategorie Standardní klasifikace produkce. *** Dříve SKPID.
sp24idmj | C(3) | MJ | Identifikátor měrné jednotky | Identifikátor měrné jednotky
sm05id | C(6) | Umístění | Identifikátor umístění | Identifikátor umístění
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
sp00uselar | C(9) | Účetní selektor artiklu | Účetní selektor artiklu | Účetní selektor artiklu
od01datzar | D | Datum zařazení | Datum zařazení | Datum zařazení inv. maj.
od01datvyr | D | Datum vyřazení | Datum vyřazení | Datum vyřazení inv. maj.
od01druhim | N(1,0) | Druh inv.maj. | Druh investičního majetku | Druh investičního majetku - HIM, NHIM, DHIM, DNHIM
od01zpuo | N(1,0) | Způsob odpisování | Způsob účetního odpisování investičního majetku | Způsob účetního odpisování investičního majetku - Neodpisovat, Dle času, Dle výkonu, Dle daň.odp.
od01pc | N(20,4) | Pořiz. cena | Pořizovací cena - účetní | Účetní pořizovací cena inv.maj., nebo nesplacená část pohledávky.
od01zcu | N(20,4) | Zůst. cena | Zůstatková cena - účetní | Účetní zůstatková cena inv.maj., nebo neodepsaný zůstatek pohledávky.
od01vc | N(20,4) | Vstup.cena | Vstupní cena - daňová | Daňová vstupní cena inv.maj., nebo nesplacená část pohledávky.
od01zcd | N(20,4) | Zůst.cena | Zůstatková cena - daňová | Daňová zůstatková cena inv.maj., nebo neodepsaný zůstatek pohledávky.
od01plczv | N(10,0) | Plán. celož. výkon | Plánovaný celoživotní výkon (pro odpis dle času je výkon v měsících) | Plánovaný celoživotní výkon. Při provedení technického zhodnocení je na uživateli, aby tuto položku podle potřeby upravil.
od01rocvyk | N(10,0) | Roč. výkon | Uvedený roční výkon se použije při výpočtu prognózy odpisů | Prognózovaný roční výkon - složí pouze k výpočtu prognózy odpisů
od01zpdo | N(1,0) | Způsob odpisování | Způsob daňového odpisování investičního majetku | Způsob daňového odpisování investičního majetku - Neodpisovat, Rovnoměrně, Zrychleně
od05odpsku | C(9) | Skupina | Odpisová skupina | Odpisová skupina pro potřebu daňového odpisování: 1 - 5
od01pocopr | N(3,0) | od01pocopr | Atribut se nepoužívá | Atribut se nepoužívá Předpokládaný počet daňových odpisů pro úplné odepsání inv. majetku.
od01zezvar | N(3,0) | od01zezvar |  |
od01jehlpr | N(1,0) | Je hlav.předmětem | Inv.maj. je hlavním předmětem souboru IM | Inv.maj. je hlavním předmětem souboru investičního majetku.
od01podhlp | C(6) | Patří pod hl.předmět | Inv.maj. patří pod hlavní předmět souboru IM | Inv.maj. patří pod hlavní předmět souboru investičního majetku.
od01datspl | D | Datum spl. | Datum splatnosti pohledávky | Datum splatnosti pohledávky
od01sazbau | N(6,2) | Roční odp.sazba % | Roční odpisová sazba pro účetní odpis pohledávky | Roční odpisová sazba pro účetní odpis pohledávky
od01sazbad | N(6,2) | Roční odp.sazba % | Roční odpisová sazba pro daňová odpis pohledávky | Roční odpisová sazba pro daňová odpis pohledávky
od01datodu | D | Odepsána dne | Datum, ke kterému byla pohledávka zcela účetně odepsána | Datum, ke kterému byla pohledávka zcela účetně odepsána
od01datodd | D | Odepsána dne | Datum, ke kterému byla pohledávka zcela daňově odepsána | Datum, ke kterému byla pohledávka zcela daňově odepsána
sp60id1 | C(13) | sp60id1 |  |
sp61id1 | C(3) | sp61id1 |  |
od01uonap | N(20,4) | od01uonap | Suma ucetnich odpisu dle danovych za rok |
od01druh | N(1,0) | od01druh |  |
od01komp | N(1,0) | Komp. | Majetek souvisí s komponentou | Dělí evidovaný majetek na investiční majetek a pohledávky.
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
od01ucodpr | N(6,2) | od01ucodpr | Odepsat % z pohledávky - účetní stav |
od01ucodop | N(6,2) | od01ucodop | Opravná položka do % výše zůstatkové ceny - účetní stav |
od01daodpr | N(6,2) | Roční odpis | Procento ročního odpisu pohledávky |
od01daodop | N(6,2) | od01daodop | Opravná položka do % výše zůstatkové ceny - daňový stav |
od01zmena | N(1,0) | od01zmena |  |
od01drodp | N(1,0) | od01drodp | Druh pohledávky |
od01datum | D | Datum | Datum |
od01odpz | N(20,4) | od01odpz | Hodnota pohledávky | Hodnota pohledávky
od37id | C(6) | Tabulka | Identifikace tabulky |
od01aktual | N(1,0) | od01aktual | Aktuální / Neaktuální karta | Aktuální / neaktuální karta
od01domes | N(3,0) | Měsíců | Počet měsíců rovnoměrného odepisování nehmotného majetku | Počet měsíců rovnoměrného odepisování nehmotného majetku
od01domtz | N(3,0) | Po TZ | Minimální počet měsíců rovnoměrného odepisování nehmotného majetku po technickém zhodnocení | Minimální počet měsíců rovnoměrného odepisování nehmotného majetku po technickém zhodnocení
od01prozvo | N(2,0) | % zvýšení | Procento zvýšení rovnoněrného odpisu v prvním roce odepisování | Procento zvýšení rovnoněrného odpisu v prvním roce odepisování
od01uozar | N(1,0) | Odpis v měs.zař. | Počítat účetní odpis i za měsíc, kdy došlo k zařazení | Počítat účetní odpis i za měsíc, kdy došlo k zařazení
od01uovyr | N(1,0) | Odpis v měs.vyř. | Počítat účetní odpis i za měsíc, kdy došlo k vyřazení | Počítat účetní odpis i za měsíc, kdy došlo k vyřazení
od01datzuo | D | Dat. zaháj. UO | Datum zahájení odepisování účetních odpisů | Datum zahájení odepisování účetních odpisů
od01datzdo | D | Dat. zaháj. DO | Datum zahájení odepisování daňových odpisů | Datum zahájení odepisování daňových odpisů

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Karta - a její SKP | ODKARTA sp17idskp | 1,1 : 0,M | SPSKP sp17idskp |
Karta - a její tech.věc.sel. | ODKARTA sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Karta - zapsal | ODKARTA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Karta - a její odpisová skupina | ODKARTA od05odpsku | 1,1 : 0,M | ODODPSKU od05odpsku |
Karta - odpovídá artiklu | ODKARTA sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Karta - ma druh artiklu | ODKARTA sp61id | 1,1 : 0,M | SPARTIKD sp61id |
Karta - má organizační selektor | ODKARTA sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Karta - má obchodní selektor | ODKARTA sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Karta - má tabulku koeficientů | ODKARTA od37id od01drodp | 1,1 : 0,M | ODTABOPR od37id od01drodp |
Karta - má umístění | ODKARTA sm05id | 1,1 : 0,M | SMUMIS sm05id |
Tabulka individuálního odpisu - patří ke kartě odepisovaného majetku | ODODPIND sp60id sp61id | 1,1 : 0,M | ODKARTA sp60id sp61id |
Událost odpisovaného majetku - má kartu | ODUDAL sp60id sp61id | 1,1 : 0,M | ODKARTA sp60id sp61id |
Výkon - ma artikl - pro RFI | ODVYKON sp60id sp61id | 1,1 : 0,M | ODKARTA sp60id sp61id |
Vazba mezi platbou a kartou odpisu,opravné položky aktiva - váže kartu odpisu,opravné položky aktiva | PLPLOD sp60id sp61id | 1,1 : 0,M s rušením | ODKARTA sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_ODKARTA_spartikl | P | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_ODKARTA_sp61id |  | sp61id | Identifikace druhu artiklu
ix_ODKARTA_sp60id |  | sp60id | Identifikace artiklu
ix_ODKARTA_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_ODKARTA_sp00datzap |  | sp00datzap | Datum a čas zápisu záznamu události
ix_ODKARTA_sp17idskp |  | sp17idskp | Identifikace kategorie Standardní klasifikace produkce.
ix_ODKARTA_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky
ix_ODKARTA_sm05id |  | sm05id | Identifikátor umístění
ix_ODKARTA_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_ODKARTA_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_ODKARTA_od01druhim |  | od01druhim | Druh investičního majetku - HIM, NHIM, DHIM, DNHIM
ix_ODKARTA_od01zpuo |  | od01zpuo | Způsob účetního odpisování investičního majetku - Neodpisovat, Dle času, Dle výkonu, Dle daň.odp.
ix_ODKARTA_od01zpdo |  | od01zpdo | Způsob daňového odpisování investičního majetku - Neodpisovat, Rovnoměrně, Zrychleně
ix_ODKARTA_od05odpsku |  | od05odpsku | Odpisová skupina pro potřebu daňového odpisování: 1 - 5
ix_ODKARTA_od01jehlpr |  | od01jehlpr | Inv.maj. je hlavním předmětem souboru investičního majetku.
ix_ODKARTA_spartikl1 |  | sp60id1, sp61id1 | CI - sp60id1+sp61id1
ix_ODKARTA_spartiknx |  |  |
ix_ODKARTA_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_ODKARTA_od01drodp |  | od01drodp |
ix_ODKARTA_odtabopr |  | od37id, od01drodp |


ODODPIND Tabulka individuálního odpisu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
od41mesic | C(2) | Měsíc | Měsíc | Měsíc
od41rok | C(4) | Rok | Rok | Rok
od41castka | N(20,4) | Částka | Částka | Částka
od41text | C(40) | Popis | Popis | Popis
od41koment | M | Komentář | Komentář | Komentář

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Tabulka individuálního odpisu - patří ke kartě odepisovaného majetku | ODODPIND sp60id sp61id | 1,1 : 0,M | ODKARTA sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_ODODPIND_sp61id |  | sp61id | Identifikace druhu artiklu
ix_ODODPIND_sp60id |  | sp60id | Identifikace artiklu
ix_ODODPIND_od41mesic |  | od41mesic | Měsíc
ix_ODODPIND_od41rok |  | od41rok | Rok
ix_ODODPIND_od41castka |  | od41castka | Částka
ix_ODODPIND_od41text |  | od41text | Popis
ix_ODODPIND_ododpind | P | sp61id, sp60id, od41mesic, od41rok |
ix_ODODPIND_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id


ODODPSKP Sazby a koeficienty odpisových skupin

Popis

Sazby a koeficienty odpisových skupin

Atributy

Atribut | Typ | Návěští | Message | Popis
od05odpsku | C(9) | Skupina | Odpisová skupina | Odpisová skupina pro potřebu daňového odpisování: 1 - 5
od40datum | D | Platnost od | Platnost sazeb a koeficientů od data včetně | Platnost sazeb a koeficientů od
od40r1rok | N(5,2) | V prvním roce | Sazba pro rovnoměrný odpis v prvním roce | Sazba pro rovnoměrný odpis v prvním roce
od40rdalsi | N(5,2) | V dalších letech | Sazba pro rovnoměrný odpis v dalších letech | Sazba pro rovnoměrný odpis v dalších letech
od40rzvys | N(5,2) | Pro odpis ze zvýšené ceny | Sazba pro rovnoměrný odpis ze zvýšené vstupní ceny | Sazba pro rovnoměrný odpis ze zvýšené vstupní ceny
od40z1rok | N(2,0) | V prvním roce | Koeficient pro zrychlený odpis v prvním roce | Koeficient pro zrychlený odpis v prvním roce
od40zdalsi | N(2,0) | V dalších letech | Koeficient pro zrychlený odpis v dalších letech | Koeficient pro zrychlený odpis v dalších letech
od40zzvys | N(2,0) | Pro odpis ze zvýšené ceny | Koeficient pro zrychlený odpis ze zvýšené ceny | Koeficient pro zrychlený odpis ze zvýšené ceny
od40proce | N(3,0) | Procento | Procento (první rok odepisování) vstupní ceny |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Sazby a koeficienty odpisových skupin - jsou sazbami odpisové skupiny | ODODPSKP od05odpsku | 1,1 : 0,M | ODODPSKU od05odpsku |

Indexy

Název | Primární | Výraz | Popis
ix_ODODPSKP_ododpskp | P | od05odpsku, od40datum | PI - od05odpsku+od40datum
ix_ODODPSKP_od05odpsku |  | od05odpsku | Odpisová skupina pro potřebu daňového odpisování: 1 - 5


ODODPSKU Odpis.skupina

Popis

Objektem typu ODODPSKU je každý záznam, který obsahuje odpisovou skupinu, podle které se počítá daňový odpis investičního majetku.

Atributy

Atribut | Typ | Návěští | Message | Popis
od05odpsku | C(9) | Skupina | Odpisová skupina | Odpisová skupina pro potřebu daňového odpisování: 1 - 5
od05r1rok | N(5,2) | od05r1rok | Sazba pro rovnoměrný odpis v prvním roce | Sazba pro rovnoměrný odpis v prvním roce
od05rdalsi | N(5,2) | od05rdalsi | Sazba pro rovnoměrný odpis v dalších letech | Sazba pro rovnoměrný odpis v dalších letech
od05rzvys | N(5,2) | od05rzvys | Sazba pro rovnoměrný odpis ze zvýšené vstupní ceny | Sazba pro rovnoměrný odpis ze zvýšené vstupní ceny
od05z1rok | N(2,0) | od05z1rok | Koeficient pro zrychlený odpis v prvním roce | Koeficient pro zrychlený odpis v prvním roce
od05zdalsi | N(2,0) | od05zdalsi | Koeficient pro zrychlený odpis v dalších letech | Koeficient pro zrychlený odpis v dalších letech
od05zzvys | N(2,0) | od05zzvys | Koeficient pro zrychlený odpis ze zvýšené ceny | Koeficient pro zrychlený odpis ze zvýšené ceny
od05koment | M | od05koment |  |
od05platdo | D | do | Platnost odpisové skupiny do | Platnost odpisové skupiny do musí být uvedena

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Sazby a koeficienty odpisových skupin - jsou sazbami odpisové skupiny | ODODPSKP od05odpsku | 1,1 : 0,M | ODODPSKU od05odpsku |
Karta - a její odpisová skupina | ODKARTA od05odpsku | 1,1 : 0,M | ODODPSKU od05odpsku |

Indexy

Název | Primární | Výraz | Popis
ix_ODODPSKU_od05odpsku | P | od05odpsku | Odpisová skupina pro potřebu daňového odpisování: 1 - 5


ODTABKOE Tabulka samotných keficientů

Atributy

Atribut | Typ | Návěští | Message | Popis
od37id | C(6) | od37id |  |
od01drodp | N(1,0) | od01drodp |  |
od38mesic | N(4,0) | od38mesic |  |
od38procen | N(6,2) | od38procen |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Tabulka samotných keficientů - má hlavičku | ODTABKOE od37id od01drodp | 1,1 : 0,M | ODTABOPR od37id od01drodp |

Indexy

Název | Primární | Výraz | Popis
ix_ODTABKOE_odtabkoe | P | od37id, od01drodp, od38mesic |
ix_ODTABKOE_odtabopr |  | od37id, od01drodp |


ODTABOPR Tabulka koeficientů oprávek

Atributy

Atribut | Typ | Návěští | Message | Popis
od37id | C(6) | od37id |  |
od01drodp | N(1,0) | od01drodp |  |
od37naztab | C(40) | od37naztab |  |
od37koment | M | od37koment |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Tabulka samotných keficientů - má hlavičku | ODTABKOE od37id od01drodp | 1,1 : 0,M | ODTABOPR od37id od01drodp |
Karta - má tabulku koeficientů | ODKARTA od37id od01drodp | 1,1 : 0,M | ODTABOPR od37id od01drodp |

Indexy

Název | Primární | Výraz | Popis
ix_ODTABOPR_odtabopr | P | od37id, od01drodp |
ix_ODTABOPR_od37id |  | od37id |
ix_ODTABOPR_od37naztab |  | od37naztab |


ODUDAL Událost odpisovaného majetku

Popis

Objektem typu ODUDAL je každý záznam, který obsahuje událost nad odepisovaným majetkem.

Atributy

Atribut | Typ | Návěští | Message | Popis
od02 | C(12) | od02 | Časová identifikace události. | Časová identifikace události.
od02datum | D | Datum | Datum události | Datum události
od02zmena | N(1,0) | Změna | Změna - příjem / výdej | Změna -Příjem, Výdej
od01komp | N(1,0) | Komp. | Majetek souvisí s komponentou | Dělí evidovaný majetek na investiční majetek a pohledávky.
od02druh | N(1,0) | Druh události | Druh události - Příjem,Výdej, Úč.odpis, Daň.odpis, Tech.zhod., Úč.odpis pohledávky,Daň.odpis pohledávky,Účetní opr.pol.,Daňová opr.pol. | Druh události - Běžná, Úč.odpis, Daň.odpis, Tech.zhod.
od02typ | N(1,0) | Typ | Typ události - Běžný, Mimořádný | Typ události - Běžný, Mimořádný Má význam u účetního a daňového odpisu.
od02platno | N(1,0) | Platnost | Platnost události | Platnost události - Platná, Stornovaná, Stornovací
od02text | C(40) | Popis | Doplňující popis události |
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
od02castka | N(20,4) | Částka | Finanční částka | Finanční částka
od02castk2 | N(20,4) | od02castk2 |  |
od01pc | N(20,4) | Pořiz. cena | Pořizovací cena - účetní | Účetní pořizovací cena inv.maj., nebo nesplacená část pohledávky.
od02pcu | N(1,0) | PC účetní | Pořizovací cena účetní | Pořizovací cena účetní u inv.majetku, nesplacená část pohl. u pohledávek. Když je Ano, změní (zvýší/sníží) se PC účetní na kartě o uvedenou částku.
od02zcu | N(1,0) | ZC účetní | Zůstatková cena účetní | Zůstatková cena účetní u inv.majetku, neodepsaná část nesplacené pohl. u pohledávek. Když je Ano, změní (zvýší/sníží) se ZC účetní na kartě o uvedenou částku.
od02vcd | N(1,0) | VC daňová | Vstupní cena daňová | Vstupní cena daňová u inv.majetku, nesplacená část pohl. u pohledávek. Když je Ano, změní (zvýší/sníží) se VC daňová na kartě o uvedenou částku.
od02zcd | N(1,0) | ZC daňová | Zůstatková cena daňová | Zůstatková cena daňová u inv.majetku, neodepsaná část nesplacené pohl. u pohledávek. Když je Ano, změní (zvýší/sníží) se ZC daňová na kartě o uvedenou částku.
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
bw01uziv | C(6) | Zapsal | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp69id | C(3) | Druh | Identifikace druhu události | Identifikace druhu události
od02procen | N(6,2) | od02procen |  |
od02char | N(2,0) | od02char |  |
od02zmpoh | N(1,0) | Zm.poh. | Změna hodnoty pohledávky | Změna hodnoty pohledávky
od02koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost odpisovaného majetku - zapsal | ODUDAL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost odpisovaného majetku - a její adresát | ODUDAL ad01id | 1,1 : 0,M | ADADSAT ad01id |
Událost odpisovaného majetku - a její obch.sel. | ODUDAL sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost odpisovaného majetku - a její org.sel. | ODUDAL sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost odpisovaného majetku - a její tech.věc.sel. | ODUDAL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost odpisovaného majetku - má druh artiklu | ODUDAL sp61id | 1,1 : 0,M | SPARTIKD sp61id |
Událost odpisovaného majetku - patří operaci procesu | ODUDAL sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost odpisovaného majetku - má typ operace | ODUDAL sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Událost odpisovaného majetku - má kartu | ODUDAL sp60id sp61id | 1,1 : 0,M | ODKARTA sp60id sp61id |
Událost - skladba - týká se operace | ODAHUD od02 | 1,1 : 0,M s rušením | ODUDAL od02 |

Indexy

Název | Primární | Výraz | Popis
ix_ODUDAL_od02 | P | od02 | Časová identifikace události.
ix_ODUDAL_od02datum |  | od02datum | Datum události
ix_ODUDAL_od02druh |  | od02druh | Druh události - Běžná, Úč.odpis, Daň.odpis, Tech.zhod.
ix_ODUDAL_od02text |  | od02text |
ix_ODUDAL_ad01id |  | ad01id | Identifikace adresáta
ix_ODUDAL_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_ODUDAL_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_ODUDAL_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_ODUDAL_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_ODUDAL_sp00datzap |  | sp00datzap | Datum a čas zápisu záznamu události
ix_ODUDAL_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_ODUDAL_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_ODUDAL_sp61id |  | sp61id | Identifikace druhu artiklu
ix_ODUDAL_sp60id |  | sp60id | Identifikace artiklu
ix_ODUDAL_spstatdu |  | sp69id, sp06idsubs |
ix_ODUDAL_sp69id |  | sp69id | Identifikace druhu události
ix_ODUDAL_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_ODUDAL_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_ODUDAL_adadsatx |  |  |


ODVYKON Výkon

Popis

Objektem typu ODVYKON je každý záznam, který obsahuje výkony, podle kterých se odepisuje evidovaný investiční majetek.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
od04datum | D | Datum | Datum, kdy byl evidovaný výkon proveden | Datum, kdy byl evidovaný výkon proveden
od01komp | N(1,0) | Komp. | Majetek souvisí s komponentou | Dělí evidovaný majetek na investiční majetek a pohledávky.
od01id | C(6) | Ident. | Identifikátor odpisovaného majetku | Identifikátor odpisovaného majetku
sp24idmj | C(3) | MJ | Identifikátor měrné jednotky | Identifikátor měrné jednotky
od04vykon | N(12,2) | Výkon | Výkon | Výkon
od04popvyk | C(40) | Text | Upřesňující text - poznámka | Upřesňující text - poznámka
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Výkon - má druh artiklu | ODVYKON sp61id | 1,1 : 0,M | SPARTIKD sp61id |
Výkon - zapsal uživatel | ODVYKON bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Výkon - ma artikl - pro RFI | ODVYKON sp60id sp61id | 1,1 : 0,M | ODKARTA sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_ODVYKON_odvykon | P | sp60id, sp61id, od04datum |
ix_ODVYKON_od04datum |  | od04datum | Datum, kdy byl evidovaný výkon proveden
ix_ODVYKON_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky
ix_ODVYKON_od04popvyk |  | od04popvyk | Upřesňující text - poznámka
ix_ODVYKON_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_ODVYKON_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_ODVYKON_sp61id |  | sp61id | Identifikace druhu artiklu


ODW1PROG Prognózování odpisů

Popis

Prognózování odpisů

Atributy

Atribut | Typ | Návěští | Message | Popis
uc37id | C(6) | Období | Identifikace účetního období | Identifikace účetního období
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
odw1pocodp | N(3,0) | odw1pocodp |  |
odw1zezvce | N(3,0) | odw1zezvce |  |
od01pc | N(20,4) | Pořiz. cena | Pořizovací cena - účetní | Účetní pořizovací cena inv.maj., nebo nesplacená část pohledávky.
od01zcu | N(20,4) | Zůst. cena | Zůstatková cena - účetní | Účetní zůstatková cena inv.maj., nebo neodepsaný zůstatek pohledávky.
od01vc | N(20,4) | Vstup.cena | Vstupní cena - daňová | Daňová vstupní cena inv.maj., nebo nesplacená část pohledávky.
od01zcd | N(20,4) | Zůst.cena | Zůstatková cena - daňová | Daňová zůstatková cena inv.maj., nebo neodepsaný zůstatek pohledávky.
odw1castk1 | N(20,4) | odw1castk1 |  |
odw1castk2 | N(20,4) | odw1castk2 |  |
od02koment | M | Poznámka | Poznámka | Poznámka
od02komenu | M | Poznámka k účetnímu odpisu | Poznámka k účetnímu odpisu | Poznámka k účetnímu odpisu

Indexy

Název | Primární | Výraz | Popis
ix_ODW1PROG_odw1prog | P | uc37id, sp61id, sp60id |
ix_ODW1PROG_odw1prog1 |  | sp61id, sp60id, uc37id | sp61id+sp60id
ix_ODW1PROG_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id


Tabulky OK...

OKAH | Aktuální hodnota xy
OKAHUD | Událost - skladba
OKARTIKL | Artikl obecné komponenty
OKUDALOS | Událost obecné komponenty
OKUMISTE | Umístění pro obecnou komponentu

Viz.také

OKAH Aktuální hodnota xy | OKAHUD Událost - skladba | OKARTIKL Artikl obecné komponenty | OKUDALOS Událost obecné komponenty | OKUMISTE Umístění pro obecnou komponentu


OKAH Aktuální hodnota xy

Popis

Objektem aktuální hodnota je každá sledovaná a vypočítavaná hodnota (údaj) vztahující se k libovolné
kombinaci artiklu, umístění a adresáta. V ideálním případě odpovídá aktuální hodnotě v reálném světě.
Obvyklé hodnoty jsou konečný stav a obrat ve finančním nebo naturálním vyjádření.
Př.: dle konkrétní komponenty
Název entity v každé komponentě je doplněn třetím slovem.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ok03id | C(6) | Umístění | Identifikace umístění pro obecnou komponentu | Identifikace umístění pro obecnou komponentu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
ok07hodnot | N(20,4) | Aktuální hodnota | Aktuální hodnota | Aktuální hodnota

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Aktuální hodnota xy - se týká druhu statistické informace | OKAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_OKAH_okah | P | sp60id, sp67id, ad01id, ok03id, sp61id, sp06idsubs |
ix_OKAH_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_OKAH_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_OKAH_ad01id |  | ad01id | Identifikace adresáta
ix_OKAH_ok03id |  | ok03id | Identifikace umístění pro obecnou komponentu
ix_OKAH_ok07hodnot |  | ok07hodnot | Aktuální hodnota
ix_OKAH_adadsatx |  |  |
ix_OKAH_spartiknx |  |  |


OKAHUD Událost - skladba

Popis

Tato vazba uvádí, které události se podílejí na skladbě aktuální hodnoty.
Má zejména servisní charakter pro fyzickou implementaci pro ovládání systému.
V LM je možné ztotožnění s objektem skladba aktuální hodnoty.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
ok01 | C(12) | ok01 | Jednoznačná časová identifikace události obecné komponenty | Jednoznačná časová identifikace události obecné komponenty
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp69id | C(6) | Druh | Identifikace druhu saldokontní hodnoty procesu | Identifikace druhu saldokontní hodnoty procesu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp74id | C(6) | sp74id | Umístění | Umístění
sp00datum | D | Datum | Datum události | Datum události
sp00text | C(40) | Popis | Popis události | Popis události
sp00hodnot | N(20,4) | Hodnota | Aktuální hodnota procesu |
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost - skladba - týká se operace | OKAHUD ok01 | 1,1 : 0,M s rušením | OKUDALOS ok01 |

Indexy

Název | Primární | Výraz | Popis
ix_OKAHUD_sp33hid |  | sp33hid | Časová identifikace hlavního procesu
ix_OKAHUD_ok01 |  | ok01 | Jednoznačná časová identifikace události obecné komponenty
ix_OKAHUD_sp69id |  | sp69id | Identifikace druhu saldokontní hodnoty procesu
ix_OKAHUD_ad01id |  | ad01id | Identifikace adresáta
ix_OKAHUD_sp74id |  | sp74id | Umístění
ix_OKAHUD_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_OKAHUD_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_OKAHUD_spahud |  | sp60id, sp61id, ad01id, sp74id, sp67id, sp06idsubs | Artikl+Aktér+Umístění+Druh hodnoty
ix_OKAHUD_spprcsal |  | sp33hid, sp69id, ad01id, sp60id, sp61id, sp74id | Primární index salda procesu


OKARTIKL Artikl obecné komponenty

Popis

Artikl obecné komponenty

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
ok02cenaj | N(7,2) | Cena | Cena za jednotku | Cena za jednotku
sp24idmj | C(3) | MJ | Identifikátor měrné jednotky | Identifikátor měrné jednotky
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
sp00uselar | C(9) | Účetní selektor artiklu | Účetní selektor artiklu | Účetní selektor artiklu
ok02cislo1 | N(20,4) | Volné číslo I | Volně použitelné číslo uživatelem | Volně použitelné číslo uživatelem
ok02cislo2 | N(20,4) | Volné číslo II | Volně použitelné číslo uživatelem | Volně použitelné číslo uživatelem
ok02cislo3 | N(20,4) | Volné číslo III | Volně použitelné číslo uživatelem | Volně použitelné číslo uživatelem
ok02text1 | C(40) | Volný text I | Volně použitelný text uživatelem | Volně použitelný text uživatelem
ok02text2 | C(40) | Volný text II | Volně použitelný text uživatelem | Volně použitelný text uživatelem
ok02text3 | C(40) | Volný text III | Volně použitelný text uživatelem | Volně použitelný text uživatelem

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Artikl obecné komponenty - v měrné jednotce | OKARTIKL sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Artikl obecné komponenty - je artiklem | OKARTIKL sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Artikl obecné komponenty - odpovídá tecnicko-věcnému selektoru | OKARTIKL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost obecné komponenty - souvisí s artiklem | OKUDALOS sp60id sp61id | 1,1 : 0,M | OKARTIKL sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_OKARTIKL_spartikl | P | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_OKARTIKL_okartiklx |  |  | Nepřímý index podle názvu artiklu
ix_OKARTIKL_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky
ix_OKARTIKL_sp60id |  | sp60id | Identifikace artiklu
ix_OKARTIKL_sp61id |  | sp61id | Identifikace druhu artiklu
ix_OKARTIKL_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_OKARTIKL_sp00uselar |  | sp00uselar | Účetní selektor artiklu


OKUDALOS Událost obecné komponenty

Popis

Událost obecné komponenty

Atributy

Atribut | Typ | Návěští | Message | Popis
ok01 | C(12) | ok01 | Jednoznačná časová identifikace události obecné komponenty | Jednoznačná časová identifikace události obecné komponenty
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
ok01datum | D | Datum | Datum | Datum
ok01text | C(40) | Popis | Popis události obecné komponenty | Popis události obecné komponenty
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ok03id | C(6) | Umístění | Identifikace umístění pro obecnou komponentu | Identifikace umístění pro obecnou komponentu
ok01mnozs | N(12,3) | Množství | Množství | Množství
ok01cena | N(12,3) | Celková cena | Celková cena | Celková cena
sp07privyd | N(1,0) | Příjem/Výdej | Příjem/Výdej, Závazek/Pohledávka .... | Příjem/Výdej
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
ok01vzucet | N(1,0) | Vztah ke statistice | Vztah ke statistice - náklady,výnosy,.... | Vztah ke statistice - náklady,výnosy,....
ok01privyd | N(1,0) | Příjem / výdej | Příznak příjem / výdej | Příznak příjem / výdej

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost obecné komponenty - souvisí s artiklem | OKUDALOS sp60id sp61id | 1,1 : 0,M | OKARTIKL sp60id sp61id |
Událost obecné komponenty - patří do fyzické operace | OKUDALOS sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost obecné komponenty - souvisí s adresátem | OKUDALOS ad01id | 1,1 : 0,M | ADADSAT ad01id |
Událost obecné komponenty - souvisí s artiklem | OKUDALOS ok03id | 1,1 : 0,M | OKUMISTE ok03id |
Událost obecné komponenty - má obchodní selektor | OKUDALOS sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost obecné komponenty - má organizační selektor | OKUDALOS sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost obecné komponenty - má technicko-věcný selektor | OKUDALOS sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost obecné komponenty - založil uživatel | OKUDALOS bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost - skladba - týká se operace | OKAHUD ok01 | 1,1 : 0,M s rušením | OKUDALOS ok01 |

Indexy

Název | Primární | Výraz | Popis
ix_OKUDALOS_ok01 | P | ok01 | Jednoznačná časová identifikace události obecné komponenty
ix_OKUDALOS_spprc |  | sp33cisd, sp33cisdpm, sp33cisdr | Identifikace procesu
ix_OKUDALOS_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_OKUDALOS_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_OKUDALOS_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_OKUDALOS_ok01datum |  | ok01datum | Datum
ix_OKUDALOS_ok01text |  | ok01text | Popis události obecné komponenty
ix_OKUDALOS_ad01id |  | ad01id | Identifikace adresáta
ix_OKUDALOS_ok03id |  | ok03id | Identifikace umístění pro obecnou komponentu
ix_OKUDALOS_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_OKUDALOS_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_OKUDALOS_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_OKUDALOS_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_OKUDALOS_sp00datzap |  | sp00datzap | Datum a čas zápisu záznamu události
ix_OKUDALOS_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_OKUDALOS_sp33cisdr |  | sp33cisdr | Rok řady čísla procesu
ix_OKUDALOS_sp61id |  | sp61id | Identifikace druhu artiklu
ix_OKUDALOS_spartiknx |  |  |
ix_OKUDALOS_adadsatx |  |  |


OKUMISTE Umístění pro obecnou komponentu

Popis

Umístění pro obecnou komponentu

Atributy

Atribut | Typ | Návěští | Message | Popis
ok03 | C(12) | ok03 | Jednoznačná časová identifikace umístění obecné komponenty | Jednoznačná časová identifikace umístění obecné komponenty
ok03id | C(6) | Umístění | Identifikace umístění pro obecnou komponentu | Identifikace umístění pro obecnou komponentu
ok03text | C(40) | Název umístění | Název umístění | Název umístění
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp00uselum | C(9) | Účetní selektor umístění | Účetní selektor umístění | Účetní selektor umístění

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Umístění pro obecnou komponentu - odpovídá organizačnímu selektoru | OKUMISTE sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost obecné komponenty - souvisí s artiklem | OKUDALOS ok03id | 1,1 : 0,M | OKUMISTE ok03id |

Indexy

Název | Primární | Výraz | Popis
ix_OKUMISTE_ok03 | U | ok03 | Jednoznačná časová identifikace umístění obecné komponenty
ix_OKUMISTE_ok03id | P | ok03id | Identifikace umístění pro obecnou komponentu
ix_OKUMISTE_ok03text |  | ok03text | Název umístění
ix_OKUMISTE_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.


Tabulky PA...

PAALGKOD | Kód algoritmu
PAALGOR | Algoritmus
PAALGVAZ | Souvislost algoritmu s algoritmem
PACISEL | Obecný číselník
PACISPOL | Položka obecného číselníku
PADRUPAR | Druh algoritmu/parametru
PAHODDEF | Popis pro zobrazení v přehledu hodnot
PAHODNOT | Hodnota parametru
PAOBJDRU | Klasifikace objektu
PAPARAM | Parametr
PAPARELE | Popis elementární hodnoty parametru
PASADA | Sada parametrů
PASADPAR | Parametr v sadě parametrů
PASYSKON | Systémová konstanta
PASYSSAD | Sada systémových konstat
PASYSVAL | Hodnota systémové konstanty
PASYVSAD | Popis verze sady konstant
PAVFFCPR | Záznam o spuštění vzdálené funkce
PAVFSASP | Nastavení automatického spuštění sady vzdálených funkcí

Viz.také

PADRUPAR Druh algoritmu/parametru | PAHODNOT Hodnota parametru | PAPARAM Parametr | PAPARELE Popis elementární hodnoty parametru | PASADA Sada parametrů | PASADPAR Parametr v sadě parametrů | PAALGKOD Kód algoritmu | PAALGOR Algoritmus | PAALGVAZ Souvislost algoritmu s algoritmem | PACISEL Obecný číselník | PACISPOL Položka obecného číselníku | PAOBJDRU Klasifikace objektu | PAHODDEF Popis pro zobrazení v přehledu hodnot | PASYSKON Systémová konstanta | PASYSSAD Sada systémových konstat | PASYSVAL Hodnota systémové konstanty | PASYVSAD Popis verze sady konstant | PAVFFCPR Záznam o spuštění vzdálené funkce | PAVFSASP Nastavení automatického spuštění sady vzdálených funkcí


PAALGKOD Kód algoritmu

Popis

Kód algoritmu

Atributy

Atribut | Typ | Návěští | Message | Popis
pa10id | C(12) | Algoritmus | Identifikátor algoritmu | Identifikátor algoritmu
pa11verze | C(6) | Verze | Číslo verze kódu algoritmu | Číslo verze kódu algoritmu
pa11popver | C(40) | Popis verze | Popis verze kódu | Popis verze kódu
pa11datum | D | Platnost | Datum platnosti od | Datum platnosti od
pa11datumd | D | do | Datum platnosti do | Datum platnosti do
pa11kod | M | Kód algorimu | Kód algorimu | Kód algorimu
pa11ceaucr | C(6) | pa11ceaucr | CRC kód certifikátu autora systému | CRC kód certifikátu autora systému
pa11ceaupd | C(50) | Cert.autora | Podpis certifikátu autora systému | Podpis certifikátu autora systému
pa11ceuzcr | C(6) | pa11ceuzcr | CRC kód certifikátu správce systému | CRC kód certifikátu správce systému
pa11ceuzpd | C(50) | Cert.správce | Podpis certifikátu správce systému | Podpis certifikátu správce systému
pa11koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Kód algoritmu - patří k algoritmu | PAALGKOD pa10id | 1,1 : 0,M | PAALGOR pa10id |

Indexy

Název | Primární | Výraz | Popis
ix_PAALGKOD_paalgkod | P | pa10id, pa11verze | PI - pa10id+pa11verze
ix_PAALGKOD_pa10id |  | pa10id | Identifikátor algoritmu


PAALGOR Algoritmus

Popis

Algoritmus

Atributy

Atribut | Typ | Návěští | Message | Popis
pa10id | C(12) | Algoritmus | Identifikátor algoritmu | Identifikátor algoritmu
pa10nazalg | C(40) | Název algoritmu | Název algoritmu | Název algoritmu
pa03id | C(6) | Druh | Identifikátoru druhu parametru | Identifikátoru druhu parametru
pa01id | C(6) | Sada | Identifikátor sady parametrů | Identifikátor sady parametrů
pa01oblast | C(2) | Oblast | Oblast sady parametrů | Oblast sady parametrů
pa10typ | N(1,0) | Typ kódu | Typ kódu | Typ kódu
pa10top | N(1,0) | Vrchol | Vrcholový algoritmus | Vrcholový algoritmus
pa10link | N(1,0) | Průchod | Způsob připojení v 1.průchod nebo 2.průchod nebo v oba průchody | Způsob připojení v 1.průchod nebo 2.průchod nebo v oba průchody
pa10ceaucr | C(6) | pa10ceaucr | CRC kód certifikátu autora systému | CRC kód certifikátu autora systému
pa10ceaupd | C(50) | Certifikát autora | Podpis certifikátu autora systému | Podpis certifikátu autora systému
pa10ceuzcr | C(6) | pa10ceuzcr | CRC kód certifikátu správce systému | CRC kód certifikátu správce systému
pa10ceuzpd | C(50) | Certifikát správce | Podpis certifikátu správce systému | Podpis certifikátu správce systému
pa10koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Algoritmus - je druhu | PAALGOR pa03id | 1,1 : 0,M | PADRUPAR pa03id |
Algoritmus - používá sadu parametrů | PAALGOR pa01id pa01oblast | 1,1 : 0,M | PASADA pa01id pa01oblast |
Kód algoritmu - patří k algoritmu | PAALGKOD pa10id | 1,1 : 0,M | PAALGOR pa10id |
Souvislost algoritmu s algoritmem - definuje 1.algoritmus | PAALGVAZ pa10id | 1,1 : 0,M | PAALGOR pa10id |
Souvislost algoritmu s algoritmem - definuje 2.algoritmus | PAALGVAZ pa10id2 | 1,1 : 0,M | PAALGOR pa10id |

Indexy

Název | Primární | Výraz | Popis
ix_PAALGOR_pa10id | P | pa10id | Identifikátor algoritmu
ix_PAALGOR_pa10nazalg |  | pa10nazalg | Název algoritmu
ix_PAALGOR_pa03id |  | pa03id | Identifikátoru druhu parametru
ix_PAALGOR_pasada |  | pa01id, pa01oblast | PI - pa01id+pa01oblast


PAALGVAZ Souvislost algoritmu s algoritmem

Popis

Souvislost algoritmu s algoritmem

Atributy

Atribut | Typ | Návěští | Message | Popis
pa10id | C(12) | Algoritmus | Identifikátor algoritmu | Identifikátor algoritmu
pa10id2 | C(12) | Algoritmus | Identifikátor algoritmu | Identifikátor algoritmu
pa12datum | D | Platnost | Datum platnosti od | Datum platnosti od
pa12datumd | D | do | Datum platnosti do | Datum platnosti do
pa12podmin | M | Podmínka připojení kódu | Podmínka připojení kódu | Podmínka připojení kódu
pa12koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Souvislost algoritmu s algoritmem - definuje 1.algoritmus | PAALGVAZ pa10id | 1,1 : 0,M | PAALGOR pa10id |
Souvislost algoritmu s algoritmem - definuje 2.algoritmus | PAALGVAZ pa10id2 | 1,1 : 0,M | PAALGOR pa10id |

Indexy

Název | Primární | Výraz | Popis
ix_PAALGVAZ_paalgvaz | P | pa10id, pa10id2 | PI - pa10id+pa10id2
ix_PAALGVAZ_pa10id |  | pa10id | Identifikátor algoritmu
ix_PAALGVAZ_pa10id2 |  | pa10id2 | Identifikátor algoritmu


PACISEL Obecný číselník

Popis

Obecný číselník

Atributy

Atribut | Typ | Návěští | Message | Popis
pa07id | C(6) | Číselník | Identifikace číselníku | Identifikace číselníku
pa07nazcis | C(40) | Název číselníku | Název číselníku | Název číselníku
pa07koment | M | Poznámka | Poznámka | Poznámka
pa07n1lb | M | Label N1 | Label numerické hodnoty 1 | Label numerické hodnoty 1
pa07n2lb | M | Label N2 | Label numerické hodnoty 2 | Label numerické hodnoty 2
pa07t1lb | M | Label T1 | Label textové hodnoty 1 | Label textové hodnoty 1
pa07t2lb | M | Label T2 | Label textové hodnoty 2 | Label textové hodnoty 2
pa07n1st | M | Stav.ř. N1 | Stavový řádek numerické hodnoty 1 | Stavový řádek numerické hodnoty 1
pa07n2st | M | Stav.ř. N2 | Stavový řádek numerické hodnoty 2 | Stavový řádek numerické hodnoty 2
pa07t1st | M | Stav.ř. T1 | Stavový řádek textové hodnoty 1 | Stavový řádek textové hodnoty 1
pa07t2st | M | Stav.ř. T2 | Stavový řádek textové hodnoty 2 | Stavový řádek textové hodnoty 2
pa07idlb | M | Label ID | Label identifikátoru položky číselníku | Label identifikátoru položky číselníku
pa07nzlb | M | Label NZ | Label názvu položky číselníku | Label názvu položky číselníku

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametr - používá číselník | PAPARAM pa07id | 1,1 : 0,M | PACISEL pa07id |
Položka obecného číselníku - má položky | PACISPOL pa07id | 1,1 : 0,M | PACISEL pa07id |

Indexy

Název | Primární | Výraz | Popis
ix_PACISEL_pa07id | P | pa07id | Identifikace číselníku
ix_PACISEL_pa07nazcis |  | pa07nazcis | Název číselníku


PACISPOL Položka obecného číselníku

Popis

Položka obecného číselníku

Atributy

Atribut | Typ | Návěští | Message | Popis
pa08id | C(10) | ID | Identifikace položky číselníku | Identifikace položky číselníku
pa07id | C(6) | Číselník | Identifikace číselníku | Identifikace číselníku
pa08nazpol | C(40) | Název položky číselníku | Název položky číselníku | Název položky číselníku
pa08koment | M | Poznámka | Poznámka | Poznámka
pa08num1 | N(20,4) | Num1 | Pomocná numerická hodnota 1 | Pomocná numerická hodnota 1
pa08num2 | N(20,4) | Num2 | Pomocná numerická hodnota 2 | Pomocná numerická hodnota 2
pa08text1 | C(40) | Text 1 | Pomocná textová hodnota 1 | Pomocná textová hodnota 1
pa08text2 | C(40) | Text 2 | Pomocná textová hodnota 2 | Pomocná textová hodnota 2

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Položka obecného číselníku - má položky | PACISPOL pa07id | 1,1 : 0,M | PACISEL pa07id |
Hodnota parametru - má hodnotu položky obecného číselníku | PAHODNOT pa08id | 1,1 : 0,M | PACISPOL pa08id |

Indexy

Název | Primární | Výraz | Popis
ix_PACISPOL_pa08id | P | pa08id | Identifikace položky číselníku
ix_PACISPOL_pa07id |  | pa07id | Identifikace číselníku
ix_PACISPOL_pa08nazpol |  | pa08nazpol | Název položky číselníku


PADRUPAR Druh algoritmu/parametru

Popis

Druh parametru

Atributy

Atribut | Typ | Návěští | Message | Popis
pa03id | C(6) | Druh | Identifikátoru druhu parametru | Identifikátoru druhu parametru
pa03nazdru | C(40) | Název druhu | Název druhu parametru | Název druhu parametru
pa03koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametr - je druhu | PAPARAM pa03id | 1,1 : 0,M | PADRUPAR pa03id |
Popis elementární hodnoty parametru - je druhu | PAPARELE pa03id | 1,1 : 0,M | PADRUPAR pa03id |
Algoritmus - je druhu | PAALGOR pa03id | 1,1 : 0,M | PADRUPAR pa03id |
Sada systémových konstat - je druhu | PASYSSAD pa03id | 1,1 : 0,M | PADRUPAR pa03id |
Systémová konstanta - je druhu | PASYSKON pa03id | 1,1 : 0,M | PADRUPAR pa03id |

Indexy

Název | Primární | Výraz | Popis
ix_PADRUPAR_pa03id | P | pa03id | Identifikátoru druhu parametru
ix_PADRUPAR_pa03nazdru |  | pa03nazdru | Název druhu parametru


PAHODDEF Popis pro zobrazení v přehledu hodnot

Popis

Popis pro zobrazení v přehledu hodnot

Atributy

Atribut | Typ | Návěští | Message | Popis
pa01oblast | C(2) | Oblast | Oblast sady parametrů | Oblast sady parametrů
pa15nazpop | C(40) | Popis | Popis pro zobrazení v přehledu hodnot | Popis pro zobrazení v přehledu hodnot
pa15defide | M | Výraz identifikace | Výraz pro zobrazení identifikace objektu v syntaxi SQL Anywhere | Výraz pro zobrazení identifikace objektu v syntaxi SQL Anywhere
pa15deftxt | M | Výraz popisu | Výraz pro zobrazení popisu objektu v syntaxi SQL Anywhere | Výraz pro zobrazení popisu objektu v syntaxi SQL Anywhere
pa15defmem | M | Výraz poznámky | Výraz pro zobrazení poznámky objektu v syntaxi SQL Anywhere | Výraz pro zobrazení poznámky objektu v syntaxi SQL Anywhere
pa15koment | M | Poznámka | Poznámka | Poznámka

Indexy

Název | Primární | Výraz | Popis
ix_PAHODDEF_pa01oblast | P | pa01oblast | Oblast sady parametrů
ix_PAHODDEF_pa15nazpop |  | pa15nazpop | Popis pro zobrazení v přehledu hodnot


PAHODNOT Hodnota parametru

Popis

Hodnota parametru

Atributy

Atribut | Typ | Návěští | Message | Popis
bw09inst1 | C(12) | bw09inst1 | Jednoznačný časový identifikátor instance objektu typu 1. |
bw09typ1 | C(2) | bw09typ1 | Identifikátor typu objektu 1. | Typ objektu
pa02id | C(6) | Parametr | Identifikátor parametru | Identifikátor parametru
pa01oblast | C(2) | Oblast | Oblast sady parametrů | Oblast sady parametrů
pa06index | N(5,0) | pa06index | Pořadové číslo záznamu vzhledem k objektu | Pořadové číslo záznamu vzhledem k objektu
pa06 | C(12) | pa06 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
pa08id | C(10) | ID | Identifikace položky číselníku | Identifikace položky číselníku
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
ad03cisban | C(2) | Účet | Identifikátor spojení na bankovní účet adresáta. | Číslo spojení na bankovní účet adresáta. *** Dříve CISBANK.
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
pa06datum | D | Platnost od | Platnost od | Platnost od
pa06datumd | D | do | Platnost do | Platnost do
pa06text1 | C(60) | Text1 | Textová elementární hodnota | Textová elementární hodnota
pa06num1 | N(20,4) | Num1 | Numerická elementární hodnota 1 | Numerická elementární hodnota 1
pa06num2 | N(20,4) | Num2 | Numerická elementární hodnota 2 | Numerická elementární hodnota 2
pa06dat1 | D | Dat1 | Datumová elementární hodnota 1 | Datumová elementární hodnota 1
pa06dat2 | D | Dat2 | Datumová elementární hodnota 2 | Datumová elementární hodnota 2
pa06cmb1 | N(1,0) | Cmb1 | Překryvný seznam elementární hodnota 1 | Překryvný seznam elementární hodnota 1
pa06cmb2 | N(1,0) | Cmb2 | Překryvný seznam elementární hodnota 2 | Překryvný seznam elementární hodnota 2
pa06koment | M | Poznámka | Poznámka |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Hodnota parametru - definuje spojení | PAHODNOT ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Hodnota parametru - definuje bankovní účet | PAHODNOT ad01id ad03cisban | 0,1 : 0,M | ADBUCTY ad01id ad03cisban |
Hodnota parametru - je hodnotou parametru | PAHODNOT pa02id pa01oblast | 1,1 : 0,M s rušením | PAPARAM pa02id pa01oblast |
Hodnota parametru - definuje adresata | PAHODNOT ad01id | 1,1 : 0,M | ADADSAT ad01id |
Hodnota parametru - má hodnotu položky obecného číselníku | PAHODNOT pa08id | 1,1 : 0,M | PACISPOL pa08id |
Hodnota parametru - se vztahuje k artiklu | PAHODNOT sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_PAHODNOT_pahodnot | P | bw09inst1, bw09typ1, pa02id, pa01oblast, pa06index | PI - BW09K1+PAPARAM+pa06index
ix_PAHODNOT_bw09k1 |  | bw09inst1, bw09typ1 |
ix_PAHODNOT_paparam |  | pa02id, pa01oblast | PI - pa02id+pa02oblast
ix_PAHODNOT_pa01oblast |  | pa01oblast | Oblast sady parametrů
ix_PAHODNOT_pa08id |  | pa08id | Identifikace položky číselníku
ix_PAHODNOT_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_PAHODNOT_adbucty1 |  | ad01id, ad03cisban | ad01id+ad03cisban
ix_PAHODNOT_ad01id |  | ad01id | Identifikace adresáta
ix_PAHODNOT_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_PAHODNOT_bw09inst1 |  | bw09inst1 |
ix_PAHODNOT_pahodnotx1 |  |  | IX - Identifikace objektu
ix_PAHODNOT_pahodnotx2 |  |  | IX - Popis objektu
ix_PAHODNOT_mzkartax1 |  |  | IX - mz01id
ix_PAHODNOT_mzkartax2 |  |  | IX - mz01prijme


PAOBJDRU Klasifikace objektu

Popis

Klasifikace objektu

Atributy

Atribut | Typ | Návěští | Message | Popis
pa13id | C(12) | Klasifikace | Identifikace klasifikace objektu | Identifikace klasifikace objektu
bw55objec | C(2) | Identifikace objektu BM | Identifikace objektu BM | Identifikace objektu BM
pa01id | C(6) | Sada | Identifikátor sady parametrů | Identifikátor sady parametrů
pa01oblast | C(2) | Oblast | Oblast sady parametrů | Oblast sady parametrů
pa13 | C(12) | pa13 | Jednoznačná identifikace | Jednoznačná identifikace
pa13nazdru | C(40) | Název klasifikace objektu | Název klasifikace objektu | Název klasifikace objektu
pa13koment | M | Poznámka | Poznámka | Poznámka
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
pa13datum | D | Platnost od | Datum platnosti od | Datum platnosti od
pa13datumd | D | do | Datum platnosti do | Datum platnosti do

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Klasifikace objektu - používá sadu parametrů | PAOBJDRU pa01id pa01oblast | 1,1 : 0,M | PASADA pa01id pa01oblast |
Klasifikace objektu - naposledy změnil popis uživatel | PAOBJDRU bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Položka smlouvy - je druhu objektu | NKSMLOUV pa13id bw55objec | 1,1 : 0,M | PAOBJDRU pa13id bw55objec |
Projektový úkol - má klasifikaci | NKUKOL pa13id bw55objec | 1,1 : 0,M | PAOBJDRU pa13id bw55objec |
Druh projektového úkolu - předplňuje klasifikaci projektového úkolu | NKUKOLD pa13id bw55objec | 1,1 : 0,M | PAOBJDRU pa13id bw55objec |
Kategorie pošty - určuje klasifikaci objektu pošty | POPOPPO pa13id bw55objec | 1,1 : 0,M | PAOBJDRU pa13id bw55objec |
Obchodovatelný artikl - předplňuje klasifikaci na událost obchodu | OBARTIKL pa13id bw55objec | 1,1 : 0,M | PAOBJDRU pa13id bw55objec |
Obchodovatelný artikl - má klasifikaci artiklu | OBARTIKL pa13idart bw55objeca | 1,1 : 0,M | PAOBJDRU pa13id bw55objec |
Druh artiklu - předplňuje klasifikaci objektu artiklu | SPARTIKD pa13idart bw55objeca | 1,1 : 0,M | PAOBJDRU pa13id bw55objec |
Událost obchodního plnění - je druhu objektu | OBUDAL pa13id bw55objec | 1,1 : 0,M | PAOBJDRU pa13id bw55objec |

Indexy

Název | Primární | Výraz | Popis
ix_PAOBJDRU_paobjdru | P | pa13id, bw55objec | PI - pa13id+bw55objec
ix_PAOBJDRU_pasada |  | pa01id, pa01oblast | PI - pa01id+pa01oblast
ix_PAOBJDRU_pa13id |  | pa13id | Identifikace klasifikace objektu
ix_PAOBJDRU_pa13 |  | pa13 | Jednoznačná identifikace
ix_PAOBJDRU_pa13nazdru |  | pa13nazdru | Název klasifikace objektu
ix_PAOBJDRU_bw01uziv |  | bw01uziv | Identifikace uživatele systému


PAPARAM Parametr

Popis

Parametr

Atributy

Atribut | Typ | Návěští | Message | Popis
pa02id | C(6) | Parametr | Identifikátor parametru | Identifikátor parametru
pa01oblast | C(2) | Oblast | Oblast sady parametrů | Oblast sady parametrů
pa03id | C(6) | Druh | Identifikátoru druhu parametru | Identifikátoru druhu parametru
pa02nazpar | C(40) | Název parametru | Název parametru | Název parametru
pa07id | C(6) | Číselník | Identifikace číselníku | Identifikace číselníku
pa02vyraz | M | Výraz | Výraz zobrazení v mřížce | Výraz zobrazení v mřížce
pa02koment | M | Poznámka | Poznámka | Poznámka
pa02period | N(5,0) | Perioda platnosti | Inicializace data platnosti hodnoty parametru do ve měsících | Inicializace data platnosti hodnoty parametru do ve měsících

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametr - je druhu | PAPARAM pa03id | 1,1 : 0,M | PADRUPAR pa03id |
Parametr - používá číselník | PAPARAM pa07id | 1,1 : 0,M | PACISEL pa07id |
Parametr v sadě parametrů - je parametrem | PASADPAR pa02id pa01oblast | 1,1 : 0,M | PAPARAM pa02id pa01oblast |
Popis elementární hodnoty parametru - patří k parametru | PAPARELE pa02id pa01oblast | 1,1 : 0,M s rušením | PAPARAM pa02id pa01oblast |
Hodnota parametru - je hodnotou parametru | PAHODNOT pa02id pa01oblast | 1,1 : 0,M s rušením | PAPARAM pa02id pa01oblast |

Indexy

Název | Primární | Výraz | Popis
ix_PAPARAM_paparam | P | pa02id, pa01oblast | PI - pa02id+pa02oblast
ix_PAPARAM_pa03id |  | pa03id | Identifikátoru druhu parametru
ix_PAPARAM_pa02nazpar |  | pa02nazpar | Název parametru
ix_PAPARAM_pa07id |  | pa07id | Identifikace číselníku


PAPARELE Popis elementární hodnoty parametru

Popis

Popis elementární hodnoty parametru

Atributy

Atribut | Typ | Návěští | Message | Popis
pa05id | C(10) | E.hodnota | Identifikace elementární hodnoty parametru | Identifikace elementární hodnoty parametru
pa02id | C(6) | Parametr | Identifikátor parametru | Identifikátor parametru
pa01oblast | C(2) | Oblast | Oblast sady parametrů | Oblast sady parametrů
pa05label | M | Návěští | Návěští | Návěští
pa05status | M | Stav.ř. | Stavový řádek | Stavový řádek
pa05delka | N(3,0) | Délka | Délka | Délka
pa05deseti | N(1,0) | Počet desetin | Počet desetin | Počet desetin
pa05init | M | Inicializace | Inicializace | Inicializace
pa05valid | M | Validace | Výraz validace | Výraz validace
pa05errmes | M | Hlášení | Chybové hlášení | Chybové hlášení
pa05pict | M | Zobrazení | Zobrazení | Zobrazení
pa03id | C(6) | Druh | Identifikátoru druhu parametru | Identifikátoru druhu parametru
pa05script | M | pa05script | Script provedený po validaci elementární hodnoty | Script provedený po validaci elementární hodnoty
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis elementární hodnoty parametru - patří k parametru | PAPARELE pa02id pa01oblast | 1,1 : 0,M s rušením | PAPARAM pa02id pa01oblast |
Popis elementární hodnoty parametru - je druhu | PAPARELE pa03id | 1,1 : 0,M | PADRUPAR pa03id |

Indexy

Název | Primární | Výraz | Popis
ix_PAPARELE_paparele | P | pa05id, pa02id, pa01oblast | PI - pa05id+PAPARAM
ix_PAPARELE_paparam |  | pa02id, pa01oblast | PI - pa02id+pa02oblast
ix_PAPARELE_pa03id |  | pa03id | Identifikátoru druhu parametru


PASADA Sada parametrů

Popis

Sada parametrů

Atributy

Atribut | Typ | Návěští | Message | Popis
pa01id | C(6) | Sada | Identifikátor sady parametrů | Identifikátor sady parametrů
pa01oblast | C(2) | Oblast | Oblast sady parametrů | Oblast sady parametrů
pa01nazsad | C(40) | Název sady | Název sady parametrů | Název sady parametrů
pa01koment | M | Poznámka | Poznámka | Poznámka
pa01aktual | N(1,0) | Aktuální | Aktuální sada parametrů | Aktuální sada parametrů

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Projektový úkol - používá sadu parametrů | NKUKOL pa01id pa01oblast | 1,1 : 0,M | PASADA pa01id pa01oblast |
Druh projektového úkolu - předplňuje sadu parametrů pro projektový úkol | NKUKOLD pa01id pa01oblast | 1,1 : 0,M | PASADA pa01id pa01oblast |
Parametr v sadě parametrů - patří do sady parametrů | PASADPAR pa01id pa01oblast | 1,1 : 0,M s rušením | PASADA pa01id pa01oblast |
Algoritmus - používá sadu parametrů | PAALGOR pa01id pa01oblast | 1,1 : 0,M | PASADA pa01id pa01oblast |
Klasifikace objektu - používá sadu parametrů | PAOBJDRU pa01id pa01oblast | 1,1 : 0,M | PASADA pa01id pa01oblast |
Vztah obchodovatelného artiklu a adresáta - používá sadu parametrů | OBARTADR pa01id pa01oblast | 1,1 : 0,M | PASADA pa01id pa01oblast |
Kategorie pošty - určuje sadu parametrů poštovní zásilky | POPOPPO pa01id pa01oblast | 1,1 : 0,M | PASADA pa01id pa01oblast |
Parametry - defininují užití sady parametrů | MZPARAM pa01id pa01oblast | 1,1 : 0,M | PASADA pa01id pa01oblast |
Pracovní funkce - skutečné a typové - používá sadu parametrů | MZPRACFU pa01id pa01oblast | 1,1 : 0,M | PASADA pa01id pa01oblast |

Indexy

Název | Primární | Výraz | Popis
ix_PASADA_pasada | P | pa01id, pa01oblast | PI - pa01id+pa01oblast
ix_PASADA_pa01id |  | pa01id | Identifikátor sady parametrů
ix_PASADA_pa01oblast |  | pa01oblast | Oblast sady parametrů
ix_PASADA_pa01nazsad |  | pa01nazsad | Název sady parametrů


PASADPAR Parametr v sadě parametrů

Popis

Parametr v sadě parametrů

Atributy

Atribut | Typ | Návěští | Message | Popis
pa01id | C(6) | Sada | Identifikátor sady parametrů | Identifikátor sady parametrů
pa02id | C(6) | Parametr | Identifikátor parametru | Identifikátor parametru
pa01oblast | C(2) | Oblast | Oblast sady parametrů | Oblast sady parametrů
pa04porad | N(4,0) | Pořadí | Pořadí parametru | Pořadí parametru
pa04kardin | N(1,0) | Výskyt parametru | Výskyt parametru | Výskyt parametru

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametr v sadě parametrů - patří do sady parametrů | PASADPAR pa01id pa01oblast | 1,1 : 0,M s rušením | PASADA pa01id pa01oblast |
Parametr v sadě parametrů - je parametrem | PASADPAR pa02id pa01oblast | 1,1 : 0,M | PAPARAM pa02id pa01oblast |

Indexy

Název | Primární | Výraz | Popis
ix_PASADPAR_pasadpar | P | pa01id, pa02id, pa01oblast | PI - pa01id+pa01oblast+pa02id
ix_PASADPAR_paparam |  | pa02id, pa01oblast | PI - pa02id+pa02oblast
ix_PASADPAR_pasada |  | pa01id, pa01oblast | PI - pa01id+pa01oblast


PASYSKON Systémová konstanta

Popis

Systémová konstanta

Atributy

Atribut | Typ | Návěští | Message | Popis
pa17id | C(6) | Sada | Identifikace sady systémových konstant | Identifikace sady systémových konstant
pa18id | C(10) | Konstanta | Identifikátor systémové konstanty | Identifikátor systémové konstanty
pa03id | C(6) | Druh | Identifikátoru druhu parametru | Identifikátoru druhu parametru
pa18nazkon | C(40) | Název konstanty | Název konstanty | Název konstanty
pa18typ | N(1,0) | Typ | Typ systémové konstanty Text / Číslo / Datum | Typ systémové konstanty Text / Číslo / Datum
pa18delka | N(2,0) | Délka | Délka hodnoty konstanty | Délka hodnoty konstanty
pa18deseti | N(2,0) | Desetiny | Počet desetin hodnoty konstanty | Počet desetin hodnoty konstanty
pa18koment | M | Poznámka | Poznámka | Poznámka
pa18porad | N(3,0) | Pořadí | Pořadí zobrazení konstanty | Pořadí zobrazení konstanty
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace
pa18platod | D | Platnost | Platnost výskytu systémové konstanty od | Platnost systémové konstanty od
pa18platdo | D | do | Platnost výskytu systémové konstanty do | Platnost systémové konstanty do
pa18specif | N(1,0) | Specifická | Nastavení Specifická=Ano, označuje konstanty, které jsou hodnotou specifické pro různé subjekty (jejich hodnoty se nemají přenášet balíčkem) | Nastavení Specifická=Ano, označuje konstanty, které jsou hodnotou specifické pro různé subjekty (jejich hodnoty se nemají přenášet balíčkem)

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Systémová konstanta - patří do sady konstat | PASYSKON pa17id | 1,1 : 0,M | PASYSSAD pa17id |
Systémová konstanta - je druhu | PASYSKON pa03id | 1,1 : 0,M | PADRUPAR pa03id |
Hodnota systémové konstanty - je hodnotou konstanty | PASYSVAL pa17id pa18id | 1,1 : 0,M | PASYSKON pa17id pa18id |

Indexy

Název | Primární | Výraz | Popis
ix_PASYSKON_pasyskon | P | pa17id, pa18id | PI - pa17id+pa18id
ix_PASYSKON_pa17id |  | pa17id | Identifikace sady systémových konstant
ix_PASYSKON_pa03id |  | pa03id | Identifikátoru druhu parametru


PASYSSAD Sada systémových konstat

Popis

Sada systémových konstat

Atributy

Atribut | Typ | Návěští | Message | Popis
pa17id | C(6) | Sada | Identifikace sady systémových konstant | Identifikace sady systémových konstant
pa03id | C(6) | Druh | Identifikátoru druhu parametru | Identifikátoru druhu parametru
pa17nazsad | C(40) | Název sady | Název sady systémových konstant | Název sady systémových konstant
pa17koment | M | Poznámka | Poznámka | Poznámka
pa17verze | N(8,3) | Verze | Verze sady systémových konstant | Verze sady systémových konstant
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace
sp00jmeakt | C(40) | Změnil | Jméno uživatele systému, který změnil záznam | Jméno uživatele systému, který změnil záznam

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Sada systémových konstat - je druhu | PASYSSAD pa03id | 1,1 : 0,M | PADRUPAR pa03id |
Systémová konstanta - patří do sady konstat | PASYSKON pa17id | 1,1 : 0,M | PASYSSAD pa17id |
Korektor transformovaných dat - používá sadu paramterů | SPKOREK pa17id | 1,1 : 0,M | PASYSSAD pa17id |
Popis verze sady konstant - je popisem verze sady konstant | PASYVSAD pa17id | 1,1 : 0,M | PASYSSAD pa17id |

Indexy

Název | Primární | Výraz | Popis
ix_PASYSSAD_pa17id | P | pa17id | Identifikace sady systémových konstant
ix_PASYSSAD_pa03id |  | pa03id | Identifikátoru druhu parametru
ix_PASYSSAD_pa17nazsad |  | pa17nazsad | Název sady systémových konstant
ix_PASYSSAD_pa17verze |  | pa17verze | Verze sady systémových konstant
ix_PASYSSAD_sp00datakt |  | sp00datakt | Datum aktualizace


PASYSVAL Hodnota systémové konstanty

Popis

Hodnota systémové konstanty

Atributy

Atribut | Typ | Návěští | Message | Popis
pa17id | C(6) | Sada | Identifikace sady systémových konstant | Identifikace sady systémových konstant
pa18id | C(10) | Konstanta | Identifikátor systémové konstanty | Identifikátor systémové konstanty
pa19platod | D | Platnost | Platnost od | Platnost od
pa19num | N(20,6) | Hodnota - číslo | Hodnota konstanty - číslo | Hodnota konstanty - číslo
pa19text | C(40) | pa19text | Hodnota konstanty - text | Hodnota konstanty - text
pa19dat | D | pa19dat | Hodnota konstanty - datum | Hodnota konstanty - datum
pa19koment | M | Poznámka | Poznámka | Poznámka
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Hodnota systémové konstanty - je hodnotou konstanty | PASYSVAL pa17id pa18id | 1,1 : 0,M | PASYSKON pa17id pa18id |

Indexy

Název | Primární | Výraz | Popis
ix_PASYSVAL_pasysval | P | pa17id, pa18id, pa19platod | PI - PASYSKON+pa19platod
ix_PASYSVAL_pasyskon |  | pa17id, pa18id | PI - pa17id+pa18id
ix_PASYSVAL_sp00datakt |  | sp00datakt | Datum aktualizace


PASYVSAD Popis verze sady konstant

Popis

Popis verze sady konstant

Atributy

Atribut | Typ | Návěští | Message | Popis
pa17id | C(6) | Sada | Identifikace sady systémových konstant | Identifikace sady systémových konstant
pa17verze | N(8,3) | Verze | Verze sady systémových konstant | Verze sady systémových konstant
pa27dne | D | Dne | Datum záznamu o verzi | Datum záznamu o verzi
sp00jmeakt | C(40) | Změnil | Jméno uživatele systému, který změnil záznam | Jméno uživatele systému, který změnil záznam
pa27koment | M | Popis | Popis verze | Popis verze
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis verze sady konstant - je popisem verze sady konstant | PASYVSAD pa17id | 1,1 : 0,M | PASYSSAD pa17id |

Indexy

Název | Primární | Výraz | Popis
ix_PASYVSAD_pasyvsad | P | pa17id, pa17verze | PI - pa17id+pa17verze
ix_PASYVSAD_pa17id |  | pa17id | Identifikace sady systémových konstant


PAVFFCPR Záznam o spuštění vzdálené funkce

Popis

Záznam o spuštění vzdálené funkce

Atributy

Atribut | Typ | Návěští | Message | Popis
pa26 | C(12) | pa26 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
pa22id | C(6) | Funkce | Identifikátor vzdálené funkce | Identifikátor vzdálené funkce
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
pa26dne | T | Dne | Datum a čas spuštění vzdálené funkce | Datum a čas spuštění vzdálené funkce
pa26stav | N(1,0) | Výsledek | Výsledek spuštění funkce | Výsledek spuštění funkce
pa26koment | M | Poznámka k výsledku | Poznámka k výsledku | Poznámka
pa22akt | T | Aktualizace | Datum aktualizace kódu funkce pro Ostrý provoz | Datum aktualizace kódu funkce - Ostrý provoz

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Záznam o spuštění vzdálené funkce - je záznamem uživatele | PAVFFCPR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_PAVFFCPR_pa26 | P | pa26 | Jednoznačná časová identifikace
ix_PAVFFCPR_pa22id |  | pa22id | Identifikátor vzdálené funkce
ix_PAVFFCPR_bw01uziv |  | bw01uziv | Identifikace uživatele systému


PAVFSASP Nastavení automatického spuštění sady vzdálených funkcí

Popis

Nastavení automatického spuštění sady vzdálených funkcí

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw05ident | C(6) | Skupina | Identifikace skupiny uživatelů | Identifikace skupiny uživatelů
pa28spust | N(1,0) | Spustit | Spustit sadu vzdálených funkcí | Spustit sadu vzdálených funkcí
pa28period | N(1,0) | Perioda | Spustit sadu vzdálených funkcí pokaždé nebo jednou denně | Spustit sadu vzdálených funkcí pokaždé nebo jednou denně
pa28impbal | N(1,0) | Balíčky | Automaticky importovat balíček při spuštění sady vzdálených funkcí | Automaticky importovat balíček při spuštění sady vzdálených funkcí
pa28spufrm | N(1,0) | Po chybě | Zobrazit formulář sady vzdálených funkcí | Zobrazit formulář sady vzdálených funkcí
pa28koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Nastavení automatického spuštění sady vzdálených funkcí - platí pro skupinu uživatelů | PAVFSASP bw05ident | 1,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_PAVFSASP_pavfsasp | P | bw02krok, bw05ident | PI - bw02krok+bw05ident
ix_PAVFSASP_bw02krok |  | bw02krok | Identifikace činnosti
ix_PAVFSASP_bw05ident |  | bw05ident | Identifikace skupiny uživatelů


Tabulky PL...

PLAH | Aktuální hodnota plateb
PLAHR | Aktuální hodnota plateb (replikovaná)
PLAHUD | Událost - skladba
PLPAROPE | Parametry komponenty platby pro druh operace
PLPLOD | Vazba mezi platbou a kartou odpisu,opravné položky aktiva
PLPLVYM | Vazba mezi platbou a vymáháním
PLPRIU | Příkaz k úhradě
PLPRIUP | Řádek příkazu k úhradě
PLUDA | Událost plateb
PLUMIST | Umístění plateb
PLUP | Účet/pokladna (vlastní)

Viz.také

PLAH Aktuální hodnota plateb | PLAHR Aktuální hodnota plateb (replikovaná) | PLAHUD Událost - skladba | PLPAROPE Parametry komponenty platby pro druh operace | PLPLOD Vazba mezi platbou a kartou odpisu,opravné položky aktiva | PLPLVYM Vazba mezi platbou a vymáháním | PLPRIU Příkaz k úhradě | PLPRIUP Řádek příkazu k úhradě | PLUDA Událost plateb | PLUMIST Umístění plateb | PLUP Účet/pokladna (vlastní)


PLAH Aktuální hodnota plateb

Popis

Aktuální hodnota plateb

Atributy

Atribut | Typ | Návěští | Message | Popis
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
pl08id | C(6) | Umístění - platby | Umístění - platby | Umístění - platby
ad01id | C(6) | Adresát | Adresát | Identifikace adresáta
pl02hodnot | N(20,4) | pl02hodnot |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Aktuální hodnota plateb - se týká druhu statistické informace | PLAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_PLAH_plah | P | sp67id, sp06idsubs, pl08id, ad01id |
ix_PLAH_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_PLAH_ad01id |  | ad01id | Identifikace adresáta
ix_PLAH_pl08id |  | pl08id | Umístění - platby
ix_PLAH_pl02hodnot |  | pl02hodnot |
ix_PLAH_adadsatx |  |  |


PLAHR Aktuální hodnota plateb (replikovaná)

Popis

Aktuální hodnota plateb (replikovaná)

Atributy

Atribut | Typ | Návěští | Message | Popis
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
pl08id | C(6) | Umístění - platby | Umístění - platby | Umístění - platby
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
pl02hodnot | N(20,4) | pl02hodnot |  |

Indexy

Název | Primární | Výraz | Popis
ix_PLAHR_plah | P | sp67id, sp06idsubs, pl08id, ad01id |


PLAHUD Událost - skladba

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
pl02 | C(12) | pl02 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ad01id | C(6) | Adresát | Adresát | Identifikace adresáta
sp74id | C(6) | Umístění | Umístění | Umístění
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp00datum | D | Datum | Datum události | Datum události
sp00text | C(40) | Popis | Popis události | Popis události
sp00hodnot | N(20,4) | Hodnota | Aktuální hodnota procesu |
pl08id | C(6) | Umístění - platby | Umístění - platby | Umístění - platby

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost - skladba - týká se adresáta | PLAHUD ad01id | 0,1 : 0,M | ADADSAT ad01id |
Událost - skladba - týká se druhu hodnoty | PLAHUD sp67id sp06idsubs | 0,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Událost - skladba - týká se operace | PLAHUD pl02 | 1,1 : 0,M s rušením | PLUDA pl02 |

Indexy

Název | Primární | Výraz | Popis
ix_PLAHUD_sp33hid |  | sp33hid | Časová identifikace hlavního procesu
ix_PLAHUD_pl02 |  | pl02 | Jednoznačná časová identifikace
ix_PLAHUD_ad01id |  | ad01id | Identifikace adresáta
ix_PLAHUD_sp74id |  | sp74id | Umístění
ix_PLAHUD_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace


PLPAROPE Parametry komponenty platby pro druh operace

Popis

Parametry komponenty platby pro druh operace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
pl02kateg | N(2,0) | Kategorie | Kategorie předepsané platby | Kategorie předepsané platby
pl02kateg2 | N(2,0) | pl02kateg2 | Kategorie předepsané platby | Kategorie předepsané platby
pl09zstav1 | N(1,0) | pl09zstav1 | Změna stavu události při vstupu navazující události plateb propojené mírou plnění | Změna stavu události při vstupu navazující události plateb propojené mírou plnění
pl09zstav2 | N(1,0) | pl09zstav2 | Změna stavu události při zrušení navazující události plateb propojené mírou plnění | Změna stavu události při zrušení navazující události plateb propojené mírou plnění
pl09koment | M | Poznámka | Poznámka | Poznámka
pl09predbe | N(1,0) | Operaci ukončovat předběžně | Operaci ukončovat pouze předběžně | Operaci ukončovat pouze předběžně
pl09prineu | N(1,0) | Povolit zařazení platby neuk.operace na příkaz k úhradě | Povolit zařazení platby neukončené operace na příkaz k úhradě | Povolit zařazení platby neukončené operace na příkaz k úhradě
pl09vsval | N(1,0) | Validace variabilního symbolu | Provádět validaci existence závazku se stejným variabilním symbolem | Provádět validaci existence závazku se stejným variabilním symbolem

Indexy

Název | Primární | Výraz | Popis
ix_PLPAROPE_sptyp | P | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému


PLPLOD Vazba mezi platbou a kartou odpisu,opravné položky aktiva

Popis

Vazba mezi platbou a kartou odpisu,opravné položky aktiva

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
pl02 | C(12) | pl02 | Jednoznačná časová identifikace | Jednoznačná časová identifikace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vazba mezi platbou a kartou odpisu,opravné položky aktiva - váže platbu | PLPLOD pl02 | 1,1 : 0,M s rušením | PLUDA pl02 |
Vazba mezi platbou a kartou odpisu,opravné položky aktiva - váže kartu odpisu,opravné položky aktiva | PLPLOD sp60id sp61id | 1,1 : 0,M s rušením | ODKARTA sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_PLPLOD_plplod | P | sp60id, sp61id, pl02 | Primární index vazby mezi platbou a kartou odpisu,opravné položky aktiva
ix_PLPLOD_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_PLPLOD_pl02 |  | pl02 | Jednoznačná časová identifikace


PLPLVYM Vazba mezi platbou a vymáháním

Popis

Vazba mezi platbou a vymáháním

Atributy

Atribut | Typ | Návěští | Message | Popis
pl02 | C(12) | pl02 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
vm02 | C(12) | vm02 | Jednoznačná časová identifikace události vymáhání | Jednoznačná časová identifikace události vymáhání

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vazba mezi platbou a vymáháním - váže platbu | PLPLVYM pl02 | 1,1 : 0,M s rušením | PLUDA pl02 |
Vazba mezi platbou a vymáháním - váže vymáhání | PLPLVYM vm02 | 1,1 : 0,M s rušením | VMUDA vm02 |

Indexy

Název | Primární | Výraz | Popis
ix_PLPLVYM_plplvym | P | pl02, vm02 | PI - vazby mezi platbou a vymáháním
ix_PLPLVYM_pl02 |  | pl02 | Jednoznačná časová identifikace
ix_PLPLVYM_vm02 |  | vm02 | Jednoznačná časová identifikace události vymáhání


PLPRIU Příkaz k úhradě

Popis

Příkaz k úhradě

Atributy

Atribut | Typ | Návěští | Message | Popis
pl03rok | C(4) | Rok | Rok vystavení příkazu k úhradě | Rok vystavení příkazu k úhradě
pl03idu | C(2) | IDÚ | Identifikace datového úložiště | Identifikace datového úložiště
pl03id | C(6) | Příkaz | Číslo příkazu k úhradě | Identifikace příkazu k úhradě
pl03uzav | N(1,0) | pl03uzav | Uzavřený příkaz k úhradě | Uzavřený příkaz k úhradě
pl01id | C(6) | Účet/pokladna | Identifikace účtu/pokladny | Identifikace účtu/pokladny
pl03datum | D | Datum | Datum příkazu k úhradě | Datum příkazu k úhradě
pl03prikuh | C(40) | Popis | Popis příkazu k úhradě | Popis příkazu k úhradě
pl03koment | M | Poznámka | Poznámka k příkazu k úhradě | Poznámka k příkazu k úhradě
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
pl03 | C(12) | pl03 | Jednoznačná časová identifikace příkazu k úhradě | Jednoznačná časová identifikace příkazu k úhradě

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Příkaz k úhradě - je určen pro účet | PLPRIU pl01id | 1,1 : 0,M | PLUP pl01id |
Příkaz k úhradě - založil uživatel | PLPRIU bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Řádek příkazu k úhradě - je na příkazu k úhradě | PLPRIUP pl03rok pl03idu pl03id | 1,1 : 0,M | PLPRIU pl03rok pl03idu pl03id |

Indexy

Název | Primární | Výraz | Popis
ix_PLPRIU_plpriu | P | pl03rok, pl03idu, pl03id | PI - příkazu k úhradě
ix_PLPRIU_pl01id |  | pl01id | Identifikace účtu/pokladny
ix_PLPRIU_pl03datum |  | pl03datum | Datum příkazu k úhradě
ix_PLPRIU_pl03prikuh |  | pl03prikuh | Popis příkazu k úhradě
ix_PLPRIU_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_PLPRIU_pl03 | U | pl03 | Jednoznačná časová identifikace příkazu k úhradě


PLPRIUP Řádek příkazu k úhradě

Popis

Řádek příkazu k úhradě

Atributy

Atribut | Typ | Návěští | Message | Popis
pl03rok | C(4) | Rok | Rok vystavení příkazu k úhradě | Rok vystavení příkazu k úhradě
pl03idu | C(2) | IDÚ | Identifikace datového úložiště | Identifikace datového úložiště
pl03id | C(6) | Příkaz | Číslo příkazu k úhradě | Identifikace příkazu k úhradě
pl02 | C(12) | pl02 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
pl04crm | N(20,4) | Částka na příkazu | Částka v zahraniční měně | Částka v referenční měně

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Řádek příkazu k úhradě - je na příkazu k úhradě | PLPRIUP pl03rok pl03idu pl03id | 1,1 : 0,M | PLPRIU pl03rok pl03idu pl03id |
Řádek příkazu k úhradě - se vztahuje k události plateb | PLPRIUP pl02 | 1,1 : 0,M | PLUDA pl02 |

Indexy

Název | Primární | Výraz | Popis
ix_PLPRIUP_plpriup | P | pl03rok, pl03idu, pl03id, pl02 |
ix_PLPRIUP_plpriu |  | pl03rok, pl03idu, pl03id | PI - příkazu k úhradě
ix_PLPRIUP_pl02 |  | pl02 | Jednoznačná časová identifikace


PLUDA Událost plateb

Popis

Objektem typu PLUDA je každá událost komponenty platby obsahující informace o vystavených nebo uhrazených platbách. Umožňuje evidovat platby také v zahraničních měnách.
*** Dříve PLATBY, APLATBY

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ad01id | C(6) | Adresát | Adresát | Identifikace adresáta
ad11cisspo | C(2) | Číslo spojení adresáta | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
ad03cisban | C(2) | Účet | Identifikátor spojení na bankovní účet adresáta. | Číslo spojení na bankovní účet adresáta. *** Dříve CISBANK.
pl02 | C(12) | pl02 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
pl02pohzav | N(1,0) | P/Z | Pohledávka/Závazek | Pohledávka/Závazek
uc01id | C(9) | Účet | Identifikátor účtu účetnictví | Identifikátor účtu
pl02datpla | D | Datum | Datum platby | Datum vystavení události plateb.
pl02datspl | D | Splatnost | Datum splatnosti | Datum splatnosti
pl02text | C(40) | Popis | Popis platby | Popis platby
pl08id | C(6) | Umístění - platby | Umístění - platby | Umístění - platby
pl02vs | C(10) | Variabilní symbol (příjemce) | Variabilní symbol (příjemce) | Variabilní symbol (příjemce)
pl02ks | C(4) | Konstantní symbol | Konstantní symbol | Konstantní symbol
pl01id | C(6) | Účet/pokladna | Identifikace účtu/pokladny | Identifikace účtu/pokladny
pl02czmnez | N(20,4) | Částka v ZM (nezaok.) | Částka v zahraniční měně nezaokrouhlená | Částka v zahraniční měně nezaokrouhlená
pl02czm | N(20,4) | Částka v ZM | Částka v zahraniční měně | Částka v zahraniční měně
pl02zalzm | N(20,4) | Záloha v ZM | Záloha v zahraniční měně | Záloha v zahraniční měně
pl02crmnez | N(20,4) | Částka v RM (nezaok.) | Částka v referenční měně nezaokrouhlená | Částka v referenční měně nezaokrouhlená
pl02crm | N(20,4) | Částka v RM | Částka v referenční měně zaokrouhlená | Částka v referenční měně zaokrouhlená.
pl02zalrm | N(20,4) | Záloha v RM | Záloha v referenční měně | Záloha v referenční měně
pl02crmu | N(20,4) | Dosud uhrazeno | Dosud uhrazeno (v referenční měně) | Částka uhrazená - v referenční měně
pl02crmnu | N(20,4) | Dosud neuhrazeno RM | Dosud neuhrazeno (v referenční měně) | Dosud neuhrazeno (v referenční měně)
pl02czmnu | N(20,4) | Dosud neuhrazeno ZM | Dosud neuhrazeno (v zahr. měně) | Dosud neuhrazeno (v zahr. měně)
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
oc01id1 | C(3) | Referenční měna | Referenční měna | Referenční měna kursu (je na pozadí)
oc03kurz | N(20,6) | Kurs | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup. | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup.
oc03mn | N(5,0) | Množství | Množství oceňovací jednotky v kursu. | Množství oceňovací jednotky v kurzu.
bw01uziv | C(6) | Zapsal | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
sp10idzak | C(9) | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Identifikátor organizačního selektoru | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Identifikátor technicko-věcného selektoru | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
pl02kurroz | N(1,0) | pl02kurroz | Účtovat kursový rozdíl | Účtovat kursový rozdíl
pl02kpmenu | N(20,4) | pl02kpmenu | Kurzový rozdíl - kurz předepsané platby je menší než kurz úhrady | Kurzový rozdíl - kurz předepsané platby je menší než kurz úhrady
pl02kpvetu | N(20,4) | pl02kpvetu | Kurzový rozdíl - kurz předepsané platby je větší než kurz úhrady | Kurzový rozdíl - kurz předepsané platby je větší než kurz úhrady
pl02kpmenr | N(20,4) | Kurzový rozdíl - KPP | Kurzový rozdíl - kurz neuhrazené části předepsané platby je menší než kurz na konci roku | Kurzový rozdíl - kurz neuhrazené části předepsané platby je menší než kurz na konci roku
pl02kpvetr | N(20,4) | Kurzový rozdíl - KPP>K.ROK | Kurzový rozdíl - kurz neuhrazené části předepsané platby je větší než kurz na konci roku | Kurzový rozdíl - kurz neuhrazené části předepsané platby je větší než kurz na konci roku
sp88id | C(6) | Text | Identifikace textu | Identifikace textu
vm06id | C(6) | Vymáhání | Identifikace algoritmu vymáhání | Identifikace algoritmu vymáhání
pl02datvym | D | Vymáhat | Datum očekávaného vymáhání | Datum očekávaného vymáhání
pl02ukonvy | N(2,0) | Úkon vymáhání | Úkon očekávaného vymáhání | Úkon očekávaného vymáhání
pl02import | N(1,0) | pl02import | Příznak importované události uhrazené platby | Příznak importované události uhrazené platby
pl02uhraze | N(1,0) | pl02uhraze | Příznak uhrazené platby | Příznak uhrazené platby
pl02kateg | N(2,0) | Kategorie | Kategorie předepsané platby | Kategorie předepsané platby

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost plateb - má adresu aktéra (odesilatele/příjemce) | PLUDA ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost plateb - má bankovní spojení aktéra (odesilatele/příjemce) | PLUDA ad01id ad03cisban | 0,1 : 0,M | ADBUCTY ad01id ad03cisban |
Událost plateb - byla založena uživatelem | PLUDA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost plateb - patří do fyzické operace | PLUDA sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost plateb - má zahraniční měnu | PLUDA oc01id | 1,1 : 0,M | OCMENA oc01id |
Událost plateb - má referenční měnu | PLUDA oc01id1 | 1,1 : 0,M | OCMENA oc01id |
Událost plateb - má obchodní selektor | PLUDA sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost plateb - má orgranizační selektor | PLUDA sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost plateb - má technicko-věcný selektor | PLUDA sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost plateb - má volný text | PLUDA sp88id | 1,1 : 0,M | SPTEXTY sp88id |
Událost plateb - používá algoritmus vymáhání | PLUDA vm06id | 1,1 : 0,M | VMALGOR vm06id |
Událost plateb - byla zaúčtována na účetní účet | PLUDA uc01id | 0,1 : 0,M | UCROZVRH uc01id |
Událost plateb - je spojena s umístěním | PLUDA pl08id | 1,1 : 0,M | PLUMIST pl08id |
Událost plateb - má účet/pokladnu | PLUDA pl01id | 1,1 : 0,M | PLUP pl01id |
Událost - skladba - týká se operace | PLAHUD pl02 | 1,1 : 0,M s rušením | PLUDA pl02 |
Vazba platba - výpis - má platbu | ZPUHR pl02 | 1,1 : 0,M | PLUDA pl02 |
Řádek příkazu k úhradě - se vztahuje k události plateb | PLPRIUP pl02 | 1,1 : 0,M | PLUDA pl02 |
Vazba mezi platbou a kartou odpisu,opravné položky aktiva - váže platbu | PLPLOD pl02 | 1,1 : 0,M s rušením | PLUDA pl02 |
Vazba mezi platbou a vymáháním - váže platbu | PLPLVYM pl02 | 1,1 : 0,M s rušením | PLUDA pl02 |

Indexy

Název | Primární | Výraz | Popis
ix_PLUDA_spprc |  | sp33cisd, sp33cisdpm, sp33cisdr | Identifikace procesu
ix_PLUDA_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_PLUDA_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_PLUDA_adbucty1 |  | ad01id, ad03cisban | ad01id+ad03cisban
ix_PLUDA_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_PLUDA_adadsatx |  |  |
ix_PLUDA_pl02 | P | pl02 | Jednoznačná časová identifikace
ix_PLUDA_uc01id |  | uc01id | Identifikátor účtu
ix_PLUDA_pl02datpla |  | pl02datpla | Datum vystavení události plateb.
ix_PLUDA_pl02datspl |  | pl02datspl | Datum splatnosti
ix_PLUDA_pl02text |  | pl02text | Popis platby
ix_PLUDA_pl08id |  | pl08id | Umístění - platby
ix_PLUDA_pl02vs |  | pl02vs | Variabilní symbol (příjemce)
ix_PLUDA_pl01id |  | pl01id | Identifikace účtu/pokladny
ix_PLUDA_pl02crm |  | pl02crm | Částka v referenční měně zaokrouhlená.
ix_PLUDA_pl02crmu |  | pl02crmu | Částka uhrazená - v referenční měně
ix_PLUDA_pl02crmnu |  | pl02crmnu | Dosud neuhrazeno (v referenční měně)
ix_PLUDA_pl02czmnu |  | pl02czmnu | Dosud neuhrazeno (v zahr. měně)
ix_PLUDA_oc01id |  | oc01id | Kód měny - oceňovací jednotky.
ix_PLUDA_oc01id1 |  | oc01id1 | Referenční měna kursu (je na pozadí)
ix_PLUDA_ad01id |  | ad01id | Identifikace adresáta
ix_PLUDA_sp33cisdr |  | sp33cisdr | Rok řady čísla procesu
ix_PLUDA_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_PLUDA_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_PLUDA_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_PLUDA_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_PLUDA_sp88id |  | sp88id | Identifikace textu
ix_PLUDA_vm06id |  | vm06id | Identifikace algoritmu vymáhání
ix_PLUDA_pl02datvym |  | pl02datvym | Datum očekávaného vymáhání
ix_PLUDA_pl02uhraze |  | pl02uhraze | Příznak uhrazené platby
ix_PLUDA_pl02kateg |  | pl02kateg | Kategorie předepsané platby


PLUMIST Umístění plateb

Popis

Umístění plateb
Provizorně pozastavená RI na SPSEOR a ADSPOJ kvůli generování

Atributy

Atribut | Typ | Návěští | Message | Popis
pl08id | C(6) | Umístění - platby | Umístění - platby | Umístění - platby
pl08text | C(40) | Název umístění | Název umístění - platby | Název umístění - platby
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Umístění plateb - má spojení na adresáta | PLUMIST ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost plateb - je spojena s umístěním | PLUDA pl08id | 1,1 : 0,M | PLUMIST pl08id |

Indexy

Název | Primární | Výraz | Popis
ix_PLUMIST_pl08id | P | pl08id | Umístění - platby
ix_PLUMIST_pl08text |  | pl08text | Název umístění - platby
ix_PLUMIST_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_PLUMIST_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_PLUMIST_ad01id |  | ad01id | Identifikace adresáta


PLUP Účet/pokladna (vlastní)

Popis

Objektem typu PLUP je každá definice vlastního účtu/pokladny. Rozšiřující údaje přebírá z bankovního spojení v adresáři.

Atributy

Atribut | Typ | Návěští | Message | Popis
ad01id | C(6) | Adresát | Adresát | Identifikace adresáta
ad03cisban | C(2) | Účet | Identifikátor spojení na bankovní účet adresáta. | Číslo spojení na bankovní účet adresáta. *** Dříve CISBANK.
pl01 | C(12) | pl01 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
pl01id | C(6) | Účet/pokladna | Identifikace účtu/pokladny | Identifikace účtu/pokladny
pl01text | C(40) | Název účtu/pokladny | Název účtu/pokladny | Název účtu/pokladny
sp11idzak | C(9) | Identifikátor organizačního selektoru | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
uc01id | C(9) | Účet | Identifikátor účtu účetnictví | Identifikátor účtu
zp07id | C(6) | Přenos | Identifikace definice přenosů | Identifikace definice přenosů

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Účet/pokladna (vlastní) - jsou spojeny s bankovním spojením | PLUP ad01id ad03cisban | 1,1 : 0,M | ADBUCTY ad01id ad03cisban |
Účet/pokladna (vlastní) - je v organizačním selektoru | PLUP sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Účet/pokladna (vlastní) - odpovídá účtu z účtového rozvrhu | PLUP uc01id | 0,1 : 0,M | UCROZVRH uc01id |
Účet/pokladna (vlastní) - má definice přenosu příkazu | PLUP zp07id | 0,1 : 0,M | ZPPRHLA zp07id |
Událost plateb - má účet/pokladnu | PLUDA pl01id | 1,1 : 0,M | PLUP pl01id |
Událost změny stavu peněz - výpisy a příkazy - má vlastní pokl/účet | ZPUDA pl01id | 1,1 : 0,M | PLUP pl01id |
Příkaz k úhradě - je určen pro účet | PLPRIU pl01id | 1,1 : 0,M | PLUP pl01id |

Indexy

Název | Primární | Výraz | Popis
ix_PLUP_adbucty1 |  | ad01id, ad03cisban | ad01id+ad03cisban
ix_PLUP_pl01 | U | pl01 | Jednoznačná časová identifikace
ix_PLUP_pl01id | P | pl01id | Identifikace účtu/pokladny
ix_PLUP_pl01text |  | pl01text | Název účtu/pokladny
ix_PLUP_ad01id |  | ad01id | Identifikace adresáta
ix_PLUP_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_PLUP_uc01id |  | uc01id | Identifikátor účtu
ix_PLUP_zp07id |  | zp07id | Identifikace definice přenosů


Tabulky PO...

POAH | Aktuální hodnota
POAHUD | Událost - skladba aktuální hodnoty pošty
POCENDSL | Ceník doplňkových služeb
POCENZAS | Cena zásilky
POKATCR | Číselná řada kategorie zásilky
POKATDSL | Spojení doplňkových služeb s kategorií zásilky
POKATZAS | Kategorie zásilky
POPOPPO | Kategorie pošty
POPOSTA | Poštovní zásilka

Viz.také

POAH Aktuální hodnota | POAHUD Událost - skladba aktuální hodnoty pošty | POCENDSL Ceník doplňkových služeb | POCENZAS Cena zásilky | POKATDSL Spojení doplňkových služeb s kategorií zásilky | POKATZAS Kategorie zásilky | POPOPPO Kategorie pošty | POPOSTA Poštovní zásilka | POKATCR Číselná řada kategorie zásilky


POAH Aktuální hodnota

Popis

****
****
Objektem aktuální hodnota je každá sledovaná a vypočítavaná hodnota (údaj) vztahující se k libovolné
kombinaci artiklu, umístění a adresáta. V ideálním případě odpovídá aktuální hodnotě v reálném světě.
Obvyklé hodnoty jsou konečný stav a obrat ve finančním nebo naturálním vyjádření.
Př.: dle konkrétní komponenty
Název entity v každé komponentě je doplněn třetím slovem.

Atributy

Atribut | Typ | Návěští | Message | Popis
po02id | C(6) | Kategorie | Identifikace kategorie pošty. | Identifikace kategorie pošty.
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
po03hodnot | N(20,4) | po03hodnot |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Aktuální hodnota - má kategorii pošty | POAH po02id | 1,1 : 0,M | POPOPPO po02id |
Aktuální hodnota - má uvedené adresové spojení | POAH ad01id | 1,1 : 0,M | ADADSAT ad01id |
Aktuální hodnota - má druh hodnoty | POAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_POAH_poah | P | po02id, ad01id, sp67id, sp06idsubs |
ix_POAH_po02id |  | po02id | Identifikace kategorie pošty.
ix_POAH_ad01id |  | ad01id | Identifikace adresáta
ix_POAH_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace


POAHUD Událost - skladba aktuální hodnoty pošty

Popis

***
***
Tato vazba uvádí, které události se podílejí na skladbě aktuální hodnoty.
Má zejména servisní charakter pro fyzickou implementaci pro ovládání systému.
V LM je možné ztotožnění s objektem skladba aktuální hodnoty.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
po01 | C(12) | po01 | Jednoznačný časový identifikátor pošty. | Jednoznačný časový identifikátor pošty. *** Dříve POSTA_OZ1.
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp74id | C(6) | sp74id | Umístění | Umístění
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp00datum | D | Datum | Datum události | Datum události
sp00text | C(40) | Popis | Popis události | Popis události
sp00hodnot | N(20,4) | Hodnota | Aktuální hodnota procesu |
sp69id | C(6) | Druh | Identifikace druhu saldokontní hodnoty procesu | Identifikace druhu saldokontní hodnoty procesu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost - skladba aktuální hodnoty pošty - se týká události pošty | POAHUD po01 | 1,1 : 0,M | POPOSTA po01 |

Indexy

Název | Primární | Výraz | Popis
ix_POAHUD_po01 |  | po01 | Jednoznačný časový identifikátor pošty.


POCENDSL Ceník doplňkových služeb

Atributy

Atribut | Typ | Návěští | Message | Popis
po54id | C(6) | Doplňková služba | Identifikace doplňkové služby | Identifikace doplňkové služby
po54sluzba | C(40) | Název | Název doplňkové služby |
po54cena | N(20,4) | Cena | Cena doplňkové služby |
po54prokaz | N(1,0) | po54prokaz | Cena platí pro každých... |
po54zvypro | N(20,4) | Pro každých | Platí pro každých |
po54odhran | N(20,4) | Od hranice | Za každých započatých nad tuto částku |
po54jedn | N(1,0) | po54jedn | Jednotka |
po54koment | M | Komentář k doplňkové službě | Komentář k doplňkové službě |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Kategorie pošty - má impl.doplňkovou službu I. | POPOPPO po54id | 1,1 : 0,M | POCENDSL po54id |
Kategorie pošty - má impl.doplňkovou službu II. | POPOPPO po54id1 | 1,1 : 0,M | POCENDSL po54id |
Poštovní zásilka - má doplňkovou službu I. | POPOSTA po54id | 1,1 : 0,M | POCENDSL po54id |
Poštovní zásilka - má doplňkovou službu II. | POPOSTA po54id1 | 1,1 : 0,M | POCENDSL po54id |
Kategorie zásilky - ma spojenou doplňkovou službu | POKATZAS po54id | 1,1 : 0,M | POCENDSL po54id |
Spojení doplňkových služeb s kategorií zásilky - má doplňkovou službu | POKATDSL po54id | 1,1 : 0,M | POCENDSL po54id |

Indexy

Název | Primární | Výraz | Popis
ix_POCENDSL_po54id | P | po54id | Identifikace doplňkové služby
ix_POCENDSL_po54sluzba |  | po54sluzba |


POCENZAS Cena zásilky

Atributy

Atribut | Typ | Návěští | Message | Popis
po52id | C(6) | Kategorie zásilky | Identifikace kategorie zásilky | Identifikace kategorie zásilky
po53hmotn | N(12,2) | po53hmotn |  |
po53rozl | C(5) | po53rozl |  |
po53cena | N(20,4) | po53cena |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Cena zásilky - je vázána na kategorii | POCENZAS po52id | 1,1 : 0,M | POKATZAS po52id |

Indexy

Název | Primární | Výraz | Popis
ix_POCENZAS_pocenzas | P | po52id, po53hmotn, po53rozl |
ix_POCENZAS_po52id |  | po52id | Identifikace kategorie zásilky
ix_POCENZAS_po53hmotn |  | po53hmotn |


POKATCR Číselná řada kategorie zásilky

Popis

Číselná řada kategorie zásilky pro určení pořadového čísla zásilky

Atributy

Atribut | Typ | Návěští | Message | Popis
po56id | C(6) | Řada | Identifikátor číselné řady zásilek | Identifikátor číselné řady zásilek
po56nazrad | C(40) | Název číselné řady | Název číselné řady zásilek | Název číselné řady zásilek
po56porcod | N(6,0) | Od | Číslování zásilek kategorie zásilek od | Číslování zásilek kategorie zásilek od
po56porcdo | N(6,0) | do | Číslování zásilek kategorie zásilek od | Číslování zásilek kategorie zásilek od
po56koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Kategorie zásilky - má definovanou číslenou řadu | POKATZAS po56id | 1,1 : 0,M | POKATCR po56id |

Indexy

Název | Primární | Výraz | Popis
ix_POKATCR_po56id | P | po56id | Identifikátor číselné řady zásilek
ix_POKATCR_po56nazrad |  | po56nazrad | Název číselné řady zásilek


POKATDSL Spojení doplňkových služeb s kategorií zásilky

Atributy

Atribut | Typ | Návěští | Message | Popis
po54id | C(6) | Doplňková služba | Identifikace doplňkové služby | Identifikace doplňkové služby
po52id | C(6) | Kategorie zásilky | Identifikace kategorie zásilky | Identifikace kategorie zásilky

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Spojení doplňkových služeb s kategorií zásilky - má kategorii zásilky | POKATDSL po52id | 1,1 : 0,M | POKATZAS po52id |
Spojení doplňkových služeb s kategorií zásilky - má doplňkovou službu | POKATDSL po54id | 1,1 : 0,M | POCENDSL po54id |

Indexy

Název | Primární | Výraz | Popis
ix_POKATDSL_pokatdsl1 | P | po54id, po52id |
ix_POKATDSL_po54id |  | po54id | Identifikace doplňkové služby
ix_POKATDSL_po52id |  | po52id | Identifikace kategorie zásilky


POKATZAS Kategorie zásilky

Atributy

Atribut | Typ | Návěští | Message | Popis
po52id | C(6) | Kategorie zásilky | Identifikace kategorie zásilky | Identifikace kategorie zásilky
po52id1 | C(6) | Nadřízená kategorie | Nadřízená kategorie zásilky |
po56id | C(6) | Řada | Identifikátor číselné řady zásilek | Identifikátor číselné řady zásilek
po52kateg | C(40) | Popis kategorie | Název kategorie zásilky |
po52strom | C(40) | Popis kategorie pro strom | Popis kategorie zásilky pro strom |
po52vybrat | N(1,0) | po52vybrat | Kategorie je možné vybrat |
po54id | C(6) | Doplňková služba | Identifikace doplňkové služby | Identifikace doplňkové služby
po52koment | M | Komentář | Komentář ke kategorii zásilky |
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
po52aktual | N(1,0) | Aktuální | Aktuální Ano/Ne | Aktuální Ano/Ne

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Kategorie zásilky - zapsal | POKATZAS bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Kategorie zásilky - ma spojenou doplňkovou službu | POKATZAS po54id | 1,1 : 0,M | POCENDSL po54id |
Kategorie zásilky - má definovanou číslenou řadu | POKATZAS po56id | 1,1 : 0,M | POKATCR po56id |
Kategorie pošty - má impl.kategorii zásilky | POPOPPO po52id | 1,1 : 0,M | POKATZAS po52id |
Poštovní zásilka - má kategorii zásilky | POPOSTA po52id | 1,1 : 0,M | POKATZAS po52id |
Cena zásilky - je vázána na kategorii | POCENZAS po52id | 1,1 : 0,M | POKATZAS po52id |
Spojení doplňkových služeb s kategorií zásilky - má kategorii zásilky | POKATDSL po52id | 1,1 : 0,M | POKATZAS po52id |

Indexy

Název | Primární | Výraz | Popis
ix_POKATZAS_po52id | P | po52id | Identifikace kategorie zásilky
ix_POKATZAS_po52id1 |  | po52id1 |
ix_POKATZAS_po56id |  | po56id | Identifikátor číselné řady zásilek
ix_POKATZAS_po52kateg |  | po52kateg |
ix_POKATZAS_po54id |  | po54id | Identifikace doplňkové služby


POPOPPO Kategorie pošty

Popis

Objektem typu POPOPPO je každý záznam, který obsahuje definice vlastnosti, která rozděluje poštovní zásilky do kategorií se stejnou nebo podobnou charakteristikou.

Př.: odeslaná faktura, přijatý fax, výhružný dopis ap.

*** Dříve POST_KOD.

Atributy

Atribut | Typ | Návěští | Message | Popis
po02 | C(12) | po02 | Jednoznačný časový identifikátor předlohy pošty. | Jednoznačný časový identifikátor předlohy pošty. *** Dříve KOD_OZ.
pa13id | C(12) | Klasifikace | Identifikace klasifikace objektu | Identifikace klasifikace objektu
bw55objec | C(2) | Identifikace objektu BM | Identifikace objektu BM | Identifikace objektu BM
pa01id | C(6) | Sada | Identifikátor sady parametrů | Identifikátor sady parametrů
pa01oblast | C(2) | Oblast | Oblast sady parametrů | Oblast sady parametrů
po02id | C(6) | Kategorie | Identifikace kategorie pošty. | Identifikace kategorie pošty.
po02typ | C(40) | Název | Název kategorie pošty. | Název kategorie pošty.
po52id | C(6) | Kategorie zásilky | Identifikace kategorie zásilky | Identifikace kategorie zásilky
po54id | C(6) | Doplňková služba | Identifikace doplňkové služby | Identifikace doplňkové služby
po54id1 | C(6) | Doplňková služba | Identifikace doplňkové služby | Identifikace doplňkové služby
po02koment | M | Komentář | Komentář kategorie pošty |
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Kategorie pošty - zapsal uživatel | POPOPPO bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Kategorie pošty - má impl.kategorii zásilky | POPOPPO po52id | 1,1 : 0,M | POKATZAS po52id |
Kategorie pošty - má impl.doplňkovou službu I. | POPOPPO po54id | 1,1 : 0,M | POCENDSL po54id |
Kategorie pošty - má impl.doplňkovou službu II. | POPOPPO po54id1 | 1,1 : 0,M | POCENDSL po54id |
Kategorie pošty - určuje klasifikaci objektu pošty | POPOPPO pa13id bw55objec | 1,1 : 0,M | PAOBJDRU pa13id bw55objec |
Kategorie pošty - určuje sadu parametrů poštovní zásilky | POPOPPO pa01id pa01oblast | 1,1 : 0,M | PASADA pa01id pa01oblast |
Poštovní zásilka - má kategorii | POPOSTA po02id | 1,1 : 0,M | POPOPPO po02id |
Aktuální hodnota - má kategorii pošty | POAH po02id | 1,1 : 0,M | POPOPPO po02id |

Indexy

Název | Primární | Výraz | Popis
ix_POPOPPO_po02 | U | po02 | Jednoznačný časový identifikátor předlohy pošty.
ix_POPOPPO_paobjdru |  | pa13id, bw55objec | PI - pa13id+bw55objec
ix_POPOPPO_pasada |  | pa01id, pa01oblast | PI - pa01id+pa01oblast
ix_POPOPPO_po02id | P | po02id | Identifikace kategorie pošty.
ix_POPOPPO_po02typ |  | po02typ | Název kategorie pošty.
ix_POPOPPO_po52id |  | po52id | Identifikace kategorie zásilky
ix_POPOPPO_po54id |  | po54id | Identifikace doplňkové služby
ix_POPOPPO_po54id1 |  | po54id1 | Identifikace doplňkové služby
ix_POPOPPO_bw01uziv |  | bw01uziv | Identifikace uživatele systému


POPOSTA Poštovní zásilka

Popis

Objektem typu POPOSTA je každý záznam, který obsahuje informace o poštovní zásilce, která přišla do firmy (došlá pošta), nebo která byla odeslána (odeslaná pošta) nebo je připravena k odeslání (zásobník pošty).

*** Dříve POSTA.

Atributy

Atribut | Typ | Návěští | Message | Popis
po01datod | D | Odeslání | Datum odeslání. | Datum odeslání. *** Dříve DATUMS.
po01porcis | N(6,0) | Pořadí | Pořadové číslo odeslané zásilky v rámci dne | Pořadové číslo odeslané zásilky v rámci dne. Umožňuje seřadit si a vytisknou zásilky v pořadí, v jakém budou podávány na poště.
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad02cisadr | C(2) | Adresa | Číslo adresy adresáta. | Číslo adresy adresáta. Program generuje automaticky. *** Dříve CISADR. C,1 !!!
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
po01 | C(12) | po01 | Jednoznačný časový identifikátor pošty. | Jednoznačný časový identifikátor pošty. *** Dříve POSTA_OZ1.
bw01uziv2 | C(6) | bw01uziv2 | Identifikace uživatele systému | Identifikace uživatele systému
po01inout | N(1,0) | po01inout | Příznak došlá/odeslaná pošta/zásobník pošty. | Příznak došlá/odeslaná pošta/zásobník pošty. *** Dříve D.
po01cena | N(20,4) | Cena zásilky | Cena zásilky, platba přepravní organizaci | Cena zásilky. *** Dříve ZNAMKA.
po01hmotn | N(12,2) | po01hmotn |  |
po01cenaz | N(20,4) | po01cenaz |  |
po01cenas | N(20,4) | po01cenas |  |
po01cenaf | N(20,4) | F.cena | Cena zásilky uvedená na faktuře odeslané | Cena zásilky uvedená na faktuře odeslané
po52id | C(6) | Kategorie zásilky | Identifikace kategorie zásilky | Identifikace kategorie zásilky
po54id | C(6) | Doplňková služba | Identifikace doplňkové služby | Identifikace doplňkové služby
po54id1 | C(6) | po54id1 | Identifikace doplňkové služby | Identifikace doplňkové služby
po01recom | N(1,0) | po01recom | Příznak doporučené zásilky. | Příznak doporučené zásilky. *** Dříve REKOMANDO.
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
po02id | C(6) | Kategorie | Identifikace kategorie pošty. | Identifikace kategorie pošty.
po01text | C(40) | Popis zásilky | Text výstižně charakterizující zásilku. | Text výstižně charakterizující zásilku. *** Dříve OBSAH.
po01koment | M | po01koment |  |
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw01uziv1 | C(6) | bw01uziv1 | Identifikace uživatele systému - druhá identifikace | Identifikace uživatele systému - druhá identifikace předplňovaná většinou na pozadí
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
po01datza | D | po01datza | Datum zápisu do pošty | Datum zápisu do pošty
ad57id | C(6) | ad57id |  |
po03r1 | M | po03r1 | První řádek adresy (např. oslovení) | Řádek je při založení události v poště prázdný. Uživatelem může být doplněn např. o oslovení.
po03r2 | M | po03r2 | Druhý řádek adresy (např. jméno) | Řádek je při založení události v poště prázdný. Uživatelem může být doplněn např. jménem adresáta.
po03r3 | M | po03r3 | Třetí řádek adresy (např. adresát) | Řádek se předplňuje názvem adresáta. Uživatel ho může editovat (např. přesunout do jiného řádku a na jeho místo dopsat jméno)
po01ulice | C(40) | po01ulice | Ulice adresy adresáta (včetně čísla popisného). | Ulice adresy adresáta (včetně čísla popisného).
po01psc | C(10) | po01psc | Poštovní směrovací číslo adresy adresáta. | Poštovní směrovací číslo adresy adresáta.
po01mesto | C(40) | po01mesto | Město adresy adresáta. | Město adresy adresáta.
ad05id | C(3) | Stát | Identifikace státu. | Identifikace státu. *** Dříve ZIP.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Poštovní zásilka - má kategorii | POPOSTA po02id | 1,1 : 0,M | POPOPPO po02id |
Poštovní zásilka - byla zapsána pracovníkem | POPOSTA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Poštovní zásilka - patří operaci dokladu | POPOSTA sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Poštovní zásilka - je vyřizována pracovníkem | POPOSTA bw01uziv2 | 0,1 : 0,M | BWUZIVAT bw01uziv |
Poštovní zásilka - má obchodní selektor | POPOSTA sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Poštovní zásilka - má organizační selektor | POPOSTA sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Poštovní zásilka - má tech. selektor | POPOSTA sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Poštovní zásilka - má spojení | POPOSTA ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Poštovní zásilka - má adresáta | POPOSTA ad01id | 1,1 : 0,M | ADADSAT ad01id |
Poštovní zásilka - má na štítku stát | POPOSTA ad05id | 1,1 : 0,M | ADSTATY ad05id |
Poštovní zásilka - má typ operace | POPOSTA sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Poštovní zásilka - má kategorii zásilky | POPOSTA po52id | 1,1 : 0,M | POKATZAS po52id |
Poštovní zásilka - má doplňkovou službu I. | POPOSTA po54id | 1,1 : 0,M | POCENDSL po54id |
Poštovní zásilka - má doplňkovou službu II. | POPOSTA po54id1 | 1,1 : 0,M | POCENDSL po54id |
Poštovní zásilka - má oslovení | POPOSTA ad57id | 1,1 : 0,M | ADOSLOV ad57id |
Událost - skladba aktuální hodnoty pošty - se týká události pošty | POAHUD po01 | 1,1 : 0,M | POPOSTA po01 |

Indexy

Název | Primární | Výraz | Popis
ix_POPOSTA_poposta3 |  | po01datod, po01porcis | po01datod + po01porcis
ix_POPOSTA_adadr1 |  | ad01id, ad02cisadr | Adresát + číslo adresy Pro zobrazení
ix_POPOSTA_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_POPOSTA_po01 | P | po01 | Jednoznačný časový identifikátor pošty.
ix_POPOSTA_sp33cisdr |  | sp33cisdr | Rok řady čísla procesu
ix_POPOSTA_sp33cisdpm |  | sp33cisdpm | Pracovní místo čísla řady procesu
ix_POPOSTA_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_POPOSTA_bw01uziv2 |  | bw01uziv2 | Identifikace uživatele systému
ix_POPOSTA_po01inout |  | po01inout | Příznak došlá/odeslaná pošta/zásobník pošty.
ix_POPOSTA_po52id |  | po52id | Identifikace kategorie zásilky
ix_POPOSTA_po54id |  | po54id | Identifikace doplňkové služby
ix_POPOSTA_po54id1 |  | po54id1 | Identifikace doplňkové služby
ix_POPOSTA_po01recom |  | po01recom | Příznak doporučené zásilky.
ix_POPOSTA_po01porcis |  | po01porcis | Pořadové číslo odeslané zásilky v rámci dne. Umožňuje seřadit si a vytisknou zásilky v pořadí, v jakém budou podávány na poště.
ix_POPOSTA_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_POPOSTA_ad01id |  | ad01id | Identifikace adresáta
ix_POPOSTA_ad11cisspo |  | ad11cisspo | Číslo spojení adresáta. Program generuje automaticky.
ix_POPOSTA_po02id |  | po02id | Identifikace kategorie pošty.
ix_POPOSTA_po01text |  | po01text | Text výstižně charakterizující zásilku.
ix_POPOSTA_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_POPOSTA_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_POPOSTA_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_POPOSTA_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_POPOSTA_bw01uziv1 |  | bw01uziv1 | Identifikace uživatele systému - druhá identifikace předplňovaná většinou na pozadí
ix_POPOSTA_sp00datzap |  | sp00datzap | Datum a čas zápisu záznamu události
ix_POPOSTA_po01datza |  | po01datza | Datum zápisu do pošty
ix_POPOSTA_po01datod |  | po01datod | Datum odeslání.
ix_POPOSTA_ad57id |  | ad57id |
ix_POPOSTA_po01psc |  | po01psc | Poštovní směrovací číslo adresy adresáta.
ix_POPOSTA_ad05id |  | ad05id | Identifikace státu.
ix_POPOSTA_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému


Tabulky PY...

PYBDP | Bonitní díl parcely
PYDRUUDA | Druh události o nemovitosti
PYJPV | Jiný právní vztah
PYKATAST | Katastrální území
PYLISDU | Listina - další údaje LDU
PYLISNEM | Přiřazení listiny k nemovitosti RL
PYLISTIN | Listina
PYNEMLV | List vlastnictví nemovitosti (těleso)
PYNEMLVP | Vlastnictví nemovitosti VLA
PYNEMOV | Nemovitost
PYNEMSTA | Nemovitost ve stavu
PYNEMZPO | Způsob ochrany nemovitosti RZO
PYOPSUB | Oprávněný subjekt - OPSUB
PYPARAM | Parametry komponenty nemovitosti
PYRIZENI | Řízení
PYRIZOBJ | Objekt řízení OBJRIZ
PYRIZPRE | Předmět řízení
PYRIZUC | Účastník řízení UCAST
PYRIZUCA | Adresa účastníka řízení ADRUCA
PYRIZUCO | Informace o obeslání účastníka řízení OBESMF
PYRIZUCT | Typ účastníka v řízení UCTYP
PYSPRCEL | Správní celek
PYSPRCEP | Pohled do PYSPRCEL
PYSTADAT | Stav dat
PYSTAV | Stav nemovitosti podle našeho zájmu
PYTOPMAP | Popis mapy v Topolu
PYTOPOZN | Označení nemovitosti pro Topol
PYTOPSQL | SQL dotaz pro zobrazení v topolu
PYTRAN | Transformace změny obsahu entity do události o nemovitosti
PYTRANAT | Výraz transformace hodnoty atributu události o nemovitosti
PYTYPCIS | Sloučený typ - spojené číselníky
PYUDAL | Událost o nemovitosti
PYUMIST | Umístění nemovitosti


Tabulky PZ...

PZOBLSKU | Oblíbená skupina uživatelů
PZOBLUZI | Uživatelé v oblíbených skupinách uživatelů
PZOLOB | Druh objektu Outlooku
PZOLOBT | Obraz objektu Outlooku v BM
PZOLREC | Konverze adresy do Outlooku
PZOLTRA | Transformace objektu BM do Outlooku
PZOLTRAV | Popis výrazu transformace z BM do vlastnosti objektu Outlooku
PZOLUSR | Poslední transformace a konverze adresy Outlooku vybraná uživatelem při odeslání zprávy z komponenty BM
PZZPRAVY | Zpráva

Viz.také

PZOBLSKU Oblíbená skupina uživatelů | PZOBLUZI Uživatelé v oblíbených skupinách uživatelů | PZOLOB Druh objektu Outlooku | PZOLOBT Obraz objektu Outlooku v BM | PZOLREC Konverze adresy do Outlooku | PZOLTRA Transformace objektu BM do Outlooku | PZOLTRAV Popis výrazu transformace z BM do vlastnosti objektu Outlooku | PZOLUSR Poslední transformace a konverze adresy Outlooku vybraná uživatelem při | PZZPRAVY Zpráva


PZOBLSKU Oblíbená skupina uživatelů

Popis

Objektem typu PZOBLSKU je každý záznam, který obsahuje oblíbenou skupinu uživatelů systému.
Kterýkoli uživatel si může vytvořit své oblíbené skupiny, každé skupině přiřadit libovolný výběr uživatelů systému. Pak může hromadně rozesílat zprávy, nebo nahlížet do více diářů tak, že si vybere oblíbenou skupinu.

Atributy

Atribut | Typ | Návěští | Message | Popis
pz07 | C(12) | pz07 | JČI oblíbené skupiny |
pz07id | C(6) | Skupina uživatelů | Identifikace oblíbené skupiny uživatelů |
pz07text | C(40) | Název skupiny | Název oblíbené skupiny uživatelů |
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Oblíbená skupina uživatelů - patří uživateli | PZOBLSKU bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Uživatelé v oblíbených skupinách uživatelů - přísluší oblíbené skupině uživatelů | PZOBLUZI pz07 | 1,1 : 0,M s rušením | PZOBLSKU pz07 |

Indexy

Název | Primární | Výraz | Popis
ix_PZOBLSKU_pz07 | U | pz07 |
ix_PZOBLSKU_pz07id | P | pz07id |
ix_PZOBLSKU_pz07text |  | pz07text |


PZOBLUZI Uživatelé v oblíbených skupinách uživatelů

Popis

Objektem typu PZOBLUZI je každý záznam, který obsahuje vazbu mezi oblíbenou skupinou uživatelů a uživateli zařazenými do skupiny.

Atributy

Atribut | Typ | Návěští | Message | Popis
pz07 | C(12) | pz07 | JČI oblíbené skupiny |
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Uživatelé v oblíbených skupinách uživatelů - má uživatele systému | PZOBLUZI bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Uživatelé v oblíbených skupinách uživatelů - přísluší oblíbené skupině uživatelů | PZOBLUZI pz07 | 1,1 : 0,M s rušením | PZOBLSKU pz07 |

Indexy

Název | Primární | Výraz | Popis
ix_PZOBLUZI_pzobluzi1 | P | pz07, bw01uziv |
ix_PZOBLUZI_pz07 |  | pz07 |
ix_PZOBLUZI_bw01uziv |  | bw01uziv | Identifikace uživatele systému


PZOLOB Druh objektu Outlooku

Popis

Druh objektu Outlooku

Atributy

Atribut | Typ | Návěští | Message | Popis
pz09id | C(6) | Druh | Identifikace druhu objektu Outlooku | Identifikace druhu objektu Outlooku
pz09nazobj | C(40) | Název objektu | Název druhu objektu Outlooku | Název druhu objektu Outlooku
pz09folder | M | Seznam složek Outlooku | Seznam složek Outlooku oddělených středníkem, ve kterých se objekt nachází | Seznam složek Outlooku
pz09dtalab | M | Text pro návěští data | Text pro návěští data v prezentaci v BM | Text pro návěští data v prezentaci v BM
pz09dtaatr | M | Výraz vlastnosti data | Výraz vlastnosti data objektu Outlooku pro prezentaci v BM | Výraz vlastnosti data objektu Outlooku pro prezentaci v BM
pz09sublab | M | Text pro návěští předmětu | Text pro návěští předmětu v prezentaci v BM | Text pro návěští předmětu v prezentaci v BM
pz09subatr | M | Výraz vlastnosti předmětu | Výraz vlastnosti předmětu objektu Outlooku pro prezentaci v BM | Výraz vlastnosti předmětu objektu Outlooku pro prezentaci v BM
pz09bodlab | M | Text pro návěští poznámky | Text pro návěští poznámky v prezentaci v BM | Text pro návěští poznámky v prezentaci v BM
pz09bodatr | M | Výraz vlastnosti předmětu | Výraz vlastnosti poznámky objektu Outlooku pro prezentaci v BM | Výraz vlastnosti poznámky objektu Outlooku pro prezentaci v BM
pz09koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Transformace objektu BM do Outlooku - je určena pro objekt Outlooku | PZOLTRA pz09id | 1,1 : 0,M | PZOLOB pz09id |

Indexy

Název | Primární | Výraz | Popis
ix_PZOLOB_pz09id | P | pz09id | Identifikace druhu objektu Outlooku
ix_PZOLOB_pz09nazobj |  | pz09nazobj | Název druhu objektu Outlooku


PZOLOBT Obraz objektu Outlooku v BM

Popis

Obraz objektu Outlooku v BM

Atributy

Atribut | Typ | Návěští | Message | Popis
pz14f | C(10) | pz14f | Výběr pro formulář | Výběr pro formulář
pz14 | C(12) | pz14 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
pz14datum | T | pz14datum | Datum a čas objektu Outlooku | Datum a čas objektu Outlooku
pz14subjec | C(100) | pz14subjec | Předmět | Předmět
pz14body | M | pz14body | Poznámka | Poznámka
bw01jmenot | C(25) | Uživatel (úplné jméno) | Úplné jméno uživatele systému | Rozšířené jméno uživatele systému
bw09inst1 | C(12) | bw09inst1 | Jednoznačný časový identifikátor instance objektu typu 1. |
bw09typ1 | C(2) | bw09typ1 | Identifikátor typu objektu 1. | Typ objektu
pz09id | C(6) | Druh | Identifikace druhu objektu Outlooku | Identifikace druhu objektu Outlooku
pz14stav | N(1,0) | Stav | Stav objektu | Stav objektu

Indexy

Název | Primární | Výraz | Popis
ix_PZOLOBT_pzolrec | P | pz14f, pz14 | PI - pz14+pz14f
ix_PZOLOBT_pz14datum |  | pz14datum | Datum a čas objektu Outlooku
ix_PZOLOBT_pz14subjec |  | pz14subjec | Předmět
ix_PZOLOBT_bw09typ1 |  | bw09typ1 | Typ objektu
ix_PZOLOBT_pz09id |  | pz09id | Identifikace druhu objektu Outlooku


PZOLREC Konverze adresy do Outlooku

Popis

Konverze adresy do Outlooku

Atributy

Atribut | Typ | Návěští | Message | Popis
pz12id | C(6) | Konverze | Identifikace konverze adresy příjemce v Outlooku | Identifikace konverze adresy příjemce v Outlooku
pz12nazkon | C(40) | Název konverze | Název konverze adresy příjemce v Outlooku | Název konverze adresy příjemce v Outlooku
bw55objec | C(2) | Identifikace objektu BM | Identifikace objektu BM | Identifikace objektu BM
pz12typ | N(1,0) | Typ | Typ určení adresy příjemce v Outlooku | Typ určení adresy příjemce v Outlooku
pz12vyraz | M | Výraz konverze | Výraz konverze | Výraz konverze
pz12koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Transformace objektu BM do Outlooku - používá konverzi adresy | PZOLTRA pz12id | 1,1 : 0,M | PZOLREC pz12id |
Poslední transformace a konverze adresy Outlooku vybraná uživatelem při odeslání zprávy z komponenty BM - poznamenává užití konverze adresy pro uživatele | PZOLUSR pz12id | 1,1 : 0,M s rušením | PZOLREC pz12id |

Indexy

Název | Primární | Výraz | Popis
ix_PZOLREC_pz12id | P | pz12id | Identifikace konverze adresy příjemce v Outlooku
ix_PZOLREC_pz12nazkon |  | pz12nazkon | Název konverze adresy příjemce v Outlooku
ix_PZOLREC_bw55objec |  | bw55objec | Identifikace objektu BM


PZOLTRA Transformace objektu BM do Outlooku

Popis

Transformace objektu BM do Outlooku

Atributy

Atribut | Typ | Návěští | Message | Popis
pz10id | C(6) | Transformace | Identifikace transformace | Identifikace transformace
pz10naztra | C(40) | Transformace | Název transformace | Název transformace
bw55objec | C(2) | Identifikace objektu BM | Identifikace objektu BM | Identifikace objektu BM
pz12id | C(6) | Konverze | Identifikace konverze adresy příjemce v Outlooku | Identifikace konverze adresy příjemce v Outlooku
pz09id | C(6) | Druh | Identifikace druhu objektu Outlooku | Identifikace druhu objektu Outlooku
pz10koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Transformace objektu BM do Outlooku - je určena pro objekt Outlooku | PZOLTRA pz09id | 1,1 : 0,M | PZOLOB pz09id |
Transformace objektu BM do Outlooku - používá konverzi adresy | PZOLTRA pz12id | 1,1 : 0,M | PZOLREC pz12id |
Popis výrazu transformace z BM do vlastnosti objektu Outlooku - patří k transformaci | PZOLTRAV pz10id | 1,1 : 0,M s rušením | PZOLTRA pz10id |
Poslední transformace a konverze adresy Outlooku vybraná uživatelem při odeslání zprávy z komponenty BM - poznamenává užití transformace pro uživatele | PZOLUSR pz10id | 1,1 : 0,M s rušením | PZOLTRA pz10id |

Indexy

Název | Primární | Výraz | Popis
ix_PZOLTRA_pz10id | P | pz10id | Identifikace transformace
ix_PZOLTRA_pz10naztra |  | pz10naztra | Název transformace
ix_PZOLTRA_bw55objec |  | bw55objec | Identifikace objektu BM
ix_PZOLTRA_pz12id |  | pz12id | Identifikace konverze adresy příjemce v Outlooku
ix_PZOLTRA_pz09id |  | pz09id | Identifikace druhu objektu Outlooku


PZOLTRAV Popis výrazu transformace z BM do vlastnosti objektu Outlooku

Popis

Popis výrazu transformace z BM do vlastnosti objektu Outlooku

Atributy

Atribut | Typ | Návěští | Message | Popis
pz10id | C(6) | Transformace | Identifikace transformace | Identifikace transformace
pz11proper | C(30) | Vlastnost | Vlastnost objektu Outlooku | Vlastnost objektu Outlooku
pz11vyraz | M | Výraz objektu BM | Výraz objektu BM | Výraz objektu BM
pz11koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis výrazu transformace z BM do vlastnosti objektu Outlooku - patří k transformaci | PZOLTRAV pz10id | 1,1 : 0,M s rušením | PZOLTRA pz10id |

Indexy

Název | Primární | Výraz | Popis
ix_PZOLTRAV_pzoltrav | P | pz10id, pz11proper | PI - pz10id+pz11proper
ix_PZOLTRAV_pz10id |  | pz10id | Identifikace transformace


PZOLUSR Poslední transformace a konverze adresy Outlooku vybraná uživatelem při

Popis

Poslední transformace a konverze adresy Outlooku vybraná uživatelem při odeslání zprávy z komponenty BM

Atributy

Atribut | Typ | Návěští | Message | Popis
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw55objec | C(2) | Identifikace objektu BM | Identifikace objektu BM | Identifikace objektu BM
pz12id | C(6) | Konverze | Identifikace konverze adresy příjemce v Outlooku | Identifikace konverze adresy příjemce v Outlooku
pz10id | C(6) | Transformace | Identifikace transformace | Identifikace transformace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Poslední transformace a konverze adresy Outlooku vybraná uživatelem při odeslání zprávy z komponenty BM - poznamenává užití konverze adresy pro uživatele | PZOLUSR pz12id | 1,1 : 0,M s rušením | PZOLREC pz12id |
Poslední transformace a konverze adresy Outlooku vybraná uživatelem při odeslání zprávy z komponenty BM - poznamenává užití transformace pro uživatele | PZOLUSR pz10id | 1,1 : 0,M s rušením | PZOLTRA pz10id |
Poslední transformace a konverze adresy Outlooku vybraná uživatelem při odeslání zprávy z komponenty BM - je uživatele | PZOLUSR bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_PZOLUSR_pzolusr | P | bw01uziv, bw55objec |
ix_PZOLUSR_pz12id |  | pz12id | Identifikace konverze adresy příjemce v Outlooku
ix_PZOLUSR_pz10id |  | pz10id | Identifikace transformace
ix_PZOLUSR_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_PZOLUSR_bw55objec |  | bw55objec | Identifikace objektu BM


PZZPRAVY Zpráva

Popis

Objektem typu PZZPRAVY je každý záznam, který obsahuje zprávu jednoho pracovníka odeslanou jinému pracovníkovi. Zpráva může být vztažena k jakémukoliv objektu systému nebo může vzniknout samostatně. Obsahuje identifikaci autora a příjemce zprávy a další údaje.
Zprávy se mohou kategorizovat dle svého charakteru.

Př.: Zápis faktury v modulu Závazky a pohledávky vyvolá možnost odeslání zprávy pracovníkovi obchodního oddělení jako informace o faktuře a zprávu lze zařadit např. do kategorie Obchodní zprávy.

Rozpracovaný plán zaznamenaný jako událost v modulu Vývěska je odeslán jako zpráva vedoucího pracovníka svým podřízeným s komentářem autora k plnění plánu, současně slouží ke kontrole plnění.

'Zpráva', DTOC($$$.sp00datzap), ALLTRIM($$$.pz01text), 'Signalizace: '+DTOC($$$.pz01datum), '', $$$.bw01uziv

*** Dříve VYVESKAX.

Atributy

Atribut | Typ | Návěští | Message | Popis
pz01 | C(12) | pz01 | Jednoznačný časový identifikátor zprávy. | Jednoznačný časový identifikátor zprávy. *** Dříve VYV_OZ5.
bw01uziv1 | C(6) | bw01uziv1 | Identifikace uživatele systému - druhá identifikace | Identifikace uživatele systému - druhá identifikace předplňovaná většinou na pozadí
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
pz01datum | D | pz01datum | Datum, které se vztahuje k uvedené zprávě. | Datum, které se vztahuje k uvedené zprávě.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
pz01datpri | T | Přijetí | Datum přijetí zprávy. | Datum přijetí zprávy. *** Dříve VYX_DAT.
pz01datzpr | T | Zpracování | Datum zpracování zprávy. | Datum zpracování zprávy. *** Dříve VYX_DATZ.
pz01text | C(40) | Text | Text výstižně popisující zprávu |
pz01koment | M | Komentář | Komentář autora zprávy. | Komentář autora zprávy. *** Dříve VYX_TXTZ.
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
pz01status | N(1,0) | pz01status | Stav zprávy 0=nepřijatá, 1=nezpracovaná, 2=zpracovaná | Stav zprávy 0=nepřijatá, 1=nezpracovaná, 2=zpracovaná
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp34 | C(12) | sp34 | Jednoznačná časová identifikace operace | Jednoznačná časová identifikace operace
pz01pripom | N(1,0) | Připomenutí | Připomenutí Ano/Ne | Připomenutí Ano/Ne
pz01casprp | T | Čas | Datum a čas připomenutí | Datum a čas připomenutí

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Zpráva - byla zapsána pracovníkem | PZZPRAVY bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Zpráva - je poslána pracovníkovi | PZZPRAVY bw01uziv1 | 1,1 : 0,M | BWUZIVAT bw01uziv |
Zpráva - má obchodní selektor | PZZPRAVY sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Zpráva - má organizační selektor | PZZPRAVY sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Zpráva - má technický selektor | PZZPRAVY sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Zpráva - patří k operaci | PZZPRAVY sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 0,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Zpráva - byla vygenerována systémem pro operaci | PZZPRAVY sp34 | 0,1 : 0,M s rušením | SPPRCOD sp34 |

Indexy

Název | Primární | Výraz | Popis
ix_PZZPRAVY_pz01 | P | pz01 | Jednoznačný časový identifikátor zprávy.
ix_PZZPRAVY_bw01uziv1 |  | bw01uziv1 | Identifikace uživatele systému - druhá identifikace předplňovaná většinou na pozadí
ix_PZZPRAVY_sp00datzap |  | sp00datzap | Datum a čas zápisu záznamu události
ix_PZZPRAVY_pz01datum |  | pz01datum | Datum, které se vztahuje k uvedené zprávě.
ix_PZZPRAVY_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_PZZPRAVY_pz01text |  | pz01text |
ix_PZZPRAVY_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_PZZPRAVY_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_PZZPRAVY_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_PZZPRAVY_pz01status |  | pz01status | Stav zprávy 0=nepřijatá, 1=nezpracovaná, 2=zpracovaná
ix_PZZPRAVY_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_PZZPRAVY_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_PZZPRAVY_sp34 |  | sp34 | Jednoznačná časová identifikace operace
ix_PZZPRAVY_pzodeslal |  |  |
ix_PZZPRAVY_pz01pripom |  | pz01pripom | Připomenutí Ano/Ne
ix_PZZPRAVY_pzpripom |  | pz01pripom, pz01casprp |


Tabulky SA...

SAKATEG | Kategorie události správy artiklu
SAKATPLT | Entita artiklu s platností kategorie
SAPALETA | Paleta barev kategorií artiklu
SAPALKAT | Barva kategorie události správy artiklu v paletě barev
SAUDAL | Událost správy artiklu

Viz.také

SAKATEG Kategorie události správy artiklu | SAKATPLT Entita artiklu s platností kategorie | SAUDAL Událost správy artiklu | SAPALETA Paleta barev kategorií artiklu | SAPALKAT Barva kategorie události správy artiklu v paletě barev


SAKATEG Kategorie události správy artiklu

Popis

Katagorie události správy artiklu

Atributy

Atribut | Typ | Návěští | Message | Popis
sa05id | C(6) | Kategorie | Identifikace kategorie události správy artiklu | Identifikace kategorie události správy artiklu
sa05nazkat | C(40) | Název kategorie | Název kategorie události správy artiklu | Název kategorie události správy artiklu
sa05typ | N(1,0) | Typ | Typ kategorie - Vstupovaná / Vypočítaná | Typ kategorie - Vstupovaná / Vypočítaná
sa05sql | M | SQL | Výraz v SQL vyhodnocovaný dotazem vracející numerickou hodnotu (0=není v kategoriii) použivá ID artiklu @sp61id,@sp60id | Výraz v SQL vyhodnocovaný dotazem vracející numerickou hodnotu (0=není v kategoriii), použivá ID artiklu @sp61id,@sp60id
sa05koment | M | Poznámka | Poznámka | Poznámka
sa05urcplt | N(1,0) | Platnost | Určuje platnost artiklu Ano/Ne | Určuje platnost artiklu Ano/Ne
bw95id | C(6) | Barva | Identifikace barvy RGB | Identifikace barvy RGB
bw95id2 | C(6) | Barva | Identifikace barvy RGB | Identifikace barvy RGB

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Kategorie události správy artiklu - má implicitní barvu písma | SAKATEG bw95id | 1,1 : 0,M | BWRGBCOL bw95id |
Kategorie události správy artiklu - má implicitní barvu pozadí | SAKATEG bw95id2 | 1,1 : 0,M | BWRGBCOL bw95id |
Událost správy artiklu - určuje kategorii | SAUDAL sa05id | 1,1 : 0,M | SAKATEG sa05id |
Barva kategorie události správy artiklu v paletě barev - je určena pro kategorii | SAPALKAT sa05id | 1,1 : 0,M | SAKATEG sa05id |
Entita artiklu s platností kategorie - určuje kategorie události správy artiklu | SAKATPLT sa05id | 1,1 : 0,M s rušením | SAKATEG sa05id |

Indexy

Název | Primární | Výraz | Popis
ix_SAKATEG_sa05id | P | sa05id | Identifikace kategorie události správy artiklu
ix_SAKATEG_sa05nazkat |  | sa05nazkat | Název kategorie události správy artiklu
ix_SAKATEG_bw95id |  | bw95id | Identifikace barvy RGB
ix_SAKATEG_bw95id2 |  | bw95id2 | Identifikace barvy RGB


SAKATPLT Entita artiklu s platností kategorie

Popis

Entita artiklu s platností kategorie

Atributy

Atribut | Typ | Návěští | Message | Popis
sa05id | C(6) | Kategorie | Identifikace kategorie události správy artiklu | Identifikace kategorie události správy artiklu
bw10nazev | C(8) | Tabulka | Název entity | Název entity

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Entita artiklu s platností kategorie - určuje kategorie události správy artiklu | SAKATPLT sa05id | 1,1 : 0,M s rušením | SAKATEG sa05id |

Indexy

Název | Primární | Výraz | Popis
ix_SAKATPLT_sakatplt | P | sa05id, bw10nazev | PI - sa05id+bw10nazev
ix_SAKATPLT_sa05id |  | sa05id | Identifikace kategorie události správy artiklu


SAPALETA Paleta barev kategorií artiklu

Popis

Paleta barev kategorií artiklu

Atributy

Atribut | Typ | Návěští | Message | Popis
sa08id | C(6) | Paleta | Identifikace palety barev | Identifikace palety barev
sa08nazpal | C(40) | Název palety | Název palety barev | Název palety barev
sa08koment | M | Poznámka | Poznámka | Poznámka
bw05ident | C(6) | Skupina | Identifikace skupiny uživatelů | Identifikace skupiny uživatelů

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Paleta barev kategorií artiklu - je používána skupinou uživatelů | SAPALETA bw05ident | 1,1 : 0,M | BWUZIVAT bw01uziv |
Barva kategorie události správy artiklu v paletě barev - je v paletě barev | SAPALKAT sa08id | 1,1 : 0,M | SAPALETA sa08id |

Indexy

Název | Primární | Výraz | Popis
ix_SAPALETA_sa08id | P | sa08id | Identifikace palety barev
ix_SAPALETA_sa08nazpal |  | sa08nazpal | Název palety barev
ix_SAPALETA_bw05ident |  | bw05ident | Identifikace skupiny uživatelů


SAPALKAT Barva kategorie události správy artiklu v paletě barev

Popis

Barva kategorie události správy artiklu v paletě barev

Atributy

Atribut | Typ | Návěští | Message | Popis
sa05id | C(6) | Kategorie | Identifikace kategorie události správy artiklu | Identifikace kategorie události správy artiklu
sa08id | C(6) | Paleta | Identifikace palety barev | Identifikace palety barev
bw95id | C(6) | Barva | Identifikace barvy RGB | Identifikace barvy RGB
bw95id2 | C(6) | Barva | Identifikace barvy RGB | Identifikace barvy RGB
sa06prior | N(3,0) | Priorita | Priorita barvy | Priorita barvy

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Barva kategorie události správy artiklu v paletě barev - je určena pro kategorii | SAPALKAT sa05id | 1,1 : 0,M | SAKATEG sa05id |
Barva kategorie události správy artiklu v paletě barev - je v paletě barev | SAPALKAT sa08id | 1,1 : 0,M | SAPALETA sa08id |
Barva kategorie události správy artiklu v paletě barev - definuje barvu RGB - popředí | SAPALKAT bw95id | 1,1 : 0,M | BWRGBCOL bw95id |
Barva kategorie události správy artiklu v paletě barev - definuje barvu RGB - pozadí | SAPALKAT bw95id2 | 1,1 : 0,M | BWRGBCOL bw95id |

Indexy

Název | Primární | Výraz | Popis
ix_SAPALKAT_sapalkat | P | sa05id, sa08id | PI - sa05id+sa08id
ix_SAPALKAT_sa08id |  | sa08id | Identifikace palety barev
ix_SAPALKAT_sa05id |  | sa05id | Identifikace kategorie události správy artiklu
ix_SAPALKAT_bw95id |  | bw95id | Identifikace barvy RGB
ix_SAPALKAT_bw95id2 |  | bw95id2 | Identifikace barvy RGB


SAUDAL Událost správy artiklu

Popis

Událost správy artiklu

Atributy

Atribut | Typ | Návěští | Message | Popis
sa02 | C(12) | sa02 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
sa05id | C(6) | Kategorie | Identifikace kategorie události správy artiklu | Identifikace kategorie události správy artiklu
sa02dat | D | Datum | Datum události | Datum události
sa02platod | D | Platnost od | Datum platnosti od | Datum platnosti od
sa02platdo | D | Platnost do | Datum platnosti do | Datum platnosti do
sa02text | C(40) | Popis | Popis události | Popis události
sa02koment | M | Poznámka | Poznámka | Poznámka
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost správy artiklu - vznikla v operaci | SAUDAL sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 0,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost správy artiklu - určuje kategorii | SAUDAL sa05id | 1,1 : 0,M | SAKATEG sa05id |
Událost správy artiklu - určuje spojení na adresáta | SAUDAL ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost správy artiklu - se týká artiklu | SAUDAL sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Událost správy artiklu - má obchodní selektor | SAUDAL sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost správy artiklu - má organizační selektor | SAUDAL sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost správy artiklu - má technicko-věcný selektor | SAUDAL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost správy artiklu - založil uživatel | SAUDAL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_SAUDAL_sa02 | P | sa02 | Jednoznačná časová identifikace
ix_SAUDAL_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_SAUDAL_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SAUDAL_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_SAUDAL_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_SAUDAL_sa05id |  | sa05id | Identifikace kategorie události správy artiklu
ix_SAUDAL_ad01id |  | ad01id | Identifikace adresáta
ix_SAUDAL_sa02dat |  | sa02dat | Datum události
ix_SAUDAL_sa02text |  | sa02text | Popis události
ix_SAUDAL_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SAUDAL_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_SAUDAL_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_SAUDAL_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.


Tabulky SM...

SMAH | Aktuální hodnota spravovaného majetku
SMAHUD | Událost - skladba
SMMAJ | Spravovaný majetek
SMREZER | Rezervace
SMUDAL | Událost spravovaného majetku
SMUMIS | Umístění

Viz.také

SMAH Aktuální hodnota spravovaného majetku | SMAHUD Událost - skladba | SMMAJ Spravovaný majetek | SMREZER Rezervace | SMUDAL Událost spravovaného majetku | SMUMIS Umístění


SMAH Aktuální hodnota spravovaného majetku

Popis

****
****
Objektem aktuální hodnota je každá sledovaná a vypočítavaná hodnota (údaj) vztahující se k libovolné
kombinaci artiklu, umístění a adresáta. V ideálním případě odpovídá aktuální hodnotě v reálném světě.
Obvyklé hodnoty jsou konečný stav a obrat ve finančním nebo naturálním vyjádření.
Př.: dle konkrétní komponenty
Název entity v každé komponentě je doplněn třetím slovem.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sm05id | C(6) | Umístění | Identifikátor umístění | Identifikátor umístění
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sm08hodnot | N(20,4) | sm08hodnot |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Aktuální hodnota spravovaného majetku - má druh hodnoty | SMAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_SMAH_smah | P | sp60id, sp61id, ad01id, sm05id, sp67id, sp06idsubs |
ix_SMAH_ad01id |  | ad01id | Identifikace adresáta
ix_SMAH_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_SMAH_sp61id |  | sp61id | Identifikace druhu artiklu
ix_SMAH_sm05id |  | sm05id | Identifikátor umístění
ix_SMAH_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace


SMAHUD Událost - skladba

Popis

***
***
Tato vazba uvádí, které události se podílejí na skladbě aktuální hodnoty.
Má zejména servisní charakter pro fyzickou implementaci pro ovládání systému.
V LM je možné ztotožnění s objektem skladba aktuální hodnoty.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
sm02 | C(12) | sm02 | Časová identifikace události. | Časová identifikace události.
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp74id | C(6) | sp74id | Umístění | Umístění
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp00datum | D | Datum | Datum události | Datum události
sp00text | C(40) | Popis | Popis události | Popis události
sp00hodnot | N(20,4) | Hodnota | Aktuální hodnota procesu |
sp69id | C(6) | Druh | Identifikace druhu saldokontní hodnoty procesu | Identifikace druhu saldokontní hodnoty procesu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost - skladba - se týká události SM | SMAHUD sm02 | 1,1 : 0,M | SMUDAL sm02 |

Indexy

Název | Primární | Výraz | Popis
ix_SMAHUD_sm02 |  | sm02 | Časová identifikace události.


SMMAJ Spravovaný majetek

Popis

Objektem typu SMMAJ je každý záznam, který obsahuje spravovaný majetek, včetně jejich identifikačních údajů. Spravovaným majetkem můhou být podle uvážení uživatele stavby, stroje, židle,....

Atributy

Atribut | Typ | Návěští | Message | Popis
sm01 | C(12) | sm01 | Jednoznačná časová identifikace záznamu. | Jednoznačná časová identifikace záznamu.
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sm01por | N(4,0) | Pořadové číslo | Pořadové číslo | Pořadové číslo
sm05id | C(6) | Umístění | Identifikátor umístění | Identifikátor umístění
sm04komp | N(1,0) | sm04komp | Majetek souvisí s komponentou. | Majetek souvisí s komponentou. Majetek evidovaný ve spravovaném majetku může být sledován i v jiných komponentách. Např. investiční majetek je jak ve spravovaném majetku, tak v komponentě Odpis. Má-li spravovaný majetek v tomto atributu Inv.maj., může se uživatel přepnout do Odpisů a podívat se tam na další informace. A opačně, z Odpisů se lze podívat do Spravovaného majetku.
sm01vyrcis | C(20) | sm01vyrcis | Výrobní číslo | Výrobní číslo
sm01rezerv | N(1,0) | sm01rezerv | Majetek lze rezervovat. | Majetek lze rezervovat. Pouze majetek, který má příznak Rezervovat = Ano lze použít v diáři rezervovaných prostředků.
sm01carkod | C(36) | sm01carkod | Čárový kód | Čárový kód
sp17idskp | C(8) | Třída SKP | Identifikace třídy Standardní klasifikace produkce. | Identifikace kategorie Standardní klasifikace produkce. *** Dříve SKPID.
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sm01koment | M | sm01koment | Komentář k evidovanému majetku | Komentář k evidovanému majetku
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
sm01cenaz | N(20,4) | Cena z. | Cena při zařazení | Cena při zařazení
sm01cenav | N(20,4) | Cena v. | Cena při vyřazení | Cena při vyřazení
sm01prodej | N(1,0) | sm01prodej | Vyřazeno prodejem | Vyřazeno prodejem
sm01stav | N(1,0) | Stav | Stav majetku Nezařazen/Zařazen/Vyřazen | Stav majetku Nezařazen,Zařazen,Vyřazen
sm01datzar | D | Datum zařazení | Datum zařazení | Datum zařazení
sm01datvyr | D | Datum vyřazení | Datum vyřazení | Datum vyřazení
sp00uselar | C(9) | Účetní selektor artiklu | Účetní selektor artiklu | Účetní selektor artiklu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Spravovaný majetek - má org.sel. | SMMAJ sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Spravovaný majetek - má tech.sel. | SMMAJ sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Spravovaný majetek - má SKP | SMMAJ sp17idskp | 1,1 : 0,M | SPSKP sp17idskp |
Spravovaný majetek - zapsal uživatel | SMMAJ bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Spravovaný majetek - je artiklem | SMMAJ sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Spravovaný majetek - spravuje adresat | SMMAJ ad01id | 1,1 : 0,M | ADADSAT ad01id |
Spravovaný majetek - je umístěn | SMMAJ sm05id | 1,1 : 0,M | SMUMIS sm05id |
Událost spravovaného majetku - se tyka majetku | SMUDAL sp60id sp61id sm01por | 1,1 : 0,M | SMMAJ sp60id sp61id sm01por |
Rezervace - má artikl - RFI | SMREZER sp60id sp61id sm01por | 1,1 : 0,M | SMMAJ sp60id sp61id sm01por |

Indexy

Název | Primární | Výraz | Popis
ix_SMMAJ_sm01 |  | sm01 | Jednoznačná časová identifikace záznamu.
ix_SMMAJ_smmaj | P | sp60id, sp61id, sm01por | PI - sp60id+sp61id+sm01por
ix_SMMAJ_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_SMMAJ_sm05id |  | sm05id | Identifikátor umístění
ix_SMMAJ_sp61id |  | sp61id | Identifikace druhu artiklu
ix_SMMAJ_sp60id |  | sp60id | Identifikace artiklu
ix_SMMAJ_sm04komp |  | sm04komp | Majetek souvisí s komponentou. Majetek evidovaný ve spravovaném majetku může být sledován i v jiných komponentách. Např. investiční majetek je jak ve spravovaném majetku, tak v komponentě Odpis. Má-li spravovaný majetek v tomto atributu Inv.maj., může se uživatel přepnout do Odpisů a podívat se tam na další informace. A opačně, z Odpisů se lze podívat do Spravovaného majetku.
ix_SMMAJ_sm01rezerv |  | sm01rezerv | Majetek lze rezervovat. Pouze majetek, který má příznak Rezervovat = Ano lze použít v diáři rezervovaných prostředků.
ix_SMMAJ_sp17idskp |  | sp17idskp | Identifikace kategorie Standardní klasifikace produkce.
ix_SMMAJ_ad01id |  | ad01id | Identifikace adresáta
ix_SMMAJ_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_SMMAJ_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_SMMAJ_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SMMAJ_sm01prodej |  | sm01prodej | Vyřazeno prodejem
ix_SMMAJ_spartiknx |  |  |


SMREZER Rezervace

Popis

Objektem typu SMREZER je každý záznam, který obsahuje rezervaci majetku. Majetek si rezervuje uživatel pro vlastní použití formou podobnou diáři.

Atributy

Atribut | Typ | Návěští | Message | Popis
sm03 | C(12) | sm03 | Časová identifikace události. | Časová identifikace události.
sm03od | T | Začátek | Datum a čas od kterého rezervace začíná |
sm03do | T | Konec | Datum a čas ve kterém rezervace končí |
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sm01por | N(4,0) | Pořadové číslo | Pořadové číslo | Pořadové číslo
bw01uziv1 | C(6) | Pro | Identifikace uživatele systému | Identifikace uživatele systému - druhá identifikace předplňovaná většinou na pozadí
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
di02id | C(6) | Kategorie | Identifikátor kategorie. | Identifikátor kategorie předdefinovaného popisu. *** Dříve VYR_ID.
sm03text | C(40) | Popis | Popis důvodu rezervace | Popis důvodu rezervace
sm03koment | M | Komentář | Komentář k rezervaci | Komentář k rezervaci
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
bw01uziv | C(6) | Zapsal | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
sm03kolize | N(1,0) | sm03kolize | Pracovní položka. Normálně má hodnotu = Ne. Když dojde k překrytí rezervace jednoho prostředku v několika záznamech, ve všech se nastavuje Kolize = Ano. Při zobrazení v okně jsou tyto záznamy barevně odlišeny od ostatních. | Pracovní položka. Normálně má hodnotu = Ne. Když dojde k překrytí rezervace jednoho prostředku v několika záznamech, ve všech se nastavuje Kolize = Ano. Při zobrazení v okně jsou tyto záznamy barevně odlišeny od ostatních.
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Rezervace - zapsaná uživatelem | SMREZER bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Rezervace - pro uživatele | SMREZER bw01uziv1 | 1,1 : 0,M | BWUZIVAT bw01uziv |
Rezervace - je kategorie | SMREZER di02id | 1,1 : 0,M | DIPOPDIA di02id |
Rezervace - pro adresáta | SMREZER ad01id | 1,1 : 0,M | ADADSAT ad01id |
Rezervace - má obch.sel. | SMREZER sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Rezervace - má org.sel. | SMREZER sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Rezervace - má tech.věc.sel. | SMREZER sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Rezervace - patří operaci dokladu | SMREZER sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 0,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Rezervace - má druh majetku | SMREZER sp61id | 1,1 : 0,M | SPARTIKD sp61id |
Rezervace - má artikl - RFI | SMREZER sp60id sp61id sm01por | 1,1 : 0,M | SMMAJ sp60id sp61id sm01por |

Indexy

Název | Primární | Výraz | Popis
ix_SMREZER_sm03 | P | sm03 | Časová identifikace události.
ix_SMREZER_sm03od |  | sm03od |
ix_SMREZER_sm03do |  | sm03do |
ix_SMREZER_smmaj |  | sp60id, sp61id, sm01por | PI - sp60id+sp61id+sm01por
ix_SMREZER_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_SMREZER_sp61id |  | sp61id | Identifikace druhu artiklu
ix_SMREZER_sp60id |  | sp60id | Identifikace artiklu
ix_SMREZER_bw01uziv1 |  | bw01uziv1 | Identifikace uživatele systému - druhá identifikace předplňovaná většinou na pozadí
ix_SMREZER_ad01id |  | ad01id | Identifikace adresáta
ix_SMREZER_di02id |  | di02id | Identifikátor kategorie předdefinovaného popisu.
ix_SMREZER_sm03text |  | sm03text | Popis důvodu rezervace
ix_SMREZER_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_SMREZER_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_SMREZER_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_SMREZER_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SMREZER_sp00datzap |  | sp00datzap | Datum a čas zápisu záznamu události
ix_SMREZER_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_SMREZER_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému


SMUDAL Událost spravovaného majetku

Popis

Objektem typu SMUDAL je každý záznam, který obsahuje událost, která souvisí se spravovaným majetkem - např.: kontrola, revize, oprava majetku...

Atributy

Atribut | Typ | Návěští | Message | Popis
sm02 | C(12) | sm02 | Časová identifikace události. | Časová identifikace události.
sm02datum | D | Datum | Datum události | Datum události Nelze uvést datum před datem inicializace.
sm02zmena | N(1,0) | Druh | Změna - příjem / výdej | Změna - příjem / výdej
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sm01por | N(4,0) | Pořadové číslo | Pořadové číslo | Pořadové číslo
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sm05id | C(6) | Umístění | Identifikátor umístění | Identifikátor umístění
sm04komp | N(1,0) | sm04komp | Majetek souvisí s komponentou. | Majetek souvisí s komponentou. Majetek evidovaný ve spravovaném majetku může být sledován i v jiných komponentách. Např. investiční majetek je jak ve spravovaném majetku, tak v komponentě Odpis. Má-li spravovaný majetek v tomto atributu Inv.maj., může se uživatel přepnout do Odpisů a podívat se tam na další informace. A opačně, z Odpisů se lze podívat do Spravovaného majetku.
sm02text | C(40) | Popis | Popis události | Popis události
sm02mn | N(12,2) | Množství | Množství | Množství
sm02cenaj | N(20,4) | Cena | Cena majetku | Cena za jednoCena za jednotku Když po zadání množství zadá uživatel jednotkovou cenu, dopočte se cena celkem a opačně. Zadá-li cenu celkem, dopočte se cena za jednotku.
sm02cenac | N(20,4) | Cena | Cena celkem | Cena celkem Když po zadání množství zadá uživatel jednotkovou cenu, dopočte se cena celkem a opačně. Zadá-li cenu celkem, dopočte se cena za jednotku.
sm02koment | M | Komentář | Komentář k události | Komentář k události
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
bw01uziv | C(6) | Zapsal | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor druhu procesu | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sm02zmstav | N(1,0) | Změna stavu | Změna stavu majetku | Změna stavu majetku
sm02zmodpo | N(1,0) | Změna odpovědnosti | Změna odpovědnosti Ano/Ne | Změna odpovědnosti Ano/Ne
sm02zmumis | N(1,0) | Změna umístění | Změna umístění Ano/Ne | Změna umístění Ano/Ne
sm02zmcen | N(1,0) | Změna ceny | Změna ceny Ne/Nová cena/Přírůstek ceny | Změna ceny Ne/Nová cena/Přírůstek ceny

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost spravovaného majetku - zapsal uživatel | SMUDAL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost spravovaného majetku - má obch.sel. | SMUDAL sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost spravovaného majetku - má org.sel. | SMUDAL sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost spravovaného majetku - má tech.věc.sel. | SMUDAL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost spravovaného majetku - má adresáta | SMUDAL ad01id | 1,1 : 0,M | ADADSAT ad01id |
Událost spravovaného majetku - patří operaci dokladu | SMUDAL sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost spravovaného majetku - se tyka majetku | SMUDAL sp60id sp61id sm01por | 1,1 : 0,M | SMMAJ sp60id sp61id sm01por |
Událost spravovaného majetku - se vztahuje k umístění | SMUDAL sm05id | 1,1 : 0,M | SMUMIS sm05id |
Událost - skladba - se týká události SM | SMAHUD sm02 | 1,1 : 0,M | SMUDAL sm02 |

Indexy

Název | Primární | Výraz | Popis
ix_SMUDAL_sm02 | P | sm02 | Časová identifikace události.
ix_SMUDAL_sm02datum |  | sm02datum | Datum události Nelze uvést datum před datem inicializace.
ix_SMUDAL_smmaj |  | sp60id, sp61id, sm01por | PI - sp60id+sp61id+sm01por
ix_SMUDAL_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_SMUDAL_ad01id |  | ad01id | Identifikace adresáta
ix_SMUDAL_sp61id |  | sp61id | Identifikace druhu artiklu
ix_SMUDAL_sp60id |  | sp60id | Identifikace artiklu
ix_SMUDAL_sm05id |  | sm05id | Identifikátor umístění
ix_SMUDAL_sm02text |  | sm02text | Popis události
ix_SMUDAL_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_SMUDAL_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_SMUDAL_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_SMUDAL_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SMUDAL_sp00datzap |  | sp00datzap | Datum a čas zápisu záznamu události
ix_SMUDAL_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_SMUDAL_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SMUDAL_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.


SMUMIS Umístění

Popis

Objektem typu SMUMIS je každý záznam, který obsahuje možná umístění spravovaného majetku. Může odpovídat územnímu, nebo organizačnímu členění firmy uživatele.

Atributy

Atribut | Typ | Návěští | Message | Popis
sm05id | C(6) | Umístění | Identifikátor umístění | Identifikátor umístění
sm05umis | C(40) | Název | Název umístění | Popis umístění
sm05koment | M | sm05koment | Komentář k umístění | Komentář k umístění
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Umístění - zapsal uživatel | SMUMIS bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Umístění - se vztahuje k org.selektoru | SMUMIS sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Spravovaný majetek - je umístěn | SMMAJ sm05id | 1,1 : 0,M | SMUMIS sm05id |
Událost spravovaného majetku - se vztahuje k umístění | SMUDAL sm05id | 1,1 : 0,M | SMUMIS sm05id |
Karta - má umístění | ODKARTA sm05id | 1,1 : 0,M | SMUMIS sm05id |

Indexy

Název | Primární | Výraz | Popis
ix_SMUMIS_sm05id | P | sm05id | Identifikátor umístění
ix_SMUMIS_sm05umis |  | sm05umis | Popis umístění
ix_SMUMIS_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SMUMIS_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.


Tabulky SP...

SPARTALG | Algoritmus předplnění a validace artiklu
SPARTIKD | Druh artiklu
SPARTIKL | Artikl
SPARTIKN | Název artiklu
SPARTIKP | Prezentace artiklu
SPARTIKV | Výběr artiklu
SPARTIKX | Replikace druhu artiklu do komponenty
SPCERT | Systémové certifikáty
SPCINDO | Doplňující položka menu objektu
SPCINDV | Doplňující vlastnost formuláře
SPCINDVD | Omezení doplňující vlastnost činnosti pro vyvolání z operace
SPCINDVI | Knihovna vkládaného kódu prováděného akcí doplnění vlastnosti činnosti
SPCINDVK | Kategorie doplňující vlastnost formuláře/knihovny vkládaného kódu
SPCINDVT | Druh implementačního rozšíření
SPCISDOK | Číselná řada
SPCISDOP | Číselné řady v letech
SPCISDOX | Číselné řady v letech
SPCIVDV | Popis verze doplňující vlastnosti formuláře
SPCIVDVI | Popis verze knihovny vkládaného kódu
SPDAVKA | Událost dávkové komponenty
SPDKAT | Kategorie dokumentu
SPDOKFIL | Jméno souboru, který byl načten
SPDOKKAT | Kategorie přidělená dokumentu
SPDOKMEM | Záznam o posledním použitém druhu dokumentu a předloze
SPDOKOBS | Dokument
SPDOKPRO | Položka protokolu dokumentu
SPDOKREV | Verze dokumentu
SPDOKTYP | Druh dokumentu
SPDOKUZI | Práce s dokumentem
SPEXTPR | Externí příkaz
SPEXTPRD | Druh externího příkazu
SPEXTPRU | Poslední výběrové volání externího programu uživatele
SPEXTPRV | Vazba složeného externího příkazu
SPEXVPR | Popis verze externího příkazu
SPGRID | Doplnění mřížky činnosti formuláře
SPGRIDS | Sloupec doplnění mřížky činnosti formuláře
SPIMP | Definice importu/exportu
SPIMPA | Konverze atributu
SPIMPD | Druh importu
SPIMPP | Procesní import
SPIMPR | Konverze řádky
SPIMPS | Spojení
SPIMPV | Výběr pro import
SPJAZYK | Jazyk
SPKALEN | Obecný kalendář
SPKALENC | Část dne v kalendáři
SPKALEND | Den obecného kalendáře
SPKALENT | Den v týdnu kalendáře
SPKALENV | Výjimka v obecném kalendáři
SPKOMPUZ | Uzavřené období komponenty
SPKONST | Konstanty transformací a šablon
SPKOREK | Korektor transformovaných dat
SPMJ | Měrná jednotka
SPMJN | Měrná jednotka v jazyce
SPMJP | Vztah měrných jednotek
SPPOHZDR | Událost procesu
SPPRC | Proces
SPPRCOD | Operace procesu
SPPRCODE | Externí primární označení operace
SPPRCODK | Kód provedený po ukončení operace
SPPRCODV | Hodnota výrazu slučování operace
SPPRCODZ | Záložka operace
SPPRCSAL | Saldokontní hodnota procesu
SPPRCTEM | Označený proces pro tisk dokladu
SPPRCVO | Vazba operací v procesu
SPPRCZDR | Vazba proces - prezentovaná operace
SPPREDK | Obecná předkontace
SPPREDKD | Druh obecné předkontace
SPPREDKP | Položka obecné předkontace
SPPREDKQ | Položka obecné předkontace - pohled s datumem platnosti do
SPPREDKV | Význam položky obecné předkontace
SPPREDLO | Typ předlohy dokumentu
SPPREKLA | Předklad umístění nebo druhu
SPPREKLP | Přeložené návěští a poznámka proměnné volné karty nebo obecného výběru nebo importu
SPPREZ | Prezentace procesu
SPPREZPL | Druh operace obsažené v prezentaci procesu
SPPRISTD | Popis práv přístupu k věcem
SPPRISTI | Pravidlo inicializace přístupových práv při vstupu nového druhu
SPPRISTS | Přístupové právo skupiny uživatelů k věci
SPPRISTU | Přístupové právo uživatele k věci
SPPRISTV | Věc s přístupem
SPPROGAK | Akce volání programu dokumentu
SPPROGRA | Volání programu
SPSABL | Šablona
SPSABLA | Atribut pravidla definice šablony
SPSABLM | Poslední šablona spuštěná uživatelem v komponentě
SPSABLP | Proměnná šablony
SPSABLR | Pravidlo definice šablony
SPSABLT | Druh šablony
SPSEOB | Obchodní selektor
SPSEOR | Organizační selektor
SPSETV | Technicko-věcný selektor
SPSEUMIS | Umístění selektoru
SPSKP | SKP
SPSQLFCE | BM funkce pro implementační rozšíření ISBM
SPSTATDI | Druh hodnoty
SPSTATDS | Druh saldokontní hodnoty procesu
SPSTATIS | Statistická hodnota
SPSTROM | Uzel obecného stromu
SPSTROMA | Zobrazovaný atribut obecného stromu
SPSTROMD | Druh uzlu obecného stromu
SPSTROMF | Funkce uzlu obecného stromu
SPSTROMI | Podmíněná ikona pro uzel obecného stromu
SPSTROMP | Vazba uzlů obecného stromu
SPSUBSYA | Vstupní atribut komponenty
SPSUBSYB | Výstupní atribut komponenty
SPSUBSYS | Komponenta
SPTEXTY | Volný text k události
SPTEXTYN | Obsah volného textu
SPTRN | Transformace
SPTRNA | Konverze atributů obsažených v pravidlu transformace
SPTRNH | Výraz pro konverzi atributů
SPTRNMP | Míra plnění
SPTRNMPC | Pohled SPTRNMP cil
SPTRNMPX | Pohled SPTRNMP zdroj->cil
SPTRNMPZ | Pohled SPTRNMP ZDROJ
SPTRNPRE | Obecná předkontace pro transformaci
SPTRNR | Pravidlo transformace
SPTRNW | Doplnění pohledu transformace
SPTRNWZ | Připojený záznam doplnění pohledu tranformace
SPTYP | Druh procesu/operace
SPTYPAL | Algoritmus
SPTYPDSP | Dynamické spojení operací
SPTYPDSX | Operace používající dynamické spojení
SPTYPEI | Import/Export operace
SPTYPFOL | Skupina procesů / předloh pro zobrazení v menu
SPTYPGO | Vyvolání operace z hlavního procesu
SPTYPMAS | Vlastnosti atributu v masce operace
SPTYPOD | Druh operace v druhu procesu
SPTYPODK | Kód provedený po ukončení operace a maska operace v procesu
SPTYPOMO | Osobní maska operace
SPTYPPAR | Rozšířené parametry operace/procesu
SPTYPPRT | Výběr tiskové předlohy procesu
SPTYPRUM | Číselná řada operace pro umístění
SPTYPSUB | Určení typu subjektu spojení adresáta pro druh operace
SPTYPUD | Typ události komponenty
SPTYPUDV | Typ události komponenty použitelný pro druh operace komponenty
SPTYPUZ | Výraz zobrazení informací o události ve stromu pro danou operaci
SPTYPVAD | Kredit adresáta pro druh hodnoty v operaci
SPTYPVLU | Pravidlo validace zápisu dat operace
SPTYPVO | Vazba druhů operací v druhu procesu
SPVOLST | Volná karta
SPVOLSTA | Atribut volné karty
SPVOLSTT | Druh volné karty
SPVOLSTU | Užití volné karty
SPVOLSTV | Definice volného pohledu volné karty
SPVYBER | Obecný výběr
SPVYBERP | Proměnná výběru
SPVYBERR | Relace výběru
SPVYBERU | Užití obecného výběru
SPVYBERV | Předepsané užití předlohy výstupu s obecným výběrem
SPXMLTAG | Tag XML dokumentu
SPXMLTDV | Doplňující vlastnost formuláře vyvolávaná tagem XML dokumentu
SPXMLVAZ | Vazba mezi tagy XML dokumentu
SPXSLSKP | Skupina XSLT předloh
SPXSLTAG | Uzel XSLT předlohy
SPXSLVAZ | Vazba mezi tagy XSL definice
SPZMENY | Evidence změn obsahu záznamů komponent a logických věcí

Viz.také

SPARTIKD Druh artiklu | SPARTIKL Artikl | SPARTIKN Název artiklu | SPARTIKP Prezentace artiklu | SPARTIKV Výběr artiklu | SPARTIKX Replikace druhu artiklu do komponenty | SPCISDOK Číselná řada | SPCISDOX Číselné řady v letech | SPDAVKA Událost dávkové komponenty | SPDOKMEM Záznam o posledním použitém druhu dokumentu a předloze | SPDOKOBS Dokument | SPDOKTYP Druh dokumentu | SPDOKUZI Práce s dokumentem | SPEXTPR Externí příkaz | SPEXTPRD Druh externího příkazu | SPIMP Definice importu/exportu | SPIMPA Konverze atributu | SPIMPD Druh importu | SPIMPP Procesní import | SPIMPR Konverze řádky | SPIMPS Spojení | SPIMPV Výběr pro import | SPJAZYK Jazyk | SPKOMPUZ Uzavřené období komponenty | SPKONST Konstanty transformací a šablon | SPMJ Měrná jednotka | SPMJN Měrná jednotka v jazyce | SPMJP Vztah měrných jednotek | SPPOHZDR Událost procesu | SPPRC Proces | SPPRCOD Operace procesu | SPPRCODE Externí primární označení operace | SPPRCODK Kód provedený po ukončení operace | SPPRCODV Hodnota výrazu slučování operace | SPPRCODZ Záložka operace | SPPRCSAL Saldokontní hodnota procesu | SPPRCTEM Označený proces pro tisk dokladu | SPPRCVO Vazba operací v procesu | SPPRCZDR Vazba proces - prezentovaná operace | SPPREDK Obecná předkontace | SPPREDKP Položka obecné předkontace | SPPREDKV Význam položky obecné předkontace | SPPREDLO Typ předlohy dokumentu | SPPREZ Prezentace procesu | SPPREZPL Druh operace obsažené v prezentaci procesu | SPPRISTS Přístupové právo skupiny uživatelů k věci | SPPRISTU Přístupové právo uživatele k věci | SPPRISTV Věc s přístupem | SPPROGRA Volání programu | SPSABL Šablona | SPSABLA Atribut pravidla definice šablony | SPSABLM Poslední šablona spuštěná uživatelem v komponentě | SPSABLP Proměnná šablony | SPSABLR Pravidlo definice šablony | SPSABLT Druh šablony | SPSEOB Obchodní selektor | SPSEOR Organizační selektor | SPSETV Technicko-věcný selektor | SPSKP SKP | SPSTATDI Druh hodnoty | SPSTATDS Druh saldokontní hodnoty procesu | SPSTATIS Statistická hodnota | SPTEXTY Volný text k události | SPTEXTYN Obsah volného textu | SPTRN Transformace | SPTRNA Konverze atributů obsažených v pravidlu transformace | SPTRNH Výraz pro konverzi atributů | SPTRNMP Míra plnění | SPTRNMPC Pohled SPTRNMP cil | SPTRNMPX Pohled SPTRNMP zdroj->cil | SPTRNMPZ Pohled SPTRNMP ZDROJ | SPTRNR Pravidlo transformace | SPTRNW Doplnění pohledu transformace | SPTYP Druh procesu/operace | SPTYPAL Algoritmus | SPTYPDSP Dynamické spojení operací | SPTYPDSX Operace používající dynamické spojení | SPTYPEI Import/Export operace | SPTYPFOL Skupina procesů / předloh pro zobrazení v menu | SPTYPGO Vyvolání operace z hlavního procesu | SPTYPMAS Vlastnosti atributu v masce operace | SPTYPOD Druh operace v druhu procesu | SPTYPODK Kód provedený po ukončení operace a maska operace v procesu | SPTYPOMO Osobní maska operace | SPTYPPAR Rozšířené parametry operace/procesu | SPTYPPRT Výběr tiskové předlohy procesu | SPTYPRUM Číselná řada operace pro umístění | SPTYPUZ Výraz zobrazení informací o události ve stromu pro danou operaci | SPTYPVAD Kredit adresáta pro druh hodnoty v operaci | SPTYPVLU Pravidlo validace zápisu dat operace | SPTYPVO Vazba druhů operací v druhu procesu | SPVOLST Volná karta | SPVOLSTA Atribut volné karty | SPVOLSTT Druh volné karty | SPVOLSTV Definice volného pohledu volné karty | SPVYBER Obecný výběr | SPVYBERP Proměnná výběru | SPVYBERR Relace výběru | SPZMENY Evidence změn obsahu záznamů komponent a logických věcí | SPCINDV Doplňující vlastnost formuláře | SPCINDVD Omezení doplňující vlastnost činnosti pro vyvolání z operace | SPCINDVI Knihovna vkládaného kódu prováděného akcí doplnění vlastnosti činnosti | SPCINDVT Druh implementačního rozšíření | SPDOKREV Verze dokumentu | SPSTROM Uzel obecného stromu | SPSTROMD Druh uzlu obecného stromu | SPSTROMP Vazba uzlů obecného stromu | SPXMLTAG Tag XML dokumentu | SPXMLVAZ Vazba mezi tagy XML dokumentu | SPXSLSKP Skupina XSLT předloh | SPXSLTAG Uzel XSLT předlohy | SPXSLVAZ Vazba mezi tagy XSL definice | SPXMLTDV Doplňující vlastnost formuláře vyvolávaná tagem XML dokumentu | SPCINDVK Kategorie doplňující vlastnost formuláře/knihovny vkládaného kódu | SPSTROMA Zobrazovaný atribut obecného stromu | SPSTROMF Funkce uzlu obecného stromu | SPPREKLA Předklad umístění nebo druhu | SPSTROMI Podmíněná ikona pro uzel obecného stromu | SPDOKPRO Položka protokolu dokumentu | SPPROGAK Akce volání programu dokumentu | SPEXTPRU Poslední výběrové volání externího programu uživatele | SPEXTPRV Vazba složeného externího příkazu | SPKALEN Obecný kalendář | SPKALENC Část dne v kalendáři | SPKALEND Den obecného kalendáře | SPKALENT Den v týdnu kalendáře | SPKALENV Výjimka v obecném kalendáři | SPTRNPRE Obecná předkontace pro transformaci | SPARTALG Algoritmus předplnění a validace artiklu | SPCISDOP Číselné řady v letech | SPGRID Doplnění mřížky činnosti formuláře | SPGRIDS Sloupec doplnění mřížky činnosti formuláře | SPPREDKD Druh obecné předkontace | SPSQLFCE BM funkce pro implementační rozšíření ISBM | SPVOLSTU Užití volné karty | SPVYBERU Užití obecného výběru | SPVYBERV Předepsané užití předlohy výstupu s obecným výběrem | SPPREDKQ Položka obecné předkontace - pohled s datumem platnosti do | SPPREKLP Přeložené návěští a poznámka proměnné volné karty nebo obecného výběru | SPPRISTI Pravidlo inicializace přístupových práv při vstupu nového druhu | SPTRNWZ Připojený záznam doplnění pohledu tranformace | SPDKAT Kategorie dokumentu | SPDOKFIL Jméno souboru, který byl načten | SPDOKKAT Kategorie přidělená dokumentu | SPSEUMIS Umístění selektoru | SPTYPSUB Určení typu subjektu spojení adresáta pro druh operace | SPTYPUD Typ události komponenty | SPTYPUDV Typ události komponenty použitelný pro druh operace komponenty | SPCINDO Doplňující položka menu objektu | SPCERT Systémové certifikáty | SPKOREK Korektor transformovaných dat | SPCIVDV Popis verze doplňující vlastnosti formuláře | SPCIVDVI Popis verze knihovny vkládaného kódu | SPEXVPR Popis verze externího příkazu


SPARTALG Algoritmus předplnění a validace artiklu

Popis

Algoritmus předplnění a validace artiklu

Atributy

Atribut | Typ | Návěští | Message | Popis
spe3 | C(12) | Algoritmus předplnění a validace | Jednoznačná časová identifikace | Jednoznačná časová identifikace
spe3nazalg | C(40) | Algoritmus | Název algoritmu | Název algoritmu
spe3kod | M | Předplnění | Kód algoritmu předplnění v jazyce Foxpro | Kód algoritmu předplnění v jazyce Foxpro
spe3kodval | M | Validace | Kód algoritmu validace v jazyce Foxpro | Kód algoritmu validace v jazyce Foxpro
spe3koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh artiklu - používá algoritmus předplnění identifikace nového artiklu | SPARTIKD spe3 | 1,1 : 0,M | SPARTALG spe3 |

Indexy

Název | Primární | Výraz | Popis
ix_SPARTALG_spe3 | P | spe3 | Jednoznačná časová identifikace
ix_SPARTALG_spe3nazalg |  | spe3nazalg | Název algoritmu


SPARTIKD Druh artiklu

Popis

Druh artiklu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp61nazdru | C(40) | Název druhu artiklu | Název druhu artiklu | Název druhu artiklu
sp61koment | M | sp61koment | Komentář ke druhu artiklu | Komentář ke druhu artiklu
ob01sklado | N(1,0) | ob01sklado | Charakter artiklu - skladovaný, neskladovaný | Příznak artiklu, který je skladován
ob02vzucet | N(1,0) | Vztah k účetnictví | Vztah k účetnictví - zboží, materiál, výrobek, služba ... | Vztah k účetnictví
ob02vzdph | N(1,0) | Vztah ceny k DPH | Vztah ceny artiklu k DPH - cena bez DPH,cena včetně DPH, cena včetně DPH z rozdílu nákladů a konečné ceny | Vztah ceny artiklu k DPH - cena bez DPH,cena s DPH, ....
dp03id | C(3) | Typ zd.pl. | Identifikace typu zdanitelného plnění | Identifikace typu zdanitelného plnění
sp61evihis | N(1,0) | sp61evihis | Předplňovat - evidovat historii ceny artiklu | Předplňovat - evidovat historii ceny artiklu
pa13idart | C(12) | Klasifikace artiklu | Identifikace klasifikace objektu artiklu | Identifikace klasifikace objektu artiklu
bw55objeca | C(2) | bw55objeca | Identifikace objektu BM - artiklu | Identifikace objektu BM - artiklu
bw95id | C(6) | Barva | Identifikace barvy RGB | Identifikace barvy RGB
bw95id2 | C(6) | Barva | Identifikace barvy RGB | Identifikace barvy RGB
spe3 | C(12) | Algoritmus předplnění a validace | Jednoznačná časová identifikace | Jednoznačná časová identifikace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh artiklu - předplňuje typ zdanitelného plnění | SPARTIKD dp03id | 0,1 : 0,M | DPZPT dp03id |
Druh artiklu - předplňuje klasifikaci objektu artiklu | SPARTIKD pa13idart bw55objeca | 1,1 : 0,M | PAOBJDRU pa13id bw55objec |
Druh artiklu - má definovanou barvu písma | SPARTIKD bw95id | 1,1 : 0,M | BWRGBCOL bw95id |
Druh artiklu - má definovanou barvu pozadí | SPARTIKD bw95id2 | 1,1 : 0,M | BWRGBCOL bw95id |
Druh artiklu - používá algoritmus předplnění identifikace nového artiklu | SPARTIKD spe3 | 1,1 : 0,M | SPARTALG spe3 |
Rezervace - má druh majetku | SMREZER sp61id | 1,1 : 0,M | SPARTIKD sp61id |
Karta - ma druh artiklu | ODKARTA sp61id | 1,1 : 0,M | SPARTIKD sp61id |
Událost odpisovaného majetku - má druh artiklu | ODUDAL sp61id | 1,1 : 0,M | SPARTIKD sp61id |
Výkon - má druh artiklu | ODVYKON sp61id | 1,1 : 0,M | SPARTIKD sp61id |
Artikl - je druhu | SPARTIKL sp61id | 1,1 : 0,M | SPARTIKD sp61id |
Replikace druhu artiklu do komponenty - se týká druhu artiklu | SPARTIKX sp61id | 1,1 : 0,M | SPARTIKD sp61id |
Artikl výroby - jsou určitým druhem artiklu | TPVYROB sp61id | 1,1 : 0,M | SPARTIKD sp61id |
Artikl výroby - je druhem vadného artiklu výroby | TPVYROB sp61id2 | 0,1 : 0,M | SPARTIKD sp61id |
Položka kusovníku TPV - obsahuje druh artiklu | TPKUSOV sp61id | 1,1 : 0,M | SPARTIKD sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_SPARTIKD_sp61id | P | sp61id | Identifikace druhu artiklu
ix_SPARTIKD_sp61nazdru |  | sp61nazdru | Název druhu artiklu
ix_SPARTIKD_dp03id |  | dp03id | Identifikace typu zdanitelného plnění
ix_SPARTIKD_paobjdra |  | pa13idart, bw55objeca | CI - pa13idart+bw55objeca
ix_SPARTIKD_bw95id |  | bw95id | Identifikace barvy RGB
ix_SPARTIKD_bw95id2 |  | bw95id2 | Identifikace barvy RGB
ix_SPARTIKD_spe3 |  | spe3 | Jednoznačná časová identifikace


SPARTIKL Artikl

Popis

Artikl

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60 | C(12) | sp60 | Jednoznačná časová identifikace artiklu | Jednoznačná časová identifikace artiklu
sp60evihis | N(1,0) | sp60evihis | Evidovat historii ceny artiklu | Evidovat historii ceny artiklu
sp24idmj | C(3) | MJ | Identifikátor měrné jednotky | Identifikátor měrné jednotky

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Artikl - je druhu | SPARTIKL sp61id | 1,1 : 0,M | SPARTIKD sp61id |
Předmět projektu - je artiklem | NKPREDPR sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Aktuální hodnota PP - je pro artikl | NKAH sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Kategorie zvířat - je artiklem | SZARTIKL sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Artikly personalistiky - je artiklem | MZPERART sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Hodnota parametru - se vztahuje k artiklu | PAHODNOT sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Událost správy artiklu - se týká artiklu | SAUDAL sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Artikl obecné komponenty - je artiklem | OKARTIKL sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Spravovaný majetek - je artiklem | SMMAJ sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Karta - odpovídá artiklu | ODKARTA sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Obchodovatelný artikl - je artiklem | OBARTIKL sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Vztah měrných jednotek - se týká artiklu | SPMJP sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Název artiklu - týká se artiklu | SPARTIKN sp60id sp61id | 1,1 : 1,M s rušením | SPARTIKL sp60id sp61id |
Položka ceníku artiklu - se týká artiklu | OBCENIK sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Skladovaný artikl - je artiklem | MTARTIKL sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Prezentace artiklu - patří artiklu | SPARTIKP sp60id sp61id | 1,1 : 1,1 s rušením | SPARTIKL sp60id sp61id |
Artikl výroby - odpovídá artiklu | TPVYROB sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Artikl mezd - je artiklem | MZARTIKL sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Vozidlo - expedice - je artiklem | EXARTIKL sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_SPARTIKL_spartikl | P | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_SPARTIKL_sp61id |  | sp61id | Identifikace druhu artiklu
ix_SPARTIKL_sp60id |  | sp60id | Identifikace artiklu
ix_SPARTIKL_spartiknx |  |  |
ix_SPARTIKL_sp60 |  | sp60 | Jednoznačná časová identifikace artiklu
ix_SPARTIKL_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky


SPARTIKN Název artiklu

Popis

Název artiklu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp38id | C(3) | Jazyk | Identifikace jazyka | Identifikace jazyka
sp62artikl | C(60) | Název artiklu | Název artiklu | Název artiklu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Název artiklu - týká se artiklu | SPARTIKN sp60id sp61id | 1,1 : 1,M s rušením | SPARTIKL sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_SPARTIKN_spartikn | P | sp60id, sp61id, sp38id | Primární index názvu artiklu
ix_SPARTIKN_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_SPARTIKN_sp62artikl |  | sp62artikl | Název artiklu
ix_SPARTIKN_sp38id |  | sp38id | Identifikace jazyka
ix_SPARTIKN_sp60id |  | sp60id | Identifikace artiklu


SPARTIKP Prezentace artiklu

Popis

Prezentace artiklu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp91foto | G | sp91foto | Prezentace artiklu | Fotografie artiklu
sp91left | N(4,0) | sp91left | Umístění LEFT | Umístění LEFT
sp91top | N(4,0) | sp91top | Umístění TOP | Umístění TOP
sp91height | N(4,0) | sp91height | Umístění HEIGHT | Umístění HEIGHT
sp91width | N(4,0) | sp91width | Umístění WIDTH | Umístění WIDTH
sp91 | C(10) | sp91 | Jednoznačná časová identifikace | Jednoznačná časová identifikace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Prezentace artiklu - patří artiklu | SPARTIKP sp60id sp61id | 1,1 : 1,1 s rušením | SPARTIKL sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_SPARTIKP_spartikl | P | sp60id, sp61id | Primární index artiklu sp60id+sp61id


SPARTIKV Výběr artiklu

Popis

Výběr artiklu pro zápis na pozadí

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Výběr artiklu - je uživatele | SPARTIKV bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_SPARTIKV_spartikv | P | sp60id, sp61id, bw01uziv |
ix_SPARTIKV_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_SPARTIKV_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPARTIKX Replikace druhu artiklu do komponenty

Popis

Replikace druhu artiklu do komponenty

Atributy

Atribut | Typ | Návěští | Message | Popis
bw10nazev | C(8) | Tabulka | Název entity | Název entity
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Replikace druhu artiklu do komponenty - se týká druhu artiklu | SPARTIKX sp61id | 1,1 : 0,M | SPARTIKD sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_SPARTIKX_spartikx | P | bw10nazev, sp61id |
ix_SPARTIKX_sp61id |  | sp61id | Identifikace druhu artiklu


SPCERT Systémové certifikáty

Popis

Systémové certifikáty

Atributy

Atribut | Typ | Návěští | Message | Popis
spg1id | C(6) | Certifikát | Identifikátor certifikátu | Identifikátor certifikátu
spe1id | C(6) | Druh | Identifikátor druhu obecné předkontace | Identifikátor druhu obecné předkontace
spg1nazev | C(40) | Název certifikátu | Název certifikátu | Název certifikátu
spg1heslo | M | spg1heslo | Uložené heslo souboru certifikátu | Uložené heslo souboru certifikátu
spg1koment | M | Poznámka | Poznámka | Poznámka
spg1soubor | M | Soubor | Soubor certifikátu | Soubor certifikátu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Systémové certifikáty - je druhu | SPCERT spe1id | 1,1 : 0,M | SPPREDKD spe1id |

Indexy

Název | Primární | Výraz | Popis
ix_SPCERT_spg1id | P | spg1id | Identifikátor certifikátu
ix_SPCERT_spe1id |  | spe1id | Identifikátor druhu obecné předkontace
ix_SPCERT_spg1nazev |  | spg1nazev | Název certifikátu


SPCINDO Doplňující položka menu objektu

Popis

Doplňující položka menu objektu

Atributy

Atribut | Typ | Návěští | Message | Popis
spg0id | C(6) | Položka | Identifikace doplňující položky menu objektu | Identifikace doplňující položky menu objektu
spa6id | C(6) | Druh | Identifikace druhu implemetačního rozšíření | Identifikace druhu implemetačního rozšíření
bw55objec | C(2) | Identifikace objektu BM | Identifikace objektu BM | Identifikace objektu BM
spg0porad | N(3,0) | Pořadí | Pořadí položky menu | Pořadí položky menu
spg0prompt | M | Název | Název položky menu | Název položky menu
spg0when | M | Podmínka | Podmínka zařazení položky menu - script v jazyce Foxpro | Podmínka zařazení položky menu - script v jazyce Foxpro
spg0typ | N(1,0) | Typ kódu | Způsob spuštění kódu - kompilovaný/nekompilovaný kód | Způsob spuštění kódu - kompilovaný/nekompilovaný kód
spg0kod | M | Kód | Kód v jazyce Foxpro vyvolaný při výběru položky menu | Kód v jazyce Foxpro vyvolaný při výběru položky menu
spg0koment | M | Poznámka | Poznámka | Poznámka
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Doplňující položka menu objektu - je druhu | SPCINDO spa6id | 1,1 : 0,M | SPCINDVT spa6id |

Indexy

Název | Primární | Výraz | Popis
ix_SPCINDO_spg0id | P | spg0id | Identifikace doplňující položky menu objektu
ix_SPCINDO_spa6id |  | spa6id | Identifikace druhu implemetačního rozšíření
ix_SPCINDO_bw55objec |  | bw55objec | Identifikace objektu BM
ix_SPCINDO_spg0porad |  | spg0porad | Pořadí položky menu
ix_SPCINDO_sp00datakt |  | sp00datakt | Datum aktualizace


SPCINDV Doplňující vlastnost formuláře

Popis

Doplňující vlastnost formuláře

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
spa7id | C(6) | Vlastnost | Identifikace doplňující vlastnosti činnosti | Identifikace doplňující vlastnosti činnosti
bw02krokx | C(6) | F2-reakce | Identifikace činnosti | Identifikace činnosti
bw81id | C(6) | MPV | Identifikace metapředlohy výstupu | Identifikace makropředlohy výstupu
bw10nazev | C(8) | Tabulka | Název entity | Název entity
sp64nazev | C(8) | Karta | Název volné karty | Identifikace volné karty
spa6id | C(6) | Druh | Identifikace druhu implemetačního rozšíření | Identifikace druhu implemetačního rozšíření
spc1id | C(6) | Kategorie | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
spa7porad | N(3,0) | Pořadí | Pořadí provádění akce doplňující vlastnosti činnosti | Pořadí provádění akce doplňující vlastnosti činnosti
spa7nazvla | C(40) | Název | Název doplňující vlastnosti činnosti | Název doplňující vlastnosti činnosti
spa7verze | N(6,3) | Verze | Verze doplňující vlastnosti formuláře | Verze doplňující vlastnosti formuláře
spa7koment | M | Poznámka | Poznámka | Poznámka
spa7kod | M | Kód | Kód provedený akcí vlastnosti činnosti v jazyce Foxpro | Kód provedený akcí vlastnosti činnosti v jazyce Foxpro
spa7typ | N(1,0) | Typ | Typ provené akce | Typ provené akce
spa7mpvnad | N(1,0) | Určení metapředlohy | Určení metapředlohy | Určení metapředlohy
spa7autom | N(1,0) | Automaticky | Vyvolat akci automaticky při spuštění | Vyvolat akci automaticky při spuštění
spa7menu | N(1,0) | Menu | Zařadit do menu | Zařadit do menu
spa7klaves | C(3) | Klávesa | CTRL-klávesa pro spuštění z menu | Klávesa pro spuštění z menu
spa7volnad | N(1,0) | Určení volné karty | Určení volné karty | Určení volné karty
spa7menudp | M | Dyn.podm. | Dynamická podmínka zařazení do menu | Dynamická podmínka zařazení do menu
spa7menusp | M | Stat.podm. | Statická podmínka zařazení do menu | Statická podmínka zařazení do menu
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace
sp00jmeakt | C(40) | Změnil | Jméno uživatele systému, který změnil záznam | Jméno uživatele systému, který změnil záznam
spe4 | C(12) | Doplnění | Identifikace doplnění mřížky formuláře | Identifikace doplnění mřížky formuláře - Jednoznačná časová identifikace
spa7style | N(1,0) | Řez písma | Řez písma položky menu - Normální/Kurzíva/Tučné/Tučná kurzíva | Řez písma položky menu - Normální/Kurzíva/Tučné/Tučná kurzíva

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Doplňující vlastnost formuláře - spouští metapředlohu | SPCINDV bw02krokx bw81id | 0,1 : 0,M | BWPRINS bw02krok bw81id |
Doplňující vlastnost formuláře - spouští volnou kartu | SPCINDV bw10nazev sp64nazev | 0,1 : 0,M | SPVOLST bw10nazev sp64nazev |
Doplňující vlastnost formuláře - je druhu | SPCINDV spa6id | 1,1 : 0,M | SPCINDVT spa6id |
Doplňující vlastnost formuláře - je kategorie | SPCINDV spc1id | 1,1 : 0,M | SPCINDVK spc1id |
Doplňující vlastnost formuláře - aktivuje doplnění mřížky činnosti formuláře | SPCINDV spe4 | 0,1 : 0,M | SPGRID spe4 |
Omezení doplňující vlastnost činnosti pro vyvolání z operace - je platné pro doplňující vlastnost činnosti | SPCINDVD bw02krok spa7id | 1,1 : 0,M s rušením | SPCINDV bw02krok spa7id |
Doplňující vlastnost formuláře vyvolávaná tagem XML dokumentu - určuje doplňující vlastnost formuláře | SPXMLTDV bw02krok spa7id | 1,1 : 0,M | SPCINDV bw02krok spa7id |
Popis verze doplňující vlastnosti formuláře - je popisem verze doplňující vlastnosti formuláře | SPCIVDV bw02krok spa7id | 1,1 : 0,M | SPCINDV bw02krok spa7id |

Indexy

Název | Primární | Výraz | Popis
ix_SPCINDV_spcindv | P | bw02krok, spa7id | PI - bw02krok+spa6id
ix_SPCINDV_bwprinsx |  | bw02krokx, bw81id | PI - bw02krokx+bw81id
ix_SPCINDV_spvolst |  | bw10nazev, sp64nazev | PI - bw10nazev+sp64nazev
ix_SPCINDV_bw02krok |  | bw02krok | Identifikace činnosti
ix_SPCINDV_spa6id |  | spa6id | Identifikace druhu implemetačního rozšíření
ix_SPCINDV_spc1id |  | spc1id | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
ix_SPCINDV_spa7nazvla |  | spa7nazvla | Název doplňující vlastnosti činnosti
ix_SPCINDV_spa7verze |  | spa7verze | Verze doplňující vlastnosti formuláře
ix_SPCINDV_sp00datakt |  | sp00datakt | Datum aktualizace
ix_SPCINDV_spe4 |  | spe4 | Identifikace doplnění mřížky formuláře - Jednoznačná časová identifikace


SPCINDVD Omezení doplňující vlastnost činnosti pro vyvolání z operace

Popis

Omezení doplňující vlastnost činnosti pro vyvolání z operace

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
spa7id | C(6) | Vlastnost | Identifikace doplňující vlastnosti činnosti | Identifikace doplňující vlastnosti činnosti
sp07idtypd | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu procesu
sp06idsubd | C(3) | sp06idsubd | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
spa5koment | M | Poznámka | Poznámka | Poznámka
spa5ready | N(1,0) | Stav operace připravena | Podle stavu operace připravena | Podle stavu operace připravena
spa5zahaje | N(1,0) | Stav operace zahájena | Podle stavu operace zahájena | Podle stavu operace zahájena
spa5ukonce | N(1,0) | Stav operace ukončena | Podle stavu operace ukončena | Podle stavu operace ukončena

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Omezení doplňující vlastnost činnosti pro vyvolání z operace - jsou vlastnostmi uzlu | SPCINDVD sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Omezení doplňující vlastnost činnosti pro vyvolání z operace - jsou vlastnostmi uzlu v druh procesu | SPCINDVD sp07idtypd sp06idsubd | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Omezení doplňující vlastnost činnosti pro vyvolání z operace - je platné pro doplňující vlastnost činnosti | SPCINDVD bw02krok spa7id | 1,1 : 0,M s rušením | SPCINDV bw02krok spa7id |

Indexy

Název | Primární | Výraz | Popis
ix_SPCINDVD_spcindvd | P | bw02krok, spa7id, sp07idtypd, sp06idsubd, sp07idtyp, sp06idsubs, sp33porad |
ix_SPCINDVD_spcindv |  | bw02krok, spa7id | PI - bw02krok+spa6id
ix_SPCINDVD_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SPCINDVD_sptypd |  | sp07idtypd, sp06idsubd | Index podle typu dokladu a subsystému dokladu


SPCINDVI Knihovna vkládaného kódu prováděného akcí doplnění vlastnosti činnosti

Popis

Knihovna vkládaného kódu prováděného akcí doplnění vlastnosti činnosti

Atributy

Atribut | Typ | Návěští | Message | Popis
spa8id | C(6) | Knihovna | Identifikace vkládaného kódu | Identifikace vkládaného kódu
spa8verze | N(6,3) | Verze | Verze knihovny vkládaného kódu | Verze knihovny vkládaného kódu
spa6id | C(6) | Druh | Identifikace druhu implemetačního rozšíření | Identifikace druhu implemetačního rozšíření
spc1id | C(6) | Kategorie | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
spa8popkod | C(40) | Popis knihovny | Popis knihovny vkládaného kódu | Popis knihovny vkládaného kódu
spa8kod | M | Kód | Obsah knihovny vkládaného kódu | Obsah knihovny vkládaného kódu
spa8koment | M | Poznámka | Poznámka | Poznámka
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace
sp00jmeakt | C(40) | Změnil | Jméno uživatele systému, který změnil záznam | Jméno uživatele systému, který změnil záznam

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Knihovna vkládaného kódu prováděného akcí doplnění vlastnosti činnosti - je druhu | SPCINDVI spa6id | 1,1 : 0,M | SPCINDVT spa6id |
Knihovna vkládaného kódu prováděného akcí doplnění vlastnosti činnosti - je kategorie | SPCINDVI spc1id | 1,1 : 0,M | SPCINDVK spc1id |
Popis verze knihovny vkládaného kódu - je popisem knihovny | SPCIVDVI spa8id | 1,1 : 0,M | SPCINDVI spa8id |

Indexy

Název | Primární | Výraz | Popis
ix_SPCINDVI_spa8id | P | spa8id | Identifikace vkládaného kódu
ix_SPCINDVI_spa8verze |  | spa8verze | Verze knihovny vkládaného kódu
ix_SPCINDVI_spa6id |  | spa6id | Identifikace druhu implemetačního rozšíření
ix_SPCINDVI_spc1id |  | spc1id | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
ix_SPCINDVI_spa8popkod |  | spa8popkod | Popis knihovny vkládaného kódu
ix_SPCINDVI_sp00datakt |  | sp00datakt | Datum aktualizace


SPCINDVK Kategorie doplňující vlastnost formuláře/knihovny vkládaného kódu

Popis

Kategorie doplňující vlastnost formuláře/knihovny vkládaného kódu

Atributy

Atribut | Typ | Návěští | Message | Popis
spc1id | C(6) | Kategorie | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
spc1nazkat | C(40) | Název kategorie | Název kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu | Název kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
spc1koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Doplňující vlastnost formuláře - je kategorie | SPCINDV spc1id | 1,1 : 0,M | SPCINDVK spc1id |
Knihovna vkládaného kódu prováděného akcí doplnění vlastnosti činnosti - je kategorie | SPCINDVI spc1id | 1,1 : 0,M | SPCINDVK spc1id |
Akce volání programu dokumentu - patří do kategorie | SPPROGAK spc1id | 1,1 : 0,M | SPCINDVK spc1id |
Externí příkaz - je v kategorii | SPEXTPR spc1id | 1,1 : 0,M | SPCINDVK spc1id |

Indexy

Název | Primární | Výraz | Popis
ix_SPCINDVK_spc1id | P | spc1id | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
ix_SPCINDVK_spc1nazkat |  | spc1nazkat | Název kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu


SPCINDVT Druh implementačního rozšíření

Popis

Druh implementačního rozšíření

Atributy

Atribut | Typ | Návěští | Message | Popis
spa6id | C(6) | Druh | Identifikace druhu implemetačního rozšíření | Identifikace druhu implemetačního rozšíření
spa6nazdru | C(40) | Název druhu | Název druhu implemetačního rozšíření | Název druhu implemetačního rozšíření
spa6koment | M | Poznámka | Poznámka | Poznámka
spa6datum | T | Datum vzniku | Datum založení druhu | Datum založení druhu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh implementačního rozšíření - byl založen uživatelem | SPCINDVT bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Doplňující vlastnost formuláře - je druhu | SPCINDV spa6id | 1,1 : 0,M | SPCINDVT spa6id |
Knihovna vkládaného kódu prováděného akcí doplnění vlastnosti činnosti - je druhu | SPCINDVI spa6id | 1,1 : 0,M | SPCINDVT spa6id |
Akce volání programu dokumentu - je druhu doplňující vlastnosti | SPPROGAK spa6id | 1,1 : 0,M | SPCINDVT spa6id |
Algoritmus výpočtu položky protokolu při výpočtu mezd - je druhu | MZPROTAL spa6id | 1,1 : 0,M | SPCINDVT spa6id |
Doplňující položka menu objektu - je druhu | SPCINDO spa6id | 1,1 : 0,M | SPCINDVT spa6id |
Korektor transformovaných dat - je druhu | SPKOREK spa6id | 1,1 : 0,M | SPCINDVT spa6id |
Volná karta - je druhu pro správu volné karty | SPVOLST spa6id | 1,1 : 0,M | SPCINDVT spa6id |

Indexy

Název | Primární | Výraz | Popis
ix_SPCINDVT_spa6id | P | spa6id | Identifikace druhu implemetačního rozšíření
ix_SPCINDVT_spa6nazdru |  | spa6nazdru | Název druhu implemetačního rozšíření
ix_SPCINDVT_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPCISDOK Číselná řada

Popis

Objektem typu SPCISDOK je každá identifikace intervalu číselné řady dokladů. K těmto intervalům jsou vztaženy veškeré identifikace typu dokladů (#SPTYP) a aktuální čísla dokladů v letech (#SPCISDOX).

*** Dříve TYPDOK.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp08idcisd | C(8) | Řada | Identifikátor číselné řady procesů | Identifikátor číselné řady procesů. *** Dříve OZNDOK.
sp08text | C(30) | Popis | Název intervalu číselné řady procesů | Název intervalu číselné řady dokladů. *** Dříve NAZDOK.
sp08intzac | N(8,0) | Začátek | Začátek intervalu číselné řady procesů | Začátek intervalu číselné řady dokladů. *** Dříve ZACIDOK.
sp08intkon | N(8,0) | Konec | Konec intervalu číselné řady procesů | Konec intervalu číselné řady dokladů. *** Dříve KONIDOK.
sp08koment | M | Poznámka | Poznámka k číselné řadě | Poznámka k číselné řadě

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Číselné řady v letech - patří číselné řadě | SPCISDOX sp08idcisd | 1,1 : 0,M s rušením | SPCISDOK sp08idcisd |
Druh procesu/operace - má číselnou řadu | SPTYP sp08idcisd | 0,1 : 0,M | SPCISDOK sp08idcisd |
Číselná řada operace pro umístění - definuje použití číselné řady | SPTYPRUM sp08idcisd | 1,1 : 0,M s rušením | SPCISDOK sp08idcisd |

Indexy

Název | Primární | Výraz | Popis
ix_SPCISDOK_sp08idcisd | P | sp08idcisd | Identifikátor číselné řady procesů.
ix_SPCISDOK_sp08text |  | sp08text | Název intervalu číselné řady dokladů.
ix_SPCISDOK_sp08intzac |  | sp08intzac | Začátek intervalu číselné řady dokladů.


SPCISDOP Číselné řady v letech

Popis

Číselné řady v letech

Atributy

Atribut | Typ | Návěští | Message | Popis
sp08idcisd | C(8) | Řada | Identifikátor číselné řady procesů | Identifikátor číselné řady procesů. *** Dříve OZNDOK.
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu

Indexy

Název | Primární | Výraz | Popis
ix_SPCISDOP_sp08idcisd |  | sp08idcisd | Identifikátor číselné řady procesů.


SPCISDOX Číselné řady v letech

Popis

Objektem typu SPCISDOX je každá informace o aktuálních číslech dokladů v jednotlivých letech. Každé informaci je nadřazena identifikace intervalu z entity (#SPCISDOK).

*** Dříve TYPDOKX.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp08idcisd | C(8) | Řada | Identifikátor číselné řady procesů | Identifikátor číselné řady procesů. *** Dříve OZNDOK.
sp08idprm | C(2) | Identifikace datového úložiště | Identifikátor pracovního místa. | Identifikátor pracovního místa.
sp09rok | N(4,0) | Rok | Rok | Rok *** Dříve ROK.
sp09aktint | N(8,0) | Aktuální | Aktuální číslo procesu | Aktuální interní číslo dokladu. *** Dříve AKTIDOK.
sp09aktext | N(8,0) | Aktuální externí | Aktuální externí číslo dokladu. | Aktuální externí číslo dokladu. *** Dříve AKTEDOK.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Číselné řady v letech - patří číselné řadě | SPCISDOX sp08idcisd | 1,1 : 0,M s rušením | SPCISDOK sp08idcisd |

Indexy

Název | Primární | Výraz | Popis
ix_SPCISDOX_spcisdox1 | P | sp08idcisd, sp08idprm, sp09rok |
ix_SPCISDOX_sp08idcisd |  | sp08idcisd | Identifikátor číselné řady procesů.
ix_SPCISDOX_sp09rok |  | sp09rok | Rok


SPCIVDV Popis verze doplňující vlastnosti formuláře

Popis

Popis verze doplňující vlastnosti formuláře

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
spa7id | C(6) | Vlastnost | Identifikace doplňující vlastnosti činnosti | Identifikace doplňující vlastnosti činnosti
spa7verze | N(6,3) | Verze | Verze doplňující vlastnosti formuláře | Verze doplňující vlastnosti formuláře
spg4dne | D | Dne | Datum záznamu o verzi | Datum záznamu o verzi
spg4koment | M | Popis | Popis verze | Popis verze
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace
sp00jmeakt | C(40) | Změnil | Jméno uživatele systému, který změnil záznam | Jméno uživatele systému, který změnil záznam

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis verze doplňující vlastnosti formuláře - je popisem verze doplňující vlastnosti formuláře | SPCIVDV bw02krok spa7id | 1,1 : 0,M | SPCINDV bw02krok spa7id |

Indexy

Název | Primární | Výraz | Popis
ix_SPCIVDV_spcivdv | P | bw02krok, spa7id, spa7verze | PI - SPCINDV+spa7verze dvi
ix_SPCIVDV_spcindv |  | bw02krok, spa7id | PI - bw02krok+spa6id


SPCIVDVI Popis verze knihovny vkládaného kódu

Popis

Popis verze knihovny vkládaného kódu

Atributy

Atribut | Typ | Návěští | Message | Popis
spa8id | C(6) | Knihovna | Identifikace vkládaného kódu | Identifikace vkládaného kódu
spa8verze | N(6,3) | Verze | Verze knihovny vkládaného kódu | Verze knihovny vkládaného kódu
spg3dne | D | Dne | Datum záznamu o verzi | Datum záznamu o verzi
spg3koment | M | Popis | Popis verze | Poznámka
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace
sp00jmeakt | C(40) | Změnil | Jméno uživatele systému, který změnil záznam | Jméno uživatele systému, který změnil záznam

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis verze knihovny vkládaného kódu - je popisem knihovny | SPCIVDVI spa8id | 1,1 : 0,M | SPCINDVI spa8id |

Indexy

Název | Primární | Výraz | Popis
ix_SPCIVDVI_spcivdvi | P | spa8id, spa8verze | PI - spa8id+spa8verze
ix_SPCIVDVI_spa8id |  | spa8id | Identifikace vkládaného kódu


SPDAVKA Událost dávkové komponenty

Popis

Událost dávkové komponenty

Atributy

Atribut | Typ | Návěští | Message | Popis
sp84 | C(12) | sp84 | Jednoznačná časová identifikace události dávkové komponenty | Jednoznačná časová identifikace události dávkové komponenty
sp07idtyp | C(6) | Druh | Identifikátor druhu operace | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp84datum | D | Datum | Datum | Datum
sp84text | C(40) | Popis | Popis události obecné komponenty | Popis události obecné komponenty
sp84koment | M | Poznámka | Poznámka k události |
sp84hodnot | N(20,4) | Hodnota | Hodnota |
bw09inst1 | C(12) | bw09inst1 | Jednoznačný časový identifikátor instance objektu typu 1. |
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost dávkové komponenty - patří do fyzické operace | SPDAVKA sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost dávkové komponenty - založil uživatel | SPDAVKA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_SPDAVKA_spdavka | P | sp84, sp07idtyp | PI - sp07idtyp+sp84
ix_SPDAVKA_sp84 |  | sp84 | Jednoznačná časová identifikace události dávkové komponenty
ix_SPDAVKA_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_SPDAVKA_bw09inst1 |  | bw09inst1 |
ix_SPDAVKA_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPDKAT Kategorie dokumentu

Popis

Kategorie dokumentu

Atributy

Atribut | Typ | Návěští | Message | Popis
spf4id | C(6) | Kategorie | Identifikace kategorie dokumentu | Identifikace kategorie dokumentu
spf4nazkat | C(40) | Název kategorie | Název kategorie dokumentu | Název kategorie dokumentu
spf4koment | M | Poznámka | Poznámka | Poznámka
spf4folder | N(1,0) | Složka | Složka Ano/Ne - kategorie bude vystupovat ve formuláři Spojené dokumenty jako složka | Složka Ano/Ne - kategorie bude vystupovat ve formuláři Spojené dokumenty jako složka
spf4idp | C(6) | Předchůdce | Identifikace kategorie dokumentu | Identifikace kategorie dokumentu
spf4expand | N(1,0) | Rozbalená | Rozbalená složka | Rozbalená složka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Kategorie dokumentu - má uvedenu podkategorii dokumentu | SPDKAT spf4idp | 0,1 : 0,M | SPDKAT spf4id |
Kategorie dokumentu - má uvedenu podkategorii dokumentu | SPDKAT spf4idp | 0,1 : 0,M | SPDKAT spf4id |
Kategorie přidělená dokumentu - určuje kategorii | SPDOKKAT spf4id | 1,1 : 0,M | SPDKAT spf4id |

Indexy

Název | Primární | Výraz | Popis
ix_SPDKAT_spf4id | P | spf4id | Identifikace kategorie dokumentu
ix_SPDKAT_spf4nazkat |  | spf4nazkat | Název kategorie dokumentu
ix_SPDKAT_spf4idp |  | spf4idp | Identifikace kategorie dokumentu


SPDOKFIL Jméno souboru, který byl načten

Popis

Jméno souboru, který byl načten

Atributy

Atribut | Typ | Návěští | Message | Popis
sp26 | C(12) | sp26 | Jednoznačná časová identifikace dokumentu | Jednoznačná časová identifikace dokumentu
spf1file | M | spf1file | Jméno načteného souboru | Jméno načteného souboru

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Jméno souboru, který byl načten - se týká dokumentu | SPDOKFIL sp26 | 1,1 : 0,M s rušením | SPDOKOBS sp26 |

Indexy

Název | Primární | Výraz | Popis
ix_SPDOKFIL_sp26 | P | sp26 | Jednoznačná časová identifikace dokumentu


SPDOKKAT Kategorie přidělená dokumentu

Popis

Kategorie přidělená dokumentu

Atributy

Atribut | Typ | Návěští | Message | Popis
spf6 | C(12) | spf6 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
spf4id | C(6) | Kategorie | Identifikace kategorie dokumentu | Identifikace kategorie dokumentu
sp26 | C(12) | sp26 | Jednoznačná časová identifikace dokumentu | Jednoznačná časová identifikace dokumentu
spf6datod | D | Zařazení | Datum zařazení dokumentu do kategorie | Datum zařazení dokumentu do kategorie
spf6datdo | D | Vyřazení | Datum vyřazení dokumentu z kategorie | Datum vyřazení dokumentu z kategorie
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Kategorie přidělená dokumentu - určuje kategorii | SPDOKKAT spf4id | 1,1 : 0,M | SPDKAT spf4id |
Kategorie přidělená dokumentu - je přidělena dokumentu | SPDOKKAT sp26 | 1,1 : 0,M s rušením | SPDOKOBS sp26 |
Kategorie přidělená dokumentu - byla přidělena uživatelem | SPDOKKAT bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_SPDOKKAT_spf6 | P | spf6 | Jednoznačná časová identifikace
ix_SPDOKKAT_spf4id |  | spf4id | Identifikace kategorie dokumentu
ix_SPDOKKAT_sp26 |  | sp26 | Jednoznačná časová identifikace dokumentu
ix_SPDOKKAT_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPDOKMEM Záznam o posledním použitém druhu dokumentu a předloze

Atributy

Atribut | Typ | Návěští | Message | Popis
sp58typ | C(2) | sp58typ | Typ objektu svázaného s dokumentem | Typ objektu svázaného s dokumentem
sp58druh | C(6) | sp58druh | Druh objektu svázaného s dokumentem | Druh objektu svázaného s dokumentem
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp57id | C(6) | Druh | Identifikátor druhu dokumentu | Identifikátor druhu dokumentu
sp01id | C(6) | Předloha | Identifikátor předlohy. | Identifikace předlohy. *** Dříve VYVT_ID.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Záznam o posledním použitém druhu dokumentu a předloze - pamatuje typ dokumentu | SPDOKMEM sp57id | 1,1 : 0,M s rušením | SPDOKTYP sp57id |
Záznam o posledním použitém druhu dokumentu a předloze - pamatuje typy předlohy | SPDOKMEM sp01id | 1,1 : 0,M s rušením | SPPREDLO sp01id |
Záznam o posledním použitém druhu dokumentu a předloze - pamatuje uživatele | SPDOKMEM bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_SPDOKMEM_spdokmem | P | sp58typ, sp58druh, bw01uziv | primární index záznamu o posledním použitém typu dokumentu
ix_SPDOKMEM_sp57id |  | sp57id | Identifikátor druhu dokumentu
ix_SPDOKMEM_sp01id |  | sp01id | Identifikace předlohy.
ix_SPDOKMEM_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPDOKOBS Dokument

Popis

Obsah dokumentu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp26 | C(12) | sp26 | Jednoznačná časová identifikace dokumentu | Jednoznačná časová identifikace dokumentu
sp57id | C(6) | Druh | Identifikátor druhu dokumentu | Identifikátor druhu dokumentu
sp01id | C(6) | Předloha | Identifikátor předlohy. | Identifikace předlohy. *** Dříve VYVT_ID.
sp26datum | T | Datum | Datum a čas založení dokumentu | Datum a čas založení dokumentu
sp26nazev | C(40) | Dokument | Název dokumentu | Název dokumentu
sp26privat | N(1,0) | sp26privat | Chráněný dokument může opravovat pouze jeho autor | Chráněný dokument
sp26koment | M | Poznámka | Komentář k dokumentu | Komentář k dokumentu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp26obs | M | sp26obs |  |
sp26oledbf | M | sp26oledbf |  |
sp26olefpt | M | sp26olefpt |  |
sp26packed | L | sp26packed |  |
sp26soubor | M | Soubor | Název souboru, ve kterém je dokument uložen | Název souboru, ve kterém je dokument uložen
sp26soudup | M | Duplikát | Název souboru, do kterého je po změně dokumentu automaticky ukládán duplikát dokumentu | Duplicitní uložení souboru na disku
sp26disk | N(1,0) | sp26disk | Dokument je uložen externě (soubor na disku, na internetu, ...) |
sp26ole | G | sp26ole |  |
sp26top | N(4,0) | sp26top | Umístění TOP | Umístění TOP
sp26left | N(4,0) | sp26left | Umístění LEFT | Umístění LEFT
sp26height | N(4,0) | sp26height | Umístění HEIGHT | Umístění HEIGHT
sp26width | N(4,0) | sp26width | Umístění WIDTH | Umístění WIDTH
sp26index | C(40) | Klíč | Klíč pro další možné vyhledávání dokumentů a určení výstupního souboru XML dokumentů | Klíč pro další možné vyhledávání dokumentů a určení výstupního souboru XML dokumentů
sp26revize | N(1,0) | sp26revize | Automatické ukládání verzí dokumentu | Automatické ukládání revizí dokumentu
sp26revint | C(5) | Interval | Interval automatického ukládání verzí v hodinách a minutách | Interval automatického ukládání revizí v hodinách a minutách
sp26semaf | N(6,0) | sp26semaf | Semafor používaný pro otevření dokumentu | Semafor používaný pro otevření dokumentu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Dokument - je vytvořen podle předlohy | SPDOKOBS sp01id | 1,1 : 0,M | SPPREDLO sp01id |
Dokument - založil uživatel | SPDOKOBS bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Dokument - má typ dokumentu | SPDOKOBS sp57id | 1,1 : 0,M | SPDOKTYP sp57id |
Verze dokumentu - je revizí dokumentu | SPDOKREV sp26 | 1,1 : 0,M s rušením | SPDOKOBS sp26 |
Položka protokolu dokumentu - patří k dokumentu | SPDOKPRO sp26 | 1,1 : 0,M s rušením | SPDOKOBS sp26 |
Jméno souboru, který byl načten - se týká dokumentu | SPDOKFIL sp26 | 1,1 : 0,M s rušením | SPDOKOBS sp26 |
Kategorie přidělená dokumentu - je přidělena dokumentu | SPDOKKAT sp26 | 1,1 : 0,M s rušením | SPDOKOBS sp26 |

Indexy

Název | Primární | Výraz | Popis
ix_SPDOKOBS_sp26 | P | sp26 | Jednoznačná časová identifikace dokumentu
ix_SPDOKOBS_sp57id |  | sp57id | Identifikátor druhu dokumentu
ix_SPDOKOBS_sp01id |  | sp01id | Identifikace předlohy.
ix_SPDOKOBS_sp26datum |  | sp26datum | Datum a čas založení dokumentu
ix_SPDOKOBS_sp26nazev |  | sp26nazev | Název dokumentu
ix_SPDOKOBS_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SPDOKOBS_sp26disk |  | sp26disk |
ix_SPDOKOBS_sp26index |  | sp26index | Klíč pro další možné vyhledávání dokumentů a určení výstupního souboru XML dokumentů


SPDOKPRO Položka protokolu dokumentu

Popis

Položka protokolu dokumentu

Atributy

Atribut | Typ | Návěští | Message | Popis
spc9 | C(12) | spc9 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
sp26 | C(12) | sp26 | Jednoznačná časová identifikace dokumentu | Jednoznačná časová identifikace dokumentu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
spc9datum | T | Dne | Datum zápisu do protokolu | Datum zápisu do protokolu
spc9popis | C(40) | Popis | Popis položky protokolu dokumentu | Popis položky protokolu dokumentu
spc9akce | C(6) | Akce | Akce položky protokolu | Akce položky protokolu
spc9klic1 | C(40) | spc9klic1 | 1.klíč položky protokolu | 1.klíč položky protokolu
spc9klic2 | C(40) | spc9klic2 | 2.klíč položky protokolu | 2.klíč položky protokolu
spc9koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Položka protokolu dokumentu - patří k dokumentu | SPDOKPRO sp26 | 1,1 : 0,M s rušením | SPDOKOBS sp26 |
Položka protokolu dokumentu - byla založena uživatelem | SPDOKPRO bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_SPDOKPRO_spc9 | P | spc9 | Jednoznačná časová identifikace
ix_SPDOKPRO_sp26 |  | sp26 | Jednoznačná časová identifikace dokumentu
ix_SPDOKPRO_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPDOKREV Verze dokumentu

Popis

Verze dokumentu

Atributy

Atribut | Typ | Návěští | Message | Popis
spb9 | C(12) | spb9 | Jednoznačná časová identifikace verze dokumentu | Jednoznačná časová identifikace verze dokumentu
sp26 | C(12) | sp26 | Jednoznačná časová identifikace dokumentu | Jednoznačná časová identifikace dokumentu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp26obs | M | sp26obs |  |
sp26oledbf | M | sp26oledbf |  |
sp26olefpt | M | sp26olefpt |  |
sp26packed | L | sp26packed |  |
spb9koment | M | Poznámka | Poznámka | Poznámka
spb9datum | T | Datum | Datum založení verze dokumentu | Datum založení verze dokumentu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Verze dokumentu - je revizí dokumentu | SPDOKREV sp26 | 1,1 : 0,M s rušením | SPDOKOBS sp26 |
Verze dokumentu - byla založena uživatelem | SPDOKREV bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_SPDOKREV_spb9 | P | spb9 | Jednoznačná časová identifikace verze dokumentu
ix_SPDOKREV_sp26 |  | sp26 | Jednoznačná časová identifikace dokumentu
ix_SPDOKREV_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPDOKTYP Druh dokumentu

Popis

Druh dokumentu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp57id | C(6) | Druh | Identifikátor druhu dokumentu | Identifikátor druhu dokumentu
sp57typdok | C(40) | Název druhu dokumentu | Název druhu dokumentu | Název druhu dokumentu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp57koment | M | Poznámka | Komentář k druhu dokumentu | Komentář k druhu dokumentu
sp57datum | T | Datum | Datum a čas založení druhu dokumentu | Datum a čas založení druhu dokumentu
sp57aktual | N(1,0) | sp57aktual | Příznak aktuálnosti druhu dokumentu |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh dokumentu - založil uživatel | SPDOKTYP bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Tag XML dokumentu - je druhu dokumentu | SPXMLTAG sp57id | 1,1 : 0,M | SPDOKTYP sp57id |
Vazba mezi tagy XML dokumentu - je druhu dokumentu | SPXMLVAZ sp57id | 1,1 : 0,M | SPDOKTYP sp57id |
Skupina archivace - ukládá dokumenty s druhem | UTARSKP sp57id | 1,1 : 0,M | SPDOKTYP sp57id |
Archivovaný soubor - je druhu | UTARDATF sp57id | 1,1 : 0,M | SPDOKTYP sp57id |
Typ předlohy dokumentu - je druhu | SPPREDLO sp57id | 1,1 : 0,M | SPDOKTYP sp57id |
Dokument - má typ dokumentu | SPDOKOBS sp57id | 1,1 : 0,M | SPDOKTYP sp57id |
Záznam o posledním použitém druhu dokumentu a předloze - pamatuje typ dokumentu | SPDOKMEM sp57id | 1,1 : 0,M s rušením | SPDOKTYP sp57id |

Indexy

Název | Primární | Výraz | Popis
ix_SPDOKTYP_sp57id | P | sp57id | Identifikátor druhu dokumentu
ix_SPDOKTYP_sp57typdok |  | sp57typdok | Název druhu dokumentu
ix_SPDOKTYP_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SPDOKTYP_sp57datum |  | sp57datum | Datum a čas založení druhu dokumentu


SPDOKUZI Práce s dokumentem

Popis

Objektem typu SPDOKUZI je záznam o čtení nebo zápisu dokumentu. Obsahuje identifikaci pracovníka, který pracoval s dokumentem, datum a čas práce, zda bylo zapisováno. Slouží též pro systém rezervací dokumentu pro práci více uživatelů.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp031 | C(12) | sp031 | Jednoznačná časová identifikace sledovaného dokumentu. | Jednoznačná časová identifikace sledovaného dokumentu.
sp03datum | T | Datum a čas od | Datum a čas použití dokumentu od. | Datum použití dokumentu.
sp03 | C(12) | sp03 | Jednoznačná časová identifikace použití dokumentu. | Jednoznačná časová identifikace použití dokumentu.
sp03datumd | T | Datum a čas do | Datum a čas použití dokumentu do. |
sp03casod | C(8) | Čas od | Čas použití dokumentu od. | Čas použití dokumentu od.
sp03casdo | C(8) | Čas do | Čas použití dokumentu do. | Čas použití dokumentu do.
sp03zpusob | N(1,0) | Způsob | Způsob použití dokumentu (čtení, čtení a zápis). | Způsob použití dokumentu (čtení, čtení a zápis).
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp03uziv | N(9,0) | sp03uziv | Pomocná proměnná s prihlášeným uživatelem dle BW_CONNEC - neviditelná | Pomocná proměnná s prihlášeným uživatelem dle BW_CONNEC - neviditelná

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Práce s dokumentem - s dokumentem pracoval | SPDOKUZI bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_SPDOKUZI_spdokuzi1 |  | sp031, sp03datum |
ix_SPDOKUZI_sp03 | P | sp03 | Jednoznačná časová identifikace použití dokumentu.
ix_SPDOKUZI_sp031 |  | sp031 | Jednoznačná časová identifikace sledovaného dokumentu.
ix_SPDOKUZI_sp03datum |  | sp03datum | Datum použití dokumentu.
ix_SPDOKUZI_sp03zpusob |  | sp03zpusob | Způsob použití dokumentu (čtení, čtení a zápis).
ix_SPDOKUZI_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPEXTPR Externí příkaz

Popis

Externí příkaz

Atributy

Atribut | Typ | Návěští | Message | Popis
sp48 | C(12) | sp48 | Jednoznačná časová identifikace externího příkazu | Jednoznačná časová identifikace externího příkazu
sp48popis | C(40) | Popis | Popis externího příkazu | Popis externího příkazu
sp48verze | N(6,3) | Verze | Verze externího příkazu | Verze externího příkazu
sp49id | C(6) | Druh | Identifikace druhu externího příkazu | Identifikace druhu externího příkazu
spc1id | C(6) | Kategorie | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
sp48prikaz | C(80) | Příkaz | Externí příkaz | Externí příkaz
sp48koment | M | Poznámka | Poznámka k externímu příkazu | Poznámka k externímu příkazu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
sp48typ | N(1,0) | Typ | Typ externího příkazu | Typ externího příkazu
sp48kod | M | Kód | Kód scriptu externího příkazu | Kód scriptu externího příkazu
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace
sp00jmeakt | C(40) | Změnil | Jméno uživatele systému, který změnil záznam | Jméno uživatele systému, který změnil záznam
sp48skryty | N(1,0) | Skrytý | Skrytý externí příkaz nezobrazovaný v menu | Skrytý externí příkaz nezobrazovaný v menu
sp48prgid | C(6) | PID | Identifikace pro programové volání | Identifikace pro programové volání
sp48nabvaz | N(1,0) | Pro vazbu | Určen pro volání z vazby externího příkazu Ano/Ne | Určen pro volání z vazby externího příkazu Ano/Ne

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Externí příkaz - založil uživatel | SPEXTPR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Externí příkaz - má druh | SPEXTPR sp49id | 1,1 : 0,M | SPEXTPRD sp49id |
Externí příkaz - je v kategorii | SPEXTPR spc1id | 1,1 : 0,M | SPCINDVK spc1id |
Vazba složeného externího příkazu - definuje předchůdce | SPEXTPRV sp48 | 1,1 : 0,M | SPEXTPR sp48 |
Vazba složeného externího příkazu - definuje následníka | SPEXTPRV sp48n | 1,1 : 0,M | SPEXTPR sp48 |
Poslední výběrové volání externího programu uživatele - se týká externího příkazu | SPEXTPRU sp48 | 1,1 : 0,M s rušením | SPEXTPR sp48 |
Popis verze externího příkazu - je popisem externího příkazu | SPEXVPR sp48 | 1,1 : 0,M | SPEXTPR sp48 |

Indexy

Název | Primární | Výraz | Popis
ix_SPEXTPR_sp48 | P | sp48 | Jednoznačná časová identifikace externího příkazu
ix_SPEXTPR_sp48popis |  | sp48popis | Popis externího příkazu
ix_SPEXTPR_sp48verze |  | sp48verze | Verze externího příkazu
ix_SPEXTPR_sp49id |  | sp49id | Identifikace druhu externího příkazu
ix_SPEXTPR_spc1id |  | spc1id | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
ix_SPEXTPR_sp48prikaz |  | sp48prikaz | Externí příkaz
ix_SPEXTPR_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SPEXTPR_sp00datakt |  | sp00datakt | Datum aktualizace


SPEXTPRD Druh externího příkazu

Popis

Druh externího příkazu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp49id | C(6) | Druh | Identifikace druhu externího příkazu | Identifikace druhu externího příkazu
sp49nazdru | C(40) | Název druhu | Název druhu externího příkazu | Název druhu externího příkazu
sp49koment | M | Poznámka | Poznámka ke druhu externího příkazu | Poznámka ke druhu externího příkazu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh externího příkazu - založil uživatel | SPEXTPRD bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Vazba složeného externího příkazu - je druhu | SPEXTPRV sp49id | 1,1 : 0,M | SPEXTPRD sp49id |
Externí příkaz - má druh | SPEXTPR sp49id | 1,1 : 0,M | SPEXTPRD sp49id |

Indexy

Název | Primární | Výraz | Popis
ix_SPEXTPRD_sp49id | P | sp49id | Identifikace druhu externího příkazu
ix_SPEXTPRD_sp49nazdru |  | sp49nazdru | Název druhu externího příkazu
ix_SPEXTPRD_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPEXTPRU Poslední výběrové volání externího programu uživatele

Popis

Poslední výběr externího programu uživatelem

Atributy

Atribut | Typ | Návěští | Message | Popis
sp48 | C(12) | sp48 | Jednoznačná časová identifikace externího příkazu | Jednoznačná časová identifikace externího příkazu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
spe0nabiz | N(1,0) | Poslední výběr externího příkazu | Uchování posledního výběru externího příkazu uživatelem | Uchování posledního výběru externího příkazu uživatelem

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Poslední výběrové volání externího programu uživatele - se týká externího příkazu | SPEXTPRU sp48 | 1,1 : 0,M s rušením | SPEXTPR sp48 |
Poslední výběrové volání externího programu uživatele - je výběrové volání uživatele | SPEXTPRU bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_SPEXTPRU_spextpru | P | sp48, bw01uziv | PI - sp48+bw01uziv
ix_SPEXTPRU_sp48 |  | sp48 | Jednoznačná časová identifikace externího příkazu
ix_SPEXTPRU_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPEXTPRV Vazba složeného externího příkazu

Popis

Vazba složeného externího příkazu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp48 | C(12) | sp48 | Jednoznačná časová identifikace externího příkazu | Jednoznačná časová identifikace externího příkazu
sp48n | C(12) | sp48n | Jednoznačná časová identifikace externího příkazu - následník ve vazbě | Jednoznačná časová identifikace externího příkazu - následník ve vazbě
sp49id | C(6) | Druh | Identifikace druhu externího příkazu | Identifikace druhu externího příkazu
spd8koment | M | Poznámka | Poznámka | Poznámka
spd8porad | N(3,0) | Pořadí | Pořadí v nabídce | Pořadí v nabídce

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vazba složeného externího příkazu - definuje předchůdce | SPEXTPRV sp48 | 1,1 : 0,M | SPEXTPR sp48 |
Vazba složeného externího příkazu - definuje následníka | SPEXTPRV sp48n | 1,1 : 0,M | SPEXTPR sp48 |
Vazba složeného externího příkazu - je druhu | SPEXTPRV sp49id | 1,1 : 0,M | SPEXTPRD sp49id |

Indexy

Název | Primární | Výraz | Popis
ix_SPEXTPRV_spextprv | P | sp48, sp48n | PI - sp48+sp48n
ix_SPEXTPRV_sp48 |  | sp48 | Jednoznačná časová identifikace externího příkazu
ix_SPEXTPRV_sp48n |  | sp48n | Jednoznačná časová identifikace externího příkazu - následník ve vazbě
ix_SPEXTPRV_sp49id |  | sp49id | Identifikace druhu externího příkazu


SPEXVPR Popis verze externího příkazu

Popis

Popis verze externího příkazu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp48 | C(12) | sp48 | Jednoznačná časová identifikace externího příkazu | Jednoznačná časová identifikace externího příkazu
sp48verze | N(6,3) | Verze | Verze externího příkazu | Verze externího příkazu
spg5dne | D | Dne | Datum záznamu o verzi | Datum záznamu o verzi
spg5koment | M | Popis | Popis verze | Popis verze
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace
sp00jmeakt | C(40) | Změnil | Jméno uživatele systému, který změnil záznam | Jméno uživatele systému, který změnil záznam

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis verze externího příkazu - je popisem externího příkazu | SPEXVPR sp48 | 1,1 : 0,M | SPEXTPR sp48 |

Indexy

Název | Primární | Výraz | Popis
ix_SPEXVPR_spexvpr | P | sp48, sp48verze | PI - sp48+spg5verze
ix_SPEXVPR_sp48 |  | sp48 | Jednoznačná časová identifikace externího příkazu


SPGRID Doplnění mřížky činnosti formuláře

Popis

Doplnění mřížky činnosti formuláře

Atributy

Atribut | Typ | Návěští | Message | Popis
spe4 | C(12) | Doplnění | Identifikace doplnění mřížky formuláře | Identifikace doplnění mřížky formuláře - Jednoznačná časová identifikace
spe4nazdop | C(40) | Doplnění | Popis doplnění mřížky formuláře | Popis doplnění mřížky formuláře
spe4koment | M | Poznámka | Poznámka | Poznámka
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Doplňující vlastnost formuláře - aktivuje doplnění mřížky činnosti formuláře | SPCINDV spe4 | 0,1 : 0,M | SPGRID spe4 |
Sloupec doplnění mřížky činnosti formuláře - patří k doplnění mřížky | SPGRIDS spe4 | 1,1 : 0,M | SPGRID spe4 |
Obecný výběr - aktivuje doplnění mřížky činnosti formuláře | SPVYBER spe4 | 0,1 : 0,M | SPGRID spe4 |

Indexy

Název | Primární | Výraz | Popis
ix_SPGRID_spe4 | P | spe4 | Identifikace doplnění mřížky formuláře - Jednoznačná časová identifikace
ix_SPGRID_spe4nazdop |  | spe4nazdop | Popis doplnění mřížky formuláře


SPGRIDS Sloupec doplnění mřížky činnosti formuláře

Popis

Sloupec doplnění mřížky činnosti formuláře

Atributy

Atribut | Typ | Návěští | Message | Popis
spe5 | C(12) | spe5 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
spe4 | C(12) | Doplnění | Identifikace doplnění mřížky formuláře | Identifikace doplnění mřížky formuláře - Jednoznačná časová identifikace
spe5alias | C(10) | Alias | Alias kurzoru mřížky | Alias kurzoru mřížky
spe5captio | M | Návěští | Návěští sloupce | Návěští sloupce
spe5status | M | Stav.řádek | Stavový řádek sloupce | Stavový řádek sloupce
spe5expr | M | Výraz | Výraz sloupce v syntaxi jazyka Visual Foxpro (místo alias je možné zadávat makro $$$) | Výraz sloupce v syntaxi jazyka Visual Foxpro
spe5pict | M | Formát | Formát hodnoty výrazu | Formát hodnoty výrazu
spe5pozice | N(2,0) | Pozice | Pozice sloupce v mřížce | Pozice sloupce v mřížce
spe5porad | N(2,0) | Pořadí | Pořadí sloupce stejné pozice | Pořadí zařazení sloupce do mřížky
spe5sirka | N(3,0) | Šířka | Šířka sloupce v pixelech | Šířka sloupce v pixelech
spe5koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Sloupec doplnění mřížky činnosti formuláře - patří k doplnění mřížky | SPGRIDS spe4 | 1,1 : 0,M | SPGRID spe4 |

Indexy

Název | Primární | Výraz | Popis
ix_SPGRIDS_spe5 | P | spe5 | Jednoznačná časová identifikace
ix_SPGRIDS_spe4 |  | spe4 | Identifikace doplnění mřížky formuláře - Jednoznačná časová identifikace


SPIMP Definice importu/exportu

Popis

Definice importu

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw10nazev | C(8) | Tabulka | Název entity | Název entity
sp93id | C(6) | I-E | Identifikace importu-exportu | Identifikace importu
sp93nazimp | C(40) | Název importu-exportu | Název importu-exportu | Název importu
sp92id | C(6) | Druh | Identifikace druhu importu-exportu | Identifikace druhu importu-exportu
sp94id | C(6) | Spojení | Identifikace spojení | Identifikace spojení
sp93select | M | Selekt | Selekt importu-exportu | Selekt importu-exportu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
sp93koment | M | Poznámka | Poznámka k importu | Poznámka k importu
sp93oktop | N(4,0) | sp93oktop | Umístění tlačítka OK - TOP | Umístění tlačítka OK - TOP
sp93stleft | N(4,0) | sp93stleft | Umístění tlačítka STORNO - LEFT | Umístění tlačítka STORNO - LEFT
sp93okleft | N(4,0) | sp93okleft | Umístění tlačítka OK - LEFT | Umístění tlačítka OK - LEFT
sp93sttop | N(4,0) | sp93sttop | Umístění tlačítka STORNO - TOP | Umístění tlačítka STORNO - TOP
sp93height | N(4,0) | sp93height | Umístění okna - HEIGHT | Umístění okna - HEIGHT
sp93width | N(4,0) | sp93width | Umístění okna - WIDTH | Umístění okna - WIDTH
sp93impexp | N(1,0) | sp93impexp | Import / export / update dat | Import / export dat
sp93expsel | M | sp93expsel | Select pro export | Select pro export
sp93nabize | N(1,0) | Nabízet | Nabízet import-export k provedení | Nabízet import-export k provedení
sp93prikaz | M | Příkazy | Příkazy provedené po importu-exportu | Příkaz provedený po importu-exportu
sp93comini | M | Init | Inicializační příkaz | Inicializační příkaz
sp93repcid | M | Čas.id. | Výraz pro atribut časové identifikace | Výraz pro atribut časové identifikace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Definice importu/exportu - založil uživatel | SPIMP bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Definice importu/exportu - je druhu | SPIMP sp92id | 1,1 : 0,M | SPIMPD sp92id |
Definice importu/exportu - používá spojení | SPIMP sp94id | 1,1 : 0,M | SPIMPS sp94id |
Import/Export operace - se vztahuje k definici exportu | SPTYPEI bw02krok bw10nazev sp93id | 1,1 : 0,M | SPIMP bw02krok bw10nazev sp93id |
Šablona - definuje odkaz na import | SPSABL bw02krok bw10nazev sp93id | 0,1 : 0,M | SPIMP bw02krok bw10nazev sp93id |
Výběr pro import - náleží k importu | SPIMPV bw02krok bw10nazev sp93id | 1,1 : 0,M s rušením | SPIMP bw02krok bw10nazev sp93id |
Procesní import - používá definici importu | SPIMPP bw02krok bw10nazev sp93id | 1,1 : 0,M | SPIMP bw02krok bw10nazev sp93id |
Konverze řádky - se týká importu | SPIMPR bw02krok bw10nazev sp93id | 1,1 : 0,M s rušením | SPIMP bw02krok bw10nazev sp93id |

Indexy

Název | Primární | Výraz | Popis
ix_SPIMP_spimp | P | bw02krok, bw10nazev, sp93id | bw02krok+bw10nazev+sp93id
ix_SPIMP_bw02krok |  | bw02krok | Identifikace činnosti
ix_SPIMP_sp93id |  | sp93id | Identifikace importu
ix_SPIMP_bw10nazev |  | bw10nazev | Název entity
ix_SPIMP_sp92id |  | sp92id | Identifikace druhu importu-exportu
ix_SPIMP_sp94id |  | sp94id | Identifikace spojení
ix_SPIMP_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPIMPA Konverze atributu

Popis

Konverze atributu

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw10nazev | C(8) | Tabulka | Název entity | Název entity
sp93id | C(6) | I-E | Identifikace importu-exportu | Identifikace importu
sp99cisr | N(2,0) | Číslo | Číslo konvertovaného definice řádky | Číslo konvertovaného definice řádky
bw11nazev | C(10) | Atribut | Název atributu | Název atributu
sp95vyraz | M | Výraz | Výraz |
sp95koment | M | Poznámka | Poznámka |
sp95obecna | N(1,0) | sp95obecna | Atribut má platnost pro všechny záznamy | Atribut má platnost pro všechny záznamy

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Konverze atributu - je na konv.radku | SPIMPA bw02krok bw10nazev sp93id sp99cisr | 1,1 : 0,M s rušením | SPIMPR bw02krok bw10nazev sp93id sp99cisr |

Indexy

Název | Primární | Výraz | Popis
ix_SPIMPA_spimpa | P | bw02krok, bw10nazev, sp93id, sp99cisr, bw11nazev |
ix_SPIMPA_spimpr |  | bw02krok, bw10nazev, sp93id, sp99cisr |


SPIMPD Druh importu

Popis

Druh importu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp92id | C(6) | Druh | Identifikace druhu importu-exportu | Identifikace druhu importu-exportu
sp92nazdru | C(40) | Název druhu | Název druhu importu-exportu | Název druhu importu
sp92koment | M | Poznámka | Poznámka ke druhu importu-exportu | Poznámka ke druhu importu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh importu - založil uživatel | SPIMPD bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Definice importu/exportu - je druhu | SPIMP sp92id | 1,1 : 0,M | SPIMPD sp92id |
Procesní import - je druhu | SPIMPP sp92id | 1,1 : 0,M | SPIMPD sp92id |

Indexy

Název | Primární | Výraz | Popis
ix_SPIMPD_sp92id | P | sp92id | Identifikace druhu importu-exportu
ix_SPIMPD_sp92nazdru |  | sp92nazdru | Název druhu importu
ix_SPIMPD_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPIMPP Procesní import

Popis

Procesní import

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtypd | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu procesu
sp06idsubd | C(3) | sp06idsubd | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw10nazev | C(8) | Tabulka | Název entity | Název entity
sp93id | C(6) | I-E | Identifikace importu-exportu | Identifikace importu
sp92id | C(6) | Druh | Identifikace druhu importu-exportu | Identifikace druhu importu-exportu
sp97nazimp | C(40) | Název | Název procesního importu | Název procesního importu
sp97privyr | M | Jedn.id. | Výraz jednoznačné identifikace operace | Výraz jednoznačné identifikace operace
sp97rozvyr | M | Rozpad | Výraz rozpadu na procesy | Výraz rozpadu na procesy
sp97pozadi | N(1,0) | sp97pozadi | Spustit operaci na pozadí | Spustit operaci na pozadí
sp97mod | N(1,0) | sp97mod | Způsob založení operace | Napojit do běžícího procesu
sp97koment | M | Poznámka | Poznámka | Poznámka
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
sp97vcisdr | M | Rok | Výraz identifikace roku pro napojení do procesu | Výraz identifikace roku pro napojení do procesu
sp97vcisdp | M | IDÚ | Výraz identifikace IDÚ pro napojení do procesu | Výraz identifikace IDÚ pro napojení do procesu
sp97vcisd | M | Číslo | Výraz identifikace čísla procesu pro napojení do procesu | Výraz identifikace čísla procesu pro napojení do procesu
sp97vporad | M | Pořadí | Výraz identifikace pořadí pro napojení do procesu | Výraz identifikace pořadí pro napojení do procesu
sp97menu | N(1,0) | sp97menu | Zobrazit procesní import v menu | Zobrazit procesní import v menu
sp97callid | C(6) | CID | Identifikace importu pro volání prostředky BM | Identifikace importu pro volání prostředky BM

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Procesní import - se týká operace v procesu | SPIMPP sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPTYPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad |
Procesní import - používá definici importu | SPIMPP bw02krok bw10nazev sp93id | 1,1 : 0,M | SPIMP bw02krok bw10nazev sp93id |
Procesní import - založil uživatel | SPIMPP bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Procesní import - je druhu | SPIMPP sp92id | 1,1 : 0,M | SPIMPD sp92id |

Indexy

Název | Primární | Výraz | Popis
ix_SPIMPP_spimpp | P | sp07idtypd, sp06idsubd, sp07idtyp, sp06idsubs, sp33porad, bw02krok, bw10nazev, sp93id |
ix_SPIMPP_sptypod |  | sp07idtypd, sp06idsubd, sp07idtyp, sp06idsubs, sp33porad | Identifikace druhu operace v druhu procesu
ix_SPIMPP_sptypd |  | sp07idtypd, sp06idsubd | Index podle typu dokladu a subsystému dokladu
ix_SPIMPP_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SPIMPP_spimp |  | bw02krok, bw10nazev, sp93id | bw02krok+bw10nazev+sp93id
ix_SPIMPP_sp92id |  | sp92id | Identifikace druhu importu-exportu
ix_SPIMPP_sp97nazimp |  | sp97nazimp | Název procesního importu
ix_SPIMPP_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SPIMPP_sp06idsubs |  | sp06idsubs | Identifikace subsystému.
ix_SPIMPP_sp97callid |  | sp97callid | Identifikace importu pro volání prostředky BM


SPIMPR Konverze řádky

Popis

Konverze řádky

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw10nazev | C(8) | Tabulka | Název entity | Název entity
sp93id | C(6) | I-E | Identifikace importu-exportu | Identifikace importu
sp99cisr | N(2,0) | Číslo | Číslo konvertovaného definice řádky | Číslo konvertovaného definice řádky
sp99podmin | M | Podmínka | Podmínka přenosu | Podmínka přenosu
sp99koment | M | Poznámka | Poznámka | Poznámka
sp99primar | M | sp99primar | Primární klíč exportu | Primární klíč exportu
sp99key | M | Klíč pro Update | Klíč pro Update - seznam atributů klíče oddělených čárkou | Klíč pro Update - seznam atributů klíče oddělených čárkou

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Konverze řádky - se týká importu | SPIMPR bw02krok bw10nazev sp93id | 1,1 : 0,M s rušením | SPIMP bw02krok bw10nazev sp93id |
Konverze atributu - je na konv.radku | SPIMPA bw02krok bw10nazev sp93id sp99cisr | 1,1 : 0,M s rušením | SPIMPR bw02krok bw10nazev sp93id sp99cisr |

Indexy

Název | Primární | Výraz | Popis
ix_SPIMPR_spimpr | P | bw02krok, bw10nazev, sp93id, sp99cisr |
ix_SPIMPR_spimp |  | bw02krok, bw10nazev, sp93id | bw02krok+bw10nazev+sp93id


SPIMPS Spojení

Popis

Spojení

Atributy

Atribut | Typ | Návěští | Message | Popis
sp94id | C(6) | Spojení | Identifikace spojení | Identifikace spojení
sp94nazspo | C(40) | Název spojení | Název spojení | Název spojení
sp94druh | N(1,0) | Druh spojení | Druh spojení | Druh spojení
sp94koment | M | Poznámka | Poznámka ke spojení | Poznámka ke spojení
sp94spojen | C(20) | Spojení OS | Spojení operačního systému | Spojení operačního systému
sp94uid | C(20) | Uživatel | Identifikace uživatele | Identifikace uživatele
sp94pwd | C(20) | Heslo | Heslo uživatele | Heslo uživatele
sp94cp | N(4,0) | K. stránka | Kódová stránka | Kódová stránka
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Spojení - založil uživatel | SPIMPS bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Uzel informačního panelu - používá spojení | IPUZEL sp94id | 0,1 : 0,M | SPIMPS sp94id |
Definice importu/exportu - používá spojení | SPIMP sp94id | 1,1 : 0,M | SPIMPS sp94id |

Indexy

Název | Primární | Výraz | Popis
ix_SPIMPS_sp94id | P | sp94id | Identifikace spojení
ix_SPIMPS_sp94nazspo |  | sp94nazspo | Název spojení
ix_SPIMPS_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPIMPV Výběr pro import

Popis

Výběr pro import

Atributy

Atribut | Typ | Návěští | Message | Popis
sp96 | C(12) | sp96 | Jednoznačná časová identifikace proměnné importu | Jednoznačná časová identifikace proměnné importu
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw10nazev | C(8) | Tabulka | Název entity | Název entity
sp93id | C(6) | I-E | Identifikace importu-exportu | Identifikace importu
sp96cisprm | C(4) | Proměnná | Číslo proměnné definice importu | Číslo proměnné definice importu
sp96nazev | C(10) | Název | Název proměnné | Název proměnné
sp96typ | N(1,0) | Typ | Typ proměnné | Typ proměnné
sp96delka | N(3,0) | Délka | Délka proměnné | Délka proměnné
sp96deseti | N(2,0) | Desetiny | Počet desetin | Počet desetin
sp96label | C(30) | Návěští | Návěští proměnné | Návěští proměnné
sp96trida | N(1,0) | Třída | Třída ovládacího prvku | Třída ovládacího prvku
sp96left | N(4,0) | sp96left | Umístění LEFT | Umístění LEFT
sp96top | N(4,0) | sp96top | Umístění TOP | Umístění TOP
sp96height | N(4,0) | sp96height | Umístění HEIGHT | Umístění HEIGHT
sp96width | N(4,0) | sp96width | Umístění WIDTH | Umístění WIDTH
sp96laleft | N(4,0) | sp96laleft | Umístění - LABEL LEFT | Umístění - LABEL LEFT
sp96latop | N(4,0) | sp96latop | Umístění - LABEL TOP | Umístění - LABEL TOP
sp96pict | C(60) | Hodnoty | Text pro zaškrtávací políčko nebo seznam hodnot pro překryvný seznam oddělených čárkou | Názvy hodnot pro překryvný seznam
sp96vyraz | C(60) | Výraz | Výraz proměnné šablony | Výraz proměnné šablony
sp96init | M | Inicializace | Inicializační hodnota proměnné šablony | Inicializační hodnota proměnné šablony
sp96vstup | N(1,0) | Naplnění | Způsob naplnění proměnné - vstupem nebo výpočtem | Způsob naplnění proměnné - vstupem nebo výpočtem
bw02krokx | C(6) | F2-reakce | Identifikace činnosti | Identifikace činnosti
sp96valid | M | Validace | Script v jazyce Foxpro | Script v jazyce Foxpro

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Výběr pro import - náleží k importu | SPIMPV bw02krok bw10nazev sp93id | 1,1 : 0,M s rušením | SPIMP bw02krok bw10nazev sp93id |

Indexy

Název | Primární | Výraz | Popis
ix_SPIMPV_sp96 | P | sp96 | Jednoznačná časová identifikace proměnné importu
ix_SPIMPV_spimp |  | bw02krok, bw10nazev, sp93id | bw02krok+bw10nazev+sp93id


SPJAZYK Jazyk

Popis

Jazyk

Atributy

Atribut | Typ | Návěští | Message | Popis
sp38id | C(3) | Jazyk | Identifikace jazyka | Identifikace jazyka
sp38jazyk | C(40) | Název jazyka | Název jazyka | Název jazyka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Předloha výstupu v makropředloze - bude tisknout jazykem | BWPRINSP sp38id | 0,1 : 0,M | SPJAZYK sp38id |
Předklad umístění nebo druhu - je překladem v jazyce | SPPREKLA sp38id | 1,1 : 0,M | SPJAZYK sp38id |
Přeložené návěští a poznámka proměnné volné karty nebo obecného výběru nebo importu - je v jazyce | SPPREKLP sp38id | 1,1 : 0,M | SPJAZYK sp38id |
Uživatel systému - mluví zazykem | BWUZIVAT sp38id | 0,1 : 0,M | SPJAZYK sp38id |
Předloha pro výstup - má přednastavený jazyk | BWPRINTD sp38id | 0,1 : 0,M | SPJAZYK sp38id |
Cizí popis účtu - je v jazyce | UCROZVRN sp38id | 1,1 : 0,M s rušením | SPJAZYK sp38id |
Měrná jednotka v jazyce - je v jazyce | SPMJN sp38id | 1,1 : 0,M | SPJAZYK sp38id |
Obsah volného textu - je v jazyce | SPTEXTYN sp38id | 1,1 : 0,M | SPJAZYK sp38id |

Indexy

Název | Primární | Výraz | Popis
ix_SPJAZYK_sp38id | P | sp38id | Identifikace jazyka
ix_SPJAZYK_sp38jazyk |  | sp38jazyk | Název jazyka


SPKALEN Obecný kalendář

Popis

Obecný kalendář

Atributy

Atribut | Typ | Návěští | Message | Popis
spd3id | C(6) | Kalendář | Identifikace kalendáře | Identifikace kalendáře
spd3nazkal | C(40) | Název kalendáře | Název kalendáře | Název kalendáře
spd3typ | N(1,0) | Typ | Pro vyhodnocení platnosti dne musí být uveden - Denní kalendář - den v týdnu, Týdenní kalendář - jednotlivý platný den | Pro vyhodnocení platnosti dne musí být uveden - Denní kalendář - den v týdnu, Týdenní kalendář - jednotlivý platný den
spd3koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Den obecného kalendáře - se vztahuje ke kalendáři | SPKALEND spd3id | 1,1 : 0,M | SPKALEN spd3id |
Den v týdnu kalendáře - je dnem obecného kalendáře | SPKALENT spd3id | 1,1 : 0,M | SPKALEN spd3id |
Trasa expedice - používá kalendář | EXTRASA spd3id | 1,1 : 0,M | SPKALEN spd3id |
Řidič - expedice - je vytěžován podle kalendáře | EXRIDIC spd3id | 1,1 : 0,M | SPKALEN spd3id |

Indexy

Název | Primární | Výraz | Popis
ix_SPKALEN_spd3id | P | spd3id | Identifikace kalendáře
ix_SPKALEN_spd3nazkal |  | spd3nazkal | Název kalendáře


SPKALENC Část dne v kalendáři

Popis

Část dne v kalendáři

Atributy

Atribut | Typ | Návěští | Message | Popis
spd5id | C(6) | Část dne | Identifikace části dne | Identifikace části dne
spd5nazcas | C(40) | Název části dne | Název části dne | Název části dne
spd5casod | C(5) | Čas od | Čas od | Čas od
spd5casdo | C(5) | Čas do | Čas do | Čas do
spd5koment | M | Poznámka | Poznámka | Poznámka
spd5predpl | N(1,0) | Předplňovat | Předplňovat při zaloření nového kalendáře do dnů v týdnu | Předplňovat při zaloření nového kalendáře do dnů v týdnu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Den obecného kalendáře - definuje část dne | SPKALEND spd5id | 1,1 : 0,M | SPKALENC spd5id |
Den v týdnu kalendáře - se týká části dne | SPKALENT spd5id | 1,1 : 0,M | SPKALENC spd5id |
Výjimka v obecném kalendáři - je k části dne | SPKALENV spd5id | 1,1 : 0,M | SPKALENC spd5id |

Indexy

Název | Primární | Výraz | Popis
ix_SPKALENC_spd5id | P | spd5id | Identifikace části dne
ix_SPKALENC_spd5nazcas |  | spd5nazcas | Název části dne


SPKALEND Den obecného kalendáře

Popis

Den obecného kalendáře

Atributy

Atribut | Typ | Návěští | Message | Popis
spd4datum | D | Datum | Datum | Datum
spd3id | C(6) | Kalendář | Identifikace kalendáře | Identifikace kalendáře
spd5id | C(6) | Část dne | Identifikace části dne | Identifikace části dne
spd4koment | M | Poznámka | Poznámka | Poznámka
spd4platno | N(1,0) | Platný | Platný den kalendáře Ano/Ne | Platný den kalendáře Ano/Ne

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Den obecného kalendáře - se vztahuje ke kalendáři | SPKALEND spd3id | 1,1 : 0,M | SPKALEN spd3id |
Den obecného kalendáře - definuje část dne | SPKALEND spd5id | 1,1 : 0,M | SPKALENC spd5id |

Indexy

Název | Primární | Výraz | Popis
ix_SPKALEND_spkalend | P | spd4datum, spd3id, spd5id | PI - spd4datum+spd3id+spd5id
ix_SPKALEND_spd3id |  | spd3id | Identifikace kalendáře
ix_SPKALEND_spd5id |  | spd5id | Identifikace části dne


SPKALENT Den v týdnu kalendáře

Popis

Den v týdnu kalendáře

Atributy

Atribut | Typ | Návěští | Message | Popis
spd3id | C(6) | Kalendář | Identifikace kalendáře | Identifikace kalendáře
spd5id | C(6) | Část dne | Identifikace části dne | Identifikace části dne
spd6den | N(1,0) | Den | Den v týdnu | Den v týdnu
spd6koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Den v týdnu kalendáře - je dnem obecného kalendáře | SPKALENT spd3id | 1,1 : 0,M | SPKALEN spd3id |
Den v týdnu kalendáře - se týká části dne | SPKALENT spd5id | 1,1 : 0,M | SPKALENC spd5id |

Indexy

Název | Primární | Výraz | Popis
ix_SPKALENT_spkalent | P | spd3id, spd5id, spd6den | PI - spd3id+spd5id+spd6den
ix_SPKALENT_spd3id |  | spd3id | Identifikace kalendáře
ix_SPKALENT_spd5id |  | spd5id | Identifikace části dne


SPKALENV Výjimka v obecném kalendáři

Popis

Výjimka v obecném kalendáři

Atributy

Atribut | Typ | Návěští | Message | Popis
bw10nazev | C(8) | Tabulka | Název entity | Název entity
spd7id | C(6) | spd7id | Identifikace vlastníka kalendáře | Identifikace vlastníka kalendáře
spd7datum | D | Datum | Datum | Datum
spd5id | C(6) | Část dne | Identifikace části dne | Identifikace části dne
spd7platno | N(1,0) | Platí | Platnost dne kalendáře | Platnost dne kalendáře
spd7koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Výjimka v obecném kalendáři - je k části dne | SPKALENV spd5id | 1,1 : 0,M | SPKALENC spd5id |

Indexy

Název | Primární | Výraz | Popis
ix_SPKALENV_spkalendv | P | bw10nazev, spd7id, spd7datum, spd5id | PI - bw10nazev+spd7id+spd7datum+spd5id
ix_SPKALENV_spd5id |  | spd5id | Identifikace části dne
ix_SPKALENV_spd7id |  | spd7id | Identifikace vlastníka kalendáře
ix_SPKALENV_spd7datum |  | spd7datum | Datum


SPKOMPUZ Uzavřené období komponenty

Popis

Uzavřené období komponenty

Atributy

Atribut | Typ | Návěští | Message | Popis
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp04datvod | D | Vstup datum od | Povolené období pro vstup od | Povolené období pro vstup od
sp04datvdo | D | do | Povolené období pro vstup do | Povolené období pro vstup do
sp04vyraz | M | sp04vyraz | Výraz zobrazených informací o události ve stromu | Výraz zobrazených informací o události ve stromu
sp04valsto | N(1,0) | Kontrolovat při stornu | Validovat otevřené období komponenty při stornu procesu | Validovat otevřené období komponenty při stornu procesu
sp04valzsu | N(1,0) | Kontrolovat při rušení stavu ukončena | Validovat otevřené období komponenty při rušení stavu ukončena | Validovat otevřené období komponenty při zrušení stavu ukončena

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Uzavřené období komponenty - je komponenty | SPKOMPUZ sp06idsubs | 1,1 : 0,M | SPSUBSYS sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_SPKOMPUZ_sp06idsubs | P | sp06idsubs | Identifikace subsystému.


SPKONST Konstanty transformací a šablon

Popis

Konstanty transformací a šablon

Atributy

Atribut | Typ | Návěští | Message | Popis
sp73id | C(10) | Konstanta | Identifikace konstanty | Identifikace konstanty
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp73nazkon | C(40) | Název konstanty | Název konstanty | Název konstanty
sp73hodnot | C(40) | Hodnota | Hodnota konstanty | Hodnota konstanty
sp73koment | M | Poznámka | Poznámka ke konstantě | Poznámka ke konstantě

Indexy

Název | Primární | Výraz | Popis
ix_SPKONST_spkonst | P | sp73id, sp33cisdpm |
ix_SPKONST_sp73nazkon |  | sp73nazkon | Název konstanty


SPKOREK Korektor transformovaných dat

Popis

Korektor transformovaných dat

Atributy

Atribut | Typ | Návěští | Message | Popis
spg2id | C(6) | Korektor | Identifikace korektoru transformovaných dat | Identifikace korektoru transformovaných dat
pa17id | C(6) | Sada | Identifikace sady systémových konstant | Identifikace sady systémových konstant
spa6id | C(6) | Druh | Identifikace druhu implemetačního rozšíření | Identifikace druhu implemetačního rozšíření
spg2nazkor | C(40) | Název korektoru | Název korektoru transformovaných dat | Název korektoru transformovaných dat
spg2kod | M | Kód | Kód kortektoru v jazyce Foxpro (Lparameters _this,_thisform,_alias,_params ...) | Kód kortektoru v jazyce Foxpro
spg2koment | M | Poznámka | Poznámka | Poznámka
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Korektor transformovaných dat - používá sadu paramterů | SPKOREK pa17id | 1,1 : 0,M | PASYSSAD pa17id |
Korektor transformovaných dat - je druhu | SPKOREK spa6id | 1,1 : 0,M | SPCINDVT spa6id |
Druh procesu/operace - používá korektor | SPTYP spg2id | 0,1 : 0,M | SPKOREK spg2id |

Indexy

Název | Primární | Výraz | Popis
ix_SPKOREK_spg2id | P | spg2id | Identifikace korektoru transformovaných dat
ix_SPKOREK_pa17id |  | pa17id | Identifikace sady systémových konstant
ix_SPKOREK_spa6id |  | spa6id | Identifikace druhu implemetačního rozšíření


SPMJ Měrná jednotka

Atributy

Atribut | Typ | Návěští | Message | Popis
sp24idmj | C(3) | MJ | Identifikátor měrné jednotky | Identifikátor měrné jednotky
sp24koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost skladu zvířat - má MJ | SZUDAL sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Událost skladu zvířat - má pomocnou MJ | SZUDAL sp24idmj1 | 1,1 : 0,M | SPMJ sp24idmj |
Kategorie zvířat - má RMJ | SZARTIKL sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Technologický postup k datu rozpracovaný na KJ pilotního artiklu - byl zpracován pro měrnou jednotkou kalkulační jednice artiklu | TPTECVV sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Vstup/výstup technologického postupu k datu na kalkulační jednici - má množství v měrné jednotce | TPTECVVP sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Artikly personalistiky - v měrné jednotce | MZPERART sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Sazba položky celního sazebníku v období - má měrnou jednotku | OBCELPRC sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Sazba položky celního sazebníku v období - má měrnou jednotku KN | OBCELPRC sp24idmj2 | 1,1 : 0,M | SPMJ sp24idmj |
Artikl obecné komponenty - v měrné jednotce | OKARTIKL sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Obchodovatelný artikl - má měrnou jednotku jako referenční | OBARTIKL sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Měrná jednotka v jazyce - patří k měrné jednotce | SPMJN sp24idmj | 1,1 : 0,M s rušením | SPMJ sp24idmj |
Vztah měrných jednotek - se týká první jednotky | SPMJP sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Vztah měrných jednotek - se týká druhé jednotky | SPMJP sp24idmj2 | 1,1 : 0,M | SPMJ sp24idmj |
Událost obchodního plnění - je obchodována v měrné jednotce | OBUDAL sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Událost obchodního plnění - má referenční měrnou jednotku | OBUDAL sp24idmj1 | 1,1 : 0,M | SPMJ sp24idmj |
Událost obchodního plnění - má dopřesňující měrnou jednotku | OBUDAL sp24idmj2 | 1,1 : 0,M | SPMJ sp24idmj |
Položka ceníku artiklu - je za měrnou jednotku | OBCENIK sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Skladovaný artikl - má referenční měrnou jednotku | MTARTIKL sp24idmj | 1,1 : 1,1 | SPMJ sp24idmj |
Událost skladu - má měrnou jednotku | MTUDA sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Událost skladu - má referenční měrnou jednotku | MTUDA sp24idmj1 | 1,1 : 0,M | SPMJ sp24idmj |
Artikl výroby - je veden v měrné jednotce | TPVYROB sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Artikl výroby - má měrnou jednotku vedenou v tabulkách | TPVYROB sp24idmj2 | 1,1 : 0,M | SPMJ sp24idmj |
Položka kusovníku TPV - je veden v měrné jednotce | TPKUSOV sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Výrobní zakázka - má množství v uvedené MJ | VRVYR sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Výrobní zakázka - má množství v RMJ | VRVYR sp24idmj1 | 1,1 : 0,M | SPMJ sp24idmj |
Vstup nebo výstup výrobního úkolu - má množství artiklu uvedeno v měrné jednotce | VRUDOPMA sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Řád zaokrouhlování měrné jednotky vyráběného artiklu - je měrnou jednotkou | TPMJNED sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |

Indexy

Název | Primární | Výraz | Popis
ix_SPMJ_sp24idmj | P | sp24idmj | Identifikátor měrné jednotky


SPMJN Měrná jednotka v jazyce

Atributy

Atribut | Typ | Návěští | Message | Popis
sp24idmj | C(3) | MJ | Identifikátor měrné jednotky | Identifikátor měrné jednotky
sp38id | C(3) | Jazyk | Identifikace jazyka | Identifikace jazyka
sp58mjnaz | C(40) | Název měrné jednotky | Název měrné jednotky | Název měrné jednotky
sp58idmj | C(20) | Rozšířená identifikace | Rozšířená identifikace měrné jednotky | Rozšířená identifikace měrné jednotky

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Měrná jednotka v jazyce - je v jazyce | SPMJN sp38id | 1,1 : 0,M | SPJAZYK sp38id |
Měrná jednotka v jazyce - patří k měrné jednotce | SPMJN sp24idmj | 1,1 : 0,M s rušením | SPMJ sp24idmj |

Indexy

Název | Primární | Výraz | Popis
ix_SPMJN_spmjn | P | sp24idmj, sp38id | PI - sp24idmj+sp38id
ix_SPMJN_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky
ix_SPMJN_sp38id |  | sp38id | Identifikace jazyka


SPMJP Vztah měrných jednotek

Atributy

Atribut | Typ | Návěští | Message | Popis
sp24idmj | C(3) | MJ | Identifikátor měrné jednotky | Identifikátor měrné jednotky
sp24idmj2 | C(3) | Měrná jednotka | Identifikátor měrné jednotky | Identifikátor měrné jednotky
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp59podil | N(20,10) | sp59podil |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vztah měrných jednotek - se týká první jednotky | SPMJP sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Vztah měrných jednotek - se týká druhé jednotky | SPMJP sp24idmj2 | 1,1 : 0,M | SPMJ sp24idmj |
Vztah měrných jednotek - se týká artiklu | SPMJP sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_SPMJP_spmjp | P | sp24idmj, sp24idmj2, sp60id, sp61id |
ix_SPMJP_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky
ix_SPMJP_sp24idmj2 |  | sp24idmj2 | Identifikátor měrné jednotky
ix_SPMJP_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id


SPPOHZDR Událost procesu

Popis

Událost procesu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp07text | C(30) | sp07text | Název druhu procesu | Název typu dokladu. *** Dříve NAZPDR.
sp34ready | N(1,0) | Operace připravena | Operace je připravena ke spuštění | Operace připravena
sp34zahaje | N(1,0) | sp34zahaje | Operace zahájena | Operace zahájena
sp34datzac | T | Zahájení operace | Datum zahájení operace | Datum zahájení operace
sp34ukonce | N(1,0) | sp34ukonce | Operace ukončena | Příznak ukončené operace
sp34datkon | T | Ukončení operace | Datum ukončení operace | Datum ukončení operace

Indexy

Název | Primární | Výraz | Popis
ix_SPPOHZDR_sp33hid |  | sp33hid | Časová identifikace hlavního procesu


SPPRC Proces

Popis

Proces

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtypd | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu procesu
sp06idsubd | C(3) | sp06idsubd | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery
sp33 | C(12) | sp33 | Jednoznačná časová identifikace procesu | Jednoznačná časová identifikace procesu
sp33text | C(30) | Popis | Popis procesu | Popis procesu
sp33extcis | C(15) | Externí číslo | Externí číslo procesu | Externí číslo procesu
sp33koment | M | Poznámka | Komentář k procesu | Komentář k procesu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp33datum | T | Vznik procesu | Datum zahájení procesu | Datum zahájení procesu
sp33cisdo | C(8) | Číslo procesu | Číslo procesu - předcházejícího procesu | Číslo procesu - předcházejícího procesu
sp33cisdpo | C(2) | IDÚ | Identifikace datového úložiště v čísle procesu - předcházejícího procesu | Pracovní místo čísla procesu - předcházejícího procesu
sp33cisdro | C(4) | Rok | Rok řady čísla procesu - předcházejícího procesu | Rok řady čísla procesu - předcházejícího procesu
sp33porado | N(2,0) | sp33porado | Pořadí stejné operace na jednom dokladu | Pořadí stejné operace na jednom dokladu
sp07idtypo | C(6) | Druh procesu | Identifikátor druhu procesu - předcházejícího procesu | Identifikátor typu procesu - předcházejícího procesu
sp33storno | N(1,0) | Stav procesu | Stav procesu - Nestornovaný,Stornovaný,Stornující | Stav procesu - Nestornovaný,Stornovaný,Stornující
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
sp33semaf | N(4,0) | Aktuální hodnota semaforu procesu | Aktuální hodnota semaforu procesu | Aktuální hodnota semaforu procesu
sp33setval | M | sp33setval | Set proměnné procesu | Set proměnné procesu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Proces - založil uživatel | SPPRC bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Proces - má typ logického dokladu | SPPRC sp07idtypd sp06idsubd | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Proces - vznikl na základě fyzické operace nadřízeného dokladu | SPPRC sp33cisdo sp33cisdpo sp33cisdro sp07idtypd sp06idsubd sp33porado | 0,1 : 0,M s rušením | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Popis procesu popisným údajem aplikace - popisuje proces | APPRCPOP sp33cisd sp33cisdpm sp33cisdr | 1,1 : 0,M s rušením | SPPRC sp33cisd sp33cisdpm sp33cisdr |
Operace procesu - patří k fyzickému dokladu | SPPRCOD sp33cisd sp33cisdpm sp33cisdr | 1,1 : 0,M s rušením | SPPRC sp33cisd sp33cisdpm sp33cisdr |
Vazba proces - prezentovaná operace - váže fyzický doklad | SPPRCZDR sp33cisd sp33cisdpm sp33cisdr | 1,1 : 0,M s rušením | SPPRC sp33cisd sp33cisdpm sp33cisdr |
Saldokontní hodnota procesu - se týká procesu | SPPRCSAL sp33hid | 1,1 : 0,M s rušením | SPPRC sp33 |

Indexy

Název | Primární | Výraz | Popis
ix_SPPRC_spprc | P | sp33cisd, sp33cisdpm, sp33cisdr | Identifikace procesu
ix_SPPRC_sptypd |  | sp07idtypd, sp06idsubd | Index podle typu dokladu a subsystému dokladu
ix_SPPRC_sp33 | U | sp33 | Jednoznačná časová identifikace procesu
ix_SPPRC_sp33cisdpm |  | sp33cisdpm | Pracovní místo čísla řady procesu
ix_SPPRC_sp33text |  | sp33text | Popis procesu
ix_SPPRC_sp33extcis |  | sp33extcis | Externí číslo procesu
ix_SPPRC_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SPPRC_sp33datum |  | sp33datum | Datum zahájení procesu
ix_SPPRC_sp07idtypd |  | sp07idtypd | Identifikátor typu procesu
ix_SPPRC_spprco |  | sp33cisdo, sp33cisdpo, sp33cisdro | Identifikace procesu, který předcházjí procesu
ix_SPPRC_spprcodo |  | sp33cisdo, sp33cisdpo, sp33cisdro, sp07idtypd, sp06idsubd, sp33porado | Identifikace operace v procesu, který předcházjí procesu
ix_SPPRC_sp33storno |  | sp33storno | Stav procesu - Nestornovaný,Stornovaný,Stornující
ix_SPPRC_sp33hid |  | sp33hid | Časová identifikace hlavního procesu
ix_SPPRC_sp33semaf |  | sp33semaf | Aktuální hodnota semaforu procesu
ix_SPPRC_spad01adsa |  |  |
ix_SPPRC_adadsatx |  |  |


SPPRCOD Operace procesu

Popis

Operace procesu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp34left | N(5,0) | sp34left | Pozice okna - levá souřadnice | Pozice okna - levá souřadnice
sp34top | N(5,0) | sp34top | Pozice okna - horní souřadnice | Pozice okna - horní souřadnice
sp34height | N(4,0) | sp34height | Výška okna | Výška okna
sp34width | N(4,0) | sp34width | Šířka okna | Šířka okna
sp34main | N(1,0) | sp34main | Kořenová operace procesu | Kořenová operace procesu
sp34ready | N(1,0) | Operace připravena | Operace je připravena ke spuštění | Operace připravena
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp34datzac | T | Zahájení operace | Datum zahájení operace | Datum zahájení operace
bw01uziv1 | C(6) | bw01uziv1 | Identifikace uživatele systému - druhá identifikace | Identifikace uživatele systému - druhá identifikace předplňovaná většinou na pozadí
sp34datkon | T | Ukončení operace | Datum ukončení operace | Datum ukončení operace
sp34ukonce | N(1,0) | sp34ukonce | Operace ukončena | Příznak ukončené operace
sp34ukoncp | N(1,0) | sp34ukoncp | Operace ukončena předběžně | Operace ukončena předběžně
sp34zahaje | N(1,0) | sp34zahaje | Operace zahájena | Operace zahájena
sp34preuko | N(1,0) | Předcházející operace musí být ukončeny | Předcházející operace musí být ukončeny | Předcházející operace musí být ukončeny
sp34tisko | N(1,0) | sp34tisko | Po ukončení výstup operace | Po ukončení výstup operace
sp34tiskd | N(1,0) | sp34tiskd | Po ukončení výstup dokladu | Po ukončení výstup dokladu
sp34autom | N(1,0) | sp34autom | Spouštět operaci automaticky | Spouštět operaci automaticky
sp34ukproc | N(1,0) | sp34ukproc | Ukončuje proces | Ukončuje proces
sp34neauk | N(1,0) | sp34neauk | Operaci automaticky neukončovat po opuštění formuláře klávesou ESC | Operaci automaticky neukončovat po opuštění formuláře klávesou ESC
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw04ident | C(10) | Ident. | Identifikace předlohy pro výstup | Identifikace předlohy pro výstup
bw81id | C(6) | MPV | Identifikace metapředlohy výstupu | Identifikace makropředlohy výstupu
sp50id | C(12) | sp50id | Jednoznačná časová identifikace šablony | Jednoznačná časová identifikace šablony
sp34 | C(12) | sp34 | Jednoznačná časová identifikace operace | Jednoznačná časová identifikace operace
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
sp34hlavpr | N(1,0) | sp34hlavpr | Odvozený proces bude hlavním procesem | Odvozený proces bude hlavním procesem
sp34semaf | N(4,0) | sp34semaf | Změna hodnoty semaforu procesu | Změna hodnoty semaforu procesu
bw05ident | C(6) | Skupina | Identifikace skupiny uživatelů | Identifikace skupiny uživatelů
sp34cisop | C(6) | sp34cisop | Pomocné číslo operace | Pomocné číslo operace
sp34umiste | C(6) | sp34umiste | Umístění | Umístění
sp34idciso | C(3) | Řada operace | Identifikace řady operace |
sp34datzms | T | sp34datzms | Datum změny stavu operace | Datum změny stavu operace
sp34neaktu | N(1,0) | sp34neaktu | Příznak neaktuální operace |
sp44typ | C(3) | sp44typ | Typ práva přístupu | Typ práva přístupu
sp34zahidu | C(2) | sp34zahidu | Zahajující datové úložiště | Zahajující datové úložiště
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Operace procesu - je typu operace | SPPRCOD sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Operace procesu - patří k fyzickému dokladu | SPPRCOD sp33cisd sp33cisdpm sp33cisdr | 1,1 : 0,M s rušením | SPPRC sp33cisd sp33cisdpm sp33cisdr |
Operace procesu - zahájil uživatel | SPPRCOD bw01uziv | 0,1 : 0,M | BWUZIVAT bw01uziv |
Operace procesu - ukončil uživatel | SPPRCOD bw01uziv1 | 0,1 : 0,M | BWUZIVAT bw01uziv |
Operace procesu - použije šablonu | SPPRCOD sp50id | 0,1 : 0,M | SPSABL sp50id |
Operace procesu - má uvedeného adresáta | SPPRCOD ad01id | 1,1 : 0,M | ADADSAT ad01id |
Operace procesu - tiskne metapředlohou výstupu | SPPRCOD bw02krok bw81id | 0,1 : 0,M | BWPRINS bw02krok bw81id |
Předmět projektu - používá inicializační operaci | NKPREDPR sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 0,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Hodnota parametru předmětu projektu - byla založena v operaci procesu | NKHODNP sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Položka smlouvy - vznikla v operaci | NKSMLOUV sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost plnění položky smlouvy - vznikla v operaci | NKSMLPLN sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost o záloze - vznikla v operaci | ZAUDAL sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Projektový úkol - byl založen v operaci | NKUKOL sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Plnění projektového úkolu - vzniklo v operaci | NKUKOLP sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost skladu zvířat - patří do fyzické operace | SZUDAL sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Popis operace procesu pro jednotlivého uživatele - je pro operaci procesu | APOPEPOU sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M s rušením | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost personalistiky - patří do fyzické operace | MZPERUDA sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost správy artiklu - vznikla v operaci | SAUDAL sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 0,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost vývěsky - náleží fyzické operaci dokladu | VYUDALOS sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 0,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Poštovní zásilka - patří operaci dokladu | POPOSTA sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Zpráva - patří k operaci | PZZPRAVY sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 0,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Zpráva - byla vygenerována systémem pro operaci | PZZPRAVY sp34 | 0,1 : 0,M s rušením | SPPRCOD sp34 |
Proces - vznikl na základě fyzické operace nadřízeného dokladu | SPPRC sp33cisdo sp33cisdpo sp33cisdro sp07idtypd sp06idsubd sp33porado | 0,1 : 0,M s rušením | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Vazba operací v procesu - má první uzel | SPPRCVO sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M s rušením | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Vazba operací v procesu - má druhý uzel | SPPRCVO sp33cisd2 sp33cisdp2 sp33cisdr2 sp07idtyp2 sp06idsub2 sp33porad2 | 1,1 : 0,M s rušením | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Vazba proces - prezentovaná operace - váže fyzickou operaci | SPPRCZDR sp33cisd2 sp33cisdp2 sp33cisdr2 sp07idtyp2 sp06idsub2 sp33porad2 | 1,1 : 0,M s rušením | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost obecné komponenty - patří do fyzické operace | OKUDALOS sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Účetní událost - patří operaci dokladu | UCDENIK sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost spravovaného majetku - patří operaci dokladu | SMUDAL sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Rezervace - patří operaci dokladu | SMREZER sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 0,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost odpisovaného majetku - patří operaci procesu | ODUDAL sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost obchodního plnění - patří do fyzické operace | OBUDAL sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost DPH - patří do fyzické operace | DPUDA sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost plateb - patří do fyzické operace | PLUDA sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost skladu - patří do fyzické operace | MTUDA sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost změny stavu peněz - výpisy a příkazy - patří do fyzické operace | ZPUDA sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost dávkové komponenty - patří do fyzické operace | SPDAVKA sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událostní entita mezd - patří do fyzické operace | MZUDALOS sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost vymáhání - náleží fyzické operaci | VMUDA sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Záložka operace - se vztahuje k operaci | SPPRCODZ sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M s rušením | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Hodnota výrazu slučování operace - patří k operaci | SPPRCODV sp34 | 0,1 : 1,1 s rušením | SPPRCOD sp34 |
Úkolové listy - patří do fyzické operace | MZUKOLLI sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Kód provedený po ukončení operace - se vztahuje k operaci procesu | SPPRCODK sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,1 s rušením | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Výrobní zakázka - patří k operaci | VRVYR sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost úkolu ve výrobě - patří do fyzické operace | VRUDOPER sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Externí primární označení operace - se vztahuje k operaci | SPPRCODE sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M s rušením | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Vstup nebo výstup výrobního úkolu - patří do fyzické operace | VRUDOPMA sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 0,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost expedice - patří operaci procesu | EXUDAL sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Operace spojená s událostí expedice - se týká operace | EXUDAOPE sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |

Indexy

Název | Primární | Výraz | Popis
ix_SPPRCOD_spprcod | P | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_SPPRCOD_spprc |  | sp33cisd, sp33cisdpm, sp33cisdr | Identifikace procesu
ix_SPPRCOD_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SPPRCOD_sp33cisdr |  | sp33cisdr | Rok řady čísla procesu
ix_SPPRCOD_sp33cisdpm |  | sp33cisdpm | Pracovní místo čísla řady procesu
ix_SPPRCOD_sp06idsubs |  | sp06idsubs | Identifikace subsystému.
ix_SPPRCOD_sp34ready |  | sp34ready | Operace připravena
ix_SPPRCOD_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SPPRCOD_bw01uziv1 |  | bw01uziv1 | Identifikace uživatele systému - druhá identifikace předplňovaná většinou na pozadí
ix_SPPRCOD_sp34ukonce |  | sp34ukonce | Příznak ukončené operace
ix_SPPRCOD_sp34ukoncp |  | sp34ukoncp | Operace ukončena předběžně
ix_SPPRCOD_sp34zahaje |  | sp34zahaje | Operace zahájena
ix_SPPRCOD_bw04printd |  | bw02krok, bw04ident | Primární klíč předlohy pro výstup BW02krok+BW04ident
ix_SPPRCOD_bwprins |  | bw02krok, bw81id | PI - bw02krok+bw81id
ix_SPPRCOD_sp50id |  | sp50id | Jednoznačná časová identifikace šablony
ix_SPPRCOD_sp34 | U | sp34 | Jednoznačná časová identifikace operace
ix_SPPRCOD_sp33datumx |  |  |
ix_SPPRCOD_sp33hid |  | sp33hid | Časová identifikace hlavního procesu
ix_SPPRCOD_bw05ident |  | bw05ident | Identifikace skupiny uživatelů
ix_SPPRCOD_spad01id |  |  |
ix_SPPRCOD_spad01adsa |  |  |
ix_SPPRCOD_spprcodpc |  | sp34umiste, sp34idciso, sp06idsubs, sp33cisdr, sp33cisdpm, sp34cisop | Referenční identifikace
ix_SPPRCOD_spsp34frei |  |  |
ix_SPPRCOD_sp34idciso |  | sp34idciso |
ix_SPPRCOD_sp34datzms |  | sp34datzms | Datum změny stavu operace
ix_SPPRCOD_ad01id |  | ad01id | Identifikace adresáta


SPPRCODE Externí primární označení operace

Popis

Externí primární označení operace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp98eident | C(20) | sp98eident | Externí identifikace operace | Externí identifikace operace
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Externí primární označení operace - se vztahuje k operaci | SPPRCODE sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M s rušením | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |

Indexy

Název | Primární | Výraz | Popis
ix_SPPRCODE_sp98eident | P | sp98eident | Externí identifikace operace
ix_SPPRCODE_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu


SPPRCODK Kód provedený po ukončení operace

Popis

Kód provedený po ukončení operace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp21kod | M | sp21kod | Kód provedený po ukončení operace | Kód provedený po ukončení operace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Kód provedený po ukončení operace - se vztahuje k operaci procesu | SPPRCODK sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,1 s rušením | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |

Indexy

Název | Primární | Výraz | Popis
ix_SPPRCODK_spprcod | P | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu


SPPRCODV Hodnota výrazu slučování operace

Popis

Hodnota výrazu slučování operace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp34 | C(12) | sp34 | Jednoznačná časová identifikace operace | Jednoznačná časová identifikace operace
sp90hodnot | M | sp90hodnot | Hodnota výrazu slučování operace | Hodnota výrazu slučování operace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Hodnota výrazu slučování operace - patří k operaci | SPPRCODV sp34 | 0,1 : 1,1 s rušením | SPPRCOD sp34 |

Indexy

Název | Primární | Výraz | Popis
ix_SPPRCODV_sp34 | P | sp34 | Jednoznačná časová identifikace operace


SPPRCODZ Záložka operace

Popis

Záložka operace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Záložka operace - se vztahuje k operaci | SPPRCODZ sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M s rušením | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Záložka operace - se vztahuje k adresátovi | SPPRCODZ ad01id | 1,1 : 0,M s rušením | ADADSAT ad01id |

Indexy

Název | Primární | Výraz | Popis
ix_SPPRCODZ_spprcod | P | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_SPPRCODZ_ad01id |  | ad01id | Identifikace adresáta
ix_SPPRCODZ_sp33cisdr |  | sp33cisdr | Rok řady čísla procesu
ix_SPPRCODZ_sp33cisdpm |  | sp33cisdpm | Pracovní místo čísla řady procesu
ix_SPPRCODZ_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_SPPRCODZ_sp06idsubs |  | sp06idsubs | Identifikace subsystému.


SPPRCSAL Saldokontní hodnota procesu

Popis

Saldokontní hodnota procesu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
sp69id | C(6) | Druh | Identifikace druhu saldokontní hodnoty procesu | Identifikace druhu saldokontní hodnoty procesu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp74id | C(6) | sp74id | Umístění | Umístění
sp74hodnot | N(20,4) | sp74hodnot | Saldokontní hodnota v procesu | Saldokontní hodnota v procesu
sp74skryta | N(1,0) | sp74skryta | Skrytá saldokontní hodnota | Skrytá saldokontní hodnota

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Saldokontní hodnota procesu - se týká adresáta | SPPRCSAL ad01id | 1,1 : 0,M | ADADSAT ad01id |
Saldokontní hodnota procesu - se týká druhu saldokontní hodnoty procesu | SPPRCSAL sp69id | 1,1 : 0,M | SPSTATDS sp69id |
Saldokontní hodnota procesu - se týká procesu | SPPRCSAL sp33hid | 1,1 : 0,M s rušením | SPPRC sp33 |
Událost - skladba - koresponduje s aktuální hodnotou procesu | OBAHUD sp33hid sp69id ad01id sp60id sp61id sp74id | 1,1 : 0,M | SPPRCSAL sp33hid sp69id ad01id sp60id sp61id sp74id |
Událost - skladba - koresponduje s aktuální hodnotou procesu | MTAHUD sp33hid sp69id ad01id sp60id sp61id sp74id | 1,1 : 0,M | SPPRCSAL sp33hid sp69id ad01id sp60id sp61id sp74id |
Událost - skladba - koresponduje s aktuální hodnotou procesu | ZPAHUD sp33hid ad01id sp60id sp61id sp74id | 1,1 : 0,M | SPPRCSAL sp33hid ad01id sp60id sp61id sp74id |

Indexy

Název | Primární | Výraz | Popis
ix_SPPRCSAL_spprcsal | P | sp33hid, sp69id, ad01id, sp60id, sp61id, sp74id | Primární index salda procesu
ix_SPPRCSAL_sp33hid |  | sp33hid | Časová identifikace hlavního procesu
ix_SPPRCSAL_sp69id |  | sp69id | Identifikace druhu saldokontní hodnoty procesu
ix_SPPRCSAL_ad01id |  | ad01id | Identifikace adresáta
ix_SPPRCSAL_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_SPPRCSAL_sp74id |  | sp74id | Umístění


SPPRCTEM Označený proces pro tisk dokladu

Popis

Označený proces pro tisk dokladu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp76 | C(10) | Jednoznačná časová identifikace | Jednoznačná časová identifikace | Jednoznačná časová identifikace
sp76id | C(10) | sp76id | Identifikace tisku | Identifikace tisku
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu

Indexy

Název | Primární | Výraz | Popis
ix_SPPRCTEM_sp76 | P | sp76 | Jednoznačná časová identifikace
ix_SPPRCTEM_sp76id |  | sp76id | Identifikace tisku


SPPRCVO Vazba operací v procesu

Popis

Vazba operací procesu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp33cisd2 | C(8) | sp33cisd2 | Pořadové číslo procesu | Číslo dokladu - výběr
sp33cisdp2 | C(2) | IDÚ | Identifikace datového úložiště dat v čísle procesu - druhý uzel | Pracovní místo čísla dokladu - druhý uzel
sp33cisdr2 | C(4) | Rok | Rok řady čísla procesu - druhý uzel | Rok řady čísla dokladu - druhý uzel
sp07idtyp2 | C(6) | sp07idtyp2 | Identifikace druhu operace - druhý uzel | Identifikace druhu operace - druhý uzel
sp06idsub2 | C(3) | Komponenta | Identifikace komponenty - přijemce transformovaných dat | Identifikace komponenty - přijemce transformovaných dat
sp33porad2 | N(2,0) | sp33porad2 | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp35crc | C(5) | sp35crc |  |
sp07idtypa | C(6) | sp07idtypa | Identifikace druhu operace - výstupní uzel dokladu prvního uzlu | Identifikace druhu operace - výstupní uzel dokladu prvního uzlu
sp06idsuba | C(3) | sp06idsuba | Identifikace komponenty - výstupní uzel procesu prvního uzlu | Identifikace komponenty - výstupní uzel procesu prvního uzlu
sp07idtypb | C(6) | sp07idtypb | Identifikace operace - vstupní uzel procesu druhého uzlu | Identifikace operace - vstupní uzel procesu druhého uzlu
sp06idsubb | C(3) | sp06idsubb |  |
sp33porada | N(2,0) | sp33porada | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp33poradb | N(2,0) | sp33poradb | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp36 | C(12) | sp36 | Jednoznačná časová identifikace transformace | Jednoznačná časová identifikace transformace
sp35trans | N(1,0) | sp35trans | Bude probíhat transformace | Bude probíhat transformace
sp35samost | N(1,0) | sp35samost | Vazba není svázaná s vazbami vstupujícími do druhého uzlu | Vazba není svázaná s vazbami vstupujícími do druhého uzlu
sp35poukon | N(1,0) | sp35poukon | Vykonat transformaci po ukončení procesu | Vykonat transformaci po ukončení procesu
sp35poradi | N(3,0) | sp35poradi | Pořadí transformace | Pořadí transformace
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp35rozhod | N(1,0) | sp35rozhod | Zobrazit operace | Napojená operace je připravena k rozhodnutí uživatelem
sp35rozlis | C(1) | sp35rozlis | Rozlišení vazby pro transformaci | Rozlišení vazby pro transformaci
sp35aktzpr | N(4,0) | sp35aktzpr | Posun signalizace zprávy - počet dnů | Posun signalizace zprávy - počet dnů
bw05ident | C(6) | Skupina | Identifikace skupiny uživatelů | Identifikace skupiny uživatelů
sp19id | C(6) | Předkontace | Identifikace obecné předkontace | Identifikace obecné předkontace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vazba operací v procesu - má první uzel | SPPRCVO sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M s rušením | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Vazba operací v procesu - má druhý uzel | SPPRCVO sp33cisd2 sp33cisdp2 sp33cisdr2 sp07idtyp2 sp06idsub2 sp33porad2 | 1,1 : 0,M s rušením | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Vazba operací v procesu - má vstupní operaci dokladu v druhém uzlu typu operace/dokladu | SPPRCVO sp07idtypb sp06idsubb | 0,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Vazba operací v procesu - používá transformaci | SPPRCVO sp36 | 0,1 : 0,M | SPTRN sp36 |
Vazba operací v procesu - má výstupní operaci dokladu v prvním uzlu typu operace/dokladu | SPPRCVO sp07idtypa sp06idsuba | 0,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Vazba operací v procesu - má první uzel typu operace | SPPRCVO sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Vazba operací v procesu - je spojena s významem položky obecné předkontace | SPPRCVO sp19id | 0,1 : 0,M | SPPREDK sp19id |
Vazba operací v procesu - bude rozhodnuta skupinou uživatelů | SPPRCVO bw05ident | 0,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_SPPRCVO_spprcvo | P | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad, sp33cisd2, sp33cisdp2, sp33cisdr2, sp07idtyp2, sp06idsub2, sp33porad2, sp35crc | Primární index vazby
ix_SPPRCVO_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_SPPRCVO_spprcod2 |  | sp33cisd2, sp33cisdp2, sp33cisdr2, sp07idtyp2, sp06idsub2, sp33porad2 | Identifikace operace - druhý uzel
ix_SPPRCVO_spprc |  | sp33cisd, sp33cisdpm, sp33cisdr | Identifikace procesu
ix_SPPRCVO_spprc2 |  | sp33cisd2, sp33cisdp2, sp33cisdr2 |
ix_SPPRCVO_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SPPRCVO_sptyp2 |  | sp07idtyp2, sp06idsub2 |
ix_SPPRCVO_sptypa |  | sp07idtypa, sp06idsuba |
ix_SPPRCVO_sptypb |  | sp07idtypb, sp06idsubb |
ix_SPPRCVO_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_SPPRCVO_sp07idtyp2 |  | sp07idtyp2 | Identifikace druhu operace - druhý uzel
ix_SPPRCVO_sp07idtypa |  | sp07idtypa | Identifikace druhu operace - výstupní uzel dokladu prvního uzlu
ix_SPPRCVO_sp07idtypb |  | sp07idtypb | Identifikace operace - vstupní uzel procesu druhého uzlu
ix_SPPRCVO_sp36 |  | sp36 | Jednoznačná časová identifikace transformace
ix_SPPRCVO_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SPPRCVO_sp35rozhod |  | sp35rozhod | Napojená operace je připravena k rozhodnutí uživatelem
ix_SPPRCVO_bw05ident |  | bw05ident | Identifikace skupiny uživatelů
ix_SPPRCVO_sp19id |  | sp19id | Identifikace obecné předkontace


SPPRCZDR Vazba proces - prezentovaná operace

Popis

Vazba proces - prezentovaná operace procesu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp33cisd2 | C(8) | sp33cisd2 | Pořadové číslo procesu | Číslo dokladu - výběr
sp33cisdp2 | C(2) | IDÚ | Identifikace datového úložiště dat v čísle procesu - druhý uzel | Pracovní místo čísla dokladu - druhý uzel
sp33cisdr2 | C(4) | Rok | Rok řady čísla procesu - druhý uzel | Rok řady čísla dokladu - druhý uzel
sp07idtyp2 | C(6) | sp07idtyp2 | Identifikace druhu operace - druhý uzel | Identifikace druhu operace - druhý uzel
sp06idsub2 | C(3) | Komponenta | Identifikace komponenty - přijemce transformovaných dat | Identifikace komponenty - přijemce transformovaných dat
sp33porad2 | N(2,0) | sp33porad2 | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vazba proces - prezentovaná operace - váže fyzický doklad | SPPRCZDR sp33cisd sp33cisdpm sp33cisdr | 1,1 : 0,M s rušením | SPPRC sp33cisd sp33cisdpm sp33cisdr |
Vazba proces - prezentovaná operace - váže fyzickou operaci | SPPRCZDR sp33cisd2 sp33cisdp2 sp33cisdr2 sp07idtyp2 sp06idsub2 sp33porad2 | 1,1 : 0,M s rušením | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |

Indexy

Název | Primární | Výraz | Popis
ix_SPPRCZDR_spprczdr | P | sp33cisd, sp33cisdpm, sp33cisdr, sp33cisd2, sp33cisdp2, sp33cisdr2, sp07idtyp2, sp06idsub2, sp33porad2 | Primární index SPPRCZDR
ix_SPPRCZDR_spprc |  | sp33cisd, sp33cisdpm, sp33cisdr | Identifikace procesu
ix_SPPRCZDR_spprcod2 |  | sp33cisd2, sp33cisdp2, sp33cisdr2, sp07idtyp2, sp06idsub2, sp33porad2 | Identifikace operace - druhý uzel


SPPREDK Obecná předkontace

Popis

Obecná předkontace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp19id | C(6) | Předkontace | Identifikace obecné předkontace | Identifikace obecné předkontace
sp19nazpre | C(40) | Název předkontace | Název obecné předkontace | Název obecné předkontace
sp19koment | M | Poznámka | Poznámka k obecné předkontaci | Poznámka k obecné předkontaci
sp19akter | N(1,0) | sp19akter | Předkontace spojená s adresátem | Předkontace spojená s adresátem
spe1id | C(6) | Druh | Identifikátor druhu obecné předkontace | Identifikátor druhu obecné předkontace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Obecná předkontace - je druhu | SPPREDK spe1id | 1,1 : 0,M | SPPREDKD spe1id |
Obecná předkontace pro transformaci - určuje předkontaci | SPTRNPRE sp19id | 1,1 : 0,M | SPPREDK sp19id |
Dynamická transformace druhu plnění projektového úkolu - používá obecnou předkontaci | NKUKOPDT sp19id | 0,1 : 0,M | SPPREDK sp19id |
Vazba druhů operací v druhu procesu - je spojena s významem položky obecné předkontace | SPTYPVO sp19id | 0,1 : 0,M | SPPREDK sp19id |
Vazba operací v procesu - je spojena s významem položky obecné předkontace | SPPRCVO sp19id | 0,1 : 0,M | SPPREDK sp19id |
Dynamické spojení operací - používá obecnou předkontaci | SPTYPDSP sp19id | 0,1 : 0,M | SPPREDK sp19id |
Položka obecné předkontace - patří k obecné transformaci | SPPREDKP sp19id | 1,1 : 0,M | SPPREDK sp19id |

Indexy

Název | Primární | Výraz | Popis
ix_SPPREDK_sp19id | P | sp19id | Identifikace obecné předkontace
ix_SPPREDK_sp19nazpre |  | sp19nazpre | Název obecné předkontace
ix_SPPREDK_spe1id |  | spe1id | Identifikátor druhu obecné předkontace


SPPREDKD Druh obecné předkontace

Popis

Druh obecné předkontace

Atributy

Atribut | Typ | Návěští | Message | Popis
spe1id | C(6) | Druh | Identifikátor druhu obecné předkontace | Identifikátor druhu obecné předkontace
spe1nazdru | C(40) | Název druhu | Název druhu obecné předkontace | Název druhu obecné předkontace
spe1koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Systémové certifikáty - je druhu | SPCERT spe1id | 1,1 : 0,M | SPPREDKD spe1id |
Obecná předkontace - je druhu | SPPREDK spe1id | 1,1 : 0,M | SPPREDKD spe1id |

Indexy

Název | Primární | Výraz | Popis
ix_SPPREDKD_spe1id | P | spe1id | Identifikátor druhu obecné předkontace
ix_SPPREDKD_spe1nazdru |  | spe1nazdru | Název druhu obecné předkontace


SPPREDKP Položka obecné předkontace

Popis

Položka obecné transformace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp19id | C(6) | Předkontace | Identifikace obecné předkontace | Identifikace obecné předkontace
sp47id | C(6) | Význam | Identifikace významu položky obecné předkontace | Identifikace významu položky obecné předkontace
sp23datpla | D | Platnost od | Datum platnosti položky obecné předkontace od | Datum platnosti položky obecné předkontace od
sp23hodnot | M | Hodnota | Hodnota položky překontace | Hodnota položky překontace
sp23koment | M | Poznámka | Poznámka k položce předkontace | Poznámka k položce předkontace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Položka obecné předkontace - patří k obecné transformaci | SPPREDKP sp19id | 1,1 : 0,M | SPPREDK sp19id |
Položka obecné předkontace - má význam | SPPREDKP sp47id | 1,1 : 0,M | SPPREDKV sp47id |

Indexy

Název | Primární | Výraz | Popis
ix_SPPREDKP_sppredkp | P | sp19id, sp47id, sp23datpla | PI - sp19id+sp47id
ix_SPPREDKP_sp19id |  | sp19id | Identifikace obecné předkontace
ix_SPPREDKP_sp47id |  | sp47id | Identifikace významu položky obecné předkontace


SPPREDKQ Položka obecné předkontace - pohled s datumem platnosti do

Popis

Položka obecné předkontace - pohled s datumem platnosti do

Atributy

Atribut | Typ | Návěští | Message | Popis
sp19id | C(6) | Předkontace | Identifikace obecné předkontace | Identifikace obecné předkontace
sp47id | C(6) | Význam | Identifikace významu položky obecné předkontace | Identifikace významu položky obecné předkontace
sp23datpla | D | Platnost od | Datum platnosti položky obecné předkontace od | Datum platnosti položky obecné předkontace od
sp23hodnot | M | Hodnota | Hodnota položky překontace | Hodnota položky překontace
sp23koment | M | Poznámka | Poznámka k položce předkontace | Poznámka k položce předkontace


SPPREDKV Význam položky obecné předkontace

Popis

Význam položky obecné předkontace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp47id | C(6) | Význam | Identifikace významu položky obecné předkontace | Identifikace významu položky obecné předkontace
sp47nazvyz | C(40) | Popis významu | Popis významu položky obecné předkontace | Popis významu položky obecné předkontace
sp47koment | M | Poznámka | Poznámka k významu položky obecné předkontace | Poznámka k významu položky obecné předkontace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Uživatel systému - je spojen s významen položky obecné předkontace | BWUZIVAT sp47id | 0,1 : 0,M | SPPREDKV sp47id |
Položka obecné předkontace - má význam | SPPREDKP sp47id | 1,1 : 0,M | SPPREDKV sp47id |

Indexy

Název | Primární | Výraz | Popis
ix_SPPREDKV_sp47id | P | sp47id | Identifikace významu položky obecné předkontace
ix_SPPREDKV_sp47nazvyz |  | sp47nazvyz | Popis významu položky obecné předkontace


SPPREDLO Typ předlohy dokumentu

Popis

Objektem typu SPPREDLO je popis předlohy dokumentu. Musí obsahovat identifikaci popisu programu volaného při zpracovnání dokumentu (#SPPROGRA). Dále obsahuje příznak, zda se má při zpracování dokumentu vytvářet MAILMERGE. Může obsahovat implicitní obsah dokumentu, který má být použit při tvorbě nového dokumentu.
Př.: předloha dokumentu typu dopis, formulář pracovní smlouvy
*** Dříve VYVESKAT.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp01id | C(6) | Předloha | Identifikátor předlohy. | Identifikace předlohy. *** Dříve VYVT_ID.
sp01 | C(12) | sp01 | Jednoznačná časová identifikace předlohy dokumentu |
sp01predlo | C(30) | Název předlohy dokumentu | Text výstižně popisující předlohu. | Text výstižně popisující předlohu. *** Dříve VYVT_TEXT.
sp01koment | M | Komentář | Komentář, který detailně popisuje význam předlohy. | Komentář, který detailně popisuje význam předlohy.
sp02id | C(5) | Aplikace | Identifikace spouštěného programu. | Identifikace spouštěného programu. *** Dříve VYVP_ID.
sp57id | C(6) | Druh | Identifikátor druhu dokumentu | Identifikátor druhu dokumentu
sp01empty | N(1,0) | Prázdná předloha | Příznak nevytvoření imlicitní předlohy a současně i blokování proti opravě. | Příznak nevytvoření imlicitní předlohy a současně i blokování proti opravě. *** Dříve VYVT_PREDL.
sp01blok | N(1,0) | Blokování | Příznak blokování dokumentu předlohy proti opravě. | Příznak blokování dokumentu předlohy proti opravě. *** Dříve VYVT_BLOK.
sp01merge | N(1,0) | sp01merge | Příznak vytvoření dat pro hromadnou korespondenci. | Příznak vytvářet mailmerge. *** Dříve VYVT_MAIL.
sp01mailfi | C(8) | Soubor MailMerge | Jméno souboru hromadné korespondece (MailMerge). |
sp01mailpa | C(100) | Cesta pro soubor MailMerge | Cesta (PATH) pro uložení souboru pro hromadnou korespondenci (MailMerge). |
sp01mailpr | C(3) | sp01mailpr | Přípona souboru pro mailmerge | Přípona souboru pro mailmerge
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp01obs | M | sp01obs | Konkrétní dokument. |
sp01packed | L | sp01packed | Pakováno / nepakováno | Pakováno / nepakováno
sp01aktual | N(1,0) | sp01aktual | Příznak aktuálnosti předlohy |
sp01script | M | Script | Skript v jazyce Foxpro vyvolaný po otevření dokumentu (parametry_this,_sp26,_predloha,_poprve) | Skript v jazyce Foxpro vyvolaný po otevření dokumentu (parametry_this,_sp26,_predloha,_poprve)
sp01lbx2 | M | Definice pro konvertor WINWORD | Definice pro konvertor WINWORD | Definice pro konvertor WINWORD

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Typ předlohy dokumentu - používá program | SPPREDLO sp02id | 1,1 : 0,M s rušením | SPPROGRA sp02id |
Typ předlohy dokumentu - byla založena pracovníkem | SPPREDLO bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Typ předlohy dokumentu - je druhu | SPPREDLO sp57id | 1,1 : 0,M | SPDOKTYP sp57id |
Dokument - je vytvořen podle předlohy | SPDOKOBS sp01id | 1,1 : 0,M | SPPREDLO sp01id |
Záznam o posledním použitém druhu dokumentu a předloze - pamatuje typy předlohy | SPDOKMEM sp01id | 1,1 : 0,M s rušením | SPPREDLO sp01id |

Indexy

Název | Primární | Výraz | Popis
ix_SPPREDLO_sp01id | P | sp01id | Identifikace předlohy.
ix_SPPREDLO_sp01 | U | sp01 |
ix_SPPREDLO_sp01predlo |  | sp01predlo | Text výstižně popisující předlohu.
ix_SPPREDLO_sp02id |  | sp02id | Identifikace spouštěného programu.
ix_SPPREDLO_sp57id |  | sp57id | Identifikátor druhu dokumentu


SPPREKLA Předklad umístění nebo druhu

Popis

Předklad umístění nebo druhu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp38id | C(3) | Jazyk | Identifikace jazyka | Identifikace jazyka
bw10nazev | C(8) | Tabulka | Název entity | Název entity
spc7id | C(6) | Umístění | Identifikace umístění nebo druhu | Identifikace umístění nebo druhu
spc7idsub | C(3) | Subidentifikace | Subidentifikace | Subidentifikace
spc7text | C(40) | Popis | Popis | Popis
spc7koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Předklad umístění nebo druhu - je překladem v jazyce | SPPREKLA sp38id | 1,1 : 0,M | SPJAZYK sp38id |

Indexy

Název | Primární | Výraz | Popis
ix_SPPREKLA_spprekla | P | sp38id, bw10nazev, spc7id, spc7idsub | PI - bw10nazev+sp38id+spc7id+spc7idsub
ix_SPPREKLA_sp38id |  | sp38id | Identifikace jazyka


SPPREKLP Přeložené návěští a poznámka proměnné volné karty nebo obecného výběru

Popis

Přeložené návěští a poznámka proměnné volné karty nebo obecného výběru nebo importu

Atributy

Atribut | Typ | Návěští | Message | Popis
bw10nazev | C(8) | Tabulka | Název entity | Název entity
sp38id | C(3) | Jazyk | Identifikace jazyka | Identifikace jazyka
spe8typ | N(10,0) | Typ | Typ textu | Typ textu
spe8key1 | C(12) | spe8key1 | Klíč překládané položky 1 | Klíč překládané položky 1
spe8key2 | C(12) | spe8key2 | Klíč překládané položky 2 | Klíč překládané položky 2
spe8key3 | C(12) | spe8key3 | Klíč překládané položky 3 | Klíč překládané položky 3
spe8text | M | Text | Text | Text
spe8koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Přeložené návěští a poznámka proměnné volné karty nebo obecného výběru nebo importu - je v jazyce | SPPREKLP sp38id | 1,1 : 0,M | SPJAZYK sp38id |

Indexy

Název | Primární | Výraz | Popis
ix_SPPREKLP_sppreklp | P | bw10nazev, sp38id, spe8typ, spe8key1, spe8key2, spe8key3 | PI - bw10nazev+sp38id+spe8typ+spe8key1+spe8key2+spe8key3
ix_SPPREKLP_sp38id |  | sp38id | Identifikace jazyka


SPPREZ Prezentace procesu

Popis

Prezentace procesu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp77id | C(6) | Prezentace | Identifikátor prezentace procesu | Identifikátor prezentace procesu
sp77prezen | C(40) | sp77prezen | Název prezentace procesu | Název prezentace procesu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp77koment | M | Poznámka | Poznámka k prezentaci procesu | Poznámka k prezentaci procesu
sp77datzal | T | sp77datzal | Datum založení | Datum založení

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Prezentace procesu - založil uživatel | SPPREZ bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Předloha pro výstup - souvisí s prezentací procesu | BWPRINTD sp77id | 0,1 : 0,M | SPPREZ sp77id |
Druh operace obsažené v prezentaci procesu - patří prezentaci | SPPREZPL sp77id | 1,1 : 0,M s rušením | SPPREZ sp77id |

Indexy

Název | Primární | Výraz | Popis
ix_SPPREZ_sp77id | P | sp77id | Identifikátor prezentace procesu
ix_SPPREZ_sp77prezen |  | sp77prezen | Název prezentace procesu
ix_SPPREZ_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPPREZPL Druh operace obsažené v prezentaci procesu

Popis

Druhy operací obsažené v prezentaci procesu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp77id | C(6) | Prezentace | Identifikátor prezentace procesu | Identifikátor prezentace procesu
sp78poradi | N(5,0) | Pořadí | Pořadí operace v prezentaci | Pořadí operace v prezentaci
sp78vpoces | N(1,0) | sp78vpoces | Prezentovat operaci přímo obsaženou v procesu |
sp78refer | N(1,0) | sp78refer | Operace je referenční | Operace je referenční

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh operace obsažené v prezentaci procesu - se týká druhu operace | SPPREZPL sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Druh operace obsažené v prezentaci procesu - patří prezentaci | SPPREZPL sp77id | 1,1 : 0,M s rušením | SPPREZ sp77id |

Indexy

Název | Primární | Výraz | Popis
ix_SPPREZPL_spprezpl | P | sp07idtyp, sp06idsubs, sp77id |
ix_SPPREZPL_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SPPREZPL_sp77id |  | sp77id | Identifikátor prezentace procesu
ix_SPPREZPL_sp06idsubs |  | sp06idsubs | Identifikace subsystému.


SPPRISTI Pravidlo inicializace přístupových práv při vstupu nového druhu

Popis

Pravidlo inicializace přístupových práv při vstupu nového druhu

Atributy

Atribut | Typ | Návěští | Message | Popis
spe9id | C(6) | Pravidlo | Identifikace pravidla inicializace přístupových práv při vstupu nového druhu | Identifikace pravidla inicializace přístupových práv při vstupu nového druhu
spe9nazpra | C(40) | Popis pravidla | Popis pravidla inicializace přístupových práv při vstupu nového druhu | Popis pravidla inicializace přístupových práv při vstupu nového druhu
spe9typ | N(1,0) | Typ | Typ pravidla | Typ pravidla
spe9prior | N(3,0) | Priorita | Priorita aplikace pravidla | Priorita aplikace pravidla
spe9koment | M | Poznámka | Poznámka | Poznámka

Indexy

Název | Primární | Výraz | Popis
ix_SPPRISTI_spe9id | P | spe9id | Identifikace pravidla inicializace přístupových práv při vstupu nového druhu
ix_SPPRISTI_spe9nazpra |  | spe9nazpra | Popis pravidla inicializace přístupových práv při vstupu nového druhu
ix_SPPRISTI_spe9prior |  | spe9prior | Priorita aplikace pravidla


SPPRISTS Přístupové právo skupiny uživatelů k věci

Popis

Přístupové právo skupiny uživatelů k věci

Atributy

Atribut | Typ | Návěští | Message | Popis
sp44vec | C(6) | sp44vec | Přistupovaná věc | Přistupovaná věc
sp44typ | C(3) | sp44typ | Typ práva přístupu | Typ práva přístupu
bw05ident | C(6) | Skupina | Identifikace skupiny uživatelů | Identifikace skupiny uživatelů
sp44pristu | N(1,0) | Právo přístupu | Právo přístupu - Žádné,Čtení,Zápis | Právo přístupu - Žádné,Čtení,Zápis
sp44oprava | N(1,0) | sp44oprava | Nepovoleno opravovat | Nepovoleno opravovat
sp44ukonce | N(1,0) | sp44ukonce | Nepovoleno ukončit operaci | Nepovoleno ukončit operaci

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Přístupové právo skupiny uživatelů k věci - souvisí se skupinou uživatelů | SPPRISTS bw05ident | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_SPPRISTS_spprists | P | sp44vec, sp44typ, bw05ident | Primární index přístupového práva skupiny uživatelů k věci
ix_SPPRISTS_sppristv |  | sp44typ, sp44vec | PI - věci s přístupem
ix_SPPRISTS_sp44vec |  | sp44vec | Přistupovaná věc
ix_SPPRISTS_bw05ident |  | bw05ident | Identifikace skupiny uživatelů


SPPRISTU Přístupové právo uživatele k věci

Popis

Přístupové právo uživatele k věci

Atributy

Atribut | Typ | Návěští | Message | Popis
sp44vec | C(6) | sp44vec | Přistupovaná věc | Přistupovaná věc
sp44typ | C(3) | sp44typ | Typ práva přístupu | Typ práva přístupu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp44pristu | N(1,0) | Právo přístupu | Právo přístupu - Žádné,Čtení,Zápis | Právo přístupu - Žádné,Čtení,Zápis
sp44oprava | N(1,0) | sp44oprava | Nepovoleno opravovat | Nepovoleno opravovat
sp44ukonce | N(1,0) | sp44ukonce | Nepovoleno ukončit operaci | Nepovoleno ukončit operaci
sp44expl | N(1,0) | sp44expl | Právo je uživateli přiřazeno explicitně | Právo je uživateli přiřazeno explicitně

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Přístupové právo uživatele k věci - souvisí s uživatelem | SPPRISTU bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_SPPRISTU_sppristu | P | sp44vec, sp44typ, bw01uziv | Primární index přístupových práv
ix_SPPRISTU_sppristv |  | sp44typ, sp44vec | PI - věci s přístupem
ix_SPPRISTU_sppristux2 |  | sp44typ, bw01uziv, sp44pristu | to byl index, ktery zpusoboval zpomaleni SQL dotazu - preferoval SPPRISTU
ix_SPPRISTU_sp44vec |  | sp44vec | Přistupovaná věc
ix_SPPRISTU_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPPRISTV Věc s přístupem

Popis

Věc s přístupem

Atributy

Atribut | Typ | Návěští | Message | Popis
sp44typ | C(3) | sp44typ | Typ práva přístupu | Typ práva přístupu
sp44vec | C(6) | sp44vec | Přistupovaná věc | Přistupovaná věc
sp85text | C(40) | Popis | Popis věci | Popis věci
sp85nazpra | C(40) | Název práva | Název práva věci s přístupem | Název práva věci s přístupem
sp85koment | M | Poznámka | Poznámka k věci s přístupem | Poznámka k věci s přístupem
sp85skup | N(1,0) | Skupina práv | Skupina práv Procesy/Operace/Ostatní | Skupina práv Procesy a operace/Ostatní

Indexy

Název | Primární | Výraz | Popis
ix_SPPRISTV_sppristv | P | sp44typ, sp44vec | PI - věci s přístupem
ix_SPPRISTV_sp85text |  | sp85text | Popis věci
ix_SPPRISTV_sp85nazpra |  | sp85nazpra | Název práva věci s přístupem


SPPROGAK Akce volání programu dokumentu

Popis

Akce volání programu dokumentu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp02id | C(5) | Aplikace | Identifikace spouštěného programu. | Identifikace spouštěného programu. *** Dříve VYVP_ID.
spc8id | C(6) | Akce | Interní identifikace akce | Interní identifikace akce
spa6id | C(6) | Druh | Identifikace druhu implemetačního rozšíření | Identifikace druhu implemetačního rozšíření
spc1id | C(6) | Kategorie | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
spc8porad | N(3,0) | Pořadí | Pořadí zobrazení akce | Pořadí zobrazení akce
spc8nazev | C(40) | Název akce | Název akce | Název akce
spc8statba | M | Stav.řádek | Poznámka o akci v menu | Poznámka o akci v menu
spc8kod | M | Kód | Kód akce | Kód akce
spc8kodwhe | M | Kód podm. | Kód podmínky akce | Kód podmínky akce
spc8koment | M | Poznámka | Poznámka | Poznámka
spc8char | N(2,0) | Charakter | Charakter akce | Charakter akce
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Akce volání programu dokumentu - je přidělena k programu | SPPROGAK sp02id | 1,1 : 0,M | SPPROGRA sp02id |
Akce volání programu dokumentu - je druhu doplňující vlastnosti | SPPROGAK spa6id | 1,1 : 0,M | SPCINDVT spa6id |
Akce volání programu dokumentu - patří do kategorie | SPPROGAK spc1id | 1,1 : 0,M | SPCINDVK spc1id |

Indexy

Název | Primární | Výraz | Popis
ix_SPPROGAK_spprogak | P | sp02id, spc8id | PI - sp02id+spc8id
ix_SPPROGAK_sp02id |  | sp02id | Identifikace spouštěného programu.
ix_SPPROGAK_spa6id |  | spa6id | Identifikace druhu implemetačního rozšíření
ix_SPPROGAK_spc1id |  | spc1id | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu


SPPROGRA Volání programu

Popis

Objektem typu SPPROGRA je definice a způsob vyvolání programu pro zpracovnání dokumentu.

Př.: Word, MS Excell

*** Dříve VYVESKAU.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp02id | C(5) | Aplikace | Identifikace spouštěného programu. | Identifikace spouštěného programu. *** Dříve VYVP_ID.
sp02nazev | C(25) | Název | Název spouštěné aplikace | Název spouštěného programu. *** Dříve VYVT_NAZEV.
sp02olezab | C(8) | Zabudované OLE | Zabudované OLE |
sp02doswin | N(1,0) | Typ spuštění | Aplikace Windows DDE / Dos / Windows OLE / Zabudované OLE / Windows CALL |
sp02pripon | C(15) | Přípona | Přípona pracovního souboru. | Přípona pracovního souboru. *** Dříve VYT_PRIP.
sp02ddemes | C(30) | Zpráva DDE | Zpráva DDE | Zpráva DDE
sp02ddeapl | C(30) | Aplikace | Aplikace DDE | Aplikace DDE
sp02ddepol | C(30) | Položka | Položka DDE | Položka DDE
sp02empty | N(1,0) | sp02empty | Vytvářet prázdný soubor při prvém použití. | Vytvářet prázdný soubor při prvém použití. *** Dříve VYVT_GENER.
sp02call | C(60) | Volání | Volání programu - příkazový řádek. | Volání programu - příkazový řádek. *** Dříve VYVT_PROG.
sp02calln | C(60) | dle WIN.INI | Volání programu - příkazový řádek.z WIN.INI |
sp02callpa | N(1,0) | Parametry volání | Parametry volání aplikace | Parametry volání aplikace - způsob otevření okna s aplikací
sp02olecla | C(30) | Třída OLE | Třída OLE | Třída OLE - specifikace třídy objektu typu OLE.
sp02local | N(1,0) | sp02local | Spuštění lokálně |
sp02udrzba | C(20) | Údržba | Program spouštěný při údržbě předlohy. | Program spouštěný při údržbě předlohy. *** Dříve VYVT_PROGP.
sp02wfe | N(1,0) | sp02wfe | Příznak čekání na ukončení práce aplikace |
sp02oinfo | N(1,0) | Info o otevření | Zobrazit informaci o otevření dokumentu | Zobrazit informaci o otevření dokumentu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Akce volání programu dokumentu - je přidělena k programu | SPPROGAK sp02id | 1,1 : 0,M | SPPROGRA sp02id |
Typ předlohy dokumentu - používá program | SPPREDLO sp02id | 1,1 : 0,M s rušením | SPPROGRA sp02id |

Indexy

Název | Primární | Výraz | Popis
ix_SPPROGRA_sp02id | P | sp02id | Identifikace spouštěného programu.
ix_SPPROGRA_sp02nazev |  | sp02nazev | Název spouštěného programu.


SPSABL Šablona

Popis

Šablona

Atributy

Atribut | Typ | Návěští | Message | Popis
sp50id | C(12) | sp50id | Jednoznačná časová identifikace šablony | Jednoznačná časová identifikace šablony
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp50sablon | C(40) | Šablona | Název šablony |
sp50koment | M | Komentář | Poznámka k šabloně | Poznámka k šabloně
sp50okleft | N(4,0) | sp50okleft | Umístění tlačítka OK - LEFT | Umístění tlačítka OK - LEFT
sp50oktop | N(4,0) | sp50oktop | Umístění tlačítka OK - TOP | Umístění tlačítka OK - TOP
sp50sttop | N(4,0) | sp50sttop | Umístění tlačítka STORNO - TOP | Umístění tlačítka STORNO - TOP
sp50stleft | N(4,0) | sp50stleft | Umístění tlačítka STORNO - LEFT | Umístění tlačítka STORNO - LEFT
sp50height | N(4,0) | sp50height | Umístění okna - HEIGHT | Umístění okna - HEIGHT
sp50width | N(4,0) | sp50width | Umístění okna - WIDTH | Umístění okna - WIDTH
sp50zdroje | C(4) | Vstup šablony | Identifikace vstupu šablony |
sp54id | C(6) | Druh šablony | Druh šablony | Druh šablony
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp50datum | T | Datum vzniku | Datum vzniku šablony | Datum vzniku šablony
sp50verej | N(1,0) | sp50verej | Veřejná šablona - je přístupná všem uživatelům systému | Veřejná šablona - je přístupná všem uživatelům systému
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw10nazev | C(8) | Tabulka | Název entity | Název entity
sp93id | C(6) | I-E | Identifikace importu-exportu | Identifikace importu
sp50update | N(1,0) | Hromadná oprava | Šablona pro hromadnou opravu záznamů | Šablona pro hromadnou opravu záznamů

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Šablona - je druhu šablony | SPSABL sp54id | 1,1 : 0,M | SPSABLT sp54id |
Šablona - byla založena uživatelem | SPSABL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Šablona - definuje odkaz na import | SPSABL bw02krok bw10nazev sp93id | 0,1 : 0,M | SPIMP bw02krok bw10nazev sp93id |
Druh operace v druhu procesu - použije šablonu | SPTYPOD sp50id | 0,1 : 0,M s rušením | SPSABL sp50id |
Operace procesu - použije šablonu | SPPRCOD sp50id | 0,1 : 0,M | SPSABL sp50id |
Pravidlo definice šablony - patří do šablony | SPSABLR sp50id | 1,1 : 0,M s rušením | SPSABL sp50id |
Proměnná šablony - patří do šablony | SPSABLP sp50id | 1,1 : 0,M s rušením | SPSABL sp50id |
Poslední šablona spuštěná uživatelem v komponentě - je šablona | SPSABLM sp50id | 1,1 : 0,M s rušením | SPSABL sp50id |

Indexy

Název | Primární | Výraz | Popis
ix_SPSABL_sp50id | P | sp50id | Jednoznačná časová identifikace šablony
ix_SPSABL_sp50sablon |  | sp50sablon |
ix_SPSABL_sp54id |  | sp54id | Druh šablony
ix_SPSABL_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SPSABL_spimp |  | bw02krok, bw10nazev, sp93id | bw02krok+bw10nazev+sp93id


SPSABLA Atribut pravidla definice šablony

Popis

Atribut pravidla definice šablony

Atributy

Atribut | Typ | Návěští | Message | Popis
sp51 | C(12) | sp51 | Jednoznačná časová identifikace pravidla šablony | Jednoznačná časová identifikace pravidla šablony
sp39nazev | C(10) | Atribut události | Atribut události | Atribut události
sp52 | C(12) | sp52 | Jednoznačná časová identifikace proměnné šablony | Jednoznačná časová identifikace proměnné šablony
sp53opak | N(1,0) | sp53opak | Opakovaná hodnota atributu | Opakovaná hodnota atributu
sp53hodn | M | sp53hodn | Hodnota vložená do atributu | Hodnota vložená do atributu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Atribut pravidla definice šablony - patří do definice šablony | SPSABLA sp51 | 1,1 : 0,M s rušením | SPSABLR sp51 |
Atribut pravidla definice šablony - je naplněn proměnnou šablony | SPSABLA sp52 | 0,1 : 0,M s rušením | SPSABLP sp52 |

Indexy

Název | Primární | Výraz | Popis
ix_SPSABLA_spsabla | P | sp51, sp39nazev | Pravidlo šablony + atribut
ix_SPSABLA_sp51 |  | sp51 | Jednoznačná časová identifikace pravidla šablony
ix_SPSABLA_sp52 |  | sp52 | Jednoznačná časová identifikace proměnné šablony


SPSABLM Poslední šablona spuštěná uživatelem v komponentě

Popis

Poslední šablona spuštěná uživatelem v komponentě

Atributy

Atribut | Typ | Návěští | Message | Popis
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp50id | C(12) | sp50id | Jednoznačná časová identifikace šablony | Jednoznačná časová identifikace šablony
sp54id | C(6) | Druh šablony | Druh šablony | Druh šablony

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Poslední šablona spuštěná uživatelem v komponentě - je šablona | SPSABLM sp50id | 1,1 : 0,M s rušením | SPSABL sp50id |
Poslední šablona spuštěná uživatelem v komponentě - byla vybrána z typu šablony | SPSABLM sp54id | 0,1 : 0,M s rušením | SPSABLT sp54id |
Poslední šablona spuštěná uživatelem v komponentě - souvisí s uživatelem | SPSABLM bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_SPSABLM_spsablm | P | sp06idsubs, bw01uziv | Prim.ind. poslední šablona spuštěná uživatelem v komponentě
ix_SPSABLM_sp50id |  | sp50id | Jednoznačná časová identifikace šablony
ix_SPSABLM_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SPSABLM_sp54id |  | sp54id | Druh šablony


SPSABLP Proměnná šablony

Popis

Proměnná šablony

Atributy

Atribut | Typ | Návěští | Message | Popis
sp52 | C(12) | sp52 | Jednoznačná časová identifikace proměnné šablony | Jednoznačná časová identifikace proměnné šablony
sp50id | C(12) | sp50id | Jednoznačná časová identifikace šablony | Jednoznačná časová identifikace šablony
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp52cisprm | C(4) | Proměnná | Číslo proměnné definice šablony | Číslo proměnné definice šablony
sp52nazev | C(10) | Název proměnné | Název proměnné | Název proměnné
sp52typ | N(1,0) | Typ | Typ proměnné | Typ proměnné
sp52delka | N(3,0) | Délka proměnné | Délka proměnné | Délka proměnné
sp52deseti | N(2,0) | Počet desetin | Počet desetin | Počet desetin
sp52label | C(30) | Návěští proměnné | Návěští proměnné | Návěští proměnné
sp52trida | N(1,0) | Třída | Třída ovládacího prvku | Třída ovládacího prvku
sp52left | N(4,0) | sp52left | Umístění LEFT | Umístění LEFT
sp52top | N(4,0) | sp52top | Umístění TOP | Umístění TOP
sp52height | N(4,0) | sp52height | Umístění HEIGHT | Umístění HEIGHT
sp52width | N(4,0) | sp52width | Umístění WIDTH | Umístění WIDTH
sp52laleft | N(4,0) | sp52laleft | Umístění - LABEL LEFT | Umístění - LABEL LEFT
sp52latop | N(4,0) | sp52latop | Umístění - LABEL TOP | Umístění - LABEL TOP
sp52pict | C(60) | Hodnoty | Text pro zaškrtávací políčko nebo seznam hodnot pro překryvný seznam oddělených čárkou | Názvy hodnot pro překryvný seznam
sp52vyraz | C(60) | Výraz | Výraz proměnné šablony | Výraz proměnné šablony
sp52init | M | Inicializace | Inicializační hodnota proměnné šablony | Inicializační hodnota proměnné šablony
sp52vstup | N(1,0) | Naplnění | Způsob naplnění proměnné - vstupem nebo výpočtem | Způsob naplnění proměnné - vstupem nebo výpočtem
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
sp52valid | M | Validace | Script v jazyce Foxpro pro validaci vstupu | Script v jazyce Foxpro pro validaci vstupu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Proměnná šablony - patří do šablony | SPSABLP sp50id | 1,1 : 0,M s rušením | SPSABL sp50id |
Atribut pravidla definice šablony - je naplněn proměnnou šablony | SPSABLA sp52 | 0,1 : 0,M s rušením | SPSABLP sp52 |

Indexy

Název | Primární | Výraz | Popis
ix_SPSABLP_sp52 | P | sp52 | Jednoznačná časová identifikace proměnné šablony
ix_SPSABLP_sp50id |  | sp50id | Jednoznačná časová identifikace šablony


SPSABLR Pravidlo definice šablony

Popis

Pravidlo definice šablony

Atributy

Atribut | Typ | Návěští | Message | Popis
sp51 | C(12) | sp51 | Jednoznačná časová identifikace pravidla šablony | Jednoznačná časová identifikace pravidla šablony
sp50id | C(12) | sp50id | Jednoznačná časová identifikace šablony | Jednoznačná časová identifikace šablony
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp51cisrad | C(4) | Pořadové číslo | Pořadové číslo pravidla šablony | Pořadové číslo pravidla šablony
sp51kod | M | sp51kod | Kód řádku šablony | Kód řádku šablony
sp51when | M | Podmínka | Podmínka uplatnění pravidla šablony | Podmínka uplatnění pravidla šablony

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Pravidlo definice šablony - patří do šablony | SPSABLR sp50id | 1,1 : 0,M s rušením | SPSABL sp50id |
Atribut pravidla definice šablony - patří do definice šablony | SPSABLA sp51 | 1,1 : 0,M s rušením | SPSABLR sp51 |

Indexy

Název | Primární | Výraz | Popis
ix_SPSABLR_sp51 | P | sp51 | Jednoznačná časová identifikace pravidla šablony
ix_SPSABLR_sp50id |  | sp50id | Jednoznačná časová identifikace šablony


SPSABLT Druh šablony

Popis

Druh šablony

Atributy

Atribut | Typ | Návěští | Message | Popis
sp54id | C(6) | Druh šablony | Druh šablony | Druh šablony
sp54druhsa | C(40) | Název druhu šablony | Název druhu šablony | Název druhu šablony
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp54datum | T | Datum vzniku | Datum založení druhu šablon | Datum založení druhu šablon
sp54koment | M | Komentář | Popis druhu šablon | Popis druhu šablon

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh šablony - založil uživatel | SPSABLT bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Šablona - je druhu šablony | SPSABL sp54id | 1,1 : 0,M | SPSABLT sp54id |
Poslední šablona spuštěná uživatelem v komponentě - byla vybrána z typu šablony | SPSABLM sp54id | 0,1 : 0,M s rušením | SPSABLT sp54id |

Indexy

Název | Primární | Výraz | Popis
ix_SPSABLT_sp54id | P | sp54id | Druh šablony
ix_SPSABLT_sp54druhsa |  | sp54druhsa | Název druhu šablony
ix_SPSABLT_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPSEOB Obchodní selektor

Popis

Objetem typu SPSEOB je každý obchodní selektor selektor. Obchodním selektorem se rozumí např. rozdělění zboží dle poskytovaných rabatů ap....

Objektem typu SPZAK je každý záznam definující zakázku, na kterou je možno směrovat ekonomické a obchodní informace vznikající v systému. Musí obsahovat první a druhou část identifikace zakázky, název zakázky, datum zahájení a datum ukončení zakázky.

Př: Středisko uživatele, stroj, výrobek, obchodní aktivita, výkon apod.

*** Dříve ZAKAZKY.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp10 | C(12) | sp10 | Jednoznačná časová identifikace obchodního selektoru |
sp10text | C(60) | Název obchodního selektoru | Název obchodního selektoru | Název obchodního selektoru *** Dříve NAZZAK.
sp10koment | M | Poznámka | Poznámka k obchodnímu selektoru | Poznámka k obchodnímu selektoru
sp10analyt | C(9) | Analytika obchodního selektoru | Analytika obchodního selektoru | Analytika obchodního selektoru
sp10datum | D | Platnost od | Datum platnosti selektoru od | Datum platnosti selektoru od
sp10datumd | D | Platnost do | Datum platnosti selektoru do | Datum platnosti selektoru do

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Předmět projektu - má obchodní selektor | NKPREDPR sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Hodnota parametru předmětu projektu - má obchodní selektor | NKHODNP sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Položka smlouvy - má obchodní selektor | NKSMLOUV sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost plnění položky smlouvy - má obchodní selektor | NKSMLPLN sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost o záloze - má obchodní selektor | ZAUDAL sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Projektový úkol - má obchodní selektor | NKUKOL sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Plnění projektového úkolu - má obchodní selektor | NKUKOLP sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost skladu zvířat - má obchodní selektor | SZUDAL sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost personalistiky - má obchodní selektor | MZPERUDA sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost správy artiklu - má obchodní selektor | SAUDAL sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Záznam o plnění úkolu v programu EVIVYK.EXE - má obchodní selektor | NKUKOLPE sp10idzak | 0,1 : 0,M | SPSEOB sp10idzak |
Adresát - odpovídá obchodnímu selektoru | ADADSAT sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost vývěsky - má obchodní selektor | VYUDALOS sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Poštovní zásilka - má obchodní selektor | POPOSTA sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Zpráva - má obchodní selektor | PZZPRAVY sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost obecné komponenty - má obchodní selektor | OKUDALOS sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Spojení adresáta - má obchodní selektor | ADSPOJ sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Účetní událost - má obchodní selektor | UCDENIK sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost spravovaného majetku - má obch.sel. | SMUDAL sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Rezervace - má obch.sel. | SMREZER sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Karta - má obchodní selektor | ODKARTA sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost odpisovaného majetku - a její obch.sel. | ODUDAL sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost obchodního plnění - má obchodní selektor | OBUDAL sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost DPH - má obchodní selektor | DPUDA sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost plateb - má obchodní selektor | PLUDA sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost skladu - má obchodní selektor | MTUDA sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost změny stavu peněz - výpisy a příkazy - má obchodní selektor | ZPUDA sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Mzda - má obchodní selektor | MZMZDY sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událostní entita mezd - má obchodní selektor | MZUDALOS sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost vymáhání - má obchodní selektor | VMUDA sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Úkolové listy - má obchodní selektor | MZUKOLLI sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Výrobní zakázka - obsahuje obchodní selektor | VRVYR sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost úkolu ve výrobě - zahrnuje obchodní selektor | VRUDOPER sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Vstup nebo výstup výrobního úkolu - zahrnuje obchodní selektor | VRUDOPMA sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Řidič - expedice - odpovídá obchodnímu selektoru | EXRIDIC sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost expedice - má obchodní selektor | EXUDAL sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |

Indexy

Název | Primární | Výraz | Popis
ix_SPSEOB_sp10idzak | P | sp10idzak | Identifikátor obchodního selektoru.
ix_SPSEOB_sp10 |  | sp10 |
ix_SPSEOB_sp10text |  | sp10text | Název obchodního selektoru
ix_SPSEOB_sp10datum |  | sp10datum | Datum platnosti selektoru od


SPSEOR Organizační selektor

Popis

Objetem typu SPSEOR je každý organizační selektor. Organizačním selektorem se rozumí např. sklad, úsek.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
spf3id | C(6) | Umístění | Identifikace umístění selektoru | Identifikace umístění selektoru
sp11 | C(12) | sp11 | Jednoznačná časová identifikace organizačního selektoru. | Jednoznačná časová identifikace organizačního selektoru.
sp11text | C(60) | Název organizačního selektoru | Název organizačního selektoru | Název organizačního selektoru
sp11koment | M | Poznámka k organizačnímu selektoru | Poznámka k organizačnímu selektoru | Poznámka k organizačnímu selektoru
sp11analyt | C(9) | Analytika organizačního selektoru | Analytika organizačního selektoru | Analytika organizačního selektoru
sp11datum | D | Platnost od | Datum platnosti selektoru od | Datum platnosti selektoru od
sp11datumd | D | Platnost do | Datum platnosti selektoru do | Datum platnosti selektoru do

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Organizační selektor - má umístění | SPSEOR spf3id | 1,1 : 0,M | SPSEUMIS spf3id |
Umístění parametru předmětu projektu - má organizační selektor | NKPARDRU sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Hodnota parametru předmětu projektu - má organizační selektor | NKHODNP sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Položka smlouvy - má organizační selektor | NKSMLOUV sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost plnění položky smlouvy - má organizační selektor | NKSMLPLN sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost o záloze - má organizační selektor | ZAUDAL sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Umístění zálohy - má organizační selektor | ZAUMISTE sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Alokace mezd - umístění - odpovídá organizačnímu selektoru | MZUMIST sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Projektový úkol - má organizační selektor | NKUKOL sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Řešitel projektového úkolu - má organizační selektor | NKZDROJ sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Plnění projektového úkolu - má organizační selektor | NKUKOLP sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost skladu zvířat - má organizační selektor | SZUDAL sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Umístění kategorie zvířat - má organizační selektor | SZUMIST sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost personalistiky - má organizační selektor | MZPERUDA sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost správy artiklu - má organizační selektor | SAUDAL sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost vývěsky - má organizační selektor | VYUDALOS sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Poštovní zásilka - má organizační selektor | POPOSTA sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Zpráva - má organizační selektor | PZZPRAVY sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost obecné komponenty - má organizační selektor | OKUDALOS sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Umístění pro obecnou komponentu - odpovídá organizačnímu selektoru | OKUMISTE sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Účetní událost - má organizační selektor | UCDENIK sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Spravovaný majetek - má org.sel. | SMMAJ sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost spravovaného majetku - má org.sel. | SMUDAL sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Umístění - se vztahuje k org.selektoru | SMUMIS sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Rezervace - má org.sel. | SMREZER sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Karta - má organizační selektor | ODKARTA sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost odpisovaného majetku - a její org.sel. | ODUDAL sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost obchodního plnění - má organizační selektor | OBUDAL sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost DPH - má organizační selektor | DPUDA sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost plateb - má orgranizační selektor | PLUDA sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Účet/pokladna (vlastní) - je v organizačním selektoru | PLUP sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost skladu - má organizační selektor | MTUDA sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Umístění - distribuční kanál - má organizační selektor | OBUMIST sp11idzak | 1,1 : 1,1 | SPSEOR sp11idzak |
Pracovní poměr - má organizační selektor | MZPRACPO sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Sklad - má organizační selektor | MTSKL sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost změny stavu peněz - výpisy a příkazy - má organizační selektor | ZPUDA sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Mzda - má orgnizační selektor | MZMZDY sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událostní entita mezd - má organizační selektor | MZUDALOS sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost vymáhání - má organizační selektor | VMUDA sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Organizační jednotka - číselník - má organizační selektor | MZORGJED sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Úkolové listy - má orgnizační selektor | MZUKOLLI sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Výrobní zakázka - obsahuje organizační selektor | VRVYR sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost úkolu ve výrobě - zahrnuje organizační selektor | VRUDOPER sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Výrobní linka / stroj / skladové úložiště výroby - má organizační selektor | TPLINKA sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Vstup nebo výstup výrobního úkolu - zahrnuje organizační selektor | VRUDOPMA sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Trasa expedice - má organizační selektor | EXTRASA sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost expedice - má organizační selektor | EXUDAL sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |

Indexy

Název | Primární | Výraz | Popis
ix_SPSEOR_sp11idzak | P | sp11idzak | Identifikátor organizačního selektoru.
ix_SPSEOR_spf3id |  | spf3id | Identifikace umístění selektoru
ix_SPSEOR_sp11 |  | sp11 | Jednoznačná časová identifikace organizačního selektoru.
ix_SPSEOR_sp11text |  | sp11text | Název organizačního selektoru
ix_SPSEOR_sp11datum |  | sp11datum | Datum platnosti selektoru od


SPSETV Technicko-věcný selektor

Popis

Objetem typu SPSEVT je každý technicko-věcný selektor. Technicko-věcným selektorem se rozumí např. kategorie majetku (dopravní prostředky, budovy ap.) ....

Atributy

Atribut | Typ | Návěští | Message | Popis
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
sp20 | C(12) | sp20 | Jednoznačná časová identifikace technicko-věcného selektoru. | Jednoznačná časová identifikace technicko-věcného selektoru.
sp20text | C(60) | Název technicko-věcného selektoru | Název technicko-věcného selektoru. | Název technicko-věcného selektoru.
sp20koment | M | Poznámka k technicko-věcnému selektoru | Poznámka k technicko-věcnému selektoru | Poznámka k technicko-věcnému selektoru
sp20analyt | C(9) | Analytika technicko-věcného selektoru | Analytika technicko-věcného selektoru | Analytika technicko-věcného selektoru
sp20datum | D | Platnost od | Datum platnosti selektoru od | Datum platnosti selektoru od
sp20datumd | D | Platnost do | Datum platnosti selektoru do | Datum platnosti selektoru do

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Předmět projektu - Má TV selektor | NKPREDPR sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Hodnota parametru předmětu projektu - má technicko-věcný selektor | NKHODNP sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Položka smlouvy - má technicko-věcný selektor | NKSMLOUV sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost plnění položky smlouvy - má technicko-věcný selektor | NKSMLPLN sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost o záloze - má technicko-věcný selektor | ZAUDAL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Projektový úkol - má technicko-věcný selektor | NKUKOL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Druh projektového úkolu - má TV-selektor | NKUKOLD sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Plnění projektového úkolu - má technicko-věcný selektor | NKUKOLP sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Druh plnění projektového úkolu - má TV-selektor | NKUKOPD sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Kategorie zvířat - má technicko-věcný selektor | SZARTIKL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost personalistiky - má technicko-vědecký selektor | MZPERUDA sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Artikly personalistiky - má technicko věcný selektor | MZPERART sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Uplatnění předmětu ZDP - předplňuje TV-selektor na události | DPZPTU sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost správy artiklu - má technicko-věcný selektor | SAUDAL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost vývěsky - má technicko-věcný selektor | VYUDALOS sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Poštovní zásilka - má tech. selektor | POPOSTA sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Zpráva - má technický selektor | PZZPRAVY sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Artikl obecné komponenty - odpovídá tecnicko-věcnému selektoru | OKARTIKL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost obecné komponenty - má technicko-věcný selektor | OKUDALOS sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Účetní událost - má TV-selektor | UCDENIK sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Spravovaný majetek - má tech.sel. | SMMAJ sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost spravovaného majetku - má tech.věc.sel. | SMUDAL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Rezervace - má tech.věc.sel. | SMREZER sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Karta - a její tech.věc.sel. | ODKARTA sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost odpisovaného majetku - a její tech.věc.sel. | ODUDAL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Obchodovatelný artikl - je zařazena do technicko-věcného selektoru | OBARTIKL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost obchodního plnění - má technicko-věcný selektor | OBUDAL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost DPH - má technicko-věcný selektor | DPUDA sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Sazba daně z přidané hodnoty - má technicko-věcný selektor | DPZPS sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost plateb - má technicko-věcný selektor | PLUDA sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Mzdová položka - má technicko věcný selektor | MZMZDPOL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Skladovaný artikl - má tech. věc. selektor | MTARTIKL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost skladu - má technicko-věcný selektor | MTUDA sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Pracovní poměr - má technicko věcný selektor | MZPRACPO sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost změny stavu peněz - výpisy a příkazy - má tech.věc selektor | ZPUDA sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Mzda - má technicko-věcný selektor | MZMZDY sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Řádek daňového přiznání - se uplatňuje pro technicko-věcný selektor | DPPRIRD sp20idzak | 0,1 : 0,M | SPSETV sp20idzak |
Událostní entita mezd - má technicko-vědecký selektor | MZUDALOS sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost vymáhání - má technicko-věcný selektor | VMUDA sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Volný text k události - je spojen s technicko-věcným selektorem | SPTEXTY sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Úkolové listy - má techinicko-věcný selektor | MZUKOLLI sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Artikl výroby - odpovídá technicko-věcnému selektoru | TPVYROB sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Technologická operace - má technicko-věcný selektor | TPOPERAC sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Výrobní zakázka - obsahuje technicko-věcný selektor | VRVYR sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost úkolu ve výrobě - zahrnuje technicko-věcný selektor | VRUDOPER sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Artikl mezd - má technicko věcný selektor | MZARTIKL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Výrobní linka / stroj / skladové úložiště výroby - má technicko-věcný selektor | TPLINKA sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Vstup nebo výstup výrobního úkolu - zahrnuje technicko-věcný selektor | VRUDOPMA sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Vozidlo - expedice - má TV selektor | EXARTIKL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost expedice - má tecnicko-věcný selektor | EXUDAL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |

Indexy

Název | Primární | Výraz | Popis
ix_SPSETV_sp20idzak | P | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_SPSETV_sp20 |  | sp20 | Jednoznačná časová identifikace technicko-věcného selektoru.
ix_SPSETV_sp20text |  | sp20text | Název technicko-věcného selektoru.
ix_SPSETV_sp20datum |  | sp20datum | Datum platnosti selektoru od


SPSEUMIS Umístění selektoru

Popis

Umístění selektoru

Atributy

Atribut | Typ | Návěští | Message | Popis
spf3id | C(6) | Umístění | Identifikace umístění selektoru | Identifikace umístění selektoru
spf3nazumi | C(40) | Název umístění | Název umístění selektoru | Název umístění selektoru
spf3koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Organizační selektor - má umístění | SPSEOR spf3id | 1,1 : 0,M | SPSEUMIS spf3id |

Indexy

Název | Primární | Výraz | Popis
ix_SPSEUMIS_spf3id | P | spf3id | Identifikace umístění selektoru
ix_SPSEUMIS_spf3nazumi |  | spf3nazumi | Název umístění selektoru


SPSKP SKP

Popis

Objetem typu SKP je každá kategorie Standardní klasifikace produkce.

*** Dříve SKP.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp17idskp | C(8) | Třída SKP | Identifikace třídy Standardní klasifikace produkce. | Identifikace kategorie Standardní klasifikace produkce. *** Dříve SKPID.
sp17text | C(70) | Název třídy Standardní klasifikace produkce | Název kategorie Standardní klasifikace produkce. | Název kategorie Standardní klasifikace produkce. *** Dříve SKPNA
sp17pozn | C(40) | Poznámka | Poznámka ke kategorii Standardní klasifikaci produkce. | Poznámka ke kategorii Standardní klasifikaci produkce.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Spravovaný majetek - má SKP | SMMAJ sp17idskp | 1,1 : 0,M | SPSKP sp17idskp |
Karta - a její SKP | ODKARTA sp17idskp | 1,1 : 0,M | SPSKP sp17idskp |
Obchodovatelný artikl - je veden ve třídě SKP | OBARTIKL sp17idskp | 1,1 : 0,M | SPSKP sp17idskp |
Skladovaný artikl - je veden ve třídě SKP | MTARTIKL sp17idskp | 1,1 : 0,M | SPSKP sp17idskp |
Artikl výroby - je veden ve třídě SKP | TPVYROB sp17idskp | 1,1 : 0,M | SPSKP sp17idskp |

Indexy

Název | Primární | Výraz | Popis
ix_SPSKP_sp17idskp | P | sp17idskp | Identifikace kategorie Standardní klasifikace produkce.
ix_SPSKP_sp17text |  | sp17text | Název kategorie Standardní klasifikace produkce.


SPSQLFCE BM funkce pro implementační rozšíření ISBM

Popis

BM funkce pro implementační rozšíření ISBM

Atributy

Atribut | Typ | Návěští | Message | Popis
spe2id | C(12) | BM-funkce | Identifikace BM-funkce | Identifikace BM-funkce
spe2datod | D | Platnost | Datum platnost BM-funkce od | Datum platnost BM-funkce od
spe2typ | N(1,0) | Typ | Typ návratové hodnoty BM-funkce | Typ návratové hodnoty BM-funkce
spe2nazfce | C(40) | Název BM-funkce | Název BM-funkce | Název BM-funkce
spe2sql | M | SQL | SQL dotaz, ve kterém jsou parametry pozičně reprezentovány proměnnými @p1,@p2,...,@p9 | SQL dotaz
spe2zkupar | M | Test par. | Testovací parametry - zadává se seznam konstant s syntaxi Sybase | Testovací parametry - zadává se seznam konstant s syntaxi Sybase
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace
spe2koment | M | Poznámka | Poznámka | Poznámka

Indexy

Název | Primární | Výraz | Popis
ix_SPSQLFCE_spsqlfce | P | spe2id, spe2datod |
ix_SPSQLFCE_spe2id |  | spe2id | Identifikace BM-funkce
ix_SPSQLFCE_spe2nazfce |  | spe2nazfce | Název BM-funkce


SPSTATDI Druh hodnoty

Popis

Objektem druh hodnoty je každá sledovaná a vypočítavaná hodnota vztahující se k libovolné kombinaci artiklu, umístění a adresáta nebo k odpovídajícím selektorům.
Základní členění tohoto druhu hodnoty je aktuální hodnota a statistická hodnota, konečný stav a obrat, finanční a naturální.
Př.: aktuální množství na skladě, aktální stav na účtě, obrat zboží, obrat na bankovním účtě apod.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp67druinf | C(40) | Název druhu hodnoty | Název druhu hodnoty | Název druhu hodnoty
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp67datum | T | sp67datum | Datum založení druhu hodnoty | Datum založení druhu hodnoty
sp67skryta | N(1,0) | sp67skryta |  |
sp67koment | M | Poznámka | Poznámka k druhu hodnoty | Poznámka k druhu hodnoty
sp67charak | N(1,0) | Saldokonto | Sledovat saldokonto | Sledovat saldokonto Hodnota Ano - způsobí aktualizaci "Skladby aktuální hodnoty"
sp67akter | N(1,0) | sp67akter | Agregovat za adresáta | Agregovat za adresáta
sp67artikl | N(1,0) | sp67artikl | Agregovat za artikl | Agregovat za artikl
sp67umiste | N(1,0) | sp67umiste | Agregovat za umístění | Agregovat za umístění
sp39nazev | C(10) | Atribut události | Atribut události | Atribut události
sp67aktual | N(1,0) | Aktuální | Aktualizuje aktuální stav ? | Aktualizuje aktuální stav ano nebo ne
sp69id | C(6) | Druh | Identifikace druhu saldokontní hodnoty procesu | Identifikace druhu saldokontní hodnoty procesu
sp67mesic | N(1,0) | sp67mesic | Zahrnout den do statistické hodnoty | Zahrnout den do statistické hodnoty
sp67vyber | N(1,0) | Podmínka | Podmínka statistické hodnoty | Podmínka statistické hodnoty
sp67statis | N(1,0) | Statistická | Aktualizuje statistické hodnoty ? | Aktualizuje statistické hodnoty ano nebo ne
sp67obrat | N(1,0) | Obrat | Aktualizuje obraty ? | Aktualizuje obraty ano nebo ne
sp67omesic | N(1,0) | sp67omesic | Zahrnout den do hodnoty obratu | Zahrnout den do hodnoty obratu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh hodnoty - založil uživatel | SPSTATDI bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Druh hodnoty - odpovídá druhu saldokontní hodnoty procesu | SPSTATDI sp69id | 0,1 : 0,M | SPSTATDS sp69id |
Aktuální hodnota PP - je pro druh hodnoty | NKAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Aktuální hodnota záloh - týká se druhu hodnoty | ZAAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Aktuální hodnota projektových úkolů - je druhu hodnoty | NKAHUK sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Aktuální hodnota plnění projektových úkolů - je druhu hodnoty | NKAHUP sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Aktuální hodnota skladu zvířat - má druh hodnoty | SZAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Obrat skladu zvířat - se vztahuje k druhu hodnoty | SZOBRAT sp67id sp06idsubs | 1,1 : 0,M s rušením | SPSTATDI sp67id sp06idsubs |
Parametry komponenty sklad zvířat - definují druh hodnoty - 1. volitelná zobrazovaná hodnota | SZPAR sp67id1 sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Parametry komponenty sklad zvířat - definují druh hodnoty - 2. volitelná zobrazovaná hodnota | SZPAR sp67id2 sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Parametry komponenty sklad zvířat - definují druh hodnoty - 3. volitelná zobrazovaná hodnota | SZPAR sp67id3 sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Parametry komponenty sklad zvířat - definují druh hodnoty - Množství ve finančním vyjádření (pro výpočet ceny skladové) | SZPAR sp67id4 sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Parametry komponenty sklad zvířat - definují druh hodnoty - Množství v naturálním vyjádření (pro výpočet ceny skladové) | SZPAR sp67id5 sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Parametry komponenty sklad zvířat - definují druh hodnoty - Množství v naturálním vyjádření (pro výpočet KD) | SZPAR sp67id6 sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Parametry změny stavu peněz - definují druh hodnoty - stav ve finančním vyjádření | ZPPARZSP sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Algoritmus - se týká druhu informace | SPTYPAL sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Aktuální hodnota xy - se týká druhu statistické informace | OKAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Statistická hodnota - se týká druhu informace | SPSTATIS sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Aktuální hodnota spravovaného majetku - má druh hodnoty | SMAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Aktuální hodnota - má druh hodnoty | POAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Aktuální hodnota obchodu - se týká druhu statistické informace | OBAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Událost - skladba - týká se druhu hodnoty | OBAHUD sp67id sp06idsubs | 0,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Událost - skladba - týká se druhu hodnoty | DPAHUD sp67id sp06idsubs | 0,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Aktuální hodnota vývěsky - má druh hodnoty | VYAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Aktuální hodnota plateb - se týká druhu statistické informace | PLAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Událost - skladba - týká se druhu hodnoty | PLAHUD sp67id sp06idsubs | 0,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Aktuální hodnota - má druh hodnoty | ODAH sp67id sp06idsubs | 1,1 : 1,1 | SPSTATDI sp67id sp06idsubs |
Aktuální hodnota skladu - týká se statistické informace | MTAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Událost - skladba - týká se druhu hodnoty | MTAHUD sp67id sp06idsubs | 0,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Aktuální hodnota změny stavu peněz - se týká druhu statistické informace | ZPAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Událost - skladba - týká se druhu hodnoty | ZPAHUD sp67id sp06idsubs | 0,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Pravidlo validace zápisu dat operace - kontroluje druh hodnoty | SPTYPVLU sp67id sp06idsub2 | 1,1 : 0,M s rušením | SPSTATDI sp67id sp06idsubs |
Kredit adresáta pro druh hodnoty v operaci - se vztahuje k druhu hodnoty | SPTYPVAD sp67id sp06idsub2 | 1,1 : 0,M s rušením | SPSTATDI sp67id sp06idsubs |
Aktuální hodnota vymáhání - týká se statistické informace | VMAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Parametry komponenty sklady - definují druh hodnoty - stav ve finančním vyjádření | MTPARSKL sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Parametry komponenty sklady - definují druh hodnoty - stav v naturálním vyjádření | MTPARSKL sp67id2 sp06idsub2 | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Parametry komponenty sklady - definují druh hodnoty - rezervované množství v naturálním vyjádření | MTPARSKL sp67id3 sp06idsub3 | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Parametry komponenty sklady - definují druh hodnoty - stav ve finančním vyjádření - ocenění předběžné | MTPARSKL sp67id4 sp06idsub4 | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Parametry komponenty sklady - definují druh hodnoty - rezervované množství v naturálním vyjádření - předběžné ocenění | MTPARSKL sp67id6 sp06idsub6 | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Obrat skladu - se vztahuje k druhu hodnoty | MTOBRAT sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Obrat účtu ZP - se vztahuje k druhu hodnoty | ZPOBRAT sp67id sp06idsubs | 1,1 : 0,M s rušením | SPSTATDI sp67id sp06idsubs |
Aktuální hodnota komponenty výrobní operace - se týká druhu statistické informace | VRAHOPER sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Aktuální hodnota komponenty vstupy výrobní operace - se týká druhu statistické informace | VRAHOPMA sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Aktuální hodnota komponenty zakázka výroby - se týká druhu statistické informace | VRAHVYR sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Aktuální hodnota expedice - je druhu hodnoty | EXAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_SPSTATDI_spstatdi | P | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_SPSTATDI_sp06idsubs |  | sp06idsubs | Identifikace subsystému.
ix_SPSTATDI_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SPSTATDI_sp69id |  | sp69id | Identifikace druhu saldokontní hodnoty procesu


SPSTATDS Druh saldokontní hodnoty procesu

Popis

Druh saldokontní hodnoty procesu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp69id | C(6) | Druh | Identifikace druhu saldokontní hodnoty procesu | Identifikace druhu saldokontní hodnoty procesu
sp69drusal | C(40) | Název druhu | Název druhu saldokontní hodnoty procesu | Název druhu saldokontní hodnoty procesu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp69datum | T | sp69datum | Datum založení druhu saldokontní hodnoty procesu | Datum založení druhu saldokontní hodnoty procesu
sp69koment | M | Poznámka | Poznámka k druhu saldokontní hodnoty procesu | Poznámka k druhu saldokontní hodnoty procesu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh saldokontní hodnoty procesu - Založil uživatel | SPSTATDS bw01uziv | 0,1 : 0,M | BWUZIVAT bw01uziv |
Druh hodnoty - odpovídá druhu saldokontní hodnoty procesu | SPSTATDI sp69id | 0,1 : 0,M | SPSTATDS sp69id |
Saldokontní hodnota procesu - se týká druhu saldokontní hodnoty procesu | SPPRCSAL sp69id | 1,1 : 0,M | SPSTATDS sp69id |

Indexy

Název | Primární | Výraz | Popis
ix_SPSTATDS_sp69id | P | sp69id | Identifikace druhu saldokontní hodnoty procesu
ix_SPSTATDS_sp69drusal |  | sp69drusal | Název druhu saldokontní hodnoty procesu
ix_SPSTATDS_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPSTATIS Statistická hodnota

Popis

Objektem statistická hodnota je každá sledovaná a vypočítávaná hodnota vztahující se k libovolné kombinaci selektorů vztažená k určitému časovému období.
Př.: hodnota množství na skladě, hodnota stavu účtu, hodnota obratu zboží, hodnota obratu na bankovním účtě apod.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp71datum | D | Datum | Datum statistické hodnoty | Rok statistické hodnoty
sp71pstav | N(20,4) | Poč.stav | Počáteční stav statistické hodnoty | Počáteční stav statistické hodnoty
sp71prijem | N(20,4) | Příjem | Příjem statistické hodnoty | Příjem statistické hodnoty
sp71vydej | N(20,4) | Výdej | Výdej statistické hodnoty | Výdej statistické hodnoty

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Statistická hodnota - se týká druhu informace | SPSTATIS sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_SPSTATIS_spstatis | P | sp06idsubs, sp67id, sp20idzak, sp11idzak, sp10idzak, sp71datum | Primární index statistické hodnoty
ix_SPSTATIS_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_SPSTATIS_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_SPSTATIS_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_SPSTATIS_sp71datum |  | sp71datum | Rok statistické hodnoty
ix_SPSTATIS_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace


SPSTROM Uzel obecného stromu

Popis

Uzel obecného stromu

Atributy

Atribut | Typ | Návěští | Message | Popis
spb6id | C(6) | Uzel | Identifikace uzlu stromu | Identifikace uzlu stromu
spb6nazuzl | C(40) | Název uzlu | Název uzlu stromu | Název uzlu stromu
spb8id | C(6) | Druh | Identifikace druhu uzlu stromu | Identifikace druhu uzlu stromu
spb6top | N(1,0) | Vrchol | Vrcholový uzel stromu | Vrcholový uzel stromu
bw88id | C(6) | Ikona | Identifikace ikony | Identifikace ikony
spb6sql | M | SQL | SQL dotaz uzlu stromu | SQL dotaz uzlu stromu
spb6vyrazo | M | Výraz třídění | Výraz třídění uzlu stromu | Výraz třídění uzlu stromu
spb6vyraz | M | Výraz zobrazení | Výraz pro zobrazení popisu uzlu ve stromu | Výraz pro zobrazení popisu uzlu ve stromu
spb6vyrazh | M | Výraz hierarchie | Výraz hierarchického členění uzlu stromu | Výraz hierarchického členění uzlu stromu
spb6maskah | M | Maska hierarchie | Maska hierarchického členění uzlu stromu | Maska hierarchického členění uzlu stromu
spb6kodsta | M | Skript startu | Skript spouštěný při startu stromu | Skript spouštěný při startu stromu
spb6koment | M | Poznámka | Poznámka | Poznámka
bw10nazev | C(8) | Tabulka | Název entity | Název entity
spb6ediwhe | M | Podmínka | Podmínka opravy dat | Podmínka opravy
spb6dradef | M | Výraz DRAG | Výraz vrácený při DRAG uzlu | Výraz vrácený při DRAG uzlu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Uzel obecného stromu - je druhu | SPSTROM spb8id | 1,1 : 0,M | SPSTROMD spb8id |
Uzel obecného stromu - je zobrazován s ikonou | SPSTROM bw88id | 1,1 : 0,M | BWIKONA bw88id |
Vazba uzlů obecného stromu - určuje předchůdce | SPSTROMP spb6id | 1,1 : 0,M s rušením | SPSTROM spb6id |
Vazba uzlů obecného stromu - určuje následníka | SPSTROMP spb6id2 | 1,1 : 0,M | SPSTROM spb6id |
Zobrazovaný atribut obecného stromu - je atributem uzlu obecného stromu | SPSTROMA spb6id | 1,1 : 0,M s rušením | SPSTROM spb6id |
Funkce uzlu obecného stromu - je funkcí uzlu | SPSTROMF spb6id | 1,1 : 0,M s rušením | SPSTROM spb6id |
Podmíněná ikona pro uzel obecného stromu - určuje uzel obecného stromu | SPSTROMI spb6id | 1,1 : 0,M s rušením | SPSTROM spb6id |

Indexy

Název | Primární | Výraz | Popis
ix_SPSTROM_spb6id | P | spb6id | Identifikace uzlu stromu
ix_SPSTROM_spb6nazuzl |  | spb6nazuzl | Název uzlu stromu
ix_SPSTROM_spb8id |  | spb8id | Identifikace druhu uzlu stromu
ix_SPSTROM_bw88id |  | bw88id | Identifikace ikony
ix_SPSTROM_bw10nazev |  | bw10nazev | Název entity


SPSTROMA Zobrazovaný atribut obecného stromu

Popis

Zobrazovaný atribut obecného stromu

Atributy

Atribut | Typ | Návěští | Message | Popis
spb6id | C(6) | Uzel | Identifikace uzlu stromu | Identifikace uzlu stromu
spc2atrib | C(10) | Atribut | Atribut | Atribut
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
spc2label | M | Návěští | Návěští | Návěští
spc2status | M | Stav. ř. | Stavový řádek | Stavový řádek
spc2autosi | N(1,0) | P.oknu | Přizpůsobovat oknu | Přizpůsobovat oknu
spc2porad | N(3,0) | Pořadí | Pořadí zobrazení | Pořadí zobrazení
spc2koment | M | Pozn. | Poznámka | Poznámka
spc2left | N(5,0) | spc2left | Umístění LEFT | Umístění LEFT
spc2top | N(5,0) | spc2top | Umístění TOP | Umístění TOP
spc2height | N(5,0) | spc2height | Umístění HEIGHT |
spc2width | N(5,0) | spc2width | Umístění WIDTH | Umístění WIDTH
spc2laleft | N(5,0) | spc2laleft | Umístění návěští LEFT | Umístění návěští LEFT
spc2latop | N(5,0) | spc2latop | Umístění návěští TOP | Umístění návěští TOP
spc2when | M | Podm. | Podmínka vstupu | Podmínka vstupu
spc2pict | M | Formát | Formát prvku | Formát prvku
spc2trida | N(1,0) | Třída | Třída prvku | Třída prvku

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Zobrazovaný atribut obecného stromu - je atributem uzlu obecného stromu | SPSTROMA spb6id | 1,1 : 0,M s rušením | SPSTROM spb6id |

Indexy

Název | Primární | Výraz | Popis
ix_SPSTROMA_spstroma | P | spb6id, spc2atrib | PI - spb6id+spc2atrib
ix_SPSTROMA_spb6id |  | spb6id | Identifikace uzlu stromu


SPSTROMD Druh uzlu obecného stromu

Popis

Druh uzlu obecného stromu

Atributy

Atribut | Typ | Návěští | Message | Popis
spb8id | C(6) | Druh | Identifikace druhu uzlu stromu | Identifikace druhu uzlu stromu
spb8druuzl | C(40) | Název druhu | Název druhu uzlu stromu | Název druhu uzlu stromu
spb8koment | M | Poznámka | Poznámka | Poznámka
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh uzlu obecného stromu - založil uživatel | SPSTROMD bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Uzel obecného stromu - je druhu | SPSTROM spb8id | 1,1 : 0,M | SPSTROMD spb8id |

Indexy

Název | Primární | Výraz | Popis
ix_SPSTROMD_spb8id | P | spb8id | Identifikace druhu uzlu stromu
ix_SPSTROMD_spb8druuzl |  | spb8druuzl | Název druhu uzlu stromu
ix_SPSTROMD_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPSTROMF Funkce uzlu obecného stromu

Popis

Funkce uzlu obecného stromu

Atributy

Atribut | Typ | Návěští | Message | Popis
spc3 | C(10) | spc3 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
spb6id | C(6) | Uzel | Identifikace uzlu stromu | Identifikace uzlu stromu
spc3popfce | C(40) | Funkce | Popis funkce | Popis funkce
spc3typ | N(1,0) | Typ | Typ funkce | Typ funkce
spc3keyb | N(1,0) | Klávesa | Vyvolat funkce na klávesu | Vyvolat funkce na klávesu
spc3kod | M | Kód | Kód funkce | Kód funkce
spc3koment | M | Pozn. | Poznámka | Poznámka
spc3porad | N(3,0) | Pořadí | Pořadí funkce | Pořadí funkce
spc3podmin | M | Podm. | Podmínka vyvolání funkce | Podmínka vyvolání funkce

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Funkce uzlu obecného stromu - je funkcí uzlu | SPSTROMF spb6id | 1,1 : 0,M s rušením | SPSTROM spb6id |

Indexy

Název | Primární | Výraz | Popis
ix_SPSTROMF_spc3 | P | spc3 | Jednoznačná časová identifikace
ix_SPSTROMF_spb6id |  | spb6id | Identifikace uzlu stromu


SPSTROMI Podmíněná ikona pro uzel obecného stromu

Popis

Podmíněná ikona pro uzel obecného stromu

Atributy

Atribut | Typ | Návěští | Message | Popis
spb6id | C(6) | Uzel | Identifikace uzlu stromu | Identifikace uzlu stromu
bw88id | C(6) | Ikona | Identifikace ikony | Identifikace ikony
spc6podm | M | Podmínka | Podmínka použití ikony | Podmínka použití ikony
spc6porad | N(3,0) | Pořadí | Pořadí vyhodnocení | Pořadí vyhodnocení

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Podmíněná ikona pro uzel obecného stromu - určuje uzel obecného stromu | SPSTROMI spb6id | 1,1 : 0,M s rušením | SPSTROM spb6id |
Podmíněná ikona pro uzel obecného stromu - určuje ikonu | SPSTROMI bw88id | 1,1 : 0,M | BWIKONA bw88id |

Indexy

Název | Primární | Výraz | Popis
ix_SPSTROMI_spstromi | P | spb6id, bw88id | PI - spb6id+bw88id
ix_SPSTROMI_spb6id |  | spb6id | Identifikace uzlu stromu
ix_SPSTROMI_bw88id |  | bw88id | Identifikace ikony


SPSTROMP Vazba uzlů obecného stromu

Popis

Vazba uzlů obecného stromu

Atributy

Atribut | Typ | Návěští | Message | Popis
spb6id | C(6) | Uzel | Identifikace uzlu stromu | Identifikace uzlu stromu
spb6id2 | C(6) | Uzel | Identifikace připojeného uzlu stromu | Identifikace připojeného uzlu stromu
spb7alias | C(6) | Alias | Alias připojeného uzlu stromu | Alias připojeného uzlu stromu
spb7porad | N(3,0) | Pořadí | Pořadí | Pořadí
spb7param | M | Skutečné parametry | Skutečné parametry použité v doplnění where uzlu stromu | Skutečné parametry použité v doplnění where uzlu stromu
spb7attr | M | Doplnění ATRIBUTY | Doplnění SQL dotazu na jeho začátku (je-li uveden atribut musí být posledním textu znakem čárka) | Doplnění SQL dotazu na jeho začátku (je-li uveden atribut musí být posledním textu znakem čárka)
spb7from | M | Doplnění FROM | Doplnění FROM připojeného uzlu stromu | Doplnění FROM připojeného uzlu stromu
spb7where | M | Doplnění WHERE | Doplnění WHERE připojeného uzlu stromu | Doplnění WHERE připojeného uzlu stromu
spb7folder | M | Popis folderu | Popis folderu | Popis folderu
spb7vyrazo | M | Výraz třídění | Výraz třídění uzlu stromu | Výraz třídění uzlu stromu
spb7podpri | M | Podmínka připojení | Podmínka připojení uzlu | Podmínka připojení uzlu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vazba uzlů obecného stromu - určuje předchůdce | SPSTROMP spb6id | 1,1 : 0,M s rušením | SPSTROM spb6id |
Vazba uzlů obecného stromu - určuje následníka | SPSTROMP spb6id2 | 1,1 : 0,M | SPSTROM spb6id |

Indexy

Název | Primární | Výraz | Popis
ix_SPSTROMP_spstromp | P | spb6id, spb6id2, spb7alias | PI - spb6id+spb6id2+spb7alias
ix_SPSTROMP_spb6id |  | spb6id | Identifikace uzlu stromu
ix_SPSTROMP_spb6id2 |  | spb6id2 | Identifikace připojeného uzlu stromu


SPTEXTY Volný text k události

Popis

Volný text k události

Atributy

Atribut | Typ | Návěští | Message | Popis
sp88id | C(6) | Text | Identifikace textu | Identifikace textu
sp88text | C(40) | Popis | Popis textu | Popis textu
sp88koment | M | Poznámka | Poznámka |
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Volný text k události - je spojen s technicko-věcným selektorem | SPTEXTY sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Vlastnosti atributu v masce operace - mají definované chybové hlášení při neplatné validaci volným textem | SPTYPMAS sp88id | 1,1 : 0,M | SPTEXTY sp88id |
Událost plateb - má volný text | PLUDA sp88id | 1,1 : 0,M | SPTEXTY sp88id |
Událost vymáhání - je spojena s textem | VMUDA sp88id | 1,1 : 0,M | SPTEXTY sp88id |
Den v postupu vymáhání - je spojen s textem | VMPOSTUB sp88id | 1,1 : 0,M | SPTEXTY sp88id |
Obsah volného textu - patří identifikaci textu | SPTEXTYN sp88id | 1,1 : 1,M s rušením | SPTEXTY sp88id |

Indexy

Název | Primární | Výraz | Popis
ix_SPTEXTY_sp88id | P | sp88id | Identifikace textu
ix_SPTEXTY_sp88text |  | sp88text | Popis textu
ix_SPTEXTY_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.


SPTEXTYN Obsah volného textu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp88id | C(6) | Text | Identifikace textu | Identifikace textu
sp38id | C(3) | Jazyk | Identifikace jazyka | Identifikace jazyka
sp89obsah | M | Obsah textu | Obsah textu | Obsah textu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Obsah volného textu - je v jazyce | SPTEXTYN sp38id | 1,1 : 0,M | SPJAZYK sp38id |
Obsah volného textu - patří identifikaci textu | SPTEXTYN sp88id | 1,1 : 1,M s rušením | SPTEXTY sp88id |

Indexy

Název | Primární | Výraz | Popis
ix_SPTEXTYN_sptextyn | P | sp88id, sp38id |
ix_SPTEXTYN_sp88id |  | sp88id | Identifikace textu
ix_SPTEXTYN_sp38id |  | sp38id | Identifikace jazyka


SPTRN Transformace

Popis

Transformace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp36 | C(12) | sp36 | Jednoznačná časová identifikace transformace | Jednoznačná časová identifikace transformace
sp36text | C(30) | Název transformace | Název transformace | Název transformace
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp36datum | T | Dne | Datum založení transformace | Datum založení transformace
sp36koment | M | Poznámka | Poznámka o transformaci | Poznámka o transformaci
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp06idsub2 | C(3) | Komponenta | Identifikace komponenty - přijemce transformovaných dat | Identifikace komponenty - přijemce transformovaných dat
sp40agre | C(12) | Agregační výraz | Výraz slučování záznamů podle pravidla transformace | Výraz slučování záznamů podle pravidla transformace
sp40filt | C(12) | Výběr | Výběr záznamů konvertovaných pravidlem transformace | Výběr záznamů konvertovaných pravidlem transformace
sp40 | C(12) | sp40 | Jednoznačná časová identifikace výrazu pro konverzi atributů | Jednoznačná časová identifikace výrazu pro konverzi atributů
sp36inttra | N(1,0) | Interní transformace | Transformace dynamické vazby | Interní transformace hlavního procesu
sp36ptran | N(1,0) | Prog. transformace | Program transformace | Program transformace
sp36pravou | N(1,0) | sp36pravou | Nastavit právo spuštění následující operace podle umístění | Nastavit právo spuštění následující operace podle umístění
spa1id | C(6) | Doplnění | Identifikace doplnění pohledu transformace | Identifikace doplnění pohledu transformace
sp36aktfil | N(1,0) | sp36aktfil | Aktivovat následující operaci pouze v případě, že existuje událost ukončované operace vyhovující filtru transformace | Aktivovat následující operaci pouze v případě, že existuje událost ukončované operace vyhovující filtru transformace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Transformace - provedl uživatel | SPTRN bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Transformace - spustí následující operaci za podmínky | SPTRN sp40filt | 0,1 : 0,M | SPTRNH sp40 |
Transformace - definuje rozpad následujících operací podle výrazu | SPTRN sp40agre | 0,1 : 0,M | SPTRNH sp40 |
Transformace - používá doplnění pohledu transformace | SPTRN sp06idsubs spa1id | 0,1 : 0,M | SPTRNW sp06idsubs spa1id |
Transformace - má výraz zobrazení informace v zásobníku operací o rozpadlých procesech | SPTRN sp40 | 0,1 : 0,M | SPTRNH sp40 |
Obecná předkontace pro transformaci - určuje transformaci | SPTRNPRE sp36 | 1,1 : 0,M | SPTRN sp36 |
Dynamická transformace druhu plnění projektového úkolu - používá transformaci | NKUKOPDT sp36 | 0,1 : 0,M | SPTRN sp36 |
Pravidlo transformace - patří do transformace | SPTRNR sp36 | 1,1 : 0,M s rušením | SPTRN sp36 |
Vazba druhů operací v druhu procesu - používá transformaci | SPTYPVO sp36 | 0,1 : 0,M | SPTRN sp36 |
Vazba operací v procesu - používá transformaci | SPPRCVO sp36 | 0,1 : 0,M | SPTRN sp36 |
Dynamické spojení operací - používá transformaci | SPTYPDSP sp36 | 1,1 : 0,M | SPTRN sp36 |

Indexy

Název | Primární | Výraz | Popis
ix_SPTRN_sp36 | P | sp36 | Jednoznačná časová identifikace transformace
ix_SPTRN_sp36text |  | sp36text | Název transformace
ix_SPTRN_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SPTRN_sp06idsub2 |  | sp06idsub2 | Identifikace komponenty - přijemce transformovaných dat
ix_SPTRN_sp40agre |  | sp40agre | Výraz slučování záznamů podle pravidla transformace
ix_SPTRN_sp40filt |  | sp40filt | Výběr záznamů konvertovaných pravidlem transformace
ix_SPTRN_sp40 |  | sp40 | Jednoznačná časová identifikace výrazu pro konverzi atributů
ix_SPTRN_sptrnw |  | sp06idsubs, spa1id | PI - sp06idsubs+spa1id


SPTRNA Konverze atributů obsažených v pravidlu transformace

Popis

Konverze atributů obsažených v pravidlu transformace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp37 | C(12) | Operace | Jednoznačná časová identifikace pravidla transformace | Jednoznačná časová identifikace pravidla transformace
sp39nazev | C(10) | Atribut události | Atribut události | Atribut události
sp40 | C(12) | sp40 | Jednoznačná časová identifikace výrazu pro konverzi atributů | Jednoznačná časová identifikace výrazu pro konverzi atributů
sp38suma | N(1,0) | sp38suma | Suma za údaj | Suma za údaj
sp38refer | N(1,0) | sp38refer | Referenční atribut | Referenční atribut
sp38agreg | N(1,0) | sp38agreg | Agregační údaj | Agregační údaj
sp38hodn | M | sp38hodn | Hodnota vložená do atributu | Hodnota vložená do atributu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Konverze atributů obsažených v pravidlu transformace - patří pravidlu transformace | SPTRNA sp37 | 1,1 : 0,M s rušením | SPTRNR sp37 |
Konverze atributů obsažených v pravidlu transformace - představuje výraz | SPTRNA sp40 | 0,1 : 0,M | SPTRNH sp40 |

Indexy

Název | Primární | Výraz | Popis
ix_SPTRNA_sptrna | P | sp37, sp39nazev | Pravidlo transformace + atribut
ix_SPTRNA_sp37 |  | sp37 | Jednoznačná časová identifikace pravidla transformace
ix_SPTRNA_sp39nazev |  | sp39nazev | Atribut události
ix_SPTRNA_sp40 |  | sp40 | Jednoznačná časová identifikace výrazu pro konverzi atributů


SPTRNH Výraz pro konverzi atributů

Popis

Výraz pro konverzi atributů

Atributy

Atribut | Typ | Návěští | Message | Popis
sp40 | C(12) | sp40 | Jednoznačná časová identifikace výrazu pro konverzi atributů | Jednoznačná časová identifikace výrazu pro konverzi atributů
sp40nazev | C(30) | Název výrazu | Název výrazu | Název výrazu
sp40vyraz | M | Výraz | Výraz konverze atributů | Výraz konverze atributů
sp40koment | M | Poznámka | Poznámka k výrazu | Poznámka k výrazu
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp39typ | C(1) | Typ | Typ atributu | Typ atributu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vlastnosti atributu v masce operace - definují výraz komponenty | SPTYPMAS sp40 | 0,1 : 0,M | SPTRNH sp40 |
Pravidlo transformace - používá používá agregační výraz | SPTRNR sp40agre | 0,1 : 0,M | SPTRNH sp40 |
Pravidlo transformace - používá používá výběrový výraz | SPTRNR sp40filt | 0,1 : 0,M | SPTRNH sp40 |
Transformace - spustí následující operaci za podmínky | SPTRN sp40filt | 0,1 : 0,M | SPTRNH sp40 |
Transformace - definuje rozpad následujících operací podle výrazu | SPTRN sp40agre | 0,1 : 0,M | SPTRNH sp40 |
Transformace - má výraz zobrazení informace v zásobníku operací o rozpadlých procesech | SPTRN sp40 | 0,1 : 0,M | SPTRNH sp40 |
Konverze atributů obsažených v pravidlu transformace - představuje výraz | SPTRNA sp40 | 0,1 : 0,M | SPTRNH sp40 |

Indexy

Název | Primární | Výraz | Popis
ix_SPTRNH_sp40 | P | sp40 | Jednoznačná časová identifikace výrazu pro konverzi atributů
ix_SPTRNH_sp40nazev |  | sp40nazev | Název výrazu
ix_SPTRNH_sp06idsubs |  | sp06idsubs | Identifikace subsystému.
ix_SPTRNH_sp39typ |  | sp39typ | Typ atributu
ix_SPTRNH_spsubsya |  | sp06idsubs, sp39typ | sp06idsubs+sp39typ


SPTRNMP Míra plnění

Popis

Míra plnění

Atributy

Atribut | Typ | Návěští | Message | Popis
sp43zdroj | C(12) | Zdroj | Identifikace zdrojového záznamu pro míru plnění | Identifikace zdrojového záznamu pro míru plnění
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp39nazevc | C(10) | Cílová hodnota | Cílová hodnota | Cílová hodnota
sp35rozlis | C(1) | sp35rozlis | Rozlišení vazby pro transformaci | Rozlišení vazby pro transformaci
sp37rozlis | C(1) | Rozlišení | Rozlišení cílové hodnoty | Rozlišení cílové hodnoty
sp43cil | C(12) | Cíl | Identifikace cílového záznamu pro míru plnění | Identifikace cílového záznamu pro míru plnění
sp06idsub2 | C(3) | Komponenta | Identifikace komponenty - přijemce transformovaných dat | Identifikace komponenty - přijemce transformovaných dat

Indexy

Název | Primární | Výraz | Popis
ix_SPTRNMP_sptrnmp | P | sp43zdroj, sp06idsubs, sp39nazevc, sp35rozlis, sp37rozlis, sp43cil, sp06idsub2 | Primární index SPTRNMP
ix_SPTRNMP_sptrnmp1 |  | sp43zdroj, sp06idsubs |
ix_SPTRNMP_sptrnmp2 |  | sp43cil, sp06idsub2 |


SPTRNMPC Pohled SPTRNMP cil

Popis

Pohled SPTRNMP cil

Atributy

Atribut | Typ | Návěští | Message | Popis
sp43cil | C(12) | Cíl | Identifikace cílového záznamu pro míru plnění | Identifikace cílového záznamu pro míru plnění
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp06idsub2 | C(3) | Komponenta | Identifikace komponenty - přijemce transformovaných dat | Identifikace komponenty - přijemce transformovaných dat
sp43cil2 | C(12) | sp43cil2 |  |


SPTRNMPX Pohled SPTRNMP zdroj->cil

Popis

Pohled SPTRNMP zdroj->cil

Atributy

Atribut | Typ | Návěští | Message | Popis
sp43cil | C(12) | Cíl | Identifikace cílového záznamu pro míru plnění | Identifikace cílového záznamu pro míru plnění
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp06idsub2 | C(3) | Komponenta | Identifikace komponenty - přijemce transformovaných dat | Identifikace komponenty - přijemce transformovaných dat
sp43zdroj | C(12) | Zdroj | Identifikace zdrojového záznamu pro míru plnění | Identifikace zdrojového záznamu pro míru plnění


SPTRNMPZ Pohled SPTRNMP ZDROJ

Popis

Pohled SPTRNMP ZDROJ

Atributy

Atribut | Typ | Návěští | Message | Popis
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp06idsub2 | C(3) | Komponenta | Identifikace komponenty - přijemce transformovaných dat | Identifikace komponenty - přijemce transformovaných dat
sp43zdroj | C(12) | Zdroj | Identifikace zdrojového záznamu pro míru plnění | Identifikace zdrojového záznamu pro míru plnění
sp43zdroj2 | C(12) | sp43zdroj2 |  |


SPTRNPRE Obecná předkontace pro transformaci

Popis

Obecná předkontace pro transformaci

Atributy

Atribut | Typ | Návěští | Message | Popis
sp19id | C(6) | Předkontace | Identifikace obecné předkontace | Identifikace obecné předkontace
sp36 | C(12) | sp36 | Jednoznačná časová identifikace transformace | Jednoznačná časová identifikace transformace
spd2koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Obecná předkontace pro transformaci - určuje předkontaci | SPTRNPRE sp19id | 1,1 : 0,M | SPPREDK sp19id |
Obecná předkontace pro transformaci - určuje transformaci | SPTRNPRE sp36 | 1,1 : 0,M | SPTRN sp36 |

Indexy

Název | Primární | Výraz | Popis
ix_SPTRNPRE_sptrnpre | P | sp19id, sp36 | PI - sp06idsubs+sp19id
ix_SPTRNPRE_sp36 |  | sp36 | Jednoznačná časová identifikace transformace
ix_SPTRNPRE_sp19id |  | sp19id | Identifikace obecné předkontace


SPTRNR Pravidlo transformace

Popis

Pravidlo transformace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp37 | C(12) | Operace | Jednoznačná časová identifikace pravidla transformace | Jednoznačná časová identifikace pravidla transformace
sp36 | C(12) | sp36 | Jednoznačná časová identifikace transformace | Jednoznačná časová identifikace transformace
sp37text | C(30) | Název | Název pravidla transformace | Název pravidla transformace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp06idsub2 | C(3) | Komponenta | Identifikace komponenty - přijemce transformovaných dat | Identifikace komponenty - přijemce transformovaných dat
sp37datum | T | Dne | Datum založení pravidla | Datum založení pravidla
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp37koment | M | Poznámka | Poznámka k pravidlu transformace | Poznámka k pravidlu transformace
sp40agre | C(12) | Agregační výraz | Výraz slučování záznamů podle pravidla transformace | Výraz slučování záznamů podle pravidla transformace
sp40filt | C(12) | Výběr | Výběr záznamů konvertovaných pravidlem transformace | Výběr záznamů konvertovaných pravidlem transformace
sp39nazevz | C(10) | Zdrojová hodnota | Zdrojová hodnota | Zdrojová hodnota
sp39nazevc | C(10) | Cílová hodnota | Cílová hodnota | Cílová hodnota
sp37rozlis | C(1) | Rozlišení | Rozlišení cílové hodnoty | Rozlišení cílové hodnoty
sp37cisrad | C(4) | Pořadové číslo | Pořadové číslo pravidla transformace | Pořadové číslo pravidla transformace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Pravidlo transformace - patří subsystému | SPTRNR sp06idsubs | 1,1 : 0,M | SPSUBSYS sp06idsubs |
Pravidlo transformace - patří do transformace | SPTRNR sp36 | 1,1 : 0,M s rušením | SPTRN sp36 |
Pravidlo transformace - založil uživatel | SPTRNR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Pravidlo transformace - používá používá agregační výraz | SPTRNR sp40agre | 0,1 : 0,M | SPTRNH sp40 |
Pravidlo transformace - používá používá výběrový výraz | SPTRNR sp40filt | 0,1 : 0,M | SPTRNH sp40 |
Konverze atributů obsažených v pravidlu transformace - patří pravidlu transformace | SPTRNA sp37 | 1,1 : 0,M s rušením | SPTRNR sp37 |

Indexy

Název | Primární | Výraz | Popis
ix_SPTRNR_sp37 | P | sp37 | Jednoznačná časová identifikace pravidla transformace
ix_SPTRNR_sp36 |  | sp36 | Jednoznačná časová identifikace transformace
ix_SPTRNR_sp37text |  | sp37text | Název pravidla transformace
ix_SPTRNR_sp06idsubs |  | sp06idsubs | Identifikace subsystému.
ix_SPTRNR_sp06idsub2 |  | sp06idsub2 | Identifikace komponenty - přijemce transformovaných dat
ix_SPTRNR_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SPTRNR_sp40agre |  | sp40agre | Výraz slučování záznamů podle pravidla transformace
ix_SPTRNR_sp40filt |  | sp40filt | Výběr záznamů konvertovaných pravidlem transformace


SPTRNW Doplnění pohledu transformace

Popis

Doplnění pohledu transformace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
spa1id | C(6) | Doplnění | Identifikace doplnění pohledu transformace | Identifikace doplnění pohledu transformace
spa1nazdop | C(40) | Název doplnění | Název doplnění pohledu transformace | Název doplnění pohledu transformace
spa1atrib | M | Atributy | Seznam doplněných atributů do pohledu transformace | Seznam doplněných atributů do pohledu transformace
spa1join | M | Selekt - join | Část selekt - join doplnění pohledu transformace | Část selekt - join doplnění pohledu transformace
spa1where | M | Výběr | Část výběr (where) doplnění pohledu transformace | Část výběr (where) doplnění pohledu transformace
spa1checks | C(17) | spa1checks | Kontrolní číslo pohledu transformace | Kontrolní číslo pohledu transformace
spa1koment | M | Poznámka | Poznámka | Poznámka
spa1fetchm | N(1,0) | Fetchmemo | Fetchmemo | Fetchmemo
spa1merge | N(1,0) | Slučování | Slučovat s předdefinovaným dotazem | Slučovat s předdefinovaným dotazem
spa1kod | M | Skript | Kód skriptu provedený nad daty dotazu před transformací | Kód scriptu provedený nad daty dotazu před transformací

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Připojený záznam doplnění pohledu tranformace - náleží k doplnění pohledu transformace | SPTRNWZ sp06idsubs spa1id | 1,1 : 0,M | SPTRNW sp06idsubs spa1id |
Transformace - používá doplnění pohledu transformace | SPTRN sp06idsubs spa1id | 0,1 : 0,M | SPTRNW sp06idsubs spa1id |

Indexy

Název | Primární | Výraz | Popis
ix_SPTRNW_sptrnw | P | sp06idsubs, spa1id | PI - sp06idsubs+spa1id
ix_SPTRNW_spa1id |  | spa1id | Identifikace doplnění pohledu transformace
ix_SPTRNW_spa1nazdop |  | spa1nazdop | Název doplnění pohledu transformace


SPTRNWZ Připojený záznam doplnění pohledu tranformace

Popis

Připojený záznam doplnění pohledu tranformace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
spa1id | C(6) | Doplnění | Identifikace doplnění pohledu transformace | Identifikace doplnění pohledu transformace
spf0porad | N(3,0) | Pořadí | Pořadí | Pořadí
spf0txt1 | C(40) | Txt1 | Text 1 | Text 1
spf0txt2 | C(40) | Txt2 | Text 2 | Text 2
spf0txt3 | C(40) | Txt3 | Text 3 | Text 3
spf0txt4 | C(40) | Txt4 | Text 4 | Text 4
spf0txt5 | C(40) | Txt5 | Text 5 | Text 5
spf0txt6 | C(40) | Txt6 | Text 6 | Text 6
spf0num1 | N(20,4) | Num1 | Num 1 | Num 1
spf0num2 | N(20,4) | Num2 | Num 2 | Num 2
spf0num3 | N(20,4) | Num3 | Num 3 | Num 3
spf0koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Připojený záznam doplnění pohledu tranformace - náleží k doplnění pohledu transformace | SPTRNWZ sp06idsubs spa1id | 1,1 : 0,M | SPTRNW sp06idsubs spa1id |

Indexy

Název | Primární | Výraz | Popis
ix_SPTRNWZ_sptrnwz | P | sp06idsubs, spa1id, spf0porad | Jednoznačná časová idenitfikace
ix_SPTRNWZ_sptrnw |  | sp06idsubs, spa1id | PI - sp06idsubs+spa1id


SPTYP Druh procesu/operace

Popis

Objektem typu SPTYP je každá identifikace druh procesu/operace. Obsahuje základní informace společné pro všechny typy v systému jako je identifikace subsystému, identifikace typu, identifikace číselné řady ap. Obsahuje vazbu na číselné řady dokladů v roce, na pravidla předkontace ap.

*** Dříve TYP...

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor druhu operace | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp08idcisd | C(8) | Řada | Identifikátor číselné řady procesů | Identifikátor číselné řady procesů. *** Dříve OZNDOK.
spg2id | C(6) | Korektor | Identifikace korektoru transformovaných dat | Identifikace korektoru transformovaných dat
sp07text | C(30) | Text | Název druhu procesu | Název typu dokladu. *** Dříve NAZPDR.
sp07koment | M | Poznámka | Komentář k druhu procesu | Komentář k typu dokladu. *** Dříve POPD.
sp07operac | N(1,0) | sp07operac | Daný druh je druhem operace | Daný druh je druhem operace
sp07autom | N(1,0) | Implicitně spouštět | Způsob spuštění činnosti po ukončení předchozí činnosti | Způsob spuštění činnosti po ukončení předchozí činnosti
sp07menu | N(1,0) | sp07menu | Zobrazovat v menu nebo se jedná o referenční proces | Typ dokladu určený pro zobrazení v menu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp07datzal | T | Datum založení | Datum založení | Datum založení
sp07skryta | N(1,0) | sp07skryta | Druh procesu/operace běžně nezobrazovaný | Typ dokladu/operace běžně nezobrazovaný
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw81id | C(6) | MPV | Identifikace metapředlohy výstupu | Identifikace makropředlohy výstupu
bw04ident | C(10) | Ident. | Identifikace předlohy pro výstup | Identifikace předlohy pro výstup
sp07maska | M | První vstupní údaj | Vstupní maska událostí operace | Vstupní maska událostí operace
sp79id | C(6) | Skupina | Identifikace skupiny procesů | Identifikace skupiny procesů
sp07privyd | N(1,0) | Příjem/Výdej | Příjem/Výdej, Závazek/Pohledávka .... | Příjem/Výdej
sp07charak | N(1,0) | Charakter | Charakter operace - běžná, dávková, dávková unikátní | Charakter operace - běžná, dávková, dávková unikátní
sp07vzudvz | N(1,0) | MP dávkové operace | Míra plnění při transformaci z dávk.operace propojuje událost nebo vazbu dávk.operace | Míra plnění při transformaci z dávkové operace propojuje událost nebo vazbu dávkové operace na událost
sp07idciso | C(3) | Řada operace | Identifikace řady operace |
sp07testmp | N(1,0) | Test mírou plnění | Test míry plnění při ukončení operace | Test míry plnění při ukončení operace
sp07 | C(12) | sp07 | Jednoznačná časová idenitifikace | Jednoznačná časová idenitifikace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh procesu/operace - přísluší subsystému | SPTYP sp06idsubs | 1,1 : 0,M | SPSUBSYS sp06idsubs |
Druh procesu/operace - má číselnou řadu | SPTYP sp08idcisd | 0,1 : 0,M | SPCISDOK sp08idcisd |
Druh procesu/operace - založil uživatel | SPTYP bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Druh procesu/operace - tiskne doklad metapředlohou výstupu | SPTYP bw02krok bw81id | 0,1 : 0,M | BWPRINS bw02krok bw81id |
Druh procesu/operace - patří do skupiny procesů pro zobrazení v menu | SPTYP sp79id | 0,1 : 0,M | SPTYPFOL sp79id |
Druh procesu/operace - používá korektor | SPTYP spg2id | 0,1 : 0,M | SPKOREK spg2id |
Import/Export operace - se vztahuje k druhu operace | SPTYPEI sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Prezentace parametrů - definuje inicializační proces předmětu projektu | NKPRP sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Replikovaný proces mezi DÚ - replikuje proces | IERPRC sp07idtypd sp06idsubd | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Informace o replikovaných událostech operace v procesu - je informace o operaci v procesu | IERUDA sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Šablona procesu technologického postupu - Používá jako předlohu proces | TPSABPRC sp07idtypd sp06idsubd | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Vlastnosti atributu v masce operace - patří k operaci | SPTYPMAS sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Druh operace s vyhodnocením kurzu k prvému dni měsíce - je druhu operace | OCKUROPE sp07idtyp sp06idsubs | 1,1 : 0,1 | SPTYP sp07idtyp sp06idsubs |
Omezení doplňující vlastnost činnosti pro vyvolání z operace - jsou vlastnostmi uzlu | SPCINDVD sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Omezení doplňující vlastnost činnosti pro vyvolání z operace - jsou vlastnostmi uzlu v druh procesu | SPCINDVD sp07idtypd sp06idsubd | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Proces/Operace aplikace - odpovídá procesu BM | APPROP sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Parametry operace komponenty ZSP - Jsou pro operaci komponenty ZSP | ZPPAROPE sp07idtyp sp06idsubs | 1,1 : 0,1 | SPTYP sp07idtyp sp06idsubs |
Parametry operací - sklad zvířat - je na druhu operace | SZPAROPE sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Parametry operace komponenty ZAL - Jsou pro operaci komponenty ZAL | ZAPAROPE sp07idtyp sp06idsubs | 1,1 : 0,1 s rušením | SPTYP sp07idtyp sp06idsubs |
Druh projektového úkolu použitelný v druhu operace - definuje druh operace | NKUKOLDO sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Druh položky smlouvy použitelný v druhu operace - definuje druh operace | NKPLNDOP sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Určení typu subjektu spojení adresáta pro druh operace - určuje typ subjektu spojení pro druh operace | SPTYPSUB sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Určení typu subjektu spojení adresáta pro druh operace - určuje typ subjektu spojení pro druh procesu | SPTYPSUB sp07idtypd sp06idsubd | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Vazba druh operace-typ události - má druh operace | SZDOTU sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Typ události komponenty použitelný pro druh operace komponenty - je pro druh operace | SPTYPUDV sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Skupina archivace - zapisuje protokol na téma vývěsky | UTARSKP sp07idtyp sp06idsubs | 0,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Událost vývěsky - má uvedeno téma (typ operace) | VYUDALOS sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Poštovní zásilka - má typ operace | POPOSTA sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Rozšířené parametry operace/procesu - se týkají operace | SPTYPPAR sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Druh operace v druhu procesu - je obsažena na typu dokladu | SPTYPOD sp07idtypd sp06idsubd | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Druh operace v druhu procesu - je vyvoláním dokladu nebo operace | SPTYPOD sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Vazba druhů operací v druhu procesu - je na typu dokladu | SPTYPVO sp07idtypd sp06idsubd | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Proces - má typ logického dokladu | SPPRC sp07idtypd sp06idsubd | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Operace procesu - je typu operace | SPPRCOD sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Vazba operací v procesu - má vstupní operaci dokladu v druhém uzlu typu operace/dokladu | SPPRCVO sp07idtypb sp06idsubb | 0,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Vazba operací v procesu - má výstupní operaci dokladu v prvním uzlu typu operace/dokladu | SPPRCVO sp07idtypa sp06idsuba | 0,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Vazba operací v procesu - má první uzel typu operace | SPPRCVO sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Událost odpisovaného majetku - má typ operace | ODUDAL sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Algoritmus - se týká druhu operace | SPTYPAL sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Algoritmus - se uplatní pro druh hlavního procesu | SPTYPAL sp07idtypd sp06idsubd | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Vyvolání operace z hlavního procesu - bude vyvolávat z procesu | SPTYPGO sp07idtypd sp06idsubd | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Druh operace obsažené v prezentaci procesu - se týká druhu operace | SPPREZPL sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Dynamické spojení operací - se týká druhu procesu | SPTYPDSP sp07idtypd sp06idsubd | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Pravidlo validace zápisu dat operace - patří k druhu operace | SPTYPVLU sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Kredit adresáta pro druh hodnoty v operaci - se vztahuje k druhu operace | SPTYPVAD sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Osobní maska operace - patří k druhu operace | SPTYPOMO sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Číselná řada operace pro umístění - je spojena s druhem operace | SPTYPRUM sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Výraz zobrazení informací o události ve stromu pro danou operaci - je výraz pro druh operace | SPTYPUZ sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Propojení operací obchodu a skladu pro přepočet nákladů v události obchodu - se vztahují k druhu procesu | OBDEFPRE sp07idtypd sp06idsubd | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Propojení operací obchodu a skladu pro přepočet nákladů v události obchodu - váže operaci obchodu | OBDEFPRE sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Propojení operací obchodu a skladu pro přepočet nákladů v události obchodu - váže operaci skladu | OBDEFPRE sp07idtyp2 sp06idsub2 | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Operace používající dynamické spojení - týká se druhu operace | SPTYPDSX sp07idtyp2 sp06idsub2 | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Technologická operace - vytváří operaci komponenty vstupů a výstupů IC | TPOPERAC sp07idtyp2 sp06idsub2 | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Parametry komponenty obchod pro druh operace - se týkají druhu operace | OBPAROPE sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Výběr tiskové předlohy procesu - jsou určeny pro druh procesu | SPTYPPRT sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_SPTYP_sptyp | P | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SPTYP_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_SPTYP_sp06idsubs |  | sp06idsubs | Identifikace subsystému.
ix_SPTYP_sp08idcisd |  | sp08idcisd | Identifikátor číselné řady procesů.
ix_SPTYP_spg2id |  | spg2id | Identifikace korektoru transformovaných dat
ix_SPTYP_sp07text |  | sp07text | Název typu dokladu.
ix_SPTYP_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SPTYP_bwprins |  | bw02krok, bw81id | PI - bw02krok+bw81id
ix_SPTYP_sp79id |  | sp79id | Identifikace skupiny procesů
ix_SPTYP_sp07 | U | sp07 | Jednoznačná časová idenitifikace


SPTYPAL Algoritmus

Popis

Objektem algoritmus je každá definice jak daný druh operace aktualizuje daný druh hodnoty.
Př.: Druh operace přijetí na sklad aktualizuje druh hodnoty stav skladu v kusech přičtením množství v kusech z události.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp07idtypd | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu procesu
sp06idsubd | C(3) | sp06idsubd | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery
sp70privyd | N(1,0) | +/-/PV | Výpočet +=příjem, -=výdej, PV=podle atributu vyjadřující příjmovou/výdajovou událost (pokud existuje pro komponentu) | Příjem/Výdej

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Algoritmus - se týká druhu operace | SPTYPAL sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Algoritmus - se týká druhu informace | SPTYPAL sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Algoritmus - se uplatní pro druh hlavního procesu | SPTYPAL sp07idtypd sp06idsubd | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Algoritmus - týká se druhu komponenty | SPTYPAL sp06idsubs | 1,1 : 0,M | SPSUBSYS sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_SPTYPAL_sptypal | P | sp07idtyp, sp06idsubs, sp67id, sp07idtypd, sp06idsubd | Primární indexTyp+druh hodnoty
ix_SPTYPAL_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SPTYPAL_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_SPTYPAL_sptypd |  | sp07idtypd, sp06idsubd | Index podle typu dokladu a subsystému dokladu
ix_SPTYPAL_sp06idsubs |  | sp06idsubs | Identifikace subsystému.


SPTYPDSP Dynamické spojení operací

Popis

Dynamické spojení operací

Atributy

Atribut | Typ | Návěští | Message | Popis
sp14id | C(6) | sp14id | Druh dynamického spojení operací | Druh dynamického spojení operací
sp07idtypd | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu procesu
sp06idsubd | C(3) | sp06idsubd | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery
sp07idtyp | C(6) | Druh | Identifikátor druhu operace | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp36 | C(12) | Transformace | Tranformace mezi operacemi | Jednoznačná časová identifikace transformace
sp32rozlis | C(1) | Rozlišení vazby | Rozlišení vazby pro transformaci | Rozlišení vazby pro transformaci
sp32poradi | N(3,0) | Pořadí transf. | Pořadí transformace | Pořadí transformace
sp14koment | M | Poznámka | Poznámka k dynamickému spojení operací | Poznámka k dynamickému spojení operací
sp19id | C(6) | Předkontace | Identifikace obecné předkontace | Identifikace obecné předkontace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Dynamické spojení operací - se týká druhu procesu | SPTYPDSP sp07idtypd sp06idsubd | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Dynamické spojení operací - vytváří popojení na operaci v procesu | SPTYPDSP sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad | 0,1 : 0,M s rušením | SPTYPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad |
Dynamické spojení operací - používá transformaci | SPTYPDSP sp36 | 1,1 : 0,M | SPTRN sp36 |
Dynamické spojení operací - používá obecnou předkontaci | SPTYPDSP sp19id | 0,1 : 0,M | SPPREDK sp19id |
Operace používající dynamické spojení - týká se dynamického spojení | SPTYPDSX sp14id sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad sp36 | 1,1 : 0,M s rušením | SPTYPDSP sp14id sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad sp36 |

Indexy

Název | Primární | Výraz | Popis
ix_SPTYPDSP_sptypsp | P | sp14id, sp07idtypd, sp06idsubd, sp07idtyp, sp06idsubs, sp33porad, sp36 |
ix_SPTYPDSP_sptypd |  | sp07idtypd, sp06idsubd | Index podle typu dokladu a subsystému dokladu
ix_SPTYPDSP_sptypod |  | sp07idtypd, sp06idsubd, sp07idtyp, sp06idsubs, sp33porad | Identifikace druhu operace v druhu procesu
ix_SPTYPDSP_sp07idtypd |  | sp07idtypd | Identifikátor typu procesu
ix_SPTYPDSP_sp06idsubs |  | sp06idsubs | Identifikace subsystému.
ix_SPTYPDSP_sp36 |  | sp36 | Jednoznačná časová identifikace transformace
ix_SPTYPDSP_sp19id |  | sp19id | Identifikace obecné předkontace


SPTYPDSX Operace používající dynamické spojení

Popis

Operace používající dynamické spojení

Atributy

Atribut | Typ | Návěští | Message | Popis
sp14id | C(6) | sp14id | Druh dynamického spojení operací | Druh dynamického spojení operací
sp07idtypd | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu procesu
sp06idsubd | C(3) | sp06idsubd | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp36 | C(12) | sp36 | Jednoznačná časová identifikace transformace | Jednoznačná časová identifikace transformace
sp07idtyp2 | C(6) | sp07idtyp2 | Identifikace druhu operace - druhý uzel | Identifikace druhu operace - druhý uzel
sp06idsub2 | C(3) | Komponenta | Identifikace komponenty - přijemce transformovaných dat | Identifikace komponenty - přijemce transformovaných dat

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Operace používající dynamické spojení - týká se druhu operace | SPTYPDSX sp07idtyp2 sp06idsub2 | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Operace používající dynamické spojení - týká se dynamického spojení | SPTYPDSX sp14id sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad sp36 | 1,1 : 0,M s rušením | SPTYPDSP sp14id sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad sp36 |

Indexy

Název | Primární | Výraz | Popis
ix_SPTYPDSX_sptypdsx | P | sp14id, sp07idtypd, sp06idsubd, sp07idtyp, sp06idsubs, sp33porad, sp36, sp07idtyp2, sp06idsub2 |
ix_SPTYPDSX_sptypsp |  | sp14id, sp07idtypd, sp06idsubd, sp07idtyp, sp06idsubs, sp33porad, sp36 |
ix_SPTYPDSX_sptyp2 |  | sp07idtyp2, sp06idsub2 |


SPTYPEI Import/Export operace

Popis

Import/Export operace

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw10nazev | C(8) | Tabulka | Název entity | Název entity
sp93id | C(6) | I-E | Identifikace importu-exportu | Identifikace importu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp68porad | N(3,0) | Pořadí | Pořadí exportu | Pořadí exportu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Import/Export operace - se vztahuje k druhu operace | SPTYPEI sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Import/Export operace - se vztahuje k definici exportu | SPTYPEI bw02krok bw10nazev sp93id | 1,1 : 0,M | SPIMP bw02krok bw10nazev sp93id |

Indexy

Název | Primární | Výraz | Popis
ix_SPTYPEI_sptypei | P | bw02krok, bw10nazev, sp93id, sp07idtyp, sp06idsubs |
ix_SPTYPEI_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SPTYPEI_spimp |  | bw02krok, bw10nazev, sp93id | bw02krok+bw10nazev+sp93id


SPTYPFOL Skupina procesů / předloh pro zobrazení v menu

Popis

Skupina procesů pro zobrazení v menu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp79id | C(6) | Skupina | Identifikace skupiny procesů | Identifikace skupiny procesů
sp79folder | C(40) | Název skupiny | Název skupiny procesů | Název skupiny procesů
sp79koment | M | Poznámka | Poznámka ke skupině procesů | Poznámka ke skupině procesů
sp79datzal | T | Datum založení | Datum založení | Datum založení
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp79uzprc | N(1,0) | Skupina procesu | Použití pro procesy Ano/Ne | Použití pro procesy Ano/Ne
sp79uzpre1 | N(1,0) | Skupina předlohy výstupu | Použití pro předlohy výstupu ve vlastnostech předlohy Ano/Ne | Použití pro předlohy výstupu ve vlastnostech předlohy Ano/Ne
sp79uzpre2 | N(1,0) | Osobní skupina předlohy výstupu | Použití pro určení osobní skupiny předlohy výstupu Ano/Ne | Použití pro určení osobní skupiny předlohy výstupu Ano/Ne

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Skupina procesů / předloh pro zobrazení v menu - založil uživatel | SPTYPFOL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Metapředloha výstupu - patří do skupiny | BWPRINS sp79id | 0,1 : 0,M | SPTYPFOL sp79id |
Předloha pro výstup - patří do skupiny předloh | BWPRINTD sp79id | 0,1 : 0,M | SPTYPFOL sp79id |
Druh procesu/operace - patří do skupiny procesů pro zobrazení v menu | SPTYP sp79id | 0,1 : 0,M | SPTYPFOL sp79id |

Indexy

Název | Primární | Výraz | Popis
ix_SPTYPFOL_sp79id | P | sp79id | Identifikace skupiny procesů
ix_SPTYPFOL_sp79folder |  | sp79folder | Název skupiny procesů
ix_SPTYPFOL_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPTYPGO Vyvolání operace z hlavního procesu

Popis

Vyvolání operace z hlavního dokladu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp72id | C(6) | Identifikace | Identifikace vyvolání | Identifikace vyvolání
sp07idtypd | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu procesu
sp06idsubd | C(3) | sp06idsubd | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery
sp07idtyp | C(6) | Druh | Identifikátor druhu operace | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp72nazev | C(40) | Název | Název vyvolání | Název vyvolání
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp72datum | T | Datum založení | Datum založení | Datum založení

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vyvolání operace z hlavního procesu - bude vyvolávat z procesu | SPTYPGO sp07idtypd sp06idsubd | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Vyvolání operace z hlavního procesu - bude vyvolávat operaci | SPTYPGO sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPTYPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad |
Vyvolání operace z hlavního procesu - založil uživatel | SPTYPGO bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_SPTYPGO_sp72id | P | sp72id | Identifikace vyvolání
ix_SPTYPGO_sptypod |  | sp07idtypd, sp06idsubd, sp07idtyp, sp06idsubs, sp33porad | Identifikace druhu operace v druhu procesu
ix_SPTYPGO_sptypd |  | sp07idtypd, sp06idsubd | Index podle typu dokladu a subsystému dokladu
ix_SPTYPGO_sp72nazev |  | sp72nazev | Název vyvolání
ix_SPTYPGO_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_SPTYPGO_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPTYPMAS Vlastnosti atributu v masce operace

Popis

Vlastnosti atributu v masce operace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp07idtypd | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu procesu
sp06idsubd | C(3) | sp06idsubd | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp39nazev | C(10) | Atribut události | Atribut události | Atribut události
sp82top | N(1,0) | Nastavit 1. | Nastavit na atribut při vstupu nové události | Nastavit na atribut při vstupu nové události
sp82vstup | N(1,0) | Editovat | Povolit vstup hodnoty v události | Povolit vstup hodnoty v události
sp82opakov | N(1,0) | Opakovat | Opakovat hodnotu podle aktuální události | Opakovat hodnotu podle aktuální události
sp82pamat | N(1,0) | Pamatovat | Pamatovat hodnotu pro příští spuštění operace aktuálním uživatelem | Pamatovat hodnotu pro příští spuštění operace aktuálním uživatelem
sp82init | N(1,0) | Inicializovat | Způsob inicializace | Způsob inicializace
sp40 | C(12) | Výraz | Výraz | Jednoznačná časová identifikace výrazu pro konverzi atributů
sp82text | C(80) | Konstanta | Znaková konstanta | Znaková konstanta
sp82num | N(20,6) | Konstanta | Numerická konstanta | Numerická konstanta
sp82cmbchk | N(2,0) | Konstanta | Hodnota překryvný seznam | Hodnota překryvný seznam
sp82koment | M | Poznámka | Poznámka |
sp82porad | N(3,0) | Pořadí | Pořadí | Pořadí
sp82valid | M | Validace | Výraz validace vstupu atributu v události ( not EMPTY(###) , ###>0 ...) | Výraz validace vstupu atributu v události ( not EMPTY(###) , ###>0 ...)
sp88id | C(6) | Text | Identifikace textu | Identifikace textu
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
sp82intval | N(1,0) | Interní validace | Interní validace - Zapnuta/Vypnuta | Interní validace - Zapnuta/Vypnuta
sp82intprd | N(1,0) | Interní předplňování | Interní předplňování - Zapnuto/Vypnuto | Interní předplňování - Zapnuto/Vypnuto

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vlastnosti atributu v masce operace - patří k operaci | SPTYPMAS sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Vlastnosti atributu v masce operace - definují výraz komponenty | SPTYPMAS sp40 | 0,1 : 0,M | SPTRNH sp40 |
Vlastnosti atributu v masce operace - mají definované chybové hlášení při neplatné validaci volným textem | SPTYPMAS sp88id | 1,1 : 0,M | SPTEXTY sp88id |

Indexy

Název | Primární | Výraz | Popis
ix_SPTYPMAS_sptypmas | P | sp07idtyp, sp06idsubs, sp07idtypd, sp06idsubd, bw01uziv, sp33porad, sp39nazev | PI - SPTYP+SPTYPD+bw01uziv+sp33porad+sp39nazev
ix_SPTYPMAS_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SPTYPMAS_sp39nazev |  | sp39nazev | Atribut události
ix_SPTYPMAS_sptypd |  | sp07idtypd, sp06idsubd | Index podle typu dokladu a subsystému dokladu
ix_SPTYPMAS_sptypod |  | sp07idtypd, sp06idsubd, sp07idtyp, sp06idsubs, sp33porad | Identifikace druhu operace v druhu procesu
ix_SPTYPMAS_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SPTYPMAS_sp40 |  | sp40 | Jednoznačná časová identifikace výrazu pro konverzi atributů
ix_SPTYPMAS_sp88id |  | sp88id | Identifikace textu


SPTYPOD Druh operace v druhu procesu

Popis

Operace druhu procesu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtypd | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu procesu
sp06idsubd | C(3) | sp06idsubd | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp31left | N(5,0) | sp31left | Pozice okna - levá souřadnice | Pozice okna - levá souřadnice
sp31top | N(5,0) | sp31top | Pozice okna - hodní souřadnice | Pozice okna - hodní souřadnice
sp31height | N(4,0) | sp31height | Výška okna | Výška okna
sp31width | N(4,0) | sp31width | Šířka okna | Šířka okna
sp31main | N(1,0) | sp31main | Kořenová operace druhu procesu | Kořenová operace druhu procesu
sp31tisko | N(1,0) | sp31tisko | Po ukončení výstup operace | Po ukončení výstup operace
sp31tiskd | N(1,0) | sp31tiskd | Po ukončení výstup dokladu | Po ukončení výstup dokladu
sp31autom | N(1,0) | sp31autom | Spouštět operaci | Spouštět operaci automaticky
sp31ukproc | N(1,0) | sp31ukproc | Ukončuje proces | Ukončuje proces
sp50id | C(12) | sp50id | Jednoznačná časová identifikace šablony | Jednoznačná časová identifikace šablony
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw04ident | C(10) | Ident. | Identifikace předlohy pro výstup | Identifikace předlohy pro výstup
bw81id | C(6) | MPV | Identifikace metapředlohy výstupu | Identifikace makropředlohy výstupu
sp31neauk | N(1,0) | sp31neauk |  |
sp31hlavpr | N(1,0) | sp31hlavpr | Odvozený proces bude hlavním procesem | Odvozený proces bude hlavním procesem
sp31semaf | N(4,0) | sp31semaf | Změna hodnoty semaforu procesu | Změna hodnoty semaforu procesu
bw05ident | C(6) | Skupina | Identifikace skupiny uživatelů | Identifikace skupiny uživatelů
sp31zaloz | N(1,0) | sp31zaloz | Vytvořit záložku na operaci v procesu | Vytvořit záložku na operaci v procesu
sp31preuko | N(1,0) | sp31preuko | Předcházející operace musí být ukončeny | Předcházející operace musí být ukončeny
sp31zahidu | C(2) | sp31zahidu | Zahajující datové úložiště | Zahajující datové úložiště

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh operace v druhu procesu - je obsažena na typu dokladu | SPTYPOD sp07idtypd sp06idsubd | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Druh operace v druhu procesu - je vyvoláním dokladu nebo operace | SPTYPOD sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Druh operace v druhu procesu - tiskne metapředlohou výstupu | SPTYPOD bw02krok bw81id | 0,1 : 0,M | BWPRINS bw02krok bw81id |
Druh operace v druhu procesu - použije šablonu | SPTYPOD sp50id | 0,1 : 0,M s rušením | SPSABL sp50id |
Druh operace v druhu procesu - má určenou skupinu uživatelů, která ji smí ukončit | SPTYPOD bw05ident | 0,1 : 0,M | BWUZIVAT bw01uziv |
Technologický krok v technologickém postupu - odpovídá uzlu diagramu procesu | TPTECOPR sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPTYPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad |
Uzel procesu aplikace - odpovídá uzlu v procesu inf.centra | APPROPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPTYPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad |
Dynamická transformace druhu plnění projektového úkolu - je směřována do uzlu procesu | NKUKOPDT sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPTYPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad |
Vazba druhů operací v druhu procesu - má první uzel | SPTYPVO sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M s rušením | SPTYPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad |
Vazba druhů operací v druhu procesu - má druhý uzel | SPTYPVO sp07idtypd sp06idsubd sp07idtyp2 sp06idsub2 sp33porad2 | 1,1 : 0,M s rušením | SPTYPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad |
Vazba druhů operací v druhu procesu - určuje vstupní operaci dokladu v druhém uzlu | SPTYPVO sp07idtyp2 sp06idsub2 sp07idtypb sp06idsubb sp33poradb | 0,1 : 0,M | SPTYPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad |
Vazba druhů operací v druhu procesu - určuje výstupní operaci dokladu v prvním uzlu | SPTYPVO sp07idtyp sp06idsubs sp07idtypa sp06idsuba sp33porada | 0,1 : 0,M | SPTYPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad |
Vyvolání operace z hlavního procesu - bude vyvolávat operaci | SPTYPGO sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPTYPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad |
Dynamické spojení operací - vytváří popojení na operaci v procesu | SPTYPDSP sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad | 0,1 : 0,M s rušením | SPTYPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad |
Kód provedený po ukončení operace a maska operace v procesu - se vztahuje k operaci procesu | SPTYPODK sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad | 1,1 : 0,1 s rušením | SPTYPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad |
Procesní import - se týká operace v procesu | SPIMPP sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPTYPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad |

Indexy

Název | Primární | Výraz | Popis
ix_SPTYPOD_sptypod | P | sp07idtypd, sp06idsubd, sp07idtyp, sp06idsubs, sp33porad | Identifikace druhu operace v druhu procesu
ix_SPTYPOD_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SPTYPOD_sptypd |  | sp07idtypd, sp06idsubd | Index podle typu dokladu a subsystému dokladu
ix_SPTYPOD_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_SPTYPOD_sp06idsubs |  | sp06idsubs | Identifikace subsystému.
ix_SPTYPOD_sp50id |  | sp50id | Jednoznačná časová identifikace šablony
ix_SPTYPOD_bwprins |  | bw02krok, bw81id | PI - bw02krok+bw81id
ix_SPTYPOD_bw05ident |  | bw05ident | Identifikace skupiny uživatelů


SPTYPODK Kód provedený po ukončení operace a maska operace v procesu

Popis

Kód provedený po ukončení operace a maska operace v procesu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtypd | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu procesu
sp06idsubd | C(3) | sp06idsubd | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp18kod | M | sp18kod | Kód provedený po ukončení operace | Kód provedený po ukončení operace
sp18maska | M | První vstupní údaj | Vstupní maska událostí operace v procesu | Vstupní maska událostí operace v procesu
sp18kodsta | M | sp18kodsta | Kód provedený po ukončení operace - statický | Kód provedený po ukončení operace - statický

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Kód provedený po ukončení operace a maska operace v procesu - se vztahuje k operaci procesu | SPTYPODK sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad | 1,1 : 0,1 s rušením | SPTYPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad |

Indexy

Název | Primární | Výraz | Popis
ix_SPTYPODK_sptypod | P | sp07idtypd, sp06idsubd, sp07idtyp, sp06idsubs, sp33porad | Identifikace druhu operace v druhu procesu


SPTYPOMO Osobní maska operace

Popis

Osobní maska operace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp82maska | M | První vstupní údaj | Osobní vstupní maska událostí operace | Osobní vstupní maska událostí operace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Osobní maska operace - patří k druhu operace | SPTYPOMO sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Osobní maska operace - patří uživateli systému | SPTYPOMO bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_SPTYPOMO_sptypomo | P | sp07idtyp, sp06idsubs, bw01uziv | PI - osobní masky operace
ix_SPTYPOMO_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SPTYPOMO_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPTYPPAR Rozšířené parametry operace/procesu

Popis

Rozšířené parametry operace/procesu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
bw10nazev | C(8) | Tabulka | Název entity | Název entity
sp64nazev | C(8) | Karta | Název volné karty | Identifikace volné karty
sp16opakov | N(1,0) | sp16opakov | Předplňovat - opakovat vstup při startu procesu | Předplňovat - opakovat vstup při startu procesu
sp16vstko | N(1,0) | sp16vstko | Po ukončení vstup volné karty operace | Po ukončení vstup volné karty operace
sp16vstkp | N(1,0) | sp16vstkp | Po ukončení vstup volné karty procesu | Po ukončení vstup volné karty procesu
sp16pict | M | Zobrazení | Zobrazení atributu | Zobrazení atributu
sp16init | M | Inicializace | Inicializační výraz | Inicializační výraz
sp16poradi | N(3,0) | Poř. | Pořadí vstupu atributu | Pořadí vstupu atributu
sp16koment | M | Poznámka | Poznámka |
sp16emptyo | N(1,0) | Ukončení operace bez událostí | Povolit ukončení operace bez událostí | Povolit ukončení operace bez událostí
sp16pozauk | N(1,0) | Operaci na pozadí vždy ukončovat automaticky | Operaci spuštěnou na pozadí ukončit automaticky bez ohledu na nastavení v diagramu | Operaci spuštěnou na pozadí ukončit automaticky bez ohledu na nastavení v diagramu
sp16zrcsto | N(1,0) | Zrcadlové storno | Zrcadlové storno ANO=při stornu vznikají inverzní operace a události, NE=při stornu jsou operace a události zrušeny i pro ukončené operace | Chování druhu operace při stornu - zrcadlové storno ANO=při stornu vznikají nové operace a události, NE=při stornu jsou operace a události zrušeny
sp16prcpop | M | Výraz popisu procesu | Výraz nebo skript v jazyce Foxpro (uvedený slovem SCRIPT) pro předplnění popisu procesu podle operace zahajující proces | Výraz pro předplnění popisu procesu podle operace zahajující proces
sp16prcext | M | Výraz externí identifikace procesu | Výraz nebo skript v jazyce Foxpro (uvedený slovem SCRIPT) pro předplnění externí identifikace procesu podle operace zahajující proces | Výraz pro předplnění externí identifikace procesu podle operace zahajující proces
sp16valsto | N(1,0) | Kontrolovat při stornu | Validovat otevřené období komponenty při stornu procesu | Validovat otevřené období komponenty při stornu procesu
sp16valzsu | N(1,0) | Kontrolovat při rušení stavu ukon. | Validovat otevřené období komponenty při rušení stavu ukončena | Validovat otevřené období komponenty při rušení stavu ukončena
sp16zbstro | N(1,0) | Zobrazovat ve stromu procesu | Zobrazovat ve stromu hlavního procesu Ano/Ne | Zobrazovat ve stromu hlavního procesu Ano/Ne
sp16prccom | M | Výraz poznámky procesu | Výraz nebo skript v jazyce Foxpro (uvedený slovem SCRIPT) pro předplnění poznámky procesu podle operace zahajující proces | Výraz pro předplnění poznámky procesu podle operace zahajující proces

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Rozšířené parametry operace/procesu - se týkají operace | SPTYPPAR sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Rozšířené parametry operace/procesu - definují spojenou volnou kartu | SPTYPPAR bw10nazev sp64nazev | 0,1 : 0,M | SPVOLST bw10nazev sp64nazev |

Indexy

Název | Primární | Výraz | Popis
ix_SPTYPPAR_sptyp | P | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SPTYPPAR_spvolst |  | bw10nazev, sp64nazev | PI - bw10nazev+sp64nazev


SPTYPPRT Výběr tiskové předlohy procesu

Popis

Výběrové tiskové předlohy procesu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw04ident | C(10) | Ident. | Identifikace předlohy pro výstup | Identifikace předlohy pro výstup
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Výběr tiskové předlohy procesu - jsou určeny pro druh procesu | SPTYPPRT sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Výběr tiskové předlohy procesu - definuje použitou předlohu | SPTYPPRT bw02krok bw04ident | 1,1 : 0,M | BWPRINTD bw02krok bw04ident |

Indexy

Název | Primární | Výraz | Popis
ix_SPTYPPRT_sptypprt | P | sp07idtyp, bw02krok, bw04ident | PI - SPTYP+BW04PRINTD
ix_SPTYPPRT_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SPTYPPRT_bw04printd |  | bw02krok, bw04ident | Primární klíč předlohy pro výstup BW02krok+BW04ident


SPTYPRUM Číselná řada operace pro umístění

Popis

Číselná řada operace pro umístění

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp83id | C(6) | Umístění | Identifikace umístění | Identifikace umístění
sp08idcisd | C(8) | Řada | Identifikátor číselné řady procesů | Identifikátor číselné řady procesů. *** Dříve OZNDOK.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Číselná řada operace pro umístění - je spojena s druhem operace | SPTYPRUM sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Číselná řada operace pro umístění - definuje použití číselné řady | SPTYPRUM sp08idcisd | 1,1 : 0,M s rušením | SPCISDOK sp08idcisd |

Indexy

Název | Primární | Výraz | Popis
ix_SPTYPRUM_sptyprum | P | sp07idtyp, sp06idsubs, sp83id | PI - SPTYP+sp83id
ix_SPTYPRUM_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SPTYPRUM_sp08idcisd |  | sp08idcisd | Identifikátor číselné řady procesů.


SPTYPSUB Určení typu subjektu spojení adresáta pro druh operace

Popis

Určení typu spojení adresáta pro druh operace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtypd | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu procesu
sp06idsubd | C(3) | sp06idsubd | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
spf2cssp | N(1,0) | Spojení | Pořadové číslo spojení v události operace | Pořadové číslo spojení v události operace
ad58id | C(6) | Typ | Identifikátor typu subjektu pro spojení adresáta | Identifikátor typu subjektu pro spojení adresáta
spf2pouimp | N(1,0) | Použít impl. | Použít implicitní spojení adresáta v případě, že pro něj neexistuje spojení daného typu subjektu | Použít implicitní spojení adresáta v případě, že pro něj neexistuje spojení daného typu subjektu
spf2kod | M | Kód | Script v jazyce Foxpro vyvolávaný pro určení spojení | Script v jazyce Foxpro vyvolávaný pro určení spojení
spf2koment | M | Poznámka | Poznámka | Poznámka
ad08id | C(6) | Kategorie | Identifikace kategorie adresáta. | Identifikace kategorie. *** Dříve KLICID.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Určení typu subjektu spojení adresáta pro druh operace - určuje typ subjektu spojení pro druh operace | SPTYPSUB sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Určení typu subjektu spojení adresáta pro druh operace - určuje typ subjektu spojení pro druh procesu | SPTYPSUB sp07idtypd sp06idsubd | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Určení typu subjektu spojení adresáta pro druh operace - má uvedený typ subjektu spojení | SPTYPSUB ad58id | 1,1 : 0,M | ADTYPSUB ad58id |
Určení typu subjektu spojení adresáta pro druh operace - má uvedenou kategorii spojení | SPTYPSUB ad08id | 0,1 : 0,M | ADKAT ad08id |

Indexy

Název | Primární | Výraz | Popis
ix_SPTYPSUB_sptypsub | P | sp07idtypd, sp06idsubd, sp07idtyp, sp06idsubs, spf2cssp | PI - SPTYP+SPTYPD+spf2cssp
ix_SPTYPSUB_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SPTYPSUB_sptypd |  | sp07idtypd, sp06idsubd | Index podle typu dokladu a subsystému dokladu
ix_SPTYPSUB_ad58id |  | ad58id | Identifikátor typu subjektu pro spojení adresáta
ix_SPTYPSUB_ad08id |  | ad08id | Identifikace kategorie.


SPTYPUD Typ události komponenty

Popis

Typ události komponenty

Atributy

Atribut | Typ | Návěští | Message | Popis
spf8id | C(6) | Typ | Identifikátor typu události komponenty | Identifikátor typu události komponenty
spf8naztyp | C(40) | Název typu | Název typu události komponenty | Název typu události komponenty
spf8koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Typ události komponenty použitelný pro druh operace komponenty - je pro typ události | SPTYPUDV spf8id | 1,1 : 0,M | SPTYPUD spf8id |
Skupina archivace - zapisuje protokol na typ události | UTARSKP spf8id | 1,1 : 0,M | SPTYPUD spf8id |
Událost vývěsky - je typu | VYUDALOS spf8id | 1,1 : 0,M | SPTYPUD spf8id |

Indexy

Název | Primární | Výraz | Popis
ix_SPTYPUD_spf8id | P | spf8id | Identifikátor typu události komponenty
ix_SPTYPUD_spf8naztyp |  | spf8naztyp | Název typu události komponenty


SPTYPUDV Typ události komponenty použitelný pro druh operace komponenty

Popis

Typ události komponenty použitelný pro typ operace komponenty

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
spf8id | C(6) | Typ | Identifikátor typu události komponenty | Identifikátor typu události komponenty
spf9koment | M | Poznámka | Poznámka | Poznámka
spf9pocat | N(1,0) | Počáteční | Počáteční typ pro druh operace | Počáteční typ pro druh operace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Typ události komponenty použitelný pro druh operace komponenty - je pro typ události | SPTYPUDV spf8id | 1,1 : 0,M | SPTYPUD spf8id |
Typ události komponenty použitelný pro druh operace komponenty - je pro druh operace | SPTYPUDV sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_SPTYPUDV_sptypudv | P | sp07idtyp, sp06idsubs, spf8id |
ix_SPTYPUDV_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SPTYPUDV_spf8id |  | spf8id | Identifikátor typu události komponenty


SPTYPUZ Výraz zobrazení informací o události ve stromu pro danou operaci

Popis

Výraz zobrazení informací o události ve stromu pro danou operaci

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp86vyraz | M | sp86vyraz | Výraz zobrazených informací o události ve stromu | Výraz zobrazených informací o události ve stromu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Výraz zobrazení informací o události ve stromu pro danou operaci - je výraz pro druh operace | SPTYPUZ sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_SPTYPUZ_sptyp | P | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému


SPTYPVAD Kredit adresáta pro druh hodnoty v operaci

Popis

Kredit adresáta pro druh hodnoty v operaci

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsub2 | C(3) | Komponenta | Identifikace komponenty - přijemce transformovaných dat | Identifikace komponenty - přijemce transformovaných dat
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp81hodnot | N(20,4) | Hodnota varování | Mezní porovnávaná hodnota pro varování | Mezní porovnávaná hodnota pro varování
sp81hodno2 | N(20,4) | Hodnota zákazu vstupu | Mezní porovnávaná hodnota pro zákaz vstupu | Mezní porovnávaná hodnota pro zákaz vstupu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Kredit adresáta pro druh hodnoty v operaci - se vztahuje k druhu hodnoty | SPTYPVAD sp67id sp06idsub2 | 1,1 : 0,M s rušením | SPSTATDI sp67id sp06idsubs |
Kredit adresáta pro druh hodnoty v operaci - se vztahuje k adresátovi | SPTYPVAD ad01id | 1,1 : 0,M s rušením | ADADSAT ad01id |
Kredit adresáta pro druh hodnoty v operaci - se vztahuje k druhu operace | SPTYPVAD sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_SPTYPVAD_sptypvad | P | sp07idtyp, sp06idsubs, sp67id, sp06idsub2, ad01id | PI - kreditu adresáta pro druh hodnoty
ix_SPTYPVAD_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SPTYPVAD_spstatdi2 |  | sp67id, sp06idsub2 | CK na druh sledované informace s sp06idsubs2
ix_SPTYPVAD_ad01id |  | ad01id | Identifikace adresáta
ix_SPTYPVAD_sptypvlu |  | sp07idtyp, sp06idsubs, sp67id, sp06idsub2 | PI - Pravidla validace zápisu dat operace
ix_SPTYPVAD_neprimyin1 |  |  |


SPTYPVLU Pravidlo validace zápisu dat operace

Popis

Pravidlo validace zápisu dat operace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor druhu operace | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsub2 | C(3) | Komponenta | Identifikace komponenty - přijemce transformovaných dat | Identifikace komponenty - přijemce transformovaných dat
sp80vetmen | N(1,0) | sp80vetmen | Aktuální hodnota je větší nebo menší než uvedená hodnota | Aktuální hodnota je větší nebo menší než uvedená hodnota
sp80hodnot | N(20,4) | než | Mezní porovnávaná hodnota pro varování | Mezní porovnávaná hodnota pro varování
sp80hodno2 | N(20,4) | a než | Mezní porovnávaná hodnota pro zákaz vstupu | Mezní porovnávaná hodnota pro zákaz vstupu
sp80zprava | N(1,0) | sp80zprava | Odeslat zprávu uživateli systému | Odeslat zprávu uživateli systému
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp80textz | M | Text odeslané zprávy | Text odeslané zprávy | Text odeslané zprávy

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Pravidlo validace zápisu dat operace - patří k druhu operace | SPTYPVLU sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Pravidlo validace zápisu dat operace - kontroluje druh hodnoty | SPTYPVLU sp67id sp06idsub2 | 1,1 : 0,M s rušením | SPSTATDI sp67id sp06idsubs |
Pravidlo validace zápisu dat operace - obsahuje požadavek odeslání zprávy uživateli systému | SPTYPVLU bw01uziv | 0,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_SPTYPVLU_sptypvlu | P | sp07idtyp, sp06idsubs, sp67id, sp06idsub2 | PI - Pravidla validace zápisu dat operace
ix_SPTYPVLU_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SPTYPVLU_spstatdi2 |  | sp67id, sp06idsub2 | CK na druh sledované informace s sp06idsubs2
ix_SPTYPVLU_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPTYPVO Vazba druhů operací v druhu procesu

Popis

Vazba druhů operací v druhu procesu

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtypd | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu procesu
sp06idsubd | C(3) | sp06idsubd | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp07idtyp2 | C(6) | sp07idtyp2 | Identifikace druhu operace - druhý uzel | Identifikace druhu operace - druhý uzel
sp06idsub2 | C(3) | Komponenta | Identifikace komponenty - přijemce transformovaných dat | Identifikace komponenty - přijemce transformovaných dat
sp33porad2 | N(2,0) | sp33porad2 | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp32crc | C(5) | sp32crc |  |
sp07idtypa | C(6) | sp07idtypa | Identifikace druhu operace - výstupní uzel dokladu prvního uzlu | Identifikace druhu operace - výstupní uzel dokladu prvního uzlu
sp06idsuba | C(3) | sp06idsuba | Identifikace komponenty - výstupní uzel procesu prvního uzlu | Identifikace komponenty - výstupní uzel procesu prvního uzlu
sp33porada | N(2,0) | sp33porada | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp07idtypb | C(6) | sp07idtypb | Identifikace operace - vstupní uzel procesu druhého uzlu | Identifikace operace - vstupní uzel procesu druhého uzlu
sp06idsubb | C(3) | sp06idsubb |  |
sp33poradb | N(2,0) | sp33poradb | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp36 | C(12) | sp36 | Jednoznačná časová identifikace transformace | Jednoznačná časová identifikace transformace
sp32trans | N(1,0) | sp32trans | Bude probíhat transformace | Bude probíhat transformace
sp32samost | N(1,0) | Vazba | Vazba vstupující do druhého uzlu | Vazba není svázaná s vazbami vstupujícími do druhého uzlu
sp32poukon | N(1,0) | sp32poukon | Vykonat transformaci po ukončení procesu | Vykonat transformaci po ukončení procesu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp32rozlis | C(1) | Rozlišení vazby | Rozlišení vazby pro transformaci | Rozlišení vazby pro transformaci
sp32aktzpr | N(4,0) | sp32aktzpr | Posun signalizace zprávy - počet dnů | Posun signalizace zprávy - počet dnů
bw05ident | C(6) | Skupina | Identifikace skupiny uživatelů | Identifikace skupiny uživatelů
sp32poradi | N(3,0) | Pořadí transf. | Pořadí transformace | Pořadí transformace
sp19id | C(6) | Předkontace | Identifikace obecné předkontace | Identifikace obecné předkontace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vazba druhů operací v druhu procesu - je na typu dokladu | SPTYPVO sp07idtypd sp06idsubd | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |
Vazba druhů operací v druhu procesu - má první uzel | SPTYPVO sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M s rušením | SPTYPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad |
Vazba druhů operací v druhu procesu - má druhý uzel | SPTYPVO sp07idtypd sp06idsubd sp07idtyp2 sp06idsub2 sp33porad2 | 1,1 : 0,M s rušením | SPTYPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad |
Vazba druhů operací v druhu procesu - určuje vstupní operaci dokladu v druhém uzlu | SPTYPVO sp07idtyp2 sp06idsub2 sp07idtypb sp06idsubb sp33poradb | 0,1 : 0,M | SPTYPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad |
Vazba druhů operací v druhu procesu - používá transformaci | SPTYPVO sp36 | 0,1 : 0,M | SPTRN sp36 |
Vazba druhů operací v druhu procesu - určuje výstupní operaci dokladu v prvním uzlu | SPTYPVO sp07idtyp sp06idsubs sp07idtypa sp06idsuba sp33porada | 0,1 : 0,M | SPTYPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad |
Vazba druhů operací v druhu procesu - je spojena s významem položky obecné předkontace | SPTYPVO sp19id | 0,1 : 0,M | SPPREDK sp19id |
Vazba druhů operací v druhu procesu - bude rozhodnuta skupinou uživatelů | SPTYPVO bw05ident | 0,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_SPTYPVO_sptypvo | P | sp07idtypd, sp06idsubd, sp07idtyp, sp06idsubs, sp33porad, sp07idtyp2, sp06idsub2, sp33porad2, sp32crc |
ix_SPTYPVO_sptypod |  | sp07idtypd, sp06idsubd, sp07idtyp, sp06idsubs, sp33porad | Identifikace druhu operace v druhu procesu
ix_SPTYPVO_sptypod2 |  | sp07idtypd, sp06idsubd, sp07idtyp2, sp06idsub2, sp33porad2 | Identifikace druhého druhu operace v druhu procesu
ix_SPTYPVO_sptypoda |  | sp07idtyp, sp06idsubs, sp07idtypa, sp06idsuba, sp33porada | Vazba na výstupní uzel vyvolávaného dokladu
ix_SPTYPVO_sptypodb |  | sp07idtyp2, sp06idsub2, sp07idtypb, sp06idsubb, sp33poradb | Vazba na vstupní uzel vyvolávaného dokladu
ix_SPTYPVO_sptypd |  | sp07idtypd, sp06idsubd | Index podle typu dokladu a subsystému dokladu
ix_SPTYPVO_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SPTYPVO_sptyp2 |  | sp07idtyp2, sp06idsub2 |
ix_SPTYPVO_sp36 |  | sp36 | Jednoznačná časová identifikace transformace
ix_SPTYPVO_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SPTYPVO_bw05ident |  | bw05ident | Identifikace skupiny uživatelů
ix_SPTYPVO_sp19id |  | sp19id | Identifikace obecné předkontace


SPVOLST Volná karta

Popis

Volná karta

Atributy

Atribut | Typ | Návěští | Message | Popis
bw10nazev | C(8) | Tabulka | Název entity | Název entity
sp64nazev | C(8) | Karta | Název volné karty | Identifikace volné karty
sp64volstr | C(40) | Popis | Popis volné karty | Popis volné karty
sp64dcapti | M | Dynamický nadpis | Dynamický nadpis | Dynamický nadpis
sp64koment | M | Komentář | Komentář k volné kartě | Komentář k volné kartě
sp66id | C(6) | Druh | Druh volné karty - pro přístup uživatele | Druh volné karty - pro přístup uživatele
spa6id | C(6) | Druh | Identifikace druhu implemetačního rozšíření | Identifikace druhu implemetačního rozšíření
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp64datum | T | Vznik | Datum vzniku volné karty | Datum vzniku volné karty
sp64top | N(4,0) | sp64top | Umístění okna - TOP | Umístění okna - TOP
sp64left | N(4,0) | sp64left | Umístění okna - LEFT | Umístění okna - TOP
sp64height | N(4,0) | sp64height | Umístění okna - HEIGHT | Umístění okna - HEIGHT
sp64width | N(4,0) | sp64width | Umístění okna - WIDTH | Umístění okna - WIDTH
sp64zmena | C(10) | sp64zmena | Časová identifikace přegenerování struktury volné karty | Časová identifikace přegenerování struktury volné karty
sp64tileft | N(4,0) | sp64tileft | Umístění čas - LEFT | Umístění čas - LEFT
sp64titop | N(4,0) | sp64titop | Umístění čas - TOP | Umístění čas - TOP
sp64uzleft | N(4,0) | sp64uzleft | Umístění uživatel - LEFT | Umístění uživatel - LEFT
sp64uztop | N(4,0) | sp64uztop | Umístění uživatel - TOP | Umístění uživatel - TOP
sp64auto | N(1,0) | sp64auto | Vyvolat automaticky při spuštění formuláře | Vyvolat automaticky při spuštění formuláře
sp64posuv | N(1,0) | Posuvník | Posuvník okna volné karty Žádný/Horizontální/Vertikální/Oba horizontální i vertikální | Posuvník okna volné karty Žádný/Horizontální/Vertikální/Oba horizontální i vertikální
sp64reswin | N(1,0) | Velikost | Umožnit změnu velikosti okna - Ne/Horizontálně/Vertikálně/Oběma směry - horizontálně i vertikálně | Umožnit změnu velikosti okna - Ne/Horizontálně/Vertikálně/Oběma směry - horizontálně i vertikálně
sp64requ | N(1,0) | sp64requ | Po vstupu volné karty znovu načíst kartu | Po vstupu volné karty znovu načíst kartu
sp64script | M | Skript | Kód v jazyce Foxpro provedený před zápisem dat volné karty | Kód v jazyce Foxpro provedený před zápisem dat volné karty
sp64uzshow | N(1,0) | Autor | Zobrazovat informaci o autorovi záznamu Ano/Ne | Zobrazovat informaci o autorovi záznamu Ano/Ne

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Volná karta - je druhu pro přístup uživatele | SPVOLST sp66id | 1,1 : 0,M | SPVOLSTT sp66id |
Volná karta - byla založena uživatelem | SPVOLST bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Volná karta - je druhu pro správu volné karty | SPVOLST spa6id | 1,1 : 0,M | SPCINDVT spa6id |
Definice volného pohledu volné karty - patří k volné kartě | SPVOLSTV bw10nazev sp64nazev | 1,1 : 0,M s rušením | SPVOLST bw10nazev sp64nazev |
Doplňující vlastnost formuláře - spouští volnou kartu | SPCINDV bw10nazev sp64nazev | 0,1 : 0,M | SPVOLST bw10nazev sp64nazev |
Užití volné karty - je užitím volné karty | SPVOLSTU bw10nazev sp64nazev | 1,1 : 0,M s rušením | SPVOLST bw10nazev sp64nazev |
Rozšířené parametry operace/procesu - definují spojenou volnou kartu | SPTYPPAR bw10nazev sp64nazev | 0,1 : 0,M | SPVOLST bw10nazev sp64nazev |
Atribut volné karty - patří k volné struktuře | SPVOLSTA bw10nazev sp64nazev | 1,1 : 0,M s rušením | SPVOLST bw10nazev sp64nazev |

Indexy

Název | Primární | Výraz | Popis
ix_SPVOLST_spvolst | P | bw10nazev, sp64nazev | PI - bw10nazev+sp64nazev
ix_SPVOLST_sp64nazev |  | sp64nazev | Identifikace volné karty
ix_SPVOLST_sp64volstr |  | sp64volstr | Popis volné karty
ix_SPVOLST_sp66id |  | sp66id | Druh volné karty - pro přístup uživatele
ix_SPVOLST_spa6id |  | spa6id | Identifikace druhu implemetačního rozšíření
ix_SPVOLST_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPVOLSTA Atribut volné karty

Popis

Atribut volné karty

Atributy

Atribut | Typ | Návěští | Message | Popis
bw10nazev | C(8) | Tabulka | Název entity | Název entity
sp64nazev | C(8) | Karta | Název volné karty | Identifikace volné karty
sp65nazev | C(10) | Název | Název atributu volné karty | Název atributu volné karty
sp66id | C(6) | Druh | Druh volné karty - pro přístup uživatele | Druh volné karty - pro přístup uživatele
sp65poradi | N(3,0) | sp65poradi | Pořadí atributu volné karty | Pořadí atributu volné karty
sp65typ | N(1,0) | Typ | Typ atributu volné karty | Typ atributu volné karty
sp65delka | N(3,0) | Délka | Délka atributu volné karty | Délka atributu volné karty
sp65deseti | N(2,0) | Des. | Počet desetin atributu volné karty | Počet desetin atributu volné karty
sp65trida | N(1,0) | Třída | Třída ovládacího prvku |
sp65label | C(60) | Návěští | Návěští atributu volné karty | Návěští atributu volné karty
sp65mess | C(60) | Poznámka | Poznámka atributu volné karty | Poznámka atributu volné karty
sp65init | M | Inicializace | Inicializační hodnota atributu volné karty | Inicializační hodnota atributu volné karty
sp65pict | M | Zobrazení | Text pro zaškrtávací políčko nebo seznam hodnot pro překryvný seznam oddělených čárkou | Picture atributu volné karty
sp65top | N(4,0) | sp65top | Umístění TOP | Umístění TOP
sp65left | N(4,0) | sp65left | Umístění LEFT | Umístění LEFT
sp65latop | N(4,0) | sp65latop | Umístění - LABEL TOP | Umístění - LABEL TOP
sp65laleft | N(4,0) | sp65laleft | Umístění - LABEL LEFT | Umístění - LABEL LEFT
sp65height | N(4,0) | sp65height | Umístění HEIGHT | Umístění HEIGHT
sp65usazen | N(1,0) | sp65usazen | Atribut byl usazen na pozici okna | Atribut byl usazen na pozici okna
sp65width | N(4,0) | sp65width | Umístění WIDTH | Umístění WIDTH
sp65index | N(1,0) | sp65index | Vytvářet index podle atributu | Vytvářet index podle atributu
sp65nonull | N(1,0) | sp65nonull | Povinný údaj | Povinný údaj
sp65cid | C(10) | sp65cid | Časová identifikace atributu volné karty | Časová identifikace atributu volné karty
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
sp65valid | M | Validace | Script validace v jazyce Foxpro | Script validace v jazyce Foxpro
sp65when | M | Podmínka | Podmínka vstupu atributu | Podmínka vstupu atributu
sp65autosi | N(1,0) | P.oknu | Přizpůsobovat oknu | Přizpůsobovat oknu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Atribut volné karty - patří k volné struktuře | SPVOLSTA bw10nazev sp64nazev | 1,1 : 0,M s rušením | SPVOLST bw10nazev sp64nazev |
Atribut volné karty - je druhu | SPVOLSTA sp66id | 1,1 : 0,M | SPVOLSTT sp66id |

Indexy

Název | Primární | Výraz | Popis
ix_SPVOLSTA_spvolsta | P | bw10nazev, sp64nazev, sp65nazev |
ix_SPVOLSTA_spvolst |  | bw10nazev, sp64nazev | PI - bw10nazev+sp64nazev
ix_SPVOLSTA_sp64nazev |  | sp64nazev | Identifikace volné karty
ix_SPVOLSTA_sp66id |  | sp66id | Druh volné karty - pro přístup uživatele
ix_SPVOLSTA_sp65poradi |  | sp65poradi | Pořadí atributu volné karty


SPVOLSTT Druh volné karty

Popis

Druh volné karty

Atributy

Atribut | Typ | Návěští | Message | Popis
sp66id | C(6) | Druh | Druh volné karty - pro přístup uživatele | Druh volné karty - pro přístup uživatele
sp66druhst | C(40) | Název druhu volné karty | Název druhu volné karty | Název druhu volné karty
sp66datum | T | Vznik | Datum založení druhu volné karty | Datum založení druhu volné karty
sp66koment | M | Komentář | Popis druhu volné karty | Popis druhu volné karty
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh volné karty - založil uživatel | SPVOLSTT bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Volná karta - je druhu pro přístup uživatele | SPVOLST sp66id | 1,1 : 0,M | SPVOLSTT sp66id |
Atribut volné karty - je druhu | SPVOLSTA sp66id | 1,1 : 0,M | SPVOLSTT sp66id |

Indexy

Název | Primární | Výraz | Popis
ix_SPVOLSTT_sp66id | P | sp66id | Druh volné karty - pro přístup uživatele
ix_SPVOLSTT_sp66druhst |  | sp66druhst | Název druhu volné karty
ix_SPVOLSTT_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPVOLSTU Užití volné karty

Popis

Užití volné karty

Atributy

Atribut | Typ | Návěští | Message | Popis
bw10nazev | C(8) | Tabulka | Název entity | Název entity
sp64nazev | C(8) | Karta | Název volné karty | Identifikace volné karty
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
spe7dat1 | D | Poprvé | Datum prvního užití volné karty | Datum prvního užití volné karty
spe7dat2 | D | Naposledy | Datum posledního užití volné karty | Datum posledního užití volné karty
spe7pocet | N(6,0) | Počet | Celkový počet užití volné karty | Celkový počet užití volné karty

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Užití volné karty - je užitím volné karty | SPVOLSTU bw10nazev sp64nazev | 1,1 : 0,M s rušením | SPVOLST bw10nazev sp64nazev |
Užití volné karty - zaznamenává užití předlohy uživatelem | SPVOLSTU bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_SPVOLSTU_spvolstu | P | bw10nazev, sp64nazev, bw01uziv | PI - SPVOLST+bw01uziv
ix_SPVOLSTU_spvolst |  | bw10nazev, sp64nazev | PI - bw10nazev+sp64nazev
ix_SPVOLSTU_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPVOLSTV Definice volného pohledu volné karty

Popis

Definice volného pohledu volné karty

Atributy

Atribut | Typ | Návěští | Message | Popis
bw10nazev | C(8) | Tabulka | Název entity | Název entity
sp64nazev | C(8) | Karta | Název volné karty | Identifikace volné karty
sp75id | C(6) | Pohled | Identifikace volného pohledu | Identifikace volného pohledu
sp75volpoh | C(40) | Popis volného pohledu | Popis volného pohledu | Popis volného pohledu
sp75select | M | Dotaz | Dotaz volného pohledu | Dotaz volného pohledu
sp75atrret | M | Návratové hodnoty | Návratové hodnoty zdrojového formuláře | Návratové hodnoty zdrojového formuláře
sp75atrfor | M | Formální parametry | Formální parametry dotazu | Formální parametry dotazu
sp75koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Definice volného pohledu volné karty - patří k volné kartě | SPVOLSTV bw10nazev sp64nazev | 1,1 : 0,M s rušením | SPVOLST bw10nazev sp64nazev |

Indexy

Název | Primární | Výraz | Popis
ix_SPVOLSTV_spvolstv | P | bw10nazev, sp64nazev, sp75id |
ix_SPVOLSTV_spvolst |  | bw10nazev, sp64nazev | PI - bw10nazev+sp64nazev


SPVYBER Obecný výběr

Popis

Výběr

Atributy

Atribut | Typ | Návěští | Message | Popis
sp27id | C(12) | sp27id | Jednoznačná časová identifikace obecného výběru | Jednoznačná časová identifikace obecného výběru
sp27vyber | C(40) | Výběr | Název obecného výběru | Název obecného výběru
sp27koment | M | Komentář | Poznámka k obecnému výběru | Poznámka k obecnému výběru
sp27okleft | N(4,0) | sp27okleft | Umístění tlačítka OK - LEFT | Umístění tlačítka OK - LEFT
sp27oktop | N(4,0) | sp27oktop | Umístění tlačítka OK - TOP | Umístění tlačítka OK - TOP
sp27sttop | N(4,0) | sp27sttop | Umístění tlačítka STORNO - TOP | Umístění tlačítka STORNO - TOP
sp27stleft | N(4,0) | sp27stleft | Umístění tlačítka STORNO - LEFT | Umístění tlačítka STORNO - LEFT
sp27height | N(4,0) | sp27height | Umístění okna - HEIGHT | Umístění okna - HEIGHT
sp27width | N(4,0) | sp27width | Umístění okna - WIDTH | Umístění okna - WIDTH
sp27datum | T | Datum vzniku | Datum vzniku výběru | Datum vzniku výběru
sp27verej | N(1,0) | sp27verej | Veřejný obecný výběr - je přístupný všem uživatelům systému | Veřejná obecný výběr - je přístupný všem uživatelům systému
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
sp27vyraz | M | Výraz | Výraz obecného výběru | Výraz obecného výběru
sp27idpohl | C(10) | Výběr | Určení výběru | Identifikace pohledu obecného výběru
sp27atrib | M | Atributy | Atributy obecného výběru | Atributy obecného výběru
spe4 | C(12) | Doplnění | Identifikace doplnění mřížky formuláře | Identifikace doplnění mřížky formuláře - Jednoznačná časová identifikace
bw66id | C(6) | Druh | Identifikace druhu předlohy | Identifikace druhu předlohy
sp27from | M | FROM | Doplnění obecného výběru FROM | Doplnění obecného výběru

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Obecný výběr - založil uživatel | SPVYBER bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Obecný výběr - aktivuje doplnění mřížky činnosti formuláře | SPVYBER spe4 | 0,1 : 0,M | SPGRID spe4 |
Obecný výběr - je druhu | SPVYBER bw66id | 1,1 : 0,M | BWPRINTT bw66id |
Předepsané užití předlohy výstupu s obecným výběrem - je pro obecný výběr | SPVYBERV sp27id | 1,1 : 0,M s rušením | SPVYBER sp27id |
Užití obecného výběru - je užitím obecného výběru | SPVYBERU sp27id | 1,1 : 0,M s rušením | SPVYBER sp27id |
Parametr činnosti menu - definuje užití obecného výběru | BWMENPAR sp27id | 0,1 : 0,M | SPVYBER sp27id |
Proměnná výběru - patří do výběru | SPVYBERP sp27id | 1,1 : 0,M s rušením | SPVYBER sp27id |
Relace výběru - patří do výběru | SPVYBERR sp27id | 1,1 : 0,M s rušením | SPVYBER sp27id |

Indexy

Název | Primární | Výraz | Popis
ix_SPVYBER_sp27id | P | sp27id | Jednoznačná časová identifikace obecného výběru
ix_SPVYBER_sp27vyber |  | sp27vyber | Název obecného výběru
ix_SPVYBER_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SPVYBER_spe4 |  | spe4 | Identifikace doplnění mřížky formuláře - Jednoznačná časová identifikace
ix_SPVYBER_bw66id |  | bw66id | Identifikace druhu předlohy


SPVYBERP Proměnná výběru

Popis

Proměnná výběru

Atributy

Atribut | Typ | Návěští | Message | Popis
sp28 | C(12) | sp28 | Jednoznačná časová identifikace proměnné obecného výběru | Jednoznačná časová identifikace proměnné obecného výběru
sp27id | C(12) | sp27id | Jednoznačná časová identifikace obecného výběru | Jednoznačná časová identifikace obecného výběru
sp28cisprm | C(4) | Proměnná | Číslo proměnné definice obecného výběru | Číslo proměnné definice obecného výběru
sp28nazev | C(10) | Název proměnné | Název proměnné obecného výběru | Název proměnné obecného výběru
sp28typ | N(1,0) | Typ | Typ proměnné obecného výběru | Typ proměnné obecného výběru
sp28delka | N(3,0) | Délka proměnné | Délka proměnné obecného výběru | Délka proměnné obecného výběru
sp28deseti | N(2,0) | Počet desetin | Počet desetin obecného výběru | Počet desetin obecného výběru
sp28label | C(30) | Návěští | Návěští proměnné obecného výběru | Návěští proměnné obecného výběru
sp28trida | N(1,0) | Třída | Třída ovládacího prvku | Třída ovládacího prvku
sp28left | N(4,0) | sp28left | Umístění LEFT | Umístění LEFT
sp28top | N(4,0) | sp28top | Umístění TOP | Umístění TOP
sp28height | N(4,0) | sp28height | Umístění HEIGHT | Umístění HEIGHT
sp28width | N(4,0) | sp28width | Umístění WIDTH | Umístění WIDTH
sp28laleft | N(4,0) | sp28laleft | Umístění - LABEL LEFT | Umístění - LABEL LEFT
sp28latop | N(4,0) | sp28latop | Umístění - LABEL TOP | Umístění - LABEL TOP
sp28pict | M | Hodnoty | Text pro zaškrtávací políčko nebo seznam hodnot pro překryvný seznam oddělených čárkou | Názvy hodnot pro překryvný seznam
sp28vyraz | C(60) | Výraz | Výraz proměnné obecného výběru | Výraz proměnné obecného výběru
sp28vstup | N(1,0) | Naplnění | Způsob naplnění proměnné - vstupem nebo výpočtem | Způsob naplnění proměnné - vstupem nebo výpočtem
sp28init | M | Inicializace | Inicializační hodnota proměnné obecného výběru | Inicializační hodnota proměnné obecného výběru
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
sp28valid | M | Validace | Script v jazyce Foxpro |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Proměnná výběru - patří do výběru | SPVYBERP sp27id | 1,1 : 0,M s rušením | SPVYBER sp27id |

Indexy

Název | Primární | Výraz | Popis
ix_SPVYBERP_sp28 | P | sp28 | Jednoznačná časová identifikace proměnné obecného výběru
ix_SPVYBERP_sp27id |  | sp27id | Jednoznačná časová identifikace obecného výběru


SPVYBERR Relace výběru

Popis

Doplňující relace výběru

Atributy

Atribut | Typ | Návěští | Message | Popis
sp29alias | C(22) | sp29alias | Alias připojeného souboru | Alias připojeného souboru
sp27id | C(12) | sp27id | Jednoznačná časová identifikace obecného výběru | Jednoznačná časová identifikace obecného výběru
sp29soubor | C(22) | sp29soubor | Název připojeného souboru | Název připojeného souboru
sp29parent | C(22) | sp29parent | Alias nadřazeného souboru | Alias nadřazeného souboru
sp29vyraz | M | sp29vyraz | Výraz spojení nadřazeného alias s aktuálním alias | Výraz spojení nadřazeného alias s aktuálním alias
bw19idrel | C(11) | bw19idrel | Identifikace napojené entity relací předdefinovaného slovníku dat | Identifikace napojené entity relací předdefinovaného slovníku dat
sp29volna | N(1,0) | sp29volna | Příznak - napojená tabulka je tabulkou volných struktur | Příznak - napojená tabulka je tabulkou volných struktur

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Relace výběru - patří do výběru | SPVYBERR sp27id | 1,1 : 0,M s rušením | SPVYBER sp27id |

Indexy

Název | Primární | Výraz | Popis
ix_SPVYBERR_spvyberr | P | sp29alias, sp27id |
ix_SPVYBERR_sp27id |  | sp27id | Jednoznačná časová identifikace obecného výběru


SPVYBERU Užití obecného výběru

Popis

Užití obecného výběru

Atributy

Atribut | Typ | Návěští | Message | Popis
sp27id | C(12) | sp27id | Jednoznačná časová identifikace obecného výběru | Jednoznačná časová identifikace obecného výběru
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
spe6dat1 | D | Poprvé | Datum prvního užití obecného výběru | Datum prvního užití obecného výběru
spe6dat2 | D | Naposledy | Datum posledního užití obecného výběru | Datum posledního užití obecného výběru
spe6pocet | N(6,0) | Počet | Celkový počet užití obecného výběru | Celkový počet užití obecného výběru

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Užití obecného výběru - je užitím obecného výběru | SPVYBERU sp27id | 1,1 : 0,M s rušením | SPVYBER sp27id |
Užití obecného výběru - zaznamenává užití obecného výběru uživatelem | SPVYBERU bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_SPVYBERU_spvyberu | P | sp27id, bw01uziv | PI - sp27id+bw01uziv
ix_SPVYBERU_sp27id |  | sp27id | Jednoznačná časová identifikace obecného výběru
ix_SPVYBERU_bw01uziv |  | bw01uziv | Identifikace uživatele systému


SPVYBERV Předepsané užití předlohy výstupu s obecným výběrem

Popis

Předepsané užití předlohy výstupu s obecným výběrem

Atributy

Atribut | Typ | Návěští | Message | Popis
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
bw04ident | C(10) | Ident. | Identifikace předlohy pro výstup | Identifikace předlohy pro výstup
sp27id | C(12) | sp27id | Jednoznačná časová identifikace obecného výběru | Jednoznačná časová identifikace obecného výběru

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Předepsané užití předlohy výstupu s obecným výběrem - je pro obecný výběr | SPVYBERV sp27id | 1,1 : 0,M s rušením | SPVYBER sp27id |
Předepsané užití předlohy výstupu s obecným výběrem - je pro předlohu výstupu | SPVYBERV bw02krok bw04ident | 1,1 : 0,M s rušením | BWPRINTD bw02krok bw04ident |

Indexy

Název | Primární | Výraz | Popis
ix_SPVYBERV_spvyberv | P | bw02krok, bw04ident, sp27id | PI - BW04PRINTD+sp27id
ix_SPVYBERV_bw04printd |  | bw02krok, bw04ident | Primární klíč předlohy pro výstup BW02krok+BW04ident
ix_SPVYBERV_sp27id |  | sp27id | Jednoznačná časová identifikace obecného výběru


SPXMLTAG Tag XML dokumentu

Popis

Tag XML dokumentu

Atributy

Atribut | Typ | Návěští | Message | Popis
spb1tag | C(20) | Tag | Identifikace TAG v XML dokumentu | Identifikace TAG v XML dokumentu
sp57id | C(6) | Druh | Identifikátor druhu dokumentu | Identifikátor druhu dokumentu
bw88id | C(6) | Ikona | Identifikace ikony | Identifikace ikony
spb1label | C(80) | Popis | Popis tagu dokumentu | Popis tagu dokumentu
spb1status | C(80) | Stavový ř. | Stavový řádek hodnoty | Stavový řádek hodnoty
spb1uzel | N(1,0) | Uzel | Je tag uzlem dokumentu ? | Je tag uzlem dokumentu
spb1extfil | N(1,0) | Externí s. | Externí soubor | Externí soubor
spb1top | N(1,0) | Vrchol | Vrcholový uzel dokumentu ? | Vrcholový uzel dokumentu ?
spb1voltxt | N(1,0) | Volný text | Uzel s volným textem | Uzel s volným textem
spb1typ | N(1,0) | Typ hodnoty | Typ hodnoty | Typ hodnoty
spb1len | N(3,0) | Délka | Délka údaje | Délka údaje
spb1dec | N(2,0) | Desetiny | Počet desetin údaje | Počet desetin údaje
spb1koment | M | Poznámka | Poznámka | Poznámka
spb1trida | N(1,0) | Třída | Třída ovládacího prvku | Třída ovládacího prvku
spb1pict | M | Zobrazení |  |
spb1dynlab | M | DN | Výraz dynamického návěští | Výraz dynamického návěští
spb2dynlab | M | DN | Výraz dynamického návěští | Výraz dynamického návěští
spb1defsty | M | spb1defsty | Definice stylu pro volný text | Definice stylu pro volný text
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Tag XML dokumentu - je druhu dokumentu | SPXMLTAG sp57id | 1,1 : 0,M | SPDOKTYP sp57id |
Tag XML dokumentu - používá ikonu | SPXMLTAG bw88id | 1,1 : 0,M | BWIKONA bw88id |
Vazba mezi tagy XML dokumentu - definuje 1.tag | SPXMLVAZ spb1tag | 1,1 : 0,M s rušením | SPXMLTAG spb1tag |
Vazba mezi tagy XML dokumentu - definuje 2.tag | SPXMLVAZ spb1tag2 | 1,1 : 0,M | SPXMLTAG spb1tag |
Uzel XSLT předlohy - je určen pro tag XML | SPXSLTAG spb1tag | 1,1 : 0,M | SPXMLTAG spb1tag |
Doplňující vlastnost formuláře vyvolávaná tagem XML dokumentu - určuje tag XML dokumentu | SPXMLTDV spb1tag | 1,1 : 0,M | SPXMLTAG spb1tag |

Indexy

Název | Primární | Výraz | Popis
ix_SPXMLTAG_spb1tag | P | spb1tag | Identifikace TAG v XML dokumentu
ix_SPXMLTAG_sp57id |  | sp57id | Identifikátor druhu dokumentu
ix_SPXMLTAG_bw88id |  | bw88id | Identifikace ikony
ix_SPXMLTAG_spb1label |  | spb1label | Popis tagu dokumentu


SPXMLTDV Doplňující vlastnost formuláře vyvolávaná tagem XML dokumentu

Popis

Doplňující vlastnost formuláře vyvolávaná tagem XML dokumentu

Atributy

Atribut | Typ | Návěští | Message | Popis
spb1tag | C(20) | Tag | Identifikace TAG v XML dokumentu | Identifikace TAG v XML dokumentu
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti
spa7id | C(6) | Vlastnost | Identifikace doplňující vlastnosti činnosti | Identifikace doplňující vlastnosti činnosti
spc0alias | C(6) | Alias | Alias volání doplňující vlastnosti formuláře | Alias volání doplňující vlastnosti formuláře
spc0nazvla | C(40) | Název volání | Název volání doplňující vlastnosti | Název volání doplňující vlastnosti
spc0porad | N(3,0) | Pořadí | Pořadí zobrazení v menu | Pořadí zobrazení v menu
spc0param | M | Parametry | Parametry volání doplňující vlastnosti formuláře | Parametry volání doplňující vlastnosti formuláře
spc0koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Doplňující vlastnost formuláře vyvolávaná tagem XML dokumentu - určuje tag XML dokumentu | SPXMLTDV spb1tag | 1,1 : 0,M | SPXMLTAG spb1tag |
Doplňující vlastnost formuláře vyvolávaná tagem XML dokumentu - určuje doplňující vlastnost formuláře | SPXMLTDV bw02krok spa7id | 1,1 : 0,M | SPCINDV bw02krok spa7id |

Indexy

Název | Primární | Výraz | Popis
ix_SPXMLTDV_spxmltdv | P | spb1tag, bw02krok, spa7id, spc0alias | PI - spb1tag+SPCINDV+spc0alias
ix_SPXMLTDV_spb1tag |  | spb1tag | Identifikace TAG v XML dokumentu
ix_SPXMLTDV_spcindv |  | bw02krok, spa7id | PI - bw02krok+spa6id


SPXMLVAZ Vazba mezi tagy XML dokumentu

Popis

Vazba mezi tagy XML dokumentu

Atributy

Atribut | Typ | Návěští | Message | Popis
spb1tag2 | C(20) | Tag | Identifikace navazujícího tagu | Identifikace navazujícího tagu
spb1tag | C(20) | Tag | Identifikace TAG v XML dokumentu | Identifikace TAG v XML dokumentu
spb2tagals | C(20) | Alias | Alias tag při použití pod nadřízeným tagem (není-uveden použije se identifikace z vlastní definice tagu) | Alias tag při použití pod nadřízeným tagem (není-uveden použije se identifikace z vlastní definice tagu)
sp57id | C(6) | Druh | Identifikátor druhu dokumentu | Identifikátor druhu dokumentu
bw88id | C(6) | Ikona | Identifikace ikony | Identifikace ikony
spb2porad | N(3,0) | Poř. | Pořadí zobrazení popisného údaje | Pořadí zobrazení popisného údaje
spb2label | C(80) | Návěští | Popis tagu dokumentu | Popis tagu dokumentu
spb2status | C(80) | Stavový ř. | Stavový řádek hodnoty | Stavový řádek hodnoty
spb2init | M | Init | Inicializační hodnota atributu | Inicializační hodnota atributu
spb2kardin | N(1,0) | Kardinalita | Kardinalita | Kardinalita
spb2left | N(5,0) | spb2left | Umístění LEFT | Umístění LEFT
spb2top | N(5,0) | spb2top | Umístění TOP | Umístění TOP
spb2laleft | N(5,0) | spb2laleft | Umístění návěští LEFT | Umístění návěští LEFT
spb2latop | N(5,0) | spb2latop | Umístění návěští TOP | Umístění návěští TOP
spb2width | N(5,0) | spb2width | Umístění WIDTH | Umístění WIDTH
spb2height | N(5,0) | spb2height | Umístění HEIGHT | Umístění HEIGHT
spb2zovzdy | N(1,0) | Z.vždy | Zobrazovat vždy (tj. také u podřízených uzlů) | Zobrazovat vždy (tj. také u podřízených uzlů)
spb2zonasl | N(1,0) | Z.násl. | Zobrazovat je-li následníkem | Zobrazovat je-li následníkem
spb2autosi | N(1,0) | Přizp.oknu | Přizpůsobovat oknu | Přizpůsobovat oknu
spb2dynlab | M | DN | Výraz dynamického návěští | Výraz dynamického návěští
spb2sort | M | Třídící klíč | Třídící klíč | Třídící klíč
spb2odkaz | N(1,0) | Odkaz | Příznak uzlu odkazujícího na uzel jiného dokumentu | Příznak uzlu odkazujícího na uzel jiného dokumentu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vazba mezi tagy XML dokumentu - definuje 1.tag | SPXMLVAZ spb1tag | 1,1 : 0,M s rušením | SPXMLTAG spb1tag |
Vazba mezi tagy XML dokumentu - definuje 2.tag | SPXMLVAZ spb1tag2 | 1,1 : 0,M | SPXMLTAG spb1tag |
Vazba mezi tagy XML dokumentu - používá ikonu | SPXMLVAZ bw88id | 1,1 : 0,M | BWIKONA bw88id |
Vazba mezi tagy XML dokumentu - je druhu dokumentu | SPXMLVAZ sp57id | 1,1 : 0,M | SPDOKTYP sp57id |
Vazba mezi tagy XSL definice - odpovídá vazbě XML defince | SPXSLVAZ spb1tag2 spb1tag spb2tagals | 1,1 : 0,M | SPXMLVAZ spb1tag2 spb1tag spb2tagals |

Indexy

Název | Primární | Výraz | Popis
ix_SPXMLVAZ_spxmlvaz | P | spb1tag2, spb1tag, spb2tagals | PI - spb1tag+spb1tag2
ix_SPXMLVAZ_spb1tag |  | spb1tag | Identifikace TAG v XML dokumentu
ix_SPXMLVAZ_sp57id |  | sp57id | Identifikátor druhu dokumentu
ix_SPXMLVAZ_bw88id |  | bw88id | Identifikace ikony
ix_SPXMLVAZ_spb1tag2 |  | spb1tag2 | Identifikace navazujícího tagu


SPXSLSKP Skupina XSLT předloh

Popis

Skupina XSLT předloh

Atributy

Atribut | Typ | Návěští | Message | Popis
spb5id | C(6) | Skupina | Skupina XSLT předloh | Skupina XSL
spb5nazskp | C(40) | Náz.skup. XSLT | Název skupiny XSLT předloh | Název skupiny XSLT předloh musí být uveden
spb5koment | M | Poznámka | Poznámka | Poznámka
spb5kod | M | Kód | Kód přípravy předlohy XMLT uzlu | Kód přípravy předlohy XMLT uzlu
spb5web | N(1,0) | Výstup na WEB | Skupina XSLT předloh pro výstupu na WEB | Skupina XSLT předloh pro výstupu na WEB
spb5idcall | C(6) | Vazební skupina | Vazební skupina XSLT předloh pro výstup na WEB | Vazební skupina XSLT předloh pro výstup na WEB
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Skupina XSLT předloh - má definovanou vazební skupinu pro výstup na WEB | SPXSLSKP spb5idcall | 0,1 : 0,M | SPXSLSKP spb5id |
Uzel XSLT předlohy - patří do skupiny XSLT předloh | SPXSLTAG spb5id | 1,1 : 0,M | SPXSLSKP spb5id |
Skupina XSLT předloh - má definovanou vazební skupinu pro výstup na WEB | SPXSLSKP spb5idcall | 0,1 : 0,M | SPXSLSKP spb5id |

Indexy

Název | Primární | Výraz | Popis
ix_SPXSLSKP_spb5id | P | spb5id | Skupina XSL
ix_SPXSLSKP_spb5nazskp |  | spb5nazskp | Název skupiny XSLT předloh musí být uveden
ix_SPXSLSKP_spb5idcall |  | spb5idcall | Vazební skupina XSLT předloh pro výstup na WEB


SPXSLTAG Uzel XSLT předlohy

Popis

Uzel XSLT předlohy

Atributy

Atribut | Typ | Návěští | Message | Popis
spb5id | C(6) | Skupina | Skupina XSLT předloh | Skupina XSL
spb1tag | C(20) | Tag | Identifikace TAG v XML dokumentu | Identifikace TAG v XML dokumentu
spb3naztag | C(40) | Náz. XSLT uzlu | Název uzlu XSLT předloh | Název uzlu XSLT předloh
spb3kod | M | spb3kod | Kód zpracování uzlu XSLT předlohy | Kód zpracování uzlu XSLT předlohy
spb3koment | M | Poznámka | Poznámka | Poznámka
spb3top | N(1,0) | Vrchol | Vrcholový uzel XSLT předlohy | Vrcholový uzel XSLT předlohy
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Uzel XSLT předlohy - je určen pro tag XML | SPXSLTAG spb1tag | 1,1 : 0,M | SPXMLTAG spb1tag |
Uzel XSLT předlohy - patří do skupiny XSLT předloh | SPXSLTAG spb5id | 1,1 : 0,M | SPXSLSKP spb5id |
Vazba mezi tagy XSL definice - definuje 1.uzel XSLT definice | SPXSLVAZ spb5id spb1tag | 1,1 : 0,M s rušením | SPXSLTAG spb5id spb1tag |
Vazba mezi tagy XSL definice - definuje 2.uzel XSLT definice | SPXSLVAZ spb5id2 spb1tag2 | 1,1 : 0,M | SPXSLTAG spb5id spb1tag |

Indexy

Název | Primární | Výraz | Popis
ix_SPXSLTAG_spxsltag | P | spb5id, spb1tag | PI - spb5id+spb1tag
ix_SPXSLTAG_spb5id |  | spb5id | Skupina XSL
ix_SPXSLTAG_spb1tag |  | spb1tag | Identifikace TAG v XML dokumentu
ix_SPXSLTAG_spb3naztag |  | spb3naztag | Název uzlu XSLT předloh


SPXSLVAZ Vazba mezi tagy XSL definice

Popis

Vazba mezi tagy XSL definice pro výstup dokumentu

Atributy

Atribut | Typ | Návěští | Message | Popis
spb1tag2 | C(20) | Tag | Identifikace navazujícího tagu | Identifikace navazujícího tagu
spb1tag | C(20) | Tag | Identifikace TAG v XML dokumentu | Identifikace TAG v XML dokumentu
spb2tagals | C(20) | Alias | Alias tag při použití pod nadřízeným tagem (není-uveden použije se identifikace z vlastní definice tagu) | Alias tag při použití pod nadřízeným tagem (není-uveden použije se identifikace z vlastní definice tagu)
spb5id | C(6) | Skupina | Skupina XSLT předloh | Skupina XSL
spb5id2 | C(6) | Skupina | Skupina XSLT navazujícího uzlu XSLT | Skupina XSLT navazujícího uzlu XSLT
spb4poradi | N(3,0) | Pořadí | Pořadí zpracování navazujícího uzlu XSLT předloh | Pořadí zpracování navazujícího uzlu XSLT předloh
spb4samost | N(1,0) | Samostatný | Vznikne samostatný dokument | Vznikne samostatný dokument
spb4selekt | N(1,0) | Selektivní | Selektivní zpracování | Selektivní zpracování
spb4sort | M | Třídit | Výraz setřídění při zpracování | Výraz setřídění při zpracování
spb4filtr | M | Vybrat | Výraz podmínky zařazení do zpracování | Výraz podmínky zařazení do zpracování
spb4label | M | V.návěští | Výraz vyhodnocení návěští uzlu | Výraz vyhodnocení návěští uzlu
spb4seeals | N(1,0) | Viz.také | V dokumentu vznikne odkaz Viz.také | V dokumentu vznikne odkaz Viz.také

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vazba mezi tagy XSL definice - definuje 1.uzel XSLT definice | SPXSLVAZ spb5id spb1tag | 1,1 : 0,M s rušením | SPXSLTAG spb5id spb1tag |
Vazba mezi tagy XSL definice - definuje 2.uzel XSLT definice | SPXSLVAZ spb5id2 spb1tag2 | 1,1 : 0,M | SPXSLTAG spb5id spb1tag |
Vazba mezi tagy XSL definice - odpovídá vazbě XML defince | SPXSLVAZ spb1tag2 spb1tag spb2tagals | 1,1 : 0,M | SPXMLVAZ spb1tag2 spb1tag spb2tagals |

Indexy

Název | Primární | Výraz | Popis
ix_SPXSLVAZ_spxslvaz | P | spb1tag2, spb1tag, spb2tagals, spb5id, spb5id2 | PI - SPXMLVAZ+spb5id+spb5id2
ix_SPXSLVAZ_spxsltag |  | spb5id, spb1tag | PI - spb5id+spb1tag
ix_SPXSLVAZ_spxsltag2 |  | spb5id2, spb1tag2 | CI - spb5id2+spb1tag2
ix_SPXSLVAZ_spxmlvaz |  | spb1tag2, spb1tag, spb2tagals | PI - spb1tag+spb1tag2
ix_SPXSLVAZ_spb1tag2 |  | spb1tag2 | Identifikace navazujícího tagu
ix_SPXSLVAZ_spb5id2 |  | spb5id2 | Skupina XSLT navazujícího uzlu XSLT


SPZMENY Evidence změn obsahu záznamů komponent a logických věcí

Popis

Evidence změn obsahu záznamů komponent a logických věcí

Atributy

Atribut | Typ | Návěští | Message | Popis
sp46 | C(9) | sp46 | Jednoznačná identifikace záznamu o změně | Jednoznačná identifikace záznamu o změně
sp46vec | C(12) | sp46vec | Identifikace změněného záznamu | Identifikace změněného záznamu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp46datum | T | sp46datum | Datum a čas změny záznamu | Datum a čas změny záznamu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Evidence změn obsahu záznamů komponent a logických věcí - se týká uživatele | SPZMENY bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_SPZMENY_spzmeny | P | sp46, sp46vec, bw01uziv |
ix_SPZMENY_sp46vec |  | sp46vec | Identifikace změněného záznamu
ix_SPZMENY_bw01uziv |  | bw01uziv | Identifikace uživatele systému


Tabulky SZ...

SZAH | Aktuální hodnota skladu zvířat
SZAHUD | Událost - skladba
SZARTIKL | Kategorie zvířat
SZARTTU | Vazba kategorie-typ události
SZARTUM | Vazba kategorie-umístění
SZDOTU | Vazba druh operace-typ události
SZMNP |
SZOBRAT | Obrat skladu zvířat
SZOBRATQ | Pohled pro zjištění posledního data obratu skladu zvířat
SZPAR | Parametry komponenty sklad zvířat
SZPAROPE | Parametry operací - sklad zvířat
SZTYPUD | Typ události skladu zvířat
SZUDAL | Událost skladu zvířat
SZUMIST | Umístění kategorie zvířat
SZZVIR | Jednotlivé zvíře
SZZVIRP | Stav zvířete na skladě v umístění

Viz.také

SZAH Aktuální hodnota skladu zvířat | SZAHUD Událost - skladba | SZARTIKL Kategorie zvířat | SZMNP | SZOBRAT Obrat skladu zvířat | SZPAR Parametry komponenty sklad zvířat | SZPAROPE Parametry operací - sklad zvířat | SZUDAL Událost skladu zvířat | SZUMIST Umístění kategorie zvířat | SZOBRATQ Pohled pro zjištění posledního data obratu skladu zvířat | SZTYPUD Typ události skladu zvířat | SZZVIR Jednotlivé zvíře | SZZVIRP Stav zvířete na skladě v umístění | SZARTTU Vazba kategorie-typ události | SZARTUM Vazba kategorie-umístění | SZDOTU Vazba druh operace-typ události


SZAH Aktuální hodnota skladu zvířat

Popis

Aktuální hodnoty skladu zvířat

Atributy

Atribut | Typ | Návěští | Message | Popis
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sz04id | C(6) | Umístění | Identifikace umístění kategorie zvířat | Identifikace umístění kategorie zvířat
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sz03hodnot | N(20,4) | sz03hodnot | Hodnota | Hodnota

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Aktuální hodnota skladu zvířat - má druh hodnoty | SZAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_SZAH_szah | P | sp06idsubs, ad01id, sp60id, sp61id, sz04id, sp67id |
ix_SZAH_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_SZAH_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_SZAH_ad01id |  | ad01id | Identifikace adresáta
ix_SZAH_sp60id |  | sp60id | Identifikace artiklu
ix_SZAH_sz04id |  | sz04id | Identifikace umístění kategorie zvířat
ix_SZAH_adadsatx |  |  |
ix_SZAH_spartiknx |  |  |


SZAHUD Událost - skladba

Popis

Událost - skladba

Atributy

Atribut | Typ | Návěští | Message | Popis
sz02 | C(12) | sz02 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
sp74id | C(6) | sp74id | Umístění | Umístění
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp00datum | D | Datum | Datum události | Datum události
sp00text | C(40) | Popis | Popis události | Popis události
sp00hodnot | N(20,4) | Hodnota | Aktuální hodnota procesu |
sp69id | C(6) | Druh | Identifikace druhu saldokontní hodnoty procesu | Identifikace druhu saldokontní hodnoty procesu


SZARTIKL Kategorie zvířat

Popis

Artikl skladu zvířat - kategorie zvířat

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp24idmj | C(3) | MJ | Identifikátor měrné jednotky | Identifikátor měrné jednotky
sz01koment | M | Poznámka | Poznámka kategorie | Poznámka kategorie
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
sz01kdx | N(1,0) | KD | Počítat krmné dny | Počítat krmné dny
sp00uselar | C(9) | Účetní selektor artiklu | Účetní selektor artiklu | Účetní selektor artiklu
sz01zpvk | N(1,0) | Zp.vedení | Způsob vedení kategorie | Způsob vedení kategorie

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Kategorie zvířat - je artiklem | SZARTIKL sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Kategorie zvířat - má RMJ | SZARTIKL sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Kategorie zvířat - založil uživatel | SZARTIKL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Kategorie zvířat - má technicko-věcný selektor | SZARTIKL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost skladu zvířat - má kategorii zvířat | SZUDAL sp60id sp61id | 1,1 : 0,M | SZARTIKL sp60id sp61id |
Vazba kategorie-umístění - má kategorii zvířat | SZARTUM sp60id sp61id | 1,1 : 0,M | SZARTIKL sp60id sp61id |
Vazba kategorie-typ události - má kategorii zvířat | SZARTTU sp60id sp61id | 1,1 : 0,M | SZARTIKL sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_SZARTIKL_spartikl | P | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_SZARTIKL_spartiknx |  |  |
ix_SZARTIKL_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SZARTIKL_sp61id |  | sp61id | Identifikace druhu artiklu
ix_SZARTIKL_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky
ix_SZARTIKL_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.


SZARTTU Vazba kategorie-typ události

Popis

Povolená typy událostí pro jednotlivé kategotie při pořizování události

Atributy

Atribut | Typ | Návěští | Message | Popis
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sz16id | C(3) | Typ | Identifikace typu události skladu zvířat | Identifikace typu události skladu zvířat
sz21koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vazba kategorie-typ události - má kategorii zvířat | SZARTTU sp60id sp61id | 1,1 : 0,M | SZARTIKL sp60id sp61id |
Vazba kategorie-typ události - má typ události | SZARTTU sz16id | 1,1 : 0,M | SZTYPUD sz16id |
Událost skladu zvířat - má povolený typ pohybu | SZUDAL sp61id sp60id sz16id | 1,1 : 0,M | SZARTTU sp61id sp60id sz16id |

Indexy

Název | Primární | Výraz | Popis
ix_SZARTTU_sz21 | P | sp61id, sp60id, sz16id | Primární index: Artikl+typ události
ix_SZARTTU_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_SZARTTU_szarttu1 |  | sz16id, sp61id, sp60id | Index podle typu události+artiklu
ix_SZARTTU_sz16id |  | sz16id | Identifikace typu události skladu zvířat


SZARTUM Vazba kategorie-umístění

Popis

Povolená umístění pro jednotlivé kategotie při pořizování události

Atributy

Atribut | Typ | Návěští | Message | Popis
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sz04id | C(6) | Umístění | Identifikace umístění kategorie zvířat | Identifikace umístění kategorie zvířat
sz20koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vazba kategorie-umístění - má kategorii zvířat | SZARTUM sp60id sp61id | 1,1 : 0,M | SZARTIKL sp60id sp61id |
Vazba kategorie-umístění - má umístění | SZARTUM sz04id | 1,1 : 0,M | SZUMIST sz04id |
Událost skladu zvířat - má povolené umístění | SZUDAL sp61id sp60id sz04id | 1,1 : 0,M | SZARTUM sp61id sp60id sz04id |

Indexy

Název | Primární | Výraz | Popis
ix_SZARTUM_sz20 | P | sp61id, sp60id, sz04id | Primární index: Artikl+umístění
ix_SZARTUM_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_SZARTUM_szartum1 |  | sz04id, sp61id, sp60id | Index podle umístěníi+artiklu
ix_SZARTUM_sz04id |  | sz04id | Identifikace umístění kategorie zvířat


SZDOTU Vazba druh operace-typ události

Popis

Povolené typy událostí a atributu P/V pro druh operace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor druhu operace | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sz16id | C(3) | Typ | Identifikace typu události skladu zvířat | Identifikace typu události skladu zvířat
sz02pv | N(1,0) | Příjem / výdej | Příznak příjem / výdej | Příznak příjem / výdej
sz25koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vazba druh operace-typ události - má druh operace | SZDOTU sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Vazba druh operace-typ události - má typ události | SZDOTU sz16id | 1,1 : 0,M | SZTYPUD sz16id |

Indexy

Název | Primární | Výraz | Popis
ix_SZDOTU_szdotu | P | sp07idtyp, sp06idsubs, sz16id, sz02pv | Primární index: Subsystém+Druh operace+typu události+atribut P/V
ix_SZDOTU_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SZDOTU_szdotu1 |  | sp07idtyp, sz16id | Index podle druhu operace a typu události
ix_SZDOTU_szdotu2 |  | sz16id, sp07idtyp | Index podle typu události a druhu operace
ix_SZDOTU_sz16id |  | sz16id | Identifikace typu události skladu zvířat


SZMNP

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sz04id | C(6) | Umístění | Identifikace umístění kategorie zvířat | Identifikace umístění kategorie zvířat
sz10hodn1 | N(20,4) | 1. zobrazovaná hodnota (u kategorie a umístění) | 1. zobrazovaná hodnota (u kategorie a umístění) | 1. zobrazovaná hodnota (u kategorie a umístění)
sz10hodn2 | N(20,4) | 2. zobrazovaná hodnota (u kategorie a umístění) | 2. zobrazovaná hodnota (u kategorie a umístění) | 2. zobrazovaná hodnota (u kategorie a umístění)
sz10hodn3 | N(20,4) | 3. zobrazovaná hodnota (u kategorie a umístění) | 3. zobrazovaná hodnota (u kategorie a umístění) | 3. zobrazovaná hodnota (u kategorie a umístění)

Indexy

Název | Primární | Výraz | Popis
ix_SZMNP_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_SZMNP_sz04id |  | sz04id | Identifikace umístění kategorie zvířat


SZOBRAT Obrat skladu zvířat

Popis

Obrat skladu zvířat

Atributy

Atribut | Typ | Návěští | Message | Popis
sz08datum | D | Datum | Datum obratu | Datum obratu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sz04id | C(6) | Umístění | Identifikace umístění kategorie zvířat | Identifikace umístění kategorie zvířat
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sz08pstav | N(20,4) | Poč.stav | Počáteční stav | Počáteční stav
sz08prijem | N(20,4) | Příjem | Příjem | Příjem
sz08vydej | N(20,4) | Výdej | Výdej | Výdej

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Obrat skladu zvířat - se vztahuje k druhu hodnoty | SZOBRAT sp67id sp06idsubs | 1,1 : 0,M s rušením | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_SZOBRAT_szobrat | P | sz08datum, sp60id, sz04id, sp67id, sp61id, sp06idsubs, ad01id | Primární index druhu sledované informace
ix_SZOBRAT_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_SZOBRAT_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_SZOBRAT_sz04id |  | sz04id | Identifikace umístění kategorie zvířat
ix_SZOBRAT_ad01id |  | ad01id | Identifikace adresáta
ix_SZOBRAT_sz08datum |  | sz08datum | Datum obratu
ix_SZOBRAT_adadsatx |  |  |
ix_SZOBRAT_spartiknx |  |  |
ix_SZOBRAT_szobrat1 |  | sp61id, sp60id, sz04id, ad01id | Index sp61id+sp60id+sz04id+ad01id+sz08datum


SZOBRATQ Pohled pro zjištění posledního data obratu skladu zvířat

Atributy

Atribut | Typ | Návěští | Message | Popis
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sz04id | C(6) | Umístění | Identifikace umístění kategorie zvířat | Identifikace umístění kategorie zvířat
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sz08datum | D | Datum | Datum obratu | Datum obratu


SZPAR Parametry komponenty sklad zvířat

Popis

Parametry komponenty sklad zvířat

Atributy

Atribut | Typ | Návěští | Message | Popis
sz09 | C(12) | sz09 | Primární klíč parametrů komponenty sklad zvířat | Primární klíč parametrů komponenty sklad zvířat
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
sp67id1 | C(3) | 1. zobrazovaná hodnota (u kategorie) | Identifikace druhu hodnoty | Identifikace druhu hodnoty
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp67id2 | C(3) | 2. zobrazovaná hodnota (u kategorie) | Identifikace druhu hodnoty |
sp67id3 | C(3) | 3. zobrazovaná hodnota (u kategorie) | Identifikace druhu hodnoty |
sp67id4 | C(3) | Množství na skladě ve finačním vyjádření - předběžné ocenění | Identifikace druhu hodnoty | Množství na skladě ve finačním vyjádření - předběžné
sp67id5 | C(3) | Množství na skladě ve naturálním vyjádření - předběžné ocenění | Identifikace druhu hodnoty | Množství na skladě ve naturálním vyjádření - předběžné ocenění
sp67id6 | C(3) | Rezervované množství na skladě - předběžné ocenění | Identifikace druhu hodnoty | Rezervované množství na skladě - předběžné ocenění
ob11id | C(3) | Skupina | Identifikace cenové skupiny | Identifikace cenové skupiny
sz09kdpsks | N(1,0) | Započítávat stavy do KD | Zápočet KD se provádí na základě PS nebo KS | Zápočet KD se provádí na základě počátečních stavů nebo konečných stavů

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametry komponenty sklad zvířat - definují druh hodnoty - 1. volitelná zobrazovaná hodnota | SZPAR sp67id1 sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Parametry komponenty sklad zvířat - definují druh hodnoty - 2. volitelná zobrazovaná hodnota | SZPAR sp67id2 sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Parametry komponenty sklad zvířat - definují druh hodnoty - 3. volitelná zobrazovaná hodnota | SZPAR sp67id3 sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Parametry komponenty sklad zvířat - aktualizoval uživatel | SZPAR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Parametry komponenty sklad zvířat - definují druh hodnoty - Množství ve finančním vyjádření (pro výpočet ceny skladové) | SZPAR sp67id4 sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Parametry komponenty sklad zvířat - definují druh hodnoty - Množství v naturálním vyjádření (pro výpočet ceny skladové) | SZPAR sp67id5 sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Parametry komponenty sklad zvířat - definují druh hodnoty - Cenová skupina zápočtu KD | SZPAR ob11id | 1,1 : 0,M | OBCENSKP ob11id |
Parametry komponenty sklad zvířat - definují druh hodnoty - Množství v naturálním vyjádření (pro výpočet KD) | SZPAR sp67id6 sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_SZPAR_sz09 | P | sz09 | Primární klíč parametrů komponenty sklad zvířat
ix_SZPAR_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SZPAR_spstatdi01 |  | sp67id1, sp06idsubs |
ix_SZPAR_spstatdi02 |  | sp67id2, sp06idsubs |
ix_SZPAR_spstatdi03 |  | sp67id3, sp06idsubs |
ix_SZPAR_spstatdi04 |  | sp67id4, sp06idsubs |
ix_SZPAR_spstatdi05 |  | sp67id5, sp06idsubs |
ix_SZPAR_spstatdi06 |  | sp67id6, sp06idsubs |
ix_SZPAR_ob11id |  | ob11id | Identifikace cenové skupiny


SZPAROPE Parametry operací - sklad zvířat

Popis

Parametry druhů operací skladu zvířat

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sz06opkd | N(1,0) | Typ operace | Typ operace | Typ operace - běžná, výpočet KD, Převod - příjem, Převod - výdej

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametry operací - sklad zvířat - je na druhu operace | SZPAROPE sp07idtyp sp06idsubs | 1,1 : 0,M s rušením | SPTYP sp07idtyp sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_SZPAROPE_sptyp | P | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému


SZTYPUD Typ události skladu zvířat

Popis

Typ události skladu zvířat

Atributy

Atribut | Typ | Návěští | Message | Popis
sz16id | C(3) | Typ | Identifikace typu události skladu zvířat | Identifikace typu události skladu zvířat
sz16text | C(40) | Název | Název typu události skladu zvířat | Název typu události skladu zvířat
sp00ucsel | C(9) | Účetní selektor | Účetní selektor | Účetní selektor
sz16koment | M | Poznámka | Poznámka | Poznámka tyouu události skladu zvířat

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost skladu zvířat - má typ události skladu zvířat | SZUDAL sz16id | 1,1 : 0,M | SZTYPUD sz16id |
Vazba kategorie-typ události - má typ události | SZARTTU sz16id | 1,1 : 0,M | SZTYPUD sz16id |
Vazba druh operace-typ události - má typ události | SZDOTU sz16id | 1,1 : 0,M | SZTYPUD sz16id |

Indexy

Název | Primární | Výraz | Popis
ix_SZTYPUD_sz16id | P | sz16id | Identifikace typu události skladu zvířat
ix_SZTYPUD_sz16text |  | sz16text | Název typu události skladu zvířat


SZUDAL Událost skladu zvířat

Popis

Událost o pohybu ve skladu zvířat

Atributy

Atribut | Typ | Návěští | Message | Popis
sz02 | C(12) | sz02 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
sz02datum | D | Datum | Datum pohybu | Datum pohybu
sz02dpor | N(5,0) | Pořadí v rámci datumu pohybu | Pořadí v rámci datumu pohybu | Pořadí v rámci datumu pohybu
sz17id | C(20) | Zvíře | Identifikace zvířete | Identifikace zvířete
sz04id | C(6) | Umístění | Identifikace umístění kategorie zvířat | Identifikace umístění kategorie zvířat
sz16id | C(3) | Typ | Identifikace typu události skladu zvířat | Identifikace typu události skladu zvířat
sz02pv | N(1,0) | Příjem / výdej | Příznak příjem / výdej | Příznak příjem / výdej
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
sp24idmj | C(3) | MJ | Identifikátor měrné jednotky | Identifikátor měrné jednotky
sp24idmj1 | C(3) | sp24idmj1 | Identifikátor měrné jednotky | Identifikátor měrné jednotky
sz02mnmj | N(20,4) | Množství v RMJ | Množství v RMJ | Množství v RMJ
sz02mnmj1 | N(20,4) | Množství v MJ - pomocné | Množství v MJ - pomocné | Množství v MJ - pomocné
sz02cj | N(20,4) | Cena za MJ | Cena za oceňovací měrnou jednotku | Cena za oceňovací měrnou jednotku
sz02cc | N(20,4) | Cena celkem | Cena celkem | Cena celkem
sz02cc1 | N(20,4) | Cena celkem - upravená | Cena celkem - upravená | Cena celkem - upravená (je-li zadána událost předcházející aktuální, je tato aktualizována)
sz02text | C(40) | Popis | Popis události | Popis události
sz02koment | M | Poznámka | Poznámka | Poznámka
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
sz02cnmj | N(1,0) | Vztah | Vztah ceny k MJ: cena za MJ se vztahuje k RMJ, nebo k MJ-pomocné | Vztah ceny k MJ - cena události se vztahuje k RMJ nebo k pomocné MJ
sz02tpcn | N(1,0) | Cena | Typ ceny | Typ ceny - skladová, zadaná
sz02ptrig | N(1,0) | sz02ptrig | Příznak triggeru (0-standard, 1 - trigger pracuje) | Příznak triggeru (0-standard, 1 - trigger pracuje)
sz02datvol | D | Volné datum | Volné datum události | Volné datum události

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost skladu zvířat - má kategorii zvířat | SZUDAL sp60id sp61id | 1,1 : 0,M | SZARTIKL sp60id sp61id |
Událost skladu zvířat - má umístění kategorie zvířat | SZUDAL sz04id | 1,1 : 0,M | SZUMIST sz04id |
Událost skladu zvířat - má spojení na adresáta | SZUDAL ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost skladu zvířat - zapsal uživatel | SZUDAL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost skladu zvířat - patří do fyzické operace | SZUDAL sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost skladu zvířat - má obchodní selektor | SZUDAL sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost skladu zvířat - má organizační selektor | SZUDAL sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost skladu zvířat - má MJ | SZUDAL sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Událost skladu zvířat - má pomocnou MJ | SZUDAL sp24idmj1 | 1,1 : 0,M | SPMJ sp24idmj |
Událost skladu zvířat - má typ události skladu zvířat | SZUDAL sz16id | 1,1 : 0,M | SZTYPUD sz16id |
Událost skladu zvířat - má povolený typ pohybu | SZUDAL sp61id sp60id sz16id | 1,1 : 0,M | SZARTTU sp61id sp60id sz16id |
Událost skladu zvířat - má povolené umístění | SZUDAL sp61id sp60id sz04id | 1,1 : 0,M | SZARTUM sp61id sp60id sz04id |

Indexy

Název | Primární | Výraz | Popis
ix_SZUDAL_sz02 | P | sz02 | Jednoznačná časová identifikace
ix_SZUDAL_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_SZUDAL_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_SZUDAL_spprc |  | sp33cisd, sp33cisdpm, sp33cisdr | Identifikace procesu
ix_SZUDAL_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_SZUDAL_sz02id01 |  | sz02datum, sz02dpor | Datum+pořadí (sz02datum+sz02dpor)
ix_SZUDAL_spartiknx |  |  |
ix_SZUDAL_adadsatx |  |  |
ix_SZUDAL_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_SZUDAL_szudalz |  | sz17id, sp61id, sp60id, sz04id | pro vyhodnoceni stavu zvirete na sklade
ix_SZUDAL_sz20 |  | sp61id, sp60id, sz04id | Primární index: Artikl+umístění
ix_SZUDAL_sz21 |  | sp61id, sp60id, sz16id | Primární index: Artikl+typ události
ix_SZUDAL_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_SZUDAL_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_SZUDAL_ad01id |  | ad01id | Identifikace adresáta
ix_SZUDAL_sp61id |  | sp61id | Identifikace druhu artiklu
ix_SZUDAL_sp60id |  | sp60id | Identifikace artiklu
ix_SZUDAL_sz04id |  | sz04id | Identifikace umístění kategorie zvířat
ix_SZUDAL_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky
ix_SZUDAL_sp24idmj1 |  | sp24idmj1 | Identifikátor měrné jednotky
ix_SZUDAL_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_SZUDAL_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_SZUDAL_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_SZUDAL_sz16id |  | sz16id | Identifikace typu události skladu zvířat
ix_SZUDAL_sz17id |  | sz17id | Identifikace zvířete


SZUMIST Umístění kategorie zvířat

Popis

Umístění kategorie zvířat - sklady zvířat, stáje

Atributy

Atribut | Typ | Návěští | Message | Popis
sz04id | C(6) | Umístění | Identifikace umístění kategorie zvířat | Identifikace umístění kategorie zvířat
sz04text | C(40) | Název | Název umístění kategorie zvířat | Název umístění kategorie zvířat
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sz04koment | M | Poznámka | Poznámka | Poznámka
sp00uselum | C(9) | Účetní selektor umístění | Účetní selektor umístění | Účetní selektor umístění

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Umístění kategorie zvířat - má organizační selektor | SZUMIST sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Umístění kategorie zvířat - má spojení na adresáta | SZUMIST ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost skladu zvířat - má umístění kategorie zvířat | SZUDAL sz04id | 1,1 : 0,M | SZUMIST sz04id |
Vazba kategorie-umístění - má umístění | SZARTUM sz04id | 1,1 : 0,M | SZUMIST sz04id |

Indexy

Název | Primární | Výraz | Popis
ix_SZUMIST_sz04id | P | sz04id | Identifikace umístění kategorie zvířat
ix_SZUMIST_sz04text |  | sz04text | Název umístění kategorie zvířat
ix_SZUMIST_ad01id |  | ad01id | Identifikace adresáta
ix_SZUMIST_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_SZUMIST_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.


SZZVIR Jednotlivé zvíře

Popis

Jednotlivá zvířata - seznam identifikací

Atributy

Atribut | Typ | Návěští | Message | Popis
sz17id | C(20) | Zvíře | Identifikace zvířete | Identifikace zvířete
sz17text | C(40) | Popis | Popis zvířete | Popis zvířete
sz17koment | M | Poznámka | Poznámka | Poznámka
sz17datvol | D | Volné datum | Volné datum | Volné datum

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost skladu zvířat - může mít identifikaci zvířete | SZUDAL sz17id | 0,1 : 1,M | SZZVIR sz17id |

Indexy

Název | Primární | Výraz | Popis
ix_SZZVIR_sz17id | P | sz17id | Identifikace zvířete


SZZVIRP Stav zvířete na skladě v umístění

Popis

Stav zvířete na skladě

Atributy

Atribut | Typ | Návěští | Message | Popis
sz17id | C(20) | Zvíře | Identifikace zvířete | Identifikace zvířete
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sz04id | C(6) | Umístění | Identifikace umístění kategorie zvířat | Identifikace umístění kategorie zvířat
sz18mn | N(20,4) | Množství | Množství zvířat na skladě v umístění | Množství zvířat na skladě v umístění se stejnou identifikací zvířete
sz02datum | D | Datum | Datum pohybu | Datum pohybu

Indexy

Název | Primární | Výraz | Popis
ix_SZZVIRP_sz17id |  | sz17id | Identifikace zvířete


Tabulky TP...

TPKALK | Kalkulační vzorec / proměnná kalkulačního vzorce
TPKALKVR | Výraz kalkulačního vzorce
TPKUSOV | Položka kusovníku TPV
TPLINKA | Výrobní linka / stroj / skladové úložiště výroby
TPLINKAD | Druh výrobní linky/stroje
TPLINKAP | Pracovník obsluhy výrobní linky/stroje ve směně s profesí
TPLINKAV | Stroj ve výrobní lince
TPMJNED | Řád zaokrouhlování měrné jednotky vyráběného artiklu
TPOPERAC | Technologická operace
TPPARAM | Parametry výroby
TPPROFOP | Pracovní výkon
TPPROFTB | Tabulka pracovních výkonů výroby
TPSABPRC | Šablona procesu technologického postupu
TPSKLADU | Skladové úložiště TPV
TPTAB | Tabulka vztahů artiklů výroby
TPTABP | Položka tabulky vztahů artiklu artiklů výroby
TPTECHAX | Artikl výroby v technologickém postupu
TPTECHPO | Technologický postup
TPTECOPR | Technologický krok v technologickém postupu
TPTECUZ | Uzel v diagramu technologického postupu
TPTECUZV | Vazba uzlů v diagramu technologického postupu
TPTECVV | Technologický postup k datu rozpracovaný na KJ pilotního artiklu
TPTECVVO | Technologický postup připravený pro rozpracování k datu
TPTECVVP | Vstup/výstup technologického postupu k datu na kalkulační jednici
TPTRASY | Výrobní trasa
TPVYROB | Artikl výroby
TPVYROBT | Třída výrobního artiklu

Viz.také

TPKALK Kalkulační vzorec / proměnná kalkulačního vzorce | TPKALKVR Výraz kalkulačního vzorce | TPKUSOV Položka kusovníku TPV | TPLINKA Výrobní linka / stroj / skladové úložiště výroby | TPLINKAD Druh výrobní linky/stroje | TPLINKAP Pracovník obsluhy výrobní linky/stroje ve směně s profesí | TPLINKAV Stroj ve výrobní lince | TPMJNED Řád zaokrouhlování měrné jednotky vyráběného artiklu | TPOPERAC Technologická operace | TPPARAM Parametry výroby | TPPROFOP Pracovní výkon | TPPROFTB Tabulka pracovních výkonů výroby | TPSABPRC Šablona procesu technologického postupu | TPSKLADU Skladové úložiště TPV | TPTAB Tabulka vztahů artiklů výroby | TPTABP Položka tabulky vztahů artiklu artiklů výroby | TPTECHAX Artikl výroby v technologickém postupu | TPTECHPO Technologický postup | TPTECOPR Technologický krok v technologickém postupu | TPTECUZ Uzel v diagramu technologického postupu | TPTECUZV Vazba uzlů v diagramu technologického postupu | TPTECVV Technologický postup k datu rozpracovaný na KJ pilotního artiklu | TPTECVVO Technologický postup připravený pro rozpracování k datu | TPTECVVP Vstup/výstup technologického postupu k datu na kalkulační jednici | TPTRASY Výrobní trasa | TPVYROB Artikl výroby | TPVYROBT Třída výrobního artiklu


TPKALK Kalkulační vzorec / proměnná kalkulačního vzorce

Popis

Kalkulační vzorec / proměnná kalkulačního vzorce

Atributy

Atribut | Typ | Návěští | Message | Popis
tp27id | C(3) | KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
tp27nazrol | C(40) | Název KV | Název kalkulačního vzorce / název proměnné kalkulačního vzorce | Název kalkulačního vzorce / název proměnné kalkulačního vzorce
tp27koment | M | Poznámka | Poznámka | Poznámka
tp27typ | N(1,0) | Typ | Typ - kalkulační vzorec / proměnná v kalkulačním vzorci | Kalkulační vzorec / proměnná v kalkulačním vzorci
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Kalkulační vzorec / proměnná kalkulačního vzorce - byla založena uživatelem | TPKALK bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Výraz kalkulačního vzorce - patří ke kalkulačnímu vzorci | TPKALKVR tp27id | 1,1 : 0,M | TPKALK tp27id |
Vstup/výstup technologického postupu k datu na kalkulační jednici - je proměnnou KV / jeho hodnota byly spočtena KV | TPTECVVP tp27id | 1,1 : 0,M | TPKALK tp27id |
Položka kusovníku TPV - představuje kalkulační vzorec / proměnnou kalkulačního vzorce | TPKUSOV tp27id | 1,1 : 0,M | TPKALK tp27id |
Pracovní výkon - je proměnnou v kalkulačním vzorci | TPPROFOP tp27id | 1,1 : 0,M | TPKALK tp27id |
Parametry výroby - určují předplňovaný KV pro vstupy v kusovníku | TPPARAM tp27id2 | 1,1 : 0,M | TPKALK tp27id |
Parametry výroby - určují předplňovaný KV pro pracovní výkon v kusovníku | TPPARAM tp27id3 | 1,1 : 0,M | TPKALK tp27id |
Vstup nebo výstup výrobního úkolu - má výpočet podle kalkulačního vzorce nebo je proměnnou kalkulačního vzorce | VRUDOPMA tp27id | 1,1 : 0,M | TPKALK tp27id |

Indexy

Název | Primární | Výraz | Popis
ix_TPKALK_tp27id | P | tp27id | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
ix_TPKALK_tp27nazrol |  | tp27nazrol | Název kalkulačního vzorce / název proměnné kalkulačního vzorce
ix_TPKALK_bw01uziv |  | bw01uziv | Identifikace uživatele systému


TPKALKVR Výraz kalkulačního vzorce

Popis

Výraz kalkulačního vzorce

Atributy

Atribut | Typ | Návěští | Message | Popis
tp27id | C(3) | KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
tp28datod | D | Platnost od | Datum platnosti výrazu kalkulačního vzorce od | Datum platnosti výrazu kalkulačního vzorce od
tp28datdo | D | do | Datum platnosti výrazu kalkulačního vzorce do | Datum platnosti výrazu kalkulačního vzorce do
tp28vyraz | M | Výraz | Výraz kalkulačního vzorce | Výraz kalkulačního vzorce
tp28koment | M | Poznámka | Poznámka | Poznámka
tp13id | C(6) | Číslo linky | Číslo výrobní linky, resp. stroje | Číslo výrobní linky, resp. stroje

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Výraz kalkulačního vzorce - patří ke kalkulačnímu vzorci | TPKALKVR tp27id | 1,1 : 0,M | TPKALK tp27id |
Výraz kalkulačního vzorce - platí pro výrobní linku | TPKALKVR tp13id | 1,1 : 0,M | TPLINKA tp13id |

Indexy

Název | Primární | Výraz | Popis
ix_TPKALKVR_tpkalkvr | P | tp27id, tp28datod | PI - tp27id+tp28datod
ix_TPKALKVR_tp27id |  | tp27id | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
ix_TPKALKVR_tp13id |  | tp13id | Číslo výrobní linky, resp. stroje


TPKUSOV Položka kusovníku TPV

Popis

Objektem typu TPKUSOV je každý záznam, který obsahuje materiál, použitý při výrobě daného výrobku, nebo polotovaru.

Atributy

Atribut | Typ | Návěští | Message | Popis
tp05id | C(13) | Operace | Identifikace technologické operace | Identifikace technologického kroku
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
tp02varian | C(6) | Varianta | Varianta technologické operace | Varianta technologické operace
tp12id | C(6) | Druh linky | Identifikace druhu výrobní linky | Identifikace druhu výrobní linky
tp02smer | N(1,0) | Směr | Vstup (materiál) nebo výstup (meziprodukt, odpad). | Vstup (materiál) nebo výstup (meziprodukt, odpad).
sp24idmj | C(3) | MJ | Identifikátor měrné jednotky | Identifikátor měrné jednotky
tp17id | C(6) | Úložiště | Identifikace skladového úložiště | Identifikace skladového úložiště
tp02pilot | N(1,0) | Pilotní artikl | Pilotní artikl | Pilotní artikl
tp02vazena | N(1,0) | Měřená položka | Měřená položka - tj. bude u ní možné při výrobě zjistit její množství na vstupu/výstupu, neměřenou bude možné rozpočítat | Vážená položka - tj. při převodu stavu zakázky na realizovaná se nebude provadet její dopočet je-li nenulová
tp02minmn | N(20,4) | Minimální množství | Minimální množství artiklu na vstupu pří proudové výrobě (nula = neurčeno) | Minimální množství artiklu na vstupu pří proudové výrobě
tp27id | C(3) | KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
tp02vyknor | N(10,3) | Výkon. norma | Počet kalkulačních jednic, vyrobených za jednotku času uvedenou v parametrech. | Počet kalkulačních jednic, vyrobených za jednotku času uvedenou v parametrech
tp02pocop | N(3,0) | Počet opakování | Počet opakování kroku. | Počet opakování kroku.
tp02normh | N(10,3) | Normohodin | Normohodin | Normohodin
tp02normhp | N(9,3) | Plus | Připočítávaný konstantní čas délky kroku v minutách | Připočítávaný kontantní čas délky kroku v minutách
tp30id | C(13) | Tabulka | Identifikátor tabulky pracovních výkonů | Identifikátor tabulky pracovních výkonů
tp02 | C(12) | tp02 | Jednoznačná časová identifikace položky kusovníku | Jednoznačná časová identifikace položky kusovníku
tp13id | C(6) | Číslo linky | Číslo výrobní linky, resp. stroje | Číslo výrobní linky, resp. stroje
tp02popis | C(60) | Popis | Popis k referenčnímu artiklu | Popis k referenčnímu artiklu
tp02koment | M | Poznámka | Poznámka k referenčnímu artiklu | Poznámka k referenčnímu artiklu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Položka kusovníku TPV - zahrnuje artikl výroby | TPKUSOV sp60id sp61id | 1,1 : 0,M | TPVYROB sp60id sp61id |
Položka kusovníku TPV - je veden v měrné jednotce | TPKUSOV sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Položka kusovníku TPV - obsahuje druh artiklu | TPKUSOV sp61id | 1,1 : 0,M | SPARTIKD sp61id |
Položka kusovníku TPV - definuje převod ze skladového úložiště TPV | TPKUSOV tp17id | 1,1 : 0,M | TPLINKA tp13id |
Položka kusovníku TPV - představuje kalkulační vzorec / proměnnou kalkulačního vzorce | TPKUSOV tp27id | 1,1 : 0,M | TPKALK tp27id |
Položka kusovníku TPV - referenční položka používá tabulku pravovních výkonů | TPKUSOV tp30id | 0,1 : 0,M | TPPROFTB tp30id |
Položka kusovníku TPV - je určena pro druh stroje | TPKUSOV tp12id | 1,1 : 0,M | TPLINKAD tp12id |
Položka kusovníku TPV - pilotní referenční artikl používá explicitně linku při vytváření úkolů výroby | TPKUSOV tp13id | 1,1 : 0,M | TPLINKA tp13id |
Položka kusovníku TPV - zahrnuje materiál technologické operace | TPKUSOV tp05id | 1,1 : 0,M s rušením | TPOPERAC tp05id |

Indexy

Název | Primární | Výraz | Popis
ix_TPKUSOV_tpkusov | P | tp05id, sp60id, sp61id, tp02varian, tp12id | PI - tp05id + SPARTIKL + tp02varian + tp12id
ix_TPKUSOV_tp05id |  | tp05id | Identifikace technologického kroku
ix_TPKUSOV_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_TPKUSOV_sp61id |  | sp61id | Identifikace druhu artiklu
ix_TPKUSOV_tp12id |  | tp12id | Identifikace druhu výrobní linky
ix_TPKUSOV_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky
ix_TPKUSOV_tp17id |  | tp17id | Identifikace skladového úložiště
ix_TPKUSOV_tp27id |  | tp27id | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
ix_TPKUSOV_spartiknx |  |  |
ix_TPKUSOV_tp30id |  | tp30id | Identifikátor tabulky pracovních výkonů
ix_TPKUSOV_tp02 |  | tp02 | Jednoznačná časová identifikace položky kusovníku
ix_TPKUSOV_tp13id |  | tp13id | Číslo výrobní linky, resp. stroje


TPLINKA Výrobní linka / stroj / skladové úložiště výroby

Popis

Výrobní linka / stroj / skladové úložiště výroby

Atributy

Atribut | Typ | Návěští | Message | Popis
tp13id | C(6) | Číslo linky | Číslo výrobní linky, resp. stroje | Číslo výrobní linky, resp. stroje
tp12id | C(6) | Druh linky | Identifikace druhu výrobní linky | Identifikace druhu výrobní linky
tp13linka | C(40) | Název linky | Název výrobní linky | Název výrobní linky
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
tp13koment | M | Komentář | Komentář, podrobně popisující výrobní linku, resp. stroj | Komentář, podrobně popisující výrobní linku, resp. stroj
mt04id | C(6) | Sklad | Identifikace umístění skladové evidence | Identifikace umístění skladové evidence
tp13strlin | N(1,0) | Stroj/Linka | Stroj nebo výrobní linka | Stroj nebo výrobní linka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Výrobní linka / stroj / skladové úložiště výroby - je určitého druhu | TPLINKA tp12id | 1,1 : 0,M s rušením | TPLINKAD tp12id |
Výrobní linka / stroj / skladové úložiště výroby - má organizační selektor | TPLINKA sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Výrobní linka / stroj / skladové úložiště výroby - má technicko-věcný selektor | TPLINKA sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Výrobní linka / stroj / skladové úložiště výroby - odpovídá skladu | TPLINKA mt04id | 0,1 : 0,M | MTSKL mt04id |
Výrobní trasa - má zdrojové úložiště | TPTRASY tp17id | 1,1 : 0,M | TPLINKA tp13id |
Výrobní trasa - má cílové úložiště | TPTRASY tp17id2 | 1,1 : 0,M | TPLINKA tp13id |
Výraz kalkulačního vzorce - platí pro výrobní linku | TPKALKVR tp13id | 1,1 : 0,M | TPLINKA tp13id |
Stroj ve výrobní lince - určuje určuje výrobní linku do které je zařazený stroj | TPLINKAV tp13idlin | 1,1 : 0,M s rušením | TPLINKA tp13id |
Stroj ve výrobní lince - určuje stroj zařazený do výrobní linky | TPLINKAV tp13id | 1,1 : 0,M s rušením | TPLINKA tp13id |
Pracovník obsluhy výrobní linky/stroje ve směně s profesí - určuje výrobní linku/stroj | TPLINKAP tp13id | 1,1 : 0,M s rušením | TPLINKA tp13id |
Přidělení kalendáře lince - určuje linku přidělenou kalendáři | VRKALPLI tp13id | 1,1 : 0,M s rušením | TPLINKA tp13id |
Artikl výroby - je ukládán ve skladovém úložišti TPV | TPVYROB tp17id | 1,1 : 0,M | TPLINKA tp13id |
Položka kusovníku TPV - definuje převod ze skladového úložiště TPV | TPKUSOV tp17id | 1,1 : 0,M | TPLINKA tp13id |
Položka kusovníku TPV - pilotní referenční artikl používá explicitně linku při vytváření úkolů výroby | TPKUSOV tp13id | 1,1 : 0,M | TPLINKA tp13id |
Událost úkolu ve výrobě - se týká linky | VRUDOPER tp13id | 1,1 : 0,M | TPLINKA tp13id |
Druh výrobní linky/stroje - má implicitní linku | TPLINKAD tp13id | 0,1 : 0,M | TPLINKA tp13id |
Vstup nebo výstup výrobního úkolu - je ukládán na skladové úložiště TPV | VRUDOPMA tp17id | 1,1 : 0,M | TPLINKA tp13id |
Vstup nebo výstup výrobního úkolu - je prováděn na stroji | VRUDOPMA tp13id | 1,1 : 0,M | TPLINKA tp13id |

Indexy

Název | Primární | Výraz | Popis
ix_TPLINKA_tp13id | P | tp13id | Číslo výrobní linky, resp. stroje
ix_TPLINKA_tp12id |  | tp12id | Identifikace druhu výrobní linky
ix_TPLINKA_tp13linka |  | tp13linka | Název výrobní linky
ix_TPLINKA_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_TPLINKA_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_TPLINKA_mt04id |  | mt04id | Identifikace umístění skladové evidence


TPLINKAD Druh výrobní linky/stroje

Popis

Objektem typu TPLINKAD je každý záznam obsahující údaje o druhu výrobní linky, resp. stroji.

Atributy

Atribut | Typ | Návěští | Message | Popis
tp12id | C(6) | Druh linky | Identifikace druhu výrobní linky | Identifikace druhu výrobní linky
tp12linka | C(40) | Název linky | Název druhu výrobní linky | Název druhu výrobní linky
tp13id | C(6) | Číslo linky | Číslo výrobní linky, resp. stroje | Číslo výrobní linky, resp. stroje
tp12koment | M | Komentář | Komentář, podrobně popisující druh výrobní linky, resp. stroje | Komentář, podrobně popisující druh výrobní linky, resp. stroje

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh výrobní linky/stroje - má implicitní linku | TPLINKAD tp13id | 0,1 : 0,M | TPLINKA tp13id |
Vstup/výstup technologického postupu k datu na kalkulační jednici - určuje vstup/výstup na druhu stroje | TPTECVVP tp12id | 1,1 : 0,M | TPLINKAD tp12id |
Položka kusovníku TPV - je určena pro druh stroje | TPKUSOV tp12id | 1,1 : 0,M | TPLINKAD tp12id |
Technologická operace - prováděný na výrobní lince určitého druhu | TPOPERAC tp12id | 1,1 : 0,M | TPLINKAD tp12id |
Pracovní výkon - je na druhu stroje | TPPROFOP tp12id | 1,1 : 0,M | TPLINKAD tp12id |
Výrobní linka / stroj / skladové úložiště výroby - je určitého druhu | TPLINKA tp12id | 1,1 : 0,M s rušením | TPLINKAD tp12id |
Položka tabulky vztahů artiklu artiklů výroby - se týká druhu stroje | TPTABP tp12id | 1,1 : 0,M | TPLINKAD tp12id |

Indexy

Název | Primární | Výraz | Popis
ix_TPLINKAD_tp12id | P | tp12id | Identifikace druhu výrobní linky
ix_TPLINKAD_tp12linka |  | tp12linka | Název druhu výrobní linky
ix_TPLINKAD_tp13id |  | tp13id | Číslo výrobní linky, resp. stroje


TPLINKAP Pracovník obsluhy výrobní linky/stroje ve směně s profesí

Popis

Pracovník obsluhy výrobní linky ve směně

Atributy

Atribut | Typ | Návěští | Message | Popis
tp39 | C(12) | tp39 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
tp13id | C(6) | Číslo linky | Číslo výrobní linky, resp. stroje | Číslo výrobní linky, resp. stroje
tp23smena | N(1,0) | Číslo směny | Číslo směny | Číslo směny
mz31id | C(6) | Identifikace | Identifikace pracovní funkce (zařazení) | Identifikace pracovní funkce (zařazení)
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
tp23datum | D | Datum | Datum v kalendáři využití linky | Datum v kalendáři využití linky
tp23datum2 | D | do | Datum v kalendáři využití linky do | Datum v kalendáři využití linky do

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Pracovník obsluhy výrobní linky/stroje ve směně s profesí - určuje výrobní linku/stroj | TPLINKAP tp13id | 1,1 : 0,M s rušením | TPLINKA tp13id |
Pracovník obsluhy výrobní linky/stroje ve směně s profesí - určuje pracovníka | TPLINKAP mz01id | 1,1 : 0,M s rušením | MZKARTA mz01id |
Pracovník obsluhy výrobní linky/stroje ve směně s profesí - určuje pracovní funkci | TPLINKAP mz31id | 1,1 : 0,M s rušením | MZPRACFU mz31id |

Indexy

Název | Primární | Výraz | Popis
ix_TPLINKAP_tp39 | P | tp39 | Jednoznačná časová identifikace
ix_TPLINKAP_tp13id |  | tp13id | Číslo výrobní linky, resp. stroje
ix_TPLINKAP_mz31id |  | mz31id | Identifikace pracovní funkce (zařazení)
ix_TPLINKAP_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.


TPLINKAV Stroj ve výrobní lince

Popis

Stroj ve výrobní lince

Atributy

Atribut | Typ | Návěští | Message | Popis
tp13id | C(6) | Číslo linky | Číslo výrobní linky, resp. stroje | Číslo výrobní linky, resp. stroje
tp38datum | D | Ode dne | Datum zařazení ve výrobní lince | Datum zařazení ve výrobní lince
tp13idlin | C(6) | Linka | Identifikace výrobní linky | Identifikace výrobní linky
tp38datumd | D | do | Datum vyřazení z výrobní linky | Datum vyřazení z výrobní linky
tp38posled | N(1,0) | Poslední | Poslední stroj linky | Poslední stroj linky

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Stroj ve výrobní lince - určuje určuje výrobní linku do které je zařazený stroj | TPLINKAV tp13idlin | 1,1 : 0,M s rušením | TPLINKA tp13id |
Stroj ve výrobní lince - určuje stroj zařazený do výrobní linky | TPLINKAV tp13id | 1,1 : 0,M s rušením | TPLINKA tp13id |

Indexy

Název | Primární | Výraz | Popis
ix_TPLINKAV_tplinkav | P | tp13id, tp38datum | PI - tp13id+tp38datum
ix_TPLINKAV_tp13idlin |  | tp13idlin | Identifikace výrobní linky
ix_TPLINKAV_tp13id |  | tp13id | Číslo výrobní linky, resp. stroje


TPMJNED Řád zaokrouhlování měrné jednotky vyráběného artiklu

Popis

Objektem typu TPMJNED je každý záznam, který obsahuje řád zaokrouhlování měrné jednotky vyráběného artiklu, např. kus.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp24idmj | C(3) | MJ | Identifikátor měrné jednotky | Identifikátor měrné jednotky
tp18rad | N(1,0) | Řád | Zaokrouhlení na řád | Zaokrouhlení na řád

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Řád zaokrouhlování měrné jednotky vyráběného artiklu - je měrnou jednotkou | TPMJNED sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Řád zaokrouhlování měrné jednotky vyráběného artiklu - je měrnou jednotkou artiklu výroby | TPMJNED sp60id sp61id | 1,1 : 0,M s rušením | TPVYROB sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_TPMJNED_tpmjned | P | sp60id, sp61id, sp24idmj | SPARTIKL + sp24idmj
ix_TPMJNED_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_TPMJNED_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky


TPOPERAC Technologická operace

Popis

Objektem typu TPOPERAC je každý záznam, který obsahuje identifikační údaje výrobních operací prováděných při výrobě výrobků a polotovarů.

Atributy

Atribut | Typ | Návěští | Message | Popis
tp05id | C(13) | Operace | Identifikace technologické operace | Identifikace technologického kroku
tp14id | C(13) | Tabulka | Identifikace tabulky artiklu výroby | Identifikace tabulky artiklu výroby
tp05operac | C(40) | Název operace | Stručný popis, charakterizující technologickou operaci | Stručný popis, charakterizující technologický krok.
tp12id | C(6) | Druh linky | Identifikace druhu výrobní linky | Identifikace druhu výrobní linky
tp05koment | M | Poznámka | Komentář, podrobně popisující technologickou operaci. | Komentář, podrobně popisující technologickou operaci.
sp07idtyp2 | C(6) | sp07idtyp2 | Identifikace druhu operace - druhý uzel | Identifikace druhu operace - druhý uzel
sp06idsub2 | C(3) | Komponenta | Identifikace komponenty - přijemce transformovaných dat | Identifikace komponenty - přijemce transformovaných dat
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
bw95id | C(6) | Barva | Identifikace barvy RGB | Identifikace barvy RGB

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Technologická operace - prováděný na výrobní lince určitého druhu | TPOPERAC tp12id | 1,1 : 0,M | TPLINKAD tp12id |
Technologická operace - pracuje s tabulkou | TPOPERAC tp14id | 1,1 : 0,M | TPTAB tp14id |
Technologická operace - má technicko-věcný selektor | TPOPERAC sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Technologická operace - vytváří operaci komponenty vstupů a výstupů IC | TPOPERAC sp07idtyp2 sp06idsub2 | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Technologická operace - používá v harmonogramu zobrazení barvou | TPOPERAC bw95id | 1,1 : 0,M | BWRGBCOL bw95id |
Technologický krok v technologickém postupu - propojuje technologický krok | TPTECOPR tp05id | 1,1 : 0,M | TPOPERAC tp05id |
Vstup/výstup technologického postupu k datu na kalkulační jednici - je vstupem/výstupem technologické operace | TPTECVVP tp05id | 1,1 : 0,M | TPOPERAC tp05id |
Uzel v diagramu technologického postupu - je uzlem typu operace | TPTECUZ tp05id | 0,1 : 0,M | TPOPERAC tp05id |
Položka kusovníku TPV - zahrnuje materiál technologické operace | TPKUSOV tp05id | 1,1 : 0,M s rušením | TPOPERAC tp05id |
Technologický postup - má pilotní technologickou operaci | TPTECHPO tp05idpilo | 0,1 : 0,M | TPOPERAC tp05id |
Událost úkolu ve výrobě - zahrnuje výrobní operaci | VRUDOPER tp05id | 1,1 : 0,M | TPOPERAC tp05id |

Indexy

Název | Primární | Výraz | Popis
ix_TPOPERAC_tp05id | P | tp05id | Identifikace technologického kroku
ix_TPOPERAC_tp14id |  | tp14id | Identifikace tabulky artiklu výroby
ix_TPOPERAC_tp05operac |  | tp05operac | Stručný popis, charakterizující technologický krok.
ix_TPOPERAC_tp12id |  | tp12id | Identifikace druhu výrobní linky
ix_TPOPERAC_sptyp2 |  | sp07idtyp2, sp06idsub2 |
ix_TPOPERAC_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_TPOPERAC_bw95id |  | bw95id | Identifikace barvy RGB


TPPARAM Parametry výroby

Popis

Objektem typu TPPARAM jsou parametry pro výpočty v komponentě TPV

Atributy

Atribut | Typ | Návěští | Message | Popis
tp07id | C(12) | tp07id |  |
ob11id | C(3) | Skupina | Identifikace cenové skupiny | Identifikace cenové skupiny
tp07hodvn | N(5,2) | Hodin výk. normy | Počet hodin, za které se uvádí výkonová norma | Počet hodin, za které se uvádí výkonová norma
tp07celkn | N(1,0) | Pracovní náklady zahrnují | Rozlišení, zda celkové náklady zahrnují mzdové či osobní náklady | Rozlišení, zda celkovové náklady zahrnují mzdové či osobní náklady.
tp15mnoz | N(14,6) | Vyrobit | Množství artiklu, které se má vyrobit | Množství artiklu, které se má vyrobit
tp25id | C(6) | Šablona | Identifikace šablony procesu technologického postupu | Identifikace šablony procesu technologického postupu
tp27id | C(3) | KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
tp27id2 | C(3) | Předplňovat KV pro vztaž.artikl | Identifikace proměnné kalkulačního vzorce předplňovaná v kusovníku | Identifikace proměnné kalkulačního vzorce předplňovaná pro vstupy v kusovníku
tp27id3 | C(3) | Předplňovat KV pro pracovní výkon | Identifikace proměnné kalkulačního vzorce předplňovaná pro pracovní výkony v kusovníku | Identifikace proměnné kalkulačního vzorce předplňovaná pro pracovní výkony
tp07smer | N(1,0) | Směrování referenčního artiklu | Předplňované směrování referenčního artiklu | Předplňované směrování referenčního artiklu
tp07skup | N(1,0) | Využívat varianty operací | Možná existence referenčních artiklů se stejnou tech.operací | Možná existence referenčních artiklů se stejnou tech.operací
sp07idtyp2 | C(6) | Vstupy a výstupy | Identifikátor druhu operace | Identifikace druhu operace - druhý uzel
tp07vytlin | N(1,0) | Vytěžovat linky | Při výpočtu výroby respektovat obsazení času linky jinými zakázkami | Při výpočtu výroby respektovat obsazení času linky jinými zakázkami
vr20minsm | N(5,2) | Min. ve směně | Minimální čas v rozdělené směně | Minimální čas v rozdělené směně
tp07predva | N(1,0) | Předplňovat číslo varianty | Předplňovat číslo varianty při vstupu referenčního artiklu | Předplňovat číslo varianty při vstupu referenčního artiklu
tp07kopope | N(1,0) | Kopírovat vždy vztažené artikly | Při kopírování operace referenčního artiklu kopírovat vždy všechny vztažené artikly varianty | Při kopírování operace referenčního artiklu kopírovat vždy všechny vztažené artikly varianty

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametry výroby - definují identifikaci šablony pro jednokrokový TP | TPPARAM tp25id | 1,1 : 0,M | TPSABPRC tp25id |
Parametry výroby - určují předplňovaný KV pro vstupy v kusovníku | TPPARAM tp27id2 | 1,1 : 0,M | TPKALK tp27id |
Parametry výroby - určují předplňovaný KV pro pracovní výkon v kusovníku | TPPARAM tp27id3 | 1,1 : 0,M | TPKALK tp27id |

Indexy

Název | Primární | Výraz | Popis
ix_TPPARAM_tp07id | P | tp07id |
ix_TPPARAM_ob11id |  | ob11id | Identifikace cenové skupiny
ix_TPPARAM_tp25id |  | tp25id | Identifikace šablony procesu technologického postupu
ix_TPPARAM_tp27id |  | tp27id | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
ix_TPPARAM_tp27id2 |  | tp27id2 | Identifikace proměnné kalkulačního vzorce předplňovaná pro vstupy v kusovníku
ix_TPPARAM_tp27id3 |  | tp27id3 | Identifikace proměnné kalkulačního vzorce předplňovaná pro pracovní výkony


TPPROFOP Pracovní výkon

Popis

Objektem typu TPPROFOP je každý záznam, který obsahuje pracovní profese, podílející se na technologické operaci s uvedením rozsahu jejich práce na operaci.

Atributy

Atribut | Typ | Návěští | Message | Popis
tp30id | C(13) | Tabulka | Identifikátor tabulky pracovních výkonů | Identifikátor tabulky pracovních výkonů
mz31id | C(6) | Identifikace | Identifikace pracovní funkce (zařazení) | Identifikace pracovní funkce (zařazení)
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
tp12id | C(6) | Druh linky | Identifikace druhu výrobní linky | Identifikace druhu výrobní linky
tp02varian | C(6) | Varianta | Varianta technologické operace | Varianta technologické operace
tp06pocet | N(3,0) | Počet | Počet pracovníků provádějících krok | Počet pracovníků provádějících krok
tp06casop | N(1,0) | Čas na oper. | Čas potřebný k provedení jednoho kroku | Čas potřebný k provedení jednoho kroku
tp06konstc | N(8,2) | Konstantní | Konstantní čas na provedení kroku (např. seřízení) | Konstantní čas na provedení kroku (např. seřízení)
tp06procca | N(6,2) | Proc. čas oper. | Výkon práce jako procento času trvání kroku | Výkon práce jako procento času trvání kroku
tp06procpr | N(6,2) | Proc. prémií | Procento prémií | Procento prémií
tp27id | C(3) | KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
tp06porad | N(4,0) | Pořadí | Pořadí zobrazení pracovního výkonu v mřížce | Pořadí zobrazení pracovního výkonu v mřížce
tp06pomcis | N(10,2) | Pomocné číslo | Pomocné číslo | Pomocné číslo

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Pracovní výkon - je ve mzdách | TPPROFOP mz31id | 1,1 : 0,M | MZPRACFU mz31id |
Pracovní výkon - vztažený k artiklu výroby | TPPROFOP sp60id sp61id | 1,1 : 0,M | TPVYROB sp60id sp61id |
Pracovní výkon - je proměnnou v kalkulačním vzorci | TPPROFOP tp27id | 1,1 : 0,M | TPKALK tp27id |
Pracovní výkon - je na druhu stroje | TPPROFOP tp12id | 1,1 : 0,M | TPLINKAD tp12id |
Pracovní výkon - na prováděné technologické operace | TPPROFOP tp30id | 1,1 : 0,M | TPPROFTB tp30id |

Indexy

Název | Primární | Výraz | Popis
ix_TPPROFOP_tpprofop | P | tp30id, mz31id, sp60id, sp61id, tp12id, tp02varian | PI - tp30id + mz31id+sp60id+sp61id+tp12id
ix_TPPROFOP_tp30id |  | tp30id | Identifikátor tabulky pracovních výkonů
ix_TPPROFOP_mz31id |  | mz31id | Identifikace pracovní funkce (zařazení)
ix_TPPROFOP_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_TPPROFOP_sp61id |  | sp61id | Identifikace druhu artiklu
ix_TPPROFOP_tp27id |  | tp27id | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
ix_TPPROFOP_tp12id |  | tp12id | Identifikace druhu výrobní linky


TPPROFTB Tabulka pracovních výkonů výroby

Popis

Tabulka pracovních výkonů výroby

Atributy

Atribut | Typ | Návěští | Message | Popis
tp30id | C(13) | Tabulka | Identifikátor tabulky pracovních výkonů | Identifikátor tabulky pracovních výkonů
tp30naztab | C(40) | Název tabulky | Název tabulky pracovních výkonů | Název tabulky pracovních výkonů
tp30koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Položka kusovníku TPV - referenční položka používá tabulku pravovních výkonů | TPKUSOV tp30id | 0,1 : 0,M | TPPROFTB tp30id |
Pracovní výkon - na prováděné technologické operace | TPPROFOP tp30id | 1,1 : 0,M | TPPROFTB tp30id |

Indexy

Název | Primární | Výraz | Popis
ix_TPPROFTB_tp30id | P | tp30id | Identifikátor tabulky pracovních výkonů
ix_TPPROFTB_tp30naztab |  | tp30naztab | Název tabulky pracovních výkonů


TPSABPRC Šablona procesu technologického postupu

Popis

Šablona procesu technologického postupu

Atributy

Atribut | Typ | Návěští | Message | Popis
tp25id | C(6) | Šablona | Identifikace šablony procesu technologického postupu | Identifikace šablony procesu technologického postupu
tp25nazsab | C(40) | Název šablony | Název šablony procesu technologického postupu | Název šablony procesu technologického postupu
tp25koment | M | Poznámka | Poznámka | Poznámka
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp07idtypd | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu procesu
sp06idsubd | C(3) | sp06idsubd | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Šablona procesu technologického postupu - byla založena uživatelem | TPSABPRC bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Šablona procesu technologického postupu - Používá jako předlohu proces | TPSABPRC sp07idtypd sp06idsubd | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Technologický postup - používá šablonu | TPTECHPO tp25id | 1,1 : 0,M | TPSABPRC tp25id |
Parametry výroby - definují identifikaci šablony pro jednokrokový TP | TPPARAM tp25id | 1,1 : 0,M | TPSABPRC tp25id |

Indexy

Název | Primární | Výraz | Popis
ix_TPSABPRC_tp25id | P | tp25id | Identifikace šablony procesu technologického postupu
ix_TPSABPRC_tp25nazsab |  | tp25nazsab | Název šablony procesu technologického postupu
ix_TPSABPRC_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_TPSABPRC_sptypd |  | sp07idtypd, sp06idsubd | Index podle typu dokladu a subsystému dokladu


TPSKLADU Skladové úložiště TPV

Popis

Skladové úložiště TPV

Atributy

Atribut | Typ | Návěští | Message | Popis
tp17id | C(6) | Úložiště | Identifikace skladového úložiště | Identifikace skladového úložiště
tp17ulozis | C(40) | Název úložiště | Název úložiště | Název úložiště
mt04id | C(6) | Sklad | Identifikace umístění skladové evidence | Identifikace umístění skladové evidence
tp12id | C(6) | Druh linky | Identifikace druhu výrobní linky | Identifikace druhu výrobní linky
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.

Indexy

Název | Primární | Výraz | Popis
ix_TPSKLADU_tp17id | P | tp17id | Identifikace skladového úložiště
ix_TPSKLADU_mt04id |  | mt04id | Identifikace umístění skladové evidence


TPTAB Tabulka vztahů artiklů výroby

Popis

Objektem typu TPTAB je každý záznam, který představuje hlavičku tabulky vztahů artiklu k jiným artiklům.

Atributy

Atribut | Typ | Návěští | Message | Popis
tp14id | C(13) | Tabulka | Identifikace tabulky artiklu výroby | Identifikace tabulky artiklu výroby
tp14naztab | C(40) | Název tabulky | Název tabulky vztahu artiklů | Název tabulky vztahu artiklů
tp14koment | M | Komentář | Komentář k tabulce artiklu výroby | Komentář k tabulce artiklu výroby

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Technologická operace - pracuje s tabulkou | TPOPERAC tp14id | 1,1 : 0,M | TPTAB tp14id |
Položka tabulky vztahů artiklu artiklů výroby - patří tabulce | TPTABP tp14id | 1,1 : 0,M s rušením | TPTAB tp14id |

Indexy

Název | Primární | Výraz | Popis
ix_TPTAB_tp14id | P | tp14id | Identifikace tabulky artiklu výroby
ix_TPTAB_tp14naztab |  | tp14naztab | Název tabulky vztahu artiklů


TPTABP Položka tabulky vztahů artiklu artiklů výroby

Popis

Objektem typu TPTABP je každý záznam, kde je uvedeno potřebné množství druhého artiklu, aby mohlo být vyrobeno množství prvního artiklu ve vztahu uvedených měrných jednotek

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id2 | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id2 | C(3) | Druh | Identifikace druhu artiklu | Identifikace druhu artiklu
tp14id | C(13) | Tabulka | Identifikace tabulky artiklu výroby | Identifikace tabulky artiklu výroby
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
tp12id | C(6) | Druh linky | Identifikace druhu výrobní linky | Identifikace druhu výrobní linky
tp15mnoz | N(14,6) | Vyrobit | Množství artiklu, které se má vyrobit | Množství artiklu, které se má vyrobit
tp15mnoz2 | N(14,6) | Potřeba | Množství artiklu potřebné k výrobě množství svázaného artiklu | Množství artiklu potřebné k výrobě množství svázaného artiklu
tp15koment | M | Komentář | Komentář | Komentář

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Položka tabulky vztahů artiklu artiklů výroby - týká se pilotního artiklu výroby | TPTABP sp60id sp61id | 1,1 : 0,M s rušením | TPVYROB sp60id sp61id |
Položka tabulky vztahů artiklu artiklů výroby - týká se svázaného artiklu výroby | TPTABP sp60id2 sp61id2 | 1,1 : 0,M s rušením | TPVYROB sp60id sp61id |
Položka tabulky vztahů artiklu artiklů výroby - patří tabulce | TPTABP tp14id | 1,1 : 0,M s rušením | TPTAB tp14id |
Položka tabulky vztahů artiklu artiklů výroby - se týká druhu stroje | TPTABP tp12id | 1,1 : 0,M | TPLINKAD tp12id |

Indexy

Název | Primární | Výraz | Popis
ix_TPTABP_tptabp | P | sp60id2, sp61id2, tp14id, sp60id, sp61id, tp12id, tp15mnoz | TPTAB2 + SPARTIKL + tp15mnoz
ix_TPTABP_tp14id |  | tp14id | Identifikace tabulky artiklu výroby
ix_TPTABP_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_TPTABP_sp61id |  | sp61id | Identifikace druhu artiklu
ix_TPTABP_spartikl2 |  | sp60id2, sp61id2 | CI - sp60id2+sp61id2
ix_TPTABP_sp61id2 |  | sp61id2 | Identifikace druhu artiklu
ix_TPTABP_tptab2 |  | sp60id2, sp61id2, tp14id | SPARTIKL2 + tp14id
ix_TPTABP_tp12id |  | tp12id | Identifikace druhu výrobní linky


TPTECOPR Technologický krok v technologickém postupu

Popis

Technologický krok v technologickém postupu

Atributy

Atribut | Typ | Návěští | Message | Popis
tp03id | C(13) | Tech. postup | Identifikace technologického postupu | Identifikace technologického postupu
tp25id | C(6) | Šablona | Identifikace šablony procesu technologického postupu | Identifikace šablony procesu technologického postupu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp07idtypd | C(6) | Druh procesu | Identifikátor druhu procesu | Identifikátor typu procesu
sp06idsubd | C(3) | sp06idsubd | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery | Identifikace subsystému procesu - kvůli RI - obsahuje vždy tři mezery
tp05id | C(13) | Operace | Identifikace technologické operace | Identifikace technologického kroku
tp26pilot | N(1,0) | Pilotní | Pilotní technolologický krok (určuje vyráběné/zpracovánané artikly) | Pilotní technolologický krok (určuje vyráběné/zpracovánané artikly)

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Technologický krok v technologickém postupu - patří k technlogickému postupu | TPTECOPR tp03id | 1,1 : 0,M s rušením | TPTECHPO tp03id |
Technologický krok v technologickém postupu - propojuje technologický krok | TPTECOPR tp05id | 1,1 : 0,M | TPOPERAC tp05id |
Technologický krok v technologickém postupu - odpovídá uzlu diagramu procesu | TPTECOPR sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPTYPOD sp07idtypd sp06idsubd sp07idtyp sp06idsubs sp33porad |

Indexy

Název | Primární | Výraz | Popis
ix_TPTECOPR_tptecopr | P | tp03id, tp25id, sp07idtyp, sp06idsubs, sp33porad | PI - TPTECHPOP + TPSABOPR
ix_TPTECOPR_tptechpop |  | tp03id | tp03id
ix_TPTECOPR_sptypod |  | sp07idtypd, sp06idsubd, sp07idtyp, sp06idsubs, sp33porad | Identifikace druhu operace v druhu procesu
ix_TPTECOPR_tpsabopr |  | tp25id, sp07idtyp, sp06idsubs, sp33porad | TPTECHPOP + tp05id
ix_TPTECOPR_tp05id |  | tp05id | Identifikace technologického kroku


TPTECUZ Uzel v diagramu technologického postupu

Popis

Uzel v diagramu technologického postupu

Atributy

Atribut | Typ | Návěští | Message | Popis
tp36 | C(10) | tp36 | Jednoznačná časová identifikace uzlu | Jednoznačná časová identifikace uzlu
tp03iddia | C(13) | tp03iddia | Technologický postup - vlastník diagramu | Technologický postup - vlastník diagramu
tp03id | C(13) | Tech. postup | Identifikace technologického postupu | Identifikace technologického postupu
tp05id | C(13) | Operace | Identifikace technologické operace | Identifikace technologického kroku
tp36pilot | N(1,0) | tp36pilot | Pilotní uzel v diagramu technologického postupu | Pilotní uzel v diagramu technologického postupu
tp36left | N(5,0) | tp36left | Pozice okna - levá souřadnice | Pozice okna - levá souřadnice
tp36top | N(5,0) | tp36top | Pozice okna - horní souřadnice | Pozice okna - horní souřadnice
tp36height | N(4,0) | tp36height | Výška okna | Výška okna
tp36width | N(4,0) | tp36width | Šířka okna | Šířka okna
tp36rozlis | C(1) | tp36rozlis | Rozlišení operace pro linku | Rozlišení operace pro linku

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Uzel v diagramu technologického postupu - patří k technologickému postupu | TPTECUZ tp03iddia | 1,1 : 0,M s rušením | TPTECHPO tp03id |
Uzel v diagramu technologického postupu - je uzlem typu postup | TPTECUZ tp03id | 0,1 : 0,M | TPTECHPO tp03id |
Uzel v diagramu technologického postupu - je uzlem typu operace | TPTECUZ tp05id | 0,1 : 0,M | TPOPERAC tp05id |
Vazba uzlů v diagramu technologického postupu - definuje uzel předchůdce | TPTECUZV tp36p | 1,1 : 0,M s rušením | TPTECUZ tp36 |
Vazba uzlů v diagramu technologického postupu - definuje uzel následníka | TPTECUZV tp36n | 1,1 : 0,M s rušením | TPTECUZ tp36 |

Indexy

Název | Primární | Výraz | Popis
ix_TPTECUZ_tp36 | P | tp36 | Jednoznačná časová identifikace uzlu
ix_TPTECUZ_tp03iddia |  | tp03iddia | Technologický postup - vlastník diagramu
ix_TPTECUZ_tp03id |  | tp03id | Identifikace technologického postupu
ix_TPTECUZ_tp05id |  | tp05id | Identifikace technologického kroku


TPTECUZV Vazba uzlů v diagramu technologického postupu

Popis

Vazba uzlů v diagramu technologického postupu

Atributy

Atribut | Typ | Návěští | Message | Popis
tp36p | C(10) | tp36p | Jednoznačná časová identifikace uzlu předchůdce | Jednoznačná časová identifikace uzlu předchůdce
tp36n | C(10) | tp36n | Jednoznačná časová identifikace uzlu následník | Jednoznačná časová identifikace uzlu následník
tp37cposun | N(7,2) | tp37cposun | Posun následující operace v hodinách | Posun následující operace v hodinách
tp37posun | N(1,0) | tp37posun | Časový posun | Časový posun

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vazba uzlů v diagramu technologického postupu - definuje uzel předchůdce | TPTECUZV tp36p | 1,1 : 0,M s rušením | TPTECUZ tp36 |
Vazba uzlů v diagramu technologického postupu - definuje uzel následníka | TPTECUZV tp36n | 1,1 : 0,M s rušením | TPTECUZ tp36 |

Indexy

Název | Primární | Výraz | Popis
ix_TPTECUZV_tptecuzv | P | tp36p, tp36n | PI - tp36p+tp36n
ix_TPTECUZV_tp36p |  | tp36p | Jednoznačná časová identifikace uzlu předchůdce
ix_TPTECUZV_tp36n |  | tp36n | Jednoznačná časová identifikace uzlu následník


TPTECVV Technologický postup k datu rozpracovaný na KJ pilotního artiklu

Popis

Technologický postup k datu rozpracovaný na KJ pilotního artiklu

Atributy

Atribut | Typ | Návěští | Message | Popis
tp03id | C(13) | Tech. postup | Identifikace technologického postupu | Identifikace technologického postupu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
tp32datum | D | Platnost od | Datum platnosti od | Datum platnosti od
tp01kj | N(8,2) | Kalkulační jednice | Množství výrobku, obsažené v jedné kalkulační jednici | Množství výrobku, obsažené v jedné kalkulační jednici
sp24idmj | C(3) | MJ | Identifikátor měrné jednotky | Identifikátor měrné jednotky
tp32 | C(12) | tp32 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
tp32datakt | T | Aktualizace | Datum poslední aktualizace | Datum poslední aktualizace
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
tp32wrkfil | M | tp32wrkfil | Pracovní soubory obsahují stav diagramu a kusovníku v okamžiku výpočtu | Pracovní soubory obsahují stav diagramu a kusovníku v okamžiku výpočtu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Technologický postup k datu rozpracovaný na KJ pilotního artiklu - patří k technologickému postupu | TPTECVV tp03id | 1,1 : 0,M | TPTECHPO tp03id |
Technologický postup k datu rozpracovaný na KJ pilotního artiklu - patří k pilotnímu artiklu TP | TPTECVV sp60id sp61id | 1,1 : 0,M | TPVYROB sp60id sp61id |
Technologický postup k datu rozpracovaný na KJ pilotního artiklu - byl zpracován pro měrnou jednotkou kalkulační jednice artiklu | TPTECVV sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Technologický postup k datu rozpracovaný na KJ pilotního artiklu - přepočet uživatel | TPTECVV bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Vstup/výstup technologického postupu k datu na kalkulační jednici - patří k TP k datu | TPTECVVP tp32 | 1,1 : 0,M s rušením | TPTECVV tp32 |

Indexy

Název | Primární | Výraz | Popis
ix_TPTECVV_tptecvv | P | tp03id, sp60id, sp61id, tp32datum | PI - TPTECHPO+SPARTIKL+tp32datum
ix_TPTECVV_tptechpop |  | tp03id | tp03id
ix_TPTECVV_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_TPTECVV_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky
ix_TPTECVV_tp32datum |  | tp32datum | Datum platnosti od
ix_TPTECVV_tp32 | U | tp32 | Jednoznačná časová identifikace
ix_TPTECVV_tp32datakt |  | tp32datakt | Datum poslední aktualizace
ix_TPTECVV_bw01uziv |  | bw01uziv | Identifikace uživatele systému


TPTECVVO Technologický postup připravený pro rozpracování k datu

Popis

Technologický postup připravený pro rozpracování k datu

Atributy

Atribut | Typ | Návěští | Message | Popis
tp34 | C(12) | tp34 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
tp03id | C(13) | Tech. postup | Identifikace technologického postupu | Identifikace technologického postupu
tp32datum | D | Platnost od | Datum platnosti od | Datum platnosti od
tp34proart | N(1,0) | tp34proart | Zpracovat pouze pro výrobek | Zpracovat pouze pro výrobek
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu

Indexy

Název | Primární | Výraz | Popis
ix_TPTECVVO_tptecvvo | P | tp34, tp03id, tp32datum | PI - tp34+tp03id+tp32datum
ix_TPTECVVO_tptechpop |  | tp03id | tp03id
ix_TPTECVVO_tp32datum |  | tp32datum | Datum platnosti od
ix_TPTECVVO_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_TPTECVVO_tptechar |  | tp03id, sp60id, sp61id | tp03id+SPARTIKL


TPTECVVP Vstup/výstup technologického postupu k datu na kalkulační jednici

Popis

Vstup/výstup technologického postupu k datu na kalkulační jednici

Atributy

Atribut | Typ | Návěští | Message | Popis
tp32 | C(12) | tp32 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
tp33porad | N(4,0) | Poř. | Pořadí | Pořadí
tp05id | C(13) | Operace | Identifikace technologické operace | Identifikace technologického kroku
tp02varian | C(6) | Varianta | Varianta technologické operace | Varianta technologické operace
sp24idmj | C(3) | MJ | Identifikátor měrné jednotky | Identifikátor měrné jednotky
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
tp27id | C(3) | KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
tp33mn | N(20,6) | Množství | Množství | Množství
tp33cena | N(20,6) | Cena | Celková cena | Celková cena
tp33cj | N(20,6) | Cena za j. | Cena za jednotku materiálu / práce | Cena za jednotku materiálu / práce
tp33cj2 | N(20,6) | Cena za j. | Cena za jednotku materiálu / práce - druhá část | Cena za jednotku materiálu / práce - druhá část
tp33privyd | N(1,0) | V/V | Vstup / Výstup | Vstup / Výstup
tp33zdroj | C(30) | Zdroj ceny | Zdroj pro stanovení ceny | Zdroj pro stanovení ceny
tp12id | C(6) | Druh linky | Identifikace druhu výrobní linky | Identifikace druhu výrobní linky

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vstup/výstup technologického postupu k datu na kalkulační jednici - patří k TP k datu | TPTECVVP tp32 | 1,1 : 0,M s rušením | TPTECVV tp32 |
Vstup/výstup technologického postupu k datu na kalkulační jednici - určuje vstup/výstup artiklu výroby | TPTECVVP sp60id sp61id | 1,1 : 0,M | TPVYROB sp60id sp61id |
Vstup/výstup technologického postupu k datu na kalkulační jednici - je vstupem/výstupem technologické operace | TPTECVVP tp05id | 1,1 : 0,M | TPOPERAC tp05id |
Vstup/výstup technologického postupu k datu na kalkulační jednici - má množství v měrné jednotce | TPTECVVP sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Vstup/výstup technologického postupu k datu na kalkulační jednici - je proměnnou KV / jeho hodnota byly spočtena KV | TPTECVVP tp27id | 1,1 : 0,M | TPKALK tp27id |
Vstup/výstup technologického postupu k datu na kalkulační jednici - určuje vstup/výstup na druhu stroje | TPTECVVP tp12id | 1,1 : 0,M | TPLINKAD tp12id |

Indexy

Název | Primární | Výraz | Popis
ix_TPTECVVP_tptecvvp | P | tp32, tp33porad | PI - tp32+tp33porad
ix_TPTECVVP_tp32 |  | tp32 | Jednoznačná časová identifikace
ix_TPTECVVP_tp05id |  | tp05id | Identifikace technologického kroku
ix_TPTECVVP_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky
ix_TPTECVVP_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_TPTECVVP_tp27id |  | tp27id | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
ix_TPTECVVP_tp12id |  | tp12id | Identifikace druhu výrobní linky


TPTECHAX Artikl výroby v technologickém postupu

Popis

Artikl výroby v technologickém postupu
### as select tptecopr.tp03id,tpkusov.sp60id,tpkusov.sp61id
from %%%.tptecopr,%%%.tpkusov
where tpkusov.tp05id=tptecopr.tp05id and tptecopr.tp26pilot=1 and tpkusov.tp02pilot=1

Atributy

Atribut | Typ | Návěští | Message | Popis
tp03id | C(13) | Tech. postup | Identifikace technologického postupu | Identifikace technologického postupu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Artikl výroby v technologickém postupu - se týká výrobního artiklu | TPTECHAX sp60id sp61id | 1,1 : 0,M | TPVYROB sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_TPTECHAX_tptechar | P | tp03id, sp60id, sp61id | tp03id+SPARTIKL
ix_TPTECHAX_tp03id |  | tp03id | Identifikace technologického postupu
ix_TPTECHAX_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id


TPTECHPO Technologický postup

Popis

Objektem typu TPTECHPO je každý záznam, který obsahuje identifikační údaje technologického postupu

Atributy

Atribut | Typ | Návěští | Message | Popis
tp03id | C(13) | Tech. postup | Identifikace technologického postupu | Identifikace technologického postupu
tp03techpo | C(40) | Popis tech. postupu | Stručný popis, charakterizující technologický postup | Stručný popis, charakterizující technologický postup
tp03koment | M | Komentář | Komentář, podrobně popisující technologický postup | Komentář, podrobně popisující technologický postup
tp03datod | D | Datum platnosti od | Datum platnosti definice technologického postupu od | Datum platnosti definice technologického postupu od
tp03datdo | D | Datum platnosti do | Datum platnosti definice technologického postupu do | Datum platnosti definice technologického postupu do
tp03platny | N(1,0) | Platný | Technologický postup je platný, resp. neplatný | Technologický postup je platný, resp. neplatný
tp25id | C(6) | Šablona | Identifikace šablony procesu technologického postupu | Identifikace šablony procesu technologického postupu
tp03pilot | N(1,0) | Pilotní | Pilotní pro určení ceny vstupu/výstupu podle TP k datu | Pilotní pro určení ceny vstupu/výstupu podle TP k datu
tp05idpilo | C(13) | tp05idpilo | Identifikace pilotní technologické operace postupu | Identifikace pilotní technologické operace postupu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Technologický postup - používá šablonu | TPTECHPO tp25id | 1,1 : 0,M | TPSABPRC tp25id |
Technologický postup - má pilotní technologickou operaci | TPTECHPO tp05idpilo | 0,1 : 0,M | TPOPERAC tp05id |
Technologický krok v technologickém postupu - patří k technlogickému postupu | TPTECOPR tp03id | 1,1 : 0,M s rušením | TPTECHPO tp03id |
Technologický postup k datu rozpracovaný na KJ pilotního artiklu - patří k technologickému postupu | TPTECVV tp03id | 1,1 : 0,M | TPTECHPO tp03id |
Uzel v diagramu technologického postupu - patří k technologickému postupu | TPTECUZ tp03iddia | 1,1 : 0,M s rušením | TPTECHPO tp03id |
Uzel v diagramu technologického postupu - je uzlem typu postup | TPTECUZ tp03id | 0,1 : 0,M | TPTECHPO tp03id |

Indexy

Název | Primární | Výraz | Popis
ix_TPTECHPO_tptechpop | P | tp03id | tp03id
ix_TPTECHPO_tp03id |  | tp03id | Identifikace technologického postupu
ix_TPTECHPO_tp03techpo |  | tp03techpo | Stručný popis, charakterizující technologický postup
ix_TPTECHPO_tp25id |  | tp25id | Identifikace šablony procesu technologického postupu
ix_TPTECHPO_tp05idpilo |  | tp05idpilo | Identifikace pilotní technologické operace postupu


TPTRASY Výrobní trasa

Popis

Výrobní trasy

Atributy

Atribut | Typ | Návěští | Message | Popis
tp22id | C(6) | Trasa | Identifikace trasy | Identifikace trasy
tp22naztra | C(40) | Popis trasy | Popis trasy | Popis trasy
tp17id | C(6) | Úložiště | Identifikace skladového úložiště | Identifikace skladového úložiště
tp17id2 | C(6) | Cíl | Identifikace skladového úložiště |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Výrobní trasa - má zdrojové úložiště | TPTRASY tp17id | 1,1 : 0,M | TPLINKA tp13id |
Výrobní trasa - má cílové úložiště | TPTRASY tp17id2 | 1,1 : 0,M | TPLINKA tp13id |
Importované měření-vážení výroby - je vážením na trase | VRIMPVYR tp22id | 1,1 : 0,M | TPTRASY tp22id |

Indexy

Název | Primární | Výraz | Popis
ix_TPTRASY_tp22id | P | tp22id | Identifikace trasy
ix_TPTRASY_tp22naztra |  | tp22naztra | Popis trasy
ix_TPTRASY_tp17id |  | tp17id | Identifikace skladového úložiště
ix_TPTRASY_tp17id2 |  | tp17id2 |


TPVYROB Artikl výroby

Popis

Objektem typu TPVYROB je každý záznam, který obsahuje seznam vyráběných výrobků a polotovarů. Do seznamu lze zařadit pouze ty výrobky, které jsou evidované na kartách obchodního artiklu.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
tp21id | C(3) | Třída | Identifikace třídy výrobního artiklu | Identifikace třídy výrobního artiklu
tp01mtodp | N(1,0) | M/O | Rozlišení materiálu a odpadu. | Rozlišení materiálu a odpadu.
tp01vyna | N(1,0) | N/V | Artikl výroby představuje náklad (materiál, likvidace opadu) nebo výnos (prodej odpadu). | Artikl výroby představuje náklad (materiál, likvidace opadu) nebo výnos (prodej odpadu).
tp01koment | M | Komentář | Komentář, podrobně popisující artikl výroby | Komentář, podrobně popisující výrobek / polotovar
tp01cis | C(20) | Číslo | Pomocné číslo artiklu výroby | Pomocné číslo výrobku
sp24idmj | C(3) | MJ | Identifikátor měrné jednotky | Identifikátor měrné jednotky
sp24idmj2 | C(3) | Měrná jednotka | Identifikátor měrné jednotky | Identifikátor měrné jednotky
tp01kj | N(8,2) | Kalkulační jednice | Množství výrobku, obsažené v jedné kalkulační jednici | Množství výrobku, obsažené v jedné kalkulační jednici
tp01pozn1 | C(20) | Pozn. 1 | Poznámka | Poznámka
tp01pozn2 | C(20) | Pozn. 2 | Poznámka | Poznámka
tp01pozn3 | C(20) | Pozn. 3 | Poznámka | Poznámka
tp01pozn4 | C(20) | Pozn. 4 | Poznámka | Poznámka
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
tp01jkpov | C(13) | JKPOV | Identifikace třídy klasifikace průmyslových oborů a výrobců | Identifikace třídy klasifikace průmyslových oborů a výrobců
tp01carkod | C(36) | Čárový kód | Čárový kód artiklu výroby | Čárový kód artiklu výroby
sp17idskp | C(8) | Třída SKP | Identifikace třídy Standardní klasifikace produkce. | Identifikace kategorie Standardní klasifikace produkce. *** Dříve SKPID.
sp60id2 | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id2 | C(3) | Druh | Identifikace druhu artiklu | Identifikace druhu artiklu
tp01kvalit | N(1,0) | Kvalita | Kvalita I./II./III./IV. | Kvalita I./II./III./IV.
tp17id | C(6) | Úložiště | Identifikace skladového úložiště | Identifikace skladového úložiště
tp01rozpmn | N(1,0) | Rozp. mn. | Rozpočítávat množství na vstupu | Rozpočítávat množství na vstupu podle skutečné spotřeby
tp01odcasu | N(1,0) | Čas | Množství artiklu na vstupu/výstupu úkolu je odvozováno podle trvání úkolu | Množství artiklu na vstupu/výstupu je odvozováno podle trvání úkolu
tp01cislo1 | N(20,4) | Volné číslo I | Volně použitelné číslo | Volně použitelné číslo
tp01cislo2 | N(20,4) | Volné číslo II | Volně použitelné číslo | Volně použitelné číslo
tp01cislo3 | N(20,4) | Volné číslo III | Volně použitelné číslo | Volně použitelné číslo

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Artikl výroby - jsou určitým druhem artiklu | TPVYROB sp61id | 1,1 : 0,M | SPARTIKD sp61id |
Artikl výroby - odpovídá artiklu | TPVYROB sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Artikl výroby - odpovídá technicko-věcnému selektoru | TPVYROB sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Artikl výroby - je veden v měrné jednotce | TPVYROB sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Artikl výroby - je veden ve třídě SKP | TPVYROB sp17idskp | 1,1 : 0,M | SPSKP sp17idskp |
Artikl výroby - je druhem vadného artiklu výroby | TPVYROB sp61id2 | 0,1 : 0,M | SPARTIKD sp61id |
Artikl výroby - je třídy | TPVYROB tp21id | 1,1 : 0,M | TPVYROBT tp21id |
Artikl výroby - je ukládán ve skladovém úložišti TPV | TPVYROB tp17id | 1,1 : 0,M | TPLINKA tp13id |
Artikl výroby - má měrnou jednotku vedenou v tabulkách | TPVYROB sp24idmj2 | 1,1 : 0,M | SPMJ sp24idmj |
Artikl výroby - je vadným výrobkem artiklu výroby | TPVYROB sp60id2 sp61id2 | 0,1 : 0,M | TPVYROB sp60id sp61id |
Artikl výroby v technologickém postupu - se týká výrobního artiklu | TPTECHAX sp60id sp61id | 1,1 : 0,M | TPVYROB sp60id sp61id |
Technologický postup k datu rozpracovaný na KJ pilotního artiklu - patří k pilotnímu artiklu TP | TPTECVV sp60id sp61id | 1,1 : 0,M | TPVYROB sp60id sp61id |
Vstup/výstup technologického postupu k datu na kalkulační jednici - určuje vstup/výstup artiklu výroby | TPTECVVP sp60id sp61id | 1,1 : 0,M | TPVYROB sp60id sp61id |
Artikl výroby - je vadným výrobkem artiklu výroby | TPVYROB sp60id2 sp61id2 | 0,1 : 0,M | TPVYROB sp60id sp61id |
Položka kusovníku TPV - zahrnuje artikl výroby | TPKUSOV sp60id sp61id | 1,1 : 0,M | TPVYROB sp60id sp61id |
Pracovní výkon - vztažený k artiklu výroby | TPPROFOP sp60id sp61id | 1,1 : 0,M | TPVYROB sp60id sp61id |
Výrobní zakázka - výrobního artiklu | VRVYR sp60id sp61id | 1,1 : 0,M | TPVYROB sp60id sp61id |
Událost úkolu ve výrobě - je úkolem vyrobit/zpracovat artikl | VRUDOPER sp60id sp61id | 1,1 : 0,M | TPVYROB sp60id sp61id |
Položka tabulky vztahů artiklu artiklů výroby - týká se pilotního artiklu výroby | TPTABP sp60id sp61id | 1,1 : 0,M s rušením | TPVYROB sp60id sp61id |
Položka tabulky vztahů artiklu artiklů výroby - týká se svázaného artiklu výroby | TPTABP sp60id2 sp61id2 | 1,1 : 0,M s rušením | TPVYROB sp60id sp61id |
Vstup nebo výstup výrobního úkolu - se vztahuje k artiklu výroby | VRUDOPMA sp60id sp61id | 1,1 : 0,M | TPVYROB sp60id sp61id |
Řád zaokrouhlování měrné jednotky vyráběného artiklu - je měrnou jednotkou artiklu výroby | TPMJNED sp60id sp61id | 1,1 : 0,M s rušením | TPVYROB sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_TPVYROB_spartikl | P | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_TPVYROB_sp60id |  | sp60id | Identifikace artiklu
ix_TPVYROB_sp61id |  | sp61id | Identifikace druhu artiklu
ix_TPVYROB_spartiknx |  |  |
ix_TPVYROB_tp21id |  | tp21id | Identifikace třídy výrobního artiklu
ix_TPVYROB_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky
ix_TPVYROB_sp24idmj2 |  | sp24idmj2 | Identifikátor měrné jednotky
ix_TPVYROB_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_TPVYROB_sp17idskp |  | sp17idskp | Identifikace kategorie Standardní klasifikace produkce.
ix_TPVYROB_spartikl2 |  | sp60id2, sp61id2 | CI - sp60id2+sp61id2
ix_TPVYROB_sp61id2 |  | sp61id2 | Identifikace druhu artiklu
ix_TPVYROB_tp17id |  | tp17id | Identifikace skladového úložiště


TPVYROBT Třída výrobního artiklu

Popis

Třída výrobního artiklu

Atributy

Atribut | Typ | Návěští | Message | Popis
tp21id | C(3) | Třída | Identifikace třídy výrobního artiklu | Identifikace třídy výrobního artiklu
tp21naztri | C(40) | Název třídy | Název třídy výrobního artiklu | Název třídy výrobního artiklu
tp21koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Artikl výroby - je třídy | TPVYROB tp21id | 1,1 : 0,M | TPVYROBT tp21id |

Indexy

Název | Primární | Výraz | Popis
ix_TPVYROBT_tp21id | P | tp21id | Identifikace třídy výrobního artiklu
ix_TPVYROBT_tp21naztri |  | tp21naztri | Název třídy výrobního artiklu


Tabulky UC...

UCAKONT | Rok+den+účet+měna z obratové tabulky
UCAKONTS | Rok+den+účet+selektor+měna z obratové tabulky
UCBUNKA | Buňka výkazu
UCDENIK | Účetní událost
UCDENROZ | Pracovní záznam pro rozúčtování události účetnictví
UCDRUHV | Druh výkazu
UCHLAKNI | Záznam v hlavní knize účtu
UCKONTO | Záznam o stavu konta
UCKONTOS | Záznam o stavu konta se selektorem
UCLIST | List výkazu
UCOBDOBI | Účetní období
UCOBRTAB | Měsíční obrat
UCPRCSA2 | Saldokonto do data
UCPRCSAL | Saldokontní hodnota účetníctví
UCRADEK | Řádek výkazu
UCROZVRH | Účet z rozvrhu
UCROZVRN | Cizí popis účtu
UCSLOUP | Sloupec výkazu
UCVAZLIS | Navázání listů výkazu
UCVAZVYK | Vazba výkazů
UCVYKAZ | Definice výkazu

Viz.také

UCDENIK Účetní událost | UCAKONT Rok+den+účet+měna z obratové tabulky | UCAKONTS Rok+den+účet+selektor+měna z obratové tabulky | UCBUNKA Buňka výkazu | UCDRUHV Druh výkazu | UCHLAKNI Záznam v hlavní knize účtu | UCKONTO Záznam o stavu konta | UCKONTOS Záznam o stavu konta se selektorem | UCLIST List výkazu | UCOBDOBI Účetní období | UCOBRTAB Měsíční obrat | UCPRCSA2 Saldokonto do data | UCPRCSAL Saldokontní hodnota účetníctví | UCRADEK Řádek výkazu | UCROZVRH Účet z rozvrhu | UCROZVRN Cizí popis účtu | UCSLOUP Sloupec výkazu | UCVAZLIS Navázání listů výkazu | UCVAZVYK Vazba výkazů | UCVYKAZ Definice výkazu | UCDENROZ Pracovní záznam pro rozúčtování události účetnictví


UCAKONT Rok+den+účet+měna z obratové tabulky

Popis

Rok+den+účet+měna z obratové tabulky

Atributy

Atribut | Typ | Návěští | Message | Popis
uc03rok | C(4) | Rok | Rok ve kterém došlo k pohybu | Rok, ve kterém došlo k pohybu
uc03mesic | C(2) | Měsíc | Měsíc, ve kterém došlo k pohybu | Měsíc, ve kterém došlo k pohybu
uc01id | C(9) | Účet | Identifikátor účtu účetnictví | Identifikátor účtu
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
uc03faze | N(1,0) | Fáze | Fáze události v účetním období - otevření, běžná, uzavření | Fáze události v účetním období - otevření, běžná, uzavření
uc03druh | N(1,0) | Druh | Druh informace skutečnost, plán ... | Druh informace skutečnost, plán ...
uc37id | C(6) | Období | Identifikace účetního období | Identifikace účetního období

Indexy

Název | Primární | Výraz | Popis
ix_UCAKONT_ucakont |  | uc03rok, uc03mesic, uc01id, oc01id | rok+mesic+uc01id+oc01id


UCAKONTS Rok+den+účet+selektor+měna z obratové tabulky

Popis

Rok+den+účet+selektor+měna z obratové tabulky

Atributy

Atribut | Typ | Návěští | Message | Popis
uc03druh | N(1,0) | Druh | Druh informace skutečnost, plán ... | Druh informace skutečnost, plán ...
uc03rok | C(4) | Rok | Rok ve kterém došlo k pohybu | Rok, ve kterém došlo k pohybu
uc03faze | N(1,0) | Fáze | Fáze události v účetním období - otevření, běžná, uzavření | Fáze události v účetním období - otevření, běžná, uzavření
uc01id | C(9) | Účet | Identifikátor účtu účetnictví | Identifikátor účtu
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
uc03mesic | C(2) | Měsíc | Měsíc, ve kterém došlo k pohybu | Měsíc, ve kterém došlo k pohybu
uc37id | C(6) | Období | Identifikace účetního období | Identifikace účetního období


UCBUNKA Buňka výkazu

Atributy

Atribut | Typ | Návěští | Message | Popis
vs01id | C(6) | vs01id |  |
vs02id | C(6) | vs02id |  |
vs03id | C(6) | vs03id |  |
vs03popis | M | vs03popis |  |
vs00typzaz | N(1,0) | vs00typzaz |  |
vs00prekr1 | N(1,0) | vs00prekr1 |  |
uc01id | C(9) | Účet | Identifikátor účtu účetnictví | Identifikátor účtu
uc01id_m | M | uc01id_m |  |
vs00plan | N(1,0) | vs00plan | Spočítat plán nebo skutečnost |
vs00dyn1 | N(1,0) | vs00dyn1 |  |
vs00prekr2 | N(1,0) | vs00prekr2 |  |
sp11id_m | M | sp11id_m |  |
vs00dyn2 | N(1,0) | vs00dyn2 |  |
vs00obdobi | N(1,0) | vs00obdobi |  |
vs00dyn5 | N(1,0) | vs00dyn5 |  |
vs00od | C(10) | vs00od |  |
vs00do | C(10) | vs00do |  |
vs00po | C(10) | vs00po |  |
vs00zdata | N(1,0) | vs00zdata |  |
vs00prekr6 | N(1,0) | vs00prekr6 |  |
vs00typho2 | N(1,0) | vs00typho2 |  |
vs00excel | M | vs00excel |  |
vs00tucne | N(1,0) | vs00tucne |  |
vs00ital | N(1,0) | vs00ital |  |
vs00negace | N(1,0) | vs00negace |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Buňka výkazu - patří řádku | UCBUNKA vs01id vs02id | 1,1 : 0,M | UCRADEK vs01id vs02id |
Buňka výkazu - patří sloupci | UCBUNKA vs01id vs03id | 1,1 : 0,M | UCSLOUP vs01id vs03id |
Buňka výkazu - pat59 listu | UCBUNKA vs01id | 1,1 : 1,1 s rušením | UCLIST vs01id |

Indexy

Název | Primární | Výraz | Popis
ix_UCBUNKA_vsbunka | P | vs01id, vs02id, vs03id |
ix_UCBUNKA_vsradek |  | vs01id, vs02id |
ix_UCBUNKA_vssloup |  | vs01id, vs03id |
ix_UCBUNKA_vs01id |  | vs01id |


UCDENIK Účetní událost

Popis

Objektem typu UCDENIK je každý záznam, který obsahuje účetní události - zápisy do úetního deníku.

Atributy

Atribut | Typ | Návěští | Message | Popis
uc02 | C(12) | uc02 | Jednoznačná časová identifikace události. | Jednoznačná časová identifikace události.
uc02datum | D | Datum | Datum účetního případu | Datum účetního případu.
sp07druh | N(1,0) | Druh události | Plánovaná/Ujednaná/Realizovaná událost |
uc01id | C(9) | Účet | Identifikátor účtu účetnictví | Identifikátor účtu
uc02strana | N(1,0) | Strana | Strana účtu MD/Dal | Strana účtu MD/Dal
uc02castka | N(20,4) | Částka | Finanční částka | Finanční částka
uc02faze | N(1,0) | Druh | Fáze události v účetním období - otevření, běžná, uzavření | Fáze události v účetním období - otevření, běžná, uzavření
uc02druh2 | N(1,0) | Druh 2.část | Druh události 2.část - skutečnost, plán | Druh události 2.část - skutečnost, plán
uc02platno | N(1,0) | Platnost | Platnost účtu - platný, stornovaný, stornující | Platnost účtu - platný, stornovaný, stornovací Platný účet nabyde stronováním příznaku stornovací, nově vytvořený doklad, který byl vytvořen kopií s obrácenými znaménky má příznak Stornovací.
uc02popuda | C(40) | Popis události | Popis účetní události | Popis účetní události
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
uc02parov | N(1,0) | Jiné párování | Záznam byl saldokontně párován importem | Záznam byl saldokontně párován importem
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
oc01id1 | C(3) | oc01id1 | Referenční měna | Referenční měna kursu (je na pozadí)
uc02castkz | N(20,4) | Částka ZM | Částka v zahraniční měně | Částka v zahraniční měně
uc15parid | C(14) | IDP | Identifikace párování | Identifikace párování
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
uc02druh | N(1,0) | uc02druh | Původní hodnota atributu uc02faze | Původní hodnota atributu uc02faze

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Účetní událost - zapsal uživatel | UCDENIK bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Účetní událost - patří operaci dokladu | UCDENIK sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Účetní událost - má adresáta | UCDENIK ad01id | 1,1 : 0,M | ADADSAT ad01id |
Účetní událost - má organizační selektor | UCDENIK sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Účetní událost - účtuje o zahraniční měně | UCDENIK oc01id | 1,1 : 0,M | OCMENA oc01id |
Účetní událost - účtuje o referenční měně | UCDENIK oc01id1 | 1,1 : 0,M | OCMENA oc01id |
Účetní událost - má obchodní selektor | UCDENIK sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Účetní událost - má TV-selektor | UCDENIK sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Účetní událost - patří účtu z rozvrhu | UCDENIK uc01id | 1,1 : 0,M | UCROZVRH uc01id |

Indexy

Název | Primární | Výraz | Popis
ix_UCDENIK_uc02 | P | uc02 | Jednoznačná časová identifikace události.
ix_UCDENIK_uc02datum |  | uc02datum | Datum účetního případu.
ix_UCDENIK_uc01id |  | uc01id | Identifikátor účtu
ix_UCDENIK_uc02strana |  | uc02strana | Strana účtu MD/Dal
ix_UCDENIK_uc02castka |  | uc02castka | Finanční částka
ix_UCDENIK_uc02faze |  | uc02faze | Fáze události v účetním období - otevření, běžná, uzavření
ix_UCDENIK_uc02popuda |  | uc02popuda | Popis účetní události
ix_UCDENIK_ad01id |  | ad01id | Identifikace adresáta
ix_UCDENIK_adadsatx |  |  |
ix_UCDENIK_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_UCDENIK_sp00datzap |  | sp00datzap | Datum a čas zápisu záznamu události
ix_UCDENIK_ucdenik1 |  | uc02datum, uc01id | datum + číslo účtu
ix_UCDENIK_ucdenik2 |  | uc02datum, sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | datum + id operace
ix_UCDENIK_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_UCDENIK_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_UCDENIK_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_UCDENIK_oc01id |  | oc01id | Kód měny - oceňovací jednotky.
ix_UCDENIK_oc01id1 |  | oc01id1 | Referenční měna kursu (je na pozadí)
ix_UCDENIK_uc15parid |  | uc15parid | Identifikace párování
ix_UCDENIK_ucprcsal |  | uc15parid, uc01id |
ix_UCDENIK_ucobrt7 |  | uc01id, sp10idzak, sp11idzak, sp20idzak | uc01id+sp11idzak
ix_UCDENIK_ucdeniks |  | uc15parid, uc01id |
ix_UCDENIK_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_UCDENIK_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.


UCDENROZ Pracovní záznam pro rozúčtování události účetnictví

Popis

Pracovní záznam pro rozúčtování události účetnictví

Atributy

Atribut | Typ | Návěští | Message | Popis
uc40 | C(12) | uc40 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
uc02 | C(12) | uc02 | Jednoznačná časová identifikace události. | Jednoznačná časová identifikace události.
uc01id | C(9) | Účet | Identifikátor účtu účetnictví | Identifikátor účtu
uc02castka | N(20,4) | Částka | Finanční částka | Finanční částka
uc02popuda | C(40) | Popis události | Popis účetní události | Popis účetní události
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.

Indexy

Název | Primární | Výraz | Popis
ix_UCDENROZ_ucdenroz | P | uc40, uc02 | PI - uc40+uc02
ix_UCDENROZ_uc01id |  | uc01id | Identifikátor účtu
ix_UCDENROZ_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_UCDENROZ_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_UCDENROZ_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.


UCDRUHV Druh výkazu

Atributy

Atribut | Typ | Návěští | Message | Popis
vs09id | C(6) | vs09id |  |
vs09druh | C(40) | vs09druh |  |
vs09popis | M | vs09popis |  |
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh výkazu - zapsal uživatel | UCDRUHV bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |
Definice výkazu - má druh výkazu | UCVYKAZ vs09id | 1,1 : 0,M | UCDRUHV vs09id |

Indexy

Název | Primární | Výraz | Popis
ix_UCDRUHV_vs09id | P | vs09id |
ix_UCDRUHV_bw01uziv |  | bw01uziv | Identifikace uživatele systému


UCKONTO Záznam o stavu konta

Popis

Konto účetnictví

Atributy

Atribut | Typ | Návěští | Message | Popis
uc03rok | C(4) | Rok | Rok ve kterém došlo k pohybu | Rok, ve kterém došlo k pohybu
uc03mesic | C(2) | Měsíc | Měsíc, ve kterém došlo k pohybu | Měsíc, ve kterém došlo k pohybu
uc03faze | N(1,0) | Fáze | Fáze události v účetním období - otevření, běžná, uzavření | Fáze události v účetním období - otevření, běžná, uzavření
uc01id | C(9) | Účet | Identifikátor účtu účetnictví | Identifikátor účtu
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
uc03druh | N(1,0) | Druh | Druh informace skutečnost, plán ... | Druh informace skutečnost, plán ...
uc37id | C(6) | Období | Identifikace účetního období | Identifikace účetního období
uc03psvyk | N(20,4) | uc03psvyk |  |
uc03mdr | N(20,4) | Má dáti | Obrat strany MD | Obrat strany MD realizovaný
uc03dalr | N(20,4) | Dal | Obrat strany Dal | Obrat strany Dal realizovaný
uc03ksvyk | N(20,4) | Konečný stav | Konečný stav účtu |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Záznam o stavu konta - se vztahuje k účetnímu období | UCKONTO uc37id | 1,1 : 0,M | UCOBDOBI uc37id |

Indexy

Název | Primární | Výraz | Popis
ix_UCKONTO_ucobrt6 |  | uc03rok, uc03mesic, uc03faze, uc01id | rok+mesic+ucet+mena
ix_UCKONTO_ucobrt2 |  | uc01id, uc03rok, uc03mesic, uc03faze | Ucet+rok+mesic
ix_UCKONTO_ucakont |  | uc03rok, uc03mesic, uc01id, oc01id | rok+mesic+uc01id+oc01id
ix_UCKONTO_uc37id |  | uc37id | Identifikace účetního období
ix_UCKONTO_uc01id |  | uc01id | Identifikátor účtu


UCKONTOS Záznam o stavu konta se selektorem

Popis

Konto účetnictví se selektory

Atributy

Atribut | Typ | Návěští | Message | Popis
uc03rok | C(4) | Rok | Rok ve kterém došlo k pohybu | Rok, ve kterém došlo k pohybu
uc03mesic | C(2) | Měsíc | Měsíc, ve kterém došlo k pohybu | Měsíc, ve kterém došlo k pohybu
uc03faze | N(1,0) | Fáze | Fáze události v účetním období - otevření, běžná, uzavření | Fáze události v účetním období - otevření, běžná, uzavření
uc01id | C(9) | Účet | Identifikátor účtu účetnictví | Identifikátor účtu
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
uc03druh | N(1,0) | Druh | Druh informace skutečnost, plán ... | Druh informace skutečnost, plán ...
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
uc37id | C(6) | Období | Identifikace účetního období | Identifikace účetního období
uc03psvyk | N(20,4) | uc03psvyk |  |
uc03mdr | N(20,4) | Má dáti | Obrat strany MD | Obrat strany MD realizovaný
uc03dalr | N(20,4) | Dal | Obrat strany Dal | Obrat strany Dal realizovaný
uc03ksvyk | N(20,4) | Konečný stav | Konečný stav účtu |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Záznam o stavu konta se selektorem - se vztahuje k účetnímu období | UCKONTOS uc37id | 1,1 : 0,M | UCOBDOBI uc37id |

Indexy

Název | Primární | Výraz | Popis
ix_UCKONTOS_ucobrt6 |  | uc03rok, uc03mesic, uc03faze, uc01id | rok+mesic+ucet+mena
ix_UCKONTOS_ucobrt4 |  | uc01id, sp11idzak, uc03rok, uc03mesic, uc03faze | ucet+selektor+rok+mesic
ix_UCKONTOS_ucobrt2 |  | uc01id, uc03rok, uc03mesic, uc03faze | Ucet+rok+mesic
ix_UCKONTOS_ucobrt7 |  | uc01id, sp10idzak, sp11idzak, sp20idzak | uc01id+sp11idzak
ix_UCKONTOS_ucobrt1 |  | uc03druh, uc03rok, uc03faze, uc01id, sp10idzak, sp11idzak, sp20idzak, oc01id, uc03mesic | Rok + číslo účtu + selektory + měsíc
ix_UCKONTOS_ucobrt8 |  | uc03rok, uc03mesic, uc01id, sp11idzak | Období, účet a selektor
ix_UCKONTOS_uc37id |  | uc37id | Identifikace účetního období
ix_UCKONTOS_uc01id |  | uc01id | Identifikátor účtu
ix_UCKONTOS_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_UCKONTOS_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_UCKONTOS_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.


UCLIST List výkazu

Atributy

Atribut | Typ | Návěští | Message | Popis
vs01id | C(6) | List | Identifikace listu |
vs01nazev | C(60) | Název | Název listu |
vs01nazev1 | M | vs01nazev1 |  |
vs01nazlis | C(60) | vs01nazlis |  |
vs01popis | M | Popis | Popis listu |
vs01konst | M | vs01konst |  |
vs01pocslo | N(2,0) | vs01pocslo |  |
vs00prekr1 | N(1,0) | vs00prekr1 |  |
uc01id | C(9) | Účet | Identifikátor účtu účetnictví | Identifikátor účtu
uc01id_m | M | uc01id_m |  |
vs00plan | N(1,0) | vs00plan | Spočítat plán nebo skutečnost |
vs00dyn1 | N(1,0) | vs00dyn1 |  |
vs00prekr2 | N(1,0) | vs00prekr2 |  |
sp11id_m | M | sp11id_m |  |
vs00dyn2 | N(1,0) | vs00dyn2 |  |
vs00obdobi | N(1,0) | vs00obdobi |  |
vs00dyn5 | N(1,0) | vs00dyn5 |  |
vs00od | C(10) | vs00od |  |
vs00do | C(10) | vs00do |  |
vs00po | C(10) | vs00po |  |
vs00zdata | N(1,0) | vs00zdata |  |
vs00prekr6 | N(1,0) | vs00prekr6 |  |
vs00typho2 | N(1,0) | vs00typho2 |  |
vs00excel | M | vs00excel |  |
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
vs01hide | N(1,0) | vs01hide |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
List výkazu - zapsal uživatel | UCLIST bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Buňka výkazu - pat59 listu | UCBUNKA vs01id | 1,1 : 1,1 s rušením | UCLIST vs01id |
Řádek výkazu - patří listu | UCRADEK vs01id | 1,1 : 0,M s rušením | UCLIST vs01id |
Sloupec výkazu - patří k listu | UCSLOUP vs01id | 1,1 : 0,M s rušením | UCLIST vs01id |
Navázání listů výkazu - má list | UCVAZLIS vs01id | 1,1 : 0,M | UCLIST vs01id |

Indexy

Název | Primární | Výraz | Popis
ix_UCLIST_vs01id | P | vs01id |


UCOBDOBI Účetní období

Popis

Účetní období

Atributy

Atribut | Typ | Návěští | Message | Popis
uc37id | C(6) | Období | Identifikace účetního období | Identifikace účetního období
uc37rok1 | C(4) | Rok od | Rok otevření účetního období | Rok otevření účetního období
uc37mesic1 | C(2) | Měsíc od | Měsíc otevření účetního období | Měsíc otevření účetního období
uc37rok2 | C(4) | Rok do | Rok uzavření účetního období | Rok uzavření účetního období
uc37mesic2 | C(2) | Měsíc do | Měsíc uzavření účetního období | Měsíc uzavření účetního období
uc37nazobd | C(40) | Název období | Název účetního období | Název účetního období
uc37otevre | N(1,0) | uc37otevre | Příznak otevřeného účetního období | Příznak otevřeného účetního období
uc37uzavre | N(1,0) | uc37uzavre | Příznak uzavřeného účetního období | Příznak uzavřeného účetního období
uc37koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Záznam v hlavní knize účtu - se vztahuje k účetnímu období | UCHLAKNI uc37id | 1,1 : 0,M | UCOBDOBI uc37id |
Záznam o stavu konta - se vztahuje k účetnímu období | UCKONTO uc37id | 1,1 : 0,M | UCOBDOBI uc37id |
Záznam o stavu konta se selektorem - se vztahuje k účetnímu období | UCKONTOS uc37id | 1,1 : 0,M | UCOBDOBI uc37id |
Měsíční obrat - se vztahuje k účetnímu období | UCOBRTAB uc37id | 1,1 : 0,M | UCOBDOBI uc37id |

Indexy

Název | Primární | Výraz | Popis
ix_UCOBDOBI_uc37id | P | uc37id | Identifikace účetního období
ix_UCOBDOBI_ucobdobi |  | uc37rok1, uc37mesic1, uc37rok2, uc37mesic2 | uc37rok1+uc37mesic1+uc37rok2+uc37mesic2


UCOBRTAB Měsíční obrat

Popis

Objektem typu UCOBRTAB je každý záznam, který obsahuje měsíční obraty účtu.
Neevidují se měsíce, ve kterých nedošlo k pohybu.
V obratové tabulce je evidován i plán.
Otevření účetních knih se zapisuje do měsíce 00, uzavření do měsíce 13. Z toho plyne, že nelze otevírat a uzavírat knihy dvakrát v jednom roce (při vyhlášení konkurzu ap.).

Atributy

Atribut | Typ | Návěští | Message | Popis
uc03druh | N(1,0) | Druh | Druh informace skutečnost, plán ... | Druh informace skutečnost, plán ...
uc03rok | C(4) | Rok | Rok ve kterém došlo k pohybu | Rok, ve kterém došlo k pohybu
uc03faze | N(1,0) | Fáze | Fáze události v účetním období - otevření, běžná, uzavření | Fáze události v účetním období - otevření, běžná, uzavření
uc01id | C(9) | Účet | Identifikátor účtu účetnictví | Identifikátor účtu
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
uc03mesic | C(2) | Měsíc | Měsíc, ve kterém došlo k pohybu | Měsíc, ve kterém došlo k pohybu
uc37id | C(6) | Období | Identifikace účetního období | Identifikace účetního období
uc03mdr | N(20,4) | Má dáti | Obrat strany MD | Obrat strany MD realizovaný
uc03dalr | N(20,4) | Dal | Obrat strany Dal | Obrat strany Dal realizovaný
uc03ksvyk | N(20,4) | Konečný stav | Konečný stav účtu |
uc03psvyk | N(20,4) | uc03psvyk |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Měsíční obrat - je v měně | UCOBRTAB oc01id | 1,1 : 0,M | OCMENA oc01id |
Měsíční obrat - se vztahuje k účetnímu období | UCOBRTAB uc37id | 1,1 : 0,M | UCOBDOBI uc37id |

Indexy

Název | Primární | Výraz | Popis
ix_UCOBRTAB_ucobrt1 | P | uc03druh, uc03rok, uc03faze, uc01id, sp10idzak, sp11idzak, sp20idzak, oc01id, uc03mesic | Rok + číslo účtu + selektory + měsíc
ix_UCOBRTAB_uc37id |  | uc37id | Identifikace účetního období
ix_UCOBRTAB_uc03rok |  | uc03rok | Rok, ve kterém došlo k pohybu
ix_UCOBRTAB_uc03mesic |  | uc03mesic | Měsíc, ve kterém došlo k pohybu
ix_UCOBRTAB_uc01id |  | uc01id | Identifikátor účtu
ix_UCOBRTAB_oc01id |  | oc01id | Kód měny - oceňovací jednotky.
ix_UCOBRTAB_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_UCOBRTAB_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_UCOBRTAB_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_UCOBRTAB_ucobrt2 |  | uc01id, uc03rok, uc03mesic, uc03faze | Ucet+rok+mesic
ix_UCOBRTAB_ucobr3 |  |  |
ix_UCOBRTAB_ucobrt4 |  | uc01id, sp11idzak, uc03rok, uc03mesic, uc03faze | ucet+selektor+rok+mesic
ix_UCOBRTAB_ucobrt5 |  | sp11idzak, uc03mesic |
ix_UCOBRTAB_ucobrt6 |  | uc03rok, uc03mesic, uc03faze, uc01id | rok+mesic+ucet+mena
ix_UCOBRTAB_ucobrt7 |  | uc01id, sp10idzak, sp11idzak, sp20idzak | uc01id+sp11idzak
ix_UCOBRTAB_ucobrt8 |  | uc03rok, uc03mesic, uc01id, sp11idzak | Období, účet a selektor


UCPRCSA2 Saldokonto do data

Atributy

Atribut | Typ | Návěští | Message | Popis
uc15parid | C(14) | IDP | Identifikace párování | Identifikace párování
uc01id | C(9) | Účet | Identifikátor účtu účetnictví | Identifikátor účtu
uc15hodnot | N(20,4) | uc15hodnot |  |
uc28 | C(12) | uc28 | Jednoznačná časová identifikace | Jednoznačná časová identifikace

Indexy

Název | Primární | Výraz | Popis
ix_UCPRCSA2_ucprcsal |  | uc15parid, uc01id |
ix_UCPRCSA2_uc01id |  | uc01id | Identifikátor účtu
ix_UCPRCSA2_uc15hodnot |  | uc15hodnot |
ix_UCPRCSA2_uc15hodabs |  |  |


UCPRCSAL Saldokontní hodnota účetníctví

Atributy

Atribut | Typ | Návěští | Message | Popis
uc15parid | C(14) | IDP | Identifikace párování | Identifikace párování
uc01id | C(9) | Účet | Identifikátor účtu účetnictví | Identifikátor účtu
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
uc15hodnot | N(20,4) | uc15hodnot |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Saldokontní hodnota účetníctví - má účet v rozvrhu | UCPRCSAL uc01id | 1,1 : 0,M | UCROZVRH uc01id |

Indexy

Název | Primární | Výraz | Popis
ix_UCPRCSAL_ucprcsal | P | uc15parid, uc01id |
ix_UCPRCSAL_uc15parid |  | uc15parid | Identifikace párování
ix_UCPRCSAL_uc01id |  | uc01id | Identifikátor účtu
ix_UCPRCSAL_uc15hodnot |  | uc15hodnot |
ix_UCPRCSAL_uc15hodabs |  |  |


UCRADEK Řádek výkazu

Atributy

Atribut | Typ | Návěští | Message | Popis
vs01id | C(6) | vs01id |  |
vs02id | C(6) | vs02id |  |
vs02nazev | C(60) | vs02nazev |  |
vs02popis | M | vs02popis |  |
vs00poradi | N(5,0) | vs00poradi |  |
vs00typzaz | N(1,0) | vs00typzaz |  |
vs00prekr1 | N(1,0) | vs00prekr1 |  |
uc01id | C(9) | Účet | Identifikátor účtu účetnictví | Identifikátor účtu
uc01id_m | M | uc01id_m |  |
uc01strana | N(1,0) | uc01strana | Strana účtu MD/Dal | Strana účtu MD/Dal
vs00hloubk | N(1,0) | vs00hloubk |  |
vs00plan | N(1,0) | vs00plan | Spočítat plán nebo skutečnost |
vs00dyn1 | N(1,0) | vs00dyn1 |  |
vs00prekr2 | N(1,0) | vs00prekr2 |  |
sp11id_m | M | sp11id_m |  |
vs00dyn2 | N(1,0) | vs00dyn2 |  |
vs00obdobi | N(1,0) | vs00obdobi |  |
vs00dyn5 | N(1,0) | vs00dyn5 |  |
vs00od | C(10) | vs00od |  |
vs00do | C(10) | vs00do |  |
vs00po | C(10) | vs00po |  |
vs00zdata | N(1,0) | vs00zdata |  |
vs00prekr6 | N(1,0) | vs00prekr6 |  |
vs00typho2 | N(1,0) | vs00typho2 |  |
vs00delit | C(20) | vs00delit |  |
vs00excel | M | vs00excel |  |
vs00tucne | N(1,0) | vs00tucne |  |
vs00ital | N(1,0) | vs00ital |  |
vs00hide | N(1,0) | vs00hide |  |
vs00format | M | vs00format |  |
vs00negace | N(1,0) | vs00negace |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Řádek výkazu - patří listu | UCRADEK vs01id | 1,1 : 0,M s rušením | UCLIST vs01id |
Buňka výkazu - patří řádku | UCBUNKA vs01id vs02id | 1,1 : 0,M | UCRADEK vs01id vs02id |

Indexy

Název | Primární | Výraz | Popis
ix_UCRADEK_vsradek | P | vs01id, vs02id |
ix_UCRADEK_vs01id |  | vs01id |


UCROZVRH Účet z rozvrhu

Popis

Objektem typu UCROZVRH je každý záznam, který obsahuje jednotlivé účty účtového rozvrhu uživatele.

Atributy

Atribut | Typ | Návěští | Message | Popis
uc01id | C(9) | Účet | Identifikátor účtu účetnictví | Identifikátor účtu
uc01strana | N(1,0) | uc01strana | Strana účtu MD/Dal | Strana účtu MD/Dal
uc01saldo | N(1,0) | uc01saldo | Jedná se o saldokontní účet Ano/Ne | Jedná se o saldokontní účet Ano/Ne
uc01obratz | N(1,0) | Obrat v ZM | Sledovat obrat v zahraniční měně Ano/Ne | Sledovat obrat v zahraniční měně Ano/Ne
uc01povobz | N(1,0) | Povinná částka v ZM | Povinnost uvádět nenulovou částku v ZM v událostech účetnictví pro účet Ano/Ne | Povinnost uvádět nenulový obrat v ZM v událostech účetnictví pro účet Ano/Ne
uc01datzac | D | uc01datzac | Začátek platnosti účtu | Začátek platnosti účtu
uc01datkon | D | uc01datkon | Konec platnosti účtu | Konec platnosti účtu
uc01koment | M | uc01koment | Komentář upřesňující používání účtu | Komentář upřesňující používání účtu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
uc01obrobc | N(1,0) | Obrat obchodního selektoru | Sledovat obrat obchodního selektoru Ano/Ne | Sledovat obrat obchodního selektoru Ano/Ne
uc01obrorg | N(1,0) | Obrat organizačního selektoru | Sledovat obrat organizačního selektoru Ano/Ne | Sledovat obrat organizačního selektoru Ano/Ne
uc01obrtv | N(1,0) | Obrat tech.-věcného selektoru | Sledovat obrat technicko-věcného selektoru Ano/Ne | Sledovat obrat technicko-věcného selektoru Ano/Ne
uc01povobc | N(1,0) | Povinný OBS | Povinnost uvádět obchodní selektor v událostech účetnictví pro účet Ano/Ne | Povinnost uvádět obchodní selektor v události účetnictví pro účet
uc01povorg | N(1,0) | Povinný ORS | Povinnost uvádět organizační selektor v událostech účetnictví pro účet Ano/Ne | Povinnost uvádět organizační selektor v událostech účetnictví pro účet
uc01povtv | N(1,0) | Povinný TVS | Povinnost uvádět technicko-věcný selektor v událostech účetnictví pro účet Ano/Ne | Povinnost uvádět technicko-věcný selektor v událostech účetnictví pro účet

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Účet z rozvrhu - někdo zapsal | UCROZVRH bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Uplatnění předmětu ZDP - definuje účetní účet | DPZPTU uc01id | 1,1 : 0,M | UCROZVRH uc01id |
Účetní událost - patří účtu z rozvrhu | UCDENIK uc01id | 1,1 : 0,M | UCROZVRH uc01id |
Cizí popis účtu - patří účtu | UCROZVRN uc01id | 1,1 : 1,M s rušením | UCROZVRH uc01id |
Sazba daně z přidané hodnoty - odpovídá účtu účetnictví pro nápočet | DPZPS uc01id | 0,1 : 0,M | UCROZVRH uc01id |
Sazba daně z přidané hodnoty - odpovídá účtu účetnictví pro odpočet | DPZPS uc01id2 | 0,1 : 0,M | UCROZVRH uc01id |
Událost plateb - byla zaúčtována na účetní účet | PLUDA uc01id | 0,1 : 0,M | UCROZVRH uc01id |
Účet/pokladna (vlastní) - odpovídá účtu z účtového rozvrhu | PLUP uc01id | 0,1 : 0,M | UCROZVRH uc01id |
Saldokontní hodnota účetníctví - má účet v rozvrhu | UCPRCSAL uc01id | 1,1 : 0,M | UCROZVRH uc01id |
Účet a strana k druhu události - váže na účtový rozvrh | MZDRUCET uc01id | 0,1 : 0,M | UCROZVRH uc01id |

Indexy

Název | Primární | Výraz | Popis
ix_UCROZVRH_ucrozvrh1 |  |  |
ix_UCROZVRH_uc01id | P | uc01id | Identifikátor účtu
ix_UCROZVRH_uc01strana |  | uc01strana | Strana účtu MD/Dal
ix_UCROZVRH_uc01saldo |  | uc01saldo | Jedná se o saldokontní účet Ano/Ne
ix_UCROZVRH_uc01datzac |  | uc01datzac | Začátek platnosti účtu
ix_UCROZVRH_uc01datkon |  | uc01datkon | Konec platnosti účtu
ix_UCROZVRH_bw01uziv |  | bw01uziv | Identifikace uživatele systému


UCROZVRN Cizí popis účtu

Popis

Relace do UCROZVRN má mít Rušit podle relace = Ano

Objektem typu UCROZVRN je každý záznam, který obsahuje cizojazyčný popis účtu.
Pro každý účet v účtovém rozvrhu je možné zapsat do této entity cizojazyčné popisy účtu. Každému popisu je přiřazen stát, pro který uvedený popis platí.

Atributy

Atribut | Typ | Návěští | Message | Popis
uc01id | C(9) | Účet | Identifikátor účtu účetnictví | Identifikátor účtu
sp38id | C(3) | Jazyk | Identifikace jazyka | Identifikace jazyka
uc04popuct | C(40) | Text | Cizojazyčný popis účtu. | Cizojazyčný popis účtu.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Cizí popis účtu - je v jazyce | UCROZVRN sp38id | 1,1 : 0,M s rušením | SPJAZYK sp38id |
Cizí popis účtu - patří účtu | UCROZVRN uc01id | 1,1 : 1,M s rušením | UCROZVRH uc01id |

Indexy

Název | Primární | Výraz | Popis
ix_UCROZVRN_uccizjaz1 | P | uc01id, sp38id | účet + stát
ix_UCROZVRN_uc01id |  | uc01id | Identifikátor účtu
ix_UCROZVRN_sp38id |  | sp38id | Identifikace jazyka
ix_UCROZVRN_uc04popuct |  | uc04popuct | Cizojazyčný popis účtu.


UCSLOUP Sloupec výkazu

Atributy

Atribut | Typ | Návěští | Message | Popis
vs01id | C(6) | vs01id |  |
vs03id | C(6) | vs03id |  |
vs03nazev | C(60) | vs03nazev |  |
vs03popis | M | vs03popis |  |
vs00poradi | N(5,0) | vs00poradi |  |
vs00typzaz | N(1,0) | vs00typzaz |  |
vs00prekr1 | N(1,0) | vs00prekr1 |  |
uc01id | C(9) | Účet | Identifikátor účtu účetnictví | Identifikátor účtu
uc01id_m | M | uc01id_m |  |
uc01strana | N(1,0) | uc01strana | Strana účtu MD/Dal | Strana účtu MD/Dal
vs00plan | N(1,0) | vs00plan | Spočítat plán nebo skutečnost |
vs00dyn1 | N(1,0) | vs00dyn1 |  |
vs00prekr2 | N(1,0) | vs00prekr2 |  |
sp11id_m | M | sp11id_m |  |
vs00dyn2 | N(1,0) | vs00dyn2 |  |
vs00obdobi | N(1,0) | vs00obdobi |  |
vs00dyn5 | N(1,0) | vs00dyn5 |  |
vs00od | C(10) | vs00od |  |
vs00do | C(10) | vs00do |  |
vs00po | C(10) | vs00po |  |
vs00zdata | N(1,0) | vs00zdata |  |
vs00prekr6 | N(1,0) | vs00prekr6 |  |
vs00typho2 | N(1,0) | vs00typho2 |  |
vs00delit | C(20) | vs00delit |  |
vs00excel | M | vs00excel |  |
vs00tucne | N(1,0) | vs00tucne |  |
vs00ital | N(1,0) | vs00ital |  |
vs00hide | N(1,0) | vs00hide |  |
vs00format | M | vs00format |  |
vs00negace | N(1,0) | vs00negace |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Sloupec výkazu - patří k listu | UCSLOUP vs01id | 1,1 : 0,M s rušením | UCLIST vs01id |
Buňka výkazu - patří sloupci | UCBUNKA vs01id vs03id | 1,1 : 0,M | UCSLOUP vs01id vs03id |

Indexy

Název | Primární | Výraz | Popis
ix_UCSLOUP_vssloup | P | vs01id, vs03id |
ix_UCSLOUP_vs01id |  | vs01id |


UCVAZLIS Navázání listů výkazu

Atributy

Atribut | Typ | Návěští | Message | Popis
vs07 | C(12) | vs07 |  |
vs01id | C(6) | vs01id |  |
vs08puvpor | N(3,0) | vs08puvpor |  |
vs00poradi | N(5,0) | vs00poradi |  |
vs08nazev | C(60) | vs08nazev |  |
vs08popis | M | vs08popis |  |
vs08par1 | C(40) | vs08par1 |  |
vs08par2 | C(40) | vs08par2 |  |
vs08par3 | C(40) | vs08par3 |  |
vs08par4 | C(40) | vs08par4 |  |
vs08par5 | C(40) | vs08par5 |  |
vs08npar1 | C(40) | vs08npar1 |  |
vs08npar2 | C(40) | vs08npar2 |  |
vs08npar3 | C(40) | vs08npar3 |  |
vs08npar4 | C(40) | vs08npar4 |  |
vs08npar5 | C(40) | vs08npar5 |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Navázání listů výkazu - má list | UCVAZLIS vs01id | 1,1 : 0,M | UCLIST vs01id |
Navázání listů výkazu - je na výkazu | UCVAZLIS vs07 | 1,1 : 0,M | UCVYKAZ vs07 |

Indexy

Název | Primární | Výraz | Popis
ix_UCVAZLIS_vsvazlis | P | vs07, vs01id, vs08puvpor |


UCVAZVYK Vazba výkazů

Atributy

Atribut | Typ | Návěští | Message | Popis
vs07 | C(12) | vs07 |  |
vs071 | C(12) | vs071 |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vazba výkazů - má výkaz | UCVAZVYK vs07 | 1,1 : 0,M | UCVYKAZ vs07 |
Vazba výkazů - má druhý výkaz | UCVAZVYK vs071 | 1,1 : 0,M | UCVYKAZ vs07 |

Indexy

Název | Primární | Výraz | Popis
ix_UCVAZVYK_vsvakvyz | P | vs07, vs071 |
ix_UCVAZVYK_vs07 |  | vs07 |
ix_UCVAZVYK_vs071 |  | vs071 |


UCVYKAZ Definice výkazu

Atributy

Atribut | Typ | Návěští | Message | Popis
vs07 | C(12) | vs07 |  |
vs07nazev | C(40) | Název | Název výkazu |
vs09id | C(6) | vs09id |  |
vs07soubor | C(100) | vs07soubor |  |
vs07popis | M | Popis | Popis výkazu |
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
vs08npar1 | C(40) | vs08npar1 |  |
vs08npar2 | C(40) | vs08npar2 |  |
vs08npar3 | C(40) | vs08npar3 |  |
vs08npar4 | C(40) | vs08npar4 |  |
vs08npar5 | C(40) | vs08npar5 |  |
vs07rewrit | N(1,0) | vs07rewrit |  |
uc24heslo | C(20) | uc24heslo |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Definice výkazu - zapsal uživatel | UCVYKAZ bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Definice výkazu - má druh výkazu | UCVYKAZ vs09id | 1,1 : 0,M | UCDRUHV vs09id |
Navázání listů výkazu - je na výkazu | UCVAZLIS vs07 | 1,1 : 0,M | UCVYKAZ vs07 |
Vazba výkazů - má výkaz | UCVAZVYK vs07 | 1,1 : 0,M | UCVYKAZ vs07 |
Vazba výkazů - má druhý výkaz | UCVAZVYK vs071 | 1,1 : 0,M | UCVYKAZ vs07 |

Indexy

Název | Primární | Výraz | Popis
ix_UCVYKAZ_vs07 | P | vs07 |
ix_UCVYKAZ_vs09id |  | vs09id |


UCHLAKNI Záznam v hlavní knize účtu

Popis

Hlavní kniha účtu

Atributy

Atribut | Typ | Návěští | Message | Popis
uc03rok | C(4) | Rok | Rok ve kterém došlo k pohybu | Rok, ve kterém došlo k pohybu
uc03mesic | C(2) | Měsíc | Měsíc, ve kterém došlo k pohybu | Měsíc, ve kterém došlo k pohybu
uc03faze | N(1,0) | Fáze | Fáze události v účetním období - otevření, běžná, uzavření | Fáze události v účetním období - otevření, běžná, uzavření
uc01id | C(9) | Účet | Identifikátor účtu účetnictví | Identifikátor účtu
uc03druh | N(1,0) | Druh | Druh informace skutečnost, plán ... | Druh informace skutečnost, plán ...
uc37id | C(6) | Období | Identifikace účetního období | Identifikace účetního období
uc03mdr | N(20,4) | Má dáti | Obrat strany MD | Obrat strany MD realizovaný
uc03dalr | N(20,4) | Dal | Obrat strany Dal | Obrat strany Dal realizovaný
uc03ksvyk | N(20,4) | Konečný stav | Konečný stav účtu |
uc03psvyk | N(20,4) | uc03psvyk |  |
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Záznam v hlavní knize účtu - se vztahuje k účetnímu období | UCHLAKNI uc37id | 1,1 : 0,M | UCOBDOBI uc37id |

Indexy

Název | Primární | Výraz | Popis
ix_UCHLAKNI_ucobrt6 |  | uc03rok, uc03mesic, uc03faze, uc01id | rok+mesic+ucet+mena
ix_UCHLAKNI_uc37id |  | uc37id | Identifikace účetního období
ix_UCHLAKNI_uc01id |  | uc01id | Identifikátor účtu
ix_UCHLAKNI_ucobrt2 |  | uc01id, uc03rok, uc03mesic, uc03faze | Ucet+rok+mesic


Tabulky UT...

UTARDATC | Obsah archivovaného souboru
UTARDATF | Archivovaný soubor
UTARDATP | Cesta uloženého souboru archivace
UTARSKP | Skupina archivace
UTARSKPA | Adresář archivovaných souborů skupiny archivace
UTARSKPV | Vazba skupin archivace

Viz.také

UTARDATC Obsah archivovaného souboru | UTARDATF Archivovaný soubor | UTARDATP Cesta uloženého souboru archivace | UTARSKP Skupina archivace | UTARSKPA Adresář archivovaných souborů skupiny archivace | UTARSKPV Vazba skupin archivace


UTARDATC Obsah archivovaného souboru

Popis

Obsah archivovaného souboru

Atributy

Atribut | Typ | Návěští | Message | Popis
ut06datzal | T | ut06datzal | Datum založení | Datum založení
ut05 | C(12) | ut05 | Jednoznačná časová identifikace - soubor | Jednoznačná časová identifikace - soubor
ut06fildat | T | ut06fildat | Datum a čas archivovaného souboru | Datum a čas archivovaného souboru
ut06filsiz | N(6,0) | ut06filsiz | Velikost archivovaného souboru | Velikost archivovaného souboru
ut06filsic | N(6,0) | ut06filsic | Velikost komprivovaného souboru | Velikost komprivovaného souboru
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
ut06conten | M | ut06conten | Obsah archivovaného souboru | Obsah archivovaného souboru

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Obsah archivovaného souboru - je obsahem souboru | UTARDATC ut05 | 1,1 : 0,M s rušením | UTARDATF ut05 |
Obsah archivovaného souboru - založil uživatel | UTARDATC bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_UTARDATC_ut05 |  | ut05 | Jednoznačná časová identifikace - soubor
ix_UTARDATC_bw01uziv |  | bw01uziv | Identifikace uživatele systému


UTARDATF Archivovaný soubor

Popis

Archivovaný soubor

Atributy

Atribut | Typ | Návěští | Message | Popis
ut05 | C(12) | ut05 | Jednoznačná časová identifikace - soubor | Jednoznačná časová identifikace - soubor
ut04 | C(12) | ut04 | Jednoznačná časová identifikace - cesta | Jednoznačná časová identifikace - cesta
sp57id | C(6) | Druh | Identifikátor druhu dokumentu | Identifikátor druhu dokumentu
ut05name | M | ut05name | Název souboru archivace | Název souboru archivace
ut05pockop | N(3,0) | ut05pockop | Počet ukládaných archivních kopií souboru (-1=neomezený počet kopií) | Počet ukládaných archivních kopií souboru (-1=neomezený počet kopií)

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Archivovaný soubor - je v adresáři | UTARDATF ut04 | 1,1 : 0,M s rušením | UTARDATP ut04 |
Archivovaný soubor - je druhu | UTARDATF sp57id | 1,1 : 0,M | SPDOKTYP sp57id |
Obsah archivovaného souboru - je obsahem souboru | UTARDATC ut05 | 1,1 : 0,M s rušením | UTARDATF ut05 |

Indexy

Název | Primární | Výraz | Popis
ix_UTARDATF_ut05 | P | ut05 | Jednoznačná časová identifikace - soubor
ix_UTARDATF_ut04 |  | ut04 | Jednoznačná časová identifikace - cesta
ix_UTARDATF_sp57id |  | sp57id | Identifikátor druhu dokumentu


UTARDATP Cesta uloženého souboru archivace

Popis

Cesta uloženého souboru archivace

Atributy

Atribut | Typ | Návěští | Message | Popis
ut04 | C(12) | ut04 | Jednoznačná časová identifikace - cesta | Jednoznačná časová identifikace - cesta
ut04path | M | ut04path | Název cesty souboru archivace | Název cesty souboru archivace
ut04patdes | C(40) | ut04patdes | Popis adresáře ve stromu | Popis adresáře ve stromu
ut04datakt | T | ut04datakt | Datum archivace |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Archivovaný soubor - je v adresáři | UTARDATF ut04 | 1,1 : 0,M s rušením | UTARDATP ut04 |

Indexy

Název | Primární | Výraz | Popis
ix_UTARDATP_ut04 | P | ut04 | Jednoznačná časová identifikace - cesta


UTARSKP Skupina archivace

Popis

Skupina archivace

Atributy

Atribut | Typ | Návěští | Message | Popis
ut01id | C(6) | Skupina | Identifikace skupiny | Identifikace skupiny
ut01nazskp | C(40) | Název skupiny | Název skupiny | Název skupiny
bw87id | C(6) | Počítač | Identifikace počítače v BM | Identifikace počítače v BM
sp57id | C(6) | Druh | Identifikátor druhu dokumentu | Identifikátor druhu dokumentu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
spf8id | C(6) | Typ | Identifikátor typu události komponenty | Identifikátor typu události komponenty
ut01aktiv | N(1,0) | Aktivní | Skupina je aktivní Ano/Ne (pro neaktivní skupinu se neprovádí archivace) | Skupina je aktivní Ano/Ne (pro neaktivní skupinu se neprovádí archivace)
ut01nabiz | N(1,0) | Nabízet | Nabízená skupina Ano/Ne (z nabízených skupin se vybírá při startu archivace) | Nabízená skupina Ano/Ne (z nabízených skupin se vybírá při startu archivace)
ut01pockop | N(3,0) | Počet kopií | Počet ukládaných archivních kopií souborů ve skupině (-1=neomezený počet kopií) | Počet ukládaných archivních kopií souborů ve skupině (-1=neomezený počet kopií)
ut01prefix | M | Adresář-A | Adresář archivu, do kterého má být archiv uložen | Doplnění vrcholvého uzlu ve stromu stromu archivu
ut01koment | M | Poznámka | Poznámka | Poznámka
ut01path0 | M | Adresář-* | Kořenový adresář (*) doplněný do popisů adresářů | Kořenový adresář (*) doplněný do popisů adresářů
ut01textv | C(40) | Text | Text události vývěsky | Text události vývěsky

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Skupina archivace - ukládá dokumenty s druhem | UTARSKP sp57id | 1,1 : 0,M | SPDOKTYP sp57id |
Skupina archivace - může být použita při spuštění z počítače | UTARSKP bw87id | 1,1 : 0,M | BWPRINMC bw87id |
Skupina archivace - zapisuje protokol na téma vývěsky | UTARSKP sp07idtyp sp06idsubs | 0,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Skupina archivace - zapisuje protokol na typ události | UTARSKP spf8id | 1,1 : 0,M | SPTYPUD spf8id |
Adresář archivovaných souborů skupiny archivace - je adresářem skupiny | UTARSKPA ut01id | 1,1 : 0,M | UTARSKP ut01id |
Vazba skupin archivace - určuje nadřízenou skupinu archivace | UTARSKPV ut01id | 1,1 : 0,M | UTARSKP ut01id |
Vazba skupin archivace - určuje podřízenou skupinu archivace | UTARSKPV ut01id2 | 1,1 : 0,M | UTARSKP ut01id |

Indexy

Název | Primární | Výraz | Popis
ix_UTARSKP_ut01id | P | ut01id | Identifikace skupiny
ix_UTARSKP_ut01nazskp |  | ut01nazskp | Název skupiny
ix_UTARSKP_bw87id |  | bw87id | Identifikace počítače v BM
ix_UTARSKP_sp57id |  | sp57id | Identifikátor druhu dokumentu
ix_UTARSKP_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_UTARSKP_spf8id |  | spf8id | Identifikátor typu události komponenty


UTARSKPA Adresář archivovaných souborů skupiny archivace

Popis

Adresář archivovaných souborů skupiny archivace

Atributy

Atribut | Typ | Návěští | Message | Popis
ut02 | C(12) | ut02 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
ut01id | C(6) | Skupina | Identifikace skupiny | Identifikace skupiny
ut02aktiv | N(1,0) | Aktivní | Definice je aktivní Ano/Ne (pro neaktivní se neprovádí archivace) | Definice je aktivní Ano/Ne (pro neaktivní se neprovádí archivace)
ut02path | M | Adresář | Archivovaný adresář (jeho název může začínat makrem %userprofile% např. %userprofile%\dokumenty) | Archivovaný adresář
ut02patdes | C(40) | Popis ve stromu | Popis adresáře ve stromu | Popis adresáře ve stromu
ut02koment | M | Poznámka | Poznámka | Poznámka
ut02includ | M | Archivovat soubory | Seznam archivovaných souborů | Seznam archivovaných souborů
ut02exclud | M | Nearchivovat soubory | Seznam nearchivovaných souborů | Seznam nearchivovaných souborů
ut02incsub | N(1,0) | Včetně podadresářů | Archivovat adresář včetně podadresářů Ano/Ne | Archivovat adresář včetně podadresářů

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Adresář archivovaných souborů skupiny archivace - je adresářem skupiny | UTARSKPA ut01id | 1,1 : 0,M | UTARSKP ut01id |

Indexy

Název | Primární | Výraz | Popis
ix_UTARSKPA_ut02 | P | ut02 | Jednoznačná časová identifikace
ix_UTARSKPA_ut01id |  | ut01id | Identifikace skupiny


UTARSKPV Vazba skupin archivace

Popis

Vazba skupin archivace

Atributy

Atribut | Typ | Návěští | Message | Popis
ut01id | C(6) | Skupina | Identifikace skupiny | Identifikace skupiny
ut01id2 | C(6) | Skupina | Identifikace podřízené skupiny | Identifikace podřízené skupiny

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vazba skupin archivace - určuje nadřízenou skupinu archivace | UTARSKPV ut01id | 1,1 : 0,M | UTARSKP ut01id |
Vazba skupin archivace - určuje podřízenou skupinu archivace | UTARSKPV ut01id2 | 1,1 : 0,M | UTARSKP ut01id |

Indexy

Název | Primární | Výraz | Popis
ix_UTARSKPV_utarskpv | P | ut01id, ut01id2 | PI - ut01id+ut01id2
ix_UTARSKPV_ut01id |  | ut01id | Identifikace skupiny
ix_UTARSKPV_ut01id2 |  | ut01id2 | Identifikace podřízené skupiny


Tabulky VK...

VKBUNKA | Buňka
VKDOTAZ | Vstupní dotaz spuštěného výkazu
VKDOTAZP | Vstupní proměnné výkazu
VKDRUHV | Druh výkazu
VKFCE | Funkce pro výkazy
VKFCEP | Parametr funkce výkazů
VKFORMAT | Formát buňky ve výkazu
VKHARDEF | Paleta zobrazování popisek harmonogramu
VKKTPOLE | Popis pole kontingenční tabulky
VKLIST | List výkazu
VKRADEK | Řádek
VKSABLON | Šablona listu výkazu
VKSLOUP | Sloupec
VKTEMRAD | Pracovní řádek listu
VKVYKAZ | Výkaz
VKVYKLIS | Vazba výkazu a listu
VKVZOR | Vzor listu
VKVZORV | Výraz vzoru listu

Viz.také

VKBUNKA Buňka | VKDOTAZ Vstupní dotaz spuštěného výkazu | VKDOTAZP Vstupní proměnné výkazu | VKDRUHV Druh výkazu | VKFCE Funkce pro výkazy | VKFCEP Parametr funkce výkazů | VKFORMAT Formát buňky ve výkazu | VKLIST List výkazu | VKRADEK Řádek | VKSABLON Šablona listu výkazu | VKSLOUP Sloupec | VKTEMRAD Pracovní řádek listu | VKVYKAZ Výkaz | VKVYKLIS Vazba výkazu a listu | VKVZOR Vzor listu | VKVZORV Výraz vzoru listu | VKHARDEF Paleta zobrazování popisek harmonogramu | VKKTPOLE Popis pole kontingenční tabulky


VKBUNKA Buňka

Popis

Buňka

Atributy

Atribut | Typ | Návěští | Message | Popis
vk03id | C(6) | List | Identifikace listu | Identifikace listu
vk04id | C(6) | Sloupec | Identifikace sloupce | Identifikace sloupce
vk05id | C(6) | Řádek | Identifikace řádku | Identifikace řádku
vk06nazev | C(40) | Buňka | Název buňky | Název buňky
vk06param | M | Param. | Param. | Parametry buňky
vk06obvyr | N(1,0) | Obsah výrazu | Obsah výrazu | Obsah výrazu
vk06vyraz | M | Výraz | Výraz | Výraz
vk06koment | M | Pozn. | Poznámka | Poznámka
vk12id | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Buňka - patří k sloupci | VKBUNKA vk04id vk03id | 1,1 : 0,M s rušením | VKSLOUP vk04id vk03id |
Buňka - patří k řádku | VKBUNKA vk05id vk03id | 1,1 : 0,M s rušením | VKRADEK vk05id vk03id |
Buňka - používá formát | VKBUNKA vk12id | 1,1 : 0,M | VKFORMAT vk12id |

Indexy

Název | Primární | Výraz | Popis
ix_VKBUNKA_vkbunka | P | vk03id, vk04id, vk05id | PI - vk03id+vk04id+vk05id
ix_VKBUNKA_vksloup |  | vk04id, vk03id | PI - vk04id+vk03id
ix_VKBUNKA_vkradek |  | vk05id, vk03id | PI - vk05id+vk03id
ix_VKBUNKA_vk12id |  | vk12id | Identifikace formátu buňky


VKDOTAZ Vstupní dotaz spuštěného výkazu

Popis

Vstupní dotaz spuštěného výkazu

Atributy

Atribut | Typ | Návěští | Message | Popis
vk17id | C(6) | Dotaz | Identifikace dotazu | Identifikace dotazu
vk17nazev | C(40) | Název dotazu | Název dotazu | Název dotazu
vk17koment | M | Poznámka | Poznámka | Poznámka
vk17okleft | N(4,0) | vk17okleft | Umístění tlačítka OK - LEFT | Umístění tlačítka OK - LEFT
vk17oktop | N(4,0) | vk17oktop | Umístění tlačítka OK - TOP | Umístění tlačítka OK - TOP
vk17sttop | N(4,0) | vk17sttop | Umístění tlačítka STORNO - TOP | Umístění tlačítka STORNO - TOP
vk17stleft | N(4,0) | vk17stleft | Umístění tlačítka STORNO - LEFT | Umístění tlačítka STORNO - LEFT
vk17height | N(4,0) | vk17height | Umístění okna - HEIGHT | Umístění okna - HEIGHT
vk17width | N(4,0) | vk17width | Umístění okna - WIDTH | Umístění okna - WIDTH
vk17kod | M | Kód | Kód provedený po vstupu dotazu | Kód provedený po vstupu dotazu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Výkaz - má určený vstup | VKVYKAZ vk17id | 1,1 : 0,M | VKDOTAZ vk17id |
Vstupní proměnné výkazu - patří k dotazu | VKDOTAZP vk17id | 1,1 : 0,M s rušením | VKDOTAZ vk17id |

Indexy

Název | Primární | Výraz | Popis
ix_VKDOTAZ_vk17id | P | vk17id | Identifikace dotazu
ix_VKDOTAZ_vk17nazev |  | vk17nazev | Název dotazu


VKDOTAZP Vstupní proměnné výkazu

Popis

Vstupní proměnné výkazu

Atributy

Atribut | Typ | Návěští | Message | Popis
vk09id | C(12) | vk09id | Jednoznačná časová identifikace | Jednoznačná časová identifikace
vk17id | C(6) | Dotaz | Identifikace dotazu | Identifikace dotazu
vk09cisprm | C(4) | Proměnná | Číslo proměnné definice výkazu | Číslo proměnné definice výkazu
vk09nazev | C(10) | Název proměnné | Název proměnné výkazu | Název proměnné výkazu
vk09typ | N(1,0) | Typ | Typ proměnné výkazu | Typ proměnné výkazu
vk09delka | N(3,0) | Délka proměnné | Délka proměnné výkazu | Délka proměnné výkazu
vk09deseti | N(2,0) | Počet desetin | Počet desetin proměnné výkazu | Počet desetin proměnné výkazu
vk09label | C(30) | Návěští | Návěští proměnné výkazu | Návěští proměnné výkazu
vk09trida | N(1,0) | Třída | Třída ovládacího prvku | Třída ovládacího prvku
vk09left | N(4,0) | vk09left | Umístění LEFT | Umístění LEFT
vk09top | N(4,0) | vk09top | Umístění TOP | Umístění TOP
vk09height | N(4,0) | vk09height | Umístění HEIGHT | Umístění HEIGHT
vk09width | N(4,0) | vk09width | Umístění WIDTH | Umístění WIDTH
vk09latop | N(4,0) | vk09latop | Umístění - LABEL TOP | Umístění - LABEL TOP
vk09laleft | N(4,0) | vk09laleft | Umístění - LABEL LEFT | Umístění - LABEL LEFT
vk09pict | C(60) | vk09pict | Text pro zaškrtávací políčko nebo seznam hodnot pro překryvný seznam oddělených čárkou |
vk09vyraz | M | vk09vyraz | Výraz proměnné výkazu | Výraz proměnné výkazu
vk09vstup | N(1,0) | Naplnění | Způsob naplnění proměnné - vstupem nebo výpočtem | Způsob naplnění proměnné - vstupem nebo výpočtem
vk09init | C(60) | Inicializace | Inicializační hodnota proměnné výkazu | Inicializační hodnota proměnné výkazu
bw02krok | C(6) | Činnost | Identifikace činnosti | Identifikace činnosti

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vstupní proměnné výkazu - patří k dotazu | VKDOTAZP vk17id | 1,1 : 0,M s rušením | VKDOTAZ vk17id |

Indexy

Název | Primární | Výraz | Popis
ix_VKDOTAZP_vk09id | P | vk09id | Jednoznačná časová identifikace
ix_VKDOTAZP_vk17id |  | vk17id | Identifikace dotazu


VKDRUHV Druh výkazu

Popis

Druh výkazu

Atributy

Atribut | Typ | Návěští | Message | Popis
vk02id | C(6) | Druh | Identifikace druhu výkazu | Identifikace druhu výkazu
vk02nazdru | C(40) | Název druhu výkazu | Název druhu výkazu | Název druhu výkazu
vk02koment | M | Poznámka | Poznámka k druhu výkazu | Poznámka k druhu výkazu
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh výkazu - založil uživatel | VKDRUHV bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Výkaz - je druhu | VKVYKAZ vk02id | 1,1 : 0,M | VKDRUHV vk02id |

Indexy

Název | Primární | Výraz | Popis
ix_VKDRUHV_vk02id | P | vk02id | Identifikace druhu výkazu
ix_VKDRUHV_vk02nazdru |  | vk02nazdru | Název druhu výkazu
ix_VKDRUHV_bw01uziv |  | bw01uziv | Identifikace uživatele systému


VKFCE Funkce pro výkazy

Popis

Funkce pro výkazy

Atributy

Atribut | Typ | Návěští | Message | Popis
vk10id | C(8) | Funkce | Identifikátor funkce | Identifikátor funkce
vk10nazev | C(40) | Název funkce | Název funkce | Název funkce
vk10typ | N(1,0) | Typ | Typ hodnoty funkce | Typ hodnoty funkce
vk10kod | M | Kód | Kód funkce | Kód funkce
vk10templa | M | Template | Template funkce | Template funkce
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
vk10koment | M | Poznámka | Poznámka | Poznámka
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Funkce pro výkazy - založil uživatel | VKFCE bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Parametr funkce výkazů - patří k funkci | VKFCEP vk10id | 1,1 : 0,M s rušením | VKFCE vk10id |

Indexy

Název | Primární | Výraz | Popis
ix_VKFCE_vk10id | P | vk10id | Identifikátor funkce
ix_VKFCE_vk10nazev |  | vk10nazev | Název funkce
ix_VKFCE_bw01uziv |  | bw01uziv | Identifikace uživatele systému


VKFCEP Parametr funkce výkazů

Atributy

Atribut | Typ | Návěští | Message | Popis
vk10id | C(8) | Funkce | Identifikátor funkce | Identifikátor funkce
vk11porad | N(2,0) | Pořadí | Pořadí parametru | Pořadí parametru
vk11nazev | C(8) | Parametr | Název parametru | Název parametru
vk11popis | C(40) | Popis parametru | Popis parametru | Popis parametru
vk11typ | N(1,0) | Typ | Typ parametru | Typ parametru
vk11koment | M | Poznámka | Poznámka | Poznámka
vk11sezatr | M | Atribut | Název atributu pro seznam | Název atributu pro seznam
vk11ln | N(2,0) | Délka hodnoty | Délka hodnoty atributu pro seznam | Délka hodnoty atributu pro seznam

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametr funkce výkazů - patří k funkci | VKFCEP vk10id | 1,1 : 0,M s rušením | VKFCE vk10id |

Indexy

Název | Primární | Výraz | Popis
ix_VKFCEP_vkfcep | P | vk10id, vk11porad |
ix_VKFCEP_vk10id |  | vk10id | Identifikátor funkce


VKFORMAT Formát buňky ve výkazu

Popis

Formát buňky ve výkazu

Atributy

Atribut | Typ | Návěští | Message | Popis
vk12id | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk12nazev | C(40) | Název formátu | Název formátu buňky | Název formátu buňky
vk12font | C(50) | Font | Název fontu | Název fontu
vk12fonts | N(2,0) | Velikost | Velikost písma | Velikost písma
vk12bold | N(1,0) | vk12bold | Tučný text | Tučný text
vk12italic | N(1,0) | vk12italic | Text kurzívou | Text kurzívou
vk12ohran | N(1,0) | Ohraničení | Ohraničení | Ohraničení
vk12barva | N(2,0) | Barva | Barva zobrazení | Barva zobrazení
vk12koment | M | Poznámka | Poznámka | Poznámka
vk12numfor | C(20) | Formát čísel | Formát číselných hodnot | Formát číselných hodnot
vk12numzao | C(20) | Formát zaokrouhlených | Formát zaokrohlených číselných hodnot | Formát zaokrohlených číselných hodnot
vk12ohr1 | N(1,0) | vk12ohr1 | Levé ohraničení | Levé ohraničení
vk12ohr2 | N(1,0) | vk12ohr2 | Pravé ohraničení | Pravé ohraničení
vk12ohr3 | N(1,0) | vk12ohr3 | Horní ohraničení | Horní ohraničení
vk12ohr4 | N(1,0) | vk12ohr4 | Dolní ohraničení | Dolní ohraničení

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
List výkazu - používá formát | VKLIST vk12id | 1,1 : 0,M | VKFORMAT vk12id |
List výkazu - má formát prvního sloupce listu podle vzoru | VKLIST vk12id1 | 1,1 : 0,M | VKFORMAT vk12id |
List výkazu - má formát druhého sloupce listu podle vzoru | VKLIST vk12id2 | 1,1 : 0,M | VKFORMAT vk12id |
List výkazu - má formát třetího sloupce listu podle vzoru | VKLIST vk12id3 | 1,1 : 0,M | VKFORMAT vk12id |
List výkazu - má formát šestého sloupce listu podle vzoru | VKLIST vk12id6 | 1,1 : 0,M | VKFORMAT vk12id |
List výkazu - má formát čtvrtého sloupce listu podle vzoru | VKLIST vk12id4 | 1,1 : 0,M | VKFORMAT vk12id |
List výkazu - má formát pátého sloupce listu podle vzoru | VKLIST vk12id5 | 1,1 : 0,M | VKFORMAT vk12id |
List výkazu - má formát sedmého sloupce listu podle vzoru | VKLIST vk12id7 | 1,1 : 0,M | VKFORMAT vk12id |
List výkazu - má formát osmého sloupce listu podle vzoru | VKLIST vk12id8 | 1,1 : 0,M | VKFORMAT vk12id |
List výkazu - má formát devátého sloupce listu podle vzoru | VKLIST vk12id9 | 1,1 : 0,M | VKFORMAT vk12id |
Sloupec - používá formát | VKSLOUP vk12id | 1,1 : 0,M | VKFORMAT vk12id |
Řádek - používá formát | VKRADEK vk12id | 1,1 : 0,M | VKFORMAT vk12id |
Buňka - používá formát | VKBUNKA vk12id | 1,1 : 0,M | VKFORMAT vk12id |
Vzor listu - má formát prvního konstantního sloupce | VKVZOR vk12id1 | 1,1 : 0,M | VKFORMAT vk12id |
Vzor listu - má formát druhého konstantního sloupce | VKVZOR vk12id2 | 1,1 : 0,M | VKFORMAT vk12id |
Vzor listu - má formát třetího konstantního sloupce | VKVZOR vk12id3 | 1,1 : 0,M | VKFORMAT vk12id |

Indexy

Název | Primární | Výraz | Popis
ix_VKFORMAT_vk12id | P | vk12id | Identifikace formátu buňky
ix_VKFORMAT_vk12nazev |  | vk12nazev | Název formátu buňky


VKHARDEF Paleta zobrazování popisek harmonogramu

Popis

Paleta zobrazování popisek harmonogramu

Atributy

Atribut | Typ | Návěští | Message | Popis
vk18id | C(6) | Paleta | Identifikace palety zobrazení v harmonogramu | Identifikace palety zobrazení v harmonogramu
vk18hrmid | C(10) | vk18hrmid | Identifikace harmonogramu | Identifikace harmonogramu
vk18nazdef | C(40) | Název palety | Název palety zobrazení v harmonogramu | Název palety zobrazení v harmonogramu
vk18ylabel | M | Návěští Y | Výraz v jazyce Foxpro pro zobrazení návěští na ose Y v harmonogramu | Výraz v jazyce Foxpro pro zobrazení návěští na ose Y v harmonogramu
vk18ytoolt | M | Tooltip Y | Výraz v jazyce Foxpro pro zobrazení tooltipu na ose Y v harmonogramu | Výraz v jazyce Foxpro pro zobrazení tooltipu na ose Y v harmonogramu
vk18ywidth | N(3,0) | Šířka sloupce | Šířka sloupce návěští na ose Y v pixelech | Šířka sloupce návěští na ose Y v pixelech
vk18ulabel | M | Návěští události | Výraz v jazyce Foxpro pro zobrazení návěští události v harmonogramu | Výraz v jazyce Foxpro pro zobrazení návěští události v harmonogramu
vk18utoolt | M | Tooltip události | Výraz v jazyce Foxpro pro zobrazení tooltipu události v harmonogramu | Výraz v jazyce Foxpro pro zobrazení tooltipu události v harmonogramu
vk18ucolor | M | Barva události | Výraz v jazyce Foxpro pro určení barvy události v diagramu | Výraz v jazyce Foxpro pro určení barvy události v diagramu
vk18usensi | N(2,0) | Citlivost | Citlivost napojení následující události harmonogramu za předcházející událost v minutách | Citlivost napojení následující události harmonogramu za předcházející událost v minutách
vk18koment | M | Poznámka | Poznámka | Poznámka
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace
vk18udblcl | M | Kód dvojího kliku | Kód v jazyce Foxpro spuštěný při dvojím kliku na události (Lparameters _thisform,_thisform_harm,_this) | Kód v jazyce Foxpro spuštěný při dvojím kliku na události (Lparameters _thisform,_thisform_harm,_this)

Indexy

Název | Primární | Výraz | Popis
ix_VKHARDEF_vkhardef | P | vk18id, vk18hrmid | PI - vk18id+vk18hrmid
ix_VKHARDEF_vk18id |  | vk18id | Identifikace palety zobrazení v harmonogramu
ix_VKHARDEF_vk18nazdef |  | vk18nazdef | Název palety zobrazení v harmonogramu


VKKTPOLE Popis pole kontingenční tabulky

Popis

Popis pole kontingenční tabulky

Atributy

Atribut | Typ | Návěští | Message | Popis
vk20id | C(40) | Pole | Název pole kontingenční tabulky | Název pole kontingenční tabulky
vk03id | C(6) | List | Identifikace listu | Identifikace listu
vk20oblast | N(1,0) | Oblast | Oblast umístění pole | Oblast umístění pole
vk20porad | N(3,0) | Pořadí | Pořadí zpracování pole kontingenční tabulky | Pořadí zpracování pole kontingenční tabulky
vk20vyrobl | M | Určení oblasti výrazem | Výraz pro určení umístění pole v oblasti (hodnota) | Výraz pro určení umístění pole
vk20numfor | C(20) | Formát čísla | Formát čísla | Formát čísla
vk20fsest | M | Filtr sestavy | Výraz pro určení hodnoty filtru sestavy (hodnota) | Výraz pro určení hodnoty filtru sestavy
vk20vyrvis | M | Výběr popisků | Výraz pro výběr popisků (makro) | Výraz pro výběr popisků
vk20vyrdet | M | Zobrazení podpopisků | Výraz zobrazení podřízených popisků (makro) | Výraz zobrazení podřízených popisků
vk20script | M | Skript | Skript v jazyce Foxpro spuštěný pro pole kontingenční tabulky | Skript v jazyce Foxpro spuštěný pro pole kontingenční tabulky
vk20koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis pole kontingenční tabulky - patří k listu | VKKTPOLE vk03id | 1,1 : 0,M | VKLIST vk03id |

Indexy

Název | Primární | Výraz | Popis
ix_VKKTPOLE_vkktpole | P | vk20id, vk03id | PI - vk20id+vk03id
ix_VKKTPOLE_vk03id |  | vk03id | Identifikace listu
ix_VKKTPOLE_vk20porad |  | vk20porad | Pořadí zpracování pole kontingenční tabulky


VKLIST List výkazu

Popis

List

Atributy

Atribut | Typ | Návěští | Message | Popis
vk03id | C(6) | List | Identifikace listu | Identifikace listu
vk14id | C(6) | Vzor | Identifikace vzoru listu | Identifikace vzoru listu
vk03nazev | C(40) | Název listu | Název listu | Název listu
vk03typ | N(1,0) | Typ listu | Typ listu výkazu | Typ listu výkazu
bw20id | C(6) | Pohled | Identifikace pohledu slovníku dat | Identifikace pohledu
bw04ident | C(10) | Ident. | Identifikace předlohy pro výstup | Identifikace předlohy pro výstup
vk03pohwhe | M | Where | Doplněk dotazu WHERE pohledu slovníku dat | Doplněk dotazu WHERE pohledu slovníku dat
vk03param | M | Param. | Parametry listu | Parametry listu
vk03koment | M | Poznámka | Poznámka | Poznámka
vk13id | C(6) | Šablona | Identifikace šablony listu dokumentu | Identifikace šablony listu dokumentu
vk12id | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk03s1naz | M | Sloupec 10 | Nadpis 1.sloupce | Nadpis 1.sloupce
vk03s2naz | M | Sloupec 20 | Nadpis 2.sloupce | Nadpis 2.sloupce
vk03s3naz | M | Sloupec 30 | Nadpis 3.sloupce | Nadpis 3.sloupce
vk03s4naz | M | Sloupec 40 | Nadpis 4.sloupce | Nadpis 4.sloupce
vk03s5naz | M | Sloupec 50 | Nadpis 5.sloupce | Nadpis 5.sloupce
vk03s6naz | M | Sloupec 60 | Nadpis 6.sloupce | Nadpis 6.sloupce
vk03s7naz | M | Sloupec 70 | Nadpis 7.sloupce | Nadpis 4.sloupce
vk03s8naz | M | Sloupec 80 | Nadpis 8.sloupce | Nadpis 5.sloupce
vk03s9naz | M | Sloupec 90 | Nadpis 9.sloupce | Nadpis 6.sloupce
vk03s1sir | N(3,0) | vk03s1sir | Šířka 1.sloupce | Šířka 1.sloupce
vk03s2sir | N(3,0) | Šířka | Šířka 2.sloupce | Šířka 2.sloupce
vk03s3sir | N(3,0) | Šířka | Šířka 3.sloupce | Šířka 3.sloupce
vk03s4sir | N(3,0) | vk03s4sir | Šířka 4.sloupce | Šířka 4.sloupce
vk03s5sir | N(3,0) | vk03s5sir | Šířka 5.sloupce | Šířka 5.sloupce
vk03s6sir | N(3,0) | vk03s6sir | Šířka 6.sloupce | Šířka 6.sloupce
vk03s7sir | N(3,0) | vk03s7sir | Šířka 4.sloupce | Šířka 4.sloupce
vk03s8sir | N(3,0) | vk03s8sir | Šířka 5.sloupce | Šířka 5.sloupce
vk03s9sir | N(3,0) | vk03s9sir | Šířka 6.sloupce | Šířka 6.sloupce
vk03nadpis | M | Nadpis listu | Nadpis listu | Nadpis listu
vk03zaloz | M | Záložka listu | Záložka listu | Záložka listu
vk12id1 | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk12id2 | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk12id3 | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk12id4 | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk12id5 | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk12id6 | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk12id7 | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk12id8 | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk12id9 | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk03s1plat | N(1,0) | vk03s1plat | Zobrazovat 1.sloupec vzoru | Zobrazovat 1.sloupec vzoru
vk03s2plat | N(1,0) | vk03s2plat | Zobrazovat 2.sloupec vzoru | Zobrazovat 2.sloupec vzoru
vk03s3plat | N(1,0) | vk03s3plat | Zobrazovat 3.sloupec vzoru | Zobrazovat 3.sloupec vzoru
vk03pdmslp | M | Dodatečné deklarace | Podmínky pro zařazení sloupců do listu, rezervace zdrojů systému | Podmínky pro zařazení sloupců do listu
vk03kod | M | vk03kod | Kód v jazyce Foxpro provedený po vytvoření výkazu | Kód v jazyce Foxpro provedený po vytvoření výkazu
vk03ktsql | M | SQL | SQL dotaz pro kontingenční tabulku | SQL dotaz pro kontingenční tabulku

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
List výkazu - používá formát | VKLIST vk12id | 1,1 : 0,M | VKFORMAT vk12id |
List výkazu - bude vytvořen šablonou | VKLIST vk13id | 1,1 : 0,M | VKSABLON vk13id |
List výkazu - je vytvářen podle vzoru | VKLIST vk14id | 1,1 : 0,M | VKVZOR vk14id |
List výkazu - má formát prvního sloupce listu podle vzoru | VKLIST vk12id1 | 1,1 : 0,M | VKFORMAT vk12id |
List výkazu - má formát druhého sloupce listu podle vzoru | VKLIST vk12id2 | 1,1 : 0,M | VKFORMAT vk12id |
List výkazu - má formát třetího sloupce listu podle vzoru | VKLIST vk12id3 | 1,1 : 0,M | VKFORMAT vk12id |
List výkazu - má formát šestého sloupce listu podle vzoru | VKLIST vk12id6 | 1,1 : 0,M | VKFORMAT vk12id |
List výkazu - má formát čtvrtého sloupce listu podle vzoru | VKLIST vk12id4 | 1,1 : 0,M | VKFORMAT vk12id |
List výkazu - má formát pátého sloupce listu podle vzoru | VKLIST vk12id5 | 1,1 : 0,M | VKFORMAT vk12id |
List výkazu - má formát sedmého sloupce listu podle vzoru | VKLIST vk12id7 | 1,1 : 0,M | VKFORMAT vk12id |
List výkazu - má formát osmého sloupce listu podle vzoru | VKLIST vk12id8 | 1,1 : 0,M | VKFORMAT vk12id |
List výkazu - má formát devátého sloupce listu podle vzoru | VKLIST vk12id9 | 1,1 : 0,M | VKFORMAT vk12id |
List výkazu - používá předlohu výstupu | VKLIST bw20id bw04ident | 0,1 : 0,M | BWPRINTD bw02krok bw04ident |
List výkazu - používá pohled slovníku dat | VKLIST bw20id | 0,1 : 0,M | BWSLDPOH bw20id |
Sloupec - patří k listu | VKSLOUP vk03id | 1,1 : 0,M s rušením | VKLIST vk03id |
Řádek - patří k listu | VKRADEK vk03id | 1,1 : 0,M s rušením | VKLIST vk03id |
Vazba výkazu a listu - váže list | VKVYKLIS vk03id | 1,1 : 0,M | VKLIST vk03id |
Popis pole kontingenční tabulky - patří k listu | VKKTPOLE vk03id | 1,1 : 0,M | VKLIST vk03id |

Indexy

Název | Primární | Výraz | Popis
ix_VKLIST_vk03id | P | vk03id | Identifikace listu
ix_VKLIST_vk14id |  | vk14id | Identifikace vzoru listu
ix_VKLIST_vk03nazev |  | vk03nazev | Název listu
ix_VKLIST_bwsldpop |  | bw20id, bw04ident | Cizí klíč předlohy pro výstup BW20id+BW04ident slovníkem pojmů
ix_VKLIST_bw20id |  | bw20id | Identifikace pohledu
ix_VKLIST_vk13id |  | vk13id | Identifikace šablony listu dokumentu
ix_VKLIST_vk12id |  | vk12id | Identifikace formátu buňky
ix_VKLIST_vk12id1 |  | vk12id1 | Identifikace formátu buňky
ix_VKLIST_vk12id2 |  | vk12id2 | Identifikace formátu buňky
ix_VKLIST_vk12id3 |  | vk12id3 | Identifikace formátu buňky
ix_VKLIST_vk12id4 |  | vk12id4 | Identifikace formátu buňky
ix_VKLIST_vk12id5 |  | vk12id5 | Identifikace formátu buňky
ix_VKLIST_vk12id6 |  | vk12id6 | Identifikace formátu buňky
ix_VKLIST_vk12id7 |  | vk12id7 | Identifikace formátu buňky
ix_VKLIST_vk12id8 |  | vk12id8 | Identifikace formátu buňky
ix_VKLIST_vk12id9 |  | vk12id9 | Identifikace formátu buňky


VKRADEK Řádek

Popis

Řádek

Atributy

Atribut | Typ | Návěští | Message | Popis
vk05id | C(6) | Řádek | Identifikace řádku | Identifikace řádku
vk03id | C(6) | List | Identifikace listu | Identifikace listu
vk05nazev | M | Název | Název řádku | Název řádku
vk05param | M | Param. | Parametry řádku | Parametry řádku
vk05obvyr | N(1,0) | Obsah výrazu | Obsah výrazu | Obsah výrazu
vk05vyraz | M | Výraz | Výraz | Výraz
vk05koment | M | Pozn. | Poznámka | Poznámka
vk05porad | N(4,0) | vk05porad | Pořadové číslo řádku | Pořadové číslo řádku
vk12id | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk05hidden | N(1,0) | vk05hidden | Skrytý řádek | Skrytý řádek

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Řádek - patří k listu | VKRADEK vk03id | 1,1 : 0,M s rušením | VKLIST vk03id |
Řádek - používá formát | VKRADEK vk12id | 1,1 : 0,M | VKFORMAT vk12id |
Buňka - patří k řádku | VKBUNKA vk05id vk03id | 1,1 : 0,M s rušením | VKRADEK vk05id vk03id |

Indexy

Název | Primární | Výraz | Popis
ix_VKRADEK_vkradek | P | vk05id, vk03id | PI - vk05id+vk03id
ix_VKRADEK_vk03id |  | vk03id | Identifikace listu
ix_VKRADEK_vk12id |  | vk12id | Identifikace formátu buňky


VKSABLON Šablona listu výkazu

Popis

Šablona listu výkazu

Atributy

Atribut | Typ | Návěští | Message | Popis
vk13id | C(6) | Šablona | Identifikace šablony listu dokumentu | Identifikace šablony listu dokumentu
vk13nazev | C(40) | Název šablony | Název šablony | Název šablony
vk13strrow | N(4,0) | Počáteční řádek | Počáteční řádek výstupu listu | Počáteční řádek výstupu listu
vk13strcol | N(4,0) | Počáteční sloupec | Počáteční sloupec výstupu listu | Počáteční sloupec výstupu listu
vk13koment | M | Poznámka | Poznámka | Poznámka
vk13soubor | M | Soubor šablony | Soubor šablony | Soubor šablony
vk13zrusli | N(1,0) | Zrušit existující list | Zrušit existující list před založením nového listu | Zrušit existující list před založením nového listu
vk13vymali | N(1,0) | Vymazat list | Vymazat obsah listu při založení listu | Vymazat obsah listu při založení listu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
List výkazu - bude vytvořen šablonou | VKLIST vk13id | 1,1 : 0,M | VKSABLON vk13id |

Indexy

Název | Primární | Výraz | Popis
ix_VKSABLON_vk13id | P | vk13id | Identifikace šablony listu dokumentu
ix_VKSABLON_vk13nazev |  | vk13nazev | Název šablony


VKSLOUP Sloupec

Popis

Sloupec

Atributy

Atribut | Typ | Návěští | Message | Popis
vk04id | C(6) | Sloupec | Identifikace sloupce | Identifikace sloupce
vk03id | C(6) | List | Identifikace listu | Identifikace listu
vk04nazev | M | Název sloupce | Název sloupce | Název sloupce
vk04param | M | Param. | Parametry sloupce | Parametry sloupce
vk04obvyr | N(1,0) | Obsah výrazu | Obsah výrazu | Obsah výrazu
vk04vyraz | M | Výraz | Výraz | Výraz
vk04koment | M | Pozn. | Poznámka | Poznámka
vk04sirka | N(3,0) | Šířka | Šířka sloupce | Šířka sloupce
vk04porad | N(4,0) | vk04porad | Pořadové číslo sloupce | Pořadové číslo sloupce
vk12id | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk04hidden | N(1,0) | vk04hidden | Skrytý sloupec | Skrytý sloupec
vk04zaokr | N(1,0) | Zakroulování | Zaokrouhlovaná hodnota | Zaokrouhlovaná hodnota

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Sloupec - patří k listu | VKSLOUP vk03id | 1,1 : 0,M s rušením | VKLIST vk03id |
Sloupec - používá formát | VKSLOUP vk12id | 1,1 : 0,M | VKFORMAT vk12id |
Buňka - patří k sloupci | VKBUNKA vk04id vk03id | 1,1 : 0,M s rušením | VKSLOUP vk04id vk03id |

Indexy

Název | Primární | Výraz | Popis
ix_VKSLOUP_vksloup | P | vk04id, vk03id | PI - vk04id+vk03id
ix_VKSLOUP_vk03id |  | vk03id | Identifikace listu
ix_VKSLOUP_vk12id |  | vk12id | Identifikace formátu buňky


VKTEMRAD Pracovní řádek listu

Popis

Pracovní řádek listu

Atributy

Atribut | Typ | Návěští | Message | Popis
vk16 | C(9) | vk16 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
vk05id | C(6) | Řádek | Identifikace řádku | Identifikace řádku
vk03id | C(6) | List | Identifikace listu | Identifikace listu
vk05nazev | M | Název | Název řádku | Název řádku
vk05porad | N(4,0) | vk05porad | Pořadové číslo řádku | Pořadové číslo řádku
vk05hidden | N(1,0) | vk05hidden | Skrytý řádek | Skrytý řádek
vk16s1tp | N(1,0) | S10 | Typ výpočtu ve sloupci 1 | Typ výpočtu ve sloupci 1
vk16s1fr | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk16s1p1 | M | P11 | Parametr 1 | Parametr 1
vk16s1p2 | M | P12 | Parametr 2 | Parametr 2
vk16s1p3 | M | P13 | Parametr 3 | Parametr 3
vk16s1p4 | M | P14 | Parametr 4 | Parametr 4
vk16s1p5 | M | P15 | Parametr 5 | Parametr 5
vk16s1vr | M | Výraz | Výraz | Výraz
vk16s1vz | M | Vzorec | Vzorec | Vzorec
vk16s1nb | C(40) | S10 | Název buňky S10 | Název buňky S10
vk16s2tp | N(1,0) | S20 | Typ výpočtu ve sloupci 2 | Typ výpočtu ve sloupci 3
vk16s2fr | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk16s2p1 | M | P21 | Parametr 1 | Parametr 1
vk16s2p2 | M | P22 | Parametr 2 | Parametr 2
vk16s2p3 | M | P23 | Parametr 3 | Parametr 3
vk16s2p4 | M | P24 | Parametr 4 | Parametr 4
vk16s2p5 | M | P25 | Parametr 5 | Parametr 5
vk16s2vr | M | Výraz | Výraz | Výraz
vk16s2vz | M | Vzorec | Vzorec | Vzorec
vk16s2nb | C(40) | S20 | Název buňky S20 | Název buňky S20
vk16s3tp | N(1,0) | S30 | Typ výpočtu ve sloupci 3 | Typ výpočtu ve sloupci 3
vk16s3fr | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk16s3p1 | M | P31 | Parametr 1 | Parametr 1
vk16s3p2 | M | P32 | Parametr 2 | Parametr 2
vk16s3p3 | M | P33 | Parametr 3 | Parametr 3
vk16s3p4 | M | P34 | Parametr 4 | Parametr 4
vk16s3p5 | M | P35 | Parametr 5 | Parametr 5
vk16s3vr | M | Výraz | Výraz | Výraz
vk16s3vz | M | Vzorec | Vzorec | Vzorec
vk16s3nb | C(40) | S30 | Název buňky S30 | Název buňky S30
vk12id | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk16s4tp | N(1,0) | S40 | Typ výpočtu ve sloupci 4 | Typ výpočtu ve sloupci 4
vk16s4fr | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk16s4p1 | M | P41 | Parametr 1 | Parametr 1
vk16s4p2 | M | P42 | Parametr 2 | Parametr 2
vk16s4p3 | M | P43 | Parametr 3 | Parametr 3
vk16s4p4 | M | P44 | Parametr 4 | Parametr 4
vk16s4p5 | M | P45 | Parametr 5 | Parametr 5
vk16s4vr | M | Výraz | Výraz | Výraz
vk16s4vz | M | Vzorec | Vzorec | Vzorec
vk16s4nb | C(40) | S40 | Název buňky S40 | Název buňky S40
vk16s5tp | N(1,0) | S50 | Typ výpočtu ve sloupci 5 | Typ výpočtu ve sloupci 5
vk16s5fr | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk16s5p1 | M | P51 | Parametr 1 | Parametr 1
vk16s5p2 | M | P52 | Parametr 2 | Parametr 2
vk16s5p3 | M | P53 | Parametr 3 | Parametr 3
vk16s5p4 | M | P54 | Parametr 4 | Parametr 4
vk16s5p5 | M | P55 | Parametr 5 | Parametr 5
vk16s5vr | M | Výraz | Výraz | Výraz
vk16s5vz | M | Vzorec | Vzorec | Vzorec
vk16s5nb | C(40) | S50 | Název buňky S50 | Název buňky S50
vk16s6tp | N(1,0) | S60 | Typ výpočtu ve sloupci 6 | Typ výpočtu ve sloupci 6
vk16s6fr | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk16s6p1 | M | P61 | Parametr 1 | Parametr 1
vk16s6p2 | M | P62 | Parametr 2 | Parametr 2
vk16s6p3 | M | P63 | Parametr 3 | Parametr 3
vk16s6p4 | M | P64 | Parametr 4 | Parametr 4
vk16s6p5 | M | P65 | Parametr 5 | Parametr 5
vk16s6vr | M | Výraz | Výraz | Výraz
vk16s6vz | M | Vzorec | Vzorec | Vzorec
vk16s6nb | C(40) | S60 | Název buňky S60 | Název buňky S60
vk16s7tp | N(1,0) | S70 | Typ výpočtu ve sloupci 7 | Typ výpočtu ve sloupci 7
vk16s7fr | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk16s7p1 | M | P71 | Parametr 1 | Parametr 1
vk16s7p2 | M | P72 | Parametr 2 | Parametr 2
vk16s7p3 | M | P73 | Parametr 3 | Parametr 3
vk16s7p4 | M | P74 | Parametr 4 | Parametr 4
vk16s7p5 | M | P75 | Parametr 5 | Parametr 5
vk16s7vr | M | Výraz | Výraz | Výraz
vk16s7vz | M | Vzorec | Vzorec | Vzorec
vk16s7nb | C(40) | S70 | Název buňky S70 | Název buňky S70
vk16s8tp | N(1,0) | S80 | Typ výpočtu ve sloupci 8 | Typ výpočtu ve sloupci 8
vk16s8fr | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk16s8p1 | M | P81 | Parametr 1 | Parametr 1
vk16s8p2 | M | P82 | Parametr 2 | Parametr 2
vk16s8p3 | M | P83 | Parametr 3 | Parametr 3
vk16s8p4 | M | P84 | Parametr 4 | Parametr 4
vk16s8p5 | M | P85 | Parametr 5 | Parametr 5
vk16s8vr | M | Výraz | Výraz | Výraz
vk16s8vz | M | Vzorec | Vzorec | Vzorec
vk16s8nb | C(40) | S80 | Název buňky S80 | Název buňky S80
vk16s9tp | N(1,0) | S90 | Typ výpočtu ve sloupci 9 | Typ výpočtu ve sloupci 9
vk16s9fr | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk16s9p1 | M | P91 | Parametr 1 | Parametr 1
vk16s9p2 | M | P92 | Parametr 2 | Parametr 2
vk16s9p3 | M | P93 | Parametr 3 | Parametr 3
vk16s9p4 | M | P94 | Parametr 4 | Parametr 4
vk16s9p5 | M | P95 | Parametr 5 | Parametr 5
vk16s9vr | M | Výraz | Výraz | Výraz
vk16s9vz | M | Vzorec | Vzorec | Vzorec
vk16s9nb | C(40) | S90 | Název buňky S90 | Název buňky S90

Indexy

Název | Primární | Výraz | Popis
ix_VKTEMRAD_vktemrad | P | vk16, vk05id |
ix_VKTEMRAD_vk03id |  | vk03id | Identifikace listu


VKVYKAZ Výkaz

Popis

Výkaz

Atributy

Atribut | Typ | Návěští | Message | Popis
vk01id | C(6) | Výkaz | Identifikace výkazu | Identifikace výkazu
vk02id | C(6) | Druh | Identifikace druhu výkazu | Identifikace druhu výkazu
vk17id | C(6) | Dotaz | Identifikace dotazu | Identifikace dotazu
vk01nazev | C(40) | Název výkazu | Název výkazu | Název výkazu
vk01soubor | M | Výstupní soubor výkazu | Výstupní soubor výkazu | Výstupní soubor výkazu
vk01popis | M | Popis výkazu | Popis výkazu | Popis výkazu
vk01vyrsou | M | Výraz názvu | Výraz názvu souboru výkazu | Výraz názvu souboru výkazu
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
vk01heslo | C(30) | Heslo | Heslo pro uzavření výkazu | Heslo pro uzavření výkazu
vk01zamyka | N(1,0) | vk01zamyka | Zamykat listy výkazu | Zamykat listy výkazu
vk01sezpol | N(1,0) | Zobrazovat seznam polí | Zobrazovat seznam polí kontingenčních tabulek (pouze pro Excel 2007) | Zobrazovat seznam polí kontingenčních tabulek (pouze pro Excel 2007)

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Výkaz - je druhu | VKVYKAZ vk02id | 1,1 : 0,M | VKDRUHV vk02id |
Výkaz - založil uživatel | VKVYKAZ bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Výkaz - má určený vstup | VKVYKAZ vk17id | 1,1 : 0,M | VKDOTAZ vk17id |
Vazba výkazu a listu - váže výkaz | VKVYKLIS vk01id | 1,1 : 0,M | VKVYKAZ vk01id |

Indexy

Název | Primární | Výraz | Popis
ix_VKVYKAZ_vk01id | P | vk01id | Identifikace výkazu
ix_VKVYKAZ_vk02id |  | vk02id | Identifikace druhu výkazu
ix_VKVYKAZ_vk17id |  | vk17id | Identifikace dotazu
ix_VKVYKAZ_vk01nazev |  | vk01nazev | Název výkazu
ix_VKVYKAZ_bw01uziv |  | bw01uziv | Identifikace uživatele systému


VKVYKLIS Vazba výkazu a listu

Popis

Listy spojené s výkazem

Atributy

Atribut | Typ | Návěští | Message | Popis
vk01id | C(6) | Výkaz | Identifikace výkazu | Identifikace výkazu
vk08porad | N(3,0) | vk08porad | Pořadí listu na výkazu | Pořadí listu na výkazu
vk03id | C(6) | List | Identifikace listu | Identifikace listu
vk08parami | M | Parametry INI | Parametry listu ve výkazu - počáteční inicializace (dostupné pro dynamické proměnné) | Parametry listu ve výkazu - počáteční inicializace (dostupné pro dynamické proměnné)
vk08param | M | Parametry | Parametry listu ve výkazu | Parametry listu ve výkazu
vk08nazev | C(40) | Explicitní název | Explicitní název listu | Explicitní název listu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vazba výkazu a listu - váže list | VKVYKLIS vk03id | 1,1 : 0,M | VKLIST vk03id |
Vazba výkazu a listu - váže výkaz | VKVYKLIS vk01id | 1,1 : 0,M | VKVYKAZ vk01id |

Indexy

Název | Primární | Výraz | Popis
ix_VKVYKLIS_vkvyklis | P | vk01id, vk08porad | Listy spojené s výkazem
ix_VKVYKLIS_vk01id |  | vk01id | Identifikace výkazu
ix_VKVYKLIS_vk03id |  | vk03id | Identifikace listu


VKVZOR Vzor listu

Popis

Vzor listu

Atributy

Atribut | Typ | Návěští | Message | Popis
vk14id | C(6) | Vzor | Identifikace vzoru listu | Identifikace vzoru listu
vk14nazev | C(40) | Název vzoru | Název vzoru listu | Název vzoru listu
vk14sllab1 | M | 1.sloupec | Návěští 1.sloupce ve tvaru výrazu | Návěští 1.sloupce ve tvaru výrazu
vk14slvyr1 | M | Výraz | Výraz 1.sloupce | Výraz 1.sloupce
vk14sllab2 | M | 2.sloupec | Návěští 2.sloupce ve tvaru výrazu | Návěští 2.sloupce ve tvaru výrazu
vk14slvyr2 | M | Výraz | Výraz 2.sloupce | Výraz 2.sloupce
vk14sllab3 | M | 3.sloupec | Návěští 3.sloupce ve tvaru výrazu | Návěští 3.sloupce ve tvaru výrazu
vk14slvyr3 | M | Výraz | Výraz 3.sloupce | Výraz 3.sloupce
vk14param | M | Parametry | Parametry vzoru listu | Parametry vzoru listu
vk14koment | M | Poznámka | Poznámka | Poznámka
vk14slsir1 | N(3,0) | Šířka | Šířka sloupce | Šířka sloupce
vk12id1 | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk14slsir2 | N(3,0) | Šířka | Šířka sloupce | Šířka sloupce
vk12id2 | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky
vk14slsir3 | N(3,0) | Šířka | Šířka sloupce | Šířka sloupce
vk12id3 | C(6) | Formát | Identifikace formátu buňky | Identifikace formátu buňky

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vzor listu - má formát prvního konstantního sloupce | VKVZOR vk12id1 | 1,1 : 0,M | VKFORMAT vk12id |
Vzor listu - má formát druhého konstantního sloupce | VKVZOR vk12id2 | 1,1 : 0,M | VKFORMAT vk12id |
Vzor listu - má formát třetího konstantního sloupce | VKVZOR vk12id3 | 1,1 : 0,M | VKFORMAT vk12id |
List výkazu - je vytvářen podle vzoru | VKLIST vk14id | 1,1 : 0,M | VKVZOR vk14id |
Výraz vzoru listu - patří ke vzoru | VKVZORV vk14id | 1,1 : 0,M | VKVZOR vk14id |

Indexy

Název | Primární | Výraz | Popis
ix_VKVZOR_vk14id | P | vk14id | Identifikace vzoru listu
ix_VKVZOR_vk14nazev |  | vk14nazev | Název vzoru listu
ix_VKVZOR_vk12id1 |  | vk12id1 | Identifikace formátu buňky
ix_VKVZOR_vk12id2 |  | vk12id2 | Identifikace formátu buňky
ix_VKVZOR_vk12id3 |  | vk12id3 | Identifikace formátu buňky


VKVZORV Výraz vzoru listu

Popis

Výraz vzoru listu

Atributy

Atribut | Typ | Návěští | Message | Popis
vk14id | C(6) | Vzor | Identifikace vzoru listu | Identifikace vzoru listu
vk15porad | N(2,0) | Pořadí | Pořadí výrazu | Pořadí výrazu
vk15nazev | C(40) | Popis výrazu | Popis výrazu | Popis výrazu
vk15vyraz | M | Výraz | Výraz | Výraz
vk15koment | M | Poznámka | Poznámka | Poznámka
vk15prid1 | C(20) | 1.p. | 1.parametr výrazu vzoru listu | 1.parametr výrazu vzoru listu
vk15prtyp1 | N(1,0) | Typ | Typ 1.parametru výrazu vzoru listu | Typ 1.parametru výrazu vzoru listu
vk15prlen1 | N(2,0) | Délka | Délka hodnoty 1.parametru vzoru listu | Délka hodnoty 1.parametru vzoru listu
vk15prlab1 | C(30) | Náv. | Návěští 1.parametru vzoru listu | Návěští 1.parametru vzoru listu
vk15prdef1 | M | Def. | Implicitní hodnota 1.parametru vzoru listu | Implicitní hodnota 1.parametru vzoru listu
vk15prid2 | C(20) | 2.p. | 2.parametr výrazu vzoru listu | 2.parametr výrazu vzoru listu
vk15prtyp2 | N(1,0) | Typ | Typ 2.parametru výrazu vzoru listu | Typ 2.parametru výrazu vzoru listu
vk15prlen2 | N(2,0) | Délka | Délka hodnoty 2.parametru vzoru listu | Délka hodnoty 2.parametru vzoru listu
vk15prlab2 | C(30) | Náv. | Návěští 2.parametru vzoru listu | Návěští 2.parametru vzoru listu
vk15prdef2 | M | Def. | Implicitní hodnota 2.parametru vzoru listu | Implicitní hodnota 2.parametru vzoru listu
vk15prid3 | C(20) | 3.p. | 3.parametr výrazu vzoru listu | 3.parametr výrazu vzoru listu
vk15prtyp3 | N(1,0) | Typ | Typ 3.parametru výrazu vzoru listu | Typ 3.parametru výrazu vzoru listu
vk15prlen3 | N(2,0) | Délka | Délka hodnoty 3.parametru vzoru listu | Délka hodnoty 3.parametru vzoru listu
vk15prlab3 | C(30) | Náv. | Návěští 3.parametru vzoru listu | Návěští 3.parametru vzoru listu
vk15prdef3 | M | Def. | Implicitní hodnota 3.parametru vzoru listu | Implicitní hodnota 3.parametru vzoru listu
vk15prid4 | C(20) | 4.p. | 4.parametr výrazu vzoru listu | 4.parametr výrazu vzoru listu
vk15prtyp4 | N(1,0) | Typ | Typ 4.parametru výrazu vzoru listu | Typ 4.parametru výrazu vzoru listu
vk15prlen4 | N(2,0) | Délka | Délka hodnoty 4.parametru vzoru listu | Délka hodnoty 4.parametru vzoru listu
vk15prlab4 | C(30) | Náv. | Návěští 4.parametru vzoru listu | Návěští 4.parametru vzoru listu
vk15prdef4 | M | Def. | Implicitní hodnota 4.parametru vzoru listu | Implicitní hodnota 4.parametru vzoru listu
vk15prid5 | C(20) | 5.p. | 5.parametr výrazu vzoru listu | 5.parametr výrazu vzoru listu
vk15prtyp5 | N(1,0) | Typ | Typ 5.parametru výrazu vzoru listu | Typ 5.parametru výrazu vzoru listu
vk15prlen5 | N(2,0) | Délka | Délka hodnoty 5.parametru vzoru listu | Délka hodnoty 5.parametru vzoru listu
vk15prlab5 | C(30) | Náv. | Návěští 5.parametru vzoru listu | Návěští 5.parametru vzoru listu
vk15prdef5 | M | Def. | Implicitní hodnota 5.parametru vzoru listu | Implicitní hodnota 5.parametru vzoru listu
vk15prid6 | C(20) | 6.p. | 6.parametr výrazu vzoru listu | 6.parametr výrazu vzoru listu
vk15prtyp6 | N(1,0) | Typ | Typ 6.parametru výrazu vzoru listu | Typ 6.parametru výrazu vzoru listu
vk15prlen6 | N(2,0) | Délka | Délka hodnoty 6.parametru vzoru listu | Délka hodnoty 6.parametru vzoru listu
vk15prlab6 | C(30) | Náv. | Návěští 6.parametru vzoru listu | Návěští 6.parametru vzoru listu
vk15prdef6 | M | Def. | Implicitní hodnota 6.parametru vzoru listu | Implicitní hodnota 6.parametru vzoru listu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Výraz vzoru listu - patří ke vzoru | VKVZORV vk14id | 1,1 : 0,M | VKVZOR vk14id |

Indexy

Název | Primární | Výraz | Popis
ix_VKVZORV_vkvzorv | P | vk14id, vk15porad |
ix_VKVZORV_vk14id |  | vk14id | Identifikace vzoru listu


Tabulky VM...

VMAH | Aktuální hodnota vymáhání
VMAHUD | Událost - skladba
VMALGOR | Algoritmus vymáhání
VMPOSTU | Postup vymáhání
VMPOSTUB | Den v postupu vymáhání
VMUDA | Událost vymáhání

Viz.také

VMAH Aktuální hodnota vymáhání | VMAHUD Událost - skladba | VMALGOR Algoritmus vymáhání | VMPOSTU Postup vymáhání | VMPOSTUB Den v postupu vymáhání | VMUDA Událost vymáhání


VMAH Aktuální hodnota vymáhání

Popis

Aktuální hodnota vymáhání

Atributy

Atribut | Typ | Návěští | Message | Popis
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
vm03hodnot | N(20,4) | vm03hodnot |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Aktuální hodnota vymáhání - týká se statistické informace | VMAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_VMAH_vmah | P | sp67id, sp06idsubs, ad01id |
ix_VMAH_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_VMAH_ad01id |  | ad01id | Identifikace adresáta


VMAHUD Událost - skladba

Popis

Událost - skladba

Atributy

Atribut | Typ | Návěští | Message | Popis
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp00datum | D | Datum | Datum události | Datum události
sp00text | C(40) | Popis | Popis události | Popis události
sp00hodnot | N(20,4) | Hodnota | Aktuální hodnota procesu |
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp74id | C(6) | sp74id | Umístění | Umístění
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
sp69id | C(6) | Druh | Identifikace druhu saldokontní hodnoty procesu | Identifikace druhu saldokontní hodnoty procesu


VMALGOR Algoritmus vymáhání

Popis

Algoritmus vymáhání

Atributy

Atribut | Typ | Návěští | Message | Popis
vm06id | C(6) | Vymáhání | Identifikace algoritmu vymáhání | Identifikace algoritmu vymáhání
vm06text | C(40) | Popis | Popis algoritmu vymáhání | Popis algoritmu vymáhání
vm06koment | M | Poznámka | Poznámka | Poznámka
vm06penale | N(8,4) | Penále % | Hodnota penále | Hodnota penále
vm04id | C(6) | Postup | Identifikace postupu vymáhání | Identifikace postupu vymáhání
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Algoritmus vymáhání - založil uživatel | VMALGOR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Algoritmus vymáhání - používá postup vymáhán | VMALGOR vm04id | 1,1 : 0,M | VMPOSTU vm04id |
Událost plateb - používá algoritmus vymáhání | PLUDA vm06id | 1,1 : 0,M | VMALGOR vm06id |

Indexy

Název | Primární | Výraz | Popis
ix_VMALGOR_vm06id | P | vm06id | Identifikace algoritmu vymáhání
ix_VMALGOR_vm06text |  | vm06text | Popis algoritmu vymáhání
ix_VMALGOR_vm04id |  | vm04id | Identifikace postupu vymáhání
ix_VMALGOR_bw01uziv |  | bw01uziv | Identifikace uživatele systému


VMPOSTU Postup vymáhání

Popis

Postup vymáhání

Atributy

Atribut | Typ | Návěští | Message | Popis
vm04id | C(6) | Postup | Identifikace postupu vymáhání | Identifikace postupu vymáhání
vm04text | C(40) | Název postupu | Název postupu vymáhání | Název postupu vymáhání
vm04koment | M | Poznámka | Poznámka postupu vymáhání | Poznámka postupu vymáhání
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Postup vymáhání - založil uživatel | VMPOSTU bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Den v postupu vymáhání - je ve vymáhání | VMPOSTUB vm04id | 1,1 : 1,1 s rušením | VMPOSTU vm04id |
Algoritmus vymáhání - používá postup vymáhán | VMALGOR vm04id | 1,1 : 0,M | VMPOSTU vm04id |

Indexy

Název | Primární | Výraz | Popis
ix_VMPOSTU_vm04id | P | vm04id | Identifikace postupu vymáhání
ix_VMPOSTU_vm04text |  | vm04text | Název postupu vymáhání
ix_VMPOSTU_bw01uziv |  | bw01uziv | Identifikace uživatele systému


VMPOSTUB Den v postupu vymáhání

Popis

Den v postupu vymáhání

Atributy

Atribut | Typ | Návěští | Message | Popis
vm04id | C(6) | Postup | Identifikace postupu vymáhání | Identifikace postupu vymáhání
vm05den | N(4,0) | Den | Den v postupu vymáhání od data splatnosti | Den v postupu vymáhání od data splatnosti
vm05ukon | N(1,0) | Úkon | Úkon v postupu vymáhání - žádný, penalizace, upomínka | Úkon v postupu vymáhání
vm05zpenal | N(1,0) | vm05zpenal | Změnit hodnotu procent penále o % ? | Změnit hodnotu procent penále o % ?
vm05plusp | N(8,4) | Hodnota změny penále | Hodnota změny penále | Hodnota změny penále
vm05koment | M | Poznámka | Poznámka | Poznámka bodu postupu vymáhání
vm05presko | N(1,0) | Povolit přeskočení úkonu | Povolit přeskočit tento řádek, pokud v postupu vymáhání došlo ke skluzu. | Povolit přeskočit tento řádek, pokud v postupu vymáhání došlo ke skluzu.
sp88id | C(6) | Text | Identifikace textu | Identifikace textu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Den v postupu vymáhání - je ve vymáhání | VMPOSTUB vm04id | 1,1 : 1,1 s rušením | VMPOSTU vm04id |
Den v postupu vymáhání - je spojen s textem | VMPOSTUB sp88id | 1,1 : 0,M | SPTEXTY sp88id |

Indexy

Název | Primární | Výraz | Popis
ix_VMPOSTUB_vmpostub | P | vm04id, vm05den | PI bodu postupu vymáhání
ix_VMPOSTUB_vm04id |  | vm04id | Identifikace postupu vymáhání
ix_VMPOSTUB_sp88id |  | sp88id | Identifikace textu


VMUDA Událost vymáhání

Popis

Objektem typu PLUDA je každá událost komponenty vymáhání pohledávek obsahující informace o vystavených upomínkách a penále.

Atributy

Atribut | Typ | Návěští | Message | Popis
vm02 | C(12) | vm02 | Jednoznačná časová identifikace události vymáhání | Jednoznačná časová identifikace události vymáhání
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
vm02upopen | N(2,0) | vm02upopen | Upomínka nebo penále | Upomínka nebo penále
vm02datud | D | Vznik | Datum vzniku události vymáhání | Datum vzniku události vymáhání
vm02datum | D | Datum | Datum události vymáhání pohledávky pro spojení s platbou podle kalendáře | Datum události vymáhání pohledávky pro spojení s platbou podle kalendáře
vm02text | C(40) | Popis | Popis události vymáhání pohledávky | Popis události vymáhání pohledávky
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
vm02czm | N(20,4) | Částka v ZM | Částka v zahraniční měně | Částka v zahraniční měně
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
vm02koment | M | Poznámka | Poznámka k vymáhání |
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
sp88id | C(6) | Text | Identifikace textu | Identifikace textu
vm02dnu | N(5,0) | vm02dnu | Počet penalizovaných dnů | Počet penalizovaných dnů
vm02zaklad | N(20,4) | vm02zaklad | Základní penalizovaná částka - částka, ze které se počítá penále | Základní penalizovaná částka - částka, ze které se počítá penále

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost vymáhání - náleží fyzické operaci | VMUDA sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost vymáhání - má adresu aktéra (odesilatele/příjemce) | VMUDA ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost vymáhání - byla založena uživatelem | VMUDA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost vymáhání - má zahraniční měnu | VMUDA oc01id | 1,1 : 0,M | OCMENA oc01id |
Událost vymáhání - má obchodní selektor | VMUDA sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost vymáhání - má organizační selektor | VMUDA sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost vymáhání - má technicko-věcný selektor | VMUDA sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost vymáhání - je spojena s textem | VMUDA sp88id | 1,1 : 0,M | SPTEXTY sp88id |
Vazba mezi platbou a vymáháním - váže vymáhání | PLPLVYM vm02 | 1,1 : 0,M s rušením | VMUDA vm02 |

Indexy

Název | Primární | Výraz | Popis
ix_VMUDA_vm02 | P | vm02 | Jednoznačná časová identifikace události vymáhání
ix_VMUDA_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_VMUDA_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_VMUDA_adadsatx |  |  |
ix_VMUDA_vm02datud |  | vm02datud | Datum vzniku události vymáhání
ix_VMUDA_vm02datum |  | vm02datum | Datum události vymáhání pohledávky pro spojení s platbou podle kalendáře
ix_VMUDA_vm02text |  | vm02text | Popis události vymáhání pohledávky
ix_VMUDA_ad01id |  | ad01id | Identifikace adresáta
ix_VMUDA_oc01id |  | oc01id | Kód měny - oceňovací jednotky.
ix_VMUDA_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_VMUDA_sp00datzap |  | sp00datzap | Datum a čas zápisu záznamu události
ix_VMUDA_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_VMUDA_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_VMUDA_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_VMUDA_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_VMUDA_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_VMUDA_sp88id |  | sp88id | Identifikace textu


Tabulky VR...

VRAHOPER | Aktuální hodnota komponenty výrobní operace
VRAHOPMA | Aktuální hodnota komponenty vstupy výrobní operace
VRAHUDOM | Událost - skladba
VRAHUDOP | Událost - skladba
VRAHUDVY | Událost - skladba
VRAHVYR | Aktuální hodnota komponenty zakázka výroby
VRIMPVYR | Importované měření-vážení výroby
VRKAL | Kalendář výroby
VRKALLIN | Směna výrobní linky
VRKALPLI | Přidělení kalendáře lince
VRKALPOL | Položka kalendáře výroby
VRUDOPER | Událost úkolu ve výrobě
VRUDOPMA | Vstup nebo výstup výrobního úkolu
VRUDOPMX | Vstup nebo výstup výrobního úkolu - distinct
VRUDOPNS | Následující skupina úkolů výroby
VRVYR | Výrobní zakázka

Viz.také

VRAHOPER Aktuální hodnota komponenty výrobní operace | VRAHOPMA Aktuální hodnota komponenty vstupy výrobní operace | VRAHUDOM Událost - skladba | VRAHUDOP Událost - skladba | VRAHUDVY Událost - skladba | VRAHVYR Aktuální hodnota komponenty zakázka výroby | VRIMPVYR Importované měření-vážení výroby | VRUDOPER Událost úkolu ve výrobě | VRUDOPMA Vstup nebo výstup výrobního úkolu | VRUDOPNS Následující skupina úkolů výroby | VRVYR Výrobní zakázka | VRKAL Kalendář výroby | VRKALLIN Směna výrobní linky | VRKALPLI Přidělení kalendáře lince | VRKALPOL Položka kalendáře výroby | VRUDOPMX Vstup nebo výstup výrobního úkolu - distinct


VRAHOPER Aktuální hodnota komponenty výrobní operace

Popis

Aktuální hodnoty komponenty výrobní kroky

Atributy

Atribut | Typ | Návěští | Message | Popis
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
tp13id | C(6) | Číslo linky | Číslo výrobní linky, resp. stroje | Číslo výrobní linky, resp. stroje
vr16hodnot | N(20,4) | Hodnota | Aktuální hodnota | Aktuální hodnota

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Aktuální hodnota komponenty výrobní operace - se týká druhu statistické informace | VRAHOPER sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_VRAHOPER_vrahoper | P | sp67id, sp06idsubs, tp13id |
ix_VRAHOPER_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_VRAHOPER_tp13id |  | tp13id | Číslo výrobní linky, resp. stroje


VRAHOPMA Aktuální hodnota komponenty vstupy výrobní operace

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
vr18hodnot | N(20,4) | Hodnota | Aktuální hodnota | Aktuální hodnota

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Aktuální hodnota komponenty vstupy výrobní operace - se týká druhu statistické informace | VRAHOPMA sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_VRAHOPMA_vrahopma | P | sp60id, sp61id, sp67id, sp06idsubs |
ix_VRAHOPMA_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_VRAHOPMA_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id


VRAHUDOM Událost - skladba

Popis

Událost - skladba

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
vr14 | C(12) | vr14 | Časová identifikace | Časová identifikace
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp00datum | D | Datum | Datum události | Datum události
sp00text | C(40) | Popis | Popis události | Popis události
sp00hodnot | N(20,4) | Hodnota | Aktuální hodnota procesu |


VRAHUDOP Událost - skladba

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
vr09 | C(12) | vr09 | Časová identifikace události. | Časová identifikace události.
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp00datum | D | Datum | Datum události | Datum události
sp00text | C(40) | Popis | Popis události | Popis události
sp00hodnot | N(20,4) | Hodnota | Aktuální hodnota procesu |
sp74id | C(6) | sp74id | Umístění | Umístění


VRAHUDVY Událost - skladba

Popis

Událost - skladba

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
vr02 | C(12) | vr02 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp00datum | D | Datum | Datum události | Datum události
sp00text | C(40) | Popis | Popis události | Popis události
sp00hodnot | N(20,4) | Hodnota | Aktuální hodnota procesu |


VRAHVYR Aktuální hodnota komponenty zakázka výroby

Popis

Aktuální hodnoty komponenty zakázka výroby

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
vr22hodnot | N(20,4) | Hodnota | Hodnota | Hodnota

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Aktuální hodnota komponenty zakázka výroby - se týká druhu statistické informace | VRAHVYR sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_VRAHVYR_vrahvyr | P | sp60id, sp61id, sp67id, sp06idsubs |
ix_VRAHVYR_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_VRAHVYR_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id


VRIMPVYR Importované měření-vážení výroby

Popis

Importované měření-vážení výroby

Atributy

Atribut | Typ | Návěští | Message | Popis
vr27 | C(15) | vr27 | Jednoznačná časová identifikace importu měření výroby | Jednoznačná časová identifikace importu měření výroby
vr02vyrc | C(15) | Výroba č. | Číslo výroby. | Číslo výroby.
tp22id | C(6) | Trasa | Identifikace trasy | Identifikace trasy
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
vr14mn | N(20,6) | Množství | Množství | Množství
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
vr27status | N(1,0) | vr27status | Stav zpracování | Stav zpracování

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Importované měření-vážení výroby - je vážením na trase | VRIMPVYR tp22id | 1,1 : 0,M | TPTRASY tp22id |
Importované měření-vážení výroby - se týká výrobní zakázka | VRIMPVYR vr02vyrc | 1,1 : 0,M s rušením | VRVYR vr02vyrc |

Indexy

Název | Primární | Výraz | Popis
ix_VRIMPVYR_vr27 | P | vr27 | Jednoznačná časová identifikace importu měření výroby
ix_VRIMPVYR_vr02vyrc |  | vr02vyrc | Číslo výroby.
ix_VRIMPVYR_tp22id |  | tp22id | Identifikace trasy
ix_VRIMPVYR_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_VRIMPVYR_vr27status |  | vr27status | Stav zpracování


VRKAL Kalendář výroby

Popis

Kalendář výroby

Atributy

Atribut | Typ | Návěští | Message | Popis
vr32id | C(6) | Kalendář | Identifikace kalendáře | Identifikace kalendáře
vr32nazkal | C(40) | Název kalendáře | Název kalendáře | Název kalendáře musí být uveden
vr32koment | M | Poznámka | Poznámka | Poznámka
vr32uroven | N(5,0) | Úroveň | Úroveň kalendáře | Úroveň kalendáře
vr32vseob | N(1,0) | Všeobecný kalendář | Všeobecný kalendář | Všeobecný kalendář

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Položka kalendáře výroby - se patří do kalendáře | VRKALPOL vr32id | 1,1 : 0,M | VRKAL vr32id |
Přidělení kalendáře lince - určuje kalendář přidělený výrobní lince | VRKALPLI vr32id | 1,1 : 0,M s rušením | VRKAL vr32id |

Indexy

Název | Primární | Výraz | Popis
ix_VRKAL_vr32id | P | vr32id | Identifikace kalendáře
ix_VRKAL_vr32nazkal |  | vr32nazkal | Název kalendáře musí být uveden


VRKALLIN Směna výrobní linky

Popis

Směna výrobní linky

Atributy

Atribut | Typ | Návěští | Message | Popis
tp23datum | D | Datum | Datum v kalendáři využití linky | Datum v kalendáři využití linky
tp23smena | N(1,0) | Číslo směny | Číslo směny | Číslo směny
tp13id | C(6) | Číslo linky | Číslo výrobní linky, resp. stroje | Číslo výrobní linky, resp. stroje
vr32id | C(6) | Kalendář | Identifikace kalendáře | Identifikace kalendáře
tp23casod | C(4) | Od | Hodina začátku směny | Hodina začátku směny
tp23koment | M | Poznámka | Poznámka | Poznámka
tp23trvani | N(5,2) | Doba trvání | Doba trvání směny v hodinách | Doba trvání směny v hodinách
tp23uskut | N(1,0) | Směna se uskuteční (uskutečnila) | Směna se uskuteční (uskutečnila) Ano/Ne | Směna se uskuteční (uskutečnila) Ano/Ne

Indexy

Název | Primární | Výraz | Popis
ix_VRKALLIN_vrkallin |  | tp23datum, tp23smena, tp13id | Index - tp23datum+tp23smena+tp13id
ix_VRKALLIN_tp13id |  | tp13id | Číslo výrobní linky, resp. stroje
ix_VRKALLIN_vr32id |  | vr32id | Identifikace kalendáře


VRKALPLI Přidělení kalendáře lince

Popis

Přidělení kalendáře lince

Atributy

Atribut | Typ | Návěští | Message | Popis
vr32id | C(6) | Kalendář | Identifikace kalendáře | Identifikace kalendáře
tp13id | C(6) | Číslo linky | Číslo výrobní linky, resp. stroje | Číslo výrobní linky, resp. stroje
vr36datod | D | Platnost od | Platnost od | Platnost od
vr36datdo | D | do | Platnost do | Platnost do

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Přidělení kalendáře lince - určuje linku přidělenou kalendáři | VRKALPLI tp13id | 1,1 : 0,M s rušením | TPLINKA tp13id |
Přidělení kalendáře lince - určuje kalendář přidělený výrobní lince | VRKALPLI vr32id | 1,1 : 0,M s rušením | VRKAL vr32id |

Indexy

Název | Primární | Výraz | Popis
ix_VRKALPLI_vrkalpli | P | vr32id, tp13id, vr36datod | Jednoznačná časová identifikace
ix_VRKALPLI_vr32id |  | vr32id | Identifikace kalendáře
ix_VRKALPLI_tp13id |  | tp13id | Číslo výrobní linky, resp. stroje
ix_VRKALPLI_vr36datod |  | vr36datod | Platnost od


VRKALPOL Položka kalendáře výroby

Popis

Položka kalendáře výroby

Atributy

Atribut | Typ | Návěští | Message | Popis
tp23datum | D | Datum | Datum v kalendáři využití linky | Datum v kalendáři využití linky
tp23smena | N(1,0) | Číslo směny | Číslo směny | Číslo směny
vr32id | C(6) | Kalendář | Identifikace kalendáře | Identifikace kalendáře
tp23casod | C(4) | Od | Hodina začátku směny | Hodina začátku směny
tp23koment | M | Poznámka | Poznámka | Poznámka
tp23trvani | N(5,2) | Doba trvání | Doba trvání směny v hodinách | Doba trvání směny v hodinách
tp23uskut | N(1,0) | Směna se uskuteční (uskutečnila) | Směna se uskuteční (uskutečnila) Ano/Ne | Směna se uskuteční (uskutečnila) Ano/Ne

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Položka kalendáře výroby - se patří do kalendáře | VRKALPOL vr32id | 1,1 : 0,M | VRKAL vr32id |

Indexy

Název | Primární | Výraz | Popis
ix_VRKALPOL_vrkalpol | P | tp23datum, tp23smena, vr32id | PI - tp23datum+tp23smena+vr32id
ix_VRKALPOL_vr32id |  | vr32id | Identifikace kalendáře


VRUDOPER Událost úkolu ve výrobě

Popis

Objektem typu VRUDOPR je každý záznam, který obsahuje událost úkolu ve výrobě.

Atributy

Atribut | Typ | Návěští | Message | Popis
vr09 | C(12) | vr09 | Časová identifikace události. | Časová identifikace události.
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
vr02vyrc | C(15) | Výroba č. | Číslo výroby. | Číslo výroby.
vr09skup | C(3) | Skupina | Skupina výrobních úkolů | Skupina výrobních úkolů
vr09porc | C(6) | Poř.č. | Pořadové číslo úkolu v rámci výrobní zakázky | Pořadové číslo úkolu v rámci výrobní zakázky
vr09faze | N(1,0) | Fáze | Fáze výroby. | Fáze výroby.
vr09aktual | N(1,0) | Aktuální | Aktuální výrobní úkol Ano/Ne | Aktuální výrobní úkol Ano/Ne
tp05id | C(13) | Operace | Identifikace technologické operace | Identifikace technologického kroku
tp13id | C(6) | Číslo linky | Číslo výrobní linky, resp. stroje | Číslo výrobní linky, resp. stroje
tp12id | C(6) | Druh linky | Identifikace druhu výrobní linky | Identifikace druhu výrobní linky
vr09datum | T | Datum | Datum | Datum
vr09trvani | N(10,5) | Trvání (hod) | Délka trvání výrobního úkolu | Délka trvání výrobního úkolu
tp23smena | N(1,0) | Číslo směny | Číslo směny | Číslo směny
vr09koment | M | Poznámka | Poznámka, podrobně popisující událost výrobního úkolu | Komentář, podrobně popisující událost výrobního úkolu
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
vr09mn | N(20,4) | Množství | Objem výrobního úkolu | Objem výrobního úkolu
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
vr09text | C(40) | Popis | Popis události | Popis události
vr09harhid | N(1,0) | Skryté | Příznak skrytého úkolu v harmonogramu | Příznak skrytého úkolu v harmonogramu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost úkolu ve výrobě - zahrnuje výrobní operaci | VRUDOPER tp05id | 1,1 : 0,M | TPOPERAC tp05id |
Událost úkolu ve výrobě - zapsal uživatel | VRUDOPER bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost úkolu ve výrobě - zahrnuje obchodní selektor | VRUDOPER sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost úkolu ve výrobě - zahrnuje organizační selektor | VRUDOPER sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost úkolu ve výrobě - zahrnuje technicko-věcný selektor | VRUDOPER sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost úkolu ve výrobě - souvisí s výrobou | VRUDOPER vr02vyrc | 1,1 : 0,M | VRVYR vr02vyrc |
Událost úkolu ve výrobě - patří do fyzické operace | VRUDOPER sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost úkolu ve výrobě - se týká linky | VRUDOPER tp13id | 1,1 : 0,M | TPLINKA tp13id |
Událost úkolu ve výrobě - je úkolem vyrobit/zpracovat artikl | VRUDOPER sp60id sp61id | 1,1 : 0,M | TPVYROB sp60id sp61id |
Následující skupina úkolů výroby - má předcházející úkol | VRUDOPNS vr09 | 1,1 : 0,M s rušením | VRUDOPER vr09 |
Vstup nebo výstup výrobního úkolu - patří k operaci | VRUDOPMA vr02vyrc vr09skup vr09porc vr09faze | 1,1 : 0,M s rušením | VRUDOPER vr02vyrc vr09skup vr09porc vr09faze |

Indexy

Název | Primární | Výraz | Popis
ix_VRUDOPER_vr09 | P | vr09 | Časová identifikace události.
ix_VRUDOPER_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_VRUDOPER_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_VRUDOPER_vrudoper | U | vr02vyrc, vr09skup, vr09porc, vr09faze | UI - vr09porc+vr09skup+vr02vyrc+vr09faze
ix_VRUDOPER_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_VRUDOPER_vr02vyrc |  | vr02vyrc | Číslo výroby.
ix_VRUDOPER_tp05id |  | tp05id | Identifikace technologického kroku
ix_VRUDOPER_tp13id |  | tp13id | Číslo výrobní linky, resp. stroje
ix_VRUDOPER_tp12id |  | tp12id | Identifikace druhu výrobní linky
ix_VRUDOPER_vr09datum |  | vr09datum | Datum
ix_VRUDOPER_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_VRUDOPER_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_VRUDOPER_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_VRUDOPER_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_VRUDOPER_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_VRUDOPER_vr09text |  | vr09text | Popis události


VRUDOPMA Vstup nebo výstup výrobního úkolu

Popis

Vstupy a výstupy výrobního kroku

Atributy

Atribut | Typ | Návěští | Message | Popis
vr14 | C(12) | vr14 | Časová identifikace | Časová identifikace
vr02vyrc | C(15) | Výroba č. | Číslo výroby. | Číslo výroby.
vr09skup | C(3) | Skupina | Skupina výrobních úkolů | Skupina výrobních úkolů
vr09porc | C(6) | Poř.č. | Pořadové číslo úkolu v rámci výrobní zakázky | Pořadové číslo úkolu v rámci výrobní zakázky
vr09faze | N(1,0) | Fáze | Fáze výroby. | Fáze výroby.
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
vr09 | C(12) | vr09 | Časová identifikace události. | Časová identifikace události.
vr14privyd | N(1,0) | vr14privyd | Vstup / Výstup | Vstup / Výstup
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
vr14mnokon | N(1,0) | vr14mnokon | Konečné množství na vstupu | Konečné množství na vstupu
sp24idmj | C(3) | MJ | Identifikátor měrné jednotky | Identifikátor měrné jednotky
vr14mn | N(20,6) | Množství | Množství | Množství
vr14cena | N(20,4) | Cena | Celková cena | Celková cena
vr14cj | N(20,4) | Cena za j. | Cena za jednotku materiálu. | Cena za jednotku materiálu.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
mz01id | C(6) | Pracovník | Jednoznačná identifikace pracovníka | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
vr14datum | T | Datum | Datum události. | Datum události.
vr14koment | M | Komentář | Komentář, podrobně popisující událost pohybu materiálu ve výrobě. | Komentář, podrobně popisující událost pohybu materiálu ve výrobě.
vr14text | C(40) | Popis | Popis | Popis
tp17id | C(6) | Úložiště | Identifikace skladového úložiště | Identifikace skladového úložiště
tp27id | C(3) | KV | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
vr14casop | N(1,0) | Čas | Čas konstantní nebo odvozený z trvání úkolu | Čas konstantní nebo odvozený z trvání úkolu
vr14procca | N(6,2) | Proc. čas oper. | Výkon jako procento času trvání úkolu | Výkon jako procento času trvání úkolu
tp13id | C(6) | Číslo linky | Číslo výrobní linky, resp. stroje | Číslo výrobní linky, resp. stroje

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vstup nebo výstup výrobního úkolu - zahrnuje obchodní selektor | VRUDOPMA sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Vstup nebo výstup výrobního úkolu - zahrnuje organizační selektor | VRUDOPMA sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Vstup nebo výstup výrobního úkolu - zahrnuje technicko-věcný selektor | VRUDOPMA sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Vstup nebo výstup výrobního úkolu - zapsal uživatel | VRUDOPMA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Vstup nebo výstup výrobního úkolu - patří do fyzické operace | VRUDOPMA sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 0,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Vstup nebo výstup výrobního úkolu - patří k operaci | VRUDOPMA vr02vyrc vr09skup vr09porc vr09faze | 1,1 : 0,M s rušením | VRUDOPER vr02vyrc vr09skup vr09porc vr09faze |
Vstup nebo výstup výrobního úkolu - se vztahuje k artiklu výroby | VRUDOPMA sp60id sp61id | 1,1 : 0,M | TPVYROB sp60id sp61id |
Vstup nebo výstup výrobního úkolu - má množství artiklu uvedeno v měrné jednotce | VRUDOPMA sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Vstup nebo výstup výrobního úkolu - je ukládán na skladové úložiště TPV | VRUDOPMA tp17id | 1,1 : 0,M | TPLINKA tp13id |
Vstup nebo výstup výrobního úkolu - má výpočet podle kalkulačního vzorce nebo je proměnnou kalkulačního vzorce | VRUDOPMA tp27id | 1,1 : 0,M | TPKALK tp27id |
Vstup nebo výstup výrobního úkolu - byl proveden pracovníkem | VRUDOPMA mz01id | 1,1 : 0,M | MZKARTA mz01id |
Vstup nebo výstup výrobního úkolu - je prováděn na stroji | VRUDOPMA tp13id | 1,1 : 0,M | TPLINKA tp13id |

Indexy

Název | Primární | Výraz | Popis
ix_VRUDOPMA_vr14 | P | vr14 | Časová identifikace
ix_VRUDOPMA_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_VRUDOPMA_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_VRUDOPMA_vr09 |  | vr09 | Časová identifikace události.
ix_VRUDOPMA_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_VRUDOPMA_vrudoper |  | vr02vyrc, vr09skup, vr09porc, vr09faze | UI - vr09porc+vr09skup+vr02vyrc+vr09faze
ix_VRUDOPMA_vrudmnkon |  | vr14mnokon, vr09faze, vr14privyd | Index - vr14mnokon+vr14faze+vr14privyd
ix_VRUDOPMA_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky
ix_VRUDOPMA_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_VRUDOPMA_mz01id |  | mz01id | Jednoznačná identifikace pracovníka - osobní číslo pracovníka.
ix_VRUDOPMA_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_VRUDOPMA_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_VRUDOPMA_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_VRUDOPMA_vr14datum |  | vr14datum | Datum události.
ix_VRUDOPMA_vr14text |  | vr14text | Popis
ix_VRUDOPMA_tp17id |  | tp17id | Identifikace skladového úložiště
ix_VRUDOPMA_vr14mnokon |  | vr14mnokon | Konečné množství na vstupu
ix_VRUDOPMA_tp27id |  | tp27id | Identifikace kalkulačního vzorce / identifikace proměnné kalkulačního vzorce
ix_VRUDOPMA_tp13id |  | tp13id | Číslo výrobní linky, resp. stroje


VRUDOPMX Vstup nebo výstup výrobního úkolu - distinct

Popis

Vstup nebo výstup výrobního úkolu - distinct

Atributy

Atribut | Typ | Návěští | Message | Popis
vr02vyrc | C(15) | Výroba č. | Číslo výroby. | Číslo výroby.
vr09skup | C(3) | Skupina | Skupina výrobních úkolů | Skupina výrobních úkolů
vr09porc | C(6) | Poř.č. | Pořadové číslo úkolu v rámci výrobní zakázky | Pořadové číslo úkolu v rámci výrobní zakázky
vr09faze | N(1,0) | Fáze | Fáze výroby. | Fáze výroby.
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu


VRUDOPNS Následující skupina úkolů výroby

Popis

Následující skupina úkolů výroby

Atributy

Atribut | Typ | Návěští | Message | Popis
vr09 | C(12) | vr09 | Časová identifikace události. | Časová identifikace události.
vr02vyrc | C(15) | Výroba č. | Číslo výroby. | Číslo výroby.
vr09skup | C(3) | Skupina | Skupina výrobních úkolů | Skupina výrobních úkolů

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Následující skupina úkolů výroby - má předcházející úkol | VRUDOPNS vr09 | 1,1 : 0,M s rušením | VRUDOPER vr09 |
Následující skupina úkolů výroby - má výrobní číslo | VRUDOPNS vr02vyrc | 1,1 : 0,M | VRVYR vr02vyrc |

Indexy

Název | Primární | Výraz | Popis
ix_VRUDOPNS_vrudopns | P | vr09, vr02vyrc, vr09skup | PI - vr09+vr02vyrc+vr09skup
ix_VRUDOPNS_vr09 |  | vr09 | Časová identifikace události.
ix_VRUDOPNS_vr02vyrc |  | vr02vyrc | Číslo výroby.


VRVYR Výrobní zakázka

Popis

Objektem typu VRVYR je každý záznam, který obsahuje konkrétní informace o vyráběném výrobku.
Lze použít pro sestavení konkrétních plánů, které informují o tom, kdy, na které směně se má jakým způsobem kolik čeho vyrobit.

Atributy

Atribut | Typ | Návěští | Message | Popis
vr02 | C(12) | vr02 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
vr02vyrc | C(15) | Výroba č. | Číslo výroby. | Číslo výroby.
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
vr02datum | D | Datum | Datum výroby od data. | Datum výroby
vr02datkon | D | Datum ukončení | Datum ukončení výroby. | Datum ukončení výroby.
vr02text | C(40) | Popis | Popis výrobní zakázky | Popis výrobní zakázky
vr02smena | N(1,0) | Směna | Směna, na které se bude výrobek vyrábět. | Směna, na které se bude výrobek vyrábět.
vr02faze | N(1,0) | Fáze | Fáze výroby. | Fáze výroby.
sp24idmj | C(3) | MJ | Identifikátor měrné jednotky | Identifikátor měrné jednotky
sp24idmj1 | C(3) | sp24idmj1 | Identifikátor měrné jednotky | Identifikátor měrné jednotky
vr02mn | N(20,4) | Množství | Množství v uvedené jednotce | Množství v uvedené jednotce
vr02mnr | N(20,4) | Mn. ref. | Množství v referenční měrné jednotce | Množství v referenční měrné jednotce
vr02mnrv | N(20,4) | Požadavek | Množství v referenční měrné jednotce - požadavek na výrobu | Množství v referenční měrné jednotce - požadavek na výrobu
vr02procn | N(5,2) | % navýšení | Procento navýšení požadavku na výrobu/zpracování | Procento navýšení požadavku na výrobu/zpracování
vr02vyrob | N(20,4) | Požadavek | Požadované množství, které se má vyrobit. | Požadované množství, které se má vyrobit.
vr02hotovo | N(20,4) | Vyrobeno | Skutečně vyrobené množství. | Skutečně vyrobené množství .
vr02mater | N(1,0) | Materiál | Stav zajištění materiálu. | Stav zajištění materiálu.
vr02polot | N(1,0) | Polotovary | Stav zajištění polotovarů. | Stav zajištění polotovarů.
vr02koment | M | Komentář | Komentář, podrobně popisující požadavek na výrobu. | Komentář, podrobně popisující požadavek na výrobu.
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Výrobní zakázka - výrobního artiklu | VRVYR sp60id sp61id | 1,1 : 0,M | TPVYROB sp60id sp61id |
Výrobní zakázka - zapsána uživatelem | VRVYR bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Výrobní zakázka - obsahuje obchodní selektor | VRVYR sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Výrobní zakázka - obsahuje organizační selektor | VRVYR sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Výrobní zakázka - obsahuje technicko-věcný selektor | VRVYR sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Výrobní zakázka - patří k operaci | VRVYR sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Výrobní zakázka - má množství v uvedené MJ | VRVYR sp24idmj | 1,1 : 0,M | SPMJ sp24idmj |
Výrobní zakázka - má množství v RMJ | VRVYR sp24idmj1 | 1,1 : 0,M | SPMJ sp24idmj |
Výrobní zakázka - je zakázkou apojení adresáta | VRVYR ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Importované měření-vážení výroby - se týká výrobní zakázka | VRIMPVYR vr02vyrc | 1,1 : 0,M s rušením | VRVYR vr02vyrc |
Následující skupina úkolů výroby - má výrobní číslo | VRUDOPNS vr02vyrc | 1,1 : 0,M | VRVYR vr02vyrc |
Událost úkolu ve výrobě - souvisí s výrobou | VRUDOPER vr02vyrc | 1,1 : 0,M | VRVYR vr02vyrc |

Indexy

Název | Primární | Výraz | Popis
ix_VRVYR_vr02 | P | vr02 | Jednoznačná časová identifikace
ix_VRVYR_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_VRVYR_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_VRVYR_vr02vyrc | U | vr02vyrc | Číslo výroby.
ix_VRVYR_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_VRVYR_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_VRVYR_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_VRVYR_sp61id |  | sp61id | Identifikace druhu artiklu
ix_VRVYR_vr02datum |  | vr02datum | Datum výroby
ix_VRVYR_sp24idmj |  | sp24idmj | Identifikátor měrné jednotky
ix_VRVYR_sp24idmj1 |  | sp24idmj1 | Identifikátor měrné jednotky
ix_VRVYR_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_VRVYR_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_VRVYR_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_VRVYR_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_VRVYR_ad01id |  | ad01id | Identifikace adresáta


Tabulky VY...

VYAH | Aktuální hodnota vývěsky
VYAHUD | Událost - skladba aktuální hodnoty vývěsky
VYOZNAC | Uzel vývěsky
VYTEMA | Téma vývěsky
VYUDALOS | Událost vývěsky

Viz.také

VYAH Aktuální hodnota vývěsky | VYAHUD Událost - skladba aktuální hodnoty vývěsky | VYOZNAC Uzel vývěsky | VYTEMA Téma vývěsky | VYUDALOS Událost vývěsky


VYAH Aktuální hodnota vývěsky

Popis

****
****
Objektem aktuální hodnota je každá sledovaná a vypočítavaná hodnota (údaj) vztahující se k libovolné
kombinaci artiklu, umístění a adresáta. V ideálním případě odpovídá aktuální hodnotě v reálném světě.
Obvyklé hodnoty jsou konečný stav a obrat ve finančním nebo naturálním vyjádření.
Př.: dle konkrétní komponenty
Název entity v každé komponentě je doplněn třetím slovem.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
vy52hodnot | N(20,4) | vy52hodnot |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Aktuální hodnota vývěsky - má druh hodnoty | VYAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_VYAH_vyah | P | sp07idtyp, ad01id, sp67id, sp06idsubs |
ix_VYAH_ad01id |  | ad01id | Identifikace adresáta
ix_VYAH_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_VYAH_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace


VYAHUD Událost - skladba aktuální hodnoty vývěsky

Popis

***
***
Tato vazba uvádí, které události se podílejí na skladbě aktuální hodnoty.
Má zejména servisní charakter pro fyzickou implementaci pro ovládání systému.
V LM je možné ztotožnění s objektem skladba aktuální hodnoty.

Atributy

Atribut | Typ | Návěští | Message | Popis
vy01 | C(12) | vy01 | Jednoznačný časový identifikator události vývěsky. | Jednoznačný časový identifikator události vývěsky. *** Dříve VY_ID.
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp74id | C(6) | sp74id | Umístění | Umístění
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp00datum | D | Datum | Datum události | Datum události
sp00text | C(40) | Popis | Popis události | Popis události
sp00hodnot | N(20,4) | Hodnota | Aktuální hodnota procesu |
sp69id | C(6) | Druh | Identifikace druhu saldokontní hodnoty procesu | Identifikace druhu saldokontní hodnoty procesu


VYOZNAC Uzel vývěsky

Popis

Uzly vývěsky

Atributy

Atribut | Typ | Návěští | Message | Popis
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
vy01 | C(12) | vy01 | Jednoznačný časový identifikator události vývěsky. | Jednoznačný časový identifikator události vývěsky. *** Dříve VY_ID.
vy51icon | C(50) | Ikona | Ikona pro uzel vývěsky | Ikona pro uzel vývěsky
vy51top | N(4,0) | vy51top |  |
vy51left | N(4,0) | vy51left |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Uzel vývěsky - je události | VYOZNAC vy01 | 1,1 : 0,M s rušením | VYUDALOS vy01 |
Uzel vývěsky - patří uživateli | VYOZNAC bw01uziv | 1,1 : 0,M s rušením | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_VYOZNAC_vyoznac | P | bw01uziv, vy01 |


VYTEMA Téma vývěsky

Popis

Objektem typu VYTEMA je každý záznam, který obsahuje definice vlastnosti, která rozděluje události do skupin se společnými charakteristikami. Přiřazení téma záznamu vývěsky umožňuje určitou kategorizaci událostí vývěsky.
Témata jsou obvykle navržena způsobem odpovídajícím organizační struktuře a činnosti firmy. Uživatel si je navrhuje sám podle svých potřeb. Správné navržení těchto témat (co nejvěrněji popisující koloběh informací ve firmě) zvýší efektivní řízení firmy.

Př.: Obchodní kontakty, všeobecné informace, plán výroby, telefonáty uživatelů, servisní práce u zákazníka, administrativa, personalistika ap.

*** Dříve VYVESKAH.

Atributy

Atribut | Typ | Návěští | Message | Popis
vy02 | C(12) | vy02 | Jednoznačný časový identifikátor tématu vývěsky. | Jednoznačný časový identifikátor tématu vývěsky. *** Dříve VYV_OZ0
vy02id | C(6) | Téma | Identifikátor tématu. | Identifikátor tématu. *** Dříve VYV_ID.
vy02tema | C(40) | Název tématu | Text výstižně popisující význam tématu. | Text výstižně popisující význam tématu. *** Dříve VYV_TEMA.
vy02koment | M | Komentář k tématu | Komentář, který detailně popisuje význam tématu. | Komentář, který detailně popisuje význam tématu. *** Dříve VYV_VYZN.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
vy02idx | C(4) | vy02idx |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Téma vývěsky - bylo založeno pracovníkem | VYTEMA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_VYTEMA_vy02 |  | vy02 | Jednoznačný časový identifikátor tématu vývěsky.
ix_VYTEMA_vy02id | P | vy02id | Identifikátor tématu.
ix_VYTEMA_vy02tema |  | vy02tema | Text výstižně popisující význam tématu.


VYUDALOS Událost vývěsky

Popis

Objektem typu VYUDALOS je každý záznam, který obsahuje popis události (nebo informace), která nastala (nebo vznikla) v souvislosti s činností firmy a jejích pracovníků a je zaznamenána na vývěsce.

Př.: Telefonát, úkol, zápis z jednání, obchodní smlouva, informace o konkurenci ap.

*** Dříve VYVESKAP.

'Vývěska', DTOC($$$.vy01datod), ALLTRIM($$$.vy01text), 'Téma - '+ALLT($$$.vy02id) + ' - ' + ALLT(VYTEMA.vy02tema),'', .F.

Atributy

Atribut | Typ | Návěští | Message | Popis
vy01 | C(12) | vy01 | Jednoznačný časový identifikator události vývěsky. | Jednoznačný časový identifikator události vývěsky. *** Dříve VY_ID.
bw01uziv1 | C(6) | bw01uziv1 | Identifikace uživatele systému - druhá identifikace | Identifikace uživatele systému - druhá identifikace předplňovaná většinou na pozadí
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
ad01 | C(12) | ad01 | Jednoznačná časová identifikace adresáta | Jednoznačná časová identifikace adresáta
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
vy01datum | D | Dne | Datum pořízení události. | Datum pořízení události. *** Dříve POZN_DAT.
vy01text | C(40) | Text | Text výstižně popisující událost. | Text výstižně popisující událost. *** Dříve VYV_TEXT.
vy01koment | M | Komentář | Komentář, který detailně popisuje událost. | Komentář, který detailně popisuje událost. *** Dříve POZN_TEXT.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
spf8id | C(6) | Typ | Identifikátor typu události komponenty | Identifikátor typu události komponenty
vy01blok | N(1,0) | vy01blok | Příznak blokování záznamu události pro opravu. | Příznak blokování záznamu události pro opravu. *** Dříve VYV_BLOCK.
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
vy01exim | C(1) | vy01exim | Příznak provedení upřesnění - jediný jeho význam je při importu - nakopíruje se do struktury souboru EXUDALOS, a tam se po změně adresáta naplní, ve stálém souboru VYUDALOS není nikdy použit. Zaveden je místo relačně navázaného pracovního souboru. | Příznak provedení upřesnění - jediný jeho význam je při importu - nakopíruje se do struktury souboru EXUDALOS, a tam se po změně adresáta naplní, ve stálém souboru VYUDALOS není nikdy použit. Zaveden je místo relačně navázaného pracovního souboru.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost vývěsky - má uvedeno téma (typ operace) | VYUDALOS sp07idtyp sp06idsubs | 1,1 : 0,M | SPTYP sp07idtyp sp06idsubs |
Událost vývěsky - zapsal pracovník | VYUDALOS bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost vývěsky - má organizační selektor | VYUDALOS sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost vývěsky - má technicko-věcný selektor | VYUDALOS sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost vývěsky - má obchodní selektor | VYUDALOS sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost vývěsky - náleží fyzické operaci dokladu | VYUDALOS sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 0,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost vývěsky - vyřizuje pracovník | VYUDALOS bw01uziv1 | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost vývěsky - souvisí se spojením adresáta | VYUDALOS ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost vývěsky - je typu | VYUDALOS spf8id | 1,1 : 0,M | SPTYPUD spf8id |
Uzel vývěsky - je události | VYOZNAC vy01 | 1,1 : 0,M s rušením | VYUDALOS vy01 |

Indexy

Název | Primární | Výraz | Popis
ix_VYUDALOS_vy01 | P | vy01 | Jednoznačný časový identifikator události vývěsky.
ix_VYUDALOS_bw01uziv1 |  | bw01uziv1 | Identifikace uživatele systému - druhá identifikace předplňovaná většinou na pozadí
ix_VYUDALOS_sp00datzap |  | sp00datzap | Datum a čas zápisu záznamu události
ix_VYUDALOS_ad01 |  | ad01 | Jednoznačná časová identifikace adresáta
ix_VYUDALOS_ad01id |  | ad01id | Identifikace adresáta
ix_VYUDALOS_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_VYUDALOS_vy01datum |  | vy01datum | Datum pořízení události.
ix_VYUDALOS_vy01text |  | vy01text | Text výstižně popisující událost.
ix_VYUDALOS_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_VYUDALOS_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_VYUDALOS_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_VYUDALOS_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_VYUDALOS_spf8id |  | spf8id | Identifikátor typu události komponenty
ix_VYUDALOS_spprc |  | sp33cisd, sp33cisdpm, sp33cisdr | Identifikace procesu
ix_VYUDALOS_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_VYUDALOS_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_VYUDALOS_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.


Tabulky ZA...

ZAAH | Aktuální hodnota záloh
ZAAHUD | Události záloh - skladba
ZAFIFO | Spojení předepsání a výúčtování zálohy
ZAKARTA | Karta zálohy
ZAPAROPE | Parametry operace komponenty ZAL
ZAUDAL | Událost o záloze
ZAUMISTE | Umístění zálohy

Viz.také

ZAAH Aktuální hodnota záloh | ZAAHUD Události záloh - skladba | ZAFIFO Spojení předepsání a výúčtování zálohy | ZAKARTA Karta zálohy | ZAUDAL Událost o záloze | ZAUMISTE Umístění zálohy | ZAPAROPE Parametry operace komponenty ZAL


ZAAH Aktuální hodnota záloh

Popis

Aktuální hodnota záloh

Atributy

Atribut | Typ | Návěští | Message | Popis
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
za04id | C(6) | Umístění | Identifikace umístění zálohy | Identifikace umístění zálohy
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
oc01id2 | C(3) | oc01id2 | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
za02hodnot | N(20,4) | Hodnota | Aktuální hodnota změny stavu záloh | Aktuální hodnota změny stavu záloh

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Aktuální hodnota záloh - týká se druhu hodnoty | ZAAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_ZAAH_zaah | P | sp67id, sp06idsubs, za04id, ad01id, oc01id2 | PI
ix_ZAAH_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_ZAAH_za04id |  | za04id | Identifikace umístění zálohy
ix_ZAAH_ad01id |  | ad01id | Identifikace adresáta
ix_ZAAH_oc01id2 |  | oc01id2 | Kód měny - oceňovací jednotky.
ix_ZAAH_adadsatx |  |  |
ix_ZAAH_za02hodnot |  | za02hodnot | Aktuální hodnota změny stavu záloh


ZAAHUD Události záloh - skladba

Popis

Události záloh - skladba

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
zp02 | C(12) | zp02 | Jednoznačná časová identifikace události změny stavu peněz | Jednoznačná časová identifikace události změny stavu peněz
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp74id | C(6) | sp74id | Umístění | Umístění
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp00datum | D | Datum | Datum události | Datum události
sp00text | C(40) | Popis | Popis události | Popis události
sp00hodnot | N(20,4) | Hodnota | Aktuální hodnota procesu |


ZAFIFO Spojení předepsání a výúčtování zálohy

Popis

Spojení předepsání u a výúčtování zálohy

Atributy

Atribut | Typ | Návěští | Message | Popis
za02 | C(12) | za02 | Jednoznačná časová identifikace zálohy | Jednoznačná časová identifikace zálohy
za02v | C(12) | za02v | Jednoznačná časová identifikace vyúčtování zálohy | Jednoznačná časová identifikace vyúčtování zálohy
za05cum | N(20,4) | Spojená částka | Částka v měně úhrady zálohy | Částka v měně předepsání zálohy

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Spojení předepsání a výúčtování zálohy - spojuje událost předepsání | ZAFIFO za02 | 1,1 : 0,M | ZAUDAL za02 |
Spojení předepsání a výúčtování zálohy - spojuje událost vyúčtování | ZAFIFO za02v | 1,1 : 0,M s rušením | ZAUDAL za02 |

Indexy

Název | Primární | Výraz | Popis
ix_ZAFIFO_zafifo | P | za02, za02v | PI - za02+za02v
ix_ZAFIFO_za02 |  | za02 | Jednoznačná časová identifikace zálohy
ix_ZAFIFO_za02v |  | za02v | Jednoznačná časová identifikace vyúčtování zálohy


ZAKARTA Karta zálohy

Popis

Karta zálohy

Atributy

Atribut | Typ | Návěští | Message | Popis
za02id | C(32) | Záloha | Identifikace zálohy | Identifikace zálohy
oc01id2 | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
za02pripos | N(1,0) | P/P | Záloha přijatá/poskytnutá | Záloha přijatá/poskytnutá
za02cum | N(20,4) | Částka v MÚ | Částka v měně úhrady zálohy | Částka v měně předepsání zálohy
za02cumnv | N(20,4) | Zbývá vyúčtovat | Dosud nevyúčtovaná část zálohy | Dosud nevyúčtovaná část zálohy

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Karta zálohy - je karta adresáta | ZAKARTA ad01id | 1,1 : 0,M | ADADSAT ad01id |

Indexy

Název | Primární | Výraz | Popis
ix_ZAKARTA_zakarta |  | za02id, oc01id2, ad01id, za02pripos |
ix_ZAKARTA_za02id |  | za02id | Identifikace zálohy
ix_ZAKARTA_oc01id2 |  | oc01id2 | Kód měny - oceňovací jednotky.
ix_ZAKARTA_ad01id |  | ad01id | Identifikace adresáta


ZAPAROPE Parametry operace komponenty ZAL

Popis

Parametry operace komponenty ZAL

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
za07ukurro | N(1,0) | za07ukurro | Operace pro určení kurzového rozdílu zálohy | Operace pro určení kurzového rozdílu zálohy
za07koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametry operace komponenty ZAL - Jsou pro operaci komponenty ZAL | ZAPAROPE sp07idtyp sp06idsubs | 1,1 : 0,1 s rušením | SPTYP sp07idtyp sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_ZAPAROPE_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému


ZAUDAL Událost o záloze

Popis

Událost o záloze

Atributy

Atribut | Typ | Návěští | Message | Popis
za02 | C(12) | za02 | Jednoznačná časová identifikace zálohy | Jednoznačná časová identifikace zálohy
za02prevyu | N(1,0) | Charakter | Charakter události úhrada/vyúčtování zálohy | Charakter události předepsání/vyúčtování zálohy
za02pripos | N(1,0) | P/P | Záloha přijatá/poskytnutá | Záloha přijatá/poskytnutá
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
za02id | C(32) | Záloha | Identifikace zálohy | Identifikace zálohy
oc01id2 | C(3) | oc01id2 | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
oc01id1 | C(3) | oc01id1 | Referenční měna | Referenční měna kursu (je na pozadí)
oc03kurz | N(20,6) | Kurs | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup. | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup.
oc03mn | N(5,0) | Množství | Množství oceňovací jednotky v kursu. | Množství oceňovací jednotky v kurzu.
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
za04id | C(6) | Umístění | Identifikace umístění zálohy | Identifikace umístění zálohy
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
za02czm | N(20,4) | Částka v ZM | Částka v zahraniční měně | Částka v zahraniční měně
za02crm | N(20,4) | Částka v RM | Částka v referenční měně | Částka v referenční měně
za02cum | N(20,4) | Částka v MÚ | Částka v měně úhrady zálohy | Částka v měně předepsání zálohy
za02datum | D | Datum | Datum události | Datum události
za02text | C(40) | Popis | Popis události | Popis události
za02koment | M | Poznámka | Poznámka | Poznámka
za02cumnv | N(20,4) | Zbývá vyúčtovat | Dosud nevyúčtovaná část zálohy | Dosud nevyúčtovaná část zálohy
za02kuroz | N(20,4) | Kurzový rozdíl | Kurzový rozdíl | Kurzový rozdíl
za02p | C(12) | za02p | Jednoznačná časová identifikace zálohy předchůdce pro kurzový rozdíl | Jednoznačná časová identifikace zálohy předchůdce pro kurzový rozdíl

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost o záloze - vznikla v operaci | ZAUDAL sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost o záloze - má spojení adresáta | ZAUDAL ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost o záloze - se spojená s adresátem | ZAUDAL ad01id | 1,1 : 0,M | ADADSAT ad01id |
Událost o záloze - založil uživatel | ZAUDAL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost o záloze - má obchodní selektor | ZAUDAL sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost o záloze - má organizační selektor | ZAUDAL sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost o záloze - má technicko-věcný selektor | ZAUDAL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost o záloze - je spojena s umístěním zálohy | ZAUDAL za04id | 1,1 : 0,M | ZAUMISTE za04id |
Událost o záloze - uvádí částku v zahraniční měně | ZAUDAL oc01id | 1,1 : 0,M | OCMENA oc01id |
Událost o záloze - uvádí částku v refrenční měně | ZAUDAL oc01id1 | 1,1 : 0,M | OCMENA oc01id |
Událost o záloze - uvádí částku v měně předpisu zálohy | ZAUDAL oc01id2 | 1,1 : 0,M | OCMENA oc01id |
Spojení předepsání a výúčtování zálohy - spojuje událost předepsání | ZAFIFO za02 | 1,1 : 0,M | ZAUDAL za02 |
Spojení předepsání a výúčtování zálohy - spojuje událost vyúčtování | ZAFIFO za02v | 1,1 : 0,M s rušením | ZAUDAL za02 |

Indexy

Název | Primární | Výraz | Popis
ix_ZAUDAL_za02 | P | za02 | Jednoznačná časová identifikace zálohy
ix_ZAUDAL_za02prevyu |  | za02prevyu | Charakter události předepsání/vyúčtování zálohy
ix_ZAUDAL_adadsatx |  |  |
ix_ZAUDAL_spprc |  | sp33cisd, sp33cisdpm, sp33cisdr | Identifikace procesu
ix_ZAUDAL_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_ZAUDAL_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_ZAUDAL_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_ZAUDAL_zakarta |  | za02id, oc01id2, ad01id, za02pripos |
ix_ZAUDAL_za02id |  | za02id | Identifikace zálohy
ix_ZAUDAL_ad01id |  | ad01id | Identifikace adresáta
ix_ZAUDAL_oc01id |  | oc01id | Kód měny - oceňovací jednotky.
ix_ZAUDAL_oc01id1 |  | oc01id1 | Referenční měna kursu (je na pozadí)
ix_ZAUDAL_oc01id2 |  | oc01id2 | Kód měny - oceňovací jednotky.
ix_ZAUDAL_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_ZAUDAL_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_ZAUDAL_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_ZAUDAL_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_ZAUDAL_za04id |  | za04id | Identifikace umístění zálohy
ix_ZAUDAL_sp00datzap |  | sp00datzap | Datum a čas zápisu záznamu události
ix_ZAUDAL_za02datum |  | za02datum | Datum události
ix_ZAUDAL_za02text |  | za02text | Popis události
ix_ZAUDAL_za02cumnv |  | za02cumnv | Dosud nevyúčtovaná část zálohy
ix_ZAUDAL_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.


ZAUMISTE Umístění zálohy

Popis

Umístění zálohy

Atributy

Atribut | Typ | Návěští | Message | Popis
za04id | C(6) | Umístění | Identifikace umístění zálohy | Identifikace umístění zálohy
za04text | C(40) | Název umístění | Název umístění zálohy | Název umístění zálohy
za04koment | M | Poznámka | Poznámka | Poznámka
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Umístění zálohy - má organizační selektor | ZAUMISTE sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost o záloze - je spojena s umístěním zálohy | ZAUDAL za04id | 1,1 : 0,M | ZAUMISTE za04id |

Indexy

Název | Primární | Výraz | Popis
ix_ZAUMISTE_za04id | P | za04id | Identifikace umístění zálohy
ix_ZAUMISTE_za04text |  | za04text | Název umístění zálohy
ix_ZAUMISTE_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.


Tabulky ZP...

ZPAH | Aktuální hodnota změny stavu peněz
ZPAHR | Aktuální hodnota změny stavu peněz (replikovaná)
ZPAHUD | Událost - skladba
ZPOBRAT | Obrat účtu ZP
ZPOBRATQ | Pohled pro zjištění posledního data obratu ZP
ZPPAROPE | Parametry operace komponenty ZSP
ZPPARZSP | Parametry změny stavu peněz
ZPPRHLA | Definice přenosu příkazu
ZPPRHLX | Podmíněná definice přenosu příkazu
ZPPRPOL | Polozky definice platebniho prikazu
ZPUDA | Událost změny stavu peněz - výpisy a příkazy
ZPUHR | Vazba platba - výpis

Viz.také

ZPAH Aktuální hodnota změny stavu peněz | ZPAHR Aktuální hodnota změny stavu peněz (replikovaná) | ZPAHUD Událost - skladba | ZPOBRAT Obrat účtu ZP | ZPOBRATQ Pohled pro zjištění posledního data obratu ZP | ZPPRHLA Definice přenosu příkazu | ZPPRPOL Polozky definice platebniho prikazu | ZPUDA Událost změny stavu peněz - výpisy a příkazy | ZPUHR Vazba platba - výpis | ZPPAROPE Parametry operace komponenty ZSP | ZPPRHLX Podmíněná definice přenosu příkazu | ZPPARZSP Parametry změny stavu peněz


ZPAH Aktuální hodnota změny stavu peněz

Popis

Aktuální hodnota změny stavu peněz

Atributy

Atribut | Typ | Návěští | Message | Popis
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
pl01id | C(6) | Účet/pokladna | Identifikace účtu/pokladny | Identifikace účtu/pokladny
oc01id2 | C(3) | oc01id2 | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
zp02hodnot | N(20,4) | zp02hodnot |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Aktuální hodnota změny stavu peněz - se týká druhu statistické informace | ZPAH sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_ZPAH_zpah | P | sp67id, sp06idsubs, ad01id, pl01id, oc01id2 |
ix_ZPAH_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_ZPAH_ad01id |  | ad01id | Identifikace adresáta
ix_ZPAH_pl01id |  | pl01id | Identifikace účtu/pokladny
ix_ZPAH_oc01id2 |  | oc01id2 | Kód měny - oceňovací jednotky.
ix_ZPAH_zp02hodnot |  | zp02hodnot |
ix_ZPAH_adadsatx |  |  |


ZPAHR Aktuální hodnota změny stavu peněz (replikovaná)

Popis

Aktuální hodnota změny stavu peněz (replikovaná)

Atributy

Atribut | Typ | Návěští | Message | Popis
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
pl01id | C(6) | Účet/pokladna | Identifikace účtu/pokladny | Identifikace účtu/pokladny
oc01id2 | C(3) | oc01id2 | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
zp02hodnot | N(20,4) | zp02hodnot |  |

Indexy

Název | Primární | Výraz | Popis
ix_ZPAHR_zpah | P | sp67id, sp06idsubs, ad01id, pl01id, oc01id2 |


ZPAHUD Událost - skladba

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33hid | C(12) | sp33hid | Časová identifikace hlavního procesu | Časová identifikace hlavního procesu
zp02 | C(12) | zp02 | Jednoznačná časová identifikace události změny stavu peněz | Jednoznačná časová identifikace události změny stavu peněz
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp74id | C(6) | sp74id | Umístění | Umístění
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp00datum | D | Datum | Datum události | Datum události
sp00text | C(40) | Popis | Popis události | Popis události
sp00hodnot | N(20,4) | Hodnota | Aktuální hodnota procesu |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost - skladba - týká se adresáta | ZPAHUD ad01id | 0,1 : 0,M | ADADSAT ad01id |
Událost - skladba - koresponduje s aktuální hodnotou procesu | ZPAHUD sp33hid ad01id sp60id sp61id sp74id | 1,1 : 0,M | SPPRCSAL sp33hid ad01id sp60id sp61id sp74id |
Událost - skladba - týká se druhu hodnoty | ZPAHUD sp67id sp06idsubs | 0,1 : 0,M | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_ZPAHUD_sp33hid |  | sp33hid | Časová identifikace hlavního procesu
ix_ZPAHUD_zp02 |  | zp02 | Jednoznačná časová identifikace události změny stavu peněz
ix_ZPAHUD_ad01id |  | ad01id | Identifikace adresáta
ix_ZPAHUD_sp74id |  | sp74id | Umístění
ix_ZPAHUD_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace


ZPOBRAT Obrat účtu ZP

Popis

Obraty účtů ZP

Atributy

Atribut | Typ | Návěští | Message | Popis
zp11datum | D | Datum | Datum obratu | Datum obratu
oc01id2 | C(3) | oc01id2 | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
pl01id | C(6) | Účet/pokladna | Identifikace účtu/pokladny | Identifikace účtu/pokladny
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
zp11pstav | N(20,4) | Poč.stav | Počáteční stav | Počáteční stav
zp11prijem | N(20,4) | Příjem | Příjem | Příjem
zp11vydej | N(20,4) | Výdej | Výdej | Výdej

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Obrat účtu ZP - se vztahuje k druhu hodnoty | ZPOBRAT sp67id sp06idsubs | 1,1 : 0,M s rušením | SPSTATDI sp67id sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_ZPOBRAT_zpobrat | P | zp11datum, oc01id2, pl01id, sp67id, sp06idsubs, ad01id | PI - obraty účtů ZP
ix_ZPOBRAT_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_ZPOBRAT_zp11datum |  | zp11datum | Datum obratu
ix_ZPOBRAT_pl01id |  | pl01id | Identifikace účtu/pokladny
ix_ZPOBRAT_ad01id |  | ad01id | Identifikace adresáta
ix_ZPOBRAT_oc01id2 |  | oc01id2 | Kód měny - oceňovací jednotky.
ix_ZPOBRAT_adadsatx |  |  |


ZPOBRATQ Pohled pro zjištění posledního data obratu ZP

Popis

Pohled pro zjištění posledního data obratu ZP

Atributy

Atribut | Typ | Návěští | Message | Popis
zp11datum | D | Datum | Datum obratu | Datum obratu
pl01id | C(6) | Účet/pokladna | Identifikace účtu/pokladny | Identifikace účtu/pokladny
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
oc01id2 | C(3) | oc01id2 | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.


ZPPAROPE Parametry operace komponenty ZSP

Popis

Parametry operace komponenty ZSP

Atributy

Atribut | Typ | Návěští | Message | Popis
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
zp15nulzm | N(1,0) | zp15nulzm | Povolit nulovou částku v ZM | Povolit nulovou částku v ZM
zp15koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametry operace komponenty ZSP - Jsou pro operaci komponenty ZSP | ZPPAROPE sp07idtyp sp06idsubs | 1,1 : 0,1 | SPTYP sp07idtyp sp06idsubs |

Indexy

Název | Primární | Výraz | Popis
ix_ZPPAROPE_sptyp | P | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému


ZPPARZSP Parametry změny stavu peněz

Atributy

Atribut | Typ | Návěští | Message | Popis
zp18 | C(12) | zp18 | Primární klíč parametrů komponenty ZSP |
sp67id | C(3) | Druh hodnoty | Identifikace druhu hodnoty | Identifikace druhu statistické informace
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametry změny stavu peněz - definují druh hodnoty - stav ve finančním vyjádření | ZPPARZSP sp67id sp06idsubs | 1,1 : 0,M | SPSTATDI sp67id sp06idsubs |
Parametry změny stavu peněz - aktualizoval uživatel | ZPPARZSP bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |

Indexy

Název | Primární | Výraz | Popis
ix_ZPPARZSP_zp18 | P | zp18 |
ix_ZPPARZSP_spstatdi |  | sp67id, sp06idsubs | Primární index druhu sledované informace
ix_ZPPARZSP_bw01uziv |  | bw01uziv | Identifikace uživatele systému


ZPPRHLA Definice přenosu příkazu

Popis

Definice přenosu příkazu

Atributy

Atribut | Typ | Návěští | Message | Popis
zp07id | C(6) | Přenos | Identifikace definice přenosů | Identifikace definice přenosů
zp07nazev | C(40) | zp07nazev |  |
zp07ext | C(3) | zp07ext |  |
zp07if | M | zp07if |  |
zp07komen | M | zp07komen |  |
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
zp07radek | M | zp07radek |  |
zp07posl | M | zp07posl |  |
zp07outsou | C(160) | zp07outsou |  |
zp07insou | C(160) | zp07insou |  |
zp07inpro | C(10) | zp07inpro |  |
zp07outfor | C(10) | zp07outfor |  |
zp07prom1 | M | zp07prom1 |  |
zp07prom2 | M | zp07prom2 |  |
zp07prom3 | M | zp07prom3 |  |
zp07prom4 | M | zp07prom4 |  |
zp07prom5 | M | zp07prom5 |  |
zp07outpro | C(10) | zp07outpro |  |
zp07outpar | M | zp07outpar |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Definice přenosu příkazu - zapsal | ZPPRHLA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Podmíněná definice přenosu příkazu - má nadřízenou definici přenosu | ZPPRHLX zp07idp | 1,1 : 0,M s rušením | ZPPRHLA zp07id |
Podmíněná definice přenosu příkazu - určuje definici přenosu příkazu | ZPPRHLX zp07id | 1,1 : 0,M | ZPPRHLA zp07id |
Účet/pokladna (vlastní) - má definice přenosu příkazu | PLUP zp07id | 0,1 : 0,M | ZPPRHLA zp07id |
Polozky definice platebniho prikazu - ma hlavicku | ZPPRPOL zp07id | 1,1 : 0,M | ZPPRHLA zp07id |

Indexy

Název | Primární | Výraz | Popis
ix_ZPPRHLA_zp07id | P | zp07id | Identifikace definice přenosů
ix_ZPPRHLA_zp07nazev |  | zp07nazev |


ZPPRHLX Podmíněná definice přenosu příkazu

Popis

Podmíněná definice přenosu příkazu

Atributy

Atribut | Typ | Návěští | Message | Popis
zp07idp | C(6) | zp07idp | Nadřízená identifikace definice přenosů | Nadřízená identifikace definice přenosů
zp07id | C(6) | Přenos | Identifikace definice přenosů | Identifikace definice přenosů
zp16smer | N(1,0) | Směr | Směr přenosu Vstup/Výstup | Směr přenosu Vstup/Výstup
zp16kod | M | Kód podmínky | Kód podmínky uplatnění přenosu | Kód podmínky uplatnění přenosu
zp16koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Podmíněná definice přenosu příkazu - má nadřízenou definici přenosu | ZPPRHLX zp07idp | 1,1 : 0,M s rušením | ZPPRHLA zp07id |
Podmíněná definice přenosu příkazu - určuje definici přenosu příkazu | ZPPRHLX zp07id | 1,1 : 0,M | ZPPRHLA zp07id |

Indexy

Název | Primární | Výraz | Popis
ix_ZPPRHLX_zpprhlx | P | zp07idp, zp07id, zp16smer | PI - zp07idp+zp07id
ix_ZPPRHLX_zp07idp |  | zp07idp | Nadřízená identifikace definice přenosů
ix_ZPPRHLX_zp07id |  | zp07id | Identifikace definice přenosů


ZPPRPOL Polozky definice platebniho prikazu

Atributy

Atribut | Typ | Návěští | Message | Popis
zp07id | C(6) | Přenos | Identifikace definice přenosů | Identifikace definice přenosů
zp08typ | N(2,0) | zp08typ |  |
zp08prikaz | M | zp08prikaz |  |
zp08koment | M | zp08koment |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Polozky definice platebniho prikazu - ma hlavicku | ZPPRPOL zp07id | 1,1 : 0,M | ZPPRHLA zp07id |

Indexy

Název | Primární | Výraz | Popis
ix_ZPPRPOL_zpprpol | P | zp07id, zp08typ |
ix_ZPPRPOL_zp07id |  | zp07id | Identifikace definice přenosů
ix_ZPPRPOL_zp08typ |  | zp08typ |


ZPUDA Událost změny stavu peněz - výpisy a příkazy

Atributy

Atribut | Typ | Návěští | Message | Popis
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
ad03cisban | C(2) | Účet | Identifikátor spojení na bankovní účet adresáta. | Číslo spojení na bankovní účet adresáta. *** Dříve CISBANK.
oc02idbank | C(4) | Kód banky | Kód banky | Kód banky
ad03pructu | C(6) | Prefix ú. | Prefix bankovního účtu adresáta | Prefix bankovního účtu adresáta
ad03ucet | C(34) | Č. účtu | Číslo bankovního účtu adresáta. | Číslo bankovního účtu adresáta. *** Dříve UCET.
ad03ssymb | C(10) | Specifický symbol | Specifický symbol adresáta | Specifický symbol adresáta
zp02 | C(12) | zp02 | Jednoznačná časová identifikace události změny stavu peněz | Jednoznačná časová identifikace události změny stavu peněz
zp02kredeb | N(1,0) | Příjem/Výdej | Příjem/Výdej = Credit/Debet | Příznak příjem/výdej
zp02text | C(40) | Popis | Popis události | Popis události
zp02dat | D | Datum | Datum výpisu z banky/příkazu k úhradě | Datum výpisu z banky/příkazu k úhradě
pl01id | C(6) | Účet/pokladna | Identifikace účtu/pokladny | Identifikace účtu/pokladny
oc01id | C(3) | Měna | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
zp02czm | N(20,4) | Částka v ZM | Částka k úhradě/inkasu v ZM | Částka k úhradě/inkasu v ZM
oc01id1 | C(3) | oc01id1 | Referenční měna | Referenční měna kursu (je na pozadí)
zp02crm | N(20,4) | Částka v RM | Částka k úhradě/inkasu v RM | Částka k úhradě/inkasu v RM
oc01id2 | C(3) | oc01id2 | Kód měny - oceňovací jednotky. | Kód měny - oceňovací jednotky.
zp02cum | N(20,4) | Částka v MÚ | Částka v měně bankovního účtu / pokladny | Částka v měně účtu
oc03kurz | N(20,6) | Kurs | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup. | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup.
oc03mn | N(5,0) | Množství | Množství oceňovací jednotky v kursu. | Množství oceňovací jednotky v kurzu.
zp02poplz | N(1,0) | Poplatky v zahraničí | Poplatky v zahraničí | Poplatky v zahraničí
zp02poplt | N(1,0) | Poplatky v tuzemsku | Poplatky v tuzemsku | Poplatky v tuzemsku
zp02ucel | C(35) | Důvod | Důvod/účel platby | Důvod/účel platby
zp02titul | C(3) | Titul | Platební titul | Platební titul
pl02vs | C(10) | Variabilní symbol | Variabilní symbol (příjemce) | Variabilní symbol (příjemce)
pl02vs1 | C(10) | Variabilní symbol (plátce) | Variabilní symbol (plátce) | Variabilní symbol (plátce)
pl02ks | C(4) | Konstantní symbol | Konstantní symbol | Konstantní symbol
zp02avizo1 | C(70) | Avízo | Avízo pro příjemce (1. část) | Avízo pro příjemce (1. část)
zp02avizo2 | C(70) | Avízo | Avízo pro příjemce (2. část) | Avízo pro příjemce (2. část)
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
zp02done | N(1,0) | zp02done | Příznak zpracovanosti | Příznak zpracovanosti
zp02czmp | N(20,4) | zp02czmp | Částka v ref.měně spojená se všemi platbami (v absolutní hodnotě) | Částka v ref.měně spojená se všemi platbami
zp02sparov | N(1,0) | zp02sparov | Částka byla spárovaná s platbami | Částka byla spárovaná s platbami
zp02parova | N(1,0) | Párov. | Bude se událost změny stavu peněz párovat na události plateb | Bude se událost změny stavu peněz párovat na události plateb
zp02zauct | N(1,0) | zp02zauct | Změna stavu peněz je považována za zaúčtovanou |
zp02poradi | N(4,0) | zp02poradi |  |

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost změny stavu peněz - výpisy a příkazy - má spojení adresáta | ZPUDA ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost změny stavu peněz - výpisy a příkazy - má bankovní spojení adresáta | ZPUDA ad01id ad03cisban | 0,1 : 0,M | ADBUCTY ad01id ad03cisban |
Událost změny stavu peněz - výpisy a příkazy - má vlastní pokl/účet | ZPUDA pl01id | 1,1 : 0,M | PLUP pl01id |
Událost změny stavu peněz - výpisy a příkazy - má měnu | ZPUDA oc01id | 1,1 : 0,M | OCMENA oc01id |
Událost změny stavu peněz - výpisy a příkazy - má organizační selektor | ZPUDA sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost změny stavu peněz - výpisy a příkazy - má tech.věc selektor | ZPUDA sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Událost změny stavu peněz - výpisy a příkazy - má obchodní selektor | ZPUDA sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost změny stavu peněz - výpisy a příkazy - patří do fyzické operace | ZPUDA sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost změny stavu peněz - výpisy a příkazy - byla zapsána uživateleme | ZPUDA bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost změny stavu peněz - výpisy a příkazy - má měnu bankovního účtu/pokladny | ZPUDA oc01id2 | 1,1 : 0,M | OCMENA oc01id |
Vazba platba - výpis - má výpis | ZPUHR zp02 | 1,1 : 0,M | ZPUDA zp02 |

Indexy

Název | Primární | Výraz | Popis
ix_ZPUDA_spprc |  | sp33cisd, sp33cisdpm, sp33cisdr | Identifikace procesu
ix_ZPUDA_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_ZPUDA_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_ZPUDA_adbucty1 |  | ad01id, ad03cisban | ad01id+ad03cisban
ix_ZPUDA_adbucty4 |  | oc02idbank, ad03pructu, ad03ucet, ad03ssymb | Index : oc02idbank+ad03pructu+ad03ucet
ix_ZPUDA_zpudaucet |  | ad03ucet, ad03pructu, oc02idbank | Index podle identifikace banky,prefix účtu, účet
ix_ZPUDA_adadsatx |  |  |
ix_ZPUDA_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_ZPUDA_zp02 | P | zp02 | Jednoznačná časová identifikace události změny stavu peněz
ix_ZPUDA_zp02text |  | zp02text | Popis události
ix_ZPUDA_zp02dat |  | zp02dat | Datum výpisu z banky/příkazu k úhradě
ix_ZPUDA_oc02idbank |  | oc02idbank | Kód banky
ix_ZPUDA_pl01id |  | pl01id | Identifikace účtu/pokladny
ix_ZPUDA_oc01id |  | oc01id | Kód měny - oceňovací jednotky.
ix_ZPUDA_zp02czm |  | zp02czm | Částka k úhradě/inkasu v ZM
ix_ZPUDA_zp02crm |  | zp02crm | Částka k úhradě/inkasu v RM
ix_ZPUDA_oc01id2 |  | oc01id2 | Kód měny - oceňovací jednotky.
ix_ZPUDA_pl02vs |  | pl02vs | Variabilní symbol (příjemce)
ix_ZPUDA_pl02vs1 |  | pl02vs1 | Variabilní symbol (plátce)
ix_ZPUDA_ad01id |  | ad01id | Identifikace adresáta
ix_ZPUDA_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_ZPUDA_sp00datzap |  | sp00datzap | Datum a čas zápisu záznamu události
ix_ZPUDA_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_ZPUDA_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_ZPUDA_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_ZPUDA_sp33cisd |  | sp33cisd | Číslo procesu
ix_ZPUDA_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_ZPUDA_zp02sparov |  | zp02sparov | Částka byla spárovaná s platbami
ix_ZPUDA_spsp34frei |  |  |
ix_ZPUDA_zp02poradi |  | zp02poradi |


ZPUHR Vazba platba - výpis

Atributy

Atribut | Typ | Návěští | Message | Popis
zp02 | C(12) | zp02 | Jednoznačná časová identifikace události změny stavu peněz | Jednoznačná časová identifikace události změny stavu peněz
pl02 | C(12) | pl02 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
zp02done | N(1,0) | zp02done | Příznak zpracovanosti | Příznak zpracovanosti
zp03czm | N(20,4) | Částka k úhradě | Hodnota částky z výpisu uhrazující platbu v zahraniční měně úhrady | Hodnota částky z výpisu uhrazující platbu v zahraniční měně
zp03czmpl | N(20,4) | zp03czmpl | Hodnota částky z výpisu uhrazující platbu v zahraniční měně platby | Hodnota částky z výpisu uhrazující platbu v zahraniční měně platby

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vazba platba - výpis - má platbu | ZPUHR pl02 | 1,1 : 0,M | PLUDA pl02 |
Vazba platba - výpis - má výpis | ZPUHR zp02 | 1,1 : 0,M | ZPUDA zp02 |

Indexy

Název | Primární | Výraz | Popis
ix_ZPUHR_zpuhr1 | P | zp02, pl02 |
ix_ZPUHR_zp02 |  | zp02 | Jednoznačná časová identifikace události změny stavu peněz
ix_ZPUHR_pl02 |  | pl02 | Jednoznačná časová identifikace


Informační panel - insolventní adresáti

1. Insolvenční rejstřík a evidence úpadců

Informační panel „Adresáti v úpadku“ poskytuje uživateli komfortní a uživatelsky „přítulný“ přehled jednotlivých insolventních adresátů a jejich uhrazených i neuhrazených pohledávek vůči Vaší firmě. U každého adresáta je možný přímý náhled do insolvenčního rejstříku či do evidence úpadců. Toto řešení Vám pomůže včas identifikovat problémové odběratele a tak se vyhnout riskantním obchodům anebo alespoň zachránit maximum z již uskutečněných obchodů s nimi, což považujeme zejména v dnešní době za velmi důležité. Podrobnější informace o tomto informačním panelu (IP) má uživatel k dispozici dále v textu.

Základní vlastnosti insolvenčního rejstříku (tím pádem i evidence úpadců), které uživatel jistě ocení, jsou:

¨ je to přímý zdroj informací

¨ je to nástroj doručování většiny soudních rozhodnutí a jiných písemností

¨ je veřejně a snadno dostupný

¨ motivuje k aktivnímu zapojení účastníků insolvenčního řízení tím, že jim umožňuje pravidelné sledování insolvenčního řízení a vyhledávání důležitých informací

Co všechno má uživatel v insolvenčním rejstříku k dispozici? Jsou to následující informace (viz insolvenční zákon):

¨ veškerá rozhodnutí insolvenčního soudu vydaná v insolvenčním řízení

¨ veškerá podání, která se vkládají do soudního spisu vedeného insolvenčním soudem ohledně dlužníka (podání jsou s ohledem na ochranu osobních údajů v některých případech anonymizována)

¨ zákonem stanovené informace o insolvenčních správcích

¨ zákonem stanovené informace o dlužnících

¨ informace o hlavních řízeních probíhajících v členských státech EU

A proč je tak důležité sledovat informace poskytované insolvenčním rejstříkem?

Zákon o úpadku a způsobech jeho řešení (182/2006 Sb.) zpřísnil podmínky pro přihlášení pohledávek do konkursního řízení. Nově je možné pohledávky přihlašovat od počátku insolvenčního řízení do konce lhůty stanovené soudem. Tato lhůta je mnohdy stanovena na pouhých 30 dnů od prohlášení konkursu. K pohledávkám přihlášeným po této lhůtě se dle zákona nepřihlíží a nejsou v konkursu uspokojovány.

Pokud tedy nebudete pravidelně sledovat své dlužníky, může se stát, že na jejich majetek bude prohlášen konkurs a Vy se o tom dozvíte až po uplynutí soudem stanovené lhůty. Ztratíte tak nejen možnost účastnit se insolvenčního řízení, ale například i možnost vytvořit na takovouto pohledávku alespoň opravnou položku a tuto uplatnit jako daňový náklad ve smyslu Zákona o rezervách pro zjištění základu daně z příjmů.

Informační panel – Adresáti v úpadku sleduje Vaše dlužníky či smluvní partnery právě pro případ, že by s nimi bylo zahájeno některé z řízení dle insolvenčního zákona. Každý den Vám umožní mít aktuální přehled, zda s nimi nebylo zahájeno insolvenční řízení, a tak máte možnost na případné zahájení insolvenčního řízení včas reagovat, tj. svoji pohledávku přihlásit anebo obchod vůbec neuzavírat.

Stálé evidence „insolvenční rejstřík“ a „evidenci úpadců“ provozuje Ministerstvo spravedlnosti. Bohužel insolvenční rejstřík vede Ministerstvo spravedlnosti způsobem, který reálně neumožňuje zpracování dat z něj přímo ve Vašem IS[1]. Z toho důvodu naše firma připravila svým uživatelům možnost využívat těchto evidencí prostřednictvím serveru firmy BM Servis. Po stránce technické se jedná o řešení, kdy se na našem serveru shromažďují veškerá data o řešení úpadků (aktualizace každou hodinu) z informačních systémů Ministerstva spravedlnosti a Váš IS Bílý Motýl (přesněji jeho informační panel „Adresáti v úpadku“) z něj pro Vás čerpají relevantní on line[2] údaje uspořádané do smysluplného přehledného celku. Velkou výhodou sledování insolvencí pomocí našeho informačního panelu je to, že uživatel nemusí hlídat a pak následně vyhledávat vytipované adresáty, ale informační panel automaticky hlídá všechny adresáty, které má uživatel zadány v adresáři, včetně signalizace problému e-mailem.

Informační panely jsou nástrojem, který slouží k přehlednému zobrazení vybraných dat vyplývajících z informací uložených v systému. Obsah informačního panelu je tedy volně definovatelný a je ho možné přizpůsobit individuálním potřebám jednotlivých uživatelů, tzn. že pro jednoho uživatele může být nadefinován např. informační panel, který mu zobrazuje připravené projektové úkoly ke zpracování, pro dalšího uživatele může být připraven informační panel s informacemi o jednotlivých dlužnících a jejich částkách po splatnosti apod.

Ať už informační panel zobrazuje jakékoliv informace, jeho ovládání z hlediska uživatele je shodné. Po jeho aktivaci se uživateli zobrazí stránka informačního panelu. Každá stránka obsahuje horní lištu s ovládacími tlačítky. Po jejich stisku se uživateli zobrazí další dostupné informace, pomocí tlačítka „Zpět“ v horní liště se opět vrátí do původní stránky. Na stránce informačního panelu může uživatel kromě ovládání na horní liště využít ještě i hypertextových odkazů, např. v přehledu dlužných částek adresáta je možno si pomocí hypertextového odkazu aktivovat přímo činnost „adresář“ s kontaktem na daného adresáta nebo si spustit přímo proces, kterým byla vytvořena dlužná pohledávka a prohlédnout si ji v událostech plateb apod. Návrat do stránky informačního panelu uživatel provede opět buď pomocí tlačítka „Zpět“ a nebo aktivací stránky informačního panelu z dolní lišty počítače.

Již ze samotného názvu „Adresáti v úpadku“ je zřejmé, že tento informační panel poskytuje uživateli informace o adresátech (pouze adresáti uvedení v činnosti „adresář“ v IS BM), kteří se dostali do platební neschopnosti. Než se pustíme do vlastního popisu daného informačního panelu, pokusíme si v krátkosti nastínit „životní cyklus“ dlužníka, jak je zachycen v IS BM:

¨ je nutno mít nadefinovánu obecnou předkontaci[3] „INFUPA – Informace o úpadcích“ včetně jejích položek (např. definice kategorie adresátů – úpadek nebo definice kategorií, u kterých si uživatel chce sám určit, zda se mají či nemají zobrazovat v informačním panelu apod.). Tato potřebná nastavení Vám můžeme zrealizovat (tzn. zajistit instalaci s ověřením funkčnosti) nebo poslat ve formě balíčku.

¨ je nutno provést nastavení informačního panelu, zejména kategorie adresátů, což zajistí následné sledování adresátů, kteří jsou k aktuálnímu datu do ní zařazeni

¨ dlužník, který vstoupí do insolvenčního řízení (nebo je v evidenci úpadců) se následně zobrazí v tomto informačním panelu a z něj podle definice stránky inf. panelu „nastavení“ odejde informační mail vybraným uživatelům (s informací, že tento adresát je problémový a je nutno se o něj zajímat) a daný adresát je zařazen do kategorie „úpadek“.

¨ v rámci insolvenčního řízení se odehrávají různá řízení (čili akce nebo úkony), o kterých je uživatel opět informován pomocí e-mailu

¨ konec životního cyklu insolventního adresáta může být dvojí:

- dokáže se „vzchopit“ (např. provede reorganizaci), splatí své pohledávky a pak je insolvenční řízení ukončeno a uživatel by si takového adresáta měl vyřadit z kategorie úpadek a ukončit mu platnost této kategorie[4]

- „nepřežije“ insolvenční řízení a firma je zrušena (tj. vymazána z obchodního rejstříku) a uživatel by si měl daného adresáta zařadit do kategorie „firma zrušena“ (nebo jak si danou kategorii pro zrušené adresáty pojmenuje). Pak je vhodné si v informačním panelu „Adresáti v úpadku“ nastavit, že tato kategorie adresátů se v panelu sledovat nebude.

2. Stránka IP „Adresáti v úpadku“

A nyní se vrátíme k vlastnímu popisu informačního panelu „Adresáti v úpadku“. Po jeho aktivaci se uživateli zobrazí následující stránka informačního panelu (viz. obr. 1) se zvýrazněným tlačítkem „Adresáti v úpadku“.

Obr. 1

Uživatel má přehled adresátů (z jeho vlastní činnosti adresář), kteří se dostali do insolvenčního řízení a nebo jsou v evidenci úpadců. Formulář informačního panelu není nutno nijak podrobně popisovat, jednotlivé sloupečky jsou poměrně jasné a je zřejmé, co zobrazují, přesto si je i zde vyjmenujeme:

¨ IČO / RČ a adresát – identifikace adresáta (kliknutím na IČO [jde na ARES] nebo název adresáta je uživatel přesměrován do adresáře)

¨ Posl. uhr. pohledávka – datum splatnosti poslední uhrazené pohledávky daného adresáta

¨ Posl. neuhr. pohledávka – datum splatnosti pohledávky, která dosud není uhrazena

¨ Neuhrazeno Kč – celková částka v Kč po splatnosti (kliknutím na částku si uživatel zobrazí přehled plateb, ze kterých se tato částka skládá, dále lze kliknutím na číslo procesu zobrazit přímo jednotlivé pohledávky, ze kterých je celková dlužná částka tvořena – formulář pohledávky se ukončí pomocí tlačítka ESC, v dolní liště PC se aktivuje informační panel a pomocí tlačítka Zpět se uživatel vrátí do přehledu adresátů v úpadku)

¨ V kategorii úpadců – datum, od kdy (případně i do kdy) je daný adresát zařazen[5] v kategorii úpadců, např. kategorie UPADEK (u každého adresáta může mít tato kategorie různou identifikaci podle nadefinování jednotlivých uživatelů[6] (pokud se jedná o automatické zařazení do kategorie dle IP, pak se zde jedná o datum, kdy s daným adresátem bylo zahájeno insolvenční řízení)

¨ Odesílání mailu – Ano/Ne – zobrazeno podle nastavení kategorií pod tlačítkem Nastavení. Pokud je daný adresát v kategorii, která je nastavena v atributu „sledované kategorie adresátů – odesílat email“ je zde uvedeno Ano (tj. o akcích, resp. událostech, které budou evidovány v rámci řešení úpadku daného adresáta budete informováni emailem)

¨ Evidován v – informace, jestli je adresát evidován v insolvenčním rejstříku či v evidenci úpadců a datum prvního a posledního zveřejnění této informace. Po stisku „insolvenční rejstřík“ je uživateli on line zobrazen aktuální záznam daného adresáta z insolvenčního rejstříku (obr. 2 + obr. 3 Detail insolvenčního řízení). Po stisku „Evidence úpadců“ je uživateli on line zobrazen aktuální záznam daného adresáta z evidence úpadců (viz. ukázka obr. 4).

Další sloupce se týkají změn provedených v evidenci úpadců nebo v insolvenčním rejstříku, tzn. datum, kdy byl daný adresát poprvé zveřejněn v některém registru a datum poslední provedené změny (tzn. proběhne-li v registru úpadců nebo v insolvenčním rejstříku určitá akce, je zde toto datum zveřejněno).

Při kliknutí na jednotlivé názvy sloupečků dochází ke změně třídění informačního panelu, tzn. může být setříděn podle názvu adresáta, dlužné částky apod. Ukázka, jak vypadá náhled do záznamů insolvenčního rejstříku (po stisku Insolvenční rejstřík ve sloupečku Evidován v) daného adresáta (na dalším obrázku je zobrazen insolvenční rejstřík i s detailem):

Obr. 2

Obr. 3

A pro konkrétní představu následuje i pohled do evidence dlužníků (po stisku Evidence úpadců ve sloupečku Evidován v):

Obr. 4

2.1 Výběr adresátů

Na dalším obrázku (obr. 5) má uživatel k dispozici detailní náhled na šedé pole „Výběr adresátů“, který má k dispozici v dolní části formuláře po stisku stránky inf. panelu „Adresáti v úpadku“. Uživatel si může zvolit jednotlivé kategorie, jejichž adresáty chce kontrolovat z hlediska insolvence (či úpadku) tím, že je zaškrtne a stiskne tlačítko „Vyhledat“. Zároveň může použít i kombinovaný výběr kategorií, tzn. zaškrtat si vybrané kategorie v horní části šedého pole a následně tento výběr doladit pomocí kategorií vybraných pod možností „A zároveň“.[7] Možnost výběru jednotlivých kategorií je dána právě nadefinovanými hodnotami v obecné předkontaci. U každého z okruhu kategorií lze v překryvném seznamu vybrat tyto možnosti:

¨ vybrat všechny adresáty – bez ohledu na označené kategorie

¨ vybrat pouze adresáty – kteří jsou zařazeni do některé označené kategorie

¨ nevybírat adresáty – kteří jsou zařazeni do některé označené kategorie

V dolní části formuláře je možno si výběr adresátů ještě zúžit pomocí atributu „neuhradil pohledávku“. Při jeho zatržení jsou z vybraných kategorií vybráni pouze ti adresáti, kteří mají některou pohledávku vůči nám neuhrazenou.

Možnost „zobrazit tabulku v Excelu“ znamená, že po jejím stisku se uživateli aktivuje aplikace MS Excel a dané údaje z informačního panelu jsou zobrazeny ve formě tabulky v Excelu.

Pokud uživatel nemá zařazení adresátů do kategorie dlužníků vyřešeno pomocí externího příkazu (automatická aktivace po spuštění IS BM, což doporučujeme), lze využít tlačítko „zařadit adresáty do kategorie úpadců“ ve spodní části formuláře informačního panelu.

Obr. 5

2.1.1 Obecná předkontace INFUPA

Předchozí popsaný Výběr adresátů či nastavená kategorie úpadců se definují v obecné předkontaci „INFUPA – Informace o úpadcích“ (v hlavním menu – Informační centrum – Typy a řady – Obecné předkontace). Jak jsme se již zmínili v úvodu dokumentu, tuto obecnou předkontaci můžeme vytvořit přímo na míru uživateli nebo Vám může být dodána balíčkem (pak je však nutno v hodnotách obecné předkontace změnit definice kategorií podle vlastní definice kategorií uživatele).

Na dalším obrázku (obr. 6) má uživatel k dispozici možnou definici dané obecné předkontace. Na první záložce „obecné předkontace“ se nadefinuje její identifikace a název (tj. INFUPA – Informace o úpadcích). Důležité pro správný chod informačního panelu jsou však hodnoty nadefinované na záložce „položky obecné předkontace“.

Obr. 6

Tato obecná předkontace se původně využívala i pro starší způsob evidence úpadců v IS BM, proto je zde k dispozici více významových položek. Pro IP „Adresáti v úpadku“ jsou však důležité pouze tyto položky:

¨ INFU04 – UPADEK – Kategorie adresátů – úpadců – v hodnotě této položky musí být uvedena identifikace kategorie, která je nadefinována pro sledování adresátů v úpadku. Tato kategorie musí být nadefinována v činnosti Adresář - Kategorie adresátů.

¨ INFU06 – 1 – Registrován pro Insolventní adresáty - hodnota 1 uvedená v této položce přidá sloupec "Evidován v" do panelu plateb[8], tzn. obsluha panelu plateb má zároveň u dlužníka ihned informaci o jeho případném zařazení do evidence úpadců či do insolvenčního rejstříku.

¨ INFU07 – definice jednotlivých kategorií – Výběr adresátů – 1. část – v hodnotě této položky jsou vyjmenovány identifikace kategorií, které se zobrazují v informačním panelu "Adresáti v úpadku" v 1.části Výběru adresátů. Příkaz NEWLINE je nástroj, který umožňuje zpřehlednit Výběr adresátů na daném IP, tzn. je možno si významově podobné kategorie uvést na jednom řádku a další významově podobné kategorie na druhém řádku atd.

¨ INFU08 – definice jednotlivých kategorií – Výběr adresátů – 2. část (A zároveň) - v hodnotě této položky jsou vyjmenovány identifikace kategorií, které se zobrazují v informačním panelu "Adresáti v úpadku" v 2. části Výběru adresátů (A zároveň). Příkaz NEWLINE je nástroj, který umožňuje zpřehlednit Výběr adresátů na daném IP, tzn. je možno si významově podobné kategorie uvést na jednom řádku a další významově podobné kategorie na druhém řádku atd.

3. Stránka IP „Nastavení“

Pod další ikonou, kterou má uživatel na informačním panelu k dispozici je stránka inf. panelu „Nastavení“ (viz. obr. 7). Její základní definici by uživatel měl provést před vlastním zahájením práce s informačním panelem. Uživatel zde definuje tyto informace:

¨ E-mail – uživatel zde uvede emailové adresy, na které chce pak následně odesílat informativní maily o insolvenčních řízeních adresátů (či o evidenci úpadců)

¨ Sledované oddíly ISIR – jedná se o terminologii insolvenčního rejstříku, tzn. které oddíly a jejich provedené řízení chce uživatel sledovat (oddíl A – řízení do úpadku, oddíl B – řízení po úpadku, oddíl C – incidenční spory, oddíl D – ostatní a oddíl P – přihlášky)

¨ Sledované kategorie adresátů – odesílat email – vyjmenované kategorie adresátů (možnost wilcards) u kterých chce, aby v případě jakékoliv změny v insolvenčním rejstříku byl na výše uvedené emailové adresy zaslán informativní e-mail[9]

¨ Sledované kategorie adresátů – neodesílat email – zde jsou uvedeny kategorie adresátů (případně i celý adresář, pokud je zde uvedeno %), které se budou pouze sledovat na IP – informativní email se odesílat nebude

¨ V pravé části formuláře si může uživatel případně nastavit, které typy událostí chce vyloučit, tzn. nesledovat v insolvenčních řízeních.

Po nadefinování těchto atributů uživatel stiskne tlačítko „Zapsat“ a následně stiskne tlačítko „Aktualizovat seznam IČ a RČ“. Tím dojde k zapsání informace na našem serveru, která IČ a RČ chce uživatel sledovat. Tuto aktualizaci uživatel provádí po prvním spuštění informačního panelu a pak v případě, že provede změny v adresáři (tzn. zařadí nového adresáta, změní IČO apod.). Po stisku OK je zaktualizován seznam sledovaných IČ a RČ a zároveň jsou zjištění dlužníci zařazeni do kategorie úpadců[10].

Obr. 7

V dolní části stránky IP „Nastavení“ má uživatel pro informaci k dispozici statistické údaje:

¨ počet sledovaných IČ/RČ – s odesíláním emailu – jedná se o počet adresátů v adresáři z kategorií, které jsou uvedeny v atributu „sledované kategorie adresátů – odesílat email. Sledují se pouze adresáti, kteří mají v adresáři uvedeno IČ nebo RČ.

¨ počet sledovaných IČ/RČ – bez odesílání emailu - jedná se o počet adresátů v adresáři z kategorií, které jsou uvedeny v atributu „sledované kategorie adresátů – neodesílat email. Sledují se pouze adresáti, kteří mají v adresáři uvedeno IČ nebo RČ.

¨ počet odeslaných emailů – počet, kolik bylo odesláno informativních emailů (emailové adresy jsou nadefinovány v atributu E-mail)

¨ počet dlužníků v ISIR – celkový počet adresátů evidovaných v insolvenčním rejstříku

¨ počet dlužníků v EVUP – celkový počet adresátů evidovaných v evidenci úpadců

¨ poslední záznam ISIR, poslední záznam EVUP – poslední záznamy v evidenci úpadců či v insolvenčním rejstříků týkající se i adresátů, které nemá uživatel zadané v adresáři. Tyto data slouží k informaci, zda daná služba evidence úpadců na serveru běží, tzn. pokud by se datum neměnilo, je nutno nám poslat upozornění, že služba neběží.

Tuto aktualizaci RČ a IČ je možno i zautomatizovat (doporučujeme[11]), tzn. lze využít externí příkaz, který tuto aktualizaci provede automaticky každý den po přihlášení uživatele do systému BM[12]. Po přihlášení do systému může být zobrazen např. tento dotaz:

Jak jsme se již zmínili na začátku tohoto dokumentu, jsou veškerá data z evidence úpadců a insolvenčního rejstříku umístěna na našem serveru. Pomocí tohoto externího příkazu si uživatel aktualizuje seznam sledovaných IČ a RČ[13]. Poté při aktivaci informačního panelu „Adresáti v úpadku“ dojde v podstatě k aktualizaci dotazu, kteří adresáti se mají kontrolovat z hlediska evidence úpadců či insolvence.

4. Stránka IP „E-maily“

Po stisku stránky IP „E-maily“ v horní liště informačního panelu má uživatel k dispozici přehled, kdy a komu byl odeslán informativní mail o nastalých událostech (akcích) v řešení úpadku, viz. obr. 8.

Obr. 8

Po rozkliknutí informace ISIR ve sloupečku „Předmět“ má uživatel k dispozici tento náhled:

Pomocí tlačítka Zpět se uživatel vrátí do přehledu odeslaných emailů. Po kliknutí na IČO adresáta se uživateli zobrazí hlavní stránka z evidence úpadců nebo insolvenčního rejstříku s údaji daného adresáta. Návrat do této obrazovky uživatel opět provede pomocí tlačítka Zpět v horní liště stránky informačního panelu. V obsahu emailu má uživatel ještě i možnost zobrazit si dokument, který se dané řádky popisu týká. Po kliknutí na Ano ve sloupečku „Dokument“ se uživateli nabízí možnost Otevřít-Uložit-Storno dokument, který obsahuje informace týkající se popisu dané akce (ve většině případů se jedná o dokument s příponou PDF, tzn. typu Adobe Acrobat Document). Návrat se opět provede pomocí tlačítka Zpět.

[1] Například způsobem obdobným jako jsme zpřístupňovali data z evidence úpadců, neboť Váš IS Bílý Motýl by byl zcela zahlcen nepotřebnými daty, což by se projevilo snížením jeho výkonu i významným nárůstem velikosti databáze.

[2] Podmínkou je samozřejmě Vaše připojení k síti internet, kde se využívá technika webových služeb.

[3] Podrobné vysvětlení obecné předkontace je dále k dispozici v kapitole 2.1.1

[4] Pokud by daný adresát znovu vstoupil do úpadku, resp. vznikne nový záznam v ISIR, je vytvořeno nové zařazení do kategorie úpadek.

[5] V případě, že je ukončena platnost daného adresáta v kategorii úpadců, je zde k dispozici i datum do.

[6] Název „UPADEK“ lze však implementačně doporučit (význam takové kategorie je pak zřejmý na první pohled).

[7] Uživatel může mít např. nastaveno, že se mají vybrat všichni adresáti bez ohledu na označené kategorie a ve volbě „A zároveň“ si může k tomu doladit možnost „nevybírat adresáty – kteří jsou zařazeni do některé označené skupiny“. Nebo může mít v 1. části výběru zvoleno, že se mají zobrazit všichni adresáti z označených kategorií a ve 2. části „A zároveň“ bude mít nastaveno, že se nemají zobrazit adresáti z kategorie „firma zrušena“.

[8] Informační panel „platby“ poskytuje uživateli přehled o okamžitém stavu závazků a pohledávek.

[9] Pokud adresát splňuje podmínky pro odesílání emailu, je mail odeslán, i když splňuje podmínky i pro neodesílání emailu.

[10] Aktualizaci IČ a RČ automaticky provádí externí příkaz (import RČ a IČ a zařazení adresátů do kategorie úpadců), který uživateli doporučujeme nastavit si automaticky při spuštění IS BM. Provést ručně aktualizaci má smysl pouze v případě, pokud se od spuštění IS BM neaktualizoval daný externí příkaz s importem IČ a RČ.

[11] Má smysl užít jen mimo interval pravidelné aktualizace externím příkazem, např. zařadím nového adresáta nebo změním nastavení IP .

[12]Lze nastavit i to, aby externí příkaz byl spouštěn 1x denně, ne po každém přihlášení do IS BM, protože to může proběhnout i několikrát denně.

[13] Pomocí parametrů lze nastavit, že tento příkaz proběhne automaticky 1x za den pro přihlášení prvního uživatele do IS BM.

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 25.02.2015


Dokumentace jazyka kódu pro ukončení operace

Dokumentace jazyka kódu pro ukončení operace

Kód pro ukončení operace slouží k řízení probíhajícího procesu na základě informací v událostech operací procesu a uživatelských rozhodnutí. Řízení procesu spočívá v modifikaci jeho procesního diagramu nastavením stavu operací do stavu připravena nebo v odstranění těch operací, které ztratily vzhledem ke vstoupeným informacím smysl. Kód musí být zapsán ve zvláštním programovacím jazyce.

Příkaz

Popis

DECLARE

Slouží k deklaraci proměnných použitých v kódu.

Má tři možné formy:

· deklarace dotazu na informace o událostech některé z operací procesu

Dotaz | Popis
COUNT | Zjištění počtu událostí COUNT('komponenta-druh operace') [FOR podmínka] Př.: počet všech událostí v operaci ‚nap‘ komponenty ‚DPH‘, které mají atribut ‚dp02odpnap‘ roven 1 (události odpočet) DECLARE počet=COUNT('DPH-nap') FOR dp02odpnap=1
MAX | Maximální hodnota výrazu MAX('komponenta-druh operace',výraz) [FOR podmínka] Př.: největší hodnota ‘ob02mnr’ (množství v referenční měrné jednotce) mezi událostmi operace ‚prij‘ komponenty obchod DECLARE maximum=MAX('OBC-prij',ob02mnr)
MIN | Minimální hodnota výrazu MIN('komponenta-druh operace',výraz) [FOR podmínka] Př.: nejmenší hodnota ‘ob02mnr’ (množství v referenční měrné jednotce) mezi událostmi operace ‚prij‘ komponenty obchod DECLARE mnozstvi=MIN('OBC-prij',ob02mnr)
SELECT | Hodnota výrazu v prvé události operace SELECT('komponenta-druh operace',výraz) [FOR podmínka] Př.: hodnota výrazu ‚ad01id‘ (identifikace adresáta) z prvého záznamu operace ‚prij‘ komponenty obchod DECLARE adresat=SELECT('OBC-prij',ad01id)
SUM | Součet hodnot výrazu SUM('komponenta-druh operace',výraz) [FOR podmínka] Př.: Celkový součet výrazu ‚pl02crmnez‘ (částka v referenční měně nezaokrouhlená) událostí operace ‚xxx‘ komponenty platby DECLARE prom5=SUM('PLA-xxx', pl02crmnez)

· deklarace běžných proměnných užitých ve formuláři

DECLARE x,z,y

· deklarace objektových proměnných

DECLARE object o1,object o2

SET

Slouží k inicializaci proměnné

Má tři možné formy:

· nastavení proměnné procesu

SET #N#=hodnota

Kde N je cifra 1,2,…,9 a hodnota je numerická hodnota

· přiřazení hodnoty běžné proměnné

SET x=a+b

· inicializace objektové proměnné

SET o1=CREATE(‘třída objektu‘)

IF

Podmiňuje provádění příkazů

· Jednořádkový IF

IF <podmínka> THEN <příkaz>

· Víceřádkový IF

IF <podmínka>

<příkaz>

….

[ELSE

<příkaz>

….]

ENDIF

ACTIVATE

Aktivuje operaci nebo proces uvedený v parametru

ACTIVATE ‘OBC-DODANI’

Nebo aktivace uzlu diagramu v nadřízeném procesu, ze kterého byl process vyvolán

ACTIVATE PARENT

DELETE

Ruší z diagramu operaci nebo proces uvedený v parametru

DELETE ‘OBC-DODANI’

ERROR

Chybové hlášení (operace nebude ukončena)

ERROR ‘Máte tam chybu’

CANCEL

Ukončení kódu, bez chybového hlášení (operace nebude ukončena)

CANCEL

RETURN

Ukončení kódu, bez chybového hlášení (operace bude ukončena)

RETURN

*

Komentář

V kódu mohou být použity konstanty a funkce

#MP# | Konstanta obsahuje informaci, že operace byla ukončena s nenaplněnou mírou plnění
ASK | Dotaz k uživateli – tvar ANO/NE Funkce s jedním parametrem typu text. Vrací logickou hodnotu TRUE nebo FALSE
ASK3 | Dotaz k uživateli – tvar ANO/NE/STORNO Funkce s jedním parametrem typu text. Vrací textovou hodnotu ‚A‘ nebo ‚N‘ nebo ‚Z‘

Příklad použití konstanty #MP# a funkce ASK3:

DECLARE dotaz

IF #MP#

SET dotaz=ASK3('Je dodání ukončeno ?')

IF dotaz='N'

ACTIVATE PARENT

ELSE

IF dotaz='Z' THEN CANCEL

ENDIF

ENDIF

Příklad souvisí s možností nastavení parametru operace „Test mírou plnění“ na hodnotu „Rozhodne kód po ukončení operace“, který způsobí to, že po ukončení operace s nenaplněnou mírou plnění nebude zobrazen obvyklý dotaz „Míra plnění nebyla naplněna. Přesto ukončit operaci“ v případě, že se v kódu po ukončení někde vyskytuje odkaz na konstantu #MP#.

V kódu je dále možné pracovat s objekty, které mohou provádět nejrůznější akce. Pro tyto objekty musí být dodavatelem systému připraveny třídy.

V současné době je připravena třída pro práci s daty, třída pro vstup uživatelské informace a třída pro odesílání MAIL.

KU_DATA - Třída objektů pro práci s daty (volné karty procesů a operací, informace událostí operací, SQL dotazy)

Metoda

Popis

SET_PROCESS

Nastavení objektu na proces

OBJEKT.SET_PROCESS([‘druh procesu‘][,start])

Není-li parametr uveden, nastaví na proces aktuálně ukončované operace (není třeba provádět po inicializaci objektu, pokud se dále bude pracovat s volnými kartami operací aktuálního procesu, inicializací je objekt nastaven na tento proces).

Je-li parametr uveden vyhledává objekt proces určeného druhu, který v hlavním procesu předcházel aktuálnímu procesu.

V tomto případě je třeba práci s dalšími metodami ošetřit dotazem metodou FOUND, která vrací logickou hodnotu TRUE, v případě, že byl odpovídající proces nalezen.

Při uvedení znaku ‘*‘ v prvém parametru, potom je objekt nastaven na proces, který je ve stromu bezprostředním předchůdcem uzlu ve stromu (kterého -> to je dáno parametrem ‘start‘) bez ohledu na to, jakého je druhu.

Vlastnost objektu SP07IDTYPD přitom obsahuje identifikaci druhu procesu, na který byl objekt nastaven posledním užitím metody SET_PROCESS.

Parametr ‘start‘ – určuje uzel ve stromu procesu, od kterého je proces vyhledáván.

Není-li uveden nebo při uvedené logické hodnotě FALSE (.F.) , je vyhledáván proces druhu podle prvého parametru metody ve stromu počínaje od čísla procesu odpovídajícímu aktuálně ukončované operaci.

Při uvedení druhého parametru s logickou hodnotou TRUE (.T.), se vyhledávání ve stromu zahajuje od čísla procesu, na který byl objekt nastaven posledním užitím metody SET_PROCESS.

SET_OPERATION

OBJEKT. SET_OPERATION([‘komponenta’,’druh operace’[,pořadí]])

Není-li parametr uveden, nastaví na aktuálně ukončovanou operaci (není třeba provádět po inicializaci objektu, inicializací je objekt nastaven na tuto operaci)

Je-li parametr uveden vyhledává objekt operaci určeného druhu v procesu, který byl určen metodou SET_PROCESS.

V tomto případě je třeba práci s dalšími metodami ošetřit dotazem metodou FOUND, která vrací logickou hodnotu TRUE, v případě, že

byla odpovídající operace nalezena.

Při nastavení na uzel diagramu charakteru proces se jako první parametr uvádí prázdný řetězec a druhý parametr druh procesu (využití např. při použití metody OP_EXEC – založení nového procesu na základě diagramu)

FOUND

OBJEKT.FOUND()

Vrací logickou hodnotu TRUE nebo FALSE podle toho, zda byl proces nebo operace vyvoláním metody SET_PROCESS nebo SET_OPERATION nalezen.

FC_READ

OBJEKT.FC_READ(‘identifikace volné karty‘)

Vyvoláním je aktivována volná karta určené identifikace procesu nebo operace, na kterou(ý) je objekt nastaven posledním voláním metod SET_PROCESS nebo SET_OPERATION, pro uživatelský vstup.

V okamžiku volání metody nesmí být objektem otevřena volná karta metodou FC_OPEN.

FC_OPEN

OBJEKT.FC_OPEN(‘identifikace volné karty‘)

Metoda otevírá volnou kartu pro programový přístup metodami FC_GET a FC_PUT.

Je otevřena volná karta procesu nebo operace, na kterou(ý) je objekt nastaven posledním voláním metod SET_PROCESS nebo SET_OPERATION.

FC_GET

OBJEKT.FC_GET(‘identifikace atributu volné karty‘)

Metoda vrací hodnotu atributu volné karty. Atribut se musí být součástí volné karty otevřené metodou FC_OPEN.

FC_PUT

OBJEKT.FC_PUT(‘identifikace atributu volné karty‘,hodnota)

Metoda nastavuje hodnotu atributu volné karty. Atribut se musí být součástí volné karty otevřené metodou FC_OPEN a musí být stejného typu jako zapisovaná hodnota.

Takto vložená informace se zapisuje na volnou kartu metodou FC_SAVE nebo v rámci transakce ukončení operace nebyla-li metoda FC_SAVE v následujícím kódu užita.

Provedené změny karty je možné zrušit před příkazem FC_SAVE metodou FC_ROLLBACK

FC_SAVE

OBJEKT.FC_SAVE()

Ukládá změny provedené metodami FC_PUT a uzavírá volnou kartu.

FC_ROLLBACK

OBJEKT.FC_ROLLBACK()

Ruší změny provedené metodami FC_PUT.

FC_CLOSE

OBJEKT. FC_CLOSE()

Uzavírá volnou kartu.

EV_COUNT

OBJEKT. EV_COUNT([‘podmínka‘])

Vrací počet událostí operace, na kterou je objekt nastaven posledním voláním metody SET_OPERATION.

Při nastavení objektu na operaci procesu aktuálně ukončované operace ekvivalent DECLARE …=COUNT(….

EV_MAX

OBJEKT. EV_MAX(‘výraz‘ [,‘podmínka‘])

Vrací maximální hodnotu výrazu nad událostmi operace, na kterou je objekt nastaven posledním voláním metody SET_OPERATION.

Při nastavení objektu na operaci procesu aktuálně ukončované operace ekvivalent DECLARE …=MAX(….

EV_MIN

OBJEKT. EV_MIN(‘výraz‘ [,‘podmínka‘])

Vrací minimální hodnota výrazu nad událostmi operace, na kterou je objekt nastaven posledním voláním metody SET_OPERATION.

Při nastavení objektu na operaci procesu aktuálně ukončované operace ekvivalent DECLARE …=MIN(….

EV_SELECT

OBJEKT. EV_SELECT(‘výraz‘ [,‘podmínka‘])

Vrací hodnotu výrazu prvé události operace, na kterou je objekt nastaven posledním voláním metody SET_OPERATION.

Při nastavení objektu na operaci procesu aktuálně ukončované operace ekvivalent DECLARE …=SELECT(….

EV_SUM

OBJEKT. EV_SUM(‘výraz‘ [,‘podmínka‘])

Vrací suma výrazu nad událostmi operace, na kterou je objekt nastaven posledním voláním metody SET_OPERATION.

Při nastavení objektu na operaci procesu aktuálně ukončované operace ekvivalent DECLARE …=SUM(….

SQL_OPEN

OBJEKT. SQL_OPEN(‘SQL dotaz‘)

Metoda otevírá soubor pro následné dotazy metodou SQL_GET.

V okamžiku dotazu jsou nastaveny pomocné proměnné _sp33cisdr,_sp33cisdpm,_sp33cisd,_sp07idtyp,_sp06idsubs,_sp33porad podle posledního vyvolání metod SET_PROCESS nebo SET_OPERATION. Tyto proměnné je možné použít v dotazu v otazníkové konvenci

SQL_GET

OBJEKT.SQL_GET(‘identifikace atributu SQL dotazu‘)

Vrací hodnotu atributu ze souboru otevřeného posledním volání metody SQL_OPEN.

SQL_CLOSE

OBJEKT.SQL_CLOSE()

Uzavírá soubor otevření metodou SQL_OPEN.

OP_PRINT

OBJEKT.OP_PRINT(‘Identifikace předlohy‘[,způsob vyvolání])

Provádí výstup operace nebo procesu podle posledního nastavení metodou SET_OPERATION resp. SET_PROCESS

Identifikaci předlohy je možné zjistit ve vlastnostech předlohy na poslední záložce atribut ID:.

Z této identifikace se uvádí část identifikace za znakem podtržení (např. je-li OB0101_W123456789, uvádí se W123456789)

Parametr způsob vyvolání může nabývat hodnotu 1. Je-li uveden znamená, že výstup podle předlohy bude vyvolán bezprostředně voláním metody (tj. výstupní soubor Excelu nebo HTML bude k dispozici odesílanému E-mailu objektem třídy KU_MAIL).

Není-li parametr způsob vyvolání uveden, potom bude výstup proveden až po úspěšném ukončení operace a informace o provedeném výstupu se zapíše do „průběhu operací“, odkud ho bude možné zopakovat.

OP_PRINT_META

OBJEKT.OP_PRINT_META(‘Metapředloha‘[,způsob vyvolání])

Provádí výstup operace nebo procesu metapředlohou podle posledního nastavení metodou SET_OPERATION resp. SET_PROCESS

Parametr způsob vyvolání může nabývat hodnotu 1. Je-li uveden znamená, že výstup podle metapředlohy bude vyvolán bezprostředně voláním metody (tj. výstupní soubor Excelu nebo HTML bude k dispozici odesílanému E-mailu objektem třídy KU_MAIL).

Není-li parametr způsob vyvolání uveden, potom bude výstup proveden až po úspěšném ukončení operace a informace o provedeném výstupu se zapíše do „průběhu operací“, odkud ho bude možné zopakovat.

OP_EXEC

OBJEKT.OP_EXEC()

Spustí (uloží do zásobníku, na rozdíl od ACTIVATE třeba i ukončenou) operaci podle posledního nastavení metodou SET_OPERATION.

Metoda je určena ke spouštění operací v nadřazeném procesu.

V případě nastavení na uzel typu proces se vždy zahájí nový proces

OP_EVALUATE

OBJEKT.OP_EVALUATE([výraz])

Slouží ke zjištění informací o stavu operace (uzlu), na kterou byl objekt nastaven posledním užitím metody SET_OPERATION.

Metoda má jediný parametr, který obsahuje výraz, ve kterém má smysl uvádět atributy tabulky SPPRCOD - viz.datový model.

Metoda vrací hodnotu výrazu nebo FALSE (.F.), není-li možné výraz vyhodnotit.

OP_DELETE

OBJEKT. OP_DELETE()

Ruší operaci (uzel) ve stromu hlavního procesu, na kterou byl objekt nastaven posledním užitím metody SET_OPERATION.

Metoda nemá parametry.

Na rozdíl od příkazu DELETE kódu po ukončení, je možné s její pomocí rušit uzly v diagramech nadřízených procesů.

Metoda vrací logickou hodnotu TRUE v případě, že zrušení uzlu bylo úspěšné.

Pozor - rušení operace není prováděno v rámci transakce kódu po ukončení operace.

DOC_SHOW

OBJEKT.DOC_SHOW([text] [,mod])

Zobrazí dokumenty (zobrazí okno s dokumenty jako po CTRL D) spojené s procesem nebo operací podle posledního nastavení volání metodou SET_PROCESS nebo SET_OPERATION.

Parametr TEXT (je-li uveden) může obsahovat textovou hodnotu nabízenou při zakládání nového dokumentu (jinak je nabízen název operace resp. číslo procesu).

Parametr MOD může nabývat hodnotu 1, která způsobí, že je bezprostředně nabídnut vstup nového dokumentu.

Okno s dokumenty není spuštěno modálně (tj. program kódu po ukončení operace nezastaví a po vyvolání okna pokračuje), proto je třeba ošetřit jeho ukončení příkazem ERROR resp. CANCEL (viz.příklad.)

BM_MSG_SEND

OBJECT. BM_MSG_SEND([PRIKAZ],[PRIJEMCE], [TEXT],

[KOMENT],[DATUM])

Odešle zprávu BM a spojí ji s určenou operací.

Parametry:

1/ [PRIKAZ] - text - má význam SHOW - program zastaví a nechá uživatele doeditovat zprávu a určit příjemce zprávy

2/ [PRIJEMCE] - text - přijemce zprávy - může být -

a/ prázdný - je-li _prikaz="SHOW"

b/ seznam identifikací uživatelů (podle tabulky BWUZIVAT) oddělených čárkou

c/ * - zpráva má být odeslána všem aktivním uživatelům systému s právem zápis na operaci, které se zpráva týká

d/ @<skupina živatelů> - zpráva má být všem aktivním uživatelům systému, kteří náleží do dané skupiny

3/ [TEXT]- text - popis zprávy - řetězec ### v textu je nahrazován identifikací a názvem operace

4/ [KOMENT] - text - komentář ke zprávě - řetězec ### v textu je nahrazován identifikací a názvem operace

5/ [DATUM] - datum - datum signalizace zprávy - nepovinný - není-li uveden, datum signalizace odpovídá systémovému datu počítače

Zpráva je odesílána v rámci transakce ukončení operace, tzn. pokud se uplatní v kódu po ukončení příkaz ERROR nebo CANCEL, zpráva nebude odeslána, stejně jako pokud zápis dat o ukončení datový server z nějakého důvodu odmítne.

Zpráva je odeslána na operaci určenou posledním volání metody SET_OPERATION.

Z přehledu zpráv může potom příjemce zprávy operaci přímo spouštět klávesou F9. Jestliže byla zpráva odeslána na uzel typu proces a pro tento uzel již existují nestornované podřízené procesy, bude spuštěna první operace jednoho z nich s informativním hlášením.

Metoda vrací logickou hodnotu TRUE nebo FALSE podle toho, zda byla nějaká zpráva odeslána lépe řečeno připravena k odeslání.

Příklady použití objektu třídy KU_DATA:

*Příklad práce s volnou kartou

DECLARE OBJECT karta

DECLARE kapac

* inicializace objektu „karta“

SET karta=CREATE('KU_DATA')

* vyhledání procesu předchůdce druhu OO1

karta.SET_PROCESS('OO1')

IF NOT karta.FOUND()

ERROR 'Nenašel proces'

RETURN

ELSE

* otevření volné karty procesu pro aktualizaci uživatelem

karta.FC_READ('SCHVALEN')

* otevření volné karty 'SCHVALEN' procesu 'OO1' pro přístup programu

karta.FC_OPEN('SCHVALEN')

* zjištění hodnoty atributu „kapacita“ volné karty 'SCHVALEN' procesu 'OO1'

SET kapac=karta.FC_GET('kapacita')

* uzavření volné karty

karta.FC_CLOSE()

* nastavení objektu na operaci 'OBC-pobj' procesu 'OO1'

karta.SET_OPERATION('OBC','pobj')

IF NOT karta.FOUND()

ERROR 'Nenašel operaci'

RETURN

ELSE

* otevření volné karty 'test' operace 'OBC-pobj' procesu 'OO1' pro program

karta.FC_OPEN('test')

zápis hodnoty 2 do atributu 'volba'

karta.FC_PUT('volba',2)

* uložení změn a uzavření volné karty

karta.FC_SAVE()

* otevření volné karty pro aktualizaci uživatelem

karta.FC_READ('test')

ENDIF

ENDIF

*Příklad zjišťování hodnot událostí operací

DECLARE OBJECT ob

DECLARE suma

* inicializace objektu „ob“

SET ob=CREATE('KU_DATA')

* vyhledání procesu předchůdce druhu OO1

ob.SET_PROCESS('OO1')

IF NOT ob.FOUND()

ERROR 'Nenašel proces'

RETURN

ELSE

* nastavení objektu na operaci 'OBC-pobj' procesu 'OO1'

ob.SET_OPERATION('OBC','pobj')

IF NOT ob.FOUND()

ERROR 'Nenašel operaci'

RETURN

ELSE

* sumární hodnota nad událostmi operace 'OBC-pobj' procesu 'OO1' do suma

suma=ob.ev_sum(‘ob02mnr’)

.

.

ENDIF

ENDIF

*Příklad zjišťování hodnot SQL dotazem

DECLARE OBJECT ob

DECLARE suma

* inicializace objektu „ob“

SET ob=CREATE('KU_DATA')

* vyhledání procesu předchůdce druhu OO1

ob.SET_PROCESS('OO1')

IF NOT ob.FOUND()

ERROR 'Nenašel proces'

RETURN

ELSE

* nastavení objektu na operaci 'OBC-pobj' procesu 'OO1'

ob.SET_OPERATION('OBC','pobj')

IF NOT ob.FOUND()

ERROR 'Nenašel operaci'

RETURN

ELSE

* otevření SQL dotazu operace 'OBC-pobj' procesu 'OO1'

ob.SQL_OPEN(‘SELECT SUM(OBUDAL.ob02mnr) AS soucet FROM’+;

‘ %%%.OBUDAL WHERE sp33cisdr=?_sp33cisdr AND ‘+;

‘sp33cisdpm=?_sp33cisdpm AND ‘+;

‘sp33cisd=?_sp33cisd AND ‘+;

‘sp07idtyp=?_sp07idtyp AND ‘+;

‘sp06idsubs=?_sp07idsubs AND ‘+;

‘sp33porad=?_sp33porad‘)

* zjištění hodnoty atributu soucet SQL dotazu

SET suma=NVL(ob.SQL_GET(‘soucet’),0)

.

.

ENDIF

ENDIF

*Příklad tisku dokladu nadřízeného procesu

DECLARE OBJECT ob

* inicializace objektu „ob“

SET ob=CREATE('KU_DATA')

* vyhledání procesu předchůdce druhu OO1

ob.SET_PROCESS('OO1')

IF NOT ob.FOUND()

ERROR 'Nenašel proces'

RETURN

ELSE

ob.OP_PRINT(‘WASDEFXFEW‘)

ENDIF

* Příklad práce s dokumentem operace

DECLARE OBJECT dt

DECLARE pc1,pc2

DECLARE popis=select('vyv-obcinf',vy01text)

SET dt=CREATE('ku_data')

* založil uživatel dokument k operaci ?

dt.sql_open([select count(*) as pocet from %%%.spprcod,%%%.bwobject,]+;

[%%%.spdokobs where ]+;

[sp33cisdr=?_sp33cisdr and sp33cisdpm=?_sp33cisdpm and ]+;

[sp33cisd=?_sp33cisd and sp34=bw09inst1 and bw09typ2='DD' and ]+;

[sp26=bw09inst2 and sp26obs is not null])

set pc1=dt.sql_get('pocet')

dt.sql_close()

if pc1=0

* nezaložil !!!

dt.sql_open([select count(*) as pocet from %%%.spprcod,%%%.bwobject where ]+;

[sp33cisdr=?_sp33cisdr and sp33cisdpm=?_sp33cisdpm and ]+;

[sp33cisd=?_sp33cisd and sp34=bw09inst1 and bw09typ2='DD'])

set pc2=dt.sql_get('pocet')

dt.sql_close()

if pc2>0

* existuje alespoň jeden prázdný dokument operace

dt.doc_show(popis)

ERROR 'Dokument je prázdný'

else

* žádný dokument nebyl dosud založen

dt.doc_show(popis,1)

cancel

endif

endif

*

* Příklad odeslání zprávy BM

DECLARE OBJECT ob

SET ob=CREATE('KU_DATA')

ob.SET_OPERATION('','ZAUCT')

IF !ob.BM_MSG_SEND('SHOW','@UCETNI','Zaúčtujte','Operace : ###') THEN cancel

* Příklad nastavení objektu na nadřízený proces

DECLARE OBJECT ob

SET ob=CREATE('KU_DATA')

ob.set_process('*')

IF ob.found() AND ob.sp07idtypd="PROCE1"

ob.set_process('*',.T.)

IF ob.found() AND ob.sp07idtypd="PROCE2"

.........

.........

ENDIF

ENDIF

* Příklad rušení uzlu metodou OP_DELETE

DECLARE OBJECT ob

SET ob=CREATE('KU_DATA')

ob.set_process('*')

IF ob.found()

ob.set_operation('DPH','dpnsex')

IF ob.found() AND ob.op_evaluate('sp34zahaje')=0

ob.op_delete()

ENDIF

ENDIF

KU_INPUT - Třída objektů pro vstup uživatelské informace

Metoda

Popis

INP_FORMCAPTION

Nastavení nadpisu vstupního formuláře

OBJEKT. INP_FORMCAPTION (‘Název formuláře‘)

INP_CHECKBOX

Příprava zaškrtávacího políčka

OBJEKT.INP_CHECKBOX('Proměnná','Text'[,inic[,'Návěští']])

Parametr 'Proměnná' určuje běžnou proměnnou definovanou příkazem DECLARE, do které bude po vstupu formuláře metodou INP_READ vložena hodnota vstupu zaškrtávacího políčka.

Parametr 'Text' určuje popis zaškrtávacího políčka.

Nepovinný parametr inic může nabývat hodnot 0 nebo 1, při jeho neuvedení je odpovídající proměnná inicializována hodnotou 0.

Je-li uveden parametr 'Návěští', potom bude ve vstupním formuláři vlevo od zaškrtávacího políčka zobrazeno návěští s odpovídajícím textem.

INP_COMBOBOX

Příprava překryvného seznamu

OBJEKT. INP_COMBOBOX('Proměnná','Text'[,inic[,'Návěští']])

Parametr 'Proměnná' určuje běžnou proměnnou definovanou příkazem DECLARE, do které bude po vstupu formuláře metodou INP_READ vložena hodnota vstupu překryvného seznamu.

Obsah seznamu je určen parametrem 'Text' (jednotlivé položky seznamu jsou v parametru odděleny čárkou).

Nepovinný parametr inic může nabývat hodnot větších než 0, při jeho neuvedení je odpovídající proměnná inicializována hodnotou 1.

Je-li uveden parametr 'Návěští', potom bude ve vstupním formuláři vlevo od překryvného seznamu zobrazeno návěští s odpovídajícím textem.

INP_OPTIONGROUP

Příprava skupiny přepínačů

OBJEKT.INP_OPTIONGROUP('Proměnná','Text'[,inic[,'Návěští']])

Parametr 'Proměnná' určuje běžnou proměnnou definovanou příkazem DECLARE, do které bude po vstupu formuláře metodou INP_READ vložena hodnota vstupu skupiny přepínačů.

Přepínače jsou definovány obsahem parametru 'Text' (jednotlivé přepínače jsou v parametru odděleny čárkou).

Nepovinný parametr inic může nabývat hodnot větších než 0, při jeho neuvedení je odpovídající proměnná inicializována hodnotou 1.

Je-li uveden parametr 'Návěští', potom bude ve vstupním formuláři vlevo od skupiny přepínačů zobrazeno návěští s odpovídajícím textem.

INP_LABEL

Příprava návěští

OBJEKT.INP_LABEL('Návěští')

Metodou je vloženo do vstupního formuláře návěští s odpovídajícím textem na samostatný řádek.

INP_LINE

Příprava oddělovací linky

OBJEKT.INP_LINE()

Metodou je vložena do vstupního formuláře oddělovací linka.

INP_READ

Aktivace vstupního formuláře

OBJEKT.INP_READ()

Metoda zahajuje vstup formuláře s prvky určenými metodami INP_CHECKBOX, INP_COMBOBOX, INP_OPTIONGROUP, INP_LABEL a INP_LINE.

Vrací logickou hodnotu TRUE při ukončení formuláře tlačítkem ‚OK‘ nebo jeho uzavření tlačítkem ‚x‘ v nadpisu formuláře.

Vrací logickou hodnotu FALSE při ukončení formuláře tlačítkem ‚Storno‘ nebo klávesou ESC.

Příklad použití objektu třídy KU_INPUT:

DECLARE p1,p2,p3

DECLARE OBJECT rd

SET rd=CREATE('KU_INPUT')

rd.INP_FORMCAPTION('Název formuláře')

rd.INP_CHECKBOX('p1','Zaškrtnutí')

rd.INP_LINE()

rd.INP_COMBOBOX('p2','Volba 1,Volba 2,Volba 3,Volba 4',3,'Návěští')

rd.INP_LINE()

rd.INP_LABEL('Návěští')

rd.INP_OPTIONGROUP('p3','Přepínač 1, Přepínač 2, Přepínač 3',2)

IF NOT rd.INP_READ()

* zde by obvykle následoval příkaz CANCEL

ERROR 'Uživatel stiskl ESC'

ELSE

* zde by obvykle následoval kód vyhodnocení hodnot proměnných p1,p2,p3

ERROR 'Zjištěné hodnoty P1='+LTRIM(STR(p1))+;

', P2='+LTRIM(STR(p2))+;

', P3='+LTRIM(STR(p3))

ENDIF

KU_MAIL - Třída objektů pro odesílání MAIL

Metoda

Popis

SET_RECIPADRESS

Nastavení adresy příjemce

OBJEKT. SET_RECIPADRESS(‘Adresa‘)

Je možné přímo předat objektu jednu nebo více adres oddělených středníkem nebo určit adresáta na jeho E-MAILovou adresu(y) má být zpráva odeslána (v tom případě musí adresa začínat znakem ‘*‘)

SET_SUBJECT

Nastavení předmětu zprávy

OBJEKT. SET_SUBJECT(‘text‘)

SET_MESSAGETEXT

Nastavení popisu zprávy

OBJEKT.SET_MESSAGETEXT (‘text‘)

SET_FILE

Připojení souboru(ů)

OBJEKT. SET_FILE (‘Seznam souborů‘)

Seznam souborů je seznam dvojic identifikace + popis souboru oddělených středníkem (popis souboru by měl mít uvedenu příponu)

Např.:

‘soubor1.txt;Seznam uživatelů.txt;dokumentx.doc;Přehled.doc‘

znamená, že do MAIL bude přenesen soubor1.txt, který bude v MAIL vystupovat jako Seznam uživatelů.txt a soubor dokumentx.doc, který bude v MAIL vystupovat jako Přehled.doc.

Popis souboru není povinný.

SET_PROMPT

Nastavení možnosti úpravy MAIL

OBJEKT.SET_PROMPT(0/1)

Při uvedení hodnoty parametru metody 1 (přednastavená hodnota) bude možné výstupní MAIL před odesláním upravit.

SEND_MAIL

Odeslání MAIL

OBJEKT. SEND_MAIL()

Odeslání MAIL musí předcházet některá z předcházejících metod.

Není-li metoda SEND_MAIL v kódu po ukončení užita, bude MAIL odeslán v rámci transakce ukončení operace.

Po provedení SEND_MAIL se automaticky provádí RESET_MAIL.

V souvislosti s odesíláním je možné nastavit jméno profilu v souboru BW.INI nebo lokálně v BWLCL.INI parametrem ‚mail_profile‘ v sekci ‚Preferences‘ např.:

mail_profile=Nastavení MS Exchange

RESET_MAIL

Vynulování stavu objektu

OBJEKT. RESET_MAIL()

Nuluje nastavení vlastností MAIL, pro odeslání dalšího MAIL bude třeba nastavit některou jeho vlastnost.

Příklad použití objektu třídy KU_MAIL:

DECLARE OBJECT mail

SET mail=CREATE('KU_MAIL')

mail.SET_RECIPADRESS(‘bmservis@bmservis.cz‘)

mail.SET_SUBJECT(‘Pozdrav‘)

mail.SET_MESSAGETEXT(‘Nazdar‘+CHR(13)+tool.jmeno)

IF NOT mail.SEND_MAIL()

CANCEL

ENDIF

Novinky:

17.01.2003

V kódu po ukončení operace je možné přidat skript v jazyce FOXPRO.

Skript musí být uveden příkazem "SCRIPT" a ukončen příkazem "ENDSCRIPT".

V okamžiku běhu skriptu je v proměnné _THIS odkaz na objekt řídící zpracovnání kódu po ukončení operace a v proměnné _THIS_SPRAVCE odkaz na objekt řídící transformace.

V kódu skriptu je možné použít metodu ADDACTION pro modifikaci diagramu ve tvaru:

_THIS.addaction(<<akce>>,<<druh>>[,<<komponenta>>]).

Např.:

_this.addaction('ACTIVATE','operace','OBC')

_this.addaction('DELETE','proces')

Kód skriptu musí vracet logickou hodnotu. V případě, že vrátí logickou hodnotu FALSE, zpracování kódu po ukončení bude přerušeno a operace nebude ukončena.

Dokumentace jazyka kódu pro ukončení operace

Kód pro ukončení operace slouží k řízení probíhajícího procesu na základě informací v událostech operací procesu a uživatelských rozhodnutí. Řízení procesu spočívá v modifikaci jeho procesního diagramu nastavením stavu operací do stavu připravena nebo v odstranění těch operací, které ztratily vzhledem ke vstoupeným informacím smysl. Kód musí být zapsán ve zvláštním programovacím jazyce.

Příkaz

Popis

DECLARE

Slouží k deklaraci proměnných použitých v kódu.

Má tři možné formy:

· deklarace dotazu na informace o událostech některé z operací procesu

Dotaz | Popis
COUNT | Zjištění počtu událostí COUNT('komponenta-druh operace') [FOR podmínka] Př.: počet všech událostí v operaci ‚nap‘ komponenty ‚DPH‘, které mají atribut ‚dp02odpnap‘ roven 1 (události odpočet) DECLARE počet=COUNT('DPH-nap') FOR dp02odpnap=1
MAX | Maximální hodnota výrazu MAX('komponenta-druh operace',výraz) [FOR podmínka] Př.: největší hodnota ‘ob02mnr’ (množství v referenční měrné jednotce) mezi událostmi operace ‚prij‘ komponenty obchod DECLARE maximum=MAX('OBC-prij',ob02mnr)
MIN | Minimální hodnota výrazu MIN('komponenta-druh operace',výraz) [FOR podmínka] Př.: nejmenší hodnota ‘ob02mnr’ (množství v referenční měrné jednotce) mezi událostmi operace ‚prij‘ komponenty obchod DECLARE mnozstvi=MIN('OBC-prij',ob02mnr)
SELECT | Hodnota výrazu v prvé události operace SELECT('komponenta-druh operace',výraz) [FOR podmínka] Př.: hodnota výrazu ‚ad01id‘ (identifikace adresáta) z prvého záznamu operace ‚prij‘ komponenty obchod DECLARE adresat=SELECT('OBC-prij',ad01id)
SUM | Součet hodnot výrazu SUM('komponenta-druh operace',výraz) [FOR podmínka] Př.: Celkový součet výrazu ‚pl02crmnez‘ (částka v referenční měně nezaokrouhlená) událostí operace ‚xxx‘ komponenty platby DECLARE prom5=SUM('PLA-xxx', pl02crmnez)

· deklarace běžných proměnných užitých ve formuláři

DECLARE x,z,y

· deklarace objektových proměnných

DECLARE object o1,object o2

SET

Slouží k inicializaci proměnné

Má tři možné formy:

· nastavení proměnné procesu

SET #N#=hodnota

Kde N je cifra 1,2,…,9 a hodnota je numerická hodnota

· přiřazení hodnoty běžné proměnné

SET x=a+b

· inicializace objektové proměnné

SET o1=CREATE(‘třída objektu‘)

IF

Podmiňuje provádění příkazů

· Jednořádkový IF

IF <podmínka> THEN <příkaz>

· Víceřádkový IF

IF <podmínka>

<příkaz>

….

[ELSE

<příkaz>

….]

ENDIF

ACTIVATE

Aktivuje operaci nebo proces uvedený v parametru

ACTIVATE ‘OBC-DODANI’

Nebo aktivace uzlu diagramu v nadřízeném procesu, ze kterého byl process vyvolán

ACTIVATE PARENT

DELETE

Ruší z diagramu operaci nebo proces uvedený v parametru

DELETE ‘OBC-DODANI’

ERROR

Chybové hlášení (operace nebude ukončena)

ERROR ‘Máte tam chybu’. Příkaz ERROR neukončuje provádění kódu po ukončení operace.

CANCEL

Ukončení kódu, bez chybového hlášení (operace nebude ukončena)

CANCEL

RETURN

Ukončení kódu, bez chybového hlášení (operace bude ukončena)

RETURN

*

Komentář

Použití příkazu ERROR v kombinaci s RETURN:

Algoritmus provádění příkazů v kódu po ukončení je neprovádí sekvenčně, jak by se dalo předpokládat. V níže uvedené posloupnosti příkazů se provede dříve skupina příkazů IF ..... ENDIF a teprve po ní se provede příkaz ERROR.

DECLARE cena0=COUNT('OBC-obpit1') FOR dp02czarm=0 ERROR 'xxx'

IF cena0>0

DECLARE dotaz1

SET dotaz1=ASK3('Cena materiálu je opravdu nulová?')

IF dotaz1='N' OR dotaz1='Z'

CANCEL

ENDIF

ENDIF

Příkaz ERROR neukončuje provádění kódu po ukončení operace. Tato vlastnost nebude z důvodu kompatibility změněna. Příkaz pro ukončení zpracování kódu je RETURN.

Např.:

DECLARE cena0=COUNT('OBC-obpit1') FOR dp02czarm=0 ERROR 'xxx'

RETURN

IF cena0>0

DECLARE dotaz1

SET dotaz1=ASK3('Cena materiálu je opravdu nulová?')

IF dotaz1='N' OR dotaz1='Z'

CANCEL

ENDIF

ENDIF

V kódu po ukončení operace je možné testovat, zda je nebo není operace ukončována předběžně.

Příkazem IF je možné testovat proměnnou THIS.OPERACE_UKONCOVANA_PREDBEZNE

Např.:

IF THIS.OPERACE_UKONCOVANA_PREDBEZNE

RETURN

ENDIF

Dále je možné v kódu po ukončení určit, že má nebo nemá být operace ukončena předběžně. Toto nastavení musí být provedeno scriptem v jazyce Foxpro.

Např.:

SCRIPT

_THIS.OPERACE_UKONCOVANA_PREDBEZNE=.T.

ENDSCRIPT

V kódu mohou být použity konstanty a funkce

#MP# | Konstanta obsahuje informaci, že operace byla ukončena s nenaplněnou mírou plnění
ASK | Dotaz k uživateli – tvar ANO/NE Funkce s jedním parametrem typu text. Vrací logickou hodnotu TRUE nebo FALSE
ASK3 | Dotaz k uživateli – tvar ANO/NE/STORNO Funkce s jedním parametrem typu text. Vrací textovou hodnotu ‚A‘ nebo ‚N‘ nebo ‚Z‘

Příklad použití konstanty #MP# a funkce ASK3:

DECLARE dotaz

IF #MP#

SET dotaz=ASK3('Je dodání ukončeno ?')

IF dotaz='N'

ACTIVATE PARENT

ELSE

IF dotaz='Z' THEN CANCEL

ENDIF

ENDIF

Příklad souvisí s možností nastavení parametru operace „Test mírou plnění“ na hodnotu „Rozhodne kód po ukončení operace“, který způsobí to, že po ukončení operace s nenaplněnou mírou plnění nebude zobrazen obvyklý dotaz „Míra plnění nebyla naplněna. Přesto ukončit operaci“ v případě, že se v kódu po ukončení někde vyskytuje odkaz na konstantu #MP#.

V kódu je dále možné pracovat s objekty, které mohou provádět nejrůznější akce. Pro tyto objekty musí být dodavatelem systému připraveny třídy.

V současné době je připravena třída pro práci s daty, třída pro vstup uživatelské informace a třída pro odesílání MAIL.

KU_DATA - Třída objektů pro práci s daty (volné karty procesů a operací, informace událostí operací, SQL dotazy)

Metoda

Popis

SET_PROCESS

Nastavení objektu na proces

OBJEKT.SET_PROCESS([‘druh procesu‘][,start])

Není-li parametr uveden, nastaví na proces aktuálně ukončované operace (není třeba provádět po inicializaci objektu, pokud se dále bude pracovat s volnými kartami operací aktuálního procesu, inicializací je objekt nastaven na tento proces).

Je-li parametr uveden vyhledává objekt proces určeného druhu, který v hlavním procesu předcházel aktuálnímu procesu.

V tomto případě je třeba práci s dalšími metodami ošetřit dotazem metodou FOUND, která vrací logickou hodnotu TRUE, v případě, že byl odpovídající proces nalezen.

Při uvedení znaku ‘*‘ v prvém parametru, potom je objekt nastaven na proces, který je ve stromu bezprostředním předchůdcem uzlu ve stromu (kterého -> to je dáno parametrem ‘start‘) bez ohledu na to, jakého je druhu.

Vlastnost objektu SP07IDTYPD přitom obsahuje identifikaci druhu procesu, na který byl objekt nastaven posledním užitím metody SET_PROCESS.

Parametr ‘start‘ – určuje uzel ve stromu procesu, od kterého je proces vyhledáván.

Není-li uveden nebo při uvedené logické hodnotě FALSE (.F.) , je vyhledáván proces druhu podle prvého parametru metody ve stromu počínaje od čísla procesu odpovídajícímu aktuálně ukončované operaci.

Při uvedení druhého parametru s logickou hodnotou TRUE (.T.), se vyhledávání ve stromu zahajuje od čísla procesu, na který byl objekt nastaven posledním užitím metody SET_PROCESS.

SET_OPERATION

OBJEKT. SET_OPERATION([‘komponenta’,’druh operace’[,pořadí]])

Není-li parametr uveden, nastaví na aktuálně ukončovanou operaci (není třeba provádět po inicializaci objektu, inicializací je objekt nastaven na tuto operaci)

Je-li parametr uveden vyhledává objekt operaci určeného druhu v procesu, který byl určen metodou SET_PROCESS.

V tomto případě je třeba práci s dalšími metodami ošetřit dotazem metodou FOUND, která vrací logickou hodnotu TRUE, v případě, že

byla odpovídající operace nalezena.

Při nastavení na uzel diagramu charakteru proces se jako první parametr uvádí prázdný řetězec a druhý parametr druh procesu (využití např. při použití metody OP_EXEC – založení nového procesu na základě diagramu)

FOUND

OBJEKT.FOUND()

Vrací logickou hodnotu TRUE nebo FALSE podle toho, zda byl proces nebo operace vyvoláním metody SET_PROCESS nebo SET_OPERATION nalezen.

FC_READ

OBJEKT.FC_READ(‘identifikace volné karty‘)

Vyvoláním je aktivována volná karta určené identifikace procesu nebo operace, na kterou(ý) je objekt nastaven posledním voláním metod SET_PROCESS nebo SET_OPERATION, pro uživatelský vstup.

V okamžiku volání metody nesmí být objektem otevřena volná karta metodou FC_OPEN.

FC_OPEN

OBJEKT.FC_OPEN(‘identifikace volné karty‘)

Metoda otevírá volnou kartu pro programový přístup metodami FC_GET a FC_PUT.

Je otevřena volná karta procesu nebo operace, na kterou(ý) je objekt nastaven posledním voláním metod SET_PROCESS nebo SET_OPERATION.

FC_GET

OBJEKT.FC_GET(‘identifikace atributu volné karty‘)

Metoda vrací hodnotu atributu volné karty. Atribut se musí být součástí volné karty otevřené metodou FC_OPEN.

FC_PUT

OBJEKT.FC_PUT(‘identifikace atributu volné karty‘,hodnota)

Metoda nastavuje hodnotu atributu volné karty. Atribut se musí být součástí volné karty otevřené metodou FC_OPEN a musí být stejného typu jako zapisovaná hodnota.

Takto vložená informace se zapisuje na volnou kartu metodou FC_SAVE nebo v rámci transakce ukončení operace nebyla-li metoda FC_SAVE v následujícím kódu užita.

Provedené změny karty je možné zrušit před příkazem FC_SAVE metodou FC_ROLLBACK

FC_SAVE

OBJEKT.FC_SAVE()

Ukládá změny provedené metodami FC_PUT a uzavírá volnou kartu.

FC_ROLLBACK

OBJEKT.FC_ROLLBACK()

Ruší změny provedené metodami FC_PUT.

FC_CLOSE

OBJEKT. FC_CLOSE()

Uzavírá volnou kartu.

EV_COUNT

OBJEKT. EV_COUNT([‘podmínka‘])

Vrací počet událostí operace, na kterou je objekt nastaven posledním voláním metody SET_OPERATION.

Při nastavení objektu na operaci procesu aktuálně ukončované operace ekvivalent DECLARE …=COUNT(….

EV_MAX

OBJEKT. EV_MAX(‘výraz‘ [,‘podmínka‘])

Vrací maximální hodnotu výrazu nad událostmi operace, na kterou je objekt nastaven posledním voláním metody SET_OPERATION.

Při nastavení objektu na operaci procesu aktuálně ukončované operace ekvivalent DECLARE …=MAX(….

EV_MIN

OBJEKT. EV_MIN(‘výraz‘ [,‘podmínka‘])

Vrací minimální hodnota výrazu nad událostmi operace, na kterou je objekt nastaven posledním voláním metody SET_OPERATION.

Při nastavení objektu na operaci procesu aktuálně ukončované operace ekvivalent DECLARE …=MIN(….

EV_SELECT

OBJEKT. EV_SELECT(‘výraz‘ [,‘podmínka‘])

Vrací hodnotu výrazu prvé události operace, na kterou je objekt nastaven posledním voláním metody SET_OPERATION.

Při nastavení objektu na operaci procesu aktuálně ukončované operace ekvivalent DECLARE …=SELECT(….

EV_SUM

OBJEKT. EV_SUM(‘výraz‘ [,‘podmínka‘])

Vrací suma výrazu nad událostmi operace, na kterou je objekt nastaven posledním voláním metody SET_OPERATION.

Při nastavení objektu na operaci procesu aktuálně ukončované operace ekvivalent DECLARE …=SUM(….

SQL_OPEN

OBJEKT. SQL_OPEN(‘SQL dotaz‘)

Metoda otevírá soubor pro následné dotazy metodou SQL_GET.

V okamžiku dotazu jsou nastaveny pomocné proměnné _sp33cisdr,_sp33cisdpm,_sp33cisd,_sp07idtyp,_sp06idsubs,_sp33porad podle posledního vyvolání metod SET_PROCESS nebo SET_OPERATION. Tyto proměnné je možné použít v dotazu v otazníkové konvenci

SQL_GET

OBJEKT.SQL_GET(‘identifikace atributu SQL dotazu‘)

Vrací hodnotu atributu ze souboru otevřeného posledním volání metody SQL_OPEN.

SQL_CLOSE

OBJEKT.SQL_CLOSE()

Uzavírá soubor otevření metodou SQL_OPEN.

OP_PRINT

OBJEKT.OP_PRINT(‘Identifikace předlohy‘[,způsob vyvolání])

Provádí výstup operace nebo procesu podle posledního nastavení metodou SET_OPERATION resp. SET_PROCESS

Identifikaci předlohy je možné zjistit ve vlastnostech předlohy na poslední záložce atribut ID:.

Z této identifikace se uvádí část identifikace za znakem podtržení (např. je-li OB0101_W123456789, uvádí se W123456789)

Parametr způsob vyvolání může nabývat hodnotu 1. Je-li uveden znamená, že výstup podle předlohy bude vyvolán bezprostředně voláním metody (tj. výstupní soubor Excelu nebo HTML bude k dispozici odesílanému E-mailu objektem třídy KU_MAIL).

Není-li parametr způsob vyvolání uveden, potom bude výstup proveden až po úspěšném ukončení operace a informace o provedeném výstupu se zapíše do „průběhu operací“, odkud ho bude možné zopakovat.

OP_PRINT_META

OBJEKT.OP_PRINT_META(‘Metapředloha‘[,způsob vyvolání])

Provádí výstup operace nebo procesu metapředlohou podle posledního nastavení metodou SET_OPERATION resp. SET_PROCESS

Parametr způsob vyvolání může nabývat hodnotu 1. Je-li uveden znamená, že výstup podle metapředlohy bude vyvolán bezprostředně voláním metody (tj. výstupní soubor Excelu nebo HTML bude k dispozici odesílanému E-mailu objektem třídy KU_MAIL).

Není-li parametr způsob vyvolání uveden, potom bude výstup proveden až po úspěšném ukončení operace a informace o provedeném výstupu se zapíše do „průběhu operací“, odkud ho bude možné zopakovat.

OP_EXEC

OBJEKT.OP_EXEC()

Spustí (uloží do zásobníku, na rozdíl od ACTIVATE třeba i ukončenou) operaci podle posledního nastavení metodou SET_OPERATION.

Metoda je určena ke spouštění operací v nadřazeném procesu.

V případě nastavení na uzel typu proces se vždy zahájí nový proces

OP_EVALUATE

OBJEKT.OP_EVALUATE([výraz])

Slouží ke zjištění informací o stavu operace (uzlu), na kterou byl objekt nastaven posledním užitím metody SET_OPERATION.

Metoda má jediný parametr, který obsahuje výraz, ve kterém má smysl uvádět atributy tabulky SPPRCOD - viz.datový model.

Metoda vrací hodnotu výrazu nebo FALSE (.F.), není-li možné výraz vyhodnotit.

OP_DELETE

OBJEKT. OP_DELETE()

Ruší operaci (uzel) ve stromu hlavního procesu, na kterou byl objekt nastaven posledním užitím metody SET_OPERATION.

Metoda nemá parametry.

Na rozdíl od příkazu DELETE kódu po ukončení, je možné s její pomocí rušit uzly v diagramech nadřízených procesů.

Metoda vrací logickou hodnotu TRUE v případě, že zrušení uzlu bylo úspěšné.

Pozor - rušení operace není prováděno v rámci transakce kódu po ukončení operace.

DOC_SHOW

OBJEKT.DOC_SHOW([text] [,mod])

Zobrazí dokumenty (zobrazí okno s dokumenty jako po CTRL D) spojené s procesem nebo operací podle posledního nastavení volání metodou SET_PROCESS nebo SET_OPERATION.

Parametr TEXT (je-li uveden) může obsahovat textovou hodnotu nabízenou při zakládání nového dokumentu (jinak je nabízen název operace resp. číslo procesu).

Parametr MOD může nabývat hodnotu 1, která způsobí, že je bezprostředně nabídnut vstup nového dokumentu.

Okno s dokumenty není spuštěno modálně (tj. program kódu po ukončení operace nezastaví a po vyvolání okna pokračuje), proto je třeba ošetřit jeho ukončení příkazem ERROR resp. CANCEL (viz.příklad.)

BM_MSG_SEND

OBJECT. BM_MSG_SEND([PRIKAZ],[PRIJEMCE], [TEXT],

[KOMENT],[DATUM])

Odešle zprávu BM a spojí ji s určenou operací.

Parametry:

1/ [PRIKAZ] - text - má význam SHOW - program zastaví a nechá uživatele doeditovat zprávu a určit příjemce zprávy

2/ [PRIJEMCE] - text - přijemce zprávy - může být -

a/ prázdný - je-li _prikaz="SHOW"

b/ seznam identifikací uživatelů (podle tabulky BWUZIVAT) oddělených čárkou

c/ * - zpráva má být odeslána všem aktivním uživatelům systému s právem zápis na operaci, které se zpráva týká

d/ @<skupina živatelů> - zpráva má být všem aktivním uživatelům systému, kteří náleží do dané skupiny

3/ [TEXT]- text - popis zprávy - řetězec ### v textu je nahrazován identifikací a názvem operace

4/ [KOMENT] - text - komentář ke zprávě - řetězec ### v textu je nahrazován identifikací a názvem operace

5/ [DATUM] - datum - datum signalizace zprávy - nepovinný - není-li uveden, datum signalizace odpovídá systémovému datu počítače

Zpráva je odesílána v rámci transakce ukončení operace, tzn. pokud se uplatní v kódu po ukončení příkaz ERROR nebo CANCEL, zpráva nebude odeslána, stejně jako pokud zápis dat o ukončení datový server z nějakého důvodu odmítne.

Zpráva je odeslána na operaci určenou posledním volání metody SET_OPERATION.

Z přehledu zpráv může potom příjemce zprávy operaci přímo spouštět klávesou F9. Jestliže byla zpráva odeslána na uzel typu proces a pro tento uzel již existují nestornované podřízené procesy, bude spuštěna první operace jednoho z nich s informativním hlášením.

Metoda vrací logickou hodnotu TRUE nebo FALSE podle toho, zda byla nějaká zpráva odeslána lépe řečeno připravena k odeslání.

Příklady použití objektu třídy KU_DATA:

*Příklad práce s volnou kartou

DECLARE OBJECT karta

DECLARE kapac

* inicializace objektu „karta“

SET karta=CREATE('KU_DATA')

* vyhledání procesu předchůdce druhu OO1

karta.SET_PROCESS('OO1')

IF NOT karta.FOUND()

ERROR 'Nenašel proces'

RETURN

ELSE

* otevření volné karty procesu pro aktualizaci uživatelem

karta.FC_READ('SCHVALEN')

* otevření volné karty 'SCHVALEN' procesu 'OO1' pro přístup programu

karta.FC_OPEN('SCHVALEN')

* zjištění hodnoty atributu „kapacita“ volné karty 'SCHVALEN' procesu 'OO1'

SET kapac=karta.FC_GET('kapacita')

* uzavření volné karty

karta.FC_CLOSE()

* nastavení objektu na operaci 'OBC-pobj' procesu 'OO1'

karta.SET_OPERATION('OBC','pobj')

IF NOT karta.FOUND()

ERROR 'Nenašel operaci'

RETURN

ELSE

* otevření volné karty 'test' operace 'OBC-pobj' procesu 'OO1' pro program

karta.FC_OPEN('test')

zápis hodnoty 2 do atributu 'volba'

karta.FC_PUT('volba',2)

* uložení změn a uzavření volné karty

karta.FC_SAVE()

* otevření volné karty pro aktualizaci uživatelem

karta.FC_READ('test')

ENDIF

ENDIF

*Příklad zjišťování hodnot událostí operací

DECLARE OBJECT ob

DECLARE suma

* inicializace objektu „ob“

SET ob=CREATE('KU_DATA')

* vyhledání procesu předchůdce druhu OO1

ob.SET_PROCESS('OO1')

IF NOT ob.FOUND()

ERROR 'Nenašel proces'

RETURN

ELSE

* nastavení objektu na operaci 'OBC-pobj' procesu 'OO1'

ob.SET_OPERATION('OBC','pobj')

IF NOT ob.FOUND()

ERROR 'Nenašel operaci'

RETURN

ELSE

* sumární hodnota nad událostmi operace 'OBC-pobj' procesu 'OO1' do suma

suma=ob.ev_sum(‘ob02mnr’)

.

.

ENDIF

ENDIF

*Příklad zjišťování hodnot SQL dotazem

DECLARE OBJECT ob

DECLARE suma

* inicializace objektu „ob“

SET ob=CREATE('KU_DATA')

* vyhledání procesu předchůdce druhu OO1

ob.SET_PROCESS('OO1')

IF NOT ob.FOUND()

ERROR 'Nenašel proces'

RETURN

ELSE

* nastavení objektu na operaci 'OBC-pobj' procesu 'OO1'

ob.SET_OPERATION('OBC','pobj')

IF NOT ob.FOUND()

ERROR 'Nenašel operaci'

RETURN

ELSE

* otevření SQL dotazu operace 'OBC-pobj' procesu 'OO1'

ob.SQL_OPEN(‘SELECT SUM(OBUDAL.ob02mnr) AS soucet FROM’+;

‘ %%%.OBUDAL WHERE sp33cisdr=?_sp33cisdr AND ‘+;

‘sp33cisdpm=?_sp33cisdpm AND ‘+;

‘sp33cisd=?_sp33cisd AND ‘+;

‘sp07idtyp=?_sp07idtyp AND ‘+;

‘sp06idsubs=?_sp07idsubs AND ‘+;

‘sp33porad=?_sp33porad‘)

* zjištění hodnoty atributu soucet SQL dotazu

SET suma=NVL(ob.SQL_GET(‘soucet’),0)

.

.

ENDIF

ENDIF

*Příklad tisku dokladu nadřízeného procesu

DECLARE OBJECT ob

* inicializace objektu „ob“

SET ob=CREATE('KU_DATA')

* vyhledání procesu předchůdce druhu OO1

ob.SET_PROCESS('OO1')

IF NOT ob.FOUND()

ERROR 'Nenašel proces'

RETURN

ELSE

ob.OP_PRINT(‘WASDEFXFEW‘)

ENDIF

* Příklad práce s dokumentem operace

DECLARE OBJECT dt

DECLARE pc1,pc2

DECLARE popis=select('vyv-obcinf',vy01text)

SET dt=CREATE('ku_data')

* založil uživatel dokument k operaci ?

dt.sql_open([select count(*) as pocet from %%%.spprcod,%%%.bwobject,]+;

[%%%.spdokobs where ]+;

[sp33cisdr=?_sp33cisdr and sp33cisdpm=?_sp33cisdpm and ]+;

[sp33cisd=?_sp33cisd and sp34=bw09inst1 and bw09typ2='DD' and ]+;

[sp26=bw09inst2 and sp26obs is not null])

set pc1=dt.sql_get('pocet')

dt.sql_close()

if pc1=0

* nezaložil !!!

dt.sql_open([select count(*) as pocet from %%%.spprcod,%%%.bwobject where ]+;

[sp33cisdr=?_sp33cisdr and sp33cisdpm=?_sp33cisdpm and ]+;

[sp33cisd=?_sp33cisd and sp34=bw09inst1 and bw09typ2='DD'])

set pc2=dt.sql_get('pocet')

dt.sql_close()

if pc2>0

* existuje alespoň jeden prázdný dokument operace

dt.doc_show(popis)

ERROR 'Dokument je prázdný'

else

* žádný dokument nebyl dosud založen

dt.doc_show(popis,1)

cancel

endif

endif

*

* Příklad odeslání zprávy BM

DECLARE OBJECT ob

SET ob=CREATE('KU_DATA')

ob.SET_OPERATION('','ZAUCT')

IF !ob.BM_MSG_SEND('SHOW','@UCETNI','Zaúčtujte','Operace : ###') THEN cancel

* Příklad nastavení objektu na nadřízený proces

DECLARE OBJECT ob

SET ob=CREATE('KU_DATA')

ob.set_process('*')

IF ob.found() AND ob.sp07idtypd="PROCE1"

ob.set_process('*',.T.)

IF ob.found() AND ob.sp07idtypd="PROCE2"

.........

.........

ENDIF

ENDIF

* Příklad rušení uzlu metodou OP_DELETE

DECLARE OBJECT ob

SET ob=CREATE('KU_DATA')

ob.set_process('*')

IF ob.found()

ob.set_operation('DPH','dpnsex')

IF ob.found() AND ob.op_evaluate('sp34zahaje')=0

ob.op_delete()

ENDIF

ENDIF

KU_INPUT - Třída objektů pro vstup uživatelské informace

Metoda

Popis

INP_FORMCAPTION

Nastavení nadpisu vstupního formuláře

OBJEKT. INP_FORMCAPTION (‘Název formuláře‘)

INP_CHECKBOX

Příprava zaškrtávacího políčka

OBJEKT.INP_CHECKBOX('Proměnná','Text'[,inic[,'Návěští']])

Parametr 'Proměnná' určuje běžnou proměnnou definovanou příkazem DECLARE, do které bude po vstupu formuláře metodou INP_READ vložena hodnota vstupu zaškrtávacího políčka.

Parametr 'Text' určuje popis zaškrtávacího políčka.

Nepovinný parametr inic může nabývat hodnot 0 nebo 1, při jeho neuvedení je odpovídající proměnná inicializována hodnotou 0.

Je-li uveden parametr 'Návěští', potom bude ve vstupním formuláři vlevo od zaškrtávacího políčka zobrazeno návěští s odpovídajícím textem.

INP_COMBOBOX

Příprava překryvného seznamu

OBJEKT. INP_COMBOBOX('Proměnná','Text'[,inic[,'Návěští']])

Parametr 'Proměnná' určuje běžnou proměnnou definovanou příkazem DECLARE, do které bude po vstupu formuláře metodou INP_READ vložena hodnota vstupu překryvného seznamu.

Obsah seznamu je určen parametrem 'Text' (jednotlivé položky seznamu jsou v parametru odděleny čárkou).

Nepovinný parametr inic může nabývat hodnot větších než 0, při jeho neuvedení je odpovídající proměnná inicializována hodnotou 1.

Je-li uveden parametr 'Návěští', potom bude ve vstupním formuláři vlevo od překryvného seznamu zobrazeno návěští s odpovídajícím textem.

INP_OPTIONGROUP

Příprava skupiny přepínačů

OBJEKT.INP_OPTIONGROUP('Proměnná','Text'[,inic[,'Návěští']])

Parametr 'Proměnná' určuje běžnou proměnnou definovanou příkazem DECLARE, do které bude po vstupu formuláře metodou INP_READ vložena hodnota vstupu skupiny přepínačů.

Přepínače jsou definovány obsahem parametru 'Text' (jednotlivé přepínače jsou v parametru odděleny čárkou).

Nepovinný parametr inic může nabývat hodnot větších než 0, při jeho neuvedení je odpovídající proměnná inicializována hodnotou 1.

Je-li uveden parametr 'Návěští', potom bude ve vstupním formuláři vlevo od skupiny přepínačů zobrazeno návěští s odpovídajícím textem.

INP_LABEL

Příprava návěští

OBJEKT.INP_LABEL('Návěští')

Metodou je vloženo do vstupního formuláře návěští s odpovídajícím textem na samostatný řádek.

INP_LINE

Příprava oddělovací linky

OBJEKT.INP_LINE()

Metodou je vložena do vstupního formuláře oddělovací linka.

INP_READ

Aktivace vstupního formuláře

OBJEKT.INP_READ()

Metoda zahajuje vstup formuláře s prvky určenými metodami INP_CHECKBOX, INP_COMBOBOX, INP_OPTIONGROUP, INP_LABEL a INP_LINE.

Vrací logickou hodnotu TRUE při ukončení formuláře tlačítkem ‚OK‘ nebo jeho uzavření tlačítkem ‚x‘ v nadpisu formuláře.

Vrací logickou hodnotu FALSE při ukončení formuláře tlačítkem ‚Storno‘ nebo klávesou ESC.

Příklad použití objektu třídy KU_INPUT:

DECLARE p1,p2,p3

DECLARE OBJECT rd

SET rd=CREATE('KU_INPUT')

rd.INP_FORMCAPTION('Název formuláře')

rd.INP_CHECKBOX('p1','Zaškrtnutí')

rd.INP_LINE()

rd.INP_COMBOBOX('p2','Volba 1,Volba 2,Volba 3,Volba 4',3,'Návěští')

rd.INP_LINE()

rd.INP_LABEL('Návěští')

rd.INP_OPTIONGROUP('p3','Přepínač 1, Přepínač 2, Přepínač 3',2)

IF NOT rd.INP_READ()

* zde by obvykle následoval příkaz CANCEL

ERROR 'Uživatel stiskl ESC'

ELSE

* zde by obvykle následoval kód vyhodnocení hodnot proměnných p1,p2,p3

ERROR 'Zjištěné hodnoty P1='+LTRIM(STR(p1))+;

', P2='+LTRIM(STR(p2))+;

', P3='+LTRIM(STR(p3))

ENDIF

KU_MAIL - Třída objektů pro odesílání MAIL

Metoda

Popis

SET_RECIPADRESS

Nastavení adresy příjemce

OBJEKT. SET_RECIPADRESS(‘Adresa‘)

Je možné přímo předat objektu jednu nebo více adres oddělených středníkem nebo určit adresáta na jeho E-MAILovou adresu(y) má být zpráva odeslána (v tom případě musí adresa začínat znakem ‘*‘)

SET_SUBJECT

Nastavení předmětu zprávy

OBJEKT. SET_SUBJECT(‘text‘)

SET_MESSAGETEXT

Nastavení popisu zprávy

OBJEKT.SET_MESSAGETEXT (‘text‘)

SET_FILE

Připojení souboru(ů)

OBJEKT. SET_FILE (‘Seznam souborů‘)

Seznam souborů je seznam dvojic identifikace + popis souboru oddělených středníkem (popis souboru by měl mít uvedenu příponu)

Např.:

‘soubor1.txt;Seznam uživatelů.txt;dokumentx.doc;Přehled.doc‘

znamená, že do MAIL bude přenesen soubor1.txt, který bude v MAIL vystupovat jako Seznam uživatelů.txt a soubor dokumentx.doc, který bude v MAIL vystupovat jako Přehled.doc.

Popis souboru není povinný.

SET_PROMPT

Nastavení možnosti úpravy MAIL

OBJEKT.SET_PROMPT(0/1)

Při uvedení hodnoty parametru metody 1 (přednastavená hodnota) bude možné výstupní MAIL před odesláním upravit.

SEND_MAIL

Odeslání MAIL

OBJEKT. SEND_MAIL()

Odeslání MAIL musí předcházet některá z předcházejících metod.

Není-li metoda SEND_MAIL v kódu po ukončení užita, bude MAIL odeslán v rámci transakce ukončení operace.

Po provedení SEND_MAIL se automaticky provádí RESET_MAIL.

V souvislosti s odesíláním je možné nastavit jméno profilu v souboru BW.INI nebo lokálně v BWLCL.INI parametrem ‚mail_profile‘ v sekci ‚Preferences‘ např.:

mail_profile=Nastavení MS Exchange

RESET_MAIL

Vynulování stavu objektu

OBJEKT. RESET_MAIL()

Nuluje nastavení vlastností MAIL, pro odeslání dalšího MAIL bude třeba nastavit některou jeho vlastnost.

Příklad použití objektu třídy KU_MAIL:

DECLARE OBJECT mail

SET mail=CREATE('KU_MAIL')

mail.SET_RECIPADRESS(‘bmservis@bmservis.cz‘)

mail.SET_SUBJECT(‘Pozdrav‘)

mail.SET_MESSAGETEXT(‘Nazdar‘+CHR(13)+tool.jmeno)

IF NOT mail.SEND_MAIL()

CANCEL

ENDIF

Novinky:

17.01.2003

V kódu po ukončení operace je možné přidat skript v jazyce FOXPRO.

Skript musí být uveden příkazem ".SCRIPT" a ukončen příkazem ".ENDSCRIPT".

V okamžiku běhu skriptu je v proměnné _THIS odkaz na objekt řídící zpracovnání kódu po ukončení operace a v proměnné _THIS_SPRAVCE odkaz na objekt řídící transformace.

V kódu skriptu je možné použít metodu ADDACTION pro modifikaci diagramu ve tvaru:

_THIS.addaction(<<akce>>,<<druh>>[,<<komponenta>>]).

Např.:

_this.addaction('ACTIVATE','operace','OBC')

_this.addaction('DELETE','proces')

Kód skriptu musí vracet logickou hodnotu.

V případě, že vrátí logickou hodnotu FALSE, zpracování kódu po ukončení bude přerušeno a operace nebude ukončena.

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 19.01.2015


SYSDIA - knihovna

Knihovna SYSDIA slouží ke komunikaci uživatele se systémem pomocí zadávaných hodnot. Dále je zde vybudována podpora pro vstup údajů ze seznamu dat databáze jako překryvného seznamu (ComboBox) a speciální podpora pro vstup druhu artiklu a artiklu jako překryvného seznamu (ComboBoxu).

Viz.také:

SYSDIA - příklady, Třída - BM_CODE_SYSDIA, Třída - SP60ID_COMBOBOX, Třída - SP61ID_COMBOBOX, Třída - SYSDIA_COMBOBOX, Třída - SYSDIA_POM_FORM_F2, Třída - SYSDIA_TEXTBOXF2

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Informační panel - platby

Informační panel – „pohledávky dle adresátů“

Informační panel „pohledávky dle adresátů“ poskytuje uživateli komfortní a uživatelsky „přítulný“ přehled jednotlivých pohledávek řazený dle adresátů a členěný dle dnů po splatnosti. Přehled lze zobrazit k aktuálnímu datu či libovolnému datu dle zadání uživatele, současně může uživatel zvolit zobrazení jen určité podmnožiny pohledávek (např. za středisko, zakázky apod.). Pohledávky lze analyzovat detailním pohledem anebo naopak sumárním pohledem v časové řadě.

Po prvním spuštění tohoto panelu se uživateli zobrazí přehled pohledávek adresátů k aktuálnímu datu (v našem případě je to na obr.1 datum 31.5.2007). Pro vysvětlení uživateli není směrodatné, z jakého data jsou obrázky, pro pochopení problematiky tohoto IP jsou naprosto dostačující. Implicitní setřídění pohledávek je dle neuhrazené částky celkem k aktuálnímu datu. Aktuálním datem na informačním panelu rozumíme datum, ke kterému je vždy zobrazen výběr pohledávek a je viditelné na horní liště (tučně zvýrazněno). Podle toho, jaké si uživatel vybere datum do výběru (to se pak stává aktuálním) se mění přehled adresátů a hodnota pohledávek.

Nyní si stručně popíšeme rozvržení jednotlivých informací na formuláři. Adresáti a jejich pohledávky jsou setříděni podle hodnoty ve sloupci „neuhrazeno“. Jednoduchým překliknutím na jiný sloupec (např. „splatné 30“) se zároveň změní třídění adresátů (pomocí tlačítka „Zpět“ v horní liště se uživatel vrátí k původnímu setřídění).

U každého adresáta je k dispozici informace o celkové částce „neuhrazeno“. Je to celková suma všech pohledávek, které jsou dosud neuhrazené k aktuálnímu datu (opět je zde nutno zdůraznit, že aktuální datum je datum uvedené v horní liště, nikoliv dnešní datum). Sloupec „z toho splatné“ obsahuje pohledávky, jejichž datum splatnosti je již aktuální. Sloupce „splatné 30“ a „splatné 90“ obsahují pohledávky, které jsou po splatnosti více než 30 a než 90 dnů. Sloupec „opravné položky“ poskytuje informaci o stavu vytvořených opravných položek k daným pohledávkám k aktuálnímu datu. Sloupec „vymáhání“ a „počet vymáhání“ informuje o tom, kdy proběhla poslední událost vymáhání a kolikátá již byla.

Např. na obr. 1 je dobře viditelné, že u adresáta „MKR služby s.r.o.“ proběhlo do 31.05.2007 poslední vymáhání 12.4.2007 a bylo již třetí v pořadí. Tímto jsme si krátce vysvětlili, jaké informace jsou uživateli dostupné pod jednotlivými sloupci.

(obr. 1)

Jak jsme se již zmínili výše, po prvním spuštění panelu je stav pohledávek zobrazen k aktuálnímu datu. Vedle atributu datum je atribut organizační selektor, tzn. že uživatel má možnost vybrat si pohledávky i za určitý organizační selektor nebo jeho část, viz. obrázek č. 1 (vybírat lze i podle zakázky nebo je možno definovat jiný výběrový prvek). Horní lišta formuláře poskytuje uživateli souhrnnou informaci o celkové hodnotě pohledávek v jednotlivých sloupcích za určitý selektor k aktuálnímu datu.

V případě, že uživatel chce datum stavu pohledávek změnit, přepíše ho v daném atributu a stiskne tlačítko vyhledat. Datum, ke kterému jsou platby zobrazeny je vždy viditelné v horní části formuláře (viz. obr. 2 – „stav plateb k datu 30.04.2007 p%“, přestože v atributu datum je viditelné datum, které bylo naposledy zadáváno, tj. 31.05.2007). Při změně data pak má uživatel zároveň možnost si informace ve formuláři pohodlně měnit pomocí tlačítek „před měsícem“ (stav plateb k poslednímu dni předchozího měsíce), „další měsíc“ (stav plateb k poslednímu dni následujícího měsíce), „dnes“ (stav plateb k dnešnímu datu). Návrat k původní hodnotě se vždy provede pomocí tlačítka Zpět (horní lišta formuláře).

(obr. 2)

V případě, že uživatel potřebuje mít ihned k dispozici údaje o adresátech v přehledu pohledávek, stačí klik přímo na názvu adresáta a aktivuje se činnost „adresář“ s informacemi o konkrétním adresátu.

Stiskem aktuálního data (modře zvýrazněno) v souhrnném řádku formuláře (obr. 2 - „stav plateb k datu 30.04.2007 p%“) se uživateli zobrazí informace o souhrnném stavu pohledávek v letech – viz. obr.3. Pomocí tlačítek Zpět a Vpřed se v tomto formuláři uživatel pohodlně pohybuje.

(obr. 3 – Pohledávky v čase)

Stiskem konkrétního data ve formuláři „pohledávky v čase“ se uživatel přepne do hlavní nabídky informačního panelu, kde budou hodnoty pohledávek v jednotlivých sloupcích zobrazeny právě k tomuto datu, tzn. klikne-li uživatel např. na datum 31.01.2005 (viz. obr. 3) budou pohledávky v informačním panelu zobrazeny k aktuálnímu datu 31.01.2005.

Při kliknutí na jednotlivé hodnoty pohledávek se uživateli zobrazí konkrétní operace plateb, jejichž souhrn vytváří danou hodnotu pohledávek. Např. při kliknutí na hodnotu ve sloupci „neuhrazeno“ se uživateli zobrazí přehled plateb, jejichž suma tvoří hodnotu v tomto sloupci. Na obr. 4 je názorně vidět, že u adresáta Life International a.s. je sloupec „neuhrazeno“ ve výši 219 739,60Kč (viz. obr. 1) tvořen sedmi událostmi plateb, z nichž pět jich je již po splatnosti (tučně zvýrazněno).

(obr. 4)

Kliknutím na modře zvýrazněnou identifikaci procesu se uživateli aktivuje odpovídající operace platby. Její ukončení se provede pomocí standardních funkcí IS BM. Pomocí tlačítka „Zpět“ se uživatel vrátí z informačního panelu „Platby v detailu“ do původní nabídky informačního panelu.

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.02.2015


Popis jazyka generátoru sestav

Popis jazyka generátoru sestav

Společné příkazy

Příkaz

Syntaxe

Popis

.KOMENTÁŘ

.KOMENTÁŘ

Popisný řádek

.DOKUD

.DOKUD [<seznam atributů>]

Cyklus se změnou pozice záznamu zpracovávaných dat.

Probíhá seznam příkazů až do nejbližšího příkazu ".KONEC" do té doby, dokud se nezmění alespoň jeden z atributů zadaných v seznamu.

.KONEC

.KONEC

Uzavírá seznam příkazů předcházejícího příkazu ".DOKUD".

.PŘIŘAĎ

.PŘIŘAĎ <proměnná>=<výraz>

Přiřazuje hodnotu proměnné, kterou zároveň tímto definuje.

Př.: .PŘIŘAĎ $(cislo)= $(cislo)+1

.KDYŽ

.KDYŽ <logický výraz>

Podmínka provedení následujících příkazů až do nejbližšího příkazu ".JINAK" nebo ".KONEC_KDYŽ".

Př.:

.KDYŽ $(x)=5

.PŘIŘAĎ $(cislo)= 1

.JINAK

.PŘIŘAĎ $(cislo)= 2

.KONEC_KDYŽ

.JINAK

.JINAK

Doplňuje příkaz ".KDYŽ", seznam následujících příkazů až do nejbližšího příkazu ".KONEC_KDYŽ" bude proveden při neplatnosti podmínky příkazu ".KDYŽ".

.KONEC_KDYŽ

.KONEC_KDYŽ

Ukončuje seznam prováděných příkazů za podmínky ".KDYŽ" (resp. ".JINAK")

.CYKLUS

.CYKLUS <logický výraz>

Seznam následujících příkazů až do nejbližšího příkazu ".KONEC_CYKLUS" bude prováděn do té doby, dokud platí podmínka uvedená v tomto příkazu.

Př.:

.PŘIŘAĎ $(i)=1

.CYKLUS $(i)<=10

Text $(i)

.PŘIŘAĎ $(i)= $(i)+1

.KONEC_CYKLUS

.KONEC_CYKLUS

.KONEC_CYKLUS

Ukončuje seznam prováděných příkazů v cyklu ".CYKLUS"

.DEKLARACE

.DEKLARACE <p>,<t>[,<l>[,<d>]],<v>

Deklarace proměnné, která mění svůj obsah při pohybu v datech (zejména pro použití v příkazu ".DOKUD").

<p> je název proměnné,

<t> je typ hodnoty proměnné (C,D,T,N,M)

<l> je délka hodnoty proměnné (pro typy C a N)

<d> je počet des.míst hodnoty proměnné (pro typ N)

<v> je výraz proměnné

Př.:

.DEKLARACE $(datum),D,SQL_TISK.datum

.DEKLARACE $(cislo),N,20,4,SQL_TISK.cislo

.DEKLARACE $(text),C,40,SQL_TISK.text

.CALL

.CALL <činnost>, <předloha>,<filtr>,<p1>,<p2>,<p3>

Vyvolá v průběhu výstupu jinou tiskovou předlohu.

Identifikaci předlohy a činnosti je možné zjistit ve vlastnostech předlohy na poslední záložce atribut ID:.

Např. pro identifikaci předlohy OB0101_W123456789, uvádí se příkaz .CALL ‘OB0101‘,‘W123456789‘,…..

Parametrem ‚filtr‘ může být výraz, který složí podmínku dotazu v textové formě jazyka SQL.

Parametry ‘p1‘,‘p2‘,‘p3‘ jsou volné parametry, které jsou k dispozici autorovi volané předlohy v syntaxi this.param1, this.param2 a this.param3. Jejich nejčastější využití je pro přenos názvu výstupního souboru nebo názvu výstupní záložky listu.

.SCRIPT

.SCRIPT

v předloze výstupu typu Excel a HTML je možné definovat skript v jazyce FOXPRO.

Skript musí být uveden příkazem ".SCRIPT" a ukončen příkazem ".ENDSCRIPT".

V okamžiku běhu skriptu je v proměnné _THIS odkaz na objekt řídící výstup předlohou.

Kód skriptu musí vracet logickou hodnotu.

V případě, že vrátí logickou hodnotu FALSE, zpracování výstupu ukončeno bude přerušeno.

.ENDSCRIPT

.ENDSCRIPT

Viz. SCRIPT

Metoda load_my_adress

this.load_my_adress

Metodu je možné vyvolávat ve skriptu předlohy výstupu.

Potom jsou pro výstup dostupné v objektu ADM1.AD atributy odpovídající vlastní adrese nastavené v adresáři:

ADM1.AD.ad01id, ADM1.AD.ad01adsat,

ADM1.AD.ad01unodpo, ADM1.AD.ad01adsat2, ADM1.AD.ad01ico, ADM1.AD.ad01dico,ADM1.AD.ad01koment,ADM1.AD.sp10idzak, ADM1.AD.ad01klic,

ADM1.AD.ad01rc, ADM1.AD.ad01ksymb,

ADM1.AD.ad01pladph, ADM1.AD.ad01zakljm, ADM1.AD.ad01spolec, ADM1.AD.ad01volne1, ADM1.AD.ad01volne2, ADM1.AD.ad01volne3, ADM1.AD.ad02cisads, ADM1.AD.ad58id,

ADM1.AD.ad13nsc, ADM1.AD.ad11jmeno,

ADM1.AD.ad11cislo, ADM1.AD.ad11fax,

ADM1.AD.ad11mobil, ADM1.AD.ad11email, ADM1.AD.ad11cisost, ADM1.AD.ad11pozn,

ADM1.AD.ad02ulice, ADM1.AD.ad13psc,

ADM1.AD.ad02mesto, ADM1.AD.ad05stat,

ADM1.AD.ad05nazeva, ADM1.AD.ad58naztyp, ADM1.AD.bw01jmeno, ADM1.AD.sp10text,

ADM1.AD.ad02ulice3, ADM1.AD.ad13psc3,

ADM1.AD.ad02mesto3, ADM1.AD.ad05id3,

ADM1.AD.ad05stat3

Vlastnost předlohy výstupu SKRIPT

Vlastnost předlohy výstupu SKRIPT se definuje na záložce "Deklarace" a je v ní možné definovat kód v jazyce Foxpro, který má bude prováděn před provedením dotazu SQL.

V okamžiku běhu skriptu je v proměnné _THIS odkaz na objekt řídící výstup předlohou výstupu.

Např.:

LOCAL _o

* přidání vlastnosti TEMP_DATUM1 do objektu _THIS inicializovanou aktuálním datem

_this.addproperty('temp_datum1',date())

* třída BM_CODE_SYSDIA definuje objekt pro dialog

_o=CREATEOBJECT('bm_code_sysdia')

* inicializace objektu třídy BM_CODE_SYSDIA

_o.start(_this,'Datum')

* bude vstup do vlastnosti TEMP_DATUM1 objektu _THIS

_o.addtextbox('temp_datum1')

* metoda READ zahajuje vstup formuláře a vrací FALSE při uživatelově stisku ESC

RETURN _o.read()

#INCLUDE sysdia

V předloze výstupu je potom možné odkazovat na vstoupenou proměnnou jako THIS.TEMP_DATUM1.

Odkaz v doplnění SQL dotazu ve vlastnostech předlohy však není tímto způsobem možný.

Proto jinak např.:

LOCAL _o

* vstupní informace bude uložena v objektu TOOL, ale mohla již být definována předchozím spuštěním předlohy

DO CASE

CASE TYPE('tool.temp_datum1')='U'

* dosud není vlastnost TEMP_DATUM1 objektu TOOL definována

* přidání vlastnosti TEMP_DATUM1 do objektu TOOL inicializovanou aktuálním datem

tool.addproperty('temp_datum1',date())

CASE TYPE('tool.temp_datum1')<>'D'

* vlastnost TEMP_DATUM1 je definována, ale není typu datum

tool.temp_datum1=DATE()

ENDCASE

_o=CREATEOBJECT('bm_code_sysdia')

_o.start(tool,'Datum')

* bude vstup do vlastnosti TEMP_DATUM1 objektu TOOL

_o.addtextbox('temp_datum1')

RETURN _o.read()

#INCLUDE sysdia

V předloze výstupu je potom možné odkazovat na vstoupenou proměnnou jako TOOL.TEMP_DATUM1.

V doplnění SQL dotazu ve vlastnostech předlohy bude možné odkazovat v otazníkové konvenci např.:

tabulka.datum>=?tool.temp_datum1

Příklad použití příkazu .CALL

Příklad použití příkazu .CALL v komponentě „Projektové řízení“ – výstup do Excel výběrového řízení, kdy na jednom listu budou parametry dodávky a na druhém technická specifikace předmětu projektu.

Předloha nad událostmi obchodu operace „Výběrové řízení“ na začátku vyvolá předlohu činnosti „Předmět projektu“, která vytvoří soubor Excelu s obsahem technické specifikace daného předmětu. Tento soubor potom předloha obchodu použije jako vzor pro vytvoření nového souboru Excel pro každého účastníka výběrového řízení.

V předloze činnosti „Předmět projektu“ je v kódu po vytvoření užita sekvence:

.KDYŽ this.extern

.CLOSE_EXCEL

.KONEC_KDYŽ

a

.KDYŽ this.extern

.EXCEL_OTEVŘI this.param1, 'template\vykazy.xlt'

.PŘIŘAĎ $(list)=this.param2

.JINAK

.EXCEL_OTEVŘI 'C:\TMP\KARTAP.XLS', 'template\vykazy.xlt'

.PŘIŘAĎ $(list)="Karta předmětu"

.KONEC_KDYŽ

.EXCEL_NOVÝ_LIST $(list)

Parametr this.extern nabývá logickou hodnotu TRUE v případě, že byla předloha vyvolána příkazem .CALL

V souvislosti s použitím šablony používané novými výkazy jsou dále pro doplnění hlavičky výkazu použity příkazy:

.EP xlsheet.Shapes('nadpis').textframe.Characters.Text='Karta předmětu'

.EP xlsheet.Shapes('nadpis').textframe.autosize=.T.

.EP xlsheet.Shapes('autor').textframe.Characters.Text=ALLTRIM(tool.jmeno)+

' '+TTOC(DATETIME())

.EP xlsheet.Shapes('autor').textframe.autosize=.T.

Výstup do EXCELU

Příkaz

Syntaxe

Popis

.EXCEL

.EXCEL

Popisuje, že definice je určena k výstupu do EXCELU.

Musí být uveden na prvním řádku definice.

.EXCEL_NEUKLÁDAT

.EXCEL_NEUKLÁDAT

Soubor bude po ukončení prohlížení v EXCELU zrušen.

.EXCEL_OTEVŘI

.EXCEL_OTEVŘI <soubor>,<template>

Otevře soubor uvedený v příkazu kopií ze souboru "template". Uvedené parametry jsou výrazy, vyhodnocované při zpracování předlohy (tj. názvy mohou být odvozeny z dat)

Př.:

.EXCEL_OTEVŘI "VYSTUP.XLS","C:\ZDROJ.XLS"

Je-li v parametru „template“ uvedena šablona Excelu (přípona XLT), potom výstupní soubor není přepsán, ale listy vytvářené příkazem EXCEL_LIST budou vytvářeny podle dané šablony.

.EXCEL_LIST

.EXCEL_LIST <název>

Přepne na zpracování listu uvedeného v parametru.

Není-li list v aktuálním otevřeném souboru EXCELU obsažen, je založen nový list.

Př.:

.PŘIŘAĎ $(list)='Název listu'

.EXCEL_LIST $(list)

nebo

.EXCEL_LIST 'Název listu'

.EXCEL_NOVÝ_LIST

.EXCEL_NOVÝ_LIST <název>

Vytvoří nový list podle zadaného parametru. Funguje stejně jako příkaz EXCEL_LIST, s tím rozdílem, že pokud list s daným jménem existuje, bude před vytvořením nového listu zrušen (vhodné pro odstranění formátování předchozího výstupu)

.EXCEL_CLEAR_SHEET

.EXCEL_CLEAR_SHEET

Vymaže obsah aktuálního listu.

.EXCEL_VYHLEDEJ

.EXCEL_VYHLEDEJ <výraz>

Vyhledá v datech záznam odpovídající výrazu (např. pro účel odvození jména výstupního XLS souboru podle variabilního symbolu při tisku faktury)

.EXCEL_NÁVRAT_UKAZATELE

.EXCEL_NÁVRAT_UKAZATELE

Návrat na záznam pře provedením posledního příkazu ".EXCEL_VYHLEDEJ".

.EXCEL_STRANA

.EXCEL_STRANA <výraz>

Po dokončení výstupu do EXCELU bude na danou pozici vloženo odstránkování.

Je vhodnější než přímým příkazem EXCELU z důvodu rychlosti.

.EXCEL_PŘÍKAZ

.EXCEL_PŘÍKAZ <příkaz>

Provede vedený příkaz.

.EP

.EP <příkaz>

Ekvivalent příkazu ".EXCEL_PŘÍKAZ"

Metoda EX_COLUMN

…this.ex_column(5)..

Metoda vrací znakovou identifikaci sloupce např.:

xlsheet.Columns('A:'+this.ex_column($(se))).autofit

Metoda EX_CELL

…this.ex_cell(5,3)..

Metoda vrací znakovou identifikaci buňky např.:

xlsheet.range(this.ex_cell(4,$(r)+1)).SELECT

Metoda EX_RANGE

this.ex_range(5,3,7,4)

Metoda vrací znakovou identifikaci oblasti např.:

xlsheet.range(this.ex_range(1,$(r),$(se),$(r))).WrapText = .T.

Výstup do EXCELU pracuje s objekty XLAPP (odpovídá objektu Application), XLWB (odpovídá objektu Workbook) a XLSHEET (odpovídá objektu Worksheet).

Příkazem v předloze ".EXCEL_PŘÍKAZ" je možné volat metody, číst a měnit vlastnosti těchto objektů.

Tabulka příkladů práce s objekty EXCELU

Příklad | Popis
.prirad $(row)=xlsheet.range('r_start').row | Zjištění řádku pojmenované buňky listu.
.prirad $(col)=xlsheet.range('c_start'). Column | Zjištění sloupce pojmenované buňky listu.
.EP xlsheet.range('součet').value=$(a)+$(b) | Vložení hodnoty do pojmenované buňky listu.
.EP xlsheet.cells[$(row),$(col)].value=$(a)+$(b) | Vložení hodnoty do buňky v pozicích $(row) a $(col).
.EP xlsheet.range('A'+ LTRIM(STR($(row)))+':'+CHR(ASC('A')-1+$(col_posledni))+LTRIM(STR($(row)))).Borders(1).LineStyle = 1 | Levé ohraničení buněk od prvního sloupce do sloupce jehož číslo je uloženo v proměnné $(col_posledni) tenkou čarou. Parametr Borders : 1 = levý, 2 = pravý, 3 = horní, 4 = dolní
.EP xlsheet.range('A'+LTRIM(STR($(r)))+ ':'+CHR(ASC('A')-1+$(col_posledni))+LTRIM(STR($(r)))).Borders(3).Weight = 3 | Určení ohraničení buněk od prvního sloupce do sloupce jehož číslo je uloženo v proměnné $(col_posledni) tlustou čarou
.prirad $(pom)='=SUM(R['+LTRIM(STR($(r_od)-$(r)))+']C:R[-1]C)' .EP xlsheet.cells[$(r),$(c_pokladna)].FormulaR1C1=$(pom) .EP xlsheet.cells[$(r),$(c_banka)].FormulaR1C1=$(pom) | Relativní adresování R1C1 pro sumu řádků ve sloupci.
.EP xlsheet.cells[$(row),$(col)].Formula='=A1+A2' | Definování výpočtové buňky v přímém adresování
.EP xlsheet.rows($(row)).hidden=.T. | Skrytí řádky
.EP xlsheet.Columns.($(col)).hidden=.T. | Skrytí sloupce
.EP xlsheet.range('c_datum').columnWidth=200 | Změna šířky sloupce pojmenované buňky
.EP xlsheet.range('A1').columnWidth=100 | Změna šířky sloupce 1
.EP xlsheet.range("A"+LTRIM(STR($(r)))).RowHeight=20 | Změna výšky řádky.
.EP xlsheet.range("A1").SELECT | Nastavení na buňku A1 (např. po ukončení výstupu)
.EP xlsheet.cells[$(row),$(col)].font.bold=.T. | Nastavení tučného textu v buňce (podobně "italic").
.EP xlsheet.Shapes("nodberatel").textframe.Characters.Text='Abnehmer' | Změna textu pojmenovaného textframe v listu.
.EP xlsheet.range("A1:A10").copy .EP xlsheet.range("A"+LTRIM(STR($(row)))).SELECT .EP xlsheet.Paste | Kopírování oblasti A1:A10 do oblasti podle proměnné $(row).
.EP xlsheet.range("A"+LTRIM(STR($(r)))+":A"+LTRIM(STR($(r)+1))).EntireRow.Insert | Vsunutí dvou řádků
.EP xlsheet.range("A"+LTRIM(STR($(r2)))).EntireRow.delete | Odstranění řádky
.EP xlsheet.cells[$(row),$(col)].NumberFormat='##0' | Definování numerického formátu buňky.
.EP xlsheet.cells[$(r),$(c)].NumberFormat='#,##0.00 "'+ALLTRIM($(OBUDAL_oc01id2))+'"' | Definování numerického formátu buňky s měnou.
.EP xlsheet.HPageBreaks.Add(xlsheet.Range("A"+LTRIM(STR($(r))))) | Vložení odstránkování (lépe je z důvodu rychlosti použít ".excel_strana $(r)")
.EP xlsheet.Protect(, .T., .T., .T.) | Zablokování listu pro opravy
.EP xlsheet.UnProtect | Odblokování listu pro opravy
.prirad $(list_vse)='Peněžní deník' .prirad $(list_den)='Denní součty' . . .excel_list $(list_den) .prirad $(pom)=[=']+$(list_vse)+['!] .prirad $(i)=$(od) .cyklus $(i)<=$(do) .EP xlsheet.cells[$(rd),$(i)].value=$(pom)+CHR(ASC('A')-1+$(i))+LTRIM(STR($(r))) .prirad $(i)=$(i)+1 .konec_cyklus .excel_list $(list_vse) | Příklad převodu součtových hodnot z listu na list.
.komentar deklarace pole použité v prostředí FOXPRO .EP LOCAL ARRAY _var1[50] .prirad $(c_pokladna)=xlsheet.range('c_pokladna').column .prirad $(c_banka)=xlsheet.range('c_banka').column .komentar vynulování obsahu pole .EP _var1=0 .DOKUD $(UCDENIK_sp33cisdr),$(UCDENIK_sp33cisdpm),$(UCDENIK_sp33cisd) .komentar naplnění obsahu pole podle účetního dokladu .prirad $(castka)=$(UCDENIK_uc02castka)*IIF($(UCDENIK_uc02strana)=1,1,-1) .když SUBSTR($(UCDENIK_uc01id),1,3)='211' .EP _var1[$(c_pokladna)]=_var1[$(c_pokladna)]+$(castka) .konec_když .když SUBSTR($(UCDENIK_uc01id),1,3)='221' .EP _var1[$(c_banka)]=_var1[$(c_banka)]+$(castka) .konec_když . .KONEC .prirad $(i)=$(od) .cyklus $(i)<=$(do) .když _var1[$(i)]<>0 .EP xlsheet.cells[$(r),$(i)].value=_var1[$(i)] .konec_kdyz .prirad $(i)=$(i)+1 .konec_cyklus | Příklad použití pole v souvislosti s příkazem ".CYKLUS"
.EP xlsheet.range("D2").SELECT .EP XLapp.ActiveWindow.FreezePanes=.T. | Od buňky D2 výše jsou zmrazeny posuvy těchto řádků a sloupců
.EP xlsheet.range(“A1”).WrapText=.T. | V buňce A1 je zalamován text
.EP xlsheet.PageSetup.Orientation=2 | Orientace výstupu pro tisk
.EP Xlapp.ActiveWindow.WindowState=2 | Maximalizuje okno dokumentu
.EP xlsheet.range(“A1:C2”).MergeCells=.T | Sloučení buňek A1 až C2
.EP xlsheet.range[2,8].HorizontalAlignment=3 | Zarovnání textu na střed
.EP xlsheet.Columns(“E:E“).EntireColumn.Autofit | Sloupec E bude mít dynamickou šířku
.EP xlsheet.cells[2,2].value=IIF(TYPE(‘this.otec.obec_vyber.p[1]’)=’D’,this.otec.obec_vyber.p[1],{}) | Do buňky B2 je vložena hodnota prvního parametru z obecného výběru formuláře, současně je provedena i kontrola na typ

Výstup do HTML

Příkaz | Syntaxe | Popis
.HTML | .HTML soubor | Definuje název výstupního souboru. Např.: .HTML C:\KTL\KATALOG.HTM
.OTEVŘI | .OTEVŘI [<název>] | Otevře výstup do HTML souboru. Není-li parametr uveden, otevře opakovaně soubor uvedený v příkazu ".HTML". Při uvedeném parametru je případný existující soubor přepsán. Např.: .OTEVŘI "C:\KTL\"+ALLTRIM(OBARTIKL_sp60id)+'.HTM'
.OTEVŘI_ZNOVU | .OTEVŘI_ZNOVU <název> | Otevře opakovaně soubor, tj. výstupy budou zapisovány za konec tohoto existujícího souboru.

MAIL výstupu předloh

Příkazy pro Mail výstupních dokumentů se uplatňují při výstupu do Excel (typ 2) a výstupu do HTML.

Technické podmínky – instalovaná pošta kompatibilní s MS MAPI a nainstalován prvek AktiveX MSMAPI32.OCX.

Mail je odeslán příkazem MAIL_SEND, při výstupu do HTML okamžitě, je-li výstupní soubor uzavřen příkazem UZAVŘI , při výstupu do EXCEL okamžitě, je-li výstupní soubor uzavřen příkazem EXCEL_CLOSE, jinak po ukončení práce uživatele se souborem v EXCELU.

Po úspěšném odeslání MAIL je původní výstupní soubor zrušen.

Byl-li v průběhu výstupu do HTML odeslán alespoň jeden mail, nebude browser spuštěn po ukončení výstupní předlohy.

Příkaz

Syntaxe

Popis

.MAIL_RECIPADRESS

MAIL_RECIPADRESS ‘adresa(y)’

Určuje adresu příjemce je možné zadávat seznam adres oddělených středníkem např. ‘a.@telecom.cz; b.@telecom.cz;‘

Nebo je možné určit atribut ve výstupním souboru (uvedený znakem ‘*‘), který odpovídá identifikaci adresáta např. ‘*OBUDAL_ad01id‘. V tom případě bude MAIL odeslán na všechny e-mailové adresy adresátů obsažených ve výstupu.

Nebo je možné určit identifikaci adresáta (uvedenou znakem ‘*‘), kterému má být mail odeslán

např. ‘*‘+SQL_TISK.OBUDAL_ad01id. V tom případě bude MAIL odeslán na všechny e-mailové adresy daného adresáta.

.MAIL_SUBJECT

MAIL_SUBJECT ‘text‘

Předmět zprávy např. ‘Faktura za dodání‘

.MAIL_MESSAGETEXT

MAIL_MESSAGETEXT ‘text‘

Popisná část zprávy např. ‘Fakturujeme Vám ‘+SQL_TISK.OBUDAL_ob02text+CHR(13)+‘Těšíme se na další spolupráci‘+CHR(13)+‘Fakturoval:‘+tool.jmeno

.MAIL_FILE

MAIL_FILE ‘soubor‘

Nastavení souboru spojeného s mailem na jiný než je soubor vytvářený předlohou. Při uvedení prázdného řetězce nebude s mailem spojen žádný soubor.

.MAIL_BM_FILE

MAIL_BM_FILE cid[,typ]

Nastavení souboru spojeného s mailem na soubor(y) uložený v BM. Při neuvedení parametru TYP se předpokládá, že v parametru CID je uvedena jednoznačná časová identifikace dokumentu. Uvedený parametr TYP znamená výstup dokumentů spojených s objektem typu daného tímto parametrem (může být ‘%‘).

Při použití tohoto příkazu je třeba použít příkaz MAIL_SEND s parametrem 2 nebo 3.

Dále viz. Příklad

.MAIL_SEND

MAIL_SEND 0/1/2/3

Odeslání mailu s uvedeným parametrem 0 nebo 2 bez možnosti jeho dotvoření v editoru. Při užití parametru 1 nebo 3 bude mail možné dotvořit v editoru mailu.

Užití parametru 2 nebo 3 způsobí, že spojený soubor nebude po odeslání zrušen.

V souvislosti s odesíláním je možné nastavit jméno profilu v souboru BW.INI nebo lokálně v BWLCL.INI parametrem ‚mail_profile‘ v sekci ‚Preferences‘ např.:

mail_profile=Nastavení MS Exchange

.EXCEL_CLOSE

EXCEL_CLOSE

Doplňující příkaz pro EXCEL určený pro použití s MAIL. Při jeho uvedení bude po vytvoření soubor v EXCEL uzavřen a MAIL bude možné přímo odeslat.

.UZAVŘI

UZAVŘI

Doplňující příkaz pro výstup do HTML určený pro použití s MAIL. Při jeho uvedení bude po vytvoření výstupní soubor uzavřen a MAIL bude možné přímo odeslat.

Příklad

.HTML temp.htm

.MAIL_FILE ''

.MAIL_BM_FILE sql_tisk.vy01,‘%‘

.MAIL_RECIPADRESS '*'+$(Vyudalos_ad01id)

.MAIL_SUBJECT $(Vyudalos_vy01text)

.MAIL_MESSAGETEXT $(Vyudalos_vy01koment)

.MAIL_SEND 3

© 2002,2003 BM Servis České Budějovice.Všechna práva vyhrazena.

Filip Petr - 18.02.2005


Popis programu EVIVYK

PROGRAM EVIVYK.EXE

Tento dokument seznámí uživatele s jednou z možností zadávání plnění úkolů v projektovém řízení pomocí vytvořeného programu EVIVYK.EXE.

Základním předpokladem pro fungování tohoto programu je:

- IS BM obsahuje komponentu 'Projektové řízení'

- verze BM.EXE je s datem generování po 27.1.2010

EVIVYK.EXE je distribuován v souboru BM.ZIP (jeho adresář \BMSQL\EVIVYK).

Celý tento adresář by měl být umístěn v podadresáři adresáře uložení BM.EXE. Informace zobrazované programem EVIVYK.EXE je možné nastavit kódem 'knihovny vkládaného kódu' s identifikací EVIVYK. V každém případě je třeba tuto knihovnu založit a v jejím kódu nastavit atribut SP07IDTYPD.

Po spuštění tohoto programu (ať už výběrem a aktivací souboru evivyk.exe na určeném místě v PC nebo automatickým spuštěním po startu po přihlášení do IS BM) se uživateli jako první aktivuje přihlášení k tomuto programu, kde je předplněno jméno uživatele a uživatel zapíše pouze své heslo (heslo je totožné s heslem do IS BM).

Po přihlášení se uživateli zobrazí přehled projektových úkolů, ze kterých si uživatel zvolí ten, jehož se jeho plnění týká. Přitom zůstává na horní liště tohoto formuláře vysvícena možnost „Nové plnění úkolu“. Po výběru úkolu (dvojklik pravého tlačítka myši) uživatel zadává další atributy.

Stiskem ikonky „křížek“ v ovládací liště daného formuláře se tento program minimalizuje na dolní lištu počítače (ikonka bílé obálky) a je kdykoliv připraven k použití. Stačí pak pouze stiskem znovu aktivovat a zadat nové plnění úkolu.

Uživateli se po výběru projektového úkolu zobrazí následující formulář. Ten je konstantně umístěn v pravé dolní části obrazovky (velikost a místo umístění měnit nelze, pouze maximalizovat). Uživatel zde má v horní liště předplněn zvolený projektový úkol a dále je předplněn atribut datum aktuálním datem. Další údaje na druhém řádku formuláře jsou kromě data a času ikony:

¨ ikona hodiny – tj. časovač – měří čas daného úkolu, tzn. při výběru projektového úkolu a následném stisku ikonky časovač systém automaticky měří čas, který uživatel na daném úkolu strávil.

¨ popis úkolu – uživateli se po stisku této ikonky zobrazí popis, který je zapsán u zadání projektového úkolu

¨ odstranit plnění úkolu – tuto ikonku uživatel využije v okamžiku, kdy zjistí, že dané plnění nakonec vůbec nechce zapsat. Po stisku této ikonky je pak nutno ještě potvrdit tlačítko „odstranit plnění“.

Na dalším řádku se zadává krátký popis vztahující se k plnění projektového úkolu a v případě potřeby lze delší komentář zapsat v dalším atributu (viz. komentář). Další atribut, který se týká identifikace druhu plnění si uživatel vybere z překryvného seznamu. Implicitně je předplněna možnost „pracovní výkon“, další možnosti mohou být např.: „pracovní výkon – ukončení úkolu, změna stavu úkolu na připraven, čas strávený na cestě“ (nabídka těchto identifikací druhů plnění se mění v závislosti na druhu vybraného projektového úkolu).

Předchozí obrázek poskytuje uživateli pouze vzorovou možnost, jak může vypadat zadávání plnění projektových úkolů. Podle nastavení definice knihovny vkládaného kódu může uživatel při zadávání plnění ještě vstupovat např. obchodní selektor.

V případě, že si uživatel po aktivaci této činnosti vybral určitý projektový úkol a při jeho plnění zjistí, že by potřeboval daný projektový úkol změnit (např. při komunikaci se zákazníkem uživatel nejprve vybere projektový úkol typu „hotline“ a během hovoru může zjistit, že se bude jednat spíše o typ „servisní zásah“) lze projektový úkol pohodlně změnit. Toto se provede dvojklikem na modré liště s názvem projektového úkolu. Uživateli se zobrazí šedě zobrazený seznam dalších projektových úkolů daného druhu a stiskem pravého tlačítka myši na názvu tohoto úkolu je původní plnění přepsáno.

Po zadání všech atributů uživatel pak stiskne tlačítko „Zapsat plnění“ a potvrdí možnost „přepsat všechna Vaše plnění úkolů do BM“. Systém přepíše všechna zapsaná plnění do komponenty projektové řízení (nepřepíše pouze ty plnění s nevyplněným časem, když je čas u daného úkolu povinný).

Tímto způsobem tedy uživatel zadává jednotlivá plnění. Pro zadání dalšího plnění stiskne opět tlačítko „nové plnění úkolu“ a po vyplnění všech atributů tlačítko „zapsat plnění“, přičemž během plnění daného úkolu může opět změnit druh plnění (dvojklik na modré liště).

Může nastat situace, že se během doby, kdy má uživatel tento program aktivní např. změní určité zadání v knihovně vkládaného kódu a pak je nutno si tento aktivní formulář znovu obnovit. To se provede po stisku levého tlačítka myši na tlačítku „nové plnění úkolu“ pomocí Obnovit. Další z možností po stisku levého tlačítka myši je Konec aplikace.

Pro zkušenější uživatele nebo implementátory je v následující části popisu k dispozici příklad možnosti definice obsahu knihovny vkládaného kódu EVIVYK.

<pre>

* Provádí nastavení programu EVIVYK.EXE

* ve výrazech je možné pracovat s atributy:

* sp61id,sp60id,nk01verze,sp62artikl

* nk43,nk43idu,nk43porad,nk43stav,nk43datz,nk43datu,nk43text,nk43koment

* nk53id,nk53nazdru,pa13id,nk42id,nk44id,sp00datzap,sp10text

* atribut sp10text může nabývat hodnotu NULL

* atribut SP07IDTYPD - určuje druh procesu, který bude zakládán při přepisu plnění úkolů z pracovního souboru do komponenty plnění úkolů

* !!! toto je jediné povinné nastavení !!!

_this.sp07idtypd='HPXU01'

* atribut SP33CISDPM - určuje datové úložiště vzniklého procesu

_this.sp33cisdpm='01'

* atribut SQL_UKOLY_PLUS - doplňuje implicitní výběr úkolů pro založení nového plnění úkolu

_this.sql_ukoly_plus='nkukol.nk43stav in(2,3) and nkpredpr.nk01stav=4'

* atribut VYRAZ_STROM_PREDMET - mění implicitní zobrazení předmětu projektu ve stromu, ze kterého se vybírají úkoly pro založení nového plnění úkolu

_this.vyraz_strom_predmet='ALLTRIM(sp62artikl)'

* atribut VYRAZ_STROM_UKOL - mění implicitní zobrazení druhu úkolu ve stromu, ze kterého se vybírají úkoly pro založení nového plnění úkolu

TEXT TO _this.vyraz_strom_ukol noshow

ALLTRIM(nk53nazdru)+IIF((pa13id='T' AND nk53id <> 'IIS') or EMPTY(nk43text),'',' ['+allTRIM(nk43text)+']')

ENDTEXT

* atribut VYRAZ_STROM_ORDER - mění implicitní seřazení úkolů ve stromu, ze kterého se vybírají úkoly pro založení nového plnění úkolu

_this.vyraz_strom_order=[sp62artikl+IIF(pa13id='T','A','B')+nk53nazdru]

* atribut VYRAZ_NADPIS_CAPTION - mění implicitní zobrazení nadpisu plnění úkolu v seznamu rozpracovaných plnění úkolů

TEXT to _this.vyraz_nadpis_caption noshow

IIF(vykony.nk62datum=DATE(),'',

LEFT(TRANSFORM(vykony.nk62datum),IIF(YEAR(vykony.nk62datum)=YEAR(DATE()),6,20))+' ')+

TRIM(vykony.sp62artikl)+'; '+TRIM(vykony.nk53nazdru)+

IIF((vykony.pa13id='T' AND vykony.nk53id <> 'IIS') or EMPTY(vykony.nk43text),'',' ['+allTRIM(vykony.nk43text)+']')+

IIF(vykony.nk62hodin=0,'',' - '+thisform.trans_hodin(vykony.nk62hodin)+' hod.')

ENDTEXT

* atribut VYRAZ_NADPIS_ZMENA - mění implicitní zobrazení v menu úkolů zobrazovaném při změně druhu úkolu předmětu úkolu

TEXT to _this.vyraz_nadpis_zmena noshow

TRIM(sp62artikl)+'; '+TRIM(nk53nazdru)+IIF((pa13id='T' AND nk53id <> 'IIS') or EMPTY(nk43text),'',' ['+allTRIM(nk43text)+']')

ENDTEXT

* atribut VYRAZ_PODMINKA_TIMER - určuje logický výraz - je-li při založení nového plnění úkolu vyhodnocen TRUE, bude toto plnění založeno se spuštěným měřením času

_this.vyraz_podminka_timer=[sp60id='0001']

* metodou SPSEOB_ADD se stanoví to, zda bude s plněním úkolu vstupován obchodní selektor a jaké selektory se budou vstupovat

* např. pro plnění úkolů, jejichž název předmětu projektu začíná písmenem A, je povinný vstup obchodního selektoru začínajícího písmeny IPV0

_this.spseob_add([sp62artikl='A'],[sp10idzak like 'IPV0%'])

* a dále pro plnění úkolů, jejichž název předmětu projektu začíná písmenem E, je povinný vstup obchodního selektoru začínajícího písmenem E

_this.spseob_add([sp62artikl='E'],[sp10idzak like 'E%'])

* atribut TIMER_CLOSECONN.INTERVAL - uvádí čas v milisekundách, po jeho uplynutí je automaticky uzavřeno otevřené spojení s databází

_this.Timer_closeconn.interval=5000

</pre>

© 1996-2010 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 29.01.2010


Roční evidenční list důchodového pojištění a registr pojištěnců - nastavení

Tento dokument obsahuje popis nastavení ročních evidenčních listů důchodového pojištění (dále RELDP) a registru pojištěnců (dále REGPJ) v systému IS BM.

Pro správnou funkci je třeba vykonat:

· zaregistrovat se k elektronickému podávání

· instalovat balíček E-CSSZ

· doplnit další nastavení IS BM

· instalovat CAPICOM.DLL

· nainstalovat certifikáty

1. Registrace k elektronickému podávání

Informace o registraci k elektronickému podávání naleznete na adresách

http://www.cssz.cz/tiskopisy/ELDP_2004/podminky_pro_org/podminky.asp

a

http://www.cssz.cz/nemocenske/prihlasky/info_k_registracim.asp .

2. Balíček E-CSSZ

Instaluje se obvyklým způsobem činností ‚Import balíčku‘ z menu ‚SYSTÉM‘ hlavního menu programu.

3. Další nastavení BM

3.1. Předlohy dokumentů a nastavení práv

Vytvářená RELDP jsou ukládány jako běžné dokumenty BM. Protože, potom budou obsahovat osobní data, která má organizace za povinnost ze zákona chránit, je třeba vytvořit dokumentu pro vyhrazení přístupu oprávněným osobám.

Importem balíčku se založí druh dokumentu RELDP0, ke kterému je třeba nastavit práva.

Dále jsou v balíčku obsaženy předlohy dokumentu RELDP a REGPJ a spouštěné aplikace RELDP a REGPJ.

Dále je třeba nastavit přístupová práva pro druh doplňující vlastnosti MZDY, která určuje práva k funkcím spouštěné aplikace RELDP resp. REGPJ.

A to proto, že BM nedefinuje práva přístupu k předlohám dokumentu a nic proto nebrání libovolnému uživateli založit dokument s předlohou RELDP.

Nastavte právo čtení oprávněným osobám.

Rozhodněte o funkcích ‚Potvrzení přijetí dat‘ a ‚Výmaz obsahu dokumentu‘, které jsou destruktivní.

3.2. Obecné předkontace

Programy aplikace RELDP se řídí nastavením obecných předkontací.

Tato nastavení byla přenesena balíčkem a je je třeba upravit v předkontaci RELDP.

Význam

Popis významu

Hodnota

Uplatňuje se

EMAIL

E-mail

Nepovinný – E-mail doručení zprávy o zpracování

RELDP,REGPJ

RELDP1

Variabilní symbol

Není- li uveden, bere se z parametrů mezd

RELDP,REGPJ

RELDP2

Identifikace adresáta

Identifikace adresáta – vaše firma

RELDP,REGPJ

RELDP4

Uživatelský identifikátor

identifikátor přidělený po registraci na ČSSZ

RELDP,REGPJ

RELDP5

Heslo

heslo přidělené po registraci na ČSSZ

RELDP,REGPJ

RELDP6

URL portálu veřejné správy

https://bezpecne.podani.gov.cz/submission

RELDP,REGPJ

RELDP7

Identifikace podpisového klíče

Identifikace Vašeho podpisového klíče

RELDP,REGPJ

RELDP8

Povolit rušení odeslaného

1 (viz.dále)

RELDP,REGPJ

RELDP9

Úložiště šifrovacího klíče

neuvedeno nebo ‚addressbook‘

RELDP,REGPJ

RELDPA

Předplňovat - "Generovat chybu"

1 nebo 0

RELDP

RELDPD

Číslo okresu org. jednotky ČSSZ

Uplatňuje se pro REGPJ – číslo okresu Vaší OSSZ zjistíte na adrese

http://www.cssz.cz/nemocenske/prihlasky/soubory/ciselniky_pr.htm

REGPJ

RELDPE

Hodnoty pro zjištění rod.stavu

Význam atributu Rodinný stav uváděný na kartě pracovníka může být v některých implementacích změněn.

Je-li tomu tak, je třeba nastavit tento parametr textem, ve kterém znak:

pomlčka - odpovídá - neurčeno

1 - odpovídá - Svobodná/ý

2 - odpovídá - Vdaná/Ženatý

5 - odpovídá - Vdova/Vdovec

4 - odpovídá - Rozvedená/ý

Např.:

Atribut Rodinný stav byl na kartě pracovníka cizojazyčností změněn na:

-, Svobodná/ý ,Vdaná/Ženatý ,Vdova/Vdovec , Rozvedená/ý, Svobodná/ý osam., Rozvedená/ý osam., Vdova/Vdovec osam.

Potom musí být tento parametr nastaven:

-1254145

REGPJ

RELDPF

Certifikát CSSZ

Např.: DIS.CSSZ.2012

ELDP, ONZ

RELDPH

Místně příslušná OSSZ

Název místně příslušné OSSZ, nepovinný atribut, ale některé OSSZ ho vyžadují. Můžete ho tedy zadat, nebo ne.

ELDP09, ELDP11

KATMZ1

Kategorie -Cizozemský nositel poj.

Plnit hodnotou CIZPOJ

RELDP

KATMZ2

Kategorie - Trvalý pobyt v ČR

Plnit hodnotou CRPOBY

RELDP

KATMZ3

Kategorie - Místo výkonu činnosti

Plnit hodnotou MISVYK

RELDP

KATMZ4

Kategorie - Studující

Plnit hodnotou STUDEN

RELDP

KATMZ5

Kategorie - Kategorie "L"

Plnit hodnotou KATEGL

RELDP

KATMZ6

Kategorie - Registrovaný uchazeč

Plnit hodnotou REGUCH

RELDP

KATMZ7

Kategorie - statutární zástupce

Plnit hodnotou STATUT

RELDP

KATMZ8

Kategorie - Člen kolektivních orgánů právnických os

Plnit hodnotou QCLEN

RELDP, ONZ – platné od 1.1.2012

KATMZ9

Kategorie - Prokurista

Plnit hodnotou PROKU

RELDP, ONZ

KATM10

Kontaktní adresa

Plnit hodnotou ADRES2

Číselník Kategorie pracovníků, ADRES2, účel musí být Kontakt adr.

ONZ

KATM11

Jednatel, společník, …

Plnit hodnotou STATU1

Číselník Kategorie pracovníků, STATU1, účel musí být Další1

ONZ

KATM12

Jednatel, společník, …

Plnit hodnotou STATU2

První znak údaje Kód

Číselník Kategorie pracovníků, STATU2, účel musí být Další2

ELDP

Pozn.: Parametr RELDP6 musí být nastaven na https://bezpecne.podani.gov.cz/submission - pokud se v příkladech objevuje URL https://bezpecne.dev.gov.cz/submission, jedná se o URL testovacího portálu.

V nové verzi BM je možné nastavovat práva přístupu k obecným předkontacím, proto po nainstalování této verze nezapomeňte omezit práva přístupu k předkontaci RELDP.

3.3. Pracovníci v kategoriích

Programy aplikace RELDP využívají nastavení Kategorií.

V činnosti MZDY A PERSONALISTIKA – MZDY – DEFINICE – Kategorie pracovníků je nutné nastavit kategorie, které budeme chtít u některého pracovníka využít. Tento číselník je možné naplnit pomocí balíčku.

Kategorie | Název | Účel | Uplatňuje se
ADRES2 | Kontaktní adresa | Kontakt adr. | ONZ
CIZPOJ | Cizozemský nositel poj. | Cizozemský nositel pojištění | ELDP
CRPOBY | Trvalý pobyt v ČR | Trvalý pobyt v ČR | ELDP
DUSPOR | Důchodové spoření - II. pilíř | Neurčeno | Nepoužívá se
KATEGL | Kategorie "L" | Neurčeno | ELDP
MISVYK | Místo výkonu činnosti | Místo výkonu činnosti | ELDP
PROKU | Prokurista | Neurčeno | ELDP, ONZ
QCLEN | Člen kolektivních orgánů právnických os | Neurčeno | ELDP, ONZ – platné od 1.1.2012
REGUCH | Registrovaný uchazeč | Neurčeno | ELDP
STATUT | Statutární zástupce | Neurčeno | ELDP
STATU1 | Jednatel, … | Další1 | ONZ
STATU2 | Jednatel, … | Další2 | ELDP
STATUT | Statutární zástupce | Neurčeno | ELDP
STUDEN | Studující | Neurčeno | ELDP

V činnosti MZDY A PERSONALISTIKA – MZDY – Karta pracovníka – Volby – Pracovníci v kategoriích je možné ke konkrétnímu pracovníkovi nastavit Kategorii, do které patří.

3.4. Trigger

V balíčku je obsažen trigger, který zabraňuje zrušení odeslaných REDLP a REGPJ.

Tento trigger je třeba pro importu balíčku vygenerovat.

Nastavením parametru RELDP8 = 1 v obecné předkontaci REDLP je možné přechodně povolit rušení odeslaných RELDP.

3.5. Volná karta

Pro REGPJ je třeba nainstalovat (vygenerovat) volnou kartu formuláře pracovní poměry (je obsažena v balíčku).

Tuto volnou kartu je třeba pro importu balíčku vygenerovat.

3.5. Státy v adresáři

3.5.1. Kód státu pro RELDP

Pro cizince uváděné na RELDP se místo PSČ uvádí kód státu.

Uveďte v poznámce ve formuláři státy kód podle následující tabulky KOST=<kód> (např. pro Slovensko KOST=703), pro státy, které jsou uvedeny v adresách podle karet pracovníků.

Číselník států naleznete na adrese http://www.scp.cz/wwwscp/czuziv/sstaty.htm.

3.5.2. Kód státu pro REGPJ

Identifikace států vkládaných do hlášení REGPJ musí odpovídat normě CZ_GEONOM.

Pokud neodpovídá identifikace státu v BM identifikaci státu podle této normy

Uveďte v poznámce ve formuláři státy kód podle následující tabulky IDST=<id> (např. pro ČR IDST=CZ viz. http://www.cssz.cz/nemocenske/prihlasky/soubory/ciselniky_pr.htm).

4. Knihovna CAPICOM.DLL

Pokud není na počítači, ze kterého se bude provádět, nainstalována v adresáři C:\WINDOWS\SYSTEM32 (nebo C:\WINT\SYSTEM32 …) knihovna CAPICOM.DLL.

Nahrajte ji do tohoto adresáře a zaregistrujte příkazem

REGSVR32.EXE C:\WINDOWS\SYSTEM32\ CAPICOM.DLL.

5. Instalace certifikátů

Nainstalujte certifikáty:

CSSZ_CA_CERT.cer

ICA_Kval.cer

sifrovaci-certifikat.cer

verisign.cer

a certifikát pro podpis.

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Smitková Olga - 22.06.2016


Roční evidenční list důchodového pojištění a registr pojištěnců - ovládání

Tento dokument obsahuje popis ovládání ročních evidenčních listů důchodového pojištění (dále RELDP) a registru pojištěnců (dále REGPJ) v systému IS BM.

1. Založení dokumentu

RELDP a REGPJ je možné vytvořit založením nového dokumentu ručně ve formuláři dokumentů nebo z mezd z přehledu karet pracovníků.

1.1. Založení dokumentu RELDP

1.1.1. Založení RELDP ve formuláři Dokumenty

Po založení nového dokumentu s předlohou výstupu RELDP

způsobí oprava dokumentu vyvolání formuláře pro vstup parametrů výpočtu RELDP, který bude uložen v dokumentu.

Zadává se:

  • Rok zpracování
  • Pracovní poměr - Neukončený v daném roce / Ukončený v daném roce / Nerozhoduje
  • Starobní důchod – Nepřiznán v daném roce / Přiznán v daném roce / Nerozhoduje
  • Pracovník od – tj. osobní číslo pracovníka, spolu s do určuje pracovníky zařazené do RELDP
  • do - tj. osobní číslo pracovníka
  • Generovat opravná hlášení – budou generována pouze opravná hlášení
  • Generovat chybu – v RELDP bude vytvořena záměrná chyba

Výpočet je možné přerušit a dokument není vytvořen, stejně jako pokud je zjištěna chyba v datech kontrolami, které v sobě obsahuje.

Výpočet je možné provádět pouze s prázdnými dokumenty, jejichž datum a čas založení odpovídá aktuálnímu datu.

1.1.2. Založení RELDP nad kartou pracovníka

Ve formuláři Karta pracovníka je možné vytvářet RELDP pro aktuálně zobrazeného nebo označené pracovníky.

Následuje dotaz na parametry výpočtu s parametry popsanými v předchozí kapitole, chybí zde výběr pracovníku od-do a je zde možné zaškrtnout možnost vytváření pro označené pracovníky a upravit název dokumentu, který bude výpočtem vytvořen.

Vytváří se dokument druhu RELDP0 s předlohou RELDP.

Výpočet je možné přerušit a dokument není vytvořen, stejně jako pokud je zjištěna chyba v datech kontrolami, které v sobě obsahuje.

Při výpočtu se vytváří objektové vazby, mezi dokumentem a kartou pracovníka s mezi dokumentem a pracovním poměrem, které jsou v dokumentu obsažené.

Tato vazba se dále využívá při následných výpočtech, protože podle ní program rozpoznává, zda má pro pracovní poměr počítat pro daný rok prvotní nebo opravné RELDP.

Opakovaný výpočet pro stejný rok bez zaškrtnutého ‚Generovat opravná hlášení‘ nezahrne program tento pracovní poměr.

Při procházení karet pracovníků, je možné získat přehled o tom, v kterých RELDP jsou hlášení obsažena v okně spojených dokumentů.

1.2.1. Založení REGPJ ve formuláři Dokumenty

Po založení nového dokumentu s předlohou výstupu REGPJ

způsobí oprava dokumentu vyvolání formuláře pro vstup parametrů výpočtu REGPJ, který bude uložen v dokumentu.

Při prvém zadávání se zobrazí formulář s informací:

Dokud se tento formulář při výpočtu zobrazuje, potom se v následujícím formuláři pro vstup parametrů výpočtu předplňuje typ na „Hromadný sběr“, jinak se předplňuje typ „Běžná“.

Zadává se:

  • Dnešní datum – při uvedení jiného data než je aktuální, bude výpočet proveden, tak jako by dnes bylo uvedené datum
  • Akce – Přihláška / Odhláška
  • Typ – Běžná / Hromadný sběr / Oprava / Změna
  • Od data přijetí/ukončení – umožňuje vybrat pracovní poměry podle data přijetí do PM resp. Ukončení PM podle toho zda se jedná o přihlášku nebo odhlášku
  • Datum změny – pro typ změny je třeba zadat datum
  • Vkládat pouze změněné – při zaškrtnutí pro typ změna a oprava program vybere pouze ty, jejichž data se liší od dat naposledy odeslaných na ČSSZ
  • Pracovník od – tj. osobní číslo pracovníka, spolu s do určuje pracovníky zařazené do hlášení REGPJ
  • do - tj. osobní číslo pracovníka
  • RČ pracovníků – umožňuje zahrnout do výpočtu pracovníky, kteří mají na své kartě uvedeno/neuvedeno rodné číslo

Výpočet je možné přerušit a dokument není vytvořen, stejně jako pokud je zjištěna chyba v datech kontrolami, které v sobě obsahuje.

Výpočet je možné provádět pouze s prázdnými dokumenty, jejichž datum a čas založení odpovídá aktuálnímu datu.

1.1.2. Založení REGPJ nad kartou pracovníka

Ve formuláři Karta pracovníka je možné vytvářet REGPJ pro aktuálně zobrazeného nebo označené pracovníky.

Následuje dotaz na parametry výpočtu s parametry popsanými v předchozí kapitole, chybí zde výběr pracovníku od-do a je zde možné zaškrtnout možnost vytváření pro označené pracovníky a upravit název dokumentu, který bude výpočtem vytvořen.

Vytváří se dokument druhu RELDP0 s předlohou REGPJ.

Výpočet je možné přerušit a dokument není vytvořen, stejně jako pokud je zjištěna chyba v datech kontrolami, které v sobě obsahuje.

Při výpočtu se vytváří objektové vazby, mezi dokumentem a kartou pracovníka s mezi dokumentem a pracovním poměrem, které jsou v dokumentu obsažené.

Tato vazba se dále využívá při následných výpočtech, protože podle ní program rozpoznává, zda byla již pro pracovní poměr přihláška resp. odhláška pro REGPJ vytvořena pro typ Běžná.

Dále se při výpočtu zapisuje informace o datech naposledy odeslaných na ČSSZ pro výběr všech PM, které se změnily.

Při procházení karet pracovníků, je možné získat přehled o tom, v kterých hlášeních do REGPJ jsou obsaženi v okně spojených dokumentů.

2. Práce s vytvořeným RELDP

2.1. Výstupy

Je-li RELDP resp. REGPJ v dokumentu BM vytvořeno, způsobí editace dokumentu vyvolání formuláře s přehledem pracovníků v něm obsažených.

V jeho mřížce je možné pravým klikem na návěštích OSČ, Zaměstnanec a Rodné č. měnit setřídění.

Pravý klik na návěští sloupce označování způsobí označení/odznačení všech.

Označení se přenáší do formuláře karet pracovníků (pro jednodušší vyhledávání chyb v datech pro výpočet).

V dolní části obrazovky je možné vybírat pracovníky podle OSČ, jména nebo rodného čísla nebo určit předlohu výstupu, zaškrtnout požadavek výstupu na tiskárnu nebo výběr tisku označených.

Po pravém kliku na překryvném seznamu Předloha je možné upravovat, kopírovat nebo vytvářet vlastní předlohy výstupu.

2.1.1. Výstupy RELDP

2.1.1.1. Předloha výstupu – 1. Formulář k podpisu

Je určena pro výstup dokladu, který musí pracovník ze zákona podepsat a obdržet jednu kopii.

2.1.1.2. Předloha výstupu – 1. Informativní přehled – HTML

Vytváří přehled pro kontrolu dat.

2.1.2. Výstupy REGPJ

2.1.2.1. Předloha výstupu – 1. Přihláška k nem. poj.

2.2. Opravy

Tlačítko oprava ve formuláři pro výstup umožňuje opravit informace aktuálně zobrazeného pracovníka.

Opravovat je možné do té doby, dokud není dokument úspěšně odeslán.

Informace o změnách jsou zaznamenávány do protokolu dokumentu.

2.2.1. Oprava RELDP

2.2.2. Oprava REGPJ

3. Další funkce dokumentu

V menu Volby jsou pro dokument vytvořený odpovídající předlohou dokumentu , dostupné v podmenu AKCE DOKUMENTU další funkce.

3.1. Odeslat internetem na ČSSZ

Zahájí odeslání dokumentu.

Funkce je popsána v samostatné kapitole 4.

3.2. Validace XSD

Funkce je zavedena pouze pro RELDP.

Je dostupná v případě, že máte v adresáři \BMSQL\TEMPLATE nainstalován soubor RELDP.XSD a ve Windows nainstalován XML Parser.

Tato funkce není významná, protože zjištění chyb není úplně přesné.

3.3. XML

Zobrazí obsahu souboru ve formátu XML v internetovém prohlížeči.

3.4. Export datové věty

Provede export obsahu dokumentu ve formátu XML do souboru na disk např. pro odeslání jiným programem.

3.5. Potvrzení přijetí dat

Zapíše do protokolu dokumentu informaci, že data byla přijata na ČSSZ.

Použití je vhodné v případech:

  • dokument obsahuje pracovníky, jejichž hlášení byla odeslána mimo systém v průběhu daného roku (např. Ukončili pracovní poměr, odešli do důchodu, …)
  • dokument byl odeslán jiným programem a obdrželi jsme informační E-mail o úspěšném předání
  • dokument byl odeslán BM, ale BM nedokáže zjistit úspěšné předání a obdrželi jsme informační E-mail o úspěšném předání
  • Předali jsme dokument jiným způsobem a víme, že předání bylo úspěšné

Potvrzení způsobí zablokování dokumentu před opravou a je-li správně nainstalován správcem systému trigger pro nepovolení rušení odeslaných RELDP, způsobí nemožnost jeho zrušení.

Při pokus o jeho zrušení se objeví hlášení:

3.6. Výmaz obsahu dokumentu

Vyčistí obsah dokumentu, takže je možné znovu jeho obsah vypočítat.

Funkci používejte pouze v případě jistoty, že dokument nebyl přijato na ČSSZ.

4. Odeslání dokumentu

Provádí se akcí dokumentu Odeslat internetem na ČSSZ.

Uživatel je nejprve informován o tom, že bude podepsána datová věta, a může tlačítkem Náhled zkontrolovat co podepisuje.

Je možné, že program nedokáže dokument podepsat, protože nebude nalezen šifrovací certifikát. V tom případě stačí nastavit parametr obecné předkontace RELDP9 na hodnotu ‚addressbook‘ (různé systémy instalují tento certifikát do různých úložišť).

Po podpisu se zobrazí formulář pro odeslání, ve kterém zadá heslo přidělené pro komunikaci (může být přeplněno podle obecné předkontace RELDP).

Tlačítkem odeslat je hlášení odesláno na portál veřejné správy (PVS) a komunikace s ním je zobrazována v seznamu ve středu formuláře.

Úspěšné předání signalizuje příjem zprávy SUBMIT_RESPONSE.

Neúspěšné předání signalizuje příjem zprávy SUBMIT_ERROR.

Důvodem nepřijetí zprávy může být mj. chyba přenosu, chyba autentizace, … nebo chybný obsah hlášení, pro který hlášení neprošlo kontrolami na serveru ČSSZ.

V případě přijetí takové zprávy, zobrazuje následně program při prohlížení dokumentu chyby v mřížce a jsou zobrazeny také na výstupu předloh.

Výsledek zpracování obdrží osoba, jejíž email je evidován na PVS a volitelně osoba jejíž email je uveden v obecné předkontaci REDLP (obdrží pouze první email).

Nejčastější odezvou PVS je SUBMIT_ACKNOWLEDGEMENT, kterou PVS sděluje, že zpráva byla přijata a nebyla dosud zpracována.

Přitom je možné přenos přerušit.

Následné odeslání dokumentu způsobí tyto dotazy:

V tom případě se doporučuje zvolit tlačítko Ano a program se pokusí pokračovat v dotazování na stav podání.

Volbu Ne vyberte pouze v případě jistoty, že dokument nebyl skutečně přijat, jinak mohou být jeho data předána vícekrát.

Protože se jedná o nebezpečné rozhodnutím, bude program požadovat potvrzení tohoto Vašeho rozhodnutí.

© 1996-2007 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 29.09.2005


Typy a triky

IS Bílý Motýl

Tipy a triky

Určeno pokročilým správcům informačního systému Bílý Motýl (základní věci se zde nedočtete)

1. Tiskové předlohy (tp)

a) Obecná pravidla tp:

- přístup k atributu obecného výběru v tp - this.otec.obec_vyber.p[1]

- přístup k atributu obecného výběru v doplnění tp - ?this.obec_vyber.p[4]

- přístup k atributu obecného výběru ve skriptu deklarace tp - _this.otec.obec_vyber.p[4]

b) Informace o vlastní adrese

Metoda LOAD_MY_ADRESS vytváří pro předlohu výstupu objekt ADM1.AD, ze kterého je možné ve výstupu zobrazit vlastní adresu adresáře.

Metodu je možné vyvolávat ve skriptu předlohy výstupu např.:

*<pre>

_this.load_my_adress

*</pre>

Potom jsou pro výstup dostupné v objektu ADM1.AD atributy odpovídající vlastní adrese nastavené v adresáři:

ADM1.AD.ad01id, ADM1.AD.ad01adsat,

ADM1.AD.ad01unodpo, ADM1.AD.ad01adsat2, ADM1.AD.ad01ico, ADM1.AD.ad01dico,ADM1.AD.ad01koment,ADM1.AD.sp10idzak, ADM1.AD.ad01klic,

ADM1.AD.ad01rc, ADM1.AD.ad01ksymb,

ADM1.AD.ad01pladph, ADM1.AD.ad01zakljm, ADM1.AD.ad01spolec, ADM1.AD.ad01volne1, ADM1.AD.ad01volne2, ADM1.AD.ad01volne3, ADM1.AD.ad02cisads, ADM1.AD.ad58id,

ADM1.AD.ad13nsc, ADM1.AD.ad11jmeno,

ADM1.AD.ad11cislo, ADM1.AD.ad11fax,

ADM1.AD.ad11mobil, ADM1.AD.ad11email, ADM1.AD.ad11cisost, ADM1.AD.ad11pozn,

ADM1.AD.ad02ulice, ADM1.AD.ad13psc,

ADM1.AD.ad02mesto, ADM1.AD.ad05stat,

ADM1.AD.ad05nazeva, ADM1.AD.ad58naztyp, ADM1.AD.bw01jmeno, ADM1.AD.sp10text,

ADM1.AD.ad02ulice3, ADM1.AD.ad13psc3,

ADM1.AD.ad02mesto3, ADM1.AD.ad05id3,

ADM1.AD.ad05stat3

c) V doplněních je možné používat komentáře:

/* POVRCH */

CASE SUBSTR(VRUDOPMA.sp60id,3,1)

WHEN 'L' then 'LESKLÝ'

WHEN 'M' then 'MATNÝ'

WHEN 'B' then 'BRUS'

ELSE '???'

END as povrch,

/* JAKOST */

CASE SUBSTR(VRUDOPMA.sp60id,2,1)

WHEN 1 then '4301'

WHEN 2 then '4404'

WHEN 3 then '4571'

WHEN 4 then 'FAL'

ELSE '???'

END as jakost

d) Excel:

.EP Xlapp.ActiveWindow.WindowState=2 | Maximalizuje okno dokumentu
.EP xlsheet.range(“A1:C2”).MergeCells=.T. | Sloučení buňek A1 až C2
.EP xlsheet.range[2,8].HorizontalAlignment=3 | Zarovnání textu na střed
.EP xlsheet.Columns(“E:E“).EntireColumn.Autofit | Sloupec E bude mít dynamickou šířku
.EP xlsheet.Cells($(r),$(s)).Select .EP xlapp.Selection.EntireRow.Insert | Vložení nové řádky
.EP xlsheet.range().Interior.ColorIndex=15 | Šedá řádka
.EP xlsheet.PageSetup.PrintTitleRows‘=$9:$1’ | Řádky 1-9 se opakují při tisku na všech stránkách
.EP xlsheet.Range(‘X’).value= | V šabloně - název buňky X
.EP xlsheet.Names.Add(“nazev”,”=R40C2”) | Pojmenovat buňku
.EP xlsheet.Rows(trans($(x))+":"+trans($(y))).Select | Označení celé řádky
.EP xlsheet.range('A:A').AutoFilter (1, "=za*", 1) | Autofilter, seznam pod sipkou

e) Někdy se hodí ukládat tp na lokální disky uživatelů:

.prirad $(time)=TTOC(DATETIME(),1)

.EXCEL_OTEVŘI 'c:\BMTiskovésestavy\XXX\XXX_'+SUBSTR($(time),1,4)+'-'+SUBSTR($(time),5,2)+'-'+SUBSTR($(time),7,2)+' '+SUBSTR($(time),9,2)+'-'+SUBSTR($(time),11,2)+'.XLS', 'template\empty.xlt'

f) Dotaz při spuštění tp

V scriptu tp:

*<pre>

LOCAL _o

DO CASE

CASE TYPE('tool.temp_datod')='U'

tool.addproperty('temp_datod',1)

ENDCASE

DO CASE

CASE TYPE('tool.temp_datdo')='U'

tool.addproperty('temp_datdo',1)

ENDCASE

tool.temp_datod=date()

tool.temp_datdo=date()

_o=CREATEOBJECT('bm_code_sysdia')

_o.start(tool,'Od do')

_o.addtextbox('temp_datod')

_o.addtextbox('temp_datdo')

RETURN _o.read()

#INCLUDE sysdia

*</pre>

V doplnění pak ?tool.temp_datod

V tp pak tool.temp_datod

Pozn.

V doplnění je možné použít i hodnotu z normálního výběru na záložce formuláře, například ?thisform._ok01datum je datum z výběru událostí obecné komponenty

2. Transformace

a) Ve výrazech transformace je možné použít select:

~~tool.sql_dotaz([select ISNULL(OBU.ob05id,'') from %%%.OBUMIST OBU,

%%%.BWUZIVAT_ORGSEL VK where VK.bw01uziv=?_p1 and VK.orgsel=OBU.sp11idzak], tool.uziv)

3. DVF

a) Pokud chcete použít v dvf v dotazu seznam s předvyplněnými hodnotami (ob05text je zobrazí, ob05id je návratová hodnota):

this.frm.addcombobox('_ob05id',[~select ob05text,ob05id from BM_SERVIS.OBUMIST order by ob05id],'Umístiní obc:')

b) Příklad připojení na jinou databázi:

script

local _c

_c=sqlconnec('nazev_odbc','bm_servis','bms')

do bw_exec with _c,[select * from bm_servis.ADADSAT AD, bm_servis.ADSPOJ AJ, bm_servis.ADADR AR where ]+;

[AD.ad01id=AJ.ad01id and ad.ad11cisspo=aj.ad11cisspo and ]+;

[AD.ad01id=AR.ad01id and ar.ad02cisadr=aj.ad02cisadr],'data'

=sqldisconnect(_c)

do bw_exec with .F.,[select ad01id from bm_servis.adadsat],'data2'

select data2

index on ad01id tag ad01id

select data

set rela to ad01id into data2

delete all for !eof('data2')

use in data2

c) Vyvolání volné karty z doplňující vlastnosti formuláře

_this.aktivuj_volnstr(PADR('VYUDALOS',8),PADR('DNM_INFO',8),.t.)

nebo pokud je VK spoustena z jineho formulare:

*************************************************************************

LOCAL _o

do bw_prika with [do form SP0187 with '','',padr('SPSEOR',8),padr('POPAKC',8) NAME _p1],_o

IF VARTYPE(_o)='O' AND !ISNULL(_o)

_o.prijmy_parametr(.F.,NKHODNP.sp11idzak)

ENDIF

*************************************************************************

LOCAL _o

DO bw_prika with [Do Form vy0147 with '','','K','','' NAME _p1],_o

IF VARTYPE(_o)='O'

_o._pf_.p2.vy01text.value='test'

ENDIF

KEYBOARD '{PGDN}'

d) Příklad update množství u označených záznamů nad události obchodu

LOCAL _rc

if !bw_hlase('Q',_this.caption,'Opravdu chcete toto?')

return

endif

_this.lockscreen=.T.

select OBUDAL

_rc=iif(eof(),0,recno())

replace all ob02mn with ob02mn*1.05,;

ob02mnr with 0, ob02text with 'Prooez 5%', ob02cj01 with 0,;

dp02czazm with 0, dp02cdpzm with 0, dp02czarm with 0, dp02cdprm with 0;

for seek(_this.identifoz+padr(obudal.ob02,len(bwselect.bw27sele)),'bwselect')

if _rc<>0

go _rc

endif

_this.formshow

if !_this._edit

_this.formakce('=')

endif

_this.lockscreen=.F.

4. Masky

a) Přeplňování skladu podle artiklu:

Do validace masky napište (bw_callx volá dvf na činností MT0101 s identifikací SKLAD):

TYPE('_this')<>'O' or bw_callx('MT0101','SKLAD ',1,_this)

!!! DVF může vracet příkazem „return .T.“ nebo „return .F.“ logickou hodnotu pro vyhodnocení validace

Dvf pak může vypadat například takto:

LPARAMETERS _this

LOCAL _thisform

_thisform=_this

DO WHILE UPPER(_thisform.baseclass)<>'FORM'

_thisform=_thisform.parent

ENDDO

select MTUDA

if INLIST(SUBSTR(sp61id,2,1),'5')

replace mt04id with RIGHT(sp61id,1)+'M0000'

else

if INLIST(SUBSTR(sp61id,2,1),'6')

if RIGHT(ALLTRIM(_thisform._o_kompo_.sp07idtypd ),1)='1'

replace mt04id with 'AM0000'

endif

if RIGHT(ALLTRIM(_thisform._o_kompo_.sp07idtypd),1)='2'

replace mt04id with 'BM0000'

endif

endif

endif

b) Příklad použití dynamické masky (ve výrazu masky)

~##V tool.sql_dotaz([select ob03cj02 from %%%.OBCENIK where sp60id=?_p1], $$$.sp60id)

5. Import/Export

a) Příklad import z Excelu:

script

local _o

_o=createobject('bm_code_sysexc')

_o.start('data',;

'sp10idzak N(9) ; 1'+chr(13)+;

'sp10text C(80) ; 2'+chr(13)+;

'sp10koment C(200) ; 3', ;

'list1')

#INCLUDE sysexc

endscript

b) Příklad importu z Podnikatele, kde je vidět jak se dostanu k aktuálnímu číslu procesu, jak se požívá filter a jak se přidává řádek do již existujícího kursoru

script

public _sort

rest from c:\tmp\!\gepraces.kod addi

use c:\tmp\!\ucdenikp.dbf in 0 alias data excl

LOCAL _cis, _ad01id, _filt

_cis=tool.sql_dotaz([select
TRIM(pl02text) from PLUDA where sp33cisd=?_p1 and sp33cisdpm=?_p2 and
sp33cisdr=?_p3], _this._thisform._o_kompo_.sp33cisd,
_this._thisform._o_kompo_.sp33cisdpm, _this._thisform._o_kompo_.sp33cisdr)

_ad01id=tool.sql_dotaz([select ad01id from PLUDA where sp33cisd=?_p1 and sp33cisdpm=?_p2 and sp33cisdr=?_p3], _this._thisform._o_kompo_.sp33cisd, _this._thisform._o_kompo_.sp33cisdpm, _this._thisform._o_kompo_.sp33cisdr)

_cis=IIF(AT('*UC*',_cis)<>0,SUBSTR(_cis,AT('*UC*',_cis)+4,9))

select data

_filt='LEFT(cisdok,9)="'+_cis+'"'

set filt to &_filt.

loca for .t.

LOCAL ARRAY _p[1]

LOCAL _wrk

_wrk=bw_param('TMP')

SELECT data

=AFIELDS(_p)

COPY TO (_wrk)

USE IN data

DO bwaddatr WITH _p,"ad01id","C",6,0

CREATE CURSOR data FROM ARRAY _p

APPEND FROM (_wrk)

DO bw_workd WITH _wrk

select data

replace all ad01id with _ad01id

c) Pokud je potřeba použít proměnnou z dotazu importu jako parametr v selektu, je potřeba použít potržítko

do bw_exec with .F.,[select SUBSTR(sp61id,2,1) _sp61id,sp60id _sp60id from bm_servis.TPVYROB

where RIGHT(sp61id,1)=?_p1],'data2', _[SBU]

6. Volné karty

a)

Datumová, inicializace: ~THIS._datdo

Návratová hodnota: THIS._datdo

Formální parametr: _datum a potom použití ?_datum

z výběru formuláře:

inicializace: ~THIS._sp61id

návratová hodnota: THIS._sp61id

z obecného výběru:

inicializace: ~this.obec_vyber.p[1]

návratová hodnota: this.obec_vyber.p[1]

b) Příklad složitějšího pohledu pro inspiraci

select isnull((select ob03cj02 from %%%.OBCENIK where sp60id=?_sp60id and sp61id=?_sp61id and ob11id='001' and ob12id='000'),0) prodej,

isnull((select (mt03cena/mt03mn) from %%%.MTMNP where sp60id=?_sp60id and sp61id=?_sp61id and mt04id=?_ob05id),0) sklad,

isnull((select ob03cj02 from %%%.OBCENIK where sp60id=?_sp60id and sp61id=?_sp61id and ob11id='101' and ob12id='000'),0) nakup,

isnull((select sp59podil from %%%.SPMJP where sp60id=?_sp60id and sp61id=?_sp61id and sp24idmj='m ' and sp24idmj2='kg '),0) metry,

(prodej-(sklad*1.15))*100/prodej sleva15,

(prodej-(sklad*1.05))*100/prodej sleva5,

(prodej-(sklad*1.10))*100/prodej sleva10,

(prodej-(sklad*1.20))*100/prodej sleva20,

prodej*metry cena_za_metr

c) Příklady v definování atributů volné karty

Atribut Zobrazení pro třídu Překryvný seznam a typ znakový

Je možné zadat SQL dotaz uvedený znaky *~

Dotaz musí vracet dva sloupce. První sloupec určuje text zobrazovaný v překryvném seznamu a druhý hodnotu předávanou na volnou kartu.

Napo. SQL dotaz pro překryvný seznam se seznamem uživatelů

*~select (if bw01aktiv=1 then '' else '* ' endif)+bw01jmeno,bw01uziv from %%%.bwuzivat where bw01uziv<>'$SYSTE' order by bw01aktiv desc,bw01jmeno

Atribut Inicializace

muže obsahovat výraz uvedený znakem #

např.: #tool.uziv pro inicializaci hodnoty volné karty identifikací aktuálního uživatele systému.

© 2002,2003 BM Servis České Budějovice.Všechna práva vyhrazena.

Kukla Petr - 09.12.2005


Přístup do IS BM přes WEB

O B S A H

1. Přehled adresátů. 4

1.1 Detail adresáta. 4

1.2 Založit nového adresáta. 5

2. Přehled adres. 6

2.1 Založit novou adresu. 6

3. Přehled spojení 6

3.1 Založení nového spojení 7

4. Vývěska. 7

4.1 Nový záznam vývěsky. 8

5. Kategorie adresátů a spojení 8

5.1 Nové přiřazení kategorie. 8

6. Oceněné příležitosti 9

Přístup do IS BM přes webové rozhraní byl speciálně vytvořen pro dealery a partnery společnosti BM Servis s.r.o.

Před vlastním přihlášením na web je nejprve nutné si nastavit v IS BM parametr „PasswordHashAlgorithm“ (menu Systém – Nastavení programu BM). Doporučujeme stejné nastavení jako na uvedeném obrázku.

Následně je nutno ještě provést změnu přihlašovacího hesla do IS BM, proto aby se zaktualizovalo hash heslo uživatele (hash heslo znamená v podstatě otisk zadaného hesla). Je možno si zvolit nové heslo a při dalším klasickém přihlášení do IS BM si heslo znovu přepsat na původní a nebo je možno po aktivaci tlačítka „změna hesla“ (v přihlašovacím okně) jen své původní heslo napsat i do potvrzení nového hesla.

Po těchto prvních techničtějších krůčcích (provedou se pouze jednou před prvním přihlášením) už lze přistoupit k vlastnímu přihlášení do IS BM přes webové rozhraní.

Po aktivaci internetového prohlížeče (Explorer, Google Chrome, Firefox apod.) je nutno zadat adresu:

https:/is.bm.cz:8443

Po její aktivaci je uživatel vyzván k zadání přístupového hesla (viz. obrázek). Jméno i heslo je shodné s přístupovým jménem a heslem do informačního systému BM.

Po zadání hesla se spustí IS BM v činnosti Přehled adresátů. Název každé činnosti, kde se uživatel právě nachází je viditelný v modře zvýrazněné liště a nebo v levé části menu (aktivní činnost je zvýrazněna tučným písmem). Každý z dealerů či partnerů IS BM má v Přehledu adresátů dostupné pouze „své“ adresáty. Toho je docíleno pomocí skrytého filtrování přes směrovací číslo a nastavení obecné předkontace „Adresát – DI – oblast“.

Popíšeme si chování IS BM přes webové rozhraní na této první obrazovce, jeho chování je v každé další činnosti stejné nebo případně hodně podobné:

¨ v levé části obrazovky je k dispozici jednoduché menu, ze kterého je možno spouštět jednotlivé dostupné činnosti

¨ nad horní lištou s názvem činnosti je vždy pro uživatele k dispozici informace o místě v IS BM, kde se uživatel právě nachází (např. při kliku na název adresáta na této první obrazovce je nahoře informace (Hlavní stránka – Adresář – Přehled adresátů – Detail adresáta)

¨ v horní části obrazovky je vpravo nahoře ve žlutém políčku ikonka „křížek“, ta umožňuje roztažení dat na celou obrazovku. Jeho opětovným stiskem se uživatel vrátí do původního zobrazení (není dostupné ve všech činnostech, pouze tam, kde je to technicky možné)

¨ pokud to systém v daném okamžiku povoluje, může být vedle této ikony ještě dostupné tlačítko plus. To umožňuje zadat nový záznam k dané činnosti (návrat zpět je pomocí šipky zpět – klasické ovládání Windows)

¨ stiskem na modře zvýrazněné atributy (např. na název adresáta) se vždy uživatel dostane do další činnosti (klasické hypertextové odkazy), která s daným atributem úzce souvisí (návrat zpět opět pomocí šipky zpět).

¨ podle vybraných atributů lze uvedená data i třídit. Každý atribut podle kterého lze data na obrazovce třídit má vedle svého názvu ve sloupci malou ikonku „šipka dolů“. Pokud jsou právě podle tohoto atributu data setříděna je tato ikonka „šipka dolů“ zvýrazněna v rámečku (na obrázku s Přehledem adresátů je toto dobře viditelné u atributu název adresáta).

¨ tam kde to systém umožňuje, je u daného záznamu k dispozici i sloupeček AKCE, kde je možno daný záznam opravit (editovat) – ikonka „tužtička“ a nebo zrušit – ikonka „křížek“.

¨ dole na obrazovce má většinou uživateli informaci o celkovém počtu záznamů a celkovém počtu stránek. Zatržením atributu „plynulé dočítání dat“ se způsobí to, že systém bude po jednotlivých stránkách rolovat, uživatel se nemusí překlikávat po jednotlivých stránkách

¨ editační činnosti se jsou závislé na nastavení přístupových práv, takže ne vždy musí uživatel mít k dispozici vše, co je zde popsáno

1. Přehled adresátů

V horní části obrazovky je možno si vyfiltrovat potřebný výběr. Výběrové hodnoty jsou:

¨ název adresáta

¨ město

¨ osoba

¨ kategorie – obrat, počet zaměstnanců, typ společnosti, obchodní stádium – v kategoriích je možno si v překryvném výběrovém seznamu (klik na šipku u kategorie) zaškrtat jednotlivé kategorie a nebo zvolit možnost Vše, čímž se zatrhnout naráz všechny kategorie v překryvném seznamu. Po opětovném kliku na šipku u kategorie se výběrové možnosti dané kategorie „zavřou“.

Pokud uživatel zadává údaje do filtru, např. píše název adresáta, kterého chce hledat, systém automaticky v tu chvíli již vyhledává a v dolní části obrazovky daného adresáta zobrazí. Pokud je uživatel v zadávání filtrů ve výběru příliš rychlý nebo se jedná o složitější výběr, je vhodné následně použít tlačítko „Filtruj“.

Pokud si uživatel vybere větší množinu adresátů, systém ji automaticky rozdělí do jednotlivých stránek (podle nastaveného atributu „záznamů na stránce“) a dole na obrazovce poskytne uživateli informaci o celkovém počtu záznamů a celkovém počtu stránek.

1.1 Detail adresáta

Stiskem modře označeného názvu adresáta se uživatel proklikne na Detail adresáta. Detail adresáta poskytuje uživateli tyto jednotlivé subboxy (tj. okénka):

¨ základní obchodní informace – IČO, implicitní kontaktní údaj a info o implicitní adrese

¨ spojení – jednotlivá nadefinovaná spojení – řazeno dle abecedy, implicitní spojení je zvýrazněno tučně

¨ kategorie adresáta

¨ adresy adresáta

¨ oceněné příležitosti – fiktivní parametr – s jakou pravděpodobností očekáváme jakýsi možný výdělek. V ostrých datech IS BM se jedná o nastavení hodnot parametru „BD – tržby plán“. Zde se zobrazují pouze platné příležitosti, pokud se některá příležitost zruší, tak se původní příležitost zneplatní (čili nastaví se jí automaticky datum platnosti od – do).

Upozornění: Tlačítko přidání záznamu nové oceněné příležitosti se použije v podstatě pouze při jejím prvním založení, pak je pro její změnu či zpřesnění nutno důsledně používat tlačítko EDITACE. Právě z důvodu, aby zde byla k dispozici vždy právě aktuální oceněná příležitost.

Pokud již k danému adresátovi existují záznamy vývěsky, jsou dostupné ve spodní části obrazovky pod jednotlivými subboxy. Pro vývěsku platí jedna výjimka od ostatních subboxů, nový záznam se nepřidává pomocí tlačítka „plus“, ale pomocí ikonky „nový záznam adresáta na vývěsce“ ve sloupečku AKCE.

Pokud je komentář k události vývěsky delší, než je zde možno zobrazit (pokračování textu naznačují tři tečky na konci komentáře), lze si ho kompletně zobrazit po stisku akce „upravit záznam vývěsky“. Po jeho přečtení se lze vrátit pomocí šipky zpět.

1.2 Založit nového adresáta

Po aktivaci možnosti založení nového adresáta (tlačítko „plus“ v pravém horním rohu) se uživateli zobrazí okno „nový adresát“, kde jsou k dispozici následující atributy, ty které jsou označeny * jsou při zadávání povinné:

¨ název

¨ IČ

¨ DIČ

¨ komentář k adresátovi

¨ komentář k adrese

¨ osoba

¨ mail

¨ mobilní tel.

¨ telefon (pevná linka)

¨ komentář ke spojení

¨ ulice

¨ 2. řádek adresy

¨ PSČ

¨ pošta

Nového adresáta je nutno potvrdit stiskem tlačítka „Zapsat nového adresáta“. V případě, že nový záznam uložit nechcete, stiskněte šipku zpět.

Zadáním nového adresáta se v podstatě u adresáta kompletně vyplní tzv. implicitní spojení, tzn. základní údaje o firmě, adrese a spojení.

2. Přehled adres

Po aktivaci této činnosti z levého menu se uživateli zobrazí přehled adres adresáta. V horní části obrazovky jsou k dispozici výběrové (filtrační) atributy. Z jejich názvu je zřejmé, co je jejich obsahem, za vysvětlení stojí atribut 2. řádek adresy, který je v ostrém IS BM představován atributem „byt“ v adrese adresáta.

Do vyhledávacího pole „adresa“ je možno uvést libovolnou část adresy (ulici, město apod.).

Jednotlivé adresy adresáta jsou následně zobrazeny v seznamu. Po kliku na název adresáta se uživateli zobrazí karta „Detail adresáta“ (viz. popis výše), po kliku na modrý odkaz „ulice“ ve sloupečku „adresa s odkazem“ se uživateli zobrazí adresní údaje dané adresy včetně doplňujících informací a kompletní spojení na uvedené adrese. Návrat ze všech odkazů pomocí šipky zpět.

Ve sloupečku Akce jsou dostupné editační činnosti „opravit adresu“ a „zrušit adresu“.

2.1 Založit novou adresu

Po aktivaci možnosti založení nové adresy (tlačítko „plus“ v pravém horním rohu) se uživateli zobrazí okno „založit novou adresu“, kde jsou k dispozici následující atributy, ty které jsou označeny * jsou při zadávání povinné:

¨ adresát – název adresáta

¨ ulice

¨ 2. řádek adresy

¨ PSČ

¨ pošta

¨ případná poznámka

Novou adresu je nutno potvrdit stiskem tlačítka „Zapsat novou adresu“. V případě, že nový záznam uložit nechcete, stiskněte šipku zpět.

U nově zadávaných adres by bylo vhodné dodržet následující pravidla. Název adresáta a ulice jsou jasně dané atributy, 2. řádek adresy představuje např. opravdu přímo byt nebo patro nebo to může být i vlastní označení čtvrti města. PSČ a pošta jsou atributy, které se vztahují přímo k definici pošty daného adresáta. Např. adresa firmy BM Servis podle těchto pravidel vypadá následovně:

¨ adresát – BM Servis s.r.o.

¨ ulice – Školní 2235

¨ 2. řádek adresy – České Budějovice 3

¨ PSČ – 370 10

¨ pošta – České Budějovice 10

3. Přehled spojení

Po aktivaci této činnosti z levého menu se uživateli zobrazí přehled spojení adresáta. V horní části obrazovky jsou k dispozici výběrové (filtrační) atributy:

¨ název adresáta

¨ město

¨ osoba

¨ mail

¨ výběry podle nadefinovaných kategorií

Po zadání výběru (filtru) se uživateli v seznamu zobrazí jednotlivá spojení adresáta či adresátů. Po kliku na název adresáta se uživateli zobrazí karta „Detail adresáta“ (viz. popis výše), po kliku na modrý odkaz „jméno“ ve sloupečku „Jméno (spojení)“ se uživateli zobrazí detailní informace k danému spojení (jméno, funkce, mobil, www apod.) a v dalším subboxu (okénku) informace o kategoriích spojení, které jsou nadefinované u daného adresáta. Po kliku na modrý odkaz „PSČ“ ve sloupečku „adresa“ se uživateli zobrazí adresní údaje dané adresy včetně doplňujících informací a kompletní spojení na uvedené adrese. Návrat ze všech odkazů pomocí šipky zpět.

Ve sloupečku Akce jsou dostupné editační činnosti „opravit údaje spojení“ a „zrušit spojení“.

3.1 Založení nového spojení

Po aktivaci možnosti zadání nového spojení (tlačítko „plus“ v pravém horním rohu) se uživateli zobrazí okno „nové spojení adresáta“, kde jsou k dispozici následující atributy, ty které jsou označeny * jsou při zadávání povinné:

¨ název adresáta – po zadání názvu adresáta se v pravém horním rohu v překryvném seznamu

zobrazí dostupné adresy adresáta (atribut „adresa“). Uživatel vyberu tu adresu, ke které právě zadává nové spojení

¨ jméno

¨ funkce

¨ mail

¨ telefonní číslo – myslí se případná pevná linka

¨ mobilní telefon

¨ fax

¨ WWW

¨ poznámka

Uložení nového spojení se provede stiskem tlačítka „Zapsat nové spojení“. V případě, že nový záznam uložit nechcete, stiskněte šipku zpět.

4. Vývěska

Po aktivaci této činnosti z levého menu se uživateli zobrazí přehled událostí vývěsky. V horní části obrazovky jsou k dispozici výběrové atributy:

¨ název adresáta

¨ město

¨ osoba

¨ možnost vyhledávání událostí od data – do data – po kliku na modrý čtvereček se vedle data zobrazí kalendář. Dvojklikem lze vybrat zvolené datum. Šipky 0 – 30 a D + 30 posouvají oba atributy od data – do data vždy naráz o 30 dnů zpět nebo naopak o 30 dnů dopředu.

¨ text z vývěsky – jakákoliv část textu, která je uvedena v atributu text

¨ zdroj informace

¨ výběry podle nadefinovaných kategorií

Po zapsání filtru se uživateli zobrazí přehled událostí vývěsky. Po kliku na název adresáta se uživateli zobrazí karta „Detail adresáta“ (viz. popis výše). Ve sloupečku „komentář“ je možno si po stisku na modrý odkaz „celý text“ zobrazit celý komentář u dané události vývěsky. Okno s nabídkou celého komentáře lze zavřít pomocí ikonky „křížek“.

Ve sloupečku Akce jsou dostupné editační činnosti „opravit tento záznam vývěsky“, „zrušit tento záznam vývěsky“ a „související dokumenty“ (po kliku na tuto ikonku bude možno prohlížet či editovat příslušný dokument).

4.1 Nový záznam vývěsky

Po aktivaci možnosti zadání nového záznamu vývěsky (tlačítko „plus“ v pravém horním rohu) se uživateli zobrazí okno „nový záznam vývěsky“, kde jsou k dispozici následující atributy, ty které jsou označeny * jsou při zadávání povinné:

¨ adresát

¨ text

¨ komentář

Uložení nového záznamu vývěsky se provede stiskem tlačítka „Zapsat nový záznam na vývěsce“. V případě, že nový záznam uložit nechcete, stiskněte šipku zpět.

5. Kategorie adresátů a spojení

Po aktivaci této činnosti z levého menu se uživateli zobrazí přehled jednotlivých kategorií adresáta a kategorií spojení. V horní části obrazovky je k dispozici filtr, kde je možno si vybrat z následujících atributů:

¨ název adresáta

¨ město

¨ osoba

¨ (ne)platné k datu – vybrat datum po kliku na kalendář a propojit to s atributem platnost, kde si uživatel zvolí buď pouze platné a nebo naopak neplatné k zadanému datu

¨ výběr z překryvného seznamu – kategorie, obrat, počet zaměstnanců, typ společnosti, obchodní stádium

Po zadání filtru je ve spodní části obrazovky přehled vybraných dat. K dispozici je informace o názvu adresáta, jeho ulici a městu, jménu, kategorii, datech platnosti (od – do), komentáři.

Ve sloupečku Akce jsou dostupné editační činnosti „oprava přiřazení kategorie“ a „zrušení tohoto záznamu s kategorií adresáta“.

5.1 Nové přiřazení kategorie

Po aktivaci možnosti zadání nového přiřazení kategorie (tlačítko „plus“ v pravém horním rohu) se uživateli zobrazí okno „nová kategorie spojení adresáta“, kde jsou k dispozici následující atributy, ty které jsou označeny * jsou při zadávání povinné. Tyto atributy se mohou lišit v souvislostí s tím, jakou kategorii uživatel vkládá. Pokud se jedná o kategorii adresáta, jsou to:

¨ typ kategorie – z překryvného seznamu zvoleno kategorie adresáta

¨ adresát

¨ kategorie – v překryvném seznamu jsou dostupné pouze kategorie daného adresáta

¨ datum od – datum platnosti zařazení do kategorie od

¨ komentář

Pokud se jedná o kategorii spojení, jsou to následující atributy:

¨ typ kategorie – z překryvného seznamu zvoleno kategorie spojení

¨ adresát

¨ spojení – v překryvném seznamu jsou dostupné pouze spojení daného adresáta

¨ kategorie – v překryvném seznamu jsou dostupné pouze kategorie spojení daného adresáta

¨ datum od – datum platnosti zařazení do kategorie od

¨ komentář

Uložení nového záznamu vývěsky se provede stiskem tlačítka „Zapsat novou kategorii“. V případě, že nový záznam uložit nechcete, stiskněte šipku zpět.

6. Oceněné příležitosti

Po aktivaci této činnosti z levého menu se uživateli zobrazí přehled možných oceněných příležitostí. Výběrové pole v horní části obrazovky jsou:

¨ adresát

¨ kategorie stádia – výběr z překryvného seznamu

Přehled v dolní části obrazovky poskytuje uživateli informace s jakou pravděpodobností očekáváme jakýsi možný výdělek u vybraných adresátů. V ostrých datech IS BM se jedná o nastavení hodnot parametru „BD – tržby plán“. Zobrazují se pouze platné příležitosti, pokud se některá příležitost zruší (tlačítko ze sloupečku Akce „Ukončení platnosti oceněné příležitosti“), tak se původní oceněná příležitost zneplatní (čili nastaví se jí automaticky datum platnosti do).

V modré liště pod výběrovým polem je k dispozici informace o celkové sumě oceněných příležitostí, nad sloupcem Částka a Částka přepočítaná (o zadané procento).

Tlačítko „nová příležitost“ se použije v podstatě pouze při jejím prvním založení, pak pro její změnu či zpřesnění je vhodnější použít tlačítko ze sloupečku Akce „Změna příležitosti“ (toto tlačítko je dostupné pouze ze subboxu Detail adresáta) . Právě z důvodu, aby zde byla k dispozici vždy právě aktuální oceněná příležitost.

Při vstupu nové příležitosti se zadává adresát, datum plánované tržby, výše tržby, kategorie příležitosti (výběr z překryvného seznamu) a případný komentář k příležitosti.

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 24.09.2015


ELDP a Místně příslušná OSSZ

ELDP a Místně příslušná OSSZ
Byly aktualizovány knihovny ELDP a tisková sestava.

Knihovny a novou tiskovou sestavu je nutné nahrát pomocí Sady vzdálených funkcí "Výpočet ELDP"
Nastavte Obecnou předkontaci RELDP.

Byla přidána možnost zapsat do hlášení ELDP nepovinný atribut "Místně příslušná OSSZ". Některé sociálky to vyžadují, i když povinný je pouze kód OSSZ

V Obecné předkontaci RELDP (Informační centrum - Typy a řady - Obecné předkontace) musí být Položka obecné předkontace "RELDPH - Místně příslušná OSSZ" s hodnotou "název obce".

Ing. Olga Smitková 15.06.16


ELDP a společník

ELDP a společník
Byly aktualizovány knihovny ELDP
Byla přidána reakce, pokud je pracovník typu S - společník, jednatel, .... (1. znak údaje Kód)
Nahrajte si aktualizované knihovny.

Pokud takového pracovníka nemáte ve stavu, nic dalšího nenastavujte, pokud máte, proveďte následující nastavení.

Nastavení jednatele u ELDP:
1) V obecné předkontaci RELDP musí být Položka obecné předkontace "KATM12 - Jednatel pro ELDP" s hodnotou STATU2 . Do
Poznámky si dejte "S - společník, jednatel, komandista, ředitel o.p.s pro ELDP. 1. znak údaje Kód"

2) V číselníku Kategorie pracovníků zadat novou hodnotu "STATU2 Jednatel pro ELDP" Číselník naleznete přes menu INFO K PRACOVNÍKOVI - Pracovníci v kategoriích. Do Poznámky si dejte "S - společník, jednatel, komandista, ředitel o.p.s pro ELDP. 1. znak údaje Kód". Atribut Účel MUSÍ být nastaven na hodnotu Další2 (Tuto hodnotu si můžete pomocí cizojazyčnosti přejmenovat).

3) Na Kartě pracovníka - Volby - Pracovníci v kategoriích přidělíte pracovníkovi hodnotu STATU2.

Ing. Olga Smitková 17.05.16


ONZ a společník

ONZ a společník
Byly aktualizovány knihovny ONZ
Byla přidána reakce, pokud je pracovník typu S - společník, jednatel, ....
Nahrajte si aktualizované knihovny.

Pokud takového pracovníka nemáte ve stavu, nic dalšího nenastavujte, pokud máte, proveďte následující nastavení.

Nastavení jednatele u ONZ:
1) V obecné předkontaci RELDP musí být Položka obecné předkontace "KATM11 - Jednatel pro ONZ" s hodnotou STATU1 . Do Poznámky si dejte "S - společník, jednatel, komandista, ředitel o.p.s, osoby pověřené obchodním vedením"

2) V číselníku kategorie pracovníků zadat novou hodnotu "STATU1 Jednatel pro ONZ" Číselník naleznete přes menu INFO K PRACOVNÍKOVI - Pracovníci v kategoriích. Do Poznámky si dejte "S - společník, jednatel, komandista, ředitel o.p.s, osoby pověřené obchodním vedením". Atribut Účel MUSÍ být nastaven na hodnotu Další1 (Tuto hodnotu si můžete pomocí cizojazyčnosti přejmenovat).

3) Na Kartě pracovníka - Volby - Pracovníci v kategoriích přidělíte pracovníkovi hodnotu STATU1.

Ing. Olga Smitková 17.05.16


Plátcova pokladna

Plátcova pokladna
V souvislosti se zpracováním mezd, které přechází do plateb byla vyvinuta úprava, která umožní rozdělení těchto informací podle počtu plátcových pokladen.

Plátcovou pokladnou je taková organizační složka, organizační jednotka plátce daně z příjmů fyzických osob ze závislé činnosti, v níž dochází k vybírání nebo srážení této daně nebo záloh na ni a kde jsou k tomu uloženy všechny potřebné doklady.

Obdobný pojem jako plátcova pokladna je v jiných zákonech (o sociálním a zdravotním pojištění) mzdová účtárna.

Úprava programu spočívá v zavedení nového číselníku (Plátcovy pokladny). Číselník se napojuje do Umístění mezd a pomocí Pracovních funkcí zasahuje až do Pracovního poměru.

Zatím byla pro tyto účely upravena pouze jedna šablona "Mzdy - podrobně UC i PL". Upravena byla ta část, která překlápí mzdy do plateb (mzdové položky zálohová daň, srážková daň, daňový bonus, roční vyrovnání daně a bonusu (L41… a L43….)).
Ing. Olga Smitková 03.03.16


Font písma

Font písma
Umožnít změnu velikosti fontu písma při editaci externích příkazů.

Font závisí na bw_mocom.prg

Program bw_mocom.prg byl upraven tak, aby respektoval nastavení
v činnosti "Nastavení programu BM" - jde o záznam Preferences - Font_kodu
Default hodnota je 10
Je možné nastavit jinou hodnotu.

Dne 11.2.2015 nastaveno v Galaxii, aby se do všech vygenerovaných verzí automaticky dostalo nastavení Preferences - Font_kodu. Ve verzích, ve kterých je toto již nastaveno je nutné před nahráním bm.exe smazat Preferences - Font_kodu v tabulce BWOPTION.

Obrázek nastavení - viz dokument.
Ing. Olga Smitková 16.10.14


Uplatnění slevy na poplatníka - důchodci

Uplatnění slevy na poplatníka - důchodci
UPLATNĚNÍ SLEVY NA POPLATNÍKA U POŽIVATELŮ STAROBNÍHO DŮCHODU ZA ROK 2013

Popis způsobu uplatnění - viz dokument

Týká se sestavy "DPZVD6 Vyúčtování daně" nad činností "Prohlížení výplatních lístků".

Týká se sestavy "Výpočet daně z příjmů 2012-14" nad činností "Prohlížení výplatních lístků".

Základní sleva na poplatníka činí 24840 Kč ročně (tj. 2070 měsíčně).

Neuplatněnou slevu na dani za rok 2013 doporučujeme zadat pomocí srážky zápornou částkou. Tuto srážku zadáme např. do mezd za říjen/2014.
Formulář "Výpočet daně z příjmů 2012-14" za rok 2013 už neměníme.

Srážka se nesmí projevit ve formuláři "Výpočet daně z příjmů 2012-14" za rok 2014.
Ing. Olga Smitková 15.10.14


Daň žádná - bez mzdové položky

Daň žádná - bez mzdové položky
V činnosti Daňové tabulky souhrnné je možné nadefinovat "žádnou daň".

Je to pro případ, kdy nechceme, aby vznikla mzdová položky s vyčíslením daně.

Na první záložce zadejte hlavičku a na záložce Položky zadejte daň typu "Žádná", procento 0, pevná část 0.

Na toto nastavení reaguje Výpočet a nevznikne žádná mzdová položka s vyčíslením daně.
Ing. Olga Smitková 20.03.14


Důchodové spoření - vyúčtování

Důchodové spoření - vyúčtování
"Vyúčtování pojistného na důchodové spoření ", elektronicky je to PDSVD1

Jak se spouští ?
Sestava se spouští v činnosti Prohlížení výplatních lístků a jmenuje se "Důch. spoř.-vyúčt. (jen 2013)". Sestava otevře elektronickou komunikaci (obdobně jako např. odesílání daňového přiznání DPH) a předplní požadované údaje. Zatím je nastavena na použití za rok 2013.

Jak se nastaví?
- Číslo účastníka důchodového spoření zadejte do činnosti Karta pracovníka - Volby - Pracovníci a kategoriích - ke kategorii "Důchodové spoření - II. pilíř". Viz obrázek duch_spor_cislo.jpg
- Musíte mít vyplněnou hlavičku DPH - činnost v sekci DPH - Daňové přiznání - hlavička. Viz dokument hlavicka_priklad.docx
-Tiskovou sestavu k vygenerovanému dokumentu "Důch. spoř.-vyúčt. (jen 2013)" nahrajte pomocí Sady vzdálených funkcí.

Chcete-li dokument ukládat do Motýla, musíte si vytvořit předlohu ADISMZ.
- Nahrát balíček duch_spor_zaloha.bex
- Předlohu dokumentu ADISMZ - ADIS MZDY (Sada vzdálených funkcí toto nenahraje, použijte nastavení dle obrázku duch_spor_predloha.jpg)

Balíčky a obrázky jsou na n:\_mzdy2013 a na našem FTP Pro zakazniky/mzdy2014/duch_sporeni
Ing. Olga Smitková 03.03.14


NEMPRI hlášení elektronicky

NEMPRI hlášení elektronicky
Formulář NEMPRI (Příloha k žádosti o) je možné podávat elektronicky.

Co k tomu je potřeba ?
- povolení od místní CSSZ
- knihovny NEMPRI, NEMPRB, NEMPRF, NEMPRE, CSSZBS, CSSZED, CSSZVS, XMLDOM, XMLDOK
- Předlohu dokumentu NEMPRI - Příloha k žádosti o (Sada vzdálených funkcí toto nenahraje, použijte nastavení dle obrázku nempri_predloha.jpg)
- Spouštěnou aplikaci NEMPR - Příloha k žádosti o (Sada vzdálených funkcí toto nenahraje, nahrajte si balíček nempri_aplikace)
- do obecné předkontace RELDP - RELDP1 zapsat variabilní symbol
- doplňující vlastnost formuláře nad Nepřítomností pro nemoc - "NEMPRI - Příloha k žádosti o"
- tiskovou sestavu k vygenerovanému dokumentu "Příloha k žádosti o (elektron)"

Povolení od ČSSZ získáte vyplněním formuláře "Oznámení o pověření k zajištění všech úkonů souvisejících s e-Podáním ČSSZ" , na kterém zaškrtnete všechny 4 možnosti. Formulář není součástí Bílého motýla.

Je možné využít Sadu vzdálených funkcí "Výpočet NEMPRI"

Balíčky a obrázky jsou na n:\_mzdy2013 a na našem FTP Pro zakazniky/mzdy2013/nempri

Jak se to potom používá ?
V činnosti Nepřítomnost pro nemoc klikněte na daného pracovníka nebo vyberte pracovníky pomocí označování , spusťte Volby a vyberte Příloha k žádosti o. Vznikne dokument, který bude obsahovat údaje o dané nepřítomnosti. Dokument můžete vytisknout a odeslat elektronicky.

Číslo legitimace (číslo potvrzení) nesmí obsahovat mezery.
Ing. Olga Smitková 29.11.13


Sestava "*Zápočtový list výdělek (skon)"

Sestava "*Zápočtový list výdělek (skon)"
Uživatelský popis:
Sestava slouží např. pro odevzdání na úřadu práce.

Sestava se tiskne nad činností Karta pracovníka, pouze pro pracovníky, kteří mají ukončený pracovní poměr.

Sestavu zaměstnavatel vydá pracovníkovi neprodleně nebo ji zaměstnavatel může vytisknout po delší časové prodlevě, zpětně.
Sestava zobrazuje průměrný hrubý výdělek a průměrný čistý výdělek. Čistý výdělek se počítá podle legislativy, platné v okamžiku ukončení pracovního poměru.
Čistý příjem se uvádí bez případného daňového bonusu.

V sestavě je také možné zaškrtnou "Zobrazit podrobnosti", pak se v sestavě objeví celý postup, pomocí něhož se došlo k průměrnému čistému výdělku.
Je určena pouze pro pracovníka, který ukončuje jeden pracovní poměr, nikoliv pro pracovníka, který ukončuje více pracovních poměrů (některá nastavení na pracovních poměrech, která ovlivňují výpočet čistého příjmu mohou být různá a toto pak sestava nezachytí. Např. jeden pracovní poměr může mít nastaveno SP typu vše a druhý pracovní poměr může mít nastaveno SP pouze typu Důchod).

Sestava potřebuje aktualizovanou předlohu Potvrzeni_o_zam_vydelek.xls

Technický popis:
Sestava musí vyhodnotit, zda smí vzít hodinový průměr z aktuálních údajů na Kartě pracovníka, či nikoliv.

Pokud pracovník skončil v měsíci, ve kterém se průměry přepočítávají, tj. v březnu, červnu, září nebo prosinci a zároveň byl zápočtový list vystaven až po provedení uzávěrky za březen (červen, září nebo prosinec), pak průměr na Kartě pracovníka již není pro účely Zápočtového listu správný. V takové situaci si vezme průměr z Historie pracovních poměrů (tj. najde si průměr, který se v daném čtvrtletí používal).

Rozhodující okamžik je tedy provedení nebo neprovedení uzávěrky měsíce, ve kterém pracovník odešel (datum skončení pracovního poměru) a to, zda se jedná o měsíc, ve kterém se přepočítávají průměry.

Dále je sestava je upravena tak, aby příslušné údaje (dle aktuální legislativy) brala z Karty pracovníka, z jednotlivých záložek. Jedná se o údaje nezdanitelné položky, daňový zvýhodnění bez bonusu, daňová zvýhodnění s bonusem.

Při výpočtu čistého příjmu se nepřičítá případný daňový bonus. Čistý příjem se uvádí bez daňového bonusu.

Příklad z Démonie :
Zaměstnanec končí dne 30.6. pracovní poměr a potřebuje potvrzení pro úřad práce, použije se průměrný výdělek za II. čtvrtletí,
vychází se z toho, že ke skončení pracovního poměru došlo ve II. čtvrtletí. I kdyby si pro potvrzení přišel až v červenci.

(Průměrný výdělek za II. čtvrtletí je ten výdělek, který se vypočetl z údajů II. čtvrtletí a používá se v následujícím III. čtvrtletí.)
Ing. Olga Smitková 27.06.13

Viz.také

Zápočtový list (potvrzení o příjmech)


Důchodové spoření - elektronické hlášení

Důchodové spoření - elektronické hlášení
"Hlášení k záloze na pojistné na důchodové spoření za období ... ", elektronicky je to PDSHL1

Jak se spouští ?
Sestava se spouští v činnosti Prohlížení výplatních lístků a jmenuje se "Důch. spoř. -záloha (PDSHL1)". Sestava otevře elektronickou komunikaci (obdobně jako např. odesílání daňového příznání DPH) a předplní požadované údaje.

Jak se nastaví?
- Číslo účastníka důchodového spoření zadejte do činnosti Karta pracovníka - Volby - Pracovníci a kategoriích - ke kategorii "Důchodové spoření - II. pilíř". Viz obrázek duch_spor_cislo.jpg
- Musíte mít vyplněnou hlavičku DPH - činnost v sekci DPH - Daňové přiznání - hlavička. Viz dopkument hlavicka_priklad.docx
-Tiskovou sestavu k vygenerovanému dokumentu "Důch. spoř. -záloha (PDSHL1)" nahrajte pomocí sady vzdálenách funkcí "Nastavení mezd pro rok 2013"

Chcete-li dokument ukládat do Motýla, musíte si vytvořit předlohu ADISMZ.
- Nahrát balíček duch_spor_zaloha.bex
- Předlohu dokumentu ADISMZ - ADIS MZDY (Sada vzdálených funkcí toto nenahraje, použijte nastavení dle obrázku duch_spor_predloha.jpg)

Balíčky a obrázky jsou na n:\_mzdy2013 a na našem FTP Pro zakazniky/mzdy2013/duch_sporeni
Ing. Olga Smitková 19.04.13


ELDP a prokurista

ELDP a prokurista
Byly aktualizovány knihovny ELDP a ONZ.

Byla přidána reakce, pokud je pracovník typu P - prokurista.
Nahrajte si aktualizované knihovny.

Pokud takového pracovníka nemáte ve stavu, nic dalšího nenastavujte, pokud máte, proveďte následující nastavení.

Nastavení prokuristy:
1) V obecné předkontaci RELDP musí být Položka obecné předkontace "KATMZ9 - Prokurista" s hodnotou PROKU
2) V číselníku kategorie pracovníků zadat novou hodnotu "PROKU Prokurista" Číselník naleznete přes menu INFO K PRACOVNÍKOVI - Pracovníci v kategoriích.
3) Na Kartě pracovníka - Volby - Pracovníci v kategoriích přidělíte pracovníkovi hodnotu PROKU.
Ing. Olga Smitková 25.04.13


PVPOJ elektronicky

PVPOJ elektronicky
Formulář PVPOJ je možné podávat elektronicky.

Co k tomu je potřeba ?
- povolení od místní CSSZ
- knihovny PVPOJA, PVPOJB, PVPOJF, CSSZBS, CSSZVO, XMLDOK, XMLDOM
- Předlohu dokumentu PVPOJ - Přehled o výši pojistného (Sada vzdálených funkcí toto nenahraje, použijte nastavení dle obrázku pvpoj_predloha.jpg)
- Spouštěnou aplikaci PVPOJ - Přehled o výši pojistného (Sada vzdálených funkcí toto nenahraje, nahrajte si balíček pvpoj-aplikace)
- do obecné předkontace RELDP - RELDP1 zapsat variabilní symbol
- doplňující vlastnost formuláře nad Kartou pracovníka - "ELPOD1 - Elektronická podání" (zahrnuje podání ONZ, ELDP, ELDP extra, PVPOJ)
- externí příkazy
Elektronická podání
Oznámení o nástupu do zam.
Evidenční list důch. pojištění 09
Evidenční list důch. poj. extra
Přehled o výši pojistného
- tiskovou sestavu k vygenerovanému dokumentu "Přehled o výši pojistného"

Je možné využít Sadu vzdálených funkcí "Výpočet PVPOJ"

Povolení od ČSSZ získáte vyplněním formuláře "Oznámení o pověření k zajištění všech úkonů souvisejících s e-Podáním ČSSZ" , na kterém zaškrtnete všechny 4 možnosti. Formulář není součástí Bílého motýla.

Balíčky a obrázky jsou na n:\_mzdy2013 a na našem FTP Pro zakazniky/mzdy2013/pvpoj

Jak se to potom používá ?
V činnosti Karta pracovníka klikněte na pracovníka pomlčka (lze to spustit pouze na tomto pracovníkovi), spusťte Volby a vyberte Elektronická podání - PVPOJ. Vznikne dokument, který bude obsahovat údaje daného měsíce. Dokument můžete vytisknout a odeslat elektronicky.
Ing. Olga Smitková 28.03.13


Cizinci a solidární daň

Cizinci a solidární daň
Cizinci a solidární daň
Organizace, které takové pracovníky nemají, nemusí nic nastavovat, nastavení proběhlo automaticky.
U cizinců, kteří mají formulář E101, je potřeba upravit mzdové položky tak, aby bylo možné vypočítat solidární daň.

V činnosti DEFINICE - POLOŽKY MEZD - PŘÍJMY A NÁHRADY - Doplňující údaje bylo zavedeno nové zaškrtávátko "Solidární daň". Automaticky je nastaveno stejně, jako zaškrtávátko "Zdanitelný příjem".

Je-li zaškrtnuto "Zdanitelný příjem" u nějaké mzdové položky, znamená to, že tato mzdová položka bude započtena do základu daně zálohové.
Je-li zaškrtnuto "Solidární daň" u nějaké mzdové položky, znamená to, že tato mzdová položka bude započtena do základu solidární daně.
Jestliže potřebujeme nastavit odlišné chování mzdové položky vůči běžné dani a vůči solidární dani, pak toto řídíme popsanými zaškrtávátky.

Ing. Olga Smitková 08.02.13


Mzdy - souhrnné změny v kalendářích

Mzdy - souhrnné změny v kalendářích
V oblasti generování denních kalendářů (jejich fondu pracovní doby) bylo zavedeno několik novinek.

Činnost "Pracovní doba" se nachází v menu Mzdy - Definice. Přes Volby je možné vyvolat několik způsobů generování fondu pracovní doby po dnech nebo po měsících.

Změny :
1) Ke každému kalendáři nově náleží atribut Aktuální Ano/Ne. Využije se to např. při zadávání pracovního poměru.
2) Byl zaveden nový číselník "Číselník svátků". Zde je možné si nastavit dny, které jsou svátky. Číselník obsahuje datum svátku, popis svátku a komentář. Slouží ke generování denních kalendářů. Při generování denních kalendářů se program ptá, zda chcete označit pracovní dny jako svátky (podle číselníku svátků).
3) Byla zavedena nová možnost generování FPD po dnech. Je to "Generuj FPD s periodou po dnech", která vygeneruje nový fond pracovní doby po dnech pro zadané období podle zadané periody. Po spuštění generace je nutné zadat období od - do, ve kterém generování proběhne a periodu střídání pracovních a nepracovních dnů. Perioda se uvádí pomocí znaků P (pracovní den) a N (nepracovní den). Příklad : PPPPPNN - po 5-ti pracovních dnech následují 2 dny nepracovní. Na dotaz je zde možnost označit pracovní dny jako svátky (podle číselníku svátků).

4) Ke každému dennímu kalendáři je možné automaticky vygenerovat svátky. Pomocí činnosti "Generuj svátky podle číselníku svátků". Do již vygenerovaného denního kalendáře označí pracovní dny jako svátky (podle číselníku svátků).

5) Shrnutí možností generování FPD
Generuj FPD po měsících - zůstává beze změny
Generuj veškerý FPD po měs. - zůstává beze změny

Generuj FPD po dnech - byla přidána možnost označit pracovní dny jako svátky (podle číselníku svátků)

Generuj veškerý FPD po dnech - - byla přidána možnost označit pracovní dny jako svátky (podle číselníku svátků)

Generuj FPD s periodou po dnech - zde je možné definovat FPD v určitém časovém období dle periody. Perioda se zadává pomocí písmen P a N, kdy P znamená pracovní den a N nepracovní den. Na dotaz je zde možnost označit pracovní dny jako svátky (podle číselníku svátků)

Generuj svátky podle číselníku svátků - do již vygenerovaného denního kalendáře označí pracovní dny jako svátky (podle číselníku svátků)

Ing. Olga Smitková 27.06.12


ELDP a ONZ

ELDP a ONZ
Byly aktualizovány knihovny ELDP a ONZ.
Byla přidána reakce, pokud je pracovník typu Q - členové kolektivních orgánů právnických osob.
Pro správné fungování knihoven musíte provést následující nastavení (i když pracovníka typu Q nemáte ve stavu).

Nastavení :
1) V obecné předkontaci RELDP musí být Položka obecné předkontace "KATMZ8 - Člen kolektivních orgánů právnických os" s hodnotou QCLEN
2) V číselníku kategorie pracovníků zadat novou hodnotu "QCLEN Člen kolektivního orgánu právnických os." Číselník naleznete přes menu INFO K PRACOVNÍKOVI - Pracovníci v kategoriích.
3) Na Kartě pracovníka - Volby - Pracovníci v kategoriích přidělíte pracovníkovi hodnotu QCLEN.
Ing. Olga Smitková 27.04.12


Sestava "Rekapitulace výplatního lístku"

Sestava "Rekapitulace výplatního lístku"
Byla navržena nová sestava "Rekapitulace výplatního lístku", která slouží k tisku historických výplatních lístků.

Sestava zobrazí též zdravotní pojišťovnu, platnou v zadaném měsíci.
Tříděna abecedně dle osobního čísla.
Sestava nezobrazuje aktuální stav dovolené - tj. kolik dovolené zbývá čerpat, protože u výplatního lístku z minulého období by tento údaj byl zavádějící.
Ing. Olga Smitková 02.12.11


Vyměřovací základ a jeho snižování

Vyměřovací základ a jeho snižování
Nová funkčnost programu Bílý motýl dle legislativy.

Legislativa:
Vyměřovacím základem poživatelů invalidního důchodu, kteří pracují u zaměstnavatele, který zaměstnává více než 50% osob se zdravotním postižením (invalidní důchodci a osoby zdravotně znevýhodněné), částka přesahující vyměřovací základ osoby, za kterou je plátcem pojistného stát (od roku 2010 je to 5355 Kč). Tzn., že pojistné by se u invalidních důchodců vypočetlo z příjmu sníženého o 5355 Kč.

Popis řešení:
Řešení je provedeno v programovém kódu, je tedy nutná nová verze.
Řešení má význam pro organizace, které zaměstnávají více než 50% osob se zdravotním postižením. Ostatní organizace nemusí nahrávat novou verzi a nemusí nic nastavovat.

Popis nastavení:
Na Kartě pracovníka - záložka Osobní údaje - byl přidán nový typ Zdravotního pojištění "Plátcem je stát (snížit o konstantu)".

Typy zdravotního pojištění tedy budou:
1) Sledovat min. vym. základ
2) Plátcem je stát (neponižovat o konstantu)
3) Nesledovat min.vym.základ
4) Plátcem je stát (snížit o konstantu)

S úpravou úzce souvisí legislativní konstanta "Vym. základ ZP (mz27zpstat)", kterou je potřeba pro variantu 4) nastavit pro rok 2011 na hodnotu 5355 Kč. Nastavení se provádí v činnosti DEFINICE - Legislativní konstanty.
Ve výpočtu u pracovníků s variantou 4) dojde u základu zdravotního pojištění o ponížení o 5355 a z toho se vypočtou odvody ZP.

Shrnutí:
A) organizace, které NEzaměstnávají více než 50% osob se zdravotním postižením, neudělají nic, nemusí si nahrát novou verzi a nemusí nic nastavit.
B) organizace, které zaměstnávají více než 50% osob se zdravotním postižením, si musí nahrát novou verzi a u pracovníků - invalidů musí provést nastavení dle popisu nastavení (viz výše).

Ing. Olga Smitková 29.06.11


Mzdy - nulový hodinový průměr

Mzdy - nulový hodinový průměr
Při pokusu zapsat mzdovou položku, která vychází z hodinového průměru, a tento konkrétní průměr je nulový, se objeví upozornění 'Varování - použitý hodinový průměr je nulový'. Motýl dovolí takový záznam zapsat, pouze upozorní na možnou nesrovnalost.

Objevuje se v činnostech Výplatní lístky, Všechny výplatní lístky - zadávání, Prohlížení výplatního lístku, Komplexní zadávání výplatních lístků.

Při Optimalizovaném výpočtu dojde k zápisu do Protokolu - u položek, které vychází z hodinového průměru a mají ho zadán nulový.
Jedná se o hlášení PRAVI7 - Pravidelné příjmy 07 - Pracovník má na mzdové položce ... použitý nulový hodinový průměr.

Ing. Olga Smitková 12.04.11


Varovné hlášení - zadávání mezd dopředu

Varovné hlášení - zadávání mezd dopředu
Při pokusu o zadání mzdové položky nikoliv do aktuálního měsíce, ale do některého následujícího se spustí varovné hlášení "Zapisujete položky do jiného měsíce, než aktuálního !" Zadání se přesto umožní, je pouze informativní.

Objevuje se v činnostech Výplatní lístky, Všechny výplatní lístky - zadávání, Prohlížení výplatního lístku, Komplexní zadávání výplatních lístků.
Ing. Olga Smitková 12.04.11


Nulování částek v zadávání mezd

Nulování částek v zadávání mezd
V činnostech - Výplatní lístky zadavání, Výplatní lístky, Prohlížení výplatních lístků a Komplexní zadávání
se při opravě dnů nebo hodin přepočte celková částka na mzdové položce podle nových hodnot.

Příklad: dovolená, kdy změním 3 dny na 2 dny a peníze se přepočítají.

Ing. Olga Smitková 18.03.11


Potvrzení o příjmech vz.19

Potvrzení o příjmech vz.19
K dispozici je sestava Sestava "Potvrzení o příjmech vz.19", která slouží jako potvrzení o příjmech platné pro rok 2011.
Ing. Olga Smitková 08.03.11


Šablony mezd

Šablony mezd
Při zpracování mezd dochází k odeslání údajů do komponenty platby, účetnictví nebo i statistika. Provádí se to spuštěním procesu. Proces pracuje s předem navrženými šablonami a tyto šablony pracují přímo s daty v aktuálním měsíci. Typicky se proces používá vždy po zpracování mezd za daný měsíc a před jeho uzávěrkou.

Pokud se na chybu v tomto procesu přijde trochu později a již je provedena uzávěrka právě zpracovaného měsíce, je to problém, protože Bílý motýl je již nastaven na následující měsíc.

Nyní nově šablony obsahují dotaz na měsíc a rok, ke kterému chceme proces spustit.
Je tedy možné spustit proces nad daty již uzavřeného měsíce.

Ing. Olga Smitková 23.03.11


Sestavy Plnění povinného podílu osob

Sestavy Plnění povinného podílu osob
Sestavy se pouští v činnosti Prohlížením výplatních lístků a POTŘEBUJE OBECNÝ VÝBĚR!!!!

Jedna sestava (legislativní) se jmenuje Plnění povinného podílu osob a druhá (kontrolní) se jmenuje Plnění pov.podílu - mzdové pol..
Obě sestavy se používají pouze s obecným výběrem Plnění povinného podílu osob. Tento obecný výběr umožní vyloučit ze zpracování nevhodné mzdové položky. Které to jsou je u každého uživatele individuální. Nejlépe se to zjistí pomocí kontrolní sestavy Plnění pov.podílu - mzdové pol. Nechtěné mzdové položky pak vyjmenujte v obecném výběru (upravte si ho).
Sestavy automaticky nezahrnují položku náhrada mzdy za nemoc, protože údaje o těchto hodinách jsou již obsaženy v položce N10000.

Popis k obecnému výběru:
Obecný výběr pro sestavy Plnění povinného podílu osob a Plnění pov.podílu - mzdové pol. .
Obecný výběr vyloučí některé mzdové položky.
Místo znaků XXXXXX zadejte identifikaci vaší mzdové položky, která nepatří do sestavy. Zadávejte položku v délce 6 znaků, pokud je kratší, doplňte ji mezerami.
Příklad 'AM01 '.

Popis k sestavě Plnění povinného podílu osob:
Sestava pro úřad práce o plnění povinného podílu osob se zdravotním postižením.
Sestava se povinně používá společně s obecným výběrem Plnění povinného podílu osob.
Vyplňuje se u organizací s více než 25-ti zaměstnanci v pracovním poměru.
Vyplňuje se do 15.2. za uplynulý kal. rok

Některé údaje je nutno vyplnit při spuštění sestavy.
Celkový fond pracovní doby se zjistí z měsíčního kalendáře, který je uveden v činnosti Parametry - záložka Chování. Předpokládá se, že dny zde uvedené jsou včetně státků.
Proto je potřeba při spuštění sestavy vyplnit počet svátků v daném roce.

Sestava zahrnuje pouze položky typu příjem, nemocenské a ošetřovné, neplacené volno.
Sestava nezahrnuje položku náhrada mzdy za nemoc, protože údaje o hodinách jsou již obsaženy v položce N10000.
Dále nezahrnuje pracovníky s druhem pracovního poměru Dohoda o provedení práce a Dohoda o pracovní činnosti.
Pokud zaškrtnete "Zobrazit podrobnosti" sestava ukáže údaje, ze kterých počítá.

Pokud máte některé mzdové položky (např. překážky v práci), které nechcete do sestavy zahrnovat, je upravit obecný výběr (Plnění povinného podílu osob), a tím tyto položky vyloučit.

Popis k sestavě Plnění pov.podílu - mzdové pol. .:
Kontrolní sestava k sestavě pro úřad práce o plnění povinného podílu osob se zdravotním postižením.
Sestava se povinně používá společně s obecným výběrem Plnění povinného podílu osob.
Vyplňuje se u organizací s více než 25-ti zaměstnanci v pracovním poměru.
Vyplňuje se do 15.2. za uplynulý kal. rok

Sestava zahrnuje pouze položky typu příjem, nemocenské a ošetřovné, neplacené volno.
Sestava nezahrnuje položku náhrada mzdy za nemoc, protože údaje o hodinách jsou již obsaženy v položce N10000.
Dále nezahrnuje pracovníky s druhem pracovního poměru Dohoda o provedení práce a Dohoda o pracovní činnosti.
Pokud máte některé mzdové položky (např. překážky v práci), které nechcete do sestavy zahrnovat, je upravit obecný výběr (Plnění povinného podílu osob), a tím tyto položky vyloučit.

Ing. Olga Smitková 28.01.11


Exekuce - poměrné uplatnění

Exekuce - poměrné uplatnění
Došlo k úpravě výpočtu pohledávek v případech, kdy máme více pohledávek nepřednostních i přednostních ke stejnému datu doručení. Musí existovat alespoň jedna přednostní pohledávka.

Postup uplatňování :
Nejprve se ze druhé třetiny u částky bez omezení uplatní pohledávky přednostní. Pokud nebyla využita celá částka "bez omezení", je tato přesunuta do první třetiny.

Z první třetiny se sráží poměrným způsobem všechny pohledávky, které mají stejné datum doručení. Poměrný výpočet se ale provádí podle PŮVODNÍ výše pohledávky, nikoliv podle částky, která zbývá po provedení srážky ze 2. třetiny.

V některých případech se může stát, že dojde k překročení původní výše pohledávky. Pokud se tak stane, je nutné na pohledávku srazit pouze částku do výše pohledávky a zbytek rozdělit mezi ostatní pohledávky, které nebyly uplatněny v plné výši.

Program zapíše hlášení do Protokolu a vyzve obsluhu k ručnímu upravení výše exekucí.
Hlášení se jmenuje POH008 a je vhodné nastavit jeho chování. Je možné mu např. změnit barvu, nastavit pozastavení programus informací o chybě ... Nastavení se provede v činnosti Algoritmy výpočtu protokolu, - druhá záložka Užití algoritmu v sekci DEFINICE.

Příklad
čerpáno ze Mzdové účetní 10/2010.
Zaměstnanec má čistou mzdu 14000, nemá další vyživované osoby.
Má jednu exekuci přednostní na 179 310 a druhou nepřednostní na 20 208. Obě exekuce mají STEJNÝ datum doručení.

Výše jednotlivých třetin bude 2574 a částka zabavitelná bez omezení bude 1128.
Pro přednostní pohledávku se použije druhá třetina a částka zabavitelná bez omezení 2574 + 1128 = 3702 Kč.

179310+20208 = 199518

První třetina se rozdělí poměrným číslem :
2574 : 199518 = 0,0129
0,0129 * 179310 = 2313
0,0129 * 20208 = 261
Přednostní pohledávka se uhradí ve výši 3702 + 2313 = 6015
Nepřednostní pohledávka se uhradí ve výši 261.
Ing. Olga Smitková 26.11.10


Sestava Čtvrtletní potvrzení příjmů

Sestava Čtvrtletní potvrzení příjmů
Sestava slouží k potvrzování průměrného hrubého a průměrného čistého příjmu, vždy z údajů za nějaké čtvrtletí ve smyslu zákoníku práce.

V sestavě zadáme čtvrtletí a rok. Dále zadáme, zda chceme zobrazit podrobnosti výpočtu jednotlivých údajů.
Zadané čtvrtletí se stává rozhodným obdobím.

Sestava zobrazí údaje :
Hrubý příjem - součet hrubých příjmů za tři měsíce rozhodného období
Čistý příjem - součet čistých příjmů za tři měsíce rozhodného období

Průměrný hrubý měsíční příjem se vypočítá na základě příjmů v rozhodném období, hodinový průměr rozhodného období bývá historicky uložen v činnosti Historie pracovního poměru.
Pokud ho tam sestava nenajde, pak vezme hodinový průměr, který je uveden na Kartě pracovníka - Další informace.
Příklad :
Rozhodné období bude 1. čtvrtletí 2009, pak se sestava podívá do Historie pracovního poměru v měsících 4,5,6/2009.
V těchto měsících se používal hodinový průměr vypočítaný z údajů 1. čtvrtletí 2009

Průměrný čistý měsíční příjem se vypočítá z průměrného hrubého měsíčního příjmu podle legislativy platné k poslednímu dni rozhodného období.

Zákon 262/2006
Průměrný měsíční hrubý výdělek se vypočítá tak, že se průměrný hodinový výdělek zaměstnance vynásobí průměrným počtem hodin, připadajících na jeden měsíc v průměrném roce.
Průměrný hodinový výdělek he hrubá mzdy za rozhodné období / odpracované hodiny za rozhodné období.
Rozhodné období je předchozí kalendářní čtvrtletí. Do hrubé mzdy se započítávají pouze částky, které se vážou na výkon práce.
Ing. Olga Smitková 16.11.10


Tooltip - mzdová položka

Tooltip - mzdová položka
Byla vytvořena doplňující vlastnost formuláře - tooltip - TIPMZ2, která při vstupu kurzoru na identifikaci mzdové položky zobrazí "samostatné informační okno" s údaji o názvu a o platnosti této mzdové položky.

Platí pro všechny výskyty atributu Identifikace mzdové položky, např. v činnostech Výplatní lístky, Výplatní lístky - zadávání, Prohlížení výplatních lístků nebo Komplexní zadávání výplatních lístků.
Ing. Olga Smitková 15.10.10


MZDY - ošetřování osamělou osobou

MZDY - ošetřování osamělou osobou
Zadáváme-li Ošetřování osamělou osobou, pak takové osobě náleží jiná nemocenská dávka, než osobě, která ošetřuje člena rodiny a není osamělá.

Zadávání řešíme z podhledu výpočtu nemocenské dávky a z pohledu výpočtu ELDP.

1) V činnosti Nepřítomnost pro nemoc je důvod, v pořadí sedmý - Ošetřování osamělou osobou. Ten použijeme pro zadání a dále pokračujeme v záložce Dávky běžným způsobem.
V Parametrech nemocenských dávek je možné definovat způsob výpočtu dávky u ošetřování osobou, která je osamělá. Důvod Ošetřování osamělou osobou byl přidán i do Parametrů nemocenských dávek.

Výpočet výplatních lístků vytvoří mzdové položky N20000 a N21000 jako u běžného ošetřování.

Pokud zadáváte ošetřování osobou, která není osamělá, použijete v činnosti Nepřítomnost pro nemoc důvod Ošetřování.

2) Z hlediska správného ELDP je také důležité zadat v činnosti Nepřítomnost pro nemoc důvod - Ošetřování osamělou osobou.

Pozn. : OČR osamělou osobou se dříve řídilo podle nastavení na Kartě pracovníka - Osobní údaje - Stav (-, svobodná, vdaná, vdova, rozvedená, další 1, další 2, další 3). Jestliže je nastaven Stav v pořadí šestý až osmý, tj. další 1, další 2, další 3, pak to ovlivňuje také vyloučené doby v ELDP. V tomto případě budou i Nepřítomnosti s důvodem Ošetřování posuzovány jako by došlo k ošetřování osamělou osobou.

Doporučený postup :
- Na Kartě - Osobní údaje používat pouze Stav (-, svobodná, vdaná, vdova, rozvedená)
- V nepřítomnosti pro nemoc důsledně rozlišovat, zda šlo o důvod Ošetřování nebo o důvod Ošetřování osamělou osobou.
- Ke správné funkčnosti potřebujete Knihovnu ELDP09 aktualizovanou k datu 21.4.2010. Je uložena na našem FTP v sekci Pro zákazníky \ Mzdy 2010 \ Eldp.

Ing. Olga Smitková 21.04.10


Sestava Zákonné pojištění odpovědnosti

Sestava Zákonné pojištění odpovědnosti
Byla aktualizována sestava excelová Zákonné pojištění odpovědnosti. Jmenuje se "Zákonné pojištění odp. 2010".

Aktualizaci využijí ti zákazníci, kteří mají "ve stavu" jednatele, kteří pobírají mzdu - plat podle obchodního zákoníku vyšší než 5900 Kč.

Balíčky jsou na FTP v sekci Pro zákazníky \ Mzdy 2010 \ Sestavy

Ing. Olga Smitková 08.04.10


Příloha k žádosti o 89 621 3

Příloha k žádosti o 89 621 3
byla aktualizována tisková předloha "Příloha k žádosti o (89 621 3)", která s používá v činnosti Nepřítomnost pro nemoc.

Balíčky jsou na FTP v sekci Pro zákazníky \ Mzdy 2010 \ Sestavy

Ing. Olga Smitková 01.03.10


Sestava "Dávky a náhrady"

Sestava "Dávky a náhrady"
Sestava se nachází v činnosti Nepřítomnost pro nemoc a jmenuje se "Dávky a náhrady".

Slouží pro přehledné zobrazení stavu nemocenských dávek a případných vyplacených náhrad nemocenského.

Sestava respektuje nastavení výběru činnosti. K daným nepřítomnostem se zobrazí i Náhrada mzdy pro nemoc, pokud byla vyplacena.

Balíčky jsou uloženy na FTP v sekci Pro zákazníky \ Mzdy 2010 \ Sestavy

Ing. Olga Smitková 23.02.10


Sestava Výpočet daně a daň. zvýh. 2009

Sestava Výpočet daně a daň. zvýh. 2009
Sestava Výpočet daně a daň. zvýh. 2009
za zdaňovací období 2009, vzor 14

Dobrý den,

posíláme vám upravenou sestavu Výpočet daně ... pro rok 2009.

Sestava "Výpočet daně a daňového zvýhodnění u daně z příjmů fyzických osob ze závislé činnosti a z funkčních požitků za zdaňovací období 2009" je součástí ročního zúčtování za rok 2009.

Sestava je téměř stejná se sestavou za rok 2008. Rozdíly jsou v čísle roku v hlavičce a v textu pokynů.

Nová sestava je uložena formou balíčku Vypocet_dane_2009 na našem FTP v sekci Pro zákazníky \ Mzdy 2010 \ Sestavy
Nedílnou součástí je předloha Vypocet_dane_2009.xlt, kterou je potřeba nahrát do složky Template.

Za BM Servis s.r.o.
Olga Smitková

Ing. Olga Smitková 22.02.10


Používání aliasu ve mzdách

Používání aliasu ve mzdách
V činnosti Karta pracovníka - záložka Pracovní poměry je možné zadat alias jména pracovníka a tento se pak projeví v činnostech Komlexní zadávání výplatních lístků a Nepřítomnost pro nemoc.

Využije se hlavně u pracovníků, kteří se jmenují stejně a pro účely snazšího zadávání mezd je vhodné je rozlišit.
Ing. Olga Smitková 04.08.09


Sestava "Příloha k žádosti o (89 621 2)"

Sestava "Příloha k žádosti o (89 621 2)"
Byla vytvořena nová sestava "Příloha k žádosti o (89 621 2)".

Tato sestava je oproti původní upravena - do části i) na druhé straně se nezapisují záznamy o ošetřování, ale pouze záznamy o nemoci.

Ing. Olga Smitková 28.08.09


Sestavy Potvrzení o zam. -2 sestavy ZL

Sestavy Potvrzení o zam. -2 sestavy ZL
V souladu se zákonem 262/2006 paragraf 313 byla vytvořena sestava Potvrzení o zaměstnání (zápočtový list)

Sestava se jmenuje "*Zápočtový list standard" a je typu běžná, nikoliv excel.

Sestava obsahuje záznamy o nemocech v posledním roce před ukončením pracovního poměru, záznamy o prováděných srážkách, které trvají i nadále.

Sestava neobsahuje údaje o výši průměrného výdělku - toto se uvádí na samostatném potvrzení (kvůli podpoře v nezaměstnanosti)

Sestava '*Zápočtový list - výdělek' je k dispozici v naší verzi, v empty verzi. Dále na FTP a v adresáři N:\_VERZE_MZDY_2009\......
------------------------------------------------------------------------
V souladu se zákonem 435/2004 paragraf 42 byla vytvořena sestava Potvrzení pro podporu v nezaměstnanosti. Sestava obsahuje informace o průměrném hrubém a čistém výdělku.

Sestava se jmenuje "*Zápočtový list - výdělek", je typu excel a potřebuje šablonu (Potvrzeni_o_zam_vydelek.xlt).

Sestava se zeptá na datum - 'Legislativa ke dni '. K tomuto datu se načtou potřebné legislativní konstanty. V sestavě je také možné zaškrtnou 'Zobrazit podrobnosti ' - pak se v sestavě objeví celý postup, pomocí něhož se došlo k průměrnému čistému výdělku.

Je určena pouze pro pracovníka, který ukončuje jeden pracovní poměr, nikoliv pro pracovníka, který ukončuje více pracovních poměrů.

Některá nastavení na pracovních poměrech, která ovlivňují výpočet čistého příjmu mohou být různá a toto pak sestava nezachytí. Např. jeden pracovní poměr může mít nastaveno SP typu vše a druhý pracovní poměr může mít nastaveno SP pouze typu Důchod.

Sestavuje možné použít k opětovnému vytisknutí i po delším čase po odchodu pracovníka.

Sestavu zaměstnavatel vydá pracovníkovi např. pro odevzdání na úřadu práce neprodleně, pravděpodobně ještě před provedením uzávěrky měsíce, ve kterém zaměstnanec odchází. V tu chvíli je na Kartě pracovníka ještě správný hodinový průměr.

Pokud ale pracovník skončil v měsíci, ve kterém se průměry přepočítávají, tj. v březnu, červnu, září nebo prosinci a zároveň byl zápočtový list vystaven až po provedení uzávěrky za březen (červen, září nebo prosinec), pak průměr na Kartě pracovníka již není pro účely Zápočtového listu správný.

V takové situaci si vezmeme průměr z Historie pracovních poměrů (tj. najde si průměr, který se v daném čtvrtletí používal).

Rozhodující okamžik je tedy provedení nebo neprovedení uzávěrky měsíce, ve kterém pracovník odešel (datum skončení pracovního poměru).

Příklad z Démonie :
Zaměstnanec končí dne 30.6. pracovní poměr a potřebuje potvrzení pro úřad práce, použije se průměrný výdělek za II. čtvrtletí,
vychází se z toho, že ke skončení pracovního poměru došlo ve II. čtvrtletí. I kdyby si pro potvrzení přišel až v červenci.

(Průměrný výdělek za II. čtvrtletí je ten výdělek, který se vypočetl z údajů II. čtvrtletí a používá se v následujícím III. čtvrtletí.)

Ing. Olga Smitková 28.08.09


Mzdy - mimořádná sleva na pojistném

Mzdy - mimořádná sleva na pojistném
Balíčky jsou uloženy na n:\_verze_mzdy_2009\mimoradna_sleva

Je k dispozici sestava excel - "Mimořádná sleva", která slouží jako přípravná sestava k oficiálnímu formuláři.

Sestava vyžaduje :
- instalaci nové verze
- nastavení atributů Doručení výpovědi a Odvolání výpovědi u těch pracovníků, kteří jsou ve výpovědi v roce 2009 (nastaví se v činnosti Další informace)

- zadání nových legislativních konstant (ručně nebo balíčkem) :
mz27spmzda - Průměrná mzda pro účely slevy na SP (číslo 20,2) v hodnotě 27100,-
mz27sppro1 - Procento rozdílu pro účely slevy na SP (číslo 6,2) v hodnotě 3,3%
mz27sppro2 - Max. procento pro účely slevy na SP (číslo 6,2) v hodnotě 25%

- nahrání předlohy emptyxlt_mimoradna_sleva.xlt

- nahrání balíčku se sestavou

- u pracovníků, jejichž zaměstnání má charakter "Malého rozsahu" musí být na Kartě pracovníka - Pracovní poměry - Volby - Charakter pracovníka v p.p. nastaven charakter MALROZS. (Automatické jednorázové nastavení tohoto charakteru je možné individuálně na požádání).

Může se stát, že sestava nějakého pracovníka a jeho pracovní poměr odmítá zařadit, potom
u tohoto pracovního poměru nastavte charakter 'SLEVA_ANO'.

Může se stát, že sestava nějakého pracovníka a jeho pracovní poměr zařazuje , i když ho zařazovat nemá, potom u tohoto pracovního poměru nastavte nastavte charakter 'SLEVA_NE'.

Sestava se obsluhuje :
- z činnosti Prohlížení výplatních lístků
- do výběru nastavte požadovaný rozsah měsíců, např. 01/2009 - 07/2009 (za předpokladu, že zákon bude platný od 1.8.2009)
- na dotaz sestavy "První den nabytí účinnosti zákona" odpovězte 1.8.2009 (za předpokladu, že zákon bude platný od 1.8.2009)
- za každý měsíc bude vytvořen samostatný list

Sestava zahrne pracovníky :
- kteří jsou v prac. poměru k 31.8.2009 (za předpokladu, že zákon bude platný od 1.8.2009)
- v měsíci, který odpracovali celý
- nemají nastaveno MALROZS nebo mají nastaveno MALROZS, ale jejich příjem je vyšší než 2000,-
- zaměstnání mělo být delší než 3 měsíce
- pouze měsíce, ve kterých zaměstnanec není ve výpovědi

Sestava zatím nezahrnuje tyto situace:
- organizace je v likvidaci

Technické podrobnosti nastavení sestavy:
Podmínky v doplnění

and mzmzdy.mz28id = 'I20000'
pouze položky I20000 - základ sociálního pojištění

and ((
(MZPRACPO.mz32skonpp is null or MZPRACPO.mz32skonpp >= ?tool.temp_datum_konec)
Pracovní poměr trvá k 31.8.2009

and year(?tool.temp_datum) = mzmzdy.mz02rok
and mzmzdy.mz02mesic < month(?tool.temp_datum)
Jen pro měsíce, které tam dle zákona patří, tj. 01-07/2009

AND (MZPRACPO.mz32nempoj =1 AND MZPRACPO.mz32pojist =2)
)
OR
(left(mzcharpp.mz72id,9) = 'SLEVA_ANO') )
p.p. zakládá účast na nem. pojištění a je typu Vše nebo má p.p. nastaven charakter 'SLEVA_ANO'

Podmínky uvnitř
zam. trvalo celý měsíc
zam. trvalo déle než 3 měsíce
nastaven charakter MALROZS
nastaven charakter SLEVA_NE
zam. je tento měsíc ve výpovědi
Ing. Olga Smitková 03.07.09

Viz.také

Sestava Mimořádná sleva - nezařazeni


Sestava Mimořádná sleva - nezařazeni

Sestava Mimořádná sleva - nezařazeni
Balíčky jsou uloženy na n:\_verze_mzdy_2009\mimoradna_sleva

Je k dispozici sestava "Mimořádná sleva - nezařazeni". Je určena jako kontrolní.

Sestava ukáže v jednotlivých měsících pracovníky, kteří mají pracovní poměr alespoň po část roku 2009, ale nevyhovuje u nich některá z dalších podmínek pro poskytnutí slevy na pojistném.

Sestava vyžaduje :
- instalaci nové verze
- nastavení atributů Doručení výpovědi a Odvolání výpovědi u těch pracovníků, kteří jsou ve výpovědi v roce 2009 (nastaví se v činnosti Další informace)

- zadání nových legislativních konstant (ručně nebo balíčkem) :
mz27spmzda - Průměrná mzda pro účely slevy na SP (číslo 20,2) v hodnotě 27100,-
mz27sppro1 - Procento rozdílu pro účely slevy na SP (číslo 6,2) v hodnotě 3,3%
mz27sppro2 - Max. procento pro účely slevy na SP (číslo 6,2) v hodnotě 25%

- nahrání předlohy emptyxlt_mimoradna_sleva.xlt

- nahrání balíčku se sestavou

Sestava se obsluhuje :
- z činnosti Prohlížení výplatních lístků
- do výběru nastavte požadovaný rozsah měsíců, např. 01/2009 - 07/2009 (za předpokladu, že zákon bude platný od 1.8.2009)
- na dotaz sestavy "První den nabytí účinnosti zákona" odpovězte 1.8.2009 (za předpokladu, že zákon bude platný od 1.8.2009)
- za každý měsíc bude vytvořen samostatný list

Sestava zatím nezahrnuje tyto situace:
- organizace je v likvidaci

Sestava existuje i ve variantě - "Mimořádná sleva - nezařazeni - bez verze"
Ing. Olga Smitková 15.07.09

Viz.také

Mzdy - mimořádná sleva na pojistném


Mzdy - Druhy událostí

Mzdy - Druhy událostí
Činnost Druhy událostí, která řídí tvorbu Událostí mezd byla upravena.

Ve druhé záložce Účty a strany se objevily nové atributy :
Platné pro účetnictví
Platné pro platby
Platné pro statistiku
Platné pro ostatní

Jejich hodnoty jsou Neurčeno, Ano, Ne.
Jestliže je nastaveno Ano, pak se příslušný řádek uplatní při spuštění šablony (událostí mezd vznikají pomocí naprogramovaných šablon).
Jestliže je nastaveno Neurčeno nebo Ne, pak s takovým záznamem daná šablona nepracuje.

Automaticky byly tyto nové atributy nastaveny tak, aby byl zachován původní smysl činnosti.
Ing. Olga Smitková 21.04.09


Karta pracovníka - externí identifikátor

Karta pracovníka - externí identifikátor
Na Kartu pracovníka byl přidán atribut externí identifikátor (MZKARTA.mz01idext).

Využívá se jako druhé OSC (osobní číslo).

Může být využíván např. v sestavách, ....

Podle externího identifikátoru lze provádět výběry a třídit.
Ing. Olga Smitková 13.03.09


Mzdy - koeficient mzdové položky

Mzdy - koeficient mzdové položky
Součástí definice mzdové položky je koeficient. Na jeho základě se vypočítá konečná částka mzdové položky. Obvykle je tento koeficient 1. Je možné ho ale přepsat na libovolnou hodnotu, např. hodnota 0,5 znamená, že se konečná částka mzdové položky vezme jen z 50-ti %.

V činnosti Pravidelné příjmy se uplatňuje individuální koeficient. Obvyklá hodnota je 0. V tom případě se totiž použije koeficient v definici mzdové položky. Pokud je uveden jiný individuální koeficient, než 0, pak se v daném pravidelném příjmu použije tento.

Nově je zavedena možnost zadat vzorec pro koeficient. V činnosti "Příjmy a náhrady" je vytvořen nový atribut - "Vzorec pro koeficient".

Předpokládáme, že "Vzorec pro koeficient" se bude používat až ve výpočtu, pro zjištění skutečného koeficientu. "Vzorec pro koeficient" může záviset na pracovníkovi, na jeho pracovním poměru, na mzdové položce v aktuálním měsíci, ...

Pokud je z hlediska obsahu vzorce možné ho v činnosti "Příjmy a náhrady" vyčíslit, pak se přímo v této činnosti zapíše, jinak zůstane na hodnotě 1 a vzorec se uplatní až později.

V činnostech Výplatní lístky, Výplatní lístky - zadávání, Prohlížení výplatních lístků je možné mzdovou položku, která má ve své definici "Vzorec pro koeficient" zadat ručně. Vlastní koeficient se vypočte podle této definice.

"Vzorec pro koeficient" se uplatní při výpočtu v kombinaci s použitím mzdové položky v Pravidelných příjmech.

Ing. Olga Smitková 24.11.08


Životní a penzijní připojištění

Životní a penzijní připojištění
Platnost od 1.1.2008

V činnosti Karta pracovníka je možné na záložce Srážky zadat srážku "Penzijní (životní) příspěvek od zaměstnavatele".
- tato srážka bude typu Částku srážet
- má zaškrtnuto "Započítávat do limitu penzijního a životního pojištění"
- tuto srážku lze pak použít na Kartě pracovníka - záložka Srážky

Ke správné funkčnosti této nové možnosti musí být dodrženo několik podmínek :

- v menu Definice - Položky mezd - Příjmy a náhrady je nutné zavést mzdovou položku, která bude představovat položku, na kterou se zapíše částka k dodanění penzijního příspěvku zaměstnavatele.
- v Legislativních konstantách je nutné mít nastavenu konstantu mz27penzli "Limit penzijního a životního pojištění" (pro rok 2008 je to 24 000,- Kč)
- v Legislativních konstantách je nutné mít nastavenu konstantu mz27penzid "Identifikace mzdové položky k dodanění penzijního příspěvku od zaměstnavatele"
- v menu Definice - Dotazy při běhu výpočtu zadat dotaz s důvodem 5 a s popisem "Penzijní a životní příspěvek je vyšší než limit pro poskytování těchto příspěvků.
1 - Poskytnout příspěvek a částečně ho dodanit pomocí další mzdové položky
2 - Poskytnout příspěvek bez dodanění"
V běžných případech bude nutno ponechat odpověď 1, odpověď 2 slouží pouze k nápravě nestandardních situací.

Na Kartě pracovníka - Volby - je činnost Další informace karty - tam je atribut mz01pznapo - Nápočet limitovaného příspěvku

Uzávěrka nakopíruje stav Nápočtu limitovaného příspěvku do Historie karty a aktualizuje Nápočet na kartě (Další informace karty). Aktualizace nápočtu proběhne tak, jak je částka zadána, tj. nikoliv v absolutní hodnotě.

Výpočet nahlásí případné překročení "Limit penzijního a životního pojištění" (z legislativních konstant) do Protokolu.

NOVĚ výpočet sám hlídá, zda došlo k překročení "Limitu penzijního a životního pojištění" a zda bude nutné část příspěvku dodanit.

Odvod samotného zaměstnance na penzijní připojištění je možné zadat na Kartě pracovníka na záložce Srážky jako běžnou srážku.
Ing. Olga Smitková 03.11.08


Zákonné pojištění odpovědnosti

Zákonné pojištění odpovědnosti
Zákonné pojištění odpovědnosti je nově přesunuto do výpočtu mezd, aby bylo možné toto pojištění odeslat do plateb spolu s ostatními platbami mezd daného měsíce.

Vypočítá se automaticky při výpočtu mezd za všechny pracovníky. Pouze v měsících 3, 6, 9, 12.

Ve výplatním lístku vzniknou u pracovníka "pomlčka" dva záznamy - I40000 - základ zákonného pojištění odpovědnosti a I41000 - odvod zákonného pojištění odpovědnosti.

POZOR ! V činnosti DEFINICE - POLOŽKY MEZD - Odvody musí být zadány položky I40000 - Základ zákonného pojištění odpovědnosti a I41000 - Odvod zákonného pojištění odpovědnosti.

V činnosti Parametry - záložka Adresáti vznikl další záznam pro pojišťovnu, do které se odesílá odvod zákonného pojištění odpovědnosti.
Výpočet mezd pracuje s tímto adresátem obdobně jako s ostatními adresáty, zde uvedenými.
POZOR ! Musíte si tedy zde vložit správného adresáta a další údaje, dle vašeho adresáře.

S vypočtenými položkami může pracovat i šablona s procesem, který odesílá mzdy do plateb. Musíte ale provést nastavení v Druhu události.

Ing. Olga Smitková 30.09.08


Konec padesátihaléřů v Čechách

Konec padesátihaléřů v Čechách
K 1.9.2008 končí používání padesátihaléřů.

Je potřeba upravit procesy, které pracují s penězi v hotovosti - s pokladnou.

Ve většině implementací je to řešeno v kódu (statickém) po ukončení na operaci komponenty OBC. V kódu je použito obzaok50(). Toto bylo nastaveno v okamžiku, kdy došlo k likvidaci desetníků a dvacetníků.

Nyní je třeba udělat úpravu a nastavit obzaok50(.F.,.F.,'',1)

Poslední parametr je parametr "mince". Nastavením parametru mince na hodnotu 1 bude docházet k zaokrouhlení na celé koruny.

Nastavení proveďte dne 1.9.2008.

Pokud jste dočetli až sem a stále nerozumíte, kontaktujte vašeho implementátora :-)

Příklad (platnost do 31.8.2008):
Prodej za 127,60 Kč (Cena bez DPH)
Základ DPH po přepočtu "na padesátihaléře" je 127,98
DPH po přepočtu "na padesátihaléře" je 11,52
Dohromady je to 139,50

Příklad (platnost od 1.9.2008):
Prodej za 127,60 Kč (Cena bez DPH)
Základ DPH po přepočtu "na celé koruny" je 128,44
DPH po přepočtu "na celé koruny" je 11,56
Dohromady je to 140,00
Ing. Olga Smitková 13.08.08


Legisl. konstanta Limit hodin pro DPP

Legisl. konstanta Limit hodin pro DPP
Do legislativních konstant byla přidána nová konstanta "Limit hodin pro DPP" - pro rok 2008 má hodnotu 150 hodin ročně (mz27limdpp - legislativní konstanta).
Do doplňujících údajů bylo přidáno zaškrtávátko Dohoda o prov.práce a nastaveno na Nezaškrtnuto (mz29dpp - doplňující údaje mzdové položky).

Pokud konstanta nebude ve verzi definována, výpočet to nahlásí a nebude pokračovat.
Pokud konstanta bude definována, ale její hodnota nebude zadána, pak výpočet nebude pokračovat.
Pokud konstanta bude definována i zadána, bude proveden test dosažení limitu hodin pro DPP.

Test :
Při výpočtu výplatního lístku se sečtou hodiny u všech mzdových položek na výplatních lístcích pracovníka, které mají zaškrtnuto "Dohoda o provedení práce".
Překročení Limitu hodin pro DPP hlášeno do Protokolu - hlášení FPD002. Do Protoklu bude též nahlášeno, že se dosažení limitu hodin pro DPP blíží - hlášení FPD003.
Kontrola probíhá v rámci zpracovávaného roku pro měsíce leden až měsíc, který se právě zpracovává.

Ing. Olga Smitková 06.08.08


Nemocenská od 1.9.2008

Nemocenská od 1.9.2008
Od 1.9.2008 se začíná vyplácet nemocenská dávka jiným způsobem.

Uživatelé musí ukončit platnost algoritmu A08A2 v činnosti PARAMETRY NEMOC. POJIŠTĚNÍ -Platnost algoritmu v období. Ukončení je třeba nastavit ke dni 31.8.2008

Kromě ukončení algoritmu původního (viz výše) může uživatel vše ostatní nastavit pomocí balíčku.

Pozor, tentokrát i nemoci, které začaly 30.8. nebo 31.8. se CELÉ počítají podle staré úpravy, tj. 60% za první 3 dny.

Ing. Olga Smitková 07.08.08


Změna WWW adres ČNB

Změna WWW adres ČNB
Na webových stránkách stránkách ČNB se objevila tato informace:
----------------------------------------------------------------------------------------------
Upozorňujeme uživatele webových stránek ČNB, že k 1.9.2008 bude ukončeno dosavadní automatické přesměrovávání url adres používaných v minulosti na webu ČNB na adresy platné v současnosti. Týká se to adres začínajících wdb.cnb.cz/... a adres začínajících na www.cnb.cz/cz/. Veškeré v současnosti platné adresy začínají www.cnb.cz/cs/ resp. www.cnb.cz/en/. Žádáme zejména uživatele, kteří si stahují kurzy devizového trhu v txt formátu, aby tuto změnu promítli do svých automatizovaných systémů.

Samostatný odbor komunikace ČNB
----------------------------------------------------------------------------------------------

V souvislosti s touto informací byly do návodů a balíčků vloženy aktualizované externí příkazy pro načtení kurzů ČNB.
Ing. Petr Filip 12.08.08


ELDP - kódy 71 a 72

ELDP - kódy 71 a 72
V rámci ELDP hlášení se uvádí i údaj Typ ELDP.

Bílý Motýl doposud pracoval s typy 01, 51, 02, 52. Nově pracuje i s typem 71 a 72.

Typ 71 - se uvádí v případech, kdy ELDP za daný kalendářní rok, jehož označení mělo vykazovat hodnotu 01, vyhotoven nebyl, a je vyhotovován dodatečně po uplynutí jednoho a více kalendářních roků, jehož se vyplňované údaje týkají (např. na ELDP vyhotovovaném v roce 2006 za rok 2004 se již uvede hodnota 71)

Typ 72 - se uvádí v případech, kdy ELDP za daný kalendářní rok, jehož označení mělo vykazovat hodnotu 02, vyhotoven nebyl, a je vyhotovován dodatečně po uplynutí jednoho a více kalendářních roků, jehož se vyplňované údaje týkají (např. na ELDP vyhotovovaném v roce 2006 za rok 2004 se již uvede hodnota 72)

Zavedená podmínka zní :
Jestliže je počet ELDP vytvořených pro rok zpracování nulový, tj. nebylo ještě vytvořeno žádné ELDP pro daného pracovníka v daném roce a zároveň rok zpracování+1 < aktuální rok, pak použij kód 71 nebo 72 (dle ukončení či neukončení pracovního poměru)

Ing. Olga Smitková 30.06.08


Nemocenská od 30.6.2008

Nemocenská od 30.6.2008
Od 30.6.2008 se začíná vyplácet nemocenská dávka jiným způsobem.

Uživatelé musí ukončit platnost algoritmu A08A v činnosti PARAMETRY NEMOC. POJIŠTĚNÍ -Platnost algoritmu v období. Ukončení je třeba nastavit ke dni 27.6.2008

Na období 28.6. a 29.6. se budou vztahovat dva speciální přechodné algoritmy a od 30.6. bude plati algoritmus nový.

Kromě ukončení algoritmu původního (viz výše) může uživatel vše ostatní nastavit pomocí balíčku.

Ing. Olga Smitková 10.06.08


Mzdy - nová hodnota ročního daň. bonusu

Mzdy - nová hodnota ročního daň. bonusu
Informace pro zákazníky, implementátory a distributory :

pokud jste již provedli roční zúčtování za rok 2007, pak si v činnosti Parametry nastavte novou hodnotu Maximálního ročního bonusu (52 200) pro rok 2008!
Ing. Olga Smitková 03.04.08


Název artiklu a názvy selektorů

Název artiklu a názvy selektorů
V BM byly zvětšeny délky položek název artiklu, název organizačního selektoru, název obchodního selektoru a název technicko-věcného selektoru ze 40 na 60 znaků.

Po této změně mohou nastat problémy s funkcí implementačních rozšíření - zejména uživatelských triggerů.
Pro vyhledání uložených procedur a triggerů, které by mohly způsobit problémy, byl do návodů a balíčků doplněn externí příkaz 'Výskyt textu v procedurách a triggerech'.
Ing. Petr Filip 21.03.08


Penzij. a život. pojištění v roce 2008

Penzij. a život. pojištění v roce 2008
Pravidla pro používání penzijního a životního připojištění ve mzdách :

- přestat používat srážku "Penzij. poj. s daňovým limitem" - platila jen do 31.12.2007

- v Legislativních konstantách nastavit konstantu mz27penzli - Limit penzijního a životního pojištění - hodnota je 24000,-

- na Kartě pracovníka - Volby - je nová činnost Další informace karty - a tam je nový atribut mz01pznapo - Nápočet limitovaného příspěvku

- Výpočet nahlásí případné překročení Limitu (z legislativních konstant), nahlásí se do Protokolu

- Uzávěrka nakopíruje stav Nápočtu limitovaného příspěvku do Historie karty a aktualizuje Nápočet na kartě (Další informace karty). Aktualizace nápočtu proběhne tak, jak je částka zadána, tj. nikoliv v absolutní hodnotě.

- v menu DEFINICE - POLOŽKY MEZD - Srážky nastavit zaškrtávátko "Započítávat do limitu penzijního a životního pojištění" u mzdové položky "Odvod připojištění firma".

Ing. Olga Smitková 17.12.07


Výdeje z pokladny do mínusu

Výdeje z pokladny do mínusu
Výdeje z pokladny do mínusu lze hlídat pomocí nové úpravy.

V komponentě změna stavu peněz je nutné nastavit v nové činnosti "Základní druhy hodnot" hodnotu množství ve finančním vyjádření na jednu z aktuálních hodnot (obvykle je to hodnota STU). Pokud zde hodnota nastavena nebude, program nebude níže uvedenou kontrolu provádět.

V činnosti "Vlastní účty/pokladny" je atribut "Debet". Tento atribut se nastaví v činnosti "Bankovní spojení adresátů".

Potom na události změny stavu peněz dojde k následující kontrole :

Jestliže není zaškrtnuto, pak se při zadání debetu poklady kontroluje stav pokladny (podle aktuální hodnoty uvedené viz výše). Pokud by se provedením debetu dosáhlo záporných hodnot v pokladně, program zobrazí chybové hlášení a neumožní takovou událost zapsat.

Jestliže je zaškrtnuto, pak se stav pokladny (podle aktuální hodnoty uvedené viz výše) nekontroluje.
Událost bude zapsána tak, jak je.
Ing. Olga Smitková 26.07.07

Viz.také

Výběr zajímavých novinek


Penzijní připojištění ve mzdách

Penzijní připojištění ve mzdách
Platnost pouze do 31.12.2007

V činnosti Karta pracovníka je možné na záložce Srážky zadat příspěvek zaměstnavatele na penzijní připojištění dvojím způsobem:

a) použijeme srážku, která má v definici uvedeno Srážet - Procento ze základu SP (pozn. toto procento musí být menší než 5%)

b) NOVĚ je možné použít srážku, která má v definici uvedeno Srážet - Penzij. poj. s daňovým limitem. Program pak bude sám hlídat, zda došlo k překročení hranice 5% ze základu SP a zda bude nutné část příspěvku dodanit.

Ke správné funkčnosti této nové možnosti musí být dodrženo několik podmínek :

- v menu Definice - Položky mezd - Příjmy a náhrady je nutné zavést novou položku, která bude představovat položku, na kterou se zapíše částka k dodanění penzijního příspěvku zaměstnavatele.
- v legislativních konstantách je nutné zavést konstantu mz27penznu N3 - procento jako hranice, od které je nutné "Penzijní příspěvek od zaměstnavatele" dodaňovat
- v legislativních konstantách je nutné zavést konstantu mz27penzid Text - identifikace mzdové položky k dodanění penzijního příspěvku od zaměstnavatele
- v menu Definice - Položky mezd - Srážky - zavést srážku "Penzijní příspěvek od zaměstnavatele" s typem Penzij. poj. s daňovým limitem (překryvný seznam). Tuto srážku lze pak použít na Kartě pracovníka - záložka Srážky.
- v menu Definice - Dotazy při běhu výpočtu zadat dotaz s důvodem 4. Tento dotaz nebude pravým dotazem, ale bude pouze oznamovat, že došlo k situaci, při které se bude část "Penzijního příspěvku od zaměstnavatele" dodaňovat. Platná odpověď je 1.

Odvod samotného zaměstnance na penzijní připojištění je možné zadat na Kartě pracovníka na záložce Srážky jako běžnou srážku.
Ing. Olga Smitková 05.06.07


Mzdy - souhrnné daňové tabulky

Mzdy - souhrnné daňové tabulky
Práce s daňovými tabulkami byla zcela změněna.

Doposud se používaly formuláře Měsíční daňová tabulka, Daňová tabulka bez prohlášení. V kombinaci s údaji na Kartě pracovníka a s výší příjmu se během výpočtu jedna z těchto tabulek použila. Tyto formuláře zaniknou. Též zanikne formulář Roční daňová tabulka.

Jako náhrada vznikne nový formulář Daňové tabulky souhrnné.
Tyto daňové tabulky je možné nahrát balíčkem.
Formulář má na první záložce uvedenu identifikaci daňové tabulky, druh měsíční/roční a dále popis a komentář.
Na druhé záložce jsou uvedeny vlastní hodnoty jednotlivých řádků tabulky. Jsou zde již známé atributy - dolní a horní hranice, pevná část, sazba.

Nově se uvádí u každého řádku Typ vzniklé daně (zálohová, srážková, roční zúčtování). Tento typ určuje, zda na základě této řádky vznikne mzdová položka L11000 (Daň zálohová), L21000 (Daň srážková) nebo L41000 (Vyrovnání přeplatku na dani).

Nový je též atribut Platnost od, který určuje platnost daného řádku.

POZOR !
Pokud se daňová tabulka v dalším roce nemění, je možné ponechat VŠECHNY záznamy tak jak jsou uvedeny. Např. máme zadány záznamy s platností od 1.1.2006, tyto VŠECHNY budou platit i v roce 2007.
Pokud se daňová tabulka v následujícím roce částečně nebo zcela mění, je nutné znovu vložit VŠECHNY řádky tabulky, tedy i ty, které se nezměnily, s novou Platností od. Např. pokud od 1.1.2007 bude platit nová daňová tabulka, je třeba ji zadat k tomuto datu zcela znovu, nelze předpokládat, že řádky, jejichž údaje se nezměnily a jsou s platností od 1.1.2006, zůstanou platné.
Program vyhledá vždy k dané identifikaci tabulky záznamy s takovou platností od, která je nejblíže zpracovávanému období. Na ostatní řádky tabulky nebere zřetel.

Na Kartě pracovníka přibude atribut mza7id, což je vazba na tabulku MZDANHLA.
Karta pracovníka tak bude obsahovat informaci, která daňová tabulka se u zaměstnance použije.

Příklady nastavení tabulek pro rok 2007
MZDANPOL

Zálohová daňová tabulka 2007

Od Do Pevná % Typ daně Identifikace Platnost od
0 10 100 0 12 zálohová DPM001 1.1.2006
10 101 18 200 1 212 19 zálohová DPM001 1.1.2006
18 201 27 600 2 751 25 zálohová DPM001 1.1.2006
27 601 9999999 5101 32 z álohová DPM001 1.1.2006

Zálohová a srážková daňová tabulka kombinovaná 2007

Od Do Pevná % Typ daně Identifikace Platnost od
0 5000 0 15 srážková DKM001 1.1.2006
5001 31 100 1000 20 zálohová DKM001 1.1.2006
31 101 999999 6 221 32 zálohová DKM001 1.1.2006

Pozn. Pevná částka 1000 ve druhé řádce vznikla jako 20% z částky 5000.

Srážková daňová tabulka pro cizince 2007

Od Do Pevná % Typ daně Identifikace Platnost od
0 999999 0 25 srážková DNC001 1.1.2006

Zálohová daňová tabulka bez prohlášení 2007 (tato tabulka se nebude používat, nahrazuje ji tabulka DKM001)

Od Do Pevná % Typ daně Identifikace Platnost od
0 31 100 0 20 zálohová DNM001 1.1.2006
31 101 999999 6 221 32 zálohová DNM001 1.1.2006

Roční daňová tabulka 2006

Od Do Pevná % Typ daně Identifikace Platnost od
0 121 200 0 12 Roční_zúčt. DPR001 1.1.2006
121 201 218 400 14 544 19 Roční_zúčt. DPR001 1.1.2006
218 401 331 200 33 012 25 Roční_zúčt. DPR001 1.1.2006
331 201 9999999 61 212 32 Roční_zúčt. DPR001 1.1.2006

Ing. Olga Smitková 05.04.07

Viz.také

Výběr zajímavých novinek


Mzdy - kalendáře nepravidelné

Mzdy - kalendáře nepravidelné

Při používání denních kalendářů existují dvě možnosti :
1) pravidelný kalendář, ve kterém se nemění úvazek jednotlivých dnů, tj. pracovní doba připadající na jeden den je vždy stejná, např. 8 hod

2) nepravidelný kalendář, ve kterém se úvazek ke každému dni určuje zvlášť, tj. pracovní doba připadající na jeden den může být jiná než v jiný den tohoto kalendáře

V činnosti DEFINICE - Pracovní doba - na první záložce se určuje typ denního kalendáře. Na druhé záložce jsou pak rozepsány údaje k jednotlivým dnům.

Používání denních kalendářů typu "Ke každému dni zvlášť " má několik logických úskalí :
1) pokud používáte na Kartě pracovníka Pravidelné příjmy, pak se k použití u pracovníka s tímto kalendářem nehodí možnosti 2 a 3 (Dopočíst do FPD dle hodin, Součet odpracovaných). Může dojít k chybnému dopočtení počtu pracovních dnů.
2) Při uzávěrce mezd předpokládáme, že pracovník s tímto kalendářem nemá pravidelný kalendář, a tudíž se mu mění úvazek.
3) Doporučujeme v Parametrech používat Způsob výpočtu denního průměru - "Dle odpracovaných dnů" a nikoliv "Dle úvazku" (je zde hlášení do Protokolu). Pokud přesto chcete používat v Parametrech Způsob výpočtu denního průměru "Dle úvazku", pak pracovníci, kteří mají tento kalendář budou zpracováni tak, jako by bylo nastaveno "Dle odpracovaných dnů".

Programová úprava zasahuje do těchto oblastí :
1) Vkládání mezd
2) Vkládání úkolových lístků
3) Optimalizovaný výpočet mezd
4) Uzávěrka - přepočet průměrů
5) Uzávěrka - přepočet průměru na nemoc
6) Generování kalendářů denních

Do Protokolu jsou nově zařazena hlášení PRAVI4, PRUM08

PRAVI4 - Pravidelné příjmy 04.
NEVHODNÉ použití pravidelného příjmu. Pracovník má Denní kalendář typu Zvlášť ke každému dni,
a proto je NEVHODNÉ použít u mzdové položky ….. tento typ pravidelného příjmu.
Zkontrolujte počet hodin a dnů! Vhodnější je typ pravidelného příjmu ... odděleně ve dnech a hodinách.'

PRUM08 - Průměry 08
Pracovník má denní kalendář typu zvlášť. Výpočet se provede dle odpracovaných dnů.
Ing. Olga Smitková 23.02.07

Viz.také

Výběr zajímavých novinek


Mzdy - srážky - typ vzorcem

Mzdy - srážky - typ vzorcem
Mezi možné definice srážek přibyla srážka typu vzorcem.

Doposud byly používané srážky typu (atribut mz28srazet):

1 Částku srážet
2 Procento z HP
3 Vše k výplatě
4 Procento z ČP(odbory)
5 Částku vyplatit
6 Procento ze základu SP

Nová možnost (sedmá) je Vzorcem

Zadáte-li tuto srážku do DEFINICE - POLOŽKY MEZD - Srážky - musíte uvést též vzorec (atribut mz28vzorec), např. mz02kc_j * mz02vykon.

Srážka je použitelná pouze jako ruční, tj. nelze ji zadat v Kartě pracovníka - záložka Srážky, ale pouze v činnosti Všechny výpl. lístky-zadávání. Pokud se najde využití, bude zapracována i pro použití na Kartě pracovníka.

Při použití srážky vzorcem dojde k přenosu hodnoty Kč/j do činnosti Všechny výpl. lístky-zadávání.

Ing. Olga Smitková 13.02.07


Událost skladové evidence

Událost skladové evidence
Výpočet ceny váženým průměrem při výdeji ze skladu artiklu s uvedeným výrobním číslem je možné nastavit v souboru je možné nastavit v souboru BW.INI v sekci [Sklad] parametrem CenaVC.

Při nastavení CenaVC=1, potom je použita průměrná cena příjmů a výdejů artiklů na stejný sklad se stejným výrobním číslem.
Při nastavení CenaVC=0, potom je použita průměrná cena příjmů a výdejů artiklů na stejný sklad s libovolným výrobním číslem.

Není-li parametr uveden, probíhá výpočet jako kdyby CenaVC=0.
Ing. Petr Filip 09.11.01


Fiktivní příspěvek pro info-mail

Fiktivní příspěvek pro info-mail
Kateřina Folvarská 10.06.16


Fiktivní příspěvek

Fiktivní příspěvek
- potřebuji ho k vytvoření hlavičky infomailu
Kateřina Folvarská 01.05.16


Fiktivní příspěvek

Fiktivní příspěvek
- potřebuji ho k vytvoření hlavičky infomailu
Kateřina Folvarská 09.05.16


Fiktivní příspěvek

Fiktivní příspěvek
- potřebuji ho k vytvoření hlavičky infomailu
Kateřina Folvarská 15.04.16


Fiktivní příspěvek

Fiktivní příspěvek
- potřebuji ho k vytvoření hlavičky infomailu
Kateřina Folvarská 13.03.16


fiktivní příspěvek

fiktivní příspěvek
- potřebuji ho pro vytvoření hlavičky infomailu
Kateřina Folvarská 05.01.16


fiktivní příspěvek

fiktivní příspěvek
Kateřina Folvarská 01.12.15


Fiktivní příspěvek

Fiktivní příspěvek
- potřebuji ho pro vytvoření hlavičky infomailu
Kateřina Folvarská 20.11.15


Fiktivní příspěvek

Fiktivní příspěvek
- potřebuji ho pro vytvoření hlavičky infomailu
Kateřina Folvarská 01.11.15


Fiktivní příspěvek

Fiktivní příspěvek
- potřebuji ho k vytvoření hlavičky infomailu
Daniela Postlová 01.09.15


Fiktivní příspěvek

Fiktivní příspěvek
- potřebuji ho pro vytvoření hlavičky infomailu
Daniela Postlová 10.05.15


příspěvek pro zapsání bulletinu

příspěvek pro zapsání bulletinu
- nejde mi zapsat březnový bulletin, resp. nechce se vytvořit hlavička procesu, když za dané období není žádný příspěvek s tématem opt121, musela jsem si jeden pokusný vytvořit sama
Daniela Postlová 16.02.15


EV: bm_overeni_uzivatele_hash

EV: bm_overeni_uzivatele_hash
Do EV jsem přidal funkci: bm_overeni_uzivatele_hash

Popis:
// Ověřuje uživatele (tabulka BWUZIVAT) dle zadaného hesla pomocí HASHe (atribut bw01hhesh)
//
// Způsob "HASHování" a způsob uložení HASHe se nastavuje v SYSTÉM->Nastavení programu BM:
// Sekce: Preferences, Parametr: PasswordHashAlgorithm, PasswordHashHexa (tabulka BWOPTION)
//
// Parametry:
// @uzivatel ... identifikce uživatele (atribut bw01uziv) - implicitní, je-li délka <=6
// / jméno uživatele (atribut bw01jmeno) - implicitní, je-li délka >6, popř. #J v parametru @zpusob
// @heslo ... heslo uživatele
// @zpusob ... určuje chování funkce, může obsahovat řídící znaky:
// #J - paramter @uzivatel je jméno uživatele (atribut bw01jmeno)
// #N - neprovádi se převod hesla na malá písmena (v IS BM jsou uložena hesla malými písmeny)
// #M - při chybě zobrazení oznámení (MESSAGE TYPE WARNING TO CLIENT)
// #R - při chybě chyba ODBC (RAISERROR )
// #H: - způsob "HASHování", není-li uvedeno, potom se řídí parametrem PasswordHashAlgorithm pro hodnoty: 1,2,5,50
// kde může mít hodnoty: MD5,SHA1,SHA1_FIPS,SHA256,SHA256_FIPS
// #U: - způsob uložení HASHe v IS BM, není-li uvedeno, potom se řídí parametrem PasswordHashHexa
// kde může mít hodnoty: B(binárně),H(hexadecimálně)
//
// Návratové hodnoty:
// 1 ... OK
// 0 ... : Chybné heslo (RAISERROR 23000)
// -1 ... : Uživatel nenalezen (RAISERROR 23001)
// -2 ... : Uživatel nemá vygenerovaný HASH (RAISERROR 23002)
// -3 ... : Nepodporovaný typ HASHe (Parametr PasswordHashAlgorithm) (RAISERROR 23003)
Michal Struska 31.10.14


Předplnění účtu adresáta

Předplnění účtu adresáta
Vznikly 2 doplňující vlastnosti BINDBU v adresáři a v bankovních spojeních: předplnění banky a účtu při zadání * do kódu banky a po založení adresáta.
Michal Struska 09.10.14


Práce s exekucemi ve mzdách

Práce s exekucemi ve mzdách
Pro speciální případy exekucí z více pracovních poměrů u různých zaměstnavatelů, nebo z více různorodých rent od jiných plátců byla vyvinuta tato úprava.

Pokud vaši zaměstnanci s exekucemi mají pracovní poměr pouze u vás, nemusíte nic nastavovat.

Při zpracování exekucí v rámci výpočtu mezd se pracuje s nezabavitelnou částkou na poplatníka, případně na vyživované osoby.
Zaměstnanec ale může pobírat mzdu od více plátců.
V tom případě platí: Pobírá-li povinný mzdu od více plátců, vztahuje se nařízená exekuce na všechny jeho mzdy či příjmy, s nimiž se pro účely srážek nakládá jako se mzdou.

Objevil se reálně případ, kdy od soudu přišlo rozhodnutí o exekuci a v tomto rozhodnutí bylo výslovně řečeno, že se povinnému nemá uplatnit nezabavitelná částka z důvodu, že pobírá rentu od ministerstva vnitra a tato pokrývá nezabavitelnou část mzdy.

Popis nastavení:
Na Kartu pracovníka - záložka Osobní údaje byl přidán nový atribut - Brát v úvahu nezabavitelnou částku ? - Ano, Ne, implicitně Ano, (mz01exekuc)
Nastavení bude platit pro VŠECHNY exekuce daného pracovníka!
Optimalizovaný výpočet provede výpočet výše exekuce s ohledem na toto nastavení.

Uzávěrka zapisuje Historii karty pracovníka - do historie karty se bude tento nový atribut zahrnovat.

Příklad:
Démonia 5/2015
21/2015 Nastoupil u nás zaměstnanec, který je poživatelem starobního důchodu. Zároveň na něj přišel exekuční příkaz, v kterém je uvedeno, že nezabavitelné částky pro účely srážek ze mzdy se uplatňují u plátce důchodu. Jak máme postupovat při provádění srážek ze mzdy?

V tomto případě se jedná o více plátců příjmů a exekutor nařídil podle § 298 odst. 1 OSŘ, že nezabavitelné částky budou uplatněny u důchodu. Zaměstnavatel v tomto případě postihne celou čistou mzdu zaměstnance. Tzn., že ji nejprve porovná s částkou 9177 Kč a to, co je nad ní srazí celé a potom ještě jednu nebo dvě třetiny. V případě nižší čisté mzdy než 9177 Kč se srazí jedna nebo dvě třetiny z této částky.

Ing. Olga Smitková 22.09.11


Parametry polí formulářů

Parametry polí formulářů
Ve formuláři 'Parametry polí formulářů' :
- na první záložce se tak jako doposud definuje 'Funkce automatického dokončování'
- na druhé záložce se nově definují skripty v jazyce Foxpro daného pole formuláře

Na na druhé záložce nazvané 'Skripty pole' se zadává:
- typ skriptu - překryvný seznam - zatím je aplikován jediný typ skriptu 'Reakce na F2'
- skript - text - obsahuje kód v jazyce Foxpro
- poznámka

Pro uplatnění skriptů vzhledem k uživateli vedeném u skriptu platí totéž, co platí v tomto smyslu pro 'Funkce automatického dokončování':
Takto definované parametry, jsou specifické pro dané pole daného formuláře pro aktuálně přihlášeného uživatele systému.
Uživatel s právy správce systému má možnost aktivovat funkci automatického dokončování pro dané pole daného formuláře pro všechny uživatele systému založením parametrů pro uživatele SYSTÉM.
Pokud je pro pole definováno Globální nastavení parametrů a zároveň nastavení parametrů uživatele, potom se uplatňuje nastavení uživatele.

Skript typu 'Reakce na F2' se provádí na vstupním poli formuláře po stisku klávesy F2 resp. po pravém kliku myší.
Tomuto skriptu jsou předávány parametry (ve skriptu se neuvádí příkaz PARAMETER):
- _this - objekt, na kterém uživatel stiskl klávesu F2
- _thisform - objekt formuláře

Skript musí vracet hodnotu:
- .T. - TRUE - v případě, že skript proběhl a nemá být provedena funkce, která je pro 'Reakci na F2' naprogramována v BM.EXE
- .F. - FALSE - v případě, že skript neproběhl a má být provedena funkce, která je pro 'Reakci na F2' naprogramována v BM.EXE

Jediný společný skript je určen pro pole umístěná v mřížce a pro pole na stránce formuláře.
Pokud nemá být skript proveden pro pole v mřížce, může být tato potřeba ošetřena na začátku skriptu např. kódem:
IF UPPER(_this.parent.baseclass)='COLUMN'
    RETURN .F.
ENDIF

Příklad skriptu, který po pravém kliku myší na datumu události obchodu v gridu vyvolá kalendář a potom zapíše do události vrácenou hodnotu:
Local _ret
Do Case
Case !_thisform.komp_stav
    * když se nejedná o spuštěnou operaci, provede se obvyklá akce po F2 naprogramovaná v BM.EXE
    Return .F.
Case _thisform._o_kompo_.ukoncena
    * když se jedná o ukončenou operaci, provede se obvyklá akce po F2 naprogramovaná v BM.EXE
    Return .F.
Case _thisform._o_kompo_.sp07idtypd<>'PROCES'
    * když se nejedná o operaci druhu procesu 'PROCES', provede se obvyklá akce po F2 naprogramovaná v BM.EXE
    Return .F.
Case Upper(_this.Parent.BaseClass)<>'COLUMN'
    * když se nejedná o pole v mřížce, provede se obvyklá akce po F2 naprogramovaná v BM.EXE
    Return .F.
Endcase
If Val(Tool.get_prof('','CalendarXP','1',.T.))=1
    Do bw_prika With [Do Form bw_gdate With _p1,.T. to _p2],_this.Value,_ret
Else
    Do bw_prika With [Do Form bw_gdatx With _p1,.T. to _p2],_this.Value,_ret
Endif
If Type('_ret')$'TD' And _ret<>Nvl(_this.Value,{})
    _this.Value=_ret
    _thisform._pf_.p1.ob02datdod.Value=Max(_thisform._pf_.p1.ob02datdod.Value,_ret)
    _thisform._pf_.p1.ob02dat.Refresh
    If !_thisform._edit
        _thisform.formakce('=')
    Endif
Endif
* když skript nevrátí hodnotu .F. ('RETURN .T.' nemusí být uveden, protože skript, který nebyl ukončen příkazem RETURN, vždy vrací hodnotu .T.),
* tak se neprovede obvyklá akce po F2 naprogramovaná v BM.EXE

Ing. Petr Filip 22.03.11


Různé změny formulářů

Různé změny formulářů
Byly provedeny tyto změny formulářů:
Formulář 'Uživatelské triggery' je nyní možné neomezeně zvětšovat
Formulář 'Hypertextové odkazy' (týká se Informačních panelů) byl dopněn o výběrovou záložku
Ing. Petr Filip 22.03.11


Výrobní úkoly

Výrobní úkoly
Byla opravena funkce 'Předplnění vstupů a výstupů', která se používá ve formuláři 'Výrobní úkoly' pro naplnění vstupů a výstupů výrobního úkolu na záložce 'Vstupy a výstupy'.
Tato funkce nepředplňovala identifikaci stroje v záznamu od vstupu/výstupu a nyní jí předplňuje.
Ing. Petr Filip 17.03.11


Funkce automatického dokončování

Funkce automatického dokončování
Ve formuláři 'Parametry polí formulářů' přibyl atribut 'Počet řádků', kterým je možné nastavit počet zobrazovaných řádků v seznamu návrhů 'Funkce automatického dokončování'.
'Počet řádků' udává maximální počet zobrazovaných řádků, při užití 'Funkce automatického dokončování' může být počet řádků zobrazených v seznamu návrhů menší v závislosti na výšce okna aktuálního formuláře.
Ing. Petr Filip 22.02.11


Intrastat

Intrastat
Vzdálenou funkcí je možné stáhnout definice pro generování Intrastatu v roce 2011.

Klikněte na 'Spustit vzdálenou funkci' pro spuštění vzdálené funkce.
Ing. Petr Filip 11.02.11


Nepřítomnosti - zaškrtávátko u částky

Nepřítomnosti - zaškrtávátko u částky
V Nepřítomnostech pro nemoc je na záložce Dávka u atributu Částka zaškrtávátko Nepřepočítávat.

Pokud vyplníte nějakou částku a zaškrtnete ho (pravděpodobně chcete výpočtu vnutit svou vlastní částku pro náhradu mzdy za nemoc), projeví se to pouze u Náhrady mzdy. Na evidenci OČR, MD a RD nemá toto zaškrtávátko vliv.

Nemocenské dávky jako OČR, RD, MD zaměstnavatel již delší dobu nepropácí, pouze je eviduje. Proplácí Náhradu za nemoc a to není dávka.

Ing. Olga Smitková 09.02.11


Korektor transformovaných dat

Korektor transformovaných dat
Korektor transformovaných dat je nyní možné definovat také u druhu operace (doposud ho bylo možné definovat jenom u druhu procesu).

V případě, že je korektor definován u druhu procesu i u druhu operace, potom se nejdříve provádí kód korektoru uvedeného u druhu procesu a potom se provádí kód korektoru uvedeného u druhu operace.
Ing. Petr Filip 10.01.11


Sestava Odsouhlasení údajů na kartě

Sestava Odsouhlasení údajů na kartě
Sestava slouží k odsouhlasení údajů uvedených na Kartě, jako např. srážky, exekuce, slevy na dani, zdravotní pojišťovna, ...
Sestava je určena pro pracovníka, který údaje písemně potvrdí nebo doplní podle skutečnosti.

Každému pracovníkovi se vytiskne jeden list s údaji a on ho podepíše, případně upraví.
Ing. Olga Smitková 28.01.11


Mzdy - náhrada do účetnictví

Mzdy - náhrada do účetnictví
Při vytváření událostí mezd pro účely účetnictví docházelo k chybám vlivem zaokrouhlování poloviny Náhrady mzdy.

K nápravě situace potřebujete novou verzi a speciální přenastavení Druhu událostí pro Náhradu mzdy.

V činnosti Druhy událostí na druhé záložce přibyl atribut Zaokrouhlení (mz69zaok) s hodnotami Ne,Ano+,Ano-
Tento atribut nemá žádný automatický význam, jeho význam je vždy nutné naprogramovat.

Šablona vypočte zaokrouhlení a pro řádky s "Ano+" vytvoří událost na "pomlčkového" zaměstnance s hodnotou +0,50 Kč.
Šablona vypočte zaokrouhlení a pro řádky s "Ano-" vytvoří událost na "pomlčkového" zaměstnance s hodnotou -0,50 Kč.

Nastavení Druhů událostí na Náhradě mzdy:
2 varianty
1. dává 100% náhrady na 521/331 a 50% náhrady 336/524
2. dává 50% náhrady 521/331, 50% náhrady na 336/331

Pro 1. bude 521/331 NE, 336/524 ANO+ a bude fungovat i pro kombinaci společníků a zaměstnanců - pouze přibyde 522/366 NE
Pro 2. bude 521 ANO-/331 NE, 336 Ano+/331 NE a pro kombinaci společníků a zaměstnanců - přibyde 522/366 NE a 336/366 NE, tj. opravíme o 0,50 Kč účet 521 i kdyby měl náhradu za nemoc pouze společník!
Ing. Olga Smitková 06.12.10


Pravidla inicializací přístupových práv

Pravidla inicializací přístupových práv
Ve formuláři 'Pravidla inicializací přístupových práv' přibyl atribut:
Uplatnění - text - uvádí se v něm seznam typů práv, pro které se má pravidlo uplatnit

Příklad implementace:
Do BM mají přístup uživatelé, kteří mají v systému významně omezená práva tj. nejsou členy skupiny $KAZDY - jsou členy skupiny EXTERN.
Tito uživatelé by měli mít možnost tisku faktur a sestav skladových pohybů.

Pro tuto potřebu definujeme pravidlo:
Identifikace pravidla = '______'
Typ pravidla = kopie práva
Priorita = 999
Uplatnění = 'TSK,TUO,TUP,OBC,DPH,PLA'

K tomuto pravidlu definujeme přískupová práva pro skupiny uživatelů:
$KAZDY = zápis
EXTERN = čtení

Potom při založení nového skladu, umístění obchodu, umístění plateb nebo nové operace obchodu, DPH a plateb budou automaticky přidělana práva skupinám uživatelů:
$KAZDY = zápis
EXTERN = čtení

Ing. Petr Filip 29.12.10


"Příloha k žádosti o (89 6213)"

"Příloha k žádosti o (89 6213)"
Do bulettinu:

Sestava "Příloha k žádosti o (89 621 3) " byla upravena tak, aby reagovala na situaci, kdy v rozhodném období není vyměřovací základ nebo tam jsou jen vyloučené doby a musí se tedy hledat zpětně rok, ve kterém byl dosažen započitatelný příjem.

Popis:
a) Sestava v případě, že pracovník měl v rozhodném období vyměřovací základ, pracuje standardně.

b) V případě, že ne, např. se jedná o nemoc po rodičovské nebo mateřské dovolené, pak sestava "couvá" vždy o rok, o další rok, …. Tak dlouho, dokud se nenajde vyměřovací základ.
Zjistit, zda jsou v rozhodném období pouze vyloučené doby je příliš složité. Proto sestava na řádku 10 pouze nahlásí "Pracovník měl naposledy vyměřovací základ v roce ……".
Obsluha pak musí excelovou sestavu doplnit, podle údajů ze zjištěného roku.

Pozn.: Do sestavy je zabudována zvláštnost firmy Eaton, a to že položku M60000 používají jako rodičovskou dovolenou.

Ing. Olga Smitková 16.11.10


Artikly výroby

Artikly výroby
Ve formuláři "Artikly výroby" se nově vstupuje položka celního sazebníku.
Ing. Petr Filip 08.11.10


Druhy procesů a operací

Druhy procesů a operací
Ve formuláři 'Druhy procesů' byly provedeny tyto změny:
- bez náhrady byla zrušena záložky 'Export' a s ní spojená funkčnost (v žádně implementaci se nepoužívala)
- přibyla nová záložka 'Popisné info'

Na záložce 'Popisné info' formuláře 'Druhy procesů' je možné definovat několik záznamů popisné informace spojené s druhem procesu:
- Význam - identifikátor významu položky obecné předkontace - součást primárního klíče
- Volný text - identifikátor volného textu
- Kód - kód v jazyce Foxpro
- Datum 1 - datum
- Datum 2 - datum
- Text 1 - text
- Text 2 - text
- Num1 - číslo
- Num2 - číslo
- Poznámka

Ve formuláři 'Druhy operací přibyla nová záložka 'Info', na které je možné definovat několik záznamů popisné informace spojené s druhem operace:
- Význam - identifikátor významu položky obecné předkontace - součást primárního klíče
- Volný text - identifikátor volného textu
- Kód - kód v jazyce Foxpro
- Datum 1 - datum
- Datum 2 - datum
- Text 1 - text
- Text 2 - text
- Num1 - číslo
- Num2 - číslo
- Poznámka

Nová verze knihovny SYSPDF, která se používá při tisku dokladů procesů do souborů PDF a ISDOC, používá 'Popisné informace' uvedené u tištěného druhu procesu pro sestavení emailu.
Používá 'Popisné informace' s těmito významy:
EMAIL1 - určení Příjemce zprávy
EMAIL2 - určení Předmětu zprávy
EMAIL3 - určení Textu zprávy

Příklad popisné informace významu EMAIL3:
'Volný text' definuje text:
Fakturujeme Vám:<br>
Faktura číslo: <<spprc_sp33cisdr>>-<<spprc_sp33cisdpm>>-<<spprc_sp33cisd>><br>
VS: <b><i><<alltrim(pluda_pl02vs)>></i></b><br>
Cena: <b><<alltrim(trans(pluda_pl02czm,'999 999 999.99'))>></b><br>
<br>
<br>
<h5>Seznam dodaného zboží:</h5>
<br>
##TABLE##
<br>

'Kód' obsahuje kód v jazyce Foxpro:
* Knihovna SYSPDF volá tento kód s parametry:
* _THIS = objekt, který provádí výstup do PDF
* _RIDIC = řídící objekt tisku
* _SP89OBSAH = text Volného textu
* _DATA = objekt s atributu záznamu 'Popisné informace' mj. _DATA.SPH1DAT1, _DATA.SPH1DAT2, _DATA.SPH1TEXT1, _DATA.SPH1TEXT2, _DATA.SPH1NUM1, _DATA.SPH1NUM2
*
Local _rt,_err,_chb,_txt
Select sql_tisk
Locate All For sppohzdr_sp06idsubs='PLA'
If !Found()
    Return _sp89obsah
Endif
Try
    _rt=Textmerge(_sp89obsah)
    _chb=.F.
Catch To _err
    _rt=_err.Message+Chr(13)+Chr(10)+_sp89obsah
    _chb=.T.
Endtry
If _chb
    Return _rt
Endif
_txt='<table border cellspacing="0" ><tr><th>Popis zboží</th><th>Množství</th></tr>'
Select sql_tisk
Scan All For sppohzdr_sp06idsubs='OBC'
    _txt=_txt+'<tr><td>'+Alltrim(obudal_ob02text)+'</td><td style="text-align:right">'+Trans(obudal_ob02mn)+'</td></tr>'
Endscan
_txt=_txt+'</table>'
Go Top In sql_tisk
Return Strtran(_rt,'##TABLE##',_txt,1,1,1)

Ing. Petr Filip 02.11.10


Emaily odesílané z BM

Emaily odesílané z BM
'Nastavení programu BM' MSMAPI->UseOutlook=1 způsobí to, že pro odesílání emailu z BM bude používán objekt Outlooku místo objektu vyvolaného z MSMAPI32.OCX.

Použití objektu Outlooku přináší tyto výhody:
- při editaci mailu před jeho odesláním se používá plnohodnotný Word => je možné např. používat tučné písmo, vkládat tabulky, vkládat obrázky, ...
- text mailu předplněný z BM může být ve formátu HTML (tj. může obsahovat např. logo firmy, tabulky, tučné písmo,...) - text mailu musí v tomto případě začínat tagem
<HTML>

- Outlook dokáže takto vytvořené maily posílat do Datové schránky (pro tuto funkci je třeba v Outlooku nainstalovat potřebný plug-in)
- při automatickém odesílání mailu (bez možnosti opravy uživatelem) není třeba potvrzení uživatele o tom, že program BM je oprávněn odeslat mail

Při použití objektu Outlooku je možné také vyvolávat program BW_MAPI tak, že BM nečeká na ukončení úpravy mailu uživatelem
BM_MAPI, která má nyní parametry:
lcrecipaddress,lcsubject,lcmessagetext,lcfiles,randomsend,sp38id
přitom parametr randomsend může mít hodnoty:
.T. nebo 0 - mail bude odeslán bez možnosti jeho úpravy
.F. nebo 1 - mail se nabídne k úpravě - program BM zastaví a čeká na ukončení úpravy mailu
2 - mail se nabídne k úpravě - program BM nezastaví a nečeká na ukončení úpravy mailu

V předlohách výstupu je možné použít příkaz:
.MAIL_SEND 2

Pro vložení firemního loga do mailu ve formátu HTML je třeba:
- soubor obrázku musí být v mailu uveden mezi přílohami dokumentu
- obrázek je v uveden v textu mailu v syntaxi cid:, např.
'<p><img width=218 height=80 src="cid:fi_logo.gif"></p>'

Dalším 'Nastavením programu BM' MSMAPI->MailTemplate= (uplatní se pouze při nastavení MSMAPI->UseOutlook=1), je možné vytvářet vzhledově jednotné maily, které na svém konci obsahují např. logo firmy, kontaktní informace odesílatele mailu např. telefonní číslo, emailovou adresu, odkaz na webovou stránku, ...).

V tomto nastavení se uvádí .
Volné texty se definují ve formuláři 'Volné texty' (INFORMAČNÍ CENTRUM -> TYPY A ŘADY -> Volné texty).
Volný text použitý pro vytváření vzhledově jednotných mailů, by měl:
- být ve formátu HTML - tj. měl by začínat textem
<HTML>
a dále by měl obsahovat makro ##BODY##, které bude nahrazeno textem mailu
- v položce 'Kód' na záložce 'Další' - by měl obsahovat kód v jazyce Foxpro, který vrací upravený text (doplněný kontaktní informace odesílatete mailu např. jeho jméno, telefonní číslo, ...)
- položce 'Přílohy mailu' na záložce 'Další' - je možné uvádět seznam souborů (obrázků), které budou doplněny do mailu jako přílohy - např. výsledný mail má obsahovat firemní logo (tj. ve volném textu je uvedeno
'<p><img width=218 height=80 src="cid:fi_logo.gif"></p>'
), potom by měl být uveden soubor třeba 'bmps\fi_logo.gif'

Text mailu, který nahradí ve výsledném mailu makro ##BODY##,musí obsahovat html-tagy pro odřádkování (BR).

Pro zjištění výsledného tvaru kostry mailu používá BM metodu 'tool.sptexty_vrat_text', která má parametry:
- _SP88ID - identifikace volného textu
- _SP38ID - jazyk volného textu (nepovinný)
Vrací upravený text v daném jazyce (pokud není takový text v jazyce definovaný, tak v jazyce uživatele).
Text upraví spuštěním 'kódu' uvedeného u textu.
'Kódu' jsou předány parametry:
- _SP89OBSAH - text volného textu
- _DATA - objekt, který obsahuje všechny atributy volného textu - mj. atribut SP38ID (_DATA.SP38ID), ve kterém je jazyk textu (tj. _SP89OBSAH)

Příklad volného textu určeného pro vytváření vzhledově jednotných mailů.
'Text' volného textu např.:
<html>
<body>
##BODY##
<br>
<span style='color:navy;'>S pozdravem</span><br>
<b><span style='color:navy;'><<tool.jmenot>></span><b><br>
<br>
<p><img width=218 height=80 src="cid:fi_logo.gif"></p>
<span style='color:navy;'>Naše firma s.r.o.</span><br>
<span style='color:navy;'>Uliční 1, 999 99 Kolobřehy</span><br>
<span style='color:navy;'>Tel.: +420 999 999 999 (sekretariát), <<alltrim(tool.sql_dotaz([select bw01telef from %%%.bwuzivat where bw01uziv=?tool.uziv]))>> (přímý)</span><br>
<span style='color:navy;'>Fax: +420 999 999 999</span><br>
<span style='color:navy;'>Skype: ???</span><br>
<span style='color:navy;'><a href="http://www.nasefirma.cz/">http://www.nasefirma.cz/</a></span>
<span style='color:navy;'>, </span><span style='color:navy;'><a href="http://nasefirma.inshop.cz/">http://nasefirma.inshop.cz/</a></span><br>
</body>
</html>

'Kód' volného textu např.:
Local _rt,_err
Try
    _rt=Textmerge(_sp89obsah)
Catch To _err
    _rt='<h1>'+_err.Message+'</h1>'+Chr(13)+Chr(10)+_sp89obsah
Endtry
Return _rt

'Přílohy mailu' volného textu např.:
bmps\fi_logo.gif

Ing. Petr Filip 02.11.10


Java skript Dtue_ie5.js

Java skript Dtue_ie5.js
Byla opravena chyba java skriptu Dtue_ie5.js, který je používán při zobrazování stránek v interním webovém prohlížeči programu BM.

Chyba se objevovala náhodně v okně úloh na jeho stránkách, které používají interní webový prohlížeč (např. v okně 'Návody a balíčky' často při změně šířky okna úloh).
Chybu hlásil webový prohlížeč ':
Ve skriptu na této stránce došlo k chybě.
Řádek: 127
Znak: 38
Chyba: 'document.all.popUpWindow.style' má hodnotu null nebo není objekt
...
Chcete na této stránce i nadále spouštět skripty? ANO/NE

Soubor Dtue_ie5.js se nachází v adresáři BMSQL\SCRIPTS a celý tento adresář (a také adresář BMSQL\STYLESHEETS) je ve verzích generovaných po 11.11.2010 obsažen z souboru BM.ZIP.

Pokud nechcete čekat na novou verzi BM a působí Vám Dtue_ie5.js problémy, pošlu Vám oba adresáře mailem.
Ing. Petr Filip 11.11.10


Kdo drží tabulku

Kdo drží tabulku
Byly aktualizovány doplňující vlastnosti formuláře (DPV)
'Kdo drží tabulku' formulářů:
- Uživatelské triggery
- Volné karty
- Nastavená sledování změn tabulek

Klikněte na 'Spustit vzdálenou funkci'.
Tyto DPV můžete aktualizovat
na stránce 'Systémové DPV'
ve formuláři této vzdálené funkce.

Ing. Petr Filip 10.11.10


Návody a balíčky

Návody a balíčky
Ve stránce 'Návodů a balíčků' se nyní objevuje hypertext 'Zpět'.
Nachází se vlevo vedle ikony BM v modrém záhlaví stránky.

Klikněte na 'Spustit vzdálenou funkci' pro aktualizaci jejich programového kódu.
Ing. Petr Filip 11.11.10


Návody a balíčky

Návody a balíčky
'Návody a balíčky' mají novou funkčnost - novinky mohou mít definované
hypertextové odkazy 'Spustit vzdálenou funkci'.

Proveďte aktualizaci pomocí vzdálené funkce
'Návody a balíčky'
spuštěné z formuláře
INFORMAČNÍ CENTRUM ->
ALGORITMY A PARAMETRY ->
Sady vzdálených funkcí.
Ing. Petr Filip 08.11.10


Návody a balíčky

Návody a balíčky
Pro správné zobrazování listopadových novinek v panelu
proveďte aktualizaci pomocí vzdálené funkce
'Návody a balíčky'
spuštěné z formuláře
INFORMAČNÍ CENTRUM ->
ALGORITMY A PARAMETRY ->
Sady vzdálených funkcí.
Ing. Petr Filip 02.11.10


Ovládání - přepínání mezi okny

Ovládání - přepínání mezi okny
Okno úloh: - v seznamu oken v 'Okně úloh' se nyní zobrazuje většina oken programu BM - nově také okna informačních panelů, diagramů procesů, okno s předlohami výstupu, ... Diagramy procesů: - po pravém kliku myší na plochu okna diagramu se zobrazí menu, ve kterém je seznam oken včetně hlavního okna programu a výběrem z tohoto seznamu je možné rychle se přepnout do vybraného okna Informační panely: Pravý klik na tlačítko 'Zpět! způsobí přepnutí do hlavního okna programu
Ing. Petr Filip 02.11.10


Ovládání - výběrová záložka

Ovládání - výběrová záložka
Na výběrové záložce formulářů je možné zadat výběr záznamů, jejichž hodnota jediného atributu je obsažena ve vybrané množině hodnot (např. výběr karet spravovaného majetku, u kterých je uvedeno umístění majetku v KANCELÁŘI1 nebo v KANCELÁŘI2 nebo v ...).

Pro tento účel jsou u takových atributů na záložce Výběr zobrazeny ikony zaškrtávacího políčka (dále 'ikona seznamu hodnot').

Po kliknutí myší (klik, pravý klik nebo dvojí klik) na 'ikonu seznamu hodnot' se zobrazí uživateli okno se seznamem možných hodnot atributu, ve kterém označuje množinu hodnot atributu.
Přitom, když:
- označí jednou hodnotu je tato hodnota přenesena do hodnoty atributu ve formuláři na výběrovou záložce (podobně jako vrácení hodnoty po F2)
- označí více hodnot, potom je hodnota atributu ve formuláři na výběrovou záložce vynulována, atribut se stane nepřístupným a 'ikonu seznamu hodnot' změní svůj vzhled na 'zaškrtnutá' . Při pohybu myší nad nepřístupným atributem se potom zobrazuje nápověda, ve které je zobrazen seznam vybraných hodnot.

Ve formuláři se seznamem možných hodnot atributu je možné použít pravý klik myší, po kterém je možné označit všechny hodnoty nebo naopak zrušit označení všech hodnot.
---------------------------------------------------------------------------

Použití 'ikony seznamu hodnot' u atributů na výběrové záložce formulářů je implementačně nastavitelné:
- je možné měnit definici 'ikony seznamu hodnot', která byla dodána v programu BM.EXE
- je možné potlačit zobrazení 'ikony seznamu hodnot', která byla dodána v programu BM.EXE
- je možné vytvořit vlastní definici 'ikony seznamu hodnot'

Nastavení 'ikon seznamu hodnot' se provádí činností 'Doplnění výběrové záložky formuláře' vyvolávané z menu 'TYPY A ŘADY' nebo z formuláře 'Doplňující vlastnosti formuláře' klávesou F7.
Ve formuláři této činnosti se uvádí:
- Činnost - identitfikace činnosti
- Atribut - název výběrového atributu
- Aktivní/Neaktivní - překryvný seznam - při nastavení Neaktivní se nebude 'ikona seznamu hodnot' na výběrové záložce zobrazovat
- Návěští - text - určuje návěští okna se seznamem možných hodnot (uplatní se v případě, že atribut nemá uvedeno na výběrové záložce návěští a není uveden jeho překlad)
- Původ - překryvný seznam - Systémová definice/Uživatelská definice - systémové definice byly naprogramovány v BM.EXE, není je možné zrušit a je možné u nich měnit pouze atributy 'Aktivní/Neaktivní', 'Původ' a 'Poznámka'. Při instalaci nové verze BM se mohou změnit všechna nastavení systémové definice kromě atributů 'Aktivní/Neaktivní' a 'Poznámka' nebo může být zrušena, pokud byla v nové verzi BM.EXE odstraněna.
Pokud implementátor změní nastavení původu ze Systémová definice na Uživatelská definice, potom taková definice nebude po instalaci nové verze BM.EXE v žádném případě zrušena ani žádným způsobem měněna.
V případě, že implementátor změní původ ze Systémová definice na Uživatelská definice a definici opraví a potom následně změní původ z Uživatelská definice na Systémová definice, potom se po ukončení formuláře 'Doplnění výběrové záložky formuláře' nastavení takové definice obnoví podle toho jak je definována v BM.EXE (tj. přepíše jeho změny).
- Typ zdroje - překryvný seznam - SQL,COMBOBOX,SEZNAM,SCRIPT - určuje význam obsahu atributu 'Zdroj'
- Zdroj - víceřádkový text - obsahuje definici, podle které se naplní seznam v okně možných hodnot
- Ikona - překryvný seznam - Vlevo vedle atributu/Uvnitř atributu - určuje umístění 'ikony seznamu hodnot' (při nastavení Uvnitř atributu bude ikona umístěna v pravém horním rohu atributu) - uplatní podle nastavení parametrů uživatele "Zobrazování ikon seznamů hodnot"
- Vedle - text - určuje název jiného atributu, vedle kterého má být ikona umístěna při nastavení Ikona='Vlevo vedle atributu' (typickým případem je kategorie artiklu tj. pro atribut SA05ID je vhodné umístit ikonu před překryvný seznam Je/Není/Byl/Nebyl tj. atribut SA05EXISTS) - uplatní podle nastavení parametrů uživatele "Zobrazování ikon seznamů hodnot"
- Model SQL - víceřádkový text - obsahuje část SQL dotazu, která bude doplněna do výsledného SQL dotazu formuláře - text by měl obsahovat makro ###, které bude při sestavování SQL dotazu nahrazeno seznamem vybraných hodnot (např. 'OBARTIKL.SP20IDZAK IN (###)' ) - může obsahovat makro $$$, které bude nahrazeno názvem hlavní tabulky formuláře (např. pro formulář 'Obchodovatelný artikl' to může být '$$$.SP20IDZAK IN (###)' )
- Poznámka - víceřádkový text

Na záložce 'Předklad návěští okna' je možné definovat předklad návěští okna se seznamem možných hodnot v různých jazycích.
Návěští okna se seznamem možných hodnot bude:
- je-li uveden překlad návěští okna v jazyce uživatele, tak se uplatní tento text
- když má výběrový atribut uveden na výběrové záložce návěští, tak se uplatní text návěští výběrového atributu
- jinak se uplatní text uvedený v atributu Návěští

Pravidla pro obsah atributu 'Zdroj' pro různé typy zdrojů:
Typ zdroje=SQL
Zdroj musí obsahovat příkaz v jazyce SQL, který vytváří kurzor s nejméně dvěma sloupci (použijí se pouze dva prvé sloupce):
- první sloupec určuje text zobrazený v seznamu možných hodnot
- druhý sloupec určuje hodnotu položky seznamu, která se uplatní ve výsledném SQL dotazu

Typ zdroje=COMBOBOX
Používá se pro výběrové atributy typu překryvný seznam
Zdroj se neuvádí - seznam je naplněn podle obsahu seznamu, tak jak je uveden v atributu. Přitom se neuplatní první položka překryvného seznamu (hodnota 1=Vše).

Typ zdroje=SEZNAM
V textu zdroje je uveden seznam výčtem. V textu může být použit znak ';' (středník).
Syntaxe:
; nebo ,
kde
je hodnota položky seznamu, která se uplatní ve výsledném SQL dotazu,
je text zobrazený v seznamu možných hodnot.
Např.:
2010;Rok 2010
2009;Rok 2009
2008;Rok 2008
....

Typ zdroje=SCRIPT
Zdroj musí obsahovat kód v jazyce Foxpro, který vytváří kurzor s aliasem DATA s nejméně dvěma sloupci (použijí se pouze dva prvé sloupce):
- první sloupec určuje text zobrazený v seznamu možných hodnot
- druhý sloupec určuje hodnotu položky seznamu, která se uplatní ve výsledném SQL dotazu
Např.:
Local _i
Select 0
Create Cursor Data (popis c(4),rok c(4))
For _i=Year(Date()) To Year(Date())-10 Step -1
    Append Blank
    Replace popis With Trans(_i),;
        rok With Trans(_i)
Endfor

Ing. Petr Filip 06.10.10


Ovládání - Drag&Drop

Ovládání - Drag&Drop
BM umožňuje kopírování dokumentů BM tažením myší (Drag&Drop), ze stromů ve kterých se vyskytují dokumenty:
- Spojené dokumenty
- Strom hlavního procesu

Dokument je možné tímto způsobem kopírovat:
- do jiných aplikací Windows (zpráva Outlooku, Explorer, ...)
- mezi různými stromy aktuálně spuštěného BM - v tomto případě je zobrazen dotaz na to, jestli má být připojena kopie dokumentu nebo odkaz na dokument
Ing. Petr Filip 09.09.10


Ovládání - Drag&Drop

Ovládání - Drag&Drop
BM umožňuje kopírování záznamů formulářů tažením myší (Drag&Drop).

Kopírování je možné z formulářů, které obsahují záložky.
Provádí se tažením záložky (Drag) a jejím upuštěním (Drop) na záložku jiného formuláře.
Přitom je ve formuláři, který přijímá data, zahájen vstup jednoho nebo několika nových záznamů, podle toho, zda bylo tažení záložky provedeno levým nebo pravým tlačítkem myši.
Při tažení levým tlačítkem myši se provádí kopírování aktuálního záznamu formuláře.
Při tažení pravým tlačítkem myši se provádí kopírování všech záznamů formuláře (maximálně však 10000 záznamů).
Tato funkčnost se podobá doplňující vlastnosti formuláře 'Clipboard dat'.
Na rozdíl od doplňující vlastnosti formuláře 'Clipboard dat' je však možné tímto způsobem kopírovat data mezi různými formuláři (kopírují se pouze atributy, které jsou pro oba formuláře společné) - je možné např. kopírovat tímto způsobem vybrané artikly do nově zakládaných událostí obchodu.
Kopírování je možné také mezi formuláři dvou různých aktuálně spuštěných BM.EXE - tento způsob používání se však nedoporučuje, protože se v tomto případě se projeví chyba, jejíž příčinu se nepodařilo v současné chvíli odhalit - chyba se projeví při ukončování programu BM.EXE, ze kterého bylo kopírována data -> program se neukončí, ale zahltí procesor tak, že musí být ukončen ukončením procesu ve 'Správci úloh systému Windows'.

Tažením záložky formuláře je možné kopírovat data také do listu programu Excel (nebo jiného programu, který přijímá funkcí Drag&Drop data ve formátu CSV).
Data jsou kopírována data, tak jak jsou zobrazená v mřížce formuláře.
Kopíruje se jeden nebo několik záznamů, podle toho, zda bylo tažení záložky provedeno levým nebo pravým tlačítkem myši.
Při tažení levým tlačítkem myši se provádí kopírování aktuálního záznamu formuláře.
Při tažení pravým tlačítkem myši se provádí kopírování všech záznamů formuláře.
Pokud bylo do Excelu kopírováno více záznamů a v některém sloupci je uveden numerický údaj, potom je pro tyto sloupce doplněn součtový řádek.
Ing. Petr Filip 09.09.10


Ovládání - Drag&Drop

Ovládání - Drag&Drop
Ve formulářích BM je možné používat funkce Drag&Drop (Táhni a pusť) textových položek formulářů

Funkci Drag (tj. táhnout text) je možné provádět
- z položek typu text nebo MEMO
Přitom je možné text táhnout v rámci programu BM nebo do jiného programu Windows (Word, zpráva Outlooku,...)

Funkci Drop (tj. přijetí taženého textu) je možné provádět
- do položek typu MEMO (kromě tažení textu v rámci stejné položky typu MEMO)
- do položek typu text na výběrové záložce formuláře
Přitom je možné přijímat text tažený v rámci programu BM nebo z jiného programu Windows (Word, zpráva Outlooku,...)
Ing. Petr Filip 02.09.10


Potvrzení o zaměstnání (ZL) standard

Potvrzení o zaměstnání (ZL) standard
Sestava "Potvrzení o zaměstnání (ZL) standard" byla opravena - nyní nezahrnuje ošetřování, ale pouze nemoc.

Sestava je uložena na FTP.
Sestava je uložena v empty verzi.
Ing. Olga Smitková 30.08.10


Sestava Poklad ÚR 1-02

Sestava Poklad ÚR 1-02
Sestava je v empty verzi - nad Prohlížením výplatních lístků - "Podklad pro úr 1-02"

Nová sestava "Podklad pro úr 1-02" slouží jako Podklad pro vyplnění Výkazu ČSÚ "Výkaz o pracovní neschopnosti pro nemoc a úraz".
Daniela Postlová 30.08.10


Okno úloh

Okno úloh
Menu zobrazené po pravém kliku myší v okně úloh na položku stromů 'Okna' a 'Menu BM' obsahuje nově také složku 'PŘICHYCENÍ OKNA ÚLOH' , pod kterou se skrývají možnosti pro přichycení okna úloh v hlavním okně BM:
'Vlevo'
'Vpravo'
'Nahoře'
'Dole'
'Nepřichyceno'
Ing. Petr Filip 12.07.10


Potvrzení příjmů pro SSP

Potvrzení příjmů pro SSP
Jsou k dispozici nové sestavy "Potvrzení příjmů pro SSP 2009" a "Potvrzení příjmů pro SSP 2010".

Jedná se o Potvrzení příjmů (obvykle čtvrtletních) pro účely státní sociální podpory.
Spouští se v činnosti Prohlížení výplatních lístků.

Sestavy slouží jako podklad pro vyplnění formuláře "Doklad o výši čtvrtletního příjmu".

Sestavy jsou uložena v empty verzi.
Od 4.8.2010 jsou sestavy též na FTP.
Ing. Olga Smitková 16.07.10


Účetní deník

Účetní deník
V účtovém rozvrhu přibyl atribut:
Povinná částka v ZM - překryvný seznam - Ano/Ne

Pro účty s nastavením 'Povinná částka v ZM' = Ano není možné zadat událost účetního deníku s nulovou částkou v ZM
Ing. Petr Filip 13.07.10


Vlastnosti operace

Vlastnosti operace
V BM nyní není možné zrušit stav ukončena operace, která se nachází ve stornovaném nebo stornujícím procesu.
Ing. Petr Filip 13.07.10


Výkazy

Výkazy
Pokud je v názvu souboru výkazu obsažen adresář, který neexistuje, IS BM jej před vytvořením výkazu založí.
Ing. Petr Filip 13.07.10


Importy balíčků

Importy balíčků
Ve formuláři zobrazeném při importu balíčku přibylo tlačítko 'Uložit balíček jako ...'.

Po jeho užití je uživatel vybírá soubor s příponou BEX, do kterého má být uložena kopie aktuálního balíčku.
Může vybrat také již existující soubor balíčku, ke kterému má být aktuální soubor balíčku připojen.

Podnětem pro vytvoření této funkce je zavádění vzdálených funkcí BM, které umožní předávat balíčky s nastavením BM prostřednictvím Internetu.
- pro předání balíčků uživalelům, jejichž systémy nedokážou z nějakého důvodu používat vzdálené funkce BM
- pro vytvoření balíčků nastavení BM předáváných obvykle na konci roku

Pozn.: Tuto funkčnost je možné použít také pro slučování balíčků vytvořených klasickým způsobem
Ing. Petr Filip 17.06.10


Karty spravovaného majetku

Karty spravovaného majetku
Při vstupu nové karty spravovaného majetku s identifikací artiklu, která je již v BM zavedena, dochází nyní k předplnění dalšího volného pořadového čísla pro danou identifikaci artiklu.

Dále byla opravena chyba, která se projevovala při současném vstupu nových karet spravovaného majetku se shodnou identifikací artiklu s různým pořadovým číslem hlášením "SPARTIKV is not unique".
Ing. Petr Filip 15.06.10


Potvrzení o příjmech vz.18

Potvrzení o příjmech vz.18
K dispozici je sestava Sestava "Potvrzení o příjmech vz.18", která slouží jako potvrzení o příjmech platné pro rok 2010.
Ing. Olga Smitková 10.06.10


Výstup metapředlohou

Výstup metapředlohou
Ve formuláři zobrazovaném při užití metapředlohy nastavené pro interaktivní výběr předlohy, byl doplněn k seznamu předloh, které se mají tisknout text "Předlohy vybrané k výstupu".
Ing. Petr Filip 15.06.10


Informační panely

Informační panely
V definici uzlu informačního panelu je možné na záložce Další vyplňovat položku Refresh, ve které se uvádí čas ve vteřinách, po jehož uplynutí má být stránka obnovena.
Toto nastavení se týká informačních panelů spouštěných z BM - pro aplikaci informačních panelů ve WBM se tato položka nevyužívá.

Příklad použití - ve skladu se skladníkovi automaticky aktualizuje stránka, na které se mu zobrazují skladové výdejky vytvářené na jiném pracovišti.
Ing. Petr Filip 11.05.10


sady vzdálených funkcí

sady vzdálených funkcí
u zákazníka je nutné :
- verze po 20.05.2010
- nastavit obecnou předkontaci WEBSRV->WEBC01 na http://isbm.bmservis.cz/ws/bmwssrv.WSDL a nainstalovat aktuální verzi externího příkazu "Návody a balíčky".
- v adresáři PRGS musí být knihovna nbweb.app

Ing. Karel Franěk 25.05.10

Viz.také

Sledování verzí impl. rozšíření


Sestavy Průměrný počet pracovníků

Sestavy Průměrný počet pracovníků
V empty verzi jsou dvě podobné sestavy :

a) Průměrný počet pracovníků za čtvrtletí - "Prum_pocet_pracovniku_za_ctvrt"

b) Průměrný přepočtený počet pracovníků za čtvrtletí - "Prum_prepoct_pocet_prac_ctvr" - sestava na rozdíl od první, respektuje vliv délky úvazku.

Obě sestavy respektují pravidlo :
- pokud v rámci čtvrtletí součet kal. dnů na mateřské dovolené a součet kal. dnů na rodičovské dovolené je stejný jako počet kal. dnů ve čtvrtletí, pak se předpokládá, že zaměstnanec je po celé čtvrtletí na MD nebo RD nebo kombinaci obou a do evidenčního počtu se nezapočte.
- pracující podle dohod konaných mimo pracovní poměr budou ti pracující, kteří mají druh pracovního poměru DPP nebo DPČ

Pol. 13 POCFYZQ
Průměrný počet zaměstnanců (fyzických osob) v evidenčním počtu za poslední
kalendářní čtvrtletí sledovaného období. Vypočítá se jako aritmetický průměr
průměrného počtu zaměstnanců v evidenčním počtu za jednotlivé měsíce. Průměrný
počet za měsíc se počítá jako součet počtů fyzických osob v jednotlivých dnech
měsíce sledovaného období (včetně dnů pracovního klidu a pracovního volna), který
se dělí počtem všech kalendářních dnů příslušného měsíce.

Pol. 14 POCPREPQ
Průměrný přepočtený počet zaměstnanců v evidenčním počtu za poslední kalendářní
čtvrtletí sledovaného období. Přepočty se provedou u zaměstnanců, kteří
z provozních či jiných důvodů mají sjednanou kratší pracovní dobu (ZP § 80), dále
u zaměstnanců vykonávající vedlejší činnost v souběžném pracovním poměru či
zaměstnanců, vykonávajících práci příležitostně. Přepočty se neprovedou
u zaměstnanců, kteří z důvodu zdraví škodlivého prostředí či směnného provozu
mají stanovenou zkrácenou pracovní dobu (ZP § 79, odst. 2).

------------------------------------------------------------
Existuje i varianta těchto sestav, kdy řekneme , že učni jsou ti, kteří mají OSC začínající číslem 8 . Takoví učni se pak do sestavy nezapočítávají.

Varianta sestav je ummístěna v n:\_verze_mzdy_2010 \ zatim_nepredavat \ prum_pocty

---------------------------------------
Dne 10.9.2013 - popis
V činnosti Karta pracovníka máme k dispozici 2 tiskové sestavy:

a) Průměrný počet pracovníků za čtvrtletí - "Prum_pocet_pracovniku_za_ctvrt"

b) Průměrný přepočtený počet pracovníků za čtvrtletí - "Prum_prepoct_pocet_prac_ctvr" - sestava na rozdíl od první, respektuje vliv délky úvazku.

Obě sestavy respektují pravidlo :
- pokud v rámci čtvrtletí součet kal. dnů na mateřské dovolené a součet kal. dnů na rodičovské dovolené je stejný jako počet kal. dnů ve čtvrtletí, pak se předpokládá, že zaměstnanec je po celé čtvrtletí na MD nebo RD nebo kombinaci obou a do evidenčního počtu se nezapočte.
- pracující podle dohod konaných mimo pracovní poměr budou ti pracující, kteří mají druh pracovního poměru DPP nebo DPČ

Sestava - "Prum_pocet_pracovniku_za_ctvrt" obsahuje sloupce:
Číslo pracovníka, příjmení a jméno, počet dnů v p.p. (v zadaném čtvrtletí byl …dnů v pracovním poměru), datum vzniku a skončení p.p.

Na konci je vyčíslen absolutní počet pracovníků (každý se počítá jako 1 ks), celkem (součet dnů v pracovním poměru za všechny pracovníky), průměrně (celkem /kal. dnů). Kal. dnů je počet kalendářních dnů v daném čtvrtletí.

Sestava "Prum_prepoct_pocet_prac_ctvr" obsahuje navíc tyto sloupce:
Úvazek (konkrétní úvazek pracovníka), poměr (počet dnů v p.p./kal. dnů ve čtvrtletí), Dle úvazku (poměr * (konkrétní úvazek/8))

Na konci je navíc vyčíslen výraz "Průměrně", jako (celkem/kal. dnů) /(součet všech úvazků/(8* počet pracovníků))
Kal. dnů je počet kalendářních dnů v daném čtvrtletí.
-----------
Prum_pocet_pracovniku_za_ctvrt

if (mzpracpo.mz32vznipp <= ?tool.temp_datod) and (MZPRACPO.mz32skonpp is null or MZPRACPO.mz32skonpp >= ?tool.temp_datdo)
then ((DATE(?tool.temp_datdo) - DATE(?tool.temp_datod)) +1)
else
….
endif
endif
endif pocet_dnu, - počet podle data zahájení a data skončení pp
and
mzkarta.mz01id not like '- ' and not (mzpracpo.mz32druh in (4,5))
pocet_prac iif(Sql_tisk.pocet_dnu > nvl(Sql_tisk.mater,0)+ nvl(Sql_tisk.rodic,0),1,0) - SUMA

počet_dnu_celkem iif(Sql_tisk.pocet_dnu > nvl(Sql_tisk.mater,0)+ nvl(Sql_tisk.rodic,0),Sql_tisk.pocet_dnu,0) - SUMA, sesčítaný počet dnů u těch, co nebyli na MD nebo na RD

dnu_kal day(gomonth(tool.temp_datod,1)-1)+ day(gomonth(tool.temp_datod,2)-1)+day(tool.temp_datdo) počet dnů ve čtvrtletí

průměrně pocet_dnu_celk/ dnu_kal

Prum_prepoct_pocet_prac_ctvr

if (mzpracpo.mz32vznipp <= ?tool.temp_datod) and (MZPRACPO.mz32skonpp is …

endif
endif
endif pocet_dnu, - počet podle data zahájení a data skončení pp

Počet dnů v p.p. počet_dnu
Poměr Sql_tisk.pocet_dnu/ dnu_kal
Dle úvazku (Sql_tisk.pocet_dnu/ dnu_kal)* (Sql_tisk.mz25hodden/8)

Pracovníků absolutně pocet_prac = iif(Sql_tisk.pocet_dnu > nvl(Sql_tisk.mater,0)+ nvl(Sql_tisk.rodic,0),1,0)
pocet_dnu_celk = iif(Sql_tisk.pocet_dnu > nvl(Sql_tisk.mater,0)+ nvl(Sql_tisk.rodic,0),Sql_tisk.pocet_dnu,0) sesčítaný počet dnů u těch, co nebyli na MD nebo na RD

průměrně (pocet_dnu_celk/ dnu_kal)*( uvazku_celkem/(8* pocet_prac))
dnu_kal day(gomonth(tool.temp_datod,1)-1)+ day(gomonth(tool.temp_datod,2)-1)+day(tool.temp_datdo) počet dnů ve čtvrtletí
uvazku_celkem = iif(Sql_tisk.pocet_dnu > nvl(Sql_tisk.mater,0)+ nvl(Sql_tisk.rodic,0),Sql_tisk.mz25hodden,0)

Ing. Olga Smitková 21.05.10


Vstupní maska operace

Vstupní maska operace
V definici vstupní masky operace je možné mj. uvádět atributy:
- Interní validace - překryvný seznam Zapnuta/Vypnuta - nastavení Vypnuta způsobí to, že při vstupu události nebude na daném atributu prováděna validace naprogramovaná BM.EXE
- Interní předplňování - překryvný seznam Zapnuto/Vypnuto - nastavení Vypnuto způsobí to, že při vstupu události nebude daný atribut dynamicky předplňován tak, jak je naprogranován v BM.EXE

Pozn.: nevhodné vypnutí interní validace může způsobovat chybné chování systému (např. pro datumové položky doporučujeme kombinovat vypnutí interní validace s validačním výrazem 'NOT EMPTY(###)' ).

Na atributu Validace je aplikovat klávesu F2, kterou se do něho předplní výraz validace atributu, tak jak byla naprogramována v BM.EXE.
Ing. Petr Filip 11.05.10


Formuláře Pro Zdravotní Pojišťovny

Formuláře Pro Zdravotní Pojišťovny
VZP http://www.vzp.cz/cms/internet/cz/Platci/formulare/Formulare-pro-zamestnavatele/
VZP 2 http://www.vzp.cz/cms/internet/cz/ekomunikace/portal/sluzby/

ZPMV http://www.zpmvcr.cz/download/formulare/Nove%20formulare%202009/Informace_%20formulare%20pro%20platce%20pojisneho.pdf
Ing. Karel Franěk 30.04.10


Procesy

Procesy
Ve formuláři Procesy se nyní v mřížce a na první záložce zobrazuje adresát, který je uveden v úvodní operaci procesu (pozn. do operace zapisuje, když je v uzlu procesu nastaveno 'Vytvořit záložku při založení procesu').
Podle identifikace a názvu adresáta je možné vyhledávat a třídit v mřížce.

V souvislosti s touto změnou byl mírně změněn vzhled první záložky formuláře Operace.
Ing. Petr Filip 19.04.10


Předlohy výstupu

Předlohy výstupu
Pro předlohu výstupu je možné definovat její přílohy.

Přílohou k předloze výstupu se rozumí externí soubor uložený na disku, který je potřebný pro její funkci.
Přílohou k předloze výstupu může být např. soubor:
- template pro předlohu výstupu typu Excel (soubory s příponou XLT, XLTX, XLS, XLSX)
- obrázek použitý v klasické předloze výstupu (např. firemní logo)

Přílohy k předloze výstupu se definují ve formuláři vyvolaném z menu pravého kliku myší na předloze volbou 'Přílohy k předloze' nebo pro uživatele s právy správce po pravém kliku myší na tlačítku vlastnosti předlohy.
K jedné předloze je možné definovat větší počet příloh.
Ve formuláři pro definování příloh se uvádí:
- jméno souboru (doporučuje se uvádět jméno souboru s relativní cestou)
- poznámka

Kopie obsahu souboru přílohy je ukládána v databázi ve formátu ZIP a přitom se používá knihovna VFPCOMPRESSION.FLL, která je obvykle uložena v adresáři PRGS (bez existence knihovny VFPCOMPRESSION.FLL není možné přílohy definovat).
Kopie jednoho souboru se stejným názvem je v databázi uložena pouze jedenkrát a při rušení záznamu o příloze k předloze výstupu je kopie souboru v databázi automaticky zrušena v případě, že se jedná o soubor, který není uveden jako příloha žádné jiné předlohy výstupu a také se nejedná o soubor uvedený u některé Šablony listů výkazů.

Ve formuláři pro definování příloh se zobrazuje datum a čas kopie souboru, která je uložena v databázi. Při zápisu dat formuláře se porovnává tento datum a čas s datem a časem souboru, který uložen na disku a v případě, že se nerovnají (+- 2 vteřiny), je nabídnuta možnost zápisu kopie obsahu souboru do databáze.
Při otevírání formuláře pro definování příloh se porovnají datum a čas kopie souboru a datum a čas souboru jednotlivých příloh, a jestliže se pro některou z nich nerovnají (+- 2 vteřiny), pak je formulář otevřen s aktivním tlačítkem OK.

V seznamu příloh funguje dvojí klik v seznamu příloh, kterým je vyvolán podle přípony souboru program (např. Excel), který otevírá soubor přílohy uložený na disku.

Při spuštění nebo opravě předlohy výstupu, je prováděna kontrola, jestli všechny její přílohy na disku existují a v případě, že neexistují jsou 'vybaleny' jejich kopie z databáze.
Provádí se pouze kontrola existence souboru, vůbec se neporovnává datum a čas souboru (tj. nedochází k přepisu souboru na disku ani v případě, že je starší než jeho kopie v databázi).
Podmínkou pro tuto funkci je existence knihovny VFPCOMPRESSION.FLL, pokud není tato knihovna nainstalována, potom se při spuštění nebo opravě předlohy výstupu objeví hlášení 'Sestava obsahuje přílohy, které není možné vybalit, protože nemáte nainstalovanou knihovnu VFPCOMPRESSION.FLL'.

Po ukončení opravy předlohy výstupu typu Excel, Word nebo Ostatní je analyzována její definice (i když nebyla definice změněna) a v případě, že v ní byly zjištěny odkazy na na disku existující soubory, které by měly být uvedené jako přílohy dané předlohy, potom je automaticky vyvolán formulář pro definování příloh, ve kterém jsou tyto nové přílohy připravené k zápisu.

Při exportu předlohy výstupu do balíčku, jsou exportovány také její přílohy včetně kopie obsahu souboru přílohy.
Import balíčku nikdy nepřepisuje existující kopii souboru přílohy v databázi a ani neprovádí její 'vybalení' do souboru na disku (to se provede až při prvním spuštění nebo první opravě předlohy výstupu nebo po dvojím kliku v seznamu příloh).

Knihovna VFPCOMPRESSION.FLL požaduje pro svou funkci ve Windows starších než Vista existenci souborů C:\WINDOWS\SYSTEM32\MSVCP71.DLL a C:\WINDOWS\SYSTEM32\MSVCR71.DLL.
Ing. Petr Filip 27.04.10


Sledování verzí impl. rozšíření

Sledování verzí impl. rozšíření
V BM je v současné době doplňován o možnost sledování verzí implementačních rozšíření.

Tyto změny jsou nyní realizovány ve formulářích 'Knihovny vkládaného kódu', 'Doplňující vlastnosti formuláře', 'Externí příkazy', ve kterých byl doplněn na hlavní záložce atribut 'Verze' a ve formuláři 'Sady systémových konstant' (ten už atribut 'Verze' obsahoval).
Ve všech těchto formulářích přibyla nová záložka 'Popis verze ...', která je určena pro vstup popisu jednotlivých verzí daného implementačního rozšíření.
Zadává se:
- číslo popisované verze
- text popisu verze
- datum pořízení popisu
- jméno autora popisu (vloží se automaticky - nejde přepsat)

Další implementační rozšíření budou následovat (např. Předlohy výstupu).

Ing. Petr Filip 02.04.10

Viz.také

sady vzdálených funkcí


Systémové konstanty

Systémové konstanty
Ve formuláři 'Sady systémových konstant' přibyl na záložce 'Konstanty' atribut 'Specifická' (může mít hodnotu ANO nebo NE), který označuje konstanty jejichž hodnota je specifická pro různé subjekty.
V mřížce jsou řádky konstant s nastavením 'Specifická'=ANO zobrazené na světle modrém podkladu.

Hodnoty konstant, které mají nastaven atribut 'Specifická'=ANO, nebudou při exportu do balíčku vyvolaném v tomto formuláři zahrnuty do balíčku.

Toto nové nastavení má dopad ve formuláři 'Hodnoty sady konstant', ve kterém jsou v mřížce řádky 'hodnotou specifických' konstant zobrazované na světle modrém podkladu a na výběrové záložce je možné vybírat 'Konstanty' (překryvný seznam):
- Všechny
- Hodnotou specifické pro různé subjekty
- Hodnotou shodné pro různé subjekty

Ing. Petr Filip 02.04.10


Šablony listů výkazů

Šablony listů výkazů
Ve formuláři 'Šablony listů výkazů' je možné na atributu 'Soubor šablony' klávesou F2 vyvolat vstup, kterým se provede zápis kopie souboru šablony do databáze.

Kopie obsahu souboru šablony je ukládána v databázi ve formátu ZIP a přitom se používá knihovna VFPCOMPRESSION.FLL, která je obvykle uložena v adresáři PRGS (při neexistenci knihovny VFPCOMPRESSION.FLL nejsou kopie souborů šablony ukládány).
Kopie jednoho souboru se stejným názvem je v databázi uložena pouze jedenkrát a při změně názvu souboru je kopie souboru v databázi automaticky zrušena v případě, kdy se jedná o soubor, který není uveden jako příloha některé předlohy výstupu nebo jako soubor jiné šablony.

Ve formuláři se zobrazuje datum a čas kopie souboru, která je uložena v databázi.
Při zápisu dat formuláře se porovnává tento datum a čas s datem a časem souboru, který uložen na disku a v případě, že se nerovnají (+- 2 vteřiny),
je nabídnuta možnost zápisu kopie obsahu souboru do databáze.

Při spuštění výkazu, je prováděna kontrola toho, zda všechny jeho šablony na disku existují a v případě, že neexistují jsou 'vybaleny' jejich kopie z databáze.
Provádí se pouze kontrola existence souboru, vůbec se neporovnává datum a čas souboru (tj. nedochází k přepisu souboru na disku ani v případě, že je starší než jeho kopie v databázi).
Podmínkou pro tuto funkci je existence knihovny VFPCOMPRESSION.FLL, pokud není tato knihovna nainstalována, potom se při spuštění nebo opravě předlohy výstupu objeví hlášení 'Výkaz obsahuje soubory šablon, které není možné vybalit, protože nemáte nainstalovanou knihovnu VFPCOMPRESSION.FLL'.

Při exportu definice výkazu do balíčku, jsou exportovány také jeho šablony včetně kopie obsahu souboru šablony.
Import balíčku nikdy nepřepisuje kopii souboru šablony v databázi a ani neprovádí její 'vybalení' do souboru na disku (to se provede až při prvním spuštění výkazu).

Knihovna VFPCOMPRESSION.FLL požaduje pro svou funkci ve Windows starších než Vista existenci souborů C:\WINDOWS\SYSTEM32\MSVCP71.DLL a C:\WINDOWS\SYSTEM32\MSVCR71.DLL.
Ing. Petr Filip 27.04.10


Datum aktualizace v mřížkách

Datum aktualizace v mřížkách
Ve formulářích 'Externí příkazy','Doplňující vlastnosti formuláře','Doplňující položky menu objektů','Knihovny vkládaného kódu','Hodnoty sady konstant' a 'Seznam předloh výstupu' byl do mřížky doplněn sloupec 'Aktualizace' resp. 'Poslední změna', ve kterém je uveden datum aktualizace odpovídajícího záznamu. Podle tohoto sloupce je možné vybrat třídění.
Ing. Petr Filip 25.03.10


ELDP - nová verze pro rok 2009, 2010

ELDP - nová verze pro rok 2009, 2010
Dobrý den,

posíláme vám nové knihovny pro ELDP 2009 a 2010.

Změny jsou popsány v přiloženém dokumentu, prosím, seznamte se s ním.

Pokud máte v evidenci zaměstnankyně, které jsou nebo byly na mateřské dovolené během roku 2009 a chcete jim dělat ELDP, budete potřebovat novou verzi a přiložené nové knihovny ELDP09. Pokud takovéto zaměstnankyně nemáte, pak vám postačí pouze nové knihovny ELDP09.

Nové knihovny jsou též na FTP v sekci Pro zákazníky \ Mzdy 2010\Eldp.

Za BM Servis s.r.o.
Olga Smitková

Ing. Olga Smitková 16.03.10


Okna Spojení adresátů a Adresy adresátů

Okna Spojení adresátů a Adresy adresátů
Okna Spojení adresátů a Adresy adresátů nebylo možné zvětšit na celou obrazovku, nyní je to možné.
Ing. Petr Filip 25.03.10


Sestava kontrolní k ročnímu zúčtování

Sestava kontrolní k ročnímu zúčtování
Sestava "Výpočet daně z příjmů (předběž)" slouží ke kontrole údajů, nastavených na Kartě pracovníka pro účely provedení ročního zúčtování. Při ročním zúčtování je totiž nutné na kartu zadat např. údaje o úrocích z úvěrů, o příspěvcích na penzijní připojištění, o dodatečných slevách (na manželku, na invaliditu, ...), dále údaje od předchozího zaměstnavatele, ...

Sestava se spouští v činnosti "Prohlížení výplatních lístků". Ve výběru činnosti se uvádí měsíc a rok, ve kterém se provede roční zúčtování. Např. při ročním zúčtování za rok 2009 je nutné do výběru zadat např. od 02/2010 do 02/2010.

Aby nebyla zaměnitelná se sestavou, která se tiskne výlučně po provedení ročního zúčtování, má tato v sobě vloženo upozornění 'SESTAVA JE POUZE PŘEDBĚŽNÁ - ROČNÍ ZÚČTOVÁNÍ PRAVDĚPODOBNĚ JEŠTĚ NEBYLO PROVEDENO '.

Nová sestava je uložena formou balíčku Vypocet_dane_predbezny na našem FTP v sekci Pro zákazníky \ Mzdy 2010 \ Sestavy
Nedílnou součástí je předloha Vypocet_dane_2009.xlt, kterou je potřeba nahrát do složky Template.

Ing. Olga Smitková 23.03.10


Účetní výkazy - datum

Účetní výkazy - datum
lze předplnit datum do hlavičky účetních výkazů:
(v případě zájmu se obraťte na svého implementátora)
Stačí doplnit kód spouštěný po vytvoření listu.

Local _dt

_dt=Gomonth(Date(Val([rokd]),Val([mesd]),1),1)-1

* odstranuji se tecky z datumu - je to tak dobre ?

* nazev CC muze byt ruzny v jinem listu

xlsheet.shapes('cc').textframe.characters.Text=Strt(Trans(_dt),'.')

Ing. Blanka Tůmová 30.03.10


Událost skladové evidence

Událost skladové evidence
bylo odstraněno opakování hodnoty atributu "Buňka" při vstupu události skladové evidence, které bylo v BM naprogramováno 'natvrdo'.
Pokud toto chování vyhovovalo v implementacích využívajících skladové buňky, je u nich třeba doplnit opakování atributu "Buňka" v maskách operací skladu.
Ing. Petr Filip 17.03.10


Výroba

Výroba
Ve formuláři 'Vstupy a výstupy výr.úkolů' přibyla na výběrové záložce možnost zaškrtnout návěští 'Datum'.
Toto zaškrtávací políčko ovlivní vybírané události:
- zaškrtnuté - vyhledávané datum je datumem vstupu/výstupu
- nezaškrtnuté - vyhledávané datum je datumem zahájení výrobního úkolu

Použití výběru s nezaškrtnutým 'Datum' (tj. podle data zahájení výrobního úkolu) může dramaticky zrychlit výběr při velkém objemu dat.
Ing. Petr Filip 18.03.10


Zápočtový list (potvrzení o příjmech)

Zápočtový list (potvrzení o příjmech)
Byla provedena úprava sestavy "*Zápočtový list - výdělek". Sestava byla přizpůsobena k opětovnému vytisknutí i po delším čase po odchodu pracovníka.

Sestavu zaměstnavatel vydá pracovníkovi např. pro odevzdání na úřadu práce neprodleně, pravděpodobně ještě před provedením uzávěrky měsíce, ve kterém zaměstnanec odchází. V tu chvíli je na Kartě pracovníka ještě správný hodinový průměr.

Pokud ale pracovník skončil v měsíci, ve kterém se průměry přepočítávají, tj. v březnu, červnu, září nebo prosinci a zároveň byl zápočtový list vystaven až po provedení uzávěrky za březen (červen, září nebo prosinec), pak průměr na Kartě pracovníka již není pro účely Zápočtového listu správný.

Úprava sestavy spočívá v tom, že v takové situaci si vezmeme průměr z Historie pracovních poměrů (tj. najde si průměr, který se v daném čtvrtletí používal).

Rozhodující okamžik je tedy provedení nebo neprovedení uzávěrky měsíce, ve kterém pracovník odešel (datum skončení pracovního poměru).

Sestava je na FTP v sekci Pro zákazníky \ Mzdy 2010\Sestavy. Balíček se jmenuje Zapoct_list_vydelek.bex
Sestava potřebuje aktualizovanou předlohu Potvrzeni_o_zam_vydelek.xls

Příklad z Démonie :
Zaměstnanec končí dne 30.6. pracovní poměr a potřebuje potvrzení pro úřad práce, použije se průměrný výdělek za II. čtvrtletí,
vychází se z toho, že ke skončení pracovního poměru došlo ve II. čtvrtletí. I kdyby si pro potvrzení přišel až v červenci.

(Průměrný výdělek za II. čtvrtletí je ten výdělek, který se vypočetl z údajů II. čtvrtletí a používá se v následujícím III. čtvrtletí.)

-------------------------
Kompletní popis :
V souladu se zákonem 262/2006 paragraf 313 byla vytvořena sestava Potvrzení o zaměstnání (zápočtový list)

Sestava se jmenuje "*Zápočtový list standard" a je typu běžná, nikoliv excel.

Sestava obsahuje záznamy o nemocech v posledním roce před ukončením pracovního poměru, záznamy o prováděných srážkách, které trvají i nadále.

Sestava neobsahuje údaje o výši průměrného výdělku - toto se uvádí na samostatném potvrzení (kvůli podpoře v nezaměstnanosti)

Sestava '*Zápočtový list - výdělek' je k dispozici v naší verzi, v empty verzi. Dále na FTP a v adresáři N:\_VERZE_MZDY_2009\......
------------------------------------------------------------------------
V souladu se zákonem 435/2004 paragraf 42 byla vytvořena sestava Potvrzení pro podporu v nezaměstnanosti. Sestava obsahuje informace o průměrném hrubém a čistém výdělku.

Sestava se jmenuje "*Zápočtový list - výdělek", je typu excel a potřebuje šablonu (Potvrzeni_o_zam_vydelek.xlt).

Sestava se zeptá na datum - 'Legislativa ke dni '. K tomuto datu se načtou potřebné legislativní konstanty. V sestavě je také možné zaškrtnou 'Zobrazit podrobnosti ' - pak se v sestavě objeví celý postup, pomocí něhož se došlo k průměrnému čistému výdělku.

Je určena pouze pro pracovníka, který ukončuje jeden pracovní poměr, nikoliv pro pracovníka, který ukončuje více pracovních poměrů.

Některá nastavení na pracovních poměrech, která ovlivňují výpočet čistého příjmu mohou být různá a toto pak sestava nezachytí. Např. jeden pracovní poměr může mít nastaveno SP typu vše a druhý pracovní poměr může mít nastaveno SP pouze typu Důchod.

Sestavuje možné použít k opětovnému vytisknutí i po delším čase po odchodu pracovníka.

Sestavu zaměstnavatel vydá pracovníkovi např. pro odevzdání na úřadu práce neprodleně, pravděpodobně ještě před provedením uzávěrky měsíce, ve kterém zaměstnanec odchází. V tu chvíli je na Kartě pracovníka ještě správný hodinový průměr.

Pokud ale pracovník skončil v měsíci, ve kterém se průměry přepočítávají, tj. v březnu, červnu, září nebo prosinci a zároveň byl zápočtový list vystaven až po provedení uzávěrky za březen (červen, září nebo prosinec), pak průměr na Kartě pracovníka již není pro účely Zápočtového listu správný.

V takové situaci si vezmeme průměr z Historie pracovních poměrů (tj. najde si průměr, který se v daném čtvrtletí používal).

Rozhodující okamžik je tedy provedení nebo neprovedení uzávěrky měsíce, ve kterém pracovník odešel (datum skončení pracovního poměru).

Příklad z Démonie :
Zaměstnanec končí dne 30.6. pracovní poměr a potřebuje potvrzení pro úřad práce, použije se průměrný výdělek za II. čtvrtletí,
vychází se z toho, že ke skončení pracovního poměru došlo ve II. čtvrtletí. I kdyby si pro potvrzení přišel až v červenci.

(Průměrný výdělek za II. čtvrtletí je ten výdělek, který se vypočetl z údajů II. čtvrtletí a používá se v následujícím III. čtvrtletí.)
Ing. Olga Smitková 19.03.10

Viz.také

Sestava "*Zápočtový list výdělek (skon)"


Informační panely

Informační panely
Funkčnost přenosu zobrazené tabulky do Wordu a Excelu byla rozšířena o možnost vytvoření dokumentu přímo ve formátu Wordu resp. Excelu.

Provádí se vložením kódu v jazyce Foxpro do atributu 'SQL dotaz' v definici uzlu informačního panelu.
Tento kód vytvoří soubor v požadovaném formátu (případě, že je nastavena proměnná '_this.output_format') a jeho název vloží do proměnné '_this.rodic.output_file'.

V příkladech se předpokládá, že na počítači je nainstalován Excel - a v případě použití pro WBM není jeho volání nějakým způsobem omezeno IIS-serverem.

Příklad 1. - klasický SQL dotaz
#SCRIPT
#ENDSCRIPT

Select sp26,sp26datum,sp26nazev,bw01jmeno,sp26index,spdokobs.sp01id,sp01predlo,sp57typdok,spdokobs.sp57id,sp26koment,sp26disk,sp26soubor From %%%.spdokobs spdokobs,%%%.bwuzivat bwuzivat,%%%.sppredlo sppredlo,%%%.spdoktyp spdoktyp,%%%.sppristu sppristu Where
spdokobs.sp57id=sppristu.sp44vec And sppristu.sp44typ='TDO' And  sppristu.bw01uziv=?Tool.uziv And
sppristu.sp44pristu>1 And
spdokobs.bw01uziv=bwuzivat.bw01uziv And spdokobs.sp01id=sppredlo.sp01id And spdokobs.sp57id=spdoktyp.sp57id

#SCRIPT
Local _txt,_xlapp,_xlwb,_xlsheet,_err
* Pokud má být vytvářen XLS, potom _this.output_format='XLS'
If Empty(_this.output_format) Or _this.output_format<>'XLS'
    Return
Endif
If _this.web
    * Výstup do Excelu pro WBM musí být uložen v adresáři -> _this.rodic.Path s příponou XLSX nebo XLS
    _this.rodic.output_file=_this.rodic.Path+'tmp\'+Stuff(Sys(2015),1,1,'')+'.xlsx'
Else
    * Výstup do Excelu pro BM.EXE bude uložen v libovolném pracovním souboru s příponou XLSX nebo XLS
    _this.rodic.output_file=bw_param('TMP','.xlsx')
Endif
* _xlapp = OLE object Excelu
_xlapp=Createobject( "Excel.Application")
* _xlwb = objekt dokumentu Excelu
_xlwb=_xlapp.workbooks.Add
* _xlsheet = objekt listu Excelu
_xlsheet=_xlwb.worksheets[1]
Select Data
_i=0
Scan All
    * _i obsahuje číslo řádku
    _i=_i+1
    * sp26datum do prvního sloupce
    _xlsheet.cells[_i,1].Value=sp26datum
    * sp26nazev do druhého sloupce
    _xlsheet.cells[_i,2].Value=sp26nazev
    * bw01jmeno do třetího sloupce
    _xlsheet.cells[_i,3].Value=bw01jmeno
Endscan
_xlapp.displayalerts=.F.
* uložení dokumentu
_xlwb.SaveAs(_this.rodic.output_file)
_xlapp.displayalerts=.T.
* uzavření dokumentu
_xlwb.Close()
_xlsheet=.F.
_xlwb=.F.
_xlapp=.F.
#ENDSCRIPT

Příklad 2. - programovaný SQL dotaz
Local _txt,_xlapp,_xlwb,_xlsheet,_err
Local _sql
TEXT TO _sql Noshow
Select sp26,sp26datum,sp26nazev,bw01jmeno,sp26index,spdokobs.sp01id,sp01predlo,sp57typdok,spdokobs.sp57id,sp26koment,sp26disk,sp26soubor From %%%.spdokobs spdokobs,%%%.bwuzivat bwuzivat,%%%.sppredlo sppredlo,%%%.spdoktyp spdoktyp,%%%.sppristu sppristu Where
spdokobs.sp57id=sppristu.sp44vec And sppristu.sp44typ='TDO' And  sppristu.bw01uziv=?Tool.uziv And
sppristu.sp44pristu>1 And
spdokobs.bw01uziv=bwuzivat.bw01uziv And spdokobs.sp01id=sppredlo.sp01id And spdokobs.sp57id=spdoktyp.sp57id
ENDTEXT
If !bw_exec(.F.,_sql,'Data')
    Return
Endif

* Pokud má být vytvářen XLS, potom _this.output_format='XLS'
If Empty(_this.output_format) Or _this.output_format<>'XLS'
    Return
Endif
If _this.web
    * Výstup do Excelu pro WBM musí být uložen v adresáři -> _this.rodic.Path s příponou XLSX nebo XLS
    _this.rodic.output_file=_this.rodic.Path+'tmp\'+Stuff(Sys(2015),1,1,'')+'.xlsx'
Else
    * Výstup do Excelu pro BM.EXE bude uložen v libovolném pracovním souboru s příponou XLSX nebo XLS
    _this.rodic.output_file=bw_param('TMP','.xlsx')
Endif
* _xlapp = OLE object Excelu
_xlapp=Createobject( "Excel.Application")
* _xlwb = objekt dokumentu Excelu
_xlwb=_xlapp.workbooks.Add
* _xlsheet = objekt listu Excelu
_xlsheet=_xlwb.worksheets[1]
Select Data
_i=0
Scan All
    * _i obsahuje číslo řádku
    _i=_i+1
    * sp26datum do prvního sloupce
    _xlsheet.cells[_i,1].Value=sp26datum
    * sp26nazev do druhého sloupce
    _xlsheet.cells[_i,2].Value=sp26nazev
    * bw01jmeno do třetího sloupce
    _xlsheet.cells[_i,3].Value=bw01jmeno
Endscan
_xlapp.displayalerts=.F.
* uložení dokumentu
_xlwb.SaveAs(_this.rodic.output_file)
_xlapp.displayalerts=.T.
* uzavření dokumentu
_xlwb.Close()
_xlsheet=.F.
_xlwb=.F.
_xlapp=.F.

Ing. Petr Filip 18.02.10


Předlohy výstupu

Předlohy výstupu
Ve formuláři pro definování předlohy výstupu Excel typu 1 byly doplněny atributy:
- Kontrola otevření - zaškrtávací políčko - zaškrtnuté nedovolí opakovaný výstup předlohy Excelu v situaci, kdy uživatel neuzavřel soubor v Excelu vytvořeného posledním použitím stejné předlohy nebo jiné předlohy provádějící výstup do stejného souboru
- Soubor neukládat - zaškrtávací políčko - zaškrtnuté způsobí zrušení souboru na disku po jeho uzavření v Excelu - zrušení souboru proběhne pouze v případě, že byl soubor v Excelu uzavřen před ukončením programu BM

V definici předlohy výstupu Excel typu 2 je možné použít příkaz:
.KONTROLA_OTEVŘENÍ,
který způsobí to, že předloha nedovolí opakovaný výstup do Excelu v situaci, kdy uživatel neuzavřel soubor v Excelu vytvořeného posledním použitím stejné předlohy nebo jiné předlohy provádějící výstup do stejného souboru.
Tento příkaz musí být uveden před příkazem .EXCEL_OTEVŘI.

Ing. Petr Filip 18.02.10


Výkazy

Výkazy
Atributem šablony 'Vymazat list' (Ano/Ne) je možné nastavit to, že obsah listu výkazu v Excelu nebude před jeho vytvářením vymazán.

Použití: šablona XLT může obsahovat popisy řádků výkazu a vzorce, které nemusí být uvedeny v definici listu.
Ing. Petr Filip 10.02.10


Doplňující vlastnosti formuláře

Doplňující vlastnosti formuláře
V definici doplňující vlastnosti formuláře je mj. atribut 'Řez písma položky menu' , kterým je možné stanovit to, že odpovídající položka menu Volby bude písmem Normálním nebo Kurzívou nebo Tučně nebo Tučnou kurzívou.
Ing. Petr Filip 28.01.10


Fonty CE v klasických předlohách výstupu

Fonty CE v klasických předlohách výstupu
BM automaticky provádí při otevření klasické předlohy pro opravu nebo tisk záměnu fontů 'Arial CE' ,'Courier New CE' a 'Times New Roman CE' za 'Arial-Středoevropský','Courier New-Středoevropský' a 'Times New Roman-Středoevropský', pokud jsou v této předloze použity.

Nastavením BM Printing->Potlac_FontCE=0 je možné tuto funkčnost potlačit.
Ing. Petr Filip 28.01.10


Plnění úkolů projektů (EVIVYK.EXE)

Plnění úkolů projektů (EVIVYK.EXE)
Pro zjednodušení zadávání plnění úkolů v projektovém řízení byl vytvořen program EVIVYK.EXE.
Předpokladem pro fungování tohoto programu je:
- Vaše BM obsahuje komponentu 'Projektové řízení'
- verze BM.EXE s datem generování po 27.1.2010.

EVIVYK.EXE je distribuován v souboru BM.ZIP (jeho adresář \BMSQL\EVIVYK).
Celý tento adresář by měl být umístěn v podadresáři adresáře uložení BM.EXE.

Podrobná dokumentace k programu EVIVYK.EXE bude obsažena v helpu programu BM ve složce 'Další dokumentace'.

Informace zobrazované programem EVIVYK.EXE je možné nastavit kódem 'Knihovny vkládaného kódu' s identifikací EVIVYK.
V každém případě je třeba tuto knihovnu založit a v jejím kódu nastavit atribut SP07IDTYPD.

Příklad obsahu knihovny EVIVYK:
* Provádí nastavení programu EVIVYK.EXE
* ve výrazech je možné pracovat s atributy:
* sp61id,sp60id,nk01verze,sp62artikl
* nk43,nk43idu,nk43porad,nk43stav,nk43datz,nk43datu,nk43text,nk43koment
* nk53id,nk53nazdru,pa13id,nk42id,nk44id,sp00datzap,sp10text
* atribut sp10text může nabývat hodnotu NULL

* atribut SP07IDTYPD - určuje druh procesu, který bude zakládán při přepisu plnění úkolů z pracovního souboru do komponenty plnění úkolů
* !!! toto je jedinné povinné nastavení !!!
_this.sp07idtypd='HPXU01'

* atribut SP33CISDPM - určuje datové úložiště vzniklého procesu
_this.sp33cisdpm='01'

* atribut SQL_UKOLY_PLUS - doplňuje implicitní výběr úkolů pro založení nového plnění úkolu
_this.sql_ukoly_plus='nkukol.nk43stav in(2,3) and nkpredpr.nk01stav=4'

* atribut VYRAZ_STROM_PREDMET - mění implicitní zobrazení předmětu projektu ve stromu, ze kterého se vybírají úkoly pro založení nového plnění úkolu
_this.vyraz_strom_predmet='ALLTRIM(sp62artikl)'

* atribut VYRAZ_STROM_UKOL - mění implicitní zobrazení druhu úkolu ve stromu, ze kterého se vybírají úkoly pro založení nového plnění úkolu
TEXT TO _this.vyraz_strom_ukol noshow
ALLTRIM(nk53nazdru)+IIF((pa13id='T' AND nk53id <> 'IIS') or EMPTY(nk43text),'',' ['+allTRIM(nk43text)+']')
ENDTEXT

* atribut VYRAZ_STROM_ORDER - mění implicitní seřazení úkolů ve stromu, ze kterého se vybírají úkoly pro založení nového plnění úkolu
_this.vyraz_strom_order=[sp62artikl+IIF(pa13id='T','A','B')+nk53nazdru]

* atribut VYRAZ_NADPIS_CAPTION - mění implicitní zobrazení nadpisu plnění úkolu v seznamu rozpracovaných plnění úkolů
TEXT to _this.vyraz_nadpis_caption noshow
IIF(vykony.nk62datum=DATE(),'',
LEFT(TRANSFORM(vykony.nk62datum),IIF(YEAR(vykony.nk62datum)=YEAR(DATE()),6,20))+' ')+
TRIM(vykony.sp62artikl)+'; '+TRIM(vykony.nk53nazdru)+
IIF((vykony.pa13id='T' AND vykony.nk53id <> 'IIS') or EMPTY(vykony.nk43text),'',' ['+allTRIM(vykony.nk43text)+']')+
IIF(vykony.nk62hodin=0,'',' - '+thisform.trans_hodin(vykony.nk62hodin)+' hod.')
ENDTEXT

* atribut VYRAZ_NADPIS_ZMENA - mění implicitní zobrazení v menu úkolů zobrazovaném při změně druhu úkolu předmětu úkolu
TEXT to _this.vyraz_nadpis_zmena noshow
TRIM(sp62artikl)+'; '+TRIM(nk53nazdru)+IIF((pa13id='T' AND nk53id <> 'IIS') or EMPTY(nk43text),'',' ['+allTRIM(nk43text)+']')
ENDTEXT

* atribut VYRAZ_PODMINKA_TIMER - určuje logický výraz - je-li při založení nového plnění úkolu vyhodnocen TRUE, bude toto plnění založeno se spuštěným měřením času
_this.vyraz_podminka_timer=[sp60id='0001']

* metodou SPSEOB_ADD se stanoví to, zda bude s plněním úkolu vstupován obchodní selektor a jaké selektory se budou vstupovat
* např. pro plnění úkolů, jejichž název předmětu projektu začíná pismenem A, je povinný vstup obchodního selektoru začínajícího písmeny IPV0
_this.spseob_add([sp62artikl='A'],[sp10idzak like 'IPV0%'])
* a dále pro plnění úkolů, jejichž název předmětu projektu začíná pismenem E, je povinný vstup obchodního selektoru začínajícího písmenen E
_this.spseob_add([sp62artikl='E'],[sp10idzak like 'E%'])

* atribut TIMER_CLOSECONN.INTERVAL - uvádí čas v milisekundách, po jeho uplynutí je automaticky uzavřeno otevřené spojení s databází
_this.Timer_closeconn.interval=5000

Ing. Petr Filip 28.01.10


Zákonné pojištění odpovědnosti

Zákonné pojištění odpovědnosti
a jednatelé

Úprava se projeví zejména ve firmách, které mají pracovníky, kteří jsou odměňování podle obchodního zákoníku mzdou rovnou nebo vyšší než 5900,- Kč.

V činnosti Doplňující údaje je nové zaškrtávátko "Zák. poj. odpovědnosti" . Při jeho zaškrtnutí dojde k započítání dané mzdové položky do výpočtu základu zákonného pojištění odpovědnosti (Kooperativa). Nové zaškrtávátko je automaticky nastaveno podle existujícího zaškrtávátka "Základ s.p.", které se dosud využívalo pro výpočet zákonného pojištění odpovědnosti. U běžných pracovníků není potřeba nic nastavovat, ale u lidí, kteří jsou odměňování podle obchodního zákoníku mzdou rovnou nebo vyšší než 5900,- Kč musíte provést změny na mzdových položkách. Musíte jim zadat nové mzdové položky, které nebudou mít zaškrtnuto zaškrtávátko "Zák. poj. odpovědnosti"

Z legislativy vyplynulo, že pokud má někdo odměnu za výkon funkce jednatele, která je rovná nebo vyšší než 5900 Kč, pak jeho odměna není součástí základu zákonného pojištění odpovědnosti, ačkoliv se z ní počítá sociální pojištění.
V tom případě je nutné, aby jeho odměna neměla zaškrtnuto nové zaškrtávátko "Zák. poj. odpovědnosti".

Možné situace:
- Odměna za výkon funkce jednatele bude jedna mzdová položka a nebude mít zaškrtnuto "Zák. poj. odpovědnosti".
- Měsíční mzda pracovníka - zaměstnance bude jiná mzdová položka a bude mít zaškrtnuto "Zák. poj. odpovědnosti".

Ing. Olga Smitková 10.12.09


Čárový kód - výběr událostí obchodu

Čárový kód - výběr událostí obchodu
Výběrová záložka formuláře Události obchodu byla doplněna o možnost výběru čárového kódu uvedeného u artiklu události
Ing. Petr Filip 23.11.09


Čárový kód - výběr událostí skladu

Čárový kód - výběr událostí skladu
Výběrová záložka formuláře Události skladové evidence byla doplněna o možnost výběru čárového kódu uvedeného u artiklu události
Ing. Petr Filip 23.11.09


Dokumenty

Dokumenty
V okně vlastnosti dokumentu je nyní možné změnit druh dokumentu v případě, že uživatel má k původnímu druhu dokumentu právo zápis.
Ing. Petr Filip 03.11.09


Kalendáře - pracovní doba

Kalendáře - pracovní doba
V činnosti Pracovní doba (kalendáře) na záložce FPD do dnech byl přidán nový atribut.

Určí, zda je zadaný den kalenářní pondělí, úterý, středa, ....

Slouží k lepší orientaci v denních kalendářích.
Ing. Olga Smitková 30.11.09


Knihovny ONZ a ELDP novinky

Knihovny ONZ a ELDP novinky
Opravené knihovny jsou vždy na našem FTP.

ONZ
opraveno 11.11.2009
Pokud pracovník má hlášení REGPJ a je potřeba mu udělat změnové ONZ, pak toto lze, protože REGPJ a ONZ se porovnávají.

Z porovnávání je vyjmuta hodnota "pohlaví" (employee_client_stat_mal) protože v REGPJ se uváděla v hodnotách 0,1,2 a v ONZ se uvádí v hodnotách 0,M,Ž
Z porovnání je též vyjmuta hodnota "VS společnosti pro komunikaci s ČSSZ" protože při jeho změně není potřeba hlásit změny u všech pracovníků.

ELDP09
opraveno 1.12.2009
Nemoci, které vznikly po skončení prac. poměru se na ELDP09 nevykazují. Platí to též pro OČR, mateřské (kódy N, R, M).
Pozor, pouze pokud ke skončení p.p došlo v průběhu roku 2008 a výplata dávek nem. poj. plyne i v roce 2009 se údaje s kódem N,R,M vykazují.
Ing. Olga Smitková 30.11.09


Ovládání

Ovládání
Bylo doplněna funkčnost informační lišty formuláře (to je ta, na které se mj. zobrazuje počet zobrazených a označených záznamů) o další reakci na klik myší. Pravý klik na této liště způsobí aktivaci menu Volby.

Bylo doplněna funkčnost zaškrtávacího políčka v mřížce, kterým se označuje záznam. V případě, že menu Volby formuláře obsahuje podmenu OZNAČOVÁNÍ, potom pravý klik na tomto zaškrtávacím políčku způsobí zobrazení menu, které odpovídá obsahu podmenu OZNAČOVÁNÍ (tj. s možnostmi Označení všech, Odznačení všech, ...)
Ing. Petr Filip 05.11.09


Předplňované datum splatnosti pohledávky

Předplňované datum splatnosti pohledávky
V BM je možné nastavení, které způsobí výpočet předplňovanéhé data splatnosti pohledávky volitelně pro různé adresáty vzhledem k datu platby (obvykle je to DZP) nebo aktuálnímu datu vystavení pohledávky.

K tomuto účelu je třeba založit novou obecnou předkontaci adresáta s identifikací BMSPL2 (nazvanou např. 'Splatnost je vzhledem k DZP').
Při vstupu události platby se potom předplňuje datum splatnosti pro adresáty, kteří mají v této obecné předkontaci uveden text začínající malým nebo velkým písmenem A (např. Ano) vypočtený vzhledem k datu platby a pro ostatní vzhledem k aktuálnímu datu.

Pozn.: Pokud požadujete výpočet data splatnosti vždy vzhledem k aktuálnímu datu není třeba obecnou předkontaci adresáta BMSPL2 definovat.
Ing. Petr Filip 23.11.09


Archivace

Archivace
BM nyní obsahuje nástroj, kterým je možné archivovat soubory, které nejsou uloženy v BM, do databáze BM.
Ing. Petr Filip 23.10.09


Dokumenty

Dokumenty
Při otevírání dokumentu Wordu resp. Excelu resp. Powerpointu , který by měl mít podle předlohy dokumentu příponu DOC resp. XLS resp. PPT, ale přitom je tento dokument uložený ve formátu office2007 (přípona DOCX resp. XLSX resp. PPTX), má pracovní soubor dokumentu otevíraný Wordem resp. Excelem resp. Powerpointem příponu DOCX resp. XLSX resp. PPTX.
Tuto funčnost je možné potlačit nastavením BM Preferences->OFFICEX=0.

Při kopírováním dokumentu s příponou DOCX resp. XLSX resp. PPTX do okna 'Spojené dokumenty' tažením myší nebo volbou 'Načíst dokument' po pravém kliku myší, mohou být v překryvném seznamu pro výběr předlohy dostupné také předlohy BM, které jsou definovány s příponou DOC resp. XLS resp. PPT v případě, že není definovaná žádná předloha BM s s příponou DOCX resp. XLSX resp. PPTX.
Ing. Petr Filip 29.10.09


Informační panely

Informační panely
V definicích informačních panelů byly provedeny tyto změny:

1/ Je možné definovat atributy elementu BODY
Provádí se na záložce Další v položce 'Atributy elementu BODY'.
Pro tvar definice platí stejná pravidla jako pro definování atributů elementů resp. sloupců, s těmito rozdíly:
a/ je možné použít vložení definice uložené v knihovnách vkládaného kódu klausulí #INCLUDE
b/ pokud je prvním slovem definice slovo NODEFAULT, potom nebudou v elementu BODY atributy 'topmargin=0 id="bodyID" class = "dtBODY"', které jsou jinak do elementu vkládány automaticky

Př.:
onLoad="return relatedActions('ob11id','sp99','sp24idmj','ob02cj01c');"

2/ Ve vlastnosti 'SQL dotaz' definice uzlu je nyní možné vložit dva skripty provedené před a po provedení SQL dotazu
Oběma skriptům jsou přitom předávány parametry, se kterými je stránka vyvolána (_p1,_p2,...,_p14) a v proměnné _this je předán řídící objekt vytvářející stránku, skriptu před SQL dotazem je navíc předán v proměnné _OBJ_SQL objekt, který má ve svém atributu SQL obsažen text následně prováděného SQL dotazu (skript může tento text měnit).

Provádí se uvedením slova #SCRIPT na začátku definice SQL dotazu (nesmí být před ním žádné mezery ani prázdné řádky).
Za tímto slovem následuje kód skriptu v jazyce Foxpro vyvolaný bezprostředně před provedením SQL dotazu a za ním je na novém řádku slovo #ENDSCRIPT (nesmí být před ním žádné mezery).
Pak následuje vlastní tvar SQL dotazu v syntaxi SQL.
A potom může být uvedeno na samostatném řádku slovo #SCRIPT (nesmí být před ním žádné mezery), za kterým následuje kód v jazyce Foxpro vyvolaný po provedení SQL dotazu.

Př.:
#SCRIPT
* vytvoří proměnnou TOOL.MOJE_PROMENNA a ta se potom použije v SQL dotazu
tool.addproperty('MOJE_PROMENNA','A%')
#ENDSCRIPT
select sp26,sp26datum,sp26nazev,bw01jmeno,sp26index,spdokobs.sp01id,sp01predlo,sp57typdok,spdokobs.sp57id,sp26koment,sp26disk,sp26soubor from %%%.spdokobs spdokobs,%%%.bwuzivat bwuzivat,%%%.sppredlo sppredlo,%%%.spdoktyp spdoktyp,%%%.sppristu sppristu where
spdokobs.sp57id=sppristu.sp44vec and sppristu.sp44typ='tdo' and  sppristu.bw01uziv=?tool.uziv and
sppristu.sp44pristu>1 and
sp26nazev like ?TOOL.MOJE_PROMENNA and
spdokobs.bw01uziv=bwuzivat.bw01uziv and spdokobs.sp01id=sppredlo.sp01id and spdokobs.sp57id=spdoktyp.sp57id
#SCRIPT
* modifikuje data, která vrátil SQL dotaz v kurzoru DATA
select data
replace all sp26nazev with '* '+sp26nazev
#ENDSCRIPT

Nebo:
#SCRIPT
* doplní následně provedený SQL dotaz
_OBJ_SQL.SQL=_OBJ_SQL.SQL+" and sp26nazev like 'A%' "
#ENDSCRIPT
select sp26,sp26datum,sp26nazev,bw01jmeno,sp26index,spdokobs.sp01id,sp01predlo,sp57typdok,spdokobs.sp57id,sp26koment,sp26disk,sp26soubor from %%%.spdokobs spdokobs,%%%.bwuzivat bwuzivat,%%%.sppredlo sppredlo,%%%.spdoktyp spdoktyp,%%%.sppristu sppristu where
spdokobs.sp57id=sppristu.sp44vec and sppristu.sp44typ='tdo' and  sppristu.bw01uziv=?tool.uziv and
sppristu.sp44pristu>1 and
spdokobs.bw01uziv=bwuzivat.bw01uziv and spdokobs.sp01id=sppredlo.sp01id and spdokobs.sp57id=spdoktyp.sp57id
#SCRIPT
* modifikuje data, která vrátil SQL dotaz v kurzoru DATA
select data
replace all sp26nazev with '* '+sp26nazev
#ENDSCRIPT

Pozn.: V případě, že je potřeba použít pouze skript po SQL dotazu, potom je třeba definovat skript prováděný před SQL dotazem prázdný.
Např.:
#SCRIPT
#ENDSCRIPT
select sp26,sp26datum,sp26nazev,bw01jmeno,sp26index,spdokobs.sp01id,sp01predlo,sp57typdok,spdokobs.sp57id,sp26koment,sp26disk,sp26soubor from %%%.spdokobs spdokobs,%%%.bwuzivat bwuzivat,%%%.sppredlo sppredlo,%%%.spdoktyp spdoktyp,%%%.sppristu sppristu where
spdokobs.sp57id=sppristu.sp44vec and sppristu.sp44typ='tdo' and  sppristu.bw01uziv=?tool.uziv and
sppristu.sp44pristu>1 and
spdokobs.bw01uziv=bwuzivat.bw01uziv and spdokobs.sp01id=sppredlo.sp01id and spdokobs.sp57id=spdoktyp.sp57id
#SCRIPT
* modifikuje data, která vrátil SQL dotaz v kurzoru DATA
select data
replace all sp26nazev with '* '+sp26nazev
#ENDSCRIPT

Ing. Petr Filip 02.09.09


Korektor transformovaných dat

Korektor transformovaných dat
'Korektor transformovaných dat' je nový prvek zpracování procesů v BM.

Ke každému druhu procesu je možné definovat právě jeden nebo žádný 'Korektor'.
Jedná se o definici kódu v jazyce Foxpro, který je spouštěn v rámci zpracování fyzického procesu v okamžiku po provedení všech transformací do operace těsně před tím, než jsou data předplněná tranformací zobrazena uživateli ve formuláři operace.

Kromě kódu v jazyce Foxpro obsahuje korektor odkaz na 'Sadu systémových konstant', které definují parametry, kterými se tento kód řídí.

Při spuštění korektoru má jeho kód k dispozici parametry:
_this - objekt - řídící objekt transformace (obsahuje mj. atributy identifikující operaci)
_thisform - objekt - objekt formuláře
_alias - text - alias kurzoru, do kterého byla transformována data
_params - objekt - objekt s atributy, které mají hodnoty sady systémových konstant

Příklad Korektoru:
Proces je faktura přijatá, která může (a nemusí) být vytvářena na na základě dokumentu ve formátu ISDOC
Jeho 'Sada systémových konstant' mj. obsahuje konstanty:
- AKTIVNI - numerická hodnota - uvedením hodnoty jiné než 1 je možné korektor vypnout
- OP_DPH, ve které je uveden seznam všech operací DPH, jejichž transformovaná data mají být korigována (úkolem korektoru pro tyto operace je korigovat transformované hodnoty podle hodnot uvedených v souboru ISDOC tak, aby částky odpovídaly ... )
- OP_PLA, ve které je uveden seznam všech operací plateb, jejichž transformovaná data mají být korigována (úkolem korektoru pro tyto operace je korigovat transformované hodnoty podle hodnot uvedených v souboru ISDOC tak, aby částky odpovídaly, doplnit variabilní symbol, hodnotu zálohy, datum splatnosti, identifikaci odpovídajícího bankovního spojení, ...)

A tady je jeho kód:
do case
case _params.AKTIVNI<>1
    return
case _this.sp06idsubs='DPH'  and je_to_operace_ke_zpracovani(_this.sp07idtyp,_params.OP_DPH) and je_podle_dokumentu_isdoc(_this)
    do zpracuj_dph with _this,_alias
case _this.sp06idsubs='PLA'  and je_to_operace_ke_zpracovani(_this.sp07idtyp,_params.OP_PLA) and je_podle_dokumentu_isdoc(_this)
    do zpracuj_pla with _this,_alias
endcase

Procedure je_to_operace_ke_zpracovani
Lparameters _sp07idtyp,_filtr
Return atc([,]+alltrim(_sp07idtyp)+[,],[,]+strt(_filtr,' ')+[,])>0

Procedure je_podle_dokumentu_isdoc
Lparameters _this
Return tool.sql_dotaz([select count() from %%%.spprc,%%%.bwobject,%%%.spdokobs ...])>0

Procedure zpracuj_dph
Lparameters _this,_alias
* .
* .

Procedure zpracuj_pla
Lparameters _this,_alias
* .
* .

Pozn.: tvůrce Korektoru zakládá hodnoty 'Sady systémových konstant' s datem platnosti od 1.1.2000, při potřebě změnit hodnotu konstanty v konkrétní implementaci je vhodné zadat novou hodnotu dané konstanty s vyšším datem platnosti od.
Pokud by nebyl dodržen tento postup mohlo by dojít při importu nové verze korektoru balíčkem k nežádoucímu přepisu hodnoty konstanty v dané implementaci.

Ing. Petr Filip 03.09.09


Odepisovaný majetek

Odepisovaný majetek
Na kartě odepisovaného majetku přibyl atribut 'Umístění', který odkazuje (žluté pole) do stávajícího číselníku "Umístění spravovaného majetku", ke kterému se definují přístupová práva.

Takto definovaná přístupová práva se projevují v komponentě Odepisovaný majetek takto:
- při prohlížení karet investičního majetku daný uživatel vidí jen ty karty, ke kterým má alespoň právo čtení; při založení F3 či opravě F4 karty lze uvést jen ta umístění, ke kterým má daný uživatel přístup "zápis",
- při prohlížení událostí IMO (tj. Změny odepisovaného majetku) daný uživatel vidí jen události týkající se těch karet, ke kterým má alespoň právo čtení; zápis (oprava) změn lze provést jen k těm kartám, k jejichž umístění má daný uživatel nastaveno právo zápisu,
- při výpočtu "účetních odpisů" a "daňových odpisů" šablonou je možné vybrat umístění, za které se má udělat odpis, (tj. je možné odepsat najednou skupinu majetku vymezenou jednotným umístěním) nebo vypočítat odpisy pro veškerý majetek přístupný (zápis) danému uživateli.
- při výpočtu prognózy odpisů je možné vybrat umístění, za které se má udělat prognóza odpisu, (tj. je možné odepsat najednou skupinu majetku vymezenou jednotným umístěním) nebo vypočítat prognózu odpisů pro veškerý majetek přístupný (čtení nebo zápis) danému uživateli.

Umístění je obsaženo na prvé a také na výběrové záložce ve formulářích "Odepisovaný majetek", "Změny odepisovaného majetku" a "Prognózování odpisů".

Ing. Petr Filip 08.09.09


Sady systémových konstant

Sady systémových konstant
Ve formuláři 'Sady systémových konstant' je možné na záložce 'Konstanty' uvádět datum platnosti výskytu konstanty od - do (předpokládá se, že IS BM pracuje, resp. využívá, danou konstantu jen ve zde uvedeném období)

Uvedení data platnosti výskytu konstanty se projeví ve formuláři 'Hodnoty sady konstant':
1/ není možné zadat hodnotu konstanty s platností do období, které nespadá do období platnosti výskytu konstanty uvedené v její definici
2/ platnost výskytu konstanty se uplatní při užití výběrů 'Platné dnes', 'Neplatné dnes, 'Platné k datu' a 'Neplatné k datu'
3/ konstanty, které jsou podle platnosti jejich hodnot platné a přitom nejsou platné podle jejich platností výskytu se v mřížce zobrazují podbarvené světlejší šedou barvou

Pozn.: Tato změna byla vyvolána potřebou vyloučit z přehledu 'dnes platných konstant' ty legislativní konstanty mezd, které vzhledem bouřlivému vývoji legislativy mezd ztratily pro jejich současný výpočet smysl.
Ing. Petr Filip 03.09.09


Dokumenty

Dokumenty
Při otevření dokumentu, ke kterému má aktuální uživatel právo zápis, ale který má v daném okamžiku otevřený pro zápis jiný uživatel, se zobrazuje v hlášení jméno tohoto jiného uživatele.

Toto hlášení obsahuje text:
Dokument otevřen pouze pro čtení !
Případné změny nebudou zaznamenány !
Dokument má právě otevřený pro zápis uživatel "Jméno jiného uživatele".

Ing. Petr Filip 04.08.09


Dokumenty - Spouštěné aplikace

Dokumenty - Spouštěné aplikace
Přípona souboru Spouštěné aplikace nyní může mít až 15 znaků (např. DOCX, XLSX, ISDOC, ISDOCX, ...)
Ing. Petr Filip 25.08.09


EORI

EORI
V adresáři je nově možné na záložce 'Další' zadávat registrační a identifikační číslo hospodářských subjektů (číslo EORI) (Economic Operators Registration and Identification number), které bude sloužit jako společný identifikační údaj hospodářských subjektů a jiných osob při jejich kontaktu s celními orgány v celé Evropské unii. Číslo EORI bude uváděno v celním prohlášení jako identifikátor subjektu.
Ing. Petr Filip 20.08.09


Systémové certifikáty

Systémové certifikáty
Pro potřeby digitálního podpisu je nyní možné ukládat v BM systémové certifikáty.

Systémové certifikáty se definují ve formuláři INFORMAČNÍ CENTRUM -> TYPY A ŘADY -> Systémové certifikáty.
Uvádí se:
Identifikace systémového certifikátu - 6 znaků
Název certifikátu
Druh certifikátu
Soubor certifikátu - jméno souboru na disku s příponou PFX (exportovaný privátní klíč)
Poznámka

Ke každému systémovému certifikátu je nutné uložit heslo, se kterým byl soubor certifikátu (PFX) vytvořen.
Provádí se v menu Volby -> Definovat heslo nebo klávesou F5.
Toto heslo je uloženo v databázi zakryptované.

Podepisování dokumentů probíhá interními rutinami BM.EXE, kterým je jedním z parametrů předána 'Identifikace systémového certifikátu'.

V této chvíli je tímto způsobem vyřešeno podepisování dokumentů:
- PDF - Acrobat Reader - podepisování nástrojem PortableSigner (Open Source) http://portablesigner.sourceforge.net/
- XML - podle norem XML Signature Syntax and Processing (Second Edition) http://www.w3.org/TR/xmldsig-core/, XML Encryption Syntax and Processing http://www.w3.org/TR/xmlenc-core/ , Canonical XML http://www.w3.org/TR/xml-c14n, Exclusive XML Canonicalization http://www.w3.org/TR/xml-exc-c14n/ - podepisování nástrojem XML Security Library (Open Source) http://www.aleksey.com/xmlsec/index.html - tento způsob podepisování dokumentů se používá pro soubory ve formátu ISDOC = elektronická fakturace, kterou připravujeme

Ing. Petr Filip 25.08.09


Neplacené volno typu "pouze organizace"

Neplacené volno typu "pouze organizace"
Platné pro organizace, které používají položku Neplacené volno, která má uvedeno "Pouze organizace"

V legislativě (Démonie 6/2009) se uvádí:

15/09 Zaměstnavatel nemá stálou práci a se zaměstnanci se dohodl, že si budou od 13. do 27. dubna čerpat neplacené volno a zároveň se zavázal, že za zaměstnance zaplatí celé zdravotní pojištění za dobu neplaceného volna. Jak máme posuzovat zaměstnavatelem uhrazené pojistné ve výši 4,5%, které byl povinen platit zaměstnanec? Jedná se u zaměstnance o nepeněžní plnění a musí se u něho navýšit základ daně o částku, kterou za něho uhradil zaměstnavatel?

V případě poskytnutí neplaceného volna může si zaměstnavatel zaměstnance zavázat, že mu uhradí zcela nebo z části částku pojistného, které má za zaměstnance zaměstnavatel povinnost uhradit (tj. 9% z pojistného za dobu neplaceného volna). Zbylých 4,5% by měl vždy uhradit zaměstnanec. Jestliže zaměstnavatel uhradí za zaměstnance i tuto částku, jedná se podle § 6 odst. 3 zákona o daních z příjmů o jinou formu plnění zaměstnavatele za zaměstnance a tudíž se z tohoto plnění musí zaplatit daň z příjmů a tím i pojistné na SZ a VZP. Aby se jednalo o daňově uznatelný výdaj zaměstnavatele, měl by poskytování tohoto plnění uvést v kolektivní smlouvě nebo stanovit vnitřním předpisem, jako „práva zaměstnanců vyplývající z kolektivní smlouvy nebo vnitřního předpisu“ podle § 24 odst. 2 písm. j) bod 5 zákona o daních z příjmů.

Analýza - Bílý motýl
Pokud použijete položku Neplacené volno, která má uvedeno "Pouze organizace", pak je nutné částku 4,5% ze základu zdravotního pojištění za neplacené volno zdanit, odvést z ní ZP a SP. Tato částka je totiž "jiná forma plnění zaměstnavatele za zaměstnance".

Řešení - Bílý Motýl:
a) V DEFINICE - POLOŽKY MEZD - Příjmy a náhrady vytvořit novou mzdovou položku
např. AM_NV s názvem Jiná forma plnění (NV) a v Doplňujících údajích zaškrtnout odpovídající údaje (tj. zdanitený příjem, zdravotní pojištění, sociální pojištění).

b) Samostatně vypočítat kolik je 4,5% ze základu zdravotního pojištění za neplacené volno, které jste u pracovníka zadali. Neplacené volno musí být typu "pouze organizace"

c) Do výplatního lístku ručně zadat neplacené volno.

d) Do výplatního lístku ručně zadat novou mzdovou položku, např. AM_NV Jiná forma plnění (NV) a zadat sem vypočtené peníze (viz bod b).

e) Výpočet zpracuje veškeré údaje,včetně nové mzdové položky AM_NV.

Ing. Olga Smitková 03.07.09


Spojené dokumenty

Spojené dokumenty
Ve stromech spojených dokumentů je nyní možné určit popis dokumentu ve stromu.
Provádí se nastavením parametru BM Preferences->Skript_pro_popis_dokumentu, kterým se uvádí identifikace knihovny vkládaného kódu, jejíž kód bude spouštěn pro určení popisu dokumentu.
Tento skript musí vracet textovou hodnotu a v okamžiku jeho provádění má k dispozici informace o dokumentu v kurzoru _DOCS, který obsahuje mj.atributy:

SP26
SP26DATUM
SP26NAZEV
SP26INDEX
SP57ID
SP57TYPDOK
SP01ID
SP01PREDLO
SP26SOUBOR
SP26DISK
BW01UZIV
BW01JMENO
BW01JMENOT
SP44PRISTU

Kromě popisu dokumentu ve stromu je možné změnit také ikonu dokumentu vložením názvu souboru ikony do proměnné _NODE.ICON.

Př.:
Do Case
Case sp26disk<>1
Case Empty(Sys(2000,(sp26soubor)+''))
_node.Icon='hotovo'
Case Inlist(Upper(Justext(sp26soubor)),'BMP','ICO','JPG','GIF')
_node.Icon=sp26soubor
Endcase
Return Trans(sp26datum)+' '+Trim(sp26nazev)+Iif(sp26disk=1,' ('+Justfname(sp26soubor)+')','')
Ing. Petr Filip 17.07.09


Definice mzdového listu

Definice mzdového listu
Do definice mzdového listu byl přidán atribut "Vytvářet nulový řádek" - Ano/Ne.

Implicitní nastavení je Ano.

Při výpočtu mzdového listu u mnoha pracovníků vznikají řádky, které jsou u daného pracovníka v celém roce nulové. Některé řádky také mají smysl pouze u úzké skupiny pracovníků (ostatní tam budou vždy - ve všech měsících - mít nuly). Příkladem takového řádku jsou třeba Exekuce.

Pokud na takovéto řádky použijete nastavení "Vytvářet nulový řádek" - Ne, vytvoří se tento řádek pouze u pracovníků, kteří v něm mají nějaké hodnoty (alespoň v jednom měsíci). U ostatních pracovníků se řádek vynechá.
Ing. Olga Smitková 01.06.09


Podpis výstupu do PDF

Podpis výstupu do PDF
Aktuální verze knihovny pro výstup do PDF (v balíčcích) umožňuje výstupní dokument digitálně podepsat.

Parametr SIGNEDPDF=1 určuje, že dokument PDF má být digitálně podepsán aplikací PortableSigner. Uplatní se v případě, že je aplikace PortableSigner nainstalována (na počítači se vyskytuje soubor 'C:\Program Files\MagWien\PortableSigner\PortableSigner.jar'). Pro PortableSigner se neprovádí AUNTOINSTALL, protože pro jeho funkci je třeba instalovat Sun-Javu a pro Sun-Javu 'local_policy.jar' a 'US_export_policy.jar'.
Samotné podepisování potom probíhá tak, že se objeví okno aplikace PortableSigner, ve kterém poprvé uživatel vybere soubor PFX (v něm je uložen jeho podpis chráněný heslem), zadá heslo a dokument PDF podepíše.

Ing. Petr Filip 02.06.09


Kalkulátor

Kalkulátor
Byla doplněna funkčnost kalkulátoru:
1/ nové tlačítko 'Copy' kopíruje výsledek ve zobrazený vstupním poli do schránky (clipboardu)
2/ pravý klik na tlačítku '=' kopíruje výsledek výpočtu do schránky (clipboardu)
3/ pravý klik na tlačítku 'SUM' kopíruje výsledek výpočtu do schránky (clipboardu)
4/ výpočet provedený klávesou CTRL+ENTER kopíruje výsledek do schránky (clipboardu)
5/ kalkulátor pamatuje svou pozici na obrazovce v rámci aktuálního spuštění BM
6/ kalkulátor pamatuje počet desetin výpočtu v rámci aktuálního spuštění BM
7/ kalkulátor pamatuje posledních 100 mezivýsledků v překryvném seznamu v rámci aktuálního spuštění BM
8/ do překryvného seznamu mezivýsledků je možné vkládat poznámky - za poznámku se považuje text uvedený znakem '*'
9/ v překryvném seznamu mezivýsledků je možné odstranit záznam klávesou CTRL+DEL
Ing. Petr Filip 15.05.09


Výkazy

Výkazy
Byla doplněna funkčnost makra $RS(...), které se používá ve statistických výkazech v buňkách typu vzorec.

Doposud bylo možné toto makro používat pouze pro vložení seznamu buněk Excelu pro různé funkce Excelu (např. =SUM($RS(...)), =AVG($RS(...)) , ....).

V aktuální verze BM může makro $RS(...) vkládat do výsledného výrazu místo seznamu buněk Excelu jejich součet.
Stane se tak v případě, že posledním znakem vzorce před makrem $RS(...) je znak '=' nebo '+' nebo '-'.

Příklad.:
K výrazu - =SUM($RS(mezisoucet)), který je vyhodnocen např. =SUM(C1,C5,C7,C11:C17,C20)
je ekvivalentní výraz - =$RS(mezisoucet), který je vyhodnocen např. =C1+C5+C7+SUM(C11:C17)+C20

Tato změna byly vyvolána vlastností Excelu ve verzích 11 a nižších, podle které je možné v seznamu funkce SUM uvádět nejvýše 32 položek.
Ing. Petr Filip 25.05.09


Výkazy - kontingenční listy

Výkazy - kontingenční listy
Byla doplněna funkčnost Výkazů BM o možnost definovat listy, které obsahují kontingenční tabulku Excelu.

Popis nástroje Excelu kontingenční tabulka najdete v nápovědě programu Excel.
Píše se v ní mj.:
Pomocí kontingenční tabulky můžete shrnout, analyzovat, prozkoumat a zobrazit souhrnná data. Pomocí kontingenčního grafu lze vizualizovat tato souhrnná data v kontingenční tabulce a můžete snadno zobrazit porovnání, vzory a trendy. Jak kontingenční tabulka, tak i kontingenční graf vám umožňují provádět informovaná rozhodnutí o důležitých datech v organizaci.

Ve formulářu "Definice výkazů' přibyl atribut:
- zobrazovat seznam polí - překryvný seznam - Ano/Ne - který určuje jestli se má obrazovat seznam polí kontingenčních tabulek (pouze pro Excel 2007)

Změnil se vzhled formuláře 'Listy výkazů':
- formulář byl rozdělen na záložky
- na 1.záložce nazvané 'Listy výkazů' se vstupují základní informace o listu, které jsou společné pro 'Běžné' a 'Kontingeční' typy listů (typ listu se vstupuje na této záložce)
- na 2.záložce nazvané 'Běžný list' se vstupují atributy běžných typů listů
- na 3.záložce nazvané 'Kontingenční list' se vstupují atributy kontingenčních typů listů
- na 4.záložce nazvané 'Pole kontingenčního listu' se vstupují vlastnosti jednotlivých polí vytvářené kontingenční tabulky

Na 3.záložce nazvané 'Kontingenční list' se vstupuje jediný nový atribut:
- SQL - text - obsahuje SQL dotaz, který má být zdrojem dat pro vytvářenou kontingenční tabulku
V SQL dotazu se mohou uplatnit proměnné listu výkazu uvedené v hranatých závorkách.

Na 3.záložce nazvané 'Kontingenční list' se vstupuje seznam polí vytvářené kontingenční tabulky, přitom se pro každé pole definuje:
- název pole - text - musí korespondovat s názvem atributu vytvářeným SQL dotazem (musí být exaktně totožný, tj.včetně diakritiky a velkých a malých písmen)
- pořadí - číslo - pořadí zpracování pole při vytváření kontingenční tabulky
- oblast - překryvný seznam - Žádná,Filtr sestavy,Popisky sloupců,Popisky řádků,Hodnoty - určuje oblast kontingeční tabulky, ve které se má pole uplatnit
- určení oblasti výrazem - text - tento atribut je určen pro uvedení proměnné výkazu tak, aby při použití list v konkrétním výkazu bylo možné měnit umístění jednotlivých polí - uplatní se pouze v případě, že výraz představuje numerickou hodnotu v intervalu 1-5
- filtr sestavy - text - uplatní se pro pole v oblasti 'Filtr sestavy' - uplatní se pouze v případě, že hodnota výrazu odpovídá některé z hodnot pole v kontingenční tabulce
- výběr popisků - text - uplatní se pro pole v oblasti 'Filtr sestavy' nebo 'Popisky sloupců' nebo 'Popisky řádků' - výraz musí obsahovat textový literál, který obsahuje výraz vyhodnocovaný v okamžiku vytváření kontingenční tabulky - přitom tento výraz obvykle pracuje s proměnnou _PIVOTITEM (objekt položky pole) nejčastěji s jeho vlastností _PIVOTITEM.VALUE
- zobrazení podpopisků - text - uplatní se pro pole v oblasti 'Popisky sloupců' nebo 'Popisky řádků' - výraz musí obsahovat textový literál, který obsahuje výraz vyhodnocovaný v okamžiku vytváření kontingenční tabulky - přitom tento výraz obvykle pracuje s proměnnou _PIVOTITEM (objekt položky pole) nejčastěji s jeho vlastností _PIVOTITEM.VALUE
- formát čísla - text - uplatní se pro pole v oblasti 'Hodnoty'
- skript - text - skript v jazyce Foxpro provedený po zpracování daného pole (kódu jsou přitom k dispozici objekty - v proměnné _PIVOTFIELD objekt pole kontingenční tabulku a v proměnné _PIVOTTABLE objekt kontingenční tabulky)
- poznámka - text

Upozornění:
V případě, že databáze nepoužívá interní kódování textu v kódu 1250, potom se nebude v kontingenčních tabulkách správně zobrazovat diakritika.
V tom případě může pomoci nastavení parametru BM
Preferences->ADODBcharset=cp1250,
který určuje kódovou stránku, ve která mají být vraceny texty SQL dotazů zpracovávaných prostřednictvím ADO.

Další změny v definicích výkazů:
- ve formuláři 'Definice výkazů' - doplněna výběrová záložka
- ve formuláři 'Listy výkazů' - doplněna výběrová záložka

Příklad - Kontingenční tabulka, která čerpá z účetní obratové tabulky.
Typ listu - 'Kontingenční'
SQL -
SELECT
left(ucobrtab.uc01id,1) "Třída",
trim(ucobrtab.uc01id)+' '+trim(uc04popuct) "Účet",
uc03rok Rok,
uc03mesic "Měsíc",
uc03mdr "Má dáti",
uc03dalr "Dal",
(uc03mdr-uc03dalr)*(if uc01strana=2 then -1 else 1 endif) Obrat,
sp10idzak OBS,
sp11idzak ORS,
sp20idzak TVS
FROM
%%%.ucobrtab ,%%%.ucrozvrh,%%%.ucrozvrn
WHERE
uc03faze=2 and uc03druh=1 and (uc03dalr<>0 or uc03mdr<>0)
and
ucrozvrh.uc01id=ucobrtab.uc01id
and
ucrozvrn.uc01id=ucobrtab.uc01id and ucrozvrn.sp38id=[jazyk]
and
sp11idzak like [sql_sp11idzak_like]

V SQL dotazu je uvedená proměnná [sql_sp11idzak_like], která musí být deklarovaná v parametrech listu (viz.dále).

Pole kontingenčního listu:
Třída - Pořadí=10 - Oblast=Filtr sestavy - Určení oblasti výrazem=[oblast_trida] - Filtr sestavy=[filtr_trida] - Výběr popisků=[popisky_trida] - Zobrazení podpopisků=[rozbaleni_trida]
Rok - Pořadí=20 - Oblast=Filtr sestavy - Určení oblasti výrazem=[oblast_rok] - Filtr sestavy=[filtr_rok] - Výběr popisků=[popisky_rok] - Zobrazení podpopisků=[rozbaleni_rok]
Účet - Pořadí=30 - Oblast=Popisky řádků - Určení oblasti výrazem=[oblast_ucet] - Filtr sestavy=[filtr_ucet] - Výběr popisků=[popisky_ucet] - Zobrazení podpopisků=[rozbaleni_ucet]
ORS - Pořadí=40 - Oblast=Popisky řádků - Určení oblasti výrazem=[oblast_ors] - Filtr sestavy=[filtr_ors] - Výběr popisků=[popisky_ors] - Zobrazení podpopisků=[rozbaleni_ors]
Měsíc - Pořadí= 50 - Oblast=Popisky sloupců - Určení oblasti výrazem=[oblast_mesic] - Filtr sestavy=[filtr_mesic] - Výběr popisků=[popisky_mesic] - Zobrazení podpopisků=[rozbaleni_mesic]
Obrat - Pořadí=60 - Oblast=Hodnoty - Určení oblasti výrazem=[oblast_obrat] - Formát čísla=#,##0.00
TVS - Pořadí=70 - Oblast=Žádná - Určení oblasti výrazem=[oblast_tvs] - Filtr sestavy=[filtr_tvs] - Výběr popisků=[popisky_tvs] - Zobrazení podpopisků=[rozbaleni_tvs]
OBS - Pořadí=80 - Oblast=Žádná - Určení oblasti výrazem=[oblast_obs] - Filtr sestavy=[filtr_obs] - Výběr popisků=[popisky_obs] - Zobrazení podpopisků=[rozbaleni_obs]

Pozn.:
Pokud má být ve výrazech 'Výběr popisků' resp. 'Zobrazení podpopisků' uveden přímo výraz (místo např. [popisky_ors]), musí být tento výraz v definici pole uveden jako textový literál (např. [_pivotitem.value = 'ABC']).

V definici polí příkladu jsou použité proměnné listu a některé z nich musí být deklarovány v parametrech listu, jinak by byla při vytváření listu hlášena syntaktická chyba.
V parametrech listu proto musí být uvedeno:
jazyk=tool.jazyk
sql_sp11idzak_like='%'
popisky_trida=''
rozbaleni_trida=''
popisky_rok=''
rozbaleni_rok=''
popisky_ucet=''
rozbaleni_ucet=''
popisky_ors=''
rozbaleni_ors=''
popisky_mesic=''
rozbaleni_mesic=''
popisky_tvs=''
rozbaleni_tvs=''
popisky_obs=''
rozbaleni_obs=''

Aplikace příkladu listu ve výkazu:

Název listu ve výkazu - 'Zisk vloni'
Parametry listu ve výkazu:
filtr_trida='6'
filtr_rok=trans(year(date())-1)

Název listu ve výkazu - 'Zisk letos'
Parametry listu ve výkazu:
filtr_trida='6'
filtr_rok=trans(year(date()))

Název listu ve výkazu - 'Náklady vloni'
Parametry listu ve výkazu:
filtr_trida='5'
filtr_rok=trans(year(date())-1)

Název listu ve výkazu - 'Náklady letos'
Parametry listu ve výkazu:
filtr_trida='5'
filtr_rok=trans(year(date()))

Název listu ve výkazu - 'Zisk letos za středisko ABC'
Parametry listu ve výkazu:
filtr_trida='6'
filtr_rok=trans(year(date()))
popisky_ors=[_pivotitem.value = 'ABC']

Název listu ve výkazu - 'Zisk letos za středisko ABC - jinak - s fitrováním dat v SQL dotazu'
Parametry listu ve výkazu:
filtr_trida='6'
filtr_rok=trans(year(date()))
sql_sp11idzak_like='ABC%'

Název listu ve výkazu - 'Zisk letos - členění podle TVS'
Parametry listu ve výkazu:
filtr_trida='6'
filtr_rok=trans(year(date()))
oblast_ors=1
oblast_tvs=4

Název listu ve výkazu - 'Zisk letos - členění podle OBS'
Parametry listu ve výkazu:
filtr_trida='6'
filtr_rok=trans(year(date()))
oblast_ors=1
oblast_obs=4

Název listu ve výkazu - 'Zisk sumárně (rok ve sloupcích) - poslední čtyři roky'
Parametry listu ve výkazu:
filtr_trida='6'
oblast_rok=3
popisky_rok=[VAL(_pivotitem.value) > year(date())-4]
rozbaleni_rok=[.F.]
* rozbaleni_rok=[.F.] - rok bude mít podřízené popisky Měsíce a [.F.] (FALSE) způsobí to, že nebudou po vytvoření listu vidět (v Excelu 2007 se měsíce jednotlivých roků zobrazují jako podsložky - nebudou rozbalené)

Ing. Petr Filip 11.05.09


Komplexní zadávání výplatních lístků

Komplexní zadávání výplatních lístků
V komponentě Mzdy byla vytvořena nová činnost "Komplexní zadávání výplatních lístků". Má obdobnou funkčnost jako "Prohlížení výplatních lístků".

Slouží k zadávání údajů a k jejich prohlížení. Pomocí menu Volby je též možné provést "Optimalizovaný výpočet mezd" (např. za jednoho pracovníka, za skupinu pracovníků nebo za všechny pracovníky (zadá se %)).

Související tiskové sestavy zatím zůstávají v ostatních činnostech, ale v budoucnu sem budou převedeny.

Ing. Olga Smitková 27.04.09


Měsíční průměry ve mzdách

Měsíční průměry ve mzdách
Dopřesnění způsobu výpočtu - upozornění :
I když organizace používá kalendáře denní, musí být vygenerován plánovací kalendář ve variantě měsíční. Jinak nedojde k výpočtu měsíčních průměrů.

Celý popis :
Způsob výpočtu měsíčního průměrného výdělku.

Do činnosti Parametry byl vložen atribut kalendář, který určuje jeden z měsíčních kalendářů FPD jako plánovací kalendář, platný pro všechny zaměstnance.

V činnosti Uzávěrka, nebo v činnosti Přepočet h., d. a m. průměrů se bude pracovat s tímto kalendářem, s jeho dny. Úvazek hodin za den je 0, tj. i počet hodin v jednotlivých měsících kalendáře je 0.

Průměrný počet dnů v měsíci se zjistí pomocí tohoto kalendáře.
Měsíční průměr je počítán pomocí denního průměru a průměrného počtu dnů z kalendáře z parametrů. Průměrný počet dnů se vezme tabulky, která sleduje fond pracovní doby ve variantě měsíční. Tj. musí být vygenerován plánovací kalendář ve variantě měsíční, a to i tehdy, když organizace používá kalendáře denní.

Do Protokolu dojde k zápisu položky PRUM06 - informativně se sem zapíše použitý průměrný počet dnů v měsíci.
Ing. Olga Smitková 23.04.09


Předlohy výstupu

Předlohy výstupu
V okně, ze kterého se spouštějí a upravují předlohy výstupu je nyní možné kromě zobrazení ve formě různého typu seznamu, zvolit také zobrazení předloh ve formě stromu.

Volba zobrazení se provádí stejným způsobem jako se provádí změna zobrazení činností v okně hlavního menu programu (tlačítkem Strom).

Předlohy výstupu jsou ve stromu organizovány do složek, které se určují podle nové vlastnosti předloh výstupu a metapředloh výstupu - 'Skupina' (změnily se formuláře 'Vlastnosti předlohy' a 'Metapředlohy výstupu')
Tyto skupiny se definují činností 'Seznam skupin procesů / předloh výstupu' (původní činnost se jmenovala 'Seznam skupin procesů').
Ve formuláři 'Seznam skupin procesů / předloh výstupu' přibyly atributy:
- Skupina procesu - překryvný seznam - Ano/Ne
- Skupina předlohy výstupu - překryvný seznam - Ano/Ne
- Osobní skupina předlohy výstupu - překryvný seznam - Ano/Ne

Předlohy a metapředlohy, které nemají uvedenou skupinu, nejsou zařazeny do žádné složky (zobrazují se v první úrovni stromu za složkami).
Na rozdíl od zobrazení ve formě seznamu, ve kterém jsou metapředlohy umisťovány seřazené podle názvu na jeho začátek, jsou ve složkách stromu jeho poduzly řazené podle názvu bez ohledu na to jestli se jedná o předlohy nebo metapředlohy.
Také v souvislosti s tímto řazením ve stromu byla změněna ikona (Panda) položek seznamů a stromů, které představují metapředlohy.

Při uzavírání okna předloh výstupu se ukládá pro každého uživatele informace, které složky stromu byly rozbalené, takže při následujícím otevření tohoto okna stejným uživatelem budou rozbalené.

Po pravém kliku na předlohu výstupu ve stromu se ve vyvolaném menu navíc zobrazují volby:
Metapředlohy - vyvolání formuláře pro definování metapředloh
Skupiny procesů / předloh výstupu - vyvolání formuláře pro definování skupin
OSOBNÍ SKUPINA PŘEDLOHY - zobrazí podmenu, ve kterém uživatel může vybrat skupinu předloh výstupu
Nastavení stromu - vyvolání formuláře pro definování vlastností zobrazení stromu

Po pravém kliku metapředlohu výstupu ve stromu se vyvolaném menu zobrazují volby:
Metapředlohy - vyvolání formuláře pro definování metapředloh
OSOBNÍ SKUPINA PŘEDLOHY - zobrazí podmenu, ve kterém uživatel může vybrat skupinu předloh výstupu
Skupiny procesů / předloh výstupu - vyvolání formuláře pro definování skupin
Nastavení stromu - vyvolání formuláře pro definování vlastností zobrazení stromu

Po pravém kliku na složku stromu (skupinu) se vyvolaném menu zobrazují volby:
Metapředlohy - vyvolání formuláře pro definování metapředloh
Skupiny procesů / předloh výstupu - vyvolání formuláře pro definování skupin
Nastavení stromu - vyvolání formuláře pro definování vlastností zobrazení stromu

Výběrem z podmenu volby OSOBNÍ SKUPINA PŘEDLOHY může uživatel zařadit danou předlohu do vlastní soukromé skupiny předloh.
V podmenu volby OSOBNÍ SKUPINA PŘEDLOHY je také možné vybrat položku 'ŽÁDNÁ SKUPINA', kterou je možné přidělení osobní skupiny předlohy zrušit.
Přitom platí to, že v případě, že má některá předloha uvedenou skupinu ve svých vlastnostech (formulář 'Vlastnosti předlohy') a zároveň uživatel zařadil předlohu v podmenu volby OSOBNÍ SKUPINA PŘEDLOHY do jiné skupiny, potom je tato předloha zobrazena v jeho stromu dvakrát tj. v obou skupinách.

Tato nová funkčnost je možná ve verzích BM pod Visual Foxpro 8.0 nebo vyšší.

----------------------------------------------------------------------------------
Další změnou jsou přesuny některých vlastností předlohy výstupu na záložkách formuláře 'Vlastnosti předlohy':
- Název předlohy přesunut ze záložky Popis na záložku Obecné
- Poznámka ze záložky Obecné na záložku Info
- Informace o datu vytvoření a změně ze záložky Info na záložku Popis
- Profil spušténí za záložky Info na záložku Popis

Ing. Petr Filip 22.04.09


Spojené dokumenty, Strom hlav. procesu

Spojené dokumenty, Strom hlav. procesu
Ve stromech zobrazovaných ve formulářích 'Spojené dokumenty', 'Strom hlavního procesu' a v obdobných stromech formuláře 'Okno úloh' je nyní možné doplnit implementačně definovatelné funkce pro menu vyvolávaná po pravém kliku myší na uzlu představující objekt BM.

Pro definici těchto nastavení vznikla nová činnost INFORMAČNÍ CENTRUM -> TYPY A ŘADY -> Doplňující položky menu objektů.

Ve formuláři této činnosti se uvádí:
Položka - text - identifikace položky menu
Druh - překryvný seznam - definuje přístupová práva
Objekt BM - překryvný seznam - určuje typ objektu BM (nemusí být uveden), pro který se má položka menu uplatnit
Pořadí - číslo - určuje pořadí zobrazení položky menu
Podmínka - text - je-li uveden, musí obsahovat kód v jazyce Foxpro, který vrací logickou hodnotu .T. (TRUE) nebo .F. (FALSE)
Typ kódu - překryvný seznam - Nekompilovaný kód / Kompilovaný kód - rozhoduje o tom, jestli má být spuštěný kód kompilován
Kód - text - obsahuje kód v jazyce Foxpro spouštěný po výběru položky menu
Poznámka - volný text
Aktualizace - datum a čas, kdy byla naposledy definice položky menu změněna - uplatňuje se při importu balíčků

Doplňující položky menu jsou umisťovány na začátek standardního menu a uplatní se v případě, že 'Objekt BM' není určen nebo je totožný.
O uplatnění doplňující položky menu může také rozhodnout kód Podmínky.
Pro toto rozhodnutí má kód k dispozici předané parametry (v kódu se příkaz PARAMETERS resp. LPARAMETERS neuvádí):
_this - objekt - řídící objekt uzlu stromu, na kterém byl proveden pravý klik
_bw09typ1 - text - identifikace objektu BM
_bw09inst1 - jednoznačná časová identifikace objektu
Kromě toho jsou podle typu objektu BM k dispozici atributy objektu _this:
Pro typ objektu Adresář (AD) - _this.ad01id
Pro typ objektu Artikl (AR) - _this.sp61id,_this.sp60id
Pro typ objektu Proces (PR) - _this.sp33cisdr,_this.sp33cisdpm,_this.sp33cisd
Pro typ objektu Operace (OO) - _this.sp33cisdr,_this.sp33cisdpm,_this.sp33cisd,_this.sp06idsubs,_this.sp07idtyp,_this.sp33porad

Kód spouštěný po výběru položky menu má k dispozici parametry (v kódu se příkaz PARAMETERS resp. LPARAMETERS neuvádí):
_this - objekt - řídící objekt uzlu stromu, na kterém byl proveden pravý klik
_bw09typ1 - text - identifikace objektu BM
_bw09inst1 - jednoznačná časová identifikace objektu
_main_objekt - objekt - řídící objekt stromu
Kromě toho jsou podle typu objektu BM k dispozici atributy objektu _this.
Může být spouštěný podle nastavení 'Typ kódu' v kompilovaném nebo nekompilovaném tvaru (kompilovaný tvar je určen pro případy, kdy kód vytváří nemodální objekty např. nemodální formulář).
Parametr _main_objekt je předáván kódu pro případ, že je třeba po provedení kódu provést přezobrazení stromu např. přezobrazení připojených dokumentů příkazem '_main_objekt.prezobraz_uzel(_this,.T.)'.

Ing. Petr Filip 06.04.09


Zprávy databázového serveru

Zprávy databázového serveru
byla vytvořena nová činnost SYSTÉM->Zprávy databázového serveru .

Zobrazí formulář a v něm seznam zpráv databátového serveru (podobný seznam zpráv je možné vidět v programech SQL Central nebo DBConsole).
Zprávy se v seznamu doplňují každých 5 vteřin.
Zprávy jsou zobrazovány pouze pro verze databázového serveru 8 nebo vyšší.

Nová činnost používá volání programu BWSRVMES.
Tento program má parametry:
_form_caption - text - nadpis okna formuláře
_cmdfree_caption - text - popis volného tlačítka formuláře
_cmdfree_script - text - skript v jazyce Foxpro vyvolaný po stisku volného tlačítka
_interval - číslo - interval aktualizace seznamu zpráv databázového serveru - uplatní se, pokud se větší než 3
_filtr - text - je-li uveden budou zobrazeny pouze zprávy začínající daným textem

Pozn.: je-li program BWSRVMES volán v externím příkazu , doplňující vlastnosti formuláře, ..., musí se jednat o kompilovaný kód.

Např.:
LOCAL _kod_foxpro
* v proměnné _kod_foxpro bude kód volného tlačítka formuláře
TEXT TO _kod_foxpro NOSHOW
* kód skriptu nejdříve odstartuje událostní trigger "Prepocet FIFO"
tool.sqlcall(.F.,'TRIGGER EVENT "Prepocet FIFO"')
*  a potom znepřístupní volné tlačítko formuláře
_thisform.cmdfree.enabled=.F.
ENDTEXT
* fomulář bude mít nadpis 'FIFO'
* volné tlačítko buden mít popis 'Přepočet FIFO'
* po je stisku bude vyvolán skript uvedený v proměnné _kod_foxpro
* frekvence aktualizace seznamu zpráv databázového serveru bude 3 vteřiny
DO bwsrvmes WITH 'FIFO','Přepočet FIFO',_kod_foxpro,3
Ing. Petr Filip 10.04.09


Dokumenty Excel 2003 vs. 2007 v BM

Dokumenty Excel 2003 vs. 2007 v BM
Problém dokumentů Microsoft Word a Microsoft Excel ve formátu 2007, které jsou uloženy jako dokumenty BM a jsou otevírány na počítači, který používá Office 2003 s nainstalovaným balíčkem kompatibility s Office 2007 (tyto dokumenty mají běžně přípony DOCX resp. XLSX).

Dokument BM Excelu uložený ve formátu 2007 není možné na počítači s Office 2003 řádně otevřít (neprovede se konverze).
Důvodem je to, že konvertor není součástí Excelu 2003.
Příponě XLSX je substituován program MOC.EXE (tj. "Microsoft Open XML Converter" uložený např."C:\Program Files\Microsoft Office\Office12\Moc.exe") a ne přímo program aplikace Excel.
MOC.EXE nejprve soubor konvertuje a následně spustí Excel.
Důsledkem toho je, že ani ze spuštěného Excelu 2003 není možné řádně otevřít dokument ve formátu 2007 (XLSX).

Pro dokument Wordu 2007 (DOCX) v této situaci problém nenastává, protože konvertor je přímo zahrnut do Wordu 2003.
Ing. Petr Filip 17.03.09


Hodnoty předmětu projektu

Hodnoty předmětu projektu
Hodnoty předmětu projektu byly doplněny o elementární hodnotu Měna (definuje se ve formuláři 'Parametry předmětů projektu' na záložce 'Definice struktury').
To také znamená, že tabulka NKHODNP byla doplněna o atribut OC01ID.
Ing. Petr Filip 04.03.09


Okno úloh

Okno úloh
V parametrech nastavení okna úloh je možné nastavit to, aby se při spuštění nového procesu z okna úloh předplňoval adresát zobrazený v aktuálním formuláři pro nově zakládané události v jeho první operaci.
Adresát je předplňován pouze v případě, úvodní operace procesu má nastavenou vlastnost 'Vytvořit záložku při založení procesu'.

Tento parametr nastavení okna úloh se jmenuje 'Předplňovat adresáta v novém procesu' a má tato možná nastavení:
Ano - z formuláře Adresář - adresát se bude předplňovat pouze v případě, že aktuálním formulářem je Adresář
Ano - z formulářů událostí a Adresář - adresát se bude předplňovat pouze v případě, že aktuálním formulářem je Adresář nebo událost operace komponenty
Ano - adresát se bude předplňovat vždy, pokud aktuální formulář obsahuje atribut adresáta
Ne - adresát se nebude nikdy předplňovat
Ing. Petr Filip 06.03.09


Nastavení stromu

Nastavení stromu
V činnostech, které využívají stromové zobrazení, jako je strom hlavního procesu, obecné stromy, strom pracovníka, hlavní menu a okno úloh má uživatel možnost nastavit si zobrazení a způsob ovládání. Toto provede stiskem pravého tlačítka myši na názvu činnosti a zvolí možnost „Nastavení stromu“. Zde jsou k dispozici následující atributy:

¨ font – výběr druhu písma, ve kterém bude daná činnost zobrazena (uživatele je v tomto případě nutno upozornit, aby si vybírali fonty, které zvládají zobrazení diakritiky, jinak pak zobrazení činnosti může vypadat tzv. jako „rozsypaný čaj“)

¨ velikost písma – tlačítkem nahoru nebo dolů si uživatel zvolí velikost daného písma

¨ kurzíva – při zatržení tohoto příznaku bude zvolený font písma ještě zvýrazněn kurzívou

¨ ‘+’ také ve vrcholových uzlech stromu – při standardním stromovém zobrazení činností mají vrcholové uzly před svým názvem ve většině případů ikonu a rozbalují se dvojklikem myši na názvu činnosti (nebo ikoně). Teprve další činnosti pod nimi mají před svým názvem znaménko ‘+’, což znamená, že je možno je ještě dále rozkliknout. Při zatržení tohoto atributu bude znaménko ‘+’ i před názvy vrcholových uzlů a klikem na něj se ihned rozbaluje nabídka činností pod ním.

¨ používat zjednodušené ovládání – při standardním ovládání se činnosti v menu aktivují dvojklikem levého tlačítka myši. Vysvětlíme si na příkladu hlavního menu. Uživatel si dvojklikem myši aktivuje činnost Marketing, ta zůstane rozbalená a dalším dvojklikem si aktivuje činnost Platby. Znamená to, že nyní má v hlavním menu rozbalenu nabídku dvou činností. V případě, že tuto nabídku chce zavřít, musí ji opětovným dvojklikem zase zavřít. Zatržení tohoto příznaku umožňuje uživateli změnit chování činností. Po kliku (jednom kliku levého tlačítka myši – nikoliv dvojkliku) na názvu činnosti se tato okamžitě rozbalí. Při kliku a rozbalení další činnosti se zároveň ihned první rozbalená činnost zase automaticky zavře. Vysvětlíme si opět na příkladu hlavního menu. Uživatel stiskem levého tlačítka myši aktivuje činnost Marketing, ta se ihned rozbalí, dalším stiskem levého tlačítka myši aktivuje činnost Platby. Ta se ihned rozbalí, ale zároveň se ihned automaticky zavře původní otevřená činnost Marketing.

Lehce odlišné chování jednotlivých menu může nastat v případě, že uživatel bude mít v této činnosti zároveň zatrženy atributy „‘+’ také ve vrcholových uzlech stromu“ a „ používat zjednodušené ovládání“. Pak skutečně i při ovládání menu funguje kombinace standardního a zjednodušeného ovládání menu. Při kliku na název činnosti se menu chová podle příznaku „používat zjednodušené ovládání“, tzn. menu se ovládá pouze stiskem levého tlačítka myši. Při kliku na znaménko ‘+’ u vrcholového uzlu se menu ovládá standardně. Opět si tuto situaci vysvětlíme na příkladu hlavního menu. Uživatel má samozřejmě zatrženy oba jmenované atributy. Při stisku levého tlačítka myši na názvu činnosti Marketing se rozbalí nabídka této činnosti. Po stisku znaménka ‘+’ u činnosti Platby se rovněž rozbalí nabídka této činnosti. Dalším stiskem levého tlačítka myši např. na názvu činnosti DHP se automaticky zavře nabídka činnosti Marketing (chová se podle zjednodušeného ovládání menu), ale nabídka činnosti Platby zůstane otevřená (chová se podle standardního ovládání menu).
Daniela Postlová 26.02.09


Prohlížeč výstupů předloh

Prohlížeč výstupů předloh
ve volbách výstupu předloh je možné pro výstup typu Sestava a Prohlížení zaškrtnout 'V prohlížeči výstupů předloh'.
Spustí se formulář 'Prohlížeč výstupů předloh'.

Pouze pro Foxpro 9.
Tisk z formuláře 'Prohlížeč výstupů předloh' nemusí odpovídat běžnému textu (hvězdičky a tečky).

Popis:

Po stisku ikony tiskárna na vybrané předloze výstupu se uživateli zobrazí dialogové okno "zahájení výstupu podle předlohy". Uživatel si v současné době mohl zvolit směr tisku "na tiskárnu, do souboru nebo prohlížení". K volbě prohlížení má nyní k dispozici i možnost nemodálního prohlížení výstupů klasických předloh výstupu. Toto mu umožňuje nový atribut "v prohlížeči výstupů předloh".
Při jeho zatržení se uživateli následně zobrazí daná sestava ve formě náhledu před tiskem ve vlastním formuláři "prohlížeč výstupů předloh" s vlastní ovládací lištou. Pokud nechá uživatel tento formulář aktivní, tak při prohlížení jednotlivých klasických sestav se zatrženým atributem "v prohlížeči výstupů předloh" se všechny tyto sestavy zobrazují jako přehled právě v tomto formuláři, tzn. uživatel může mít např. vyfiltrován přehled vystavených faktur a vyvoláním tisku každé faktury se zatrženým atributem "v prohlížeči výstupů předloh" se do formuláře "prohlížeč výstupů předloh" naplní přehled všech těchto faktur.
Pomocí ikonek na ovládací liště (tlačítko první stránka/předchozí stránka/následující stránka/poslední stránka) se uživatel může v přehledu volně pohybovat, přičemž levá část formuláře zobrazuje přehled předloh výstupu a pravá část formuláře zobrazuje náhled dané předlohy.
Další tlačítko "zachovat/nezachovat poměr rozměrů výšky šířky stránky" funguje jako přepínač a umožňuje uživateli buď zachovat poměr rozměrů výšky a šířky dané předlohy výstupu nebo po jeho stisku roztažení předlohy výstupu do nastavené velikosti daného formuláře. Tím je ovšem porušen poměr rozměrů předlohy výstupu, tzn. že daná předloha výstupu je pro uživatele zvětšená, tj. čitelnější, ovšem bude zřejmě mnohem více zvětšena do šířky. Po stisku pravého tlačítka na tomto přepínači se automaticky upraví šířka formuláře, tzn. zarovná se přesně na velikost stránky.
Tlačítko tiskárna aktivuje tisk dané předlohy výstupu. Tlačítko dveře znamená totéž co ESC, tzn. opuštění a uzavření formuláře "prohlížeč výstupů předloh".
Pokud tedy zůstává tento formulář aktivní, tzn. uživatel ho během práce s IS BM nezavírá, ale např. pouze "uklízí" na dolní lištu PC, přehled jednotlivých zobrazených předloh výstupu narůstá a mohou zde být zobrazeny všechny předlohy, které uživatel použil během dne při práci s IS BM. V případě, že uživatel tento formulář ukončí, přehled předloh výstupu se vymaže a při dalším spuštění tohoto formuláře je opět prázdný.
Tuto vlastnost předloh výstupu lze využívat pouze pro verze IS BM pod FoxPro 9 a vyšší.

Upozornění:
V některých případech nemusí zobrazená předloha výstupu plně odpovídat její vytištěné verzi. Program, který je využit ve formuláři na zobrazení předloh výstupu toto technicky neumožňuje (a není z autorské dílny firmy BM Servis), tzn. pouze ho pro tento formulář využíváme a u některých předloh může docházet ke zkreslení atributů (především atributů typu formát), tzn. že uživatel pak místo částky vidí hvězdičky/tečky nebo jsou chybně zobrazena pořadová čísla apod. V takovém případě doporučujeme, pokud je to technicky možné, aby si uživatel danou předlohu výstupu upravil (tzn. atributy typu formát zvětšil).
Daniela Postlová 06.02.09


Překlad textů

Překlad textů
při překladu textu prvku typu překryvný seznam je možné zaškrtnout 'Uložit přeložený text do BWSLOVPP'.

Zaškrnutí způsobí uložení textu do tabulky BWSLOVPP.
Tato tabulka má atributy:
- bw57idt - jednoznačná identifikace textu - je zobrazena ve formuláři překladu textu prvku typu překryvný seznam
- sp38id - identifikace jazyka
- bwa7id - numerická - odpovídá hodnotě atributu typu překryvný seznam
- bwa7text - textová - text přidělený hodnotě atributu překladem

Např. pro hodnotu atributu 'úkon vymáhání'
Přeložený text:
Upom.,1,Penále,2,Soud,3,Exek.,4,Tr. ozn.,5,Ost.,6,NEVYM.,7,Výzva,8,Telef.,9,Odlož.,10,Mail,30,Telef.2,31
vznikne v tabulce BWSLOVPP 12 záznamů:
bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=1, bwa7text=Upom.
bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=2, bwa7text=Penále
bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=3, bwa7text=Soud
bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=4, bwa7text=Exek.
bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=5, bwa7text=Tr. ozn.
bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=6, bwa7text=Ost.
bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=7, bwa7text=NEVYM.
bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=8, bwa7text=Výzva.
bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=9, bwa7text=Telef.
bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=10, bwa7text=Odlož.
bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=30, bwa7text=Mail
bw57idt=_RZU14KD54, sp38id=CZE, bwa7id=31, bwa7text=Telef.2

V SQL dotazu je potom možné tabulku použít:
(select bwa7text from %%%.bwslovpp where bwslovpp.bw57idt='_RZU14KD54' and bwslovpp.sp38id='CZE' and bwslovpp.bwa7id=PLUDA.pl02ukonvy) ukon_text
Ing. Petr Filip 16.02.09


Pošta

Pošta
V události pošty se objevila nová numerická položka 'F.cena', která je určena pro vstup částky fakturované jako poštovné na faktuře.
Ing. Petr Filip 17.01.09


Spojené dokumenty

Spojené dokumenty
Ve formuláři 'Spojené dokumenty' se nově zobrazuje složka 'PROCESY ADRESÁTA' a v ní se (nepřímo) zobrazují procesy, které byly založeny pro adresáta.
Procesy založenými pro adresáta se rozumí procesy, které mají odpovídající identifikaci adresáta uvedenou v úvodní operaci procesu (SPPRCOD).

Složky procesů jsou obsaženy ve složce 'PROCESY ADRESÁTA' nepřímo.
Na první úrovni se pod touto složkou zobrazuje seznam složek let (roky jsou seřazeny sestupně).
Na druhé úrovni (ve složce roku) se zobrazuje seznam složek číselných řad druhů procesů (číselné řady jsou v seznamu seřazeny podle začátku číselných řad vzestupně).
A teprve na třetí úrovni se (ve složce číselné řady druhu procesu) se zobrazuje seznam složek procesů, ve kterém jsou obsaženy procesy odpovídající roku a druhu procesu s číselnou řadou, které jsou uvedeny v nadřazených složkách.

Složka procesu je totožná se složkou, která se zobrazuje ve formuláři 'Strom hlavního procesu' s tím, že není možné provádět některé volby menu vyvolaného ze stromu po pravém kliku myší.
Jedná se o tyto funkce:
- Obnovit
- Kopírovat odkaz na proces
- Osamostatnit proces
- Napojit proces

Položka stromu odpovídající procesu obsahuje text:
číslo procesu, druh procesu, popis procesu, jméno zakladatele procesu a datum a čas založení procesu
(tento text se takto změnil také ve formulářích 'Spojené dokumenty' a 'Okno úloh').
Ing. Petr Filip 17.01.09


Výstup do formátu TIFF

Výstup do formátu TIFF
Knihovny DEFPDF a SYSPDF nyní lépe ošetřují výstup dokladu procesu do PDF.

Obsahují mj. možnost uložit výstup do PDF jako dokument BM připojený k procesu objektovou vazbou.
Novinka je popsána na konci komentáře knihovny SYPDF (popis parametrů SP57ID a SP01ID).

Viz. Návody a balíčky
Ing. Petr Filip 17.01.09


Definice k přiznání DPH pro rok 2009

Definice k přiznání DPH pro rok 2009
Pro přiznání DPH roce 2009 je třeba filtrovat události DPH zahrnuté do výpočtu hodnot některých řádků přiznání podle technicko-věcného selektoru uvedeného v události.
Bez tohoto řešení, by neúměrně narostl počet předmětů zdanitelného plnění, který by znamenal zesložitění vstupů událostí DPH pro případy, které jsou bez toho pro většinu firem používajících ISBM pouze hypotetické nebo ojedinělé.

Proto přibyla v definici pro výpočet řádku daňového přiznání (s uvedeným Způsob výpočtu=Hodnota) možnost uvádět technicko-věcný selektor.
Je-li v takovém řádku selektor vyplněn a je uveden jiný selektor než '-', potom se do vypočtených hodnot řádku zahrnou pouze události DPH, které mají v sobě zapsán tento technicko-věcný selektor.
Je-li v takovém řádku uveden selektor '-', potom budou vypočtené hodnoty řádku nulové.
Řádek definice s technicko-věcným selektorem '-' není možné běžně vstupovat.

Při exportu definice daňového přiznání do balíčku je zobrazen dotaz "Nastavit vyplněný technicko-věcný selektor v řádcích definice na hodnotu '-' ?" v případě, že tato definice daňového přiznání obsahuje řádek s vyplněným selektorem jiným než '-'.

Pro definici Daňového přiznání je možné určit její platnost zadáním data platnosti OD a DO.
Vyplněná platnost definice se uplatní na výběrové záložce, kde je možné vybrat daňová přiznání:
- Platná i neplatná
- Platná dnes
- Platná minulý měsíc

Při výpočtu daňového přiznání není možné zadat měsíc a rok výpočtu, který nespadá do období platnosti definice daňového přiznání (je-li období platnosti vyplněno).

Ing. Petr Filip 19.12.08


Okno úloh a zobrazování hlavního menu BM

Okno úloh a zobrazování hlavního menu BM
V nastavení Okna úloh je možné nastavit parametr 'Zobrazovat hlavní menu programu'.

Tento parametr má souvislost s dalšími parametry nastavení Okna úloh - 'Otevírat okno úloh při spuštění programu', 'Přepínat do hlavního menu programu' a 'Ukončení programu klávesou ALT+F4'.

Proto, pokud se nemá zobrazovat okno hlavního menu programu (tj. 'Zobrazovat hlavní menu programu' je nezaškrtnuté), potom není možné hodnoty těchto parametrů měnit a přitom změna hodnoty parametru 'Zobrazovat hlavní menu programu' ze zaškrtnuté na nezaškrtnuté zároveň způsobí změnu jejich hodnot na:
- 'Otevírat okno úloh při spuštění programu' = Vždy
- 'Přepínat do hlavního menu programu' = Nikdy
- 'Ukončení programu klávesou ALT+F4' = zaškrtnuté

Není-li právě okno hlavního menu programu zobrazeno, je ho možné vyvolat z menu formuláře Obecné->Hlavní menu.
Z menu Volby v okně hlavního menu programu je potom možné vybrat položku 'Skrýt menu', která toto okno skryje (volba 'Skrýt menu' je dostupná pouze v případě nastavení okna úloh 'Zobrazovat hlavní menu programu' = nezaškrtnuté).

Při uzavření okna úloh se v případě, že okno hlavního menu programu není přístupné, okno hlavního menu programu zpřístupní.
Ing. Petr Filip 02.12.08


BM a přechod na euro na Slovensku

BM a přechod na euro na Slovensku
V souvislosti s přechodem Slovenské republiky na novou měnu byly provedeny v BM následující změny:

1/ pro každou měnu je možné stanovit období platnosti měny
2/ nový formulář 'Tabulka přechodů na měny' - vyvolává se z menu Volby formuláře INFORMAČNÍ CENTRUM->OCEŇOVÁNÍ->Parametry oceňování
3/ předplňování referenční měny a měny události v událostech, ve kterých se pracuje s měnou (obchod, DPH, platby, změna stavu peněz, zálohy, účetnictví)

ad.1/ není možné vstoupit událost s měnou, jejíž datum nespadá do období platnosti měny (je-li uvedeno)

ad.2/ ve formuláři 'Tabulka přechodů na měny' se uvádí datum platnosti OD a identifikátor měny.
!!!POZOR!!! Tato informace se týká referenční měny a bude vyplňována ve verzích BM používaných na Slovensku !!!POZOR!!!
Ve verzích BM na Slovensku bude uváděno EUR od 1.1.2009.

ad.3/ při vstupu události se podle obsahu 'Tabulky přechodů na měny' předplňuje v události podle data události předplňuje referenční měna a může se také podle data události předplňovat jiná cizí měna události v případě, že měna uvedená u adresáta je totožná s referenční měnou uvedenou v 'Parametrech oceňování'

Ing. Petr Filip 26.11.08


Dokumenty - spouštěné aplikace

Dokumenty - spouštěné aplikace
Nová vlastnost aplikace spouštěné při otevírání dokumentu 'Info o otevření', určuje chování BM po otevření dokumentu (nastavuje ve formuláři 'Spouštěné aplikace').

Tato vlastnost může nabývat hodnoty:
Ano s potvrzením - po otevření dokumentu bude otevíráno okno, které uživatel musí uzavřít (klávesou ESC, tlačítkem OK nebo ikonou uzavření okna)
Ano bez potvrzení - po otevření dokumentu bude otevíráno okno, které uživatel může uzavřít (klávesou ESC nebo ikonou uzavření okna), pokud uživatel okno neuzavře uzavře se samo po 5 vteřinách
Ne - po otevření dokumentu nebude zobrazeno žádné okno

Pozn.: pro některé aplikace je nutné ponechat nastavení vlastnosti 'Ano s potvrzením'.
Jedná se o aplikace, které neblokují jimi otevřené soubory.
V jejich případě, kdyby BM po otevření dokumentu nezastavil, potom by BM soubor dokumentu bezprostředně zrušil a aplikace by nemohla prezentovat daný dokument.
Těmito aplikacemi mohou být programy pro zobrazení obrázků, internet explorer (soubory s příponami HTM, XML, ...) ....
JJ - asi taky AcrobatReader
Ing. Petr Filip 07.11.08


Informační panely

Informační panely
Na stránce informačního panelu je možné vytvářet odkazy, které způsobí vyvolání programu Windows (jiného než internetový prohlížeč) a v něm otevření souboru, který odpovídá celé zobrazené stránce (může to být více tabulek) nebo jednotlivé tabulce zobrazené na stránce.

Při vytváření stránky informačního panelu je dostupná vlastnost řídícího objektu vytváření stránky OUTPUT_FORMAT, která má při vytváření běžné stránky zobrazované v internetovém prohlížeči hodnotu 'prázdný text' a při vytváření stránky určené pro zobrazení v programu Windows obsahuje hodnotu, kterou je tříznaková přípona souboru.
Přitom, je-li stránka vytvářena s nastavenou vlastností OUTPUT_FORMAT řídícího objektu, potom do vytvářených tabulek nejsou vkládány hypertextové odkazy, je potlačeno vytváření automatických hlaviček a patiček stránky a po vytvoření stránky je vyvolán program Windows podle uvedené přípony (hodnoty vlastnosti OUTPUT_FORMAT).

Do stránky informačního panelu je možné vkládat hypertextové odkazy, které zajistí vytvoření stránky s nastavenou vlastností řídícího objektu vytváření stránky OUTPUT_FORMAT třemi způsoby:
- v kódu patičky prezentace stránky
- ve vlastnosti POSTTEXT definice uzlu informačního panelu
- hypertextovým odkazem, který je součástí tabulky informačního panelu

Mějme např. uživatelskou knihovnu vkládaného kódu USRPAN (její obsah je na konci tohoto textu).

S knihovnou USRPAN je možné zadat v kódu patičky prezentace stránky nebo ve vlastnosti POSTTEXT definice uzlu informačního panelu kód:
#SCRIPT
Return zobrazit_v_excelu_a_wordu(_this)

#INCLUDE USRPAN

Takto budou do stránky vloženy hypertexty, které převedou do programu Windows celou zobrazenou stránku (může to být více tabulek).

Pro vložení hypertextu s nastavení vlastnosti OUTPUT_FORMAT řídícího objektu přímo do tabulky je třeba vytvořit zvláštní definici hypertextu informačních panelů, která obsahuje kód vracející text 'output_format=', kde je tříznaková přípona souboru (příklad kódu hypertextu RETURN 'output_format=XLS')
Tímto způsobem bude do stránky vložen hypertext, který převede do programu Windows danou tabulku.

Při vytváření stránky určené pro zobrazení v programu Windows je pro úspěšné uplatnění stylů nutné, aby styly byly přímo obsaženy v souboru předaném programu Windows.
Proto je třeba zasáhnou do popisu stylu v prezentaci stránky informačního panelu a v jeho kódu podmínit v případě, že je nastavena vlastnost OUTPUT_FORMAT řídícího objektu, vložení textu stylů do vytvářené stránky.
Např. s užitím knihovny USRPAN:
#SCRIPT
Return vrat_styl(_this)

#INCLUDE USRPAN

V některých případech je vhodné pro výstup stránky do programu Windows vyloučit některé sloupce tabulky, řádky tabulky,prvky stránek nebo celou jednotlivou tabulku zobrazenou na stránce (poslední platí pro hypertexty v kódu patičky prezentace stránky nebo ve vlastnosti POSTTEXT definice uzlu informačního panelu).
V tom případě je možné uvádět ve vlastnosti Podmínka v definici takového sloupce, řádku, prvku stránky nebo podřízeného uzlu výraz EMPTY(this.output_format).

Knihovna USRPAN
--------------------------
* Knihovna USRPAN
Procedure zobrazit_v_excelu_a_wordu
Lparameters _this
Local _html,_scid
If Type('_this.output_format')='C' And Empty(_this.output_format) And _this.Level=0
    _scid=_this.get_currenttoppage_script_id()
Else
    _scid=''
Endif
Do Case
Case Empty(_scid)
    _html=''
Case _this.web
    TEXT to _html textmerge noshow
<br><a href="<<_this.web_main_url>>?fce=SCRIPT<<'&'>>id=<<_scid>><<'&'>>output_format=XLS" target=_blank>Zobrazit v Excelu</a>
<br><a href="<<_this.web_main_url>>?fce=SCRIPT<<'&'>>id=<<_scid>><<'&'>>output_format=DOC" target=_blank>Zobrazit ve Wordu</a>
    ENDTEXT
Other
    TEXT to _html textmerge noshow
<br><a href="BMPANEL:<<ltrim(str(_scid))>>?output_format=XLS">Zobrazit v Excelu</a>
<br><a href="BMPANEL:<<ltrim(str(_scid))>>?output_format=DOC">Zobrazit ve Wordu</a>
    ENDTEXT
Endcase
Return _html

Procedure vrat_styl
Lparameters _this
Local _bd
Do Case
Case Type('_this.output_format')='C' And !Empty(_this.output_format)
    If Type('tool.web')='L' And Tool.web
        _bd='<STYLE>'+Filetostr('c:\inetpub\bmstyles\Scripts\DTUE.css')+'</STYLE>'
    Else
        _bd='<STYLE>'+Filetostr('Scripts\DTUE.css')+'</STYLE>'
    Endif
Case Type('tool.web')='L' And Tool.web
    TEXT TO _bd TEXTMERGE NOSHOW
<!--CSS_START-->
<SCRIPT SRC="/bmstyles/Scripts/dtuelink.js"></SCRIPT>
<!--CSS_END-->
    ENDTEXT
Other
    TEXT TO _bd TEXTMERGE NOSHOW
<!--CSS_START-->
<SCRIPT SRC="<<sys(5)+curdir()>>Scripts\dtuelink.js"></SCRIPT>
<!--CSS_END-->
    ENDTEXT
Endcase
Return _bd

Ing. Petr Filip 18.11.08


Výstup do formátu TIFF

Výstup do formátu TIFF
Knihovna SYSPDF byla rozšířena o možnost výstupu ve formátu TIFF.

Viz. Návody a balíčky
Ing. Petr Filip 23.10.08


INTRASTAT - aktualizace

INTRASTAT - aktualizace
INTRASTAT
byl aktualizován i dokument Intrastat - popis pro implementátory

Ve vykazování Intrastatu byly provedeny zásadní změny:

1. Výsledný soubor csv obsahuje nyní grupované pohyby, dle následujících atributů:

měsíc
rok
DIČ
dovoz/vývoz
země odeslání/určení
kraj
země původu
povaha transakce
doprava
dodací podmínky
zvláštní pohyb
kód zboží
statistický znak

Z této změny vyplývá zpřesnění uváděné hmotnosti a částky, zaokrouhluje se až grupovaný řádek dle pravidel Intrastatu.

2. Došlo ke zpřesnění vykazování zemí:

Dovoz - země odeslání je odvozena z adresáta (ad01id), země původu je odvozena z výrobního čísla nakupovaného zboží (detailní informace poskytne implementátor) nebo z volné karty Intrastat, která byla tímto atributem rozšířena
Vývoz - země určení je odvozena z příjemce (ad01id1), kraj původu je odvozen z výrobního čísla prodávaného zboží (detailní informace poskytne implementátor) nebo z volné karty Intrastat, která byla tímto atributem rozšířena

S touto změnou úzce souvisí nutnost evidování skladových karet s údaji o místě původu, tedy nutnost použití výrobního čísla při každém příjmu na sklad při nákupu z EU. Podrobnosti o tvaru a generování VČ po konzultaci s implementátorem.

3. Z důvodu častého vypisování dvou a více kursů měny Celním úřadem na vykazovaný měsíc došlo ke změně v záznamu kursů pro vykazování Intrastatu, nyní jsou kursy Celního úřadu ukládány v komponentě Oceňování v IS BM.
Mgr. Petr Kukla 02.09.08


Mzdy - nepřítomnosti - překryv

Mzdy - nepřítomnosti - překryv
Do činnosti "Nepřítomnost pro nemoc" přibylo nové hlášení.

Ve většině případů není možné, aby se na jednom pracovním poměru u jednoho pracovníka nemoci překrývaly. Není ale vyloučené, že takový překryv budeme potřebovat zadat.

Hlášení říká :
"Zadaná nepřítomnost se překrývá s jinou !!!!
Skutečně chcete zapsat údaje PŘES jinou nepřítomnost ?

Ano - Chci překryv s jinou nepřítomností
Ne - Nechci překryv s jinou nepřítomností"

Pokud uživatel odpoví Ano, systém dovolí zapsat záznam nepřítomnosti, který se překrývá s jinou již dříve zapsanou nepřítomností.

Pokud uživatel odpoví Ne, pak systém záznam nedovolí zapsat dokud ho uživatel neopraví na datum, které se s jinou nepřítomností nepřekrývá.

Implicitně je nastavena odpoveď Ne.
Ing. Olga Smitková 11.09.08


Návěští sloupce/řádku v definici IP

Návěští sloupce/řádku v definici IP
v definici řádků a sloupců informačních panelů je možné v jejich vlastnostech 'Návěští' uvádět za znakem '~' (vlnovka) výraz v syntaxi Foxpro, který bude vyhodnocován v okamžiku vytváření tabulky a zjištěná hodnota bude vložena do vytvářené tabulky
Ing. Petr Filip 01.09.08


Odepisovaný majetek - karta - výběr

Odepisovaný majetek - karta - výběr
Změněn výběr u karet odepisovaného majetku takto :

Možnosti :
Všechny
Jen hlavní předměty souboru
Jen podřízené předměty (mají uveden nadřízený artikl)
Jen samostatné předměty(nezaškrtnuté a bez nadřízeného artiklu)
Hlavní a podřízené předměty

Nastavení "Jen podřízené karty" funguje zavádějícím způsobem.

Hlavní karty jsou ty, které mají zaškrtnuto "Je hlavním předmětem souboru".
Podřízené karty jsou ty, které toto nemají zaškrtnuto a které mají uveden nadřízený artikl.
Samostatné předměty jsou ty, které nejsou ani hlavní ani podřízené, tj. nemají zaškrtnuto "Je hlavním předmětem souboru" ani nemají uveden nadřízený artikl.

Ing. Olga Smitková 03.09.08


Číselné řady pořadí položek smluv

Číselné řady pořadí položek smluv
Novou činností 'Číselné řady pořadí položek smluv' je možné definovat pro jednotlivá datová úložiště číselné řady pro pořadí nově zakládané položky smlouvy.

Tímto způsobem je řešen problém při zadávání nové položky smlouvy v implementacích s daty uloženými na několika datových úložištích, kde hrozí nebezpečí konfliktu pořadí položky smlouvy.
Ing. Petr Filip 13.08.08


Editor uzlů informačních panelů

Editor uzlů informačních panelů
je nový nástroj pro údržbu stránek informačních panelů.
Ing. Petr Filip 13.08.08


Předlohy výst. EXCEL 1 - soubor výrazem

Předlohy výst. EXCEL 1 - soubor výrazem
je-li název výstupního souboru v předloze výstupu typu 1 uveden znakem '~' (vlnovka), potom se při zpracování předlohy předpokládá, že za vlnovkou následuje výraz v syntaxi Foxpro, který vrátí textovou hodnotu, která bude určovat název výstupního souboru.
Ing. Petr Filip 13.08.08


Informační panely

Informační panely
pro tabulku informačního panelu je možné nastavit stránkování.
Na záložce Další se uvádí:
Stránkování - číslo - uvádí počet záznamů umístěných na stránce - hodnota nula znamená, že se stránkování neprovádí, pokud počet záznamů pro vytvoření tabulky nepřekročí uvedené číslo, potom se řádek s odkazy pro přechod na stránky tabulky nevytváří
Odkazy - překryvný seznam Před tabulku / Za tabulku / Před i Za tabulku - určuje kam mají být umístěn řádek s odkazy pro přechod na jednotlivé stránky
Zahrnout - překryvný seznam Do tabulky / Mimo tabulku - určuje jestli má být řádek s odkazy pro přechod na jednotlivé stránky umístěn jako součást tabulky nebo má být umístěn mimo tabulku
Tag - text - určuje grafické vlastnosti řádku s odkazy (např. TD STYLE="background:yellow; font-size:120%; text-align=center"), při umístění řádku s odkazy mimo tabulku jsou tagy TD a TH nahrazeny za tag DIV
Návěští - text - je určeno pro doplnění textu do řádku s odkazy (např.: Stránky). V textu návěští se může vyskytovat makro ###, které určuje umístění bloku s odkazy v textu návěští (např. 'Text před odkazy ### Text za odkazy' může zobrazit 'Text před odkazy 1 2 3 4 >>> Text za odkazy')

V řádku s odkazy jsou odkazy na jednotlivé stránky představovány jejich pořadovými čísly a v případě, že byla data pro zobrazení tabulky setříděna příkazem Foxpro INDEX (tj. se pro tabulku uplatní Výraz třídění nebo ji uživatel setřídil klikem na návěští některého jejího sloupce), zobrazuje se při pohybu myší přes číslo stránky text (tooltip), který je vyhodnocením indexového výrazu pro první záznam zobrazovaný na stránce.

V řádku s odkazy je zobrazován seznam maximálně 21 odkazů na jednotlivé stránky tabulky. V případě, že v tomto seznamu není obsažena první stránka, potom řádek s odkazy obsahuje také odkaz s textem '<<<', který způsobuje přechod na stránku s pořadovým číslem (aktuálně_zobrazená_stránka - 20).
V případě, že v seznamu odkazů není obsažena poslední stránka, potom řádek s odkazy obsahuje také odkaz s textem '>>>', který způsobuje přechod na stránku s pořadovým číslem (aktuálně_zobrazená_stránka + 20).

Pokud tabulka obsahuje sloupce, které je možné třídit, potom je vždy po setřídění klikem na návěští sloupce zobrazována její první stránka.

Pro stránkovanou tabulku musí platit, že se identifikace uzlu informačního panelu, kterým je tabulka definována včetně Alias (pokud se tabulku uplatňuje na stránce informačního panelu jako poduzel), vyskytne při vytváření stránky informačního panelu právě jednou.

Narozdíl od funkčnosti třídění nestránkované tabulky (klik na návěští sloupce) kdy, pokud je tabulka součástí skupiny tabulek, potom je setříděná tabulka zobrazena samostatně (tj. není zobrazována stránka, ve které je tabulka obsažena, ale samostatná stránka tabulky), funguje třídění stránkované tabulky (klik na návěští sloupce) tak, že setříděná tabulka je zobrazována opětně jako součást skupiny tabulek.
Stejné je chování při přechodu na jinou stránku tabulky, tzn. při přechodu na jinou stránku tabulky je zobrazována stránka informačního panelu, ve které je tabulka obsažena.

Pozn.: Této vlastnosti je možné využít i pro tabulky s možností třídění klikem na návěští sloupce, pro které platí pravidlo její jednoznačné identifikace ve vytvářené stránce informačního panelu a přitom pro tuto tabulku nemá smysl stránkovat. Stačí zadat do vlastnosti uzlu tabulky 'Stránkování' velkou hodnotu a potom bude po kliku na návěští sloupce zobrazována stránka informačního panelu, ve které je tabulka obsažena.

Ing. Petr Filip 14.07.08


Mzdy - výpočet

Mzdy - výpočet
Byla vytvořena nová činnost "Pomocný optimalizovaný výpočet JEDNOHO pracovníka".

Je výhodná pro společnosti s velmi vysokým počtem zaměstnanců, protože klasický Optimalizovaný výpočet bývá příliš pomalý. Činnost je vhodná pro přepočet jednoho pracovníka, pokud je potřeba zjistit, jak bude vypadat jeho výplatní lístek a pokud si nejsme jisti, zda je u tohoto pracovníka vše zadáno správně.

Po kontrole pracovníka se MUSÍ spustit klasický Optimalizovaný výpočet pro všechny pracovníky nebo se ručně musí dorovnat zaokrouhlení odvodu sociálního pojištění.

POZOR - činnost "Pomocný optimalizovaný výpočet JEDNOHO pracovníka" neprovádí korekci zaokrouhlování na položce Odvod sociálního pojištění.

Činnost "Pomocný optimalizovaný výpočet JEDNOHO pracovníka" se spouští přes Volby nad činnosti Výplatní lístky.
Ing. Olga Smitková 15.07.08


Typy událostí komponent

Typy událostí komponent
K druhu operace může být přidělen žádný nebo několik typů události.
K pořízení totoho vztahu slouží nová činnost 'Typy událostí komponent' (v menu INFORMAČNÍ CENTRUM->TYPY A ŘADY->Typy událostí komponent).
Zadává se:
- identifikace komponenty
- identifikace typu
- název typu
- Počáteční - překryvný seznam Ano/Ne - Ano určuje typ události předplněný při vstupu nové události
- poznámka

Typy událostí je možné přidělovat k druhu operace také ve formuláři 'Druhy operací' na záložce 'Typy'.

V současné době je možné je možné používat typy událostí pouze pro komponentu 'obecná událost' (vývěska).

Ing. Petr Filip 14.07.08


Adresář uložení souboru BWLCL.INI

Adresář uložení souboru BWLCL.INI
BWLCL.INI je soubor, ve kterém jsou ukládány informace o naposledy přihlášeném uživateli programu a dále se v něm uchovávají informace o všech uživatelích, kteří se k programu historicky přihlásili. Tato informace se využívá pro naplnění seznamu uživatelů v překryvném seznamu při přihlašování uživatele k programu.

Doposud se tento soubor ukládal v adresáři C:\WINDOWS\SYSTEM.
Protože se ve Windows Vista bere implicitně přístup do systémové složky jiným programem za nepovolený, změnil se adresář uložení tohoto souboru podle obsahu systémové proměnné APPDATA. Bude např. ve tvaru 'C:\Documents and Settings\jméno_uživatele.název_domény\Data aplikací\BM\'.
Tato změna má za následek, že při prvním přihlášení jednotlivého uživatele Windows k BM bude seznam historicky přihlášených uživatelů prázdný.

Pozn.: v některých starších verzích Windows (jako třeba Windows NT 4.0 SP6) se tato změna neprojeví, protože systémovou proměnnou APPDATA nepodporují.

Ing. Petr Filip 18.06.08


Doplňující vlastnosti formuláře

Doplňující vlastnosti formuláře
Byl doplněn typ DPV o 'Spustit kompilovaný kód'.
Rozdíl proti typu DPV 'Spustit kód' je v tom, že tento skript není prováděn příkazem Foxpro EXECSCRIPT, nýbrž je zkompilován a následně je spuštěn zkompilovaný program (soubor s příponou FXP).

Kódem externích příkazů s tímto novým typem je možné vytvářet objekty, které po provedení kódu nezanikají.
Takto je například možné udělat formulář, který zůstane na obrazovce třeba až do ukončení programu a je možné se přitom přepínat mezi ním a jinými běžnými formuláři BM.

Příklad:
* Výsledkem volání kódu je zobrazení formuláře na obrazovce
* Ale pouze pro typ externího příkazu 'Script Foxpro - kompilovaný' tento formulář bezprostředně po provedení kódu nezanikne
LOCAL _o
_o=CREATEOBJECT('xform')
_o.show
* metoda objektu TOOL - ADD_USER_WINDOW - uchovává odkaz na objekt _O v rámci atributů objektu TOOL
* jinak by objekt _O zanikl po ukončení kódu v každém případě
tool.add_user_window(_o)

define class xform as form
enddefine

Další možné využití tohoto typu DPV je v souvislosti s připojováním metod k objektům formuláře (BINDEVENT) bez použití objektu BWSCRIPT.
Ing. Petr Filip 18.06.08


Externí příkazy

Externí příkazy
Byl doplněn typ externího příkazu o 'Script Foxpro - kompilovaný'.
Rozdíl proti typu externího příkazu 'Script Foxpro' je v tom, že tento skript není prováděn příkazem Foxpro EXECSCRIPT, nýbrž je zkompilován a následně je spuštěn zkompilovaný program (soubor s příponou FXP).

Kódem externích příkazů s tímto novým typem je možné vytvářet objekty, které po provedení kódu nezanikají.
Takto je například možné udělat formulář, který zůstane na obrazovce třeba až do ukončení programu a je možné se přitom přepínat mezi ním a jinými běžnými formuláři BM.

Příklad:
* Výsledkem volání kódu je zobrazení formuláře na obrazovce
* Ale pouze pro typ externího příkazu 'Script Foxpro - kompilovaný' tento formulář bezprostředně po provedení kódu nezanikne
LOCAL _o
_o=CREATEOBJECT('xform')
_o.show
* metoda objektu TOOL - ADD_USER_WINDOW - uchovává odkaz na objekt _O v rámci atributů objektu TOOL
* jinak by objekt _O zanikl po ukončení kódu v každém případě
tool.add_user_window(_o)

define class xform as form
enddefine
Ing. Petr Filip 18.06.08


Hyperlinky v textových polích

Hyperlinky v textových polích
do víceřádkových polí formulářů (např. poznámky) je možné zapisovat hyperlinkové odkazy na internetovou adresu (např. http://www.bmservis.cz).
Tyto odkazy jsou v textu zobrazeny modrým písmem a při CTRL+KLIK dojde k vyvolání internetového prohlížeče s přechodem na odpovídajícící odkaz.

Tato funkčnost platí pro BM ve verzích pod Foxpro 8.0 nebo vyšší.

Ing. Petr Filip 19.06.08


Informační panely

Informační panely
V prezentaci stránky informačního panelu je možné definovat 'Atributy elementů TR'.

V těchto položkách se uvádějí jednotlivé HTML-atributy elementu následované výrazem v jazyce Foxpro oddělené enterem.
Př.: BGCOLOR=IIF(MOD(this.citac_radku,2)=1,'YELLOW','')

Stejné nastavení je možné také u jednotlivých řádků v definici IP.
V případě, že je uvedeno nastavení u jednotlivého řádku v definici IP a také v prezentaci stránky, potom se uplatní obě tato nastavení.

Ing. Petr Filip 10.06.08


Informační panely

Informační panely
ve formuláři Definice informačních panelů přibyla na záložce Řádky položka pro určení HTML-atributů elementu TR.

V těchto položkách se uvádějí jednotlivé HTML-atributy elementu následované výrazem v jazyce Foxpro oddělené enterem.

Př.: BGCOLOR=IIF(MOD(this.citac_radku,2)=1,'YELLOW','')

Pokud je hodnota vyhodnoceného výrazu prázdná, potom není atribut do elementu vkládán, jinak je hodnota atributu uvedena ohraničení apostrofy (pro uvedený příklad BGCOLOR="YELLOW").
Je-li název atributu uvedený znakem vlnovka, potom hodnota atributu není ohraničena apostrofy.
Např.: ~BGCOLOR=IIF(MOD(this.citac_radku,2)=1,'YELLOW','') -> BGCOLOR=YELLOW

Syntaxe ~= vkládá mezi atributy elementu přímo text bez jakéhokoliv formátovávání.
Např.: ~=IIF(MOD(this.citac_radku,2)=1,'BGCOLOR=YELLOW','') -> BGCOLOR=YELLOW

Uvedená pravidla se uplatňují taká pro odpovídající nastavení návěští sloupce a elementu tabulky.

Ing. Petr Filip 06.06.08


Návody a balíčky

Návody a balíčky
Při spuštění externího příkazu 'Návody a balíčky' se může vyskytnout chyba "OLE -nesprávný řetězec třídy", která je způsobena tím, že není zaregistrován systémový COM-objekt MSXML3.DLL, který se nachází v adresáři C:\WINDOWS\SYSTEM32. V tom případě je ho třeba zaregistrovat programem REGSVR32.
Ing. Petr Filip 19.06.08


Prognózování odpisů

Prognózování odpisů
V činosti Prognózování odpisů bylo provedeno několik změn.

V původním nastavení bylo možné použít k výpočtu i rok, který nebyl přímo nadefinován včinnosti Účetních období. Toto nyní nebude možné.
Výpočet bude muset být vždy proveden za rok(období), které bude nadefinováno v činnosti Účetní období.

Prognózování odpisů je možné používat dvěma způsoby :
a) používáme hospodářský rok, který začíná např. v dubnu jednoho roku a končí v březnu následujícího roku. V tomto případě je nutné nadefinovat příslušné hospodářské roky např. s identifikací H2007, H2008, H2009, .... do činnosti Účetní období. Poté je možné provést vlastní výpočet.

b) používáme běžný kalendářní rok, který začíná v lednu a končí v prosinci téhož roku. V tomto případě můžeme při definování roků v činnosti Účetní období využít funkci Předplň účetní období (Volby nad Účetními obdobími). Tato činnost po zadání rozmezí roků sama vyplní jednotlivá účetní období s identifikacemi např. 2007, 2008, 2009,... Poté je možné provést vlastní výpočet.

Ing. Olga Smitková 18.06.08


Šablony, obecné výběry a importy

Šablony, obecné výběry a importy
1/ VALIDACE
Pro proměnné šablon, obecných výběrů a importů je možné definovat vlastnost 'Validace'.
V této vlastnosti se uvádí skript v jazyce Foxpro, který se provádí v okamžiku validace dané proměnné ve vstupním formuláři.
Ve skriptu se mohou vyskytovat odkazy na všechny proměnné dané definice, ktreré jsou vstupovány, uvedené v hranatých nebo složených závorkách.
Proměnná uvedená v hranatých závorkách obsahuje v okamžiku vstupu formuláře hodnotu dané proměnné.
Proměnná uvedená ve složených závorkách obsahuje v okamžiku vstupu formuláře objekt, kterým je proměnná zobrazena.
Makro ### obsahuje v okamžiku vstupu formuláře hodnotu proměnné, pro kterou je prováděna validace.

V okamžiku spuštění kódu validace jsou mu k dispozici proměnné:
- _THISFORM - objekt formuláře, ve kterém je prováděn vstup
- _THIS - objekt proměnné, která je validována

Pro účely validace obsahuje formulář metodu TEST_ZMENA, která musí být vyvolána s parametry:
- identifikace - jednoznačná textová identifikace hodnoty
- hodnota - libovolná hodnota
Metoda vrací numerické hodnoty:
0 - hodnota dané identifikace, je stejná jako hodnota uložená při předcházejícím volání této metody se stejnou identifikací
1 - hodnota dané identifikace, je jiná než hodnota uložená při předcházejícím volání této metody se stejnou identifikací
2 - hodnota dané identifikace byla právě poprvé uložena voláním této metody

Příklad předplnění měny podle vstupovaného adresáta:
If _thisform.test_zmena('adresat',###)=1 Or Empty([mena])
[mena]=Tool.sql_dotaz([select oc01id from %%%.adadsat where ad01id=?_p1],###)
Endif
--------------------------------------------
2/ INICIALIZACE
Ve vlastnosti 'Inicializace' je možné uvádět libovolně dlouhý text a používat volání interních funkcí (např.: SQL_DOTAZ).
V takovém případě musí být výraz uveden znakem '~' (vlnovka).
Ing. Petr Filip 10.06.08


Vstup adresáta webovou službou

Vstup adresáta webovou službou
návody a balíčky byly doplněny o doplňující vlastnost formuláře 'Předplnění adresáta podle ARES', která slouží k vyplnění údajů o adresátovi pomocí webové služby Ministerstva financí ČR.
Dále vytvořena stránka IP 'Adresát v ARES' pro 'Okno úloh'

Viz. návody a balíčky.
Ing. Petr Filip 05.06.08


Oceňování kurzem včerejšího dne

Oceňování kurzem včerejšího dne
v parametrech oceňování je možné uvádět hodinu a minutu, do které se má pracovat pro datum dnešního dne s kurzem včerejšího dne.
Ing. Petr Filip 16.05.08


Odesílání emailů - oprava problému

Odesílání emailů - oprava problému
V BM byla provedena oprava, která řeší problém odesílání emailů, který se projevoval při odesílání chybou 'Třída není licencována k použití' (řešilo se opravou registru na stanici).
Protože není možné dopady této změny 100%-tně ověřit, proto je možné nastavením BM MSMAPI->UseForm=0 obnovit původní způsob odesílání emailů.
Ing. Petr Filip 15.05.08


Okno úloh

Okno úloh
Okno úloh je nástroj pro usnadnění ovládání programu BM.

Toto okno je zobrazováno jako součást základního okna BM, ve kterém je ve verzích BM po Visual Foxpro 9.0 ukotvitelné.

Okno úloh se volitelně automaticky vyvolává při spuštění programu BM nebo je ho možné vyvolat z menu Obecné -> NABÍDKY -> Okno úloh

V okně jsou zobrazena ovládací tlačíka, kterými se mění jeho obsah.
Kromě základních tlačítek a s nimi spojenými zobrazovanými obsahy, je možné definovat vlastní tlačítka pro zobrazení stránek informačních panelů.
V parametru BM - OKNOULOH->VLOZENEINFPANELY je možné zadat seznam identifikací stránek informačních panelů oddělených čárkou.
Popis a ikona takto definovaných tlačítek okna úloh odpovídají názvům a ikonám uvedeným v popisu stránky informačního panelu.
Jednotlivým uživatelům jsou zobrazovány takto definovaná tlačíka pouze v případě, že mají právo přístupu k odpovídající stránce informačního panelu alespoň Čtení.
Pravá klik myší na tlačítku pro zobrazení stránky informačního panelu způsobí znovunačení stránky.

Okno úloh obsahuje tato základní ovládací tlačítka
1. Okna
Zobrazí seznam názvů aktivních oken BM.
Klik na název okna v seznamu způsobí ativaci daného okna

2. Menu BM
Zobrazí základní ovládací menu programu BM, za kterého je možné spouštět činnosti BM

3. Poslední dokumenty
Zobrazí seznam posledních 30-ti dokumentů BM, které uživatel naposledy otevřel seřazený podle data a času sestupně.
Klik na dokument způsobí otevření dokumentu.
Opakovaný klik na tlačítko 'Poslední dokumenty' způsobí aktualizaci seznamu.

4. Nápověda
Zobrazí nápovědu BM k formuláři, který je právě aktivní.
Obsah okna se mění při přepínání mezi formuláři.

5. Formulář - uživatelský popis
Zobrazí dvě vstupní textová pole, ve kterých uživatel vytváří vlastní uživatelský popis formuláře.
Prvé textové pole je určeno pro 'Sdílený popis', který je dostupný všem uživatelům systému.
Druhé textové pole je určeno pro 'Soukromý popis', který je dostupný pouze aktuálnímu uživateli systému.
Vstupované popisy jsou ukládány na vývěsku s tématem, které je dáno parametrem BM - OKNOULOH->TEMAUZIVPOPISU (pokud není tento parametr nastaven nebo uvedené téma neexistuje, není možné uživatelské popisy zadávat).
Uživatelé, kteří nemají právo přístupu Zápis k danému tématu vývěsky, mohou obsah textového pole 'Sdílený popis' pouze číst.
Obsah okna se mění při přepínání mezi formuláři a při tého změně dochází také k zápisu uživatelem zadaného popisu.
Zápis změněného popisu je také možné vyvolat opakovaným stiskem tohoto tlačítka ('Formulář - uživatelský popis').

6. Operace - uživatelský popis
Zobrazí dvě vstupní textová pole, ve kterých uživatel vytváří vlastní uživatelský popis operace.
Tlačítko je zobrazené jako nepovolené, pokud aktivní formulář není formulářem spuštěné operace.
Prvé textové pole je určeno pro 'Sdílený popis', který je dostupný všem uživatelům systému.
Druhé textové pole je určeno pro 'Soukromý popis', který je dostupný pouze aktuálnímu uživateli systému.
Vstupované popisy jsou ukládány na vývěsku s tématem, které je dáno parametrem BM - OKNOULOH->TEMAUZIVPOPISU (pokud není tento parametr nastaven nebo uvedené téma neexistuje, není možné uživatelské popisy zadávat).
Uživatelé, kteří nemají právo přístupu Zápis k danému tématu vývěsky, mohou obsah textového pole 'Sdílený popis' pouze číst.
Obsah okna se mění při přepínání mezi formuláři a při tého změně dochází také k zápisu uživatelem zadaného popisu.
Zápis změněného popisu je také možné vyvolat opakovaným stiskem tohoto tlačítka ('Operace - uživatelský popis').

7. Operace v procesu - uživatelský popis
Zobrazí dvě vstupní textová pole, ve kterých uživatel vytváří vlastní uživatelský popis operace v daném procesu.
Tlačítko je zobrazené jako nepovolené, pokud aktivní formulář není formulářem spuštěné operace.
Prvé textové pole je určeno pro 'Sdílený popis', který je dostupný všem uživatelům systému.
Druhé textové pole je určeno pro 'Soukromý popis', který je dostupný pouze aktuálnímu uživateli systému.
Vstupované popisy jsou ukládány na vývěsku s tématem, které je dáno parametrem BM - OKNOULOH->TEMAUZIVPOPISU (pokud není tento parametr nastaven nebo uvedené téma neexistuje, není možné uživatelské popisy zadávat).
Uživatelé, kteří nemají právo přístupu Zápis k danému tématu vývěsky, mohou obsah textového pole 'Sdílený popis' pouze číst.
Obsah okna se mění při přepínání mezi formuláři a při tého změně dochází také k zápisu uživatelem zadaného popisu.
Zápis změněného popisu je také možné vyvolat opakovaným stiskem tohoto tlačítka ('Operace v procesu - uživatelský popis').

8. Proces - uživatelský popis
Zobrazí dvě vstupní textová pole, ve kterých uživatel vytváří vlastní uživatelský popis procesu dané operace.
Tlačítko je zobrazené jako nepovolené, pokud aktivní formulář není formulářem spuštěné operace.
Prvé textové pole je určeno pro 'Sdílený popis', který je dostupný všem uživatelům systému.
Druhé textové pole je určeno pro 'Soukromý popis', který je dostupný pouze aktuálnímu uživateli systému.
Vstupované popisy jsou ukládány na vývěsku s tématem, které je dáno parametrem BM - OKNOULOH->TEMAUZIVPOPISU (pokud není tento parametr nastaven nebo uvedené téma neexistuje, není možné uživatelské popisy zadávat).
Uživatelé, kteří nemají právo přístupu Zápis k danému tématu vývěsky, mohou obsah textového pole 'Sdílený popis' pouze číst.
Obsah okna se mění při přepínání mezi formuláři a při tého změně dochází také k zápisu uživatelem zadaného popisu.
Zápis změněného popisu je také možné vyvolat opakovaným stiskem tohoto tlačítka ('Proces - uživatelský popis').

9. Nastavení okna úloh
Je určeno pro vstup nastavení, které ovlivňují chování okna úloh.
Tato nastavení jsou specifická pro každého jednotlivého uživatele BM.
Jedná se o tato nastavení:
a/ Otevírat okno úloh při spuštění programu - skupina přepínačů
- Vždy
- Pokud bylo otevřeno při ukončení programu
- Nikdy
b/ Přepínat do hlavního menu programu - skupina přepínačů
určuje chování v situaci, kdy uživatel v základní okně BM uzavře poslední formulář a přitom je otevřené okno úloh. V tomto okamžiku se program přepne do okna hlavního menu a základní okno BM skryje nebo zůstane základní okno BM aktivní.
- Vždy
- Když není aktivní úloha 'Menu BM'
- Nikdy
c/ Používat zobrazení tlačítek - překryvný seznam
určuje jakým způsobem mají být v okně úloh zobrazena ovládací tlačítka
- Textová tlačítka 1 - obsah okna úloh je zobrazován v pevné pozici dané nastavením zobrazování úkolů
- Textová tlačítka 2 - obsah okna úloh je zobrazován dynamicky vždy pod dané tlačítko v seznamu tlačítek
- Ikony
- Překryvný seznam
d/ Nastavit zobrazování úkolů - tlačítko
po stisku tohoto tlačítka se zobrazí seznam, ve kterém je možné měnit pořadí tlačítek, potlačit zobrazení tlačítka a určit pozici okna úloh pro zobrazení tlačítek 'Textová tlačítka 1'
e/ Seznam vlastních stránek IP - textové pole
uvádí se seznam vlastních stránek informačních panelů, které mají být zobrazeny v okně úloh
f/ Dotazovat při uzavírání okna úloh - zaškrtávací políčko

Ing. Petr Filip 15.05.08


VFP9, předlohy výstupu a čeština

VFP9, předlohy výstupu a čeština
Pro práci s klasickými předlohami výstupu ve verzích BM pod Visual Foxpro 9.0 je třeba mít nainstalován program REPORTBUILDER.APP, který zajišťuje zobrazování formulářů pro vstup vlastností polí, pásů, .... v českém jazyce.
Tento program je obsažen v ZIP souboru návodů a balíčků (adresář PRGS).
Ing. Petr Filip 25.05.08


Doplňující vlastnost a VK adresáta

Doplňující vlastnost a VK adresáta
V doplňujících vlastnostech formuláře je možné definovat také otevření volné karty adresáta.
BM přitom nemůže provádět kontrolu, zda je možné pro daný formulář volnou kartu adresáta použít (tj. je-li adresát na prvé stránce formuláře obsažen). Chybné užití takto definované DPV bude proto generovat chybu BM.
Ing. Petr Filip 10.04.08


Konstanty, Obecné předkontace

Konstanty, Obecné předkontace
Formuláře:
Konstanty
Obecné předkontace
Významy položek předkontací
byly doplněny o výběrovou záložku
Ing. Petr Filip 30.04.08


Pozice oken formulářů na obrazovce

Pozice oken formulářů na obrazovce
Při uchovávání pozice okna formuláře BM zaznamenává mj. aktuální rozlišení monitoru.

Při nastavení parametru uživatele "Uchovávání pozice okna ve vztahu k rozlišení obrazovky" = "Přepočítávat pozice poměrem aktuálního rozlišení obrazovky" se
tato informace uplatňuje při obnovení uchované pozice okna při spuštění formuláře na počítačích s jiným rozlišením monitoru, kdy se podle ní přepočítávají:
- umístění levého horní rohu okna v pixelech v ose X = [uložená pozice] * [uložené rozlišení v ose X] / [aktuální rozlišení v ose X]
- výška okna v pixelech = [uložená výška] * [uložené rozlišení v ose X] / [aktuální rozlišení v ose X]
- umístění levého horní rohu okna v pixelech v ose Y = [uložená pozice] * [uložené rozlišení v ose Y] / [aktuální rozlišení v ose Y]
- šířka okna v pixelech = [uložená šířka] * [uložené rozlišení v ose Y] / [aktuální rozlišení v ose Y]

Dalším možným nastavením parametru uživatele "Uchovávání pozice okna ve vztahu k rozlišení obrazovky" je "Zvlášť pro různá rozlišení obrazovky".
Ing. Petr Filip 18.04.08


Určení linek výrobních operací

Určení linek výrobních operací
Ve formuláři pro určení výrobní linek výrobních úkolů generované výrobní zakázky jsou dostupné informace:
- identifikace operace
- varianta operace
- název operace
- identifikace linky
- druh artiklu
- identifikace artiklu
- název artiklu
Ing. Petr Filip 10.04.08


Výstupy do PDF

Výstupy do PDF
Knihovna SYSPDF, byla rozšířena o proceduru PRINT2PDF_SPPRC, která umožňuje při hromadném tisku většího počtu dokladů vytvoření odpovídajícího počtu samostatných souborů PDF resp. emailů.

Zde je výpis doplněné části popisu knihovny SYSPDF:
------------------------------------------------------------------------

Pro výstup procesů (např. faktur) je možné použít volání procedury PRINT2PDF_SPPRC, která zajistí vytvoření samostatný PDF soubor pro každý jednotlivý proces.
Tato procedura má parametry:
_RIDIC - objekt - řídící objekt tisku BM
_AKCE
_TYP
_FRX - text - název souboru definice výstupu Foxpro (přípona FRX) - obvykle se používá ten, který předaný řídícím objektem tisku BM
_PARAMETR_PROFILU - text - parametr profilu výstupu - obvykle se používá ten, který předaný řídícím objektem tisku BM, tj. ten který má u sebe uveden profil předlohy resp. metapředlohy výstupu
_TRIDA - text - název třídy odvozené z třídy BM_CODE_SYSPDF (v příkladu MY_SYSPDF).

Při použití parametru _TRIDA je možné v odpovídající třídě definovat metody vyvolávané opakovaně pro každý vytvářený soubor PDF:
LET_RECIPADDRESS - vrací text - určení adresy emaliu
LET_SUBJECT - vrací text - určení předmětu emaliu
LET_MESSAGETEXT - vrací text - určení obsahu emaliu
LET_OUTFILE - vrací text - určení názvu souboru PDF
Pozn.: V příkladu je uveden kód metody LET_OUTFILE tak, jak je definován ve třídě BM_CODE_SYSPDF. Pokud by zůstal v konkrétní implemetaci stejný, není třeba tuto metodu v definici třídy uvádět.

*------------------------------- příklad použití procedury PRINT2PDF_SPPRC
return print2pdf_spprc(_this,_akce,_typ,_frx,_parametr_profilu,'my_syspdf')
#INCLUDE SYSPDF

Define Class my_syspdf as bm_code_syspdf

Procedure let_recipaddress
return '*pluda_ad01id'

Procedure let_subject
return 'Faktura '+sql_tisk.spprc_sp33cisdr+'-'+sql_tisk.spprc_sp33cisdpm+'-'+sql_tisk.spprc_sp33cisd

Procedure let_messagetext
return 'Zaplaťte včas.'

Procedure let_outfile
local _pth
_pth=this.get_param('OUTPATH','')
* výstupní adresář je možné definovat parametrem profilu OUTPATH např. OUTPATH=C:\TMP
if !empty(_pth)
_pth=addbs(_pth)
do bw_mkadr with _pth
else
_pth=Sys(2023)+'\'
endif
return _pth+spprc_sp33cisdr+'-'+spprc_sp33cisdpm+'-'+spprc_sp33cisd+'.PDF'

enddefine
*------------------------------ konec příkladu použití procedury PRINT2PDF_SPPRC
Ing. Petr Filip 09.04.08


Funkce automatického dokončování

Funkce automatického dokončování
Pro funkci automatického dokončování byla na položkách formulářů, pro které se tato funkce uplatňuje, doplněna reakce na klávesu CTRL+ŠIPKA_DOLŮ.
Způsobí přechod do seznamu návrhů, ve kterém je následně možný pohyb přímo stiskem počátečních písmen textu jednotlivých návrhů.
Klávesu CTRL+ŠIPKA_DOLŮ je možné užít i v případě, že seznam návrhů není právě zobrazen.

Doposud byl přechod do seznamu návrhů možný pouze pomocí myši.

Ve formuláři definujícím funkci automatického dokončování se dále vstupuje:
Uplatní se znaků - uvádí se počet znaků vstupovaného pole, které se uplatní jako výběr pro naplnění seznamu návrhů (-1=všechny)
Přenášet hodnotu - Ano/Ne - při nastavení Ano způsobí přenášení hodnoty do vstupovaného pole při listování v aktivním seznamu návrhů (aktivním např. po užití klávesy CTRL+ŠIPKA_DOLŮ)
Ing. Petr Filip 12.03.08


Loňské údaje v ročním zúčtování

Loňské údaje v ročním zúčtování
Rozšíření funkčnosti ročního zúčtování

V činnosti Karta pracovníka - záložka Roční položky je nově možné zadávat údaje od předchozího zaměstnavatele.

Jedná se o mzdové položky
L30000 - Loňský příjem
L31000 - Loňský odvod
L32000 - Loňská daň
L35000 - Loňský daňový bonus

Dosud používaný způsob (tj. zadání do aktuálního měsíce, ve kterém zpracovávám roční zúčtování) zůstává zachován.

Poznámka :
L34000 - Loňská sleva na dani - tato položka již ztratila smysl
L33000 - Loňský nárok na zvýhodnění - je standartně možné zadávat na záložce Karty pracovníka - Roční položky ve formě položky typu Daňové zvýhodnění - roční nebo roční s bonusem.
Ing. Olga Smitková 11.03.08


Menu Volby x Nabídky

Menu Volby x Nabídky
Je se stává nepřehledným vzhledem k velkému počtu možných doplňujících vlastností (DPV) formuláře a přitom řada těchto DPV je dostupná v uživatelsky definovatelných nabídkách (např. DPV pro zobrazení grafů)

Proto je možné při definování nabídek (formulář vyvolaný volbou Obecné->NABÍDKY->Definování nabídek) nastavit pro každou jednotlivou položku menu její vlastnost Menu=NE. Toto nastavení způsobí potlačení zobrazování dané položky menu pro všechny uživatele BM.

Vlastnost Menu=NE mohou mít nastavenou, také položky menu, které nejsou obsaženy v žádné nabídce a tak je možné vyloučit volby, které jsou součástí programu BM a přitom se vůbec nepoužívají (např. volba Odeslat do Outlooku).
Ing. Petr Filip 19.03.08


Odpisové skupiny - procento

Odpisové skupiny - procento
V činnosti Odpisové skupiny záložka Sazby a koeficienty se nachází nový atribut - procento.

Souvisí pouze s daňovým odpisem zrychleným a používá se pouze v prvním roce odepisování. Jedná se o legislativní změnu.

Ing. Olga Smitková 26.03.08


Předlohy výstupu - Excel 2007

Předlohy výstupu - Excel 2007
Nastavením parametru BM Preferences->Excel_Fileformat (ve formuláři SYSTÉM->Nastavení programu BM) je možné určit formát výstupního souboru Excelu vytvářeného předlohami výstupu typu Excel.
Tento parametr může obsahovat jednu nebo více definic pro různé verze Excelu oddělených středníkem.
Každá tato definice obsahuje číslo verze Excelu (je dostupné v Systémové informace vyvolaných z formuláře O aplikaci Aplikace sady Office->Microsoft Office Excel->Souhrnné informace), po kterém za pomlčkou následuje číslo formátu souboru Excelu.

Např.:
Excel_Fileformat=12.0-56

Tato funkčnost byla doplněna pro možnost odesílání vytvořených dokumentů Excelu 2007 z IS BM e-mailem partnerům, kteří používají nižší verze Excelu.

Ing. Petr Filip 12.03.08


Cenová období

Cenová období
Zabudována kontrola překryvu cenových období v rámci jedné cenové skupiny.

Překryv není možný.
Ing. Olga Smitková 21.02.08


Informační panely

Informační panely
ve fomuláři Definice informačních panelů přibyly na záložkách Sloupce a Elementy položky pro určení HTML-atributů návěští sloupce resp. vytvářeného elementu tabulky.

V těchto položkách se uvádějí jednotlivé HTML-atributy elementu následované výrazem v jazyce Foxpro oddělené enterem (např. TITLE=výraz v jazyce Foxpro).

Určené HTML-atributy vytvářeného elementu tabulky (na záložce Elementy) se uplatní pouze v případě, že:
- element má zaškrtnuto - Tučně nebo Kurzíva nebo Podtržené
- nebo je s elementem spojen hypertextový odkaz
- nebo má element uveden jiný tag (např. neutrální DIV)

Příklad definice HTML-atributů návěští sloupce:
TITLE='Setřízení tabulky podle data splatnosti pohledávky'
TARGET=iif(this.web,'_blank','_self')

Příklad definice HTML-atributů vytvářeného elementu tabulky:
TITLE='Kategorie adresáta:'+chr(13)+tool.sql_dotaz([select list(trim(ad08kateg),char(13)) from %%%.adkatads,%%%.adkat where adkatads.ad01id=?_p1 and adkat.ad08id=adkatads.ad08id],ad01id)
Ing. Petr Filip 27.02.08


Konverze pro štítek v události pošty

Konverze pro štítek v události pošty
Při zadávání adresy adresáta (formulář Adresář na záložce Adresy nebo formulář Adresy adresátů) je možné určit jakým způsobem mají být naplněny informace tištěné na štítek z události poštovní zásilky.

Definice konverze se vkládají činností hlavního menu programu MARKETING->ADRESÁŘ->ČÍSELNÍKY A PARAMETRY->Konverze pro štítek v události pošty.
Tyto definice obsahují atributy:
- Identifikace definice konverze
- Název definice konverze
- Výraz konverze 1.řádku štítku - výraz v jazyce Foxpro - není-li uveden, předplní se prázdný text
- Výraz konverze 2.řádku štítku - výraz v jazyce Foxpro - není-li uveden, předplní se jméno pro štítek resp. jméno uvedené ve spojení
- Výraz konverze 3.řádku štítku - výraz v jazyce Foxpro - není-li uveden, předplní se název firmy adresáta
- Poznámka
Ing. Petr Filip 26.02.08


Mzdy - definice daňových zvýhodnění

Mzdy - definice daňových zvýhodnění
V činnosti DEFINICE - POLOŽKY MEZD - Daňová zvýhodnění a slevy na dani byly přidány atributy Platnost od a Platnost do (mz28oddata, mz28dodata).

V kartě pracovníka je záložka daňová zvýhodnění, která již má atributy platnost do a platnost do (mz36oddata,mz36dodata). Položka uvedená na záložce Karty musí mít takovou platnost, která by nepřesahovala platnost položky v Definicích.

Pokud má položka v Definicích uvedenu platnost do, pak se tato platnost předplní při jejím použití na záložce Karty.
Ing. Olga Smitková 06.02.08


Odvozené menu

Odvozené menu
Ve starších verzích BM nebylo možné zrušit uživatelem odvozené menu, pokud ho některý uživatel používal.

Nyní může toto menu uživatel s právy správce odstranit v případě, že menu nepoužívá žádný aktivní uživatel.
Ing. Petr Filip 07.02.08


Pozice oken formulářů na obrazovce

Pozice oken formulářů na obrazovce
BM volitelně zaznamenává pozice oken formulářů pro jednotlivé uživatele systému tak, že při následujícím spouštění formuláře je jeho okno zobrazeno v zaznamenané pozici.

Takto je možné zaznamenávat pozice oken formulářů, pro které je možné použít volbu z menu Obecné -> Parametry formuláře všech komponent s výjimkou komponent:
- mzdy
- sklad zvířat
- bibliografie
- aukční dům
- pozemky
Pro tyto komponenty bude funkčnost zaznamenávání pozice oken formulářů postupně doplněna.

Způsob zaznamenávání pozice okna je dán nastavením Parametrů uživatele (hlavní menu SYSTÉM -> Parametry uživatele) a Parametrů daného formuláře ( menu Obecné -> Parametry formuláře).

Ve formuláři Parametry uživatele se mj. uvádí parametr Uchovávat pozice oken (překryvný seznam) s možnostmi:
- Nikdy
- Ne
- Ano - automaticky vždy při uzavření okna
- Ano - při nastavení parametrů formuláře

Ve formuláři Parametry formuláře se mj. uvádí parametr Uchovávat pozice oken (překryvný seznam) s možnostmi:
- Ne
- Ano - automaticky vždy při uzavření okna (1)
- Ano - při nastavení parametrů formuláře (2)
- Podle nastavení parametrů uživatele

Výsledné chování BM z hlediska uchování vyplývá z nastavení obou těchto parametrů.
Při nastavení Parametry formuláře->Uchovávat pozice oken = Podle nastavení parametrů uživatele se chová podle nastavení Parametry uživatele->Uchovávat pozice oken.

Uchování pozice okna může probíhat automaticky vždy při uzavření daného okna formuláře nebo vždy probíhá při nastavení parametrů formuláře nebo je možné uložit pozici okna funkcí menu Obecné->Uchovat pozici okna formuláře.
Automatické uchování pozice okna neproběhne také v případě, že:
- Parametry uživatele->Uchovávat pozice oken = Nikdy
- uzavírané okno je maximalizované
- uzavírané okno je minimalizované
- umístění levého horní rohu okna v pixelech v ose X není v intervalu -10 pixelů až šířka nadřízeného okna v pixelech -50 pixelů
- umístění levého horní rohu okna v pixelech v ose Y není v intervalu -10 pixelů až výška nadřízeného okna v pixelech -50 pixelů

Funkci menu Obecné->Uchovat pozici okna formuláře je možné použít v případě, že:
- Parametry uživatele->Uchovávat pozice oken<>Nikdy
- dané okno není maximalizované
- dané okno není minimalizované
- pozice daného okna nemá být ukládána automaticky

K obnovení uchované pozice okna při spuštění formuláře dochází, pokud vyplývá z obou parametrů nastavení (1) nebo (2) a přitom:
- Parametry uživatele->Uchovávat pozice oken<>Nikdy
- obnovovaná pozice okna je taková, že umístění levého horní rohu okna v pixelech v ose X je v intervalu -10 pixelů až šířka nadřízeného okna v pixelech -50 pixelů
- obnovovaná pozice okna je taková, že umístění levého horní rohu okna v pixelech v ose Y je v intervalu -10 pixelů až výška nadřízeného okna v pixelech -50 pixelů
Výška okna formuláře se obnovuje pouze v případě, že je možné libovolně měnit výšku jeho okna až do výšky nadřazeného okna.
Šířka okna formuláře se obnovuje pouze v případě, že je možné libovolně měnit šířku jeho okna až do šířky nadřazeného okna.

Pozice okna se obvykle uchovává jediná pro daný formulář s výjimkou:
- formulář spuštěné operace komponenty - ukládají pozice zvlášť pro každý druh operace
- formulář Strom hlavního procesu - ukládají pozice zvlášť pro každý druh hlavního procesu
- formulář Spojené dokumenty - ukládají pozice zvlášť pro každý druh objektu, ke kterému jsou dokumenty připojeny
- formulář Volné karty - ukládají pozice zvlášť pro každou volnou kartu
- formulář Obecného stromu - ukládají pozice zvlášť pro každý obecný strom
Ing. Petr Filip 18.02.08


Překlad textů - Překryvný seznam

Překlad textů - Překryvný seznam
Obsah překryvného seznamu je možné definovat překladem textu dvojím způsobem:
- prostým výčtem
- výčtem s uvedením hodnot

Pro obsah překryvného seznamu definovaného prostým výčtem je hodnota vybrané položky daná jejím pořadím v přeloženém textu.
Např.:
Vše,Uvažovaný,Zamítnutý,Odložený,Schválený,Rozpracovaný,Ukončený

Pro obsah překryvného seznamu definovaného výčtem s uvedením hodnot je hodnota vybrané položky definovaná numerickou hodnotou, která je v seznamu uvedena bezprostředně za danou položkou.
Např.:
Vše,1,Schválený,5,Uvažovaný,2,Zamítnutý,3,Odložený,4,Rozpracovaný,6,Ukončený,7
Proto, aby byl přeložený text překryvného seznamu považován za obsah definovaný výčtem s uvedením hodnot musí platit:
- celkový počet položek seznamu je sudý
- na sudých pozicích seznamu jsou uvedena celá čísla
- alespoň jeden text na liché pozici v seznamu není celé číslo (např. text '1,2,3,4' není považován za obsah definovaný výčtem s uvedením hodnot)
- nesmí existovat hodnota překryvného seznamu, která by se opakovala (např. text 'Vše,1,Schválený,5,Uvažovaný,1' není považován za obsah definovaný výčtem s uvedením hodnot)

Použití překladu obsahu překryvného seznamu výčtem s uvedením hodnot umožňuje vyloučit z překryvného seznamu hodnoty, které nemají v dané implementaci smysl.
Např.:
Vše,1,Uvažovaný,2,Schválený,5,Ukončený,7

Ing. Petr Filip 19.02.08


Spojené dokumenty

Spojené dokumenty
Byla obnovena a rozšířena funkčnost ve stromu spojených dokumentů pro jeho uzly týkajících se počtu událostí založených v BM pro aktuálně zobrazeného adresáta resp. artikl.

Ve verzi BM pro rok 2007 bylo možné pravým klikem nebo dvojím klikem na těchto uzlech vyvolat formulář pro zobrazení odpovídajících událostí.
V první verzi BM pro rok 2008 bylo možné tuto funkci vyvolat pouze pravým klikem myši.
V dalších verzích nyní funguje:
- pravý klik myši na uzlu ve stromu zobrazujícím celkový počet událostí komponenty nebo počet událostí komponenty některého druhu operace - vyvolává formulář pro zobrazení odpovídajících událostí
- dvojí klik myši na uzlu ve stromu zobrazujícím počet událostí komponenty některého druhu operace - vyvolává formulář pro zobrazení odpovídajících událostí navíc s předplněným výběrem daného druhu operace
Ing. Petr Filip 05.02.08


Strom hlavního procesu

Strom hlavního procesu
Ve stromu hlavního procesu se nyní nezobrazuje u jeho první operace ve složených závorkách hodnota rozpadu, která byla vyhodnocena při rozpadu transformací na procesy.
Důvodem pro rozhodnutí je zvýšení přehlednosti stromu (v implementacích se např. pro rozpad procesů užívá jednoznačná časová identifikace).
Ing. Petr Filip 19.02.08


Šablona OBC odskok F2 pomocí překryvného

Šablona OBC odskok F2 pomocí překryvného
Při práci se šablonou je možné u proměnných nastavit odskok na číselník, který je relevantní k dané proměnné.

Odskok na klasifikaci objektů je ale obtížné používat, a proto je lépe tuto funkčnost nahradit použitím překryvného seznamu s výrazem *~select pa13id,pa13id from paobjdru where bw55objec='OB' . Proměnnou, která zachycuje tento výraz je třeba zapracovat do pravidel šablony.

Překryvný seznam s výrazem dovoluje použít pouze velmi krátký výraz, a proto je možné použít pouze atributy pa13id,pa13id místo vhodnějších pa13id,pa13nazdru.

Zabudováno do návodů a balíčků.
Ing. Olga Smitková 21.02.08


Výroba

Výroba
Proces Zakázky výroby
1) V procesu Zakázky výroby opravena funkčnost výběru datum od, datumd do.

2) Výběr doplněn o atribut datum ukončení (vr02datkon)

ad 1) a 2) Výběr nyní má 4 atributy :
datum zahájení od, datum zahájení do
datum ukončení od, datum ukončení do.

3) Do gridu doplněny selektory

Ing. Olga Smitková 21.02.08


Předlohy výstupu (PDF)

Předlohy výstupu (PDF)
V definici předlohy výstupu přibyla na záložce Deklarace vlastnost předlohy 'Skript po SQL dotazu' a původní vlastnost 'Script' byla přejmenována na 'Script před SQL dotazem'.

'Skript po SQL dotazu' je prováděn bezprostředně před výstupem, který nebude proveden v případě, že tento vrátí hodnotu .F. (FALSE).
Skriptu jsou předány tyto parametry:
_THIS - řídící objekt výstupu
_THISFORM - objekt formuláře pro který je prováděn výstup
_FRX - jméno souboru s definicí výstupu FRX
_AKCE - text PRINT, TOFILE, PREVIEW nebo EDIT podle toho, jaká činnost je s předlohou prováděna
_PROMPT - .T. nebo .F. podle toho, zda uživatel zaškrtl Nastavení tiskárny
_PARAMETR_PROFILU - text uvedený v 'Parametru profilu' profilu předlohy resp. metapředlohy
_TYP - numerická hodnota 1 pro předlohu typu Sestava nebo 2 pro předlohu typu Excel nebo 3 pro předlohu typu Ostatní nebo 4 pro předlohu typu Word

Pozn.: v souvislosti s touto novinkou přibyl atribut Parametr profilu ve formuláři Profily spuštění předloh

V parametru programu BM 'Printing->Default_skript_po_SQL' je možné zadat identifikaci Knihovny vkládaného kódu, jejíž kód má být prováděn pro všechny předlohy výstupu, které nemají vyplněnou vlastnost 'Skript po SQL dotazu'.

Skript je prováděn vždy při výstupu předlohou nebo její opravě (proto by měl brát ohled na obsah parametru _AKCE) a může provádět např. :
- modifikaci dat, která budou vystupována
- vytvoření jiného formátu výstupu (PDF,....)

Pro výstup předlohami typu výstupu jsou v Návodech a balíčcích knihovny pro výstup do dokumentu ve formátu PDF.
Pro představu o tomto řešení je v následujícím textu uveden popis napsaný v jejich poznámce (nebude uveden v helpu).

-----------------------------------------------
Knihovna SYSPDF
Knihovna s funkcemi pro výstup tiskové předlohy typu Sestava do souboru ve formátu PDF.

Tato knihovna podporuje dva způsoby vytvoření PDF dokumentu:
1/ využití nástroje Ghostscript
2/ výstup prostřednictvím PDF tiskárny

Ghostscript
Jedná se o produkt firmy Artifex Software Inc. (http://www.artifex.com), který je distribuován v licencování AFPL (Aladdin Ghostscript Free Public License) nebo jeho novější verze v licencování GNU (General Public License).
Ghostscript je možné získat na http://www.cs.wisc.edu/~ghost/ .
Ghostscript je interpret jazyka PostScript (PS) do Portable Document Format (PDF).
Kód knihovny provádí nejprve výstup tisku do souboru ve formátu PostScript a následně spouští Ghostscript, který převádí tento soubor do formátu PDF. Proto je třeba, aby byla na počítači provádějícím výstup kromě GhostScriptu nainstalována také PostScriptová tiskárna.
PostScriptovou tiskárnu je možné získat např. na http://www.adobe.com/support/downloads/product.jsp?product=pdrv&platform=win (je třeba stáhnout zvlášť installer a PPD).

PDF tiskárna
Jedná se o programy, které vytvářejí virtuální tiskárnu tak, že při tiskovém výstupu jakéhokoliv programu Windows na tuto tiskárnu je vytvářen dokument PDF.
Může se jednat o freewareové produkty (např. PDFCreator) nebo komerční produkty (např. tiskárna PRINT2PDF firmy Software602)

Knihovna SYSPDF se používá ve spojení s kódem uvedeným v předloze výstupu ve vlastnosti 'Skript po SQL dotazu'.
Např.:
******************************************************************************
Local _rt
IF _akce<>'TOFILE' OR _typ<>1
select sql_tisk
RETURN .T.
ELSE
_rt=print2pdf(_this,'',_frx,_parametr_profilu)=0
select sql_tisk
go top
return _rt
ENDIF

#INCLUDE SYSPDF
*******************************************************************************

Pozn.: proměnné _AKCE, _FRX, _THIS, _TYP a _PARAMETR_PROFILU jsou proměnné, které předává BM tomuto kódu při jeho volání jejich význam je popsán v helpu BM.

V příkladu je uvedena jedna možnost volání výstupu do PDF touto knihovnou, a to volání programu PRINT2PDF, který má parametry:
_RIDIC - objekt - řídící objekt tisku BM
_OUTFILE - text - název vytvářeného výstupního souboru PDF - je-li prázdný, potom bude jeho název TEMP1.PDF nebo TEMP2.PDF nebo TEMP3.PDF ... (první vytvořitelný - který nemá právě otevřený Acrobat Reader) v temporary adresáři
_FRX - text - název souboru definice výstupu Foxpro (přípona FRX) - obvykle se používá ten, který předaný řídícím objektem tisku BM
_PARAMETR_PROFILU - text - parametr profilu výstupu - obvykle se používá ten, který předaný řídícím objektem tisku BM, tj. ten který má u sebe uveden profil předlohy resp. metapředlohy výstupu
_RECIPADDRESS - text - emailová adresa
_SUBJECT - text - předmět emailu - je-li neprázdný a přitom není dáno parametry profilu jinak, potom bude vytvářen email, jehož bude vytvořený PDF dokument přílohou
_MESSAGETEXT - text - obsah emailu
Program vrací numerickou hodnotu:
0 - PDF dokument nebyl vytvářen
1 - PDF dokument byl vytvořen resp. PDF dokument byl vytvořen a odeslán emailem
17 - chyba - Programu Print2PDF nebyly předány parametry
18 - chyba - V adresáři "xxx" nebyl nalezen žádný program pro spuštění instalace
19 - chyba - Tiskárna "xxx" není na Vašem počítači nainstalovaná
20 - chyba - Ghostscript není na Vašem počítači nainstalován
21 - chyba - Pro spuštění Ghostscriptu není v adresáři "xxx" nalezen program "GSWIN32C.EXE"
24 - chyba - Soubor "xxx" nebyl příkazem REPORT FORM TO PRINTER vytvořen
25 - chyba - Soubor "xxx" nebyl příkazem REPORT FORM TO FILE vytvořen
26 - chyba - Ghostscript nevytvořil soubor "xxx"
27 - chyba - Uživatel neodeslal email

Druhou možností je možné pracovat ve skriptu 'Skript po SQL dotazu' přímo s objektem třídy BM_CODE_SYSPDF pro výstup do PDF definovaném v knihovně SYSPDF resp. jiném implementátorem vytvořeným objektem jiné knihovny odvozeným z třídy objektu BM_CODE_SYSPDF.
Např. ekvivalentní kód předchozímu příkladu:

**************************************************************************
Local lopdf, _rt
IF _akce<>'TOFILE' OR _typ<>1
select sql_tisk
RETURN .T.
ENDIF

select sql_tisk
go top

lopdf = Createobject("bm_code_syspdf")
lopdf.ridic=_this
lopdf.parametr_profilu=_parametr_profilu
lopdf.recipaddress='*PLUDA_AD01ID'
lopdf.subject='Faktura '+sql_tisk.spprc_sp33cisdr+'-'+sql_tisk.spprc_sp33cisd
*lopdf.subject='Faktura '+bw_tiskh('PLA', 'SQL_TISK.PLUDA_pl02vs')
lopdf.messagetext='Zaplaťte nebo zemřete !!!'+chr(13)+chr(13)+tool.jmenot
lopdf.creport= _frx
* Metoda MAIN objektu třídy BM_CODE_SYSPDF vytváří dokument PDF a vrací numerickou hodnotu (0,1,17 ...)
Return lopdf.Main()=0

#INCLUDE SYSPDF

***************************************************************************

Vytváření PDF dokumentu může být ovlivněno parametry uvedenými v proměnné _PARAMETR_PROFILU, ve kterém mohou být odělené uvedené parametry CRLF nebo středníkem.
Jedná se o:
PDF=0 - výstup do PDF nemá být prováděn - default PDF=1
GHOSTSCRIPT=0 - nebude používán Ghostscript, ale PDF tiskárna - default GHOSTSCRIPT=1
PRINTER=název tiskárny - jiný název použité tiskárny než default - default při GHOSTSCRIPT=1 je to PRINTER=GENERIC POSTSCRIPT PRINTER a při GHOSTSCRIPT=0 je to PRINTER=PRINT2PDF
PRINTERFILE=název výstupního dokumentu PDF tiskárny (při GHOSTSCRIPT=0) - default PRINTERFILE=C:\TMP\SOUBOR.PDF
PRINTRESOLUTION=600 - rozlišení PDF dokumentu v pixelech při GHOSTSCRIPT=1 (při GHOSTSCRIPT=1) - default PRINTRESOLUTION=300
GSFOLDER=kořenový adresář, ve kterém je nainstalován Ghostscript (při GHOSTSCRIPT=1) - default GSFOLDER=C:\Program Files\GS a GSFOLDER=C:\GS
EMAIL=0 - nebude odeslán email, i když je Subject uveden - default EMAIL=1
DROPPDF=0 - dokument PDF nebude po odeslání emailu zrušen - default DROPPDF=1
VIEWPDF=0 - nebude spouštěn Acrobat Reader pro prohlížení dokumentu ani v případě, že není odesílán email - VIEWPDF=1
AUTOINSTALLPATH=jiný adresář pro automatickou instalaci Ghostscriptu a postscriptové tiskárny (při GHOSTSCRIPT=1) - default AUTOINSTALLPATH=AUTOINSTALL

Parametr AUTOINSTALLPATH naznačuje, že může být při tisku automatizovaně prováděna instalace Ghostscriptu a postscriptové tiskárny, pokud nejsou na počítači uživatele nalezeny.
Pro tuto instalaci je třeba vytvořit adresář podle tohoto parametru s podadresáři GHOSTSCRIPT a PSDRIVERS a do nich umístit jejich instalační EXE.
Při nastavení AUTOINSTALLPATH=NO není automatická instalace prováděna.

------------------------------------
Knihovna DEFPDF
Knihovna určená pro uvedení v parametru BM Printing->Default_skript_po_SQL, která způsobí to, že tisk předlohami výstupu typu Sestava do souboru vytvoří PDF dokumentu a následně ho zobrazí v Acrobat Readeru.
Pro svou funkci používá knihovnu SYSPDF.
Ing. Petr Filip 15.01.08


Oceňování kurzem včerejšího dne

Oceňování kurzem včerejšího dne
zákon umožňuje do 15-cti hodin vyhodnocovat částky v zahraničních měnách kurzem předchozího dne, protože ČNB stanoví kurzy měn pro každý den až právě v 15 hodin každého dne (na Slovensku byli chytřejší - NBS stanoví kurz každý den pro následující den)
Proto je možné nastavit parametr oceňování 'Pro dnešní datum do 15.hodin pracovat s včerejším kurzem', který respektuje toto ustanovení.
Tj. způsobí předplňování kurzu předchozího dne (v pondělí pátečním kurzem) při vstupu události s aktuálním datem a přitom je aktuální čas počítače menší než 15 hodin a při nastavení 'Automatická aktualizace kurzu' je podle stejného pravidla aktualizován kurz dané měny uložený v BM.
Ing. Petr Filip 10.12.07


Předlohy výstupu

Předlohy výstupu
Sybase SQL Anywhere verze 9 je citlivější na SQL dotazy obsahující na příkazy obsahující klauzuli LEFT OUTER JOIN, která musí být v jejím případě umísťována bezprostředně za tabulku, ke které navazující tabulka připojována.

Např. SQL dotaz:
select * from bm_servis.adadsat,bm_servis.spseob left outer join bm_servis.adspoj on adspoj.ad01id=adadsat.ad01id where spseob.sp10idzak=adadsat.sp10idzak
který je funkční v nižších verzích Sybase SQL Anywhere, musí mít pro Sybase SQL Anywhere verze 9 tvar:
select * from bm_servis.adadsat left outer join bm_servis.adspoj on adspoj.ad01id=adadsat.ad01id,bm_servis.spseob where spseob.sp10idzak=adadsat.sp10idzak

Pro řešení tohoto problému je možné ve vlastnostech předlohy výstupu určovat v její vlastnosti Select-join (záložka Doplnění), kam má být která část uvedené definice do sestavovaného SQL dotazu zařazena.
Ve vlastnosti Select-join je možné uvádět definici jednu nebo několik subdefinic oddělených znakem '|' (svislá čára).
Syntaxe subdefinice je:
[#alias#] [tělo subdefinice]
Každá z těchto subdefinic určuje ve svém těle část SQL dotazu, která má být v sestavovaném SQL dotazu umístěna na různém místě podle uvedeného alias.

Příklad nastavení vlastnosti Select-join pro předlohu výstupu Události plateb:
#PLUDA# LEFT OUTER JOIN %%%.ADBUCTY UC99 ON UC99.AD01ID=PLUDA.AD01ID AND UC99.AD03CISBAN='99' |
#ADADSAT# LEFT OUTER JOIN %%%.ADSPOJ SP13 ON SP13.AD01ID=ADADSAT.AD01ID AND SP13.AD11CISSPO='13'

Ing. Petr Filip 10.12.07


Předlohy výstupu

Předlohy výstupu
V předlohách výstupu typu Excel typu 1 je možné na záložce Sloupce zaškrtnutím 'Zobrazit nuly', zajistit vložení nulové hodnoty do buňky v Excelu i v případě, že vyhodnocením výrazu sloupce je zjištěna nulová hodnota.
Pro sloupce, ve kterých je definován Mezisoučet, je možné zaškrtnutím 'Také pro 1 řádek' zajistit zobrazení mezisoučtového řádku pro nejnižší úroveň mezisoučtu také v případě, že zdrojem pro mezisoučet je jediný řádek.
Ing. Petr Filip 20.12.07


Sériové číslo programu

Sériové číslo programu
programy BM pro rok 2008 používají nové registrační klíče, ve kterých je zakódováno omezení maximálního možného počtu přihlášených uživatelů.
Součástí dodávky verze pro rok 2008 je proto vytištěný list obsahující tyto nové registrační klíče.
Ing. Petr Filip 11.12.07


Předplňování komentáře procesu

Předplňování komentáře procesu
Na záložce Další u Druhu procesu je možné mj. definovat v položce 'Výraz poznámky procesu' - výraz nebo skript v jazyce Foxpro, na základě jehož vyhodnocení je předplňován text komentáře nově zakládaného procesu.

Skript je možné definovat po pravém kliku myší na položce a jeho text musí být uveden slovem SCRIPT (také pro výraz popisu procesu a výraz externí identifikace procesu).
V kódu skriptu je možné odkazovat se na proměnné:
- _THIS - řídící objekt operace (např. pro využití jeho atributů _THIS.SP33CISDRO, _THIS.SP33CISDPO, _THIS.SP33CISDO ...)
- _ALIAS - alias kurzoru, ve kterém se nacházejí informace pro vytvoření popisu

Přiklad:
SCRIPT
LOCAL _sp33text
_sp33text=tool.sql_dotaz([select sp33text from %%%.spprc where sp33cisdr=?_p1 and sp33cisdpm=?_p2 and sp33cisd=?_p3],;
    _this.sp33cisdro, _this.sp33cisdpo, _this.sp33cisdo)
RETURN _sp33text
Ing. Petr Filip 02.11.07

Viz.také

Výběr zajímavých novinek


Výběr zajímavých novinek

Výběr zajímavých novinek
Obsahuje výběr zajímavých novinek za poslední tři roky.

Klikněte na hypertextový odkaz Výběr zajímavých novinek.
Ing. Petr Filip 09.11.07

Viz.také

Mzdy - palety a kategorie | Signalizace zpráv | Selektory v účetním deníku | Označování výrazem | Transformace procesů | Předlohy dokumentů - přístupová práva | Přizpůsobení mřížek formulářů BM | Výdeje z pokladny do mínusu | Úpravy adresáře | Návrat hodnoty a volná karta | Artikly - předplňování a validace | Změna velikosti okna formuláře | Strom hlavního procesu | Hlavní menu programu | Mzdy - souhrnné daňové tabulky | Palety barev adresátů | Kontrola VS v události komponenty platby | Mzdy - kalendáře nepravidelné | Pravidla inicializací přístupových práv | Správa artiklu | Nastavení sledování změn tabulek | Platby | Třídění v mřížce po kliku na sloupec | Výstupy z BM na jehličkové tiskárny | Strom hlavního procesu | Spojené dokumenty - Strom hlavního proc. | Informační panely | Změna velkosti okna formuláře | Problémy s nápovědou pod Windows 2003 | Volné karty - dynamický combobox | Klávesa CTRL+Q na výběrové záložce | Informační panely - třídění sloupců | Sledování změn v záznamech tabulek BM | Událost účetnictví - rozúčtování | Výkazy zaokrouhleně | Událost účetnictví - kontrola selektorů | Spojení adresátů | Více měn jednoho bankovního účtu | Spojení adresátů v událostech komponent | Třídění dat v mřížkách formulářů | Předlohy výstupu - výstup do Word | Předplňování komentáře procesu | Kategorie dokumentů - Spojené dokumenty | Spojení adresátů v událostech komponent | Parametry uživatele | Funkce automatického dokončování


Artikly - předplňování a validace

Artikly - předplňování a validace
Druh artiklu byl doplněn o novou vlastnost "Algoritmus předplnění a validace identifikace nového artiklu".
V překryvném seznamu je možné stanovit pro druh artiklu algoritmus, podle kterého bude předplněna identifikace artiklu při vstupu nového artiklu daného druhu a validován vstup nového artiklu.
Funkčnost předplnění a validace identifikace artiklu je v tomto okamžiku realizovaná ve všech formulářích artiklů v vyjímkou formulářů:
- artikly bibliografie
- artikly aukčního domu
- nemovitosti
- artikly mezd

Algoritmy se definují novou činností nazvanou "Algoritmy předplnění a validace artiklu"
V její formuláři se uvádí:
název algoritmu
kód předplnění - text - skript v jazyce Foxpro, který se uplatní při zakládání nového artiklu daného druhu pro předplnění jeho identifikace
kód validace - text - skript v jazyce Foxpro, který se uplatní při zakládání nového artiklu daného druhu pro validaci jeho identifikace
poznámka - libovolný text

V kódu předplnění jsou k dispozici proměnné:
_ALIAS - text - alias kurzoru formuláře, ve kterém je artikl vstupován
_SP61ID - text - druh artiklu, který je vstupován
Kód musí vracet hodnotu typu text, kterou bude předplněna identifikace artiklu

V kódu validace jsou k dispozici proměnné:
_ALIAS - text - alias kurzoru formuláře, ve kterém je artikl vstupován
_SP61ID - text - druh artiklu, který je vstupován
_SP60ID - text - identifikace artiklu, který je vstupován
Kód musí vracet logickou hodnotu .T. (TRUE) nebo .F. (FALSE)

V souvislosti s touto novou funkčností je k dispozici knihovna vkládaného kódu SYSAR1, která obsahuje mj. uživatelské funkce:
1/ ID_ARTIKLU
Tato funkce vrací identifikaci nového artiklu podle užitých parametrů:
_ALIAS - text - alias kurzoru formuláře, ve kterém je artikl vstupován (užije se proměnná _ALIAS)
_PREFIX - text - proměnný text užitý na začátku identifikace artiklu (např. rok)
_CIFER - číslo - počet cifer pořadového čísla artiklu stejného druhu se stejným prefixem a postfixem - počet cifer+délka prefixu+délka postfixu nesmí být větší než 13
_POSTFIX - text - proměnný text užitý na konci identifikace artiklu - tento parametr není povinný
2/ VALID_ARTIKLU
Tato funkce vrací identifikaci nového artiklu podle užitých parametrů:
_ALIAS - text - alias kurzoru formuláře, ve kterém je artikl vstupován (užije se proměnná _ALIAS)
_PREFIX - text - proměnný text musí být užitý na začátku identifikace artiklu (např. rok)
_CIFER - číslo - počet cifer pořadového čísla artiklu stejného druhu se stejným prefixem a postfixem - počet cifer+délka prefixu+délka postfixu nesmí být větší než 13
_POSTFIX - text - proměnný text musí být užitý na konci identifikace artiklu - tento parametr není povinný

Omezení:
Vzhledem k programovému řešení nemusí obě popsané funkce správně fungovat, pokud se budou v hodnotě prefixu resp. postfixu vyskytovat náhražkové znaky (wildcards) používané podmínkou LIKE v SQL dotazech Sybase SQL Anywhere (_, %, [, ]) a ve funkci LIKE() Visual Foxpro ( * , ? ).

Příklady použití knihovny SYSAR1:
1/ identifikace artiklu obsahuje rok+pořadové číslo artiklu na 5 cifer
Kód předplnění:
RETURN id_artiklu(_alias,TRANS(YEAR(DATE()))+'-',5)
#INCLUDE SYSAR1
Vrátí identifikaci nového artiklu např. 2005-00025
Kód validace:
RETURN valid_artiklu(_alias,TRANS(YEAR(DATE()))+'-',5)
#INCLUDE SYSAR1
Vrátí logickou hodnotu .T. v případě, že má identifikace artiklu odpovídající strukturu včetně hodnoty prefixu

2/ identifikace artiklu obsahuje pořadové číslo artiklu na 7 cifer (bez prefixu a postfixu)
Kód předplnění:
RETURN id_artiklu(_alias,'',7)
#INCLUDE SYSAR1
Vrátí identifikaci nového artiklu např. 0000123
Kód validace:
RETURN valid_artiklu(_alias,'',7)
#INCLUDE SYSAR1
Vrátí logickou hodnotu .T. v případě, že má identifikace artiklu odpovídající strukturu

3/ identifikace artiklu obsahuje rok a měsíc+pořadové číslo artiklu na 4 cifry
Kód předplnění:
RETURN id_artiklu(_alias,LEFT(DTOC(DATE(),1),6)+'-',4)
#INCLUDE SYSAR1
Vrátí identifikaci nového artiklu např. 200507-0101
Kód validace:
RETURN valid_artiklu(_alias,LEFT(DTOC(DATE(),1),6)+'-',4)
#INCLUDE SYSAR1
Vrátí logickou hodnotu .T. v případě, že má identifikace artiklu odpovídající strukturu včetně hodnoty prefixu

4/ identifikace artiklu obsahuje rok + identifikaci datového úložiště+pořadové číslo artiklu na 5 cifer
Kód předplnění:
RETURN id_artiklu(_alias,TRANS(YEAR(DATE()))+'-'+RIGHT(tool.user,2)+'-',5)
#INCLUDE SYSAR1
Vrátí identifikaci nového artiklu např. 2005-01-40501.
Kód validace:
RETURN valid_artiklu(_alias,TRANS(YEAR(DATE()))+'-'+RIGHT(tool.user,2)+'-',5)
#INCLUDE SYSAR1
Vrátí logickou hodnotu .T. v případě, že má identifikace artiklu odpovídající strukturu včetně hodnoty prefixu

5/ identifikace artiklu obsahuje pořadové číslo artiklu na 5 cifer + identifikaci datového úložiště
Kód předplnění:
RETURN id_artiklu(_alias,'',5,'/'+RIGHT(tool.user,2))
#INCLUDE SYSAR1
Vrátí identifikaci nového artiklu např. 00045/05
Kód validace:
RETURN valid_artiklu(_alias,'',5,'/'+RIGHT(tool.user,2))
#INCLUDE SYSAR1
Vrátí logickou hodnotu .T. v případě, že má identifikace artiklu odpovídající strukturu včetně hodnoty postfixu

6/ identifikace artiklu obsahuje rok,měsíc a den+pořadové číslo artiklu na 4 cifry
Kód předplnění:
RETURN id_artiklu(_alias,DTOC(DATE(),1)+'-',4)
#INCLUDE SYSAR1
Vrátí identifikaci nového artiklu např. 20050713-0101
Kód validace:
RETURN valid_artiklu(_alias,DTOC(DATE(),1)+'-',4)
#INCLUDE SYSAR1
Vrátí logickou hodnotu .T. v případě, že má identifikace artiklu odpovídající strukturu včetně hodnoty prefixu

Doporučení:
Konstruovat názvy algoritmů tak, aby odpovídali tvaru předplňované hodnoty např. pro příklady:
ad 1/ RRRR-NNNNN
ad 2/ NNNNNNN
ad 3/ RRRRMM-NNNN
ad 4/ RRRR-DU-NNNNN
ad 5/ NNNNN/DU
ad 6/ RRRRMMDD-NNNN

Zde je obsah knihovny SYSAR1 pro inspiraci v případech, kdy její funkčnost nebude dostatečná:
PROCEDURE id_artiklu
LPARAMETERS _alias,_prefix,_cifer,_postfix
LOCAL _sp61id,_sp60id1,_sp60id2,_mezer,_limit1,_limit2,_maska
* Následující komentáře jsou pro příklad skutečných parametrů _PREFIX=TRANS(YEAR(DATE()))+'-' a _CIFER=4
* Identifikace artiklu bude vypadat RRRR-NNNN, kde RRRR je rok a NNNN je pořadové číslo v roce
* v proměnné _ALIAS je aktuálně alias kurzoru do kterého jsou vstupována data
IF EMPTY(_postfix)
_postfix=''
ENDIF
SELECT (_alias)
_sp61id=sp61id
_mezer=LEN(sp60id)-LEN(_prefix)-_cifer-LEN(_postfix)
* limitní identifikace artiklu od RRRR-0000
_limit1=_prefix+REPLICATE('0',_cifer)+_postfix+SPACE(_mezer)
* limitní identifikace artiklu od RRRR-9999
_limit2=_prefix+REPLICATE('9',_cifer)+_postfix+SPACE(_mezer)
* maska vyloučí artikly např. RRRR-NNNNNN, ale ne RRRR-NNN nebo RRRR-NABC (to udělá uživatelská funkce jsou_tam_cifry)
_maska=_prefix+REPLICATE('?',_cifer)+_postfix+SPACE(_mezer)
* dotaz do kurzoru, protože mohou být vstoupeny artikly, které nejsou zatím zapsány na server
CALCULATE MAX(sp60id) TO _sp60id1 FOR sp61id=_sp61id AND BETWEEN(sp60id,_limit1,_limit2) AND ;
LIKEC(_maska,sp60id) AND jsou_tam_cifry(sp60id,_maska)
* maska vyloučí artikly např. RRRR-NNNNNN ale i RRRR-NABC
_maska=_prefix+REPLICATE('[0-9]',_cifer)+_postfix+SPACE(_mezer)
* dotaz na server do tabulky SPARTIKL, protože ne všechny artikly musí být aktuálně v kurzoru
_sp60id2=tool.sql_dotaz([select max(sp60id) from %%%.spartikl where sp61id=?_p1 and ]+;
[sp60id between ?_p2 and ?_p3 and sp60id like ?_p4],_sp61id,_limit1,_limit2,_maska)
IF _sp60id1<_sp60id2
* dotazem na server bylo zjištěno větší pořadové číslo
_sp60id1=_sp60id2
ENDIF
IF EMPTY(_sp60id1)
* jedná se o první artikl s prefixem daného roku
RETURN _prefix+REPLICATE('0',_cifer-1)+'1'+_postfix
ELSE
* vrací zvýšené pořadové číslo v roce
RETURN _prefix+PADL(LTRIM(STR(VAL(STUFF(_sp60id1,1,LEN(_prefix),''))+1)),_cifer,'0')+_postfix
ENDIF

PROCEDURE jsou_tam_cifry
LPARAMETERS _sp60id,_maska
* vrací TRUE pokud na pozicích všech otazníků v masce jsou cifry
LOCAL _i
FOR _i=1 TO MIN(LEN(_sp60id),LEN(_maska))
IF SUBSTR(_maska,_i,1)='?' AND !ISDIGIT(SUBSTR(_sp60id,_i,1))
RETURN .F.
ENDIF
ENDFOR
RETURN .T.

PROCEDURE valid_artiklu
LPARAMETERS _alias,_prefix,_cifer,_postfix
LOCAL _mezer,_maska,_sp60id
_sp60id=EVALUATE(_alias+'.sp60id')
IF EMPTY(_postfix)
_postfix=''
ENDIF
_mezer=LEN(_sp60id)-LEN(_prefix)-_cifer-LEN(_postfix)
_maska=_prefix+REPLICATE('?',_cifer)+_postfix+SPACE(_mezer)
RETURN LIKEC(_maska,_sp60id) AND jsou_tam_cifry(_sp60id,_maska)
Ing. Petr Filip 21.07.05

Viz.také

Výběr zajímavých novinek


Funkce automatického dokončování

Funkce automatického dokončování
V BM je možné nastavit funkci automatického dokončování při vstupu údajů formuláře podobně jako je možné pro Internet Explorer viz. http://support.microsoft.com/?kbid=217148.

Funkce automatického dokončování se nastavuje zvlášť pro každé pole formuláře, ve kterém je vstupován textový údaj.

Aktivaci této funkce je možné udělat při nastavení na dané pole formuláře dvojím způsobem:
1/ po stisku klávesy CTRL+HOME a odsouhlasení aktivace funkce uživatelem
2/ nastavením parametrů pole formuláře vyvolaném po pravém stisku klávesy myši, při kterém je zároveň podržena klávesa CTRL (CTRL+pravý klik).

V zobrazeném formuláři se vstupuje:
Činnost - identifikace činnosti (formuláře)
Pole - identifikace pole formuláře
Uživatel - identifikace uživatele systému
Funkce automatického dokončování - překryvný seznam - Ano/Ne
Naplnění seznamu návrhů - překryvný seznam - Vstupem/SQL dotazem/Výčtem/Skriptem
SQL/Výčet/Skript - text - tvar SQL dotazu pro Naplnění seznamu návrhů=SQL dotazem nebo seznam hodnot Naplnění seznamu návrhů=Výčtem nebo skript v jazyce Foxpro, který vytvoří seznam hodnot Naplnění seznamu návrhů=Skriptem
Výraz prefixu - text - výraz v jazyce Foxpro
Poznámka - text - libovolný text

Takto definované parametry, jsou specifické pro dané pole daného formuláře pro aktuálně přihlášeného uživatele systému.
Uživatel s právy správce systému má možnost aktivovat funkci automatického dokončování pro dané pole daného formuláře pro všechny uživatele systému založením parametrů pro uživatele SYSTÉM.
Pokud je pro pole definováno Globální nastavení parametrů a zároveň nastavení parametrů uživatele, potom se uplatňuje nastavení uživatele.

Při vstupu textového pole formuláře, pro které je aktivní funkce automatického dokončování, zobrazuje BM seznam návrhů.
Pokud určitý návrh v seznamu odpovídá požadovaným kritériím pro dané pole, klepněte na něj nebo jej vyberte pomocí klávesy ŠIPKA DOLŮ a potom stiskněte klávesu ENTER.
Chcete-li ze seznamu návrhů vymazat jednotlivé položky, klepněte v seznamu návrhů pro dané pole na požadovanou položku a potom stiskněte klávesu DELETE (při nastavení parametru Naplnění seznamu návrhů=Vstupem) .
Seznam návrhů funkce automatického dokončování se automaticky zobrazí při vstupu znaku v poli.

Podle nastavení parametru pole formuláře - Naplnění seznamu návrhů - BM vytváří seznam návrhů:
1/ nastavení Vstupem
Funkce automatického dokončování uchovává hodnoty zadávané v poli formuláře, jakou je například položka, kterou jste právě zadali, po dalším stisku klávesy CTRL+HOME.
V budoucnu pak může kontrolovat předchozí zadané položky a při zadávání nových položek zobrazovat návrhy.
Seznam návrhů se vytváří tímto způsobem zvlášť pro každého uživatele BM.
2/ nastavení SQL dotazem
Seznam návrhů je naplněn na základě SQL dotazu
Např. formulář Adresář může mít pro pole obchodního selektoru na výběrové záložce nastaven parametr SQL/Výčet/Skript:
SELECT SP10IDZAK FROM %%%.SPSEOB ORDER BY SP10IDZAK
3/ nastavení Výčtem
Seznam návrhů je naplněn na základě textu uvedeného ve výčtu
Např. formulář Procesy může mít pro pole roku identifikace procesu na výběrové záložce nastaven parametr SQL/Výčet/Skript:
2001
2002
2003
2004
4/ nastavení Skriptem
Seznam návrhů je naplněn na vyvoláním kódu v jazyce Foxpro
Např. formulář Procesy může mít pro pole roku identifikace procesu na výběrové záložce nastaven parametr SQL/Výčet/Skript:
LOCAL _i,_rt
_rt=''
FOR _i=2000 TO YEAR(DATE())
    _rt=_rt+TRANS(_i)+CHR(13)
ENDFOR
RETURN _rt

Při aktivaci funkce klávesou CTRL+HOME je pro dané pole automaticky vytvořen záznam pro daného uživatele s nastavením Naplnění seznamu návrhů=Vstupem.

Seznam návrhů pro vytvářený SQL dotazem nebo Výčtem může být tvořen jedním nebo dvěma sloupci.
Např. formulář Adresář může mít pro pole obchodního selektoru na výběrové záložce nastaven parametr SQL/Výčet/Skript:
SELECT SP10TEXT,SP10IDZAK FROM %%%.SPSEOB ORDER BY SP10TEXT
Např. formulář Procesy může mít pro pole roku identifikace procesu na výběrové záložce nastaven parametr SQL/Výčet/Skript:
Rok 01|2001
Rok 02|2002
Rok 03|2003
Rok 04|2004
V tom případě jsou v seznamu návrhů zobrazovány texty obsažené v prvním sloupci a položky seznamu návrhů vybírány a vraceny podle druhého sloupce.

Výraz prefixu se obvykle používá ve spojení s nastavením Naplnění seznamu návrhů=SQL dotazem.
Výraz prefixu je vyhodnocován v okamžiku vytváření seznamu návrhů objektem daného pole formuláře,
jeho hodnota filtruje položky vložené do seznamu návrhů.
Typicky se tato možnost používá při implementaci funkce automatického dokončování pro pole formulářů, ve kterých se vstupuje artikl.
Např. obchodovatelný artikl:
Parametr SQL dotaz
SELECT SP62ARTIKL,OBARTIKL.SP61ID+OBARTIKL.SP60ID FROM %%%.OBARTIKL,%%%.SPARTIKN
WHERE SPARTIKN.SP61ID=OBARTIKL.SP61ID AND SPARTIKN.SP60ID=OBARTIKL.SP60ID AND
SPARTIKN.SP38ID=?TOOL.JAZYK AND SP00AKTUAL=1 ORDER BY SP62ARTIKL
Parametr Výraz prefixu
THIS.PARENT.SP61ID.VALUE
Podle SQL dotazu je ve druhý sloupec seznamu návrhů naplněn výrazem OBARTIKL.SP61ID+OBARTIKL.SP60ID.
Při vytváření seznamu návrhů je polem, ve kterém je vstupována identifikace artiklu, vyhodnocen výraz THIS.PARENT.SP61ID.VALUE
a tím je zjištěna hodnota identifikace druhu artiklu vstoupená uživatelem na stejné stránce fomuláře.
Do seznamu návrhů jsou potom naplněny artikly daného druhu.

SQL dotaz je obvykle vyhodnocován pouze jednou, při prvním vytváření seznamu návrhů daného pole formuláře.
V některých případech je vhodné omezit počet vrácených záznamů a SQL dotaz provádět při každé změně seznamu návrhů.
V tom případě se výraz SQL dotazu uvádí znakem '*' a hodnota prefixu je v tomto výrazu prezentována termem ?_P1.
Jedná se např. o implementaci funkce automatického dokončování pro pole formulářů, ve kterých se vstupuje spojení adresátů.
Parametr SQL dotaz
*SELECT AD11JMENO,AD01ID+AD11CISSPO FROM %%%.ADSPOJ WHERE AD01ID=?_P1 AND TRIM(AD11JMENO)<>'' ORDER BY AD11JMENO
Parametr Výraz prefixu
THIS.PARENT.AD01ID.VALUE

-------------------
pozn. PK

pokud ma select vracet artikly (nazev, sp60id) dle druhu artiklu na formulari

musi byt v selectu (nazev, sp61id+sp60id) a prefix THIS.PARENT.sp61id.VALUE
--------------------

Při definování obsahu parametru SQL/Výčet je možné používat makra
Příklady maker:
----------------------------------------------------------------
ID=SYS001
Název=SQL_spseob_XXX
select sp10text,left(sp10idzak,3) from %%%.spseob where sp10idzak like '___000000' and current date between isnull(sp10datum,current date) and isnull(sp10datumd,current date) order by sp10text
----------------------------------------------------------------
ID=SYS002
Název=SQL_mtskl
select mt04text,mt04id from %%%.mtskl order by mt04text
----------------------------------------------------------------
ID=SYS003
Název=SQL_spseob
select sp10text,sp10idzak from %%%.spseob where current date between isnull(sp10datum,current date) and isnull(sp10datumd,current date) order by sp10text
----------------------------------------------------------------
ID=SYS004
Název=SQL_obumist
SELECT ob05text,ob05id FROM OBUMIST order by OBUMIST.ob05text
----------------------------------------------------------------
ID=SYS005
Název=SQL_spsetv
select sp20text,sp20idzak from %%%.spsetv where current date between isnull(sp20datum,current date) and isnull(sp20datumd,current date) order by sp20text
----------------------------------------------------------------
ID=SYS006
Název=SQL_spseor
select sp11text,sp11idzak from %%%.spseor where current date between isnull(sp11datum,current date) and isnull(sp11datumd,current date) order by sp11text
----------------------------------------------------------------
ID=SYS007
Název=SQL_adkat
select ad08kateg,ad08id from %%%.adkat order by ad08kateg
----------------------------------------------------------------
ID=SYS008
Název=SEZ_sp33cisdr
2001
2002
2003
2004
2005
2006
----------------------------------------------------------------
ID=SYS009
Název=SQL_bwuzivat
select bw01jmeno,bw01uziv from %%%.bwuzivat where bw01aktiv=1 order by bw01jmeno
----------------------------------------------------------------
ID=SYS010
Název=SQL_spseob_adadsat
select distinct sp10text,spseob.sp10idzak from
%%%.spseob,%%%.adadsat
where
adadsat.sp10idzak=spseob.sp10idzak and
current date between isnull(sp10datum,current date) and isnull(sp10datumd,current date)
order by sp10text
----------------------------------------------------------------

Pokud je funkce automatického dokončování nastavena pro pole vyhledávací záložky formuláře a výběrem položky ze seznamu návrhů je vrácen text delší než je jeho kapacita, potom je pole automaticky přepnuto do stavu rozšířeného vyhledávání (viz. Různé změny v BM dne 05.05.2004).

Pozn.:
Tato funkčnost BM byla pojmenována 'Funkce automatického dokončování' podle českého překladu obdobného chování Internet Exploreru z anglického pojmu 'Automatic completion functionality', který překládá slovo 'completion' jako 'dokončování'.
Podle slovníku slovo 'completion' znamená také 'vyplnění'.
Ing. Petr Filip 28.08.06

Viz.také

Výběr zajímavých novinek


Hlavní menu programu

Hlavní menu programu
program umožňuje zapamatování pozice okna hlavního menu individuálně pro každého uživatele systému.
Provádí se z menu Volby okna hlavního menu programu volbou 'Umístění okna menu programu', po jejímž zvolení se zobrazí vstup, ve kterém je možné vybrat:
- Uchovat pro příští spuštění programu - okno se zobrazí při příštím spuštění programu aktuálním uživatelem ve stejné pozici a rozměry
- Obnovit výchozí pro příští spuštění programu - okno se zobrazí při příštím spuštění programu aktuálním uživatelem v pozici a rozměry, které jsou určeny programem BM
Ing. Petr Filip 06.02.06

Viz.také

Výběr zajímavých novinek


Informační panely

Informační panely
Ve formuláři 'Prezentace stránek panelů' je možné přizpůsobit vzhled hlavičky a patičky stránky informačního panelu.

Toto se nastavení se provádí uvedením kódu v jazyce Foxpro v atributech 'Kód hlavičky' a 'Kód patičky'.
Oba tyto kódy musí vrátit textovou hodnotu.
Text vrácený kódem hlavičky je ve výsledném obsahu HTML souboru uložen za koncový tag HEAD.
Text vrácený kódem patičky je vložen na konec HTML souboru a musí obsahovat koncový tag BODY.

------------------------------------------
Výraz třídění sloupce (Výraz třídění na záložce Sloupce definice uzlu informačního panelu) může být uveden znakem '*'.
Tímto způsobem se definuje střídavé vzestupné a sestupné třídění při opakovaném stisku hypertextu návěští sloupce.
------------------------------------------
Ve formátu sloupce (Formát na záložce Sloupce definice uzlu informačního panelu) je možné uvádět formáty času:
- @*TM - převádí numerickou hodnotu, která odpovídá počtu vteřin do tvaru MMM:SS
- @*TH - převádí numerickou hodnotu, která odpovídá počtu vteřin do tvaru HHH:MM
Oba tyto formáty je možné také uvádět ve tvaru @Z*TM resp. @Z*TH, kterými je do výstupu vkládán prázdný text v případě, že je formátovaný počet vteřin nulový.

Pozn.:
Uvedené formáty nejsou součástí jazyka Visual Foxpro.

Ing. Petr Filip 13.09.07

Viz.také

Výběr zajímavých novinek


Informační panely - třídění sloupců

Informační panely - třídění sloupců
Pro stránky typu prvek stránky - tabulka je možné na záložce Sloupce ve vlastnosti Výraz třídění uvádět výraz v syntaxi Visual Foxpro.
Pro takto definovaný sloupec je ve výsledné HTML stránce návěští sloupce uvedeno návěští ve tvaru hypertextového odkazu.
Po stisku tohoto hypertextového odkazu je stránka přezobrazena setřízená podle hodnot získaných na základě výrazu třídění sloupce.

Pozn.:
Výraz třídění by měl reflektovat možnost výskytu hodnoty NULL v obsažených atributech (obvykle datumové atributy).
Např. NVL(sp34datuko,DTOT({})).
Ing. Petr Filip 14.05.07

Viz.také

Výběr zajímavých novinek


Kategorie dokumentů - Spojené dokumenty

Kategorie dokumentů - Spojené dokumenty
Každý dokument BM je možné zařadit do různých kategorií.
Zařazení do kategorie se provádí na záložce 'Kategorie dokumentů' formuláře 'Dokumenty' nebo ve formuláři 'Vlastnosti dokumentu' na záložce 'Kategorie'.

Kategorie se definují ve formuláři 'Kategorie dokumentů', kde se uvádí:
Identifikace kategorie
Název kategorie
Složka - překryvný seznam - Ano/Ne - Ano = dokument zařazený do této kategorie bude ve formuláři 'Spojené dokumenty' ve složce odpovídající názvu kategorie
Rozbalená - překryvný seznam - Ano/Ne - při nastavení Složka=Ano -> Ano = složka ve formuláři 'Spojené dokumenty' bude rozbalená
Předchůdce - identifikátor kategorie - při nastavení Složka=Ano -> určuje nadsložku dané složky ve stromu ve formuláři 'Spojené dokumenty'
Poznámka

-------------------------------------------
Spojené dokumenty
Ve stromu se pro dokumenty uplatňují jejich zařazení do kategorií, které mají ve své definici nastavení Složka=Ano. Je-li dokument zařazen do takové kategorie, potom se ve stromu vytvoří adresářová struktura vyplývající ze vztahu kategorií (viz. atribut Předchůdce).
Při založení nového dokumentu po pravém kliku na položku stromu, která odpovídá kategorii dokumentu, je ve formuláři 'Vlastnosti dokumentu' na záložce 'Kategorie' předplněno zařazení do odpovídající kategorie.
Při kopírování dokumentu se zařazení do kategorie nedědí.

Ve stromu se kromě dokumentů, které jsou přímo spojeny s objektem BM, zobrazují jako jejich poduzly také dokumenty, které jsou objektovou vazbou spojeny s dokumentem (následníci).
Z podmenu NAVAZUJÍCÍ DOKUMENTY obsaženého v menu vyvolaném po pravém kliku na dokumentu je možné připojovat jeho nové následníky.
Příklad: K dokumentu charakteru smlouva je vhodné připojit dokumenty s jejími dodatky.

---------------------------------------------
V terminologii dokumentů byl změněn pojem 'Revize' a 'Verze'.
Ing. Petr Filip 13.07.07

Viz.také

Výběr zajímavých novinek


Klávesa CTRL+Q na výběrové záložce

Klávesa CTRL+Q na výběrové záložce
Formuláře si pamatují hodnoty dvaceti naposledy zadaných výběrů (na výběrové záložce) po spuštění programu.

Klávesou CTRL+Q je možné na výběrové záložce formuláře listovat mezi těmito zapamatovanými výběry.
Ing. Petr Filip 05.06.07

Viz.také

Výběr zajímavých novinek


Kontrola VS v události komponenty platby

Kontrola VS v události komponenty platby
Nový parametr operace komponenty platby umožňuje nastavit chování BM při zápisu události (závazku) operace daného druhu z hlediska kontroly duplicity variabilního symbolu.
Jedná se o parametr 'Validace variabilního symbolu', ve kterém je možné vybrat nastavení:
- Podle parametrů plateb - kontrola se bude provádět podle nastavení ekvivalentního parametru plateb
- Ne - viz. chování popsané pro odpovídající parametr plateb
- Ano - viz. chování popsané pro odpovídající parametr plateb
- Ano stejného adresáta - viz. chování popsané pro odpovídající parametr plateb

Ing. Petr Filip 26.07.06

Viz.také

Výběr zajímavých novinek


Mzdy - palety a kategorie

Mzdy - palety a kategorie
v IS BM bylo v komponentě Mzdy zaveden soubor nových činností Kategorie a palety barev pracovníků.

Kategorie pracovníků
-------------------------------
Formulář slouží k definování kategorií pracovníků.
Zadává se :

- identifikace kategorie
- název kategorie

Ke každé kategorii je možné definovat činnost Definování typu kategorie pracovníků (pomocí menu Volby).

Definování typu kategorie pracovníků
-----------------------------------------------------
Činnost slouží k definování vlastností a významu kategorie.

Zadává se :
- typ (vstupovaná, vypočítaná)
- výraz v SQL (pro typ vypočítaná)
- poznámka
- identifikace pracovníka (používá se k testování)

Definování typu vypočítaná by měl provádět vždy pouze pověřený pracovník (např. implementátor). k této činnosti je nutné nastavit přístupová práva.

Stanovení příslušnosti pracovníka v kategorii
----------------------------------------------------------
a/ kategorie typu Vstupovaná

Pracovník je v kategorii, pokud informace v činnosti Pracovníci v kategoriích, má záznam uvedenu platnost od - do v intervalu, do kterého spadá dotazované datum.

b/ kategorie typu Vypočítaná

Pracovník je v kategorii, pokud vyhodnocení výrazu SQL vrátí hodnotu větší než 0
Tento výraz v syntaxi SQL Anywhere je vyhodnocován při zpracování SQL dotazu. Používají se v něm proměnné @mz01id (osobní číslo pracovníka) a @datum. Vyhodnocením výrazu musí být numerická hodnota.
Protože je výraz vyhodnocován uloženou procedurou až při zpracování SQL dotazu a není kompilován na straně klienta tak, jak je to v případě obecných výběrů, může chybně definovaný SQL výraz způsobovat to, že dotaz bude vracet žádný nebo menší počet záznamů než by měl bez nahlášení chyby. Proto je v IS BM zabudován nástroj na testování těchto výrazů.

Např.:
1/ Pracovník má vedlejší pracovní poměr
(select count() from %%%.mzpracpo where mz01id=@mz01id and @datum between isnull(mz32vznipp,@datum) and isnull(mz32skonpp,@datum) and mz32druh=2)

2/ Pracovník má dohodu o pracovní činnosti
(select count() from %%%.mzpracpo where mz01id=@mz01id and @datum between isnull(mz32vznipp,@datum) and isnull(mz32skonpp,@datum) and mz32druh=5)

Pozn.:
V příkladech 1/ a 2/ se používá funkce COUNT, protože vyhodnocením výrazu bude hodnota 0 nebo 1

Palety barev kategorií pracovníků
--------------------------------------------------------
Formulář slouží k definování palet barev kategorií pracovníků.
Pro každou paletu se definují v ní obsažené kategorie.
Na výběrové záložce formuláře Karta pracovníka potom vybírá uživatel paletu barev a podle vybrané palety jsou pracovníci v mřížce vybarvovány barvou kategorií, které má paleta u sebe uvedeny.

Zadává se:
Na záložce Palety barev kategorií pracovníků
- identifikace palety
- název palety
- skupina
- poznámka
Na záložce Kategorie v paletě
- identifikace kategorie
- priorita - určuje prioritu určení barvy v paletě barev v případě, kdy pracovník odpovídá většímu počtu kategorií v paletě
- barva písma
- barva pozadí
Palety barev je možné exportovat do balíčku.

Příklad:
Vytvořením palety "Pracovní poměry" s uvedenými kategoriemi:
"Hlavní pracovní poměr"
"Vedlejší pracovní poměr"
"Souběžný pracovní poměr"
"Dohoda o provedení práce"
"Dohoda o pracovní činnosti"
"Ostatní"
dovolí uživateli zobrazovat v mřížkách formuláře Karta pracovníka pracovníky rozlišené barevně podle druhu pracovního poměru.

Formulář Karta pracovníka
--------------------------------------
Na výběrové záložce formuláře Karta pracovníka se uvádí:
1/ vztah ke kategorii
- vztah ke kategorii - překryvný seznam - Je / Není - kde Je=K dnešnímu datu je v kategorii, Není=K dnešnímu datu není v kategorii
- identifikátor kategorie
- název kategorie
- k datu (není-li datum uveden, bere se v úvahu dnešní datum)
2/ vybarvení mřížky
- v překryvném seznamu se vybírá paleta barev kategorií
3/ výběr pracovníků, které přísluší do aspoň jedné z kategorií uvedené v paletě ad 2/
- způsobí označené zaškrtávací políčko Paleta

Ing. Olga Smitková 27.07.05

Viz.také

Výběr zajímavých novinek


Nastavení sledování změn tabulek

Nastavení sledování změn tabulek
BM umožňuje také sledování změn záznamů na volných kartách
Ve formuláři 'Nastavení sledování změn tabulek' je možné kromě tabulky z datového modelu BM také uvádět název s ní spojené volné karty.
Triggery pro sledování změn záznamů volných karet nejsou automaticky přegenerovávány při změně struktury volné karty a jejím přegenorování činností 'Generování tabulky' ve formuláři pro definování volné karty.
Z formuláře definování volné karty je možné generovat triggery přímo volbou 'Generovat triggery tabulky' nebo je možné z menu Volby tohoto formuláře vyvolat formuláře 'Nastavení sledování změn tabulek' a 'Uživatelské triggery'.

Z formuláře volné karty je možné z menu Obecné vyvolat volbou 'Přehled změn záznamu' formulář 'Přehled změn záznamů tabulek'.

V záznamu ve formuláři 'Přehled změn záznamů tabulek' se vyskytuje atribut název volné karty a je možné tento atribut uvádět také na výběrové záložce.

Ing. Petr Filip 29.10.07

Viz.také

Výběr zajímavých novinek


Návrat hodnoty a volná karta

Návrat hodnoty a volná karta
Nastavení Preferences->Prep_CTRLF1=0

Nastavuje programové řešení přepínání mezi okny formulářů BM po návratu hodnoty z formuláře vyvolaného klávesou F2.
Nastavení Prep_CTRLF1=1 přepíná na okno přijímající hodnotu emulací stisku kláves CTRL+F1.
Nastavení Prep_CTRLF1=0 přepíná na okno přijímající hodnotu voláním jeho metody SHOW.

Toto nastavení bylo umožněno pro řešení situace, kdy má formulář odesílající hodnotu nastavenu vlastnost 'Ponechat formulář po návratu hodnoty' a přitom je v okamžiku odeslání otevřena volná karta tohoto formuláře.
Programové řešení emulací stisku kláves CTRL+F1 v tomto případě přepíná na okno volné karty.

Toto chování je nastavitelné, protože nebylo možné vzhledem k rozsahu variant uspokojivě otestovat.
Ing. Petr Filip 05.06.07

Viz.také

Výběr zajímavých novinek


Označování výrazem

Označování výrazem
funkci menu Volby -> OZNAČOVÁNÍ -> Označování výrazem je možné používat také ve formulářích spuštění operace komponenty.

Praktické použití této možnosti je např. pro uperaci komponenty smluv, kdy je možné označovat různé položky smlouvy v operaci podle různých hledisek a s takto označenými položkami provádět různé hromadné úkony (např. vložit do označených položek stejnou cenu pomocí doplňující vlastnosti formuláře).
Ing. Petr Filip 08.03.07

Viz.také

Výběr zajímavých novinek


Palety barev adresátů

Palety barev adresátů
umožňují zobrazovat adresáty v mřížce adresáře v různých barvách v závislosti na jejich zařazení do kategorií.

V souvislosti s tím byly rozšířeny vlastnosti kategorie adresáta o atributy:
- typ - překryvný seznam Vstupovaná/Vypočítaná
- SQL - memo - SQL výraz pro typ Vypočítaná

Tyto vlastnosti se nevstupují přímo ve formuláři 'Kategorie adresátů', ale volbou 'Definování typu kategorie adresáta' (F5) z tohoto formuláře.

Stanovení příslušnosti adresáta v kategorii
----------------------------------------------------------
a/ kategorie typu Vstupovaná
Adresát patří do kategorie, pokud má u sebe uveden záznam o zařazení do kategorie platný k aktuálnímu datu.
b/ kategorie typu Vypočítaná
Adresát patří do kategorie, pokud vyhodnocení výrazu SQL vrátí hodnotu větší než 0
Tento výraz v syntaxi SQL Anywhere je vyhodnocován při zpracování SQL dotazu. Používají se v něm proměnné @ad01id (adresát),@ad11cispo (spojení adresáta),@bw01uziv (aktuálně přihlášený uživatel systému), @datum (datum vyhodnocení - obvykle aktuání datum systému).
Vyhodnocením výrazu musí být numerická hodnota.
Protože je výraz vyhodnocován uloženou procedurou až při zpracování SQL dotazu a není kompilován na straně klienta tak, jak je to v případě obecných výběrů, může chybně definovaný SQL výraz způsobovat to, že dotaz bude vracet žádný nebo menší počet záznamů než by měl bez nahlášení chyby.
Proto je možné použít ve formuláři 'Definování typu kategorie adresáta' tlačítko 'Testovat', kterým se provede test SQL dotazu.

Příklady SQL dotazů:
1/ Adresát je naším oběratelem
(select count() from %%%.obudal where ad01id=@ad01id and ob02privyd=4)
2/ Adresát je naším dodavatelem
(select count() from %%%.obudal where ad01id=@ad01id and ob02privyd=3)
3/ Adresát je naším oběratelem v posledním roce
(select count() from %%%.obudal where ad01id=@ad01id and ob02privyd=4 and ob02dat between @datum-365 and @datum)
4/ Adresát je naším dlužníkem
if exists(select * from %%%.pluda where ad01id=@ad01id and pl02pohzav=1 and pl02uhraze=0) then 1 else 0 endif

Pozn.: v příkladech 1,2 a 3 byl použita funkce COUNT, lépe pro efektivní zpracování dotazu by bylo užít způsob IF EXISTS(SELECT * ....

Palety barev kategorií adresátů
--------------------------------------------------------
Formulář slouží k definování palet barev kategorií.
Pro každou paletu se definují v ní obsažené kategorie.
Na výběrové záložce formuláře 'Adresář' potom vybírá uživatel paletu barev a podle vybrané palety jsou adresáti v mříže vybarvovány barvou kategorií, které má paleta u sebe uvedeny.
Zadává se:
Na záložce Palety barev kategorií
- identifikace palety
- název palety
- poznámka
- skupina uživatelů - určuje uživatele palety
Na záložce Kategorie v paletě
- identifikace kategorie - je možné uvádět vstupované i vypočítané kategorie adresátů
- priorita - určuje prioritu určení barvy v paletě barev v případě adresát odpovídá většímu počtu kategorií v paletě
- barva písma
- barva pozadí
Palety barev bude možné exportovat do balíčku.

Příklad:
Vytvořením palety "Odběratelé a dodavatelé" s uvedenými kategoriemi:
"Adresát je naším oběratelem" - červené pozadí
"Adresát je naším dodavatelem" - modré pozadí

Formulář Adresář
------------------------
Změny výběrové záložky:
1/ výběr kategorie adresáta
- je možné zadávat kategorie vstupované i vypočítané
2/ vybarvení mřížky
- v překryvném seznamu se vybírá paleta barev kategorií
- v případě, že není vybrána žádná paleta - budou adresáti v mřížce barevně zobrazováni původním způsobem
3/ výběr artiklů, které přísluší do aspoň jedné z kategorií uvedené v paletě ad 2/
- způsobí označené zaškrtávací políčko Paleta
V menu Volby přibyla funkce 'Legenda palety barev', která zobrazí okno s přehledem barev aktuálně zvolené palety.

Programová podpora
-------------------------------

Uložená funkce 'ADADSAT je v kategorii'
-----------------------------------------------------------------
Vrací hodnotu 1 nebo 0 podle toho zda, adresát patří do požadované kategorie
Parametry:
ad08id - identifikace kategorie nebo %
ad08nazkat - název kategorie nebo %
ad01id - identifikace adresáta
ad11cisspo - spojení adresáta
bw01uziv - identifikace uživatele systému
datum - datum, ke kterému má být vyhodnocována příslušnost v kategorii

např.:
select * from %%%.adadsat where %%%."ADADSAT je v kategorii"('ODBERA','%',ADADSAT.ad01id,ADADSAT.ad11cisspo,?tool.uziv,current date)=1
Ing. Petr Filip 05.10.05

Viz.také

Výběr zajímavých novinek


Parametry uživatele

Parametry uživatele
Nastavením 'Parametrů uživatele' je mj. možné nastavit barevné zobrazení aktuální řádky v mřížkách formulářů.
Parametr 'Zvýraznění řádku v mřížce' (překryvný seznam) určuje způsob zobrazení s možnostmi:
- 'Ne' - aktuální řádek v mřížkách nebude barevně zvýrazňován
- 'Ano - varianta 1' - aktuální řádek v mřížkách bude barevně zvýrazňován - při vstupu do buňky mřížky bude buňka vybarvena B/W (černé písmo na bílém podkladu) - při pohybu v mřížce pomocí klávesnice bude obsah buňky označen pro funkčnost klávesy CTRL+C tj. buňka bude zčásti vybarvena W/B (bílé písmo na modrém podkladu)
- 'Ano - varianta 2' - aktuální řádek v mřížkách bude barevně zvýrazňován - při vstupu do buňky mřížky bude buňka vybarvena barvou zvýraznění - při pohybu v mřížce pomocí klávesnice bude obsah buňky označován pro funkčnost klávesy CTRL+C tj. buňka bude zčásti vybarvena W/B (bílé písmo na modrém podkladu)
- 'Ano - varianta 3' - aktuální řádek v mřížkách bude barevně zvýrazňován - při vstupu do buňky mřížky bude buňka vybarvena barvou zvýraznění - při pohybu v mřížce pomocí klávesnice nebude obsah buňky automaticky označován pro funkčnost klávesy CTRL+C

Parametry 'Barva písma zvýraznění' a 'Barva pozadí zvýraznění' určují barvy zvýraznění aktuálního řádku v mřížce.
V překryvných seznamech je možné vybírat barvy definované činností 'Barvy RGB' (klávesa F2).

Pozn.: Součástí 'Návodů a balíčků' je balíček, který obsahuje řadu barev.

Pozn.: Možnost nastavení barevného zobrazování aktuální řádky v mřížkách formulářů je funkční pouze ve verzích BM pod Visual Foxpro verze 8.0 nebo vyšší.
Ing. Petr Filip 05.10.06

Viz.také

Výběr zajímavých novinek


Platby

Platby
Pro druh operace plateb je nyní možné definovat parametr:
Povolit zařazení platby neuk.operace na příkaz k úhradě - Ano/Ne,
který dovolí zařadit platbu na příkaz k úhradě i když její operace není ukončena.

Ve formulářích Události plateb, Události změny stavu peněz, Příkaz k úhradě je možné po pravém kliku na návěští VS vyvolat formuláře Události plateb nebo Události změny stavu peněz s předplněným variabilním symbolem ve výběru.

Do formuláře Příkazy k úhradě byl doplněn adresát.
Ing. Petr Filip 29.03.05

Viz.také

Výběr zajímavých novinek


Pravidla inicializací přístupových práv

Pravidla inicializací přístupových práv
Při zakládání nového druhu se k němu automaticky přidělují práva přístupu uživatelů a skupin uživatelů.
To, komu a jaká práva k danému druhu budou přidělena, je možné ovlivnit nastavením 'Pravidel inicializací přístupových práv '.
Tato pravidla se definují činností INFORMAČNÍ CENTRUM - TYPY A ŘADY - Pravidla inicializací přístupových práv.
Ve formuláři 'Pravidla inicializací přístupových práv' se definuje:
- pravidlo - šestiznaková identifikace pravidla
- název pravidla
- typ pravidla - překryvný seznam - Každý uživatel zápis / Každý uživatel čtení / Každý uživatel žádná práva / Kopie práv
- priorita pravidla
- poznámka

Při zakládání nového druhu se nejprve vyhledává pravidlo, které:
1/ má stejnou identifikaci jako je identifikace nového druhu
2/ pokud není takové pravidlo nalezeno, vyhledává se první pravidlo s nejvyšší prioritou (priorita 1 je vyšší než priorita 2), jehož identifikace je 'jako' identifikace nového druhu , tj. vyhovuje podmínce logického výrazu Sybase SQL Anywhere - identifikace_nového_druhu LIKE identifikace_pravidla

Pokud není pro nový druh pravidlo inicializace přístupových práv nalezeno - bude přiděleno přístupové právo Zápis skupině uživatelů KAŽDÝ UŽIVATEL SYSTÉMU stejně jako všem aktivním uživatelům této skupiny.
Jinak budou přidělena práva podle typu pravidla:
- typ Každý uživatel zápis - bude přiděleno přístupové právo Zápis skupině uživatelů KAŽDÝ UŽIVATEL SYSTÉMU stejně jako všem aktivním uživatelům této skupiny
- typ Každý uživatel čtení - bude přiděleno přístupové právo Čtení skupině uživatelů KAŽDÝ UŽIVATEL SYSTÉMU stejně jako všem aktivním uživatelům této skupiny
- typ Každý uživatel žádná práva - nebudou přidělena práva přístupu žádné skupině uživatelů ani žádnému uživateli
- typ Kopie práv - budou přidělena stejná práva, jako jsou aktuálně nastavena pro dané pravidlo (tato práva se definují stejně jako práva k druhům - klávesa CTRL+B)

Při každé nové instalaci BM se automaticky vytvářejí pravidla:
- 'SYSTEM' - typ Každý uživatel čtení
- 'HIDDEN' - typ Každý uživatel žádná práva
- '-' - typ Každý uživatel zápis
Tato pravidla není vhodné rušit (další instalací BM se znovu vytvoří), ale je možné měnit jejich typ.
Změna typu pravidla '-' se nedoporučuje, protože se jedná o identifikaci nově doplňovaných druhů BM a může nastat situace, kdy po instalaci nové verze BM budou s nimi spojená data pro uživatele nedostupná.

Pozn.:
Při definování pravidla se záměrem uplatnění 'nový druh je jako pravidlo' je si třeba uvědomit, že se při jeho vyhodnocování uplatňují všechny znaky včetně mezer.
Např. pravidlo s identifikací '%' vyhoví všem identifikacím druhů, které mají první libovolný znak následovaný pěti mezerami.

Pozn.:
Pravidla s identifikací typu 'Každý uživatel žádná práva' mohou způsobovat, že po importu balíčků implementačních rozšíření, ve kterých mohou být obsaženy jejich druhy, může být implementátor uveden v omyl takový, že pro něho budou následně tato implementační rozšíření neviditelná.

Příklady pravidel:
- 'SYSTEM' - typ Každý uživatel čtení
- 'HIDDEN' - typ Každý uživatel žádná práva
- 'OBECNY' - typ Každý uživatel zápis
- 'OBECNE' - typ Každý uživatel zápis
- 'OBECNA' - typ Každý uživatel zápis
- 'VEREJ' - typ Každý uživatel zápis
- 'Z_____' - typ Každý uživatel zápis - priorita 10
- 'C_____' - typ Každý uživatel čtení - priorita 10
- '______' - typ Kopie práv - priorita 999

Ing. Petr Filip 10.03.06

Viz.také

Výběr zajímavých novinek


Problémy s nápovědou pod Windows 2003

Problémy s nápovědou pod Windows 2003
Po instalaci aktualizace zabezpečení 896358, aktualizace Microsoft Windows Server 2003 Service Pack (SP1) nebo aktualizace zabezpečení 840315 můžete zaznamenat následující příznaky:
Pokud jste nainstalovali aktualizaci zabezpečení 896358 nebo aktualizaci Windows Server 2003 SP1, můžete zaznamenat následující příznaky:
- Nelze použít funkce některých webových aplikací v počítači. Po klepnutí na odkaz se například nezobrazí téma.
- Pokud se pokusíte otevřít soubor CHM (Compiled Help Module) ve sdílené síťové složce pomocí cesty UNC (Universal Naming Convention), témata v souboru CHM se nezobrazí.
Pokud jste nainstalovali aktualizaci zabezpečení 840315, nefungují v počítači správně webové aplikace, které používají vnořené protokoly v protokolech InfoTech v adrese URL.

Popis odstranění problému je na adrese http://support.microsoft.com/kb/896054/cs
Ing. Petr Filip 24.07.06

Viz.také

Výběr zajímavých novinek


Předlohy dokumentů - přístupová práva

Předlohy dokumentů - přístupová práva
Pro předlohy dokumentů se definují přístupuvá práva pro čtení a zápis předlohy.

Tato práva se uplatňují ve formuláři 'Předlohy dokumentů' obvyklým způsobem.

Ve formuláři 'Dokumenty' se uplatňují tak, že:
1/ uživatel může založit nový dokument s předlohou výstupu, ke které má přístupové právo čtení nebo zápis
2/ přístup k existujícím dokumentům je řízen právy spojenými s druhem daného dokumentu (tj. uživatel může číst nebo opravovat dokumenty vytvořenými předlohami, ke kterým nemá právo přístupu čtení ani zápis)
Ing. Petr Filip 21.11.06

Viz.také

Výběr zajímavých novinek


Předlohy výstupu - výstup do Word

Předlohy výstupu - výstup do Word
Předlohou výstupu umožňují výstup do Word.
Tyto předlohy mají nastaven typ předlohy ve vlastnostech předlohy Typ=Word.
Při vytváření nové předlohy vybírá uživatel ze seznamu atributů podobně při vytváření nové předlohy typu Excel.
Oprava předlohy funguje podobně jako oprava předlohy typu Excel - je vyvolán podobný formulář.

Výstupní dokument Wordu je vytvářen podle template (vzoru), kterým je soubor formátu Word.
Při výstupu předlohou výstupu je nejprve založen výstupní soubor Wordu, který je kopií tohoto template.
Předpokládá, že v template jsou obsaženy záložky, které odpovídají názvům uvedeným v předloze spolu s výrazy v jazyce Foxpro.
Hodnoty zjištěné při výstupu předlohou vyhodnocením výrazů jsou vkládány do výstupu podle záložek z template.

Formulář pro definování předlohy má 4 záložky:
- Hlavička
- Skupiny
- Elementy
- E-mail

Na záložce Hlavička se definují vlastnosti týkající se výstupního souboru Wordu.
Jsou to vlastnosti:
Soubor - název výstupního souboru Wordu - výraz v jazyce Foxpro nebo skript v jazyce Foxpro uvedený slovem SCRIPT - nepovinný parametr - není-li uveden vytváří se dokument s náhodným jménem, který bude zrušen
Šablona - název souboru šablony (templale) pro vytvoření souboru Wordu - výraz v jazyce Foxpro nebo skript v jazyce Foxpro uvedený slovem SCRIPT - nepovinný parametr
Podmínka - podmínka v jazyce Foxpro, kterou jsou filtrovány záznamy SQL_TISK - nepovinný parametr
Vícesouborový tisk - zaškrtávací políčko - zašktnuté způsobí při tisku vytváření samostatných dokumentů Word pro každý záznam SQL_TISK
Heslo - heslo uzamčení výstupní souboru Wordu pro provádění změn - nepovinný parametr
Úvodní skript - skript v jazyce Foxpro provádění před zahájením výstupu - není-li skript vyplněn, potom je po pravém kliku ve vstupu tohoto atributu předplní vzor kódu pro zápis vytvořeného dokumentu jako dokumentu BM
Závěrečný skript - skript v jazyce Foxpro provádění po ukončení výstupu - není-li skript vyplněn, potom je po pravém kliku ve vstupu tohoto atributu předplní vzor kódu pro zastavení BM - čekání na uložení dokumentu
Digitální podpis - překryvný seznam - Nikdy,Ano,Ne - určuje jak bude předplněno okno možností zobrazované před zahájením výstupu předlohou
Příprava e-mail - překryvný seznam - Nikdy,Ano,Ne - určuje jak bude předplněno okno možností zobrazované před zahájením výstupu předlohou
Ukládat jako dokument BM - překryvný seznam - Nikdy,Ano,Ne - určuje jak bude předplněno okno možností zobrazované před zahájením výstupu předlohou (nastavení Ano resp. Ne má smysl pouze v případě, že vlastnost Úvodní skript obsahuje odpovídající kód)
Poznámka - poznámka předlohy z vlastností předlohy

Vlastnosti Digitální podpis, Příprava e-mail a Ukládat jako dokument BM se uplatňují v kombinaci s nastavením profilu spuštění předlohy uvedeného ve vlastnostech předlohy výstupu.
V profilu se nyní nově uvádí chování při vyvolání předlohy dvojklikem nebo ikonou také pro předlohy typu Word.
Pro tento typ předlohy se navíc uvádějí nastavení:
Digitální podpis - překryvný seznam - Volitelné,Volitelné Ano,Volitelné Ne,Nevolitelné,Nevolitelné Ano,Nevolitelné Ne
Příprava e-mail - překryvný seznam - Volitelné,Volitelné Ano,Volitelné Ne,Nevolitelné,Nevolitelné Ano,Nevolitelné Ne
Dokument BM - překryvný seznam - Volitelné,Volitelné Ano,Volitelné Ne,Nevolitelné,Nevolitelné Ano,Nevolitelné Ne
Podle kombinaci těchto nastavení a odpovídajících vlastností předlohy typu Word jsou předplněna odpovídající zaškrtávací políčka v okně možností výstupu vyvolaného při spuštění předlohy:
----------------------------------------------------------------------------------------
|Předloha |Profil |Okno možností výstupu |
|-------------------------------------------------------------------------------------- |
|Nikdy |Volitelné |Nepovoleno měnit - nezaškrtnuto |
|Nikdy |Volitelné Ano |Nepovoleno měnit - nezaškrtnuto |
|Nikdy |Volitelné Ne |Nepovoleno měnit - nezaškrtnuto |
|Nikdy |Nevolitelné |Nepovoleno měnit - nezaškrtnuto |
|Nikdy |Nevolitelné Ano |Nepovoleno měnit - nezaškrtnuto |
|Nikdy |Nevolitelné Ne |Nepovoleno měnit - nezaškrtnuto |
|Ano |Volitelné |Povoleno měnit - zaškrtnuto |
|Ano |Volitelné Ano |Povoleno měnit - zaškrtnuto |
|Ano |Volitelné Ne |Povoleno měnit - nezaškrtnuto |
|Ano |Nevolitelné |Nepovoleno měnit - zaškrtnuto |
|Ano |Nevolitelné Ano |Nepovoleno měnit - zaškrtnuto |
|Ano |Nevolitelné Ne |Nepovoleno měnit - nezaškrtnuto |
|Ne |Volitelné |Povoleno měnit - nezaškrtnuto |
|Ne |Volitelné Ano |Povoleno měnit - zaškrtnuto |
|Ne |Volitelné Ne |Povoleno měnit - nezaškrtnuto |
|Ne |Nevolitelné |Nepovoleno měnit - nezaškrtnuto |
|Ne |Nevolitelné Ano |Nepovoleno měnit - zaškrtnuto |
|Ne |Nevolitelné Ne |Nepovoleno měnit - nezaškrtnuto |
----------------------------------------------------------------------------------------

Pozn.:
Pokud má být dokument digitálně podepsán a uživatel ho digitálně nepodepíše, potom tento dokument nebude vytištěn ani odeslán e-mailem, bude uzavřen a zrušen

Pozn.:
Pokud je název šablony při výstupu předlohou text začínající znakem '*' (hvězdička), potom se předkládá, že je za hvězdičkou uveden klíč dokumentu BM, který má být použit jako šablona.
Přitom musí existovat dokument BM s daným klíčem, který musí mít nastavenu vlastnost 'Duplikát' (v této vlastnosti se uvádí název souboru na disku, kam má být ukládána kopie dokumentu).
Při výstupu předlohou program vyhledává dokument BM podle daného klíče a podle názvu souboru uvedeného v jeho vlastnosti 'Duplikát' vytváří kopii dokumentu BM do tohoto souboru v případě, že:
1/ tento soubor neexistuje
2/ datum založení souboru je menší než poslední záznam o změně dokumentu BM zaznamenané v jeho použití
Doporučuje se ve vlastnosti 'Duplikát' dokumentu BM uvádět jinou příponu souboru než DOC tak, aby se neumožnilo upravovat tento soubor na disku (např. TEMPLATE\FAKTURA.DOX).

Na záložce Skupiny se definují skupiny elementů vkládaných do výstupu.
Účelem rozdělení elementů do skupin je možnost vytváření tabulek ve Wordu vytvářených na základě nezávislých SQL dotazů nebo zvýšení přehlednosti definice předlohy výstupu.
Definují se vlastnosti:
Seznam - seznam - seznam skupin definujících výstup
Název - název skupiny - neuplaňuje se při výstupu
Tabulka - tabulka vytvářená skupinou - je-li uveden, potom je do výstupu vyplňována tabulka se sloupci vytvářenými na základě elementů skupiny - předpokládá se, že v template je odpovídající tabulka Word označená značkou s názvem stejným jako je uvedený název tabulky
Od řádky - je dostupný, pokud je vyplněn atribut 'Tabulka' - určuje řádek, od které má být tabulka ve Word vyplňována
Borders - zaškrtávací políčko - je dostupný, pokud je vyplněn atribut 'Tabulka' - zaškrtnutý určuje, že každý nový řádek tabulky má být ohraničen
Parametry - parametry pro SQL dotaz - seznam výrazů v jazyce Foxpro
SQL - SQL dotaz skupiny (odkazuje na parametry v syntaxi ?_p1..) nebo skript v jazyce Foxpro uvedený slovem SCRIPT (při použití parametrů musí obsahovat LPARAMETERS s odpovídajím počtem formálních parametrů) přitom se předpokládá, že skript vytvoří kurzor s aliasem DATA
Skript - Skript skupiny v jazyce Foxpro vyvolaný po naplnění skupiny podle definovaných elementů - může odkazovat objekty _wrd=řídící objekt Wordu, _this=řídící objekt skupiny
Podmínka - podmínka v jazyce Foxpro, kterou jsou filtrovány záznamy SQL_TISK nebo data SQL dotazu pro danou skupinu
Poznámka - poznámka skupiny

Na záložce Elementy se definují elementy aktuální skupiny záložky Skupiny.
Definují se vlastnosti:
Seznam - seznam - seznam elementů skupiny
ID - identifikace elementu - pro elementy netabulkové skupiny musí být uvedena odpovídá názvu záložky v template
Návěští - je dostupný, pokud je vyplněn atribut 'Tabulka' skupiny - návěští sloupce v tabulce - výraz v jazyce Foxpro
Výraz - výraz v jazyce Foxpro - jeho hodnota bude vložena do tabulky resp. do výstupního textu náhradou textu označeného v template záložkou s názvem odpovídajícím ID
Překlad - překryvný seznam - obsahuje seznam jazyků nastavených v IS - pro každý výstupní jazyk předlohy je možné definovat samostatné definice vlastností 'Návěští' a 'Výraz'
Cizojazyčné návěští - odpovídá atributu 'Návěští'
Cizojazyčný výraz - odpovídá atributu 'Výraz'
Formát - formátovací text vyhodnoceného výrazu - viz. funkce Foxpro TRANSFORM
Suma - zaškrtávací políčko - je dostupný, pokud je vyplněn atribut 'Tabulka' skupiny - příznak, že pro sloupec tabulky má být vytvořen sumární řádek
Poznámka - poznámka elementu

Atributy podmínky definované na záložkách 'Hlavicka' a 'Skupiny' umožnují komplexní výstup s vytvořením vetšího počtu tabulek v dokumentu bez využití SQL dotazu ve vlastnostech skupin (typické napr. pro tisk dokladu procesu).
Např. tisk faktury - podmínky při zaškrtnutém 'Vícesouborový tisk':
Hlavička - SQL_TISK.sppohzdr_sp06idsubs='PLA'
Skupina - Záhlaví - sppohzdr_sp33cisdr+sppohzdr_sp33cisdpm+sppohzdr_sp33cisd= _root_data.sppohzdr_sp33cisdr+_root_data.sppohzdr_sp33cisdpm+_root_data.sppohzdr_sp33cisd
Skupina - Dodavatel - sppohzdr_sp06idsubs='OBC' and sppohzdr_sp33cisdr+sppohzdr_sp33cisdpm+sppohzdr_sp33cisd= _root_data.sppohzdr_sp33cisdr+_root_data.sppohzdr_sp33cisdpm+_root_data.sppohzdr_sp33cisd
Skupina - Odberatel - sppohzdr_sp06idsubs='OBC' and sppohzdr_sp33cisdr+sppohzdr_sp33cisdpm+sppohzdr_sp33cisd= _root_data.sppohzdr_sp33cisdr+_root_data.sppohzdr_sp33cisdpm+_root_data.sppohzdr_sp33cisd
Skupina - Dodací list (tabulka OBC) - sppohzdr_sp06idsubs='OBC' and sppohzdr_sp33cisdr+sppohzdr_sp33cisdpm+sppohzdr_sp33cisd= _root_data.sppohzdr_sp33cisdr+_root_data.sppohzdr_sp33cisdpm+_root_data.sppohzdr_sp33cisd
Skupina - Daňové údaje (tabulka DPH) - sppohzdr_sp06idsubs='DPH' and sppohzdr_sp33cisdr+sppohzdr_sp33cisdpm+sppohzdr_sp33cisd= _root_data.sppohzdr_sp33cisdr+_root_data.sppohzdr_sp33cisdpm+_root_data.sppohzdr_sp33cisd
Skupina - O platbě - sppohzdr_sp06idsubs='PLA' and sppohzdr_sp33cisdr+sppohzdr_sp33cisdpm+sppohzdr_sp33cisd= _root_data.sppohzdr_sp33cisdr+_root_data.sppohzdr_sp33cisdpm+_root_data.sppohzdr_sp33cisd
Ve výrazech podmínek se vyskytuje alias _ROOT_DATA, nejedná se o alias kurzoru, ale o objekt, který při zpracování obsahuje atributy s názvy a hodnotami odpovídajícími záznamu vybranému filterm hlavičky (SQL_TISK.sppohzdr_sp06idsubs='PLA').

Výraz elementu netabulkové skupiny elementů může obsahovat volání příkazu CALCULATE jazyka Foxpro, přitom se bere v úvahu podmínka uvedená u skupiny.
Např.:
CALC SUM($(OBUDAL_dp02czazm))

Ve výrazech tisku je možné použít vlastnosti a metody řídícího objektu vytváření skupiny:
THIS.SP38ID - text - identifikace jazyka výstupu předlohy
THIS.VOLNY_TEXT - metoda s parametry _SP88ID,_DEFAULT - vyhledává volný text s idenitfikací _SP88ID v jazyce výstupu předlohy - není-li tento text definován vrací hodnotu _DEFAULT

Na záložce E-mail se definují parametry, které umožní odeslat vytvořený dokument e-mailem.
Definují se vlastnosti:
Příjemce - emailová adresa příjemce - výraz v jazyce Foxpro nebo skript v jazyce Foxpro uvedený slovem SCRIPT - nepovinný parametr
Předmět - předmět zprávy - výraz v jazyce Foxpro nebo skript v jazyce Foxpro uvedený slovem SCRIPT - povinný parametr, pokud má být odesílán e-mail
Název DOC - název, pod kterým bude dokument uveden v e-mailu jako příloha - výraz v jazyce Foxpro nebo skript v jazyce Foxpro uvedený slovem SCRIPT - nepovinný parametr
Další přílohy - seznam dalších příloh, které budou připojeny k e-mailu. Položky seznamu jsou odděleny středníkem ve tvaru [soubor na disku];[název přilohy] ... - výraz v jazyce Foxpro nebo skript v jazyce Foxpro uvedený slovem SCRIPT - nepovinný parametr
Text - text e-mailu - text nebo skript v jazyce Foxpro uvedený slovem SCRIPT - nepovinný parametr
Připravit e-mail z Wordu - E-mail bude připraven nebo odeslán z Wordu - zaškrtávací políčko
Důležitost - Malá/Velká - nastavení důležitosti e-mailu (pouze při odesláni z Wordu) - překryvný seznam Automaticky odeslat e-mail - e-mail bude odeslán bez možnosti úpravy uživatelem - zaškrtávací políčko Uzavřít dokument pro/po odeslání e-mailu - dokument bude před nebo po odeslání e-mailu uzavřen (pro/po podle toho, zda je dokument odesílán z Word nebo ne) - zaškrtávací políčko

Pozn.:
Pro e-mail z Wordu:
1/ obsah vytvářeného dokumentu bude textem zprávy e-mailu
2/ text získaný podle vlastnosti Text vložen do Úvodu e-mailu
3/ je-li zaškrtnuto 'Automaticky odeslat e-mail' a zároveň je zaškrtnuto 'Uzavřít dokument pro/po odeslání e-mailu', potom bude dokument po automatickém odeslání e-mailu uzavřen

Pozn.:
Pro e-mail neodesílaný z Wordu:
1/ obsah vytvářeného dokumentu bude přílohou e-mailu
2/ text získaný podle vlastnosti Text bude textem zprávy
3/ je-li zaškrtnuto 'Uzavřít dokument pro/po odeslání e-mailu', potom bude dokument uzavřen a okamžitě bude připraven e-mail k odeslání resp. e-mail odeslán podle 'Automaticky odeslat e-mail'
4/ není-li zaškrtnuto 'Uzavřít dokument pro/po odeslání e-mailu', potom bude e-mail odesílán až po uzavření vytvářeného souboru uživatelem

Pozn.:
Pokud je vyhodnocením atributu příjemce e-mailu text uvedený znakem '*', předpokládá se, že v textu následuje seznam identifikací adresátů oddělených středníkem

Pozn.:
Pokud je v textu e-mailu text (ne skript), potom se na tento text aplikuje funkce TEXTMERGE jazyka Foxpro. Např.:
Dobrý den,
<>
S pozdravem <>

Program BM nekomunikuje při výstupu předlohou výstupu typu Word s programem WORD přímo, ale prostřednictví knihovny vkládaného kódu SYSDOC.
Proto musí být pro funkčnost instalována tato knihovna s datem aktualizace, které není starší než 1.1.2007 (existence knihovny a datum aktualizace je programem kontrolována).
Oddělená komunikace umožňuje připojení jiného textového editoru než WORDu.

Knihovna SYSDOC musí obsahovat definici třídy BM_CODE_SYSDOC, která obsahuje metody volané programem BM:
CREATEFILE - parametry _soubor,_template - zakládá a otevírá nový dokumentu Word s názvem _soubor, kopií ze souboru s návem _template
DEFAULTBORDER_RESET - bez parametrů - nastavení vytváření tabulky s viditelným ohraničením
DEFAULTBORDER_NONE - bez parametrů - nastavení vytváření tabulky s neviditelným ohraničením
BOOKMARK_REPLACE_TABLE - parametry _zalozka,_radek,_hodnota1,_hodnota2,... - vloží do tabulky v záložce _založka řádek s pořadovým číslem _radek s hodnotami sloupců _hodnota1,_hodnota2,...
BOOKMARK_TABLE_LINE_BOTTOM - parametry _zalozka,_radek,_border - vytvoří nebo zruší ohraničení tabulky v záložce _založka pro řádek s pořadovým číslem _radek podle hodnoty _border (TRUE nebo FALSE)
BOOKMARK_REPLACE_TEXT - parametry _zalozka,_hodnota - nahradí text ve vytvářeném dokumentu označený záložkou _záložka textem _hodnota
PRINTPREVIEW - bez parametrů - vyvolá náhled aktuálně vytvářeného dokumentu
PRINTOUT - parametry _kopie,_tiskarna - vytiskne počet kopií aktuálně vytvářeného dokumentu na požadovanou tiskárnu
SAVE - bez parametrů - uložení aktuálně vytvářeného dokumentu Wordu
DOCCLOSE - bez parametrů - uzavře aktuálně vytvářený dokument

Pozn.:
V souvislosti s existencí typu předlohy Word je možné přednastavit nastavit chování výstupu zvlášť pro předlohy typu Word ve formuláři 'Profily spuštění výstupu'.

Pozn.:
Výstupy předlohami typu Word umožňují směrovat výstupy na různé tiskárny podle definic 'Logických tiskáren'.

Pozn.:
Funkčnost výstupu předlohami typu Word byla testována pro verzi Word 2003, předpokládaná bezproblémová funkčnost je verze 2000 nebo vyšší.
Ing. Petr Filip 05.01.07

Viz.také

Výběr zajímavých novinek


Přizpůsobení mřížek formulářů BM

Přizpůsobení mřížek formulářů BM
v nové verzi BM je možné přidávat do mřížek formulářů vlastní sloupce.

Vlastní sloupce do mřížky můžeme přidávat ze dvou důvodů:
1/ chceme přidat sloupec, který je ve struktuře kurzoru dotazu (např. jméno kontaktní osoby ve formuláři adresáře)
2/ chceme přidat sloupec, který není ve struktuře kurzoru dotazu (např. celková suma pohledávek adresáta ve formuláři adresáře) - pouze pro základní mřížku formuláře

Důvod ad.1/ je řešen pomocí doplňujících vlastností formuláře a důvod ad.2/ je řešen pomocí obecných výběrů.

Mezi atributy doplňující vlastnosti formuláře a obecného výběru přibyl atribut odkazující na tabulku "Doplnění mřížky formuláře", na kterém je klávesou F2 vyvolán formulář.

Ve formuláři "Doplnění mřížky formuláře" se definuje:
na první záložce -
název doplnění - text
poznámka
na druhé záložce popis jednotlivých sloupců doplnění -
alias - text - alias kurzoru, který mřížka zobrazuje - pro základní mřížku nemusí být uveden - pro ostatní je možné zjistit volbou "Statistika SQL"
návěští - text - bude zobrazen v záhlaví sloupce
stavový řádek - text - text zobrazovaný na stavovém řádku obrazovky při vstupu na položku sloupce
výraz - text - výraz v jazyce Foxpro - hodnota získaná jeho vyhodnocením bude zobrazována ve sloupci (ve výrazu je možné užít makro $$$, které je nahrazováno aliasem kurzoru mřížky)
formát - text - formátovací výraz pro hodnotu výrazu
pozice - číslo - určuje pozici sloupce v mřížce - není ovlivňována osobním nastavením mřížky uživatele, tj. sloupec je vždy zobrazen v dané pozici bez ohledu na tato nastavení
pořadí - číslo - určuje pořadí sloupce v rámci stejné pozice
šířka - číslo - šířka sloupce v pixelech

Pokud vyhodnocení výrazu sloupce není platná hodnota, není tento sloupec do mřížky zařazen (tj. neplatný výraz není považován za chybu).
Vyjímku tvoří výrazy uvedené znakem vlnovka - předpokládá se, že výrazu je uvedena funkce např. tool.sql_dotaz.

Řešení doplňující vlastností formuláře
-----------------------------------------------------
Dále byl doplněn nový typ vlastnosti - "Doplnění mřížky formuláře"
Pro doplňující vlastnosti tohoto typu je požadován vstup atributu "Doplnění mřížky formuláře"

Příklad - Jméno kontaktní osoby ve formuláři adresáře:
Odpovídající doplnění mřížky formuláře bude obsahovat definici sloupce
alias =
návěští = Osoba
stavový řádek = Jméno kontaktní osoby
výraz = $$$.ad11jmeno
formát =
pozice = 3
pořadí = 10
šířka = 80

Řešení obecným výběrem
------------------------------------
Dále byl doplněn nový atribut nazvaný Atributy, ve kterém se uvádí seznam atributů v syntaxi Sybase SQL Anywhere, který má být doplněn do výsledného dotazu obecného výběru.

Příklad - Celková suma pohledávek adresáta do mřížky ve formuláři adresáře:
V obecném výběru:
atributy = (select sum(pluda.pl02czrmnu) from %%%.pluda where pluda.ad01id=adadsat.ad01id and pluda.pl02pohzav=1 and pluda.pl02uhraze=0) as dluh
výraz = dluh>0
Odpovídající doplnění mřížky formuláře bude obsahovat definici sloupce
alias =
návěští = Dluh
stavový řádek = Dluh adresáta
výraz = $$$.dluh
formát = 999 999 999.99
pozice = 2
pořadí = 10
šířka = 80

Ing. Petr Filip 16.09.05

Viz.také

Výběr zajímavých novinek


Selektory v účetním deníku

Selektory v účetním deníku
nově je možné v účetním deníku obchodní a technicko-věcný selektor.

V účtové osnově přibyly atributy:
Sledoval obrat obchodního selektoru Ano/Ne,
Sledoval obrat organizačního selektoru Ano/Ne,
a Sledoval obrat tecnicko-věcného selektoru Ano/Ne,
které určují, zda se selektor uvedený na události účetnictví o daném účtu promítá do obratové tabulky.
Při změně těchto nastavení je třeba provádět přepočet obratové tabulky účetnictví.
Ing. Petr Filip 16.09.05

Viz.také

Výběr zajímavých novinek


Signalizace zpráv

Signalizace zpráv
v BM je možné u zpráv definovat datum a čas připomenutí zprávy jejímu příjemci.

Ve formuláři zprávy je možné zadat:
Připomenutí - překryvný seznam Ano/Ne
Čas - datum a čas připomenutí

Zpráva je připomínána jejímu příjemci v případě, že:
- má nastaveno Připomenutí=Ano
- nebyla dosud zpracována
- datum a čas připomenutí je menší než aktuální systémové datum a čas
- BM v daném okamžiku nemá aktivní modální okno

Připomenutí je provedeno spuštěním stránky informačního panelu v samostatném okně pro každou připomínanou zprávu v rámci hlavního okna programu.

Určení takto spuštěné stránky se provádí nastavením parametru BM (činnost SYSTÉM->Nastavení programu BM) Zpravy->pripomenuti_stranka, ve kterém se uvádí identifikace stránky informačního panelu.
Pro obecné užití je připravena stránka s identifikací SYPZ0134HR01, které bude k dispozici v Návodech a balíčcích.

BM skenuje požadavky připomenutí zpráv ve volitelném intervalu podle parametru BM Zpravy->pripomenuti_timeout (implicitně 5 minut).
V případě, že je v okamžiku skenování aktivní modální okno, odloží skenování podle parametru BM Zpravy->pripomenuti_timeout_odlozeni (implicitně 1 minuta).

Okamžik připomenutí zpráv:
- 15 vteřin po přihlášení k programu těch zpráv, jejichž datum a čas připomenutí je v tomto okamžiku menší než aktuální systémové datum a čas
- zprávy, které vznikly po spuštění programu na stejném počítači nebo jiném počítači zadané jiným uživatelem systému s maximálním zpožděním podle parametru Zpravy->pripomenuti_timeout
- je-li v okamžiku, kdy by mělo být zobrazeno okno s připomenutím aktivní modální okno, potom je připomenutí odloženo podle parametru Zpravy->pripomenuti_timeout_odlozeni
- jinak je připomenutí provedeno v určený čas

Pozn.:
V panelu SYPZ0134HR01 je užit odkaz na uzel SYPZ0134TW01, ve kterém je definována buňka P20-R10-S10. V této buňce nastavte odkaz na uzel, kterému ve Vaší implementaci odpovídá 'Přehled projektových úkolů'.

----------------------------------------------------------------
Změna formulářů pro vstup a zobrazení objektů ve vazbě:
- změna popisu tlačítka Následuje za Následují
- změna popisu tlačítka Předchází za Předcházejí

Ing. Petr Filip 10.05.06

Viz.také

Výběr zajímavých novinek


Sledování změn v záznamech tabulek BM

Sledování změn v záznamech tabulek BM
Do BM byly zahrnuty funkce, které umožňují sledování změn jednotlivých atributů záznamů tabulek IS.

Činností menu SYSTÉM -> Nastavení sledování změn tabulek - se určují tabulky, jejichž změny záznamů mají být sledovány.
Uvádí se:
Tabulka - identifikace tabulky IS BM
Založení - Ano/Ne - bude zaznamenávána informace o založení záznamu do tabulky
Oprava - Ano/Ne - bude zaznamenávána informace o změně záznamu tabulky
Rušení - Ano/Ne - bude zaznamenávána informace o zrušení záznamu tabulky
Aktivní - Ano/Ne - nastavení Ne je určeno pro pozastavení sledování změn (např. před hromadnou změnou dat pomocí ISQL)
Výraz popisu - výraz v syntaxi Sybase SQL Anywhere - před jednotlivými atributy je třeba uvádět prefix $$$., který je v generovaných triggerech nahrazován textem new_name resp. old_name
Poznámka - libovolný text

Po vložení definic je třeba vygenerovat triggery, které budou sledovat změny v určených tabulkách.
Provádí se z menu Volby formuláře činnostmi:
Generovat triggery tabulky - pro aktuální definici
Generovat triggery všech tabulek - pro všechny definice
Jejich funkčnost je totožná pro činnost Uživatelské triggery.
Při generování triggerů je třeba, aby v daném okamžiku nepracoval s dotčenými tabulkami jiný uživatel.

Příklady výrazu popisu:
Tabulka ADADSAT - $$$.ad01adsat
Tabulka ADADR - (select ad01adsat from %%%.ADADSAT where ad01id=$$$.ad01id)
Tabulka ADSPOJ - (select ad01adsat from %%%.ADADSAT where ad01id=$$$.ad01id)
Tabulka SPARTIKN (název artiklu) - $$$.sp62artikl
Tabulka OBARTIKL - (select sp62artikl from %%%.SPARTIKN where sp61id=$$$.sp61id and sp60id=$$$.sp60id and sp38id='CZE')
Tabulka MTARTIKL - (select sp62artikl from %%%.SPARTIKN where sp61id=$$$.sp61id and sp60id=$$$.sp60id and sp38id='CZE')

Činnost menu SYSTÉM -> Přehled změn záznamů tabulek - slouží k prohlížení změn
Záznam o změně obsahuje:
Tabulka - identifikace tabulky IS BM
Popis - předplněný podle výrazu popisu v definici - je ho možné upravovat
Změna - Založení/Oprava/Zrušení
Klíč - text odpovídající primárnímu klíči záznamu
Uživatel - jméno uživatele (pro změny provedené mimo IS BM uživatel SYSTÉM)
Datum a čas změny
Poznámka - libovolný text

Na záložce atributy jsou zaznamenány změny jednotlivých atributů.
Změna typu Založení nezaznamenává vstoupené atributy.
Změna typu Oprava zaznamenává původní a nové hodnoty změněných atributů.
Změna typu Zrušení zaznamenává původní hodnoty atributů zrušeného záznamu s výjimkou prázdných textových atributů (C resp.char) a poznámka (M resp. long varchar).

Pro vyhledávání měněných záznamů je k dispozici výběrová záložka.

Po spuštění formulářů, které pracují s tabulkou uvedenou v Nastavení sledování změn tabulek je možné pro aktuální záznam vyvolat formulář Přehled změn záznamů tabulek činností z menu Obecné -> Přehled změn záznamu. Přitom se automaticky odpovídajícím způsobem předplní výběrová záložka.

Při implementaci IS BM s použitím replikací je třeba řešit problém identifikace uživatele, který provedl změnu.
Změny dat prováděné triggery totiž nejsou replikovány, protože se předpokládá, že totožný trigger bude spuštěn na vzdáleném počitači při synchronizaci dat prováděné replikačním agentem.
Replikační agent však nemůže identifikovat uživatele IS BM, který provedl změnu.
Proto záznamy o změnách dat, které byly provedeny na vzdáleném datovém úložišti mají uvedeného uživatele SYSTÉM.
Pro následné doplnění uživatele, který skutečně provedl změnu je k dispozici uložená procedura:
'BWUPDRC prepis bw01uziv'
kterou je možné vyvolávat událostním triggerem v syntaxi:
CALL bm_servis."BWUPDRC prepis bw01uziv"().

Ing. Petr Filip 27.10.04

Viz.také

Výběr zajímavých novinek


Spojené dokumenty - Strom hlavního proc.

Spojené dokumenty - Strom hlavního proc.
BM umožňuje přenášet soubory tažením myší do okna spojených dokumentů s objektem BM (vyvolává se klávesou CTRL+D) např. z okna průzkumníka Windows (tažením myší není možné připojovat přílohy e-mailu).
Stejným způsobem je možné připojovat dokumenty k procesům nebo operacím ve formuláři Strom hlavního procesu a objektům, které mají zobrazený připojený dokument (obrázek) na volné kartě prostřednictvím atributu volné karty typu Multimediální.
Pokud je v okamžiku uvolnění tlačítka myši stisknuta na klávesnici klávesa SHIFT, potom je v následně zobrazeném formuláři vlastností dokumentu předplněno na záložce 'Uložení dokumentu' zaškrtnuté 'Externí uložení'.

Při založení dokumentu tažením myší je ukládána informace o názvu načteného dokumentu (ukládá se do tabulky SPDOKFIL).
Při opakovaném načtení dokumentu stejného názvu je zobrazen dotaz např.:
-----------------------------------------------------------------------------
Dokument "c:\adresar\faktura.doc"byl již do BM načten.
Načtení provedl(a) - Novák Josef naposledy dne 15.03.2006 15:21:35 .
Má být dokument opakovaně načten do BM (volba Ano) nebo má být připojen tento dříve načtený dokument (volba Ne) ?
-----------------------------------------------------------------------------
Po stisknutím tlačítka:
Ano - je založen nový dokument
Ne - není zakládán nový dokument a je pouze vytvořena objektová vazba mezi objektem BM a dokumentem BM, který byl dříve načten
Storno - neprovádí se žádná akce
Ing. Petr Filip 19.03.07

Viz.také

Výběr zajímavých novinek


Spojení adresátů

Spojení adresátů
Kromě zařazování adresátů do kategorií je také možné zařazovat do kategorií také jejich jednotlivá spojení.

Zařazování spojení adresátů do kategorií se provádí ve formulářích:
- adresář
- spojení adresátů
na záložce 'Kategorie spojení'.

Ve formuláři 'Kategorie adresátů' se zakládají kategorie jak pro adresáty, tak pro spojení adresátů.
Jsou rozlišeny atributem 'Uplatnění' (překryvný seznam - Kategorie adresáta/Kategorie spojení adresáta).
V tomto formuláři byla nově zavedana výběrová záložka.

Kategorii je možné uvádět na výběrové záložce formuláře 'Adresář' , čímž mohou být vybráni mj. adresáti, pro které existuje spojení zařazené do odpovídající vstupované kategorie.
Vyhledávání kategorie ve formuláři 'Spojení adresátů', vybírá pouze spojení zařazená do kategorií s uplatněním 'Kategorie spojení adresáta'.

V kategoriích spojení adresátů je možné používat Vypočítané typy kategorií.
Př.: SQL vypočítané kategorie 'Dodací spojení' podle realizovaných dodacích listů
if exists(select * from %%%.obudal where ad01id=@ad01id and ad11cisspo=@ad11cisspo and sp07idtyp='dodlis') then 1 else 0 endif

Kategorii spojení adresáta je možné použít ve formuláři 'Druhy operací' na záložce 'Spojení', kde se definuje algoritmus předplňování spojení adresáta v událostech.

Pozn.: ve formuláři Adresář byly také změněny popisy záložek
Pozn.: byl změněn název formuláře z MARKETING -> ADRESÁŘ -> INFORMACE K ADRESÁTŮM -> Kategorie adresátů na MARKETING -> ADRESÁŘ -> INFORMACE K ADRESÁTŮM -> Zařazení adresátů

Programová podpora
-------------------------------

Uložená funkce 'ADSPOJ je v kategorii'
-----------------------------------------------------------------
Vrací hodnotu 1 nebo 0 podle toho, zda spojení adresáta patří do požadované kategorie
Parametry:
ad08id - identifikace kategorie nebo %
ad08nazkat - název kategorie nebo %
ad01id - identifikace adresáta
ad11cisspo - spojení adresáta
bw01uziv - identifikace uživatele systému
datum - datum, ke kterému má být vyhodnocována příslušnost v kategorii

např.:
select * from %%%.adspoj where %%%."ADSPOJ je v kategorii"('DODSPO','%',ADSPOJ.ad01id,ADSPOJ.ad11cisspo,?tool.uziv,current date)=1
Ing. Petr Filip 14.08.07

Viz.také

Výběr zajímavých novinek


Spojení adresátů v událostech komponent

Spojení adresátů v událostech komponent
BM obsahuje možnost předplňování rozdílného čísla spojení adresáta v událostech různých operací komponent.

Ve formuláři Druhy operací se na záložce Spojení definuje jakým způsobem má program určit číslo spojení adresáta při vstupu nové události daného druhu operace.
Zadává se:
1/ Spojení - překryvný seznam - 1.adresáta nebo 2.adresáta - určuje, kterého adresáta v události se daná definice týká (zadat hodnotu 2.adresáta má smysl pouze pro operace komponenty obchod, jejíž události obsahují dva adresáty)
2/ Subjekt - text - uvádí se identifikátor typu subjektu spojení adresáta - bude předpňováno spojení daného typu subjektu
3/ Použít impl. - překryvný seznam - Ano nebo Ne - určuje pravidlo, zda se má použít implicitní spojení adresáta v případě, že pro něj neexistuje spojení daného typu subjektu
4/ Proces - text - uvádí se identifikátor druhu procesu - umožňuje definovat různé způsoby předplnění spojení adresáta pro danou operaci použitou v různých druzích procesů
5/ Kód - text - kód v jazyce Foxpro vyvolávaný pro určení spojení adresáta - kódu jsou v okamžiku jeho vyvolání dostupné proměnné - _THIS (instance objektu formuláře, ve kterém je prováděn vstup), _AD01ID (identifikace adresáta, pro kterého má být předplněno spojení) a _SPF2CSSP (odpovídá zadávané vlastnosti ad.1/ - nabývá hodnot 1 nebo 2) - kód by měl vracet textovou hodnotu
6/ Poznámka - libovolný text

Postup zjištění předplňovaného čísla spojení adresáta:
1/ je vyhledána definice pro určení spojení pro daný druh operace v odpovídajícím druhu procesu - není-li taková definice nalezena, vyhledává se definice pro daný druh operace s uvedeným druhem procesu '-'
2/ není-li ani jedna taková definice nalezena, předplní se spojení uvedené jako implicitní pro daného adresáta
3/ je-li uveden Kód a v průběhu zpracování vrátí nepráznou textovou hodnotu, spojení adresáta bude předplněno touto hodnotou
4/ je-li uveden neprázný Subjekt (jeho identifikace není '-') - vyhledává se nejmenší spojení vstupovaného adresáta, které má u sebe uvedený typ subjektu spojení - je-li takové nalezeno, potom je spojení v události předplněno jeho identifikací
5/ v závislosti na nastavení Použít impl. se předplní spojení uvedené jako implicitní pro daného adresáta nebo nic

Pozn.:
Pokud se uplatní definice Subjekt='-' a Použít impl.=Ne, žádné číslo spojení adresáta se nepředplní, tj. uživatel je přinucen určit spojení adresáta.

Příklad kódu:
RETURN tool.sql_dotaz([select min(adspoj.ad11cisspo) from %%%.adspoj,adadsat where adspoj.ad01id=?_p1 and adadsat.ad01id=adspoj.ad01id and adspoj.ad02cisadr=adadsat.ad02cisads],_ad01id)
Předplní nejnižší číslo spojení, které obsahuje adresu uvedenou u adresáta na záložce 'Obchodní rejstřík' (nepřehlédněte část SQL dotazu adspoj.AD02CISADR=adadsat.AD02CISADS)

Pozn.:
Proto, aby bylo možné použít definice předplnění spojení adresáta v událostech vývěsky nevstupovaných procesně, bylo ve formuláři Vývěska zaměněno pořadí vstupu adresáta a tématu vývěsky.
Ing. Petr Filip 11.05.07

Viz.také

Výběr zajímavých novinek


Spojení adresátů v událostech komponent

Spojení adresátů v událostech komponent
BM obsahuje možnost předplňování rozdílného čísla spojení adresáta v událostech různých operací komponent.

Ve formuláři Druhy operací se na záložce Spojení definuje jakým způsobem má program určit číslo spojení adresáta při vstupu nové události daného druhu operace.
Zadává se:
1/ Spojení - překryvný seznam - 1.adresáta nebo 2.adresáta - určuje, kterého adresáta v události se daná definice týká (zadat hodnotu 2.adresáta má smysl pouze pro operace komponenty obchod, jejíž události obsahují dva adresáty)
2/ Subjekt - text - uvádí se identifikátor typu subjektu spojení adresáta - bude předpňováno spojení daného typu subjektu
3/ Kategorie - text - uvádí se kategorie spojení adresáta - bude předpňováno spojení, které je k datu události zařazeno do uvedené kategorie, je možné zadat také vypočítávanou kategorii
4/ Použít impl. - překryvný seznam - Ano nebo Ne - určuje pravidlo, zda se má použít implicitní spojení adresáta v případě, že pro něj neexistuje spojení daného typu subjektu
5/ Proces - text - uvádí se identifikátor druhu procesu - umožňuje definovat různé způsoby předplnění spojení adresáta pro danou operaci použitou v různých druzích procesů
6/ Kód - text - kód v jazyce Foxpro vyvolávaný pro určení spojení adresáta - kódu jsou v okamžiku jeho vyvolání dostupné proměnné - _THIS (instance objektu formuláře, ve kterém je prováděn vstup), _AD01ID (identifikace adresáta, pro kterého má být předplněno spojení) a _SPF2CSSP (odpovídá zadávané vlastnosti ad.1/ - nabývá hodnot 1 nebo 2) - kód by měl vracet textovou hodnotu
7/ Poznámka - libovolný text

Postup zjištění předplňovaného čísla spojení adresáta:
1/ je vyhledána definice pro určení spojení pro daný druh operace v odpovídajícím druhu procesu - není-li taková definice nalezena, vyhledává se definice pro daný druh operace s uvedeným druhem procesu '-'
2/ není-li ani jedna taková definice nalezena, předplní se spojení uvedené jako implicitní pro daného adresáta
3/ je-li uveden Kód a v průběhu zpracování vrátí nepráznou textovou hodnotu, spojení adresáta bude předplněno touto hodnotou
4/ je-li uveden neprázný Subjekt (jeho identifikace není '-') - vyhledává se nejmenší spojení vstupovaného adresáta, které má u sebe uvedený typ subjektu spojení - je-li takové nalezeno, potom je spojení v události předplněno jeho identifikací
5/ je-li uvedena kategorie spojení adresáta - vyhledává se nejmenší spojení vstupovaného adresáta, které je k datu události zařazeno do uvedené kategorie (je možné zadat také vypočítávanou kategorii) - je-li takové nalezeno, potom je spojení v události předplněno jeho identifikací
6/ v závislosti na nastavení Použít impl. se předplní spojení uvedené jako implicitní pro daného adresáta nebo nic

Pozn.:
Pokud se uplatní definice Subjekt='-' a Použít impl.=Ne, žádné číslo spojení adresáta se nepředplní, tj. uživatel je přinucen určit spojení adresáta.

Příklad kódu:
RETURN tool.sql_dotaz([select min(adspoj.ad11cisspo) from %%%.adspoj,adadsat where adspoj.ad01id=?_p1 and adadsat.ad01id=adspoj.ad01id and adspoj.ad02cisadr=adadsat.ad02cisads],_ad01id)
Předplní nejnižší číslo spojení, které obsahuje adresu uvedenou u adresáta na záložce 'Obchodní rejstřík' (nepřehlédněte část SQL dotazu adspoj.AD02CISADR=adadsat.AD02CISADS)

Pozn.:
Proto, aby bylo možné použít definice předplnění spojení adresáta v událostech vývěsky nevstupovaných procesně, bylo ve formuláři Vývěska zaměněno pořadí vstupu adresáta a tématu vývěsky.
Ing. Petr Filip 14.08.07

Viz.také

Výběr zajímavých novinek


Správa artiklu

Správa artiklu
v IS BM byla zavedena nová komponenta nazvaná 'Správa artiklu', která se vyskytuje v hlavním menu programu pod složkou INFORMAČNÍ CENTRUM -> SPRÁVA ARTIKLU.
V této složce jsou obsaženy činnosti:
Události správy artiklu
Druhy artiklu
Artikl
Kategorie událostí správy artiklu
Palety barev kategorií

Událost správy artiklu
---------------------------------------------
Slouží zejména k zařazování artiklů do kategorií.
Má vlastnosti, které jsou obvyklé u standarních událostí komponent BM:
- identifikátory operace procesu
- datum události
- popis události
- artikl
- adresát
- spojení adresáta
- poznámka
- selektory
- datum založení
- identifikace uživatele, který jí založil
- událost je objektem BM (tj. je k ní mj. připojovat dokumenty)
Specifickými atributy události jsou:
- kategorie
- datum platnosti příslušnosti do kategorie od
- datum platnosti příslušnosti do kategorie do

Události mohou vznikat v operacích procesů i mimo procesy (podobně jako vývěska).
Na události je možné vstoupit pouze kategorii typu Vstupovaná (viz.dále)

Druhy artiklu
--------------------------------
Pro druh artiklu je možné nově definovat barvy písma a barvy pozadí pro zobrazování v mřížkách vybraných formulářů (viz. dále).

Kategorie událostí správy artiklu
--------------------------------------------------------
Formulář slouží k definování kategorií událostí správy artiklu.
Zadává se:
Na záložce Kategorie
- identifikace kategorie
- název kategorie
- určuje platnost - překryvný seznam Ano/Ne
- typ - překryvný seznam Vstupovaná/Vypočítaná
- SQL - memo - SQL výraz pro typ Vypočítaná
- barva písma
- barva pozadí
- poznámka
Na záložce Palety barev
- identifikace palety
- priorita - určuje prioritu určení barvy v paletě barev v případě artikl odpovídá většímu počtu kategorií v paletě
- barva písma
- barva pozadí
Na záložce Určení platnosti, je-li 'určuje platnost=Ano' , se zaškrtávají tabulky artiklu jichž se platnost týká (např. pro případ na skladě je minimání potřebné množství artiklu pro reklamace, ale artiklem se již neprodává - tj. kategorie musí definovat platnost pouze obchodovatelného artiklu)
Ke kategorii je možné definovat přístupová práva.

Stanovení příslušnosti artiklu v kategorii
----------------------------------------------------------
a/ kategorie typu Vstupovaná
Artikl je v kategorii, pokud poslední událost s datem události do dnešního dne včetně, má uvedenu platnost od - do v intervalu, do kterého spadá dotazované datum (poslední je ta, která má nejvyšší datum události a v případě dvou událostí se stejným datumem nejvyšší datum a čas zápisu události).
Z uvedeného vyplývá:
- příslušnost artiklu v kategorii je možné plánovat do budoucnosti
- pokud, existuje více událostí se stejnou kategorií pro stejný artikl nenaplánované do budoucnosti, uplatňuje se pro stanovení příslušnosti artiklu do kategorie právě a pouze poslední událost z nich na časové ose určené datem události a datem a časem zápisu události
b/ kategorie typu Vypočítaná
Artikl je v kategorii, pokud vyhodnocení výrazu SQL vrátí hodnotu větší než 0
Tento výraz v syntaxi SQL Anywhere je vyhodnocován při zpracování SQL dotazu. Používají se v něm proměnné @sp61id (druh artiklu) a @sp60id (artikl). Vyhodnocením výrazu musí být numerická hodnota.
Protože je výraz vyhodnocován uloženou procedurou až při zpracování SQL dotazu a není kompilován na straně klienta tak, jak je to v případě obecných výběrů, může chybně definovaný SQL výraz způsobovat to, že dotaz bude vracet žádný nebo menší počet záznamů než by měl bez nahlášení chyby. Proto bude do BM doplněn nástroj na testování těchto výrazů.

Např.:
1/ Skladovaný artikl je aktuální
(select count() from %%%.mtartikl where sp61id=@sp61id and sp60id=@sp60id and sp00aktual=1)
2/ Množství artiklu na skladě je v intervalu 101 až 1000
if isnull((select sum(mt02hodnot) from %%%.mtah where sp61id=@sp61id and sp60id=@sp60id and sp67id='NAT'),0) between 101 and 1000 then 1 else 0 endif
3/ Artikl obchodu má u sebe uvedeno, že je skladovaný
(select count() from %%%.obartikl where sp61id=@sp61id and sp60id=@sp60id and ob01sklado=1)
4/ Artikl bez události v komponentě skladové evidence
if not exists(select * from %%%.mtuda ud,%%%.spprc where sp61id=@sp61id and sp60id=@sp60id and spprc.sp33cisdr=ud.sp33cisdr and spprc.sp33cisdpm=ud.sp33cisdpm and spprc.sp33cisd=ud.sp33cisd and spprc.sp33storno=1) then 1 else 0 endif
Pozn.:
V příkladech 1/ a 2/ se používá funkce COUNT, protože vyhodnocením výrazu bude hodnota 0 nebo 1 (sp61id a sp60id jsou atributy primárního klíče tabulek MTARTIKL i OBARTIKL)
V příkladě 4/ funkce s používá EXISTS, protože použití funkce COUNT by nebylo optimální
(sp61id a sp60id nejsou atributy primárního klíče tabulky MTUDA - dotaz by procházel větší počet událostí)

Určení platnosti artiklu
------------------------------
Platnost artiklu definují kategorie s nastaveným atributem 'určuje platnost=Ano'.
Za platný artikl je považován takový, který :
a/ kategorie typu Vstupovaná
- neexistuje pro něj žádná událost s kategorií určující platnost
- poslední událost o libovolné kategorii určující platnost nenaplánovaná do budoucnosti má uvedenou platnost od-do, do které spadá odpovídající datum.
b/ kategorie typu Vypočítaná
- vyhodnocení SQL výrazu definovaného pro kategorii vrátí hodnotu jinou než 0

Palety barev kategorií
--------------------------------------------------------
Formulář slouží k definování palet barev kategorií.
Pro každou paletu se definují v ní obsažené kategorie.
Na výběrových záložkách formulářů artiklů potom vybírá uživatel paletu barev a podle vybrané palety jsou artikly v mříže vybarvovány barvou kategorií, které má paleta u sebe uvedeny.
Zadává se:
Na záložce Palety barev kategorií
- identifikace palety
- název palety
- poznámka
Na záložce Kategorie v paletě
- identifikace kategorie
- priorita - určuje prioritu určení barvy v paletě barev v případě artikl odpovídá většímu počtu kategorií v paletě
- barva písma
- barva pozadí
Palety barev bude možné exportovat do balíčku.

Příklad:
Vytvořením palety "Množství artiklu na skladě" s uvedenými kategoriemi:
"Množství artiklu na skladě je 0"
"Množství artiklu na skladě je v intervalu 1 až 100"
"Množství artiklu na skladě je v intervalu 101 až 1000"
"Množství artiklu na skladě je větší 1000"
dovolí uživateli zobrazovat v mřížkách formulářů artiklů (a to nejen ve formuláři skladovaného artiklu) artikly rozlišené barevně podle množství.

Formuláře artiklů
-----------------------
Na výběrových záložkách formulářů artiklů se uvádí:
1/ platnost artiklu
- platnost - překryvný seznam - Platné i neplatné / Platné dnes / Neplatné dnes / Platné k datu / Neplatné k datu
- datum pro platnosti Platné k datu a Neplatné k datu
2/ vztah ke kategorii
- vztah ke kategorii - překryvný seznam - Je / Není / Byl / Nebyl - kde Je=K dnešnímu datu je v kategorii, Není=K dnešnímu datu není v kategorii, Byl=Není v kategorii, ale byl, Nebyl=Není a nikdy nebyl v kategorii (pro typ kategorií Vypočítaná jsou vyhodnocovány pouze vztahy Je a Není)
- identifikátor kategorie
- název kategorie
3/ vybarvení mřížky
- v překryvném seznamu se vybírá paleta barev kategorií
4/ výběr artiklů, které přísluší do aspoň jedné z kategorií uvedené v paletě ad 3/
- způsobí označené zaškrtávací políčko Paleta
Menu Volby formulářů artiklů bylo doplněno o vyvolání formuláře Události správy artiklu většinou klávesou F6 nebo bez určení klávesy (pokud byla již tato klávesa obsazena jinou funkcí)

Postup stanovení barvy artiklu v mřížce
---------------------------------------------------------
1/ neplatný artikl - barva uvedená u kategorie způsobující jeho neplatnost
2/ jinak - pokud platný artikl patří do kategorie, které je uvedena u vybrané palety a v této vazbě je uvedena barva - barva uvedená ve vazbě kategorie a palety (uplatní se první kategorie v paletě podle priority -1 je vyšší priorita než 2)
3/ jinak - pokud platný artikl patří do kategorie, které je uvedena u vybrané palety a v této vazbě není uvedena barva a přitom je uvedena barva u kategorie - barva kategorie
4/ jinak - pokud neplatí 1/ ani 2/ ani 3/ - barva druhu artiklu

Tento postup se provádí zvlášť pro barvu písma a zvlášť pro barvu pozadí, tím je umožněno např. 'vybravovat' artikly podle druhu artiklu barvu pozadí a barvu písma podle kategorií.

Upravené formuláře s artikly
----------------------------------------
Artikl obecné komponenty
Spravovaný majetek
Obchodovatelný artikl
Ceník artiklu
Odpisovaný majetek
Artikly skladu
Karty pohledávek
Aktuální hodnoty obchodu (částečně)
Aktuální hodnoty skladu (částečně)
Množství artiklu na skladech (částečně)
Obraty skladu (částečně)
Vozidla expedice
Obraty skladu - VČ (částečně)
Artikly skladu - VČ
Předmět projektu (částečně)
Artikl
Artikly výroby
Přehled referenčních artiklů
TP k datu rozpracované na KJ
Vztahy obchodovatelných artiklů k adresátům

Programová podpora
-------------------------------
BM obsahuje tyto programové prvky, které je možné použít v souvislosti se správou artiklu v obecných výběrech, triggerech a doplňujících vlastnostech formulářů:

Uložená funkce 'SPARTIKL platnost artiklu'
-----------------------------------------------------------------
Vrací hodnotu 1 nebo 0 podle toho, zda se jedná o platný nebo neplatný artikl
Parametry:
sp61id - druh artiklu
sp60id - artikl
datum - datum, ke kterému je zjišťována platnost
bw10nazev - název tabulky artiklu (např. pro OBCENIK je to SPARTIKL) viz. záložka 'Určení platnosti' formuláře 'Kategorie událostí správy artiklu'

např.:
select * from %%%.obudal where %%%."SPARTIKL platnost artiklu"(OBUDAL.sp61id,OBUDAL.sp60id,current date,'OBARTIKL')=1

Uložená funkce 'SPARTIKL vztah ke kategorii'
------------------------------------------------------------------------
Vrací hodnotu 1 nebo 0 podle toho zda, artikl patří do požadované kategorie
Parametry:
sp61id - druh artiklu
sp60id - artikl
sa05id - identifikace kategorie nebo %
sa05nazkat - název kategorie nebo %
datum - datum, ke kterému je zjišťována platnost
vztah - číslo - Je=1 / Není=2 / Byl=3 / Nebyl=4

např.:
select * from %%%.mtuda where %%%."SPARTIKL vztah ke kategorii"(MTUDA.sp61id,MTUDA.sp60id,'OVCE ','%',current date,1)=1

Uložená funkce 'SPARTIKL barva artiklu'
-----------------------------------------------------------------
Vrací hodnotu RGB písma nebo pozadí pro artikl, pokud existuje, jinak -1
Parametry:
sp61id - druh artiklu
sp60id - artikl
datum - datum, ke kterému je zjišťována barva
sa06vyzbar - číslo - písmo=1 / pozadí=2
bw10nazev - název tabulky artiklu (např. pro OBCENIK je to SPARTIKL) viz. záložka 'Určení platnosti' formuláře 'Kategorie událostí správy artiklu'

Uložená funkce 'SPARTIKL zarazeni do kategorie'
-------------------------------------------------------------------------
Zakládá událost správy artiklu. Vrací jednoznačnou časou identifikaci vytvořené události.
Parametry:
commit - číslo - 0 nebo 1 - 1=po vytvoření události je proveden příkaz COMMIT (v triggerech se musí uvádět 0)
sp61id - druh artiklu
sp60id - artikl
sa05id - identifikace kategorie
sa02dat - datum události - datum nebo null - je-li uvedeno null - vytvoří se událost s dnešním datem
sa02platod - datum platnosti od - datum nebo null
sa02platdo - datum platnosti do - datum nebo null

např.:
...
set @sa02=bm_servis."SPARTIKL zarazeni do kategorie"(0,new_name.sp61id,new_name.sp60id,'OVCE ',null,null,null)
...

Uživatelsky definovaná funkce Foxpro - SAZARART
--------------------------------------------------------------------------
Zakládá událost správy artiklu. Vrací jednoznačnou časou identifikaci vytvořené události.
sp61id - druh artiklu
sp60id - artikl
sa05id - identifikace kategorie
sa02dat - datum události - datum nebo neuvedeno - není-li uvedeno - vytvoří se událost s dnešním datem
sa02platod - datum platnosti od - datum nebo neuvedeno
sa02platdo - datum platnosti do - datum nebo neuvedeno
např.:
...
DO SAZARART WITH 'ZBO','RENDLIK','NADOBI'
...

Ing. Petr Filip 01.04.05

Viz.také

Výběr zajímavých novinek


Strom hlavního procesu

Strom hlavního procesu
Z menu aktivovaného po pravém kliku myší na uzlu hlavního procesu, který je objektem BM, je možné vybrat volbu 'NAVAZUJÍCÍ DOKUMENT' , pod kterou se skrývá menu pro připojení dokumentu k danému objektu (Nový dokument, Načíst dokument,Kopírovat odkaz ...).

Objekty BM, které se mohou vyskytovat ve stromu hlavního procesu jsou:
- procesy
- operace
- dokumenty
- zprávy
- události operací komponent

Pro uzly ve stromu hlavního procesu 'dokumenty' se uplatňuje totožná funkčnost jako ve formuláři 'Spojené dokumenty', tj. mj. stejné menu po pravém kliku klávesu myši, možnost připojovat navazující dokumenty, zobrazení zařazení dokumentu do kategorie jako složky stromu, ...

Při přenášením souboru tažením myší do stromu hlavního procesu je možné dokument připojit také k jinému objektu BM, než jsou objekty procesů resp. operací.
Ing. Petr Filip 19.07.07

Viz.také

Výběr zajímavých novinek


Strom hlavního procesu

Strom hlavního procesu
To, které druhy operací mají být zobrazeny ve stromu hlavního procesu je možné ovlivnit nastavením parametru druhu operace 'Zobrazovat ve stromu procesu'=Ano/Ne na záložce Další.

Typicky se toto nastavení používá pro druhy operací, které se vkládají do diagramu procesu pouze pro umožnění odblokování operace.
Ing. Petr Filip 29.09.06

Viz.také

Výběr zajímavých novinek


Transformace procesů

Transformace procesů
Nová vlastnost transformace procesů
'Aktivovat následující operaci podle filtru transformace' (zaškrtávací políčko) způsobuje, že:
následující operace je aktivována (převedena do stavu připravena) pouze v případě, že existuje událost ukončované operace vyhovující filtru transformace.

Toto nastavení má smysl v případě, že je nastavena vlastnost transformace 'Filtr transformace'.
Vzhledem k tomu, že pro vyhodnocení podmínky se používá v případě tohoto nastavení kurzor aktuálně ukončované operace, je třeba, aby v ní byly užity pouze atributy tohoto kurzoru (nesmí v ní být mj. použity atributy doplnění transformace).

Tato funkčnost byla doplněna v souvislosti s používáním plnění projektových úkolů v procesech, kdy různé druhy plnění úkolů mohou vyvolávat různá pokračování procesu.
Ing. Petr Filip 12.08.05

Viz.také

Výběr zajímavých novinek


Třídění dat v mřížkách formulářů

Třídění dat v mřížkách formulářů
je nyní možné také sestupně.
V případě, že uživatel při pravém kliku na hlavičku sloupce v mřížce podrží klávesu SHIFT, budou data v mřížce seřazena sestupně.
Ing. Petr Filip 22.11.04

Viz.také

Výběr zajímavých novinek


Třídění v mřížce po kliku na sloupec

Třídění v mřížce po kliku na sloupec
Nově definovaná událost formuláře (viz. Pojem - Zpracování skriptů) GRID_HEADER_CLIK umožňuje implementačně definovat třídění sloupce po kliku na návěští sloupce v mřížce formuláře (např. v mřížce je identifikace artiklu a datum - po kliku na sloupec artiklu se požaduje setřídění artikl+datum).
Událost GRID_HEADER_CLIK vzniká při kliku na návěští sloupce mřížky ve formuláři a vyvolává skript připojený k formuláři doplňující vlastností formuláře voláním metody ADDSCRIPT.
Ve skriptu je možné odkazovat se na proměnné:
_objscript.recordsource - alias cursoru mřížky
_objscript.attribute - název atributu zobrazeného ve sloupci (včetně aliasu), na který uživatel klikl
Kód skriptu by měl vrátit výraz v syntaxi jazyka Foxpro pro příkaz INDEX ON.

Příklad doplňující vlastnosti formuláře připojující skript pro událost GRID_HEADER_CLIK:
LOCAL _kod
TEXT TO _kod NOSHOW
IF _objscript.recordsource='VRUDOPER' AND TYPE(_objscript.attribute)='C'
    RETURN [UPPER(]+_objscript.attribute+[)+DTOS(NVL(vr02datum,{}))+LEFT(ad01adsat,50)]
ELSE
    RETURN _objscript.attribute
ENDIF
ENDTEXT
_this.makroprikaz("this.addscript(CREATEOBJECT([bwscript],[GRID_HEADER_CLIK],[GRID_HEADER_CLIK],[],_p1))",_kod)

Ing. Petr Filip 04.10.07

Viz.také

Výběr zajímavých novinek


Událost účetnictví - kontrola selektorů

Událost účetnictví - kontrola selektorů
Pro každý účet účtového rozvrhu je možné nastavit jeho vlastnosti:
- Povinnost uvádět obchodní selektor v událostech účetnictví pro účet Ano/Ne
- Povinnost uvádět organizační selektor v událostech účetnictví pro účet Ano/Ne
- Povinnost uvádět technicko-věcný selektor v událostech účetnictví pro účet Ano/Ne

Uplatní se při vytváření událostí účetnictví, kdy není možné zapsat událost s hodnotou selektoru neurčeno ('-'), pokud je pro daný typ selektoru účtu události stanovena povinnost uvádět selektor.
Ing. Petr Filip 18.12.06

Viz.také

Výběr zajímavých novinek


Událost účetnictví - rozúčtování

Událost účetnictví - rozúčtování
Klávesou F5 nebo funkcí menu 'Volby' -> 'Rozúčtování události účetnictví' je možné rozúčtovat události účetního
deníku neukončené operace na více událostí bez nutnosti přepisovat původní hodnotu v Kč - zdědit popis původní události, příp. selektory.
Přitom jsou nově vzniklé události spojeny stejnými záznamy míry plnění transformace na události jiných komponent jako událost, která byla rozúčtována.
Při rozúčtování události účetnictví, která obsahuje také částku v cizí měně, potom je také rozúčtována tato částka.
Ing. Petr Filip 18.12.06

Viz.také

Výběr zajímavých novinek


Úpravy adresáře

Úpravy adresáře
Byly provedeny tyto změny formuláře Adresát:

1/ při zápisu nově založeného adresáta je automaticky změněno jeho číslo na první volné číslo adresáta v číselné řadě adresátů v případě, že v čase mezi jeho založením klávesou F3 a zápisem založil jiný uživatel nového adresáta - v tomto případě ve starších verzích BM nebylo možné nového adresáta zapsat
2/ při zakládání nového bankovního spojení je předplňováno číslo bankovního spojení
3/ pro rodné číslo adresáta je možné parametricky nastavit jeho kontrolu na modulo 11 - kontrola se nastavuje v parametrech adresáře nastavením 'Kontrola rodného čísla MOD11'

Ing. Petr Filip 28.06.07

Viz.také

Výběr zajímavých novinek


Více měn jednoho bankovního účtu

Více měn jednoho bankovního účtu
V zahraničních bankách je obvyklé, že jsou na jednom účtu vedeny zůstatky více měn.

Proto byla doplněna funkčnost BM:
U bankovního účtu adresáta je možné definovat další měny na záložce 'Další měny' a na první záložce se stále uvádí jediná měna (základní měna účtu).
V události změny stavu peněz je nyní možné vstupovat do položky Měna účtu v případě, že bankovní účet je typu 'účet' a má definované 'Další měny' .

Předplňování měny účtu (MÚ) a částky měny účtu (ČMÚ) v události změny stavu peněz probíhá:
1/ v případě vstupu vlastního účtu typu 'pokladna' - (MÚ)=(měna částky v ZM), přitom vstup není povolen, (ČMÚ)=(částka v ZM) přitom vstup není povolen

2/ v případě vstupu vlastního účtu typu 'účet' bez definovaných dalších měn - (MÚ)=(základní měna bankovního účtu) přitom vstup není povolen, pokud je ref.měna nebo zah.měna shodná s (MÚ) (ČMÚ)=(odpovídající částka), přitom vstup není povolen, jinak (ČMÚ) vstupuje uživatel

3/ v případě vstupu vlastního účtu typu 'účet' s definovanými dalšími měnami - pokud některá 'další měna účtu' odpovídá měně částky v ZM (MÚ)=(měna částky v ZM), jinak (MÚ)=(základní měna účtu), přitom je vždy vstup povolen, pokud je ref.měna nebo zah.měna shodná s (MÚ) (ČMÚ)=(odpovídající částka), přitom není vstup povolen, jinak (ČMÚ) vstupuje uživatel

Vstup (MÚ) je možný pouze ve variantě ad. 3/ a přitom je možné vstupovat 'základní měnu účtu' nebo 'další měny účtu'.
Ing. Petr Filip 23.08.05

Viz.také

Výběr zajímavých novinek


Volné karty - dynamický combobox

Volné karty - dynamický combobox
Volná karta může být nastavena tak, že se mění obsah překryvného seznamu (pro atributy třídy překryvný seznam) při změně hodnoty jiného atributu volné karty.

Pro tuto možnost je třeba definovat:
1/ pro atribut třídy překryvný seznam v atributu pro seznam hodnot kód, který zajistí naplnění překryvného seznamu
2/ pro atribut, při jehož změně hodnoty má být provedena změna obsahu překryvného seznamu, nastavit validační funkci, kterou se nepřímo vyvolá kód změny překryvného seznamu.
K tomuto účelu se využívá metoda SET_ROWSOURCE atributu třídy překryvný seznam.
Tuto metodu je možné vyvolat výrazem v syntaxi:
_THIS.PARENT.SPF_[název atributu volné karty třídy překryvný seznam].SET_ROWSOURCE()
Např.:
Return _this.parent.spf_sp60id.set_rowsource()

Kód pro naplnění hodnot překryvného seznamu se obvykle uvádí pomocí makra a musí začínat textem *~SCRIPT.
V kódu se vyskytují odkazy na atributy volné karty, které ovlivňují obsah překryvného seznamu - těmito odkazy jsou názvy atributů uvedené v hranatých závorkách a před levou závorkou je uveden znak podtržení (např. _[SP61ID]).
Kódu je dále k dispozici v proměnné _THIS instance objektu třídy překryvný seznam, který je odvozen z objektu třídy COMBOBOX Visual Foxpro.

Příklad:
Volné karta, na které je vstupován artikl.
Obsahuje atributy:
1/ SP61ID - druh artiklu - C(3) - třída textové pole
2/ SP60ID - artikl - C(13) - třída překryvný seznam
Požadavek - obsah překryvného seznamu (SP60ID) má odpovídat hodnotě druhu artiklu (SP61ID)

Nastavení vlastností atributů:
1/ vlastnost Validace atributu SP61ID - RETURN _THIS.PARENT.SPF_SP60ID.SET_ROWSOURCE()
2/ vlastnost Seznam hodnot pro překryvný seznam atributu SP60ID - COMBOBOX_SPARTIKL()

COMBOBOX_SPARTIKL je makro, s definovaný kódem:
*~SCRIPT
Local _pc,_als,_li,_i
* _THIS obsahuje instanci objektu třídy překryvný seznam odvozené ze třídy COMBOBOX Visual Foxpro
Do Case
Case Empty(_[sp61id])
    Return .F.
Case Type('_this.free_sp61id')<>'C'
    * pokud objekt _THIS nemá vlastnost FREE_SP61ID, potom je mu tato vlastnost metodou ADDPROPERTY přidělena
    * touto část kódu se půjde pouze jednou
    * ve vlastnosti FREE_SP61ID se bude pamatovat, pro kterou hodnotu SP61ID je naplněn překryvný seznam
    _this.AddProperty('free_sp61id',_[sp61id])
    * vlastnosti COLUMNCOUNT a COLUMNWIDTHS jsou vizuální vlastnosti - toto nastavení, aby seznam lépe vypadal
    _this.columncount=0
    _this.ColumnWidths=''
Case _this.free_sp61id=_[sp61id]
    * poslední zapamatovaná hodnota v FREE_SP61ID odpovídá aktuální hodnotě SP61ID na volné kartě
    * obsah překryvného seznamu není proto třeba měnit
    Return
Other
    * uložení aktuální hodnotě SP61ID z volné karty do FREE_SP61ID
    _this.free_sp61id=_[sp61id]
Endcase
* metoda Clear vymazává obsah překryvného seznamu
_this.Clear
_als=Select()
* SQL dotaz na zjištění názvů artiklů požadovaného druhu
If !bw_exec(.F.,[select sp60id,sp62artikl from %%%.spartikn where sp61id=?_p1 and sp38id='CZE'],'_art',_this.free_sp61id)
    Select (_als)
    Return
Endif
Select _art
* setřízení názvů česky
Set Collate To 'czech'
Index On sp62artikl Tag klic
Set Collate To 'machine'
_pc=0
_li=0
* v cyklu bude naplněn překryvný seznam
Scan All
    _pc=_pc+1
    * metoda ADDITEM přidává řádek překryvného seznamu
    _this.AddItem(Trim(sp62artikl),_pc)
    * pomocí vlastnosti LIST vkládá kód do druhého sloupce hodnotu identifikace artiklu
    _this.List[_pc,2]=sp60id
    if _this.value=sp60id
        _li=_pc
    endif
Endscan
_this.listindex=_li
Use In _art
Select (_als)
* kód funguje zároveň jako validační funkce
Return _pc>0
Ing. Petr Filip 14.05.07

Viz.také

Výběr zajímavých novinek


Výkazy zaokrouhleně

Výkazy zaokrouhleně
pro vytvoření výkazu, ve kterém mají být hodnoty zobrazovány zaokrouhlené na celá čísla, tisíce, milióny nebo miliardy je možné definovat proměnnou výkazu ZAOKROUHLI.

Nabývá-li tato proměnná v okamžiku výpočtu výkazu hodnot 2 nebo 3 nebo 4 nebo 5, potom hodnoty, které mají ve svém sloupci nastavenu vlastnost Zaokrouhlovat=Ano nebudou zobrazovány v Excelu formátem buňky podle vlastnosti 'Formát čísel' , ale podle vlastnosti 'Formát zaokr.' (není-li vyplněn formátem #,##0) doplněným podle požadovaného zaokrouhlení.

V případě, že proměnná ZAOKROUHLI nabývá hodnotu:
2 - hodnoty budou zobrazovány zaokrouhlené na celá čísla - obvykle formátem #,##0
3 - hodnoty budou zobrazovány zaokrouhlené na tisíce - obvykle formátem #,##0,
4 - hodnoty budou zobrazovány zaokrouhlené na milióny - obvykle formátem #,##0,,
5 - hodnoty budou zobrazovány zaokrouhlené na miliardy - obvykle formátem #,##0,,,

Pokud se má způsob zaokrouhlování týkat všech listů výkazu, potom je vhodné definovat proměnnou ZAOKROUHLI v dotazu výkazu např.:
Proměnná - ZAOKROUHLI
Typ - Numerická
Návěští - Zaokrouhlit
Naplnění - Vstup
Inicializace - 1
Třída - Překryvný seznam - Ne,Koruny,Tisíce,Milióny

Pozn.:
Listy výkazů definovaných podle vzoru mohou obsahovat sloupce, které nemají být zobrazovány zaokrouhleně (např. čísla řádků účetní výsledovky, ....).
Nastavení vlastnosti Zaokrouhlovat=Ne pro tyto sloupce je možné postupem:
1/ zapamatujte si obsah vlastnost listu - Vzor
2/ nastavte vlastnost listu Vzor = -
3/ vyvolejte opravu listu klávesou F6
4/ nastavte vlastnost daného sloupce Zaokrouhlovat=Ne
5/ obnovte vlastnost listu - Vzor

Ing. Petr Filip 10.02.06

Viz.také

Výběr zajímavých novinek


Výstupy z BM na jehličkové tiskárny

Výstupy z BM na jehličkové tiskárny
Předlohy výstupu z BM provádějí výstup na tiskárnu pomocí prostředků Windows.
Při výstupu na jehličkou tiskárnu to znamená výrazné snížení rychlosti výstupu oproti tisku z Dosu.

BM nyní obsahuje možnost výstupu na tiskárny, při kterém je tisk prováděn podobně jako v Dosu přímým zasíláním Ascii-znaků na tiskárnu, tj. negraficky.

Předloha výstupu, která má provádět výstup na negrafickou tiskárnu, musí mít ve své definici určenou logickou tiskárnu.
Logická tiskárna přitom musí směřovat výstup na fyzickou tiskárnu obsahující nastavení popisující výstup na negrafickou tiskárnu.

V popisu fyzické tiskárny přibyla tato nastavení:
- typ tiskárny - má význam právě pro negrafické tiskárny - pro které se prostřednictvím typu tiskárny definují řídicí příkazy (escape sekvence)
- grafická - překryvný seznam Ano/Ne
- init.kód - text - sekvence zaslaná tiskárně před zahájením tisku (např. přepnutí do condensed) - obsahuje hexa kódy podle dokumentace nebo dokazy na řídící příkazy typu tiskárny viz.dále
- CP - číslo kódové stránky znaků odesílaných na tiskárnu - je-li menší než 0 budou zasílány znaky bez diakritiky - 0 = překódování znaků se neprovádí
- sloupců - udává počet sloupců tiskárny - např. při tisku condensed znaky může mít sestava na 80ti sloupcové tiskárně 132 sloupců
- řádků - udává počet řádků na stránce sestavy
- testovaní mód - překryvný seznam Ano/Ne - při nastaveném Ano - je tisk směřován do souboru, jehož obsah je následně zobrazen na obrazovce

Po F2 na typu tiskárny je vyvolán formulář pro vstup typů tiskáren, kde se definují řídící kódy tiskárny. Řídící kódy se uvádějí v hexadecimálním tvaru.
Např.:
FF - formfeed - 0C
SI - condensed mode - 0F
Při přepínání velikosti písma je vhodné vypínat condensed mode.
Např.:
10CPI - 12 1B 50
12CPI - 12 1B 4D
15CPI - 12 1B 67

Identifikátory řídících kódu je možné uvádět v předlohách výstupu jako texty uvedené třemi znaky @ (zavináč) a zakončené třemi znaky @ (zavináč).
Tyto texty musí být uváděny na samostatných řádkách.
Např.:
@@@FF@@@
@@@SI@@@
@@@10CPI@@@
..................
Ve vlastnostech těchto textů je vhodné uvádět podmínku tisku:
NOT this.graficka_tiskarna
s nastavením 'Odstranit prázdné řádky'.
To umožní provádět výstup stejné předlohy na negrafických i grafických tiskárnách.
Jako poslední řádek pásu zápatí v definici předlohy je nutné uvádět odkaz na řídící kód odstránkování, např. @@@FF@@@.

Při výstupu předlohy, která ve vztahu na logickou tiskárnu, tiskne na negrafickou fyzickou tiskárnu, je výstup prováděn nejprve do souboru a teprve potom je zařazován do fronty pro tisk (přitom jsou v textu souboru nahrazovány identifikátory řídících kódu, jejich hexadecimálními hodnotami).

Výstup je prováděn prostřednictvím WIN32API, funkcí, která obchází ovladač tiskárny (funkce Escape - PASSTHROUGH), takže není třeba instalovat žádný nový ovladač tiskárny.
Ing. Petr Filip 29.03.05

Viz.také

Výběr zajímavých novinek


Změna velikosti okna formuláře

Změna velikosti okna formuláře
roztažení okna formuláře do šířky a délky tak, že se při tom mění velikost hlavní mřížky formuláře a pokud je to možné také délka mřížek na ostatních záložkách, je možné také u formulářů určených pro definování implementačních rozšíření.
Jedná se o formuláře:
- Obecné výběry
- Volné karty
- Import/export dat
- Šablony
- Transformace
- Informační panely
- Obecné stromy

Ing. Petr Filip 06.02.06

Viz.také

Výběr zajímavých novinek


Změna velkosti okna formuláře

Změna velkosti okna formuláře
nová verze BM umožňuje roztažení okna formuláře do šířky tak, že se při tom mění velikost hlavní mřížky formuláře do šířky a pokud je to vhodné také šířka mřížek na ostatních záložkách.

Tato funkčnost byla zavedena ve formulářích:
- událostí komponent s vyjímkou některých specializovaných komponent
- aktuálních hodnot komponent s vyjímkou některých specializovanýh komponent
- artiklů komponent s vyjímkou některých specializovaných komponent
- obratů komponent
- adresář
- dokumenty
- účtový rozvrh
- účetní saldokonto
- obratové tabulky účetnictví
- konta účetnictví
- TP rozpracované k datu
- Referenční artikly
- Procesy
- Operace
- Druhy procesů
- Druhy operací
Ing. Petr Filip 29.09.05

Viz.také

Výběr zajímavých novinek


Aktuální hodnota

Aktuální hodnota
Je-li uveden druh procesu pro Hodnotu operace ve formuláři Druhy operaci, vyhodnocuje se daný druh hodnoty pro odpovídající operaci:
- aktuální hodnota - v případě, že se operace vyskytuje přímo v procesu daného druhu
- obratová hodnota - v případě, že se operace vyskytuje přímo v procesu daného druhu
- statistická hodnota - v případě, že se operace vyskytuje přímo v procesu daného druhu
- saldokontní hodnota - v případě, že se operace vyskytuje v hlavním procesu daného druhu
Ing. Petr Filip 06.09.07


Kód po ukončení operace

Kód po ukončení operace
V kódu po ukončení operace je možné testovat, zda je nebo není operace ukončována předběžně.
Příkazem IF je možné testovat proměnnou THIS.OPERACE_UKONCOVANA_PREDBEZNE.
Např.:
IF THIS.OPERACE_UKONCOVANA_PREDBEZNE
RETURN
ENDIF

Dále je možné v kódu po ukončení určit, že má nebo nemá být operace ukončena předběžně.
Toto nastavení musí být provedeno scriptem v jazyce Foxpro.
Např.:
SCRIPT
_THIS.OPERACE_UKONCOVANA_PREDBEZNE=.T.
ENDSCRIPT
Ing. Petr Filip 19.09.07


Mzdy - nová hlášení do protokolu

Mzdy - nová hlášení do protokolu
V protokolu mezd jsou zabudována tato nová hlášení uzávěrky.

'POH005'
'Pohledávky 05'
'Pracovník má pohledávku ….. Její zůstatek (……) byl snížen o …… na hodnotu …….'
Došlo ke snížení zůstatku pohledávky.
Vyskytuje se v uzávěrce.

'POH006'
'Pohledávky 06'
'Pracovník má pohledávku (srážku nebo exekuci) ….. Její nedoplatek (…..) byl snížen o …..na hodnotu …..'
Došlo ke snížení nedoplatku pohledávky.
Vyskytuje se v uzávěrce.

'POH007'
'Pohledávky 07'
'Pracovník má pohledávku (srážku nebo exekuci) …..Její nedoplatek (……) byl navýšen o …… na hodnotu ……'
Došlo ke zvýšení nedoplatku pohledávky.
Vyskytuje se v uzávěrce.

'PUJ004'
'Půjčky 04'
'Pracovník má půjčku …… Její zůstatek (…..) byl snížen o …… na hodnotu …..'
Zůstatek půjčky byl snížen.
Vyskytuje se v uzávěrce mezd.
Ing. Olga Smitková 05.09.07


Odpisovaný majetek

Odpisovaný majetek
Do činnosti Změny odpisovaného majetku byl přidán atribut Typ (od02typ) s hodnotami Běžný, Mimořádný.

Tento atribut se zadává jako Běžný. Je přístupný pouze pokud je v druhu nastaveno Účetní odpis nebo Daňový odpis.

Používá se pouze v souvislosti se šablonami Účetní odpis a Daňový odpis.

Pro šablony Účetní odpis a Daňový odpis v okamžiku výpočtu o kolik byl již odpis snížen ve zpracovávaném roce se události typu "mimořádný" nezapočítávají.

Ing. Olga Smitková 11.09.07


Hash hesla uživatele

Hash hesla uživatele
Pro možnost používání přihlašovacích hesel uživatelů jinými programovými systémy než je BM, ukládá volitelně BM do tabulky uživatelů systému (BWUZIVAT) při změně hesla uživatelem zadané heslo zakódované určenou hash funkcí.

Hash funkce je transformace, která jako vstup přijímá řetězec znaků o libovolné délce a výsledkem je pak řetězec znaků s pevnou délkou, tzv. hash nebo také otisk. Hash funkce se často používají v kryptografii, kde se však na její kvalitu kladou další kritéria.
Funkce je jednosměrná, je nemožné jednoznačně najít k otisku původní text.

Parametrem programu BM Preferencess->PasswordHashAlgorithm určuje použitou hash funkci pro zakódování hesla.

1 = SHA1 (a.k.a SHA160)
2 = SHA256
3 = SHA384
4 = SHA512 *Default
5 nebo 50= MD5
6 = RIPEMD128
7 = RIPEMD256

Hash se ukládá do atributu BW01HHASH tabulky BWUZIVAT v binárním nebo hexadecimálním tvaru (při nastavení Preferencess->PasswordHashHexa=1) a číslo hash funkce se zapisuje do atributu BW01HHASHT.
Před zakódování hesla hash funkcí se jeho text převádí na malá písmena.

Pro použití hash funkcí 1 až 7 je třeba, aby byl v adresáři programu BM nainstalován soubor VFPENCRYPTION.FLL a dále je třeba na každou stanici instalovat knihovny VC++ 8.0 runtime.

Použití funkce 50 (MD5) nevyžaduje instalaci žádných externích prostředků.

Možnost ukládat hash hesla uživatele je pouze ve verzích BM pod Visual Foxpro 8.0 nebo vyšší.
Ing. Petr Filip 01.08.07


Šablony otevření+uzavření účetních knih

Šablony otevření+uzavření účetních knih
V činnosti ÚČETNICTVÍ - SPECIÁLNÍ ČINNOSTI - Parametry účetnictví byl založen nový parametr "Povolit otevření a uzavření podrozvahových účtů" se stavy Nepovolit,Povolit,Varovat. Pomocí tohoto parametru lze ovlivňovat chování šablony Otevření či uzavření knih.

Nepovolit - Otevření či uzavření knih v období se neprovede, pokud v daném účetním období je již alespoň jedna událost otevření či uzavření.
Povolit - Otevření či uzavření knih v období se provede, i když existují v daném účetním období nějaké události otevření či uzavření. Při standardním provozu by mělo platit, že uživatelé spouští proces pro otevření a uzavření účtů 0 až 6 a další proces pro otevření a uzavření podrozvahových účtů - každý pouze jednou.
Varovat - Šablona zjistila, že v daném účetním období již je alespoň jedna událost otevření či uzavření.Šablona se zeptá obsluhy, zda si přesto přeje provést otevření či uzavření knih.

Implicitně je nastaveno Nepovolit.

Funkce šablony Otevření účetních knih - šablona otevírá účty třídy 0 až 4 - je třeba vytvořit pouze jeden doklad=proces otevření těchto účtů v každém účetním období
Funkce šablony Uzavření účetních knih - šablona uzavírá účty třídy 0 až 6 - platí stejná podmínka jako výše
Funkce importu Otevření či Uzavření podrozvahových účtů - otevírá či uzavírá účty 75 až 79 - platí stejná podmínka

Z výše uvedeného vyplývá: Pro společnosti pracující s podrozvahovými účty je vhodné používat nastavení Povolit či Varovat + kombinaci šablony a importu.
Ing. Olga Smitková 14.08.07


Nový způsob evidování přihlášených uživ.

Nový způsob evidování přihlášených uživ.
BM nyní obsahuje nový způsob záznamu aktuálně přihlášených uživatelů.

Původní řešení zaznamenávalo uživatele v souboru ...\SYST\ADMIN\BWCONNEC.DBF.
Nové řešení sleduje přihlášené uživatele v tabulce BWCONNEQ v SQL databázi, a nachází se nyní ve fázi testování v ostrém provozu u vybraných uživatelů BM (uplatní se při nastavení v souboru BW.INI Preferencess->BWCONNEQ=1).

Pokud počet současně přihlášených uživatelů překročí licenci provozovatele BM na počet současně přihlášených zobrazí se uživateli dotaz:
----------------------------------------------------
PŘIHLÁŠENÍ DO BM
Po Vašem vstupu do BM bude k BM přihlášeno NN uživatelů a tím bude licence Vaší firmy pro používání BM překročena o NN současně přihlášených uživatelů.
Vaše odpověď ANO Vám umožní vstup do programu a bude považována za objednání dalších licencí BM.
----------------------------------------------------
Při nastavení programu BM Preferencess->Licence_prodluzovat=0 nebude tento dotaz zobrazen a uživateli nebude vstup do BM povolen.

Pro zobrazení seznamu přihlášených uživatelů byla vytvořena nová činnost nazvaná 'Přehled přihlášených (SQL) '. V mřížce formuláře je nyní mj. uveden sloupec Identifikace, který obsahuje čísla spojení, která uživatelů přidělil databázový server.
Z menu Volby formuláře je možné vyvolat činnosti:
Obrazovka uživatele - vyvolá formulář, ve kterém je periodicky zobrazován obsah obrazovky daného uživatele
Stav programu BM uživatele - vyvolá formulář, ve kterém je periodicky zobrazován stav programu BM daného uživatele

Pro funkčnost činnosti 'Obrazovka uživatele' je třeba udělat tato nastavení:
1/ nahrát do adresáře \BMSQL resp. \BMSQL\PRGS soubor JPGDLL.DLL
2/ definovat právo přístupu k této činnosti některé skupině uživatelů
3/ nastavit parametr programu BM 'SpySleepInterval'

Pozn.: Obrazovka se nepřenáší, pokud uživatel pracuje v režimu Terminal-Server.
Pozn.: Administrátor systému BM, by měl po konzultovaci s právním zástupcem zajistit právní čistotu používání činnosti 'Obrazovka uživatele'.

Pro funkčnost činnosti 'Stav programu BM uživatele' je třeba udělat tato nastavení:
1/ vytvořit externí příkaz s PID=STATUS (nebo nainstalovat tento příkaz z návodů a balíčků)
2/ nastavit parametr programu BM 'SpySleepInterval'

Princip fungování obou činností je založen na časovém objektu, který je nainstalován při startu programu, a který při spuštěném programu periodicky čte záznam přihlášeného uživatele v tabulce BWCONNEQ.
Interval periodického čtení je dán nastavením programu BM:
Preferencess->SpySleepInterval - určuje periodu ve vteřínách v situaci, kdy není žádný požadavek na sejmutí obrazovky resp. zjištění stavu
Preferencess->SpyRunInterval - na tuto periodu se změní interval čtení záznamu v tabulce BWCONNEQ po do dobu trvání požadavku na sejmutí obrazovky resp. zjištění stavu

Formulář 'Obrazovka uživatele' při svém spuštění zapisuje do atributu BW14SPYCNT (zvýší jeho hodnotu o 1) tabulky BWCONNEQ požadavek na sejmutí obrazovky uživatele.
Formulář 'Stav programu BM uživatele' při svém spuštění zapisuje do atributu BW14SPYCNS (zvýší jeho hodnotu o 1) tabulky BWCONNEQ požadavek na zjištění stavu programu BM.

Program BM, který plní požadavek na sejmutí obrazovky zapisuje do tabulky BWCONNEQ do atributu BW14SPYJPG obrazovku Windows ve formátu JPEG.
Program BM, který plní požadavek na zjištění stavu programu spouští externí příkaz s PID=STATUS, předpokládá se, že jeho kód zapíše stav ve formátu HTML do tabulky BWCONNEQ do atributu BW14SPYSTA obrazovku Windows ve formátu JPEG.
Obvykle jsou v kódu HTML předaném v atributu BW14SPYSTA obsaženy mj. hypertextové odkazy, po jejichž zvolení zapíše BM do tabulky BWCONNEQ do atributu BW14SPYKOD kód v jazyce Foxpro, který má být proveden na počítači uživatele (např. kód, který ukončí program BM).

V souvislosti novým způsobem záznamu aktuálně přihlášených uživatelů eviduje BM maximální počet současně přihlášených uživatelů. Pro každý den, kdy došlo k alespoň jednomu přihlášení k BM, zapisuje program do tabulky BWCONNES datum, největší počet současně přihlášených v daném dni a identifikaci uživatele, který byl posledním z přihlášených.

Ing. Petr Filip 13.07.07


Předlohy výstupu do Wordu

Předlohy výstupu do Wordu
Umožňují opakované použití šablony ve výstupu.

V definici předlohy je možné k tomuto účelu použít parametry:
Opakovaná - zaškrtávací pole - zaškrtnuté způsobí při tisku pro každý záznam SQL_TISK opakované vložení šablony do výstupu DOC
Nová stránka - zaškrtávací pole - zaškrtnuté ve spojení s Opakovaná způsobí při tisku vložení konce stránky před další vložení šablony do výstupu DOC
Ing. Petr Filip 13.07.07


Mzdy - nepřítomnosti - výběr

Mzdy - nepřítomnosti - výběr
Výběr činnosti Nepřítomnost pro nemoc byl z důvodu používání cizojazyčnosti rozšířen.

Na první záložce činnosti Nepřítomnost pro nemoc se udává důvod nepřítomnosti (např. nemoc, ošetřování, mateřská dovolená, ...). Pomocí cizojazyčnosti lze tento seznam libovolně rozšířit.

Do výběru činnosti Nepřítomnosti pro nemoc bylo zabudováno zaškrtávátko Ostatní důvody.

Toto zaškrtávátko vybere všechny důvody od pořadí sedm v překryvném seznamu důvodů nepřítomnosti výše.
Ing. Olga Smitková 07.06.07


MZDY - ošetřování osamělou osobou

MZDY - ošetřování osamělou osobou
Úprava řeší výpočet dávky, pokud je ošetřování prováděno osamělou osobou. Takové osobě náleží jiná nemocenská dávka, než osobě, která ošetřuje člena rodiny a není osamělá.

V činnosti Nepřítomnost pro nemoc je nový důvod, v pořadí sedmý - Ošetřování osamělou osobou.
Stejný důvod byl přidán do Parametrů nemocenských dávek.V Parametrech nemocenských dávek je možné definovat způsob výpočtu dávky u ošetřování osobou, která je osamělá.

Výpočet výplatních lístků vytvoří mzdové položky N20000 a N21000, tj. jako u běžného ošetřování.

Pokud zadáváte ošetřování osobou, která není osamělá, použijete v činnosti Nepřítomnost pro nemoc důvod Ošetřování.

Pokud zadáváte ošetřování osobou, která je osamělá, použijete v činnosti Nepřítomnost pro nemoc důvod Ošetřování osamělou osobou.
Ing. Olga Smitková 15.06.07


TPV a výroba - linky

TPV a výroba - linky
Do tabulky referenčních artiklů byl doplněn atribut, do kterého lze zadat implicitní linku (druh je daný technologickou operací) s tímto významem "implicitní linka pro tento referenční artikl".
Tato implicitní linka, je-li v ref. artiklu uvedena, přebíje (předplní) při plánování výroby (generování výrobních úkolů) implicitní linku uvedenou u druhu linky.
Ing. Petr Filip 05.06.07


Změna ikon oken BM

Změna ikon oken BM
Pro určení ikony okna hlavního menu programu je možné použít Nastavení programu BM v souboru BW.INI Preferences->BMMenuIcon=[soubor ikony].

Pro určení ikony hlavního okna programu je možné použít Nastavení programu BM v souboru BW.INI Preferences->BMIcon=[soubor ikony].

BM umožňuje definovat externí příkaz, jehož kód má být proveden bezprostředně po každém přihlášení uživatele k programu.
Tímto způsobem je spouštěn externí příkaz s PID=STARTU v případě, že není nastaveno v BW.INI Preferences->StartupCode=0.
Tuto možnost je možné použít mj. pro změnu vzhledu BM např. příkazem _screen.backcolor=RGB(192,255,192).
Ing. Petr Filip 05.06.07


Informační panely - formátování sektorů

Informační panely - formátování sektorů
Pro každou stránku informačního panelu je možné definovat na záložce Sektory její rozčlenění na sektory.
Sektory jsou ve výsledném HTML textu realizovány pomocí tabulky (dále tabulky rozvržení sektorů).
Pro každý sektor se uvádí:
1/ identifikace sektoru - 2 znaky - Pozice sektoru stránky ve tvaru písmeno+cifra - písmeno určuje pozici v ose X, cifra určuje pozici v ose Y
2/ maximální počet sloupců sloučených do sektoru - číslo
3/ maximální počet řádků sloučených do sektoru - číslo
4/ prázdný sektor - překryvný seznam Ano/Ne - určuje zda má být sektor zobrazen i když je prázdný
5/ pretext - text - text vložený před buňku sektoru
6/ tag buňky - text - tag buňky sektoru tabulky
7/ posttext - text - text vložený za buňku sektoru
8/ poznámka - libovolný text

Na takto definované sektory je potom možné odkazovat:
1/ pro uzel na záložce Další - určuje, do kterého sektoru bude umístěn výstup uzlu typu prvek stánky
Pro uzel je zde možné dále nastavit Popis stylu tabulky rozvržení sektorů (např. class="dtTABLE" cellspacing="0").
2/ pro poduzly uzlu na záložce Poduzly uzlu - určuje, do kterého sektoru bude umístěn výstup zpracování daného poduzlu.

Příklad vložení tabulky do sektoru:
vlastnost Pretext sektoru
[table class="dtTABLE_papayawhip" cellspacing="0"][tr>[th]Mám řešit úkoly[/th][/tr][td]

vlastnost Posttext sektoru -
[/tr][/table][/td]

Ing. Petr Filip 14.05.07


Bankovní výpisy - Gemini 4.1.

Bankovní výpisy - Gemini 4.1.
Byly vypracovány dva nové formáty elektronického výpisu z účtu pro systém Gemini 4.1 (např. Volksbank)

Program ge117kmo.prg při zjišťování čísla účtu, kódu banky a variabilního symbolu vychází z údajů od pozice 142 - detaily.

Program ge118kmo.prg při zjišťování čísla účtu, kódu banky a variabilního symbolu a i jiných údajů vychází z údajů od pozice 176 - informační pole.
Ing. Olga Smitková 30.04.07


MZDY - chyba uzávěrky

MZDY - chyba uzávěrky
Ve verzích, které byly generované v období 14.2.2007 až 18.3.2007 se objevuje chyba uzávěrky. Projeví se tam, kde jsou používány měsíční kalendáře. Ve verzích, které využívají denní kalendáře se chyba neprojeví.
Ing. Olga Smitková 19.03.07


Pošta - dokumenty

Pošta - dokumenty
Mailmerge dokumentu BM připojeného k operaci pošty obsahuje také atribut 'ČJ krátké', jehož hodnotou je text odpovídající identifikaci procesu (9999-99-99999999).
Ing. Petr Filip 19.03.07


Skript předlohy dokumentu

Skript předlohy dokumentu
pro každou předlohu dokumentu (formulář Předlohy dokumentu) je možné mj. definovat její vlastnosti:
- Skript - text - skript v jazyce Foxpro spouštěný bezprostředně po otevření dokumentu resp. předlohy dokumentu externím programem
- Definice pro konvertor WINWORD - text

Kód skriptu v jazyce Foxpro je vyvolán s parametry:
- _this - objekt - řídící objekt BM, který otevírá dokument
- _sp26 - jednoznačná časová identifikace dokumentu BM resp. předlohy dokumentu
- _predloha - logická hodnota nabývající hodnotu .T. (TRUE), pokud je opravována předloha dokumentu
- _workfile - název pracovního souboru, ve kterém je opravován dokument resp. předloha dokumentu
- _poprve - logická hodnota nabývající hodnotu .T. (TRUE) při první opravě dokumentu

Kód skriptu může použít Konvertor WINWORD.
Konvertor WINWORD je interní objekt BM, který je používán také při výstupu předlohou výstupu typu Word.
Pro definici konverze může skript použít 'Definici pro konvertor WINWORD' uvedenou v předloze dokumentu.
Ve formuláři 'Předlohy dokumentu' je možné spustit volbu z menu Volby->Editovat definici pro konvertor WINWORD (klávesa F7), kterou je vyvolán formulář pro vstup definice konverze stejný jako při definování předlohy výstupu typu Word.

Kromě použití konvertoru WINWORD je možné použít skript např.:
- načtení dat mailmerge po otevření dokumentu (prvním založení nebo každém otevření) - Word 2003 toto sám automaticky neprovádí
- vytvoření vlastního specifického mailmerge (mailmerge může být tímto způsobem použit bez nutnosti propojení s operací pošty)

Příklad skriptu s použitím konvertoru WINWORD - skript při prvním otevření dokumentu, předplní tento dokument textem charakteru e-mail:
- vlastnost Skript obsahuje
LOCAL _o,_sql
IF !_poprve OR _predloha
       * konverze nebude provedena, pokud je otevírána předloha nebo se nejedná o první otevření dokumentu
    RETURN
ENDIF
* proměnná _SQL bude obsahovat sql dotaz pro zjištení hodnot z události vývěsky spojené s dokumentem
* všimněte si použití parametru _SP26
TEXT TO _sql TEXTMERGE NOSHOW
select first vyudalos.*,adspoj.ad11email,adadsat.ad01adsat
from
%%%.bwobject,%%%.vyudalos,%%%.adadsat,%%%.adspoj
where
bwobject.bw09inst2='<<_SP26>>' and
bwobject.bw09typ2='DD' and
bwobject.bw09typ1='VY' and
vyudalos.vy01=bwobject.bw09inst1 and
adadsat.ad01id=vyudalos.ad01id and
adspoj.ad01id=vyudalos.ad01id and
adspoj.ad11cisspo=vyudalos.ad11cisspo
ENDTEXT
* konvetor používá data kurzoru SQL_TISK
IF !bw_exec(.F.,_sql,'sql_tisk')
    RETURN
ENDIF
* volání uložené procedury BW_OWRD vrací instanci objektu konvertoru WINWORD
_o=bw_owrd()
* metoda ADDPROPERTY přidává v instanci objektu vlastnost WORKFILE s názvem pracovního souboru dokumentu tak,
* aby konvertor vytvořil soubor s tímto názvem (viz. definice konverze)
_o.addproperty('workfile',_workfile)
* TOOL.OLEOBJ[2] obsahuje při aktuálním spuštění skriptu odkaz na objekt aplikace Wordu
* dokument ve Wordu musí být uzavřen - konvertor ho znovu otevře resp. vytvoří s jiným obsahem (pokud je v definici konverze určena předloha)
tool.oleobj[2].activedocument.close
* metoda GET_DEFKONV řídícího objektu otevření dokumentu vrátí obsah definice pro konvertor uvedený u předlohy dokumentu
* metoda GO objektu konvertoru spouští konverzi - druhý parametr .T. musí být uveden (určuje, že se nejedná o konverzi podle předlohy výstupu)
_o.go(_this.get_defkonv(),.T.)

- vlastnost Definice pro konvertor WINWORD obsahuje (všiměte si nastavení .FILE this.workfile)
.WINWORD 1.0
* SPRÁVCE 16.03.2007 15:26:11
.FILE this.workfile
.FILEFORMAT 1
.TEMPLATE 'K:\BMSQL\template\email.dox'
.EMAIL_ADDRESS
ad11email
.ENDEMAIL_ADDRESS
.EMAIL_SUBJECT
vy01text
.ENDEMAIL_SUBJECT
.EMAIL_WORD
.EMAIL_IMPORTANCE 1
.BWPRINTD_BW04WRDEMA
.GROUP
.TABLETYPE 3
.FROM 1
.BORDERS
.ELEMENT body
.EXPR vy01koment
.COMMENT
Komentář, který detailně popisuje událost. - M(10,0)
.ENDCOMMENT
.ELEMENT BWUZIVAT_bw01jmeno
.LABEL "Zapsal"
.EXPR tool.jmenot
.COMMENT
Jméno uživatele systému - C(17,0)
.ENDCOMMENT

Ing. Petr Filip 19.03.07


Roční zúčtování 2006 - novinky

Roční zúčtování 2006 - novinky
Roční zúčtování za 2006 (novinky) :

1) Karta pracovníka měla záložku Roční nezdanitelné položky.
Tato je nyní přejmenovaná na Roční položky.

Zadávají se sem roční nezdanitelné položky (tak jako v minulosti) a navíc i daňová zvýhodnění typu roční nebo
roční s bonusem (toto jsou vlastně nároky na daňové zvýhodnění).

Všechny zde zadané položky mají charakter "od jiného zaměstnavatele".
Výjimku tvoří Daňové zvýhodnění na manželku a na manželku jako ZTP, které se uplatňuje jako roční (není tedy od jiného zaměstnavatele a zadává se také sem).

Doporučené ROČNÍ identifikace :
Na poplatníka JJR021
Na manželku JJR022
Na manželku ZTP JJR023
Na částečnou invaliditu JJR024
Na plnou invaliditu JJR025
Držitel průkazu ZTP/P JJR026
Na studium JJR027
Na dítě JJR01
Na ZPT dítě JJR11

2) Do výplatního lístku se tyto souhrnné roční položky dostanou automaticky při výpočtu ročního zúčtování, obdobně jako roční nezdanitelné položky

3) Karta pracovníka má záložku Daňová zvýhodnění, ale její funkčnost je nově omezena. Zadávají se zde pouze položky daňová zvýhodnění, která NEJSOU typu roční nebo roční s bonusem.

4) Bude vhodné položky L33000, L34000 - loňský nárok, loňská sleva ZCELA PŘESTAT POUŽÍVAT a namísto nich používat Daňová zvýhodnění typu roční nebo roční s bonusem.

Např. Daňové zvýhodnění na děti je používané u současného zaměstnavatele jako typu měsíční s bonusem.
Údaj o nároku na daňové zvýhodnění na děti, který pochází od bývalého zaměstnavatele, se zadá novou mzdovou položkou,
která bude typu Daňové zvýhodnění roční s bonusem - viz 1)

5) Do položky L35000 se zadají bonusy vyplacené jiným zaměstnavatelem (zde se nejedná o nárok, ale o skutečně vyplacené částky).

6) Loňské údaje bylo možné zadat jako položky L33000, L34000 - loňský nárok, loňská sleva . Z historických důvodů se zde ale myslí položky, ze kterých je možné získat daňový bonus. A proto bude lépe tyto položky přestat používat - viz 4) a namísto nich používat položky dle bodu 1)

Sestavy - z činnosti "Prohlížení výplatních lístků"
- Výpočet daně a daňového zvýhodnění 2006 - pouští se s výběrem 01/2007 až 01/2007 nebo 02/2007 až 02/2007 nebo 03/2007 až 03/2007
- Potvrzení o zdanitelných příjmech ze závislé činnosti … 2006 - pouští se s výběrem 01/2006 až 12/2006

Sestavy mohou být specifické pro jednotlivé zákazníky. Poraďte se s implementátorem.

Ing. Olga Smitková 23.02.07


Zaokrouhlování - kód po ukončení

Zaokrouhlování - kód po ukončení
V kódu po ukončení (statickém - prodej za hotové) se používá procedura obzaok50. Byla rozšířena o čtvrtý parametr _mince. Nabývá hodnot 0.5 nebo 1

Takto je možné regulovat, zda chci zaokrouhlit celkovou cenu na padesátník nebo na korunu.

Příklad :
if not obzaok50(.F.,.F.,"",0.5)
cancel
endif

if not obzaok50(.F.,.F.,"",1)
cancel
endif
Ing. Olga Smitková 15.12.06


Karta pracovníka - Srážky

Karta pracovníka - Srážky
V komponentě mzdy došlo k rozšíření způsobu práce se srážkami.

V činnosti Karta pracovníka, na záložce Srážky se objevil nový atribut "S limitem do". Je do něho možné zadat hranici, ke které se váže sražená částka.

Porovnávání s touto hranicí se provádí v absolutní hodnotě.

Příklad:
Chci srážet 10% z čistého příjmu, maximálně však 300,- Kč. Jestliže konkrétních 10% z čistého příjmu pracovníka přesáhne částku 300,- Kč, pak dojde ke srážce pouze ve výši 300,- Kč.
Částku 300 je nutné zapsat do atributu "S limitem do".

Příklad:
Chci srážet -10% z čistého příjmu (mínus), minimálně však -300,- Kč. Jestliže konkrétních -10% z čistého příjmu pracovníka bude menších, než částka -300,- Kč, pak dojde ke srážce pouze ve výši -300,- Kč.
Částku -300 (mínus třista) je nutné zapsat do atributu "S limitem do".

Příklad:
Konkrétní vypočtená srážka je např. -850,- Kč a porovnává se s "S limitem do" -500,- Kč, pak se provede srážka pouze -500,- Kč

Je-li tento atribut nulový, pak se nic neděje.
Ing. Olga Smitková 15.11.06


Skupiny uživatelů x uživatelé systému

Skupiny uživatelů x uživatelé systému
V BM jsou uloženy uživatelé a skupiny uživatelů v jediné společné tabulce (BWUZIVAT).
To umožňuje kromě definování zařazení uživatelů do skupin také definování vztahů mezi skupinami uživatelů.

Hierarchická struktura skupin uživatelů má dopad na definování přístupových práv.
Např.:
Máme definované skupiny uživatelů VEDENÍ a skupiny OBCHODNÍ ŘEDITEL, ŘEDITEL VÝROBY, které jsou zařazené do skupiny VEDENÍ. Potom uživatel zařazený do skupiny OBCHODNÍ ŘEDITEL je nepřímo zařazen do skupiny VEDENÍ a vztahují se k němu všechna přístupová práva definovaná pro skupinu VEDENÍ.

Uživatele je možné zařadit do skupiny uživatelů, která je zároveň uživatelem systému. V tom případě zařazený uživatel vlastní pouze ta přístupová práva, která jsou přímo udělena uživateli, který v tomto vztahu vystupuje jako skupina uživatelů (obvykle např. definování práv k řešiteli projektového úkolu).

Ve starších verzích BM byly skupiny uživatelů uloženy v samostatné tabulce BWODBOR. V aktuální verzi je tato tabulka reprezentována pohledem čerpajícím z tabulky BWUZIVAT. Atribut BW01US rozlišuje záznam v tabulce BWUZIVAT - hodnota BW01US=1 určuje, že se jedná o uživatele systému.

Dále se změnil způsob definování přístupových práv.
Oprávnění k činnostem je nyní možné definovat individuálně přímo na konkrétního uživatele.
Ve formulářích 'Přístupová práva' a 'Přístupová práva k procesům a operacím' se práva původně se vstupovala na dvou samostaných záložkách - nyní se vstupují na jediné záložce přímým vstupem klávesu F3.
Tato změna bude zaznamenána v dokumentaci.

Nová činnost 'Zařazení do skupin uživatelů' zobrazuje vztahy uživatelů a skupin ve stromové struktuře, ve které je možné po pravém kliku myší zařazovat uživatele do skupin novým způsobem.

Při instalaci nové verze BM dochází ke sloučení obsahu tabulek BWOBDOR a BWUZIVAT, přitom nejsou přenášeny ty skupiny uživatelů, které mají stejnou identifikace jako některý uživatel. Proto by měl správce systému před instalací nové verze změnit jejich identifikace (identifikaci skupiny uživatelů $SPRAV nemusí měnit - instalace ji automaticky změní na SPRAVC).

Ing. Petr Filip 21.11.06


Výrobní číslo v události ochodu

Výrobní číslo v události ochodu
v události obchodu je možné zadávat výrobní číslo artiklu.
Dále se pro každou událost operace obchodu uchovává její pořadové číslo v operaci, které je možné opravovat.
Po spuštění založené operace obchodu jsou její události zobrazené podle toho pořadí (pokud není určeno jiné setřídění).
Pořadí události v operaci obchodu je možné použít také v předlohách výstupu (atribut OB02PORADI).
Ing. Petr Filip 21.11.06


Mzdy - Pravděpodobné průměry

Mzdy - Pravděpodobné průměry
Byla vytvořena nová činnost
SPECIÁLNÍ ČINNOSTI - Přepočet průměru h., d. a m. (pravděpodobný průměr)

Činnost vypočítá průměr hodinový, denní a měsíční.

V činnosti je možné zvolit OSC pracovníka a vybrat čtvrtletí, z jehož údajů se průměr vypočítá.

Průměry h., d. a m. se vypočtou z dosud známých údajů a obsluha je zcela zodpovědná za to, že údaje, které jsou v daném okamžiku v systému Bílý motýl jsou kompletní.

Do protokolu se vepíše hlášení

PRUM07 - Pracovník má průměr vypočítaný pomocí činnosti Přepočet průměrů h.,d. a m. (Pravděpodobný průměr).
Jeho průměr byl vypočten podle dosud dostupných údajů - tyto nemusí být kompletní a průměr tedy nemusí být správně.

Doporučení pro implementaci : Zvážit přístupová práva k této činnosti.
Ing. Olga Smitková 10.10.06


Informační panely

Informační panely
Pro uzel informačního panelu typu 'Prvek stránky' je možné nastavit parametr 'Typ prvku' -
1/ '-' - bude vytvořen seznam hypertextových odkazů s texty podle vyhodnocení výrazu uvedeného v parametru 'Výraz názvu' - počet těchto odkazů odpovídá počtu záznamů vrácených SQL dotazem
2/ 'Tabulka' - bude vytvořena tabulka podle popisu tabulky
3/ 'Odkazy s vyvoláním skriptu' - bude vytvořen seznam hypertextových odkazů s texty podle vyhodnocení výrazu uvedeného v parametru 'Výraz názvu' - počet těchto odkazů odpovídá počtu záznamů vrácených SQL dotazem

Při nastavení parametru 'Typ prvku' jiném než 'Tabulka' je třeba takový uzel zařadit pod jiný uzel (jako poduzel uzlu) s nastavením parametru 'Návěští = Odkaz na stránku'.
Stisk hypertextu vytvořeného pro uzel s typem prvku '-' způsobí zobrazení stránky, která je sestavena podle definovaných vztahů s poduzly tohoto uzlu.
Pro uzel s typem prvku 'Odkazy s vyvoláním skriptu' se na záložce Ostatní definuje parametr SKRIPT, ve kterém se uvádí skript v jazyce Foxpro. Tento skript je vyhodnocován při vytváření stránky a vrací jiný skript v jazyce Foxpro, který bude aktivován při stisku odpovídajícího hypertextu a přitom je okno informačního panelu minimalizováno, pokud neprovedl skript při vytváření stránky nastavení _THIS.HREF_WEB=.T. .

Pozn.:
Součástí 'Návodů a balíčků' je balíček obsahující definice uzlů informačního panelu, které vytvářejí stránky odpovídající hlavnímu menu programu (nebo jeho části). Z těchto stránek je možné spouštět činnosti BM stejně jako z hlavního menu programu.
Ing. Petr Filip 29.09.06


Informační panely

Informační panely
Některé uzly umístěné jako poduzly jiného uzlu ve vztahu s nastavením 'Návěští = Odkaz na stránku' není vhodné, aby se v popisu hypertextu zobrazoval počet záznamů (např. odkaz na stránku, na které je prováděn vstup pro výběr záznamů).
Pro tyto uzly je možné zadat v parametru 'SQL dotaz' příkaz _THIS.ADDPROPERTY('SHOW_DATACOUNT',.F.), přitom je třeba, aby spojení pro tento uzel bylo definované spojení typu XBASE.
Ing. Petr Filip 29.09.06


Určení výstupního adresáře výstupů

Určení výstupního adresáře výstupů
Parametry z nastavení IS BM - Preferences->Excel_Output_Path a Preferences->HTML_Output_Path se uplatňují se pro předlohy výstupu typu Excel resp. Ostatní, pro které určuje adresář výstupního souboru v případě, že v názvu souboru není uvedena absolutní adresářová cesta.
Pokud přitom tento adresář na počítači neexistuje, potom se automaticky zakládá.

V případě potřeby ukládání výstupního souboru v adresáři relativním k adresáři programu BM, při současném nastavení parametru Preferences->Excel_Output_Path resp. Preferences->HTML_Output_Path, se uvádí název souboru ve tvaru @\relativni_cesta\nazev_soubor.XLS.
Ing. Petr Filip 15.09.06


Čas výroby

Čas výroby
Ve formuláři TPV - Přehled referenčních artiklů - je nově možné definovat na záložce Referenční artikly v atributu Plus - Připočítávaný kontantní čas délky kroku v minutách.
O tuto dobu se prodlouží při výpočtu výrobních úkolů zakázky doba trvání odpovídajícího výrobního úkolu.
Ing. Petr Filip 21.08.06


Definice komunikace s bankou

Definice komunikace s bankou
Zpracování výpisů z banky se děje pomocí činnosti Definice komunikace s bankou

V této činnosti - záložka Definice položek vstupu došlo k rozšíření funkčnosti o čtyři nové atributy. Jsou to tyto Typy položky : Částka 2 (v RM), Měna 2 (oc01id1), Párov., Důvod

Pokud používáte pro přijetí výpisu vlastní program zpracovávající výpis ( viz záložka nastavení vstupu), pak analogicky můžete pracovat s těmito novými atributy tabulky ZPW2PREN : zp09castk2, zp09mena2, zp09parova, zp09ucel

Ing. Olga Smitková 08.08.06


Mzdy - pravidelné příjmy

Mzdy - pravidelné příjmy
Mzdové položky mají ve své definici uvedený koeficient (činnost Příjmy a náhrady).

Nově byla zavedena možnost používat individuální koeficient - závisí na pracovníkovi a pracovním poměru. Jedná se o činnost Karta pracovníka - Pravidelné příjmy. V této činnosti je možné nastavit individuální koeficient, který se při výpočtu uplatní místo koeficientu na mzdové položce. (Je-li individuální koeficient nastaven na hodnotu 0, pak se používá se koeficient mzdové položky)

Má-li pracovník v pravidelných příjmech nastaven individuální koeficient, uvede se tato skutečnost do Protokolu.

Ing. Olga Smitková 01.08.06


Platnost technologického postupu

Platnost technologického postupu
Při Generování úkolů zakázky výroby se pro výběr použitého technologického postupu (TP) z překryvného seznamu uplatňují datumy platnosti uvedené u TP.
Do tohoto překryvného seznamu jsou naplněny pouze TP platné podle datumů jejich platnosti k datu ukončení výroby zakázky uvedeného u zakázky, a zároveň mající nastavenou vlastnost Platný=Ano.
Ing. Petr Filip 21.08.06


Strom hlavního procesu

Strom hlavního procesu
Uzly stromu hlavního procesu, které jsou poduzly uzlu představujícího proces v hlavním procesu (ikona dopravní značky zákaz vjezdu do jednosměrné ulice nebo stop), jsou ve formuláři stromu doplňovány dynamicky v okamžiku rozbalení uzlu představujícího proces.
Tím je umožněna dostatečně rychlá odezva při zobrazování stromů rozsáhlých procesů.
Při nastavení vlastnosti BM StromHP->Dynamicke_rozbalovani=0 je strom kompletně naplněn při startu formuláře stromu (za cenu horší odezvy jeho zobrazení).
Ing. Petr Filip 09.08.06


Návaznost technologického měření ve výr.

Návaznost technologického měření ve výr.
BM umožňuje aktualizovat při ukončení operace hodnoty vstupů a výstupů výrobní operace podle hodnot naměřených prostředky technologie.
-------------------------------
Příklad skriptu:
SCRIPT
* doporučení - uložte tento script do knihovny vkládaného kódu

* v konstantě _tcdata je název souboru s daty měření
#Define _caption 'VÝROBA'
#Define _tcdata 'm:\bmsql18\techno\tcudopma.dbf'
Local _frm,_frm0,_loc,_kalkul,_rc,_iden,_rt,_chybi_mereni
Local Array _p[1]
If !File(_tcdata)
    Do bw_hlase With '!',_caption,'Nebyl nalezen soubor s daty měření.'
    Return .F.
Endif
*************************
* vyhledání objektu formuláře, ze kterého je operace ukončována
For Each _frm0 In _Screen.Forms
    If Type('_frm0.identc')='C' And _frm0.identc='VR0010' And Set('datasession')=_frm0.makroprikaz([return set('datasession')])
        _frm=_frm0
    Endif
Endfor
If Vartype(_frm)<>'O'
    Do bw_hlase With '!',_caption,'Nebyl nalezen formulář výrobního úkolu.'
    Return .F.
Endif
*************************
* otevření souboru s daty měření
If Used('_tcudopma')
    Use In _tcudopma
Endif
Select 0
Use (_tcdata) Alias _tcudopma Shared
**************************
* cursor vrudopma4 obsahuje všechny vstupy a výstupy všech výrobních úkolů ukončované operace
* objekt _this_spravce je řídící objekt pro řízení operace - obsahuje mj. identifikaci operace
* nacti_vrudopma4 je procedura umístěna na konci skriptu
Do nacti_vrudopma4 With _this_spravce
_loc=bw_lock('L','Fvrudopma4')
**************************
_kalkul=''
_chybi_mereni=''
Select vrudopma4
Scan All
* vyhledání naměřené hodnoty v datech měření
    Select _tcudopma
    Locate All For vr02vyrc+vr09skup+vr09porc+sp61id+sp60id=;
        vrudopma4.vr02vyrc+vrudopma4.vr09skup+vrudopma4.vr09porc+vrudopma4.sp61id+vrudopma4.sp60id
    Do Case
    Case Found()
    Case technologicky_merit(vrudopma4.sp61id,vrudopma4.sp60id) && podmínka artikl, který by měl být měřen. Viz. procedura na konci skriptu
        _chybi_mereni=_chybi_mereni+Chr(13)+vrudopma4.sp61id+'-'+Trim(vrudopma4.sp60id)+' - '+;
            TRIM(vrudopma4.vr02vyrc)+'-'+vrudopma4.vr09skup+'-'+vrudopma4.vr09porc
        Loop
    Other
        Loop
    Endcase
    Select vrudopma4
    If Atc(vr02vyrc+vr09skup+vr09porc,_kalkul)=0
* poznamenání identifikace výrobního úkolu, který se bude muset přepočítat podle KV
        _kalkul=_kalkul+vr02vyrc+vr09skup+vr09porc+Chr(13)
    Endif
* aktualizace naměřeného množství a ceny
    Replace vr14mn With _tcudopma.vr14mn
    Replace vr14cena With Round(vr14cj*vr14mn,2)
Endscan
Use In _tcudopma
If !Empty(_kalkul)
* přepočet podle KV všech výrobních úkolů, u kterých byly změněny vstupy/výstupy
    Select vrudoper
    _rc=Iif(Eof(),0,Recno())
    _frm.LockScreen=.T.
    =Alines(_p,_kalkul)
    For Each _iden In _p
        Select vrudoper
        Locate All For vr02vyrc+vr09skup+vr09porc=_iden
        If Found()
            Select vrudopma4
            Set Filter To vr02vyrc+vr09skup+vr09porc='&_iden'
* metoda zapis_kalkulaci formuláře výrobních úkolů přepočítává podle KV určený alias
            _frm.zapis_kalkulaci('vrudopma4')
            Select vrudopma4
            Set Filter To
        Endif
    Endfor
    If _rc<>0
        Go _rc In vrudoper
    Endif
    _frm.LockScreen=.F.
Endif
* zápis dat
_rt=bw_lock('U',_loc)<>'*'
=CursorSetProp('buffering',5,'vrudopma4')
If _rt And !Empty(_chybi_mereni)
    _rt=bw_hlase('QN',_caption,'Neznámá naměřená hodnota pro artikl, který by měl být měřen:'+Chr(13)+_chybi_mereni+;
        CHR(13)+Chr(13)+'Přesto ukončit operaci ?')
Endif
Return _rt

Procedure nacti_vrudopma4
Lparameters _this_spravce
Local _sp33cisdr,_sp33cisdpm,_sp33cisd,_sp33porad,_sp06idsubs,_sp07idtyp
_sp33cisdr=_this_spravce.sp33cisdr
_sp33cisdpm=_this_spravce.sp33cisdpm
_sp33cisd=_this_spravce.sp33cisd
_sp33porad=_this_spravce.sp33porad
_sp06idsubs=_this_spravce.sp06idsubs
_sp07idtyp=_this_spravce.sp07idtyp
Select vrudopma4
=Tablerevert(.T.)
=CursorSetProp('buffering',3)
=Requery()
Go Bott
=CursorSetProp('buffering',5)

Procedure technologicky_merit
Lparameters _sp61id,_sp60id
* Return Tool.sql_dotaz(....
* Return Inlist(_sp61id,'AAA','BBB',...)
Return .T.

ENDSCRIPT
Ing. Petr Filip 24.07.06


Harmonogram výroby

Harmonogram výroby
Byly provedeny tyto změny v harmonogramu výroby:

1/ zobrazení dne a jeho názvu
- v prvním sloupci je zobrazován datum - dříve datum a název dne
- ve třetím sloupci jsou zobrazovány dva prvé znaky názvu dne a číslo směny - dříve číslo směny
2/ je možné určit ikonu přesunu v harmonogramu parametrem programu BM Harmonogram->DragIcon
např. DragIcon=pointer.ico
Tento parametr určuje ikonu kurzoru myši použitou při přesunu položek harmonogranu.
Je možné použít ikonu umístěnou mimo program BM nebo ikonu uloženou v BM.EXE (drag2pg.ico, drag3pg.ico, pointer.ico, point13.ico, point14.ico ...).
3/ pro každou Technologickou operaci je možné určit její barvu v harmonogramu
4/ je-li na počítači instalována komponenta ndToolTip.ocx, potom je po pravém kliku v harmonogramu, při pohybu myší zobrazována bublina s informací o výrobním úkolu, na který právě myš ukazuje.
Ing. Petr Filip 27.06.06


Mzdy a sociální pojištění

Mzdy a sociální pojištění
Na Kartě pracovníka přidána záložka pro zadání Sociální pojišťovny (obdobně jako je na Kartě možnost zadání Zdravotní pojišťovny). Je totiž možné, aby v organizaci pracovali lidé s různými sociálními pojišťovnami. Přitom platí : Pokud pracovník nemá u sebe na Kartě uvedenu žádnou sociální pojišťovnu, pak se použije adresa z činnosti Parametry.

Číselník Zdravotní pojišťovny byl přejmenován na Zdravotní a sociální pojišťovny. Jsou zde oba druhy pojišťoven zároveň, ale jsou odlišeny typem.

Při Optimalizovaném výpočtu došlo ke změnám u zápisu adresáta na položkách I20000, I21000 a I31000. U položky I20000 je to hlavně z pomocných výpočetních důvodů. Došlo ke změně též v zaokrouhlení odvodu I31000 .

U zpracování typu jednotlivě (viz Parametry) dochází k takovýmto zaokrouhlením :
Pro každou skupinu pracovníků se stejnou sociální pojišťovnou uvedenou na kartě pracovníka - vznikne I31000 s adresátem dle sociální pojišťovny. Rozdíl součtu těchto I31000 a odvodu vypočítaného ze součtu I30000 se zapíše na adresáta dle sociální pojišťovny.

Pro skupinu pracovníků, která nemá na kartě uvedenu žádnou sociální pojišťovnu - vznikne I31000 s adresátem dle činnosti Parametry. Rozdíl součtu těchto I31000 a odvodu vypočítaného ze součtu I30000 se zapíše s adresátem dle činnosti Parametry.

U zpracování typu souhrnně (viz Parametry) dochází k takovýmto zaokrouhlením :
Za každou sociální pojišťovnu dojde k výpočtu I31000 ze součtu I30000.
Rozdíl součtu těchto I31000 o odvodu vypočítaného z celkového součtu I30000 se zapíše s adresátem dle činnosti Parametry.
Ing. Olga Smitková 16.06.06


Rozšíření aplikace BM

Rozšíření aplikace BM
součástí aplikace BM je COM objekt, který je určen zápis technologických dat do databáze BM.

Tento objekt je obsažen v programu BMCOM.EXE.
Instalace se provádí příkazem:
BMCOM.EXE /REGSERVER
Instalaci COM objektu je třeba provádět na každé stanici, kde je využíván.

Identifikace COM objektu: bmcom.bmdataobject

Metody:
connect - připojení k databázi BM pomocí spojení ODBC
Parametry:
dsn - název ODBC spojení
uid - jmého uživatele
pwd - heslo
Návratová hodnota:
true = úspěšné spojení

open - otevření kurzoru tabulky dat BM
Parametry:
tabulka - název tabulky dat v databázi BM
Návratová hodnota:
true = úspěšné otevření

add - přidání nového záznamu do kurzoru
Parametry:
tabulka - název tabulky dat v databázi BM otevřené metodou open
Návratová hodnota:
true = zápis do kurzoru byl proveden

setvalue - nastavení hodnoty atributu kurzoru
Parametry:
tabulka - název tabulky dat v databázi BM otevřené metodou open
atribut - název atributu
hodnota - nová hodnota atributu
Návratová hodnota:
true = zápis do kurzoru byl proveden

save - uložení změn všech změněných kurzorů v jediné transakci
Parametry:
-
Návratová hodnota:
true = zápis byl proveden

close - uzavření kurzoru
Parametry:
tabulka - název tabulky dat v databázi BM otevřené metodou open
Návratová hodnota:
true = kurzor byl uzavřen

jci - návrat jednoznačné časové identifikace
Parametry:
-
Návratová hodnota:
jednoznačná časová identifikace

getlasterror - zjištění textu popisujícího chybu posledního volání metody COM objektu
Parametry:
-
Návratová hodnota:
text popisující chybu nebo prázdný řetězec

Příklady použití COM objektu v jazyce Foxpro
Příklad zápisu do tabulky konstant:
LOCAL _data
_data=CREATEOBJECT('bmcom.bmdataobject')
IF NOT _data.connect('bmdata','uid','pwd')
WAIT WIND _data.getlasterror()
RETURN
ENDIF
_data.open('SPKONST')
_data.add('SPKONST')
_data.setvalue('SPKONST','sp73id','AAAAA')
_data.setvalue('SPKONST','sp33cisdpm','01')
_data.setvalue('SPKONST','sp73hodnot','hodnota')
_data.setvalue('SPKONST','sp73nazkon','Konstanta AAAAA')
_data.setvalue('SPKONST','sp73koment','')
_data.add('SPKONST')
….
_data.add('SPKONST')
….
IF NOT _data.save()
WAIT WIND _data.getlasterror()
RETURN
ENDIF

Příklad zápisu do tabulky vývěsky:
LOCAL _data
_data=CREATEOBJECT('bmcom.bmdataobject')
IF NOT _data.connect('bmdata','uid','pwd')
WAIT WIND _data.getlasterror()
RETURN
ENDIF
_data.open('VYUDALOS')
_data.add('VYUDALOS')
_data.setvalue('VYUDALOS','vy01',_data.jci())
_data.setvalue('VYUDALOS','vy01datum',DATE())
_data.setvalue('VYUDALOS','bw01uziv','LUSIYD')
_data.setvalue('VYUDALOS','bw01uziv1','LUSIYD')
_data.setvalue('VYUDALOS','sp00datzap',DATETIME())
_data.setvalue('VYUDALOS','vy01text','text')
_data.setvalue('VYUDALOS','vy01koment','')
_data.setvalue('VYUDALOS','ad01id','-')
_data.setvalue('VYUDALOS','ad11cisspo','01')
_data.setvalue('VYUDALOS','sp06idsubs','VYV')
_data.setvalue('VYUDALOS','sp07idtyp','opt121')
_data.setvalue('VYUDALOS','sp10idzak','-')
_data.setvalue('VYUDALOS','sp11idzak','-')
_data.setvalue('VYUDALOS','sp20idzak','-')
IF NOT _data.save()
WAIT WIND _data.getlasterror()
RETURN
ENDIF
Ing. Petr Filip 27.06.06


Spojené dokumenty

Spojené dokumenty
Pokud je v hlavním adresáři programu obsažen program PCT_DLL.DLL, potom je možné založit nový dokument připojený k objektu s obsahem obrázku aktuálně vloženého do clipboardu.
Po pravém kliku myší v okně spojených dokumentů objektu, je možné v tom případě vybrat volbu 'Uložit obrázek v clipboardu'. Následně je zobrazen formulář s obrázkem v clipboardu a po jeho schválení uživatelem, pokračuje zakládání dokumentu běžným způsobem tj. vstupem jeho vlastností.

Obrázek je ukládán ve formátu JPEG.
Ing. Petr Filip 27.06.06


Druh události smlouvy x druh operace

Druh události smlouvy x druh operace
Pro každý druh události smlouvy je možné definovat několik druhů operací, ve kterých výhradně je možné daný druh události smlouvy zadat.
Nastavení se projevuje při zadávání událostí smluv v operaci druhu, který :
a/ je takto uveden alespoň u jednoho druhu události smlouvy, potom je možné vybrat pouze druhy událostí smluv, které mají u sebe daný druh operace uveden
b/ není takto uveden u žádného druhu události smlouvy, potom je možné vybrat pouze ty druhy událostí smluv, které u sebe nemají žádný druh operace uveden
Ing. Petr Filip 15.05.06


Kontrola pravopisu

Kontrola pravopisu
Z okna pro vstup textu vyvolávaného na polích typu text (memo) klávesou F2 nebo pravým klikem po položce nebo jejím návěští je možné po pravém kliku nebo F2 vybrat nově také volbu Kontrola pravopisu.

Tato funkce vyžaduje na počítači instalovaný Word 2000.
Ing. Petr Filip 11.05.06


MZDY - minimální mzda a inval. důchod

MZDY - minimální mzda a inval. důchod
Do optimalizovaného výpočtu mezd byla doplněna reakce na minimální mzdu u pracovníků, kteří jsou invalidní a částečně invalidní.

U těchto pracovníků se totiž jejich příjem porovnává nikoliv s celou minimální mzdou, ale jen s 50% minimální mzdy v případě invalidního pracovníka nebo s 75% minimální mzdy v případě částečně invalidního pracovníka.

Nutná nastavení (pokud je neuděláte, nebude sice výpočet padat, ale nebude reagovat na tuto odlišnost) :

1)
do INFORMAČNÍ CENTRUM - ALGORITMY A PARAMETRY - Sady systémových konstant - do MZDLEG přidat dvě položky
mz27inval Procento min. mzdy při inval. důch typ číslo velikosti 3 (hodnota 50%) a
mz27cinval Procento min. mzdy při část. inval. důch typ číslo velikosti 3 (hodnota 75%)

2)Pomocí překladu textů přeložit text -,starobní,invalidní,sirotčí,vdovský/vdovecký na text -,starobní,invalidní,sirotčí,vdovský/vdovecký,částečně invalidní

3) V Kartě pracovníka - druhá záložka nastavit příslušným pracovníkům typ důchodu (atribut mz01duchty)

poznámka :
Úprava bude mít vliv na hlášení o minimální mzdě MIN001. Zda má vliv i na hlášení MIN002 není jisté.

MIN001 - hlášení o doplatku mzdy do výše minimální mzdy - důchod má vliv

MIN002 - hlášení o odvodu ZP - důchod asi nemá vliv ????
Ing. Olga Smitková 10.05.06


Plnění úkolu projektu x řízení procesu

Plnění úkolu projektu x řízení procesu
V BM je možné zadáním plnění projektového úkolu vybraného druhu řídit hlavní proces, ve kterém je toto plnění obsaženo.

Proto byla doplněna funkčnost BM:
1/ pro každý druh projektového úkolu je možné definovat několik druhů operací, ve kterých výhradně je možné daný druh úkolu zadat
2/ pro každý druh plnění projektového úkolu je možné definovat několik dynamických transformací, které se dynamicky založí při ukončení operace, pokud se v ní vyskytnou události daného druhu plnění

Nastavení ad.1/ se projevuje při zadávání událostí projektových úkolu v operaci druhu, který :
a/ je takto uveden alespoň u jednoho druhu projektového úkolu, potom je možné vybrat pouze druhy projektových úkolů, které mají u sebe druh operace uveden
b/ není takto uveden u žádného druhu projektového úkolu, potom je možné vybrat pouze ty druhy projektových úkolů, které u sebe nemají žádný druh operace uveden

Nastavení ad.2/ se projevuje při ukončování operace plnění projektového úkolu:
a/ vytvoří se vazba mezi ukončovanou operací a určeným uzlem (resp.uzly) hlavního procesu (vazba se nevytváří, pokud uzel v hlavním procesu neexistuje)
b/ pokud vazba mezi těmito uzly již existuje, modifikuje její vlastnosti (tj. Transformace, Vazba, Rozlišení, Pořadí, Rozlišení, Předkontace)
c/ při zadávání plnění projektového plnění ze stránky informačního panelu zajišťuje vytvoření vazby knihovna IPSCRU, která spouští tímto způsobem propojený uzel, pokud je vlastnost dynamické vazby Vazba=Běžná

Ing. Petr Filip 15.05.06


Projektové úkoly

Projektové úkoly
Ve formuláři pro zadávání projektových úkolů se na záložce 'Připomenutí' přímo vstupují události komponenty 'Zprávy' spojené s odpovídajícím úkolem.

U druhu projektového úkolu je možné nastavit vlastnost 'Připomenutí řešiteli', která způsobí to, že při založení nového úkolu daného druhu automaticky vznikne 'Připomenutí' tj. připojená zpráva směrovaná na uživatele, který je řešitelem tohoto nového úkolu.
Zpráva nevzniká, pokud je tímto uživatelem uživatel, který zapisuje úkol (tj. dává úkol sám sobě).
Ing. Petr Filip 15.05.06


Obraty skladu - VČ

Obraty skladu - VČ
ve formuláři 'Obraty skladu - VČ' je možné nově zadat výběr:
- druh hodnoty
- poslední obrat - překryvný seznam - Neurčeno / Pouze - při volbě Pouze se vyberou jenom poslední obraty v zadaném období

Dále byl změněn výběr při nevyplněném datu do a do:
- datum od - vybíralo se k 1.1. aktuálního roku - nyní k 1.1.1900
- datum do - vybíralo se k 31.12. aktuálního roku - nyní k 1.1.2100
Ing. Petr Filip 14.03.06


Otevřená období komponent

Otevřená období komponent
Pokud není pro komponentu definováno otevřené období, potom není povolen vstup událostí s datem mimo interval 1.1.1980 až 1.1.2100.

Pozn.:
Důsledkem toho je, že pro komponenty, ve kterých se mohou vyskytnout události s menším datem (spravovaný majetek, odepisovaný majetek, ....) je třeba definovat otevřené období komponenty.
Ing. Petr Filip 14.03.06


Sady systémových konstant

Sady systémových konstant
Pro definování a uchování hodnot konstant potřebných pro funkce programu BM slouží činnost 'Sady systémových konstant'.
Formulář této činnosti se vyvolává z hlavního menu programu INFORMAČNÍ CENTRUM - ALGORITMY A PARAMETRY - Sady systémových konstant.

V tomto formuláři se zadává:
Na záložce Sady
- identifikace sady konstant - 6 znaků
- název sady konstant
- druh sady konstant - určuje přístupová práva pro definování sady
- verze - numerická 8,3 - pro určení aktuálnosti sady - uvádí se obvykle rok a měsíc např. 2006.030 v březnu roku 2006
- poznámka
- aktualizace - datum a čas aktualizace záznamu
Na záložce Konstanty (zde se definuje struktura sady konstant)
- identifikace konstanty - 10 znaků
- název konstanty
- druh konstanty - určuje přístupová práva uživatele pro nastavení hodnoty konstanty
- typ konstanty - překryvný seznam - Text / Číslo / Datum
- pořadí zobrazení konstanty při zadávání hodnot sady konstant
- délka - pro typ Text / Číslo
- desetiny - pro typ Číslo
- poznámka
- aktualizace - datum a čas aktualizace záznamu

Hodnoty sady konstant se zadávají z formuláře Sady systémových konstant po stisku klávesy F9 nebo z hlavního menu programu INFORMAČNÍ CENTRUM - ALGORITMY A PARAMETRY - HODNOTY KONSTANT, kde se zobrazují všechny uživateli dostupné sady konstant.
Zadává se na záložce Hodnoty konstant
- konstanta - překryvný seznam naplněný seznamem konstant definovaných pro danou sadu
- datum platnosti od
- hodnota konstanty podle typu vybrané konstanty
- poznámka
- aktualizace - datum a čas aktualizace záznamu
Pomocí nastavení výběru na výběrové záložce je možné vybírat hodnoty konstant k různému datu platnosti.

Sady konstant je možné exportovat do balíčku z formuláře Sady systémových konstant. Přitom je do balíčku exportována jak definice sady konstant, tak její hodnoty.
Při importu balíčku dojde k přepisu dříve zadaných definic konstant resp. jejich hodnot podle u nich uvedeného data a času aktualizace.

V tomto okamžiku je programem BM používána jediná sada systémových konstant, a to v komponentě Mzdy nazvaná 'Legislativní konstanty mezd', nicméně pro implementaci je možné definovat vlastní sady konstant a umisťovat příslušné položky menu INFORMAČNÍ CENTRUM - ALGORITMY A PARAMETRY - HODNOTY KONSTANT do uživatelského menu.

Pro použití hodnot konstant v SQL dotazech je možné použít uložené procedury:
Procedura 'PASYSVAL hodnota - text' - zjišťuje hodnotu textové konstanty
Parametry:
- identifikace sady systémových konstant
- identifikace konstanty
- datum, ke kterému se vybere platná konstanta - nepovinný parametr - není-li uveden vybírá se podle aktuálního data
Procedura vrací textovou hodnotu, není-li konstanta k datu nalezena vrací NULL.

Procedura 'PASYSVAL hodnota - cislo' - zjišťuje hodnotu číselné konstanty
Parametry:
- identifikace sady systémových konstant
- identifikace konstanty
- datum, ke kterému se vybere platná konstanta - nepovinný parametr - není-li uveden vybírá se podle aktuálního data
Procedura vrací numerickou hodnotu, není-li konstanta k datu nalezena vrací NULL.

Procedura 'PASYSVAL hodnota - datum' - zjišťuje hodnotu datumové konstanty
Parametry:
- identifikace sady systémových konstant
- identifikace konstanty
- datum, ke kterému se vybere platná konstanta - nepovinný parametr - není-li uveden vybírá se podle aktuálního data
Procedura vrací datumovou hodnotu, není-li konstanta k datu nalezena vrací NULL.

Příklad:
... WHERE .... AND TABULKA.cislo=%%%."PASYSVAL hodnota - cislo"('SADA','konstanta7',current date-30) AND ....

Pro použití hodnot konstant ve skriptech v jazyce Foxpro je možné použít objekt inicializovaný programem PA0119OB a jeho metody:
Metoda LOAD_DATA
Parametry:
- identifikace sady systémových konstant
- datum, ke kterému se vyberou platné konstanty - nepovinný parametr - není-li uveden vybírá se podle aktuálního data
Metoda vytvoří v objektu atributy se identifikacemi a hodnotami konstant určené sady.
Vrací logickou hodnotu .T. (TRUE) v případě, že byly hodnoty všech definovaných konstant naplněny do atributů objektu, jinak zobrazí chybové hlášení a vrátí hodnotu .F. (FALSE).
Vlastnost objektu PARAM_VERZE je metodou nastavena na číslo verze sady (používá se pro zjištění aktuálnosti sady).

Příklad:
LOCAL _o
_o=PA0119OB()
IF NOT _o.load_data('MZDLEG',DATE())
RETURN
ENDIF
IF _o.param_verze<2006.010
DO bw_hlase WITH '!','NAČTENÍ SADY','Sada konstant MZDLEG není aktuální.'+CHR(13)+;
'Importuje aktuální balíček s touto sadou.'
RETURN
ENDIF
? 'Odvod SP zaměstnanec=',_o.mz27spzam
? 'Odvod SP organizace =',_o.mz27sporg

Metoda GET_VALUE
Parametry:
- identifikace sady systémových konstant
- identifikace konstanty
- datum, ke kterému se vybere platná konstanta - nepovinný parametr - není-li uveden vybírá se podle aktuálního data
Vrací hodnotu určené konstanty z určené sady systémových konstant k datu.
Není-li konstanta nalezena vrátí hodnotu .F. (FALSE).

Příklad:
? hodnota_mz27spzam()

PROCEDURE hodnota_mz27spzam
LOCAL _o
_o=PA0119OB()
RETURN _o.get_value('MZDLEG','mz27spzam',DATE())
Ing. Petr Filip 14.03.06


Volné karty

Volné karty
umožňují definovat práva přístupu k jednotlivým atributům volné karty

Na záložce Karty se definuje:
.
.
Správce - překryvný seznam - vybírá se ze seznamu druhů implementačních rozšíření - určuje právo uživatele ke správě (definování) volné karty
Druh - překryvný seznam - vybírá se ze seznamu druhů volných karet - určuje právo uživatele pro přístup k datům volné karty - tj. Žádné / Čtení / Zápis
.
.

Na záložce Atributy volné karty se definuje:
.
.
Druh - překryvný seznam - vybírá se ze seznamu druhů volných karet - určuje právo uživatele pro přístup k danému atributu volné karty - tj. Žádné / Čtení / Zápis
.
.

K tabulce volné karty je naprogramován trigger, který při změně druhu volné karty (v tabulce SPVOLST) provádí změnu druhu těch atributů volné karty (v tabulce SPVOLSTA), které mají uveden stejný druh jako původní druh volné karty.
Ing. Petr Filip 20.03.06


Volné karty

Volné karty
Na volných kartách je možné také zobrazovat videoklipy uložené jako dokumenty BM nebo externí soubory (jejich název může být odvozen např. podle identifikace artiklu).
Popis implementace byl doplněn v popisu novinky z 24.2.2006 'Volné karty'.
Ing. Petr Filip 10.03.06


Definice maker

Definice maker
Pod pojmem makro rozumíme definici substituce, podle které se má v textu obsahujícím název makra (volání makra) nahradit toto volání výrazem uvedeným v definici makra.
Makro může mít definováno parametry, podle jejichž hodnot, uvedených ve volání makra, má být výraz před substitucí upraven.
Makra se využívají pro definování často opakovaných textů nebo pro překlad textů do uživatelsky srozumitelné formy.

Makra je možné používat:
1/ v Metapředlohách výstupu - vlastnosti Podmínka a Tiskárna na záložce Předlohy v metapředloze
2/ v atributech Volné karty - vlastnosti Inicializace, Validace a Text popisující atributy třídy překryvný seznam resp. zaškrtávací políčko
3/ v Informačních panelech - vlastnosti SQL
4/ v Obecných výběrech - proměnné výběru typu Makro
5/ v Označování výrazem - výraz (používají stejná makra jako v obecných výběrech)

Na první záložce formuláře definice makra se uvádí:
- identifikátor definice makra
- název makra - nesmí obsahovat mezeru
- typ - překryvný seznam - specifikuje typ hodnoty makra - uplatňuje se pro 2/ - typ logický se nabízí pro vlastnost Validace, ostatní typy pro vlastnosti Validace a Text popisující atributy třídy
- template - vzor skutečných parametrů makra, který bude předplněn při výběru makra uživatelem
- proměnné - překryvný seznam Ano/Ne - Ano = parametry jsou proměnné jazyka SQL nebo proměnné programového kódu, tzn. do výsledného textu zpracovaného makra má být přenesen jejich text bez transformace (používá se pro 2/ a 3/)
- výraz - výraz v jazyce SQL (pro 3/,4/ a 5/) nebo výraz v jazyce Foxpro (pro 1/ a 2/ kromě Validace) nebo kód v jazyce Foxpro (pro 2/ v atributu validace)
- from - doplnění SQL dotazu v části FROM (uplatňuje se pouze pro 5/)
- poznámka - libovolný text

Na záložce parametry makra se uvádí:
- pořadí parametru
- název parametru
- typ parametru - Znakový / Numerický / Datumový / Časový / Vložený text
- Délka hodnoty parametru (pro typ parametru=Znakový / Numerický)
- Počet desetinných míst (pro typ parametru=Numerický)

Při zpracování textu, ve kterém je obsaženo existující makro nahradí BM všechny výskyty tohoto makra v tomto textu upraveným výrazem definice makra.
Ve výrazu definice makra přitom vyhledává parametry makra a nahrazuje je podle skutečných hodnot uvedených ve vyvolání makra.
Parametry makra jsou ve výrazu makra uváděny ohraničené v hranatých závorkách a při úpravě výrazu makra jsou nahrazovány:
- konstantní hodnotou skutečného parametru ve formátu SQL (proměnné=Ne a Znakový / Numerický / Datumový / Časový)
- nebo hodnotou skutečného parametru bez transformace (proměnné=Ne a typ parametru=Vložený text)
- nebo textem skutečného parametru (proměnné=Ano)

Ve výrazech maker je možné uvádět text $$$, který bude nahrazen názvem databázové tabulky, jejíž obsah je odpovídajícím formulářem zobrazován.

Ve výrazu makra je možné uvádět jiná makra, ale přitom je třeba dbát, aby nedošlo k zacyklení tj., aby makro tímto způsobem přímo nebo nepřímo odkazovalo samo na sebe.

Příklady:
1/ formulář - Adresát
1a/ makro pro vyhledávání tuzemských adresátů
- název makra - Tuzemec
- template - neuveden
- výraz - ADADR.dp04tuzzah=1
- parametry - neuvedeny
1b/ makro pro vyhledávání adresátů s textem v názvu
- název makra - Název_obsahuje
- template - '?'
- výraz - $$$.ad01adsat LIKE '%[OBSAHUJE]%'
- parametry - OBSAHUJE typ=Vložený text
Užití těchto maker např.:
NOT Tuzemec() AND Název_obsahuje('kopyto')
vytvoří část SQL dotazu
NOT ADADR.dp04tuzzah=1 AND ADADSAT.ad01adsat LIKE '%kopyto%'

2/ formulář - Události obchodu
2a/ makro pro vyhledání událostí s volitelným typem zdanitelného plnění
- název makra - Typ_ZDP
- template - '?'
- výraz - $$$.dp03id=[TZDP]
- parametry - TZDP typ=Znakový, Délka=3
2b/ makro pro vyhledání událostí s typem zdanitelného plnění = základní sazba
- název makra - Typ_ZDP_základní
- template - neuveden
- výraz - Typ_ZDP('ZA1')
- parametry - neuvedeny
2c/ makro pro vyhledání událostí s datem dodání v intervalu
- název makra - Dodání_od_do
- template - {1.1.2006},{31.12.2006}
- výraz - $$$.ob02datdod BETWEEN [D1] AND [D2]
- parametry - D1 typ=Datumový a D2 typ=Datumový
Užití těchto maker např. :
(Typ_ZDP('XX') OR Typ_ZDP_základní()) AND Dodání_od_do({2.5.2006},{8.12.2006})
vytvoří část SQL dotazu
(OBUDAL.dp03id='XX ' OR OBUDAL.dp03id='ZA1' ) AND OBUDAL.ob02datdod BETWEEN '2006/05/02' AND '2006/12/08'
Ing. Petr Filip 20.02.06


Design formulářů implement. rozšíření

Design formulářů implement. rozšíření
při úpravě vzhledu formulářů v činnostech, ve kterých definuje implementátor vstupní formulář je možné po pravém kliku klávesou myši na atributu určit jeho rozměry.
Je možné určit šířku atributů třídy textové pole, překryvný seznam , u atributů typu Textové, Multimediální nebo Makro je možné navíc určit jejich výšku.

Tímto způsobem je možné měnit vzhled vstupních formulářů v činnostech:
- Volné karty
- Obecné výběry
- Šablony
- Importy/Exporty dat
- Dotazy výkazů
Ing. Petr Filip 20.02.06


Formulář uživatelů programu

Formulář uživatelů programu
byl doplněn o výběrovou záložku
Ing. Petr Filip 06.02.06


Ikony uložené v BM.EXE

Ikony uložené v BM.EXE
BM.EXE v sobě mj. obsahuje zabalené ikony (soubory s příponou ICO a BMP).
Tyto ikony je možné použít jako ikony předloh výstupu, činností hlavního menu programu, nabídek, obecných stromů nebo informačních panelů.
Při definování nabídek a seznamu ikon při vytváření obecných stromů resp. informačních panelů je dostupný po pravém kliku myší na příslušné vlastnosti prostřednictvím menu seznam všech ikon obsažených v BM.EXE (BM.EXE ve verzích pod Visual Foxpro 8 nebo vyšší včetně obrázku ikony).
Ing. Petr Filip 27.02.06


ISBM - Internet - PDA

ISBM - Internet - PDA
V ISBM je řešen mj. přístup mobilních zařízení typu PDA pomocí internetu.

Ve vlastnostech vrcholových uzlů WEB menu, je možné určit alternativní uzel WEB menu v překryvném seznamu (návěští Pro PDA:).
V tomto seznamu je možné vybírat z listových uzlů WEB menu odkazující na stránku informačního panelu (adresa #INFPAGE [identifikace stránky]).
Při přihlašování PDA rozpozná WBM, že se jedná o zařízení typu WAP a vytvoří výstup podle tohoto alternativního uzlu.
Zobrazované stránky informačních panelů pro PDA jsou upraveny tak, že ve stránce není obsaženo standarní záhlaví stránky a hypertextové odkazy na stránky jsou zobrazovány tak, aby zabíraly na obrazovce méně prostoru.
Ing. Petr Filip 24.02.06


Mzdy - mzdové položky Odvod

Mzdy - mzdové položky Odvod
Do činnosti DEFINICE - POLOŽKY MEZD - Odvody

L33000 - Loňský nárok
L34000 - Loňská sleva
L35000 - Loňský bonus

Zadání těchto nových položek do činnosti Odvody vám umožní nastavit údaje od jiného zaměstnavatele (pracovník pracoval část roku u jiného zaměstnavatele a část roku u toho, který zpracovává roční zúčtování) a tak budou tyto údaje zahrnuty do ročního zúčtování.
Ing. Olga Smitková 15.02.06


Mzdy - šablona mz0048 upravena

Mzdy - šablona mz0048 upravena
dne 16.2.06
Byla upravena šablona na výstupu mezd - mz048 - Mzdy podrobně - UC i PL . Změna v části UC - do vzniklé události doplněn adresát.
Ing. Olga Smitková 20.02.06


Obecné výběry

Obecné výběry
Typ proměnné výběru 'Makro' slouží k definování vstupního textového pole pro sestavení podmínky výběru.
Po vyvolání výběru má uživatel možnost vybírat předdefinovaná makra v menu po pravém kliku myší na tomto poli.
Kromě výběru makra do sestavované podmínky má uživatel po pravém kliku myší na poli typu 'Makro' ukládat (odstraňovat) a následně vybírat vzory sestavených podmínek .
Každý uživatel si takto může vytvářet své vlastní soubory vzorů sestavených podmínek (tabulka pro uložení těchto vzorů je sdílena s formulářem Označování výrazem).
Makra připravuje pro uživatele implementátor systému položkou menu Volby -> Definice maker formuláře pro definování obecných výběrů.

Použití obecných výběrů s proměnnými výběru typu makro je možné pouze ve verzích BM pod Visual Foxpro 8 nebo vyšší.
Ing. Petr Filip 20.02.06


Překlad popisek

Překlad popisek
Ve formulářích pro definování implementačních rozšířeních (volných karet, obecných výběrů, importů/exportů dat, šablon, výkazů, metapředloh výstupu) je možné vyvolat funkci menu ''Volby' - 'Překlad popisek' .
Překlad názvů předloh výstupu se provádí volbou 'Překlad popisek' z menu po pravém kliku v seznamu předloh.
Popiskou se rozumí návěští vstupovaných resp. zobrazovaných atributů, text stavového řádku, text zaškrtávacího políčka, seznam hodnot překryvného seznamu, název implementačního rozšíření.

Funkcí 'Překlad popisek' je vyvolán formulář, ve kterém se vstupuje:
- Jazyk
- Typ textu - určuje co je textem překládáno - Návěští / Stavový řádek / Text pro zaškrtávací políčko nebo překryvný seznam / Chybové hlášení
- Text - přeložený text
- Poznámka - libovolný text

Překlady názvů implementačních rozšíření se provádějí samostatnými funkcemi menu 'Volby' :
- Překlad popisek - název volné karty
- Překlad popisek - název obecného výběru
- Překlad popisek - název šablony
- Překlad popisek - název importu/exportu
- Překlad popisek - název metapředlohy
- Překlad popisek - název výkazu

Přeložené názvy se uplatňují při práci s BM v cizím jazyce :
- v menu 'Obecné' (volné karty a obecné výběry) - tyto překlady mají vyšší prioritu než překlady v 'Definování nabídek'.
- v překryvných seznamech obecných výběrů (Výběr) na výběrových záložkách formulářů
- ve výběrech pro spuštění (šablony a import/export dat).

Ing. Petr Filip 09.02.06


Překlad textů

Překlad textů
přeložené texty popisek formulářů jsou ukládány mimo SQL databázi implementace BM nebo v SQL databázi implementace BM.
O tom rozhoduje nastavení programu BM - Preferences->Slovnik_SQL.

Při nastavení Preferences->Slovnik_SQL
- 0 (implicitní) - preložené texty jsou ukládány v souborech SLOVNIK\SLOV_XXX.DBF a SLOVNIK\SLOV_XXX.FPT a SLOVNIK\SLOV_XXX.CDX, kde XXX identifikace jazyka
- 1 - preložené texty jsou ukládány do tabulky BWSLOVNI v SQL databázi

Ve formuláři SYSTÉM->Překlad textů je možné provádět export a import přeložených textů do tabulky BWSLOVNI funkcemi menu Volby:
- Export slovníku textů
- Import slovníku textů - je možné importovat soubory vytvořené exportem nebo soubory původně uložené mimo databázi (SLOVNIK\SLOV_XXX.DBF)
Obě tyto funkce jsou dostupné při nastavení Preferences->Slovnik_SQL=1.
Ing. Petr Filip 10.02.06


Strom hlavního procesu

Strom hlavního procesu
ve stromu hlavního procesu se zobrazuje informace o tom, kdo operaci zahájil a ukončil tímto způsobem:
1/ operace byla zahájena a nebyla dosud ukončena
tvar -(Jméno_uživatele datum_a_čas_zahájení)
např.:
(Zahájil František 08.01.2006 12:01:36)
2/ operace byla zahájena a ukončena stejným uživatelem v jednom dni
tvar -(Jméno_uživatele datum_a_čas_zahájení - čas_ukončení)
např.:
(Zahájil František 08.01.2006 11:12:16 - 11:12:20)
3/ operace byla zahájena a ukončena stejným uživatelem v jiném dni
tvar -(Jméno_uživatele datum_a_čas_zahájení - datum_a_čas_ukončení)
např.:
(Zahájil František 08.01.2006 10:07:48 - 11.01.2006 07:18:45)
4/ operace byla zahájena a ukončena jiným uživatelem v jednom dni
tvar -(Jméno_uživatele datum_a_čas_zahájení - čas_ukončení Jméno_uživatele)
např.:
(Zahájil František 03.01.2006 14:10:23 - 11:12:20 Ukončil Josef)
5/ operace byla zahájena a ukončena jiným uživatelem v jiném dni
tvar -(Jméno_uživatele datum_a_čas_zahájení - datum_a_čas_ukončení Jméno_uživatele)
např.:
(Zahájil František 07.01.2006 15:03:11 - 08.01.2006 17:11:49 Ukončil Josef)

Komplexní informaci o stavu operace je možné získat výběrem volby 'Vlastnosti operace' z menu po pravém kliku na uzlu stromu.
Ing. Petr Filip 06.02.06


Volné karty

Volné karty
na volné kartě je možné zobrazovat obrázky nebo videoklipy v atributech typu 'Multimediální'.

Atributy volné karty typu 'Multimediální' se používají:
1/ s nevyplněnou vlastností 'Inicializace' - obrázek nebo videoklip je ukládán v tabulce volné karty
2/ s vyplněnou vlastností 'Inicializace' výrazem uvedeným znakem '=' - obrázek není uložen v tabulce volné karty - na volné kartě je zobrazován obrázek ze souboru, jehož název je určen vyhodnocením výrazu této vlastnosti
3/ s vyplněnou vlastností 'Inicializace' výrazem uvedeným znakem '=' a uvedeným textem AVI v popisu třídy atributu - videoklip není uložen v tabulce volné karty - na volné kartě je zobrazován videoklip ze souboru, jehož název je určen vyhodnocením výrazu této vlastnosti

Výraz vlastnosti 'Inicializace' je vyhodnocován dynamicky při přezobrazování volné karty, takže se při pohybu v záznamech formuláře, ke kterému je karta připojena, může docházet ke změně zobrazovaného obrázku resp. videoklipu.
Multimediální atributy v vyplněnou vlastností 'Inicializace' mohou mít uveden ve vlastnosti 'Validace' kód v jazyce Foxpro, který má být prováděn při pravém kliku myší na obrázku resp. pravém okraji videoklipu.

Jsou připravena makra, které usnadňují vytváření volných karet pro zobrazování multimédií, které jsou uloženy jako dokumenty BM připojené k objektům BM.
Rozhodnutí o tom zda budou obrázky objektů ukládány v tabulce volné karty (ad 1/) nebo jako dokumenty BM (ad 2/) ovlivní implementaci.
Obrázky objektů BM implementované způsobem ad 1/ je možné prohlížet prostřednictvím volné karty a tisknout klasickou předlohou výstupu, další možnosti nejsou.
Obrázky objektů BM implementované způsobem ad 2/ (s využitím maker) je možné tisknout v předlohách výstupu typu Excel (tisk v klasické předloze výstupu je obtížný), použít s jinými nástroji Windows (např. publikovat na internetu), zahrnout do řízení procesu (např. při pořizování přijaté faktury přinutit uživatele připojit k procesu oskenovanou kopii přijaté faktury).

--------------------------------------------------------------------------------
Pro zobrazování dokumentů BM, které jsou svým charakterem obrázky resp.videoklipy, připojené k objektům BM, jsou připravena makra pro použití ve vlastnostech 'Inicializace' a 'Validace' multimediálních atributů volných karet.

Pro vlastnost 'Inicializace' makro - DOKUMENT_OBRAZEK_OBJEKTU.
Substitucí makra vznikne výraz, který vrací název souboru obsahujícího obrázek, který je uložen v dokumentu připojeného k objektu BM.
Protože k objektu BM může být připojeno více dokumentů, z nichž pouze některé jsou obrázky, uvádí se parametrem tohoto makra, jakého druhu dokumentu a jakou předlohu dokumentu může mít připojený obrázek.
Jediným parametrem makra je identifikátor obecné předkontace, které by měly mít uvedeny hodnoty:
- VK0001 - seznam druhů dokumentů
- VK0002 - seznam předloh výstupu
Na volné kartě je potom zobrazován obrázek uložený v prvním nalezeném připojeném dokumentu, který je druhu podle hodnoty VK0001 a má předlohu výstupu podle hodnoty VK0002.
Dokument s obrázkem nebo videoklipem přitom může být uložen v databázi BM nebo uložený externě.

Pro vlastnost 'Validace' makro - DOKUMENT_OBRAZEK_RIGHTCLICK
Toto makro je možné použít pouze v případě, že je ve vlastnosti 'Inicializace' uvedeno volání makra DOKUMENT_OBRAZEK_OBJEKTU.
Substitucí makra vznikne kód v jazyce Foxpro, který po pravém kliku klávesou myši na obrázku resp. pravém okraji videoklipu zobrazí menu:
1/ v případě, že dokument není k objektu BM připojen:
1a/ Založit dokument - obrázek
- volbou uživatel vybírá soubor obrázku s příponou podle hodnoty obecné předkontace VK0001 (identifikace této překontace je dána voláním makra DOKUMENT_OBRAZEK_OBJEKTU)
- následně vstupuje vlastnosti nově zakládaného dokumentu s předplněným názvem podle prvého parametru makra a s předplněným způsobem uložením dokumentu podle druhého parametru makra (0=předplňovat ukládání do databáze, 1=předplňovat externí uložení na disk), přitom vybírá druh dokumentu podle VK0001 a předlohu dokumentu podle VK0002 a odpovídající přípony

2/ v případě, že je dokument k objektu BM připojen:
2a/ Vyměnit dokument - obrázek
- volbou uživatel vybírá soubor obrázku s příponou podle předlohy daného dokumentu, kterým bude nahrazen obrázek uložený v dokumentu BM
2b/ Opravit dokument - obrázek
- volbou je vyvolána oprava dokumentu
2c/ Uložit jako ...
- volba pro uložení kopie obrázku na disk
2d/ Kopírovat
- provede kopii souboru do schránky Windows (obrázek je potom možné např. vložit do dokumentu Wordu, jako přílohu e-mailu, ...)
2e/ Vlastnosti dokumentu
- volba pro prohlížení a opravy vlastností dokumentu BM
Volby 2a/ je podmíněna právem zápis uživatele k druhu daného dokumentu.

Pro vlastnost 'Inicializace' makro - EXTERNI_OBRAZEK
Makro se používá ve vlastnostech 'Inicializace' atributů typu 'Multimediální' volných karet.
Substitucí makra vznikne výraz, který vrací název souboru obsahujícího obrázek resp. videoklip podle parametrů makra.
Parametry:
1/ adresářová cesta k souboru
2/ název souboru bez přípony
3/ přípona souboru - může být uvedena souborová maska např. '*'
Makro je třeba uvádět s prefixem SCRIPT.
Příklad:
=script externi_obrazek('mediup\pict\',[sp60id],'*')

Pro vlastnost 'Validace' makro - EXTERNI_OBRAZEK_RIGHTCLICK
Makro se používá ve vlastnostech 'Validace' atributů typu 'Multimediální' volných karet.
Toto makro se většinou používá při použití makra EXTERNI_OBRAZEK uvedeného ve vlastnosti 'Inicializace'.
Substitucí makra vznikne kód v jazyce Foxpro, který po pravém kliku klávesou myši na obrázku zobrazí menu:
1/ Kopírovat - provede kopii souboru do schránky Windows (obrázek je potom možné např. vložit do dokumentu Wordu, jako přílohu e-mailu, ...)
Příklad:
externi_obrazek_rightclick()

Příklady:
1/ Procesy
Karta - FOTO
Název volné karty - Foto dokladu procesu
Velikost - Oběma směry horizontálně i vertikálně
Posuvník - Oba horizontální i vertikální
Autor - Nezobrazovat na volné kartě
Atribut - PICT
Typ - Multimediální
Inicializace - =dokument_obrazek_objektu('VKIM01')
Validace - dokument_obrazek_rightclick([sp33cisdr]+'-'+[sp33cisdpm]+'-'+[sp33cisd] , 0)
Přizpůsobení oknu - Ne
Šířka - 700
Výška - 1000

2/ Operace
Karta - FOTO
Název volné karty - Foto dokladu operace
Velikost - Oběma směry horizontálně i vertikálně
Posuvník - Oba horizontální i vertikální
Autor - Nezobrazovat na volné kartě
Atribut - PICT
Typ - Multimediální
Inicializace - =dokument_obrazek_objektu('VKIM02')
validace - dokument_obrazek_rightclick('['+trim(iif(empty([sp06idsubs]),[sp07idtyp],lower([sp06idsubs]+'-'+[sp07idtyp])))+'] '+[sp33cisdr]+'-'+[sp33cisdpm]+'-'+[sp33cisd] , 0)
Přizpůsobení oknu - Ne
Šířka - 700
Výška - 1000

3/ Artikl (SP)
Karta - FOTO
Název volné karty - Foto artiklu
Velikost - Oběma směry horizontálně i vertikálně
Posuvník - Žádný
Autor - Nezobrazovat na volné kartě
Atribut - PICT
Typ - Multimediální
Inicializace - =dokument_obrazek_objektu('VKIM03')
Validace - dokument_obrazek_rightclick([sp61id]+'-'+[sp60id] , 0)
Přizpůsobení oknu - Obojí
Šířka - není podstatná
Výška - není podstatná

Ing. Petr Filip 24.02.06


Evidenční list důchodového pojištění

Evidenční list důchodového pojištění
Aktuální verze řešení odesílání RELDP na ČSSZ umožňuje zachytávat změny RELDP.
Tato funkčnost je určena především pro evidenční listy odesílané při ukončení pracovního poměru (povinnost odeslat evidenční list je do 8 dní po ukončení pracovního poměru a přitom mzdy jsou zpracovány až na začátku druhé dekády následujícího měsíce).

V novém řešení se informace pro vyhodnocení změn ukládá spolu s vazbou mezi dokumentem hlášení a pracovním poměrem (do souboru BWOBJECX).
V souvislosti s tím je součástí balíčku pro zpracování RELDP a REGPJ externí příkaz, který vytváří obsah souboru BWOBJECX. Tento externí příkaz se automaticky vyvolá při vytváření prvního dokumentu hlášení RELDP novou verzí programu.

Při vytváření RELDP se kromě volby 'Generovat opravná hlášení' může také zaškrtnout volba 'Pouze změněných RELDP'. V tom případě jsou do dokumentu zahrnuty pouze RELDP těch pracovních poměrů, které mají jiný obsah než naposledy vytvořený RELDP v zadaném roce.

Dále se změnila funkčnost volby 'Generovat opravná hlášení':
1/ nezaškrnuté - do dokumentu jsou zahrnuty RELDP pracovních poměrů, pro které nebyl dosud RELDP v zadaném roce vytvořen
2/ zaškrnuté - do dokumentu jsou zahrnuty pouze opravné RELDP (změněné nebo také nezměněné podle volby 'Pouze změněných RELDP')
Ing. Petr Filip 09.01.06


Obecné výběry

Obecné výběry
Hodnoty proměnných obecného výběru formuláře jsou dostupné v objektu:
THISFORM.OBEC_VYBER.VAR
který obsahuje vlastnosti odpovídající názvům a hodnotám proměnných aktuálního obecného výběru.

Př.: THISFORM.OBEC_VYBER.VAR.DATUM
Ing. Petr Filip 16.01.06


Přehled přihlášených uživatelů

Přehled přihlášených uživatelů
v přehledu přihlášených uživatelů přibyl sloupec 'Spojení', ve kterém je zobrazován název ODBC spojení a název počítače, na kterém uživatel pracuje.

Poznámka pro správce systému:
při instalaci nové verze programu zrušte soubor \BMSQL\SYST\ADMIN\BWCONNEC.DBF, jinak bude obsah tohoto sloupce zobrazován na 10 znaků.
Ing. Petr Filip 16.01.06


Selektory

Selektory
při vyvolání formuláře pro vstup obchodního,organizačního a technicko-věcného selektoru je aktivována výběrová záložka.
Původní chování těchto formulářů při jejich spuštění je možné obnovit nastavením Selektory->OBC_vyber resp. Selektory->ORG_vyber resp. Selektory->TVS_vyber na hodnotu 0 činností 'Nastavení programu BM'.
Ing. Petr Filip 16.01.06


Volná karta

Volná karta
Ve verzích BM generovaných od 1.12.2005 do 9.1.2006 byla chyba, které se projevovala tím, že při vstupu volné karty mohlo docházet ke konfliktům identifikátorů atributů volné karty s názvy vlastností nebo metod objektu formuláře volné karty.
Tato chyba byla opravena.

Nově je možné v popisech Zobrazení, Inicializace a Validace jednotlivých atributů volné karty uvádět identifikátory atributů primárního klíče tabulky, se kterou je VK spojena.
Tyto identifikátory se uvádějí v hranatých závorkách.

Např.: na volnou kartu adresáta zobrazit název adresáta
v atributu inicializace - =tool.sql_dotaz([select ad01adsat from %%%.adadsat where ad01id=?_p1],[ad01id])
Ing. Petr Filip 09.01.06


Volné karty

Volné karty
Z formulářů, na kterých se vyskytuje některý ze selektorů, je možné vyvolávat jeho volné karty z menu Obecné -> VOLNÉ KARTY SELEKTORŮ -> OBCHODNÍ SELEKTOR resp. Obecné -> VOLNÉ KARTY SELEKTORŮ -> ORGANIZAČNÍ SELEKTOR resp. Obecné -> VOLNÉ KARTY SELEKTORŮ -> TECHNICKO-VĚCNÝ SELEKTOR.

Další změny:
1/ nová vlastnost volné karty - Velikost - umožnit změnu velikosti okna VK - Ne/Horizontálně/Vertikálně/Oběma směry - horizontálně i vertikálně (původně bylo totochování spojeno s vlastností Posuvník)

2/ nová vlastnost volné karty - Skript - slouží k definování skriptu v jazyce Foxpro vyvolávaného v okamžiku zápisu volné karty - pokud skript vrátí logickou hodnotu .F. (FALSE), není karta zapsána
Vyvolání skriptu se dá využít:
a/ k zápisu dalších informací na VK
např.: datum na VK je datem aktualizace VK
REPLACE bw01uziv1 WITH tool.uziv
REPLACE sp00datzap WITH DATETIME()
REPLACE bw01jmeno WITH tool.jmeno
b/ odeslání e-mailu před zápisem VK

3/ nová vlastnost volné karty - Autor - určuje, zda má být na VK zobrazována informace o uživateli, který založil VK a datum jejího založení (Zobrazovat na volné kartě / Nezobrazovat na volné kartě)

4/ nová vlastnost atributu volné karty - Podmínka - umožňuje definovat logický výraz v jazyce Foxpro určující podmínku vstupu do daného atributu.
Pokud podmínka obsahuje výraz .F. - atribut je zobrazen formátem pouze čtení
Pokud podmínka obsahuje výraz .NULL. - není atribut na obrazovce zobrazen

5/ nová vlastnost atributu volné karty - P.oknu (přizpůsobení oknu) - určuje, změny velkosti atributu při změnách velikosti okna - Ne / Horizontálně / Vertikálně / Obojí

6/ hodnoty vypočítávaných atributů jsou zapisovány na volnou kartu.
Ing. Petr Filip 16.01.06


Oprávnění k činnostem

Oprávnění k činnostem
uživatel s právy správce ISBM má možnost definovat oprávnění k činnosti také:
1/ v hlavním menu programu volbou 'Oprávnění k činnostem' po pravém kliku na činnosti
2/ volbou 'Oprávnění k činnosti' z menu 'Obecné' libovolného formuláře
Ing. Petr Filip 07.12.05


Předlohy výstupu

Předlohy výstupu
Předlohy výstupu typu EXCEL1 byly doplněny o možnost spouštění skriptu.
Při definování předlohy se skript v jazyce Foxpro zadává v textovém poli na záložce 'Skript'.

Skript zpracovává různé události, které nastávají při vytvářeních výstupu.
Kód skriptu má k dispozici tyto proměnné:
_EVENT - identifikace události
_COLUMN_OBJECT.NAZEV_SLOUPCE - název sloupce při událostech týkajících se buňky
_COLUMN_OBJECT.VAL - hodnota vkládaná do buňky při událostech týkajících se buňky
_COLNO - číslo sloupce v Excelu při událostech týkajících se buňky
_ROWNO - číslo řádky v Excelu při událostech týkajících se buňky

Události před založením a po vytvoření listu
BEFORE_LIST - Událost před založením listu
V této fázi vytváření výstupu může skript měnit obsah kurzoru SQL_TISK (na základě jeho obsahu následně vzniká výstup).
AFTER_LIST - Událost po vytvoření listu
V této fázi vytváření výstupu může skript upravit vzhled výsledného listu

Události týkající se buňky
BEFORE_CELL - Událost před založením běžné buňky
Může měnit hodnotu proměnné _COLUMN_OBJECT.VAL, pokud skript vrátí logickou hodnotu .F. (FALSE), nebude žádná hodnota do buňky vložena.
AFTER_CELL - Událost po založení běžné buňky
Je určena pro formátování buňky
BEFORE_SUBTOTAL_CELL - Událost před založením buňky mezisoučtu
Pokud skript vrátí logickou hodnotu .F. (FALSE), nebude žádná hodnota do buňky vložena.
AFTER_SUBTOTAL_CELL - Událost po založením buňky mezisoučtu
Je určena pro formátování buňky
BEFORE_TOTAL_CELL - Událost před založením buňky závěrečného celkového součtu
Pokud skript vrátí logickou hodnotu .F. (FALSE), nebude žádná hodnota do buňky vložena.
AFTER_TOTAL_CELL - Událost po založením buňky závěrečného celkového součtu
Je určena pro formátování buňky

Pravý klik na textové pole záložky 'Skript', vyvolává editor programů s předplnění vzoru skriptu, pokud byl pravý klik proveden na prázdném textovém poli.

Příklad:
#INCLUDE OLBEXC
* OLBEXC je knihovna obsahující konstanty Excelu - viz. Návody a Balíčky
DO CASE
CASE INLIST(_event,'AFTER_CELL','AFTER_SUBTOTAL_CELL','AFTER_TOTAL_CELL')
DO CASE
CASE LOWER(_column_object.nazev_sloupce)='jmeno_sloupce'
* vloží podmíněné formátování buňky - její hodnota bude zobrazena červeným textem, pokud je záporná
xlsheet.cells[_rowno,_colno].FormatConditions.Delete
xlsheet.cells[_rowno,_colno].FormatConditions.Add(xlCellValue, xlLess, "0")
xlsheet.cells[_rowno,_colno].FormatConditions(1).Font.ColorIndex = 3
ENDCASE
ENDCASE

Ing. Petr Filip 08.12.05


Řešitelé projektových úkolů

Řešitelé projektových úkolů
Byl doplněn nový atribut řešitele projektového úkolu - Profese, který váže na tabulku komponenty Mzdy - Pracovní funkce (MZPRACPO)
Ing. Petr Filip 07.12.05


Volné karty

Volné karty
byly provedeny tyto změny v definování a ovládání volných karet:

1/ volnou kartu je možné 'Znovu načíst' volbou z menu Obecné nebo klávesou F6
2/ nová vlastnost definice volné karty 'Znovu načítat' způsobuje znovunačtení volné karty po zápisu dat na kartu
3/ nová vlastnost Posuvník - překryvný seznam s hodnotami - Žádný,Horizontální,Vertikální,Oba horizontální i vertikální - určuje, zda okno karty bude mít posuvníky
4/ ve vlastnosti 'Dynamický nadpis' je možné uvádět výraz v jazyce Foxpro uvedený znakem '=', v tomto výrazu je možné získat hodnoty primárního klíče uvedením názvů atributů primárního klíče v hranatých závorkách.

Další změny se týkají atributů volné karty:
1/ ve vlastnosti inicializace je možné uvádět text uvedený rovnítkem
- hodnota takového atributu není ukládána do dat volné karty a tento atribut není možné editovat
- za rovnítkem se uvádí výraz v jazyce Foxpro, jehož hodnota je zobrazována pro daný atribut ve volné kartě
- hodnota atributu ve volné kartě je přezobrazována při každé změně, kterou provede uživatel vstupem libovolného atributu
- ve výrazu je možné názvy atributů volné karty ohraničené hranatými závorkami, tyto texty představují hodnotu odpovídajícího atributu
- pro správné vyhodnocení je nutné, aby vstupované atributy uváděné ve výrazu měly pořadí menší než atribut, ve kterém je uvedena vypočtená hodnota
- za rovnítkem vlastnosti inicializace je možné zadat prefix SCRIPT - inicializace je potom provedena víceřádkového skriptu v jazyce Foxpro
Příklady:
a/ název adresáta zobrazováného na volné kartě na základě identifikace adresáta (atribut IDADR) vstupované uživatelem:
=tool.sql_dotaz([select ad01adsat from %%%.adadsat where ad01id=?_p1],[idadr])
b/ součet dvou hodnot vstupovaných uživatelem
=[hodnota1]+[hodnota2]
c/ příklad řešení se skriptem
=SCRIPT
IF [hodnota1]>20
RETURN [hodnota2]
ELSE
RETURN [hodnota1]
ENDIF

2/ přibyla vlastnost validace, ve kterém je možné uvádět kód v jazyce Foxpro, který vrací hodnoty TRUE nebo FALSE signaluzující validitu atributu
- v tomto kódu je možné uvádět text ### (představuje daný atribut) nebo názvy jiných atributů volné karty ohraničené hranatými závorkami, tyto texty představují hodnotu odpovídajícího atributu
Příklady:
a/ validace na na nenulovou hodnotu
IF ###=0
WAIT WIND 'Částka nesmí být nulová' NOWAIT
RETURN .F.
ENDIF
b/ validace existence adresáta zadaného uživatelem na volnou kartu
IF EMPTY([adnazev])
* předpokládá se, že ADNAZEV je atribut volné karty inicializovaný podobně jako v příkladu 1a.
* tento atribut bude v průběhu vstupu prázdný, pokud hodnota atributu identifikace adresáta (v příkladu 1a se jedná o atribut IDADR) neodpovídá existujícímu adresátovi
WAIT WIND 'Adresát musí být uveden' NOWAIT
RETURN .F.
ENDIF
3/ ve vlastnostech atributů Zobrazení, Inicializace a Validace je možné používat makra
- základní makra jsou k dispozici v Návodech a balíčcích
- definování maker se provádí činností 'Definice maker' z menu Volby formuláře Volná karta
Řešení příkladů pomocí těchto maker:
1a/ fky_nazev_adresata([idadr])
2a/ valid_neprazdny('Částka nesmí být nulová')
2b/ valid_fky([adnazev],'Adresát musí být uveden')
Ing. Petr Filip 07.12.05


Změna velikosti okna formuláře

Změna velikosti okna formuláře
možnost roztažení okna formuláře do šířky dopracována do těchto činností :

- události mezd
- úkolové listy
- prohlížení výplatních lístků
- výplatní lístky
- výplatní lístky - zadávání
- události personalistiky
Ing. Olga Smitková 02.12.05


Změny v souvislosti se stornováním

Změny v souvislosti se stornováním
V souvislosti se stornováním procesu, diagramem procesu a stromem hlavního procesu:
1/ uživatel, který nemá právo k založení druh procesu nemůže proces tohoto druhu stornovat
2/ uživatel, který nemá právo k činnosti "Storno procesu" vyvolávané z formuláře "Procesy", nemůže provádět zrušení stavu ukončena žádné operace (z formuláře Vlastnosti operace) ani mu není umožněno stornovat proces ve Stromu hlavního procesu
3/ uživatel, který nemá právo k činnosti "Diagram procesu" vyvolávané z formuláře "Procesy", nemá dostupnou možnost vyvolat diagram procesu z formulářů událostí operací komponent ani ze Stromu hlavního procesu
4/ uživatel, který nemá právo k činnosti "Strom hlavního procesu" vyvolávané z formuláře "Procesy", nemá dostupnou možnost vyvolat Strom hlavního procesu z formulářů událostí operací komponent
Ing. Petr Filip 07.12.05


Registr pojištěnců

Registr pojištěnců
Oprava chyby - opravná a změnová hlášení
------------------------------------------------------------------------
Při vytváření opravného hlášení registru pojištěnců se projevila chyba při vytváření opravných a změnových hlášení - program vkládal pracovníky, u kterých nebyla provedena žádná změna.

Chyba byla způsobena nesprávným řešením ukládání informace o tom, jaká data data jsou o pracovním poměru pracovníka uložena ve vytvořeném souboru zasílaném na ČSSZ.
Data byla ukládána na volnou kartu spojenou se záznamem o pracovním poměru.

Pokud uživatel vytvořil dokument hlášení registru pojištěnců a následně tento dokument zrušil,
potom se informace v něm obsažených pracovních poměrů pro porovnání při vytváření opravných nebo změnových hlášení ztratila - tyto pracovní poměry byly zahrnovány do všech následně vytvářených dokumentů opravných nebo změnových hlášení.

V opraveném řešené se informace pro vyhodnocení změn ukládá spolu s vazbou mezi dokumentem hlášení a pracovním poměrem (do souboru BWOBJECX) - volná karta pracovního poměru přestala
být využívána.

V souvislosti s tím je součástí balíčku pro zpracování RELDP a REGPJ externí příkaz, který vytváří obsah souboru BWOBJECX. Tento externí příkaz se automaticky vyvolá při vytváření prvního dokumentu hlášení registru pojištěnců novou verzí programu.

Oprava chyby - datum odchodu do důchodu
-------------------------------------------------------------------
Program chybně vytvářel hlášení, kdy do data odchodu do důchodu vkládal datum uvedené na kartě pracovníka zmenšené o jeden den.

Změny ZÁSAD PRO VYPLŇOVÁNÍ TISKOPISU "PŘIHLÁŠKA K NEMOCENSKÉMU POJIŠTĚNÍ - ODHLÁŠKA"
-------------------------------------------------------------------------------------------------------------------------------------------------------------------
k 27.10.2005 byla na http://www.cssz.cz publikovány tyto změny, které se projevily v programu:
1/ odpadá povinnost hlásit změny titulu, počtu dětí, pracovního úvazku
2/ údaj Předpokládaný hrubý měsíční příjem se stal povinným
Předpokládaný hrubý měsíční příjem - uvádí se přibližný předpokládaný příjem zaměstnance, který se zahrnuje do vyměřovacího základu pro pojistné na sociální zabezpečení. Není-li příjem pravidelný, uvede se předpokládaný průměrný měsíční příjem. V případě, kdy je předpokládaný příjem vyšší než 400 Kč, postačí uvést 400 Kč.
Podle odpovědi na náš dotaz na OSSZ České Budějovice není třeba pro již odeslaná hlášení vytvářet opravná hlášení.
Program naplňuje do údaje Předpokládaný hrubý měsíční příjem hodnotu 400, pokud je v záznamu o pracovním poměru pracovníka uvedeno "Účast na nemocenském pojištěni=Ano".
Ing. Petr Filip 07.11.05


Druh adresáta

Druh adresáta
Pro každého adresáta je nyní možné definovat jeho druh, jehož prostřednictvím se definují přístupová práva uživatelů systému Čtení, Zápis nebo Žádné.
Toto právo se vztahuje k základní informacím o adresátovi, jeho adresám a adresním spojením a neomezuje možnost zadat adresáta např. v událostech komponent.
Práva k bankovním spojením adresáta se definují při nastavování práv přístupu zvlášť zaškrtnutím voleb - 'Ban.spojení - čtení' a 'Ban.spojení - žádné'.

Např.:
Nastavení práva k druhu adresáta = Zápis
Volba 'Ban.spojení - čtení' = Zaškrtnutá
Uživatel může měnit základní informace o adresátovi, přidávat adresy a adresní spojení adresáta, ale bankovní spojení adresáta může pouze číst

Nastavení práva k druhu adresáta = Zápis
Volba 'Ban.spojení - žádné' = Zaškrtnutá
Uživatel může měnit základní informace o adresátovi, přidávat adresy a adresní spojení adresáta, ale bankovní spojení adresáta nevidí, ani nesmí nové bankovní spojení přidávat

Nastavení práva k druhu adresáta = Čtení
Volba 'Ban.spojení - čtení' = Nezaškrtnutá
Volba 'Ban.spojení - žádné' = Nezaškrtnutá
Uživatel nemůže měnit základní informace o adresátovi, nemůže přidávat ani měnit adresy a adresní spojení adresáta, ale bankovní spojení adresáta může měnit i přidávat
Ing. Petr Filip 05.10.05


Nabídka aktivních oken

Nabídka aktivních oken
při nové možnosti roztahovat okna to šířky zabírá nabídka aktivních oken zbytečně šířku obrazovky. Proto je nyní možné zaškrtnout v parametrech uživatele spolu s volbou 'Zobrazovat nabídku aktivních oken' volbu 'Ikony'.
V tom případě je potom nabídka aktivních oken zobrazována jako tlačítka s ikonami a ukotví se při příštím spuštění programu v dolní části obrazovky.
Ing. Petr Filip 29.09.05


Obecné výběry

Obecné výběry
Pro podporu rozhodování implementátora při vyřazování nepoužívaných obecných výběrů se nyní nově sleduje užití obecných výběrů.
Ve formuláři Obecného výběru se v mřížce na záložce 'Užití obecného výběru' zobrazuje:
kdo - jméno uživatele
kdy poprvé - datum prvního použití výběru uživatelem
kdy naposledy - datum posledního použití výběru uživatelem
kolikrát - celkový počet použití výběru uživatelem

Tyto informace se ukládají do tabulky SPVYBERU s atributy:
sp27id - primárního klíč obecného výběru
bw01uziv - kdo - identifikace uživatele
spe6dat1 - kdy poprvé
spe6dat2 - kdy naposledy
spe6pocet - kolikrát
Ing. Petr Filip 20.09.05


Obecný výběr x Předloha výstupu

Obecný výběr x Předloha výstupu
některé předlohy výstupu fungují pouze v případě, že jsou vybrána data konkrétním obecným výběrem.
Tato vlastnost byla ještě posílena novou možností obecných výběrů - definování atributů, které jsou mj. také součástí SQL dotazu předlohy výstupu.

Pro záznam vztahu mezi obecným výběrem a předlohou výstupu se nyní nově definuje pro obecný výběr na záložce 'Spojené předlohy výstupu' seznam předloh, které vyžadují pro svou funkčnost aktuálně použití daný výběr.
Tímto vztahem může být tudíž definován mezi obecným výběrem a předlohou relační vztah M:N.

V okně předloh výstupu se nyní nově mohou vyskytovat předlohy s ikonou podobnou dopravní značce zákaz vjezdu do jednosměrné ulice.
Tímto způsobem jsou signalizovány předlohy, které jsou ve vztahu k alespoň jednomu obecnému výběru a přitom žádný z nich není užit pro výběr dat formuláře.
Pokud se pokusí uživatel o výstupu takovou předlohou, výstup nebude proveden a zobrazí se hlášení:
'Předlohu je možné použít pouze s obecným výběrem xxxx '.

Obecný výběr má dále nový atribut Druh (Druh předlohy výstupu), kterým se definují přístupová práva uživatelů pro jeho použití.
Ing. Petr Filip 20.09.05


Předlohy výstupu

Předlohy výstupu
Pro podporu rozhodování implementátora při vyřazování nepoužívaných předloh výstupu se nyní nově sleduje užití předloh výstupu.
Ve vlastnostech předlohy se užití předlohy zobrazuje na záložce 'Info' v seznamu:
kdo - jméno uživatele
kdy poprvé - datum prvního použití předlohy uživatelem
kdy naposledy - datum posledního použití předlohy uživatelem
kolikrát - celkový počet použití předlohy uživatelem

Tyto informace jsou ukládány do tabulky BWPRINTU s atributy:
bw02krok - část primárního klíče předlohy výstupu
bw04ident - část primárního klíče předlohy výstupu
bw01uziv - kdo - identifikace uživatele
bwa0dat1 - kdy poprvé
bwa0dat2 - kdy naposledy
bwa0pocet - kolikrát
Ing. Petr Filip 20.09.05


Volné karty

Volné karty
Pro podporu rozhodování implementátora při vyřazování nepoužívaných volných karet se nyní nově sleduje užití volných karet.
Zaznamenáváno není užití volné karty, která je otevírána automaticky při spuštění formuláře.
Ve formuláři Volné karty se v mřížce na záložce 'Užití volné karty' zobrazuje:
kdo - jméno uživatele
kdy poprvé - datum prvního použití volné karty uživatelem
kdy naposledy - datum posledního použití volné karty uživatelem
kolikrát - celkový počet použití volné karty uživatelem

Tyto informace se ukládají do tabulky SPVOLSTU s atributy:
bw10nazev - část primárního klíče volné karty
sp64nazev - část primárního klíče volné karty
bw01uziv - kdo - identifikace uživatele
spe6dat1 - kdy poprvé
spe6dat2 - kdy naposledy
spe6pocet - kolikrát
Ing. Petr Filip 20.09.05


Zobrazování desetinných míst na formul.

Zobrazování desetinných míst na formul.
Bylo vyřešeno doplňující vlastností formuláře - viz. Návody a balíčky
Ing. Petr Filip 29.09.05


IC-Druhy oper.-ukončení oper. bez udál.

IC-Druhy oper.-ukončení oper. bez udál.
Bylo opraveno chyba programu, která se projevovala při ukončování operace bez událostí, a při nastavené vlastnosti druhu operace "Ukončení operace bez událostí" na hodnotu "Ne" nebo "Rozhodnutí uživatele" :
1/ operace spouštěná na pozadí se vždy automaticky ukončovala, i když neměla žádné události
2/ pokud uživatel založil událost a následně ji po zápisu zrušil - operaci bylo možné ukončit, i když neměla žádné události

Platí, že pokud může být ukončena operace bez událostí musí mít explicitně nastaveno "Ukončení operace bez událostí" na hodnotu "Ano".
Operace spuštěná na pozadí, která má být ukončena a přitom nevznikly tranformací žádné události, zastaví a zobrazí svůj formulář, tak jako by transformací vznikly chybné události.

Tato oprava může ovlivnit chování procesů, kde byla opravená chyba žádoucí - pro ně bude třeba nastavit vlastnosti dotčených operací "Ukončení operace bez událostí" na hodnotu "Ano".
Ing. Petr Filip 05.08.05


Inicializace duplikovaného artiklu

Inicializace duplikovaného artiklu
V nové verzi programu je možné určit hodnoty atributů artiklů, které jsou automaticky zakládány (podle nastavení u druhu artiklu) při založení artiklu jiné komponenty.
Provádí se nastavením v souboru BW.INI v sekci [Init_Atributu_Duplikovanych_Artiklu], kde se uvádí parametry ve tvaru :
[tabulka].[atribut]=[konstanta v syntaxi Sybase SQL Anywhere]

Toto nastavení se uplatní při instalaci nové verze BM, kdy se vytvářejí triggery zajišťující duplikaci artiklů mezi komponentami.

Např.:
[init_atributu_duplikovanych_artiklu]
obartikl.ob01nulcen=0
mtartikl.ob01nulcen=0
Ing. Petr Filip 08.08.05


Sledování změn v záznamech tabulek BM

Sledování změn v záznamech tabulek BM
Rozšíření o možnost výběru záznamů a sledovaných atributů

V činnosti SYSTÉM -> Nastavení sledování změn tabulek je nyní možné nově nastavit atributy:
Podmínka - výraz v syntaxi Sybase SQL Anywhere - před jednotlivými atributy je třeba uvádět prefix $$$., který je v generovaných triggerech nahrazován textem new_name resp. old_name - omezuje množinu sledovaných záznamů
Atributy - překryvný seznam - určuje způsob výběru podle seznamu atributů uvedených v následujícím atributu 'Seznam atributů' - Všechny vyjmenované atributy / Všechny kromě vyjmenovaných atributů
Seznam atributů - uvádí se seznam atributů tabulky, jejichž hodnoty mají být resp. nemají být sledovány

Př.:
Omezení sledování změn tabulky obchodovatelného artiklu (OBARTIKL) výhradně pro druh artiklu 'ZBO' .
Podmínka = $$$.sp61id='ZBO'

Př.:
Při sledování změn tabulky uživatelé programu (BWUZIVAT) je vhodné vyloučit ze sledování atributy BW01NAPOSL (Datum a čas posledního vyvolání systému - aktualizuje se při každém přihlášení uživatele) a SP38ID (Identifikace jazyka - může uživatel sám měnit)
Atributy = Všechny kromě vyjmenovaných atributů
Seznam atributů = bw01naposl,sp38id
Ing. Petr Filip 02.08.05


Spojené dokumenty

Spojené dokumenty
Vyvolání formuláře "Spojené dokumenty" klávesou CTRL+D bylo dosud možné pouze z formulářů pro vstup objektů BM (události, artikly, adresát, ....).
Nyní je možné připojovat dokumenty k záznamům tabulek, které nejsou objekty BM.
V přechodném období není funkčnost formuláře "Spojené dokumenty" úplná v tom, že v některých formulářích nedochází při pohybu v mřížce k jeho přezobrazování. Tento nedostatek bude odstraňován postupně (v případě potřeby přednostní úpravy konkrétního formuláře informujte vývoj BM).

Pro implementátory:
Vazba (BWOBJECT) mezi dokumentem (SPDOKOBS) a tabulkou, která není objektem BM se provádí prostřednictvím tabulky BWOBJECN.
Tato tabulka obsahuje atributy:
bw10nazev - c(8) - název tabulky
bw99key - c(50) - hodnota primárního klíče záznamu v tabulce
bw99 - c(12) - jednoznačná časová identifikace pro vazbu prostřednictvím tabulky BWOBJECT
Do tabulky BWOBJECN se zapisuje v okamžiku připojování prvního dokumentu např. při připojování dokumentu k druhu artiklu se vytvoří záznam bw10nazev='SPARTIKD', bw99key=(druh artiklu tj. hodnota sp61id+SPACE(47)), bw99=(jednoznačná časová identifikace)

Dále byl doplněn obsah formuláře "Spojené dokumenty":
1/ do složky s dokumenty adresáta jsou navíc složky:
Kategorie adresáta - a pod ní zařazení adresáta do kategorií
Události adresáta - obsahuje seznam komponent, ve kterých se daný adresát vyskytuje s uvedeným počtem záznamů (N1), a pokud je možné vyhodnotit počet událostí včetně spojení a tento počet není roven N1, zobrazí se (N1/N2). Pod každou komponetou je možné rozbalit seznam s přehledem druhů operací a počty záznamů.
2/ pokud je to možné, je obsažena složka s dokumenty artiklu
3/ ve složce s dokumenty artiklu je složka:
Události artiklu - obdobný obsah jako složky adresáta

Pokud není složka událostí rozbalena, vytváří se její obsah teprve v okamžiku jejího rozbalení.
Nerozbalené složky událostí mají popis uzavřený v závorkách tj. '( Události adresáta )' a '( Události artiklu )' proto, aby si uživatel uvědomil, že byť se jeví jako neprázdná složka, nemusí pro adresáta resp. artikl existovat nějaká událost.

Ovládání myší:
Pravý klik na složce Kategorie adresáta - vyvolání formuláře kategorií adresáta
Dvojí klik na konkrétní kategorii adresáta - vyvolání formuláře kategorií adresáta
Pravý klik na komponentě ve složce událostí - vyvolání formuláře událostí komponenty
Dvojí klik na druhu operace ve složce komponenty - vyvolání formuláře událostí komponenty
Ing. Petr Filip 29.08.05


Výpočet ceny bez DPH

Výpočet ceny bez DPH
z ceny včetně DPH je možné ovlivnit nastavením parametru BM v sekci 'DPH' je možné nastavit parametr 'Rad_Koeficientu', který určuje počet desetinných míst koeficientu pro výpočet ceny bez DPH z ceny včetně DPH.
Při nastavení parametru hodnotou větší než 0 se počítá:
= * ROUND(100/(100 + ),)

Při nastavení parametru hodnotou menší nebo rovno 0 se počítá:
= * 100/(100 + )

Toto nastavení bylo umožněno pro verze BM používané na Slovensku, v Čechách je podle legislativy nutné ponechat nastavení s použitím koeficientu zaokrouhleného na 4 desetinná místa.
Ing. Petr Filip 12.08.05


Bankovní spojení adresáta

Bankovní spojení adresáta
V bankovním spojení adresáta přibyl atribut 'Aktuální' nabývající hodnoty Ano/Ne.
Vstupuje se ve formulářích 'Adresář' a 'Bankovní spojení adresátů'.
V mřížkách těchto formulářů jsou neaktuální bankovní spojení zobrazeny na šedivém podkladě.
Ve formuláři 'Bankovní spojení adresátů' je možné vybírat spojení podle této vlastnosti.

Ing. Petr Filip 11.07.05


BM-funkce pro SQL

BM-funkce pro SQL
V řadě uživatelských implementačních rozšířeních (doplnění výstupů, transformace, obecné výběry, volné karty, ...) se opakovaně potřebuje užít dost složitá konstrukce pro získání hodnoty (např. nákladová cena z TPTECVVP k datu, výše opravné položky či úhrady k datu k platbě, hmotnost výrobku z VRUDOPMA, ...). V dnešní praxi se obvykle řeší opakovaným sestavováním SELECTu v doplnění - vždy se postaví mírně odlišně (zaokroulování, ...) a pak se řeší nekonzistence informací.

Nová činnost v ISBM - INFORMAČNÍ CENTRUM - TYPY A ŘADY - BM-funkce pro SQL - tento problém řeší.
Zadává se:
Identifikace BM-funkce - 12-ti znakový identifikátor
Název BM-funkce - popisuje funkci
Typ návratové hodnoty BM-funkce - překryvný seznam - Znaková,Numerická,Datumová,Časová
Datum platnosti funkce od - datum
SQL dotaz BM-funkce - text obsahující selekt v syntaxi Sybase SQL Anywhere
Testovací parametry - seznam parametrů (konstant) pro testování BM-funkce (parametry musí být definovány v syntaxi Foxpro)
Poznámka - libovolný text
Kromě toho se při opravě funkce automaticky nastavuje atribut Aktualizace aktuálním datem a časem systému, který zajišťuje při importu balíčku zachování poslední nejaktuálnější verze BM-funkce.

V implementačních rozšířeních ISBM se potom konkrétní BM-funkce odkazují v odpovídajících SQL dotazech voláním uložené procedury:
bmfce_C - pro typ návratové hodnoty funkce Znaková
nebo bmfce_N - pro typ návratové hodnoty funkce Numerická
nebo bmfce_D - pro typ návratové hodnoty funkce Datumová
nebo bmfce_T - pro typ návratové hodnoty funkce Časová

v syntaxi např.:
bm_servis.bmfce_C([Identifikace BM-funkce],[platnost],[parametr1],[parametr2],...,[parametr9])

Parametr Platnost určuje datum rozhodující, jestliže je definováno více BM-funkcí se stejnou identifikací, která z nich podle jejich data platnosti bude vyhodnocena. Obvykle se uvádí konstanta NULL nebo CURRENT DATE (tj. v obou případech BM-funkce platná k atuálnímu datu).

Nepovinné parametry [parametr1],[parametr2],...,[parametr9] jsou v SQL dotazu funkce reprezentovány pozičné proměnnými @p1,@p2,....,@p9.

Vytvořenou BM-funkci je možné testovat volbou Testovat SQL výraz (klávesa F5) v případě, že jsou u ní nadefinovány Testovací parametry. Mělo by být pravidelem, že každá funkce je tímto způsobem otestována, protože syntakticky chybně nadefinovaná funkce se neprojeví chybou SQL při použití v implementačních rozšířeních.

Exporty do balíčku, byly upraveny tak, že je-li v exportu obsažen záznam, který odkazuje v některém svém atributu na BM-funkci, potom je tato automatizovaně vložena do tohoto balíčku (tato funkčnost se neuplatňuje pro exporty ve starém formátu).

Př.:
BM-funkce vracející množství artiklu na všech skladech.
Identifikace BM-funkce - MT-AHNAT-ALL
Typ návratové hodnoty BM-funkce - Numerická
SQL dotaz BM-funkce - SELECT SUM(mt02hodnot) FROM %%%.MTAH WHERE sp67id='NAT' AND sp61id=@p1 AND sp60id=@p2
Testovací parametry - 'ZBO',PADR('HOBLIK',13)

Použití této BM-funkce v doplnění tiskové předlohy výstupu obchodovatelného artiklu:
...., %%%.bmfce_N('MT-AHNAT-ALL',null,obartikl.sp61id,obartikl.sp60id) mnozstvi, ....

Použití této BM-funkce v obecném výběru obchodovatelného artiklu:
%%%.bmfce_N('MT-AHNAT-ALL',null,obartikl.sp61id,obartikl.sp60id)>1000
Ing. Petr Filip 11.07.05


Předloha výstupu x dokument v BM

Předloha výstupu x dokument v BM
Jazyk generátoru sestav předloh výstupu do EXCEL (Excel typu 2) nyní umožňuje vytvořený výstup automatizovaně ukládat jako dokument v BM.

K tomuto účelu slouží nové příkazy:
.BM_DOKUMENT
.BM_DOKUMENT_KLÍČ

Příkaz BM_DOKUMENT
Definuje pro zakládaný dokument jeho předlohu, druh, název a poznámku
Parametry:
ASK - logická - TRUE = uživatel bude před uložením dokumentu do BM dotázán, zda má být dokument skutečně uložen
SP01ID - textová - identifikátor předlohy dokumentu
SP57ID - textová - identifikace druhu dokumentu - pokud nemá uživatel k tomuto druhu dokumentu stanovené právo zápis, nebude dokument zakládán
SP26NAZEV - textová - název dokumentu
SP26KOMENT - textová - poznámka - nepovinný parametr

Příkaz BM_DOKUMENT_KLÍČ
Určuje klíč dokumentu (např. typicky období výpočtu).
Tímto příkazem se zapisuje do protokolu dokumentu.
Zajistí to, aby se vyskytoval dokument vytvořený předlohou výstupu za určité období po opakovaném spuštění této předlohy mezi dokumenty BM právě jedenkrát.
Pokud se při zpracování předlohy výstupu vyskytuje v BM dokument s uvedenou stejnou předlohou dokumentu se záznamem v protokolu dokumentu
se stejnou hodnotou klíče:
1/ dokument nebude přepsán ani založen nový dokument, pokud uživatel nemá právo přístupu ZÁPIS k druhu tohoto dříve vytvořeného dokumentu
2/ jinak bude uživatel vyzván k rozhodnutí, zda má být tento dokument přepsán.
Parametry:
SPC9KLIC1 - textová - klíč dokumentu
SPC9POPIS - textová - popis - nepovinný parametr - není-li uveden, pak se to protokolu zapíše text - 'Výpočet za:'
SPC9KOMENT - textová - poznámka v protokolu - nepovinný parametr

Pokud je užit příkaz BM_DOKUMENT_KLÍČ, musí být uveden za příkazem BM_DOKUMENT.
Uvedení příkazu BM_DOKUMENT automaticky obsahuje funkci příkazu EXCEL_NEUKLÁDAT

Příklad:
Část kódu předlohy výstupu přiznání k dani z DPH - s použitím obecně užívané předlohy dokumentu
.BM_DOKUMENT .T.,'EXCEL','OBECNE','Přiznání k dani z DPH '+$(S-dp11rok)+'/'+$(S-dp11meskva)+' ('+$(DPPRI_dp02char2_)+')'
.KDYŽ SQL_TISK.DPPRI_dp02char2<>2
* Běžné daňové přiznání se může za konkrétní rok a měsíc vyskytovat mezi dokumenty v BM pouze jednou
* Klíč dokumentu musí obsahovat unikátní identifikaci DP, bude např. 'DP 2005/07'
.BM_DOKUMENT_KLÍČ 'DP '+$(S-dp11rok)+'/'+$(S-dp11meskva)
.KONEC_KDYŽ

Příklad:
Část kódu předlohy výstupu přiznání k dani z DPH - s použitím předlohy dokumentu DANPRI (má jinak obdobné vlastnosti jako předloha EXCEL)
.BM_DOKUMENT .T.,'DANPRI','OBECNE','Přiznání k dani z DPH '+$(S-dp11rok)+'/'+$(S-dp11meskva)+' ('+$(DPPRI_dp02char2_)+')'
.KDYŽ SQL_TISK.DPPRI_dp02char2<>2
* Běžné daňové přiznání se může za konkrétní rok a měsíc vyskytovat mezi dokumenty v BM pouze jednou
* Klíč dokumentu nemusí obsahovat unikátní identifikaci DP, protože byla užita specializovaná předloha DANPRI (bude např. '2005/07')
.BM_DOKUMENT_KLÍČ $(S-dp11rok)+'/'+$(S-dp11meskva)
.KONEC_KDYŽ
Ing. Petr Filip 28.07.05


Příkazy k úhradě tuzemské x zahraniční

Příkazy k úhradě tuzemské x zahraniční
V některých případech nepostačuje jediná definice komunikace s bankou vztažená k jednomu bankovnímu účtu.
Např. HVB Bank používá pro příkazy k úhradě jiný formát dat pro tuzemsko (*.cfd) a jiný formát dat pro zahraničí (*.cfa).

Proto byl formulář 'Definice komunikace s bankou' rozšířen o záložku 'Podmíněné definice'.
Na této záložce je možné zadat jiné definice komunikace, které mohou být použity namísto základní definice uvedené na první záložce formuláře.
Uvádí se:
Přenos - text - identifikace podmíněné definice komunikace s bankou
Směr - překryvný seznam - Vstup/Výstup - určuje to, zda se jedná o podmíněnou definici užitou při exportu příkazu k úhradě nebo importu bankovního výpisu
Kód podmínky - text - kód v jazyce Foxpro - musí vracet numerickou hodnotu
Poznámka - libovolný text

Podmíněná definice - směr Vstup
Uplatní se při načítání bankovního výpisu odpovídající šablonou v operaci změny stavu peněz.
V proměnné _SOUBOR má kód podmínky k dispozici název souboru, který bude importován.
Předpokládá se, že kód rozpozná formát importovaného souboru a vrátí numerickou hodnotu:
0 - formát neodpovídá podmíněné definici
1 (nebo větší než 0) - formát odpovídá podmíněné definici - import výpisu bude proveden podle této definice
-1 (nebo menší než 0) - byla zjištěna chyba - import nemá být vůbec proveden

Podmíněná definice - směr Výstup
Uplatní se při vytváření příkazu k úhradě
V proměnných _PL03ROK,_PL03IDU a _PL03ID má kód podmínky k dispozici identifikátory exportovaného příkazu k úhradě.
Předpokládá se, že kód rozpozná podle položek příkazu, že by měl být užit a vrátí numerickou hodnotu:
0 - podmíněná definice nemá být užita (např. její formát dat je určen pro tuzemské příkazy, ale všechny položky příkazu odkazují na zahraniční adresáty)
1 (nebo větší než 0) - podmíněná definice má být užita (např. její formát dat je určen pro tuzemské příkazy a přitom všechny položky příkazu odkazují na tuzemské adresáty)
-1 (nebo menší než 0) - byla zjištěna chyba - export nemá být vůbec proveden - (např. nedá se rozhodnout, protože položky příkazu odkazují na tuzemské i zahraniční adresáty)

V případě, že všechny podmíněné definice vrátí hodnotu 0, provede se import resp. export podle základní definice.
Pokud podmíněná definice vrátí hodnotu -1, měla by o důvodu přerušení zpracování vyvolat odpovídající hlášení.
Ing. Petr Filip 29.07.05


TPV - přehled referenčních artiklů

TPV - přehled referenčních artiklů
V přehledu referenčních artiklů je možné zadávat na záložce Pracovní výkony variantu operace (funkčnost je obdobná jako u vztažených artiklů).

V parametrech TPV je možné nastavit 'Předplňovat číslo varianty=Ano'. Toto nastavení se projeví při zadání nového referenční artiklu předplněním nejvyššího volného pořadového čísla uvedeného ve variantě stejné operace mezi již existujícími referenčními artikly (6 cifer).
Při vstupu nového pracovního výkonu se při nastavení parametru 'Předplňovat číslo varianty=Ano' předplňuje varianta uvedená u referenčního artiklu. Při nastavení parametru 'Předplňovat číslo varianty=Ne' se předplňuje pomlčka.
Ing. Petr Filip 11.07.05


Validace na existující IČO v adresáři

Validace na existující IČO v adresáři
Bylo změněno řešení validace na existující IČO při vstupu adresáta.
V případě, že uživatel vstoupil nového adresáta s IČO, které již v adresáři existuje nebo změnil IČO dříve založeného adresáta na IČO, které již v adresáři existuje, je zobrazen formulář s hlášením:
IČO xxxxx bylo již užito pro adresáta xxx.

Stisk tlačítka OK - povolí vstup adresáta se zadaným duplicitním IČO
Stisk tlačítka Storno - nutí uživatele IČO změnit

Při stisku tlačítka OK je možné zaškrtnout volbu 'Vypnout kontrolu duplicitního IČO pro toto spuštění formuláře', která způsobuje potlačení kontroly duplicitního IČO pro právě jen spuštěný formulář 'Adresář' (využije se při importu dat do adresáře).
Ing. Petr Filip 13.07.05


Číselné řady

Číselné řady
Pro zakládání procesu s jinou identifikací roku v čísle procesu, která neopovídá roku v datu události, byl doplněn parametr nastavení programu BM v sekci Procesy:

rok_podle_ucetniho_obdobi=1

Způsobí založení procesu s rokem podle identifikace účetního období, do kterého spadá datum události.
Pozor - přebírají se pouze prvé čtyři znaky identifikace účetního období.
Používá se v implementacích, kde účetní rok neodpovídá roku kalendářnímu.
Ing. Petr Filip 27.06.05


Multiverze v BM

Multiverze v BM
Pro používání BM ve velkém počtu multiverzí, byla doplněna funkčnost programu usnadňující implementaci v oblastech:
1/ podpora automatizovaného zakládání ODBC spojeních na stanicích
2/ automatické spouštění odpovídající databáze na databázovém serveru v okamžiku zvolení multiverze
3/ sdílení lokálních souborů ukládaných na stanicích všemi multiverzemi

K tomuto účelu jsou možná v souboru BW.INI tato nastavení:

1/ Parametr EngineName v sekci Connection
EngineName=název serveru
Uplaňuje se při startu programu, způsobí automatické vytvoření ODBC spojení:
a/ Server name: název serveru
b/ Database name: odpovídá názvu spojení
c/ Network TCP/IP: Ano
d/ Buffer size: 4096
e/ Translator: Adaptive Server Anywhere 7.0 Translator - je-li nastaven parametr Connection->Translator=1
Souvisí dále s parametrem Connection->EngineVersion, který musí být nastaven na 7, pokud se nejedná o verzi databázového serveru 8.

2/ Parametr EngineVersion v sekci Connection
EngineVersion=7
Uplatní se spolu s parametrem Connection->EngineName nebo Connection->DatabaseFile. Určuje verzi databázového serveru vytvářeného spojení resp. verzi serveru, na které má být automatizovaně spuštěna po zvolení multiverze odpovídající databáze.

3/ Parametr Translator v sekci Connection
Translator=1
Uplatní se spolu s parametrem Connection->EngineName. Určuje, že vytvářené spojení má používat translator "Adaptive Server Anywhere 7.0 Translator"

4/ Parametr DatabaseFile v sekci Connection
DatabaseFile=maska DB souboru
Způsobí při startu programu start databáze na databázovém serveru určeném parametrem Connection->EngineName.
V parametru se musí vyskytovat tři znaky #, které budou nahrazeny názvem spojení, po tomto nahrazení musí parametr odpovídat souboru DB včetně cesty na počítači, na kterém je spuštěn databázový server (např. C:\DATA\###\###.DB).
Je-li server jiné verze než 8, musí být nastaven také parametr Connection->EngineVersion.

5/ Parametr DBCPath v sekci Preferences
DBCPath=maska cesty
Definuje používání souborů s příponami DBC,DCX a DCT, které jsou potřebné pro práci BM a které jsou ukládány na lokální stanici.
Není-li parametr uveden, ukládají se tyto soubory v adresáři:
C:\[cesta programu]\[název spojení]
V parametru musí být jeden znak #, který je nahrazován pořadovým číslem současně spuštěného BM.
Dále může být v parametru obsaženo makro $CURDIR$ , které je nahrazováno [cesta programu]
Např.:
DBCPath=C:$CURDIR$\DBC\#
Parametr se nesmí používat se současně nastaveným parametrem Preferences->DBCOpenShare.
Ing. Petr Filip 27.06.05


Formulář Uživatelé programu

Formulář Uživatelé programu
K uživateli programu byla doplněna položka Telefon.
Ing. Petr Filip 16.04.05


Import/Export dat

Import/Export dat
V definici spojení pro import/export dat je nyní možné uvádět v atributu 'Spojení OS' znak *,
což má stejný dopad, jako kdyby v něm bylo uveden název ODBC spojení programu BM k databázi.

Ing. Petr Filip 16.04.05


Obecné předkontace

Obecné předkontace
Ve formuláři obecné překontace se nově uvádí druh obecné překontace, který určuje přístupová práva uživatelů žádné/čtení/zápis.
Ing. Petr Filip 16.04.05


Ovládání formulářů

Ovládání formulářů
Byla rozšířena možnost horizontálního zvětšení oken jiných než formulářů událostí, aktuálních hodnot a obratových hodnot.
Jedná se o formuláře:
Artikl obecné komponenty
Artikly skladu
Artikly výroby
Ceník artiklu
Číselné řady
Druhy hodnot
Druhy operací
Druhy procesů
Kalendáře směn výroby
Kategorie událostí správy artiklu
Konta
Konta se selektory
Obecné kalendáře
Obecné předkontace
Obchodní selektor
Obchodovatelný artikl
Obratová tabulka
Obratová tabulka se selektory
Operace
Organizační selektor
Položky smluv
Procesy
Předmět projektu
Přehled referenčních artiklů
Přehled směn výrobních linek
Přehled záloh
Přehled záloh plnění smluv
Přístupová práva
Přístupy k procesům a operacím
Sklady
Skupiny uživatelů
Spravovaný majetek
Tabulky vztahů artiklů
Technicko-věcný selektor
TP k datu rozpracované na KJ
Účetní saldokonto
Účetní saldokonto do data
Účtový rozvrh
Uživatelé programu
Výrobní úkoly (úprava)
Vývěska
Zprávy

V souvislosti s tím pro připomenutí - maximalizace okna resp. stažení maximalizovaného okna se provádí klávesou CTRL+F10

Ing. Petr Filip 16.04.05


Výkazy

Výkazy
V kódu funkce výkazu (atribut kód) je nyní možné uvádět skript v jazyce Foxpro.
Tento skript musí začínat slovem SCRIPT.
Má-li funkce funkce definované parametry, jsou tyto k programu skriptu dostupné jako proměnné identifikované _par_ + název parametru.

Funkce typu seznam musí vytvářet kurzor s aliasem _WORK, ostatní musí vracet požadovanou hodnotu příkazem RETURN.

Příklad skriptu :
SCRIPT
LOCAL _navrat
_navrat=tool.sql_dotaz([select sum(uc03ksvyk*(if ucrozvrh.uc01strana=1 then 1 else -1 endif)) from %%%.ucobrtab,%%%.ucrozvrh where uc01id like ?_p1 ]+;
[and uc03mesic=?_p2 and uc03rok=?_p3 and uc03druh=?_p4 and uc03faze=2 ]+;
[and oc01id='CZK' and ucobrtab.uc01id=ucrozvrh.uc01id],_par_ucet,_par_mesd,_par_rokd,_par_druh)
_navrat=_navrat+563
RETURN _navrat
Ing. Petr Filip 16.04.05


Spojení adresáta

Spojení adresáta
byl doplněn parametr nastavení BM v sekci Adresar - Spojeni_Vyber=1, které způsobí při vyvolání formuláře spojení adresáta vždy vstup na výběrovou záložku (např. po F2).
Kromě toho byly do mřížky tohoto formuláře doplněny atributy město a ulice jejich včetně třídění, tak aby bylo možné uchovat nastavení mřížky se tříděním podle města nebo ulice.
Ing. Petr Filip 29.03.05


Zkušební doba

Zkušební doba
Činnost "Karta pracovníka" má nově na záložce "Pracovní poměry" umístěny atributy "vznik prac. poměru", "skončení prac. poměru" a atribut "Zkušební doba".

Činnost "Další informace" má atributy "vznik a skončení pracovního poměru" uvedeny pouze informativně, bez možnosti opravy.

Atribut "Zkušební doba" je v činnosti "Karta pracovníka" předplňován podle těchto pravidel :
· Předplňování je řízeno nastavením v činnosti "Parametry". (V činnosti "Parametry" je atribut "Velikost zkušeb. doby v měs. (0=nepředplňovat)". Nechci-li velikost zkušební doby předplňovat je zde zadáno 0. Pokud zkušební dobu chci předplňovat, zadá se zde počet měsíců, po které bude zkušební doba trvat.)
· Jestliže zadávám zcela nový záznam o pracovním poměru pracovníka (tj. přidávám na "Kartu pracovníka" další pracovní poměr), pak se atribut "zkušební doba" předplní.
· Jestliže opravuji dříve vzniklý záznam o pracovním poměru pracovníka, pak se atribut "zkušební doba" NEpředplní. (takto je tedy možné zadat, že pracovník nebude mít žádnou zkušební dobu, nebo že bude mít jinou, která nebude v souladu s nastavením v "Parametrech".)
· Použitím činnosti "Volby - Nastavení zkušební doby" - nad "Kartou pracovníka" (záložkou "Pracovní poměry") - se atribut "zkušební doba" nastaví opět v souladu s údaji v "Parametrech".

Příklad nastavení v souladu s údaji v "Parametrech" :
a) Vznik pracovního poměru 1.1.2003, velikost zkušební doby 6, zkušební doba 30.6.2003
b) Vznik pracovního poměru 5.1.2003, velikost zkušební doby 6, zkušební doba 4.7.2003

Ing. Olga Smitková 30.03.05


Mzdy - Parametry

Mzdy - Parametry
Činnost "Parametry" byla rozšířena o atributy, které určují adresáta, na kterého se bude odvádět daňový bonus.

Tyto atributy byly předplněny podle údajů atributů, které určují kam se odvádí zálohová daň.

Daňový bonus vzniká při výpočtu mezd, u pracovníků, kteří ho uplatňují a dále postupuje do zpracování v komponentě platby.
Ing. Olga Smitková 09.02.05


Mzdy - výstup - události

Mzdy - výstup - události
Upravena činnost "Druh události" - Překryvné seznamy "Do účetnictví", "Do plateb", "Do statistiky","Ostatní" byly rozšířeny na možnosti " Ano, Ne, Ano v absolutní hodnotě, Ano s obráceným znaménkem".

V souladu s tímto rozšířením byly přepracovány i šablony, které se používají při tvorbě událostí mezd.

A proto je NUTNÉ, aby si uživatelé znovu nastavili výstup těchto mzdových položek :
- Nepřítomnosti pro nemoc
- Vyrovnání ročního daňového přeplatku
- Měsíční daňový bonus
- Roční daňový bonus

Ing. Olga Smitková 07.02.05


Obecný kalendář

Obecný kalendář
V IS BM je možné definovat Obecné kalendáře volbou hlavního menu programu:
INFORMAČNÍ CENTRUM -> TYPY A ŘADY -> Obecné kalendáře

Je možné definovat adresáře typu:
1/ Denní kalendář
2/ Týdenní kalendář

Tyto typy souvisí s uloženou funkcí databáze 'SPKALEN_platny_den', která slouží ke zjišťování platného data určeného kalendáře v SQL dotazech.
Pro typ 'Denní kalendář' musí být jednotlivé platné dny kalendáře vyjmenovány (záložka Jednotlivé dny kalendáře).
Pro typ 'Týdenní kalendář' je den považován za platný pokud odpovídá určenému dne týdne daného kalendáře (záložka Dny v týdnu kalendáře).

Záložka Dny v týdnu kalendáře -
obsahuje výčet dnů v týdnu, které mají pro daný kalendář význam - pro typ kalendáře Týdenní má význam pro vyhodnocení funkcí 'SPKALEN_platny_den' a pro oba typy určuje dny v týdnu a část dne pro funkci 'Předplnit kalendář' , kterou je možné automatizovaně vstupovat jednotlivé dny kalendáře.
Kromě dne v týdnu se zadává v překryvném seznamu část dne. Klávesou F2 se na tomto překryvném seznamu vyvolává formulář pro definování částí dne. Podstatnou informací části dne pro vyhodnocování funkcí 'SPKALEN_platny_den' je počáteční a konečná hodina (vyhodnocuje datum včetně času).
Částí dne může být např. pracovní směna nebo celý den.

Záložka Jednotlivé dny kalendáře -
obsahuje výčet jednotlivých dnů kalendáře - pro typ kalendáře Denní musí být den na této záložce uveden jako platný, proto aby funkce 'SPKALEN_platny_den' vyhodnotila jí vyhodnocované datum jako platné.
Platný den uvedený pro typ kalendáře Týdenní, který není dnem v týdnu uvedeným na záložce 'Dny v týdnu kalendáře' , je funkcí 'SPKALEN_platny_den' vyhodnocen jako platný.
Neplatný den uvedený pro typ kalendáře Týdenní, který je dnem v týdnu uvedeným na záložce 'Dny v týdnu kalendáře' , je funkcí 'SPKALEN_platny_den' vyhodnocen jako neplatný.
Kromě datumu se na této zálože uvádí část dne a stav dne Platný/Neplatný.

Funkce - SPKALEN_platny_den
Parametry: in @spd3id char(6),in @spd4datum timestamp,in @bw10nazev char(8),in @spd7id char(6)
@spd3id - identifikace kalendáře
@spd4datum - datum/datumčas - dotazované datum
@bw10nazev - entita, které se týká výjimka kalendáři
@spd7id - hodnota primárního klíče entity, které se týká výjimka kalendáři

Funkce vrací numerickou hodnotu (tinyint) :
0 - dotazované datum v určeném kalendáři je neplatné
1 - dotazované datum v určeném kalendáři je platné

Parametry @bw10nazev a @spd7id souvisí s používáním obecných kalendářů v komponentách IS BM. V současné době se jedná o komponentu Expedice, kde má smysl definovat kalendář pro trasu pro výpočet rozdělení dodacích listů na expediční příkazy.
Např. tuto trasu jezdíme v pondělí a ve čtvrtek, a můžeme zadat pro ní vyjímku tento konkrétní den i když je to středa tuto trasu pojedeme nebo výjimku pro jiný den i když je to čtvrtek nepojedeme, protože je sněhová kalamita.
V expedici se používají obecné kalendáře také ve spojení s tabulkou řidičů.
Výjimky v kalendáři jsou ukládány ve společné entitě (SPKALENV).

Př.:
obecný výběr událostí vývěsky, které mají platné datum podle kalendáře 'K1'
bm_servis.SPKALEN_platny_den('K1 ',VYUDALOS.vy01datum,null,null)=1

Obecný kalendář používá tyto tabulky:
SPKALEN - Obecný kalendář
SPKALENT - Den v týdnu obecného kalendáře
SPKALEND - Den obecného kalendáře
SPKALENC - Část dne v obecném kalendáři
SPKALENV - Výjimka v obecném kalendáři

Ing. Petr Filip 23.02.05


Podpora Windows Terminal Server

Podpora Windows Terminal Server
Nová nastavení BM pro podporu implementací v prostředí Windows Terminal Server.

DbcOpenShare=1
Povolí možnost spustit stejnou aplikaci BM vícekrát na jednom počítači.
Není-li tento parametr nastaven na 1, hlásí program při současném spuštění BM:
"Není možné otevřít definiční soubor komunikace s databází. Možné opakované spuštění programu.".
V prostředí Windows Terminal Server je tímto umožněno opakovaně spustit stejnou implementaci BM na počítači, který pracuje jako server, a tím je možný přístup většího počtu užvatelů.

Bitmap=Off
Za normálních okolností BM překresluje obrazovku tak, že v paměti nakreslí potřebnou bitmapu a poté celou bitmapu zobrazí.
U normálních implementací je takto zajištěn vyšší výkon při zobrazování, implementace běžící v prostředí Citrix nebo Windows Terminal Server jsou na tom ale opačně - jejich výkon klesá.
V těchto prostředích je totiž klientovi odesílány každá změna obrazovky. Protože i sebemenší změna na obrazovce BM znamená překreslit celý obsah obrazovky, zvyšuje se celkové množství zasílaných dat.
Neuvedení parametru odpovídá nastavení Bitmap=On, které znamená překreslování obrazovky pomocí bitmap.
Nastavení Bitmap=Off je vhodné pro implementace běžící v prostředí Citrix nebo Windows Terminal Server.
Nastavení tohoto parametru je možné provádět pro konkrétní počítače a uplatní se teprve po následném spuštění BM.
Aktuální chování BM z hlediska překreslování bitmap se zobrazuje ve formuláři "O aplikaci".

Parametr 'Bitmap=Off' má smysl definovat pouze v BM pod Foxprem verze 8 nebo vyšší, jinak je možné vypnout překreslování obrazovek pomocí bimap přidáním řádku Bitmap=Off do souboru CONFIG.FPW.

Ing. Petr Filip 05.02.05


Transformace

Transformace
Byla doplněna funkčnost pro parametrizaci transformací v procesech.

Ve vazbách operací v diagramech procesů je možné, kromě transformace, definovat obecnou předkontaci.
Hodnoty položek dané předkontace jsou vyhodnotitelné ve výrazech pravidel transformace.

Obecné předkontace se v definici vazby operací vybírají z překryvného seznamu, ve kterém se nabízejí ty, které jsou určeny pro danou transformaci (ve fomuláři pro vstup transfomací přibyla záložka 'Obecné předkontace', ve které se definují ty předkontace, které je možné pro danou transformaci používat).
Pravý klik na tomto překryvném seznamu, vyvolává formulář pro definování obecných předkontací, ve kterém jsou zobrazeny pouze ty, které jsou povoleny pro danou transformaci. V tomto případě vstup nové obecné předkontace automaticky připojují toto předkontaci k dané transformaci.

Ve výrazech transformací je možné používat dvě nové makra:
###OPT###([,]) - vrací hodnotu položky předkontace uvedené v transformaci platné volitelně k určenému datu,
kde
- je identifikace významu položky předkontace
- je nepovinný parametr - výraz, který po vyhodnocení určuje datum, ke kterému má být zjištěná hodnota platná
###OP###(,[,]) - vrací hodnotu položky určené předkontace platné volitelně k určenému datu,
kde
- je identifikace obecné předkontace
- je identifikace významu položky předkontace
- je nepovinný parametr - výraz, který po vyhodnocení určuje datum, ke kterému má být zjištěná hodnota platná
Makra vrací textovou hodnotu a v případě odpovídající hodnota položky předkontace neexistuje vrací prázný text.

Je-li některé z těchto maker použito v definici výrazu, musí být uveden jeho dvojí prefix vlnovka (~).
Např.:
~~###OPT###('UCE311',data.pl02datpla)
~~###OP###('PLAUCT','UCE311',data.pl02datpla)
~~VAL(###OPT###(data.ad01id,data.ob02dat))

Ve formuláři pro definování výrazů přibyla záložka 'Položky předkontací', která je dostupná, pokud byl vyvolán po F2 při zadávání pravidel transformace. Zde jsou zobrazeny hodnoty položek překontací povolené pro danou tranformaci, které je možné upravovat.
Volba 'Význam předkontace do schránky' na této stránce vloží do clipboardu odpovídající tvar makra ###OPT###.

Ve skriptech doplnění pohledu transformací je identifikace předkontace aktuálně zpracovávané transformace dostupná v proměnné _SP19ID a hodnoty položek předkontace je v nich potom možné získat použitím metody 'get_obecna_predkontace' objektu TOOL.
Např.:
SELECT (_alias)
_ucet311=tool.get_obecna_predkontace(_sp19id,'UCE311',pl02datpla)
_sleva=VAL(tool.get_obecna_predkontace(_sp19id,ad01id,ob02dat))

Ing. Petr Filip 12.02.05


Výkazy

Výkazy
Komponenta účetnictví nesprávně aktualizovala obratovou tabulku v případě, že účetní období neodpovídalo kalendářnímu roku.
Tato chyba byla odstraněna.

V definici 'Dotazu výkazů' přibyla možnost definovat kód v jazyce Foxpro, který je spouštěn bezprostředně po vstupu dotazu.
Tento kód může přidávat nové a měnit definované proměnné dotazu výkazu.
Proto má k dispozici funkce objektu _THIS, který je kódu předáván v okamžiku jeho vyvolání:
_THIS.CTENI_PROMENNE() - kde je textová identifikace proměnné dotazu, vrací hodnotu proměnné, v případě, že proměnná neexistuje vrací .F.
_THIS.ZAPIS_PROMENNE(,) - kde je textová identifikace proměnné dotazu a je její požadovaná hodnota, je založena nová proměnná, pokud dosud neexistuje

Např.:
.
.
_THIS.CTENI_PROMENNE('ROK')
.
.
_THIS.ZAPIS_PROMENNE('ROK','2005')
.
.

Příkladem použití kód v 'Dotazu výkazů' je určení začátku a konce předcházejícího účetního období v případě, že účetní období odpovídající uživatelem zadanému datu nebo předcházející účetní období neodpovídají kalendářnímu roku.
Ing. Petr Filip 12.02.05


Zákonné pojištění odpovědnosti

Zákonné pojištění odpovědnosti
Do Bílého Motýla byla zabudována možnost výpočtu zákonného pojištění odpovědnosti za škodu.

Nastavení programu :
· Činnost "Parametry" - nastavit atribut "sazba(promile)" - uvádí promile čtvrtletního odvodu na zákonné pojištění odpovědnosti. Je-li uvedena nula, pak se zákonné pojištění nepočítá.

· Činnost "DEFINICE - Odvody" - nastavit dvě nové položky I40000 (základ zákonného pojištění odpovědnosti) a I41000 (odvod zákonného pojištění odpovědnosti).

· Činnost "SPECIÁLNÍ ČINNOSTI" - činnost "Výpočet zákonného pojištění odpovědnosti organizace". Činnost předplní předpokládané čtvrtletí výpočtu podle datumu poslední uzávěrky. Vypočítá součet základů sociálního pojištění v tomto čtvrtletí a součet uloží do mzdové položky I40000. Z tohoto základu vypočítá odvod zákonného pojištění a uloží ho do položky I41000. Tyto dvě nové položky se zapíší k pracovníkovi "- " a pracovnímu poměru "01", do měsíce a roku, který je právě zpracováván.

Dle informací z ASPII :

125/1993

(2) Pojistné si vypočítává zaměstnavatel ze základu stanoveného shodně s postupem pro určení vyměřovacího základu pojistného na sociální zabezpečení a příspěvku na státní politiku zaměstnanosti dle zvláštního zákona. (§ 5 odst. 1 písm. a) zákona č. 589/1992 Sb., o pojistném na sociální zabezpečení a příspěvku na státní politiku zaměstnanosti). Základem pro výpočet pojistného je souhrn vyměřovacích základů za uplynulé kalendářní čtvrtletí všech zaměstnanců, které v tomto období zaměstnavatel zaměstnával. K výpočtu použije sazbu uvedenou v příloze této vyhlášky pro příslušnou kategorii určenou podle převažující základní činnosti tvořící předmět podnikání zaměstnavatele.

(3) Pojistné za I. čtvrtletí každého kalendářního roku je splatné do 31. ledna, za II. čtvrtletí do 30. dubna, za III. čtvrtletí do 31. července a za IV. čtvrtletí do 31. října. Pojistné za I. a II. čtvrtletí 1993 je splatné do 31. května 1993.

(4) Vznikne-li zaměstnavateli, který v předcházejícím čtvrtletí nezaměstnával žádného zaměstnance, povinnost platit pojistné na toto pojištění, zaplatí zaměstnavatel první pojistné vypočítané ze základu dle odstavce 2 stanoveného pro dané čtvrtletí, a to zpětně, nejpozději do konce prvního měsíce následujícího čtvrtletí.

Ing. Olga Smitková 07.02.05


Zvětšování formulářů BM

Zvětšování formulářů BM
podle parametrů uživatele bylo rozšířeno o možnost nastavení koeficientu zobrazení mřížky.
Při nastavení rozdílného 'Koeficientu zobrazení' a 'Koeficientu zobrazení mřížky' ve formuláři 'Parametry uživatele', jsou velikosti písma textů mřížkách a ostatních textů formářů BM rozdílné.
Ing. Petr Filip 05.02.05


Oceňování v komponentě obchod

Oceňování v komponentě obchod
Přidělení cenové skupiny při vstupu události obchodu je možné podle adresáta nebo podle příjemce uvedeného v události.

Převažující nastavení pro všechny události obchodu se provádí v 'SYSTÉM -> Nastavení BM' uvedením parametru v sekci 'Obchod' -> 'cen_skp_podle_adresata=0' (pro určení cenové skupiny podle příjemce) nebo 'cen_skp_podle_adresata=1' (pro určení cenové skupiny podle adresáta - default).
Kromě toho je možné definovat toto nastavení definovat různě pro jednotlivé druhy událostí komponenty obchod v parametrech druhu pro obchod ( činností 'INFORMAČNÍ CENTRUM -> Druhy operací -> volba Parametry operace komponenty').
Uvádí se zde parametr (překryvný seznam) 'Cenová skupiny podle' - 'Nastavení BM / Adresáta / Příjemce'
Ing. Petr Filip 09.11.04


Přecenění záloh na konci roku

Přecenění záloh na konci roku
Pro druhy událostí komponenty zálohy je nyní možné definovat Parametr komponenty 'Operace pro určení kurzového rozdílu zálohy'.

Události tohoto druhu musí být charakteru vyúčtování zálohy a vstupuje se na nich pouze částka v referenční měně (částka v ZM a částka v měně úhrady zůstávají nulové).

Událostí tohoto druhu se mění referenční hodnota zálohy, která byla uhrazena v cizí měně - mění se její hodnota v referenční měně logicky - ne v atributu události, kterou byla záloha uhrazena.

Pro výpočet událostí tohoto druhu přeceňující zálohy podle kurzu byla vytvořena doplňující vlastnost formuláře 'Update podle kurzu' .
Zadává se:
1/ Zálohy - Přijaté/Poskytnuté
2/ Datum přecenění
3/ Měna

Hodnota se vypočítává podle vzorce:
(dosud nevyúčtováno v měně úhrady)*(kurz data přecenění) - (dosud nevyúčtováno v měně úhrady)*(kurz data úhrady) - (suma všech předchozích přecenění hodnoty zálohy v RM)

Aktuální hodnotu zálohy v RM je možné stanovit vzorcem:
(dosud nevyúčtováno v měně úhrady)*(kurz data úhrady) + (suma všech přecenění hodnoty zálohy v RM)

Kontrolu správnosti výpočtu je možné ověřit po přecenění zadáním vyúčtování zálohy ve stejném kurzu, jako byl kurz přecenění. Takové vyúčtování musí mít kurzový rozdíl roven 0.

Pozn.1:
Přecenění zálohy na konci roku musí proběhnout před její první úhradou v novém roce.

Pozn.2:
Přecenění záloh nesprávně funguje v situaci, kdy je třeba přecenit dvě stejně identifikované a přitom nevyúčtované zálohy .
V tomto případě výpočet přecenění hlásí duplicitu záloh, protože není možné určit, ke které úhradě zálohy přeceňující událost patří.
Ing. Petr Filip 18.11.04


Předlohy výstupu

Předlohy výstupu
viz dokument objektu

**************************************
byla doplněna nová funkčnost pro definování předloh výstupu typu Excel.

Zůstala zachována možnost definovat předlohy dvojího typu:
1/ deklaračního typu
2/ programového typu

Nová funkčnost byla doplněna v deklaračním typu excelovských předloh výstupu s cílem usnadnit širšímu okruhu uživatelů BM jednoduše vytvářet a upravovat výstupu do Excelu.

Bylo změněno:
1/ generátor výstupu podle definice
- možnost použití šablon (soubor XLT)
- možnost vytváření víceúrovňových mezisoučtů
- rozšířené formátování výstupu

2/ nový editor deklaračních předloh výstupu
- doposud se definice upravovala textovým editorem Foxpro
- nově se definice upravuje ve formuláři, ve kterém se definují vlastnosti listu a vlastnosti jednotlivých sloupců

Editor deklaračních předloh výstupu do Excelu
----------------------------------------------------------------------------------
Formulář obsahuje dvě záložky. Záložku pro deklaraci vlastností listu a záložku pro deklaraci vlastností jednotlivých sloupců listu.

Záložka List
-----------------------
1/ Název listu - výraz v syntaxi Foxpro (obvykle textová kontanta) - určuje název listu v Excelu
2/ Soubor - text - určuje výstupní soubor
3/ Šablona - text - určuje šablonu (XLT), podle které se založí list
4/ R-Agregace - výraz v syntaxi Foxpro - řádková agregace - po sobě následující zpracovávané záznamy, pro které je hodnota vyhodnocení záznamu shodná, budou sloučeny do jednoho řádku vystupujícího do Excelu a při tom jsou načítány hodnoty ve sloupcích, ve kterých je definována hodnota
5/ Indexovat - zaškrtávací políčko - zaškrnuté způsobí při uvedeném R-Agregace indexování podle tohoto výrazu
6/ Podpis řádek 1 - 3 výrazy v syntaxi Foxpro - hodnota bude vložena na konci listu do prvých tří sloupců
7/ Podpis řádek 2 - 3 výrazy v syntaxi Foxpro - hodnota bude vložena na konci listu za řádek 1 podpisu do prvých tří sloupců
8/ Podpis řádek 3 - 3 výrazy v syntaxi Foxpro - hodnota bude vložena na konci listu za řádek 2 podpisu do prvých tří sloupců
9/ Textframe 1 - 1x text + 1x výraz v syntaxi Foxpro - hodnota výrazu bude vložena do pojmenovaného textového rámce - název rámce je dán textem - předpokládá se, že se tento rámec vyskytuje v šabloně
10/ Textframe 2 - 1x text + 1x výraz v syntaxi Foxpro - hodnota výrazu bude vložena do pojmenovaného textového rámce - název rámce je dán textem - předpokládá se, že se tento rámec vyskytuje v šabloně
11/ 1.řádek - numerická hodnota - určuje první řádek výstupu na listu
12/ 1.sloupec - numerická hodnota - určuje první sloupec výstupu na listu
13/ Celková suma - překryvný seznam - Ano/Ne/Ano tučně/Ano kurzívou/Ano tučně+kurzívou - odpovídající hodnota způsobuje vytvoření závěrečného součtového řádku za všechny řádky výstupu v požadovaném formátu
14/ Automatický formát - zaškrtávací políčko - zaškrnuté způsobí přizpůsobení šířky sloupců
15/ Tisk na šířku - zaškrtávací políčko
16/ Rychlý výstup - zaškrtávací políčko - zaškrnuté urychluje výstup do Excelu -
17/ Tlačítko OK - uložení změn a ukončení formuláře
18/ Tlačítko Storno - ukončení formuláře bez uložení změn
19/ Tlačítko Editor - vyvolá editor Foxpro se vstupem dané definice

Záložka Sloupce
----------------------------
1/ Seznam sloupců - v seznamu je možné sloupce přesouvat
2/ Nadpis - výraz v syntaxi Foxpro (obvykle textová kontanta) - určuje nadpis sloupce
3/ Název sloupce - text - je určen pro definování sloupců typu vzorec
4/ Typ - překryvný seznam - Text/Hodnota/Vzorec
a/ text - znakové a datumové položky
b/ hodnota - numerické hodnoty
c/ vzorec - výpočtové sloupce
5/ Výraz obsahu - pro typy text nebo hodnota výraz v syntaxi Foxpro, pro typ vzorec text odpovídající výpočtovému výrazu v Excelu, ve kterém je možné uvádět odkazy na sloupce pomocí názvů sloupců v hranatých závorkách
6/ Formát - text - obvykle určuje formátování čísla (např.#,###.00) viz. dokumentace Excelu
7/ Šířka - numerická hodnota - nepovinná - určuje šířku sloupce
8/ Font - překryvný seznam - -/Tučně/Kurzívou/Tučně+kurzívou
9/ Svislé ohraničení - překryvný seznam - -/Levé/Pravé/Levé+pravé
10/ Suma - zaškrtávací políčko - zaškrnuté určuje, že sloupec bude součtován v součtových řádcích
11/ Neopakovat - zaškrtávací políčko - zaškrnuté určuje, opakovaná hodnota ve sloupci nebude v následujících řádcích zobrazena
12/ Mezisoučet - překryvný seznam - Ano/Ne/Ano tučně/Ano kurzívou/Ano tučně+kurzívou - odpovídající hodnota způsobuje vytvoření mezisoučtového řádku při změně hodnoty ve sloupci
13/ Dynamický sloupec - maximální počet sloupců - numerická hodnota - je-li uvedena kladná hodnota omezuje počet sloupců dynamického sloupce
14/ Dynamický sloupec - S-Agregace - výraz v syntaxi Foxpro - sloupcová agregace, která se používá ve spojení s řádkovou agregací (S-Agregace). Podle tohoto výrazu se při slučování řádků vytvářejí sloupce. Slučované řádky, pro které tento výraz nabývá shodnou hodnotu, jsou sečteny do tohoto sloupce s hodnotami vyhodnocení Výrazu obsahu.
15/ Výběr - výraz v syntaxi Foxpro - výraz musí nabývat logickou hodnotu - je-li výraz uveden a při zpracování řádku nabyde hodnotu nepravda (FALSE) - nebude hodnota do sloupce výstupního řádku vložena resp.přičtena
16/ Poznámka - libovolný text
17/ Tlačítko Nový - založení nového sloupce typu Text/Hodnota
18/ Tlačítko Nový (vzorec) - založení nového sloupce typu Vzorec
19/ Tlačítko Odstranit - zrušení sloupce
20/ Tlačítko Kopie - vložení kopie aktuálního sloupce

Pozn.1:
Při vytváření nové předlohy typu Excel se ve formuláři výběru položek zařazených do nové předlohy doposud předlpňovalo vytváření předlohy programového typu. Nyní se předplňuje vytváření předlohy deklaračního typu.

Pozn.2:
Pro příklad použití dynamických sloupců byla vytvořena předloha výstupu nad událostmi komponenty obchod nazvaná 'Zkušební příklad v Excelu'

Ing. Petr Filip 18.11.04


Příprava vzdálené databáze pro replikace

Příprava vzdálené databáze pro replikace
bez nutnosti provedení extraktu.

V popisu se používá
- D1 = konsolidovaná databáze
- D2 = vzdálená databáze
- user_01 = publisher konsolidované databáze
- user_02 = remote user konsolidované databáze

1/ kopie databáze D1.DB na D2.DB
2/ otevření D2.DB v Sybase SQL Centralu
3/ zrušení uživatele user_01
4/ změna uživatele user_02 - není remote - 'Revoke remote' po pravém kliku
5/ změna uživatele user_02 na publisher - 'Set publisher' po pravém kliku
6/ nastavení Remote message types tak, aby odpovídal adrese user_02 jako je v databázi D1
7/ vytvoření remote uživatele user_01 s adresou Remote message types jako je v databázi D1
8/ přidělení publikace pub_01-02 uživateli user_01
9/ odstartovat publikaci pro uživatele user_02 po volbě 'Properties' po pravém kliku -> z obrazovky 'user_02 properties' -> záložka 'SQL Remote' -> tlačítko 'Advanced' -> v následujícím okně tlačítko 'Start now'
10/ uzavření Sybase SQL Centralu
11/ otevření D1.DB v ISQL
12/ vykonat příkaz 'REMOTE RESET user_02'
13/ uzavření ISQL

Ing. Petr Filip 02.11.04


Spojení adresáta v událostech

Spojení adresáta v událostech
Ve výběrech událostí komponent:
Platby,Sklad,Obchod,Zálohy,Pošta,Změna stavu peněz,Vymáhání
bylo doplněna možnost výběru podle spojení adresáta.

V komponentě Vývěska bylo v události doplněno spojení adresáta.

Vyvolání přehledu událostí adresáta po pravém kliku na návěští adresáta předplňuje na výběrovou záložku spojení adresáta, pokud není nastaven v 'Nastavení BM' parametr 'Vyber_spojeni_adresata=0' v sekci 'Komponenta-XXX', kde XXX odpovídá identifikaci komponenty.

Po pravém kliku na návěští adresáta je možné vybrat události 'Obchod - příjemce'.

V komponentách
Platby,Sklad,Obchod,Zálohy,Pošta,Změna stavu peněz,Vymáhání,Vývěska a Expedice se ve formuláři událostí zobrazuje v atributu odpovídajícímu názvu adresáta - 'Název adresáta'+', Město z adresy'+', Kontaktní osoba ze spojení adresáta' nebo nový atribut 'Alias' z tabulky spojení adresáta (ad11adsat z tabulky ADSPOJ), je-li vyplněn.

Ing. Petr Filip 09.11.04


MZDY - Volné údaje

MZDY - Volné údaje
Nad činností Karta pracovníka je možné pomocí klávesy F9 vyvolat činnost Volné údaje pracovníků.

Obsah této činnosti odpovídá třetí záložce v činnosti Karta pracovníka. Uživatel zde ale nepracuje pouze s údaji jednoho pracovníka, ale je zde výběr, který umožňuje volit všechny pracovníky a další výběrové parametry. Záznamy je možné vkládat, opravovat a rušit.

Pozor - při použití této činnosti není brán v potaz nadefinovaný výskyt parametrů (např. 0:1, 1:1, 1:M, ...)
Ing. Olga Smitková 04.10.04


Typ zdanitelného plnění

Typ zdanitelného plnění
ve formuláři Typ zdanitelného plnění přibyla záložka 'Substituce TZP'.

Nastavení uvedená na této záložce se uplatňují při vstupu událostí obchodu.
Při vstupu nové události způsobí přeplnění jiného TZP než je uvedeno u artiklu , a to podle TZP a klasifikace uvedené u artiklu obchodu příznaku plátce DPH a typu místa plnění uvedeného u vstupovaného adresáta.
V substituci se udádí:
- identifikace TZP
- typ místa
- odpočet/nápočet
- příznak plátce DPH adresáta
- klasifikace artiklu obchodu
- datum platnosti od
- datum platnosti do

Př.:
- je vstupována událost obchodu - prodej pro adresáta s typem místa EU, který je plátcem DPH a artiklem, který má u sebe uvedenu klasifikací Z (zboží) a typ zdanitelného plnění ZA1
- pro TZP ZA1 je definovaná substituce (OSV,EU,Nápočet,Plátce DPH=Ano,Z)
- potom na události obchodu bude předplněn TZP OSV

Ing. Petr Filip 25.08.04


Událost obchodu

Událost obchodu
oprava programu:
při změně typu zdanitelného plnění jsou vynulovány vypočtené částky základu DPH a DPH
Ing. Petr Filip 25.08.04


Volné karty

Volné karty
Změny v definici volné karty.

Atribut Zobrazení
Je možné uvádět libovolně dlouhý text

Atribut Zobrazení pro třídu Překryvný seznam a typ znakový
Je možné zadat SQL dotaz uvedený znaky *~
Dotaz musí vracet dva sloupce. První sloupec určuje text zobrazovaný v překryvném seznamu a druhý hodnotu předávanou na volnou kartu.
Např. SQL dotaz pro překryvný seznam se seznamem uživatelů
*~select (if bw01aktiv=1 then '' else '* ' endif)+bw01jmeno,bw01uziv from %%%.bwuzivat where bw01uziv<>'$SYSTE' order by bw01aktiv desc,bw01jmeno

Atribut Inicializace
může obsahovat výraz uvedený znakem #
např.: #tool.uziv pro inicializaci hodnoty volné karty identifikací aktuálního uživatele systému.
Ing. Petr Filip 25.08.04


Konzultace překladu do angličtiny

Konzultace překladu do angličtiny
13.7. přišla mi SMS, kde chce další vyjádření, ale v mailu nic nemám - telefonicky jsem o tom informoval odpoledne (pí Darmokoupilová nic nevěděla).
Pokud něco chtějí ozvou se.
----------------------------------------------------------------
Dekujeme za informace, pane Jando.
V pripade dalších dotazu se na Vas opet obrátíme.

S pranim prijemneho dne!

Veronika Dvorackova
PS Skrivanek
------------------------------------------------
Vážená paní Vegešová, dobrý den,

Vzorek překladu se jeví po stránce formální v pořádku - pochopili jsme se. Současně přikládám vyplněný soubor s dotazy překladatelky, hned jsem tam přidal několik dalších zkratek.

S pozdravem

Ing.Jaroslav Janda
BM Servis s.r.o.
-------------------------------------------------
Vazeny pane Jando,

V příloze zasilam vzorek prekladu + tabulku ve wordu, kde prekladatelka pise v cj zkratky a text, kterému dobře nerozumi, takze prosim o doplneni vysvetleni.

Predem moc dekuji za připomínky a zpetnou zpravu ohledne prekladu.

Hezky den!

Zuzana Vegesova
Ing. Jaroslav Janda 13.07.04


Mzdy - platnost TV selektoru

Mzdy - platnost TV selektoru
Do komponenty Mzdy byla dopracována funkčnost hlídání platnosti technicko-věcného selektoru

Vlastnost byla zabudována do těchoto činností :
Události mezd, Úkolové listy, Události personalistiky - dle data události

Prohlížení výplatních lístků, Výplatní lístky - zadávání, Výplatní lístky - platnost TV selektoru se řídí prvním dnem měsíce, který zapisuji, tj. dle "1.mz02mesic.mz02rok"

V činnosti Karta pracovníka - záložka Pracovní poměry - platnost TV selektoru se řídí datem v Parametrech - datem zpracovávaného měsíce, tj. datem poslední uzávěrky zvětšeném o jeden měsíc.

Činnost Optimalizovaný výpočet mezd - test - platnost TV selektoru se řídí prvním dnem měsíce, který počítám, tj. this. datod

Činnost Definice mzdových položek nepodléhá kontrole na platnost TV selektoru, protože nemá časovou závislost, časová závislost se posunuje až do zadávání a výpočtu výplatních lístků.
Ing. Olga Smitková 20.07.04


Mzdy - uzávěrka

Mzdy - uzávěrka
Úprava přepočítávání hodinových, denních a měsíčních průměrů.

U pracovníků, kteří odpracovali méně než 22 dní ve zkoumaném čtvrtletí - pracovníky rozdělujeme do dvou skupin :
- pracovníci, kteří jsou v pracovním poměru déle než je zkoumané čtvrtletí - průměry se u nich nepřepočítávají a do protokolu se zapíše upozornění

- pracovníci, kteří zahájili pracovní poměr během zkoumaného čtvrtletí - průměry se přepočítají a do protokolu se zapíše upozornění
Ing. Olga Smitková 28.07.04


Objednávka překladu

Objednávka překladu
k dispozici je verze IS BM v anglické verzi
Ing. Jaroslav Janda 12.07.04


Otevřená období komponent x rušení udál.

Otevřená období komponent x rušení udál.
rušení záznamu události komponenty klávesou F8 nebo rušení označených událostí v neukončené operaci nedovolí zrušit událost, která je mimo otevřené období komponenty.

Stejně tak není povoleno změnit datum události, která byla uložena s datem, které je v daném okamžiku mimo otevřené období komponenty.
Ing. Petr Filip 01.07.04


Příprava a zajištění překladu do angl.

Příprava a zajištění překladu do angl.
Ing. Jaroslav Janda 09.07.04


Spuštění editoru na textových položkách

Spuštění editoru na textových položkách
Z okna pro vstup textu vyvolávaného na polích typu text (memo) klávesou F2 nebo pravým klikem pa položce nebo jejím návěští je možné po pravém kliku nebo F2 vybrat nově také volbu Editor, která otevře editor FoxPro.

Ve vlastnostech předlohy výstupu se nově spouští po pravém kliku na textové položce editor FoxPro a ne okno s textovou položkou dynamicky měnící svou velikost podle změn velikosti okna tak jako doposud.
Ing. Petr Filip 01.07.04


Úkolové lístky - pořadí zadávání

Úkolové lístky - pořadí zadávání
Úkolové lístky :
Do událostí úkolové lístky byl přidán nový atribut mz02poradi - pořadí události úkolového lístku. Tento atribut obsahuje pořadí vkládané události v rámci jedné operace - obdobně jako pořadí u bankovního výpisu.
Ing. Olga Smitková 28.07.04


Kód po ukončení operace

Kód po ukončení operace
Pro druh operace v druhu procesu (v diagramu) je možné kromě běžného kódu po ukončení operace nově zadávat
- Statický kód druhu operace v druhu procesu.

Tento kód se zadává po zaškrtnutí volby Statický kód druhu operace v druhu procesu ve formuláři pro vstup kódu po ukončení.

Celkový kód prováděný po ukončení operace se sestavuje spojením:
[statický kód druhu operace v druhu procesu] + [nestatický kód po ukončení operace, který je spojen s operací ve fyzickém procesu]

Z toho vyplývá, že statický kód je prováděn vždy pro danou operaci v druhu procesu i když byla operace ukončena a následně byl její stav ukončena zrušen. Narozdíl od nestatického kódu, který je po ukončení operace pro danou operaci ve fyzickém procesu vymazán.

Použití statického kódu je vhodné pro různé validace dat ukončované operace (např. musí být vyplněn selektor) nebo kódů měnících obsah dat událostí ukončované operace (v této chvíli především zaokrouhlování obchodu na 50 haléřů).

POZOR na nevhodný postup:
1/ vznikl fyzický proces s operací v jejímž kódu po ukončení je např. uvedeno DECLARE pocet=COUNT(.....
2/ implementátor upravil odpovídající druh procesu:
a/ uvedl ve statickém kódu DECLARE pocet=COUNT(.....
b/ zrušil v původním nestatickém kódu DECLARE pocet=COUNT(.....
3/ uživatel pokračuje ve fyzickém procesu a ukončuje operaci
4/ kód po ukončení operace hlásí chybu dvojí deklarace proměnné pocet
Ing. Petr Filip 15.06.04


Otevřená období komponent x zruš.st.uk.

Otevřená období komponent x zruš.st.uk.
U otevřeného období komponenty se nově uvádí:
Kontrolovat při rušení stavu ukončena - Ano/Ne

U druhu operace se nově na záložce Další uvádí:
Kontrolovat při rušení stavu ukončena - Ano/Ne

Zrušení stavu ukončena se neprovede, je-li uvedeno u otevřeného období Ano a druhu operace Ano (nebo nevyplněné Další):
1/ pokud by byla zrušena událost s datem mimo otevřené období komponenty
Ing. Petr Filip 15.06.04


Otevřená období komponet x storno

Otevřená období komponet x storno
U otevřeného období komponenty se nově uvádí:
Kontrolovat při stornu - Ano/Ne

U druhu operace se nově na záložce Další uvádí:
Kontrolovat při stornu - Ano/Ne

Storno procesu se neprovede, je-li uvedeno u otevřeného období Ano a druhu operace Ano (nebo nevyplněné Další):
1/ pokud by stornem vznikla inverzní událost s datem mimo otevřené období komponenty
2/ pokud by stornem byla zrušena událost s datem mimo otevřené období komponenty
Ing. Petr Filip 15.06.04


Upgrade databáze SQL Anywhere

Upgrade databáze SQL Anywhere
Zde je batch pro upgrade databáze z verze SQL Anywhere 7 do verze SQL Anywhere 8.

REM spustí engine abychom nemuseli vytvářet spojení
DBENG8 db7 d8p41250
REM upgadeuje data z databáze db7 do databáze d8p41250
REM v prikazu nastavte spravne parametry UID a PWD
"C:\Program Files\Sybase\SQL Anywhere 8\win32\dbunload.exe" -xi -c "dbf=db7;uid=spravce;pwd=heslo" -ac "dbf=db8p41250;uid=spravce;pwd=heslo" -v -o c:\protokol\unload.txt

Ve spojení na databázi d8p41250 se potom neuvádí translator, je možné použít klienta SQL Anywhere 7, nicméně při použití klienta SQL Anywhere 8 je odezva zřetelně lepší.
Doporučujeme nastavovat ve spojení prostřednictvím klienta na záložce 'Network' - 'Buffer size=4096'
Ing. Petr Filip 30.06.04


Výpočet daňového přiznání

Výpočet daňového přiznání
Při výpočtu daňového přiznání dochází automaticky ke kopírování proměnných daňového přiznání s hodnotami podle předchozího období,
pokud nejsou tyto proměnné pro vypočítávané období definovány.
Ing. Petr Filip 28.06.04


Kód po ukončení operace

Kód po ukončení operace
V kódu po ukončení operace je možné využít změny objektu třídy KU_DATA.

Metoda SET_PROCESS:
Byl doplněn druhý parametr, který určuje místo ve stromu procesu, od kterého je vyhledáván přecházející proces.
Uvádí se logická hodnota.
Při neuvedení druhého parametru nebo uvedené logické hodnotě FALSE (.F.) se objekt chová tak jako doposud, tj. je vyhledáván proces druhu podle prvého parametru metody ve stromu počínaje od čísla procesu odpovídajícímu aktuálně ukončované operaci.
Při uvedení druhého parametru s logickou hodnotou TRUE (.T.), se vyhledávání ve stromu zahajuje od čísla procesu, na který byl objekt nastaven posledním užitím metody SET_PROCESS.
Tato možnost souvisí s další změnou metody SET_PROCESS. Je-li jako identifikátor vyhledávaného procesu užit znak *, potom je objekt nastaven na proces, který je ve stromu bezprostředním předchůdcem uzlu ve stromu (kterého -> to je dáno hodnotou druhého parametru metody) bez ohledu na to, jakého je druhu.
Nová vlastnost objektu SP07IDTYPD - obsahuje identifikaci druhu procesu, na který byl objekt nastaven posledním užitím metody SET_PROCESS.

Nová metoda OP_EVALUATE:
Slouží ke zjištění informací o stavu operace (uzlu), na kterou byl objekt nastaven posledním užitím metody SET_OPERATION.
Metoda má jediný parametr, který obsahuje výraz, ve kterém má smysl uvádět atributy tabulky SPPRCOD - viz.datový model.
Metoda vrací hodnotu výrazu nebo FALSE (.F.), není-li možné výraz vyhodnotit.

Nová metoda OP_DELETE:
Ruší operaci (uzel) ve stromu hlavního procesu, na kterou byl objekt nastaven posledním užitím metody SET_OPERATION.
Metoda nemá parametry.
Na rozdíl od příkazu DELETE kódu po ukončení, je možné s její pomocí rušit uzly v diagramech nadřízených procesů.
Metoda vrací logickou hodnotu TRUE v případě, že zrušení uzlu bylo úspěšné.
Pozor - rušení operace není prováděno v rámci transakce kódu po ukončení operace.

Příklad 1:
DECLARE OBJECT ob
SET ob=CREATE('KU_DATA')
ob.set_process('*')
IF ob.found()
ob.set_operation('DPH','dpnsex')
IF ob.found() AND ob.op_evaluate('sp34zahaje')=0
ob.op_delete()
ENDIF
ENDIF

Příklad 2:
DECLARE OBJECT ob
SET ob=CREATE('KU_DATA')
ob.set_process('*')
IF ob.found() AND ob.sp07idtypd="PROCE1"
ob.set_process('*',.T.)
IF ob.found() AND ob.sp07idtypd="PROCE2"
.........
.........
ENDIF
ENDIF

Ing. Petr Filip 28.05.04


Nová činnost OBC

Nová činnost OBC
"Vztahy obchodovatelných artiklů k adresátům"
umožňuje zadávat informace každého jednotlivého adresáta k obchodovatelnému artiklu.
Především jak je ve vztahu k danému adresátovi artikl identifikován (identifikace, čárový kód, název)
Další vlastnosti vztahu je možné popsat obecnými parametry.

"Vztah obchodovatelného artiklu k adresátovi" je objektem BM - tzn. je možné k němu připojovat jiné objekty (např. dokumenty, události na vývěsce, ...)

"Vztah obchodovatelného artiklu k adresátovi" má časovou platnost
Ing. Petr Filip 18.05.04


Nulování množství v MJ

Nulování množství v MJ
při vstupu událostí obchodu a skladu není vhodné, protože uživatel vstoupí množství v MJ a potom v RMJ.

Vstup množství v RMJ vynuluje množství v MJ a následně přepočítá množství v MJ podle množství v RMJ podle vztahu měrných jednotek.
V případě, že tento vztah není definován (někdy nemůže být definován - určuje se při prodeji přesným měřením) předplní se do množství v MJ stejné jako v RMJ.

Toto chování na událostech obchodu a skladu bylo změněno:
K nulování množství v MJ při vstupu množství v RMJ dochází pouze v případě, že se jedná o vstup ve stejné měrné jednotce.
Ing. Petr Filip 18.05.04


Obecné výběry

Obecné výběry
Obecné výběry ve verzi BM pod Foxpro 8.0 mohou využívat objekty CursorAdapteru.

Objekt CursorAdapter dovoluje vytvářet kurzory pro formuláře bez nutnosti zakládání vzdálených pohledů (jsou ukládány na lokálním disku počítače v databázi Foxpro se jménem BWSQL.DBC).

S CursorAdapterem je proto možné vytvářet flexibilnější obecné výběry, protože nehrozí drastický nárůst velkosti databáze BWSQL.

Ve výrazu SQL obecného výběru se za oddělovačem ".POST_SCRIPT" uvádí kód v jazyce Foxpro, který sestavuje výsledný SQL dotaz na základě vstoupených proměnných obecného výběru.
Odkazy na proměnné obecného výběru jsou v tomto kódu jsou možné:
- ohraničením v hranatých závorkách - pro náhradu do SQL dotazu
- ohraničením znaky "<" a ">" - pro přístup k hodnotě proměnné v kódu Foxpro
Kód tohoto skriptu sestavuje část SQL dotazu do proměnné _THIS.SQL_PLUS

Např.:
.post_script
local _sql
if <checkbox1>=1
    _this.sql_plus=IIF(EMPTY(_this.sql_plus),'',_this.sql_plus+' AND ')+;
        'exists(select * from bm_servis.tabulka1 where .... atribut=[textbox1])'
endif
if <checkbox2>=1
    text to _sql noshow
exists(select * from bm_servis.tabulka2 where .... atribut=[textbox2]) and
exists(select * from bm_servis.tabulka3 where .... atribut=[textbox3])
    endtext
    _this.sql_plus=IIF(EMPTY(_this.sql_plus),'',_this.sql_plus+' AND ')+_sql
endif
......

Ing. Petr Filip 18.05.04


Optimalizace SQL dotazu při tisku

Optimalizace SQL dotazu při tisku
Při opravě výstupní předlohy typu sestava nad událostmi obchodu s určitým doplněním SQL dotazu hlásí program chybu SQL "Chyba ODBC 18 - Řádek je příliš dlouhý"

To je způsobeno příliš velkou délkou SQL dotazu.

Řešení je v optimalizaci SQL dotazu pro tisk, kterou se délka SQL dotazu zkrátí:
Při vytváření výstupu podle předlohy výstupu BM vytváří SQL dotaz pro datový server.
Tento dotaz koresponduje s výběrem dat formuláře, pro který je tisk prováděn.
Výběr dat formuláře na základě hodnot zadaných na jeho výběrové záložce obsahuje obvykle
větší počet výrazů LIKE s výběrem libovolné hodnoty
(např. ADADSAT.ad01id LIKE '%' ve formuláři Adresáře při neurčeném číslu adresáta ve výběru).
BM nově optimalizuje SQL dotaz pro tisk tak, že z dotazu tyto výrazy z dotazu vyřazuje.

Nastavením Optimalize_Select=0 v sekci Printing v "Nastavení programu BM" může být tato optimalizace potlačena.
Ing. Petr Filip 18.05.04


Počet znaků OS na události obchodu

Počet znaků OS na události obchodu
Atribut ob02hs (obchodní smlouva) tabulky OBUDAL (událost obchodu) byl prodloužen na 20 znaků
Ing. Petr Filip 18.05.04


Různé změny v BM

Různé změny v BM
Klávesa CTRL+SPACE na výběrové záložce formuláře na znakové položce vyvolává okno pro vstup delšího textu, tím je umožněno zadat delší text pro formátovaný pro výběr v SQL dotazu v klauzuli LIKE.

Uložení do balíčku - umožňuje do balíčku opakovaně vložit informace jednoho druhu

Metoda OP_PRINT_META objektu třídu KU_DATA používaná v kódu po ukončení operace může být používána bez parametru určujícího metapředlohu.
Při nastavení SET_PROCESS tiskne metapředlohu uvedenou u druhu procesu aktuálního procesu.
Při nastavení SET_OPERATION tiskne metapředlohu výstupu operace uvedenou v uzlu diagramu fyzického procesu, která odpovídá aktuální operaci.

Externí příkazy -
Externím příkazem může být nově také skript v jazyce Foxpro
Atribut "Skrytý" - Ano/Ne - při nastavení Ano potlačuje zobrazování Externího příkazu v hlavním menu programu
Atribut "Programová identifikace" - umožňuje vyvolávat externí příkazy ze skriptů - voláním programu SPCALEXT - např. _promenna=SPCALEXT('PRGID')
Ing. Petr Filip 05.05.04


Strom hlavního procesu

Strom hlavního procesu
Ve stromu hlavního procesu se nyní pod uzly představující fyzické procesy a operace zobrazují volné
karty definované u odpovídajících druhů procesů a operací.
Na uzlu představujícím volnou kartu je možné po dvojím klikem spustit formulář volné karty.
V takto vyvolané volné kartě není možné měnit hodnoty.
Ing. Petr Filip 20.05.04


Vyvolání vol.karty operace na události

Vyvolání vol.karty operace na události
Zde je příklad doplňujících vlastností formuláře pro vyvolání VK operace:
a/ na klávesu
b/ po založení operace

a/ na klávesu
* s dynamickou podmínkou - !EOF('$$$') AND RECNO('$$$')>0
* vyvolání volné karty operace s identifikací ZPUSOBD
_this.aktivuj_volnstr(PADR([SPPRCOD],8),PADR([ZPUSOBD],8),.T.)

b/ po založení operace
* Doplňující vlastnost nastavte - spouštět automaticky - ne na klávesu
* Nastavuje skript formuláře pro vstup volné karty operace ZPUSOBD
* Pro tuto doplňující vlastnost je vhodné nastavit na záložce Omezení pro operace
* operaci v procesu ve stavu -
* Stav operace připravena - Připravena
* Stav operace zahájena - Nezahájena
* Stav operace ukončena - Neukončena
LOCAL _o,_script
* připojení skriptu k formuláři aktivovaného po zápisu dat (UPDATE_COMPLETED) * SPUST_VK je libovolný identifikátor
_o=_this.makroprikaz("RETURN this.addscript(createobject([bwscript],[SPUST_VK],[UPDATE_COMPLETED]))")
IF VARTYPE(_o)<>'O'
    RETURN
ENDIF
_script=''
TEXT TO _script NOSHOW
* vyvolání volné karty operace s identifikací ZPUSOBD
_this.aktivuj_volnstr(PADR([SPPRCOD],8),PADR([ZPUSOBD],8),.T.)
* deaktivace skriptu tak, aby se aktivoval pouze jednou
_objscript.scriptactive=.F.
ENDTEXT
_o.scriptcode=_script

Ing. Petr Filip 18.05.04


Šablony

Šablony
V definici pravidla transformace šablony je možné u každého jednotlivého pravidla definovat podmínku zařazení řádku do výstupu šablony.
Uvádí se logický výraz v syntaxi Foxpro, ve kterém je možné použít proměnné šablony uvedené v hranatých závorkách.
Ing. Petr Filip 09.04.04


Klasifikace objektu

Klasifikace objektu
Klasifikace objektu je nástroj, kterým je možné sdělovat určitou obecnou vlastnost, která je společná různým objektům BM stejného druhu.

Klasifikaci objektu je v této chvíli možné uvádět v události obchodu.

Pro vstup klasifikace objektu slouží činnost, která je vyvolávána klávesou F2.
V této činnosti se definuje, kromě identifikátoru klasifikace a jejího názvu, sada obecných parametrů.
Na druhé záložce formuláře je pak možné vstupovat hodnoty obecných parametrů definovaných touto sadou.
Tyto hodnoty jsou vztaženy ke klasifikaci a stávají se tímto společné pro všechny objekty, ve kterých je klasifikace uvedena.

Ing. Petr Filip 03.03.04


Obchod - Celní sazebník

Obchod - Celní sazebník
V komponentě obchod přibyly činnosti pro podporu zpracování celního sazebníku - Celní sazebník a Sazby celního sazebníku.
V činnosti Obchodovatelný artikl je možné zadávat do obchodovatelného artiklu položku celního sazebníku a podle této položky na výběrové záložce vybírat.
Ing. Petr Filip 03.03.04


Událost obchodu

Událost obchodu
Ve formuláři obchodu je možné na události obchodu uvádět její klasifikaci.
Podle klasifikace je také možné události vybírat.
Ing. Petr Filip 03.03.04


Diagram procesu

Diagram procesu
je možné měnit velikost okna formuláře pro vstup kódu po ukončení operace a při tom se mění velikost editačního pole.
Ing. Petr Filip 19.02.04


Dokumenty

Dokumenty
nová vlastnost dokumentu "duplikát" slouží k automatickému ukládání kopie dokumentu na disku.
Vytvoření duplikátu se provádí při ukládání změněného dokumentu.
Ing. Petr Filip 21.02.04


Doplnění klíče SPTYP do entit komponent

Doplnění klíče SPTYP do entit komponent
uvedení klíče SPTYP v tabulkách komponent vede v některých případech ke zrychlení odezvy SQL dotazů nad tabulkami komponent

Tyto klíče byly doplněny do:
DPH - DPUDA
Sklad - MTUDA - sp07idtyp zrušen - zaveden SPTYP
Hodnoty předmětu projektu - NKHODNP
Úkol předmětu projektu - NKUKOL
Plnění úkolu předmětu projektu - NKUKOLP
Položka smlouvy - NKSMLOUV
Událost plnění položky smlouvy - NKSMLPLN
Událost obchodního plnění - OBUDAL - sp07idtyp zrušen - zaveden SPTYP
Událost odpisovaného majetku - ODUDAL
Událost obecné komponenty - OKUDALOS - sp07idtyp zrušen - zaveden SPTYP
Událost plateb - PLUDA - sp07idtyp zrušen - zaveden SPTYP
Poštovní zásilka - POPOSTA
Událost o nemovitosti - PYUDAL
Událost skladu zvířat - SZUDAL
Událost spravovaného majetku - SMUDAL
Účetní událost - UCDENIK - sp07idtyp zrušen - zaveden SPTYP - zrušena RI na SPTYP
Událost vymáhání - VMUDA
Výrobní zakázka - VRVYR
Událost úkolu ve výrobě - VRUDOPER
Vstup nebo výstup výrobního úkolu - VRUDOPMA
Událost vývěsky - VYUDALOS
Událost o záloze - ZAUDAL
Událost změny stavu peněz - výpisy a příkazy - ZPUDA
Ing. Petr Filip 04.02.04


Export adresáře do Outlooku

Export adresáře do Outlooku
Nově vytvořená doplňující vlastnost formuláře "Spojení adresátů" (jmenuje se Export do Outlooku) umožňuje exportovat zobrazená spojení adresátů do Outlooku.

Opakovaný export aktualizuje dříve exportovaná spojení.
Ing. Petr Filip 13.02.04


Kód po ukončení operace

Kód po ukončení operace
Objekt KU_DATA používaný v kódu po ukončení operace po ukončení operace, byl rozšířen o metodu:
BM_MSG_SEND, která odešle zprávu BM a spojí ji s určenou operací.

Parametry:
_prikaz,_bw01uziv1,_pz01text,_pz01koment,_pz01datum

1/ _prikaz - text - má význam SHOW - program zastaví a nechá uživatele doeditovat zprávu a určit příjemce zprávy
2/ _bw01uziv1 - text - přijemce zprávy - může být -
a/ prázdný - je-li _prikaz="SHOW"
b/ seznam identifikací uživatelů (podle tabulky BWUZIVAT) oddělených čárkou
c/ * - zpráva má být odeslána všem aktivním uživatelům systému s právem zápis na operaci, které se zpráva týká
d/ @ - zpráva má být všem aktivním uživatelům systému, kteří náleží do dané skupiny
3/ _pz01text - text - popis zprávy - řetězec ### v textu je nahrazován identifikací a názvem operace
4/ _pz01koment - text - komentář ke zprávě - řetězec ### v textu je nahrazován identifikací a názvem operace
5/ _pz01datum - datum - datum signalizace zprávy - nepovinný - není-li uveden, datum signalizace odpovídá systémovému datu počítače

Zpráva je odesílána v rámci transakce ukončení operace, tzn. pokud se uplatní v kódu po ukončení příkaz ERROR nebo CANCEL, zpráva nebude odeslána, stejně jako pokud zápis dat o ukončení datový server z nějakého důvodu odmítne.
Zpráva je odeslána na operaci určenou posledním volání metody SET_OPERATION.
Z přehledu zpráv může potom příjemce zprávy operaci přímo spouštět klávesou F9. Jestliže byla zpráva odeslána na uzel typu proces a pro tento uzel již existují nestornované podřízené procesy, bude spuštěna první operace jednoho z nich s informativním hlášením.

Metoda vrací logickou hodnotu TRUE nebo FALSE podle toho, zda byla nějaká zpráva odeslána lépe řečeno připravena k odeslání.

Příklad:
DECLARE OBJECT ob
SET ob=CREATE('KU_DATA')
ob.set_operation('','ZAUCT')
if !ob.bm_msg_send('SHOW','@UCETNI','Je pro Vás připraveno účtování','Číslo operace : ###')
cancel
endif
Ing. Petr Filip 27.02.04


Obecné stromy

Obecné stromy
nová funkčnost dovoluje vytvářet složitější programové prvky.
Ing. Petr Filip 03.02.04


Odesílání E-mailu v kódu po ukončení

Odesílání E-mailu v kódu po ukončení
operace - chyba BM odhalená v příkladu v dokumentaci - použití proměnné MAIL havarovalo v příkazu MAIL.SEND_MAIL() na syntaktickou chybu.
Tato chyba byla odstraněna.
Ing. Petr Filip 13.02.04


Ovládání formulářů

Ovládání formulářů
Formuláře událostí, aktuálních hodnot a obratových hodnot, které mají hlavní grid roztažený přes šíři formuláře, je nyní možné vertikálně zvětšovat.
Přitom se hlavní grid formuláře roztahuje a položky na stránkách se posunují dolů.

V souvislosti s tím pro připomenutí - maximalizace okna resp. stažení maximalizovaného okna se provádí klávesou CTRL+F10
Ing. Petr Filip 27.02.04


Problém tisku BM ve verzi VFP 8.0

Problém tisku BM ve verzi VFP 8.0
Nové nastavení BM - TTOPTION v sekci PRINTERSETUP řeší problém tisku ve Visual Foxpro 8.0.
Špatné zobrazování proporcionálních znaků tištěného výstupu a prohlížení výstupu tiskových předloh typu sestava, které pod Visual Foxpro 7.0 fungovaly.

Význam mají hodnoty:
1=Print as bitmapped graphics
2=Download as soft fonts
3=Substitute device fonts

Doporučená hodnota při problémech je 1.
Diskuze o tomto problému je na internetové adrese:
http://fox.orgasoft.cz/vysledky.php?subject=Tisk+a+diakritika+pod+VFP7+a+VFP8%3F&spec=&razeni=id&vazba=&pocatek=1&kolik=20

Pokud nastavení TTOPTION nepomůže, mělo by pomoci nastavení ovladače tiskárny v nastavení písma:
"Zavádět truetypová písma jako rastrová" a ještě je nutno zaškrtnout "Vypnout písma zařízení".

Nastavení se neuplatní při tisku na logickou tiskárnu - pro každou odpovídající fyzickou tiskárnu se musí nastavit individuálně (formulář Fyzické tiskárny).
Ing. Petr Filip 29.02.04


Předlohy výstupu

Předlohy výstupu
Metoda LOAD_MY_ADRESS vytváří pro předlohu výstupu objekt ADM1.AD, ze kterého je možné ve výstupu zobrazit vlastní adresu adresáře.

Metodu je možné vyvolávat ve skriptu předlohy výstupu např.:

*
_this.load_my_adress
*

Potom jsou pro výstup dostupné v objektu ADM1.AD atributy odpovídající vlastní adrese nastavené v adresáři:
ADM1.AD.ad01id, ADM1.AD.ad01adsat,
ADM1.AD.ad01unodpo, ADM1.AD.ad01adsat2, ADM1.AD.ad01ico, ADM1.AD.ad01dico,ADM1.AD.ad01koment,ADM1.AD.sp10idzak, ADM1.AD.ad01klic,
ADM1.AD.ad01rc, ADM1.AD.ad01ksymb,
ADM1.AD.ad01pladph, ADM1.AD.ad01zakljm, ADM1.AD.ad01spolec, ADM1.AD.ad01volne1, ADM1.AD.ad01volne2, ADM1.AD.ad01volne3, ADM1.AD.ad02cisads, ADM1.AD.ad58id,
ADM1.AD.ad13nsc, ADM1.AD.ad11jmeno,
ADM1.AD.ad11cislo, ADM1.AD.ad11fax,
ADM1.AD.ad11mobil, ADM1.AD.ad11email, ADM1.AD.ad11cisost, ADM1.AD.ad11pozn,
ADM1.AD.ad02ulice, ADM1.AD.ad13psc,
ADM1.AD.ad02mesto, ADM1.AD.ad05stat,
ADM1.AD.ad05nazeva, ADM1.AD.ad58naztyp, ADM1.AD.bw01jmeno, ADM1.AD.sp10text,
ADM1.AD.ad02ulice3, ADM1.AD.ad13psc3,
ADM1.AD.ad02mesto3, ADM1.AD.ad05id3,
ADM1.AD.ad05stat3

Ing. Petr Filip 24.02.04


Předlohy výstupu

Předlohy výstupu
V předlohách typu EXCEL je možné použít metody:

EX_COLUMN
Metoda vrací znakovou identifikaci sloupce např.:
xlsheet.Columns('A:'+this.ex_column($(se))).autofit

EX_CELL
Metoda vrací znakovou identifikaci buňky např.:
xlsheet.range(this.ex_cell(4,$(r)+1)).SELECT

EX_RANGE
Metoda vrací znakovou identifikaci oblasti např.:
xlsheet.range(this.ex_range(1,$(r),$(se),$(r))).WrapText = .T.
Ing. Petr Filip 24.02.04


Selektory

Selektory
Ve formulářích obchodního, organizačního a technicko-věcného selektoru přibyly datumové atributy "Platnost od" a "Platnost do".
Na výběrové záložce je možné určit výběr:
Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu

Při zadávání událostí komponent není povolen vstup události se selektorem, který jehož platnost neodpovídá datu uvedenému na události.

Ing. Petr Filip 24.02.04


Strom hlavního procesu

Strom hlavního procesu
Ve stromu hlavního procesu se nyní pod uzlem operace zobrazují zprávy, které byly o operaci odeslány.
Zobrazovány jsou zprávy, jejichž je aktuální uživatel autorem nebo příjemcem.

Ze stromu je také možné přímo zprávy o operaci vytvářet výběrem z menu po pravém kliku na operaci volbou "Odeslat zprávu o operaci".

Na uzlu představujícím zprávu o operaci je možné po pravém kliku z menu volbou "Zobrazit zprávu", spustit formulář s danou událostí zprávy.

Menu "Volby" formulářů událostí komponent bylo rozšířeno o možnost "Odeslat zprávu o operaci", která má stejnou funkčnost jako ve stromu.
Tato nová funkce dubluje možnost z menu "Obecné" - "Odeslat zprávu", kterou bylo možné vyvolávat při spuštěné operaci (bude ze systému odstraněna).

Pro připomenutí - operace, ke kterým vznikla zpráva o operaci, je možné vyhledávat ve formuláři operací ve výběru při "Zobrazit"="Spojené se zprávami"
Ing. Petr Filip 27.02.04


Tabulky aktuálních hodnot

Tabulky aktuálních hodnot
Byla odstraněna referenční integrita tabulek artiklů komponent nad tabulkami aktuálních hodnot komponent, která způsobovala nemožnost přečíslování identifikace artiklu v tabulce SPARTIKL (tj.nadtypový artikl - změna jeho identifikace se promítá do všech identifikací artiklů komponent).
Ing. Petr Filip 24.02.04


Kontrola dat před jejich zápisem

Kontrola dat před jejich zápisem
Počínaje verzí BM 19.1.2004 je při zápisu dat prováděna závěrečná kontrola dat v jediném cyklu.
Ve starších verzích byla tato kontrola, na některých formulářích prováděna vícekrát.
Protože se tato funkce vyskytuje na všech formulářích BM, není možné udělat jejich 100%-ní kontrolu.
Přestože je předpoklad, že to nebude nutné, nastavením "Zapis_Dat_Pocet_Cyklu=1" v sekci "Transient" je možné
obnovit původní chování BM při jeho chybách vyplývajících z této programové změny bez nutnosti
instalace opravené verze BM.

Dana - dne 28.1.2004 zapsáno ve slovníku pojmů
Ing. Petr Filip 23.01.04


Mzdy - výpočet

Mzdy - výpočet
položka K výplatě se v kódu zaokrouhlovala podle padesátníku, ale bylo to zřejmě chybně, protože srážka může být na desetinná místa a K výplatě pak musí vycházet také na desetinná místa.

Opraveno - nyní se v kódu již nezaokrouhluje.
Ing. Olga Smitková 13.01.04


Nastavení programu BM

Nastavení programu BM
je nová funkce BM (SYSTÉM -> Nastavení programu BM).

V nových verzích BM je převážná většina nastaveních původně ukládáná v souboru BW.INI zapsaná v datech (nové tabulky BWOPTION a BWOPTIOC).

Činností "Nastavení programu BM" je možné tato nastavení definovat.
Význam jednotlivých nastavení včetně jejich popisu definují programátoři v Galaxii a při instalaci nové verze jsou nová možná nastavení programu BM do dat přidávána.
Při doplňování nového nastavení do dat, které je aktuálně nastaveno také v BW.INI, je toto nastavení přidáno s hodnotou, která je v BW.INI.

V přehledu nastavení jsou v mřížce zobrazována nastavení, která je možné definovat pouze v BW.INI (tj. potřebné informace pro program ještě před jeho připojením k databázovému serveru), v šedivých řádcích.
Těmto nastavením není možné definovat hodnotu.
Některá nastavení je možné definovat také lokálně pro datová úložiště nebo konkrétní počítače.
Přitom v lokální definici datové úložiště "-" znamená libovolné datové úložiště a počítač "-" libovolný počítač.
Nastavení, která je možné definovat v datech, jsou v mřížce v bílých řádcích a případné změny odpovídajích parametrů v BW.INI nemají po instalaci nové verze na chod programu vliv.

Dana - 28.1.2004 zapsáno do slovníku pojmů
Ing. Petr Filip 23.01.04


Operace

Operace
Ve formuláři "Operace" jsou v řádky mřížky operací ze stornovaných nebo stornujících procesů podbarveny šedou barvou stejně jako operace ve stornovaných nebo stornujících procesech na záložce "Operace hlavního procesu"

Na vývěrové záložce je možné vybrat operace procesů Všechny/Stornované/Stornující
Ing. Petr Filip 02.01.04


Procesy

Procesy
Ve formuláři "Procesy" jsou v řádky mřížky stornovaných a stornujících procesů podbarveny šedou barvou stejně jako operace ve stornovaných nebo stornujících procesech na záložkách "Operace procesu" a "Operace hlavního procesu"

Na vývěrové záložce je možné vybrat procesy Všechny/Stornované/Stornující
Ing. Petr Filip 02.01.04


Přístup k souboru BW.INI

Přístup k souboru BW.INI
Při čtení nastavení uloženého v souboru BW.INI, není v nových verzích BM používána funkce WINAPI, ale vlastní kód BM.

Tato změna je reakcí na případy, kdy v některých implementacích u zákazníků docházelo k zablokování přístupu k tomuto souboru některými stanicemi.
Ing. Petr Filip 23.01.04


Rušení události komponenty

Rušení události komponenty
Při rušení události libovolné komponenty, ze které byla transformována data (může nastat po odblokování operace) se systém zachová podle nastavení parametru "Delete_Transformed_Event" v sekci "Preferenced" nastavení BM :
0 - není povoleno
1 - je povoleno
2 - rozhodne uživatel

Dana - do slovníku pojmů zapsáno dne 28.1.2004
Ing. Petr Filip 23.01.04


fonty na WIN NT4.0

fonty na WIN NT4.0
zobrazování ve verzi FP8 na WINNT 4.0
- pomohlo následující
v registrech win /regedit/
HKEY_LOCAL_MACHINE\MICROSOFT\WINDOWS NT\
FONTSUBSTITUES\ přidáno ARIEL,0 ARIEL,238

provedl a vykoumal PF
Ing. Karel Franěk 29.12.03


Úprava mezd pro rok 2004

Úprava mezd pro rok 2004
Změny v nastavení v Galaxii

- v činnosti Nepřítomnost pro nemoc - záložka dávky - atribut mz38davka - CALC nastaven po novele na čtvrtou možnost (původně na třetí možnost)

- v činnosti uzávěrka mezd v kódu po otevření nastaveno nově "do MZ0045U2 with _mmes,_rrok,_zzpusob"

-zbývá nastavení možnosti posílat parametry balíčkem - nastaveno dne 5.1.2004

-nastavit tabulku, která zachycuje složení konkrétní dávky (pouze pro účely tisku)
-nastavit upozornění do strukturovaného protokolu, že pracovník je nepřítomen v měsíci, kdy nastoupil
Ing. Olga Smitková 19.12.03


Informační panel

Informační panel
Pro stránku informačního panelu byla doplněna možnost definovat pro každého jednotlivého uživatele systému uzly stránky, které mají být pro něho zobrazovány:
1/ vždy
2/ nebo skryté
3/ nebo nikdy

Toto nastavení je možné provádět pro aktuálního uživatele volbou menu činnosti "Definice informačních panelů" nebo pravým klikem na novém tlačítku "Skryté" nástrojové lišty informačního panelu.

Při zamačknutém tlačítku "Skryté" nástrojové lišty informačního panelu jsou zobrazovány na jeho aktivní stánce uzly označené uživatelem jako "skryté" nebo "zobrazovat vždy".
Při vymačknutém tlačítku "Skryté" jsou zobrazovány uzly označené uživatelem "zobrazovat vždy" (podobnou funkci obsahuje hlavní menu programu).
Ing. Petr Filip 25.11.03


Oprava zobrazení objektových vazeb

Oprava zobrazení objektových vazeb
a vazeb míry plnění na objekt OK (událost obecné komponety).
Ve stávajících verzích u tlačítka objektu v souvislostech objektů pro objekty událostí obecné komponety vždy zobrazovalo "-" pro předchůdce i následníky.
Ing. Petr Filip 25.11.03


Příkaz k úhradě - velká záloha

Příkaz k úhradě - velká záloha
V případě pohledávky kladné, která má u sebe zálohu, která je větší, než vlastní pohledávka, chci rozdíl - část zálohy vrátit partnerovi pomocí příkazu k úhradě.

V takovémto případě je dosud neuhrazeno záporné.

Do kódu činnosti Příkaz k úhradě jsem tedy přidala podmínku na výběr plateb do příkazu - pohledávka kladná a dosud neuhrazeno v zahraniční měně záporné.
Ing. Olga Smitková 05.11.03


Sklad - dobropis - řešení

Sklad - dobropis - řešení
nový dokument - problém vyřešen
Ing. Olga Smitková 03.11.03


Výkazy

Výkazy
Listy výkazů v nové verzi programu mohou provádět výstup předlohou výstupu pohledu slovníku dat.
Pokud je v definici listu výkazu uveden pohled slovníku dat s předlohou výstupu, bude při zpracování listu výkazu při výpočtu výkazu prováděn výstup podle dané předlohy.
Přitom je možné v "doplnění WHERE SQL dotazu slovníku dat" předávat parametry zadané uživatelem v dotazu výkazu a parametry nastavené v definici listu a v parametrech uvedených v přiřazení listu na výkaz.
V "doplnění WHERE SQL dotazu slovníku dat" se tyto parametry uvádějí v hranatých závorkách.

Např.:
dotazem výkazu je vstupován parametr NAZEV
v "doplnění WHERE SQL dotazu slovníku dat" je uvedeno - ad01adsat LIKE [nazev_s_procentem]
v parametrech listu výkazu je uvedeno - nazev_s_procentem='%'
v parametrech přiřazení listu na výkaz (ne v parametrech INI) je uvedeno - nazev_s_procentem='%'+trim([nazev])+'%'

Při výstupu předlohou typu Excel nebo Ostatní jsou pro jejich kód dostupné v:
THIS.PARAM1 - název listu
THIS.PARAM2 - název výstupního souboru Excelu
THIS.PARAM3 - název souboru šablony Listu

Odlišné chování předlohy výstupu při výstupu ve slovníku dat a při výstupu na list výkazu je potom možné dosáhnout např.:
.EXCEL
.KDYŽ !EMPTY(this.param1) AND !EMPTY(this.param2) AND !EMPTY(this.param3)
.EXCEL_OTEVŘI this.param2, this.param3
.EP xlsheet.UnProtect
.PŘIŘAĎ $(list)=this.param1
.EXCEL_NOVÝ_LIST $(list)
.EP xlsheet.Shapes('nadpis').textframe.Characters.Text=$(list)
.EP xlsheet.Shapes('nadpis').textframe.autosize=.T.
.EP xlsheet.Shapes('autor').textframe.Characters.Text=ALLTRIM(tool.jmenot)+' '+TTOC(DATETIME())
.EP xlsheet.Shapes('autor').textframe.autosize=.T.
.PŘIŘAĎ $(r)=7
.JINAK
.EXCEL_OTEVŘI 'TMP.XLS', 'template\empty.xls'
.EXCEL_NEUKLÁDAT
.EP xlsheet.UnProtect
.PŘIŘAĎ $(list)="test"
.EXCEL_LIST $(list)
.EP xlsheet.range("D2").SELECT
.EP XLapp.ActiveWindow.FreezePanes=.T.
.PŘIŘAĎ $(r)=1
.EXCEL_NEUKLÁDAT
.KONEC_KDYŽ
Ing. Petr Filip 25.11.03


MZDY - úkolové listy

MZDY - úkolové listy
přidán atribut minuty, dle analýzy v souvisejících vývěskách.

Minuty se nepředplňují.
Hodiny se předplňují buď
- podle minuty/60
- podle do-od
- podle dnů

Dnů se předplňují podle hodin.

Příklady zadání :
1. Nevyplním od, do. Vyplním minuty.
Dopočtou se hodiny podle minuty/60 a dny podle hodin.

2. Vyplním od, do. Nevyplním minuty.
Dopočtou se hodiny podle do-od, dopočtou se dny podle hodin.
Následně se dopočtou minuty podle hodiny *60

3. Vyplním pouze dny.
Dopočtou se hodiny podle dnů.
Následně se dopočtou minuty podle hodiny *60
Ing. Olga Smitková 17.10.03


MZDY - výstupy

MZDY - výstupy
úprava v šablonách, které zajišťují převod mezd do plateb.

Problém : položky typu doplatek ( např. doplatek ZP zam., doplatek daně zál., ...) se šablonou "MZDY -souhrn PL" nepřevedou do plateb, ačkoliv by se převést měly.

Upraveno - již se převedou obdobně jako jiné odvody.

Zkontrolováno, že šablona "Mzdy - souhrn UC" tyto položky do účetnictví převede.
Ing. Olga Smitková 14.10.03


MZDY-výplatní lístky

MZDY-výplatní lístky
V činnosti Výplatní lístky dopracováno předplňování adresáta, bankovního účtu, KS a VS u vybraných položek typu odvod a dodatečný odvod.

Údaje se předplňují dle :
- platných zdravotních pojišťoven
- nastavení v parametrech (srážková a zálohová daň, sociální pojištění)

Stejná funkčnost zapracována dne 17.10.2003 do činnosti Výplatní lístky - zadávání.
Ing. Olga Smitková 16.10.03


POS - otevřená období komponent

POS - otevřená období komponent
komponemta Pošta opraveny tak, aby reagovala na omezení v "Otevřená období komponent".
Ing. Olga Smitková 21.10.03


sklad - dobropis

sklad - dobropis
zpátky na stromy

Během dalšího testování se objevily chyby v předplňování cen a výpočtu ceny celkem.

Kód byl vrácen do původního stavu, tj. bez reakce na bw.ini
Ing. Olga Smitková 24.10.03

Viz.také

Sklad - dobropis - řešení


Sklad - dobropis - řešení

Sklad - dobropis - řešení
pomocí BW.INI vyřešena činnost skladu - viz dokument
Ing. Olga Smitková 22.10.03

Viz.také

sklad - dobropis


Výstup z mezd

Výstup z mezd
Výstup mezd do účetnictví a výstup mezd do statistiky se ve stejném měsíci vždy o pár drobných lišil.

Důvod je ten, že do účetnictví se posílají JEDNOTLIVÉ hrubé příjmy (např. přímá mzda, osobní hodnocení, dovolená, ...).

Do statistiky se ale posílá již celkový zaokrouhlený hrubý příjem (H30000).

Náprava : nastaveno, aby se do účetnictví posílalo i zaokrouhlení (H25000).
Statistika beze změny.
Ing. Olga Smitková 06.10.03


MZDY - odvod ZP z neplaceného volna

MZDY - odvod ZP z neplaceného volna
teorie :
1.Část odpracoval a část měl NV ,Např. NV = 3 hodiny, FPD-3 hodiny, NEodvádí se zdravotní pojištění
2. Neodpracoval celou směnu, ale měl celý den NV, NV= celá směna, např. 7.5 hodiny, FPD-7.5 hodiny odvádí se zdravotní pojištění, ze 7.5 hodiny

Info : zdravotni pojisteni za neplacene volno se odvadi pouze v pripade, ze pracovnik neodpracuje celou smenu. V pripade, ze pracovnik ve dni pracoval, tak se ZP z neplaceneho volna neodvadi a typ mzdy pro neplacene volno by mel slouzi v tuto chvili pouze k evidenci neodpracovane doby z FPD. Toto jsem si overoval na VZP, BM ti spocita odvod i za 1 hodinu NV!!

Řešeno úpravou v optimalizovaném výpočtu a testováno dle připojeného dokumentu.
Ing. Olga Smitková 18.09.03


MZDY - Optimalizovaný výpočet

MZDY - Optimalizovaný výpočet
Během výpočtu se do protokolu napíše upozornění, že pro zpracovávané období nemá pracovník zadanou zdravotní pojšťovnu. Na kartě.
Ing. Olga Smitková 25.09.03


Pošta

Pošta
Předplňování pořadového čísla zásilky probíhá podle číselné řady spojené s kategorií zásilky.

Změněný stav:
pořadové číslo zásilky v poště se bylo doplňováno triggerem nad tabulkou POPOSTA vyhledáním nejvyššího pořadového čísla události pošty v rámci týdne a jeho zvětšením o 1.
Tímto byla pořadová čísla zásilek v jediné číselné řadě.

Nový - aktuální stav:
1/ byla pro komponentu POSTA byla založena nová entita POKATCR (číselná řada kategorie zásilky) relačně spojená s POKATZAS (kategorie zásilky)
2/ byla založena nový formulář pro vstup do entity POKATCR - "Číselné řady kategorií zásilek"
3/ ve formuláři "Kategorie zásilky" je vstupován atribut identifikátor číselné řady (po56id) s odpovídající F2 reakcí
4/ trigger tabulky POPOSTA nyní předpňuje pořadí zásilky v intervalu podle POKATZAS->POKATCR

Ing. Petr Filip 29.09.03


Vymáhání - selektory

Vymáhání - selektory
Do událostí vymáhání předplňování organizačního selektoru dle vymáhané platby.

Již dříve bylo naprogramováno :
- obchodní selektor dle adresáta ( ten je shodou okolností stejný jako na platbě)
- technicko-věcný selektor - předplňování podle textu upomínky
Ing. Olga Smitková 16.09.03


MZDY - uzávěrka

MZDY - uzávěrka
Ve Speciálních činnostech dopracovány dvě činnosti :

- Přepočet průměru h., d. a m. (znovu vypočte průměry na dovolenou)

- Přepočet průměru na nemoc (znovu vypočte průměry na nemocenskou)

Tyto dvě činnosti se spouští vyjímečně, jako oprava nepovedené uzávěrky - a jen v měsících 3,6,9,12.
V ostaních měsících neprovedou nic.

Je třeba k nim donastavit práva !
Ing. Olga Smitková 07.08.03


Nepřítomnosti pro nemoc

Nepřítomnosti pro nemoc
též viz dokument - kapitola 4.1.

4.1. Úpravy ve mzdách pro účel teorie závěrečné
- V Kartě pracovníka - Pravidelných příjmech byla doplněna jedna možnost nastavení.

Dopočíst do FPD dle dnů - atribut dny se zjistí s ohledem na FPD, atribut hodiny se doplní dle kalendáře pracovníka

- Položka N10000 (nemoc v pracovních dnech - používá se ke korekci fondu pracovní doby) - 10 dnů a 2 hodiny nemoci se v této položce zaznamená jako 11 pracovních dnů, 15 kalendářních dnů a 77 hodin.
- Položka N11000 (nemoc v kalendářních dnech - používá se k zapsání nemocenské dávky, nesouvisí s fondem pracovní doby) - 14 kalendářních dnů a 2 hodiny proplacené nemoci se zaznamená jako 11 pracovních dnů, 15 kalendářních dnů a 0 hodin.
- Příjmovou položku A1 (měsíční mzda) zadáme do pravidelných příjmů pomocí atributu Dopočíst do FPD dle dnů - pak bude vycházet 12 dnů a 90 hodin.

Tabulka testování
Položka Bez nemocí S nemocí S nemocí S nemocí
Typ Dopočíst do FPD dle hodin Dopočíst do FPD dle hodin Dopočíst odděleně dny a hodiny Dopočíst do FPD dle dnů
Protokol Nic FPD souhlasí FPD souhlasí 167 <> 172.5
N10000 - 11;15 / 77 11;15 / 77 11;15 / 77
N11000 - 11;15 / 0 11;15 / 0 11;15 / 0
A1 23 / 172.5 12.73 / 95.5 12 / 95.5 12 / 90
Ing. Olga Smitková 29.08.03


Opraven výpočet průměru na nemocenskou

Opraven výpočet průměru na nemocenskou
Počítá se při uzávěrce.

Dle připojené vývěsky.
Ing. Olga Smitková 01.08.03


Adresář

Adresář
Do struktury tabulky ADADSAT byl doplněn atribut AD01UNODPO typu NUMERIC(1).
Činnost AD0137 - Adresář - na záložce "Další informace" se tento atribut vstupuje jako překryvný seznam s hodnotami ANO/NE (atribut má návěští "Odpovídá názvu")

Hodnota ANO - změna názvu adresáta na úvodní záložce provádí automaticky změnu úplného názvu adresáta na záložce "Další informace" a přitom uživatel nemůže úplný název adresáta měnit

Hodnota NE - změna názvu adresáta na úvodní záložce provádí automaticky změnu úplného názvu adresáta na záložce "Další informace" pouze v případě, že je úpný název nevyplněn a přitom uživatel může úplný název adresáta měnit
Ing. Petr Filip 15.07.03


Masky operace

Masky operace
Při vstupu událostí komponent byla doplněna možnost dynamicky předplňovat nevyplněný atribut na základě informace uvedené v masce operace.
Pro atribut v masce se zadává:
1/ inicializovat Konstantou nebo výrazem
2/ ve výrazu je uveden text v syntaxi ##V (ve výrazu mohou být uvedeny znaky $$$, které budou nahrazeny odpovídajícím alias komponenty)

Použití dynamické inicializace v masce operace nemusí vždy fungovat, pokud ji přebíjí dynamická inicializace atributu naprogramovaná ve formuláři.
To nastává v případě, že programátorem naprogramovaná dynamická inicializace není umístěna bezprostředně před vstup atributu.
Pro úplné dořešení tohoto problému bude po dalším doplnění funkčnosti masek operací.

pozn. PK - vyraz muze vypadat i takto>

~##V tool.sql_dotaz([select ob03cj02 from %%%.OBCENIK where sp60id=?_p1], $$$.sp60id)
Ing. Petr Filip 15.07.03


Mzdy - strukturovaný protokol

Mzdy - strukturovaný protokol
Nově byla vytvořena činnost Protokol strukturovaný. Je to ekvivalent k činnosti Protokol. Úzce souvisí s činností Optimalizovaný výpočet mezd. Do Protokolu se zapisují nejasnosti a odchylky, které se projevily během výpočtu mezd.

Strukturovaný protokol má v hlavičce své absolutní pořadové číslo (mz03poradi). Přes menu Volby - Položky protokolu ( klávesa F6) se vyvolají jednotlivé položky protokolu, což jsou údaje o konkrétních anomáliích. Strukturovaný protokol se při dalším spuštění Optimalizovaného výpočtu mezd automaticky nemaže, ale vytvoří se další. V činnosti Strukturovaný protokol je možné protokoly mazat. S hlavičkou se smažou i položky.

Činnosti Výpočet výplatního lístku a Výpočet mezd všech pracovníků pracují s Protokolem. Ale tento způsob výpočtu by měl být uživateli postupně opouštěn a nahrazen používáním optimalizovaného výpočtu a Strukturovaného protokolu.
Ing. Olga Smitková 15.07.03


Mzdy - dny a hodiny

Mzdy - dny a hodiny
Požadavek 4) výplatní lístky zadávání - zpřístupnit oboje dny pro opravy -

Zpřístupněny atributy - dny, kal. dny a hodiny v činnostech Výplatní lístky, Výplatní lístky - zadávání.

V Prohlížení výplatních lístků již bylo přístupné.
Ing. Olga Smitková 23.07.03


Mzdy - uzávěrka

Mzdy - uzávěrka
uzávěrka mezd též pracuje se Strukturovaným protokolem a nikoliv s Protokolem (dřívějším).
Ing. Olga Smitková 16.07.03


Obecné výběry

Obecné výběry
pravý klik nad seznamem obecných výběrů na výběrové záložce vyvolá přechod na definování obecných výběrů.

Aktualizace při definování obecných výběrů vyvolává automaticky obnovení seznamu obecných výběrů na výběrové záložce odpovídajích aktivních formulářů.
Ing. Petr Filip 09.07.03


Sestavy pro nové ZP

Sestavy pro nové ZP
v souvislosti se změnami na Kartě - viz vývěska

sestavy uloženy na M:\BMDOK\Návody a balíčky\Předlohy výstupu\Mzdy\ZP hlášení\MZ0072......
Ing. Olga Smitková 10.07.03

Viz.také

MZDY - karta pracovníka


MZDY - karta pracovníka

MZDY - karta pracovníka
na kartě pracovníka je nová záložka - Zdravotní pojišťovny - obsahuje seznam zdravotních pojišťoven pracovníka, u kterých byl postupně pojištěn. Nedovolí překryv záznamů. Je to tabulka MZZDRPOJ.

Zbývá změnu zapracovat :
- do uzávěrky - historie (historii zrušit) - HOTOVO 17.6.03 - historie ponechána
- do výpočtu - zápis adresáta zdravotní pojišťovny - HOTOVO 17.6.03
- do šablon pro tvorbu událostí mezd -MZ0048, MZ0082, MZ0084 (nebylo potřeba upravovat - do ad01id totiž plní pomlčku), MZ0085 (nebylo potřeba upravovat - do ad01id totiž plní pomlčku), MZ0087, MZ0103, MZ0089 (nebylo potřeba upravovat), MZ0090 (nebylo potřeba upravovat), MZ0096 (nebylo potřeba upravovat) - HOTOVO 19.7.03
- do tisku - přístupnost atributů - HOTOVO 19.7.03
- do tiskových sestav pro zdravotní pojišťovny - hotovo - viz napojená vývěska

Doplňující vlastnost formuláře - pro nakopírování MZKARTA.mz70idp do MZZDRPOJ

Kde ještě se projeví ?
Ing. Olga Smitková 16.06.03

Viz.také

Sestavy pro nové ZP


Třídění dle názvu artiklu

Třídění dle názvu artiklu
v událostech obchodu padaly sestavy,které byly hned při jejich prvním nastavování nastaveny na třídění dle Názvu artiklu.

V Galaxii je totiž na OBUDAL.SPARTIKLX výraz
sp60artikl | *OBUDAL_sp60artikl

opravila jsem na
sp60artikl | *OBARTIKL_sp60artikl
Ing. Olga Smitková 16.07.03


Změna identifikátoru umístění

Změna identifikátoru umístění
nebo druhu v odpovídajících tabulkách provádí automaticky (triggery) změny v tabulkách definujících práva přístupu.
Před touto programovou změnou bylo nutné práva po změně identifikátoru druhu nebo umístění znovu nastavovat.
Ing. Petr Filip 09.07.03


Dokumenty

Dokumenty
Dokumenty nově umožňují sledování revizí.

Revizí dokumentu se rozumí kopie obsahu dokumentu zaznamenaná v čase.

Ve formuláři "Dokumenty" přibyla záložka "Revize dokumentu", na které se zobrazuje seznam všech revizí aktuálního dokumentu. Funční klávesa F6 a klávesa "Editovat dokument" otevírá na této záložce revizi dokumentu.
Pro každou revizi se eviduje datum a čas jejího vzniku a uživatel, který ji založil. Kromě toho je možné na záložce "Revize dokumentu" doplnit k revizi poznámku (zde je také možné nepotřebné revize rušit).
Seznam je setříděn podle data sestupně.

Revize dokumentu mohou vznikat automaticky, je-li nastavena nová vlastnost dokumentu "Automatické ukládání revizí dokumentu" (při každé opravě dokumentu vzniká nová revize) nebo manuálně volbou menu "Uložit novou revizi dokumentu".

Ve formuláři "Spojené dokumenty" se ve stromu pod každým dokumentem zobrazují také jeho revize.
Z menu vyvolaného pravým klikem myši je možné prohlížet revizi dokumentu (také dvojitým klikem), manuálně zakládat nové revize a rušit nepotřebné revize.
Kromě toho je v menu vyvolaného pravým klikem nad uzlem zobrazujícím dokument, užit volbu "Obnovit přehled revizí".

Revize je možné sledovat pouze pro dokumenty uložené v databázi.
Ing. Petr Filip 10.06.03


Dokumenty

Dokumenty
Oprava chyby - opravena funkčnost "Prezentace dokumentu" - projevovala se chybou při spuštění prezentace
"Chyba OLE" - "1732 datový typ není pro tuto vlastnost platný"
Ing. Petr Filip 10.06.03


Dokumenty

Dokumenty
Oprava chyby - nyní se správně zapisuje informace v přehledu užití dokumentu, o tom že uživatel provedl změnu dokumentu
Ing. Petr Filip 10.06.03


Moeller - bod 1 část druhá

Moeller - bod 1 část druhá
problém s pracovníky 10356, 10724, 10745 se neprojevil. Nemůžu ho identifikovat. Možná se opravil spolu s úpravou kódu pro bod 1 - první část.
Ing. Olga Smitková 02.06.03


Moeller - bod 10

Moeller - bod 10
denní průměr na dovolenou se může počítat dvěma způsoby:
a) - stávající způsob - podle hodinového průměru, který násobíme počtem hodin úvazku
b) - nově - nezávisle na hodinovém průměru, podle vzorce zahrnované peníze do průměru děleno počet odpracovaných dnů.

Aby toto mohlo fungovat, přidala jsem:
- do Parametrů překryvný seznam na "Způsob výpočtu denního průměru" - "Dle denního úvazku", "Dle odpracovaných dnů". Nastaveno bude na typ "Dle denního úvazku".

- do Doplňujících údajů u příjmů - zaškrtávátko "Dny zahrnout do průměru". Nastaveno tak, jak je nastaveno zaškrtávátko "Hodiny zahrnout do průměru".
Ing. Olga Smitková 02.06.03


Moeller - bod 4

Moeller - bod 4
Z činnosti Výplatní lístky je možné přes Volby spustit činnost Optimalizovaný výpočet.

Činnost Výpočet všech výplatních lístků zatím rušit nebudu - je možné k ní nastavit práva.
Ing. Olga Smitková 03.06.03


Moeller - bod 6

Moeller - bod 6
navržené řešení zamítnuto.

Zablokovat zadávání hrubých mezd v momentě spuštění Optimalizovaného výpočtu mezd je nešikovné, protože je pravděpodobné, že první spuštění výpočtu nepovede ke konečným mzdám - pravděpodobně se objeví drobné chyby a opomenutí při zadávání.

Pokud je nutné nějak zablokovat možnost zadávání mezd a možnost opravy vypočítaných mezd, je třeba to navrhnout jinak.

Nestačí na to práva a zodpovědnost jednotlivých mzdových účetních ?

Ing. Olga Smitková 11.06.03


MZDY - Prohlížení výplatních lístků

MZDY - Prohlížení výplatních lístků
do výběru přidána možnost výběru dle druhu mzdové položky - příjmy,odvody,součty příjmů, ...
Ing. Olga Smitková 10.06.03


MZDY - Protokol

MZDY - Protokol
Protokol hlásí, že pracovníkův pracovní poměr ve zpracovávaném měsíci končí.
Ing. Olga Smitková 10.06.03


MZDY-nové možnosti v pravidel. příjmech

MZDY-nové možnosti v pravidel. příjmech

Dodatek:
Při používání Pravidelných příjmů na Kartě pracovníka nastal problém s nemožností zápisu samostatných hodin a nulových dnů ( resp. samostatných dnů a nulových hodin).

U příjmové položky, která vznikla pomocí pravidelných příjmů je nutná možnost zápisu odlišných hodin a odlišných dnů.

Navrhované řešení :
- v menu Definice - Položky mezd - příjmy a náhrady - nastavit u mzdové položky (např. základní mzda pracovníka) zaškrtávátka (jedno nebo obě) "povoleny nulové dny" a "povoleny nulové hodiny".
- V menu Karta pracovníka - Pravidelné příjmy - nastavit tuto mzdovou položku (základní mzda pracovníka)
- Činnost "Optimalizovaný výpočet mezd" vypočítá položku z pravidelných příjmů tak, aby hodiny a dny spolu souhlasily
- Tento řádek výplatního lístku lze ale nyní přepsat na libovolné hodiny a libovolné dny

Tímto by se vyřešil problém zápisu různých dnů a hodin v rámci jednoho řádku, i když by se to muselo udělat RUČNĚ.
NEBO
V činnosti pravidelné příjmy rozšířit způsob dopočtu hodin "Nevyplňovat,Dopočíst do FPD,Součet odpracovaných" o dvě možnosti "Dopočíst do FPD odděleně ve dnech a v hodinách","Součet odpracovaných odděleně ve dnech a v hodinách"

Možnost :
· Nevyplňovat - atribut hodiny se vůbec nevyplňuje, přenesou se pouze peníze
· Dopočíst do FPD - atribut hodiny se zjistí s ohledem na FPD, atribut dny se doplní dle kalendáře pracovníka
· Součet odpracovaných - atribut hodiny se zjistí s ohledem na příjmy se zaškrtávátkem hodiny započítávat pro pohyblivou složku měsíční, atribut dny se doplní dle kalendáře pracovníka
· Dopočíst do FPD odděleně ve dnech a v hodinách - atribut hodiny se zjistí s ohledem na FPD, atribut dny se zjistí s ohledem na FPD. Dny a hodiny tedy spolu vůbec nemusí korespondovat.
· Součet odpracovaných odděleně ve dnech a v hodinách - atribut hodiny se zjistí s ohledem na příjmy se zaškrtávátkem hodiny započítávat pro pohyblivou složku měsíční, atribut dny se zjistí s ohledem na příjmy se zaškrtávátkem hodiny započítávat pro pohyblivou složku měsíční. Dny a hodiny tedy spolu vůbec nemusí korespondovat.

Příklad : FPD 22 dnů/ 165 hodin, 7.5 hodiny denně
Ve výplatních lístkách zadáno :
- C1 dovolená - 3 dny / 22.5 hodin
- D1 paragraf - 0 dny / 10hodin

V pravidelných příjmech zadáno :
- A1B - základní mzda - dopočíst FPD odděleně ve dnech a hodinách - 19 dnů / 132.5 hodin
- A2 - osobní hodnocení - dopočíst FPD odděleně ve dnech a hodinách - 19 dnů / 132.5 hodin

Příklad druhý : testováno i ve variantě Součet odpracovaných odděleně ve dnech a v hodinách

Ing. Olga Smitková 06.06.03


Nepřítomnosti ve mzdách

Nepřítomnosti ve mzdách
dokument aktualizován
Ing. Olga Smitková 03.06.03

Viz.také

Moeller - dotaz k bodu 5


personalistika - bod 5

personalistika - bod 5
2) bod 5 v současné verzi UMÍME
5. Provázat zadávání údajů Platnost od a do tak aby po zadání datumu od se
automaticky doplnil datum do a to tak že se přidá počet měsíců zadaný v okně
Volné číslo1.Údaj v okně Volné číslo1 bude ale pro vázaný s Volným
textem 3 tak, že pro jednotlivé položky se předplní
zadané číslo. (Např.: Po zadaní slov "Doba trvání " do okna Volný text3
automaticky se v okně Volný text1 objeví číslo 6, nebo po zadaní slov
"Lhůta" do okna Volný text3 automaticky se v okně Volný text1 objeví číslo
12. Číslo se vybere podle toho jak to bude v tabulce z které se předplňuje
okno pro Volný
text3). Přesto ale okna u Volné číslo1, Platnost od a do by měly zůstat
editovatelné.

Umíme pomocí Editovat script.
Ing. Olga Smitková 27.06.03


Přehled o použití dokumentů

Přehled o použití dokumentů
V menu MARKETING -> DOKUMENTY je nová činnost, jejíž formulář zobrazuje přehled o použití dokumentů v čase.

Činnost se dá využít zapomětlivci typu "bože, s kterým dokumentem jsem já to minulý týden pracoval" nebo správci systému pro zjištění, zda některý nevhodný uživatel systému nahlédl do citlivého dokumentu (při chybném nastavení přístupových práv k druhům dokumentů).
Ing. Petr Filip 11.06.03


Výběry s uživatelem

Výběry s uživatelem
Seznamy uživatelů v překryvných seznamech na výběrových záložkách jsou nyní abecedně tříděné tak, že nejdříve jsou v seznamu uvedeni aktuální uživatelé a potom neaktuální.
Pro neaktuální je navíc za jménem v seznamu uvedena hvězdička.
Ing. Petr Filip 11.06.03


Již nepracující pracovníci

Již nepracující pracovníci
Pracovník, jehož pracovní poměr skončil a přesto :

1) má nějaký hrubý příjem - pak má i kompletní výplatní lístek, pouze nepřenesu pravidelné příjmy z karty

2) má nemocenské dávky - jeho výplatní lístek obsahuje nem. dávku, půjčku, srážku, položku k výplatě

3) má vyrovnání přeplatku na dani - jeho výplatní lístek obsahuje čistý příjem, půjčku, srážku, k výplatě

+ připojený dokument
Ing. Olga Smitková 27.05.03


Moeler - řešení bodu 2

Moeler - řešení bodu 2

historie PP - přidány položky mz32cislo1, mz32cislo2, mz32cislo3 a položky mz32dovnov a mz32dovsta.

Do hodnot mz32dovnov a mz32dovsta se zapisuje hodnota nové a staré dovolené z karty pracovníka TĚSNĚ PŘED UZÁVĚRKOU.
Ing. Olga Smitková 14.05.03


Moeller - bod 7

Moeller - bod 7
Dle Michala se ptám stejně.
Ing. Olga Smitková 30.05.03


Moeller - dotaz k bodu 5

Moeller - dotaz k bodu 5
Prosím o rychlé vyjádření a připomínky
viz dokument
Ing. Olga Smitková 29.05.03

Viz.také

Nepřítomnosti ve mzdách


Moeller - řešení bodu 3

Moeller - řešení bodu 3
vychází-li mínusová čistá mzda, srážky se neprovedou
Ing. Olga Smitková 28.05.03


Moeller - řešení bodu 8

Moeller - řešení bodu 8
Pokud v činnosti Optimalizovaný výpočet nevyberete žádného pracovníka, počítají se všichni.
Ing. Olga Smitková 26.05.03


Moeller bod 1 - část první

Moeller bod 1 - část první
problém s pracovníky 30916 a 30802 opraven v kódu.
Ing. Olga Smitková 30.05.03


MZDY - úprava vyplatních lístků

MZDY - úprava vyplatních lístků
U činnosti "Výplatní lístky - zadávání" byla doplněna možnost zadat přímo zde adresáta, bankovní účet, KS a VS. Využije se to zejména u ručně vložených srážek.

Doplněno též u činností "Výplatní lístky" a "Prohlížení výplatních lístků".

Týká se to položek typu odvody, nemoci, srážky a půjčky. Činnost optimalizovaný výpočet je předplňuje podle parametrů, podle zdravotních pojišťoven a podle karty (srážky a půjčky).

Činnosti "Výpočet výplatního lístku" a "Výpočet všech výplatních lístků" tyto nové atributy předplňují pomlčkou a hodnotou 01.

Ing. Olga Smitková 02.05.03

Viz.také

MZDY - opravy | Roční zúčtování | MZDY - výstup mezd do plateb


MZDY - opravy

MZDY - opravy
opravy hlášené z Elmeru - optimalizovaný výpočet mezd:
1) má-li pracovník ručně vloženou srážku, padalo to na MZMZDY3.mz28srazet a MZMZDY3.mz28kc_j - opraveno v kódu
2) u velké organizace se chybně přetahovala položka N11000 do výplatního lístku při výpočtu ( dny pracovní a dny kalendářní tam nezaznamenávaly část dne nemoci - tj. hodiny nemoci) - opraveno
Ing. Olga Smitková 30.04.03

Viz.také

MZDY - úprava vyplatních lístků


MZDY - výstup mezd do plateb

MZDY - výstup mezd do plateb
Souhrnný výstup mezd do plateb je pro srážky a půjčky přepracován v souvislosti se změnami na výplatních lístcích (viz spojená vývěska).

Šablona se zeptá, zda chci použít údaje a adresátovi, účtu, KS a VS z výplatních lístků nebo ne. Pokud ne, berou se údaje z karty.

Dotaz je v šabloně zabudován proto, že v současné situaci část klientů počítá výplatní lístky starým způsobem ( tj. bez zaznamenávání adresátů, ... do výplatní lístek) a část klientů již používá optimalizovaný výpočet výplatních lístků (ten zaznamenává údaje o adresátovi, účtu, KS a VS přímo na výplatní lístek).
Ing. Olga Smitková 07.05.03

Viz.také

MZDY - úprava vyplatních lístků


Roční zúčtování

Roční zúčtování
U činnosti "Roční zúčtování" byla doplněna možnost zadat přímo zde adresáta, bankovní účet, KS a VS.

Výpočet ročního zúčtování u položky L41000 - vyrovnání přeplatku na dani vezme adresáta, účet, KS a VS z parametrů (pro zálohovou daň). Je zde možnost tyto údaje opravit.
Ing. Olga Smitková 26.05.03

Viz.také

MZDY - úprava vyplatních lístků


MZDY - zpětné nepřítomnosti

MZDY - zpětné nepřítomnosti
V činnosti nepřítomnost pro nemoc se uvádí aktuální základ z karty pracovníka. Pokud ale zapisuji nepřítomnost s datumem od PŘED poslední uzávěrkou, pak základ (na první záložce) předplním pomocí historie pracovních poměrů.
Ing. Olga Smitková 07.05.03


Obecné stromy

Obecné stromy
Nový nástroj BM "Obecné stromy" umožňuje uživatelsky definovat vztahy mezi daty a následně tyto vztahy zobrazovat ve formě stromu (podobný formát jako např. strom hlavního procesu).

Ve formuláři "Definice obecných stromů" (menu INFORMAČNÍ CETRUM->TYPY ŘADY->OBECNÉ STROMY) se definují uzly stromů a vztahy mezi nimi.
Na záložce "Uzly obecného stromu" se definují tyto atributy:
1/ identifikace uzlu - jednoznačně identifikuje uzel
2/ název uzlu - pro vrcholový uzel určuje název odpovídající položky hlavního menu a nadpis formuláře stromu
3/ druh uzlu - definuje práva přístupu
4/ ikona uzlu - určuje ikonu, která bude použita pro položky odvozené z definice uzlu
5/ volba vrcholový uzel Ano/Ne - pro vrcholové uzly je možné vyvolávat výsledný strom a objeví se také jako položky hlavního menu programu v menu VYVOLÁNÍ OBECNÉHO STROMU
6/ SQL dotaz - výstupem tohoto dotazu jsou určeny položky stromu vzniklé na základě dané definice
7/ výraz třídění - výraz v jazyce Foxpro - definuje setřídění dat
8/ výraz zobrazení - výraz v jazyce Foxpro - definuje text zobrazený ve stromu
9/ výraz hiearchie - výraz v jazyce Foxpro - určuje, že daná definice uzlu určuje hierarchické zobrazení
10/ maska hierarchie - text - rozpadá hodnotu vyhodnocenou výrazem hierachie do struktury stromu
11/ poznámka

Příklad uzlu definujícího hierarchické zobrazení obchodního selektoru, ve vlastnostech definice uzlu:
6/ SQL dotaz - SELECT sp10idzak,sp10text FROM %%%.SPSEOB WHERE sp10idzak like '____00000'
7/ výraz třídění - sp10text
8/ výraz zobrazení - sp10text
9/ výraz hiearchie - sp10idzak
10/ maska hierarchie - AABC
(tj. záznamy, které mají prvé dva znaky v sp10idzak shodné se vyskytují na stejné úrovni menu)

Na záložce "Připojené uzly" se k odpovídající definici uzlu připojují uzly, jejichž definice jsou zpracovávány dynamicky pro jednotlivé položky výsledného stromu.
Definují se tyto vlastnosti:
1/ identifikace připojeného uzlu
2/ alias - totožný uzel může být při použití aliasu připojen vícekrát
3/ pořadí připojeného uzlu
4/ skutečné parametry - seznam výrazů v jazyce Foxpro oddělených čárkou , ve kterých je možné použít odkazy na objekt _DATA, který obsahuje jako atributy aktuální položky výsledného stromu - maximální počet paramertů je 8
5/ doplnění WHERE - obsahuje fragment příkazu SQL, který bude doplněn k SQL dotazu při zpracování připojeného uzlu, je v něm možné použít odkaz na hodnoty výrazu "skutečných parametrů" uvedením výrazu ?_pX, X je pozice výrazu v seznamu skutečných parametrů
7/ výraz třídění - výraz v jazyce Foxpro - definuje setřídění dat - je-li uveden přebíjí odpovídající atribut v připojeném uzlu

Příklad napojení adresáře na uzel obchodního selektoru z předchozího příkazu:
Předpokládá se, že připojený uzel má ve vlastnosti "SQL dotaz" uvedeno - SELECT ad01id,ad01adsat FROM %%%.ADADSAT
4/ skutečné parametry - LEFT(_data.sp10idzak,4)+'%'
5/ doplnění WHERE - ADADSAT.sp10idzak LIKE ?_p1

Ke každé definici uzlu je možné připojit skript v jazyce Foxpro vyvolávaný při dvojím kliku na odpovídající položce výsledného stromu.
Skript je možné definovat volbou F5 menu formuláře a je v něm možné používat odkazy na knihovny vkládaného kódu (např. výstup do HTML).
V okamžiku vyvolání skriptu je dostupný objekt _DATA, který obsahuje jako atributy aktuální položky výsledného stromu
Např. pro spuštění adresáře se zobrazením odpovídajícího adresáta by bylo možné použít:
tool.makroprikaz([do form AD0137 with '','',.F.,'A',_p1],_data.ad01id)
Ing. Petr Filip 16.05.03


Strom hlavního procesu

Strom hlavního procesu
ze stromu hlavního procesu je možné otevírat dokumenty napojené k procesu nebo operaci
Ing. Petr Filip 15.05.03


Dokumenty

Dokumenty
ve formuláři dokumenty je možné vyvolat z menu klávesou F5 funkci kopírovat odkaz na dokument.
Ing. Petr Filip 04.04.03


MZDY - výpočet

MZDY - výpočet
do výpočtu mezd zapracována reakce na kontrolu minimálního vyměřovacího základu.

Kontrola minimálního vyměřovacího základu
Dok.: Program nekrátí minimální vyměřovací základ podle zákona (např. při nemoci, při vzniku a skončení pracovního poměru, ap.). I v těchto případech nahlásí chybu a je na mzdové účetní, aby situaci posoudila.

Když Minimální základ pro ZP = Sledovat a Základ ZP < Minimální základ ZP, pak do Protokolu: Celkový základ zdravotního pojištění je u pracovníka menší, než stanovený minimální základ.

Mzdová účetní situaci posoudí v PRŮBĚHU výpočtu a rozhodne o ní buď :
- nechá vypočítat odvod ZP přímým odvodem ze mzdy
- nebo z minimálního vyměřovacího základu.

Jestliže se nerozhodne ani na jeden dotaz odpovědět Ano, pak se odvod ZP vypočítá přímým odvodem ze mzdy.
Ing. Olga Smitková 14.04.03


MZDY - zápis 0 dní a např. 10 hodin

MZDY - zápis 0 dní a např. 10 hodin
a naopak

Připomínku k zápisu typu 0 dní a 10 hodin jsem vyřešila pomocí definice - položky mezd, kde u položek typu příjmy a náhrady a neplacené volno jsou dvě nová zaškrtávátka, která povolují nulovou hodnotu u dnů nebo u hodin.

Tento vliv je zabudován do činností "Výplatní lístky", "Výplatní lístky - zadávání" a v "Prohlížení výplatních lístků" bylo již dříve možno zapsat nulu do dnů nebo hodin
Ing. Olga Smitková 18.04.03


Obecné předkontace

Obecné předkontace
primární klíč "položky obecné předkontace" byl rozšířen od atribut "datum platnosti od" (nyní má tvar "význam položky"+"datum platnosti od")

To znamená, že je možné vstoupit k jedné obecné předkontaci více položek se shodným významem.
Tato možnost se využívá při konstruování kalkulačního vzorce v komponentě výroba.
Pro jiná použití obecných předkontací v ISBM není důsledek existence položek se shodným významem v jedné obecné předkontaci v této chvíli definován.

Ing. Petr Filip 18.04.03


Obecné výběry

Obecné výběry
Výraz obecného výběru může obsahovat skript v jazyce Foxpro.

Výraz se skriptem má tvar:
<část SQL dotazu>
.script

Skript je prováděn před odesláním dotazu SQL databázovému serveru a dá se použít při vytváření výstupů, pro které je obtížné sestavit SQL dotaz.
V okamžiku běhu skriptu jsou dostupné v proměnných:
_thisform - objekt formuláře, ze kterého je spuštěn obecný výběr
_this - objekt, který konstruuje obecný výběr

Obvykle skript zapisuje informace do globálních temporary tabulek SQL databáze (tj. pracovních tabulek jejichž obsah je vlastní každému jednotlivému připojení k databázi).
K tomuto účelu je možné využít tabulku BM_SERVIS.BWOZNAC, která je určena pro označování objektů BM nebo potřebnou tabulku vytvořit v SYBASE SQL Centralu.

Např. demonstrační příklad obecného výběru se skriptem, který zobrazuje adresáty se názvem podle obsahu vstupované proměnné výběru [nazev] :

exists(select * from %%%.BWOZNAC where bw51=?thisform.work_select and BWOZNAC.bw51ob=ADADSAT.ad01)

.script
LOCAL _o,_bw51
* vytvoření vlastnosti formuláře "work_select", jejíž obsah bude určovat množinu záznamů použitých tímto obecným výběrem v daném formuláři
IF TYPE('_thisform.work_select')<>'C'
* sys(2015) vrací systémovou jednoznačnou časovou identifikaci
_bw51=sys(2015)
_thisform.addproperty('work_select',_bw51)
ELSE
* při opakovaném spuštění obecného výběru již vlastnost formuláře "work_select" existuje
_bw51=_thisform.work_select
ENDIF
_o=createobject('vyber')
* [nazev] je identifikace proměnné obecného výběru
_o.start([nazev],_bw51)
* vlastnost "print_template_data" formuláře určuje, že pohled pracuje pracovní tabulkou (tj. při tisku se nebude vytvářet nové spojení, pro které by byla pracovní tabulka BM_SERVIS.BWOZNAC prázdná)
_thisform.print_template_data=.T.

* definice třídy objektů "vyber"
define class vyber as session
* pracuje v lokální datové seanci - nemůže dojít ke konfliktu alias otevřených tabulek
datasession=2

procedure init
* inicializace prostředí (SET)
do bw_set

procedure start
* procedura "start" provádí zápis do tabulky BWOZNAC
lparameters _ad01adsat,_bw51
local _loc
select 0
* vzdálený pohled "bwsql!SY0111_bwoznac" vybírá záznamy obsahující v atributu BW51 hodnotu danou proměnnou _BW51 z tabulky "BM_SERVIS.BWOZNAC" do kurzoru s aliasem "bwoznac"
use bwsql!SY0111_bwoznac alias bwoznac
go bott
* program "bw_lock" uvádí a ukončuje transakční zápis dat z kurzoru "bwoznac"
_loc=bw_lock('L','Fbwoznac')
* zruší záznamy v BWOZNAC vytvořené při předchozím spuštění tohoto obecného výběru v daném formuláři
delete all
do bw_lock with 'U',_loc
_loc=bw_lock('L','Fbwoznac')
* dotaz vrátí v kurzoru "_work" jednoznačné časové identifikace adresátů s názvy podle proměnné "_ad01adsat"
do bw_exec with .F.,[select ad01 from %%%.adadsat where ad01adsat like ?_p1],'_work',_ad01adsat
select _work
scan all
* zápis do tabulky BWOZNAC
select bwoznac
append blank
replace bw01uziv with tool.uziv,;
bw51 with _bw51,;
bw51ob with _work.ad01
endscan
do bw_lock with 'U',_loc
use in _work
use in bwoznac
enddefine

Ing. Petr Filip 18.04.03


Události komponent a strom hl.procesu

Události komponent a strom hl.procesu
z událostí komponent a stromu hlavního procesu je možné vyvolat přechod do seznamu procesů s předplněným výběrem s identifikací procesu aktuální události (resp. aktuální operace nebo procesu ve stromu)
Ing. Petr Filip 04.04.03


Unload databáze

Unload databáze
UNLOAD databáze se používá pro její defragmentaci a tím její optimální odezvu.

Přitom se jeví jako výhodné změnit její vnitřní kódování.

V instalacích BM je v této chvíli využívána kolace 852LATIN2 (tj. kódování a třídění LATIN2 pro střední a východní evropu).
SYBASE SQL Anywhere 7.x.x umožňuje použití kolace 1250LATIN2 (tj. kódování a třídění windows pro střední a východní evropu), které je výhodné protože se jedná o ANSI kódování ve stejném kódu jako je kódování znaků na stanici klientu a není nutné při přenosu dat transformovat texty z kódu 852 do 1250.

V helpu SYBASE SQL Anywhere je pod heslem "Changing a database from one collation to another" popsán postup, jak při UNLOAD udělat konverzi vnitřního kódování databáze.

Ověřený postup:
1/ vyvořte adresáře c:\unld a c:\unld\unload

2/ příkazem
dbunload.exe -xx -c "dsn=spojeni;uid=uzivatel;pwd=heslo" -r c:\unld\reload.sql c:\unld\unload
proveďte UNLOAD databáze, přitom ODBC spojení "spojeni" nesmí používat translator
místo parametru -xx použijte -ix pokud engine běží na stejném počítači
v průběhu unloadu nesmí být k databázi připojen jiný uživatel

3/ nastavte systémovou proměnnou SQLLOCALE na hodnotu CHARSET=cp852 (provádí se ve vlastnostech systému, vyvolaných například na ikoně "Tento počítač" po pravém kliku volbou "Vlastnosti", na záložce "Upřesnit" tlačítkem "Proměnné prostředí" ve Windows XP)

4/ spusťte engine s prázdnou databází vytvořenou s kolací 1250LATIN2 s parametry -ct -z např.
dbeng7 -ct -z c:\data\databaze.db

5/ spusťte dbisqlc.exe a přihlašte se k databázi
v message window tohoto programu by se mělo objevit
Database collation is "1250latin2";engine is sending in charset "cp852", display translation is on

6/ zadejte příkaz
read c:\unld\reload.sql

7/ po naplnění databáze ukončete dbisqlc a vypněte engine

8/ zrušte systémovou proměnnou SQLLOCALE

9/ po nainstalování databáze do ostrého provozu je třeba na všech stanicích zrušit v odpovídajících spojeních používání translatoru

10/ pokud překódování neproběhlo správně, potom se do systému nebude moci přihlásit uživatel s diakritickým znakem ve jméně a vyhledání firem v adresáři začínajících písmenem "C" nevrátí adresáty začínající znakem "Č"
Pravděpodně jste nevypnul použití translatoru ve spojení v kroku ad. 2/

Tento postup byl ověřen na SYBASE SQL Anywhere 7.0.4 EBF 3421
Ing. Petr Filip 18.04.03


Specifikace mezd

Specifikace mezd
Ing. Olga Smitková 04.03.03


Import/export/update dat

Import/export/update dat
Shrnutí:

Formulář "Definice importu/exportu" záložka "Definice importu-exportu"
Definuje základní vlastnosti importu

1/ identifikace importu/exportu/updatu dat - jednoznačně identifikuje v rámci činnosti
2/ název importu/exportu/updatu dat
3/ druh - právo zápis - uživatele má povoleno vytvářet
právo čtení - uživatel má právo spouštět
4/ spojení - definuje spojení s externím zdrojem dat
Druh spojení
a/ ODBC
b/ XBASE
c/ Text (nemá význam pro export)
5/ import/export/update dat - určuje charakter definice
6/ atribut nabízet - při nastavení Ne nebude import nabízen při vyvolání pro spuštění po volbě z menu Obecné formuláře (není aktuální nebo je vyvoláván jiným způsobem např. procesním importem)
7/ selekt - obsahuje definici pro zpřístupnění zdrojových dat importu/updatu nebo dat do kterých bude exportováno
pro spojení druhu:
a/ ODBC - příkaz selekt v jazyce SQL
v definici se mohou vyskytovat "proměnné importu" v hranatých závorkách
b/ XBASE - příkazy v jazyce Foxpro - otevírající tabulky
musí otevřít tabulku nebo kurzor s aliasem DATA
v definici se mohou vyskytovat "proměnné importu" v hranatých závorkách
%S% v příkazech je nahrazeno obsahem atributu "Spojení OS" uvedeného ve spojení.
V příkazech se mohou vyskytovat "proměnné importu" v hranatých závorkách.
Je možné v atributu "Selekt" použít přímý kód Foxpro, ve kterém je možné použít všechny
možnosti jazyka např. vytváření podprogramů, tříd objektů atd.
Takto definovaný kód musí být uveden příkazem "SCRIPT"
a může být ukončen příkazem "ENDSCRIPT".
Po vyvolání je mu dostupný objekt importu v proměnné _THIS.
V kódu je možné uvádět odkazy na knihovny vkládaného kódu (klauzule #INCLUDE).

c/ Text - definice importu z textového souboru
1. řádek název vstupního souboru včetně adresářové cesty (adresář může být definovám %S%)
2. řádek definuje typ textového souboru
a/ TXT [] []
import z textového souboru s pevnou délkou věty
- znak tečka nebo čárka určuje znak desetinné tečky v numerických hodnotách
- logický výraz pro výběr dat
b/ část příkazu APPEND FROM jazyka Foxpro
[[TYPE] [DELIMITED [WITH Delimiter | WITH BLANK | WITH TAB | WITH
CHARACTER Delimiter] | DIF | FW2 | MOD | PDOX | RPD |
SDF | SYLK | WK1 | WK3 | WKS | WR1 | WRK | CSV | XLS | XL5
[SHEET cSheetName] | XL8 [SHEET cSheetName]]] [AS nCodePage]
[FOR lExpression]
3. řádky definující strukturu souboru, který bude použit pro import dat
řádky uvedené znakem * jsou chápány jako komentáře
pro typ textového souboru ad.a/
[] =
pro typ textového souboru ad.b/
[]
- identifikátor atributu v konvencích Foxpro max.délka 10
- typ atributu
C - znakový atribut
D - datumový atribut
T - datum-časový atribut
N - numerický atribut
M - memo atribut (text)
- musí být uveden pro atributy typu C a N
uvádí se v kulatých závorkách např. C(16) nebo N(10) nebo N(20,4)
- výraz v jazyce Foxpro, který je vyhodnocován pro řádek textového souboru
řádek textového souboru je ve výrazu reprezentován textem ###
např. SUBSTR(###,10,5) nebo VAL(SUBSTR(###,14,4))

Příklady:
%s%\vstup.txt
TXT . TRIM(firma)<>'-'
firma C(40) = SUBSTR(###,15,40)
ico C(10) = SUBSTR(###,12,10)
obrat N(12,2) = VAL(SUBSTR(###,58,12))

nebo

%s%\vstup.xls
XL8 SHEET 'Seznam firem' FOR TRIM(firma)<>'-'
firma C(40)
ico C(10)
obrat N(12,2)

8/ příkazy - příkazy v jazyce Foxpro provedené po exportu dat (nevyužívá se pro import a update)
9/ init - určuje příkaz vyvolaný ještě před zahájením importu.
Předpokládá se použití některých činností, které vracejí v pracovním souboru
seznam označených záznamů jako třeba adresář.
V okamžiku vyvolání příkazu, je v proměnné "_o.wrk2" uloženo jméno dosud neexistujícího
souboru, který bude vytvořen příkazem.
V okamžiku vyvolání kódu popsaného v atributu "Selekt" importu je toto jméno dostupné "this.wrk2".
Takto definovaný import byl použit v aplikaci "Fragment" a zde je vysvětlení jeho definice:
a/ Init obsahuje
DO FORM ad0137 WITH this.identif,'!',_o.wrk2,'',''
- znamená vyvolání formuláře "Adresář" před zahájením importu, tak aby zablokoval
aktivaci formuláře, ze kterého je import vyvolán a vrátil v souboru
definovaného obsahem proměnné "_o.wrk2" označené adresáty
b/ obsah Selekt
*
select 0
create cursor data (ad01id c(6),sp61id c(3),sp60id c(13))
if !empty(this.wrk2);append from (this.wrk2)
do nkprcpre with this._thisform
*
- vytvoření kurzoru (kurzor=pracovní soubor, který je automaticky smazán po jeho
uzavření) se strukturou identifikace adresáta a identifikace artiklu
- v případě, že údaj o názvu pracovního souboru není prázný doplní se do kurzoru
seznam označených adresátů
(název může být prázdný, je-li kód vyvolán v okamžiku
přípravy importu např. "Prohlížení importovaných dat" nebo "Předplnění hodnot")
- vyvolání programu "nkprcpre", který doplní do záznamů
identifikaci artiklu a k tomu využije informace formuláře,
do kterého je prováděn import (parametr this._thisform)

10/ Čas.id. - definuje výraz jehož hodnota bude vložena do
jednoznačné časové identifikace objektu (má význam pouze při importu objektů).
Jestliže při importu již existuje v tabulce záznam se stejnou časovou identifikací,
potom není importován.
Při update slouží tato definice jako výraz pro určení záznamu, který má být aktualizován.

Pro charakter definice typu Export je dostupná z menu Volby funkce "SELECT pro export".
Po jejím vyvolání se zobrazí okno pro vstup dotazu SQL, který bude použit pro získání exportovaných
dat (není-li dosud definován, předplní se dotaz odpovídající dotazu formuláře, ze kterého byla definice Importu/exportu vyvolána).
V definice konverze bude výstup tohoto dotazu vystupovat jako tabulka s aliasem _EXP_.

Formulář "Definice importu/exportu" záložka "Proměnné importu-exportu"
Definuje proměnné , které může uživatel vstupovat před zahájením importu, exportu nebo update dat a proměnné, které jsou odvozené ze vstupovaných hodnot.
Atrinut "Naplnění" -
a/ hodnota Vstup - hodnota proměnné je vstupována uživatelem
b/ hodnota Výpočet - hodnota proměnné je odvozena podle hodnot proměnných
definovaných s nižším pořadím
Hodnota proměnné je vyhodnocena na základě "Výrazu proměnné", který v sobě obsahuje
odkazy na proměnné uvedené v hranatých závorkách.
Používá se např. pro sestavení SQL dotazu s operátorem LIKE
Např.:
- proměnná v pořadí 10 je vstupována uživatelem je znaková má identifikátor FIRMA
- proměnná v pořadí 20 s deintifikátorem FIRMA0 je vypočítavaná
s hodnotou určenou výrazem
TRIM([FIRMA])+'%'
Potom je možné v SQL dotazu zadat ..... ADADSAT.ad01adsat LIKE [FIRMA0] ...

Formulář "Konverze atributů" záložka "Konverze řádků"
Z jednoho vstupního řádku může být transformováno žádný, jeden nebo více řádků.
Atribut "Podmínka" rozhoduje o tom zda bude řádek použit.
Přitom má pro Import nebo Update význam používat odkazy na atributy otevřených
tabulek s aliasem DATA nebo případně další relačně propojené tabulky
otevřené podle příkazů "Selekt" definice s druhem spojení XBASE.
Pro Export má význam použití atributů s aliasem _EXP_.
Ve podmínce se mohou vyskytovat "proměnné importu" v hranatých závorkách.
Atribut "Primární klíč pro export" určuje výraz vyhodnocený při exportu nad cílovými daty.
Pokud se v cílových datech vyskytuje záznam se stejnou hodnotou výrazu, potom není
exportovaný řádek zapsán.
Atribut "Klíč pro update" se používá při update dat když není nastavena vlastnost "Čas.id.".
Obsahuje seznam výstupních atributů oddělených čárkou.
Určují záznam, který má být aktualizován.

Formulář "Konverze atributů" záložka "Konverze atributů"
Definuje transformaci dat jednotlivých atributů.
Atribut "Atribut"
Určuje výstupní atribut, jehož hodnota bude při importu/exportu/update naplněna vyhodnocením výrazu
Atribut "Výraz" obsahuje výraz v jazyce Foxpro
Ve výrazu se mohou vyskytovat "proměnné importu" v hranatých závorkách.
Hodnota získaná vyhodnocením výrazu musí být stejného typu jako "atribut", do kterého bude
vložena.
Atribut "Obecná platnost" definuje prvém řádku konverze,
že daný výraz je platný pro všechny následující řádky, na kterých se potom nemusí uvádět.

Importy a exporty dat vytvořené nad formuláři událostí komponent je možné automatizovaně vyvolávat
při běhu procesu:
1/ uvedením šablony používající import v diagramu procesu ve
vlastnosti uzlu procesu "Šablona prvého vstupu"
Spustí import při spuštění operace, pokud operace neobsahuje události
2/ uvedením exportu v seznamu exportů na záložce "Exporty" u popisu druhu operace
Spustí export po ukončení operace

Importy událostí komponent je možné používat v "Procesních importech".

PROCESNÍ IMPORT - je nástroj pro spouštění importů událostí komponent s automatizovaným založením procesu resp. založení událostí v operacích existujících procesů na základě importovaných dat.
Přitom se mohou importovaná data automaticky rozpadat do událostí většího počtu operací.

Definice procesního importu obsahuje atributy:
1/ název
2/ druh - právo zápis - uživatele má povoleno vytvářet
právo čtení - uživatel má právo spouštět
3/ druh procesu - bude založen nebo použit pro vyhledání operace, do které mají být importována data
4/ druh operace v druhu procesu - určuje operaci a tím i výstupní komponetu
5/ identifikace importu - určuje použitou definici importu
6/ založení - definuje způsob založení operace při spuštění procesního importu
a/ nový proces - založí nový proces s identifikací podle číselné řady druhu procesu
b/ nový proces podle záložky - založí nový proces v procesu, jehož některý uzel typu proces má
uvedenu identifikaci adresáta shodnou s identifikací adresáta získanou z importovaných
dat. Tento uzel se může vyskytovat právě jednou ve stavu "aktuální" v nestonovaném procesu.
Adresát se pro tento způsob založení automaticky stává součástí klíče rozpadu událostí do
operací.
c/ nový proces - napojení - založí nový proces v procesu definovaného druhu
na základě identifikací procesu získaných z importovavých dat
(vyhodnocením výrazů na záložce výrazy).
Mezi všemi procesy odpovídajícího hlavního procesu je vyhledán ten, který ve svém diagramu
obsahuje uzel typu proces s druhem procesu procesního importu a v něm založí nový proces.
Identifikátory procesu se pro tento způsob založení automaticky stávávají součástí klíče rozpadu
událostí do operací.
Tento způsob založení se podobá "napojení do procesu", při kterém pokračuje uživatel v procesu
zadáním identifikátoru procesu uvedeného na dokladu externího partnera. Při importu v tomto
případě přicházejí v elektronické podobě.
d/ nový proces s EI (externí identifikací) - založí nový proces s identifikátory získanými
podle importovavých dat (vyhodnocením výrazů na záložce výrazy)
Identifikátory procesu se pro tento způsob založení automaticky stávávají součástí klíče rozpadu
událostí do operací.
e/ existující proces s EI (externí identifikací) - vyhledá proces s identifikátory podle importovaných
dat (vyhodnocením výrazů na záložce výrazy) a v něm neukončenou operaci (ne typu uzel)
druhu uvedeného v definici procesního importu a do této operace importu události.
Identifikátory procesu se pro tento způsob založení automaticky stávávají součástí klíče rozpadu
událostí do operací.
f/ nový proces - možné napojení - kombinuje způsoby založení ad.a/ a ad.c/
V přídadě, že proces nebyl způsobem založení stejně jako ad.c/ nalezen je založen nový
proces stejným způsobem jako ad.c/
7/ spustit operaci na pozadí - úvodní operace importu bude spuštěna na pozadí
8/ zobrazit v menu - ovlivňuje zobrazení volby spuštění procesního importu z hlavního menu programu
9/ CID - jednoznačná idenfikace pro volání procesního importu programovýmí prostředky

Na záložce Výrazy se uvádí výrazy vyhodnocované v průběhu importu na základě importovaných dat
10/ rozpad - ovlivňuje rozpad importovaných dat do událostí různých operací (a tím procesů)
11/ jedn.id. - jednoznačná identifikace - jednoznačně identifikuje skupinu záznamů importovaných
dat odpovídajících jediné fyzické operaci v BM.
V přehledu fyzických operací se zobrazuje na úvodní záložce s návěštím "Externí ID".
Užití výrazu jednoznačné identifikace zabraňuje opakovanému importu stejných dat.
Výraz se automaticky stávává součástí klíče rozpadu událostí do operací.
Největší možná délka externí identifikace je 20 znaků.
12/ Rok - výraz pro určení roku identifikace procesu
povinný pro založení ad.c/ , ad.d/, ad.e/, ad.f/
13/ IDÚ - výraz pro určení identifikace datového úložiště identifikace procesu
povinný pro založení ad.c/ , ad.d/, ad.e/, ad.f/
14/ Číslo - výraz pro určení čísla procesu identifikace procesu
povinný pro založení ad.c/ , ad.d/, ad.e/, ad.f/
15/ Pořadí - výraz pro určení pořadí operace identifikace procesu
jediný numerický - obvykle 1
povinný pro založení ad.c/ , ad.d/, ad.e/, ad.f/

Ing. Petr Filip 14.02.03


MZDY - roční uzávěrka

MZDY - roční uzávěrka
opraven způsob výpočtu základu ročního zúčtování
Ing. Olga Smitková 26.02.03


MZDY - úpravy

MZDY - úpravy
Úpravy :

1. atributy platnost od-do na kartě pracovníka - záložky nezdanitelné položky měsíční, nezdanitelné položky roční, srážky, půjčky + zapracování do výpočtu výplatních lístků jednoho i všech

2. srážky typu procento z čistého příjmu - počítá nyní z čistý příjem + nemocenská dávka

3. nová činnost podobná kartě pracovníka - první čtyři záložky a vybrané informace z dalších informací ( z důvodu nemožnosti zadat práva k jednotlivým záložkám)

4. poznámka : datum signalizace píše upozornění do protokolu měsíc předem, než by se položka uplatnila chybně
Ing. Olga Smitková 07.02.03

Viz.také

Mzdy - úpravy 2. díl


Mzdy - úpravy 2. díl

Mzdy - úpravy 2. díl
Úpravy :

5. Pravidelné příjmy - možnost zadání platnosti od-do
- funguje v činnosti výpočet jednoho výplatního lístku i v činnosti výpočet všech výplatních lístků

6. oprava výpočtu datumu narození podle zadaného rodného čísla - hotovo

7. úprava funkčnosti obchodního selektoru ve mzdách - selektor je vázán přes kartu pracovníka a atribut adresát ( je tedy na adresátovi) - přetahuje se buď ručním vložením nebo výpočtem do činností úkolové listy, výplatní lístky, výplaní lístky - zadávání, prohlížení výplatních lístků.

8. do umístění mezd byl přidán organizační selektor, v činnostech úkolové lístky a událoati mezd se zatím organizační selektor předplňuje dle pracovního poměru (pokud není plněn například šablonou) - KE ZVÁŽENÍ - dvě možnosti:
- podle údaje v parametrech bude možno rozhodnout, zda chci organizační selektor předplňovat podle pracovního poměru nebo podle umístění
- má význam umístění jako atribut přenést i do výplatních lístků (MZMZDY) a následně i do mzdových událostí ?

9. do výplatních lístků dopracováno počítadlo, které informuje o běhu výpočtu
Ing. Olga Smitková 11.02.03

Viz.také

MZDY - úpravy


Empty verze - dokumenty

Empty verze - dokumenty
Mgr. Petr Kukla 20.01.03


Kód po ukončení operace

Kód po ukončení operace
v kódu po ukončení operace je možné přidat skript v jazyce FOXPRO.
Skript musí být uveden příkazem "SCRIPT" a ukončen příkazem "ENDSCRIPT".
V okamžiku běhu skriptu je v proměnné _THIS odkaz na objekt řídící zpracování kódu po ukončení operace a v proměnné _THIS_SPRAVCE odkaz na objekt řídící transformace.

V kódu skriptu je možné použít metodu ADDACTION pro modifikaci diagramu ve tvaru:
_THIS.addaction(<>,<>[,<>]).
Např.:
_this.addaction('ACTIVATE','operace','OBC')
_this.addaction('DELETE','proces')

Kód skriptu musí vracet logickou hodnotu.
V případě, že vrátí logickou hodnotu FALSE, zpracování kódu po ukončení bude přerušeno a operace nebude ukončena.

Ing. Petr Filip 17.01.03


MZDY - nepřítomnosti

MZDY - nepřítomnosti
k dávce nemocenské byly nově přidány dva atributy:
- nepřepočítávat kalendářní dny
- nepřepočítávat pracovní dny

aby šlo zadávat i dávky typu:
od 3.10. do 3.10.
dnů kalend.: 0+2 hod.
dnů prac. : 1+0 hod.

na upozornění Elmeru
testováno na demoverzi
Ing. Olga Smitková 16.01.03


Penalizace v ZM

Penalizace v ZM
opravena funkčnost penalizací v ZM, testováno též na demo verzi na souboru šesti faktur (zp03czmpl)
Ing. Olga Smitková 14.01.03


Podněty z porady a navržená řešení k EV

Podněty z porady a navržená řešení k EV
viz. dokument
Mgr. Petr Kukla 30.01.03


Prijeti noveho pracovnika ve WIP

Prijeti noveho pracovnika ve WIP
Postup pri prijeti noveho pracovnika :
1. v SYSTEM - Uzivatele programu zadat noveho pracovnika a zapamatovat si uvodni heslo
2. v SYSTEM - Skupiny uzivatelu pracovnika zaradit do nekterych skupin z hlediska pristupovych prav
3. v INFORMACNI CENTRUM - Organizacni selektor - pridelit pracovnikovi novy selektor
4. POUZE PRO STRED. REALIZACE - v SPRAVOVANY MAJETEK - Spravovany majetek aktualizovat artikl s druhem PLA, vcetne volne karty Umisteni obchodu
5. v OBCHOD - Umisteni obchodu pridelit nove umisteni, nebo udaje aktualizovat
6. po prihlaseni pracovnika do BM mu pridelit nektere uzivatelske menu, nebo mu vytvorit menu nove

Ing. Olga Smitková 07.01.03


Předlohy výstupy

Předlohy výstupy
v předloze výstupu typu Excel a HTML je možné definovat skript v jazyce FOXPRO.
Skript musí být uveden příkazem ".SCRIPT" a ukončen příkazem ".ENDSCRIPT".
V okamžiku běhu skriptu je v proměnné _THIS odkaz na objekt řídící výstup předlohou.
Kód skriptu musí vracet logickou hodnotu.
V případě, že vrátí logickou hodnotu FALSE, zpracování výstupu ukončeno bude přerušeno.

Ing. Petr Filip 17.01.03


Předlohy výstupy

Předlohy výstupy
byla zavedena nová vlastnost předlohy výstupu SKRIPT.
Definuje se na záložce "Deklarace" a je v ní možné definovat kód v jazyce Foxpro, který má bude prováděn před provedením dotazu SQL.
V okamžiku běhu skriptu je v proměnné _THIS odkaz na objekt řídící výstup předlohou výstupu.

Např.:
LOCAL _o
* přidání vlastnosti TEMP_DATUM1 do objektu _THIS inicializovanou aktuálním datem
_this.addproperty('temp_datum1',date())
* třída BM_CODE_SYSDIA definuje objekt pro dialog
_o=CREATEOBJECT('bm_code_sysdia')
* inicializace objektu třídy BM_CODE_SYSDIA
_o.start(_this,'Datum')
* bude vstup do vlastnosti TEMP_DATUM1 objektu _THIS
_o.addtextbox('temp_datum1')
* metoda READ zahajuje vstup formuláře a vrací FALSE při uživatelově stisku ESC
RETURN _o.read()

#INCLUDE sysdia

V předloze výstupu je potom možné odkazovat na vstoupenou proměnnou jako THIS.TEMP_DATUM1.
Odkaz v doplnění SQL dotazu ve vlastnostech předlohy však není tímto způsobem možný.

Proto jinak např.:
LOCAL _o
* vstupní informace bude uložena v objektu TOOL, ale mohla již být definována předchozím spuštěním předlohy
DO CASE
CASE TYPE('tool.temp_datum1')='U'
    * dosud není vlastnost TEMP_DATUM1 objektu TOOL definována
     * přidání vlastnosti TEMP_DATUM1 do objektu TOOL inicializovanou aktuálním datem
     tool.addproperty('temp_datum1',date())
CASE TYPE('tool.temp_datum1')<>'D'
    * vlastnost TEMP_DATUM1 je definována, ale není typu datum
    tool.temp_datum1=DATE()
ENDCASE
_o=CREATEOBJECT('bm_code_sysdia')
_o.start(tool,'Datum')
* bude vstup do vlastnosti TEMP_DATUM1 objektu TOOL
_o.addtextbox('temp_datum1')
RETURN _o.read()

#INCLUDE sysdia

V předloze výstupu je potom možné odkazovat na vstoupenou proměnnou jako TOOL.TEMP_DATUM1.
V doplnění SQL dotazu ve vlastnostech předlohy bude možné odkazovat v otazníkové konvenci např.:
tabulka.datum>=?tool.temp_datum1

Ing. Petr Filip 17.01.03


Sloučení adresátů

Sloučení adresátů
viz. dokument
Mgr. Petr Kukla 30.01.03


Transformace

Transformace
v doplnění pohledu transformace je možné uvádět skript v jazyce Foxpro.
Tento skript je prováděn před transformací dat.
V okamžiku běhu skriptu je v proměnné _THIS odkaz na objekt řídící transformaci a v proměnné _ALIAS alias pracovní oblasti, ve které je otevřen kurzor, ze kterého budou transformována data (skript může obsah tohoto kurzoru měnit).
Ing. Petr Filip 17.01.03


Zálohy ve mzdách

Zálohy ve mzdách
Rozhodla jsem o ukončení používání části menu
MZDY - ZÁLOHY - Výplata zálohy
- Prohlížení vypočtených záloh

Tyto činnosti dnes lépe a plně nahradí výdajový pokladní doklad v kombinaci s pozdějším importem do zpracování mezd formou srážky ze mzdy.
Ing. Olga Smitková 29.01.03


Duplicita adresátů

Duplicita adresátů
Pro údržbu adresáře byla doplněna činnost, která umožňuje sloučení adresátů.

Činnost se spouští z menu programu "MARKETING" -> "ADRESÁŘ" -> "ČÍSELNÍKY A PARAMETRY" -> "Duplicita adresátů".
Činnost je přístupná pouze správci systému nebo uživatelům s právy správce nebo uživatelům ze skupin uživatelů, kterým byla tato činnost povolena v "Oprávnění k činnostem" (tj. není implicitně povolena všem uživatelům).

Na záložce "Adresát" formuláře "Duplicita adresátů" se uvádí:
1/ původní adresát
2/ aktuální adresát

Záložka "Spojení" definuje, která spojení původního adresáta odpovídají spojením aktuálního adresáta.

Záložka "Bankovní spojení" definuje, která bankovní spojení původního adresáta odpovídají bankovním spojením aktuálního adresáta.

Po nastavení dat popisující duplicitu adresátů je možné z menu "Volby" vyvolat funkci "Zaměnit vazby na původního".
Tato funkce převede datové vazby směrované na původního adresáta aktuálnímu adresátovi, tak aby bylo možné následně původního adresáta běžným způsobem zrušit.
Je měněn odkaz na původního adresáta podle záložky "Adresát", na jeho spojení podle záložky "Spojení", na jeho bankovní spojení podle záložky "Bankovní spojení" všude tam, kde se tyto vyskytují jako cizí klíče (např. v událostech komponent).
Navíc jsou kopírovány objektové vazby původního adresáta k aktuálnímu adresátovi.

Záměna adresátů v událostech komponenty zálohy není provedena, pokud pro původního adresáta existuje událost typu "vyúčtování" zálohy. V tomto případě je třeba odpovídající operace odblokovat a události vyúčtování smazat a po provedení funkce "Zaměnit vazby na původního" opakovaně tyto události vytvořit pro aktuálního adresáta.

Nedefinovaná spojení původního adresáta na záložce "Spojení" způsobí, že tato spojení budou zkopírována ke spojením aktuálního adresáta (včetně adres). Přitom se infomace o tom, že tato nově založená spojení aktuálního adresáta jsou totožná s odpovídajícími spojeními původního adresáta zapíše dat tak, že se po provedení funkce začnou objevovat na záložce "Spojení", jako kdyby je uživatel zadal ručně.
To umožňuje tuto funkci spouštět opakovaně.

Nedefinovaná bankovní spojení původního adresáta na záložce "Bankovní spojení" fungují obdobně jako nedefinovaná spojení původního adresáta na záložce "Spojení" s tím rozdílem, že bankovní spojení původního adresáta není k aktuálnímu adresátovi přidáváno v případě, že u něho již existuje bankovní spojení se stejným kódem banky, prefixem účtu, číslem bankovního účtu a specifickým symbolem.
Ing. Petr Filip 20.12.02


Script formuláře činnosti

Script formuláře činnosti
Formuláře činností BM nově umožňují zpracování skriptů.

Skript je programový kód vyvolaný na základě programové události.
V této verzi jsou definovány tyto události:
1/ zahájení editace - EDIT_START
2/ ukončení editace - EDIT_END
3/ úspěšný zápis dat - UPDATE_COMPLETED
4/ aktivace formuláře (přepnutí z jiného formuláře) - FORM_ACTIVATE
5/ deaktivace formuláře (přepnutí na jiný formulář) - FORM_DEACTIVATE
6/ ukončení formuláře - FORM_DESTROY

Skripty jsou připojovány k danému formuláři jeho metodou ADDSCRIPT.
Syntaxe:
objekt_formulare.addscript(objekt_skriptu)

objekt_formulare - je objekt formuláře, ke kterému má být skript připojen
objekt_skriptu - je objekt, který bude spouštět daný skript
Metoda vrací odkaz na objekt skriptu (objekt_skriptu)

K formuláři může být pro stejnou událost připojeno několik různých skriptů, jejichž
objekty musí splňovat tyto podmínky pro rozhraní jejich komunikace s formulářem:
1/ vlastnost SCRIPTID - jednoznačná identifikace skriptu - pokud je v okamžiku připojování skriptu
metodou ADDSCRIPT již k formuláři připojen skript se stejnou identintifikací, potom je tento
dříve připojený skript od formuláře odpojen

2/ metoda SCRIPTENABLED
Rozhoduje o tom, že skript bude proveden
Parametry:
_this - objekt formuláře, ze kterého je metoda vyvolána
_typ - identifikace události formuláře (EDIT_START nebo EDIT_END ....)
Návratová hodnota:
logická hodnota - udává, zda je možné skript vyvolat

3/ metoda SCRIPTEVENT
Spouští skript
Parametry:
_this - objekt formuláře, ze kterého je metoda vyvolána
_typ - identifikace události formuláře (EDIT_START nebo EDIT_END ....)

V BM je předdefinována třída objektů BWSCRIPT, která splňuje podmínky rozhraní pro komunikaci objektu
skriptu s formulářem.
Třída objektů BWSCRIPT definuje tyto vlastnosti a metody:
1/ vlastnost SCRIPTID - viz. rozhraní

2/ vlastnost SCRIPTTYPE - obsahuje seznam identifikací událostí formuláře oddělených čárkou, pro které
se má skript uplatnit (např. EDIT_START)

3/ vlastnost SCRIPTACTIVE - logická hodnota - FALSE určuje, že skript nemá být aktivován i když nastala
událost podle SCRIPTTYPE

4/ vlastnost SCRIPTCOMMAND - textová hodnota - je-li naplněna, určuje příkaz, který bude skriptem proveden

5/ vlastnost SCRIPTCODE - textová hodnota - není-li vlastnost SCRIPTCOMMAND naplněna, musí obsahovat
víceřádkový programový kód prováděný skriptem

6/ metoda SCRIPTENABLED - viz. rozhraní
Parametry:
_this - objekt formuláře, ze kterého je metoda vyvolána
_typ - identifikace události formuláře (EDIT_START nebo EDIT_END ....)
Návratová hodnota:
logická hodnota - udává, zda je možné skript vyvolat
Rozhoduje o tom, že skript bude proveden podle předaného parametru _typ a vlastností SCRIPTTYPE a SCRIPTACTIVE

7/ metoda SCRIPTEVENT - viz. rozhraní
Parametry:
_this - objekt formuláře, ze kterého je metoda vyvolána
_typ - identifikace události formuláře (EDIT_START nebo EDIT_END ....)
Spouští skript
je-li naplněna vlastnost SCRIPTCOMMAND bude proveden příkaz v ní uvedený
(může použít proměnné _this a _typ)
není-li naplněna vlastnost SCRIPTCOMMAND provádí se víceřádkový programový kód
obsažený v SCRIPTCODE doplněný o "LPARAMETERS _this,_typ,_objscript".
Tomuto kódu je v předáváno v parametrech:
_this - objekt formuláře
_typ - identifikace události formuláře
_objscript - objekt skriptu

Objekt třídy BWSCRIPT je možné vytvářet s parametry, které inicializují jeho vlastnosti.
Např.:
_o=createobject("BWSCRIPT",_scriptid,_scripttype,_scriptcommand,_scriptcode)

Příklad použití v aplikaci Fragment.
Firma Fragment používá jako způsob prodeje svým distributorům komisní prodej.
Zboží v komisi u každého jednotlivého distributora je evidováno v BM na zvláštním skladě.
Při vyúčtování prodeje z komise doposud využívala ručního zadávání programovou šablonu
"Převod mezi sklady" událostí skladu.
Připravuje zavedení automatizovaného zpravování vyúčtování hlášení o prodejích z komise
předávaných od distributorů pomocí textových souborů.
Řešení tohoto požadavku je pomocí "doplňující vlastnosti" formuláře "Převod mezi sklady"
typu program spouštěný z menu formuláře.
Tento program zpracuje vybraný textový soubor a podle jeho obsahu aktualizuje
aktuálně zobrazená data.
Přitom vytvoří protokol o zpracování ve formátu HTML, ve kterém jsou informace o načtených datech
s případným popisem rozporů v evidenci distributora a firmy Fragment.
Program dále zařídí, že tento protokol stejně jako textový soubor od distributora, bude uložen připojený
dokument k procesu, který operace skladového výdeje z komise zahajuje.
To je možné udělat teprve po zápisu událostí výdeje ze skladu, protože v okamžiku běhu programu doplňující
vlastnosti proces neexistuje a nemusí ani podle rozhodnutí obsluhy vzniknout.
Proto připojí k formuláři výdeje ze skladu skript aktivovaný událostí tohoto formuláře
UPDATE_COMPLETED. Tento skript vloží do dat odpovídající dokumenty a propojí je s procesem
datovou objektovou vazbou.

Část kódu programu doplňující vlastnosti formuláře, která zajišťuje vytvoření skriptu:
    * nalezení formuláře skladového výdeje, ke kterému má být skript připojen
    FOR _i=1 TO _SCREEN.FORMCOUNT
        _otec=_SCREEN.FORMS[_i]
        * ve vlastnosti identif je jednoznačná časová identifikace formuláře
        * ve vlastnosti otec formuláře "Převod mezi sklady" je jednoznačná časová identifikace formuláře,
        * do kterého mají být převedena data - objekt běžícího programového kódu obsahuje
        * ve své vlastnosti _this odkaz na tento formulář
        IF TYPE('_otec.identif')='C' AND _otec.identif==THIS._this.otec
            * časové identifikace s shodují - formulář byl nalezen
            EXIT
        ENDIF
    ENDFOR
    IF _i>_SCREEN.FORMCOUNT
        * fomulář události skladového výdeje nebyl nalezen
        RETURN
    ENDIF

    * připojení skriptu pro založení dokumentu - textový soubor od distributora

    * po provedení cyklu je v proměnné _otec odkaz na objekt formuláře skladového výdeje
    * metoda makroprikaz je vyvolána v tomto objektu -  provede příkaz uvedený jako parametr
    * tj. založí objekt třídy BWSCRIPT a připojí ho do seznamu svých skriptů
    * objekt skriptu má jednoznačnou identifikaci V1 a skript jím definovaný bude spouštěn
    * při události formuláře UPDATE_COMPLETED
    _o=_otec.makroprikaz("RETURN this.addscript(createobject([bwscript],[V1],[UPDATE_COMPLETED]))")
    * metoda addscript vrací odkaz na připojený objekt skriptu
    * proto by měl být v proměnné _o odkaz na objekt skriptu
    IF VARTYPE(_o)<>'O'
        RETURN
    ENDIF
    * pro založení dokumentu bude  v kódu použit objekt, který vrací program SP0103DP
    * náledující kód nastaví vlastnosti tohoto objektu tak, aby bylo možné před založením dokumentu
    * doplnit pouze časovou identifikaci procesu
    _o2=sp0103dp()
    * druh dokumentu
    _o2._sp57id='DOK001'
    * předloha dokumentu
    _o2._sp01id="NOTEPA"
    * poznámka k dokumentu
    _o2._sp26koment='Vytvořeno při automatizovaném zpracování komise'
    * soubor ukládaný do dat - proměnnou _soubor_zdroj naplnil program mimo ukázku
    _o2._sp26soubor=_soubor_zdroj
    * popis dokumentu - proměnnou _ad01adsat naplnil program mimo ukázku
    _o2._sp26nazev='Z - Nahláška - '+_ad01adsat
    *  do objektu skriptu přidáme vlastnost dokument a do ní odkaz na objekt pro vytvoření dokumentu
    _o.ADDPROPERTY('dokument',_o2)
    * pozn.: nyní _o2 odkazuje na stejný objekt jako _o.dokument

    * vytvoření kódu skriptu
    _script=''
    * následující příkaz Foxpro TEXT vloží do proměnné _script vše až po ENDTEXT
    * v nezměněném tvaru včetně odřádkování
TEXT TO _script NOSHOW
    * toto je kód skriptu
    * bude proveden až v okamžiku události UPDATE_COMPLETED formuláře skladového výdeje
    * v době běhu skriptu se tento nachází v datové seanci formuláře skladového výdeje
    * k tomuto kódu přidá objekt skriptu řádek "LPARAMETERS _this,_typ,_objscript"
    LOCAL _sp33
    * zjištění časové identifikace odpovídajícího procesu
    _sp33=tool.sql_dotaz([select sp33 from %%%.spprc where sp33cisdr=?_p1 AND sp33cisdpm=?_p2 AND sp33cisd=?_p3],;
        MTUDA.sp33cisdr,MTUDA.sp33cisdpm,MTUDA.sp33cisd)
    IF !EMPTY(_sp33)
        * objekt skriptu předal při vyvolání kódu skriptu v parametru _objscript odkaz na sebe
        * v připojené vlastnosti "dokument" objektu skriptu se náchází objekt pro založení dokumentu
        * vyvoláním jeho metody GO je založen dokument s odkazem na datový
        * objekt typu proces (PR) s časovou identifikací podle proměnné _sp33
        * úspěšné založení dokumentu zároveň deaktivuje objekt skriptu
        _objscript.scriptactive=!_objscript.dokument.go('PR',_sp33)
    ENDIF
ENDTEXT
    * naplnění vlastnosti kód skriptu objektu skriptu
    _o.scriptcode=_script

    * připojení skriptu pro založení dokumentu - protokol o zpracování

    * liší se od části pro založení dokumentu textový soubor od distributora:
    * 1/ typ objektu skriptu je V2
    * 2/ nastavením vlastností objektu pro vytvoření dokumentu
    _o=_otec.makroprikaz("RETURN this.addscript(createobject([bwscript],[V2],[UPDATE_COMPLETED]))")
    IF VARTYPE(_o)<>'O'
        RETURN
    ENDIF
    _o2=sp0103dp()
    _o2._sp57id='DOK001'
    _o2._sp01id='HTML'
    _o2._sp26koment='Vytvořeno při automatizovaném zpracování komise'
    _o2._sp26soubor=_soubor_protokol
    _o2._sp26nazev='V - Nahláška - '+_ad01adsat
    * naplnění vlastnosti kód skriptu objektu skriptu
    * kód skriptu je stejný, protože vše podstatné je ve vlastnostech objektu pro založení dokumentu
    _o.ADDPROPERTY('dokument',_o2)
    _o.scriptcode=_script

Ing. Petr Filip 07.12.02


Mapa přístupových práv

Mapa přístupových práv
je nová činnost, která je určena pro usnadnění definování práv přístupu k druhům procesů, druhům operací, umístěním komponent ...

Po spuštění činnosti jsou zobrazena práva v mřížce, ve kterém je je možné po pravém kliku myší měnit.

Činnost se nachází v menu programu "INFORMAČNÍ CENTRUM" -> "TYPY A ŘADY" -> "Mapa přístupových práv" a měla by být po nainstalování této verze BM běžným uživatelů zakázána.

Činnost je možné také vyvolat z formuláře pro definování práv přístupu (vyvolávaného klávesou CTRL+B) klávesou F5. V tom případě se zobrazí omezený počet práv odpovídajícího druhu.
Ing. Petr Filip 24.11.02


Platby - roční vyúčtování kurz.rozdílů

Platby - roční vyúčtování kurz.rozdílů
Roční vyúčtování kurzových rozdílů předepsaných plateb je řešeno ve verzi BM pro rok 2003 následujícím způsobem:

1/ informace o kurzovém rozdílu se platbě předává jejím spárováním s událostí ZSP, která je založena druhem operace s nastaveným parametrem operace "Povolit nulové částky v ZM". V událostech takového druhu operace ZSP je možné zadávat nulovou částku v ZM a také je tyto události možné párovat s platbami běžným způsobem.

2/ pro spárování událostí ZSP podle bodu ad. 1/ byly doplněny do záznamu o platbě v datovém modelu atributy:
a/ "Kurzový rozdíl - KPP b/ "Kurzový rozdíl - KPP>K.ROK" - atribut PL02KPVETR - kurz předepsané platby je větší než kurz při ročním vyúčtování
je-li při párování v události ZSP záporná hodnota částky v RM, znamená to, že hodnota pohledávky/závazku v RM se snížila => kurz v okamžiku vystavení předpisu platby byl vyšší než na konci roku => přičte se částka v RM události ZSP do spárované události předpisu platby do atributu PL02KPVETR v absolutní hodnotě (POZOR atribut PL02KPVETR proto nikdy nebude obsahovat zápornou hodnotu)
je-li při párování v události ZSP kladná hodnota částky v RM, znamená to, že hodnota pohledávky/závazku v RM se zvýšila => kurz v okamžiku vystavení předpisu platby byl nižší než na konci roku => přičte se částka v RM události ZSP do spárované události předpisu platby do atributu PL02KPMENR
Atributy PL02KPVETR a PL02KPMENR je možné použít při transformacích z operací plateb.

3/ pro výpočet kurzových rozdílů byla vytvořena "Doplňující vlastnost formuláře" událostí ZSP typu program, který je možné vyvolat z menu "Volby" položkou "Update podle kurzu".
Následuje vstup formuláře, ve kterém se zadává měna a datum, pro které má být proveden výpočet kurzových rozdílů neuhrazených předepsaných plateb v zadané měně k zadanému datu.
Před výpočtem musí být kurz pro odpovídající měnu uveden v kurzovém lístku.
Program vypočítává hodnotu kurzového rozdílu výrazem:
(kurzový rozdíl) = (dosud neuhrazeno v ZM k datu) * (kurz) - (dosud neuhrazeno v RM k datu)
Ing. Petr Filip 15.11.02


Platby - účtování o úhradě v ZM

Platby - účtování o úhradě v ZM
Pro transformace z operací plateb byl doplněn atribut PL02UHRZM - "Uhrazeno v zahraniční měně spojenou změnou stavu peněz",
který obsahuje částku v ZM spárovaných událostí ZSP.
Ing. Petr Filip 15.11.02


Práva k bankám

Práva k bankám
v komponentě ZPS upraveno tak, aby pokud je operace na pozadí, šlo zapsat na jakoukoliv banku

v komponentě PLA se práva u identifikace banky (pl01id) neuplatňují, zapsat lze na jakoukoliv banku
Ing. Olga Smitková 19.11.02


Práva versus uživatelská menu

Práva versus uživatelská menu
V "Systém - Oprávnění k činnostem" je standartní struktura činností s možností definovat k těmto činnostem práva.

Menu si uživatel (nebo implementátor) může přetvářet, například tím, že do "OBLÍBENÉ" si přidá nějakou činnost (např. Události obchodu).

"Oprávnění k činnostem" nastavuje práva VE VZTAHU k jejich umístění v menu. Události obchodu ze sekce "OBLÍBENÉ" tedy nejsou ve stejném vztahu k menu jako Události obchodu ze sekce "OBCHOD" !

K událostem obchodu ze sekce "OBLÍBENÉ" ale nelze nastavit práva pomocí činnosti "Oprávnění k činnostem".

Řešení :
V "Oprávnění k činnostem" nastavit práva k činnostem např. pomocí skupin uživatelů.
Z hlavního menu odvodit další menu (pro skupiny uživatelů) a z nich (pokud je to nutné) odvodit ještě další menu (pro jednotlivé uživatele ve skupině).

Skupiny, které jsou různé z hlediska práv, tedy nemohou mít společné menu (muselo by být přísně standardní a nikoliv uživatelské - dodefinované).
Ing. Olga Smitková 01.11.02


Selektory - nulování

Selektory - nulování
Pravidlo : Selektory se, pokud jsou prázdné, předplňují. Selektory se při změně některých atributů vymažou a následně znovu předplní podle nových údajů.

Obchodní selektor se zpravidla předplňuje podle adresáta.
Organizační selektor se zpravidla předplňuje podle umístění.
Technicko-věcný selektor se zpravidla předplňuje podle artiklu.

Dle výše uvedeného byly upraveny komponenty :
- sklad
- obchod
- dph (TV selektor se zde předplňuje dle kombinace datum - typ zdanitelného plnění - tuzemsko/zahraničí; se změnou adresáta se nuluje tuzemsko/zahraničí a tudíž se změnou adresáta se mění obchodní i TV selektor)
- platby (TV selektor se zde předplňuje podle textu - sp88id)
- účetnictví (pouze organizační selektor - nepředplňuje se)
- vymáhání (organizační sel se nepředplňuje, TV selektor se zde předplňuje podle textu - sp88id)
- pošta (org. sel. a TV sel. se nepředplňují)
- obecná komponenta
- zálohy (TV selektor se nepředplňuje)
- zsp (TV selektor se nepředplňuje)
- úkolové listy (obch. sel. podle adresáta, org. sel. podle pracovního poměru, TV dle pracovního poměru nebo dle mzdové položky v závislosti na parametru v Parametrech)
- události mezd (obch. sel. podle adresáta, org. sel. podle pracovního poměru, TV dle pracovního poměru nebo dle mzdové položky v závislosti na parametru v Parametrech)
- změny odpisovaného majetku (obch. sel. dle adresáta, org. a TV sel. dle karty - artiklu)
- změny spravovaného majetku (obch. sel. dle adresáta, org. sel. dle umístění, TV sel. dle artiklu)
- rezervace majetku (obch. sel. dle adresáta, org. sel. - nepředplňuje se, TV sel. dle artiklu)
- zprávy (selektory se nepředplňují)
- obecná událost (V Galaxii nemám práva - neopraveno)
Ing. Olga Smitková 01.11.02


Banka ABO - nastavení

Banka ABO - nastavení
V adresáři musí existovat tyto Paškovy účty :
- 14144....
- 6674.... (tento mají nyní v datech na firmu MARPA, ale účet se objevuje na výpisu jako "náš")

Výpis z účtu :
V definici komunikace s bankou nastavit :
- GPC
- KB107.prg

Příkaz k úhradě :
V definici komunikace s bankou nastavit :
- KPC
- kb108
- kb108.prg
- doladit okkénko Předplnění parametrů podle údajů z banky

Pozn.:
Cvičné soubory s výpisem z účtu obsahovaly údaje pro oba účty (viz výše), tzn. výpis se bude muset zpracovávat dvakrát, pokaždé s jinou identifikací z činnosti Účty/pokladny.

Soubory kb107.prg a kb108.prg a kb108.scx jsou k dispozici na N:\olina\kbbest.
Ing. Olga Smitková 25.10.02


MZDY - vznik a skončení prac. poměru

MZDY - vznik a skončení prac. poměru
oprava chyby ve mzdách - přetahování pravidelných příjmů u pracovníků, kteří nastoupili až v následujících měsících a jejich prac. poměr trvá -> NEPŘETAHOVAT!

testováno v demo verzi (bmsql8) dle připojeného dokumentu
Ing. Olga Smitková 02.10.02

Viz.také

MZDY - nepřítomnosti


MZDY - nepřítomnosti

MZDY - nepřítomnosti
programování - úprava situací, kdy pracovník skončil prac. poměr a je nemocný, nebo začal p.p. a šel marodit

viz dokument testovacích příkladů
Ing. Olga Smitková 11.06.02

Viz.také

MZDY - vznik a skončení prac. poměru


Příkaz k úhradě

Příkaz k úhradě
pro BM Servis - nastavena nová definice komunikace s bankou (0300S)

Pro obchodní banku - externí program ob0100.prg - sčítá záznamy o platbách dle prefixu kreditního účtu + kreditního účtu + variabilního symbolu
Ing. Olga Smitková 16.10.02


MZDY - uzávěrka

MZDY - uzávěrka
oprava programového kódu

Chybné chování v případě, že měl pracovník v jednom měsíci více položek typu dovolená.

testováno : data Fragment
Ing. Olga Smitková 06.09.02


Práva přístupu ke mzdám

Práva přístupu ke mzdám
pro potřeby Moelleru nastavena práva přístupu k tomuto :
- k výplatním místům
- pomocí výplatních míst i ke kartě pracovníka

- pomocí umístění, které se nachází na "Pracovním místě" též nastavena práva na kartě pracovníka - k jednotlivým prac. poměrům.
- též funkčnost práv u událostí mezd a úkolových lístků - opět pomocí umístění
Ing. Olga Smitková 10.09.02


Gemini Volksbank - řešení problémů

Gemini Volksbank - řešení problémů
problémy (historické i předané Jardou) a jejich řešení :
1.při opakovaném spouštění systém padá - opraveno, již nepadá
2. nově doplněno předplňování specifického symbolu u domácího výpisu z účtu
3. popis na řádce výpisu stejný jako na platbě nelze udělat, protože soubor s daty takové údaje neobsahuje, záznamy jsou příliš různorodé - u domácího výpisu doporučuji do popisu řádky dát pevný text, např.: "Bankovní výpis č. :"
- u zahraničního výpisu do popisu plním hodnotu ze souboru s výpisem
4. poplatky u zahraničního výpisu se generují - pravděpodobně to bylo způsobeno chybou padání systému
5. u domácího výpisu se nově předplňuje prefix účtu
Ing. Olga Smitková 07.08.02


Chyba importu

Chyba importu
způsobená ve verzi Foxpro 7.0 odlišným chováním oproti verzi Foxpro 5.0 - APPEND FROM soubor SDF respektuje nastavení SET POINT.
Problém odstraněn rozšířením deklarace - za příznak typu importu SDF je možné zadat znak oddělovače desetin v numerických údajích.
Např.
SOUBOR.TXT
SDF .
určuje, že v numerických údajích je použita jako oddělovač desetin tečka
Ing. Petr Filip 27.08.02


Tisk stornované a stornující faktury

Tisk stornované a stornující faktury
tisk byl nevyhovující, protože u stornované i u stornující faktury nebylko možné zobrazit datumy z DPH a PLA.

Řeší to použití souboru bw_tiskh_cele.prg v sestavě.
Program hledá požadovanou infortmaci v celém sql_tisk bez ohledu na podřízenost na nadřízenost procesů v prezentaci dané sestavy.

Pozor: soubor je nutné compilovat ve správné verzi foxpro.

Testováno u WIP (verze Foxpro 5.0)
Ing. Olga Smitková 22.08.02


Gemini Volksbank domácí

Gemini Volksbank domácí
upraven program pro přijetí domácího výpisu takto :

- nově předplňuje prefix účtu
- nově předplňuje SS
- při opětovném spouštění již nepadá

- do popisu nelze vybrat nějaký smysluplný text, protože záznamy jsou příliš různorodé - návrh - proměnná šablony POPIS s obsahem: 'bankovní výpis č.:'
Ing. Olga Smitková 30.07.02


Kalkulátor

Kalkulátor
Součástí BM je nově vyprogramovaný kalkulátor.
Ing. Petr Filip 15.07.02


Import / Export dat

Import / Export dat
V definici importu typu XBASE je možné v atributu "Selekt" použít přímý kód Foxpro, ve kterém je možné použít všechny možnosti jazyka např. vytváření podprogramů, tříd objektů atd.

Takto definovaný kód musí být uveden příkazem "SCRIPT" a může být ukončen příkazem "ENDSCRIPT". Po vyvolání je mu dostupný objekt importu v proměnné _THIS.

V kódu je možné uvádět odkazy na knihovny vkládaného kódu (klauzule #INCLUDE).
Ing. Petr Filip 25.06.02


Nabídky

Nabídky
Oprava chyby, při které se v některých případech ztrácel název ikon po nadefinování nabídky.
Ing. Petr Filip 25.06.02


Předplňování selektorů v transformacích

Předplňování selektorů v transformacích
Oprava chyby předplňování selektorů v transformacích.

Vysvětlení chyby v tomto modelovém případě:
1/ byla ukončena operace obecné komponenty se zápisem události
2/ byla ukončena operace účetnictví
3/ následuje automatické vyvolání obecné komponenty s transformací z operace ad. 2/
a nastává chyba předplnění TV selektoru, který je předpněn podle artiklu uvedeného v události ad. 1/

Chyba je opravena pouze ve verzi BM pro Foxpro 7.0
Ing. Petr Filip 17.06.02


Skladová evidence

Skladová evidence
Oprava chyby vstupu události skladové evidence, která se projevovala vynulováním cen za jednotky při změně množství
Ing. Petr Filip 17.06.02


Spuštění externího příkazu

Spuštění externího příkazu
V definici spouštěného externího externího příkazu je možné vyvolat program definovaný jako doplňující parametr formuláře.

Spouštěný příkaz musí být definován jako příkaz typu Foxpro a má tvar:

tool.call_program(id.činnosti,id.dopl.vlatnosti)

Např.:
tool.call_program('*','PROGR')
Ing. Petr Filip 25.06.02


Vzhled programu

Vzhled programu
Nastavením parametru "SpecialEffect" v sekci "Preferences" je možné změnit vzhled formulářů.

SpecialEffect=1 - ploché zobrazení
SpecialEffect=2 - ploché zobrazení s přechodem do třídimenzionálního zobrazení při pohybem myši nad údajem (odpovídá standardu Windows XP)
Ing. Petr Filip 25.06.02


Webové služby

Webové služby
Bílý Motýl ve verzi pro Runtime Foxpro 7.0 podporuje Webové služby.

Webové služby jsou základním stavebním blokem pro implementaci distribuovaného zpracování na Internetu.
Vytváří standard pro integraci aplikací prostřednictvím internetu.
Předpokládá se, že budoucnost aplikací je v jejich komunikaci s různými zdroji informací internetu pomocí Webových služeb.

Existuje řada definic pojmu "Webová služba", ale většina definic má tyto společné rysy:
1/ Webové služby definují standardní Web protokol pro přístup uživatelů Web - obvykle protokol SOAP
2/ Webové služby definují protokol pro rozhraní popisující službu na Webovém serveru - Web Services Description Language (WSDL)
3/ Webové služby jsou registrovány pro vyhledání potenciálními uživateli na specializovaných webových stránkách - Universal Discovery Description and Integration (UDDI)

Pomocí webových služeb spolu mohou pomocí internetu komunikovat systémy vytvořené na různých platformách.

V této chvíli není k dispozici na internetu velký počet aplikací, nicméně předpokládám v budoucnu tyto okruhy zpracování:
1/ služby provádějící jednorázový výpočet podle předaných parametrů
např. přepočet částky z jedné měny do jiné měny
2/ služby vracející komplexnější informaci podle předaných parametrů
např. předpověď počasí pro zadanou oblast na určené období
3/ veřejné služby institucí
např. kurzovní lístek
4/ specializované služby pro komunikaci mezi partnery
např. předávání objednávek a faktur mezi obchodními partnery

BM umožňuje ve svých implementací:
1/ zpracovávat informace externích webových služeb
2/ publikovat vlastní webové služby

Ing. Petr Filip 07.06.02

Viz.také

Webové služby - publikování | Webové služby - import


Webové služby - import

Webové služby - import
BM dovoluje definovat importy dat, které zpracovávají informace získané prostřednictvím webových služeb.
Přitom používá protokol MS SOAP, který musí být na počítači instalován.

V kódu pro import spojení typu XBASE se spojení provádí pomocí COM objektu "MSSOAP.SoapClient" např.:
* deklarace proměnné pro objekt klienta
LOCAL _xsoap
* vytvoření objektu klienta
_xsoap = CREATEOBJECT("MSSOAP.SoapClient")
* inicializace klienta pro použití webové služby
_xsoap.MSSoapInit('http://isbm.bmservis.cz./Webpub/bmwssrv.WSDL', "bmwssrv", "bmwssrvSoapPort")
* deklarace proměnné pro uložení získané informace
LOCAL _buffer
* volání metody služby s parametry
_buffer=_xsoap.getdata('VY0001','UZIVATEL','HESLO',date(),date(),'','',.F.,.F.,.F.,.F.,.F.,.F.,.F.,.F.)
* převod dat předaných ve formátu XML do kurzoru s aliasem DATA
=XMLTOCURSOR(_buffer,'data',0)
Ing. Petr Filip 08.06.02

Viz.také

Webové služby


Webové služby - publikování

Webové služby - publikování
BM dovoluje publikovat vlastní Webové služby na internetu.
Předpokladem je provozovat vlastní Web server, na kterém musí být nainstalován:
1/ MS SOAP
2/ runtime Foxpro 7.0
3/ COM objekt BMWSSRV
4/ Webová služba BMWSSRV.WSDL

COM objekt BMWSSRV je součástí BM. Svou metodou GETDATA odesílá klientovi informace získané z dat BM pomocí SQL dotazu.
To jaký dotaz má být odeslán a komu je informace dostupná je dáno definicemi uloženými v BM.
K tomuto účelu slouží činnost hlavního menu programu -> "INFORMAČNÍ CENTRUM" -> "IMPORT / EXPORT" -> "KONFIGURACE WEBOVÝCH SLUŽEB" -> "Webové služby".
Každá WS definovaná touto činností má definovány:
1/ identifikace služby
2/ název služby
3/ příznak platnosti služby
4/ SQL výraz
5/ výraz pro setřídění resp. grupování
6/ popis výstupních atributů
7/ popis parametrů
8/ popis licencí

ad 1. Identifikace služby
Jednoznačně identifikuje služby - je předávána COM objektu BMWSSRV v prvním parametru metody GETDATA

ad 3.příznak platnosti služby
umožňuje pozastavit platnost služby při údržbě

ad 4. SQL výraz
je výraz v syntaxi Foxpro po jehož vyhodnocení vznikne tvar SQL dotazu
např.
[select adadsat.ad01id,adadsat.ad01adsat,adadsat.ad01adsat2 from %%%.adadsat where adadsat.ad01adsat like ']+trim(param.ad01adsat)+[%' and adadsat.ad01id like ']+trim(param.ad01id)+[%']
Ve výrazu se mohou vyskytovat odkazy na parametry WS (ad 7.).
Celkový tvar dotazu SQL vzniká složením části vzniklé vyhodnocením tohoto výrazu, a dále části vzniklé vyhodnocením SQL výrazu uvedeného u licence (ad 8.), a dále vyhodnocením výrazu ad.5.

ad 6. popis výstupních atributů
slouží popis atributů zobrazovaných ve formulářích programu BMWSCLI.EXE, který je určen pro testování definic WS.
V popisu se uvádí seznam atributů s popisem jejich návěští a poznámek

ad 7. popis parametrů
Na záložce "Parametry služby" je uveden seznam parametrů předávaných WS při volání metody GETDATA.
Tyto parametry musí být službě pro metodu GETDATA předávány pozičně podle zadaného pořadí, přičemž takto definovaný pořadově první parametr WS musí být uveden jako celkově čtvrtý parametr volání této metody.
Parametry služby se uplatňují pro sestavování výsledného SQL dotazu výrazem (ad.4.). Při je sestavování jsou parametry uloženy jako vlastnosti objektu PARAM s daným jménem.
Kromě toho má objekt PARAM pro předané parametry typu text další vlastnost jejíž název je odvozen z názvu parametru s postfixem "_LIKE", který bude obsahovat hodnotu parametru zleva bez mezer doplněnou znakem "%".
Např. po předání parametru JMENO s hodnotu "Klaus " bude mít objekt PARAM pro vytvoření SQL dotazu vlastnosti JMENO s hodnotou "Klaus " a JMENO_LIKE s hodnotou "Klaus%", které budou k dispozici ve tvaru PARAM.JMENO a PARAM.JMENO_LIKE.

ad 8. licence
Na záložce "Licence" se uvádí seznam uživatelů (resp.skupin uživatelů) webových služeb (nejedná se o uživatele zadávané ve formuláři "Uživatelé systému") oprávněných používat danou službu.
Ke každé licenci je možné definovat výraz, který se po vyhodnocení stane částí celkového SQL dotazu (viz. ad.4.).
V tomto výrazu je možné použít odkazy na parametry uživatele webové služby, které jsou v objektu PARAM reprezentovány vlastnostmi USR_P1, USR_P2 a USR_P3.

Uživatelé webových služeb se vkládají činností např. z hlavního menu "INFORMAČNÍ CENTRUM" -> "IMPORT / EXPORT" -> "KONFIGURACE WEBOVÝCH SLUŽEB" -> "Uživatelé webových služeb"
Uživatelem WS může být konkrétní uživatel nebo skupina uživatelů.
Pro volání metody GETDATA je identifikován jménem (2.parametr) a heslem (3.parametr).
Jeho přístup ke službám je možné pozastavit nastavením "Aktivní uživatel" na "Ne".

Syntaxe volání metody GETDATA objektu BMWSSRV:
objekt.GETDATA(,,,,,...,)
Ing. Petr Filip 08.06.02

Viz.také

Webové služby


Doplňující parametry formuláře

Doplňující parametry formuláře
umožňují přidat k činnostem vlastní položky menu nebo automaticky vyvolat (při otevření formuláře) spuštění předlohy výstupu, volné karty nebo kódu Foxpro.
Tato funkčnost se vztahuje pro verzi BM pro Foxpro 7.0

Činnost pro definování "Doplňujících vlastností formuláře" se vyvolává z menu formuláře "Obecné".

Každá tato vlastnost určuje akci:
1/ vyvolání metapředlohy výstupu nebo
2/ spuštění kódu v jazyce Foxpro nebo
3/ vyvolání volné karty nebo
4/ vytvoření položky menu s funkčností 1/ nebo 2/ nebo 3/

Pokud vlastnost určuje akci vyvolání metapředlohy výstupu je možné určit pro formuláře událostí komponent vyvolání metapředlohy výstupu dokladu procesu nebo dokladu nadřízeného procesu.
V tom případě není určení metapředlohy výstupu (MPV) povinné, vyvolá se metapředloha uvedená u odpovídajícího druhu procesu.

Pokud vlastnost určuje akci vyvolání volné karty je možné určit pro formuláře událostí komponent vyvolání volné karty procesu nebo operace.
V tom případě není určení volné karty povinné, vyvolá se volná karta odpovídajícího druhu operace resp. procesu.

Akci specifikovanou doplňující vlastností formuláře je možné vyvolat automaticky při spuštění formuláře.
Pro formuláře událostí komponent je možné omezit vyvolání této akce na vybrané operace.
Na záložce "Omezení pro operace" se uvádí seznam operací v procesech, při jejichž spuštění se má požadovaná akce vykonat. Uvedení druhu procesu "-" znamená, že se akce vyvolá pro daný druh operace v libovolném druhu procesu. Kromě toho je možné určit podmínku, v jakém stavu "připravena","zahájena" nebo "ukončena" se daná operace musí nacházet.
Uvedení některé operace v seznamu automaticky znamená, že se akce nebude provádět při vyvolání formuláře v režimu prohlížení událostí odpovídající komponenty.

Při doplnění menu formuláře je možné určit CTRL-klávesu pro vyvolání odpovídající funkce.
Je možné zadat písmeno nebo funkční klávesu F1-F12.

Pro vytváření uživatelských nabídek (toolbarů) je vhodné uvádět pro ekvivalentní doplňující vlastnosti různých formulářů stejnou identifikaci.

Druhem doplňující vlastnosti formuláře jsou dána přístupová práva.
Proto, aby se akce vlastnosti provedla, musí mít aktuální uživatel k jejímu druhu právo alespoň "čtení".
Uživatel s právem "zápis" může vytvářet doplňující vlastnosti daného druhu.

Příklady praktického užití:
Právy k druhu je tedy možné omezit automatické vyvolání volné karty pouze pro vybrané uživatele (to dosud nešlo).
Účetnímu se automaticky zobrazí při účtování úhrady závazku faktura (výstup metapředlohy dokladu nadřízeného procesu), o které účtuje.

Doplňující vlastnost formuláře může definovat vyvolání programového kódu Foxpro.
V textovém poli "kód" je možné zadat plnohodnotný program v jazyce Foxpro, který je možné snáze upravovat v editoru po stisku klávesy F5.
Do kódu je automaticky přidán prvý řádek:
LPARAMETERS _this,
kterým je mu předán objekt formuláře, ze kterého byl vyvolán.
Do kódu je možné vkládat opakovaně použitelné části použitím klausule:
#INCLUDE .
Formulář pro vstup vkládaných kódů se vyvolává z formuláře doplňujících vlastností formuláře klávesou F6.
Přístup k položkám vkládaných kódů je také chráněn jejich druhem a jejich kód je také možné upravovat v editoru po klávese F5.
Ve vkládaném kódu může být uvedena klausule #INCLUDE, která do něho zařadí jiný vkládaný kód.

V této chvíli byl vytvořeno řešení podporující vytváření výstupu do HTML, které plně využívá výhod objektového programování.
Sestává ze dvou základních "vkládaných kódů" (dále knihoven).
Knihovna SYSHTM definuje třídu, která slouží k vytváření obsahu HTML souboru.
Knihovna SYSPRC definuje třídu, pro usnadnění práce s operací v procesu.

To, jakým způsobem je možné jednoduše přehledy zobrazované ve webovém prohlížeči vytvářet budiž patrné v následujím příkladu, který vytvoří přehled událostí obchodu v nadřízeném procesu k události.

LOCAL _o,_o2
* založíme objekt pro orientaci v procesech podle definice třídy v knihovně SYSPRC (viz.#INCLUDE na konci)
_o2=CREATEOBJECT('bm_code_sysprc',_this)
* založíme objekt pro vytváření souboru HTML podle definice třídy v knihovně SYSHTM (viz.#INCLUDE na konci)
_o=CREATEOBJECT('bm_code_syshtm')
* výstupní sestava bude mít titul 'Moje sestava'
_o.settitle('Moje sestava')
* vytvoříme hlavičku souboru HTML
_o.genheader
* do textu vložíme nadpis 'QUICK INFO'
_o.gentag_h2('QUICK INFO',.T.)
* budeme vytvoříme tabulku - tu je třeba inicializovat
_o.table_reset
* připravíme data pro naplnění tabulky
* metoda opendata vrací TRUE, když úspěšný dotaz vrátil alespoň jeden řádek
* všimněte si použití objektu _O2 při sestavování dotazu
IF _o.opendata([select obudal.ad01id,adadsat.ad01adsat,obudal.ob02dat,obudal.ob02datdod,]+;
[obudal.sp61id,obudal.sp60id,spartikn.sp62artikl,obudal.ob02mn,]+;
[obudal.ob02cj01c,obudal.dp02czazm,obudal.dp02cdpzm,obudal.dp02czarm,obudal.dp02cdprm,]+;
[obudal.oc01id,obudal.dp02sazba]+;
[ from %%%.obudal,%%%.spartikn,%%%.adadsat where ]+;
_o2.filter('OBUDAL',.T.)+;
[ and spartikn.sp61id=obudal.sp61id]+;
[ and spartikn.sp60id=obudal.sp60id]+;
[ and spartikn.sp38id=?tool.jazyk]+;
[ and adadsat.ad01id=obudal.ad01id])
* do prvého sloupce tabulky bude vkládán obsah podle výrazu "sp61id+'-'+sp60id" a bude mít nadpis "Artikl"
_o.table_addcol([sp61id+'-'+sp60id],'Artikl')
* podobně
_o.table_addcol([sp62artikl],'Název artiklu')
* podobně + navíc je určeno, že číslo má mít formát 20,2
_o.table_addcol([ob02mn],'Množství',20,2)
_o.table_addcol([ob02cj01c],'CJ',20,2)
* sloupce s cizí měnou má smysl vytvářet, pokud jsme neobchodovali v korunách
IF _o.getvalue([oc01id])<>'CZK'
_o.table_addcol([dp02czazm+dp02cdpzm],'Cena ZM',20,2)
_o.table_addcol([oc01id],'Měna')
ENDIF
* pro tento sloupec budeme chtít celkový součet
_o.table_addcol([dp02czarm],'Základ DPH',20,2,.t.)
_o.table_addcol([dp02sazba],'%')
_o.table_addcol([dp02cdprm],'DPH',20,2)
_o.table_addcol([dp02czarm+dp02cdprm],'Cena Kč',20,2,.t.)
* gentableheader - vytváří hlavičku tabulky s nadpisy sloupců v tomto případě navíc s jedním hlavičkovým řádkem
_o.gentableheader(" 'Obchod - '+dtoc(ob02dat)+' ['+ad01id+'] - '+alltrim(ad01adsat) ")
* gentable - vygeneruje tabulku s daty dotazu metody OPENDATA na základě definic sloupců (TABLE_ADDCOL)
_o.gentable
* gentablefooter - vygeneruje koncovou značku tabulky
_o.gentablefooter
ENDIF
* genfooter - vygeneruje koncové značky HTML dokumentu
_o.genfooter
* show - zobrazí dokument v interním HTML prohlížeči BM
* metoda LABEL objektu _O2 vrátí identifikaci procesu, kterou metoda SHOW zobrazí v nadpisu okna
_o.show(_o2.label(.T.))
* klausule #INCLUDE připojí knihovnu SYSHTM, která obsahuje deklaraci třídy objektu "bm_code_syshtm"
* knihovnu SYSPRC, která obsahuje deklaraci třídy objektu "bm_code_sysprc" není třeba připojovat (tu si připojuje SYSHTM)
#INCLUDE syshtm

Protože, objekt "bm_code_syshtm" knihovny SYSHTM je zdrojem pro nezávislá řešení, umožňují principy objektového programování, na jeho základě vytvořit vlastní objekt (např. "bm_code_usrhtm" v knihovně USRHTM), který překryje "bm_code_syshtm" v metodách a vlastnostech dotýkajících se formátování (vzhledu) výstupního HTML dokumentu.

Ing. Petr Filip 27.05.02


MZDY - kalendáře po dnech

MZDY - kalendáře po dnech
připraveno k testování - viz dokument
Ing. Olga Smitková 22.05.02


MZDY - rodné číslo a datum narození

MZDY - rodné číslo a datum narození
na přání Moelleru - viz spojená vývěska

po vložení rodného čísla se předplní datum narození odvozením z rodného čísla.
Ing. Olga Smitková 30.05.02


OKO - událost - Ctrl S

OKO - událost - Ctrl S
opraveno dle vývěsky, přidán součet množství
Ing. Olga Smitková 29.05.02


Úprava algoritmu zpracování

Úprava algoritmu zpracování
SQL dotazů pro tisk dokladu procesu (optimalizátor SQL dotazů Sybase SQL Anywhere 8.0 nesnáší syntaxi 1=0 za WHERE).
Úprava byla implementována ve verzi BM pro Foxpro 7.0.
Ing. Petr Filip 17.05.02


Výsledky testu Sybase SQL ANYWHERE 8.0

Výsledky testu Sybase SQL ANYWHERE 8.0
Test byl proveden na verzi databáze, kterou má BM Servis poskytnutou jak partner Sybase (autentizovaná verze na zlatém disku nebyla v dané chvíli k dispozici).
Verze byla aktualizována PATHem EBF2289, tj. verze databáze byla 8.0.0.2289.

1/ Převod dat:
Při UNLOAD je třeba překódovat kód z 852LATIN2 na 1250LATIN2 postupem
a/ vytvořit ODBC spojení na databázi verze 7 pro driver 8 (opravdu 8) bez uvedení translatoru - např. db7
b/ vytvořit ODBC spojení na prázdnou databázi verze 8 pro driver 8 bez uvedení translatoru - např. db8
c/ spustit BAT s příkazem
"C:\Program Files\Sybase\SQL Anywhere 8\win32\dbunload.exe" -xi -c "dsn=db7;uid=spravce;pwd=heslo" -ac "dsn=db8;uid=spravce;pwd=heslo" -v -o d:\log\unload.txt
d/ celý Unload pravděpodobně neproběhne v pořádku a bez jakéhokoliv hlášení se ukončí - proč spadl najdete v d:\log\unload.txt
e/ Unload nejspíše spadne při převodu triggerů proto je třeba verzi dat přegenerovat
f/ protože zřejmě nevytvořil správně ani indexy (projevuje se pády při spouštění procesů) je třeba verzi přegenerovat s reorganizací databáze

2/ Nastavení ODBC:
a/ nastavení DSN driveru pro Sybase SQL Anywhere 8.0 s databází vytvořenou ve verzi 7.0 se může uvádět translator (ne však pro Unload)
b/ nastavení DSN driveru pro Sybase SQL Anywhere 8.0 s databází nově vytvořenou ve verzi 8.0 se nesmí uvádět translator

3/ Změny enginu:
a/ podporuje kódovou stránku 1250LATIN2 patřící do skupiny ANSI kódů, a proto nepotřebuje translator
b/ stránka 1250 je také kódem českých Windows, proto translaci nemusí vůbec provádět (rychlost)
c/ má nový druh indexů (Patricia B-tree compressed) pro indexy s délkou klíče delší než 10, a sám je automaticky nastavuje (už se neplatňuje HASH LIMIT jako ve verzi 7.0)
d/ má vylepšený optimalizátor SQL dotazů
e/ jazyk enginu je háklivější na uvádění uvádění vlastníka tabulky v SQL dotazech - zejména je-li jím SYS

4/ Důsledky pro BM pro verzi databáze 8.0 :
a/ byl upraven verzátor, tak aby nenastavoval HASH LIMIT
b/ upraven generátor předloh výstupu dokladů procesů (pro Foxpro 7.0), protože optimalizátor nesnáší 1=0 za WHERE
c/ oprava chyb vznikajích podle 3e.

5/ Porovnání rychlosti
Subjektivním odhadem se jeví, že engine8 je rychlejší než engine7 při zpracování procesů a také při běžném prohlížení dat.
Řádová rychlost se projevila při zabrazení hodnot předmětu projektu (data Fragment)
Ing. Petr Filip 17.05.02


Bílý motýl pro WEB - WBM

Bílý motýl pro WEB - WBM
objekt WBM pro internetový server byl převeden na Visual Foxpro 7.0
Ing. Petr Filip 16.04.02


Do událostí vymáhání přiděláno Ctrl+S

Do událostí vymáhání přiděláno Ctrl+S
Do událostí vymáhání přiděláno Ctrl+S
Ing. Olga Smitková 03.04.02


Dokumenty

Dokumenty
oprava chyby, která se projevovala při spouštění dokumentu typu Excel s BM vygenerovaným pro verzi Foxpro 7.0 při ukončení Excelu.
V této souvislosti byl zaveden parametr souboru BW.INI, sekce "Preferences" -
LOCK_EXCEL=0 ,
který nastavuje původní chování BM ve vztahu k Excelu.
Ing. Petr Filip 08.04.02


e-mail v BM

e-mail v BM
Problém vyvolávání "Outlook Express" místo "Microsoft Outlook" při odesílání e-mail z BM, je pravděpodobně způsoben nastavením "Outlook Express" jako programu "Elektronická pošta" ve vlastnostech Internetu.
Ing. Petr Filip 25.04.02


Gemini - domácí a zahraniční výpis z úču

Gemini - domácí a zahraniční výpis z úču
dokument - popis programového kódu a pravidel nastavení
Ing. Olga Smitková 16.04.02


Gemini - domácí výpis z účtu

Gemini - domácí výpis z účtu
Zpracováno a otestováno - domácí výpis z účtu - elektronicky systémem Gemini.

V adresáři např.: M:\BMSQL12\BANKA\ musí být soubor GE107KMO.FXP

V Definice komunikace s bankou - záložka Nastavení vstupu - program zpracovávající výpis musí být GE107KMO.
Ing. Olga Smitková 10.04.02


Chyba generování volné karty

Chyba generování volné karty
Chyba vzniká, pokud vzdálené pohledy BM ukládané do BWSQL.* byly vytvořeny ještě ve verzi BM pro Sybase SQL Anywhere 5.0.
BWSQL.* ukládané v adresáři C:\BMSQL\ se automaticky nově přegeneruje při instalaci nové verze programu, pokud byly před spuštěním programu zrušeny.
Ing. Petr Filip 25.04.02


Import dat

Import dat
na vstupu proměnných importu je možné definovat reakci na klávesu F2
Ing. Petr Filip 15.04.02


Kód po ukončení operace

Kód po ukončení operace
Oprava chyby objektu KU_MAIL (odeslání e-mail po ukončení operace) - vyvolání metod SET_RECIPADRESS,SET_SUBJECT a SET_MESSAGETEXT se správně uvedenými parametry se neprovádělo pro "Chybný typ parametru"
Ing. Petr Filip 17.04.02


MZDY - kalendáře po dnech

MZDY - kalendáře po dnech
od ing. Novosvětského požadavek na kalendář FPD po jednotlivých dnech.

Zbývá - zabudovat do výpočtu mezd, možná i do uzávěrky - průměry na dovolenou ?

Hotovo - V činnosti pracovní doba - záložka s kalendářem + automatismus při jeho vygenerování. V parametrech jeden parametr, který určuje, jaký kalendář se má používat (po měsících/ po dnech).

Ing. Olga Smitková 19.04.02


MZDY - nepřítomnost pro nemoc

MZDY - nepřítomnost pro nemoc
drobná chyba v činnosti nepřítomnost pro nemoc,
dávka někdy padala - přetečení

testováno - kopie BM
Ing. Olga Smitková 03.04.02


MZDY - prémie s půlročním charakterem

MZDY - prémie s půlročním charakterem
Uzávěrka reaguje i na prémie s půlročním charakterem - půlí je a zahrnuje tu půlku do průměru na dovolenou.

Testováno na verzi -kopie BM
Ing. Olga Smitková 02.04.02

Viz.také

MZDY - reklamace průměrů na dovolenou


MZDY - reklamace průměrů na dovolenou

MZDY - reklamace průměrů na dovolenou
dle provázané vývěsky zjištěno v Bílém Motýlovi
bod 1 - v pořádku

bod 2 - dopracováno krácení dle odpracované a neodpracované doby. Testováno pro měsíční kalendář FPD na kopii BM.
Dopracována i varianta pro denní kalendář FPD (suma pracovních dnů = počet dnů FPD, pokud je svátek proplácen jako odpracovaný, pak nemá příznak svátek, ale pracovní den)

bod 3 - vlivem doplňujících údajů přesčasy započítávám nebo ne, s tím, že započítávanou částku nikdy nenavyšuji
Ing. Olga Smitková 25.04.02

Viz.také

MZDY - prémie s půlročním charakterem


MZDY - vznik a skončení prac. poměru

MZDY - vznik a skončení prac. poměru
v některých případech se špatně pokrátila mzda, pokud pracovník nastoupil v půlce měsíce a dále pracuje.

Rozpor mezi MZPRACPO.mz32skonpp=
a MZPRACPO.mz32skonpp={ . . }

Jako konec prac. poměru je v tom případě dosazeno 1.1.2200.

Testováno : BM kopie, pouze oprava algoritmu, nikoliv struktury databáze
Ing. Olga Smitková 08.04.02


MZDY - zaokrouhlení hrubé mzdy

MZDY - zaokrouhlení hrubé mzdy
zaokrouhlení ve mzdách upraveno tak, aby vycházelo menší než jedna. Oprava - příjmy počítáme na dvě desetinná místa.

testováno : kopie BM, pouze oprava algoritmu, nikoliv struktury databáze
Ing. Olga Smitková 08.04.02


Platby

Platby
Oprava chyby - Formulář událostí plateb - převod zaokrouhlené a nezaokrouhlené částky v ZM do odpovídajících částek v RM - při platbě v měně CZK se do nezaokrouhlené částky v RM nesprávně předplňovala zaokrouhlená částka v ZM
Ing. Petr Filip 11.04.02


Pošta

Pošta
Oprava chyby výpočtu ceny
poštovného
Ing. Petr Filip 05.04.02


Reklamace výpočtu nemocenských dávek

Reklamace výpočtu nemocenských dávek
testováno na Bílém motýlovi se závěrem, že to počítá správně. (tj. včetně zaokrouhlení).
Důvod je ten, že základ (tj. peníze) se počítají jako součet všech základů SP zaměstnance. Tyto základy SP zaměstnance jsou již zaokrouhleny.

viz vývěska
Ing. Olga Smitková 24.04.02


Skladová evidence

Skladová evidence
úprava přepočtu cen za jednotky a celkové ceny při vstupu události
Ing. Petr Filip 08.04.02


Vymáhání

Vymáhání
doplněn druhý datum v události, podle kterého určuje rok v čísle procesu při jeho zakládání.
Funkce označování vymáhaných plateb je nyní vyvolávána klávesou F6 místo původní F9.
Ing. Petr Filip 09.04.02


Vývěska - strom vývěsky

Vývěska - strom vývěsky
k činnosti vývěska byla doplněna funkce "Strom vývěsky" vyvolávaná na klávesu F5.
Zobrazuje strom vytvořený z událostí vývěsky a dokumentů spojených objektovými vazbami.
Ing. Petr Filip 02.04.02


Změna stavu peněz - banka

Změna stavu peněz - banka
nastavení definice banky u nás - elektronický příkaz k úhradě - oba variabilní symboly stejné

Původní interní variabilní symbol - debvs se skládá z dvou čísel roku + idu + pl03id (číslo příkazu).
Ing. Olga Smitková 17.04.02


Změna stavu uzlu diagramu procesu

Změna stavu uzlu diagramu procesu
Změnu stavu uzlu diagramu procesu pro operativní zásah správce systému BM je možné řešit pomocí volné karty a uživatelských triggerů
Ing. Petr Filip 25.04.02


MZDY - artikly

MZDY - artikly
úkol : Výpočet mzdy podle sazby v ceníku artiklu

řešení:
- karta pracovníka má u svého pracovního poměru tarifní stupnici a tar. třídu. tarifní třída má u sebe cenovou skupinu (ob11id).
- Příjmy a náhrady umožňují definovat typ mzdy - "dle artiklu mezd" (mz28puvod).
- výplatní lístky a výplatní lístky - zadávání nemohou používat výše zmíněný typ mzdy, protože zde není k dispozici artikl mezd. (?!?!?!?!)
- úkolové listy mohou používat výše zmíněnou mzdovou položku, protože na úkolových listech je artikl mezd. Úkolové listy se vkládájí procesem.
- Na cenové skupině existují práva přístupu.

Otázka : potřebujete, aby bylo možné používat výše zmíněný typ mzdy i na výplatních lístcích - zadávání ?
Otázka : kdo a jak navkládá ceník k artiklům mezd ?
Ing. Olga Smitková 07.03.02


MZDY - přechod do účetnictví

MZDY - přechod do účetnictví
Upravena šablona "MZDY - UC podrobně a částečně rozděleně" - MZ0103

Chyba u p. Kroneisla ve Stadleru nebyla vlivem pokračující nemoci, ale vlivem chyby šablony do účetnictví.
Pokud pracovník má příjmy nulové, byla chyba v rozdrobování mzdových položek dle trojice selektorů na příjmech.

Opraveno, testováno.
Ing. Olga Smitková 22.03.02


MZDY - šablona do účetnictví

MZDY - šablona do účetnictví
Upravena šablona "MZDY - UC podrobně a částečně rozděleně" - MZ0103

- zaokrouhlení, které vzniklo vlivem odvodu sociálního pojištění za firmu se nyní již kontuje.

pozn.: pracovník "-" musí mít u sebe správné charaktery
Ing. Olga Smitková 21.03.02


MZDY - zaokrouhlení hrubého příjmu

MZDY - zaokrouhlení hrubého příjmu
přidána položka H25000, které je zaokrouhlení hrubého příjmu.

- do DEFINICE - POLOŽKY MEZD - Součty příjmů je třeba přidat položku H25000 a předkontovat ji.

- ve výpočtu všech výplatních lístků i ve výpočtu jednoho výplatního lístku se tato položka vypočítá a lze ji použít dále např. při vstupu do účetnictví
Ing. Olga Smitková 21.03.02


Doplnění popisu BW.INI

Doplnění popisu BW.INI
Doplnění popisu BW.INI
popis parametrů souboru BW.INI
Ing. Petr Filip 22.02.02


Kalkulátor vyvolávaný na F2

Kalkulátor vyvolávaný na F2
Kalkulátor vyvolávaný na F2
na numerické hodnotě při přenosu hodnoty necelého čísla někdy ořezával desetiny.
To je způsobeno chybou Foxpro v souvislosti s proměnnou _CALCMEM.
Nové řešení nepoužívá tuto proměnnou, ale simuluje vstup z klávesnice.
To způsobuje odlišné chování při využití kalkulátoru např.podle příkladu nad událostmi skladové karty:
1/ pravý klik na množství v události
2/ krát na kalkulačce
3/ pravý klik na jednotkové ceně v události
4/ na kalkulačce je rovnou zobrazen součin - v původním řešení bylo třeba stisknout =

Ing. Petr Filip 20.02.02


Účetnictví

Účetnictví
Účetnictví
oprava činností "Účetní saldokonto" a "Účetní saldokonto do data".
Doplněny atributy tisku události týkající se adresáta.
Změna - hodnoty z první záložky je nyní možné tisknout samostaně => pro starší předlohy výstupu, ve kterých se požaduje pohyb v událostech účetnictví je třeba ve vlastnostech předlohy "Pohyb v podřízených ..." zaškrtnout "Deník"
Ing. Petr Filip 28.02.02


Adresář

Adresář
Oprava chyby - nebylo možné tisknout za vybranou kategorii adresátů
Ing. Petr Filip 10.01.02


Dávkové operace

Dávkové operace
při výběru událostí pro "Označení pro dávku" je nyní možné přerušit načítání klávesou ESC.
Ing. Petr Filip 16.01.02


Dokumenty

Dokumenty
Oprava chyby - v záznamu o užití dokumentu se nyní správně zapisuje datum a čas zahájení práce s dokumentem
Ing. Petr Filip 10.01.02


Dokumenty - Spouštěné aplikace

Dokumenty - Spouštěné aplikace
je-li spouštěná aplikace
1/ typu spuštění "Windows podle přípony"
2/ a zároveň má uvedeno v příponě "???"
3/ a zároveň se jedná o dokument externě uložený s názvem s příponou,
potom se spustí aplikace podle přípony v názvu externě uloženého dokumentu
Ing. Petr Filip 24.01.02


Dokumenty artiklu

Dokumenty artiklu
je nová činnost pro prohlížení dokumentů artiklů.

Vyvolává se z přehledu artiklů (v této chvíli obchodu, skladu, obecné komponenty, děl bibliografie, předmětu projektu, informačního centra, věcí aukčního domu) nebo pravým klikem na návěští artiklu výběrem z menu.
Zobrazuje objektově propojené dokumenty, které jsou následníky daného artiklu.
V tomto přehledu je možné nové dokumenty vkládat, editovat jejich obsah klávesou F6.
Pro externě uložené dokumenty se navíc zobrazuje na formuláři jeho náhled propojením pomocí OLE.
V případě práva editace daného dokumentu je možné dvojím klikem na náhledu vyvolat odpovídající program Windows.

Pozn.:
Při rušení záznamu v přehledu dokumentů artiklu, na rozdíl od dokumentů objektu, je zrušen záznam o dokumentu

Tato činnost byla zavedena pro usnadnění definování podkladů pro dynamicky prezentované HTML stránky WEB.
Ing. Petr Filip 24.01.02


Externí příkazy

Externí příkazy
je nyní možné předávat pomocí balíčku
Ing. Petr Filip 10.01.02


Mailem od nás

Mailem od nás
instrukce o způsobu nápravy situace ve mzdách.

Telefonicky s ing. Erlebachovou - dostanou se na to v pátek 11.1.2002 a zavolají.

viz dokument
Ing. Olga Smitková 09.01.02


Obraty na účtech ZSP

Obraty na účtech ZSP
změna na výběrové záložce - zaškrtávací políčko "Zahrnout poslední obrat" bylo nahrazeno překryvným seznamem s návěštím "Poslední obrat".
Nabývá hodnot -
1/ Neurčeno = výběr bez ohledu na poslední obrat (původně bez zašktrnutí)
2/ Zahrnout = není-li v zadaném období obrat, zobrazí se také obrat s nejvyšším nižžším datem (původně to provádělo zaškrtnutí)
3/ Pouze = jsou zobrazeny pouze poslední obraty v zadaném období
Posledním obratem je záznam s nejvyšším datem mezi záznamy, jejichž obsah je stejný v atributech druh hodnoty, vlastní účet/pokladna , měna a adresát.

Volbou "Pouze" atributu "Poslední obrat" je možné, při zadání "Data do", získat přehled odpovídající stavu aktuálních hodnot k zadanému datu v atributu "Konečný stav".
Ing. Petr Filip 10.01.02


Obraty skladu

Obraty skladu
změna na výběrové záložce - zaškrtávací políčko "Zahrnout poslední obrat" bylo nahrazeno překryvným seznamem s návěštím "Poslední obrat".
Nabývá hodnot -
1/ Neurčeno = výběr bez ohledu na poslední obrat (původně bez zašktrnutí)
2/ Zahrnout = není-li v zadaném období obrat, zobrazí se také obrat s nejvyšším nižžším datem (původně to provádělo zaškrtnutí)
3/ Pouze = jsou zobrazeny pouze poslední obraty v zadaném období
Posledním obratem je záznam s nejvyšším datem mezi záznamy, jejichž obsah je stejný v atributech druh hodnoty, sklad , druh artiklu, artikl a adresát.

Volbou "Pouze" atributu "Poslední obrat" je možné, při zadání "Data do", získat přehled odpovídající stavu aktuálních hodnot k zadanému datu v atributu "Konečný stav".
Ing. Petr Filip 10.01.02


Proces zahájený dávkovou operací

Proces zahájený dávkovou operací
při zahájení procesu nedávkovou operací je rok v čísle procesu odvozován podle data uvedeném v její událostech.

Je-li proces zahájen dávkovou operací, je možné určit rok v čísle procesu při vstupu popisu procesu zaškrtnutím volby "Vznik procesu k datu" a zadáním data, jinak je rok v čísle procesu odvozován od aktuálního data.

V procesech spouštěných na pozadí zahajajovaných dávkovou operací je vždy rok v čísle procesu odvozován podle aktuálního data.
POŽADUJEME ZMĚNU TAKTO : V procesech spouštěných na pozadí zahajajovaných dávkovou operací je vždy rok v čísle procesu odvozován podle data uvedeného v jejích událostech.
Ing. Petr Filip 16.01.02


Procesní importy

Procesní importy
Vlastnost "Založení" procesního importu byla rozšířena o hodnotu "Nový proces - možné napojení".

Tato hodnota kombinuje hodnoty "Nový proces" a "Nový proces - napojení":
1/ funguje jako "Nový proces", pokud nebyl proces podle nastavení procesního importu nalezen
1/ funguje jako "Nový proces - napojení", pokud byl proces podle nastavení procesního importu nalezen
Ing. Petr Filip 24.01.02


Předlohy výstupu

Předlohy výstupu
Ve vlastnostech předlohy výstupu přibyla záložka "Deklarace", na které se vyskytuje nová textová vlastnost předlohy "Dodatečné deklarace".
V ní je možné doplnit seznam hodnot nabízený při zakládání nové předlohy.
Každý řádek v deklaraci definuje jeden nový výraz seznamu, má tvar (jeho jednotlivé části jsou odděleny středníky):
;;;
kde
je identifikátor doplněný textem "_USER", pod kterým bude vystupovat v předlohách typu "Excel" a "Ostatní"
určuje typ výrazu. Je možné zadávat typy "N", "C", "D", "T", "L". Pro typy "N" a "C" musí být dále v závorkách uveden rozměr hodnoty výrazu
určuje text zobrazený v seznamu při zakládání nové předlohy
specifikuje výraz pro výpočet hodnoty

Např.:
KS ; N(12,2) ; Konečný stav ; SQL_tisk.mtobrat_mt14pstav+SQL_tisk.mtobrat_mt14prijem-SQL_tisk.mtobrat_mt14vydej

Pozn.:
1/ ve výrazu je možné používat atributy vyplývající z doplnění pohledu

2/ v předlohách typu "Excel" nebo "Ostatní" vystupují doplněné výrazy ve své symbolické podobě, tzn. že případná oprava tvaru výrazu v dodatečných deklaracích se promítá do výsledku předlohy

3/ pro předlohy typu Excel2 je možné definovat výpočtové sloupce tak ,že se jako výraz uvede text vzorce Excelu
Např.:
Soucet ; N(7,4) ; Součet ; '=RC(-2)+RC(-1)'
Ve sloupci v Excelu potom vzniknou v daném sloupci výpočtové buňky se součtem buněk v sousedních dvou sloupcích zleva ve stejném řádku.
Ing. Petr Filip 16.01.02


Replikace - extract

Replikace - extract
pro usnadnění extraktu distribuované databáze pro replikaci, je možné použít Sybase utilitu DBXTRACT v příkazovém souboru BAT.
Např.:

COPY prazdna.db m:\bmsql\data\cilova.db
@IF ERRORLEVEL==1 GOTO :ERROR
dbxtract.exe -xi -xp -xt -xv -c "dsn=zdroj;uid=uziv;pwd=heslo" -ac "dsn=cil;uid=uziv;pwd=heslo" user_02
@IF ERRORLEVEL==1 GOTO :ERROR
CD m:\bmsql
BM.EXE
GOTO :END
:ERROR
@ECHO Extract se nepodařil
@pause
:END

Vyvolání BM po extraktu je možné ve spojení s parametrem "Wait_Update_Version=0" v sekci "Preferences" souboru BW.INI, který způsobí, že při potřebě generování struktur dat při změně verze programu nebo po extraktu, automaticky spustí verzování.
Spuštění tohoto BAT zvládne odpovědný uživatel zákazníka, který předtím musí zrušit ručně soubor m:\bmsql\data\cilova.db, čímž je zajištěna ochrana před nekompetentním provedení jinou osobou.

Pozn.:
Je-li na počítači instalována také Sybase SQL Anywhere 5.x, je třeba volání dbxtract.exe uvést s celou cestou např.:
"C:\Program Files\Sybase\SQL Anywhere 7\win32\dbxtract.exe" -xp -xt -xv -c "dsn=zdroj;uid=uziv;pwd=heslo" -ac "dsn=cil;uid=uziv;pwd=heslo" user_02

Pozn.:
Popis parametrů utility DBXTRACT je uveden v dokumentaci k Sybase SQL Anywhere 7.x .

Pozn.:
Při extraktu na datovém serveru je možné místo -xi použít parametr -ii.

Pozn.:
Při extraktu na datovém serveru je třeba, aby byl server spuštěn s prametrem "-gn all"

Pozn.:
V průběhu extraktu server dovolí pracovat s BM.
To může způsobit chybu extraktu při vytváření cizích klíčů.

Ing. Petr Filip 10.01.02


Replikace - publikace

Replikace - publikace
V popisu publikace pro replikace v BM je možné nastavit pro nadřízené a podřízené DÚ vlastnosti "Replikovat statistiky" s hodnotami Ano/Ne.
Při volbě Ano jsou replikovány záznamy v tabulkách aktuálních hodnot, účetní obratové tabulky a statistických hodnot.
Dobré využití této nové možnosti je při plné replikaci na notebook, které odstraňuje potřebu provádění přepočtu aktuálních hodnot, hodnot obratů a statistických hodnot po vyextrahování distribuované databáze.
Pro řešení s částečnými replikacemi je vhodnější použít jako dosud "Replikace aktuálních hodnot".

Důvodem dobrého rozmyslu replikace statistických hodnot, je jejich způsob přepočtu, při kterém jsou původní záznamy ve statistice vymazány a vznikají nové záznamy s přepočtenými hodnotami. Tím může vzniknout problém velkého objemu dat, který je třeba replikovat, zejména při replikaci pomocí internetu.

Poznámka:
Při zadání "Replikovat statistiky" Ano na nadřízeném DÚ a Ne na podřízeném DÚ je třeba po vyextrahování databáze pro podřízené DÚ generovat publikaci Sybase.
Ing. Petr Filip 10.01.02


Řešení tisku čárového kódu

Řešení tisku čárového kódu
ve firmě Obal Rozkoš.
Připojený dokument řeší tisk unikátních čárových kódů pro různé artikly.
Pro každý artikl je potřeba vytisknout zadaný počet různých čárových kódů.
Ing. Petr Filip 21.01.02


Sklad - programování

Sklad - programování
do výběru u artiklů skladu doplněno

"$$$.ob02vzucet BETWEEN ?thisform._ob02vzucet1 AND ?thisform._ob02vzucet2 and"

do EXIST a NOEXIST
Praktický důsledek : bez této opravy nešlo vybrat artikly zároveň se vztahem k účetnictví nějakým a množstvím nulovým či nenulovým.
Ing. Olga Smitková 10.01.02


Transformace

Transformace
transformace je nyní možné kopírovat.

V nadpisu okna pravidla transformace se objevuje název transformace.
Ing. Petr Filip 17.01.02


Volné karty

Volné karty
byly doplněny další F2-reakce z oblasti mezd (též pro obecné výběry a výkazy).
Tip:
Pro zobrazení odpovídajících hodnot cizích klíčů tabulek k atributům, které jsou na kartě vstupovány, je možné použít výpočtové atributy.
Např.:
Vytváříme volnou kartu, na které má být vstupována identifikace adresáta (bude reagovat na F2) a chceme, aby byl na volné kartě zobrazen také jeho název.
Řešením je vytvoření výpočtého atributu volné karty, který bude plněn pomocí volné pohledu.
Volný pohled využívá hodnotu atributu volné karty, který je v daný okamžik uložen v tabulce Foxpro s aliasem SPF.
Pro náš příklad bude mít SQL dotaz tvar :
select ad01adsat from %%%.adadsat where ad01id=?spf.adresat (adresat je identifikátor atributu volné karty).

Ing. Petr Filip 10.01.02


Volné karty procesů a operací

Volné karty procesů a operací
vyvolané ze spuštěných dávkových operací nyní správně zobrazují karty odpovídající dávkové operaci resp.procesu, ve kterém se operace nachází.

Pro přehlednost takových karet je vhodné v popisu volné karty procesu nebo operace ve vlastnosti "Dynamický nadpis" zadat:
~this.process_id()
Na volné kartě je potom v jejím nadpisu zobrazeno číslo procesu.
Pro volné karty operací je také možné zadat:
~this.oper_id()
Na volné kartě je potom v jejím nadpisu zobrazena identifikace operace.
Ing. Petr Filip 16.01.02


Definice výkazů

Definice výkazů
v zařazení listu k výkazu přibyl nový atribut:
"Parametry INI", který doplňuje stávající atribut "Parametry".
Při zpracování parametrů listu zařazeného na výkaz jsou parametry zpracovány v pořadí:
1/ Parametry INI
2/ Parametry listu (mohou se odkazovat na Parametry INI)
3/ Parametry (mohou měnit parametry listu)

Jsou-li uvedeny "Parametry INI" nesmí Parametry listu obsahovat dynamickou proměnnou.
Na Parametry INI se mohou odkazovat funkce dynamických proměnných řádků nebo sloupců.

Zvláštní význam v definici parametrů listu mají parametry, jejichž název začíná znakem '@'.
Tyto parametry jsou vyhodnocovány již při přípravě definice pro zpracování a proto mohou být použity jako parametry funkcí dynamických proměnných řádků nebo sloupců.
Jejich omezení je:
1/ musí mít konstatní hodnotu
2/ není je možné použít jako identifikátory dynamických proměnných

V definici šablony přibyl atribut "Zrušit existující list", který při nastavením "Ano" způsobí zrušení listu daného jména před vytvořením listu, pokud tento v souboru vytvářeného výkazu existuje.
Ing. Petr Filip 27.12.01


Import/Update dat

Import/Update dat
Definice importu dat byla doplněna o atribut "Čas.id.", která definuje výraz jehož hodnota bude vložena do jednoznačné časové identifikace objektu (má význam pouze při importu objektů).
Jestliže při importu již existuje v tabulce záznam se stejnou časovou identifikací, potom není importován.
Při update slouží tato definice jako výraz pro určení záznamu, který má být aktualizován.
Ing. Petr Filip 27.12.01


Import/Update dat

Import/Update dat
Umožňuje zpracovávat data Outlooku.
K tomu slouží interní metoda vyvolávaná při importu/update spojením typu XBASE :
this.outlook_read( ,,[<,.T.>]) ,
kde

je výstupní alias (obvykle 'DATA')

název souboru (včetně cesty) popisu převodu vlastností objektu Outlooku do atributů cursoru

symbolická identifikace folderu Outlooku, podle které se v popisném souboru určí název skutečného folderu v Outlooku, z něhož budou transformována data do cursoru
<,.T.>
nepovinný parametr, je-li uveden nebudou do cursoru přenášeny informace o objektech, které byly již v minulosti importovány.

Metoda outlook_read při importu přidává k objektů v Outlooku uživatelský atribut BWCID, do kterého při jeho založení vkládá jednoznačnou časovou identifikaci.
Jeho hodnota je zapisována v cursoru do atributu _BWCID_.
Pro správnou funkci je třeba ve vlastnosti importu "Čas.id." zadat výraz "data._bwcid_", čímž je zaručeno, že jednoznačná časová identifikace objektu Outlooku (BWCID) je shodná s časovou identifikací objektu Bílého Motýla.

Jednou z očekávaných aplikací importu z Outlooku je import z folderu typu deník do událostí mezd (výkazy práce,přestávky na oběd ...)

Příklady volání metody outlook_read:
1/ import
this.outlook_read( 'data','template\outlook.cfg','DENIK',.T.)
2/ update
this.outlook_read( 'data','template\outlook.cfg','DENIK')

Příklad obsahu :
* příkaz FOLDER určuje skutečný název podle parametru
FOLDER #UKOLY=Úkoly
* protože je možné, že se požadovaný folder vyskytuje na různých počítačích s různými názvy
* může se vyskytnou vícekrát
FOLDER #UKOLY=Aufgaben
FOLDER #DENIK=Deník
FOLDER #DORUCENA_POSTA=Doručená pošta

* tyto řádky definují strukturu cursoru a za středníkem jím odpovídající vlastnosti objektu Outlooku, případně výrazy zpracovávající vlastnosti objektu (začínají znakem vlnovka)
* přitom je možné se odkazovat na objekty _ITEM nebo _NAMESPACE (viz. dokumentace Outlooku)
* následují řádek by také mohl být - subject m;~_item.subject
subject m;subject
body m;body
currentuser c(40);~_namespace.currentuser.name

* znakem # jsou uvedeny deklarace specifické pro určitý druh objektu Outlooku
* předcházející deklarace jsou společné pro všechny objekty Outlooku
#DENIK
* this.getrecipients je metoda objektu outlook_read vytvářející textový seznam podle adresátů spojených s objektem Outlooku
recipients m;~this.getrecipients(_item.Recipients)
categories m;categories
start T;start
end T;end
duration n(12,2);duration

* konec definice

Potřebné informace o vlastnostech objektů Outlooku pro vytvoření získáte tímto způsobem:
1/ ve spuštěném Outlooku vyberte z menu "Nástroje" - "Makro" - "Editor jazyka Visual Basic"
2/ spustí se Editor jazyka Visual Basic - stiskněte F1
3/ zadejte Outlook Item Objects
4/ vyberte Outlook Item Objects
5/ zobrazí se seznam druhů objektů Outlooku
6/ vyberte jeden z nich
7/ vyberte Properties

Ing. Petr Filip 27.12.01


MZDY - nemoc

MZDY - nemoc
dne 20.12.2001 jsem dodělala opravy mezd dle bodu 1 a 2. U bodu 3 se jedná o úpravu tiskových sestav. Testovala jsem pro malou i velkou organizaci.

Pro den, ve kterém zaměstnanec odpracoval hodiny začala mu neschopnost

1. Odpracoval x hodin ty jsou zaplaceny mzdou, zbytek dne je nemoc.

2. Výpočet nemocenské dávky za 1. den se musí provést z vyměř. základu za
počet hodin nemoci.Tento den se bere již jako 1.den nemoci (50%)+ další 2
dny (50%) pokračování (69%)

3. Pokud v den nástupu nempocenské byly odpracované nějaké hodiny, nepatří
tento den do vyloučné doby na evidenční list.Do dnů podpůrčí doby (trvání
nemoci) tento den patří.
Ing. Olga Smitková 20.12.01


Oceňování

Oceňování
Pro určení data kurzu zadané měny v událostech komponent Obchod, DPH, Platby, Změna stavu peněz a Zálohy je možné činností hlavního menu "INFORMAČNÍ CENTRUM" - > "OCEŇOVÁNÍ" -> "Operace s kurzem prvého dne" stanovit, že má být použit datum prvého dne v měsíci data události daného druhu operace.
Kromě toho je možné zadat "Posun roku", který bude odečten při výpočtu data kurzu (je možné zadat hodnotu 0 až 1000)
Ing. Petr Filip 12.12.01


Spravovaný majetek

Spravovaný majetek
událost spravovaného majetku má nový atribut "Změna ceny", který může nabývat hodnot:
1/ Ne
2/ Nová cena
3/ Přírůstek
Hodnoty 2/ a 3/ je možné zadat při stavu události "Zařazení" nebo "Vyřazení":
2/ Nová cena = na kartu bude zapsána hodnota z události
3/ Přírůstek = cena na kartě bude změněna o hodnotu z události
Ing. Petr Filip 17.12.01


Šablony

Šablony
šablonami je možné definovat hromadnou opravu aktuálně zobrazených záznamů.
K tomuto slouží nová vlastnost šablony "Hromadná oprava".
Je-li tento atribut nastaven na hodnotu "Ano", jedná se o šablonu, která nebude vkládat nové záznamy, ale opravovat existující záznamy vstoupenou nebo konstaní hodnotou v atributech události podle definice šablony.
Typickým případem může být například změna adresáta ve všech událostech operace.
Při změně hodnoty atributu záznamu nedochází, k "vynulování" logicky souvisejících atributů a tím k jejich následnému přepočtu. Tuto vlastnost musí šablona respektovat.
Např. pro šablonu, která mění množství v událostech obchodu, je vhodné deklarovat mezi proměnnými šablony vypočítávanou hodnotu NULA a touto proměnnou měnit hodnoty atributů - množství v referenční měrné jednotce a celkové ceny odvozované z opraveného množství.
Ing. Petr Filip 09.12.01


Datový model projektového řízení

Datový model projektového řízení
Ing. Petr Filip 01.11.01


Druh procesu

Druh procesu
Druh procesu se stal objektem
Ing. Petr Filip 09.11.01


Druhy procesů

Druhy procesů
umožňují ve svých vlastnostech specifikovat výrazy podle, kterých mají být předplněny popis procesu a externí identifikace procesu.
Na záložce "Další" formuláře druhy procesů je možné zadat:
1/ Výraz popisu procesu
2/ Výraz externí identifikace procesu

Je možné zadávat výrazy ve formátu FoxPro, ve kterých je možné použít atributy dotazu formuláře (např. typicky "ad01adsat" pro přenos názvu adresáta)
Kromě toho je možné použít rutinu BM pro SQL-dotaz (např. pro přenos názvu adresáta "tool.sql_dotaz([select ad01adsat from %%%.adadsat where ad01id=?_p1,ad01id]")
Ing. Petr Filip 09.11.01


Metapředlohy výstupu

Metapředlohy výstupu
pro předlohu výstupu uvedené v metapředloze je možné určit parametr, který je předán předloze při výstupu metapředlohou.
Má význam pro předlohy typu Excel nebo HTML, ve kterých je parametr dostupný v proměnné 'this.param1'.
Např. pro pokyn předloze typu Excel, že má být odeslána Mailem, uvedeme v parametru text 'MAIL' a v kódu předlohy zadáme:

.KDYŽ !EMPTY(this.param1) AND ALLTRIM(this.param1)='MAIL'
.EXCEL_CLOSE
.MAIL_RECIPADRESS .....
.MAIL_SUBJECT ......
.MAIL_MESSAGETEXT .....
.MAIL_SEND 1
.JINAK
.EXCEL_NEUKLÁDAT
.KONEC_KDYŽ
Ing. Petr Filip 16.11.01


MZDY - uzávěrka

MZDY - uzávěrka
Test na to, zda pracovník odpracoval 22 dnů za čtvrtletí.

Test nastaven takto : Počet odpracovaných hodin/hodin za den dle kalendáře pracovníka < 22

Testováno v kopii naší verze.
Ing. Olga Smitková 02.11.01


Procesy a operace

Procesy a operace
Oprava chyby - nebylo možné zrušit vytvořenou vazbu objektů na proces nebo operaci z odpovídajícího formuláře
Ing. Petr Filip 09.11.01


Projednání platebních podmínek smlouvy

Projednání platebních podmínek smlouvy
na IS BM (zřejmě od 10:00).
Připravit smlouvu dle nabídky a poslat ji do Accontu.
Dále diskuse o zapojení (resp. vyškolení) jejich nového pracovníka do IS BM.
Ing. Jaroslav Janda 02.11.01


Schůzka k DM mzdy

Schůzka k DM mzdy
domluveno s Olinou.
odloženo
Ing. Jaroslav Janda 01.11.01


SKLAD

SKLAD
V Bílém Motýlovi byly provedeny ve skladu nedávno změny. Ve skladu existuje průměrná cena (4,47 DM) a také cena příjemky s výrobním číslem (4,38 DM).

Pokud děláte výdejku bez výrobního čísla, uplatní se cena průměrná (4,47 DM).
Pokud děláte výdejku s výrobním číslem, uplatní se cena s výrobním číslem (4,37 DM).

Ing. Olga Smitková 05.11.01


Transformace

Transformace
V definici transformace je možné spolu s výrazem "Rozpad na procesy", uvádět výraz "Popis rozpadu".
"Popis rozpadu" určuje text zobrazovaný v zásobníku operací v seznamu operací.
Ve výrazu je možné použít rutinu BM pro SQL-dotaz (např. pro přenos názvu adresáta "~tool.sql_dotaz([select ad01adsat from %%%.adadsat where ad01id=?_p1,Data.ad01id]") pro zobrazení informací, které nejsou součástí dotazu transformace.
Ing. Petr Filip 09.11.01


Událost obchodu

Událost obchodu
dosud počítala kurz události v cizí měně podle data dodání stejně jako sazba DPH podle data dodání.
To je považováno za chybu, proto je v nové verzi počítán kurz podle data události stejně sazba DPH .

Počítání kurzu a sazby DPH podle data dodání je možné v nové verzi nastavit v souboru BW.INI v sekci [Obchod] parametrem 'DPH_Kurz_Dodani=1'.
Ing. Petr Filip 16.11.01


Vlastnosti položky menu

Vlastnosti položky menu
dovolují ve výběru některých vybraných činností nastavit výběrovou hodnotu 'Výběrová záložka', která ovlivňuje chování činnosti po jejím vyvolání.
Je možné vybrat hodnoty:
1/ Neurčeno
tj.chování nezměněno
2/ Aktivovat
tj.po spuštění činnosti z dané položky menu bude aktivována výběrová záložka
3/ Neaktivovat
tj.po spuštění činnosti z dané položky menu nebude aktivována výběrová záložka, nýbrž přímo aktivován dotaz

V této chvíli mají tuto možnost činnosti 'Druhy procesů', 'Druhy operací', 'Procesy', 'Operace'
Ing. Petr Filip 16.11.01


Zásobník operací

Zásobník operací
Byla změněna reakce na dvojklik v seznamu operací.
Ten dříve pozastavoval (resp.rušil pozastavení) provádění operace v zásobníku.
V nové verzi způsobí dvojklik spuštění operace.
Pravý klik v seznamu operací nyní nově pozastavuje (resp. ruší pozastavení) provádění operace v zásobníku.
Nové tlačítko "Vyčistit" slouží k vymazání celého obsahu zásobníku.
Ing. Petr Filip 09.11.01


AD - výběr smluv

AD - výběr smluv
Obecné výběry - smlouvy živé, neživé
RNDr. Jan Sekyra 25.10.01


AD - výběr událostí AUK

AD - výběr událostí AUK
- oprava chyby
- doplněn výběr dle stavu věci a změny stavu - atributy au01vydan, au02vydan
RNDr. Jan Sekyra 25.10.01


AD - výplaty - výběr

AD - výplaty - výběr
Obecné výběry - vyplacené, nevyplacené
nový výběr dle stavu pohledávek za komitentem:
- uhrazené
- neuhrazené
- nedopřesněné
Výběr se uplatňuje na záložce Pohledávky
RNDr. Jan Sekyra 25.10.01


Cizojazyčnost

Cizojazyčnost
Překlady textů položek menu, které nejsou v Galaxii generovány je možné provádět volbou:
Obecné -> NABÍDKY -> Definovat nabídky
tlačítkem "Překlad"
Tímto způsobem je možné překládat také položky, které jsou do menu generovány dynamicky (názvy obecných výběrů, volných karet, nabídek).

Pro zobrazení systémových položek menu v cizím jazyce je možné je možné spustit program s cizojazyčnou knihovnou runtimu Foxpro.
Volání programu se potom provádí např.:
BM.EXE -Lc:\winnt\system32\vfp5deu.dll
Přitom musí být nastaveny parametry:
CODEPAGE=1250 v souboru v COUNFIG.FPW
SystemMenu=1 s souboru BW.INI

Knihovny jsou k dispozici v adresáři K:\BMSQL\SLOVNIK\KNIHOV.
Ing. Petr Filip 10.10.01


Dokončen překlad pojmů IS BM do němčiny

Dokončen překlad pojmů IS BM do němčiny
ještě běží překlad názvů činností.
Ing. Jaroslav Janda 08.10.01


Hrubý datový model výroby

Hrubý datový model výroby
***
***
Ing. Petr Filip 12.10.01


Ovládání formuláře

Ovládání formuláře
Změna ovládání:
Pohyb na další záznam z klávesnice se provádí klávesou CTRL+PGDN a na předchozí záznam klávesou CTRL+PGUP.
V předchozích verzích se provádělo klávesou CTRL+šipka vlevo a CTRL+šipka vpravo.
Ing. Petr Filip 26.10.01


Příkaz k úhradě pro Mirku

Příkaz k úhradě pro Mirku
Změněno nastavení v "definice komunikace s bankou".

Platí následující :
pohledávka záporná = příkaz
pohledávka kladná = inkaso
závazek záporný = inkaso
závazek kladný = příkaz

Jestliže dělám příkaz na pohledávku zápornou (např. dobropis) MUSÍ být částka na příkazu uvedena záporně (protože jedině s touto kolonkou definice komunikace s bankou pracuje).

Původně :
IIF($typzaz$=1,'32','11')+
STRT(STR(INT($castka$),13),' ','0')+
STRT(STR(INT(($castka$-INT($castka$))*100),2),' ','0')+

Nyní :
IIF(($typzaz$=1 and $castka$<0)or($typzaz$=2 and $castka$>=0),'11','32')+
STRT(STR(INT(abs($castka$)),13),' ','0')+
STRT(STR(INT((abs($castka$)-INT(abs($castka$)))*100),2),' ','0')+
Ing. Olga Smitková 08.10.01


Rezervace majetku

Rezervace majetku
Do činnosti (pomocí OUTVIEW) doplněny některé atributy, aby bylo možné používat transformace.

Testováno: verze pro WIP
Ing. Olga Smitková 02.10.01


Řízení procesů

Řízení procesů
oprava chyby - vazba XOR funguje správně pro vazbu vycházející z uzlu charakteru proces.
Ing. Petr Filip 12.10.01


Tisk dokladů podle prezentace procesů

Tisk dokladů podle prezentace procesů
Oprava chyby
tisk prezentovaného druhu operace, která nemá zaškrtnuté "Operace z procesu", provádí tisk událostí všech operací daného druhu v hlavním procesu (dříve nefungovalo).
Tato oprava může způsobit chybu výstupu v prezentovaných operací, které nemají omylem zašktrnuto "Operace z procesu".
Přehled těchto potenciálně nebezpečných definic je možné získat v ISQL dotazem:
SELECT * FROM BM_SERVIS.SPPREZPL WHERE
SPPREZPL.sp78vpoces=0
Ing. Petr Filip 26.10.01


Vstupní masky operace

Vstupní masky operace
Doplnění vlastností atributu ve vstupní masce operace:

1/ Validace
Určuje validační výraz vyhodnocovaný při vstupu události
Přitom je ve validačním výrazu nahrazován řetězec:
a/ ### - hodnotou odpovídajícího atributu
b/ $$$ - identifikací entity události komponety
Např.:
$$$.zp02parova=2 OR NOT EMPTY(###)
pro atribut variabilní symbol komponenty ZSP odpovídá verbální podmínce - "Párovaná událost ZSP musí mít uveden variabilní symbol"
Spolu s validačním výrazem je možné určit "Volný text", který bude zobrazen jako chybové hlášení (podporuje cizojazyčnost).

2/ F2-reakce
Pro libovolný textový atribut je možné nastavit reakci na klávesu F2.
Přitom, je-li určena F2-reakce programem BM, uplatní se F2-reakce definovaná pro atribut v masce operace.
Tím je např. možné vyvolat nabídkou F2 události obchodu na artiklu vyvolat výběr ze seznamu skladovaných artiklů.
Ing. Petr Filip 02.10.01


A dům - možnost slevy

A dům - možnost slevy
Činnost je dostupná nad věcí AD , která není vlastní.
Po spuštění se zobrazí formulář se vstupním polem pro zadání částky slevy a s informací na jakou minimální částku (minimální prodejní cena) lze věc podle smlouvy a kalendáře zlevnit. Částka slevy musí být větší než nula, nová prodejní cena nesmí být menší než minimální prod. cena a nákupní cena snížená o částku slevy musí být nenulová. Po zápisu dojde ke snížení jak prodejní, tak nákupní ceny o zadanou částku slevy.
RNDr. Jan Sekyra 27.09.01


AD - parametry blokování

AD - parametry blokování
V činnosti Parametry blokování vyvolané kl. F5 z činnosti Parametry věcí lze nastavit počty dnů blokování zvlášť pro každý důvod - karta, posudek, neurčeno. Tyto hodnoty se pak použijí pro výpočet datumu blokování v operaci blokování věci.
RNDr. Jan Sekyra 12.09.01


Předlohy výstupu

Předlohy výstupu
Vlastnosti předlohy výstupu byly doplněny o možnost určení "Logické tiskárny".
Logická tiskárna určuje nepřímo skutečnou fyzickou tiskárnu, na kterou má být proveden výstup.

Logické tiskárny se definují v menu SYSTÉM spolu s dalšími souvisejícími objekty.
Jsou to:
1/ Logické tiskárny
2/ Fyzické tiskárny
3/ Pracoviště uživatelů BM
4/ Počítače uživatelů BM

Logická tiskárna (1) je propojena s pracovištěm (3) a v této vazbě je odkaz na fyzickou tiskárnu (3).
Pracoviště (3) definuje množinu počítačů (4), které mají z hlediska výstupu na tiskárnu shodné vlastnosti.

Přidělení logické tiskárny předloze výstupu má význam při přímém výstupu na tiskárnu klasickou předlohou nebo předlohou typu Excel.
Je-li uvedena, potom při přímém výstupu BM před tiskem vyhledává podle systémové (Windows) identifikace počítače (4) vazbou pracoviště (3) na danou logickou tiskárnu (1) konkrétní fyzickou tiskárnu (2), na kterou má být proveden výstup.
Je-li taková fyzická tiskárna nalezena, potom BM vloží do předlohy parametry nalezené tiskárny.
Není-li nalezena, potom je před tiskem uživatel vyzván k výběru tiskárny i když podle profilu měl být proveden přímý výstup bez dotazu na výstupní tiskárnu.

Fyzická tiskárna k logické tiskárně není nalezena v případě, že pro odpovídající pracoviště není definována vazba na odpovídající logickou tiskárnu nebo není-li fyzická tiskárna aktivní (vlastnost objektu fyzická tiskárna).

Příklady logických tiskáren:
Výstup na hlavičkový papír
Výstup na běžný papír
Výstup na obálky
Výstup na etikety
....

Má-li skutečná tiskárna více příhradek pro vstup papíru, je pro ní možné definovat více fyzických tiskáren.
Tato možnost se bohužel neuplatní při výstupu předlohou typu Excel.

Nastavení parametrů fyzické tiskárny se provádí v přehledu fyzických tiskáren klávesou F5, po které se zobrazí prázdná výstupní předloha, ve které se volbou menu "Soubor" -> "Vzhled stránky" určí parametry tiskárny.

Tiskárny uvedené v metapředlohách jsou logické tiskárny.
Metapředloha může změnit logickou tiskárnu definovanou v ní obsažené předloze.
Při výstupu do Excel je v ní možné určit současný výstup na více různých logických tiskáren.

Ing. Petr Filip 07.09.01


Vstupní masky operace

Vstupní masky operace
Byl změněn datový model masek operací.
Původně byly informace o vlastnostech atributů v masce operace uloženy ve společném atributu (memo).
Nyní jsou vlastnosti atributů v masce operace uloženy ve standardní datové tabulce (SPTYPMAS), která je spojena s tabulkou výrazů komponenty (SPTRNH která definuje také výrazy pro transformace).

Tato změna umožňuje inicializovat atribut podle masky nejenom konstantním textem nebo předkontací, ale také výrazem vyhodnoceným v okamžiku pořízení nového záznamu (např. datum odvozený podle aktuálního data, SQL dotaz, externí uživatelsky definovaná funkce, ...).
Pro systematičnost implementace je dobré definovat některé významné konstanty např. umístění (bankovní účty, sklady, ...) ve výrazech komponent.

Činnost "Definice výrazů komponenty" je rozšířena o záložky "Výskyt v transformacích atributů" a "Výskyt v maskách operací", ze kterých je možný přechod do definic transformací resp. masek operací.

V přehledu komponent (činnost "Komponenty") je možný přechod do přehledu výrazů ("Definice výrazů") z menu Volby->VÝRAZY KOMPONENT. To bylo doposud možné pouze při definování transformací.
Ing. Petr Filip 15.09.01


AD - zadání více záloh na smlouvu

AD - zadání více záloh na smlouvu
- do tabulky AUPOHL doplněn atribut "číslo zálohy na smlouvu"
- validace zápisu do tabulky AUPOHL - úprava triggerů, párování úhrady proti předpisu
- předplňování čísla zálohy posledním existujícím
- úprava importu vyrovnání nákladů komponenty AUP

RNDr. Jan Sekyra 10.08.01


Aktuální a statist. hodnoty

Aktuální a statist. hodnoty
Oprava chyby aktualizace aktuálních a statistických hodnot.
Chyba nastával při opravě události v atributu, který mění identifikátor hodnoty (např. sklad, artikl) a přitom hodnota pro kombinaci opravovaných atributů byla nulová.
Ing. Petr Filip 03.08.01


Druhy operací

Druhy operací
Záložka "Další" přehledu druhů operací obsahuje nové atributy.

Ukončení operace bez události (netýká se operací, které zahajují proces) - stavy
1/ Ano - operace může být ukončena i když nebyly založeny žádné události (nebyla zahájena)
2/ Ne - nemůže být ukončena nezahájená operace (default)
3/ Rozhodne uživatel

Operaci na pozadí vždy ukončovat automaticky - stavy
1/ Ano - ukončí automaticky byť v diagramu je uvedeno "Automaticky neukončovat"
2/ Ne - automatické (ne)ukončování operace na pozadí odpovídá diagramu (nyní default)

Zrcadlové storno - umožňuje nastavit, že se pro daný druh operace bude chovat storno vždy tak, jako kdyby operace nebyla ukončena. Tj. záznamy o událostech a samotná fyzická operace budou při stornu zrušeny.
Stavy
1/ Ano - (default pro většinu komponent) události ani fyzická operace nebudou pro ukončené operace daného druhu zrušeny a budou vytvořeny inverzní operace a události
2/ Ne - události a fyzické operace stornovaných procesů budou vždy rušeny
Pozn.: Některé komponenty nemohou z principu vytvářet při stornu inverzní události (události obsahují unikátní klíče). Proto je pro ně default stav zrcadlového storna NE.
Chování komponent z tohoto pohledu je dostupné v přehledu komponent (činnost "Komponenty").
Ing. Petr Filip 09.08.01


Evidenční lístek - psaní - dle ceny

Evidenční lístek - psaní - dle ceny
Tisková sestava, která doporučené zásilky sečte podle ceny - jako obyčejná psaní.
Ing. Olga Smitková 20.08.01


Kód po ukončení operace

Kód po ukončení operace
Nový parametr metody OP_PRINT objektu KU_DATA.
Viz. dokument

Po této změně je třeba opravit kódy po ukončení, ve kterých metodou OP_PRINT vzniká soubor pro odeslání MAILU.
Ing. Petr Filip 03.08.01


Kód po ukončení operace

Kód po ukončení operace
Popis metody SET_OPERATION byl doplněn o text:

Při nastavení na uzel diagramu charakteru proces se jako první parametr uvádí prázdný řetězec a druhý parametr druh procesu (využití např. při použití metody OP_EXEC - založení nového procesu na základě diagramu)
Ing. Petr Filip 09.08.01


Metapředloha výstupu

Metapředloha výstupu
je objekt, který v sobě skrývá jednu nebo více skutečných předloh systému BM vytvořených pro jednotlivou činnost (formulář).
V datovém modelu systému jsou objekty spojovány s předlohami výstupu právě pomocí objektu "Metapředloha výstupu" (např. předloha výstupu pro doklad spojený s druhem procesu, doklad tištěný podle předlohy druhu operace v diagramu procesu ...).

Výstup podle předlohy výstupu zařazené v metapředloze výstupu může být podmíněný.
Podmínka výstupu předlohou se vyhodnocuje v okamžiku tisku a je uváděna v definici metapředlohy v syntaxi jazyka Foxpro. Může obsahovat makra (viz. vývěska OPT121-17.8.2001-Označování výrazem).
Typickým příkladem makra může být zjištění národnosti aktéra, kterého se týká proces faktury.
Odpovídající makro může v sobě použít funkce BM pro SQL dotaz a přitom použít proměnné _sp33cisdr, _sp33cisdpm, _sp33cisd, _sp06idsubs, _sp07idtyp a _sp33porad, které identifikují aktuálně vystupující operaci/proces.

Předloha výstupu v metapředloze výstupu může být prováděna s některými jinými vlastnostmi než s těmi, které jsou v ní uvedeny.
Jedná se o:
1/ výstupní jazyk
2/ počet kopií
3/ profil výstupu
4/ navíc pro předlohu typu Excel může definovat výstup na určenou jednu nebo několik různých tiskárem (ve výrazech je možné používat makra)

Kromě toho může být vlastností předlohy výstupu v metapředloze určeno, že při výstupu metapředlohou uživatel rozhodne, která nebo které její předlohy mají být užity.

Metapředlohu je také možné používat volitelně jako běžnou předlohu (tj. může být použita ze seznamu předloh výstupu činnosti).

Metapředloha výstupu stejně jako předloha výstupu má určena přístupová právy druhem předlohy (stejná entita). Při výstupu metapředlohou se na práva přístupu na v ní obsažené předlohy nepohlíží.

Seznam metapředloh je možné vyvolat v činnostech "Druhy procesů" a "Druhy operací" klávesou F2 při vstupu, v činnosti "Komponenty" z menu Volby a ze seznamu předloh výstupu činnosti výběrem z menu po pravém kliku myší.

V souvislosti se zavedením metapředloh byla zrušena funkčnost předloh spojených s druhy procesů pro výběr předlohy pro tisk při běhu procesu.
Odpovídající záložka v činnosti "Druhy procesů" přechodně zůstala (bez možností editovat), aby podle ní mohl implementátor upravit metapředlohu procesů.

Instalace nového systému vytváří pro původně spojené předlohy s datovými objekty odpovídající metapředlohy a přitom je identifikuje číselnými identifikátory. Proto je přechodně dovoleno identifikace metapředloh opravovat.

Objekt KU_DATA (využívá se k kódu po ukončení operace) byl doplněn o metodu OP_PRINT_META, která provádí výstup metapředlohou.
Ing. Petr Filip 17.08.01


Množství artiklu na skladech

Množství artiklu na skladech
Činnost se vyvolávala pouze na pravý klik na návěští artiklu.
Byla doplněna o výběrovou záložku a zařazena do hlavního menu pod skupinu "SKLAD".
Dále se vyvolává při vstupu události skladové evidence na atributu "skladové úložiště" při skladovém výdeji a na atributu "buňka" vždy. V obou případech je možné přejít do výběru seznamu skladů resp. skladových buněk klávesou F5.
Ing. Petr Filip 03.08.01


Nabídky

Nabídky
Oprava chyby, která se projevovala při aktivní nástrojové liště (toolbaru) při ukončování programu.

Vytvořena nabídka "Základní" obsahuje významné společné funkce formulářů.
Ing. Petr Filip 03.08.01


OKO - aktuální hodnoty

OKO - aktuální hodnoty
doplněno třídění dle částky
Ing. Olga Smitková 27.08.01


Označování výrazem

Označování výrazem
je další způsob získávání informací z BM.
Vyvolává je položkou menu
"Volby - OZNAČOVÁNÍ - Označování výrazem".
Funkce vyvolá vstup pro zadání a uchovávání výrazů přihlášeného uživatele.
Po uložení výrazu je možné vyvolat označení záznamů, které vyhovují zadané podmínce a přitom se uplatňuje také aktuálně platný výběr výběrové záložky a příp. aktuálně použitý obecný výběr.
Funkce "Označování výrazem" se uplatňuje pouze ve formulářích objektů BM a není ji možné vyvolat z menu "OZNAČOVÁNÍ", je-li v dané chvíli aktivní výběr označených záznamů.
Pro usnadnění zadávání dotazu může uživatel používat implementátorem systému předdefinovaná makra.
Atributem makra je mj. jeho druh, kterým je možné vyhradit jeho exkluzivní použití některým uživatelům systému.
Každý formulář má svou vlastní množinu maker.
V makru se definuje:
1/ název makra
2/ template tvar skutečných parametrů makra
3/ textové pole pro vstup části SQL dotazu za WHERE
(výraz makra)
4/ textové pole pro vstup části SQL dotazu za FROM
5/ formální parametry makra

Při zadávání dotazu uvádí uživatel název makra (1) se skutečnými parametry.
Při jeho vyhodnocování dojde k nahrazení odpovídající části dotazu obsahem (3).
Přitom jsou formální parametry (5) nahrazeny parametry skutečnými.

Makra pro označování výrazem obsahují ve výrazu makra výraz v syntaxi SQL jazyka serveru Sybase SQL Anywhere, který zpravidla vrací logickou hodnotu.
Formální parametry makra se ve výrazu makra uvádějí v hranatých závorkách.
Makra není možné vnořovat.
Definovat makra je možné z formuláře "Označování výrazem" klávesou F5.

Při zadávání výrazu označování může uživatel vyvolat rychlou nápovědu klávesou F2 nebo pravým tlačítkem myši.
Ing. Petr Filip 17.08.01


Procesy

Procesy
Odpověď na:
Dávková operace nelze ve vlastnostech uvést do stavu připravena, tj. nelze ji opravovat po ukončení. Nevím jak na ni reaguje storno, zda ji "odpojí" pokud je unikátní.

Vlastnosti dávkových operací je možné vyvolat ze stromu a odtud eventuálně zrušit stav ukončena.
Od nové verze je možné vyvolat vlastnosti operace v přehledu operací resp. procesů.

Storno vždy ruší dávkovou operaci včetně jejich událostí, protože nemůže vytvářet odpovídající inverzní události.
Ing. Petr Filip 09.08.01


příkaz k úhradě - v BM Servisu

příkaz k úhradě - v BM Servisu
Chyba v přenosu příkazu k úhradě z BM do obchodní banky - v souvislosti se specifickým symbolem.

V definice komunikace s bankou je třeba nastavit v Nastavení výstupu do definice řádku toto :

IIF($typzaz$=1,'32','11')+
STRT(STR(INT($castka$),13),' ','0')+
STRT(STR(INT(($castka$-INT($castka$))*100),2),' ','0')+
SUBSTR(DTOC($datump$,1),3,6)+
PADR($mena$,3,' ')+
STRT(STR(prom5,4),' ','0')+
PADL(ALLT($ks$),10,'0')+
PADL(ALLT($prdu$),6,'0')+
PADL(ALLT($du$),10,'0')+
PADL(ALLT($ss$),10,'0')+
PADL(ALLT($debvs$),10,'0')+
PADL(ALLT($idkb$),4,'0')+
SPACE(3)+
PADL(ALLT($prku$),6,'0')+
PADL(ALLT($ku$),10,'0')+
PADL(ALLT($debss$),10,'0')+
PADL(ALLT($vs$),10,'0')

$ss$ je totiž specifický symbol náš vlastní
$debss$ je totiž specifický symbol na platbě
Ing. Olga Smitková 09.08.01

Viz.také

Příkaz k úhradě


Příkaz k úhradě

Příkaz k úhradě
Z Fragmentu hlásili, že pokud se pokouší o příkaz k úhradě na platbu do spořitelny se specifickým symbolem, pak jim program KB Best platbu vrátí.

Opraveno - v činnosti Příkaz k úhradě chyběl v pohledu atribut ADBUCTY.ad03ssymb - dopsáno jako na pozadí.

Konzultovat s Mirkou - měla podobný problém - odstranění viz vývěska
Ing. Olga Smitková 11.07.01

Viz.také

příkaz k úhradě - v BM Servisu


Rozšířené možnosti výběrů

Rozšířené možnosti výběrů
Na atributu "uchovat" výběrových záložek, je možné pravým klikem vyvolat seznam výběrů vstupem.
Tyto výběry jsou shodné s výběry spojovanými s položkami hlavního menu.
Po pravém kliku je také možné "výběry vstupem" definovat. Tato možnost se v menu objeví v případě, že odpovídající činnost je dostupná v hlavním menu programu.
Přístup k "výběru vstupem", tj. zda se zobrazí na pravý klik atributu "uchovat", je možný dvojím způsobem podle nastavení atributu výběru "veřejný přístup" - stavy:
1/ Ano - přístup je dán zařazením aktuálního uživatele do některé ze skupiny uživatelů spojených s výběrem. Přidělovat práva skupin uživatelů mají vlastník výběru, uživatel s právy správce a správce systému (stejně jako nastavovat atributu "veřejný přístup"). Tzn., že výběr nemusí být nabídnut na atributu "uchovat" jeho vlastníkovi.
2/ Ne - přístup je výhradně dostupný pro vlastníka výběru. Ve formuláři pro definování "výběrů vstupem" se výběr s takto nastaveným atributem zobrazí pouze jeho vlastníkovi, uživateli s právy správce a správci systému (při neveřejném přístupu není možné spojovat skupiny uživatelů s výběrem)
Popsané řešení přístupů se nevztahuje k výběrům spojeným s činnostmi v hlavním menu programu.

Samotné nastavení parametrů výběru (klávesa F5) je dovoleno všem uživatelům.

Nově založený "výběr vstupem" automaticky získává aktuální nastavení atributů výběrové záložky ve stavu po posledním zápisu výběru na výběrové záložce.

Ing. Petr Filip 09.08.01


Událost obchodu

Událost obchodu
Oprava chyby, která se projevovala při opravě jednotkové ceny po okamžitém zápisu bez opuštění atributu disketou v základním toolbaru chybným přepočtem procenta slevy a celkové ceny.
Ing. Petr Filip 03.08.01


*A dům - skladné - dopracování požadavku

*A dům - skladné - dopracování požadavku
Řešení viz. spojený dokument
RNDr. Jan Sekyra 04.07.01


AD - atributy pro tisk

AD - atributy pro tisk
atributy identifikace procesu dány k dispozici pro tisk v činnosti Události v aukčním domě.
RNDr. Jan Sekyra 11.07.01


AD - datum události v komp. AUP

AD - datum události v komp. AUP
se nyní plní datumem uvedeným v parametrech uživatele.
RNDr. Jan Sekyra 19.07.01


AD - komponenta AUK

AD - komponenta AUK
dány k dispozici pro transformaci atributy identifikace procesu
RNDr. Jan Sekyra 16.07.01


AD - prodej se ztrátou

AD - prodej se ztrátou
Umožněn prodej vlastní věci s prodejní cenou stejnou nebo nižší než nákupní s upozorněním uživatele na tuto skutečnost ; základ DPH a DPH jsou v tomto případě nulové.
RNDr. Jan Sekyra 13.07.01


AD - přejmenování překryv. seznamů

AD - přejmenování překryv. seznamů
pro způsob úhrady.
RNDr. Jan Sekyra 13.07.01


AD - seznam vydražitelů v akci

AD - seznam vydražitelů v akci
řešení viz. dokument
RNDr. Jan Sekyra 24.07.01


AD - suma nad věcmi

AD - suma nad věcmi
- "Pohledávky" přejmenováno na "Neuhrazené pohledávky"
- "Pohledávky smluv" přejmenováno na "Nevyrovnané zálohy"
- doplněna částka k úhradě (dosaženo + aukční přirážka)
a částka skladného
RNDr. Jan Sekyra 04.07.01


AD - Sumy udál. AD - doplnění

AD - Sumy udál. AD - doplnění
- uhrazeno hotově
- uhrazeno na účet
- uhrazeno zálohou
RNDr. Jan Sekyra 19.07.01


AD - vyplacení věci - různé varianty

AD - vyplacení věci - různé varianty
řešení viz. dokument
RNDr. Jan Sekyra 13.07.01


AD - výplaty

AD - výplaty
Umožněno vyplacení i nepředané věci, tj. věc je v AD.
RNDr. Jan Sekyra 16.07.01


AD - vyřazené smlouvy

AD - vyřazené smlouvy
vyřešeno sestavou v EXCELU.
RNDr. Jan Sekyra 18.07.01


AD - zadání věcí bez cen na smlouvu

AD - zadání věcí bez cen na smlouvu
- K věci přidán atribut Rozpracována Ano/Ne
- u rozpracované věci lze zadat nulové ceny + %
- rozpracovanou věc nelze prodat
- doplněn výběr Rozpracována -Ano/Ne nad věcmi AD
RNDr. Jan Sekyra 16.07.01


AD - zrušení vybraných sloupců

AD - zrušení vybraných sloupců
v mřížce formuláře Události v aukčním domě v operaci běžného prodeje.
Týká se sloupců:
- částka k výplatě
- částka provize
- procento pro výpočet ceny k vyplacení

viz. spojená vývěska a dokument
RNDr. Jan Sekyra 11.07.01


Další postup v implementaci AUD

Další postup v implementaci AUD
viz.dokument
Ing. Petr Filip 10.07.01


Evidenční lístek poštovného - řešení

Evidenční lístek poštovného - řešení
Opravena sestava
Evidenční lístek poštovného - chtějí doporučené zásilky uvádět nikoli sečtené, ale každou zvlášť; normální dopisy uvádět sečtené - jako doposud ( vždy ty se stejnou sazbou za kus)
Ing. Olga Smitková 25.07.01


Funkce výkazů

Funkce výkazů
viz.dokument
Ing. Petr Filip 09.07.01


Mzdy - výplatní lístek

Mzdy - výplatní lístek
V činnostech "Výplatní lístek" a "výplat. lístky - zadávání" byla opravena funkčnost atributu mz02hotove ( v penězích).

Předplňuje se dle nastavení na mzdové položce (příjmy a náhrady).

testováno: kopie BM za 05/2001
Ing. Olga Smitková 26.07.01


Popis souboru BW.INI

Popis souboru BW.INI
připojený dokument obsahuje popis možností nastavení souboru bw.ini
Ing. Olga Smitková 13.07.01

Viz.také

ZPS - oprava atributu ad01id


ZPS - oprava atributu ad01id

ZPS - oprava atributu ad01id
V Galaxii opraven calc atributu ad01id (na pozadí).

Původně bylo ADBUCTY3.ad01id
Nyní iif(empty(ADBUCTY3.ad01id),'- ',ADBUCTY3.ad01id)

Souvisí s elektronickým stykem s bankou a s nastavením bw.ini - viz vývěska
Ing. Olga Smitková 13.07.01

Viz.také

Popis souboru BW.INI


AD - blokování

AD - blokování
Věci AD rozlišeny barevně dle důvodu blokování:
- modrá: důvodem blokování je úhrada kartou
- červená: důvodem blokování je posudek pro nového majitele
- zelená: důvod blokování neurčen
černá: věci aktuálně neblokované (vzhledem k aktuálnímu datu)
RNDr. Jan Sekyra 25.06.01


AD - blokování - pro kartu je teď 14 dnů

AD - blokování - pro kartu je teď 14 dnů
RNDr. Jan Sekyra 22.06.01


AD - doplnění stromu hlav. procesu

AD - doplnění stromu hlav. procesu
a digramu procesu v činnosti Věci aukčního domu.
RNDr. Jan Sekyra 22.06.01


AD - typy věcí

AD - typy věcí
- do formuláře Typy věcí přidán atribut Typ (grafika,obraz....)
- Věci AD: při přechodu na nový řádek v mřížce, po zadání typu a po návratu z nabídky nad typem věci se provádí aktulizace překryvného seznamu s názvy typů věcí tak, že se nabízí pouze typy věcí aktuálního typu. Aktualizace se provádí pouze při změně hodnoty typu.
RNDr. Jan Sekyra 22.06.01


Dynamická aktualizace překryv. seznamu

Dynamická aktualizace překryv. seznamu
viz. dokument
RNDr. Jan Sekyra 22.06.01


Import / Export / Update dat

Import / Export / Update dat
V nové verzi BM je možné v importech/updatech používat podprogram BW_EREAD, který konvertuje data z MS-Excel.
Je vyvoláván s parametry:
1/ Alias cursoru, který bude převodem vytvořen
2/ Název konfiguračního souboru
3/ Název list MS-Excelu

V konfiguračním souboru je uložena struktura vytvářeného kursoru a informace, ve kterých sloupcích se nacházejí odpovídající hodnoty v syntaxi:
;.
je v syntaxi Foxpro.
Např.:
sp60id c(13);1
au01cnaksm n(20,4);10
au01cprosm n(20,4);9
au01cvyvol n(20,4);8
au01procen n(2);7

Podprogram se po svém vyvolání zeptá na jméno souboru Excelu, z jehož listu daném parametrem čte data od druhého řádku do řádku, který obsahuje v prvém sloupci prázdnou hodnotu.

Příklad volání:
DO bw_eread WITH 'Data','update.cfg','Inventura'
Ing. Petr Filip 27.06.01


Jak nastavit pevný kurz na celý měsíc

Jak nastavit pevný kurz na celý měsíc
V činnosti "Parametry oceňování" se nastaví OBĚ zaškrtávátka (Předplňovat kurz pouze je-li aktuální, Automatická aktualizace kurzu) na NEZAŠKRTNUTO.

V činnosti "Měny a kurzy" nastavit kurzy dopředu, např. 1.5.2001 18,-
1.6.2001 19,-
1.7.2001 20,-
....

V událostech obchodu se pak předplní kurz dle datumu splatnosti té události.
Ing. Olga Smitková 15.06.01


O výrobě panu Pavoučkovi

O výrobě panu Pavoučkovi
viz.dokument
Ing. Petr Filip 13.06.01


Parametry oceňování a kurz

Parametry oceňování a kurz
V činnosti Parametry oceňování jsou dvě zaškrtávátka.

a) "Předplňovat kurz pouze je-li aktuální"
Z helpu plyne :
Pokud je tato volba zaškrtnuta, dojde u položek kurzu (obchod..) k předplnění aktuálním kurzem. Pokud kurz aktuální není, musí se doplnit ručně.

Upřesnění :
Aktuálním kurzem se rozumí v případě komponenty PLA kurz se stejným datumem jako datum na PLA (nikoli datum splatnosti).
Aktuálním kurzem se rozumí v případě komponenty OBC kurz se stejným datumem jako datum dodání na OBC (nikoli datum splatnosti).

JE-LI zaškrtnuto, pak se kurz předplní POUZE v případě, že se datumem (viz výše) "trefím" do datumu kurzu.

NENÍ-LI zaškrtnuto, pak se kurz předplní VŽDY a to ten, ktery logicky patří k zadanému datumu.

b) "Automatická aktualizace kurzu"
Z helpu plyne:
Pokud je tato volba zaškrtnuta, zadá-li se kurz, je automaticky aktualizován v číselníku měn a kurzů (jen, pokud ještě pro daný den neexistuje).

Upřesnění :
Daný den je buď datum na PLA nebo datum splatnosti na OBC.
Ing. Olga Smitková 15.06.01


Platby - Karty pohledávek

Platby - Karty pohledávek
Z činnosti Události plateb šlo přes Volby vyvolat Karty pohledávek.

Nyní jde totéž přes klávesy Ctrl+K.
Ing. Olga Smitková 14.06.01


Procesní importy - oprava chyby

Procesní importy - oprava chyby
Chyba se projevovala nenaplněním událostí operace při rozpadu procesním importem na více procesů.
Mohla se projevit v případě, že :
1/ rozpadem vzniklo více než 20 procesů spouštěných na pozadí a běh některého z nich byl přerušen pro chybu vstupu
2/ rozpadem vzniklo více než 20 procesů spouštěných na pozadí a podle diagramu některého z nich následoval vstup operace, která nebyla spuštěna na pozadí
3/ rozpadem vzniklo více než 20 procesů nespouštěných na pozadí
Při této chybě se vždy ztrácely záznamy, které patřily poslednímu procesu vzniklému rozpadem podle importovaných dat.
Ing. Petr Filip 07.06.01


Rodné číslo v adresáři

Rodné číslo v adresáři
Přidána validace na výskyt rodného čísla - obdobně jako u IČA.

Parametrem nastaveno zda chci validovat rodné číslo (zda se vyskytuje totéž v jiného adresáta).

Testováno na datech kopie BM.
Ing. Olga Smitková 22.06.01


Spravovaný majetek - sumy

Spravovaný majetek - sumy
Dopracována činnost Ctrl+S nad spravovaným majetkem.
Sčítá sm02cenaj.
TISK zde již také funguje.
Ing. Olga Smitková 05.06.01


Událost o věci v AD

Událost o věci v AD
- do tabulky AUUDALOS doplněny atributy au02zpuhr2, au02zpuhr3, au02cdosa1, au02cdosa2, au02cdosa3, au02vs2, au02vs3
- přidané atributy doplněny do formuláře činnosti Události v aukčním domě
- atribut au02cdosa1 se předplňuje cenou dosaženou
- validace na atributu au02cdosa3: součet dílčích cen = cena dosažená
- nové atributy dány k dispozici pro transformace a pro tisk
RNDr. Jan Sekyra 21.06.01


Kód po ukončení operace

Kód po ukončení operace
Doplnění objektu KU_DATA DOC_SHOW
Ing. Petr Filip 31.05.01


MZDY - nová položka

MZDY - nová položka
Do položek mezd přibyla položka N51000 - Jiná nepřítomnost a N50000 - Jiná nepřítomnost v prac. dnech. Činnost "DEFINICE - POLOŽKY MEZD - Dávky nemocenského pojištění" je dočasně uvolněna i pro vkládání. (Auditoři, Fragment i my si musíme tyto dvě položky vložit). Položky jsou též součástí první instalace.

Využije se v souvislosti s tiskem hlášení na sociálku a s nepřítomností pro nemoc typu jiná.

Jestliže v "nepřítomnosti pro nemoc" zadám typ jiná, pak při následném spuštění výpočtu mezd se součástí výplatního lístku stanou jedna (malá organizace) nebo obě (velká organizace) výše zmiňované položky.

U nás je třeba "jiná" přejmenovat na "rodičovský příspěvek".

Otázka - nevím, jak zacházejí s rodičovským příspěvkem u velkých organizací - kdo ho proplácí?
Ing. Olga Smitková 04.05.01


Mzdy - šablona MZ0096

Mzdy - šablona MZ0096
 Šablona "Mzdy - podrobně OST" (MZ0096)
Šablona zapisuje údaje z mezd podrobně, tj. za každého pracovníka zvlášť a za každou mzdovou položku zvlášť. Zapisuje POUZE údaje ostatní (mají označení OST) a na Druzích událostí mají nastaveno Ostatní "Ano". Šablona zapisuje pouze stranu Dal. Šablona nezapisuje selektory. Pokud zapisuje mzdovou položku typu srážky, vezme adresáta z Karty pracovníka.
Ing. Olga Smitková 25.05.01


Mzdy - umístění

Mzdy - umístění
viz provázaná vývěska - bod 3)

Do činností "Úkolové listy" a "Události mezd" bylo přidáno umístění mezd. Přidáno bylo též do výběrů.

Umístění mezd váže na přístupová práva.

Testována na datech frag7.
Ing. Olga Smitková 09.05.01


Odpisovaný majetek - doplnění výběru

Odpisovaný majetek - doplnění výběru
Doplněn výběrový atribut "K datu":
- vyřazené k datu - vyberou se všechny s datem vyřazení stejným nebo před zadaným datem
- nevyřazené k datu - vyberou se všechny s datem vyřazení neuvedeným nebo pozdějším než zadané datum
RNDr. Jan Sekyra 15.05.01


Odpisovaný majetek - prognózování odpisů

Odpisovaný majetek - prognózování odpisů
Dočasně skryty atributy Zůstatková cena účetních odpisů a Zůstatková cena daňových odpisů
RNDr. Jan Sekyra 15.05.01


Odpisy a opravné položky pohledávek

Odpisy a opravné položky pohledávek
Karta odpisu - opravné položky byla doplněna o atribut Aktuální/Neaktuální.
Neaktuální karty nejsou zahrnuty do výstupů šablon výpočtu odpisu/opravné položky.
Ing. Petr Filip 22.05.01


Předlohy výstupu

Předlohy výstupu
Doplnění jazyka o nový příkaz .MAIL_BM_FILE a nové hodnoty příkazu .MAIL_SEND (nyní [0/1/2/3])
Ing. Petr Filip 31.05.01


Sestavy - součtové výrazy

Sestavy - součtové výrazy
Příklad : Chci tisknout přehled plateb VČETNĚ informací o jejich úhradách. Na konci sestavy chci mít SOUČET všech částek z plateb (pl02czm).

Řešení chybné:
Pokud součet řeším jen jako sum(pl02czm), pak to není součet plateb, ale platby se "namnožily" podle počtu úhrad. (Tj. Má-li platba na 10 000,- DVĚ úhrady, do součtu se započítá 10 000,- * 2=20 000,-)

Řešení správné:
- Do sestavy nadefinuji proměnnou (např. _xxx), která má hodnotu proměnné _xxx (tj. sama sebe).
- Udělám skupinu přes platby (pl02)
- Na záhlaví skupiny spustím dvojklikem "záhlaví skupiny", kde nastavím "spuštění výrazu při vstupu" takto: bw_prika('_xxx=_xxx+SQL_TISK.PLUDA_pl02czm')

Tímto způsobem se každá platba načte jen jednou.
Ing. Olga Smitková 18.05.01


Spojení s bankou

Spojení s bankou
ve formátu KB best již ve Fragmentu funguje (od 24.5.2001).

viz otec
Ing. Olga Smitková 25.05.01


A dům (1) - doplnit výběr věcí

A dům (1) - doplnit výběr věcí
dle režimu prodeje a souběhu.
RNDr. Jan Sekyra 25.04.01


A dům (2) - vyřešit způsob aktualizace

A dům (2) - vyřešit způsob aktualizace
způsobu prodeje věci (za účelem dohledání věci).
RNDr. Jan Sekyra 25.04.01


A dům - číslování smluv

A dům - číslování smluv
K druhu věci přidán atribut vstupní maska č. smlouvy.
Při pořizování smlouvy se provádí kontrola identifikace smlouvy na masku, pokud je uvedena v druhu věci pro druh aktuální operace.
RNDr. Jan Sekyra 19.04.01


A dům - validace věci a akce - návrh

A dům - validace věci a akce - návrh
řešení
RNDr. Jan Sekyra 24.04.01


Karta pracovníka

Karta pracovníka
Z Karty pracovníka lze vyvolat činnost "Cyklus při vstupu nového pracovníka" klávesou F7 nebo z menu Volby.

Činnost postupně spouští všechny povinné činnosti, které je nutné vyplnit.

Jsou to :
- Další informace
- Charakter pracovníka v p.p.
- Pravidelné příjmy
- Osobní údaje

Testováno na datech AD - oba pracovní poměry.
Ing. Olga Smitková 10.04.01


MZDY - výpočet jednoho výplatního

MZDY - výpočet jednoho výplatního
lístku - chyba ve výpočtu části pravidelné příjmy - dny, hodiny, peníze

Opraveno
Testováno na datech Fr.
Ing. Olga Smitková 06.04.01


Obecná komponenta

Obecná komponenta
na umístění OK se vztahují přístupová práva.
Ing. Petr Filip 09.04.01


Podněty A dům byly vyřešeny

Podněty A dům byly vyřešeny
V procesu napojené podněty byly vyřešeny
Ing. Petr Filip 25.04.01


Replikace artiklů

Replikace artiklů
Od nové verze programu je možné v uživatelských triggerech používat volání replikace artiklu.

Galaxie generuje uložené procedury databázového serveru pro vybrané artikly komponent, které slouží k replikaci artiklu.
Název procedury má tvar "Replikace_artiklu XXXXXX", kde XXXXXX je název tabulky artiklu.
Tj.:
OBARTIKL - obchodovatelný artikl
MTARTIKL - skladovaný artikl
SMMAJ - spravovaný majetek
OKARTIKL - artikl obecné komponenty
NKPREDPR - předmět projektu
BIART - artikl bibliografie
Název procedure určuje odkud má být replikováno.

Parametry procedury jsou:
1. identifikace druhu artiklu
2. druh artiklu
3. uvádí se u artiklů jejichž primární klíč má třetí atribut (pro NKPREDPR nk01verze, pro SMMAJ sm01por)
4. název tabulky, ve které má být artikl založen

Např.:
Založení artiklu v tabulce MTARTIKL podle artiklu v tabulce OBARTIKL.
CALL BM_SERVIS."Replikace_artiklu OBARTIKL"(new_name.sp60id,new_name.sp61id,'MTARTIKL')
Založení artiklu v tabulce OBARTIKL podle artiklu v tabulce NKPREDPR.
CALL BM_SERVIS."Replikace_artiklu NKPREDPR"(new_name.sp60id,new_name.sp61id,new_name.nk01verze,'MTARTIKL')

Příklad využití v komponentě "Projektové řízení" v implementaci Fragmentu, kdy se uživatelskými triggery k předmětu projektu založí obchodovatelný artikl, teprve když je schválen. K odpovídajícímu obchodovatelnému artiklu se potom založí skladovaný artikl v okamžiku vystavení objednávky do tiskárny.
Odpovídající druh artiklu přitom nesmí mít nastaven "Výskyt druhu artiklu".
Ing. Petr Filip 12.04.01


Šablona do obchodu

Šablona do obchodu
Programovatelná šablona "převod mezi sklady", ale bez validace množství na skladě.

"Převod mezi sklady - start bez validace"
"Převod mezi sklady - cíl bez validace"
Ing. Olga Smitková 04.04.01


Transformace do předběžně ukončené

Transformace do předběžně ukončené
operace.
Od nové verze BM automaticky nedochází k opakované transformaci při spuštění operace, která byla ukončena předběžně.
Původní chování je možné obnovit nastavením parametru "trans_do_predb_ukoncenych=1" v sekci "Preferences" souboru BW.INI.
Ing. Petr Filip 10.04.01


AD - poznámky

AD - poznámky
viz. dokument
RNDr. Jan Sekyra 28.03.01


AUKČNÍ DŮM - chyby a jejich opravy

AUKČNÍ DŮM - chyby a jejich opravy
Vyplacení věcí z akce:
- pravá myš na náv. Adresát - chyba Alias ADADSAT is not
found - opraveno
- v seznamu komitentů se zobrazuje adresát v akci tolikrát, kolik má uvedeno spojení - opraveno - vazbou adresáta na implicitní spojení
stejná chyba na záložce Pohledávky, label Věc - opraveno

Smlouvy aukčního domu:
- záložka Věci - pravá myš na Věc - chyba Proměnná sp61id nebyla nalezena - opraveno
- záložka Pohledávky - táž chyba - opraveno

Nefunkční nabídka kl. F2 v těchto činnostech:
* Smlouvy aukčního domu
- zál. Pohledávky - atr. Věc - opraveno
* Pohledávky v aukčním domě
- atr. selektorů, druh operace, druh procesu - opraveno
* Věci aukčního domu - opraveno
- zál. Pohledávky - atr. obch. a org. selektorů
- zál. výběr - atr. Akce prodeje, atr. Aktuální uložení, jméno autora - zkomolený popis
* Vyplacení věcí z akce - opraveno
- zál výběr - atr. adresát
* Parametry věcí - opraveno
- atr. cen. sk. - Cena prodejní
- atr. Měna, atr. MJ
* Importy pro vyplacení
- Poznámka tučně
* Akce
- po F2 na spojení adresáta - chyba Expression is invalid. Use a valid Expression for DYNAMICFORECOLOR property.
Tato chyba se objevuje i v událostech komponent po F2 na spojení adresáta.

RNDr. Jan Sekyra 12.03.01


AUKČNÍ DŮM - oprava chyb

AUKČNÍ DŮM - oprava chyb
1) V operaci běžného prodeje v procesu prodeje na prodejně jsou skryty některé atributy (a není přístupná záložka O věci), které jsou ale vidět na sumárním formuláři vyvolaném ^S.
Stav: opraveno
2) Činnost Vyplacení věcí z akce, záložka Pohledávky, pravá myš na náv. Věc, čin. Události v aukčním domě - chybně se předplní artikl na výb. záložce;
táž chyba v čin. Smlouvy AD, záložka Pohledávky
Stav: opraveno
RNDr. Jan Sekyra 27.03.01


AUKČNÍ DŮM - vytvoření výstupů

AUKČNÍ DŮM - vytvoření výstupů
+ PPD a VPD - varianty bez položek a s položkami - nad procesy dle tiskopisů.
RNDr. Jan Sekyra 26.03.01


Doplnění pohledu transformace

Doplnění pohledu transformace
rozšiřuje možnosti transformací mezi operacemi v procesech.
Podobně jako u tiskových předloh je možné doplnit vlastnosti SQL dotazu, který bude užit při transformaci.

V poli "Atributy" je možné zadat atributy, které rozšíří nabídku atributů pro transformaci (zařadí se před FROM).

V poli "Selekt-join" je možné doplnit dotaz o odkaz na další tabulky (zařadí se za FROM).

V poli "Výběr" se zadává doplňující podmínky odvislé od obsahu "Selekt-join" (zařadí se za WHERE) nebo může obsahovat případný ORDER.

Atribut "Slučování" (Ano/Ne) určuje, zda má být výsledný pohled složen s definicí pohledu transformace dodaného s BM.

Atribut "Fetchmemo" (Ano/Ne) by měl být nastaven na "Ano" v případě, že připojený atribut z další tabulky je charakteru text (memo).

V definicích je možné uvádět makra:
%%% - bude nahrazeno identifikací vlastníka tabulky (BM_SERVIS)
$$$ - bude nahrazeno aliasem tabulky událostí odpovídající komponenty (OUT_VIEW)

Spojení na další tabulky je možné v relaci 1:1 nebo v relaci 0:1. Při spojení v relaci 1:1 musí definice v poli "Selekt-join" začínat čárkou. Při spojení v relaci 0:1 se používá klausule LEFT OUTER JOIN.
Např. přidání externího čísla procesu mezi atributy pro transformaci:
1/ v relaci 1:1
v poli "Atributy" - SPPRC2.sp33extcis
v poli "Selekt-join" - , %%%.SPPRC SPPRC2
v poli "Výběr" - SPPRC2.sp33cisdr=$$$.sp33cisdr AND SPPRC2.sp33cisdpm=$$$.sp33cisdpm AND
SPPRC2.sp33cisd=$$$.sp33cisd
"Fetchmemo" - může být Ne, protože atribut sp33extcis nemá charakter memo.
2/ v relaci 0:1
v poli "Atributy" - SPPRC2.sp33extcis
v poli "Selekt-join" - LEFT OUTER JOIN %%%.SPPRC SPPRC2
ON SPPRC2.sp33cisdr=$$$.sp33cisdr AND SPPRC2.sp33cisdpm=$$$.sp33cisdpm AND
SPPRC2.sp33cisd=$$$.sp33cisd
v poli "Výběr" - nic
"Fetchmemo" - může být Ne, protože atribut sp33extcis nemá charakter memo.

Ve výrazech transformací, které využívají atributy tabulek napojených v relaci 0:1, je třeba pamatovat na to, že tyto atributy mohou nabývat hodnoty NULL.
Je-li v datovém modelu BM zahrnuta mezi danými tabulkami relace 1:1 je lépe používat možnost 1 (je optimálnější). Při doplňování atributů volných karet k dotazu je nutné použít variantu 2.

Spojení transformace s "doplněním pohledu transformace" se provádí v definici transformace a zde je také možné vyvolat přechod k jejich zadávání (klávesou F2).
Výsledný tvar dotazu je možné zobrazit v této činnosti klávesou F6 nebo je možné ladit výsledný dotaz (klávesou F5).

Dotaz odpovídajícího doplnění je možné také použít v kódu po ukončení operace v klauzuli DECLARE. Syntaxe byla doplněna o možnost uvedení identifikace doplnění za znakem '/'.
Např.: DECLARE extc=SELECT('OBC-pobj/EXTCIS',sp33extcis)

Objekt KU_DATA nebyl zatím o možnost použití doplněného pohledu transformace rozšířen.
Ing. Petr Filip 15.03.01


Import / Export dat

Import / Export dat
V definice importu/exportu byla rozšířena o možnost typ Update.
Pro tento typ se definuje v "Konverze atributů" parametr "Klíč pro Update".
Takto definovaný import/export/update nepřidává ani neexportuje záznamy, nýbrž mění obsah dat aktuálně zobrazených záznamů.
Přitom vyhledává mezi zobrazenými záznamy ty, které mají stejnou hodnotu v atributech uvedených v seznamu "Klíč pro Update".
Pokud je prováděn update na první záložce formuláře, potom jsou změněné záznamy v hlavní mřížce formuláře zobrazeny se šedivým podkladem.
Bezprostředně po update data nejsou zapsána, zápis provádí uživatel běžným způsobem jako by změny dat provedl sám (tj. disketou nebo odpovědí "Ano" po escape).
Ing. Petr Filip 27.03.01


Mzdové listy

Mzdové listy
opravena chyba ve výpočtu mzdových listů (pokud je řádek mzdového listu definován pomocí jiného řádku, nerozlišovala jsem o jaký pracovní poměr se jedná) - nyní se striktně hlídá číslo pracovního poměru.

Z toho plyne vlastnost mzdových listů - má-li pracovník více pracovních poměrů, má též VÍCE mzdových listů.

Nepřehlednost mzdových listů plyne z charakteru výplatního lístku pracovníka, který má více než jeden pracovní poměr - některé údaje jsou totiž POUZE na jednom pracovním poměru.

Řešením by byla sestava, která vytiskne součtový mzdový list za oba pracovní poměry - budou v ní ale chybět údaje o jednotlivých pracovních poměrech z karty. Při tisku mzdových listů za každý pracovní poměr zvlášť mám sice údaje v hlavičce kompletní, ale údaje o dnech, hodinách a penězích je třeba SEČÍST !!!!!!!!

Testováno na datech AD audit.
Ing. Olga Smitková 14.03.01


MZDY -pracovník nepracoval, ale byl

MZDY -pracovník nepracoval, ale byl
nemocný a srážka ze mzdy se mu neprovedla.

Odpověď: Testovala jsem situaci na pracovnici 00405 - pí Hansíkové. Dala jsem jí nemoc od 1.2.2001 do 28.2.2001. Pravidlené příjmy se neprojevily, nemoc se projevila a z ní se ODEČETLA srážka. Tj. vše jak má být.

Testováno na verzi AD auditorů - problém se neprojevil.
Ing. Olga Smitková 01.03.01


Mzdy - nová šablona

Mzdy - nová šablona
Šablona "Mzdy - UC podrobně a částečně rozděleně" (MZ0103)

Tuto šablonu budeme (od mezd 03/20001) používat v BM Servisu.
Šablona zapisuje údaje z mezd podrobně, tj. každého pracovníka zvlášť a každou mzdovou položku zvlášť. Zapisuje POUZE údaje potřebné do účetnictví (mají označení UC). Šablona zapisuje stranu MD i Dal. Šablona zapisuje selektory.
Mzdové položky typu "příjmy a náhrady" šablona zapisuje tak, jak je uvedeno na výplatním lístku i s příslušnými selektory.
Mzdové položky - hrubý příjem, odvod SP organizace, odvod ZP organizace - se rozpočítávají dle poměru trojice selektorů u příjmů daného pracovníka. Šablona zapisuje všechny selektory.
Mzdové položky ostatních typů šablona zapisuje tak, jak je uvedeno na výplatním lístku.
Tato šablona je tedy kombinací šablon "Mzdy - podrobně ST" a "Mzdy - UC podrobně".

Ing. Olga Smitková 23.03.01


Mzdy - uzávěrka

Mzdy - uzávěrka
Chyba ve výpočtu průměru na nemocenskou.

Správný postup :
dnů = suma kalendářních dnů v uzavíraném čtvrtletí (trvání pracovního poměru) snížená o dny nepřítomnosti s náhradou mzdy a dnů nemoci, ošetřování a pomoci v mateřství, výkon služby v ozbrojených silách a výkon civilní náhradní služby.

Chybně se nezapočítávalo : dnů nemoci, ošetřování a pomoci v mateřství.

Testováno - data Ad audit
Ing. Olga Smitková 26.03.01


Mzdy - výstup do plateb

Mzdy - výstup do plateb
opravena šablona MZ0082 - do plateb souhrn.

Oprava byla se smyslu možnosti použít na Kartě pracovníka VÍCE různých charakterů.

Testováno na datech AD audit. Testovány srážky, půjčky, příjmy, odvody SP, odvody ZP, daně, přeplatky na dani
Ing. Olga Smitková 09.03.01


MZDY - výstup do statistiky

MZDY - výstup do statistiky
opraveno - rozpočítávání vystupujících položek probíhá nyní dle VŠECH tří selektorů , nejen dle TV selektoru.

Testováno na kopii BM
Ing. Olga Smitková 12.03.01


Platby - pl02czmnez

Platby - pl02czmnez
Do outview přidán atribut pl002czmnez - pro transformace.

Přidány též atributy identifikace procesu - sp33....
Upraveny popisy u některých položek.
Přidány též atributy identifikace nadřazeného procesu - sp33cisdro, sp33cispo, sp33cisdo.

Testováno na datech AD audit
Ing. Olga Smitková 09.03.01


Počet odkazů na záznam

Počet odkazů na záznam
je nový funkce v menu "Obecné".
Zobrazí aktuální počet odkazů na záznam zobrazený v hlavní mřížce aktivního formuláře.
Zobrazený seznam vychází z pravidel referenční integrity v databázi.
Ing. Petr Filip 19.03.01


Předlohy výstupu

Předlohy výstupu
V předlohách výstupu je možné použít proměnnou TOOL.BW01EMAIL.
V této proměnné je uložena adresa e-mail aktuálně přihlášeného uživatele (podle odpovídajícího atributu ze seznamu uživatelů systému).
Ing. Petr Filip 27.03.01


Předlohy výstupu

Předlohy výstupu
Při opravě tiskové předlohy výstupu nebo při jejím prohlížení na obrazovce se nově skrývá menu aktivních oken.
Ing. Petr Filip 09.03.01


Předlohy výstupu

Předlohy výstupu
rozšíření příkazů výstupu do Excelu:
1/ příkaz EXCEL_OTEVŘI může mít ve svém druhém parametru uvedenu Excelovskou šablonu (soubor s příponou XLT) - to umožňuje vytvářet výstupy shodného formátu jako nové šablony a provádět výstupy různých předloh do jednoho souboru (zajímavé použití ve spojení s přikazem CALL)
2/ příkaz CALL může mít další tři libovolné parametry, jejichž hodnoty jsou dostupné ve volané předloze v syntaxi this.param1,this.param2 a this.param3 (využití je možné pro přenos názvu souboru nebo názvu listu)

Byl zaveden nový příkaz EXCEL_NOVÝ_LIST, který má podobnou funkci jako příkaz EXCEL_LIST s tím rozdílem, že pokud již v souboru Excelu existuje list se stejným názvem, bude tento list zrušen před založením listu (určeno pro odstranění nežádoucího formátování předchozího výstupu).
Ing. Petr Filip 20.03.01


Rezervované zdroje systému

Rezervované zdroje systému
Doplnění funkčnosti činností při jejichž běhu je vhodné, aby nedocházelo ke změnám dat.
V této chvíli se jedná o výpočty výkazů a přepočty hodnot statistiky.
Tyto činnosti rezervují nebo mohou rezervovat zdroje.
Rezervace může být sdílená nebo výhradní.
Činnost "Přepočet obratové tabulky účetnictví" rezervuje vždy výhradně zdroj s identifikací UCE (komponenta účetnictví).
Před "Přepočtem statistických hodnot" uživatel rozhoduje, zda mají být rezervovány zdroje (komponenty).
V nových výkazech je možné definovat pro každý jednotlivý list, které komponenty (zdroje) mají být rezervovány (příkazem LOCK v parametru dodatečné deklarace).
Je-li v době zápisu události komponenty rezervován zdroj, jehož identifikace odpovídá identifikaci komponenty, není zápis povolen.
Při testu přístupu ke zdroji BM zjišťuje, zda záznam o rezervaci zapsal klient, který je aktuálně připojen k datovému serveru. Protože časová prodleva, po které datový server pozná, že klient umřel, může být delší, je v podmenu SYSTÉM programu k dispozici činnost "Rezervované zdroje systému".
V ní je možné zrušit záznam o rezervaci klávesou F8.

Rezervaci zdrojů systému je možné vyřadit uvedení parametru "rezervovat_zdroje=0" v sekci "Preferences" souboru BW.INI.
Ing. Petr Filip 09.03.01


Roční zúčtování mezd

Roční zúčtování mezd
Vyjádření : V systému Bílý motýl se toto neprojeví, protože tam operuji pouze s položkou "Základ zálohové daně","Zálohová daň","nezdanitelné položky roční","Loňský odvod - daň - příjem".

"Úhrn příjmů ze závislé činnosti a funkčních požitků" a "Pojistné" se projeví pouze v tiskové sestavě.
Ing. Olga Smitková 26.03.01


Spouštění spojení z jednotlivých

Spouštění spojení z jednotlivých
událostí přes klávesu F2 opraveno v komponentách OBC, PLA, DPH.
Ing. Olga Smitková 16.03.01


Šablony

Šablony
Je možné nově vytvořit šablonu pro kopii události, na které je program nastaven v okamžiku volání šablony, nastavením "Vstupu šablony" na "Kopie události".
Ing. Petr Filip 22.03.01


Výběr ve vlastnostech činnosti

Výběr ve vlastnostech činnosti
hlavního menu programu.
U parametrů typu překryvný seznam se nabízejí možnosti podle cizojazyčného překladu.
(pozn. je třeba přegenerovat činnosti, zejména události)
Ing. Petr Filip 22.03.01


Zablokovat systém BM

Zablokovat systém BM
je nová funkce v menu "Obecné" formuláře a menu "Volby" hlavního menu programu.
Funkce skryje všechna okna BM a zobrazí formulář pro vstup jména a hesla. Při zadání jména a hesla uživatele, který se systémem pracoval se skrytá okna znovu zobrazí.
Zadat je také možné zadat jméno a heslo správce systému nebo jméno a heslo uživatele, který má nastaveno "Právo odblokovat" (nová vlastnost uživatele v činnosti "Uživatelé programu").
O tom, že program odblokoval někdo jiný a měl tedy možný přístup k jeho datům pod jeho identifikací, je systémem odeslána uživatelovi zpráva BM.
Ing. Petr Filip 19.03.01


Chyby tisku - ODPISY, SM

Chyby tisku - ODPISY, SM
Oprava chyb hlášených serverem před tiskem v činnostech Spravovaný majetek a Odpisovaný majetek.
RNDr. Jan Sekyra 16.02.01


Jak doplnit hodnoty obecného výběru

Jak doplnit hodnoty obecného výběru
do předlohy výstupu.
Hodnoty zadané v obecném výběru je možné zobrazit v předloze výstupu výrazem:
this.otec.obec_vyber.p[],
kde pořadí je pořadové číslo proměnné výběru.
Je vhodné tak, aby předloha fungovala také bez obecného výběru, otestovat typ hodnoty výrazu např.: pro hodnotu obecného výběru typu datum:
IIF(TYPE('this.otec.obec_vyber.p[1]')='D',this.otec.obec_vyber.p[1],{})
Ing. Petr Filip 14.02.01


Kód po ukončení operace

Kód po ukončení operace
Objekt KU_DATA obsahuje novou metodu 'OP_PRINT' určenou pro výstup operace nebo procesu podle předlohy.
Viz. dokument
Ing. Petr Filip 02.02.01


Kód po ukončení operace

Kód po ukončení operace
Zaveden nový objekt KU_MAIL pro odesílání MAIL.
Viz. dokument
Ing. Petr Filip 02.02.01


Kód po ukončení operace

Kód po ukončení operace
metoda OP_EXEC objektu třídy KU_DATA umožňuje aktivovat operaci v nadřazeném procesu.
Ing. Petr Filip 20.02.01


MAIL a předlohy výstupu

MAIL a předlohy výstupu
Předlohy výstupu do Excel a HTML umožňují ve svém kódu definovat odeslání MAILu po vytvoření výstupu.
Viz. doplněný dokument popisu jazyka generátoru sestav.

Pro odeslání mail z události vývěsky byla vytvořena předloha 'Odeslat mail' typu 'Ostatní', která je definována
.MAIL_FILE ''
.MAIL_RECIPADRESS '*'+$(Vyudalos_ad01id)
.MAIL_SUBJECT $(Sptyp_sp07text)
.MAIL_MESSAGETEXT $(Vyudalos_vy01text)+CHR(13)+(Vyudalos_vy01koment)
.MAIL_SEND 1

Ing. Petr Filip 02.02.01


Multiverze a Bílý motýl

Multiverze a Bílý motýl
V souboru BW.INI určit výběr datového zdroje, který má být užit při spuštění programu.
Zadává se v sekci 'Preferences' parametry Multi_Datasource<číslo>=;
Např.:
[Preferences]
Multi_Datasource1=zdroj1 ; Firma 1.zákazníka
Multi_Datasource2=zdroj2 ; Firma 2.zákazníka
Multi_Datasource3=zdroj3 ; Firma 3.zákazníka

Při spuštění programu uživatel vybírá datový zdroj, se kterým má program pracovat. Popis uvedený v druhé části parametru za středníkem se stane popisem hlavních oken programu.
Ing. Petr Filip 07.02.01


MZDY - osobní údaje

MZDY - osobní údaje
na Kartu pracovníka - Volby - Osobní údaje byla zabudována možnost evidovat jména a rodná čísla dětí, údaje o invaliditě, údaje o studiu.

Tyto údaje jsou důležité pro tisk sestavy "Potvrzení o zdanitelných příjmech ze závislé činnosti a funkčních požitků a o sražených zálohách na daň za zdańovací období ...".

Jsou k dispozici položky text1, text2, text3, text4, platnost od, platnost do, komentář.
Lze zde také evidovat nějaké další textové údaje.

Testováno : spuštěním činností Karta pracovníka, Osobní údaje, Prohlížení výplatních lístků.
Ing. Olga Smitková 20.02.01


MZDY - technický selektor

MZDY - technický selektor
Došlo k upravení postavení technického selektoru v komponentě mzdy, a to takto:
1. Technický selektor je umístěn na mzdové položce (DEFINICE - POLOŽKY MEZD -Příjmy a náhrady, odvody, ...)
2. Technický selektor je též umístěn na Kartě pracovníka - u jeho pracovního poměru.
3. V činnosti "Parametry" ( v sekci MZDY) je překryvný seznam, který je pravidlem odkud se bude technický selektor natahovat do výplatního lístku a do úkolových listů. Stavy jsou - nenaplňovat, z karty pracovníka, ze mzdové položky.
Ing. Olga Smitková 15.02.01


Obecný výběr saldokonto adresáta

Obecný výběr saldokonto adresáta
nad činností Účetní saldokonto k datu.
RNDr. Jan Sekyra 14.02.01


Odpisovaný majetek

Odpisovaný majetek
Vytvořena funkce pro nápočet předpokládané celkové doby odpisování (v letech) inv. majetku.
Výpočet aktualizuje karty inv. majetku
- odpisovaného
- dosud neodepsaného, tj. nenulová zůstatková cena pro daň. odpisování
- nevyřazeného

Na záložku Daňové odpisy formuláře Odpisovaný majetek zařazen atribut od01pocopr - předpokládaný počet odpisů.
Atribut zařazen mezi atributy k tisku.

RNDr. Jan Sekyra 12.02.01


Předlohy výstupu

Předlohy výstupu
nový příkaz .CALL dovoluje vyvolat z předloh výstupu typu Excel nebo typu Ostatní jinou předlohu výstupu
Ing. Petr Filip 20.02.01


Spojené dokumenty

Spojené dokumenty
V přehledu dokumentů spojených s objektem (vyvolaných klávesou CTRL+D) je možné odesílat vybraný dokument mailem výběrem z menu volbou 'Odeslat dokument' po pravém kliku na daném dokumentu.
V souvislosti s odesíláním je možné nastavit jméno profilu v souboru BW.INI nebo lokálně v BWLCL.INI parametrem 'mail_profile' v sekci 'Preferences' např.:
mail_profile=Nastavení MS Exchange
Ing. Petr Filip 07.02.01


Spravovaný majetek - výběr

Spravovaný majetek - výběr
Doplněn výběr majetku dle data zařazení od - do a data vyřazení od - do.
RNDr. Jan Sekyra 15.02.01


Spuštění programu

Spuštění programu
Oprava chyby při opakovaném spuštění programu.
Při opakovaném spuštění programu nyní vypisuje hlášení o tom, že byl pravděpodobně spuštěn podruhé a dále nepokračuje.
Při jiném neúspěšném spojení s databází již není možné změnit základní přístupové heslo k databázi, pokud není v souboru BW.INI v sekci 'Preferences' uveden parametr 'Edit_Password=1¨.
Ing. Petr Filip 07.02.01


Storno procesu

Storno procesu
Při stornování procesu je prováděna kontrola tak, aby události operací stornujícího procesu nezapisovaly do neotevřeného období příslušné komponenty.
Je možné zadat také jiné datum (JJ: předplní se aktuální datum uživatele) než "dnešní" při stornování k datu.
Ing. Petr Filip 14.02.01


Test generátoru časové identifikace

Test generátoru časové identifikace
Program pro test generátoru jednoznačné časové identifikace.
Viz. dokument.

Ing. Petr Filip 27.02.01


Uživatelské triggery

Uživatelské triggery
- vytvoření uživatelských triggerů pro interní implementaci BM nad volnou kartou procesu - varianta INSERT, UPDATE - stručný popis - testování - import do ostré verze
RNDr. Jan Sekyra 13.02.01


Uživatelské triggery

Uživatelské triggery
V definici uživatelského triggeru přibyl atribut volná karta, pomocí kterého je možné definovat triggery k volným kartám.
Ing. Petr Filip 02.02.01


Základní menu BM

Základní menu BM
je možné ukončit klávesou ALT+F4 bez ohledu na nastavení parametrů uživatele, pokud není právě aktivní formulář některé činnosti.
Ing. Petr Filip 07.02.01


BM - oprav.pol. k pohledávkám

BM - oprav.pol. k pohledávkám
ODTABKOE - od38procen změněno z 5.2 na 6.2
Ing. Olga Smitková 03.01.01


Číslo účtu v bankovním spojení adresáta

Číslo účtu v bankovním spojení adresáta
Validaci čísla bankovního účtu v bankovním spojení adresáta je možné nastavit v činnosti "Banky" nastavením atributu "Kontrola čísla účtu" pro každou jednotlivou banku.
Hodnoty atributu jsou :
1/ Žádná - tj.nebude se provádět kontrola
nebo
2/ Varování modulo 11 - tj. bude se provádět kontrola účtu prodle pravidla "Modulo 11" a při zadání nevyhovujícího čísla je zobrazeno v pravém horním rohu varovné hlášení a záznam bude možné zapsat
nebo
3/ Nepovolit modulo 11 - tj. bude se provádět kontrola účtu prodle pravidla "Modulo 11" a při zadání nevyhovujícího čísla nebude možné záznam zapsat

Tato nastavení se uplatňují při zadávání bankovního spojení v adresáři činnostmi "Adresář" a "Bankovní spojení adresáta" a při uvedení čísla bankovního účtu v události změny stavu peněz.
Ing. Petr Filip 23.01.01


Karta artiklu skladu s výrobním číslem

Karta artiklu skladu s výrobním číslem
V komponentě skladové evidence přibyla činnost "Artikly skladu - VČ".
Zobrazuje přehled karet artiklů vzniklých událostmi s vyplněným výrobním číslem.
Karta artiklu s výrobním číslem vzniká automaticky při založení události skladu charakteru "příjem" se zadaným výrobním číslem, pro které dosud neexistuje pro daný sklad a artikl.
Druhou možností založení karty je vstup uživatelem.
Na kartě je zobrazen datum prvého příjetí artiklu s výrobním číslem na daný sklad a jeho aktuální množství na daném skladě (možnost výběru karet s nenulovým množstvím).
Dále jsou na kartě uživatelsky modifikovatelné položky - datum (při založení karty je naplněn datem přijetí a je možné podle něho třídit) a poznámka.
Další atributy je možné doplnit volnou kartou.
Karta artiklu s výrobním číslem je automaticky zrušena při zrušení odpovídající události, pokud se nevyskytuje mezi událostmi událost identifikující stejný artikl s výrobním číslem.
Podobně při opravě identifikace karty artiklu v události může být původní karta zrušena a založena nová karta.

Kartu artiklu skladu s výrobním číslem je možné vyvolat klávesou F2 při vstupu událostí skladové evidence.
Je určena pro usnadnění rozhodnutí obsluhy, který fyzický artikl má být expedován (např. podle běžící záruční nebo expirační doby)

"Primárním klíčem" karty artiklu s VČ je identifikace artiklu, výrobní číslo a sklad, proto se při jeho převodu mezi sklady zakládá nová karta.

Přístup ke kartám artiklu s VČ je dán právy přístupu k odpovídajícímu skladu.

Naplnění karet v systému je možné činností "Naplnění ..." vyvolané z formuláře "Artikly skladu - VČ" (stačí pouze jednou po instalaci této verze systému, protože dále budou vznikat automaticky)
Ing. Petr Filip 20.01.01


Kód po ukončení operace

Kód po ukončení operace
Změny v možnostech kódu po ukončení operace.
V kódu po ukončení operace je nově možné pracovat s volnou kartou, mírou plnění, sestavit dotaz SQL, získat informace z událostí operací jiného procesu než je proces proces aktuálně ukončované operace.
Viz.dokument.
Ing. Petr Filip 08.01.01


Měrné jednotky

Měrné jednotky
Přibyl atribut entity měrná jednotka v jazycích "Rozšířená identifikace měrné jednotky" (sp58idmj znaková 20) určený pro výstup předlohou.
Pro použití v předlohách výstupu je ho třeba doplnit ve vlastnostech předlohy na záložce doplnění
např.:
(select spmjn.sp58idmj from bm_servis.spmjn where spmjn.sp24idmj=obudal.sp24idmj and spmjn.sp38id=?tool.jazyk) sp58idmj

Dále byl prodloužen název měrné jednotky na 40 znaků a doplněn komentář.
Ing. Petr Filip 29.01.01


Modulo účtu

Modulo účtu
Způsob řešení: vyřešeno zadávání způsobu validace čísla účtu u banky
Ing. Petr Filip 27.01.01


MZDY - daňová tabulka

MZDY - daňová tabulka
Přidána třetí daňová tabulka - pro případy "podepsal prohlášení ne a plat vyšší než limit ".

Úprava provedena i ve Výpočtu výplatních lístků.

Pro rok 2001 :
0 - 27300 0 20%
27301 - 27600 5460 25%
27601 - 999999999 5535 32%
Ing. Olga Smitková 26.01.01


MZDY - nepřítomnosti

MZDY - nepřítomnosti
evidence nepřítomností pro nemoc eviduje i číslo nemoci - byla tam chyba porovnávání velikosti čísla nemoci ve formátu C3 - převedeno na porovnávání numerických čísel nemoci.

Důsledek byl, že nešla zapsat nemoc s číslem 11, protože '9 ' > '11'.

testováno : naše verze
Ing. Olga Smitková 19.01.01


Mzdy - sestava "sociální pojištění

Mzdy - sestava "sociální pojištění
"sociální pojištění - hlášení"

Oprava sestavy - sloupec náhradní doby.
testováno na našich datech pro měsíce 12/2000 a 09/2000.

Pozn.: předpokládám, že sloupec "omluvená absence" obsahuje kal. dny nepřítomností (nemoc, ošetřování a MD) a kal. dny NEPLACENÉHO VOLNA.
Sloupec "náhradní doby" obsahuje totéž MIMO neplaceného volna.
Ing. Olga Smitková 12.01.01


MZDY - uzávěrka

MZDY - uzávěrka
Opraveno -NIKDY SE NESMÍ PROPLÁCET NEMOCI DOPŘEDU

Příklad : Dělám uzávěrku za 11/2000. Dělám jí např. 5.12.2000. V nepřítomnostech mám zaevidováno jako proplatit ANO nemoci z 11/2000, ale už i některé nové z 12/2000. Uzávěrka dosud vzala všechny nepřítomnosti, které mají nastaveno proplatit ANO a vyplnila jim proplaceno dne 30.11.2000. S takovou nepřítomností již nelze manipulovat.

Testováno : na datech Fr. - uzávěrka za 10/2000 - nemoci k proplacení i z 11/2000.
Ing. Olga Smitková 12.01.01


MZDY - výkazy

MZDY - výkazy
pokud počítám znovu výkaz, zadá se rok a číslo pracovníka - tyto staré údaje se smažou a vypočítají se znovu.

Dříve se smazaly VŠECHNY údaje z výkazu a vypočte se znovu celý výkaz nebo část dle údajů rok, pracovník

Testováno na naší verzi a ve Fragmentu (pracovníci 3, 30, 33)
Ing. Olga Smitková 19.01.01


MZDY - zaokrouhlování

MZDY - zaokrouhlování
v Bílém motýlovi.

Oprava dle pokynů od Jirky - viz provázaná vývěska.

Testováno na kopii našeho motýla.
U zákazníků je nutné udělat úpravy tiskových výstupů.
Ing. Olga Smitková 29.01.01


ODPISY - odpisovaný majetek

ODPISY - odpisovaný majetek
Do tisku doplněny fiktivní atributy ODKARTA.od01pocodp a ODKARTA.od01zezvce.
(Atributy nešly doplnit při tvorbě sestavy na záložce "Doplnění").
RNDr. Jan Sekyra 12.01.01


ODPISY - sestavy

ODPISY - sestavy
Stručný inventurní přehled
Podklad k daňovému přiznání
RNDr. Jan Sekyra 12.01.01


ODPISY - změny souvisejicí

ODPISY - změny souvisejicí
s prognózováním odpisů.
1) Na formulář Změny odpisovaného majetku doplněn atribut "finanční částka nesnížená", který je viditelný a přístupný pouze v událostech účetního nebo daňového odpisu.
2) na formuláři Prognózování odpisů přibyla výběrová záložka, kde lze zadat prognózovaný rok a případně i artikl. Zadané hodnoty se použijí pro výpočet prognózy.
3) Odstraněna chyba vypočtení záporné zůstatkové ceny daňového odpisování v případě prognózy na rok, ve kterém již byl proveden účetní odpis.
RNDr. Jan Sekyra 29.01.01


Odvozování roku v čísle procesu

Odvozování roku v čísle procesu
se je-li prvou operací operace komponenty obchod provádí podle data události obchodu.
Nastavením parametru 'datum2=1' v sekci [Komponenta_OBC] souboru BW.INI možné nastavit odvozování roku v čísle nového procesu podle druhého datumu (dodání).

Obsah BW.INI:
.
.
.
[Komponenta_OBC]
datum2=1
.
.
.
Ing. Petr Filip 09.01.01


Operace v procesu

Operace v procesu
Změna datového modelu.
Adresát spojený s operací v procesu byl dříve uložen v entitě "záložka adresáta na operaci v procesu" (SPPRCODZ) v relaci 0:1.
Protože se v praxi ukázalo, že tato relace se blíží k 1:1, byla identifikace adresáta vložena přímo do entity operace (SPPRCOD).
Od nové verze je proto možné měnit adresáta spojeného s operací v přehledu operací.

Obsah entity SPPRCODZ je možné po instalaci systému vymazat.
Ing. Petr Filip 26.01.01


Optimalizace chodu databázového stroje

Optimalizace chodu databázového stroje
Při použití datového serveru Sybase SQL Anywhere verze 7.0.x, vytváří nová verze systému některé primární indexy a indexy cizích klíčů s nastaveným parametrem HASH SIZE větším než 10.
Tuto vlastnost je možné potlačit nebo omezit nastavením parametru "Hash_limit" v sekci "Preferences" souboru BW.INI.
Při uvedení hodnoty menší než 10 budou indexy vytvářeny tak jako doposud (s hodnotou 10).
Uvedení vyšší hodnoty způsobí snížení definovaných hodnot na danou úroveň.
Od této verze byly nastaveny vyšší hodnoty HASH SIZE pro :
1/ primární index procesů (SPPRC) na 15
2/ primární index operací (SPPRCOD) na 24
3/ primární index přístupových práv (SPPRISTU) na 16
4/ a všechny cizí klíče, které se na ně odkazují
5/ primární index aktuálních hodnot obchodu (OBAH) na 30
6/ primární index aktuálních hodnot skladu (MTAH) na 24
7/ primární index obratů skladu (MTOBRAT) na 24
8/ primární index aktuálních obecné komponenty (OKAH) na 26
9/ primární index statistických hodnot (SPSTATIS) na 38

Ve vztahu primárních a odpovídajících cizích klíčů platí, že musí být vytvořeny se stejnou hodnotou HASH SIZE. To může způsobovat problémy při používání volných karet chybami hlášenými datovým serverem při vkládání volné karty nebo rušení záznamu, ke kterému je připojena volná karta. V tom případě přegenerujte strukturu volné karty (V této chvíli se jedná volné karty procesů a operací).
Instalace systému s "reorganizací" obnovuje cizí klíče volných karet.
Ing. Petr Filip 26.01.01


Popis komponenty zálohy

Popis komponenty zálohy
Ing. Blanka Tůmová 11.01.01


Popis uzavření a otevření knih úč.

Popis uzavření a otevření knih úč.
Ing. Blanka Tůmová 09.01.01


Prognózování odpisů - změna kvůli tisku

Prognózování odpisů - změna kvůli tisku
Tabulka pro nápočet je nyní dočasná (TEMPORARY), takže v tisku lze potom použít atributy z tabulek s touto provázaných.
RNDr. Jan Sekyra 15.01.01


Řízení běžícího procesu

Řízení běžícího procesu
Následuje-li po ukončení operace operace, která má být spuštěna na pozadí. Je spuštěna bez ohledu na práva aktuálního uživatele k této operaci (uživatel obdrží vždy přechodné právo "zápis").
Ing. Petr Filip 26.01.01


Sklady - výrob. čísla - popis

Sklady - výrob. čísla - popis
Události skladu v kombinaci s výrobním číslem

- udělám příjem nějakého artiklu a zadám u té události výrobní číslo a počet kusů 1
- stav skladu bude 2 (dřívější) + 1
- teď mohu udělat výdej ze skladu na artikl s tím výrobním číslem, ale program dovolí vydat pouze ten 1 kus
- nebo udělám výdej ze skladu na artikl bez výrobního čísla, pak program dovolí vydat celé 3 kusy

Ing. Olga Smitková 17.01.01


Spojené dokumenty

Spojené dokumenty
V přehledu "Spojené dokumenty" vyvolávané klávesou CTRL+D je nově možné, kromě dokumentů "Objektu", "Operace", "Adresáta", připojovat dokumenty "Procesu"
Ing. Petr Filip 26.01.01


Strom hlavního procesu

Strom hlavního procesu
Oprava chyby, která se objevovala při vyvolání prohlížení tisku ze stromu po zobrazení výstupu hlášením "Spojení je obsazeno".
Chyba se projevovala pouze u instalací s databází Sybase SQL Anywhere verze 5.x.
Ing. Petr Filip 26.01.01


Událost obchodu

Událost obchodu
Při vstupu události obchodu je možné zadávat "Čárový kód" uvedený na kartě artiklu.
Ing. Petr Filip 20.01.01


Událost skladové evidence

Událost skladové evidence
Při vstupu události skladové evidence je možné zadávat "Čárový kód" uvedený na kartě artiklu.
Ing. Petr Filip 20.01.01


Verifikace prognózování odpisů

Verifikace prognózování odpisů
společně s Blankou.
RNDr. Jan Sekyra 30.01.01


VÝROBA - výstupy do Excelu

VÝROBA - výstupy do Excelu
nad činnostmi Výrobní kroky a Vstupy a výstupy výroby.
RNDr. Jan Sekyra 24.01.01


Vyřešené úkoly

Vyřešené úkoly
viz. proces, ve kterém se nachází tato událost
Ing. Petr Filip 02.01.01


Zálohy - chybí CTRL S

Zálohy - chybí CTRL S
Způsob řešení: programování
Řešitel: Honza
Termín realizace: do 4.1.2001
Objem práce: 2 dny
Doplněna funkce Sumy - zálohy v činnosti Události záloh
a funkce Sumy - přehled záloh v činnosti Přehled záloh.
Testováno procesem s operací Přijetí (poskytnutí) zálohy.
Dalším procesem vyúčtování záloh.
Ing. Petr Filip 02.01.01


Zápis z porady

Zápis z porady
Daniela Postlová 23.01.01


Změny datového modelu

Změny datového modelu
nové verze BM.
Pro optimalizaci odezev databázového serveru bylo změněno pořadí atributů primárního klíče identifikace procesu a operace.
Z tohoto důvodu je nutné provést reorganizaci tabulek v databázi (skutečné pořadí sloupců v tabulkách musí odpovídat požadované sekvenci).
Za tímto účelem byly rozšířeny možnosti instalace o volby:
1/ Bez reorganizace databáze
volba pro běžnou instalaci
2/ Částečná reorganizace databáze
reorganizuje ty tabulky, jejichž pořadí sloupců neodpovídá pořadí sloupců v datovém modelu BM. Doporučuje se udělat při instalaci této verze BM
3/ Úplná reorganizace databáze
reorganizace všech tabulek. Je určena k optimalizaci stavu databáze po delším období provozu.

Reorganizace jedné tabulky probíhá algoritmem :
1/ vytvoření tabulky se jménem ve tvaru WRK_+jméno tabulky
2/ převod obsahu původní tabulky do tabulky WRK...
3/ zrušení původní tabulky
4/ přejmenování tabulky WRK... na jméno původní tabulky
5/ vytvoření indexů a cizích klíčů

Kroky 3/ a 4/ nemohou být součástí jedné transakce, proto je možné v případě nouze přejmenovat soubor WRK... ručně v "Sybase SQL Centralu".
V každém případě je nutné před každou instalací nové verze systému udělat úplnou zálohu dat.

Při instalaci systému s "reorganizací", ve kterém jsou nastaveny replikace, je třeba zrušit všechny publikace a znovu vytvořit vzdálené databáze.
Ing. Petr Filip 26.01.01


Dlouhodobé podněty mzdy

Dlouhodobé podněty mzdy
Způsob řešení:
Řešitel:
Termín realizace:
Objem práce:
Ing. Olga Smitková 01.12.00


DPH

DPH
přidán nový atribut dp02uod - uplatnění odvodu daně
- stavy 1,2,3 (100%,0%,kráceno)

Přidán do DPUDA, OBUDAL, DPPRID (řádek daňového přiznání).

Do událostí přidány též výběry.

Na datech ADaudit je NOVÉ daňové přiznání - DANPRI3, ale není celé.
Ing. Olga Smitková 07.12.00


Evidence docházky

Evidence docházky
Provedeny úpravy činnosti úkolové listy a načítání úkolových listů, tak aby šlo pohodlně vkládat informace o docházce jednotlivých pracovníků.

viz dokument - podrobný návod k použití pro Fragment

testováno : data Fragmentu
Ing. Olga Smitková 15.12.00


Mzdy - pořadí uplatnění srážek

Mzdy - pořadí uplatnění srážek
a půjček na kartě pracovníka při výpočtu výplatních lístků.

Na Kartu pracovníka - záložka srážky a záložka půjčky přibyly nové atributy - pořadí. vepíše se sem pořadové číslo uplatnění dané položky při výpočtu výplatního lístku.

Změny provedeny a testovány - karta pracovníka, výpočet jednoho výplatního lístku a výpočet všech výplatních lístků.
Ing. Olga Smitková 21.12.00


Adresář - bankovní spojení

Adresář - bankovní spojení
doplněn tisk k činnosti "Adresář - bankovní spojení"
Ing. Petr Filip 11.11.00


AKM - nebiblio komise, úč.výkaz

AKM - nebiblio komise, úč.výkaz
Způsob řešení: konzultace v AKM a vyřešení
Řešitel: Blanka
Termín realizace:
Objem práce:
Ing. Petr Filip 21.11.00


Aktualizace DPH podle novely

Aktualizace DPH podle novely
Způsob řešení: analýza a programování
Řešitel: Olga, Blanka, Petr
Termín realizace: 8.12.2000
Objem práce: 1
Ing. Petr Filip 21.11.00


Aktualizace helpů

Aktualizace helpů
Způsob řešení: dokumentace
Řešitel: Dana
Termín realizace:
Objem práce:
Ing. Petr Filip 21.11.00


Činnost "Kategorie adresáta"

Činnost "Kategorie adresáta"
Oprava chyby programu - při vyvolání údajů adresáta na záložce "Adresáti v kategorii" z tučného nápisu "Adresát"
Ing. Petr Filip 21.11.00


Druh procesů

Druh procesů
výběr druhů procesů rozšířen o možnost výběru za skupinu
Ing. Petr Filip 11.11.00


Druhý adresát v události pošty

Druhý adresát v události pošty
pro ing.Novosvětského se nebude řešit
Viz. proces
Ing. Petr Filip 21.11.00


Fragment - doladění zaokr. prodejů

Fragment - doladění zaokr. prodejů
Způsob řešení: nastavení procesu
Řešitel: Pavel, Blanka, Olina
Termín realizace: řešení předáno k zákazníkovi k posouzení
Objem práce:

Fragment schválil, předána dokumentace Pavlovi
Ing. Petr Filip 21.11.00


Investiční majetek

Investiční majetek
pro transformaci z investičního majetku a odpisů a opravných položek pohledávek je doplněn název karty
Ing. Petr Filip 11.11.00


Karta opravné položky pohledávky

Karta opravné položky pohledávky
Oprava chyby - výběr - již funguje F2 Adresát
Ing. Petr Filip 11.11.00


Katalogy zboží - OBC

Katalogy zboží - OBC
Na druhou záložku přidána cenová skupina. Je tam navázaný číselník cenových skupin přes F2.

Při použití šablony výstup z katalogu se cenová skupina zapisuje na událost obchodu.

Testováno : na datech Fragmentu
Ing. Olga Smitková 07.11.00


Mzdy - chybné datum účtování

Mzdy - chybné datum účtování
vyřešeno - Tůmová
Ing. Olga Smitková 21.11.00


Mzdy - průměry

Mzdy - průměry
HOTOVO
provedena oprava chyby při výpočtu průměrů

nezapočítávaly se vánoční prémie

položka mz29id - 61
Ing. Olga Smitková 24.11.00


MZDY - události

MZDY - události
opravena chyba, kdy se události mezd a úkolové listy mezd NEZOBRAZOVALY, když jsem vyvolala již spuštěný proces. Muselo se dát znovu načíst.

opraveno, funguje jako u všech ostatních událostí - záznamy se zobrazí ihned
Ing. Olga Smitková 29.11.00


MZDY- nepřítomnost

MZDY- nepřítomnost
do výběru přidána možnost výběru nemocenských dávek-
vše, proplaceno, neproplaceno.

Pozn.: Pokud je nepřítomnost definována pouze na první záložce a dosud nemá vloženu žádnou nem. dávku (druhá záložka), pak se zobrazí pouze výběrem vše, tj. - (pomlčka).
Ing. Olga Smitková 23.11.00


Nastavení parametrů WEB serveru BM

Nastavení parametrů WEB serveru BM
na MS IIS 5.0 tak, aby vše fungovalo - viz.dokument
Ing. Petr Filip 02.11.00


Nová komponenta Zálohy

Nová komponenta Zálohy
je k dispozici v BM.
Viz. dokument.
Ing. Petr Filip 20.11.00


Oprava chyby na vývěsce

Oprava chyby na vývěsce
chyba programu se projevovala při PGUP na poznámce
Ing. Petr Filip 11.11.00


Opraveno napojování objektů

Opraveno napojování objektů
SM v ostré verzi BM opravou dat
Ing. Olga Smitková 13.11.00


Ovládání formulářů

Ovládání formulářů
Doplněna funkce mřížky o možnost setřídit zobrazený seznam podle libovolného sloupce kliknutím na hlavičku s popisem sloupce.
Tuto funkci je možné použít u mřížek jejichž data jsou odvozena od SQL dotazu.
Ing. Petr Filip 11.11.00


Podněty byly vyřešeny

Podněty byly vyřešeny
procesně spojené podněty s tímto záznamem byly vyřešeny
Ing. Petr Filip 21.11.00


Podněty oblast mezd

Podněty oblast mezd
viz. procesně spojené podněty
Způsob řešení: programování
Řešitel: Olga
Termín realizace:
Objem práce:
Ing. Petr Filip 21.11.00


Posílám pozdrav z AKM

Posílám pozdrav z AKM
odezva je velmi pomalá.
Asi bude třeba vyndat obrázky + důkladný mimo proxy
Ing. Petr Filip 22.11.00


Pošta

Pošta
jméno pro štítek se inicializuje "oficiálním" jménem ze spojení je-li uvedeno, jinak se inicializuje jménem "neoficiálním"
Ing. Petr Filip 11.11.00


Pošta - události

Pošta - události
dopněn výběr podle popisu události, názvu adresáta a kategorie adresáta
Ing. Petr Filip 11.11.00


Programové řešení

Programové řešení
Účetní saldokonto - vytvořit obecný výběr za adresáta
PLA - zabudovat parametr - splatnost od dnešního data, nebo od data platby
IMO - na události IMO je okýnko Pořizovací cena (Jaroušek toto okýnko má pro pohledávky) - předplňovat PC i pro odpisovaný majetek pořizovací cenou =cena použitá pro výpočet - šablona (Petr)
ZSP -Možnost definovat, že pokladna nesmí jít do záporu
Způsob řešení: analýza a programování (Olga)
ZSP - Možnost definovat, že pokladna nesmí jít do záporu. (Olga,Petr)
Řešitel: Olga, Petr
Termín realizace: 9.12.2000
Objem práce: 2x1 den
Ing. Petr Filip 21.11.00


Programové řešení - aukční dům

Programové řešení - aukční dům
Programové úpravy podle podnětů procesně spojených
Způsob řešení: programování
Řešitel: Petr, Blanka
Termín realizace:
Objem práce:
Ing. Petr Filip 21.11.00


Prověření závěrek IMO a účetnictví

Prověření závěrek IMO a účetnictví
Způsob řešení: prověření na kopii ostrého BM
Řešitel: Blanka
Termín realizace: 4. - 8.12.2000
Objem práce: 2 dny
Ing. Petr Filip 21.11.00


Při návštěvě

Při návštěvě
doplněny sestavy
1. Hromadný příjmový podkladní doklad s imformací o DPH - denní přehled
2. Přehled denních plateb karet
Ing. Petr Filip 09.11.00


Rozšířený filtr tisku a slovníku dat

Rozšířený filtr tisku a slovníku dat
Ve výrazech je možné použít odkaz do obecných předkonací ve tvaru :
[]
Potom existuje-li překontace dané identifikace, potom bude výraz nahrazen hodnotou předkontace s významem uvedeným pro aktuálního uživatele v seznamu uživatelů (nový atribut uživatele systému).
Není-li hodnota parametru pro odpovídající význam hodnoty uvedena, potom je výraz nahrazen prázdným řetězcem.
Ing. Petr Filip 11.11.00


řešení nepřítomností a FPD

řešení nepřítomností a FPD
Byl vyřešen problém - viz vývěska.

Zaškrtávátko bylo změněno na překryvný seznam se stavy Ano,Ne, implicitně Ano.

Byla stanovena pravidla :
1. Má-li nemoc nastaveno proplatit=Ano, pak se u velké organizace peníze do výplatního lístku zaevidují vždy. Dále se hodnotí, kam spadají datumy Od a Do na danné nemocenské dávce.
a)Jestliže spadají do měsíce, který zpracovávám, pak se pokrátí o tyto pracovní dny i mzdové položky, které se krátí dle FPD (např. měsíční mzda).
b) Jestliže nespadají do měsíce, který zpracovávám, pak se měsíční mzda nekrátí.

2. Má-li nemoc nastaveno proplatit=Ne, pak se u velké organizace do výplatního lístku žádné peníze nezaznamenají. Dále se opět hodnotí, kam spadají datumy Od a Do na danné nemocenské dávce.
a)Jestliže spadají do měsíce, který zpracovávám, pak se pokrátí o tyto pracovní dny i mzdové položky, které se krátí dle FPD (např. měsíční mzda).
b) Jestliže nespadají do měsíce, který zpracovávám, pak se měsíční mzda nekrátí.

Testováno na datech Adaudit - pracovník 00615.
Ing. Olga Smitková 03.11.00


Spojení adresáta

Spojení adresáta
Odstraněna chyba, která se projevovala v této činnosti nezobrazováním spojení nově pořízených adresátů
Ing. Petr Filip 11.11.00


Tisky - výběry

Tisky - výběry
když v tisku ve výběrech - podmínkách tvoříme podmínku, pak se zapíše, pokud do ní vstupuji znovu, nesmím zůstat stát myší na poslední opravované položce (části podmínky)

Pokud myší překliknu na jinou část podmínky, pak se neprojevuje chyba (viz provázaná vývěska) a změna se uchová.
Ing. Olga Smitková 23.11.00


Událost vývěsky

Událost vývěsky
téma se opakuje při vstoupení nového záznamu
Ing. Petr Filip 11.11.00


Údržba systému BM v BM

Údržba systému BM v BM
Odpisy k pohledávkám - opravit slovníkem dat (importováno jako opravná položka), provést rozpuštění vytvořených dle úhrad a zaúčtovat.
Proces zálohových faktur - Jarda
Opravit výkaz rozvaha ve zkráceném rozsahu - účty s možnými zůstatky aktivními nebo pasivními se nezapočítávají na správnou stranu (do pohledávek nebo do závazků)
Obecný výběr nad účetním saldokontem za adresáta

Způsob řešení: implementace
Řešitel: Blanka, Olga
Termín realizace: 4.12.2000
Objem práce: 1
Ing. Petr Filip 21.11.00


Vytvoření dokumentace inf. centra

Vytvoření dokumentace inf. centra
Způsob řešení: dokumentace
Řešitel: Dana
Termín realizace: 15.12.2000
Objem práce: 10
Ing. Petr Filip 21.11.00


Vytvoření katalogu sestav

Vytvoření katalogu sestav
Způsob řešení: v ostrém BM
Řešitel: Dana
Termín realizace: 10.1.2000 první verze s metodikou
Objem práce: 5
Ing. Petr Filip 21.11.00


Vytvoření tiskových výstupů

Vytvoření tiskových výstupů
IMO, spravovaný majetek, peněžní deník pro jednoduché účetnictví, příkaz k úhradě (oprava předlohy), účetní saldokonto
Způsob řešení: analýza, vytvoření sestav ve verzi BM a Fragment
Řešitel: Olga, Blanka, Honza
Termín realizace: 12.,13.,14.12.2000
Objem práce: 3x3 dny
Příkaz k úhradě - opraveno
Ing. Petr Filip 21.11.00


Diagram procesu

Diagram procesu
Oprava pro SYBASE SQL 7 - urychlení SQL dotazu před zobrazením seznamu pro založení nového uzlu.
Zpomalování způsobuje výskyt atributu charakteru text (long var char) v SQL dotazu.
Ing. Petr Filip 03.10.00


Mzdy - důvod ukončení p.p.

Mzdy - důvod ukončení p.p.
Na Kartu pracovníka - Další informace - byl přidán atribut důvod ukončení pracovního poměru. Je to položka znaková - na 40 znaků (C40).

Píše se do ní slovně důvod ukončení pracovního poměru pracovníka.

Bylo přidáno též do tisků u činností
- karta pracovníka
- prohlížení výplatních lístků
- výkazy - prohlížení

Testováno :
spuštěním činností - včetně tisků
Ing. Olga Smitková 16.10.00


MZDY - Přehled odvodů - rekapitulace

MZDY - Přehled odvodů - rekapitulace
Tisková sestava "Přehled odvodů - rekapitulace" z činnosti MZDY - Prohlížení výplatních lístků - byla rozšířena o položku "Odvod ZP zaměstnanec za organizaci" (vzniká z neplaceného volna).

Testováno : spuštěním sestavy na našich datech v měsíci 08/2000 - sestava musí mít podmínku "Odvod do SR zaměstnanec".

Pozn.: Totéž platí pro sestavu "Přehled odvodů dle typu" ze stejné činnosti.
Ing. Olga Smitková 13.10.00


MZDY - součtování Ctrl+S

MZDY - součtování Ctrl+S
Do činností
- události mezd
- úkolové listy

byla dopracována možnost stisku kláves Ctrl+S, která vyvolá součty smysluplných údajů na událostech.

Testováno : spuštěním uvedených činností
Pozn.: funkce Ctrl+S je též dostupná v činnosti Prohlížení výplatních lístků.
Ing. Olga Smitková 13.10.00


MZDY - výpočet výplatních lístků

MZDY - výpočet výplatních lístků
A)Testován a ověřován výpočet v případě, že některý z pracovních poměrů je dohoda, která NEMÁ zadán datum vzniku prac. poměru.

V programu provedena mírná změna (přidána podmínka empty(nvl(MZPRACPO.mz32vznipp,{})) ).

Testováno na datech ADaudit v měsíci 06/2000
1. pí Hansíková 00405 - dva prac. poměry, druhý je dohoda a NEMÁ datum vzniku p.p., podepsal prohlášení Ano, lze srážet Ne, účast na nem. pojištění jen u hlavního prac. poměru - položky THP1, OSOH, APROC, STRAV, VSEUC, půjčka, O01, ZAKDOH a nemoc

2.pí Šteyerová 00887 - jeden prac. poměr - dohoda, která má i nemá datum vzniku p.p.
2a. varianta podepsal prohlášení Ne, lze srážet Ano , příjem menší než limit srážkové daně
2b. varianta podepsal prohlášení Ne, lze srážet Ano , příjem větší než limit srážkové daně
2c. varianta podepsal prohlášení Ano, lze srážet Ne

B) Zpracován případ, kdy pracovník ukončil prac. poměr, ale ještě jsou mu vypláceny nějaké peníze (ručně zadané nebo nemoci) - viz dokument
Ing. Olga Smitková 25.10.00


Nastavení systému BM

Nastavení systému BM
pro SYBASE SQL Anywhere 7.0.
Je provedeno nastavením parametru "fetchmemo=0" v souboru BW.INI
Tento parametr nastaví při instalaci verze pohledům vlastnost odpovídající vlastnost, která znamená, že MEMO pole nejsou natahovány v rámci dotazu SQL hned, ale až v okamžiku jeho potřeby. Toto způsobí jeho značné zrychlení, které zřejmě souvisí s organizací dat v databázi SYBASE 7.0 (bloby jsou ukládány odděleně od dat s pevnou délkou).
Nastavení nemá vliv při použití SYBASE 5.0 .

Nastavení, ale způsobuje padání programu pro některé dotazy, které mohou souviset:
1/ s neprovedeným GO BOTT po REQUERY
2/ zdá se problém funkce EVAL

Pro odstranění v ostrém provozu systému v BM je možné
1/ uvádět v parametru "NoFetchMemo" seznam pohledů oddělených čárkou, kterým má být při spuštění programu nastavena vlastnost fetchmemo=1
2/ byl vytvořen program NOFETCH.EXE, který po spuštění v adresáři C:\BMSQL\BM_SERVIS odblokuje nastavení stanice pro jednotlivého uživatele, který by měl velké problémy. Program je uložen v adresáři K:\BMSQL.
3/ instalací nové verze programu s nastavením "fetchmemo=1" v BW.INI uvede všechny pohledy do stavu, ve kterém systém fungoval před touto změnou
Ing. Petr Filip 04.10.00

Viz.také

Sybase SQL Anywhere 7.0


Oprava tisku označených

Oprava tisku označených
na SYBASE SQL ANYWHERE 7.0.
Chyba nemožnosti tisku označených vznikla z důvodu úpravy programu, která odstraňovala chybu databáze při tisku velkého objemu záznamů po přerušení klávesou ESC.
BM na SYBASE SQL ANYWHERE 7.0 se v tomto případě otevírá nové připojení, které nemá dostupné data v souboru označení uložené v tabulce charakteru GLOBAL TEMPORARY (má pracovní obsah právě pro každé jednotlivé připojení).
Podobný problém nastavá u činností, kterým uložené procedury naplní obsah souboru tohoto typu.
Pro tyto případy bude komplexně vyřešeno po INVEXu.

Ing. Petr Filip 07.10.00


Opravné položky a odpisy pohledávek

Opravné položky a odpisy pohledávek
Oprava stávajícího řešení.
Na první záložce karty pohledávky se jsou obsaženy atributy podstatné pro synchronizaci s komponentou platby a výpočet odpisů šablonou:
a1/ datum založení karty - uživatelem modifikovatelný
a2/ hodnota pohledávky v okamžiku založení karty (a1) dále aktualizovaná událostmi komponenty "Odpisovaný majetek"
a3/ procento ročního odpisu pro karty definující odpis
a4/ identifikace tabulky pro karty definující opr.položku (představuje legislativní vlastnosti pohledávky pro stanovení výše možného odpisu)
a5/ na druhé záložce procento odpisu pro účetní odepisování

Výpočet odpisů potom probíhá pomocí šablon nad událostmi komponenty "Odpisovaný majetek".
Pro výpočet daňových odpisů:
b1/ zadává se datum odpisu, ke kterému se má výpočet provádět. Hodnota pohledávky pro výpočet odpisu se vztahuje právě k tomuto datu a pokud neodpovídá částce zapsané na kartě odpisu (a2) signalizuje to šabloně, že má udělat oprávku (korekci) předchozích odpisů (jedná se o pohledávky u kterých po odpisu došlo k úhradě)
b2/ omezení procenta odpisu, které způsobí výpočet s nižším procentem těch pohledávek, které by podle svého stavu mohli odepisovat více
b3/ zaškrtávací pole "Pouze oprávky", které určuje šabloně, že má provádět pouze korekci odpisů pohledávek (korekce odpisu pohledávky probíhá vždy při výpočtu bez ohledu na toto nastavení)

Při vytváření záznamů o korekci odpisu se informace o jednotlivých úhradách převádějí na výstupní události šablony:
c1/ vybírající se úhrady do data popsaného v b1 včetně, které způsobily rozdíl popsaný v b1
c2/ datum události odpovídá datu úhrady
c3/ odepisovaná částka se vypočítává DOSUD_ODEPSÁNO*UHRAZENÁ_ČÁSTKA/ČÁSTKA_a2
c4/ stav pohledávky v okamžiku odpisu je naplněn aktuální neuhrazenou částí pohledávky k datu b1
c5/ nastaven příznak "Změna hodnoty pohledávky" na "Ano", který způsobí aktualizaci hodnoty pohledávky na kartě (a2)

Pro výpočet účetních odpisů:
d1/ zadává se datum odpisu, ke kterému se má výpočet provádět. Hodnota pohledávky pro výpočet odpisu se vztahuje právě k tomuto datu.
d2/ výpočet probíhá podle procenta uvedeného na kartě (a5)

Výpočet všech druhů odpisů je možný provádět opakovaně, vždy se bere v úvahu částka dosud odepsaná a aktuální stav pohledávky k datu b1.

Problémy k dořešení:
e1/ dobropis
e2/ kurzový rozdíl - zahrnout či nezahrnout do hodnoty úhrady a aktuálního stavu pohledávky k datu b1

Ing. Petr Filip 03.10.00


Platby - penalizace

Platby - penalizace
Byla opravena a detailně testována možnost penalizace (typ penalizace - nezávislý dnech v algoritmu vymáhání) faktur.

Podrobnější popis v dokumentu.
Ing. Olga Smitková 12.10.00


Šablona převod mezi sklady

Šablona převod mezi sklady
Šablona slouží pro hromadný výběr artiklů pro potřeby událostí obchodu nebo skladu.

Šablona byla parametrizována - parametr má hodnoty 1 a 2.

Je-li nastaveno 1 : Do událostí se bude přeplňovat sklad, který v šabloně NENÍ označen jako cíl.

Je-li nastaveno 2 : Do událostí se bude přeplňovat sklad, který v šabloně JE označen jako cíl.

Testováno na datech Fragmentu.
Ing. Olga Smitková 30.10.00


Šablony

Šablony
Oprava, která umožňuje zadávat hodnoty překryvných seznamů větší než 9
Ing. Petr Filip 03.10.00


Datový model

Datový model
Je nová činnost menu "SYSTÉM".
Zobrazuje datový model uložený v programu.
Ing. Petr Filip 26.09.00

Viz.také

Uživatelské triggery


Uživatelské triggery

Uživatelské triggery
Je nová činnost menu "SYSTÉM".
Slouží k tvorbě uživatelem definovaným triggerů
TRIGGER = program uložený v databázi, který je spojený s některou tabulkou databáze. Je vyvoláván při změnách dané tabulky (volitelně při vkládání nového záznamu nebo opravě záznamu nebo rušení záznamu). Nemá žádné parametry a nemůže být aktivován jiným způsobem než změnou dat.
Uživatelsky definované triggery jsou typu ROW-LEVEL bez možnosti "After update of" (z důvodu některých jejich problémů ve verzi Sybase SQL Anywhere 5.0)

V definici triggeru se uvádí:
1/ tabulka, ke které přísluší
2/ název trigger
3/ pořadí triggeru (toto je ve skutečném triggeru v databázi zvětšeno o 50, tak aby nedocházelo ke konfliktu s triggery BM)
4/ timming spuštění triggeru "before" (před) nebo "after" (po) událostí, která mění data tabulky
5/ událost, při které má být trigger aktivován - "insert" (vkládání) nebo "update" (oprava) nebo "delete" (rušení) záznamu v tabulce
6/ kód triggeru

Popis triggeru uložený v databázi má strukturu:

BEGIN

END;

V definici uživatelského triggeru v BM se uvádí kód bez uvedení BEGIN a END.
V kódu triggerů je možné se odkazovat na atributy záznamu, který jej aktivoval:
1/ při INSERT - new_name - alias záznamu, který vstupuje do tabulky
2/ při UPDATE - old_name - alias záznamu, který obsahuje hodnoty před změnou
- new_name - alias záznamu, který obsahuje změněné hodnoty
3/ při DELETE - old_name - alias záznamu, který je rušen z tabulky

Případné změny dat provedené triggerem jsou obsaženy ve stejné transakci jako změna, která ho vyvolala, proto by neměl obsahovat příkaz "COMMIT".

Je-li uživatelský trigger definován, je třeba ho vygenerovat odpovídající volbou menu činnosti (také činností "Datový model"). Měl by být odladěn neboť při instalaci nové verze BM se triggery obnovují (instalace by hlásila chyby).

Typickým příkladem použití je trigger tabulky "OBARTIKL" (obchodovatelný artikl), který při opravě technicko-věcného selektoru aktualizuje selektor odpovídajícího skladovaného artiklu (tabulka "MTARTIKL").
Kód pro událost "AFTER" "UPDATE" může mít obsah:
if new_name.sp20idzak<>old_name.sp20idzak then
update %%%.mtartikl set sp20idzak=new_name.sp20idzak where
mtartikl.sp60id=new_name.sp60id and mtartikl.sp61id=new_name.sp61id and
sp20idzak<>new_name.sp20idzak;
end if;

Pozn.1: v kódu je při generování text %%% nahrazen identifikací uživatele (v daném případě BM_SERVIS)
Pozn.2: pro použití je třeba vytvořit opačný trigger pro tabulku "MTARTIKL"

Další možné využití se dá očekávat pro řízení procesů aktualizacemi volných karet.

Špatně konstruovaný trigger může napáchat neostranitelné škody v datech, proto v této chvíli váhám zda jeho vstup a generování nepovolit pouze správci systému.
Ing. Petr Filip 26.09.00

Viz.také

Datový model


Dokumenty

Dokumenty
Pokus o odstranění problémů Wordu a Excelu
1/ zaveden parametr "Office97" v souboru BW.INI v sekci "Preferences", který určuje při hodnotě 1 (default), jehož nastavení na 0 ponechává některé následující funkce v původním stavu (v příští verzi bude možné zadat tento parametr také v souboru BWLCL.INI v systémovém adresáři Windows na stanici, který bude mít vyšší prioritu)
2/ Excel problém otevírání prvního dokumentu (bylo třeba zvlášť spouštět) odstraněn
3/ Word při Office97=1 se neotevírá vícekrát (používá objektový model Office97)
4/ Excel při Office97=1 přenáší do nadpisu okna název dokumentu
5/ Word při Office97=1 přenáší do nadpisu okna název dokumentu

Přenos názvu do nadpisu okna bude třeba zapracovat do výkazů
Ing. Petr Filip 21.09.00

Viz.také

Předlohy výstupu


Předlohy výstupu

Předlohy výstupu
Do Excelu podle parametru "Office97" (viz.otec - popis změn v "Dokumenty") do nadpisu okna název předlohy.
Tuto vlastnost je možné potlačit uvedením příkazu ".NEMĚNIT_NADPIS" v definici předlohy.
Ing. Petr Filip 21.09.00

Viz.také

Dokumenty


Import/export dat

Import/export dat
Nový atribut "Init" v definici importu určuje příkaz vyvolaný ještě před zahájením importu.
Předpokládá se použití některých činností, které vracejí v pracovním souboru seznam označených záznamů jako třeba adresář.
V okamžiku vyvolání příkazu, je v proměnné "_o.wrk2" uloženo jméno dosud neexistujícího souboru, který bude vytvořen příkazem.
V okamžiku vyvolání kódu popsaného v atributu "Selekt" importu je toto jméno dostupné "this.wrk2".
Takto definovaný import byl použit v aplikaci "Fragment" a zde je vysvětlení jeho definice:
1/ Init obsahuje
*
DO FORM ad0137 WITH this.identif,'!',_o.wrk2,'',''
*
- znamená vyvolání formuláře "Adresář" před zahájením importu, tak aby zablokoval aktivaci formuláře, ze kterého je import vyvolán a vrátil v souboru definovaného obsahem proměnné "_o.wrk2" označené adresáty
2/ obsah Selekt
*
select 0
create cursor data (ad01id c(6),sp61id c(3),sp60id c(13))
if !empty(this.wrk2);append from (this.wrk2)
do nkprcpre with this._thisform
*
- vytvoření kurzoru (kurzor=pracovní soubor, který je automaticky smazán po jeho uzavření) se strukturou identifikace adresáta a identifikace artiklu
- v případě, že údaj o názvu pracovního souboru není prázný doplní se do kurzoru seznam označených adresátů (název může být prázdný, je-li kód vyvolán v okamžiku přípravy importu např. "Prohlížení importovaných dat" nebo "Předplnění hodnot")
- vyvolání programu "nkprcpre", který doplní do záznamů identifikaci artiklu a k tomu využije informace formuláře, do kterého je prováděn import (parametr this._thisform)

Ing. Petr Filip 20.09.00


Masky operací

Masky operací
Opravena chyba - která se projevovala při definování hodnoty překryvného seznamu, která odpovídala pořadí v seznamu větší než 8 - hlásila "Numeric overflow"
Ing. Petr Filip 20.09.00


Menu formulářů

Menu formulářů
Položky menu formulářů komponent "Diagram","Strom hlavního procesu" a "Spuštění procesu" byly přesunuty z menu "Obecné" do menu "Volby" stejně jako položka menu "Informace o operaci", která je zde pod novým názvem "Vlastnosti operace".

Položky menu "Volby" odpovídající reakci na klávesu F2 se nyní nezobrazují. Jejich zobrazování je možné nastavit zadáním parametru "F2menu=1" v sekci "Preferences" souboru BW.INI.
Ing. Petr Filip 04.09.00


MZDY - Doplňkové odvody

MZDY - Doplňkové odvody
Do menu MZDY - DEFINICE - POLOŽKY MEZD - byla přidána činnost - číselník - "Doplňkové odvody".

Jsou zde předdefinovány položky mezd, které slouží k zaznamenání přeplatků a nedoplatků :
- doplatek ZP zaměstnanec - I15000
- doplatek ZP organizace - I16000
- doplatek SP zaměstnanec - I22000
- doplatek SP organizace - I32000
- doplatek daně zálohové - L12000
- doplatek daně srážkové - L22000

Tyto položky jsou též součástí první instalace.

Pokud bude taková položka použita na výplatním lístku, dojde pouze k odečtení těchto peněz od čistého příjmu. Toto pravidlo neplatí v případě položek "doplatek ZP organizace - I16000" a "doplatek Sp organizace - I32000". Tyto dvě položky se pouze zapíší, jinak nic.

Testováno : spuštění číselníku a zadání údajů
opětovně testováno

Pozn.: Pokud chcete tyto položky používat ve stávajících verzích Bílého motýla, je nutné je ručně navkládat.
Ing. Olga Smitková 11.09.00


Mzdy - chyba

Mzdy - chyba
Chyba : Ve výpočtu výplatních lístků byla chyba - pokud měl pracovník dva pracovní poměry a zároveň stravenky jako srážku, potom se tyto stravenky neodečetly z čistého příjmu.

Řešení : úpravou algoritmu - chyběl cyklus přes všechny pracovní poměry

Testováno : Na datech Adaudit - 03/2000 - všechny výplatní lístky znovu.
Ing. Olga Smitková 22.09.00


O aplikaci ...

O aplikaci ...
V menu formuláře hlavního menu programu přibyla položka "O aplikaci ...", tak jak je obvyklé u Windows programů
Ing. Petr Filip 26.09.00


Obecné výběry

Obecné výběry
Oprava chyby, která se projevovala při definování pohledu na klávesu F2 na poli "selektu" s delším textem
Ing. Petr Filip 26.09.00


Odpisy pohledávek

Odpisy pohledávek
V posledních verzích BM byla omylem odpojena činnost "Karty pohledávek".
Tato činnost se vyskytuje v menu "ODPISY A OPRAV.POL. POHLEDÁVEK" a také ve menu formuláře "Události plateb".

V implementaci BM v BM jsem napojil druhdy naimportované karty pohledávek odpovídajícím platbám (je třeba udělat kontrolu a nastavit správný atribut v událostech).
Přitom jsem odhalil chybu - nejde zrušit karta pohledávky.
Ing. Petr Filip 05.09.00


Oprávnění k činnostem

Oprávnění k činnostem
V této činnosti je možné nově definovat práva také skupině "KAŽDÝ UŽIVATEL SYSTÉMU".
Ing. Petr Filip 27.09.00


Ostrý BM

Ostrý BM
funguje nyní na "Adaptive Server Anywhere 7".
Nejsou instalovány tyto stanice.
Olina,Jaroušek,Rosťa,Honza,Pepa,Mirka,Karel,Michal

Současně byl zastaven server na Novellu, na kterém byly příslušně modifikovány soubory AUTOEXEC.NCF a STARTBMS.NCF
WBM byl přesměrován na nový datový server.

Pro instalaci stanic je třeba po nainstalování nového klienta vytvořit spojení BM_SERVIS, translator "Adaptive Server Anywhere 7.0 Translator",
server BM_SERVIS databáze BMSQL7, network zaškrtnout "TCP/IP" a odškrtnout "Shared memory"
Ing. Petr Filip 27.09.00


Předávání - dokumentace

Předávání - dokumentace
Předán systém tvorby a údržby technické dokumentace od Jaroslava Jandy ml. - viz dokument
Ing. Olga Smitková 22.09.00


Předlohy výstupu

Předlohy výstupu
Pro vytváření nových předloh výstupu typu "Sestava" je možné použít předdefinované vzory.
Pro použití této funkce je možné v souboru BW.INI předdefinovat až devět vzorů v sekci "Preferences" parametry "PRINT_TEMPLATEx", kde x je číslo vzoru 1 až 9. V uvádí se [;].
Není-li uveden předpokládá se, že vzor se nachází v podadresáři TEMPLATE adresáře programu pod jménem PTEMPx, kde x je číslo vzoru.
Je-li uveden musí být obsahovat jméno včetně přípony FRX.
Je-li vytvořen musí být spolu s ním v odpovídajícím adresáři soubor se stejným jménem s příponou FRT.
Případné změny v souboru BW.INI se projeví při novém spuštění programu.

Soubory vzoru je možné upravovat v seznamu předloh výstupu po pravém kliku výběrem z menu.
Soubor vzoru musí v pásu "Detail" obsahovat text s obsahem "Start_atr". Tento text určuje pozici, od které budou při vytváření nové sestavy vkládány vybrané položky a nebude do sestavy přenesen.
Položka s obsahem 'LABEL' bude nahrazena názvem předlohy (nemusí být uvedena).

Při vytváření nové předlohy typu "Sestava", může uživatel vybrat kromě položek zařazených do výstupu také vzor, podle kterého má být nová sestava vytvořena.

Opravené chyby -
Vyvolání předlohy výstupu typu sestava klávesou F12 z činnosti hlavního menu s předdefinovanou předlohou výstupu vrací správné výsledky.
Do výstupu je možné zařadit název obecného výběru.
Ing. Petr Filip 07.09.00


Slovník dat

Slovník dat
Dopracování možností uživatelského filtru tisku (promítá se i do běžných tiskových předloh)
1/ je možné zadat výraz bez logického operátoru
2/ odstraněna chyba negace
3/ filtr v definici prostředí pohledu je možné zadat neomezeně dlouhý
4/ ve filtrech je pro pohledy použité ve WBM je možné používat term ?this.bw01uziv

Je třeba udělat některé změny v WBM, které budou navazovat na tyto změny
Ing. Petr Filip 21.09.00


SM - úpravy

SM - úpravy
Události spravovaného majetku:
převedeno na plnohodnotnou komponentu se vstupem pouze z procesu, doplněny informace o operaci do grid ua na formulář, doplněna práva na operaci a umístění, doplněna záložka aktuální stav věci, vstup umístění @!, popis není povinný, doplňuje se '-', doplněn výběr na změny: umístění a vlastníka
Testováno spuštěním procesu a vkladáním událostí

Obecně SM:
doplněny výběry, události o výběry dle operace, stav artiklu... doplněny definice tisku: Uda, Rez, AH, Artikl, Umís
Testováno použitím nově přidaných výběrů na všechny možnosti

Karty SM:
doplněn výběr a možnost hromadného vstupu označených karet do událostí SM, návrat sp60id nebo sm01por dle parametrů, doplněna práva na umístění, opakování druhu artiklu při vstupu
Testováno hromadným výběrem, a F2 na pořadí v událostech

Rezervace:
Testování funkčnosti, doplnění výběru pořadí (testováno F2), práva na umístění, rozšíření kontroly překrytí o sm01por

SM:
Vyřazena činnost inicializace a parametry SM a návazné testy na událostech SM
Jaroslav Janda ml. 06.09.00


Souvislosti objektů

Souvislosti objektů
Oprava chyby zobrazení souvislostí objektů.
Ing. Petr Filip 27.09.00


Spojené dokumenty

Spojené dokumenty
vyvolávané klávesou CTRL+D nad objekty.
1/ založení nového dokumentu - klávesa OK při zadávání nového dokumentu je povolena (dříve bylo třeba nejdříve změnit některou vlastnost zpravidla název)
2/ kopie dokumentu - klávesa OK není povolena proto, aby uživatel změnil název kopie
3/ menu vyvolávané pravým klikem na prvku stromu je možné vyvolat klávesou F6
4/ v menu vyvolaném na dokumentu přibyla možnost "Uložit jako...", která slouží k exportu obsahu dokumentu na disk. Je možné přednastavit adresářovou cestu, která bude nabídnuta, parametrem "Doc_export_file" v souboru BW.INI v sekci "Preferences". Při ukládání souboru je též případně vytvářen soubor mailmarge.
5/ v menu vyvolaném na uzlovém prvku stromu přibyla možnost "Vložit kopii dokumentu 'xxxx'", která dovoluje přidat kopii dokumentu (ne odkaz) označeného volbou "Kopírovat odkaz na dokument".

Ing. Petr Filip 20.09.00


Spravovaný majetek

Spravovaný majetek
Oprava chyby při vstupu události byl přepisován adresát a umístění.
Rozšíření přístupu práv - události jsou přístupné tomu, kdo má právo k operaci a zároveň k umístění v události a zároveň k umístění na kartě majetku
Ing. Petr Filip 26.09.00

Viz.také

Spravovaný majetek

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Spravovaný majetek

Spravovaný majetek
Práva přístupu k události byla změněna (viz.otec) Události jsou přístupné tomu, kdo má právo k operaci a zároveň k umístění v události
Ing. Petr Filip 27.09.00

Viz.také

Spravovaný majetek

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Šablony komponent

Šablony komponent
Šablona může v sobě obsahovat odkaz na import, který je vyvolán při aktivaci šablony (klávesou CTRL+F3 nebo při spuštění operace).
Je-li v šabloně uveden odkaz na import, šablona žádné jiné akce než přesměrování na import neprovádí.
Import je vyvolán i když je druhu, kterému nemá běžně uživatel přístup.
Ing. Petr Filip 20.09.00


Účetní saldokonto

Účetní saldokonto
V činnostech "Účetní saldokonto" a "Účetní saldokonto k datu" byly provedeny změny:
1/ možnost setřídění podle absolutní hodnoty částky
2/ události účetnictví ze stornovaných nebo stornujících procesů jsou v mřížce na druhé záložce podbarveny šedou barvou
3/ v činnosti "Účetní saldokonto" je na druhé záložce možné měnit IDP události a "Jiné párování" - přístup k těmto změnám se odvozuje podle práva přístupu k druhu operace, ve které byl účetní zápis proveden
Ing. Petr Filip 21.09.00


Uživatelé systému

Uživatelé systému
V této činnosti se nově zobrazuje uživateli s právy správce v seznamu uživatelů také "Správce systému".
Ing. Petr Filip 27.09.00


Vlastnosti předlohy

Vlastnosti předlohy
Oprava chyby, která se projevovala po vyvolání okna s textem na pravý klik na polích charakteru poznámka s delším textem
Ing. Petr Filip 26.09.00


Archivace dat

Archivace dat
V souboru DBBACK.INI přibyl parameter "GO", který má význam s hodnotou "1" (např. GO=1).
Tento parametr způsobí, že okamžitě po spuštění DBBACK.EXE je provedena archivace (resp.replikace) a po úspěšné archivaci se program ukončí.
Parametr je určen pro spouštění archivace z plánovače úloh Windows.

Současně jsem přemístil archivaci na počítač BM_PC_26, protože archivace na "VOICE MAIL SERVERU" nebyla spolehlivá (síťové chyby "Error sending packet") a nešlo provádět úplnou archivaci.
Archivace se spouští plánovačem úloh ve 23:00 s úplnou archivací v pátek.

Testováno - nové nastavení archivace v BM
Ing. Petr Filip 12.08.00


Hlavní menu programu

Hlavní menu programu
Vlastnosti položky hlavního menu resp. výběr definovaný k položce hlavního menu je doplněn o možnost definování předlohy výstupu.
Tuto předlohu je potom možné přímo vyvolat z formuláře činnosti spuštěné z hlavního menu klávesou F12.
Profilem chování takto vyvolané předlohy je profil dvojkliku.

P.S. Takto je možné vyvolat i předlohu, ke které nemá uživatel přístup daný druhem předlohy. Do budoucna je třeba rozhodnout, zda tomu tak má být.

Testováno - funkčnost klávesy F12
Ing. Petr Filip 03.08.00


Instalace systému

Instalace systému
Pro implementátory - před instalací této verze zrušte v "SYBASE SQL Centralu" triggery tabulky "UCDENIK", které při jakékoli změně záznamu přepočítávaly obrat v obratové tabulce (tj. i když se nezměnila částka hodnota v události se do obratové tabulky přičetla a zase odečetla) - tato chyba byla touto verzí odstraněna.
Zrušit původní triggery je třeba, protože se při instalaci do tabulky přidávají nové atributy (5) a následně se inicializují.

Testování - bez toho zřejmě systém s větším počtem záznamů v UCDENIK nenainstalujete.
Ing. Petr Filip 15.08.00


MT - skladová cena

MT - skladová cena
V souvislosti s předběžným výdejem se může kazit skladová cena.
Př.
Na skladě je nulové množství
1. Výdej 10 ks
2. Příjem 110 ks v ceně 20 Kč/ks
3. Ocenění předběžného výdeje:
skl. cena = 2200/120 = 18.3333,
cena celkem = 183.333
Aktuální množství na skladě = 100 ks
Cena = 2200 - 183.333 = 2016,667, tj
skl. cena za ks = 20.16667
RNDr. Jan Sekyra 18.08.00


Mzdy - Generace událostí mezd -sumárníPL

Mzdy - Generace událostí mezd -sumárníPL
Šablona - Generace událostí mezd - sumární - platby -opraveno, přidána funkčnost na všechny typy mzdových položek (tj. příjmy a náhrady, součty příjmů,
neplacené volno, měsíční a roční nezdanitelné položky)

testováno : na datech Adaudit spuštěním šablony pro položku "K výplatě".
Ing. Olga Smitková 21.08.00


Mzdy - srážky a půjčky

Mzdy - srážky a půjčky
Do formulářů činností "Srážky" a "Půjčky" byl přidán zaškrtávací atribut "tisknout".

Srážka na výplatním lístku se předplní dle tohoto nastavení.

Jedná se o atribut, který lze využít v sestavě pro tisk výplatních lístků - v podmínce sestavy . reguluje se tím, které řádky výplatního lístku chci tisknout a které ne.

Testování : spuštění činností "Srážky", "Půjčky" a "Výplatní lístky".
Ing. Olga Smitková 04.08.00


Mzdy- šablona pro události mezd

Mzdy- šablona pro události mezd
Vytvořena nová PROGRAMOVATELNÁ šablona na vkládání událostí mezd.

Je to šablona "Mzdy - podrobně - OST" (MZ0096)

Šablona zapisuje údaje z mezd podrobně, tj. za každého pracovníka zvlášť a za každou mzdovou položku zvlášť. Zapisuje POUZE údaje ostatní (mají označení OST) a na Druzích událostí mají nastaveno Ostatní "Ano". Šablona nezapisuje selektory.

Testováno: Spuštěním šablony.
Ing. Olga Smitková 29.08.00


Obecné výběry

Obecné výběry
Odstraněna chyba - obnovení nastavených relací po výběru
Odstraněna chyba - možná nefunkce obecných výběrů na formulářích, ve kterých je základní mřížka umístěna na první záložce (při překliku na další záložku není vidět)

Testováno - formuláře "Obratová tabulka","Seznam prováděných činností","Druhy operací"
Ing. Petr Filip 15.08.00


Obratová tabulka

Obratová tabulka
Obratová tabulka má novou strukturu.
Přibyly atributy
"Fáze v účetním období" - Otevření/Běžná/Uzavření
"Druh informace" - Skutečnost/Plán
Oba tyto atributy mají svůj ekvivalent v účetním deníku.
Události účetního deníku fáze otevření bez ohledu na datum události aktualizují obratovou tabulku záznamem s prvým měsícem a rokem období.
Události účetního deníku fáze uzavření bez ohledu na datum události aktualizují obratovou tabulku záznamem s posledním měsícem a rokem období.
V původním řešení zapisovaly tyto události s rokem odpovídajícímu datu události a měsíci 00 a 13.

Na výběrové záložce činnosti obratové tabulky a obratové tabulky se selektory přibyla možnost výběru za účetní období.

Po nainstalování nové verze je třeba přepočítat obratovou tabulku.
Ing. Petr Filip 19.08.00

Viz.také

Událost účetnictví


Obratová tabulka

Obratová tabulka
Formulář má jednotné ovládání s činnostmi "Hlavní kniha", "Konta" a "Konta se selektory"
Na všech těchto formulářích se nově vyskytuje "Měna".
Na záložce "Deník" je dostupný seznam událostí účetnictví, ze kterých byl odpovídající záznam složen a vyvolat odpovídající operace klávesou F9.
Je možné vytvářet tiskové předlohy se spojením agregované informace a jejích zdrojů v účetním deníku.

Pro implementátory - činnosti "Hlavní kniha", "Konta" a "Konta se selektory" čerpají své informace z pohledů databáze nad obratovou tabulkou "UCKONTA","UCKONTAS","UCHLAKNI", ke kterým je možné přistupovat jako k běžným tabulkám databáze.

Testováno - výběry, zobrazení hodnot ve formulářích
Zbývá otestovat - předlohy výstupu
Ing. Petr Filip 15.08.00

Viz.také

Událost účetnictví


Operace

Operace
Oprava výběru podle externího čísla procesu.
Je dovoleno zadat neúplné externí číslo procesu.

Testováno - výběr podle neúplného externího čísla procesu
Ing. Petr Filip 28.08.00


Parametry účetnictví

Parametry účetnictví
Byl ponechán jediný atribut "Povoleno účtování do budoucnosti", který dovoluje vytvářet účetní zápisy s datem větší než je aktuální datum.
Ing. Petr Filip 19.08.00

Viz.také

Účetní období


Procesy

Procesy
Oprava výběru podle externího čísla procesu.
Je dovoleno zadat neúplné externí číslo procesu.

Testováno - výběr podle neúplného externího čísla procesu
Ing. Petr Filip 28.08.00


Předlohy výstupu

Předlohy výstupu
Pravý klik na předloze výstupu nabízí v menu nově volbu "Export do balíčku".
Tato volba způsobí vyvolání formuláře pro export do balíčku s předplněným názvem, který odpovídá interní identifikaci předlohy v BM (ta je také zobrazována ve vlastnostech předlohy na záložce "Info").
Tento předplněný název balíčku může být doplněn o cestu, která může být definována v souboru BW.INI v odstavci [Preferences] parametrem "Adresar_predloh".
Např.:
[Preferences]
Adresar_predloh=M:\PREDLOHY

Exportem do balíčku vznikne kromě souborů s příponami "BEX" a "FPT" také soubor s příponou "TXT", který obsahuje mj. informace o názvu předlohy, datu jejího vzniku a modifikace, autorovi, popisu přelohy
Např.:

Přehled salda včetně skladby
----------------------------
Předloha výstupu
Činnost: (UC0140) Účetní saldokonto do data
Typ: Sestava
Autor: Správce systému
Vznik: 14.06.2000 17:22:38
Změna: 22.08.2000 18:45:42
Popis:
Přehled záznamů o účetním saldokontě s událostmi v účetním deníku, které se podílely na jejich skladbě.

Balíček vytvořil: SPRÁVCE (00000-01) 22.08.2000 19:05:54

Další soubor stejného jména s příponou "BMP" (grafický soubor), by měl vytvořit autor balíčku ručně a měl by obsahovat příklad výstupu předlohy.

Budoucí využití předpokládám ve vytvoření formuláře, ve kterém by uživatel vybíral ze seznamu "balíčků" sestavy, které chce přidat do své implementace BM. Zdrojem informací budou právě soubory s příponou "TXT" a "BMP".
Ing. Petr Filip 23.08.00

Viz.také

Předlohy výstupu

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Předlohy výstupu

Předlohy výstupu
Export předlohy výstupu pravým klikem ze seznamu předloh
1/ vyvolá export, ve kterém není možné měnit název a popis předlohy, protože tyto informace vycházejí z vlastností předlohy
2/ nastavuje vlastnost předlohy systémová (export činností "Seznam předloh výstupu" toto neprovádí) tak, aby uživatel nemohl měnit definici předlohy a nedošlo při pozdějším načtení stejné předlohy, ke ztrátě těchto změn. Změnu definice předlohy může udělat na její kopii.
3/ nastavuje hodnoty cizích klíčů předlohy (profil spuštění,druh předlohy, skrytá a skrytá všem) na implicitní hodnoty proto, aby se importem nepřenášely k uživateli záznamy odpovídajících souborů (export činností "Seznam předloh výstupu" toto neprovádí).
Tuto vlastnost je možné potlačit nastavením parametru 'Reset_cizich_klicu_exp_predlohy=0' v sekci 'Preferences' souboru BW.INI.
4/ přenos souvisejících souborů (předlohy Excelu z podadresáře TEMPLATE a loga z podadresáře BMPS) není automatizován

Vlastnosti předlohy
1/ Je možné měnit vlastnost systémová při nastavením parametru 'Povol_zmenit_priznak_syst_predlohy=1' v sekci 'Preferences' souboru BW.INI.
2/ U předlohy označené jako systémová je možné měnit její vlastnosti - druh předlohy, profil předlohy, skrytá, skrytá všem. Importem balíčku při přepisu existující předlohy (provádí se v případě, že datum a čas poslední změny původní předlohy je menší nebo roven datu poslední změny importované předlohy) se tyto informace zachovává.
3/ Uživatel má s touto verzí přístupné vlastnosti předlohy i v případě, že se jedná o předlohu druhu, ke které má pouze právo čtení. V tomto případě nemá přístupné všechny záložky formuláře vlastností a může měnit pouze atribut 'skrytá'

Přehled balíčků odpovídající činnosti
Je možné vyvolat ze seznamu předloh výstupu pravým klikem s následným výběrem volby 'Balíčky'.
Popis viz. činnost 'Přehled balíčků'.
Po importu balíčku je třeba obnovit seznam předloh pravým klikem s následným výběrem volby 'Obnovit'.
Ing. Petr Filip 30.08.00

Viz.také

Přehled balíčků | Předlohy výstupu


Přehled balíčků

Přehled balíčků
Je nová činnost podmenu 'SYSTÉM'.
Zobrazí přehled balíčků vytvořených ve formuláři "Předlohy výstupu" (v budoucnu také "Volné karty" a "Obecné výběry"). Pohybem v seznamu je možné uvidět odpovídající popis a je možné také zobrazit příklad výstupu předlohy, pokud byl vytvořen (soubor s příponou BMP).
Stlačením klávesy 'Import' je možné importovat jeden nebo více balíčků označováním v seznamu (myš nebo šipky) + (shift nebo ctrl) podle standardu Windows.
Adresář, ve kterém se balíčky vyhledávají může být definován nastavením parametru 'adresar_predloh' v sekci 'Preferences' souboru BW.INI. Není-li uveden vyhledávají se v podadresáři BAL adresáře instalace BM.
Ing. Petr Filip 30.08.00

Viz.také

Předlohy výstupu


Přehled spárování

Přehled spárování
Vyvolání automatického párování se nyní neprovádí klávesou F9, ale klávesou F6.
Klávesa F9 způsobí vyvolání odpovídající operace spojené platby.
Mřížka plateb obsahuje informaci o identifikaci operace platby.

Testování - funkce kláves F6 a F9
Ing. Petr Filip 23.08.00

Viz.také

Událost změnu stavu peněz


Přepočet obratů dle VČ artiklů

Přepočet obratů dle VČ artiklů
Pro správný nápočet příjmů a výdejů v naturálním vyjádření musí mít druh hodnoty uvedeno množství v ref. MJ. Pokud by bylo uvedeno množství v MJ na události (v případě chyby implementátora), pak by vypočtené hodnoty mohly být nesmyslné.
RNDr. Jan Sekyra 17.08.00


Přepočet saldokonta účetnictví

Přepočet saldokonta účetnictví
Se nyní provádí novou činností účetnictví (dříve se prováděl v rámci přepočtu statistických hodnot).

Testováno - přepočet saldokonta
Ing. Petr Filip 15.08.00

Viz.také

Účetní saldokonto


Řízení procesů - transformace

Řízení procesů - transformace
Byla upraven algoritmus provádějící transformace mezi operacemi, měl by mírně urychlit transformace zejména do účetnictví.

Testováno - proces nákupu a účtování částečných úhrad
Ing. Petr Filip 03.08.00


Spravovaný majetek

Spravovaný majetek
Opraven nefungující výběr na selektory na kartě majetku

Testováno - výběry formuláře "Spravovaný majetek"
Ing. Petr Filip 15.08.00


Spravovaný majetek (DKP)

Spravovaný majetek (DKP)
Nová verze modulu "Spravovaný majetek" (dále SM) jej změnila z podoby skladu do podoby komponenty, která sleduje stav každého jednotlivého objektu majetku.
Identifikace artiklu SM obsahuje kromě identifikace artiklu a druhu artiklu navíc pořadové číslo, které identifikuje každý jednotlivý výskyt majetku stejné třídy (např. 2 automobily Felicie mohou být identifikovány artiklem AUT-FELICIE a rozlišeny pořadovým číslem 1 a 2).
Identifikace včetně pořadového čísla se vyskytuje také v událostech, ve statistikách se vyskytuje pouze artikl bez pořadového čísla.
Každý artikl SM má kromě běžných atributů, které je možné měnit přímo na formuláři artiklu, atributy, jejichž obsah aktualizují události SM.
Jsou to:
- Stav - "Nezařazen/Zařazem/Vyřazen"
- Identifikace adresáta - odpovědnost
- Identifikace umístění SM
- Datum zařazení
- Cena při zařazení
- Datum Vyřazení
- Cena při vyřazení
Počáteční hodnoty pro stav je "Nezařazen" a prázdné hodnoty pro ostatní.
Událost o SM má atributy, které mění stav majetku v ní uvedeném. Jsou to:
- datum události
- změna stavu věci "-/Nezařazen/Zařazen/Vyřazen"
- změna odpovědnosti "Ano/Ne" a id.adresáta
- změna umístění "Ano/Ne" a id.umístění
- cena
Při změně stavu věci na "Zařazen" nebo "Vyřazen" se do odpovídajících atributů atriklu SM zapisuje též datum a cena.
Při vstupu nového záznamu není možné zadat změnu stavu již vyřazeného SM ani změnu stavu ze zařazeného na zařazené, je však možné ho opravit (tato vlastnost je pro najetí, bude potlačena).
Události SM neobsahují dříve užité atributy množství, měrná jednotka a cena celkem, protože každá událost se týká každého jednotlivého objektu (konkrétního stolu, židle, telefonu, ....)

Pro implementaci:
- je třeba upravit aktuální hodnoty SM
- transformace do SM a z SM
- pokud již byly v modulu SM, je možné vyvolat přepočet stavů uloženou procedurou databáze ze SYBASE SQL Centralu "SMMAJ celkovy prepocet stavu".

Pro vývoj:
- přitvrdit pravidlo o možných změnách stavu SM
- rozhodnout - validace "Změna odpovědnosti"=Ano, přitom nesmí být uveden "Neurčený adresát"
- rozhodnout - validace "Změna umístění"=Ano, přitom nesmí být uveden "Neurčené umístění"
- doplnit výběry
- na událostech nejsou vidět identifikátory operace i v gridech
- hromadný vstup označených artiklů SM při návratu hodnoty do událostí SM
- návrat hodnoty na F2 pro "pořadové číslo" v událostech SM
- prověřit definice tisku
- rozhodnout o org.selektoru v artiklu SM, který se nikde nepoužívá (JJ: mnohdy nastane, že se změní odpovědný pracovník/adresát, ale majetek je stále ve stejném organizačním celku)
- zabezpečení - zdá se mi nezabezpečené (JJ - zejména vstup nové události mimo operace)
- inicializace atributů při vstupu nového artiklu SM podle již existujícího prvku stejné třídy¨
- do výběru artiklů a událostí doplnit právo přístupu k umístění SM a operaci
- doplnit na událostech záložku "Aktuální stav věci" a výběry týkající se stavu věci
- rozhodnout zda doplnit na artiklech záložku s přehledem událostí o daném artiklu (JJ: ne, pokud to nebude nový standard ve všech komponentách)
- zrušit funkci "Inicializace SM" a její dopady (JJ: a co parametry a základní druhy hodnot?)
- artikl SM by měl být objektem s vlastní časovou identifikací (ne sp60)
- doplnit v SM trigger pro SPPRC, který při stornování procesu, provede přepočet stavů majetku obsaženého v procesu
- doplnit dokumentaci funkčního modelu
- doplnit dokumentaci datového modelu
- doplnit help

Testováno: vstup dat v událostech a artiklech, dopad na změny stavů.
Ing. Petr Filip 10.08.00


Sybase SQL Anywhere 7.0

Sybase SQL Anywhere 7.0
Testovací verze BM na platformě Sybase SQL Anywhere 7.0 je k dispozici ke spuštění (M:\BMSQ12\BM.EXE).
Jedná se o autentizovanou verzi Sybase (kterou smíme šířit).
Pro BM je třeba pro práci s "Sybase SQL Anywhere 7.0" nastavit v souboru BW.INI v sekci [Preferences] parametr any7=1.
Pro spuštění je třeba nainstalovat odpovídajícího klienta.

Naše verze "Sybase SQL Anywhere 7.0" na zlatém disku obsahuje chyby odstraněné patchem na build 463.
Tento patch je uložen na CD s kopií zlatého disku a je ho třeba nainstalovat po instalaci základní verze.

Chyby, které se patchem opravily se projevovaly:
1/ při opravě ODBC spojení (ovládací panely-zdroje dat) se kazil parametry TranslationDll a TranslationOption v systémovém registru pro dané spojení (potom se nebylo možné připojit na databázi klientem).
Pokud se chyba znovu objeví, dá se jí vyhnout tím, že při každé opravě spojení nastavíte parametr Translation na "nepoužívá" a potom vrátíte nastavení na "Sybase SQL Anywhere 7.0 Translator"

2/ projevila se při převodu dat z databáze verze 5.0 do verze 7.0 instalací. Při převodu tabulky "SPDOKOBS" (dokumenty), kdy se vyskytovala chyba "There is already a variable named ..."
Výtažek z README patche popisuje odtranění chyby, jejíž příčina je zřejmě totožná s naší chybou.

(Build #402 - Engineering Case #183736)
===========================================================================

During the execution of an update/insert via ODBC, a bound parameter
can cause the ODBC driver to create a database variable if the bound
parameter contained a large amount of data, ( more than 32k ). If SQLFreeStmt
is then called for the statement, with the SQL_RESET_PARAMS option,
the database variable was not dropped. Any future statement that caused
a database variable to be created would potentially fail with the error
'Database variable already exists'. The problem occurred in a VB application
executing an "insert into ASADB.x select * from ACCESSDB.y" statement
where one of the columns in the ACCESSDB table was an OLE object.

Zajímavé je, že chybové hlášení uvedené v popisu 'Database variable already exists' v dokumentaci k Sybase SQL Anywhere 7.0 neexistuje (mělo být "There is already a variable named ...", protože se jedné o chybu ODBC)

Nyní uvádím pro nás významné vlastnosti "Sybase SQL Anywhere 7.0":

1/ plánovač úloh zakomponovaný v databázi, který umožní např. vyvolání archivace nebo uložených procedur v určeném čase
2/ vyvolání archivace příkazem databáze
3/ dynamické změny velikosti cache optimalizují výkon serveru
4/ hash-ování indexů pro rychlejší přístup k datům
5/ oddělené ukládání dlouhých hodnot (u nás obsah dokumentů a poznámky) zrychluje přístup k datům
6/ parametr OPTIMIZATION_GOAL určuje, zda má optimalizátor určovat strategii zpracování dotazu na vyhledání jednoho nebo všech záznamů (bude třeba vyzkoušet)
7/ příkaz BACKUP pro NetWare 5 umožňuje archivovat rovnou na pásku
8/ prostor operační paměti věnovaný každému uživateli je menší => větší rychlost, větší počet uživatelů
9/ 100% využití víceprocesorových serverů

Vlastnosti programování (nemůžeme využít do úplného přechodu na 7.0 u všech uživatelů)
1/ proměnné kurzory v triggerech a uložených procedůrách
2/ klausule FIRST a TOP příkazu SELECT
3/ nové vlastnosti příkazu TRUNCATE
4/ příkaz LOCK TABLE
5/ možnosti replikací

Další informace zíkáte na WEB Sybase nebo v příručce "ADAPTIVE SERVER ANYWHERE Getting started".

Na CD s kopií zlatého disku je také adresář EMPTY obsahující prázdnou databázi. Tato databáze obsahuje :
1/ uživatele BM_Servis
2/ nastavený public option "Blocking=Off"
3/ puclic option "Database_Authentication=....." pro autentizaci BM
Ing. Petr Filip 25.08.00

Viz.také

Nastavení systému BM


Šablony pro otevření a uzavření

Šablony pro otevření a uzavření
účetních knih startují výběrem účetního období a druhu informace (Skutečnost/Plán).
Je možné vybrat z obdobích, která nejsou označené jako otevřené resp. uzavřené.
Při uzavření se generují události tak, aby došlo k vynulování konečného stavu záznamů obratové tabulky fáze uzavření zvoleného období, proto je možné tuto funkci vyvolat opakovaně.
Při otevření se generují události tak, aby byly obraty na účtech fáze uzavření předcházejícího období shodné s obraty na účtech fáze otevření zvoleného období, proto je možné tuto funkci vyvolat opakovaně.
Ing. Petr Filip 19.08.00

Viz.také

Účetní období


UC - Transformace

UC - Transformace
Doplněn atribut organizační selektor sp11idzak, který je možné použít v transformaci z účetnictví.

Jaroslav Janda ml. 03.08.00


Účetní období

Účetní období
V komponentě "účetnictví" byl zaveden pojem "Účetní období" a jemu odpovídající činnost.
Každému záznamu v účetním deníku odpovídá právě jedno "účetní období", které má stavy "otevřené/neotevřené" a "uzavřené/neuzavřené".
Účetní období nemusí být dlouhé 12 měsíců, nemusí začínat prvým měsícem v roce a končit posledním měsícem roku a může zasahovat do dvou let.
Účetní období označené jako uzavřené nedovoluje zápis událostí s datem, které mu odpovídají a není nabízeno v šabloně pro uzavření účetních knih.
Dále je dovoleno zapisovat události účetnictví do "neotevřeného" období a "otevřená" období nejsou nabízena v šabloně pro otevření účetních knih.

Zavedením pojmu "účetní období" byl zrušen pojem "inicializace účetnictví", protože ho nahradilo zařazení účetního období odpovídající činností.
Ing. Petr Filip 19.08.00

Viz.také

Událost účetnictví | Šablony pro otevření a uzavření | Parametry účetnictví


Událost účetnictví

Událost účetnictví
Původní atribut druh události byl nahrazen dvěma atributy.
"Fáze účetního období" - Otevření/Běžná/Uzavření
"Druh události" - Skutečnost/Plán
Oba tyto atributy mají svůj ekvivalent v obratové tabulce.

Oba tyto atributy je třeba v implementacích zamaskovat.

Ing. Petr Filip 19.08.00

Viz.také

Obratová tabulka | Účetní období


Účetní saldokonto

Účetní saldokonto
V činnostech "Účetní saldokonto" a "Účetní saldokonto k datu" není již není zobrazován jeden z procesů, ve kterém saldokonto vzniklo.

Testování - odpovídající procesy, přepočet saldokonta
Ing. Petr Filip 23.08.00

Viz.také

Účetní saldokonto

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Účetní saldokonto

Účetní saldokonto
Párování účetních událostí není vztaženo k hlavnímu procesu, ale je ho možné uživatelsky měnit v události účetnictví. Proto přibyl i zde atribut "IDP" na obrazovce i ve výběrech.
V tomto směru se změnilo i "Účetní saldokonto k datu"

Testováno - formuláře saldokonta
Ing. Petr Filip 15.08.00

Viz.také

Účetní saldokonto | Přepočet saldokonta účetnictví | Událost účetnictví


Událost účetnictví

Událost účetnictví
Byla rozšířena o několik dalších atributů.
"Částka v zahraniční měně" - umožňuje zapisovat do obratové tabulky záznamy o účtu v ZM. Zápis se provede v případě, že měna uvedená v události není referenční a účtovém rozvrhu je uvedeno, že se má o účtu zapisovat do obratové tabulky v ZM. O částce v ref.měně se zapisuje do obr.tab. vždy. Pro částku v ZM se nekontroluje podvojnost.
"Měna" - určuje měnu částky v ZM
"IDP" - identifikátor párování - definuje pro saldokontní účty vazební informaci pro párování. Uživatel může tento údaj měnit a není-li při zápisu vyplněn zapíše se do něho identifikace hlavního procesu ve tvaru RRRRUUPPPPPP. Saldokonto se aktualizuje v částce v referenční měně.
Ve formuláři přibyla záložka "Protiúčty-saldokonto", ve které se zobrazují ty záznamy z deníku, které mají stejné IDP a účet, odpovídající operaci je možné vyvolat klávesou F9. Tyto informace není možné v této chvíli tisknout (sdělte svůj názor).

Testováno - párování saldokonta, aktualizace obratové tabulky v cizí a referenční měně
Ing. Petr Filip 15.08.00

Viz.také

Účetní saldokonto | Obratová tabulka


Událost změnu stavu peněz

Událost změnu stavu peněz
"Přehled spárování" původně vyvolávaný klávesou F9 se nyní vyvolává klávesou F6.
Klávesou F9 se nyní vyvolává operace odpovídající odálosti

Testování - funkce kláves F6 a F9
Ing. Petr Filip 23.08.00

Viz.také

Přehled spárování


Události - obchodu

Události - obchodu
do tisku doplněny atributy selektoprů - sp10idzak, sp11idzak, sp20idzak

Testováno: úprava sestavy - rozšíření o selektory
Ing. Olga Smitková 04.08.00


Události skladu

Události skladu
Ceny za jednotku nejsou od této verze zaokrouhlovány na dvě desetinná místa.

Testováno - vstup nedělitelné hodnoty
Ing. Petr Filip 03.08.00


WEB DEFINICE

WEB DEFINICE
je možné exportovat do balíčku pravým klikem na položce.
Do balíčku se exportují také případné podřízené položky s vazbami včetně všech souvisejících informací (pohledů slovníku dat, výběrů, tiskových předloh, druhů a profilů).
Tuto funkci je možné použít export pohledů slovníku dat do balíčku.

Testováno - export a import balíčku
Ing. Petr Filip 03.08.00

Viz.také

WEB DEFINICE

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


ZP - Transformace

ZP - Transformace
Doplněn atribut jméno adresáta ad01adsat, který je možné použít v transformaci ze změny stavu peněz.
Jaroslav Janda ml. 04.08.00


Do událostí plateb přidáno

Do událostí plateb přidáno
třídění dle účtu účetnictví (uc01id)

Testováno : Spuštěním činnosti a setříděním údajů
Ing. Olga Smitková 13.07.00


Formulář událostí komponenty platby

Formulář událostí komponenty platby
Parametr plateb "Implicitní doba splatnosti" byl rozdělen na dva parametry - "Implicitní doba splatnosti pohledávky" (nese v sobě původní přednastavenou hodnotu) a "Implicitní doba splatnosti závazku" (inicializován na 0).
Má-li parametr odpovídající charakteru předepsané platby hodnotu 0, potom se hodnota data splatnosti nepředplňuje a vstup data splatnosti kontroluje (je validní, je-li vstoupeno neprázdné datum).

Testováno - různé varianty nastavení parametrů
Ing. Petr Filip 16.07.00


Formulář událostí komponenty platby

Formulář událostí komponenty platby
Podle nových parametrů plateb provádějí kontrolu existence stejného variabilního symbolu v jiné události charakteru závazek, je-li parametr "Validace variabilního symbolu" nastaven na "Ano" nebo "Ano stejného adresáta" (počáteční hodnota je "Ne").
Rozdíl mezi nastavením "Ano" a "Ano stejného adresáta" je, že při nastavení "Ano stejného adresáta" se vyhledávají závazky kromě VS také navíc podle stejné identifikace adresáta.
Kromě toho je možné v parametru "Nevalidované variabilní symboly" zadat seznam VS, pro které nebude kontrola prováděna.
Validace je prováděna v okamžiku zápisu dat a v případě, že byl nalezen nestornovaný závazek se stejným VS (a podle parametru adresátem) je vydána zpráva pro rozhodnutí obsluhy, zda má BM zapsat data např.:

"Variabilní symbol 990178
identifikuje také závazek 1999-01-00000078
k adresátovi 000233 - "Anenské slatinné lázně a.s."
s datem splatnosti 05.08.1999 a částkou 100 CZK.

Celkový počet jiných závazků s tímto VS je 2.

Vložit data ?"

Informace o celkovém počtu závazků s tímto VS je uvedena proto, že zobrazené informace o platbě se týkají prvého nalezeného záznamu o platbě.

Testováno - různé varianty nastavení parametrů.

Galaxie - přegenerujte pohledy formuláře události plateb
Ing. Petr Filip 16.07.00


Informace o instalaci

Informace o instalaci
Právě nainstalovaná verze obsahuje programovou změnu, kterou bylo třeba udělat pro umožnění tisku v BM pro WEB (tou změnou je vytvoření společné tiskové podtřídy pro aplikaci BM pro WEB a BM).
Změny se mohou projevit v chybném chování programu zejména při výstupech.
Věnujte jim proto prosím větší pozornost.
Ing. Petr Filip 27.07.00


MZDY - výstup do EXCELU

MZDY - výstup do EXCELU
Přehled mzdových údajů v činnosti Prohlížení výplatních lístků.
Testováno na datech AdAudit.
RNDr. Jan Sekyra 18.07.00


Obecné výběry

Obecné výběry
Doplnění možnosti spuštění obecného výběru přímo ze záložky "Výběr".
Testováno spuštěním činnosti a aktivací normálního výběru.
Implementováno do všech susbsystémů kromě: BI, MZ, TPV, VYR, EXP. Pak též: SPOL, SYST.
Honza: implementováno do subsystémů TPV, VYR a MZ.
Jaroslav Janda ml. 03.07.00


Ovládání stromů

Ovládání stromů
Mírně poopraveno vyvolání menu na pravý klik ve stromech.

Testováno - zkoušky pravého tlačítka myši
Ing. Petr Filip 27.07.00


Předlohy výstupu

Předlohy výstupu
Vytvoření nové předlohy typu EXCEL je možné ve tvaru druhého typu (programovaná varianta)
Na formuláři výběru atributů je k tomu určeno zaškrtávátko "Excel typu2".
Dále se na tomto formuláři pro tento druh předlohy nově uplatňuje zaškrtávátko "Mezisoučet", které definuje sloupce, za které budou prováděny mezisoučty.
Výsledkem je předloha, která je naformátovaná a obsahuje libovolný počet mezisoučtů.
Tuto předlohu dále může implementátor upravovat.
Jako příklad upravené předlohy je v ostrém BM takto upravená předloha u činnosti "Obratová tabulka" - "Kontrola obratové tabulky"

Testováno - různé předlohy
Ing. Petr Filip 27.07.00


Předlohy výstupu

Předlohy výstupu
Předloha výstupu má novou vlastnost "Profil spuštění" (vlastnosti předlohy záložka Info), která definuje jak se má předloha chovat po jejím vyvolání dvojklikem nebo ikonou "tiskárna" ze seznamu předloh.
Jednotlivé profily se definují činností "Profily spuštění předloh" v podmenu "SYSTÉM" hlavního menu programu.
Definují to, zda má při odpovídajícím způsobu spuštění následovat přímo spuštění předlohy nebo rozhodnutí.
Dále se pro předlohy typu "Sestava" a "Excel" určuje kam má být výstup směrován (Tiskárna/Do souboru/Prohlížení).
Pro předlohy typu "Sestava" se navíc určuje, má-li při výstupu na tiskárnu předcházet výběr tiskárny.

Testováno - různé varianty profilů
Ing. Petr Filip 22.07.00


Předlohy výstupu

Předlohy výstupu
Dovolují vytvářet agregované výstupy.
Ve vlastnostech předlohy přibyla záložka "Seskupování", na kterou se uvádí informace potřebné pro vytvoření dotazu SQL s klauzulí GROUP BY.
Při zaškrtnutém "Seskupování" se zde v poli "Atributy a výrazy příkazu SELECT" uvádí část sestaveného příkazu mezi SELECT a FROM.

Např.:
MTUDA.sp60id MTARTIKL_sp60id,MTUDA.sp61id MTARTIKL_sp61id,MTUDA.mt04id MTUDA_mt04id,SUM(MTUDA.mt02mnr*(if MTUDA.mt02pv=1 then 1 else -1 endif)) MTUDA_mt02mnr

V poli "Doplnění klausulí" GROUP a HAVING" se uvádí odpovídají část dotazu.

Např.:
MTUDA.sp60id,MTUDA.sp61id,MTUDA.mt04id
HAVING MTUDA_mt02mnr<>0
ORDER BY MTUDA.mt04id,MTUDA.sp61id,MTUDA.sp60id

Uvedené příklady jsou vlastnosti zkušebních sestav událostí skladu.

Testování - sestavy událostí skladu v BM ostrá verze
Ing. Petr Filip 22.07.00


Předlohy výstupy

Předlohy výstupy
Ve vlastnostech předlohy je možné použít pravý klik na polích typu text.
Způsobí otevření okna pro text pro snadnější editaci větších textů.

Testováno - pravý klik na odpovídajících polích
Ing. Petr Filip 27.07.00


Strom procesu

Strom procesu
Oprava chyby, která nastávala při napojování procesu do procesu, ve kterém dosud neexistoval uzel charakteru proces s odpovídajícím druhem procesu.
Nově vložený uzel nesprávně dostával příznak počáteční operace procesu. Důsledkem toho bylo, že při rušení uzlu v diagramu se program pokoušel mazat ty, které neměly být logicky rušeny (z diagramu se při správné funkci rušení některého prvku mažou všechny uzly kromě počátečního, do kterých by nevedla žádná vazba).

Pro zobrazení chybných uzlů můžete použít příkaz v Centralu
SELECT * FROM bm_servis.SPPRCOD WHERE sp06idsubs=SPACE(3) AND sp34main=1
a opravit
UPDATE bm_servis.SPPRCOD SET sp34main=0 WHERE sp06idsubs=SPACE(3) AND sp34main=1

testováno - po opravě chyba nenastává
Ing. Petr Filip 28.07.00


Strom procesu

Strom procesu
Menu vyvolávané pravým klikem je možné vyvolat klávesou F6 a použít klávesovou zkratku F6+podtržený znak ve volbě.
V souvislosti s tím je třeba připomenout funkci klávesy CTRL+F10 (maximalizace okna)

Testováno - vyvolání menu klávesou F6
Ing. Petr Filip 16.07.00

Viz.také

Strom procesu

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Strom procesu

Strom procesu
Pokus o zrychlení načtení rozsáhlých procesů

Testováno - strom
Ing. Petr Filip 13.07.00


Strom procesu

Strom procesu
Pravý klik na operaci v procesu nabízí v menu možnost "Události operace".
Výběrem této volby se zobrazí krátký popis všech událostí operace.
Na takto zobrazených událostech nabízí pravý klik možnosti "Míra plnění - předchůdci" a "Míra plnění - následníci". Výběrem této volby se zobrazí události různých komponent, z kterých byla událost odvozena (resp.které vyvolala) a na nich je zase možné vyvolat předchůdce a následníky podle míry plnění.

Popis zobrazených událostí je předplňován v definici Galaxie (zatím pro komponenty DPH,OBC,PLA,SKL,UCE - první příklad).
V konkrétní implementaci BM je možné tyto definice změnit funkcí menu formuláře "Komponenty" (tj.definice pro celou komponentu) nebo ve formuláři "Druhy operací" (tj.definice jinak zobrazované informace ve stromu pro daný druh operace).
Ve výrazech (tvar FOX) je možné použít atributy, které jsou dostupné na formulářích událostí komponenty.

V souvislosti s těmito změnami byl doplněn export do balíčku druhů procesů.

Testováno - strom procesu, export do balíčku

Uživatelé Galaxie nechť přegenerují struktury souborů SPTYPUZ a SPKOMPUZ, vygenerují menu a přegenerují pohledy činností SPOL.
Ing. Petr Filip 13.07.00

Viz.také

Strom procesu

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Události obchodu

Události obchodu
Na druhou záložku přibyl atribut ob02volna N 20.4
Přidáno i do transformace.

Do gridu a do třídění bylo přidáno základ DPH v ZM, DPH v ZM, základ DPH v RM, DPH v RM.

Testování : Spuštěním formuláře.
Ing. Olga Smitková 17.07.00


Výstup do EXCELu

Výstup do EXCELu
Saldo pohledávek a závazků nad událostmi plateb.
RNDr. Jan Sekyra 10.07.00


WEB DEFINICE

WEB DEFINICE
je složka menu, která přibyla v menu SYSTÉM
Obsahuje funkce definování toho, jak má být vytvářeno menu v BM pro WEB.
Prvou činností "Definice WEB menu", se definuje struktura menu - definují položky typu menu 1 (mohou obsahovat pouze další podmenu), položky typu menu 2 (mohou obsahovat pouze listy) a listové položky (ekvivalent koncových položek menu).
Položky typu menu mohou mít nastavené vlastnosti "vrchol" (menu tj. menu bude dostupné na internetu), "default" (je vždy jediné a se použije jako vrcholové pro uživatele, kteří nemají uvedené "Explicitní WEB menu" (zadává se v seznamu uživatelů)).
Listové položky menu vyvolají při výběru buď internetovou adresu nebo pohled ve slovníku dat. Je-li funkcí vyvolání pohledu, je třeba zadat filtr pohledu a volitelně určit předlohu výstupu (v budoucím použití se provede výstup HTML nebo se přenese výstupní EXCEL dokument).
Každá položka menu je určitého druhu (druhá činnost v menu "WEB DEFINICE") a na tento druh vážou práva přístupu, která se projeví ve vytvořeném menu na internetu.
Každá položka se může vyskytovat ve více různých menu.

Tento nový způsob navigace v BM pro WEB umožní integrovat v menu informace z různých zdrojů a řešení (slovníku dat,externích řešení a případných dalších budoucích nástrojů vytvořených u nás).

Testováno - intranet BM
Ing. Petr Filip 20.07.00

Viz.také

WEB DEFINICE

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Formulář 'Číselné řady'

Formulář 'Číselné řady'
doplněna výběrová obrazovka, záložka s přehledem procesů s danou řadou, atribut poznámka k číselné řadě

Testováno : spuštění činnosti

Ing. Petr Filip 16.06.00


Formulář 'Seznam uživatelů'

Formulář 'Seznam uživatelů'
Uživatel nastavenou vlastností "Práva správce" (nový atribut). Má všechny možnosti správce (definování práv přístupu k činnostem, definování uživatelů, právo modifikovat předlohy výstupu s přístupem čtení,...) s výjímkou základního menu, které se zobrazuje podle jeho zařazení do skupin uživatelů.

Testováno - formulář "Seznam uživatelů", definování přístupových práv k činnostem, předlohy výstupu

Pro Galaxii vygenerujte soubor SPPRISTV, přegenerujte pohledy SYST
Ing. Petr Filip 16.06.00


Formuláře - 'Uživatelé systému' a

Formuláře - 'Uživatelé systému' a
'Skupiny uživatelů'
byly doplněny o záložky s aktuálním přehledem skupin uživatele resp. uživatelů ve skupině.
Doplněn tisk ve formuláři 'Skupiny uživatelů' o pohyb 'Uživatelé ve skupině'
Testováno - spuštění formulářů
Ing. Petr Filip 20.06.00


Formuláře - 'Uživatelé systému' a

Formuláře - 'Uživatelé systému' a
'Skupiny uživatelů'
Doplněna záložka "Přístupy k věcem", která zobrazuje veškerá práva definovaná v systému kromě práv přístupu k činnostem.
Zobrazené popisy jsou obsažené v tabulce SPPRISTV, který je nadtypem ke všem tabulkám druhů definujících práva. Tento soubor je aktualizován triggery, teprve od této verze BM, proto je třeba naplnit ho dávkou - volbou "Aktualizace ..." v těchto formulářích.

Testováno : spuštění formulářů

Pro Galaxii vygenerujte soubor SPPRISTV, přegenerujte pohledy SYST a SPOL, přegenerujte druhy
Ing. Petr Filip 16.06.00


Mzdový list - kalendářní dny

Mzdový list - kalendářní dny
V typech řádků výkazu je přidán atribut typ s hodnotami : "-,pracovní dny,kalendářní dny,peníze,hodiny,další1,další2,další3.

Na identifikaci typu řádku již nyní nezáleží (P,D,H), ale záleži na nastavení tohoto nového atributu.

JE NUTNÉ U NÁS, VE FRAGMENTU A U AUDITORů NASTAVIT SPRÁVNĚ HODNOTY V ČINNOSTI " TYPY ŘÁDKů PRO VÝKAZY" - nový atribut.

U nás nastaveno 21.6.2000

Testováno : výpočet výkazu jednoho a všech pracovníků.
Ing. Olga Smitková 20.06.00

Viz.také

Mzdy- oprava výpočtu mzdového listu


Mzdy- oprava výpočtu mzdového listu

Mzdy- oprava výpočtu mzdového listu
pro jednoho pracovníka a následně oprava prohlížení mzdových listů.
zdroj : Ing. Novosvětský

testováno : výpočtem jednoho mzdového listu a výpočtem všech mzdových listů - včetně kontroly správnosti čísel dle definice mzdového listu

další požadavek: umožnit výpočet řádku typu "kalendářní dny", typ P slouží pro pracovní dny - doděláno 20.6.2000 - viz svázaná vývěska
Ing. Olga Smitková 19.06.00

Viz.také

Mzdový list - kalendářní dny


Mzdy - dělení nulou

Mzdy - dělení nulou
v činnosti "Výplatní lístky" - zdrojích MZ0028DN a MZ0032KO bylo odstraněno možné dělení nulou.

Tyto zdroje zajišťují výpočet dnů, pokud znám hodiny a výpočet celkové částky Kč. Pokud pracovník má kalendář, který má FPD (fond pracovní doby) v počítaném měsíci nulový, docházelo by k dělení nulou.

Nyní v takovém případě bude počet dnů nula a Kč také nula.
Ing. Olga Smitková 19.06.00


Mzdy - do parametrů přidán datum výplaty

Mzdy - do parametrů přidán datum výplaty
mezd.
Dále pak nastavení datumu výplaty, pokud běžný den výplaty připadá na sobotu nebo neděli.

testováno : spuštěním formuláře

S tím souvisí sestava "Sociální pojištění - BM", která se spouští z "Odvody soc. pojištění".

Sestava testována na datech ADaudit, po nahrání nové verze u nás je nutné upravit tuto sestavu i u nás.
Ing. Olga Smitková 23.06.00


Mzdy - EXCEL - sestava hrubé

Mzdy - EXCEL - sestava hrubé
mzdy dle selektorů. Spouští se z "Prohlížení výplatních lístků".

Vypracoval Honza na datech ADaudit.
Testováno : Honza - AD audit, Olina - na našich datech

Poznámka : Sestava naplňuje tabulku - je nutné trochu posečkat.
Ing. Olga Smitková 29.06.00


Mzdy - funkce nad labelem pracovníka

Mzdy - funkce nad labelem pracovníka
Na kartě pracovníka je TUČNĚ zapsáno OSC (osobní číslo pracovníka) a z něj se pravým klikem rozvíjí menu s činnostmi -
- události mezd
- nepřítomnost pro nemoc
- jednotlivé výčetky platidel
- prohlížení výplatních lístků

Na Kartě pracovníka je též tučně ADRESÁT a na něj jsou navázány činnosti pro adresáta obvyklé.

V analýze se zpracovává možnost úplného zrušení pracovníka (mz01id) a nahrazení adresátem (ad01id) - prolíná se celým blokem mezd.
Ing. Olga Smitková 19.06.00


Mzdy - nepřítomnost pro nemoc - Do

Mzdy - nepřítomnost pro nemoc - Do
Oprava validace položky "Do". Od a Do se nesmí překrývat s jinou nepřítomností. Situace, že Od = Do byla původně vyhodnocena jako chybná. Nyní se Od a Do může rovnat.

Testování : 1) zadání nemoci, kde Od je 15.5.2000 a Do je 15.5.2000
2) zadání nemoci, kde Od je 15.5.2000 a Do je 16.5.2000
Ing. Olga Smitková 02.06.00


Mzdy - oprava šablony pro výstup z mezd

Mzdy - oprava šablony pro výstup z mezd
do plateb - souhrn.
Testováno na datech AdAudit.
RNDr. Jan Sekyra 20.06.00


Mzdy - Podklad pro ELDP

Mzdy - Podklad pro ELDP
Výstup do EXCELU
Testování:
- na datech AdAudit výstup jednoho i všech pracovníků
- na pracovníkovi s datem vzniku prac. p. v roce výpočtu
- na pracovníkovi s datem ukončení prac. p. v roce výpočtu
- nápočet dnů neplac. volna, nemoci a ošetřování
- nápočet vyměř. základu soc. poj. a částek soc. dávek
RNDr. Jan Sekyra 02.06.00


Mzdy - Přehled výpočtu nemoc. dávek

Mzdy - Přehled výpočtu nemoc. dávek
Sestava.
Testováno na datech Adaudit.
RNDr. Jan Sekyra 06.06.00


Mzdy - události mezd - grid

Mzdy - události mezd - grid
do gridu přidáno číslo, příjmení, jméno a titul pracovníka.
Třídí se dle OSC (čísla pracovníka).
Ing. Olga Smitková 19.06.00


Mzdy - výplatní lístky

Mzdy - výplatní lístky
Chyba : když dám na výběru ESC, padá to, hlásí nesoulad mezi typy operátoru a operandu

Odstraněno
testováno : spuštěním činnosti (ESC i PgDn)
Ing. Olga Smitková 07.06.00


Mzdy - Výplatní lístky

Mzdy - Výplatní lístky
Změna v pořadí atributů "v penězích", "tisknout" a "poznámka". Vyplňují se až po zadání selektorů.

Testováno : zadání položky mezd do výplatního lístku.
Ing. Olga Smitková 02.06.00


Mzdy - výpočet jednoho a všech výplat.

Mzdy - výpočet jednoho a všech výplat.
lístků.

Při výpočtu výplatních lístků (jednoho i všech) se do atributu mz02dnukal (dnů kalendářních) zapíše počet kalendářních dnů v případě nemoci, ošetřování a mateřské (mz28pdruh3 = 1,3,7). Údaje se zjistí z činnosti "Nepřítomnost pro nemoc".
Platí pro malou i velkou organizaci.

Využije se v sestavě "Přehled výpočtu nemoc. dávek".

Testováno : na datech AD audit (00615 -pí. Erlebachová), přepočet jednoho výplatního lístku a přepočet všech výplatních lístků.

Honza:
Výplatní lístky pořízené ve verzi bez této úpravy bude třeba
pro správný nápočet ELDP aktualizovat ručně.

Ing. Olga Smitková 07.06.00


Návrh úpravy modulu nemoc. dávek

Návrh úpravy modulu nemoc. dávek
Popis je v napojeném dokumentu.
RNDr. Jan Sekyra 09.06.00


Obecné výběry

Obecné výběry
bude možné zadávat na výběrové záložce formuláře.
(pro takto upravené formuláře se zároveň tímto odstraňuje chybné zobrazení názvu výběru na dolní liště při vyvolání obecného výběru přednastavením v menu)

Testováno - formuláře s výběry SPOL

Pro zařazení této možnosti je třeba :
1.přidat do výběrové entity atribut "sp27idpohl" se všemi přednastavenými vlastnostmi
2.entitu vygenerovat
3.umístit v "Prostředí-atributy" před "sp00savefi"
4.vložit v aktivaci výběru místo příkazu "this.aktivuj_pohled(this.prepar)" příkaz "this.aktivuj_obecny_vyber(this.xxxx.sp27idpohl)" (kde xxxx je název výběrové entity)
5.umístit na obrazovce před "Uschovat"

Všechny běžné formuláře doplníme touto možností do 30.6.
Ing. Petr Filip 20.06.00


Oprava tisku dokladů

Oprava tisku dokladů
z označených procesů
Testováno - výstupy na datech Obalu
Ing. Petr Filip 07.06.00


Párování úhrad na platby

Párování úhrad na platby
Oprava - párovaná částka se předplňuje se znaménkem mínus - při párování CRxzávazek nebo DBxpohledávka
Barva datumu - červená - spárovaná částka neodpovídá částce v události změny stavu peněz (to je v pořádku jedná-li se o sdruženou úhradu několika plateb, jinak chyba)
Testováno : párování různých variant úhrad a plateb
Ing. Petr Filip 16.06.00


Podvojnost při ukončení operace

Podvojnost při ukončení operace
Při ukončení operace nebyla hlídána podvojnost, neboť při zrušení události byla přeskočena kontrola podvojnosti spouštěna před uložením dat.

Zařazena metoda valid_ukonceni_operace(). Testována při otevření operace, zrušení záznamu a ukončení operace.
Jaroslav Janda ml. 21.06.00


Programová dokumentace

Programová dokumentace
Jaroslav Janda ml. 07.06.00


Předlohy výstupu

Předlohy výstupu
Rozšíření atributů o : druh předlohy, zakladatel předlohy, skrytá všem
Druh předlohy definuje práva - žádný přístup, čtení, zápis
Uživatel s právem přístupu čtení, který není správcem systému ani autorem předlohy nemůže předlohu kopírovat, rušit, opravovat, nejsou mu dostupné vlastnosti předlohy
Je možné definovat druh předlohy, který není dostupný žádnému uživateli systému a na něj "odkládat" předlohy, které není možné zrušit nebo u kterých není jisté, zda bude třeba danou předlohu někdy v budoucnu použít.
Druh předlohy je proto možné měnit v činnosti "Seznam předloh výstupu" (na F2 se zde druhy předloh definují)
Předloha s nastavenou vlastností "skrytá všem" je skrytá všem bez ohledu na privátní nastavení vlastnosti "skrytá".

Testováno : různé varianty práv k druhům předloh

Pro Galaxii vygenerujte soubor BWPRINTD,BWPRINTT, přegenerujte pohledy SYST a SPOL, přegenerujte systémové pohledy, založte druh předlohy "-", přegenerujte soubor BWPRINTD

Ing. Petr Filip 16.06.00


Přehled prováděných činností

Přehled prováděných činností
nová činnost menu 'SYSTÉM'.
Provizorní, zatím nemá tisk.
Testováno - spuštění formuláře - test výběrů
Ing. Petr Filip 20.06.00


Přidat do výběru mezd příjmení prac.

Přidat do výběru mezd příjmení prac.
Do těchto činností (do jejich výběru) je přidáno příjmení, jméno a titul pracovníka .
- události mezd
- úkolové listy
- karta pracovníka
- nepřítomnost pro nemoc
- prohlížení výplatních lístků
- jednotlivé výčetky platidel
- odvody soc. poj. dle lidí
- odvody zdrav. poj. - lidi (dodělán i výběr na OSC)
- roční zúčtování daně
- historie údajů na kartě (promítá se i do uzávěrky)
- historie pracovního poměru (promítá se i do uzávěrky)

U činnosti "Výplatní lístky" je OSC povinné, takže výběr dle příjmení, ... je diskutabilní. Ponecháno další analýze.

Testováno: Spuštěním příslušných činností.
Dne 20.6.2000 opravena ve všech těchto činnostech možnost tisku - testováno - spuštěním sestav.

Dne 11.7.2000 chyba MZ0074_MZPOJSUM - MZKARTA3 not found - opraveno v činnostech Odvody zdrav. poj. - lidi a Sumář odvodů zdrav. poj. . Testováno spuštěním činností. (Byl tam společný kontejner a podmínka v prostředí).
Ing. Olga Smitková 15.06.00


Příkaz k úhradě - omezení

Příkaz k úhradě - omezení
úkol : nedovolit vystavit příkaz k úhradě na neukončenou operaci (stornovaný, stornující proces), vždy s KLADNOU částkou

provedení : do činnosti události plateb přidána entita PLUDA - SPPRCOD2, atributy sp34ukonce, sp34ukoncp, sp33storno
v činnosti Příkaz k úhradě upraven kód - podmínka a ABS

testování :
pokus o uhrazení platby :
1) neuhrazená, nestornovaná, ukončená - ANO
2) uhrazená, nestornovaná, ukončená - NE
3) neuhrazená, stornovaná, ukončená - NE
4) neuhrazená, stornující, ukončená - NE
5) neuhrazená, nestornovaná, neukončená - NE
6) záporná pohledávka - částka v ZM záporná
- záloha v ZM - záporná
-částka na příkazu - KLADNÁ
Tento bod nutno konzultovat s Mirkou.
Tisk příkazu k úhradě - vše kladné.
Ing. Olga Smitková 14.06.00


Saldo do data

Saldo do data
Popis:
Nezohledněno jiné párování.

Testování:
Změnou vlastnosti události a opětovným spuštěním činnosti
Jaroslav Janda ml. 07.06.00


storno - chyba

storno - chyba
Chyba : Vlastnost ALIAS - PREPISU nebyla nalezena.
Při stornu procesu.

Opraveno v komponentě plateb.
Ing. Olga Smitková 05.06.00


Testování aktualizace zůstatku dovolené

Testování aktualizace zůstatku dovolené
na kartách pracovních poměrů pracovníků uzávěrkou mezd na datech AdAudit.
Provedena uzávěrka mezd za leden, únor a březen 2000.
Karty za leden a za únor byly aktualizovány správně.
Při uzávěrce března se objevila progr. chyba "Numerické přetečení. Došlo ke ztrátě dat..." a žádná z karet nebyla zaktualizována. Po zopakování březnové uzávěrky se objevila táž chyba, ale všechny karty byly zaktualizovány správně.

Olina (19.6.2000): Numerické přetečení bylo vlivem dělení nulou - pracovník měl kalendář "-", kde byl počet hodin 0.
RNDr. Jan Sekyra 16.06.00


Transformace - saldokontní hodnota

Transformace - saldokontní hodnota
ve výrazu transformace.
Saldokontní hodnotu aktuálního hlavního procesu je možné vyvoláním metody "saldo" v syntaxi:
~~this.saldo([typ],[druh hodnoty],[druh artiklu],[artikl])
kde [typ] je pro budoucí použití uvádějte "1"
[druh hodnoty] je druh saldokontní hodnoty
[druh artiklu] je identifikace druhu artiklu
[artikl] je identifikace artiklu
Metoda vrací sumu za daný druh saldokontní hodnoty a artikl.
Testováno na výrazu - ~~LTRIM(STR(this.saldo('1','SALDO',Data.sp61id,Data.sp60id))) v datech Fragmentu - transformace v procesu převod od distributora
Ing. Petr Filip 02.06.00


Transformace - vyvolání funkce

Transformace - vyvolání funkce
ve výrazu transformace do atributu typu text.
Je možné uvedením dvou znaků vlnovka na začátku výrazu.
Testováno - Fragment - transformace v procesu převod od distributora
Ing. Petr Filip 02.06.00


Události obchodu

Události obchodu
K atributu sp60id (artikl) přidán reset atributu ob02cj01c (cena za jednotku).

Při opravě artiklů na události se nepřepisovaly ceny.

Testováno : zadání a opravou událostí obchodu.
Ing. Olga Smitková 23.06.00


Úpravy v modulu nemoc. dávek

Úpravy v modulu nemoc. dávek
podle návrhu.
Testováno:
- výpočet dávky nemoci celé v měsíci
- výpočet dávek nemoci přes měsíc
- výpočet dávek nemoci přes období se změnou parametrů
- výpočet dávky za ošetřování
Dne 19.6.2000 kontrolovala Olina - v pořádku (nepřítomnost pro nemoc, parametry, uzávěrka) - později se pravděpodobně odstraní (alespoň vizuálně) některé atributy ze "starých" parametrů.
RNDr. Jan Sekyra 16.06.00


Valid data v ÚČ

Valid data v ÚČ
V účetnictví je zakázáno účtovat dopředu, proto byl zařazen test na datum, které nesmí být větší než dnešní.

Testováno zakládáním událostí s vyšším datem než dnešním.
Jaroslav Janda ml. 21.06.00


Volné karty

Volné karty
Menu "Obecné" formulářů událostí komponent bylo rozšířeno o "Volné karty adresáta" a "Volné karty artiklu (SP)" (karty nadtypového artiklu SPARTIKL).
Proto je vhodné definovat volné karty, která se týkají adresáta (např. stav pohledávek) nad adresářem a ty které se týkají artiklu (např. aktuální množství artiklu na skladech) nad SPARTIKL.
Menu "Obecné" formulářů artiklů v podmenu "Voné karty" nabízí, kromě vlastních vlastních volných karet také volné karty SPARTIKL.

Testováno - formuláře komponent a artiklů
Ing. Petr Filip 16.06.00


Volné karty

Volné karty
Oprava zobrazení volných karet (na které nemá právo přístupu každý) v menu po přihlášení uživatele.

Testování - bude prověřeno na naší verzi
Ing. Petr Filip 16.06.00


Výkazy ÚČ

Výkazy ÚČ
Spuštění excelovských maker pomocí konstrukce "spustitmakro=". Viz. dokumentace.
Jaroslav Janda ml. 22.06.00


Vymáhání - dle textu upomínky

Vymáhání - dle textu upomínky
Oprava systému vymáhání pohledávek. Přidána možnost "Podle dat (texty)". Znemožněno poslat po první upomínce upomínku třetí a druhou vynechat.
Změny provedeny v kódu po otevření činnosti Události vymáhání a v činnosti Parametry výpočtu vymáhání. Trigger v PLUDA neměněn.

Testováno : několikeré upomínání tří pohledávek typem "podle dat (texty)"
(splatnost vše 29.2.
- první pohledávka upomínána 22.3. - text1, 1.4. - text2, 1.5. - text3, 6.6. - text4
- druhá pohledávka upomínána 12.3. - text1, 1.4. - text2, 10.4. - text3. 6.6. -text4
- třetí pohledávka upomínána 15.3. - text1, 21.3. - text2, 10.4. - text3. 6.6. -text4)
Ve způsobu vymáhání nastaveno : 10 dnů - text1, 20 dnů - text2, 30 dnů - text3, 40 dnů - text4.
Dokumentace : viz dokument
Ing. Olga Smitková 06.06.00


Změna pořadí položky hlavního menu

Změna pořadí položky hlavního menu
Opraveno padání programu tvrdou chybou.

Testováno - změna pořadí položek nejvyšší úrovně menu
Ing. Petr Filip 20.06.00


ZSP bankovní spojení

ZSP bankovní spojení
Nalezení v ADBUCTY i podle SS. Napojení číselníku bank přes F2 nad id.banky (oc02idbank)

Testováno na hledání "normalního" účtu, na hledání účtu české spořitelny tj. se SS. F2 na id banky a návrat hodnoty.
Jaroslav Janda ml. 09.06.00


Bibliografie - třídění děl při pročíslov

Bibliografie - třídění děl při pročíslov
bere v úvahu anglické a německé členy (mimo "A") na začátku názvu díla.
Kromě toho je možné potlačit třídění podle českého CH.
Testováno - funkce pročíslování katalogu
Ing. Petr Filip 25.05.00


Bibliografie - změna pořadí díla v katal

Bibliografie - změna pořadí díla v katal
oprava chyb - vyřešeno triggerem nad tabulkou BIKAKART
Testováno - změna pořadí díla v kapitole
Ing. Petr Filip 25.05.00


Definování nabídek

Definování nabídek
uvedení znaku vlnovka v textu názvu ikony znamená, že na odpovídající tlačítko bude přenesen text za vlnovkou
Testování - vytvoření uživatelské nabídky
Ing. Petr Filip 31.05.00


Definování nabídek

Definování nabídek
nabídky je možné exportovat do balíčku tlačítkem "Export" ve formuláři "Definování nabídek"
Testováno - export a import balíčku
Ing. Petr Filip 31.05.00


Dokument spojený s objektem

Dokument spojený s objektem
vyvolaný po klávese CTRL + D
Založení nového dokumentu - přenese text definovaný v parametrech činnosti v GALAXII |#OBJECT (potřeba prověřit nastavení tohoto parametru)
Testováno - nový dokument nad objektem dokumentu
Ing. Petr Filip 29.05.00


Doplnění funkčnosti programového výstupu

Doplnění funkčnosti programového výstupu
a do HTML.
Viz.dokument.
Testováno - "Pokladní kniha" události ZSP (verze BM) a "Peněžní deník" události účetnictví (verze AKM ostrá data)
Ing. Petr Filip 25.05.00


Dotaz 'Statistika SQL' z menu 'Obecné'

Dotaz 'Statistika SQL' z menu 'Obecné'
vrací na prvním řádku název vzdáleného pohledu.
Testováno - dotazy na několika formulářích
Ing. Petr Filip 30.05.00


Formulář "Parametry uživatele"

Formulář "Parametry uživatele"
neprovádí změnu zobrazení velikosti formuláře podle parametru, který se v něm zadává tak, aby bylo možné tento parametr změnit při zadání hodnoty, která neodpovídá rozlišení obrazovky
Testováno - spuštění při zadaném velkém zvětšení
Ing. Petr Filip 25.05.00


Formuláře - procesů, operací a

Formuláře - procesů, operací a
saldokontních hodnot procesů ("nedokončené procesy"), byly doplněny o záložku "Operace hlavního procesu", ve které se zobrazuje seznam všech odpovídajích operací komponent, které jsou ve stejném hlavním (saldokontním) procesu.
Seznam je setříděn podle data zahájení operací.
Operace dosud nezahájené jsou na jeho začátku zobrazené modrou barvou.
Z formuláře "Procesy" byla odstraněna záložka "Zdrojové operace".
Testováno - spuštění všech tří formulářů
Ing. Petr Filip 25.05.00


Funkce zařazení a vyřazení procesu

Funkce zařazení a vyřazení procesu
z hlavního stromu procesu byly doplněny k formuláři "Hlavní strom procesu".
Pravým klikem nad uzlem procesu, byla doplněna nabídka:
"Kopírovat odkaz na proces" - kopíruje odkaz na proces pro následující volbu
"Vložit proces XXXX" - vloží proces vybraný použitím přechozí volby - přitom přepočte účetní a procesní saldokonto
"Osamostatnit proces" - vyjme proces ze zobrazeného hlavního procesu - přitom přepočte účetní a procesní saldokonto
Testováno - funkčnost voleb, kontrolován přepočet účetního saldokonta
Ing. Petr Filip 25.05.00


Nový parametr uživatele -

Nový parametr uživatele -
Stránka výběru po spuštění č. "Procesy","Operace".
Jeho zaškrtnutí způsobí po spuštění těchto činností přechod na výběrovou stránku.
Testováno - spuštění činností s nastaveným a nenastaveným parametrem, spuštění souvislostí objektů
Ing. Petr Filip 25.05.00


Objekt - "Příkaz k úhradě"

Objekt - "Příkaz k úhradě"
byl implementován v subsystému platby.
Testováno - běžné akce s objektem
Ing. Petr Filip 25.05.00


Objekt - 'Proces'

Objekt - 'Proces'
byl implementován v subsystému informační centrum (SPOL).
Testováno - běžné akce s objektem
Ing. Petr Filip 25.05.00


Oprava chybného chování po výběru

Oprava chybného chování po výběru
plateb při vytváření příkazu k úhradě
1. po vyvolání formuláře událostí plateb již není možné se přepnout zpět na formulář příkazů
2. po ukončení formuláře plateb je vyvoláno správné menu
Testování - vytvoření příkazu k úhradě
Ing. Petr Filip 25.05.00


Oprava zobrazení popisu objektu

Oprava zobrazení popisu objektu
při zobrazení souvislosti ve změněném měřítku zobrazení formuláře
Testováno - souvislost objektu 'Proces' a 'Událost DPH'
Ing. Petr Filip 25.05.00


Párování úhrad na platby

Párování úhrad na platby
v dolní mřížce spojených plateb - se zobrazuje název a identifikace adresáta.
Testováno - zobrazení existujících vazeb, párování klávesou F5, párování klávesou F9
Ing. Petr Filip 29.05.00


Pokladní kniha

Pokladní kniha
nový výstup do EXCELU nad událostmi ZSP.
Testován - výstup
Ing. Petr Filip 25.05.00


Saldo do data

Saldo do data
Popis:
- násobený seznam událostí ve skladbě saldokonta

Testování:
- BM data, spuštění činnosti
Jaroslav Janda ml. 31.05.00


Velká písmena v umístění na události

Velká písmena v umístění na události
obecné komponenty a v číselníku umístění obecné komponenty. Do příslušného atributu lze nyní zapisovat pouze velká písmena. Na žádost Mirky.

Testováno : zadání nového umístění do číselníku a zápis jedné události obecné komponenty.
Ing. Olga Smitková 30.05.00


Výběry

Výběry
Popis:
- přidání výberového kritéria číslo dokladu do, druh procesu do činnosti "Událost..."
- navěšení činnosti druh operace, druh procesu
- DPH, Expedice, Pošta, Odpisy, Účetnictví, Sklady, Obchod, ZP, Platby, OK

Testování:
- spuštění činnosti, výběr pouze jednoho čísla, výběr intervalu od do, výběr na druh procesu,
- spuštění navěšených činností druh operace a procesu

Jaroslav Janda ml. 31.05.00


Vyvolání obecného výběru

Vyvolání obecného výběru
používá k sestavení dotazu nově i odvozené pohledy spojené s formulářem.
Odvozený pohled je použit např. u formuláře plateb v dotazu, který obsahuje zadaný účet účetnictví nebo formulář adresáře s dotazem na příslušnost v kategorii.
Testováno - formuláře "Procesy","Operace","Události plateb","Díla bibliografie"
Pro tuto funkci je třeba přegenerovat činnosti, které obsahují odvozené pohledy
Ing. Petr Filip 30.05.00


Změna algoritmu vyřazení díla z kapitoly

Změna algoritmu vyřazení díla z kapitoly
vyřešeno triggerem
Testováno - po vyřazení nebo zařazení díla do kapitoly katalogu dojde k správnému posunu pořadí děl v následujících kapitolách
Ing. Petr Filip 25.05.00


Je určeno pro definování stylů pro zobrazení stránky informačního panelu

Tato činnosti je určena pro nastavení stylů pro zobrazení stránky informačního panelu. Definuje se :

¨ identifikace a název prezentace

¨ popis stylu stránky - HTML text, který definuje styly

¨ kód hlavičky – umožňuje nastavit přizpůsobení vzhledu hlavičky informačního panelu. Tento kód (v jazyce Foxpro) musí vracet textovou hodnotu. Text vrácený kódem hlavičky je ve výsledném obsahu HTML souboru uložen za koncový tag HEAD.

¨ kód patičky - umožňuje nastavit přizpůsobení vzhledu patičky informačního panelu. Tento kód (v jazyce Foxpro) musí vracet textovou hodnotu. Text vrácený kódem patičky je vložen na konec HTML souboru a musí obsahovat koncový tag BODY.

Na stránce informačního panelu je možné vytvářet odkazy, které způsobí vyvolání programu Windows (jiného než internetový prohlížeč) a v něm otevření souboru, který odpovídá celé zobrazené stránce (může to být více tabulek) nebo jednotlivé tabulce zobrazené na stránce. Při vytváření stránky informačního panelu je dostupná vlastnost řídícího objektu vytváření stránky OUTPUT_FORMAT, která má při vytváření běžné stránky zobrazované v internetovém prohlížeči hodnotu 'prázdný text' a při vytváření stránky určené pro zobrazení v programu Windows obsahuje hodnotu, kterou je tříznaková přípona souboru. Přitom platí, že je-li stránka vytvářena s nastavenou vlastností OUTPUT_FORMAT řídícího objektu, potom do vytvářených tabulek nejsou vkládány hypertextové odkazy, je potlačeno vytváření automatických hlaviček a patiček stránky a po vytvoření stránky je vyvolán program Windows podle uvedené přípony (hodnoty vlastnosti OUTPUT_FORMAT).

Do stránky informačního panelu je možné vkládat hypertextové odkazy, které zajistí vytvoření stránky s nastavenou vlastností řídícího objektu vytváření stránky OUTPUT_FORMAT třemi způsoby:

- v kódu patičky prezentace stránky

- ve vlastnosti POSTTEXT definice uzlu informačního panelu

- hypertextovým odkazem, který je součástí tabulky informačního panelu

K tomuto účelu slouží např. uživatelská knihovna vkládaného kódu USRPAN. S knihovnou USRPAN je možné zadat v kódu patičky prezentace stránky nebo ve vlastnosti POSTTEXT definice uzlu informačního panelu kód:

<pre>

#SCRIPT

Return zobrazit_v_excelu_a_wordu(_this)

#INCLUDE USRPAN

</pre>

Takto budou do stránky vloženy hypertexty, které převedou do programu Windows celou zobrazenou stránku (může to být více tabulek).

Při vytváření stránky určené pro zobrazení v programu Windows je pro úspěšné uplatnění stylů nutné, aby styly byly přímo obsaženy v souboru předaném programu Windows. Proto je třeba zasáhnou do popisu stylu v prezentaci stránky informačního panelu a v jeho kódu podmínit v případě, že je nastavena vlastnost OUTPUT_FORMAT řídícího objektu, vložení textu stylů do vytvářené stránky.

Např. s užitím knihovny USRPAN:

<pre>

#SCRIPT

Return vrat_styl(_this)

#INCLUDE USRPAN

</pre>

V některých případech je vhodné pro výstup stránky do programu Windows vyloučit některé sloupce tabulky, řádky tabulky,prvky stránek nebo celou jednotlivou tabulku zobrazenou na stránce (poslední platí pro hypertexty v kódu patičky prezentace stránky nebo ve vlastnosti POSTTEXT definice uzlu informačního panelu). V tom případě je možné uvádět ve vlastnosti Podmínka v definici takového sloupce, řádku, prvku stránky nebo podřízeného uzlu výraz 'EMPTY(this.output_format)'.

¨ popis stylu prvku stránky - kód v jazyce Foxpro, který vrací text doplňující formát prvku

¨ atributy elementů TR – zde se uvádějí jednotlivé HTML atributy elementu následované výrazem v jazyce Foxpro oddělené klávesou Enter, např. BGCOLOR=IIF(MOD(this.citac_radku,2)=1,'YELLOW','') – stejné nastavení je možno uvádět také u jednotlivých řádků v činnosti definice uzlů inf. panelů. V případě, že je uvedeno nastavení u jednotlivého řádku v definici uzlů inf. panelů a rovněž zde v prezentaci stránek panelů, potom se uplatní obě tato nastavení.

¨ poznámka


INFORMACE O ADRESÁTOVI

Popis

Tuto činnost lze vyvolat z kterékoliv činnosti, která pracuje s určitým adresátem. Je možno ji vyvolat i z menu (položka Volby). Nabízejí se tyto možnosti:

¨ vývěska adresáta

¨ pošta adresáta

¨ adresář

¨ spojení

¨ adresy

¨ bankovní spojení

¨ aktuální hodnoty plateb

Pokud je položka "adresát" na obrazovce zvýrazněna tučně, je toto menu možno vyvolat klikem myši přímo z této položky. Klikem myši na vybrané činnosti dojde rovněž k její aktivaci.

Upozornění:

Tyto činnosti jsou vztaženy pouze k aktuálnímu adresátovi a poskytují uživateli základní informace o něm.

Viz.také

UDÁLOSTI ADRESÁTA | AKTUÁLNÍ HODNOTY ADRESÁTA | OBRATOVÉ HODNOTY ADRESÁTA | Adresář | Adresy adresátů | Spojení adresátů | Bankovní spojení adresátů | Cenové skupiny adresáta | Předkontace adresáta | Strom adresáta | Vztahy obchodovatelných artiklů k adresátům


Označování podle kategorií

Popis

Tuto funkci uživatel využije při práci s adresářem v tom případě, že jednotlivé adresáty má zařazeny v kategoriích. Pak je možno tuto funkci využít např. při odesílání informačních mailů pouze pro vybranou kategorii (nebo více kategorií) adresátů, tzn. uživatel si na základě vybraných kategorií adresáty označí a tyto označené pak přenese do poštovní zásilky. Při aktivaci tohoto označování podle kategorií se uživateli jako první zobrazí okno, kde si jednotlivé kategorie vybere (přesune pomocí tlačítka se šipkou). V případě, že si vybere více kategorií, je nutno u těchto kategorií určit příznak „nebo“ a „a zároveň“, tzn. zda označovaní adresáti mají být v té a nebo v té kategorii a nebo jestli mají být zároveň v obou kategoriích. Poté stiskne tlačítko „vpřed“ v dolní části okna.

V případě, že si uživatel u jednotlivých adresátů eviduje jejich časovou příslušnou v kategorii, využije na druhém okně volbu „zpracovat příslušné do kategorie za období“. V takovém případě pak musí mít vyplněnu kolonku od data – do data. Např. výběr od 25.8.1995 do 15.1.2006 vybere všechny adresáty, kteří v tomto období do kategorie byli zařazeni, ale i ty, kteří byli v tomto období vyřazeni, prostě jedno datum jejich příslušnosti do kategorie spadá do zvoleného období. V případě, že uživatel chce aktuální přehled adresátů k vybranému dni, zadá období od -do v tomto tvaru, od 1.1.2006 do 1.1.2006. Zaškrtávátko „bez přerušení“ zajistí, že budou vybráni ti adresáti, jejichž přítomnost v kategorii nebyla v daném období skončena a za nějaký čas znovu obnovena, tzn. přítomnost adresáta v kategorii nebyla přerušena.

Pokud uživatel nezpracovává období adresáta v kategorii, nechá tuto volbu prázdnou a opět stiskne tlačítko „vpřed“.

Další okno nabízí uživateli možnost zvolit si způsob označení, tzn. že se mají vybraní adresáti rovnou označit. V případě, že uživatel měl již před touto volbou nějaké adresáty označeny, může jim toto označení i zrušit (volba „předtím zrušit aktuální označení“). Pak uživatel znovu stiskne tlačítko „vpřed“. Poslední okno uživateli poskytne konečný přehled nadefinovaného označování. V případě, že uživatel s touto informací souhlasí, stiskne tlačítko „dokončit“. V posledním okně se uživateli zobrazí průvodce označováním, který mu poskytne informaci o konečném výsledku označování. Po stisku tlačítka OK je označování podle kategorií dokončeno a uživatel je vrácen zpět do adresáře, kde si pod volbou označování zvolí možnost „přehled označených“. V případě, že by chtěl některou informaci před dokončením označování ještě změnit, může využít tlačítka „zpět“.


Změna implicitního spojení

Popis

Pomocí této činnosti provede uživatel změnu nastaveného implicitního spojení u vybraného adresáta. Implicitní spojení je to spojení, které se uživateli zobrazuje při prohlížení adresáře a při práci s adresátem (např. na vývěsce, poště apod.).

Postup při změně implicitního spojení je následující:

¨ uživatel si v adresáři aktivuje záložku "spojení adresáta".

¨ v levé části okna je přehled všech zadaných spojení adresáta. Uživatel umístí kurzor na zvolené spojení a následným spuštěním činnosti změna implicitního spojení (menu Volby nebo Ctrl I) nebo stiskem tlačítka Impl. je toto vybrané spojení přiřazeno danému adresátovi jako implicitní. Při spuštění činnosti adresář se potom zobrazuje právě toto spojení.


Adresy

Popis

Uživateli se zobrazuje přehled adres u jednotlivých adresátů. U každé jednotlivé adresy se vstupují tyto údaje:

¨ číslo adresy

¨ ulice

¨ město - tj. PSČ a město (je možno ho vybrat z číselníku)

¨ stát

¨ poznámka k dané adrese

Nové adresy k vybranému adresátu lze zařazovat pouze v činnosti adresář - záložka Adresy. Při vyvolání adres adresáta z jiné činnosti může uživatel adresy pouze prohlížet, nemůže je zadávat, opravovat ani rušit.

Datový model

  • ADADR Adresa
    • ADSTATY Stát

    • Formulář

    Formulář činnosti - Uživatelé programu
Mřížka [Adresy]
Adresa | Číslo adresy adresáta.
Ulice | Ulice adresy adresáta (včetně čísla popisného).
Byt | Ulice bytu adresáta (včetně čísla popisného)
 | Poštovní směrovací číslo adresy adresáta.
Město | Město adresy adresáta.
Stát | Název státu.
 | Identifikace státu.
Komentář | Kometář k adrese adresáta.
Typ místa | Typ místa tuzemsko, zahraničí, Evropská Unie ....

    Mřížka [Adresy] činnosti - Uživatelé programu

    Mřížka [Adresy] činnosti - Uživatelé programu
Adresa | Číslo adresy adresáta.
Město | Město adresy adresáta.


Spojení

Popis

Nadefinovaná spojení původního adresáta na záložce "Spojení" způsobí, že tato spojení budou zkopírována ke spojením aktuálního adresáta (včetně adres). Přitom informace o tom, že tato nově založená spojení aktuálního adresáta jsou totožná s odpovídajícími spojeními původního adresáta se zapíše do dat tak, že se po provedení funkce začnou objevovat na záložce "Spojení", jako kdyby je uživatel zadal ručně. To umožňuje tuto funkci spouštět opakovaně.

Datový model

  • ADSPOJ Spojení adresáta
    • ADTYPSPO Typ spojení
    • ADADR Adresa
    • SPSEOB Obchodní selektor

    • Formulář

    Formulář činnosti - Obchodní selektor
Mřížka [Spojení]
Spojení | Číslo spojení adresáta.
Adresa | Číslo adresy adresáta.
Ulice | Ulice adresy adresáta (včetně čísla popisného).
Byt | Ulice bytu adresáta (včetně čísla popisného)
 | Poštovní směrovací číslo adresy adresáta.
 | Město adresy adresáta.
Stát | Identifikace státu.
 | Název státu.
Komentář | Kometář k adrese adresáta.
Typ | Identifikace typu spojení
 | Název typu spojení
 | Směrové číslo státu pro telefonní spojení.
 | Národní směrové číslo státu pro telefonní spojení (UTO).
Telefon | Telefonní číslo
Jméno | Jméno kontaktní osoby.
Funkce | Funkce kontaktní osoby
Komentář | Komentář ke spojení
Obch. sel. | Identifikátor obchodního selektoru

    Mřížka [Spojení] činnosti - Obchodní selektor

    Mřížka [Spojení] činnosti - Obchodní selektor
Jméno | Jméno kontaktní osoby.
Spojení | Číslo spojení adresáta.
Adresa | Číslo adresy adresáta.
UTO | Národní směrové číslo státu pro telefonní spojení (UTO).
Telefon | Telefonní číslo
Mobil | Číslo mobilního telefonu
e-mail | E-mail spojení adresáta
Fax | Faxové číslo

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresy | Seznam adres za adresáta.
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Typ spojení | Seznam typů spojení.

    Viz.také

    Adresy | Obchodní selektor | Typ spojení


Označení sebe

Popis

Pro zadávání některých údajů (např. události plateb, skladu, účetnictví) je vhodné, aby v adresáři byla možnost označit sama sebe.

Tuto možnost nabízí uživateli právě tato činnost. V adresáři si uživatel vybere svoji adresu a spustí tuto činnost. Systém potom pokládá dotaz: "Opravdu chcete označit adresáta ............ jako sebe?". Po potvrzení volby Ano potom systém v událostech jako vlastníka předplňuje tuto zvolenou identifikaci adresáta.


Změna implicitního bank.spojen

Popis

Uživatel si v seznamu bankovních spojení (účet nebo pokladna) vybere spojení, které chce mít jako implicitní a přesune se na něj kurzorem. Potom stačí kliknout myší na tlačítko "implicitní bankovní spojení" a dané spojení se v tu chvíli stává implicitním. Prvotním příznakem implicitního spojení je jeho zvýraznění červeně.


UDÁLOSTI ADRESÁTA

Popis

U činnosti adresář stojí za samostatnou poznámku položka adresát, která je na obrazovce zvýrazněna tučně. Po jejím stisku "tlačítkem myši" se zobrazí následující nabídka, ze které má uživatel možnost si přímo vyvolat:

¨ vývěsku adresáta

¨ poštu adresáta

¨ obchod

¨ skladovou evidenci

¨ platby

¨ DPH

¨ obecnou komponentu

¨ vymáhání

¨ změny stavu peněz

¨ a možné jiné události, které se týkají pouze daného adresáta.

Každou z těchto činností je možno po stisku tlačítka myši aktivovat. Tyto činnosti si uživatel může vyvolat i z menu volby, kde se nabízí ta samá nabídka.

Viz.také

Vývěska | Pošta | Událost obchodu | Událost skladové evidence | Události plateb | Události DPH | Události obecné komponenty | Události vymáhání | Události změny stavu peněz | Události o zálohách | Zakázky výroby | Výrobní úkoly | Harmonogram výroby | Hodnoty předmětu projektu | Položky smluv | Události plnění smluv | Projektové úkoly | Plnění projektových úkolů | Událost personalistiky | Událost skladu zvířat


AKTUÁLNÍ HODNOTY ADRESÁTA

Popis

Aktuální hodnoty adresáta má uživatel možnost si vyvolat z adresáře. Jsou umístěny v menu volby nebo jsou přístupné po stisku pravého tlačítka myši na tučně zvýrazněné položce adresát. Zatím se nabízejí události z těchto komponent:

¨ platby

¨ obchod

¨ skladová evidence

¨ změny stavu peněz

Nabídka komponent se může časem samozřejmě rozšířit. U každé komponenty se uživateli nabízejí ty události, které nějak souvisí s nadefinovanými aktuálními hodnotami, které chce uživatel podrobně sledovat. Např. stav materiálu na skladě, stav financí na účtu apod.

Viz.také

Aktuální hodnoty plateb | Aktuální hodnoty obchodu | Aktuální hodnoty skladu | Aktuální hodnoty ZSP | Aktuální hodnoty obecné komp. | Aktuální hodnoty záloh | Přehled záloh


DOS - Dávková replikace

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Slučování spojení adresáta

Popis

Tato činnost poskytuje uživateli možnost sloučit spojení (jedno nebo více) daného adresáta (není to činnost podobná duplicitě adresátů, která slučuje dva různé adresáty do jednoho zvoleného, ale v této činnosti se jedno nebo více spojení daného adresáta spojí do určeného spojení).

V praxi se definuje:

¨ adresát – identifikace daného adresáta

¨ spojení – identifikace spojení, které má zůstat zachováno (resp. číslo spojení, do kterého se mají ostatní vybraná spojení sloučit)

¨ sloučená spojení – seznam spojení, které chce uživatel sloučit oddělený čárkou (např. 02,03)

Tyto údaje následně zapsat (ikona disketa). Jednotlivé atributy všech uvedených spojení se automaticky doplní do příslušných položek. Na záložce „slučovaná spojení“ je přehled spojení, které se budou slučovat. Po stisku klávesy ESC se systém dotazuje: „Spustit konverzi?“ – Ano/Ne. Po volbě Ano je provedeno sloučení spojení daného adresáta.

Datový model

  • ADSPOSLU Popis sloučení spojení adresáta
    • ADADSAT Adresát
    • ADSPOJ Spojení adresáta

    • Formulář

    Formulář činnosti - Konv. listu do nových výkazů
Mřížka [Sloučená spojení]
Adresát | Identifikace adresáta
 | Název adresáta
 | Číslo spojení adresáta.
 | Jméno kontaktní osoby.
Sloučená spojení | Seznam sloučených spojení
Listovací rámeček
Stránka #1 Sloučená spojení
 | Národní směrové číslo státu pro telefonní spojení (UTO).
Telefon | Telefonní číslo
 | Telefonní číslo
Fax | Faxové číslo
 | Faxové číslo
Mobil | Číslo mobilního telefonu
 | Číslo mobilního telefonu
e-mail | E-mail spojení adresáta
 | E-mail spojení adresáta
Jiné | Jiné spojení adresáta
 | Jiné spojení adresáta
Komentář | Komentář ke spojení
 | Komentář ke spojení
 | Provádět výpočet
Stránka #2 Slučovaná spojení
Mřížka [Slučovaná spojení]
Jméno | Jméno kontaktní osoby.
 | Národní směrové číslo státu pro telefonní spojení (UTO).
Telefon | Telefonní číslo
Fax | Faxové číslo
Mobil | Číslo mobilního telefonu
e-mail | E-mail spojení adresáta
Jiné | Jiné spojení adresáta

    Mřížka [Sloučená spojení] činnosti - Konv. listu do nových výkazů

    Mřížka [Sloučená spojení] činnosti - Konv. listu do nových výkazů
Adresát | Identifikace adresáta
Spojení | Číslo spojení adresáta.
Název adresáta | Název adresáta
Jméno | Jméno kontaktní osoby.

    Mřížka [Slučovaná spojení] činnosti - Konv. listu do nových výkazů

    Mřížka [Slučovaná spojení] činnosti - Konv. listu do nových výkazů
Spojení | Číslo spojení adresáta.
Jméno | Jméno kontaktní osoby.
Telefon | Telefonní číslo
Fax | Faxové číslo
Mobil | Číslo mobilního telefonu
e-mail | E-mail spojení adresáta
Jiné | Jiné spojení adresáta


Naplnění parametrů spojení

Popis

Na základě nadefinovaných typů subjektů spojení a jejich parametrů naplní parametry daného spojení (tzn. spojení na kterém je umístěn kurzor) k jednotlivým adresátům v adresáři.

Upozornění: Jedná se o poměrně časově náročnou operaci.


Strom adresáta

Popis

Jedná se o činnost, která uživateli umožňuje sestavit si informace o adresátovi přehledně ve stromovém vyjádření. Tuto činnost má uživatel k dispozici v hlavním menu v činnosti adresář pod menu Volby nebo po stisku klávesy F5. Dále ji má dostupnou na každém labelu „adresát“ (tzn. po stisku pravého tlačítka myši na tučně zvýrazněném atributu adresář).

Po aktivaci této činnosti se uživateli otevře nové okno s činností strom adresáta. Uživateli se zobrazuje název adresáta a pod ním jsou navěšeny jednotlivé adresy adresáta (stiskem znaménka + se adresa rozbalí). V dolní části okna této činnosti má uživatel ještě k dispozici menu „vývěska a dokumenty“. Po kliknutí myši na tomto menu se uživateli zpřístupní znaménko + a po jeho rozbalení má k dispozici události vývěsky (dvojklikem na názvu se menu rozbalí ihned), které byly vytvořeny s tímto adresátem a dokumenty, které se týkají tohoto adresáta.

Po stisku pravého tlačítka myši kdekoliv v prostoru okna této činnosti má uživatel k dispozici tyto možnosti:

¨ obnovit – při jakékoliv změně v adresáři se touto činností aktualizuje strom adresáta

¨ následníci – vývěska – vyvolá se okno činnosti události vývěsky, které jsou k dané události ve vztahu následník (tzn. syn)

¨ následníci – dokumenty – vyvolá se okno činnosti dokumenty, které jsou k dané události připojeny jako objekty pomocí objektových vazeb (tzn. přes Ctrl D)

¨ spojení adresáta – zobrazí se okno činnosti s přehledem nadefinovaných spojení adresáta

Formulář

Formulář činnosti - Naplnění parametrů spojení
Strom adresáta

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Zaměnit vazby na původního

Popis

Tato funkce převede datové vazby směrované na původního adresáta aktuálnímu adresátovi tak, aby bylo možné následně původního adresáta běžným způsobem zrušit. Je měněn odkaz na původního adresáta podle záložky "Adresát", na jeho spojení podle záložky "Spojení", na jeho bankovní spojení podle záložky "Bankovní spojení" všude tam, kde se tyto vyskytují jako cizí klíče (např. v událostech komponent). Navíc jsou kopírovány objektové vazby původního adresáta k aktuálnímu adresátovi.

Záměna adresátů v událostech komponenty zálohy není provedena, pokud pro původního adresáta existuje událost typu "vyúčtování" zálohy. V tomto případě je třeba odpovídající operace odblokovat a události vyúčtování smazat a po provedení funkce "Zaměnit vazby na původního" opakovaně tyto události vytvořit pro aktuálního adresáta.


OBRATOVÉ HODNOTY ADRESÁTA

Popis

Obratové hodnoty adresáta má uživatel možnost si vyvolat z adresáře. Jsou umístěny v menu volby nebo jsou přístupné po stisku pravého tlačítka myši na tučně zvýrazněné položce adresát. Nabídka komponent se může časem samozřejmě rozšířit. U každé komponenty se uživateli nabízejí ty události, které nějak souvisí s nadefinovanými obratovými hodnotami, které chce uživatel sledovat.

Viz.také

Obraty skladu | Obraty na účtech ZSP | Obraty skladu zvířat


Definování typu kategorie adresáta

Popis

Pro možnost použití palety barev a definice kategorií spojení adresáta byly rozšířeny vlastnosti kategorie adresáta o další atributy. Tyto atributy se nevstupují přímo ve formuláři „kategorie adresátů“, ale pomocí činnosti „definování typu kategorie adresáta“ (menu volby nebo klávesa F5) z tohoto formuláře.

Vzhledem k činnosti paleta barev byly rozšířeny vlastnosti kategorie adresáta o tyto atributy:

¨ typ - překryvný seznam Vstupovaná/Vypočítaná

¨ SQL - memo pole - SQL výraz pro typ Vypočítaná

Stanovení příslušnosti adresáta v kategorii podle typu:

¨ kategorie typu Vstupovaná - adresát patří do kategorie, pokud má u sebe uveden záznam o zařazení do kategorie platný k aktuálnímu datu

¨ kategorie typu Vypočítaná - adresát patří do kategorie, pokud vyhodnocení výrazu SQL vrátí hodnotu větší než 0. Tento výraz v syntaxi SQL Anywhere je vyhodnocován při zpracování SQL dotazu. Používají se v něm proměnné @ad01id (adresát), @ad11cispo (spojení adresáta), @bw01uziv (aktuálně přihlášený uživatel systému), @datum (datum vyhodnocení - obvykle aktuální datum systému). Vyhodnocením výrazu musí být numerická hodnota.

¨ testovat – provede test zadaného SQL dotazu (tzn. pro kategorie Vypočítané). Protože je výraz vyhodnocován uloženou procedurou až při zpracování SQL dotazu a není kompilován na straně klienta tak, jak je to v případě obecných výběrů, může chybně definovaný SQL výraz způsobovat to, že dotaz bude vracet žádný nebo menší počet záznamů než by měl bez nahlášení chyby. V atributu adresát se uvádí fiktivní číslo adresáta (v adresáři ale musí existovat), které má smysl pouze pro ověření daného SQL dotazu, na definici vypočítané kategorie jinak nemá žádný vliv.

Možné příklady SQL dotazů:

1. adresát je naším odběratelem

(select count() from %%%.obudal where ad01id=@ad01id and ob02privyd=4)

2. adresát je naším dodavatelem

(select count() from %%%.obudal where ad01id=@ad01id and ob02privyd=3)

3. adresát je naším odběratelem v posledním roce

(select count() from %%%.obudal where ad01id=@ad01id and ob02privyd=4 and ob02dat between @datum-365 and @datum)

4. adresát je naším dlužníkem

if exists(select * from %%%.pluda where ad01id=@ad01id and pl02pohzav=1 and pl02uhraze=0) then 1 else 0 endif

Pozn.: v příkladech 1,2 a 3 byl použita funkce COUNT, lépe pro efektivní zpracování dotazu by bylo užít způsob IF EXISTS(SELECT * ....

Datový model

  • ADKAT Kategorie adresáta

    • Formulář

     | Formulář činnosti - Spojení adresátů
 | Kategorie | Identifikace kategorie adresáta.
 |  | Text vystihující charakter kategorie
 | Typ | Typ kategorie - Vstupovaná / Vypočítaná
 | SQL | Výraz v SQL vyhodnocovaný dotazem vracející numerickou hodnotu (0=není v kategoriii) použivá ID adresáta @ad01id,@ad11cisspo,@datum
 | Komentář | Komentář ke kategorii
Adresát | Identifikace adresáta |
Číslo spojení adresáta.

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Testovat SQL výraz |
F2 | Adresář | Přehled adresátů
F2 | Spojení adresátů | Přehled spojení adresátů

    Viz.také

    Testovat SQL výraz | Adresář | Spojení adresátů


Legenda palety barev

Popis

Legenda palety barev poskytuje uživateli přehled o kategoriích adresátů a jejich barvách v dané paletě. Zobrazení této činnosti je podmíněno vhodně zadaným filtrem v činnosti Adresář na záložce Výběr (nutno mít zaškrtnut atribut „paleta“ a zvolenu paletu, čímž je zajištěno, že jsou následně zobrazeny záznamy všech kategorií dané palety).

Formulář

Formulář činnosti - Barvy RGB
Paleta Identifikace palety barev
Mřížka [Kategorie v paletě]

Mřížka [Kategorie v paletě] činnosti - Barvy RGB

Mřížka [Kategorie v paletě] činnosti - Barvy RGB
Priorita | Priorita barvy
Název kategorie | Text vystihující charakter kategorie


Procesy a operace aplikace

Popis

Tuto činnost uživatel aktivuje po stisku klávesy F6 nebo z menu Volby v činnosti „Aplikace“. Tato činnost je poměrně náročnější na komplexní znalost programu, takže by ji měl definovat buď zkušený uživatel nebo implementátor programu.

Datový model

  • APPROP Proces/Operace aplikace
    • SPTYP Druh procesu/operace

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Kód tranformace | Kód tranformace
F6 | Design formuláře popis.údajů | Design formuláře popisných údajů
F7 | Diagram procesu | Zobrazení diagramu procesu
F2 | Druhy procesů | Přehled druhů procesů
F2 | Skupiny uživatelů | Definování skupin uživatelů
F2 | Typy popisných údajů | Typy popisných údajů aplikace

    Formulář

    Formulář činnosti - Design formuláře popis.údajů
Mřížka [Procesy a operace]
Název | Název procesu/operace
Komponenta | Identifikace komponenty
Druh | Identifikátor druhu
 | Název druhu procesu
Listovací rámeček
Stránka #1 Procesy a operace
Top proces | Top proces
Údaje rozmístěny | Popisné údaje rozmístěny
Řídící příznaky | Řídící příznaky procesu/operace
Odvození umístění | Způsob odvození umístění pro operaci/proces
Typ | Typ práva přístupu
Umístění | Umístění
Příkaz | Příkaz pro spuštění z menu
Poznámka | Poznámka
Stránka #2 Uzly procesu
Mřížka [Uzly procesu]
Komponenta | Identifikace komponenty
Druh | Identifikátor druhu
Pořadí | Pořadí stejného druhu operace v jednom procesu
Název druhu | Název druhu procesu
Název | Název procesu/operace
Samostatné ukončení | Samostatné ukončení
Zakládat při stavu nadřízeného procesu | Zakládat při stavu nadřízeného procesu
Stránka #3 Popisné údaje
Mřížka [Popisné údaje]
Typ | Identifikátor typu popisného údaje aplikace
Text | Text popisného údaje
Pořadí | Pořadí zobrazení popisného údaje
Zobrazovat návěští | Zobrazovat návěští ve formuláři
Stránka #4 Skupiny uživatelů
Mřížka [Skupiny uživatelů]
Skupina | Identifikace skupiny uživatelů
Název skupiny uživatelů | Název skupiny uživatelů
Umístění | Umístění
Popis práva | Popis práva skupiny uživatelů
Stránka #5 Předlohy výstupu
Mřížka [Předlohy výstupu]
ID | Identifikace předlohy
Název | Název předlohy
Předloha | Soubor předlohy
Dotaz při výstupu | Dotaz při výstupu předlohou
Počet kopií | Počet kopií při výstupu předlohou
SQL | SQL dotaz pro výstup předlohou

    Mřížka [Procesy a operace] činnosti - Design formuláře popis.údajů

    Mřížka [Procesy a operace] činnosti - Design formuláře popis.údajů
Název | Název procesu/operace
Druh | Identifikátor druhu
Komponenta | Identifikace komponenty
Název druhu | Název druhu procesu
Top proces | Top proces
Odvození umístění | Způsob odvození umístění pro operaci/proces
Typ | Typ práva přístupu
Údaje rozmístěny | Popisné údaje rozmístěny

    Mřížka [Uzly procesu] činnosti - Design formuláře popis.údajů

    Mřížka [Uzly procesu] činnosti - Design formuláře popis.údajů
Název | Název procesu/operace
Komponenta | Identifikace komponenty
Druh | Identifikátor druhu
Název druhu | Název druhu procesu

    Mřížka [Popisné údaje] činnosti - Design formuláře popis.údajů

    Mřížka [Popisné údaje] činnosti - Design formuláře popis.údajů
Pořadí | Pořadí zobrazení popisného údaje
Typ | Identifikátor typu popisného údaje aplikace
Text | Text popisného údaje

    Mřížka [Skupiny uživatelů] činnosti - Design formuláře popis.údajů

    Mřížka [Skupiny uživatelů] činnosti - Design formuláře popis.údajů
Skupina | Identifikace skupiny uživatelů
Název skupiny uživatelů | Název skupiny uživatelů
Umístění | Umístění
Popis práva | Popis práva skupiny uživatelů

    Mřížka [Předlohy výstupu] činnosti - Design formuláře popis.údajů

    Mřížka [Předlohy výstupu] činnosti - Design formuláře popis.údajů
ID | Identifikace předlohy
Název předlohy | Název předlohy
Předloha | Soubor předlohy
Dotaz při výstupu | Dotaz při výstupu předlohou
Počet kopií | Počet kopií při výstupu předlohou

    Viz.také

    Kód tranformace | Design formuláře popis.údajů | Diagram procesu | Druhy procesů | Skupiny uživatelů | Typy popisných údajů


Kód tranformace

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Menu aplikace

Popis

Tuto činnost uživatel aktivuje po stisku klávesy F5 nebo z menu Volby v činnosti „Aplikace“. Tato činnost je poměrně náročnější na komplexní znalost programu, takže by ji měl definovat buď zkušený uživatel nebo implementátor programu.

Při definici menu aplikace se vstupují tyto atributy:

¨ identifikace a název položky menu

¨ popis

¨ vrchol – zda se jedná o vrcholový prvek menu – volba Ano/Ne

¨ typ položky menu – formulář / složka / program (při volbě program se vstupuje i atribut „kód“)

¨ formální parametry

¨ návratová hodnota

¨ kód – pro typ položky menu program

¨ poznámka

Podrobnější informace k menu aplikace se následně nastavují na záložce „SQL dotazy“ a „podřízené položky menu“.

Datový model

  • APMENU Prvek menu aplikace

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Design formuláře aplikace | Design formuláře aplikace
F6 | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností
F9 | Spustit kód | Spustit kód
F2 | Menu aplikace | Definování menu aplikace

    Formulář

    Formulář činnosti - Knihovny vkládaného kódu
Mřížka [Menu]
ID | Identifikace položky menu
Název | Název položky menu
Listovací rámeček
Stránka #1 Menu
Popis | Popis položky menu
Vrchol | Vrcholový prvek menu
Typ | Typ položky menu
Formální parametry | Formální parametry
Návratová hodnota | Návratová hodnota formuláře
Kód | Kód programu/formuláře
Poznámka | Poznámka
Stránka #2 SQL dotazy
Mřížka [SQL dotazy]
Pořadí | Pořadí otevření souboru podle dotazu SQL
Alias | Alias dotazu
Editační oblasti | Stránky editační oblasti např. Page1,Page2,...
Vkládání | Vkládání dat povoleno
Oprava | Oprava dat povolena
Rušení | Rušení dat povoleno
Načítat data | Načítat data dotazu ihned po spuštění formuláře
SQL | Dotaz SQL (!!! včetně aliasů tabulek za FROM - jinak nemusí správně fungovat aktualizace dat !!!)
Kód po zápisu dat | Kód po zápisu dat
Všeobecný kód | Všeobecný kód
Poznámka | Poznámka
Stránka #3 Podřízené položky menu
Mřížka [Podřízené položky menu]
ID | Následující položka menu
Název | Název položky menu
Skutečné par. | Skutečné parametry
Stat.podmínka | Statická podmínka
Dyn.podmínka | Dynamická podmínka
Funkční klávesa | Funkční klávesa
F2-položka | Položka přijímající reakci na klávesu F2

    Mřížka [Menu] činnosti - Knihovny vkládaného kódu

    Mřížka [Menu] činnosti - Knihovny vkládaného kódu
ID | Identifikace položky menu
Typ | Typ položky menu
Název | Název položky menu
Popis | Popis položky menu
Vrchol | Vrcholový prvek menu

    Mřížka [SQL dotazy] činnosti - Knihovny vkládaného kódu

    Mřížka [SQL dotazy] činnosti - Knihovny vkládaného kódu
Pořadí | Pořadí otevření souboru podle dotazu SQL
Alias | Alias dotazu

    Mřížka [Podřízené položky menu] činnosti - Knihovny vkládaného kódu

    Mřížka [Podřízené položky menu] činnosti - Knihovny vkládaného kódu
ID | Následující položka menu
Název | Název položky menu

    Viz.také

    Design formuláře aplikace | Knihovny vkládaného kódu | Spustit kód


Design formuláře aplikace

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Spustit kód

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Design formuláře popis.údajů

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Vybrat soubor dokumentu

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYBDP Bonitní díl parcely

Popis

Bonitní díl parcely

Atributy

Atribut | Typ | Návěští | Message | Popis
py31bpej | C(5) | BPEJ | Kód bonitního dílu parcely BPEJ | Kód bonitního dílu parcely BPEJ
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
py31vymera | N(6,0) | Výměra | Výměra bonitního dílu | Výměra bonitního dílu
py32id | C(6) | Stav dat | Identifikátor stavu dat | Identifikátor stavu dat
py21rizvzn | C(30) | Řízení vzniku | Řízení vzniku | Řízení vzniku
py21rizzan | C(30) | Řízení zániku | Řízení zániku | Řízení zániku
py31datvzn | D | Datum vzniku | Datum vzniku | Datum vzniku
py31datzan | D | Datum zániku | Datum zániku | Datum zániku

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Bonitní díl parcely - patří parcele | PYBDP sp60id sp61id | 1,1 : 0,M s rušením | PYNEMOV sp60id sp61id |
Bonitní díl parcely - je ve stavu dat | PYBDP py32id | 1,1 : 0,M | PYSTADAT py32id |
Bonitní díl parcely - vznikl řízením | PYBDP py21rizvzn | 1,1 : 0,M | PYRIZENI py21id |
Bonitní díl parcely - zanikl řízením | PYBDP py21rizzan | 1,1 : 0,M | PYRIZENI py21id |

Indexy

Název | Primární | Výraz | Popis
ix_PYBDP_pybdp | P | py31bpej, sp60id, sp61id | PI - SPARTIKL+py31bpej
ix_PYBDP_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_PYBDP_py32id |  | py32id | Identifikátor stavu dat
ix_PYBDP_py21rizvzn |  | py21rizvzn | Řízení vzniku
ix_PYBDP_py21rizzan |  | py21rizzan | Řízení zániku

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYDRUUDA Druh události o nemovitosti

Popis

Druh události o nemovitosti

Atributy

Atribut | Typ | Návěští | Message | Popis
py03id | C(6) | Druh | Identifikace druhu události o nemovitosti | Identifikace druhu události o nemovitosti
py03nazdru | C(40) | Název druhu | Název druhu události o nemovitosti | Název druhu události o nemovitosti
py04id | C(6) | Umístění | Identifikace umístění nemovitosti | Identifikace umístění nemovitosti
py06id | C(6) | Stav | Identifikace stavu nemovitosti | Identifikace stavu nemovitosti
py03koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Druh události o nemovitosti - má definováno právo zadávání uživatelem podle umístění | PYDRUUDA py04id | 1,1 : 0,M | PYUMIST py04id |
Druh události o nemovitosti - se týká druhu události | PYDRUUDA py06id | 0,1 : 0,M s rušením | PYSTAV py06id |
Událost o nemovitosti - je druhu | PYUDAL py03id | 1,1 : 0,M | PYDRUUDA py03id |
Transformace změny obsahu entity do události o nemovitosti - generuje událost o nemovitosti s druhem události | PYTRAN py03id | 1,1 : 0,M | PYDRUUDA py03id |

Indexy

Název | Primární | Výraz | Popis
ix_PYDRUUDA_py03id | P | py03id | Identifikace druhu události o nemovitosti
ix_PYDRUUDA_py03nazdru |  | py03nazdru | Název druhu události o nemovitosti
ix_PYDRUUDA_py04id |  | py04id | Identifikace umístění nemovitosti
ix_PYDRUUDA_py06id |  | py06id | Identifikace stavu nemovitosti

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYJPV Jiný právní vztah

Popis

Jiný právní vztah vyjadřuje jiný než vlastnický vztah jednoho subjektu
(oprávněného subjektu nebo nemovitosti) k jednomu předmětu
(k jedné nemovitosti, k vlastnictví nebo k dalšímu jinému právnímu vztahu).
Vztah k předmětu "typu vlastnictví" nebo "jiný právní vztah"
je realizován tabulkou "OMEZENÍ PRÁV".
U jiného právního vztahu nemusí být uveden subjekt.
Typy jiných právních vztahů, typy subjektů a předmět
jiného právního vztahu jsou dány číselníkem právních vztahů.
Vazby *_K definují nemovitosti či OS, které jsou "povinné", vazby *_PRO definují "oprávněné" nemovitosti či OS.

Atributy

Atribut | Typ | Návěští | Message | Popis
py23id | C(30) | JPV | Identifikace jiného právního vztahu | Identifikace jiného právního vztahu
sp60id2 | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id2 | C(3) | Druh | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id1 | C(13) | sp60id1 |  |
sp61id1 | C(3) | sp61id1 |  |
py18id | C(30) | List vl. | ID listu vlastnictví | ID listu vlastnictví
py23datvzn | D | Datum vzniku | Datum vzniku | Datum vzniku
py23datzan | D | Datum zániku | Datum zániku | Datum zániku
py21rizvzn | C(30) | Řízení vzniku | Řízení vzniku | Řízení vzniku
py21rizzan | C(30) | Řízení zániku | Řízení zániku | Řízení zániku
py23poznam | M | Popis | Poznámka - popis | Poznámka - popis
py12typpra | C(10) | Právní vztah | Typ právního vztahu | Typ právního vztahu
py16id1 | C(30) | S. k tíži | Oprávněnému subjektu k tíži | Identifikace oprávněného subjektu k tíži
py16id2 | C(30) | S. ku prosp. | Oprávněnému subjektu ku prospěchu | Identifikace oprávněného subjektu ku prospěchu
ad01id1 | C(6) | Importovaný | Identifikace importovaného adresáta | Identifikace adresáta - pro import
ad01id2 | C(6) | Adresát | Adresát subjektu spojení adresáta | Adresát subjektu spojení adresáta
py32id | C(6) | Stav dat | Identifikátor stavu dat | Identifikátor stavu dat

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Jiný právní vztah - se týká listu vlastnictví | PYJPV py18id | 1,1 : 0,M | PYNEMLV py18id |
Jiný právní vztah - má určený typ právního vztahu | PYJPV py12typpra | 1,1 : 0,M | PYTYPCIS py12id |
Jiný právní vztah - určuje nemovitost k tíži | PYJPV sp60id1 sp61id1 | 1,1 : 0,M | PYNEMOV sp60id sp61id |
Jiný právní vztah - určuje nemovitost ku prospěchu | PYJPV sp60id2 sp61id2 | 1,1 : 0,M | PYNEMOV sp60id sp61id |
Jiný právní vztah - zanikl řízením | PYJPV py21rizzan | 0,1 : 0,M | PYRIZENI py21id |
Jiný právní vztah - je adresátovi - oprávněnému subjektu k tíži | PYJPV ad01id1 | 1,1 : 0,M | ADADSAT ad01id |
Jiný právní vztah - je ve stavu | PYJPV py32id | 1,1 : 0,M | PYSTADAT py32id |
Přiřazení listiny k nemovitosti RL - má uveden jiný právní vztah | PYLISNEM py23id | 1,1 : 0,M | PYJPV py23id |

Indexy

Název | Primární | Výraz | Popis
ix_PYJPV_py23id | P | py23id | Identifikace jiného právního vztahu
ix_PYJPV_spartikl2 |  | sp60id2, sp61id2 | CI - sp60id2+sp61id2
ix_PYJPV_spartikl1 |  | sp60id1, sp61id1 | CI - sp60id1+sp61id1
ix_PYJPV_py18id |  | py18id | ID listu vlastnictví
ix_PYJPV_py21rizvzn |  | py21rizvzn | Řízení vzniku
ix_PYJPV_py21rizzan |  | py21rizzan | Řízení zániku
ix_PYJPV_py12typpra |  | py12typpra | Typ právního vztahu
ix_PYJPV_py16id1 |  | py16id1 | Identifikace oprávněného subjektu k tíži
ix_PYJPV_py16id2 |  | py16id2 | Identifikace oprávněného subjektu ku prospěchu
ix_PYJPV_ad01id1 |  | ad01id1 | Identifikace adresáta - pro import
ix_PYJPV_ad01id2 |  | ad01id2 | Adresát subjektu spojení adresáta
ix_PYJPV_py32id |  | py32id | Identifikátor stavu dat

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYKATAST Katastrální území

Popis

Centrálně spravovaný číselník všech katastrálních uzemí

Atributy

Atribut | Typ | Návěští | Message | Popis
py10id | C(6) | Katastr | Číslo katastru | Číslo katastru
py11id | C(8) | Správní celek | Obec,Část obce, Okres,Kraj | Obec,Část obce, Okres,Kraj
py10nazkat | C(60) | Název katastru | Název katastru nemovitostí | Název katastru
py10platod | D | Platnost od | Platnost katastru od | Platnost katastru od
py10platdo | D | do | Platnost katastru do | Platnost katastru do

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Katastrální území - má uveden kód obce | PYKATAST py11id | 1,1 : 0,M | PYSPRCEL py11id |
Nemovitost - patří do katastru | PYNEMOV py10id | 1,1 : 0,M | PYKATAST py10id |
List vlastnictví nemovitosti (těleso) - patří do katatru | PYNEMLV py10id | 1,1 : 0,M | PYKATAST py10id |

Indexy

Název | Primární | Výraz | Popis
ix_PYKATAST_py10id | P | py10id | Číslo katastru
ix_PYKATAST_py11id |  | py11id | Obec,Část obce, Okres,Kraj

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYLISDU Listina - další údaje LDU

Atributy

Atribut | Typ | Návěští | Message | Popis
py17id | C(30) | Listina | Identifikace listiny | Identifikace listiny
py12koddal | C(10) | Kód | Kód dalšího údaje | Kód dalšího údaje

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Listina - další údaje LDU - patří k listině | PYLISDU py17id | 1,1 : 0,M | PYLISTIN py17id |
Listina - další údaje LDU - je typu | PYLISDU py12koddal | 1,1 : 0,M | PYTYPCIS py12id |

Indexy

Název | Primární | Výraz | Popis
ix_PYLISDU_pyldu | P | py17id, py12koddal | PI - py17id+py12koddal
ix_PYLISDU_py17id |  | py17id | Identifikace listiny
ix_PYLISDU_py12koddal |  | py12koddal | Kód dalšího údaje

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYLISNEM Přiřazení listiny k nemovitosti RL

Popis

RL
Popis:
Vazební tabulka mezi nemovitostmi a vlastnictvími na nabývací tituly.
Ve vazební tabulce RL vždy platí, že pokud je vyplněn údaj OPSUB_ID, je také vyplněný údaj PAR_ID nebo BUD_ID nebo JED_ID.

Atributy

Atribut | Typ | Návěští | Message | Popis
py22id | C(30) | ID | Identifikace přiřazení listiny k nemovitostem | Identifikace přiřazení listiny k nemovitostem
py16id | C(30) | Subjekt | Identifikace oprávněného subjektu | Identifikace oprávněného subjektu
py17id | C(30) | Listina | Identifikace listiny | Identifikace listiny
py23id | C(30) | JPV | Identifikace jiného právního vztahu | Identifikace jiného právního vztahu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
py22datvzn | D | Datum vzniku | Datum vzniku | Datum vzniku
py22datzan | D | Datum zániku | Datum zániku | Datum zá niku
py21rizvzn | C(30) | Řízení vzniku | Řízení vzniku | Řízení vzniku
py21rizzan | C(30) | Řízení zániku | Řízení zániku | Řízení zániku
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
py32id | C(6) | Stav dat | Identifikátor stavu dat | Identifikátor stavu dat

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Přiřazení listiny k nemovitosti RL - spojuje listinu s nemovitostí | PYLISNEM sp60id sp61id | 1,1 : 0,M | PYNEMOV sp60id sp61id |
Přiřazení listiny k nemovitosti RL - určuje listinu | PYLISNEM py17id | 1,1 : 0,M | PYLISTIN py17id |
Přiřazení listiny k nemovitosti RL - vzniklo řízením | PYLISNEM py21rizvzn | 0,1 : 0,M | PYRIZENI py21id |
Přiřazení listiny k nemovitosti RL - zaniklo řízením | PYLISNEM py21rizzan | 0,1 : 0,M | PYRIZENI py21id |
Přiřazení listiny k nemovitosti RL - má uveden jiný právní vztah | PYLISNEM py23id | 1,1 : 0,M | PYJPV py23id |
Přiřazení listiny k nemovitosti RL - definuje adresáta - oprávněný subjekt spojený s listinou a nemovitostí | PYLISNEM ad01id | 1,1 : 0,M | ADADSAT ad01id |
Přiřazení listiny k nemovitosti RL - je ve stavu dat | PYLISNEM py32id | 1,1 : 0,M | PYSTADAT py32id |

Indexy

Název | Primární | Výraz | Popis
ix_PYLISNEM_py22id | P | py22id | Identifikace přiřazení listiny k nemovitostem
ix_PYLISNEM_py16id |  | py16id | Identifikace oprávněného subjektu
ix_PYLISNEM_py17id |  | py17id | Identifikace listiny
ix_PYLISNEM_py23id |  | py23id | Identifikace jiného právního vztahu
ix_PYLISNEM_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_PYLISNEM_py21rizvzn |  | py21rizvzn | Řízení vzniku
ix_PYLISNEM_py21rizzan |  | py21rizzan | Řízení zániku
ix_PYLISNEM_ad01id |  | ad01id | Identifikace adresáta
ix_PYLISNEM_py32id |  | py32id | Identifikátor stavu dat

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYLISTIN Listina

Popis

Tabulka LISTINY obsahuje základní údaje charakterizující listinu jako
podklad rozhodování a/nebo zápis do KN v rámci řízení.

Atributy

Atribut | Typ | Návěští | Message | Popis
py17id | C(30) | Listina | Identifikace listiny | Identifikace listiny
py21id | C(30) | Řízení | Číslo řízení | Číslo řízení
py12typlis | C(10) | Typ | Typ listiny | Typu listiny
py17popis | M | Popis | Popis obsahu listiny | Popis obsahu listiny
py17obsah | C(1) | Obsah existuje | Identifikátor existence obsahu listiny | Identifikátor existence obsahu listiny
py17stran | N(4,0) | Stran | Počet stran | Počet stran
py17datpla | D | Platnost | Datum platnosti nebo nabytí právní moci | Datum platnosti nebo nabytí právní moci
py17zhotov | C(60) | Zhotovitel | Jméno zhotovitele listiny | Jméno zhotovitele listiny
py17datzho | D | Vyhotovení | Datum vyhotovení listiny | Datum vyhotovení listiny
py17pczhot | C(7) | Číslo | Pořadové číslo zhotovitele listiny | Pořadové číslo zhotovitele listiny
py17dopzho | C(60) | JČ zhotovitele | Doplnění jednacího čísla listiny zhotovitele | Doplnění jednacího čísla listiny zhotovitele
py17zhozkr | C(10) | Zkratka | Zkratka zhotovitlele | Zkratka zhotovitlele
py17zmepvz | C(1) | Z. právního vztahu | Indikace změny právního vztahu | Indikace změny právního vztahu
py17pravmo | D | Právní moc | Datum nabytí právní moci | Datum nabytí právní moci
py17datvyk | D | Vykonavatelnost | Datum vykonavatelnosti | Datum vykonavatelnosti

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Listina - mají typ | PYLISTIN py12typlis | 1,1 : 0,M | PYTYPCIS py12id |
Listina - patří k řízení | PYLISTIN py21id | 0,1 : 0,M | PYRIZENI py21id |
Přiřazení listiny k nemovitosti RL - určuje listinu | PYLISNEM py17id | 1,1 : 0,M | PYLISTIN py17id |
Listina - další údaje LDU - patří k listině | PYLISDU py17id | 1,1 : 0,M | PYLISTIN py17id |

Indexy

Název | Primární | Výraz | Popis
ix_PYLISTIN_py17id | P | py17id | Identifikace listiny
ix_PYLISTIN_py21id |  | py21id | Číslo řízení
ix_PYLISTIN_py12typlis |  | py12typlis | Typu listiny

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYNEMLV List vlastnictví nemovitosti (těleso)

Popis

List vlastnictví nemovitosti (těleso)

Atributy

Atribut | Typ | Návěští | Message | Popis
py18id | C(30) | List vl. | ID listu vlastnictví | ID listu vlastnictví
py10id | C(6) | Katastr | Číslo katastru | Číslo katastru
py18cistel | N(6,0) | Číslo listu | Číslo listu vlastnictví | Číslo listu vlastnictví
py18datvzn | D | Datum vzniku | Datum vzniku | Datum vzniku
py18datzan | D | Datum zániku | Datum zániku | Datum zániku
py21rizvzn | C(30) | Řízení vzniku | Řízení vzniku | Řízení vzniku
py21rizzan | C(30) | Řízení zániku | Řízení zániku | Řízení zániku
py32id | C(6) | Stav dat | Identifikátor stavu dat | Identifikátor stavu dat
py18extid | C(30) | Externí | Externí ID listu vlastnictví | Externí ID listu vlastnictví

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
List vlastnictví nemovitosti (těleso) - patří do katatru | PYNEMLV py10id | 1,1 : 0,M | PYKATAST py10id |
List vlastnictví nemovitosti (těleso) - vznikl řízením | PYNEMLV py21rizvzn | 1,1 : 0,M | PYRIZENI py21id |
List vlastnictví nemovitosti (těleso) - zanikl řízením | PYNEMLV py21rizzan | 1,1 : 0,M | PYRIZENI py21id |
List vlastnictví nemovitosti (těleso) - je ve stavu | PYNEMLV py32id | 1,1 : 0,M | PYSTADAT py32id |
Nemovitost - je uvedena na listu vlastnictví | PYNEMOV py18id | 1,1 : 0,M | PYNEMLV py18id |
Vlastnictví nemovitosti VLA - je uvedeno na listu vlastnictví | PYNEMLVP py18id | 1,1 : 0,M s rušením | PYNEMLV py18id |
Jiný právní vztah - se týká listu vlastnictví | PYJPV py18id | 1,1 : 0,M | PYNEMLV py18id |

Indexy

Název | Primární | Výraz | Popis
ix_PYNEMLV_py18id | P | py18id | ID listu vlastnictví
ix_PYNEMLV_pytelesa | U | py10id, py18cistel | UI - py10id+py18cistel
ix_PYNEMLV_py10id |  | py10id | Číslo katastru
ix_PYNEMLV_py21rizvzn |  | py21rizvzn | Řízení vzniku
ix_PYNEMLV_py21rizzan |  | py21rizzan | Řízení zániku
ix_PYNEMLV_py32id |  | py32id | Identifikátor stavu dat

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYNEMLVP Vlastnictví nemovitosti VLA

Popis

Vlastnictví vyjadřuje vlastnický vztah (typ právního vztahu a podíl) jednotlivých oprávněných osob zapsaných v části A-LV (TELESO) ke všem nemovitostem zapsaným v B-LV

Atributy

Atribut | Typ | Návěští | Message | Popis
py19id | C(30) | Vlastnictví | Číslo vlastnictví | Číslo vlastnictví
py18id | C(30) | List vl. | ID listu vlastnictví | ID listu vlastnictví
py16id | C(30) | Subjekt | Identifikace oprávněného subjektu | Identifikace oprávněného subjektu
py12typpra | C(10) | Právní vztah | Typ právního vztahu | Typ právního vztahu
py21rizvzn | C(30) | Řízení vzniku | Řízení vzniku | Řízení vzniku
py21rizzan | C(30) | Řízení zániku | Řízení zániku | Řízení zániku
py19datvzn | D | Datum vzniku | Datum vzniku | Datum vzniku
py19datzan | D | Datum zániku | Datum zániku | Datum zániku
py19podcit | N(30,0) | Čitatel | Čitatel podílu vlastnictví spoluvlastníka | Čitatel podílu vlastnictví spoluvlastníka
py19podjme | N(30,0) | Jmenovatel | Jmenovatel podílu vlastnictví spoluvlastníka | Jmenovatel podílu vlastnictví spoluvlastníka
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
py32id | C(6) | Stav dat | Identifikátor stavu dat | Identifikátor stavu dat

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Vlastnictví nemovitosti VLA - je uvedeno na listu vlastnictví | PYNEMLVP py18id | 1,1 : 0,M s rušením | PYNEMLV py18id |
Vlastnictví nemovitosti VLA - má určený typ právního vztahu | PYNEMLVP py12typpra | 1,1 : 0,M | PYTYPCIS py12id |
Vlastnictví nemovitosti VLA - vznikl řízením | PYNEMLVP py21rizvzn | 1,1 : 0,M | PYRIZENI py21id |
Vlastnictví nemovitosti VLA - vznikl řízením | PYNEMLVP py21rizzan | 1,1 : 0,M | PYRIZENI py21id |
Vlastnictví nemovitosti VLA - má určeného adresáta - oprávněný subjekt | PYNEMLVP ad01id | 1,1 : 0,M | ADADSAT ad01id |
Vlastnictví nemovitosti VLA - je ve stavu dat | PYNEMLVP py32id | 1,1 : 0,M | PYSTADAT py32id |

Indexy

Název | Primární | Výraz | Popis
ix_PYNEMLVP_py19id | P | py19id | Číslo vlastnictví
ix_PYNEMLVP_py18id |  | py18id | ID listu vlastnictví
ix_PYNEMLVP_py16id |  | py16id | Identifikace oprávněného subjektu
ix_PYNEMLVP_py12typpra |  | py12typpra | Typ právního vztahu
ix_PYNEMLVP_py21rizvzn |  | py21rizvzn | Řízení vzniku
ix_PYNEMLVP_py21rizzan |  | py21rizzan | Řízení zániku
ix_PYNEMLVP_ad01id |  | ad01id | Identifikace adresáta
ix_PYNEMLVP_py32id |  | py32id | Identifikátor stavu dat

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYNEMOV Nemovitost

Popis

Nemovitostí se rozumí parcela nebo část parcely nebo budova nebo část budovy nebo jednotka.

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
sp60id1 | C(13) | sp60id1 |  |
sp61id1 | C(3) | sp61id1 |  |
sp60id2 | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id2 | C(3) | Druh | Identifikace druhu artiklu | Identifikace druhu artiklu
py10id | C(6) | Katastr | Číslo katastru | Číslo katastru
py01extid | C(40) | Externí id. | Externí identifikace nemovitosti | Externí identifikace nemovitosti
py01datvzn | D | Dat.vzniku | Datum vzniku | Datum vzniku
py01datzan | D | Dat.zániku | Datum zániku | Datum zániku
py01char | N(1,0) | Charakter | Charakter nemovitosti - Parcela/Díl parcely/Budova/Část budovy/Jednotka | Charakter nemovitosti - Parcela/Díl parcely/Budova/Část budovy/Jednotka
py04id | C(6) | Umístění | Identifikace umístění nemovitosti | Identifikace umístění nemovitosti
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
py12typnem | C(10) | Typ | Typ nemovitosti | Typ nemovitosti (typbud,typjed)
py12zdrevi | C(10) | Zdroj evidence | Zdroj evidence parcel | Zdroj evidence parcel
py12zpuvym | C(10) | Určení výměry | Způsob určení výměry | Způsob určení výměry
py12zpuvyu | C(10) | Způsob využití | Způsob využití nemovitosti | Způsob využití nemovitosti
py18id | C(30) | List vl. | ID listu vlastnictví | ID listu vlastnictví
py21rizvzn | C(30) | Řízení vzniku | Řízení vzniku | Řízení vzniku
py21rizzan | C(30) | Řízení zániku | Řízení zániku | Řízení zániku
py01kmecis | N(5,0) | Kmenové číslo | Kmenové číslo parcely | Kmenové číslo parcely
py01vymera | N(6,0) | Výměra | Výměra parcely | Výměra parcely
py01cisdil | N(1,0) | Číslo dílu | Číslo dílu parcely | Číslo dílu parcely
py32id | C(6) | Stav dat | Identifikátor stavu dat | Identifikátor stavu dat

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Nemovitost - má umístění | PYNEMOV py04id | 1,1 : 0,M | PYUMIST py04id |
Nemovitost - má technicko-věcný selektor | PYNEMOV sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |
Nemovitost - patří do katastru | PYNEMOV py10id | 1,1 : 0,M | PYKATAST py10id |
Nemovitost - parcela nebo část parcely má budovu (jednu nebo žádnou) | PYNEMOV sp60id1 sp61id1 | 0,1 : 0,M | PYNEMOV sp60id sp61id |
Nemovitost - parcela je dílem parcely resp. část budovy je částí budovy resp. jednotka je v budově | PYNEMOV sp60id2 sp61id2 | 0,1 : 0,M | PYNEMOV sp60id sp61id |
Nemovitost - je typu | PYNEMOV py12typnem | 1,1 : 0,M | PYTYPCIS py12id |
Nemovitost - parcela má zdroj evidence parcel | PYNEMOV py12zdrevi | 1,1 : 0,M | PYTYPCIS py12id |
Nemovitost - má způsob využití výměry | PYNEMOV py12zpuvyu | 1,1 : 0,M | PYTYPCIS py12id |
Nemovitost - parcela má způsob určení výměry | PYNEMOV py12zpuvym | 1,1 : 0,M | PYTYPCIS py12id |
Nemovitost - je uvedena na listu vlastnictví | PYNEMOV py18id | 1,1 : 0,M | PYNEMLV py18id |
Nemovitost - vznikla řízením | PYNEMOV py21rizvzn | 1,1 : 0,M | PYRIZENI py21id |
Nemovitost - zanikla řízením | PYNEMOV py21rizzan | 1,1 : 0,M | PYRIZENI py21id |
Nemovitost - má organizační selektor | PYNEMOV sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Nemovitost - je artiklem | PYNEMOV sp60id sp61id | 1,1 : 0,M | SPARTIKL sp60id sp61id |
Nemovitost - má stav dat | PYNEMOV py32id | 1,1 : 0,M | PYSTADAT py32id |
Nemovitost - parcela nebo část parcely má budovu (jednu nebo žádnou) | PYNEMOV sp60id1 sp61id1 | 0,1 : 0,M | PYNEMOV sp60id sp61id |
Nemovitost - parcela je dílem parcely resp. část budovy je částí budovy resp. jednotka je v budově | PYNEMOV sp60id2 sp61id2 | 0,1 : 0,M | PYNEMOV sp60id sp61id |
Událost o nemovitosti - je o nemovitosti | PYUDAL sp60id sp61id | 1,1 : 0,M | PYNEMOV sp60id sp61id |
Nemovitost ve stavu - určuje nemovitost | PYNEMSTA sp60id sp61id | 1,1 : 0,M s rušením | PYNEMOV sp60id sp61id |
Objekt řízení OBJRIZ - spojuje řízení s nemovitostí | PYRIZOBJ sp60id sp61id | 1,1 : 0,M | PYNEMOV sp60id sp61id |
Přiřazení listiny k nemovitosti RL - spojuje listinu s nemovitostí | PYLISNEM sp60id sp61id | 1,1 : 0,M | PYNEMOV sp60id sp61id |
Jiný právní vztah - určuje nemovitost k tíži | PYJPV sp60id1 sp61id1 | 1,1 : 0,M | PYNEMOV sp60id sp61id |
Jiný právní vztah - určuje nemovitost ku prospěchu | PYJPV sp60id2 sp61id2 | 1,1 : 0,M | PYNEMOV sp60id sp61id |
Způsob ochrany nemovitosti RZO - je definován pro nemovitost | PYNEMZPO sp60id sp61id | 1,1 : 0,M s rušením | PYNEMOV sp60id sp61id |
Bonitní díl parcely - patří parcele | PYBDP sp60id sp61id | 1,1 : 0,M s rušením | PYNEMOV sp60id sp61id |
Označení nemovitosti pro Topol - je označením nemovitosti | PYTOPOZN sp60id sp61id | 1,1 : 0,M s rušením | PYNEMOV sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_PYNEMOV_spartikl | P | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_PYNEMOV_spartikl1 |  | sp60id1, sp61id1 | CI - sp60id1+sp61id1
ix_PYNEMOV_spartikl2 |  | sp60id2, sp61id2 | CI - sp60id2+sp61id2
ix_PYNEMOV_spartiknx |  |  |
ix_PYNEMOV_py10id |  | py10id | Číslo katastru
ix_PYNEMOV_py01extid |  | py01extid | Externí identifikace nemovitosti
ix_PYNEMOV_py04id |  | py04id | Identifikace umístění nemovitosti
ix_PYNEMOV_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_PYNEMOV_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_PYNEMOV_py12typnem |  | py12typnem | Typ nemovitosti (typbud,typjed)
ix_PYNEMOV_py12zdrevi |  | py12zdrevi | Zdroj evidence parcel
ix_PYNEMOV_py12zpuvym |  | py12zpuvym | Způsob určení výměry
ix_PYNEMOV_py12zpuvyu |  | py12zpuvyu | Způsob využití nemovitosti
ix_PYNEMOV_py18id |  | py18id | ID listu vlastnictví
ix_PYNEMOV_py21rizvzn |  | py21rizvzn | Řízení vzniku
ix_PYNEMOV_py21rizzan |  | py21rizzan | Řízení zániku
ix_PYNEMOV_py01kmecis |  | py01kmecis | Kmenové číslo parcely
ix_PYNEMOV_py32id |  | py32id | Identifikátor stavu dat

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYNEMSTA Nemovitost ve stavu

Popis

Nemovitost ve stavu

Atributy

Atribut | Typ | Návěští | Message | Popis
py06id | C(6) | Stav | Identifikace stavu nemovitosti | Identifikace stavu nemovitosti
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
py07porad | N(5,0) | Pořadí záznamu | Pořadí záznamu | Pořadí záznamu
py07platod | D | Platnost od | Platnost od | Platnost od
py07platdo | D | do | Platnost do | Platnost do

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Nemovitost ve stavu - určuje stav | PYNEMSTA py06id | 1,1 : 0,M | PYSTAV py06id |
Nemovitost ve stavu - určuje nemovitost | PYNEMSTA sp60id sp61id | 1,1 : 0,M s rušením | PYNEMOV sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_PYNEMSTA_pynemsta | P | py06id, sp60id, sp61id, py07porad | PI - py06id+SPARTIKL+py07porad
ix_PYNEMSTA_py06id |  | py06id | Identifikace stavu nemovitosti
ix_PYNEMSTA_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYNEMZPO Způsob ochrany nemovitosti RZO

Popis

Vazební tabulka přiřazující způsob ochrany nemovitosti ke konkrétní parcele, budově nebo jednotce.

Způsoby ochrany parcel jsou vázány na parcelu, nikoli na díl parcely.
Nemovitosti mohou mít jen takové způsoby ochrany, které jsou pro ně povoleny.

Atributy

Atribut | Typ | Návěští | Message | Popis
py27id | C(30) | ID | Identifikace záznamu | Identifikace záznamu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
py21rizvzn | C(30) | Řízení vzniku | Řízení vzniku | Řízení vzniku
py21rizzan | C(30) | Řízení zániku | Řízení zániku | Řízení zániku
py12zpuoch | C(10) | Ochrana | Způsob ochrany nemovitosti | Způsob ochrany nemovitosti
py27datvzn | D | Datum vzniku | Datum vzniku | Datum vzniku
py27datzan | D | Datum zániku | Datum zániku | Datum zániku
py32id | C(6) | Stav dat | Identifikátor stavu dat | Identifikátor stavu dat

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Způsob ochrany nemovitosti RZO - vznikl řízením | PYNEMZPO py21rizvzn | 1,1 : 0,M | PYRIZENI py21id |
Způsob ochrany nemovitosti RZO - zanikl řízením | PYNEMZPO py21rizzan | 1,1 : 0,M | PYRIZENI py21id |
Způsob ochrany nemovitosti RZO - je definován pro nemovitost | PYNEMZPO sp60id sp61id | 1,1 : 0,M s rušením | PYNEMOV sp60id sp61id |
Způsob ochrany nemovitosti RZO - určuje typ způsobu ochrana pro nemovitost | PYNEMZPO py12zpuoch | 1,1 : 0,M | PYTYPCIS py12id |
Způsob ochrany nemovitosti RZO - je ve stavu dat | PYNEMZPO py32id | 1,1 : 0,M | PYSTADAT py32id |

Indexy

Název | Primární | Výraz | Popis
ix_PYNEMZPO_py27id | P | py27id | Identifikace záznamu
ix_PYNEMZPO_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_PYNEMZPO_py21rizvzn |  | py21rizvzn | Řízení vzniku
ix_PYNEMZPO_py21rizzan |  | py21rizzan | Řízení zániku
ix_PYNEMZPO_py12zpuoch |  | py12zpuoch | Způsob ochrany nemovitosti
ix_PYNEMZPO_py32id |  | py32id | Identifikátor stavu dat

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYOPSUB Oprávněný subjekt - OPSUB

Popis

Fyzická nebo právnická osoba jako vlastník nebo jiný oprávněný.
Manželé v bezpodílovém spoluvlastnictví.

Sloupce ID_ZDROJ a VERZE_ZDROJ se uplatní pro práci se společnými daty. Identi-fikují instanci oprávněného subjektu na pracovišti, které první provedlo změnu v oprávněném
subjektu.

Poznámka: některé fyzické osoby mohou být zapsány nestandardně (příjmení, jméno atd. nejsou zapsány ve struktuře pod údaji JMENO, PRIJMENI,…, ale jsou dohromady v údaji NAZEV, resp. NAZEV_U); je to důsledek migrace dat, postupně jsou údaje opravovány.

Poznámka: Sloupce NAZEV_U, JMENO_U, PRIJMENI_U obsahují "normalizovaný" tvar názvu, jména a příjmení (bez diakritiky, velká písmena). Rodné příjmení je u účastníků, u oprávněných subjektů nikoli.

Atributy

Atribut | Typ | Návěští | Message | Popis
py16id | C(30) | Subjekt | Identifikace oprávněného subjektu | Identifikace oprávněného subjektu
py12typos | C(10) | Typ | Typ oprávněného subjektu | Typ oprávněného subjektu
py12charos | C(10) | Charakteristika | Charakteristika oprávněného subjektu | Charakteristika oprávněného subjektu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
py16datvzn | D | Datum vzniku | Datum vzniku | Datum vzniku
py16datzan | D | Datum zániku | Datum zániku | Datum zániku
py21rizvzn | C(30) | Řízení vzniku | Řízení vzniku | Řízení vzniku
py21rizzan | C(30) | Řízení zániku | Řízení zániku | Řízení zániku
py16idpar1 | C(30) | Je 1 partner BSM | Je 1 partner BSM | Je 1 partner BSM - bezpodílové spoluvlastnictví manželů
py16idpar2 | C(30) | Je 2 partner BSM | Je 2 partner BSM | Je 2 partner BSM - bezpodílové spoluvlastnictví manželů
py16zdroj | C(40) | Pracoviště | Identifikace zdrojového pracoviště | Identifikace zdrojového pracoviště
py16ico | C(10) | IČO | IČO | IČO
py16dopico | C(3) | Doplněk IČO | Doplněk IČO | Doplněk IČO
py16rodcis | C(10) | Rodné číslo | Rodné číslo | Rodné číslo
py16titpre | C(40) | Titul před | Titul před jménem | Titul před jménem
py16titza | C(10) | Titul za | Titul za jménem | Titul za jménem
py16jmeno | C(24) | Jméno | Jméno | Jméno
py16cisdom | N(4,0) | Číslo domovní | Číslo domovní | Číslo domovní
py16cisor | C(4) | Číslo orientační | Číslo orientační | Číslo orientační
py16ulice | C(40) | Ulice | Ulice | Ulice
py16castob | C(60) | Část obce | Část obce | Část obce
py16obec | C(60) | Obec | Obec | Obec
py16okres | C(40) | Okres | Okres | Okres
py16stat | C(40) | Stát | Stát | Stát
py16psc | N(5,0) | PSČ | PSČ | PSC
py16nazpri | C(254) | Název subjektu | Název nebo příjmení oprávněného subjektu | Název nebo příjmení oprávněného subjektu
ad01id1 | C(6) | Importovaný | Identifikace importovaného adresáta | Identifikace adresáta - pro import
ad01id2 | C(6) | Adresát | Adresát subjektu spojení adresáta | Adresát subjektu spojení adresáta
py32id | C(6) | Stav dat | Identifikátor stavu dat | Identifikátor stavu dat

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Oprávněný subjekt - OPSUB - má charakteristiku | PYOPSUB py12charos | 1,1 : 0,M | PYTYPCIS py12id |
Oprávněný subjekt - OPSUB - je typu | PYOPSUB py12typos | 1,1 : 0,M | PYTYPCIS py12id |
Oprávněný subjekt - OPSUB - odpovídá adresátovi | PYOPSUB ad01id | 1,1 : 0,M | ADADSAT ad01id |
Oprávněný subjekt - OPSUB - vznikl řízením | PYOPSUB py21rizvzn | 1,1 : 0,M | PYRIZENI py21id |
Oprávněný subjekt - OPSUB - zanikl řízením | PYOPSUB py21rizzan | 1,1 : 0,M | PYRIZENI py21id |
Oprávněný subjekt - OPSUB - má partnera BMS 2 | PYOPSUB ad01id2 | 1,1 : 0,M | ADADSAT ad01id |
Oprávněný subjekt - OPSUB - má partnera BMS 1 | PYOPSUB ad01id1 | 1,1 : 0,M | ADADSAT ad01id |
Oprávněný subjekt - OPSUB - je ve stavu dat | PYOPSUB py32id | 1,1 : 0,M | PYSTADAT py32id |

Indexy

Název | Primární | Výraz | Popis
ix_PYOPSUB_py16id | P | py16id | Identifikace oprávněného subjektu
ix_PYOPSUB_py12typos |  | py12typos | Typ oprávněného subjektu
ix_PYOPSUB_py12charos |  | py12charos | Charakteristika oprávněného subjektu
ix_PYOPSUB_ad01id |  | ad01id | Identifikace adresáta
ix_PYOPSUB_py21rizvzn |  | py21rizvzn | Řízení vzniku
ix_PYOPSUB_py21rizzan |  | py21rizzan | Řízení zániku
ix_PYOPSUB_py16idpar1 |  | py16idpar1 | Je 1 partner BSM - bezpodílové spoluvlastnictví manželů
ix_PYOPSUB_py16idpar2 |  | py16idpar2 | Je 2 partner BSM - bezpodílové spoluvlastnictví manželů
ix_PYOPSUB_py16nazpri |  |  | Název nebo příjmení oprávněného subjektu
ix_PYOPSUB_ad01id1 |  | ad01id1 | Identifikace adresáta - pro import
ix_PYOPSUB_ad01id2 |  | ad01id2 | Adresát subjektu spojení adresáta
ix_PYOPSUB_py32id |  | py32id | Identifikátor stavu dat

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYPARAM Parametry komponenty nemovitosti

Popis

Parametry komponenty nemovitosti

Atributy

Atribut | Typ | Návěští | Message | Popis
py30 | C(12) | py30 | Jednoznačná identifikace | Jednoznačná identifikace
pa01id | C(6) | Sada | Identifikátor sady parametrů | Identifikátor sady parametrů
pa01oblast | C(2) | Oblast | Oblast sady parametrů | Oblast sady parametrů
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor druhu operace | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Parametry komponenty nemovitosti - definují sadu parametrů nemovitosti | PYPARAM pa01id pa01oblast | 1,1 : 0,M | PASADA pa01id pa01oblast |
Parametry komponenty nemovitosti - definují implicitní operaci použitou při generování událostí na pozadí | PYPARAM sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |

Indexy

Název | Primární | Výraz | Popis
ix_PYPARAM_py30 | P | py30 | Jednoznačná identifikace
ix_PYPARAM_pasada |  | pa01id, pa01oblast | PI - pa01id+pa01oblast
ix_PYPARAM_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYRIZENI Řízení

Popis

Řízení

Atributy

Atribut | Typ | Návěští | Message | Popis
py21id | C(30) | Řízení | Číslo řízení | Číslo řízení
py12typriz | C(10) | Typ | Kód typu řízení | Kód typu řízení
py21porcis | N(8,0) | Pořadí | Pořadí řízení daného charakteru | Pořadí řízení daného charakteru
py21datriz | D | Zahájeno | Datum zahájení řízení | Datum zahájení řízení
py21stav | C(20) | Stav | Aktuální stav řízení | Aktuální stav řízení
py21fcekod | N(4,0) | Poslední funkce | Kód poslední realizované funkce | Kód poslední realizované funkce
py21typope | N(4,0) | Poslední operace | Kód poslední realizované operace | Kód poslední realizované operace
py21fcekov | N(4,0) | Významná funkce | Kód poslední významné realizované funkce | Kód poslední významné realizované funkce
py21typopv | N(4,0) | Významná operace | Kód poslední významné realizované operace | Kód poslední významné realizované operace
py21uzisys | C(30) | Odpovědná osoba | Jméno uživatele, který má přiřazeno řízení | Jméno uživatele, který má přiřazeno řízení
py21uzirol | C(30) | Role | Jméno role, která má přiřazeno řízení | Jméno role, která má přiřazeno řízení
py21osvob | N(1,0) | Osvobozeno | Osvobozeno od platby Ano/Ne | Osvobozeno od platby Ano/Ne
py21kolek | N(5,0) | Kolek | Hodnota kolkové známky | Hodnota kolkové známky
py21datum | D | Další datum | Datum (další význam podle typu řízení) | Datum (další význam podle typu řízení)
py21datum2 | D | Další datum | Datum (další význam podle typu řízení) | Datum (další význam podle typu řízení)
py21popis | M | Popis | Popis (další význam podle typu řízení) | Popis (další význam podle typu řízení)
py21datuza | D | Datum uzavření | Datum uzavření řízení | Datum uzavření řízení

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Řízení - má definovaný typ řízení | PYRIZENI py12typriz | 1,1 : 0,M | PYTYPCIS py12id |
Nemovitost - vznikla řízením | PYNEMOV py21rizvzn | 1,1 : 0,M | PYRIZENI py21id |
Nemovitost - zanikla řízením | PYNEMOV py21rizzan | 1,1 : 0,M | PYRIZENI py21id |
Účastník řízení UCAST - se účatní řízení | PYRIZUC py21id | 1,1 : 0,M | PYRIZENI py21id |
Oprávněný subjekt - OPSUB - vznikl řízením | PYOPSUB py21rizvzn | 1,1 : 0,M | PYRIZENI py21id |
Oprávněný subjekt - OPSUB - zanikl řízením | PYOPSUB py21rizzan | 1,1 : 0,M | PYRIZENI py21id |
Listina - patří k řízení | PYLISTIN py21id | 0,1 : 0,M | PYRIZENI py21id |
List vlastnictví nemovitosti (těleso) - vznikl řízením | PYNEMLV py21rizvzn | 1,1 : 0,M | PYRIZENI py21id |
List vlastnictví nemovitosti (těleso) - zanikl řízením | PYNEMLV py21rizzan | 1,1 : 0,M | PYRIZENI py21id |
Vlastnictví nemovitosti VLA - vznikl řízením | PYNEMLVP py21rizvzn | 1,1 : 0,M | PYRIZENI py21id |
Vlastnictví nemovitosti VLA - vznikl řízením | PYNEMLVP py21rizzan | 1,1 : 0,M | PYRIZENI py21id |
Objekt řízení OBJRIZ - spojuje nemovitost s řízením | PYRIZOBJ py21id | 1,1 : 0,M | PYRIZENI py21id |
Přiřazení listiny k nemovitosti RL - vzniklo řízením | PYLISNEM py21rizvzn | 0,1 : 0,M | PYRIZENI py21id |
Přiřazení listiny k nemovitosti RL - zaniklo řízením | PYLISNEM py21rizzan | 0,1 : 0,M | PYRIZENI py21id |
Jiný právní vztah - zanikl řízením | PYJPV py21rizzan | 0,1 : 0,M | PYRIZENI py21id |
Předmět řízení - je vztažen k řízení | PYRIZPRE py21id | 1,1 : 0,M | PYRIZENI py21id |
Způsob ochrany nemovitosti RZO - vznikl řízením | PYNEMZPO py21rizvzn | 1,1 : 0,M | PYRIZENI py21id |
Způsob ochrany nemovitosti RZO - zanikl řízením | PYNEMZPO py21rizzan | 1,1 : 0,M | PYRIZENI py21id |
Bonitní díl parcely - vznikl řízením | PYBDP py21rizvzn | 1,1 : 0,M | PYRIZENI py21id |
Bonitní díl parcely - zanikl řízením | PYBDP py21rizzan | 1,1 : 0,M | PYRIZENI py21id |

Indexy

Název | Primární | Výraz | Popis
ix_PYRIZENI_py21id | P | py21id | Číslo řízení
ix_PYRIZENI_py12typriz |  | py12typriz | Kód typu řízení

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYRIZOBJ Objekt řízení OBJRIZ

Popis

Objektem řízení je nemovitost účastná řízení a to parcela, jednotka
nebo budova. Tabulka je vazební tabulkou mezi řízením a nemovitostí. Při
plombování řízení (vklad, záznam) lze zaplombovat vybrané objekty říze
ní.
V objektu řízení nejsou zapsány nově vznikající nemovitosti!

Atributy

Atribut | Typ | Návěští | Message | Popis
py20id | C(30) | ID | Identifikace objektu řízení | Identifikace objektu řízení
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
py21id | C(30) | Řízení | Číslo řízení | Číslo řízení
py20datplo | D | Zaplombování | Datum zaplombování nebo zápisu objektů do řízení. | Datum zaplombování nebo zápisu objektů do řízení.
py20datodp | D | Odplombování | Datum odstranění plomby | Datum odstranění plomby

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Objekt řízení OBJRIZ - spojuje řízení s nemovitostí | PYRIZOBJ sp60id sp61id | 1,1 : 0,M | PYNEMOV sp60id sp61id |
Objekt řízení OBJRIZ - spojuje nemovitost s řízením | PYRIZOBJ py21id | 1,1 : 0,M | PYRIZENI py21id |

Indexy

Název | Primární | Výraz | Popis
ix_PYRIZOBJ_py20id | P | py20id | Identifikace objektu řízení
ix_PYRIZOBJ_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_PYRIZOBJ_py21id |  | py21id | Číslo řízení

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYRIZPRE Předmět řízení

Popis

Tabulka Předměty řízení obsahuje přiřazené typy předmětu řízení vybrané z číselníku Typy předmětu řízení. Předmět řízení podrobněji specifikuje náplň daného řízení.

Atributy

Atribut | Typ | Návěští | Message | Popis
py21id | C(30) | Řízení | Číslo řízení | Číslo řízení
py12typpre | C(10) | Typ | Typ předmětu řízení | Typ předmětu řízení

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Předmět řízení - je vztažen k řízení | PYRIZPRE py21id | 1,1 : 0,M | PYRIZENI py21id |
Předmět řízení - má typ předmětu řízení | PYRIZPRE py12typpre | 1,1 : 0,M | PYTYPCIS py12id |

Indexy

Název | Primární | Výraz | Popis
ix_PYRIZPRE_pyrizpre | P | py21id, py12typpre | PI - py21id+py12typpre
ix_PYRIZPRE_py21id |  | py21id | Číslo řízení
ix_PYRIZPRE_py12typpre |  | py12typpre | Typ předmětu řízení

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYRIZUC Účastník řízení UCAST

Popis

Účastníky se rozumí fyzické nebo právnické osoby (případně
jejich organizační jednotky) dotčené příslušným řízením. Je-li nějaká
osoba účastná více řízení, jsou údaje v entitě Účastník zaznamenány
opakovaně.

Poznámka: Sloupce NAZEV_U, JMENO_U, PRIJMENI_U obsahují “normalizovaný” tvar názvu, jména a příjmení (bez diakritiky, velká písmena). Rodné příjmení je u účastníků, u oprávněných subjektů nikoli.

Atributy

Atribut | Typ | Návěští | Message | Popis
py14id | C(30) | Účastník | Identifikace účastníka řízení | Identifikace účastníka řízení
py21id | C(30) | Řízení | Číslo řízení | Číslo řízení
py14ico | C(8) | IČO | IČO | IČO
py14doplic | C(3) | Doplněk IČO | Doplněk IČO | Doplněk IČO
py14jmeno | C(40) | Jméno | Jméno | Jméno
py14titpre | C(40) | Titul před | Titul před jménem | Titul před jménem
py14titza | C(10) | Titul za | Titul za jménem | Titul za jménem
py14prijmr | C(40) | Příjmení rodné | Příjmení rodné | Příjmení rodné
py14rodcis | C(10) | Rodné číslo | Rodné číslo | Rodné číslo
py14podpis | C(1) | Ověření podpisu | Ověření podpisu proti podpisovému vzoru. | Ověření podpisu proti podpisovému vzoru.
py14overen | C(1) | Ověření proti OPSUB | Ověření proti OPSUB - oprávněné subjekty | Pokud je Účastníkem proti Oprávněným subjektům ověřen manuálně, je hodnota sloupce Overeni_proti_os nastavena na "úspěšně ověřen uživatelem". +4/VA Pokud je Účastník dohledán v Oprávněných subjektech automaticky systémem, je hodnota sloupce Overeni_proti_OS nastavena na "úspěšně ověřen systémem". Totéž platí pro ověření proti RS. +5/VA Pokud není Účastník dohledán v Oprávněných subjektech automaticky systémem, je hodnota sloupce Overeni_proti_OS nastavena na "neúspěšně ověřen systémem". Totéž platí pro ověření proti RS.
py14dic | C(14) | DIČ | DIČ | DIČO
py14objm | C(254) | Název | Obchodní jméno | Obchodní jméno
py14druhuc | N(1,0) | Druh účastníka | Druh účastníka řízení (fyzická, právnická osoba). | Druh účastníka řízení (fyzická, právnická osoba).

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Účastník řízení UCAST - se účatní řízení | PYRIZUC py21id | 1,1 : 0,M | PYRIZENI py21id |
Adresa účastníka řízení ADRUCA - je vázána na účastníka řízení | PYRIZUCA py14id | 1,1 : 0,M | PYRIZUC py14id |
Typ účastníka v řízení UCTYP - je definován pro účastníka řízení | PYRIZUCT py14id | 1,1 : 0,M | PYRIZUC py14id |
Informace o obeslání účastníka řízení OBESMF - se týká účastníka řízení | PYRIZUCO py14id | 1,1 : 0,M | PYRIZUC py14id |

Indexy

Název | Primární | Výraz | Popis
ix_PYRIZUC_py14id | P | py14id | Identifikace účastníka řízení
ix_PYRIZUC_py21id |  | py21id | Číslo řízení

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYRIZUCA Adresa účastníka řízení ADRUCA

Popis

Adresa účastníka řízení. Jeden účastník může mít více typů adres -
jednotlivé typy jsou dány hodnotou atributu TYP ADRESY.

Atributy

Atribut | Typ | Návěští | Message | Popis
py14id | C(30) | Účastník | Identifikace účastníka řízení | Identifikace účastníka řízení
py13typadr | N(1,0) | Typ | Typ adresy | Typ adresy
py13okres | C(40) | Okres | Okres | Okres
py13obec | C(60) | Obec | Obec | Obec
py13casobc | C(60) | Část obce | %Cást obce | Část obce
py13cisdom | N(4,0) | Číslo domovní | Číslo domovní | Číslo domovní
py13ulice | C(60) | Ulice | Ulice | Ulice
py13cisor | C(4) | Číslo orientační | Číslo orientační | Číslo orientační
py13psc | N(5,0) | Psč | Psč | Psč
py13stat | C(23) | Stát | Stát | Stát
py13telef | C(40) | Telefon | Telefonní číslo | Telefonní číslo
py13fax | C(40) | Fax | Fax | Fax

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Adresa účastníka řízení ADRUCA - je vázána na účastníka řízení | PYRIZUCA py14id | 1,1 : 0,M | PYRIZUC py14id |

Indexy

Název | Primární | Výraz | Popis
ix_PYRIZUCA_pyadruca | P | py14id, py13typadr | PI - py14id+py13typadr
ix_PYRIZUCA_py14id |  | py14id | Identifikace účastníka řízení

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYRIZUCO Informace o obeslání účastníka řízení OBESMF

Popis

V tabulce jsou údaje o obesláních v rámci definovaných operací. Jsou sledovány pouze údaje o obeslání v rámci operace 103 - Vypravení spisu. Vytvoření záznamu proběhne v okamžiku změny stavu obeslání na jeden ze stavů (6 = doručenka přija-ta - doručeno, 7 = doručenka přijata - doručeno 3.den od uložení, 8 = předá-no/doručeno vyvěšením, 9 = storno korespondence, 0 = korespondence nedoručena). Pro stavy 6, 7 a 8 bude rovněž vyplněno datum přijetí doručenky. Pro každého účastníka je vytvořen maximálně jeden záznam a to podle následujících pravidel. Pokud bude vytvořen záznam se stavem obeslání 6, 7 nebo 8, o účastníku, k němuž již existuje záznam se stavem 0 nebo 9, nahradí se původní záznam novým obeslá-ním. Pokud již existuje záznam se stavem 6, 7 nebo 8, nový záznam se bude igno-rovat. Pokud dojde k aktualizaci datumu doručení, bude tato změna opět zazname-nána k příslušnému záznamu o obeslání.

Atributy

Atribut | Typ | Návěští | Message | Popis
py28id | C(30) | Obeslání | Identifikace obeslání úč.řízení | Identifikace obeslání úč.řízení
py14id | C(30) | Účastník | Identifikace účastníka řízení | Identifikace účastníka řízení
py16id | C(30) | Subjekt | Identifikace oprávněného subjektu | Identifikace oprávněného subjektu
py28stavob | C(1) | Stav obeslání | Stav obeslání | Stav obeslání
py28datpri | D | Přijato | Datum přijetí korespondence účastníkem - doručenka | Datum přijetí korespondence účastníkem
py12zpuobe | C(10) | Způsob | Způsob obeslání | Způsob obeslání
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Informace o obeslání účastníka řízení OBESMF - se týká účastníka řízení | PYRIZUCO py14id | 1,1 : 0,M | PYRIZUC py14id |
Informace o obeslání účastníka řízení OBESMF - udává způsob obeslání účastníka řízení | PYRIZUCO py12zpuobe | 1,1 : 0,M | PYTYPCIS py12id |
Informace o obeslání účastníka řízení OBESMF - se týká adresáta - oprávněného subjektu | PYRIZUCO ad01id | 1,1 : 0,M | ADADSAT ad01id |

Indexy

Název | Primární | Výraz | Popis
ix_PYRIZUCO_py28id | P | py28id | Identifikace obeslání úč.řízení
ix_PYRIZUCO_py14id |  | py14id | Identifikace účastníka řízení
ix_PYRIZUCO_py16id |  | py16id | Identifikace oprávněného subjektu
ix_PYRIZUCO_py12zpuobe |  | py12zpuobe | Způsob obeslání
ix_PYRIZUCO_ad01id |  | ad01id | Identifikace adresáta

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYRIZUCT Typ účastníka v řízení UCTYP

Popis

Vazební tabulka mezi účastníky řízení a číselníkem TYPY_UCASTNIKU.

Atributy

Atribut | Typ | Návěští | Message | Popis
py14id | C(30) | Účastník | Identifikace účastníka řízení | Identifikace účastníka řízení
py12typuca | C(10) | Typ | Typ účastníka řízení | Typ účastníka řízení

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Typ účastníka v řízení UCTYP - má definovaný typ pro účastníka řízeni | PYRIZUCT py12typuca | 1,1 : 0,M | PYTYPCIS py12id |
Typ účastníka v řízení UCTYP - je definován pro účastníka řízení | PYRIZUCT py14id | 1,1 : 0,M | PYRIZUC py14id |

Indexy

Název | Primární | Výraz | Popis
ix_PYRIZUCT_pyuctyp | P | py14id, py12typuca | PI py14id+py12kodid
ix_PYRIZUCT_py14id |  | py14id | Identifikace účastníka řízení
ix_PYRIZUCT_py12typuca |  | py12typuca | Typ účastníka řízení

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYSPRCEL Správní celek

Popis

Správní celky - část obce, obec, okres,kraj

Atributy

Atribut | Typ | Návěští | Message | Popis
py11id | C(8) | Správní celek | Obec,Část obce, Okres,Kraj | Obec,Část obce, Okres,Kraj
py11idnsc | C(8) | Nadř. celek | Nadřazený správní celek | Nadřazený správní celek
py11nazspc | C(60) | Název | Název správního celku | Název správního celku
py11platod | D | Platnost od | Platnost spr.celku od | Platnost spr.celku od
py11platdo | D | Platnost do | Platnost spr.celku do | Platnost spr.celku do

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Správní celek - je podřízený správnímu celku | PYSPRCEL py11idnsc | 0,1 : 0,M | PYSPRCEL py11id |
Katastrální území - má uveden kód obce | PYKATAST py11id | 1,1 : 0,M | PYSPRCEL py11id |
Správní celek - je podřízený správnímu celku | PYSPRCEL py11idnsc | 0,1 : 0,M | PYSPRCEL py11id |

Indexy

Název | Primární | Výraz | Popis
ix_PYSPRCEL_py11id | P | py11id | Obec,Část obce, Okres,Kraj
ix_PYSPRCEL_py11idnsc |  | py11idnsc | Nadřazený správní celek
ix_PYSPRCEL_py11nazspc |  | py11nazspc | Název správního celku

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYSPRCEP Pohled do PYSPRCEL

Atributy

Atribut | Typ | Návěští | Message | Popis
py11id | C(8) | Správní celek | Obec,Část obce, Okres,Kraj | Obec,Část obce, Okres,Kraj
py11nazspc | C(60) | Název | Název správního celku | Název správního celku

Indexy

Název | Primární | Výraz | Popis
ix_PYSPRCEP_py11id |  | py11id | Obec,Část obce, Okres,Kraj

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYSTADAT Stav dat

Popis

Stav dat podle stavu a kontextu dat Geodezie

Atributy

Atribut | Typ | Návěští | Message | Popis
py32id | C(6) | Stav dat | Identifikátor stavu dat | Identifikátor stavu dat
py32popsta | C(40) | Název stavu dat | Název stavu dat | Název stavu dat
py32koment | M | Poznámka | Poznámka | Poznámka
py32stadat | N(3,0) | Stav ISKN | Stav v informačním systému katastru nemovitostí | Stav v informačním systému katastru nemovitostí
py32prikon | N(1,0) | Kontext změny ISKN | Kontext změny v informačním systému katastru nemovitostí | Kontext změny v informačním systému katastru nemovitostí
py32podb | N(1,0) | Podbarvit | Podbarvení v mřížce | Podbarvení v mřížce

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Nemovitost - má stav dat | PYNEMOV py32id | 1,1 : 0,M | PYSTADAT py32id |
Oprávněný subjekt - OPSUB - je ve stavu dat | PYOPSUB py32id | 1,1 : 0,M | PYSTADAT py32id |
List vlastnictví nemovitosti (těleso) - je ve stavu | PYNEMLV py32id | 1,1 : 0,M | PYSTADAT py32id |
Vlastnictví nemovitosti VLA - je ve stavu dat | PYNEMLVP py32id | 1,1 : 0,M | PYSTADAT py32id |
Přiřazení listiny k nemovitosti RL - je ve stavu dat | PYLISNEM py32id | 1,1 : 0,M | PYSTADAT py32id |
Jiný právní vztah - je ve stavu | PYJPV py32id | 1,1 : 0,M | PYSTADAT py32id |
Způsob ochrany nemovitosti RZO - je ve stavu dat | PYNEMZPO py32id | 1,1 : 0,M | PYSTADAT py32id |
Bonitní díl parcely - je ve stavu dat | PYBDP py32id | 1,1 : 0,M | PYSTADAT py32id |

Indexy

Název | Primární | Výraz | Popis
ix_PYSTADAT_py32id | P | py32id | Identifikátor stavu dat
ix_PYSTADAT_py32popsta |  | py32popsta | Název stavu dat

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYSTAV Stav nemovitosti podle našeho zájmu

Popis

Stav nemovitosti podle našeho zájmu

Atributy

Atribut | Typ | Návěští | Message | Popis
py06id | C(6) | Stav | Identifikace stavu nemovitosti | Identifikace stavu nemovitosti
py06nazsta | C(40) | Název stavu | Název stavu nemovitosti | Název stavu nemovitosti
py06barva | N(1,0) | Barva | Barva zvýraznění nemovitosti ve stavu | Barva zvýraznění nemovitosti ve stavu
py06koment | M | Poznámka | Poznámka | Poznámka
py06sql | M | Určující SQL dotaz odvozeného stavu | Určující SQL dotaz odvozeného stavu vracející atributy s významem sp61id,sp60id,py07datod,py07datdo | Určující SQL dotaz stavu
py06masql | N(1,0) | Odvozený stav | Stav nemovitosti je odvozený podle stavu dat Ano/Ne | Odvozený stav
bw95id | C(6) | Barva | Identifikace barvy RGB | Identifikace barvy RGB
py06prior | N(3,0) | Priorita | Priorita stavu pro zobrazení barvy nemovitosti | Priorita stavu pro zobrazení barvy

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Stav nemovitosti podle našeho zájmu - má definovanou barvu pro Topol | PYSTAV bw95id | 1,1 : 0,M | BWRGBCOL bw95id |
Druh události o nemovitosti - se týká druhu události | PYDRUUDA py06id | 0,1 : 0,M s rušením | PYSTAV py06id |
Nemovitost ve stavu - určuje stav | PYNEMSTA py06id | 1,1 : 0,M | PYSTAV py06id |

Indexy

Název | Primární | Výraz | Popis
ix_PYSTAV_py06id | P | py06id | Identifikace stavu nemovitosti
ix_PYSTAV_py06nazsta |  | py06nazsta | Název stavu nemovitosti
ix_PYSTAV_bw95id |  | bw95id | Identifikace barvy RGB

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYTOPMAP Popis mapy v Topolu

Popis

Popis mapy v Topolu

Atributy

Atribut | Typ | Návěští | Message | Popis
py35idcol | C(6) | SQL barvy | Identifikace dotazu SQL pro zobrazení barev | Identifikace dotazu SQL pro zobrazení barev
py35idpop | C(6) | SQL popisu | Identifikace dotazu SQL pro zobrazení popisů | Identifikace dotazu SQL pro zobrazení popisů
py35idleg | C(6) | SQL legendy | Identifikace dotazu SQL pro zobrazení legendy | Identifikace dotazu SQL pro zobrazení legendy
py36popis | C(40) | Mapa | Popis mapy | Popis mapy
py36koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis mapy v Topolu - používá SQL dotaz pro zobrazení popisu | PYTOPMAP py35idpop | 1,1 : 0,M | PYTOPSQL py35id |
Popis mapy v Topolu - používá SQL dotaz pro zobrazení legendy | PYTOPMAP py35idleg | 1,1 : 0,M | PYTOPSQL py35id |
Popis mapy v Topolu - používá SQL dotaz pro zobrazení barev | PYTOPMAP py35idcol | 1,1 : 0,M | PYTOPSQL py35id |

Indexy

Název | Primární | Výraz | Popis
ix_PYTOPMAP_pytopmap | P | py35idcol, py35idpop | PI - py35idcol+py35idpop
ix_PYTOPMAP_py35idcol |  | py35idcol | Identifikace dotazu SQL pro zobrazení barev
ix_PYTOPMAP_py35idpop |  | py35idpop | Identifikace dotazu SQL pro zobrazení popisů
ix_PYTOPMAP_py35idleg |  | py35idleg | Identifikace dotazu SQL pro zobrazení legendy

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYTOPOZN Označení nemovitosti pro Topol

Popis

Označení nemovitosti pro Topol

Atributy

Atribut | Typ | Návěští | Message | Popis
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Označení nemovitosti pro Topol - je označením nemovitosti | PYTOPOZN sp60id sp61id | 1,1 : 0,M s rušením | PYNEMOV sp60id sp61id |

Indexy

Název | Primární | Výraz | Popis
ix_PYTOPOZN_spartikl | P | sp60id, sp61id | Primární index artiklu sp60id+sp61id

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYTOPSQL SQL dotaz pro zobrazení v topolu

Popis

SQL dotazy pro zobrazení v topolu

Atributy

Atribut | Typ | Návěští | Message | Popis
py35id | C(6) | ID | Identifikace dotazu SQL | Identifikace dotazu SQL
py35popis | C(40) | Popis | Popis SQL dotazu | Popis SQL dotazu
py35typ | N(1,0) | Typ | Typ SQL dotazu | Typ SQL dotazu
py35sql | M | SQL | SQL dotaz | SQL dotaz
py35koment | M | Poznámka | Poznámka | Poznámka
sp00datakt | T | Aktualizace | Datum aktualizace | Datum aktualizace

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Popis mapy v Topolu - používá SQL dotaz pro zobrazení popisu | PYTOPMAP py35idpop | 1,1 : 0,M | PYTOPSQL py35id |
Popis mapy v Topolu - používá SQL dotaz pro zobrazení legendy | PYTOPMAP py35idleg | 1,1 : 0,M | PYTOPSQL py35id |
Popis mapy v Topolu - používá SQL dotaz pro zobrazení barev | PYTOPMAP py35idcol | 1,1 : 0,M | PYTOPSQL py35id |

Indexy

Název | Primární | Výraz | Popis
ix_PYTOPSQL_py35id | P | py35id | Identifikace dotazu SQL
ix_PYTOPSQL_py35popis |  | py35popis | Popis SQL dotazu

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYTRAN Transformace změny obsahu entity do události o nemovitosti

Popis

Transformace změny obsahu entity do události o nemovitosti

Atributy

Atribut | Typ | Návěští | Message | Popis
py09 | C(12) | py09 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
bw10nazev | C(8) | Tabulka | Název entity | Název entity
py09naztra | C(40) | Transformace | Název transformace | Název transformace
py09podins | M | Podmínka | Podmínka vzniku události o nemovitosti při vložení záznamu | Podmínka vzniku události o nemovitosti při vložení záznamu
py09podupd | M | Podmínka | Podmínka vzniku události o nemovitosti při opravě záznamu | Podmínka vzniku události o nemovitosti při opravě záznamu
py09poddel | M | Podmínka | Podmínka vzniku události o nemovitosti při zrušení záznamu | Podmínka vzniku události o nemovitosti při zrušení záznamu
py09insert | N(1,0) | Vkládání | Uplatní se při vložení záznamu tabulky Ano/Ne | Uplatní se při vložení záznamu tabulky Ano/Ne
py09update | N(1,0) | Oprava | Uplatní se při opravě záznamu tabulky Ano/Ne | Uplatní se při opravě záznamu tabulky Ano/Ne
py09delete | N(1,0) | Rušení | Uplatní se při rušení záznamu tabulky Ano/Ne | Uplatní se při rušení záznamu tabulky Ano/Ne
py03id | C(6) | Druh | Identifikace druhu události o nemovitosti | Identifikace druhu události o nemovitosti
py09koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Transformace změny obsahu entity do události o nemovitosti - generuje událost o nemovitosti s druhem události | PYTRAN py03id | 1,1 : 0,M | PYDRUUDA py03id |
Výraz transformace hodnoty atributu události o nemovitosti - je výrazem transformace | PYTRANAT py09 | 1,1 : 0,M | PYTRAN py09 |

Indexy

Název | Primární | Výraz | Popis
ix_PYTRAN_py09 | P | py09 | Jednoznačná časová identifikace
ix_PYTRAN_bw10nazev |  | bw10nazev | Název entity
ix_PYTRAN_py09naztra |  | py09naztra | Název transformace
ix_PYTRAN_py03id |  | py03id | Identifikace druhu události o nemovitosti

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYTRANAT Výraz transformace hodnoty atributu události o nemovitosti

Popis

Výraz transformace hodnoty atributu události o nemovitosti

Atributy

Atribut | Typ | Návěští | Message | Popis
py09 | C(12) | py09 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
bw11nazev | C(10) | Atribut | Název atributu | Název atributu
py05vyraz | M | Výraz | Výraz transformované hodnoty do atributu | Výraz transformované hodnoty do atributu
py05koment | M | Poznámka | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Výraz transformace hodnoty atributu události o nemovitosti - je výrazem transformace | PYTRANAT py09 | 1,1 : 0,M | PYTRAN py09 |

Indexy

Název | Primární | Výraz | Popis
ix_PYTRANAT_pytranat | P | py09, bw11nazev | PI - py09+bw11nazev
ix_PYTRANAT_py09 |  | py09 | Jednoznačná časová identifikace
ix_PYTRANAT_bw11nazev |  | bw11nazev | Název atributu

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYTYPCIS Sloučený typ - spojené číselníky

Popis

Sloučený typ - typjed, typbud, zpvybu, zdpaze, zpurvy, charos, typriz, typpre, dul, typlis, typuca, typsos, zpochn, kodchb, zpvypo, drupoz,zpvyje,typrav.
Popisné číselníky z IMPORTU NVF spojené do jedné entity.

Atributy

Atribut | Typ | Návěští | Message | Popis
py12id | C(10) | ID | Identifikace typu | Kód sloučeného typu TYP - je označení zdrojové entity kód - je vlastní popisný kód
py12platod | D | Platnost od | Platnost od | Platnost od
py12platdo | D | Platnost do | Platnost do | Platnost do
py12nazev | C(60) | Název typu | Název typu | Název sloučeného typu
py12zkrat | C(16) | Zkratka | Zkratka typu | Zkratka sloučeného typu
py12poznam | M | Poznámka | Poznámka | Poznámka- popis sloučeného typu
py12dopkod | C(3) | Doplňkový kód | Doplňkový kód - Způsob využití jednotek ZPVYJE | Doplňkový kód - Způsob využití jednotek ZPVYJE
py12zpopla | C(1) | Zpoplatněn | Je typ rizeni zpoplatněn TYPRIZ Ano/Ne | Je typ rizeni zpoplatněn TYPRIZ
py12druhli | C(2) | Druh listiny | Druh listiny - TYPLIS | Druh listiny - TYPLIS
bw95id | C(6) | Barva | Identifikace barvy RGB | Identifikace barvy RGB

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Sloučený typ - spojené číselníky - má definovanou barvu pro Topol | PYTYPCIS bw95id | 1,1 : 0,M | BWRGBCOL bw95id |
Nemovitost - je typu | PYNEMOV py12typnem | 1,1 : 0,M | PYTYPCIS py12id |
Nemovitost - parcela má zdroj evidence parcel | PYNEMOV py12zdrevi | 1,1 : 0,M | PYTYPCIS py12id |
Nemovitost - má způsob využití výměry | PYNEMOV py12zpuvyu | 1,1 : 0,M | PYTYPCIS py12id |
Nemovitost - parcela má způsob určení výměry | PYNEMOV py12zpuvym | 1,1 : 0,M | PYTYPCIS py12id |
Typ účastníka v řízení UCTYP - má definovaný typ pro účastníka řízeni | PYRIZUCT py12typuca | 1,1 : 0,M | PYTYPCIS py12id |
Oprávněný subjekt - OPSUB - má charakteristiku | PYOPSUB py12charos | 1,1 : 0,M | PYTYPCIS py12id |
Oprávněný subjekt - OPSUB - je typu | PYOPSUB py12typos | 1,1 : 0,M | PYTYPCIS py12id |
Listina - mají typ | PYLISTIN py12typlis | 1,1 : 0,M | PYTYPCIS py12id |
Vlastnictví nemovitosti VLA - má určený typ právního vztahu | PYNEMLVP py12typpra | 1,1 : 0,M | PYTYPCIS py12id |
Řízení - má definovaný typ řízení | PYRIZENI py12typriz | 1,1 : 0,M | PYTYPCIS py12id |
Jiný právní vztah - má určený typ právního vztahu | PYJPV py12typpra | 1,1 : 0,M | PYTYPCIS py12id |
Předmět řízení - má typ předmětu řízení | PYRIZPRE py12typpre | 1,1 : 0,M | PYTYPCIS py12id |
Listina - další údaje LDU - je typu | PYLISDU py12koddal | 1,1 : 0,M | PYTYPCIS py12id |
Způsob ochrany nemovitosti RZO - určuje typ způsobu ochrana pro nemovitost | PYNEMZPO py12zpuoch | 1,1 : 0,M | PYTYPCIS py12id |
Informace o obeslání účastníka řízení OBESMF - udává způsob obeslání účastníka řízení | PYRIZUCO py12zpuobe | 1,1 : 0,M | PYTYPCIS py12id |

Indexy

Název | Primární | Výraz | Popis
ix_PYTYPCIS_py12id | P | py12id | Kód sloučeného typu TYP - je označení zdrojové entity kód - je vlastní popisný kód
ix_PYTYPCIS_py12nazev |  | py12nazev | Název sloučeného typu
ix_PYTYPCIS_bw95id |  | bw95id | Identifikace barvy RGB

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYUDAL Událost o nemovitosti

Atributy

Atribut | Typ | Návěští | Message | Popis
py02 | C(12) | py02 | Jednoznačná časová identifikace | Jednoznačná časová identifikace
sp33cisd | C(8) | Číslo procesu | Pořadové číslo procesu | Číslo procesu
sp33cisdpm | C(2) | IDÚ | Identifikace datového úložiště číselné řady procesu | Pracovní místo čísla řady procesu
sp33cisdr | C(4) | Rok | Rok v identifikaci procesu | Rok řady čísla procesu
sp07idtyp | C(6) | Druh | Identifikátor typu dokladu. | Identifikátor typu dokladu. *** Dříve OZNPDR.
sp06idsubs | C(3) | Komponenta | Identifikace komponenty | Identifikace subsystému. *** Dříve OZNSUB.
sp33porad | N(2,0) | sp33porad | Pořadí stejného druhu operace v jednom procesu | Pořadí stejného druhu operace v jednom procesu
sp60id | C(13) | Artikl | Identifikace artiklu | Identifikace artiklu
sp61id | C(3) | Druh artiklu | Identifikace druhu artiklu | Identifikace druhu artiklu
ad01id | C(6) | Adresát | Identifikace adresáta | Identifikace adresáta
ad11cisspo | C(2) | ad11cisspo | Číslo spojení adresáta. | Číslo spojení adresáta. Program generuje automaticky.
py03id | C(6) | Druh | Identifikace druhu události o nemovitosti | Identifikace druhu události o nemovitosti
py02zmstav | N(1,0) | Změna stavu | Změnit stav nemovitosti Ne/Vznik stavu/Ukončení stavu/Zrušení stavu | Změnit stav nemovitosti Ne/Vznik stavu/Ukončení stavu/Zrušení stavu
bw01uziv | C(6) | Ident. | Identifikace uživatele systému | Identifikace uživatele systému
sp10idzak | C(9) | Obch. sel. | Identifikátor obchodního selektoru | Identifikátor obchodního selektoru. *** Dříve CISZAK.
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.
sp20idzak | C(9) | Tech. sel. | Identifikátor technicko-věcného selektoru. | Identifikátor technicko-věcného selektoru.
py02datum | D | Datum | Datum události o nemovitosti | Datum události o nemovitosti
py02datum2 | D | Druhé datum | Druhé datum události o nemovitosti | Datum události o nemovitosti do
py02datum3 | D | Třetí datum | Třetí datum události o nemovitosti | Třetí datum události o nemovitosti
py02text | C(40) | Popis | Popis události o nemovitosti | Popis události o nemovitosti
py02hodnot | N(20,4) | Hodnota | Hodnota | Hodnota
sp00datzap | T | Datum a čas zápisu | Datum a čas zápisu záznamu události | Datum a čas zápisu záznamu události
py02koment | M | Pozn. | Poznámka | Poznámka

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Událost o nemovitosti - je o nemovitosti | PYUDAL sp60id sp61id | 1,1 : 0,M | PYNEMOV sp60id sp61id |
Událost o nemovitosti - je druhu | PYUDAL py03id | 1,1 : 0,M | PYDRUUDA py03id |
Událost o nemovitosti - byla založena v operaci | PYUDAL sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad | 1,1 : 0,M | SPPRCOD sp33cisd sp33cisdpm sp33cisdr sp07idtyp sp06idsubs sp33porad |
Událost o nemovitosti - má spojení na adresáta | PYUDAL ad01id ad11cisspo | 1,1 : 0,M | ADSPOJ ad01id ad11cisspo |
Událost o nemovitosti - založil uživatel | PYUDAL bw01uziv | 1,1 : 0,M | BWUZIVAT bw01uziv |
Událost o nemovitosti - má obchodní selektor | PYUDAL sp10idzak | 1,1 : 0,M | SPSEOB sp10idzak |
Událost o nemovitosti - má organizační selektor | PYUDAL sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Událost o nemovitosti - má technicko-věcný selektor | PYUDAL sp20idzak | 1,1 : 0,M | SPSETV sp20idzak |

Indexy

Název | Primární | Výraz | Popis
ix_PYUDAL_py02 | P | py02 | Jednoznačná časová identifikace
ix_PYUDAL_spprcod |  | sp33cisd, sp33cisdpm, sp33cisdr, sp07idtyp, sp06idsubs, sp33porad | Identifikace operace procesu
ix_PYUDAL_sptyp |  | sp07idtyp, sp06idsubs | Index podle druhu operace a subsystému
ix_PYUDAL_spartikl |  | sp60id, sp61id | Primární index artiklu sp60id+sp61id
ix_PYUDAL_adspoj5 |  | ad01id, ad11cisspo | ad01id+ad11cisspo
ix_PYUDAL_adadsatx |  |  |
ix_PYUDAL_spartiknx |  |  |
ix_PYUDAL_ad01id |  | ad01id | Identifikace adresáta
ix_PYUDAL_py03id |  | py03id | Identifikace druhu události o nemovitosti
ix_PYUDAL_sp07idtyp |  | sp07idtyp | Identifikátor typu dokladu.
ix_PYUDAL_bw01uziv |  | bw01uziv | Identifikace uživatele systému
ix_PYUDAL_sp10idzak |  | sp10idzak | Identifikátor obchodního selektoru.
ix_PYUDAL_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.
ix_PYUDAL_sp20idzak |  | sp20idzak | Identifikátor technicko-věcného selektoru.
ix_PYUDAL_py02datum |  | py02datum | Datum události o nemovitosti
ix_PYUDAL_py02text |  | py02text | Popis události o nemovitosti

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


PYUMIST Umístění nemovitosti

Popis

Umístění nemovitosti

Atributy

Atribut | Typ | Návěští | Message | Popis
py04id | C(6) | Umístění | Identifikace umístění nemovitosti | Identifikace umístění nemovitosti
py04nazumi | C(40) | Název umístění | Název umístění nemovitosti | Název umístění nemovitosti
py04koment | M | Poznámka | Poznámka | Poznámka
sp11idzak | C(9) | Org. sel. | Identifikátor organizačního selektoru. | Identifikátor organizačního selektoru.

Referenční integrita

Význam | Tabulka 1 | Kardinalita | Tabulka 2 | Popis
Umístění nemovitosti - má organizační selektor | PYUMIST sp11idzak | 1,1 : 0,M | SPSEOR sp11idzak |
Nemovitost - má umístění | PYNEMOV py04id | 1,1 : 0,M | PYUMIST py04id |
Druh události o nemovitosti - má definováno právo zadávání uživatelem podle umístění | PYDRUUDA py04id | 1,1 : 0,M | PYUMIST py04id |

Indexy

Název | Primární | Výraz | Popis
ix_PYUMIST_py04id | P | py04id | Identifikace umístění nemovitosti
ix_PYUMIST_py04nazumi |  | py04nazumi | Název umístění nemovitosti
ix_PYUMIST_sp11idzak |  | sp11idzak | Identifikátor organizačního selektoru.

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Výpočet DP

Popis

Tuto činnost uživatel aktivuje z činnosti "daňová přiznání" po stisku klávesy F5 nebo volbou příslušné činnosti z menu Volby.

Činnost "výpočet DP" slouží k výpočtu daňového přiznání. Zadávají se zde dva parametry. Rok a měsíc (je možno zadat i kvartál - ve tvaru Q1, Q2, ...), pro který chceme DP vypočítat. Takto zadané parametry zapíšeme (uložíme ikonou disketa) a vypočtené daňové přiznání si pak uživatel může prohlížet v činnosti "vypočtená daňová přiznání".

Formulář

Formulář činnosti - Události DPH
Rok | Rok
Měsíc | Měsíc


Vypočtená daňová přiznání

Popis

Tuto činnost uživatel aktivuje z činnosti "daňová přiznání" po stisku klávesy F6 nebo volbou příslušné činnosti z menu Volby.

Nejprve je třeba vyplnit příslušné položky výběru. Uživatel zadá rok a měsíc (měsíc ve tvaru 01, 02, ... 10, 12. V případě, že chce vypočítat daňové přiznání za čtvrtletí zadává čísla ve tvaru 3,6,9,12). Po uložení výběru má uživatel k dispozici dosud vypočtená daňová přiznání. Nevstupují se zde žádné položky, uživatel má možnost si vybrané daňové přiznání pouze prohlížet nebo tisknout (vybere si měsíc a rok a v případě výběru za čtvrtletí zadaného roku je nutno zadat do výběru Q1, Q2, Q3 nebo Q4).

Vypočtené daňové přiznání je možno zpracovat i elektronickou cestou (viz. pojem „elektronické přiznání DPH“ ve Slovníku pojmů), tzn. odeslat ho přímo na daňový portál České daňové správy.

Datový model

  • DPPRIRDH Hodnota řádku daňového přiznání v období
    • DPPRIRD Řádek daňového přiznání
      • DPPRI Daňové přiznání

    • Formulář

    Formulář činnosti - Události DPH
Mřížka [Přehled]
Daň.přiz. | Identifikace daňového přiznání
 | Název daňového přiznání
 | Běžná, opravné hlášení, neuplatněné DPH ....
Listovací rámeček
Stránka #1 Přehled DP
Stránka #2 Výběr
Rok | Rok
Měsíc / kvartál | Měsíc / kvartál - 01,02,....,12 / Q1,Q2,Q3,Q4
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Přehled] činnosti - Události DPH

    Mřížka [Přehled] činnosti - Události DPH
Rok | Rok
M/Q | Měsíc / kvartál - 01,02,....,12 / Q1,Q2,Q3,Q4
Par. | Číslo paragrafu řádku daňového přiznání
Popis řádku | Popis řádku daňového přiznání
Dlouhý popis | Popis řádku daňového přiznání - dlouhý
Označ. | Označení řádku na formuláři vypočtené daně
Základ daně | Základ daně
DPH - vstup | DPH - vstup
DPH - výstup | DPH - výstup

    Atributy tisku

    Základní údaje
Daň.přiz. | Identifikace daňového přiznání | DPPRIRDH_dp08id | C(6)
Název | Název daňového přiznání | DPPRI_dp08nazpri | C(40)
Událost | Běžná, opravné hlášení, neuplatněné DPH .... | Výpočet | C(18)
Řádek | Identifikace řádku daňového přiznání | DPPRIRDH_dp09id | C(6)
Popis řádku | Popis řádku daňového přiznání | DPPRIRD_dp09text | C(40)
Dlouhý popis | Popis řádku daňového přiznání - dlouhý | DPPRIRD_dp09text2 | M
Označení řádku | Označení řádku na formuláři vypočtené daně | DPPRIRD_dp09oznace | C(9)
Paragraf | Číslo paragrafu řádku daňového přiznání | DPPRIRD_dp09parag | N(2)
Pořadí | Pořadí řádku daňového přiznání v paragrafu | DPPRIRD_dp09porad | N(3)
XML - základ | Název XML atributu pro hodnotu základu daně | DPPRIRD_dp09xmlzak | M
XML - vstup | Název XML atributu pro hodnotu vstupu daně | DPPRIRD_dp09xmlvst | M
XML - výstup | Název XML atributu pro hodnotu výstupu daně | DPPRIRD_dp09xmlvys | M
Rok | Rok | DPPRIRDH_dp11rok | C(4)
Měsíc / kvartál | Měsíc / kvartál - 01,02,....,12 / Q1,Q2,Q3,Q4 | DPPRIRDH_dp11meskva | C(2)
Základ daně | Základ daně | DPPRIRDH_dp11zaklad | N(20,4)
DPH - vstup | DPH - vstup | DPPRIRDH_dp11vstup | N(20,4)
DPH - výstup | DPH - výstup | DPPRIRDH_dp11vystup | N(20,4)
Základ | Zahrnout na daňové přiznání / vypočítat hodnotu sloupce - základ daně | Výpočet | C(3)
Vstup | Zahrnout na daňové přiznání / vypočítat hodnotu sloupce - DPH vstup | Výpočet | C(3)
Výstup | Zahrnout na daňové přiznání / vypočítat hodnotu sloupce - DPH výstup | Výpočet | C(3)


SUMy - DPH

Popis

Uživatel má možnost prohlížet si celkové sumy, které se týkají událostí DPH. Tato sumarizace částek je možná u událostí všech komponent (plateb, změna stavu peněz apod.) v celém informačním systému po stisku klávesy Ctrl S nebo volbě příslušné činnosti z menu Volby..

Do tohoto přehledu není možno uživatelsky zasahovat (tzn. opravovat nebo rušit), slouží pouze pro informativní přehled. Přehled obsahuje základ DPH v ZM (zahr.měně), DPH v ZM, celkem v ZM, základ DPH v RM (refer.měně), DPH v RM, DPH v RM zaokr. a celkem v RM přehledně uspořádaný do třech sloupců - odpočet, nápočet a jejich rozdíl. V případě, že uživatel při práci s DPH nepoužíval cizí měnu, jsou částky v zahraniční a referenční měně shodné.

Formulář

Formulář činnosti - Prognózování odpisů
Základ DPH v ZM | Částka základu daně z přidané hodnoty v ZM - odpočet
DPH v ZM | Částka daně z přidané hodnoty v zahraniční měně - odpočet
Celkem (v ZM) | Celkem základ DPH + DPH - ZM
Základ DPH v RM | Částka základu daně z přidané hodnoty v referenční měně
DPH v RM | Částka daně z přidané hodnoty v referenční měně
DPH v RM (zaokr.) | Zaokrouhlená částka daně z přidané hodnoty v referenční měně
Celkem (v RM) | Celkem základ DPH + DPH (zaokrouhlené) - RM
Odpočet | Částka základu daně z přidané hodnoty v ZM - nápočet
Nápočet | Částka daně z přidané hodnoty v zahraniční měně - nápočet
Rozdíl | Celkem základ DPH + DPH - ZM - nápočet
 | Částka základu daně z přidané hodnoty v RM - nápočet
 | Částka daně z přidané hodnoty v referenční měně - nápočet
 | Zaokrouhlená částka daně z přidané hodnoty v RM - nápočet
 | Celkem základ DPH + DPH (zaokrouhlené) - RM - nápočet
 | Částka základu daně z přidané hodnoty v ZM -(odpočet- nápočet)
 | Částka daně z přidané hodnoty v zahraniční měně - rozdíl
 | Celkem základ DPH + DPH - ZM - rozdíl
 | Částka základu daně z přidané hodnoty v RM - rozdíl
 | Částka daně z přidané hodnoty v referenční měně - rozdíl
 | Zaokrouhlená částka daně z přidané hodnoty v RM - rozdíl
 | Celkem základ DPH + DPH (zaokrouhlené) - RM - rozdíl


Proměnné daňového přiznání

Popis

Tuto činnost uživatel aktivuje z činnosti "daňová přiznání" po stisku klávesy F7 nebo volbou příslušné činnosti z menu Volby.

Uživatel si nejprve zvolí ve výběru rok. Zobrazuje se mu přehled proměnných daného daňového přiznání. U každé proměnné, která se pak v daňovém přiznání zapisuje do kolonky výraz, je možno zadat hodnotu za zvolené období. Tato hodnota se pak vztahuje k řádku daňového přiznání, ve kterém je jako výraz uvedena částka právě této proměnné.

Pokud nejsou proměnné pro vypočítávané období definovány, dochází automaticky ke kopírování proměnných daňového přiznání a jejich nastavení na nulovou hodnotu. Tu je následně nutno uživatelsky opravit.

Datový model

  • DPPRIHOD Hodnoty doplňované na daňové přiznání

    • Formulář

    Formulář činnosti - Události DPH
Mřížka [Proměnné daňového přiznání]
Listovací rámeček
Stránka #1 Proměnné daňového přiznání
Daň.přiz. | Identifikace daňového přiznání
Rok | Rok
Měsíc / kvartál | Měsíc / kvartál - 01,02,...,11,12 / Q1,Q2,Q3,Q4
$REŽIM$ | Odpočet daně při změně režimu
$VYPOŘÁDÁNÍ-VSTUP$ | Vypořádání vstup
$VYPOŘÁDÁNÍ-VÝSTUP$ | Vypořádání výstup
$DALŠÍ1$ | Pomocná proměnná
$DALŠÍ2$ | Pomocná proměnná
$DALŠÍ3$ | Pomocná proměnná
Poznámka | Poznámka
Stránka #2 Výběr
Rok | Rok
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Proměnné daňového přiznání] činnosti - Události DPH

    Mřížka [Proměnné daňového přiznání] činnosti - Události DPH
Daň.přiz. | Identifikace daňového přiznání
Rok | Rok
Měsíc / kvartál | Měsíc / kvartál - 01,02,...,11,12 / Q1,Q2,Q3,Q4
$REŽIM$ | Odpočet daně při změně režimu
$VYPOŘÁDÁNÍ-VSTUP$ | Vypořádání vstup
$VYPOŘÁDÁNÍ-VÝSTUP$ | Vypořádání výstup
$DALŠÍ1$ | Pomocná proměnná
$DALŠÍ2$ | Pomocná proměnná
$DALŠÍ3$ | Pomocná proměnná


Rozdělení dodacích listů

Popis

Činnost rozdělení dodacích listů úzce souvisí s procesním zpracováním událostí expedice. Jejich naplňování je možno provést i načtením vytvořených dodacích listů. Uživatel tedy přijímá objednávky od svých zákazníků, tím vytváří události komponenty obchod. Následně aktivuje spuštění expedičního příkazu a zadá datum, trasu, vozidlo a řidiče. V menu Volby (nebo po stisku klávesy F7) spustí činnost „rozdělení dodacích listů“. Nejprve se systém dotazuje na datum dodání dodacích listů, zadává se datum v intervalu datum od a datum do. Poté se spustí vlastní činnost rozdělení dodacích listů. V horní části formuláře je viditelná hlavička vytvořeného expedičního příkazu. Spodní část je rozdělena na dvě části:

¨ nezařazené DL – tj. DL, které jsou v systému vytvořeny, ale dosud nebyly zařazeny na žádný expediční příkaz

¨ DL expedičního příkazu – tj. DL, které jsou již aktivně přesunuty na daný expediční příkaz

Při přesunu DL na expediční příkaz je uživatel pomocí tlačítka „šipka“ přesune z části nezařazené DL do části DL expedičního příkazu. Po stisku klávesy ESC se systém dotazuje: „Zapsat data? Ano/Ne“. Po potvrzení volby Ano je daný DL (nebo více DL) načteno do jednoho expedičního příkazu podle uvedené trasy. Každá trasa má v systému nadefinovány své adresáty, tzn. adresáty, kteří se vyskytují na dané trase. Uživatel pak může mít např. několik dodacích listů, ale při aktivaci činnosti rozdělení dodacích listů se načtou pouze ty dodací listy, které jsou vystaveny na ty adresáty, kteří jsou zároveň adresáti dané trasy, tzn. při vytváření expedičního příkazu je důležitý atribut trasa (podle něj se vyhodnocují adresáti) a datum dodání (je datem expedičního příkazu).

Údaje z dodacích listů jsou pak k dispozici na expedičním příkazu v událostech expedice. Na záložce „dodací listy“ je přehled hlaviček dodacích listů daného expedičního příkazu a na záložce „položky DL“ jsou k dispozici všechny položky těchto DL.

Formulář

Formulář činnosti - Datum expedičních příkazů
Expediční příkazy | Seznam expedičních příkazů
Tlačítko | Nový expediční příkaz
Tlačítko | Ostranit expediční příkaz
Tlačítko | Automatické vytvoření expedičních příkazů
Tlačítko | Doplnění identifikací skladů a skladových buněk
Tlačítko | Ukončení expedičního příkazu
DL expedičního příkazu | Dodací listy na expedičním příkazu
Tlačítko | Odstranit dodací list z expedičního příkazu
Tlačítko | Vložit dodací list na expediční příkaz
Nezařazené DL | Nezařazené dodací listy

Viz.také

Datum expedičních příkazů | Vlastnosti expedičního příkazu


Vlastnosti expedičního příkazu

Popis

Činnost vlastnosti expedičního příkazu úzce souvisí s procesním zpracováním událostí expedice (pomocí činnosti rozdělení dodacích listů). Uživatel přijímá objednávky od svých zákazníků, tím vytváří události komponenty obchod. Následně aktivuje spuštění expedičního příkazu a zadá datum, trasu, vozidlo a řidiče. V menu Volby (nebo po stisku klávesy F7) spustí činnost „rozdělení dodacích listů“. Nejprve se systém dotazuje na datum dodání dodacích listů, zadává se datum v intervalu datum od a datum do. Poté se spustí vlastní činnost rozdělení dodacích listů. V horní části formuláře je viditelná hlavička vytvořeného expedičního příkazu. Spodní část je rozdělena na dvě části:

¨ nezařazené DL – tj. DL, které jsou v systému vytvořeny, ale dosud nebyly zařazeny na žádný expediční příkaz

¨ DL expedičního příkazu – tj. DL, které jsou již aktivně přesunuty na daný expediční příkaz

Při přesunu DL na expediční příkaz je uživatel pomocí tlačítka „šipka“ přesune z části nezařazené DL do části DL expedičního příkazu. Po stisku klávesy ESC se systém dotazuje: „Zapsat data? Ano/Ne“. Po potvrzení volby Ano je daný DL (nebo více DL) načteno do jednoho expedičního příkazu podle uvedené trasy. Každá trasa má v systému nadefinovány své adresáty, tzn. adresáty, kteří se vyskytují na dané trase. Uživatel pak může mít např. několik dodacích listů, ale při aktivaci činnosti rozdělení dodacích listů se načtou pouze ty dodací listy, které jsou vystaveny na ty adresáty, kteří jsou zároveň adresáti dané trasy, tzn. při vytváření expedičního příkazu je důležitý atribut trasa (podle něj se vyhodnocují adresáti) a datum dodání (je datem expedičního příkazu).

Další možnosti této činnosti jsou:

¨ Nový příkaz – ruční vložení expedičního příkazu

¨ Odstranit příkaz – zrušení expedičního příkazu

¨ Výpočet – automatické vytvoření expedičních příkazů

¨ Přidělení – doplnění identifikací skladů a skladových buněk

Formulář

Formulář činnosti - Konv. listu do nových výkazů
Trasa | Identifikace trasy
Odjezd | Datum a čas odjezdu
 | Datum a čas přijezdu
Popis | Popis události
Vozidlo | Vozidlo expedice
Řidič | Identifikace řidiče
Hmotnost (kg) | Hmotnost v kilogramech
Vzdálenost (km) | Ujetý počet kilometrů
Plocha (m2) | Úložná plocha v metrech čtverečných
Objem (m3) | Úložný objem v metrech kubických
Počet DL | Počet dodacích listů
Počet odběratelů | Počet odběratelů
Poznámka | Poznámka k události
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.


Datum expedičních příkazů

Popis

Při aktivaci činnosti „rozdělení dodacích listů“ se systém nejprve dotazuje na datum dodání dodacích listů v období od – do. Datum dodání DL se zároveň bere jako datum expedice. Zadáním tohoto intervalu uživatel definuje množinu DL, které mohou být součástí daného expedičního příkazu.

Formulář

Formulář činnosti - Konv. listu do nových výkazů
Odjezd Datum a čas odjezdu


Export pro vážní server

Popis

Tato činnost se aktivuje po stisku F6 nebo spuštěním činnosti „export pro vážní server“ z menu Volby v činnosti Události expedice. Zadává se identifikace souboru vážního serveru a počet záznamů.

Formulář

Formulář činnosti - Datum expedičních příkazů
Soubor vážního serveru | Soubor vážního serveru
Počet přidaných prázdných záznamů | Počet přidaných prázdných záznamů


Generování publikace

Popis

Nezdokumentováno.

Datový model

  • IEUZVAZ Vazba pracovních míst (alias IEUZVAZ4)
    • IEUZEL Datové úložiště

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Vlastnosti vazby

Popis

Nezdokumentováno.

Formulář

Formulář činnosti - Přístupová práva
 | Seznam možných datových entit
 | Seznam datových entit
Tlačítko | Přidání označených
Tlačítko | Přidání všech
Tlačítko | Zrušení volby označených
Tlačítko | Zrušení volby všech
Tlačítko | Ukončení výběru


Export převodní tabulky

Popis

Nezdokumentováno.

Datový model

  • IEKONV Konverzní tabulka

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Import převodní tabulky

Popis

Nezdokumentováno.

Datový model

  • IEKONV Konverzní tabulka

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Vlastnosti vazby - činnosti

Popis

Nezdokumentováno.

Formulář

Formulář činnosti - Přístupová práva
 | Seznam možných datových entit
 | Seznam datových entit
Tlačítko | Přidání označených
Tlačítko | Přidání všech
Tlačítko | Zrušení volby označených
Tlačítko | Zrušení volby všech
Tlačítko | Ukončení výběru


Doplnit nadřízené procesy

Popis

Tuto činnost má uživatel dostupnou po stisku klávesy F5 nebo pod menu Volby v činnosti „Seznam replikovaných procesů“. Po její aktivaci program provede doplnění nadřízených procesů na základě druhu operací.


Doplnit nadřízené procesy 2

Popis

Tuto činnost má uživatel dostupnou po stisku klávesy F6 nebo pod menu Volby v činnosti „Seznam replikovaných procesů“. Po její aktivaci program provede doplnění nadřízených procesů na základě fyzických operací.


Spustit informační panel

Popis

Tato činnost aktivuje daný informační panel. Aktivuje se spuštěním činnosti z menu Volby nebo stiskem klávesy F9.


Zobrazovat na stránce informačního panelu

Popis

Tento formulář uživatel aktivuje po stisku pravého tlačítka „Skryté“ na informačním panelu. Slouží pro možnost uživatelského nastavení, které poduzly informačního panelu mají pro daného uživatele být skryté. Implicitně pak zůstávají skryté, po stisku tlačítka „Skryté“ (levým tlačítkem myši) se potom zobrazí i tyto skryté.

Datový model

  • IPUZELP Poduzel uzlu informačního panelu
    • IPUZEL Uzel informačního panelu (alias IPUZEL2)
      • IPDRUH Druh uzlu informačního panelu
        • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Vybrat soubor dokumentu
Mřížka [Poduzly uzlu]
Uzel | Identifikátor poduzlu informačního panelu
Alias | Alias poduzlu informačního panelu
Název uzlu | Název uzlu informačního panelu
Zobrazení poduzlu | Zobrazení poduzlu pro uživatele Vždy,Skryté,Nikdy

    Mřížka [Poduzly uzlu] činnosti - Vybrat soubor dokumentu

    Mřížka [Poduzly uzlu] činnosti - Vybrat soubor dokumentu
Pořadí | Pořadí
Uzel | Identifikátor poduzlu informačního panelu
Alias | Alias poduzlu informačního panelu
Název uzlu | Název uzlu informačního panelu


Buňky

Popis

Každý sklad může být rozdělen na úložný prostor (buňky). Každá buňka přísluší určitému skladu. Uvádí se tyto atributy:

¨ buňka - identifikace skladové buňky a název skladové buňky. Identifikátor skladové buňky může být zadán strukturovaně (řada, regál, patro).

¨ čárový kód - kód automatické identifikace (např. pro automatické zakladače).

¨ umístění buňky osa X, Y, Z - možnost ještě více rozčlenit umístění v buňce

Datový model

  • MTBUN Skladová buňka
    • MTSKL Sklad

    • Formulář

    Formulář činnosti - Události změny stavu peněz
Mřížka [Buňky]
Sklad | Identifikace umístění skladové evidence
Buňka | Identifikace skladové buňky
Název | Název skladové buňky
Čarový kód | Kód automatické identifikace
Umístění buňky osa X | Umístění buňky osa X
Umístění buňky osa Y | Umístění buňky osa Y
Umístění buňky osa Z | Umístění buňky osa Z
Volný text | Volný text

    Mřížka [Buňky] činnosti - Události změny stavu peněz

    Mřížka [Buňky] činnosti - Události změny stavu peněz
Sklad | Identifikace umístění skladové evidence
Buňka | Identifikace skladové buňky
Název | Název skladové buňky
Čarový kód | Kód automatické identifikace


Celkem - sklad

Popis

Tuto činnost uživatel spustí aktivací příslušné činnosti z menu Volby a nebo stiskem CTRL S. Uživatel má k dispozici sumární přehled uspořádaný do přehledné tabulky. Vyfiltrované události (záložka Výběr) jsou setříděny ve třech sloupcích – Příjem / Výdej / Rozdíl.

Formulář

Formulář činnosti - Události změny stavu peněz
Množství | Množství artiklu - příjem
Výdej | Množství artiklu - výdej
Množství v RMJ | Množství artiklu v referenční měrné jednotce - příjem
Příjem | Množství artiklu v referenční měrné jednotce - výdej
Cena | Cena celkem - příjem
 | Cena celkem - výdej
Rozdíl | Množství artiklu - rozdíl
 | Množství artiklu v referenční měrné jednotce - rozdíl
Celkem | Cena celkem - rozdíl


Progr. sablona - nenulovy skla

Popis

Na zadaném skladu šablona vybere nenulové množství (vyhledává v aktuálních hodnotách skladu).

Formulář

Formulář činnosti - Sklady
Sklad Identifikace umístění skladové evidence

Vyvolávané činnosti

K. | Činnost | Popis
F2 | Sklady | Seznam skladů

Viz.také

Sklady


Konečné ocenění

Popis

Konečné ocenění uživatel v událostech skladové evidence využije v případě, že zná konečnou cenu přijímaného nebo vydávaného artiklu a i množství je přesně dáno.

Tato činnost má smysl použít při potřebě převést větší množství událostí s oceněním předběžným jedním krokem na ocenění konečné. Uživatel si vybere události s předběžným oceněním, které chce změnit a pod menu Volby nebo klávesou F5 aktivuje činnost "konečné ocenění". Systém se potom dotazuje: "Opravdu si přejete nastavit ocenění artiklů jako konečné?". Ano - Ne.


Převod mezi sklady

Popis

Převod mezi sklady je programová šablona, která na základě nadefinovaných parametrů umožňuje uživateli převést vybraný artikl (nebo všechny artikly) mezi určenými sklady.

Datový model

  • MTAHTEMP Temp soubor pro hromadný vstup množství
    • MTSKL Sklad
    • MTSKL Sklad (alias MTSKL2)
    • MTARTIKL Skladovaný artikl
      • SPARTIKL Artikl
      • SPSETV Technicko-věcný selektor

    • Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
- | Úplný výdej | Úplný výdej ze skladu
F2 | Adresář | Přehled adresátů
F2 | Artikly skladu | Seznam skladovaných artiklů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Množství artiklu na skladech | Množství artiklu na skladech a buňkách
F2 | Sklady | Seznam skladů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

    Formulář činnosti - Množství artiklu na skladech
Mřížka [Přesun mezi sklady]
Listovací rámeček
Stránka #1 Přehled stavů
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
 | Kód automatické identifikace
Sklad | Identifikace umístění skladové evidence
Buňka | Identifikace skladové buňky
 | Název skladu
Množství | Množství na zdrojovém skladě
Cíl | Identifikace cílového skladu
 | Název skladu
Cíl | Množství na cílovém skladě
TVS | Identifikátor technicko-věcného selektoru.
 | Název technicko-věcného selektoru.
 | Identifikace skladové buňky
Přesun | Předávané množství
Stránka #2 Aktuální stavy
Mřížka [Aktuální stavy]
Stránka #3 Výběr
Předplňovaný adresát | Identifikace adresáta
 | Název adresáta
Zdrojový sklad | Identifikace zdrojového skladu
Cílový sklad | Identifikace cílového skladu
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Tech. sel. | Identifikátor technicko-věcného selektoru.
 | Název artiklu
Označování | Označování převáděných artiklů
Desetiny | Počet desetin v zobrazeném množství
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Přesun mezi sklady] činnosti - Množství artiklu na skladech

    Mřížka [Přesun mezi sklady] činnosti - Množství artiklu na skladech
Označování | Označení záznamu
Buňka | Identifikace skladové buňky
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Zdroj | Množství na zdrojovém skladě
Cíl | Množství na cílovém skladě
Buňka | Identifikace skladové buňky
Přesun | Předávané množství
Po přesunu | Hodnota
Popis | Popis

    Mřížka [Aktuální stavy] činnosti - Množství artiklu na skladech

    Mřížka [Aktuální stavy] činnosti - Množství artiklu na skladech
Sklad | Identifikace umístění skladové evidence
Buňka | Identifikace skladové buňky
Název skladu | Název skladu
Množství | Hodnota

    Atributy tisku

    Základní údaje
Druh artiklu | Identifikace druhu artiklu | MTAHTEMP_sp61id | C(3)
Artikl | Identifikace artiklu | MTAHTEMP_sp60id | C(13)
Název artiklu | Název artiklu | MTARTIKL_sp60artikl | C(60)
Tech. sel. | Identifikátor technicko-věcného selektoru. | MTARTIKL_sp20idzak | C(9)
Název technicko-věcného selektoru | Název technicko-věcného selektoru. | SPSETV_sp20text | C(60)
Zdroj | Identifikace umístění skladové evidence | MTAHTEMP_mt04id | C(6)
Buňka | Identifikace skladové buňky | MTAHTEMP_mt05id | C(9)
Název skladu | Název skladu | MTSKL_mt04text | C(40)
Množství | Množství na zdrojovém skladě | MTAHTEMP_mt16hodno1 | N(20,4)
Cíl | Identifikace cílového skladu | MTAHTEMP_mt04id2 | C(6)
Buňka | Identifikace skladové buňky | MTAHTEMP_mt05id2 | C(9)
Název skladu | Název skladu | MTSKL2_mt04text | C(40)
Množství | Množství na cílovém skladě | MTAHTEMP_mt16hodno2 | N(20,4)
Přesun | Předávané množství | MTAHTEMP_mt02hodnot | N(20,4)

    Viz.také

    OZNAČOVÁNÍ | Úplný výdej | Adresář | Artikly skladu | Druhy artiklů | Množství artiklu na skladech | Sklady | Technicko-věcný selektor


Úplný výdej

Popis

Tato činnost (dostupná v menu Volby) při použití programové šablony převod mezi sklady umožňuje převést všechny vybrané artikly mezi zvolenými sklady.


Naplnění artiklů s VČ

Popis

Na základě údajů např. v událostech doplní artikly s výrobním číslem do číselníku artiklů.


Vybrat jinou buňku

Popis

Tuto činnost uživatel aktivuje z menu Volby nebo stiskem funkční klávesy F5. Zobrazí se mu činnost „buňky“, kde si může zvolit jinou skladovou buňku, než měl původně vybráno.


Vybrat jiný sklad

Popis

Tuto činnost uživatel aktivuje z menu Volby nebo stiskem funkční klávesy F6. Zobrazí se mu činnost „sklady“, kde si může zvolit jiný sklad, než měl původně vybráno.


Celkem - AH

Popis

Po stisku klávesy Ctrl S má uživatel možnost zjistit celkovou sumu vyfiltrovaných aktuálních hodnot za zvolené období.


Generuj FPD po měsících

Popis

Tato činnost vygeneruje fond pracovní doby v měsících pro jeden (právě aktuální) kalendář (právě aktuálním kalendářem se rozumí ten, na kterém v danou chvíli stojí kurzor nebo je označen).


Úkolová-tarifní

Popis

Vztahuje se k právě danému příjmu a aktivuje se po stisku příslušného tlačítka. Toto tlačítko se rozsvítí pouze po určitém výběru položky "původ Kč/j" (původ spojený s tarifem). Po aktivaci této činnosti se předplní identifikace příjmu a uživatel dále zadává (vlastně spíš vybírá z číselníku) stupnici, třídu a Kč za jednotku.

Datový model

  • MZUKOLTA Úkolová mzda tarifní
    • MZTARSTU Stupnice zahrnuje

    • Formulář

    Formulář činnosti - Výběr tar. třídy (úkolová-tari
Mřížka [ukol-tarif]
Ident. příjmu | Jednoznačná identifikace mzdové položky
Stupnice | Identifikace tarifní stupnice
 | Popis tarifní stupnice
Třída | Tarifní třída (1-99)
Kč/ j | Kč/ j

    Mřížka [ukol-tarif] činnosti - Výběr tar. třídy (úkolová-tari

    Mřížka [ukol-tarif] činnosti - Výběr tar. třídy (úkolová-tari
Stupnice | Identifikace tarifní stupnice
Třída | Tarifní třída (1-99)
Kč/ j | Kč/ j

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Tarifní stupnice | Mzdové tarifní stupnice a jim odpovídající tarifní třídy.
F2 | Výběr tar. třídy (úkolová-tari | Umožní zvolit nějakou existující tar. třídu

    Viz.také

    Tarifní stupnice | Výběr tar. třídy (úkolová-tari


Charakter vlastnosti

Popis

Jedná se o činnost, která v podstatě funguje jako skrytý číselník a je podkladem pro způsob účtování. V podstatě si zde může uživatel zadat cokoliv, podle čeho chce nějak rozlišit způsob účtování, např. společník, zaměstnanec nebo THP, dělníci apod. Charakter vlasnosti není v podstatě tedy ničím jiným než určením způsobu účtování druhu účetní události.

Datový model

  • MZCHARAK Charakter vlastnosti

    • Formulář

    Formulář činnosti - Nový záznam podle schématu
Mřížka [Charakter vlastnosti]
Vlastnost | Charakter vlastnosti
Komentář | Komentář

    Mřížka [Charakter vlastnosti] činnosti - Nový záznam podle schématu

    Mřížka [Charakter vlastnosti] činnosti - Nový záznam podle schématu
    Vlastnost Charakter vlastnosti


Výběr tar. třídy

Popis

Uživateli se nabízí číselník tarifních stupnic a zároveň číselník tarifních tříd platných pro danou stupnici.

Datový model

  • MZTARTRI Tarifní třída

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Cenové skupiny | Přehled cenových skupin obchodovatelného artiklu

    Formulář

    Formulář činnosti - Cenové skupiny
Mřížka [Třídy]
Stupnice | Identifikace tarifní stupnice
Třída | Tarifní třída (1-99)
Sazba | Firemní mzda hodinová
Min. měsíční mzda | Minimální mzda měsíční
Skupina | Identifikace cenové skupiny
Volné číslo | Volné číslo 1
Text | Volný text
Komentář | Komentář

    Mřížka [Třídy] činnosti - Cenové skupiny

    Mřížka [Třídy] činnosti - Cenové skupiny
Stupnice | Identifikace tarifní stupnice
Třída | Tarifní třída (1-99)
Sazba | Firemní mzda hodinová
Min. měsíční mzda | Minimální mzda měsíční

    Atributy tisku

    Základní údaje
Stupnice | Identifikace tarifní stupnice | MZTARTRI_mz23id | C(6)
Třída | Tarifní třída (1-99) | MZTARTRI_mz24trida | C(2)
Sazba | Firemní mzda hodinová | MZTARTRI_mz24hodmzd | N(8,2)
Min. měsíční mzda | Minimální mzda měsíční | MZTARTRI_mz24minmzd | N(5)
Komentář | Komentář | MZTARTRI_mz24komen | M

    Viz.také

    Cenové skupiny


Pravidelné příjmy

Popis

Jsou k dispozici na kartě pracovníka na záložce pracovní poměr po stisku klávesy F5 nebo volbou příslušné činnosti z menu Volby. Na úvod se uživateli zobrazují údaje z karty pracovníka, tzn. osobní číslo, jméno a identifikace pracovního poměru. Další údaje se již vstupují:

¨ jednoznačná identifikace mzdové položky (jak jsme se již zmínili výše, tyto příjmy a náhrady by měl definovat implementátor nebo zkušený mzdový pracovník)

¨ popis – přetáhne se současně s identifikací mzdové položky

¨ hodiny – způsob dopočtu hodin na výplatním lístku. Na výběr z překryvného seznamu jsou tyto možnosti:

- nevyplňovat – po přenosu pravidelných příjmů do výplatního lístku se atribut hodiny nevyplní. Na výplatní lístek se pak přenese přesně tolik Kč, kolik je zde vyplněno. Atribut hodiny na výplatním lístku bude 0.

- dopočíst do FPD dle hodin – hodiny na výplatním lístku se pak počítají jako hodiny FPD ve zpracovávaném měsíci mínus součet hodin mzdových položek s doplňujícím údajem („hodiny jsou součástí FPD – Ano“) mínus součet hodin nepřítomností mínus součet hodin neplaceného volna mínus součet hodin ve kterých pracovní poměr ve zpracovávaném měsíci netrval. Dny na výplatním lístku jsou pak výsledkem poměru hodin na výplatním lístku a pracovního úvazku (úvazek je součástí kalendáře pracovníka a tento je součástí pracovního poměru). Odečítané mzdové položky byly zadány do výplatního lístku ručně nebo pomocí úkolových lístků.

- součet odpracovaných dle hodin – hodiny se vypočte jako suma těch mzdových položek, které mají v doplňujících údajích zadáno „hodiny započítávat pro nárok na pohyblivou složku měsíční – Ano“. Použije se např. při pravidelné měsíční pohyblivé složce, jejíž výše je závislá na počtu odpracovaných hodin při výkonu určitých prací. Dny na výplatním lístku jsou pak výsledkem poměru hodin na výplatním lístku a pracovního úvazku (úvazek je součástí kalendáře pracovníka a tento je součástí pracovního poměru).

- dopočíst do FPD odděleně ve dnech a v hodinách – hodiny se zjistí s ohledem na FPD (stejný postup výpočtu jako u možnosti „dopočíst FPD dle hodin“). Dny se pak samostatně zjistí s ohledem na FPD (stejný postup výpočtu jako u možnosti „dopočíst FPD dle dnů“). Dny a hodiny pak tedy spolu vůbec nemusí korespondovat. Používá se hlavně v případech, kdy na výplatní lístek vstupují položky jako paragraf (nebo dovolená půl dne), které mají pak specifický způsob zápisu, např. 0dnů, 2,5 hodiny apod.

- součet odpracovaných odděleně ve dnech a v hodinách – stejný výpočet jako při možnosti „součet odpracovaných dle hodin“, ale hodiny a dny se počítají samostatně, nikoliv podle úvazku.

- dopočíst do FPD dle dnů – stejný výpočet jako při možnosti „dopočíst do FPD dle hodin“, ale výpočet se zajímá pouze o dny a hodiny se pak spočítají jako dny * úvazek.

- suma svátků – používá se pouze u organizací s denním kalendářem. Z kalendáře se do hodin a dnů na výplatním lístku vyplní součet údajů, které se vážou k typu dne svátek. Úzce souvisí s dalším nastavením položky „náhrada mzdy“ v činnosti Příjmy a náhrady. V každém případě je nutné, aby pracovník, který bude mít nastavenu tuto možnost výpočtu hodin měl v kalendáři označen jako svátky pouze dny, které jsou jeho pracovními (tzn. např. pracovník v turnusech bude mít prac. týden út – so a např. na pátek připadá svátek, pak je nutné, aby út až so byly označeny jako pracovní dni). Používá se pouze u denních kalendářů, jestliže bude mít pracovník měsíční kalendář, pak se zapíše do protokolu chybové hlášení PRAVI6 a dny a hodiny položky zůstanou nulové.

¨ Kč/j – množství Kč za jednotku

¨ indiv. koef. – umožňuje nadefinovat konkrétní koeficient pro konkrétního pracovníka u dané položky mzdy (např. chci pracovníkovi dlouhodobě nastavit prémie 50%. Potom je zde v tomto koeficientu nastaveno 0,5 a platí to právě na konkrétní položku mzdy a konkrétního pracovníka). V případě, že je uveden tento individuální koeficient, má při výpočtu mzdových položek přednost před atributem „koeficient“ v dolní části formuláře.

¨ od data – do data – datum zahájení a datum ukončení platnosti položky

¨ koeficient, výpočet Kč a dopl. údaj jsou informace, které se sem jako informace automaticky natáhnou při zadání identifikace mzdové položky

Datový model

  • MZMZDPPV Pravidelná mzdová položka
    • MZMZDPOL Mzdová položka

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Příjmy a náhrady |

    Formulář

    Formulář činnosti - Doplňující údaje k příjmům
Mřížka [Pravidelné měs. příjmy]
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Prac. poměr | Číslo pracovního poměru
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Hodiny | Způsob dopočtu hodin na výplatním lístku.
Kč / j | Kč / j
Indiv. koef. | Individuální koeficient, jímž se násobí Kč / j (je-li 0 použije se koeficient mzdové položky)
Platnost od | Datum zahájení platnosti položky
do | Datum ukončení platnosti položky
Koeficient | Koeficient, jímž se násobí Kč / j
Výpočet Kč | Způsob výpočtu celkové částky Kč
Dopl.údaj | Popis doplňující položky mezd

    Mřížka [Pravidelné měs. příjmy] činnosti - Doplňující údaje k příjmům

    Mřížka [Pravidelné měs. příjmy] činnosti - Doplňující údaje k příjmům
Identifikace | Jednoznačná identifikace mzdové položky
Příjem | Popis mzdové položky
Pracovník | Jednoznačná identifikace pracovníka
Číslo p.p. | Číslo pracovního poměru
Hodiny | Způsob dopočtu hodin na výplatním lístku.
Kč / j | Kč / j

    Atributy tisku

    Základní údaje
Pracovník - OSC | Jednoznačná identifikace pracovníka | MZMZDPPV_mz01id | C(6)
Číslo p.p. | Číslo pracovního poměru | MZMZDPPV_mz32cispp | C(2)
Mzdová položka | Jednoznačná identifikace mzdové položky | MZMZDPPV_mz28id | C(6)
Popis | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Kč / j | Kč / j | MZMZDPPV_mz35kc_j | N(9,2)
Hodiny | Způsob dopočtu hodin na výplatním lístku. | Výpočet | C(42)

    Viz.také

    Příjmy a náhrady | Doplňující údaje k příjmům


Přes měsíc

Popis

Tato činnost se použije pokud uživatel potřebuje spočítat dávku, která přesahovala přes měsíc. Po spuštění této činnosti se zadává datum zahájení vyplácení nemocenské dávky a datum ukončení vyplácení nemocenské dávky. Na základě těchto datumů se potom spočte vlastní hodnota dávky a podle jednotlivých měsíců se zapíše do řádek.

Datový model

  • MZNEMOC Nemoc

    • Formulář

    Formulář činnosti - Karta pracovníka
Datum začátku splácení | Zadání data počátku splácení
Datum konce splácení | Zadání data konce splácení
Dávky proplatit ? | Dávky proplatit v nejbližším výplatním termínu? - Ano,Ne


Generuj veškerý FPD po měs.

Popis

Tato činnost přegeneruje fond pracovní doby (FPD) v měsících pro všechny dosud založené kalendáře.


Generace událostí mezd-UC i PL

Popis

Tato činnost slouží k přenesení vypočtených mzdových údajů do událostí mezd, aby je pak po převodu do systému bylo možno zaúčtovat, prohlížet apod.

Datový model

  • MZMZDY Mzda
    • MZMZDPOL Mzdová položka
      • MZDRUHUD Druh události

    • Formulář

    Formulář činnosti - Charakter vlastnosti
    Datum zpracovávaných mezd Datum


Další informace

Popis

Jsou k dispozici na kartě pracovníka na záložce pracovní poměr po stisku klávesy F6 nebo volbou příslušné činnosti z menu Volby. Jsou zde atributy, které přímo vážou na pracovní poměr. Uživateli se nabízí tyto informace:

¨ o pracovním poměru – tj. datum zahájení, účast prac. poměru na nemocenském pojištění, důvod ukončení prac. poměru

¨ vztah k pojistnému na sociální zabezpečení – žádný/vše/důchod. Možnost vybrat si z překryvného seznamu je z toho důvodu, že u některých skupin pracovníků se odvádí pouze důchodové pojištění. Odvod nemocenského pojištění a odvod na politiku nezaměstnanosti se neprovádí. Implicitně je však v tomto atributu nastavena možnost „Vše“. Pokud je na konkrétní mzdové položce uvedeno, že se z ní počítá sociální pojištění, tak pak na její další chování mají vliv možnosti nastavené zde:

- žádný – odvod sociálního pojištění bude nulový

- vše – odvod sociálního pojištění se provede podle všech tří složek (důchodové pojištění, nemocenské pojištění a příspěvek na státní politiku zaměstnanosti)

- důchod – odvod sociálního pojištění se provede pouze podle důchodového pojištění

¨ o průměrech – hodinový, denní, měsíční – tyto údaje se po provedených uzávěrkách automaticky přepočítávají. Používají se např. při výpočtu peněz za denní dovolenou a nově např. pro nemocenské dávky platné od roku 2007.

¨ o dovolené – roční nárok, zůstatky, nová dovolená. Tyto údaje se po provedených uzávěrkách automaticky přepočítávají. Dovolená byla v současné době přepracována, nicméně „staré“ nastavení lze dále používat (pro implementaci nových dovolených je vytvořen samostatný uživatelský návod) – podrobnější popis položek je uveden níže

¨ volné datum a tři volná čísla – možno libovolně využít dle potřeb uživatele

Vzhledem ke změně v evidenci nemocenských dávek pro r. 2009 je atribut „denní vyměřovací základ 2008“ umístněn až v dolní části formuláře a slouží pouze pro výpočet nemocenských dávek, které pokračují z roku 2008, tzn. počítají se ještě podle pravidel roku 2008. Dávky totiž zaměstnavatel v r. 2009 neproplácí.

Údaje týkající se dovolené:

¨ roční nárok na dovolenou – celkový nárok na dovolenou v daném roce

¨ zůstatek dovolené z minulého roku – využívá se ve mzdových listech

¨ převod dovolené do příštího roku – využívá se ve mzdových listech. Tento atribut nastaví vždy uzávěrka za 12/rok (během roku se jeho hodnota nemění)

¨ zůstatek staré dovolené – průběžný zůstatek dovolené z té části dovolené, která byla převedena z minulého roku

¨ zůstatek nové dovolené – průběžný zůstatek dovolené z té části dovolené, která vychází z nároku k 1.1. daného roku

Atributy „zůstatek staré dovolené“ a „zůstatek nové dovolené“ dohromady označují aktuální stav dovolené k datu poslední uzávěrky, tzn. pokud např. zpracováváme mzdy za 04/2008, je v těchto atributech hodnota stavu k 31.3.2008.

S výše uvedenými atributy dále pracuje uzávěrka mezd. Před vlastním provedením uzávěrky mezd (za měsíc prosinec) je nutno mít správně uvedeny roční nároky na dovolenou na následující rok.

Datový model

  • MZPRACPO Pracovní poměr

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Charakter vlastnosti | Charakter vlastnosti - spolěčníci, zaměstnanci ,...

    Formulář

    Formulář činnosti - Charakter vlastnosti
Pracovník | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Prac. poměr | Číslo pracovního poměru
 | Vznik prac. poměru
 | Skončení prac. poměru
Vztah k pojistnému na soc. zabezp. | Vztah k pojistnému na sociální zabezpečení
Datum doručení výpovědi | Datum doručení výpovědi nebo datum uzavření dohody rozvázání pracovního poměru
Datum odvolání výpovědi | Datum odvolání výpovědi
Důvod ukončení p.p. | Důvod ukončení pracovního poměru
Hodinový průměr | Hodinový průměr
Denní průměr | Denní průměr
Měsíční průměr | Měsíční průměr
Roční nárok na dovolenou | Roční nárok na dovolenou.
Zůstatek dovolené z minulého roku | Zůstatek dovolené z minulého roku, stav k 1.1. - neodečítá se z něj, ke mzdovému listu
Převod dovolené do příštího roku | Převod dovolené do příštího roku - stav k 1.1., neodečítá se z něj, ke mzdovému listu
Zůstatek staré dovolené | Zůstatek staré dovolené
Zůstatek nové dovolené | Zůstatek nové dovolené
Volné datum I | Volně použitelné datum
Volné číslo I | Volně použitelné číslo
Volné číslo II | Volně použitelné číslo
Volné číslo III | Volně použitelné číslo
Denní vyměřovací základ 2008 (poslední hodnota platná pro 12/2008) | Denní vyměřovací základ nemocenského pojištění neredukovaný.
Účast na n.p. | Zakládá pracovní poměr účast na nemocenském pojištění?

    Atributy tisku

    Základní údaje
OSC | Jednoznačná identifikace pracovníka | MZPRACPO_mz01id | C(6)
Číslo p.p. | Číslo pracovního poměru | MZPRACPO_mz32cispp | C(2)
Denní vyměřovací základ | Denní vyměřovací základ nemocenského pojištění. | MZPRACPO_mz32npzakl | N(3)
Skončení p.p. | Skončení prac. poměru | MZPRACPO_mz32skonpp | D
Vznik p.p. | Vznik prac. poměru | MZPRACPO_mz32vznipp | D
Určující | Jedná se o určující prac.pom. (při více prac.poměrech)? | Výpočet | C(3)
Roční nárok na dovolenou | Roční nárok na dovolenou. | MZPRACPO_mz32dovnar | N(6,2)
Zůstatek staré dovolené | Zůstatek staré dovolené | MZPRACPO_mz32dovsta | N(6,2)
Zůstatek nové dovolené | Zůstatek nové dovolené | MZPRACPO_mz32dovnov | N(6,2)
Hodinový průměr | Hodinový průměr | MZPRACPO_mz32pruhod | N(9,2)
Denní průměr | Denní průměr | MZPRACPO_mz32pruden | N(9,2)
Měsíční průměr | Měsíční průměr | MZPRACPO_mz32prumes | N(9,2)

    Viz.také

    Charakter vlastnosti


Výběr tar. třídy (úkolová-tari

Popis

Uživateli se nabízí číselník tarifních stupnic, ze kterého si vybere potřebnou tarifní skupinu a třídu nebo v případě potřeby založí novou.

Datový model

  • MZTARTRI Tarifní třída

    • Formulář

    Formulář činnosti - Výběr tar. třídy (úkolová-tari
Mřížka [Třídy]
Stupnice | Identifikace tarifní stupnice
Třída | Tarifní třída (1-99)
Sazba | Firemní mzda hodinová
Min. měsíční mzda | Minimální mzda měsíční
Komentář | Komentář

    Mřížka [Třídy] činnosti - Výběr tar. třídy (úkolová-tari

    Mřížka [Třídy] činnosti - Výběr tar. třídy (úkolová-tari
Stupnice | Identifikace tarifní stupnice
Třída | Tarifní třída (1-99)
Sazba | Firemní mzda hodinová
Min. měsíční mzda | Minimální mzda měsíční


Definice výkazu

Popis

Tato činnost se spouští z menu Volby v činnosti seznam výkazů. Jedná se o vytvoření definice daného výkazu, tj. toho výkazu, na kterém stál v činnosti seznam výkazů kurzor. Na první obrazovce se záložkou "řádky" se definují jednotlivé řádky mzdových výkazů.

U každého řádku se zadává:

¨ řádek - číslo řádku ve výkazu

¨ popis - vlastní popis řádku

¨ typ - jakého typu je daný řádek (výběr z číselníku)

¨ tisknout - zda se při tisku výkazu má tento řádek tisknout či nikoliv. Může nastat situace, že některé řádky mohou sloužit pouze pro výpočet jiného řádku, potom uživatel jistě ocení možnost, že si vytiskne pouze tento vybraný řádek a pomocné výpočtové řádky se na výkazu tisknout nebudou.

Druhou důležitou záložkou na této obrazovce je záložka "složky". Pod touto záložkou uživatel definuje jednotlivé složky, ze kterých se počítá daný (tj. aktuální) řádek. Může se jednat o jednu nebo o několik složek. Při zadávání každé složky se vstupují tyto údaje:

¨ identifikace - může se jednat o řádek nebo mzdovou položku. Nejčastěji se bude zcela určitě zadávat mzdová položka. Pokud však uživatel zadá řádek, znamená to, že při výpočtu této složky se určitým způsobem pracuje s výsledkem již spočteného řádku. Číslo tohoto řádku pak uživatel zadává v položce "řádek".

¨ typ - jedná se o vlastní výběr mzdové položky

¨ operace - udává se, jakým způsobem se k sobě mají jednotlivé složky v řádku chovat. Zda se k sobě mají přičítat (což bude zřejmě nejčastější způsob) nebo se mohou odečítat, dělit či násobit.

Datový model

  • MZDLD Výkazy - řádky

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Typy řádků pro výkazy | Typy řádků pro výkazy
F2 | Výběr mzd. pol. pro výkazy | Lupa v činnosti definice výkazů na Identifikace mzdové položky

    Formulář

    Formulář činnosti - Výběr mzd. pol. pro výkazy
Mřížka [Řádky]
Listovací rámeček
Stránka #1 Řádky
Výkaz | Identifikace výkazu
 | Popis výkazu
Řádek | Číslo řádku
Popis | Popis řádku
Typ | Typ řádku
 | Popis řádku
Vytvářet nulový řádek ? | Vytvářet nulový řádek ? Má být řádek vytvořen i v případě, že jeho hodnoty jsou v celém roce nula ?
Komentář | Komentář
Tisknout | Tisknout ano/ne?
Stránka #2 Složky
Mřížka [Složky řádků]
Identifikace | Identifikace
Typ | Jednoznačná identifikace mzdové položky
 | Popis mzdové položky
Řádek | Číslo řádku
 | Název řádku uvedeného jako složka jiného řádku
Operace | Identifikace operace

    Mřížka [Řádky] činnosti - Výběr mzd. pol. pro výkazy

    Mřížka [Řádky] činnosti - Výběr mzd. pol. pro výkazy
Řádek | Číslo řádku
Popis | Popis řádku
Typ | Typ řádku
Nulový | Vytvářet nulový řádek ? Má být řádek vytvořen i v případě, že jeho hodnoty jsou v celém roce nula ?
Tisknout | Tisknout ano/ne?

    Mřížka [Složky řádků] činnosti - Výběr mzd. pol. pro výkazy

    Mřížka [Složky řádků] činnosti - Výběr mzd. pol. pro výkazy
Typ | Jednoznačná identifikace mzdové položky
Řádek | Číslo řádku
Operace | Identifikace operace

    Atributy tisku

    Základní údaje
Výkaz | Identifikace výkazu | MZDLD_mz49id | C(6)
Popis | Popis výkazu | MZVYKAZY_mz49popis | C(30)
Řádek | Číslo řádku | MZDLD_mz50id | N(4)
Popis | Popis řádku | MZDLD_mz50nazev | C(40)
Tisknout | Tisknout ano/ne? | Výpočet | C(3)
Typ | Typ řádku | MZDLD_mz51typ | C(1)
Vytvářet nulový řádek ? | Vytvářet nulový řádek ? Má být řádek vytvořen i v případě, že jeho hodnoty jsou v celém roce nula ? | Výpočet | C(3)
Popis | Popis řádku | MZDLTYPR_mz51popis | C(55)
Identifikace | Identifikace | Výpočet | C(14)
Mzdová položka | Jednoznačná identifikace mzdové položky | MZDLP_mz28id | C(6)
Popis | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Řádek | Číslo řádku | MZDLP_mz52radek | N(5)
Operace | Identifikace operace | Výpočet | C(6)
Popis | Název řádku uvedeného jako složka jiného řádku | MZDLP_mz52popis | C(40)

    Viz.také

    Typy řádků pro výkazy | Výběr mzd. pol. pro výkazy


Výpočet výkazu

Popis

Tuto činnost uživatel spouští z menu Volby v činnosti seznam výkazů. Při výpočtu výkazu uživatel pouze zadává rok, za který chce daný výkaz spočítat a tento údaj následně uloží (ikonka "disketa"). Systém sám uživateli nahlásí, kdy je výpočet výkazu dokončen. Po ukončení této operace je pak možno si jednotlivé vypočtené výkazy prohlédnout, popř. i vytisknout.

Datový model

  • MZDLIST Mzdový list

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Karta pracovníka | Karta pracovníka

    Formulář

    Formulář činnosti - Karta pracovníka
Zadejte rok zpracování výkazu | Rok
Zadejte pracovníka | Číslo pracovníka

    Atributy tisku

    Základní údaje
Datum | Datum | MZDLIST_datum | D
Identifikace | Identifikace výkazu | MZDLIST_mz49id | C(6)
OSC | Jednoznačná identifikace pracovníka | MZDLIST_mz01id | C(6)
Řádek | Číslo řádku | MZDLIST_mz50id | N(4)
Hodnota | Hodnota-peníze,hodiny,dny,... | MZDLIST_mz53hodnot | N(12)

    Viz.také

    Karta pracovníka


Seznam pracovníků pro výběr

Popis

Uživatel si může každý výkaz spočítat za jednotlivé pracovníky zvlášť (v tomto případě je nutno vždy zadat číslo pracovníka) nebo pokud nechá toto políčko prázdné, spočítá se vybraný výkaz pro všechny pracovníky najednou.

V podstatě se nejedná o výpočet výkazu, ale o jeho zobrazení. Výpočet výkazu probíhá vždy pro všechny pracovníky najednou, ale jednotlivé výkazy je pak možno prohlížet jednotlivě či všechny najednou. Ve většině případů se výkazy jistě budou prohlížet pro všechny pracovníky najednou, může však nastat situace, že bude v danou chvíli potřeba daný výkaz pouze pro jednoho pracovníka a potom by bylo zbytečné prohlížet výkazy pro všechny pracovníky a složitě výkaz daného pracovníka hledat.

Datový model

  • MZKARTA Pracovník

    • Formulář

    Formulář činnosti - Algoritmus stanovení nem. dávky
Mřížka [pracovníci]
OSC | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Titul | Titul pracovníka (před jménem)

    Mřížka [pracovníci] činnosti - Algoritmus stanovení nem. dávky

    Mřížka [pracovníci] činnosti - Algoritmus stanovení nem. dávky
OSC | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Datum narození | Datum narození
Rodné číslo | Rodné číslo
Žena/muž | Žena, muž
Stav | Stav - svobodný/á,ženatý,vdaná,vdovec,vdova,rozvedený/á
Typ důchodu | Typ důchodu
Datum přiznání | Datum přiznání důchodu, pracovník dovršil důchodový věk
Ext.id. | Externí identifikace pracovníka

    Atributy tisku

    Základní údaje
OSC | Jednoznačná identifikace pracovníka | MZKARTA_mz01id | C(6)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Výpl. místo | Jednoznačná identifikace výplatního místa | MZKARTA_mz22id | C(6)


Výběr pracovního poměru

Popis

Jedná se pouze o výběr pracovního poměru z číselníku. Po zadání čísla pracovníka se pak po aktivaci této činnosti uživateli nabízí přehled pracovních poměrů daného pracovníka, z něhož si vybere pracovní poměr.

Datový model

  • MZPRACPO Pracovní poměr
    • MZKALEN Kalendář má
    • MZPRACFU Pracovní funkce - skutečné a typové
      • MZUMIST Alokace mezd - umístění
    • MZTARTRI Tarifní třída
    • MZTARSTU Stupnice zahrnuje

    • Formulář

    Formulář činnosti - Umístění mezd
Mřížka [Prac. poměr]
OSC | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Číslo p.p. | Číslo pracovního poměru
Druh | Druh pracovního poměru
Prac. funkce | Identifikace pracovní funkce (zařazení)
 | Popis pracovní funkce (pracovního zařazení)
Kalendář | Jednoznačná identifikace kalendáře
 | Název kalendáře
Stupnice | Identifikace tarifní stupnice
 | Popis tarifní stupnice
Třída | Tarifní třída (1-99)
Umístění | Identifikace umístění mezd
 | Název umístění mezd
 | Jedná se o určující prac.pom. (při více prac.poměrech)?
Zkušební lhůta | Datum ukončení zkušební lhůty
Org. sel. | Identifikátor organizačního selektoru.

    Mřížka [Prac. poměr] činnosti - Umístění mezd

    Mřížka [Prac. poměr] činnosti - Umístění mezd
Číslo p.p. | Číslo pracovního poměru
Druh | Druh pracovního poměru
Prac. funkce | Identifikace pracovní funkce (zařazení)

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Pracovní doba | Kalendáře a jim odpovídající měsíční fond pracovní doby.
F2 | Pracovní místa skut. a typová | Popis pracovní funkce (zařazení)
F2 | Tarifní stupnice | Mzdové tarifní stupnice a jim odpovídající tarifní třídy.
F2 | Umístění mezd | Umístění mezd - alokace
F2 | Výběr tar. třídy | Umožní zvolit nějakou existující tar. třídu

    Viz.také

    Organizační selektor | Pracovní doba | Pracovní místa skut. a typová | Tarifní stupnice | Umístění mezd | Výběr tar. třídy


Výběr mzd. pol. pro výkazy

Popis

Tato činnost se uživateli nabízí při definování mzdových výkazů pod záložkou "složky". Je možno ji vyvolat z menu volby, ikonou lupa nebo stiskem klávesy F2. Uživateli se pak zobrazí číselník mzdových položek určený pro výkazy, z něhož si vybere příslušnou položku (stiskem klávesy Ctrl Enter nebo ikonou "návrat hodnoty") a pokračuje v definování složek mzdového výkazu.

Datový model

  • MZMZDPOL Mzdová položka

    • Formulář

    Formulář činnosti - Výběr tar. třídy (úkolová-tari
Mřížka [Mzd. položky]
Listovací rámeček
Stránka #1 Mzdové položky
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...
Stránka #2 Výběr
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Mzd. položky] činnosti - Výběr tar. třídy (úkolová-tari

    Mřížka [Mzd. položky] činnosti - Výběr tar. třídy (úkolová-tari
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...


Charakter pracovníka v p. p.

Popis

Charakterem pracovníka se rozumí jak bude v systému zařazen z hlediska účtování v druhu účetní události. Může se jednat o rozdělení společník, zaměstnanec nebo pracovník THP či dělník apod.

Tato činnost je uživateli přístupná v menu volby na záložce "pracovní poměry" v činnosti karta pracovníka.

Datový model

  • MZCHARPP Charaktery pracovníka v prac. poměru

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Charakter vlastnosti | Charakter vlastnosti - spolěčníci, zaměstnanci ,...

    Formulář

    Formulář činnosti - Charakter vlastnosti
Mřížka [Charakter pracovníka v prac. poměru]
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Číslo p.p. | Číslo pracovního poměru
Charakter | Charakter vlastnosti
 | Komentář

    Mřížka [Charakter pracovníka v prac. poměru] činnosti - Charakter vlastnosti

    Mřížka [Charakter pracovníka v prac. poměru] činnosti - Charakter vlastnosti
Pracovník | Jednoznačná identifikace pracovníka
Číslo p.p. | Číslo pracovního poměru
Vlastnost | Charakter vlastnosti

    Atributy tisku

    Základní údaje
Pracovník | Jednoznačná identifikace pracovníka | MZCHARPP_mz01id | C(6)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Číslo p.p. | Číslo pracovního poměru | MZCHARPP_mz32cispp | C(2)
Druh prac. poměru | Druh pracovního poměru | Výpočet | C(19)
Charakter | Charakter vlastnosti | MZCHARPP_mz72id | C(20)
Komentář | Komentář | MZCHARAK_mz72koment | M
Zdrav. pojišťovna | Identifikace pojišťovny, např. 111, 121 ,... | MZKARTA_mz70idp | C(3)

    Viz.také

    Charakter vlastnosti


Generace událostí-platby- sumá

Popis

Jedná se o programové šablony, které slouží pro vytváření událostí (i agregovaných) mezd z různých pohledů (např. z hlediska plateb, účetnictví, statistiky apod.).

Datový model

  • MZMZDY Mzda
    • MZMZDPOL Mzdová položka
      • MZDRUHUD Druh události
    • MZKARTA Pracovník
      • MZPOJSEZ Seznam zdravotních pojišťoven

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Generace událostí mezd - jen U

Popis

Jedná se o programové šablony, které slouží pro vytváření událostí (i agregovaných) mezd z různých pohledů (např. z hlediska plateb, účetnictví, statistiky apod.).

Datový model

  • MZMZDY Mzda
    • MZMZDPOL Mzdová položka
      • MZDRUHUD Druh události

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Generace událostí - souhrn UC

Popis

Jedná se o programové šablony, které slouží pro vytváření událostí (i agregovaných) mezd z různých pohledů (např. z hlediska plateb, účetnictví, statistiky apod.).

Datový model

  • MZMZDY Mzda
    • MZMZDPOL Mzdová položka
      • MZDRUHUD Druh události

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


SUMY

Popis

Tato činnost se aktivuje stiskem klávesy Ctrl S ve formuláři výplatní lístky. Podle údajů, které jsou na záložce „výběr“ ve výplatních lístcích zadány se potom zobrazují následující údaje:

¨ počet dnů celkem

¨ počet dnů kalendářních celkem

¨ celkem hodin

¨ celkem částka Kč

Formulář

Formulář činnosti - Karta pracovníka
Dnů | Počet dnů (výkonu práce, volna, nemoci,...)
Dnů kalendářních | Počet kalendářních dnů.
Hodin | Počet hodin (výkonu práce, volna, nemoci,...)
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
Dnů do FPD | Počet dnů, které se započítávají do FPD
Hodin do FPD | Počet hodin, které se započítávají do FPD


Generace událostí - statistika

Popis

Jedná se o programové šablony, které slouží pro vytváření událostí (i agregovaných) mezd z různých pohledů (např. z hlediska plateb, účetnictví, statistiky apod.).

Datový model

  • MZMZDY Mzda
    • MZMZDPOL Mzdová položka
      • MZDRUHUD Druh události
    • MZKARTA Pracovník (alias MZKARTA2)
      • MZZDRPOJ Zdravotní pojišťovny a jejich přidělení

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Generace událostí - UC dle org

Popis

Jedná se o programové šablony, které slouží pro vytváření událostí (i agregovaných) mezd z různých pohledů (např. z hlediska plateb, účetnictví, statistiky apod.).

Datový model

  • MZMZDY Mzda
    • MZMZDPOL Mzdová položka
      • MZDRUHUD Druh události

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Generace - UC dle org + SP org

Popis

Jedná se o programové šablony, které slouží pro vytváření událostí (i agregovaných) mezd z různých pohledů (např. z hlediska plateb, účetnictví, statistiky apod.).

Datový model

  • MZMZDY Mzda
    • MZMZDPOL Mzdová položka
      • MZDRUHUD Druh události

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Generace událostí - podrobně -

Popis

Jedná se o programové šablony, které slouží pro vytváření událostí (i agregovaných) mezd z různých pohledů (např. z hlediska plateb, účetnictví, statistiky apod.).

Datový model

  • MZMZDY Mzda
    • MZMZDPOL Mzdová položka
      • MZDRUHUD Druh události

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


SUMY - úkolové listy

Popis

Tato činnost se spustí aktivací příslušné činnosti pod menu Volby ve formuláři „úkolové listy“ nebo po stisku Ctrl S. Informace zde zobrazené jsou závislé na vyfiltrovaných údajích na záložce „výběr“ a zároveň sumární údaje odpovídají pracovníkovi a pracovnímu poměru podle toho, na kterém místě formuláře má uživatel umístěn kurzor.

Formulář

Formulář činnosti - Umístění mezd
Hodin | Počet hodin (výkonu práce, volna, nemoci,...)
Dnů | Počet dnů (výkonu práce, volna, nemoci,...)
Částka | Celková částka v Kč (mzda, daň, srážka, ..., ap.)
Přestávka | Přestávka v práci - v hodinách
Pracovník | Jednoznačná identifikace pracovníka
Číslo p.p. | Číslo pracovního poměru
Měsíc | Měsíc
Hodin dle FPD | Pracovních hodin v měsíci
Dnů dle FPD | Počet pracovních dnů v měsíci.
Rozdíl | Rozdíl dnů - dnů dle FPD
Součty odpovídají pracovníkovi a pracovnímu poměru dle toho, kde na mřížce zrovna stojíte. | Rozdíl hodin - hodin dle FPD


SUMA - události mezd

Popis

Tato činnost se spustí aktivací příslušné činnosti pod menu Volby nebo stiskem klávesy Ctrl S ve formuláři „události mezd“. Sumární údaje jsou agregované podle typu události.

Formulář

Formulář činnosti - Charakter vlastnosti
Kč - UC | Celková částka v Kč - typ UC
Kč - ST | Celková částka v Kč - typ ST
Kč - PL | Celková částka v Kč - typ PL
Kč - OST | Celková částka v Kč - typ OST


Generace událostí - účetnictví

Popis

Jedná se o programové šablony, které slouží pro vytváření událostí (i agregovaných) mezd z různých pohledů (např. z hlediska plateb, účetnictví, statistiky apod.).

Datový model

  • MZMZDY Mzda
    • MZMZDPOL Mzdová položka
      • MZDRUHUD Druh události
    • MZKARTA Pracovník (alias MZKARTA2)
      • MZZDRPOJ Zdravotní pojišťovny a jejich přidělení
        • MZPOJSEZ Seznam zdravotních pojišťoven

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Seznam typových pracovních míst

Popis

Typová místa uživatel využije při práci s modulem personalistika, především při vytváření skutečných pracovních míst. Je možno si např. nadefinovat typové místo obchodník a na jeho základě pak vytvořit třeba tři skutečné pracovní místa obchodník 01 – 03 s drobnými rozdíly. V této činnosti uživatel typová místa nedefinuje, slouží skutečně jen jako seznam. V případě potřeby nového typového místa je nutno aktivovat činnost „pracovní místa skut. a typová“ (menu Mzdy – Definice). U každého typového místa je v této činnosti k dispozici informace o:

¨ identifikace pracovní funkce (zařazení)

¨ popis funkce

¨ typ pracovní funkce – skutečná/typová

¨ tř. KZAM – třída podle klasifikace zaměstnání

¨ kalendář – jednoznačná identifikace kalendáře používaného pro dané pracovní místo

¨ stupnice – identifikace tarifní stupnice

¨ třída – třída 1 až 99

¨ typové místo – identifikace typové pracovní funkce

¨ umístění – identifikace umístění mezd

¨ komentář – libovolný popis

Datový model

  • MZPRACFU Pracovní funkce - skutečné a typové

    • Vyvolávané činnosti

    K. | Činnost | Popis
^O | OZNAČOVÁNÍ | Označení, odznačení, přehled všech/označených
F2 | Pracovní doba | Kalendáře a jim odpovídající měsíční fond pracovní doby.
F2 | Tarifní stupnice | Mzdové tarifní stupnice a jim odpovídající tarifní třídy.
F2 | Umístění mezd | Umístění mezd - alokace
F2 | Výběr tar. třídy | Umožní zvolit nějakou existující tar. třídu

    Formulář

    Formulář činnosti - Hodnoty požadavku/vlastnost
Mřížka [prac. zařazení]
Identifikace | Identifikace pracovní funkce (zařazení)
Popis | Popis pracovní funkce (pracovního zařazení)
Typ | Typ pracovního místa
Tř. KZAM | Třída podle klasifikace zaměstnání
Kalendář | Jednoznačná identifikace kalendáře
Stupnice | Identifikace tarifní stupnice
Třída | Tarifní třída (1-99)
Umístění | Identifikace umístění mezd
Typové místo | Identifikace typové pracovní funkce (zařazení)
Komentář | Komentář k popisu pracovního místa
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události

    Mřížka [prac. zařazení] činnosti - Hodnoty požadavku/vlastnost

    Mřížka [prac. zařazení] činnosti - Hodnoty požadavku/vlastnost
Identifikace | Identifikace pracovní funkce (zařazení)
Prac.funkce | Popis pracovní funkce (pracovního zařazení)
Identifikace | Jednoznačná identifikace kalendáře
Identifikace | Identifikace tarifní stupnice
Třída | Tarifní třída (1-99)
Tř. KZAM | Třída podle klasifikace zaměstnání
Umístění | Identifikace umístění mezd
Typové místo | Identifikace typové pracovní funkce (zařazení)
Typ | Typ pracovního místa
Stav | Stav

    Viz.také

    OZNAČOVÁNÍ | Pracovní doba | Tarifní stupnice | Umístění mezd | Výběr tar. třídy | Hodnoty požadavku/vlastnost


Generuj FPD po dnech

Popis

Tato činnost vygeneruje fond pracovní doby ve dnech pro jeden (právě aktuální) kalendář (právě aktuálním kalendářem se rozumí ten, na kterém je v danou chvíli umístněn kurzor nebo je označen).


Generuj veškerý FPD po dnech

Popis

Tato činnost přegeneruje fond pracovní doby (FPD) ve dnech pro všechny dosud založené kalendáře.


Kalendáře

Popis

Uživatel má jednak k dispozici nabídku stávajících kalendářů a jednak má možnost si nový kalendář založit a vygenerovat si k němu příslušný fond pracovní doby (FPD). Kalendář slouží pro kontrolu počtu zadaných hodin, nehlídá práci ve svátek a přesčasy.

Pokud uživatel zadává nový kalendář, postupuje tímto způsobem. Pod záložkou kalendář založí nový kalendář (včetně denního úvazku) a poté spustí činnost "generuj FPD" (menu volby). Program poté spočítá FPD k danému kalendáři.

Na FPD se při výpočtu mezd porovnává, zda má pracovník zadán plný počet hodin. Po zadání mzdových položek (dovolená, nemoc,...), lze podle FPD dopočítávat hodiny implicitní práce do plně odpracované doby v měsíci.

Datový model

  • MZKALEN Kalendář má

    • Formulář

    Formulář činnosti - Nový záznam podle schématu
Mřížka [kalendáře]
Kalendář | Jednoznačná identifikace kalendáře
 | Název kalendáře
Hod / den | Pracovní doba hodin / den
Komentář | Komentář

    Mřížka [kalendáře] činnosti - Nový záznam podle schématu

    Mřížka [kalendáře] činnosti - Nový záznam podle schématu
Identifikace | Jednoznačná identifikace kalendáře
Kalendář | Název kalendáře
Hod / den | Pracovní doba hodin / den


Výběr položky

Popis

Uživatel má pomocí této činnosti možnost si vyfiltrovat výběr mzdové položky podle svých aktuálních potřeb.

Datový model

  • MZMZDPOL Mzdová položka

    • Formulář

    Formulář činnosti - Algoritmus stanovení nem. dávky
Mřížka [Mzd. položky]
Listovací rámeček
Stránka #1 Mzdové položky
Mzdová položka | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...
Stránka #2 Výběr
Mzdová položka | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Mzd. položky] činnosti - Algoritmus stanovení nem. dávky

    Mřížka [Mzd. položky] činnosti - Algoritmus stanovení nem. dávky
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...


Záložka zdrav.poj. (P3)

Popis

Tato záložka poskytuje přehled o zdravotních pojišťovnách daného pracovníka. Eviduje se:

¨ zdravotní pojišťovna – tj. kód pojišťovny a číslo pod kterým je daná pojišťovna zařazena v adresáři IS BM (toto číslo se automaticky natáhne z karty pojišťovny)

¨ číslo pojištěnce – zadává se pouze v případě, že je odlišné od rodného čísla pracovníka

¨ datum zahájení platnosti položky

¨ datum ukončení platnosti položky


Záložka osob.údaje(P2)

Popis

Jako první jsou na této záložce k dispozici atributy, které přímo souvisí s řízením běhu výpočtu mezd. Jedná se o:

¨ zdravotní pojištění – zvolená možnost z překryvného seznamu řídí způsob výpočtu zdravotního pojištění pracovníka

¨ podepsal prohlášení – tento atribut přímo řídí způsob výpočtu uplatnění zálohové daně

¨ lze srážet – tento atribut přímo řídí způsob výpočtu uplatnění srážkové daně

¨ provést roční zúčtování – pokud je zatrženo, provede se u tohoto pracovníka výpočet ročního zúčtování daně. Pokud zatrženo není, znamená to, že pracovník si přiznání daně provádí sám, mimo firmu.

Další údaje, které jsou zde k dispozici slouží částečně i jako podklad pro hlášení RELDP:

¨ rodné číslo

¨ číslo občanského průkazu

¨ rodné příjmení

¨ datum narození

¨ místo narození

¨ státní příslušnost

¨ stav – tzn. rodinný stav (možno vybrat z překryvného seznamu)

¨ počet dětí

¨ informace, zda se jedná či nejedná o pracovníka zdravotně postiženého

¨ muž/žena

¨ další příjmení – tzn. příjmení předcházející současnému příjmení

¨ v případě, že se jedná o pracujícího důchodce, tak informace o typu důchodu, od kdy ho pracovník pobírá a kolik Kč

Tyto vyplněné údaje mohou mít vliv na uživatelem nadefinované sestavy, které si vytvořil pro své interní účely, některé informace se uvádějí i na mzdovém listu.


Záložka volné údaje (PA1)

Popis

Na této záložce je vhodné evidovat údaje o pracovníkovi, které nás zajímají a které nám neumožňují sledovat jiné záložky, např. údaje o dosaženém vzdělání, o provedených školeních apod. Jsou to uživatelsky nastavitelné údaje a pro jejich správné fungování je třeba mít nadefinovány sady parametrů a jejich strukturu (menu Obecné – Hodnoty parametrů objektu - Sady parametrů).


Záložka prac.poměry (P4)

Popis

Tato záložka je svojí důležitostí pro kartu pracovníka klíčová. Zadává se zde seznam pracovních poměrů pracovníka u organizace. K dispozici jsou tyto atributy:

¨ číslo p.p. – číslo prac. poměru a jeho druh (na výběr z překryvného seznamu)

¨ prac. funkce – identifikace pracovní funkce (seznam pracovních funkcí by si měla každá organizace uživatelsky nadefinovat)

¨ kalendář – identifikace kalendáře, který je platný pro daného pracovníka, je nedílnou součásti pracovního poměru a ve výpočtu mezd má zásadní vliv (např. pro výpočet FPD, minimální mzdy apod.). Při vytváření nového kalendáře se definuje jeho identifikace, název a počet hodin za den. Pak je nutno každému kalendáři v číselníku vygenerovat fond pracovní doby ve dnech nebo v měsících (menu Volby) – podle nastavení atributu „typ kalendáře“ v činnosti Parametry – záložka Chování.

¨ stupnice – identifikace tarifní stupnice. V číselníku se u každé stupnice evidují i jednotlivé tarifní třídy

¨ třída – identifikace tarifní třídy

¨ určující – možná volba Ano/Ne. Pokud má uživatel více pracovních poměrů, musí mít jeden určený jako určující.

¨ vznik p.p. – datum zahájení daného pracovního poměru

¨ typ mzdy – volbou typu mzdy se v podstatě určuje způsob odměňování (měsíční, hodinová apod.). Typ mzdy byl vyvinut pro účely hlídání překročení minimální mzdy. Je nastaven na kartě pracovníka (záložka pracovní poměry) a předplňuje se podle uvedené pracovní funkce.

¨ skončení p.p. – datum ukončení pracovního poměru

¨ zkušeb. lhůta – datum ukončení zkušební lhůty pracovníka u daného prac. poměru

¨ selektory

Na této záložce má uživatel pod menu Volby k dispozici další důležité atributy, které je nutno u pracovníka evidovat . Jsou dostupné v činnosti:

¨ pravidelné příjmy (funkční klávesa F5)

¨ další informace (funkční klávesa F6)

Pro snadnější zadání a zamezení opomenutí některých údajů u pracovníka je možné po zadání a uložení pracovního poměru využít možnost, kterou uživateli nabízí činnost Cyklus při vstupu nového pracovníka (menu Volby nebo funkční klávesa F7). Po aktivaci této činnosti se uživateli postupně zobrazující všechny činnosti, které je nutné v této souvislosti vyplnit.


Záložka měs.nezd.pol. (P5)

Popis

Jedná se o historickou záložku. Údaje, které se zadávaly na této záložce byly platné do prosince 2005. Jednalo se o částky, o které je možné snížit základ daně – v současné době nahrazeno na záložce daňová zvýhodnění.


Záložka roč.nezd.pol (P6)

Popis

Na této záložce se evidují údaje, které jsou potřebné k provedení ročního zúčtování daně. Mzdová účetní je může vyplňovat postupně během roku. Údaje se do výpočtu zahrnou až v okamžiku, kdy je příznak „provést roční zúčtování“ nastaven na Ano (záložka osobní údaje).


Záložka půjčky (P7)

Popis

Na záložku půjčky doporučujeme zadávat pohledávky, které mají nepřednostní fixní charakter a u kterých se splácí jedna pevná částka každý měsíc. Při uzávěrce mezd dojde o odečtení provedené splátky půjčky od zůstatku půjčky. Datum doručení soudního rozhodnutí je povinné. Zadávají se tyto údaje:

¨ identifikace – poměrně složité nadefinování, které by měl dělat pouze zkušený uživatel nebo přímo implementátor. Definuje se zde vlastní identifikace, její popis, druh, poddruh, výše Kč, způsob srážení, priorita (1-pohledávky, 2-srážky na vlastní účet, 3-pohl.výživné), způsob uplatnění exekuční pohl. a zda se položka bude či nebude tisknout na výplatním lístku.

¨ kolik Kč srážet, pořadí srážky

¨ identifikace adresáta a jeho bankovního spojení

¨ variabilní symbol

¨ datum doručení soudního rozhodnutí

¨ od data – do data


Záložka srážky (P8)

Popis

Na záložku srážky doporučujeme zadávat pouze nepohledávky, např. srážku typu „vše na účet“. Datum doručení rozhodnutí je v tomto případě nepovinný. Zadávají se tyto údaje:

¨ identifikace – poměrně složité nadefinování, které by měl dělat pouze zkušený uživatel nebo přímo implementátor. Definuje se zde vlastní identifikace, její popis, druh, poddruh, výše Kč, způsob srážení, priorita (1-pohledávky, 2-srážky na vlastní účet, 3-pohl.výživné), způsob uplatnění exekuční pohl. a zda se položka bude či nebude tisknout na výplatním lístku.

¨ kolik Kč srážet, pořadí srážky

¨ identifikace adresáta a jeho bankovního spojení

¨ variabilní symbol

¨ datum doručení soudního rozhodnutí

¨ od data – do data


Položky protokolu

Popis

Tato činnost se aktivuje po stisku klávesy F6 nebo spuštěním příslušné činnost v menu Volby z činnosti Protokol strukturovaný. Na základě nadefinovaného filtru na záložce Výběr (např. zajímá-li uživatele pouze konkrétní pracovník nebo konkrétní mzdová položka – pokud je výběr ponechán prázdný, načtou se všechny položky protokolu, ze kterého byla tato činnost aktivována) jsou k dispozici údaje, které hlásí uživateli určité nesrovnalosti, které nastaly během výpočtu mezd. Co, za jakých okolností, případně jak barevně zobrazeno, má systém hlásit jako nesrovnalost se nastavuje v činnosti algoritmy výpočtu protokolu.

Datový model

  • MZPROTPL Položky protokolu k hlavičce protokolu
    • MZKARTA Pracovník
    • MZPROTAU Užití algoritmu výpočtu položky protokolu při výpočtu mezd
      • BWRGBCOL Hodnota RGB barvy
      • BWRGBCOL Hodnota RGB barvy (alias BWRGBCOL2)

    • Formulář

    Formulář činnosti - Karta pracovníka
Mřížka [Položky protokolu]
Listovací rámeček
Stránka #1 Položky protokolu
Položka | Identifikace položky
Pořadové číslo | Pořadové číslo jednotlivého hlášení v rámci hlavičky.
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Číslo p.p. | Číslo pracovního poměru
Popis | Popis hlášení
Text hlášení | Text hlášení
Poznámka uživatele | Poznámka uživatele
Stránka #2 Výběr
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Číslo p.p. | Číslo pracovního poměru
Položka | Identifikace položky
Popis | Popis hlášení
Skrytá | Skrytá položka protokolu Ano / Ne
Uchovat | Příznak uchování výběrového hlediska
Výběr | Určení výběru

    Mřížka [Položky protokolu] činnosti - Karta pracovníka

    Mřížka [Položky protokolu] činnosti - Karta pracovníka
Položka | Identifikace položky
Popis | Popis hlášení
OSC | Jednoznačná identifikace pracovníka
Číslo p.p. | Číslo pracovního poměru
Pořadové číslo | Pořadové číslo jednotlivého hlášení v rámci hlavičky.
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Titul | Titul pracovníka (před jménem)

    Atributy tisku

    Základní údaje
Pracovník | Jednoznačná identifikace pracovníka | MZPROTPL_mz01id | C(6)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Číslo p.p. | Číslo pracovního poměru | MZPROTPL_mz32cispp | C(2)
Popis | Popis hlášení | MZPROTPL_mz04popis | C(40)
Text hlášení | Text hlášení | MZPROTPL_mz04pozn | M
Položka | Identifikace položky | MZPROTPL_mz04id | C(6)
Pořadové číslo | Pořadové číslo jednotlivého hlášení v rámci hlavičky. | MZPROTPL_mz04poradi | N(5)


Složení dávky

Popis

Tuto činnost uživatel aktivuje stiskem klávesy F6 nebo spuštěním příslušné činnosti z menu Volby v činnosti Nepřítomnost pro nemoc. Složení dávky je v podstatě pouze informativní přehled, jak je daná nemocenská dávka nadefinována (tzn. hodnota první tři dny apod.). Složení dávky se řídí nastavenými parametry nemocenských dávek.

Datový model

  • MZNDSLOZ Nemocenská dávka - složení

    • Formulář

    Formulář činnosti - Karta pracovníka
Mřížka [Složení nem. dávky]
Typ | Typ údaje
Hodnota | Hodnota údaje určitého typu
Ode dne | Platné od pořadového čísla dne
Počet dnů | Počet dnů dávky

    Mřížka [Složení nem. dávky] činnosti - Karta pracovníka

    Mřížka [Složení nem. dávky] činnosti - Karta pracovníka
Typ | Typ údaje
Hodnota | Hodnota údaje určitého typu
Ode dne | Platné od pořadového čísla dne
Počet dnů | Počet dnů dávky

    Atributy tisku

    Základní údaje
Typ | Typ údaje | Výpočet | C(12)
JČI nem. dávky | Jednoznačná časová identifikace | MZNDSLOZ_mz38 | C(12)
Hodnota | Hodnota údaje určitého typu | MZNDSLOZ_mz15hodnot | N(10,4)


Nastavení zkušební doby

Popis

Tato činnost se aktivuje příslušnou činností v menu Volby z Karty pracovníka – záložka Pracovní poměry. Chování této činnosti závisí na nastaveném atributu v činnosti Parametry (v činnosti "Parametry" je atribut "Velikost zkušeb. doby v měs.“. Uživatel zadá potřebný počet měsíců, hodnota 0 = nepředplňovat).

Pokud je tento parametr nastaven na určitý počet měsíců, tak se při definování nového záznamu o pracovním poměru pracovníka automaticky atribut „zkušební doba“ předplní.

Jestliže uživatel opravuje již dříve vzniklý záznam o pracovním poměru pracovníka, pak se atribut "zkušební doba" NEpředplní. (takto je tedy možné zadat, že pracovník nebude mít žádnou zkušební dobu, nebo že bude mít jinou, která nebude v souladu s nastavením v "Parametrech".). Použitím činnosti "Volby - Nastavení zkušební doby" - nad "Kartou pracovníka" (záložkou "Pracovní poměry") - se atribut "zkušební doba" nastaví opět v souladu s údaji v "Parametrech".


Volné údaje pracovníků

Popis

Tato činnost se aktivuje z karty pracovníka – stiskem klávesy F9 nebo spuštěním příslušné činnosti z menu Volby. Umožňuje uživateli prohlížet nadefinované libovolné (tedy skutečně doslova „volné“) údaje o pracovnících, např. dosažené vzdělání, národnost, uskutečněná školení apod. Vlastní definice těchto údajů se provádí v činnosti Karta pracovníka na záložce Volné údaje.

Datový model

  • PAHODNOT Hodnota parametru
    • PAPARAM Parametr (alias PAPARAMPR)
      • PADRUPAR Druh algoritmu/parametru (alias PADRUPARPR)
        • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTUPR)
    • ADSPOJ Spojení adresáta (alias ADSPOJPR)
    • ADADSAT Adresát (alias ADADSATPR)
    • ADBUCTY Bankovní účty adresátů (alias ADBUCTYPR)
    • PACISPOL Položka obecného číselníku (alias PACISPOLPR)
    • SPARTIKL Artikl (alias SPARTIKLPR)
      • SPARTIKN Název artiklu (alias SPARTIKNPR)
    • MZKARTA Pracovník
      • MZKARTA Pracovník (alias MZKARTA2)

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresář | Přehled adresátů
F2 | Artikl | Seznam artiklu
F2 | Bankovní spojení adresátů |
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Karta pracovníka | Karta pracovníka
F2 | Obecné parametry | Obecné parametry
F2 | Položky obecného číselníku | Položky obecného číselníku
F2 | Spojení adresátů | Přehled spojení adresátů

    Formulář

    Formulář činnosti - Druhy artiklů
Mřížka [Volné údaje pracovníků]
Listovací rámeček
Stránka #1 Volné údaje pracovníků
Pracovník | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Rodné číslo | Rodné číslo
Parametr | Identifikátor parametru
Název parametru | Název parametru
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Identifikátor spojení na bankovní účet adresáta.
 | Název adresáta
ID | Identifikace položky číselníku
 | Název položky číselníku
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Text1 | Textová elementární hodnota
Dat1 | Datumová elementární hodnota 1
Dat2 | Datumová elementární hodnota 2
Num1 | Numerická elementární hodnota 1
Num2 | Numerická elementární hodnota 2
Cmb1 | Překryvný seznam elementární hodnota 1
Cmb2 | Překryvný seznam elementární hodnota 2
Poznámka | Poznámka
Platnost od | Platnost od
do | Platnost do
Stránka #2 Výběr
Pracovník | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Jméno | Jméno pracovníka
Parametr | Identifikátor parametru
Text1 | Textová elementární hodnota
Adresát | Identifikace adresáta
 | Název adresáta
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
ID | Identifikace položky číselníku
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 | Platnost nebo neplatnost k datu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Volné údaje pracovníků] činnosti - Druhy artiklů

    Mřížka [Volné údaje pracovníků] činnosti - Druhy artiklů
Pracovník | Jednoznačná identifikace pracovníka
Příjmení | Příjmení pracovníka
Název parametru | Název parametru
Hodnota parametru | Hodnota parametru
Platnost od | Platnost od
do | Platnost do
Jméno | Jméno pracovníka

    Atributy tisku

    Základní údaje
Pracovník | Jednoznačná identifikace pracovníka | MZKARTA_mz01id | C(6)
Rodné příjmení | Rodné příjmení | MZKARTA_mz01rodne | C(15)
Příjmení | Příjmení pracovníka | MZKARTA_mz01prijme | C(50)
Rodné číslo | Rodné číslo | MZKARTA_mz01rodc | C(11)
Jméno | Jméno pracovníka | MZKARTA_mz01jmeno | C(50)
Datum narození | Datum narození | MZKARTA_mz01naroz | D
Titul | Titul pracovníka (před jménem) | MZKARTA_mz01titul | C(15)
Parametr | Identifikátor parametru | PAHODNOT_pa02id | C(6)
Název parametru | Název parametru | PAPARAMPR_pa02nazpar | C(40)
Hodnota parametru | Hodnota parametru | Výpočet | C(100)
Poznámka | Poznámka | PAHODNOT_pa06koment | M
Platnost od | Platnost od | PAHODNOT_pa06datum | D
do | Platnost do | PAHODNOT_pa06datumd | D
Adresát | Identifikace adresáta | PAHODNOT_ad01id | C(6)
Název adresáta | Název adresáta | ADADSATPR_ad01adsat | C(100)
IČO | Identifikační číslo organizace. | ADADSATPR_ad01ico | C(10)
DIČ | Daňové identifikační číslo adresáta. | ADADSATPR_ad01dico | C(16)
Rodné číslo | Rodné číslo adresáta | ADADSATPR_ad01rc | C(10)
Spojení | Číslo spojení adresáta. | PAHODNOT_ad11cisspo | C(2)
Jméno | Jméno kontaktní osoby. | ADSPOJPR_ad11jmeno | C(40)
Jméno na štítek | Jméno pracovníka na poštovní štítek | ADSPOJPR_ad11jmenop | C(100)
Telefon | Telefonní číslo | ADSPOJPR_ad11cislo | C(60)
Fax | Faxové číslo | ADSPOJPR_ad11fax | C(60)
Jiné | Jiné spojení adresáta | ADSPOJPR_ad11cisost | C(60)
Mobil | Číslo mobilního telefonu | ADSPOJPR_ad11mobil | C(60)
e-mail | E-mail spojení adresáta | ADSPOJPR_ad11email | C(60)
Účet | Identifikátor spojení na bankovní účet adresáta. | PAHODNOT_ad03cisban | C(2)
Kód banky | Kód banky | ADBUCTYPR_oc02idbank | C(4)
Pobočka | Název pobočky, která vede bankovní účet adresátovi. | ADBUCTYPR_ad03poboc | C(25)
Prefix ú. | Prefix bankovního účtu adresáta | ADBUCTYPR_ad03pructu | C(6)
Č. účtu | Číslo bankovního účtu adresáta. | ADBUCTYPR_ad03ucet | C(34)
Specifický symbol | Specifický symbol adresáta | ADBUCTYPR_ad03ssymb | C(10)
Měna | Kód měny - oceňovací jednotky. | ADBUCTYPR_oc01id | C(3)
Název ú. | Název účtu | ADBUCTYPR_ad03nauctu | C(20)
Text1 | Textová elementární hodnota | PAHODNOT_pa06text1 | C(60)
Identifikace položky číselníku | Identifikace položky číselníku | PAHODNOT_pa08id | C(10)
Název položky číselníku | Název položky číselníku | PACISPOLPR_pa08nazpol | C(40)
Druh artiklu | Identifikace druhu artiklu | PAHODNOT_sp61id | C(3)
Artikl | Identifikace artiklu | PAHODNOT_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKNPR_sp62artikl | C(60)
Num1 | Numerická elementární hodnota 1 | PAHODNOT_pa06num1 | N(20,4)
Num2 | Numerická elementární hodnota 2 | PAHODNOT_pa06num2 | N(20,4)
Dat1 | Datumová elementární hodnota 1 | PAHODNOT_pa06dat1 | D
Dat2 | Datumová elementární hodnota 2 | PAHODNOT_pa06dat2 | D
Cmb1 | Překryvný seznam elementární hodnota 1 | PAHODNOT_pa06cmb1 | N(1)
Cmb2 | Překryvný seznam elementární hodnota 2 | PAHODNOT_pa06cmb2 | N(1)
Oblast | Oblast sady parametrů | PAHODNOT_pa01oblast | C(2)

    Viz.také

    Adresář | Artikl | Bankovní spojení adresátů | Druhy artiklů | Karta pracovníka | Obecné parametry | Položky obecného číselníku | Spojení adresátů


Dotazy výpočtu

Popis

Tato činnost se aktivuje při spuštění optimalizovaného výpočtu mezd. Uživatel má možnost ovlivnit další běh výpočtu u zobrazených pracovníků.

Datový model

  • MZDOTAZ Hromadný speciální dotaz při běhu výpočtu
    • MZKARTA Pracovník
    • MZDOTPRI Druhy speciálních testů výpočtu při běhu výpočtu

    • Formulář

    Formulář činnosti - Srážky
Mřížka [Dotazy k výpočtu]
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Rodné číslo | Rodné číslo
Číslo p.p. | Číslo pracovního poměru
 | Typ dotazu (koresponduje se záznamem v Protokolu)
 | Priorita
 | Důvod dotazu
Dotaz | Dotaz - znění
Odpověď | Odpověď
Komentář | Komentář
Číslo 1 | Číselná hodnota

    Mřížka [Dotazy k výpočtu] činnosti - Srážky

    Mřížka [Dotazy k výpočtu] činnosti - Srážky
Označování | Označení záznamu
Pracovník | Jednoznačná identifikace pracovníka
Číslo p.p. | Číslo pracovního poměru
Typ hlášení v protokolu | Typ dotazu (koresponduje se záznamem v Protokolu)
Odpověď | Odpověď
Číslo 1 | Číselná hodnota
Priorita | Priorita
Platný | Záznam je platný v aktuálním výpočtu
Důvod | Důvod dotazu

    Atributy tisku

    Základní údaje
OSC | Jednoznačná identifikace pracovníka | MZDOTAZ_mz01id | C(6)
Číslo p.p. | Číslo pracovního poměru | MZDOTAZ_mz32cispp | C(2)
Typ hlášení v protokolu | Typ dotazu (koresponduje se záznamem v Protokolu) | MZDOTAZ_mz08typdot | C(6)
Dotaz | Dotaz - znění | MZDOTAZ_mz08dotaz | M
Komentář | Komentář | MZDOTAZ_mz08koment | M
Odpověď | Odpověď | Výpočet | C(1)
Platný | Záznam je platný v aktuálním výpočtu | Výpočet | C(3)


Záložka daňová zvýhodnění (PA2)

Popis

Tato záložka je platná od 1.1.2005 pro zadání zvýhodnění na děti a od 1.1.2006 pro zadání zvýhodnění i na ostatní položky. Důležité jsou tyto atributy:

¨ identifikace (identifikace, popis a druh daň. zvýhodnění. Daň. zvýh. může být charakteru měsíční, měsíční s bonusem, roční a roční s bonusem. U každého daň. zvýhodnění se dále uvádí částka a příznak, zda se má tisknout tato hodnota na výplatním lístku)

¨ datum signalizace – signalizuje datum do kdy je možno dané daňové zvýhodnění uplatňovat (např. odpočet na dítě nebo na studenta). Výpočet mezd pak toto datum zachytí a v případě potřeby upozorní, že uživatel by měl změnit datum platnosti.


Definování typu kategorie pracovníků

Popis

Pro možnost použití palety barev kategorií pracovníků byly rozšířeny vlastnosti kategorie pracovníků o další atributy. Tyto atributy se nevstupují přímo ve formuláři „kategorie pracovníků“, ale pomocí činnosti „definování typu kategorie pracovníků“ (menu volby nebo klávesa F5) z tohoto formuláře.

Vzhledem k činnosti paleta barev byly rozšířeny vlastnosti kategorie pracovníků o tyto atributy:

¨ typ - překryvný seznam Vstupovaná/Vypočítaná

¨ SQL - memo pole - SQL výraz pro typ Vypočítaná

Stanovení příslušnosti pracovníka v kategorii podle typu:

¨ kategorie typu Vstupovaná - pracovník patří do kategorie, pokud má u sebe uveden záznam o zařazení do kategorie platný k aktuálnímu datu

¨ kategorie typu Vypočítaná - pracovník patří do kategorie, pokud vyhodnocení výrazu SQL vrátí hodnotu větší než 0. Tento výraz v syntaxi SQL Anywhere je vyhodnocován při zpracování SQL dotazu. Používají se v něm proměnné @mz01id (pracovník). Vyhodnocením výrazu musí být numerická hodnota.

¨ testovat – provede test zadaného SQL dotazu. Protože je výraz vyhodnocován uloženou procedurou až při zpracování SQL dotazu a není kompilován na straně klienta tak, jak je to v případě obecných výběrů, může chybně definovaný SQL výraz způsobovat to, že dotaz bude vracet žádný nebo menší počet záznamů než by měl bez nahlášení chyby.

Datový model

  • MZKARADD Kategorie pracovníka

    • Formulář

    Formulář činnosti - Karta pracovníka
Kategorie | Identifikace kategorie pracovníka
Název kategorie | Název kategorie pracovníka
Typ | Typ kategorie - Vstupovaná / Vypočítaná
SQL | Výraz v SQL vyhodnocovaný dotazem vracející numerickou hodnotu (0=není v kategoriii) použivá ID pracovníka @mz01id
Poznámka | Poznámka
Pracovník | Jednoznačná identifikace pracovníka

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Testovat SQL výraz |
F2 | Karta pracovníka | Karta pracovníka

    Viz.také

    Testovat SQL výraz | Karta pracovníka


Vztahy mezi pracovníky a osobami

Popis

Tato činnost představuje v podstatě číselník vztahů mezi pracovníky a osobami, který uživatel následně využívá v činnosti Vztahy k osobám. Definuje se:

¨ identifikace

¨ popis – např. vyživovaná osoba apod.

¨ předplňovat – Ano/Ne – právě tato volba je úzce napojena na činnost Vztahy k osobám. Pokud je zde nastaveno Ano, tak při zadání nové osoby v činnosti Vztahy k osobám se automaticky do její druhé záložky „významy vztahu“ předplní tato identifikace a popis vztahu. Pokud je zde nastaveno Ne, tak při zadání nové osoby v činnosti Vztahy k osobám se na druhé záložce „významy vztahu“ musí vztah naplnit ručně a zde nastavené identifikace se uživateli zobrazují jako překryvný seznam v atributu „význam“.

Datový model

  • MZVZTAHY Číselník možných vztahů mezi pracovníkem a osobou

    • Formulář

    Formulář činnosti - Druh události
Mřížka [Vztahy pracovník - osoba]
Identifikace | Identifikace vztahu
Popis | Popis vztahu
Předplňovat | Předplňovat do vazby pracovník - osoba. Ano/ne
Komentář | Komentář

    Mřížka [Vztahy pracovník - osoba] činnosti - Druh události

    Mřížka [Vztahy pracovník - osoba] činnosti - Druh události
Identifikace | Identifikace vztahu
Popis | Popis vztahu


Záložka exekuce (PA3)

Popis

Na záložku exekuce doporučujeme zadávat pohledávky přednostní či nepředností, s fixní měsíční splátkou či pohyblivou splátkou typu „tolik, kolik lze“. Datum doručení soudního rozhodnutí je povinný. Při uzávěrce mezd dojde k odečtení provedené splátky exekuce od zůstatku exekuce. Od zůstatku se odečte pouze taková částka, která byla skutečně sražena. Při tvorbě mzdových položek typu exekuce pečlivě volte první znak identifikace této mzdové položky. Podle identifikace se ve většině implementací třídí záznamy na výplatním lístku.

Zadávají se tyto údaje:

¨ identifikace mzdové položky (složitější nastavování, které by měl provádět pouze zkušený uživatel nebo implementátor)

¨ částka – celková exekuční částka

¨ zůstatek – exekuční částka k doplacení, její výši snižuje uzávěrka

¨ srážet – měsíční srážená exekuční částka (např. částka výživného)

¨ nedoplatek – slouží jenom pro účely výživného (jeho výši zvyšuje a snižuje uzávěrka)

¨ adresát – příjemce peněžních částek

¨ bankovní údaje příjemce

¨ typ – bankovní údaj (speciální bank.styk se spořitelnou)

¨ doručení – datum doručení exekučního rozhodnutí

¨ platnost záznamu od - do


Generace událostí mezd - UC podrobně org.sel.

Popis

Jedná se o programové šablony, které slouží pro vytváření událostí (i agregovaných) mezd z různých pohledů (např. z hlediska plateb, účetnictví, statistiky apod.).

Datový model

  • MZMZDY Mzda
    • MZMZDPOL Mzdová položka
      • MZDRUHUD Druh události

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Další informace - dílčí

Popis

Tuto činnost lze aktivovat vyvoláním pod menu Volby v činnosti Karta pracovníka na záložce Pracovní poměry. Uživateli se zobrazují další údaje k danému pracovníkovi. Jsou to:

¨ jméno pracovníka, číslo pracovního poměru, datum zahájení

¨ účast na nemocenském pojištění – zda pracovní poměr zakládá účast na nemocenském pojištění

¨ důvod ukončení p.p. – možnost zaznamenat důvod ukončení pracovního poměru

¨ počet dní nároku na roční dovolenou

¨ počet dní dovolené převedený z minulého roku

¨ kolik dnů se v případě potřeby má provést do příštího roku

¨ počet dnů, které tvoří zůstatek staré dovolené

¨ počet dnů, které tvoří zůstatek nové dovolené

Datový model

  • MZPRACPO Pracovní poměr

    • Formulář

    Formulář činnosti - Doplňující údaje k příjmům
Pracovník | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
Prac. poměr | Číslo pracovního poměru
 | Vznik prac. poměru
 | Skončení prac. poměru
Účast na n.p. | Zakládá pracovní poměr účast na nemocenském pojištění?
Vztah k pojistnému na soc. zabezp. | Vztah k pojistnému na sociální zabezpečení
Důvod ukončení p.p. | Důvod ukončení pracovního poměru
Volné datum I | Volně použitelné datum
Roční nárok na dovolenou | Roční nárok na dovolenou.
Zůstatek dovolené z minulého roku | Zůstatek dovolené z minulého roku
Převod dovolené do příštího roku | Převod dovolené do příštího roku
Zůstatek staré dovolené | Zůstatek staré dovolené
Zůstatek nové dovolené | Zůstatek nové dovolené


Záložka sociální pojišťovny (PA4)

Popis

Záložka sociální pojišťovny se použije pro definici pojišťovny zahraničního pracovníka. Pokud organizace zaměstnává cizince, potřebuje údaje o sociální pojišťovně pro zajištění správnosti výpočtu mezd.


Třídy KZAM

Popis

Jedná se o státem vytvořený číselník tříd KZAM (klasifikace zaměstnanosti). Tento číselník není součástí dodávky systému a uživatel si naplní pouze ty třídy, které při své práci běžně používá.

Datový model

  • MZKZAM Třída KZAM

    • Formulář

    Formulář činnosti - OZNAČOVÁNÍ
Mřížka [Třídy KZAM]
Identifikace | Identifikace třídy KZAM
Popis | Popis třídy KZAM
Komentář | Komentář

    Mřížka [Třídy KZAM] činnosti - OZNAČOVÁNÍ

    Mřížka [Třídy KZAM] činnosti - OZNAČOVÁNÍ
Identifikace | Identifikace třídy KZAM
Popis | Popis třídy KZAM


Další informace karty

Popis

Atributy v této činnosti vznikly na základě mzdové reformy r. 2008. Organizacím s touto reformou vzniká povinnost sledovat výši maximální vyměřovacího základu na zdravotní a sociální pojištění a výši limitu penzijního a životního připojištění. Hodnoty, kterých tyto atributy mohou podle zákona dosahovat jsou uvedeny v legislativních konstantách. V případě, že uživatel má na kartě uvedenu cizí sociální pojišťovnu, je zde odvedená částka napočítávána v měně uvedené u cizí pojišťovny.

Po každé provedené uzávěrce mezd se do těchto atributů přenesou částky těchto atributů z daného měsíce. V případě, že by např. během listopadové výplaty systém zjistil, že maximální hodnoty těchto atributů jsou již překročeny, bude toto hlášení (překročení limitu) zapsáno do protokolu výpočtu mezd.

Datový model

  • MZKARTA Pracovník

    • Formulář

    Formulář činnosti - Charakter vlastnosti
Pracovník | Jednoznačná identifikace pracovníka
 | Příjmení pracovníka
 | Jméno pracovníka
 | Titul pracovníka (před jménem)
ZP vyměř. základy nápočet | Nápočet dosavadních vyměřovacích základů ZP v aktuálním roce pro porovnání s maximálním vyměřovacím základem ZP.
SP vyměř. základy nápočet | Nápočet dosavadních vyměřovacích základů SP v aktuálním roce pro porovnání s maximálním vyměřovacím základem SP.
Penzij. a život. připojištění nápočet | Nápočet dosavadních příspěvků penzij. a život. pojištění v aktuálním roce pro porovnání s limitem připojištění.


Generace událostí - statistika jednotlivě

Popis

Programová šablona pro tvorbu událostí mezd.

Datový model

  • MZMZDY Mzda
    • MZMZDPOL Mzdová položka
      • MZDRUHUD Druh události
    • MZKARTA Pracovník (alias MZKARTA2)
      • MZZDRPOJ Zdravotní pojišťovny a jejich přidělení

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Mzdové položky použitelné jako roční

Datový model

  • MZMZDPOL Mzdová položka

    • Formulář

    Formulář činnosti - Technicko-věcný selektor
Mřížka [Mzd. položky]
Mzdová položka | Jednoznačná identifikace mzdové položky
 | Popis mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...

    Mřížka [Mzd. položky] činnosti - Technicko-věcný selektor

    Mřížka [Mzd. položky] činnosti - Technicko-věcný selektor
Identifikace | Jednoznačná identifikace mzdové položky
Popis | Popis mzdové položky
Druh | Druh položky - příjem, náhrada mzdy,...

    Atributy tisku

    Základní údaje
Mzdová položka | Jednoznačná identifikace mzdové položky | MZMZDPOL_mz28id | C(6)
Popis | Popis mzdové položky | MZMZDPOL_mz28mzdpol | C(40)
Druh | Druh položky - příjem, náhrada mzdy,... | Výpočet | C(17)


Naplnění prezentace hodnot

Popis

Naplnění prezentace hodnot převádí popis vyplývající z obsahu prezentace do formy potřebné pro zobrazení parametrů u předmětu projektu a je nutné ho udělat při každé změně.


Inicializace předmětu projektu

Popis

Tato činnost je dostupná z činnosti Předmět projektu po stisku klávesy F5 nebo aktivací dané činnosti z menu Volby. Inicializací předmětu projektu (PP) je vytvořen druh procesu podle prezentace uvedené u PP. Tento druh procesu musí být vytvořen tak, aby jeho startovací operací byla operace komponenty "hodnoty předmětu projektu". Obvykle budou na tuto operaci v daném navazovat uzly typu proces, pro zadání projektových úkolů a položek smluv spojených s daným PP.

Po inicializaci PP bude vytvořen nový fyzický proces, jehož strom bude dostupný ve formuláři "Předmět projektu" položkou menu nebo klávesou F6 a odtud bude možné snadno zakládat smlouvy a úkoly spojené s odpovídajícím PP.

PP je možné inicializovat na základě již některého existujícího PP. Přitom se uvádí v jaké příbuznosti je nově inicializovaný PP k existujícímu PP. Podle tohoto vztahu a nastavení atributů příbuznosti u parametru PP bude PP dědit výskyt parametru resp. výskyt hodnoty parametru (dědění je nastaveno vždy ve směru odshora dolů, tzn. že první příbuznost dědí vždy nejvíce, poslední uvedená příbuznost v překryvném seznamu nejméně). Kromě toho do procesu inicializace vstupují "hodnoty inicializace" definované v prezentaci PP (záložka Popis hodnoty inicializace). Tyto hodnoty se uplatní podle výrazů uvedených v parametrech PP.

Přidělení parametrů PP je možné před zapsáním inicializace ovlivnit na záložce "Výběr parametrů". Jsou zobrazeny dva seznamy. V levém seznamu jsou parametry, které je možné ještě do inicializace PP zařadit. V pravém jsou ty, které již byly zařazeny. V těchto seznamech jsou před názvy parametrů uvedeny znaky:

¨ # - parametr je nepovinný

¨ * - parametr již byl PP přidělen

¨ ??? - (v pravém panelu) parametr již byl PP přidělen, ale podle prezentace by být neměl

Inicializace proběhne podle rozhodnutí uživatele po ukončení formuláře inicializace klávesou ESC. Inicializaci PP je možné provádět opakovaně.

Datový model

  • NKINIPRE Inicializace předmětu projektu

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Předmět projektu | Seznam předmětů projektu

    Formulář

    Formulář činnosti - Předmět projektu
 | Identifikace druhu artiklu
Předmět | Identifikace artiklu
 | Verze projektu
 | Název artiklu
Příbuznost | Příbuznost předmětu pro dědění výskytů a hodnot parametrů při inicializaci
 | Identifikace druhu artiklu
Odvozený z | Identifikace artiklu
 | Verze projektu
 | Název artiklu
Listovací rámeček
Stránka #1 Hodnoty inicializace
@C1 | Parametr inicializace předmětu projektu - Seznam 1
@C2 | Parametr inicializace předmětu projektu - Seznam 2
@C3 | Parametr inicializace předmětu projektu - Seznam 3
@D1 | Parametr inicializace předmětu projektu - Datum 1
@T1 | Parametr inicializace předmětu projektu - Text 1
@N1 | Parametr inicializace předmětu projektu - Num 1
@D2 | Parametr inicializace předmětu projektu - Datum 2
@T2 | Parametr inicializace předmětu projektu - Text 2
@N2 | Parametr inicializace předmětu projektu - Num 2
@D3 | Parametr inicializace předmětu projektu - Datum 3
@T3 | Parametr inicializace předmětu projektu - Text 3
@N3 | Parametr inicializace předmětu projektu - Num 3
Stránka #2 Výběr parametrů
 | Seznam možných hodnot spojených s předmětem projektu
Tlačítko | Zařazení do seznamu inicilalizace
Tlačítko | Zařazení do seznamu inicilalizace
Tlačítko | Zařazení do seznamu inicilalizace
 | Seznam hodnot spojených s předmětem projektu

    Viz.také

    Druhy artiklů | Předmět projektu


Popis pravidla

Popis

Tato činnost se spustí po aktivaci daného pravidla z činnosti Popisy pravidel (menu Volby v činnosti Položky smluv). Jeho naplnění je určeno kombinací údajů, které jsou uvedeny na smlouvě, v plnění a v definici pravidla. Ve formuláři popisu se poté předplňuje kód poznámky uvedený v definici pravidla.

Datový model

  • NKDRUHPR Pravidlo smlouvy

    • Formulář

    Formulář činnosti - Měny a kursy
    Poznámka Poznámka


POPISY PRAVIDEL

Popis

Jedná se o činnost, která je pro uživatele dostupná pod menu Volby v činnosti „Položky smluv“. Poskytuje uživateli přehled nadefinovaných pravidel k jednotlivým smlouvám (menu O smlouvách – Nastavení smluv – Pravidla smluv).

Viz.také

Popis pravidla


Strom prezentace předmětu

Popis

Usnadňuje vytváření obsahu prezentace parametrů předmětu projektu. Pravým klikem na položce stromu je možné měnit obsah prezentace. Při provedené změně tímto způsobem se automaticky provádí "naplnění prezentace hodnot".

Formulář

Formulář činnosti - Algoritmus stanovení nem. dávky
Strom prezentace


Strom hodnot předmětu projektu

Popis

Lze vyvolat z činnosti Předměty projektu po stisku klávesy F9 nebo aktivací činnosti z menu Volby. Zobrazuje strom přidělených parametrů předmětu projektu podle prezentace PP a popisu parametrů. Dvojím klikem je možné vyvolat formulář, ve kterém je možné opravovat vlastní hodnoty odpovídajícího parametru.

Formulář

Formulář činnosti - Hodnota parametru předmětu
Hodnoty předmětu projektu

Viz.také

Hodnota parametru předmětu


Hodnota parametru předmětu

Popis

Je vyvolán po dvojím kliku na položce stromu předmětu projektu.

Umožňuje prohlížet a opravovat parametry jemu přidělené.

Datový model

  • NKHODNP Hodnota parametru předmětu projektu
    • NKPARDRU Umístění parametru předmětu projektu
      • SPPRISTU Přístupové právo uživatele k věci
    • NKPAR Parametr předmětu projektu
      • NKPRH Prezentovaná hodnota parametru
        • NKPAR Parametr předmětu projektu (alias NKPAR2)
          • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTU2)
    • NKCISHOD Hodnota číselníku hodnot parametru předmětu projektu
    • NKPREDPR Předmět projektu
      • SPARTIKN Název artiklu
    • BWUZIVAT Uživatel systému
    • ADSPOJ Spojení adresáta
      • ADADSAT Adresát (alias ADADSAT2)

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresář | Přehled adresátů
F2 | Měny a kursy | Číselník měn včetně jejich kursů
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Umístění parametrů př.projektu | Umístění parametrů předmětu projektu

    Formulář

    Formulář činnosti - Měny a kursy
Poznámka | Poznámka
 | Identifikace druhu artiklu
Předmět | Identifikace artiklu
 | Verze projektu
 | Název artiklu
Parametr | Identifikace parametru předmětu projektu
Název parametru | Název parametru předmětu projektu
Umístění | Identifikace umístění
 | Název umístění parametru
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
ID | Identifikace hodnoty
Datum 1 | Datumová položka 1 číselníku
Datum 2 | Datumová položka 2 číselníku
Text 1 | Textová položka 1 číselníku
Num 1 | Numerická položka 1 číselníku
Měna | Kód měny - oceňovací jednotky.
Num 2 | Numerická položka 2 číselníku
Výpočet | Výpočet

    Viz.také

    Adresář | Měny a kursy | Spojení adresátů | Umístění parametrů př.projektu


Reinicializace předmětů projek

Popis

Slouží k promítnutí změn v upravené prezentaci parametrů předmětu projektu (PP) do PP, které byly dříve danou prezentací inicializovány. Proces reinicializace je možné přerušit klávesou ESC a provedené změny jsou zapsány do protokolu v souboru HHPREIN.LOG v adresáři programu nebo podle parametru uvedeného parametrem HPP_PROT_ADRES v souboru BW.INI.


Zrušit inicializaci předmětu

Popis

Zruší přidělení parametrů k danému předmětu projektu.


Kopie popisu předmětu

Popis

Založí nový předmět projektu, který bude kopií aktuálně zobrazeného předmětu projektu.


Modifikace kódu pravidla

Popis

Po vyvolání klávesou F5 je možné zadávat kód pravidla v editoru Foxpro.


Modifikace kódu poznámky

Popis

Po vyvolání klávesou F6 je možné zadávat kód poznámky pravidla v editoru Foxpro.


Diagram projektového úkolu

Popis

Tuto činnost uživatel aktivuje stiskem klávesy F7 nebo příslušnou volbou z menu Volby v činnosti „projektové úkoly“. Diagram projektového úkolu je v podstatě grafické zobrazení průběhu projektového úkolu. Ovládání a chování diagramu projektového úkolu je shodné s klasickým diagramem procesu.


Předplnit kalendář

Popis

Tuto činnost má uživatel dostupnou pod menu Volby v činnosti „kalendáře řešitelů“ v okamžiku, kdy je aktivní záložka „dny v kalendáři“. Po její aktivaci se mu zobrazí formulář, kde zadává:

¨ den od – do

¨ dostupnost kapacity zdroje ke dni kalendáře a počet hodin (např. volba Ano – 8h, volba pracovní cesta – 10h apod.)

¨ zahrnout – které dny do kalendáře započítávat

Formulář

Formulář činnosti - Měny a kursy
Den | Den kalendáře
do | Den kalendáře do
Dostupnost | Dostupnost kapacity zdroje ke dni kalendáře
 | Změna kapacity zdroje v hodinách
Zahrnout | Zahrnout pondělky
Úterky | Zahrnout úterky
Středy | Zahrnout středy
Čtvrtky | Zahrnout čtvrtky
Pátky | Zahrnout pátky
Soboty | Zahrnout soboty
Neděle | Zahrnout neděle


Přepočet projektového úkolu

Popis

Tuto činnost si uživatel aktivuje po stisku F6 nebo spuštěním činnosti „přepočet projektového úkolu“ z menu Volby. Pro uživatele je tato činnost dostupná v ukončených operacích projektových úkolů a slouží zejména pro případ, že je nutno provést nějakou nečekanou a náhlou změnu v ukončeném projektu.

Datový model

  • NKUKOL Projektový úkol
    • NKUKDIAP Temporary pro výběr množiny projektových úkolů (alias NKUKDIAP3)
    • NKUKOLD Druh projektového úkolu
    • NKZDROJ Řešitel projektového úkolu
    • SPARTIKN Název artiklu
    • ADADSAT Adresát
    • SPPRCOD Operace procesu
      • SPTYP Druh procesu/operace
    • NKZDROJZ Zadavatel úkolu

    • Formulář

    Formulář činnosti - Pracovní místa skut. a typová
Mřížka [Plánované úkoly]
Stav | Stav projektového úkolu
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Název druhu operace
Stav | Stav projektového úkolu
Zahájení | Datum zahájení
Nové zahájení | Vypočtené datum zahájení
Dnů | Časová náročnost ve dnech
% | Procento plnění
Ukončení | Datum ukončení
Nové ukončení | Vypočtené datum ukončení
Popis | Popis úkolu
Druh | Identifikátor druhu úkolů
Název druhu úkolu | Název druhu úkolu
Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu
Jméno zadavatele | Jméno zadavatele projektového úkolu nebo plnění projektového úkolu
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Verze | Verze projektu
IDÚ úkolu | Identifikace datového úložiště úkolu
Poř. | Pořadí v rámci úkolů předmětu projektu
Název artiklu | Název artiklu
Adresát | Identifikace adresáta
 | Název adresáta
Poznámka | Poznámka k projektovému úkolu

    Mřížka [Plánované úkoly] činnosti - Pracovní místa skut. a typová

    Mřížka [Plánované úkoly] činnosti - Pracovní místa skut. a typová
Označování | Označení záznamu
Číslo | Číslo úkolu při přepočtu úkolu
Druh | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
IDÚ úkolu | Identifikace datového úložiště úkolu
Poř. | Pořadí v rámci úkolů předmětu projektu
Stav | Stav projektového úkolu
Zahájení | Datum zahájení
Nové zahájení | Vypočtené datum zahájení
Ukončení | Datum ukončení
Nové ukončení | Vypočtené datum ukončení
Popis | Popis úkolu
Název předmětu projektu | Název artiklu
Adresát | Identifikace adresáta
Název adresáta | Název adresáta
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Plán.náklady | Výše plánovaných nákladů
Real.náklady | Výše realizovaných nákladů
Aktualizace | Datum poslední aktualizace realizovaných nákladů
Typ | Typ úkolu - složený=je složen z více úkolů
Druh | Identifikátor druhu úkolů
Název druhu úkolu | Název druhu úkolu

    Atributy tisku

    Základní údaje
Rok | Rok v identifikaci procesu | NKUKOL_sp33cisdr | C(4)
IDÚ | Identifikace datového úložiště číselné řady procesu | NKUKOL_sp33cisdpm | C(2)
Číslo procesu | Pořadové číslo procesu | NKUKOL_sp33cisd | C(8)
Operace | Identifikátor druhu operace | NKUKOL_sp07idtyp | C(6)
Název druhu operace | Název druhu operace | SPTYP_sp07text | C(30)
Artikl | Identifikace artiklu | NKUKOL_sp60id | C(13)
Druh artiklu | Identifikace druhu artiklu | NKUKOL_sp61id | C(3)
Verze | Verze projektu | NKUKOL_nk01verze | C(3)
IDÚ úkolu | Identifikace datového úložiště úkolu | NKUKOL_nk43idu | C(2)
Poř. | Pořadí v rámci úkolů předmětu projektu | NKUKOL_nk43porad | C(6)
Název artiklu | Název artiklu | SPARTIKN_sp62artikl | C(60)
Druh | Identifikátor druhu úkolů | NKUKOL_nk53id | C(6)
Název druhu úkolu | Název druhu úkolu | NKUKOLD_nk53nazdru | C(40)
Řešitel | Identifikace řešitele | NKUKOL_nk44id | C(6)
Jméno řešitele | Jméno řešitele | NKZDROJ_nk44nazzdr | C(40)
Adresát | Identifikace adresáta | NKUKOL_ad01id | C(6)
Název adresáta | Název adresáta | ADADSAT_ad01adsat | C(100)
Číslo | Číslo úkolu při přepočtu úkolu | NKUKDIAP3_nk52cislo | N(5)
Stav | Stav projektového úkolu | Výpočet | C(11)
Zahájení | Datum zahájení | NKUKOL_nk43datz | D
Nové zahájení | Vypočtené datum zahájení | NKUKDIAP3_nk52datz | D
Dnů | Časová náročnost ve dnech | NKUKOL_nk43dennar | N(8,2)
% | Procento plnění | NKUKOL_nk43procpl | N(6,2)
Popis | Popis úkolu | NKUKOL_nk43text | C(40)
Ukončení | Datum ukončení | NKUKOL_nk43datu | D
Nové ukončení | Vypočtené datum ukončení | NKUKDIAP3_nk52datu | D
Plán.náklady | Výše plánovaných nákladů | NKUKOL_nk43nakpla | N(20,4)
Real.náklady | Výše realizovaných nákladů | NKUKOL_nk43nakrea | N(20,4)
Aktualizace | Datum poslední aktualizace realizovaných nákladů | NKUKOL_nk43datarn | D
Poznámka | Poznámka k projektovému úkolu | NKUKOL_nk43koment | M
Obch. sel. | Identifikátor obchodního selektoru | NKUKOL_sp10idzak | C(9)
Org. sel. | Identifikátor organizačního selektoru. | NKUKOL_sp11idzak | C(9)
Tech. sel. | Identifikátor technicko-věcného selektoru. | NKUKOL_sp20idzak | C(9)
Datum a čas zápisu | Datum a čas zápisu záznamu události | NKUKOL_sp00datzap | T
Stav | Stav projektu (uvažovaný, zahájený,...) | Výpočet | C(12)
Fixovat | Fixování - Ne,Zahájení,Ukončení - při plánování úkolu | Výpočet | C(8)
Zpráva při změně zahájení | Odeslat zprávu vedoucímu projektu při změně data zahájen | Výpočet | C(3)
Zpráva při změně ukončení | Odeslat zprávu vedoucímu projektu při změně data ukončení | Výpočet | C(3)


Aplikovat generický úkol

Popis

Činnost „aplikovat generický úkol“ představuje pro uživatele možnost jak si na základě jakési vytvořené osnovy (činnost generické projektové úkoly) předplnit jednotlivé projektové úkoly za vybraný předmět a vybraného adresáta. Tato činnost se aktivuje z události projektové úkoly (tzn. jedná se o procesní zpracování) a je pro uživatele k dispozici pod menu Volby.

V levé části formuláře se uživateli zobrazují nadefinované generické projektové úkoly, umístěním kurzoru na něj je v podstatě vybrán, ve spodní části formuláře se zadává druh a identifikace artiklu, verze projektu a adresát. V pravé části formuláře jsou k dispozici případné proměnné (nadefinované na záložce „proměnné“ v činnosti generické projektové úkoly).

Vyvolávané činnosti

K. | Činnost | Popis
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Předmět projektu | Seznam předmětů projektu

Formulář

Formulář činnosti - Adresář
 | Seznam možných hodnot spojených s předmětem projektu
Druh | Identifikace druhu artiklu
Předmět | Identifikace artiklu
Verze | Verze projektu
Název artiklu | Název artiklu
Adresát | Identifikace adresáta
 | Název adresáta
Zahájení | Datum zahájení úkolu
Řešitel 1 | Identifikace řešitele
Řešitel 2 | Identifikace řešitele
Řešitel 3 | Identifikace řešitele
Řešitel 4 | Identifikace řešitele
Datum 1 | Datumová položka 1
Datum 2 | Datumová položka 2
Datum 3 | Datumová položka 3
Num 3 | Numerická položka 1
Num 2 | Numerická položka 2
Num 3 | Numerická položka 3

Viz.také

Adresář | Druhy artiklů | Předmět projektu


Šablona - plnění proj. úkolu

Popis

Jedná se o šablonu, která uživateli usnadňuje naplnění projektových úkolů. Ve výběrové záložce je možno vyfiltrovat potřebné údaje (nejčastěji minimálně řešitele) a takto nadefinovaný výběr načíst. Uživateli se následně zobrazuje vyfiltrovaný přehled projektových úkolů.

Datový model

  • NKUKOL Projektový úkol
    • PAOBJDRU Klasifikace objektu
    • NKZDROJZ Zadavatel úkolu
    • NKZDROJ Řešitel projektového úkolu
    • ADADSAT Adresát
    • BWUZIVAT Uživatel systému
    • SPARTIKN Název artiklu
    • NKUKOLD Druh projektového úkolu
    • SPPRCOD Operace procesu
      • SPTYP Druh procesu/operace

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Import plnění úkolu | Import plnění úkolu
F6 | Strom hlavního procesu | Zobrazení hlavního stromu procesu-operace
F7 | Diagram procesu | Zobrazení diagramu procesu
F9 | Spustit operaci | Spuštění zobrazené operace
F2 | Adresář | Přehled adresátů
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Druhy plnění proj.úkolů | Druhy plnění projektových úkolů
F2 | Druhy projektových úkolů | Druhy projektových úkolů
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Klasifikace objektů | Klasifikace objektů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Předmět projektu | Seznam předmětů projektu
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Řešitelé projektových úkolů | Řešitelé projektových úkolů

    Formulář

    Formulář činnosti - Klasifikace objektů
Mřížka [Projektové úkoly]
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Název druhu operace
Stav | Stav projektového úkolu
Zahájení | Datum zahájení
Dnů | Časová náročnost ve dnech
% | Procento plnění
Ukončení | Datum ukončení
Popis | Popis úkolu
Druh | Identifikátor druhu úkolů
Název druhu úkolu | Název druhu úkolu
Řešitel | Identifikace řešitele
Jméno řešitele | Jméno řešitele
Druh artiklu | Identifikace druhu artiklu
Úkol | Identifikace artiklu
Verze | Verze projektu
IDÚ úkolu | Identifikace datového úložiště úkolu
Poř. | Pořadí v rámci úkolů předmětu projektu
Název artiklu | Název artiklu
Listovací rámeček
Stránka #1 Projektové úkoly
Adresát | Identifikace adresáta
 | Název adresáta
Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu
Jméno zadavatele | Jméno zadavatele projektového úkolu nebo plnění projektového úkolu
Klasif. | Identifikace klasifikace objektu
Název klasifikace objektu | Název klasifikace objektu
Sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Pozn. | Poznámka k projektovému úkolu
Stránka #2 Plnění úkolu
Mřížka [Plnění úkolu]
Adresát | Identifikace adresáta
 | Název adresáta
Pln.druh | Identifikace druhu plnění úkolu projektového řízení
Datum | Datum plnění projektového úkolu
Hodin | Čerpání času řešitele v hodinách
Popis | Popis plnění projektového úkolu
Pozn. | Poznámka k plnění projektového úkolu
Kateg. | Kategorie plnění projektového úkolu
% | Přírůstek procenta plnění
Sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Stránka #3 Výběr
Řešitel | Identifikace řešitele
Zahájení | Datum zahájení
do | Datum zahájení do
Ukončení | Datum ukončení
do | Datum ukončení do
Stav | Stav projektového úkolu
Typ | Typ úkolu - složený=je složen z více úkolů
Popis | Popis úkolu
Adresát | Identifikace adresáta
 | Název adresáta
Kategorie | Identifikace kategorie adresáta.
Druh artiklu | Identifikace druhu artiklu
Úkol | Identifikace artiklu
Verze | Verze projektu
IDÚ úkolu | Identifikace datového úložiště úkolu
Poř. | Pořadí v rámci úkolů předmětu projektu
Název artiklu | Název artiklu
Druh | Identifikátor druhu úkolů
Název druhu úkolu | Název druhu úkolu
Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu
Jméno zadavatele | Jméno zadavatele projektového úkolu nebo plnění projektového úkolu
Klasif. | Identifikace klasifikace objektu
Název klasifikace objektu | Název klasifikace objektu
Sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Zapsané | Identifikace uživatele systému
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Projektové úkoly] činnosti - Klasifikace objektů

    Mřížka [Projektové úkoly] činnosti - Klasifikace objektů
Zahájení | Datum zahájení
Název předmětu projektu | Název artiklu
Název druhu úkolu | Název druhu úkolu
Popis | Popis úkolu
Ukončení | Datum ukončení
Artikl | Identifikace artiklu
Druh artiklu | Identifikace druhu artiklu
IDÚ úkolu | Identifikace datového úložiště úkolu
Verze | Verze projektu
Poř. | Pořadí v rámci úkolů předmětu projektu
Druh | Identifikátor druhu úkolů
Jméno řešitele | Jméno řešitele
Typ | Typ úkolu - složený=je složen z více úkolů
Adresát | Identifikace adresáta
Název adresáta | Název adresáta

    Mřížka [Plnění úkolu] činnosti - Klasifikace objektů

    Mřížka [Plnění úkolu] činnosti - Klasifikace objektů
Datum | Datum plnění projektového úkolu
Popis | Popis plnění projektového úkolu
Hodin | Čerpání času řešitele v hodinách
Adresát | Identifikace adresáta
 | Název adresáta

    Viz.také

    Import plnění úkolu | Strom hlavního procesu | Diagram procesu | Spustit operaci | Adresář | Druhy artiklů | Druhy plnění proj.úkolů | Druhy projektových úkolů | Kategorie adresátů | Klasifikace objektů | Obchodní selektor | Organizační selektor | Předmět projektu | Technicko-věcný selektor | Řešitelé projektových úkolů


Import plnění úkolu

Popis

Definují se zde základní vlastnosti importu a to jsou:

¨ identifikace importu/exportu/update dat - jednoznačně identifikuje v rámci činnosti

¨ název importu/exportu/update dat

¨ druh - druh importu/exportu/update dat - je k němu možno nadefinovat přístupová práva (právo zápis - uživatel má povoleno vytvářet, právo čtení - uživatel má právo spouštět)

¨ spojení - definuje spojení s externím zdrojem dat. Druh spojení může být:

- ODBC

- XBASE

- Text (nemá význam pro export)

V definici spojení pro import/export dat je možné uvádět v atributu 'Spojení OS' znak *, což má stejný dopad, jako kdyby v něm byl uveden název ODBC spojení programu BM k databázi.

¨ import/export/update dat - určuje charakter definice

¨ atribut nabízet - při nastavení Ne nebude import nabízen při vyvolání pro spuštění po volbě z menu Obecné (není aktuální nebo je vyvoláván jiným způsobem např. procesním importem)

¨ selekt - obsahuje definici pro zpřístupnění zdrojových dat importu/update nebo dat do kterých bude exportováno.

¨ příkazy - příkazy v jazyce Foxpro provedené po exportu dat (nevyužívá se pro import a update)

¨ init - určuje příkaz vyvolaný ještě před zahájením importu. Předpokládá se použití některých činností, které vracejí v pracovním souboru seznam označených záznamů jako třeba adresář. V okamžiku vyvolání příkazu, je v proměnné "_o.wrk2" uloženo jméno dosud neexistujícího souboru, který bude vytvořen příkazem. V okamžiku vyvolání kódu popsaného v atributu "Selekt" importu je toto jméno dostupné "this.wrk2".

¨ Čas.id. - definuje výraz jehož hodnota bude vložena do jednoznačné časové identifikace objektu (má význam pouze při importu objektů). Jestliže při importu již existuje v tabulce záznam se stejnou časovou identifikací, potom není importován. Při update slouží tato definice jako výraz pro určení záznamu, který má být aktualizován.

Na záložce "proměnné importu-exportu" se definují proměnné, které může uživatel vstupovat před zahájením importu, exportu nebo update dat a proměnné, které jsou odvozené ze vstupovaných hodnot. Jednotlivé proměnné se definují stejným způsobem jako u obecných výběrů, šablon nebo volných karet. Za zmínku stojí atribut „naplnění“, který může nabývat těchto hodnot:

¨ vstup - hodnota proměnné je vstupována uživatelem

¨ výpočet - hodnota proměnné je odvozena podle hodnot proměnných definovaných s nižším pořadím. Hodnota proměnné je vyhodnocena na základě "Výrazu proměnné", který v sobě obsahuje odkazy na proměnné uvedené v hranatých závorkách. Používá se např. pro sestavení SQL dotazu s operátorem LIKE. Např.:

- proměnná v pořadí 10 je vstupována uživatelem, je znaková a má identifikátor FIRMA

- proměnná v pořadí 20 s identifikátorem FIRMA0 je vypočítávaná s hodnotou určenou výrazem TRIM([FIRMA])+'%'. Potom je možné v SQL dotazu zadat ..... ADADSAT.ad01adsat LIKE [FIRMA0] ...

Datový model

  • NKUKOLS Pracovní plnění projektového úkolu pro vstup šablonou
    • ADADSAT Adresát (alias ADADSAT2)

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Import/Export dat | Import/Export dat z/do externího zdroje
F2 | Adresář | Přehled adresátů
F2 | Druhy plnění proj.úkolů | Druhy plnění projektových úkolů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

    Formulář

    Formulář činnosti - Druhy plnění proj.úkolů
Mřížka [Plnění úkolu]
Druh | Identifikace druhu artiklu
Úkol | Identifikace artiklu
Verze | Verze projektu
IDÚ úkolu | Identifikace datového úložiště úkolu
Poř. | Pořadí v rámci úkolů předmětu projektu
Druh | Identifikátor druhu úkolů
Název druhu úkolu | Název druhu úkolu
Zadavatel | Identifikátor zadavatele úkolu nebo plnění úkolu
Jméno zadavatele | Jméno zadavatele projektového úkolu nebo plnění projektového úkolu
Zahájení | Datum zahájení
Popis | Popis úkolu
Ukončení | Datum ukončení
Pozn. | Poznámka k projektovému úkolu
Adresát | Identifikace adresáta
 | Název adresáta
Pln.druh | Identifikace druhu plnění úkolu projektového řízení
Datum | Datum plnění projektového úkolu
Hodin | Čerpání času řešitele v hodinách
Popis | Popis plnění projektového úkolu
Pozn. | Poznámka k plnění projektového úkolu
Kateg. | Kategorie plnění projektového úkolu
% | Přírůstek procenta plnění
Sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.

    Mřížka [Plnění úkolu] činnosti - Druhy plnění proj.úkolů

    Mřížka [Plnění úkolu] činnosti - Druhy plnění proj.úkolů
Označování | Označení záznamu
Datum | Datum plnění projektového úkolu
Popis | Popis plnění projektového úkolu
Hodin | Čerpání času řešitele v hodinách
Adresát | Identifikace adresáta
 | Název adresáta

    Viz.také

    Import/Export dat | Adresář | Druhy plnění proj.úkolů | Obchodní selektor | Organizační selektor | Technicko-věcný selektor


Zapsat změny harmonogramu

Popis

Podle nastavených údajů na záložce výběr (datum od – do, předmět, druh, zadavatel, řešitel, adresát apod.) se uživateli automaticky nabízí graficky zpracovaný harmonogram přehledu projektových úkolů. Při kliknutí na jakékoliv políčko v harmonogramu se uživateli nabízí podrobné informace k zadanému projektovému úkolu. Jednotlivé projektové úkoly lze v harmonogramu přesouvat (metoda „táhni a drž“). Zapsání změn se provede po stisku klávesy F5 (činnost „zapsat změny harmonogramu).


Změna stavu plnění úkolu

Popis

Tato činnost je pro uživatele dostupná v menu Volby v činnosti „Plnění projektového úkolu“. Umožňuje uživateli měnit stav plnění úkolu na stornovaný/nestornovaný (funguje v podstatě jako přepínač). Při aktivaci této činnosti na vybraném plnění projektového úkolu se systém dotazuje: „Změnit stav plnění úkolu na stornovaný? Ano/Ne“. V případě, že by uživatel změnil stav na stornovaný a během času zjistil, že se potřebuje vrátit zpět do původního stavu, znovu na tomto plnění aktivuje tuto činnost a změní stav plnění úkolu na nestornovaný.


Změna stavu hodnoty PP

Popis

Hodnoty předmětu projektu mohou nabývat stav aktuální nebo neaktuální. Možnost změnit stav (na kterýkoliv z nich) nabízí činnost „změna stavu hodnoty předmětu projektu“. Tuto činnost uživatel aktivuje v menu Volby v činnosti „Hodnoty předmětu projektu“.


Druhy katalogu zboží

Popis

Tato činnost slouží k definici druhů, pod kterými jsou definovány konkrétní katalogy.

K dispozici jsou tyto atributy:

· druh - identifikace druhu katalogu (musí být uvedeno) a název druhu katalogu (musí být uvedeno).

· poznámka - poznámka k druhu katalogu.

Datový model

  • OBKATALD Druh katalogu zboží obchodu
    • BWUZIVAT Uživatel systému

    • Formulář

    Formulář činnosti - Cenová období
Mřížka [Druhy katalogů]
Druh | Identifikace druhu katalogu
 | Název druhu kalalogu
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Poznámka | Poznámka k druhu katalogu

    Mřížka [Druhy katalogů] činnosti - Cenová období

    Mřížka [Druhy katalogů] činnosti - Cenová období
Druh | Identifikace druhu katalogu
Název druhu kalalogu | Název druhu kalalogu

    Atributy tisku

    Základní údaje
Druh | Identifikace druhu katalogu | OBKATALD_ob07id | C(6)
Název druhu kalalogu | Název druhu kalalogu | OBKATALD_ob07druhka | C(40)
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(17)
Datum a čas zápisu | Datum a čas zápisu záznamu události | OBKATALD_sp00datzap | T
Poznámka | Poznámka k druhu katalogu | OBKATALD_ob07koment | M


Výstup katalogu zboží

Popis

Činnost "výstup katalogu zboží" je podobná šabloně. Jedná se vlastně o šablonu pro vstup katalogů (souborů artiklů) do události obchodu. Vstupují se tyto atributy :

¨ druh - identifikace druhu katalogu (musí být uvedeno). Lze vybrat z překryvného seznamu.

¨ katalog - identifikace katalogu (musí být uvedeno). Lze vybrat z překryvného seznamu.

¨ datum - datum vystavení události obchodovatelného artiklu (musí být uvedeno).Datum dodání obchodovatelného artiklu (musí být uvedeno). Obě tyto data lze změnit kliknutím pravého tlačítka myši.

¨ popis - popis události o obchodovatelném artiklu (musí být uvedeno).

¨ adresát - identifikace adresáta (musí být uvedeno). Lze vybrat z adresáře klávesou F2. Číslo spojení adresáta (musí být uvedeno). Lze vybrat ze seznamu klávesou F2. Sám se doplní název adresáta.

¨ počet - počet (musí být větší než 0).

Formulář

Formulář činnosti - Spojení adresátů
Druh | Identifikace druhu katalogu
Katalog | Identifikace katalogu
Datum | Datum vystavení události obchodovatelného artiklu
Dodání | Datum dodání obchodovatelného artiklu
Popis | Popis události o obchodovatelném artiklu
Adresát | Identifikace adresáta
 | Název adresáta
 | Číslo spojení adresáta.
 | Ulice adresy adresáta (včetně čísla popisného).
 | Město adresy adresáta.
 | Poštovní směrovací číslo adresy adresáta.
 | Jméno kontaktní osoby.
Počet | Počet

Vyvolávané činnosti

K. | Činnost | Popis
F2 | Adresář | Přehled adresátů
F2 | Spojení adresátů | Přehled spojení adresátů

Viz.také

Adresář | Spojení adresátů


SUMy - obchod

Popis

Jedná se o zobrazení celkové částky na aktuálních událostech obchodu. Uživatel má dostupné hodnoty základ DPH, částku DPH a celkem v zahraniční i referenční měně. Pokud uživatel v událostech obchodu nepoužívá zahraniční měnu, jsou částky v zahraniční i referenční měně stejné. K dispozici je navíc částka jednotlivých daní a celkové množství v referenční měrné jednotce.

Tuto činnost si uživatel spustí přímo v menu Volby nebo po stisku funkčních kláves Ctrl + S.

Formulář

Formulář činnosti - Předplň účetní období
Základ DPH v ZM | Částka základu daně z přidané hodnoty v ZM - odpočet
DPH v ZM | Částka daně z přidané hodnoty v zahraniční měně - odpočet
Celkem v ZM
Základ DPH v RM | Částka základu daně z přidané hodnoty v referenční měně
Snížená v RM | Částka daně z přidané hodnoty v referenční měně 5%
Základní v RM | Částka daně z přidané hodnoty v referenční měně 22%
SUMA DPH v RM | Částka daně z přidané hodnoty v referenční měně
Celkem v RM
Celkové množství | Množství obchodovatelného artiklu
Celk. množ. v RMJ | Množství obchodovatelného artiklu v referenční měrné jednotce
Příjem | Částka základu daně z přidané hodnoty v zahraniční měně
 | Částka daně z přidané hodnoty v zahraniční měně
Výdej | Částka základu daně z přidané hodnoty v referenční měně
 | Částka daně z přidané hodnoty v referenční měně 5%
 | Částka daně z přidané hodnoty v referenční měně 22%
 | Částka daně z přidané hodnoty v referenční měně
 | Množství obchodovatelného artiklu
SUMA | Množství obchodovatelného artiklu v referenční měrné jednotce
Rozdíl
 | Částka základu daně z přidané hodnoty v referenční měně
 | Částka daně z přidané hodnoty v referenční měně 5%
 | Částka daně z přidané hodnoty v referenční měně 22%


Přepočet cen artiklů

Popis

Tato činnost je dostupná v cenových skupinách v menu Volby. Přepočet (čili aktualizace) spočívá v automatizovaném vygenerování nových záznamů ceníku nebo aktualizaci již existujících záznamů pro danou cenovou skupinu a cenové období pro maskou zadané artikly z již existujících příslušných záznamů v ceníku. Automatizace je dána definicí vzorce sestaveného z odkazů na cenové skupiny a aritmetických operací pro každý numerický atribut ceníku.

Např. máme v cenové skupině 001 a období 000 ceny, které chceme navýšit koeficientem 1.05 - potom výraz - artikl bude vypadat takto: [001]*1.05 ( 001 je nová skupina)

Formulář

Formulář činnosti - Cenová období
Cílová skupina | Identifikace cenové skupiny
 | Název cenové skupiny
Cílové období | Identifikace cenového období
 | Datum platnosti od
 | Název cenového období
Zdrojové období | Identifikace cenového období
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Výraz - artikl | Výraz pro výpočet ceny
Výraz - ost.nákl. | Výraz pro výpočet ceny
Výraz - sleva | Výraz pro výpočet ceny

Vyvolávané činnosti

K. | Činnost | Popis
F2 | Cílové cenové skupiny | Přehled cenových skupin obchodovatelného artiklu
F2 | Zdrojová cenová období | Výběr cenového období
F2 | Zdrojové cenové skupiny | Přehled cenových skupin obchodovatelného artiklu

Viz.také

Cenová období | Cenové skupiny


Cenová období

Popis

Cenová období umožňují uživateli prohlížet a definovat cenová období s počátečním a koncovým datem jejich platnosti. Platnost cenových období je systémem kontrolována, tzn. že nemůže dojít k překryvu jednotlivých cenových období.

Datový model

  • OBCENOBD Cenové období cenové skupiny obchodovatelného artiklu
    • BWUZIVAT Uživatel systému
    • OBCENSKP Cenová skupina obchodovatelného artiklu

    • Formulář

    Formulář činnosti - Druhy operací
Mřížka [Cenová období]
Skupina | Identifikace cenové skupiny
Název cenové skupiny | Název cenové skupiny
Poznámka | Poznámka k cenové skupině
Období | Identifikace cenového období
Název cenového období | Název cenového období
Datum platnosti od | Datum platnosti od
do | Datum platnosti do
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Poznámka | Poznámka k cenovému období

    Mřížka [Cenová období] činnosti - Druhy operací

    Mřížka [Cenová období] činnosti - Druhy operací
Skupina | Identifikace cenové skupiny
Období | Identifikace cenového období
Datum platnosti od | Datum platnosti od
Název cenového období | Název cenového období


Parametry operací - obchod

Popis

Tyto parametry má uživatel k dispozici v činnosti Druhy operací (menu Informační centrum - Typy a řady - Druhy operací) jako možnost pod menu Volby. Parametry se v současné době vstupují zatím pouze u druhů operací komponent obchod a platby. Jedná se o:

¨ automatické nastavení „stavu“ událostí v operaci daného druhu v případě, že po dané operaci následuje operace ze stejné komponenty (obvyklé použití v kombinaci s dávkovou operací , kde se nerespektuje míra plnění ) a zároveň se zde nastavuje i „stav“ událostí v případě, že následující operace po dané operaci změnila stav (tzn. byla zrušena, stornována).

¨ předběžné ukončení - operace s tímto atributem je ukončena předběžně. Do vlastností uzlu diagramu s touto operací (atribut ukončit operaci) se však tato hodnota nepředplní, tzn. je nutné ji definovat duplicitně.

¨ cenová skupina podle – tímto atributem se u daného druhu operace obchodu přiděluje cenová skupina, která se bude předplňovat při vstupu události obchodu. Je možno nastavit tři možnosti:

¨ nastavení BM – podle nastavení IS BM v činnosti Systém (v činnosti „nastavení programu BM“ – parametr cen_skp_podle_adresata)

¨ adresáta – určení cenové skupiny podle adresáta (u daného adresáta musí v adresáři být nastavena cenová skupina – klávesa F9 nebo menu Volby – Cenová skupina adresáta a zároveň musí artikl na dané události obchodu tuto cenovou skupinu mít nadefinovanou v ceníku)

¨ příjemce – určení cenové skupiny podle příjemce (stejný princip jako u možnosti výše)

Datový model

  • OBPAROPE Parametry komponenty obchod pro druh operace

    • Formulář

    Formulář činnosti - Předplň účetní období
Změna stavu události při vstupu navazující události obchodu | Změna stavu události při vstupu navazující události obchodu propojené mírou plnění
 | Stav události - neurčeno, nevykrytá objednávka, vykrytá objednávka
Změna stavu události při zrušení navazující události obchodu | Změna stavu události při zrušení navazující události obchodu propojené mírou plnění
 | Stav události - neurčeno, nevykrytá objednávka, vykrytá objednávka
Operaci ukončovat předběžně | Operaci ukončovat pouze předběžně
Cenová skupina podle | Přidělování cenové skupiny podle Nastavení BM/Adresáta/Příjemce události obchodu
Poznámka | Poznámka


Progr. šablona.- podklad pro

Popis

Programová šablona pro hromadné zařazení artiklů s nenulovým množstvím na zadaném skladu. Šablona zapíše všechny ty artikly ze zadaného skladu, jejichž stav na skladu v naturálním vyjádření je nenulový. Pro každý artikl se zapíše nulové množství.

Datový model

  • OBUDAL Událost obchodního plnění

    • Formulář

    Formulář činnosti - Předplň účetní období
Druh pohybu | Objednávka nebo DL přijatý/vydaný
Datum | Datum
do | Datum do
Umístění | Identifikace umístění obchodu - distribučního kanálu


Označení - obchod

Popis

Činnost je dostupná v událostech obchodu v menu Volby nebo po stisku klávesy F6. Jedná se o rozšířenou nabídku možnosti označování událostí obchodu. Pokud si chce uživatel vyfiltrovat události např. určitého adresáta, které vznikly za určitých, jím zadaných podmínek, použije tuto volbu.

Formulář

Formulář činnosti - Kategorie adresátů
Způsob vykrytí | Označit podle stavu na skladě
Nevykrývat | Nevykrývat zadaný artikl
Nepovinný artikl | Artikl, který nemusí být na skladě
P/V | Objednávka nebo DL přijatý/vydaný
 | Stav události - neurčeno, nevykrytá objednávka, vykrytá objednávka
Druh operace | Identifikátor druhu operace
Datum | Datum vystavení události obchodovatelného artiklu
do | Datum do
Dodání | Datum dodání obchodovatelného artiklu
do | Datum dodání obchodovatelného artiklu do
Sklad | Identifikace umístění skladové evidence
Selektory | Identifikátor obchodního selektoru
 | Identifikátor organizačního selektoru.
 | Identifikátor technicko-věcného selektoru.
Stav artiklu | Aktuální/ neaktuální
Výběr adresátů v kategorii | Identifikace kategorie adresáta.
 | Identifikace kategorie.
 | Identifikace kategorie.
Potlačení výběru adresátů v kategorii | Identifikace kategorie.
 | Identifikace kategorie.
 | Identifikace kategorie.
Počet označených adresátů | Počet označených adresátů (0 znamená bez omezení)
Volný výběr | Výběr uživatelsky definovaný
Aktuální hodnota plateb adresáta | Identifikace druhu hodnoty
 | Je menší nebo větší než
 | Aktuální hodnota
Odznačit dříve označené události | Odznačit dříve označené události obchodu
Uchovat | Příznak uchování výběrového hlediska

Vyvolávané činnosti

K. | Činnost | Popis
F5 | Definice výrazů označování | Definice výrazů označování
F2 | Druhy hodnot | Seznam druhů statistických informací
F2 | Druhy operací | Přehled druhů operací
F2 | Kategorie adresátů | Seznam kategorií adresátů a spojení adresátů
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Sklady | Seznam skladů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů

Viz.také

Definice výrazů označování | Druhy hodnot | Druhy operací | Kategorie adresátů | Obchodní selektor | Organizační selektor | Sklady | Technicko-věcný selektor


Progr.šabl. - nenulový sklad

Popis

Programová šablona pro hromadné zařazení artiklů s nenulovým množstvím na zadaném skladu. Šablona zapíše všechny artikly ze zadaného skladu, jejichž stav na skladu v naturálním vyjádření je nenulový. Pro každý artikl se zapíše jeho celkové množství na skladě.

Formulář

Formulář činnosti - Sklady
Sklad Identifikace umístění skladové evidence

Vyvolávané činnosti

K. | Činnost | Popis
F2 | Sklady | Seznam skladů

Viz.také

Sklady


Ukončit operaci nepředběžně

Popis

Tuto činnost uživatel využije v případě, že ukončuje operaci obchodu předběžně (vlastnost uzlu v diagramu procesu - "automaticky ukončit předběžně"). V takovém případě má tato operace stav "ukončena předběžně". Pokud jí uživatel chce ukončit standardně, tzn. aby měla ve vlastnostech stav "ukončena", aktivuje na operaci obchodu v menu Volby činnost "ukončit operaci nepředběžně".


Progr.šabl. - nenulové artikly

Popis

Programová šablona pro hromadné zařazení artiklů s nenulovým množstvím na zadaném skladu. Šablona zapíše všechny artikly ze zadaného skladu, jejichž stav na skladu v naturálním vyjádření je nenulový. Pro každý artikl se zapíše nulové množství.

Formulář

Formulář činnosti - Sklady
Sklad Identifikace umístění skladové evidence

Vyvolávané činnosti

K. | Činnost | Popis
F2 | Sklady | Seznam skladů

Viz.také

Sklady


Cenové skupiny adresáta

Popis

Tato činnost poskytuje uživateli přehled o nadefinovaných cenových skupinách daného adresáta a slouží pro předplnění cenových skupin adresáta v událostech obchodu. Aktivuje se z činnosti adresář po stisku klávesy F9 nebo spuštěním příslušné činnosti z menu Volby. K dispozici jsou tyto údaje:

¨ identifikace adresáta (je předplněna)

¨ číslo spojení adresáta

¨ skupina – cenová skupina

¨ OS – v případě, že to uživatel využívá, tak číslo obchodní smlouvy

¨ umístění – umístění obchodu (výběr z číselníku)

¨ artikl – zadaná maska technicko-věcného selektoru (může být zadán konkrétní, jeho část nebo vybrány všechny)

¨ % slevy

¨ výběr podle OS – volba Ano/Ne – souvisí s vyplněním atributu OS – pokud ho uživatel uvádí a následně chce cenovou skupinu s touto slevou uplatnit pro adresáta pouze u této smlouvy, ponechá volbu Ano

¨ priorita – implicitně předplněna hodnotou 5. V případě, že adresát je uveden v několika cenových skupinách, pak se do události obchodu předplní ta cenová skupina, které je zde uvedena priorita s nižším číslem.

Datový model

  • OBCENSAK AAA v cenové skupině
    • OBCENSKP Cenová skupina obchodovatelného artiklu
    • OBUMIST Umístění - distribuční kanál
    • ADSPOJ Spojení adresáta

    • Formulář

    Formulář činnosti - Spojení adresátů
Mřížka [Cenové skupiny adresáta]
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Název adresáta
Skupina | Identifikace cenové skupiny
 | Název cenové skupiny
OS | Číslo obchodní smlouvy
Umístění | Identifikace umístění obchodu - distribučního kanálu
 | Název umístění obchodu - distribučního kanálu
Artikl | Maska technicko-věcného selektoru artiklu
Sleva % | Sleva uvedená v procentech
Výběr podle OS | Výběr podle obchodní smlouvy
Priorita | Priorita výběru ceníkové položky

    Mřížka [Cenové skupiny adresáta] činnosti - Spojení adresátů

    Mřížka [Cenové skupiny adresáta] činnosti - Spojení adresátů
Skupina | Identifikace cenové skupiny
OS | Číslo obchodní smlouvy
Umístění | Identifikace umístění obchodu - distribučního kanálu
Spojení | Číslo spojení adresáta.
Priorita | Priorita výběru ceníkové položky
Artikl | Maska technicko-věcného selektoru artiklu
Sleva % | Sleva uvedená v procentech
Výběr podle OS | Výběr podle obchodní smlouvy

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Cenové skupiny | Přehled cenových skupin obchodovatelného artiklu
F2 | Spojení adresátů | Přehled spojení adresátů
F2 | Umístění - distr. kanál | Umístění - distribuční kanál

    Viz.také

    Cenové skupiny | Spojení adresátů | Umístění - distr. kanál


Hromadná změna slevy

Popis

Umožňuje změnit slevu ve všech událostech jedné operace jedním krokem najednou. Uživatel si určí, že chce změnit slevu na všech událostech na určené procento a nebo že na všech událostech chce změnit slevu o tolik a tolik procent směrem nahoru nebo dolů.

Formulář

Formulář činnosti - Sklady
Sleva % | Sleva uvedená v procentech
Způsob aktualizace | Způsob aktualizace slevy


Tabulka přechodů na měny

Popis

Tato činnost se využívá v případě, že dochází ke změně referenční měny. Tato situace by nastala např. v okamžiku, kdy by se přestala používat česká koruna a došlo by k celkovému přechodu na měnu EURO (tak jak tomu bylo nedávno na Slovensku). Pak je nutno nastavit datum platnosti OD nové měny a identifikaci nové měny, která bude od tohoto okamžiku nahrazovat měnu referenční.

Datový model

  • OCPREMEN Přechod na měnu
    • OCMENA Měna

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Měny a kursy | Číselník měn včetně jejich kursů

    Formulář

    Formulář činnosti - Měny a kursy
Mřížka [Datum přechodů na měny]
Dne | Datum přechodu na měnu
Do | Datum platnosti měny do
Měna | Kód měny - oceňovací jednotky.
 | Název měny

    Mřížka [Datum přechodů na měny] činnosti - Měny a kursy

    Mřížka [Datum přechodů na měny] činnosti - Měny a kursy
Dne | Datum přechodu na měnu
Do | Datum platnosti měny do
Měna | Kód měny - oceňovací jednotky.
Název měny | Název měny

    Viz.také

    Měny a kursy


Účetní odpisy

Popis

Problematika účetních odpisů je podrobně popsána ve slovníku pojmů (pojem „účetní odpis“) nebo v dokumentaci modulů Odpisovaný majetek.

Formulář

Formulář činnosti - Události DPH
Datum ke kterému se provede účetní odpis Datum, ke kterému se provede účetní odpis


Daňové odpisy

Popis

Problematika daňových odpisů je podrobně popsána ve slovníku pojmů (pojem „daňový odpis“) nebo v dokumentaci modulů Odpisovaný majetek.

Formulář

Formulář činnosti - Události DPH
Období Identifikace účetního období


UDÁLOSTI A KARTY ARTIKLU

Popis

Tuto činnost má uživatel dostupnou z menu Volby. Je možno vyvolat příslušné události a karty artiklu, které souvisí s daným (tzn. právě aktuálním) investičním majetkem.

Viz.také

Změny odpisovaného majetku | Změny spravovaného majetku | Rezervace majetku | Aktuální hodnoty odpis.maj. | Aktuální hodnoty sprav.maj. | Odpisovaný majetek | Spravovaný majetek | Karty pohledávek | Prognózování odpisů


Daňová změna pohledávek

Popis

Tuto činnost nelze zapisovat samostatně, ale pouze pomocí procesního zpracování a událost o této provedené změně uživatel najde v menu Odpisy a opravné položky pohledávek v činnosti "změny pohledávek".

Formulář

Formulář činnosti - Události DPH
Datum daňových změn pohledávek | Datum, ke kterému se provedou daňové změny pohledávek
Maximálně % | Maximální procento odpisu
Pouze rozpuštění odpisů a opravných položek | Pouze rozpuštění odpisů a opravných položek


Účetní změna pohledávek

Popis

Tuto činnost nelze zapisovat samostatně, ale pouze pomocí procesního zpracování a událost o této provedené změně uživatel najde v menu Odpisy a opravné položky pohledávek v činnosti "změny pohledávek".

Formulář

Formulář činnosti - Události DPH
Datum účetních změn pohledávek Datum, ke kterému se provedou účetní změny pohledávek


Daňová oprávka pohledávky

Popis

Tuto činnost nelze zapisovat samostatně, ale pouze pomocí procesního zpracování a událost o této provedené změně uživatel najde v menu Odpisy a opravné položky pohledávek v činnosti "změny pohledávek".

Formulář

Formulář činnosti - Události DPH
Rok ke kterému se provede daňová oprávka pohledávky Rok ke kterému se provede daňová oprávka pohledávky


Účetní oprávka pohledávek

Popis

Tuto činnost nelze zapisovat samostatně, ale pouze pomocí procesního zpracování a událost o této provedené změně uživatel najde v menu Odpisy a opravné položky pohledávek v činnosti "změny pohledávek".

Formulář

Formulář činnosti - Události DPH
Rok ke kterému se provede účetní oprávka pohledávky Rok ke kterému se provede účetní oprávka pohledávky


Suma

Popis

Tato činnost umožňuje uživateli pomocí klávesy Ctrl S vysčítat si sumu zobrazených událostí.

Formulář

Formulář činnosti - Události DPH
Účetní odpisy | Suma účetních odpisů
Daňové odpisy | Suma daňových odpisů
Suma částek | Suma všech částek


Import událostí odpisů

Popis

Programová šablona, která slouží pro ruční nastavení počátečních stavů karet odpisovaného majetku.

Formulář

Formulář činnosti - Odpisovaný majetek
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Datum prvního daňového odpisu | Datum prvního daňového odpisu
Datum prvního technického zhodnocení | Datum prvního technického zhodnocení
Datum posledního technického zhodnocení | Datum posledního technického zhodnocení

Vyvolávané činnosti

K. | Činnost | Popis
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Odpisovaný majetek | Seznam odpisovaného majetku

Viz.také

Druhy artiklů | Odpisovaný majetek


Zrušení příznaku změna platby

Popis

Uživatel tuto činnost použije pouze v případě, že nechce korektně rozpustit vytvořený odpis nebo opravnou položku k pohledávce, která byla uhrazena. Je to nestandardní činnost a uživatel by ji měl používat s rozmyslem a zcela výjimečně.


Snížení odpisů opravných položek

Popis

Umožňuje výpočet daňové změny pohledávky.

Datový model

  • ODKARTA Karta
    • PLPLOD Vazba mezi platbou a kartou odpisu,opravné položky aktiva
      • PLUDA Událost plateb

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


SUMY - obecná komponenta

Popis

Po stisku klávesy Ctrl S nebo volbě příslušné činnosti z menu Volby má uživatel možnost si nad vybranými událostmi obecné komponenty aktivovat SUMU. Zobrazí se mu celková cena příjmu a výdeje a celkové množství příjmu a výdeje.

Formulář

Formulář činnosti - Měrné jednotky
Celková cena -příjem | Celková cena -příjem
Celková cena - výdej | Celková cena - výdej
Celkové množství -příjem | Celkové množství -příjem
Celkové množství - výdej | Celkové množství - výdej


Obecné parametry

Popis

Tato činnost definuje parametry spojované s objekty IS BM (pomocí činnosti sady parametrů). U každého parametru se definuje nejprve záložka „obecné parametry“:

¨ identifikace a název

¨ druh – určuje práva přístupu k parametru

¨ číselník

¨ výraz – výraz zobrazení v mřížce

¨ perioda platnosti – inicializace data platnosti hodnoty parametru do – v měsících

Na záložce „elementární hodnoty“ se definuje:

¨ elementární hodnota – může být typu:

¨ datumová - 2 hodnoty - identifikace ##pa06dat1## a ##pa06dat2##

¨ numerická - 2 hodnoty - identifikace ##pa06num1## a ##pa06num2##

¨ textová - 1 hodnota - 60 znaků - identifikace ##pa06text1##

¨ seznam - 2 hodnoty - identifikace ##pa06cmb1## a ##pa06cmb2##

¨ adresát - 1 hodnota (včetně spojení adresáta a bankovního spojení) - identifikace ##ad01id## nebo ##ad01adsat##

¨ druh – určuje práva přístupu k elementární hodnotě

¨ texty uváděné v atributech elementární 'návěští' a 'stavový řádek' se uplatňují při vstupu hodnoty parametru ve formuláři.

¨ v atributu 'zobrazení' je vhodné pro elementární hodnoty typu seznam uvádět seznam hodnot oddělených čárkou.

¨ v atributu 'inicializace' se uvádí výraz v syntaxi SYBASE SQL Anywhere, který se uplatní při inicializaci parametru (např. pro datum - CURRENT DATE).

¨ výraz validace se uplatňuje při změně elementární hodnoty prováděné uživatelem (výraz musí být uveden ve formátu Foxpro).

V tomto výrazu je možné uvádět makro ###, které bude nahrazeno identifikátorem elementární hodnoty. Např. výrazy validace uvedené u elementární hodnoty pa06num1:

¨ ###>0

¨ pa06num1>0

mají stejný efekt.

Při konstrukci výrazu validace týkající se elementárních hodnot typu datum je třeba nezapomínat, že prázdné datum je v databázi ukládáno jako hodnota NULL. Bezpečný validační výraz respektující tuto skutečnost může být např.:

¨ !EMPTY(NVL(pa06dat1,{}))

¨ nebo NVL(pa06dat2,{})>NVL(pa06dat1,{})

Výraz uvedený na první záložce u popisu obecného parametru definuje výraz, jehož hodnota je zobrazovaná na mřížce při vstupu hodnoty parametru a při tisku. Výraz se uvádí v syntaxi Foxpro. Identifikátory jednotlivých elementárních hodnot parametru se ve výrazu uvádějí a ukončují znaky ## (proto, aby výraz fungoval při prohlížení dat i při tisku). Výsledkem vyhodnocení výrazu musí být hodnota legálního typu. Např. správně:

¨ ##pa06num1##

¨ ##pa06num2##

¨ ##pa06dat1##

¨ dtoc(##pa06dat1##)+' - '+dtoc(##pa06dat1##)

¨ TRIM(##ad01adsat##)+' - '+dtoc(##pa06dat1##)

Datový model

  • PAPARAM Parametr
    • PADRUPAR Druh algoritmu/parametru
      • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Editovat script
Mřížka [Obecné parametry]
Parametr | Identifikátor parametru
Název parametru | Název parametru
Listovací rámeček
Stránka #1 Obecné parametry
Druh | Identifikátoru druhu parametru
Název druhu | Název druhu parametru
Číselník | Identifikace číselníku
Název číselníku | Název číselníku
Výraz | Výraz zobrazení v mřížce
Perioda platnosti | Inicializace data platnosti hodnoty parametru do ve měsících
Poznámka | Poznámka
Stránka #2 Elementární hodnoty
Mřížka [Elementární hodnoty]
E.hodnota | Identifikace elementární hodnoty parametru
Druh | Identifikátoru druhu parametru
Název druhu | Název druhu parametru
Návěští | Návěští
Stav.ř. | Stavový řádek
Zobrazení | Zobrazení
Délka | Délka
Počet desetin | Počet desetin
Inicializace | Inicializace
Validace | Výraz validace
Hlášení | Chybové hlášení
F2-reakce | Identifikace činnosti

    Mřížka [Obecné parametry] činnosti - Editovat script

    Mřížka [Obecné parametry] činnosti - Editovat script
Parametr | Identifikátor parametru
Název parametru | Název parametru
Druh | Identifikátoru druhu parametru
Název druhu | Název druhu parametru

    Mřížka [Elementární hodnoty] činnosti - Editovat script

    Mřížka [Elementární hodnoty] činnosti - Editovat script
E.hodnota | Identifikace elementární hodnoty parametru
Návěští | Návěští
Stav.ř. | Stavový řádek

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Editovat script | Editovat script prováděný po vstupu elementární hodnoty
F9 | Položky obecného číselníku | Položky obecného číselníku
F2 | Druhy algoritmů a parametrů | Druhy obecných algoritmů a parametrů
F2 | Obecný číselník | Obecný číselník

    Atributy tisku

    Základní údaje
Parametr | Identifikátor parametru | PAPARAM_pa02id | C(6)
Název parametru | Název parametru | PAPARAM_pa02nazpar | C(40)
Druh | Identifikátoru druhu parametru | PAPARAM_pa03id | C(6)
Název druhu | Název druhu parametru | PADRUPAR_pa03nazdru | C(40)
Výraz | Výraz zobrazení v mřížce | PAPARAM_pa02vyraz | M
Perioda platnosti | Inicializace data platnosti hodnoty parametru do ve měsících | PAPARAM_pa02period | N(5)
Poznámka | Poznámka | PAPARAM_pa02koment | M
Název druhu | Název druhu parametru | PADRUPAR2_pa03nazdru | C(40)

    Při pohybu v Elementární hodnoty
E.hodnota | Identifikace elementární hodnoty parametru | PAPARELE_pa05id | C(10)
Druh | Identifikátoru druhu parametru | PAPARELE_pa03id | C(6)
Návěští | Návěští | PAPARELE_pa05label | M
Stav.ř. | Stavový řádek | PAPARELE_pa05status | M
Zobrazení | Zobrazení | PAPARELE_pa05pict | M
Délka | Délka | PAPARELE_pa05delka | N(3)
Počet desetin | Počet desetin | PAPARELE_pa05deseti | N(1)
Inicializace | Inicializace | PAPARELE_pa05init | M
Validace | Výraz validace | PAPARELE_pa05valid | M
Hlášení | Chybové hlášení | PAPARELE_pa05errmes | M

    Viz.také

    Editovat script | Položky obecného číselníku | Druhy algoritmů a parametrů | Obecný číselník


Hodnoty parametrů objektu

Popis

Tato činnost poskytuje uživateli komplexní přehled (je možnost ho pomocí záložky výběr specifikovat) o nadefinovaných obecných parametrech (které byly užity při definici sady parametrů). U každého parametru je k dispozici informace k jakému se váže objektu, jeho název, vlastní hodnota a platnost parametru (datum od – do).

V levé mřížce je zobrazen seznam sad hodnot parametrů, ve kterých existuje alespoň jeden parametru dostupný aktuálnímu uživateli s právem alespoň čtení.

V pravé mřížce je seznam hodnot obecných parametrů, které jsou automaticky k objektu připojovány při zařazení parametru do sady parametrů při uvedení výskytu 1:1 nebo 1:M.

Další hodnoty parametrů může uživatel vstupovat klávesou F3, po jejímž stisku uživatel vybírá parametry ze seznamu, ve kterém se nabízejí parametry, pro které platí:

¨ parametr je uveden v odpovídající sadě parametrů

¨ a zároveň - přístupové právo k parametru podle jeho druhu je pro uživatele 'zápis'

¨ a zároveň - neexistuje žádný záznam s daným parametrem s platností vyhovující aktuálnímu datu nebo je parametr v sadě uveden s výskytem 1:M nebo 0:M

Rušení hodnot parametrů klávesou F8 je povoleno:

¨ přístupové právo k parametru podle jeho druhu je pro uživatele 'zápis'

¨ a zároveň - parametr je v sadě uveden s výskytem 0:1 nebo 0:M

nebo

¨ přístupové právo k parametru podle jeho druhu je pro uživatele 'zápis'

¨ a zároveň - parametr je v sadě uveden s výskytem 1:1 nebo 1:M

¨ a zároveň - existuje jiný záznam o hodnotě daného parametru s platností vyhovující aktuálnímu datu

Při pohybu v seznamu hodnot parametrů se vzhled formuláře mění způsobem odpovídajícím popisu elementárních hodnot parametru.

Datový model

  • PAHODNOT Hodnota parametru
    • PAPARAM Parametr (alias PAPARAMPR)
      • PADRUPAR Druh algoritmu/parametru (alias PADRUPARPR)
        • SPPRISTU Přístupové právo uživatele k věci (alias SPPRISTUPR)
      • PASADPAR Parametr v sadě parametrů (alias PASADPARPR)
    • ADADSAT Adresát (alias ADADSATPR)
    • PACISPOL Položka obecného číselníku (alias PACISPOLPR)
    • SPARTIKL Artikl (alias SPARTIKLPR)
      • SPARTIKN Název artiklu (alias SPARTIKNPR)

    • Formulář

    Formulář činnosti - Artikl
Mřížka [Hodnoty parametrů]
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Identifikátor spojení na bankovní účet adresáta.
 | Název adresáta
ID | Identifikace položky číselníku
 | Název položky číselníku
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Text1 | Textová elementární hodnota
Dat1 | Datumová elementární hodnota 1
Dat2 | Datumová elementární hodnota 2
Num1 | Numerická elementární hodnota 1
Num2 | Numerická elementární hodnota 2
Cmb1 | Překryvný seznam elementární hodnota 1
Cmb2 | Překryvný seznam elementární hodnota 2
Poznámka | Poznámka
Platnost od | Platnost od
do | Platnost do

    Mřížka [Hodnoty parametrů] činnosti - Artikl

    Mřížka [Hodnoty parametrů] činnosti - Artikl
Název parametru | Název parametru
Hodnota parametru | Hodnota parametru
Platnost od | Platnost od
do | Platnost do

    Vyvolávané činnosti

    K. | Činnost | Popis
- | Sady parametrů | Sady parametrů
- | Obecné parametry | Obecné parametry
F2 | Adresář | Přehled adresátů
F2 | Artikl | Seznam artiklu
F2 | Bankovní spojení adresátů |
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Položky obecného číselníku | Položky obecného číselníku
F2 | Spojení adresátů | Přehled spojení adresátů

    Atributy tisku

    Základní údaje
Parametr | Identifikátor parametru | PAHODNOT_pa02id | C(6)
Název parametru | Název parametru | PAPARAMPR_pa02nazpar | C(40)
Hodnota parametru | Hodnota parametru | Výpočet | C(100)
Poznámka | Poznámka | PAHODNOT_pa06koment | M
Platnost od | Platnost od | PAHODNOT_pa06datum | D
do | Platnost do | PAHODNOT_pa06datumd | D
Adresát | Identifikace adresáta | PAHODNOT_ad01id | C(6)
Název adresáta | Název adresáta | ADADSATPR_ad01adsat | C(100)
IČO | Identifikační číslo organizace. | ADADSATPR_ad01ico | C(10)
DIČ | Daňové identifikační číslo adresáta. | ADADSATPR_ad01dico | C(16)
Rodné číslo | Rodné číslo adresáta | ADADSATPR_ad01rc | C(10)
Spojení | Číslo spojení adresáta. | PAHODNOT_ad11cisspo | C(2)
Jméno | Jméno kontaktní osoby. | ADSPOJPR_ad11jmeno | C(40)
Jméno na štítek | Jméno pracovníka na poštovní štítek | ADSPOJPR_ad11jmenop | C(100)
Telefon | Telefonní číslo | ADSPOJPR_ad11cislo | C(60)
Fax | Faxové číslo | ADSPOJPR_ad11fax | C(60)
Jiné | Jiné spojení adresáta | ADSPOJPR_ad11cisost | C(60)
Mobil | Číslo mobilního telefonu | ADSPOJPR_ad11mobil | C(60)
e-mail | E-mail spojení adresáta | ADSPOJPR_ad11email | C(60)
Účet | Identifikátor spojení na bankovní účet adresáta. | PAHODNOT_ad03cisban | C(2)
Kód banky | Kód banky | ADBUCTYPR_oc02idbank | C(4)
Pobočka | Název pobočky, která vede bankovní účet adresátovi. | ADBUCTYPR_ad03poboc | C(25)
Prefix ú. | Prefix bankovního účtu adresáta | ADBUCTYPR_ad03pructu | C(6)
Č. účtu | Číslo bankovního účtu adresáta. | ADBUCTYPR_ad03ucet | C(34)
Specifický symbol | Specifický symbol adresáta | ADBUCTYPR_ad03ssymb | C(10)
Měna | Kód měny - oceňovací jednotky. | ADBUCTYPR_oc01id | C(3)
Název ú. | Název účtu | ADBUCTYPR_ad03nauctu | C(20)
Text1 | Textová elementární hodnota | PAHODNOT_pa06text1 | C(60)
Identifikace položky číselníku | Identifikace položky číselníku | PAHODNOT_pa08id | C(10)
Název položky číselníku | Název položky číselníku | PACISPOLPR_pa08nazpol | C(40)
Druh artiklu | Identifikace druhu artiklu | PAHODNOT_sp61id | C(3)
Artikl | Identifikace artiklu | PAHODNOT_sp60id | C(13)
Název artiklu | Název artiklu | SPARTIKNPR_sp62artikl | C(60)
Num1 | Numerická elementární hodnota 1 | PAHODNOT_pa06num1 | N(20,4)
Num2 | Numerická elementární hodnota 2 | PAHODNOT_pa06num2 | N(20,4)
Dat1 | Datumová elementární hodnota 1 | PAHODNOT_pa06dat1 | D
Dat2 | Datumová elementární hodnota 2 | PAHODNOT_pa06dat2 | D
Cmb1 | Překryvný seznam elementární hodnota 1 | PAHODNOT_pa06cmb1 | N(1)
Cmb2 | Překryvný seznam elementární hodnota 2 | PAHODNOT_pa06cmb2 | N(1)
Oblast | Oblast sady parametrů | PAHODNOT_pa01oblast | C(2)

    Viz.také

    Sady parametrů | Obecné parametry | Adresář | Artikl | Bankovní spojení adresátů | Druhy artiklů | Položky obecného číselníku | Spojení adresátů


Položky obecného číselníku

Datový model

  • PACISPOL Položka obecného číselníku

    • Formulář

    Formulář činnosti - Kopie řádku
Mřížka [Položky obecného číselníku]
ID | Identifikace položky číselníku
Název položky číselníku | Název položky číselníku
Num1 | Pomocná numerická hodnota 1
Num2 | Pomocná numerická hodnota 2
Text 1 | Pomocná textová hodnota 1
Text 2 | Pomocná textová hodnota 2
Poznámka | Poznámka

    Mřížka [Položky obecného číselníku] činnosti - Kopie řádku

    Mřížka [Položky obecného číselníku] činnosti - Kopie řádku
ID | Identifikace položky číselníku
Název položky číselníku | Název položky číselníku

    Atributy tisku

    Základní údaje
ID | Identifikace položky číselníku | PACISPOL_pa08id | C(10)
Číselník | Identifikace číselníku | PACISPOL_pa07id | C(6)
Název položky číselníku | Název položky číselníku | PACISPOL_pa08nazpol | C(40)
Poznámka | Poznámka | PACISPOL_pa08koment | M


Editovat script

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Editovat kód algoritmu

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Zkouška spojení kódu

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Spuštění kódu algoritmu

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Certifikovat kod algoritmu

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Klasifikace objektů

Datový model

  • PAOBJDRU Klasifikace objektu
    • PASADA Sada parametrů

    • Formulář

    Formulář činnosti - Sady parametrů
Mřížka [Klasifikace objektů]
Klasifikace | Identifikace klasifikace objektu
Název klasifikace objektu | Název klasifikace objektu
Listovací rámeček
Stránka #1 Klasifikace objektů
Sada | Identifikátor sady parametrů
Název sady | Název sady parametrů
Platnost od | Datum platnosti od
do | Datum platnosti do
Poznámka | Poznámka
Stránka #2 Hodnoty klasifikace objektu
Mřížka [Hodnoty parametrů]
Adresát | Identifikace adresáta
 | Číslo spojení adresáta.
 | Identifikátor spojení na bankovní účet adresáta.
 | Název adresáta
ID | Identifikace položky číselníku
 | Název položky číselníku
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Text1 | Textová elementární hodnota
Dat1 | Datumová elementární hodnota 1
Dat2 | Datumová elementární hodnota 2
Num1 | Numerická elementární hodnota 1
Num2 | Numerická elementární hodnota 2
Cmb1 | Překryvný seznam elementární hodnota 1
Cmb2 | Překryvný seznam elementární hodnota 2
Poznámka | Poznámka
Platnost od | Platnost od
do | Platnost do
Stránka #3 Výběr
Klasifikace | Identifikace klasifikace objektu
Název klasifikace objektu | Název klasifikace objektu
Sada | Identifikátor sady parametrů
Platnost | Platnost - Platné i neplatné,Platné dnes,Neplatné dnes,Platné k datu,Neplatné k datu
 | Platnost nebo neplatnost k datu
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Klasifikace objektů] činnosti - Sady parametrů

    Mřížka [Klasifikace objektů] činnosti - Sady parametrů
Klasifikace | Identifikace klasifikace objektu
Název klasifikace objektu | Název klasifikace objektu
Sada | Identifikátor sady parametrů
Název sady | Název sady parametrů

    Mřížka [Hodnoty parametrů] činnosti - Sady parametrů

    Mřížka [Hodnoty parametrů] činnosti - Sady parametrů
Název parametru | Název parametru
Hodnota parametru | Hodnota parametru
Platnost od | Platnost od
do | Platnost do

    Vyvolávané činnosti

    K. | Činnost | Popis
- | Sady parametrů | Sady parametrů
F2 | Adresář | Přehled adresátů
F2 | Bankovní spojení adresátů |
F2 | Sady parametrů | Sady parametrů
F2 | Spojení adresátů | Přehled spojení adresátů

    Atributy tisku

    Základní údaje
Klasifikace | Identifikace klasifikace objektu | PAOBJDRU_pa13id | C(12)
Oblast | Oblast sady parametrů | PAOBJDRU_pa01oblast | C(2)
Sada | Identifikátor sady parametrů | PAOBJDRU_pa01id | C(6)
Název klasifikace objektu | Název klasifikace objektu | PAOBJDRU_pa13nazdru | C(40)
Platnost od | Datum platnosti od | PAOBJDRU_pa13datum | D
do | Datum platnosti do | PAOBJDRU_pa13datumd | D
Poznámka | Poznámka | PAOBJDRU_pa13koment | M
Název parametru | Název parametru | PAPARAMPR_pa02nazpar | C(40)
Název adresáta | Název adresáta | ADADSATPR_ad01adsat | C(100)
IČO | Identifikační číslo organizace. | ADADSATPR_ad01ico | C(10)
DIČ | Daňové identifikační číslo adresáta. | ADADSATPR_ad01dico | C(16)
Rodné číslo | Rodné číslo adresáta | ADADSATPR_ad01rc | C(10)
Jméno | Jméno kontaktní osoby. | ADSPOJPR_ad11jmeno | C(40)
Jméno na štítek | Jméno pracovníka na poštovní štítek | ADSPOJPR_ad11jmenop | C(100)
Telefon | Telefonní číslo | ADSPOJPR_ad11cislo | C(60)
Fax | Faxové číslo | ADSPOJPR_ad11fax | C(60)
Jiné | Jiné spojení adresáta | ADSPOJPR_ad11cisost | C(60)
Mobil | Číslo mobilního telefonu | ADSPOJPR_ad11mobil | C(60)
e-mail | E-mail spojení adresáta | ADSPOJPR_ad11email | C(60)
Kód banky | Kód banky | ADBUCTYPR_oc02idbank | C(4)
Pobočka | Název pobočky, která vede bankovní účet adresátovi. | ADBUCTYPR_ad03poboc | C(25)
Prefix ú. | Prefix bankovního účtu adresáta | ADBUCTYPR_ad03pructu | C(6)
Č. účtu | Číslo bankovního účtu adresáta. | ADBUCTYPR_ad03ucet | C(34)
Specifický symbol | Specifický symbol adresáta | ADBUCTYPR_ad03ssymb | C(10)
Měna | Kód měny - oceňovací jednotky. | ADBUCTYPR_oc01id | C(3)
Název ú. | Název účtu | ADBUCTYPR_ad03nauctu | C(20)
Název položky číselníku | Název položky číselníku | PACISPOLPR_pa08nazpol | C(40)
Název artiklu | Název artiklu | SPARTIKNPR_sp62artikl | C(60)

    Při pohybu v Hodnoty parametrů
Parametr | Identifikátor parametru | PAHODNOT_pa02id | C(6)
Hodnota parametru | Hodnota parametru | Výpočet | C(100)
Poznámka | Poznámka | PAHODNOT_pa06koment | M
Platnost od | Platnost od | PAHODNOT_pa06datum | D
do | Platnost do | PAHODNOT_pa06datumd | D
Adresát | Identifikace adresáta | PAHODNOT_ad01id | C(6)
Spojení | Číslo spojení adresáta. | PAHODNOT_ad11cisspo | C(2)
Účet | Identifikátor spojení na bankovní účet adresáta. | PAHODNOT_ad03cisban | C(2)
Text1 | Textová elementární hodnota | PAHODNOT_pa06text1 | C(60)
Identifikace položky číselníku | Identifikace položky číselníku | PAHODNOT_pa08id | C(10)
Druh artiklu | Identifikace druhu artiklu | PAHODNOT_sp61id | C(3)
Artikl | Identifikace artiklu | PAHODNOT_sp60id | C(13)
Num1 | Numerická elementární hodnota 1 | PAHODNOT_pa06num1 | N(20,4)
Num2 | Numerická elementární hodnota 2 | PAHODNOT_pa06num2 | N(20,4)
Dat1 | Datumová elementární hodnota 1 | PAHODNOT_pa06dat1 | D
Dat2 | Datumová elementární hodnota 2 | PAHODNOT_pa06dat2 | D
Cmb1 | Překryvný seznam elementární hodnota 1 | PAHODNOT_pa06cmb1 | N(1)
Cmb2 | Překryvný seznam elementární hodnota 2 | PAHODNOT_pa06cmb2 | N(1)
Oblast | Oblast sady parametrů | PAHODNOT_pa01oblast | C(2)

    Viz.také

    Adresář | Bankovní spojení adresátů | Sady parametrů | Spojení adresátů


Popis pro zobrazení v přehledu hodnot

Datový model

  • PAHODDEF Popis pro zobrazení v přehledu hodnot

    • Formulář

    Formulář činnosti - OZNAČOVÁNÍ
Mřížka [Popis pro zobrazení]
Oblast | Oblast sady parametrů
Popis | Popis pro zobrazení v přehledu hodnot
Výraz identifikace | Výraz pro zobrazení identifikace objektu v syntaxi SQL Anywhere
Výraz popisu | Výraz pro zobrazení popisu objektu v syntaxi SQL Anywhere
Výraz poznámky | Výraz pro zobrazení poznámky objektu v syntaxi SQL Anywhere
Poznámka | Poznámka

    Mřížka [Popis pro zobrazení] činnosti - OZNAČOVÁNÍ

    Mřížka [Popis pro zobrazení] činnosti - OZNAČOVÁNÍ
Oblast | Oblast sady parametrů
Popis | Popis pro zobrazení v přehledu hodnot

    Atributy tisku

    Základní údaje
Oblast | Oblast sady parametrů | PAHODDEF_pa01oblast | C(2)
Popis | Popis pro zobrazení v přehledu hodnot | PAHODDEF_pa15nazpop | C(40)
Výraz identifikace | Výraz pro zobrazení identifikace objektu v syntaxi SQL Anywhere | PAHODDEF_pa15defide | M
Výraz popisu | Výraz pro zobrazení popisu objektu v syntaxi SQL Anywhere | PAHODDEF_pa15deftxt | M
Výraz poznámky | Výraz pro zobrazení poznámky objektu v syntaxi SQL Anywhere | PAHODDEF_pa15defmem | M
Poznámka | Poznámka | PAHODDEF_pa15koment | M


Spustit sadu funkcí

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Export příkazu k úhradě

Popis

Funkce Export příkazu k úhradě umožňuje export příkazu pro elektronický styk s bankou. Tato funkce je přístupna teprve po uzavření příkazu k úhradě.


Uzavřít příkaz

Popis

Funkce Uzavřít příkaz (klávesa F6) uzavře příkaz k úhradě. Atribut Uzavřený příkaz k úhradě bude zaškrtnut a uživatel již nebude moci cokoliv v tomto příkazu měnit, či jej smazat.

V každém případě by příznak "uzavřeného příkazu" měl mít zatržen příkaz, který již byl odeslán do banky, v takovém příkazu není vhodné již měnit žádné atributy.


SUMy - Platby

Popis

Umožňuje uživateli sečíst si aktuálně zobrazené události plateb. Sumu je možno vyvolat po stisku klávesy Ctrl S nebo volbou příslušné činnosti v menu Volby.

Formulář

Formulář činnosti - Odpisovaný majetek
Částka v ZM (nezaok.) | Částka v zahraniční měně nezaokrouhlená
Částka v ZM | Částka v zahraniční měně
Záloha v ZM | Záloha v zahraniční měně
Částka v RM (nezaok.) | Částka v referenční měně nezaokrouhlená
Částka v RM | Částka v referenční měně zaokrouhlená
Záloha v RM | Záloha v referenční měně
Dosud uhrazeno | Dosud uhrazeno (v referenční měně)
Dosud neuhrazeno RM | Dosud neuhrazeno (v referenční měně)
Pohledávka | Částka v zahraniční měně nezaokrouhlená - závazek
Závazek | Částka v zahraniční měně - závazek
Rozdíl | Záloha v zahraniční měně - závazek
SUMA | Částka v referenční měně nezaokrouhlená - závazek
 | Částka v referenční měně zaokrouhlená - závazek
 | Záloha v referenční měně - závazek
 | Dosud uhrazeno (v referenční měně) - závazek
 | Dosud neuhrazeno (v referenční měně) - závazek
 | Částka v zahraniční měně nezaokrouhlená - rozdíl
 | Částka v zahraniční měně - rozdíl
 | Záloha v zahraniční měně - rozdíl
 | Částka v referenční měně nezaokrouhlená - rozdíl
 | Částka v referenční měně zaokrouhlená - rozdíl
 | Záloha v referenční měně - rozdíl
 | Dosud uhrazeno (v referenční měně) - rozdíl
 | Dosud neuhrazeno (v referenční měně) - rozdíl


Parametry operací plateb

Popis

Tyto parametry má uživatel k dispozici v činnosti Druhy operací (menu Informační centrum - Typy a řady - Druhy operací) jako možnost pod menu Volby. Parametry se v současné době vstupují zatím pouze u druhů operací komponent obchod a platby.

Jedná se o:

¨ validace variabilního symbolu - Ne způsobí, že se variabilní symbol přijatých faktur vůbec kontrolovat nebude. Ano znamená, že systém nahlásí, pokud najde platbu se stejným variabilním symbolem. Ano stejného adresáta znamená, že systém nahlásí, že našel platbu se shodným variabilním symbolem, pokud se zároveň budou shodovat adresáti plateb. Podle parametrů plateb znamená, kontrola se bude provádět podle nastavení ekvivalentního parametru operace komponenty plateb (druhy operací, v menu Volby Parametry operace komponenty). Tato volba umožňuje nastavit chování BM při zápisu události (závazku) operace daného druhu z hlediska kontroly duplicity variabilního symbolu.

¨ automatické nastavení „stavu“ událostí v operaci daného druhu v případě, že po dané operaci následuje operace ze stejné komponenty (obvyklé použití v kombinaci s dávkovou operací, kde se nerespektuje míra plnění a zároveň se zde nastavuje i „stav“ událostí v případě, že následující operace po dané operaci změnila stav (tzn. byla zrušena, stornována).

¨ operaci ukončovat předběžně – volba Ano/Ne. Operace s tímto atributem je ukončena předběžně. Do vlastností uzlu diagramu s touto operací (atribut ukončit operaci) se však tato hodnota nepředplní, tj. je nutné ji definovat duplicitně.

¨ povolit zařazení platby neuk. operace na příkaz k úhradě – volba Ano/Ne. Pokud je zatrženo Ano je možno na vytvářený příkaz k úhradě zařadit tento druh operace platby i ve stavu neukončena (tzn. stav zahájena).

Datový model

  • PLPAROPE Parametry komponenty platby pro druh operace

    • Formulář

    Formulář činnosti - Odpisovaný majetek
Validace variabilního symbolu | Provádět validaci existence závazku se stejným variabilním symbolem
Změna stavu události při vstupu navazující události plateb | Změna stavu události při vstupu navazující události plateb propojené mírou plnění
 | Kategorie předepsané platby
Změna stavu události při zrušení navazující události plateb | Změna stavu události při zrušení navazující události plateb propojené mírou plnění
 | Kategorie předepsané platby
Povolit zařazení platby neuk.operace na příkaz k úhradě | Povolit zařazení platby neukončené operace na příkaz k úhradě
Poznámka | Poznámka


Zrušit uzavření příkazu

Popis

Tato činnost (pro uživatele dostupná v menu Volby) umožní zrušit příznak "uzavření příkazu". Do uzavřeného příkazu není možno vstupovat ani ho opravovat, v případě potřeby (ještě před skutečným odesláním příkazu) je možno si takto uzavřený příkaz ještě znovu otevřít, opravit potřebné a příkaz znovu zavřít.


Změna bankovního spojení

Popis

Umožňuje u zobrazených událostí plateb změnit identifikaci bankovního spojení. V případě potřeby změny bankovního spojení je vhodné mít vyfiltrované události pouze za shodného adresáta, jinak systém hlásí chybu, že se jedná o změnu bank. spojení u rozdílných adresátů.

Formulář

Formulář činnosti - Odpisovaný majetek
Adresát | Identifikace adresáta
Nový účet | Identifikátor spojení na bankovní účet adresáta.


INFORMACE O VARIABILNÍM SYMBOLU

Popis

Tuto činnost má uživatel dostupnou v událostech plateb pod menu Volby. Poskytuje uživateli přehled o tom, co se dělo s daným variabilním symbolem na dané události. K dispozici má dvě možnosti, které se mu automaticky nabízejí:

¨ události plateb – po aktivaci této činnosti se mu zobrazí výběrová záložka událostí plateb s předplněným adresátem a variabilním symbolem platby, ze které byla tato činnost vyvolána

¨ události změny stavu peněz - po aktivaci této činnosti se mu zobrazí výběrová záložka událostí změny stavu s předplněným adresátem a variabilním symbolem platby, ze které byla tato činnost vyvolána

Viz.také

Události plateb | Události změny stavu peněz


Vyřizuje

Popis

Tato činnost umožňuje uživateli určit pracovníka, který danou poštovní zásilku vyřizuje. V podstatě tato činnost zajišťuje, že za určitou zásilku je tímto zodpovědný určitý pracovník.

Formulář

Formulář činnosti - Zaměnit vazby na původního
Vyřizuje Identifikace uživatele systému


Odeslání pošty

Popis

Tato funkce se aktivuje stiskem klávesy F9 nebo pomocí činnosti „odeslání pošty“ pod menu Volby v činnosti Pošta. U zobrazených událostí pošty změní příznak z "k odeslání" na "odeslaná" a současně je aktuálním systémovým datem naplněn atribut datum odeslání (tento atribut je dostupný pouze formou implementačních rozšíření, např. volná karta, předlohy výstupu, ...).


SUMy

Popis

Tuto činnost lze vyvolat pomocí klávesy Ctrl S nebo volbou příslušné činnosti v menu Volby nad událostmi pošty. Po aktivaci této činnosti systém vyčíslí sumu zobrazených událostí za jednotlivé atributy a to:

· hmotnost zásilky

· hodnota zásilky

· cena zásilky

· cena obsahu

Formulář

Formulář činnosti - Zaměnit vazby na původního
Hmotnost zásilky | Hmotnost zásilky v gramech
Hodnota zásilky | Uvedená hodnota zásilky v Kč
Cena zásilky | Cena zásilky, platba přepravní organizaci
Cena obsahu | Skutečná cena obsahu zásilky


INFORMACE O ŘÍZENÍ

Popis

Jedná o položku skupinového menu dostupnou v činnosti „Řízení – pozemky“ pod menu Volby. K dispozici jsou následující informace o konkrétním (tj. aktuálním) řízení:

¨ řízení pozemky

¨ nemovitosti

¨ listiny – pozemky

¨ listy vlastnictví

¨ BM Topol

Viz.také

Řízení - pozemky | Nemovitosti | Listiny - pozemky | Listy vlastnictví | BMTopol

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


INFORMACE O NEMOVITOSTI

Popis

Jedná o položku skupinového menu dostupnou v činnosti „Nemovitosti“ pod menu Volby. K dispozici jsou následující informace o konkrétní (tj. aktuální) nemovitosti:

¨ nemovitosti

¨ jiné právní vztahy

¨ listiny – pozemky

¨ listy vlastnictví

¨ řízení - pozemky

¨ BM Topol

Viz.také

Nemovitosti | Jiné právní vztahy | Listiny - pozemky | Listy vlastnictví | Řízení - pozemky | BMTopol

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


INFORMACE O JPV

Popis

Jedná o položku skupinového menu dostupnou v činnosti „Jiné právní vztahy“ pod menu Volby. K dispozici jsou následující informace o konkrétním (tj. aktuálním) jiném právním vztahu:

¨ jiné právní vztahy

¨ listiny – pozemky

¨ listy vlastnictví

¨ BM Topol

Viz.také

Jiné právní vztahy | Listiny - pozemky | Listy vlastnictví | BMTopol

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


INFORMACE O LISTU VLASTNICTVÍ

Popis

Jedná o položku skupinového menu dostupnou v činnosti „Listy vlastnictví“ pod menu Volby. K dispozici jsou následující informace o konkrétním (tj. aktuálním) listu vlastnictví:

¨ listy vlastnictví

¨ nemovitosti

¨ jiné právní vztahy

¨ BM Topol

Viz.také

Listy vlastnictví | Nemovitosti | Jiné právní vztahy | BMTopol

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Přepočet stavu nemovitostí

Popis

Vlivem různých událostí (procesně vytvořených) dochází ke změně stavu nemovitostí. Aby uživatel měl stav nemovitostí vždy v aktuálním stavu, má k dispozici činnost „přepočet stavu nemovitostí“. Tuto činnost aktivuje z činnosti stavy nemovitostí po stisku klávesy F6 nebo volbou příslušné činnosti z menu Volby.

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


SQL dotazy pro BMTopol

Popis

Tato činnost poskytuje uživateli přehled jednotlivých nadefinovaných SQL dotazů pro BM Topol. U každého SQL dotazu se definuje identifikace, jeho typ a vlastní SQL dotaz. Tato činnost je poměrně technicky náročná, takže se nepředpokládá, že by ji uživatel definoval sám bez pomoci zkušeného implementátora.

Datový model

  • PYTOPSQL SQL dotaz pro zobrazení v topolu

    • Formulář

    Formulář činnosti - Test SQL dotazu
Mřížka [SQL dotazy]
ID | Identifikace dotazu SQL
Popis | Popis SQL dotazu
SQL | SQL dotaz
Typ | Typ SQL dotazu
Poznámka | Poznámka
Aktualizace | Datum aktualizace

    Mřížka [SQL dotazy] činnosti - Test SQL dotazu

    Mřížka [SQL dotazy] činnosti - Test SQL dotazu
Typ | Typ SQL dotazu
ID | Identifikace dotazu SQL
Popis | Popis SQL dotazu

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Test SQL dotazu |

    Atributy tisku

    Základní údaje
ID | Identifikace dotazu SQL | PYTOPSQL_py35id | C(6)
Popis | Popis SQL dotazu | PYTOPSQL_py35popis | C(40)
Typ | Typ SQL dotazu | Výpočet | C(7)
SQL | SQL dotaz | PYTOPSQL_py35sql | M
Poznámka | Poznámka | PYTOPSQL_py35koment | M
Aktualizace | Datum aktualizace | PYTOPSQL_sp00datakt | T

    Viz.také

    Test SQL dotazu

    © 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Test SQL dotazu

Popis

Tato činnost se aktivuje stiskem klávesy F5 z činnosti „SQL dotazy pro BM Topol“. Provede se test aktuálního SQL dotazu a zobrazí se data, která definuje daný SQL dotaz. V případě nesrovnalostí systém zobrazuje chybové hlášení.

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Export výsledků SQL dotazu

Popis

Provede se export výsledků SQL dotazu a uloží se do uživatelem určeného místa.

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Potvrzení zprávy

Popis

Tato činnost poskytuje uživateli možnost potvrdit vybranou zprávu a změnit tím její stav na zpracovanou.

Pro uživatele existují tři varianty, jakým způsobem lze potvrdit zprávu:

¨ dvojitým stiskem levého tlačítka myši přímo na sloupečku "zápis" nebo "stav zpracování zprávy" (tato metoda je nejrychlejší a snadno přístupná)

¨ stiskem klávesy F7

¨ výběrem funkce "potvrzení zprávy" přímo z menu Volby

Systém se potom dotazuje: "Považujete zprávu ..... za zpracovanou? Ano/Ne". Po potvrzení volby Ano se položka "zpracování" vyplní aktuálním datem a stav zpracování zprávy má příznak "+" (zelená barva).


Přijetí zprávy

Popis

Tato činnost poskytuje uživateli možnost přijmout vybranou zprávu a změnit tím její stav na přijatou.

Pro uživatele existují tři varianty, jakým způsobem lze přijmout zprávu:

¨ dvojitým stiskem levého tlačítka myši přímo na sloupečku "zápis" nebo "stav zpracování zprávy" (nejsnadnější a zároveň nejrychlejší metoda)

¨ klávesou F6

¨ výběrem funkce "přijetí zprávy" přímo z menu Volby

Systém se potom dotazuje: "Skutečně přijímáte zprávu ..... ? Ano/Ne". Po potvrzení volby Ano se položka "přijetí" vyplní aktuálním datem a stav zpracování zprávy má příznak "#" (modrá barva).


Výběr uživatelů pro zápis

Popis

Uživatel má možnost odeslat zprávu nebo zapsat do diáře komukoliv z nabídnutého seznamu (seznam obsahuje uživatele vůči nimž má uživatel právo zápisu). Kliknutím na příjemce ze seznamu a potvrzením jeho výběru šipkou se tento přesune do druhého okna. Stiskem klávesy OK je pak systémem potvrzen jako příjemce. Tímto způsobem si uživatel určí jednotlivé příjemce zprávy.

Odeslání zprávy více uživatelům najednou je možné pouze v případě, že je k tomu účelu nadefinována šablona pro vstup více uživatelů (programová šablona). Pak uživatel po aktivaci činnosti zprávy vyvolá šablonu pro vstup výběru uživatelů, kde si šipkou zvolí, které uživatele chce mít jako příjemce zprávy.

Pokud uživatel často zasílá zprávu většímu počtu stejných uživatelů najednou (např. pracovníkům svého oddělení), využije k tomu předem nadefinované oblíbené skupiny uživatelů. Při zasílání zpráv nebo zápisu do diáře všem pracovníkům jedné skupiny se pomocí zdvojené šipky označí celá skupina a po stisku OK je pak celá skupina uživatelů vybrána jako příjemci.

Formulář

Formulář činnosti - Spuštění archivace
 | Seznam pracovních zařazení
 | Seznam možných příjemců
 | Seznam příjemců
Tlačítko | Přidání označených
Tlačítko | Přidání všech
Tlačítko | Zrušení volby označených
Tlačítko | Zrušení volby všech
Tlačítko | Ukončení výběru
Text | Text výstižně popisující zprávu
Komentář | Komentář autora zprávy.


Spustit spojenou operaci

Popis

Pomocí této činnosti má uživatel možnost spustit operaci, která je s danou zprávou spojena.


Odeslat do Outlooku

Popis

Tato činnost je pro uživatele dostupná pod menu Volby v těch činnostech BM, pro které byly nadefinovány transformace spojené s určitou konverzí. Např. v komponentě vývěska činnost „odeslat do Outlooku“ spustí aplikaci Outlook, kde do textu přetáhne atribut „komentář“ z události vývěsky a do adresáta předplní mailové spojení adresáta z události vývěsky.

Datový model

  • PZOLUSR Poslední transformace a konverze adresy Outlooku vybraná uživatelem při odeslání zprávy z komponenty BM

    • Formulář

    Formulář činnosti - Přístupová práva
Transformace | Identifikace transformace
Konverze | Identifikace konverze adresy příjemce v Outlooku


Zobrazit objekt BM

Popis

Tato činnost je pro uživatele dostupná po stisku klávesy F5 v činnosti „Objekty Outlooku“. Po její aktivaci je zobrazen objekt BM spojený s daným objektem Outlooku.


Definování typu kategorie správy artiklu

Popis

Pro možnost použití palety barev a definice správy artiklu byly rozšířeny vlastnosti kategorie událostí správy artiklu o další atributy. Tyto atributy se nevstupují přímo ve formuláři „kategorie událostí správy artiklu“, ale pomocí činnosti „definování typu kategorie správy artiklu“ (menu volby nebo klávesa F5) z tohoto formuláře.

Vzhledem k činnosti paleta barev byly rozšířeny vlastnosti kategorie událostí správy artiklu o tyto atributy:

¨ typ - překryvný seznam Vstupovaná/Vypočítaná

¨ SQL - memo pole - SQL výraz pro typ Vypočítaná

Stanovení příslušnosti artiklu v kategorii podle typu:

¨ kategorie typu Vstupovaná - artikl patří do kategorie, pokud má u sebe uveden záznam o zařazení do kategorie platný k aktuálnímu datu

¨ kategorie typu Vypočítaná - artikl patří do kategorie, pokud vyhodnocení výrazu SQL vrátí hodnotu větší než 0. Tento výraz v syntaxi SQL Anywhere je vyhodnocován při zpracování SQL dotazu. Používají se v něm proměnné @sa05id. Vyhodnocením výrazu musí být numerická hodnota.

¨ testovat – provede test zadaného SQL dotazu. Protože je výraz vyhodnocován uloženou procedurou až při zpracování SQL dotazu a není kompilován na straně klienta tak, jak je to v případě obecných výběrů, může chybně definovaný SQL výraz způsobovat to, že dotaz bude vracet žádný nebo menší počet záznamů než by měl bez nahlášení chyby.

Datový model

  • SAKATEG Kategorie události správy artiklu

    • Formulář

     | Formulář činnosti - Artikl
 | Kategorie | Identifikace kategorie události správy artiklu
 | Název kategorie | Název kategorie události správy artiklu
 | Typ | Typ kategorie - Vstupovaná / Vypočítaná
 | SQL | Výraz v SQL vyhodnocovaný dotazem vracející numerickou hodnotu (0=není v kategoriii) použivá ID artiklu @sp61id,@sp60id
 | Poznámka | Poznámka
Druh | Identifikace druhu artiklu |
Artikl pro testování | Identifikace artikl pro testování výrazu

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Testovat SQL výraz |
F2 | Artikl | Seznam artiklu
F2 | Druhy artiklů | Seznam druhů artiklů

    Viz.také

    Testovat SQL výraz | Artikl | Druhy artiklů


Testovat SQL výraz

Popis

Tato činnost vrací hodnotu selectu dle testovacího parametru z činnosti BM-funkce pro SQL.


Sumy - spravovaný majetek

Popis

Po stisku klávesy Ctrl S nebo po volbě příslušné činnost z menu Volby se uživateli zobrazí suma celkové ceny za jednotku všech zobrazených událostí.

Formulář

Formulář činnosti - Prognózování odpisů
SUMA - cena za jednotku Cena majetku


Editace dokumentu

Popis

Vyvolání externího programu (např. Word, Excel...) dle předlohy dokumentu a otevření souboru s dokumentem.

Dokument lze vyvolat následujícím způsobem:

¨ stiskem klávesy F6

¨ stiskem příslušné ikony "editace dokumentu"

¨ vyvoláním příslušné činnosti z menu Volby

¨ stiskem klávesy Ctrl D u události, která je s určitým dokumentem spojena. Dvojklikem myši přímo na názvu dokumentu pak lze dokument vyvolat.

S jedním dokumentem může pracovat v jednom okamžiku více uživatelů, avšak pouze jeden může změnit jeho obsah. Pokud uživatel může dokument pouze číst, je mu toto sděleno při otevření dokumentu. Uživatel pak sice může provádět změny v dokumentu otevřeném externím programem, ale tyto změny nebudou zaznamenány. U každého dokumentu s následně evidují informace o jeho užití. Pokud se jedná o dokumenty zpracovávané programy pro Windows, může uživatel otevřít několik dokumentů najednou.

Při ukončení programu systém kontroluje, zda byly uzavřeny všechny dokumenty a v případě, že nikoliv, zobrazí seznam neuzavřených dokumentů a nedovolí uživateli opustit systém, pokud tyto dokumenty nebudou uzavřeny.


Načtení dokumentu

Popis

Tuto činnost má uživatel dostupnou v činnosti předlohy dokumentu. Jedná se o načtení dokumentu z externího souboru. Toto je možné vyvoláním příslušné činnosti z menu Volby a nebo pomocí funkční klávesy Ctrl R.


Kopie druhu procesu

Popis

Tato činnost umožňuje uživateli poměrně jednoduchou metodou vytvářet několik velmi podobných druhů procesů. Aby uživatel nemusel všechny procesy definovat celé znovu, využije právě činnost kopie druhu procesu. Vytvoří si jeden základní proces, nadefinuje jeho diagram, transformace apod. a potom využitím kopie procesu z něj vytváří procesy odvozené, které si v případných maličkostech opraví. Při vytváření kopie procesu uživatel zadává identifikaci a název nového druhu procesu. Jednotlivé vytvořené kopie přejímají od stávajícího procesu všechny jeho definice (tzn. transformace, šablony apod.). Kopií procesu se nepřenáší pouze osobní maska operace procesu.

Tuto činnost uživatel spustí po jejím výběru z menu Volby.

Formulář

Formulář činnosti - Druhy artiklů
Nový druh procesu | Identifikátor druhu procesu
Název druhu procesu | Název druhu procesu


Volné intervaly

Popis

Zobrazuje se tabulka s přehledem volných intervalů číselných řad. U každé řady je informace o začátku a konci intervalu číselné řady a o délce intervalu. Uživatel si podle svého uvážení zvolí volný interval a nadefinuje si podle něj číselnou řadu.

Formulář

Formulář činnosti - Definice výrazu
Mřížka [Volné intervaly]

Mřížka [Volné intervaly] činnosti - Definice výrazu

Mřížka [Volné intervaly] činnosti - Definice výrazu
Začátek intervalu | Začátek intervalu číselné řady procesů
Konec intervalu | Konec intervalu číselné řady procesů
Délka intervalu | Délka intervalu

Atributy tisku

Základní údaje
Začátek intervalu |  | SPW4INTE.sp08intzac | N(6)
Konec intervalu |  | SPW4INTE.sp08intkon | N(6)
Délka intervalu | Délka intervalu | Výpočet | N(6)


OZNAČOVÁNÍ

Popis

Mezi funkce, umožňující uživateli zvolit si určitou množinu dat, patří označování. Pokud je aktivní okno činnosti typu seznam s vyprogramovanou možností označování, nachází se označování pod menu Volby. Ruční označování je možné provést ve většině činností IS BM. Označování je tedy možno provést dvojím způsobem:

¨ ručně - kliknutím myši do zaškrtávacího políčka dojde k označení aktuálního záznamu. Na dolní liště činnosti má pak uživatel k dispozici informaci o počtu označených záznamů.

¨ pomocí činnosti označování v menu Volby nebo stiskem klávesy Ctrl O. Uživateli se pak zobrazí následující nabídka:

- označení všech

- odznačení všech

- přehled označených/všech

- počet označených záznamů

- označování výrazem

Označené záznamy je možno si nejen zobrazit (tj. přehled označených), ale i tisknout. V okamžiku spuštění předlohy výstupu má uživatel možnost vybrat si k tisku pouze označené záznamy. Kromě základní nabídky možností, které se uživateli nabízí po aktivaci činnosti označování (tzn. o(d)značení, přehled označených/všech, počet označených apod.) je pro některé činnosti v IS BM nabídka rozšířena, např. v adresáři označování podle kategorií, ve spuštěné neukončené operaci je možno hromadné zrušení označených záznamů apod.

Atributy tisku

Základní údaje
"Organizační selektor" | "Identifikátor organizačního selektoru." | spselorg.sp18idorg | C(4)
"Název organizačního selektoru" | "Název organizačního selektoru" | spselorg.sp18text | C(25)
"Adresát" | "Identifikace adresáta" | spselorg.ad01id | C(5)

Viz.také

Označení všech | Odznačení všech | Přehled označených / všech | Počet označených záznamů | Označování podle kategorií | Odstranit označené záznamy | Označování výrazem


Označení všech

Popis

Označí se, tzn. zaškrtnou, všechny vybrané záznamy.


Odznačení všech

Popis

Systém provede odznačení všech dosud označených záznamů (i záznamů, které právě nejsou vybrané).


Přehled označených / všech

Popis

Při první aktivaci tohoto tlačítka se uživateli zobrazí přehled označených záznamů, při dalším stisku se zobrazí přehled všech vybraných záznamů (funguje jako přepínač).

Přehled označených záznamů vypne výběr, resp. zobrazí vždy přehled všech označených záznamů nezávisle na tom, jaký výběr je právě aktuálně zvolen. Přehled označených by uživatel mohl využívat i tak, že si zvolí řadu obecných výběrů, kde si v každém výběru označí vybrané záznamy a po stisku přehled označených se mu zobrazí kompletně všechny označené záznamy ze všech výběrů.


Počet označených záznamů

Popis

Uživateli je poskytnuta informace o počtu aktuálně označených záznamů. Stejnou informaci má uživatel i na dolní liště okna činnosti.


Diagram procesu

Popis

Diagram procesu slouží uživateli jednak k prvotnímu nadefinování druhu procesu a jednak k prohlížení již existujícího procesu nebo podprocesu. Diagram procesu je možno vyvolat volbou příslušné činnosti z menu Volby nebo v určitých činnostech po stisku klávesy F7.

Při prvním vstupu do diagramu procesu (tzn. při jeho definici u druhu procesu) se uživateli zobrazí tabulka, ze které si vybere komponentu a operaci, která bude první operací v procesu. Po stisku tlačítka vybrat se tato operace přepíše jako první uzel procesu a zůstane zobrazena na obrazovce. Další operaci nebo "podproces" uživatel do diagramu procesu vloží stiskem ikony "vložit nový prvek" (v levém horním rohu obrazovky) a následným stiskem levého tlačítka myši kdekoliv na obrazovce se mu znovu zobrazí tabulka, kde si vybere komponentu a operaci, která se přepíše jako druhý uzel procesu. Pokud uživatel nevkládá operaci, ale proces, je nutno si na obrazovce "výběr typu operace/procesu" zatrhnout volbu procesu.

U každého uzlu (tzn. uzlu typu „operace“ i uzlu typu „proces“), ze kterých uživatel skládá diagram procesu lze pravým klikem myši vyvolat menu:

¨ vlastnosti

¨ kód po ukončení (pouze uzel typu operace) - uživatel zde má možnost zadávat, aktualizovat nebo rušit vytvořený kód po ukončení operace. V diagramu druhu procesu je u operace vidět celý nadefinovaný kód, ve fyzických procesech je kód po ukončení operace jen do jejího ukončení, pak se smaže.

¨ odstranit - tento atribut se využije v případě, pokud chceme některý uzel diagramu procesu zrušit, současně se odstraní vazby s uzlem související a také ty uzly, pro které je rušený uzel jediným zdrojovým uzlem

¨ vstupní maska operace (pouze uzel typu operace) - možnost definice nebo opravy vstupní masky operace

¨ maska operace v procesu (pouze uzel typu operace) - rovněž možnost definice nebo opravy masky operace v procesu

Nyní si podrobně popíšeme možnosti, které má uživatel k dispozici pod atributem vlastnosti. Pokud se jedná o uzel typu operace, uživatel vstupuje tyto údaje:

¨ zadání, zda operaci spouštět automaticky, na pozadí nebo nespouštět

¨ po nepředběžném ukončení předchozích operací - tento příznak slouží zatím pro operace skladové evidence, kde je možno provádět předběžné a konečné ocenění. Pokud je ocenění předběžné, je vhodné u následující operace v procesu zatrhnout právě tento příznak, neboť pak operace nebude pokračovat a "počká" až do té doby než u předchozí operace bude ocenění konečné. Je to výhodné zejména v případě, kdy po operaci skladové evidence (např. příjem či výdej) s předběžným oceněním následuje zaúčtování pohybu. Aby nedošlo k zaúčtování předběžného pohybu, je k dispozici právě tento příznak, který tuto alternativu umožňuje a hlídá.

¨ aktualizuje hodnotu semaforu procesu - nejprve je třeba zdůraznit, že tato hodnota není povinná, pokud uživatel nepotřebuje u daného procesu sledovat zda je z hlediska "procesního salda" ukončen, tuto hodnotu nezadává. Pokud toto sleduje, tak u první operace v procesu, ze které se provádí transformace se uvádí kladná hodnota, u operací, které následují hodnota záporná. Uvedeme si toto na příkladu - první operací v procesu je událost vývěsky, na kterou přes transformaci navazují dvě zprávy. Potom u operace vývěsky je zadána hodnota 2, u každé z operací zprávy je zadána hodnota -1. Hodnota -1 uvedená u každé této operace se přičítá k vstupní operaci v okamžiku, kdy je tato operace ukončena. Vyrovnaný semafor je tedy v tom případě, pokud je výsledná hodnota nulová.

¨ vytvořit záložku na operaci při založení procesu - tento atribut způsobí to, že na fyzicky vytvořených operacích (v činnosti „operace") je pak na obrazovce dostupný i adresát, který je zastoupen na operaci (jedná se o adresáta z první události), je-li na uzlu typu proces nevytvoří záložku na všech prvních operacích.

¨ zadání šablony prvého vstupu - pokud se operace vstupuje přes šablonu, zadá zde uživatel název šablony (např. pokud se operace týká zprávy, která se posílá několika uživatelům atd.)

¨ po ukončení operace tisk dokladu – pokud je zaškrtnuto, tiskne se po ukončení této operace doklad podle toho, jak je nadefinován u druhu procesu v atributu metapředloha

¨ po ukončení operace tisk operace - výběr metapředlohy (metapředloha s tiskem po ukončení operace musí být nadefinována v tisku v událostech té komponenty, ze které se tiskne)

¨ oprávnění ukončit operaci - výběr jména uživatele nebo skupiny uživatelů, kteří mají oprávnění operaci ukončit. V případě standardního nastavení práv je vhodné zde ponechat implicitní nastavení „každý s právem ukončit operaci“, v případě potřeby lze samozřejmě určit konkrétní skupinu uživatelů nebo přímo jen konkrétního uživatele. To znamená, že danou operaci pak skutečně bude moct do stavu ukončena dovést pouze určený uživatel nebo skupina uživatelů, ostatní uživatelé či skupiny danou operaci nikdy neukončí. (Nastavení tohoto oprávnění však vždy nemusí fungovat v případě, že je spouštění operace nastaveno na pozadí – pak se operace automaticky ukončí i přesto, že k ní daný uživatel nemá nastaveno toto oprávnění ukončit).

¨ ukončuje proces - tento příznak uživatel zatrhne především v operacích, které jsou poslední operací určitého podprocesu, který je součástí daného hlavního procesu a na které navazuje další operace nebo podproces

Pokud se jedná o uzel typu proces (tedy vlastně podproces), který je součástí hlavního procesu, po aktivaci činnosti vlastnosti jsou k dispozici tyto údaje:

¨ spouštět automaticky, na pozadí nebo nespouštět

¨ po nepředběžném ukončení předchozích operací - tento příznak slouží zatím pro operace skladové evidence, kde je možno provádět předběžné a konečné ocenění. Pokud je ocenění předběžné, je vhodné u následující operace v procesu zatrhnout právě tento příznak, neboť pak operace nebude pokračovat a "počká" až do té doby než u předchozí operace bude ocenění konečné. Je to výhodné zejména v případě, kdy po operaci skladové evidence (např. příjem či výdej) s předběžným oceněním následuje zaúčtování pohybu. Aby nedošlo k zaúčtování předběžného pohybu, je k dispozici právě tento příznak, který tuto alternativu umožňuje a hlídá.

¨ aktualizuje hodnotu semaforu procesu - hodnota uvedená zde má stejné vlastnosti jako kdyby se jednalo o operaci, akorát je nutno si uvědomit, že hodnota uvedená u operace, na kterou navazuje podproces, platí pouze ve vztahu operace - podproces, není aktuální pro operace, které jsou součástí daného podprocesu. Hodnota -1, která je uvedená u podprocesu se přičítá k vstupní operaci v okamžiku provedení podprocesu.

¨ vytvořit záložku na operaci při založení procesu - tato funkce se využije především při tvorbě dávkových procesů, např. je možno určitý čas pro daného adresáta vytvářet nové a nové dodací listy a pak je všechny najednou vyfakturovat. Je nutno vytvořit proces o jedné operaci "dodání", která bude mít zatržen tento příznak. Na základě tohoto procesu se pak aktivuje operace, např. o několika událostech a druhý den je opět nutno vystavit danému adresátu dodací list. Uživatel tedy aktivuje činnost "operace", vybere si operace, které jsou spojeny se záložkou, příslušný přehled si setřídí podle názvu adresáta, zvolí si příslušného adresáta a z menu volby nebo stiskem příslušné funkční klávesy znovu spustí operaci a vkládá další události. Takovým způsobem může k jakémukoliv adresátovi vkládat stále další a události, aniž by musel stále pouštět nový proces.

¨ odvozené procesy budou hlavními procesy - tento příznak zatrhne uživatel u procesů, které jsou součástí určitého hlavního procesu, ale uživatel přesto potřebuje znát saldokontní hodnoty pouze za tento daný proces

¨ datové úložiště zahajující operaci/proces – v případě nutnosti odlišení procesu, který má být zapsán s jiným datovým úložištěm (nepříliš používaný atribut)

Mezi jednotlivými uzly (tj. operacemi) se vytvoří vazba, která vyjadřuje vztah mezi nimi. Jedná se o ikonu "vytvořit vazbu". Tato vazba se obecně nazývá transformace.Tuto vazbu je rovněž možno nadefinovat stiskem příslušné ikony (levý horní roh obrazovky). Vazba mezi uzly je vyjádřena šipkou. Stiskem pravého tlačítka myši na této šipce má uživatel možnost upravit vlastnosti vazby nebo ji zrušit.

Před vlastním vysvětlením možností, které se nabízejí ve vlastnostech, je nutno se zmínit o principu vazeb. Každá operace může nabývat tří stavů: připravena, zahájena, ukončena. Obecně platí, že do stavu připravena se může dostat několik operací najednou, bez předchozího ukončení operace může být zahájena pouze první operace v procesu, ostatní operace je možno zahájit a následně ukončit vždy až po ukončení operace předchozí.

Pokud tedy uživatel definuje "vlastnosti" vazby, jedná se o tyto údaje:

¨ vazba - jedná se o číselné vyjádření počtu vazeb, které jsou navázány na danou operaci. Nejčastějším případem bude, že na danou operaci navazuje další operace (tzn. že ve vazbě bude uvedeno číslo 1). Pokud uživatel potřebuje, aby daná operace měla dvě a více následných vazeb, stiskne tlačítko nová operace a každou z nových vazeb samostatně nadefinuje.

¨ pořadí - jedná se o číslo, které vyjadřuje pořadí vazby v jakém se bude vyhodnocovat. Pokud se jedná o vazbu z jednoho uzlu do druhého, je většinou uvedeno implicitní číslo 10. Pokud do uzlu vstupují transformace z více uzlů, využije se právě tato možnost nastavení pořadí. Toto pořadí pak určí v jakém sledu se budou transformovaná data z několika uzlů do tohoto uzlu ukládat. Tento atribut má význam:

- pro aplikaci masky OPAKOVAT (např. datum dle první události operace)

- pro aplikaci „pomocného slučování“, které se realizuje vždy jen do první události cílové operace

¨ transformace - pokud je tento příznak zatržen, uživatel pomocí položky "vstup transformací" zadá transformaci (vybere ji ze seznamu nebo založí novou), která se vztahuje k operacím, mezi kterými je daná vazba

¨ rozlišení - pokud se např. z jedné operace vytváří shodná transformace do tří následujících operací, tak by mohlo dojít k tomu, že se tato transformace provede pouze jednou u první operace a ostatní se provádět nebudou. Pokud se ale tyto operace rozliší jednotlivými symboly A, B, C, tak přestože se jedná o stejnou transformaci, systém ji díky uvedenému rozlišení provede třikrát.

¨ předkontace – možnost výběru obecné předkontace (aby se zde předkontace nabízely, musí být zadány u dané transformace)

¨ vazba - vlastní definice vazby mezi operacemi (nebo procesy) - může být:

- běžná - po ukončení jedné operace v procesu se automaticky spouští operace nadefinovaná jako následující

- samostatná - pokud z jedné operace je nadefinováno několik souběžných vazeb do jiných operací, znamená to, že každá z těchto operací může být ukončena bez ohledu na to, jestli byly ukončeny i ty ostatní. Jinak řečeno, samostatná vazba nevyžaduje předchozí ukončení operace. Tuto vazbu uživatel využije při definování procesu, kdy z jedné operace vede vazba do několika operací a tyto operace se opětovně soustřeďují pouze do jedné operace. Potom u těchto operací bude nadefinovaná právě tato samostatná vazba a následující operace bude uvedena do stavu připravena, když bude ukončena alespoň jedna z několika předchozích operací.

- pasivní - následující operace se automaticky nedostane do stavu připravena, je nutno ji ručně spustit

výběrová (OR) - uživatel si vybere, kterou operaci spustí. Proces se následně jeví jako ukončený v případě, že byla ukončena alespoň jedna z několika možných operací. Trochu složitější je to v případě, že je u těchto operací nastavena hodnota semaforu, potom daný proces není z hlediska "procesního salda" ukončen do té doby, než jsou ukončeny všechny operace, u kterých je nastavena záporná hodnota semaforu.

- výběrová (XOR) - i v tomto případě je na výběr z několika operací. Pokud však uživatel vybere určitou operaci, ostatní operace zaniknou, nebudou se spouštět a upraví se diagram fyzického procesu.

- výběrová (OR) a (XOR) opožděná - význam OR a XOR je shodný jako u předchozích možností, navíc je zde varianta opožděná. Znamená to, že tato vazba se aktivuje až po dalším spuštění dané činnosti (po prvním spuštění se žádná vazba neaktivuje), jednoduše řečeno je její aktivace opožděna.

¨ rozhoduje - výběr uživatele, který rozhoduje o provedení vazby. Nezadává se však vlastní jméno uživatele, ale jeho funkce. Jedná se především o vazby výběrové. Při výběru uživatele je potom automaticky tomuto uživateli (resp. všem uživatelům se stejnou funkcí) zasílána zpráva, proces se v tomto okamžiku pozastaví. Uživatel, který má uvedeno, že rozhoduje, zprávu přijme a v menu volby aktivuje činnost "spustit spojenou operaci". Zobrazí se prvotní operace, na kterou navazují operace, o kterých tento uživatel rozhoduje, kterou v procesu pokračovat. Po stisku ESC se mu zobrazí na výběr právě tyto možné operace, uživatel si vyberu tu, která bude v procesu následovat a standardně pokračuje v práci s procesem.

¨ opožděná signalizace zprávy - zde se nastavuje počet dnů o kolik má být opožděna zpráva, která předchází operacím, ze kterých se provádí výběr. Např. určité události mohou mít mezi sebou časovou prodlevu - vystavení a potvrzení smlouvy apod. Tyto operace je možno zobrazit ze seznamu operací pokud se ve výběru zadá možnost, že se jedná o operace "připravené k rozhodnutí".

Při prvním spuštění diagramu procesu má uživatel k dispozici v horní liště pouze dvě ikony, a to vložit nový prvek a vytvořit vazbu. Pokud uživatel již nějaký druh procesu rozběhl a v jeho průběhu si spustí diagram procesu, je nabídka ikon v horní liště značně rozšířena, a to o tyto možnosti:

¨ zobrazit zdrojový proces

¨ vazby na jiné procesy

¨ vlastnosti (stejné jako po stisku pravého tlačítka myši)

¨ zrušit (možnost zrušit aktuální prvek - systém pokládá ještě kontrolní dotaz)

¨ spustit operaci - poprvé

¨ spustit operaci - již vytvořenou

¨ prohlížet proces

¨ diagram druhu procesu

¨ znovu načíst (jiný způsob okamžité aktualizace dat)

Pokud si uživatel aktivuje diagram již vytvořeného fyzického procesu, na každém uzlu má k dispozici, ve formě zaškrtávátek, informaci o stavu daného uzlu (připraven, zahájen, ukončen). Tímto způsobem tedy uživatel definuje diagram nebo složení procesu. Je to činnost poměrně náročná, vhodná spíše pro pokročilejší uživatele. Uživatel začátečník by měl při definování procesů spolupracovat s pracovníky implementace firmy BM Servis s.r.o.

Viz.také

Transformace


Spuštění procesu

Popis

Spuštění procesu může uživatel provést trojím způsobem:

¨ vyvoláním této činnosti přímo z menu Volby

¨ stiskem příslušné funkční klávesy (F9)

¨ aktivací první operace v procesu přímo z diagramu procesu

Po spuštění procesu se nejprve nabízí k definování první operace v procesu. Po jejím zadání, uložení a ukončení se na obrazovce objeví tabulka "nový proces", kde se zobrazuje popis procesu a externí číslo dokladu (není povinný údaj a není nutno ho vyplňovat) s možnostmi:

¨ zapsat - po stisku volby zapsat je v podstatě potvrzeno pouze zahájení procesu, první operaci v procesu pak musí uživatel ještě standardně ukončit

¨ zapsat a ukončit - tato volba v podstatě zajistí to, že první operace v procesu se ukončí zcela automaticky a systém rovnou přechází na druhou operaci v procesu

¨ nezapisovat - v případě, že uživatel zjistí chybu nebo nesrovnalost má možnost touto volbou proces nezaložit a popřípadě zadat znovu

¨ opakovat vstup

Potvrzení "nového procesu" probíhá vždy pouze u první operace v procesu. Další operace v procesu pak nabíhají automaticky. Po potvrzení ukončení jedné (dotaz "ukončit operaci?") se většinou, pokud není nadefinováno jinak (záložka apod.), spouští následující operace (podle nadefinovaného diagramu procesu). Mírně odlišně probíhá ukončování operací ne ikonou, ale po stisku klávesy ESC. V tomto případě systém pokládá dotaz "Zapsat data?" a možnosti jsou:

¨ Ano - uloží provedenou operaci, ukončit ji musí uživatel

¨ Ano ukončit operaci - uloží operaci, ukončí ji a automaticky nabíhá další operace v procesu

¨ Ne - nedojde k uložení operace, operace bude mít příznak nedokončená

¨ Storno - operace se vůbec neuloží, v případě potřeby je možno ji začít zadávat znovu

Pokud tedy uživatel chce průběh procesu mírně urychlit, je na ukončování operací vhodnější stisk klávesy ESC.


Transformace

Popis

Transformace vyjadřuje vlastní popis přeměny jedné události na druhou. Lze ji definovat, aktualizovat a rušit pouze v činnosti "diagram procesu". Uživatel ji aktivuje stiskem pravého tlačítka myši na vazbě mezi uzly, kde je transformace žádoucí. Po stisku pravého tlačítka myši je transformace dostupná po spuštění činnosti "VLASTNOSTI" a následně tlačítka "vstup transformací".

Transformace obecně definuje, jak se z dat ve zdrojovém uzlu mají předplnit data do cílového uzlu, tj. je základním nástrojem modelování datového toku. Transformace se skládá z definice základních údajů a definice pravidel (nejméně jedno pravidlo musí být vždy uvedeno). Transformace se definuje přímo při vytváření vazby uzlů v diagramu procesu po stisku tlačítka „vstup transformací" (vztahuje se k dvojici komponenta zdrojové operace - komponenta cílové operace). U každé transformace se vstupují následující atributy:

¨ transformace - vlastní název transformace (měl by vyjadřovat co transformace provádí, např. nákup za hotové, prodej za hotové, ZS - příjem, převod na BÚ apod.)

¨ filtr transformace - globální filtr pro zdrojové události, který se uplatní pro všechny pravidla uvedené transformace (např. u transformace „změna stavu - příjem" může být uveden filtr „nenulová úhrada")

¨ rozpad na procesy - má význam jen tehdy, je-li cílový uzel typu proces. Jedná se o definici výrazu (klíče) ze vstupních atributů komponenty, podle kterého se mají cílové události rozdělit (odvozené z událostí se shodným klíčem do jedné operace) do prvních operací samostatných procesů, např. dle adresáta. Pokud např. vytvoříme větší množství položek penalizačních faktur, budeme je pak zcela určitě chtít roztřídit podle jednotlivých adresátů. Jiným příkladem jsou např. nepárované položky výpisu apod.

¨ popis rozpadu – určuje text zobrazovaný v zásobníku operací v seznamu operací. Ve výrazu je možné použít rutinu BM pro SQL-dotaz (např. pro přenos názvu adresáta "~tool.sql_dotaz([select ad01adsat from %%%.adadsat where ad01id=?_p1,Data.ad01id]") pro zobrazení informací, které nejsou součástí dotazu transformace.

¨ doplnění pohledu - umožňuje rozšířit množinu výstupních atributů komponenty o další uživatelsky definované. Je důležité si uvědomit, že tento výpočet probíhá samostatně pro každou událost zdrojové operace, takže pokud je následně v pravidle transformace aplikován agregační výraz, bude doplněná numerická hodnota sčítána. To někdy není žádané a lze tomu zabránit definicí výběru v pravidle, např. RECNO ('DATA')=1

¨ prog. transformace - dodávaná nadstavba (programový kód) pro specifické případy požadavků na transformaci. Je součástí IS BM a uplatňuje se u transformací, kde nestačí základní ani doplněné atributy.

¨ právo následující operace podle umístění - pokud je tento atribut u transformace zaškrtnutý, znamená to, že při ukončení operace (zdrojového uzlu) má uživatel možnost si vybrat (definovat) alokaci pro cílový uzel (např. může určit umístění skladu apod. - podle komponenty, jejíž operace je nadefinována jako cílový uzel v transformaci). Pokud uživatel ke zvolenému umístění (alokaci) nemá (musí mít alespoň právo čtení, aby je mohl uvést) nadefinováno přístupové právo, následující uzel se nespustí, třebaže má ve vlastnostech spouštět automaticky.

¨ transformace dynamické vazby - pokud je daná transformace užita v dynamické vazbě, je nutno zaškrtnout tento příznak. Tuto transformaci není možno užít v nedynamické vazbě, resp. tato možnost není dosud zdárně ověřena z praxe.

¨ aktivovat následující operaci podle filtru transformace – zaškrtnuté způsobuje, že následující operace je aktivována (převedena do stavu připravena) pouze v případě, že existuje událost ukončované operace vyhovující filtru transformace. Z toho vyplývá, že toto nastavení má smysl pouze v případě, když je nastavena vlastnost transformace „filtr transformace“. Pro vyhodnocení podmínky se používá v případě tohoto nastavení kurzor aktuálně ukončované operace, je nutné, aby v ní byly užity pouze atributy tohoto kurzoru (nesmí v ní být použity atributy doplnění transformace).

¨ poznámka - popis užití transformace

Záložka „obecné předkontace“ poskytuje uživateli možnost nadefinovat si obecné předkontace, které jsou svázány s danou transformací a lze je využít při definování vazby (zobrazují se zde jako překryvný seznam u atributu předkontace) mezi zdrojovým a cílovým uzlem v diagramu procesu.

Záložka „výskyt transformace v typech procesů" poskytuje uživateli pouze informativní přehled o tom, v jakých druzích procesů (a mezi jakými uzly těchto druhů procesů) je daná transformace použita.

Transformace jsou společné pro druhy procesu i fyzické procesy. V diagramu fyzického procesu lze transformaci mezi uzly zaměnit za jinou, ale pak se transformace uplatní pouze tehdy, pokud zdrojová operace není ukončena nebo pokud je cílový uzel typu operace.

Datový model

  • SPTRN Transformace
    • BWUZIVAT Uživatel systému

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Pravidla transformace | Definování pravidel trnasformace
F6 | Obecné předkontace | Seznam obecných předkontací
F7 | Diagram procesu | Zobrazení diagramu procesu
- | Kopie transformace | Kopie transformace
F2 | Definice výrazu | Výrazy pro transformace
F2 | Doplnění pohledu transformace | Doplnění pohledu transformace
F2 | Obecné předkontace | Seznam obecných předkontací
F2 | Podmínka provedení | Výrazy pro transformace

    Formulář

    Formulář činnosti - Obecné předkontace
Mřížka [Transformace]
Transformace | Název transformace
Listovací rámeček
Stránka #1 Transformace
Filtr transformace | Filtr transformace platný pro všechna pravidla transformace
Rozpad na procesy | Rozpad na procesy podle výrazu
Popis rozpadu | Výraz pro popis rozpadu procesu v zásobníku operací
Doplnění pohledu | Identifikace doplnění pohledu transformace
Prog. transformace | Program transformace
Právo následující operace podle umístění | Nastavit právo spuštění následující operace podle umístění
Transformace dynamické vazby | Transformace dynamické vazby
Aktivovat následující operaci podle filtru transformace | Aktivovat následující operaci pouze v případě, že existuje událost ukončované operace vyhovující filtru transformace
Založil | Jméno uživatele systému
 | Datum založení transformace
Poznámka | Poznámka o transformaci
Stránka #2 Obecné předkontace
Mřížka [Obecné předkontace]
Předkontace | Identifikace obecné předkontace
Název předkontace | Název obecné předkontace
Poznámka | Poznámka
Stránka #3 Výskyt transformace v typech procesů
Mřížka [Výskyt transformace v typech procesů]
Druh procesu | Identifikátor druhu procesu
 | Název druhu procesu
 | Identifikace komponenty
Druh operace | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Název druhu operace
 | Identifikace komponenty
Druh operace | Identifikátor druhu operace
 | Pořadí stejného druhu operace v jednom procesu
 | Název druhu operace

    Mřížka [Transformace] činnosti - Obecné předkontace

    Mřížka [Transformace] činnosti - Obecné předkontace
Název transformace | Název transformace
Založil | Jméno uživatele systému
Dne | Datum založení transformace

    Mřížka [Obecné předkontace] činnosti - Obecné předkontace

    Mřížka [Obecné předkontace] činnosti - Obecné předkontace
Předkontace | Identifikace obecné předkontace
Název předkontace | Název obecné předkontace

    Mřížka [Výskyt transformace v typech procesů] činnosti - Obecné předkontace

    Mřížka [Výskyt transformace v typech procesů] činnosti - Obecné předkontace
Druh procesu | Identifikátor druhu procesu
Název druhu procesu | Název druhu procesu

    Atributy tisku

    Základní údaje
Název transformace | Název transformace | SPTRN_sp36text | C(30)
Dne | Datum založení transformace | SPTRN_sp36datum | T
Interní transformace | Transformace dynamické vazby | Výpočet | C(3)
Aktivovat následující operaci podle filtru transformace | Aktivovat následující operaci pouze v případě, že existuje událost ukončované operace vyhovující filtru transformace | Výpočet | C(3)
Ident. | Identifikace uživatele systému | SPTRN_bw01uziv | C(6)
Uživatel | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(17)
Uživatel (úplné jméno) | Úplné jméno uživatele systému | BWUZIVAT_bw01jmenot | C(25)
Poznámka | Poznámka o transformaci | SPTRN_sp36koment | M
Název předkontace | Název obecné předkontace | SPPREDK_sp19nazpre | C(40)

    Při pohybu v Obecné předkontace
Předkontace | Identifikace obecné předkontace | SPTRNPRE_sp19id | C(6)
Poznámka | Poznámka | SPTRNPRE_spd2koment | M

    Viz.také

    Pravidla transformace | Diagram procesu | Kopie transformace | Doplnění pohledu transformace | Obecné předkontace | Definice výrazu


Pravidla transformace

Popis

Na úvod popisu této činnosti je nutno uživatele upozornit, že definování pravidel transformace rozhodně není triviální záležitost. Pokud se nejedná o zkušeného uživatele, pravidla transformace by se měl pokusit definovat za spolupráce s pracovníky implementace firmy BM Servis.

První pravidlo, které bez výjimky platí pro definici pravidel transformace je, že kolika událostí se transformace týká, tolik řádek musí mít transformace nadefinováno. Např. pokud bude uživatel pomocí transformace chtít vytvořit z jedné události vývěsky pět zpráv, které pošle spolupracovníkům, je nutno mít nadefinováno pět řádek transformace (po jedné pro každou ze zpráv), při účtování musí být jeden řádek transformace pro stranu Má Dáti a druhý řádek pro stranu Dal nebo při fakturaci musí být jeden řádek transformace pro DPH se sníženou sazbou a druhý řádek pro DPH se základní sazbou.

Pravidla transformace jsou algoritmy datového toku, na základě kterých se události zdrojového uzlu přeměňují v události uzlu cílového (přesněji - na základě kterých se vstupní atributy cílové komponenty předplňují zejména dle výstupních atributů zdrojové komponenty). Pravidla transformace se vyvolávají po stisku klávesy F5 přímo na transformaci (nebo volbou činnosti z menu Volby) nebo je možno je přímo vyvolat po stisku pravého tlačítka myši na názvu transformace při definování vazby uzlů procesu. Každá transformace musí mít uvedeno alespoň jedno pravidlo, což si musí ohlídat implementátor.

První část (nad čarou) pravidel transformace obsahuje tyto údaje:

¨ pořadové číslo - právě číslo pravidla transformace a vedle je informace kdo a kdy transformaci založil, definuje pořadí, v jakém se pravidla uplatní a tím i pořadí cílových událostí (významné např. pro pomocné slučování)

¨ rozlišení - slouží k rozlišení pravidel se stejnou cílovou hodnotou, ale obvykle v různém významu (tj. při aplikaci pravidel s různým rozlišením nedochází k tomu, že se jejich cílové částky sčítají při vykrytí míry plnění, ale naopak vykrývají se každé zvlášť - např. při účtování na obě strany: strana MD - rozlišení 0, strana D - rozlišení 1), podobný vliv na míru plnění má i rozlišení vazby uzlů

¨ agregační výraz - výraz slučování, tzn. že události se shodnou výstupní hodnotou tohoto výrazu budou do cílové události sloučeny (z několika zdrojových bude jedna cílová), specifické je pomocné slučování (výraz "[##]") a využití obecné předkontace

¨ výběr - logický výraz - dané pravidlo transformace se uplatní pouze pro ty zdrojové události, pro které má výraz výstupní hodnotu „pravda“, tzn., že daný výraz platí. Jako doporučení z praxe je možno uvést, že do výběru v pravidlech transformace je vhodné striktně zadávat pouze ty výrazy, které platí pouze pro dané pravidlo, aby nedocházelo k duplikaci se zadaným filtrem transformace, který je společný pro všechna pravidla u dané transformace.

¨ zdrojová hodnota - hodnota (numerický atribut), která je přenášena ze zdroje (tj. z událostí operace, ze které se tato transformace provádí). Zdrojová hodnota je současně algoritmus pro výpočet cílové hodnoty mírou plnění v případě, že je takto jednoduchý. V případě, že tato hodnota není definována, je nutné algoritmus pro výpočet cílové hodnoty mírou plnění definovat přímo u vstupního atributu komponenty, který je definován jako cílová hodnota, obvykle výrazem.

¨ cílová hodnota - hodnota (numerický atribut), která řídí míru plnění pro toto pravidlo (např. lze nadefinovat, že celková cena se má převést na hodnotu částka - v míře plnění). V případě, že chceme, aby se v transformaci mezi uzly uplatnila míra plnění, musí být cílová hodnota zadána povinně.

Druhá část (pod čarou) pravidel transformace je značně variantní a odvíjí se od toho, která komponenta je zdrojová pro danou transformaci (definují ji vstupní atributy komponenty). V této části je možno definovat algoritmus předplnění (automatizace vstupu) uvedených vstupních atributů dvěma způsoby, a to tak, že uživatel může zadávat konstantní hodnoty nebo výraz.

Konstantní hodnoty uživatel zadává, pokud nechává políčko u atributů volné (nezaškrtnuté). Potom jsou sloupce vedle atributů vysvíceny bíle a konstantní hodnota se přímo vepíše, např. v popisu může být uvedeno, že se jedná o „příjem na sklad“ nebo zde může být uvedena hodnota selektorů, které se vždy týkají pouze této transformace.

Pokud políčko před atributem zaškrtneme, předchozí bílé pole se změní na žluté a uživatel může potřebný výraz vybrat z překryvného seznamu nebo má možnost si ho po stisku F2 nadefinovat.

Též je možno využít (nebo zabránit využití) implicitní definice předplnění vstupních atributů komponenty pravidlem transformace, ale to je možné pouze u těch atributů, které jsou současně v událostech zdrojové i cílové komponenty nebo je to poznámka. Pokud uživatel některý vstupní atribut nechce pravidlem transformace předplňovat, a to ani implicitně, musí k němu nadefinovat předplnění prázdným výrazem nebo nulou.

Datový model

  • SPTRNR Pravidlo transformace
    • BWUZIVAT Uživatel systému (alias BWUZIVA1)

    • Formulář

    Formulář činnosti - Definice výrazu
Mřížka [Seznam pravidel transformace]
Pořadové číslo | Pořadové číslo pravidla transformace
Založil | Jméno uživatele systému
 | Datum založení pravidla
Agregační výraz | Výraz slučování záznamů podle pravidla transformace
Výběr | Výběr záznamů konvertovaných pravidlem transformace
Rozlišení | Rozlišení cílové hodnoty
Zdrojová hodnota | Zdrojová hodnota
Cílová hodnota | Cílová hodnota

    Mřížka [Seznam pravidel transformace] činnosti - Definice výrazu

    Mřížka [Seznam pravidel transformace] činnosti - Definice výrazu
    Pořadové číslo Pořadové číslo pravidla transformace

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Agregační výraz | Výrazy pro transformace

    Viz.také

    Definice výrazu


Definice výrazu

Popis

Výrazem se zde rozumí uživatelsky definovaný výraz, který se využívá v transformacích, resp. v jejich pravidlech. Výrazy jsou selektovány dle komponenty (z pohledu vazby zdrojové) a dle druhu (C, N, D, ...).

Výrazy se formulují za použití funkcí FoxPro a výstupních atributů komponenty. Při použití jiných prvků pro definici výrazu je nutno jej uvést vlnovkou (~), pak není prováděna kontrola jejich syntaxe v okamžiku jeho definování, v okamžiku provádění programu je však syntaxe kontrolována. V případě chyby je uživateli systémem nahlášena. Jsou-li uvedeny ~ dvě, není výraz kontrolován z hlediska syntaxe ani v okamžiku definice, ani v okamžiku provádění programu. V tomto případě systém nehlásí žádnou chybu, ale padá, např. ve výrazech lze užít níže uvedené prvky v dané syntaxi:

¨ VK

~data.cspr+'-'+data.naprij - předplní atributem volné karty cspr (číslo procesu), pomlčku a atributem volné karty naprij (název příjemce)

¨ saldokontní hodnoty

~~this.saldo([typ],[druh hodnoty],[druh artiklu],[artikl]) - vrací hodnotu za daný druh saldokontní hodnoty a artikl

¨ atributy doplněné pohledem

~data.sp33extcis - příklad, kdy je připojen atribut externí číslo procesu

¨ pomocné slučování

[##] - tento výraz se užívá v atributu agregace v pravidlech transformace

¨ obecná předkontace

- do numerického atributu - ~~VAL(TOOL.HODNOTA_OBECNE_PREDKONTACE_PREDKONTACE('ADDIPR',data.ad01id1)) - předplní dle příjemce hodnotu provize

- do atributu typu C - „#P <výraz1>;<výraz2>" (výraz 1 je identifikace předkontace, výraz 2 je význam), kde <výraz x> je v daném okamžiku vyhodnotitelný výraz ve formátu FoxPro, např. (~#P 'FP-028';'IDU'+RIGHT(tool.user,2)).

Záložka "výskyt v transformacích atributů" a "výskyt v maskách operací" poskytuje uživateli přehled, kde je daný výraz využitý.

Datový model

  • SPTRNH Výraz pro konverzi atributů

    • Formulář

    Formulář činnosti - Význam předkontace do schránky
Mřížka [Seznam výrazů]
Název výrazu | Název výrazu
Listovací rámeček
Stránka #1 Výrazy
Výraz | Výraz konverze atributů
Poznámka | Poznámka k výrazu
Stránka #2 Výskyt v transformacích atributů
Mřížka [Výskyt v transformacích atributů]
Transformace | Název transformace
Atribut | Atribut události
Výběr | Název výrazu výběru pravidla transformace
Poznámka | Poznámka o transformaci
Stránka #3 Výskyt v maskách operací
Mřížka [Výskyt v maskách operací]
Komp. | Identifikace komponenty
Operace | Identifikátor druhu operace
Pořadí | Pořadí stejného druhu operace v jednom procesu
Název druhu operace | Název druhu procesu
Proces | Identifikátor druhu procesu
Název druhu procesu | Název druhu procesu
Vlastník | Jméno uživatele systému
Atribut | Atribut události
Stránka #4 Položky předkontací
Mřížka [Položky předkontací]
Předkontace | Identifikace obecné předkontace
Název předkontace | Název obecné předkontace
Význam | Identifikace významu položky obecné předkontace
Popis významu | Popis významu položky obecné předkontace
Hodnota | Hodnota položky překontace
Platnost od | Datum platnosti položky obecné předkontace od
Poznámka | Poznámka k položce předkontace

    Mřížka [Seznam výrazů] činnosti - Význam předkontace do schránky

    Mřížka [Seznam výrazů] činnosti - Význam předkontace do schránky
    Název výrazu

    Mřížka [Výskyt v transformacích atributů] činnosti - Význam předkontace do schránky

    Mřížka [Výskyt v transformacích atributů] činnosti - Význam předkontace do schránky
Komp. | Identifikace komponenty
Komp. | Identifikace komponenty - přijemce transformovaných dat
Název transformace | Název transformace
Atribut | Atribut události
Výběr | Název výrazu výběru pravidla transformace

    Mřížka [Výskyt v maskách operací] činnosti - Význam předkontace do schránky

    Mřížka [Výskyt v maskách operací] činnosti - Význam předkontace do schránky
Komp. | Identifikace komponenty
Operace | Identifikátor druhu operace
Název druhu operace | Název druhu procesu
Atribut | Atribut události
Proces | Identifikátor druhu procesu
Vlastník | Jméno uživatele systému

    Mřížka [Položky předkontací] činnosti - Význam předkontace do schránky

    Mřížka [Položky předkontací] činnosti - Význam předkontace do schránky
Předkontace | Identifikace obecné předkontace
Význam | Identifikace významu položky obecné předkontace
Popis významu | Popis významu položky obecné předkontace
Hodnota | Hodnota položky překontace
Platnost od | Datum platnosti položky obecné předkontace od

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Pravidla transformace | Definování pravidel trnasformace
F6 | Transformace | Přehled definovaných transfromací mezi komponentami
F7 | Vstupní maska operace | Definování vstupní masky operace
F9 | Výstupní atributy komponenty | Seznam výstupních atributů komponenty
- | Význam předkontace do schránky | Vloží text významu předkontace do schránky pro následné vložení klávesou CTRL+V
F2 | Výraz | Tvorba výrazu tvůrcem výrazů

    Viz.také

    Pravidla transformace | Transformace | Vstupní maska operace | Výstupní atributy komponenty | Význam předkontace do schránky | Výraz


Výraz

Popis

Výrazem se zde rozumí uživatelsky definovaný výraz, který se využívá v transformacích, resp. v jejich pravidlech. Výrazy jsou selektovány dle komponenty (z pohledu vazby zdrojové) a dle druhu (C, N, D, ...).

Výrazy se formulují za použití funkcí FoxPro a výstupních atributů komponenty. Při použití jiných prvků pro definici výrazu je nutno jej uvést vlnovkou (~), pak není prováděna kontrola jejich syntaxe v okamžiku jeho definování, v okamžiku provádění programu je však syntaxe kontrolována. V případě chyby je uživateli systémem nahlášena. Jsou-li uvedeny ~ dvě, není výraz kontrolován z hlediska syntaxe ani v okamžiku definice, ani v okamžiku provádění programu. V tomto případě systém nehlásí žádnou chybu, ale padá, např. ve výrazech lze užít níže uvedené prvky v dané syntaxi:

¨ VK

~data.cspr+'-'+data.naprij - předplní atributem volné karty cspr (číslo procesu), pomlčku a atributem volné karty naprij (název příjemce)

¨ saldokontní hodnoty

~~this.saldo([typ],[druh hodnoty],[druh artiklu],[artikl]) - vrací hodnotu za daný druh saldokontní hodnoty a artikl

¨ atributy doplněné pohledem

~data.sp33extcis - příklad, kdy je připojen atribut externí číslo procesu

¨ pomocné slučování

[##] - tento výraz se užívá v atributu agregace v pravidlech transformace

¨ obecná předkontace

- do numerického atributu - ~~VAL(TOOL.HODNOTA_OBECNE_PREDKONTACE_PREDKONTACE('ADDIPR',data.ad01id1)) - předplní dle příjemce hodnotu provize

- do atributu typu C - „#P <výraz1>;<výraz2>" (výraz 1 je identifikace předkontace, výraz 2 je význam), kde <výraz x> je v daném okamžiku vyhodnotitelný výraz ve formátu FoxPro, např. (~#P 'FP-028';'IDU'+RIGHT(tool.user,2)).

Záložka "výskyt v transformacích atributů" a "výskyt v maskách operací" poskytuje uživateli přehled, kde je daný výraz využitý.

Formulář

Formulář činnosti - Přístupová práva
Mřížka [Agregace]
Agregace | Název agregace
Listovací rámeček
Stránka #1 Agregace
Komentář | Komentář k agregaci
Stránka #2 Agregované atributy
Mřížka [Agregace]
Název atributu | Název atributu

Mřížka [Agregace] činnosti - Přístupová práva

Mřížka [Agregace] činnosti - Přístupová práva
Agregace Název agregace

Mřížka [Agregace] činnosti - Přístupová práva

Mřížka [Agregace] činnosti - Přístupová práva
Název atributu | Název atributu
Typ | Typ atributu
Délka | Délka
Desetiny | Počet desetin
Popis atributu | Popis atributu


Spustit operaci

Popis

Tato činnost umožňuje uživateli aktivovat připravenou nebo zahájenou operaci nebo si prohlédnout již vytvořenou a ukončenou operaci, pokud mu toto dovolují přístupová práva. Spustit operaci uživatel provede klávesou F9 nebo volbou příslušné činnosti v menu Volby.

V případě aktivace připravené operace má uživatel možnost zadat položky vybrané operace a operaci ukončit. Po opuštění formuláře se systém ptá: "Ukončit operaci? Ano/Ne". Po potvrzení volby Ano je operace ukončena a pokud je součástí procesu, tak po jejím ukončení automaticky nabíhá další operace v daném procesu. Po aktivaci zahájené operace již jednotlivé atributy nevstupuje, nicméně má možnost je před ukončením operace ještě opravit. Po aktivaci již ukončené operace je možno jednotlivé atributy pouze prohlížet.

Zajímavostí pro uživatele je, že pokud se jedná o nedokončenou operaci, která je součástí procesu o jedné operaci, tak se právě spuštěná nedokončená operace nabízí uživateli v režimu oprav. Pokud se jedná o nedokončenou operaci, která je součástí procesu o dvou a více operacích, tak se právě spuštěná nedokončená operace nabízí uživateli v režimu vstupu. Je to dáno tím, že pokud se jedná o proces, který obsahuje min. dvě operace, uplatňuje se mezi těmito operacemi tzv. aktivní míra plnění, tzn., že uživateli je dána možnost nechat rozpadnout danou operaci na dvě nebo více dalších operací (např. prvotní operace je objednávka 100 ks, jako další operace v procesu je dodání 100 ks, ale došlo pouze 50 ks, tzn., že uživatel pak může zadat další operaci, která bude dodání zbylých 50 ks). Proto se daná operace nabízí rovnou v režimu vstupu, pokud uživatel nebude danou operaci nijak rozpadat, normálně ji příslušnou ikonou (disketa) uloží a ukončí.


Přístupová práva

Popis

Přístupová práva se definují u každé činnosti, ve které má smysl nějakým způsobem přidělovat přístup jednotlivým pracovníkům.

Přístupová práva jednotlivých uživatelů systému se v první řadě odvíjí od toho, jaké má daný uživatel nadefinována práva ve skupině (nebo skupinách) uživatelů, ve které je zařazen. Pokud je tedy zařazen do skupiny "běžný uživatel" má u všech činností stejná práva jako všichni ostatní uživatelé ve skupině "běžný uživatel". Pokud je třeba toto implicitní právo vybranému uživateli změnit, je toto možné po zatržení příznaku explicitní právo a nastavení "práv přístupu" - výběrem z překryvného seznamu.

Standardní způsob zobrazení přístupových práv je, že v levé části obrazovky se vždy zobrazuje "to" (mohou to být činnosti, uživatelé...) K ČEMU se přístupové právo definuje a v pravé části obrazovky (včetně záložek "práva přístupu skupin uživatelů" a "aktuální práva") je zobrazeno KDO ho přiřazuje.

Uvedeme si příklad: v levé části činnosti budou zobrazeny témata vývěsky a pravé části uživatelé systému. Potom musí být následující postup takový. Kurzor je umístěn na vybraném uživateli v pravé části a jemu se přiřazují práva k jednotlivým tématům v levé části.

Dalším způsobem přidělování a evidence přístupových práv je mapa přístupových práv.

Datový model

  • SPTYP Druh procesu/operace

    • Formulář

    Formulář činnosti - Zařazení do skupin uživatelů
Mřížka [Typ]
Listovací rámeček
Stránka #1 Práva
Mřížka [Práva]
 | Identifikátor druhu
 | Název druhu
 | Identifikace skupiny uživatelů
 | Název skupiny uživatelů
Právo přístupu | Právo přístupu - Žádné,Čtení,Zápis
Zakázáno opravovat | Nepovoleno opravovat
Zakázáno ukončit operaci | Nepovoleno ukončit operaci
Stránka #2 Aktuální práva
 | Název druhu
 | Identifikátor druhu
Mřížka [Aktuální práva]

    Mřížka [Typ] činnosti - Zařazení do skupin uživatelů

    Mřížka [Typ] činnosti - Zařazení do skupin uživatelů
Název druhu | Název druhu
Druh | Identifikátor druhu

    Mřížka [Práva] činnosti - Zařazení do skupin uživatelů

    Mřížka [Práva] činnosti - Zařazení do skupin uživatelů
Skupina | Identifikace skupiny uživatelů
Název skupiny uživatelů | Název skupiny uživatelů
Právo přístupu | Právo přístupu - Žádné,Čtení,Zápis

    Mřížka [Aktuální práva] činnosti - Zařazení do skupin uživatelů

    Mřížka [Aktuální práva] činnosti - Zařazení do skupin uživatelů
Jméno pracovníka | Jméno uživatele systému
Expl. | Právo je uživateli přiřazeno explicitně
Přístup | Právo přístupu - Žádné,Čtení,Zápis
Neopravuje | Nepovoleno opravovat
Neukončuje | Nepovoleno ukončit operaci

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Mapa přístupových práv | Mapa přístupových práv
F6 | Zařazení do skupin uživatelů |
- | Přepočet práv přístupu | Přepočet práv přístupu uživatelů k věcem
F2 | Skupiny uživatelů | Definování skupin uživatelů

    Viz.také

    Mapa přístupových práv | Zařazení do skupin uživatelů | Přepočet práv přístupu | Skupiny uživatelů


Výstup dokladu

Popis

Výstupem každého procesu je doklad. U každého druhu procesu, který budeme chtít tisknout je nutno mít nadefinovánu metapředlohu výstupu. Vlastní tisk tohoto dokladu se provádí v činnosti "procesy", kde si uživatel na zvoleném druhu procesu aktivuje menu Volby a vybere příslušnou činnost nebo po stisku klávesy F5. Tisknout doklad je možno pouze u procesu, který již byl spuštěn (tzn. u fyzického procesu).


Výstup operace

Popis

Pokud je u dané operace nadefinována metapředloha výstupu (v činnosti druhy operací), je možno pomocí této činnosti získat výstup operace neboli provést její tisk.

Obraz operace (např. skladovou výdejku nebo příjemku) je možno tisknout rovnou z událostí skladu. Ve většině dalších dokladů (např. dodací list, pokladní doklady) se prolínají události z více operací (vyskladnění, DPH, předepsaná platba), a proto je nutno tisknout tento doklad z procesu. To se provede pomocí volby příslušné činnosti z menu Volby nebo po stisku klávesy F5.


Přepočet práv přístupu

Popis

Činnost přepočet práv přístupu je pro uživatele dostupná v menu SYSTÉM v činnosti uživatelé programu a skupiny uživatelů v menu Volby. Přepočet práv přístupu slouží k tomu, aby se nastavená přístupová práva správně zaznamenala a při práci jednotlivých uživatelů s IS BM uplatňovala. Při nastavování přístupových práv k funkcím je nutno spustit přepočet práv přístupu pouze v případě, že uživatel zadal do systému novou skupinu nebo nového uživatele (nebo změnil jeho zařazení do jiné skupiny), při vlastním definování přístupových práv v činnosti „oprávnění k činnostem“ pro jednotlivé skupiny není nutno přepočet spouštět.

V případě, že uživatel definuje přístupová práva přes mapu přístupových práv, je nutno pustit přepočet vždy.


Šablony

Popis

Tato činnost poskytuje uživateli možnost definice jednotlivých šablon. Šablona v tomto případě znamená jakýsi vzor, podle kterého se vstupuje nebo automaticky naplňuje událost. Při první aktivaci činnosti program spouští automaticky první záložku, pro uživatelské vyhledávání je k dispozici i záložka Výběr.

Základní šablony (např. odeslání zprávy vybraným uživatelům, zápis na vývěsku s vybranými adresáty, obecný účetní zápis, otevření a uzavření účetních knih ....) jsou dodávány společně s informačním systémem. Je ovšem zcela zřejmé, že každý uživatel má své specifické potřeby, a proto si popis při vytváření šablony blíže vysvětlíme.

Ve formulářích pro definování implementačních rozšíření (volné karty, obecné výběry, importy/exporty dat, šablony, výkazy, metapředlohy výstupu) lze pod menu Volby vyvolat činnost „překlad popisek“. Při úpravě vzhledu formulářů v činnostech, ve kterých definuje implementátor vstupní formulář (volné karty, obecné výběry, šablony, importy/exporty dat, dotazy výkazů), je možné po pravém kliku klávesou myši na atributu určit jeho rozměry. Lze definovat šířku atributů třídy textové pole, překryvný seznam a u atributů typu textové, multimediální, makro je možné navíc definovat jejich výšku.

U každé šablony je možno určit, zda se jedná o šablonu veřejnou (čili přístupnou všem ostatním uživatelům) nebo soukromou (přístupná pouze tomu, kdo tuto šablonu založil).

U každé šablony definujeme nejprve její název, druh a vstup. Do položky vstup lze např. zadat hodnotu pomlčka, uživatelé, kopie operace nebo adresář. Pokud tedy vytvářená šablona má kopírovat určitou operaci, zadá uživatel do položky vstup kopie operace. V případě, že při vstupu šablony dochází k výběru uživatelů (např. při odesílání zprávy dochází k výběru příjemců zprávy), zadá se hodnota vstupu uživatelé. Pokud uživatel potřebuje při práci se šablonou používat i adresář, zadá do hodnoty vstup adresář. V ostatních případech se zadává pomlčka.

U každé šablony je pak nutno nadefinovat její proměnné, což jsou položky, které uživatel chce v dané šabloně vstupovat. Např. při zápisu události na vývěsku uživatel jako proměnné nadefinuje datum, téma, text a komentář události. U každé proměnné uživatel zadává její název, velikost, typ (zda se jedná o proměnnou textovou, znakovou, datumovou, numerickou nebo časovou), návěští proměnné, které se zobrazuje přímo na šabloně, naplnění - a to může být způsobem "vstup" nebo "výpočet". Pokud je typu "výpočet", zadává se do dalšího políčka způsob výpočtu. Proměnné se uvádějí v hranatých závorkách, takže způsob výpočtu může vypadat např. takto: [název proměnné]*2. Pokud je způsob "vstup", je možno zadat hodnotu do položky "inicializační hodnota". Znamená to, že pokud třeba uživatel předplní inicializační hodnotu u proměnné text (např. otevření účetních knih - píše se bez apostrofů), tak při použití dané šablony se tento text předplní do položky text. Další položkou je třída, která nabízí uživateli možnost výběru z překryvného pole. Jedná se o tyto hodnoty:

¨ textové pole

¨ překryvný seznam - je ho možno využít u typu proměnné znaková a numerická. Do další položky je potom nutno zapsat proměnné tak, jak se mají v překryvném seznamu nabízet (typ proměnné musí být znaková). Uvedeme si příklad např. na hodnotách Má dáti a Dal. Do políčka vedle překryvného seznamu je možno tyto hodnoty napsat dvojím způsobem:

- MD,DAL - a pak se při vstupu šablony budou předplňovat ve tvaru MD, DAL

- *MD,M,DAL,D (včetně uvedené hvězdičky) - při vstupu šablony je pak systém bere jako dvě dvojice (MD a M a druhá dvojice je DAL a D), přičemž v překryvném seznamu zobrazuje MD a DAL a do dat se tyto hodnoty ukládají ve tvaru M a D. Pokud je překryvný seznam použit pro typ proměnné numerická, zapsané hodnoty Má dáti a Dal se budou z překryvného seznamu vybírat jako MD=1 a D=2. Takže uživatel pak vybírá buď 1 nebo 2.

¨ zaškrtávací pole - je ho možno použít pouze pro typ proměnné numerická

Další vlastnosti, které je možno u proměnných nadefinovat jsou:

¨ inicializace – inicializační hodnota proměnné ob. výběru. Je zde možno uvádět libovolně dlouhý text a používat volání interních funkcí (např.: SQL_DOTAZ). V takovém případě musí být výraz uveden znakem vlnovka (‘~’).

¨ validace – skript v jazyce Foxpro, který se provádí v okamžiku validace dané proměnné ve vstupním formuláři. Ve skriptu se mohou vyskytovat odkazy na všechny proměnné dané definice, které jsou vstupovány, uvedené v hranatých nebo složených závorkách. Proměnná uvedená v hranatých závorkách obsahuje v okamžiku vstupu formuláře hodnotu dané proměnné.

Proměnná uvedená ve složených závorkách obsahuje v okamžiku vstupu formuláře objekt, kterým je proměnná zobrazena.

Makro ### obsahuje v okamžiku vstupu formuláře hodnotu proměnné, pro kterou je prováděna validace.

V okamžiku spuštění kódu validace jsou mu k dispozici proměnné:

- _THISFORM - objekt formuláře, ve kterém je prováděn vstup

- _THIS - objekt proměnné, která je validována

Pro účely validace obsahuje formulář metodu TEST_ZMENA, která musí být vyvolána s parametry:

- identifikace - jednoznačná textová identifikace hodnoty

- hodnota - libovolná hodnota

Metoda následně vrací numerické hodnoty:

0 - hodnota dané identifikace, je stejná jako hodnota uložená při předcházejícím volání této metody se stejnou identifikací

1 - hodnota dané identifikace, je jiná než hodnota uložená při předcházejícím volání této metody se stejnou identifikací

2 - hodnota dané identifikace byla právě poprvé uložena voláním této metody

Příklad předplnění měny podle vstupovaného adresáta:

If _thisform.test_zmena('adresat',###)=1 Or Empty([mena])

[mena]=Tool.sql_dotaz([select oc01id from %%%.adadsat where ad01id=?_p1],###)

Endif

¨ třída – třída ovládacího prvku (textové pole/překryvný seznam/zaškrtávací pole)

¨ text pro zaškrtávací políčko nebo seznam hodnot pro překryvný seznam oddělených čárkou

¨ F2 reakce – možnost vyvolání vybrané činnosti (z překryvného seznamu) na klávesu F2

Po definici šablony a proměnných je nutno nadefinovat "pravidla šablony"(v menu Volby nebo po stisku klávesy F5), tj. jak má šablona předplnit atributy události. Vždy platí, že jedno pravidlo šablony předplní jednu událost. Pokud je šablona plněna importem, není nutno pravidla šablony definovat, neboť import údaje nastavené u šablony nebere v potaz, řídí se pouze svými nastaveními. Pokud se jedná o vstup šablony programovým kódem, tak rovněž platí, že jedno pravidlo šablony předplní jednu událost, přičemž každá jednotlivá položka se může vyskytovat v různých pravidlech (např. atribut částka může být v šabloně komponenty účetnictví v jednom pravidle na straně Má dáti a stejný atribut částka je v druhém pravidle na straně Dal). Pravidla šablony se definují podobně jako masky operace (pozor na "schované" pokračování seznamu atributů). U položek (atributů události), které chceme automatizovaně předplnit daným pravidlem šablony uživatel nastaví název proměnné, ty položky (atributy události), které nechce šablonou předplnit nechá prázdné a u těch, kde se má předplnit implicitní hodnota (konstanta), tuto hodnotu rovnou zapíše. Volba kopírovat se používá v případě, pokud je vstup šablony „kopie operace“ čili aby systém přesně věděl, které atributy ze zadané operace chce uživatel pomocí šablony kopírovat. U těchto atributů, které se mají zkopírovat z již vytvořené operace se zvolí právě možnost kopírovat.

Jako poslední zbývá definovat design vstupního formuláře (v menu Volby nebo po stisku klávesy F6), kde se pouze jednotlivé proměnné šablony s naplněním "vstup" rozmístí v okně tak, jak budou při aktivaci šablony zobrazeny v okně.

Šablona se aktivuje stiskem CTRL F3 v neukončené operaci nebo automaticky při spuštění operace v rámci procesu, v jehož diagramu je ve vlastnostech daného druhu operace uvedena jako šablona prvého vstupu. Pokud je definována šablona prvého vstupu ve vlastnostech uzlu, pro který je současně definována automatizace vstupu pomocí transformace, tak se šablona neuplatní.

Použití šablony lze chránit přístupovým právem přiřazeným k druhu šablony. Určité nároky na funkčnost šablony nelze řešit uživatelsky a tak je k dispozici několik programátorsky připravených vstupů šablony.

Jinak je nutno uživatele upozornit, že definování šablon není úplně jednoduchou záležitostí a uživatel by tuto činnost měl provádět nejlépe v součinnosti s pracovníky oddělení implementace firmy BM Servis s.r.o.

Datový model

  • SPSABL Šablona
    • BWUZIVAT Uživatel systému
    • SPPRISTU Přístupové právo uživatele k věci
    • SPSABLT Druh šablony
    • SPIMP Definice importu/exportu

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Pravidla šablony |
F6 | Design vstupního formuláře |
^P | Překlad popisek |
F2 | Definice importu/exportu | Definice importu nebo exportu dat
F2 | Druhy šablon |

    Formulář

    Formulář činnosti - Překlad popisek
Mřížka [Šablony]
Šablona | Název šablony
Listovací rámeček
Stránka #1 Šablony
Druh šablony | Druh šablony
 | Název druhu šablony
Import | Identifikace importu
Název importu-exportu | Název importu-exportu
Vstup šablony | Identifikace vstupu šablony
Hromadná oprava | Šablona pro hromadnou opravu záznamů
Veřejná šablona | Veřejná šablona - je přístupná všem uživatelům systému
Založil | Jméno uživatele systému
 | Datum vzniku šablony
Komentář | Poznámka k šabloně
Stránka #2 Proměnné šablony
Mřížka [Proměnné šablony]
Proměnná | Číslo proměnné definice šablony
Název proměnné | Název proměnné
Typ | Typ proměnné
Délka | Délka proměnné
Desetiny | Počet desetin
Návěští | Návěští proměnné
Naplnění | Způsob naplnění proměnné - vstupem nebo výpočtem
Výraz | Výraz proměnné šablony
Inicializace | Inicializační hodnota proměnné šablony
Validace | Script v jazyce Foxpro pro validaci vstupu
Třída | Třída ovládacího prvku
 | Text pro zaškrtávací políčko nebo seznam hodnot pro překryvný seznam oddělených čárkou
F2-reakce | Vyvolání činnosti na klávesu F2

    Mřížka [Šablony] činnosti - Překlad popisek

    Mřížka [Šablony] činnosti - Překlad popisek
Šablona | Název šablony
Uživatel | Jméno uživatele systému
Datum vzniku | Datum vzniku šablony

    Mřížka [Proměnné šablony] činnosti - Překlad popisek

    Mřížka [Proměnné šablony] činnosti - Překlad popisek
Proměnná | Číslo proměnné definice šablony
Název | Název proměnné
Typ | Typ proměnné
Délka | Délka proměnné
Desetiny | Počet desetin
Návěští | Návěští proměnné

    Atributy tisku

    Základní údaje
Komponenta | Identifikace komponenty | SPSABL_sp06idsubs | C(3)
Šablona | Název šablony | SPSABL_sp50sablon | C(40)
Druh šablony | Druh šablony | SPSABL_sp54id | C(6)
Název druhu šablony | Název druhu šablony | SPSABLT_sp54druhsa | C(40)
Datum vzniku | Datum vzniku šablony | SPSABL_sp50datum | T
Veřejná šablona | Veřejná šablona - je přístupná všem uživatelům systému | Výpočet | C(3)
Import | Identifikace importu | SPSABL_sp93id | C(6)
Název importu-exportu | Název importu | SPIMP_sp93nazimp | C(40)
Hromadná oprava | Šablona pro hromadnou opravu záznamů | Výpočet | C(3)
Proměnná | Číslo proměnné definice šablony | SPSABLP_sp52cisprm | C(4)
Název proměnné | Název proměnné | SPSABLP_sp52nazev | C(10)
Počet desetin | Počet desetin | SPSABLP_sp52deseti | N(2)
Návěští proměnné | Návěští proměnné | SPSABLP_sp52label | C(30)
Třída | Třída ovládacího prvku | Výpočet | C(16)
Hodnoty | Text pro zaškrtávací políčko nebo seznam hodnot pro překryvný seznam oddělených čárkou | SPSABLP_sp52pict | C(60)
Výraz | Výraz proměnné šablony | SPSABLP_sp52vyraz | C(60)
Inicializace | Inicializační hodnota proměnné šablony | SPSABLP_sp52init | M
Validace | Script v jazyce Foxpro pro validaci vstupu | SPSABLP_sp52valid | M
Naplnění | Způsob naplnění proměnné - vstupem nebo výpočtem | Výpočet | C(7)

    Viz.také

    Pravidla šablony | Design vstupního formuláře | Překlad popisek | Definice importu/exportu | Druhy šablon


Design vstupního formuláře

Popis

Uživateli se zobrazuje formulář, který obsahuje nadefinované proměnné dané šablony (nebo volné karty), které si na obrazovce rozmístí (pomocí myši - systém "táhni a drž") a upraví tak, jak chce, aby se mu šablona (volná karta) při vstupu zobrazovala. Design vstupního formuláře uživatel vyvolá klávesou F6 nebo volbou příslušné činnosti v menu Volby.


Pravidla šablony

Popis

Před vlastním popisem této činnosti je nutno uživatele upozornit, že pokud není zkušeným uživatelem, měl by tuto činnost poprvé provádět ve spolupráci se svým implementátorem. Vždy platí, že jedno pravidlo šablony předplní jednu událost. Ke každému pravidlu šablony je možno definovat podmínku zařazení řádku do výstupu šablony. Uvádí se logický výraz v syntaxi Foxpro, ve kterém je možné použít proměnné šablony uvedené v hranatých závorkách.Pokud je šablona plněna importem, není nutno pravidla šablony definovat, neboť import údaje nastavené u šablony nebere v potaz, řídí se pouze svými nastaveními. Pokud se jedná o vstup šablony programovým kódem, tak rovněž platí, že jedno pravidlo šablony předplní jednu událost, přičemž každá jednotlivá položka se může vyskytovat v různých pravidlech (např. atribut částka může být v šabloně komponenty účetnictví v jednom pravidle na straně Má dáti a stejný atribut částka je v druhém pravidle na straně Dal).

Uživateli se zobrazují položky, které jsou přístupné na obrazovce u událostí v činnosti, kterou chce vstupovat přes šablonu. U každé položky je k dispozici zaškrtávací políčko, které má vliv na zobrazení následujícího volného políčka. Pokud toto zaškrtávací políčko není zatrženo, zadávají se do dalšího volného políčka u jednotlivých položek konstantní (tj. trvalé, stálé) hodnoty, např. určité datum. Pokud je toto zaškrtávací políčko zatrženo, uživatel zadává jednotlivé proměnné (předplňuje se u dané položky), které má možnost si vybrat z překryvného seznamu. Nabízí se zde samozřejmě i jeho nadefinovaná proměnná (záložka "proměnné šablony"). Pokud nezadává žádnou proměnnou, nechává v pravém sloupci vyplněnu pouze hodnotu " - ", tzn., že danou položku nebude muset při vstupu události přes šablonu zadávat, bude zde implicitně předplněna pomlčka. Při vytváření kopie operace zde uživatel zadá kopírovat, v ostatních případech zadává svojí vlastní vytvořenou a nadefinovanou proměnnou.

Datový model

  • SPSABLR Pravidlo definice šablony

    • Formulář

    Formulář činnosti - Knihovny vkládaného kódu
Mřížka [Řádek vstupu]
Pořadové číslo | Pořadové číslo pravidla šablony
Podmínka | Podmínka uplatnění pravidla šablony

    Mřížka [Řádek vstupu] činnosti - Knihovny vkládaného kódu

    Mřížka [Řádek vstupu] činnosti - Knihovny vkládaného kódu
    Pořadové číslo Pořadové číslo pravidla šablony


Druhy šablon

Popis

Tato činnost umožňuje definici druhů šablon (což představuje jakoby jejich kategorie). Může se jednat např. o "obecnou" šablonu, která je přístupná všem nebo o druh šablony "obchodní", kde šablony tohoto druhu budou využívat pouze pracovníci obchodního oddělení. U každého druhu šablon má uživatel možnost se po stisku záložky "obsažené šablony" podívat, které šablony jsou obsaženy v tomto druhu. Ke každému druhu šablony je možno nadefinovat přístupová práva.

Datový model

  • SPSABLT Druh šablony
    • BWUZIVAT Uživatel systému (alias BWUZIVA1)
    • SPPRISTU Přístupové právo uživatele k věci

    • Vyvolávané činnosti

    K. | Činnost | Popis
^B | Práva přístupu k druhům šablon | Definování práv přístupu k druhům šablon

    Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Druhy šablon]
Druh šablony | Druh šablony
 | Název druhu šablony
Listovací rámeček
Stránka #1 Druhy šablon
Založil | Jméno uživatele systému
 | Datum založení druhu šablon
Komentář | Popis druhu šablon
Stránka #2 Obsažené šablony
Mřížka [Šablony]
Šablona | Název šablony
Založil | Jméno uživatele systému
 | Datum vzniku šablony
Komentář | Poznámka k šabloně

    Mřížka [Druhy šablon] činnosti - Přístupová práva

    Mřížka [Druhy šablon] činnosti - Přístupová práva
Druh šablony | Druh šablony
Název druhu šablony | Název druhu šablony
Uživatel | Jméno uživatele systému
Datum vzniku | Datum založení druhu šablon

    Mřížka [Šablony] činnosti - Přístupová práva

    Mřížka [Šablony] činnosti - Přístupová práva
Šablona | Název šablony
Uživatel | Jméno uživatele systému
Datum vzniku | Datum vzniku šablony

    Atributy tisku

    Základní údaje
Druh šablony | Druh šablony | SPSABLT_sp54id | C(6)
Název druhu šablony | Název druhu šablony | SPSABLT_sp54druhsa | C(40)
Ident. | Identifikace uživatele systému | SPSABLT_bw01uziv | C(6)
Datum vzniku | Datum založení druhu šablon | SPSABLT_sp54datum | T
Komentář | Popis druhu šablon | SPSABLT_sp54koment | M
Uživatel | Jméno uživatele systému | BWUZIVA1_bw01jmeno | C(17)
Uživatel (úplné jméno) | Úplné jméno uživatele systému | BWUZIVA1_bw01jmenot | C(25)
Šablona | Název šablony | SPSABL_sp50sablon | C(40)
Ident. | Identifikace uživatele systému | SPSABL_bw01uziv | C(6)
Datum vzniku | Datum vzniku šablony | SPSABL_sp50datum | T
Veřejná šablona | Veřejná šablona - je přístupná všem uživatelům systému | Výpočet | C(3)
Uživatel | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(17)
Uživatel (úplné jméno) | Úplné jméno uživatele systému | BWUZIVAT_bw01jmenot | C(25)

    Viz.také

    Přístupová práva


Přístupy k procesům a operacím

Popis

Na úvod je nutno upozornit, že definování přístupových práv by měl provádět pouze správce nebo pracovník k tomu určený.

Vyvolání činnosti přístupových práv uživatel provede výběrem příslušné činnosti z menu Volby a nebo po stisku Ctrl B. Pro definici přístupových práv je možno využít i činnost „mapa přístupových práv“ (klávesa F5 nebo aktivace činnosti z menu Volby).

Uživateli se zobrazuje přehled všech dosud nadefinovaných procesů a operací. Na záložce „práva“ je v pravé části formuláře přehled skupin uživatelů nebo jednotlivých uživatelů, kteří mají práva k danému procesu, tzn. že při definování přístupových práv je možno nadefinovat přístupové právo buď celé skupině uživatelů nebo jen vybraným uživatelům. (přístupová práva se definují po stisku klávesy F3 nebo po volbě ikony „vložení nového záznamu“).

Po stisku záložky "aktuální práva" se zobrazí přehled uživatelů, kteří mají v danou chvíli přístupové právo k danému procesu nebo operaci.

Datový model

  • SPTYP Druh procesu/operace

    • Formulář

    Formulář činnosti - Skupiny uživatelů
Mřížka [Práva přístupu k dokladům a operacím]
Listovací rámeček
Stránka #1 Práva
Mřížka [Práva]
 | Identifikátor druhu
 | Název druhu
 | Identifikace skupiny uživatelů
 | Název skupiny uživatelů
Právo přístupu | Právo přístupu - Žádné,Čtení,Zápis
Zakázáno opravovat | Nepovoleno opravovat
Zakázáno ukončit operaci | Nepovoleno ukončit operaci
Stránka #2 Aktuální práva
 | Název druhu
 | Identifikátor druhu
Mřížka [Aktuální práva]

    Mřížka [Práva přístupu k dokladům a operacím] činnosti - Skupiny uživatelů

    Mřížka [Práva přístupu k dokladům a operacím] činnosti - Skupiny uživatelů
Komponenta | Identifikace komponenty
Druh | Identifikátor druhu
Název druhu | Název druhu procesu

    Mřížka [Práva] činnosti - Skupiny uživatelů

    Mřížka [Práva] činnosti - Skupiny uživatelů
Skupina | Identifikace skupiny uživatelů
Název skupiny uživatelů | Název skupiny uživatelů
Právo přístupu | Právo přístupu - Žádné,Čtení,Zápis

    Mřížka [Aktuální práva] činnosti - Skupiny uživatelů

    Mřížka [Aktuální práva] činnosti - Skupiny uživatelů
Jméno pracovníka | Jméno uživatele systému
Expl. | Právo je uživateli přiřazeno explicitně
Přístup | Právo přístupu - Žádné,Čtení,Zápis
Neopravuje | Nepovoleno opravovat
Neukončuje | Nepovoleno ukončit operaci

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Mapa přístupových práv | Mapa přístupových práv
F6 | Zařazení do skupin uživatelů |
- | Přepočet práv přístupu | Přepočet práv přístupu uživatelů k věcem
F2 | Skupiny uživatelů | Definování skupin uživatelů

    Viz.také

    Mapa přístupových práv | Zařazení do skupin uživatelů | Přepočet práv přístupu | Skupiny uživatelů


Volná karta

Popis

Volná karta je nástroj, který umožňuje uživateli rozšířit množinu programátorsky definovaných atributů těch entit, ke kterým existuje činnost určená k prohlížení záznamů dané entity, o další uživatelsky definované atributy. Rozlišujeme několik volných karet, které mají významnější postavení než ostatní, a to:

¨ adresáta

¨ artiklu

¨ operace

¨ procesu

¨ vazby objektů

¨ selektorů

Pojem volná karta užíváme pro její definici i pro okno se zobrazením jejího obsahu. U každé definice volné karty se kromě její identifikace a názvu vstupují další údaje uvedené na jednotlivých záložkách. Toto je pro všechny volné karty shodné. Jedná se o záložku „atributy volné karty" a záložku „volné pohledy".Aktivovat volnou kartu je možno na základě uživatelského rozhodnutí nebo automaticky. IS BM umožňuje sledovat změny záznamů na volných kartách (po nastavení v činnosti „nastavení sledování změn tabulek“). Při změně struktury volné karty nejsou automaticky přegenerovávány triggery pro sledování změn záznamů VK. Generovat triggery je možno z formuláře definování VK volbou „generovat triggery tabulky“ nebo z menu Volby tohoto formuláře vyvolat „nastavení sledování změn tabulek“ a „uživatelské triggery“.

Definice volné karty se skládá z definice její hlavičky, prezentovaných údajů (záložka „atributy volné karty") a volných pohledů (fakticky příkazů SELECT pro získání informace výpočtem z dat IS BM - záložka „volné pohledy").V hlavičce „karty“ se definuje:

¨ identifikace volné karty

¨ název volné karty

¨ správce – identifikace druhu implementačního rozšíření. Určuje právo uživatele ke správě (definování) volné karty. Vybírá se z překryvného seznamu a možnosti jsou: -, obecný druh dopl. vlast. formuláře, správce, systémový

¨ druh volné karty – vybírá se ze seznamu druhů volných karet, určuje právo uživatele pro přístup k datům volné karty. K tabulce volné karty je naprogramován trigger, který při změně druhu volné karty (v tabulce SPVOLST) provádí změnu druhu těch atributů volné karty (v tabulce SPVOLSTA), které mají uveden stejný druh jako původní druh volné karty.

¨ velikost – umožňuje změnit velikost okna volné karty (Ne, Horizontálně, Vertikálně, Oběma směry – horizontálně i vertikálně)

¨ posuvník – zda okno volné karty bude obsahovat posuvník. Pokud je volná karta menšího formátu, posuvník není zřejmě nutný, pokud obsahuje větší množství údajů, ale je omezena určitou velikostí, je vhodné zvolit aspoň horizontální posuvník, aby bylo možno se po jednotlivých atributech volné karty pohybovat. Možnosti jsou Žádný, Horizontální, Vertikální, Oba)

¨ autor – zobrazovat na volné kartě/nezobrazovat na volné kartě. Určuje, zda má být na volné kartě zobrazována informace o uživateli, který volnou kartu založil a datum jejího založení

¨ dynamický nadpis - výraz ve formátu FoxPro, který je vyhodnotitelný na úrovni formuláře, ze kterého je volná karta vyvolána a vrací textovou hodnotu. Např. volná karta v činnosti přehled uživatelů. Pokud je v dynamickém nadpisu zapsán výraz ve tvaru bwuzivat.bw01jmeno, tak při listování seznamem uživatelů se v okně volné karty bude dynamicky měnit jméno uživatele. Je možné uvádět výraz v jazyce Foxpro uvedený znakem ‘=’ – v tomto výrazu je možné získat hodnoty primárního klíče uvedením názvů atributů primárního klíče v hranatých závorkách.

¨ vyvolat automaticky - zda se bude aktivovat automaticky při spuštění činnosti

¨ znovu načítat – tento atribut způsobuje znovunačtení volné karty po zápisu dat na kartu. Volnou kartu je navíc možné „znovu načíst“ volbou z menu Obecné nebo po stisku funkční kláves F6.

¨ skript – definuje skript v jazyce Foxpro vyvolávaný v okamžiku zápisu volné karty. Pokud skript vrátí logickou hodnotu .F. (FALSE) není karta zapsána. Vyvolání skriptu se dá využít:

a/ k zápisu dalších informací na VK

např.: datum na VK je datem aktualizace VK

REPLACE bw01uziv1 WITH tool.uziv

REPLACE sp00datzap WITH DATETIME()

REPLACE bw01jmeno WITH tool.jmeno

b/ odeslání e-mailu před zápisem VK

¨ komentář – libovolná poznámka k volné kartě

¨ informace o tom, kdo a kdy volnou kartu založil

Vzhled volné karty je dán uživatelským designem (menu Volby nebo klávesa F6 - „design vstupního formuláře"), který určuje to, jak budou jednotlivé atributy volné karty rozmístěné v okně volné karty. Pokud to daná činnost umožňuje, lze vyvolat kteroukoliv volnou kartu po stisku menu Obecné a pak si příslušnou volnou kartu vybrat podle toho, zda se jedná o volnou kartu procesu, operace apod.

Na záložce "atributy volné karty" uživatel zadává jednotlivé atributy, které se budou při aktivaci volné karty uživateli nabízet. Jedná se o:

¨ identifikaci (název) atributu,

¨ druh - vybírá se ze seznamu druhů volných karet, určuje právo uživatele pro přístup k datům volné karty

¨ typ, případně délku a počet desetinných míst (typ – znaková, numerická, datumová, časová, textová, multimediální – viz. popis níže)

¨ pořadí, v jakém bude aktualizován

¨ třída (textové pole, překryvný seznam, zaškrtávací pole). Pro atributy třídy překryvný seznam je možno nastavit dynamický combobox (viz. popis níže)

¨ zobrazení - v jakém zobrazení či formátu se bude daný atribut při aktivaci okna volné karty zobrazovat, např. u překryvných seznamů se zde uvádí volby, které se uživateli budou nabízet při vyvolání tohoto překryvného seznamu, např. Ano,Ne nebo Příjem,Výdej apod., u numerických atributů zde může být zapsán formát jak se číslo má v okně volné karty zobrazovat, např. 99 999 999.99. Je možné uvádět libovolně dlouhý text. Pro třídu překryvný seznam a typ znakový je možné zadat SQL dotaz uvedený znaky *~. Dotaz musí vracet dva sloupce. První sloupec určuje text zobrazovaný v překryvném seznamu a druhý hodnotu předávanou na volnou kartu, např. SQL dotaz pro překryvný seznam se seznamem uživatelů *~select (if bw01aktiv=1 then '' else '* ' endif )+bw01jmeno,bw01uziv from %%%.bwuzivat where bw01uziv<>'$SYSTE' order by bw01aktiv desc,bw01jmeno

¨ návěští (tzn. popis, který se u daného atributu bude zobrazovat v okně volné karty)

¨ poznámka - vlastní poznámka k atributu,

¨ inicializace - pokud je zde uveden atribut, který je výpočtový, je nutno pro něj mít vytvořen vlastní volný pohled. Pokud je tedy uveden „název volného pohledu.alias jeho atributu" (např. POHCLK.pclk1), pak se jedná o údaj prezentující vypočtenou hodnotu (pomocí příkazu SELECT), v opačném případě se jedná o atribut nové tabulky, která se musí po každé aktualizaci své struktury generovat. V případě, že se jedná o atribut třídy zaškrtávací pole, při inicializaci 0 je volný, při zadané inicializaci 1 je při aktivaci okna volné karty již zaškrtnutý nebo při překryvném seznamu jsou atributy v překr. seznamu fiktivně očíslovány 1,2,3 atd., tzn. že při zobrazení Ano,Ne a nastavení inicializace na 1 se při aktivaci okna volné karty přednastaví překryvný seznam na hodnotu Ano. Atribut může obsahovat výraz uvedený znakem #např.: #tool.uziv pro inicializaci hodnoty volné karty identifikací aktuálního uživatele systému. Ve vlastnosti inicializace je možné uvádět text uvedený rovnítkem. Hodnota takové atributu není ukládána do dat volné karty a tento atribut není možné editovat. Za rovnítkem se uvádí výraz v jazyce Foxpro, jehož hodnota je zobrazována pro daný atribut ve volné kartě. Hodnota atributu ve volné kartě je přezobrazována při každé změně, kterou proveden uživatel vstupem libovolného atributu. Pro správné vyhodnocení je nutné, aby vstupované atributy uváděné ve výrazu měly pořadí menší než atribut, ve kterém je uvedena vypočtená hodnota. Za rovnítkem vlastnosti inicializace je možné zadat prefix SCRIPT – inicializace je potom provedena pomocí víceřádkového skriptu v jazyce Foxpro. Příklady:

a/ název adresáta zobrazovaného na volné kartě na základě identifikace adresáta (atribut IDADR) vstupované uživatelem:

=tool.sql_dotaz([select ad01adsat from %%%.adadsat where ad01id=?_p1],[idadr])

b/ součet dvou hodnot vstupovaných uživatelem

=[hodnota1]+[hodnota2]

c/ příklad řešení se skriptem

=SCRIPT

IF [hodnota1]>20

RETURN [hodnota2]

ELSE

RETURN [hodnota1]

ENDIF

¨ validace – je zde možno uvádět kód v jazyce Foxpro, který vrací hodnoty TRUE nebo FALSE signalizující validitu atributu. V tomto kódu je možné uvádět text ### (představuje daný atribut) nebo názvy jiných atributů volné karty ohraničené hranatými závorkami. Tyto texty představují hodnotu odpovídajícího atributu. Příklady:

a/ validace na nenulovou hodnotu

IF ###=0

WAIT WIND 'Částka nesmí být nulová' NOWAIT

RETURN .F.

ENDIF

b/ validace existence adresáta zadaného uživatelem na volnou kartu

IF EMPTY([adnazev])

* předpokládá se, že ADNAZEV je atribut volné karty inicializovaný podobně jako v příkladu 1a

* tento atribut bude v průběhu vstupu prázdný, pokud hodnota atributu identifikace adresáta (v příkladu 1x se jedná o atribut IDADR) neodpovídá existujícímu adresátovi

WAIT WIND 'Adresát musí být uveden' NOWAIT

RETURN .F.

ENDIF

¨ podmínka – umožňuje definovat logický výraz v jazyce FoxPro určující podmínku vstupu do daného atributu. Pokud podmínka obsahuje výraz .F. – je atribut zobrazen ve formátu pouze pro čtení, pokud podmínka obsahuje výraz .NULL. – atribut není na obrazovce zobrazen.

¨ P.oknu (přizpůsobení oknu) – možnost určení případné změny velikosti atributu při změnách velikosti okna volné karty (Ne/Horizontálně/Vertikálně/Obojí)

¨ zda má být při vstupu údaje po stisku F2 aktivována uvedená činnost

Dynamický combobox:

Volná karta může být nastavena tak, že se mění obsah překryvného seznamu (platí pro atributy třídy překryvný seznam) při změně hodnoty jiného atributu volné karty (tzn. že při změně hodnoty jednoho atributu překryvný seznam se podle toho automaticky změní i hodnota druhého atributu překryvný seznam).

Pro tuto možnost je třeba definovat:

1. pro atribut třídy překryvný seznam v atributu pro seznam hodnot kód, který zajistí naplnění překryvného seznamu

2. pro atribut, při jehož změně hodnoty má být provedena změna obsahu překryvného seznamu, nastavit validační funkci, kterou se nepřímo vyvolá kód změny překryvného seznamu.

K tomuto účelu se využívá metoda SET_ROWSOURCE atributu třídy překryvný seznam.

Tuto metodu je možné vyvolat výrazem v syntaxi:

_THIS.PARENT.SPF_[název atributu volné karty třídy překryvný seznam].SET_ROWSOURCE()

Např.:

Return _this.parent.spf_sp60id.set_rowsource()

Kód pro naplnění hodnot překryvného seznamu se obvykle uvádí pomocí makra a musí začínat textem *~SCRIPT.

V kódu se vyskytují odkazy na atributy volné karty, které ovlivňují obsah překryvného seznamu - těmito odkazy jsou názvy atributů uvedené v hranatých závorkách a před levou závorkou je uveden znak podtržení (např. _[SP61ID]).

Kód má dále k dispozici proměnné _THIS instance objektu třídy překryvný seznam, který je odvozen z objektu třídy COMBOBOX Visual Foxpro.

Příklad:

Volné karta, na které je vstupován artikl. Obsahuje atributy:

1. SP61ID - druh artiklu - C(3) - třída textové pole

2. SP60ID - artikl - C(13) - třída překryvný seznam

Požadavek - obsah překryvného seznamu (SP60ID) má odpovídat hodnotě druhu artiklu (SP61ID)

Nastavení vlastností atributů:

1. vlastnost Validace atributu SP61ID - RETURN _THIS.PARENT.SPF_SP60ID.SET_ROWSOURCE()

2. vlastnost Seznam hodnot pro překryvný seznam atributu SP60ID - COMBOBOX_SPARTIKL()

COMBOBOX_SPARTIKL je makro, s definovaný kódem:

<pre>

*~SCRIPT

Local _pc,_als,_li,_i

* _THIS obsahuje instanci objektu třídy překryvný seznam odvozené ze třídy COMBOBOX Visual Foxpro

Do Case

Case Empty(_[sp61id])

Return .F.

Case Type('_this.free_sp61id')<>'C'

* pokud objekt _THIS nemá vlastnost FREE_SP61ID, potom je mu tato vlastnost metodou ADDPROPERTY přidělena

* touto část kódu se půjde pouze jednou

* ve vlastnosti FREE_SP61ID se bude pamatovat, pro kterou hodnotu SP61ID je naplněn překryvný seznam

_this.AddProperty('free_sp61id',_[sp61id])

* vlastnosti COLUMNCOUNT a COLUMNWIDTHS jsou vizuální vlastnosti - toto nastavení, aby seznam lépe vypadal

_this.columncount=0

_this.ColumnWidths=''

Case _this.free_sp61id=_[sp61id]

* poslední zapamatovaná hodnota v FREE_SP61ID odpovídá aktuální hodnotě SP61ID na volné kartě

* obsah překryvného seznamu není proto třeba měnit

Return

Other

* uložení aktuální hodnotě SP61ID z volné karty do FREE_SP61ID

_this.free_sp61id=_[sp61id]

Endcase

* metoda Clear vymazává obsah překryvného seznamu

_this.Clear

_als=Select()

* SQL dotaz na zjištění názvů artiklů požadovaného druhu

If !bw_exec(.F.,[select sp60id,sp62artikl from %%%.spartikn where sp61id=?_p1 and sp38id='CZE'],'_art',_this.free_sp61id)

Select (_als)

Return

Endif

Select _art

* setřídění názvů česky

Set Collate To 'czech'

Index On sp62artikl Tag klic

Set Collate To 'machine'

_pc=0

_li=0

* v cyklu bude naplněn překryvný seznam

Scan All

_pc=_pc+1

* metoda ADDITEM přidává řádek překryvného seznamu

_this.AddItem(Trim(sp62artikl),_pc)

* pomocí vlastnosti LIST vkládá kód do druhého sloupce hodnotu identifikace artiklu

_this.List[_pc,2]=sp60id

if _this.value=sp60id

_li=_pc

endif

Endscan

_this.listindex=_li

Use In _art

Select (_als)

* kód funguje zároveň jako validační funkce

Return _pc>0

</pre>

Ve vlastnostech atributů Zobrazení, Inicializace a Validace je možné používat makra. Základní makra jsou k dispozici v Návodech a balíčcích. Vlastní definování maker se provádí činností „definice maker“ z menu Volby formuláře volná karta. Řešení příkladů pomocí těchto maker:

1a/ fky_nazev_adresata([idadr])

2a/ valid_neprazdny('Částka nesmí být nulová')

2b/ valid_fky([adnazev],'Adresát musí být uveden')

V popisech Zobrazení, Inicializace a Validace jednotlivých atributů volné karty je možné uvádět identifikátory atributů primárního klíče tabulky, se kterou je volná karta spojena. Tyto identifikátory se uvádějí v hranatých závorkách. Např.: na volnou kartu adresáta zobrazit název adresáta v atributu inicializace - =tool.sql_dotaz([select ad01adsat from %%%.adadsat where ad01id=?_p1],[ad01id])

¨ p. oknu – přizpůsobení oknu – určuje, zda akceptovat změny velikosti atributu při změnách velikosti celého okna volné karty (Ne, Horizontálně, Vertikálně, Obojí)

¨ F2 - reakce - zda má být při vstupu údaje po stisku F2 aktivována zde uvedená činnost, tj. vstup do zvoleného číselníku.

Na záložce „atributy volné struktury" uživatel tedy definuje atributy, které po vyvolání příslušné volné karty vyplňuje, resp. prohlíží (ty mají údaj "inicializace" uveden názvem volného pohledu). Atributy volné karty jsou pak k dispozici v transformacích druhu procesu. Pokud je chceme použít jako výstupní atributy komponenty, tak v seznamu výstupních atributů komponenty (klávesa F5 v činnosti „Definice výrazu) nejsou zobrazeny. Do výrazů je nutno je zapsat po stisku klávesy F3 a před vlastní název výrazu je nutno připsat znak „~" (např. výraz ~data.divs je definován hodnotou atributu "divs" volné karty). Tento znak zaručí, že systém nebude daný výraz kontrolovat z hlediska syntaxe.

Atributy volné karty typu 'Multimediální' se používají:

1. s nevyplněnou vlastností 'Inicializace' - obrázek nebo videoklip je ukládán v tabulce volné karty

2. s vyplněnou vlastností 'Inicializace' výrazem uvedeným znakem '=' - obrázek není uložen v tabulce volné karty - na volné kartě je zobrazován obrázek ze souboru, jehož název je určen vyhodnocením výrazu této vlastnosti

3. s vyplněnou vlastností 'Inicializace' výrazem uvedeným znakem '=' a uvedeným textem AVI v popisu třídy atributu - videoklip není uložen v tabulce volné karty - na volné kartě je zobrazován videoklip ze souboru, jehož název je určen vyhodnocením výrazu této vlastnosti

Výraz vlastnosti 'Inicializace' je vyhodnocován dynamicky při přezobrazování volné karty, takže se při pohybu v záznamech formuláře, ke kterému je karta připojena, může docházet ke změně zobrazovaného obrázku resp. videoklipu. Multimediální atributy v vyplněnou vlastností 'Inicializace' mohou mít uveden ve vlastnosti 'Validace' kód v jazyce Foxpro, který má být prováděn při pravém kliku myší na obrázku resp. pravém okraji videoklipu.

K dispozici jsou makra, která usnadňují vytváření volných karet pro zobrazování multimédií, které jsou uloženy jako dokumenty BM připojené k objektům BM. Rozhodnutí o tom zda budou obrázky objektů ukládány v tabulce volné karty (ad 1.) nebo jako dokumenty BM (ad 2.) ovlivní implementaci. Obrázky objektů BM implementované způsobem ad 1. je možné prohlížet prostřednictvím volné karty a tisknout klasickou předlohou výstupu, další možnosti nejsou. Obrázky objektů BM implementované způsobem ad 2. (s využitím maker) je možné tisknout v předlohách výstupu typu Excel (tisk v klasické předloze výstupu je obtížný), použít s jinými nástroji Windows (např. publikovat na internetu), zahrnout do řízení procesu (např. při pořizování přijaté faktury přinutit uživatele připojit k procesu oskenovanou kopii přijaté faktury). Pro zobrazování dokumentů BM, které jsou svým charakterem obrázky resp.videoklipy, připojené k objektům BM, jsou připravena makra pro použití ve vlastnostech 'Inicializace' a 'Validace' multimediálních atributů volných karet.

Pro vlastnost 'Inicializace' makro - DOKUMENT_OBRAZEK_OBJEKTU.

Substitucí makra vznikne výraz, který vrací název souboru obsahujícího obrázek, který je uložen v dokumentu připojeného k objektu BM. Protože k objektu BM může být připojeno více dokumentů, z nichž pouze některé jsou obrázky, uvádí se parametrem tohoto makra, jakého druhu dokumentu a jakou předlohu dokumentu může mít připojený obrázek. Jediným parametrem makra je identifikátor obecné předkontace, které by měly mít uvedeny hodnoty:

- VK0001 - seznam druhů dokumentů

- VK0002 - seznam předloh výstupu

Na volné kartě je potom zobrazován obrázek uložený v prvním nalezeném připojeném dokumentu, který je druhu podle hodnoty VK0001 a má předlohu výstupu podle hodnoty VK0002. Dokument s obrázkem nebo videoklipem přitom může být uložen v databázi BM nebo uložený externě.

Pro vlastnost 'Validace' makro - DOKUMENT_OBRAZEK_RIGHTCLICK

Toto makro je možné použít pouze v případě, že je ve vlastnosti 'Inicializace' uvedeno volání makra DOKUMENT_OBRAZEK_OBJEKTU. Substitucí makra vznikne kód v jazyce Foxpro, který po pravém kliku klávesou myši na obrázku resp. pravém okraji videoklipu zobrazí menu:

1. v případě, že dokument není k objektu BM připojen:

1a) Založit dokument - obrázek

- volbou uživatel vybírá soubor obrázku s příponou podle hodnoty obecné předkontace VK0001 (identifikace této překontace je dána voláním makra DOKUMENT_OBRAZEK_OBJEKTU)

- následně vstupuje vlastnosti nově zakládaného dokumentu s předplněným názvem podle prvého parametru makra a s předplněným způsobem uložením dokumentu podle druhého parametru makra (0=předplňovat ukládání do databáze, 1=předplňovat externí uložení na disk), přitom vybírá druh dokumentu podle VK0001 a předlohu dokumentu podle VK0002 a odpovídající přípony

2. v případě, že je dokument k objektu BM připojen:

2a) Vyměnit dokument - obrázek

- volbou uživatel vybírá soubor obrázku s příponou podle předlohy daného dokumentu, kterým bude nahrazen obrázek uložený v dokumentu BM. Tato volba je podmíněna právem zápis pro uživatele k druhu daného dokumentu.

2b) Opravit dokument - obrázek

- volbou je vyvolána oprava dokumentu

2c) Uložit jako ...

- volba pro uložení kopie obrázku na disk

2d) Kopírovat

- provede kopii souboru do schránky Windows (obrázek je potom možné např. vložit do dokumentu Wordu, jako přílohu e-mailu, ...)

2e) Vlastnosti dokumentu

- volba pro prohlížení a opravy vlastností dokumentu BM

Pro vlastnost 'Inicializace' makro - EXTERNI_OBRAZEK

Makro se používá ve vlastnostech 'Inicializace' atributů typu 'Multimediální' volných karet. Substitucí makra vznikne výraz, který vrací název souboru obsahujícího obrázek resp. videoklip podle parametrů makra.

Parametry:

1. adresářová cesta k souboru

2. název souboru bez přípony

3. přípona souboru - může být uvedena souborová maska např. '*'

Makro je třeba uvádět s prefixem SCRIPT.

Příklad:

=script externi_obrazek('mediup\pict\',[sp60id],'*')

Pro vlastnost 'Validace' makro - EXTERNI_OBRAZEK_RIGHTCLICK

Makro se používá ve vlastnostech 'Validace' atributů typu 'Multimediální' volných karet. Toto makro se většinou používá při použití makra EXTERNI_OBRAZEK uvedeného ve vlastnosti 'Inicializace'.

Substitucí makra vznikne kód v jazyce Foxpro, který po pravém kliku klávesou myši na obrázku zobrazí menu:

1. Kopírovat - provede kopii souboru do schránky Windows (obrázek je potom možné např. vložit do dokumentu Wordu, jako přílohu e-mailu, ...)

Příklad:

externi_obrazek_rightclick()

Záložka "volné pohledy" obsahuje příkazy SELECT pro získání informací výpočtem z dat IS BM, jinými slovy záložka „volné pohledy" umožňuje doplnit definici atributů volné struktury o SQL dotaz, kterým tyto atributy mají být plněny. Definuje se zde:

¨ pohled - identifikaci a název volného pohledu,

¨ návratové hodnoty - tj. výčet atributů klíče uvozených znaky $$$. a oddělených čárkou. Je to seznam výrazů (oddělených čárkami) ve formátu FoxPro vyhodnotitelných ve formuláři, ze kterého je volná karta vyvolána. Atribut uvozený $$$. je nahrazen názvem aliasem dočasné tabulky (tj. kurzoru) událostí odpovídající komponenty, ke kterému je volná karta připojena,

¨ formální parametry - tj. výčet atributů klíče uvozených znaky _ a oddělených čárkou. Je to seznam identifikátorů pod kterými budou tyto hodnoty vystupovat v SQL dotazu. Doporučuje se, aby název jednotlivých atributů byl uvozen podtržítkem.

¨ dotaz - tj. příkaz SELECT pro získání dat, ve kterém je možné využít formální parametry uvozené otazníkem (pro příklad se zadanou inicializací v atributech volné struktury obsahuje tento volný pohled atribut pclk1),

¨ poznámka - libovolný popis uživatele.

Z výše uvedeného vyplývá, že „návratové hodnoty" vrací hodnotu daného atributu z daného formuláře na základě aktivního záznamu (např. pokud bude návratovou hodnotou atribut ad01id, tak systém v tuto chvíli vrátí identifikaci adresáta, na které je v danou chvíli v tabulce adresáře v přehledu jednotlivých záznamů umístěn kurzor). Formální parametry obsahují již konkrétní data atributu, který je v dotazu v příkazu SELECT uveden otazníkem (např. ?_ad01id). Jinými slovy, laicky řečeno, návratové hodnoty říkají systému „na co se má zeptat", formální parametry poskytují již získanou „určitou hodnotu".

Záložka „užití volné karty“ sleduje využívání jednotlivých volných karet a tím usnadňuje rozhodování implementátora o tom, kterou volnou kartu ponechat a kterou je vhodné vyřadit. Užití volné karty, která je otevírána automaticky při spuštění formuláře zde zaznamenáno není. Zobrazuje se:

¨ kdo - jméno uživatele

¨ kdy poprvé - datum prvního použití volné karty uživatelem

¨ kdy naposledy - datum posledního použití volné karty uživatelem

¨ kolikrát - celkový počet použití volné karty uživatelem

Tyto informace se ukládají do tabulky SPVOLSTU s atributy:

¨ bw10nazev - část primárního klíče volné karty

¨ sp64nazev - část primárního klíče volné karty

¨ bw01uziv - kdo - identifikace uživatele

¨ spe6dat1 - kdy poprvé

¨ spe6dat2 - kdy naposledy

¨ spe6pocet – kolikrát

Ve formulářích pro definování implementačních rozšíření (volné karty, obecné výběry, importy/exporty dat, šablony, výkazy, metapředlohy výstupu) lze pod menu Volby vyvolat činnost „překlad popisek“. Při úpravě vzhledu formulářů v činnostech, ve kterých definuje implementátor vstupní formulář (volné karty, obecné výběry, šablony, importy/exporty dat, dotazy výkazů), je možné po pravém kliku klávesou myši na atributu určit jeho rozměry. Lze definovat šířku atributů třídy textové pole, překryvný seznam a u atributů typu textové, multimediální, makro je možné navíc definovat jejich výšku.

Datový model

  • SPVOLST Volná karta
    • SPCINDVT Druh implementačního rozšíření
      • SPPRISTU Přístupové právo uživatele k věci
    • BWUZIVAT Uživatel systému (alias BWUZIVA1)

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Editovat kód vlastnosti | Editovat kód vlastnosti
F6 | Design vstupního formuláře |
^P | Překlad popisek |
- | Kontrolní kompilace | Kontrolní kompilace
- | Generování tabulky | Generování tabulky odpovídající volné struktuře
- | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností
- | Definice maker | Definice maker
- | Překlad popisek - název volné karty |
- | Generovat triggery tabulky | Generovat uživatelské triggery pro tabulku
- | Nastavení sledování změn tabulek | Nastavení sledování změn tabulek
- | Uživatelské triggery | Definování uživatelských triggerů
F2 | Druhy implementačních rozšíření | Druhy implementačních rozšíření
F2 | Druhy volných karet | Seznam druhů volných karet
F2 | Výběr makra | Výběr makra

    Formulář

    Formulář činnosti - Uživatelské triggery
Mřížka [Volné karty]
Listovací rámeček
Stránka #1 Karty
Karta | Název volné karty
 | Popis volné karty
Správce | Identifikace druhu implemetačního rozšíření
Druh | Druh volné karty - pro přístup uživatele
Velikost | Umožnit změnu velikosti okna - Ne/Horizontálně/Vertikálně/Oběma směry - horizontálně i vertikálně
Posuvník | Posuvník okna volné karty Žádný/Horizontální/Vertikální/Oba horizontální i vertikální
Autor | Zobrazovat informaci o autorovi záznamu Ano/Ne
Dynamický nadpis | Dynamický nadpis
Vyvolat automaticky | Vyvolat automaticky při spuštění formuláře
Znovu načítat | Po vstupu volné karty znovu načíst kartu
Založil | Jméno uživatele systému
 | Datum vzniku volné karty
Skript | Kód v jazyce Foxpro provedený před zápisem dat volné karty
Komentář | Komentář k volné kartě
Stránka #2 Atributy volné karty
Mřížka [Atributy volné struktury]
Název | Název atributu volné karty
Druh | Druh volné karty - pro přístup uživatele
Typ | Typ atributu volné karty
Délka | Délka atributu volné karty
Des. | Počet desetin atributu volné karty
Poř. | Pořadí atributu volné karty
Třída | Třída ovládacího prvku
Zobrazení | Text pro zaškrtávací políčko nebo seznam hodnot pro překryvný seznam oddělených čárkou
Návěští | Návěští atributu volné karty
Poznámka | Poznámka atributu volné karty
Inicializace | Inicializační hodnota atributu volné karty
Validace | Script validace v jazyce Foxpro
Podmínka | Podmínka vstupu atributu
P.oknu | Přizpůsobovat oknu
F2-reakce | Vyvolání činnosti na klávesu F2
Stránka #3 Volné pohledy
Mřížka [Volné pohledy]
Pohled | Identifikace volného pohledu
Popis volného pohledu | Popis volného pohledu
Návratové hodnoty | Návratové hodnoty zdrojového formuláře
Formální parametry | Formální parametry dotazu
Dotaz | Dotaz volného pohledu
Poznámka | Poznámka
Stránka #4 Užití volné karty
Mřížka [Užití volné karty]

    Mřížka [Volné karty] činnosti - Uživatelské triggery

    Mřížka [Volné karty] činnosti - Uživatelské triggery
Karta | Název volné karty
Popis | Popis volné karty

    Mřížka [Atributy volné struktury] činnosti - Uživatelské triggery

    Mřížka [Atributy volné struktury] činnosti - Uživatelské triggery
Název | Název atributu volné karty
Návěští | Návěští atributu volné karty
Poznámka | Poznámka atributu volné karty

    Mřížka [Volné pohledy] činnosti - Uživatelské triggery

    Mřížka [Volné pohledy] činnosti - Uživatelské triggery
Pohled | Identifikace volného pohledu
Popis volného pohledu | Popis volného pohledu

    Mřížka [Užití volné karty] činnosti - Uživatelské triggery

    Mřížka [Užití volné karty] činnosti - Uživatelské triggery
Uživatel | Jméno uživatele systému
Poprvé | Datum prvního užití volné karty
Naposledy | Datum posledního užití volné karty
Počet | Celkový počet užití volné karty

    Atributy tisku

    Základní údaje
Karta | Název volné karty | SPVOLST_sp64nazev | C(8)
Popis | Popis volné karty | SPVOLST_sp64volstr | C(40)
Druh | Identifikace druhu implemetačního rozšíření | SPVOLST_spa6id | C(6)
Název druhu | Název druhu implemetačního rozšíření | SPCINDVT_spa6nazdru | C(40)
Druh | Druh volné karty - pro přístup uživatele | SPVOLST_sp66id | C(6)
Název druhu volné karty | Název druhu volné karty | SPVOLSTT_sp66druhst | C(40)
Velikost | Umožnit změnu velikosti okna - Ne/Horizontálně/Vertikálně/Oběma směry - horizontálně i vertikálně | Výpočet | C(39)
Posuvník | Posuvník okna volné karty Žádný/Horizontální/Vertikální/Oba horizontální i vertikální | Výpočet | C(29)
Autor | Zobrazovat informaci o autorovi záznamu Ano/Ne | Výpočet | C(27)
Dynamický nadpis | Dynamický nadpis | SPVOLST_sp64dcapti | M
Znovu načítat | Po vstupu volné karty znovu načíst kartu | Výpočet | C(3)
Založil | Jméno uživatele systému | BWUZIVA1_bw01jmeno | C(17)
Vznik | Datum vzniku volné karty | SPVOLST_sp64datum | T
Skript | Kód v jazyce Foxpro provedený před zápisem dat volné karty | SPVOLST_sp64script | M
Komentář | Komentář k volné kartě | SPVOLST_sp64koment | M
Název druhu volné karty | Název druhu volné karty | SPVOLSTT2_sp66druhst | C(40)
Uživatel | Jméno uživatele systému | BWUZIVA2_bw01jmeno | C(17)

    Při pohybu v Atributy volné karty
Název | Název atributu volné karty | SPVOLSTA_sp65nazev | C(10)
Druh | Druh volné karty - pro přístup uživatele | SPVOLSTA_sp66id | C(6)
Poř. | Pořadí atributu volné karty | SPVOLSTA_sp65poradi | N(3)
Typ | Typ atributu volné karty | Výpočet | C(13)
Třída | Třída ovládacího prvku | Výpočet | C(16)
Návěští | Návěští atributu volné karty | SPVOLSTA_sp65label | C(60)
Poznámka | Poznámka atributu volné karty | SPVOLSTA_sp65mess | C(60)
Inicializace | Inicializační hodnota atributu volné karty | SPVOLSTA_sp65init | M
Validace | Script validace v jazyce Foxpro | SPVOLSTA_sp65valid | M
Podmínka | Podmínka vstupu atributu | SPVOLSTA_sp65when | M
P.oknu | Přizpůsobovat oknu | Výpočet | C(12)
Zobrazení | Text pro zaškrtávací políčko nebo seznam hodnot pro překryvný seznam oddělených čárkou | SPVOLSTA_sp65pict | M
Zdroj | Vyvolání činnosti na klávesu F2 | SPVOLSTA_bw02krok | C(6)

    Při pohybu v Užití volné karty
Poprvé | Datum prvního užití volné karty | SPVOLSTU_spe7dat1 | D
Naposledy | Datum posledního užití volné karty | SPVOLSTU_spe7dat2 | D
Počet | Celkový počet užití volné karty | SPVOLSTU_spe7pocet | N(6)

    Při pohybu v Volné pohledy
Pohled | Identifikace volného pohledu | SPVOLSTV_sp75id | C(6)
Dotaz | Dotaz volného pohledu | SPVOLSTV_sp75select | M
Návratové hodnoty | Návratové hodnoty zdrojového formuláře | SPVOLSTV_sp75atrret | M
Formální parametry | Formální parametry dotazu | SPVOLSTV_sp75atrfor | M
Popis volného pohledu | Popis volného pohledu | SPVOLSTV_sp75volpoh | C(40)
Poznámka | Poznámka | SPVOLSTV_sp75koment | M

    Viz.také

    Editovat kód vlastnosti | Design vstupního formuláře | Kontrolní kompilace | Generování tabulky | Knihovny vkládaného kódu | Definice maker | Překlad popisek | Generovat triggery tabulky | Nastavení sledování změn tabulek | Uživatelské triggery | Druhy implementačních rozšíření | Druhy volných karet | Výběr makra | Obecné výběry | Vstupní formulář volné karty


Generování tabulky

Popis

Tuto činnost musí uživatel spustit vždy po nadefinování nové volné karty. Generování tabulky slouží uživateli k vytvoření datových struktur.


Vstupní formulář volné karty

Popis

Vzhled volné karty je dán uživatelským designem (menu Volby nebo klávesa F6 - „design vstupního formuláře“), který určuje to, jak budou jednotlivé atributy volné karty rozmístěné v okně volné karty. Pokud to daná činnost umožňuje, lze vyvolat kteroukoliv volnou kartu po stisku menu Obecné a pak si příslušnou volnou kartu vybrat podle toho, zda se jedná o volnou kartu procesu, operace apod.

Formulář

Formulář činnosti - Znovu načíst
Jednoznačná časová identifikace pro pracovní soubory = plněna SYS(2015)

Vyvolávané činnosti

K. | Činnost | Popis
F5 | Ponechat na obrazovce | Ponechat na obrazovce
F6 | Znovu načíst |

Viz.také

Ponechat na obrazovce | Znovu načíst


Druhy hodnot

Popis

Jsou to hodnoty v naturálním a finančním vyjádření, které chce uživatel sledovat (např. aktuální stav materiálu na skladě nebo stav peněz na účtě). Některé druhy hodnot mohou být i saldokontní. Druhy hodnot se definují v činnosti "komponenty" po vyvolání této příslušné činnosti (klávesa F7). Zadávají se tyto údaje:

¨ druh - identifikace druhu a název druhu hodnoty

¨ vstupní hodnota - vstupní hodnotou může být množství nebo celková cena. Pokud daná hodnota nesleduje ani množství, ani celkovou cenu, zadává se 1.

¨ aktualizuje - může být aktuální, statistická, saldokontní nebo obrat. Při zadání aktuální tento druh hodnoty aktualizuje celkový stav druhu hodnoty v celé komponentě. Při zadání statistická, aktualizuje statistickou hodnotu, která je plněna dávkově. Zadáním saldokonta se aktualizují saldokontní hodnoty. Hodnotu obrat lze definovat pouze ke zjištění obratů skladu a změny stavu peněz. Hodnoty, které se týkají obratů sledují logické věci za určité období. U obratu a statistické hodnoty je možno určit, jakým způsobem se bude tato hodnota při přepočtu počítat. Pokud uživatel u některé statistické hodnoty (např. průběh prodeje) potřebuje znát její podrobnější evidenci, zatrhne příznak "den do statistické hodnoty". Evidence statistických hodnot je pak provedena po jednotlivých dnech. Pokud tato možnost není zatržena, probíhá evidence statistických hodnot po měsících, systém počítá vždy s prvním dnem v měsíci, za který danou hodnotu sesumuje. Na stejném principu funguje i obrat s příznakem "den do hodnoty obratu".

¨ druh saldokontní hodnoty - jedná se pouze o hodnoty, které sledují saldokonto. U každého druhu hodnoty se pak definuje komponenta a operace, které se hodnota týká a výpočet. Pak např. druh hodnoty "množství vydané ze skladu" u procesu výdejka má následující složení:

- operace výdejka - druh hodnoty je množství vydané ze skladu a výpočet je "+"

- operace dodání - druh hodnoty je množství vydané ze skladu a výpočet je "-"

¨ podmínka - umožňuje zadat, za jaké podmínky se tento druh hodnoty má počítat. Např. u druhů hodnot v obchodě je možno zadat, že druh hodnoty se má počítat pouze tehdy je-li vztah artiklu k účetnictví zboží. Pokud uživatel nechce vstupovat žádnou podmínku, vybere v překryvném seznamu "hvězdičku".

Potom se u druhu hodnoty zadává, zda má rozlišovat adresáta, artikl nebo umístění. Např. při druhu hodnoty neuhrazeno nás určitě zajímá adresát (který nám dluží), ale nezajímá nás artikl a umístění (tzn., že artikl a umístění budou mít tento příznak zatržen).

Datový model

  • SPSTATDI Druh hodnoty
    • BWUZIVAT Uživatel systému
    • SPSTATDS Druh saldokontní hodnoty procesu

    • Vyvolávané činnosti

    K. | Činnost | Popis
F7 | Diagram procesu | Zobrazení diagramu procesu
F2 | Druhy operací | Přehled druhů operací
F2 | Druhy procesů | Přehled druhů procesů
F2 | Druhy saldokontních hodnot | Druhy saldokontních hodnot procesu

    Formulář

    Formulář činnosti - Druhy operací
Mřížka [Druhy informací]
Druh | Identifikace druhu hodnoty
 | Název druhu hodnoty
Listovací rámeček
Stránka #1 Druhy hodnot
Vstupní hodnota | Vstupní hodnota druhu hodnoty
Aktuální | Aktualizuje aktuální stav ?
Obrat | Aktualizuje obraty ?
Statistická | Aktualizuje statistické hodnoty ?
Saldokonto | Sledovat saldokonto
Den do hodnoty obratu | Zahrnout den do hodnoty obratu
Den do statistické hodnoty | Zahrnout den do statistické hodnoty
Druh saldokontní hodnoty | Identifikace druhu saldokontní hodnoty procesu
 | Název druhu saldokontní hodnoty procesu
Nerozlišuje adresáta | Agregovat za adresáta
Nerozlišuje artikl | Agregovat za artikl
Nerozlišuje umístění | Agregovat za umístění
Podmínka | Podmínka statistické hodnoty
Založil | Jméno uživatele systému
 | Datum založení druhu hodnoty
Poznámka | Poznámka k druhu hodnoty
Stránka #2 Výskyt hodnoty
Mřížka [Výskyt hodnoty]
Operace | Identifikátor druhu operace
 | Název druhu operace
+/-/PV | Výpočet +=příjem, -=výdej, PV=podle atributu vyjadřující příjmovou/výdajovou událost (pokud existuje pro komponentu)
V procesu | Identifikátor druhu procesu
 | Název druhu procesu

    Mřížka [Druhy informací] činnosti - Druhy operací

    Mřížka [Druhy informací] činnosti - Druhy operací
Druh hodnoty | Identifikace druhu hodnoty
Název druhu hodnoty | Název druhu hodnoty

    Mřížka [Výskyt hodnoty] činnosti - Druhy operací

    Mřížka [Výskyt hodnoty] činnosti - Druhy operací
Operace | Identifikátor druhu operace
Název druhu operace | Název druhu procesu
+/-/PV | Výpočet +=příjem, -=výdej, PV=podle atributu vyjadřující příjmovou/výdajovou událost (pokud existuje pro komponentu)
V procesu | Druh hodnoty se uplatní pouze pro druh hlavního procesu
Název druhu procesu | Název druhu procesu

    Atributy tisku

    Základní údaje
Komponenta | Identifikace komponenty | SPSTATDI_sp06idsubs | C(3)
Druh hodnoty | Identifikace druhu hodnoty | SPSTATDI_sp67id | C(3)
Název druhu hodnoty | Název druhu hodnoty | SPSTATDI_sp67druinf | C(40)
Aktuální | Aktualizuje aktuální stav ? | Výpočet | C(3)
Statistická | Aktualizuje statistické hodnoty ? | Výpočet | C(3)
Saldokonto | Sledovat saldokonto | Výpočet | C(3)
Obrat | Aktualizuje obraty ? | Výpočet | C(3)
Nerozlišuje adresáta | Agregovat za adresáta | Výpočet | C(3)
Nerozlišuje artikl | Agregovat za artikl | Výpočet | C(3)
Nerozlišuje umístění | Agregovat za umístění | Výpočet | C(3)
Den do statistické hodnoty | Zahrnout den do statistické hodnoty | Výpočet | C(3)
Den do hodnoty obratu | Zahrnout den do hodnoty obratu | Výpočet | C(3)
Podmínka | Podmínka statistické hodnoty | SPSTATDI_sp67vyber | N(1)
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum založení druhu hodnoty | Datum založení druhu hodnoty | SPSTATDI_sp67datum | T
Poznámka | Poznámka k druhu hodnoty | SPSTATDI_sp67koment | M
Název druhu operace | Název druhu operace | SPTYP_sp07text | C(30)
Název druhu procesu | Název druhu procesu | SPTYP26_sp07text | C(30)

    Při pohybu v Hodnoty v operacích
Druh operace | Identifikátor druhu operace | SPTYPAL_sp07idtyp | C(6)
+/-/PV | Výpočet +=příjem, -=výdej, PV=podle atributu vyjadřující příjmovou/výdajovou událost (pokud existuje pro komponentu) | Výpočet | C(2)
V procesu | Identifikátor druhu procesu | SPTYPAL_sp07idtypd | C(6)

    Viz.také

    Diagram procesu | Druhy operací | Druhy procesů | Druhy saldokontních hodnot


Spustit přepočet

Popis

Uživatel si z levého sloupce vybere komponentu, u níž chce provést přepočet statistických hodnot a pomocí šipky ji převede do pravého sloupce. V dolní části okna uživatel určuje které hodnoty dané komponenty chce přepočítat. Následně stiskne tlačítko "přepočet". Systém provádí ještě kontrolní dotaz, zda opravdu pustit přepočet a po potvrzení volby Ano je přepočet spuštěn a následně systémem podáno informativní hlášení, že přepočet byl dokončen.


Storno procesu

Popis

Je jedním z nástrojů opravy dat fyzických procesů, který opravu téměř plně dokumentuje i autorizuje. Ke stornovanému procesu storno vždy vytvoří proces stornující ve stejné číselné řadě a ve stejné struktuře operací jako má stornovaný proces. Stornovaný proces lze poznat:

¨ v přehledu procesů je vedle názvu procesu uveden příznak „stornovaný“

¨ v diagramu procesu je vedle názvu procesu v závorce uvedeno „stornovaný“

¨ ve stromu hlavního procesu má tento proces před svou identifikací červený znak a v závorce uvedeno velké písmeno S – (S)

Diagram stornovaného procesu lze částečně modifikovat, což je možno považovat za chybu IS, z hlediska udržení korektnosti dat toto není vhodné, tzn. nedoporučujeme uživateli korigovat diagram stornovaného procesu.

Storno stornovaného (stornujícího) procesu není možné.

Stornující proces lze poznat:

¨ v přehledu procesů je vedle názvu procesu uveden příznak „stornující“

¨ v diagramu procesu je vedle názvu procesu v závorce uvedeno „stornující“

¨ ve stromu hlavního procesu má tento proces před svou identifikací červený znak a v závorce uvedeno malé písmeno S – (s)

Rovněž diagram stornujícího procesu lze částečně modifikovat, což je možno považovat za chybu IS, z hlediska udržení korektnosti dat toto není vhodné, tzn. nedoporučujeme uživateli korigovat diagram stornujícího procesu.

Ke stornovaným ukončeným operacím storno vytvoří stornující operace s inverzními (tj. opačnými) událostmi a neukončené operace stornovaného procesu zruší. Operace komponent pošta, vývěska a zprávy ve stornovaném procesu ruší vždy (na jejich stavu nezáleží), k vytvoření inverzních operací dochází pouze v případě, že mají nastaveno zrcadlové storno (činnost druhy operací – záložka Další).

Storno procesu se provádí v činnosti Procesy a operace – Procesy, kde si uživatel daný proces vyhledá, z menu Volby nebo ze stromu hlavního procesu po stisku pravého tlačítka myši. U storna je důležité vědět, že vybraný proces je nutno začít stornovat od jednotlivých podprocesů (tzn. ve stromu hlavního procesu odzdola). Pokud by uživatel nevystornoval nejprve podřízené procesy (podprocesy), systém podává informativní hlášení typu: „Proces není možné stornovat, protože obsahuje odkazy na nestornované procesy“.

Např. máme-li proces vystavená faktura (č.1), který obsahuje operace dodání a procesy DPH (č.2) a plateb (č.3), je nutno nejprve vystornovat proces plateb (č.3), pak proces DPH (č.2) a nakonec vlastní proces vystavené faktury (č.1), přičemž ke všem procesům bude vytvořen proces stornující a k operaci dodání bude vytvořena inverzní operace.

Stejně se systém chová, pokud uživatel stornuje proces, kde je použita dynamická vazba (např. ZSP - platby). I tento proces se naprosto v pořádku vystornuje, přičemž dynamická vazba je tímto zrušena (tzn. dojde k odpárování platby apod.). V případě, že se stornuje proces, kde má druh operace nastaven určité parametry operace komponenty, tak i v tomto případě se storno chová naprosto korektně (vrátí stav).

Např. pokud máme proces, kde po objednávce následuje dodací list a jeho ukončením dostávají události na objednávce stav „vykrytá“, tak po stornu tohoto dodacího listu se události objednávky vrátí zpět do stavu „nevykrytá“.

Pokud má uživatel vyhledán proces, který potřebuje stornovat, aktivuje z menu Volby činnost Storno procesu. Jako další se zobrazuje následující:

¨ informativní tabulka, jaký proces bude stornován, včetně informace, která operace bude zrušena, a která bude mít vytvořenu inverzní operaci. Uživatel má volbu OK – Storno. Po potvrzení volby OK následuje:

¨ zápis stornujícího procesu – popis procesu, komentář ke stornu a atribut „vzniknou události operací s datem“. Uživatel zvolí možnost Zapsat, zobrazí se mu ještě jedno upozorňující hlášení typu „Opravdu stornovat proces ….“?. Po potvrzení volby Ano je daný proces vystornován (získává příznak stornovaný) a je vytvořen další proces stornující.

Při stornování jednotlivých fyzických procesů jsou stornující procesy (tzn. jejich operace a události) zapsány s aktuálním systémovým datem (u storna není možno využít atribut „aktuální datum uživatele“ z parametrů uživatele). Stornující procesy nelze zapsat s datem původních událostí. Pokud by uživatel potřeboval stornovat proces s jiným datem než aktuálním systémovým, využije možnosti, které mu nabízí atribut „vzniknou události operací s datem“, který při vlastním provádění storna zaškrtne, tím se mu zpřístupní políčko pro zadání nového data a události stornujících operací jsou pak zapsány s tímto datem. Jediný problém může nastat v případě, kdyby uživatel zadal datum, které spadá do uzavřeného období komponenty, jejíž operace je součástí stornovaného procesu, pak systém včas (než cokoliv zapíše) hlásí: „Operaci … (dané číslo) není možné stornovat, protože by vznikl zápis do neotevřeného období komponenty“. Tuto možnost se změnou data storna by měl využívat pouze zkušený uživatel a ještě i s vědomím účetní, protože může dojít k „rozhození“ invetury k datu (tj. operativní evidence versus účetnictví). Možnost využívat tuto změnu datumu lze potlačit pomocí parametru „Storno_k_datu=0“, který potlačuje možnost vyplnit toto datum (hlavní menu – Systém – Nastavení programu BM).

V případě storna procesu založeného procesním importem se tento stále chová jako již importovaný. Pokud jej chceme znovu importovat, je nutno pozměnit definici jednoznačné identifikace procesního importu.

Stornování procesu je vázáno na přístupová práva, která se řídí následujícími pravidly:

¨ uživatel, který nemá právo k založení druhu procesu, nemůže proces tohoto druhu stornovat

¨ uživatel, který nemá právo k činnosti „storno procesu“ vyvolávané z formuláře „procesy“, nemůže provádět zrušení stavu ukončena žádné operace (z formuláře „vlastnosti operace“), ani mu není umožněno stornovat proces ve „stromu hlavního procesu“

¨ uživatel, který nemá právo k činnosti „diagram procesu“ vyvolávané z formuláře „procesy“, nemá dostupnou možnost vyvolat diagram procesu z formulářů událostí operací komponent ani ze stromu hlavního procesu

¨ uživatel, který nemá právo k činnosti „strom hlavního procesu“ vyvolávané z formuláře „procesy“, nemá dostupnou možnost vyvolat strom hlavního procesu z formulářů událostí operací komponent


Vyvolání operace

Popis

Po zařazení "definice vyvolání" uživatel spustí činnost "vyvolání operace" , kde je předplněn rok a identifikace datového úložiště. Číslo procesu zadává uživatel sám. Toto číslo procesu může nahrazovat i variabilní symbol.

Činnost vyvolání operace lze provést buď přímo z činnosti "definice vyvolání" výběrem této činnosti z menu "volby" anebo dvojklikem na vybranou definici vyvolání, které jsou zobrazeny pod činností "napojení do procesu".

Formulář

Formulář činnosti - Přístupová práva
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu


Strom hlavního procesu

Popis

Strom hlavního procesu je další ze způsobů zobrazení rozpracovanosti procesu. Diagram procesu poskytuje uživateli grafické zobrazení, strom hlavního procesu je jakési schéma struktury fyzického procesu. Uživatelsky změnit zobrazení a ovládání hlavního menu lze pomocí činnosti „nastavení stromu“. Tuto činnost uživatel aktivuje po stisku pravého tlačítka myši na názvu činností ve stromu hlavního procesu nebo kdekoliv ve volném prostoru stromu hlavního procesu.

Strom hlavního procesu je možno aktivovat po stisku tlačítka F6 nebo volbou příslušné činnosti z menu Volby. Zobrazuje všechny uzly, přičemž u každého uzlu je díky značce před názvem částečně viditelný i jeho stav (červená barva – zatím se s operací nepracovalo, žlutá barva - operace připravena, zelená barva – připravena a zahájena, křížek - operace ukončena). Každý uzel ve stromu procesu má po stisku pravého tlačítka myši dostupné své vlastnosti. Tyto vlastnosti jsou odlišné na základě toho, zda se jedná o uzel typu operace nebo o uzel typu proces.

Na záložce Další v činnosti „Druhy operací“ je možno nastavit, které uzly (tj. operace) se budou ve stromu hlavního procesu zobrazovat. Ve většině případů bude zřejmě nastaveno Ano, volba Ne se typicky použije pro druhy operací, které se definují v diagramu procesu pouze pro umožnění odblokování operace.

U každého uzlu ve stromu hlavního procesu se zobrazuje informace, kdo operaci zahájil a ukončil. Může nabývat stavu:

¨ operace byla zahájena a nebyla dosud ukončena (tvar: jméno uživatele, datum a čas zahájení)

¨ operace byla zahájena a ukončena stejným uživatelem v jednom dni (tvar: jméno uživatele, datum a čas zahájení – čas ukončení)

¨ operace byla zahájena ukončena stejným uživatelem v jiném dni (tvar: jméno uživatele, datum a čas zahájení, datum a čas ukončení)

¨ operace byla zahájena a ukončena jiným uživatelem v jednom dni (tvar: jméno uživatele, datum a čas zahájení, čas ukončení, jméno uživatele)

¨ operace byla zahájena a ukončena jiným uživatelem v jiném dni (tvar: jméno uživatele, datum a čas zahájení, datum a čas ukončení, jméno uživatele)

Pod uzlem (operace, proces) stromu hlavního procesu je možno vidět vše co je s uzlem spojeno:

¨ napojené dokumenty k procesu nebo operaci. Pro uzly ve stromu hlavního procesu se uplatňuje totožná funkčnost jako ve formuláři „Spojené dokumenty“ (tj. mj. stejné menu po pravém kliku klávesu myši, možnost připojovat navazující dokumenty, zobrazení zařazení dokumentu do kategorie jako složky stromu, apod.). Při přenášením souboru tažením myší do stromu hlavního procesu je možné dokument připojit také k jinému objektu BM, než jsou objekty procesů resp. operací.

¨ zprávy - pod uzlem operace nebo procesu má uživatel možnost vidět zprávy, které byly o operaci odeslány (pravý klik na operaci „odeslat zprávu o operaci“). Jednotliví aktuální uživatelé vidí pouze ty zprávy, jichž jsou sami autory nebo příjemci. Po pravém kliku myši přímo na řádku zprávy ve stromu je možno vyvolat činnost „zobrazit zprávu“. Po její aktivaci se spustí formulář s danou událostí zprávy. Zobrazované zprávy však můžou být vytvořeny už přímo při vytváření událostí operace (pod menu Volby na událostech komponent je možnost „odeslat zprávu o operaci“). Operace, ke kterým je současně vytvořena zpráva je pak možné vyhledávat ve formuláři operací se zaškrtnutou možností „zobrazit=spojené se zprávami“.

¨ volné karty – zobrazují se volné karty definované u odpovídajících druhů procesů a operací. Na uzlu představujícím volnou kartu je možné dvojklikem spustit formulář volné karty, ovšem pouze na prohlížení, udané hodnoty není možno nijak měnit.

Pokud se jedná o uzel typu operace, jsou po stisku pravého tlačítka myši dostupné tyto možnosti:

¨ obnovit - po stisku tohoto tlačítka se aktualizují (obnoví) změny provedené v mezičase (stejné jako činnost „znovu načíst")

¨ navazující dokument – možnost pomocí volby (Nový dokument, Načíst dokument) připojit dokument k danému objektu

¨ diagram procesu - zobrazí se diagram daného hlavního procesu (stejné jako klávesa F7 nebo příslušná činnost pod menu Volby)

¨ proces – aktivuje se výběrová záložka činnosti „procesy“

¨ stornovat proces - umožňuje stornovat proces, jehož součástí daná operace je. Avšak i zde platí zásada, že procesy je nutno stornovat postupně - od posledního po ten první.

¨ spustit operaci - aktivuje se daný uzel typu operace. Pokud ještě nebyla tato operace spuštěna, je tímto spuštěna poprvé, pokud již byla zahájena, uživatel má možnost si ji po aktivaci této možnosti prohlédnout (stejné jako klávesa F9 nebo příslušná činnost pod menu Volby)

¨ odeslat zprávu o operaci - umožňuje odeslat zprávu k dané operaci. Je možno vybrat jednoho nebo více příjemců zprávy, připsat krátký text a po stisku OK je zpráva odeslána. Tato zpráva se pak zobrazuje ve stromu hlavního procesu napojená pod danou operací. Dostupná je autorovi zprávy a jejím příjemcům. Zprávu k operaci je možno vytvořit v jednotlivých událostech komponent, kde pod menu Volby má uživatel možnost "Odeslat zprávu o operaci". V případě, že uživatel umístí ve stromu kurzor na řádek s danou zprávou, má po pravém tlačítku myši k dispozici volbu "zobrazit zprávu".

¨ události operace - výběrem této možnosti se zobrazí krátký popis událostí dané operace. Na takto zobrazených událostech je možno po stisku pravého tlačítka zvolit: obnovit, diagram procesu, spustit operaci, míra plnění - předchůdci a míra plnění - následníci (zobrazují se události různých komponent, z kterých byla událost odvozena, resp. které vyvolala, a na nich je zase možné vyvolat předchůdce a následníky podle míry plnění), vlastnosti operace.

¨ vlastnosti operace - uživatel má k dispozici přehled nejaktuálnějších informací o operaci - název, druh, její stav apod.

Pokud se jedná o uzel typu proces, jsou po stisku pravého tlačítka myši dostupné tyto možnosti:

¨ obnovit - po stisku tohoto tlačítka se aktualizují (obnoví) změny provedené v mezičase (stejné jako činnost „znovu načíst")

¨ navazující dokument – možnost pomocí volby (Nový dokument, Načíst dokument) připojit dokument k danému objektu

¨ diagram procesu - zobrazí se diagram daného hlavního procesu (stejné jako klávesa F7 nebo příslušná činnost pod menu Volby)

¨ proces - aktivuje se výběrová záložka činnosti „procesy“

¨ stornovat proces

¨ kopírovat odkaz na proces - ve stromu hlavního procesu je možno u položky typu proces po stisku pravé myši aktivovat činnosti „kopírovat odkaz na proces" (obdoba Windows příkazu Ctrl+C) a tento odkaz je možno k jinému procesu přiřadit (obdoba Windows příkazu Ctrl+V) opět po stisku pravého tlačítka myši na položce procesu, ke kterému chceme zkopírovaný odkaz přiřadit, a to volbou „napojit proces", tzn. že k diagramu stávajícího procesu se přiřadí i tento napojený proces.

¨ osamostatnit proces - tato možnost vyřadí vybraný proces z daného nadřízeného procesu. Tato možnost se zobrazuje pouze u podřízených procesů.

Uzly stromu hlavního procesu, které jsou poduzly uzlu představujícího proces v hlavním procesu (ikona dopravní značky zákaz vjezdu do jednosměrné ulice nebo stop), jsou ve formuláři stromu doplňovány dynamicky v okamžiku rozbalení uzlu představujícího proces. Tím je umožněna dostatečně rychlá odezva při zobrazování stromů rozsáhlých procesů.

Při nastavení vlastnosti BM StromHP - dynamicke rozbalovani = 0 je strom hlavního procesu kompletně naplněn při startu formuláře stromu (ovšem za cenu pomalejší odezvy jeho zobrazení).

Ve stromech zobrazovaných ve formulářích spojené dokumenty, strom hlavního procesu a obdobných stromech formuláře okno úloh je možno implementačně doplnit definovatelné funkce pro menu, která jsou vyvolávána po stisku pravého tlačítka myši na uzlu představujícím objekt BM. Toto implementační doplnění je možno nadefinovat v činnosti „doplňující položky menu objektů“.

Formulář

Formulář činnosti - Menu formuláře
Strom hlavního procesu

Vyvolávané činnosti

K. | Činnost | Popis
F6 | Menu formuláře | Vyvolání menu formuláře

Viz.také

Menu formuláře


Skladba saldokontní hodnoty

Popis

Zobrazí se skladba aktuální saldokontní hodnoty daného procesu. Uživateli se zobrazují informace, jaké operace se tato hodnota týká, její druh, finanční nebo naturální hodnota a údaje o adresátovi, artiklu a umístění.

Formulář

Formulář činnosti - Strom hlavního procesu
Mřížka [Aktuální hodnoty proesu]
 | Rok v identifikaci procesu
 | Identifikace datového úložiště číselné řady procesu
 | Pořadové číslo procesu
 | Pořadí stejného druhu operace v jednom procesu
Operace | Identifikátor druhu operace
 | Název druhu operace
 | Datum události
 | Popis události
 | Identifikace komponenty
 | Identifikace druhu hodnoty
 | Název druhu hodnoty
Hodnota | Aktuální hodnota procesu
Adresát | Identifikace adresáta
 | Název adresáta
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Umístění | Umístění

Mřížka [Aktuální hodnoty proesu] činnosti - Strom hlavního procesu

Mřížka [Aktuální hodnoty proesu] činnosti - Strom hlavního procesu
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Číslo procesu | Pořadové číslo procesu
Druh operace | Identifikátor druhu operace
Pořadí | Pořadí stejného druhu operace v jednom procesu
Datum | Datum události
Popis | Popis události
Hodnota | Aktuální hodnota procesu
Komponenta | Identifikace komponenty
Druh hodnoty | Identifikace druhu hodnoty
Adresát | Identifikace adresáta
Druh artiklu | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Umístění | Umístění

Vyvolávané činnosti

K. | Činnost | Popis
F6 | Strom hlavního procesu | Zobrazení hlavního stromu procesu-operace
F7 | Diagram procesu | Zobrazení diagramu procesu
F9 | Spustit operaci | Spuštění zobrazené operace

Viz.také

Strom hlavního procesu | Diagram procesu | Spustit operaci


Druhy saldokontních hodnot

Popis

Jedná se o hodnoty, které jsou úzce svázány s druhy hodnot. Saldokontní hodnoty v podstatě uživatel využívá ke zjištění, zda je daný proces z hlediska procesního saldokonta dokončen. Např. je možno mít hodnotu "objednáno" a "dodáno". Pokud je objednáno např. 5 kusů určitého artiklu a dodány zatím 3 kusy určitého artiklu, tak proces je z hlediska procesního saldokonta nedokončen. A aby mohl právě toto uživatel sledovat, je nutno mít nadefinovány potřebné druhy saldokontních hodnot.

Datový model

  • SPSTATDS Druh saldokontní hodnoty procesu
    • BWUZIVAT Uživatel systému

    • Formulář

    Formulář činnosti - Strom hlavního procesu
Mřížka [Druhy saldokontních hodnot procesu]
Druh | Identifikace druhu saldokontní hodnoty procesu
 | Název druhu saldokontní hodnoty procesu
Založil | Jméno uživatele systému
 | Datum založení druhu saldokontní hodnoty procesu
Poznámka | Poznámka k druhu saldokontní hodnoty procesu

    Mřížka [Druhy saldokontních hodnot procesu] činnosti - Strom hlavního procesu

    Mřížka [Druhy saldokontních hodnot procesu] činnosti - Strom hlavního procesu
Druh | Identifikace druhu saldokontní hodnoty procesu
Název druhu | Název druhu saldokontní hodnoty procesu


Skupiny procesů / předloh výstupu

Popis

Skupiny procesů/předloh výstupu jsou nástroj (škatulka), který k sobě umožňuje přiřadit (shluknout) druhy procesů obvykle blízkých vlastností z pohledu uživatele. U každé skupiny se zadává její identifikace a název.

Možnost definice skupin slouží uživatelům pro organizaci menu, které se mu nabízí po spuštění činnosti Nový proces. Zde se uživatelům nabízí všechny nadefinované procesy nezařazené do skupiny. Protože by mohla nastat situace, kdy by se časem toto menu příliš naplnilo a stalo se nepřehledné, je vhodnější např. procesy dle jednotlivých komponent nebo dle organizační struktury sdružit do určité skupiny. Při spuštění činnosti Nový proces se pak budou uživatelům nabízet nejprve skupiny procesů, ze kterých si dvojklikem nebo stiskem klávesy Enter vybraný proces spustí.

Kromě možnosti nadefinování skupin procesů slouží tato činnost k definici skupin předloh výstupu a k definici osobní skupiny předlohy výstupu. V této činnosti se pouze definují a určují jejich vlastnosti, jejich použití je při definici metapředloh výstupu a ve vlastnostech předloh výstupu. Význam těchto skupin spočívá v tom, že jednotlivé předlohy výstupu je možno zařazovat a třídit podle zvolených skupin, navíc pak každý uživatel může mít ještě i osobní skupinu předloh výstupu.

U každé nadefinované skupiny lze pak volbou Ano/Ne z překryvného seznamu nastavit její uplatnění:

¨ skupina procesu – použití pro procesy (Ano/Ne)

¨ skupina předloh výstupu – použití pro předlohy výstupu ve vlastnostech předlohy (Ano/Ne)

¨ osobní skupina předlohy výstupu – použití pro určení osobní skupiny předlohy výstupu (Ano/Ne)

Skupiny procesů se definují pouze v činnosti Druhy procesů - atribut skupina po stisku klávesy F2, ikony výběr nebo stisku pravého tlačítka myši přímo na atributu. Se zařazením procesů do jednotlivých skupin částečně souvisí i nastavení atributu „použití“ u druhu procesu. Pokud je nastaveno zobrazovat v menu, druh procesu se zobrazuje v činnosti Nový proces a je možno ho kdykoliv zařadit do zvolené skupiny, pokud je zde nastaveno nezobrazovat v menu, v činnosti Nový proces se pak tento druh procesu vůbec nevyskytuje a není smysluplné ho zařadit do skupiny. Možnost nezobrazovat využije uživatel zejména pokud definuje složitější proces, který se skládá nejen z operací, ale i z dalších procesů. Potom u vrcholného procesu zadá možnost zobrazit v menu a u procesů, které jsou součástí tohoto vrcholného procesu nastaví nezobrazovat v menu. Ty se pak spouští buď automaticky nebo napojením do procesu.

Datový model

  • SPTYPFOL Skupina procesů / předloh pro zobrazení v menu
    • BWUZIVAT Uživatel systému

    • Formulář

    Formulář činnosti - Překlad názvu umístění nebo druhu
Mřížka [Skupiny procesů]
Skupina | Identifikace skupiny procesů
 | Název skupiny procesů
Skupina procesu | Použití pro procesy Ano/Ne
Skupina předlohy výstupu | Použití pro předlohy výstupu ve vlastnostech předlohy Ano/Ne
Osobní skupina předlohy výstupu | Použití pro určení osobní skupiny předlohy výstupu Ano/Ne
Založil | Jméno uživatele systému
 | Datum založení
Poznámka | Poznámka ke skupině procesů

    Mřížka [Skupiny procesů] činnosti - Překlad názvu umístění nebo druhu

    Mřížka [Skupiny procesů] činnosti - Překlad názvu umístění nebo druhu
Skupina | Identifikace skupiny procesů
Název skupiny | Název skupiny procesů
Skupina procesu | Použití pro procesy Ano/Ne
Skupina předlohy výstupu | Použití pro předlohy výstupu ve vlastnostech předlohy Ano/Ne
Osobní skupina předlohy výstupu | Použití pro určení osobní skupiny předlohy výstupu Ano/Ne

    Vyvolávané činnosti

    K. | Činnost | Popis
- | Překlad názvu umístění nebo druhu | Překlad názvu umístění nebo druhu

    Atributy tisku

    Základní údaje
Skupina | Identifikace skupiny procesů | SPTYPFOL_sp79id | C(6)
Název skupiny | Název skupiny procesů | SPTYPFOL_sp79folder | C(40)
Skupina procesu | Použití pro procesy Ano/Ne | Výpočet | C(3)
Skupina předlohy výstupu | Použití pro předlohy výstupu ve vlastnostech předlohy Ano/Ne | Výpočet | C(3)
Osobní skupina předlohy výstupu | Použití pro určení osobní skupiny předlohy výstupu Ano/Ne | Výpočet | C(3)
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(30)
Datum založení | Datum založení | SPTYPFOL_sp79datzal | T
Poznámka | Poznámka ke skupině procesů | SPTYPFOL_sp79koment | M

    Viz.také

    Překlad názvu umístění nebo druhu


Spojené dokumenty

Popis

Přes vybraný objekt (vývěska, zprávy, události komponent) je možno spojit přes klávesu Ctrl D (nebo menu Volby – Dokumenty) jakýkoliv dokument. Vyvolání formuláře bylo zatím možné pouze z formulářů pro vstup objektů BM (události, artikly, adresát, ..). V IS BM je možné připojovat dokumenty i k záznamům tabulek, které nejsou objekty BM. Spojení s dokumentem čili existence vazby objekt - dokument se pak jako jiné objektové vazby ukazuje v rámečku souvislostí pomocí znaménka plus. Po stisku klávesy Ctrl D se uživateli zobrazí rámeček „spojené dokumenty“. Zde má k dispozici dokumenty objektu, procesu, operace, adresáta a artiklu. V případě potřeby vytvoření objektové vazby (např. navázání smlouvy na událost vývěsky) se využijí dokumenty objektu. Dokumenty procesu a operace se napojují automaticky, pokud dokument vzniká jako součást (je nadefinovaný v diagramu procesu) procesu nebo operace. Pod dokumenty adresáta se nejčastěji ukládají dokumenty, které jsou přímo svázány s daným adresátem, např. smlouvy, ceníky adresáta apod. Pod složkou artikl jsou obsaženy události artiklu, který je aktuální na události, ze které si uživatel spojené dokumenty vyvolal.

Další složky, které jsou dostupné pod dokumenty adresáta jsou:

¨ kategorie adresáta – ukazuje se přehled kategorií, ve kterých je daný adresát zařazen

¨ procesy adresáta – ukazuje se strukturovaný přehled procesů, které byly založeny pro daného adresáta (roky – číselné řady – jednotlivé procesy)

¨ události adresáta – ukazují se události jednotlivých komponent, ve kterých je adresát uveden

Menu události adresáta a události artiklu se po spuštění činnosti spojené dokumenty zobrazuje zabalené (tzn. před jeho názvem je znaménko +) a napsané v závorkách. V tomto případě uživatel nedokáže rozpoznat, jestli adresát či artikl některé události obsahuje. Musí nabídku událostí nejprve rozbalit, tzn. kliknout na znaménko +. A pak se mu zobrazují pouze události komponent, ve kterých je adresát nebo artikl obsažen. Události jednotlivých komponent se v nabídce zobrazují podle druhu události, tzn. že např. v událostech změny stavu peněz může mít adresát uvedeno 12 událostí pohybu příjem do pokladny a 15 událostí pohybu úhrady předepsaných plateb. V případě, že uživatel nechá nabídku složky události adresáta nebo artiklu rozbalenou a takto ukončí činnost spojené dokumenty, tak při následujícím spuštění spojených dokumentů jsou tyto složky ve stavu rozbaleno.

Tyto menu se dají ovládat i pomocí myši:

¨ pravý klik na složce kategorie adresáta - vyvolání formuláře kategorií adresáta

¨ dvojí klik na konkrétní kategorii adresáta - vyvolání formuláře kategorií adresáta

¨ pravý klik na komponentě ve složce událostí - vyvolání formuláře odpovídajících událostí komponenty

¨ dvojí klik na druhu operace ve složce komponenty - vyvolání formuláře událostí komponenty (s předplněným výběrem daného druhu operace)

V případě potřeby vytvoření dokumentu uživatel postupuje následujícím způsobem. Kurzor umístí např. na dokumenty objektu (tzn. okno spojených dokumentů je aktivní) a po stisku pravého tlačítka myši se mu zobrazí volby:

¨ nový dokument – tuto možnost uživatel využije v případě, že vytváří úplně nový dokument. Při vytváření nového dokumentu musí nadefinovat jeho vlastnosti.

¨ načíst dokument – tuto možnost uživatel využije v případě, že již má dokument vytvořený, uložený mimo systém IS BM a chce tento dokument do systému přenést. Po aktivaci této činnosti uživatel určí cestu, odkud se má soubor načíst a pak už jen upřesní vlastnosti dokumentu (název, typ dokumentu a předlohy, příznak chráněného dokumentu). Je možno využít i možnosti externího uložení dokumentu. Po stisku OK je dokument načten a stává se součástí databáze IS BM (pokud nemá nadefinováno externí uložení).

¨ uložit obrázek v clipboardu – tato možnost umožňuje připojit jako dokument obrázek, který má uživatel uložen v clipboardu, tzn. na určitém obrázku mimo IS BM uživatel potvrdí volbu kopírovat (Ctrl C) a po aktivaci této činnosti je obrázek vložen jako dokument IS BM. Tato možnost je pro uživatele aktivní, je-li v hlavním menu programu obsažen program PCT_DLL.DLL. Obrázek je ukládán ve formátu JPEG.

IS BM umožňuje přenášet soubory tažením myší (metoda „táhni a drž“) do okna spojených dokumentů např. z okna průzkumníka Windows (tažením myší není možné připojovat přílohy e-mailu). Stejným způsobem je možné připojovat dokumenty k procesům nebo operacím ve formuláři Strom hlavního procesu a objektům, které mají zobrazený připojený dokument (obrázek) na volné kartě prostřednictvím atributu volné karty typu „multimediální“.

Po přetažení souboru do IS BM se pak systém chová standardně jako při klasickém vytváření dokumentu BM. Je nutno zadat jeho vlastnosti (tzn. název, druh dokumentu apod.). Pokud je v okamžiku uvolnění tlačítka myši stisknuta na klávesnici klávesa Shift, potom se ve vlastnostech připojovaného dokumentu automaticky nastaví zaškrtnuté „externí uložení“ na záložce „uložení dokumentu“.

Při založení dokumentu tažením myší je ukládána v IS BM informace o názvu načteného dokumentu (ukládá se do tabulky SPDOKFIL). Při opakovaném načtení dokumentu stejného názvu je pak systémem zobrazen dotaz podobného typu jako:

„Dokument „........název.........“ byl již do BM načten. Načtení provedl(a) – jméno a datum. Má být dokument opakovaně načten do BM (volba Ano) nebo má být připojen tento dříve načtený dokument? (volba Ne)?

Po stisknutí tlačítka ANO je původní načtený dokument přepsán úplně novým dokumentem, po stisknutí tlačítka NE není zakládán nový dokument a je pouze vytvořena objektová vazba mezi objektem BM a dokumentem, který byl již dříve načten. Při stisku klávesy Storno se neprovede žádná akce.

Ve stromech spojených dokumentů je nyní možné individuálně si zvolit tvar popisu dokumentu ve stromu. To se provádí nastavením parametru BM Preferences->Skript_pro_popis_dokumentu, kterým se uvádí identifikace knihovny vkládaného kódu, jejíž kód bude spouštěn pro určení popisu dokumentu. Tento skript musí vracet textovou hodnotu a v okamžiku jeho provádění má k dispozici informace o dokumentu v kurzoru _DOCS, který obsahuje mj.atributy:

SP26

SP26DATUM

SP26NAZEV

SP26INDEX

SP57ID

SP57TYPDOK

SP01ID

SP01PREDLO

SP26SOUBOR

SP26DISK

BW01UZIV

BW01JMENO

BW01JMENOT

SP44PRISTU

Kromě popisu dokumentu ve stromu je možné změnit také ikonu dokumentu vložením názvu souboru ikony do proměnné _NODE.ICON.

Př.:

Do Case

Case sp26disk<>1

Case Empty(Sys(2000,(sp26soubor)+''))

_node.Icon='hotovo'

Case Inlist(Upper(Justext(sp26soubor)),'BMP','ICO','JPG','GIF')

_node.Icon=sp26soubor

Endcase

Return Trans(sp26datum)+' '+Trim(sp26nazev)+Iif(sp26disk=1,' ('+Justfname(sp26soubor)+')','')

Pokud uživatel u daného dokumentu sleduje verze, ukazují se pod názvem dokumentu ve stromovém zobrazení (tzn. po stisku znaménka +) i verze daného dokumentu. Dvojklikem je možno danou verzi otevřít. Po stisku pravého tlačítka myši na názvu revize dokumentu je možno verzi otevřít nebo zrušit. Přehled těchto verzí pod každým dokumentem se aktualizuje po aktivaci možnosti obnovit přehled verzí (viz. popis níže).

V případě, že uživatel už má několik dokumentů vytvořených a chce s dokumentem dále pracovat, vyvolá si stejně jako při založení přes klávesu Ctrl D okno „spojené dokumenty“ a umístí kurzor na vybraný název dokumentu. Po stisku pravého tlačítka myši na názvu dokumentu má uživatel k dispozici tyto možnosti:

¨ otevřít dokument – aktivuje spuštění dokumentu (stejného efektu lze dosáhnout dvojklikem levého tlačítka myši na názvu dokumentu).

¨ založit proces pošty – umožňuje vytvořit proces poštovní zásilky (nebo poštovní zásilky + zápis události na vývěsku), ke které je automaticky dokument připojen a po spojení s událostí pošty je možno využít vlastností mailmerge, tj. předplnění adresy adresáta z události pošty do dokumentu.

¨ založit proces e-mail – obdoba procesu pošty s tím rozdílem, že dokument se neposílá klasickou poštou, ale emailem. Uživateli se přesto zobrazí klasická operace pošty a po aktivaci činnosti „odeslat e-mail“ (menu Volby) se dokument odešle adresátovi z poštovní zásilky emailem. Podmínkou tohoto procesu je, že adresát musí mít v adresáři (ve spojeních) uvedeno e-mailové spojení (tzn. e-mailovou adresu).

¨ kopírovat dokument – umožňuje vytvořit kopii dokumentu. Kopii může uživatel vložit ke stejné události jako je kopírovaný dokument nebo může kopii dokumentu připojit k úplně jiné události. Na takové události uživatel vyvolá klávesou Ctrl D okno spojeného dokumentu a pravým tlačítkem myši např. na dokumentech objektu si vyvolá možnost „vložit dokument ..(jeho název).......“.

¨ uložit jako – možnost externího uložení dokumentu.

¨ uložit novou verzi dokumentu

¨ odeslat dokument – pokud je dokument spojen s událostí vývěsky, kde je uveden adresát, který má uvedeno emailové spojení, předplní se okno e-mailové pošty touto adresou s vloženým dokumentem. V případě, že není uveden adresát nebo nevlastní e-mailové spojení, otevře se e-mailová pošta s vloženým dokumentem, ale atribut KOMU zůstává prázdný.

¨ zrušit spojení s dokumentem – tato činnost ruší objektovou vazbu na událost, z které byl dokument vyvolán, tzn. událost nemá dále žádnou vazbu na tento dokument. Touto akcí je však zrušena pouze vazba, pokud by uživatel potřeboval zrušit dokument jako takový, je nutno si aktivovat činnost „dokumenty“ (menu Marketing – Dokumenty – Dokument), zde si příslušný dokument najít a pomocí klávesy F8 nebo ikony křížek tento dokument odstranit.

¨ kopírovat odkaz na dokument – v případě potřeby je možno vytvořit u vybrané události pouze odkaz na dokument, není nutno tento dokument přímo s událostí svazovat. Např. je vytvořen dokument adresáta „smlouva“ a uživatel na některé události vývěsky potřebuje vytvořit odkaz na tuto smlouvu. Potom na dokumentu smlouva aktivuje činnost kopírovat odkaz na dokument, přepne se na události vývěsky, vyvolá spojené dokumenty (Ctrl D) a po stisku pravého tlačítka myši na dokumentech objektu aktivuje možnost „spojit s dokumentem ..(jeho název).......“.

¨ prezentace dokumentu – možnost vytvoření prezentace (neboli optického náhledu) dokumentu.

¨ volné karty dokumentu

¨ volné karty vazby objektů

¨ obnovit přehled verzí – po aktivaci této možnosti se obnoví přehled verzí, který je součástí každého vytvořeného dokumentu o další uloženou kopii

¨ navazující dokument – zde je možno pomocí objektové vazby připojovat k danému dokumentu jeho následníky (možnost Nový dokument, Načíst dokument). Vytvořený následník se pak automaticky zařadí pod vlastní název dokumentu.

¨ vlastnosti dokumentu (viz. popis níže)

Vlastnosti dokumentu:

Při vytváření nového dokumentu musí nadefinovat jeho vlastnosti, tzn. na záložce „obecné“ určí název, typ dokumentu a předlohu dokumentu. K jednotlivým typů dokumentů je možno definovat přístupová práva. Při zatrženém příznaku chráněný dokument nebudou případné změny provedené v dokumentu jinými uživateli zaznamenány (aby nedošlo k omylu, při aktivaci tohoto dokumentu systém uživateli dovolí do dokumentu zapisovat nebo opravovat, ale při uložení nebudou tyto změny zaznamenány). Dokument pak smí opravovat (tzn. zapisovat do něj) pouze autor dokumentu.

Záložka „kategorie“ umožňuje daný dokument do vybrané kategorie zařadit pomocí atributu Nová a pak výběrem z překryvného seznamu nadefinovaných kategorií ji přiřadit dokumentu. Lze zadat i platnost od – do příslušnosti dokumentu ke kategorii. Zároveň poskytuje uživateli přehled o tom, v jakých kategoriích je daný dokument již zařazen. V případě potřeby je možno dokument z kategorie vyřadit pomocí atributu „odstranit“. V této činnosti se jednotlivé kategorie dokumentů nedefinují, pouze je možno vybírat z překryvného seznamu (definují se v činnosti Marketing – Dokumenty – Kategorie dokumentů).

Záložka „užití dokumentu“ ve chvíli založení uživateli žádné informace neposkytne, ale při další práci s dokumentem je zde zaznamenán každý pohyb, který byl s dokumentem proveden, tzn. datum, čas od – do, jméno uživatele a akce, kterou s dokumentem provedl (čtení, zápis).

Záložka „uložení dokumentu“ umožňuje uživateli:

¨ externí uložení - v případě normálního uložení je vytvořený dokument součástí databáze IS BM, při zatržení příznaku externí musí uživatel vytvořit odkaz (tzn. určit cestu a název souboru, ve kterém bude dokument uložen mimo IS BM) a při jeho aktivaci systém přes určenou cestu dokument vyvolá.

¨ soubor – cesta pro externí uložení dokumentu

¨ duplikát – IS BM umožňuje uživateli vytvořit si při tvorbě dokumentu rovnou jeho duplikát, který je uložen na pevném disku. Cestu na soubor, ve kterém má být daný dokument jako duplikát uložen, zadává uživatel v tomto atributu. Pro následnou práci s dokumentem pak platí, že změní-li uživatel dokument v IS BM, automaticky se mu stejně změní i duplikát na pevném disku. Opačný případ však nefunguje. Změní-li si uživatel duplikát na pevném disku, znamená to, že si soubor přepíše, jeho změny nebudou do dokumentu v IS BM přeneseny.

¨ automatické ukládání verzí dokumentu

Po vyplnění všech potřebných údajů na jednotlivých záložkách a konečném stisku OK je nový dokument vytvořen.

Ve stromech zobrazovaných ve formulářích spojené dokumenty, strom hlavního procesu a obdobných stromech formuláře okno úloh je možno implementačně doplnit definovatelné funkce pro menu, která jsou vyvolávána po stisku pravého tlačítka myši na uzlu představujícím objekt BM. Toto implementační doplnění je možno nadefinovat v činnosti „doplňující položky menu objektů“.

Formulář

Formulář činnosti - Menu formuláře
Seznam komponent

Vyvolávané činnosti

K. | Činnost | Popis
F6 | Menu formuláře | Vyvolání menu formuláře

Viz.také

Menu formuláře


Kredity adresátů

Popis

Jedná se o činnost, kterou má uživatel dostupnou pod menu Volby nebo po stisku klávesy F5 v činnosti "druhy operací" na záložce "validace vstupu" (pokud je tedy nějaká validace nastavena).

Na záložce "validace vstupu" musí mít tedy uživatel zadán určitý druh hodnoty, který má být při validaci kontrolován (např. hodnota množství odebraného zboží pro obchod apod.). Po stisku klávesy F5 je pak možno vyvolat "kredity adresátů". Na základě této činnosti je možno pro každého adresáta nastavit individuální hodnoty vztahující se k dané validaci:

¨ identifikace a název operace

¨ identifikace a druh hodnoty

¨ identifikace a název adresáta

¨ hodnota varování - částka, při které bude uživatel pouze upozorněn varovným hlášením

¨ hodnota zákazu vstupu - částka, při které již danou operaci nepůjde zapsat

Datový model

  • SPTYPVAD Kredit adresáta pro druh hodnoty v operaci
    • ADADSAT Adresát

    • Formulář

    Formulář činnosti - Adresář
Operace | Identifikátor druhu operace
 | Identifikace komponenty
 | Název druhu procesu
Druh hodnoty | Identifikace druhu hodnoty
 | Identifikace komponenty - přijemce transformovaných dat
 | Název druhu hodnoty
Mřížka [Kredity adresátů]
Adresát | Identifikace adresáta
 | Název adresáta
Hodnota varování | Mezní porovnávaná hodnota pro varování
Hodnota zákazu vstupu | Mezní porovnávaná hodnota pro zákaz vstupu

    Mřížka [Kredity adresátů] činnosti - Adresář

    Mřížka [Kredity adresátů] činnosti - Adresář
Adresát | Identifikace adresáta
Hodnota varování | Mezní porovnávaná hodnota pro varování
Hodnota zákazu vstupu | Mezní porovnávaná hodnota pro zákaz vstupu
 | Název adresáta

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Adresář | Přehled adresátů

    Viz.také

    Adresář


Výstupní atributy komponenty

Popis

Je to množina atributů, které jsou k dispozici pro tvorbu výrazů využitelných v transformacích, pro něž je daná komponenta zdrojová. Současně jsou tyto atributy přímo k dispozici v kódu po ukončení operace.

Tato základní množina atributů je dána primárně programovým kódem, dále ji lze rozšířit pomocí atributu „doplnění pohledu“ v transformaci, případně atributy volné karty operace či procesu definované na záložce „Další“ (činnost Informační centrum - Typy a řady - Druhy procesů, Druhy operací). Základní množinu výstupních atributů si může uživatel zobrazit po stisku klávesy F5 z činnosti Definice výrazů, kterou si vyvolal při definování pravidel transformace.

Doplněné atributy nelze užít v míře plnění, ale ani v určitých atributech (např. množství skladu), pokud se nevypne test mírou plnění u druhu operace (uzlu). Podobně je tomu tak i s atributy z volné karty, resp. salda.

Formulář

Formulář činnosti - Druhy plnění proj.úkolů
Mřížka [Seznam atributů]

Mřížka [Seznam atributů] činnosti - Druhy plnění proj.úkolů

Mřížka [Seznam atributů] činnosti - Druhy plnění proj.úkolů
Popis atributu | Popis atributu
Atribut události | Atribut události
Typ | Typ atributu
Délka | Délka
Desetiny | Počet desetin


Generování dokumentace

Popis

Tuto možnost má uživatel dostupnou pod menu Volby v činnosti Druhy dokumentů (Informační centrum – Typy a řady). Po její aktivaci je nejprve zobrazen dotaz: „Opravdu vytvořit dokumentaci implementace systému? Ano/Ne“. Po potvrzení volby Ano systém vytvoří tiskovou sestavu typu HTML, kde budou základní informace o druhu procesu – identifikace, název, uživatelský popis a základní atributy.


Prohlížení dokumentace

Popis

Tuto činnost má uživatel k dispozici pod menu Volby v činnosti Druhy procesů (Informační centrum – Typy a řady). Pro možnost prohlížení dokumentace je jako první krok nutno provést její vygenerování. Poté je ve formátu HTML zobrazena tisková sestava, která obsahuje zásadní informace o druhu procesu.


Spustit označené operace

Popis

Tuto činnost má uživatel dostupnou v menu Procesy a operace - Operace - pod menu Volby. Umožňuje uživateli označit si vybrané operace a touto volbou pak spustit označené operace. Může si vybrat jestli chce operace spouštět jednu po druhé jednotlivě nebo na pozadí. Např. může se jednat o skladové výdeje, které si uživatel všechny označí a tím že je pak najednou spustí, dojde k zaúčtování skladového výdeje apod.


Obecné výběry

Popis

Je to nástroj, který rozšiřuje možnosti standardního výběru a je uživatelsky definovatelný. Nadefinované obecné výběry je možno importovat pomocí balíčku a je možno je používat jako doplnění běžných výběrů v každé činnosti nebo jako pevný výběr, pokud se výběr definuje přímo jako vlastnost dané činnosti (po stisku pravého tlačítka myši na činnosti).

Ve formulářích pro definování implementačních rozšíření (volné karty, obecné výběry, importy/exporty dat, šablony, výkazy, metapředlohy výstupu) lze pod menu Volby vyvolat činnost „překlad popisek“. Při úpravě vzhledu formulářů v činnostech, ve kterých definuje implementátor vstupní formulář (volné karty, obecné výběry, šablony, importy/exporty dat, dotazy výkazů), je možné po pravém kliku klávesou myši na atributu určit jeho rozměry. Lze definovat šířku atributů třídy textové pole, překryvný seznam a u atributů typu textové, multimediální, makro je možné navíc definovat jejich výšku.

Výběry je možno definovat v každé činnosti pod záložkou Obecné - Obecné výběry - Definovat obecné výběry nebo po stisku pravého tlačítka myši přímo na obecném výběru na záložce Volby.

U každého výběru uživatel zadává jeho název, příznak, zda se jedná o výběr veřejný a pak výraz, který je nejdůležitější součástí výběru. Ve výrazu se obecnému výběru určuje, jaké atributy a jejich hodnoty má vyhledat. Výraz obecného výběru rozšiřuje klausuli WHERE příkazu SELECT dané činnosti oproti standardnímu výběru.

V případě potřeby je možno činnost rozšířit a vytvořit novou vazbu. Výraz musí být uvozen .post script a takto nadefinovaný výběr následně při spuštění funguje tak, že se sestavuje dynamicky podle toho, co v daném okamžiku zvolí uživatel. Ve výrazu je možno rovněž zadat i programový kód v jazyce FoxPro, který zajistí sestavení daného výběru. Ve výrazu se dají použít proměnné obecného výběru, musí však být uvozeny pomocí znamének menší/větší <proměnná>. Pomocí volání funkce _this.add_sql_plus (‘vlastní kód’) se doplňuje klausule WHERE a pomocí volání funkce _this.add_attr_plus (‘vlastní kód’) se doplní atributy.

V tuto chvíli je nutno upozornit implementátory, že při použití .post script ve výrazu obecného výběru nad určitou činností může nastat problém s předlohami výstupu nad touto činností. Jedná se o předlohy, které mají ve vlastnostech na záložce Seskupování vyplněny atributy SELECT, GROUP a HAVING. Tyto sestavy pak v kombinaci s takto vytvořeným výběrem nefungují, tzn. že není vhodné nad danou činností v sestavách aplikovat seskupování, pokud zároveň je v obecném výběru ve výrazu použit programový kód v jazyce FoxPro. Je velmi obtížné pak tyto sestavy a obecný výběr sladit dohromady, resp. pokud se na to implementátor nesoustředí již při jejich definování, je vlastně nemožné je potom sestavit.

I v obecném výběru má uživatel možnost dodefinovat si doplnění mřížky formuláře. V položce Atributy uživatel definuje seznam atributů v syntaxi Sybase SQL Anywhere, který má být doplněn do výsledného dotazu obecného výběru.

Na záložce „proměnné“ se definují jednotlivé proměnné obecného výběru (stejné chování jako u proměnných u šablon nebo volných karet). Ve většině obecných výběrů se ani proměnné nedefinují, obecný výběr je dostatečně definován zadaným výrazem, ale v některých případech je možno proměnné definovat, např. pokud se při aktivování obecného výběru má systém ještě dotázat na datum od - do. Na záložce proměnné výběru se vstupují následující atributy:

¨ proměnná – číslo (pořadí) a název proměnné

¨ typ – typ proměnné, její délka a počet desetin. Typ proměnné výběru „makro“ slouží k definování vstupního textového pole pro sestavení podmínky výběru. Po vyvolání výběru má uživatel možnost vybírat předdefinovaná makra v menu po pravém kliku myší na tomto poli. Kromě výběru makra do sestavované podmínky má uživatel po pravém kliku myší na poli typu „makro“ možnost ukládat (odstraňovat) a následně vybírat vzory sestavených podmínek. Každý uživatel si takto může vytvářet své vlastní soubory vzorů sestavených podmínek (tabulka pro uložení těchto vzorů je sdílena s formulářem Označování výrazem). Makra připravuje pro uživatele implementátor systému položkou menu Volby – Definice maker formuláře pro definování obecných výběrů (použití obecných výběrů s proměnnými výběru typu makro je možné pouze ve verzích BM pod Visual Foxpro 8 nebo vyšší).

¨ návěští – návěští proměnné, tak jak se bude uživateli zobrazovat při aktivaci daného obecného výběru

¨ naplnění – způsob naplnění proměnné (vstupem nebo výpočtem)

¨ výraz - ve výrazu je možno zadat jakékoliv atributy, např.:

- SPPRC.sp33storno=2 - tento obecný výběr v činnosti Procesy vybere pouze procesy, které jsou stornované

- not ADADRI.ad05id like 'CZ%' - tento obecný výběr v činnosti adresář vybere pouze ty adresáty, kteří jsou zahraniční, tj. jsou cizinci

- EXISTS (SELECT ADSPOJI.ad12id FROM %%%.ADSPOJ ADSPOJI WHERE ADSPOJI.ad01id=ADADSAT.ad01id AND TRIM(ADSPOJI.ad12id)='EMAIL') - tento obecný výběr vybere pouze ty adresáty, kteří mají spojení typu e-mail

¨ inicializace – inicializační hodnota proměnné ob. výběru. Je zde možno uvádět libovolně dlouhý text a používat volání interních funkcí (např.: SQL_DOTAZ). V takovém případě musí být výraz uveden znakem vlnovka (‘~’).

¨ validace – skript v jazyce Foxpro, který se provádí v okamžiku validace dané proměnné ve vstupním formuláři. Ve skriptu se mohou vyskytovat odkazy na všechny proměnné dané definice, které jsou vstupovány, uvedené v hranatých nebo složených závorkách. Proměnná uvedená v hranatých závorkách obsahuje v okamžiku vstupu formuláře hodnotu dané proměnné.

Proměnná uvedená ve složených závorkách obsahuje v okamžiku vstupu formuláře objekt, kterým je proměnná zobrazena.

Makro ### obsahuje v okamžiku vstupu formuláře hodnotu proměnné, pro kterou je prováděna validace.

V okamžiku spuštění kódu validace jsou mu k dispozici proměnné:

- _THISFORM - objekt formuláře, ve kterém je prováděn vstup

- _THIS - objekt proměnné, která je validována

Pro účely validace obsahuje formulář metodu TEST_ZMENA, která musí být vyvolána s parametry:

- identifikace - jednoznačná textová identifikace hodnoty

- hodnota - libovolná hodnota

Metoda následně vrací numerické hodnoty:

0 - hodnota dané identifikace, je stejná jako hodnota uložená při předcházejícím volání této metody se stejnou identifikací

1 - hodnota dané identifikace, je jiná než hodnota uložená při předcházejícím volání této metody se stejnou identifikací

2 - hodnota dané identifikace byla právě poprvé uložena voláním této metody

Příklad předplnění měny podle vstupovaného adresáta:

If _thisform.test_zmena('adresat',###)=1 Or Empty([mena])

[mena]=Tool.sql_dotaz([select oc01id from %%%.adadsat where ad01id=?_p1],###)

Endif

¨ třída – třída ovládacího prvku (textové pole/překryvný seznam/zaškrtávací pole)

¨ text pro zaškrtávací políčko nebo seznam hodnot pro překryvný seznam oddělených čárkou

¨ F2 reakce – možnost vyvolání vybrané činnosti (z překryvného seznamu) na klávesu F2

Na záložce „spojené předlohy výstupu“ si uživatel může nadefinovat, která předloha výstupu bude spojena s daným obecným výběrem. U této definice pak platí, že pokud je určitá předloha spojena s daným výběrem, funguje pouze za předpokladu, že je použit daný obecný výběr, nelze ji pak pustit samostatně.

Na záložce „užití výběru“ se sleduje využívání jednotlivých obecných výběrů. Tento přehled může sloužit i jako podklad pro implementátora při rozhodování o vyřazování nepoužívaných obecných výběrů. Zobrazuje se kdo (jméno uživatele), kdy poprvé (datum prvního použití výběru uživatelem), kdy naposledy (datum posledního použití výběru uživatelem) a kolikrát (celkový počet použití výběru uživatelem). Tyto informace se ukládají do tabulky SPVYBERU s atributy (sp27id - primárního klíč obecného výběru, bw01uziv - kdo - identifikace uživatele, spe6dat1 - kdy poprvé, spe6dat2 - kdy naposledy, spe6pocet – kolikrát). Hodnoty proměnných obecného výběru formuláře jsou dostupné v objektu: THISFORM.OBEC_VYBER.VAR, který obsahuje vlastnosti odpovídající názvům a hodnotám proměnných aktuálního obecného výběru, např. THISFORM.OBEC_VYBER.VAR.DATUM

Datový model

  • SPVYBER Obecný výběr
    • BWUZIVAT Uživatel systému
    • BWPRINTT Druh předlohy
      • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Definice maker
Mřížka [Obecné výběry]
Výběr | Název obecného výběru
Listovací rámeček
Stránka #1 Obecné výběry
Druh | Identifikace druhu předlohy
Veřejný výběr | Veřejný obecný výběr - je přístupný všem uživatelům systému
Výraz | Výraz obecného výběru
Doplnění | Identifikace doplnění mřížky formuláře
Atributy | Atributy obecného výběru
FROM | Doplnění obecného výběru FROM
Komentář | Poznámka k obecnému výběru
Založil | Jméno uživatele systému
 | Datum vzniku výběru
Stránka #2 Proměnné výběru
Mřížka [Proměnné výběru]
Proměnná | Číslo proměnné definice obecného výběru
Název proměnné | Název proměnné obecného výběru
Typ | Typ proměnné obecného výběru
Délka | Délka proměnné obecného výběru
Desetiny | Počet desetin obecného výběru
Návěští | Návěští proměnné obecného výběru
Naplnění | Způsob naplnění proměnné - vstupem nebo výpočtem
Výraz | Výraz proměnné obecného výběru
Inicializace | Inicializační hodnota proměnné obecného výběru
Validace | Script v jazyce Foxpro
Třída | Třída ovládacího prvku
Hodnoty | Text pro zaškrtávací políčko nebo seznam hodnot pro překryvný seznam oddělených čárkou
F2-reakce | Vyvolání činnosti na klávesu F2
Stránka #3 Spojené předlohy výstupu
Mřížka [Spojené předlohy výstupu]
Předloha | Identifikace předlohy pro výstup
Stránka #4 Užití výběru
Mřížka [Užití výběru]

    Mřížka [Obecné výběry] činnosti - Definice maker

    Mřížka [Obecné výběry] činnosti - Definice maker
Výběr | Název obecného výběru
Název druhu předlohy | Název druhu předlohy

    Mřížka [Proměnné výběru] činnosti - Definice maker

    Mřížka [Proměnné výběru] činnosti - Definice maker
Proměnná | Číslo proměnné definice obecného výběru
Název | Název proměnné obecného výběru
Typ | Typ proměnné obecného výběru
Délka | Délka proměnné obecného výběru
Desetiny | Počet desetin obecného výběru
Návěští | Návěští proměnné obecného výběru

    Mřížka [Spojené předlohy výstupu] činnosti - Definice maker

    Mřížka [Spojené předlohy výstupu] činnosti - Definice maker
    Název předlohy Název předlohy pro výstup

    Mřížka [Užití výběru] činnosti - Definice maker

    Mřížka [Užití výběru] činnosti - Definice maker
Uživatel | Jméno uživatele systému
Poprvé | Datum prvního užití obecného výběru
Naposledy | Datum posledního užití obecného výběru
Počet | Celkový počet užití obecného výběru

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Editovat kód vlastnosti | Editovat kód vlastnosti
F6 | Design vstupního formuláře |
^P | Překlad popisek |
- | Doplnění mřížky formuláře | Doplnění mřížky formuláře
- | Překlad popisek - název obecného výběru |
- | Definice maker | Definice maker
F2 | Doplnění mřížky formuláře | Doplnění mřížky formuláře
F2 | Druhy předloh výstupu | Druhy předloh výstupu
F2 | Prostředí pohledu | Prostředí základního pohledu činnosti

    Viz.také

    Editovat kód vlastnosti | Design vstupního formuláře | Překlad popisek | Definice maker | Doplnění mřížky formuláře | Druhy předloh výstupu | Prostředí pohledu


Prostředí pohledu

Popis

Tato činnost umožňuje vybrat si správné prostředí pohledu při definování výrazů u jednotlivých druhů (např. druh volné karty, druh procesu, druh artiklu, druh předlohy výstupu, druh obecného výběru apod.). V každém případě tato činnost není triviální, takže pracovat s ní by měl pouze zkušenější uživatel.

Formulář

Formulář činnosti - Druhy plnění proj.úkolů
 | Prostředí základního pohledu činnosti
 | Seznam komponent


Prezentace artiklu

Popis

Uživatel si v činnostech týkajících se artiklů (artikly skladu, artikly obchodu atd.) a dokumentů aktivuje menu Volby a v něm vyvolá příslušnou činnost týkající se „prezentace“. Uživateli se zobrazí samostatné okno, které je propojené s artikly nebo dokumenty. Např. můžeme mít oděvní firmu, která si ke každému atriklu obchodu vloží prezentaci (čili fotografii) každého jednotlivého kusu oděvu.

Propojení nebo vložení objektu se realizuje funkcí:

¨ „vložit objekt“ (pod menu Úpravy) – zvolit možnost Ze souboru a nebo Nový a zaškrtnout možnost „propojit“. Toto bez problému funguje při obrázcích s příponou *.jpg, některé další (např. bms) se mohou načítat chybně pouze jako ikona. V takovém případě je vhodné využít druhou možnost a to je:

¨ „vložit jinak“ v horní liště obrazovky v menu Úpravy při aktivním okně prezentace artiklu. Předpokládá se ale, že uživatel si nejprve obrázek zobrazí (zvolí možnost Kopírovat), poté se vrátí do okna Prezentace a pod menu Úpravy zvolí možnost „vložit jinak“.

Při aktivaci funkce „ponechat“ v menu Volby nebude okno s prezentací artiklu automaticky uzavřeno při ukončení činnosti s přehledem artiklů nebo dokumentů.

Datový model

  • SPARTIKP Prezentace artiklu

    • Formulář

    Formulář činnosti - Ponechat na obrazovce
    Prezentace artiklu

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Ponechat na obrazovce | Ponechat na obrazovce

    Viz.také

    Ponechat na obrazovce


Ponechat na obrazovce

Popis

Při aktivaci funkce „ponechat" v menu Volby nebude okno s prezentací artiklu automaticky uzavřeno při ukončení činnosti s přehledem artiklů nebo dokumentů.


INFORMACE O ARTIKLU

Popis

Pod touto činností jsou pro uživatele dostupné veškeré informace o artiklu, jeho události, aktuální a obratové hodnoty, množství artiklu na skladech apod. Tuto nabídku si uživatel vyvolá v činnostech, které obsahují tučně zvýrazněný atribut Artikl (po stisku pravého tlačítka myši).

Viz.také

ARTIKLY | UDÁLOSTI ARTIKLU | AKTUÁLNÍ HODNOTY ARTIKLU | OBRATOVÉ HODNOTY ARTIKLU | Nedokončené procesy | Množství artiklu na skladech | Dokumenty artiklu | TP k datu rozpracované na KJ


UDÁLOSTI ARTIKLU

Popis

Pod tímto menu má uživatel dostupné informace o událostech artiklu, které proběhly v ostatních komponentách. Např. když si uživatel prohlíží obchodovatelný artikl, tak si přes toto menu (vyvolá se pravým klikem myši na tučném atributu artikl) může vyvolat události daného artiklu např. ve skladu.

Viz.také

Události obecné komponenty | Událost obchodu | Událost skladové evidence | Změny odpisovaného majetku | Změny spravovaného majetku | Rezervace majetku | Zakázky výroby | Výrobní úkoly | Vstupy a výstupy výr. úkolů | Hodnoty předmětu projektu | Položky smluv | Události plnění smluv | Projektové úkoly | Plnění projektových úkolů | Událost skladu zvířat | Události správy artiklu


AKTUÁLNÍ HODNOTY ARTIKLU

Popis

Přes toto menu (vyvolá se pravým klikem myši na tučném atributu artikl) si uživatel vyvolá informace o aktuálních hodnotách artiklu v jednotlivých komponentách.

Viz.také

Aktuální hodnoty obecné komp. | Aktuální hodnoty obchodu | Aktuální hodnoty skladu | Aktuální hodnoty odpis.maj. | Aktuální hodnoty sprav.maj. | Aktuální hodnoty hodnot PP


ARTIKLY

Popis

Přes toto menu (vyvolá se pravým klikem myši na tučném atributu artikl) si uživatel vyvolá informace o artiklu v jednotlivých činnostech IS BM.

Viz.také

Artikl obecné komponenty | Artikly skladu | Artikly skladu - VČ | Obchodovatelný artikl | Odpisovaný majetek | Spravovaný majetek | Karty pohledávek | Předmět projektu | Strom hodnot předmětu projektu | Artikly výroby | Přehled referenčních artiklů | Kategorie zvířat | Vztahy obchodovatelných artiklů k adresátům


Prezentace dokumentu

Popis

Uživatel si v činnostech týkajících se dokumentů aktivuje menu Volby a v něm vyvolá příslušnou činnost týkající se „prezentace“. Uživateli se zobrazí samostatné okno, které je propojené s dokumenty. Např. ke každé smlouvě je možno vložit logo firmy, se kterou smlouvu uzavíráme apod.

Propojení nebo vložení objektu se realizuje funkcí „vložit objekt“ nebo „vložit“ v horní liště obrazovky v menu Úpravy při aktivním okně prezentace dokumentu. Při aktivaci funkce „ponechat“ v menu Volby nebude okno s prezentací dokumentu automaticky uzavřeno při ukončení činnosti s přehledem dokumentů.

Datový model

  • SPDOKOBS Dokument
    • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Ponechat na obrazovce

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Ponechat na obrazovce | Ponechat na obrazovce

    Viz.také

    Ponechat na obrazovce


Události označených operací

Popis

Tuto činnost si uživatel vyvolá z přehledu fyzických operací volbou příslušné činnosti z menu Volby. Jednotlivé operace si ručně označí (tj. zaškrtne). Po aktivaci této činnosti se mu spustí události komponenty, ve které se daná operace vyskytuje.


Definice importu/exportu

Popis

Definují se zde základní vlastnosti importu a to jsou:

¨ identifikace importu/exportu/update dat - jednoznačně identifikuje v rámci činnosti

¨ název importu/exportu/update dat

¨ druh - druh importu/exportu/update dat - je k němu možno nadefinovat přístupová práva (právo zápis - uživatel má povoleno vytvářet, právo čtení - uživatel má právo spouštět)

¨ spojení - definuje spojení s externím zdrojem dat. Druh spojení může být:

- ODBC

- XBASE

- Text (nemá význam pro export)

- v definici spojení pro import/export dat je možné uvádět v atributu 'Spojení OS' znak *, což má stejný dopad, jako kdyby v něm byl uveden název ODBC spojení programu BM k právě aktuální databázi

¨ import/export/update dat - určuje charakter definice

¨ atribut nabízet - při nastavení Ne nebude import nabízen při vyvolání pro spuštění po volbě z menu Obecné (není aktuální nebo je vyvoláván jiným způsobem např. procesním importem)

¨ selekt - obsahuje definici pro zpřístupnění zdrojových dat importu/update nebo dat do kterých bude exportováno. Po stisku pravého tlačítka myši v tomto políčku je dostupný datový model.

¨ příkazy - příkazy v jazyce Foxpro provedené po exportu dat (nevyužívá se pro import a update)

¨ init - určuje příkaz vyvolaný ještě před zahájením importu. Předpokládá se použití některých činností, které vracejí v pracovním souboru seznam označených záznamů jako třeba adresář. V okamžiku vyvolání příkazu, je v proměnné "_o.wrk2" uloženo jméno dosud neexistujícího souboru, který bude vytvořen příkazem. V okamžiku vyvolání kódu popsaného v atributu "Selekt" importu je toto jméno dostupné "this.wrk2".

¨ Čas.id. - definuje výraz jehož hodnota bude vložena do jednoznačné časové identifikace objektu (má význam pouze při importu objektů). Jestliže při importu již existuje v tabulce záznam se stejnou časovou identifikací, potom není importován. Při update slouží tato definice jako výraz pro určení záznamu, který má být aktualizován.

Na záložce "proměnné importu-exportu" se definují proměnné, které může uživatel vstupovat před zahájením importu, exportu nebo update dat a proměnné, které jsou odvozené ze vstupovaných hodnot. Jednotlivé proměnné se definují stejným způsobem jako u obecných výběrů, šablon nebo volných karet. Za zmínku stojí atribut „naplnění“, který může nabývat těchto hodnot:

¨ vstup - hodnota proměnné je vstupována uživatelem

¨ výpočet - hodnota proměnné je odvozena podle hodnot proměnných definovaných s nižším pořadím. Hodnota proměnné je vyhodnocena na základě "Výrazu proměnné", který v sobě obsahuje odkazy na proměnné uvedené v hranatých závorkách. Používá se např. pro sestavení SQL dotazu s operátorem LIKE. Např.:

- proměnná v pořadí 10 je vstupována uživatelem, je znaková a má identifikátor FIRMA

- proměnná v pořadí 20 s identifikátorem FIRMA0 je vypočítávaná s hodnotou určenou výrazem TRIM([FIRMA])+'%'. Potom je možné v SQL dotazu zadat ..... ADADSAT.ad01adsat LIKE [FIRMA0] ...

Mezi další vlastnosti patří:

Na záložce proměnné výběru se vstupují následující atributy:

¨ typ – typ proměnné, její délka a počet desetin. Typ proměnné výběru „makro“ slouží k definování vstupního textového pole pro sestavení podmínky výběru. Po vyvolání výběru má uživatel možnost vybírat předdefinovaná makra v menu po pravém kliku myší na tomto poli. Kromě výběru makra do sestavované podmínky má uživatel po pravém kliku myší na poli typu „makro“ možnost ukládat (odstraňovat) a následně vybírat vzory sestavených podmínek. Každý uživatel si takto může vytvářet své vlastní soubory vzorů sestavených podmínek (tabulka pro uložení těchto vzorů je sdílena s formulářem Označování výrazem). Makra připravuje pro uživatele implementátor systému položkou menu Volby – Definice maker formuláře pro definování obecných výběrů (použití obecných výběrů s proměnnými výběru typu makro je možné pouze ve verzích BM pod Visual Foxpro 8 nebo vyšší).

¨ výraz - ve výrazu je možno zadat jakékoliv atributy, např.:

- SPPRC.sp33storno=2 - tento obecný výběr v činnosti Procesy vybere pouze procesy, které jsou stornované

- not ADADRI.ad05id like 'CZ%' - tento obecný výběr v činnosti adresář vybere pouze ty adresáty, kteří jsou zahraniční, tj. jsou cizinci

- EXISTS (SELECT ADSPOJI.ad12id FROM %%%.ADSPOJ ADSPOJI WHERE ADSPOJI.ad01id=ADADSAT.ad01id AND TRIM(ADSPOJI.ad12id)='EMAIL') - tento obecný výběr vybere pouze ty adresáty, kteří mají spojení typu e-mail

¨ inicializace – inicializační hodnota proměnné ob. výběru. Je zde možno uvádět libovolně dlouhý text a používat volání interních funkcí (např.: SQL_DOTAZ). V takovém případě musí být výraz uveden znakem vlnovka (‘~’).

¨ validace – skript v jazyce Foxpro, který se provádí v okamžiku validace dané proměnné ve vstupním formuláři. Ve skriptu se mohou vyskytovat odkazy na všechny proměnné dané definice, které jsou vstupovány, uvedené v hranatých nebo složených závorkách. Proměnná uvedená v hranatých závorkách obsahuje v okamžiku vstupu formuláře hodnotu dané proměnné.

Proměnná uvedená ve složených závorkách obsahuje v okamžiku vstupu formuláře objekt, kterým je proměnná zobrazena.

Makro ### obsahuje v okamžiku vstupu formuláře hodnotu proměnné, pro kterou je prováděna validace.

V okamžiku spuštění kódu validace jsou mu k dispozici proměnné:

- _THISFORM - objekt formuláře, ve kterém je prováděn vstup

- _THIS - objekt proměnné, která je validována

Pro účely validace obsahuje formulář metodu TEST_ZMENA, která musí být vyvolána s parametry:

- identifikace - jednoznačná textová identifikace hodnoty

- hodnota - libovolná hodnota

Metoda následně vrací numerické hodnoty:

0 - hodnota dané identifikace, je stejná jako hodnota uložená při předcházejícím volání této metody se stejnou identifikací

1 - hodnota dané identifikace, je jiná než hodnota uložená při předcházejícím volání této metody se stejnou identifikací

2 - hodnota dané identifikace byla právě poprvé uložena voláním této metody

Příklad předplnění měny podle vstupovaného adresáta:

If _thisform.test_zmena('adresat',###)=1 Or Empty([mena])

[mena]=Tool.sql_dotaz([select oc01id from %%%.adadsat where ad01id=?_p1],###)

Endif

¨ třída – třída ovládacího prvku (textové pole/překryvný seznam/zaškrtávací pole)

¨ text pro zaškrtávací políčko nebo seznam hodnot pro překryvný seznam oddělených čárkou

¨ F2 reakce – možnost vyvolání vybrané činnosti (z překryvného seznamu) na klávesu F2. Při použití F2 reakce někam do programu IS BM (např. do adresáře) se někdy může systém chovat nestandardně. Po prvním odskoku do zvolené činnosti je vše ok, při druhém a dalších přestává někdy fungovat tlačítko návrat hodnoty (v panelu nástrojů). Pak je nutné místo tohoto tlačítka přenést vybranou hodnotu pomocí kláves Ctrl + Enter (tj. klávesová zkratka pro dané tlačítko). Po F2 reakci nemusí tlačítko „návrat hodnoty“ v modálních oknech fungovat.

Ve formulářích pro definování implementačních rozšíření (volné karty, obecné výběry, importy/exporty dat, šablony, výkazy, metapředlohy výstupu) lze pod menu Volby vyvolat činnost „překlad popisek“. Při úpravě vzhledu formulářů v činnostech, ve kterých definuje implementátor vstupní formulář (volné karty, obecné výběry, šablony, importy/exporty dat, dotazy výkazů), je možné po pravém kliku klávesou myši na atributu určit jeho rozměry. Lze definovat šířku atributů třídy textové pole, překryvný seznam a u atributů typu textové, multimediální, makro je možné navíc definovat jejich výšku.

Datový model

  • SPIMP Definice importu/exportu
    • SPIMPD Druh importu
    • SPIMPS Spojení
    • BWUZIVAT Uživatel systému
    • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Překlad popisek
Mřížka [Definice importu-exportu]
I-E | Identifikace importu-exportu
 | Název importu-exportu
Listovací rámeček
Stránka #1 Definice importu-exportu
Druh | Identifikace druhu importu-exportu
 | Název druhu importu-exportu
Spojení | Identifikace spojení
 | Název spojení
 | Import / export / update dat
Nabízet | Nabízet import-export k provedení
Selekt | Selekt importu-exportu
Příkazy | Příkazy provedené po importu-exportu
Init | Inicializační příkaz
Čas.id. | Výraz pro atribut časové identifikace
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Poznámka | Poznámka k importu
Stránka #2 Proměnné importu-exportu
Mřížka [Proměnné importu]
Proměnná | Číslo proměnné definice importu
Název | Název proměnné
Typ | Typ proměnné
Délka | Délka proměnné
Desetiny | Počet desetin
Návěští | Návěští proměnné
Naplnění | Způsob naplnění proměnné - vstupem nebo výpočtem
Výraz | Výraz proměnné šablony
Inicializace | Inicializační hodnota proměnné šablony
Validace | Script v jazyce Foxpro
Třída | Třída ovládacího prvku
Hodnoty | Text pro zaškrtávací políčko nebo seznam hodnot pro překryvný seznam oddělených čárkou
F2-reakce | Identifikace činnosti

    Mřížka [Definice importu-exportu] činnosti - Překlad popisek

    Mřížka [Definice importu-exportu] činnosti - Překlad popisek
I-E | Identifikace importu-exportu
Název importu-exportu | Název importu-exportu
Charakter | Import / export / update dat
Nabízet | Nabízet import-export k provedení

    Mřížka [Proměnné importu] činnosti - Překlad popisek

    Mřížka [Proměnné importu] činnosti - Překlad popisek
Proměnná | Číslo proměnné definice importu
Název | Název proměnné
Typ | Typ proměnné
Délka | Délka proměnné
Desetiny | Počet desetin
Návěští | Návěští proměnné

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Konverze atributů | Definování konverzí atributů
F6 | Design vstupního formuláře |
F7 | Prohlížení importovaných dat | Prohlížení importovaných-exportovaných dat
^P | Překlad popisek |
- | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností
- | SELECT pro export | Příkaz SELECT pro export
- | Překlad popisek - název importu/exportu |
F2 | Druhy importů-exportů | Seznam druhů importů-exportů
F2 | Spojení importů-exportů | Definovaná spojení importů-exportů

    Viz.také

    Konverze atributů | Design vstupního formuláře | Prohlížení importovaných dat | Knihovny vkládaného kódu | SELECT pro export | Překlad popisek | Druhy importů-exportů | Spojení importů-exportů


Druhy importů-exportů

Popis

Tato činnost umožňuje uživateli nadefinovat si jednotlivé druhy importů/exportů. U každého z nich se zadává identifikace a název a případná poznámka. Ke každému druhu lze nadefinovat přístupová práva (menu Volby nebo klávesa Ctrl B).

Datový model

  • SPIMPD Druh importu
    • BWUZIVAT Uživatel systému

    • Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci

    Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Druhy importů-exportů]
Druh | Identifikace druhu importu-exportu
 | Název druhu importu-exportu
Poznámka | Poznámka ke druhu importu-exportu
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události

    Mřížka [Druhy importů-exportů] činnosti - Přístupová práva

    Mřížka [Druhy importů-exportů] činnosti - Přístupová práva
Druh | Identifikace druhu importu-exportu
Název druhu | Název druhu importu-exportu

    Atributy tisku

    Základní údaje
Druh | Identifikace druhu importu-exportu | SPIMPD_sp92id | C(6)
Název druhu | Název druhu importu-exportu | SPIMPD_sp92nazdru | C(40)
Poznámka | Poznámka ke druhu importu-exportu | SPIMPD_sp92koment | M
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(17)
Datum a čas zápisu | Datum a čas zápisu záznamu události | SPIMPD_sp00datzap | T

    Viz.také

    Přístupová práva


Spojení importů-exportů

Popis

Tato činnost umožňuje uživateli nadefinovat jednotlivá spojení, která používá při definici importů/exportů. U každého spojení se definuje:

¨ identifikace a název

¨ druh spojení – ODBC, XBASE, text

¨ spojení operačního systému

¨ uživatel a jeho heslo (zadané údaje jsou zaheslované, tzv. „zahvězdičkované“)

¨ K. stránka – kódová stránka

Datový model

  • SPIMPS Spojení
    • BWUZIVAT Uživatel systému

    • Formulář

    Formulář činnosti - Artikl
Mřížka [Spojení importů]
Spojení | Identifikace spojení
 | Název spojení
Druh spojení | Druh spojení
Spojení OS | Spojení operačního systému
Uživatel | Identifikace uživatele
Heslo | Heslo uživatele
K. stránka | Kódová stránka
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Poznámka | Poznámka ke spojení

    Mřížka [Spojení importů] činnosti - Artikl

    Mřížka [Spojení importů] činnosti - Artikl
Spojení | Identifikace spojení
Název spojení | Název spojení


Konverze atributů

Popis

Pomocí činnosti konverze atributů uživatel v importu/exportu definuje odkud a kam se jednotlivé atributy importu/exportu mají zapsat. Činnost konverze atributů je pro uživatele dostupná na každé definici importu pod menu Volby nebo po stisku funkční klávesy F5. První záložka dané činnosti je „konverze řádku“, druhá záložka je „konverze atributů“. Z jednoho vstupního řádku může být transformováno žádný, jeden nebo více řádků. Na záložce „konverze řádku“ se definuje:

¨ podmínka - tento atribut rozhoduje o tom zda bude řádek použit. Přitom má pro Import nebo Update význam používat odkazy na atributy otevřených tabulek s aliasem DATA nebo případně další relačně propojené tabulky otevřené podle příkazů "Selekt" definice s druhem spojení XBASE. Pro Export má význam použití atributů s aliasem _EXP_. V atributu podmínka se mohou vyskytovat "proměnné importu" v hranatých závorkách.

¨ primární klíč exportu - tento atribut určuje výraz vyhodnocený při exportu nad cílovými daty. Pokud se v cílových datech vyskytuje záznam se stejnou hodnotou výrazu, potom není exportovaný řádek zapsán.

¨ klíč pro update - tento atribut se používá při update dat, když není nastavena vlastnost "Čas.id."(v definici importu). Obsahuje seznam výstupních atributů oddělených čárkou, které určují záznam, který má být aktualizován.

Na záložce „konverze atributů“ se definuje transformace dat jednotlivých atributů a zadává se:

¨ atribut - určuje výstupní atribut, jehož hodnota bude při importu/exportu/update naplněna vyhodnocením výrazu

¨ obecná platnost - tento atribut definuje na prvém řádku konverze, že daný výraz je platný pro všechny následující řádky, na kterých se potom nemusí uvádět.

¨ výraz - obsahuje výraz v jazyce Foxpro. Ve výrazu se mohou vyskytovat "proměnné importu" v hranatých závorkách. Hodnota získaná vyhodnocením výrazu musí být stejného typu jako "atribut", do kterého bude vložena.

Datový model

  • SPIMPR Konverze řádky

    • Formulář

    Formulář činnosti - Výraz
Mřížka [Konverze řádku]
 | Identifikace činnosti
 | Název entity
I-E | Identifikace importu-exportu
Číslo | Číslo konvertovaného definice řádky
Listovací rámeček
Stránka #1 Konverze řádku
Podmínka | Podmínka přenosu
Primární klíč exportu | Primární klíč exportu
Klíč pro Update | Klíč pro Update - seznam atributů klíče oddělených čárkou
Poznámka | Poznámka
Stránka #2 Konverze atributů
Mřížka [Konverze atributu]
Atribut | Název atributu
Obecná platnost | Atribut má platnost pro všechny záznamy
Výraz | Výraz
Poznámka | Poznámka

    Mřížka [Konverze řádku] činnosti - Výraz

    Mřížka [Konverze řádku] činnosti - Výraz
Činnost | Identifikace činnosti
Entita | Název entity
I-E | Identifikace importu-exportu
Číslo | Číslo konvertovaného definice řádky

    Mřížka [Konverze atributu] činnosti - Výraz

    Mřížka [Konverze atributu] činnosti - Výraz
Atribut | Název atributu
Poznámka | Poznámka

    Vyvolávané činnosti

    K. | Činnost | Popis
- | Předplnění atributů | Předplnění atributů
F2 | Výraz | Tvorba výrazu tvůrcem výrazů

    Viz.také

    Předplnění atributů | Výraz


Spustit procesní import

Popis

Spuštění procesního importu se provádí volbou příslušné činnosti v menu Volby a nebo po stisku funkční klávesy F9. Podle nadefinovaného atributu založení operace pak probíhá vlastní spuštění procesního importu. Uživatel se může napojovat do již existujícího procesu a nebo může spouštět proces nový apod.


Prohlížení importovaných dat

Popis

Tato činnosti je dostupná v menu Volby nebo po stisku klávesy F7. Na základě nadefinovaného importu má uživatel k dispozici množinu dat, která bude následně po spuštění procesního importu naimportována.


Předplnění atributů

Popis

Na základě nastavených transformací v konverzi atributů dochází k automatickému naplnění atributů příslušným výrazem (funguje to však pouze v případě, že atributy mají v jednotlivých tabulkách shodné identifikace).


Parametry operace komponenty

Popis

Parametry se v současné době vstupují zatím pouze u druhů operací komponent obchod, platby a sklad zvířat. Jedná se o:

¨ automatické nastavení „stavu" událostí v operaci daného druhu v případě, že po dané operaci následuje operace ze stejné komponenty (obvyklé použití v kombinaci s dávkovou operací, kde se nerespektuje míra plnění) a zároveň se zde nastavuje i „stav" událostí v případě, že následující operace po dané operaci změnila stav (tzn. byla zrušena, stornována).

¨ předběžné ukončení - operace s tímto atributem je ukončena předběžně. Do vlastností uzlu diagramu s touto operací (atribut ukončit operaci) se však tato hodnota nepředplní, tj. je nutné ji definovat duplicitně.

Události skladu zvířat lze aplikovat pouze v rámci operace, jejíž druh může mít tyto parametry:

¨ běžná - mají nastaveno všechny standardní operace jako příjem, výdej, prodej apod.,

¨ výpočet KD - nutno nastavit v parametrech operace, která provádí zápočet krmných dnů,

¨ převod - příjem, převod - výdej - nastavuje se v parametrech operací, které provádějí převod zvířat z kategorie do kategorie (nebo umístění - umístění) proto, aby bylo v pořádku zachováno ocenění (tzn. při převodu je nutno brát skladovou cenu z původního stáda) a to i tehdy, je-li původní cena následně upravená


Výběr předlohy

Popis

Výběr předlohy pro tisk dokumentu procesu.

Formulář

Formulář činnosti - Uživatelské triggery
Seznam předloh výstupu
Tlačítko
Tlačítko


Významy položek předkontací

Popis

Při aktivaci této činnosti má uživatel nejprve k dispozici záložku „Výběr“, kde může definovat množinu následujících zobrazených údajů.

V masce operace je možné využít obecnou předkontaci výrazem ve tvaru : „##P <výraz1>;<výraz2>[;default]“, kde <výraz1> je identifikace obecné předkontace a <výraz2> je význam v obecné předkontaci. Pokud obecná předkontace nemá k danému významu definovánu hodnotu, uplatní se implicitní default (tj. implicitní hodnota). Daná předkontace se vyhodnotí teprve v okamžiku vstupu na danou položku (atribut), a to pouze v případě, že neobsahuje (nebyl předplněn automatizací vstupu událostí) žádnou textovou hodnotu nebo že je uživateli nepřístupná.

Při použití obecné předkontace v pravidle transformace mezi uzly procesů se ve výrazu uvádí tato definice:

"~#P <výraz1>;<výraz2>[;default]“ kde <výraz1> je identifikace obecné předkontace a <výraz2> je význam v obecné předkontaci. Pokud obecná předkontace nemá k danému významu definovánu hodnotu, uplatní se implicitní default (tj. implicitní hodnota). Např.: výraz ~#P 'FP-028';'IDU'+RIGHT(tool.user,2)) vrátí hodnotu uvedenou v obecné předkontaci s identifikací FP-028 u významu, který vyplývá z identifikace datového úložiště (např.IDU11).

Hodnota daná výrazem s obecnou předkontací v transformaci v procesech se vyhodnocuje ještě před zápisem cílových událostí, takže je možné ji využít i v agregačním výrazu pravidla transformace. Agregační výraz pak má tuto syntaxi: „~DATA.v_<VstAtrKom>“, kde <VstAtrKom>“ je některý vstupní atribut cílové události, jehož hodnota je definována pomocí obecné předkontace a podle kterého proběhne agregace.

V šablonách je možné použít obecné předkontace pro předdefinování různých inicializačních hodnot (tím je míněn atribut inicializace v proměnných šablony). Dále je možné v šablonách tímto způsobem předdefinovat různé obsahy překryvných seznamů. V šablonách se neuvádí znak vlnovka.

Datový model

  • SPPREDKV Význam položky obecné předkontace

    • Formulář

    Formulář činnosti - Měrné jednotky
Mřížka [Význam položky obecné předkontace]
Listovací rámeček
Stránka #1 Významy položek
Význam | Identifikace významu položky obecné předkontace
 | Popis významu položky obecné předkontace
Poznámka | Poznámka k významu položky obecné předkontace
Stránka #2 Výběr
Význam | Identifikace významu položky obecné předkontace
Popis významu | Popis významu položky obecné předkontace
Výběr | Určení výběru
Uchovat | Příznak uchování výběrového hlediska

    Mřížka [Význam položky obecné předkontace] činnosti - Měrné jednotky

    Mřížka [Význam položky obecné předkontace] činnosti - Měrné jednotky
Význam | Identifikace významu položky obecné předkontace
Popis významu | Popis významu položky obecné předkontace

    Atributy tisku

    Základní údaje
Význam | Identifikace významu položky obecné předkontace | SPPREDKV_sp47id | C(6)
Popis významu | Popis významu položky obecné předkontace | SPPREDKV_sp47nazvyz | C(40)
Poznámka | Poznámka k významu položky obecné předkontace | SPPREDKV_sp47koment | M


Předkontace adresáta

Popis

V případě, že definice obecné předkontace (Informační centrum - Typy a řady) má zatržen atribut "předkontace adresáta", je v takovém případě obecná předkontace dostupná i z adresáře. Předkontaci adresáta lze vyvolat volbou příslušné činnosti z menu Volby nebo po stisku klávesy F7. Nejčastěji definovanou předkontací adresáta je individuální nastavení splatnosti pohledávky.

V případě, že v obecných předkontacích je vytvořena i obecná předkontace typu BMSPL2, pro niž platí, že datum splatnosti pohledávky se vztahuje k datu zdanitelného plnění, tak se uživateli zobrazuje následující nabídka:

¨ splatnost je vzhledem k DZP – tuto možnost uživatel využije v případě, že implicitní dobu splatnosti pohledávky chce vztahovat k datu zdanitelného plnění (tzn. tj. shodné s datem platby). Pak se datum splatnosti pohledávky tvoří způsobem: datum platby + uvedená individuální implicitní doba splatnosti pohledávky. V případě, že datum splatnosti chce uživatel takto využívat, musí v tomto atributu mít uveden text začínající malým nebo velkým písmenem A (např. Ano).

¨ splatnost pohledávky – individuální počet dní splatnosti pohledávky daného adresáta

Formulář

Formulář činnosti - Spojení adresátů
 | Jednoznačná časová identifikace pro pracovní soubory = plněna SYS(2015)
Adresát | Identifikace adresáta
 | Název adresáta


Druhy externích příkazů

Popis

Jedná se o činnost, která umožňuje uživateli nadefinovat jednotlivé druhy externích příkazů. U každého příkazu se zadává identifikace druhu a jeho název.

Ke každému druhu je možno nastavit pro uživatele přístupová práva.

Datový model

  • SPEXTPRD Druh externího příkazu
    • BWUZIVAT Uživatel systému

    • Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci

    Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Druhy příkazů]
Druh | Identifikace druhu externího příkazu
 | Název druhu externího příkazu
Založil | Jméno uživatele systému
 | Datum a čas zápisu záznamu události
Poznámka | Poznámka ke druhu externího příkazu

    Mřížka [Druhy příkazů] činnosti - Přístupová práva

    Mřížka [Druhy příkazů] činnosti - Přístupová práva
Druh | Identifikace druhu externího příkazu
Název druhu | Název druhu externího příkazu

    Atributy tisku

    Základní údaje
Druh | Identifikace druhu externího příkazu | SPEXTPRD_sp49id | C(6)
Název druhu | Název druhu externího příkazu | SPEXTPRD_sp49nazdru | C(40)
Poznámka | Poznámka ke druhu externího příkazu | SPEXTPRD_sp49koment | M
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(17)
Datum a čas zápisu | Datum a čas zápisu záznamu události | SPEXTPRD_sp00datzap | T

    Viz.také

    Přístupová práva


SELECT pro export

Popis

Příkaz SELECT pro export.


Zobrazené informace ve stromu

Popis

Jedná o činnost, kterou má uživatel dostupnou po stisku pravého tlačítka na operaci ve stromu hlavního procesu. Na výběr má několik možností, této činnosti se však týká volba "události operace". Zobrazení událostí ve stromu hlavního procesu je přímo závislé na tom, jak jsou u jednotlivých druhů operací nadefinované "informace stromu pro druh operace".

Po stisku pravého tlačítka myši na operaci ve stromu hlavního procesu a volbě "události procesu" se uživateli zobrazí jednotlivé události dané operace v procesu.

Datový model

  • SPKOMPUZ Uzavřené období komponenty

    • Formulář

    Formulář činnosti - Výraz
    Výraz zobrazených informací o události ve stromu

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Výraz | Tvorba výrazu tvůrcem výrazů

    Viz.také

    Výraz


Inf. stromu pro druh operace

Popis

Jedná se o možnost zapsat si pomocí jednotlivých výrazů způsob zobrazení událostí ve stromu hlavního procesu. Tím, že si uživatel vytvoří tyto informace stromu pro druh operace, v podstatě určuje, jak se po vyvolání stromu hlavního procesu budou zobrazovat události operace po stisku pravého tlačítka myši na operaci.

Tuto činnost má uživatel dostupnou u druhu operace v menu Volby. Po stisku klávesy F3 jsou u druhu operací některých komponent tyto informace předdefinované, jinde je musí uživatel vytvořit sám.

Datový model

  • SPTYPUZ Výraz zobrazení informací o události ve stromu pro danou operaci

    • Formulář

    Formulář činnosti - Výraz
    Výraz zobrazených informací o události ve stromu

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Výraz | Tvorba výrazu tvůrcem výrazů

    Viz.také

    Výraz


Menu formuláře

Popis

Jedná se o funkci, která je z menu Volby nebo po stisku klávesy F6 dostupná ze stromu hlavního procesu. V podstatě supluje funkci pravého tlačítka myši na činnostech stromu hlavního procesu. Pokud uživatel umístí kurzor na řádek procesu a spustí činnost menu formuláře, zobrazí se mu nabídka činností, které strom hlavního procesu umožňuje pro proces. Totéž platí pro operace procesu ve stromu hlavního procesu.


Dávkové operace události

Popis

Tato činnost je dostupná pod menu Volby v událostech. V případě, že je na danou událost napojena dávková operace, zobrazí se uživateli formulář, kde jsou k dispozici informace o dávkových operacích události.

Datový model

  • SPDAVKA Událost dávkové komponenty
    • SPPRCOD Operace procesu
      • SPPRC Proces
      • SPTYP Druh procesu/operace
        • SPPRISTU Přístupové právo uživatele k věci
      • BWUZIVAT Uživatel systému
      • BWUZIVAT Uživatel systému (alias BWUZIVA2)

    • Formulář

    Formulář činnosti - Strom hlavního procesu
Mřížka [Události dávkové komponenty]
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Název druhu operace | Název druhu procesu
Zahájení | Datum zahájení operace
Zahájil | Jméno uživatele systému
Ukončení | Datum ukončení operace
Ukončil | Jméno uživatele systému
Připravena | Operace je připravena ke spuštění
Zahájena | Operace zahájena
Předb.ukon. | Operace ukončena předběžně
Ukončena | Operace ukončena

    Mřížka [Události dávkové komponenty] činnosti - Strom hlavního procesu

    Mřížka [Události dávkové komponenty] činnosti - Strom hlavního procesu
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Operace | Identifikátor druhu operace
Název druhu operace | Název druhu procesu
Zahájení | Datum zahájení operace
Zahájil | Jméno uživatele systému
Ukončení | Datum ukončení operace
Ukončil | Jméno uživatele systému
Připravena | Operace je připravena ke spuštění
Zahájena | Operace zahájena
Předb.ukon. | Operace ukončena předběžně
Ukončena | Operace ukončena

    Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Strom hlavního procesu | Zobrazení hlavního stromu procesu-operace
F7 | Diagram procesu | Zobrazení diagramu procesu
F9 | Spustit operaci | Spuštění zobrazené operace

    Viz.také

    Strom hlavního procesu | Diagram procesu | Spustit operaci


Odstranit označené záznamy

Popis

Tato činnost je pro uživatele dostupná pod menu Volby – Označování nebo po stisku klávesy Ctrl O. Umožňuje uživateli zrušit označené záznamy (dotaz: „Opravdu odstranit označené záznamy?“). Především se tato činnost využije v operacích, když uživatel zjistí, že potřebuje větší počet událostí operace odstranit, tak aby nemusel rušit každou jednotlivě, tak si je označí a poté jedním krokem zruší.


Odeslat dokument

Popis

Tato činnost je pro uživatele dostupná pod menu Volby v činnostech, které se týkají dokumentů. Při aktivaci této činnosti dochází k automatickému spuštění aplikace MS Outlook, kde je připojen daný dokument. Pokud je dokument spojen jako objekt s operací pošty (pomocí objektové vazby) a adresát zásilky má uvedeno i spojení na mail, je při spuštění aplikace MS Outlook kromě dokumentu předplněn v mailové zprávě i adresát.


Doplnění pohledu transformace

Popis

Doplnění pohledu transformace umožňuje rozšířit množinu výstupních atributů komponenty o další uživatelsky definované. Je důležité si uvědomit, že tento výpočet probíhá samostatně pro každou událost zdrojové operace, takže pokud je následně v pravidle transformace aplikován agregační výraz, bude doplněná numerická hodnota sčítána. To někdy není žádané a lze tomu zabránit definicí výběru v pravidle, např. RECNO ('DATA')=1

Datový model

  • SPTRNW Doplnění pohledu transformace

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Editovat kód | Editovat kód vlastnosti
F6 | Aktuální tvar dotazu | Aktuální tvar dotazu doplnění pohledu transformace
F7 | Zkušební vygenerování pohledů | Zkušební vygenerování doplnění pohledů transformace
- | Kontrolní kompilace | Kontrolní kompilace
- | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností

    Formulář

    Formulář činnosti - Knihovny vkládaného kódu
Mřížka [Doplnění pohledu transformace]
Doplnění | Identifikace doplnění pohledu transformace
Název doplnění | Název doplnění pohledu transformace
Listovací rámeček
Stránka #1 Doplnění pohledů
Slučování | Slučovat s předdefinovaným dotazem
Fetchmemo | Fetchmemo
Atributy | Seznam doplněných atributů do pohledu transformace
Selekt - join | Část selekt - join doplnění pohledu transformace
Výběr | Část výběr (where) doplnění pohledu transformace
Skript | Kód skriptu provedený nad daty dotazu před transformací
Poznámka | Poznámka
Stránka #2 Připojované záznamy
Mřížka [Připojované záznamy]
Pořadí | Pořadí
Txt1 | Text 1
Txt2 | Text 2
Txt3 | Text 3
Txt4 | Text 4
Txt5 | Text 5
Txt6 | Text 6
Num1 | Num 1
Num2 | Num 2
Num3 | Num 3
Poznámka | Poznámka

    Mřížka [Doplnění pohledu transformace] činnosti - Knihovny vkládaného kódu

    Mřížka [Doplnění pohledu transformace] činnosti - Knihovny vkládaného kódu
Doplnění | Identifikace doplnění pohledu transformace
Název doplnění | Název doplnění pohledu transformace

    Mřížka [Připojované záznamy] činnosti - Knihovny vkládaného kódu

    Mřížka [Připojované záznamy] činnosti - Knihovny vkládaného kódu
Pořadí | Pořadí
Txt1 | Text 1
Txt2 | Text 2
Txt3 | Text 3
Txt4 | Text 4
Txt5 | Text 5
Txt6 | Text 6
Num1 | Num 1
Num2 | Num 2
Num3 | Num 3

    Atributy tisku

    Základní údaje
Doplnění | Identifikace doplnění pohledu transformace | SPTRNW_spa1id | C(6)
Název doplnění | Název doplnění pohledu transformace | SPTRNW_spa1nazdop | C(40)
Atributy | Seznam doplněných atributů do pohledu transformace | SPTRNW_spa1atrib | M
Selekt - join | Část selekt - join doplnění pohledu transformace | SPTRNW_spa1join | M
Výběr | Část výběr (where) doplnění pohledu transformace | SPTRNW_spa1where | M
Poznámka | Poznámka | SPTRNW_spa1koment | M
Komponenta | Identifikace komponenty | SPTRNW_sp06idsubs | C(3)
Fetchmemo | Fetchmemo | Výpočet | C(3)
Slučování | Slučovat s předdefinovaným dotazem | Výpočet | C(3)
Skript | Kód skriptu provedený nad daty dotazu před transformací | SPTRNW_spa1kod | M

    Při pohybu v Připojované záznamy
Pořadí | Pořadí | SPTRNWZ_spf0porad | N(3)
Txt1 | Text 1 | SPTRNWZ_spf0txt1 | C(40)
Txt2 | Text 2 | SPTRNWZ_spf0txt2 | C(40)
Txt3 | Text 3 | SPTRNWZ_spf0txt3 | C(40)
Txt4 | Text 4 | SPTRNWZ_spf0txt4 | C(40)
Txt5 | Text 5 | SPTRNWZ_spf0txt5 | C(40)
Txt6 | Text 6 | SPTRNWZ_spf0txt6 | C(40)
Num1 | Num 1 | SPTRNWZ_spf0num1 | N(20,4)
Num2 | Num 2 | SPTRNWZ_spf0num2 | N(20,4)
Num3 | Num 3 | SPTRNWZ_spf0num3 | N(20,4)
Poznámka | Poznámka | SPTRNWZ_spf0koment | M

    Viz.také

    Editovat kód vlastnosti | Aktuální tvar dotazu | Zkušební vygenerování pohledů | Kontrolní kompilace | Knihovny vkládaného kódu


Zkušební vygenerování pohledů

Popis

Tato činnost je pro uživatele dostupná pod menu Volby v činnosti „Doplnění pohledu transformace“. Po její aktivaci proběhne test jednotlivých nadefinovaných pohledů a uživateli je zobrazen výsledek. V případě, že zkušební vygenerování proběhlo bez chyby, systém hlásí: „test proveden. OK.“, v případě, že je nalezena chyba, je o tom uživatel informován.


Aktuální tvar dotazu

Popis

Tato činnost je pro uživatele dostupná pod menu Volby v činnosti „Doplnění pohledu transformace“. Po její aktivaci se mu zobrazí aktuální tvar dotazu doplnění pohledu transformace.


Kopie záznamu

Popis

Vytvoří kopii záznamu položky smlouvy.


VÝRAZY KOMPONENTY

Popis

Tato činnost je pro uživatele dostupná v činnosti Komponenty pod menu Volby (Informační centrum – Typy a řady). Uživateli se zobrazuje skupinové menu, které obsahuje jednotlivé výrazy komponenty pro transformace v procesech těchto typů:

¨ znakové

¨ numerické

¨ datumové

¨ datum – časové

¨ textové

¨ logické

Viz.také

Definice výrazu


Vstupní maska operace

Popis

Masky operace jsou jedním z nástrojů pro automatizaci vstupu dat (usnadnění) do událostí. Pomocí masky lze v rámci implementace "maskovat" vstupní atributy komponenty, tj. lze definovat zejména:

¨ předplňování vstupovaných údajů události konstantou, resp. konstantou s určitou závislostí na již vstoupených údajích (v případě používání identifikátorů (konstant) v uživatelských nastaveních je nutno uživatele upozornit na to, že identifikátory je NUTNO uvádět velkými písmeny, např. druh artiklu nesmí být v masce uveden jako „mat“, ale musí být zapsán ve tvaru „MAT“).

¨ omezení množiny vstupovaných údajů (atributů) události

Maska je vlastností druhu operace s případným přihlédnutím k druhu procesu, resp. k uživateli.

Všechny masky lze definovat při spuštění operace (i když neobsahuje události) z menu Obecné. Maska operace v procesu a vstupní maska operace se definují přímo v diagramu (druhu) procesu na

vlastnostech operace. Vstupní masku operace a masku operace v procesu je možno definovat i u druhu operace v příslušné činnosti pod menu Obecné (osobní masku je možno definovat pouze ZDE),

tzn. daná operace je aktivována a pod menu Obecné má uživatel dostupné tyto masky. Při jejich změně v tomto okamžiku je pak nutné ještě aktivovat činnost „obnovení masky" (rovněž menu Obecné).

Při definování osobní masky je nutno dodržet zásadu, že nejlépe se definuje pod heslem toho uživatele, pro kterého je tato osobní maska vytvářena (tzn. do IS BM musí být provedeno přihlášení pod

heslem tohoto uživatele), jinak je zápis do definice osobní masky možno zajistit volbou pamatovat (viz. popis dále). Osobní maska se definuje přímo v spuštěné fyzické operaci pro kterou má být maska

nastavena (menu Obecné - Masky - Osobní maska).

Při aplikaci masky může nastat i situace, kdy maska má nastavené odlišné hodnoty pro předplnění vstupovaných dat, než jaké jsou nadefinovány v transformaci. V tomto okamžiku systém uplatní nástroj

s vyšší prioritou, a to jsou pravidla explicitně nastavená v transformaci. Jinak v případě nastavení všech masek jsou priority následující: osobní, vstupní, maska operace v procesu, maska operace.

Po vyvolání činnosti pro definici masky operace se obecně postupuje stejně pro všechny typy masek. Stiskem F3 se zpřístupní formulář pro zadávání atributů v masce. Je možno zadat:

¨ atribut - překryvný seznam všech dostupných atributů, které může uživatel v maskách využít

¨ pořadí atributu

¨ inicializovat - uživatel má k dispozici volbu Ne, Konstantou, Výrazem. Volbu Ne uživatel použije v případě, že žádný atribut nechce přímo vstupovat (předplňuje se např. transformací), ale potřebuje

u něj nastavit např. reakci opakovat. Konstantu uživatel využije, pokud chce do masky zadat rovnou identifikaci atributu, např. identifikaci skladu, druh artiklu, číslo selektoru apod. Volbu Výrazem

uživatel použije tehdy, pokud atribut nechce vstupovat, ale určitým výrazem doplnit, vypočítat apod. Může si vybrat výraz z překryvného seznamu, pokud mu žádný v daný okamžik nevyhovuje, je možno

vytvořit nový.

¨ konstanta - v případě, že uživatel inicializuje konstantou, právě sem zapisuje její hodnotu (hodnota konstanty – identifikátoru musí být uvedena velkými písmeny, např. MAT)

¨ výraz - výběr výrazů z překryvného seznamu. Po stisku F2 a následném stisku F3 má uživatel možnost si nadefinovat výraz nový. Při vstupu událostí komponent byla doplněna možnost dynamicky

předplňovat nevyplněný atribut na základě informace uvedené v masce operace. Pro atribut v masce se zadává inicializovat konstantou nebo výrazem. Ve výrazu je uveden text v syntaxi ##V <výraz>.

Ve výrazu mohou být uvedeny znaky $$$, které budou nahrazeny odpovídajícími alias komponenty (použití dynamické inicializace v masce operace nemusí vždy fungovat, pokud ji přebíjí dynamická

inicializace atributu naprogramovaná ve formuláři. To nastává v případě, že programátorem naprogramovaná dynamická inicializace není umístěna bezprostředně před vstup atributu. Úplné dořešení

tohoto problému bude po dalším doplnění funkčnosti masek operací).

¨ validace - zde uživatel uvádí výraz, podle kterého se daný atribut bude kontrolovat. Např. uživatel může chtít kontrolovat, zda uživatel v atributu „datum splatnosti" uvádí správný datum (tzn. ve

správném tvaru, že se nepřepsal a omylem místo r. 2002 neuvádí např. pouze jen r. 02). Pak je u atributu datum splatnosti uvedena validace v následujícím tvaru: between(###,ctod('01/01/1900'),

ctod('01/01/2101')). Při stisku pravého tlačítka myši (nebo klávesy F2) na tomto atributu se uživateli automaticky předplní výraz validace, který je na tomto atributu programově nadefinován.

¨ chyb. hlášení - souvisí s uvedenou validací. Pokud validace u daného atributu zjistí nějakou nesrovnalost, může si tu uživatel nadefinovat chybové hlášení, které se pak při vstupu dané masky

zobrazí uživateli v okně činnosti. Např. právě při chybně vstoupeném datu splatnosti se objeví hlášení „chybný interval data splatnosti". Chybová hlášení si definuje uživatel sám podle svých vlastních potřeb.

¨ interní validace – překryvný seznam Zapnuta/Vypnuta - nastavení Vypnuta způsobí to, že při vstupu události nebude na daném atributu prováděna validace naprogramovaná BM.EXE

¨ interní předplňování - překryvný seznam Zapnuto/Vypnuto - nastavení Vypnuto způsobí to, že při vstupu události nebude daný atribut dynamicky předplňován tak, jak je naprogramován v BM.EXE

Pozn.: Nevhodné vypnutí interní validace může způsobovat chybné chování systému (např. pro datumové položky doporučujeme kombinovat vypnutí interní validace s validačním výrazem 'NOT EMPTY(###)' ). Na atributu Validace lze aplikovat klávesu F2, kterou se do něho předplní výraz validace atributu, tak jak byla naprogramována v BM.EXE.

¨ F2 reakce - v případě, že by uživatel chtěl při zadávání masky vstupovat i do určitých číselníků (např. adresář, seznam artiklu apod.) a případný atribut si přímo vybrat.

¨ nastavit 1. - při volbě Ano to znamená, že uživatel nastavil první vstupní údaj, což je údaj (atribut), který se bude uživatel při vytváření událostí daného druhu operace <> zadávat jako první, pokud

validace dat <> nepostaví kurzor již na předchozí . Pokud je tento údaj v událostech např. až třetí v pořadí, tak je vhodné zajistit, aby údaje před ním byly správně zadány (tj. zejména, aby byly schopné

úspěšně projít validací), např. je při vstupu první události operace v pořádku zadat a u těchto atributů nastavit v masce volbu „opakovat", pak bude při vstupu další události kurzor stát na třetím atributu.

¨ editovat - volba Ne znamená, že v události není možno tuto hodnotu editovat (atribut je šedý a nepřístupný), obvykle se užije po předplnění hodnoty maskou, transformací, nebo nemá v dané

události význam

¨ opakovat - volba Ano znamená, že tato hodnota (tento atribut) se při vstupu jednotlivých událostí v operaci vždy opakuje podle první události, je však v případě potřeby přístupná editaci

¨ pamatovat - pokud je v masce zadána konstanta, pak při prvním použití operace daného druhu od nastavení masky každým uživatelem se tato konstanta zapíše do jeho osobní masky. Pokud není v

masce zadána žádná konstanta, pouze je u atributu nastaveno pamatovat, tak uživatel při prvním vstupu události daného druhu operace tento údaj vyplní ručně a tento se pak rovněž zapíše do jeho

osobní masky operace, tzn., že při dalším spuštění daného druhu operace budou tyto údaje již předplněny z osobní masky. Pokud se časem zjistí, že nastavené údaje jsou chybné, je nutno je opravit přímo

v osobní masce (tzn. pod heslem daného uživatele).

V masce operace je v případě potřeby možno užít obecnou předkontaci.

Datový model

  • SPTYPMAS Vlastnosti atributu v masce operace
    • SPTEXTY Volný text k události

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Definice výrazu | Výrazy pro transformace
F2 | Předplnit výraz interní validace | Předplnit výraz interní validace
F2 | Volné texty | Přehled volných textů

    Formulář

    Formulář činnosti - Předplnit výraz interní validace
Mřížka [Maska operace]
Atribut | Atribut události
 | Pořadí
Inicializovat | Způsob inicializace
Konstanta | Znaková konstanta
 | Numerická konstanta
 | Hodnota překryvný seznam
Výraz | Výraz
Validace | Výraz validace vstupu atributu v události ( not EMPTY(###) , ###>0 ...)
Chyb.hlášení | Identifikace textu
Popis | Popis textu
Interní validace | Interní validace - Zapnuta/Vypnuta
Interní předplňování | Interní předplňování - Zapnuto/Vypnuto
F2-reakce | Vyvolání činnosti na klávesu F2
Nastavit 1. | Nastavit na atribut při vstupu nové události
Editovat | Povolit vstup hodnoty v události
Opakovat | Opakovat hodnotu podle aktuální události
Pamatovat | Pamatovat hodnotu pro příští spuštění operace aktuálním uživatelem
Poznámka | Poznámka

    Mřížka [Maska operace] činnosti - Předplnit výraz interní validace

    Mřížka [Maska operace] činnosti - Předplnit výraz interní validace
Popis atributu | Popis atributu
Atribut | Atribut události
Typ | Typ atributu
Nastavit 1. | Nastavit na atribut při vstupu nové události
Editovat | Povolit vstup hodnoty v události
Opakovat | Opakovat hodnotu podle aktuální události
Pamatovat | Pamatovat hodnotu pro příští spuštění operace aktuálním uživatelem
Inicializovat | Způsob inicializace

    Viz.také

    Definice výrazu | Předplnit výraz interní validace | Volné texty


Kopie transformace

Popis

Tato činnost je pro uživatele dostupná pod menu Volby v činnosti „Transformace“ (z diagramu procesu klik na tlačítko Vstup transformací ve vlastnostech vazby uzlů). Po aktivaci této činnosti se systém dotazuje na název nové transformace.

Formulář

Formulář činnosti - Knihovny vkládaného kódu
Název transformace Název transformace


Dokumenty artiklu

Popis

Tato činnost je pro uživatele dostupná pod menu Volby. V podstatě se jedná o činnost chováním shodnou s činností „spojené dokumenty – Ctrl D“. Po aktivaci této činnosti se uživateli zobrazí formulář, kde má informace o dosud vytvořených dokumentech a zároveň má po stisku klávesy F3 (nebo ikony „vložení nového záznamu“) možnost založit další nový dokument. Po stisku klávesy F6 nebo aktivaci činnosti „editace dokumentu“ z menu Volby je možno otevřít dokument.

Datový model

  • SPDOKOBS Dokument
    • BWOBJECT Vazba objektů
    • BWUZIVAT Uživatel systému
    • SPDOKTYP Druh dokumentu
      • SPPRISTU Přístupové právo uživatele k věci
    • SPPREDLO Typ předlohy dokumentu

    • Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Editace dokumentu | Editace dokumentu v externích aplikacích
F2 | Druhy dokumentů | Přehled druhů dokumentů
F2 | Předlohy dokumentů | Definice předloh dokumentů
F2 | Vybrat soubor dokumentu | Vybrat soubor dokumentu

    Formulář

    Formulář činnosti - Editace dokumentu
Mřížka [Dokumenty]
 | Typ objektu
Dokument | Název dokumentu
Druh | Identifikátor druhu dokumentu
Název druhu dokumentu | Název druhu dokumentu
Předloha | Identifikátor předlohy.
Název předlohy dokumentu | Text výstižně popisující předlohu.
Externí uložení | Dokument je uložen externě (soubor na disku, na internetu, ...)
Chráněný dokument | Chráněný dokument může opravovat pouze jeho autor
Soubor | Název souboru, ve kterém je dokument uložen
Založil | Jméno uživatele systému
Datum | Datum a čas založení dokumentu
Poznámka | Komentář k dokumentu
 | Obraz dokumentu

    Mřížka [Dokumenty] činnosti - Editace dokumentu

    Mřížka [Dokumenty] činnosti - Editace dokumentu
Datum | Datum a čas založení dokumentu
Dokument | Název dokumentu
Uživatel | Jméno uživatele systému
Druh | Identifikátor druhu dokumentu
Název druhu dokumentu | Název druhu dokumentu
Předloha | Identifikátor předlohy.
Název předlohy dokumentu | Text výstižně popisující předlohu.
Klíč | Klíč pro další možné vyhledávání dokumentů a určení výstupního souboru XML dokumentů

    Viz.také

    Editace dokumentu | Druhy dokumentů | Předlohy dokumentů | Vybrat soubor dokumentu


Import/Export dat

Popis

Umožňuje uživateli provést nebo v případě potřeby i definovat import nebo export dat z externího zdroje (např. z aplikace Excel nebo záznamy deníku aplikace Outlook). Nejčastěji se tato činnost využívá v souvislosti se šablonou plnění projektových úkolů.


Editovat kód vlastnosti

Popis

Po stisku klávesy F5 (nebo aktivací této činnosti z menu Volby) má uživatel k dispozici celý sestavený kód vlastnosti a může v případě potřeby provádět editaci.

Formulář

Formulář činnosti - Definice výrazu
Mřížka [Soubory akcí]
Komp. | Identifikace komponenty
Soubor akcí | Identifikace souboru akcí provedených při spuštění operace
Název | Název souboru akcí provedených při spuštění operace
Listovací rámeček
Stránka #1 Soubory akcí
Poznámka | Poznámka
Stránka #2 Akce v souboru akcí
Mřížka [Akce v souboru akcí]
Pořadí | Pořadí provedené akce
Popis | Popis akce provedené při spuštění operace
Typ | Typ provené akce
Automaticky | Vyvolat akci automaticky při spuštění
Menu | Zařadit do menu
Klávesa | CTRL-klávesa pro spuštění z menu
MPV | Identifikace metapředlohy výstupu
Název metapředlohy | Název metapředlohy výstupu
Doklad nadřízeného | Spustit metapředlohu dokladu nadřízeného procesu
Kód | Kód provedený akcí v jazyce Foxpro
Stav operace připravena | Podle stavu operace připravena
Stav operace zahájena | Podle stavu operace zahájena
Stav operace ukončena | Podle stavu operace ukončena
Poznámka | Poznámka

Mřížka [Soubory akcí] činnosti - Definice výrazu

Mřížka [Soubory akcí] činnosti - Definice výrazu
Komp. | Identifikace komponenty
Soubor akcí | Identifikace souboru akcí provedených při spuštění operace
Název | Název souboru akcí provedených při spuštění operace

Mřížka [Akce v souboru akcí] činnosti - Definice výrazu

Mřížka [Akce v souboru akcí] činnosti - Definice výrazu
Pořadí | Pořadí provedené akce
Popis | Popis akce provedené při spuštění operace


Druhy implementačních rozšíření

Popis

Na základě nadefinovaných druhů doplňujících vlastností formuláře jsou řízena přístupová práva jednotlivých uživatelů k dané funkci doplňující vlastnosti formuláře. Pro to, aby se funkce vlastnosti provedla, musí mít aktuální uživatel k jejímu druhu právo alespoň "čtení". Uživatel s právem "zápis" může vytvářet doplňující vlastnosti formuláře daného druhu.

Datový model

  • SPCINDVT Druh implementačního rozšíření
    • BWUZIVAT Uživatel systému
    • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Druhy doplňuících vlastností]
Druh | Identifikace druhu implemetačního rozšíření
Název druhu | Název druhu implemetačního rozšíření
Založil | Jméno uživatele systému
 | Datum založení druhu
Poznámka | Poznámka

    Mřížka [Druhy doplňuících vlastností] činnosti - Přístupová práva

    Mřížka [Druhy doplňuících vlastností] činnosti - Přístupová práva
Druh | Identifikace druhu implemetačního rozšíření
Název druhu | Název druhu implemetačního rozšíření

    Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci

    Atributy tisku

    Základní údaje
Druh | Identifikace druhu implemetačního rozšíření | SPCINDVT_spa6id | C(6)
Název druhu | Název druhu implemetačního rozšíření | SPCINDVT_spa6nazdru | C(40)
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(17)
Datum vzniku | Datum založení druhu | SPCINDVT_spa6datum | T
Poznámka | Poznámka | SPCINDVT_spa6koment | M

    Viz.také

    Přístupová práva


Vybrat obrázek

Popis

Číselník ikon, pod kterou je vždy umístěn určitý obrázek. Uživatel má možnost si vybrat buď přímo z této nabídky nebo zvolit možnost „jiná ikona“ a vybrat si svůj vlastní obrázek umístěný na vybraném místě ve svém PC.


Kontrolní kompilace

Popis

Tato činnost je pro uživatele dostupná v činnosti XSLT předlohy pod menu Volby. Odkontroluje správnost zapsaných údajů a případné nesrovnalosti uživateli hlásí (v případě, že je vše v pořádku, systém ukazuje pouze poznámku OK).


Design formuláře XML

Popis

Tato činnost je pro uživatele dostupná pod menu Volby nebo po stisku klávesy F6 v činnosti „schémata XML dokumentů“. Design formuláře umožňuje uživateli sestavit si podle nadefinovaných vazeb (záložka Vazby) optické rozložení XML dokumentu.


Editor XML

Popis

Aktivuje se po stisku F6 nebo po stisku tlačítka „editace dokumentu“ v činnosti Dokumenty. V levé části formuláře se zobrazí název daného XML dokumentu a v pravé části je informace o jeho nadpisu, popisu a obsahu. Po stisku pravého tlačítka myši na názvu dokumentu má uživatel k dispozici další činnosti související s dokumentem:

¨ výstupy

¨ přidat nový uzel – podle typu dokumentu možnost přidání další kapitoly, nového pojmu do slovníku pojmů apod.

¨ kopírovat odkaz na dokument

¨ uzamknout uzel – volba Ano/Ne

¨ editovat Word text uzlu – spustí se aplikace Word, kde má uživatel dokument k dispozici pro případnou editaci

¨ vlastnosti dokumentu

Vyvolávané činnosti

K. | Činnost | Popis
F3 | Nový záznam podle schématu |
^S | Uložit dokument | Uložit dokument

Formulář

Formulář činnosti - Nový záznam podle schématu
 | Seznam komponent
 | Jednoznačná časová identifikace pro pracovní soubory = plněna SYS(2015)

Viz.také

Nový záznam podle schématu | Uložit dokument | Výběr schématu XML


Výběr schématu XML

Popis

Výběr schématu XML.

Formulář

Formulář činnosti - Druhy plnění proj.úkolů
Seznam komponent


Uložit dokument

Popis

Tato činnost se aktivuje klávesou Ctrl S nebo volbou činnosti z menu Volby. Uživateli se zobrazuje dotaz, zda uložit dokument – volba Ano/Ne.


Kopírovat odkaz na dokument

Popis

Ve většině činností je tato možnost dostupná po stisku pravého tlačítka na názvu dokumentu (nebo funkční klávesa F5). Umožňuje zkopírovat odkaz na dokument a v jiném dokumentu po stisku pravého tlačítka myši naopak tento zkopírovaný odkaz na dokument zase vložit.


Předplnit nav. XSLT předlohy

Popis

Tuto činnost má uživatel k dispozici pod menu Volby v činnosti XSLT předlohy. Po její aktivaci dojde k automatickému naplnění navazujících XSLT předloh. Ty jsou pro uživatele k dispozici na samostatné záložce („navazující XSLT předlohy“).


Spustit obecný strom

Popis

Z činnosti „definice obecných stromů“ je možno jednotlivé obecné stromy přímo spouštět. To uživatel provede po stisku klávesy F9 nebo aktivací činnosti „spustit obecný strom“ z menu Volby. Podle nastavené definice je pak zobrazen aktuální obecný strom (po stisku klávesy F5 lze editovat hodnoty jednotlivých atributů obecného stromu).

Uživatelsky změnit zobrazení a ovládání obecného stromu lze pomocí činnosti „nastavení stromu“. Tuto činnost uživatel aktivuje po stisku pravého tlačítka myši na názvu činností v obecném stromu nebo kdekoliv ve volném prostoru obecného stromu.

Formulář

Formulář činnosti - Editor hodnot atributů uzlu obecného stromu
Obecný strom

Vyvolávané činnosti

K. | Činnost | Popis
F5 | Editor hodnot atributů uzlu obecného stromu | Editor hodnot atributů uzlu obecného stromu

Viz.také

Editor hodnot atributů uzlu obecného stromu


Strom schématu XML dokumentu

Popis

Tuto činnost uživatel aktivuje po stisku klávesy F9 z činnosti „Schémata XML dokumentů“. Pro uživatele tato činnost představuje stromové zobrazení definice schématu jednotlivých XML dokumentů.

Formulář

Formulář činnosti - Nový záznam podle schématu
Strom schématu XML dokumentu

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Nový záznam podle schématu

Popis

Po stisku klávesy F3 má uživatel možnost vytvořit nový záznam podle schématu.


Uložit novou verzi dokumentu

Popis

Jedná se o činnost, která je v případě nastavení dostupná na každém dokumentu a umožňuje sledování jednotlivých revizí. Revizí dokumentu rozumíme kopii obsahu daného dokumentu zaznamenanou v čase. Ve formuláři dokumenty je k tomuto účelu vytvořena záložka „revize dokumentu“. Zde se uživateli zobrazuje přehled jednotlivých revizí, a to těch dokumentů, které mají na záložce dokumenty zatržen příznak „automatické ukládání revizí dokumentu“. Při zatržení tohoto příznaku vznikají revize daného dokumentu automaticky, ale v případě potřeby (pokud tento příznak zatržen není, ale uživatel by si rád uchoval průběh dokumentu v čase) je možno revize vytvořit i manuálně a to volbou činnosti „uložit novou revizi dokumentu“ z menu Volby.

U každé revize se eviduje datum, čas jejího vzniku a uživatel, který ji založil. Nepotřebné revize je možné na záložce „revize dokumentu“ rušit. Revize je možné sledovat pouze pro dokumenty uložené v databázi, tzn. u dokumentů, které mají zatržen příznak „externí uložení“, revize sledovat nelze.


OBRATOVÉ HODNOTY ARTIKLU

Popis

Přes toto menu (vyvolá se pravým klikem myši na tučném atributu artikl) si uživatel vyvolá informace o obratových hodnotách artiklu.

Viz.také

Obraty skladu | Obraty skladu zvířat


Kategorie doplňující vlastnosti/knihovny

Popis

Tato činnost obsahuje jednotlivé kategorie doplňující vlastnosti/knihovny, které uživatel využije při zadávání knihovny vkládaného kódu. U každé kategorie se definuje jednoznačná identifikace, název a případná poznámka.

Datový model

  • SPCINDVK Kategorie doplňující vlastnost formuláře/knihovny vkládaného kódu

    • Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Kategorie]
Kategorie | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
Název kategorie | Název kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
Poznámka | Poznámka

    Mřížka [Kategorie] činnosti - Přístupová práva

    Mřížka [Kategorie] činnosti - Přístupová práva
Kategorie | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu
Název kategorie | Název kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu

    Atributy tisku

    Základní údaje
Kategorie | Identifikace kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu | SPCINDVK_spc1id | C(6)
Název kategorie | Název kategorie doplňující vlastnosti formuláře/knihovny vkládaného kódu | SPCINDVK_spc1nazkat | C(40)
Poznámka | Poznámka | SPCINDVK_spc1koment | M


Design formuláře uzlu obecného stromu

Popis

Tuto činnost má uživatel dostupnou po stisku klávesy F6 z činnosti „definice obecných stromů“. V podstatě slouží k vytvoření designu (čili vzhledu) aktuálního obecného stromu. To se provede srovnáním jednotlivých atributů do požadovaného tvaru.


Editor hodnot atributů uzlu obecného stromu

Popis

Po spuštění obecného stromu má uživatel po stisku klávesy F5 možnost editovat hodnoty atributů.

Formulář

Formulář činnosti - Přístupová práva
Výběr typů dle přístupu


Určit soubor duplikátu dokumentu

Popis

Uživatel ze seznamu vybírá název dokumentu, do kterého je po změně dokumentu automaticky ukládán duplikát dokumentu.


Spustit externí příkaz

Popis

Tato činnost je pro uživatele dostupná po stisku klávesy F9 v činnosti „externí příkazy“. Po jeho aktivaci systém spustí nadefinovaný aktuální externí příkaz.


Překlad názvu umístění nebo druhu

Popis

Tato činnost poskytuje uživateli možnost přeložit si aktuální umístění nebo druh procesu. Zadává se jazyk, popis ve vybraném jazyce a případná poznámka.

Datový model

  • SPPREKLA Předklad umístění nebo druhu

    • Formulář

    Formulář činnosti - Skupiny procesů / předloh výstupu
Mřížka [Překlad]
Jazyk | Identifikace jazyka
Popis | Popis
Poznámka | Poznámka

    Mřížka [Překlad] činnosti - Skupiny procesů / předloh výstupu

    Mřížka [Překlad] činnosti - Skupiny procesů / předloh výstupu
Jazyk | Identifikace jazyka
Popis | Popis
Poznámka | Poznámka


AKCE DOKUMENTU

Popis

Akce dokumentu má uživatel možnost prohlížet si na dokumentu po stisku klávesy F7. Dostupné jsou však pouze u dokumentu, která má svoji předlohu nadefinovanou na základě spouštěné aplikace, která u sebe má nadefinované akce, tzn. že pořadí je následující: předloha dokumentu – spouštěné aplikace – záložka akce.


Význam předkontace do schránky

Popis

Vloží text významu předkontace do schránky pro následné vložení klávesou CTRL+V.


Části dne obecného kalendáře

Popis

Části dne obecného kalendáře slouží uživateli pro nadefinování jednotlivých částí dne, které pak použije při definování nového kalendáře do dnů v týdnu. Uživatel vstupuje:

¨ část dne – identifikace a název části dne (např. celý den)

¨ čas od – do (definice času, který se týká zvolené části dne, tzn. při části dne celý den je pak zadáno 00:00 až 23:59)

¨ předplňovat – Ano/Ne (pokud je zadáno Ano, tato část dne se pak automaticky předplňuje do Dnů v týdnu při založení nového kalendáře)

Datový model

  • SPKALENC Část dne v kalendáři

    • Formulář

    Formulář činnosti - Předplnit kalendář
Mřížka [Části dne]
Část dne | Identifikace části dne
Název části dne | Název části dne
Čas od | Čas od
Čas do | Čas do
Předplňovat | Předplňovat při zaloření nového kalendáře do dnů v týdnu
Poznámka | Poznámka

    Mřížka [Části dne] činnosti - Předplnit kalendář

    Mřížka [Části dne] činnosti - Předplnit kalendář
Část dne | Identifikace části dne
Název části dne | Název části dne

    Atributy tisku

    Základní údaje
Část dne | Identifikace části dne | SPKALENC_spd5id | C(6)
Název části dne | Název části dne | SPKALENC_spd5nazcas | C(40)
Čas od | Čas od | SPKALENC_spd5casod | C(5)
Čas do | Čas do | SPKALENC_spd5casdo | C(5)
Předplňovat | Předplňovat při zaloření nového kalendáře do dnů v týdnu | Výpočet | C(3)
Poznámka | Poznámka | SPKALENC_spd5koment | M


Předplnit kalendář

Popis

Tato činnost se aktivuje po stisku klávesy F5 z činnosti Výjimky v kalendáři. Zadáním data od – do a nastavením příznaku platnosti se pak předplní jednotlivé dny podle nastaveného kalendáře u dané trasy.

Formulář

Formulář činnosti - Předplnit kalendář
Datum | Datum
do | Datum do
Platný | Platný den kalendáře Ano/Ne


Výjimky v kalendáři

Popis

Tato činnost poskytuje uživateli možnost nastavit si různé výjimky v kalendáři, který se přiřazuje k jednotlivým nadefinovaným trasám.

Datový model

  • SPKALENV Výjimka v obecném kalendáři
    • SPKALENC Část dne v kalendáři

    • Formulář

    Formulář činnosti - Předplnit kalendář
Mřížka [Výjimky v obecném kalendáři]
Datum | Datum
Čas od | Čas od
Čas do | Čas do
Část dne | Identifikace části dne
Platí | Platnost dne kalendáře
Poznámka | Poznámka

    Mřížka [Výjimky v obecném kalendáři] činnosti - Předplnit kalendář

    Mřížka [Výjimky v obecném kalendáři] činnosti - Předplnit kalendář
Datum | Datum
Název části dne | Název části dne
Čas od | Čas od
Čas do | Čas do

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Předplnit kalendář |
F2 | Části dne obecného kalendáře | Části dne obecného kalendáře

    Atributy tisku

    Základní údaje
Datum | Datum | SPKALENV_spd7datum | D
Část dne | Identifikace části dne | SPKALENV_spd5id | C(6)
Čas od | Čas od | SPKALENC_spd5casod | C(5)
Čas do | Čas do | SPKALENC_spd5casdo | C(5)
Platí | Platnost dne kalendáře | Výpočet | C(3)
Poznámka | Poznámka | SPKALENV_spd7koment | M

    Viz.také

    Předplnit kalendář | Části dne obecného kalendáře


Druh obecné předkontace

Popis

Uživatel má možnost si definovat jednotlivé druhy obecných předkontací. Ke každému druhu lze nastavit přístupová práva (zápis, čtení, žádné).

Datový model

  • SPPREDKD Druh obecné předkontace
    • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Druhy]
Druh | Identifikátor druhu obecné předkontace
Název druhu | Název druhu obecné předkontace
Poznámka | Poznámka

    Mřížka [Druhy] činnosti - Přístupová práva

    Mřížka [Druhy] činnosti - Přístupová práva
Druh | Identifikátor druhu obecné předkontace
Název druhu | Název druhu obecné předkontace

    Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci

    Atributy tisku

    Základní údaje
Druh | Identifikátor druhu obecné předkontace | SPPREDKD_spe1id | C(6)
Název druhu | Název druhu obecné předkontace | SPPREDKD_spe1nazdru | C(40)
Poznámka | Poznámka | SPPREDKD_spe1koment | M

    Viz.také

    Přístupová práva


Doplnění mřížky formuláře

Popis

Pro rozšíření možností uživatelů při práci s IS BM je možné přidávat do mřížek formulářů vlastní sloupce. Vlastní sloupce do mřížky formuláře můžeme přidávat ze dvou důvodů:

1. chceme přidat sloupec, který je ve struktuře kurzoru dotazu (např. jméno kontaktní osoby ve formuláři adresáře)

2. chceme přidat sloupec, který není ve struktuře kurzoru dotazu (např. celková suma pohledávek adresáta ve formuláři adresáře) - pouze pro základní mřížku formuláře

Důvod ad.1. je řešen pomocí doplňujících vlastností formuláře a důvod ad. 2. je řešen pomocí obecných výběrů.

Ve formuláři "Doplnění mřížky formuláře" se definuje na první záložce:

¨ název doplnění - text

¨ poznámka

na druhé záložce „Sloupce“ popis jednotlivých sloupců doplnění -

¨ alias - text - alias kurzoru, který mřížka zobrazuje - pro základní mřížku nemusí být uveden - pro ostatní je možné zjistit volbou "Statistika SQL"

¨ návěští - text - bude zobrazen v záhlaví sloupce

¨ stavový řádek - text - text zobrazovaný na stavovém řádku obrazovky při vstupu na položku sloupce

¨ výraz - text - výraz v jazyce Foxpro - hodnota získaná jeho vyhodnocením bude zobrazována ve sloupci (ve výrazu je možné užít makro $$$, které je nahrazováno aliasem kurzoru mřížky)

¨ formát - text - formátovací výraz pro hodnotu výrazu

¨ pozice - číslo - určuje pozici sloupce v mřížce - není ovlivňována osobním nastavením mřížky uživatele, tj. sloupec je vždy zobrazen v dané pozici bez ohledu na tato nastavení

¨ pořadí - číslo - určuje pořadí sloupce v rámci stejné pozice

¨ šířka - číslo - šířka sloupce v pixelech

Pokud vyhodnocení výrazu sloupce není platná hodnota, není tento sloupec do mřížky zařazen (tj. neplatný výraz není považován za chybu). Výjimku tvoří výrazy uvedené znakem vlnovka - předpokládá se, že výrazu je uvedena funkce např. tool.sql_dotaz.

Příklady řešení:

Řešení přidání nového sloupce (jméno kontaktní osoby ve formuláři adresáře) do formuláře mřížky přes doplnění v doplňující vlastností formuláře: Odpovídající doplnění mřížky formuláře pak bude obsahovat tuto definici sloupce:

alias =

návěští = Osoba

stavový řádek = Jméno kontaktní osoby

výraz = $$$.ad11jmeno

formát =

pozice = 3

pořadí = 10

šířka = 80

Řešení přidání nového sloupce (celková suma pohledávek adresáta) do formuláře mřížky přes položku Atributy v obecném výběru:

V obecném výběru pak bude zadáno následující:

atributy = (select sum(pluda.pl02czrmnu) from %%%.pluda
where pluda.ad01id=adadsat.ad01id and pluda.pl02pohzav=1 and
pluda.pl02uhraze=0) as dluh

výraz = dluh>0

Odpovídající doplnění mřížky formuláře bude obsahovat definici sloupce

alias =

návěští = Dluh

stavový řádek = Dluh adresáta

výraz = $$$.dluh

formát = 999 999 999.99

pozice = 2

pořadí = 10

šířka = 80

Datový model

  • SPGRID Doplnění mřížky činnosti formuláře

    • Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Doplnění mřížky]
Doplnění | Popis doplnění mřížky formuláře
Listovací rámeček
Stránka #1 Doplnění mřížky
Poznámka | Poznámka
Stránka #2 Sloupce
Mřížka [Sloupce]
Alias | Alias kurzoru mřížky
Návěští | Návěští sloupce
Stav.řádek | Stavový řádek sloupce
Výraz | Výraz sloupce v syntaxi jazyka Visual Foxpro (místo alias je možné zadávat makro $$$)
Formát | Formát hodnoty výrazu
Pozice | Pozice sloupce v mřížce
Pořadí | Pořadí sloupce stejné pozice
Šířka | Šířka sloupce v pixelech
Poznámka | Poznámka

    Mřížka [Doplnění mřížky] činnosti - Přístupová práva

    Mřížka [Doplnění mřížky] činnosti - Přístupová práva
    Doplnění Popis doplnění mřížky formuláře

    Mřížka [Sloupce] činnosti - Přístupová práva

    Mřížka [Sloupce] činnosti - Přístupová práva
Alias | Alias kurzoru mřížky
Pozice | Pozice sloupce v mřížce
Pořadí | Pořadí sloupce stejné pozice
Návěští | Návěští sloupce
Výraz | Výraz sloupce v syntaxi jazyka Visual Foxpro (místo alias je možné zadávat makro $$$)
Formát | Formát hodnoty výrazu
Šířka | Šířka sloupce v pixelech

    Atributy tisku

    Základní údaje
Doplnění | Popis doplnění mřížky formuláře | SPGRID_spe4nazdop | C(40)
Poznámka | Poznámka | SPGRID_spe4koment | M

    Při pohybu v Sloupce doplnění
Alias | Alias kurzoru mřížky | SPGRIDS_spe5alias | C(10)
Návěští | Návěští sloupce | SPGRIDS_spe5captio | M
Výraz | Výraz sloupce v syntaxi jazyka Visual Foxpro (místo alias je možné zadávat makro $$$) | SPGRIDS_spe5expr | M
Formát | Formát hodnoty výrazu | SPGRIDS_spe5pict | M
Stav.řádek | Stavový řádek sloupce | SPGRIDS_spe5status | M
Pozice | Pozice sloupce v mřížce | SPGRIDS_spe5pozice | N(2)
Pořadí | Pořadí sloupce stejné pozice | SPGRIDS_spe5porad | N(2)
Šířka | Šířka sloupce v pixelech | SPGRIDS_spe5sirka | N(3)
Poznámka | Poznámka | SPGRIDS_spe5koment | M


Znovu načíst

Popis

Tato činnost umožňuje uživateli „přezobrazení“ (doslova znovu načtení) vybraných dat. Uvedeme si její použití na konkrétním příkladu:

¨ uživatel má načtenou určitou množinu adresátů a prohlíží si jejich údaje. Po stisku klávesy F3 vloží nového adresáta. A po aktivaci činnosti „znovu načíst“ se mu k původní vybrané množině adresátů automaticky přiřadí i nově zařazený adresát.

¨ nebo při různých opravách v číselníkách, kdy pak chce uživatel kompletní údaje vidět ihned

Aktivaci činnosti „znovu načíst“ může uživatel provést dvojím způsobem:

¨ jejím spuštěním pod menu Obecné

¨ dvojklikem levého tlačítka myši na levé spodní části okna činnosti (nejčastěji zobrazuje počet vybraných záznamů)


Překlad popisek

Popis

Činnost „překlad popisek“ je možno vyvolat z menu Volby aktivací příslušné činnosti nebo pomocí klávesy Ctrl P. Popiskou se rozumí návěští vstupovaných, resp. zobrazovaných atributů, text stavového řádku, text zaškrtávacího políčka, seznam hodnot překryvného seznamu, název implementačního rozšíření.

Při zaškrtnutí atributu režim oprav lze činnost překlad popisu vyvolat i po stisku pravého tlačítka myši na daném atributu, překryvném seznamu apod.

Překlady názvů implementačních rozšíření se provádějí samostatnými funkcemi menu Volby:

¨ překlad popisek – název volné karty

¨ překlad popisek – název obecného výběru

¨ překlad popisek – název šablony

¨ překlad popisek – název importu/exportu

¨ překlad popisek – název metapředlohy

¨ překlad popisek – název výkazu

Aktivací této činnosti je vyvolán formulář, ve kterém se vstupuje:

¨ jazyk

¨ typ textu – určuje co je textem překládáno – Návěští/Stavový řádek/Text pro zaškrtávací políčko nebo překryvný seznam/Chybové hlášení

¨ text – přeložený text

¨ poznámka – libovolný text

Přeložené názvy se uplatňují při práci s IS BM v cizím jazyce, a to:

¨ v menu Obecné – tyto překlady mají vyšší prioritu než překlady v „definování nabídek“ (platí pro volné karty a obecné výběry)

¨ v překryvných seznamech obecných výběrů na výběrových záložkách formulářů

¨ ve výběrech pro spuštění (šablony a import/export dat)

Přeložené texty popisek formulářů jsou ukládány mimo SQL databázi implementace IS BM nebo v databázi implementace IS BM. O tomto uložení rozhoduje nastavení programu BM – Preferences – Slovnik_SQL (menu Systém – Nastavení programu BM). Při nastavení Preferences – Slovnik_SQL na:

¨ 0 – (implicitní). Přeložené texty jsou ukládány v souborech SLOVNIK\SLOV_XXX.DBF a SLOVNIK\SLOV_XXX.FPT a SLOVNIK\SLOV_XXX.CDX, kde XXX je identifikace jazyka

¨ 1 – přeložené texty jsou ukládány do tabulky BWSLOVNI v SQL databázi

Datový model

  • SPPREKLP Přeložené návěští a poznámka proměnné volné karty nebo obecného výběru nebo importu

    • Formulář

    Formulář činnosti - Kopie řádku
Mřížka [Přeložený text]
Jazyk | Identifikace jazyka
Typ | Typ textu
Text | Text
Poznámka | Poznámka

    Mřížka [Přeložený text] činnosti - Kopie řádku

    Mřížka [Přeložený text] činnosti - Kopie řádku
Jazyk | Identifikace jazyka
Typ | Typ textu
Text | Text


Editovat definici pro konvertor WINWORD

Popis

Pro každou předlohu dokumentu (formulář Předlohy dokumentu) je možné mj. definovat její vlastnosti:

¨ Skript - text - skript v jazyce Foxpro spouštěný bezprostředně po otevření dokumentu resp. předlohy dokumentu externím programem (záložka Deklarace)

¨ Definice pro konvertor WINWORD - text

Kód skriptu v jazyce Foxpro je vyvolán s parametry:

- _this - objekt - řídící objekt BM, který otevírá dokument

- _sp26 - jednoznačná časová identifikace dokumentu BM resp. předlohy dokumentu

- _predloha - logická hodnota nabývající hodnotu .T. (TRUE), pokud je opravována předloha dokumentu

- _workfile - název pracovního souboru, ve kterém je opravován dokument resp. předloha dokumentu

- _poprve - logická hodnota nabývající hodnotu .T. (TRUE) při první opravě dokumentu

Kód skriptu může použít Konvertor WINWORD. Konvertor WINWORD je interní objekt BM, který je používán také při výstupu předlohou výstupu typu Word. Pro definici konverze může skript použít 'Definici pro konvertor WINWORD' uvedenou v předloze dokumentu. Ve formuláři 'Předlohy dokumentu' je možné spustit volbu z menu Volby -> Editovat definici pro konvertor WINWORD (klávesa F7), kterou je vyvolán formulář pro vstup definice konverze stejný jako při definování předlohy výstupu typu Word.

Kromě použití konvertoru WINWORD je možné použít skript např.:

¨ načtení dat mailmerge po otevření dokumentu (prvním založení nebo každém otevření) - Word 2003 toto sám automaticky neprovádí

¨ vytvoření vlastního specifického mailmerge (mailmerge může být tímto způsobem použit bez nutnosti propojení s operací pošty)

Příklad skriptu s použitím konvertoru WINWORD - skript při prvním otevření dokumentu, předplní tento dokument textem charakteru e-mail:

¨ vlastnost Skript obsahuje

<pre>

LOCAL _o,_sql

IF !_poprve OR _predloha

* konverze nebude provedena, pokud je otevírána předloha nebo se nejedná o první otevření dokumentu

RETURN

ENDIF

* proměnná _SQL bude obsahovat sql dotaz pro zjištění hodnot z události vývěsky spojené s dokumentem

* všimněte si použití parametru _SP26

TEXT TO _sql TEXTMERGE NOSHOW

select first vyudalos.*,adspoj.ad11email,adadsat.ad01adsat

from

%%%.bwobject,%%%.vyudalos,%%%.adadsat,%%%.adspoj

where

bwobject.bw09inst2='<<_SP26>>' and

bwobject.bw09typ2='DD' and

bwobject.bw09typ1='VY' and

vyudalos.vy01=bwobject.bw09inst1 and

adadsat.ad01id=vyudalos.ad01id and

adspoj.ad01id=vyudalos.ad01id and

adspoj.ad11cisspo=vyudalos.ad11cisspo

ENDTEXT

* konvertor používá data kurzoru SQL_TISK

IF !bw_exec(.F.,_sql,'sql_tisk')

RETURN

ENDIF

* volání uložené procedury BW_OWRD vrací instanci objektu konvertoru WINWORD

_o=bw_owrd()

* metoda ADDPROPERTY přidává v instanci objektu vlastnost WORKFILE s názvem pracovního souboru dokumentu tak,

* aby konvertor vytvořil soubor s tímto názvem (viz. definice konverze)

_o.addproperty('workfile',_workfile)

* TOOL.OLEOBJ[2] obsahuje při aktuálním spuštění skriptu odkaz na objekt aplikace Wordu

* dokument ve Wordu musí být uzavřen - konvertor ho znovu otevře resp. vytvoří s jiným obsahem (pokud je v definici konverze určena předloha)

tool.oleobj[2].activedocument.close

* metoda GET_DEFKONV řídícího objektu otevření dokumentu vrátí obsah definice pro konvertor uvedený u předlohy dokumentu

* metoda GO objektu konvertoru spouští konverzi - druhý parametr .T. musí být uveden (určuje, že se nejedná o konverzi podle předlohy výstupu)

_o.go(_this.get_defkonv(),.T.)

</pre>

¨ vlastnost Definice pro konvertor WINWORD obsahuje (všimněte si nastavení .FILE this.workfile)

.WINWORD 1.0

* SPRÁVCE 16.03.2007 15:26:11

.FILE this.workfile

.FILEFORMAT 1

.TEMPLATE 'K:\BMSQL\template\email.dox'

.EMAIL_ADDRESS

ad11email

.ENDEMAIL_ADDRESS

.EMAIL_SUBJECT

vy01text

.ENDEMAIL_SUBJECT

.EMAIL_WORD

.EMAIL_IMPORTANCE 1

.BWPRINTD_BW04WRDEMA

.GROUP

.TABLETYPE 3

.FROM 1

.BORDERS

.ELEMENT body

.EXPR vy01koment

.COMMENT

Komentář, který detailně popisuje událost. - M(10,0)

.ENDCOMMENT

.ELEMENT BWUZIVAT_bw01jmeno

.LABEL "Zapsal"

.EXPR tool.jmenot

.COMMENT

Jméno uživatele systému - C(17,0)

.ENDCOMMENT


Umístění selektorů

Popis

Tato činnost slouží k definici jednotlivých umístění selektorů. Uživatel zadává identifikaci a název umístění. K jednotlivým umístěním lze definovat přístupová práva, čímž je pak v podstatě ošetřen přístup i k jednotlivým selektorům (nemá-li uživatel přístup k umístění uvedenému u selektoru, nemá přístup ani k vlastnímu selektoru).

Datový model

  • SPSEUMIS Umístění selektoru
    • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Umístění selektorů]
Umístění | Identifikace umístění selektoru
Název umístění | Název umístění selektoru
Poznámka | Poznámka

    Mřížka [Umístění selektorů] činnosti - Přístupová práva

    Mřížka [Umístění selektorů] činnosti - Přístupová práva
Umístění | Identifikace umístění selektoru
Název umístění | Název umístění selektoru

    Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci

    Atributy tisku

    Základní údaje
Umístění | Identifikace umístění selektoru | SPSEUMIS_spf3id | C(6)
Název umístění | Název umístění selektoru | SPSEUMIS_spf3nazumi | C(40)
Poznámka | Poznámka | SPSEUMIS_spf3koment | M

    Viz.také

    Přístupová práva


Definovat heslo

Popis

Tuto činnost lze aktivovat po stisku F5 nebo aktivací z menu Volby v činnosti Systémové certifikáty (menu Informační centrum – Typy a řady). Pro uživatele tato činnost představuje možnost nadefinovat si k danému systémovému certifikátu přístupové heslo. Po její aktivaci se zobrazí formulář, kde se 2x zadává heslo, poprvé v atributu „heslo“, podruhé pro ověření v atributu „kontrola hesla“.


Předplnit výraz interní validace

Popis

Po stisku F2 nebo pravého tlačítka myši na atributu „validace“ v masce operace se automaticky předplní výraz validace, který je na tomto atributu programově nadefinován.


Rodné číslo

Popis

Slouží k zadání rodného čísla, které je následně převedeno na identifikaci uživatele.

Obrazovku pro vstup rodného čísla uživatel vyvolá po stisku klávesy F2 na položce identifikace uživatele.

Tím je identifikace uživatele s velkou pravděpodobností jednoznačná v celé republice, což může mít význam při přenosu dat programu mezi různými organizacemi, protože tato identifikace zároveň slouží jako "elektronický podpis" informace.

Rodné číslo není povinný atribut, v případě potřeby je možno jeho vkládání klávesou ESC zrušit a identifikaci uživatele si vložit ručně.

Formulář

Formulář činnosti - Měrné jednotky
Vytvoření identifikace uživatele rodným číslem


Návrat zpět

Popis

Tato činnost umožňuje uživateli pohyb v přehledu funkčních činností v činnosti oprávnění k činnostem. V postatě je tato činnost naprosto shodná s tlačítkem zpět na obrazovce. Pokud si uživatel dvojklikem otevře nějaké menu činnosti, objeví se mu činnosti, které jsou na ni navázány. Tlačítkem "návrat zpět" se vrátí k původní činnosti.


Nápověda k činnosti

Popis

Tato činnost zobrazí uživateli nápovědu k dané činnosti.


Parametry formuláře

Popis

Jedná se o parametry, které se vždy vztahují k danému (tj. aktuálně) spuštěnému formuláři. Tyto parametry je možno nastavit na každém okně pod menu Obecné - Parametry formuláře. Je možno nastavit následující:

¨ reakce na klávesu ESCAPE při prohlížení - možnosti jsou stejné jako u parametrů uživatele, včetně toho, že je možno tyto možnosti ignorovat a zatrhnout rovnou možnost „podle parametrů uživatele“

¨ nastavení formuláře - tento atribut se týká možnosti uchování změn provedených ve formuláři. Je možno měnit jeho setřídění, po spuštění formuláře je nastaveno vždy nějaké implicitní třídění, které si může uživatel podle svých potřeb změnit a v případě potřeby i uchovat. Pokud si uživatel změní i vzhled tabulky (tj. mřížky) v okně, tzn. např. v tabulce „obchodovatelný artikl“ si přesune jednotlivé sloupečky tak, jak mu to vyhovuje, je možno si i tuto změnu uchovat. Možnosti nastavení formuláře tedy jsou:

- neukládat

- uchovat setřídění a nastavení mřížky

- uchovat setřídění

- uchovat nastavení mřížky

- zrušit uchované nastavení

¨ uchovávat pozice oken – tento atribut se týká možnosti zaznamenat pozice oken formulářů pro jednotlivé uživatele systému tak, že při následujícím spuštění daného formuláře je jeho okno zobrazeno v poslední zaznamenané pozici. Způsob zaznamenávání pozice okna formulářů je dán kombinací nastavení „parametrů uživatele“ a „parametrů daného formuláře“. Možnosti nastavení uchování pozice formuláře jsou následující:

- NE

- Ano – automaticky vždy při uzavření okna

- Ano – při nastavení parametrů formuláře

- podle nastavení parametrů uživatele

Výsledné chování IS BM z hlediska uchování pozice oken vyplývá z nastavení těchto obou parametrů. V činnosti „parametry formuláře“ při nastavení atributu „uchovávat pozice oken“ = podle nastavení parametrů uživatele se pak systém chová podle nastavení atributu „uchovávat pozice oken“ v činnosti „parametry uživatele“.

¨ ponechat formulář po návratu hodnoty - je vhodné zaškrtnout u činností typu číselníku (např. artikly skladu, obchodu, adresář) při zadávání operací o více událostech proto, aby uživatel nemusel u každé události na žlutém výběrovém poli (např. u artiklu) zadávat a potvrzovat výběr a pak přenést artikl na událost, tak při vstupu první události a tohoto atributu na číselníku např. právě zmiňovaných artiklů je vhodné zaškrtnout tento příznak a po stisku F2 se uživateli zobrazí rovnou číselník bez toho, aby musel potvrzovat nějaký výběr. Po ukončení práce s IS BM se tento příznak automaticky ruší, tzn., že při dalším přihlášení do systému je nutno si ho v případě potřeby na vybraném číselníku opětovně zaškrtnout.

Formulář

Formulář činnosti - Metapředlohy výstupu
Reakce na klávesu ESCAPE při prohlížení | Reakce na klávesu ESCAPE při prohlížení
Nastavení formuláře | Uložit aktuální nastavení formuláře (setřídění,nastavení mřížky)
Uchovávat pozice oken | Uchovávat pozice oken
Ponechat formulář po návratu hodnoty | Ponechat formulář po návratu hodnoty


Vyhledat soubor

Popis

Tato činnost umožňuje uživateli vyhledat potřebný soubor.


Inicializace hesla

Popis

Tuto funkci využije správce systému v okamžiku, kdy si některý z uživatelů změní své přístupové heslo a pak se stane, že toto změněné heslo „pozapomene“. Správce systému si spustí činnost „uživatelé programu“ (menu SYSTÉM), umístí kurzor na daného uživatele a z menu Volby aktivuje činnost „inicializace hesla“ (funkční klávesa F7). Na dotaz „opravdu si přejete inicializovat heslo uživatele xxx?“ zvolí možnost Ano a tím pádem je u tohoto uživatele znovu jako vstupní heslo platné to, které je uvedeno v atributu „počáteční heslo“.


Překlad popisu

Popis

V této činnosti se uživateli zobrazuje překlad popisu ve zvoleném jazyce. V nabídce hlavního menu si uživatel pod volbou JAZYK vybere určitý jazyk a v činnosti překlad popisu se mu budou zobrazovat všechny přeložené popisy ve zvoleném jazyce.

Formulář

Formulář činnosti - Měrné jednotky
Návěští popisu | Návěští popisu
Uložit přeložený text do BWSLOVPP | Příznak - zaznamenat přeložený text v popisné entitě SLOVPP
 | Identifikace textu
Poznámka popisu | Poznámka popisu


Uživatel přihlášený k serveru

Popis

Tato činnost je pro uživatele dostupná po stisku klávesy F5 nebo pod menu Volby v činnosti „uživatelé programu“ (menu Systém). Umožňuje provést přihlášení k serveru jako jiný uživatel (ne pod jménem uživatele nastaveným v IS BM), resp. jako přímo uživatel serveru.

Formulář

Formulář činnosti - Měrné jednotky
Uživatel | Jméno uživatele systému
Uživatel | Jméno uživatele pro přihlášení k databázovému serveru
Heslo | Heslo uživatele přihlášeného k databázovému serveru


Druhy předloh výstupu

Popis

V této činnosti jsou nadefinované vytvořené druhy předloh výstupu. Ke každému druhu předlohy je možno nadefinovat přístupová práva.

Datový model

  • BWPRINTT Druh předlohy
    • BWUZIVAT Uživatel systému

    • Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci

    Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Druhy předloh]
Druh | Identifikace druhu předlohy
 | Název druhu předlohy
Založil | Jméno uživatele systému
 | Datum a čas založení druhu předlohy
 | Poznámka k druhu předlohy

    Mřížka [Druhy předloh] činnosti - Přístupová práva

    Mřížka [Druhy předloh] činnosti - Přístupová práva
Druh | Identifikace druhu předlohy
Název druhu předlohy | Název druhu předlohy

    Atributy tisku

    Základní údaje
Druh | Identifikace druhu předlohy | BWPRINTT_bw66id | C(6)
Název druhu předlohy | Název druhu předlohy | BWPRINTT_bw66nazdru | C(40)
Poznámka | Poznámka k druhu předlohy | BWPRINTT_bw66koment | M
Datum | Datum a čas založení druhu předlohy | BWPRINTT_bw66datum | T
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(17)

    Viz.také

    Přístupová práva


Generovat triggery tabulky

Popis

Systém vygeneruje triggery dané tabulky.


Generovat všechny triggery

Popis

Systém vygeneruje triggery všech nadefinovaných tabulek.


Výběry vstupem

Popis

Nadefinované obecné výběry jsou shodné s výběry definovanými ve vlastnostech činnosti (pravý klik myši na činnosti v hlavním menu). Výběry vstupem jsou uživateli dostupné v případě, že činnost, ze které se tento výběr spouští má uživatel dostupnou v hlavním menu (tzn. pokud bude mít uživatel v hlavním menu nedostupnou komponentu obchod a její události – a na těchto událostech bude definován tento výběr vstupem, tak při spuštění např. událostí obchodu daného adresáta se mu tento výběr vstupem zobrazovat nebude). Přístup k „výběru vstupem“, tj. zda se uživateli zobrazí na pravý klik myši na atributu „uchovat“ je možný dvojím způsobem podle nastavení atributu „veřejný přístup“ při definici výběru. Tento atribut může dosahovat těchto stavů:

¨ ANO - přístup je dán zařazením aktuálního uživatele do některé ze skupiny uživatelů spojených s výběrem (tedy do skupiny, která má přístup k danému výběru). Přidělovat práva skupin uživatelů má nejen vlastník výběru, ale i správce systému a každý uživatel s právy správce (zároveň mají možnost nastavovat atribut „veřejný přístup“.) V konečném důsledku to znamená, že výběr se nemusí na atributu „uchovat“ zobrazovat ani samotnému vlastníku výběru.

¨ NE - přístup k výběru je výhradní pouze pro vlastníka výběru. Ve formuláři pro definování výběrů vstupem se výběr s takto nastaveným atributem zobrazí pouze jeho vlastníkovi, správci systému a uživateli s právy správce (při neveřejném přístupu není možno definovat pro skupiny uživatelů práva k výběru).

Datový model

  • BWMENPAR Parametr činnosti menu
    • BWUZIVAT Uživatel systému

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Výběrové hodnoty | Nastavení výběrových hodnot
F6 | Metapředlohy výstupu | Metapředlohy výstupu

    Formulář

    Formulář činnosti - Metapředlohy výstupu
Mřížka [Výběry]
Výběr | Název parametru činnosti menu
Listovací rámeček
Stránka #1 Výběry
Vlastník | Jméno uživatele systému
Veřejný přístup | Veřejný přístup k výběru - Ano=podle skupin uživatelů, Ne=pouze vlastník výběru
Poznámka | Poznámka
Stránka #2 Skupiny uživatelů
Mřížka [Skupiny uživatelů]
Skupina | Identifikace skupiny uživatelů
Název skupiny uživatelů | Název skupiny uživatelů
 | Poznámka ke skupině uživatelů

    Mřížka [Výběry] činnosti - Metapředlohy výstupu

    Mřížka [Výběry] činnosti - Metapředlohy výstupu
Název výběru | Název parametru činnosti menu
Veřejný přístup | Veřejný přístup k výběru - Ano=podle skupin uživatelů, Ne=pouze vlastník výběru

    Mřížka [Skupiny uživatelů] činnosti - Metapředlohy výstupu

    Mřížka [Skupiny uživatelů] činnosti - Metapředlohy výstupu
Označování | Označení záznamu
Skupina | Identifikace skupiny uživatelů
Název skupiny uživatelů | Název skupiny uživatelů

    Viz.také

    Výběrové hodnoty | Metapředlohy výstupu


Výběrové hodnoty

Popis

Samotné nastavení parametrů výběru (po stisku klávesy F5) je dovoleno všem uživatelům. Nově založený výběr vstupem automaticky získává aktuální nastavení atributů výběrové záložky ve stavu po posledním zápisu výběru na záložce výběr (např. uživatel si aktivuje činnost kompletní vývěska, na záložce výběr si vyplní atributy zapsal, datum události a text – aktivuje si pravou myší atribut uchovat a bude si chtít nadefinovat nový výběr vstupem). V tom případě po stisku F5 definice nového výběru budou automaticky v definici tohoto výběru již předplněny atributy zapsal, datum události a text.


Označování výrazem

Popis

Funkce vyvolá vstup pro zadání a uchovávání výrazů přihlášeného uživatele. Po uložení výrazu je možné vyvolat označení záznamů, které vyhovují zadané podmínce a zároveň se uplatňuje také aktuálně platný výběr výběrové záložky a případně aktuálně použitý obecný výběr. Funkce "Označování výrazem" se uplatňuje pouze ve formulářích objektů BM a není ji možné vyvolat z menu "označování", je-li v dané chvíli aktivní výběr s přehledem označených záznamů.

Pro usnadnění zadávání dotazu může uživatel používat implementátorem systému předdefinovaná makra. Atributem makra je mimo jiné jeho druh, kterým je možné vyhradit jeho exkluzivní použití některým uživatelům systému, tzn. nadefinovat přístupová práva.

Každý formulář má svou vlastní množinu maker.V makru se definuje:

¨ název makra

¨ template tvar skutečných parametrů makra

¨ textové pole pro vstup části SQL dotazu za WHERE (výraz makra)

¨ textové pole pro vstup části SQL dotazu za FROM

¨ formální parametry makra

Při zadávání dotazu uvádí uživatel název makra se skutečnými parametry. Při jeho vyhodnocování dojde k nahrazení odpovídající části dotazu obsahem výrazu makra. Přitom jsou formální parametry makra nahrazeny parametry skutečnými. Makra pro označování výrazem obsahují ve výrazu makra výraz v syntaxi SQL jazyka serveru Sybase SQL Anywhere, který zpravidla vrací logickou hodnotu. Formální parametry makra se ve výrazu makra uvádějí v hranatých závorkách. Makra není možné vnořovat. Definovat makra je možné z formuláře "Označování výrazem" klávesou F5 nebo volbou činnosti z menu Volby. Při zadávání výrazu označování může uživatel vyvolat rychlou nápovědu klávesou F2 nebo pravým tlačítkem myši.

Označování výrazem je možné používat také ve formulářích spuštění operace komponenty. Praktické použití této možnosti je např. pro operaci komponenty smluv, kdy je možné označovat různé položky smlouvy v operaci podle různých hledisek a s takto označenými položkami provádět různé hromadné úkony (např. vložit do označených položek stejnou cenu pomocí doplňující vlastnosti formuláře).

Datový model

  • BWOZVRZ Výraz označování výběrem

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Definice maker | Definice maker
F9 | Spustit dotaz | Spustit dotaz
F2 | Výběr makra | Výběr makra

    Formulář

    Formulář činnosti - Spustit dotaz
Mřížka [Výrazy označování]
Popis výrazu | Popis výrazu označování
Výraz | Výraz označování

    Mřížka [Výrazy označování] činnosti - Spustit dotaz

    Mřížka [Výrazy označování] činnosti - Spustit dotaz
    Popis výrazu Popis výrazu označování

    Viz.také

    Definice maker | Spustit dotaz | Výběr makra


Definice maker

Popis

Pod pojmem makro rozumíme definici substituce, podle které se má v textu obsahujícím název makra (volání makra) nahradit toto volání výrazem uvedeným v definici makra. Makro může mít definováno parametry, podle jejichž hodnot, uvedených ve volání makra, má být výraz před substitucí upraven. Makra se využívají pro definování často opakovaných textů nebo pro překlad textů do uživatelsky srozumitelné formy.

Makra je možné používat:

¨ v metapředlohách výstupu - vlastnosti Podmínka a Tiskárna na záložce Předlohy v metapředloze

¨ v atributech Volné karty - vlastnosti Inicializace, Validace a Text popisující atributy třídy překryvný seznam, resp. zaškrtávací políčko

¨ v Informačních panelech - vlastnosti SQL

¨ v Obecných výběrech - proměnné výběru typu Makro

¨ v Označování výrazem - výraz (používají stejná makra jako v obecných výběrech)

¨ v Automatickém dokončování

Na první záložce formuláře definice makra se uvádí:

¨ identifikátor definice makra

¨ název makra - nesmí obsahovat mezeru

¨ typ - překryvný seznam - specifikuje typ hodnoty makra - uplatňuje se pro 2/ - typ logický se nabízí pro vlastnost Validace, ostatní typy pro vlastnosti Validace a Text popisující atributy třídy

¨ template - vzor skutečných parametrů makra, který bude předplněn při výběru makra uživatelem

¨ proměnné - překryvný seznam Ano/Ne - Ano = parametry jsou proměnné jazyka SQL nebo proměnné programového kódu, tzn. do výsledného textu zpracovaného makra má být přenesen jejich text bez transformace (používá se pro 2/ a 3/)

¨ výraz - výraz v jazyce SQL (pro 3/,4/ a 5/) nebo výraz v jazyce Foxpro (pro 1/ a 2/ kromě Validace) nebo kód v jazyce Foxpro (pro 2/ v atributu validace)

¨ from - doplnění SQL dotazu v části FROM (uplatňuje se pouze pro 5/)

¨ poznámka - libovolný text

Na záložce parametry makra se uvádí:

¨ pořadí parametru

¨ název parametru

¨ typ parametru - Znakový / Numerický / Datumový / Časový / Vložený text

¨ Délka hodnoty parametru (pro typ parametru=Znakový / Numerický)

¨ Počet desetinných míst (pro typ parametru=Numerický)

Při zpracování textu, ve kterém je obsaženo existující makro nahradí BM všechny výskyty tohoto makra v tomto textu upraveným výrazem definice makra. Ve výrazu definice makra přitom vyhledává parametry makra a nahrazuje je podle skutečných hodnot uvedených ve vyvolání makra. Parametry makra jsou ve výrazu makra uváděny ohraničené v hranatých závorkách a při úpravě výrazu makra jsou nahrazovány:

¨ konstantní hodnotou skutečného parametru ve formátu SQL (proměnné=Ne a Znakový / Numerický / Datumový / Časový)

¨ nebo hodnotou skutečného parametru bez transformace (proměnné=Ne a typ parametru=Vložený text)

¨ nebo textem skutečného parametru (proměnné=Ano)

Ve výrazech maker je možné uvádět text $$$, který bude nahrazen názvem databázové tabulky, jejíž obsah je odpovídajícím formulářem zobrazován. Ve výrazu makra je možné uvádět jiná makra, ale přitom je třeba dbát, aby nedošlo k zacyklení tj., aby makro tímto způsobem přímo nebo nepřímo odkazovalo samo na sebe.

Datový model

  • BWOZMCR Makro výrazů
    • BWOZMCRD Druh makra výrazů
      • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Druhy maker
Mřížka [Makra]
ID | Interní identifikace makra
Makro | Název makra
Listovací rámeček
Stránka #1 Makra
Druh | Identifikátor druhu makra
Název druhu makra | Název druhu makra
Typ | Typ hodnoty makra
Template | Template makra
Proměnné | Parametry makra jsou proměnné Ano/Ne
Výraz | Výraz makra
From | Doplnění tabulek do SQL dotazu za FROM
Poznámka | Poznámka
Stránka #2 Parametry makra
Mřížka [Parametry makra]
Pořadí | Pořadí parametru
Parametr | Název parametru
Typ | Typ parametru
Délka | Délka hodnoty parametru
Des. | Počet desetin parametru

    Mřížka [Makra] činnosti - Druhy maker

    Mřížka [Makra] činnosti - Druhy maker
ID | Interní identifikace makra
Makro | Název makra
Druh | Identifikátor druhu makra
Typ | Typ hodnoty makra

    Mřížka [Parametry makra] činnosti - Druhy maker

    Mřížka [Parametry makra] činnosti - Druhy maker
Pořadí | Pořadí parametru
Parametr | Název parametru
Typ | Typ parametru
Délka | Délka hodnoty parametru
Des. | Počet desetin parametru

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Druhy maker | Druhy maker

    Atributy tisku

    Základní údaje
ID | Interní identifikace makra | BWOZMCR_bw78id | C(6)
Makro | Název makra | BWOZMCR_bw78nazev | C(40)
Druh | Identifikátor druhu makra | BWOZMCR_bw80id | C(6)
Typ | Typ hodnoty makra | Výpočet | C(9)
Název druhu makra | Název druhu makra | BWOZMCRD_bw80drumcr | C(40)
Výraz | Výraz makra | BWOZMCR_bw78vyraz | M
From | Doplnění tabulek do SQL dotazu za FROM | BWOZMCR_bw78from | M
Template | Template makra | BWOZMCR_bw78templa | M
Proměnné | Parametry makra jsou proměnné Ano/Ne | Výpočet | C(3)
Poznámka | Poznámka | BWOZMCR_bw78koment | M
Činnost | Identifikace činnosti | BWOZMCR_bw02krok | C(6)

    Při pohybu v Parametry
Pořadí | Pořadí parametru | BWOZMCRP_bw79porad | N(2)
Parametr | Název parametru | BWOZMCRP_bw79nazev | C(8)
Typ | Typ parametru | Výpočet | C(12)

    Viz.také

    Druhy maker


Druhy maker

Popis

Možnost nadefinování druhů maker, které se pak používají při vytváření definic maker. U každého druhu se zadává identifikace a název a ke každému druhu lze nadefinovat přístupová práva.

Datový model

  • BWOZMCRD Druh makra výrazů
    • BWUZIVAT Uživatel systému
    • SPPRISTU Přístupové právo uživatele k věci

    • Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Druhy maker]
Druh | Identifikátor druhu makra
Název druhu makra | Název druhu makra
Založil | Jméno uživatele systému
Datum vzniku | Datum založení druhu makra
Poznámka | Poznámka

    Mřížka [Druhy maker] činnosti - Přístupová práva

    Mřížka [Druhy maker] činnosti - Přístupová práva
Druh | Identifikátor druhu makra
Název druhu makra | Název druhu makra

    Vyvolávané činnosti

    K. | Činnost | Popis
^B | Přístupová práva | Definování práv přístupu k věci

    Atributy tisku

    Základní údaje
Druh | Identifikátor druhu makra | BWOZMCRD_bw80id | C(6)
Název druhu makra | Název druhu makra | BWOZMCRD_bw80drumcr | C(40)
Poznámka | Poznámka | BWOZMCRD_bw80koment | M
Založil | Jméno uživatele systému | BWUZIVAT_bw01jmeno | C(17)
Datum vzniku | Datum založení druhu makra | BWOZMCRD_bw80datum | T

    Viz.také

    Přístupová práva


Výběr makra

Popis

Po stisku pravého tlačítka myši má uživatel možnost vybrat si ze seznamu dosud nadefinovaných maker.


Spustit dotaz

Popis

Po stisku klávesy F9 se aktivuje funkce, která ověří správnost zápisu dotazu a v případě nesrovnalostí hlásí systém chyby.


Metapředlohy výstupu

Popis

Metapředloha výstupu je objekt, který v sobě skrývá jednu nebo více skutečných předloh výstupu systému BM vytvořených pro jednotlivou činnost (formulář). V datovém modelu systému jsou objekty spojovány s předlohami výstupu právě pomocí objektu "metapředloha výstupu" (např. předloha výstupu pro doklad spojený s druhem procesu, doklad tištěný podle předlohy druhu operace v diagramu procesu ...).

Výstup podle předlohy výstupu zařazené v metapředloze výstupu může být podmíněný. Podmínka výstupu předlohou se vyhodnocuje v okamžiku tisku a je uváděna v definici metapředlohy v syntaxi jazyka Foxpro. Může obsahovat makra. Typickým příkladem makra může být zjištění národnosti aktéra, kterého se týká proces faktury. Odpovídající makro může v sobě použít funkce BM pro SQL dotaz a přitom použít proměnné _sp33cisdr, _sp33cisdpm, _sp33cisd, _sp06idsubs, _sp07idtyp a _sp33porad, které identifikují aktuálně vystupující operaci/proces.

Po aktivaci činnosti metapředlohy výstupu (z činnosti komponenty nebo po stisku pravého tlačítka myši kdekoliv v prostoru činnosti předlohy výstupu) má uživatel k dispozici tyto informace:

¨ záložka „Metapředlohy výstupu“ – identifikace a název metapředlohy a její druh (pomocí atributu druh jsou definována přístupová práva). U každé metapředlohy výstupu lze určit její skupinu (zařazení předloh výstupu a metapředloh do skupin lze pak využít při stromovém zobrazení v činnosti Výstupy). Atribut nabízet (volba Ano/Ne) určuje, zda se bude samotný název metapředlohy také nabízet v seznamu předloh výstupu.

¨ záložka „Předlohy v metapředloze“ – obsahuje jednotlivé předlohy výstupu zařazené pod danou metapředlohu. U každé předlohy se určuje pořadí, název, jazyk, profil, počet kopií atd. Důležitým atributem je „rozhodnutí“. V případě, že metapředloha obsahuje pouze jednu předlohu výstupu, uživatel zde ponechá volbu Ne, tzn. po aktivaci dané metapředlohy bude rovnou probíhat tisk dané předlohy výstupu na základě zadaného profilu. Pokud metapředloha obsahuje více předloh výstupu a uživatel si při vlastním tisku má z tohoto seznamu vybírat, musí mít tyto předlohy nastaveno default nepřipravena. V případě, že metapředloha obsahuje více předloh výstupu, z nichž jedna je ta implicitní, kterou uživatel tiskne např. v 90% případů, ale ostatní chce mít také k dispozici ve výběru, je možno u této implicitní nastavit default připravena a ostatní předlohy budou mít stále default nepřipravena. Při samotném tisku se v rozhodovacím okně pak implicitní předloha nabízí k tisku automaticky, ale v případě potřeby je možno ji změnit za jakoukoliv sestavu z přehledu předloh tisku.

¨ záložky „Výskyt“ poskytují uživateli informační přehled o tom, kde jsou dané metapředlohy zastoupeny

Předloha výstupu v metapředloze výstupu může být prováděna s některými jinými vlastnostmi než s těmi, které jsou uvedeny u dané předlohy (tzn. že pokud se liší nadefinované vlastnosti předlohy od vlastností, které jsou uvedeny v metapředloze, je metapředloha silnější nástroj a při tisku budou uplatněny její vlastnosti). Jedná se o:

1. výstupní jazyk

2. počet kopií

3. profil výstupu

4. navíc pro předlohu typu Excel může definovat výstup na určenou jednu nebo několik různých tiskárem (ve výrazech je možné používat makra)

Kromě toho může být vlastností předlohy výstupu v metapředloze určeno, že při výstupu metapředlohou uživatel rozhodne, která nebo které její předlohy mají být v danou chvíli užity. Metapředlohu je také možné používat volitelně jako běžnou předlohu (tj. může být použita ze seznamu předloh výstupu činnosti). Metapředloha výstupu stejně jako předloha výstupu má určena přístupová práva druhem předlohy (stejná entita). Při výstupu metapředlohou se na práva přístupu v ní obsažené předlohy nepohlíží.

Seznam metapředloh je možné vyvolat v činnostech "Druhy procesů" a "Druhy operací" klávesou F2 při vstupu, v činnosti "Komponenty" z menu Volby a ze seznamu předloh výstupu činnosti výběrem z menu po pravém kliku myší.

Postup při definování metapředlohy výstupu z operace:

¨ uživatel v diagramu procesu vybere operaci, na níž chce nastavit, že po jejím ukončení se má tisknout vybraná předloha. Ve vlastnostech této operace (pravé tlačítko myši na uzlu operace) zatrhne „po ukončení operace tisk operace“. Z překryvného seznamu si zvolí vhodnou metapředlohu (v definici této metapředlohy je uvedena tisková předloha, která se po ukončení operace bude skutečně tisknout).

¨ vytvoření metapředlohy je možno trojím způsobem. V menu Informační centrum - Typy a řady - Druhy operací si uživatel vyhledá danou operaci a na atributu metapředloha stiskne F2 nebo pravé tlačítko myši. Uživatel má možnost si vybrat z již vytvořených metapředloh nebo si vytvořit metapředlohu novou. K ní pak přiřadit vhodnou tiskovou sestavu. Druhý způsob je přímo nad událostmi dané komponenty. Uživatel si vyvolá okno výstupu (menu volby Tisk nebo Ctrl T) a kdekoliv v prázdném prostoru tohoto okna po stisku pravého tlačítka myši zvolí možnost metapředlohy výstupu. Poslední způsob, jak může uživatel editovat či vytvářet předlohy je z menu Informační centrum - Typy a řady - Komponenty, kde v menu Volby je pro každou komponentu dostupná možnost metapředlohy výstupu.

¨ každá metapředloha může obsahovat „n“ tiskových předloh. Tyto předlohy jsou předlohy vytvořené „klasicky“ nad událostmi dané komponenty.

Postup při definování metapředlohy výstupu z procesu:

¨ v diagramu druhu procesu uživatel ve vlastnostech operace (té operace, jejíž události vstupují na tisk dokladu jako poslední) zatrhne atribut „po ukončení operace tisk dokladu“.

¨ v menu Informační centrum - Typy a řady - Druhy procesů u zvoleného druhu procesu nastaví po stisku F2 nebo pravého tlačítka myši metapředlohu výstupu. Může vybrat vhodnou z překryvného seznamu nebo si v případě potřeby vytvořit metapředlohu novou.

¨ jednotlivé tiskové předlohy, které si pak uživatel přiřazuje k metapředlohám se pro procesy vytvářejí v menu Procesy a operace - Procesy po aktivaci činnosti tisk (menu volby Tisk nebo Ctrl T). V této činnosti uživatel stiskne pravé tlačítko myši kdekoliv ve volném prostoru okna „výstupy“. Zvolí možnost metapředlohy a zadá si novou metapředlohu k níž přiřadí vybranou předlohu výstupu.

¨ u každé předlohy výstupu vytvořené v činnosti Procesy je nutno v jejích vlastnostech (vlastnosti předlohy si uživatel vyvolá pravým stiskem myši na názvu předlohy) nastavit ještě prezentaci. Prezentace jsou nástroj, kterým uživatel určuje, které události operací daného procesu budou pro uživatele k dispozici na předloze výstupu.

¨ jednotlivé prezentace se definují v menu Informační centrum - Typy a řady - Prezentace procesů.

Objekt KU_DATA (využívá se k kódu po ukončení operace) byl doplněn o metodu OP_PRINT_META, která provádí výstup metapředlohou.

Pro předlohu výstupu uvedenou v metapředloze je možné určit parametr, který je předloze předán při výstupu metapředlohou. Má význam pro předlohy typu Excel nebo HTML, ve kterých je parametr dostupný v proměnné 'this.param1'. Např. pro pokyn předloze typu Excel, že má být odeslána Mailem, uvedeme v parametru text 'MAIL' a v kódu předlohy zadáme:

.KDYŽ !EMPTY(this.param1) AND ALLTRIM(this.param1)='MAIL'

.EXCEL_CLOSE

.MAIL_RECIPADRESS .....

.MAIL_SUBJECT ......

.MAIL_MESSAGETEXT .....

.MAIL_SEND 1

.JINAK

.EXCEL_NEUKLÁDAT

.KONEC_KDYŽ

Ve formulářích pro definování implementačních rozšíření (volné karty, obecné výběry, importy/exporty dat, šablony, výkazy, metapředlohy výstupu) lze pod menu Volby vyvolat činnost „překlad popisek“.

Datový model

  • BWPRINS Metapředloha výstupu
    • BWPRINTT Druh předlohy
      • SPPRISTU Přístupové právo uživatele k věci

    • Vyvolávané činnosti

    K. | Činnost | Popis
F7 | Diagram procesu | Zobrazení diagramu procesu
^P | Překlad popisek |
- | Definice maker | Definice maker
F2 | Druhy předloh výstupu | Druhy předloh výstupu
F2 | Profily spuštění předloh | Profily spuštění předloh výstupu
F2 | Skupiny procesů / předloh výstupu | Seznam skupin procesů / předloh výstupu
F2 | Výběr makra | Výběr makra

    Formulář

    Formulář činnosti - Skupiny procesů / předloh výstupu
Mřížka [Metapředlohy výstupu]
MPV | Identifikace metapředlohy výstupu
Název metapředlohy | Název metapředlohy výstupu
Listovací rámeček
Stránka #1 Metapředlohy výstupu
Druh | Identifikace druhu předlohy
Název druhu předlohy | Název druhu předlohy
Skupina | Identifikace skupiny procesů
Nabízet | Nabízet v seznamu předloh výstupu formulářů
Poznámka | Poznámka
Stránka #2 Předlohy v metapředloze
Mřížka [Předlohy v metapředloze]
Poř. | Pořadí předlohy v metapředloze
Popis | Popis předlohy v metapředloze
Předloha | Identifikace předlohy pro výstup
Jazyk | Identifikace jazyka
Parametr | Parametr předaný předloze
 | Použít profil předlohy (ne=v procesech podle parametrů předlohy)
Profil | Identifikace profilu spuštění předlohy
Název profilu | Název profilu
Počet kopií | Počet kopií
Rozhodnutí | Uživatel rozhodne o výstupu
Tiskárna | Výstupní tiskárna při přímém výstupu předlohou typu Excel
Podmínka | Podmínka výstupu předlohou
Stránka #3 Výskyt - procesy/operace
Mřížka [Výskyt - procesy/operace]
Stránka #4 Výskyt - diagramy
Mřížka [Výskyt - diagramy]

    Mřížka [Metapředlohy výstupu] činnosti - Skupiny procesů / předloh výstupu

    Mřížka [Metapředlohy výstupu] činnosti - Skupiny procesů / předloh výstupu
Označování | Označení záznamu
MPV | Identifikace metapředlohy výstupu
Název metapředlohy | Název metapředlohy výstupu

    Mřížka [Předlohy v metapředloze] činnosti - Skupiny procesů / předloh výstupu

    Mřížka [Předlohy v metapředloze] činnosti - Skupiny procesů / předloh výstupu
Poř. | Pořadí předlohy v metapředloze
Popis | Popis předlohy v metapředloze

    Mřížka [Výskyt - procesy/operace] činnosti - Skupiny procesů / předloh výstupu

    Mřížka [Výskyt - procesy/operace] činnosti - Skupiny procesů / předloh výstupu
Komp. | Identifikace komponenty
Druh | Identifikátor druhu
Název druhu | Název druhu

    Mřížka [Výskyt - diagramy] činnosti - Skupiny procesů / předloh výstupu

    Mřížka [Výskyt - diagramy] činnosti - Skupiny procesů / předloh výstupu
Proces | Identifikátor druhu procesu
Komp. | Identifikace komponenty
Operace | Identifikátor druhu operace
Název druhu operace | Název druhu operace

    Viz.také

    Diagram procesu | Překlad popisek | Definice maker | Druhy předloh výstupu | Profily spuštění předloh | Skupiny procesů / předloh výstupu | Výběr makra


Definovat nastavení tiskárny

Popis

Tuto činnost je možno aktivovat z činnosti logické nebo fyzické tiskárny, pokud je definována alespoň jedna z tiskáren. Aktivuje se stiskem klávesy F5 nebo volbou příslušné činnosti z menu Volby. Po aktivaci této činnosti se uživateli zobrazí formulář návrháře sestav v jazyce FoxPro a má možnost si upravit záhlaví, tělo a zápatí stránky.


Vybrat tiskárnu

Popis

Po stisku pravého tlačítka myši má uživatel možnost vybrat si tiskárnu.


Seznam ikon

Popis

Uživatel má k dispozici přehled ikon, které může využít při tvorbě definic obecných stromů.

Datový model

  • BWIKONA Ikona v BM

    • Formulář

    Formulář činnosti - Vybrat soubor dokumentu
Mřížka [Ikony]
Ikona | Identifikace ikony
Název ikony | Název ikony
Soubor ikony | Soubor ikony
Poznámka | Poznámka

    Mřížka [Ikony] činnosti - Vybrat soubor dokumentu

    Mřížka [Ikony] činnosti - Vybrat soubor dokumentu
Ikona | Identifikace ikony
Název ikony | Název ikony

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Vybrat soubor dokumentu | Vybrat soubor dokumentu

    Atributy tisku

    Základní údaje
Ikona | Identifikace ikony | BWIKONA_bw88id | C(6)
Název ikony | Název ikony | BWIKONA_bw88naziko | C(40)
Soubor ikony | Soubor ikony | BWIKONA_bw88soubor | M
Poznámka | Poznámka | BWIKONA_bw88koment | M

    Viz.také

    Vybrat soubor dokumentu


Zobrazit objekt

Popis

Tato činnost se aktivuje stiskem klávesy F5 z činnosti „přehled změn záznamů tabulek“ (menu Systém). Uživateli se v této činnosti zobrazují jednotlivé provedené změny v tabulkách IS BM a po aktivaci činnosti „zobrazit objekt“ je přesměrován do aktuálního místa v IS BM, kde byla změna v tabulce provedena.


Definice předlohy typu Excel

Popis

Stejně jako u předloh typu „sestava“ nebo „word“ je nutno nejprve u nové sestavy typu „excel“ nadefinovat položky, které mají být v sestavě obsaženy. Po stisku ikony „opravit předlohu“ se uživateli nabízí okno „výběr položek zahrnutých do nové předlohy“. Přesunem položek z levé části okna do pravé si uživatel vybírá ty atributy, které mají být součástí nové definice sestavy typu „excel“. Po jejich nadefinování a stisku ok se mu nabízí okno s vlastní definicí předlohy. Po stisku ikony „oprava předlohy“ se mu stejné okno zobrazí už i u nadefinovaných předloh výstupu. V okně „výběr položek zahrnutých do nové předlohy“ se definuje i typ předlohy excel. Je možno definovat předlohy dvojího typu:

¨ deklarační – tento typ se předplňuje implicitně („excel typu1“) a definuje se pomocí Editoru deklaračních předloh výstupu do Excelu

¨ programový – aktivuje se, pokud uživatel zaškrtne atribut „excel typu2“. Je tvořen tzv. pseudokódem a upravuje se pomocí textového editoru Foxpro (viz. Popis jazyka generátoru sestav).

Pro možnost odesílání vytvořených dokumentů Excelu 2007 z IS BM e-mailem partnerům, kteří používají nižší verze Excelu byl v činnosti nastavení programu BM vytvořen parametr:

¨ Preferences -> Excel_Fileformat – slouží k určení formátu výstupního souboru Excelu vytvářeného předlohami výstupu typu Excel. Tento parametr může obsahovat jednu nebo více definic pro různé verze Excelu oddělených středníkem. Každá tato definice obsahuje číslo verze Excelu, po kterém za pomlčkou následuje číslo formátu souboru Excelu,

např. Excel_Fileformat=12.0-56

Číslo verze Excelu je dostupné v aplikaci Excel v činnosti Nápověda – O aplikaci Microsoft Office Excel – tlačítko Systémové informace – Microsoft Office Excel – Souhrnné informace.

Editor deklaračních předloh výstupu do Excelu obsahuje tři záložky:

¨ list

¨ sloupce

¨ skript

Záložka „LIST“

¨ název listu – určuje název listu v Excelu, výraz v syntaxi Foxpro (obvykle textová konstanta) – „vlastní název“

¨ soubor – určuje výstupní soubor předlohy - uložení (tzn. cesta k souboru) je nadefinováno (Nastavení IS BM – Preferences Excel_Output_Path) a zde se uvádí už jen přímo název souboru, např. prehled_faktur.xls .

- není uvedena defaultní cesta pro výstupy Excelu – pak se soubor ukládá do adresáře IS BM

- je uvedena absolutní adresářová cesta

¨ šablona – určuje šablonu (přípona XLT), na základě které se založí list. Šablona je uložena v adresáři TEMPLATE v IS BM.

¨ R-Agregace – výraz v syntaxi Foxpro – řádková agregace – po sobě následující zpracovávané záznamy, pro které je hodnota vyhodnocení záznamu shodná, budou sloučeny do jednoho řádku vystupujícího do Excelu a přitom jsou načítány hodnoty ve sloupcích, ve kterých je definována hodnota

¨ třídění – před vlastním tiskem se data třídí podle zde uvedeného výrazu (v syntaxi Foxpro) - v 99% se výraz třídění rovná výrazu v R-Agregaci. Pokud chceme v R-Agregaci nebo v třídění použít ALIAS z doplnění, je nutno ho definovat v deklaraci (ve vlastnostech předlohy)

¨ podpis ř.1, ř.2 a ř.3 – při definování nové předlohy jsou tyto údaje předplněny, je možno je libovolně upravit. Jedná se o výrazy v syntaxi Foxpro, které jsou vloženy v řádcích na konec listu

¨ Textframe – výraz v syntaxi Foxpro – využíváme v případě, že údaje z podpisů nechceme mít na konci listu, ale např. nahoře v záhlaví listu (nadefinován textový rámec). Předpokládá se však, že se tento rámec vyskytuje v šabloně.

¨ 1. řádek – numerická hodnota – určuje první řádek výstupu na listu (kde se začínají tisknout data)

¨ 1. sloupec – numerická hodnota – určuje první sloupec výstupu na listu

¨ celková suma – překryvný seznam – Ano/Ne/Ano tučně/Ano kurzívou/Ano tučně+kurzívou – odpovídající hodnota způsobuje vytvoření závěrečného součtového řádku za všechny řádky listu v požadovaném formátu

¨ automatický formát – zaškrtnuté způsobí přizpůsobení šířky sloupců

¨ tisk na šířku – zaškrtnuté způsobí nastavení tisku na šířku

¨ rychlý výstup – zaškrtnuté urychluje výstup do Excelu – zde je problém s diakritikou, rychlý výstup je vhodný pouze pro sestavy, kde nejsou texty

¨ tlačítko OK – uložení změn a ukončení formuláře

¨ tlačítko Storno – ukončení fomuláře bez uložení změn

¨ tlačítko Editor – vyvolá editor (Foxpro) se vstupem dané definice (pseudokód)

Záložka „SLOUPEC“

¨ seznam sloupců – je možné je libovolně přesouvat

¨ nadpis – výraz v syntaxi Foxpro – obvykle textová konstanta (např.:„název adresáta“)

¨ název sloupce – text – je určen pro definování sloupců typu vzorec (např. pro jednotlivá čtvrtletí mohou být sloupce nazvány Q1, Q2 apod.)

¨ typ – překryvný seznam, který může nabývat hodnot:

- text – znakové a datumové položky (typu „char“)

- hodnota – numerické hodnoty (typu „numeric“)

- vzorec – výpočtové sloupce, kde se používají právě názvy sloupců (např. při názvech sloupců pro čtvrtletí Q1 až Q4, je zde pak uvedeno Q1+Q2+Q3+Q4)

¨ výraz obsahu – pro typy text nebo hodnota - výraz v syntaxi Foxpro, pro typ vzorec – text odpovídající výpočtovému výrazu v Excelu, ve kterém je mžné uvádět odkazy na sloupce pomocí názvů sloupců v hranatých závorkách

¨ formát – text – obvykle určuje formátování čísla (např. ##,###.00)

¨ šířka – numerická hodnota – nepovinný údaj – určuje pevnou šířku sloupce

¨ font – styl písma – vybírá se z překryvného seznamu

¨ ohraničení – výběr z překryvného seznamu – způsob ohraničení sloupce

¨ suma – pokud je v definici listu zaškrtnuta suma, automaticky se vysoučtuje i za sloupec. Pokud v definici listu suma není, možno ji zde zaškrtnout přímo pro daný sloupec.

¨ neopakovat – zaškrtnutí tohoto atributu určuje, že opakovaná hodnota ve sloupci nebude v následujících řádcích zobrazena

¨ zobrazit nuly – zaškrtnutí tohoto atributu zajišťuje, že i v případě, že vyhodnocením výrazu sloupce je zjištěna nulová hodnota, tak i tato se bude zobrazovat při tisku dané předlohy

¨ mezisoučet – výběr z překryvného seznamu stylů – odpovídající hodnota způsobuje vytvoření mezisoučtového řádku při změně hodnoty ve sloupci

¨ tučně – možnost tisku mezisoučtu se zvýrazněním tučně

¨ kurzívou – možnost tisku mezisoučtu kurzívou

¨ také pro 1 řádek – zaškrtnutí tohoto atributu způsobuje, že i v případě, že zdrojem pro mezisoučet je jediný řádek, bude tato hodnota zobrazena

¨ dynamický sloupec – maximální počet sloupců – numerická hodnota- je-li uvedena kladná hodnota, omezuje počet sloupců dynamického sloupce (např. hodnota 12)

¨ dynamický sloupec – S-Agregace – výraz v syntaxi Foxpro – sloupcová agregace, která se používá ve spojení s řádkovou agregací. Podle tohoto výrazu se při slučování řádků vytvářejí sloupce. Slučované řádky, pro které tento výraz nabývá shodnou hodnotu, jsou sečteny do tohoto sloupce s hodnotami vyhodnocení Výrazu obsahu, např. výraz MONTH($(OBUDAL_ob02datdod))

¨ výběr – výraz v syntaxi Foxpro – výraz musí nabývat logickou hodnotu – je-li výraz uveden a při zpracování řádku nabyde hodnotu nepravda (FALSE) – nebude hodnota do sloupce výstupního řádku vložena, resp. přičtena

¨ poznámka – libovolný text k danému sloupci

¨ tlačítko Nový – založení nového sloupce typu Text/Hodnota

¨ tlačítko Nový (vzorec) – založení nového sloupce typu Vzorec

¨ tlačítko Odstranit – zrušení sloupce

¨ tlačítko Kopie – vložení kopie aktuálního sloupce

Záložka „SCRIPT“

Při definování předlohy se skript zadává v jazyce Foxpro. Skript zpracovává různé události, které nastávají při vytváření výstupu.

Kód skriptu má k dispozici tyto proměnné:

_EVENT - identifikace události

_COLUMN_OBJECT.NAZEV_SLOUPCE - název sloupce při událostech týkajících se buňky

_COLUMN_OBJECT.VAL - hodnota vkládaná do buňky při událostech týkajících se buňky

_COLNO - číslo sloupce v Excelu při událostech týkajících se buňky

_ROWNO - číslo řádky v Excelu při událostech týkajících se buňky

Události před založením a po vytvoření listu:

BEFORE_LIST - Událost před založením listu

V této fázi vytváření výstupu může skript měnit obsah kurzoru SQL_TISK (na základě jeho obsahu následně vzniká výstup).

AFTER_LIST - Událost po vytvoření listu

V této fázi vytváření výstupu může skript upravit vzhled výsledného listu

Události týkající se buňky:

BEFORE_CELL - Událost před založením běžné buňky

Může měnit hodnotu proměnné _COLUMN_OBJECT.VAL, pokud skript vrátí logickou hodnotu .F. (FALSE), nebude žádná hodnota do buňky vložena.

AFTER_CELL - Událost po založení běžné buňky

Je určena pro formátování buňky

BEFORE_SUBTOTAL_CELL - Událost před založením buňky mezisoučtu

Pokud skript vrátí logickou hodnotu .F. (FALSE), nebude žádná hodnota do buňky vložena.

AFTER_SUBTOTAL_CELL - Událost po založením buňky mezisoučtu

Je určena pro formátování buňky

BEFORE_TOTAL_CELL - Událost před založením buňky závěrečného celkového součtu

Pokud skript vrátí logickou hodnotu .F. (FALSE), nebude žádná hodnota do buňky vložena.

AFTER_TOTAL_CELL - Událost po založení buňky závěrečného celkového součtu

Je určena pro formátování buňky

Pravý klik na textovém poli záložky 'Skript' vyvolává editor programů s předplněním vzoru skriptu, pokud byl pravý klik proveden na prázdném textovém poli.

Příklad:

#INCLUDE OLBEXC

* OLBEXC je knihovna obsahující konstanty Excelu - viz. Návody a Balíčky

DO CASE

CASE INLIST(_event,'AFTER_CELL','AFTER_SUBTOTAL_CELL','AFTER_TOTAL_CELL')

DO CASE

CASE LOWER(_column_object.nazev_sloupce)='jmeno_sloupce'

* vloží podmíněné formátování buňky - její hodnota bude zobrazena červeným textem, pokud je záporná

xlsheet.cells[_rowno,_colno].FormatConditions.Delete

xlsheet.cells[_rowno,_colno].FormatConditions.Add(xlCellValue, xlLess, "0")

xlsheet.cells[_rowno,_colno].FormatConditions(1).Font.ColorIndex = 3

ENDCASE

ENDCASE

Viz.také

Předlohy výstupu


Předlohy výstupu

Popis

Tato činnost tisk se aktivuje z panelu nástrojů (ikona tiskárna), výběrem příslušné činnosti z menu Volby nebo stiskem klávesy Ctrl T. Po spuštění tisku (jakýmkoliv z uvedených způsobů) se zobrazí samostatné okno „výstupy a název činnosti“. V tomto okně je k dispozici seznam nadefinovaných předloh výstupu. Pro ovládání tohoto okna slouží panel nástrojů (tj. horní lišta), kde jsou následující možnosti ve formě ikon:

¨ spuštění výstupu – vlastní aktivace tisku vybrané předlohy výstupu

¨ oprava předlohy – u nové předlohy slouží tato činnost k výběru položek výstupu, u již nadefinované předlohy k opravě definice uspořádání položek

¨ výběry – zde je možno výběr a jeho podmínku. Tento výběr slouží pro případ, že záložka výběr a možnosti ve vlastnostech předlohy (setřídění, doplnění, seskupování) nesplňují přesně požadavky uživatele. Tímto výběrem je možno požadovaná výběrová kritéria upřesnit. Při spuštění předlohy výstupu s tímto použitým výběrem pak IS BM provádí svůj SELECT, který vychází z činnosti (nad kterou probíhá tisk) a je upraven podle uživatelských definic ve vlastnostech předlohy (setřídění, seskupování, doplnění)

¨ nová předloha – pomocí této možnosti se zadává nová předloha výstupu. Atributy, které se zde zadávají jsou shodné s atributy u vlastnosti předlohy

¨ kopie předlohy – možnost na základě již nadefinované předlohy vytvořit kopii (zadá se nový název a samozřejmě existuje možnost tuto kopii následně upravovat)

¨ vlastnosti předlohy (vlastní help „vlastnosti předlohy výstupu)

¨ zrušení – možnost zrušení vybrané předlohy výstupu

¨ zobrazovat skryté předlohy – po stisku této ikony jsou k dispozici i ty předlohy výstupu, které mají ve svých vlastnostech zatržen příznak „skrytá“

¨ způsoby zobrazení okna předloh výstupu – možnost zvolení si způsobu, jak budou jednotlivé předlohy výstupu v okně výstupu uspořádány. Je možnost zvolit zobrazení: velké ikony, malé ikony, seznam, detaily

¨ nápověda – nápověda k činnosti

¨ nápověda – seznam položek k tisku – zobrazí se přehled atributů dané činnosti, které jsou dostupné při definování uspořádání položek výstupu

¨ konec činnosti – ukončení a zavření okna „výstupy“.

Kromě činností, které nabízí panel nástrojů (tj. horní lišta) okna výstupů má uživatel k dispozici ještě i činnosti, které se mu nabídnou po stisku pravého tlačítka myši kdekoliv ve volném (tzn. bílém) prostoru okna činnosti výstupy. Některé činnosti jsou shodné s činnostmi dostupnými v horní liště, ale navíc má uživatel k dispozici:

¨ panel nástrojů – při zatržení tohoto příznaku se uživateli při aktivaci okna výstupů zobrazuje i panel nástrojů (tedy horní lišta s ovládacími ikonami), pokud tento příznak zatržen není, panel nástrojů nemá uživatel v okně výstupů k dispozici

¨ balíčky

¨ metapředlohy

¨ vzory výstupu

Vlastní zahájení tisku vybrané předlohy výstupu může uživatel provést těmito způsoby:

¨ dvojklikem levého tlačítka myši přímo na názvu vybrané předlohy výstupu

¨ stiskem ikony tiskárna v panelu nástrojů okna výstupů

¨ výběrem možnosti spustit předlohu po stisku pravého tlačítka myši na názvu předlohy

Viz.také

Definice předlohy typu Excel | Vlastnosti předlohy výstupu


Vlastnosti předlohy výstupu

Popis

Po stisku pravého tlačítka myši na názvu předlohy má uživatel k dispozici tyto možnosti:

¨ spustit předlohu – aktivuje vlastní tisk

¨ opravit předlohu – možnost opravit si vlastní definici předlohy

¨ vlastnosti předlohy – jednotlivé vlastnosti předlohy výstupu, které má uživatel k dispozici ve formě záložek, lze je vyvolat i samostatně (ikonou v panelu nástrojů) –

¨

- obecné - na této záložce se určuje typ (sestava, Excel, ostatní) a druh předlohy. K druhu předlohy lze nadefinovat přístupová práva žádný přístup/čtení/zápis. Uživatel s právem přístupu čtení, který není správcem systému ani autorem předlohy ji může spustit, ale nemůže předlohu kopírovat, rušit, opravovat a nejsou mu dostupné ani vlastnosti předlohy. Je možné definovat druh předlohy, který není dostupný žádnému uživateli systému a na něj „odkládat“ předlohy, které není možné zrušit (na základě referenční integrity) nebo u kterých není jisté, zda bude třeba danou předlohu někdy v budoucnu použít. Pokračují atributy, zda je skrytá (pouze pro aktuálně přihlášeného uživatele) nebo skrytá všem (tato předloha je skrytá všem bez ohledu na privátní nastavení vlastnosti „skrytá“. Příznak skrytá všem může nastavit pouze správce systému). Příznak systémových předloh mají předlohy dodané společně s dodávkou systému a u těchto předloh pak není možno opravovat definici předlohy. Jako další se zde může určit jazyk, v jakém se předloha bude prezentovat (daná předloha pak musí být samozřejmě definována vícejazyčně) a dopsat libovolnou poznámku. V případě potřeby je možno u předlohy změnit i ikonu, která se zobrazuje vedle názvu předlohy. Stačí kliknout na tlačítko „změnit ikonu“ a vybrat si příslušný soubor (přípona *.ico).

- popis - tato záložka obsahuje název předlohy a způsob setřídění atributů v ní, není-li na záložce „setřídění“ definováno jinak. V případě potřeby je možno zatrhnout (dvojklikem myši) i pohyb (pohyb nastavený v předloze dokladů na události umožní zadat prezentaci procesu), tzn. ze kterých tabulek se ještě mají atributy v předloze nabízet. Zatržením příznaku tisk aktuálního by se tiskl vždy jen aktuální záznam (tzn. ten, na kterém je právě umístěn kurzor) a v případě zatržení pouze součtové údaje jsou ze sestavy při tisku vynechány jednotlivé záznamy a tisknou se pouze ty řádky, na kterých je v sestavě nadefinována suma (tj. součet, nejčastější použití je u předloh typu Excel a HTML – ostatní). U atributu kopie si uživatel určí pouze počet kopií při tisku a atribut výstupy procesů obsahuje překryvný seznam možností, jak může uživatel podle svých parametrů ovlivnit tisk předlohy.

- setřídění - umožňuje uživateli nastavit si vlastní třídění, které na záložce popis není implicitně k dispozici. Při zaškrtnutí příznaku vlastní setřídění musí pak uživatel kliknout na ikonu „čtvereček“ v pravé části obrazovky a následně si atribut vybrat (tato možnost však vyžaduje jistou znalost datového modelu), též může užít atributy definované na záložce doplnění. Výraz setřídění lze zadat v syntaxi SQL (např. adadsat.ad01id) nebo v syntaxi FoxPro (např. *SPARTIKN_sp62artikl). V předloze dokladu lze definovat pouze setřídění událostí v rámci operace (setřídění dle operací je definováno v prezentaci procesu) a to jednotně pro všechny operace dané komponenty.

- seskupování - umožňuje nastavení vlastního seskupování atributů předlohy výstupu. Množina těchto atributů tisku může být uživatelsky nahrazena uvedenými atributy a výrazy, a to i z uživatelem připojených dalších tabulek na záložce doplnění. Druhá kolonka definuje „grupování“ (GROUP a HAVING) přímo na serveru. V seskupování se tedy uvádí informace potřebné pro vytvoření dotazu SQL s klauzulí GROUP BY. Při zaškrtnutém "Seskupování" se zde v poli "Atributy a výrazy příkazu SELECT" uvádí část sestaveného příkazu mezi SELECT a FROM. Jinými slovy umožňuje, aby příkaz SELECT při získání dat výstupu byl redefinován (oproti programovému kódu) s využitím klauzulí GROUP a HAVING, což je smysluplné tehdy, obsahuje-li předloha výstupu významné agregace. Ty se pak realizují na serveru, což bývá několikanásobně rychlejší (příklad zápisu je uveden ve slovníku pojmů).

V poli “Atributy a výrazy v příkazu SELECT” se uvádí například:

MTUDA.sp60id MTARTIKL_sp60id,MTUDA.sp61id MTARTIKL_sp61id,MTUDA.mt04id MTUDA_mt04id,SUM(MTUDA.mt02mnr*(if MTUDA.mt02pv=1 then 1 else -1 endif)) MTUDA_mt02mnr

V poli "Doplnění klausulí GROUP a HAVING" se uvádí odpovídají část dotazu, například:

MTUDA.sp60id,MTUDA.sp61id,MTUDA.mt04id

HAVING MTUDA_mt02mnr<>0

ORDER BY MTUDA.mt04id,MTUDA.sp61id,MTUDA.sp60id

- doplnění - umožňuje rozšířit předlohu výstupu o atributy, které se při jejím vytváření uživateli nenabízí přímo. Do kolonky „atributy“ se zadává seznam atributů nebo výrazů oddělených čárkou doplněných do dotazu ve tvaru „<alias tabulky>.<atribut>.<alias atributu>“. V příkazu SELECT se doplňuje do oblasti před FROM. Do kolonky „select-join“ se zadává seznam tabulek doplněných do dotazu SELECT mezi FROM a WHERE za deklaraci první tabulky dotazu nastavené programem. Pokud tento seznam nezačíná příkazem LEFT OUTER JOIN, musí začínat čárkou. Do kolonky „výběr“ se zadává doplnění příkazu SELECT v oblasti za WHERE, musí začínat „AND“ a je-li v dotazu obsažen logický operátor „OR“, musí být odpovídající část definice uzavřena do kulatých závorek.

Příklad: ( týká se jen části doplnění sestavy)

Nad Vývěskou (VYUDALOS) doplňení emailu spojení adresáta

Atributy: ADSPOJ.ad11email email

Select-join: ,%%%.ADSPOJ ADSPOJ

Výběr: AND VYUDALOS.ad01id=ADSPOJ.ad01id

Pozn.

V excelovské sestavě se pak k tomuto atributu dostanete například takto:

.EP xlsheet.cells[$(r),$(s9)].value=[']+sql_tisk.email

V html sestavě musíme použít Deklaraci: idemail;c(30);Email;sql_tisk.email a poté přidat atribut pomocí: $(idemail_USER_)

- deklarace - obsahuje „dodatečné deklarace“ položek výstupu. V ní je možné doplnit výběr položek výstupu nabízený při definování nové předlohy o položky získané v doplnění, o položky typu konstanta či o položky dané výrazem sestaveným z nich a implicitně dostupných položek výstupu a o proměnné obecného výběru. Každý řádek v deklaraci definuje jeden nový výraz seznamu, má tvar (jeho jednotlivé části jsou oddělené středníky):

<identifikace>;<typ>;<návěští>;<výraz>

kde

<identifikace> je identifikátor doplněný textem "_USER_", pod kterým bude vystupovat v předlohách typu "Excel" a "Ostatní"

<typ> určuje typ výrazu. Je možné zadávat typy "N", "C", "D", "T", "L". Pro typy "N" a "C" musí být dále v závorkách uveden rozměr hodnoty výrazu

<návěští> určuje text zobrazený v seznamu při zakládání nové předlohy

<výraz> specifikuje výraz pro výpočet hodnoty

Například:

KS ; N(12,2) ; Konečný stav ; SQL_tisk.mtobrat_mt14pstav+SQL_tisk.mtobrat_mt14prijem-SQL_tisk.mtobrat_mt14vydej

Pozn.:

1. ve výrazu je možné používat atributy vyplývající z doplnění pohledu (v sestavách typu ostatní (HTML) je to nutnost)

2. v předlohách typu "Excel" nebo "Ostatní" vystupují doplněné výrazy ve své symbolické podobě, tzn. že případná oprava tvaru výrazu v dodatečných deklaracích se promítá do výsledku předlohy

3. pro předlohy typu Excel2 (je implicitně nastaveno, že excelovská sestava je typu 2, nastavuje se to při výběru atributů do sestavy) je možné definovat výpočtové sloupce tak, že se jako výraz uvede text vzorce Excelu

Např.:

Soucet ; N(7,4) ; Součet ; '=RC(-2)+RC(-1)'

Ve sloupci v Excelu potom vzniknou v daném sloupci výpočtové buňky se součtem buněk v sousedních dvou sloupcích zleva ve stejném řádku.

Na záložce „deklarace“ je k dispozici i vlastnost předlohy výstupu SKRIPT. Je v ní možné definovat kód v jazyce Foxpro, který bude prováděn před provedením dotazu SQL. V okamžiku běhu skriptu je v proměnné _THIS odkaz na objekt řídící výstup předlohou výstupu. Např.:

<pre>

LOCAL _o

* přidání vlastnosti TEMP_DATUM1 do objektu _THIS inicializovanou aktuálním datem

_this.addproperty('temp_datum1',date())

* třída BM_CODE_SYSDIA definuje objekt pro dialog

_o=CREATEOBJECT('bm_code_sysdia')

* inicializace objektu třídy BM_CODE_SYSDIA

_o.start(_this,'Datum')

* bude vstup do vlastnosti TEMP_DATUM1 objektu _THIS

_o.addtextbox('temp_datum1')

* metoda READ zahajuje vstup formuláře a vrací FALSE při uživatelově stisku ESC

RETURN _o.read()

#INCLUDE sysdia

</pre>

V předloze výstupu je potom možné odkazovat na vstoupenou proměnnou jako THIS.TEMP_DATUM1.

Odkaz v doplnění SQL dotazu ve vlastnostech předlohy však není tímto způsobem možný.

Proto jinak např.:

<pre>

LOCAL _o

* vstupní informace bude uložena v objektu TOOL, ale mohla již být definována předchozím spuštěním předlohy

DO CASE

CASE TYPE('tool.temp_datum1')='U'

* dosud není vlastnost TEMP_DATUM1 objektu TOOL definována

* přidání vlastnosti TEMP_DATUM1 do objektu TOOL inicializovanou aktuálním datem

tool.addproperty('temp_datum1',date())

CASE TYPE('tool.temp_datum1')<>'D'

* vlastnost TEMP_DATUM1 je definována, ale není typu datum

tool.temp_datum1=DATE()

ENDCASE

_o=CREATEOBJECT('bm_code_sysdia')

_o.start(tool,'Datum')

* bude vstup do vlastnosti TEMP_DATUM1 objektu TOOL

_o.addtextbox('temp_datum1')

RETURN _o.read()

#INCLUDE sysdia

</pre>

V předloze výstupu je potom možné odkazovat na vstoupenou proměnnou jako TOOL.TEMP_DATUM1. V doplnění SQL dotazu ve vlastnostech předlohy bude možné odkazovat v otazníkové konvenci např.:

tabulka.datum>=?tool.temp_datum1

- info - výstupy lze aktivovat uživatelským rozhodnutím v rámci funkčnosti dané činnosti nebo automaticky na základě uživatelských definic v nastavení parametrů uzlu procesu při jeho ukončení nebo pomocí doplnění činnosti. Reakce na aktivaci je uživatelsky ovlivnitelná profilem spuštění, který je k dané předloze přiřazen, a který ovlivňuje chování předlohy po její aktivaci. Uvedení logické tiskárny v předloze výstupu umožňuje definovat pro různá uživatelsky definovaná pracoviště (každé může zahrnovat několik fyzických počítačů) různé fyzické tiskárny, na které bude výstup typu Sestava a Excel dle této předlohy směrován. Jako další tato záložka obsahuje informace o tom kdy a kým byla daná předloha vytvořena či změněna.

¨ kopírovat definici předlohy – vytvoření kopie dané předlohy

¨ zrušit definici předlohy – zrušení definice předlohy

¨ výběry - uživatel si zde může nadefinovat výběr a jeho podmínku. Tento výběr mu slouží pro případ, že záložka výběr a možnosti ve vlastnostech předlohy (setřídění, doplnění, seskupování) nesplňují přesně jeho požadavky. Tímto výběrem si pak požadovaná výběrová kritéria může upřesnit. Při spuštění předlohy výstupu s tímto použitým výběrem pak IS BM provádí svůj SELECT, který vychází z činnosti (nad kterou probíhá tisk) a je upraven podle uživatelských definic ve vlastnostech předlohy (setřídění, seskupování, doplnění)

¨ export do balíčku

¨ překlad popisek – název předlohy

¨ export webovou službou

Poznámka:

Předlohy výstupů z procesů se od jiných předloh odlišují tím, že v seskupování, setřídění, doplnění nebo v deklaracích (tzn. na záložkách ve vlastnostech předlohy) je nutno specifikovat operaci. Nad kterou operací v procesu provádíme dotaz je určeno syntaxí |“název komponenty“|, oddělovač komponent je pak řetězec |||.

Např. v předloze výstupu „faktura“ ve vlastnostech předlohy na záložce „doplnění“ je rozšířená identifikace měrné jednotky zapsána takto:

¨ atributy - |OBC| SPMJN.sp58idmj

¨ select – join - |OBC|,%%%.SPMJN SPMJN

¨ výběr - |OBC| AND OBUDAL.sp24idmj=SPMJN.sp24idmj AND SPMJN.sp38id=?tool.jazyk

Tyto popsané údaje má tedy uživatel dostupné při stisku pravého tlačítka myši na názvu všech typů předloh (sestava, ostatní, excel, word).

Pro všechny typy předloh jsou k dispozici příkazy, které se mohou při tvorbě předloh použít a ty jsou popsány v Popisu jazyka generátoru sestav (vlastní pojem ve slovníku pojmů).

Viz.také

Předlohy výstupu


Barvy RGB

Popis

Tato činnost poskytuje uživateli přehled všech barev, které je možno ve vybraných místech systému používat (např. palety barev adresátů, palety artiklů apod.).

Datový model

  • BWRGBCOL Hodnota RGB barvy

    • Formulář

    Formulář činnosti - Vybrat barvu RGB
Mřížka [Barvy RGB]
ID | Identifikace barvy RGB
Popis | Popis barvy RGB
RGB | Hodnota RGB
Poznámka | Poznámka

    Mřížka [Barvy RGB] činnosti - Vybrat barvu RGB

    Mřížka [Barvy RGB] činnosti - Vybrat barvu RGB
ID | Identifikace barvy RGB
Popis | Popis barvy RGB
RGB | Hodnota RGB

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Vybrat barvu RGB |

    Atributy tisku

    Základní údaje
Barva | Identifikace barvy RGB | BWRGBCOL_bw95id | C(6)
Popis | Popis barvy RGB | BWRGBCOL_bw95popbar | C(40)
RGB | Hodnota RGB | BWRGBCOL_bw95rgb | N(8)
Poznámka | Poznámka | BWRGBCOL_bw95koment | M

    Viz.také

    Vybrat barvu RGB


Vybrat barvu RGB

Popis

Uživateli se aktivuje tabulka, kde si může zvolit jiný odstín barvy, případně nadefinovat svoji barvu.


Typy tiskáren

Popis

Jedná se o přehled jednotlivých typů tiskáren, které pak uživatel využívá při definici logických a fyzických tiskáren.

Datový model

  • BWPRINMT Typ fyzické tiskárny

    • Formulář

    Formulář činnosti - Přístupová práva
Mřížka [Typy tiskáren]
Typ | Identifikace typu fyzické tiskárny
Název typu | Název typu fyzické tiskárny
Listovací rámeček
Stránka #1 Typy tiskáren
Poznámka | Poznámka
Stránka #2 Řídící kódy
Mřížka [Řídící kódy]
ID | Identifikace řídícího kódu tiskárny
Popis | Popis kódu pro tiskárnu
Kód | Kód pro tiskárnu (hexa)
Poznámka | Poznámka

    Mřížka [Typy tiskáren] činnosti - Přístupová práva

    Mřížka [Typy tiskáren] činnosti - Přístupová práva
Typ | Identifikace typu fyzické tiskárny
Název typu | Název typu fyzické tiskárny

    Mřížka [Řídící kódy] činnosti - Přístupová práva

    Mřížka [Řídící kódy] činnosti - Přístupová práva
ID | Identifikace řídícího kódu tiskárny
Popis | Popis kódu pro tiskárnu
Kód | Kód pro tiskárnu (hexa)

    Atributy tisku

    Základní údaje
Typ | Identifikace typu fyzické tiskárny | BWPRINMT_bw97id | C(6)
Název typu | Název typu fyzické tiskárny | BWPRINMT_bw97naztyp | C(40)
Poznámka | Poznámka | BWPRINMT_bw97koment | M

    Při pohybu v Řídící kódy
ID | Identifikace řídícího kódu tiskárny | BWPRINME_bw96id | C(6)
Popis | Popis kódu pro tiskárnu | BWPRINME_bw96popis | C(40)
Kód | Kód pro tiskárnu (hexa) | BWPRINME_bw96kod | C(40)
Poznámka | Poznámka | BWPRINME_bw96koment | M


Import slovníku textů

Popis

Tato činnost je pro uživatele dostupná v menu Volby v činnosti „Překlad textů“ (menu Systém). Po její aktivaci se systém dotazuje na název a umístění souboru, odkud má být import natažen.


Export slovníku textů

Popis

Tato činnost je pro uživatele dostupná v menu Volby v činnosti „Překlad textů“ (menu Systém). Po její aktivaci se systém dotazuje na název a umístění souboru, kam má být export uložen.


Obrazovka uživatele

Popis

Tato činnost vyvolá formulář, ve kterém je periodicky (podle nastaveného parametru) zobrazován obsah obrazovky daného uživatele. Obrazovka se nezobrazuje pokud uživatel pracuje v režimu Terminal – Server. Pro správnou funkčnost této činnosti jsou nutná tyto nastavení:

¨ v adresáři BMSQL\PRGS musí být nahrán soubor JPGDLL.DLL

¨ je nutné k této činnosti nadefinovat právo přístupu některé skupině uživatelů (v činnosti oprávnění k činnostem)

¨ nastavit parametr programu BM SpySleepInterval

Interval periodického čtení je dán nastavením programu BM:

¨ Preferencess – SpySleepInterval – ten určuje periodu ve vteřinách v situaci, kdy není žádný požadavek na sejmutí obrazovky (resp. zjištění stavu)

¨ Preferencess – SpyRunInterval – ten určuje periodu ve vteřinách, na kterou se změní interval čtení záznamu v tabulce BWCONNEQ po dobu trvání požadavku na sejmutí obrazovky (resp. zjištění stavu)

Princip fungování této činnosti je založen na časovém objektu, který je nainstalován při startu programu, a který při spuštěném programu periodicky čte záznam přihlášeného uživatele v tabulce BWCONNEQ. Formulář „obrazovka uživatele“ při svém spuštění zapisuje do atributu BW14SPYCNT (zvýší jeho hodnotu o 1) tabulky BWCONNEQ požadavek na sejmutí obrazovky uživatele (obrazovka Windows ve formátu JPEG).

Formulář

Formulář činnosti - Metapředlohy výstupu
Výběr typů dle přístupu


Stav programu BM uživatele

Popis

Tato činnost je dostupná v činnosti „přehled přihlášených (SQL)“ (hlavní menu – Systém) pod menu Volby.

Činnost vyvolá formulář, ve kterém je periodicky (podle nastaveného parametru) zobrazován stav programu daného uživatele. Pro správnou funkčnost této činnosti jsou nutná tyto nastavení:

¨ vytvořit externí příkaz s PID=STATUS (nebo ho nainstalovat z návodů a balíčků)

¨ nastavit parametr programu BM SpySleepInterval

Interval periodického čtení je dán nastavením programu BM:

¨ Preferencess – SpySleepInterval – ten určuje periodu ve vteřinách v situaci, kdy není žádný požadavek na sejmutí obrazovky (resp. zjištění stavu)

¨ Preferencess – SpyRunInterval – ten určuje periodu ve vteřinách, na kterou se změní interval čtení záznamu v tabulce BWCONNEQ po dobu trvání požadavku na sejmutí obrazovky (resp. zjištění stavu)

Princip fungování této činnosti je založen na časovém objektu, který je nainstalován při startu programu, a který při spuštěném programu periodicky čte záznam přihlášeného uživatele v tabulce BWCONNEQ. Formulář „stav programu BM uživatele“ při svém spuštění zapisuje do atributu BW14SPYCNS (zvýší jeho hodnotu o 1) tabulky BWCONNEQ požadavek na zjištění stavu programu BM. Program BM, který plní požadavek na zjištění stavu programu spouští externí příkaz s PID=STATUS, předpokládá se, že jeho kód zapíše stav ve formátu HTML do tabulky BWCONNEQ do atributu BW14SPYSTA jako obrazovku Windows ve formátu JPEG. Obvykle jsou v kódu HTML předaném v atributu BW14SPYSTA obsaženy mj. hypertextové odkazy, po jejichž zvolení zapíše BM do tabulky BWCONNEQ do atributu BW14SPYKOD kód v jazyce Foxpro, který má být proveden na počítači uživatele (např. ukončit program uživatele za 5min, reset požadavku ukončení programu, ...).


(Ne)zobrazovat kurzor v mřížce

Popis

Tato činnost je dostupná po stisku klávesy F7 nebo pod menu Volby v činnosti Sady vzdálených funkcí. Funguje v podstatě jako přepínač, jedním stiskem F7 uživatel aktivuje Nezobrazovat kurzor v mřížce, dalším stiskem F7 se naopak zase bude zobrazovat. Nezobrazovat kurzor v mřížce znamená, že aktivní řádka ve formuláři Sady vzdálených funkcí (tzn. řádka, na níž je umístěn kurzor) není nijak barevně zvýrazněna.

I v jiných činnostech v systému je pod menu Volby k dispozici (Ne)zobrazovat kurzor v mřížce, jeho funkcionalita je zde naprosto stejná.


Parametry operací skladu zvířa

Popis

Události lze aplikovat pouze v rámci operace, jejíž druh může mít tyto parametry:

¨ běžná - mají nastaveno všechny standardní operace jako příjem, výdej, prodej apod.,

¨ výpočet KD - nutno nastavit v parametrech operace, která provádí zápočet krmných dnů,

¨ převod - příjem, převod - výdej - nastavuje se v parametrech operací, které provádějí převod zvířat z kategorie do kategorie (nebo umístění - umístění) proto, aby bylo v pořádku zachováno ocenění (tzn. při převodu je nutno brát skladovou cenu z původního stáda) a to i tehdy, je-li původní cena následně upravená

Datový model

  • SZPAROPE Parametry operací - sklad zvířat

    • Formulář

    Formulář činnosti - Parametry projektového řízení
    Typ operace Typ operace


Přepočet krmných dnů

Popis

Pro zápočet krmných dnů je k dispozici program "SZUDAL krmne dny" využitelný v definici importu, kde uživatel pouze zadá datum, kategorii a umístění a program automaticky naplní operaci událostmi, které podle nastavených parametrů náleží do zápočtu krmných dnů.

Výpočet krmných dnů probíhá na základě následujícího algoritmu. Systém z obratů skladu zvířat vybere záznamy (podle data, umístění, kategorie, počátečního/konečného stavu) s nižším datem, než je zadané datum na šabloně výpočtu krmných dnů, pro ty kategorie zvířat, které mají zaškrtnutý příznak KD. Z obratů systém bere tyto hodnoty:

¨ množství (tj. počet krmných dnů) - určené parametrem „množství v MJ pro výpočet KD“ (činnost Parametry komp. sklad zvířat)

¨ podle nastavení parametru „započítávat stavy do KD“ (činnost Parametry komp. sklad zvířat) hodnota počáteční nebo konečný stav

Vyvolávané činnosti

K. | Činnost | Popis
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Kategorie zvířat | Seznam kategorií zvířat
F2 | Umístění | Seznam umístění

Formulář

Formulář činnosti - Druhy artiklů
Datum | Datum pohybu
Druh artiklu | Identifikace druhu artiklu
Kategorie | Identifikace artiklu
Umístění | Identifikace umístění kategorie zvířat
Uchovat | Příznak uchování výběrového hlediska

Viz.také

Druhy artiklů | Kategorie zvířat | Umístění


Celkem - AH

Popis

Sumární vyjádření zobrazených aktuálních hodnot.


Celkem - sklad zvířat

Popis

Tato činnost zobrazí události obchodu jako sumu. Sumární vyjádření je možno vyvolat volbou příslušné činnosti z menu Volby nebo po stisku funkční klávesy Ctrl S.

Formulář

Formulář činnosti - Druhy artiklů
Příjmy | Množství v RMJ - celkem
Výdaje | Množství v pomocné MJ - celkem
Rozdíl | Cena - celkem
Množství v RMJ | Množství v RMJ - příjmy
Množství v pomocné MJ | Množství v pomocné MJ - příjmy
Cena | Cena - příjmy
Celkem | Množství v RMJ - výdaje
 | Množství v pomocné MJ - výdaje
 | Cena - výdaje


Vztahy artiklů

Popis

Tato činnost se aktivuje po stisku klávesy F6 nebo volbou příslušné činnosti z menu Volby z činnosti Přehled referenčních artiklů. Uživateli se zobrazují vztahy artiklů, které jsou nadefinované u daného referenčního artiklu (tj. ten, na kterém před stiskem klávesy F6 byl umístěn kurzor). Pro uživatele je zde v podstatě k dispozici přehled artiklů, které jsou třeba k výrobě daného referenčního artiklu a množství jakému odpovídají (např. 1 ks natřeného plechu odpovídá množství 20 kg).

Datový model

  • TPTABP Položka tabulky vztahů artiklu artiklů výroby
    • TPVYROB Artikl výroby (alias TPVYROB3)
      • SPARTIKN Název artiklu (alias SPARTIKN3)
    • TPVYROB Artikl výroby (alias TPVYROB2)
      • SPARTIKN Název artiklu (alias SPARTIKN2)
    • TPLINKAD Druh výrobní linky/stroje

    • Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Artikly výroby | Vstup artiklů výroby
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Měrné jednotky | Číselník měrných jednotek

    Formulář

    Formulář činnosti - Měrné jednotky
Mřížka [Položky]
Dr.stroje | Identifikace druhu stroje
Název tabulky | Název tabulky vztahu artiklů
Název druhu stroje | Název druhu stroje
 | Identifikace druhu artiklu
Artiklu výroby | Identifikace artiklu
Tabulka | Identifikace tabulky artiklu výroby
 | Název artiklu
Množství | Množství
MJ | Identifikátor měrné jednotky
 | Identifikace druhu artiklu
Odpovídá množství | Identifikace artiklu
 | Název artiklu
Množství | Množství
MJ | Identifikátor měrné jednotky
 | Komentář

    Mřížka [Položky] činnosti - Měrné jednotky

    Mřížka [Položky] činnosti - Měrné jednotky
Dr.stroje | Identifikace druhu stroje
Artikl výroby | Identifikace artiklu
Množství | Množství artiklu potřebné k výrobě množství svázaného artiklu
Druh | Identifikace druhu artiklu
Název artiklu | Název artiklu
MJ | Identifikátor měrné jednotky
Artikl výroby | Identifikace artiklu
Druh | Identifikace druhu artiklu
Název artiklu | Název artiklu
Množství | Množství artiklu, které se má vyrobit
MJ | Identifikátor měrné jednotky
Tabulka | Identifikace tabulky artiklu výroby
Název druhu stroje | Název druhu stroje

    Viz.také

    Artikly výroby | Druhy artiklů | Měrné jednotky


Kopie operace

Popis

Tuto činnost si uživatel aktivuje klávesou F5 nebo volbou činnosti Kopie operace z menu Volby v činnosti „přehled referenčních artiklů“. Uživatel vytváří kopii dané (tj. aktivní) operace s tím, že si nadefinuje další artikl, kterého se má tato operace týkat, případně zvolí stejný artikl, který byl na původní operaci a nadefinuje si odlišnou variantu.

Vyvolávané činnosti

K. | Činnost | Popis
F2 | Artikly výroby | Vstup artiklů výroby
F2 | Druhy artiklů | Seznam druhů artiklů

Formulář

Formulář činnosti - Druhy artiklů
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
 | Název artiklu
Operace | Identifikace technologické operace
Název operace | Stručný popis, charakterizující technologickou operaci
Varianta | Varianta technologické operace

Viz.také

Artikly výroby | Druhy artiklů


Diagram šablony

Popis

Diagram šablony uživatel aktivuje z činnosti „šablony procesů“ stiskem klávesy F7 nebo volbou příslušné činnosti z menu Volby. Jedná se o naprosto shodný způsob definice diagramu jako u diagramu procesu.


Předplnit směny

Popis

Tato činnost je uživateli k dispozici pod menu Volby na záložce „Výjimky v kalendáři“ v činnosti Výrobní linky a stroje nebo v komponentě Výroba – Kalendáře směn výroby – menu Volby. Umožňuje uživateli nastavit si (resp. předplnit) čas jednotlivých pracovních směn pro svoje výrobní linky a stroje. Může se jednat o standardní (tedy stálé) předplnění pracovních směn nebo o zadání výjimek (např. že každý pátek pracuje první směna na zkrácenou dobu apod.).

Uživatel definuje tyto atributy:

¨ datum od – do – období, ve kterém se mají směny předplňovat (určitý den, týden, měsíc apod.)

¨ u každé směny – hodinu zahájení směny + dobu trvání směny v hodinách

¨ kalendář – označení (tj. zaškrtání) dnů, kterých se tento provoz směn v zadaném období vždy týká

V případě potřeby je k dispozici i funkce pro zrušení všech vybraných (na záložce dostupných) směn (menu Volby, činnost „zrušit zobrazené dny kalendáře“).

Formulář

Formulář činnosti - Měrné jednotky
Datum | Datum v kalendáři využití linky
do | Datum v kalendáři využití linky do
1.směna - Hodina začátku směny | 1.směna - Hodina začátku směny
Doba trvání směny | Doba trvání směny v hodinách
2.směna - Hodina začátku směny | 2.směna - Hodina začátku směny
Doba trvání směny | Doba trvání směny v hodinách
3.směna - Hodina začátku směny | 3.směna - Hodina začátku směny
Doba trvání směny | Doba trvání směny v hodinách
Pondělí | Zahrnout pondělky
Úterý | Zahrnout úterky
Středa | Zahrnout středy
Čtvrtek | Zahrnout čtvrtky
Pátek | Zahrnout pátky
Sobota | Zahrnout soboty
Neděle | Zahrnout neděle


Vytvořit jednokrokový TP

Popis

Tuto činnost uživatel aktivuje z činnosti Přehled referenčních artiklů po stisku klávesy F9 nebo volbou činnosti „vytvořit jednokrokový TP“ z menu Volby. Zobrazí se mu dialogové okno, kde je předplněna identifikace a název aktuální operace u daného referenčního artiklu a v dalším okně je vytvořen diagram TP o jednom kroku.

Formulář

Formulář činnosti - Druhy artiklů
Tech. postup | Identifikace technologického postupu
Popis tech. postupu | Stručný popis, charakterizující technologický postup


Příprava rozpracování TP

Popis

Tuto činnost uživatel aktivuje z činnosti Technologické postupy po stisku klávesy F9 nebo volbou činnosti „příprava rozpracování TP“ z menu Volby. Uživatel při aktivaci této činnosti může nejprve na záložce Výběr zvolit, který TP a s jakým datem chce spočítat a případně zadat i konkrétní artikl. TP je předplněn (podle identifikace z činnosti technologické postupy, ze které byla tato činnost aktivována), ale je možno ho změnit, datum platnosti od je předplněno aktuálním datem. Po načtení filtru na záložce Výběr se pak stiskem klávesy F9 aktivuje činnost „rozpracovat TP k datu“.

Datový model

  • TPTECVVO Technologický postup připravený pro rozpracování k datu
    • TPTECHPO Technologický postup
    • TPTECHAX Artikl výroby v technologickém postupu (alias TPTECHAX2)
      • SPARTIKN Název artiklu

    • Vyvolávané činnosti

    K. | Činnost | Popis
F9 | Rozpracovat TP k datu | Rozpracovat TP k datu
F2 | Artikly výroby | Vstup artiklů výroby
F2 | Druhy artiklů | Seznam druhů artiklů
F2 | Technologické postupy | Definice technologických postupů výroby

    Formulář

    Formulář činnosti - Artikly výroby
Mřížka [Rozpracování TP k datu]
Tech. postup | Identifikace technologického postupu
Popis tech. postupu | Stručný popis, charakterizující technologický postup
Platnost od | Datum platnosti od
Zpracovat pouze pro výrobek | Zpracovat pouze pro výrobek
Druh artiklu | Identifikace druhu artiklu
Artikl výroby | Identifikace artiklu
Název artiklu | Název artiklu

    Mřížka [Rozpracování TP k datu] činnosti - Artikly výroby

    Mřížka [Rozpracování TP k datu] činnosti - Artikly výroby
Tech. postup | Identifikace technologického postupu
Popis tech. postupu | Stručný popis, charakterizující technologický postup
Platnost od | Datum platnosti od

    Viz.také

    Rozpracovat TP k datu | Artikly výroby | Druhy artiklů | Technologické postupy


Rozpracovat TP k datu

Popis

Tato činnost se aktivuje po stisku klávesy F9 nebo volbou činnosti z menu Volby v činnosti „příprava rozpracování TP“. Program potom následně provede výpočet, jehož výsledky jsou k dispozici v činnosti „TP k datu rozpracované na KJ“. V případě zjištění nesrovnalostí (např. nebyl nalezen vztah artiklů, není známá cena pro artikl apod.) je uživateli zobrazen protokol generování úkolů zakázky, kde jsou chybové hlášky přesně vypsány.


Diagram technolog.postupu

Popis

Tato činnost se aktivuje po stisku klávesy F7 nebo pod menu Volby v činnosti Technologické postupy. Uživateli se spustí obrazovka pro definici diagramu technologického postupu. Postup definování je shodný s definicí diagramu procesu.


Kopie tech.postupu

Popis

Tato činnost se aktivuje po stisku F5 nebo volbou příslušné činnosti z menu Volby v činnosti Technologické postupy. Uživateli se zobrazí dialog, kde zadá identifikaci a název nového technologického postupu.

Formulář

Formulář činnosti - Artikly výroby
Tech. postup | Identifikace technologického postupu
Popis tech. postupu | Stručný popis, charakterizující technologický postup


Uzavření účetních knih

Popis

Uzavření účetních knih úzce souvisí s účetní uzávěrkou. Při provádění účetní uzávěrky dojde k uzavření účtů podle zákonem dané předkontace. Ke dni uzavření účetních knih systém spočítá určitý konečný zůstatek účtů.

Při uzávěrce systém tento zůstatek vynuluje a zaúčtuje podle nastavených předkontací. Uzávěrka vlastně zjistí zisk nebo ztrátu, přičemž obojí je nutno zaúčtovat. Při uzávěrce se obraty účtů (v obratové tabulce) načítají do zvláštního 13-tého měsíce, tzn., že obraty 12-tého měsíce nijak neovlivní. Běžně se uzávěrka provádí k 31.12., ale je možno, že uživatel ji bude potřebovat provést i během roku (např. konkurz nebo likvidace firmy).

Pro uzavření účetních knih slouží proces v nabídce Nový proces – Účetní zápisy – Prvotní evidence – Uzavření účetních knih. Tento proces se případně použije i pro uzavření podrozvahové evidence.

Po aktivaci procesu „uzavření účetních knih“ se nabídne šablona (Ctrl F3), která nabízí volbu období, druhu, možnost výběru otevření účtů po jednotlivých účetních selektorech či kumulaci bez ohledu na selektory a dále volbu zápisu na účty účtové třídy 7. k uzavíraným účtům 1:1 nebo agregovaně. Měnu lze vypsat a nadále se tato volba nabízí. V případě potřeby uzávěrky účtů i v cizích měnách je možné uzavírat účty po jednotlivých měnách nebo za všechny měny najednou (nevyplnění nabídky Měna).

Pro uzavření a otevření účtů podrozvahové evidence je třeba v činnosti Účetnictví – speciální činnosti – parametry účetnictví – změnit parametr „povolit otevření a uzavření podrozvahových účtů“ ze stavu Nepovolit na stav Povolit či Varovat. Proces se spouští nabídkou Obecné – Import/Export dat a výběr varianty Uzavření nebo Otevření požadovaného roku a měny. Při standardním provozu by mělo platit, že uživatelé spouští procesy pro otevření a uzavření účtů 0 až 6 a další procesy pro otevření a uzavření podrozvahových účtů – každý pouze jednou.

Systém umožňuje otevření a uzavření účetních knih provést pouze jednou ročně. V případě potřeby znovuuzavření účetních knih je nutno původní operaci otevření odblokovat (storno neprovádět) a znovu zadat správně (v případě nejasností je toto nutno řešit ve spolupráci s pracovníky IT BM Servis s.r.o., kteří provedou ruční zásah do systému).

Formulář

Formulář činnosti - Skupiny XSLT předloh
Období | Identifikace účetního období
Druh | Druh informace skutečnost, plán ...
Respektovat selektory | Respektovat selektory
Agregované zápisy na účty 7.. | Agregované zápisy na účty 7..
Měna | Kód měny - oceňovací jednotky.


Otevření účetních knih

Popis

Otevření účetních knih se ve většině případů provádí při zahájení práce s komponentou účetnictví nebo po provedení účetní uzávěrky. Pro otevření účetních knih slouží proces v nabídce Nový proces – Účetní zápisy – Prvotní evidence – Otevření účetních knih. Tento proces se případně použije i pro otevření podrozvahové evidence.

Pro otevření účetních knih platí v zásadě stejný postup jako pro uzavření. Po aktivaci činnosti „otevření účetních knih“ se nabídne šablona (Ctrl F3), která nabízí volbu období, druhu, možnost výběru otevření účtů po jednotlivých účetních selektorech či kumulaci bez ohledu na selektory a dále volbu zápisu na účty účtové třídy 7. k uzavíraným účtům 1:1 nebo agregovaně.

Rozdílná je volba respektovat selektory – při otevření knih vyplývá u uzávěrky účetních knih, provede se stejným způsobem. Na šabloně je navíc možnost volby otevření knih bez uzávěrky předchozího období. Výběrem: období, druh „skutečnost“, otevření u uzávěrky „ne“, selektory (viz.výše), agregace a měna umožní opakovaně provést provizorní otevření účetnictví. Zapsanou účetní operaci NEUKONČIT!!!

Promítnutí změn zaúčtovaných do minulého období již po otevření: znovu spustit operaci otevření účetních knih, označit všechny události (Volby označování), zrušit označené události, provést nový vstup šablonou (Ctrl F3), zapsat a neukončit. Nejrychlejším způsobem lze tuto operaci opakovaně spouštět z uživatelské nabídky.

Definitivní otevření účetních knih (po uzavření) se provede šablonou s volbou otevření z uzávěrky minulého období „ano“. Systém kontroluje existenci události uzavření účetních knih, bez ní otevření neproběhne.

Pro uzavření a otevření účtů podrozvahové evidence je třeba v činnosti Účetnictví – speciální činnosti – parametry účetnictví – změnit parametr „povolit otevření a uzavření podrozvahových účtů“ ze stavu Nepovolit na stav Povolit či Varovat. Proces se spouští nabídkou Obecné – Import/Export dat a výběr varianty Uzavření nebo Otevření požadovaného roku a měny. Při standardním provozu by mělo platit, že uživatelé spouští procesy pro otevření a uzavření účtů 0 až 6 a další procesy pro otevření a uzavření podrozvahových účtů – každý pouze jednou.

Systém umožňuje otevření a uzavření účetních knih provést pouze jednou ročně. V případě potřeby znovuotevření účetních knih je nutno původní operaci otevření odblokovat (storno neprovádět) a znovu zadat správně (v případě nejasností je toto nutno řešit ve spolupráci s pracovníky IT BM Servis s.r.o., kteří provedou ruční zásah do systému).

Formulář

Formulář činnosti - Skupiny XSLT předloh
Období | Identifikace účetního období
Druh | Druh informace skutečnost, plán ...
Otevření z uzávěrky před. období | Otevření z uzávěrky předcházejícího období
Respektovat selektory | Respektovat selektory
Agregované zápisy na účty 7.. | Agregované zápisy na účty 7..
Měna | Kód měny - oceňovací jednotky.


INFORMACE K ÚČTU

Popis

Uživatel má k dispozici veškeré informace z oblasti účetnictví, vztahující se k danému (tj. aktuálnímu) účtu.

Viz.také

Účetní deník | Účetní saldokonto | Účtový rozvrh | Obratová tabulka | Obratová tabulka se selektory | Konta | Konta se selektory


Nový druh výkazu

Popis

V první řadě je nutno nadefinovat druh výkazu. Každý výkaz musí být určitého druhu, který uživatel založí (nebo vybere) v činnosti "volby". Zadává se název a druh výkazu.

Každý výkaz musí být nejen určitého druhu, ale musí se skládat z alespoň jednoho listu. K tomu, aby bylo možno k novému výkazu zařadit jednotlivé listy, je nutno tyto listy nejprve zařadit do seznamu listů. Toto se provede pravou myší na seznamu listů pomocí činnosti "nový list". Zadává se identifikace a vlastní název listu.

Dalším krokem je založení vlastního výkazu. Toto uživatel provede stiskem pravé myši na druhu výkazu. Vybere si činnost nový výkaz a nadefinuje jeho název a soubor (tj. název souboru, ve kterém bude tento výkaz uložen. Protože se jedná o soubor typu Excel, je možno rovnou napsat příponu xls, např. výkaz.xls, jinak program si tuto příponu doplní sám). Při tvorbě názvu výkazu je uživatele možno upozornit na to, že název výkazů by měl být tvořen metodicky, jednak kvůli snadnější práci s vyhledáváním, jednak ke každému výkazu je možno nadefinovat přístupová práva a hledání se bude zase odvíjet od názvu výkazu. Otevřením menu (kliknutím na ikonce se znaménkem plus u názvu výkazu) se uživateli zobrazí možnosti:

- listy (u jednotlivých listů je možno měnit pořadí jejich zobrazování - tato možnost je přístupná po stisku pravé myši). Pokud zde není list zařazen, je možno ho vybrat právě ze seznamu listů a zařadit ho i do této činnosti

- zdrojové výkazy

Může se stát, že list je zároveň výkazem nebo může nastat varianta, že výkaz se skládá z několika listů. List se do výkazu zařadí pravou myší na položce listy, a to pomocí činnosti "zařadit nový list". Pokud se výkaz skládá z více listů, zopakuje tento postup uživatel vícekrát. Může nastat i situace, že u výkazu existuje určitý zdrojový výkaz, nebo-li k výpočtu nadefinovaných listů je nejprve třeba výpočtu tohoto zdrojového výkazu (tzn. že jednotlivé listy se odkazují na určité výpočty, které jsou k dispozici právě až po výpočtu zdrojového výkazu). Zdrojový výkaz se k výkazu připojí stejným způsobem jako jednotlivé listy, a to pravou myší (činnost "zařadit nový výkaz").


Struktura listu

Popis

Aktivací činnosti definice výkazu se mu zobrazí obrazovka, která obsahuje následující údaje. V pravém horním rohu obrazovky má uživatel k dispozici výkaz tak, jak je nadefinován. Vzhled tohoto formuláře se nepatrně mění podle toho, jaká záložka je právě aktivní (sloupec, řádek, buňka, list). V následujících odstavcích si popíšeme jednotlivé položky v závislosti na zvolené záložce. Nejdříve si popíšeme záložky, které se týkají popisu sloupců a řádků výkazu.

Pod každou záložkou uživatel zadává identifikaci a název jednotlivých údajů výkazu. Pokud uživatel potřebuje název sloupce nebo řádku nahradit (např. chce zde mít uveden přímo název účtu z účtové osnovy nebo název měsíce), je možné použít následující klíčová slova:

- $typhod$ - podle typu hodnoty je nahrazeno řetězcem: počáteční stav, konečný stav, příjem výdej, obrat

- $ucet$ - číslo účtu

- $ucetnaz$ - název účtu

- $rokod$ - rok začátku období

- $mesod$ - měsíc začátku období

- $mesnaz$ - název měsíce

- $denod$ - den začátku období

- $rokdo$ - rok konce období

- $mesdo$ - měsíc konce období

- $dendo$ - den konce období

- $pom$ - hodnota pomocné proměnné

Pokud uživatel potřebuje mít řádky výkazu napsané ve tvaru např. A I. Obraty, A I. 1. Režie apod., je i toto možné, je však nutno provést následující kroky:

¨ na záložce list daného výkazu je nutno určit počet sloupců, na které bude rozdělen název řádku (položka "počet sl. pop. řádku). Zatím jsou standardně povoleny až 4 možné sloupce, v případě potřeby je však možno tuto hodnotu změnit (rozšířit nebo zúžit), a to pomocí atributu vs01pocslo.

¨ na záložce řádek je nutno před vlastní název řádku výkazu přidat hodnotu &-& (funguje jako oddělovač sloupců), takže podle našeho příkladu bude název řádku zapsán ve tvaru A I.&-&Obraty nebo A I. 1.&-&Režie atd.

Další údaje, které uživatel zadává jsou tyto:

¨ Popis – vlastní popis, který se týká řádku, sloupce nebo listu. Záleží zcela na uživateli co si do tohoto popisu uvede, např. u statistických výkazů zde může mít uvedeno, které statistické hodnoty se tento řádek výkazu týká apod.

¨ Formátování buněk – do této kolonky se zapisují příkazy, které mají vliv na vzhled výkazu v programu Excel (např. formát čísla, velikost fontu apod.). Jednotlivé příkazy se oddělují řádkou, tzn., co řádka, to samostatný příkaz. Může být uveden jeden nebo několik najednou. Uvedeme si některé možnosti, jakým způsobem lze příkaz zapsat:

- "0.0000" (výpočet na čtyři desetinná místa)

- "0.0000$" (čtyři desetinná místa a za číslicí je uvedeno Kč)

- "#.##" (v číslech jsou odděleny tisíce, např. 1 125 145)

- font.Size=12 (určuje velikost fontu)

- Interior.ColorIndex=příslušné číslo (např. 1 = černá, 6 = žlutá) – určuje barvu výplně

- Interior.Pattern=příslušné číslo (1 = 100% výplň) – určuje styl výplně

- Font.ColorIndex= příslušné číslo (např. 1 = černá, 6 = žlutá) – určuje barvu fontu

¨ Pořadí - pořadí dané položky ve výkazu (tato hodnota se automaticky předplňuje, uživatel má samozřejmě možnost ji změnit)

¨ Typ záznamu - může být normální nebo příkaz (v případě, že se zadávaný údaj bude počítat příkazem). Od tohoto zadání se pak odvíjí i to, jestli uživatel dále vyplňuje záložku "normální definice" nebo "příkaz". Údaje "tučně" a "italica" jsou zaškrtávací políčka a slouží pouze pro dokreslení estetické stránky výkazu. Poslední zaškrtávací políčko je položka "ukrýt". Při jeho zatržení program skryje daný řádek nebo sloupec (např. v případě, že některé řádky nebo sloupce se používají pouze jako pomocné výpočty pro ostatní sloupce a řádky).

Na úrovni listu zde má uživatel k dispozici zaškrtávací políčko "skrýt nulové řádky". Znamená to, že po zatržení tohoto příznaku se vypočtené řádky, které budou mít nulovou hodnotu, nebudou ve výkazu vůbec zobrazovat.

Další položky, které si dále popíšeme souvisí s typem záznamu "normální definice". Význam položek je následující:

¨ Účet - seznam identifikátorů účtu - může být uveden pouze jeden (např. 604% - což je celý účet 604 včetně analytiky) nebo kombinace jednoho účtu a intervalu (např. 62%;630-:-640 - což jsou všechny účty začínající na 62 a zároveň účty v intervalu 630 až 640). Pravidla pro vytvoření seznamu identifikátorů jsou tedy následující:

% - celý řetězec

středník - oddělovač jednotlivých prvků

-:- - interval

V účetnictví je v případě potřeby možno zadávat hodnoty nejen skutečné, ale i plánované. Potom je zatržením příznaku plán možno určit, zda se na výkazu mají zobrazovat hodnoty skutečné nebo právě plánované.

Před položkou účet jsou dvě zaškrtávací políčka, jejichž význam je následující:

¨ Překrýt nadřízenou definici - pokud není toto políčko zatrženo, nelze do položky účet vložit žádný údaj. Pokud má tento list výkazu svůj nadefinovaný zdrojový výkaz a uživatel chce, aby se přejímal údaj z tohoto výkazu, nechá toto políčko prázdné.

¨ Dynamická hodnota - znamená, že pokud bude toto políčko zatrženo, bude následující hodnota rozepsána do jednotlivých řádek samostatně. Např. pokud uživatel uvede do položky účet 604% a účet 604 má třeba osm analytických účtů, bude k účtu 604 osm dalších samostatných záznamů, které se týkají právě analytické části.

¨ Organizační selektor - je zde k dispozici pro to, aby v účetnictví bylo možno provést konsolidovanou uzávěrku. Zaškrtávací políčka před mají stejný význam jako u položky účet.

¨ Další údaje v normální definici se týkají určení období, kde platí to samé, co bylo teď výše popsáno u položky účet. Zaškrtávací políčko dynamická hodnota zde zastává naprosto shodnou funkci, jednotlivé hodnoty pak budou rozepsány samostatně (např. při období od ledna do dubna budou rozepsány zvlášť hodnoty za leden, za únor, za březen a za duben). Další údaje k období není nutno popisovat příliš podrobně (snad jen to, že je možné počítat denní, týdenní, měsíční nebo čtvrtletní hodnoty), jejich význam je celkem jasný již z jejich názvu. Možná bude ještě vhodné se zmínit o položce "po". Určuje po kolika měsících se vytváří jednotlivé listy výkazu. Uvedeme si raději názorný příklad spojení položky "po" při využití dynamické hodnoty a naopak.

- není dynamické spojení - a budou zadány např. hodnoty měsíc, od 1, do 5, po 0 - toto zadání nám pak umožní vypočítat výkaz od ledna do května, přičemž se spočítá suma částek od ledna do května

- je zatrženo dynamické spojení - a budou zadány např. hodnoty měsíc, od 1, do 5, po 1 - spočítá se výkaz od ledna do května, přičemž bude součtován každý měsíc zvlášť. Položka "po" tedy slouží jako údaj, kolik měsíců se má sečíst do jednoho údaje. Pokud bude zadání např. od 1, do 7, po 3, tak systém postupuje následujícím způsobem, první list výkazu je za měsíc leden, jedna + tři je čtyři, takže další list výkazu je hodnota v měsíci dubnu, čtyři + tři je sedm, takže poslední list výkazu je hodnota v měsíci červenci.

¨ Pokud uživatel potřebuje vybrat určitý typ hodnoty, je nutno zaškrtnout políčko překrýt nadřízenou definici u typu hodnoty. Z jednotlivých možností si potom uživatel vybere tu hodnotu, kterou chce mít spočítanou ve sloupci nebo v řádku. Možnosti jsou:

- PS k prvnímu dni období (tj. stav od začátku roku neboli KS předchozího měsíce)

- KS k poslednímu dni období

- suma má dáti

- suma dal

- obrat za období (tj. počáteční stav mínus konečný)

¨ Poslední položkou je údaj dělit. Tento údaj využijí zejména ti uživatelé, kteří budou definovat některý ze státních výkazů, kde mají být hodnoty uvedeny v tisících. Do této položky tedy uvedou, že všechny vypočtené údaje se mají dělit tisícem.

Jako další je nutno popsat variantu, kdy typ záznamu je "příkaz".

Pokud tedy uživatel potřebuje při výpočtu výkazu využít možností, které mu nabízí příkazy programu Excel, musí využít možnosti příkaz. Pro vytváření této definice je nutné, aby uživatel měl alespoň minimální znalost příkazů tohoto programu. Pro zjednodušení práce uživatele si zde uvedeme možné příkazy a způsob jejich definice. Může to být např.:

=$R(10)-$R(20), což znamená řádek 10 mínus řádek 20

=$R(90)+$R(100), což znamená řádek 90 plus řádek 100

=SUM($R(50):$R(90)), což znamená součet řádků 50 až 90

$poradi$

Při zapsání příkazu poradi systém pak vytváří sloupec, ve kterém je zapsáno číselné pořadí jednotlivých řádek. Při vytváření příkazů mohou být samozřejmě využity i jiné matematické funkce (např. násobení, dělení apod.), ale vždy je nutno mít na paměti, že řádek musí být napsán ve tvaru $R(kdy R je příslušné číslo řádku). Uživatel má možnost si pomocí tohoto příkazu ve sloupci zvolit jakýkoliv způsob číslování, např. napíše-li tento příkaz ve tvaru 60+$poradi$, tak to znamená, že řádky ve sloupci budou očíslovány ve tvaru 60, 61, 62 apod.

Další záložka, která se uživateli nabízí je "buňka". Buňka v podstatě představuje místo, kde se spojuje řádek a sloupec. Buňka se definuje zvlášť pouze v případě, že se nějakým způsobem liší od celkové definice výkazu, tzn., že uživatel potřebuje mít na místě buňky odlišnou hodnotu od té, která zde vychází podle definice řádek a sloupců.

Poslední záložkou, kterou má uživatel k dispozici je "list". Tato záložka nemusí být povinně definována, záleží pouze na potřebách uživatele, zda tyto údaje vyplní či nikoliv. Jedná se pouze o doplňující údaje (dopřesnění období, vlastností listu apod.). Pod pojmem list se v podstatě myslí tentýž list, který se uživateli zobrazuje po spuštění programu Excel. I pro tento list je možno nadefinovat vlastní parametry, způsob jeho zobrazení apod.

Datový model

  • UCSLOUP Sloupec výkazu

    • Formulář

    Formulář činnosti - Generovaní listu (Pro Standu)
Listovací rámeček
Stránka #1 Sloupec
Identifikace | Identifikace sloupce
Název | Název sloupce
Popis | Popis sloupce
 | Formátování buněk
Pořadí | Pořadí sloupce
Typ záznamu | Typ sloupce
 | Formátování buněk
Tučně | Text buňky tučně
Italica | Text buňky italica
Negace | Příznak negovat vypočtenou hodnotu
Ukrýt | Tento sloupec bude skrytý
Listovací rámeček
Stránka #1 Normální definice
 | Překrýt nadřízenou definici
 | Dynamická hodnota
Účet | Seznam identifikátorů účtů
 | Strana účtu MD/Dal
Plán | Spočítat plán nebo skutečnost
 | Překrýt nadřízenou definici
 | Dynamická hodnota
Org. sel. | Seznam identifikátorů organizačních selektorů
 | Dynamická hodnota
Období | Období
Od | Od
Do | Do
Použij | Použij
 | Překrýt nadřízenou definici
Typ hodnoty | Typ hodnoty
Dělit | Výsledné číslo dělit konstantou
Stránka #2 Příkaz
 | Příkaz
Stránka #2 Řádek
Identifikace | Identifikace řádku
Název | Název řádku
Popis | Popis řádku
 | Formátování buněk
Pořadí | Pořadí řádku
Typ záznamu | Typ řádku
 | Formátování buněk
Tučně | Text buňky tučně
Italica | Text buňky italica
Negace | Příznak negovat vypočtenou hodnotu
Ukrýt | Tento řádek bude skrytý
Listovací rámeček
Stránka #1 Normální definice
 | Překrýt nadřízenou definici
 | Dynamická hodnota
Účet | Seznam identifikátorů účtů
 | Strana účtu MD/Dal
 | Hloubka vnoření dynamicky generovaného seznamu účtů
Plán | Spočítat plán nebo skutečnost
 | Překrýt nadřízenou definici
 | Dynamická hodnota
Org. sel. | Seznam identifikátorů organizačních selektorů
 | Dynamická hodnota
Období | Období
Od | Od
Do | Do
Použij | Použij
 | Překrýt nadřízenou definici
Typ hodnoty | Typ hodnoty
Dělit | Výsledné číslo dělit konstantou
Stránka #2 Příkaz
 | Příkaz
Stránka #3 Buňka
Řádek | Identifikace řádku
Sloupec | Identifikace sloupce
Popis | Popis buňky
Typ záznamu | Typ buňky
Tučně | Text buňky tučně
Italica | Text buňky italica
Negace | Příznak negovat vypočtenou hodnotu
Listovací rámeček
Stránka #1 Normální definice
 | Překrýt nadřízenou definici
 | Dynamická hodnota
Účet | Seznam identifikátorů účtů
Plán | Spočítat plán nebo skutečnost
 | Překrýt nadřízenou definici
 | Dynamická hodnota
Org. sel. | Seznam identifikátorů organizačních selektorů
 | Dynamická hodnota
Období | Období
Od | Od
Do | Do
Použij | Použij
 | Překrýt nadřízenou definici
Typ hodnoty | Typ hodnoty
Stránka #2 Příkaz
 | Příkaz
Stránka #4 List
List | Identifikace listu
Název | Název listu
Nadpis | Nadpis listu
Název listu | Název listu v Excelu
Popis | Popis listu
Konstanty | Definování konstant použitých v listu
Skrýt nulové řádky | Skrýt řádky s nulovými hodnotami
 | Překrýt nadřízenou definici
 | Dynamická hodnota
Účet | Seznam identifikátorů účtů
Plán | Spočítat plán nebo skutečnost
 | Překrýt nadřízenou definici
 | Dynamická hodnota
Org. sel. | Seznam identifikátorů organizačních selektorů
 | Dynamická hodnota
Období | Období
Od | Od
Do | Do
Použij | Použij
 | Překrýt nadřízenou definici
Typ hodnoty | Typ hodnoty
Počet sl. pop. řádku | Počet sloupců na který bude rozdelen název řádku

    Vyvolávané činnosti

    K. | Činnost | Popis
- | Generovaní listu (Pro Standu) |

    Viz.také

    Generovaní listu (Pro Standu)


Výpočet výkazu

Popis

Stiskem pravého tlačítka myši na názvu výkazu se uživateli nabízí možnost "spustit". Po aktivaci této činnosti naběhne na obrazovce okno, ve kterém uživatel zadá datum, ke kterému chce daný účetní výkaz spočítat. Po zadání a potvrzení tohoto data je daný výkaz spočten a zobrazen v tabulce (Excel).

Pokud má uživatel u výkazu nadefinovány určité parametry, je systémem před vlastním výpočtem výkazu požadováno zadání určité hodnoty do těchto parametrů.

Datový model

  • UCRADEK Řádek výkazu

    • Formulář

    Formulář činnosti - Parametry listu
    Od data Datum ke kterému se zpracovává výkaz

    Viz.také

    Parametry listu


Parametry listu

Popis

Pravou myší má uživatel možnost ovlivnit nejen vlastní definici listu, ale i "vlastnosti" listu jako takové. Jedná se o pět možných parametrů (jejich definice záleží pouze na uživateli), kde je u každého parametru navíc možno uvést jeho implicitní hodnotu. Ve vlastnostech tedy uživatel zadává název zvoleného parametru, případně může uvést i jeho implicitní hodnotu. Parametry jsou v této nabídce označeny hodnotami $1, $2, $3, $4 a $5. Hodnoty jednotlivých parametrů pak uživatel musí zapsat do jednotlivých položek výkazu (v činnosti definice výkazu) – viz. popis dále. Hodnoty do parametrů je možno zapisovat trojím způsobem. Každý ze způsobů je přehledně vyjádřen v následující tabulce.

Název (tzv. label) Implicitní hodnota Parametr se zadává

Např. období od Neuvedena Ano

Např. období do Např. 01.06.1999 Ne

Neuveden Např. 01.06.1999 Ne

Pro větší názornost si jednotlivé možnosti podrobně popíšeme:

1. Je uveden název parametru, implicitní hodnota není uvedena žádná. Potom systém při vlastním výpočtu výkazu požaduje zadání této implicitní hodnoty.

2. Je uveden název parametru a přitom je uvedena i určitá implicitní hodnota. Při výpočtu výkazu pak systém nepožaduje zadání implicitní hodnoty.

3. Název není uveden, ale je zadána implicitní hodnota. I v tomto případě se při výpočtu výkazu žádná implicitní hodnota nezadává.

K těmto třem možnostem je nutno sdělit, že pokud je při tvorbě parametrů použita kombinace těchto možností a jedna z nich bude možnost č. 1 (tzn. název je zadán, implicitní hodnota není uvedena), bude systém při výpočtu výkazu vždy požadovat zadání implicitní hodnoty.

Pokud tedy uživatel nadefinuje pouze název tohoto parametru (tzv. label), zadává jeho vlastní hodnotu těsně před výpočtem výkazu. Uvedeme si příklad. Uživatel si bude chtít vybraný výkaz spočítat a vytisknout pokaždé za jiný obchodní selektor. Potom do názvu prvního parametru uvede "obchodní selektor" a přímo ve výkazu uvede do položky obchodní selektor hodnotu $1 (tj. odkaz na parametr jedna).

Při spuštění výpočtu výkazu systém po uživateli žádá vyplnění vlastní identifikace obchodního selektoru. Znamená to, že stejný výkaz platí pro všechny obchodní selektory a uživatel si podle svých momentálních potřeb zvolí, za který selektor se má výkaz spočítat. Další příklad, který si pro názornost můžeme uvést je určení období, za které se má výkaz spočítat. Uživatel nazve první parametr Období od a druhý parametr Období do. Potom v definici výkazu ve skutečných položkách období od – do uvede příslušné hodnoty. Tedy do položky období od zapíše $1 a do položky období do zapíše $2. Po spuštění výpočtu pak systém požaduje zadání těchto dvou parametrů a daný výkaz se pak spočítá podle zde zadaného období. Jak jsme si již vysvětlili, pokud je u některého parametru zvolena implicitní hodnota, systém před vlastním výpočtem výkazu nepožaduje potvrzení této hodnoty.

Formulář

Formulář činnosti - Nový záznam podle schématu
$1 | Hodnota parametru 1
$2 | Hodnota parametru 2
$3 | Hodnota parametru 3
$4 | Hodnota parametru 4
$5 | Hodnota parametru 5


Generovaní listu (Pro Standu)

Datový model

  • UCROZVRH Účet z rozvrhu
    • UCROZVRN Cizí popis účtu

    • © 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Zadej datum

Popis

Zadává se datum, od kterého se má výkaz počítat, tzn. od jakého data nadefinované hodnoty do výkazu vstupují.

Formulář

Formulář činnosti - Parametry listu
Datum výkazu Datum ke kterému se zpracovává výkaz


Export listu výkazu do balíčku

Datový model

  • UCLIST List výkazu
    • BWUZIVAT Uživatel systému

    • Formulář

    Formulář činnosti - Konv. listu do nových výkazů
Mřížka [Export výkazů do balíčku]
List | Identifikace listu
Název | Název listu
Popis | Popis listu
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události

    Mřížka [Export výkazů do balíčku] činnosti - Konv. listu do nových výkazů

    Mřížka [Export výkazů do balíčku] činnosti - Konv. listu do nových výkazů
List | Identifikace listu
Název | Název listu

    Vyvolávané činnosti

    K. | Činnost | Popis
- | Konv. listu do nových výkazů | Konverze listu do nových výkazů

    Viz.také

    Konv. listu do nových výkazů


Export výkazu do balíčku

Datový model

  • UCVYKAZ Definice výkazu

    • Formulář

    Formulář činnosti - Parametry listu
Mřížka [Export výkazu do balíčku]
Název | Název výkazu
Popis | Popis výkazu
Zapsal | Jméno uživatele systému
 | Datum a čas zápisu záznamu události

    Mřížka [Export výkazu do balíčku] činnosti - Parametry listu

    Mřížka [Export výkazu do balíčku] činnosti - Parametry listu
    Název Název výkazu


Sumy stran

Popis

Jedná se o činnost, kterou uživatel aktivuje z činnosti účetní deník po stisku klávesy Ctrl S nebo spuštěním činnosti „výpočet sumy stran“ pod menu Volby. Zobrazí se tabulka se součtem hodnot na straně MD a Dal všech zobrazených údajů (jejich zobrazení závisí na vyfiltrované záložce Výběr). Při nesouhlasu stran MD a Dal je v dané tabulce vyčíslen i rozdíl.

Formulář

Formulář činnosti - Uzavření okna
Sumy stran | Sumy stran
<> | Rovnost stran
Má dáti | Suma strany má dáti
Dal | Suma strany dal
Změna | Změna KS

Vyvolávané činnosti

K. | Činnost | Popis
- | Uzavření okna |

Viz.také

Uzavření okna


Výpočet sumy stran

Popis

Tato činnost je dostupná v menu Volby nebo po stisku klávesy Ctrl S v činnosti Obratová tabulka a Obratová tabulka se selektory. Uživatel má k dispozici sumu stran Má dáti a Dal za data, která jsou zobrazena v okně formuláře.


Uzavření okna

Popis

Jedná se o tlačítko „uzavřít okno“ v činnosti Výpočet sumy stran.


Kopie listu

Formulář

Formulář činnosti - Konv. listu do nových výkazů
Kopírovaný list | Identifikace listu
Nový list | Identifikace nově vzniklého listu


Rozúčtování události účetnictví

Popis

V událostech účetnictví neukončených operací je možno rozúčtovat události účetního deníku na více událostí bez nutnosti přepisovat původní hodnotu v Kč. Rozúčtování uživatel aktivuje volbou příslušné činnosti z menu Volby a nebo stiskem klávesy F5.

Při aktivaci této činnosti se uživateli zobrazí tabulka s původní hodnotou účtu, ze kterého bylo rozúčtování aktivováno. Po přidání dalšího řádku (F3) a uvedení účtu a částky se přitom původní hodnota v účetnictví na daném účtu automaticky mění. Nově vzniklé události jsou spojeny stejnými záznamy míry plnění transformace na události jiných komponent jako událost, která byla rozúčtována.

Při rozúčtování události účetnictví, která obsahuje částku v cizí měně, je rozúčtována i tato částka.

Datový model

  • UCDENROZ Pracovní záznam pro rozúčtování události účetnictví
    • SPSEOB Obchodní selektor
    • SPSEOR Organizační selektor
    • SPSETV Technicko-věcný selektor
    • UCROZVRH Účet z rozvrhu
      • UCROZVRN Cizí popis účtu

    • Formulář

    Formulář činnosti - Organizační selektor
Mřížka [Rozúčtování]
Účet | Identifikátor účtu účetnictví
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Částka | Finanční částka
Popis události | Popis účetní události

    Mřížka [Rozúčtování] činnosti - Organizační selektor

    Mřížka [Rozúčtování] činnosti - Organizační selektor
Účet | Identifikátor účtu účetnictví
Obch. sel. | Identifikátor obchodního selektoru
Org. sel. | Identifikátor organizačního selektoru.
Tech. sel. | Identifikátor technicko-věcného selektoru.
Částka | Finanční částka
Popis události | Popis účetní události

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Obchodní selektor | Číselník obchodních selektorů
F2 | Organizační selektor | Číselník organizačních selektorů
F2 | Technicko-věcný selektor | Číselník technicko-věcných selektorů
F2 | Účtový rozvrh | Seznam syntetických a analytických účtů.

    Viz.také

    Obchodní selektor | Organizační selektor | Technicko-věcný selektor | Účtový rozvrh


Předplň účetní období

Popis

Tuto činnost má uživatel k dispozici v činnosti „účetní období“ po stisku klávesy F5 nebo pod menu Volby. Po její aktivaci se uživateli nabídne dialogové okno, kde vyplňuje rok od a rok do, tzn. že tuto činnost mohou využívat pouze ti uživatelé, kteří jako účetní období mají běžný kalendářní rok. Např. pokud zadáme rok od 2007 a rok do 2009, systém poté automaticky vytvoří tři řádky účetních období – rok 2007 - měsíc 01-12, rok 2008 – měsíc 01-12 a rok 2009 – měsíc 01-12.

Formulář

Formulář činnosti - Konv. listu do nových výkazů
Účetní období od roku | Účetní období od roku
do roku | Konec intervalu účetních období


Spuštění archivace

Popis

V této činnosti jsou ke spuštění k dispozici jednotlivé nadefinované archivace, které ve své definici mají na záložce Skupiny archivace v atributu nabízet uvedeno Ano a zároveň jsou nadefinovány s druhem dokumentu, ke kterému má daný uživatel právo zápis. Jednotlivé archivace se mohou aktivovat z této činnosti (tzn. z hlavního menu) a nebo přímo z činnosti Popis archivací z menu Volby (stiskem klávesy F9).

Po aktivaci dané archivace následuje systémový dotaz, zda uživatel chce opravdu archivovat (Ano/Ne) s informacemi o počtu archivovaných adresářů a souborů a jejich velikosti.


Definice listu

Popis

V případě užití přímé metody pro nastavení definice listu uživatel využívá navigační list. Tento list je okno, které se automaticky zobrazí společně s formulářem činnosti definice listu. Obsahuje a zobrazuje všechny definované buňky definice výkazu. Je určen pro navigaci v definici listu, tj. při kliknutí na danou buňku v navigačním listu je pod ním uživateli zobrazena definice této buňky včetně definice řádku, sloupce a parametrů listu.

Řádek je elementem definice listu s prioritou nejvyšší po buňce, tj. může definovat její implicitní vlastnosti. Daný řádek definice listu je dostupný pomocí navigačního listu, pokud definice listu není založena pomocí vzoru listu je možné zde definovat jeho vlastnosti, případně zrušit či založit nový. Jednomu řádku definice listu odpovídá jeden řádek výkazu, pokud je v atributu parametry řádku aplikován příkaz dyn, může to být více řádků výkazu. Řádek definice listu výkazů prezentovaný identifikátorem řádku umožňuje definovat pořadí a název řádku, atribut parametry, implicitní formát a obsah jeho buněk výrazem, vzorcem nebo jako prázdný, případně zda má být řádek ve výkazu skrytý.

Sloupec je elementem definice listu s prioritou po řádku, tj. může definovat implicitní vlastnosti buňky, pokud nejsou definovány řádkem. Daný sloupec definice listu je dostupný pomocí navigačního listu, pokud definice listu není založena pomocí vzoru listu je možné zde definovat jeho vlastnosti, případně zrušit či založit nový. Jednomu sloupci definice listu odpovídá jeden sloupec výkazu, pokud je v atributu parametry sloupce aplikován příkaz dyn, může to být více sloupců výkazu. Sloupec definice listu výkazů prezentovaný identifikátorem sloupce umožňuje definovat pořadí a název sloupce, atribut parametry, implicitní formát a obsah jeho buněk výrazem nebo vzorcem, případně zda má být sloupec ve výkazu skrytý.

Buňka je nejmenším elementem definice listu. Pokud není definována přímo, je definována implicitně řádkem či sloupcem definice listu, případně je definována pomocí vzoru listu. V definici listu je daná buňka dostupná pomocí navigačního listu. Přímá definice buňky je umožněna, pokud byla vložena na odpovídajícím průsečíku řádku a sloupce v navigačním listu (menu VOLBY – Vložit buňku), což je současně možné jen tehdy, pokud definice listu není založena pomocí vzoru.

Přímá definice umožňuje definovat název buňky, který je následně použitelný ve vzorcích definujících jiné buňky, v atributu „param.“ přiřadit hodnoty parametrům, formát buňky a její obsah výrazem, vzorcem nebo jako prázdnou. Formát buňky je pravidlo, které po aplikaci v definici listu pro danou buňku definuje, jak bude relevantní buňka výkazu formátována při sestavení výkazu. Formát umožňuje předdefinovat písmo, formát čísla a ohraničení buňky. V případě, že je formát buňky uveden v definici listu, sloupce, řádku má implicitní charakter pro všechny obsažené buňky.

Datový model

  • VKLIST List výkazu

    • Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Vložit sloupec | Vložit sloupec
F6 | Vložit řádek | Vložit řádek
F7 | Vložit buňku | Vložit buňku
- | Odstranit sloupec | Zrušit sloupec
- | Odstranit řádek | Odstranit řádek
- | Odstranit buňku | Odstranit buňku
- | Editovat kód vlastnosti | Editovat kód vlastnosti
- | Kontrolní kompilace | Kontrolní kompilace
- | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností
F2 | Funkce výkazů | Funkce výkazů

    Formulář

    Formulář činnosti - Knihovny vkládaného kódu
List | Identifikace listu
Název listu | Název listu
Šablona | Identifikace šablony listu dokumentu
Formát | Identifikace formátu buňky
Param. | Parametry listu
Poznámka | Poznámka
Sloupec | Identifikace sloupce
 | Pořadové číslo sloupce
Název sloupce | Název sloupce
Param. | Parametry sloupce
 | Obsah výrazu
Výraz | Výraz
Šířka | Šířka sloupce
Zakroulování | Zaokrouhlovaná hodnota
Formát | Identifikace formátu buňky
Pozn. | Poznámka
Skrytý | Skrytý sloupec
Řádek | Identifikace řádku
 | Pořadové číslo řádku
Název | Název řádku
Param. | Parametry řádku
 | Obsah výrazu
Výraz | Výraz
Formát | Identifikace formátu buňky
Pozn. | Poznámka
Skrytý | Skrytý řádek
Buňka | Název buňky
Param. | Param.
 | Obsah výrazu
Výraz | Výraz
Formát | Identifikace formátu buňky
Pozn. | Poznámka

    Viz.také

    Vložit sloupec | Vložit řádek | Vložit buňku | Odstranit sloupec | Odstranit řádek | Odstranit buňku | Editovat kód vlastnosti | Kontrolní kompilace | Knihovny vkládaného kódu | Funkce výkazů


Vložit sloupec

Popis

Po stisku klávesy F5 v činnosti Definice listu se vloží nový sloupec.


Vložit řádek

Popis

Po stisku klávesy F6 v činnosti Definice listu se vloží nový řádek.


Vložit buňku

Popis

Po stisku klávesy F7 v činnosti Definice listu se vloží nová buňka.


Odstranit sloupec

Popis

Po aktivaci činnosti „odstranit sloupec“ pod menu Volby v činnosti Definice listu je zrušen aktuální sloupec výkazu.


Odstranit řádek

Popis

Po aktivaci činnosti „odstranit řádek“ pod menu Volby v činnosti Definice listu je zrušen aktuální řádek výkazu.


Odstranit buňku

Popis

Po aktivaci činnosti „odstranit buňku“ pod menu Volby v činnosti Definice listu je zrušena aktuální buňka výkazu.


Spustit výkaz

Popis

Tato činnost se aktivuje po stisku F9 nebo spuštěním činnosti „spustit výkaz“ pod menu Volby v činnosti Definice výkazu. Podle nadefinovaného atributu „dotaz“ v definici výkazů se uživateli zobrazuje formulář se vstupními údaji (např. od data – do data, výběr určitého selektoru apod.).


Konv. listu do nových výkazů

Popis

Tato činnost se aktivuje pod menu Volby z činnosti Export listu výkazu do balíčku. Provede se konverze (tj. převod) listu z jednoho výkazu do jiného výkazu.


Definice listu podle vzoru

Popis

Pokud uživatel definuje list výkazu pomocí metody s použitím vzoru listů, musí mít nadefinován i tento vzor. Vzor listů výkazů je uživatelsky připravená „šablona“, která uživateli usnadní nastavení definice listu. Každý vzor je opakovaně použitelný pro více listů, které jsou si svou strukturou a obsahem podobné, například přípravu všech definic listů účetních výkazů lze usnadnit jediným vzorem.

Příprava vzoru zahrnuje definici jeho identifikace, která se případně uvádí v definici listu, název, atribut parametry a případnou pevné uživatelem při aplikaci vzoru již neovlivnitelné nastavení prvních tří sloupců definice listu. Uvedené nastavení sloupce spočívá v uvedení jeho názvu (budoucí nadpis), definice obsahu výrazem, formátu a šířky. Příprava vzoru dále zahrnuje definici výrazů daného vzoru.

Nejnáročnější částí při definování vzoru listů výkazů je pravděpodobně definice výrazu vzoru. Výraz vzoru listu je definice „ukazatele“ (logického pojmu), který využívá uživatel při definici listu pomocí vzoru. Výraz vzoru listu je definován pořadím, popisem, tj.názvem, pod kterým je dostupný uživateli ve vzoru, a výrazem, kterým je mu přiřazen skutečný obsah (např. pomocí funkce výkazu).

Dále je možné pro každý výraz vzoru listu definovat až pět parametrů, na jejichž skutečnou hodnotu bude uživatel dotázán při aplikaci daného výrazu vzoru listu. Parametr se definuje identifikátorem, typem (C,N,D), délkou a návěštím, pod kterým se prezentuje uživateli ve vzoru.

Pro metodu definice listu výkazu pomocí metody s použitím vzoru listů je charakteristická řádková orientace jejího nastavení při pevném maximálním počtu sloupců výkazu, tj. maximálně tři pevně definované ve vzoru a maximálně devět definovaných zde.

Řádek je definován identifikátorem, pořadím, názvem, implicitním formátem jeho buněk a případně, zda ve výkazu bude skrytý.

Pro každý sloupec je možné zde definovat jeho nadpis, implicitní formát a jeho šířku (-1 znamená skrytý). Pro list se zde definuje nadpis listu a název záložky. Na základě těchto uživatelských nastavení je automaticky vygenerována definice listu výkazů.

Pro každou ze zmíněných devíti buněk řádku může uživatel definovat název buňky, formát a způsob naplnění jejího obsahu (typ výpočtu) a to: žádný, vzorec (takto definované řádky se zobrazují v gridu šedě), výpočet anebo některý z výrazů daného vzoru, přičemž v tomto případě současně definuje hodnotu parametrů výrazu vzoru.

Použité makro $RS(...) může vkládat do výsledného výrazu místo seznamu buněk Excelu jejich součet. Stane se tak v případě, že posledním znakem vzorce před makrem $RS(...) je znak '=' nebo '+' nebo '-'.

Příklad.:

K výrazu - =SUM($RS(mezisoucet)), který je vyhodnocen např. =SUM(C1,C5,C7,C11:C17,C20)

je ekvivalentní výraz - =$RS(mezisoucet), který je vyhodnocen např. =C1+C5+C7+SUM(C11:C17)+C20

Tato změna byly vyvolána vlastností Excelu ve verzích 11 a nižších, podle které je možné v seznamu funkce SUM uvádět nejvýše 30 položek.

Datový model

  • VKTEMRAD Pracovní řádek listu

    • Formulář

    Formulář činnosti - Kopie řádku
Mřížka [Řádky]
Listovací rámeček
Stránka #1 Sloupce 1-3
Řádek | Identifikace řádku
 | Pořadové číslo řádku
Název | Název řádku
Formát | Identifikace formátu buňky
Skrytý | Skrytý řádek
S10 | Název buňky S10
 | Typ výpočtu ve sloupci 1
Formát | Identifikace formátu buňky
P11 | Parametr 1
P12 | Parametr 2
P13 | Parametr 3
P14 | Parametr 4
P15 | Parametr 5
Výraz | Výraz
Vzorec | Vzorec
S20 | Název buňky S20
 | Typ výpočtu ve sloupci 2
Formát | Identifikace formátu buňky
P21 | Parametr 1
P22 | Parametr 2
P23 | Parametr 3
P24 | Parametr 4
P25 | Parametr 5
Výraz | Výraz
Vzorec | Vzorec
S30 | Název buňky S30
 | Typ výpočtu ve sloupci 3
Formát | Identifikace formátu buňky
P31 | Parametr 1
P32 | Parametr 2
P33 | Parametr 3
P34 | Parametr 4
P35 | Parametr 5
Výraz | Výraz
Vzorec | Vzorec
Stránka #2 Sloupce 4-6
Řádek | Identifikace řádku
 | Pořadové číslo řádku
Název | Název řádku
Skrytý | Skrytý řádek
S40 | Název buňky S40
 | Typ výpočtu ve sloupci 4
Formát | Identifikace formátu buňky
P41 | Parametr 1
P42 | Parametr 2
P43 | Parametr 3
P44 | Parametr 4
P45 | Parametr 5
Výraz | Výraz
Vzorec | Vzorec
S50 | Název buňky S50
 | Typ výpočtu ve sloupci 5
Formát | Identifikace formátu buňky
P51 | Parametr 1
P52 | Parametr 2
P53 | Parametr 3
P54 | Parametr 4
P55 | Parametr 5
Výraz | Výraz
Vzorec | Vzorec
S60 | Název buňky S60
 | Typ výpočtu ve sloupci 6
Formát | Identifikace formátu buňky
P61 | Parametr 1
P62 | Parametr 2
P63 | Parametr 3
P64 | Parametr 4
P65 | Parametr 5
Výraz | Výraz
Vzorec | Vzorec
Stránka #3 Sloupce 7-9
Řádek | Identifikace řádku
 | Pořadové číslo řádku
Název | Název řádku
Skrytý | Skrytý řádek
S70 | Název buňky S70
 | Typ výpočtu ve sloupci 7
Formát | Identifikace formátu buňky
P71 | Parametr 1
P72 | Parametr 2
P73 | Parametr 3
P74 | Parametr 4
P75 | Parametr 5
Výraz | Výraz
Vzorec | Vzorec
S80 | Název buňky S80
 | Typ výpočtu ve sloupci 8
Formát | Identifikace formátu buňky
P81 | Parametr 1
P82 | Parametr 2
P83 | Parametr 3
P84 | Parametr 4
P85 | Parametr 5
Výraz | Výraz
Vzorec | Vzorec
S90 | Název buňky S90
 | Typ výpočtu ve sloupci 9
Formát | Identifikace formátu buňky
P91 | Parametr 1
P92 | Parametr 2
P93 | Parametr 3
P94 | Parametr 4
P95 | Parametr 5
Výraz | Výraz
Vzorec | Vzorec
Stránka #4 Popis listu
List | Identifikace listu
Název listu | Název listu
Vzor | Identifikace vzoru listu
Název vzoru | Název vzoru listu
Nadpis listu | Nadpis listu
Záložka listu | Záložka listu
Dodatečné deklarace | Podmínky pro zařazení sloupců do listu, rezervace zdrojů systému
Pozn. | Poznámka
Stránka #5 Popis sloupců
List | Identifikace listu
Název listu | Název listu
Vzor | Identifikace vzoru listu
Název vzoru | Název vzoru listu
Sloupec 10 | Nadpis 1.sloupce
Formát | Identifikace formátu buňky
Šířka | Šířka 1.sloupce
Sloupec 20 | Nadpis 2.sloupce
Formát | Identifikace formátu buňky
Šířka | Šířka 2.sloupce
Sloupec 30 | Nadpis 3.sloupce
Formát | Identifikace formátu buňky
Šířka | Šířka 3.sloupce
Sloupec 40 | Nadpis 4.sloupce
Formát | Identifikace formátu buňky
 | Šířka 4.sloupce
Sloupec 50 | Nadpis 5.sloupce
Formát | Identifikace formátu buňky
 | Šířka 5.sloupce
Sloupec 60 | Nadpis 6.sloupce
Formát | Identifikace formátu buňky
 | Šířka 6.sloupce
Sloupec 70 | Nadpis 7.sloupce
Formát | Identifikace formátu buňky
 | Šířka 4.sloupce
Sloupec 80 | Nadpis 8.sloupce
Formát | Identifikace formátu buňky
 | Šířka 5.sloupce
Sloupec 90 | Nadpis 9.sloupce
Formát | Identifikace formátu buňky
 | Šířka 6.sloupce
1.sloupec vzoru | Zobrazovat 1.sloupec vzoru
2.sloupec vzoru | Zobrazovat 2.sloupec vzoru
3.sloupec vzoru | Zobrazovat 3.sloupec vzoru

    Mřížka [Řádky] činnosti - Kopie řádku

    Mřížka [Řádky] činnosti - Kopie řádku
Pořadí | Pořadové číslo řádku
Řádek | Identifikace řádku
Název | Název řádku
S10 | Sloupec 1
S20 | Sloupec 2
S30 | Sloupec 3
S40 | Sloupec 4
S50 | Sloupec 5
S60 | Sloupec 6
S70 | Sloupec 7
S80 | Sloupec 8
S90 | Sloupec 9
Naz.b.S10 | Název buňky S10
Naz.b.S20 | Název buňky S20
Naz.b.S30 | Název buňky S30
Naz.b.S40 | Název buňky S40
Naz.b.S50 | Název buňky S50
Naz.b.S60 | Název buňky S60
Naz.b.S70 | Název buňky S70
Naz.b.S80 | Název buňky S80
Naz.b.S90 | Název buňky S90

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Kopie řádku | Kopie řádku

    Atributy tisku

    Základní údaje
Název | Název řádku | VKTEMRAD_vk05nazev | M
Řádek | Identifikace řádku | VKTEMRAD_vk05id | C(6)
Pořadí | Pořadové číslo řádku | VKTEMRAD_vk05porad | N(4)
Skrytý | Skrytý řádek | Výpočet | C(3)
S10 | Typ výpočtu ve sloupci 1 | Výpočet | C(7)
Formát | Identifikace formátu buňky | VKTEMRAD_vk16s1fr | C(6)
P11 | Parametr 1 | VKTEMRAD_vk16s1p1 | M
P12 | Parametr 2 | VKTEMRAD_vk16s1p2 | M
P13 | Parametr 3 | VKTEMRAD_vk16s1p3 | M
P14 | Parametr 4 | VKTEMRAD_vk16s1p4 | M
P15 | Parametr 5 | VKTEMRAD_vk16s1p5 | M
Výraz | Výraz | VKTEMRAD_vk16s1vr | M
Vzorec | Vzorec | VKTEMRAD_vk16s1vz | M
Naz.b.S10 | Název buňky S10 | VKTEMRAD_vk16s1nb | C(40)
S20 | Typ výpočtu ve sloupci 2 | Výpočet | C(7)
Formát | Identifikace formátu buňky | VKTEMRAD_vk16s2fr | C(6)
P21 | Parametr 1 | VKTEMRAD_vk16s2p1 | M
P22 | Parametr 2 | VKTEMRAD_vk16s2p2 | M
P23 | Parametr 3 | VKTEMRAD_vk16s2p3 | M
P24 | Parametr 4 | VKTEMRAD_vk16s2p4 | M
P25 | Parametr 5 | VKTEMRAD_vk16s2p5 | M
Výraz | Výraz | VKTEMRAD_vk16s2vr | M
Vzorec | Vzorec | VKTEMRAD_vk16s2vz | M
Naz.b.S20 | Název buňky S20 | VKTEMRAD_vk16s2nb | C(40)
S30 | Typ výpočtu ve sloupci 3 | Výpočet | C(7)
Formát | Identifikace formátu buňky | VKTEMRAD_vk16s3fr | C(6)
P31 | Parametr 1 | VKTEMRAD_vk16s3p1 | M
P32 | Parametr 2 | VKTEMRAD_vk16s3p2 | M
P33 | Parametr 3 | VKTEMRAD_vk16s3p3 | M
P34 | Parametr 4 | VKTEMRAD_vk16s3p4 | M
P35 | Parametr 5 | VKTEMRAD_vk16s3p5 | M
Výraz | Výraz | VKTEMRAD_vk16s3vr | M
Vzorec | Vzorec | VKTEMRAD_vk16s3vz | M
Naz.b.S30 | Název buňky S30 | VKTEMRAD_vk16s3nb | C(40)
Řádek | Identifikace řádku | Výpočet | C(9)
Formát | Identifikace formátu buňky | VKTEMRAD_vk12id | C(6)
S40 | Typ výpočtu ve sloupci 4 | Výpočet | C(7)
Formát | Identifikace formátu buňky | VKTEMRAD_vk16s4fr | C(6)
P41 | Parametr 1 | VKTEMRAD_vk16s4p1 | M
P42 | Parametr 2 | VKTEMRAD_vk16s4p2 | M
P43 | Parametr 3 | VKTEMRAD_vk16s4p3 | M
P44 | Parametr 4 | VKTEMRAD_vk16s4p4 | M
P45 | Parametr 5 | VKTEMRAD_vk16s4p5 | M
Výraz | Výraz | VKTEMRAD_vk16s4vr | M
Vzorec | Vzorec | VKTEMRAD_vk16s4vz | M
Naz.b.S40 | Název buňky S40 | VKTEMRAD_vk16s4nb | C(40)
S50 | Typ výpočtu ve sloupci 5 | Výpočet | C(7)
Formát | Identifikace formátu buňky | VKTEMRAD_vk16s5fr | C(6)
P51 | Parametr 1 | VKTEMRAD_vk16s5p1 | M
P52 | Parametr 2 | VKTEMRAD_vk16s5p2 | M
P53 | Parametr 3 | VKTEMRAD_vk16s5p3 | M
P54 | Parametr 4 | VKTEMRAD_vk16s5p4 | M
P55 | Parametr 5 | VKTEMRAD_vk16s5p5 | M
Výraz | Výraz | VKTEMRAD_vk16s5vr | M
Vzorec | Vzorec | VKTEMRAD_vk16s5vz | M
Naz.b.S50 | Název buňky S50 | VKTEMRAD_vk16s5nb | C(40)
S60 | Typ výpočtu ve sloupci 6 | Výpočet | C(7)
Formát | Identifikace formátu buňky | VKTEMRAD_vk16s6fr | C(6)
P61 | Parametr 1 | VKTEMRAD_vk16s6p1 | M
P62 | Parametr 2 | VKTEMRAD_vk16s6p2 | M
P63 | Parametr 3 | VKTEMRAD_vk16s6p3 | M
P64 | Parametr 4 | VKTEMRAD_vk16s6p4 | M
P65 | Parametr 5 | VKTEMRAD_vk16s6p5 | M
Výraz | Výraz | VKTEMRAD_vk16s6vr | M
Vzorec | Vzorec | VKTEMRAD_vk16s6vz | M
Naz.b.S60 | Název buňky S60 | VKTEMRAD_vk16s6nb | C(40)
S70 | Typ výpočtu ve sloupci 7 | Výpočet | C(7)
Formát | Identifikace formátu buňky | VKTEMRAD_vk16s7fr | C(6)
P71 | Parametr 1 | VKTEMRAD_vk16s7p1 | M
P72 | Parametr 2 | VKTEMRAD_vk16s7p2 | M
P73 | Parametr 3 | VKTEMRAD_vk16s7p3 | M
P74 | Parametr 4 | VKTEMRAD_vk16s7p4 | M
P75 | Parametr 5 | VKTEMRAD_vk16s7p5 | M
Výraz | Výraz | VKTEMRAD_vk16s7vr | M
Vzorec | Vzorec | VKTEMRAD_vk16s7vz | M
S70 | Název buňky S70 | VKTEMRAD_vk16s7nb | C(40)
S80 | Typ výpočtu ve sloupci 8 | Výpočet | C(7)
Formát | Identifikace formátu buňky | VKTEMRAD_vk16s8fr | C(6)
P81 | Parametr 1 | VKTEMRAD_vk16s8p1 | M
P82 | Parametr 2 | VKTEMRAD_vk16s8p2 | M
P83 | Parametr 3 | VKTEMRAD_vk16s8p3 | M
P84 | Parametr 4 | VKTEMRAD_vk16s8p4 | M
P85 | Parametr 5 | VKTEMRAD_vk16s8p5 | M
Výraz | Výraz | VKTEMRAD_vk16s8vr | M
Vzorec | Vzorec | VKTEMRAD_vk16s8vz | M
S80 | Název buňky S80 | VKTEMRAD_vk16s8nb | C(40)
S90 | Typ výpočtu ve sloupci 9 | Výpočet | C(7)
Formát | Identifikace formátu buňky | VKTEMRAD_vk16s9fr | C(6)
P91 | Parametr 1 | VKTEMRAD_vk16s9p1 | M
P92 | Parametr 2 | VKTEMRAD_vk16s9p2 | M
P93 | Parametr 3 | VKTEMRAD_vk16s9p3 | M
P94 | Parametr 4 | VKTEMRAD_vk16s9p4 | M
P95 | Parametr 5 | VKTEMRAD_vk16s9p5 | M
Výraz | Výraz | VKTEMRAD_vk16s9vr | M
Vzorec | Vzorec | VKTEMRAD_vk16s9vz | M
S90 | Název buňky S90 | VKTEMRAD_vk16s9nb | C(40)
Název listu | Název listu | VKLIST3_vk03nazev | C(40)
Sloupec 40 | Nadpis 4.sloupce | VKLIST3_vk03s4naz | M
Param. | Parametry listu | VKLIST3_vk03param | M
List | Identifikace listu | VKLIST3_vk03id | C(6)
Vzor | Identifikace vzoru listu | VKLIST3_vk14id | C(6)
Pozn. | Poznámka | VKLIST3_vk03koment | M
Šablona | Identifikace šablony listu dokumentu | VKLIST3_vk13id | C(6)
Formát | Identifikace formátu buňky | VKLIST3_vk12id | C(6)
Sloupec 10 | Nadpis 1.sloupce | VKLIST3_vk03s1naz | M
Sloupec 20 | Nadpis 2.sloupce | VKLIST3_vk03s2naz | M
Sloupec 30 | Nadpis 3.sloupce | VKLIST3_vk03s3naz | M
Sloupec 50 | Nadpis 5.sloupce | VKLIST3_vk03s5naz | M
Sloupec 60 | Nadpis 6.sloupce | VKLIST3_vk03s6naz | M
Šířka | Šířka 1.sloupce | VKLIST3_vk03s1sir | N(3)
Šířka | Šířka 2.sloupce | VKLIST3_vk03s2sir | N(3)
Šířka | Šířka 3.sloupce | VKLIST3_vk03s3sir | N(3)
Šířka | Šířka 4.sloupce | VKLIST3_vk03s4sir | N(3)
Šířka | Šířka 5.sloupce | VKLIST3_vk03s5sir | N(3)
Šířka | Šířka 6.sloupce | VKLIST3_vk03s6sir | N(3)
Nadpis listu | Nadpis listu | VKLIST3_vk03nadpis | M
Záložka listu | Záložka listu | VKLIST3_vk03zaloz | M
Formát | Identifikace formátu buňky | VKLIST3_vk12id1 | C(6)
Formát | Identifikace formátu buňky | VKLIST3_vk12id2 | C(6)
Formát | Identifikace formátu buňky | VKLIST3_vk12id3 | C(6)
Formát | Identifikace formátu buňky | VKLIST3_vk12id4 | C(6)
Formát | Identifikace formátu buňky | VKLIST3_vk12id5 | C(6)
Formát | Identifikace formátu buňky | VKLIST3_vk12id6 | C(6)
1.sloupec vzoru | Zobrazovat 1.sloupec vzoru | Výpočet | C(3)
2.sloupec vzoru | Zobrazovat 2.sloupec vzoru | Výpočet | C(3)
3.sloupec vzoru | Zobrazovat 3.sloupec vzoru | Výpočet | C(3)
Název šablony | Název šablony | VKSABLON_vk13nazev | C(40)
Soubor šablony | Soubor šablony | VKSABLON_vk13soubor | M
Název vzoru | Název vzoru listu | VKVZOR2_vk14nazev | C(40)

    Viz.také

    Kopie řádku


Kopie listu výkazu

Popis

Tato činnost se aktivuje z menu Volby v činnosti Listy výkazu. Při vytváření kopie uživatel zadává identifikaci a název nového listu.

Formulář

Formulář činnosti - Kopie řádku
Nový list | Identifikace listu
Název listu | Název listu


Kopie řádku

Popis

Tato činnost se aktivuje po stisku klávesy F5 v činnosti Definice listů podle vzoru. Po stisku klávesy F5 se automaticky nakopíruje další řádek (kopie se provádí z aktuálního řádku, tj. řádek na kterém je umístěn kurzor).


Paleta zobrazení v harmonogramu

Popis

V této činnosti si uživatel nadefinuje barevnou paletu, která určuje, jak se mu pak políčka v harmonogramu budou barevně zobrazovat. Zadává se:

¨ paleta – identifikace a název

¨ návěští Y – výraz v jazyce FoxPro pro zobrazení návěští na ose Y v harmonogramu (např. Trim(tp13id)+', '+Transform(tp23datum))

¨ šířka sloupce – šířka sloupce návěští na ose Y v pixelech

¨ tooltip Y – výraz v jazyce FoxPro pro zobrazení tooltipu na ose Y v harmonogramu (např. Trim(tp13id)+', '+Transform(dt_from)+' '+Transform(dt_to))

¨ návěští události – výraz v jazyce FoxPro pro zobrazení návěští události v harmonogramu (např. trim(sp60id)+' '+tp05operac)

¨ citlivost – citlivost napojení následující události harmonogramu za předcházející událost v minutách

¨ tooltip události – výraz v jazyce FoxPro pro zobrazení tooltipu události v harmonogramu (např. 'Linka - '+Trim(tp13id)+', '+Transform(vr09datum)+'-'+Transform(vr09datum+vr09trvani*3600)+Chr(13)+TRIM(ad01adsat)+Chr(13)+TRIM(tp05operac))

¨ barva události – výraz v jazyce FoxPro pro určení barvy události v diagramu

Datový model

  • VKHARDEF Paleta zobrazování popisek harmonogramu

    • Formulář

    Formulář činnosti - Knihovny vkládaného kódu
Mřížka [Paleta]
Paleta | Identifikace palety zobrazení v harmonogramu
Název palety | Název palety zobrazení v harmonogramu
Šířka sloupce | Šířka sloupce návěští na ose Y v pixelech
Návěští Y | Výraz v jazyce Foxpro pro zobrazení návěští na ose Y v harmonogramu
Tooltip Y | Výraz v jazyce Foxpro pro zobrazení tooltipu na ose Y v harmonogramu
Citlivost | Citlivost napojení následující události harmonogramu za předcházející událost v minutách
Návěští události | Výraz v jazyce Foxpro pro zobrazení návěští události v harmonogramu
Tooltip události | Výraz v jazyce Foxpro pro zobrazení tooltipu události v harmonogramu
Barva události | Výraz v jazyce Foxpro pro určení barvy události v diagramu
Kód dvojího kliku | Kód v jazyce Foxpro spuštěný při dvojím kliku na události (Lparameters _thisform,_thisform_harm,_this)
Poznámka | Poznámka
Aktualizace | Datum aktualizace

    Mřížka [Paleta] činnosti - Knihovny vkládaného kódu

    Mřížka [Paleta] činnosti - Knihovny vkládaného kódu
Paleta | Identifikace palety zobrazení v harmonogramu
Název palety | Název palety zobrazení v harmonogramu

    Vyvolávané činnosti

    K. | Činnost | Popis
F6 | Knihovny vkládaného kódu | Knihovny vkládaného kódu pro doplnění vlastností činností

    Atributy tisku

    Základní údaje
Paleta | Identifikace palety zobrazení v harmonogramu | VKHARDEF_vk18id | C(6)
Název palety | Název palety zobrazení v harmonogramu | VKHARDEF_vk18nazdef | C(40)
Šířka sloupce | Šířka sloupce návěští na ose Y v pixelech | VKHARDEF_vk18ywidth | N(3)
Návěští Y | Výraz v jazyce Foxpro pro zobrazení návěští na ose Y v harmonogramu | VKHARDEF_vk18ylabel | M
Tooltip Y | Výraz v jazyce Foxpro pro zobrazení tooltipu na ose Y v harmonogramu | VKHARDEF_vk18ytoolt | M
Citlivost | Citlivost napojení následující události harmonogramu za předcházející událost v minutách | VKHARDEF_vk18usensi | N(2)
Návěští události | Výraz v jazyce Foxpro pro zobrazení návěští události v harmonogramu | VKHARDEF_vk18ulabel | M
Tooltip události | Výraz v jazyce Foxpro pro zobrazení tooltipu události v harmonogramu | VKHARDEF_vk18utoolt | M
Barva události | Výraz v jazyce Foxpro pro určení barvy události v diagramu | VKHARDEF_vk18ucolor | M
Kód dvojího kliku | Kód v jazyce Foxpro spuštěný při dvojím kliku na události (Lparameters _thisform,_thisform_harm,_this) | VKHARDEF_vk18udblcl | M
Poznámka | Poznámka | VKHARDEF_vk18koment | M
Aktualizace | Datum aktualizace | VKHARDEF_sp00datakt | T

    Viz.také

    Knihovny vkládaného kódu


Soubor šablony

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Parametry výpočtu vymáhání

Popis

Na základě nastavených algoritmů a postupů vymáhání se pak procesně vytvářejí události vymáhání. Aktivuje se proces vymáhání, kde si pomocí funkční klávesy F6 uživatel vybere události plateb, kterých se vymáhání bude týkat. Tyto události označí (tj. zaškrtá) a pomocí klávesy ESC přenese zpět do událostí vymáhání. Zde nejprve vyplní parametry výpočtu vymáhání:

¨ datum, ke kterému se budou události (nebo událost) vymáhat – předplňuje se dnešní datum

¨ úkon – může nabývat hodnot - upomínka

- penále

- podle dat (dnů)

- podle dat (textů)

- chování jednotlivých hodnot závisí na nastavených algoritmech vymáhání.

¨ nepřenášet do částky včetně – určení min. částky, která se nebude vymáhat (např. pokud by vypočtené penále vycházelo méně než 50,- Kč, tak se nemá vymáhat)

¨ text – identifikace textu, který se má s daným úkonem vytisknout (např. text první upomínky)

Formulář

Formulář činnosti - Události změny stavu peněz
Datum, ke kterému vymáhám | Datum události vymáhání pohledávky
Úkon | Upomínka nebo penále
Nepřenášet do částky včetně | Nepřenášet do částky včetně
Text | Identifikace textu


SUMY - vymáhání

Popis

Tato činnost se aktivuje po stisku klávesy Ctrl S nebo spuštěním činnosti „SUMY – vymáhání“ z menu Volby v činnosti Události vymáhání. Uživateli se zobrazuje celková suma (částka v ZM) událostí vymáhání, které má načteny (zobrazení událostí vymáhání závisí na nastaveném filtru na záložce Výběr).

Formulář

Formulář činnosti - Události změny stavu peněz
Částka v ZM Částka v zahraniční měně


Rozpočet množství

Popis

Rozpočet artiklu se provádí po stisku klávesy F9 nebo volbou činnosti „rozpočet množství“ z menu Volby v činnosti „přehled nerozpočteného“. Po aktivaci této činnosti je uživatel vyzván k zadání skutečně spotřebovaného množství daného artiklu a následně provede rozpočet.

Můžeme si uvést tuto situaci na příkladu: výrobní podnik má 3 zakázky na výrobu montovaných stolků. Tyto stolky je nutno nalakovat. Na každý stolek je určena normovaná spotřeba laku. Nicméně po realizaci těchto tří zakázek se spočítá skutečná spotřeba laku a ta se následně rozpočítá (váženým průměrem) ke každé ze tří zakázek (normovaná spotřeba první zakázky je 2kg, druhé zakázky 5kg a třetí zakázky 10kg, což je celkem 17kg. Po realizaci těchto zakázek bylo ale zjištěno, že skutečně se spotřebovalo 34kg laku. Po provedení rozpočtu je u první zakázky uvedeno 4kg laku, u druhé zakázky 10kg a u třetí zakázky 20kg laku.

Formulář

Formulář činnosti - Přístupová práva
Množství Množství


Předplnění vstupů a výstupů

Popis

Předplní vstupy a výstupy podle nadefinování v TPV. Funkce se používá ve formuláři 'Výrobní úkoly' pro naplnění vstupů a výstupů výrobního úkolu na záložce 'Vstupy a výstupy'. Tato funkce předplňuje identifikaci stroje v záznamu od vstupu/výstupu.


Generování úkolů zakázky

Popis

Tato činnost je pro uživatele dostupná po stisku klávesy F7 nebo pod menu Volby v činnosti „zakázky výroby“. Realizací této činnosti se automaticky naplní údaje činnosti „výrobní úkoly“ a „vstupy a výstupy výrobních úkolů“. Po aktivaci této činnosti na vybrané zakázce výroby se uživateli zobrazí formulář „generování úkolů zakázky“, kde jsou následující údaje:

¨ výroba č., datum, fáze, artikl, množství a požadavek – tyto údaje jsou předplněny z definice zakázky výroby

¨ výpočet normy – při zaškrtnutí tohoto atributu budou vygenerované výrobní úkoly označeny jako normované. Normované výrobní úkoly, resp. vstupy a výstupy, slouží pro možné porovnání „kusovníku“ s plánovanými, očekávanými a realizovanými výrobními úkoly (vstupy a výstupy).

¨ technologický postup – výběr z překryvného seznamu – k dispozici jsou všechny technologické postupy, které mají jako pilotní artikl právě artikl uvedený na výrobní zakázce

¨ datum – požadované datum dokončení výroby. Předplňuje se datum z atributu datum ukončení výroby na zakázce výroby.

¨ množství – požadované množství artiklu v referenční měrné jednotce. Předplňuje se množství ze zakázky výroby.

¨ předplňovat hodnoty vstupů – volba Ano/Ne – pokud uživatel zvolí „Ne“, nejsou k vygenerovaným výrobním úkolům vygenerovány vstupy a výstupy

¨ min. ve směně – tento atribut definuje minimální naplánovanou délku času (v hod) v rozdělené směně (tato hodnota se neuplatní, pokud je čas na provedení výrobního úkolu menší než tato hodnota, ale vejde se do jedné směny). Tuto hodnotu lze definovat v parametrech TPV.

Po zadání (klávesou disketa) této činnosti se uživateli zobrazí formulář určení linek výrobních operací.

Formulář

Formulář činnosti - Přístupová práva
Výroba č. | Číslo výroby.
Datum | Datum výroby od data.
Datum ukončení | Datum ukončení výroby.
Fáze | Fáze výroby.
Výpočet normy | Výpočet normy
Popis | Popis výrobní zakázky
 | Identifikace druhu artiklu
Artikl | Identifikace artiklu
Název artiklu | Název artiklu
Množství | Množství v uvedené jednotce
MJ | Identifikátor měrné jednotky
Mn. ref. | Množství v referenční měrné jednotce
 | Identifikátor měrné jednotky
Požadavek | Množství v referenční měrné jednotce - požadavek na výrobu
Tech.p. | Identifikace technologického postupu
Datum | Datum
Množství | Množství
Předplňovat hodnoty vstupů | Předplňovat hodnoty vstupů a výstupů ke vzniklým úkolům ?
Min. ve směně | Minimální čas v rozdělené směně


Zapsat změny harmonogramu

Popis

Po aktivaci harmonogramu a provedení posunu úkolů je nutno tyto změny zapsat, tzn. zaznamenat do harmonogramu. To se provede klávesou F5 a poté se systém dotazuje: „Harmonogram obsahuje (x) změn nezapsaných v datech. Zapsat změny do dat?“ (volba Ano/Ne/Storno). Stejný dotaz se uživateli zobrazí i po provedení posunu úkolů a opuštění činnosti harmonogram stiskem klávesy ESC.


Harmonogram - posun úkolů

Popis

Tuto činnost uživatel aktivuje přímo z činnosti harmonogram výroby. Metodou „táhni a drž“ přesouvá jednotlivé buňky harmonogramu na nové, vybrané místo (např. může se vyskytnout situace, že je nutno kvůli výrobní kapacitě úkol na lince, který se provádí ve 3.směně přesunout na 1.směnu dalšího dne apod.). Po přetažení se uživateli zobrazí tabulka s informacemi o výrobním úkolu, lince, operaci, artiklu, původním datu a novém datu, na které se výrobní úkol přesouvá. V případě, že na jedné buňce v jednom čase je soustředěno více výrobních úkolů může uživatel využít volby, kterou mu poskytují tlačítka „přesun“ a „přesun jednoho“. Tlačítko „přesun“ přesune všechny dané výrobní úkoly, tlačítko „přesun jednoho“ přesune pouze aktuální výrobní úkol (tzn. ten, na kterém je umístěn kurzor).

Formulář

Formulář činnosti - TP k datu rozpracované na KJ
Mřížka [Harmonogram - posun úkolů]
VČ | Číslo výroby.
 | Skupina výrobních úkolů
 | Pořadové číslo úkolu v rámci výrobní zakázky
Fáze | Fáze výroby.
Adresát | Identifikace adresáta
 | Název adresáta
Číslo linky | Číslo výrobní linky, resp. stroje
Operace | Identifikace technologické operace
Druh | Identifikace druhu artiklu
Artikl | Identifikace artiklu
S. | Číslo směny
Datum | Datum
Trvání (hod) | Délka trvání výrobního úkolu
S. | Nové číslo směny
Nové | Nové datum
Tlačítko - Přesun | Přesun všech zobrazených
Tlačítko - Přesun jednoho | Přesun jednoho

Mřížka [Harmonogram - posun úkolů] činnosti - TP k datu rozpracované na KJ

Mřížka [Harmonogram - posun úkolů] činnosti - TP k datu rozpracované na KJ
Fáze | Fáze výroby.
Výroba č. | Číslo výroby.
Skup. | Skupina výrobních úkolů
Poř.č. | Pořadové číslo úkolu v rámci výrobní zakázky
Číslo linky | Číslo výrobní linky, resp. stroje
Operace | Identifikace technologické operace
S. | Číslo směny
Datum | Datum
Trvání (hod) | Délka trvání výrobního úkolu
S. | Nové číslo směny
Nové | Nové datum


Sloučit výrobní úkoly

Popis

Před vlastní aktivací činnosti „sloučit výrobní úkoly“ musí uživatel provést jejich označení (tato činnost je dostupná pod menu Volby v činnosti Harmonogram výroby. Po její aktivaci systém provede automatické označení výrobních úkolů ke sloučení a takto označené záznamy předplní uživateli do tabulky „slučování výrobních úkolů“).

Po spuštění činnosti se uživateli zobrazí formulář „slučování výrobních úkolů“, kde může ještě rozhodnout, zda chce slučovat i úkoly z různých směn. Po potvrzení volby OK systém zobrazí informaci jakým způsobem budou úkoly sloučeny a uživatel tuto informaci potvrdí stiskem klávesy Ano.


Označit výr.úkoly ke sloučení

Popis

Tato činnost je dostupná pod menu Volby v činnosti Harmonogram výroby. Po její aktivaci systém provede automatické označení výrobních úkolů ke sloučení a takto označené záznamy předplní uživateli do tabulky „slučování výrobních úkolů“. Systém automaticky vybírá úkoly stejné skupiny výrobního úkolu, které na sebe v čase navazují. Vlastní sloučení pak uživatel aktivuje činností „sloučit výrobní úkoly“ pod menu Volby.


Přidělit všechny linky ke kalendáři

Popis

Na záložce „Přidělené linky“ se definuje, pro které linky a v kterém období je kalendář platný. Lze použít funkci z menu Volby („přidělit všechny linky ke kalendáři“), která nadefinuje všechny linky na „nekonečné“ období. V případě, že se jedná o všeobecný kalendář, je sem automaticky zařazena každá nově založená linka. V případě, že se jedná o kalendář výjimek (shodné identifikátory), není linka na záložce uváděna (platí implicitně).


Zrušit zobrazené dny kalendáře

Popis

Na záložce „Dny kalendáře“ se definují elementy kalendáře – jeho směny. K předplnění směn lze užít funkci, která je následně automaticky vygeneruje (menu Volby, činnost „předplnit směny“). V případě potřeby je k dispozici i funkce pro zrušení všech vybraných (na záložce dostupných) směn (menu Volby, činnost „zrušit zobrazené dny kalendáře“).


Kontrolovat strukturu kalendářů

Popis

Tuto činnost má uživatel k dispozici v menu Volby v činnosti Kalendáře směn výroby. Provede kontrolu struktury kalendářů a pokud systém nenajde žádnou nesrovnalost, oznámí, že kontrola proběhla OK. V případě, že najde nesrovnalost, zobrazí uživateli příslušnou chybovou hlášku.


Nastavení příznaku rozpočteného množství

Popis

Nástroj umožňující uživateli přiřadit artiklu příznak rozpočteno bez toho, že by musel aktivovat funkci „rozpočet množství“ v činnosti „přehled nerozpočteného“. Uživatel tohoto využije zejména v případě, kdy normovaná spotřeba odpovídá skutečné spotřebě materiálu a tudíž není nutné žádný rozpočet provádět, nicméně je nutné danému materiálu nastavit příznak, že množství bylo rozpočteno.


Přidělit pracovníka výkonu úkolu

Popis

Tato činnost je pro uživatele dostupná v menu Volby nebo po stisku klávesy Ctrl P v činnosti „Výrobní úkoly“ za těchto podmínek:

¨ uživatel musí mít aktivní operaci výrobního úkolu

¨ kurzor musí být umístěn na záložce vstupy a výstupy

¨ artikl uvedený na výrobním úkolu musí mít na kartě v atributu „čas“ uvedenu hodnotu Ano

Po aktivaci této činnosti se uživateli zobrazí formulář s údaji, kde je už z návěští atributů zřejmé, co má uživatel zadávat.


Rozpočet množství - označených

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


Komunikace nad záznamem

Popis

Tuto činnost může uživatel vyvolat stiskem klávesy "Ctrl U" z vybrané události na kompletní vývěsce. Poskytne mu informaci o tom, jakým způsobem se dále komunikovalo nad danou událostí vývěsky, tzn. komu autor události poslal zprávu k události, kdy ji příjemce přijal, zpracoval a popřípadě, jestli ji znovu poslal zpět odesílateli. Tato komunikace poskytuje uživateli pouze jména a data vztahující se k dané události. Náplň zprávy, kterou autor posílal vybranému pracovníkovi není v této činnosti dostupná.

Datový model

  • BWOBJECT Vazba objektů (alias BWOBJECT2)
    • PZZPRAVY Zpráva
      • BWUZIVAT Uživatel systému (alias BWUZIVA3)
      • BWUZIVAT Uživatel systému (alias BWUZIVA4)

    • Formulář

    Formulář činnosti - Návrat k předchozí
    Mřížka [Zprávy]

    Mřížka [Zprávy] činnosti - Návrat k předchozí

    Mřížka [Zprávy] činnosti - Návrat k předchozí
S | Stav zpracování zprávy
Autor | Jméno uživatele systému
Příjemce | Jméno uživatele systému
Signalizace | Datum signalizace
Přijetí | Datum přijetí zprávy.
Zpracování | Datum zpracování zprávy.


Vývěska adresáta

Popis

Zobrazí se události vývěsky vztahující se k adresátovi, který je uveden na právě "aktivní" události.


Vývěska tématu

Popis

Zobrazí se události vývěsky vztahující se k tématu, který je uveden na právě "aktivní" události.


VÝVĚSKY

Popis

Tato činnost v sobě sdružuje následující možnosti:

· vývěska adresáta

· vývěska tématu

· vývěska otců

· vývěska synů

· návrat k předchozí

Viz.také

Vývěska adresáta | Vývěska tématu | Vývěska otců | Vývěska synů | Návrat k předchozí


Návrat k předchozí

Popis

Tato činnost umožňuje uživateli návrat k předchozí vývěsce, ze které původně vycházel. Např. uživatel je na kompletní vývěsce, vyvolá si vývěsku adresáta a po jejím prohlédnutí se potřebuje znovu vrátit na kompletní vývěsku. Pomocí této činnosti pak provede potřebný návrat.


Vlastnosti uzlu vývěsky

Popis

Uživateli se zobrazuje přehled vlastností daného uzlu. Kromě vlastností převzatých přímo z události (ze které se vytvářel uzel vývěsky) má uživatel možnost zadat i jméno grafického souboru pro ikonu.

Datový model

  • VYOZNAC Uzel vývěsky
    • VYUDALOS Událost vývěsky
      • SPTYP Druh procesu/operace
      • BWUZIVAT Uživatel systému

    • Formulář

    Formulář činnosti - Vyhledat soubor
Ikona | Ikona pro uzel vývěsky
Text | Text výstižně popisující událost.
Název tématu | Název druhu
Dne | Datum pořízení události.
Zapsal | Jméno uživatele systému

    Vyvolávané činnosti

    K. | Činnost | Popis
F2 | Vyhledat soubor | Vyhledání souboru

    Viz.také

    Vyhledat soubor


Vývěska otců

Popis

Uživateli se zobrazují veškeré události, které mají definovánu vazbu "otec" k právě "aktivní" události.


Vývěska synů

Popis

Uživateli se zobrazují veškeré události, které mají definovánu vazbu "syn" k dané události.


Štítek adresáta

Popis

Jedná se o rychlý pohled na kompletní adresu adresáta, který se vztahuje k dané události.

Datový model

  • ADADSAT Adresát
    • ADSPOJ Spojení adresáta (alias ADSPOJI)
      • ADADR Adresa (alias ADADRI)
        • ADSTATY Stát
      • ADTYPSPO Typ spojení

    • Formulář

    Formulář činnosti - Návrat k předchozí
 | Název adresáta
 | Identifikační číslo organizace.
 | Identifikace typu spojení
 | Název typu spojení
 | Směrové číslo státu pro telefonní spojení.
 | Spojení
 | Jméno kontaktní osoby.
 | Ulice adresy adresáta (včetně čísla popisného).
 | Poštovní směrovací číslo adresy adresáta.
 | Město adresy adresáta.
 | Název státu.


Strom vývěsky

Popis

Tuto činnost uživatel aktivuje po stisku F5 nebo spuštěním činnosti „strom vývěsky“ z menu Volby v činnosti Kompletní vývěska. Jedná se v podstatě o obdobný princip vyjádření událostí jako je ve stromu hlavního procesu. Je vidět základní událost, ze které byl strom spuštěn a k ní předcházející a navazující události vývěsky.

Formulář

Formulář činnosti - Návrat k předchozí
Strom vývěsky

© 1996-2016 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena


SUMy - Přehled záloh

Popis

Tuto činnost si uživatel aktivuje v činnosti Přehled záloh (po stisku klávesy Ctrl S nebo spuštěním činnosti SUMY – přehled záloh pod menu Volby). Podle zobrazených údajů (ty je možno vyfiltrovat nastavením záložky Výběr v činnosti Přehled záloh) má uživatel k dispozici tabulku, kde je údaj o hodnotě částky v měně účtu a hodnotě zbývá vyúčtovat u přijaté a poskytnuté zálohy.

Formulář

Formulář činnosti - Události změny stavu peněz
Částka v MÚ | Částka v měně úhrady zálohy
Přijatá záloha | Částka v měně úhrady zálohy poskytnuté
Zbývá vyúčtovat | Dosud nevyúčtovaná část zálohy
Poskytnutá záloha | Dosud nevyúčtovaná část zálohy poskytnuté


SUMy - zálohy

Popis

Tuto činnost uživatel aktivuje po stisku klávesy Ctrl S nebo spuštěním činnosti „SUMY – zálohy“ pod menu Volby v činnosti Události o zálohách. Podle nastaveného filtru na záložce Výběr v Událostech zde má uživatel údaje rozčleněné do čtyř sloupců (přijaté a poskytnuté úhrady a vyúčtování) z několika hledisek (částka v ZM, částka v RM, vyčíslený kurzový rozdíl, částka v měně účtu a zbývá vyúčtovat).

Formulář

Formulář činnosti - Události změny stavu peněz
Částka v ZM | Částka v zahraniční měně
Úhrada - přijaté | Částka v zahraniční měně - vyúčtování
Vyúčt. - přijaté | Částka v zahraniční měně - přijatá
 | Částka v zahraniční měně - poskytnutá
Částka v RM | Částka v referenční měně
 | Částka v referenční měně - vyúčtování
 | Částka v referenční měně - přijatá
 | Částka v referenční měně - poskytnutá
Kurzový rozdíl | Kurzový rozdíl
 | Kurzový rozdíl - vyúčtování
 | Kurzový rozdíl - přijatá
 | Kurzový rozdíl - poskytnutá
Částka v MÚ | Částka v měně úhrady zálohy
Úhrada - posk. | Částka v měně úhrady zálohy poskytnuté
 | Částka v měně úhrady zálohy - vyúčtování
 | Částka v měně úhrady zálohy - přijatá
Zbývá vyúčtovat | Dosud nevyúčtovaná část zálohy
Vyúčt. - posk. | Dosud nevyúčtovaná část zálohy poskytnuté
 | Dosud nevyúčtovaná část zálohy - vyúčtování
 | Dosud nevyúčtovaná část zálohy - přijatá


INFORMACE O ZÁLOHÁCH

Popis

Tato činnost představuje skupinové menu pod menu Volby v činnosti Události o zálohách. Při umístění kurzoru na název této činnosti se uživateli nabízejí tři možnosti:

¨ přehled záloh

¨ události o zálohách

¨ události DPH

Jedná se o soustředění veškerých možných údajů k dané aktivní (tj. ta, na které je umístěn kurzor) záloze pod jedno menu, tzn. uživatel má informace tzv. „pěkně pohromadě“.

Viz.také

Přehled záloh | Události o zálohách | Události DPH


Parametry operací ZAL

Popis

Druhy operací, pomocí kterých uživatel na konci roku provádí přecenění zálohy v cizí měně, musí mít označen (tj. zaškrtnutý) příznak „operace pro určení kurzového rozdílu zálohy“.

Datový model

  • ZAPAROPE Parametry operace komponenty ZAL

    • Formulář

    Formulář činnosti - Události změny stavu peněz
Operace pro určení kurzového rozdílu zálohy | Operace pro určení kurzového rozdílu zálohy
Poznámka | Poznámka


Párování na platby

Popis

Činnost Párování na platby slouží jako parametry pro párování plateb. Lze zde vybrat, zda chceme párovat dle variabilního symbolu, čísla účtu nebo dle částky. Také lze rozhodnout, zda se budou aktualizovat všechny zobrazené řádky výpisu.

Formulář

Formulář činnosti - Konv. listu do nových výkazů
Dle variabilního symbolu | Párování dle variabilního symbolu
Dle čísla účtu | Párování dle čísla účtu
Párování dle částky | Párování dle částky
Aktualizovat všechny | Aktualizovat všechny zobrazené řádky výpisu


Přehled spárování

Popis

Činnost Přehled spárování slouží k zobrazení přehledu spárovaných událostí plateb a změny stavu peněz.

Datový model

  • ZPUDA Událost změny stavu peněz - výpisy a příkazy
    • SPPRCOD Operace procesu (alias SPPRCOD2)

    • Formulář

    Formulář činnosti - Spustit operaci
Mřížka [Vazba výpis úhrada]
Listovací rámeček
Stránka #1 Položky výpisu
Stránka #2 Uhrazované platby
Mřížka [Vazba výpis platba]
 | Kód měny - oceňovací jednotky.
 | Kód měny - oceňovací jednotky.
Částka k úhradě | Hodnota částky z výpisu uhrazující platbu v zahraniční měně úhrady
Částka v ZM platby | Hodnota částky z výpisu uhrazující platbu v zahraniční měně platby

    Mřížka [Vazba výpis úhrada] činnosti - Spustit operaci

    Mřížka [Vazba výpis úhrada] činnosti - Spustit operaci
Označování | Označení záznamu
Datum | Datum výpisu z banky/příkazu k úhradě
CR/DB | Příjem/Výdej = Credit/Debet
VS (příjemce) | Variabilní symbol (příjemce)
Měna | Kód měny - oceňovací jednotky.
Částka v ZM | Částka k úhradě/inkasu v ZM
Částka v RM | Částka k úhradě/inkasu v RM
Kód banky | Kód banky
Prefix ú. | Prefix bankovního účtu adresáta
Č. účtu | Číslo bankovního účtu adresáta.
Kurs | Kurs oceňovací jednotky vůči referenční oceňovací jednotce - nákup.
Měna účtu | Kód měny - oceňovací jednotky.
Částka v MÚ | Částka v měně bankovního účtu / pokladny
VS (plátce) | Variabilní symbol (plátce)
Spárováno | Částka byla spárovaná s platbami

    Mřížka [Vazba výpis platba] činnosti - Spustit operaci

    Mřížka [Vazba výpis platba] činnosti - Spustit operaci
Splatnost | Datum splatnosti
P/Z | Pohledávka/Závazek
VS | Variabilní symbol (příjemce)
Měna | Kód měny - oceňovací jednotky.
Částka v ZM | Částka v zahraniční měně
Částka v RM | Částka v referenční měně zaokrouhlená
Dosud uhrazeno | Dosud uhrazeno (v referenční měně)
Rok | Rok v identifikaci procesu
IDÚ | Identifikace datového úložiště číselné řady procesu
Proces | Pořadové číslo procesu
Druh | Identifikátor druhu operace
Kód banky | Kód banky
Prefix ú. | Prefix bankovního účtu adresáta
Č. účtu | Číslo bankovního účtu adresáta.
Adresát | Identifikace adresáta
Název adresáta | Název adresáta

    Vyvolávané činnosti

    K. | Činnost | Popis
F5 | Párování plateb | Evidence událostí plateb (přijatých a vydaných)
F6 | Párování na platby |
F9 | Spustit operaci | Spuštění zobrazené operace

    Viz.také

    Události plateb | Párování na platby | Spustit operaci


Kredit a debet

Popis

Činnost Kredit a debet slouží jako přehled o kreditu a debetu konkrétní události změny stavu peněz.

Datový model

  • ZPUDA Událost změny stavu peněz - výpisy a příkazy

    • Formulář

    Formulář činnosti - Spustit operaci
Credit | Suma kreditu
Debet | Suma debetu


Spuštění vstupu

Popis

Činnost Spuštění vstupu umožňuje import dat do systému, dodaných bankou.


Spuštění výstupu

Popis

Činnost spuštění výstupu aktivuje program, který exportuje data do souboru, jehož formát umožní vstup dat do bankovního systému.


SUMy - ZP

Popis

Tato funkce se vyvolává z činnosti Události změny stavu peněz (aktivace příslušné činnosti pod menu Volby nebo po stisku Ctrl S). Podle zobrazených událostí změny stavu peněz (jejich zobrazení ovlivňuje nastavení záložky Výběr) jsou k dispozici celkové sumy hodnot kreditů a debetů za částky v ZM a RM s vyúčtovaným rozdílem.

Formulář

Formulář činnosti - Spustit operaci
Částka v ZM | Částka k úhradě/inkasu v ZM
Částka v RM | Částka k úhradě/inkasu v RM
Kredit | Částka k úhradě/inkasu v ZM - debet
Debet | Částka k úhradě/inkasu v RM - debet
Rozdíl | Částka k úhradě/inkasu v ZM - rozdíl
SUMA | Částka k úhradě/inkasu v RM - rozdíl


Parametry operací ZSP

Popis

Druhy operací, které umožňují uživateli vyúčtovat kurzové rozdíly ke konci roku, musí mít v parametrech označen (tzn. zaškrtnutý) příznak „povolit nulovou částku v ZM“.

Datový model

  • ZPPAROPE Parametry operace komponenty ZSP

    • Formulář

    Formulář činnosti - Spustit operaci
Povolit nulovou částku v ZM | Povolit nulovou částku v ZM
Poznámka | Poznámka


Třída SP60ID_COMBOBOX

Třída | SP60ID_COMBOBOX
Název | SP60ID_COMBOBOX - třída
Knihovna | SYSDIA
Rodičovská třída | SYSDIA_COMBOBOX
Bázová třída | ComboBox
Popis | Slouží ke vstupu artiklu jako překryvného seznamu (ComboBox), kde jednotlivé položky jsou názvy artiklu a hodnota (klíč) je identifikace artiklu.
Atributy třídy objektů
ENTITA_ARTIKLU | Entita artiklu
GETSQL_FROM | Doplňující seznam tabulek pro SQL-dotaz (za FROM)
GETSQL_WHERE | Doplňující výběr pro SQL-dotaz (za WHERE)
CHYBA | Hlášení při nevybrání artiklu
SP61ID | Druh artiklu
Metody třídy objektů
GETSQL | Výběr artiklu
REQUERY | Naplnění seznamu artiklu
VALID | Validace

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 05.02.2014


Atribut SP61ID - Druh artiklu

Atribut | SP61ID
Název | Druh artiklu
Typ | C
Inicializace | ""
Popis | Hodnota vlastnosti Sp61id určuje druh artiklu, pro kerý je artikl vybírán.

Viz.také:

Třída SP60ID_COMBOBOX

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 05.02.2014


Metoda GETSQL - Výběr artiklu

Metoda | GETSQL
Název | Výběr artiklu
Typ | C
Parametry |
Popis | - vrací SQL-dotaz pro výběr artiklu Parametry: - Obsah: Local _sql,_from,_where _from=iif(empty(this.getsql_from) or left(trim(this.getsql_from),1)=',','',',')+this.getsql_from _where=iif(empty(this.getsql_where) or upper(left(trim(this.getsql_where),4))='AND ','',' AND ')+this.getsql_where TEXT TO _sql TEXTMERGE NOSHOW select sp62artikl,art.sp60id from %%%.<> art,%%%.spartikn<<_from>> where art.sp61id=?_p1 and spartikn.sp61id=art.sp61id and spartikn.sp60id=art.sp60id and spartikn.sp38id=?tool.jazyk<<_where>> ENDTEXT Return _sql

Viz.také:

Třída SP60ID_COMBOBOX

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 05.02.2014


Atribut CHYBA - Hlášení při nevybrání artiklu

Atribut | CHYBA
Název | Hlášení při nevybrání artiklu
Typ | C
Inicializace | "Vyberte artik"
Popis | - změněná hodnota třídy SysDia_ComboBox

Viz.také:

Třída SP60ID_COMBOBOX

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 05.02.2014


Atribut ENTITA_ARTIKLU - Entita artiklu

Atribut | ENTITA_ARTIKLU
Název | Entita artiklu
Typ | C
Inicializace | ""
Popis | Hodnota vlastnosti Entita_Artiklu určuje entitu artiklu, pro kerý je artikl vybírán.

Viz.také:

Třída SP60ID_COMBOBOX

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 05.02.2014


Metoda REQUERY - Naplnění seznamu artiklu

Metoda | REQUERY
Název | Naplnění seznamu artiklu
Typ |
Parametry | _artikl,_sp61id
Popis | - přiřadí vlastnosti Entita_Artiklu, Sp61id hodnoty parametrů _artikl, _sp61id a vyvolá imlicitní metodu Requery s parametrem: _sp61id Parametry: _artikl,_sp61id _artikl (cName) - název entity artiklu _sp61id (cExp) - identifikace druhu artiklu

Viz.také:

Třída SP60ID_COMBOBOX

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 05.02.2014


Metoda VALID - Validace

Metoda | VALID
Název | Validace
Typ | N
Parametry |
Popis | - je uplatňována v metodě Read - není-li vybrán žádný artikl a vlastnost Chyba je typu cExp - zobrazí vlastnost Chyba a vrátí hodnotu -1 (ve formuláři posun o jeden objekt zpět)

Viz.také:

Třída SP60ID_COMBOBOX

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 05.02.2014


Atribut GETSQL_FROM - Doplňující seznam tabulek pro SQL-dotaz (za FROM)

Atribut | GETSQL_FROM
Název | Doplňující seznam tabulek pro SQL-dotaz (za FROM)
Typ | C
Inicializace | ""
Popis | Seznam tabulek pro další rozšíření výběru SQL-dotazu Použije se v metodě REQUERY

Viz.také:

Třída SP60ID_COMBOBOX

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 05.02.2014


Atribut GETSQL_WHERE - Doplňující výběr pro SQL-dotaz (za WHERE)

Atribut | GETSQL_WHERE
Název | Doplňující výběr pro SQL-dotaz (za WHERE)
Typ | C
Inicializace | ""
Popis | Další rozšíření výběru SQL-dotazu Použije se v metodě REQUERY

Viz.také:

Třída SP60ID_COMBOBOX

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 05.02.2014


Třída SP61ID_COMBOBOX

Třída | SP61ID_COMBOBOX
Název | SP61ID_COMBOBOX - třída
Knihovna | SYSDIA
Rodičovská třída | SYSDIA_COMBOBOX
Bázová třída | ComboBox
Popis | Slouží ke vstupu druhu artiklu jako překryvného seznamu (ComboBox), kde jednotlivé položky jsou názvy druhu artiklu a hodnota (klíč) je identifikace druhu artiklu.
Atributy třídy objektů
ENTITA_ARTIKLU | Entita artiklu
CHYBA | Hlášení při nevybrání druhu artiklu
Metody třídy objektů
GETSQL | Výběr druhu artiklu
INTERACTIVECHANGE | Reakce na změnu nabídky
REQUERY | Naplnění seznamu druhů artiklu

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 10.04.2008


Metoda GETSQL - Výběr druhu artiklu

Metoda | GETSQL
Název | Výběr druhu artiklu
Typ | C
Parametry |
Popis | - vrací SQL-dotaz pro výběr druhu artiklu Parametry: - Obsah: LOCAL _sql TEXT TO _sql TEXTMERGE NOSHOW select sp61nazdru,sp61id from %%%.spartikd where exists(select * from %%%.<<This.entita_artiklu>> art ,%%%.spartikn where art.sp61id=spartikd.sp61id and spartikn.sp61id=art.sp61id and spartikn.sp60id=art.sp60id and spartikn.sp38id=?tool.jazyk) ENDTEXT RETURN _sql

Viz.také:

Třída SP61ID_COMBOBOX

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 10.04.2008


Atribut CHYBA - Hlášení při nevybrání druhu artiklu

Atribut | CHYBA
Název | Hlášení při nevybrání druhu artiklu
Typ | C
Inicializace | "Vyberte druh artiklu"
Popis | - změněná hodnota třídy SysDia_ComboBox

Viz.také:

Třída SP61ID_COMBOBOX

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 10.04.2008


Atribut ENTITA_ARTIKLU - Entita artiklu

Atribut | ENTITA_ARTIKLU
Název | Entita artiklu
Typ | C
Inicializace | ""
Popis | Hodnota vlastnosti Entita_Artiklu určuje entitu artiklu, pro kerý je druh vybírán.

Viz.také:

Třída SP61ID_COMBOBOX

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 10.04.2008


Metoda REQUERY - Naplnění seznamu druhů artiklu

Metoda | REQUERY
Název | Naplnění seznamu druhů artiklu
Typ |
Parametry | _artikl
Popis | - přiřadí vlastnosti Entita_Artiklu hodnotu parametru _artikl a vyvolá imlicitní metodu Requery Parametry: _artikl _artikl (cName) - název entity artiklu

Viz.také:

Třída SP61ID_COMBOBOX

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 10.04.2008


Metoda INTERACTIVECHANGE - Reakce na změnu nabídky

Metoda | INTERACTIVECHANGE
Název | Reakce na změnu nabídky
Typ
Parametry
Popis

- zajišťuje spolupráci s objektem SP60ID (vstup artiklu - třídy /Sp60id_Class/ - implicitně Sp60id_ComboBox)

- při změně hodnoty vstupovaného objektu provede metodu Requery objektu pro vstup artiklu (jestliže takový existuje) s parametry: This.Entita_Artiklu,This.Value

Viz.také:

Třída SP61ID_COMBOBOX

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 10.04.2008


Třída SYSDIA_COMBOBOX

Třída | SYSDIA_COMBOBOX
Název | SYSDIA_COMBOBOX - třída
Knihovna | SYSDIA
Bázová třída | ComboBox
Popis

Slouží ke vstupu údajů ze seznamu dat SQL databáze jako překryvného seznamu (ComboBox). Ve většině případů je lepší použít metodu AddComboBox třídy BM_CODE_SYSDIA, kde parametr _rowso začíná znakem "~".

Její hlavní výhodu je možnost využívání parametrů (_p1,_p2,_p3,_p4) v metodě GetSql a tyto parametry dynamicky měnit dle předchozích požadavků ve formuláři.
Atributy třídy objektů
CHYBA Hlášení při nezvolení možnosti
Metody třídy objektů
GETSQL | SQL - dotaz
REQUERY | Nabídky seznamu
VALID | Validace

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 10.04.2008


Atribut CHYBA - Hlášení při nezvolení možnosti

Atribut | CHYBA
Název | Hlášení při nezvolení možnosti
Typ | C
Inicializace | Vyberte
Popis | Hodnota vlastnosti Chyba (je-li typu cExp) je zobrazována v metodě VALID (jestliže nebyl vybrán žádný prvek seznamu).

Viz.také:

Třída SYSDIA_COMBOBOX

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 10.04.2008


Metoda GETSQL - SQL - dotaz

Metoda | GETSQL
Název | SQL - dotaz
Typ | C
Parametry |
Popis | - vrací SQL-dotaz - je nuto ji uvést tvůrcem formuláře - výraz SQL by měl vracet tabulku 2 atributů, kde 1. atribut je ten, který má být zobrazován v objektu ComboBoxu jako nabídka a 2. atribut je hodnota (klíč), který je objektem vrácen - vyvolává se v metodě Requery

Viz.také:

Třída SYSDIA_COMBOBOX

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 10.04.2008


Metoda REQUERY - Nabídky seznamu

Metoda | REQUERY
Název | Nabídky seznamu
Typ |
Parametry | _p1,_p2,_p3,_p4
Popis | - naplní objekt jednotlivými nabídkami dle SQL-dotazu (metodou GetSql) pomocí programu BW_EXEC Parametry: _p1,_p2,_p3,_p4 - parametry předávané programu BW_EXEC

Viz.také:

Třída SYSDIA_COMBOBOX

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 10.04.2008


Metoda VALID - Validace

Metoda | VALID
Název | Validace
Typ | N
Parametry |
Popis | - je uplatňována v metodě Read - není-li vybrán žádný prvek seznamu a vlastnost Chyba je typu cExp - zobrazí vlastnost Chyba a vrátí hodnotu -1 (ve formuláři posun o jeden objekt zpět)

Viz.také:

Třída SYSDIA_COMBOBOX

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 10.04.2008


SYSDIA - příklady

Př. 1 - Obecné použití

------------------------------------------

Obvyklé použití bez speciálních možností a efektů

Local _o,_eee

* Vytvoření objektu _o třídy SysDia

_o=CreateObject('bm_code_sysdia')

* Formulář bude v okně Windows

_o.Top_Level_Form=.T.

* Vytvoření objektu _eee třídy Custom; vlastní formulář a jednotlivé objekty připojované do formuláře

_eee=Createobject('Custom')

* Založení formuláře _eee s názvem: Test v objektu _o

_o.Start(_eee,'Test')

* Určení šířky formuláře

_o.Width=600

* Určení šířky vstupovaných objektů třídy TextBox a ComboBox

_o.Set_Element_Width(300)

* Potvrzení stisku tlačítka Storno

_o.Set_Storno_Message('Opravdu STORNO?')

* Vstupovaný objekt text_jmeno třídy TextBox

* (Init: Space(10); Nadpis: Jméno; Maska: XXXXXXXXXX)

_eee.AddProperty('text_jmeno',Space(10))

_o.AddTextBox('text_jmeno','XXXXXXXXXX','Jméno')

* Vstupovaný objekt combo_provedeni třídy ComboBox

* (Init: 1; Nadpis: Materiál; Volby: 1-Dřevo, 2-Sklo Y, 3-Kov)

_eee.AddProperty('combo_provedeni',1)

_o.AddComboBox('combo_provedeni','Dřevo,Sklo,Kov','Materiál')

* Vstupovaný objekt combo_provedeni třídy ComboBox - volby jsou dle SQL-dotazu

* (Init: 0100; Nadpis: Banka; Volby: OCBANKA.oc02nazevb; Návratové hodnoty: OCBANKA.oc02idbank)

_eee.AddProperty('oc02idbank','0100')

_o.addcombobox('oc02idbank','~select oc02nazevb, oc02idbank from OCBANKA','Banka')

* Vstupovaný objekt option_barva třídy OptionGroup

* (Init: 1; Nadpis: Barva; Volby: 1-Zelená, 2-Modrá, 3-Bílá)

_eee.AddProperty('option_barva',1)

_o.AddOptionGroup('option_barva','Zelená,Modrá,Bílá','Barva')

* Vstupovaný objekt check_provedeni třídy CheckBox

* (Init: 1; Nadpis: S kováním)

_eee.AddProperty('check_provedeni',.f.)

_o.AddCheckBox('check_provedeni','S kováním')

* Spuštění formuláře, načtení hodnot, v případě stisku tlačítka OK vypsání zprávy: Bylo zadáno

If _o.Read()

Wait Wind 'Bylo zadáno'

Endif

Př. 2 - Přiřazení vlastností

------------------------------------------------

Je třeba změnit existující vlastnosti vstupovaného objektu

...

_eee.AddProperty('text_prijmeni',Space(10))

_o.AddTexBbox('text_prijmeni','XXXXXXXXXX','Příjmení','TextBox','prijmeni')

_o.frm.prijmeni.FontBold=.T. && Písmo bude Bold

...

* Stejného efektu dosáhneme přiřazením objektu:

* Pozor tento objekt musíme po změně vlastností uvolnit (např. přiřazením hodnoty .F.)

...

_eee.AddProperty('text_prijmeni',Space(10))

_x=_o.AddTexBbox('text_prijmeni','XXXXXXXXXX','Příjmení')

_x.FontBold=.T. && Písmo bude Bold

_x=.F. && Uvolnění objektu

...

Př. 3 - Přiřazení vlastností a metod pomocí třídy

-----------------------------------------------------------------------------------------

Je třeba změnit existující vlastnosti a metody vstupovaného objektu

...

_eee.AddProperty('text_prijmeni',Space(10))

_o.AddTexBbox('text_prijmeni','XXXXXXXXXX','Příjmení','Moje_TextBox')

_o.AddLabel('Příjmení',.F.,.F.,'lblprijmeni')

...

Define Class Moje_TextBox As TextBox

FontBold=.T. && Písmo bude Bold

FontItalic=.T. && Písmo bude Italic

Procedure Valid

* V případě zadání prázdného se zobrazí hláška: Zadejte text a focus je přesunut o jeden objekt zpět

If Empty(This.Value)

Wait Window 'Zadejte text' Nowait

Return -1

Endif

Procedure InteractiveChange

* V případě změny hodnoty naplní nadpis objektu lblprijmeni

This.Parent.lblprijmeni.Caption='Příjmení: '+This.Value

EndDefine

Př. 4 - Vstup TextBoxu jako ComboBox

--------------------------------------------------------

Vstupovaný objekt typu TextBox má časté konstantní plnění, ne však vždy

...

_eee.AddProperty('text_titul',Space(10))

_o.AddTextComboBox('text_titul','Pan,Paní,Slečna,Ing.','XXXXXXXXXX','Titul')

...

* Stejného efektu dosáhneme:

...

._eee.AddProperty('text_titul',Space(10))

_o.AddTextBox('text_titul','XXXXXXXXXX','Titul','ComboBox','titul')

_o.frm.titul.rowsource='Pan,Paní,Slečna,Ing.'

_o.frm.titul.rowsourcetype=1

...

* Stejného efektu dosáhneme pomocí vlastní třídy:

...

_eee.AddProperty('text_titul',Space(10))

_o.AddTextBox('text_titul','XXXXXXXXXX','Titul','Moje_ComboBox')

...

Define Class Moje_ComboBox As ComboBox

RowSourceType=1

RowSource='Pan,Paní,Slečna,Ing.'

EndDefine

Př. 5 - Použití třídy SysDia_ComboBox

---------------------------------------------------------

Vstup do překryvného seznamu Sql-dotazem

Běžně se nepoužívá, většinou lze řešit metodou AddComboBox, její hlavní výhodu je možnost využívání parametrů (_p1,_p2,_p3,_p4) v metodě GetSql a tyto parametry dynamicky měnit dle předchozích požadavků ve formuláři. V tomto příkladě budou vybíráni adresáti dle zvoleného 1. písmene.

...

_eee.AddProperty('ad01id_prvni_pismeno',' ')

_o.addtextbox('ad01id_prvni_pismeno','!','První písmeno','Moje_TextBox','prvni_pismeno')

_eee.AddProperty('ad01id',' ')

_o.addcombobox('ad01id','','Adresát','Moje_SysDia_ComboBox','adresat')

...

Define Class Moje_TextBox As TextBox

PROCEDURE InteractiveChange

This.Parent.adresat.Init

EndDefine

Define Class Moje_SysDia_ComboBox As SysDia_ComboBox

plus_filt=''

Procedure GetSql

Return [select ad01adsat, ad01id from %%%.ADADSAT]+IIF(EMPTY(this.plus_filt),'',' where '+This.plus_filt)

Procedure Requery

Lparameters _p1

This.plus_filt=_p1

Return DoDefault()

Procedure Init

This.Requery([ad01adsat like ']+Trim(This.Parent.prvni_pismeno.Value)+[%'])

EndDefine

Př. 6 - Použití třídy Sp61id_ComboBox

---------------------------------------------------------

Vstup druhu artiklu překryvným seznamem

...

_eee.AddProperty('sp61id','ZBO')

_o.add_sp61id('sp61id','Druh obchodovaného artiklu','obartikl')

...

Př. 7 - Použití třídy Sp60id_ComboBox

---------------------------------------------------------

Vstup artiklu překryvným seznamem

...

_eee.AddProperty('sp60id',Space(13))

_o.add_sp60id('sp60id','Obchodovaný artikl druhu ZBO','obartikl','ZBO')

...

Př. 8 - Použití třídy Sp61id_ComboBox a zároveň Sp60id_ComboBox

---------------------------------------------------------------------------------------------------------------------------

Vstup druhu artiklu a artiklu překryvným seznamem

...

* Druh artiklu

_eee.AddProperty('sp61id','ZBO')

_o.add_sp61id('sp61id','Druh','obartikl')

* Artikl

_eee.AddProperty('sp60id',Space(13))

_o.add_sp60id('sp60id','Artikl')

...

Př. 9 - Použití třídy Sp61id_ComboBox a zároveň Sp60id_ComboBox a zároveň s dalším omezením

-----------------------------------------------------------------------------------------------------------------------------------

Vstup druhu artiklu a artiklu z obchodu překryvným seznamem, kde artikly existují mezi artikly skladu

...

* Druh artiklu

_eee.AddProperty('sp61id','ZBO')

_o.add_sp61id('sp61id','Druh','obartikl')

* Artikl

_eee.AddProperty('sp60id',Space(13))

_o.add_sp60id('sp60id','Artikl')

_o.frm.sp60id.getsql_from='MTSKL '

_o.frm.sp60id.getsql_where='ART.sp61id=MTSKL.sp61id AND ART.sp60id=MTSKL.sp60id'

* Requery – načtení seznamu

_o.frm. sp60id.REQUERY('OBARTIKL', 'ZBO')

* nebo lépe:

_o.frm. sp60id.REQUERY(_o.frm.sp61id.entita_artiklu, _o.frm.sp61id.value)

...

Př. 10 - Vstup atributu s nabídkou F2

---------------------------------------------------------------------------------------------------------------------------

Vstup druhu artiklu překryvným seznamem a artiklu s nabídkou F2

Local _eee

Private _o && !!! Nelze LOCAL - odkaz na atribut v objektu bude použit jako parametr volání nabídky F2 (druh artiklu bude parametrem pro volání nabídky artiklu)

...

* Druh artiklu

_eee.AddProperty('sp61id','ZBO')

_o.add_sp61id('sp61id','Druh','obartikl')

* Artikl s nabídkou F2

_eee.AddProperty('sp60id',Space(13))

_o.AddTextBoxf2('sp60id',;

"DO bw_prika WITH [DO FORM OB0100 WITH _p1,_p2, _p3,' '], '$'+thisform.ident_time,'!RET-sp60id',_o.frm.sp61id.value",;

.F.,'Artikl')

* nebo (v tomto případě může být objekt _o LOCAL, parametr druh artiklu se odkazuje na známý objekt: DIALOG_FRM):

_o.AddTextBoxf2('sp60id',;

"DO bw_prika WITH [DO FORM OB0100 WITH _p1,_p2, _p3,' '], '$'+thisform.ident_time,'!RET-sp60id',thisform.DIALOG_FRM.sp61id.Value",;

.F.,'Artikl')

...

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Třída SYSDIA_POM_FORM_F2

Třída | SYSDIA_POM_FORM_F2
Název | SYSDIA - třída
Knihovna | SYSDIA
Bázová třída | Form
Popis | Slouží jako pomocný formulář pro vyvolání nabídky klávesou F2 ve třídě SYSDIA_TEXTBOXF2.
Atributy třídy objektů
ALLWAYSONTOP | Ostatní okna nepřekrývají formulář
CAPTION | Záhlaví
DIALOG_FRM | objekt vstupního formuláře
GVAL | Předávaná hodnota z formulářů nabídky
GZPR | Identifikace předávané hodnoty z formulářů nabídky
HEIGHT | Výška
IDENT_TIME | Jednoznačná identifikace formuláře
NAME | Název
PRIJEMCE_F2 | Objekt pro nějž je nabídka volána
SPUSTIT | Vnitřní vlastnost pro chod metody ACTIVATE
TOP | Horní umístění
WIDTH | Šířka
WINDOWTYPE | Typ formuláře
Metody třídy objektů
ACTIVATE | Aktivace
INIT | Inicializace

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Atribut ALLWAYSONTOP - Ostatní okna nepřekrývají formulář

Atribut | ALLWAYSONTOP
Název | Ostatní okna nepřekrývají formulář
Typ | O
Inicializace | .F.
Popis |

Viz.také:

Třída SYSDIA_POM_FORM_F2

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Atribut CAPTION - Záhlaví

Atribut | CAPTION
Název | Záhlaví
Typ | O
Inicializace | SYSDIA - Pomocný formulář pro nabídku F2
Popis |

Viz.také:

Třída SYSDIA_POM_FORM_F2

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Atribut HEIGHT - Výška

Atribut | HEIGHT
Název | Výška
Typ | O
Inicializace | 0
Popis |

Viz.také:

Třída SYSDIA_POM_FORM_F2

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Atribut NAME - Název

Atribut | NAME
Název | Název
Typ |
Inicializace | SYSDIA_pomocny_formular_pro_nabidku_F2
Popis |

Viz.také:

Třída SYSDIA_POM_FORM_F2

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Atribut TOP - Horní umístění

Atribut | TOP
Název | Horní umístění
Typ | O
Inicializace | -100 (mimo obrazovku)
Popis |

Viz.také:

Třída SYSDIA_POM_FORM_F2

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Atribut WIDTH - Šířka

Atribut | WIDTH
Název | Šířka
Typ | O
Inicializace | 0
Popis |

Viz.také:

Třída SYSDIA_POM_FORM_F2

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Atribut WINDOWTYPE - Typ formuláře

Atribut | WINDOWTYPE
Název | Typ formuláře
Typ | O
Inicializace | 1 (modální)
Popis |

Viz.také:

Třída SYSDIA_POM_FORM_F2

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Atribut GVAL - Předávaná hodnota z formulářů nabídky

Atribut | GVAL
Název | Předávaná hodnota z formulářů nabídky
Typ | ?
Inicializace | ""
Popis | (standardní určení v IS)

Viz.také:

Třída SYSDIA_POM_FORM_F2

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Atribut GZPR - Identifikace předávané hodnoty z formulářů nabídky

Atribut | GZPR
Název | Identifikace předávané hodnoty z formulářů nabídky
Typ | C
Inicializace | ""
Popis | (standardní určení v IS)

Viz.také:

Třída SYSDIA_POM_FORM_F2

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Atribut IDENT_TIME - Jednoznačná identifikace formuláře

Atribut | IDENT_TIME
Název | Jednoznačná identifikace formuláře
Typ | C
Inicializace | SYS(2015)
Popis | (standardní určení v IS)

Viz.také:

Třída SYSDIA_POM_FORM_F2

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Atribut PRIJEMCE_F2 - Objekt pro nějž je nabídka volána

Atribut | PRIJEMCE_F2
Název | Objekt pro nějž je nabídka volána
Typ | O
Inicializace | .F.
Popis | Do jeho vlastnosti VALUE se v metodě ACIVATE plní vlastnost GVAL - předávaná hodnota

Viz.také:

Třída SYSDIA_POM_FORM_F2

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Atribut SPUSTIT - Vnitřní vlastnost pro chod metody ACTIVATE

Atribut | SPUSTIT
Název | Vnitřní vlastnost pro chod metody ACTIVATE
Typ | L
Inicializace | .T.
Popis | Je-li .T. - spouští se nabídka, je-li .F. - formulář se zavře

Viz.také:

Třída SYSDIA_POM_FORM_F2

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Metoda INIT - Inicializace

Metoda | INIT
Název | Inicializace
Typ | O
Parametry |
Popis | Spustí se program BW_SET (standardní určení v IS)

Viz.také:

Třída SYSDIA_POM_FORM_F2

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Metoda ACTIVATE - Aktivace

Metoda | ACTIVATE
Název | Aktivace
Typ | O
Parametry |
Popis | - při 1. spuštění se vyvolá nabídka (vlastnost PRIJEMCE_F2.REAKCE_F2) - při dalším (obnovení formuláře po odchodu z nabídky) se do vlastnosti PRIJEMCE_F2.VALUE dá vlastnost GVAL a formulář se zavře

Viz.také:

Třída SYSDIA_POM_FORM_F2

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Atribut DIALOG_FRM - objekt vstupního formuláře

Atribut | DIALOG_FRM
Název | objekt vstupního formuláře
Typ | O
Inicializace | .F.
Popis |

Viz.také:

Třída SYSDIA_POM_FORM_F2

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Třída SYSDIA_TEXTBOXF2

Třída | SYSDIA_TEXTBOXF2
Název | SYSDIA - třída
Knihovna | SYSDIA
Bázová třída | TextBox
Popis | Slouží ke vstupu atributu (TextBox), s možností vyvolání nabídky po stisku klávesy F2.
Atributy třídy objektů
BACKCOLOR | Barva pozadí
FORMAT(! - velká písmena) | Formát
REAKCE_F2 | Reakce na klávesu F2
Metody třídy objektů
KEYPRESS | Stisk klávesy
RIGHTCLICK | Stik pravého tlačítka myši

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Atribut BACKCOLOR - Barva pozadí

Atribut | BACKCOLOR
Název | Barva pozadí
Typ | O
Inicializace | RGB(255,255,0) (žlutá)
Popis |

Viz.také:

Třída SYSDIA_TEXTBOXF2

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Atribut FORMAT(! - velká písmena) - Formát

Atribut | FORMAT(! - velká písmena)
Název | Formát
Typ | O
Inicializace | ! (velká písmena)
Popis |

Viz.také:

Třída SYSDIA_TEXTBOXF2

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Atribut REAKCE_F2 - Reakce na klávesu F2

Atribut | REAKCE_F2
Název | Reakce na klávesu F2
Typ | C
Inicializace | ""
Popis | Reakce na klávesu F2 (plní se v metodě ADDTEXTBOXF2 třídy BM_CODE_SYSDIA) Vyvolává se v metodě ACTIVATE třídy SYSDIA_POM_FORM_F2.

Viz.také:

Třída SYSDIA_TEXTBOXF2

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Metoda KEYPRESS - Stisk klávesy

Metoda | KEYPRESS
Název | Stisk klávesy
Typ | O
Parametry | nKeyCode, nShiftAltCtrl
Popis | Je-li stisknuta klávesa F2, vyvolá metodu RIGHTCLICK

Viz.také:

Třída SYSDIA_TEXTBOXF2

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Metoda RIGHTCLICK - Stik pravého tlačítka myši

Metoda | RIGHTCLICK
Název | Stik pravého tlačítka myši
Typ | O
Parametry |
Popis | Založí pomocný modální formulář třídy SYSDIA_POM_FORM_F2, určí mu vlastnost PRIJEMCE_F2 vlastním objektem (this), určí mu vlastnost DIALOG_FRM vlastním formulářem (thisfrm)

Viz.také:

Třída SYSDIA_TEXTBOXF2

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 02.05.2014


Třída BM_CODE_SYSDIA

Třída | BM_CODE_SYSDIA
Název | SYSDIA - třída
Knihovna | SYSDIA
Bázová třída | Custom
Popis | Slouží k vlastnímu zadávání hodnot uživatelem (vytvoří formulář, jednotlivé vstupované objekty, zadání hodnot, ...).
Atributy třídy objektů
FRM | Objekt vstupního formuláře
FRM_VERSION | Verze knihovny objektu FRM
OBJECTFOCUS | Nastavení focusu jménem prvku
OKCLICK | Bylo stisknuto tlačítko OK
OTEC | Objekt vstupovaných dat
PREFIX | Název počátku objektů vstupovaných dat
SAVEFOCUS | Nastavení focusu
SP60ID_CLASS | Název třídy pro vstup druhu artiklu
SP61ID_CLASS | Název třídy pro vstup druhu artiklu
TOP_LEVEL_FORM | Okno formuláře
WIDTH | Šířka formuláře
Metody třídy objektů
ADD_SP60ID | Artikl
ADD_SP61ID | Druh artiklu
ADDCOMBOBOX | Překryvný seznam
ADDCHECKBOX | Zaškrtávací políčko
ADDLABEL | Návěští
ADDLINE | Podtržení
ADDOPTIONGROUP | Přepínač
ADDTEXTBOX | Textové pole
ADDTEXTBOXF2 | Textové pole s nabídkou F2
ADDTEXTCOMBOBOX | Textové pole s nabídkou vstupů
NEWLINE | Prázdný řádek
READ | Spuštění formuláře
SET_ELEMENT_WIDTH | Šířka vstupovaného objektu
SET_FORM_WIDTH | Šířka formuláře
SET_LABEL_CLASS | Třída formuláře
SET_STORNO_MESSAGE | Dotaz po tlačítku Storno
START | Založení vstupního formuláře
UCHOVEJ_FOCUS | Focus
WIDTH_ASSIGN | Volaná při změně šířky formuláře

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Atribut OKCLICK - Bylo stisknuto tlačítko OK

Atribut | OKCLICK
Název | Bylo stisknuto tlačítko OK
Typ | L
Inicializace | .F.
Popis | Hodnotu vlastnosti Okclick nastavuje objekt Frm - tlačítko OK (.T. - bylo stisknuto).

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Atribut OTEC - Objekt vstupovaných dat

Atribut | OTEC
Název | Objekt vstupovaných dat
Typ | O
Inicializace | .F.
Popis | Do vlastnosti Otec bude metodou Start vložen objekt v jehož vlastnostech jsou ukládána vstupovaná data

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Atribut SAVEFOCUS - Nastavení focusu

Atribut | SAVEFOCUS
Název | Nastavení focusu
Typ | L
Inicializace | .F.
Popis | Je-li vlastnost Savefocus před přidáním prvku do formuláře TRUE, bude při vstupu nastaven na tento prvek focus.

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Atribut FRM - Objekt vstupního formuláře

Atribut | FRM
Název | Objekt vstupního formuláře
Typ | O
Inicializace | .F.
Popis | Do vlastnosti Frm bude metodou Start vložen objekt vstupního formuláře.

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Atribut OBJECTFOCUS - Nastavení focusu jménem prvku

Atribut | OBJECTFOCUS
Název | Nastavení focusu jménem prvku
Typ | C
Inicializace | .F.
Popis | Je-li ve vlastnosti Objectfocus uvedeno jméno prvku, bude při vstupu nastaven na tento prvek focus.

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Atribut PREFIX - Název počátku objektů vstupovaných dat

Atribut | PREFIX
Název | Název počátku objektů vstupovaných dat
Typ | C
Inicializace | "thisform.otec2.otec."
Popis | Vlastnost Prefix se používá při skládaní jména vlastnosti do které jsou vstupována data.

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Atribut SP61ID_CLASS - Název třídy pro vstup druhu artiklu

Atribut | SP61ID_CLASS
Název | Název třídy pro vstup druhu artiklu
Typ | C
Inicializace | "sp61id_combobox"
Popis | Vlastnost Sp61id_class určuje název třídy comboboxu pro vstup druhu artiklu.

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Atribut SP60ID_CLASS - Název třídy pro vstup druhu artiklu

Atribut | SP60ID_CLASS
Název | Název třídy pro vstup druhu artiklu
Typ | C
Inicializace | "sp60id_combobox"
Popis | Vlastnost Sp60id_class určuje název třídy comboboxu pro vstup artiklu.

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Atribut FRM_VERSION - Verze knihovny objektu FRM

Atribut | FRM_VERSION
Název | Verze knihovny objektu FRM
Typ | N
Inicializace |
Popis | Vlastnost Frm_version určuje verzi knihovny obektu Frm.

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Atribut TOP_LEVEL_FORM - Okno formuláře

Atribut | TOP_LEVEL_FORM
Název | Okno formuláře
Typ | L
Inicializace | .F.
Popis | Vlastnost určuje v kterém okně bude formulář otevřen: .T. - formulář Windows, .F. - formulář FoxPro

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Atribut WIDTH - Šířka formuláře

Atribut | WIDTH
Název | Šířka formuláře
Typ | N
Inicializace | 0
Popis | Vlastnost Width určuje šířku vstupního formuláře.

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Metoda START - Založení vstupního formuláře

Metoda | START
Název | Založení vstupního formuláře
Typ |
Parametry | _otec,_caption
Popis | - založí vstupní formulář do vlastnosti Frm, vytvoří potřebné vazby - zobrazí vstupní formulář s definovanými objekty, podtržením a tlačítky OK a Storno. Parametry: _otec,_caption _otec (cName) - název objektu v jehož vlastnostech budou ukládána vstupovaná data _caption (cExp) - nadpis okna vstupního formuláře

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Metoda ADDCHECKBOX - Zaškrtávací políčko

Metoda | ADDCHECKBOX
Název | Zaškrtávací políčko
Typ | O
Parametry | _ctrl,_caption[,_lft[,_atr_class[,_nm]]]
Popis

- přidá do vstupního formuláře zaškrtávací políčko

Parametry: _ctrl,_caption[,_lft[,_atr_class[,_nm]]]

_ctrl (cName) - název vlastnosti objektu, ve které jsou uložena vstupovaná data

_caption (cExp) - návěští u zaškrtávacího políčka

_lft (lExp) - .T. = návěští u zaškrtávacího políčka umístěno vlevo; implicitně: .F.

_atr_class (cName) - název třídy vstupovaného objektu (měl by být typu CheckBox); implicitně: "CheckBox"

_nm (cName) - název vstupovaného objektu; takto bude objekt ve formuláři pojmemován - lze se na něj odkazovat jako: (Object).frm.&_nm, kde (Objekt) je jméno objektu; implicitně: /náhodný název/

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Metoda ADDOPTIONGROUP - Přepínač

Metoda | ADDOPTIONGROUP
Název | Přepínač
Typ | O
Parametry | _ctrl,_rowso[,_lbl[,_atr_class[,_nm]]]
Popis

- přidá do vstupního formuláře přepínač

Parametry: _ctrl,_rowso[,_lbl[,_atr_class[,_nm]]]

_ctrl (cName) - název vlastnosti objektu, ve které jsou uložena vstupovaná data

_rowso (cExp) - seznam popisů hodnot oddělených čárkou

_lbl (cExp) - návěští

_atr_class (cName) - název třídy vstupovaného objektu (měl by být typu OptionGroup); implicitně: "OptionGroup"

_nm (cName) - název vstupovaného objektu; takto bude objekt ve formuláři pojmemován - lze se na něj odkazovat jako: (Object).frm.&_nm, kde (Objekt) je jméno objektu; implicitně: /náhodný název/

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Metoda ADDCOMBOBOX - Překryvný seznam

Metoda | ADDCOMBOBOX
Název | Překryvný seznam
Typ | O
Parametry | _ctrl,_rowso[,_lbl[,_atr_class[,_nm]]]
Popis

- přidá do vstupního formuláře překryvný seznam

Parametry: _ctrl,_rowso[,_lbl[,_atr_class[,_nm]]]

_ctrl (cName) - název vlastnosti objektu, ve které jsou uložena vstupovaná data

_rowso (cExp) - seznam popisů hodnot oddělených čárkou, je-li 1. znak parametru _rowso: "~", potom se jedná o SQL-dotaz, kde 1. atribut je nabídka, 2. atribut je návratová hodnota (klíč)

_lbl (cExp) - návěští

_atr_class (cName) - název třídy vstupovaného objektu (měl by být typu ComboBox); implicitně: "Combobox"

_nm (cName) - název vstupovaného objektu; takto bude objekt ve formuláři pojmemován - lze se na něj odkazovat jako: (Object).frm.&_nm, kde (Objekt) je jméno objektu; implicitně: /náhodný název/

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Metoda ADDTEXTBOX - Textové pole

Metoda | ADDTEXTBOX
Název | Textové pole
Typ | O
Parametry | _ctrl[,_inputmask,_lbl[,_atr_class[,_nm]]]
Popis

- přidá do vstupního formuláře textové pole

Parametry: _ctrl[,_inputmask,_lbl[,_atr_class[,_nm]]]

_ctrl (cName) - název vlastnosti objektu, ve které jsou uložena vstupovaná data

_inputmask (cExp) - vstupní maska

_lbl (cExp) - návěští

_atr_class (cName) - název třídy vstupovaného objektu (měl by být typu TextBox, popř. Combobox); implicitně: "TextBox"

_nm (cName) - název vstupovaného objektu; takto bude objekt ve formuláři pojmemován - lze se na něj odkazovat jako: (Object).frm.&_nm, kde (Objekt) je jméno objektu; implicitně: /náhodný název/

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Metoda ADDLABEL - Návěští

Metoda | ADDLABEL
Název | Návěští
Typ | O
Parametry | lbl[,_neposun[,_atr_class[,_nm]]]
Popis | - přidá do vstupního formuláře návěští Parametry: _lbl[,_neposun[,_atr_class[,_nm]]] _lbl (cExp) - návěští _neposun (lExp) - je-li: .T., potom se návěští neposune ve formuláři o řádek; implicitně: .F. _atr_class (cName) - název třídy vstupovaného objektu (měl by být typu Label); implicitně: "Label" _nm (cName) - název vstupovaného objektu; takto bude objekt ve formuláři pojmemován - lze se na něj odkazovat jako: (Object).frm.&_nm, kde (Objekt) je jméno objektu; implicitně: /náhodný název/

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Metoda NEWLINE - Prázdný řádek

Metoda | NEWLINE
Název | Prázdný řádek
Typ |
Parametry | [_pix1]
Popis | - přidá do vstupního 1 prázdný řádek Parametry : [_pix1] _pix1 (nExp) - počet bodů, o který se řádek posune; implicitně: výška objektu TextBox

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Metoda ADDLINE - Podtržení

Metoda | ADDLINE
Název | Podtržení
Typ | O
Parametry | [_atr_class[,_nm]]
Popis

- přidá do vstupního formuláře podtržení

Parametry: [_atr_class[,_nm]]

_atr_class (cName) - název třídy objektu podtržení; implicitně: "Shape" - vlastnost SpecialEffekt = 0 (3D)

_nm (cName) - název objektu podtržení - takto bude objekt ve formuláři pojmemován - lze se na něj odkazovat jako: (Object).frm.&_nm, kde (Objekt) je jméno objektu; implicitně: /náhodný název/

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Metoda READ - Spuštění formuláře

Metoda | READ
Název | Spuštění formuláře
Typ | L
Parametry | [_objectfocus]
Popis | - spustí vstupní formulář Parametry: [_objectfocus] _objectfocus (cName) - název objektu, na který má být nastaven focus; implicitně: 1. vstupovaný objekt formuláře Návratová hodnota: .T. - bylo stisknuto tlačítko OK, jinak .F.

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Metoda ADD_SP60ID - Artikl

Metoda | ADD_SP60ID
Název | Artikl
Typ | O
Parametry | _ctrl,_lbl[,_artikl,_sp61id]
Popis

- přidá do vstupního formuláře objekt s názvem SP60ID pro vstup artiklu třídy,

která je uvedena ve vlastnosti SP60ID_CLASS (impicicitně SP60ID_COMBOBOX)

Parametry: _ctrl,_lbl[,_artikl,_sp61id]

_ctrl (cName) - název vlastnosti objektu, ve které jsou uložena vstupovaná data

_lbl (cExp) - návěští

_sp61id (cExp) - identifikace druhu artiklu; neuvádí se, existuje-li objekt SP61ID - potom se z něho přebírá

_artikl (cName) - název entity artiklu; neuvádí se, existuje-li objekt SP61ID - potom se z něho přebírá

Je-li potřeba vyvolat funkci REQUERY až po založení objektu (např. po určení dalšího omezení v atributu GETSQL_WHERE), potom se parametry _artikl,_sp61id neuvádějí

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Metoda SET_LABEL_CLASS - Třída formuláře

Metoda | SET_LABEL_CLASS
Název | Třída formuláře
Typ |
Parametry | _atr_class
Popis | - nastaví třídu formuláře - není-li metoda uvedena, potom je formulář třídy Label Parametry: _atr_class _atr_class (cName) - název třídy formuláře (měl by být typu Label)

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Metoda SET_FORM_WIDTH - Šířka formuláře

Metoda | SET_FORM_WIDTH
Název | Šířka formuláře
Typ |
Parametry | _width
Popis | - nastaví šířku formuláře - není-li metoda uvedena, potom je šířka nastavena implicitně (6 bodů od pravého okraje) Parametry: _width _width (nExp) - počet bodů

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Metoda WIDTH_ASSIGN - Volaná při změně šířky formuláře

Metoda | WIDTH_ASSIGN
Název | Volaná při změně šířky formuláře
Typ |
Parametry | _width
Popis | - při programové změně hodnoty WITH (např. voláním metody SETFORMWITH, nebo přiřazením (Obket).Width=/nExp/, kde (Objekt) je jméno objektu) se vyvolá tato metoda Obsah: Lparameters _width This.Width=_width This.frm.Width=_width

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Metoda SET_ELEMENT_WIDTH - Šířka vstupovaného objektu

Metoda | SET_ELEMENT_WIDTH
Název | Šířka vstupovaného objektu
Typ |
Parametry | _width
Popis | - nastaví šířku dalších vstupovaných objektů typu TextBox a ComboBox - není-li metoda uvedena, potom je šířka nastavena implicitně Parametry: _width _width (nExp) - počet bodů

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Metoda SET_STORNO_MESSAGE - Dotaz po tlačítku Storno

Metoda | SET_STORNO_MESSAGE
Název | Dotaz po tlačítku Storno
Typ |
Parametry | _storno_message
Popis | - nastaví text pro hlášení (BW_HLASE - Dotaz Ano/Ne) po stisku tlačítka Storno; - je-li v dotazu stisknuto tlačítko Ne: vrátí se řízení opět formuláři, je-li stisknuto tlačítko Ano: je formulář opuštěn - není-li metoda uvedena, potom je po stisku tlačítka Storno formulář opuštěn bez jakéhokoliv dotazu Parametry: _storno_message _storno_message (cExp) - text hlášení

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Metoda UCHOVEJ_FOCUS - Focus

Metoda | UCHOVEJ_FOCUS
Název | Focus
Typ |
Parametry | _o
Popis | - vnitřní metoda (v praxi se nepoužívá) pro zapamatování si posledního vstupovaného objektu Parametry: _o _o (nExp) - číslo objektu

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Metoda ADD_SP61ID - Druh artiklu

Metoda | ADD_SP61ID
Název | Druh artiklu
Typ | O
Parametry | _ctrl,_lbl,_artikl
Popis | - přidá do vstupního formuláře objekt s názvem SP61ID pro vstup druhu artiklu třídy, která je uvedena ve vlastnosti SP61ID_CLASS (impicicitně SP61ID_COMBOBOX) Parametry: _ctrl,_lbl,_artikl _ctrl (cName) - název vlastnosti objektu, ve které jsou uložena vstupovaná data _lbl (cExp) - návěští _artikl (cName) - název entity artiklu

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Metoda ADDTEXTCOMBOBOX - Textové pole s nabídkou vstupů

Metoda | ADDTEXTCOMBOBOX
Název | Textové pole s nabídkou vstupů
Typ | O
Parametry | _ctrl[,_rowso[,_inputmask,[_lbl[,_atr_class[,_nm]]]]]
Popis

přidá do vstupního formuláře textové pole s nabídkou vstupů v překryvném seznamu

Parametry: _ctrl[,_rowso[,_inputmask,[_lbl[,_atr_class[,_nm]]]]]

_ctrl (cName) - název vlastnosti objektu, ve které jsou uložena vstupovaná data

_rowso (cExp) - seznam popisů hodnot oddělených čárkou

_inputmask (cExp) - vstupní maska

_lbl (cExp) - návěští

_atr_class (cName) - název třídy vstupovaného objektu (měl by být typu ComboBox); implicitně: "Combobox"

_nm (cName) - název vstupovaného objektu; takto bude objekt ve formuláři pojmemován - lze se na něj odkazovat jako: (Object).frm.&_nm, kde (Objekt) je jméno objektu; implicitně: /náhodný název/

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Metoda ADDTEXTBOXF2 - Textové pole s nabídkou F2

Metoda | ADDTEXTBOXF2
Název | Textové pole s nabídkou F2
Typ | O
Parametry | _ctrl[,_reakce_f2[,_inputmask,_lbl[,_atr_class[,_nm]]]]
Popis

- přidá do vstupního formuláře textové pole s reakcí na F2 (RighClick)

Parametry: _ctrl[,_inputmask,_lbl[,_atr_class[,_nm]]]

_ctrl (cName) - název vlastnosti objektu, ve které jsou uložena vstupovaná data

_reakce_f2 - znaková - reakce na F2

_inputmask (cExp) - vstupní maska

_lbl (cExp) - návěští

_atr_class (cName) - název třídy vstupovaného objektu (měl by být typu sysdia_textboxf2, popř. TextBox); implicitně: "sysdia_textboxf2"

_nm (cName) - název vstupovaného objektu; takto bude objekt ve formuláři pojmemován - lze se na něj odkazovat jako: (Object).frm.&_nm, kde (Objekt) je jméno objektu; implicitně: /náhodný název/

Viz.také:

Třída BM_CODE_SYSDIA

© 1996-2014 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 30.04.2014


Pojem - SAI - Čárový kód

Čárový kód je prostředek pro automatizovaný sběr dat. Je tvořen černotiskem vytištěnými pruhy definované šířky, umožňující přečtení pomocí technických prostředků – čteček (pro jednorozměrné kódy) či skenerů (pro jedno- i dvourozměrné kódy). Podle způsobu, jakým se konkrétní znak kóduje do skupiny pruhů, se kódy dělí do skupin. Nejpoužívanější skupiny kódů jsou:

¨ Code 2/5 (poprvé použit v roce čárových kódů. Kód 128 je jednorozměrným kódem, je schopný zakódovat 128 znaků (spodní polovinu ASCII) - jako jeden z mála u znaků umí rozlišovat a zachovat velikost písmen v kódu.

¨ Code 93 (1982)

Každý čárový kód je tvořen sekvencí čar a mezer s definovanou šířkou. Ty jsou při čtení transformovány podle své sytosti na posloupnost elektrických impulsů různé šířky a porovnávány s tabulkou přípustných kombinací. Pokud je posloupnost v tabulce nalezena, je prohlášena za odpovídající znakový řetězec. Nositelem informace je nejenom tištěná čára, ale i mezera mezi jednotlivými dílčími čarami. Krajní skupiny čar mají specifický význam – slouží jako synchronizační pro čtecí zařízení, které podle nich generuje signál Start/Stop. Technická specifikace pak vyžaduje ochranné světlé pásmo bez potisku před a za synchronizačními čarami.

Základní prvky čárového kódu jsou:

¨ šířka modulu – jde o nejužší element kódu, tedy nejmenší přípustnou šířku čáry či mezery

¨ světlé pásmo – doporučeno minimálně desetinásobek šířky modulu

¨ výška kódu – udává svislý rozměr pásu kódu

¨ délka kódu – obsazená délka pásu od první značky Start po poslední značku Stop, ale bez světlého pásma

¨ kontrast – je poměr rozdílu jasu odrazu pozadí a odrazu čáry k jasu odrazu pozadí

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.10.2015


Pojem - Dávky (nemoc)

Viz.také:

Slovník pojmů

© 1996-2007 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 14.04.2006


Pojem - Dokumenty – revize

Jedná se o činnost, která je v případě nastavení dostupná na každém dokumentu a umožňuje sledování jednotlivých revizí. Revizí dokumentu rozumíme kopii obsahu daného dokumentu zaznamenanou v čase. Ve formuláři dokumenty je k tomuto účelu vytvořena záložka „revize dokumentu“. Zde se uživateli zobrazuje přehled jednotlivých revizí, a to těch dokumentů, které mají na záložce dokumenty zatržen příznak „automatické ukládání revizí dokumentu“. Při zatržení tohoto příznaku vznikají revize daného dokumentu automaticky, ale v případě potřeby (pokud tento příznak zatržen není, ale uživatel by si rád uchoval průběh dokumentu v čase) je možno revize vytvořit i manuálně a to volbou činnosti „uložit novou revizi dokumentu“ z menu Volby.

U každé revize se eviduje datum, čas jejího vzniku a uživatel, který ji založil. Nepotřebné revize je možné na záložce „revize dokumentu“ rušit. Revize je možné sledovat pouze pro dokumenty uložené v databázi, tzn. u dokumentů, které mají zatržen příznak „externí uložení“ revize sledovat nelze.

Viz.také:

Slovník pojmů

© 1996-2007 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 24.11.2004


Pojem - Dynamická podmínka

Viz.také:

Slovník pojmů

© 1996-2007 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Historie pracovního poměru

Viz.také:

Slovník pojmů

© 1996-2007 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 14.04.2006


Pojem - Identifikace zvířete

- identifikace konkrétního zvířete

Ve skladu zvířat je možno evidovat zvířata kusově (činnost „Kategorie zvířat“) zadáním hodnoty „Kusově“ v atributu „Zp. vedení“. Potom se v událostech zadává konkrétní identifikace zvířete. Druh hodnoty: „Množství v MJ pro výpočet: KD; mn. jednotlivých zvířat“ (činnost „Parametry komp. sklad zvířat“ – obv. množství v naturálním vyjádření) tohoto konkrétního zvířete může mít stav 0 nebo 1. Přehled takto evidovaných zvířat se provádí v činnosti „Jednotlivá zvířata“.

Viz.také:

Sklad zvířat

© 1996-2008 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Struska Michal - 14.09.2007


Pojem - Nepřítomnost pro nemoc

Viz.také:

Slovník pojmů

© 1996-2007 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 14.04.2006


Pojem - Oceňování skladových zásob

Proto, aby probíhal výpočet skladové ceny na skladové pohybu musí být splněny tyto podmínky:

  1. k odpovídajícímu druhu operace musí být připojeny druhy hodnot, které jsou definované činností „Základní druhy hodnot“ jako hodnoty aktualizující množství artiklu na skladě ve finančním a naturálním vyjádření
  2. musí se jednat o výdej ze skladu – tj. událost charakteru výdej s uvedeným kladným množství artiklu nebo událost charakteru příjem s uvedeným záporným množstvím artiklu

Výpočet probíhá metodou „FIFO“ nebo „Vážený průměr“ podle nastavení odpovídající vlastnosti skladu uvedeného v události.

Zbytek doplní Olina.

Viz.také:

Sklad - komponenta SKL

© 2002,2003 BM Servis České Budějovice.Všechna práva vyhrazena.

Filip Petr - 21.08.2003


Pojem - Odpisy a opravné položky pohledávek

Tato komponenta je určena k evidenci neuhrazených pohledávek, na které je možné uplatnit odpis nebo opravné položky. Mezi nejvýznamnější atributy této komponenty patří kromě standardních odepsat procento z ceny pohledávky, finanční částka a výchozí cena a atribut, zda dochází ke změně stavu pohledávky. S komponentou Platby sdílí tato komponenta tabulku s vazbou karty odepisované pohledávky a události platby, na základě které byla založena.

Jako artikl je z hlediska odpisů a opravných položek pohledávek aplikována karta pohledávky, kterou lze založit pouze v činnosti s přehledem událostí PLA v menu Volby funkcí Karty pohledávek, přičemž její identifikace je předplněna dle druhu artiklu uvedeného v parametrech komponenty ODP a dle VS uvedeného v dané události pohledávky; současně je aktualizována vazební tabulka s událostí PLA.

Název artiklu je předplněn identifikací procesu události platby a datum aktuálním datem. Uživatelsky se definuje, zda se jedná o kartu s odpisem, pak se uvádí roční procento odpisu, či s opravnou položkou, pak se uvádí tabulka koeficientů, dle které bude relevantní šablona počítat výši opravné položky. Automaticky se doplní výše pohledávky dle atributu neuhrazeno v události PLA, která se následně aktualizuje (přepis) atributem výchozí cena z událostí ODP, které mají nastaven příznak Změna hodnoty pohledávky na Ano. Prezentované datum splatnosti je z relevantní události PLA.

Na první záložce Stav pohledávek se prezentují sumární údaje týkající se odpisů a opravných položek dané pohledávky, které se počítají z relevantních událostí ODP dle atributu finanční částka (procento a aktuální hodnota jsou dopočtené k počáteční hodnotě).

Na druhé záložce Změna pohledávky se prezentují události ODP týkající se dané karty pohledávky, jejichž operaci lze spustit z menu Volby; na šedém pozadí se prezentují ty, které mají nastaven atribut Změna hodnoty pohledávky na Ano.

Na třetí záložce Pohledávka se prezentují významné atributy z relevantní události PLA. Současně zde lze v menu Volby spustit operaci související s danou událostí PLA.

Mezi funkce dostupné v menu Volby v činnosti prezentující seznam artiklů (odepisovaných karet plateb) patří funkce prezentace artiklu (dle artiklu v IC) a funkce pro zrušení příznaku změna platby (tj. karta, na jejíž zdrojové události PLA došlo ke změně atributu dosud neuhrazeno, se bude po aplikaci této funkce chovat, jakoby ke změně atributu nedošlo). Na labelu Artikl jsou k dispozici relevantní údaje.

V případě, že se hodnota dosud neuhrazeno v události PLA nerovná hodnotě pohledávky na kartě, je zobrazována na šedém pozadí a je možné založit k dané události PLA novou kartu pohledávky. Shodně je tomu v případě nastavení atributu Změna hodnoty pohledávky na hodnotu Ano, pak se na šedém pozadí zobrazuje i tato událost.

Viz.také:

Slovník pojmů

© 1996-2008 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 18.12.2007


Pojem - Parametr (užívaný ve výkazech)

Parametry užívané ve výkazech jsou uživatelem definované parametry, které se užívají v definici výkazu, resp. listu pro její usnadnění nebo s cílem zajištění určité variability obsahu výkazu dle požadavků uživatele při sestavení výkazu. Mohou být užívány jako skutečné parametry funkcí výkazu.

Parametr je některého z těchto typů: Numeric, Charakter, Date nebo Seznam hodnot.

Každý parametr vystupuje pod svým identifikátorem. Nabytí hodnoty parametru je

definováno některým ze způsobů uvedených v posloupnosti, jak nabývají hodnoty při sestavení výkazu:

¨ přiřazením v definici vzoru listu

¨ přiřazením v atributu parametry buňky, řádku nebo sloupce definice listu

¨ aplikací výrazu vzoru s definovanými parametry v definici listu pomocí vzoru

¨ přiřazením v atributu parametry definice listu v definici výkazu

¨ přiřazením v atributu parametry definice listu

¨ přiřazením v INI parametrech definice listu v definici výkazu

¨ proměnnou dotazu.

Viz.také:

Slovník pojmů

© 1996-2007 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Pravé tlačítko myši na skupině hlavního menu

Po každém stisku pravého tlačítka myši na některé ze skupiny činností hlavního menu se uživateli zobrazí následující nabídka:

¨ vlastnosti

¨ odstranit – je aktivní pouze u skupiny, kterou si vytvořil sám uživatel, skupiny dodané se základní definicí menu odstranit nelze

¨ vložit skupinu – do vybrané skupiny činností je možno vložit další skupinu, čili uživatel si tím vytvoří jakousi podskupinu, kam si může pomocí činnosti kopírovat vložit vybrané činnosti

¨ změnit pořadí činností – tato volba umožňuje uživateli změnit pořadí činností ve vybrané skupině. Pomocí posuvníku v levé straně okna si jednotlivé činnosti přemístí podle svých potřeb.

Viz.také:

Slovník pojmů

© 1996-2007 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Předloha výstupu typu – sestava

V předlohách výstupu je možné použít proměnnou TOOL.BWEMAIL. V této proměnné je uložena adresa e-mail aktuálně přihlášeného uživatele (podle odpovídajícího atributu ze seznamu uživatelů systému).

Pro vytváření nových předloh výstupu typu "Sestava" je možné použít předdefinované vzory. Pro použití této funkce je možné v souboru BW.INI předdefinovat až devět vzorů v sekci "Preferences" parametry "PRINT_TEMPLATEx", kde x je číslo vzoru 1 až 9. V uvádí se <název vzoru>[;<soubor vzoru>].

Viz.také:

Slovník pojmů

© 1996-2007 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - Předloha výstupu typu – ostatní (HTML)

Překlad textů

Viz.také:

Slovník pojmů

© 1996-2007 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Filip Petr - 04.07.2003


Pojem - RELDP

Pojem RELDP představuje „registr evidenčních listů důchodového pojištění“. Od 1.1.2004 došlo k zásadní změně ve způsobu vedení ELDP.

Zákon o důchodovém pojištění č. 155/1995 Sb. ve znění pozdějších předpisů, je založen na pojistném principu. Podmínkou vzniku nároku na důchod je získání potřebné doby pojištění. Celková doba pojištění a výše vyměřovacího základu v rozhodném období ovlivňuje podstatným způsobem procentní výměru důchodu.

Orgány sociálního zabezpečení příslušné k rozhodování o dávkách důchodového pojištění, získávají údaje o dobách pojištění a o výši vyměřovacího základu jednotlivých pojištěnců výlučně z ELDP, které jsou od 1.1.2004 organizace povinny předávat do centrální evidence orgánů sociálního zabezpečení každoročně.

K vedení ELDP je nezbytná alespoň základní znalost ustanovení §§ 5, 8, 11 a 16 ve znění pozdějších předpisů a § 38 a 39 zák.č. 582/1991 Sb., ve znění platném od 1.1.2004.

Viz.také:

Slovník pojmů

© 1996-2009 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 21.12.2007


Pojem - SAI - Čárový kód

Čárový kód je prostředek pro automatizovaný sběr dat. Je tvořen černotiskem vytištěnými pruhy definované šířky, umožňující přečtení pomocí technických prostředků – čteček (pro jednorozměrné kódy) či skenerů (pro jedno- i dvourozměrné kódy). Podle způsobu, jakým se konkrétní znak kóduje do skupiny pruhů, se kódy dělí do skupin. Nejpoužívanější skupiny kódů jsou:

¨ Code 2/5 (poprvé použit v roce čárových kódů. Kód 128 je jednorozměrným kódem, je schopný zakódovat 128 znaků (spodní polovinu ASCII) - jako jeden z mála u znaků umí rozlišovat a zachovat velikost písmen v kódu.

¨ Code 93 (1982)

Každý čárový kód je tvořen sekvencí čar a mezer s definovanou šířkou. Ty jsou při čtení transformovány podle své sytosti na posloupnost elektrických impulsů různé šířky a porovnávány s tabulkou přípustných kombinací. Pokud je posloupnost v tabulce nalezena, je prohlášena za odpovídající znakový řetězec. Nositelem informace je nejenom tištěná čára, ale i mezera mezi jednotlivými dílčími čarami. Krajní skupiny čar mají specifický význam – slouží jako synchronizační pro čtecí zařízení, které podle nich generuje signál Start/Stop. Technická specifikace pak vyžaduje ochranné světlé pásmo bez potisku před a za synchronizačními čarami.

Základní prvky čárového kódu jsou:

¨ šířka modulu – jde o nejužší element kódu, tedy nejmenší přípustnou šířku čáry či mezery

¨ světlé pásmo – doporučeno minimálně desetinásobek šířky modulu

¨ výška kódu – udává svislý rozměr pásu kódu

¨ délka kódu – obsazená délka pásu od první značky Start po poslední značku Stop, ale bez světlého pásma

¨ kontrast – je poměr rozdílu jasu odrazu pozadí a odrazu čáry k jasu odrazu pozadí

Viz.také:

Slovník pojmů

© 1996-2015 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 15.10.2015


Pojem - Spravovaný majetek

Komponenta „spravovaný majetek“ je určena pro evidenci a správu spravovaného majetku, obvykle i inventarizovaného, různého druhu. Na každé kartě spravovaného majetku je evidován právě jeho jeden výskyt jednoznačně identifikovatelný v IS BM i v reálném světě, tj. jedná se o druhovou evidenci, kde je významnějším údajem stav oproti množství. Komponenta eviduje ve svých událostech též veškeré změny stavu, odpovědnosti i alokace, ale také případné servisní zásahy apod.

Mezi významné tabulky komponenty kromě standardizovaných patří cizojazyčné názvy spravovaného majetku. Artikl spravovaného majetku je sdílen s komponentou rezervace majetku.

Viz.také:

Slovník pojmů

© 1996-2012 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 02.11.2007


Pojem - Účetní doklad

Účetní doklad je účetní záznam, kterým účetní jednotka prokazuje skutečnosti na něm uvedené. Závazné náležitosti účetního dokladu vymezuje § 11 zákona o účetnictví - účetní doklady jsou průkazné účetní záznamy, které musí obsahovat:

¨ označení účetního dokladu,

¨ obsah účetního případu a jeho účastníky,

¨ peněžní částku nebo informaci o ceně za měrnou jednotku a vyjádření množství,

¨ okamžik vyhotovení účetního dokladu,

¨ okamžik uskutečnění účetního případu, není-li shodný s okamžikem vyhotovení účetního dokladu,

¨ podpisový záznam podle § 33a odst. 4 osoby odpovědné za účetní případ a podpisový záznam osoby odpovědné za jeho zaúčtování.

Náležitosti účetního dokladu mohou být umístěny i na jiných než účetních záznamech (např. daňová přiznání apod.); tyto záznamy se uschovávají po stejnou dobu jako účetní doklad.
Účetní doklady rozlišujeme na externí (vnější) a interní (vnitřní). Interní doklady zachycují účetní případy uvnitř účetní jednotky (např. příjemky a výdejky materiálu, storno doklady apod.), externí doklady pak zachycují případy vznikající ve styku s ostatními účetními jednotkami (dodavatelské a odběratelské firmy, banky, pojišťovny, atd.).

Viz.také:

Slovník pojmů

© 1996-2008 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 27.02.2008


Pojem - Volná karta – atributy volné struktury

Jedná se o záložku při definování volné karty, kde uživatel zadává jednotlivé atributy, které se budou při aktivaci volné karty uživateli nabízet. Jedná se o:

¨ identifikaci (název) atributu,

¨ druh - vybírá se ze seznamu druhů volných karet, určuje právo uživatele pro přístup k datům volné karty

¨ typ, případně délku a počet desetinných míst (typ – znaková, numerická, datumová, časová, textová, multimediální – viz. popis níže)

¨ pořadí, v jakém bude aktualizován

¨ třída (textové pole, překryvný seznam, zaškrtávací pole). Pro atributy typu překryvný seznam je možno nastavit dynamický combobox.

¨ zobrazení - v jakém zobrazení či formátu se bude daný atribut při aktivaci okna volné karty zobrazovat, např. u překryvných seznamů se zde uvádí volby, které se uživateli budou nabízet při vyvolání tohoto překryvného seznamu, např. Ano,Ne nebo Příjem,Výdej apod., u numerických atributů zde může být zapsán formát jak se číslo má v okně volné karty zobrazovat, např. 99 999 999.99. Je možné uvádět libovolně dlouhý text. Pro třídu překryvný seznam a typ znakový je možné zadat SQL dotaz uvedený znaky *~. Dotaz musí vracet dva sloupce. První sloupec určuje text zobrazovaný v překryvném seznamu a druhý hodnotu předávanou na volnou kartu, např. SQL dotaz pro překryvný seznam se seznamem uživatelů *~select (if bw01aktiv=1 then '' else '* ' endif )+bw01jmeno,bw01uziv from %%%.bwuzivat where bw01uziv<>'$SYSTE' order by bw01aktiv desc,bw01jmeno

¨ návěští (tzn. popis, který se u daného atributu bude zobrazovat v okně volné karty)

¨ poznámka - vlastní poznámka k atributu,

¨ inicializace - pokud je zde uveden atribut, který je výpočtový, je nutno pro něj mít vytvořen vlastní volný pohled. Pokud je tedy uveden „název volného pohledu.alias jeho atributu" (např. POHCLK.pclk1), pak se jedná o údaj prezentující vypočtenou hodnotu (pomocí příkazu SELECT), v opačném případě se jedná o atribut nové tabulky, která se musí po každé aktualizaci své struktury generovat. V případě, že se jedná o atribut třídy zaškrtávací pole, při inicializaci 0 je volný, při zadané inicializaci 1 je při aktivaci okna volné karty již zaškrtnutý nebo při překryvném seznamu jsou atributy v překr. seznamu fiktivně očíslovány 1,2,3 atd., tzn. že při zobrazení Ano,Ne a nastavení inicializace na 1 se při aktivaci okna volné karty přednastaví překryvný seznam na hodnotu Ano. Atribut může obsahovat výraz uvedený znakem #např.: #tool.uziv pro inicializaci hodnoty volné karty identifikací aktuálního uživatele systému. Ve vlastnosti inicializace je možné uvádět text uvedený rovnítkem. Hodnota takové atributu není ukládána do dat volné karty a tento atribut není možné editovat. Za rovnítkem se uvádí výraz v jazyce Foxpro, jehož hodnota je zobrazována pro daný atribut ve volné kartě. Hodnota atributu ve volné kartě je přezobrazována při každé změně, kterou proveden uživatel vstupem libovolného atributu. Pro správné vyhodnocení je nutné, aby vstupované atributy uváděné ve výrazu měly pořadí menší než atribut, ve kterém je uvedena vypočtená hodnota. Za rovnítkem vlastnosti inicializace je možné zadat prefix SCRIPT – inicializace je potom provedena pomocí víceřádkového skriptu v jazyce Foxpro. Příklady:

a/ název adresáta zobrazovaného na volné kartě na základě identifikace adresáta (atribut IDADR) vstupované uživatelem:

=tool.sql_dotaz([select ad01adsat from %%%.adadsat where ad01id=?_p1],[idadr])

b/ součet dvou hodnot vstupovaných uživatelem

=[hodnota1]+[hodnota2]

c/ příklad řešení se skriptem

=SCRIPT

IF [hodnota1]>20

RETURN [hodnota2]

ELSE

RETURN [hodnota1]

ENDIF

¨ validace – je zde možno uvádět kód v jazyce Foxpro, který vrací hodnoty TRUE nebo FALSE signalizující validitu atributu. V tomto kódu je možné uvádět text ### (představuje daný atribut) nebo názvy jiných atributů volné karty ohraničené hranatými závorkami. Tyto texty představují hodnotu odpovídajícího atributu. Příklady:

a/ validace na nenulovou hodnotu

IF ###=0

WAIT WIND 'Částka nesmí být nulová' NOWAIT

RETURN .F.

ENDIF

b/ validace existence adresáta zadaného uživatelem na volnou kartu

IF EMPTY([adnazev])

* předpokládá se, že ADNAZEV je atribut volné karty inicializovaný podobně jako v příkladu 1a

* tento atribut bude v průběhu vstupu prázdný, pokud hodnota atributu identifikace adresáta (v příkladu 1x se jedná o atribut IDADR) neodpovídá existujícímu adresátovi

WAIT WIND 'Adresát musí být uveden' NOWAIT

RETURN .F.

ENDIF

¨ podmínka – umožňuje definovat logický výraz v jazyce FoxPro určující podmínku vstupu do daného atributu. Pokud podmínka obsahuje výraz .F. – je atribut zobrazen ve formátu pouze pro čtení

Ve vlastnostech atributů Zobrazení, Inicializace a Validace je možné používat makra. Základní makra jsou k dispozici v Návodech a balíčcích. Vlastní definování maker se provádí činností „definice maker“ z menu Volby formuláře volná karta. Řešení příkladů pomocí těchto maker:

1a/ fky_nazev_adresata([idadr])

2a/ valid_neprazdny('Částka nesmí být nulová')

2b/ valid_fky([adnazev],'Adresát musí být uveden')

V popisech Zobrazení, Inicializace a Validace jednotlivých atributů volné karty je možné uvádět identifikátory atributů primárního klíče tabulky, se kterou je volná karta spojena. Tyto identifikátory se uvádějí v hranatých závorkách. Např.: na volnou kartu adresáta zobrazit název adresáta v atributu inicializace - =tool.sql_dotaz([select ad01adsat from %%%.adadsat where ad01id=?_p1],[ad01id])

¨ p. oknu – přizpůsobení oknu – určuje, zda akceptovat změny velikosti atributu při změnách velikosti celého okna volné karty (Ne, Horizontálně, Vertikálně, Obojí)

¨ F2 - reakce - zda má být při vstupu údaje po stisku F2 aktivována zde uvedená činnost, tj. vstup do zvoleného číselníku.

Na záložce „atributy volné struktury" uživatel tedy definuje atributy, které po vyvolání příslušné volné karty vyplňuje, resp. prohlíží (ty mají údaj "inicializace" uveden názvem volného pohledu). Atributy volné karty jsou pak k dispozici v transformacích druhu procesu. Pokud je chceme použít jako výstupní atributy komponenty, tak v seznamu výstupních atributů komponenty (klávesa F5 v činnosti „Definice výrazu) nejsou zobrazeny. Do výrazů je nutno je zapsat po stisku klávesy F3 a před vlastní název výrazu je nutno připsat znak „~" (např. výraz ~data.divs je definován hodnotou atributu "divs" volné karty). Tento znak zaručí, že systém nebude daný výraz kontrolovat z hlediska syntaxe.

Atributy volné karty typu 'Multimediální' se používají:

1. s nevyplněnou vlastností 'Inicializace' - obrázek nebo videoklip je ukládán v tabulce volné karty

2. s vyplněnou vlastností 'Inicializace' výrazem uvedeným znakem '=' - obrázek není uložen v tabulce volné karty - na volné kartě je zobrazován obrázek ze souboru, jehož název je určen vyhodnocením výrazu této vlastnosti

3. s vyplněnou vlastností 'Inicializace' výrazem uvedeným znakem '=' a uvedeným textem AVI v popisu třídy atributu - videoklip není uložen v tabulce volné karty - na volné kartě je zobrazován videoklip ze souboru, jehož název je určen vyhodnocením výrazu této vlastnosti

Výraz vlastnosti 'Inicializace' je vyhodnocován dynamicky při přezobrazování volné karty, takže se při pohybu v záznamech formuláře, ke kterému je karta připojena, může docházet ke změně zobrazovaného obrázku resp. videoklipu. Multimediální atributy v vyplněnou vlastností 'Inicializace' mohou mít uveden ve vlastnosti 'Validace' kód v jazyce Foxpro, který má být prováděn při pravém kliku myší na obrázku resp. pravém okraji videoklipu.

K dispozici jsou makra, která usnadňují vytváření volných karet pro zobrazování multimédií, které jsou uloženy jako dokumenty BM připojené k objektům BM. Rozhodnutí o tom zda budou obrázky objektů ukládány v tabulce volné karty (ad 1.) nebo jako dokumenty BM (ad 2.) ovlivní implementaci. Obrázky objektů BM implementované způsobem ad 1. je možné prohlížet prostřednictvím volné karty a tisknout klasickou předlohou výstupu, další možnosti nejsou. Obrázky objektů BM implementované způsobem ad 2. (s využitím maker) je možné tisknout v předlohách výstupu typu Excel (tisk v klasické předloze výstupu je obtížný), použít s jinými nástroji Windows (např. publikovat na internetu), zahrnout do řízení procesu (např. při pořizování přijaté faktury přinutit uživatele připojit k procesu oskenovanou kopii přijaté faktury). Pro zobrazování dokumentů BM, které jsou svým charakterem obrázky resp.videoklipy, připojené k objektům BM, jsou připravena makra pro použití ve vlastnostech 'Inicializace' a 'Validace' multimediálních atributů volných karet.

Pro vlastnost 'Inicializace' makro - DOKUMENT_OBRAZEK_OBJEKTU.

Substitucí makra vznikne výraz, který vrací název souboru obsahujícího obrázek, který je uložen v dokumentu připojeného k objektu BM. Protože k objektu BM může být připojeno více dokumentů, z nichž pouze některé jsou obrázky, uvádí se parametrem tohoto makra, jakého druhu dokumentu a jakou předlohu dokumentu může mít připojený obrázek. Jediným parametrem makra je identifikátor obecné předkontace, které by měly mít uvedeny hodnoty:

- VK0001 - seznam druhů dokumentů

- VK0002 - seznam předloh výstupu

Na volné kartě je potom zobrazován obrázek uložený v prvním nalezeném připojeném dokumentu, který je druhu podle hodnoty VK0001 a má předlohu výstupu podle hodnoty VK0002. Dokument s obrázkem nebo videoklipem přitom může být uložen v databázi BM nebo uložený externě.

Pro vlastnost 'Validace' makro - DOKUMENT_OBRAZEK_RIGHTCLICK

Toto makro je možné použít pouze v případě, že je ve vlastnosti 'Inicializace' uvedeno volání makra DOKUMENT_OBRAZEK_OBJEKTU. Substitucí makra vznikne kód v jazyce Foxpro, který po pravém kliku klávesou myši na obrázku resp. pravém okraji videoklipu zobrazí menu:

1. v případě, že dokument není k objektu BM připojen:

1a) Založit dokument - obrázek

- volbou uživatel vybírá soubor obrázku s příponou podle hodnoty obecné předkontace VK0001 (identifikace této překontace je dána voláním makra DOKUMENT_OBRAZEK_OBJEKTU)

- následně vstupuje vlastnosti nově zakládaného dokumentu s předplněným názvem podle prvého parametru makra a s předplněným způsobem uložením dokumentu podle druhého parametru makra (0=předplňovat ukládání do databáze, 1=předplňovat externí uložení na disk), přitom vybírá druh dokumentu podle VK0001 a předlohu dokumentu podle VK0002 a odpovídající přípony

2. v případě, že je dokument k objektu BM připojen:

2a) Vyměnit dokument - obrázek

- volbou uživatel vybírá soubor obrázku s příponou podle předlohy daného dokumentu, kterým bude nahrazen obrázek uložený v dokumentu BM. Tato volba je podmíněna právem zápis pro uživatele k druhu daného dokumentu.

2b) Opravit dokument - obrázek

- volbou je vyvolána oprava dokumentu

2c) Uložit jako ...

- volba pro uložení kopie obrázku na disk

2d) Kopírovat

- provede kopii souboru do schránky Windows (obrázek je potom možné např. vložit do dokumentu Wordu, jako přílohu e-mailu, ...)

2e) Vlastnosti dokumentu

- volba pro prohlížení a opravy vlastností dokumentu BM

Pro vlastnost 'Inicializace' makro - EXTERNI_OBRAZEK

Makro se používá ve vlastnostech 'Inicializace' atributů typu 'Multimediální' volných karet. Substitucí makra vznikne výraz, který vrací název souboru obsahujícího obrázek resp. videoklip podle parametrů makra.

Parametry:

1. adresářová cesta k souboru

2. název souboru bez přípony

3. přípona souboru - může být uvedena souborová maska např. '*'

Makro je třeba uvádět s prefixem SCRIPT.

Příklad:

=script externi_obrazek('mediup\pict\',[sp60id],'*')

Pro vlastnost 'Validace' makro - EXTERNI_OBRAZEK_RIGHTCLICK

Makro se používá ve vlastnostech 'Validace' atributů typu 'Multimediální' volných karet. Toto makro se většinou používá při použití makra EXTERNI_OBRAZEK uvedeného ve vlastnosti 'Inicializace'.

Substitucí makra vznikne kód v jazyce Foxpro, který po pravém kliku klávesou myši na obrázku zobrazí menu:

1. Kopírovat - provede kopii souboru do schránky Windows (obrázek je potom možné např. vložit do dokumentu Wordu, jako přílohu e-mailu, ...)

Příklad:

externi_obrazek_rightclick()

Příklady:

1. Procesy

Karta - FOTO

Název volné karty - Foto dokladu procesu

Velikost - Oběma směry horizontálně i vertikálně

Posuvník - Oba horizontální i vertikální

Autor - Nezobrazovat na volné kartě

Atribut - PICT

Typ - Multimediální

Inicializace - =dokument_obrazek_objektu('VKIM01')

Validace - dokument_obrazek_rightclick([sp33cisdr]+'-'+[sp33cisdpm]+'-'+[sp33cisd] , 0)

Přizpůsobení oknu - Ne

Šířka - 700

Výška - 1000

2. Operace

Karta - FOTO

Název volné karty - Foto dokladu operace

Velikost - Oběma směry horizontálně i vertikálně

Posuvník - Oba horizontální i vertikální

Autor - Nezobrazovat na volné kartě

Atribut - PICT

Typ - Multimediální

Inicializace - =dokument_obrazek_objektu('VKIM02')

validace - dokument_obrazek_rightclick('['+trim(iif(empty([sp06idsubs]),[sp07idtyp],lower([sp06idsubs]+'-'+[sp07idtyp])))+'] '+[sp33cisdr]+'-'+[sp33cisdpm]+'-'+[sp33cisd] , 0)

Přizpůsobení oknu - Ne

Šířka - 700

Výška - 1000

3. Artikl (SP)

Karta - FOTO

Název volné karty - Foto artiklu

Velikost - Oběma směry horizontálně i vertikálně

Posuvník - Žádný

Autor - Nezobrazovat na volné kartě

Atribut - PICT

Typ - Multimediální

Inicializace - =dokument_obrazek_objektu('VKIM03')

Validace - dokument_obrazek_rightclick([sp61id]+'-'+[sp60id] , 0)

Přizpůsobení oknu - Obojí

Šířka - není podstatná

Výška - není podstatná

Na záložce „atributy volné struktury“ uživatel tedy definuje atributy, které po vyvolání příslušné volné karty vyplňuje, resp. prohlíží (ty mají údaj "inicializace" uveden názvem volného pohledu). Atributy volné karty jsou pak k dispozici v transformacích druhu procesu. Pokud je chceme použít jako výstupní atributy komponenty, tak v seznamu výstupních atributů komponenty (klávesa F5 v činnosti „Definice výrazu) nejsou zobrazeny. Do výrazů je nutno je zapsat po stisku klávesy F3 a před vlastní název výrazu je nutno připsat znak „~“ (např. výraz ~data.divs je definován hodnotou atributu "divs" volné karty). Tento znak zaručí, že systém nebude daný výraz kontrolovat z hlediska syntaxe.

Viz.také:

Slovník pojmů

© 1996-2008 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 29.06.2007


Pojem - Záložka - Další u druhu operace

Po stisku klávesy F3 na záložce Další je možno zadat identifikaci a název volné karty (její atributy lze užít jako výstupní atributy komponenty). Uživatel má možnost u druhu operace nastavit tyto příznaky:

¨ po ukončení vstup volné karty procesu - tato volba se uplatní tehdy, pokud je u druhu procesu, jehož je daný druh operace součástí nastavena na záložce „další" volná karta, tak se po ukončení daného druhu operace spustí tato volná karta.

¨ po ukončení vstup volné karty operace - v případě, že je u druhu operace nadefinována volná karta a je uvedena na této záložce „další" v činnosti Druhy operací, tak se po ukončení daného druhu operace uživateli spustí právě tato nastavená volná karta.

¨ ukončení operace bez událostí - volba Ano/Ne, zda povolit ukončit daný druh operace i bez toho, že by obsahoval události

¨ operaci na pozadí vždy ukončovat automaticky - volba Ano/Ne, operace se bude na pozadí vždy ukončovat automaticky bez ohledu na to, co má nastaveno ve vlastnostech operace v diagramu procesu

¨ zrcadlové storno - volba Ano znamená, že při stornu vznikají inverzní (tj. opačné) operace a události, volba Ne znamená, že při stornu jsou operace i události zrušeny i pro ukončené operace

¨ kontrolovat při stornu – volba Ano znamená, že při stornu procesu systém kontroluje, zda otevřené období komponenty tohoto druhu operace má nastaveno kontrolovat při stornu Ano. Pokud je u otevřeného období komponenty nastaveno Ano a u druhu operace rovněž Ano (nebo není vůbec vyplněna záložka Další), storno procesu se neprovede, pokud by stornem vznikla inverzní událost s datem mimo otevřené období komponenty nebo pokud by stornem byla zrušena událost s datem mimo otevřené období komponenty.

¨ kontrolovat při rušení stavu ukon. – volba Ano znamená, že při rušení tohoto druhu operace systém kontroluje, zda otevřené období komponenty má nastaveno kontrolovat při rušení stavu ukončena Ano. Pokud je u otevřeného období komponenty nastaveno Ano a u druhu operace rovněž Ano (nebo není vůbec vyplněna záložka Další), zrušení stavu ukončena se neprovede, pokud by byla zrušena událost operace s datem mimo otevřené období komponenty. Dále platí, že rušení záznamu události komponenty klávesou F8 nebo rušení označených událostí v neukončené operaci nedovolí zrušit událost, která je mimo otevřené období komponenty. Stejně tak není povoleno změnit datum události, která byla uložena s datem, které je v daném okamžiku mimo otevřené období komponenty.

¨ zobrazovat ve stromu procesu – volba Ano/Ne. Možnost nastavení, zda druh operace má být zobrazen ve stromu hlavního procesu. Ve většině případů zřejmě bude nastaveno Ano, možnost Ne se využije především u operací, které se vkládají do diagramu procesu pouze pro umožnění odblokování operace.

© 1996-2008 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 26.03.2008


Pojem - Záložka - Další u druhu procesu

V činnosti Druhy procesů má uživatel k dispozici celou řadu záložek, které obsahují doplňující informace k druhu procesu. Na záložce „Další"se definuje:

¨ karta – možnost nadefinovat si volnou kartu, která se vztahuje k danému procesu, tj. ze které lze transformovat (její atributy lze užít jako výstupní atributy komponenty), případně ji automaticky vyvolat při ukončení určité operace (po ukončení vstup volné karty procesu)

¨ nastavení volby „předplňovat - opakovat vstup", což znamená, že volba „opakovat vstup" před zápisem událostí první operace při spuštění procesu z menu Nový proces bude implicitně zaškrtnuta.

¨ výraz popisu procesu - výraz pro předplnění popisu procesu podle operace zahajující proces

¨ výraz externí identifikace procesu - výraz pro předplnění externí identifikace procesu podle operace zahajující proces

¨ výraz poznámky procesu – výraz nebo skript v jazyce Foxpro, na základě jehož vyhodnocení je předplňován text komentáře nově zakládaného procesu. Skript je možno definovat po stisku pravého tlačítka myši na daném atributu a jeho text musí být uveden slovem SCRIPT (stejné platí pro „výraz popisu procesu“ a „výraz externí identifikace procesu“). V kódu skriptu je možno se odkazovat na tyto proměnné:

- _THIS - řídící objekt operace (např. pro využití jeho atributů _THIS.SP33CISDRO, _THIS.SP33CISDPO, _THIS.SP33CISDO ...)

- _ALIAS - alias kurzoru, ve kterém se nacházejí informace pro vytvoření popisu

Přiklad:

<pre>

SCRIPT

LOCAL _sp33text

_sp33text=tool.sql_dotaz([select sp33text from %%%.spprc where sp33cisdr=?_p1 and sp33cisdpm=?_p2 and sp33cisd=?_p3],;

_this.sp33cisdro, _this.sp33cisdpo, _this.sp33cisdo)

RETURN _sp33text

</pre>

© 1996-2008 BM Servis s.r.o., České Budějovice. Všechna práva vyhrazena.

Postlová Daniela - 26.03.2008